Namespaces

Namespaces
Namespace | Description
Autodesk.Revit.ApplicationServices |
Autodesk.Revit.Attributes |
Autodesk.Revit.Creation |
Autodesk.Revit.DB |
Autodesk.Revit.DB.Analysis |
Autodesk.Revit.DB.Architecture |
Autodesk.Revit.DB.DirectContext3D |
Autodesk.Revit.DB.Electrical |
Autodesk.Revit.DB.Events |
Autodesk.Revit.DB.ExtensibleStorage |
Autodesk.Revit.DB.ExternalService |
Autodesk.Revit.DB.Fabrication |
Autodesk.Revit.DB.IFC |
Autodesk.Revit.DB.Infrastructure |
Autodesk.Revit.DB.Lighting |
Autodesk.Revit.DB.Macros |
Autodesk.Revit.DB.Mechanical |
Autodesk.Revit.DB.Plumbing |
Autodesk.Revit.DB.PointClouds |
Autodesk.Revit.DB.Steel |
Autodesk.Revit.DB.Structure |
Autodesk.Revit.DB.Structure.StructuralSections |
Autodesk.Revit.DB.Visual |
Autodesk.Revit.Exceptions |
Autodesk.Revit.UI |
Autodesk.Revit.UI.Events |
Autodesk.Revit.UI.Macros |
Autodesk.Revit.UI.Mechanical |
Autodesk.Revit.UI.Plumbing |
Autodesk.Revit.UI.Selection |
Send comments on this topic to Autodesk


Autodesk.Revit.ApplicationServices Namespace

Classes
 | Class | Description
 | Application | Represents the Autodesk Revit Application, providing access to documents, options and other application wide data and settings.
Public class | ControlledApplication | Represents the Autodesk Revit Application with no access to documents. It provides options and other application wide data and settings for external applications OnStartup/OnShutdown.
Enumerations
 | Enumeration | Description
Public enumeration | LanguageType | An enumerated type containing the supported Revit product languages.
Public enumeration | ProductType | An enumerated type containing the possible Revit product types.


Application Class

Represents the Autodesk Revit Application, providing access to documents, options and other application wide data and settings.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.ApplicationServicesApplication
Autodesk.Revit.DB.MacrosApplicationEntryPoint

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Application : IDisposable
Public Class Application
    Implements IDisposable
public ref class Application : IDisposable
type Application =
    class
        interface IDisposable
    end

The Application type exposes the following members.

Properties
 | Name | Description
Public property | ActiveAddInId | Retrieves the Id of the currently running external application.
Public property | AllowNavigationDuringRedraw | Checks whether or not the navigation during redraw is enabled, and enable or disable it.
Public property | AllUsersAddinsLocation | The folder location for .addin files for all users.
Public property | AngleTolerance | Angle tolerance.
Public property | BackgroundColor | The background color to use for model views in this session.
 | Cities | Returns a set of all the known city locations within Revit.
Public property | Create | Provides an object that can be used to create new instances of Autodesk Revit API objects.
Public property | CurrentRevitServerAccelerator | Current Revit Server accelerator.
Public property | CurrentUserAddinsLocation | The folder location for .addin files for the current user.
Public property | CurrentUsersAddinsDataFolderPath | Path to AddinsData folder for the current user.
Public property | CurrentUsersDataFolderPath | Path to data folder for the current user.
Public property | DefaultIFCProjectTemplate | Full path to the default template file for new IFC project documents. It may be empty, in which case the DefaultProjectTemplate should be used.
Public property | DefaultProjectTemplate | Full path to the default template file for new project documents.
Public property | DefaultViewDiscipline | The view discipline that will be applied to new views by default.
Public property | Documents | Returns a set of documents within Revit.
Public property | ExportIFCCategoryTable | Full path to the file that defines Revit category to IFC entity mappings for IFC export.
Public property | FamilyTemplatePath | Default path for family template files.
Public property | ImportIFCCategoryTable | Full path to the file that defines IFC entity to Revit category mappings for IFC import.
Public property | IsArchitectureEnabled | Checks whether or not the architecture discipline is enabled, and enable or disable it.
Public property | IsElectricalAnalysisEnabled | Checks whether or not electrical analysis is enabled, and enable or disable it.
Public property | IsElectricalEnabled | Checks whether or not the electrical discipline is enabled, and enable or disable it.
Public property | IsEnergyAnalysisEnabled | Checks whether or not energy analysis is enabled, and enable or disable it.
Public property | IsInfrastructureEnabled | Checks whether or not infrastructure discipline is enabled, and enable or disable it.
 | IsLoggedIn | Checks if the user is logged in from this session to their Autodesk account.
Public property | IsMassingEnabled | Checks whether or not the massing and site tools are enabled, and enable or disable them.
Public property | IsMechanicalAnalysisEnabled | Checks whether or not mechanical analysis is enabled, and enable or disable it.
Public property | IsMechanicalEnabled | Checks whether or not the mechanical discipline is enabled, and enable or disable it.
Public property | IsPipingAnalysisEnabled | Checks whether or not piping analysis is enabled, and enable or disable it.
Public property | IsPipingEnabled | Checks whether or not the piping discipline is enabled, and enable or disable it.
Public property | IsRouteAnalysisEnabled | Checks whether or not route analysis is enabled, and enable or disable it.
Public property | IsStructuralAnalysisEnabled | Checks whether or not the structural analysis is enabled, and enable or disable it.
Public property | IsStructureEnabled | Checks whether or not the structure discipline is enabled, and enable or disable it.
Public property | IsSystemsEnabled | Checks whether or not any systems disciplines (mechanical, electrical, or piping) are enabled.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Language | The language used in the current session of Revit.
Public property | LoginUserId | The user id of the user currently logged in. The user id will be empty if the user is not logged in.
 | MinimumThickness | The minimum thickness allowed in Revit for a variety of geometric constructs. These include blends, extrusions, and wall layers.
Public property | PointCloudsRootPath | Root path for point cloud files.
Public property | Product | The product type for the current session of Revit.
Public property | RecordingJournalFilename | Retrieve the name of the journal file the Revit is currently recording to.
Public property | SharedParametersFilename | Contains the fully qualified path to a shared parameters file.
Public property | ShortCurveTolerance | The enforced minimum length for any curve created by Revit.
Public property | ShowGraphicalOpenEndsAreaBasedLoadBoundaryDisconnects | Whether or not to show the graphical open ends for Area Based Load Boundary disconnects.
Public property | ShowGraphicalWarningCableTrayConduitDisconnects | Whether or not to show the graphical warnings for CTC disconnects.
Public property | ShowGraphicalWarningDuctDisconnects | Whether or not to show the graphical warnings for duct disconnects.
Public property | ShowGraphicalWarningElectricalDisconnects | Whether or not to show the graphical warnings for Electrical disconnects.
Public property | ShowGraphicalWarningHangerDisconnects | Whether or not to show the graphical warnings for Fabrication Hanger disconnects.
Public property | ShowGraphicalWarningPipeDisconnects | Whether or not to show the graphical warnings for Pipe disconnects.
Public property | SubVersionNumber | The minor version number of Revit
Public property | SystemsAnalysisWorkfilesRootPath | Root path for systems analysis workfiles
Public property | Username | Gets the user name for the current Revit session.
Public property | VersionBuild | Returns the internal build number of the Autodesk Revit application.
Public property | VersionName | Returns the name of the Revit application.
Public property | VersionNumber | Return the primary version of the Revit application.
Public property | VertexTolerance | Vertex tolerance.
Top
Methods
 | Name | Description
Public method | CopyModel | Copies an existing model to a new file. Overwriting a file of the same name is allowed.
Public method | Dispose | Releases all resources used by the Application
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ExtractPartAtomFromFamilyFile | Writes a PartAtom XML from the contents of a family file.
Public method | GetAssets | Gets all the Assets of the specified type.
 | GetFailureDefinitionRegistry | Returns the instance of FailureDefinitionRegistry.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
 | GetLibraryPaths | Returns path information identifying where Revit searches for content.
Public method | GetRevitServerNetworkHosts | Gets the list of all Revit Server Network hosts in current session.
Public method | GetSystemsAnalysisWorkflowNames | Returns names for systems analysis workflows.
Public method | GetSystemsAnalysisWorkflows | Returns name and path information identifying systems analysis workflow files.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetWorksharingCentralGUID | Gets the worksharing central GUID of the given server-based model.
Public method | IsJournalPlaying | Determines if the application is currently in journal playback mode.
 | IsValidThickness | Checks if the input value is valid to be supplied as a thickness (for an extrusion, or blend, or wall layer, or similar geometric construct).
 | NewFamilyDocument | New family document, including family, titleblock, and annotation symbol
Public method | NewProjectDocument(String) | New project document
Public method | NewProjectDocument(UnitSystem) | Creates a new project document with no template file specified.
Public method | NewProjectTemplateDocument | New project template document
Public method | OpenDocumentFile(String) | Opens a document from disk.
 | OpenDocumentFile(ModelPath, OpenOptions) | Opens a document from disk or cloud.
Public method | OpenDocumentFile(ModelPath, OpenOptions, IOpenFromCloudCallback) | Opens a document from disk or cloud.
Public method | OpenIFCDocument(String) | Opens an IFC document from disk using default options.
Public method | OpenIFCDocument(String, IFCImportOptions) | Opens an IFC document from disk using custom options.
Public method | OpenSharedParameterFile | Enables access to shared parameter groups and definitions that are maintained on disk.
Public method | PurgeReleasedAPIObjects | Explicitly purges all API objects that have been released but are still awaiting to be finalized
 | RegisterFailuresProcessor | Replaces Revit's default user interface (if present) with alternative handling for all warnings and errors (including those not generated by your application) for the rest of the Revit session; if your application is not prepared to respond to all warnings and errors, consider use of IFailuresPreprocessor (in your opened Transaction) or the FailuresProcessing event instead of this interface.
Public method | SetLibraryPaths | Sets path information identifying where Revit searches for content.
Public method | SetSystemsAnalysisWorkflows | Sets name and path information identifying systems analysis workflow files.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UpdateRenderAppearanceLibrary | Updates the stored render appearance library, giving the Revit session access to any new RPC content.
Public method | WriteJournalComment | Writes a comment to the Revit journal file.
Top
Events
 | Name | Description
Public event | ApplicationInitialized | Subscribe to this event to get notified after the Revit application has been initialized
Public event | DocumentChanged | Subscribe to the DocumentChanged event to be notified when Revit document has changed.
Public event | DocumentClosed | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
Public event | DocumentClosing | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
Public event | DocumentCreated | Subscribe to the DocumentCreated event to be notified immediately after Revit has finished creating a new document.
Public event | DocumentCreating | Subscribe to the DocumentCreating event to be notified when Revit is just about to create a new document.
 | DocumentOpened | Subscribe to the DocumentOpened event to be notified immediately after Revit has finished opening a document.
Public event | DocumentOpening | Subscribe to the DocumentOpening event to be notified when Revit is just about to open a document.
 | DocumentPrinted | Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.
 | DocumentPrinting | Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.
Public event | DocumentReloadedLatest | Subscribe to the DocumentReloadedLatestEventArgs event to be notified immediately after Revit has finished reloading a document with central model.
Public event | DocumentReloadingLatest | Subscribe to the DocumentReloadingLatestEventArgs event to be notified when Revit is just about to reload latest changes from a central model.
Public event | DocumentSaved | Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.
Public event | DocumentSavedAs | Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.
Public event | DocumentSaving | Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document.
 | DocumentSavingAs | Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.
Public event | DocumentSynchronizedWithCentral | Subscribe to the DocumentSynchronizedWithCentral event to be notified immediately after Revit has finished synchronizing a document with central model.
Public event | DocumentSynchronizingWithCentral | Subscribe to the DocumentSynchronizingWithCentral event to be notified when Revit is just about to synchronize a document with central model.
Public event | DocumentWorksharingEnabled | Subscribe to the DocumentWorksharingEnabled event to be notified when a document has become workshared.
Public event | ElementTypeDuplicated | Subscribe to the ElementTypeDuplicated event to be notified immediately after Revit has finished duplicating an element type.
Public event | ElementTypeDuplicating | Subscribe to the ElementTypeDuplicating event to be notified when Revit is just about to duplicate an element type.
 | FailuresProcessing | Subscribe to the FailuresProcessing event to be notified when failures are being processed at the end of transaction.
Public event | FamilyLoadedIntoDocument | Subscribe to the FamilyLoadedInto event to be notified after Revit loaded a family into a document.
Public event | FamilyLoadingIntoDocument | Subscribe to the FamilyLoadingInto event to be notified when Revit is just about to load a family into a document.
Public event | FileExported | Subscribe to the FileExported event to be notified immediately after Revit has finished exporting files of formats supported by the API.
Public event | FileExporting | Subscribe to the FileExporting event to be notified when Revit is just about to export files of formats supported by the API.
Public event | FileImported | Subscribe to the FileImported event to be notified immediately after Revit has finished importing a file of format supported by the API.
Public event | FileImporting | Subscribe to the FileImporting event to be notified when Revit is just about to import a file of format supported by the API.
Public event | LinkedResourceOpened | Subscribe to the LinkedResourceOpened event to be notified immediately after Revit has finished opening a linked resource.
Public event | LinkedResourceOpening | Subscribe to the LinkedResourceOpening event to be notified when Revit is just about to open a linked resource.
Public event | ProgressChanged | Subscribe to the ProgressChanged event to be notified when an operation in Revit has progress bar data available.
Public event | ViewExported | Subscribe to the ViewExported event to be notified immediately after Revit has finished exporting a view of the document.
Public event | ViewExporting | Subscribe to the ViewExporting event to be notified when Revit is just about to export a view of the document.
 | ViewPrinted | Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.
 | ViewPrinting | Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.
Public event | ViewsExportedByContext | Subscribe to the ViewsExportedByContext event to be notified immediately after Revit has finished exporting one or more views of the document via an export context by CustomExporter.
Public event | ViewsExportingByContext | Subscribe to the ViewsExportingByContext event to be notified when Revit is just about to export one or more views of the document via an export context by CustomExporter.
Public event | WorksharedOperationProgressChanged | Subscribe to the WorksharedOperationProgressChanged to be notified when progress has changed during Collaboration for Revit's workshared operations: open model and synchronize with central.
Top
Example
C#
VB
C++
F#
Copy
string versionInfo = application.VersionBuild + "\n"
                    + application.VersionName + "\n"
                    + application.VersionNumber;
Dim versionInfo As String = (application.VersionBuild + vbLf + application.VersionName & vbLf) + application.VersionNumber

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.ApplicationServices Namespace


Application Properties

The Application type exposes the following members.

Properties
 | Name | Description
Public property | ActiveAddInId | Retrieves the Id of the currently running external application.
Public property | AllowNavigationDuringRedraw | Checks whether or not the navigation during redraw is enabled, and enable or disable it.
Public property | AllUsersAddinsLocation | The folder location for .addin files for all users.
Public property | AngleTolerance | Angle tolerance.
Public property | BackgroundColor | The background color to use for model views in this session.
 | Cities | Returns a set of all the known city locations within Revit.
Public property | Create | Provides an object that can be used to create new instances of Autodesk Revit API objects.
Public property | CurrentRevitServerAccelerator | Current Revit Server accelerator.
Public property | CurrentUserAddinsLocation | The folder location for .addin files for the current user.
Public property | CurrentUsersAddinsDataFolderPath | Path to AddinsData folder for the current user.
Public property | CurrentUsersDataFolderPath | Path to data folder for the current user.
Public property | DefaultIFCProjectTemplate | Full path to the default template file for new IFC project documents. It may be empty, in which case the DefaultProjectTemplate should be used.
Public property | DefaultProjectTemplate | Full path to the default template file for new project documents.
Public property | DefaultViewDiscipline | The view discipline that will be applied to new views by default.
Public property | Documents | Returns a set of documents within Revit.
Public property | ExportIFCCategoryTable | Full path to the file that defines Revit category to IFC entity mappings for IFC export.
Public property | FamilyTemplatePath | Default path for family template files.
Public property | ImportIFCCategoryTable | Full path to the file that defines IFC entity to Revit category mappings for IFC import.
Public property | IsArchitectureEnabled | Checks whether or not the architecture discipline is enabled, and enable or disable it.
Public property | IsElectricalAnalysisEnabled | Checks whether or not electrical analysis is enabled, and enable or disable it.
Public property | IsElectricalEnabled | Checks whether or not the electrical discipline is enabled, and enable or disable it.
Public property | IsEnergyAnalysisEnabled | Checks whether or not energy analysis is enabled, and enable or disable it.
Public property | IsInfrastructureEnabled | Checks whether or not infrastructure discipline is enabled, and enable or disable it.
 | IsLoggedIn | Checks if the user is logged in from this session to their Autodesk account.
Public property | IsMassingEnabled | Checks whether or not the massing and site tools are enabled, and enable or disable them.
Public property | IsMechanicalAnalysisEnabled | Checks whether or not mechanical analysis is enabled, and enable or disable it.
Public property | IsMechanicalEnabled | Checks whether or not the mechanical discipline is enabled, and enable or disable it.
Public property | IsPipingAnalysisEnabled | Checks whether or not piping analysis is enabled, and enable or disable it.
Public property | IsPipingEnabled | Checks whether or not the piping discipline is enabled, and enable or disable it.
Public property | IsRouteAnalysisEnabled | Checks whether or not route analysis is enabled, and enable or disable it.
Public property | IsStructuralAnalysisEnabled | Checks whether or not the structural analysis is enabled, and enable or disable it.
Public property | IsStructureEnabled | Checks whether or not the structure discipline is enabled, and enable or disable it.
Public property | IsSystemsEnabled | Checks whether or not any systems disciplines (mechanical, electrical, or piping) are enabled.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Language | The language used in the current session of Revit.
Public property | LoginUserId | The user id of the user currently logged in. The user id will be empty if the user is not logged in.
 | MinimumThickness | The minimum thickness allowed in Revit for a variety of geometric constructs. These include blends, extrusions, and wall layers.
Public property | PointCloudsRootPath | Root path for point cloud files.
Public property | Product | The product type for the current session of Revit.
Public property | RecordingJournalFilename | Retrieve the name of the journal file the Revit is currently recording to.
Public property | SharedParametersFilename | Contains the fully qualified path to a shared parameters file.
Public property | ShortCurveTolerance | The enforced minimum length for any curve created by Revit.
Public property | ShowGraphicalOpenEndsAreaBasedLoadBoundaryDisconnects | Whether or not to show the graphical open ends for Area Based Load Boundary disconnects.
Public property | ShowGraphicalWarningCableTrayConduitDisconnects | Whether or not to show the graphical warnings for CTC disconnects.
Public property | ShowGraphicalWarningDuctDisconnects | Whether or not to show the graphical warnings for duct disconnects.
Public property | ShowGraphicalWarningElectricalDisconnects | Whether or not to show the graphical warnings for Electrical disconnects.
Public property | ShowGraphicalWarningHangerDisconnects | Whether or not to show the graphical warnings for Fabrication Hanger disconnects.
Public property | ShowGraphicalWarningPipeDisconnects | Whether or not to show the graphical warnings for Pipe disconnects.
Public property | SubVersionNumber | The minor version number of Revit
Public property | SystemsAnalysisWorkfilesRootPath | Root path for systems analysis workfiles
Public property | Username | Gets the user name for the current Revit session.
Public property | VersionBuild | Returns the internal build number of the Autodesk Revit application.
Public property | VersionName | Returns the name of the Revit application.
Public property | VersionNumber | Return the primary version of the Revit application.
Public property | VertexTolerance | Vertex tolerance.
Top
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.ActiveAddInId Property

Revit 2025 API

ApplicationActiveAddInId Property

Retrieves the Id of the currently running external application.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AddInId ActiveAddInId { get; }
Public ReadOnly Property ActiveAddInId As AddInId
    Get
public:
property AddInId^ ActiveAddInId {
    AddInId^ get ();
}
member ActiveAddInId : AddInId with get

Property Value

AddInId
Remarks
The application can be either a UI application, DB application, or an external command. If no addin is active, this property will return . If an event handler is currently being executed, the returned value will be the Id of the application or command in which the event handler was registered.
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.AllowNavigationDuringRedraw Property

ApplicationAllowNavigationDuringRedraw Property

Checks whether or not the navigation during redraw is enabled, and enable or disable it.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AllowNavigationDuringRedraw { get; set; }
Public Property AllowNavigationDuringRedraw As Boolean
    Get
    Set
public:
property bool AllowNavigationDuringRedraw {
    bool get ();
    void set (bool value);
}
member AllowNavigationDuringRedraw : bool with get, set

Property Value

Boolean
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.AllUsersAddinsLocation Property

ApplicationAllUsersAddinsLocation Property

The folder location for .addin files for all users.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string AllUsersAddinsLocation { get; }
Public ReadOnly Property AllUsersAddinsLocation As String
    Get
public:
property String^ AllUsersAddinsLocation {
    String^ get ();
}
member AllUsersAddinsLocation : string with get

Property Value

String
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.AngleTolerance Property

ApplicationAngleTolerance Property

Angle tolerance.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double AngleTolerance { get; }
Public ReadOnly Property AngleTolerance As Double
    Get
public:
property double AngleTolerance {
    double get ();
}
member AngleTolerance : float with get

Property Value

Double
Remarks
Value is in radians. Two angle measurements closer than this value are considered identical. Do not use this value for any purpose other than its intended purpose, which is to check if two angles are the same within this tolerance value. Do not use this value to set the value of an angle. Doing so will result in unstable behavior.
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.BackgroundColor Property

ApplicationBackgroundColor Property

The background color to use for model views in this session.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color BackgroundColor { get; set; }
Public Property BackgroundColor As Color
    Get
    Set
public:
property Color^ BackgroundColor {
    Color^ get ();
    void set (Color^ value);
}
member BackgroundColor : Color with get, set

Property Value

Color
Exceptions
Exception | Condition
ArgumentException | When setting this property: The backgroundColor argument does not represent a valid color.
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.Cities Property

ApplicationCities Property

Returns a set of all the known city locations within Revit.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CitySet Cities { get; }
Public ReadOnly Property Cities As CitySet
    Get
public:
property CitySet^ Cities {
    CitySet^ get ();
}
member Cities : CitySet with get

Property Value

CitySet
Remarks
Each city has information about longitude, latitude etc.
Example
C#
VB
C++
F#
Copy
// Get all Revit support cities
Autodesk.Revit.DB.CitySet cities = application.Cities;

// Set all Revit support cities into an ArrayList
System.Collections.ArrayList cityList = new System.Collections.ArrayList();
foreach (Autodesk.Revit.DB.City city in cities)
{
    cityList.Add(city);
}
' Get all Revit support cities
Dim cities As Autodesk.Revit.DB.CitySet = application.Cities

' Set all Revit support cities into an ArrayList
Dim cityList As New System.Collections.ArrayList()
For Each city As Autodesk.Revit.DB.City In cities
    cityList.Add(city)
Next

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.Create Property

ApplicationCreate Property

Provides an object that can be used to create new instances of Autodesk Revit API objects.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Application Create { get; }
Public ReadOnly Property Create As Application
    Get
public:
property Application^ Create {
    Application^ get ();
}
member Create : Application with get

Property Value

Application
Remarks
The Create property returns an object that is used to create application wide utility and geometric objects within the Autodesk Revit API, such as arrays, sets, lines. This object should be used when you wish to create an object within the Autodesk Revit application memory, rather than your own application's memory. If you are performing your own memory management techniques then it is advisable to create any utility objects via the Create object. For example: Instead of Dim set As New Autodesk_Revit_ElementSet do Set set = application.Create.NewElementSet()
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.CurrentRevitServerAccelerator Property

ApplicationCurrentRevitServerAccelerator Property

Current Revit Server accelerator.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string CurrentRevitServerAccelerator { get; set; }
Public Property CurrentRevitServerAccelerator As String
    Get
    Set
public:
property String^ CurrentRevitServerAccelerator {
    String^ get ();
    void set (String^ value);
}
member CurrentRevitServerAccelerator : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentException | When setting this property: The server name can not be used to construct a well formed Uri string.
ArgumentNullException | When setting this property: A non-optional argument was null
InvalidOperationException | When setting this property: When setting the value, Revit failed to write current Revit Server accelerator to the user environment.
Remarks
Revit connects with Revit Server hosts via current Revit Server accelerator. If current Revit Server accelerator is not set, this will be an empty string.
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.CurrentUserAddinsLocation Property

ApplicationCurrentUserAddinsLocation Property

The folder location for .addin files for the current user.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string CurrentUserAddinsLocation { get; }
Public ReadOnly Property CurrentUserAddinsLocation As String
    Get
public:
property String^ CurrentUserAddinsLocation {
    String^ get ();
}
member CurrentUserAddinsLocation : string with get

Property Value

String
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.CurrentUsersAddinsDataFolderPath Property

ApplicationCurrentUsersAddinsDataFolderPath Property

Path to AddinsData folder for the current user.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string CurrentUsersAddinsDataFolderPath { get; }
Public ReadOnly Property CurrentUsersAddinsDataFolderPath As String
    Get
public:
property String^ CurrentUsersAddinsDataFolderPath {
    String^ get ();
}
member CurrentUsersAddinsDataFolderPath : string with get

Property Value

String
Remarks
Similar to C:\Users\[UserName]\AppData\Roaming\Autodesk\[ProductType]\[ReleaseName]\AddinsData
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.CurrentUsersDataFolderPath Property

ApplicationCurrentUsersDataFolderPath Property

Path to data folder for the current user.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string CurrentUsersDataFolderPath { get; }
Public ReadOnly Property CurrentUsersDataFolderPath As String
    Get
public:
property String^ CurrentUsersDataFolderPath {
    String^ get ();
}
member CurrentUsersDataFolderPath : string with get

Property Value

String
Remarks
Similar to C:\Users\[UserName]\AppData\Roaming\Autodesk\[ProductType]\[ReleaseName]
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.DefaultIFCProjectTemplate Property

ApplicationDefaultIFCProjectTemplate Property

Full path to the default template file for new IFC project documents. It may be empty, in which case the DefaultProjectTemplate should be used.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string DefaultIFCProjectTemplate { get; }
Public ReadOnly Property DefaultIFCProjectTemplate As String
    Get
public:
property String^ DefaultIFCProjectTemplate {
    String^ get ();
}
member DefaultIFCProjectTemplate : string with get

Property Value

String
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.DefaultProjectTemplate Property

ApplicationDefaultProjectTemplate Property

Full path to the default template file for new project documents.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string DefaultProjectTemplate { get; }
Public ReadOnly Property DefaultProjectTemplate As String
    Get
public:
property String^ DefaultProjectTemplate {
    String^ get ();
}
member DefaultProjectTemplate : string with get

Property Value

String
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.DefaultViewDiscipline Property

ApplicationDefaultViewDiscipline Property

The view discipline that will be applied to new views by default.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ViewDiscipline DefaultViewDiscipline { get; set; }
Public Property DefaultViewDiscipline As ViewDiscipline
    Get
    Set
public:
property ViewDiscipline DefaultViewDiscipline {
    ViewDiscipline get ();
    void set (ViewDiscipline value);
}
member DefaultViewDiscipline : ViewDiscipline with get, set

Property Value

ViewDiscipline
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | When setting this property: This functionality is not available in Revit LT.
Remarks
This view discipline may be overridden by a view template when a view template is also applied to new views.
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.Documents Property

ApplicationDocuments Property

Returns a set of documents within Revit.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual DocumentSet Documents { get; }
Public Overridable ReadOnly Property Documents As DocumentSet
    Get
public:
virtual property DocumentSet^ Documents {
    DocumentSet^ get ();
}
abstract Documents : DocumentSet with get
override Documents : DocumentSet with get

Property Value

DocumentSet
Remarks
This property can be used for the user to find all the document inside Revit.
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.ExportIFCCategoryTable Property

ApplicationExportIFCCategoryTable Property

Full path to the file that defines Revit category to IFC entity mappings for IFC export.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ExportIFCCategoryTable { get; }
Public ReadOnly Property ExportIFCCategoryTable As String
    Get
public:
property String^ ExportIFCCategoryTable {
    String^ get ();
}
member ExportIFCCategoryTable : string with get

Property Value

String
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.FamilyTemplatePath Property

ApplicationFamilyTemplatePath Property

Default path for family template files.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FamilyTemplatePath { get; }
Public ReadOnly Property FamilyTemplatePath As String
    Get
public:
property String^ FamilyTemplatePath {
    String^ get ();
}
member FamilyTemplatePath : string with get

Property Value

String
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.ImportIFCCategoryTable Property

ApplicationImportIFCCategoryTable Property

Full path to the file that defines IFC entity to Revit category mappings for IFC import.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ImportIFCCategoryTable { get; }
Public ReadOnly Property ImportIFCCategoryTable As String
    Get
public:
property String^ ImportIFCCategoryTable {
    String^ get ();
}
member ImportIFCCategoryTable : string with get

Property Value

String
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.IsArchitectureEnabled Property

ApplicationIsArchitectureEnabled Property

Checks whether or not the architecture discipline is enabled, and enable or disable it.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsArchitectureEnabled { get; set; }
Public Property IsArchitectureEnabled As Boolean
    Get
    Set
public:
property bool IsArchitectureEnabled {
    bool get ();
    void set (bool value);
}
member IsArchitectureEnabled : bool with get, set

Property Value

Boolean
Exceptions
Exception | Condition
InvalidOperationException | When setting this property: The current product type is not ProductType.Revit and discipline controls are not enabled.
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.IsElectricalAnalysisEnabled Property

ApplicationIsElectricalAnalysisEnabled Property

Checks whether or not electrical analysis is enabled, and enable or disable it.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsElectricalAnalysisEnabled { get; set; }
Public Property IsElectricalAnalysisEnabled As Boolean
    Get
    Set
public:
property bool IsElectricalAnalysisEnabled {
    bool get ();
    void set (bool value);
}
member IsElectricalAnalysisEnabled : bool with get, set

Property Value

Boolean
Exceptions
Exception | Condition
InvalidOperationException | When setting this property: The current product type is not ProductType.Revit and discipline controls are not enabled.
Remarks
Enabling electrical analysis will not take effect unless the electrical discipline is also enabled.
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.IsElectricalEnabled Property

ApplicationIsElectricalEnabled Property

Checks whether or not the electrical discipline is enabled, and enable or disable it.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsElectricalEnabled { get; set; }
Public Property IsElectricalEnabled As Boolean
    Get
    Set
public:
property bool IsElectricalEnabled {
    bool get ();
    void set (bool value);
}
member IsElectricalEnabled : bool with get, set

Property Value

Boolean
Exceptions
Exception | Condition
InvalidOperationException | When setting this property: The current product type is not ProductType.Revit and discipline controls are not enabled.
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.IsEnergyAnalysisEnabled Property

ApplicationIsEnergyAnalysisEnabled Property

Checks whether or not energy analysis is enabled, and enable or disable it.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEnergyAnalysisEnabled { get; set; }
Public Property IsEnergyAnalysisEnabled As Boolean
    Get
    Set
public:
property bool IsEnergyAnalysisEnabled {
    bool get ();
    void set (bool value);
}
member IsEnergyAnalysisEnabled : bool with get, set

Property Value

Boolean
Exceptions
Exception | Condition
InvalidOperationException | When setting this property: The current product type is not ProductType.Revit and discipline controls are not enabled.
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.IsInfrastructureEnabled Property

ApplicationIsInfrastructureEnabled Property

Checks whether or not infrastructure discipline is enabled, and enable or disable it.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsInfrastructureEnabled { get; set; }
Public Property IsInfrastructureEnabled As Boolean
    Get
    Set
public:
property bool IsInfrastructureEnabled {
    bool get ();
    void set (bool value);
}
member IsInfrastructureEnabled : bool with get, set

Property Value

Boolean
Exceptions
Exception | Condition
InvalidOperationException | When setting this property: The current product type is not ProductType.Revit and discipline controls are not enabled.
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.IsLoggedIn Property

ApplicationIsLoggedIn Property

Checks if the user is logged in from this session to their Autodesk account.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsLoggedIn { get; }
Public Shared ReadOnly Property IsLoggedIn As Boolean
    Get
public:
static property bool IsLoggedIn {
    bool get ();
}
static member IsLoggedIn : bool with get

Property Value

Boolean
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.IsMassingEnabled Property

ApplicationIsMassingEnabled Property

Checks whether or not the massing and site tools are enabled, and enable or disable them.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsMassingEnabled { get; set; }
Public Property IsMassingEnabled As Boolean
    Get
    Set
public:
property bool IsMassingEnabled {
    bool get ();
    void set (bool value);
}
member IsMassingEnabled : bool with get, set

Property Value

Boolean
Exceptions
Exception | Condition
InvalidOperationException | When setting this property: The current product type is not ProductType.Revit and discipline controls are not enabled.
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.IsMechanicalAnalysisEnabled Property

ApplicationIsMechanicalAnalysisEnabled Property

Checks whether or not mechanical analysis is enabled, and enable or disable it.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsMechanicalAnalysisEnabled { get; set; }
Public Property IsMechanicalAnalysisEnabled As Boolean
    Get
    Set
public:
property bool IsMechanicalAnalysisEnabled {
    bool get ();
    void set (bool value);
}
member IsMechanicalAnalysisEnabled : bool with get, set

Property Value

Boolean
Exceptions
Exception | Condition
InvalidOperationException | When setting this property: The current product type is not ProductType.Revit and discipline controls are not enabled.
Remarks
Enabling mechanical analysis will not take effect unless the mechanical discipline is also enabled.
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.IsMechanicalEnabled Property

ApplicationIsMechanicalEnabled Property

Checks whether or not the mechanical discipline is enabled, and enable or disable it.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsMechanicalEnabled { get; set; }
Public Property IsMechanicalEnabled As Boolean
    Get
    Set
public:
property bool IsMechanicalEnabled {
    bool get ();
    void set (bool value);
}
member IsMechanicalEnabled : bool with get, set

Property Value

Boolean
Exceptions
Exception | Condition
InvalidOperationException | When setting this property: The current product type is not ProductType.Revit and discipline controls are not enabled.
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.IsPipingAnalysisEnabled Property

ApplicationIsPipingAnalysisEnabled Property

Checks whether or not piping analysis is enabled, and enable or disable it.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsPipingAnalysisEnabled { get; set; }
Public Property IsPipingAnalysisEnabled As Boolean
    Get
    Set
public:
property bool IsPipingAnalysisEnabled {
    bool get ();
    void set (bool value);
}
member IsPipingAnalysisEnabled : bool with get, set

Property Value

Boolean
Exceptions
Exception | Condition
InvalidOperationException | When setting this property: The current product type is not ProductType.Revit and discipline controls are not enabled.
Remarks
Enabling piping analysis will not take effect unless the piping discipline is also enabled.
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.IsPipingEnabled Property

ApplicationIsPipingEnabled Property

Checks whether or not the piping discipline is enabled, and enable or disable it.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsPipingEnabled { get; set; }
Public Property IsPipingEnabled As Boolean
    Get
    Set
public:
property bool IsPipingEnabled {
    bool get ();
    void set (bool value);
}
member IsPipingEnabled : bool with get, set

Property Value

Boolean
Exceptions
Exception | Condition
InvalidOperationException | When setting this property: The current product type is not ProductType.Revit and discipline controls are not enabled.
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.IsRouteAnalysisEnabled Property

ApplicationIsRouteAnalysisEnabled Property

Checks whether or not route analysis is enabled, and enable or disable it.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsRouteAnalysisEnabled { get; set; }
Public Property IsRouteAnalysisEnabled As Boolean
    Get
    Set
public:
property bool IsRouteAnalysisEnabled {
    bool get ();
    void set (bool value);
}
member IsRouteAnalysisEnabled : bool with get, set

Property Value

Boolean
Exceptions
Exception | Condition
InvalidOperationException | When setting this property: The current product type is not ProductType.Revit and discipline controls are not enabled.
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.IsStructuralAnalysisEnabled Property

ApplicationIsStructuralAnalysisEnabled Property

Checks whether or not the structural analysis is enabled, and enable or disable it.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsStructuralAnalysisEnabled { get; set; }
Public Property IsStructuralAnalysisEnabled As Boolean
    Get
    Set
public:
property bool IsStructuralAnalysisEnabled {
    bool get ();
    void set (bool value);
}
member IsStructuralAnalysisEnabled : bool with get, set

Property Value

Boolean
Exceptions
Exception | Condition
InvalidOperationException | When setting this property: The current product type is not ProductType.Revit and discipline controls are not enabled.
Remarks
When structural analysis is disabled the structural analytical model will not be updated automatically by Revit. Enabling structural analysis will not take effect unless the structure discipline is also enabled.
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.IsStructureEnabled Property

ApplicationIsStructureEnabled Property

Checks whether or not the structure discipline is enabled, and enable or disable it.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsStructureEnabled { get; set; }
Public Property IsStructureEnabled As Boolean
    Get
    Set
public:
property bool IsStructureEnabled {
    bool get ();
    void set (bool value);
}
member IsStructureEnabled : bool with get, set

Property Value

Boolean
Exceptions
Exception | Condition
InvalidOperationException | When setting this property: The current product type is not ProductType.Revit and discipline controls are not enabled.
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.IsSystemsEnabled Property

ApplicationIsSystemsEnabled Property

Checks whether or not any systems disciplines (mechanical, electrical, or piping) are enabled.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSystemsEnabled { get; }
Public ReadOnly Property IsSystemsEnabled As Boolean
    Get
public:
property bool IsSystemsEnabled {
    bool get ();
}
member IsSystemsEnabled : bool with get

Property Value

Boolean
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.IsValidObject Property

ApplicationIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.Language Property

ApplicationLanguage Property

The language used in the current session of Revit.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LanguageType Language { get; }
Public ReadOnly Property Language As LanguageType
    Get
public:
property LanguageType Language {
    LanguageType get ();
}
member Language : LanguageType with get

Property Value

LanguageType
Remarks
Use this property to determine the language used by Revit; this can allow your application to load the appropriate resources.
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.LoginUserId Property

ApplicationLoginUserId Property

The user id of the user currently logged in. The user id will be empty if the user is not logged in.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string LoginUserId { get; }
Public ReadOnly Property LoginUserId As String
    Get
public:
property String^ LoginUserId {
    String^ get ();
}
member LoginUserId : string with get

Property Value

String
Remarks
The internal id of Autodesk ID that the current user has logged in to A360. This user id is in human unrecognizable form. In conjunction with the Store Entitlement REST API, a publisher of Autodesk Exchange Store app can verify if the current user has purchased their app from the store. For more information about Store Entitlement API, please refer to www.autodesk.com/developapps.
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.MinimumThickness Property

ApplicationMinimumThickness Property

The minimum thickness allowed in Revit for a variety of geometric constructs. These include blends, extrusions, and wall layers.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static double MinimumThickness { get; }
Public Shared ReadOnly Property MinimumThickness As Double
    Get
public:
static property double MinimumThickness {
    double get ();
}
static member MinimumThickness : float with get

Property Value

Double
Remarks
Do not use this value for any purpose other than its intended purpose. If you want to check for valid thickness value, use the function isValidThickness.
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.PointCloudsRootPath Property

ApplicationPointCloudsRootPath Property

Root path for point cloud files.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string PointCloudsRootPath { get; }
Public ReadOnly Property PointCloudsRootPath As String
    Get
public:
property String^ PointCloudsRootPath {
    String^ get ();
}
member PointCloudsRootPath : string with get

Property Value

String
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.Product Property

ApplicationProduct Property

The product type for the current session of Revit.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ProductType Product { get; }
Public ReadOnly Property Product As ProductType
    Get
public:
property ProductType Product {
    ProductType get ();
}
member Product : ProductType with get

Property Value

ProductType
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.RecordingJournalFilename Property

ApplicationRecordingJournalFilename Property

Retrieve the name of the journal file the Revit is currently recording to.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string RecordingJournalFilename { get; }
Public ReadOnly Property RecordingJournalFilename As String
    Get
public:
property String^ RecordingJournalFilename {
    String^ get ();
}
member RecordingJournalFilename : string with get

Property Value

String
Remarks
As Revit operates it keeps a log of operations that the user performs within a file, known as a journal file. These files provide information about the actions performed in a session and the state of Revit when a problem occurs. These files are included during error reporting to Autodesk.
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.SharedParametersFilename Property

ApplicationSharedParametersFilename Property

Contains the fully qualified path to a shared parameters file.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SharedParametersFilename { get; set; }
Public Property SharedParametersFilename As String
    Get
    Set
public:
property String^ SharedParametersFilename {
    String^ get ();
    void set (String^ value);
}
member SharedParametersFilename : string with get, set

Property Value

String
Remarks
This path can be read and set via this property. By default Autodesk Revit does not have a shared parameters file so this property must be set before access is made to the shared parameters file object otherwise an exception will be thrown.
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.ShortCurveTolerance Property

ApplicationShortCurveTolerance Property

The enforced minimum length for any curve created by Revit.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double ShortCurveTolerance { get; }
Public ReadOnly Property ShortCurveTolerance As Double
    Get
public:
property double ShortCurveTolerance {
    double get ();
}
member ShortCurveTolerance : float with get

Property Value

Double
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.ShowGraphicalOpenEndsAreaBasedLoadBoundaryDisconnects Property

ApplicationShowGraphicalOpenEndsAreaBasedLoadBoundaryDisconnects Property

Whether or not to show the graphical open ends for Area Based Load Boundary disconnects.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShowGraphicalOpenEndsAreaBasedLoadBoundaryDisconnects { get; set; }
Public Property ShowGraphicalOpenEndsAreaBasedLoadBoundaryDisconnects As Boolean
    Get
    Set
public:
property bool ShowGraphicalOpenEndsAreaBasedLoadBoundaryDisconnects {
    bool get ();
    void set (bool value);
}
member ShowGraphicalOpenEndsAreaBasedLoadBoundaryDisconnects : bool with get, set

Property Value

Boolean
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.ShowGraphicalWarningCableTrayConduitDisconnects Property

ApplicationShowGraphicalWarningCableTrayConduitDisconnects Property

Whether or not to show the graphical warnings for CTC disconnects.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShowGraphicalWarningCableTrayConduitDisconnects { get; set; }
Public Property ShowGraphicalWarningCableTrayConduitDisconnects As Boolean
    Get
    Set
public:
property bool ShowGraphicalWarningCableTrayConduitDisconnects {
    bool get ();
    void set (bool value);
}
member ShowGraphicalWarningCableTrayConduitDisconnects : bool with get, set

Property Value

Boolean
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.ShowGraphicalWarningDuctDisconnects Property

ApplicationShowGraphicalWarningDuctDisconnects Property

Whether or not to show the graphical warnings for duct disconnects.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShowGraphicalWarningDuctDisconnects { get; set; }
Public Property ShowGraphicalWarningDuctDisconnects As Boolean
    Get
    Set
public:
property bool ShowGraphicalWarningDuctDisconnects {
    bool get ();
    void set (bool value);
}
member ShowGraphicalWarningDuctDisconnects : bool with get, set

Property Value

Boolean
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.ShowGraphicalWarningElectricalDisconnects Property

ApplicationShowGraphicalWarningElectricalDisconnects Property

Whether or not to show the graphical warnings for Electrical disconnects.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShowGraphicalWarningElectricalDisconnects { get; set; }
Public Property ShowGraphicalWarningElectricalDisconnects As Boolean
    Get
    Set
public:
property bool ShowGraphicalWarningElectricalDisconnects {
    bool get ();
    void set (bool value);
}
member ShowGraphicalWarningElectricalDisconnects : bool with get, set

Property Value

Boolean
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.ShowGraphicalWarningHangerDisconnects Property

ApplicationShowGraphicalWarningHangerDisconnects Property

Whether or not to show the graphical warnings for Fabrication Hanger disconnects.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShowGraphicalWarningHangerDisconnects { get; set; }
Public Property ShowGraphicalWarningHangerDisconnects As Boolean
    Get
    Set
public:
property bool ShowGraphicalWarningHangerDisconnects {
    bool get ();
    void set (bool value);
}
member ShowGraphicalWarningHangerDisconnects : bool with get, set

Property Value

Boolean
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.ShowGraphicalWarningPipeDisconnects Property

ApplicationShowGraphicalWarningPipeDisconnects Property

Whether or not to show the graphical warnings for Pipe disconnects.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShowGraphicalWarningPipeDisconnects { get; set; }
Public Property ShowGraphicalWarningPipeDisconnects As Boolean
    Get
    Set
public:
property bool ShowGraphicalWarningPipeDisconnects {
    bool get ();
    void set (bool value);
}
member ShowGraphicalWarningPipeDisconnects : bool with get, set

Property Value

Boolean
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.SubVersionNumber Property

ApplicationSubVersionNumber Property

The minor version number of Revit

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SubVersionNumber { get; }
Public ReadOnly Property SubVersionNumber As String
    Get
public:
property String^ SubVersionNumber {
    String^ get ();
}
member SubVersionNumber : string with get

Property Value

String
Remarks
SubVersionNumber of Revit may have additional APIs and functionality not available in the standard customer releases. Add-ins written to support standard Revit releases should be compatible with SubVersionNumber releases, but add-ins written specifically targeting new features in SubVersionNumber releases would not be compatible with the standard releases.
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.SystemsAnalysisWorkfilesRootPath Property

ApplicationSystemsAnalysisWorkfilesRootPath Property

Root path for systems analysis workfiles

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SystemsAnalysisWorkfilesRootPath { get; }
Public ReadOnly Property SystemsAnalysisWorkfilesRootPath As String
    Get
public:
property String^ SystemsAnalysisWorkfilesRootPath {
    String^ get ();
}
member SystemsAnalysisWorkfilesRootPath : string with get

Property Value

String
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.Username Property

ApplicationUsername Property

Gets the user name for the current Revit session.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Username { get; }
Public ReadOnly Property Username As String
    Get
public:
property String^ Username {
    String^ get ();
}
member Username : string with get

Property Value

String
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.VersionBuild Property

ApplicationVersionBuild Property

Returns the internal build number of the Autodesk Revit application.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string VersionBuild { get; }
Public ReadOnly Property VersionBuild As String
    Get
public:
property String^ VersionBuild {
    String^ get ();
}
member VersionBuild : string with get

Property Value

String
Remarks
This property can be used by your application to find the version of Autodesk Revit against which your application is running. Based on this information your application can report if it is able to work correctly with that version of Autodesk Revit.
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.VersionName Property

ApplicationVersionName Property

Returns the name of the Revit application.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string VersionName { get; }
Public ReadOnly Property VersionName As String
    Get
public:
property String^ VersionName {
    String^ get ();
}
member VersionName : string with get

Property Value

String
Remarks
This property can be used by your application to find the version of Revit against which your application is running. Based on this information your application can report if it is able to work correctly with that version of Revit.
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.VersionNumber Property

ApplicationVersionNumber Property

Return the primary version of the Revit application.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string VersionNumber { get; }
Public ReadOnly Property VersionNumber As String
    Get
public:
property String^ VersionNumber {
    String^ get ();
}
member VersionNumber : string with get

Property Value

String
Remarks
This property can be used by your application to find the version of Revit against which your application is running. Based on this information your application can report if it is able to work correctly with that version of Revit.
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.VertexTolerance Property

ApplicationVertexTolerance Property

Vertex tolerance.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double VertexTolerance { get; }
Public ReadOnly Property VertexTolerance As Double
    Get
public:
property double VertexTolerance {
    double get ();
}
member VertexTolerance : float with get

Property Value

Double
Remarks
Two points within this distance are considered coincident. Do not use this value for any purpose other than its intended purpose, which is to check if two points are the same within this tolerance value. Do not use this value to set the distance between two points. Doing so will result in unstable behavior.
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application Methods

The Application type exposes the following members.

Methods
 | Name | Description
Public method | CopyModel | Copies an existing model to a new file. Overwriting a file of the same name is allowed.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ExtractPartAtomFromFamilyFile | Writes a PartAtom XML from the contents of a family file.
Public method | GetAssets | Gets all the Assets of the specified type.
 | GetFailureDefinitionRegistry | Returns the instance of FailureDefinitionRegistry.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
 | GetLibraryPaths | Returns path information identifying where Revit searches for content.
Public method | GetRevitServerNetworkHosts | Gets the list of all Revit Server Network hosts in current session.
Public method | GetSystemsAnalysisWorkflowNames | Returns names for systems analysis workflows.
Public method | GetSystemsAnalysisWorkflows | Returns name and path information identifying systems analysis workflow files.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetWorksharingCentralGUID | Gets the worksharing central GUID of the given server-based model.
Public method | IsJournalPlaying | Determines if the application is currently in journal playback mode.
 | IsValidThickness | Checks if the input value is valid to be supplied as a thickness (for an extrusion, or blend, or wall layer, or similar geometric construct).
 | NewFamilyDocument | New family document, including family, titleblock, and annotation symbol
Public method | NewProjectDocument(String) | New project document
Public method | NewProjectDocument(UnitSystem) | Creates a new project document with no template file specified.
Public method | NewProjectTemplateDocument | New project template document
Public method | OpenDocumentFile(String) | Opens a document from disk.
 | OpenDocumentFile(ModelPath, OpenOptions) | Opens a document from disk or cloud.
Public method | OpenDocumentFile(ModelPath, OpenOptions, IOpenFromCloudCallback) | Opens a document from disk or cloud.
Public method | OpenIFCDocument(String) | Opens an IFC document from disk using default options.
Public method | OpenIFCDocument(String, IFCImportOptions) | Opens an IFC document from disk using custom options.
Public method | OpenSharedParameterFile | Enables access to shared parameter groups and definitions that are maintained on disk.
Public method | PurgeReleasedAPIObjects | Explicitly purges all API objects that have been released but are still awaiting to be finalized
 | RegisterFailuresProcessor | Replaces Revit's default user interface (if present) with alternative handling for all warnings and errors (including those not generated by your application) for the rest of the Revit session; if your application is not prepared to respond to all warnings and errors, consider use of IFailuresPreprocessor (in your opened Transaction) or the FailuresProcessing event instead of this interface.
Public method | SetLibraryPaths | Sets path information identifying where Revit searches for content.
Public method | SetSystemsAnalysisWorkflows | Sets name and path information identifying systems analysis workflow files.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UpdateRenderAppearanceLibrary | Updates the stored render appearance library, giving the Revit session access to any new RPC content.
Public method | WriteJournalComment | Writes a comment to the Revit journal file.
Top
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.CopyModel Method

ApplicationCopyModel Method

Copies an existing model to a new file. Overwriting a file of the same name is allowed.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void CopyModel(
    ModelPath sourceModelPath,
    string destFilePath,
    bool overwrite
)
Public Sub CopyModel (
    sourceModelPath As ModelPath,
    destFilePath As String,
    overwrite As Boolean
)
public:
void CopyModel(
    ModelPath^ sourceModelPath,
    String^ destFilePath,
    bool overwrite
)
member CopyModel :
        sourceModelPath : ModelPath *
        destFilePath : string *
        overwrite : bool -> unit

Parameters

sourceModelPath ModelPath
The path of the file-based or server-based source model.
destFilePath String
The path of the destination file.
overwrite Boolean
True if the destination file can be overwritten; otherwise, false.
Exceptions
Exception | Condition
ArgumentException | The given path sourceModelPath is a cloud path which is not supported in this method.
ArgumentNullException | A non-optional argument was null
CentralModelAccessDeniedException | Access to the central model was denied. A possible reason is because the model was under maintenance.
CentralModelException | The central model is missing. -or- An internal error happened on the central model, please contact the server administrator.
DirectoryNotFoundException | Thrown when the directory of destination file doesn't exist.
FileArgumentAlreadyExistsException | The destination file exists and can't be overwritten. -or- destFilePath is pointing to a folder that already exists and cannot be deleted.
FileArgumentNotFoundException | The Revit model specified by sourceModelPath doesn't exist.
InvalidPathArgumentException | The destination file name includes one or more invalid characters.
RevitServerCommunicationException | The server-based central model could not be accessed because of a network communication error.
RevitServerInternalException | An internal error happened on the server, please contact the server administrator.
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.Dispose Method

ApplicationDispose Method

Releases all resources used by the Application

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.ExtractPartAtomFromFamilyFile Method

ApplicationExtractPartAtomFromFamilyFile Method

Writes a PartAtom XML from the contents of a family file.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ExtractPartAtomFromFamilyFile(
    string familyFilePath,
    string xmlFilePath
)
Public Sub ExtractPartAtomFromFamilyFile (
    familyFilePath As String,
    xmlFilePath As String
)
public:
void ExtractPartAtomFromFamilyFile(
    String^ familyFilePath,
    String^ xmlFilePath
)
member ExtractPartAtomFromFamilyFile :
        familyFilePath : string *
        xmlFilePath : string -> unit

Parameters

familyFilePath String
The family file to be processed.
xmlFilePath String
The xml file to be saved.
Exceptions
Exception | Condition
ArgumentException | If 'familyFilePath' or 'xmlFilePath' is or an empty string or if the family file doesn't exist on disk.
Remarks
If there is a TXT type catalog next to the family file (a TXT file with the same name as the RFA file), the function will read it as well and process its contents into PartAtom. To extract a PartAtom XML from a family loaded into a document in session, use Family.ExtractPartAtom().
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.GetAssets Method

ApplicationGetAssets Method

Gets all the Assets of the specified type.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<Asset> GetAssets(
    AssetType assetType
)
Public Function GetAssets (
    assetType As AssetType
) As IList(Of Asset)
public:
IList<Asset^>^ GetAssets(
    AssetType assetType
)
member GetAssets :
        assetType : AssetType -> IList<Asset>

Parameters

assetType AssetType
The asset type.

Return Value

IList Asset
Returns an array of all the Assets within Revit of the specified type.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.GetFailureDefinitionRegistry Method

ApplicationGetFailureDefinitionRegistry Method

Returns the instance of FailureDefinitionRegistry.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionRegistry GetFailureDefinitionRegistry()
Public Shared Function GetFailureDefinitionRegistry As FailureDefinitionRegistry
public:
static FailureDefinitionRegistry^ GetFailureDefinitionRegistry()
static member GetFailureDefinitionRegistry : unit -> FailureDefinitionRegistry

Return Value

FailureDefinitionRegistry
The instance of FailureDefinitionRegistry.
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.GetLibraryPaths Method

ApplicationGetLibraryPaths Method

Returns path information identifying where Revit searches for content.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IDictionary<string, string> GetLibraryPaths()
Public Function GetLibraryPaths As IDictionary(Of String, String)
public:
IDictionary<String^, String^>^ GetLibraryPaths()
member GetLibraryPaths : unit -> IDictionary<string, string>

Return Value

IDictionary String, String
The map of library paths.
Remarks
The map that is returned contains a key that is purpose of the path, such as Material Libraries and the value in the map is the fully qualified path that is used for that search path.
Example
C#
VB
C++
F#
Copy
string strLibPaths = "";
foreach (String path in application.GetLibraryPaths().Values)
{
    strLibPaths += path + "\n";
}
Dim strLibPaths As String = ""
For Each path As [String] In application.GetLibraryPaths().Values
    strLibPaths += path & vbLf
Next

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.GetRevitServerNetworkHosts Method

ApplicationGetRevitServerNetworkHosts Method

Gets the list of all Revit Server Network hosts in current session.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<string> GetRevitServerNetworkHosts()
Public Function GetRevitServerNetworkHosts As IList(Of String)
public:
IList<String^>^ GetRevitServerNetworkHosts()
member GetRevitServerNetworkHosts : unit -> IList<string>

Return Value

IList String
An array of names of all Revit Server Network hosts in current session.
Remarks
The list of Revit Server Network hosts is stored externally in the RSN[version].ini file.
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.GetSystemsAnalysisWorkflowNames Method

ApplicationGetSystemsAnalysisWorkflowNames Method

Returns names for systems analysis workflows.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<string> GetSystemsAnalysisWorkflowNames()
Public Function GetSystemsAnalysisWorkflowNames As IList(Of String)
public:
IList<String^>^ GetSystemsAnalysisWorkflowNames()
member GetSystemsAnalysisWorkflowNames : unit -> IList<string>

Return Value

IList String
An array of names of systems analysis workflows.
Remarks
The array that is returned contains the name of the systems analysis workflow, in the order they are specified in Options.
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.GetSystemsAnalysisWorkflows Method

ApplicationGetSystemsAnalysisWorkflows Method

Returns name and path information identifying systems analysis workflow files.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IDictionary<string, string> GetSystemsAnalysisWorkflows()
Public Function GetSystemsAnalysisWorkflows As IDictionary(Of String, String)
public:
IDictionary<String^, String^>^ GetSystemsAnalysisWorkflows()
member GetSystemsAnalysisWorkflows : unit -> IDictionary<string, string>

Return Value

IDictionary String, String
The map of systems analysis workflows.
Remarks
The map that is returned contains a key that is the name of the systems analysis workflow, and the value is the path to the workflow file.
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.GetWorksharingCentralGUID Method

ApplicationGetWorksharingCentralGUID Method

Gets the worksharing central GUID of the given server-based model.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid GetWorksharingCentralGUID(
    ServerPath serverModelPath
)
Public Function GetWorksharingCentralGUID (
    serverModelPath As ServerPath
) As Guid
public:
Guid GetWorksharingCentralGUID(
    ServerPath^ serverModelPath
)
member GetWorksharingCentralGUID :
        serverModelPath : ServerPath -> Guid

Parameters

serverModelPath ServerPath
The server-based model path.

Return Value

Guid
The worksharing central GUID.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
CentralModelException | The central model is missing. -or- An internal error happened on the central model, please contact the server administrator.
InapplicableDataException | Thrown when the given model is not created in Revit 2013 or later release.
RevitServerCommunicationException | The server-based central model could not be accessed because of a network communication error.
RevitServerInternalException | An internal error happened on the server, please contact the server administrator.
Remarks
The given server-based model saved in a release prior to Revit 2013 did not have this GUID. Only the given server-based model saved in Revit 2013 or later will be able to provide this value.
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.IsJournalPlaying Method

ApplicationIsJournalPlaying Method

Determines if the application is currently in journal playback mode.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsJournalPlaying()
Public Function IsJournalPlaying As Boolean
public:
bool IsJournalPlaying()
member IsJournalPlaying : unit -> bool

Return Value

Boolean
true if a journal is currently playing back, false otherwise.
Remarks
Determines if Revit is in the process of playing back a journal. It can be used to help prevent any user interaction that may cause issues during playback. For more information on Revit's journaling features contact the Autodesk Developer Network.
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.IsValidThickness Method

ApplicationIsValidThickness Method

Checks if the input value is valid to be supplied as a thickness (for an extrusion, or blend, or wall layer, or similar geometric construct).

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidThickness(
    double thickness
)
Public Shared Function IsValidThickness (
    thickness As Double
) As Boolean
public:
static bool IsValidThickness(
    double thickness
)
static member IsValidThickness :
        thickness : float -> bool

Parameters

thickness Double
The input value.

Return Value

Boolean
True if the input value is valid for thickness; false otherwise.
Remarks
This checks two conditions:
  • The value is greater than or equal to the minimum thickness allowed in Revit for these types of geometric constructs.
  • The value is less than or equal to the maximum length/distance allowed by Revit for elements.
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.NewFamilyDocument Method

ApplicationNewFamilyDocument Method

New family document, including family, titleblock, and annotation symbol

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Document NewFamilyDocument(
    string templateFileName
)
Public Overridable Function NewFamilyDocument (
    templateFileName As String
) As Document
public:
virtual Document^ NewFamilyDocument(
    String^ templateFileName
)
abstract NewFamilyDocument :
        templateFileName : string -> Document
override NewFamilyDocument :
        templateFileName : string -> Document

Parameters

templateFileName String
The template file name.

Return Value

Document
Exceptions
Exception | Condition
ArgumentException | If 'templateFileName' is or an empty string.
InvalidOperationException | If the new family document cannot be created.
Remarks
This command corresponds to File->New->Family.../TitleBlock.../Annotation Symbol....
Example
C#
VB
C++
F#
Copy
// create a new family document using Generic Model.rft template
string templateFileName = @"C:\Documents and Settings\All Users\Application Data\Autodesk\RST 2010\Imperial Templates\Generic Model.rft";
Document familyDocument = application.NewFamilyDocument(templateFileName);
if (null == familyDocument)
{
    throw new Exception("Cannot open family document");
}
' create a new family document using Generic Model.rft template
Dim templateFileName As String = "C:\Documents and Settings\All Users\Application Data\Autodesk\RST 2010\Imperial Templates\Generic Model.rft"
Dim familyDocument As Document = application.NewFamilyDocument(templateFileName)
If familyDocument Is Nothing Then
    Throw New Exception("Cannot open family document")
End If

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.NewProjectDocument Method

ApplicationNewProjectDocument Method

Overload List
 | Name | Description
Public method | NewProjectDocument(String) | New project document
Public method | NewProjectDocument(UnitSystem) | Creates a new project document with no template file specified.
Top
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.NewProjectDocument(String) Method

ApplicationNewProjectDocument(String) Method

New project document

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Document NewProjectDocument(
    string templateFileName
)
Public Overridable Function NewProjectDocument (
    templateFileName As String
) As Document
public:
virtual Document^ NewProjectDocument(
    String^ templateFileName
)
abstract NewProjectDocument :
        templateFileName : string -> Document
override NewProjectDocument :
        templateFileName : string -> Document

Parameters

templateFileName String
The template file name.

Return Value

Document
Exceptions
Exception | Condition
ArgumentException | If 'templateFileName' is or an empty string.
InvalidOperationException | If the new project document cannot be created.
Remarks
This command corresponds to New->Project command in the user-interface.
See Also

Reference

Application Class
NewProjectDocument Overload
Autodesk.Revit.ApplicationServices Namespace


Application.NewProjectDocument(UnitSystem) Method

ApplicationNewProjectDocument(UnitSystem) Method

Creates a new project document with no template file specified.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Document NewProjectDocument(
    UnitSystem unitSystem
)
Public Function NewProjectDocument (
    unitSystem As UnitSystem
) As Document
public:
Document^ NewProjectDocument(
    UnitSystem unitSystem
)
member NewProjectDocument :
        unitSystem : UnitSystem -> Document

Parameters

unitSystem UnitSystem
The unit system used for the new document.

Return Value

Document
The newly created document.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

Application Class
NewProjectDocument Overload
Autodesk.Revit.ApplicationServices Namespace


Application.NewProjectTemplateDocument Method

ApplicationNewProjectTemplateDocument Method

New project template document

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Document NewProjectTemplateDocument(
    string templateFilename
)
Public Overridable Function NewProjectTemplateDocument (
    templateFilename As String
) As Document
public:
virtual Document^ NewProjectTemplateDocument(
    String^ templateFilename
)
abstract NewProjectTemplateDocument :
        templateFilename : string -> Document
override NewProjectTemplateDocument :
        templateFilename : string -> Document

Parameters

templateFilename String
The template file name.

Return Value

Document
Exceptions
Exception | Condition
ArgumentException | If 'templateFileName' is or an empty string.
InvalidOperationException | If the project template document cannot be created.
Remarks
This command corresponds to New->Project->Project Template command in the user-interface.
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.OpenDocumentFile Method

ApplicationOpenDocumentFile Method

Overload List
 | Name | Description
Public method | OpenDocumentFile(String) | Opens a document from disk.
 | OpenDocumentFile(ModelPath, OpenOptions) | Opens a document from disk or cloud.
Public method | OpenDocumentFile(ModelPath, OpenOptions, IOpenFromCloudCallback) | Opens a document from disk or cloud.
Top
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.OpenDocumentFile(String) Method

ApplicationOpenDocumentFile(String) Method

Opens a document from disk.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Document OpenDocumentFile(
    string fileName
)
Public Function OpenDocumentFile (
    fileName As String
) As Document
public:
Document^ OpenDocumentFile(
    String^ fileName
)
member OpenDocumentFile :
        fileName : string -> Document

Parameters

fileName String
The file to be opened.

Return Value

Document
The opened document.
Exceptions
Exception | Condition
ArgumentException | The fileName to be opened is empty.
ArgumentNullException | A non-optional argument was null
CannotOpenBothCentralAndLocalException | Cannot open the local model and the central model in the same Revit session. You can close one to open the other in the same Revit session.
CentralModelException | Revit encountered serious errors while trying to open the central model.
CorruptModelException | There are too many corrupt elements to open this model.
FileAccessException | File cannot be opened in Revit LT because it was last saved in a version of Revit prior to 8.1. -or- File has an invalid extension. Try changing the file's extension and opening it again.
FileNotFoundException | The fileName to be opened doesn't exist. -or- File Not Found
InsufficientResourcesException | This computer does not have enough memory, disk space, or other necessary resource to open the model.
InvalidOperationException | Open is temporarily disabled. -or- The document can not be opened.
OperationCanceledException | Opening was canceled by the user or by an API event callback.
Remarks
This method opens the document into memory but does not make it visible to the user in any way.
See Also

Reference

Application Class
OpenDocumentFile Overload
Autodesk.Revit.ApplicationServices Namespace


Application.OpenDocumentFile(ModelPath, OpenOptions) Method

ApplicationOpenDocumentFile(ModelPath, OpenOptions) Method

Opens a document from disk or cloud.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Document OpenDocumentFile(
    ModelPath modelPath,
    OpenOptions openOptions
)
Public Function OpenDocumentFile (
    modelPath As ModelPath,
    openOptions As OpenOptions
) As Document
public:
Document^ OpenDocumentFile(
    ModelPath^ modelPath,
    OpenOptions^ openOptions
)
member OpenDocumentFile :
        modelPath : ModelPath *
        openOptions : OpenOptions -> Document

Parameters

modelPath ModelPath
The file to be opened.
openOptions OpenOptions
Options for opening the file.

Return Value

Document
The opened document.
Exceptions
Exception | Condition
ArgumentException | The modelPath to be opened is empty.
ArgumentNullException | A non-optional argument was null
CannotOpenBothCentralAndLocalException | Cannot open the local model and the central model in the same Revit session. You can close one to open the other in the same Revit session.
CentralModelAccessDeniedException | Access to the central model was denied. A possible reason is because the model was under maintenance.
CentralModelContentionException | The model on the RevitServer is being accessed by other users. -or- The central model is locked by another client.
CentralModelException | Revit encountered serious errors while trying to open the central model. -or- An internal error happened on the central model, please contact the server administrator.
CorruptModelException | There are too many corrupt elements to open this model.
FileAccessException | File cannot be opened in Revit LT because it was last saved in a version of Revit prior to 8.1. -or- File has an invalid extension. Try changing the file's extension and opening it again. -or- File was saved by an application that was not developed or licensed by Autodesk.
FileNotFoundException | The modelPath to be opened doesn't exist. -or- File Not Found
InsufficientResourcesException | This computer does not have enough memory, disk space, or other necessary resource to open the model.
InvalidOperationException | Open is temporarily disabled. -or- The cloud model is not saved in current release of Revit. -or- The model is not allowed to access. -or- The document can not be opened. -or- Revit cannot save the transmitted model as a new central because it is already opened.
OperationCanceledException | Opening was canceled by the user or by an API event callback.
RevitServerCommunicationException | The server-based central model could not be accessed because of a network communication error.
RevitServerInternalException | An internal error happened on the server, please contact the server administrator.
RevitServerUnauthorizedException | User is not authorized to access the cloud model.
WrongUserException | The local file is not owned by the current user, who therefore is not allowed to modify it.
Remarks
This method opens the document into memory but does not make it visible to the user in any way. If the user currently has ownership of elements in this model and there is no local model on this machine, Revit will post a warning.
Example
C#
VB
C++
F#
Copy
private static Document OpenDetached(Application application, ModelPath modelPath)
{
    OpenOptions options1 = new OpenOptions();

    options1.DetachFromCentralOption = DetachFromCentralOption.DetachAndDiscardWorksets;
    Document openedDoc = application.OpenDocumentFile(modelPath, options1);

    return openedDoc;
}
Private Shared Function OpenDetached(application As Application, modelPath As ModelPath) As Document
    Dim options1 As New OpenOptions()

    options1.DetachFromCentralOption = DetachFromCentralOption.DetachAndDiscardWorksets
    Dim openedDoc As Document = application.OpenDocumentFile(modelPath, options1)

    Return openedDoc
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Application Class
OpenDocumentFile Overload
Autodesk.Revit.ApplicationServices Namespace


Application.OpenDocumentFile(ModelPath, OpenOptions, IOpenFromCloudCallback) Method

ApplicationOpenDocumentFile(ModelPath, OpenOptions, IOpenFromCloudCallback) Method

Opens a document from disk or cloud.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Document OpenDocumentFile(
    ModelPath modelPath,
    OpenOptions openOptions,
    IOpenFromCloudCallback openFromCloudCallback
)
Public Function OpenDocumentFile (
    modelPath As ModelPath,
    openOptions As OpenOptions,
    openFromCloudCallback As IOpenFromCloudCallback
) As Document
public:
Document^ OpenDocumentFile(
    ModelPath^ modelPath,
    OpenOptions^ openOptions,
    IOpenFromCloudCallback^ openFromCloudCallback
)
member OpenDocumentFile :
        modelPath : ModelPath *
        openOptions : OpenOptions *
        openFromCloudCallback : IOpenFromCloudCallback -> Document

Parameters

modelPath ModelPath
The file to be opened.
openOptions OpenOptions
Options for opening the file.
openFromCloudCallback IOpenFromCloudCallback
The interface implementation to use when opening a cloud document. Only used for opening cloud model.

Return Value

Document
The opened document.
Exceptions
Exception | Condition
ArgumentException | The modelPath to be opened is empty.
ArgumentNullException | A non-optional argument was null
CannotOpenBothCentralAndLocalException | Cannot open the local model and the central model in the same Revit session. You can close one to open the other in the same Revit session.
CentralModelAccessDeniedException | Access to the central model was denied. A possible reason is because the model was under maintenance.
CentralModelContentionException | The model on the RevitServer is being accessed by other users. -or- The central model is locked by another client.
CentralModelException | Revit encountered serious errors while trying to open the central model. -or- An internal error happened on the central model, please contact the server administrator.
CorruptModelException | There are too many corrupt elements to open this model.
FileAccessException | File cannot be opened in Revit LT because it was last saved in a version of Revit prior to 8.1. -or- File has an invalid extension. Try changing the file's extension and opening it again.
FileNotFoundException | The modelPath to be opened doesn't exist. -or- File Not Found
InsufficientResourcesException | This computer does not have enough memory, disk space, or other necessary resource to open the model.
InvalidOperationException | Open is temporarily disabled. -or- The cloud model is not saved in current release of Revit. -or- The model is not allowed to access. -or- The document can not be opened. -or- Revit cannot save the transmitted model as a new central because it is already opened.
OperationCanceledException | Opening was canceled by the user or by an API event callback.
RevitServerCommunicationException | The server-based central model could not be accessed because of a network communication error.
RevitServerInternalException | An internal error happened on the server, please contact the server administrator.
RevitServerUnauthorizedException | User is not authorized to access the cloud model.
WrongUserException | The local file is not owned by the current user, who therefore is not allowed to modify it.
Remarks
This method opens the document into memory but does not make it visible to the user in any way. If the user currently has ownership of elements in this model and there is no local model on this machine, Revit will post a warning.
See Also

Reference

Application Class
OpenDocumentFile Overload
Autodesk.Revit.ApplicationServices Namespace


Application.OpenIFCDocument Method

ApplicationOpenIFCDocument Method

Overload List
 | Name | Description
Public method | OpenIFCDocument(String) | Opens an IFC document from disk using default options.
Public method | OpenIFCDocument(String, IFCImportOptions) | Opens an IFC document from disk using custom options.
Top
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.OpenIFCDocument(String) Method

ApplicationOpenIFCDocument(String) Method

Opens an IFC document from disk using default options.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Document OpenIFCDocument(
    string fileName
)
Public Function OpenIFCDocument (
    fileName As String
) As Document
public:
Document^ OpenIFCDocument(
    String^ fileName
)
member OpenIFCDocument :
        fileName : string -> Document

Parameters

fileName String
The IFC file to be opened.

Return Value

Document
The newly created document containing the IFC file.
Exceptions
Exception | Condition
ArgumentException | If 'fileName' is an empty string.
ArgumentNullException | If is passed as 'fileName' -or- A non-optional argument was null
FileArgumentNotFoundException | If the file specified by 'fileName' cannot be found.
InvalidOperationException | If Revit is missing document templates or if the file cannot be opened.
See Also

Reference

Application Class
OpenIFCDocument Overload
Autodesk.Revit.ApplicationServices Namespace


Application.OpenIFCDocument(String, IFCImportOptions) Method

ApplicationOpenIFCDocument(String, IFCImportOptions) Method

Opens an IFC document from disk using custom options.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Document OpenIFCDocument(
    string fileName,
    IFCImportOptions importOptions
)
Public Function OpenIFCDocument (
    fileName As String,
    importOptions As IFCImportOptions
) As Document
public:
Document^ OpenIFCDocument(
    String^ fileName,
    IFCImportOptions^ importOptions
)
member OpenIFCDocument :
        fileName : string *
        importOptions : IFCImportOptions -> Document

Parameters

fileName String
The IFC file to be opened.
importOptions IFCImportOptions
The options for this import.

Return Value

Document
The newly created document containing the IFC file.
Exceptions
Exception | Condition
ArgumentException | If 'fileName' is an empty string.
ArgumentNullException | A non-optional argument was null
FileArgumentNotFoundException | If the file specified by 'fileName' cannot be found.
InvalidOperationException | If Revit is missing document templates or if the file cannot be opened.
See Also

Reference

Application Class
OpenIFCDocument Overload
Autodesk.Revit.ApplicationServices Namespace


Application.OpenSharedParameterFile Method

ApplicationOpenSharedParameterFile Method

Enables access to shared parameter groups and definitions that are maintained on disk.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DefinitionFile OpenSharedParameterFile()
Public Function OpenSharedParameterFile As DefinitionFile
public:
DefinitionFile^ OpenSharedParameterFile()
member OpenSharedParameterFile : unit -> DefinitionFile

Return Value

DefinitionFile
An object that represents a shared parameters file that exists on disk. Returns if the file does not exist.
Remarks
This function is used to return an object that represents a Revit shared parameters file Revit can use only one shared parameters file at one time. The filename for the shared parameters file can be set in the Application.SharedParametersFilename property.
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.PurgeReleasedAPIObjects Method

ApplicationPurgeReleasedAPIObjects Method

Explicitly purges all API objects that have been released but are still awaiting to be finalized

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void PurgeReleasedAPIObjects()
Public Sub PurgeReleasedAPIObjects
public:
void PurgeReleasedAPIObjects()
member PurgeReleasedAPIObjects : unit -> unit
Remarks
Revit purges API objects automatically every time when command control returns from an API application (an external command, event handler, etc.) back to Revit. This is necessary because Revit does not allow API objects to be finalized when the finalization is invoked from an outside thread (from the garbage collector, specifically). This automatic purging is adequate in most scenarios. When an application uses a lot of API objects during one single command though, it may be necessary or beneficial to invoke an additional purge explicitly to free the deleted API objects from memory.
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.RegisterFailuresProcessor Method

ApplicationRegisterFailuresProcessor Method

Replaces Revit's default user interface (if present) with alternative handling for all warnings and errors (including those not generated by your application) for the rest of the Revit session; if your application is not prepared to respond to all warnings and errors, consider use of IFailuresPreprocessor (in your opened Transaction) or the FailuresProcessing event instead of this interface.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void RegisterFailuresProcessor(
    IFailuresProcessor processor
)
Public Shared Sub RegisterFailuresProcessor (
    processor As IFailuresProcessor
)
public:
static void RegisterFailuresProcessor(
    IFailuresProcessor^ processor
)
static member RegisterFailuresProcessor :
        processor : IFailuresProcessor -> unit

Parameters

processor IFailuresProcessor
Instance of Failures Processor to be used by the Revit Application.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
If there is previously registered Failures Processor, it gets discarded. If you opt to register a FailuresProcessor for Revit, your processor will become the default error handler for all Revit errors for the session. The standard Revit error dialog will not appear.
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.SetLibraryPaths Method

ApplicationSetLibraryPaths Method

Sets path information identifying where Revit searches for content.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetLibraryPaths(
    IDictionary<string, string> paths
)
Public Sub SetLibraryPaths (
    paths As IDictionary(Of String, String)
)
public:
void SetLibraryPaths(
    IDictionary<String^, String^>^ paths
)
member SetLibraryPaths :
        paths : IDictionary<string, string> -> unit

Parameters

paths IDictionary String, String
The map of library paths.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
The map that is returned should contain a key that is purpose of the path, such as Material Libraries and the value in the map is the fully qualified path to be used for that search path.
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.SetSystemsAnalysisWorkflows Method

ApplicationSetSystemsAnalysisWorkflows Method

Sets name and path information identifying systems analysis workflow files.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetSystemsAnalysisWorkflows(
    IDictionary<string, string> paths
)
Public Sub SetSystemsAnalysisWorkflows (
    paths As IDictionary(Of String, String)
)
public:
void SetSystemsAnalysisWorkflows(
    IDictionary<String^, String^>^ paths
)
member SetSystemsAnalysisWorkflows :
        paths : IDictionary<string, string> -> unit

Parameters

paths IDictionary String, String
The map of systems analysis workflows.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
The map should be specified as a key that is the name of the systems analysis workflow, and a value that is the path to the workflow file.
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.UpdateRenderAppearanceLibrary Method

ApplicationUpdateRenderAppearanceLibrary Method

Updates the stored render appearance library, giving the Revit session access to any new RPC content.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void UpdateRenderAppearanceLibrary()
Public Sub UpdateRenderAppearanceLibrary
public:
void UpdateRenderAppearanceLibrary()
member UpdateRenderAppearanceLibrary : unit -> unit
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.WriteJournalComment Method

ApplicationWriteJournalComment Method

Writes a comment to the Revit journal file.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void WriteJournalComment(
    string comment,
    bool timeStamp
)
Public Sub WriteJournalComment (
    comment As String,
    timeStamp As Boolean
)
public:
void WriteJournalComment(
    String^ comment,
    bool timeStamp
)
member WriteJournalComment :
        comment : string *
        timeStamp : bool -> unit

Parameters

comment String
Text for journal comment.
timeStamp Boolean
If a time stamp should be included in the journal comment.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application Events

The Application type exposes the following members.

Events
 | Name | Description
Public event | ApplicationInitialized | Subscribe to this event to get notified after the Revit application has been initialized
Public event | DocumentChanged | Subscribe to the DocumentChanged event to be notified when Revit document has changed.
Public event | DocumentClosed | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
Public event | DocumentClosing | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
Public event | DocumentCreated | Subscribe to the DocumentCreated event to be notified immediately after Revit has finished creating a new document.
Public event | DocumentCreating | Subscribe to the DocumentCreating event to be notified when Revit is just about to create a new document.
 | DocumentOpened | Subscribe to the DocumentOpened event to be notified immediately after Revit has finished opening a document.
Public event | DocumentOpening | Subscribe to the DocumentOpening event to be notified when Revit is just about to open a document.
 | DocumentPrinted | Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.
 | DocumentPrinting | Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.
Public event | DocumentReloadedLatest | Subscribe to the DocumentReloadedLatestEventArgs event to be notified immediately after Revit has finished reloading a document with central model.
Public event | DocumentReloadingLatest | Subscribe to the DocumentReloadingLatestEventArgs event to be notified when Revit is just about to reload latest changes from a central model.
Public event | DocumentSaved | Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.
Public event | DocumentSavedAs | Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.
Public event | DocumentSaving | Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document.
 | DocumentSavingAs | Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.
Public event | DocumentSynchronizedWithCentral | Subscribe to the DocumentSynchronizedWithCentral event to be notified immediately after Revit has finished synchronizing a document with central model.
Public event | DocumentSynchronizingWithCentral | Subscribe to the DocumentSynchronizingWithCentral event to be notified when Revit is just about to synchronize a document with central model.
Public event | DocumentWorksharingEnabled | Subscribe to the DocumentWorksharingEnabled event to be notified when a document has become workshared.
Public event | ElementTypeDuplicated | Subscribe to the ElementTypeDuplicated event to be notified immediately after Revit has finished duplicating an element type.
Public event | ElementTypeDuplicating | Subscribe to the ElementTypeDuplicating event to be notified when Revit is just about to duplicate an element type.
 | FailuresProcessing | Subscribe to the FailuresProcessing event to be notified when failures are being processed at the end of transaction.
Public event | FamilyLoadedIntoDocument | Subscribe to the FamilyLoadedInto event to be notified after Revit loaded a family into a document.
Public event | FamilyLoadingIntoDocument | Subscribe to the FamilyLoadingInto event to be notified when Revit is just about to load a family into a document.
Public event | FileExported | Subscribe to the FileExported event to be notified immediately after Revit has finished exporting files of formats supported by the API.
Public event | FileExporting | Subscribe to the FileExporting event to be notified when Revit is just about to export files of formats supported by the API.
Public event | FileImported | Subscribe to the FileImported event to be notified immediately after Revit has finished importing a file of format supported by the API.
Public event | FileImporting | Subscribe to the FileImporting event to be notified when Revit is just about to import a file of format supported by the API.
Public event | LinkedResourceOpened | Subscribe to the LinkedResourceOpened event to be notified immediately after Revit has finished opening a linked resource.
Public event | LinkedResourceOpening | Subscribe to the LinkedResourceOpening event to be notified when Revit is just about to open a linked resource.
Public event | ProgressChanged | Subscribe to the ProgressChanged event to be notified when an operation in Revit has progress bar data available.
Public event | ViewExported | Subscribe to the ViewExported event to be notified immediately after Revit has finished exporting a view of the document.
Public event | ViewExporting | Subscribe to the ViewExporting event to be notified when Revit is just about to export a view of the document.
 | ViewPrinted | Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.
 | ViewPrinting | Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.
Public event | ViewsExportedByContext | Subscribe to the ViewsExportedByContext event to be notified immediately after Revit has finished exporting one or more views of the document via an export context by CustomExporter.
Public event | ViewsExportingByContext | Subscribe to the ViewsExportingByContext event to be notified when Revit is just about to export one or more views of the document via an export context by CustomExporter.
Public event | WorksharedOperationProgressChanged | Subscribe to the WorksharedOperationProgressChanged to be notified when progress has changed during Collaboration for Revit's workshared operations: open model and synchronize with central.
Top
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.ApplicationInitialized Event

ApplicationApplicationInitialized Event

Subscribe to this event to get notified after the Revit application has been initialized

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<ApplicationInitializedEventArgs> ApplicationInitialized
Public Event ApplicationInitialized As EventHandler(Of ApplicationInitializedEventArgs)
public:
 event EventHandler<ApplicationInitializedEventArgs^>^ ApplicationInitialized {
    void add (EventHandler<ApplicationInitializedEventArgs^>^ value);
    void remove (EventHandler<ApplicationInitializedEventArgs^>^ value);
}
member ApplicationInitialized : IEvent<EventHandler<ApplicationInitializedEventArgs>,
    ApplicationInitializedEventArgs>

Value

EventHandler ApplicationInitializedEventArgs
Remarks
The event is raised after Revit was launched as fully initialized, including initialization of external applications.
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.DocumentChanged Event

ApplicationDocumentChanged Event

Subscribe to the DocumentChanged event to be notified when Revit document has changed.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DocumentChangedEventArgs> DocumentChanged
Public Event DocumentChanged As EventHandler(Of DocumentChangedEventArgs)
public:
 event EventHandler<DocumentChangedEventArgs^>^ DocumentChanged {
    void add (EventHandler<DocumentChangedEventArgs^>^ value);
    void remove (EventHandler<DocumentChangedEventArgs^>^ value);
}
member DocumentChanged : IEvent<EventHandler<DocumentChangedEventArgs>,
    DocumentChangedEventArgs>

Value

EventHandler DocumentChangedEventArgs
Remarks
This event is raised whenever a Revit transaction is either committed, undone or redone. This is a readonly event, designed to allow you to keep external data in synch with the state of the Revit database. To update the Revit database in response to changes in elements, use the IUpdater framework.
See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.DocumentClosed Event

ApplicationDocumentClosed Event

Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DocumentClosedEventArgs> DocumentClosed
Public Event DocumentClosed As EventHandler(Of DocumentClosedEventArgs)
public:
 event EventHandler<DocumentClosedEventArgs^>^ DocumentClosed {
    void add (EventHandler<DocumentClosedEventArgs^>^ value);
    void remove (EventHandler<DocumentClosedEventArgs^>^ value);
}
member DocumentClosed : IEvent<EventHandler<DocumentClosedEventArgs>,
    DocumentClosedEventArgs>

Value

EventHandler DocumentClosedEventArgs
Remarks

This event is raised immediately after Revit has finished closing a document. It is raised even when document closing failed or was cancelled (during DocumentClosing event).

This event is not cancellable, for the process of closing document has already been finished.

The document cannot be modified because the corresponding object does not exist anymore.

See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.DocumentClosing Event

ApplicationDocumentClosing Event

Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DocumentClosingEventArgs> DocumentClosing
Public Event DocumentClosing As EventHandler(Of DocumentClosingEventArgs)
public:
 event EventHandler<DocumentClosingEventArgs^>^ DocumentClosing {
    void add (EventHandler<DocumentClosingEventArgs^>^ value);
    void remove (EventHandler<DocumentClosingEventArgs^>^ value);
}
member DocumentClosing : IEvent<EventHandler<DocumentClosingEventArgs>,
    DocumentClosingEventArgs>

Value

EventHandler DocumentClosingEventArgs
Remarks

This event is raised when Revit is just about to close a document.

This event is cancellable, except when it is raised as part of application closing. Check the 'Cancellable' property of event's argument to see whether it is cancellable or not. When it is cancellable, call the 'Cancel()' method of event's argument to True to cancel it. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document may not be modified during this event.

The following API functions are not available for the current document during this event:

  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

An DocumentClosed event will be raised immediately after document is closed.

See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.DocumentCreated Event

ApplicationDocumentCreated Event

Subscribe to the DocumentCreated event to be notified immediately after Revit has finished creating a new document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DocumentCreatedEventArgs> DocumentCreated
Public Event DocumentCreated As EventHandler(Of DocumentCreatedEventArgs)
public:
 event EventHandler<DocumentCreatedEventArgs^>^ DocumentCreated {
    void add (EventHandler<DocumentCreatedEventArgs^>^ value);
    void remove (EventHandler<DocumentCreatedEventArgs^>^ value);
}
member DocumentCreated : IEvent<EventHandler<DocumentCreatedEventArgs>,
    DocumentCreatedEventArgs>

Value

EventHandler DocumentCreatedEventArgs
Remarks

This event is raised immediately after Revit has finished creating a new document. It is raised even when document creation failed or was cancelled (during DocumentCreating event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event's argument to see whether the action itself was successful or not. This event is not cancellable, for the process of document creation has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.DocumentCreating Event

ApplicationDocumentCreating Event

Subscribe to the DocumentCreating event to be notified when Revit is just about to create a new document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DocumentCreatingEventArgs> DocumentCreating
Public Event DocumentCreating As EventHandler(Of DocumentCreatingEventArgs)
public:
 event EventHandler<DocumentCreatingEventArgs^>^ DocumentCreating {
    void add (EventHandler<DocumentCreatingEventArgs^>^ value);
    void remove (EventHandler<DocumentCreatingEventArgs^>^ value);
}
member DocumentCreating : IEvent<EventHandler<DocumentCreatingEventArgs>,
    DocumentCreatingEventArgs>

Value

EventHandler DocumentCreatingEventArgs
Remarks

This event is raised when Revit is just about to create a new document.

Event is cancellable. To cancel it, call the 'Cancel()' method of event's argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document cannot be modified, for it is not created yet at the time of the event.

The following API functions are not available for the current document during this event:

  • [!:Autodesk::Revit::ApplicationServices::Application::NewProjectDocument()]
  • NewFamilyDocument(String)
  • NewProjectTemplateDocument(String)
  • OpenDocumentFile(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another DocumentCreated event will be raised immediately after document creation is finished.

See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.DocumentOpened Event

ApplicationDocumentOpened Event

Subscribe to the DocumentOpened event to be notified immediately after Revit has finished opening a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DocumentOpenedEventArgs> DocumentOpened
Public Event DocumentOpened As EventHandler(Of DocumentOpenedEventArgs)
public:
 event EventHandler<DocumentOpenedEventArgs^>^ DocumentOpened {
    void add (EventHandler<DocumentOpenedEventArgs^>^ value);
    void remove (EventHandler<DocumentOpenedEventArgs^>^ value);
}
member DocumentOpened : IEvent<EventHandler<DocumentOpenedEventArgs>,
    DocumentOpenedEventArgs>

Value

EventHandler DocumentOpenedEventArgs
Remarks

This event is raised immediately after Revit has finished opening a document. It is raised even when document opening failed or was cancelled (during DocumentOpening event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event's argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of opening document has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Example
C#
VB
C++
F#
Copy
public class Application_DocumentOpened : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// Implement this method to subscribe to event.
    /// </summary>
    public Result OnStartup(UIControlledApplication application)
    {
        try
        {
            // Register event.
           application.ControlledApplication.DocumentOpened += new EventHandler
                <Autodesk.Revit.DB.Events.DocumentOpenedEventArgs>(application_DocumentOpened);
        }
        catch (Exception)
        {
            return Result.Failed;
        }

        return Result.Succeeded;
    }

    /// <summary>
    /// Implement OnShutdown method of IExternalApplication interface to unregister subscribed event
    /// </summary>
    public Result OnShutdown(UIControlledApplication application)
    {
        // remove the event.
       application.ControlledApplication.DocumentOpened -= application_DocumentOpened;
        return Result.Succeeded;
    }

    /// <TrivialCode>
    /// Code ID: 501
    /// For DocumentOpened class description
    /// </TrivialCode>

    /// <description>
    /// This sample demonstrates how to subscribe to the DocumentOpened event and modify the model in the event handler method.
    /// </description>
    /// <summary>
    /// This is the event handler. We modify the model.
    /// </summary>
    /// <param name="sender">Event sender.</param>
    /// <param name="args"></param>
    public void application_DocumentOpened(object sender, DocumentOpenedEventArgs args)
    {
        // get document from event args.
        Document doc = args.Document;

        // Following code snippet demonstrates support of DocumentOpened event to modify the model.
        // Because DocumentOpened supports model changes, it allows user to update document data.
        // Here, this sample assigns a specified value to ProjectInformation.Address property.
        // User can change other properties of document or create(delete) something as he likes.
        //
        // Please note that ProjectInformation property is empty for family document.
        // So please don't run this sample on family document.
        using (Transaction transaction = new Transaction(doc, "Edit Address"))
        {
           if (transaction.Start() == TransactionStatus.Started)
           {
              doc.ProjectInformation.Address =
                  "United States - Massachusetts - Waltham - 1560 Trapelo Road";
              transaction.Commit();
           }
        }
    }

    /// </ExampleMethod>
}
Public Class Application_DocumentOpened
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' Implement this method to subscribe to event.
    ' </summary>
    Public Function OnStartup(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnStartup
        Try
            ' Register event.
            AddHandler application.ControlledApplication.DocumentOpened, AddressOf application_DocumentOpened
        Catch generatedExceptionName As Exception
            Return Result.Failed
        End Try

        Return Result.Succeeded
    End Function

    ' <summary>
    ' Implement OnShutdown method of IExternalApplication interface to unregister subscribed event
    ' </summary>
    Public Function OnShutdown(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnShutdown
        ' remove the event.
        RemoveHandler application.ControlledApplication.DocumentOpened, AddressOf application_DocumentOpened
        Return Result.Succeeded
    End Function

    ' <TrivialCode>
    ' Code ID: 501
    ' For DocumentOpened class description
    ' </TrivialCode>

    ' <description>
    ' This sample demonstrates how to subscribe to the DocumentOpened event and modify the model in the event handler method.
    ' </description>
    ' <summary>
    ' This is the event handler. We modify the model.
    ' </summary>
    ' <param name="sender">Event sender.</param>
    ' <param name="args"></param>
    Public Sub application_DocumentOpened(sender As Object, args As DocumentOpenedEventArgs)
        ' get document from event args.
        Dim doc As Document = args.Document

        ' Following code snippet demonstrates support of DocumentOpened event to modify the model.
        ' Because DocumentOpened supports model changes, it allows user to update document data.
        ' Here, this sample assigns a specified value to ProjectInformation.Address property.
        ' User can change other properties of document or create(delete) something as he likes.
        '
        ' Please note that ProjectInformation property is empty for family document.
        ' So please don't run this sample on family document.
        Using transaction As New Transaction(doc, "Edit Address")
            If transaction.Start() = TransactionStatus.Started Then
                doc.ProjectInformation.Address = "United States - Massachusetts - Waltham - 1560 Trapelo Road"
                transaction.Commit()
            End If
        End Using
    End Sub

    ' </ExampleMethod>
End Class

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.DocumentOpening Event

ApplicationDocumentOpening Event

Subscribe to the DocumentOpening event to be notified when Revit is just about to open a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DocumentOpeningEventArgs> DocumentOpening
Public Event DocumentOpening As EventHandler(Of DocumentOpeningEventArgs)
public:
 event EventHandler<DocumentOpeningEventArgs^>^ DocumentOpening {
    void add (EventHandler<DocumentOpeningEventArgs^>^ value);
    void remove (EventHandler<DocumentOpeningEventArgs^>^ value);
}
member DocumentOpening : IEvent<EventHandler<DocumentOpeningEventArgs>,
    DocumentOpeningEventArgs>

Value

EventHandler DocumentOpeningEventArgs
Remarks

This event is raised when Revit is just about to open a document.

Event is cancellable. To cancel it, call the 'Cancel()' method in event's argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document cannot be modified, for it is not opened yet at the time of the event.

Another DocumentOpened event will be raised immediately after document is opened.

See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.DocumentPrinted Event

ApplicationDocumentPrinted Event

Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DocumentPrintedEventArgs> DocumentPrinted
Public Event DocumentPrinted As EventHandler(Of DocumentPrintedEventArgs)
public:
 event EventHandler<DocumentPrintedEventArgs^>^ DocumentPrinted {
    void add (EventHandler<DocumentPrintedEventArgs^>^ value);
    void remove (EventHandler<DocumentPrintedEventArgs^>^ value);
}
member DocumentPrinted : IEvent<EventHandler<DocumentPrintedEventArgs>,
    DocumentPrintedEventArgs>

Value

EventHandler DocumentPrintedEventArgs
Remarks

This event is raised immediately after Revit has finished printing a view or ViewSet of the document. It is raised even when document printing failed or was cancelled (during DocumentPriting event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event's argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of printing has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Example
C#
VB
C++
F#
Copy
public class Application_DocumentPrinted : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// Implement the OnStartup method to register events when Revit starts.
    /// </summary>
    public Result OnStartup(UIControlledApplication application)
    {
        // Register related events
       application.ControlledApplication.DocumentPrinted += new EventHandler<Autodesk.Revit.DB.Events.DocumentPrintedEventArgs>(AppDocumentPrinted);
        return Result.Succeeded;
    }

    /// <summary>
    /// Implement this method to unregister the subscribed events when Revit exits.
    /// </summary>
    public Result OnShutdown(UIControlledApplication application)
    {
        // unregister events
       application.ControlledApplication.DocumentPrinted -= new EventHandler<Autodesk.Revit.DB.Events.DocumentPrintedEventArgs>(AppDocumentPrinted);
        return Result.Succeeded;
    }
    /// <TrivialCode>
    /// Code ID: 501
    /// For DocumentPrinted class description
    /// </TrivialCode>

    /// <summary>
    /// Handler method for DocumentPrinted event, it will display some event arguments.
    /// </summary>
    public void AppDocumentPrinted(object sender, Autodesk.Revit.DB.Events.DocumentPrintedEventArgs args)
    {
        StringBuilder info = new StringBuilder();
        Application app = sender as Application;
        info.AppendLine("DocumentPrintedEventArgs Parameters ------>");
        info.AppendLine("    Event Status      : " + args.Status.ToString());
        info.AppendLine("    Event Cancellable : " + args.Cancellable);
        //
        // PrintedViews
        if (0 == args.GetFailedViewElementIds().Count || 0 == args.GetPrintedViewElementIds().Count)
        {
            info.AppendLine("    Views been printed: <null>");
        }
        else
        {
            info.AppendLine("    Views been printed: ");
            DumpViewsInfo(app, args.GetPrintedViewElementIds(), "      ", ref info);
        }
        //
        // FailedViews
        if (0 == args.GetFailedViewElementIds().Count)
        {
            info.AppendLine("    Views failed: <null>");
        }
        else
        {
            info.AppendLine("    Views Failed : ");
            DumpViewsInfo(app, args.GetFailedViewElementIds(), "      ", ref info);
        }

        TaskDialog.Show("Revit",info.ToString());
    }

    /// <summary>
    /// Dump information of views: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="views">Views to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line added to message box.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewsInfo(Application app, System.Collections.Generic.IList<ElementId> viewIds, String prefix, ref StringBuilder info)
    {
        int index = 0;
        UIApplication uiApp = new UIApplication(app);
        foreach (ElementId curViewId in viewIds)
        {
            Autodesk.Revit.DB.View curView = uiApp.ActiveUIDocument.Document.GetElement(curViewId) as Autodesk.Revit.DB.View;
                DumpViewInfo(curView, String.Format("{0}#{1}", prefix, index++), ref info);
        }
    }

    /// <summary>
    /// Dump information of single view: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="view">View element to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line added to message box.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewInfo(Autodesk.Revit.DB.View view, String prefix, ref StringBuilder info)
    {
        info.AppendLine(String.Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}",
            prefix, view.Id.ToString(), view.Name, view.ViewType));
    }
    /// </ExampleMethod>
}
Public Class Application_DocumentPrinted
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' Implement the OnStartup method to register events when Revit starts.
    ' </summary>
    Public Function OnStartup(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnStartup
        ' Register related events
        AddHandler application.ControlledApplication.DocumentPrinted, AddressOf AppDocumentPrinted
        Return Result.Succeeded
    End Function

    ' <summary>
    ' Implement this method to unregister the subscribed events when Revit exits.
    ' </summary>
    Public Function OnShutdown(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnShutdown
        ' unregister events
        RemoveHandler application.ControlledApplication.DocumentPrinted, AddressOf AppDocumentPrinted
        Return Result.Succeeded
    End Function
    ' <TrivialCode>
    ' Code ID: 501
    ' For DocumentPrinted class description
    ' </TrivialCode>

    ' <summary>
    ' Handler method for DocumentPrinted event, it will display some event arguments.
    ' </summary>
    Public Sub AppDocumentPrinted(sender As Object, args As Autodesk.Revit.DB.Events.DocumentPrintedEventArgs)
        Dim info As New StringBuilder()
        Dim app As Application = TryCast(sender, Application)
        info.AppendLine("DocumentPrintedEventArgs Parameters ------>")
        info.AppendLine("    Event Status      : " & args.Status.ToString())
        info.AppendLine("    Event Cancellable : " & Convert.ToString(args.Cancellable))
        '
        ' PrintedViews
        If 0 = args.GetFailedViewElementIds().Count OrElse 0 = args.GetPrintedViewElementIds().Count Then
            info.AppendLine("    Views been printed: <null>")
        Else
            info.AppendLine("    Views been printed: ")
            DumpViewsInfo(app, args.GetPrintedViewElementIds(), "      ", info)
        End If
        '
        ' FailedViews
        If 0 = args.GetFailedViewElementIds().Count Then
            info.AppendLine("    Views failed: <null>")
        Else
            info.AppendLine("    Views Failed : ")
            DumpViewsInfo(app, args.GetFailedViewElementIds(), "      ", info)
        End If

        TaskDialog.Show("Revit", info.ToString())
    End Sub

    ' <summary>
    ' Dump information of views: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="views">Views to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line added to message box.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewsInfo(app As Application, viewIds As System.Collections.Generic.IList(Of ElementId), prefix As [String], ByRef info As StringBuilder)
        Dim index As Integer = 0
        Dim uiApp As New UIApplication(app)
        For Each curViewId As ElementId In viewIds
            Dim curView As Autodesk.Revit.DB.View = TryCast(uiApp.ActiveUIDocument.Document.GetElement(curViewId), Autodesk.Revit.DB.View)
            DumpViewInfo(curView, [String].Format("{0}#{1}", prefix, System.Math.Max(System.Threading.Interlocked.Increment(index), index - 1)), info)
        Next
    End Sub

    ' <summary>
    ' Dump information of single view: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="view">View element to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line added to message box.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewInfo(view As Autodesk.Revit.DB.View, prefix As [String], ByRef info As StringBuilder)
        info.AppendLine([String].Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}", prefix, view.Id.ToString(), view.Name, view.ViewType))
    End Sub
    ' </ExampleMethod>
End Class

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.DocumentPrinting Event

ApplicationDocumentPrinting Event

Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DocumentPrintingEventArgs> DocumentPrinting
Public Event DocumentPrinting As EventHandler(Of DocumentPrintingEventArgs)
public:
 event EventHandler<DocumentPrintingEventArgs^>^ DocumentPrinting {
    void add (EventHandler<DocumentPrintingEventArgs^>^ value);
    void remove (EventHandler<DocumentPrintingEventArgs^>^ value);
}
member DocumentPrinting : IEvent<EventHandler<DocumentPrintingEventArgs>,
    DocumentPrintingEventArgs>

Value

EventHandler DocumentPrintingEventArgs
Remarks

This event is raised when Revit is just about to print a view or ViewSet of the document.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is cancellable. To cancel it, call the 'Cancel()' method of event's argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for current document during this event:

  • All overloads of Autodesk.Revit.DB.Document.Export()
  • Autodesk::Revit::DB::Document::Print
  • Print and similar overloads.
  • SubmitPrint and similar overloads.
  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.
  • [!:Autodesk::Revit::DB::Document::Save()] .
  • [!:Autodesk::Revit::DB::Document::SaveAs(String)] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

After this event, for each view being printed, ViewPrinting and ViewPrinted events will be raised. Another event [!:Autodesk::Revit::DB::Document::DocumentPrinted] will be raised immediately after document printing is finished.

Example
C#
VB
C++
F#
Copy
public class Application_DocumentPrinting : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// Implement the OnStartup method to register events when Revit starts.
    /// </summary>
    public Result OnStartup(UIControlledApplication application)
    {
        // Register related events
       application.ControlledApplication.DocumentPrinting += new EventHandler<Autodesk.Revit.DB.Events.DocumentPrintingEventArgs>(AppDocumentPrinting);
        return Result.Succeeded;
    }

    /// <summary>
    /// Implement this method to unregister the subscribed events when Revit exits.
    /// </summary>
    public Result OnShutdown(UIControlledApplication application)
    {
        // unregister events
       application.ControlledApplication.DocumentPrinting -= new EventHandler<Autodesk.Revit.DB.Events.DocumentPrintingEventArgs>(AppDocumentPrinting);
        return Result.Succeeded;
    }
    /// <TrivialCode>
    /// Code ID: 501
    /// For DocumentPrinting class description
    /// </TrivialCode>

    /// <summary>
    /// Handler method for DocumentPrinting event, it will display some event arguments.
    /// </summary>
    public void AppDocumentPrinting(object sender, Autodesk.Revit.DB.Events.DocumentPrintingEventArgs args)
    {
        StringBuilder info = new StringBuilder();
        info.AppendLine("DocumentPrintingEventArgs Parameters ------>");

        info.AppendLine("    Event Cancellable   : " + args.Cancellable);
        info.AppendLine("    Views to be printed : "); // Views
        Application app = sender as Application;
        DumpViewsInfo(app, args.GetViewElementIds(), "    ", ref info);

        TaskDialog.Show("Revit",info.ToString());
    }

    /// <summary>
    /// Dump information of views: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="views">Views to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line added to message box.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewsInfo(Application app, System.Collections.Generic.IList<ElementId> viewIds, String prefix, ref StringBuilder info)
    {
        int index = 0;
        UIApplication uiApp = new UIApplication(app);
        foreach (ElementId curViewId in viewIds)
        {
            Autodesk.Revit.DB.View curView = uiApp.ActiveUIDocument.Document.GetElement(curViewId) as Autodesk.Revit.DB.View;
            DumpViewInfo(curView, String.Format("{0}#{1}", prefix, index++), ref info);
        }
    }

    /// <summary>
    /// Dump information of single view: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="view">View element to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line sent to message box.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewInfo(Autodesk.Revit.DB.View view, String prefix, ref StringBuilder info)
    {
        info.AppendLine(String.Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}",
            prefix, view.Id.ToString(), view.Name, view.ViewType));
    }
    /// </ExampleMethod>
}
Public Class Application_DocumentPrinting
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' Implement the OnStartup method to register events when Revit starts.
    ' </summary>
    Public Function OnStartup(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnStartup
        ' Register related events
        AddHandler application.ControlledApplication.DocumentPrinting, AddressOf AppDocumentPrinting
        Return Result.Succeeded
    End Function

    ' <summary>
    ' Implement this method to unregister the subscribed events when Revit exits.
    ' </summary>
    Public Function OnShutdown(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnShutdown
        ' unregister events
        RemoveHandler application.ControlledApplication.DocumentPrinting, AddressOf AppDocumentPrinting
        Return Result.Succeeded
    End Function
    ' <TrivialCode>
    ' Code ID: 501
    ' For DocumentPrinting class description
    ' </TrivialCode>

    ' <summary>
    ' Handler method for DocumentPrinting event, it will display some event arguments.
    ' </summary>
    Public Sub AppDocumentPrinting(sender As Object, args As Autodesk.Revit.DB.Events.DocumentPrintingEventArgs)
        Dim info As New StringBuilder()
        info.AppendLine("DocumentPrintingEventArgs Parameters ------>")

        info.AppendLine("    Event Cancellable   : " & Convert.ToString(args.Cancellable))
        info.AppendLine("    Views to be printed : ")
        ' Views
        Dim app As Application = TryCast(sender, Application)
        DumpViewsInfo(app, args.GetViewElementIds(), "    ", info)

        TaskDialog.Show("Revit", info.ToString())
    End Sub

    ' <summary>
    ' Dump information of views: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="views">Views to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line added to message box.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewsInfo(app As Application, viewIds As System.Collections.Generic.IList(Of ElementId), prefix As [String], ByRef info As StringBuilder)
        Dim index As Integer = 0
        Dim uiApp As New UIApplication(app)
        For Each curViewId As ElementId In viewIds
            Dim curView As Autodesk.Revit.DB.View = TryCast(uiApp.ActiveUIDocument.Document.GetElement(curViewId), Autodesk.Revit.DB.View)
            DumpViewInfo(curView, [String].Format("{0}#{1}", prefix, System.Math.Max(System.Threading.Interlocked.Increment(index), index - 1)), info)
        Next
    End Sub

    ' <summary>
    ' Dump information of single view: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="view">View element to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line sent to message box.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewInfo(view As Autodesk.Revit.DB.View, prefix As [String], ByRef info As StringBuilder)
        info.AppendLine([String].Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}", prefix, view.Id.ToString(), view.Name, view.ViewType))
    End Sub
    ' </ExampleMethod>
End Class

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.DocumentReloadedLatest Event

ApplicationDocumentReloadedLatest Event

Subscribe to the DocumentReloadedLatestEventArgs event to be notified immediately after Revit has finished reloading a document with central model.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DocumentReloadedLatestEventArgs> DocumentReloadedLatest
Public Event DocumentReloadedLatest As EventHandler(Of DocumentReloadedLatestEventArgs)
public:
 event EventHandler<DocumentReloadedLatestEventArgs^>^ DocumentReloadedLatest {
    void add (EventHandler<DocumentReloadedLatestEventArgs^>^ value);
    void remove (EventHandler<DocumentReloadedLatestEventArgs^>^ value);
}
member DocumentReloadedLatest : IEvent<EventHandler<DocumentReloadedLatestEventArgs>,
    DocumentReloadedLatestEventArgs>

Value

EventHandler DocumentReloadedLatestEventArgs
Remarks

This event is raised immediately after Revit has finished reloading latest changes from a central model. It is raised even when document reloading latest changes from a central model failed or was cancelled (during DocumentReloadingLatest event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event's argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of reloading latest changes from a central model has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.
  • [!:Autodesk::Revit::DB::Document::Save()] .
  • [!:Autodesk::Revit::DB::Document::SaveAs(String)] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.DocumentReloadingLatest Event

ApplicationDocumentReloadingLatest Event

Subscribe to the DocumentReloadingLatestEventArgs event to be notified when Revit is just about to reload latest changes from a central model.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DocumentReloadingLatestEventArgs> DocumentReloadingLatest
Public Event DocumentReloadingLatest As EventHandler(Of DocumentReloadingLatestEventArgs)
public:
 event EventHandler<DocumentReloadingLatestEventArgs^>^ DocumentReloadingLatest {
    void add (EventHandler<DocumentReloadingLatestEventArgs^>^ value);
    void remove (EventHandler<DocumentReloadingLatestEventArgs^>^ value);
}
member DocumentReloadingLatest : IEvent<EventHandler<DocumentReloadingLatestEventArgs>,
    DocumentReloadingLatestEventArgs>

Value

EventHandler DocumentReloadingLatestEventArgs
Remarks

This event is raised when Revit is just about to reload latest changes from a central model.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is cancellable. To cancel it, call the 'Cancel()' method in event's argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.
  • [!:Autodesk::Revit::DB::Document::Save()] .
  • [!:Autodesk::Revit::DB::Document::SaveAs(String)] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another DocumentReloadingLatest event will be raised immediately after latest changes reloading from a central model is finished.

See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.DocumentSaved Event

ApplicationDocumentSaved Event

Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DocumentSavedEventArgs> DocumentSaved
Public Event DocumentSaved As EventHandler(Of DocumentSavedEventArgs)
public:
 event EventHandler<DocumentSavedEventArgs^>^ DocumentSaved {
    void add (EventHandler<DocumentSavedEventArgs^>^ value);
    void remove (EventHandler<DocumentSavedEventArgs^>^ value);
}
member DocumentSaved : IEvent<EventHandler<DocumentSavedEventArgs>,
    DocumentSavedEventArgs>

Value

EventHandler DocumentSavedEventArgs
Remarks

This event is raised immediately after Revit has finished saving a document. Note that the first save of a newly created document will raise DocumentSavedAs rather than the DocumentSaved event. It is raised even when document saving failed or was cancelled (during DocumentSaving event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' property in event's argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of saving document has already been finished.

The following API functions are not available for the current document during this event:

  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.
  • [!:Autodesk::Revit::DB::Document::Save()] .
  • [!:Autodesk::Revit::DB::Document::SaveAs(String)] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.DocumentSavedAs Event

ApplicationDocumentSavedAs Event

Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DocumentSavedAsEventArgs> DocumentSavedAs
Public Event DocumentSavedAs As EventHandler(Of DocumentSavedAsEventArgs)
public:
 event EventHandler<DocumentSavedAsEventArgs^>^ DocumentSavedAs {
    void add (EventHandler<DocumentSavedAsEventArgs^>^ value);
    void remove (EventHandler<DocumentSavedAsEventArgs^>^ value);
}
member DocumentSavedAs : IEvent<EventHandler<DocumentSavedAsEventArgs>,
    DocumentSavedAsEventArgs>

Value

EventHandler DocumentSavedAsEventArgs
Remarks

This event is raised immediately after Revit has finished saving document with a new file name. Note that the first save of a newly created document will raise DocumentSavedAs rather than DocumentSaved event. It is raised even when document saving failed or was cancelled (during DocumentSavingAs event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' property in event's argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of saving document has already been finished.

The following API functions are not available for the current document during this event:

  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.
  • [!:Autodesk::Revit::DB::Document::Save()] .
  • [!:Autodesk::Revit::DB::Document::SaveAs(String)] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.DocumentSaving Event

ApplicationDocumentSaving Event

Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DocumentSavingEventArgs> DocumentSaving
Public Event DocumentSaving As EventHandler(Of DocumentSavingEventArgs)
public:
 event EventHandler<DocumentSavingEventArgs^>^ DocumentSaving {
    void add (EventHandler<DocumentSavingEventArgs^>^ value);
    void remove (EventHandler<DocumentSavingEventArgs^>^ value);
}
member DocumentSaving : IEvent<EventHandler<DocumentSavingEventArgs>,
    DocumentSavingEventArgs>

Value

EventHandler DocumentSavingEventArgs
Remarks

This event is raised when Revit is just about to save the document. Note that the first save of a newly created document will raise DocumentSavingAs rather than the DocumentSaving event.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

This event is cancellable, except when it is raised during close of the application. Check the 'Cancellable' property of event's argument to see whether it is cancellable or not. When it is cancellable, call the 'Cancel()' method of event's argument to cancel it. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.
  • [!:Autodesk::Revit::DB::Document::Save()] .
  • [!:Autodesk::Revit::DB::Document::SaveAs(String)] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event DocumentSaved will be raised immediately after the document has been saved.

See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.DocumentSavingAs Event

ApplicationDocumentSavingAs Event

Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DocumentSavingAsEventArgs> DocumentSavingAs
Public Event DocumentSavingAs As EventHandler(Of DocumentSavingAsEventArgs)
public:
 event EventHandler<DocumentSavingAsEventArgs^>^ DocumentSavingAs {
    void add (EventHandler<DocumentSavingAsEventArgs^>^ value);
    void remove (EventHandler<DocumentSavingAsEventArgs^>^ value);
}
member DocumentSavingAs : IEvent<EventHandler<DocumentSavingAsEventArgs>,
    DocumentSavingAsEventArgs>

Value

EventHandler DocumentSavingAsEventArgs
Remarks

This event is raised when Revit is just about to save the document with a new file name. Note that the first save of a newly created document will raise DocumentSavingAs rather than DocumentSaving event.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

This event is cancellable, except when it is raised during close of the application. Check the 'Cancellable' property of event's argument to see whether it is cancellable or not. When it is cancellable, call the 'Cancel()' method of event's argument to cancel it. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.
  • [!:Autodesk::Revit::DB::Document::Save()] .
  • [!:Autodesk::Revit::DB::Document::SaveAs(String)] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event DocumentSavedAs will be raised immediately after the document has been saved with a new file name.

Example
C#
VB
C++
F#
Copy
public class DocumentSavingAs : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// This method subscribes to DocumentSavingAs event.
    /// </summary>
    public Result OnStartup(UIControlledApplication application)
    {
       application.ControlledApplication.DocumentSavingAs += new EventHandler<DocumentSavingAsEventArgs>(CheckProjectStatusInitial);
        return Result.Succeeded;
    }

    /// <summary>
    /// Implement OnShutdown method of IExternalApplication interface to unregister subscribed event
    /// </summary>
    public Result OnShutdown(UIControlledApplication application)
    {
        // unregister subscribed event
       application.ControlledApplication.DocumentSavingAs -= new EventHandler<DocumentSavingAsEventArgs>(CheckProjectStatusInitial);
        return Result.Succeeded;
    }

    /// <summary>
    /// Event handler method for DocumentSavingAs event. This method will check the "Project Status" value,
    /// if it is null or empty string cancel the save as process.
    /// </summary>
    /// <param name="sender">The source of the event.</param>
    /// <param name="args">Event arguments that contains the event data.</param>
    private void CheckProjectStatusInitial(Object sender, DocumentSavingAsEventArgs args)
    {
        Document doc = args.Document;
        ProjectInfo proInfo = doc.ProjectInformation;

        // Project information is only available for project document.
        if (null != proInfo)
        {
            if (string.IsNullOrEmpty(proInfo.Status))
            {
                // cancel the save as process.
                args.Cancel();
                TaskDialog.Show("Revit","Status project parameter is not set.  Save is aborted.");
            }
        }
    }
    /// </ExampleMethod>
}
Public Class DocumentSavingAs
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' This method subscribes to DocumentSavingAs event.
    ' </summary>
    Public Function OnStartup(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnStartup
        AddHandler application.ControlledApplication.DocumentSavingAs, AddressOf CheckProjectStatusInitial
        Return Result.Succeeded
    End Function

    ' <summary>
    ' Implement OnShutdown method of IExternalApplication interface to unregister subscribed event
    ' </summary>
    Public Function OnShutdown(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnShutdown
        ' unregister subscribed event
        RemoveHandler application.ControlledApplication.DocumentSavingAs, AddressOf CheckProjectStatusInitial
        Return Result.Succeeded
    End Function

    ' <summary>
    ' Event handler method for DocumentSavingAs event. This method will check the "Project Status" value,
    ' if it is null or empty string cancel the save as process.
    ' </summary>
    ' <param name="sender">The source of the event.</param>
    ' <param name="args">Event arguments that contains the event data.</param>
    Private Sub CheckProjectStatusInitial(sender As [Object], args As DocumentSavingAsEventArgs)
        Dim doc As Document = args.Document
        Dim proInfo As ProjectInfo = doc.ProjectInformation

        ' Project information is only available for project document.
        If proInfo IsNot Nothing Then
            If String.IsNullOrEmpty(proInfo.Status) Then
                ' cancel the save as process.
                args.Cancel()
                TaskDialog.Show("Revit", "Status project parameter is not set.  Save is aborted.")
            End If
        End If
    End Sub
    ' </ExampleMethod>
End Class

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.DocumentSynchronizedWithCentral Event

ApplicationDocumentSynchronizedWithCentral Event

Subscribe to the DocumentSynchronizedWithCentral event to be notified immediately after Revit has finished synchronizing a document with central model.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DocumentSynchronizedWithCentralEventArgs> DocumentSynchronizedWithCentral
Public Event DocumentSynchronizedWithCentral As EventHandler(Of DocumentSynchronizedWithCentralEventArgs)
public:
 event EventHandler<DocumentSynchronizedWithCentralEventArgs^>^ DocumentSynchronizedWithCentral {
    void add (EventHandler<DocumentSynchronizedWithCentralEventArgs^>^ value);
    void remove (EventHandler<DocumentSynchronizedWithCentralEventArgs^>^ value);
}
member DocumentSynchronizedWithCentral : IEvent<EventHandler<DocumentSynchronizedWithCentralEventArgs>,
    DocumentSynchronizedWithCentralEventArgs>

Value

EventHandler DocumentSynchronizedWithCentralEventArgs
Remarks

This event is raised immediately after Revit has finished synchronizing a document with central model. It is raised even when document synchronizing with central model failed or was cancelled (during DocumentSynchronizingWithCentral event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event's argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of synchronizing a document with central model has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.
  • [!:Autodesk::Revit::DB::Document::Save()] .
  • [!:Autodesk::Revit::DB::Document::SaveAs(String)] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.DocumentSynchronizingWithCentral Event

ApplicationDocumentSynchronizingWithCentral Event

Subscribe to the DocumentSynchronizingWithCentral event to be notified when Revit is just about to synchronize a document with central model.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DocumentSynchronizingWithCentralEventArgs> DocumentSynchronizingWithCentral
Public Event DocumentSynchronizingWithCentral As EventHandler(Of DocumentSynchronizingWithCentralEventArgs)
public:
 event EventHandler<DocumentSynchronizingWithCentralEventArgs^>^ DocumentSynchronizingWithCentral {
    void add (EventHandler<DocumentSynchronizingWithCentralEventArgs^>^ value);
    void remove (EventHandler<DocumentSynchronizingWithCentralEventArgs^>^ value);
}
member DocumentSynchronizingWithCentral : IEvent<EventHandler<DocumentSynchronizingWithCentralEventArgs>,
    DocumentSynchronizingWithCentralEventArgs>

Value

EventHandler DocumentSynchronizingWithCentralEventArgs
Remarks

This event is raised when Revit is just about to synchronize a document with central model.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is cancellable. To cancel it, call the 'Cancel()' method in event's argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.
  • [!:Autodesk::Revit::DB::Document::Save()] .
  • [!:Autodesk::Revit::DB::Document::SaveAs(String)] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another DocumentSynchronizedWithCentral event will be raised immediately after document synchronizing with central model is finished.

See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.DocumentWorksharingEnabled Event

ApplicationDocumentWorksharingEnabled Event

Subscribe to the DocumentWorksharingEnabled event to be notified when a document has become workshared.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DocumentWorksharingEnabledEventArgs> DocumentWorksharingEnabled
Public Event DocumentWorksharingEnabled As EventHandler(Of DocumentWorksharingEnabledEventArgs)
public:
 event EventHandler<DocumentWorksharingEnabledEventArgs^>^ DocumentWorksharingEnabled {
    void add (EventHandler<DocumentWorksharingEnabledEventArgs^>^ value);
    void remove (EventHandler<DocumentWorksharingEnabledEventArgs^>^ value);
}
member DocumentWorksharingEnabled : IEvent<EventHandler<DocumentWorksharingEnabledEventArgs>,
    DocumentWorksharingEnabledEventArgs>

Value

EventHandler DocumentWorksharingEnabledEventArgs
Remarks

This event is raised when Revit has just enabled worksharing in the document.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.ElementTypeDuplicated Event

ApplicationElementTypeDuplicated Event

Subscribe to the ElementTypeDuplicated event to be notified immediately after Revit has finished duplicating an element type.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<ElementTypeDuplicatedEventArgs> ElementTypeDuplicated
Public Event ElementTypeDuplicated As EventHandler(Of ElementTypeDuplicatedEventArgs)
public:
 event EventHandler<ElementTypeDuplicatedEventArgs^>^ ElementTypeDuplicated {
    void add (EventHandler<ElementTypeDuplicatedEventArgs^>^ value);
    void remove (EventHandler<ElementTypeDuplicatedEventArgs^>^ value);
}
member ElementTypeDuplicated : IEvent<EventHandler<ElementTypeDuplicatedEventArgs>,
    ElementTypeDuplicatedEventArgs>

Value

EventHandler ElementTypeDuplicatedEventArgs
Remarks

This event is raised immediately after Revit has finished duplicating an element type. It is raised even when duplicating an element type failed or was cancelled (during ElementTypeDuplicating event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in the event's argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of duplicating an element type has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.ElementTypeDuplicating Event

ApplicationElementTypeDuplicating Event

Subscribe to the ElementTypeDuplicating event to be notified when Revit is just about to duplicate an element type.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<ElementTypeDuplicatingEventArgs> ElementTypeDuplicating
Public Event ElementTypeDuplicating As EventHandler(Of ElementTypeDuplicatingEventArgs)
public:
 event EventHandler<ElementTypeDuplicatingEventArgs^>^ ElementTypeDuplicating {
    void add (EventHandler<ElementTypeDuplicatingEventArgs^>^ value);
    void remove (EventHandler<ElementTypeDuplicatingEventArgs^>^ value);
}
member ElementTypeDuplicating : IEvent<EventHandler<ElementTypeDuplicatingEventArgs>,
    ElementTypeDuplicatingEventArgs>

Value

EventHandler ElementTypeDuplicatingEventArgs
Remarks

This event is raised when Revit is just about to duplicate an element type.

Event is cancellable. To cancel it, call the 'Cancel()' method in event's argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • All overloads of Autodesk.Revit.DB.Document.Import()
  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.
  • [!:Autodesk::Revit::DB::Document::Save()] .
  • [!:Autodesk::Revit::DB::Document::SaveAs(String)] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another ElementTypeDuplicated event will be raised immediately after duplicating an element type is finished.

See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.FailuresProcessing Event

ApplicationFailuresProcessing Event

Subscribe to the FailuresProcessing event to be notified when failures are being processed at the end of transaction.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<FailuresProcessingEventArgs> FailuresProcessing
Public Event FailuresProcessing As EventHandler(Of FailuresProcessingEventArgs)
public:
 event EventHandler<FailuresProcessingEventArgs^>^ FailuresProcessing {
    void add (EventHandler<FailuresProcessingEventArgs^>^ value);
    void remove (EventHandler<FailuresProcessingEventArgs^>^ value);
}
member FailuresProcessing : IEvent<EventHandler<FailuresProcessingEventArgs>,
    FailuresProcessingEventArgs>

Value

EventHandler FailuresProcessingEventArgs
Remarks

This event is raised when failures are being processed during transaction commit or rollback operations. Handlers of this event have a limited ability to modify the document and/or failures in it, using the provided restricted failures accessor interface.

The event arguments provide access to the FailuresAccessor via [!:Autodesk::Revit::DB::FailuresProcessingEventArgs::GetFailuresAccessor()] which contains the details of the errors and/or warnings that caused the event to trigger.

The arguments also allow you to set a processing result via [!:Autodesk::Revit::DB::FailuresProcessingEventArgs::SetProcessingResult()]. The processing result determines if Revit will attempt to recommit the currently failing transaction, roll it back, or continue. If you are explicitly dismissing warnings from the event callback, a processing result of Continue is sufficient. But if you are explicitly resolving errors from the event callback, you must change the processing result to ProceedWithCommit to ensure that the user is not shown the dismissed errors. If you wish to cancel the transaction silently without showing the errors to the user, set the processing result to ProceedWithRollback, however you must also call SetClearAfterRollback(Boolean) in order to dismiss the errors and silently cancel the transaction.

Example
C#
VB
C++
F#
Copy
[Autodesk.Revit.Attributes.Transaction(Autodesk.Revit.Attributes.TransactionMode.Manual)]

 public class NoUnenclosedRoomWarnings : IExternalApplication
 {
     static AddInId m_appId = new AddInId(new Guid("EB296268-8364-4d25-96E6-F664C608503C"));

     public Result OnStartup(UIControlledApplication application)
     {
         //Create an API application that subscribes to FailuresProcessing event for the lifetime of the session.
         application.ControlledApplication.FailuresProcessing += new EventHandler<FailuresProcessingEventArgs>(CheckWarnings);
         return Result.Succeeded;
     }

     public Result OnShutdown(UIControlledApplication application)
     {
         return Result.Succeeded;
     }

     private void CheckWarnings(object sender, FailuresProcessingEventArgs e)
     {
         FailuresAccessor fa = e.GetFailuresAccessor();
         IList<FailureMessageAccessor> failList = new List<FailureMessageAccessor>();
         failList = fa.GetFailureMessages(); // Inside event handler, get all warnings
         foreach (FailureMessageAccessor failure in failList)
         {
             // check FailureDefinitionIds against ones that you want to dismiss,
             FailureDefinitionId failID = failure.GetFailureDefinitionId();
             // prevent Revit from showing Unenclosed room warnings
             if (failID == BuiltInFailures.RoomFailures.RoomNotEnclosed)
             {
                 fa.DeleteWarning(failure);
             }
         }
     }
 }
<Autodesk.Revit.Attributes.Transaction(Autodesk.Revit.Attributes.TransactionMode.Manual)> _
Public Class NoUnenclosedRoomWarnings
    Implements IExternalApplication
    Shared m_appId As New AddInId(New Guid("EB296268-8364-4d25-96E6-F664C608503C"))

    Public Function OnStartup(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnStartup
        'Create an API application that subscribes to FailuresProcessing event for the lifetime of the session.
        AddHandler application.ControlledApplication.FailuresProcessing, AddressOf CheckWarnings
        Return Result.Succeeded
    End Function

    Public Function OnShutdown(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnShutdown
        Return Result.Succeeded
    End Function

    Private Sub CheckWarnings(sender As Object, e As FailuresProcessingEventArgs)
        Dim fa As FailuresAccessor = e.GetFailuresAccessor()
        Dim failList As IList(Of FailureMessageAccessor) = New List(Of FailureMessageAccessor)()
        failList = fa.GetFailureMessages()
        ' Inside event handler, get all warnings
        For Each failure As FailureMessageAccessor In failList
            ' check FailureDefinitionIds against ones that you want to dismiss,
            Dim failID As FailureDefinitionId = failure.GetFailureDefinitionId()
            ' prevent Revit from showing Unenclosed room warnings
            If failID = BuiltInFailures.RoomFailures.RoomNotEnclosed Then
                fa.DeleteWarning(failure)
            End If
        Next
    End Sub
End Class

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.FamilyLoadedIntoDocument Event

ApplicationFamilyLoadedIntoDocument Event

Subscribe to the FamilyLoadedInto event to be notified after Revit loaded a family into a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<FamilyLoadedIntoDocumentEventArgs> FamilyLoadedIntoDocument
Public Event FamilyLoadedIntoDocument As EventHandler(Of FamilyLoadedIntoDocumentEventArgs)
public:
 event EventHandler<FamilyLoadedIntoDocumentEventArgs^>^ FamilyLoadedIntoDocument {
    void add (EventHandler<FamilyLoadedIntoDocumentEventArgs^>^ value);
    void remove (EventHandler<FamilyLoadedIntoDocumentEventArgs^>^ value);
}
member FamilyLoadedIntoDocument : IEvent<EventHandler<FamilyLoadedIntoDocumentEventArgs>,
    FamilyLoadedIntoDocumentEventArgs>

Value

EventHandler FamilyLoadedIntoDocumentEventArgs
Remarks

This event is raised immediately after Revit has finished loading a family into a document. It is raised even when family loading failed or was cancelled (during FamilyLoadingIntoDocument event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event's argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of importing has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.FamilyLoadingIntoDocument Event

ApplicationFamilyLoadingIntoDocument Event

Subscribe to the FamilyLoadingInto event to be notified when Revit is just about to load a family into a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<FamilyLoadingIntoDocumentEventArgs> FamilyLoadingIntoDocument
Public Event FamilyLoadingIntoDocument As EventHandler(Of FamilyLoadingIntoDocumentEventArgs)
public:
 event EventHandler<FamilyLoadingIntoDocumentEventArgs^>^ FamilyLoadingIntoDocument {
    void add (EventHandler<FamilyLoadingIntoDocumentEventArgs^>^ value);
    void remove (EventHandler<FamilyLoadingIntoDocumentEventArgs^>^ value);
}
member FamilyLoadingIntoDocument : IEvent<EventHandler<FamilyLoadingIntoDocumentEventArgs>,
    FamilyLoadingIntoDocumentEventArgs>

Value

EventHandler FamilyLoadingIntoDocumentEventArgs
Remarks

This event is raised when Revit is just about to load a family into a document.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is cancellable. To cancel it, call the 'Cancel()' method in event's argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • All overloads of Autodesk.Revit.DB.Document.Import()
  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.
  • [!:Autodesk::Revit::DB::Document::Save()] .
  • [!:Autodesk::Revit::DB::Document::SaveAs(String)] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another FamilyLoadedIntoDocument event will be raised immediately after family loading is finished.

See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.FileExported Event

ApplicationFileExported Event

Subscribe to the FileExported event to be notified immediately after Revit has finished exporting files of formats supported by the API.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<FileExportedEventArgs> FileExported
Public Event FileExported As EventHandler(Of FileExportedEventArgs)
public:
 event EventHandler<FileExportedEventArgs^>^ FileExported {
    void add (EventHandler<FileExportedEventArgs^>^ value);
    void remove (EventHandler<FileExportedEventArgs^>^ value);
}
member FileExported : IEvent<EventHandler<FileExportedEventArgs>,
    FileExportedEventArgs>

Value

EventHandler FileExportedEventArgs
Remarks

This event is raised immediately after Revit has finished exporting files of formats supported by the API. It is raised even when file exporting failed or was cancelled (during FileExporting event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event's argument to see whether the action itself was successful or not. If export is a part of 'Publish to Buzzsaw' command which consists of two parts â€“ export of a document followed by publishing it to a BuzzSaw server, the event status only reflects the result of the Export action. The publishing part of the command could still be cancelled or could fail after FileExported event is raised.

This event is not cancellable, for the process of exporting file has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.FileExporting Event

ApplicationFileExporting Event

Subscribe to the FileExporting event to be notified when Revit is just about to export files of formats supported by the API.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<FileExportingEventArgs> FileExporting
Public Event FileExporting As EventHandler(Of FileExportingEventArgs)
public:
 event EventHandler<FileExportingEventArgs^>^ FileExporting {
    void add (EventHandler<FileExportingEventArgs^>^ value);
    void remove (EventHandler<FileExportingEventArgs^>^ value);
}
member FileExporting : IEvent<EventHandler<FileExportingEventArgs>,
    FileExportingEventArgs>

Value

EventHandler FileExportingEventArgs
Remarks

This event is raised when Revit is just about to export files of formats supported by the API.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is cancellable. To cancel it, call the 'Cancel()' method in event's argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • All overloads of Autodesk.Revit.DB.Document.Export()
  • Autodesk.Revit.Document.Print()
  • Print and similar overloads.
  • SubmitPrint and similar overloads.
  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.
  • [!:Autodesk::Revit::DB::Document::Save()] .
  • [!:Autodesk::Revit::DB::Document::SaveAs(String)] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another FileExported event will be raised immediately after file exporting is finished.

See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.FileImported Event

ApplicationFileImported Event

Subscribe to the FileImported event to be notified immediately after Revit has finished importing a file of format supported by the API.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<FileImportedEventArgs> FileImported
Public Event FileImported As EventHandler(Of FileImportedEventArgs)
public:
 event EventHandler<FileImportedEventArgs^>^ FileImported {
    void add (EventHandler<FileImportedEventArgs^>^ value);
    void remove (EventHandler<FileImportedEventArgs^>^ value);
}
member FileImported : IEvent<EventHandler<FileImportedEventArgs>,
    FileImportedEventArgs>

Value

EventHandler FileImportedEventArgs
Remarks

This event is raised immediately after Revit has finished importing a file of format supported by the API. It is raised even when file importing failed or was cancelled (during FileImporting event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event's argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of importing has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.FileImporting Event

ApplicationFileImporting Event

Subscribe to the FileImporting event to be notified when Revit is just about to import a file of format supported by the API.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<FileImportingEventArgs> FileImporting
Public Event FileImporting As EventHandler(Of FileImportingEventArgs)
public:
 event EventHandler<FileImportingEventArgs^>^ FileImporting {
    void add (EventHandler<FileImportingEventArgs^>^ value);
    void remove (EventHandler<FileImportingEventArgs^>^ value);
}
member FileImporting : IEvent<EventHandler<FileImportingEventArgs>,
    FileImportingEventArgs>

Value

EventHandler FileImportingEventArgs
Remarks

This event is raised when Revit is just about to import a file of format supported by the API.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is cancellable. To cancel it, call the 'Cancel()' method in event's argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • All overloads of Autodesk.Revit.DB.Document.Import()
  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.
  • [!:Autodesk::Revit::DB::Document::Save()] .
  • [!:Autodesk::Revit::DB::Document::SaveAs(String)] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another FileImported event will be raised immediately after file importing is finished.

See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.LinkedResourceOpened Event

ApplicationLinkedResourceOpened Event

Subscribe to the LinkedResourceOpened event to be notified immediately after Revit has finished opening a linked resource.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<LinkedResourceOpenedEventArgs> LinkedResourceOpened
Public Event LinkedResourceOpened As EventHandler(Of LinkedResourceOpenedEventArgs)
public:
 event EventHandler<LinkedResourceOpenedEventArgs^>^ LinkedResourceOpened {
    void add (EventHandler<LinkedResourceOpenedEventArgs^>^ value);
    void remove (EventHandler<LinkedResourceOpenedEventArgs^>^ value);
}
member LinkedResourceOpened : IEvent<EventHandler<LinkedResourceOpenedEventArgs>,
    LinkedResourceOpenedEventArgs>

Value

EventHandler LinkedResourceOpenedEventArgs
Remarks

This event is raised immediately after Revit has finished opening a linked resource. Only supports linked resources for following types : Revit; IFC; CAD(dwg, dxf, dgn, sat); Topography; It is raised even when a linked resource opening failed. The LinkedResourceOpened events would not raised if there are no update on linked CAD, IFC resources.

Check the 'Status' field in event's argument to see whether the action itself was successful or not.

Another LinkedResourceOpening event will be raised when Revit is just about to open a linked resource.

See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.LinkedResourceOpening Event

ApplicationLinkedResourceOpening Event

Subscribe to the LinkedResourceOpening event to be notified when Revit is just about to open a linked resource.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<LinkedResourceOpeningEventArgs> LinkedResourceOpening
Public Event LinkedResourceOpening As EventHandler(Of LinkedResourceOpeningEventArgs)
public:
 event EventHandler<LinkedResourceOpeningEventArgs^>^ LinkedResourceOpening {
    void add (EventHandler<LinkedResourceOpeningEventArgs^>^ value);
    void remove (EventHandler<LinkedResourceOpeningEventArgs^>^ value);
}
member LinkedResourceOpening : IEvent<EventHandler<LinkedResourceOpeningEventArgs>,
    LinkedResourceOpeningEventArgs>

Value

EventHandler LinkedResourceOpeningEventArgs
Remarks

This event is raised when Revit is just about to open a linked resource. Only supports linked resources for following types : Revit; IFC; CAD(dwg, dxf, dgn, sat); This event would not be raised if there are no update on linked CAD, IFC resources.

Event is not cancellable.

The linked resource cannot be modified, for it is not opened yet at the time of the event.

Another LinkedResourceOpened event will be raised immediately after linked resource is opened.

See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.ProgressChanged Event

ApplicationProgressChanged Event

Subscribe to the ProgressChanged event to be notified when an operation in Revit has progress bar data available.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<ProgressChangedEventArgs> ProgressChanged
Public Event ProgressChanged As EventHandler(Of ProgressChangedEventArgs)
public:
 event EventHandler<ProgressChangedEventArgs^>^ ProgressChanged {
    void add (EventHandler<ProgressChangedEventArgs^>^ value);
    void remove (EventHandler<ProgressChangedEventArgs^>^ value);
}
member ProgressChanged : IEvent<EventHandler<ProgressChangedEventArgs>,
    ProgressChangedEventArgs>

Value

EventHandler ProgressChangedEventArgs
Remarks

Handlers of this event may use the Cancel method to cancel the operation tracked by the progress bar. Users may not change the document in the handler for this event. Exception ModificationForbiddenException will be thrown if any document-modifying method is called during this event's handler.

See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.ViewExported Event

ApplicationViewExported Event

Subscribe to the ViewExported event to be notified immediately after Revit has finished exporting a view of the document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<ViewExportedEventArgs> ViewExported
Public Event ViewExported As EventHandler(Of ViewExportedEventArgs)
public:
 event EventHandler<ViewExportedEventArgs^>^ ViewExported {
    void add (EventHandler<ViewExportedEventArgs^>^ value);
    void remove (EventHandler<ViewExportedEventArgs^>^ value);
}
member ViewExported : IEvent<EventHandler<ViewExportedEventArgs>,
    ViewExportedEventArgs>

Value

EventHandler ViewExportedEventArgs
Remarks

This event is raised immediately after Revit has finished exporting a view of the document. It is raised only during accelerated export jobs, in which views are exported in parallel using a background process. Accelerated export only occurs when exporting to DWF formats and not combining views into a single file.

It is raised even when view exporting failed.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event's argument to see whether the action was successful or not.

This event is not cancellable, for the process of view exporting has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.ViewExporting Event

ApplicationViewExporting Event

Subscribe to the ViewExporting event to be notified when Revit is just about to export a view of the document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<ViewExportingEventArgs> ViewExporting
Public Event ViewExporting As EventHandler(Of ViewExportingEventArgs)
public:
 event EventHandler<ViewExportingEventArgs^>^ ViewExporting {
    void add (EventHandler<ViewExportingEventArgs^>^ value);
    void remove (EventHandler<ViewExportingEventArgs^>^ value);
}
member ViewExporting : IEvent<EventHandler<ViewExportingEventArgs>,
    ViewExportingEventArgs>

Value

EventHandler ViewExportingEventArgs
Remarks

This event is raised when Revit is just about to export a view of the document. It is raised only during accelerated export jobs, in which views are exported in parallel using a background process. Accelerated export only occurs when exporting to DWF formats and not combining views into a single file.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is not cancellable. The 'Cancellable' property of event's argument is always False.

The following API functions are not available for the current document during this event:

  • All overloads of Autodesk.Revit.DB.Document.Export()
  • Autodesk.Revit.DB.Document.Print()
  • Print and similar overloads.
  • SubmitPrint and similar overloads.
  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.
  • [!:Autodesk::Revit::DB::Document::Save()] .
  • [!:Autodesk::Revit::DB::Document::SaveAs(String)] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event ViewExported will be raised immediately after view exporting is finished.

See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.ViewPrinted Event

ApplicationViewPrinted Event

Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<ViewPrintedEventArgs> ViewPrinted
Public Event ViewPrinted As EventHandler(Of ViewPrintedEventArgs)
public:
 event EventHandler<ViewPrintedEventArgs^>^ ViewPrinted {
    void add (EventHandler<ViewPrintedEventArgs^>^ value);
    void remove (EventHandler<ViewPrintedEventArgs^>^ value);
}
member ViewPrinted : IEvent<EventHandler<ViewPrintedEventArgs>,
    ViewPrintedEventArgs>

Value

EventHandler ViewPrintedEventArgs
Remarks

This event is raised immediately after Revit has finished printing a view of the document. If multiple views are combined to a single file, this event will be raised only once. It is raised even when view printing failed.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event's argument to see whether the action was successful or not.

This event is not cancellable, for the process of view printing has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Example
C#
VB
C++
F#
Copy
public class Application_ViewPrinted : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// Implement the OnStartup method to register events when Revit starts.
    /// </summary>
    public Result OnStartup(UIControlledApplication application)
    {
        // Register related events
        application.ControlledApplication.ViewPrinted += new EventHandler<Autodesk.Revit.DB.Events.ViewPrintedEventArgs>(AppViewPrinted);
        return Result.Succeeded;
    }

    /// <summary>
    /// Implement this method to unregister the subscribed events when Revit exits.
    /// </summary>
    public Result OnShutdown(UIControlledApplication application)
    {
        // unregister events
       application.ControlledApplication.ViewPrinted -= new EventHandler<Autodesk.Revit.DB.Events.ViewPrintedEventArgs>(AppViewPrinted);
        return Result.Succeeded;
    }
    /// <TrivialCode>
    /// Code ID: 501
    /// For ViewPrinted class description
    /// </TrivialCode>

    /// <summary>
    /// Handler method for ViewPrinting event, it will dump some event arguments.
    /// </summary>
    public void AppViewPrinted(object sender, Autodesk.Revit.DB.Events.ViewPrintedEventArgs args)
    {
        StringBuilder info = new StringBuilder();
        info.AppendLine("ViewPrintedEventArgs Parameters ------>");
        info.AppendLine("    Event Status        : " + args.Status);
        info.AppendLine("    TotalViews          : " + args.TotalViews);
        info.AppendLine("    View Index          : " + args.Index);
        info.AppendLine("    View Information    :");
        DumpViewInfo(args.View, "      ", ref info);

        TaskDialog.Show("Revit",info.ToString());
    }

    /// <summary>
    /// Dump information of single view: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="view">View element to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line added to message box string.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewInfo(Autodesk.Revit.DB.View view, String prefix, ref StringBuilder info)
    {
        info.AppendLine(String.Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}",
            prefix, view.Id.ToString(), view.Name, view.ViewType));
    }
    /// </ExampleMethod>
}
Public Class Application_ViewPrinted
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' Implement the OnStartup method to register events when Revit starts.
    ' </summary>
    Public Function OnStartup(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnStartup
        ' Register related events
        AddHandler application.ControlledApplication.ViewPrinted, AddressOf AppViewPrinted
        Return Result.Succeeded
    End Function

    ' <summary>
    ' Implement this method to unregister the subscribed events when Revit exits.
    ' </summary>
    Public Function OnShutdown(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnShutdown
        ' unregister events
        RemoveHandler application.ControlledApplication.ViewPrinted, AddressOf AppViewPrinted
        Return Result.Succeeded
    End Function
    ' <TrivialCode>
    ' Code ID: 501
    ' For ViewPrinted class description
    ' </TrivialCode>

    ' <summary>
    ' Handler method for ViewPrinting event, it will dump some event arguments.
    ' </summary>
    Public Sub AppViewPrinted(sender As Object, args As Autodesk.Revit.DB.Events.ViewPrintedEventArgs)
        Dim info As New StringBuilder()
        info.AppendLine("ViewPrintedEventArgs Parameters ------>")
        info.AppendLine("    Event Status        : " & Convert.ToString(args.Status))
        info.AppendLine("    TotalViews          : " & Convert.ToString(args.TotalViews))
        info.AppendLine("    View Index          : " & Convert.ToString(args.Index))
        info.AppendLine("    View Information    :")
        DumpViewInfo(args.View, "      ", info)

        TaskDialog.Show("Revit", info.ToString())
    End Sub

    ' <summary>
    ' Dump information of single view: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="view">View element to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line added to message box string.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewInfo(view As Autodesk.Revit.DB.View, prefix As [String], ByRef info As StringBuilder)
        info.AppendLine([String].Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}", prefix, view.Id.ToString(), view.Name, view.ViewType))
    End Sub
    ' </ExampleMethod>
End Class

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.ViewPrinting Event

ApplicationViewPrinting Event

Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<ViewPrintingEventArgs> ViewPrinting
Public Event ViewPrinting As EventHandler(Of ViewPrintingEventArgs)
public:
 event EventHandler<ViewPrintingEventArgs^>^ ViewPrinting {
    void add (EventHandler<ViewPrintingEventArgs^>^ value);
    void remove (EventHandler<ViewPrintingEventArgs^>^ value);
}
member ViewPrinting : IEvent<EventHandler<ViewPrintingEventArgs>,
    ViewPrintingEventArgs>

Value

EventHandler ViewPrintingEventArgs
Remarks

This event is raised when Revit is just about to print a view of the document. If multiple views are combined to a single file, this event will be raised only once.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is not cancellable. The 'Cancellable' property of event's argument is always False.

The following API functions are not available for the current document during this event:

  • All overloads of Autodesk.Revit.DB.Document.Export()
  • Autodesk.Revit.DB.Document.Print()
  • Print and similar overloads.
  • SubmitPrint and similar overloads.
  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.
  • [!:Autodesk::Revit::DB::Document::Save()] .
  • [!:Autodesk::Revit::DB::Document::SaveAs(String)] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event ViewPrinted will be raised immediately after view printing is finished.

Example
C#
VB
C++
F#
Copy
public class Application_ViewPrinting : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// Implement the OnStartup method to register events when Revit starts.
    /// </summary>
    public Result OnStartup(UIControlledApplication application)
    {
        // Register related events
       application.ControlledApplication.ViewPrinting += new EventHandler<Autodesk.Revit.DB.Events.ViewPrintingEventArgs>(AppViewPrinting);
        return Result.Succeeded;
    }

    /// <summary>
    /// Implement this method to unregister the subscribed events when Revit exits.
    /// </summary>
    public Result OnShutdown(UIControlledApplication application)
    {
        // unregister events
       application.ControlledApplication.ViewPrinting -= new EventHandler<Autodesk.Revit.DB.Events.ViewPrintingEventArgs>(AppViewPrinting);
        return Result.Succeeded;
    }
    /// <TrivialCode>
    /// Code ID: 501
    /// For ViewPrinting class description
    /// </TrivialCode>

    /// <summary>
    /// Handler method for ViewPrinting event, it will display some event arguments.
    /// </summary>
    public void AppViewPrinting(object sender, Autodesk.Revit.DB.Events.ViewPrintingEventArgs args)
    {
        StringBuilder info = new StringBuilder();
        info.AppendLine("ViewPrintingEventArgs Parameters ------>");
        info.AppendLine("    Event Cancellable   : " + args.Cancellable);
        info.AppendLine("    TotalViews          : " + args.TotalViews);
        info.AppendLine("    View Index          : " + args.Index);
        info.AppendLine("    View Information    :"); // View
        DumpViewInfo(args.View, "      ", ref info);

        TaskDialog.Show("Revit",info.ToString());
    }

    /// <summary>
    /// Dump information of single view: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="view">View element to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line added to message box string.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewInfo(Autodesk.Revit.DB.View view, String prefix, ref StringBuilder info)
    {
        info.AppendLine(String.Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}",
            prefix, view.Id.ToString(), view.Name, view.ViewType));
    }
    /// </ExampleMethod>
}
Public Class Application_ViewPrinting
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' Implement the OnStartup method to register events when Revit starts.
    ' </summary>
    Public Function OnStartup(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnStartup
        ' Register related events
        AddHandler application.ControlledApplication.ViewPrinting, AddressOf AppViewPrinting
        Return Result.Succeeded
    End Function

    ' <summary>
    ' Implement this method to unregister the subscribed events when Revit exits.
    ' </summary>
    Public Function OnShutdown(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnShutdown
        ' unregister events
        RemoveHandler application.ControlledApplication.ViewPrinting, AddressOf AppViewPrinting
        Return Result.Succeeded
    End Function
    ' <TrivialCode>
    ' Code ID: 501
    ' For ViewPrinting class description
    ' </TrivialCode>

    ' <summary>
    ' Handler method for ViewPrinting event, it will display some event arguments.
    ' </summary>
    Public Sub AppViewPrinting(sender As Object, args As Autodesk.Revit.DB.Events.ViewPrintingEventArgs)
        Dim info As New StringBuilder()
        info.AppendLine("ViewPrintingEventArgs Parameters ------>")
        info.AppendLine("    Event Cancellable   : " & Convert.ToString(args.Cancellable))
        info.AppendLine("    TotalViews          : " & Convert.ToString(args.TotalViews))
        info.AppendLine("    View Index          : " & Convert.ToString(args.Index))
        info.AppendLine("    View Information    :")
        ' View
        DumpViewInfo(args.View, "      ", info)

        TaskDialog.Show("Revit", info.ToString())
    End Sub

    ' <summary>
    ' Dump information of single view: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="view">View element to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line added to message box string.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewInfo(view As Autodesk.Revit.DB.View, prefix As [String], ByRef info As StringBuilder)
        info.AppendLine([String].Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}", prefix, view.Id.ToString(), view.Name, view.ViewType))
    End Sub
    ' </ExampleMethod>
End Class

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.ViewsExportedByContext Event

ApplicationViewsExportedByContext Event

Subscribe to the ViewsExportedByContext event to be notified immediately after Revit has finished exporting one or more views of the document via an export context by CustomExporter.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<ViewsExportedByContextEventArgs> ViewsExportedByContext
Public Event ViewsExportedByContext As EventHandler(Of ViewsExportedByContextEventArgs)
public:
 event EventHandler<ViewsExportedByContextEventArgs^>^ ViewsExportedByContext {
    void add (EventHandler<ViewsExportedByContextEventArgs^>^ value);
    void remove (EventHandler<ViewsExportedByContextEventArgs^>^ value);
}
member ViewsExportedByContext : IEvent<EventHandler<ViewsExportedByContextEventArgs>,
    ViewsExportedByContextEventArgs>

Value

EventHandler ViewsExportedByContextEventArgs
Remarks

This event is raised immediately after Revit has finished exporting views of the document via an export context by CustomExporter.

It is raised even when view exporting via export context by CustomExporter failed.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event's argument to see whether the action was successful or not.

This event is not cancellable, for the process of view exporting by CustomExporter has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.ViewsExportingByContext Event

ApplicationViewsExportingByContext Event

Subscribe to the ViewsExportingByContext event to be notified when Revit is just about to export one or more views of the document via an export context by CustomExporter.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<ViewsExportingByContextEventArgs> ViewsExportingByContext
Public Event ViewsExportingByContext As EventHandler(Of ViewsExportingByContextEventArgs)
public:
 event EventHandler<ViewsExportingByContextEventArgs^>^ ViewsExportingByContext {
    void add (EventHandler<ViewsExportingByContextEventArgs^>^ value);
    void remove (EventHandler<ViewsExportingByContextEventArgs^>^ value);
}
member ViewsExportingByContext : IEvent<EventHandler<ViewsExportingByContextEventArgs>,
    ViewsExportingByContextEventArgs>

Value

EventHandler ViewsExportingByContextEventArgs
Remarks

This event is raised when Revit is just about to export views of the document via an export context by CustomExporter.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is cancellable. To cancel it, call the 'Cancel()' method in event's argument to True.

The following API functions are not available for the current document during this event:

  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event ViewsExportedByContext will be raised immediately after view exporting by CustomExporter is finished.

See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application.WorksharedOperationProgressChanged Event

ApplicationWorksharedOperationProgressChanged Event

Subscribe to the WorksharedOperationProgressChanged to be notified when progress has changed during Collaboration for Revit's workshared operations: open model and synchronize with central.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<WorksharedOperationProgressChangedEventArgs> WorksharedOperationProgressChanged
Public Event WorksharedOperationProgressChanged As EventHandler(Of WorksharedOperationProgressChangedEventArgs)
public:
 event EventHandler<WorksharedOperationProgressChangedEventArgs^>^ WorksharedOperationProgressChanged {
    void add (EventHandler<WorksharedOperationProgressChangedEventArgs^>^ value);
    void remove (EventHandler<WorksharedOperationProgressChangedEventArgs^>^ value);
}
member WorksharedOperationProgressChanged : IEvent<EventHandler<WorksharedOperationProgressChangedEventArgs>,
    WorksharedOperationProgressChangedEventArgs>

Value

EventHandler WorksharedOperationProgressChangedEventArgs
Remarks

This event is only supported for Collaboration for Revit and will not be raised for those operations occurring in local-worksharing and Revit Server workflow. Users may not change the document in the handler for this event. It is NOT recommended to do any time-consuming work when handling WorksharedOperationProgressChanged event. This can increase workshared operation time." Exception ModificationForbiddenException will be thrown if any document-modifying method is called during this event's handler.

See Also

Reference

Application Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication Class

Represents the Autodesk Revit Application with no access to documents. It provides options and other application wide data and settings for external applications OnStartup/OnShutdown.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.ApplicationServicesControlledApplication

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ControlledApplication
Public Class ControlledApplication
public ref class ControlledApplication
type ControlledApplication = class end

The ControlledApplication type exposes the following members.

Properties
 | Name | Description
Public property | ActiveAddInId | Retrieves the Id of the currently running external application.
Public property | AllUsersAddinsLocation | The folder location for .addin files for all users.
 | Cities | Returns a set of all the known city locations within Revit.
Public property | Create | Provides an object that can be used to create new instances of Autodesk Revit API objects.
Public property | CurrentUserAddinsLocation | The folder location for .addin files for the current user.
Public property | CurrentUsersAddinsDataFolderPath | Path to AddinsData folder for the current user.
Public property | CurrentUsersDataFolderPath | Path to data folder for the current user.
Public property | IsLateAddinLoading | Indicates whether this add-in is loaded on the fly or not. If it is loaded when is Revit starting up, it is false, otherwise it should be true.
Public property | Language | The language used in the current session of Revit.
Public property | Product | The product type for the current session of Revit.
Public property | RecordingJournalFilename | Retrieve the name of the journal file the Revit is currently recording to.
Public property | SharedParametersFilename | Contains the fully qualified path to a shared parameters file.
Public property | SubVersionNumber | The minor version number of Revit
Public property | VersionBuild | Returns the internal build number of the Autodesk Revit application.
Public property | VersionName | Returns the name of the Revit application.
Public property | VersionNumber | Return the primary version of the Revit application.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | GetFailureDefinitionRegistry | Returns the instance of FailureDefinitionRegistry.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
 | GetLibraryPaths | Returns path information identifying where Revit searches for content.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsJournalPlaying | Determines if the application is currently in journal playback mode.
Public method | OpenSharedParameterFile | Enables access to shared parameter groups and definitions that are maintained on disk.
 | RegisterFailuresProcessor | Replaces Revit's default user interface (if present) with alternative handling for all warnings and errors (including those not generated by your application) for the rest of the Revit session; if your application is not prepared to respond to all warnings and errors, consider use of IFailuresPreprocessor (in your opened Transaction) or the FailuresProcessing event instead of this interface.
Public method | SetLibraryPaths | Sets path information identifying where Revit searches for content.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | WriteJournalComment | Writes a comment to the Revit journal file.
Top
Events
 | Name | Description
Public event | ApplicationInitialized | Subscribe to this event to get notified after the Revit application has been initialized
Public event | DocumentChanged | Subscribe to the DocumentChanged event to be notified when Revit document has changed.
Public event | DocumentClosed | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
Public event | DocumentClosing | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
Public event | DocumentCreated | Subscribe to the DocumentCreated event to be notified immediately after Revit has finished creating a new document.
Public event | DocumentCreating | Subscribe to the DocumentCreating event to be notified when Revit is just about to create a new document.
 | DocumentOpened | Subscribe to the DocumentOpened event to be notified immediately after Revit has finished opening a document.
Public event | DocumentOpening | Subscribe to the DocumentOpening event to be notified when Revit is just about to open a document.
 | DocumentPrinted | Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.
 | DocumentPrinting | Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.
Public event | DocumentReloadedLatest | Subscribe to the DocumentReloadedLatestEventArgs event to be notified immediately after Revit has finished reloading a document with central model.
Public event | DocumentReloadingLatest | Subscribe to the DocumentReloadingLatestEventArgs event to be notified when Revit is just about to reload latest changes from a central model.
Public event | DocumentSaved | Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.
Public event | DocumentSavedAs | Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.
Public event | DocumentSaving | Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document.
 | DocumentSavingAs | Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.
Public event | DocumentSynchronizedWithCentral | Subscribe to the DocumentSynchronizedWithCentral event to be notified immediately after Revit has finished synchronizing a document with central model.
Public event | DocumentSynchronizingWithCentral | Subscribe to the DocumentSynchronizingWithCentral event to be notified when Revit is just about to synchronize a document with central model.
Public event | ElementTypeDuplicated | Subscribe to the ElementTypeDuplicated event to be notified immediately after Revit has finished duplicating an element type.
Public event | ElementTypeDuplicating | Subscribe to the ElementTypeDuplicating event to be notified when Revit is just about to duplicate an element type.
 | FailuresProcessing | Subscribe to the FailuresProcessing event to be notified when failures are being processed at the end of transaction.
Public event | FamilyLoadedIntoDocument | Subscribe to the FamilyLoadedInto event to be notified after Revit loaded a family into a document.
Public event | FamilyLoadingIntoDocument | Subscribe to the FamilyLoadingInto event to be notified when Revit is just about to load a family into a document.
Public event | FileExported | Subscribe to the FileExported event to be notified immediately after Revit has finished exporting files of formats supported by the API.
Public event | FileExporting | Subscribe to the FileExporting event to be notified when Revit is just about to export files of formats supported by the API.
Public event | FileImported | Subscribe to the FileImported event to be notified immediately after Revit has finished importing a file of format supported by the API.
Public event | FileImporting | Subscribe to the FileImporting event to be notified when Revit is just about to import a file of format supported by the API.
Public event | LinkedResourceOpened | Subscribe to the LinkedResourceOpened event to be notified immediately after Revit has finished opening a linked resource.
Public event | LinkedResourceOpening | Subscribe to the LinkedResourceOpening event to be notified when Revit is just about to open a linked resource.
Public event | ProgressChanged | Subscribe to the ProgressChanged event to be notified when an operation in Revit has progress bar data available.
 | ViewPrinted | Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.
 | ViewPrinting | Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.
Public event | WorksharedOperationProgressChanged | Subscribe to the WorksharedOperationProgressChanged to be notified when progress has changed during Collaboration for Revit's workshared operations: open model and synchronize with central.
Top
See Also

Reference

Autodesk.Revit.ApplicationServices Namespace


ControlledApplication Properties

The ControlledApplication type exposes the following members.

Properties
 | Name | Description
Public property | ActiveAddInId | Retrieves the Id of the currently running external application.
Public property | AllUsersAddinsLocation | The folder location for .addin files for all users.
 | Cities | Returns a set of all the known city locations within Revit.
Public property | Create | Provides an object that can be used to create new instances of Autodesk Revit API objects.
Public property | CurrentUserAddinsLocation | The folder location for .addin files for the current user.
Public property | CurrentUsersAddinsDataFolderPath | Path to AddinsData folder for the current user.
Public property | CurrentUsersDataFolderPath | Path to data folder for the current user.
Public property | IsLateAddinLoading | Indicates whether this add-in is loaded on the fly or not. If it is loaded when is Revit starting up, it is false, otherwise it should be true.
Public property | Language | The language used in the current session of Revit.
Public property | Product | The product type for the current session of Revit.
Public property | RecordingJournalFilename | Retrieve the name of the journal file the Revit is currently recording to.
Public property | SharedParametersFilename | Contains the fully qualified path to a shared parameters file.
Public property | SubVersionNumber | The minor version number of Revit
Public property | VersionBuild | Returns the internal build number of the Autodesk Revit application.
Public property | VersionName | Returns the name of the Revit application.
Public property | VersionNumber | Return the primary version of the Revit application.
Top
See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.ActiveAddInId Property

ControlledApplicationActiveAddInId Property

Retrieves the Id of the currently running external application.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AddInId ActiveAddInId { get; }
Public ReadOnly Property ActiveAddInId As AddInId
    Get
public:
property AddInId^ ActiveAddInId {
    AddInId^ get ();
}
member ActiveAddInId : AddInId with get

Property Value

AddInId
Remarks
The application can be either a UI application, DB application, or an external command. If no addin is active, this property will return . If an event handler is currently being executed, the returned value will be the Id of the application or command in which the event handler was registered.
See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.AllUsersAddinsLocation Property

ControlledApplicationAllUsersAddinsLocation Property

The folder location for .addin files for all users.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string AllUsersAddinsLocation { get; }
Public ReadOnly Property AllUsersAddinsLocation As String
    Get
public:
property String^ AllUsersAddinsLocation {
    String^ get ();
}
member AllUsersAddinsLocation : string with get

Property Value

String
See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.Cities Property

ControlledApplicationCities Property

Returns a set of all the known city locations within Revit.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CitySet Cities { get; }
Public ReadOnly Property Cities As CitySet
    Get
public:
property CitySet^ Cities {
    CitySet^ get ();
}
member Cities : CitySet with get

Property Value

CitySet
Remarks
Each city has information about longitude, latitude etc.
Example
C#
VB
C++
F#
Copy
// Get all Revit support cities
Autodesk.Revit.DB.CitySet cities = application.Cities;

// Set all Revit support cities into an ArrayList
System.Collections.ArrayList cityList = new System.Collections.ArrayList();
foreach (Autodesk.Revit.DB.City city in cities)
{
    cityList.Add(city);
}
' Get all Revit support cities
Dim cities As Autodesk.Revit.DB.CitySet = application.Cities

' Set all Revit support cities into an ArrayList
Dim cityList As New System.Collections.ArrayList()
For Each city As Autodesk.Revit.DB.City In cities
    cityList.Add(city)
Next

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.Create Property

ControlledApplicationCreate Property

Provides an object that can be used to create new instances of Autodesk Revit API objects.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Application Create { get; }
Public ReadOnly Property Create As Application
    Get
public:
property Application^ Create {
    Application^ get ();
}
member Create : Application with get

Property Value

Application
Remarks
The Create property returns an object that is used to create application wide utility and geometric objects within the Autodesk Revit API, such as arrays, sets, lines. This object should be used when you wish to create an object within the Autodesk Revit application memory, rather than your own application's memory. If you are performing your own memory management techniques then it is advisable to create any utility objects via the Create object. For example: Instead of Dim set As New Autodesk_Revit_ElementSet do Set set = application.Create.NewElementSet()
See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.CurrentUserAddinsLocation Property

ControlledApplicationCurrentUserAddinsLocation Property

The folder location for .addin files for the current user.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string CurrentUserAddinsLocation { get; }
Public ReadOnly Property CurrentUserAddinsLocation As String
    Get
public:
property String^ CurrentUserAddinsLocation {
    String^ get ();
}
member CurrentUserAddinsLocation : string with get

Property Value

String
See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.CurrentUsersAddinsDataFolderPath Property

ControlledApplicationCurrentUsersAddinsDataFolderPath Property

Path to AddinsData folder for the current user.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string CurrentUsersAddinsDataFolderPath { get; }
Public ReadOnly Property CurrentUsersAddinsDataFolderPath As String
    Get
public:
property String^ CurrentUsersAddinsDataFolderPath {
    String^ get ();
}
member CurrentUsersAddinsDataFolderPath : string with get

Property Value

String
Remarks
Similar to C:\Users\[UserName]\AppData\Roaming\Autodesk\[ProductType]\[ReleaseName]\AddinsData
See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.CurrentUsersDataFolderPath Property

ControlledApplicationCurrentUsersDataFolderPath Property

Path to data folder for the current user.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string CurrentUsersDataFolderPath { get; }
Public ReadOnly Property CurrentUsersDataFolderPath As String
    Get
public:
property String^ CurrentUsersDataFolderPath {
    String^ get ();
}
member CurrentUsersDataFolderPath : string with get

Property Value

String
Remarks
Similar to C:\Users\[UserName]\AppData\Roaming\Autodesk\[ProductType]\[ReleaseName]
See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.IsLateAddinLoading Property

ControlledApplicationIsLateAddinLoading Property

Indicates whether this add-in is loaded on the fly or not. If it is loaded when is Revit starting up, it is false, otherwise it should be true.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsLateAddinLoading { get; }
Public ReadOnly Property IsLateAddinLoading As Boolean
    Get
public:
property bool IsLateAddinLoading {
    bool get ();
}
member IsLateAddinLoading : bool with get

Property Value

Boolean
See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.Language Property

ControlledApplicationLanguage Property

The language used in the current session of Revit.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LanguageType Language { get; }
Public ReadOnly Property Language As LanguageType
    Get
public:
property LanguageType Language {
    LanguageType get ();
}
member Language : LanguageType with get

Property Value

LanguageType
Remarks
Use this property to determine the language used by Revit; this can allow your application to load the appropriate resources.
See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.Product Property

ControlledApplicationProduct Property

The product type for the current session of Revit.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ProductType Product { get; }
Public ReadOnly Property Product As ProductType
    Get
public:
property ProductType Product {
    ProductType get ();
}
member Product : ProductType with get

Property Value

ProductType
See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.RecordingJournalFilename Property

ControlledApplicationRecordingJournalFilename Property

Retrieve the name of the journal file the Revit is currently recording to.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string RecordingJournalFilename { get; }
Public ReadOnly Property RecordingJournalFilename As String
    Get
public:
property String^ RecordingJournalFilename {
    String^ get ();
}
member RecordingJournalFilename : string with get

Property Value

String
Remarks
As Revit operates it keeps a log of operations that the user performs within a file, known as a journal file. These files provide information about the actions performed in a session and the state of Revit when a problem occurs. These files are included during error reporting to Autodesk.
See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.SharedParametersFilename Property

ControlledApplicationSharedParametersFilename Property

Contains the fully qualified path to a shared parameters file.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SharedParametersFilename { get; set; }
Public Property SharedParametersFilename As String
    Get
    Set
public:
property String^ SharedParametersFilename {
    String^ get ();
    void set (String^ value);
}
member SharedParametersFilename : string with get, set

Property Value

String
Remarks
This path can be read and set via this property. By default Autodesk Revit does not have a shared parameters file so this property must be set before access is made to the shared parameters file object otherwise an exception will be thrown.
See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.SubVersionNumber Property

ControlledApplicationSubVersionNumber Property

The minor version number of Revit

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SubVersionNumber { get; }
Public ReadOnly Property SubVersionNumber As String
    Get
public:
property String^ SubVersionNumber {
    String^ get ();
}
member SubVersionNumber : string with get

Property Value

String
Remarks
SubVersionNumber of Revit may have additional APIs and functionality not available in the standard customer releases. Add-ins written to support standard Revit releases should be compatible with SubVersionNumber releases, but add-ins written specifically targeting new features in SubVersionNumber releases would not be compatible with the standard releases.
See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.VersionBuild Property

ControlledApplicationVersionBuild Property

Returns the internal build number of the Autodesk Revit application.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string VersionBuild { get; }
Public ReadOnly Property VersionBuild As String
    Get
public:
property String^ VersionBuild {
    String^ get ();
}
member VersionBuild : string with get

Property Value

String
Remarks
This property can be used by your application to find the version of Autodesk Revit against which your application is running. Based on this information your application can report if it is able to work correctly with that version of Autodesk Revit.
See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.VersionName Property

ControlledApplicationVersionName Property

Returns the name of the Revit application.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string VersionName { get; }
Public ReadOnly Property VersionName As String
    Get
public:
property String^ VersionName {
    String^ get ();
}
member VersionName : string with get

Property Value

String
Remarks
This property can be used by your application to find the version of Revit against which your application is running. Based on this information your application can report if it is able to work correctly with that version of Revit.
See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.VersionNumber Property

ControlledApplicationVersionNumber Property

Return the primary version of the Revit application.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string VersionNumber { get; }
Public ReadOnly Property VersionNumber As String
    Get
public:
property String^ VersionNumber {
    String^ get ();
}
member VersionNumber : string with get

Property Value

String
Remarks
This property can be used by your application to find the version of Revit against which your application is running. Based on this information your application can report if it is able to work correctly with that version of Revit.
See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication Methods

The ControlledApplication type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | GetFailureDefinitionRegistry | Returns the instance of FailureDefinitionRegistry.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
 | GetLibraryPaths | Returns path information identifying where Revit searches for content.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsJournalPlaying | Determines if the application is currently in journal playback mode.
Public method | OpenSharedParameterFile | Enables access to shared parameter groups and definitions that are maintained on disk.
 | RegisterFailuresProcessor | Replaces Revit's default user interface (if present) with alternative handling for all warnings and errors (including those not generated by your application) for the rest of the Revit session; if your application is not prepared to respond to all warnings and errors, consider use of IFailuresPreprocessor (in your opened Transaction) or the FailuresProcessing event instead of this interface.
Public method | SetLibraryPaths | Sets path information identifying where Revit searches for content.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | WriteJournalComment | Writes a comment to the Revit journal file.
Top
See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.GetFailureDefinitionRegistry Method

ControlledApplicationGetFailureDefinitionRegistry Method

Returns the instance of FailureDefinitionRegistry.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionRegistry GetFailureDefinitionRegistry()
Public Shared Function GetFailureDefinitionRegistry As FailureDefinitionRegistry
public:
static FailureDefinitionRegistry^ GetFailureDefinitionRegistry()
static member GetFailureDefinitionRegistry : unit -> FailureDefinitionRegistry

Return Value

FailureDefinitionRegistry
The instance of FailureDefinitionRegistry.
See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.GetLibraryPaths Method

ControlledApplicationGetLibraryPaths Method

Returns path information identifying where Revit searches for content.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IDictionary<string, string> GetLibraryPaths()
Public Function GetLibraryPaths As IDictionary(Of String, String)
public:
IDictionary<String^, String^>^ GetLibraryPaths()
member GetLibraryPaths : unit -> IDictionary<string, string>

Return Value

IDictionary String, String
The map of library paths.
Remarks
The map that is returned contains a key that is purpose of the path, such as Material Libraries and the value in the map is the fully qualified path that is used for that search path.
Example
C#
VB
C++
F#
Copy
string strLibPaths = "";
foreach (String path in application.GetLibraryPaths().Values)
{
    strLibPaths += path + "\n";
}
Dim strLibPaths As String = ""
For Each path As [String] In application.GetLibraryPaths().Values
    strLibPaths += path & vbLf
Next

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.IsJournalPlaying Method

ControlledApplicationIsJournalPlaying Method

Determines if the application is currently in journal playback mode.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsJournalPlaying()
Public Function IsJournalPlaying As Boolean
public:
bool IsJournalPlaying()
member IsJournalPlaying : unit -> bool

Return Value

Boolean
true if a journal is currently playing back, false otherwise.
Remarks
Determines if Revit is in the process of playing back a journal. It can be used to help prevent any user interaction that may cause issues during playback. For more information on Revit's journaling features contact the Autodesk Developer Network.
See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.OpenSharedParameterFile Method

ControlledApplicationOpenSharedParameterFile Method

Enables access to shared parameter groups and definitions that are maintained on disk.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DefinitionFile OpenSharedParameterFile()
Public Function OpenSharedParameterFile As DefinitionFile
public:
DefinitionFile^ OpenSharedParameterFile()
member OpenSharedParameterFile : unit -> DefinitionFile

Return Value

DefinitionFile
An object that represents a shared parameters file that exists on disk. Returns if the file does not exist.
Remarks
This function is used to return an object that represents a Revit shared parameters file Revit can use only one shared parameters file at one time. The filename for the shared parameters file can be set in the Application.SharedParametersFilename property.
See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.RegisterFailuresProcessor Method

ControlledApplicationRegisterFailuresProcessor Method

Replaces Revit's default user interface (if present) with alternative handling for all warnings and errors (including those not generated by your application) for the rest of the Revit session; if your application is not prepared to respond to all warnings and errors, consider use of IFailuresPreprocessor (in your opened Transaction) or the FailuresProcessing event instead of this interface.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void RegisterFailuresProcessor(
    IFailuresProcessor processor
)
Public Shared Sub RegisterFailuresProcessor (
    processor As IFailuresProcessor
)
public:
static void RegisterFailuresProcessor(
    IFailuresProcessor^ processor
)
static member RegisterFailuresProcessor :
        processor : IFailuresProcessor -> unit

Parameters

processor IFailuresProcessor
Instance of Failures Processor to be used by the Revit Application.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
If there is previously registered Failures Processor, it gets discarded. If you opt to register a FailuresProcessor for Revit, your processor will become the default error handler for all Revit errors for the session. The standard Revit error dialog will not appear.
See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.SetLibraryPaths Method

ControlledApplicationSetLibraryPaths Method

Sets path information identifying where Revit searches for content.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetLibraryPaths(
    IDictionary<string, string> paths
)
Public Sub SetLibraryPaths (
    paths As IDictionary(Of String, String)
)
public:
void SetLibraryPaths(
    IDictionary<String^, String^>^ paths
)
member SetLibraryPaths :
        paths : IDictionary<string, string> -> unit

Parameters

paths IDictionary String, String
The map of library paths.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
The map that is returned should contain a key that is purpose of the path, such as Material Libraries and the value in the map is the fully qualified path to be used for that search path.
See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.WriteJournalComment Method

ControlledApplicationWriteJournalComment Method

Writes a comment to the Revit journal file.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void WriteJournalComment(
    string comment,
    bool timeStamp
)
Public Sub WriteJournalComment (
    comment As String,
    timeStamp As Boolean
)
public:
void WriteJournalComment(
    String^ comment,
    bool timeStamp
)
member WriteJournalComment :
        comment : string *
        timeStamp : bool -> unit

Parameters

comment String
Text for journal comment.
timeStamp Boolean
If a time stamp should be included in the journal comment.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication Events

The ControlledApplication type exposes the following members.

Events
 | Name | Description
Public event | ApplicationInitialized | Subscribe to this event to get notified after the Revit application has been initialized
Public event | DocumentChanged | Subscribe to the DocumentChanged event to be notified when Revit document has changed.
Public event | DocumentClosed | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
Public event | DocumentClosing | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
Public event | DocumentCreated | Subscribe to the DocumentCreated event to be notified immediately after Revit has finished creating a new document.
Public event | DocumentCreating | Subscribe to the DocumentCreating event to be notified when Revit is just about to create a new document.
 | DocumentOpened | Subscribe to the DocumentOpened event to be notified immediately after Revit has finished opening a document.
Public event | DocumentOpening | Subscribe to the DocumentOpening event to be notified when Revit is just about to open a document.
 | DocumentPrinted | Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.
 | DocumentPrinting | Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.
Public event | DocumentReloadedLatest | Subscribe to the DocumentReloadedLatestEventArgs event to be notified immediately after Revit has finished reloading a document with central model.
Public event | DocumentReloadingLatest | Subscribe to the DocumentReloadingLatestEventArgs event to be notified when Revit is just about to reload latest changes from a central model.
Public event | DocumentSaved | Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.
Public event | DocumentSavedAs | Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.
Public event | DocumentSaving | Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document.
 | DocumentSavingAs | Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.
Public event | DocumentSynchronizedWithCentral | Subscribe to the DocumentSynchronizedWithCentral event to be notified immediately after Revit has finished synchronizing a document with central model.
Public event | DocumentSynchronizingWithCentral | Subscribe to the DocumentSynchronizingWithCentral event to be notified when Revit is just about to synchronize a document with central model.
Public event | ElementTypeDuplicated | Subscribe to the ElementTypeDuplicated event to be notified immediately after Revit has finished duplicating an element type.
Public event | ElementTypeDuplicating | Subscribe to the ElementTypeDuplicating event to be notified when Revit is just about to duplicate an element type.
 | FailuresProcessing | Subscribe to the FailuresProcessing event to be notified when failures are being processed at the end of transaction.
Public event | FamilyLoadedIntoDocument | Subscribe to the FamilyLoadedInto event to be notified after Revit loaded a family into a document.
Public event | FamilyLoadingIntoDocument | Subscribe to the FamilyLoadingInto event to be notified when Revit is just about to load a family into a document.
Public event | FileExported | Subscribe to the FileExported event to be notified immediately after Revit has finished exporting files of formats supported by the API.
Public event | FileExporting | Subscribe to the FileExporting event to be notified when Revit is just about to export files of formats supported by the API.
Public event | FileImported | Subscribe to the FileImported event to be notified immediately after Revit has finished importing a file of format supported by the API.
Public event | FileImporting | Subscribe to the FileImporting event to be notified when Revit is just about to import a file of format supported by the API.
Public event | LinkedResourceOpened | Subscribe to the LinkedResourceOpened event to be notified immediately after Revit has finished opening a linked resource.
Public event | LinkedResourceOpening | Subscribe to the LinkedResourceOpening event to be notified when Revit is just about to open a linked resource.
Public event | ProgressChanged | Subscribe to the ProgressChanged event to be notified when an operation in Revit has progress bar data available.
 | ViewPrinted | Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.
 | ViewPrinting | Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.
Public event | WorksharedOperationProgressChanged | Subscribe to the WorksharedOperationProgressChanged to be notified when progress has changed during Collaboration for Revit's workshared operations: open model and synchronize with central.
Top
See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.ApplicationInitialized Event

ControlledApplicationApplicationInitialized Event

Subscribe to this event to get notified after the Revit application has been initialized

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<ApplicationInitializedEventArgs> ApplicationInitialized
Public Event ApplicationInitialized As EventHandler(Of ApplicationInitializedEventArgs)
public:
 event EventHandler<ApplicationInitializedEventArgs^>^ ApplicationInitialized {
    void add (EventHandler<ApplicationInitializedEventArgs^>^ value);
    void remove (EventHandler<ApplicationInitializedEventArgs^>^ value);
}
member ApplicationInitialized : IEvent<EventHandler<ApplicationInitializedEventArgs>,
    ApplicationInitializedEventArgs>

Value

EventHandler ApplicationInitializedEventArgs
Remarks
The event is raised after Revit was launched as fully initialized, including initialization of external applications.
See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.DocumentChanged Event

ControlledApplicationDocumentChanged Event

Subscribe to the DocumentChanged event to be notified when Revit document has changed.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DocumentChangedEventArgs> DocumentChanged
Public Event DocumentChanged As EventHandler(Of DocumentChangedEventArgs)
public:
 event EventHandler<DocumentChangedEventArgs^>^ DocumentChanged {
    void add (EventHandler<DocumentChangedEventArgs^>^ value);
    void remove (EventHandler<DocumentChangedEventArgs^>^ value);
}
member DocumentChanged : IEvent<EventHandler<DocumentChangedEventArgs>,
    DocumentChangedEventArgs>

Value

EventHandler DocumentChangedEventArgs
Remarks
This event is raised whenever a Revit transaction is either committed, undone or redone. This is a readonly event, designed to allow you to keep external data in synch with the state of the Revit database. To update the Revit database in response to changes in elements, use the IUpdater framework.
See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.DocumentClosed Event

ControlledApplicationDocumentClosed Event

Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DocumentClosedEventArgs> DocumentClosed
Public Event DocumentClosed As EventHandler(Of DocumentClosedEventArgs)
public:
 event EventHandler<DocumentClosedEventArgs^>^ DocumentClosed {
    void add (EventHandler<DocumentClosedEventArgs^>^ value);
    void remove (EventHandler<DocumentClosedEventArgs^>^ value);
}
member DocumentClosed : IEvent<EventHandler<DocumentClosedEventArgs>,
    DocumentClosedEventArgs>

Value

EventHandler DocumentClosedEventArgs
Remarks

This event is raised immediately after Revit has finished closing a document. It is raised even when document closing failed or was cancelled (during DocumentClosing event).

This event is not cancellable, for the process of closing document has already been finished.

The document cannot be modified because the corresponding object does not exist anymore.

See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.DocumentClosing Event

ControlledApplicationDocumentClosing Event

Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DocumentClosingEventArgs> DocumentClosing
Public Event DocumentClosing As EventHandler(Of DocumentClosingEventArgs)
public:
 event EventHandler<DocumentClosingEventArgs^>^ DocumentClosing {
    void add (EventHandler<DocumentClosingEventArgs^>^ value);
    void remove (EventHandler<DocumentClosingEventArgs^>^ value);
}
member DocumentClosing : IEvent<EventHandler<DocumentClosingEventArgs>,
    DocumentClosingEventArgs>

Value

EventHandler DocumentClosingEventArgs
Remarks

This event is raised when Revit is just about to close a document.

This event is cancellable, except when it is raised as part of application closing. Check the 'Cancellable' property of event's argument to see whether it is cancellable or not. When it is cancellable, call the 'Cancel()' method of event's argument to True to cancel it. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document may not be modified during this event.

The following API functions are not available for the current document during this event:

  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

An DocumentClosed event will be raised immediately after document is closed.

See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.DocumentCreated Event

ControlledApplicationDocumentCreated Event

Subscribe to the DocumentCreated event to be notified immediately after Revit has finished creating a new document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DocumentCreatedEventArgs> DocumentCreated
Public Event DocumentCreated As EventHandler(Of DocumentCreatedEventArgs)
public:
 event EventHandler<DocumentCreatedEventArgs^>^ DocumentCreated {
    void add (EventHandler<DocumentCreatedEventArgs^>^ value);
    void remove (EventHandler<DocumentCreatedEventArgs^>^ value);
}
member DocumentCreated : IEvent<EventHandler<DocumentCreatedEventArgs>,
    DocumentCreatedEventArgs>

Value

EventHandler DocumentCreatedEventArgs
Remarks

This event is raised immediately after Revit has finished creating a new document. It is raised even when document creation failed or was cancelled (during DocumentCreating event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event's argument to see whether the action itself was successful or not. This event is not cancellable, for the process of document creation has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.DocumentCreating Event

ControlledApplicationDocumentCreating Event

Subscribe to the DocumentCreating event to be notified when Revit is just about to create a new document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DocumentCreatingEventArgs> DocumentCreating
Public Event DocumentCreating As EventHandler(Of DocumentCreatingEventArgs)
public:
 event EventHandler<DocumentCreatingEventArgs^>^ DocumentCreating {
    void add (EventHandler<DocumentCreatingEventArgs^>^ value);
    void remove (EventHandler<DocumentCreatingEventArgs^>^ value);
}
member DocumentCreating : IEvent<EventHandler<DocumentCreatingEventArgs>,
    DocumentCreatingEventArgs>

Value

EventHandler DocumentCreatingEventArgs
Remarks

This event is raised when Revit is just about to create a new document.

Event is cancellable. To cancel it, call the 'Cancel()' method of event's argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document cannot be modified, for it is not created yet at the time of the event.

The following API functions are not available for the current document during this event:

  • [!:Autodesk::Revit::ApplicationServices::Application::NewProjectDocument()]
  • NewFamilyDocument(String)
  • NewProjectTemplateDocument(String)
  • OpenDocumentFile(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another DocumentCreated event will be raised immediately after document creation is finished.

See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.DocumentOpened Event

ControlledApplicationDocumentOpened Event

Subscribe to the DocumentOpened event to be notified immediately after Revit has finished opening a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DocumentOpenedEventArgs> DocumentOpened
Public Event DocumentOpened As EventHandler(Of DocumentOpenedEventArgs)
public:
 event EventHandler<DocumentOpenedEventArgs^>^ DocumentOpened {
    void add (EventHandler<DocumentOpenedEventArgs^>^ value);
    void remove (EventHandler<DocumentOpenedEventArgs^>^ value);
}
member DocumentOpened : IEvent<EventHandler<DocumentOpenedEventArgs>,
    DocumentOpenedEventArgs>

Value

EventHandler DocumentOpenedEventArgs
Remarks

This event is raised immediately after Revit has finished opening a document. It is raised even when document opening failed or was cancelled (during DocumentOpening event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event's argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of opening document has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Example
C#
VB
C++
F#
Copy
public class Application_DocumentOpened : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// Implement this method to subscribe to event.
    /// </summary>
    public Result OnStartup(UIControlledApplication application)
    {
        try
        {
            // Register event.
           application.ControlledApplication.DocumentOpened += new EventHandler
                <Autodesk.Revit.DB.Events.DocumentOpenedEventArgs>(application_DocumentOpened);
        }
        catch (Exception)
        {
            return Result.Failed;
        }

        return Result.Succeeded;
    }

    /// <summary>
    /// Implement OnShutdown method of IExternalApplication interface to unregister subscribed event
    /// </summary>
    public Result OnShutdown(UIControlledApplication application)
    {
        // remove the event.
       application.ControlledApplication.DocumentOpened -= application_DocumentOpened;
        return Result.Succeeded;
    }

    /// <TrivialCode>
    /// Code ID: 501
    /// For DocumentOpened class description
    /// </TrivialCode>

    /// <description>
    /// This sample demonstrates how to subscribe to the DocumentOpened event and modify the model in the event handler method.
    /// </description>
    /// <summary>
    /// This is the event handler. We modify the model.
    /// </summary>
    /// <param name="sender">Event sender.</param>
    /// <param name="args"></param>
    public void application_DocumentOpened(object sender, DocumentOpenedEventArgs args)
    {
        // get document from event args.
        Document doc = args.Document;

        // Following code snippet demonstrates support of DocumentOpened event to modify the model.
        // Because DocumentOpened supports model changes, it allows user to update document data.
        // Here, this sample assigns a specified value to ProjectInformation.Address property.
        // User can change other properties of document or create(delete) something as he likes.
        //
        // Please note that ProjectInformation property is empty for family document.
        // So please don't run this sample on family document.
        using (Transaction transaction = new Transaction(doc, "Edit Address"))
        {
           if (transaction.Start() == TransactionStatus.Started)
           {
              doc.ProjectInformation.Address =
                  "United States - Massachusetts - Waltham - 1560 Trapelo Road";
              transaction.Commit();
           }
        }
    }

    /// </ExampleMethod>
}
Public Class Application_DocumentOpened
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' Implement this method to subscribe to event.
    ' </summary>
    Public Function OnStartup(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnStartup
        Try
            ' Register event.
            AddHandler application.ControlledApplication.DocumentOpened, AddressOf application_DocumentOpened
        Catch generatedExceptionName As Exception
            Return Result.Failed
        End Try

        Return Result.Succeeded
    End Function

    ' <summary>
    ' Implement OnShutdown method of IExternalApplication interface to unregister subscribed event
    ' </summary>
    Public Function OnShutdown(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnShutdown
        ' remove the event.
        RemoveHandler application.ControlledApplication.DocumentOpened, AddressOf application_DocumentOpened
        Return Result.Succeeded
    End Function

    ' <TrivialCode>
    ' Code ID: 501
    ' For DocumentOpened class description
    ' </TrivialCode>

    ' <description>
    ' This sample demonstrates how to subscribe to the DocumentOpened event and modify the model in the event handler method.
    ' </description>
    ' <summary>
    ' This is the event handler. We modify the model.
    ' </summary>
    ' <param name="sender">Event sender.</param>
    ' <param name="args"></param>
    Public Sub application_DocumentOpened(sender As Object, args As DocumentOpenedEventArgs)
        ' get document from event args.
        Dim doc As Document = args.Document

        ' Following code snippet demonstrates support of DocumentOpened event to modify the model.
        ' Because DocumentOpened supports model changes, it allows user to update document data.
        ' Here, this sample assigns a specified value to ProjectInformation.Address property.
        ' User can change other properties of document or create(delete) something as he likes.
        '
        ' Please note that ProjectInformation property is empty for family document.
        ' So please don't run this sample on family document.
        Using transaction As New Transaction(doc, "Edit Address")
            If transaction.Start() = TransactionStatus.Started Then
                doc.ProjectInformation.Address = "United States - Massachusetts - Waltham - 1560 Trapelo Road"
                transaction.Commit()
            End If
        End Using
    End Sub

    ' </ExampleMethod>
End Class

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.DocumentOpening Event

ControlledApplicationDocumentOpening Event

Subscribe to the DocumentOpening event to be notified when Revit is just about to open a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DocumentOpeningEventArgs> DocumentOpening
Public Event DocumentOpening As EventHandler(Of DocumentOpeningEventArgs)
public:
 event EventHandler<DocumentOpeningEventArgs^>^ DocumentOpening {
    void add (EventHandler<DocumentOpeningEventArgs^>^ value);
    void remove (EventHandler<DocumentOpeningEventArgs^>^ value);
}
member DocumentOpening : IEvent<EventHandler<DocumentOpeningEventArgs>,
    DocumentOpeningEventArgs>

Value

EventHandler DocumentOpeningEventArgs
Remarks

This event is raised when Revit is just about to open a document.

Event is cancellable. To cancel it, call the 'Cancel()' method in event's argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document cannot be modified, for it is not opened yet at the time of the event.

Another DocumentOpened event will be raised immediately after document is opened.

See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.DocumentPrinted Event

ControlledApplicationDocumentPrinted Event

Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DocumentPrintedEventArgs> DocumentPrinted
Public Event DocumentPrinted As EventHandler(Of DocumentPrintedEventArgs)
public:
 event EventHandler<DocumentPrintedEventArgs^>^ DocumentPrinted {
    void add (EventHandler<DocumentPrintedEventArgs^>^ value);
    void remove (EventHandler<DocumentPrintedEventArgs^>^ value);
}
member DocumentPrinted : IEvent<EventHandler<DocumentPrintedEventArgs>,
    DocumentPrintedEventArgs>

Value

EventHandler DocumentPrintedEventArgs
Remarks

This event is raised immediately after Revit has finished printing a view or ViewSet of the document. It is raised even when document printing failed or was cancelled (during DocumentPriting event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event's argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of printing has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Example
C#
VB
C++
F#
Copy
public class Application_DocumentPrinted : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// Implement the OnStartup method to register events when Revit starts.
    /// </summary>
    public Result OnStartup(UIControlledApplication application)
    {
        // Register related events
       application.ControlledApplication.DocumentPrinted += new EventHandler<Autodesk.Revit.DB.Events.DocumentPrintedEventArgs>(AppDocumentPrinted);
        return Result.Succeeded;
    }

    /// <summary>
    /// Implement this method to unregister the subscribed events when Revit exits.
    /// </summary>
    public Result OnShutdown(UIControlledApplication application)
    {
        // unregister events
       application.ControlledApplication.DocumentPrinted -= new EventHandler<Autodesk.Revit.DB.Events.DocumentPrintedEventArgs>(AppDocumentPrinted);
        return Result.Succeeded;
    }
    /// <TrivialCode>
    /// Code ID: 501
    /// For DocumentPrinted class description
    /// </TrivialCode>

    /// <summary>
    /// Handler method for DocumentPrinted event, it will display some event arguments.
    /// </summary>
    public void AppDocumentPrinted(object sender, Autodesk.Revit.DB.Events.DocumentPrintedEventArgs args)
    {
        StringBuilder info = new StringBuilder();
        Application app = sender as Application;
        info.AppendLine("DocumentPrintedEventArgs Parameters ------>");
        info.AppendLine("    Event Status      : " + args.Status.ToString());
        info.AppendLine("    Event Cancellable : " + args.Cancellable);
        //
        // PrintedViews
        if (0 == args.GetFailedViewElementIds().Count || 0 == args.GetPrintedViewElementIds().Count)
        {
            info.AppendLine("    Views been printed: <null>");
        }
        else
        {
            info.AppendLine("    Views been printed: ");
            DumpViewsInfo(app, args.GetPrintedViewElementIds(), "      ", ref info);
        }
        //
        // FailedViews
        if (0 == args.GetFailedViewElementIds().Count)
        {
            info.AppendLine("    Views failed: <null>");
        }
        else
        {
            info.AppendLine("    Views Failed : ");
            DumpViewsInfo(app, args.GetFailedViewElementIds(), "      ", ref info);
        }

        TaskDialog.Show("Revit",info.ToString());
    }

    /// <summary>
    /// Dump information of views: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="views">Views to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line added to message box.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewsInfo(Application app, System.Collections.Generic.IList<ElementId> viewIds, String prefix, ref StringBuilder info)
    {
        int index = 0;
        UIApplication uiApp = new UIApplication(app);
        foreach (ElementId curViewId in viewIds)
        {
            Autodesk.Revit.DB.View curView = uiApp.ActiveUIDocument.Document.GetElement(curViewId) as Autodesk.Revit.DB.View;
                DumpViewInfo(curView, String.Format("{0}#{1}", prefix, index++), ref info);
        }
    }

    /// <summary>
    /// Dump information of single view: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="view">View element to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line added to message box.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewInfo(Autodesk.Revit.DB.View view, String prefix, ref StringBuilder info)
    {
        info.AppendLine(String.Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}",
            prefix, view.Id.ToString(), view.Name, view.ViewType));
    }
    /// </ExampleMethod>
}
Public Class Application_DocumentPrinted
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' Implement the OnStartup method to register events when Revit starts.
    ' </summary>
    Public Function OnStartup(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnStartup
        ' Register related events
        AddHandler application.ControlledApplication.DocumentPrinted, AddressOf AppDocumentPrinted
        Return Result.Succeeded
    End Function

    ' <summary>
    ' Implement this method to unregister the subscribed events when Revit exits.
    ' </summary>
    Public Function OnShutdown(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnShutdown
        ' unregister events
        RemoveHandler application.ControlledApplication.DocumentPrinted, AddressOf AppDocumentPrinted
        Return Result.Succeeded
    End Function
    ' <TrivialCode>
    ' Code ID: 501
    ' For DocumentPrinted class description
    ' </TrivialCode>

    ' <summary>
    ' Handler method for DocumentPrinted event, it will display some event arguments.
    ' </summary>
    Public Sub AppDocumentPrinted(sender As Object, args As Autodesk.Revit.DB.Events.DocumentPrintedEventArgs)
        Dim info As New StringBuilder()
        Dim app As Application = TryCast(sender, Application)
        info.AppendLine("DocumentPrintedEventArgs Parameters ------>")
        info.AppendLine("    Event Status      : " & args.Status.ToString())
        info.AppendLine("    Event Cancellable : " & Convert.ToString(args.Cancellable))
        '
        ' PrintedViews
        If 0 = args.GetFailedViewElementIds().Count OrElse 0 = args.GetPrintedViewElementIds().Count Then
            info.AppendLine("    Views been printed: <null>")
        Else
            info.AppendLine("    Views been printed: ")
            DumpViewsInfo(app, args.GetPrintedViewElementIds(), "      ", info)
        End If
        '
        ' FailedViews
        If 0 = args.GetFailedViewElementIds().Count Then
            info.AppendLine("    Views failed: <null>")
        Else
            info.AppendLine("    Views Failed : ")
            DumpViewsInfo(app, args.GetFailedViewElementIds(), "      ", info)
        End If

        TaskDialog.Show("Revit", info.ToString())
    End Sub

    ' <summary>
    ' Dump information of views: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="views">Views to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line added to message box.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewsInfo(app As Application, viewIds As System.Collections.Generic.IList(Of ElementId), prefix As [String], ByRef info As StringBuilder)
        Dim index As Integer = 0
        Dim uiApp As New UIApplication(app)
        For Each curViewId As ElementId In viewIds
            Dim curView As Autodesk.Revit.DB.View = TryCast(uiApp.ActiveUIDocument.Document.GetElement(curViewId), Autodesk.Revit.DB.View)
            DumpViewInfo(curView, [String].Format("{0}#{1}", prefix, System.Math.Max(System.Threading.Interlocked.Increment(index), index - 1)), info)
        Next
    End Sub

    ' <summary>
    ' Dump information of single view: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="view">View element to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line added to message box.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewInfo(view As Autodesk.Revit.DB.View, prefix As [String], ByRef info As StringBuilder)
        info.AppendLine([String].Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}", prefix, view.Id.ToString(), view.Name, view.ViewType))
    End Sub
    ' </ExampleMethod>
End Class

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.DocumentPrinting Event

ControlledApplicationDocumentPrinting Event

Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DocumentPrintingEventArgs> DocumentPrinting
Public Event DocumentPrinting As EventHandler(Of DocumentPrintingEventArgs)
public:
 event EventHandler<DocumentPrintingEventArgs^>^ DocumentPrinting {
    void add (EventHandler<DocumentPrintingEventArgs^>^ value);
    void remove (EventHandler<DocumentPrintingEventArgs^>^ value);
}
member DocumentPrinting : IEvent<EventHandler<DocumentPrintingEventArgs>,
    DocumentPrintingEventArgs>

Value

EventHandler DocumentPrintingEventArgs
Remarks

This event is raised when Revit is just about to print a view or ViewSet of the document.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is cancellable. To cancel it, call the 'Cancel()' method of event's argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for current document during this event:

  • All overloads of Autodesk.Revit.DB.Document.Export()
  • Autodesk::Revit::DB::Document::Print
  • Print and similar overloads.
  • SubmitPrint and similar overloads.
  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.
  • [!:Autodesk::Revit::DB::Document::Save()] .
  • [!:Autodesk::Revit::DB::Document::SaveAs(String)] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

After this event, for each view being printed, ViewPrinting and ViewPrinted events will be raised. Another event [!:Autodesk::Revit::DB::Document::DocumentPrinted] will be raised immediately after document printing is finished.

Example
C#
VB
C++
F#
Copy
public class Application_DocumentPrinting : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// Implement the OnStartup method to register events when Revit starts.
    /// </summary>
    public Result OnStartup(UIControlledApplication application)
    {
        // Register related events
       application.ControlledApplication.DocumentPrinting += new EventHandler<Autodesk.Revit.DB.Events.DocumentPrintingEventArgs>(AppDocumentPrinting);
        return Result.Succeeded;
    }

    /// <summary>
    /// Implement this method to unregister the subscribed events when Revit exits.
    /// </summary>
    public Result OnShutdown(UIControlledApplication application)
    {
        // unregister events
       application.ControlledApplication.DocumentPrinting -= new EventHandler<Autodesk.Revit.DB.Events.DocumentPrintingEventArgs>(AppDocumentPrinting);
        return Result.Succeeded;
    }
    /// <TrivialCode>
    /// Code ID: 501
    /// For DocumentPrinting class description
    /// </TrivialCode>

    /// <summary>
    /// Handler method for DocumentPrinting event, it will display some event arguments.
    /// </summary>
    public void AppDocumentPrinting(object sender, Autodesk.Revit.DB.Events.DocumentPrintingEventArgs args)
    {
        StringBuilder info = new StringBuilder();
        info.AppendLine("DocumentPrintingEventArgs Parameters ------>");

        info.AppendLine("    Event Cancellable   : " + args.Cancellable);
        info.AppendLine("    Views to be printed : "); // Views
        Application app = sender as Application;
        DumpViewsInfo(app, args.GetViewElementIds(), "    ", ref info);

        TaskDialog.Show("Revit",info.ToString());
    }

    /// <summary>
    /// Dump information of views: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="views">Views to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line added to message box.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewsInfo(Application app, System.Collections.Generic.IList<ElementId> viewIds, String prefix, ref StringBuilder info)
    {
        int index = 0;
        UIApplication uiApp = new UIApplication(app);
        foreach (ElementId curViewId in viewIds)
        {
            Autodesk.Revit.DB.View curView = uiApp.ActiveUIDocument.Document.GetElement(curViewId) as Autodesk.Revit.DB.View;
            DumpViewInfo(curView, String.Format("{0}#{1}", prefix, index++), ref info);
        }
    }

    /// <summary>
    /// Dump information of single view: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="view">View element to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line sent to message box.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewInfo(Autodesk.Revit.DB.View view, String prefix, ref StringBuilder info)
    {
        info.AppendLine(String.Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}",
            prefix, view.Id.ToString(), view.Name, view.ViewType));
    }
    /// </ExampleMethod>
}
Public Class Application_DocumentPrinting
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' Implement the OnStartup method to register events when Revit starts.
    ' </summary>
    Public Function OnStartup(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnStartup
        ' Register related events
        AddHandler application.ControlledApplication.DocumentPrinting, AddressOf AppDocumentPrinting
        Return Result.Succeeded
    End Function

    ' <summary>
    ' Implement this method to unregister the subscribed events when Revit exits.
    ' </summary>
    Public Function OnShutdown(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnShutdown
        ' unregister events
        RemoveHandler application.ControlledApplication.DocumentPrinting, AddressOf AppDocumentPrinting
        Return Result.Succeeded
    End Function
    ' <TrivialCode>
    ' Code ID: 501
    ' For DocumentPrinting class description
    ' </TrivialCode>

    ' <summary>
    ' Handler method for DocumentPrinting event, it will display some event arguments.
    ' </summary>
    Public Sub AppDocumentPrinting(sender As Object, args As Autodesk.Revit.DB.Events.DocumentPrintingEventArgs)
        Dim info As New StringBuilder()
        info.AppendLine("DocumentPrintingEventArgs Parameters ------>")

        info.AppendLine("    Event Cancellable   : " & Convert.ToString(args.Cancellable))
        info.AppendLine("    Views to be printed : ")
        ' Views
        Dim app As Application = TryCast(sender, Application)
        DumpViewsInfo(app, args.GetViewElementIds(), "    ", info)

        TaskDialog.Show("Revit", info.ToString())
    End Sub

    ' <summary>
    ' Dump information of views: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="views">Views to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line added to message box.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewsInfo(app As Application, viewIds As System.Collections.Generic.IList(Of ElementId), prefix As [String], ByRef info As StringBuilder)
        Dim index As Integer = 0
        Dim uiApp As New UIApplication(app)
        For Each curViewId As ElementId In viewIds
            Dim curView As Autodesk.Revit.DB.View = TryCast(uiApp.ActiveUIDocument.Document.GetElement(curViewId), Autodesk.Revit.DB.View)
            DumpViewInfo(curView, [String].Format("{0}#{1}", prefix, System.Math.Max(System.Threading.Interlocked.Increment(index), index - 1)), info)
        Next
    End Sub

    ' <summary>
    ' Dump information of single view: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="view">View element to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line sent to message box.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewInfo(view As Autodesk.Revit.DB.View, prefix As [String], ByRef info As StringBuilder)
        info.AppendLine([String].Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}", prefix, view.Id.ToString(), view.Name, view.ViewType))
    End Sub
    ' </ExampleMethod>
End Class

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.DocumentReloadedLatest Event

ControlledApplicationDocumentReloadedLatest Event

Subscribe to the DocumentReloadedLatestEventArgs event to be notified immediately after Revit has finished reloading a document with central model.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DocumentReloadedLatestEventArgs> DocumentReloadedLatest
Public Event DocumentReloadedLatest As EventHandler(Of DocumentReloadedLatestEventArgs)
public:
 event EventHandler<DocumentReloadedLatestEventArgs^>^ DocumentReloadedLatest {
    void add (EventHandler<DocumentReloadedLatestEventArgs^>^ value);
    void remove (EventHandler<DocumentReloadedLatestEventArgs^>^ value);
}
member DocumentReloadedLatest : IEvent<EventHandler<DocumentReloadedLatestEventArgs>,
    DocumentReloadedLatestEventArgs>

Value

EventHandler DocumentReloadedLatestEventArgs
Remarks

This event is raised immediately after Revit has finished reloading latest changes from a central model. It is raised even when document reloading latest changes from a central model failed or was cancelled (during DocumentReloadingLatest event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event's argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of reloading latest changes from a central model has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.
  • [!:Autodesk::Revit::DB::Document::Save()] .
  • [!:Autodesk::Revit::DB::Document::SaveAs(String)] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.DocumentReloadingLatest Event

ControlledApplicationDocumentReloadingLatest Event

Subscribe to the DocumentReloadingLatestEventArgs event to be notified when Revit is just about to reload latest changes from a central model.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DocumentReloadingLatestEventArgs> DocumentReloadingLatest
Public Event DocumentReloadingLatest As EventHandler(Of DocumentReloadingLatestEventArgs)
public:
 event EventHandler<DocumentReloadingLatestEventArgs^>^ DocumentReloadingLatest {
    void add (EventHandler<DocumentReloadingLatestEventArgs^>^ value);
    void remove (EventHandler<DocumentReloadingLatestEventArgs^>^ value);
}
member DocumentReloadingLatest : IEvent<EventHandler<DocumentReloadingLatestEventArgs>,
    DocumentReloadingLatestEventArgs>

Value

EventHandler DocumentReloadingLatestEventArgs
Remarks

This event is raised when Revit is just about to reload latest changes from a central model.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is cancellable. To cancel it, call the 'Cancel()' method in event's argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.
  • [!:Autodesk::Revit::DB::Document::Save()] .
  • [!:Autodesk::Revit::DB::Document::SaveAs(String)] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another DocumentReloadingLatest event will be raised immediately after latest changes reloading from a central model is finished.

See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.DocumentSaved Event

ControlledApplicationDocumentSaved Event

Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DocumentSavedEventArgs> DocumentSaved
Public Event DocumentSaved As EventHandler(Of DocumentSavedEventArgs)
public:
 event EventHandler<DocumentSavedEventArgs^>^ DocumentSaved {
    void add (EventHandler<DocumentSavedEventArgs^>^ value);
    void remove (EventHandler<DocumentSavedEventArgs^>^ value);
}
member DocumentSaved : IEvent<EventHandler<DocumentSavedEventArgs>,
    DocumentSavedEventArgs>

Value

EventHandler DocumentSavedEventArgs
Remarks

This event is raised immediately after Revit has finished saving a document. Note that the first save of a newly created document will raise DocumentSavedAs rather than the DocumentSaved event. It is raised even when document saving failed or was cancelled (during DocumentSaving event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' property in event's argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of saving document has already been finished.

The following API functions are not available for the current document during this event:

  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.
  • [!:Autodesk::Revit::DB::Document::Save()] .
  • [!:Autodesk::Revit::DB::Document::SaveAs(String)] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.DocumentSavedAs Event

ControlledApplicationDocumentSavedAs Event

Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DocumentSavedAsEventArgs> DocumentSavedAs
Public Event DocumentSavedAs As EventHandler(Of DocumentSavedAsEventArgs)
public:
 event EventHandler<DocumentSavedAsEventArgs^>^ DocumentSavedAs {
    void add (EventHandler<DocumentSavedAsEventArgs^>^ value);
    void remove (EventHandler<DocumentSavedAsEventArgs^>^ value);
}
member DocumentSavedAs : IEvent<EventHandler<DocumentSavedAsEventArgs>,
    DocumentSavedAsEventArgs>

Value

EventHandler DocumentSavedAsEventArgs
Remarks

This event is raised immediately after Revit has finished saving document with a new file name. Note that the first save of a newly created document will raise DocumentSavedAs rather than DocumentSaved event. It is raised even when document saving failed or was cancelled (during DocumentSavingAs event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' property in event's argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of saving document has already been finished.

The following API functions are not available for the current document during this event:

  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.
  • [!:Autodesk::Revit::DB::Document::Save()] .
  • [!:Autodesk::Revit::DB::Document::SaveAs(String)] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.DocumentSaving Event

ControlledApplicationDocumentSaving Event

Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DocumentSavingEventArgs> DocumentSaving
Public Event DocumentSaving As EventHandler(Of DocumentSavingEventArgs)
public:
 event EventHandler<DocumentSavingEventArgs^>^ DocumentSaving {
    void add (EventHandler<DocumentSavingEventArgs^>^ value);
    void remove (EventHandler<DocumentSavingEventArgs^>^ value);
}
member DocumentSaving : IEvent<EventHandler<DocumentSavingEventArgs>,
    DocumentSavingEventArgs>

Value

EventHandler DocumentSavingEventArgs
Remarks

This event is raised when Revit is just about to save the document. Note that the first save of a newly created document will raise DocumentSavingAs rather than the DocumentSaving event.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

This event is cancellable, except when it is raised during close of the application. Check the 'Cancellable' property of event's argument to see whether it is cancellable or not. When it is cancellable, call the 'Cancel()' method of event's argument to cancel it. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.
  • [!:Autodesk::Revit::DB::Document::Save()] .
  • [!:Autodesk::Revit::DB::Document::SaveAs(String)] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event DocumentSaved will be raised immediately after the document has been saved.

See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.DocumentSavingAs Event

ControlledApplicationDocumentSavingAs Event

Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DocumentSavingAsEventArgs> DocumentSavingAs
Public Event DocumentSavingAs As EventHandler(Of DocumentSavingAsEventArgs)
public:
 event EventHandler<DocumentSavingAsEventArgs^>^ DocumentSavingAs {
    void add (EventHandler<DocumentSavingAsEventArgs^>^ value);
    void remove (EventHandler<DocumentSavingAsEventArgs^>^ value);
}
member DocumentSavingAs : IEvent<EventHandler<DocumentSavingAsEventArgs>,
    DocumentSavingAsEventArgs>

Value

EventHandler DocumentSavingAsEventArgs
Remarks

This event is raised when Revit is just about to save the document with a new file name. Note that the first save of a newly created document will raise DocumentSavingAs rather than DocumentSaving event.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

This event is cancellable, except when it is raised during close of the application. Check the 'Cancellable' property of event's argument to see whether it is cancellable or not. When it is cancellable, call the 'Cancel()' method of event's argument to cancel it. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.
  • [!:Autodesk::Revit::DB::Document::Save()] .
  • [!:Autodesk::Revit::DB::Document::SaveAs(String)] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event DocumentSavedAs will be raised immediately after the document has been saved with a new file name.

Example
C#
VB
C++
F#
Copy
public class DocumentSavingAs : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// This method subscribes to DocumentSavingAs event.
    /// </summary>
    public Result OnStartup(UIControlledApplication application)
    {
       application.ControlledApplication.DocumentSavingAs += new EventHandler<DocumentSavingAsEventArgs>(CheckProjectStatusInitial);
        return Result.Succeeded;
    }

    /// <summary>
    /// Implement OnShutdown method of IExternalApplication interface to unregister subscribed event
    /// </summary>
    public Result OnShutdown(UIControlledApplication application)
    {
        // unregister subscribed event
       application.ControlledApplication.DocumentSavingAs -= new EventHandler<DocumentSavingAsEventArgs>(CheckProjectStatusInitial);
        return Result.Succeeded;
    }

    /// <summary>
    /// Event handler method for DocumentSavingAs event. This method will check the "Project Status" value,
    /// if it is null or empty string cancel the save as process.
    /// </summary>
    /// <param name="sender">The source of the event.</param>
    /// <param name="args">Event arguments that contains the event data.</param>
    private void CheckProjectStatusInitial(Object sender, DocumentSavingAsEventArgs args)
    {
        Document doc = args.Document;
        ProjectInfo proInfo = doc.ProjectInformation;

        // Project information is only available for project document.
        if (null != proInfo)
        {
            if (string.IsNullOrEmpty(proInfo.Status))
            {
                // cancel the save as process.
                args.Cancel();
                TaskDialog.Show("Revit","Status project parameter is not set.  Save is aborted.");
            }
        }
    }
    /// </ExampleMethod>
}
Public Class DocumentSavingAs
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' This method subscribes to DocumentSavingAs event.
    ' </summary>
    Public Function OnStartup(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnStartup
        AddHandler application.ControlledApplication.DocumentSavingAs, AddressOf CheckProjectStatusInitial
        Return Result.Succeeded
    End Function

    ' <summary>
    ' Implement OnShutdown method of IExternalApplication interface to unregister subscribed event
    ' </summary>
    Public Function OnShutdown(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnShutdown
        ' unregister subscribed event
        RemoveHandler application.ControlledApplication.DocumentSavingAs, AddressOf CheckProjectStatusInitial
        Return Result.Succeeded
    End Function

    ' <summary>
    ' Event handler method for DocumentSavingAs event. This method will check the "Project Status" value,
    ' if it is null or empty string cancel the save as process.
    ' </summary>
    ' <param name="sender">The source of the event.</param>
    ' <param name="args">Event arguments that contains the event data.</param>
    Private Sub CheckProjectStatusInitial(sender As [Object], args As DocumentSavingAsEventArgs)
        Dim doc As Document = args.Document
        Dim proInfo As ProjectInfo = doc.ProjectInformation

        ' Project information is only available for project document.
        If proInfo IsNot Nothing Then
            If String.IsNullOrEmpty(proInfo.Status) Then
                ' cancel the save as process.
                args.Cancel()
                TaskDialog.Show("Revit", "Status project parameter is not set.  Save is aborted.")
            End If
        End If
    End Sub
    ' </ExampleMethod>
End Class

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.DocumentSynchronizedWithCentral Event

ControlledApplicationDocumentSynchronizedWithCentral Event

Subscribe to the DocumentSynchronizedWithCentral event to be notified immediately after Revit has finished synchronizing a document with central model.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DocumentSynchronizedWithCentralEventArgs> DocumentSynchronizedWithCentral
Public Event DocumentSynchronizedWithCentral As EventHandler(Of DocumentSynchronizedWithCentralEventArgs)
public:
 event EventHandler<DocumentSynchronizedWithCentralEventArgs^>^ DocumentSynchronizedWithCentral {
    void add (EventHandler<DocumentSynchronizedWithCentralEventArgs^>^ value);
    void remove (EventHandler<DocumentSynchronizedWithCentralEventArgs^>^ value);
}
member DocumentSynchronizedWithCentral : IEvent<EventHandler<DocumentSynchronizedWithCentralEventArgs>,
    DocumentSynchronizedWithCentralEventArgs>

Value

EventHandler DocumentSynchronizedWithCentralEventArgs
Remarks

This event is raised immediately after Revit has finished synchronizing a document with central model. It is raised even when document synchronizing with central model failed or was cancelled (during DocumentSynchronizingWithCentral event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event's argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of synchronizing a document with central model has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.
  • [!:Autodesk::Revit::DB::Document::Save()] .
  • [!:Autodesk::Revit::DB::Document::SaveAs(String)] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.DocumentSynchronizingWithCentral Event

ControlledApplicationDocumentSynchronizingWithCentral Event

Subscribe to the DocumentSynchronizingWithCentral event to be notified when Revit is just about to synchronize a document with central model.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DocumentSynchronizingWithCentralEventArgs> DocumentSynchronizingWithCentral
Public Event DocumentSynchronizingWithCentral As EventHandler(Of DocumentSynchronizingWithCentralEventArgs)
public:
 event EventHandler<DocumentSynchronizingWithCentralEventArgs^>^ DocumentSynchronizingWithCentral {
    void add (EventHandler<DocumentSynchronizingWithCentralEventArgs^>^ value);
    void remove (EventHandler<DocumentSynchronizingWithCentralEventArgs^>^ value);
}
member DocumentSynchronizingWithCentral : IEvent<EventHandler<DocumentSynchronizingWithCentralEventArgs>,
    DocumentSynchronizingWithCentralEventArgs>

Value

EventHandler DocumentSynchronizingWithCentralEventArgs
Remarks

This event is raised when Revit is just about to synchronize a document with central model.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is cancellable. To cancel it, call the 'Cancel()' method in event's argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.
  • [!:Autodesk::Revit::DB::Document::Save()] .
  • [!:Autodesk::Revit::DB::Document::SaveAs(String)] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another DocumentSynchronizedWithCentral event will be raised immediately after document synchronizing with central model is finished.

See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.ElementTypeDuplicated Event

ControlledApplicationElementTypeDuplicated Event

Subscribe to the ElementTypeDuplicated event to be notified immediately after Revit has finished duplicating an element type.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<ElementTypeDuplicatedEventArgs> ElementTypeDuplicated
Public Event ElementTypeDuplicated As EventHandler(Of ElementTypeDuplicatedEventArgs)
public:
 event EventHandler<ElementTypeDuplicatedEventArgs^>^ ElementTypeDuplicated {
    void add (EventHandler<ElementTypeDuplicatedEventArgs^>^ value);
    void remove (EventHandler<ElementTypeDuplicatedEventArgs^>^ value);
}
member ElementTypeDuplicated : IEvent<EventHandler<ElementTypeDuplicatedEventArgs>,
    ElementTypeDuplicatedEventArgs>

Value

EventHandler ElementTypeDuplicatedEventArgs
Remarks

This event is raised immediately after Revit has finished duplicating an element type. It is raised even when duplicating an element type failed or was cancelled (during ElementTypeDuplicating event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in the event's argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of duplicating an element type has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.ElementTypeDuplicating Event

ControlledApplicationElementTypeDuplicating Event

Subscribe to the ElementTypeDuplicating event to be notified when Revit is just about to duplicate an element type.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<ElementTypeDuplicatingEventArgs> ElementTypeDuplicating
Public Event ElementTypeDuplicating As EventHandler(Of ElementTypeDuplicatingEventArgs)
public:
 event EventHandler<ElementTypeDuplicatingEventArgs^>^ ElementTypeDuplicating {
    void add (EventHandler<ElementTypeDuplicatingEventArgs^>^ value);
    void remove (EventHandler<ElementTypeDuplicatingEventArgs^>^ value);
}
member ElementTypeDuplicating : IEvent<EventHandler<ElementTypeDuplicatingEventArgs>,
    ElementTypeDuplicatingEventArgs>

Value

EventHandler ElementTypeDuplicatingEventArgs
Remarks

This event is raised when Revit is just about to duplicate an element type.

Event is cancellable. To cancel it, call the 'Cancel()' method in event's argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • All overloads of Autodesk.Revit.DB.Document.Import()
  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.
  • [!:Autodesk::Revit::DB::Document::Save()] .
  • [!:Autodesk::Revit::DB::Document::SaveAs(String)] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another ElementTypeDuplicated event will be raised immediately after duplicating an element type is finished.

See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.FailuresProcessing Event

ControlledApplicationFailuresProcessing Event

Subscribe to the FailuresProcessing event to be notified when failures are being processed at the end of transaction.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<FailuresProcessingEventArgs> FailuresProcessing
Public Event FailuresProcessing As EventHandler(Of FailuresProcessingEventArgs)
public:
 event EventHandler<FailuresProcessingEventArgs^>^ FailuresProcessing {
    void add (EventHandler<FailuresProcessingEventArgs^>^ value);
    void remove (EventHandler<FailuresProcessingEventArgs^>^ value);
}
member FailuresProcessing : IEvent<EventHandler<FailuresProcessingEventArgs>,
    FailuresProcessingEventArgs>

Value

EventHandler FailuresProcessingEventArgs
Remarks

This event is raised when failures are being processed during transaction commit or rollback operations. Handlers of this event have a limited ability to modify the document and/or failures in it, using the provided restricted failures accessor interface.

The event arguments provide access to the FailuresAccessor via [!:Autodesk::Revit::DB::FailuresProcessingEventArgs::GetFailuresAccessor()] which contains the details of the errors and/or warnings that caused the event to trigger.

The arguments also allow you to set a processing result via [!:Autodesk::Revit::DB::FailuresProcessingEventArgs::SetProcessingResult()]. The processing result determines if Revit will attempt to recommit the currently failing transaction, roll it back, or continue. If you are explicitly dismissing warnings from the event callback, a processing result of Continue is sufficient. But if you are explicitly resolving errors from the event callback, you must change the processing result to ProceedWithCommit to ensure that the user is not shown the dismissed errors. If you wish to cancel the transaction silently without showing the errors to the user, set the processing result to ProceedWithRollback, however you must also call SetClearAfterRollback(Boolean) in order to dismiss the errors and silently cancel the transaction.

Example
C#
VB
C++
F#
Copy
[Autodesk.Revit.Attributes.Transaction(Autodesk.Revit.Attributes.TransactionMode.Manual)]

 public class NoUnenclosedRoomWarnings : IExternalApplication
 {
     static AddInId m_appId = new AddInId(new Guid("EB296268-8364-4d25-96E6-F664C608503C"));

     public Result OnStartup(UIControlledApplication application)
     {
         //Create an API application that subscribes to FailuresProcessing event for the lifetime of the session.
         application.ControlledApplication.FailuresProcessing += new EventHandler<FailuresProcessingEventArgs>(CheckWarnings);
         return Result.Succeeded;
     }

     public Result OnShutdown(UIControlledApplication application)
     {
         return Result.Succeeded;
     }

     private void CheckWarnings(object sender, FailuresProcessingEventArgs e)
     {
         FailuresAccessor fa = e.GetFailuresAccessor();
         IList<FailureMessageAccessor> failList = new List<FailureMessageAccessor>();
         failList = fa.GetFailureMessages(); // Inside event handler, get all warnings
         foreach (FailureMessageAccessor failure in failList)
         {
             // check FailureDefinitionIds against ones that you want to dismiss,
             FailureDefinitionId failID = failure.GetFailureDefinitionId();
             // prevent Revit from showing Unenclosed room warnings
             if (failID == BuiltInFailures.RoomFailures.RoomNotEnclosed)
             {
                 fa.DeleteWarning(failure);
             }
         }
     }
 }
<Autodesk.Revit.Attributes.Transaction(Autodesk.Revit.Attributes.TransactionMode.Manual)> _
Public Class NoUnenclosedRoomWarnings
    Implements IExternalApplication
    Shared m_appId As New AddInId(New Guid("EB296268-8364-4d25-96E6-F664C608503C"))

    Public Function OnStartup(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnStartup
        'Create an API application that subscribes to FailuresProcessing event for the lifetime of the session.
        AddHandler application.ControlledApplication.FailuresProcessing, AddressOf CheckWarnings
        Return Result.Succeeded
    End Function

    Public Function OnShutdown(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnShutdown
        Return Result.Succeeded
    End Function

    Private Sub CheckWarnings(sender As Object, e As FailuresProcessingEventArgs)
        Dim fa As FailuresAccessor = e.GetFailuresAccessor()
        Dim failList As IList(Of FailureMessageAccessor) = New List(Of FailureMessageAccessor)()
        failList = fa.GetFailureMessages()
        ' Inside event handler, get all warnings
        For Each failure As FailureMessageAccessor In failList
            ' check FailureDefinitionIds against ones that you want to dismiss,
            Dim failID As FailureDefinitionId = failure.GetFailureDefinitionId()
            ' prevent Revit from showing Unenclosed room warnings
            If failID = BuiltInFailures.RoomFailures.RoomNotEnclosed Then
                fa.DeleteWarning(failure)
            End If
        Next
    End Sub
End Class

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.FamilyLoadedIntoDocument Event

ControlledApplicationFamilyLoadedIntoDocument Event

Subscribe to the FamilyLoadedInto event to be notified after Revit loaded a family into a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<FamilyLoadedIntoDocumentEventArgs> FamilyLoadedIntoDocument
Public Event FamilyLoadedIntoDocument As EventHandler(Of FamilyLoadedIntoDocumentEventArgs)
public:
 event EventHandler<FamilyLoadedIntoDocumentEventArgs^>^ FamilyLoadedIntoDocument {
    void add (EventHandler<FamilyLoadedIntoDocumentEventArgs^>^ value);
    void remove (EventHandler<FamilyLoadedIntoDocumentEventArgs^>^ value);
}
member FamilyLoadedIntoDocument : IEvent<EventHandler<FamilyLoadedIntoDocumentEventArgs>,
    FamilyLoadedIntoDocumentEventArgs>

Value

EventHandler FamilyLoadedIntoDocumentEventArgs
Remarks

This event is raised immediately after Revit has finished loading a family into a document. It is raised even when family loading failed or was cancelled (during FamilyLoadingIntoDocument event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event's argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of importing has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.FamilyLoadingIntoDocument Event

ControlledApplicationFamilyLoadingIntoDocument Event

Subscribe to the FamilyLoadingInto event to be notified when Revit is just about to load a family into a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<FamilyLoadingIntoDocumentEventArgs> FamilyLoadingIntoDocument
Public Event FamilyLoadingIntoDocument As EventHandler(Of FamilyLoadingIntoDocumentEventArgs)
public:
 event EventHandler<FamilyLoadingIntoDocumentEventArgs^>^ FamilyLoadingIntoDocument {
    void add (EventHandler<FamilyLoadingIntoDocumentEventArgs^>^ value);
    void remove (EventHandler<FamilyLoadingIntoDocumentEventArgs^>^ value);
}
member FamilyLoadingIntoDocument : IEvent<EventHandler<FamilyLoadingIntoDocumentEventArgs>,
    FamilyLoadingIntoDocumentEventArgs>

Value

EventHandler FamilyLoadingIntoDocumentEventArgs
Remarks

This event is raised when Revit is just about to load a family into a document.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is cancellable. To cancel it, call the 'Cancel()' method in event's argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • All overloads of Autodesk.Revit.DB.Document.Import()
  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.
  • [!:Autodesk::Revit::DB::Document::Save()] .
  • [!:Autodesk::Revit::DB::Document::SaveAs(String)] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another FamilyLoadedIntoDocument event will be raised immediately after family loading is finished.

See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.FileExported Event

ControlledApplicationFileExported Event

Subscribe to the FileExported event to be notified immediately after Revit has finished exporting files of formats supported by the API.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<FileExportedEventArgs> FileExported
Public Event FileExported As EventHandler(Of FileExportedEventArgs)
public:
 event EventHandler<FileExportedEventArgs^>^ FileExported {
    void add (EventHandler<FileExportedEventArgs^>^ value);
    void remove (EventHandler<FileExportedEventArgs^>^ value);
}
member FileExported : IEvent<EventHandler<FileExportedEventArgs>,
    FileExportedEventArgs>

Value

EventHandler FileExportedEventArgs
Remarks

This event is raised immediately after Revit has finished exporting files of formats supported by the API. It is raised even when file exporting failed or was cancelled (during FileExporting event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event's argument to see whether the action itself was successful or not. If export is a part of 'Publish to Buzzsaw' command which consists of two parts â€“ export of a document followed by publishing it to a BuzzSaw server, the event status only reflects the result of the Export action. The publishing part of the command could still be cancelled or could fail after FileExported event is raised.

This event is not cancellable, for the process of exporting file has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.FileExporting Event

ControlledApplicationFileExporting Event

Subscribe to the FileExporting event to be notified when Revit is just about to export files of formats supported by the API.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<FileExportingEventArgs> FileExporting
Public Event FileExporting As EventHandler(Of FileExportingEventArgs)
public:
 event EventHandler<FileExportingEventArgs^>^ FileExporting {
    void add (EventHandler<FileExportingEventArgs^>^ value);
    void remove (EventHandler<FileExportingEventArgs^>^ value);
}
member FileExporting : IEvent<EventHandler<FileExportingEventArgs>,
    FileExportingEventArgs>

Value

EventHandler FileExportingEventArgs
Remarks

This event is raised when Revit is just about to export files of formats supported by the API.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is cancellable. To cancel it, call the 'Cancel()' method in event's argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • All overloads of Autodesk.Revit.DB.Document.Export()
  • Autodesk.Revit.Document.Print()
  • Print and similar overloads.
  • SubmitPrint and similar overloads.
  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.
  • [!:Autodesk::Revit::DB::Document::Save()] .
  • [!:Autodesk::Revit::DB::Document::SaveAs(String)] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another FileExported event will be raised immediately after file exporting is finished.

See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.FileImported Event

ControlledApplicationFileImported Event

Subscribe to the FileImported event to be notified immediately after Revit has finished importing a file of format supported by the API.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<FileImportedEventArgs> FileImported
Public Event FileImported As EventHandler(Of FileImportedEventArgs)
public:
 event EventHandler<FileImportedEventArgs^>^ FileImported {
    void add (EventHandler<FileImportedEventArgs^>^ value);
    void remove (EventHandler<FileImportedEventArgs^>^ value);
}
member FileImported : IEvent<EventHandler<FileImportedEventArgs>,
    FileImportedEventArgs>

Value

EventHandler FileImportedEventArgs
Remarks

This event is raised immediately after Revit has finished importing a file of format supported by the API. It is raised even when file importing failed or was cancelled (during FileImporting event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event's argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of importing has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.FileImporting Event

ControlledApplicationFileImporting Event

Subscribe to the FileImporting event to be notified when Revit is just about to import a file of format supported by the API.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<FileImportingEventArgs> FileImporting
Public Event FileImporting As EventHandler(Of FileImportingEventArgs)
public:
 event EventHandler<FileImportingEventArgs^>^ FileImporting {
    void add (EventHandler<FileImportingEventArgs^>^ value);
    void remove (EventHandler<FileImportingEventArgs^>^ value);
}
member FileImporting : IEvent<EventHandler<FileImportingEventArgs>,
    FileImportingEventArgs>

Value

EventHandler FileImportingEventArgs
Remarks

This event is raised when Revit is just about to import a file of format supported by the API.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is cancellable. To cancel it, call the 'Cancel()' method in event's argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • All overloads of Autodesk.Revit.DB.Document.Import()
  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.
  • [!:Autodesk::Revit::DB::Document::Save()] .
  • [!:Autodesk::Revit::DB::Document::SaveAs(String)] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another FileImported event will be raised immediately after file importing is finished.

See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.LinkedResourceOpened Event

ControlledApplicationLinkedResourceOpened Event

Subscribe to the LinkedResourceOpened event to be notified immediately after Revit has finished opening a linked resource.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<LinkedResourceOpenedEventArgs> LinkedResourceOpened
Public Event LinkedResourceOpened As EventHandler(Of LinkedResourceOpenedEventArgs)
public:
 event EventHandler<LinkedResourceOpenedEventArgs^>^ LinkedResourceOpened {
    void add (EventHandler<LinkedResourceOpenedEventArgs^>^ value);
    void remove (EventHandler<LinkedResourceOpenedEventArgs^>^ value);
}
member LinkedResourceOpened : IEvent<EventHandler<LinkedResourceOpenedEventArgs>,
    LinkedResourceOpenedEventArgs>

Value

EventHandler LinkedResourceOpenedEventArgs
Remarks

This event is raised immediately after Revit has finished opening a linked resource. Only supports linked resources for following types : Revit; IFC; CAD(dwg, dxf, dgn, sat); Topography; It is raised even when a linked resource opening failed. The LinkedResourceOpened events would not raised if there are no update on linked CAD, IFC resources.

Check the 'Status' field in event's argument to see whether the action itself was successful or not.

Another LinkedResourceOpening event will be raised when Revit is just about to open a linked resource.

See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.LinkedResourceOpening Event

ControlledApplicationLinkedResourceOpening Event

Subscribe to the LinkedResourceOpening event to be notified when Revit is just about to open a linked resource.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<LinkedResourceOpeningEventArgs> LinkedResourceOpening
Public Event LinkedResourceOpening As EventHandler(Of LinkedResourceOpeningEventArgs)
public:
 event EventHandler<LinkedResourceOpeningEventArgs^>^ LinkedResourceOpening {
    void add (EventHandler<LinkedResourceOpeningEventArgs^>^ value);
    void remove (EventHandler<LinkedResourceOpeningEventArgs^>^ value);
}
member LinkedResourceOpening : IEvent<EventHandler<LinkedResourceOpeningEventArgs>,
    LinkedResourceOpeningEventArgs>

Value

EventHandler LinkedResourceOpeningEventArgs
Remarks

This event is raised when Revit is just about to open a linked resource. Only supports linked resources for following types : Revit; IFC; CAD(dwg, dxf, dgn, sat); This event would not be raised if there are no update on linked CAD, IFC resources.

Event is not cancellable.

The linked resource cannot be modified, for it is not opened yet at the time of the event.

Another LinkedResourceOpened event will be raised immediately after linked resource is opened.

See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.ProgressChanged Event

ControlledApplicationProgressChanged Event

Subscribe to the ProgressChanged event to be notified when an operation in Revit has progress bar data available.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<ProgressChangedEventArgs> ProgressChanged
Public Event ProgressChanged As EventHandler(Of ProgressChangedEventArgs)
public:
 event EventHandler<ProgressChangedEventArgs^>^ ProgressChanged {
    void add (EventHandler<ProgressChangedEventArgs^>^ value);
    void remove (EventHandler<ProgressChangedEventArgs^>^ value);
}
member ProgressChanged : IEvent<EventHandler<ProgressChangedEventArgs>,
    ProgressChangedEventArgs>

Value

EventHandler ProgressChangedEventArgs
Remarks

Handlers of this event may use the Cancel method to cancel the operation tracked by the progress bar. Users may not change the document in the handler for this event. Exception ModificationForbiddenException will be thrown if any document-modifying method is called during this event's handler.

See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.ViewPrinted Event

ControlledApplicationViewPrinted Event

Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<ViewPrintedEventArgs> ViewPrinted
Public Event ViewPrinted As EventHandler(Of ViewPrintedEventArgs)
public:
 event EventHandler<ViewPrintedEventArgs^>^ ViewPrinted {
    void add (EventHandler<ViewPrintedEventArgs^>^ value);
    void remove (EventHandler<ViewPrintedEventArgs^>^ value);
}
member ViewPrinted : IEvent<EventHandler<ViewPrintedEventArgs>,
    ViewPrintedEventArgs>

Value

EventHandler ViewPrintedEventArgs
Remarks

This event is raised immediately after Revit has finished printing a view of the document. If multiple views are combined to a single file, this event will be raised only once. It is raised even when view printing failed.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event's argument to see whether the action was successful or not.

This event is not cancellable, for the process of view printing has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Example
C#
VB
C++
F#
Copy
public class Application_ViewPrinted : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// Implement the OnStartup method to register events when Revit starts.
    /// </summary>
    public Result OnStartup(UIControlledApplication application)
    {
        // Register related events
        application.ControlledApplication.ViewPrinted += new EventHandler<Autodesk.Revit.DB.Events.ViewPrintedEventArgs>(AppViewPrinted);
        return Result.Succeeded;
    }

    /// <summary>
    /// Implement this method to unregister the subscribed events when Revit exits.
    /// </summary>
    public Result OnShutdown(UIControlledApplication application)
    {
        // unregister events
       application.ControlledApplication.ViewPrinted -= new EventHandler<Autodesk.Revit.DB.Events.ViewPrintedEventArgs>(AppViewPrinted);
        return Result.Succeeded;
    }
    /// <TrivialCode>
    /// Code ID: 501
    /// For ViewPrinted class description
    /// </TrivialCode>

    /// <summary>
    /// Handler method for ViewPrinting event, it will dump some event arguments.
    /// </summary>
    public void AppViewPrinted(object sender, Autodesk.Revit.DB.Events.ViewPrintedEventArgs args)
    {
        StringBuilder info = new StringBuilder();
        info.AppendLine("ViewPrintedEventArgs Parameters ------>");
        info.AppendLine("    Event Status        : " + args.Status);
        info.AppendLine("    TotalViews          : " + args.TotalViews);
        info.AppendLine("    View Index          : " + args.Index);
        info.AppendLine("    View Information    :");
        DumpViewInfo(args.View, "      ", ref info);

        TaskDialog.Show("Revit",info.ToString());
    }

    /// <summary>
    /// Dump information of single view: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="view">View element to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line added to message box string.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewInfo(Autodesk.Revit.DB.View view, String prefix, ref StringBuilder info)
    {
        info.AppendLine(String.Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}",
            prefix, view.Id.ToString(), view.Name, view.ViewType));
    }
    /// </ExampleMethod>
}
Public Class Application_ViewPrinted
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' Implement the OnStartup method to register events when Revit starts.
    ' </summary>
    Public Function OnStartup(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnStartup
        ' Register related events
        AddHandler application.ControlledApplication.ViewPrinted, AddressOf AppViewPrinted
        Return Result.Succeeded
    End Function

    ' <summary>
    ' Implement this method to unregister the subscribed events when Revit exits.
    ' </summary>
    Public Function OnShutdown(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnShutdown
        ' unregister events
        RemoveHandler application.ControlledApplication.ViewPrinted, AddressOf AppViewPrinted
        Return Result.Succeeded
    End Function
    ' <TrivialCode>
    ' Code ID: 501
    ' For ViewPrinted class description
    ' </TrivialCode>

    ' <summary>
    ' Handler method for ViewPrinting event, it will dump some event arguments.
    ' </summary>
    Public Sub AppViewPrinted(sender As Object, args As Autodesk.Revit.DB.Events.ViewPrintedEventArgs)
        Dim info As New StringBuilder()
        info.AppendLine("ViewPrintedEventArgs Parameters ------>")
        info.AppendLine("    Event Status        : " & Convert.ToString(args.Status))
        info.AppendLine("    TotalViews          : " & Convert.ToString(args.TotalViews))
        info.AppendLine("    View Index          : " & Convert.ToString(args.Index))
        info.AppendLine("    View Information    :")
        DumpViewInfo(args.View, "      ", info)

        TaskDialog.Show("Revit", info.ToString())
    End Sub

    ' <summary>
    ' Dump information of single view: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="view">View element to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line added to message box string.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewInfo(view As Autodesk.Revit.DB.View, prefix As [String], ByRef info As StringBuilder)
        info.AppendLine([String].Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}", prefix, view.Id.ToString(), view.Name, view.ViewType))
    End Sub
    ' </ExampleMethod>
End Class

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.ViewPrinting Event

ControlledApplicationViewPrinting Event

Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<ViewPrintingEventArgs> ViewPrinting
Public Event ViewPrinting As EventHandler(Of ViewPrintingEventArgs)
public:
 event EventHandler<ViewPrintingEventArgs^>^ ViewPrinting {
    void add (EventHandler<ViewPrintingEventArgs^>^ value);
    void remove (EventHandler<ViewPrintingEventArgs^>^ value);
}
member ViewPrinting : IEvent<EventHandler<ViewPrintingEventArgs>,
    ViewPrintingEventArgs>

Value

EventHandler ViewPrintingEventArgs
Remarks

This event is raised when Revit is just about to print a view of the document. If multiple views are combined to a single file, this event will be raised only once.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is not cancellable. The 'Cancellable' property of event's argument is always False.

The following API functions are not available for the current document during this event:

  • All overloads of Autodesk.Revit.DB.Document.Export()
  • Autodesk.Revit.DB.Document.Print()
  • Print and similar overloads.
  • SubmitPrint and similar overloads.
  • [!:Autodesk::Revit::DB::Document::Close()] and similar overloads.
  • [!:Autodesk::Revit::DB::Document::Save()] .
  • [!:Autodesk::Revit::DB::Document::SaveAs(String)] and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event ViewPrinted will be raised immediately after view printing is finished.

Example
C#
VB
C++
F#
Copy
public class Application_ViewPrinting : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// Implement the OnStartup method to register events when Revit starts.
    /// </summary>
    public Result OnStartup(UIControlledApplication application)
    {
        // Register related events
       application.ControlledApplication.ViewPrinting += new EventHandler<Autodesk.Revit.DB.Events.ViewPrintingEventArgs>(AppViewPrinting);
        return Result.Succeeded;
    }

    /// <summary>
    /// Implement this method to unregister the subscribed events when Revit exits.
    /// </summary>
    public Result OnShutdown(UIControlledApplication application)
    {
        // unregister events
       application.ControlledApplication.ViewPrinting -= new EventHandler<Autodesk.Revit.DB.Events.ViewPrintingEventArgs>(AppViewPrinting);
        return Result.Succeeded;
    }
    /// <TrivialCode>
    /// Code ID: 501
    /// For ViewPrinting class description
    /// </TrivialCode>

    /// <summary>
    /// Handler method for ViewPrinting event, it will display some event arguments.
    /// </summary>
    public void AppViewPrinting(object sender, Autodesk.Revit.DB.Events.ViewPrintingEventArgs args)
    {
        StringBuilder info = new StringBuilder();
        info.AppendLine("ViewPrintingEventArgs Parameters ------>");
        info.AppendLine("    Event Cancellable   : " + args.Cancellable);
        info.AppendLine("    TotalViews          : " + args.TotalViews);
        info.AppendLine("    View Index          : " + args.Index);
        info.AppendLine("    View Information    :"); // View
        DumpViewInfo(args.View, "      ", ref info);

        TaskDialog.Show("Revit",info.ToString());
    }

    /// <summary>
    /// Dump information of single view: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="view">View element to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line added to message box string.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewInfo(Autodesk.Revit.DB.View view, String prefix, ref StringBuilder info)
    {
        info.AppendLine(String.Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}",
            prefix, view.Id.ToString(), view.Name, view.ViewType));
    }
    /// </ExampleMethod>
}
Public Class Application_ViewPrinting
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' Implement the OnStartup method to register events when Revit starts.
    ' </summary>
    Public Function OnStartup(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnStartup
        ' Register related events
        AddHandler application.ControlledApplication.ViewPrinting, AddressOf AppViewPrinting
        Return Result.Succeeded
    End Function

    ' <summary>
    ' Implement this method to unregister the subscribed events when Revit exits.
    ' </summary>
    Public Function OnShutdown(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnShutdown
        ' unregister events
        RemoveHandler application.ControlledApplication.ViewPrinting, AddressOf AppViewPrinting
        Return Result.Succeeded
    End Function
    ' <TrivialCode>
    ' Code ID: 501
    ' For ViewPrinting class description
    ' </TrivialCode>

    ' <summary>
    ' Handler method for ViewPrinting event, it will display some event arguments.
    ' </summary>
    Public Sub AppViewPrinting(sender As Object, args As Autodesk.Revit.DB.Events.ViewPrintingEventArgs)
        Dim info As New StringBuilder()
        info.AppendLine("ViewPrintingEventArgs Parameters ------>")
        info.AppendLine("    Event Cancellable   : " & Convert.ToString(args.Cancellable))
        info.AppendLine("    TotalViews          : " & Convert.ToString(args.TotalViews))
        info.AppendLine("    View Index          : " & Convert.ToString(args.Index))
        info.AppendLine("    View Information    :")
        ' View
        DumpViewInfo(args.View, "      ", info)

        TaskDialog.Show("Revit", info.ToString())
    End Sub

    ' <summary>
    ' Dump information of single view: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="view">View element to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line added to message box string.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewInfo(view As Autodesk.Revit.DB.View, prefix As [String], ByRef info As StringBuilder)
        info.AppendLine([String].Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}", prefix, view.Id.ToString(), view.Name, view.ViewType))
    End Sub
    ' </ExampleMethod>
End Class

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication.WorksharedOperationProgressChanged Event

ControlledApplicationWorksharedOperationProgressChanged Event

Subscribe to the WorksharedOperationProgressChanged to be notified when progress has changed during Collaboration for Revit's workshared operations: open model and synchronize with central.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<WorksharedOperationProgressChangedEventArgs> WorksharedOperationProgressChanged
Public Event WorksharedOperationProgressChanged As EventHandler(Of WorksharedOperationProgressChangedEventArgs)
public:
 event EventHandler<WorksharedOperationProgressChangedEventArgs^>^ WorksharedOperationProgressChanged {
    void add (EventHandler<WorksharedOperationProgressChangedEventArgs^>^ value);
    void remove (EventHandler<WorksharedOperationProgressChangedEventArgs^>^ value);
}
member WorksharedOperationProgressChanged : IEvent<EventHandler<WorksharedOperationProgressChangedEventArgs>,
    WorksharedOperationProgressChangedEventArgs>

Value

EventHandler WorksharedOperationProgressChangedEventArgs
Remarks

This event is only supported for Collaboration for Revit and will not be raised for those operations occurring in local-worksharing and Revit Server workflow. Users may not change the document in the handler for this event. It is NOT recommended to do any time-consuming work when handling WorksharedOperationProgressChanged event. This can increase workshared operation time." Exception ModificationForbiddenException will be thrown if any document-modifying method is called during this event's handler.

See Also

Reference

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


LanguageType Enumeration

An enumerated type containing the supported Revit product languages.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum LanguageType
Public Enumeration LanguageType
public enum class LanguageType
type LanguageType
Members
Member name | Value | Description
English_USA | 0 | English USA.
German | 1 | German.
Spanish | 2 | Spanish.
French | 3 | French.
Italian | 4 | Italian.
Dutch | 5 | Dutch.
Chinese_Simplified | 6 | Chinese simplified.
Chinese_Traditional | 7 | Chinese traditional.
Japanese | 8 | Japanese.
Korean | 9 | Korean.
Unknown | -1 | Unknown.
Russian | 10 | Russian.
Czech | 11 | Czech.
Polish | 12 | Polish.
Hungarian | 13 | Hungarian.
Brazilian_Portuguese | 14 | Brazilian Portuguese.
English_GB | 15 | English - United Kingdom.
See Also

Reference

Autodesk.Revit.ApplicationServices Namespace


ProductType Enumeration

An enumerated type containing the possible Revit product types.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ProductType
Public Enumeration ProductType
public enum class ProductType
type ProductType
Members
Member name | Value | Description
Architecture | 0 | Architecture.
Structure | 1 | Structure.
MEP | 2 | MEP.
Revit | 3 | Revit.
LT | 4 | LT.
Unknown | 5 | Unknown.
See Also

Reference

Autodesk.Revit.ApplicationServices Namespace


Autodesk.Revit.Attributes Namespace

Classes
 | Class | Description
Public class | JournalingAttribute | The custom journaling attribute to control the journaling behavior of the external command.
Public class | RegenerationAttribute | The custom regeneration attribute to control the regeneration behavior of the external command or external application.
Public class | TransactionAttribute | The custom transaction attribute to control the transaction behavior of the external command.
Enumerations
 | Enumeration | Description
Public enumeration | JournalingMode | All journaling modes supported by Revit external commands.
Public enumeration | RegenerationOption | All regeneration options supported by Revit external commands and external applications.
Public enumeration | TransactionMode | All transaction modes supported by Revit external commands.


JournalingAttribute Class

The custom journaling attribute to control the journaling behavior of the external command.
Inheritance Hierarchy
SystemObject
SystemAttribute
Autodesk.Revit.AttributesJournalingAttribute

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class JournalingAttribute : Attribute
Public Class JournalingAttribute
    Inherits Attribute
public ref class JournalingAttribute : public Attribute
type JournalingAttribute =
    class
        inherit Attribute
    end

The JournalingAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | JournalingAttribute | Constructs a new JournalingAttribute.
Top
Properties
 | Name | Description
Public property | Mode | Journaling mode.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.Attributes Namespace


JournalingAttribute Constructor

Constructs a new JournalingAttribute.

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public JournalingAttribute(
    JournalingMode mode
)
Public Sub New (
    mode As JournalingMode
)
public:
JournalingAttribute(
    JournalingMode mode
)
new :
        mode : JournalingMode -> JournalingAttribute

Parameters

mode JournalingMode
See Also

Reference

JournalingAttribute Class
Autodesk.Revit.Attributes Namespace


JournalingAttribute Properties

The JournalingAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Mode | Journaling mode.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute)
Top
See Also

Reference

JournalingAttribute Class
Autodesk.Revit.Attributes Namespace


JournalingAttribute.Mode Property

JournalingAttributeMode Property

Journaling mode.

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public JournalingMode Mode { get; }
Public ReadOnly Property Mode As JournalingMode
    Get
public:
property JournalingMode Mode {
    JournalingMode get ();
}
member Mode : JournalingMode with get

Property Value

JournalingMode
See Also

Reference

JournalingAttribute Class
Autodesk.Revit.Attributes Namespace


JournalingAttribute Methods

The JournalingAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

JournalingAttribute Class
Autodesk.Revit.Attributes Namespace


JournalingMode Enumeration

All journaling modes supported by Revit external commands.

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum JournalingMode
Public Enumeration JournalingMode
public enum class JournalingMode
type JournalingMode
Members
Member name | Value | Description
UsingCommandData | 0 | Uses the "StringStringMap" supplied in the command data. Hides all Revit journal entries in between the external command invocation and the StringStringMap entry. Commands which invoke the Revit UI for selection or for responses to task dialogs may not replay correctly.
NoCommandData | 1 | Does not write contents of the ExternalCommandData.Data map to the Revit journal. But does allow Revit API calls to write to the journal as needed. This option should allow commands which invoke the Revit UI for selection or for responses to task dialogs to replay correctly.
See Also

Reference

Autodesk.Revit.Attributes Namespace


RegenerationAttribute Class

The custom regeneration attribute to control the regeneration behavior of the external command or external application.
Inheritance Hierarchy
SystemObject
SystemAttribute
Autodesk.Revit.AttributesRegenerationAttribute

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RegenerationAttribute : Attribute
Public Class RegenerationAttribute
    Inherits Attribute
public ref class RegenerationAttribute : public Attribute
type RegenerationAttribute =
    class
        inherit Attribute
    end

The RegenerationAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | RegenerationAttribute | Constructs a new RegenerationAttribute.
Top
Properties
 | Name | Description
Public property | Option | Regeneration option.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.Attributes Namespace


RegenerationAttribute Constructor

Constructs a new RegenerationAttribute.

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RegenerationAttribute(
    RegenerationOption option
)
Public Sub New (
    option As RegenerationOption
)
public:
RegenerationAttribute(
    RegenerationOption option
)
new :
        option : RegenerationOption -> RegenerationAttribute

Parameters

option RegenerationOption
See Also

Reference

RegenerationAttribute Class
Autodesk.Revit.Attributes Namespace


RegenerationAttribute Properties

The RegenerationAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Option | Regeneration option.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute)
Top
See Also

Reference

RegenerationAttribute Class
Autodesk.Revit.Attributes Namespace


RegenerationAttribute.Option Property

RegenerationAttributeOption Property

Regeneration option.

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RegenerationOption Option { get; }
Public ReadOnly Property Option As RegenerationOption
    Get
public:
property RegenerationOption Option {
    RegenerationOption get ();
}
member Option : RegenerationOption with get

Property Value

RegenerationOption
See Also

Reference

RegenerationAttribute Class
Autodesk.Revit.Attributes Namespace


RegenerationAttribute Methods

The RegenerationAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

RegenerationAttribute Class
Autodesk.Revit.Attributes Namespace


RegenerationOption Enumeration

All regeneration options supported by Revit external commands and external applications.

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum RegenerationOption
Public Enumeration RegenerationOption
public enum class RegenerationOption
type RegenerationOption
Members
Member name | Value | Description
Manual | 0 | The API framework will not regenerate after every model level change. Instead, you may use the regeneration APIs to force update of the document after a group of changes. SuspendUpdating blocks are unnecessary and should not be used. Performance of multiple modifications of the Revit document should be faster than RegenerationOption.Automatic. Because this mode suspends all updates to the document, your application should not read data from the document after it has been modified until the document has been regenerated, or it runs the risk of accessing stale data. This mode will be only option in a future release.
See Also

Reference

Autodesk.Revit.Attributes Namespace


TransactionAttribute Class

The custom transaction attribute to control the transaction behavior of the external command.
Inheritance Hierarchy
SystemObject
SystemAttribute
Autodesk.Revit.AttributesTransactionAttribute

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TransactionAttribute : Attribute
Public Class TransactionAttribute
    Inherits Attribute
public ref class TransactionAttribute : public Attribute
type TransactionAttribute =
    class
        inherit Attribute
    end

The TransactionAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | TransactionAttribute | Constructs a new TransactionAttribute.
Top
Properties
 | Name | Description
Public property | Mode | Transaction mode.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.Attributes Namespace


TransactionAttribute Constructor

Constructs a new TransactionAttribute.

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TransactionAttribute(
    TransactionMode mode
)
Public Sub New (
    mode As TransactionMode
)
public:
TransactionAttribute(
    TransactionMode mode
)
new :
        mode : TransactionMode -> TransactionAttribute

Parameters

mode TransactionMode
See Also

Reference

TransactionAttribute Class
Autodesk.Revit.Attributes Namespace


TransactionAttribute Properties

The TransactionAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Mode | Transaction mode.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute)
Top
See Also

Reference

TransactionAttribute Class
Autodesk.Revit.Attributes Namespace


TransactionAttribute.Mode Property

TransactionAttributeMode Property

Transaction mode.

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TransactionMode Mode { get; }
Public ReadOnly Property Mode As TransactionMode
    Get
public:
property TransactionMode Mode {
    TransactionMode get ();
}
member Mode : TransactionMode with get

Property Value

TransactionMode
See Also

Reference

TransactionAttribute Class
Autodesk.Revit.Attributes Namespace


TransactionAttribute Methods

The TransactionAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

TransactionAttribute Class
Autodesk.Revit.Attributes Namespace


TransactionMode Enumeration

All transaction modes supported by Revit external commands.

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum TransactionMode
Public Enumeration TransactionMode
public enum class TransactionMode
type TransactionMode
Members
Member name | Value | Description
Manual | 1 | The API framework will not create a transaction (but will create an outer group to roll back all changes if the external command returns a failure status). Instead, you may use combinations of transactions, sub-transactions, and groups. You will have to follow all rules regarding use of transactions and related classes. You will have to give your transactions names, which will then appear in the undo menu. Revit will check that all transactions (also groups and sub-transaction) are properly closed upon return from an external command. If not, it will discard all changes to the model.
ReadOnly | 2 | No transaction (nor group) will be created, and no transaction may be created for the lifetime of the command. The External command may use methods that only read from the model, but not methods that write anything to it. Exceptions will be thrown if the command either tries to start a transaction (or group) or attempts to write to the model.
See Also

Reference

Autodesk.Revit.Attributes Namespace


Autodesk.Revit.Creation Namespace

Classes
 | Class | Description
Public class | Application | The Application Creation object is used to create new instances of utility objects.
Public class | AreaCreationData | A class which wraps the arguments of Area for batch creation
Public class | Document | The Document Creation object is used to create new instances of elements within the Autodesk Revit project.
Public class | FamilyInstanceCreationData | A class which wraps the arguments of FamilyInstance for batch creation.
Public class | FamilyItemFactory | The Family Item Factory object is used to create new instances of elements within the Autodesk Revit Family.
Public class | ItemFactoryBase | The ItemFactoryBase object is used to create new instances of elements within the Autodesk Revit document.
Enumerations
 | Enumeration | Description
Public enumeration | eRefFace | Indicates the reference face. The Opening will be created at the direction perpendicular to the reference face.


Application Class

The Application Creation object is used to create new instances of utility objects.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.CreationApplication

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Application : APIObject
Public Class Application
    Inherits APIObject
public ref class Application : public APIObject
type Application =
    class
        inherit APIObject
    end

The Application type exposes the following members.

Properties
Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | NewAreaCreationData | Creates an object which wraps the arguments of Area for batch creation.
Public method | NewBoundingBoxUV | Creates an empty two-dimensional rectangle.
Public method | NewBoundingBoxUV(Double, Double, Double, Double) | Creates a two-dimensional rectangle with supplied values.
Public method | NewBoundingBoxXYZ | Creates a three-dimensional rectangular box.
Public method | NewCategorySet | Creates a new instance of a set specifically for holding category objects.
 | NewColor | Returns a new color object.
Public method | NewCombinableElementArray | Returns an array that can hold combinable element objects.
Public method | NewCurveArrArray | Creates an empty array that can store geometric curve loops.
Public method | NewCurveArray | Creates an empty array that can store geometric curves.
Public method | NewCurveLoopsProfile | Creates a new CurveLoopsProfile object.
Public method | NewDoubleArray | Creates a new instance of a double array.
Public method | NewDWFExportOptions | Creates DWF Export options.
Public method | NewDWFXExportOptions | Creates DWFX Export options.
Public method | NewElementId | Creates a new Autodesk::Revit::DB::ElementId^ object.
Public method | NewElementSet | Creates a new instance of a set specifically for holding elements.
Public method | NewFaceArray | Creates a new instance of a face array.
Public method | NewFamilyInstanceCreationData(FamilySymbol, IListXYZ) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(Face, Line, FamilySymbol) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(Curve, FamilySymbol, Level, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(Face, XYZ, XYZ, FamilySymbol) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, Element, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, Level, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, Element, Level, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilySymbolProfile | Creates a new FamilySymbolProfile object.
Public method | NewFBXExportOptions | Creates 3D-Studio Max (FBX) Export options.
Public method | NewGBXMLImportOptions | Creates Green-Building XML Import options.
 | NewGeometryOptions | Creates an object to specify user preferences in parsing of geometry.
Public method | NewInstanceBinding | Creates a new empty instance binding object.
Public method | NewInstanceBinding(CategorySet) | Creates a new instance binding object containing the categories passed as a parameter.
Public method | NewIntersectionResultArray | Creates a new instance of an IntersectionResult array.
Public method | NewPointOnEdge | Create a PointOnEdge object which is used to define the placement of a ReferencePoint.
Public method | NewPointOnEdgeEdgeIntersection | Construct a PointOnEdgeEdgeIntersection object which is used to define the placement of a ReferencePoint given two references to edge.
Public method | NewPointOnEdgeFaceIntersection | Construct a PointOnEdgeFaceIntersection object which is used to define the placement of a ReferencePoint given a references to edge and a reference to face.
Public method | NewPointOnFace | Construct a PointOnFace object which is used to define the placement of a ReferencePoint given a reference and a location on the face.
Public method | NewPointOnPlane | Construct a PointOnPlane object which is used to define the placement of a ReferencePoint from its property values.
Public method | NewPointRelativeToPoint | Create a PointRelativeToPoint object, which is used to define the placement of a ReferencePoint relative to a host point.
Public method | NewProjectPosition | Creates a new project position object.
Public method | NewReferenceArray | Creates a new instance of a reference array.
Public method | NewReferencePointArray | Creates an empty array that can store ReferencePoint objects.
Public method | NewSpaceSet | Creates a new instance of a space set.
Public method | NewTypeBinding | Creates a new empty type binding object.
Public method | NewTypeBinding(CategorySet) | Creates a new type binding object containing the categories passed as a parameter.
Public method | NewUV | Creates a UV object at the origin.
Public method | NewUV(UV) | Creates a UV object by copying the supplied UV object.
Public method | NewUV(Double, Double) | Creates a UV object representing coordinates in 2-space with supplied values.
Public method | NewVertexIndexPair | Creates a new VertexIndexPair object.
Public method | NewVertexIndexPairArray | Returns an array that can hold VertexIndexPair objects.
Public method | NewViewSet | Creates a new instance of a View set.
Public method | NewXYZ | Creates a XYZ object at the origin.
Public method | NewXYZ(XYZ) | Creates a XYZ object by copying the supplied XYZ object.
Public method | NewXYZ(Double, Double, Double) | Creates a XYZ object representing coordinates in 3-space with supplied values.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
General purpose objects can be generated by this creation object. Creating objects via this object ensures that they will be correctly constructed and will reside in the Autodesk Revit memory space.
See Also

Reference

Autodesk.Revit.Creation Namespace


Application Properties

The Application type exposes the following members.

Properties
Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

Application Class
Autodesk.Revit.Creation Namespace


Application Methods

The Application type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | NewAreaCreationData | Creates an object which wraps the arguments of Area for batch creation.
Public method | NewBoundingBoxUV | Creates an empty two-dimensional rectangle.
Public method | NewBoundingBoxUV(Double, Double, Double, Double) | Creates a two-dimensional rectangle with supplied values.
Public method | NewBoundingBoxXYZ | Creates a three-dimensional rectangular box.
Public method | NewCategorySet | Creates a new instance of a set specifically for holding category objects.
 | NewColor | Returns a new color object.
Public method | NewCombinableElementArray | Returns an array that can hold combinable element objects.
Public method | NewCurveArrArray | Creates an empty array that can store geometric curve loops.
Public method | NewCurveArray | Creates an empty array that can store geometric curves.
Public method | NewCurveLoopsProfile | Creates a new CurveLoopsProfile object.
Public method | NewDoubleArray | Creates a new instance of a double array.
Public method | NewDWFExportOptions | Creates DWF Export options.
Public method | NewDWFXExportOptions | Creates DWFX Export options.
Public method | NewElementId | Creates a new Autodesk::Revit::DB::ElementId^ object.
Public method | NewElementSet | Creates a new instance of a set specifically for holding elements.
Public method | NewFaceArray | Creates a new instance of a face array.
Public method | NewFamilyInstanceCreationData(FamilySymbol, IListXYZ) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(Face, Line, FamilySymbol) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(Curve, FamilySymbol, Level, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(Face, XYZ, XYZ, FamilySymbol) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, Element, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, Level, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, Element, Level, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilySymbolProfile | Creates a new FamilySymbolProfile object.
Public method | NewFBXExportOptions | Creates 3D-Studio Max (FBX) Export options.
Public method | NewGBXMLImportOptions | Creates Green-Building XML Import options.
 | NewGeometryOptions | Creates an object to specify user preferences in parsing of geometry.
Public method | NewInstanceBinding | Creates a new empty instance binding object.
Public method | NewInstanceBinding(CategorySet) | Creates a new instance binding object containing the categories passed as a parameter.
Public method | NewIntersectionResultArray | Creates a new instance of an IntersectionResult array.
Public method | NewPointOnEdge | Create a PointOnEdge object which is used to define the placement of a ReferencePoint.
Public method | NewPointOnEdgeEdgeIntersection | Construct a PointOnEdgeEdgeIntersection object which is used to define the placement of a ReferencePoint given two references to edge.
Public method | NewPointOnEdgeFaceIntersection | Construct a PointOnEdgeFaceIntersection object which is used to define the placement of a ReferencePoint given a references to edge and a reference to face.
Public method | NewPointOnFace | Construct a PointOnFace object which is used to define the placement of a ReferencePoint given a reference and a location on the face.
Public method | NewPointOnPlane | Construct a PointOnPlane object which is used to define the placement of a ReferencePoint from its property values.
Public method | NewPointRelativeToPoint | Create a PointRelativeToPoint object, which is used to define the placement of a ReferencePoint relative to a host point.
Public method | NewProjectPosition | Creates a new project position object.
Public method | NewReferenceArray | Creates a new instance of a reference array.
Public method | NewReferencePointArray | Creates an empty array that can store ReferencePoint objects.
Public method | NewSpaceSet | Creates a new instance of a space set.
Public method | NewTypeBinding | Creates a new empty type binding object.
Public method | NewTypeBinding(CategorySet) | Creates a new type binding object containing the categories passed as a parameter.
Public method | NewUV | Creates a UV object at the origin.
Public method | NewUV(UV) | Creates a UV object by copying the supplied UV object.
Public method | NewUV(Double, Double) | Creates a UV object representing coordinates in 2-space with supplied values.
Public method | NewVertexIndexPair | Creates a new VertexIndexPair object.
Public method | NewVertexIndexPairArray | Returns an array that can hold VertexIndexPair objects.
Public method | NewViewSet | Creates a new instance of a View set.
Public method | NewXYZ | Creates a XYZ object at the origin.
Public method | NewXYZ(XYZ) | Creates a XYZ object by copying the supplied XYZ object.
Public method | NewXYZ(Double, Double, Double) | Creates a XYZ object representing coordinates in 3-space with supplied values.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Application Class
Autodesk.Revit.Creation Namespace


Application.NewAreaCreationData Method

ApplicationNewAreaCreationData Method

Creates an object which wraps the arguments of Area for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AreaCreationData NewAreaCreationData(
    ViewPlan areaView,
    UV point
)
Public Function NewAreaCreationData (
    areaView As ViewPlan,
    point As UV
) As AreaCreationData
public:
AreaCreationData^ NewAreaCreationData(
    ViewPlan^ areaView,
    UV^ point
)
member NewAreaCreationData :
        areaView : ViewPlan *
        point : UV -> AreaCreationData

Parameters

areaView ViewPlan
The view of area element.
point UV
A point which lies in an enclosed region of area boundary where the new area will reside.

Return Value

AreaCreationData
The object containing the data needed for area creation.
See Also

Reference

Application Class
Autodesk.Revit.Creation Namespace


Application.NewBoundingBoxUV Method

ApplicationNewBoundingBoxUV Method

Creates a two-dimensional rectangle.
Overload List
 | Name | Description
Public method | NewBoundingBoxUV | Creates an empty two-dimensional rectangle.
Public method | NewBoundingBoxUV(Double, Double, Double, Double) | Creates a two-dimensional rectangle with supplied values.
Top
See Also

Reference

Application Class
Autodesk.Revit.Creation Namespace


Application.NewBoundingBoxUV Method

ApplicationNewBoundingBoxUV Method

Creates an empty two-dimensional rectangle.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BoundingBoxUV NewBoundingBoxUV()
Public Function NewBoundingBoxUV As BoundingBoxUV
public:
BoundingBoxUV^ NewBoundingBoxUV()
member NewBoundingBoxUV : unit -> BoundingBoxUV

Return Value

BoundingBoxUV
See Also

Reference

Application Class
NewBoundingBoxUV Overload
Autodesk.Revit.Creation Namespace


Application.NewBoundingBoxUV(Double, Double, Double, Double) Method

ApplicationNewBoundingBoxUV(Double, Double, Double, Double) Method

Creates a two-dimensional rectangle with supplied values.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BoundingBoxUV NewBoundingBoxUV(
    double min_u,
    double min_v,
    double max_u,
    double max_v
)
Public Function NewBoundingBoxUV (
    min_u As Double,
    min_v As Double,
    max_u As Double,
    max_v As Double
) As BoundingBoxUV
public:
BoundingBoxUV^ NewBoundingBoxUV(
    double min_u,
    double min_v,
    double max_u,
    double max_v
)
member NewBoundingBoxUV :
        min_u : float *
        min_v : float *
        max_u : float *
        max_v : float -> BoundingBoxUV

Parameters

min_u Double
The first coordinate of min.
min_v Double
The second coordinate of min.
max_u Double
The first coordinate of max.
max_v Double
The second coordinate of max.

Return Value

BoundingBoxUV
See Also

Reference

Application Class
NewBoundingBoxUV Overload
Autodesk.Revit.Creation Namespace


Application.NewBoundingBoxXYZ Method

ApplicationNewBoundingBoxXYZ Method

Creates a three-dimensional rectangular box.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BoundingBoxXYZ NewBoundingBoxXYZ()
Public Function NewBoundingBoxXYZ As BoundingBoxXYZ
public:
BoundingBoxXYZ^ NewBoundingBoxXYZ()
member NewBoundingBoxXYZ : unit -> BoundingBoxXYZ

Return Value

BoundingBoxXYZ
See Also

Reference

Application Class
Autodesk.Revit.Creation Namespace


Application.NewCategorySet Method

ApplicationNewCategorySet Method

Creates a new instance of a set specifically for holding category objects.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CategorySet NewCategorySet()
Public Function NewCategorySet As CategorySet
public:
CategorySet^ NewCategorySet()
member NewCategorySet : unit -> CategorySet

Return Value

CategorySet
A new instance of a Category Set.
Remarks
This type of set is used during the creation of instance and type bindings.
See Also

Reference

Application Class
Autodesk.Revit.Creation Namespace


Application.NewColor Method

ApplicationNewColor Method

Returns a new color object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color NewColor()
Public Function NewColor As Color
public:
Color^ NewColor()
member NewColor : unit -> Color

Return Value

Color
The new color object.
Example
C#
VB
C++
F#
Copy
Color NewColorInfo(Autodesk.Revit.Creation.Application appCreation)
{
    // Create a new color
    Autodesk.Revit.DB.Color color = appCreation.NewColor();

    // Set its RGB values
    color.Red = (byte)127;
    color.Green = (byte)64;
    color.Blue = (byte)32;

    // Display the color info
    StringBuilder info = new StringBuilder();
    info.AppendLine("Red:\t" + color.Red.ToString());
    info.AppendLine("Green:\t" + color.Green.ToString());
    info.AppendLine("Blue:\t" + color.Blue.ToString());

    TaskDialog.Show("Revit",info.ToString());

    return color;
}
Private Function NewColorInfo(appCreation As Autodesk.Revit.Creation.Application) As Color
    ' Create a new color
    Dim color As Autodesk.Revit.DB.Color = appCreation.NewColor()

    ' Set its RGB values
    color.Red = CByte(127)
    color.Green = CByte(64)
    color.Blue = CByte(32)

    ' Display the color info
    Dim info As New StringBuilder()
    info.AppendLine("Red:" & vbTab & color.Red.ToString())
    info.AppendLine("Green:" & vbTab & color.Green.ToString())
    info.AppendLine("Blue:" & vbTab & color.Blue.ToString())

    TaskDialog.Show("Revit", info.ToString())

    Return color
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Application Class
Autodesk.Revit.Creation Namespace


Application.NewCombinableElementArray Method

ApplicationNewCombinableElementArray Method

Returns an array that can hold combinable element objects.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CombinableElementArray NewCombinableElementArray()
Public Function NewCombinableElementArray As CombinableElementArray
public:
CombinableElementArray^ NewCombinableElementArray()
member NewCombinableElementArray : unit -> CombinableElementArray

Return Value

CombinableElementArray
An empty array that can contain any CombinableElement derived objects.
See Also

Reference

Application Class
Autodesk.Revit.Creation Namespace


Application.NewCurveArrArray Method

ApplicationNewCurveArrArray Method

Creates an empty array that can store geometric curve loops.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurveArrArray NewCurveArrArray()
Public Function NewCurveArrArray As CurveArrArray
public:
CurveArrArray^ NewCurveArrArray()
member NewCurveArrArray : unit -> CurveArrArray

Return Value

CurveArrArray
The empty array of curve loops.
See Also

Reference

Application Class
Autodesk.Revit.Creation Namespace


Application.NewCurveArray Method

ApplicationNewCurveArray Method

Creates an empty array that can store geometric curves.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurveArray NewCurveArray()
Public Function NewCurveArray As CurveArray
public:
CurveArray^ NewCurveArray()
member NewCurveArray : unit -> CurveArray

Return Value

CurveArray
An empty array that can hold geometric curves.
Remarks
This method can be used to create an array that can hold any curve type object. This array can be then passed to methods, such as NewAreaLoad, to represent the geometry for the boundary of the load.
See Also

Reference

Application Class
Autodesk.Revit.Creation Namespace


Application.NewCurveLoopsProfile Method

ApplicationNewCurveLoopsProfile Method

Creates a new CurveLoopsProfile object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurveLoopsProfile NewCurveLoopsProfile(
    CurveArrArray curveLoops
)
Public Function NewCurveLoopsProfile (
    curveLoops As CurveArrArray
) As CurveLoopsProfile
public:
CurveLoopsProfile^ NewCurveLoopsProfile(
    CurveArrArray^ curveLoops
)
member NewCurveLoopsProfile :
        curveLoops : CurveArrArray -> CurveLoopsProfile

Parameters

curveLoops CurveArrArray
The curve loops of the Profile.

Return Value

CurveLoopsProfile
The new CurveLoopsProfile object.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the argument is .
See Also

Reference

Application Class
Autodesk.Revit.Creation Namespace


Application.NewDoubleArray Method

ApplicationNewDoubleArray Method

Creates a new instance of a double array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DoubleArray NewDoubleArray()
Public Function NewDoubleArray As DoubleArray
public:
DoubleArray^ NewDoubleArray()
member NewDoubleArray : unit -> DoubleArray

Return Value

DoubleArray
See Also

Reference

Application Class
Autodesk.Revit.Creation Namespace


Application.NewDWFExportOptions Method

ApplicationNewDWFExportOptions Method

Creates DWF Export options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DWFExportOptions NewDWFExportOptions()
Public Function NewDWFExportOptions As DWFExportOptions
public:
DWFExportOptions^ NewDWFExportOptions()
member NewDWFExportOptions : unit -> DWFExportOptions

Return Value

DWFExportOptions
See Also

Reference

Application Class
Autodesk.Revit.Creation Namespace


Application.NewDWFXExportOptions Method

ApplicationNewDWFXExportOptions Method

Creates DWFX Export options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DWFXExportOptions NewDWFXExportOptions()
Public Function NewDWFXExportOptions As DWFXExportOptions
public:
DWFXExportOptions^ NewDWFXExportOptions()
member NewDWFXExportOptions : unit -> DWFXExportOptions

Return Value

DWFXExportOptions
See Also

Reference

Application Class
Autodesk.Revit.Creation Namespace


Application.NewElementId Method

ApplicationNewElementId Method

Creates a new Autodesk::Revit::DB::ElementId^ object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId NewElementId()
Public Function NewElementId As ElementId
public:
ElementId^ NewElementId()
member NewElementId : unit -> ElementId

Return Value

ElementId
The new Autodesk::Revit::DB::ElementId^ object.
See Also

Reference

Application Class
Autodesk.Revit.Creation Namespace


Application.NewElementSet Method

ApplicationNewElementSet Method

Creates a new instance of a set specifically for holding elements.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementSet NewElementSet()
Public Function NewElementSet As ElementSet
public:
ElementSet^ NewElementSet()
member NewElementSet : unit -> ElementSet

Return Value

ElementSet
A new Element Set.
Remarks
This is a general purpose set for passing elements to and from methods.
See Also

Reference

Application Class
Autodesk.Revit.Creation Namespace


Application.NewFaceArray Method

ApplicationNewFaceArray Method

Creates a new instance of a face array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FaceArray NewFaceArray()
Public Function NewFaceArray As FaceArray
public:
FaceArray^ NewFaceArray()
member NewFaceArray : unit -> FaceArray

Return Value

FaceArray
See Also

Reference

Application Class
Autodesk.Revit.Creation Namespace


Application.NewFamilyInstanceCreationData Method

ApplicationNewFamilyInstanceCreationData Method

Creates an adaptive component which wraps the arguments of NewFamilyInstance() for batch creation.
Overload List
 | Name | Description
Public method | NewFamilyInstanceCreationData(FamilySymbol, IListXYZ) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(Face, Line, FamilySymbol) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(Curve, FamilySymbol, Level, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(Face, XYZ, XYZ, FamilySymbol) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, Element, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, Level, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, Element, Level, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Top
See Also

Reference

Application Class
Autodesk.Revit.Creation Namespace


Application.NewFamilyInstanceCreationData(FamilySymbol, IList<XYZ>) Method

ApplicationNewFamilyInstanceCreationData(FamilySymbol, IListXYZ) Method

Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    FamilySymbol symbol,
    IList<XYZ> adaptivePoints
)
Public Function NewFamilyInstanceCreationData (
    symbol As FamilySymbol,
    adaptivePoints As IList(Of XYZ)
) As FamilyInstanceCreationData
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData(
    FamilySymbol^ symbol,
    IList<XYZ^>^ adaptivePoints
)
member NewFamilyInstanceCreationData :
        symbol : FamilySymbol *
        adaptivePoints : IList<XYZ> -> FamilyInstanceCreationData

Parameters

symbol FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
adaptivePoints IList XYZ
The adaptive point location where the adaptive instance is to be placed.

Return Value

FamilyInstanceCreationData
See Also

Reference

Application Class
NewFamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


Application.NewFamilyInstanceCreationData(Face, Line, FamilySymbol) Method

ApplicationNewFamilyInstanceCreationData(Face, Line, FamilySymbol) Method

Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    Face face,
    Line position,
    FamilySymbol symbol
)
Public Function NewFamilyInstanceCreationData (
    face As Face,
    position As Line,
    symbol As FamilySymbol
) As FamilyInstanceCreationData
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData(
    Face^ face,
    Line^ position,
    FamilySymbol^ symbol
)
member NewFamilyInstanceCreationData :
        face : Face *
        position : Line *
        symbol : FamilySymbol -> FamilyInstanceCreationData

Parameters

face Face
A face of a geometry object.
position Line
A line on the face defining where the symbol is to be placed.
symbol FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.

Return Value

FamilyInstanceCreationData
See Also

Reference

Application Class
NewFamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


Application.NewFamilyInstanceCreationData(XYZ, FamilySymbol, StructuralType) Method

ApplicationNewFamilyInstanceCreationData(XYZ, FamilySymbol, StructuralType) Method

Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    StructuralType structuralType
)
Public Function NewFamilyInstanceCreationData (
    location As XYZ,
    symbol As FamilySymbol,
    structuralType As StructuralType
) As FamilyInstanceCreationData
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData(
    XYZ^ location,
    FamilySymbol^ symbol,
    StructuralType structuralType
)
member NewFamilyInstanceCreationData :
        location : XYZ *
        symbol : FamilySymbol *
        structuralType : StructuralType -> FamilyInstanceCreationData

Parameters

location XYZ
The physical location where the instance is to be placed.
symbol FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
structuralType StructuralType
Specify if the family instance is structural.

Return Value

FamilyInstanceCreationData
See Also

Reference

Application Class
NewFamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


Application.NewFamilyInstanceCreationData(Curve, FamilySymbol, Level, StructuralType) Method

ApplicationNewFamilyInstanceCreationData(Curve, FamilySymbol, Level, StructuralType) Method

Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    Curve curve,
    FamilySymbol symbol,
    Level level,
    StructuralType structuralType
)
Public Function NewFamilyInstanceCreationData (
    curve As Curve,
    symbol As FamilySymbol,
    level As Level,
    structuralType As StructuralType
) As FamilyInstanceCreationData
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData(
    Curve^ curve,
    FamilySymbol^ symbol,
    Level^ level,
    StructuralType structuralType
)
member NewFamilyInstanceCreationData :
        curve : Curve *
        symbol : FamilySymbol *
        level : Level *
        structuralType : StructuralType -> FamilyInstanceCreationData

Parameters

curve Curve
The curve where the instance is based.
symbol FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
level Level
A Level object that is used as the base level for the object.
structuralType StructuralType
If structural then specify the type of the component.

Return Value

FamilyInstanceCreationData
See Also

Reference

Application Class
NewFamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


Application.NewFamilyInstanceCreationData(Face, XYZ, XYZ, FamilySymbol) Method

ApplicationNewFamilyInstanceCreationData(Face, XYZ, XYZ, FamilySymbol) Method

Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    Face face,
    XYZ location,
    XYZ referenceDirection,
    FamilySymbol symbol
)
Public Function NewFamilyInstanceCreationData (
    face As Face,
    location As XYZ,
    referenceDirection As XYZ,
    symbol As FamilySymbol
) As FamilyInstanceCreationData
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData(
    Face^ face,
    XYZ^ location,
    XYZ^ referenceDirection,
    FamilySymbol^ symbol
)
member NewFamilyInstanceCreationData :
        face : Face *
        location : XYZ *
        referenceDirection : XYZ *
        symbol : FamilySymbol -> FamilyInstanceCreationData

Parameters

face Face
A face of a geometry object.
location XYZ
Point on the face where the instance is to be placed.
referenceDirection XYZ
A vector that defines the direction of the family instance.
symbol FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.

Return Value

FamilyInstanceCreationData
See Also

Reference

Application Class
NewFamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


Application.NewFamilyInstanceCreationData(XYZ, FamilySymbol, Element, StructuralType) Method

ApplicationNewFamilyInstanceCreationData(XYZ, FamilySymbol, Element, StructuralType) Method

Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    Element host,
    StructuralType structuralType
)
Public Function NewFamilyInstanceCreationData (
    location As XYZ,
    symbol As FamilySymbol,
    host As Element,
    structuralType As StructuralType
) As FamilyInstanceCreationData
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData(
    XYZ^ location,
    FamilySymbol^ symbol,
    Element^ host,
    StructuralType structuralType
)
member NewFamilyInstanceCreationData :
        location : XYZ *
        symbol : FamilySymbol *
        host : Element *
        structuralType : StructuralType -> FamilyInstanceCreationData

Parameters

location XYZ
The physical location where the instance is to be placed.
symbol FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
host Element
The object into which the family instance is to be inserted, often known as the host.
structuralType StructuralType
If structural then specify the type of the component.

Return Value

FamilyInstanceCreationData
See Also

Reference

Application Class
NewFamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


Application.NewFamilyInstanceCreationData(XYZ, FamilySymbol, Level, StructuralType) Method

ApplicationNewFamilyInstanceCreationData(XYZ, FamilySymbol, Level, StructuralType) Method

Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    Level level,
    StructuralType structuralType
)
Public Function NewFamilyInstanceCreationData (
    location As XYZ,
    symbol As FamilySymbol,
    level As Level,
    structuralType As StructuralType
) As FamilyInstanceCreationData
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData(
    XYZ^ location,
    FamilySymbol^ symbol,
    Level^ level,
    StructuralType structuralType
)
member NewFamilyInstanceCreationData :
        location : XYZ *
        symbol : FamilySymbol *
        level : Level *
        structuralType : StructuralType -> FamilyInstanceCreationData

Parameters

location XYZ
The physical location where the instance is to be placed.
symbol FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
level Level
A Level object that is used as the base level for the object.
structuralType StructuralType
If structural then specify the type of the component.

Return Value

FamilyInstanceCreationData
See Also

Reference

Application Class
NewFamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


Application.NewFamilyInstanceCreationData(XYZ, FamilySymbol, Element, Level, StructuralType) Method

ApplicationNewFamilyInstanceCreationData(XYZ, FamilySymbol, Element, Level, StructuralType) Method

Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    Element host,
    Level level,
    StructuralType structuralType
)
Public Function NewFamilyInstanceCreationData (
    location As XYZ,
    symbol As FamilySymbol,
    host As Element,
    level As Level,
    structuralType As StructuralType
) As FamilyInstanceCreationData
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData(
    XYZ^ location,
    FamilySymbol^ symbol,
    Element^ host,
    Level^ level,
    StructuralType structuralType
)
member NewFamilyInstanceCreationData :
        location : XYZ *
        symbol : FamilySymbol *
        host : Element *
        level : Level *
        structuralType : StructuralType -> FamilyInstanceCreationData

Parameters

location XYZ
The physical location where the instance is to be placed.
symbol FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
host Element
The object into which the family instance is to be inserted, often known as the host.
level Level
A Level object that is used as the base level for the object.
structuralType StructuralType
If structural then specify the type of the component.

Return Value

FamilyInstanceCreationData
See Also

Reference

Application Class
NewFamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


Application.NewFamilyInstanceCreationData(XYZ, FamilySymbol, XYZ, Element, StructuralType) Method

ApplicationNewFamilyInstanceCreationData(XYZ, FamilySymbol, XYZ, Element, StructuralType) Method

Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    XYZ referenceDirection,
    Element host,
    StructuralType structuralType
)
Public Function NewFamilyInstanceCreationData (
    location As XYZ,
    symbol As FamilySymbol,
    referenceDirection As XYZ,
    host As Element,
    structuralType As StructuralType
) As FamilyInstanceCreationData
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData(
    XYZ^ location,
    FamilySymbol^ symbol,
    XYZ^ referenceDirection,
    Element^ host,
    StructuralType structuralType
)
member NewFamilyInstanceCreationData :
        location : XYZ *
        symbol : FamilySymbol *
        referenceDirection : XYZ *
        host : Element *
        structuralType : StructuralType -> FamilyInstanceCreationData

Parameters

location XYZ
The physical location where the instance is to be placed.
symbol FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
referenceDirection XYZ
A vector that dictates the direction of certain family instances.
host Element
The object into which the family instance is to be inserted, often known as the host.
structuralType StructuralType
If structural then specify the type of the component.

Return Value

FamilyInstanceCreationData
See Also

Reference

Application Class
NewFamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


Application.NewFamilySymbolProfile Method

ApplicationNewFamilySymbolProfile Method

Creates a new FamilySymbolProfile object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilySymbolProfile NewFamilySymbolProfile(
    FamilySymbol familySymbol
)
Public Function NewFamilySymbolProfile (
    familySymbol As FamilySymbol
) As FamilySymbolProfile
public:
FamilySymbolProfile^ NewFamilySymbolProfile(
    FamilySymbol^ familySymbol
)
member NewFamilySymbolProfile :
        familySymbol : FamilySymbol -> FamilySymbolProfile

Parameters

familySymbol FamilySymbol
The family symbol of the Profile.

Return Value

FamilySymbolProfile
The new FamilySymbolProfile object.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the argument familySymbol is .
See Also

Reference

Application Class
Autodesk.Revit.Creation Namespace


Application.NewFBXExportOptions Method

ApplicationNewFBXExportOptions Method

Creates 3D-Studio Max (FBX) Export options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FBXExportOptions NewFBXExportOptions()
Public Function NewFBXExportOptions As FBXExportOptions
public:
FBXExportOptions^ NewFBXExportOptions()
member NewFBXExportOptions : unit -> FBXExportOptions

Return Value

FBXExportOptions
See Also

Reference

Application Class
Autodesk.Revit.Creation Namespace


Application.NewGBXMLImportOptions Method

ApplicationNewGBXMLImportOptions Method

Creates Green-Building XML Import options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GBXMLImportOptions NewGBXMLImportOptions()
Public Function NewGBXMLImportOptions As GBXMLImportOptions
public:
GBXMLImportOptions^ NewGBXMLImportOptions()
member NewGBXMLImportOptions : unit -> GBXMLImportOptions

Return Value

GBXMLImportOptions
See Also

Reference

Application Class
Autodesk.Revit.Creation Namespace


Application.NewGeometryOptions Method

ApplicationNewGeometryOptions Method

Creates an object to specify user preferences in parsing of geometry.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Options NewGeometryOptions()
Public Function NewGeometryOptions As Options
public:
Options^ NewGeometryOptions()
member NewGeometryOptions : unit -> Options

Return Value

Options
Example
C#
VB
C++
F#
Copy
Autodesk.Revit.DB.Options geomOption = application.Create.NewGeometryOptions();
if (null != geomOption)
{
    geomOption.ComputeReferences = true;
    geomOption.DetailLevel = Autodesk.Revit.DB.ViewDetailLevel.Fine;

    // Either the DetailLevel or the View can be set, but not both
    //geomOption.View = commandData.Application.Application.ActiveDocument.ActiveView;

    TaskDialog.Show("Revit", "Geometry Option created successfully.");
}
Dim geomOption As Autodesk.Revit.DB.Options = application.Create.NewGeometryOptions()
If geomOption IsNot Nothing Then
    geomOption.ComputeReferences = True
    geomOption.DetailLevel = Autodesk.Revit.DB.ViewDetailLevel.Fine

    ' Either the DetailLevel or the View can be set, but not both
    'geomOption.View = commandData.Application.Application.ActiveDocument.ActiveView;

    TaskDialog.Show("Revit", "Geometry Option created successfully.")
End If

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Application Class
Autodesk.Revit.Creation Namespace


Application.NewInstanceBinding Method

ApplicationNewInstanceBinding Method

Creates a new instance binding object.
Overload List
 | Name | Description
Public method | NewInstanceBinding | Creates a new empty instance binding object.
Public method | NewInstanceBinding(CategorySet) | Creates a new instance binding object containing the categories passed as a parameter.
Top
See Also

Reference

Application Class
Autodesk.Revit.Creation Namespace


Application.NewInstanceBinding Method

ApplicationNewInstanceBinding Method

Creates a new empty instance binding object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public InstanceBinding NewInstanceBinding()
Public Function NewInstanceBinding As InstanceBinding
public:
InstanceBinding^ NewInstanceBinding()
member NewInstanceBinding : unit -> InstanceBinding

Return Value

InstanceBinding
A new instance binding object.
Remarks
Instance binding objects are used for attaching shared parameter definitions to all instances of an element within a category. Categories can be added to the instance binding via the Categories property of the InstanceBinding object
See Also

Reference

Application Class
NewInstanceBinding Overload
Autodesk.Revit.Creation Namespace


Application.NewInstanceBinding(CategorySet) Method

ApplicationNewInstanceBinding(CategorySet) Method

Creates a new instance binding object containing the categories passed as a parameter.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public InstanceBinding NewInstanceBinding(
    CategorySet categorySet
)
Public Function NewInstanceBinding (
    categorySet As CategorySet
) As InstanceBinding
public:
InstanceBinding^ NewInstanceBinding(
    CategorySet^ categorySet
)
member NewInstanceBinding :
        categorySet : CategorySet -> InstanceBinding

Parameters

categorySet CategorySet
A set of categories that will be added to the binding.

Return Value

InstanceBinding
A new instance binding object.
Remarks
Instance binding objects are used for attaching shared parameter definitions to all instances of an element within a category.
See Also

Reference

Application Class
NewInstanceBinding Overload
Autodesk.Revit.Creation Namespace


Application.NewIntersectionResultArray Method

ApplicationNewIntersectionResultArray Method

Creates a new instance of an IntersectionResult array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IntersectionResultArray NewIntersectionResultArray()
Public Function NewIntersectionResultArray As IntersectionResultArray
public:
IntersectionResultArray^ NewIntersectionResultArray()
member NewIntersectionResultArray : unit -> IntersectionResultArray

Return Value

IntersectionResultArray
See Also

Reference

Application Class
Autodesk.Revit.Creation Namespace


Application.NewPointOnEdge Method

ApplicationNewPointOnEdge Method

Create a PointOnEdge object which is used to define the placement of a ReferencePoint.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PointOnEdge NewPointOnEdge(
    Reference edgeReference,
    PointLocationOnCurve locationOnCurve
)
Public Function NewPointOnEdge (
    edgeReference As Reference,
    locationOnCurve As PointLocationOnCurve
) As PointOnEdge
public:
PointOnEdge^ NewPointOnEdge(
    Reference^ edgeReference,
    PointLocationOnCurve^ locationOnCurve
)
member NewPointOnEdge :
        edgeReference : Reference *
        locationOnCurve : PointLocationOnCurve -> PointOnEdge

Parameters

edgeReference Reference
The reference whose edge the object will be created on.
locationOnCurve PointLocationOnCurve
The location on the edge.

Return Value

PointOnEdge
If creation was successful then a new object is returned, otherwise an exception with failure information will be thrown.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument edgeReference or locationOnCurve is .
See Also

Reference

Application Class
Autodesk.Revit.Creation Namespace


Application.NewPointOnEdgeEdgeIntersection Method

ApplicationNewPointOnEdgeEdgeIntersection Method

Construct a PointOnEdgeEdgeIntersection object which is used to define the placement of a ReferencePoint given two references to edge.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PointOnEdgeEdgeIntersection NewPointOnEdgeEdgeIntersection(
    Reference edgeReference1,
    Reference edgeReference2
)
Public Function NewPointOnEdgeEdgeIntersection (
    edgeReference1 As Reference,
    edgeReference2 As Reference
) As PointOnEdgeEdgeIntersection
public:
PointOnEdgeEdgeIntersection^ NewPointOnEdgeEdgeIntersection(
    Reference^ edgeReference1,
    Reference^ edgeReference2
)
member NewPointOnEdgeEdgeIntersection :
        edgeReference1 : Reference *
        edgeReference2 : Reference -> PointOnEdgeEdgeIntersection

Parameters

edgeReference1 Reference
The first edge reference.
edgeReference2 Reference
The second edge reference.

Return Value

PointOnEdgeEdgeIntersection
A new PointOnEdgeEdgeIntersection object.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument edgeReference1 or edgeReference2 is .
See Also

Reference

Application Class
Autodesk.Revit.Creation Namespace


Application.NewPointOnEdgeFaceIntersection Method

ApplicationNewPointOnEdgeFaceIntersection Method

Construct a PointOnEdgeFaceIntersection object which is used to define the placement of a ReferencePoint given a references to edge and a reference to face.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PointOnEdgeFaceIntersection NewPointOnEdgeFaceIntersection(
    Reference edgeReference,
    Reference faceReference,
    bool orientWithEdge
)
Public Function NewPointOnEdgeFaceIntersection (
    edgeReference As Reference,
    faceReference As Reference,
    orientWithEdge As Boolean
) As PointOnEdgeFaceIntersection
public:
PointOnEdgeFaceIntersection^ NewPointOnEdgeFaceIntersection(
    Reference^ edgeReference,
    Reference^ faceReference,
    bool orientWithEdge
)
member NewPointOnEdgeFaceIntersection :
        edgeReference : Reference *
        faceReference : Reference *
        orientWithEdge : bool -> PointOnEdgeFaceIntersection

Parameters

edgeReference Reference
The edge reference.
faceReference Reference
The face reference.
orientWithEdge Boolean

Return Value

PointOnEdgeFaceIntersection
A new PointOnEdgeFaceIntersection object.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument edgeReference or faceReference is .
See Also

Reference

Application Class
Autodesk.Revit.Creation Namespace


Application.NewPointOnFace Method

ApplicationNewPointOnFace Method

Construct a PointOnFace object which is used to define the placement of a ReferencePoint given a reference and a location on the face.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PointOnFace NewPointOnFace(
    Reference faceReference,
    UV uv
)
Public Function NewPointOnFace (
    faceReference As Reference,
    uv As UV
) As PointOnFace
public:
PointOnFace^ NewPointOnFace(
    Reference^ faceReference,
    UV^ uv
)
member NewPointOnFace :
        faceReference : Reference *
        uv : UV -> PointOnFace

Parameters

faceReference Reference
The reference whose face the object will be created on.
uv UV
A 2-dimensional position.

Return Value

PointOnFace
A new PointOnFace object.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument faceReference or uv is .
See Also

Reference

Application Class
Autodesk.Revit.Creation Namespace


Application.NewPointOnPlane Method

ApplicationNewPointOnPlane Method

Construct a PointOnPlane object which is used to define the placement of a ReferencePoint from its property values.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PointOnPlane NewPointOnPlane(
    Reference planeReference,
    UV position,
    UV xvec,
    double offset
)
Public Function NewPointOnPlane (
    planeReference As Reference,
    position As UV,
    xvec As UV,
    offset As Double
) As PointOnPlane
public:
PointOnPlane^ NewPointOnPlane(
    Reference^ planeReference,
    UV^ position,
    UV^ xvec,
    double offset
)
member NewPointOnPlane :
        planeReference : Reference *
        position : UV *
        xvec : UV *
        offset : float -> PointOnPlane

Parameters

planeReference Reference
A reference to some plane in the document. (Note: the reference must satisfy IsValidPlaneReference(), but this is not checked until this PointOnPlane object is assigned to a ReferencePoint.)
position UV
Coordinates of the point's projection onto the plane; see the Position property.
xvec UV
The direction of the point's X-coordinate vector in the plane's coordinates; see the XVec property. Optional; default value is (1, 0).
offset Double
Signed offset from the plane; see the Offset property.

Return Value

PointOnPlane
A new PointOnPlane object with 2-dimensional Position, XVec, and Offset properties set to match the given 3-dimensional arguments.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument planeReference or position or xvec is or offset is not a valid double value.
See Also

Reference

Application Class
Autodesk.Revit.Creation Namespace


Application.NewPointRelativeToPoint Method

ApplicationNewPointRelativeToPoint Method

Create a PointRelativeToPoint object, which is used to define the placement of a ReferencePoint relative to a host point.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PointRelativeToPoint NewPointRelativeToPoint(
    Reference hostPointReference
)
Public Function NewPointRelativeToPoint (
    hostPointReference As Reference
) As PointRelativeToPoint
public:
PointRelativeToPoint^ NewPointRelativeToPoint(
    Reference^ hostPointReference
)
member NewPointRelativeToPoint :
        hostPointReference : Reference -> PointRelativeToPoint

Parameters

hostPointReference Reference
The reference of the host point.

Return Value

PointRelativeToPoint
If creation is successful then a new PointRelativeToPoint object is returned, otherwise an exception with failure information will be thrown.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument hostPointReference is .
See Also

Reference

Application Class
Autodesk.Revit.Creation Namespace


Application.NewProjectPosition Method

ApplicationNewProjectPosition Method

Creates a new project position object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ProjectPosition NewProjectPosition(
    double ew,
    double ns,
    double elevation,
    double angle
)
Public Function NewProjectPosition (
    ew As Double,
    ns As Double,
    elevation As Double,
    angle As Double
) As ProjectPosition
public:
ProjectPosition^ NewProjectPosition(
    double ew,
    double ns,
    double elevation,
    double angle
)
member NewProjectPosition :
        ew : float *
        ns : float *
        elevation : float *
        angle : float -> ProjectPosition

Parameters

ew Double
East to West offset in feet.
ns Double
North to South offset in feet.
elevation Double
Elevation above sea level in feet.
angle Double
Rotation angle away from true north in the range of -PI to +PI.

Return Value

ProjectPosition
Remarks
This object contains offset information and is used by the project location object for setting the project location relative to the site location. Measurements are in feet and radians.
See Also

Reference

Application Class
Autodesk.Revit.Creation Namespace


Application.NewReferenceArray Method

ApplicationNewReferenceArray Method

Creates a new instance of a reference array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReferenceArray NewReferenceArray()
Public Function NewReferenceArray As ReferenceArray
public:
ReferenceArray^ NewReferenceArray()
member NewReferenceArray : unit -> ReferenceArray

Return Value

ReferenceArray
See Also

Reference

Application Class
Autodesk.Revit.Creation Namespace


Application.NewReferencePointArray Method

ApplicationNewReferencePointArray Method

Creates an empty array that can store ReferencePoint objects.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReferencePointArray NewReferencePointArray()
Public Function NewReferencePointArray As ReferencePointArray
public:
ReferencePointArray^ NewReferencePointArray()
member NewReferencePointArray : unit -> ReferencePointArray

Return Value

ReferencePointArray
An empty array that can hold ReferencePoint objects.
Remarks
This method can be used to create an array that can hold ReferencePoint objects. This array can be then passed to methods, such as NewCurveByPoints, to represent two or more PointElements.
See Also

Reference

Application Class
Autodesk.Revit.Creation Namespace


Application.NewSpaceSet Method

ApplicationNewSpaceSet Method

Creates a new instance of a space set.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SpaceSet NewSpaceSet()
Public Function NewSpaceSet As SpaceSet
public:
SpaceSet^ NewSpaceSet()
member NewSpaceSet : unit -> SpaceSet

Return Value

SpaceSet
See Also

Reference

Application Class
Autodesk.Revit.Creation Namespace


Application.NewTypeBinding Method

ApplicationNewTypeBinding Method

Creates a new type binding object.
Overload List
 | Name | Description
Public method | NewTypeBinding | Creates a new empty type binding object.
Public method | NewTypeBinding(CategorySet) | Creates a new type binding object containing the categories passed as a parameter.
Top
See Also

Reference

Application Class
Autodesk.Revit.Creation Namespace


Application.NewTypeBinding Method

ApplicationNewTypeBinding Method

Creates a new empty type binding object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TypeBinding NewTypeBinding()
Public Function NewTypeBinding As TypeBinding
public:
TypeBinding^ NewTypeBinding()
member NewTypeBinding : unit -> TypeBinding

Return Value

TypeBinding
A new type binding object.
Remarks
Type binding objects are used for attaching shared parameter definitions to a type within a category. Categories can be added to the instance binding via the Categories property of the InstanceBinding object
See Also

Reference

Application Class
NewTypeBinding Overload
Autodesk.Revit.Creation Namespace


Application.NewTypeBinding(CategorySet) Method

ApplicationNewTypeBinding(CategorySet) Method

Creates a new type binding object containing the categories passed as a parameter.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TypeBinding NewTypeBinding(
    CategorySet categorySet
)
Public Function NewTypeBinding (
    categorySet As CategorySet
) As TypeBinding
public:
TypeBinding^ NewTypeBinding(
    CategorySet^ categorySet
)
member NewTypeBinding :
        categorySet : CategorySet -> TypeBinding

Parameters

categorySet CategorySet
A set of categories that will be added to the binding.

Return Value

TypeBinding
A new type binding object.
Remarks
Type binding objects are used for attaching shared parameter definitions to a type within a category.
See Also

Reference

Application Class
NewTypeBinding Overload
Autodesk.Revit.Creation Namespace


Application.NewUV Method

ApplicationNewUV Method

Creates a UV object representing coordinates in 2-space.
Overload List
 | Name | Description
Public method | NewUV | Creates a UV object at the origin.
Public method | NewUV(UV) | Creates a UV object by copying the supplied UV object.
Public method | NewUV(Double, Double) | Creates a UV object representing coordinates in 2-space with supplied values.
Top
See Also

Reference

Application Class
Autodesk.Revit.Creation Namespace


Application.NewUV Method

ApplicationNewUV Method

Creates a UV object at the origin.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public UV NewUV()
Public Function NewUV As UV
public:
UV^ NewUV()
member NewUV : unit -> UV

Return Value

UV
See Also

Reference

Application Class
NewUV Overload
Autodesk.Revit.Creation Namespace


Application.NewUV(UV) Method

ApplicationNewUV(UV) Method

Creates a UV object by copying the supplied UV object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public UV NewUV(
    UV uv
)
Public Function NewUV (
    uv As UV
) As UV
public:
UV^ NewUV(
    UV^ uv
)
member NewUV :
        uv : UV -> UV

Parameters

uv UV
The supplied UV object

Return Value

UV
See Also

Reference

Application Class
NewUV Overload
Autodesk.Revit.Creation Namespace


Application.NewUV(Double, Double) Method

ApplicationNewUV(Double, Double) Method

Creates a UV object representing coordinates in 2-space with supplied values.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public UV NewUV(
    double u,
    double v
)
Public Function NewUV (
    u As Double,
    v As Double
) As UV
public:
UV^ NewUV(
    double u,
    double v
)
member NewUV :
        u : float *
        v : float -> UV

Parameters

u Double
The first coordinate.
v Double
The second coordinate.

Return Value

UV
Exceptions
Exception | Condition
ArgumentException | Thrown when setting an infinite number to the U or V property.
See Also

Reference

Application Class
NewUV Overload
Autodesk.Revit.Creation Namespace


Application.NewVertexIndexPair Method

ApplicationNewVertexIndexPair Method

Creates a new VertexIndexPair object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VertexIndexPair NewVertexIndexPair(
    int iTop,
    int iBottom
)
Public Function NewVertexIndexPair (
    iTop As Integer,
    iBottom As Integer
) As VertexIndexPair
public:
VertexIndexPair^ NewVertexIndexPair(
    int iTop,
    int iBottom
)
member NewVertexIndexPair :
        iTop : int *
        iBottom : int -> VertexIndexPair

Parameters

iTop Int32
The index of the vertex pair from the top profile of a blend.
iBottom Int32
The index of the vertex pair from the bottom profile of a blend.

Return Value

VertexIndexPair
The new VertexIndexPair object.
See Also

Reference

Application Class
Autodesk.Revit.Creation Namespace


Application.NewVertexIndexPairArray Method

ApplicationNewVertexIndexPairArray Method

Returns an array that can hold VertexIndexPair objects.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VertexIndexPairArray NewVertexIndexPairArray()
Public Function NewVertexIndexPairArray As VertexIndexPairArray
public:
VertexIndexPairArray^ NewVertexIndexPairArray()
member NewVertexIndexPairArray : unit -> VertexIndexPairArray

Return Value

VertexIndexPairArray
The new VertexIndexPairArray objects.
See Also

Reference

Application Class
Autodesk.Revit.Creation Namespace


Application.NewViewSet Method

ApplicationNewViewSet Method

Creates a new instance of a View set.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ViewSet NewViewSet()
Public Function NewViewSet As ViewSet
public:
ViewSet^ NewViewSet()
member NewViewSet : unit -> ViewSet

Return Value

ViewSet
See Also

Reference

Application Class
Autodesk.Revit.Creation Namespace


Application.NewXYZ Method

ApplicationNewXYZ Method

Creates a XYZ object representing coordinates in 3-space.
Overload List
 | Name | Description
Public method | NewXYZ | Creates a XYZ object at the origin.
Public method | NewXYZ(XYZ) | Creates a XYZ object by copying the supplied XYZ object.
Public method | NewXYZ(Double, Double, Double) | Creates a XYZ object representing coordinates in 3-space with supplied values.
Top
See Also

Reference

Application Class
Autodesk.Revit.Creation Namespace


Application.NewXYZ Method

ApplicationNewXYZ Method

Creates a XYZ object at the origin.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ NewXYZ()
Public Function NewXYZ As XYZ
public:
XYZ^ NewXYZ()
member NewXYZ : unit -> XYZ

Return Value

XYZ
See Also

Reference

Application Class
NewXYZ Overload
Autodesk.Revit.Creation Namespace


Application.NewXYZ(XYZ) Method

ApplicationNewXYZ(XYZ) Method

Creates a XYZ object by copying the supplied XYZ object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ NewXYZ(
    XYZ xyz
)
Public Function NewXYZ (
    xyz As XYZ
) As XYZ
public:
XYZ^ NewXYZ(
    XYZ^ xyz
)
member NewXYZ :
        xyz : XYZ -> XYZ

Parameters

xyz XYZ
The supplied XYZ object

Return Value

XYZ
See Also

Reference

Application Class
NewXYZ Overload
Autodesk.Revit.Creation Namespace


Application.NewXYZ(Double, Double, Double) Method

ApplicationNewXYZ(Double, Double, Double) Method

Creates a XYZ object representing coordinates in 3-space with supplied values.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ NewXYZ(
    double x,
    double y,
    double z
)
Public Function NewXYZ (
    x As Double,
    y As Double,
    z As Double
) As XYZ
public:
XYZ^ NewXYZ(
    double x,
    double y,
    double z
)
member NewXYZ :
        x : float *
        y : float *
        z : float -> XYZ

Parameters

x Double
The first coordinate.
y Double
The second coordinate.
z Double
The third coordinate.

Return Value

XYZ
Exceptions
Exception | Condition
ArgumentException | Thrown when setting an infinite number to the X, Y or Z property.
See Also

Reference

Application Class
NewXYZ Overload
Autodesk.Revit.Creation Namespace


AreaCreationData Class

A class which wraps the arguments of Area for batch creation
Inheritance Hierarchy
SystemObject
Autodesk.Revit.CreationAreaCreationData

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AreaCreationData
Public Class AreaCreationData
public ref class AreaCreationData
type AreaCreationData = class end

The AreaCreationData type exposes the following members.

Constructors
 | Name | Description
Public method | AreaCreationData(Object) | Initializes a new instance of the AreaCreationData class
Public method | AreaCreationData(ViewPlan, UV) | The data needed to create a new area
Top
Properties
 | Name | Description
Public property | TagPoint | Specify the location of the area tag.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.Creation Namespace


AreaCreationData Constructor

Overload List
 | Name | Description
Public method | AreaCreationData(Object) | Initializes a new instance of the AreaCreationData class
Public method | AreaCreationData(ViewPlan, UV) | The data needed to create a new area
Top
See Also

Reference

AreaCreationData Class
Autodesk.Revit.Creation Namespace


AreaCreationData(Object) Constructor

Initializes a new instance of the AreaCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AreaCreationData(
    Object proxy
)
Public Sub New (
    proxy As Object
)
public:
AreaCreationData(
    Object^ proxy
)
new :
        proxy : Object -> AreaCreationData

Parameters

proxy Object
See Also

Reference

AreaCreationData Class
AreaCreationData Overload
Autodesk.Revit.Creation Namespace


AreaCreationData(ViewPlan, UV) Constructor

The data needed to create a new area

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AreaCreationData(
    ViewPlan areaView,
    UV point
)
Public Sub New (
    areaView As ViewPlan,
    point As UV
)
public:
AreaCreationData(
    ViewPlan^ areaView,
    UV^ point
)
new :
        areaView : ViewPlan *
        point : UV -> AreaCreationData

Parameters

areaView ViewPlan
The view of area element.
point UV
The point which lies in the enclosed region of AreaBoundaryLines to put the new created Area
See Also

Reference

AreaCreationData Class
AreaCreationData Overload
Autodesk.Revit.Creation Namespace


AreaCreationData Properties

The AreaCreationData type exposes the following members.

Properties
 | Name | Description
Public property | TagPoint | Specify the location of the area tag.
Top
See Also

Reference

AreaCreationData Class
Autodesk.Revit.Creation Namespace


AreaCreationData.TagPoint Property

AreaCreationDataTagPoint Property

Specify the location of the area tag.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public UV TagPoint { get; set; }
Public Property TagPoint As UV
    Get
    Set
public:
property UV^ TagPoint {
    UV^ get ();
    void set (UV^ value);
}
member TagPoint : UV with get, set

Property Value

UV
See Also

Reference

AreaCreationData Class
Autodesk.Revit.Creation Namespace


AreaCreationData Methods

The AreaCreationData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AreaCreationData Class
Autodesk.Revit.Creation Namespace


Document Class

The Document Creation object is used to create new instances of elements within the Autodesk Revit project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.CreationItemFactoryBase
Autodesk.Revit.CreationDocument

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Document : ItemFactoryBase
Public Class Document
    Inherits ItemFactoryBase
public ref class Document : public ItemFactoryBase
type Document =
    class
        inherit ItemFactoryBase
    end

The Document type exposes the following members.

Properties
Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | NewAlignment | Add a new locked alignment into the Autodesk Revit document. (Inherited from ItemFactoryBase)
Public method | NewArea | Creates a new area
 | NewAreaBoundaryConditions(Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Area BoundaryConditions element on a host element.
 | NewAreaBoundaryConditions(Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Area BoundaryConditions element on a reference.
Public method | NewAreaBoundaryLine | Creates a new boundary line as an Area border.
Public method | NewAreas | Creates new areas
Public method | NewAreaTag | Creates a new area tag.
Public method | NewCrossFitting | Add a new family instance of a cross fitting into the Autodesk Revit document, using four connectors.
Public method | NewCurtainSystem | Creates a new CurtainSystem element from a set of faces.
Public method | NewCurtainSystem2 | Creates a new CurtainSystem element from a set of face references.
Public method | NewDetailCurve | Creates a new detail curve element. (Inherited from ItemFactoryBase)
Public method | NewDetailCurveArray | Creates an array of new detail curve elements. (Inherited from ItemFactoryBase)
 | NewDimension(View, Line, ReferenceArray) | Creates a new linear dimension object using the default dimension style. (Inherited from ItemFactoryBase)
Public method | NewDimension(View, Line, ReferenceArray, DimensionType) | Creates a new linear dimension object using the specified dimension style. (Inherited from ItemFactoryBase)
Public method | NewElbowFitting | Add a new family instance of an elbow fitting into the Autodesk Revit document, using two connectors.
Public method | NewExtrusionRoof | Creates a new Extrusion Roof.
 | NewFamilyInstance(Face, Line, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a line on that face for its position, and a type/symbol. (Inherited from ItemFactoryBase)
 | NewFamilyInstance(Line, FamilySymbol, View) | Add a line based detail family instance into the Autodesk Revit document, using an line and a view where the instance should be placed. (Inherited from ItemFactoryBase)
 | NewFamilyInstance(Reference, Line, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a line on that face for its position, and a type/symbol. (Inherited from ItemFactoryBase)
Public method | NewFamilyInstance(XYZ, FamilySymbol, StructuralType) | Inserts a new instance of a family into the document, using a location and a type/symbol. (Inherited from ItemFactoryBase)
Public method | NewFamilyInstance(XYZ, FamilySymbol, View) | Add a new family instance into the Autodesk Revit document, using an origin and a view where the instance should be placed. (Inherited from ItemFactoryBase)
 | NewFamilyInstance(Curve, FamilySymbol, Level, StructuralType) | Inserts a new instance of a family into the document, using a curve, type/symbol and reference level.
 | NewFamilyInstance(Face, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol. (Inherited from ItemFactoryBase)
 | NewFamilyInstance(Reference, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a location, reference direction, and a type/symbol. (Inherited from ItemFactoryBase)
 | NewFamilyInstance(XYZ, FamilySymbol, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the host element. (Inherited from ItemFactoryBase)
Public method | NewFamilyInstance(XYZ, FamilySymbol, Level, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the level. (Inherited from ItemFactoryBase)
 | NewFamilyInstance(XYZ, FamilySymbol, Element, Level, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a base level.
 | NewFamilyInstance(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a reference direction. (Inherited from ItemFactoryBase)
 | NewFamilyInstances2 | Creates Family instances within the document. (Inherited from ItemFactoryBase)
Public method | NewFascia(FasciaType, Reference) | Creates a fascia along a reference.
Public method | NewFascia(FasciaType, ReferenceArray) | Creates a fascia along a reference array.
Public method | NewFlexDuct(IListXYZ, FlexDuctType) | Adds a new flexible duct into the document, using a point array and duct type.
Public method | NewFlexDuct(Connector, Connector, FlexDuctType) | Adds a new flexible duct into the document, using two connector, and duct type.
Public method | NewFlexDuct(Connector, IListXYZ, FlexDuctType) | Adds a new flexible duct into the document, using a connector, point array and duct type.
Public method | NewFlexPipe(IListXYZ, FlexPipeType) | Adds a new flexible pipe into the document, using a point array and pipe type.
Public method | NewFlexPipe(Connector, Connector, FlexPipeType) | Adds a new flexible pipe into the document, using two connector, and flexible pipe type.
Public method | NewFlexPipe(Connector, IListXYZ, FlexPipeType) | Adds a new flexible pipe into the document, using a connector, point array and pipe type.
 | NewFootPrintRoof | Creates a new FootPrintRoof element.
 | NewGroup | Creates a new type of group. (Inherited from ItemFactoryBase)
Public method | NewGutter(GutterType, Reference) | Creates a gutter along a reference.
Public method | NewGutter(GutterType, ReferenceArray) | Creates a gutter along a reference array.
 | NewLineBoundaryConditions(Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Line BoundaryConditions element on a host element.
 | NewLineBoundaryConditions(Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Line BoundaryConditions element on a reference.
 | NewMechanicalSystem | Creates a new MEP mechanical system element.
 | NewModelCurve | Creates a new model line element. (Inherited from ItemFactoryBase)
Public method | NewModelCurveArray | Creates an array of new model line elements. (Inherited from ItemFactoryBase)
Public method | NewOpening(Element, CurveArray, eRefFace) | Creates a new opening in a beam, brace and column.
Public method | NewOpening(Element, CurveArray, Boolean) | Creates a new opening in a roof, floor and ceiling.
Public method | NewOpening(Level, Level, CurveArray) | Creates a new shaft opening between a set of levels.
Public method | NewOpening(Wall, XYZ, XYZ) | Creates a rectangular opening on a wall.
Public method | NewPipingSystem | Creates a new MEP piping system element.
 | NewPointBoundaryConditions | Creates a new Point BoundaryConditions Element.
 | NewReferencePlane | Creates a new instance of ReferencePlane. (Inherited from ItemFactoryBase)
 | NewReferencePlane2 | Creates a new instance of ReferencePlane. (Inherited from ItemFactoryBase)
Public method | NewRoom(Phase) | Creates a new unplaced room and with an assigned phase.
 | NewRoom(Level, UV) | Creates a new room on a level at a specified point.
 | NewRoom(Room, PlanCircuit) | Creates a new room within the confines of a plan circuit, or places an unplaced room within the confines of the plan circuit.
Public method | NewRoomBoundaryLines | Creates a new boundary line as an Room border.
Public method | NewRooms2(Level) | Creates new rooms in each plan circuit found in the given level in the last phase.
Public method | NewRooms2(Level, Phase) | Creates new rooms in each plan circuit found in the given level in the given phase.
Public method | NewRooms2(Phase, Int32) | Creates new unplaced rooms in the given phase.
 | NewRoomTag | Creates a new RoomTag referencing a room in the host model or in a Revit link.
Public method | NewSlabEdge(SlabEdgeType, Reference) | Creates a slab edge along a reference.
Public method | NewSlabEdge(SlabEdgeType, ReferenceArray) | Creates a slab edge along a reference array.
Public method | NewSpace(Phase) | Creates a new unplaced space on a given phase.
Public method | NewSpace(Level, UV) | Creates a new space element on the given level at the given location.
Public method | NewSpace(Level, Phase, UV) | Creates a new space element on the given level, at the given location, and assigned to the given phase.
Public method | NewSpaceBoundaryLines | Creates a new boundary line as an Space border.
Public method | NewSpaces2(Phase, Int32) | Creates a set of new unplaced spaces on a given phase.
Public method | NewSpaces2(Level, Phase, View) | Creates new spaces on the available plan circuits of a the given level.
Public method | NewSpaceTag | Creates a new SpaceTag.
Public method | NewSpotCoordinate | Generate a new spot coordinate object within the project.
Public method | NewSpotElevation | Generate a new spot elevation object within the project.
Public method | NewTakeoffFitting | Add a new family instance of an takeoff fitting into the Autodesk Revit document, using one connector and one MEP curve.
Public method | NewTeeFitting | Add a new family instance of a tee fitting into the Autodesk Revit document, using three connectors.
Public method | NewTransitionFitting | Add a new family instance of an transition fitting into the Autodesk Revit document, using two connectors.
Public method | NewUnionFitting | Add a new family instance of an union fitting into the Autodesk Revit document, using two connectors.
Public method | NewZone | Creates a new Zone element.
Public method | PlaceGroup | Place an instance of a Model Group into the Autodesk Revit document, using a location and a group type. (Inherited from ItemFactoryBase)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The Document Creation object is a utility object that is used to create new instances of elements within the Autodesk Revit project. This object, available from the Document.Create property should be used to create elements instead of using New. This object ensures that the elements created are added to the document correctly.
See Also

Reference

Autodesk.Revit.Creation Namespace


Document Properties

The Document type exposes the following members.

Properties
Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

Document Class
Autodesk.Revit.Creation Namespace


Document Methods

The Document type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | NewAlignment | Add a new locked alignment into the Autodesk Revit document. (Inherited from ItemFactoryBase)
Public method | NewArea | Creates a new area
 | NewAreaBoundaryConditions(Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Area BoundaryConditions element on a host element.
 | NewAreaBoundaryConditions(Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Area BoundaryConditions element on a reference.
Public method | NewAreaBoundaryLine | Creates a new boundary line as an Area border.
Public method | NewAreas | Creates new areas
Public method | NewAreaTag | Creates a new area tag.
Public method | NewCrossFitting | Add a new family instance of a cross fitting into the Autodesk Revit document, using four connectors.
Public method | NewCurtainSystem | Creates a new CurtainSystem element from a set of faces.
Public method | NewCurtainSystem2 | Creates a new CurtainSystem element from a set of face references.
Public method | NewDetailCurve | Creates a new detail curve element. (Inherited from ItemFactoryBase)
Public method | NewDetailCurveArray | Creates an array of new detail curve elements. (Inherited from ItemFactoryBase)
 | NewDimension(View, Line, ReferenceArray) | Creates a new linear dimension object using the default dimension style. (Inherited from ItemFactoryBase)
Public method | NewDimension(View, Line, ReferenceArray, DimensionType) | Creates a new linear dimension object using the specified dimension style. (Inherited from ItemFactoryBase)
Public method | NewElbowFitting | Add a new family instance of an elbow fitting into the Autodesk Revit document, using two connectors.
Public method | NewExtrusionRoof | Creates a new Extrusion Roof.
 | NewFamilyInstance(Face, Line, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a line on that face for its position, and a type/symbol. (Inherited from ItemFactoryBase)
 | NewFamilyInstance(Line, FamilySymbol, View) | Add a line based detail family instance into the Autodesk Revit document, using an line and a view where the instance should be placed. (Inherited from ItemFactoryBase)
 | NewFamilyInstance(Reference, Line, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a line on that face for its position, and a type/symbol. (Inherited from ItemFactoryBase)
Public method | NewFamilyInstance(XYZ, FamilySymbol, StructuralType) | Inserts a new instance of a family into the document, using a location and a type/symbol. (Inherited from ItemFactoryBase)
Public method | NewFamilyInstance(XYZ, FamilySymbol, View) | Add a new family instance into the Autodesk Revit document, using an origin and a view where the instance should be placed. (Inherited from ItemFactoryBase)
 | NewFamilyInstance(Curve, FamilySymbol, Level, StructuralType) | Inserts a new instance of a family into the document, using a curve, type/symbol and reference level.
 | NewFamilyInstance(Face, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol. (Inherited from ItemFactoryBase)
 | NewFamilyInstance(Reference, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a location, reference direction, and a type/symbol. (Inherited from ItemFactoryBase)
 | NewFamilyInstance(XYZ, FamilySymbol, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the host element. (Inherited from ItemFactoryBase)
Public method | NewFamilyInstance(XYZ, FamilySymbol, Level, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the level. (Inherited from ItemFactoryBase)
 | NewFamilyInstance(XYZ, FamilySymbol, Element, Level, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a base level.
 | NewFamilyInstance(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a reference direction. (Inherited from ItemFactoryBase)
 | NewFamilyInstances2 | Creates Family instances within the document. (Inherited from ItemFactoryBase)
Public method | NewFascia(FasciaType, Reference) | Creates a fascia along a reference.
Public method | NewFascia(FasciaType, ReferenceArray) | Creates a fascia along a reference array.
Public method | NewFlexDuct(IListXYZ, FlexDuctType) | Adds a new flexible duct into the document, using a point array and duct type.
Public method | NewFlexDuct(Connector, Connector, FlexDuctType) | Adds a new flexible duct into the document, using two connector, and duct type.
Public method | NewFlexDuct(Connector, IListXYZ, FlexDuctType) | Adds a new flexible duct into the document, using a connector, point array and duct type.
Public method | NewFlexPipe(IListXYZ, FlexPipeType) | Adds a new flexible pipe into the document, using a point array and pipe type.
Public method | NewFlexPipe(Connector, Connector, FlexPipeType) | Adds a new flexible pipe into the document, using two connector, and flexible pipe type.
Public method | NewFlexPipe(Connector, IListXYZ, FlexPipeType) | Adds a new flexible pipe into the document, using a connector, point array and pipe type.
 | NewFootPrintRoof | Creates a new FootPrintRoof element.
 | NewGroup | Creates a new type of group. (Inherited from ItemFactoryBase)
Public method | NewGutter(GutterType, Reference) | Creates a gutter along a reference.
Public method | NewGutter(GutterType, ReferenceArray) | Creates a gutter along a reference array.
 | NewLineBoundaryConditions(Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Line BoundaryConditions element on a host element.
 | NewLineBoundaryConditions(Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Line BoundaryConditions element on a reference.
 | NewMechanicalSystem | Creates a new MEP mechanical system element.
 | NewModelCurve | Creates a new model line element. (Inherited from ItemFactoryBase)
Public method | NewModelCurveArray | Creates an array of new model line elements. (Inherited from ItemFactoryBase)
Public method | NewOpening(Element, CurveArray, eRefFace) | Creates a new opening in a beam, brace and column.
Public method | NewOpening(Element, CurveArray, Boolean) | Creates a new opening in a roof, floor and ceiling.
Public method | NewOpening(Level, Level, CurveArray) | Creates a new shaft opening between a set of levels.
Public method | NewOpening(Wall, XYZ, XYZ) | Creates a rectangular opening on a wall.
Public method | NewPipingSystem | Creates a new MEP piping system element.
 | NewPointBoundaryConditions | Creates a new Point BoundaryConditions Element.
 | NewReferencePlane | Creates a new instance of ReferencePlane. (Inherited from ItemFactoryBase)
 | NewReferencePlane2 | Creates a new instance of ReferencePlane. (Inherited from ItemFactoryBase)
Public method | NewRoom(Phase) | Creates a new unplaced room and with an assigned phase.
 | NewRoom(Level, UV) | Creates a new room on a level at a specified point.
 | NewRoom(Room, PlanCircuit) | Creates a new room within the confines of a plan circuit, or places an unplaced room within the confines of the plan circuit.
Public method | NewRoomBoundaryLines | Creates a new boundary line as an Room border.
Public method | NewRooms2(Level) | Creates new rooms in each plan circuit found in the given level in the last phase.
Public method | NewRooms2(Level, Phase) | Creates new rooms in each plan circuit found in the given level in the given phase.
Public method | NewRooms2(Phase, Int32) | Creates new unplaced rooms in the given phase.
 | NewRoomTag | Creates a new RoomTag referencing a room in the host model or in a Revit link.
Public method | NewSlabEdge(SlabEdgeType, Reference) | Creates a slab edge along a reference.
Public method | NewSlabEdge(SlabEdgeType, ReferenceArray) | Creates a slab edge along a reference array.
Public method | NewSpace(Phase) | Creates a new unplaced space on a given phase.
Public method | NewSpace(Level, UV) | Creates a new space element on the given level at the given location.
Public method | NewSpace(Level, Phase, UV) | Creates a new space element on the given level, at the given location, and assigned to the given phase.
Public method | NewSpaceBoundaryLines | Creates a new boundary line as an Space border.
Public method | NewSpaces2(Phase, Int32) | Creates a set of new unplaced spaces on a given phase.
Public method | NewSpaces2(Level, Phase, View) | Creates new spaces on the available plan circuits of a the given level.
Public method | NewSpaceTag | Creates a new SpaceTag.
Public method | NewSpotCoordinate | Generate a new spot coordinate object within the project.
Public method | NewSpotElevation | Generate a new spot elevation object within the project.
Public method | NewTakeoffFitting | Add a new family instance of an takeoff fitting into the Autodesk Revit document, using one connector and one MEP curve.
Public method | NewTeeFitting | Add a new family instance of a tee fitting into the Autodesk Revit document, using three connectors.
Public method | NewTransitionFitting | Add a new family instance of an transition fitting into the Autodesk Revit document, using two connectors.
Public method | NewUnionFitting | Add a new family instance of an union fitting into the Autodesk Revit document, using two connectors.
Public method | NewZone | Creates a new Zone element.
Public method | PlaceGroup | Place an instance of a Model Group into the Autodesk Revit document, using a location and a group type. (Inherited from ItemFactoryBase)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Document Class
Autodesk.Revit.Creation Namespace


Document.NewArea Method

DocumentNewArea Method

Creates a new area

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Area NewArea(
    ViewPlan areaView,
    UV point
)
Public Function NewArea (
    areaView As ViewPlan,
    point As UV
) As Area
public:
Area^ NewArea(
    ViewPlan^ areaView,
    UV^ point
)
member NewArea :
        areaView : ViewPlan *
        point : UV -> Area

Parameters

areaView ViewPlan
The view of area element.
point UV
The point which lies in the enclosed region of AreaBoundaryLines to put the new created Area

Return Value

Area
Exceptions
Exception | Condition
ArgumentException | Thrown if the area view does not exist in the given document.
See Also

Reference

Document Class
Autodesk.Revit.Creation Namespace


Document.NewAreaBoundaryConditions Method

DocumentNewAreaBoundaryConditions Method

Creates a new Area BoundaryConditions element.
Overload List
Name | Description
NewAreaBoundaryConditions(Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Area BoundaryConditions element on a host element.
NewAreaBoundaryConditions(Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Area BoundaryConditions element on a reference.
Top
See Also

Reference

Document Class
Autodesk.Revit.Creation Namespace


Document.NewAreaBoundaryConditions(Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) Method

DocumentNewAreaBoundaryConditions(Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) Method

Creates a new Area BoundaryConditions element on a host element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BoundaryConditions NewAreaBoundaryConditions(
    Element hostElement,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus
)
Public Function NewAreaBoundaryConditions (
    hostElement As Element,
    X_Translation As TranslationRotationValue,
    X_TranslationSpringModulus As Double,
    Y_Translation As TranslationRotationValue,
    Y_TranslationSpringModulus As Double,
    Z_Translation As TranslationRotationValue,
    Z_TranslationSpringModulus As Double
) As BoundaryConditions
public:
BoundaryConditions^ NewAreaBoundaryConditions(
    Element^ hostElement,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus
)
member NewAreaBoundaryConditions :
        hostElement : Element *
        X_Translation : TranslationRotationValue *
        X_TranslationSpringModulus : float *
        Y_Translation : TranslationRotationValue *
        Y_TranslationSpringModulus : float *
        Z_Translation : TranslationRotationValue *
        Z_TranslationSpringModulus : float -> BoundaryConditions

Parameters

hostElement Element
A Wall, Slab or Slab Foundation to host the boundary conditions.
X_Translation TranslationRotationValue
A value indicating the X axis translation option.
X_TranslationSpringModulus Double
Translation Spring Modulus for X axis. Ignored if X_Translation is not "Spring".
Y_Translation TranslationRotationValue
A value indicating the Y axis translation option.
Y_TranslationSpringModulus Double
Translation Spring Modulus for Y axis. Ignored if Y_Translation is not "Spring".
Z_Translation TranslationRotationValue
A value indicating the Z axis translation option.
Z_TranslationSpringModulus Double
Translation Spring Modulus for Z axis. Ignored if Z_Translation is not "Spring".

Return Value

BoundaryConditions
If successful, NewAreaBoundaryConditions returns an object for the newly created BoundaryConditions with the BoundaryType = 2 - "Area". is returned if the operation fails.
Exceptions
Exception | Condition
ArgumentException | Thrown if the host element does not exist in the given document.
Remarks
This method will only function with the Autodesk Revit Structure application.
Example
C#
VB
C++
F#
Copy
bool CreateAreaConditionWithElement(AnalyticalPanel wall, Autodesk.Revit.Creation.Document docCreation)
{
   // Create Area Boundary Conditions using a given Wall and defaulting to fixed in all directions
   BoundaryConditions condition = docCreation.NewAreaBoundaryConditions(wall, TranslationRotationValue.Fixed, 0,
                                                                              TranslationRotationValue.Fixed, 0,
                                                                              TranslationRotationValue.Fixed, 0);
   return (null != condition);
}
Private Function CreateAreaConditionWithElement(wall As Wall, docCreation As Autodesk.Revit.Creation.Document) As Boolean
    ' Create Area Boundary Conditions using a given Wall and defaulting to fixed in all directions
    Dim condition As BoundaryConditions = docCreation.NewAreaBoundaryConditions(wall, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, _
        0)
    Return (condition IsNot Nothing)
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Document Class
NewAreaBoundaryConditions Overload
Autodesk.Revit.Creation Namespace


Document.NewAreaBoundaryConditions(Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) Method

DocumentNewAreaBoundaryConditions(Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) Method

Creates a new Area BoundaryConditions element on a reference.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BoundaryConditions NewAreaBoundaryConditions(
    Reference reference,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus
)
Public Function NewAreaBoundaryConditions (
    reference As Reference,
    X_Translation As TranslationRotationValue,
    X_TranslationSpringModulus As Double,
    Y_Translation As TranslationRotationValue,
    Y_TranslationSpringModulus As Double,
    Z_Translation As TranslationRotationValue,
    Z_TranslationSpringModulus As Double
) As BoundaryConditions
public:
BoundaryConditions^ NewAreaBoundaryConditions(
    Reference^ reference,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus
)
member NewAreaBoundaryConditions :
        reference : Reference *
        X_Translation : TranslationRotationValue *
        X_TranslationSpringModulus : float *
        Y_Translation : TranslationRotationValue *
        Y_TranslationSpringModulus : float *
        Z_Translation : TranslationRotationValue *
        Z_TranslationSpringModulus : float -> BoundaryConditions

Parameters

reference Reference
The Geometry reference obtained from a Wall, Slab or Slab Foundation.
X_Translation TranslationRotationValue
A value indicating the X axis translation option.
X_TranslationSpringModulus Double
Translation Spring Modulus for X axis. Ignored if X_Translation is not "Spring".
Y_Translation TranslationRotationValue
A value indicating the Y axis translation option.
Y_TranslationSpringModulus Double
Translation Spring Modulus for Y axis. Ignored if Y_Translation is not "Spring".
Z_Translation TranslationRotationValue
A value indicating the Z axis translation option.
Z_TranslationSpringModulus Double
Translation Spring Modulus for Z axis. Ignored if Z_Translation is not "Spring".

Return Value

BoundaryConditions
If successful, NewAreaBoundaryConditions returns an object for the newly created BoundaryConditions with the BoundaryType = 2 - "Area". is returned if the operation fails.
Remarks
This method will only function with the Autodesk Revit Structure application.
Example
C#
VB
C++
F#
Copy
bool CreateAreaConditionWithReference(AnalyticalPanel wall, Autodesk.Revit.Creation.Document docCreation)
{
   // Get the Geometry reference to the wall
   Reference profileReference = null;
   if (null == wall)
   {
      return false; // the profile reference can't be retrieved.
   }

   // loop through the curves of the wall and get the first one as a reference
   foreach (Curve curve in wall.GetOuterContour())
   {
      AnalyticalModelSelector selector = new AnalyticalModelSelector(curve);

      profileReference = wall.GetReference(selector);
      if (null != profileReference)
      {
         break;
      }
   }
   BoundaryConditions condition = null;
   // Create the Area Boundary Conditions if we have a profileReference
   if (null != profileReference)
   {
      // Create Area Boundary Conditions with profile reference.
      condition = docCreation.NewAreaBoundaryConditions(profileReference, TranslationRotationValue.Fixed, 0,
                                                                          TranslationRotationValue.Fixed, 0,
                                                                          TranslationRotationValue.Fixed, 0);
   }
   return (null != condition);
}
Private Function CreateAreaConditionWithReference(wall As Wall, docCreation As Autodesk.Revit.Creation.Document) As Boolean
   ' Get the Geometry reference to the wall
   Dim profileReference As Reference = Nothing
   Dim document As Document = wall.Document
   Dim analytical As Autodesk.Revit.DB.Structure.AnalyticalPanel = Nothing
   Dim relManager As Autodesk.Revit.DB.Structure.AnalyticalToPhysicalAssociationManager = Autodesk.Revit.DB.Structure.AnalyticalToPhysicalAssociationManager.GetAnalyticalToPhysicalAssociationManager(document)

   If (relManager Is Nothing) Then
      Return False
   End If

   Dim counterpartId As ElementId = relManager.GetAssociatedElementId(wall.Id)
   If (counterpartId Is Nothing) Then
      Return False
   End If

   analytical = document.GetElement(counterpartId)
   If analytical Is Nothing Then
      ' the profile reference can't be retrieved.
      Return False
   End If

   ' loop through the curves of the wall and get the first one as a reference
   For Each curve As Curve In analytical.GetOuterContour().ToList()
      profileReference = curve.Reference
      If profileReference IsNot Nothing Then
         Exit For
      End If
   Next

   Dim condition As BoundaryConditions = Nothing
   ' Create the Area Boundary Conditions if we have a profileReference
   If profileReference IsNot Nothing Then
      ' Create Area Boundary Conditions with profile reference.
      condition = docCreation.NewAreaBoundaryConditions(profileReference, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed,
              0)
   End If
   Return (condition IsNot Nothing)
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Document Class
NewAreaBoundaryConditions Overload
Autodesk.Revit.Creation Namespace


Document.NewAreaBoundaryLine Method

DocumentNewAreaBoundaryLine Method

Creates a new boundary line as an Area border.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ModelCurve NewAreaBoundaryLine(
    SketchPlane sketchPlane,
    Curve geometryCurve,
    ViewPlan areaView
)
Public Function NewAreaBoundaryLine (
    sketchPlane As SketchPlane,
    geometryCurve As Curve,
    areaView As ViewPlan
) As ModelCurve
public:
ModelCurve^ NewAreaBoundaryLine(
    SketchPlane^ sketchPlane,
    Curve^ geometryCurve,
    ViewPlan^ areaView
)
member NewAreaBoundaryLine :
        sketchPlane : SketchPlane *
        geometryCurve : Curve *
        areaView : ViewPlan -> ModelCurve

Parameters

sketchPlane SketchPlane
The sketch plane.
geometryCurve Curve
The geometry curve on which the boundary line are
areaView ViewPlan
The View for the new Area

Return Value

ModelCurve
Exceptions
Exception | Condition
ArgumentException | Thrown if the sketch plane does not exist in the given document.
ArgumentException | Thrown if the area view does not exist in the given document.
See Also

Reference

Document Class
Autodesk.Revit.Creation Namespace


Document.NewAreas Method

DocumentNewAreas Method

Creates new areas

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementSet NewAreas(
    List<AreaCreationData> dataList
)
Public Function NewAreas (
    dataList As List(Of AreaCreationData)
) As ElementSet
public:
ElementSet^ NewAreas(
    List<AreaCreationData^>^ dataList
)
member NewAreas :
        dataList : List<AreaCreationData> -> ElementSet

Parameters

dataList List AreaCreationData
A list of AreaCreationData which wraps the creation arguments of the areas to be created.

Return Value

ElementSet
If successful an Element Set which contains the areas should be returned, otherwise the exception will be thrown.
Exceptions
Exception | Condition
ArgumentNullException | If AreaCreationData's areaPoint is .
InvalidOperationException | If the area cannot be created successfully or the phase is invalid or regeneration fails at the end of the batch creation.
See Also

Reference

Document Class
Autodesk.Revit.Creation Namespace


Document.NewAreaTag Method

DocumentNewAreaTag Method

Creates a new area tag.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AreaTag NewAreaTag(
    ViewPlan areaView,
    Area room,
    UV point
)
Public Function NewAreaTag (
    areaView As ViewPlan,
    room As Area,
    point As UV
) As AreaTag
public:
AreaTag^ NewAreaTag(
    ViewPlan^ areaView,
    Area^ room,
    UV^ point
)
member NewAreaTag :
        areaView : ViewPlan *
        room : Area *
        point : UV -> AreaTag

Parameters

areaView ViewPlan
The area view
room Area
The area to tag
point UV
The position of the area tag

Return Value

AreaTag
Exceptions
Exception | Condition
ArgumentException | Thrown if the area view does not exist in the given document.
ArgumentException | Thrown if the area does not exist in the given document.
See Also

Reference

Document Class
Autodesk.Revit.Creation Namespace


Document.NewCrossFitting Method

DocumentNewCrossFitting Method

Add a new family instance of a cross fitting into the Autodesk Revit document, using four connectors.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyInstance NewCrossFitting(
    Connector connector1,
    Connector connector2,
    Connector connector3,
    Connector connector4
)
Public Function NewCrossFitting (
    connector1 As Connector,
    connector2 As Connector,
    connector3 As Connector,
    connector4 As Connector
) As FamilyInstance
public:
FamilyInstance^ NewCrossFitting(
    Connector^ connector1,
    Connector^ connector2,
    Connector^ connector3,
    Connector^ connector4
)
member NewCrossFitting :
        connector1 : Connector *
        connector2 : Connector *
        connector3 : Connector *
        connector4 : Connector -> FamilyInstance

Parameters

connector1 Connector
The first connector to be connected to the cross.
connector2 Connector
The second connector to be connected to the cross.
connector3 Connector
The third connector to be connected to the cross.
connector4 Connector
The fourth connector to be connected to the cross.

Return Value

FamilyInstance
If creation was successful then an family instance to the new object is returned, and the transition fitting will be added at the connectors' end if necessary, otherwise an exception with failure information will be thrown.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument connector1, connector2, connector3, or connector4 is .
ArgumentException | Thrown when the connectors cannot be used for cross creation. For example, they cannot be from the same element, they must be of the same domain, and the owner of the connectors should be a (flex) duct or pipe.
InvalidOperationException | Thrown when cross fitting cannot be created.
See Also

Reference

Document Class
Autodesk.Revit.Creation Namespace


Document.NewCurtainSystem Method

DocumentNewCurtainSystem Method

Creates a new CurtainSystem element from a set of faces.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurtainSystem NewCurtainSystem(
    FaceArray faces,
    CurtainSystemType curtainSystemType
)
Public Function NewCurtainSystem (
    faces As FaceArray,
    curtainSystemType As CurtainSystemType
) As CurtainSystem
public:
CurtainSystem^ NewCurtainSystem(
    FaceArray^ faces,
    CurtainSystemType^ curtainSystemType
)
member NewCurtainSystem :
        faces : FaceArray *
        curtainSystemType : CurtainSystemType -> CurtainSystem

Parameters

faces FaceArray
The faces new CurtainSystem will be created on.
curtainSystemType CurtainSystemType
The Type of CurtainSystem to be created.

Return Value

CurtainSystem
The CurtainSystem created will be returned when the operation succeeds.
Exceptions
Exception | Condition
ArgumentNullException | Thrown in following cases: The input argument faces or curtainSystemType is . The size of faces is zero.
InvalidOperationException | Thrown when the CurtainSystem cannot be created or regenerate fails.
ArgumentException | Thrown if the curtain system type does not exist in the given document.
Remarks
The input faces will be copied during the operations so that they can be any faces.
See Also

Reference

Document Class
Autodesk.Revit.Creation Namespace


Document.NewCurtainSystem2 Method

DocumentNewCurtainSystem2 Method

Creates a new CurtainSystem element from a set of face references.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> NewCurtainSystem2(
    ReferenceArray faces,
    CurtainSystemType curtainSystemType
)
Public Function NewCurtainSystem2 (
    faces As ReferenceArray,
    curtainSystemType As CurtainSystemType
) As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ NewCurtainSystem2(
    ReferenceArray^ faces,
    CurtainSystemType^ curtainSystemType
)
member NewCurtainSystem2 :
        faces : ReferenceArray *
        curtainSystemType : CurtainSystemType -> ICollection<ElementId>

Parameters

faces ReferenceArray
The faces new CurtainSystem will be created on.
curtainSystemType CurtainSystemType
The Type of CurtainSystem to be created.

Return Value

ICollection ElementId
A set of ElementIds of CurtainSystems will be returned when the operation succeeds.
Exceptions
Exception | Condition
ArgumentNullException | Thrown in following cases: The input argument faces or curtainSystemType is . The size of faces is zero.
InvalidOperationException | Thrown when the CurtainSystem cannot be created, for example, the input faces don't belong to same mass or generic model. Or regenerate fails.
ArgumentException | Thrown if the curtain system type does not exist in the given document.
Remarks
The faces can belong to different masses or generic models. The number of CurtainSystems will be equal to the number of masses and generic models.
See Also

Reference

Document Class
Autodesk.Revit.Creation Namespace


Document.NewElbowFitting Method

DocumentNewElbowFitting Method

Add a new family instance of an elbow fitting into the Autodesk Revit document, using two connectors.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyInstance NewElbowFitting(
    Connector connector1,
    Connector connector2
)
Public Function NewElbowFitting (
    connector1 As Connector,
    connector2 As Connector
) As FamilyInstance
public:
FamilyInstance^ NewElbowFitting(
    Connector^ connector1,
    Connector^ connector2
)
member NewElbowFitting :
        connector1 : Connector *
        connector2 : Connector -> FamilyInstance

Parameters

connector1 Connector
The first connector to be connected to the elbow.
connector2 Connector
The second connector to be connected to the elbow.

Return Value

FamilyInstance
If creation was successful then an family instance to the new object is returned, otherwise an exception with failure information will be thrown.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument connector1 or connector2 is .
ArgumentException | Thrown when the connectors cannot be used for the elbow creation. For example, they cannot be from the same element, they must be of the same domain, and the angle between them must fall within the valid range (typically 2 to 95 degrees).
InvalidOperationException | Thrown when an elbow fitting cannot be created because the angle between the two connectors is too large or too small, the connectors are not close enough together, or the connectors are placed at positions with too high of a tolerance.
See Also

Reference

Document Class
Autodesk.Revit.Creation Namespace


Document.NewExtrusionRoof Method

DocumentNewExtrusionRoof Method

Creates a new Extrusion Roof.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExtrusionRoof NewExtrusionRoof(
    CurveArray profile,
    ReferencePlane refPlane,
    Level level,
    RoofType roofType,
    double extrusionStart,
    double extrusionEnd
)
Public Function NewExtrusionRoof (
    profile As CurveArray,
    refPlane As ReferencePlane,
    level As Level,
    roofType As RoofType,
    extrusionStart As Double,
    extrusionEnd As Double
) As ExtrusionRoof
public:
ExtrusionRoof^ NewExtrusionRoof(
    CurveArray^ profile,
    ReferencePlane^ refPlane,
    Level^ level,
    RoofType^ roofType,
    double extrusionStart,
    double extrusionEnd
)
member NewExtrusionRoof :
        profile : CurveArray *
        refPlane : ReferencePlane *
        level : Level *
        roofType : RoofType *
        extrusionStart : float *
        extrusionEnd : float -> ExtrusionRoof

Parameters

profile CurveArray
The profile of the extrusion roof. The curves of the profile must be contiguous and form one open loop without self-intersections. The profile curves must lie in the %refPlane% parallel to z-axis.
refPlane ReferencePlane
The work plane for the extrusion roof. It must be parallel to z-axis.
level Level
The level of the extrusion roof.
roofType RoofType
Type of the extrusion roof.
extrusionStart Double
Start the extrusion. Measured from %refPlane% in the direction of the plane normal.
extrusionEnd Double
End the extrusion. Measured from %refPlane% in the direction of the plane normal.

Return Value

ExtrusionRoof
Exceptions
Exception | Condition
ArgumentException | Thrown if the work plane does not exist in the given document.
ArgumentException | Thrown if the level does not exist in the given document.
ArgumentException | Thrown if the roof type does not exist in the given document.
Remarks
This method will regenerate the document even in manual regeneration mode.
See Also

Reference

Document Class
Autodesk.Revit.Creation Namespace


Document.NewFamilyInstance Method

DocumentNewFamilyInstance Method

Inserts a new instance of a family into the document.
Overload List
 | Name | Description
 | NewFamilyInstance(Face, Line, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a line on that face for its position, and a type/symbol.
 | NewFamilyInstance(Line, FamilySymbol, View) | Add a line based detail family instance into the Autodesk Revit document, using an line and a view where the instance should be placed.
 | NewFamilyInstance(Reference, Line, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a line on that face for its position, and a type/symbol.
Public method | NewFamilyInstance(XYZ, FamilySymbol, StructuralType) | Inserts a new instance of a family into the document, using a location and a type/symbol.
Public method | NewFamilyInstance(XYZ, FamilySymbol, View) | Add a new family instance into the Autodesk Revit document, using an origin and a view where the instance should be placed.
 | NewFamilyInstance(Curve, FamilySymbol, Level, StructuralType) | Inserts a new instance of a family into the document, using a curve, type/symbol and reference level.
 | NewFamilyInstance(Face, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol.
 | NewFamilyInstance(Reference, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a location, reference direction, and a type/symbol.
 | NewFamilyInstance(XYZ, FamilySymbol, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the host element.
Public method | NewFamilyInstance(XYZ, FamilySymbol, Level, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the level.
 | NewFamilyInstance(XYZ, FamilySymbol, Element, Level, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a base level.
 | NewFamilyInstance(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a reference direction.
Top
See Also

Reference

Document Class
Autodesk.Revit.Creation Namespace


Document.NewFamilyInstance(Curve, FamilySymbol, Level, StructuralType) Method

DocumentNewFamilyInstance(Curve, FamilySymbol, Level, StructuralType) Method

Inserts a new instance of a family into the document, using a curve, type/symbol and reference level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyInstance NewFamilyInstance(
    Curve curve,
    FamilySymbol symbol,
    Level level,
    StructuralType structuralType
)
Public Function NewFamilyInstance (
    curve As Curve,
    symbol As FamilySymbol,
    level As Level,
    structuralType As StructuralType
) As FamilyInstance
public:
FamilyInstance^ NewFamilyInstance(
    Curve^ curve,
    FamilySymbol^ symbol,
    Level^ level,
    StructuralType structuralType
)
member NewFamilyInstance :
        curve : Curve *
        symbol : FamilySymbol *
        level : Level *
        structuralType : StructuralType -> FamilyInstance

Parameters

curve Curve
The curve where the instance is based.
symbol FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
level Level
A Level object that is used as the base level for the object.
structuralType StructuralType
If structural then specify the type of the component.

Return Value

FamilyInstance
If creation was successful then an instance to the new object is returned, otherwise .
Exceptions
Exception | Condition
ArgumentException | Thrown if the family symbol does not exist in the given document.
ArgumentException | Thrown if the level does not exist in the given document.
ArgumentException | Thrown if The symbol is not active.
Remarks
This method is used to insert one family instance into another element along the geometry of a curve. If the instance fails to be created an exception may be thrown.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

The host object must be one that supports insertion of instances otherwise this method will fail. All levels within the document can be found by iterating over the entire document and searching for objects of type Autodesk.Revit.Elements.Level.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call.

Example
C#
VB
C++
F#
Copy
FamilyInstance CreateBeam(Autodesk.Revit.DB.Document document, View view)
{

   // get the given view's level for beam creation
    Level level = document.GetElement(view.LevelId) as Level;

    // get a family symbol
    FilteredElementCollector collector = new FilteredElementCollector(document);
    collector.OfClass(typeof(FamilySymbol)).OfCategory(BuiltInCategory.OST_StructuralFraming);

    FamilySymbol gotSymbol = collector.FirstElement() as FamilySymbol;

    // create new beam 10' long starting at origin
    XYZ startPoint = new XYZ(0, 0, 0);
    XYZ endPoint = new Autodesk.Revit.DB.XYZ(10, 0, 0);

    Autodesk.Revit.DB.Curve beamLine = Line.CreateBound(startPoint, endPoint);

    // create a new beam
    FamilyInstance instance = document.Create.NewFamilyInstance(beamLine, gotSymbol,
                                                                level, StructuralType.Beam);

    return instance;
}
Private Function CreateBeam(document As Autodesk.Revit.DB.Document, view As View) As FamilyInstance

    ' get the given view's level for beam creation
    Dim level As Level = TryCast(document.GetElement(view.LevelId), Level)

    ' get a family symbol
    Dim collector As New FilteredElementCollector(document)
    collector.OfClass(GetType(FamilySymbol)).OfCategory(BuiltInCategory.OST_StructuralFraming)

    Dim gotSymbol As FamilySymbol = TryCast(collector.FirstElement(), FamilySymbol)

    ' create new beam 10' long starting at origin
    Dim startPoint As New XYZ(0, 0, 0)
    Dim endPoint As XYZ = New Autodesk.Revit.DB.XYZ(10, 0, 0)

    Dim beamLine As Autodesk.Revit.DB.Curve = Line.CreateBound(startPoint, endPoint)

    ' create a new beam
    Dim instance As FamilyInstance = document.Create.NewFamilyInstance(beamLine, gotSymbol, level, StructuralType.Beam)

    Return instance
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Document Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


Document.NewFamilyInstance(XYZ, FamilySymbol, Element, Level, StructuralType) Method

DocumentNewFamilyInstance(XYZ, FamilySymbol, Element, Level, StructuralType) Method

Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a base level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyInstance NewFamilyInstance(
    XYZ location,
    FamilySymbol symbol,
    Element host,
    Level level,
    StructuralType structuralType
)
Public Function NewFamilyInstance (
    location As XYZ,
    symbol As FamilySymbol,
    host As Element,
    level As Level,
    structuralType As StructuralType
) As FamilyInstance
public:
FamilyInstance^ NewFamilyInstance(
    XYZ^ location,
    FamilySymbol^ symbol,
    Element^ host,
    Level^ level,
    StructuralType structuralType
)
member NewFamilyInstance :
        location : XYZ *
        symbol : FamilySymbol *
        host : Element *
        level : Level *
        structuralType : StructuralType -> FamilyInstance

Parameters

location XYZ
The physical location where the instance is to be placed on the specified level.
symbol FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
host Element
A host object into which the instance will be embedded
level Level
A Level object that is used as the base level for the object.
structuralType StructuralType
If structural then specify the type of the component.

Return Value

FamilyInstance
If creation was successful then an instance to the new object is returned, otherwise .
Exceptions
Exception | Condition
ArgumentException | Thrown if the family symbol does not exist in the given document.
ArgumentException | Thrown if the host does not exist in the given document.
ArgumentException | Thrown if the level does not exist in the given document.
ArgumentException | Thrown if The symbol is not active.
Remarks
This form of NewFamilyInstance is the most commonly used in Autodesk Revit since there are a large number of elements that use levels, such as Walls, Columns etc. If the instance fails to be created an exception may be thrown.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

All levels within the document can be found by iterating over the entire document and searching for objects of type Autodesk.Revit.Elements.Level.

Some Families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted these linear family instances can have their endpoints changed by using the instance's Element.Location property.

Note: ForbiddenForDynamicUpdateException might be thrown during a dynamic update if the inserted instance establishes a mutual dependency with another structure.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call.

Example
C#
VB
C++
F#
Copy
void CreateDoorsInWall(Autodesk.Revit.DB.Document document, Wall wall)
{
    // get wall's level for door creation
    Level level = document.GetElement(wall.LevelId) as Level;

    FilteredElementCollector collector = new FilteredElementCollector(document);
    ICollection<Element> collection = collector.OfClass(typeof(FamilySymbol))
                                               .OfCategory(BuiltInCategory.OST_Doors)
                                               .ToElements();
    IEnumerator<Element> symbolItor = collection.GetEnumerator();

    double x = 0, y = 0, z = 0;
    while (symbolItor.MoveNext())
    {
        FamilySymbol symbol = symbolItor.Current as FamilySymbol;
        XYZ location = new XYZ(x, y, z);
        FamilyInstance instance = document.Create.NewFamilyInstance(location, symbol, wall, level, StructuralType.NonStructural);
        x += 10;
        y += 10;
        z += 1.5;
    }
}
Private Sub CreateDoorsInWall(document As Autodesk.Revit.DB.Document, wall As Wall)
    ' get wall's level for door creation
    Dim level As Level = TryCast(document.GetElement(wall.LevelId), Level)

    Dim collector As New FilteredElementCollector(document)
    Dim collection As ICollection(Of Element) = collector.OfClass(GetType(FamilySymbol)).OfCategory(BuiltInCategory.OST_Doors).ToElements()
    Dim symbolItor As IEnumerator(Of Element) = collection.GetEnumerator()

    Dim x As Double = 0, y As Double = 0, z As Double = 0
    While symbolItor.MoveNext()
        Dim symbol As FamilySymbol = TryCast(symbolItor.Current, FamilySymbol)
        Dim location As New XYZ(x, y, z)
        Dim instance As FamilyInstance = document.Create.NewFamilyInstance(location, symbol, wall, level, StructuralType.NonStructural)
        x += 10
        y += 10
        z += 1.5
    End While
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Document Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


Document.NewFascia Method

DocumentNewFascia Method

Creates a fascia.
Overload List
 | Name | Description
Public method | NewFascia(FasciaType, Reference) | Creates a fascia along a reference.
Public method | NewFascia(FasciaType, ReferenceArray) | Creates a fascia along a reference array.
Top
See Also

Reference

Document Class
Autodesk.Revit.Creation Namespace


Document.NewFascia(FasciaType, Reference) Method

DocumentNewFascia(FasciaType, Reference) Method

Creates a fascia along a reference.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Fascia NewFascia(
    FasciaType FasciaType,
    Reference reference
)
Public Function NewFascia (
    FasciaType As FasciaType,
    reference As Reference
) As Fascia
public:
Fascia^ NewFascia(
    FasciaType^ FasciaType,
    Reference^ reference
)
member NewFascia :
        FasciaType : FasciaType *
        reference : Reference -> Fascia

Parameters

FasciaType FasciaType
The type of the fascia to create
reference Reference
A planar line or arc that represents the place where you want to place the fascia.

Return Value

Fascia
If successful a new fascia object within the project, otherwise .
Exceptions
Exception | Condition
ArgumentException | Thrown if the fascia type does not exist in the given document.
See Also

Reference

Document Class
NewFascia Overload
Autodesk.Revit.Creation Namespace


Document.NewFascia(FasciaType, ReferenceArray) Method

DocumentNewFascia(FasciaType, ReferenceArray) Method

Creates a fascia along a reference array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Fascia NewFascia(
    FasciaType FasciaType,
    ReferenceArray references
)
Public Function NewFascia (
    FasciaType As FasciaType,
    references As ReferenceArray
) As Fascia
public:
Fascia^ NewFascia(
    FasciaType^ FasciaType,
    ReferenceArray^ references
)
member NewFascia :
        FasciaType : FasciaType *
        references : ReferenceArray -> Fascia

Parameters

FasciaType FasciaType
The type of the fascia to create
references ReferenceArray
An array of planar lines and arcs that represents the place where you want to place the fascia.

Return Value

Fascia
If successful a new fascia object within the project, otherwise .
Exceptions
Exception | Condition
ArgumentException | Thrown if the fascia type does not exist in the given document.
See Also

Reference

Document Class
NewFascia Overload
Autodesk.Revit.Creation Namespace


Document.NewFlexDuct Method

DocumentNewFlexDuct Method

Adds a new flexible duct into the document.
Overload List
 | Name | Description
Public method | NewFlexDuct(IListXYZ, FlexDuctType) | Adds a new flexible duct into the document, using a point array and duct type.
Public method | NewFlexDuct(Connector, Connector, FlexDuctType) | Adds a new flexible duct into the document, using two connector, and duct type.
Public method | NewFlexDuct(Connector, IListXYZ, FlexDuctType) | Adds a new flexible duct into the document, using a connector, point array and duct type.
Top
See Also

Reference

Document Class
Autodesk.Revit.Creation Namespace


Document.NewFlexDuct(IList<XYZ>, FlexDuctType) Method

DocumentNewFlexDuct(IListXYZ, FlexDuctType) Method

Adds a new flexible duct into the document, using a point array and duct type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FlexDuct NewFlexDuct(
    IList<XYZ> points,
    FlexDuctType ductType
)
Public Function NewFlexDuct (
    points As IList(Of XYZ),
    ductType As FlexDuctType
) As FlexDuct
public:
FlexDuct^ NewFlexDuct(
    IList<XYZ^>^ points,
    FlexDuctType^ ductType
)
member NewFlexDuct :
        points : IList<XYZ> *
        ductType : FlexDuctType -> FlexDuct

Parameters

points IList XYZ
The point array indicating the path of the flexible duct, including the end points.
ductType FlexDuctType
The type of the flexible duct.

Return Value

FlexDuct
If creation was successful then a new flexible duct is returned, otherwise an exception with failure information will be thrown.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument points is .
InvalidOperationException | Thrown when the flexible duct cannot be created or regenerate fails.
ArgumentException | Thrown if the flexible duct type does not exist in the given document.
See Also

Reference

Document Class
NewFlexDuct Overload
Autodesk.Revit.Creation Namespace


Document.NewFlexDuct(Connector, Connector, FlexDuctType) Method

DocumentNewFlexDuct(Connector, Connector, FlexDuctType) Method

Adds a new flexible duct into the document, using two connector, and duct type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FlexDuct NewFlexDuct(
    Connector connector1,
    Connector connector2,
    FlexDuctType ductType
)
Public Function NewFlexDuct (
    connector1 As Connector,
    connector2 As Connector,
    ductType As FlexDuctType
) As FlexDuct
public:
FlexDuct^ NewFlexDuct(
    Connector^ connector1,
    Connector^ connector2,
    FlexDuctType^ ductType
)
member NewFlexDuct :
        connector1 : Connector *
        connector2 : Connector *
        ductType : FlexDuctType -> FlexDuct

Parameters

connector1 Connector
The first connector to be connected to the duct.
connector2 Connector
The second connector to be connected to the duct.
ductType FlexDuctType
The type of the flexible duct.

Return Value

FlexDuct
If creation was successful then a new flexible duct is returned, otherwise an exception with failure information will be thrown.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument connector1 or connector2 is .
InvalidOperationException | Thrown when the flexible duct cannot be created or regenerate fails.
ArgumentException | Thrown if the flexible duct type does not exist in the given document.
Remarks
If the connectors are fitting or equipment connectors of the correct domain, and if the connectors' direction match the direction of the flexible duct to be created, the connectors will be automatically connected. A transition fitting will be added at the connector(s) if necessary. If the connector's type, domain, does not match the one of the input connector, no connection will be established.
See Also

Reference

Document Class
NewFlexDuct Overload
Autodesk.Revit.Creation Namespace


Document.NewFlexDuct(Connector, IList<XYZ>, FlexDuctType) Method

DocumentNewFlexDuct(Connector, IListXYZ, FlexDuctType) Method

Adds a new flexible duct into the document, using a connector, point array and duct type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FlexDuct NewFlexDuct(
    Connector connector,
    IList<XYZ> points,
    FlexDuctType ductType
)
Public Function NewFlexDuct (
    connector As Connector,
    points As IList(Of XYZ),
    ductType As FlexDuctType
) As FlexDuct
public:
FlexDuct^ NewFlexDuct(
    Connector^ connector,
    IList<XYZ^>^ points,
    FlexDuctType^ ductType
)
member NewFlexDuct :
        connector : Connector *
        points : IList<XYZ> *
        ductType : FlexDuctType -> FlexDuct

Parameters

connector Connector
The connector to be connected to the duct, including the end points.
points IList XYZ
The point array indicating the path of the flexible duct.
ductType FlexDuctType
The type of the flexible duct.

Return Value

FlexDuct
If creation was successful then a new flexible duct is returned, otherwise an exception with failure information will be thrown.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument connector or points is .
InvalidOperationException | Thrown when the flexible duct cannot be created or regenerate fails.
ArgumentException | Thrown if the flexible duct type does not exist in the given document.
Remarks
If the connector is a fitting or equipment connector of the correct domain, and if the connector's direction matches the direction of the flexible duct to be created, the connectors will be automatically connected. A transition fitting will be added at the connector(s) if necessary. If the connector's type, domain, does not match the one of the input connector, no connection will be established.
See Also

Reference

Document Class
NewFlexDuct Overload
Autodesk.Revit.Creation Namespace


Document.NewFlexPipe Method

DocumentNewFlexPipe Method

Adds a new flexible pipe into the document.
Overload List
 | Name | Description
Public method | NewFlexPipe(IListXYZ, FlexPipeType) | Adds a new flexible pipe into the document, using a point array and pipe type.
Public method | NewFlexPipe(Connector, Connector, FlexPipeType) | Adds a new flexible pipe into the document, using two connector, and flexible pipe type.
Public method | NewFlexPipe(Connector, IListXYZ, FlexPipeType) | Adds a new flexible pipe into the document, using a connector, point array and pipe type.
Top
See Also

Reference

Document Class
Autodesk.Revit.Creation Namespace


Document.NewFlexPipe(IList<XYZ>, FlexPipeType) Method

DocumentNewFlexPipe(IListXYZ, FlexPipeType) Method

Adds a new flexible pipe into the document, using a point array and pipe type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FlexPipe NewFlexPipe(
    IList<XYZ> points,
    FlexPipeType pipeType
)
Public Function NewFlexPipe (
    points As IList(Of XYZ),
    pipeType As FlexPipeType
) As FlexPipe
public:
FlexPipe^ NewFlexPipe(
    IList<XYZ^>^ points,
    FlexPipeType^ pipeType
)
member NewFlexPipe :
        points : IList<XYZ> *
        pipeType : FlexPipeType -> FlexPipe

Parameters

points IList XYZ
The point array indicating the path of the flexible pipe, including the end points.
pipeType FlexPipeType
The type of the flexible pipe.

Return Value

FlexPipe
If creation was successful then a new flexible pipe is returned, otherwise an exception with failure information will be thrown.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument points is .
InvalidOperationException | Thrown when the flexible pipe cannot be created or regenerate fails.
ArgumentException | Thrown if the flexible pipe type does not exist in the given document.
See Also

Reference

Document Class
NewFlexPipe Overload
Autodesk.Revit.Creation Namespace


Document.NewFlexPipe(Connector, Connector, FlexPipeType) Method

DocumentNewFlexPipe(Connector, Connector, FlexPipeType) Method

Adds a new flexible pipe into the document, using two connector, and flexible pipe type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FlexPipe NewFlexPipe(
    Connector connector1,
    Connector connector2,
    FlexPipeType pipeType
)
Public Function NewFlexPipe (
    connector1 As Connector,
    connector2 As Connector,
    pipeType As FlexPipeType
) As FlexPipe
public:
FlexPipe^ NewFlexPipe(
    Connector^ connector1,
    Connector^ connector2,
    FlexPipeType^ pipeType
)
member NewFlexPipe :
        connector1 : Connector *
        connector2 : Connector *
        pipeType : FlexPipeType -> FlexPipe

Parameters

connector1 Connector
The first connector to be connected to the pipe.
connector2 Connector
The second connector to be connected to the pipe.
pipeType FlexPipeType
The type of the flexible pipe.

Return Value

FlexPipe
If creation was successful then a new flexible pipe is returned, otherwise an exception with failure information will be thrown.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument connector1 or connector2 is .
InvalidOperationException | Thrown when the flexible pipe cannot be created or regenerate fails.
ArgumentException | Thrown if the flexible pipe type does not exist in the given document.
Remarks
If the connectors are fitting or equipment connectors of the correct domain, and if the connectors' direction match the direction of the flexible pipe to be created, the connectors will be automatically connected. A transition fitting will be added at the connector(s) if necessary. If the connector's type, domain, does not match the one of the input connectors, no connection will be established.
See Also

Reference

Document Class
NewFlexPipe Overload
Autodesk.Revit.Creation Namespace


Document.NewFlexPipe(Connector, IList<XYZ>, FlexPipeType) Method

DocumentNewFlexPipe(Connector, IListXYZ, FlexPipeType) Method

Adds a new flexible pipe into the document, using a connector, point array and pipe type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FlexPipe NewFlexPipe(
    Connector connector,
    IList<XYZ> points,
    FlexPipeType pipeType
)
Public Function NewFlexPipe (
    connector As Connector,
    points As IList(Of XYZ),
    pipeType As FlexPipeType
) As FlexPipe
public:
FlexPipe^ NewFlexPipe(
    Connector^ connector,
    IList<XYZ^>^ points,
    FlexPipeType^ pipeType
)
member NewFlexPipe :
        connector : Connector *
        points : IList<XYZ> *
        pipeType : FlexPipeType -> FlexPipe

Parameters

connector Connector
The connector to be connected to the flexible pipe, including the end points.
points IList XYZ
The point array indicating the path of the flexible pipe.
pipeType FlexPipeType
The type of the flexible pipe.

Return Value

FlexPipe
If creation was successful then a new flexible pipe is returned, otherwise an exception with failure information will be thrown.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument connector or points is .
InvalidOperationException | Thrown when the flexible pipe cannot be created or regenerate fails.
ArgumentException | Thrown if the flexible pipe type does not exist in the given document.
Remarks
If the connector is a fitting or equipment connector of the correct domain, and if the connector's direction matches the direction of the flexible pipe to be created, the connectors will be automatically connected. A transition fitting will be added at the connector(s) if necessary. If the connector's type, domain, does not match the one of the input connector, no connection will be established.
See Also

Reference

Document Class
NewFlexPipe Overload
Autodesk.Revit.Creation Namespace


Document.NewFootPrintRoof Method

DocumentNewFootPrintRoof Method

Creates a new FootPrintRoof element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FootPrintRoof NewFootPrintRoof(
    CurveArray footPrint,
    Level level,
    RoofType roofType,
    out ModelCurveArray footPrintToModelCurvesMapping
)
Public Function NewFootPrintRoof (
    footPrint As CurveArray,
    level As Level,
    roofType As RoofType,
    <OutAttribute> ByRef footPrintToModelCurvesMapping As ModelCurveArray
) As FootPrintRoof
public:
FootPrintRoof^ NewFootPrintRoof(
    CurveArray^ footPrint,
    Level^ level,
    RoofType^ roofType,
    [OutAttribute] ModelCurveArray^% footPrintToModelCurvesMapping
)
member NewFootPrintRoof :
        footPrint : CurveArray *
        level : Level *
        roofType : RoofType *
        footPrintToModelCurvesMapping : ModelCurveArray byref -> FootPrintRoof

Parameters

footPrint CurveArray
The footprint of the FootPrintRoof.
level Level
The level of the FootPrintRoof.
roofType RoofType
Type of the FootPrintRoof.
footPrintToModelCurvesMapping ModelCurveArray
An array of Model Curves corresponding to the set of Curves input in the footPrint. By knowing which Model Curve was created by each footPrint curve, you can set properties like SlopeAngle for each curve.

Return Value

FootPrintRoof
Exceptions
Exception | Condition
ArgumentException | Thrown if the level does not exist in the given document.
ArgumentException | Thrown if the roof type does not exist in the given document.
Remarks
This method will regenerate the document even in manual regeneration mode.
Example
C#
VB
C++
F#
Copy
// Before invoking this sample, select some walls to add a roof over.
// Make sure there is a level named "Roof" in the document.

// find the Roof level
FilteredElementCollector collector = new FilteredElementCollector(document);
collector.OfClass(typeof(Level));
var elements = from element in collector where element.Name == "Roof" select element;
Level level = elements.Cast<Level>().ElementAt<Level>(0);

collector = new FilteredElementCollector(document);
collector.OfClass(typeof(RoofType));
RoofType roofType = collector.FirstElement() as RoofType;

// Get the handle of the application
Autodesk.Revit.ApplicationServices.Application application = document.Application;

// Define the footprint for the roof based on user selection
CurveArray footprint = application.Create.NewCurveArray();
UIDocument uidoc = new UIDocument(document);
ICollection<ElementId> selectedIds = uidoc.Selection.GetElementIds();
if (selectedIds.Count != 0)
{
    foreach (ElementId id in selectedIds)
    {
        Element element = document.GetElement(id);
        Wall wall = element as Wall;
        if (wall != null)
        {
            LocationCurve wallCurve = wall.Location as LocationCurve;
            footprint.Append(wallCurve.Curve);
            continue;
        }

        ModelCurve modelCurve = element as ModelCurve;
        if (modelCurve != null)
        {
            footprint.Append(modelCurve.GeometryCurve);
        }
    }

}
else
{
    throw new Exception("You should select a curve loop, or a wall loop, or loops combination \nof walls and curves to create a footprint roof.");
}

ModelCurveArray footPrintToModelCurveMapping = new ModelCurveArray();
FootPrintRoof footprintRoof = document.Create.NewFootPrintRoof(footprint, level, roofType, out footPrintToModelCurveMapping);
ModelCurveArrayIterator iterator = footPrintToModelCurveMapping.ForwardIterator();
iterator.Reset();
while (iterator.MoveNext())
{
    ModelCurve modelCurve = iterator.Current as ModelCurve;
    footprintRoof.set_DefinesSlope(modelCurve, true);
    footprintRoof.set_SlopeAngle(modelCurve, 0.5);
}
' Before invoking this sample, select some walls to add a roof over.
' Make sure there is a level named "Roof" in the document.

' find the Roof level
Dim collector As New FilteredElementCollector(document)
collector.OfClass(GetType(Level))
: Dim elements As System.Collections.Generic.IEnumerable(Of Autodesk.Revit.DB.Element)
elements = From element In collector _
 Where element.Name = "Roof" _
 Select element

Dim level As Level = elements.Cast(Of Level)().ElementAt(0)

collector = New FilteredElementCollector(document)
collector.OfClass(GetType(RoofType))
Dim roofType As RoofType = TryCast(collector.FirstElement(), RoofType)

' Get the handle of the application
Dim application As Autodesk.Revit.ApplicationServices.Application = document.Application

' Define the footprint for the roof based on user selection
Dim footprint As CurveArray = application.Create.NewCurveArray()
Dim uidoc As New UIDocument(document)
Dim selectedIds As ICollection(Of ElementId) = uidoc.Selection.GetElementIds()
If selectedIds.Count <> 0 Then
    For Each id As ElementId In selectedIds
        Dim element As Element = document.GetElement(id)
        Dim wall As Wall = TryCast(element, Wall)
        If wall IsNot Nothing Then
            Dim wallCurve As LocationCurve = TryCast(wall.Location, LocationCurve)
            footprint.Append(wallCurve.Curve)
            Continue For
        End If

        Dim modelCurve As ModelCurve = TryCast(element, ModelCurve)
        If modelCurve IsNot Nothing Then
            footprint.Append(modelCurve.GeometryCurve)
        End If

    Next
Else
    Throw New Exception("You should select a curve loop, or a wall loop, or loops combination " & vbLf & "of walls and curves to create a footprint roof.")
End If

Dim footPrintToModelCurveMapping As New ModelCurveArray()
Dim footprintRoof As FootPrintRoof = document.Create.NewFootPrintRoof(footprint, level, roofType, footPrintToModelCurveMapping)
Dim iterator As ModelCurveArrayIterator = footPrintToModelCurveMapping.ForwardIterator()
iterator.Reset()
While iterator.MoveNext()
    Dim modelCurve As ModelCurve = TryCast(iterator.Current, ModelCurve)
    footprintRoof.DefinesSlope(modelCurve) = True
    footprintRoof.SlopeAngle(modelCurve) = 0.5
End While

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Document Class
Autodesk.Revit.Creation Namespace


Document.NewGutter Method

DocumentNewGutter Method

Creates a gutter.
Overload List
 | Name | Description
Public method | NewGutter(GutterType, Reference) | Creates a gutter along a reference.
Public method | NewGutter(GutterType, ReferenceArray) | Creates a gutter along a reference array.
Top
See Also

Reference

Document Class
Autodesk.Revit.Creation Namespace


Document.NewGutter(GutterType, Reference) Method

DocumentNewGutter(GutterType, Reference) Method

Creates a gutter along a reference.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Gutter NewGutter(
    GutterType GutterType,
    Reference reference
)
Public Function NewGutter (
    GutterType As GutterType,
    reference As Reference
) As Gutter
public:
Gutter^ NewGutter(
    GutterType^ GutterType,
    Reference^ reference
)
member NewGutter :
        GutterType : GutterType *
        reference : Reference -> Gutter

Parameters

GutterType GutterType
The type of the gutter to create
reference Reference
A planar line or arc that represents the place where you want to place the gutter.

Return Value

Gutter
If successful a new gutter object within the project, otherwise .
Exceptions
Exception | Condition
ArgumentException | Thrown if the gutter type does not exist in the given document.
See Also

Reference

Document Class
NewGutter Overload
Autodesk.Revit.Creation Namespace


Document.NewGutter(GutterType, ReferenceArray) Method

DocumentNewGutter(GutterType, ReferenceArray) Method

Creates a gutter along a reference array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Gutter NewGutter(
    GutterType GutterType,
    ReferenceArray references
)
Public Function NewGutter (
    GutterType As GutterType,
    references As ReferenceArray
) As Gutter
public:
Gutter^ NewGutter(
    GutterType^ GutterType,
    ReferenceArray^ references
)
member NewGutter :
        GutterType : GutterType *
        references : ReferenceArray -> Gutter

Parameters

GutterType GutterType
The type of the gutter to create
references ReferenceArray
An array of planar lines and arcs that represents the place where you want to place the gutter.

Return Value

Gutter
If successful a new gutter object within the project, otherwise .
Exceptions
Exception | Condition
ArgumentException | Thrown if the gutter type does not exist in the given document.
See Also

Reference

Document Class
NewGutter Overload
Autodesk.Revit.Creation Namespace


Document.NewLineBoundaryConditions Method

DocumentNewLineBoundaryConditions Method

Creates a new Line BoundaryConditions element.
Overload List
Name | Description
NewLineBoundaryConditions(Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Line BoundaryConditions element on a host element.
NewLineBoundaryConditions(Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Line BoundaryConditions element on a reference.
Top
See Also

Reference

Document Class
Autodesk.Revit.Creation Namespace


Document.NewLineBoundaryConditions(Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) Method

DocumentNewLineBoundaryConditions(Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) Method

Creates a new Line BoundaryConditions element on a host element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BoundaryConditions NewLineBoundaryConditions(
    Element hostElement,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus,
    TranslationRotationValue X_Rotation,
    double X_RotationSpringModulus
)
Public Function NewLineBoundaryConditions (
    hostElement As Element,
    X_Translation As TranslationRotationValue,
    X_TranslationSpringModulus As Double,
    Y_Translation As TranslationRotationValue,
    Y_TranslationSpringModulus As Double,
    Z_Translation As TranslationRotationValue,
    Z_TranslationSpringModulus As Double,
    X_Rotation As TranslationRotationValue,
    X_RotationSpringModulus As Double
) As BoundaryConditions
public:
BoundaryConditions^ NewLineBoundaryConditions(
    Element^ hostElement,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus,
    TranslationRotationValue X_Rotation,
    double X_RotationSpringModulus
)
member NewLineBoundaryConditions :
        hostElement : Element *
        X_Translation : TranslationRotationValue *
        X_TranslationSpringModulus : float *
        Y_Translation : TranslationRotationValue *
        Y_TranslationSpringModulus : float *
        Z_Translation : TranslationRotationValue *
        Z_TranslationSpringModulus : float *
        X_Rotation : TranslationRotationValue *
        X_RotationSpringModulus : float -> BoundaryConditions

Parameters

hostElement Element
A Beam.
X_Translation TranslationRotationValue
A value indicating the X axis translation option.
X_TranslationSpringModulus Double
Translation Spring Modulus for X axis. Ignored if X_Translation is not "Spring".
Y_Translation TranslationRotationValue
A value indicating the Y axis translation option.
Y_TranslationSpringModulus Double
Translation Spring Modulus for Y axis. Ignored if Y_Translation is not "Spring".
Z_Translation TranslationRotationValue
A value indicating the Z axis translation option.
Z_TranslationSpringModulus Double
Translation Spring Modulus for Z axis. Ignored if Z_Translation is not "Spring".
X_Rotation TranslationRotationValue
A value indicating the option for rotation about the X axis.
X_RotationSpringModulus Double
Rotation Spring Modulus for X axis. Ignored if X_Rotation is not "Spring"

Return Value

BoundaryConditions
If successful, NewLineBoundaryConditions returns an object for the newly created BoundaryConditions with the BoundaryType = 1 - "Line". is returned if the operation fails.
Exceptions
Exception | Condition
ArgumentException | Thrown if the host element does not exist in the given document.
Remarks
This method will only function with the Autodesk Revit Structure application.
Example
C#
VB
C++
F#
Copy
bool CreateLineConditionsWithElement(AnalyticalMember column, Autodesk.Revit.Creation.Document docCreation)
  {
      if (column.StructuralRole != AnalyticalStructuralRole.StructuralRoleColumn)
      {
          throw new Exception("This sample only works for columns.");
      }

      // Create the new line boundary conditions
      BoundaryConditions condition = docCreation.NewLineBoundaryConditions(column, TranslationRotationValue.Fixed, 0,
                                                                                TranslationRotationValue.Fixed, 0,
                                                                                TranslationRotationValue.Fixed, 0,
                                                                                TranslationRotationValue.Fixed, 0);
      return (null != condition);
  }
Private Function CreateLineConditionsWithElement(column As FamilyInstance, docCreation As Autodesk.Revit.Creation.Document) As Boolean
    If StructuralType.Column <> column.StructuralType Then
        Throw New Exception("This sample only works for columns.")
    End If

    ' Create the new line boundary conditions
    Dim condition As BoundaryConditions = docCreation.NewLineBoundaryConditions(column, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, _
        0, TranslationRotationValue.Fixed, 0)
    Return (condition IsNot Nothing)
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Document Class
NewLineBoundaryConditions Overload
Autodesk.Revit.Creation Namespace


Document.NewLineBoundaryConditions(Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) Method

DocumentNewLineBoundaryConditions(Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) Method

Creates a new Line BoundaryConditions element on a reference.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BoundaryConditions NewLineBoundaryConditions(
    Reference reference,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus,
    TranslationRotationValue X_Rotation,
    double X_RotationSpringModulus
)
Public Function NewLineBoundaryConditions (
    reference As Reference,
    X_Translation As TranslationRotationValue,
    X_TranslationSpringModulus As Double,
    Y_Translation As TranslationRotationValue,
    Y_TranslationSpringModulus As Double,
    Z_Translation As TranslationRotationValue,
    Z_TranslationSpringModulus As Double,
    X_Rotation As TranslationRotationValue,
    X_RotationSpringModulus As Double
) As BoundaryConditions
public:
BoundaryConditions^ NewLineBoundaryConditions(
    Reference^ reference,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus,
    TranslationRotationValue X_Rotation,
    double X_RotationSpringModulus
)
member NewLineBoundaryConditions :
        reference : Reference *
        X_Translation : TranslationRotationValue *
        X_TranslationSpringModulus : float *
        Y_Translation : TranslationRotationValue *
        Y_TranslationSpringModulus : float *
        Z_Translation : TranslationRotationValue *
        Z_TranslationSpringModulus : float *
        X_Rotation : TranslationRotationValue *
        X_RotationSpringModulus : float -> BoundaryConditions

Parameters

reference Reference
The Geometry reference to a Beam's, Wall's, Wall Foundation's, Slab's or Slab Foundation's analytical line.
X_Translation TranslationRotationValue
A value indicating the X axis translation option.
X_TranslationSpringModulus Double
Translation Spring Modulus for X axis. Ignored if X_Translation is not "Spring".
Y_Translation TranslationRotationValue
A value indicating the Y axis translation option.
Y_TranslationSpringModulus Double
Translation Spring Modulus for Y axis. Ignored if Y_Translation is not "Spring".
Z_Translation TranslationRotationValue
A value indicating the Z axis translation option.
Z_TranslationSpringModulus Double
Translation Spring Modulus for Z axis. Ignored if Z_Translation is not "Spring".
X_Rotation TranslationRotationValue
A value indicating the option for rotation about the X axis.
X_RotationSpringModulus Double
Rotation Spring Modulus for X axis. Ignored if X_Rotation is not "Spring"

Return Value

BoundaryConditions
If successful, NewLineBoundaryConditions returns an object for the newly created BoundaryConditions with the BoundaryType = 1 - "Line". is returned if the operation fails.
Remarks
This method will only function with the Autodesk Revit Structure application.
Example
C#
VB
C++
F#
Copy
bool CreateLineConditionWithReference(AnalyticalMember column, Autodesk.Revit.Creation.Document docCreation)
{
   if (column.StructuralRole != AnalyticalStructuralRole.StructuralRoleColumn)
   {
      throw new Exception("This sample only work for columns.");
   }

   // Get the line reference for the column analytical model
   Reference lineReference = null;

   AnalyticalModelSelector selector = new AnalyticalModelSelector(column.GetCurve());
   lineReference = column.GetReference(selector);
   if (null == lineReference)
   {
      throw new Exception("Unable to get reference line for selected column.");
   }

   // Create line Boundary Conditions for the column
   BoundaryConditions condition = docCreation.NewLineBoundaryConditions(lineReference, TranslationRotationValue.Fixed, 0,
                                                                                TranslationRotationValue.Fixed, 0,
                                                                                TranslationRotationValue.Fixed, 0,
                                                                                TranslationRotationValue.Fixed, 0);
   return (null != condition);
}
Private Function CreateLineConditionWithReference(column As FamilyInstance, docCreation As Autodesk.Revit.Creation.Document) As Boolean
    If StructuralType.Column <> column.StructuralType Then
        Throw New Exception("This sample only work for columns.")
    End If

 ' Get the line reference for the column analytical model
 Dim lineReference As Reference = Nothing
 Dim analyticalModel As Autodesk.Revit.DB.Structure.AnalyticalElement = Nothing
 Dim document As Document = column.Document
 Dim relManager As Autodesk.Revit.DB.Structure.AnalyticalToPhysicalAssociationManager = Autodesk.Revit.DB.Structure.AnalyticalToPhysicalAssociationManager.GetAnalyticalToPhysicalAssociationManager(document)

 If (relManager Is Nothing) Then
    Return False
 End If

 Dim counterpartId As ElementId = relManager.GetAssociatedElementId(column.Id)
 If (counterpartId Is Nothing) Then
    Return False
 End If

 analyticalModel = document.GetElement(counterpartId)

 Dim selector As AnalyticalModelSelector = New AnalyticalModelSelector(analyticalModel.GetCurve())
 lineReference = analyticalModel.GetReference(selector)
 If lineReference Is Nothing Then
        Throw New Exception("Unable to get reference line for selected column.")
    End If

    ' Create line Boundary Conditions for the column
    Dim condition As BoundaryConditions = docCreation.NewLineBoundaryConditions(lineReference, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, _
        0, TranslationRotationValue.Fixed, 0)
    Return (condition IsNot Nothing)
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Document Class
NewLineBoundaryConditions Overload
Autodesk.Revit.Creation Namespace


Document.NewMechanicalSystem Method

DocumentNewMechanicalSystem Method

Creates a new MEP mechanical system element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MechanicalSystem NewMechanicalSystem(
    Connector baseEquipmentConnector,
    ConnectorSet connectors,
    DuctSystemType ductSystemType
)
Public Function NewMechanicalSystem (
    baseEquipmentConnector As Connector,
    connectors As ConnectorSet,
    ductSystemType As DuctSystemType
) As MechanicalSystem
public:
MechanicalSystem^ NewMechanicalSystem(
    Connector^ baseEquipmentConnector,
    ConnectorSet^ connectors,
    DuctSystemType ductSystemType
)
member NewMechanicalSystem :
        baseEquipmentConnector : Connector *
        connectors : ConnectorSet *
        ductSystemType : DuctSystemType -> MechanicalSystem

Parameters

baseEquipmentConnector Connector
One connector within base equipment which is used to connect with the system. The base equipment is optional for the system, so this argument may be . The baseEquipmentConnector should not be included in the connectors.
connectors ConnectorSet
Connectors that will connect to the system. The owner elements of these connectors will be added into system as its elements.
ductSystemType DuctSystemType
The system type.

Return Value

MechanicalSystem
If creation was successful then an instance of mechanical system is returned, otherwise an exception with information will be thrown.
Exceptions
Exception | Condition
InvalidOperationException | Thrown when calling this function outside of the Autodesk Revit MEP product.
ArgumentNullException | Thrown when the input connectors parameter value is .
ArgumentOutOfRangeException | Thrown when the ductSystemType parameter is out of permitted scope.
ArgumentException | Thrown when some connectors can't be used to create the mechanical system. All the input connectors and base equipment connector should match system type and domain with the system, and they should not have been used in another system. The owner of BaseConnector should be a mechanical equipment, and the owner of other connectors should be a mechanical equipment or air terminal.
InvalidOperationException | Thrown when the mechanical system creation failed.
Remarks
This method will regenerate the document even in manual regeneration mode.
Example
C#
VB
C++
F#
Copy
// create a connector set for new mechanical system
ConnectorSet connectorSet = new ConnectorSet();
// Base equipment connector
Connector baseConnector = null;

// Select a Parallel Fan Powered VAV and some Supply Diffusers
// prior to running this example
ConnectorSetIterator csi = null;
ICollection<ElementId> selectedIds = uiDocument.Selection.GetElementIds();
Document document = uiDocument.Document;
foreach (ElementId id in selectedIds)
{
    Element e = document.GetElement(id);
    if (e is FamilyInstance)
    {
        FamilyInstance fi = e as FamilyInstance;
        Family family = fi.Symbol.Family;
        // Assume the selected Mechanical Equipment is the base equipment for new system
        if (family.FamilyCategory.Name == "Mechanical Equipment")
        {
            //Find the "Out" and "SupplyAir" connector on the base equipment
            if (null != fi.MEPModel)
            {
                csi = fi.MEPModel.ConnectorManager.Connectors.ForwardIterator();
                while (csi.MoveNext())
                {
                    Connector conn = csi.Current as Connector;
                    if (conn.Direction == FlowDirectionType.Out && conn.DuctSystemType == DuctSystemType.SupplyAir)
                    {
                        baseConnector = conn;
                        break;
                    }
                }
            }
        }
        else if (family.FamilyCategory.Name == "Air Terminals")
        {
            // add selected Air Terminals to connector set for new mechanical system
            csi = fi.MEPModel.ConnectorManager.Connectors.ForwardIterator();
            csi.MoveNext();
            connectorSet.Insert(csi.Current as Connector);
        }
    }
}

MechanicalSystem mechanicalSys = null;
if (null != baseConnector && connectorSet.Size > 0)
{
    // create a new SupplyAir mechanical system
    mechanicalSys = uiDocument.Document.Create.NewMechanicalSystem(baseConnector, connectorSet, DuctSystemType.SupplyAir);
}
' create a connector set for new mechanical system
Dim connectorSet As New ConnectorSet()
' Base equipment connector
Dim baseConnector As Connector = Nothing

' Select a Parallel Fan Powered VAV and some Supply Diffusers
' prior to running this example
Dim csi As ConnectorSetIterator = Nothing
Dim selectedIds As ICollection(Of ElementId) = uiDocument.Selection.GetElementIds()
Dim document As Document = uiDocument.Document
For Each id As ElementId In selectedIds
    Dim e As Element = document.GetElement(id)
    If TypeOf e Is FamilyInstance Then
        Dim fi As FamilyInstance = TryCast(e, FamilyInstance)
        Dim family As Family = fi.Symbol.Family
        ' Assume the selected Mechanical Equipment is the base equipment for new system
        If family.FamilyCategory.Name = "Mechanical Equipment" Then
            'Find the "Out" and "SupplyAir" connector on the base equipment
            If fi.MEPModel IsNot Nothing Then
                csi = fi.MEPModel.ConnectorManager.Connectors.ForwardIterator()
                While csi.MoveNext()
                    Dim conn As Connector = TryCast(csi.Current, Connector)
                    If conn.Direction = FlowDirectionType.Out AndAlso conn.DuctSystemType = DuctSystemType.SupplyAir Then
                        baseConnector = conn
                        Exit While
                    End If
                End While
            End If
        ElseIf family.FamilyCategory.Name = "Air Terminals" Then
            ' add selected Air Terminals to connector set for new mechanical system
            csi = fi.MEPModel.ConnectorManager.Connectors.ForwardIterator()
            csi.MoveNext()
            connectorSet.Insert(TryCast(csi.Current, Connector))
        End If
    End If
Next

Dim mechanicalSys As MechanicalSystem = Nothing
If baseConnector IsNot Nothing AndAlso connectorSet.Size > 0 Then
    ' create a new SupplyAir mechanical system
    mechanicalSys = uiDocument.Document.Create.NewMechanicalSystem(baseConnector, connectorSet, DuctSystemType.SupplyAir)
End If

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Document Class
Autodesk.Revit.Creation Namespace


Document.NewOpening Method

DocumentNewOpening Method

Creates a new opening.
Overload List
 | Name | Description
Public method | NewOpening(Element, CurveArray, eRefFace) | Creates a new opening in a beam, brace and column.
Public method | NewOpening(Element, CurveArray, Boolean) | Creates a new opening in a roof, floor and ceiling.
Public method | NewOpening(Level, Level, CurveArray) | Creates a new shaft opening between a set of levels.
Public method | NewOpening(Wall, XYZ, XYZ) | Creates a rectangular opening on a wall.
Top
See Also

Reference

Document Class
Autodesk.Revit.Creation Namespace


Document.NewOpening(Element, CurveArray, eRefFace) Method

DocumentNewOpening(Element, CurveArray, eRefFace) Method

Creates a new opening in a beam, brace and column.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Opening NewOpening(
    Element famInstElement,
    CurveArray profile,
    eRefFace iFace
)
Public Function NewOpening (
    famInstElement As Element,
    profile As CurveArray,
    iFace As eRefFace
) As Opening
public:
Opening^ NewOpening(
    Element^ famInstElement,
    CurveArray^ profile,
    eRefFace iFace
)
member NewOpening :
        famInstElement : Element *
        profile : CurveArray *
        iFace : eRefFace -> Opening

Parameters

famInstElement Element
host element of the opening, can be a beam, brace and column.
profile CurveArray
profile of the opening.
iFace eRefFace
face on which opening is based on.

Return Value

Opening
If successful, an Opening object is returned.
Exceptions
Exception | Condition
ArgumentException | Thrown if the family instance element does not exist in the given document.
Remarks
This method forms opening on a beam, brace and column.
See Also

Reference

Document Class
NewOpening Overload
Autodesk.Revit.Creation Namespace


Document.NewOpening(Element, CurveArray, Boolean) Method

DocumentNewOpening(Element, CurveArray, Boolean) Method

Creates a new opening in a roof, floor and ceiling.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Opening NewOpening(
    Element hostElement,
    CurveArray profile,
    bool bPerpendicularFace
)
Public Function NewOpening (
    hostElement As Element,
    profile As CurveArray,
    bPerpendicularFace As Boolean
) As Opening
public:
Opening^ NewOpening(
    Element^ hostElement,
    CurveArray^ profile,
    bool bPerpendicularFace
)
member NewOpening :
        hostElement : Element *
        profile : CurveArray *
        bPerpendicularFace : bool -> Opening

Parameters

hostElement Element
Host element of the opening. Can be a roof, floor, or ceiling.
profile CurveArray
Profile of the opening.
bPerpendicularFace Boolean
True if the profile is cut perpendicular to the intersecting face of the host. False if the profile is cut vertically.

Return Value

Opening
If successful, an Opening object is returned.
Exceptions
Exception | Condition
ArgumentException | Thrown if the host element does not exist in the given document.
See Also

Reference

Document Class
NewOpening Overload
Autodesk.Revit.Creation Namespace


Document.NewOpening(Level, Level, CurveArray) Method

DocumentNewOpening(Level, Level, CurveArray) Method

Creates a new shaft opening between a set of levels.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Opening NewOpening(
    Level bottomLevel,
    Level topLevel,
    CurveArray profile
)
Public Function NewOpening (
    bottomLevel As Level,
    topLevel As Level,
    profile As CurveArray
) As Opening
public:
Opening^ NewOpening(
    Level^ bottomLevel,
    Level^ topLevel,
    CurveArray^ profile
)
member NewOpening :
        bottomLevel : Level *
        topLevel : Level *
        profile : CurveArray -> Opening

Parameters

bottomLevel Level
bottom level
topLevel Level
top level
profile CurveArray
profile of the opening.

Return Value

Opening
If successful, an Opening object is returned.
Exceptions
Exception | Condition
ArgumentException | Thrown if the bottom level does not exist in the given document.
ArgumentException | Thrown if the top level does not exist in the given document.
Remarks
This method forms an opening on floor, ceiling and roof. Make sure topLevel is higher than bottomLevel, otherwise an exception will be returned.
See Also

Reference

Document Class
NewOpening Overload
Autodesk.Revit.Creation Namespace


Document.NewOpening(Wall, XYZ, XYZ) Method

DocumentNewOpening(Wall, XYZ, XYZ) Method

Creates a rectangular opening on a wall.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Opening NewOpening(
    Wall wall,
    XYZ pntStart,
    XYZ pntEnd
)
Public Function NewOpening (
    wall As Wall,
    pntStart As XYZ,
    pntEnd As XYZ
) As Opening
public:
Opening^ NewOpening(
    Wall^ wall,
    XYZ^ pntStart,
    XYZ^ pntEnd
)
member NewOpening :
        wall : Wall *
        pntStart : XYZ *
        pntEnd : XYZ -> Opening

Parameters

wall Wall
Host element of the opening.
pntStart XYZ
One corner of the rectangle.
pntEnd XYZ
The opposite corner of the rectangle.

Return Value

Opening
If successful, an Opening object is returned.
Exceptions
Exception | Condition
ArgumentException | Thrown if the wall does not exist in the given document, or if the wall doesn't support rectangular openings.
Remarks
Slanted stacked walls do not support rectangular openings.
See Also

Reference

Document Class
NewOpening Overload
Autodesk.Revit.Creation Namespace


Document.NewPipingSystem Method

DocumentNewPipingSystem Method

Creates a new MEP piping system element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PipingSystem NewPipingSystem(
    Connector baseEquipmentConnector,
    ConnectorSet connectors,
    PipeSystemType pipingSystemType
)
Public Function NewPipingSystem (
    baseEquipmentConnector As Connector,
    connectors As ConnectorSet,
    pipingSystemType As PipeSystemType
) As PipingSystem
public:
PipingSystem^ NewPipingSystem(
    Connector^ baseEquipmentConnector,
    ConnectorSet^ connectors,
    PipeSystemType pipingSystemType
)
member NewPipingSystem :
        baseEquipmentConnector : Connector *
        connectors : ConnectorSet *
        pipingSystemType : PipeSystemType -> PipingSystem

Parameters

baseEquipmentConnector Connector
One connector within base equipment which is used to connect with the system. The base equipment is optional for the system, so this argument may be . The baseEquipmentConnector should not be included in the connectors.
connectors ConnectorSet
Connectors that will connect to the system. The owner elements of these connectors will be added into system as its elements.
pipingSystemType PipeSystemType
The System type.

Return Value

PipingSystem
If creation was successful then an instance of piping system is returned, otherwise an exception with information will be thrown.
Exceptions
Exception | Condition
InvalidOperationException | Thrown when calling this function outside of the Autodesk Revit MEP product.
ArgumentNullException | Thrown when the connectors parameter value is .
ArgumentOutOfRangeException | Thrown when the pipingSystemType parameter value is out of permitted scope.
ArgumentException | Thrown when some connectors can't be used to create the mechanical system. All the input connectors and base equipment connector should match system type and domain with the system, and they should not have been used in another system.
InvalidOperationException | Thrown when the piping system creation failed.
Remarks
This method will regenerate the document even in manual regeneration mode.
See Also

Reference

Document Class
Autodesk.Revit.Creation Namespace


Document.NewPointBoundaryConditions Method

DocumentNewPointBoundaryConditions Method

Creates a new Point BoundaryConditions Element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BoundaryConditions NewPointBoundaryConditions(
    Reference reference,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus,
    TranslationRotationValue X_Rotation,
    double X_RotationSpringModulus,
    TranslationRotationValue Y_Rotation,
    double Y_RotationSpringModulus,
    TranslationRotationValue Z_Rotation,
    double Z_RotationSpringModulus
)
Public Function NewPointBoundaryConditions (
    reference As Reference,
    X_Translation As TranslationRotationValue,
    X_TranslationSpringModulus As Double,
    Y_Translation As TranslationRotationValue,
    Y_TranslationSpringModulus As Double,
    Z_Translation As TranslationRotationValue,
    Z_TranslationSpringModulus As Double,
    X_Rotation As TranslationRotationValue,
    X_RotationSpringModulus As Double,
    Y_Rotation As TranslationRotationValue,
    Y_RotationSpringModulus As Double,
    Z_Rotation As TranslationRotationValue,
    Z_RotationSpringModulus As Double
) As BoundaryConditions
public:
BoundaryConditions^ NewPointBoundaryConditions(
    Reference^ reference,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus,
    TranslationRotationValue X_Rotation,
    double X_RotationSpringModulus,
    TranslationRotationValue Y_Rotation,
    double Y_RotationSpringModulus,
    TranslationRotationValue Z_Rotation,
    double Z_RotationSpringModulus
)
member NewPointBoundaryConditions :
        reference : Reference *
        X_Translation : TranslationRotationValue *
        X_TranslationSpringModulus : float *
        Y_Translation : TranslationRotationValue *
        Y_TranslationSpringModulus : float *
        Z_Translation : TranslationRotationValue *
        Z_TranslationSpringModulus : float *
        X_Rotation : TranslationRotationValue *
        X_RotationSpringModulus : float *
        Y_Rotation : TranslationRotationValue *
        Y_RotationSpringModulus : float *
        Z_Rotation : TranslationRotationValue *
        Z_RotationSpringModulus : float -> BoundaryConditions

Parameters

reference Reference
A Geometry reference to a Beam's, Brace's or Column's analytical line end.
X_Translation TranslationRotationValue
A value indicating the X axis translation option.
X_TranslationSpringModulus Double
Translation Spring Modulus for X axis. Ignored if X_Translation is not "Spring".
Y_Translation TranslationRotationValue
A value indicating the Y axis translation option.
Y_TranslationSpringModulus Double
Translation Spring Modulus for Y axis. Ignored if Y_Translation is not "Spring".
Z_Translation TranslationRotationValue
A value indicating the Z axis translation option.
Z_TranslationSpringModulus Double
Translation Spring Modulus for Z axis. Ignored if Z_Translation is not "Spring".
X_Rotation TranslationRotationValue
A value indicating the option for rotation about the X axis.
X_RotationSpringModulus Double
Rotation Spring Modulus for X axis. Ignored if X_Rotation is not "Spring".
Y_Rotation TranslationRotationValue
A value indicating the option for rotation about the Y axis.
Y_RotationSpringModulus Double
Rotation Spring Modulus for Y axis. Ignored if Y_Rotation is not "Spring".
Z_Rotation TranslationRotationValue
A value indicating the option for rotation about the Z axis.
Z_RotationSpringModulus Double
Rotation Spring Modulus for Z axis. Ignored if Y_Rotation is not "Spring".

Return Value

BoundaryConditions
If successful, NewPointBoundaryConditions returns an object for the newly created BoundaryConditions with the BoundaryType = 0 - "Point". is returned if the operation fails.
Remarks
This method will only function with the Autodesk Revit Structure application.
Example
C#
VB
C++
F#
Copy
bool CreatePointBoundaryCondition(Autodesk.Revit.DB.Document document, AnalyticalMember column)
{
   // Get the start point reference of the column
   Reference startReference = null;
   if (null != column)
   {
      AnalyticalModelSelector selector = new AnalyticalModelSelector(column.GetCurve(), AnalyticalCurveSelector.StartPoint);
      startReference = column.GetReference(selector);
   }
   else
   {
      throw new Exception("Cannot get end point for selected column");
   }

   // Get the Revit creation document
   Autodesk.Revit.Creation.Document docCreation = document.Create;

   // Create the Point Boundary Conditions for the start point
   BoundaryConditions condition = docCreation.NewPointBoundaryConditions(startReference,
                                                                         TranslationRotationValue.Fixed, 0,
                                                                         TranslationRotationValue.Fixed, 0,
                                                                         TranslationRotationValue.Fixed, 0,
                                                                         TranslationRotationValue.Fixed, 0,
                                                                         TranslationRotationValue.Fixed, 0,
                                                                         TranslationRotationValue.Fixed, 0);
   if (null == condition)
   {
      throw new Exception("Can't create the point boundary condition for selected column start point.");
   }

   // Give the user some information
   TaskDialog.Show("Revit", "Point boundary condition created successfully.");

   return (null != condition);
}
Private Function CreatePointBoundaryCondition(document As Autodesk.Revit.DB.Document, column As FamilyInstance) As Boolean
    ' Get the start point reference of the column
    Dim startReference As Reference = Nothing
 Dim analyticalModel As Autodesk.Revit.DB.Structure.AnalyticalElement = Nothing
 Dim relManager As Autodesk.Revit.DB.Structure.AnalyticalToPhysicalAssociationManager = Autodesk.Revit.DB.Structure.AnalyticalToPhysicalAssociationManager.GetAnalyticalToPhysicalAssociationManager(document)

 If (relManager Is Nothing) Then
    Return False
 End If

 Dim counterpartId As ElementId = relManager.GetAssociatedElementId(column.Id)
 If (counterpartId Is Nothing) Then
    Return False
 End If

 analyticalModel = document.GetElement(counterpartId)

 If analyticalModel IsNot Nothing Then
    Dim selector As AnalyticalModelSelector = New AnalyticalModelSelector(analyticalModel.GetCurve(), AnalyticalCurveSelector.StartPoint)
    startReference = analyticalModel.GetReference(selector)
 Else
    Throw New Exception("Cannot get end point for selected column")
    End If

    ' Get the Revit creation document
    Dim docCreation As Autodesk.Revit.Creation.Document = document.Create

    ' Create the Point Boundary Conditions for the start point
    Dim condition As BoundaryConditions = docCreation.NewPointBoundaryConditions(startReference, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, _
        0, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, _
        0)
    If condition Is Nothing Then
        Throw New Exception("Can't create the point boundary condition for selected column start point.")
    End If

    ' Give the user some information
    TaskDialog.Show("Revit", "Point boundary condition created successfully.")

    Return (condition IsNot Nothing)
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Document Class
Autodesk.Revit.Creation Namespace


Document.NewRoom Method

DocumentNewRoom Method

Creates a new room.
Overload List
 | Name | Description
Public method | NewRoom(Phase) | Creates a new unplaced room and with an assigned phase.
 | NewRoom(Level, UV) | Creates a new room on a level at a specified point.
 | NewRoom(Room, PlanCircuit) | Creates a new room within the confines of a plan circuit, or places an unplaced room within the confines of the plan circuit.
Top
See Also

Reference

Document Class
Autodesk.Revit.Creation Namespace


Document.NewRoom(Phase) Method

DocumentNewRoom(Phase) Method

Creates a new unplaced room and with an assigned phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Room NewRoom(
    Phase phase
)
Public Function NewRoom (
    phase As Phase
) As Room
public:
Room^ NewRoom(
    Phase^ phase
)
member NewRoom :
        phase : Phase -> Room

Parameters

phase Phase
The phase in which the room is to exist.

Return Value

Room
If successful the new room , otherwise .
Exceptions
Exception | Condition
ArgumentException | Thrown if the phase does not exist in the given document.
See Also

Reference

Document Class
NewRoom Overload
Autodesk.Revit.Creation Namespace


Document.NewRoom(Level, UV) Method

DocumentNewRoom(Level, UV) Method

Creates a new room on a level at a specified point.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Room NewRoom(
    Level level,
    UV point
)
Public Function NewRoom (
    level As Level,
    point As UV
) As Room
public:
Room^ NewRoom(
    Level^ level,
    UV^ point
)
member NewRoom :
        level : Level *
        point : UV -> Room

Parameters

level Level
The level on which the room is to exist.
point UV
A 2D point that dictates the location of the room on that specified level.

Return Value

Room
If successful the new room will be returned, otherwise .
Exceptions
Exception | Condition
ArgumentException | Thrown if the level does not exist in the given document.
Remarks
This method will regenerate the document even in manual regeneration mode.
Example
C#
VB
C++
F#
Copy
Room CreateRoom(Autodesk.Revit.DB.Document document, Level level)
{
    // Create a UV structure which determines the room location
   UV roomLocation = new UV(0, 0);

    // Create a new room
    Room room = document.Create.NewRoom(level, roomLocation);
    if (null == room)
    {
        throw new Exception("Create a new room failed.");
    }

    return room;
}
Private Function CreateRoom(document As Autodesk.Revit.DB.Document, level As Level) As Room
    ' Create a UV structure which determines the room location
    Dim roomLocation As New UV(0, 0)

    ' Create a new room
    Dim room As Room = document.Create.NewRoom(level, roomLocation)
    If room Is Nothing Then
        Throw New Exception("Create a new room failed.")
    End If

    Return room
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Document Class
NewRoom Overload
Autodesk.Revit.Creation Namespace


Document.NewRoom(Room, PlanCircuit) Method

DocumentNewRoom(Room, PlanCircuit) Method

Creates a new room within the confines of a plan circuit, or places an unplaced room within the confines of the plan circuit.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Room NewRoom(
    Room room,
    PlanCircuit circuit
)
Public Function NewRoom (
    room As Room,
    circuit As PlanCircuit
) As Room
public:
Room^ NewRoom(
    Room^ room,
    PlanCircuit^ circuit
)
member NewRoom :
        room : Room *
        circuit : PlanCircuit -> Room

Parameters

room Room
The room which you want to locate in the circuit. Pass to create a new room.
circuit PlanCircuit
The circuit in which you want to locate a room.

Return Value

Room
If successful the room is returned, otherwise .
Exceptions
Exception | Condition
InvalidOperationException | If the existing room is already placed.
ArgumentException | Thrown if the room does not exist in the given document.
ArgumentException | Thrown if the circuit does not exist in the given document.
InvalidOperationException | Thrown if the level obtained from the circuit has no associated view .
Remarks
This method will regenerate the document even in manual regeneration mode.
Example
C#
VB
C++
F#
Copy
Room InsertNewRoomInPlanCircuit(Autodesk.Revit.DB.Document document, Level level, Phase newConstructionPhase)
{
    // create room using Phase
    Room newScheduleRoom = document.Create.NewRoom(newConstructionPhase);

    // set the Room Number and Name
    string newRoomNumber = "101";
    string newRoomName = "Class Room 1";
    newScheduleRoom.Name = newRoomName;
    newScheduleRoom.Number = newRoomNumber;

    // Get a PlanCircuit
    PlanCircuit planCircuit = null;
    // first get the plan topology for given level
    PlanTopology planTopology = document.get_PlanTopology(level);

    // Iterate circuits in this plan topology
    foreach (PlanCircuit circuit in planTopology.Circuits)
    {
        // get the first circuit we find
        if (null != circuit)
        {
            planCircuit = circuit;
            break;
        }
    }

    Room newRoom2 = null;
    if (null != planCircuit)
    {
        using (Transaction transaction = new Transaction(document, "Create Room"))
        {
           if (transaction.Start() == TransactionStatus.Started)
           {
               // The input room must exist only in the room schedule,
               // meaning that it does not display in any plan view.
               newRoom2 = document.Create.NewRoom(newScheduleRoom, planCircuit);
               // a model room with the same name and number is created in the
               // view where the PlanCircuit is located
               if (null != newRoom2)
               {
                   // Give the user some information
                   TaskDialog.Show("Revit", "Room placed in Plan Circuit successfully.");
               }
               transaction.Commit();
           }
        }
    }

    return newRoom2;
}
Private Function InsertNewRoomInPlanCircuit(document As Autodesk.Revit.DB.Document, level As Level, newConstructionPhase As Phase) As Room
    ' create room using Phase
    Dim newScheduleRoom As Room = document.Create.NewRoom(newConstructionPhase)

    ' set the Room Number and Name
    Dim newRoomNumber As String = "101"
    Dim newRoomName As String = "Class Room 1"
    newScheduleRoom.Name = newRoomName
    newScheduleRoom.Number = newRoomNumber

    ' Get a PlanCircuit
    Dim planCircuit As PlanCircuit = Nothing
    ' first get the plan topology for given level
    Dim planTopology As PlanTopology = document.PlanTopology(level)

    ' Iterate circuits in this plan topology
    For Each circuit As PlanCircuit In planTopology.Circuits
        ' get the first circuit we find
        If circuit IsNot Nothing Then
            planCircuit = circuit
            Exit For
        End If
    Next

    Dim newRoom2 As Room = Nothing
    If planCircuit IsNot Nothing Then
        Using transaction As New Transaction(document, "Create Room")
            If transaction.Start() = TransactionStatus.Started Then
                ' The input room must exist only in the room schedule,
                ' meaning that it does not display in any plan view.
                newRoom2 = document.Create.NewRoom(newScheduleRoom, planCircuit)
                ' a model room with the same name and number is created in the
                ' view where the PlanCircuit is located
                If newRoom2 IsNot Nothing Then
                    ' Give the user some information
                    TaskDialog.Show("Revit", "Room placed in Plan Circuit successfully.")
                End If
                transaction.Commit()
            End If
        End Using
    End If

    Return newRoom2
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Document Class
NewRoom Overload
Autodesk.Revit.Creation Namespace


Document.NewRoomBoundaryLines Method

DocumentNewRoomBoundaryLines Method

Creates a new boundary line as an Room border.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ModelCurveArray NewRoomBoundaryLines(
    SketchPlane sketchPlane,
    CurveArray curves,
    View view
)
Public Function NewRoomBoundaryLines (
    sketchPlane As SketchPlane,
    curves As CurveArray,
    view As View
) As ModelCurveArray
public:
ModelCurveArray^ NewRoomBoundaryLines(
    SketchPlane^ sketchPlane,
    CurveArray^ curves,
    View^ view
)
member NewRoomBoundaryLines :
        sketchPlane : SketchPlane *
        curves : CurveArray *
        view : View -> ModelCurveArray

Parameters

sketchPlane SketchPlane
The sketch plan
curves CurveArray
The geometry curves on which the boundary lines are
view View
The View for the new Room

Return Value

ModelCurveArray
Exceptions
Exception | Condition
ArgumentException | Thrown if the sketch plane does not exist in the given document.
ArgumentException | Thrown if the view does not exist in the given document.
See Also

Reference

Document Class
Autodesk.Revit.Creation Namespace


Document.NewRooms2 Method

DocumentNewRooms2 Method

Overload List
 | Name | Description
Public method | NewRooms2(Level) | Creates new rooms in each plan circuit found in the given level in the last phase.
Public method | NewRooms2(Level, Phase) | Creates new rooms in each plan circuit found in the given level in the given phase.
Public method | NewRooms2(Phase, Int32) | Creates new unplaced rooms in the given phase.
Top
See Also

Reference

Document Class
Autodesk.Revit.Creation Namespace


Document.NewRooms2(Level) Method

DocumentNewRooms2(Level) Method

Creates new rooms in each plan circuit found in the given level in the last phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> NewRooms2(
    Level level
)
Public Function NewRooms2 (
    level As Level
) As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ NewRooms2(
    Level^ level
)
member NewRooms2 :
        level : Level -> ICollection<ElementId>

Parameters

level Level
The level from which the circuits are found.

Return Value

ICollection ElementId
If successful, a set of ElementIds which contains the rooms created should be returned, otherwise .
Exceptions
Exception | Condition
ArgumentOutOfRangeException | If the view of the relevant level can not be retrieved.
InvalidOperationException | If the phase is invalid, or regeneration fails at the end of the creation.
ArgumentException | Thrown if the level does not exist in the given document.
See Also

Reference

Document Class
NewRooms2 Overload
Autodesk.Revit.Creation Namespace


Document.NewRooms2(Level, Phase) Method

DocumentNewRooms2(Level, Phase) Method

Creates new rooms in each plan circuit found in the given level in the given phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> NewRooms2(
    Level level,
    Phase phase
)
Public Function NewRooms2 (
    level As Level,
    phase As Phase
) As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ NewRooms2(
    Level^ level,
    Phase^ phase
)
member NewRooms2 :
        level : Level *
        phase : Phase -> ICollection<ElementId>

Parameters

level Level
The level from which the circuits are found.
phase Phase
The phase on which the room is to exist.

Return Value

ICollection ElementId
If successful, a set of ElementIds which contains the rooms should be returned, otherwise the exception will be thrown.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | If the view of the relevant level can not be retrieved.
InvalidOperationException | If the phase is invalid, or regeneration fails at the end of the creation.
ArgumentException | Thrown if the level does not exist in the given document.
ArgumentException | Thrown if the phase does not exist in the given document.
See Also

Reference

Document Class
NewRooms2 Overload
Autodesk.Revit.Creation Namespace


Document.NewRooms2(Phase, Int32) Method

DocumentNewRooms2(Phase, Int32) Method

Creates new unplaced rooms in the given phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> NewRooms2(
    Phase phase,
    int count
)
Public Function NewRooms2 (
    phase As Phase,
    count As Integer
) As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ NewRooms2(
    Phase^ phase,
    int count
)
member NewRooms2 :
        phase : Phase *
        count : int -> ICollection<ElementId>

Parameters

phase Phase
The phase on which the rooms are to exist.
count Int32
The number of the rooms to be created.

Return Value

ICollection ElementId
If successful, a set of ElementIds which contains the rooms should be returned, otherwise the exception will be thrown.
Exceptions
Exception | Condition
InvalidOperationException | If the room can not be created successfully or regeneration fails at the end of the creation.
ArgumentException | Thrown if the phase does not exist in the given document.
See Also

Reference

Document Class
NewRooms2 Overload
Autodesk.Revit.Creation Namespace


Document.NewRoomTag Method

DocumentNewRoomTag Method

Creates a new RoomTag referencing a room in the host model or in a Revit link.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RoomTag NewRoomTag(
    LinkElementId roomId,
    UV point,
    ElementId viewId
)
Public Function NewRoomTag (
    roomId As LinkElementId,
    point As UV,
    viewId As ElementId
) As RoomTag
public:
RoomTag^ NewRoomTag(
    LinkElementId^ roomId,
    UV^ point,
    ElementId^ viewId
)
member NewRoomTag :
        roomId : LinkElementId *
        point : UV *
        viewId : ElementId -> RoomTag

Parameters

roomId LinkElementId
The HostOrLinkElementId of the Room.
point UV
A 2D point that defines the tag location on the level of the room.
viewId ElementId
The id of the view where the tag will be shown. If and the room in not in a Revit link, the view of the room will be used.

Return Value

RoomTag
If successful a RoomTag object will be returned, otherwise .
Exceptions
Exception | Condition
ArgumentException | viewId is not associated with a plan view or section view.
InvalidOperationException | viewId is null and the room is in a linked file.
Example
C#
VB
C++
F#
Copy
RoomTag CreateRoomTag(Autodesk.Revit.DB.Document document, Room room)
{
    // Create a UV structure which determine the room tag location
   UV roomTagLocation = new UV(0, 0);

    // Create a new room tag in the created room
    LinkElementId roomId = new LinkElementId(room.Id);
    RoomTag roomTag = document.Create.NewRoomTag(roomId, roomTagLocation, ElementId.InvalidElementId);
    if (null == roomTag)
    {
        throw new Exception("Create a new room tag failed.");
    }

    // Give the user some information
    TaskDialog.Show("Revit","Room tag created successfully.");

    return roomTag;
}
Private Function CreateRoomTag(document As Autodesk.Revit.DB.Document, room As Room) As RoomTag
    ' Create a UV structure which determine the room tag location
    Dim roomTagLocation As New UV(0, 0)

    ' Create a new room tag in the created room
    Dim roomId As New LinkElementId(room.Id)
    Dim roomTag As RoomTag = document.Create.NewRoomTag(roomId, roomTagLocation, ElementId.InvalidElementId)
    If roomTag Is Nothing Then
        Throw New Exception("Create a new room tag failed.")
    End If

    ' Give the user some information
    TaskDialog.Show("Revit", "Room tag created successfully.")

    Return roomTag
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Document Class
Autodesk.Revit.Creation Namespace


Document.NewSlabEdge Method

DocumentNewSlabEdge Method

Creates a slab edge.
Overload List
 | Name | Description
Public method | NewSlabEdge(SlabEdgeType, Reference) | Creates a slab edge along a reference.
Public method | NewSlabEdge(SlabEdgeType, ReferenceArray) | Creates a slab edge along a reference array.
Top
See Also

Reference

Document Class
Autodesk.Revit.Creation Namespace


Document.NewSlabEdge(SlabEdgeType, Reference) Method

DocumentNewSlabEdge(SlabEdgeType, Reference) Method

Creates a slab edge along a reference.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SlabEdge NewSlabEdge(
    SlabEdgeType SlabEdgeType,
    Reference reference
)
Public Function NewSlabEdge (
    SlabEdgeType As SlabEdgeType,
    reference As Reference
) As SlabEdge
public:
SlabEdge^ NewSlabEdge(
    SlabEdgeType^ SlabEdgeType,
    Reference^ reference
)
member NewSlabEdge :
        SlabEdgeType : SlabEdgeType *
        reference : Reference -> SlabEdge

Parameters

SlabEdgeType SlabEdgeType
The type of the slab edge to create
reference Reference
A planar line or arc that represents the place where you want to place the slab edge.

Return Value

SlabEdge
If successful a new slab edge object within the project, otherwise .
Exceptions
Exception | Condition
ArgumentException | Thrown if the slab edge type does not exist in the given document.
See Also

Reference

Document Class
NewSlabEdge Overload
Autodesk.Revit.Creation Namespace


Document.NewSlabEdge(SlabEdgeType, ReferenceArray) Method

DocumentNewSlabEdge(SlabEdgeType, ReferenceArray) Method

Creates a slab edge along a reference array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SlabEdge NewSlabEdge(
    SlabEdgeType SlabEdgeType,
    ReferenceArray references
)
Public Function NewSlabEdge (
    SlabEdgeType As SlabEdgeType,
    references As ReferenceArray
) As SlabEdge
public:
SlabEdge^ NewSlabEdge(
    SlabEdgeType^ SlabEdgeType,
    ReferenceArray^ references
)
member NewSlabEdge :
        SlabEdgeType : SlabEdgeType *
        references : ReferenceArray -> SlabEdge

Parameters

SlabEdgeType SlabEdgeType
The type of the slab edge to create
references ReferenceArray
An array of planar lines and arcs that represents the place where you want to place the slab edge.

Return Value

SlabEdge
If successful a new slab edge object within the project, otherwise .
Exceptions
Exception | Condition
ArgumentException | Thrown if the slab edge type does not exist in the given document.
See Also

Reference

Document Class
NewSlabEdge Overload
Autodesk.Revit.Creation Namespace


Document.NewSpace Method

DocumentNewSpace Method

Creates a new space.
Overload List
 | Name | Description
Public method | NewSpace(Phase) | Creates a new unplaced space on a given phase.
Public method | NewSpace(Level, UV) | Creates a new space element on the given level at the given location.
Public method | NewSpace(Level, Phase, UV) | Creates a new space element on the given level, at the given location, and assigned to the given phase.
Top
See Also

Reference

Document Class
Autodesk.Revit.Creation Namespace


Document.NewSpace(Phase) Method

DocumentNewSpace(Phase) Method

Creates a new unplaced space on a given phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Space NewSpace(
    Phase phase
)
Public Function NewSpace (
    phase As Phase
) As Space
public:
Space^ NewSpace(
    Phase^ phase
)
member NewSpace :
        phase : Phase -> Space

Parameters

phase Phase
The phase in which the space is to exist.

Return Value

Space
If successful the new space should be returned, otherwise .
Exceptions
Exception | Condition
ArgumentException | Thrown if the phase does not exist in the given document.
See Also

Reference

Document Class
NewSpace Overload
Autodesk.Revit.Creation Namespace


Document.NewSpace(Level, UV) Method

DocumentNewSpace(Level, UV) Method

Creates a new space element on the given level at the given location.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Space NewSpace(
    Level level,
    UV point
)
Public Function NewSpace (
    level As Level,
    point As UV
) As Space
public:
Space^ NewSpace(
    Level^ level,
    UV^ point
)
member NewSpace :
        level : Level *
        point : UV -> Space

Parameters

level Level
The level on which the space is to exist.
point UV
A 2D point that dictates the location on that specified level.

Return Value

Space
If successful the new space element is returned, otherwise .
Exceptions
Exception | Condition
ArgumentNullException | Thrown when level or point is .
InvalidOperationException | Thrown when the space cannot be created.
ArgumentException | Thrown if the level does not exist in the given document.
See Also

Reference

Document Class
NewSpace Overload
Autodesk.Revit.Creation Namespace


Document.NewSpace(Level, Phase, UV) Method

DocumentNewSpace(Level, Phase, UV) Method

Creates a new space element on the given level, at the given location, and assigned to the given phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Space NewSpace(
    Level level,
    Phase phase,
    UV point
)
Public Function NewSpace (
    level As Level,
    phase As Phase,
    point As UV
) As Space
public:
Space^ NewSpace(
    Level^ level,
    Phase^ phase,
    UV^ point
)
member NewSpace :
        level : Level *
        phase : Phase *
        point : UV -> Space

Parameters

level Level
The level on which the room is to exist.
phase Phase
The phase in which the room is to exist.
point UV
A 2D point that dictates the location on that specified level.

Return Value

Space
If successful a new Space element within the project, otherwise .
Exceptions
Exception | Condition
ArgumentNullException | Thrown when level, phase or point is .
InvalidOperationException | Thrown when the space cannot be created.
ArgumentException | Thrown if the level does not exist in the given document.
ArgumentException | Thrown if the phase does not exist in the given document.
See Also

Reference

Document Class
NewSpace Overload
Autodesk.Revit.Creation Namespace


Document.NewSpaceBoundaryLines Method

DocumentNewSpaceBoundaryLines Method

Creates a new boundary line as an Space border.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ModelCurveArray NewSpaceBoundaryLines(
    SketchPlane sketchPlane,
    CurveArray curves,
    View view
)
Public Function NewSpaceBoundaryLines (
    sketchPlane As SketchPlane,
    curves As CurveArray,
    view As View
) As ModelCurveArray
public:
ModelCurveArray^ NewSpaceBoundaryLines(
    SketchPlane^ sketchPlane,
    CurveArray^ curves,
    View^ view
)
member NewSpaceBoundaryLines :
        sketchPlane : SketchPlane *
        curves : CurveArray *
        view : View -> ModelCurveArray

Parameters

sketchPlane SketchPlane
The sketch plan
curves CurveArray
The geometry curves on which the boundary lines are
view View
The View for the new Space

Return Value

ModelCurveArray
Exceptions
Exception | Condition
ArgumentException | Thrown if the sketch plane does not exist in the given document.
ArgumentException | Thrown if the view does not exist in the given document.
See Also

Reference

Document Class
Autodesk.Revit.Creation Namespace


Document.NewSpaces2 Method

DocumentNewSpaces2 Method

Creates one or more spaces.
Overload List
 | Name | Description
Public method | NewSpaces2(Phase, Int32) | Creates a set of new unplaced spaces on a given phase.
Public method | NewSpaces2(Level, Phase, View) | Creates new spaces on the available plan circuits of a the given level.
Top
See Also

Reference

Document Class
Autodesk.Revit.Creation Namespace


Document.NewSpaces2(Phase, Int32) Method

DocumentNewSpaces2(Phase, Int32) Method

Creates a set of new unplaced spaces on a given phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> NewSpaces2(
    Phase phase,
    int count
)
Public Function NewSpaces2 (
    phase As Phase,
    count As Integer
) As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ NewSpaces2(
    Phase^ phase,
    int count
)
member NewSpaces2 :
        phase : Phase *
        count : int -> ICollection<ElementId>

Parameters

phase Phase
The phase in which the spaces are to exist.
count Int32

Return Value

ICollection ElementId
If successful, a set of ElementIds of new unplaced spaces are be returned, otherwise .
Exceptions
Exception | Condition
ArgumentException | Thrown if the phase does not exist in the given document.
See Also

Reference

Document Class
NewSpaces2 Overload
Autodesk.Revit.Creation Namespace


Document.NewSpaces2(Level, Phase, View) Method

DocumentNewSpaces2(Level, Phase, View) Method

Creates new spaces on the available plan circuits of a the given level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> NewSpaces2(
    Level level,
    Phase phase,
    View view
)
Public Function NewSpaces2 (
    level As Level,
    phase As Phase,
    view As View
) As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ NewSpaces2(
    Level^ level,
    Phase^ phase,
    View^ view
)
member NewSpaces2 :
        level : Level *
        phase : Phase *
        view : View -> ICollection<ElementId>

Parameters

level Level
The level on which the spaces is to exist.
phase Phase
The phase in which the spaces is to exist.
view View
The view on which the space tags for the spaces are to display.

Return Value

ICollection ElementId
If successful, a set of ElementIds which contains the rooms should be returned, otherwise the exception will be thrown.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The view of the relevant level can not be retrieved.
InvalidOperationException | The phase is invalid or regeneration fails at the end of the creation.
ArgumentException | Thrown if the level does not exist in the given document.
ArgumentException | Thrown if the phase does not exist in the given document.
ArgumentException | Thrown if the view does not exist in the given document.
Remarks
This method will regenerate the document even in manual regeneration mode.
See Also

Reference

Document Class
NewSpaces2 Overload
Autodesk.Revit.Creation Namespace


Document.NewSpaceTag Method

DocumentNewSpaceTag Method

Creates a new SpaceTag.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SpaceTag NewSpaceTag(
    Space space,
    UV point,
    View view
)
Public Function NewSpaceTag (
    space As Space,
    point As UV,
    view As View
) As SpaceTag
public:
SpaceTag^ NewSpaceTag(
    Space^ space,
    UV^ point,
    View^ view
)
member NewSpaceTag :
        space : Space *
        point : UV *
        view : View -> SpaceTag

Parameters

space Space
The Space which the tag refers.
point UV
A 2D point that dictates the location on the level of the space.
view View
The view where the tag will lie.

Return Value

SpaceTag
If successful a SpaceTag object will be returned, otherwise . Suitable exceptions will be fired if the parameters are invalid.
Exceptions
Exception | Condition
ArgumentException | Thrown if the space does not exist in the given document.
ArgumentException | Thrown if the view does not exist in the given document.
See Also

Reference

Document Class
Autodesk.Revit.Creation Namespace


Document.NewSpotCoordinate Method

DocumentNewSpotCoordinate Method

Generate a new spot coordinate object within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SpotDimension NewSpotCoordinate(
    View view,
    Reference reference,
    XYZ origin,
    XYZ bend,
    XYZ end,
    XYZ refPt,
    bool hasLeader
)
Public Function NewSpotCoordinate (
    view As View,
    reference As Reference,
    origin As XYZ,
    bend As XYZ,
    end As XYZ,
    refPt As XYZ,
    hasLeader As Boolean
) As SpotDimension
public:
SpotDimension^ NewSpotCoordinate(
    View^ view,
    Reference^ reference,
    XYZ^ origin,
    XYZ^ bend,
    XYZ^ end,
    XYZ^ refPt,
    bool hasLeader
)
member NewSpotCoordinate :
        view : View *
        reference : Reference *
        origin : XYZ *
        bend : XYZ *
        end : XYZ *
        refPt : XYZ *
        hasLeader : bool -> SpotDimension

Parameters

view View
The view in which the spot coordinate is to be visible.
reference Reference
The reference to which the spot coordinate is to be bound.
origin XYZ
The point which the spot coordinate evaluate.
bend XYZ
The bend point for the spot coordinate.
end XYZ
The end point for the spot coordinate.
refPt XYZ
The actual point on the reference which the spot coordinate evaluate.
hasLeader Boolean
Indicate if it has leader or not.

Return Value

SpotDimension
If successful a new spot dimension object, otherwise .
Exceptions
Exception | Condition
ArgumentException | Thrown if the view does not exist in the given document.
Remarks
If the origin point is not on the reference, it'll be projected to the reference automatically. And the refPt is projected point. If the reference is not valid or the point cannot be projected to reference correctly, an exception will be thrown
See Also

Reference

Document Class
Autodesk.Revit.Creation Namespace


Document.NewSpotElevation Method

DocumentNewSpotElevation Method

Generate a new spot elevation object within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SpotDimension NewSpotElevation(
    View view,
    Reference reference,
    XYZ origin,
    XYZ bend,
    XYZ end,
    XYZ refPt,
    bool hasLeader
)
Public Function NewSpotElevation (
    view As View,
    reference As Reference,
    origin As XYZ,
    bend As XYZ,
    end As XYZ,
    refPt As XYZ,
    hasLeader As Boolean
) As SpotDimension
public:
SpotDimension^ NewSpotElevation(
    View^ view,
    Reference^ reference,
    XYZ^ origin,
    XYZ^ bend,
    XYZ^ end,
    XYZ^ refPt,
    bool hasLeader
)
member NewSpotElevation :
        view : View *
        reference : Reference *
        origin : XYZ *
        bend : XYZ *
        end : XYZ *
        refPt : XYZ *
        hasLeader : bool -> SpotDimension

Parameters

view View
The view in which the spot elevation is to be visible.
reference Reference
The reference to which the spot elevation is to be bound.
origin XYZ
The point which the spot elevation evaluate.
bend XYZ
The bend point for the spot elevation.
end XYZ
The end point for the spot elevation.
refPt XYZ
The actual point on the reference which the spot elevation evaluate.
hasLeader Boolean
Indicate if it has leader or not.

Return Value

SpotDimension
If successful a new spot dimension object, otherwise .
Exceptions
Exception | Condition
ArgumentException | Thrown if the view does not exist in the given document.
Remarks
If the origin point is not on the reference, it'll be projected to the reference automatically. And the refPt is the projected point. If the reference is not valid or the point cannot be projected to reference correctly, an exception will be thrown
See Also

Reference

Document Class
Autodesk.Revit.Creation Namespace


Document.NewTakeoffFitting Method

DocumentNewTakeoffFitting Method

Add a new family instance of an takeoff fitting into the Autodesk Revit document, using one connector and one MEP curve.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyInstance NewTakeoffFitting(
    Connector connector,
    MEPCurve curve
)
Public Function NewTakeoffFitting (
    connector As Connector,
    curve As MEPCurve
) As FamilyInstance
public:
FamilyInstance^ NewTakeoffFitting(
    Connector^ connector,
    MEPCurve^ curve
)
member NewTakeoffFitting :
        connector : Connector *
        curve : MEPCurve -> FamilyInstance

Parameters

connector Connector
The connector to be connected to the takeoff.
curve MEPCurve
The duct or pipe which is the trunk for the takeoff.

Return Value

FamilyInstance
If creation was successful then an family instance to the new object is returned, otherwise an exception with failure information will be thrown.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument connector1 or curve is .
ArgumentException | Thrown when the connector and the curve cannot be used for takeoff creation. For example, they must be of the same domain, the curve must be a duct or pipe, and the owner of the connector should be (flex) duct or pipe.
InvalidOperationException | Thrown when takeoff fitting cannot be created.
ArgumentException | Thrown if the curve does not exist in the given document.
See Also

Reference

Document Class
Autodesk.Revit.Creation Namespace


Document.NewTeeFitting Method

DocumentNewTeeFitting Method

Add a new family instance of a tee fitting into the Autodesk Revit document, using three connectors.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyInstance NewTeeFitting(
    Connector connector1,
    Connector connector2,
    Connector connector3
)
Public Function NewTeeFitting (
    connector1 As Connector,
    connector2 As Connector,
    connector3 As Connector
) As FamilyInstance
public:
FamilyInstance^ NewTeeFitting(
    Connector^ connector1,
    Connector^ connector2,
    Connector^ connector3
)
member NewTeeFitting :
        connector1 : Connector *
        connector2 : Connector *
        connector3 : Connector -> FamilyInstance

Parameters

connector1 Connector
The first connector to be connected to the tee.
connector2 Connector
The second connector to be connected to the tee.
connector3 Connector
The third connector to be connected to the tee. This should be connected to the branch of the tee.

Return Value

FamilyInstance
If creation was successful then an family instance to the new object is returned, and the transition fitting will be added at the connectors' end if necessary, otherwise an exception with failure information will be thrown.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument connector1, connector2 or connector3 is .
ArgumentException | Thrown when the connectors cannot be used for the tee creation. For example, they cannot be from the same element, they must be of the same domain, and the owner of the connectors should be a (flex) duct or pipe.
InvalidOperationException | Thrown when tee fitting cannot be created.
See Also

Reference

Document Class
Autodesk.Revit.Creation Namespace


Document.NewTransitionFitting Method

DocumentNewTransitionFitting Method

Add a new family instance of an transition fitting into the Autodesk Revit document, using two connectors.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyInstance NewTransitionFitting(
    Connector connector1,
    Connector connector2
)
Public Function NewTransitionFitting (
    connector1 As Connector,
    connector2 As Connector
) As FamilyInstance
public:
FamilyInstance^ NewTransitionFitting(
    Connector^ connector1,
    Connector^ connector2
)
member NewTransitionFitting :
        connector1 : Connector *
        connector2 : Connector -> FamilyInstance

Parameters

connector1 Connector
The first connector to be connected to the transition.
connector2 Connector
The second connector to be connected to the transition.

Return Value

FamilyInstance
If creation was successful then an family instance to the new object is returned, otherwise an exception with failure information will be thrown.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument connector1 or connector2 is .
ArgumentException | Thrown when the connectors cannot be used for transition creation. For example, they cannot be from the same element, they must be of the same domain, and the owner of connector1 should be a (flex) duct or pipe.
InvalidOperationException | Thrown when transition fitting cannot be created.
See Also

Reference

Document Class
Autodesk.Revit.Creation Namespace


Document.NewUnionFitting Method

DocumentNewUnionFitting Method

Add a new family instance of an union fitting into the Autodesk Revit document, using two connectors.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyInstance NewUnionFitting(
    Connector connector1,
    Connector connector2
)
Public Function NewUnionFitting (
    connector1 As Connector,
    connector2 As Connector
) As FamilyInstance
public:
FamilyInstance^ NewUnionFitting(
    Connector^ connector1,
    Connector^ connector2
)
member NewUnionFitting :
        connector1 : Connector *
        connector2 : Connector -> FamilyInstance

Parameters

connector1 Connector
The first connector to be connected to the union.
connector2 Connector
The second connector to be connected to the union.

Return Value

FamilyInstance
If creation was successful then an family instance to the new object is returned, otherwise an exception with failure information will be thrown.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument connector1 or connector2 is .
ArgumentException | Thrown when the connectors cannot be used for union creation. For example, they cannot be from the same element, they must be of the same domain and shape, and the owner of the connector1 should be a (flex) duct or pipe.
InvalidOperationException | Thrown when union fitting cannot be created.
See Also

Reference

Document Class
Autodesk.Revit.Creation Namespace


Document.NewZone Method

DocumentNewZone Method

Creates a new Zone element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Zone NewZone(
    Level level,
    Phase phase
)
Public Function NewZone (
    level As Level,
    phase As Phase
) As Zone
public:
Zone^ NewZone(
    Level^ level,
    Phase^ phase
)
member NewZone :
        level : Level *
        phase : Phase -> Zone

Parameters

level Level
The level on which the Zone is to exist.
phase Phase
The associative phase on which the Zone is to exist.

Return Value

Zone
If successful a new Zone element within the project, otherwise .
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the specified parameter Value is .
InvalidOperationException | Thrown when the electrical system cannot be created by these input phase and level.
ArgumentException | Thrown if the level does not exist in the given document.
ArgumentException | Thrown if the phase does not exist in the given document.
See Also

Reference

Document Class
Autodesk.Revit.Creation Namespace


eRefFace Enumeration

Indicates the reference face. The Opening will be created at the direction perpendicular to the reference face.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum eRefFace
Public Enumeration eRefFace
public enum class eRefFace
type eRefFace
Members
Member name | Value | Description
CenterX | 1 | The reference face is at the middle of the element in the direction of x-axis and its normal is parallel to x-axis.
CenterY | 4 | The reference face is at the middle of the element in the direction of y-axis and its normal is parallel to y-axis.
CenterZ | 7 | The reference face is at the middle of the element in the direction of z-axis and its normal is parallel to z-axis.
Remarks
Direction of the opening.
See Also

Reference

Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Class

A class which wraps the arguments of FamilyInstance for batch creation.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.CreationFamilyInstanceCreationData

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FamilyInstanceCreationData
Public Class FamilyInstanceCreationData
public ref class FamilyInstanceCreationData
type FamilyInstanceCreationData = class end

The FamilyInstanceCreationData type exposes the following members.

Constructors
 | Name | Description
Public method | FamilyInstanceCreationData(Object) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(FamilySymbol, IListXYZ) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(Face, Line, FamilySymbol) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(XYZ, FamilySymbol, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(Curve, FamilySymbol, Level, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(Face, XYZ, XYZ, FamilySymbol) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(XYZ, FamilySymbol, Element, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(XYZ, FamilySymbol, Level, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(XYZ, FamilySymbol, Element, Level, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class
Top
Properties
 | Name | Description
Public property | Axis | Get or set the axis of the FamilyInstance
Public property | RotateAngle | Get or set the rotate angle of the FamilyInstance
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Constructor

Overload List
 | Name | Description
Public method | FamilyInstanceCreationData(Object) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(FamilySymbol, IListXYZ) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(Face, Line, FamilySymbol) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(XYZ, FamilySymbol, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(Curve, FamilySymbol, Level, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(Face, XYZ, XYZ, FamilySymbol) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(XYZ, FamilySymbol, Element, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(XYZ, FamilySymbol, Level, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(XYZ, FamilySymbol, Element, Level, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class
Top
See Also

Reference

FamilyInstanceCreationData Class
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData(Object) Constructor

Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyInstanceCreationData(
    Object proxy
)
Public Sub New (
    proxy As Object
)
public:
FamilyInstanceCreationData(
    Object^ proxy
)
new :
        proxy : Object -> FamilyInstanceCreationData

Parameters

proxy Object
See Also

Reference

FamilyInstanceCreationData Class
FamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData(FamilySymbol, IList<XYZ>) Constructor

FamilyInstanceCreationData(FamilySymbol, IListXYZ) Constructor

Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyInstanceCreationData(
    FamilySymbol symbol,
    IList<XYZ> adaptivePoints
)
Public Sub New (
    symbol As FamilySymbol,
    adaptivePoints As IList(Of XYZ)
)
public:
FamilyInstanceCreationData(
    FamilySymbol^ symbol,
    IList<XYZ^>^ adaptivePoints
)
new :
        symbol : FamilySymbol *
        adaptivePoints : IList<XYZ> -> FamilyInstanceCreationData

Parameters

symbol FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
adaptivePoints IList XYZ
The adaptive points where the adaptive instance is to be initialized.
See Also

Reference

FamilyInstanceCreationData Class
FamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData(Face, Line, FamilySymbol) Constructor

Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyInstanceCreationData(
    Face face,
    Line position,
    FamilySymbol symbol
)
Public Sub New (
    face As Face,
    position As Line,
    symbol As FamilySymbol
)
public:
FamilyInstanceCreationData(
    Face^ face,
    Line^ position,
    FamilySymbol^ symbol
)
new :
        face : Face *
        position : Line *
        symbol : FamilySymbol -> FamilyInstanceCreationData

Parameters

face Face
A face of a geometry object.
position Line
A line on the face defining where the symbol is to be placed.
symbol FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
See Also

Reference

FamilyInstanceCreationData Class
FamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData(XYZ, FamilySymbol, StructuralType) Constructor

Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    StructuralType structuralType
)
Public Sub New (
    location As XYZ,
    symbol As FamilySymbol,
    structuralType As StructuralType
)
public:
FamilyInstanceCreationData(
    XYZ^ location,
    FamilySymbol^ symbol,
    StructuralType structuralType
)
new :
        location : XYZ *
        symbol : FamilySymbol *
        structuralType : StructuralType -> FamilyInstanceCreationData

Parameters

location XYZ
The physical location where the instance is to be placed.
symbol FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
structuralType StructuralType
Specify if the family instance is structural.
See Also

Reference

FamilyInstanceCreationData Class
FamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData(Curve, FamilySymbol, Level, StructuralType) Constructor

Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyInstanceCreationData(
    Curve curve,
    FamilySymbol symbol,
    Level level,
    StructuralType structuralType
)
Public Sub New (
    curve As Curve,
    symbol As FamilySymbol,
    level As Level,
    structuralType As StructuralType
)
public:
FamilyInstanceCreationData(
    Curve^ curve,
    FamilySymbol^ symbol,
    Level^ level,
    StructuralType structuralType
)
new :
        curve : Curve *
        symbol : FamilySymbol *
        level : Level *
        structuralType : StructuralType -> FamilyInstanceCreationData

Parameters

curve Curve
The curve where the instance is based.
symbol FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
level Level
A Level object that is used as the base level for the object.
structuralType StructuralType
If structural then specify the type of the component.
See Also

Reference

FamilyInstanceCreationData Class
FamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData(Face, XYZ, XYZ, FamilySymbol) Constructor

Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyInstanceCreationData(
    Face face,
    XYZ location,
    XYZ referenceDirection,
    FamilySymbol symbol
)
Public Sub New (
    face As Face,
    location As XYZ,
    referenceDirection As XYZ,
    symbol As FamilySymbol
)
public:
FamilyInstanceCreationData(
    Face^ face,
    XYZ^ location,
    XYZ^ referenceDirection,
    FamilySymbol^ symbol
)
new :
        face : Face *
        location : XYZ *
        referenceDirection : XYZ *
        symbol : FamilySymbol -> FamilyInstanceCreationData

Parameters

face Face
A face of a geometry object.
location XYZ
Point on the face where the instance is to be placed.
referenceDirection XYZ
A vector that defines the direction of the family instance.
symbol FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
See Also

Reference

FamilyInstanceCreationData Class
FamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData(XYZ, FamilySymbol, Element, StructuralType) Constructor

Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    Element host,
    StructuralType structuralType
)
Public Sub New (
    location As XYZ,
    symbol As FamilySymbol,
    host As Element,
    structuralType As StructuralType
)
public:
FamilyInstanceCreationData(
    XYZ^ location,
    FamilySymbol^ symbol,
    Element^ host,
    StructuralType structuralType
)
new :
        location : XYZ *
        symbol : FamilySymbol *
        host : Element *
        structuralType : StructuralType -> FamilyInstanceCreationData

Parameters

location XYZ
The physical location where the instance is to be placed.
symbol FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
host Element
The object into which the FamilyInstance is to be inserted, often known as the host.
structuralType StructuralType
If structural then specify the type of the component.
See Also

Reference

FamilyInstanceCreationData Class
FamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData(XYZ, FamilySymbol, Level, StructuralType) Constructor

Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    Level level,
    StructuralType structuralType
)
Public Sub New (
    location As XYZ,
    symbol As FamilySymbol,
    level As Level,
    structuralType As StructuralType
)
public:
FamilyInstanceCreationData(
    XYZ^ location,
    FamilySymbol^ symbol,
    Level^ level,
    StructuralType structuralType
)
new :
        location : XYZ *
        symbol : FamilySymbol *
        level : Level *
        structuralType : StructuralType -> FamilyInstanceCreationData

Parameters

location XYZ
The physical location where the instance is to be placed.
symbol FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
level Level
A Level object that is used as the base level for the object.
structuralType StructuralType
If structural then specify the type of the component.
See Also

Reference

FamilyInstanceCreationData Class
FamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData(XYZ, FamilySymbol, Element, Level, StructuralType) Constructor

Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    Element host,
    Level level,
    StructuralType structuralType
)
Public Sub New (
    location As XYZ,
    symbol As FamilySymbol,
    host As Element,
    level As Level,
    structuralType As StructuralType
)
public:
FamilyInstanceCreationData(
    XYZ^ location,
    FamilySymbol^ symbol,
    Element^ host,
    Level^ level,
    StructuralType structuralType
)
new :
        location : XYZ *
        symbol : FamilySymbol *
        host : Element *
        level : Level *
        structuralType : StructuralType -> FamilyInstanceCreationData

Parameters

location XYZ
The physical location where the instance is to be placed.
symbol FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
host Element
The object into which the FamilyInstance is to be inserted, often known as the host.
level Level
A Level object that is used as the base level for the object.
structuralType StructuralType
If structural then specify the type of the component.
See Also

Reference

FamilyInstanceCreationData Class
FamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData(XYZ, FamilySymbol, XYZ, Element, StructuralType) Constructor

Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    XYZ referenceDirection,
    Element host,
    StructuralType structuralType
)
Public Sub New (
    location As XYZ,
    symbol As FamilySymbol,
    referenceDirection As XYZ,
    host As Element,
    structuralType As StructuralType
)
public:
FamilyInstanceCreationData(
    XYZ^ location,
    FamilySymbol^ symbol,
    XYZ^ referenceDirection,
    Element^ host,
    StructuralType structuralType
)
new :
        location : XYZ *
        symbol : FamilySymbol *
        referenceDirection : XYZ *
        host : Element *
        structuralType : StructuralType -> FamilyInstanceCreationData

Parameters

location XYZ
The physical location where the instance is to be placed.
symbol FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
referenceDirection XYZ
A vector that dictates the direction of certain family instances.
host Element
The object into which the FamilyInstance is to be inserted, often known as the host.
structuralType StructuralType
If structural then specify the type of the component.
See Also

Reference

FamilyInstanceCreationData Class
FamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Properties

The FamilyInstanceCreationData type exposes the following members.

Properties
 | Name | Description
Public property | Axis | Get or set the axis of the FamilyInstance
Public property | RotateAngle | Get or set the rotate angle of the FamilyInstance
Top
See Also

Reference

FamilyInstanceCreationData Class
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData.Axis Property

FamilyInstanceCreationDataAxis Property

Get or set the axis of the FamilyInstance

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Line Axis { get; set; }
Public Property Axis As Line
    Get
    Set
public:
property Line^ Axis {
    Line^ get ();
    void set (Line^ value);
}
member Axis : Line with get, set

Property Value

Line
Remarks
The element property will be the axis while performing the rotation.
See Also

Reference

FamilyInstanceCreationData Class
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData.RotateAngle Property

FamilyInstanceCreationDataRotateAngle Property

Get or set the rotate angle of the FamilyInstance

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double RotateAngle { get; set; }
Public Property RotateAngle As Double
    Get
    Set
public:
property double RotateAngle {
    double get ();
    void set (double value);
}
member RotateAngle : float with get, set

Property Value

Double
Remarks
The FamilyInstance will rotate this angle when the instance is created.
See Also

Reference

FamilyInstanceCreationData Class
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Methods

The FamilyInstanceCreationData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FamilyInstanceCreationData Class
Autodesk.Revit.Creation Namespace


FamilyItemFactory Class

The Family Item Factory object is used to create new instances of elements within the Autodesk Revit Family.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.CreationItemFactoryBase
Autodesk.Revit.CreationFamilyItemFactory

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FamilyItemFactory : ItemFactoryBase
Public Class FamilyItemFactory
    Inherits ItemFactoryBase
public ref class FamilyItemFactory : public ItemFactoryBase
type FamilyItemFactory =
    class
        inherit ItemFactoryBase
    end

The FamilyItemFactory type exposes the following members.

Properties
Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | NewAlignment | Add a new locked alignment into the Autodesk Revit document. (Inherited from ItemFactoryBase)
Public method | NewAngularDimension(View, Arc, Reference, Reference) | Creates a new angular dimension object using the default dimension type.
Public method | NewAngularDimension(View, Arc, Reference, Reference, DimensionType) | Creates a new angular dimension object using the specified dimension type.
 | NewArcLengthDimension(View, Arc, Reference, Reference, Reference) | Creates a new arc length dimension object using the default dimension type.
Public method | NewArcLengthDimension(View, Arc, Reference, Reference, Reference, DimensionType) | Creates a new arc length dimension object using the specified dimension type.
 | NewBlend | Add a new Blend instance into the Autodesk Revit family document.
Public method | NewControl | Add a new control into the Autodesk Revit family document.
 | NewCurveByPoints | Create a 3d curve through two or more points in an Autodesk Revit family document.
Public method | NewDetailCurve | Creates a new detail curve element. (Inherited from ItemFactoryBase)
Public method | NewDetailCurveArray | Creates an array of new detail curve elements. (Inherited from ItemFactoryBase)
Public method | NewDiameterDimension | Creates a new diameter dimension object using the default dimension type.
 | NewDimension(View, Line, ReferenceArray) | Creates a new linear dimension object using the default dimension style. (Inherited from ItemFactoryBase)
Public method | NewDimension(View, Line, ReferenceArray, DimensionType) | Creates a new linear dimension object using the specified dimension style. (Inherited from ItemFactoryBase)
 | NewExtrusion | Add a new Extrusion instance into the Autodesk Revit family document.
 | NewExtrusionForm | Create new Form element by Extrude operation, and add it into the Autodesk Revit family document.
 | NewFamilyInstance(Face, Line, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a line on that face for its position, and a type/symbol. (Inherited from ItemFactoryBase)
 | NewFamilyInstance(Line, FamilySymbol, View) | Add a line based detail family instance into the Autodesk Revit document, using an line and a view where the instance should be placed. (Inherited from ItemFactoryBase)
 | NewFamilyInstance(Reference, Line, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a line on that face for its position, and a type/symbol. (Inherited from ItemFactoryBase)
Public method | NewFamilyInstance(XYZ, FamilySymbol, StructuralType) | Inserts a new instance of a family into the document, using a location and a type/symbol. (Inherited from ItemFactoryBase)
Public method | NewFamilyInstance(XYZ, FamilySymbol, View) | Add a new family instance into the Autodesk Revit document, using an origin and a view where the instance should be placed. (Inherited from ItemFactoryBase)
 | NewFamilyInstance(Face, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol. (Inherited from ItemFactoryBase)
 | NewFamilyInstance(Reference, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a location, reference direction, and a type/symbol. (Inherited from ItemFactoryBase)
 | NewFamilyInstance(XYZ, FamilySymbol, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the host element. (Inherited from ItemFactoryBase)
Public method | NewFamilyInstance(XYZ, FamilySymbol, Level, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the level. (Inherited from ItemFactoryBase)
 | NewFamilyInstance(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a reference direction. (Inherited from ItemFactoryBase)
 | NewFamilyInstances2 | Creates Family instances within the document. (Inherited from ItemFactoryBase)
Public method | NewFormByCap | Create new Form element by cap operation (to create a single-surface form), and add it into the Autodesk Revit family document.
Public method | NewFormByThickenSingleSurface | Create a new Form element by thickening a single-surface form, and add it into the Autodesk Revit family document.
 | NewGroup | Creates a new type of group. (Inherited from ItemFactoryBase)
 | NewLinearDimension(View, Line, ReferenceArray) | Generate a new linear dimension object using the default dimension type.
Public method | NewLinearDimension(View, Line, ReferenceArray, DimensionType) | Creates a new linear dimension object using the specified dimension type.
 | NewLoftForm | Create new Form element by Loft operation, and add it into the Autodesk Revit family document.
 | NewModelCurve | Creates a new model line element. (Inherited from ItemFactoryBase)
Public method | NewModelCurveArray | Creates an array of new model line elements. (Inherited from ItemFactoryBase)
Public method | NewModelText | Create a model text in the Autodesk Revit family document.
Public method | NewOpening | Create an opening to cut the wall or ceiling.
Public method | NewRadialDimension(View, Reference, XYZ) | Creates a new radial dimension object using the default dimension type.
Public method | NewRadialDimension(View, Reference, XYZ, DimensionType) | Generate a new radial dimension object using a specified dimension type.
 | NewReferencePlane | Creates a new instance of ReferencePlane. (Inherited from ItemFactoryBase)
 | NewReferencePlane2 | Creates a new instance of ReferencePlane. (Inherited from ItemFactoryBase)
Public method | NewReferencePoint(PointElementReference) | Create a reference point on an existing reference in an Autodesk Revit family document.
Public method | NewReferencePoint(Transform) | Create a reference point at a given location and with a given coordinate system in an Autodesk Revit family document.
Public method | NewReferencePoint(XYZ) | Create a reference point at a given location in an Autodesk Revit family document.
 | NewRevolution | Add a new Revolution instance into the Autodesk Revit family document.
 | NewRevolveForms | Create new Form elements by revolve operation, and add them into the Autodesk Revit family document.
Public method | NewSweep(Boolean, ReferenceArray, SweepProfile, Int32, ProfilePlaneLocation) | Adds a new sweep form into the family document, using an array of selected references as a 3D path.
 | NewSweep(Boolean, CurveArray, SketchPlane, SweepProfile, Int32, ProfilePlaneLocation) | Adds a new sweep form to the family document, using a path of curve elements.
Public method | NewSweptBlend(Boolean, Reference, SweepProfile, SweepProfile) | Adds a new swept blend into the family document, using a selected reference as the path.
 | NewSweptBlend(Boolean, Curve, SketchPlane, SweepProfile, SweepProfile) | Add a new swept blend into the family document, using a curve as the path.
Public method | NewSweptBlendForm | Create new Form element by swept blend operation, and add it into the Autodesk Revit family document.
Public method | NewSymbolicCurve | Create a symbolic curve in an Autodesk Revit family document.
Public method | PlaceGroup | Place an instance of a Model Group into the Autodesk Revit document, using a location and a group type. (Inherited from ItemFactoryBase)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The Family Item Factory object is a utility object that is used to create new instances of elements within the Autodesk Revit Family Document. This object should be used to create elements instead of using New. This object ensures that the elements created are added to the family document correctly.
See Also

Reference

Autodesk.Revit.Creation Namespace


FamilyItemFactory Properties

The FamilyItemFactory type exposes the following members.

Properties
Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


FamilyItemFactory Methods

The FamilyItemFactory type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | NewAlignment | Add a new locked alignment into the Autodesk Revit document. (Inherited from ItemFactoryBase)
Public method | NewAngularDimension(View, Arc, Reference, Reference) | Creates a new angular dimension object using the default dimension type.
Public method | NewAngularDimension(View, Arc, Reference, Reference, DimensionType) | Creates a new angular dimension object using the specified dimension type.
 | NewArcLengthDimension(View, Arc, Reference, Reference, Reference) | Creates a new arc length dimension object using the default dimension type.
Public method | NewArcLengthDimension(View, Arc, Reference, Reference, Reference, DimensionType) | Creates a new arc length dimension object using the specified dimension type.
 | NewBlend | Add a new Blend instance into the Autodesk Revit family document.
Public method | NewControl | Add a new control into the Autodesk Revit family document.
 | NewCurveByPoints | Create a 3d curve through two or more points in an Autodesk Revit family document.
Public method | NewDetailCurve | Creates a new detail curve element. (Inherited from ItemFactoryBase)
Public method | NewDetailCurveArray | Creates an array of new detail curve elements. (Inherited from ItemFactoryBase)
Public method | NewDiameterDimension | Creates a new diameter dimension object using the default dimension type.
 | NewDimension(View, Line, ReferenceArray) | Creates a new linear dimension object using the default dimension style. (Inherited from ItemFactoryBase)
Public method | NewDimension(View, Line, ReferenceArray, DimensionType) | Creates a new linear dimension object using the specified dimension style. (Inherited from ItemFactoryBase)
 | NewExtrusion | Add a new Extrusion instance into the Autodesk Revit family document.
 | NewExtrusionForm | Create new Form element by Extrude operation, and add it into the Autodesk Revit family document.
 | NewFamilyInstance(Face, Line, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a line on that face for its position, and a type/symbol. (Inherited from ItemFactoryBase)
 | NewFamilyInstance(Line, FamilySymbol, View) | Add a line based detail family instance into the Autodesk Revit document, using an line and a view where the instance should be placed. (Inherited from ItemFactoryBase)
 | NewFamilyInstance(Reference, Line, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a line on that face for its position, and a type/symbol. (Inherited from ItemFactoryBase)
Public method | NewFamilyInstance(XYZ, FamilySymbol, StructuralType) | Inserts a new instance of a family into the document, using a location and a type/symbol. (Inherited from ItemFactoryBase)
Public method | NewFamilyInstance(XYZ, FamilySymbol, View) | Add a new family instance into the Autodesk Revit document, using an origin and a view where the instance should be placed. (Inherited from ItemFactoryBase)
 | NewFamilyInstance(Face, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol. (Inherited from ItemFactoryBase)
 | NewFamilyInstance(Reference, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a location, reference direction, and a type/symbol. (Inherited from ItemFactoryBase)
 | NewFamilyInstance(XYZ, FamilySymbol, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the host element. (Inherited from ItemFactoryBase)
Public method | NewFamilyInstance(XYZ, FamilySymbol, Level, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the level. (Inherited from ItemFactoryBase)
 | NewFamilyInstance(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a reference direction. (Inherited from ItemFactoryBase)
 | NewFamilyInstances2 | Creates Family instances within the document. (Inherited from ItemFactoryBase)
Public method | NewFormByCap | Create new Form element by cap operation (to create a single-surface form), and add it into the Autodesk Revit family document.
Public method | NewFormByThickenSingleSurface | Create a new Form element by thickening a single-surface form, and add it into the Autodesk Revit family document.
 | NewGroup | Creates a new type of group. (Inherited from ItemFactoryBase)
 | NewLinearDimension(View, Line, ReferenceArray) | Generate a new linear dimension object using the default dimension type.
Public method | NewLinearDimension(View, Line, ReferenceArray, DimensionType) | Creates a new linear dimension object using the specified dimension type.
 | NewLoftForm | Create new Form element by Loft operation, and add it into the Autodesk Revit family document.
 | NewModelCurve | Creates a new model line element. (Inherited from ItemFactoryBase)
Public method | NewModelCurveArray | Creates an array of new model line elements. (Inherited from ItemFactoryBase)
Public method | NewModelText | Create a model text in the Autodesk Revit family document.
Public method | NewOpening | Create an opening to cut the wall or ceiling.
Public method | NewRadialDimension(View, Reference, XYZ) | Creates a new radial dimension object using the default dimension type.
Public method | NewRadialDimension(View, Reference, XYZ, DimensionType) | Generate a new radial dimension object using a specified dimension type.
 | NewReferencePlane | Creates a new instance of ReferencePlane. (Inherited from ItemFactoryBase)
 | NewReferencePlane2 | Creates a new instance of ReferencePlane. (Inherited from ItemFactoryBase)
Public method | NewReferencePoint(PointElementReference) | Create a reference point on an existing reference in an Autodesk Revit family document.
Public method | NewReferencePoint(Transform) | Create a reference point at a given location and with a given coordinate system in an Autodesk Revit family document.
Public method | NewReferencePoint(XYZ) | Create a reference point at a given location in an Autodesk Revit family document.
 | NewRevolution | Add a new Revolution instance into the Autodesk Revit family document.
 | NewRevolveForms | Create new Form elements by revolve operation, and add them into the Autodesk Revit family document.
Public method | NewSweep(Boolean, ReferenceArray, SweepProfile, Int32, ProfilePlaneLocation) | Adds a new sweep form into the family document, using an array of selected references as a 3D path.
 | NewSweep(Boolean, CurveArray, SketchPlane, SweepProfile, Int32, ProfilePlaneLocation) | Adds a new sweep form to the family document, using a path of curve elements.
Public method | NewSweptBlend(Boolean, Reference, SweepProfile, SweepProfile) | Adds a new swept blend into the family document, using a selected reference as the path.
 | NewSweptBlend(Boolean, Curve, SketchPlane, SweepProfile, SweepProfile) | Add a new swept blend into the family document, using a curve as the path.
Public method | NewSweptBlendForm | Create new Form element by swept blend operation, and add it into the Autodesk Revit family document.
Public method | NewSymbolicCurve | Create a symbolic curve in an Autodesk Revit family document.
Public method | PlaceGroup | Place an instance of a Model Group into the Autodesk Revit document, using a location and a group type. (Inherited from ItemFactoryBase)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


FamilyItemFactory.NewAngularDimension Method

FamilyItemFactoryNewAngularDimension Method

Creates a new angular dimension object.
Overload List
 | Name | Description
Public method | NewAngularDimension(View, Arc, Reference, Reference) | Creates a new angular dimension object using the default dimension type.
Public method | NewAngularDimension(View, Arc, Reference, Reference, DimensionType) | Creates a new angular dimension object using the specified dimension type.
Top
See Also

Reference

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


FamilyItemFactory.NewAngularDimension(View, Arc, Reference, Reference) Method

FamilyItemFactoryNewAngularDimension(View, Arc, Reference, Reference) Method

Creates a new angular dimension object using the default dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Dimension NewAngularDimension(
    View view,
    Arc arc,
    Reference firstRef,
    Reference secondRef
)
Public Function NewAngularDimension (
    view As View,
    arc As Arc,
    firstRef As Reference,
    secondRef As Reference
) As Dimension
public:
Dimension^ NewAngularDimension(
    View^ view,
    Arc^ arc,
    Reference^ firstRef,
    Reference^ secondRef
)
member NewAngularDimension :
        view : View *
        arc : Arc *
        firstRef : Reference *
        secondRef : Reference -> Dimension

Parameters

view View
The view in which the dimension is to be visible.
arc Arc
The extension arc of the dimension.
firstRef Reference
The first geometric reference to which the dimension is to be bound. The reference must be perpendicular to the extension arc.
secondRef Reference
The second geometric reference to which the dimension is to be bound. The reference must be perpendicular to the extension arc.

Return Value

Dimension
If creation was successful the new angular dimension is returned, otherwise an exception with failure information will be thrown.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when any input argument is .
ArgumentException | Thrown when the argument is invalid.
InvalidOperationException | Thrown when the creation failed.
Remarks
The currently user set default style is used for the created dimension.
See Also

Reference

FamilyItemFactory Class
NewAngularDimension Overload
Autodesk.Revit.Creation Namespace


FamilyItemFactory.NewAngularDimension(View, Arc, Reference, Reference, DimensionType) Method

FamilyItemFactoryNewAngularDimension(View, Arc, Reference, Reference, DimensionType) Method

Creates a new angular dimension object using the specified dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Dimension NewAngularDimension(
    View view,
    Arc arc,
    Reference firstRef,
    Reference secondRef,
    DimensionType dimensionType
)
Public Function NewAngularDimension (
    view As View,
    arc As Arc,
    firstRef As Reference,
    secondRef As Reference,
    dimensionType As DimensionType
) As Dimension
public:
Dimension^ NewAngularDimension(
    View^ view,
    Arc^ arc,
    Reference^ firstRef,
    Reference^ secondRef,
    DimensionType^ dimensionType
)
member NewAngularDimension :
        view : View *
        arc : Arc *
        firstRef : Reference *
        secondRef : Reference *
        dimensionType : DimensionType -> Dimension

Parameters

view View
The view in which the dimension is to be visible.
arc Arc
The extension arc of the dimension.
firstRef Reference
The first geometric reference to which the dimension is to be bound. The reference must be perpendicular to the extension arc.
secondRef Reference
The second geometric reference to which the dimension is to be bound. The reference must be perpendicular to the extension arc.
dimensionType DimensionType
The dimension style to be used for the dimension.

Return Value

Dimension
If creation was successful the new angular dimension is returned, otherwise an exception with failure information will be thrown.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when any input argument is .
ArgumentException | Thrown when the argument firstRef/secondRef/dimensionType is invalid.
InvalidOperationException | Thrown when the creation failed.
See Also

Reference

FamilyItemFactory Class
NewAngularDimension Overload
Autodesk.Revit.Creation Namespace


FamilyItemFactory.NewArcLengthDimension Method

FamilyItemFactoryNewArcLengthDimension Method

Creates a new arc length dimension object.
Overload List
 | Name | Description
 | NewArcLengthDimension(View, Arc, Reference, Reference, Reference) | Creates a new arc length dimension object using the default dimension type.
Public method | NewArcLengthDimension(View, Arc, Reference, Reference, Reference, DimensionType) | Creates a new arc length dimension object using the specified dimension type.
Top
See Also

Reference

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


FamilyItemFactory.NewArcLengthDimension(View, Arc, Reference, Reference, Reference) Method

FamilyItemFactoryNewArcLengthDimension(View, Arc, Reference, Reference, Reference) Method

Creates a new arc length dimension object using the default dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Dimension NewArcLengthDimension(
    View view,
    Arc arc,
    Reference arcRef,
    Reference firstRef,
    Reference secondRef
)
Public Function NewArcLengthDimension (
    view As View,
    arc As Arc,
    arcRef As Reference,
    firstRef As Reference,
    secondRef As Reference
) As Dimension
public:
Dimension^ NewArcLengthDimension(
    View^ view,
    Arc^ arc,
    Reference^ arcRef,
    Reference^ firstRef,
    Reference^ secondRef
)
member NewArcLengthDimension :
        view : View *
        arc : Arc *
        arcRef : Reference *
        firstRef : Reference *
        secondRef : Reference -> Dimension

Parameters

view View
The view in which the dimension is to be visible.
arc Arc
The extension arc of the dimension.
arcRef Reference
Geometric reference of the arc to which the dimension is to be bound. This reference must be parallel to the extension arc.
firstRef Reference
The first geometric reference to which the dimension is to be bound. This reference must intersect the arcRef reference.
secondRef Reference
The second geometric reference to which the dimension is to be bound. This reference must intersect the arcRef reference.

Return Value

Dimension
If creation was successful the new arc length dimension is returned, otherwise an exception with failure information will be thrown.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when any input argument is .
ArgumentException | Thrown when the argument arcRef/ref1/ref2 is invalid.
InvalidOperationException | Thrown when the creation failed.
Remarks
The currently user set default style is used for the created dimension.
Example
C#
VB
C++
F#
Copy
public Dimension CreateArcDimension(Document document, SketchPlane sketchPlane)
{
    Autodesk.Revit.Creation.Application appCreate = document.Application.Create;
    Line gLine1 = Line.CreateBound(new XYZ(0, 2, 0), new XYZ(2, 2, 0));
    Line gLine2 = Line.CreateBound(new XYZ(0, 2, 0), new XYZ(2, 4, 0));
    Arc arctoDim = Arc.Create(new XYZ(1, 2, 0), new XYZ(-1, 2, 0), new XYZ(0, 3, 0));
    Arc arcofDim = Arc.Create(new XYZ(0, 3, 0), new XYZ(1, 2, 0), new XYZ(0.8, 2.8, 0));

    Autodesk.Revit.Creation.FamilyItemFactory creationFamily = document.FamilyCreate;
    ModelCurve modelCurve1 = creationFamily.NewModelCurve(gLine1, sketchPlane);
    ModelCurve modelCurve2 = creationFamily.NewModelCurve(gLine2, sketchPlane);
    ModelCurve modelCurve3 = creationFamily.NewModelCurve(arctoDim, sketchPlane);
    //get their reference
    Reference ref1 = modelCurve1.GeometryCurve.Reference;
    Reference ref2 = modelCurve2.GeometryCurve.Reference;
    Reference arcRef = modelCurve3.GeometryCurve.Reference;

    Dimension newArcDim = creationFamily.NewArcLengthDimension(document.ActiveView, arcofDim, arcRef, ref1, ref2);
    if (newArcDim == null)
    {
        throw new Exception("Failed to create new arc length dimension.");
    }

    return newArcDim;
}
Public Function CreateArcDimension(document As Document, sketchPlane As SketchPlane) As Dimension
    Dim appCreate As Autodesk.Revit.Creation.Application = document.Application.Create
    Dim gLine1 As Line = Line.CreateBound(New XYZ(0, 2, 0), New XYZ(2, 2, 0))
    Dim gLine2 As Line = Line.CreateBound(New XYZ(0, 2, 0), New XYZ(2, 4, 0))
    Dim arctoDim As Arc = Arc.Create(New XYZ(1, 2, 0), New XYZ(-1, 2, 0), New XYZ(0, 3, 0))
    Dim arcofDim As Arc = Arc.Create(New XYZ(0, 3, 0), New XYZ(1, 2, 0), New XYZ(0.8, 2.8, 0))

    Dim creationFamily As Autodesk.Revit.Creation.FamilyItemFactory = document.FamilyCreate
    Dim modelCurve1 As ModelCurve = creationFamily.NewModelCurve(gLine1, sketchPlane)
    Dim modelCurve2 As ModelCurve = creationFamily.NewModelCurve(gLine2, sketchPlane)
    Dim modelCurve3 As ModelCurve = creationFamily.NewModelCurve(arctoDim, sketchPlane)
    'get their reference
    Dim ref1 As Reference = modelCurve1.GeometryCurve.Reference
    Dim ref2 As Reference = modelCurve2.GeometryCurve.Reference
    Dim arcRef As Reference = modelCurve3.GeometryCurve.Reference

    Dim newArcDim As Dimension = creationFamily.NewArcLengthDimension(document.ActiveView, arcofDim, arcRef, ref1, ref2)
    If newArcDim Is Nothing Then
        Throw New Exception("Failed to create new arc length dimension.")
    End If

    Return newArcDim
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

FamilyItemFactory Class
NewArcLengthDimension Overload
Autodesk.Revit.Creation Namespace


FamilyItemFactory.NewArcLengthDimension(View, Arc, Reference, Reference, Reference, DimensionType) Method

FamilyItemFactoryNewArcLengthDimension(View, Arc, Reference, Reference, Reference, DimensionType) Method

Creates a new arc length dimension object using the specified dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Dimension NewArcLengthDimension(
    View view,
    Arc arc,
    Reference arcRef,
    Reference firstRef,
    Reference secondRef,
    DimensionType dimensionType
)
Public Function NewArcLengthDimension (
    view As View,
    arc As Arc,
    arcRef As Reference,
    firstRef As Reference,
    secondRef As Reference,
    dimensionType As DimensionType
) As Dimension
public:
Dimension^ NewArcLengthDimension(
    View^ view,
    Arc^ arc,
    Reference^ arcRef,
    Reference^ firstRef,
    Reference^ secondRef,
    DimensionType^ dimensionType
)
member NewArcLengthDimension :
        view : View *
        arc : Arc *
        arcRef : Reference *
        firstRef : Reference *
        secondRef : Reference *
        dimensionType : DimensionType -> Dimension

Parameters

view View
The view in which the dimension is to be visible.
arc Arc
The extension arc of the dimension.
arcRef Reference
Geometric reference of the arc to which the dimension is to be bound. This reference must be parallel to the extension arc.
firstRef Reference
The first geometric reference to which the dimension is to be bound. This reference must intersect the arcRef reference.
secondRef Reference
The second geometric reference to which the dimension is to be bound. This reference must intersect the arcRef reference.
dimensionType DimensionType
The dimension style to be used for the dimension.

Return Value

Dimension
If creation was successful the new arc length dimension is returned, otherwise an exception with failure information will be thrown.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when any input argument is .
ArgumentException | Thrown when the argument arcRef/ref1/ref2/dimensionType is invalid.
InvalidOperationException | Thrown when the creation failed.
See Also

Reference

FamilyItemFactory Class
NewArcLengthDimension Overload
Autodesk.Revit.Creation Namespace


FamilyItemFactory.NewBlend Method

FamilyItemFactoryNewBlend Method

Add a new Blend instance into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Blend NewBlend(
    bool isSolid,
    CurveArray profile1,
    CurveArray profile2,
    SketchPlane sketchPlane
)
Public Function NewBlend (
    isSolid As Boolean,
    profile1 As CurveArray,
    profile2 As CurveArray,
    sketchPlane As SketchPlane
) As Blend
public:
Blend^ NewBlend(
    bool isSolid,
    CurveArray^ profile1,
    CurveArray^ profile2,
    SketchPlane^ sketchPlane
)
member NewBlend :
        isSolid : bool *
        profile1 : CurveArray *
        profile2 : CurveArray *
        sketchPlane : SketchPlane -> Blend

Parameters

isSolid Boolean
Indicates if the Blend is Solid or Void.
profile1 CurveArray
The first blend section. It should represent a single, planar curve loop.
profile2 CurveArray
The second blend section. It should represent a single, planar curve loop lying in a plane parallel to that of the first blend section.
sketchPlane SketchPlane
The sketch plane for the first profile. Use this to associate the "base" of the blend to geometry from another element. Optional, it can be if you want Revit to derive a new sketch plane from the geometry of the base profile.

Return Value

Blend
If creation was successful the new blend is returned, otherwise an exception with failure information will be thrown.
Exceptions
Exception | Condition
ArgumentException | Thrown when the argument is invalid.
InvalidOperationException | Thrown when creation is attempted in Conceptual Mass, 2D, or other family where blends cannot be created.
InvalidOperationException | Thrown when the creation failed.
Remarks
This method creates a blend in a family document. Revit will determine an appropriate default mapping for the vertices of the two profiles. A profile loop cannot contain just one closed curve - in such a case, the curve must be split into at least two segments, so that Revit can find vertices to use for mapping the blend. Caution: several aspects of the Blend are not (easily) predictable from the input arguments. For example, the Blend's TopOffset may be less than its BottomOffset in some cases, depending on the orientations of the profile loops and the orientation of the sketch plane (if a sketch plane is provided). Also, such orientations can affect whether the first or second profile lies in the sketch plane (if a sketch plane is provided).
Example
C#
VB
C++
F#
Copy
private Blend CreateBlend(UIApplication application, SketchPlane sketchPlane)
{
    Blend blend = null;

    // make sure we have a family document
    Document familyDocument = application.ActiveUIDocument.Document;
    if (true == familyDocument.IsFamilyDocument)
    {
        // Define top and base profiles for the blend
        CurveArray topProfile = new CurveArray();
        CurveArray baseProfile = new CurveArray();

        // create rectangular base profile
        XYZ p00 = XYZ.Zero;
        XYZ p01 = new XYZ(10, 0, 0);
        XYZ p02 = new XYZ(10, 10, 0);
        XYZ p03 = new XYZ(0, 10, 0);
        Line line01 = Line.CreateBound(p00, p01);
        Line line02 = Line.CreateBound(p01, p02);
        Line line03 = Line.CreateBound(p02, p03);
        Line line04 = Line.CreateBound(p03, p00);

        baseProfile.Append(line01);
        baseProfile.Append(line02);
        baseProfile.Append(line03);
        baseProfile.Append(line04);

        // create rectangular top profile
        XYZ p10 = new XYZ(5, 2, 10);
        XYZ p11 = new XYZ(8, 5, 10);
        XYZ p12 = new XYZ(5, 8, 10);
        XYZ p13 = new XYZ(2, 5, 10);
        Line line11 = Line.CreateBound(p10, p11);
        Line line12 = Line.CreateBound(p11, p12);
        Line line13 = Line.CreateBound(p12, p13);
        Line line14 = Line.CreateBound(p13, p10);

        topProfile.Append(line11);
        topProfile.Append(line12);
        topProfile.Append(line13);
        topProfile.Append(line14);

        // now create solid rectangular blend
        blend = familyDocument.FamilyCreate.NewBlend(true, topProfile, baseProfile, sketchPlane);

        if (null != blend)
        {
            // move to proper place
            XYZ transPoint1 = new XYZ(0, 11, 0);
            ElementTransformUtils.MoveElement(familyDocument, blend.Id, transPoint1);
        }
        else
        {
            throw new Exception("Create new Blend failed.");
        }
    }
    else
    {
        throw new Exception("Please open a Family document before invoking this command.");
    }

    return blend;
}
Private Function CreateBlend(application As UIApplication, sketchPlane As SketchPlane) As Blend
    Dim blend As Blend = Nothing

    ' make sure we have a family document
    Dim familyDocument As Document = application.ActiveUIDocument.Document
    If True = familyDocument.IsFamilyDocument Then
        ' Define top and base profiles for the blend
        Dim topProfile As New CurveArray()
        Dim baseProfile As New CurveArray()

        ' create rectangular base profile
        Dim p00 As XYZ = XYZ.Zero
        Dim p01 As New XYZ(10, 0, 0)
        Dim p02 As New XYZ(10, 10, 0)
        Dim p03 As New XYZ(0, 10, 0)
        Dim line01 As Line = Line.CreateBound(p00, p01)
        Dim line02 As Line = Line.CreateBound(p01, p02)
        Dim line03 As Line = Line.CreateBound(p02, p03)
        Dim line04 As Line = Line.CreateBound(p03, p00)

        baseProfile.Append(line01)
        baseProfile.Append(line02)
        baseProfile.Append(line03)
        baseProfile.Append(line04)

        ' create rectangular top profile
        Dim p10 As New XYZ(5, 2, 10)
        Dim p11 As New XYZ(8, 5, 10)
        Dim p12 As New XYZ(5, 8, 10)
        Dim p13 As New XYZ(2, 5, 10)
        Dim line11 As Line = Line.CreateBound(p10, p11)
        Dim line12 As Line = Line.CreateBound(p11, p12)
        Dim line13 As Line = Line.CreateBound(p12, p13)
        Dim line14 As Line = Line.CreateBound(p13, p10)

        topProfile.Append(line11)
        topProfile.Append(line12)
        topProfile.Append(line13)
        topProfile.Append(line14)

        ' now create solid rectangular blend
        blend = familyDocument.FamilyCreate.NewBlend(True, topProfile, baseProfile, sketchPlane)

        If blend IsNot Nothing Then
            ' move to proper place
            Dim transPoint1 As New XYZ(0, 11, 0)
            ElementTransformUtils.MoveElement(familyDocument, blend.Id, transPoint1)
        Else
            Throw New Exception("Create new Blend failed.")
        End If
    Else
        Throw New Exception("Please open a Family document before invoking this command.")
    End If

    Return blend
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


FamilyItemFactory.NewControl Method

FamilyItemFactoryNewControl Method

Add a new control into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Control NewControl(
    ControlShape controlShape,
    View view,
    XYZ origin
)
Public Function NewControl (
    controlShape As ControlShape,
    view As View,
    origin As XYZ
) As Control
public:
Control^ NewControl(
    ControlShape controlShape,
    View^ view,
    XYZ^ origin
)
member NewControl :
        controlShape : ControlShape *
        view : View *
        origin : XYZ -> Control

Parameters

controlShape ControlShape
The shape of the control.
view View
The view in which the control is to be visible. It must be a FloorPlan view or a CeilingPlan view.
origin XYZ
The origin of the control.

Return Value

Control
If successful, the newly created control is returned, otherwise an exception with error information will be thrown.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument-"view" or "position"-is .
ArgumentException | Thrown when the input argument-"view"-is invalid.
ArgumentOutOfRangeException | Thrown when the input argument-"controlType"-is out of range.
InvalidOperationException | Thrown when control creation failed.
See Also

Reference

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


FamilyItemFactory.NewCurveByPoints Method

FamilyItemFactoryNewCurveByPoints Method

Create a 3d curve through two or more points in an Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurveByPoints NewCurveByPoints(
    ReferencePointArray points
)
Public Function NewCurveByPoints (
    points As ReferencePointArray
) As CurveByPoints
public:
CurveByPoints^ NewCurveByPoints(
    ReferencePointArray^ points
)
member NewCurveByPoints :
        points : ReferencePointArray -> CurveByPoints

Parameters

points ReferencePointArray
Two or more PointElements. The curve will interpolate these points.

Return Value

CurveByPoints
The newly created curve.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when points is .
ArgumentException | Thrown when points does not contain at least two PointElements.
InvalidOperationException | Thrown when the family is not a Conceptual Mass Family.
Example
C#
VB
C++
F#
Copy
ReferencePointArray rpa = new ReferencePointArray();

XYZ xyz = document.Application.Create.NewXYZ(0, 0, 0);
ReferencePoint rp = document.FamilyCreate.NewReferencePoint(xyz);
rpa.Append(rp);

xyz = document.Application.Create.NewXYZ(0, 30, 10);
rp = document.FamilyCreate.NewReferencePoint(xyz);
rpa.Append(rp);

xyz = document.Application.Create.NewXYZ(0, 60, 0);
rp = document.FamilyCreate.NewReferencePoint(xyz);
rpa.Append(rp);

xyz = document.Application.Create.NewXYZ(0, 100, 30);
rp = document.FamilyCreate.NewReferencePoint(xyz);
rpa.Append(rp);

xyz = document.Application.Create.NewXYZ(0, 150, 0);
rp = document.FamilyCreate.NewReferencePoint(xyz);
rpa.Append(rp);

curve = document.FamilyCreate.NewCurveByPoints(rpa);
Dim rpa As New ReferencePointArray()

Dim xyz As XYZ = document.Application.Create.NewXYZ(0, 0, 0)
Dim rp As ReferencePoint = document.FamilyCreate.NewReferencePoint(xyz)
rpa.Append(rp)

xyz = document.Application.Create.NewXYZ(0, 30, 10)
rp = document.FamilyCreate.NewReferencePoint(xyz)
rpa.Append(rp)

xyz = document.Application.Create.NewXYZ(0, 60, 0)
rp = document.FamilyCreate.NewReferencePoint(xyz)
rpa.Append(rp)

xyz = document.Application.Create.NewXYZ(0, 100, 30)
rp = document.FamilyCreate.NewReferencePoint(xyz)
rpa.Append(rp)

xyz = document.Application.Create.NewXYZ(0, 150, 0)
rp = document.FamilyCreate.NewReferencePoint(xyz)
rpa.Append(rp)

curve = document.FamilyCreate.NewCurveByPoints(rpa)

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


FamilyItemFactory.NewDiameterDimension Method

FamilyItemFactoryNewDiameterDimension Method

Creates a new diameter dimension object using the default dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Dimension NewDiameterDimension(
    View view,
    Reference arcRef,
    XYZ origin
)
Public Function NewDiameterDimension (
    view As View,
    arcRef As Reference,
    origin As XYZ
) As Dimension
public:
Dimension^ NewDiameterDimension(
    View^ view,
    Reference^ arcRef,
    XYZ^ origin
)
member NewDiameterDimension :
        view : View *
        arcRef : Reference *
        origin : XYZ -> Dimension

Parameters

view View
The view in which the dimension is to be visible.
arcRef Reference
Geometric reference of the arc to which the dimension is to be bound.
origin XYZ
The point where the witness line of the diameter dimension will lie.

Return Value

Dimension
If creation was successful the new diameter dimension is returned, otherwise an exception with failure information will be thrown.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when any input argument is .
ArgumentException | Thrown when the argument arcRef is invalid.
InvalidOperationException | Thrown when the creation failed.
Remarks
The currently user set default style is used for the created dimension.
See Also

Reference

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


FamilyItemFactory.NewExtrusion Method

FamilyItemFactoryNewExtrusion Method

Add a new Extrusion instance into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Extrusion NewExtrusion(
    bool isSolid,
    CurveArrArray profile,
    SketchPlane sketchPlane,
    double end
)
Public Function NewExtrusion (
    isSolid As Boolean,
    profile As CurveArrArray,
    sketchPlane As SketchPlane,
    end As Double
) As Extrusion
public:
Extrusion^ NewExtrusion(
    bool isSolid,
    CurveArrArray^ profile,
    SketchPlane^ sketchPlane,
    double end
)
member NewExtrusion :
        isSolid : bool *
        profile : CurveArrArray *
        sketchPlane : SketchPlane *
        end : float -> Extrusion

Parameters

isSolid Boolean
Indicates if the Extrusion is Solid or Void.
profile CurveArrArray
The profile of the newly created Extrusion. This may contain more than one curve loop. Each loop must be a fully closed curve loop and the loops may not intersect. All input curves must lie in the same plane. The loop can be a unbound circle or ellipse, but its geometry will be split in two in order to satisfy requirements for sketches used in extrusions.
sketchPlane SketchPlane
The sketch plane for the extrusion. The direction of extrusion is determined by the normal for the sketch plane. To extrude in the other direction set the end value to negative.
end Double
The length of the extrusion.

Return Value

Extrusion
If creation was successful the new Extrusion is returned, otherwise an exception with failure information will be thrown.
Exceptions
Exception | Condition
ArgumentException | Thrown when the input argument-profile-is or empty array.
ArgumentNullException | Thrown when the input argument-sketchPlane-is .
ArgumentException | Thrown when the input argument-sketchPlane-is an invalid sketch plane.
InvalidOperationException | Thrown when the creation failed.
Remarks
This method creates an extrusion in a family document. The extrusion will be extended perpendicular to the sketch plane of the extrusion profile.
Example
C#
VB
C++
F#
Copy
private Extrusion CreateExtrusion(Autodesk.Revit.DB.Document document, SketchPlane sketchPlane)
{
    Extrusion rectExtrusion = null;

    // make sure we have a family document
    if (true == document.IsFamilyDocument)
    {
        // define the profile for the extrusion
        CurveArrArray curveArrArray = new CurveArrArray();
        CurveArray curveArray1 = new CurveArray();
        CurveArray curveArray2 = new CurveArray();
        CurveArray curveArray3 = new CurveArray();

        // create a rectangular profile
        XYZ p0 = XYZ.Zero;
        XYZ p1 = new XYZ(10, 0, 0);
        XYZ p2 = new XYZ(10, 10, 0);
        XYZ p3 = new XYZ(0, 10, 0);
        Line line1 = Line.CreateBound(p0, p1);
        Line line2 = Line.CreateBound(p1, p2);
        Line line3 = Line.CreateBound(p2, p3);
        Line line4 = Line.CreateBound(p3, p0);
        curveArray1.Append(line1);
        curveArray1.Append(line2);
        curveArray1.Append(line3);
        curveArray1.Append(line4);

        curveArrArray.Append(curveArray1);

        // create solid rectangular extrusion
        rectExtrusion = document.FamilyCreate.NewExtrusion(true, curveArrArray, sketchPlane, 10);

        if (null != rectExtrusion)
        {
            // move extrusion to proper place
            XYZ transPoint1 = new XYZ(-16, 0, 0);
            ElementTransformUtils.MoveElement(document, rectExtrusion.Id, transPoint1);
        }
        else
        {
            throw new Exception("Create new Extrusion failed.");
        }
    }
    else
    {
        throw new Exception("Please open a Family document before invoking this command.");
    }

    return rectExtrusion;
}
Private Function CreateExtrusion(document As Autodesk.Revit.DB.Document, sketchPlane As SketchPlane) As Extrusion
    Dim rectExtrusion As Extrusion = Nothing

    ' make sure we have a family document
    If True = document.IsFamilyDocument Then
        ' define the profile for the extrusion
        Dim curveArrArray As New CurveArrArray()
        Dim curveArray1 As New CurveArray()
        Dim curveArray2 As New CurveArray()
        Dim curveArray3 As New CurveArray()

        ' create a rectangular profile
        Dim p0 As XYZ = XYZ.Zero
        Dim p1 As New XYZ(10, 0, 0)
        Dim p2 As New XYZ(10, 10, 0)
        Dim p3 As New XYZ(0, 10, 0)
        Dim line1 As Line = Line.CreateBound(p0, p1)
        Dim line2 As Line = Line.CreateBound(p1, p2)
        Dim line3 As Line = Line.CreateBound(p2, p3)
        Dim line4 As Line = Line.CreateBound(p3, p0)
        curveArray1.Append(line1)
        curveArray1.Append(line2)
        curveArray1.Append(line3)
        curveArray1.Append(line4)

        curveArrArray.Append(curveArray1)

        ' create solid rectangular extrusion
        rectExtrusion = document.FamilyCreate.NewExtrusion(True, curveArrArray, sketchPlane, 10)

        If rectExtrusion IsNot Nothing Then
            ' move extrusion to proper place
            Dim transPoint1 As New XYZ(-16, 0, 0)
            ElementTransformUtils.MoveElement(document, rectExtrusion.Id, transPoint1)
        Else
            Throw New Exception("Create new Extrusion failed.")
        End If
    Else
        Throw New Exception("Please open a Family document before invoking this command.")
    End If

    Return rectExtrusion
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


FamilyItemFactory.NewExtrusionForm Method

FamilyItemFactoryNewExtrusionForm Method

Create new Form element by Extrude operation, and add it into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Form NewExtrusionForm(
    bool isSolid,
    ReferenceArray profile,
    XYZ direction
)
Public Function NewExtrusionForm (
    isSolid As Boolean,
    profile As ReferenceArray,
    direction As XYZ
) As Form
public:
Form^ NewExtrusionForm(
    bool isSolid,
    ReferenceArray^ profile,
    XYZ^ direction
)
member NewExtrusionForm :
        isSolid : bool *
        profile : ReferenceArray *
        direction : XYZ -> Form

Parameters

isSolid Boolean
Indicates if the Form is Solid or Void.
profile ReferenceArray
The profile of extrusion. It should consist of only one curve loop.
direction XYZ
The direction of extrusion, with its length the length of the extrusion. The direction must be perpendicular to the plane determined by profile. The length of vector must be non-zero.

Return Value

Form
If creation was successful new form is returned.
Exceptions
Exception | Condition
InvalidOperationException | Thrown when creation is attempted in Conceptual Mass, 2D, or other family where extrusions cannot be created.
Example
C#
VB
C++
F#
Copy
private Form CreateExtrusionForm(Autodesk.Revit.DB.Document document)
{
    Form extrusionForm = null;

    // Create one profile
    ReferenceArray ref_ar = new ReferenceArray();

    XYZ ptA = new XYZ(10, 10, 0);
    XYZ ptB = new XYZ(90, 10, 0);
    ModelCurve modelcurve = MakeLine(document, ptA, ptB);
    ref_ar.Append(modelcurve.GeometryCurve.Reference);

    ptA = new XYZ(90, 10, 0);
    ptB = new XYZ(10, 90, 0);
    modelcurve = MakeLine(document, ptA, ptB);
    ref_ar.Append(modelcurve.GeometryCurve.Reference);

    ptA = new XYZ(10, 90, 0);
    ptB = new XYZ(10, 10, 0);
    modelcurve = MakeLine(document, ptA, ptB);
    ref_ar.Append(modelcurve.GeometryCurve.Reference);

    // The extrusion form direction
    XYZ direction = new XYZ(0, 0, 50);

    extrusionForm = document.FamilyCreate.NewExtrusionForm(true, ref_ar, direction);

    int profileCount = extrusionForm.ProfileCount;

    return extrusionForm;
}

public ModelCurve MakeLine(Document doc, XYZ ptA, XYZ ptB)
{
    Autodesk.Revit.ApplicationServices.Application app = doc.Application;
    // Create plane by the points
    Line line = Line.CreateBound(ptA, ptB);
    XYZ norm = ptA.CrossProduct(ptB);
    if (norm.IsZeroLength()) norm = XYZ.BasisZ;
    Plane plane = Plane.CreateByNormalAndOrigin(norm, ptB);
    SketchPlane skplane = SketchPlane.Create(doc, plane);
    // Create line here
    ModelCurve modelcurve = doc.FamilyCreate.NewModelCurve(line, skplane);
    return modelcurve;
}
Private Function CreateExtrusionForm(document As Autodesk.Revit.DB.Document) As Form
    Dim extrusionForm As Form = Nothing

    ' Create one profile
    Dim ref_ar As New ReferenceArray()

    Dim ptA As New XYZ(10, 10, 0)
    Dim ptB As New XYZ(90, 10, 0)
    Dim modelcurve As ModelCurve = MakeLine(document, ptA, ptB)
    ref_ar.Append(modelcurve.GeometryCurve.Reference)

    ptA = New XYZ(90, 10, 0)
    ptB = New XYZ(10, 90, 0)
    modelcurve = MakeLine(document, ptA, ptB)
    ref_ar.Append(modelcurve.GeometryCurve.Reference)

    ptA = New XYZ(10, 90, 0)
    ptB = New XYZ(10, 10, 0)
    modelcurve = MakeLine(document, ptA, ptB)
    ref_ar.Append(modelcurve.GeometryCurve.Reference)

    ' The extrusion form direction
    Dim direction As New XYZ(0, 0, 50)

    extrusionForm = document.FamilyCreate.NewExtrusionForm(True, ref_ar, direction)

    Dim profileCount As Integer = extrusionForm.ProfileCount

    Return extrusionForm
End Function

Public Function MakeLine(doc As Document, ptA As XYZ, ptB As XYZ) As ModelCurve
    Dim app As Autodesk.Revit.ApplicationServices.Application = doc.Application
    ' Create plane by the points
    Dim line__1 As Line = Line.CreateBound(ptA, ptB)
    Dim norm As XYZ = ptA.CrossProduct(ptB)
    If norm.IsZeroLength() Then
        norm = XYZ.BasisZ
    End If
 Dim plane As Plane = plane.CreateByNormalAndOrigin(norm, ptB)
    Dim skplane As SketchPlane = SketchPlane.Create(doc, plane)
    ' Create line here
    Dim modelcurve As ModelCurve = doc.FamilyCreate.NewModelCurve(line__1, skplane)
    Return modelcurve
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


FamilyItemFactory.NewFormByCap Method

FamilyItemFactoryNewFormByCap Method

Create new Form element by cap operation (to create a single-surface form), and add it into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Form NewFormByCap(
    bool isSolid,
    ReferenceArray profile
)
Public Function NewFormByCap (
    isSolid As Boolean,
    profile As ReferenceArray
) As Form
public:
Form^ NewFormByCap(
    bool isSolid,
    ReferenceArray^ profile
)
member NewFormByCap :
        isSolid : bool *
        profile : ReferenceArray -> Form

Parameters

isSolid Boolean
Indicates if the Form is Solid or Void.
profile ReferenceArray
The profile of the newly created cap. It should consist of only one curve loop.

Return Value

Form
If creation was successful new form is returned.
See Also

Reference

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


FamilyItemFactory.NewFormByThickenSingleSurface Method

FamilyItemFactoryNewFormByThickenSingleSurface Method

Create a new Form element by thickening a single-surface form, and add it into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Form NewFormByThickenSingleSurface(
    bool isSolid,
    Form singleSurfaceForm,
    XYZ thickenDir
)
Public Function NewFormByThickenSingleSurface (
    isSolid As Boolean,
    singleSurfaceForm As Form,
    thickenDir As XYZ
) As Form
public:
Form^ NewFormByThickenSingleSurface(
    bool isSolid,
    Form^ singleSurfaceForm,
    XYZ^ thickenDir
)
member NewFormByThickenSingleSurface :
        isSolid : bool *
        singleSurfaceForm : Form *
        thickenDir : XYZ -> Form

Parameters

isSolid Boolean
Indicates if the Form is Solid or Void.
singleSurfaceForm Form
The single-surface form element. It can have one top/bottom face or one side face.
thickenDir XYZ
The offset of capped solid.

Return Value

Form
This function will modify the input singleSurfaceForm and return the same element.
See Also

Reference

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


FamilyItemFactory.NewLinearDimension Method

FamilyItemFactoryNewLinearDimension Method

Creates a new linear dimension object.
Overload List
 | Name | Description
 | NewLinearDimension(View, Line, ReferenceArray) | Generate a new linear dimension object using the default dimension type.
Public method | NewLinearDimension(View, Line, ReferenceArray, DimensionType) | Creates a new linear dimension object using the specified dimension type.
Top
See Also

Reference

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


FamilyItemFactory.NewLinearDimension(View, Line, ReferenceArray) Method

FamilyItemFactoryNewLinearDimension(View, Line, ReferenceArray) Method

Generate a new linear dimension object using the default dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Dimension NewLinearDimension(
    View view,
    Line line,
    ReferenceArray references
)
Public Function NewLinearDimension (
    view As View,
    line As Line,
    references As ReferenceArray
) As Dimension
public:
Dimension^ NewLinearDimension(
    View^ view,
    Line^ line,
    ReferenceArray^ references
)
member NewLinearDimension :
        view : View *
        line : Line *
        references : ReferenceArray -> Dimension

Parameters

view View
The view in which the dimension is to be visible.
line Line
The extension line of the dimension.
references ReferenceArray
An array of geometric references to which the dimension is to be bound. You must supply at least two references, and all references supplied must be parallel to each other and perpendicular to the extension line.

Return Value

Dimension
If creation was successful the new linear dimension is returned, otherwise an exception with failure information will be thrown.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when any input argument is .
ArgumentException | Thrown when the argument "references" is invalid.
InvalidOperationException | Thrown when the creation failed.
Remarks
The currently user set default style is used for the created dimension.
Example
C#
VB
C++
F#
Copy
public Dimension CreateLinearDimension(Document document)
{
    // first create two lines
    XYZ pt1 = new XYZ(5, 5, 0);
    XYZ pt2 = new XYZ(5, 10, 0);
    Line line = Line.CreateBound(pt1, pt2);
    Plane plane = Plane.CreateByNormalAndOrigin(pt1.CrossProduct(pt2), pt2);
    SketchPlane skplane = SketchPlane.Create (document, plane);
    ModelCurve modelcurve1 = document.FamilyCreate.NewModelCurve(line, skplane);

    pt1 = new XYZ(10, 5, 0);
    pt2 = new XYZ(10, 10, 0);
    line = Line.CreateBound(pt1, pt2);
    plane = Plane.CreateByNormalAndOrigin(pt1.CrossProduct(pt2), pt2);
    skplane = SketchPlane.Create (document, plane);
    ModelCurve modelcurve2 = document.FamilyCreate.NewModelCurve(line, skplane);

    // now create a linear dimension between them
    ReferenceArray ra = new ReferenceArray();
    ra.Append(modelcurve1.GeometryCurve.Reference);
    ra.Append(modelcurve2.GeometryCurve.Reference);

    pt1 = new XYZ(5, 10, 0);
    pt2 = new XYZ(10, 10, 0);
    line = Line.CreateBound(pt1, pt2);

    Dimension dim = document.FamilyCreate.NewLinearDimension(document.ActiveView, line, ra);

    // create a label for the dimension called "width"
    FamilyParameter param = document.FamilyManager.AddParameter("width",
        GroupTypeId.Constraints,
        SpecTypeId.Length, false);

    dim.FamilyLabel = param;

    return dim;
}
Public Function CreateLinearDimension(document As Document) As Dimension
    ' first create two lines
    Dim pt1 As New XYZ(5, 5, 0)
    Dim pt2 As New XYZ(5, 10, 0)
    Dim line__1 As Line = Line.CreateBound(pt1, pt2)
 Dim plane As Plane = plane.CreateByNormalAndOrigin(pt1.CrossProduct(pt2), pt2)
    Dim skplane As SketchPlane = SketchPlane.Create(document, plane)
    Dim modelcurve1 As ModelCurve = document.FamilyCreate.NewModelCurve(line__1, skplane)

    pt1 = New XYZ(10, 5, 0)
    pt2 = New XYZ(10, 10, 0)
    line__1 = Line.CreateBound(pt1, pt2)
 plane = plane.CreateByNormalAndOrigin(pt1.CrossProduct(pt2), pt2)
    skplane = SketchPlane.Create(document, plane)
    Dim modelcurve2 As ModelCurve = document.FamilyCreate.NewModelCurve(line__1, skplane)

    ' now create a linear dimension between them
    Dim ra As New ReferenceArray()
    ra.Append(modelcurve1.GeometryCurve.Reference)
    ra.Append(modelcurve2.GeometryCurve.Reference)

    pt1 = New XYZ(5, 10, 0)
    pt2 = New XYZ(10, 10, 0)
    line__1 = Line.CreateBound(pt1, pt2)

    Dim [dim] As Dimension = document.FamilyCreate.NewLinearDimension(document.ActiveView, line__1, ra)

    ' create a label for the dimension called "width"
    Dim param As FamilyParameter = document.FamilyManager.AddParameter("width", GroupTypeId.Constraints, SpecTypeId.Length, False)

    [dim].FamilyLabel = param

    Return [dim]
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

FamilyItemFactory Class
NewLinearDimension Overload
Autodesk.Revit.Creation Namespace


FamilyItemFactory.NewLinearDimension(View, Line, ReferenceArray, DimensionType) Method

FamilyItemFactoryNewLinearDimension(View, Line, ReferenceArray, DimensionType) Method

Creates a new linear dimension object using the specified dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Dimension NewLinearDimension(
    View view,
    Line line,
    ReferenceArray references,
    DimensionType dimensionType
)
Public Function NewLinearDimension (
    view As View,
    line As Line,
    references As ReferenceArray,
    dimensionType As DimensionType
) As Dimension
public:
Dimension^ NewLinearDimension(
    View^ view,
    Line^ line,
    ReferenceArray^ references,
    DimensionType^ dimensionType
)
member NewLinearDimension :
        view : View *
        line : Line *
        references : ReferenceArray *
        dimensionType : DimensionType -> Dimension

Parameters

view View
The view in which the dimension is to be visible.
line Line
The extension line of the dimension.
references ReferenceArray
An array of geometric references to which the dimension is to be bound. You must supply at least two references, and all references supplied must be parallel to each other and perpendicular to the extension line.
dimensionType DimensionType
The dimension style to be used for the dimension.

Return Value

Dimension
If creation was successful the new linear dimension is returned, otherwise an exception with failure information will be thrown.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when any input argument is .
ArgumentException | Thrown when the argument is invalid.
InvalidOperationException | Thrown when the creation failed.
See Also

Reference

FamilyItemFactory Class
NewLinearDimension Overload
Autodesk.Revit.Creation Namespace


FamilyItemFactory.NewLoftForm Method

FamilyItemFactoryNewLoftForm Method

Create new Form element by Loft operation, and add it into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Form NewLoftForm(
    bool isSolid,
    ReferenceArrayArray profiles
)
Public Function NewLoftForm (
    isSolid As Boolean,
    profiles As ReferenceArrayArray
) As Form
public:
Form^ NewLoftForm(
    bool isSolid,
    ReferenceArrayArray^ profiles
)
member NewLoftForm :
        isSolid : bool *
        profiles : ReferenceArrayArray -> Form

Parameters

isSolid Boolean
Indicates if the Form is Solid or Void.
profiles ReferenceArrayArray
The profile set of the newly created loft. Each profile should consist of only one curve loop.

Return Value

Form
If creation was successful form is are returned.
Example
C#
VB
C++
F#
Copy
private Form CreateLoftForm(Autodesk.Revit.DB.Document document)
{
    Form loftForm = null;

    ReferencePointArray rpa = new ReferencePointArray();
    ReferenceArrayArray ref_ar_ar = new ReferenceArrayArray();
    ReferenceArray ref_ar = new ReferenceArray();
    ReferencePoint rp = null;
    XYZ xyz = null;

    // make first profile curve for loft
    xyz = document.Application.Create.NewXYZ(0, 0, 0);
    rp = document.FamilyCreate.NewReferencePoint(xyz);
    rpa.Append(rp);

    xyz = document.Application.Create.NewXYZ(0, 50, 10);
    rp = document.FamilyCreate.NewReferencePoint(xyz);
    rpa.Append(rp);

    xyz = document.Application.Create.NewXYZ(0, 100, 0);
    rp = document.FamilyCreate.NewReferencePoint(xyz);
    rpa.Append(rp);

    CurveByPoints cbp = document.FamilyCreate.NewCurveByPoints(rpa);
    ref_ar.Append(cbp.GeometryCurve.Reference);
    ref_ar_ar.Append(ref_ar);
    rpa.Clear();
    ref_ar = new ReferenceArray();

    // make second profile curve for loft
    xyz = document.Application.Create.NewXYZ(50, 0, 0);
    rp = document.FamilyCreate.NewReferencePoint(xyz);
    rpa.Append(rp);

    xyz = document.Application.Create.NewXYZ(50, 50, 30);
    rp = document.FamilyCreate.NewReferencePoint(xyz);
    rpa.Append(rp);

    xyz = document.Application.Create.NewXYZ(50, 100, 0);
    rp = document.FamilyCreate.NewReferencePoint(xyz);
    rpa.Append(rp);

    cbp = document.FamilyCreate.NewCurveByPoints(rpa);
    ref_ar.Append(cbp.GeometryCurve.Reference);
    ref_ar_ar.Append(ref_ar);
    rpa.Clear();
    ref_ar = new ReferenceArray();

    // make third profile curve for loft
    xyz = document.Application.Create.NewXYZ(75, 0, 0);
    rp = document.FamilyCreate.NewReferencePoint(xyz);
    rpa.Append(rp);

    xyz = document.Application.Create.NewXYZ(75, 50, 5);
    rp = document.FamilyCreate.NewReferencePoint(xyz);
    rpa.Append(rp);

    xyz = document.Application.Create.NewXYZ(75, 100, 0);
    rp = document.FamilyCreate.NewReferencePoint(xyz);
    rpa.Append(rp);

    cbp = document.FamilyCreate.NewCurveByPoints(rpa);
    ref_ar.Append(cbp.GeometryCurve.Reference);
    ref_ar_ar.Append(ref_ar);

    loftForm = document.FamilyCreate.NewLoftForm(true, ref_ar_ar);

    return loftForm;
}
Private Function CreateLoftForm(document As Autodesk.Revit.DB.Document) As Form
    Dim loftForm As Form = Nothing

    Dim rpa As New ReferencePointArray()
    Dim ref_ar_ar As New ReferenceArrayArray()
    Dim ref_ar As New ReferenceArray()
    Dim rp As ReferencePoint = Nothing
    Dim xyz As XYZ = Nothing

    ' make first profile curve for loft
    xyz = document.Application.Create.NewXYZ(0, 0, 0)
    rp = document.FamilyCreate.NewReferencePoint(xyz)
    rpa.Append(rp)

    xyz = document.Application.Create.NewXYZ(0, 50, 10)
    rp = document.FamilyCreate.NewReferencePoint(xyz)
    rpa.Append(rp)

    xyz = document.Application.Create.NewXYZ(0, 100, 0)
    rp = document.FamilyCreate.NewReferencePoint(xyz)
    rpa.Append(rp)

    Dim cbp As CurveByPoints = document.FamilyCreate.NewCurveByPoints(rpa)
    ref_ar.Append(cbp.GeometryCurve.Reference)
    ref_ar_ar.Append(ref_ar)
    rpa.Clear()
    ref_ar = New ReferenceArray()

    ' make second profile curve for loft
    xyz = document.Application.Create.NewXYZ(50, 0, 0)
    rp = document.FamilyCreate.NewReferencePoint(xyz)
    rpa.Append(rp)

    xyz = document.Application.Create.NewXYZ(50, 50, 30)
    rp = document.FamilyCreate.NewReferencePoint(xyz)
    rpa.Append(rp)

    xyz = document.Application.Create.NewXYZ(50, 100, 0)
    rp = document.FamilyCreate.NewReferencePoint(xyz)
    rpa.Append(rp)

    cbp = document.FamilyCreate.NewCurveByPoints(rpa)
    ref_ar.Append(cbp.GeometryCurve.Reference)
    ref_ar_ar.Append(ref_ar)
    rpa.Clear()
    ref_ar = New ReferenceArray()

    ' make third profile curve for loft
    xyz = document.Application.Create.NewXYZ(75, 0, 0)
    rp = document.FamilyCreate.NewReferencePoint(xyz)
    rpa.Append(rp)

    xyz = document.Application.Create.NewXYZ(75, 50, 5)
    rp = document.FamilyCreate.NewReferencePoint(xyz)
    rpa.Append(rp)

    xyz = document.Application.Create.NewXYZ(75, 100, 0)
    rp = document.FamilyCreate.NewReferencePoint(xyz)
    rpa.Append(rp)

    cbp = document.FamilyCreate.NewCurveByPoints(rpa)
    ref_ar.Append(cbp.GeometryCurve.Reference)
    ref_ar_ar.Append(ref_ar)

    loftForm = document.FamilyCreate.NewLoftForm(True, ref_ar_ar)

    Return loftForm
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


FamilyItemFactory.NewModelText Method

FamilyItemFactoryNewModelText Method

Create a model text in the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ModelText NewModelText(
    string text,
    ModelTextType modelTextType,
    SketchPlane sketchPlane,
    XYZ position,
    HorizontalAlign horizontalAlign,
    double depth
)
Public Function NewModelText (
    text As String,
    modelTextType As ModelTextType,
    sketchPlane As SketchPlane,
    position As XYZ,
    horizontalAlign As HorizontalAlign,
    depth As Double
) As ModelText
public:
ModelText^ NewModelText(
    String^ text,
    ModelTextType^ modelTextType,
    SketchPlane^ sketchPlane,
    XYZ^ position,
    HorizontalAlign horizontalAlign,
    double depth
)
member NewModelText :
        text : string *
        modelTextType : ModelTextType *
        sketchPlane : SketchPlane *
        position : XYZ *
        horizontalAlign : HorizontalAlign *
        depth : float -> ModelText

Parameters

text String
The text to be displayed.
modelTextType ModelTextType
The type of model text. If this parameter is , the default type will be used.
sketchPlane SketchPlane
The sketch plane of the model text. The direction of model text is determined by the normal of the sketch plane. To extrude in the other direction set the depth value to negative.
position XYZ
The position of the model text. The position must lie in the sketch plane.
horizontalAlign HorizontalAlign
The horizontal alignment.
depth Double
The depth of the model text.

Return Value

ModelText
If successful, the newly created model text is returned, otherwise an exception with error information will be thrown.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument text, sketchPlane or XYZ is .
ArgumentException | Thrown when input argument text is an empty string. Thrown when input argument horizontalAlign or depth is invalid.
InvalidOperationException | Thrown when model text creation failed.
See Also

Reference

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


FamilyItemFactory.NewOpening Method

FamilyItemFactoryNewOpening Method

Create an opening to cut the wall or ceiling.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Opening NewOpening(
    Element host,
    CurveArray profile
)
Public Function NewOpening (
    host As Element,
    profile As CurveArray
) As Opening
public:
Opening^ NewOpening(
    Element^ host,
    CurveArray^ profile
)
member NewOpening :
        host : Element *
        profile : CurveArray -> Opening

Parameters

host Element
Host elements that new opening would lie in. The host can only be a wall or a ceiling.
profile CurveArray
The profile of the newly created opening. This may contain more than one curve loop. Each loop must be a fully closed curve loop and the loops may not intersect. The profiles will be projected into the host plane.

Return Value

Opening
If successful, the newly created opening is returned, otherwise an exception with error information will be thrown.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument host or profile is .
ArgumentException | Thrown when host isn't a wall or a ceiling. Thrown when profile doesn't contain any loops.
InvalidOperationException | Thrown when opening creation failed.
See Also

Reference

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


FamilyItemFactory.NewRadialDimension Method

FamilyItemFactoryNewRadialDimension Method

Creates a new radial dimension object.
Overload List
 | Name | Description
Public method | NewRadialDimension(View, Reference, XYZ) | Creates a new radial dimension object using the default dimension type.
Public method | NewRadialDimension(View, Reference, XYZ, DimensionType) | Generate a new radial dimension object using a specified dimension type.
Top
See Also

Reference

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


FamilyItemFactory.NewRadialDimension(View, Reference, XYZ) Method

FamilyItemFactoryNewRadialDimension(View, Reference, XYZ) Method

Creates a new radial dimension object using the default dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Dimension NewRadialDimension(
    View view,
    Reference arcRef,
    XYZ origin
)
Public Function NewRadialDimension (
    view As View,
    arcRef As Reference,
    origin As XYZ
) As Dimension
public:
Dimension^ NewRadialDimension(
    View^ view,
    Reference^ arcRef,
    XYZ^ origin
)
member NewRadialDimension :
        view : View *
        arcRef : Reference *
        origin : XYZ -> Dimension

Parameters

view View
The view in which the dimension is to be visible.
arcRef Reference
Geometric reference of the arc to which the dimension is to be bound.
origin XYZ
The point where the witness line of the radial dimension will lie.

Return Value

Dimension
If creation was successful the new arc length dimension is returned, otherwise an exception with failure information will be thrown.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when any input argument is .
ArgumentException | Thrown when the argument arcRef is invalid.
InvalidOperationException | Thrown when the creation failed.
Remarks
The currently user set default style is used for the created dimension.
See Also

Reference

FamilyItemFactory Class
NewRadialDimension Overload
Autodesk.Revit.Creation Namespace


FamilyItemFactory.NewRadialDimension(View, Reference, XYZ, DimensionType) Method

FamilyItemFactoryNewRadialDimension(View, Reference, XYZ, DimensionType) Method

Generate a new radial dimension object using a specified dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Dimension NewRadialDimension(
    View view,
    Reference arcRef,
    XYZ origin,
    DimensionType dimensionType
)
Public Function NewRadialDimension (
    view As View,
    arcRef As Reference,
    origin As XYZ,
    dimensionType As DimensionType
) As Dimension
public:
Dimension^ NewRadialDimension(
    View^ view,
    Reference^ arcRef,
    XYZ^ origin,
    DimensionType^ dimensionType
)
member NewRadialDimension :
        view : View *
        arcRef : Reference *
        origin : XYZ *
        dimensionType : DimensionType -> Dimension

Parameters

view View
The view in which the dimension is to be visible.
arcRef Reference
Geometric reference of the arc to which the dimension is to be bound.
origin XYZ
The point where the witness line of the radial dimension will lie.
dimensionType DimensionType
The dimension style to be used for the dimension.

Return Value

Dimension
If creation was successful the new arc length dimension is returned, otherwise an exception with failure information will be thrown.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when any input argument is .
ArgumentException | Thrown when the argument arcRef/dimensionType is invalid.
InvalidOperationException | Thrown when the creation failed.
Remarks
The dimension will be created on default place.
See Also

Reference

FamilyItemFactory Class
NewRadialDimension Overload
Autodesk.Revit.Creation Namespace


FamilyItemFactory.NewReferencePoint Method

FamilyItemFactoryNewReferencePoint Method

Creates a reference point.
Overload List
 | Name | Description
Public method | NewReferencePoint(PointElementReference) | Create a reference point on an existing reference in an Autodesk Revit family document.
Public method | NewReferencePoint(Transform) | Create a reference point at a given location and with a given coordinate system in an Autodesk Revit family document.
Public method | NewReferencePoint(XYZ) | Create a reference point at a given location in an Autodesk Revit family document.
Top
See Also

Reference

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


FamilyItemFactory.NewReferencePoint(PointElementReference) Method

FamilyItemFactoryNewReferencePoint(PointElementReference) Method

Create a reference point on an existing reference in an Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReferencePoint NewReferencePoint(
    PointElementReference A_0
)
Public Function NewReferencePoint (
    A_0 As PointElementReference
) As ReferencePoint
public:
ReferencePoint^ NewReferencePoint(
    PointElementReference^ A_0
)
member NewReferencePoint :
        A_0 : PointElementReference -> ReferencePoint

Parameters

A_0 PointElementReference

Return Value

ReferencePoint
The newly created ReferencePoint.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the argument is .
InvalidOperationException | Thrown when the family is not a Conceptual Mass Family.
Remarks
The location and coordinate system of the point is determined by the particular PointReference subclass, and the point will remain constrained to that reference.
See Also

Reference

FamilyItemFactory Class
NewReferencePoint Overload
Autodesk.Revit.Creation Namespace


FamilyItemFactory.NewReferencePoint(Transform) Method

FamilyItemFactoryNewReferencePoint(Transform) Method

Create a reference point at a given location and with a given coordinate system in an Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReferencePoint NewReferencePoint(
    Transform A_0
)
Public Function NewReferencePoint (
    A_0 As Transform
) As ReferencePoint
public:
ReferencePoint^ NewReferencePoint(
    Transform^ A_0
)
member NewReferencePoint :
        A_0 : Transform -> ReferencePoint

Parameters

A_0 Transform

Return Value

ReferencePoint
The newly created ReferencePoint.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the argument is .
InvalidOperationException | Thrown when the family is not a Conceptual Mass Family.
See Also

Reference

FamilyItemFactory Class
NewReferencePoint Overload
Autodesk.Revit.Creation Namespace


FamilyItemFactory.NewReferencePoint(XYZ) Method

FamilyItemFactoryNewReferencePoint(XYZ) Method

Create a reference point at a given location in an Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReferencePoint NewReferencePoint(
    XYZ A_0
)
Public Function NewReferencePoint (
    A_0 As XYZ
) As ReferencePoint
public:
ReferencePoint^ NewReferencePoint(
    XYZ^ A_0
)
member NewReferencePoint :
        A_0 : XYZ -> ReferencePoint

Parameters

A_0 XYZ

Return Value

ReferencePoint
The newly created ReferencePoint.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the argument is .
InvalidOperationException | Thrown when the family is not a Conceptual Mass Family.
Remarks
The ReferencePoint will have a default coordinate system corresponding to the global coordinate system.
See Also

Reference

FamilyItemFactory Class
NewReferencePoint Overload
Autodesk.Revit.Creation Namespace


FamilyItemFactory.NewRevolution Method

FamilyItemFactoryNewRevolution Method

Add a new Revolution instance into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Revolution NewRevolution(
    bool isSolid,
    CurveArrArray profile,
    SketchPlane sketchPlane,
    Line axis,
    double startAngle,
    double endAngle
)
Public Function NewRevolution (
    isSolid As Boolean,
    profile As CurveArrArray,
    sketchPlane As SketchPlane,
    axis As Line,
    startAngle As Double,
    endAngle As Double
) As Revolution
public:
Revolution^ NewRevolution(
    bool isSolid,
    CurveArrArray^ profile,
    SketchPlane^ sketchPlane,
    Line^ axis,
    double startAngle,
    double endAngle
)
member NewRevolution :
        isSolid : bool *
        profile : CurveArrArray *
        sketchPlane : SketchPlane *
        axis : Line *
        startAngle : float *
        endAngle : float -> Revolution

Parameters

isSolid Boolean
Indicates if the Revolution is Solid or Void.
profile CurveArrArray
The profile of the newly created revolution. This may contain more than one curve loop. Each loop must be a fully closed curve loop and the loops must not intersect. All loops must lie in the same plane. The loop can be a unbound circle or ellipse, but its geometry will be split in two in order to satisfy requirements for sketches used in extrusions.
sketchPlane SketchPlane
The sketch plane for the revolution. The direction of revolution is determined by the normal for the sketch plane.
axis Line
The axis of revolution. This axis must lie in the same plane as the curve loops.
startAngle Double
The start angle of Revolution in radians.
endAngle Double
The end angle of Revolution in radians.

Return Value

Revolution
If creation was successful the new revolution is returned, otherwise an exception with failure information will be thrown.
Exceptions
Exception | Condition
ArgumentException | Thrown when the input argument-profile-is or empty array.
ArgumentNullException | Thrown when the input argument-sketchPlane-is .
ArgumentException | Thrown when the input argument-sketchPlane-is an invalid sketch plane.
ArgumentNullException | Thrown when the input argument-axis-is .
InvalidOperationException | Thrown when creation is attempted in Conceptual Mass, 2D, or other family where revolutions cannot be created.
InvalidOperationException | Thrown when the creation failed.
Remarks
This method creates an Revolution in a family document. The Revolution will be rotated the plane of the Revolution profile about the Axis.
Example
C#
VB
C++
F#
Copy
private Revolution CreateRevolution(Autodesk.Revit.DB.Document document, SketchPlane sketchPlane)
{
    Revolution revolution = null;

    // make sure we have a family document
    if (true == document.IsFamilyDocument)
    {
        // Define a profile for the revolution
        CurveArrArray curveArrArray = new CurveArrArray();
        CurveArray curveArray = new CurveArray();

        // create a rectangular profile for the revolution
        XYZ p0 = XYZ.Zero;
        XYZ p1 = new XYZ(10, 0, 0);
        XYZ p2 = new XYZ(10, 10, 0);
        XYZ p3 = new XYZ(0, 10, 0);
        Line line1 = Line.CreateBound(p0, p1);
        Line line2 = Line.CreateBound(p1, p2);
        Line line3 = Line.CreateBound(p2, p3);
        Line line4 = Line.CreateBound(p3, p0);

        XYZ pp = new XYZ(1, -1, 0);
        Line axis1 = Line.CreateBound(XYZ.Zero, pp);
        curveArray.Append(line1);
        curveArray.Append(line2);
        curveArray.Append(line3);
        curveArray.Append(line4);

        curveArrArray.Append(curveArray);

        // create solid rectangular revolution
        revolution = document.FamilyCreate.NewRevolution(true, curveArrArray, sketchPlane, axis1, -Math.PI, 0);

        if (null != revolution)
        {
            // move to proper place
            XYZ transPoint1 = new XYZ(0, 32, 0);
            ElementTransformUtils.MoveElement(document, revolution.Id, transPoint1);
        }
        else
        {
            throw new Exception("Create a new Revolution failed.");
        }
    }
    else
    {
        throw new Exception("Please open a Family document before invoking this command.");
    }

    return revolution;
}
Private Function CreateRevolution(document As Autodesk.Revit.DB.Document, sketchPlane As SketchPlane) As Revolution
    Dim revolution As Revolution = Nothing

    ' make sure we have a family document
    If True = document.IsFamilyDocument Then
        ' Define a profile for the revolution
        Dim curveArrArray As New CurveArrArray()
        Dim curveArray As New CurveArray()

        ' create a rectangular profile for the revolution
        Dim p0 As XYZ = XYZ.Zero
        Dim p1 As New XYZ(10, 0, 0)
        Dim p2 As New XYZ(10, 10, 0)
        Dim p3 As New XYZ(0, 10, 0)
        Dim line1 As Line = Line.CreateBound(p0, p1)
        Dim line2 As Line = Line.CreateBound(p1, p2)
        Dim line3 As Line = Line.CreateBound(p2, p3)
        Dim line4 As Line = Line.CreateBound(p3, p0)

        Dim pp As New XYZ(1, -1, 0)
        Dim axis1 As Line = Line.CreateBound(XYZ.Zero, pp)
        curveArray.Append(line1)
        curveArray.Append(line2)
        curveArray.Append(line3)
        curveArray.Append(line4)

        curveArrArray.Append(curveArray)

        ' create solid rectangular revolution
        revolution = document.FamilyCreate.NewRevolution(True, curveArrArray, sketchPlane, axis1, -Math.PI, 0)

        If revolution IsNot Nothing Then
            ' move to proper place
            Dim transPoint1 As New XYZ(0, 32, 0)
            ElementTransformUtils.MoveElement(document, revolution.Id, transPoint1)
        Else
            Throw New Exception("Create a new Revolution failed.")
        End If
    Else
        Throw New Exception("Please open a Family document before invoking this command.")
    End If

    Return revolution
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


FamilyItemFactory.NewRevolveForms Method

FamilyItemFactoryNewRevolveForms Method

Create new Form elements by revolve operation, and add them into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormArray NewRevolveForms(
    bool isSolid,
    ReferenceArray profile,
    Reference axis,
    double startAngle,
    double endAngle
)
Public Function NewRevolveForms (
    isSolid As Boolean,
    profile As ReferenceArray,
    axis As Reference,
    startAngle As Double,
    endAngle As Double
) As FormArray
public:
FormArray^ NewRevolveForms(
    bool isSolid,
    ReferenceArray^ profile,
    Reference^ axis,
    double startAngle,
    double endAngle
)
member NewRevolveForms :
        isSolid : bool *
        profile : ReferenceArray *
        axis : Reference *
        startAngle : float *
        endAngle : float -> FormArray

Parameters

isSolid Boolean
Indicates if the Form is Solid or Void.
profile ReferenceArray
The profile of the newly created revolution. It should consist of only one curve loop. The profile must be in the same plane as the axis.
axis Reference
The axis of revolution. The axis is a line that must lie in the same plane as the curves in the profile.
startAngle Double
The start angle of Revolution in radians.
endAngle Double
The end angle of Revolution in radians.

Return Value

FormArray
If creation was successful new forms are returned.
Remarks
Typically this operation produces only a single form, but some combinations of arguments will create multiple forms from a single profile.
Example
C#
VB
C++
F#
Copy
private FormArray CreateRevolveForm(Document document)
{
    FormArray revolveForms = null;

    // Create one profile
    ReferenceArray ref_ar = new ReferenceArray();

    XYZ ptA = new XYZ(0, 0, 10);
    XYZ ptB = new XYZ(100, 0, 10);
    Line line = Line.CreateBound(ptA, ptB);
    ModelCurve modelcurve = MakeLine(document, ptA, ptB);
    ref_ar.Append(modelcurve.GeometryCurve.Reference);

    ptA = new XYZ(100, 0, 10);
    ptB = new XYZ(100, 100, 10);
    modelcurve = MakeLine(document, ptA, ptB);
    ref_ar.Append(modelcurve.GeometryCurve.Reference);

    ptA = new XYZ(100, 100, 10);
    ptB = new XYZ(0, 0, 10);
    modelcurve = MakeLine(document, ptA, ptB);
    ref_ar.Append(modelcurve.GeometryCurve.Reference);

    // Create axis for revolve form
    ptA = new XYZ(-5, 0, 10);
    ptB = new XYZ(-5, 10, 10);
    ModelCurve axis = MakeLine(document, ptA, ptB);

    // make axis a Reference Line
    axis.ChangeToReferenceLine();

    // Typically this operation produces only a single form,
    // but some combinations of arguments will create multiple froms from a single profile.
    revolveForms = document.FamilyCreate.NewRevolveForms(true, ref_ar, axis.GeometryCurve.Reference, 0, Math.PI / 4);

    return revolveForms;
}

public ModelCurve MakeLine(Document doc, XYZ ptA, XYZ ptB)
{
    Autodesk.Revit.ApplicationServices.Application app = doc.Application;
    // Create plane by the points
    Line line = Line.CreateBound(ptA, ptB);
    XYZ norm = ptA.CrossProduct(ptB);
    if (norm.IsZeroLength()) norm = XYZ.BasisZ;
    Plane plane = Plane.CreateByNormalAndOrigin(norm, ptB);
    SketchPlane skplane = SketchPlane.Create(doc, plane);
    // Create line here
    ModelCurve modelcurve = doc.FamilyCreate.NewModelCurve(line, skplane);
    return modelcurve;
}
Private Function CreateRevolveForm(document As Document) As FormArray
    Dim revolveForms As FormArray = Nothing

    ' Create one profile
    Dim ref_ar As New ReferenceArray()

    Dim ptA As New XYZ(0, 0, 10)
    Dim ptB As New XYZ(100, 0, 10)
    Dim line__1 As Line = Line.CreateBound(ptA, ptB)
    Dim modelcurve As ModelCurve = MakeLine(document, ptA, ptB)
    ref_ar.Append(modelcurve.GeometryCurve.Reference)

    ptA = New XYZ(100, 0, 10)
    ptB = New XYZ(100, 100, 10)
    modelcurve = MakeLine(document, ptA, ptB)
    ref_ar.Append(modelcurve.GeometryCurve.Reference)

    ptA = New XYZ(100, 100, 10)
    ptB = New XYZ(0, 0, 10)
    modelcurve = MakeLine(document, ptA, ptB)
    ref_ar.Append(modelcurve.GeometryCurve.Reference)

    ' Create axis for revolve form
    ptA = New XYZ(-5, 0, 10)
    ptB = New XYZ(-5, 10, 10)
    Dim axis As ModelCurve = MakeLine(document, ptA, ptB)

    ' make axis a Reference Line
    axis.ChangeToReferenceLine()

    ' Typically this operation produces only a single form,
    ' but some combinations of arguments will create multiple froms from a single profile.
    revolveForms = document.FamilyCreate.NewRevolveForms(True, ref_ar, axis.GeometryCurve.Reference, 0, Math.PI / 4)

    Return revolveForms
End Function

Public Function MakeLine(doc As Document, ptA As XYZ, ptB As XYZ) As ModelCurve
    Dim app As Autodesk.Revit.ApplicationServices.Application = doc.Application
    ' Create plane by the points
    Dim line__1 As Line = Line.CreateBound(ptA, ptB)
    Dim norm As XYZ = ptA.CrossProduct(ptB)
    If norm.IsZeroLength() Then
        norm = XYZ.BasisZ
    End If
 Dim plane As Plane = plane.CreateByNormalAndOrigin(norm, ptB)
    Dim skplane As SketchPlane = SketchPlane.Create(doc, plane)
    ' Create line here
    Dim modelcurve As ModelCurve = doc.FamilyCreate.NewModelCurve(line__1, skplane)
    Return modelcurve
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


FamilyItemFactory.NewSweep Method

FamilyItemFactoryNewSweep Method

Adds a new sweep form to the family document.
Overload List
 | Name | Description
Public method | NewSweep(Boolean, ReferenceArray, SweepProfile, Int32, ProfilePlaneLocation) | Adds a new sweep form into the family document, using an array of selected references as a 3D path.
 | NewSweep(Boolean, CurveArray, SketchPlane, SweepProfile, Int32, ProfilePlaneLocation) | Adds a new sweep form to the family document, using a path of curve elements.
Top
See Also

Reference

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


FamilyItemFactory.NewSweep(Boolean, ReferenceArray, SweepProfile, Int32, ProfilePlaneLocation) Method

FamilyItemFactoryNewSweep(Boolean, ReferenceArray, SweepProfile, Int32, ProfilePlaneLocation) Method

Adds a new sweep form into the family document, using an array of selected references as a 3D path.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Sweep NewSweep(
    bool isSolid,
    ReferenceArray path,
    SweepProfile profile,
    int profileLocationCurveIndex,
    ProfilePlaneLocation profilePlaneLocation
)
Public Function NewSweep (
    isSolid As Boolean,
    path As ReferenceArray,
    profile As SweepProfile,
    profileLocationCurveIndex As Integer,
    profilePlaneLocation As ProfilePlaneLocation
) As Sweep
public:
Sweep^ NewSweep(
    bool isSolid,
    ReferenceArray^ path,
    SweepProfile^ profile,
    int profileLocationCurveIndex,
    ProfilePlaneLocation profilePlaneLocation
)
member NewSweep :
        isSolid : bool *
        path : ReferenceArray *
        profile : SweepProfile *
        profileLocationCurveIndex : int *
        profilePlaneLocation : ProfilePlaneLocation -> Sweep

Parameters

isSolid Boolean
Indicates if the Sweep is Solid or Void.
path ReferenceArray
The path of the sweep. The path should be reference of curve or edge obtained from existing geometry.
profile SweepProfile
The profile to create the new Sweep. The profile must lie in the XY plane, and it will be transformed to the profile plane automatically. This may contain more than one curve loop or a profile family. Each loop must be a fully closed curve loop and the loops must not intersect. The loop can be a unbound circle or ellipse, but its geometry will be split in two in order to satisfy requirements for sketches used in extrusions.
profileLocationCurveIndex Int32
The index of the path curves. The curve upon which the profile plane will be determined.
profilePlaneLocation ProfilePlaneLocation
The location on the profileLocationCurve where the profile plane will be determined.

Return Value

Sweep
If creation was successful the new Sweep is returned, otherwise an exception with failure information will be thrown.
Exceptions
Exception | Condition
ArgumentException | Thrown when the input argument-path-is or empty or an unsupported curve type.
ArgumentNullException | Thrown when the input argument-profile-is .
ArgumentOutOfRangeException | Thrown when the input argument-profileLocationCurveIndex-is out of index bounds.
ArgumentOutOfRangeException | Thrown when the input argument-profilePlaneLocation-does not exist in the ProfilePlaneLocation enumeration.
InvalidOperationException | Thrown when the creation failed.
Remarks
This method creates a sweep in a family document. The sweep will trace the profile along the path.
See Also

Reference

FamilyItemFactory Class
NewSweep Overload
Autodesk.Revit.Creation Namespace


FamilyItemFactory.NewSweep(Boolean, CurveArray, SketchPlane, SweepProfile, Int32, ProfilePlaneLocation) Method

FamilyItemFactoryNewSweep(Boolean, CurveArray, SketchPlane, SweepProfile, Int32, ProfilePlaneLocation) Method

Adds a new sweep form to the family document, using a path of curve elements.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Sweep NewSweep(
    bool isSolid,
    CurveArray path,
    SketchPlane pathPlane,
    SweepProfile profile,
    int profileLocationCurveIndex,
    ProfilePlaneLocation profilePlaneLocation
)
Public Function NewSweep (
    isSolid As Boolean,
    path As CurveArray,
    pathPlane As SketchPlane,
    profile As SweepProfile,
    profileLocationCurveIndex As Integer,
    profilePlaneLocation As ProfilePlaneLocation
) As Sweep
public:
Sweep^ NewSweep(
    bool isSolid,
    CurveArray^ path,
    SketchPlane^ pathPlane,
    SweepProfile^ profile,
    int profileLocationCurveIndex,
    ProfilePlaneLocation profilePlaneLocation
)
member NewSweep :
        isSolid : bool *
        path : CurveArray *
        pathPlane : SketchPlane *
        profile : SweepProfile *
        profileLocationCurveIndex : int *
        profilePlaneLocation : ProfilePlaneLocation -> Sweep

Parameters

isSolid Boolean
Indicates if the Sweep is Solid or Void.
path CurveArray
The path of the sweep. The path should be 2D, where all input curves lie in one plane, and the curves are not required to reference existing geometry.
pathPlane SketchPlane
The sketch plane for the path. Use this when you want to create a 2D path that resides on an existing planar face. Optional, can be for 3D paths or for 2D paths where the path should not reference an existing face.
profile SweepProfile
The profile of the newly created Sweep. This may contain more than one curve loop or a profile family. The profile must lie in the XY plane, and it will be transformed to the profile plane automatically. Each loop must be a fully closed curve loop and the loops must not intersect. The loop can be a unbound circle or ellipse, but its geometry will be split in two in order to satisfy requirements for sketches used in extrusions.
profileLocationCurveIndex Int32
The index of the path curves. The curve upon which the profile plane will be determined.
profilePlaneLocation ProfilePlaneLocation
The location on the profileLocationCurve where the profile plane will be determined.

Return Value

Sweep
If creation was successful the new Sweep is returned, otherwise an exception with failure information will be thrown.
Exceptions
Exception | Condition
ArgumentException | Thrown when the input argument-path-is or empty.
ArgumentNullException | Thrown when the input argument-profile-is .
ArgumentOutOfRangeException | Thrown when the input argument-profileLocationCurveIndex-is out of index bounds.
ArgumentOutOfRangeException | Thrown when the input argument-profilePlaneLocation-does not exist in the ProfilePlaneLocation enumeration.
InvalidOperationException | Thrown when creation is attempted in Conceptual Mass, 2D, or other family where sweeps cannot be created.
InvalidOperationException | Thrown when the creation failed.
Remarks
This method creates a sweep in a family document. The sweep will trace the profile along the path.
Example
C#
VB
C++
F#
Copy
private Sweep CreateSweep(Autodesk.Revit.DB.Document document, SketchPlane sketchPlane)
{
    Sweep sweep = null;

    // make sure we have a family document
    if (true == document.IsFamilyDocument)
    {
        // Define a profile for the sweep
        CurveArrArray arrarr = new CurveArrArray();
        CurveArray arr = new CurveArray();

        // Create an ovoid profile
        XYZ pnt1 = new XYZ(0, 0, 0);
        XYZ pnt2 = new XYZ(2, 0, 0);
        XYZ pnt3 = new XYZ(1, 1, 0);
        arr.Append(Arc.Create(pnt2, 1.0d, 0.0d, 180.0d, XYZ.BasisX, XYZ.BasisY));
        arr.Append(Arc.Create(pnt1, pnt3, pnt2));
        arrarr.Append(arr);
        SweepProfile profile = document.Application.Create.NewCurveLoopsProfile(arrarr);

        // Create a path for the sweep
        XYZ pnt4 = new XYZ(10, 0, 0);
        XYZ pnt5 = new XYZ(0, 10, 0);
        Curve curve = Line.CreateBound(pnt4, pnt5);

        CurveArray curves = new CurveArray();
        curves.Append(curve);

        // create a solid ovoid sweep
        sweep = document.FamilyCreate.NewSweep(true, curves, sketchPlane, profile, 0, ProfilePlaneLocation.Start);

        if (null != sweep)
        {
            // move to proper place
            XYZ transPoint1 = new XYZ(11, 0, 0);
            ElementTransformUtils.MoveElement(document, sweep.Id, transPoint1);
        }
        else
        {
            throw new Exception("Failed to create a new Sweep.");
        }
    }
    else
    {
        throw new Exception("Please open a Family document before invoking this command.");
    }

    return sweep;
}
Private Function CreateSweep(document As Autodesk.Revit.DB.Document, sketchPlane As SketchPlane) As Sweep
    Dim sweep As Sweep = Nothing

    ' make sure we have a family document
    If True = document.IsFamilyDocument Then
        ' Define a profile for the sweep
        Dim arrarr As New CurveArrArray()
        Dim arr As New CurveArray()

        ' Create an ovoid profile
        Dim pnt1 As New XYZ(0, 0, 0)
        Dim pnt2 As New XYZ(2, 0, 0)
        Dim pnt3 As New XYZ(1, 1, 0)
        arr.Append(Arc.Create(pnt2, 1.0, 0.0, 180.0, XYZ.BasisX, XYZ.BasisY))
        arr.Append(Arc.Create(pnt1, pnt3, pnt2))
        arrarr.Append(arr)
        Dim profile As SweepProfile = document.Application.Create.NewCurveLoopsProfile(arrarr)

        ' Create a path for the sweep
        Dim pnt4 As New XYZ(10, 0, 0)
        Dim pnt5 As New XYZ(0, 10, 0)
        Dim curve As Curve = Line.CreateBound(pnt4, pnt5)

        Dim curves As New CurveArray()
        curves.Append(curve)

        ' create a solid ovoid sweep
        sweep = document.FamilyCreate.NewSweep(True, curves, sketchPlane, profile, 0, ProfilePlaneLocation.Start)

        If sweep IsNot Nothing Then
            ' move to proper place
            Dim transPoint1 As New XYZ(11, 0, 0)
            ElementTransformUtils.MoveElement(document, sweep.Id, transPoint1)
        Else
            Throw New Exception("Failed to create a new Sweep.")
        End If
    Else
        Throw New Exception("Please open a Family document before invoking this command.")
    End If

    Return sweep
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

FamilyItemFactory Class
NewSweep Overload
Autodesk.Revit.Creation Namespace


FamilyItemFactory.NewSweptBlend Method

FamilyItemFactoryNewSweptBlend Method

Adds a new swept blend into the family document.
Overload List
 | Name | Description
Public method | NewSweptBlend(Boolean, Reference, SweepProfile, SweepProfile) | Adds a new swept blend into the family document, using a selected reference as the path.
 | NewSweptBlend(Boolean, Curve, SketchPlane, SweepProfile, SweepProfile) | Add a new swept blend into the family document, using a curve as the path.
Top
See Also

Reference

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


FamilyItemFactory.NewSweptBlend(Boolean, Reference, SweepProfile, SweepProfile) Method

FamilyItemFactoryNewSweptBlend(Boolean, Reference, SweepProfile, SweepProfile) Method

Adds a new swept blend into the family document, using a selected reference as the path.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SweptBlend NewSweptBlend(
    bool isSolid,
    Reference path,
    SweepProfile bottomProfile,
    SweepProfile topProfile
)
Public Function NewSweptBlend (
    isSolid As Boolean,
    path As Reference,
    bottomProfile As SweepProfile,
    topProfile As SweepProfile
) As SweptBlend
public:
SweptBlend^ NewSweptBlend(
    bool isSolid,
    Reference^ path,
    SweepProfile^ bottomProfile,
    SweepProfile^ topProfile
)
member NewSweptBlend :
        isSolid : bool *
        path : Reference *
        bottomProfile : SweepProfile *
        topProfile : SweepProfile -> SweptBlend

Parameters

isSolid Boolean
Indicates if the swept blend is Solid or Void.
path Reference
The path of the swept blend. The path might be a reference of single curve or edge obtained from existing geometry. Or the path can be a single sketched curve, and the curve is not required to reference existing geometry.
bottomProfile SweepProfile
The bottom profile of the newly created Swept blend. It should consist of only one curve loop. the input profile must be in one plane.
topProfile SweepProfile
The top profile of the newly created Swept blend. It should consist of only one curve loop. The profile must lie in the XY plane, and it will be transformed to the profile plane automatically.

Return Value

SweptBlend
If creation was successful the new Swept blend is returned, otherwise an exception with failure information will be thrown.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input arguments-path/bottomProfile/topProfile-are .
ArgumentException | Thrown when the input argument-bottomProfile/topProfile-is a curve based profile and the profile is .
ArgumentException | Thrown when the input argument-bottomProfile/topProfile-is a curve based profile and the profile contains or more than one curve loops.
ArgumentException | Thrown when the input argument-bottomProfile/topProfile-is a family symbol based profile and the family symbol profile is .
InvalidOperationException | Thrown when the creation failed.
Remarks
This method creates a swept blend in a family document. The swept blend will trace from bottom profile to the top along the path. Revit will determine an appropriate default mapping for the vertices of the two profiles. If the input profile is to be a cyclic profile (curve or ellipse) it must be split into at least two segments, so that Revit can find vertices to use for mapping the swept blend.
See Also

Reference

FamilyItemFactory Class
NewSweptBlend Overload
Autodesk.Revit.Creation Namespace


FamilyItemFactory.NewSweptBlend(Boolean, Curve, SketchPlane, SweepProfile, SweepProfile) Method

FamilyItemFactoryNewSweptBlend(Boolean, Curve, SketchPlane, SweepProfile, SweepProfile) Method

Add a new swept blend into the family document, using a curve as the path.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SweptBlend NewSweptBlend(
    bool isSolid,
    Curve path,
    SketchPlane pathPlane,
    SweepProfile bottomProfile,
    SweepProfile topProfile
)
Public Function NewSweptBlend (
    isSolid As Boolean,
    path As Curve,
    pathPlane As SketchPlane,
    bottomProfile As SweepProfile,
    topProfile As SweepProfile
) As SweptBlend
public:
SweptBlend^ NewSweptBlend(
    bool isSolid,
    Curve^ path,
    SketchPlane^ pathPlane,
    SweepProfile^ bottomProfile,
    SweepProfile^ topProfile
)
member NewSweptBlend :
        isSolid : bool *
        path : Curve *
        pathPlane : SketchPlane *
        bottomProfile : SweepProfile *
        topProfile : SweepProfile -> SweptBlend

Parameters

isSolid Boolean
Indicates if the swept blend is Solid or Void.
path Curve
The path of the swept blend. The path should be a single curve. Or the path can be a single sketched curve, and the curve is not required to reference existing geometry.
pathPlane SketchPlane
The sketch plane for the path. Use this when you want to create a 2D path that resides on an existing planar face. Optional, can be for a path curve obtained from geometry or for 2D paths where the path should not reference an existing edge.
bottomProfile SweepProfile
The bottom profile of the newly created Swept blend. It should consist of only one curve loop. The profile must lie in the XY plane, and it will be transformed to the profile plane automatically.
topProfile SweepProfile
The top profile of the newly created Swept blend. It should consist of only one curve loop. The profile must lie in the XY plane, and it will be transformed to the profile plane automatically.

Return Value

SweptBlend
If creation was successful the new Swept blend is returned, otherwise an exception with failure information will be thrown.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input arguments-path/bottomProfile/topProfile-are .
ArgumentException | Thrown when the input argument-bottomProfile/topProfile-is a curve based profile and the profile is .
ArgumentException | Thrown when the input argument-bottomProfile/topProfile-is a curve based profile and the profile contains or more than one curve loops.
ArgumentException | Thrown when the input argument-bottomProfile/topProfile-is a family symbol based profile and the family symbol profile is .
InvalidOperationException | Thrown when creation is attempted in Conceptual Mass, 2D, or other family where swept blends cannot be created.
InvalidOperationException | Thrown when the creation failed.
Remarks
This method creates a swept blend in a family document. The swept blend will trace from bottom profile to the top along the path. Revit will determine an appropriate default mapping for the vertices of the two profiles. If the input profile is to be a cyclic profile (curve or ellipse) it must be split into at least two segments, so that Revit can find vertices to use for mapping the swept blend.
Example
C#
VB
C++
F#
Copy
private SweptBlend CreateSweptBlend(Autodesk.Revit.DB.Document document, SketchPlane sketchPlane)
{
    SweptBlend newSweptBlend = null;

    // make sure we have a family document
    if (true == document.IsFamilyDocument)
    {
        // Create top and bottom profiles and path curve
        XYZ pnt1 = new XYZ(0, 0, 0);
        XYZ pnt2 = new XYZ(1, 0, 0);
        XYZ pnt3 = new XYZ(1, 1, 0);
        XYZ pnt4 = new XYZ(0, 1, 0);
        XYZ pnt5 = new XYZ(0, 0, 1);

        CurveArrArray arrarr1 = new CurveArrArray();
        CurveArray arr1 = new CurveArray();
        arr1.Append(Line.CreateBound(pnt1, pnt2));
        arr1.Append(Line.CreateBound(pnt2, pnt3));
        arr1.Append(Line.CreateBound(pnt3, pnt4));
        arr1.Append(Line.CreateBound(pnt4, pnt1));
        arrarr1.Append(arr1);

        XYZ pnt6 = new XYZ(0.5, 0, 0);
        XYZ pnt7 = new XYZ(1, 0.5, 0);
        XYZ pnt8 = new XYZ(0.5, 1, 0);
        XYZ pnt9 = new XYZ(0, 0.5, 0);
        CurveArrArray arrarr2 = new CurveArrArray();
        CurveArray arr2 = new CurveArray();
        arr2.Append(Line.CreateBound(pnt6, pnt7));
        arr2.Append(Line.CreateBound(pnt7, pnt8));
        arr2.Append(Line.CreateBound(pnt8, pnt9));
        arr2.Append(Line.CreateBound(pnt9, pnt6));
        arrarr2.Append(arr2);

        SweepProfile bottomProfile = document.Application.Create.NewCurveLoopsProfile(arrarr1);
        SweepProfile topProfile = document.Application.Create.NewCurveLoopsProfile(arrarr2);

        XYZ pnt10 = new XYZ(5, 0, 0);
        XYZ pnt11 = new XYZ(0, 20, 0);
        Curve curve = Line.CreateBound(pnt10, pnt11);

        // here create rectangular swept blend
        newSweptBlend = document.FamilyCreate.NewSweptBlend(true, curve, sketchPlane, bottomProfile, topProfile);
        if (null != newSweptBlend)
        {
            // move to proper place
            XYZ transPoint1 = new XYZ(11, 32, 0);
            ElementTransformUtils.MoveElement(document, newSweptBlend.Id, transPoint1);
        }
        else
        {
            throw new Exception("Failed to create new SweptBlend.");
        }
    }
    else
    {
        throw new Exception("Please open a Family document before invoking this command.");
    }
    return newSweptBlend;
}
Private Function CreateSweptBlend(document As Autodesk.Revit.DB.Document, sketchPlane As SketchPlane) As SweptBlend
    Dim newSweptBlend As SweptBlend = Nothing

    ' make sure we have a family document
    If True = document.IsFamilyDocument Then
        ' Create top and bottom profiles and path curve
        Dim pnt1 As New XYZ(0, 0, 0)
        Dim pnt2 As New XYZ(1, 0, 0)
        Dim pnt3 As New XYZ(1, 1, 0)
        Dim pnt4 As New XYZ(0, 1, 0)
        Dim pnt5 As New XYZ(0, 0, 1)

        Dim arrarr1 As New CurveArrArray()
        Dim arr1 As New CurveArray()
        arr1.Append(Line.CreateBound(pnt1, pnt2))
        arr1.Append(Line.CreateBound(pnt2, pnt3))
        arr1.Append(Line.CreateBound(pnt3, pnt4))
        arr1.Append(Line.CreateBound(pnt4, pnt1))
        arrarr1.Append(arr1)

        Dim pnt6 As New XYZ(0.5, 0, 0)
        Dim pnt7 As New XYZ(1, 0.5, 0)
        Dim pnt8 As New XYZ(0.5, 1, 0)
        Dim pnt9 As New XYZ(0, 0.5, 0)
        Dim arrarr2 As New CurveArrArray()
        Dim arr2 As New CurveArray()
        arr2.Append(Line.CreateBound(pnt6, pnt7))
        arr2.Append(Line.CreateBound(pnt7, pnt8))
        arr2.Append(Line.CreateBound(pnt8, pnt9))
        arr2.Append(Line.CreateBound(pnt9, pnt6))
        arrarr2.Append(arr2)

        Dim bottomProfile As SweepProfile = document.Application.Create.NewCurveLoopsProfile(arrarr1)
        Dim topProfile As SweepProfile = document.Application.Create.NewCurveLoopsProfile(arrarr2)

        Dim pnt10 As New XYZ(5, 0, 0)
        Dim pnt11 As New XYZ(0, 20, 0)
        Dim curve As Curve = Line.CreateBound(pnt10, pnt11)

        ' here create rectangular swept blend
        newSweptBlend = document.FamilyCreate.NewSweptBlend(True, curve, sketchPlane, bottomProfile, topProfile)
        If newSweptBlend IsNot Nothing Then
            ' move to proper place
            Dim transPoint1 As New XYZ(11, 32, 0)
            ElementTransformUtils.MoveElement(document, newSweptBlend.Id, transPoint1)
        Else
            Throw New Exception("Failed to create new SweptBlend.")
        End If
    Else
        Throw New Exception("Please open a Family document before invoking this command.")
    End If
    Return newSweptBlend
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

FamilyItemFactory Class
NewSweptBlend Overload
Autodesk.Revit.Creation Namespace


FamilyItemFactory.NewSweptBlendForm Method

FamilyItemFactoryNewSweptBlendForm Method

Create new Form element by swept blend operation, and add it into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Form NewSweptBlendForm(
    bool isSolid,
    ReferenceArray path,
    ReferenceArrayArray profiles
)
Public Function NewSweptBlendForm (
    isSolid As Boolean,
    path As ReferenceArray,
    profiles As ReferenceArrayArray
) As Form
public:
Form^ NewSweptBlendForm(
    bool isSolid,
    ReferenceArray^ path,
    ReferenceArrayArray^ profiles
)
member NewSweptBlendForm :
        isSolid : bool *
        path : ReferenceArray *
        profiles : ReferenceArrayArray -> Form

Parameters

isSolid Boolean
Indicates if the Form is Solid or Void.
path ReferenceArray
The path of the swept blend. The path should be 2D, where all input curves lie in one plane. If there's more than one profile, the path should be a single curve. It's required to reference existing geometry.
profiles ReferenceArrayArray
The profile set of the newly created swept blend. Each profile should consist of only one curve loop. Each profile must be in a plane that intersects with the path and is perpendicular to the path at the point of intersection.

Return Value

Form
If creation was successful new form is returned.
See Also

Reference

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


FamilyItemFactory.NewSymbolicCurve Method

FamilyItemFactoryNewSymbolicCurve Method

Create a symbolic curve in an Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SymbolicCurve NewSymbolicCurve(
    Curve curve,
    SketchPlane sketchPlane
)
Public Function NewSymbolicCurve (
    curve As Curve,
    sketchPlane As SketchPlane
) As SymbolicCurve
public:
SymbolicCurve^ NewSymbolicCurve(
    Curve^ curve,
    SketchPlane^ sketchPlane
)
member NewSymbolicCurve :
        curve : Curve *
        sketchPlane : SketchPlane -> SymbolicCurve

Parameters

curve Curve
The geometry curve of the newly created symbolic curve.
sketchPlane SketchPlane
The sketch plane for the symbolic curve.

Return Value

SymbolicCurve
The newly created symbolic curve.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when argument is .
InvalidOperationException | Thrown when regeneration failed. Thrown when symbolic curve creation failed.
See Also

Reference

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


ItemFactoryBase Class

The ItemFactoryBase object is used to create new instances of elements within the Autodesk Revit document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.CreationItemFactoryBase
Autodesk.Revit.CreationDocument
Autodesk.Revit.CreationFamilyItemFactory

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ItemFactoryBase : APIObject
Public Class ItemFactoryBase
    Inherits APIObject
public ref class ItemFactoryBase : public APIObject
type ItemFactoryBase =
    class
        inherit APIObject
    end

The ItemFactoryBase type exposes the following members.

Properties
Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | NewAlignment | Add a new locked alignment into the Autodesk Revit document.
Public method | NewDetailCurve | Creates a new detail curve element.
Public method | NewDetailCurveArray | Creates an array of new detail curve elements.
 | NewDimension(View, Line, ReferenceArray) | Creates a new linear dimension object using the default dimension style.
Public method | NewDimension(View, Line, ReferenceArray, DimensionType) | Creates a new linear dimension object using the specified dimension style.
 | NewFamilyInstance(Face, Line, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a line on that face for its position, and a type/symbol.
 | NewFamilyInstance(Line, FamilySymbol, View) | Add a line based detail family instance into the Autodesk Revit document, using an line and a view where the instance should be placed.
 | NewFamilyInstance(Reference, Line, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a line on that face for its position, and a type/symbol.
Public method | NewFamilyInstance(XYZ, FamilySymbol, StructuralType) | Inserts a new instance of a family into the document, using a location and a type/symbol.
Public method | NewFamilyInstance(XYZ, FamilySymbol, View) | Add a new family instance into the Autodesk Revit document, using an origin and a view where the instance should be placed.
 | NewFamilyInstance(Face, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol.
 | NewFamilyInstance(Reference, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a location, reference direction, and a type/symbol.
 | NewFamilyInstance(XYZ, FamilySymbol, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the host element.
Public method | NewFamilyInstance(XYZ, FamilySymbol, Level, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the level.
 | NewFamilyInstance(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a reference direction.
 | NewFamilyInstances2 | Creates Family instances within the document.
 | NewGroup | Creates a new type of group.
 | NewModelCurve | Creates a new model line element.
Public method | NewModelCurveArray | Creates an array of new model line elements.
 | NewReferencePlane | Creates a new instance of ReferencePlane.
 | NewReferencePlane2 | Creates a new instance of ReferencePlane.
Public method | PlaceGroup | Place an instance of a Model Group into the Autodesk Revit document, using a location and a group type.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The ItemFactoryBase object is a utility object that is used to create new instances of elements within the Autodesk Revit document. This class holds common methods used in both project documents and family documents.
See Also

Reference

Autodesk.Revit.Creation Namespace


ItemFactoryBase Properties

The ItemFactoryBase type exposes the following members.

Properties
Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


ItemFactoryBase Methods

The ItemFactoryBase type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | NewAlignment | Add a new locked alignment into the Autodesk Revit document.
Public method | NewDetailCurve | Creates a new detail curve element.
Public method | NewDetailCurveArray | Creates an array of new detail curve elements.
 | NewDimension(View, Line, ReferenceArray) | Creates a new linear dimension object using the default dimension style.
Public method | NewDimension(View, Line, ReferenceArray, DimensionType) | Creates a new linear dimension object using the specified dimension style.
 | NewFamilyInstance(Face, Line, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a line on that face for its position, and a type/symbol.
 | NewFamilyInstance(Line, FamilySymbol, View) | Add a line based detail family instance into the Autodesk Revit document, using an line and a view where the instance should be placed.
 | NewFamilyInstance(Reference, Line, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a line on that face for its position, and a type/symbol.
Public method | NewFamilyInstance(XYZ, FamilySymbol, StructuralType) | Inserts a new instance of a family into the document, using a location and a type/symbol.
Public method | NewFamilyInstance(XYZ, FamilySymbol, View) | Add a new family instance into the Autodesk Revit document, using an origin and a view where the instance should be placed.
 | NewFamilyInstance(Face, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol.
 | NewFamilyInstance(Reference, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a location, reference direction, and a type/symbol.
 | NewFamilyInstance(XYZ, FamilySymbol, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the host element.
Public method | NewFamilyInstance(XYZ, FamilySymbol, Level, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the level.
 | NewFamilyInstance(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a reference direction.
 | NewFamilyInstances2 | Creates Family instances within the document.
 | NewGroup | Creates a new type of group.
 | NewModelCurve | Creates a new model line element.
Public method | NewModelCurveArray | Creates an array of new model line elements.
 | NewReferencePlane | Creates a new instance of ReferencePlane.
 | NewReferencePlane2 | Creates a new instance of ReferencePlane.
Public method | PlaceGroup | Place an instance of a Model Group into the Autodesk Revit document, using a location and a group type.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


ItemFactoryBase.NewAlignment Method

ItemFactoryBaseNewAlignment Method

Add a new locked alignment into the Autodesk Revit document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Dimension NewAlignment(
    View view,
    Reference reference1,
    Reference reference2
)
Public Function NewAlignment (
    view As View,
    reference1 As Reference,
    reference2 As Reference
) As Dimension
public:
Dimension^ NewAlignment(
    View^ view,
    Reference^ reference1,
    Reference^ reference2
)
member NewAlignment :
        view : View *
        reference1 : Reference *
        reference2 : Reference -> Dimension

Parameters

view View
The view that determines the orientation of the alignment.
reference1 Reference
The first reference.
reference2 Reference
The second reference.

Return Value

Dimension
If creation was successful the new locked alignment dimension is returned, otherwise an exception with failure information will be thrown.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument-"view" or "headerReference" or "otherReference"-is .
ArgumentException | Thrown when the input argument-"headerReference" or "otherReference"-is invalid.
Remarks
These two references must be one of the following combinations:
  • 2 planar faces
  • planar face and reference plane
  • 2 lines
  • line and point
  • line and reference plane
  • 2 arcs
  • 2 cylindrical faces
These references must be already geometrically aligned (this function will not force them to become aligned).
See Also

Reference

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


ItemFactoryBase.NewDetailCurve Method

ItemFactoryBaseNewDetailCurve Method

Creates a new detail curve element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DetailCurve NewDetailCurve(
    View view,
    Curve geometryCurve
)
Public Function NewDetailCurve (
    view As View,
    geometryCurve As Curve
) As DetailCurve
public:
DetailCurve^ NewDetailCurve(
    View^ view,
    Curve^ geometryCurve
)
member NewDetailCurve :
        view : View *
        geometryCurve : Curve -> DetailCurve

Parameters

view View
The view in which the detail curve is to be visible.
geometryCurve Curve
The internal geometry curve for detail curve. It should be a bound curve.

Return Value

DetailCurve
If successful a new detail curve element. Otherwise .
Exceptions
Exception | Condition
ArgumentException | Thrown when curve is not in plane of the view
Remarks
Different type of detail curve element will be returned according to the type of geometry curve.
See Also

Reference

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


ItemFactoryBase.NewDetailCurveArray Method

ItemFactoryBaseNewDetailCurveArray Method

Creates an array of new detail curve elements.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DetailCurveArray NewDetailCurveArray(
    View view,
    CurveArray geometryCurveArray
)
Public Function NewDetailCurveArray (
    view As View,
    geometryCurveArray As CurveArray
) As DetailCurveArray
public:
DetailCurveArray^ NewDetailCurveArray(
    View^ view,
    CurveArray^ geometryCurveArray
)
member NewDetailCurveArray :
        view : View *
        geometryCurveArray : CurveArray -> DetailCurveArray

Parameters

view View
The view in which the detail curves are to be visible.
geometryCurveArray CurveArray
An array containing the internal geometry curves for detail lines. The curve in array should be bound curve.

Return Value

DetailCurveArray
If successful an array of new detail curve elements. Otherwise .
Exceptions
Exception | Condition
ArgumentException | Thrown when curve is not in plane of the view
See Also

Reference

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


ItemFactoryBase.NewDimension Method

ItemFactoryBaseNewDimension Method

Creates a new linear dimension object.
Overload List
 | Name | Description
 | NewDimension(View, Line, ReferenceArray) | Creates a new linear dimension object using the default dimension style.
Public method | NewDimension(View, Line, ReferenceArray, DimensionType) | Creates a new linear dimension object using the specified dimension style.
Top
See Also

Reference

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


ItemFactoryBase.NewDimension(View, Line, ReferenceArray) Method

ItemFactoryBaseNewDimension(View, Line, ReferenceArray) Method

Creates a new linear dimension object using the default dimension style.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Dimension NewDimension(
    View view,
    Line line,
    ReferenceArray references
)
Public Function NewDimension (
    view As View,
    line As Line,
    references As ReferenceArray
) As Dimension
public:
Dimension^ NewDimension(
    View^ view,
    Line^ line,
    ReferenceArray^ references
)
member NewDimension :
        view : View *
        line : Line *
        references : ReferenceArray -> Dimension

Parameters

view View
The view in which the dimension is to be visible. The view must be if the document is in [!:Autodesk::Revit::DB::SketchEditScope].
line Line
The line drawn for the dimension.
references ReferenceArray
An array of geometric references to which the dimension is to be bound.

Return Value

Dimension
If successful a new dimension object, otherwise .
Exceptions
Exception | Condition
ArgumentException | Thrown when references are not geometric references.
Remarks
The currently user set default style is used for the created dimension.
Example
C#
VB
C++
F#
Copy
Dimension CreateNewDimensionAlongLine(Autodesk.Revit.DB.Document document, Line line)
{
    // Use the Start and End points of our line as the references
    // Line must come from something in Revit, such as a beam
    ReferenceArray references = new ReferenceArray();
    references.Append(line.GetEndPointReference(0));
    references.Append(line.GetEndPointReference(1));

    // create the new dimension
    Dimension dimension = document.Create.NewDimension(document.ActiveView,
                                                        line, references);
    return dimension;
}
Private Function CreateNewDimensionAlongLine(document As Autodesk.Revit.DB.Document, line As Line) As Dimension
    ' Use the Start and End points of our line as the references
    ' Line must come from something in Revit, such as a beam
    Dim references As New ReferenceArray()
    references.Append(line.GetEndPointReference(0))
    references.Append(line.GetEndPointReference(1))

    ' create the new dimension
    Dim dimension As Dimension = document.Create.NewDimension(document.ActiveView, line, references)
    Return dimension
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

ItemFactoryBase Class
NewDimension Overload
Autodesk.Revit.Creation Namespace


ItemFactoryBase.NewDimension(View, Line, ReferenceArray, DimensionType) Method

ItemFactoryBaseNewDimension(View, Line, ReferenceArray, DimensionType) Method

Creates a new linear dimension object using the specified dimension style.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Dimension NewDimension(
    View view,
    Line line,
    ReferenceArray references,
    DimensionType dimensionType
)
Public Function NewDimension (
    view As View,
    line As Line,
    references As ReferenceArray,
    dimensionType As DimensionType
) As Dimension
public:
Dimension^ NewDimension(
    View^ view,
    Line^ line,
    ReferenceArray^ references,
    DimensionType^ dimensionType
)
member NewDimension :
        view : View *
        line : Line *
        references : ReferenceArray *
        dimensionType : DimensionType -> Dimension

Parameters

view View
The view in which the dimension is to be visible. The view must be if the document is in [!:Autodesk::Revit::DB::SketchEditScope].
line Line
The line drawn for the dimension.
references ReferenceArray
An array of geometric references to which the dimension is to be bound.
dimensionType DimensionType
The dimension style to be used for the dimension.

Return Value

Dimension
If successful a new dimension object, otherwise .
Exceptions
Exception | Condition
ArgumentException | Thrown when references are not geometric references.
See Also

Reference

ItemFactoryBase Class
NewDimension Overload
Autodesk.Revit.Creation Namespace


ItemFactoryBase.NewFamilyInstance Method

ItemFactoryBaseNewFamilyInstance Method

Inserts a new instance of a family into the document.
Overload List
 | Name | Description
 | NewFamilyInstance(Face, Line, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a line on that face for its position, and a type/symbol.
 | NewFamilyInstance(Line, FamilySymbol, View) | Add a line based detail family instance into the Autodesk Revit document, using an line and a view where the instance should be placed.
 | NewFamilyInstance(Reference, Line, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a line on that face for its position, and a type/symbol.
Public method | NewFamilyInstance(XYZ, FamilySymbol, StructuralType) | Inserts a new instance of a family into the document, using a location and a type/symbol.
Public method | NewFamilyInstance(XYZ, FamilySymbol, View) | Add a new family instance into the Autodesk Revit document, using an origin and a view where the instance should be placed.
 | NewFamilyInstance(Face, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol.
 | NewFamilyInstance(Reference, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a location, reference direction, and a type/symbol.
 | NewFamilyInstance(XYZ, FamilySymbol, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the host element.
Public method | NewFamilyInstance(XYZ, FamilySymbol, Level, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the level.
 | NewFamilyInstance(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a reference direction.
Top
See Also

Reference

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


ItemFactoryBase.NewFamilyInstance(Face, Line, FamilySymbol) Method

ItemFactoryBaseNewFamilyInstance(Face, Line, FamilySymbol) Method

Inserts a new instance of a family onto a face of an existing element, using a line on that face for its position, and a type/symbol.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyInstance NewFamilyInstance(
    Face face,
    Line position,
    FamilySymbol symbol
)
Public Function NewFamilyInstance (
    face As Face,
    position As Line,
    symbol As FamilySymbol
) As FamilyInstance
public:
FamilyInstance^ NewFamilyInstance(
    Face^ face,
    Line^ position,
    FamilySymbol^ symbol
)
member NewFamilyInstance :
        face : Face *
        position : Line *
        symbol : FamilySymbol -> FamilyInstance

Parameters

face Face
A face of a geometry object.
position Line
A line on the face defining where the symbol is to be placed.
symbol FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted. Note that this symbol must represent a family whose FamilyPlacementType is WorkPlaneBased or CurveBased.

Return Value

FamilyInstance
An instance of the new object if creation was successful, otherwise .
Exceptions
Exception | Condition
ArgumentNullException | Thrown when a non-optional argument was null.
ArgumentException | Thrown when the function cannot get the Reference from the face, or, Family cannot be placed as line-based on an input face reference, because its FamilyPlacementType is not WorkPlaneBased or CurveBased
ArgumentsInconsistentException | Thrown when the family cannot be placed on this line as it does not coincide with the input face.
InvalidOperationException | Thrown when Revit is unable to place the family instance.
ArgumentException | Thrown if The symbol is not active.
Remarks
Use this method to insert one family instance on a face of another element, using a line on the face to define the position and direction of the new symbol.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

The host object must support insertion of instances, otherwise this method will fail. If the instance fails to be created an exception may be thrown.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call.

Example
C#
VB
C++
F#
Copy
public void PlaceStiffenerOnWallFace(Autodesk.Revit.DB.Document doc, Wall wall)
{
    // The structural stiffeners family type is compatible with line-based face placement
    FilteredElementCollector fsCollector = new FilteredElementCollector(doc);
    fsCollector.OfClass(typeof(FamilySymbol)).OfCategory(BuiltInCategory.OST_StructuralStiffener);
    FamilySymbol stiffenerSymbol = fsCollector.FirstElement() as FamilySymbol;

    // The only way to get a Face to use with this NewFamilyInstance overload
    // is from Element.Geometry with ComputeReferences turned on
    Face face = null;
    Options geomOptions = new Options();
    geomOptions.ComputeReferences = true;
    GeometryElement wallGeom = wall.get_Geometry(geomOptions);
    foreach (GeometryObject geomObj in wallGeom)
    {
        Solid geomSolid = geomObj as Solid;
        if (null != geomSolid)
        {
            foreach (Face geomFace in geomSolid.Faces)
            {
                face = geomFace;
                break;
            }
            break;
        }
    }

    // Generate line for path
    BoundingBoxUV bbox = face.GetBoundingBox();
    UV lowerLeft = bbox.Min;
    UV upperRight = bbox.Max;
    double deltaU = upperRight.U - lowerLeft.U;
    double deltaV = upperRight.V - lowerLeft.V;
    double vOffset = deltaV * 0.80; // 80% up the wall face

    UV firstPoint = lowerLeft + new UV(deltaU * 0.30, vOffset);
    UV lastPoint = lowerLeft + new UV(deltaU * 0.70, vOffset);

    Line line = Line.CreateBound(face.Evaluate(firstPoint), face.Evaluate(lastPoint));

    doc.Create.NewFamilyInstance(face, line, stiffenerSymbol);
}
Public Sub PlaceStiffenerOnWallFace(doc As Autodesk.Revit.DB.Document, wall As Wall)
    ' The structural stiffeners family type is compatible with line-based face placement
    Dim fsCollector As New FilteredElementCollector(doc)
    fsCollector.OfClass(GetType(FamilySymbol)).OfCategory(BuiltInCategory.OST_StructuralStiffener)
    Dim stiffenerSymbol As FamilySymbol = TryCast(fsCollector.FirstElement(), FamilySymbol)

    ' The only way to get a Face to use with this NewFamilyInstance overload
    ' is from Element.Geometry with ComputeReferences turned on
    Dim face As Face = Nothing
    Dim geomOptions As New Options()
    geomOptions.ComputeReferences = True
    Dim wallGeom As GeometryElement = wall.Geometry(geomOptions)
    For Each geomObj As GeometryObject In wallGeom
        Dim geomSolid As Solid = TryCast(geomObj, Solid)
        If geomSolid IsNot Nothing Then
            For Each geomFace As Face In geomSolid.Faces
                face = geomFace
                Exit For
            Next
            Exit For
        End If
    Next

    ' Generate line for path
    Dim bbox As BoundingBoxUV = face.GetBoundingBox()
    Dim lowerLeft As UV = bbox.Min
    Dim upperRight As UV = bbox.Max
    Dim deltaU As Double = upperRight.U - lowerLeft.U
    Dim deltaV As Double = upperRight.V - lowerLeft.V
    Dim vOffset As Double = deltaV * 0.8
    ' 80% up the wall face
    Dim firstPoint As UV = lowerLeft + New UV(deltaU * 0.3, vOffset)
    Dim lastPoint As UV = lowerLeft + New UV(deltaU * 0.7, vOffset)

    Dim line__1 As Line = Line.CreateBound(face.Evaluate(firstPoint), face.Evaluate(lastPoint))

    doc.Create.NewFamilyInstance(face, line__1, stiffenerSymbol)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


ItemFactoryBase.NewFamilyInstance(Line, FamilySymbol, View) Method

ItemFactoryBaseNewFamilyInstance(Line, FamilySymbol, View) Method

Add a line based detail family instance into the Autodesk Revit document, using an line and a view where the instance should be placed.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyInstance NewFamilyInstance(
    Line line,
    FamilySymbol symbol,
    View specView
)
Public Function NewFamilyInstance (
    line As Line,
    symbol As FamilySymbol,
    specView As View
) As FamilyInstance
public:
FamilyInstance^ NewFamilyInstance(
    Line^ line,
    FamilySymbol^ symbol,
    View^ specView
)
member NewFamilyInstance :
        line : Line *
        symbol : FamilySymbol *
        specView : View -> FamilyInstance

Parameters

line Line
The line location of family instance. The line must in the plane of the view.
symbol FamilySymbol
A family symbol object that represents the type of the instance that is to be inserted.
specView View
A 2D view in which to display the family instance.

Return Value

FamilyInstance
Exceptions
Exception | Condition
ArgumentNullException | Thrown when input argument line or symbol or specView is .
ArgumentException | Thrown when input argument line or symbol or specView is invalid, or cannot make such type in the specView, or the line is not in the plane of specView.
InvalidOperationException | Thrown when failed to create the instance.
InvalidOperationException | Thrown when attempting to place a model-based family. Only 2D detail families can be placed in views.
ArgumentException | Thrown if The symbol is not active.
Remarks
This overload applies only to 2D family line based detail symbols. The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.
Example
C#
VB
C++
F#
Copy
void CreateDetailComponent(Autodesk.Revit.DB.Document document, View view)
{
    // Create a detail component in the given view if it is a detail or drafting view
    if (view.ViewType == ViewType.Detail ||
        view.ViewType == ViewType.DraftingView)
    {
        FamilySymbol symbol = null;
        FilteredElementCollector fsCollector = new FilteredElementCollector(document);
        fsCollector.OfClass(typeof(FamilySymbol)).OfCategory(BuiltInCategory.OST_DetailComponents);
        ICollection<Element> collection = fsCollector.ToElements();
        foreach (Element element in collection)
        {
            FamilySymbol current = element as FamilySymbol;
            // This NewFamilyInstance overload requires a curve based family
            if (current.Family.FamilyPlacementType == FamilyPlacementType.CurveBasedDetail)
            {
                symbol = current;
                break;
            }
        }

        if (symbol != null)
        {
            // create a 2' detail component at the view's origin
            XYZ start = view.Origin;
            XYZ end = start + new XYZ(2, 0, 0);

            Line line = Line.CreateBound(start, end);

            FamilyInstance instance = document.Create.NewFamilyInstance(line, symbol, view);
        }
    }
}
Private Sub CreateDetailComponent(document As Autodesk.Revit.DB.Document, view As View)
    ' Create a detail component in the given view if it is a detail or drafting view
    If view.ViewType = ViewType.Detail OrElse view.ViewType = ViewType.DraftingView Then
        Dim symbol As FamilySymbol = Nothing
        Dim fsCollector As New FilteredElementCollector(document)
        fsCollector.OfClass(GetType(FamilySymbol)).OfCategory(BuiltInCategory.OST_DetailComponents)
        Dim collection As ICollection(Of Element) = fsCollector.ToElements()
        For Each element As Element In collection
            Dim current As FamilySymbol = TryCast(element, FamilySymbol)
            ' This NewFamilyInstance overload requires a curve based family
            If current.Family.FamilyPlacementType = FamilyPlacementType.CurveBasedDetail Then
                symbol = current
                Exit For
            End If
        Next

        If symbol IsNot Nothing Then
            ' create a 2' detail component at the view's origin
            Dim start As XYZ = view.Origin
            Dim [end] As XYZ = start + New XYZ(2, 0, 0)

            Dim line__1 As Line = Line.CreateBound(start, [end])

            Dim instance As FamilyInstance = document.Create.NewFamilyInstance(line__1, symbol, view)
        End If
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


ItemFactoryBase.NewFamilyInstance(Reference, Line, FamilySymbol) Method

ItemFactoryBaseNewFamilyInstance(Reference, Line, FamilySymbol) Method

Inserts a new instance of a family onto a face referenced by the input Reference instance, using a line on that face for its position, and a type/symbol.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyInstance NewFamilyInstance(
    Reference reference,
    Line position,
    FamilySymbol symbol
)
Public Function NewFamilyInstance (
    reference As Reference,
    position As Line,
    symbol As FamilySymbol
) As FamilyInstance
public:
FamilyInstance^ NewFamilyInstance(
    Reference^ reference,
    Line^ position,
    FamilySymbol^ symbol
)
member NewFamilyInstance :
        reference : Reference *
        position : Line *
        symbol : FamilySymbol -> FamilyInstance

Parameters

reference Reference
A reference to a face.
position Line
A line on the face defining where the symbol is to be placed.
symbol FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted. Note that this symbol must represent a family whose FamilyPlacementType is WorkPlaneBased or CurveBased.

Return Value

FamilyInstance
An instance of the new object if creation was successful, otherwise .
Exceptions
Exception | Condition
ArgumentNullException | Thrown when a non-optional argument was null.
ArgumentException | Thrown when the function cannot get a face from the reference, or, when the family cannot be placed as line-based on an input face reference, because its FamilyPlacementType is not WorkPlaneBased or CurveBased
ArgumentsInconsistentException | Thrown when the family cannot be placed on this line as it does not coincide with the input face.
InvalidOperationException | Thrown when Revit is unable to place the family instance.
ArgumentException | Thrown if The symbol is not active.
Remarks
Use this method to insert one family instance on a face of another element, using a line on the face to define the position and direction of the new symbol.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

The host object must support insertion of instances, otherwise this method will fail. If the instance fails to be created an exception may be thrown.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call.

Example
C#
VB
C++
F#
Copy
public void PlaceStiffenerOnWallFaceRef(Autodesk.Revit.DB.Document doc)
{
    FilteredElementCollector wallCollector = new FilteredElementCollector(doc);
    wallCollector.OfClass(typeof(Wall));
    Wall wall = wallCollector.FirstElement() as Wall;

    // The structural stiffeners family type is compatible with line-based face placement
    FilteredElementCollector fsCollector = new FilteredElementCollector(doc);
    fsCollector.OfClass(typeof(FamilySymbol)).OfCategory(BuiltInCategory.OST_StructuralStiffener);
    FamilySymbol stiffenerSymbol = fsCollector.FirstElement() as FamilySymbol;

    // Get side face of wall
    IList<Reference> sideFaces = HostObjectUtils.GetSideFaces(wall, ShellLayerType.Exterior);
    Reference sideFaceRef = sideFaces[0];

    // Generate line for path
    Face face = wall.GetGeometryObjectFromReference(sideFaceRef) as Face;
    BoundingBoxUV bbox = face.GetBoundingBox();
    UV lowerLeft = bbox.Min;
    UV upperRight = bbox.Max;
    double deltaU = upperRight.U - lowerLeft.U;
    double deltaV = upperRight.V - lowerLeft.V;
    double vOffset = deltaV * 0.60; // 60% up the wall face

    UV firstPoint = lowerLeft + new UV(deltaU * 0.20, vOffset);
    UV lastPoint = lowerLeft + new UV(deltaU * 0.80, vOffset);

    Line line = Line.CreateBound(face.Evaluate(firstPoint), face.Evaluate(lastPoint));

    doc.Create.NewFamilyInstance(sideFaceRef, line, stiffenerSymbol);
}
Public Sub PlaceStiffenerOnWallFaceRef(doc As Autodesk.Revit.DB.Document)
    Dim wallCollector As New FilteredElementCollector(doc)
    wallCollector.OfClass(GetType(Wall))
    Dim wall As Wall = TryCast(wallCollector.FirstElement(), Wall)

    ' The structural stiffeners family type is compatible with line-based face placement
    Dim fsCollector As New FilteredElementCollector(doc)
    fsCollector.OfClass(GetType(FamilySymbol)).OfCategory(BuiltInCategory.OST_StructuralStiffener)
    Dim stiffenerSymbol As FamilySymbol = TryCast(fsCollector.FirstElement(), FamilySymbol)

    ' Get side face of wall
    Dim sideFaces As IList(Of Reference) = HostObjectUtils.GetSideFaces(wall, ShellLayerType.Exterior)
    Dim sideFaceRef As Reference = sideFaces(0)

    ' Generate line for path
    Dim face As Face = TryCast(wall.GetGeometryObjectFromReference(sideFaceRef), Face)
    Dim bbox As BoundingBoxUV = face.GetBoundingBox()
    Dim lowerLeft As UV = bbox.Min
    Dim upperRight As UV = bbox.Max
    Dim deltaU As Double = upperRight.U - lowerLeft.U
    Dim deltaV As Double = upperRight.V - lowerLeft.V
    Dim vOffset As Double = deltaV * 0.6
    ' 60% up the wall face
    Dim firstPoint As UV = lowerLeft + New UV(deltaU * 0.2, vOffset)
    Dim lastPoint As UV = lowerLeft + New UV(deltaU * 0.8, vOffset)

    Dim line__1 As Line = Line.CreateBound(face.Evaluate(firstPoint), face.Evaluate(lastPoint))

    doc.Create.NewFamilyInstance(sideFaceRef, line__1, stiffenerSymbol)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


ItemFactoryBase.NewFamilyInstance(XYZ, FamilySymbol, StructuralType) Method

ItemFactoryBaseNewFamilyInstance(XYZ, FamilySymbol, StructuralType) Method

Inserts a new instance of a family into the document, using a location and a type/symbol.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyInstance NewFamilyInstance(
    XYZ location,
    FamilySymbol symbol,
    StructuralType structuralType
)
Public Function NewFamilyInstance (
    location As XYZ,
    symbol As FamilySymbol,
    structuralType As StructuralType
) As FamilyInstance
public:
FamilyInstance^ NewFamilyInstance(
    XYZ^ location,
    FamilySymbol^ symbol,
    StructuralType structuralType
)
member NewFamilyInstance :
        location : XYZ *
        symbol : FamilySymbol *
        structuralType : StructuralType -> FamilyInstance

Parameters

location XYZ
The physical location where the instance is to be placed.
symbol FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
structuralType StructuralType
If structural then specify the type of the component.

Return Value

FamilyInstance
A valid instance of the given family if the creation is successful. An exception will be thrown otherwise.
Exceptions
Exception | Condition
ArgumentException | Thrown if the symbol is not active.
InvalidOperationException | Thrown if the family is level-based, for new instances of such families require a valid level to be supplied at the time of creation.
Remarks
Use this method to insert a family instance that does not require a host element or level. For creating instances of level-based families use one of the NewFamilyInstance methods of the Revit.Creation.Document class.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

Some Families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted these linear family instances can have their endpoints changed by using the instance's Element.Location property.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call.

See Also

Reference

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


ItemFactoryBase.NewFamilyInstance(XYZ, FamilySymbol, View) Method

ItemFactoryBaseNewFamilyInstance(XYZ, FamilySymbol, View) Method

Add a new family instance into the Autodesk Revit document, using an origin and a view where the instance should be placed.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyInstance NewFamilyInstance(
    XYZ origin,
    FamilySymbol symbol,
    View specView
)
Public Function NewFamilyInstance (
    origin As XYZ,
    symbol As FamilySymbol,
    specView As View
) As FamilyInstance
public:
FamilyInstance^ NewFamilyInstance(
    XYZ^ origin,
    FamilySymbol^ symbol,
    View^ specView
)
member NewFamilyInstance :
        origin : XYZ *
        symbol : FamilySymbol *
        specView : View -> FamilyInstance

Parameters

origin XYZ
The origin of family instance. If created on a ViewPlan, the origin will be projected onto the ViewPlan.
symbol FamilySymbol
A family symbol object that represents the type of the instance that is to be inserted.
specView View
The 2D view in which to place the family instance.

Return Value

FamilyInstance
If creation was successful then an instance to the new object is returned.
Exceptions
Exception | Condition
ArgumentNullException | One or more required arguments was
ArgumentException | The input family PlacementType was not ViewBased, the input view was not 2D, Thrown if The symbol is not active. or instances of the input FamilySymbol are not permitted on a view of this type.
Remarks
This overload applies only to 2D family symbols (detail components, annotation symbols, titleblocks, etc.). The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.
See Also

Reference

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


ItemFactoryBase.NewFamilyInstance(Face, XYZ, XYZ, FamilySymbol) Method

ItemFactoryBaseNewFamilyInstance(Face, XYZ, XYZ, FamilySymbol) Method

Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyInstance NewFamilyInstance(
    Face face,
    XYZ location,
    XYZ referenceDirection,
    FamilySymbol symbol
)
Public Function NewFamilyInstance (
    face As Face,
    location As XYZ,
    referenceDirection As XYZ,
    symbol As FamilySymbol
) As FamilyInstance
public:
FamilyInstance^ NewFamilyInstance(
    Face^ face,
    XYZ^ location,
    XYZ^ referenceDirection,
    FamilySymbol^ symbol
)
member NewFamilyInstance :
        face : Face *
        location : XYZ *
        referenceDirection : XYZ *
        symbol : FamilySymbol -> FamilyInstance

Parameters

face Face
A face of a geometry object.
location XYZ
Point on the face where the instance is to be placed.
referenceDirection XYZ
A vector that defines the direction of the family instance. Note that this direction defines the rotation of the instance on the face, and thus cannot be parallel to the face normal.
symbol FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted. Note that this symbol must represent a family whose FamilyPlacementType is WorkPlaneBased.

Return Value

FamilyInstance
An instance of the new object if creation was successful, otherwise .
Exceptions
Exception | Condition
ArgumentNullException | Thrown when a non-optional argument was null.
ArgumentException | Thrown when the function cannot get the Reference from the face, or, when the Family cannot be placed as line-based on an input face reference, because its FamilyPlacementType is not WorkPlaneBased
ArgumentsInconsistentException | Thrown when reference direction is parallel to face normal at insertion point.
InvalidOperationException | Thrown when Revit is unable to place the family instance.
ArgumentException | Thrown if The symbol is not active.
Remarks
Use this method to insert one family instance on a face of another element, using a point on the face and a vector to define the position and direction of the new symbol.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

The host object must support insertion of instances, otherwise this method will fail. If the instances fails to be created an exception may be thrown.

Some Families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted, these linear family instances can have their endpoints changed by using the instance's Element.Location property.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call.

Example
C#
VB
C++
F#
Copy
void CreateLightFixtureOnWall(Autodesk.Revit.DB.Document document, Wall wall)
{
    FilteredElementCollector collector = new FilteredElementCollector(document);
    collector.OfClass(typeof(FamilySymbol)).OfCategory(BuiltInCategory.OST_LightingFixtures);
    FamilySymbol symbol = collector.FirstElement() as FamilySymbol;

    // The only way to get a Face to use with this NewFamilyInstance overload
    // is from Element.Geometry with ComputeReferences turned on
    Face face = null;
    Options geomOptions = new Options();
    geomOptions.ComputeReferences = true;
    GeometryElement wallGeom = wall.get_Geometry(geomOptions);
    foreach (GeometryObject geomObj in wallGeom)
    {
        Solid geomSolid = geomObj as Solid;
        if (null != geomSolid)
        {
            foreach (Face geomFace in geomSolid.Faces)
            {
                face = geomFace;
                break;
            }
            break;
        }
    }

    // Get the center of the wall
    BoundingBoxUV bboxUV = face.GetBoundingBox();
    UV center = (bboxUV.Max + bboxUV.Min) / 2.0;
    XYZ location = face.Evaluate(center);
    XYZ normal = face.ComputeNormal(center);
    XYZ refDir = normal.CrossProduct(XYZ.BasisZ);

    FamilyInstance instance = document.Create.NewFamilyInstance(face, location, refDir, symbol);
}
Private Sub CreateLightFixtureOnWall(document As Autodesk.Revit.DB.Document, wall As Wall)
    Dim collector As New FilteredElementCollector(document)
    collector.OfClass(GetType(FamilySymbol)).OfCategory(BuiltInCategory.OST_LightingFixtures)
    Dim symbol As FamilySymbol = TryCast(collector.FirstElement(), FamilySymbol)

    ' The only way to get a Face to use with this NewFamilyInstance overload
    ' is from Element.Geometry with ComputeReferences turned on
    Dim face As Face = Nothing
    Dim geomOptions As New Options()
    geomOptions.ComputeReferences = True
    Dim wallGeom As GeometryElement = wall.Geometry(geomOptions)
    For Each geomObj As GeometryObject In wallGeom
        Dim geomSolid As Solid = TryCast(geomObj, Solid)
        If geomSolid IsNot Nothing Then
            For Each geomFace As Face In geomSolid.Faces
                face = geomFace
                Exit For
            Next
            Exit For
        End If
    Next

    ' Get the center of the wall
    Dim bboxUV As BoundingBoxUV = face.GetBoundingBox()
    Dim center As UV = (bboxUV.Max + bboxUV.Min) / 2.0
    Dim location As XYZ = face.Evaluate(center)
    Dim normal As XYZ = face.ComputeNormal(center)
    Dim refDir As XYZ = normal.CrossProduct(XYZ.BasisZ)

    Dim instance As FamilyInstance = document.Create.NewFamilyInstance(face, location, refDir, symbol)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


ItemFactoryBase.NewFamilyInstance(Reference, XYZ, XYZ, FamilySymbol) Method

ItemFactoryBaseNewFamilyInstance(Reference, XYZ, XYZ, FamilySymbol) Method

Inserts a new instance of a family onto a face referenced by the input Reference instance, using a location, reference direction, and a type/symbol.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyInstance NewFamilyInstance(
    Reference reference,
    XYZ location,
    XYZ referenceDirection,
    FamilySymbol symbol
)
Public Function NewFamilyInstance (
    reference As Reference,
    location As XYZ,
    referenceDirection As XYZ,
    symbol As FamilySymbol
) As FamilyInstance
public:
FamilyInstance^ NewFamilyInstance(
    Reference^ reference,
    XYZ^ location,
    XYZ^ referenceDirection,
    FamilySymbol^ symbol
)
member NewFamilyInstance :
        reference : Reference *
        location : XYZ *
        referenceDirection : XYZ *
        symbol : FamilySymbol -> FamilyInstance

Parameters

reference Reference
A reference to a face.
location XYZ
Point on the face where the instance is to be placed.
referenceDirection XYZ
A vector that defines the direction of the family instance. Note that this direction defines the rotation of the instance on the face, and thus cannot be parallel to the face normal.
symbol FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted. Note that this symbol must represent a family whose FamilyPlacementType is WorkPlaneBased.

Return Value

FamilyInstance
An instance of the new object if creation was successful, otherwise .
Exceptions
Exception | Condition
ArgumentNullException | Thrown when a non-optional argument was null.
ArgumentException | Thrown when the function cannot get the face from the reference, or, when the Family cannot be placed as line-based on an input face reference, because its FamilyPlacementType is not WorkPlaneBased
ArgumentsInconsistentException | Thrown when reference direction is parallel to face normal at insertion point.
InvalidOperationException | Thrown when Revit is unable to place the family instance.
ArgumentException | Thrown if The symbol is not active.
Remarks
Use this method to insert one family instance on a face of another element, using a point on the face and a vector to define the position and direction of the new symbol.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

The host object must support insertion of instances, otherwise this method will fail. If the instances fails to be created an exception may be thrown.

Some Families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted, these linear family instances can have their endpoints changed by using the instance's Element.Location property.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call.

Example
C#
VB
C++
F#
Copy
void CreateNurseCallDomeOnWall(Autodesk.Revit.DB.Document document, Wall wall)
{
    FilteredElementCollector collector = new FilteredElementCollector(document);
    collector.OfClass(typeof(FamilySymbol)).OfCategory(BuiltInCategory.OST_NurseCallDevices);

    FamilySymbol symbol = collector.FirstElement() as FamilySymbol;

    // Get interior face of wall
    IList<Reference> sideFaces = HostObjectUtils.GetSideFaces(wall, ShellLayerType.Interior);
    Reference interiorFaceRef = sideFaces[0];

    XYZ location = new XYZ(4, 2, 8);
    XYZ refDir = new XYZ(0, 0, 1);

    FamilyInstance instance = document.Create.NewFamilyInstance(interiorFaceRef, location, refDir, symbol);
}
Private Sub CreateNurseCallDomeOnWall(document As Autodesk.Revit.DB.Document, wall As Wall)
    Dim collector As New FilteredElementCollector(document)
    collector.OfClass(GetType(FamilySymbol)).OfCategory(BuiltInCategory.OST_NurseCallDevices)

    Dim symbol As FamilySymbol = TryCast(collector.FirstElement(), FamilySymbol)

    ' Get interior face of wall
    Dim sideFaces As IList(Of Reference) = HostObjectUtils.GetSideFaces(wall, ShellLayerType.Interior)
    Dim interiorFaceRef As Reference = sideFaces(0)

    Dim location As New XYZ(4, 2, 8)
    Dim refDir As New XYZ(0, 0, 1)

    Dim instance As FamilyInstance = document.Create.NewFamilyInstance(interiorFaceRef, location, refDir, symbol)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


ItemFactoryBase.NewFamilyInstance(XYZ, FamilySymbol, Element, StructuralType) Method

ItemFactoryBaseNewFamilyInstance(XYZ, FamilySymbol, Element, StructuralType) Method

Inserts a new instance of a family into the document, using a location, type/symbol, and the host element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyInstance NewFamilyInstance(
    XYZ location,
    FamilySymbol symbol,
    Element host,
    StructuralType structuralType
)
Public Function NewFamilyInstance (
    location As XYZ,
    symbol As FamilySymbol,
    host As Element,
    structuralType As StructuralType
) As FamilyInstance
public:
FamilyInstance^ NewFamilyInstance(
    XYZ^ location,
    FamilySymbol^ symbol,
    Element^ host,
    StructuralType structuralType
)
member NewFamilyInstance :
        location : XYZ *
        symbol : FamilySymbol *
        host : Element *
        structuralType : StructuralType -> FamilyInstance

Parameters

location XYZ
The physical location where the instance is to be placed.
symbol FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
host Element
The object into which the FamilyInstance is to be inserted, often known as the host.
structuralType StructuralType
If structural then specify the type of the component.

Return Value

FamilyInstance
If creation was successful then an instance to the new object is returned, otherwise .
Exceptions
Exception | Condition
ArgumentException | Thrown if The symbol is not active.
Remarks
This method is used to insert one family instance into another element, such as inserting a window into a wall. If the instance fails to be created an exception may be thrown.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

The host object must be one that supports insertion of instances otherwise this method will fail.

Some Families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted these linear family instances can have their endpoints changed by using the instance's Element.Location property.

Note: ForbiddenForDynamicUpdateException might be thrown during a dynamic update if the inserted instance establishes a mutual dependency with another structure.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call.

Example
C#
VB
C++
F#
Copy
Wall CreateWallWithWindows(Autodesk.Revit.DB.Document document, Level level)
{
    // Create a new wall
    // Build a location line for the wall creation
    XYZ start = new XYZ(0, 0, 0);
    XYZ end = new XYZ(10, 10, 0);
    Line wallLine = Line.CreateBound(start, end);

    // Create a wall using the location line
    Wall newWall = Wall.Create(document, wallLine, level.Id, true);

    // Find a Window type for the new windows
    FilteredElementCollector winCollector = new FilteredElementCollector(document);
    IList<Element> windowTypes = winCollector.OfCategory(BuiltInCategory.OST_Windows).WhereElementIsElementType().ToElements();
    FamilySymbol winType = windowTypes.First() as FamilySymbol;
    // put 3 windows in the wall
    double x = 2, y = 2, z = 2;
    for (int i = 0; i < 3; i++)
    {
        XYZ location = new XYZ(x, y, z);
        FamilyInstance instance = document.Create.NewFamilyInstance(location, winType, newWall, StructuralType.NonStructural);
        x += 3;
        y += 3;
    }

    return newWall;
}
Private Function CreateWallWithWindows(document As Autodesk.Revit.DB.Document, level As Level) As Wall
    ' Create a new wall
    ' Build a location line for the wall creation
    Dim start As New XYZ(0, 0, 0)
    Dim [end] As New XYZ(10, 10, 0)
    Dim wallLine As Line = Line.CreateBound(start, [end])

    ' Create a wall using the location line
    Dim newWall As Wall = Wall.Create(document, wallLine, level.Id, True)

    ' Find a Window type for the new windows
    Dim winCollector As New FilteredElementCollector(document)
    Dim windowTypes As IList(Of Element) = winCollector.OfCategory(BuiltInCategory.OST_Windows).WhereElementIsElementType().ToElements()
    Dim winType As FamilySymbol = TryCast(windowTypes.First(), FamilySymbol)
    ' put 3 windows in the wall
    Dim x As Double = 2, y As Double = 2, z As Double = 2
    For i As Integer = 0 To 2
        Dim location As New XYZ(x, y, z)
        Dim instance As FamilyInstance = document.Create.NewFamilyInstance(location, winType, newWall, StructuralType.NonStructural)
        x += 3
        y += 3
    Next

    Return newWall
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


ItemFactoryBase.NewFamilyInstance(XYZ, FamilySymbol, Level, StructuralType) Method

ItemFactoryBaseNewFamilyInstance(XYZ, FamilySymbol, Level, StructuralType) Method

Inserts a new instance of a family into the document, using a location, type/symbol, and the level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyInstance NewFamilyInstance(
    XYZ location,
    FamilySymbol symbol,
    Level level,
    StructuralType structuralType
)
Public Function NewFamilyInstance (
    location As XYZ,
    symbol As FamilySymbol,
    level As Level,
    structuralType As StructuralType
) As FamilyInstance
public:
FamilyInstance^ NewFamilyInstance(
    XYZ^ location,
    FamilySymbol^ symbol,
    Level^ level,
    StructuralType structuralType
)
member NewFamilyInstance :
        location : XYZ *
        symbol : FamilySymbol *
        level : Level *
        structuralType : StructuralType -> FamilyInstance

Parameters

location XYZ
The physical location where the instance is to be placed.
symbol FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
level Level
The level onto which the FamilyInstance is to be placed.
structuralType StructuralType
If structural then specify the type of the component.

Return Value

FamilyInstance
If creation was successful then an instance to the new object is returned, otherwise .
Exceptions
Exception | Condition
ArgumentException | Thrown if the family symbol does not exist in the given document.
ArgumentException | Thrown if the level does not exist in the given document.
ArgumentException | Thrown if The symbol is not active.
Remarks
This method is used to place a family instance onto a level. If the instance fails to be created an exception may be thrown.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

Some Families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted these linear family instances can have their endpoints changed by using the instance's Element.Location property.

Note: ForbiddenForDynamicUpdateException might be thrown during a dynamic update if the inserted instance establishes a mutual dependency with another structure.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call.

See Also

Reference

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


ItemFactoryBase.NewFamilyInstance(XYZ, FamilySymbol, XYZ, Element, StructuralType) Method

ItemFactoryBaseNewFamilyInstance(XYZ, FamilySymbol, XYZ, Element, StructuralType) Method

Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a reference direction.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyInstance NewFamilyInstance(
    XYZ location,
    FamilySymbol symbol,
    XYZ referenceDirection,
    Element host,
    StructuralType structuralType
)
Public Function NewFamilyInstance (
    location As XYZ,
    symbol As FamilySymbol,
    referenceDirection As XYZ,
    host As Element,
    structuralType As StructuralType
) As FamilyInstance
public:
FamilyInstance^ NewFamilyInstance(
    XYZ^ location,
    FamilySymbol^ symbol,
    XYZ^ referenceDirection,
    Element^ host,
    StructuralType structuralType
)
member NewFamilyInstance :
        location : XYZ *
        symbol : FamilySymbol *
        referenceDirection : XYZ *
        host : Element *
        structuralType : StructuralType -> FamilyInstance

Parameters

location XYZ
The physical location where the instance is to be placed.
symbol FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
referenceDirection XYZ
A vector that dictates the direction of certain family instances.
host Element
A host object into which the instance will be embedded
structuralType StructuralType
If structural then specify the type of the component.

Return Value

FamilyInstance
If creation was successful then an instance to the new object is returned, otherwise .
Exceptions
Exception | Condition
ArgumentException | Thrown if The symbol is not active.
Remarks
This method allows you to create FamilyInstance objects that require both a location and direction. If the instance fails to be created an exception may be thrown.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

Some Families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted these linear family instances can have their endpoints changed by using the instance's Element.Location property.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call.

Example
C#
VB
C++
F#
Copy
// Get a floor to place the beds
 FilteredElementCollector collector = new FilteredElementCollector(document);
 Floor floor = collector.OfClass(typeof(Floor)).FirstElement() as Floor;
 if (floor != null)
 {
     // Find a Bed-Box family
     Family family = null;
     FilteredElementCollector famCollector = new FilteredElementCollector(document);
     famCollector.OfClass(typeof(Family));
     ICollection<Element> collection = famCollector.ToElements();
     foreach (Element element in collection)
     {

         if (element.Name.CompareTo("Bed-Box") == 0)
         {
             family = element as Family;
             break;
         }
     }

     if (family != null)
     {
         // Enumerate the beds in the Bed-Box family
         FilteredElementCollector fsCollector = new FilteredElementCollector(document);
         ICollection<Element> fsCollection = fsCollector.WherePasses(new FamilySymbolFilter(family.Id)).ToElements();
         IEnumerator<Element> symbolItor = fsCollection.GetEnumerator();

         int x = 0, y = 0;
         int i = 0;
         while (symbolItor.MoveNext())
         {
             FamilySymbol symbol = symbolItor.Current as FamilySymbol;
             XYZ location = new XYZ(x, y, 0);
             XYZ direction = new XYZ();
             switch (i % 3)
             {
                 case 0:
                     direction = new XYZ(1, 1, 0);
                     break;
                 case 1:
                     direction = new XYZ(0, 1, 1);
                     break;
                 case 2:
                     direction = new XYZ(1, 0, 1);
                     break;
             }
             FamilyInstance instance = document.Create.NewFamilyInstance(location, symbol, direction, floor, StructuralType.NonStructural);
             x += 10;
             i++;
         }
     }
 }
' Get a floor to place the beds
Dim collector As New FilteredElementCollector(document)
Dim floor As Floor = TryCast(collector.OfClass(GetType(Floor)).FirstElement(), Floor)
If floor IsNot Nothing Then
    ' Find a Bed-Box family
    Dim family As Family = Nothing
    Dim famCollector As New FilteredElementCollector(document)
    famCollector.OfClass(GetType(Family))
    Dim collection As ICollection(Of Element) = famCollector.ToElements()
    For Each element As Element In collection

        If element.Name.CompareTo("Bed-Box") = 0 Then
            family = TryCast(element, Family)
            Exit For
        End If
    Next

    If family IsNot Nothing Then
        ' Enumerate the beds in the Bed-Box family
        Dim fsCollector As New FilteredElementCollector(document)
        Dim fsCollection As ICollection(Of Element) = fsCollector.WherePasses(New FamilySymbolFilter(family.Id)).ToElements()
        Dim symbolItor As IEnumerator(Of Element) = fsCollection.GetEnumerator()

        Dim x As Integer = 0, y As Integer = 0
        Dim i As Integer = 0
        While symbolItor.MoveNext()
            Dim symbol As FamilySymbol = TryCast(symbolItor.Current, FamilySymbol)
            Dim location As New XYZ(x, y, 0)
            Dim direction As New XYZ()
            Select Case i Mod 3
                Case 0
                    direction = New XYZ(1, 1, 0)
                    Exit Select
                Case 1
                    direction = New XYZ(0, 1, 1)
                    Exit Select
                Case 2
                    direction = New XYZ(1, 0, 1)
                    Exit Select
            End Select
            Dim instance As FamilyInstance = document.Create.NewFamilyInstance(location, symbol, direction, floor, StructuralType.NonStructural)
            x += 10
            i += 1
        End While
    End If
End If

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


ItemFactoryBase.NewFamilyInstances2 Method

ItemFactoryBaseNewFamilyInstances2 Method

Creates Family instances within the document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> NewFamilyInstances2(
    List<FamilyInstanceCreationData> dataList
)
Public Function NewFamilyInstances2 (
    dataList As List(Of FamilyInstanceCreationData)
) As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ NewFamilyInstances2(
    List<FamilyInstanceCreationData^>^ dataList
)
member NewFamilyInstances2 :
        dataList : List<FamilyInstanceCreationData> -> ICollection<ElementId>

Parameters

dataList List FamilyInstanceCreationData
A list of FamilyInstanceCreationData which wraps the creation arguments of the families to be created.

Return Value

ICollection ElementId
If the creation is successful, a set of ElementIds which contains the Family instances should be returned, otherwise the exception will be thrown.
Exceptions
Exception | Condition
ArgumentNullException | If FamilyInstanceCreationData's 'curve' or 'symbol' member is .
InvalidOperationException | If regeneration fails at the end of the batch creation.
Remarks

Note: ForbiddenForDynamicUpdateException might be thrown during a dynamic update if the inserted instance establishes a mutual dependency with another structure.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call.

Example
C#
VB
C++
F#
Copy
ICollection<ElementId> BatchCreateColumns(Autodesk.Revit.DB.Document document, Level level)
{
    List<FamilyInstanceCreationData> fiCreationDatas = new List<FamilyInstanceCreationData>();

    //ElementSet elementSet = null;
    ICollection<ElementId> elementSet = null;

    //Try to get a FamilySymbol
    FamilySymbol familySymbol = null;
    FilteredElementCollector collector = new FilteredElementCollector(document);
    ICollection<Element> collection = collector.OfClass(typeof(FamilySymbol)).ToElements();
    foreach (Element e in collection)
    {
        familySymbol = e as FamilySymbol;
        if (null != familySymbol.Category)
        {
            if ("Structural Columns" == familySymbol.Category.Name)
            {
                break;
            }
        }
    }

    if (null != familySymbol)
    {
        //Create 10 FamilyInstanceCreationData items for batch creation
        for (int i = 1; i < 11; i++)
        {
            XYZ location = new XYZ(i * 10, 100, 0);
            FamilyInstanceCreationData fiCreationData =
                new FamilyInstanceCreationData(location, familySymbol, level,  StructuralType.Column);

            if (null != fiCreationData)
            {
                fiCreationDatas.Add(fiCreationData);
            }
        }

        if (fiCreationDatas.Count > 0)
        {
            // Create Columns
            elementSet = document.Create.NewFamilyInstances2(fiCreationDatas);
        }
        else
        {
            throw new Exception("Batch creation failed.");
        }
    }
    else
    {
        throw new Exception("No column types found.");
    }

    return elementSet;
}
Private Function BatchCreateColumns(document As Autodesk.Revit.DB.Document, level As Level) As ICollection(Of ElementId)
    Dim fiCreationDatas As New List(Of FamilyInstanceCreationData)()

    'ElementSet elementSet = null;
    Dim elementSet As ICollection(Of ElementId) = Nothing

    'Try to get a FamilySymbol
    Dim familySymbol As FamilySymbol = Nothing
    Dim collector As New FilteredElementCollector(document)
    Dim collection As ICollection(Of Element) = collector.OfClass(GetType(FamilySymbol)).ToElements()
    For Each e As Element In collection
        familySymbol = TryCast(e, FamilySymbol)
        If familySymbol.Category IsNot Nothing Then
            If "Structural Columns" = familySymbol.Category.Name Then
                Exit For
            End If
        End If
    Next

    If familySymbol IsNot Nothing Then
        'Create 10 FamilyInstanceCreationData items for batch creation
        For i As Integer = 1 To 10
            Dim location As New XYZ(i * 10, 100, 0)
            Dim fiCreationData As New FamilyInstanceCreationData(location, familySymbol, level, StructuralType.Column)

            If fiCreationData IsNot Nothing Then
                fiCreationDatas.Add(fiCreationData)
            End If
        Next

        If fiCreationDatas.Count > 0 Then
            ' Create Columns
            elementSet = document.Create.NewFamilyInstances2(fiCreationDatas)
        Else
            Throw New Exception("Batch creation failed.")
        End If
    Else
        Throw New Exception("No column types found.")
    End If

    Return elementSet
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


ItemFactoryBase.NewGroup Method

ItemFactoryBaseNewGroup Method

Creates a new type of group.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Group NewGroup(
    ICollection<ElementId> elementIds
)
Public Function NewGroup (
    elementIds As ICollection(Of ElementId)
) As Group
public:
Group^ NewGroup(
    ICollection<ElementId^>^ elementIds
)
member NewGroup :
        elementIds : ICollection<ElementId> -> Group

Parameters

elementIds ICollection ElementId
A set of elements which will be made into the new group.

Return Value

Group
A new instance of a group containing the elements specified.
Remarks
  • The new group may contain more members than just the set input to this method. Elements which are closely connected with the inputs (such as sketch and sketch plane) will also be added to the group.
  • Initially the group will have a generic name, such as Group 1. This can be changed by changing the name of the group type as follows: newGroup.GroupType.Name = newName.
  • If a newly-created element is being added to a group, calling document.Regenerate() may be needed to avoid a warning visible in the UI that the group has changed outside group edit mode.
Example
C#
VB
C++
F#
Copy
Group group = null;
UIDocument uidoc = new UIDocument(document);
ICollection<ElementId> selectedIds = uidoc.Selection.GetElementIds();

if (selectedIds.Count > 0)
{
    // Group all selected elements
    group = document.Create.NewGroup(selectedIds);

}
Dim group As Group = Nothing
Dim uidoc As New UIDocument(document)
Dim selectedIds As ICollection(Of ElementId) = uidoc.Selection.GetElementIds()

If selectedIds.Count > 0 Then
    ' Group all selected elements

    group = document.Create.NewGroup(selectedIds)
Else

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


ItemFactoryBase.NewModelCurve Method

ItemFactoryBaseNewModelCurve Method

Creates a new model line element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ModelCurve NewModelCurve(
    Curve geometryCurve,
    SketchPlane sketchPlane
)
Public Function NewModelCurve (
    geometryCurve As Curve,
    sketchPlane As SketchPlane
) As ModelCurve
public:
ModelCurve^ NewModelCurve(
    Curve^ geometryCurve,
    SketchPlane^ sketchPlane
)
member NewModelCurve :
        geometryCurve : Curve *
        sketchPlane : SketchPlane -> ModelCurve

Parameters

geometryCurve Curve
The internal geometry curve for model line.
sketchPlane SketchPlane
The sketch plane this new model line resides in.

Return Value

ModelCurve
If successful a new model line element. Otherwise .
Exceptions
Exception | Condition
ArgumentException | Thrown when curve is not in the plane
Remarks
Different type of model curve element will be returned according to the type of geometry curve.
Example
C#
VB
C++
F#
Copy
// get handle to application from document
Autodesk.Revit.ApplicationServices.Application application = document.Application;

// Create a geometry line in Revit application
XYZ startPoint = new XYZ(0, 0, 0);
XYZ endPoint = new XYZ(10, 10, 0);
Line geomLine = Line.CreateBound(startPoint, endPoint);

// Create a geometry arc in Revit application
XYZ end0 = new XYZ(1, 0, 0);
XYZ end1 = new XYZ(10, 10, 10);
XYZ pointOnCurve = new XYZ(10, 0, 0);
Arc geomArc = Arc.Create(end0, end1, pointOnCurve);

// Create a geometry plane in Revit application
XYZ origin = new XYZ(0, 0, 0);
XYZ normal = new XYZ(1, 1, 0);
Plane geomPlane = Plane.CreateByNormalAndOrigin(normal, origin);

// Create a sketch plane in current document
SketchPlane sketch = SketchPlane.Create(document, geomPlane);

// Create a ModelLine element using the created geometry line and sketch plane
ModelLine line = document.Create.NewModelCurve(geomLine, sketch) as ModelLine;

// Create a ModelArc element using the created geometry arc and sketch plane
ModelArc arc = document.Create.NewModelCurve(geomArc, sketch) as ModelArc;
   ' get handle to application from document
   Dim application As Autodesk.Revit.ApplicationServices.Application = document.Application

   ' Create a geometry line in Revit application
   Dim startPoint As New XYZ(0, 0, 0)
   Dim endPoint As New XYZ(10, 10, 0)
   Dim geomLine As Line = Line.CreateBound(startPoint, endPoint)

   ' Create a geometry arc in Revit application
   Dim end0 As New XYZ(1, 0, 0)
   Dim end1 As New XYZ(10, 10, 10)
   Dim pointOnCurve As New XYZ(10, 0, 0)
   Dim geomArc As Arc = Arc.Create(end0, end1, pointOnCurve)

   ' Create a geometry plane in Revit application
   Dim origin As New XYZ(0, 0, 0)
   Dim normal As New XYZ(1, 1, 0)
Dim geomPlane As Plane = Plane.CreateByNormalAndOrigin(normal, origin)

   ' Create a sketch plane in current document
   Dim sketch As SketchPlane = SketchPlane.Create(document, geomPlane)

   ' Create a ModelLine element using the created geometry line and sketch plane
   Dim line__1 As ModelLine = TryCast(document.Create.NewModelCurve(geomLine, sketch), ModelLine)

   ' Create a ModelArc element using the created geometry arc and sketch plane
   Dim arc__2 As ModelArc = TryCast(document.Create.NewModelCurve(geomArc, sketch), ModelArc)

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


ItemFactoryBase.NewModelCurveArray Method

ItemFactoryBaseNewModelCurveArray Method

Creates an array of new model line elements.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ModelCurveArray NewModelCurveArray(
    CurveArray geometryCurveArray,
    SketchPlane sketchPlane
)
Public Function NewModelCurveArray (
    geometryCurveArray As CurveArray,
    sketchPlane As SketchPlane
) As ModelCurveArray
public:
ModelCurveArray^ NewModelCurveArray(
    CurveArray^ geometryCurveArray,
    SketchPlane^ sketchPlane
)
member NewModelCurveArray :
        geometryCurveArray : CurveArray *
        sketchPlane : SketchPlane -> ModelCurveArray

Parameters

geometryCurveArray CurveArray
An array containing the internal geometry curves for model lines.
sketchPlane SketchPlane

Return Value

ModelCurveArray
If successful an array of new model line elements. Otherwise .
Exceptions
Exception | Condition
ArgumentException | Thrown when curve is not in the plane
See Also

Reference

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


ItemFactoryBase.NewReferencePlane Method

ItemFactoryBaseNewReferencePlane Method

Creates a new instance of ReferencePlane.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReferencePlane NewReferencePlane(
    XYZ bubbleEnd,
    XYZ freeEnd,
    XYZ cutVec,
    View pView
)
Public Function NewReferencePlane (
    bubbleEnd As XYZ,
    freeEnd As XYZ,
    cutVec As XYZ,
    pView As View
) As ReferencePlane
public:
ReferencePlane^ NewReferencePlane(
    XYZ^ bubbleEnd,
    XYZ^ freeEnd,
    XYZ^ cutVec,
    View^ pView
)
member NewReferencePlane :
        bubbleEnd : XYZ *
        freeEnd : XYZ *
        cutVec : XYZ *
        pView : View -> ReferencePlane

Parameters

bubbleEnd XYZ
The bubble end applied to reference plane.
freeEnd XYZ
The free end applied to reference plane.
cutVec XYZ
The cut vector apply to reference plane, should perpendicular to the vector (bubbleEnd-freeEnd).
pView View
The specific view apply to the Reference plane.

Return Value

ReferencePlane
The newly created reference plane.
Remarks
The specific view is applied to the Reference plane only for certain view types: Legend DraftingView DrawingSheet
Example
C#
VB
C++
F#
Copy
// Define data for reference plane creation
XYZ bubbleEnd = new XYZ(1, 0, 0);   // bubble end applied to reference plane
XYZ freeEnd = new XYZ(-5, 0, 0);    // free end applied to reference plane
// Cut vector should be perpendicular to bubbleEnd-freeEnd vector
XYZ cutVec = new XYZ(0, 0, 1);  // cut vector applied to reference plane

// Create the reference plane, applying the active view
ReferencePlane refPlane = document.Create.NewReferencePlane(bubbleEnd, freeEnd, cutVec, document.ActiveView);
' Define data for reference plane creation
Dim bubbleEnd As New XYZ(1, 0, 0)
' bubble end applied to reference plane
Dim freeEnd As New XYZ(-5, 0, 0)
' free end applied to reference plane
' Cut vector should be perpendicular to bubbleEnd-freeEnd vector
Dim cutVec As New XYZ(0, 0, 1)
' cut vector applied to reference plane
' Create the reference plane, applying the active view
Dim refPlane As ReferencePlane = document.Create.NewReferencePlane(bubbleEnd, freeEnd, cutVec, document.ActiveView)

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


ItemFactoryBase.NewReferencePlane2 Method

ItemFactoryBaseNewReferencePlane2 Method

Creates a new instance of ReferencePlane.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReferencePlane NewReferencePlane2(
    XYZ bubbleEnd,
    XYZ freeEnd,
    XYZ thirdPnt,
    View pView
)
Public Function NewReferencePlane2 (
    bubbleEnd As XYZ,
    freeEnd As XYZ,
    thirdPnt As XYZ,
    pView As View
) As ReferencePlane
public:
ReferencePlane^ NewReferencePlane2(
    XYZ^ bubbleEnd,
    XYZ^ freeEnd,
    XYZ^ thirdPnt,
    View^ pView
)
member NewReferencePlane2 :
        bubbleEnd : XYZ *
        freeEnd : XYZ *
        thirdPnt : XYZ *
        pView : View -> ReferencePlane

Parameters

bubbleEnd XYZ
The bubble end applied to reference plane.
freeEnd XYZ
The free end applied to reference plane.
thirdPnt XYZ
A third point needed to define the reference plane.
pView View
The specific view apply to the Reference plane.

Return Value

ReferencePlane
The newly created reference plane.
Remarks
The specific view is applied to the Reference plane only for certain view types: Legend DraftingView DrawingSheet
Example
C#
VB
C++
F#
Copy
// Build now data before creation
XYZ bubbleEnd = new XYZ(1, 0, 0);   // bubble end applied to reference plane
XYZ freeEnd = new XYZ(-5, 0, 0);    // free end applied to reference plane
// Third point should not be on the bubbleEnd-freeEnd line
XYZ thirdPnt = new XYZ(0, 15, 0);   // 3rd point to define reference plane

// Create the reference plane in X-Y, applying the active view
ReferencePlane refPlane = document.Create.NewReferencePlane2(bubbleEnd, freeEnd, thirdPnt, document.ActiveView);
' Build now data before creation
Dim bubbleEnd As New XYZ(1, 0, 0)
' bubble end applied to reference plane
Dim freeEnd As New XYZ(-5, 0, 0)
' free end applied to reference plane
' Third point should not be on the bubbleEnd-freeEnd line
Dim thirdPnt As New XYZ(0, 15, 0)
' 3rd point to define reference plane
' Create the reference plane in X-Y, applying the active view
Dim refPlane As ReferencePlane = document.Create.NewReferencePlane2(bubbleEnd, freeEnd, thirdPnt, document.ActiveView)

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


ItemFactoryBase.PlaceGroup Method

ItemFactoryBasePlaceGroup Method

Place an instance of a Model Group into the Autodesk Revit document, using a location and a group type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Group PlaceGroup(
    XYZ location,
    GroupType groupType
)
Public Function PlaceGroup (
    location As XYZ,
    groupType As GroupType
) As Group
public:
Group^ PlaceGroup(
    XYZ^ location,
    GroupType^ groupType
)
member PlaceGroup :
        location : XYZ *
        groupType : GroupType -> Group

Parameters

location XYZ
The physical location where the group is to be placed.
groupType GroupType
A GroupType object that represents the type of group that is to be placed.

Return Value

Group
If creation was successful then an instance to the new group is returned, otherwise .
Remarks
This method is used to place a new instance of an existing group type within the document. The group's origin will placed at the point specified by the location. All group types within the document can be found by iterating over the document and looking for elements of type GroupType.
See Also

Reference

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


Autodesk.Revit.DB Namespace

Classes
Class | Description
Public class | ACADExportOptions | The base class for options used to export DWG and DXF format files.
AdaptiveComponentFamilyUtils | An interface for Adaptive Component Instances.
AdaptiveComponentInstanceUtils | An interface for Adaptive Component Instances.
Public class | AddInId | Identifies an AddIn registered with Revit
Public class | AlphanumericRevisionSettings | Contains settings that apply to Revisions with the Alphanumeric RevisionNumberType.
Public class | AngularDimension | An object that represents an Angular Dimension within the Revit project.
Public class | AnnotationMultipleAlignmentUtils | A helper providing functionality related to elements that can be aligned to one another. An element that wants to be able to align to other alignable elements using the Multiple Alignment buttons should implement this helper class.
Public class | AnnotationSymbol | This object represents a symbol of the Generic Annotation.
Public class | AnnotationSymbolType | An object that represents an annotation style.
Public class | APIObject | Supports all objects in the Autodesk Revit API hierarchy.
Public class | AppearanceAssetElement | An element that contains a rendering asset used as a portion of a material definition.
Public class | Arc | A circular arc.
Public class | ArcLengthDimension | An object that represents an ArcLengthDimension within the Revit Project.
Public class | Area | Provides access to the area topology in Autodesk Revit.
AreaFilter | A filter used to match areas.
Public class | AreaScheme | The area scheme associated with a particular area plan.
Public class | AreaTag | Provides access to the area topology in Autodesk Revit.
Public class | AreaTagFilter | A filter used to match area tags.
Public class | AreaTagType | An object that represents an Area Tag style.
Public class | AreaVolumeSettings | This class provides access to settings related to volume and area computations.
Public class | AssemblyCodeTable | AssemblyCodeTable represents the collection of ClassificationEntries for a document.
Public class | AssemblyDifference | Class that describes difference between two assemblies.
Public class | AssemblyDifferenceConfiguration | The two assemblies being compared have different spatial configuration
Public class | AssemblyDifferenceMemberCount | The two assemblies being compared have different number of members
Public class | AssemblyDifferenceMemberDifference | The two assemblies being compared have different members
Public class | AssemblyDifferenceNamingCategory | The two assemblies being compared have different naming categories
Public class | AssemblyDifferenceNone | The two assemblies being compared are identical
AssemblyInstance | Combines multiple elements for tagging, filtering, scheduling and creating isolated assembly views.
Public class | AssemblyMemberDifference | Class that describes difference between two assembly members
Public class | AssemblyMemberDifferentCategory | The two assembly members being compared have different category
Public class | AssemblyMemberDifferentGeometry | The two assembly members being compared have different geometry
Public class | AssemblyMemberDifferentParameters | The two assembly members being compared have different parameters
Public class | AssemblyMemberDifferentType | The two assembly members being compared have different type
Public class | AssemblyType | Type for construction assembly elements.
AssemblyViewUtils | Utilities that provide capabilities related to assembly view creation and validation.
Public class | AXMImportOptions | The import options used to import AXM format files.
Public class | BackgroundSettings | Represents the rendering background settings.
Public class | BarTypeDiameterOptions | This class stores the diameter information from the RebarBarType.
Public class | BaseArray | An abstract base class that represents an array within the Revit project.
Public class | BaseExportOptions | The base class for options used to export DWG, DXF and DGN format files.
Public class | BaseImportOptions | A base class containing import options used during import of several formats.
Public class | BasePoint | A class representing the Project Base Point and Survey Point. Each Revit project contains one project base point and one survey point. The project base point represents the origin of the project coordinate system. The survey point represents the origin of the shared coordinate system.
Public class | BasicFileInfo | Encapsulates basic information about a Revit file, including worksharing status, Revit version, username and central path.
BeamSystem | An object that represents a BeamSystem within the Autodesk Revit project.
Public class | BeamSystemType | An object that specifies the type of a beam system in Autodesk Revit.
Public class | BIMExportOptions | The base class for options used to export using ATF.
Public class | Binding | Binding objects are used to take a parameter definition and bind it to one or more categories.
Public class | BindingMap | The parameters BindingMap contains all the parameter bindings that exist in the Autodesk Revit project.
Public class | Blend | A blend solid or void form.
Public class | BooleanOperationsUtils | These utilities are applicable for the geometry created by GeometryCreationUtilities and the geometry of Revit model.
BoundarySegment | An object that represents a segment of an area boundary.
Public class | BoundaryValidation | Curve loop validators.
BoundingBoxContainsPointFilter | A filter used to match elements with a bounding box that contains the given point.
BoundingBoxIntersectsFilter | A filter used to match elements with a bounding box that intersects the given Outline.
BoundingBoxIsInsideFilter | A filter used to match elements with a bounding box that is contained by the given Outline.
BoundingBoxUV | A two-dimensional rectangle, parallel to the coordinate axes.
BoundingBoxXYZ | A three-dimensional rectangular box at an arbitrary location and orientation within the Revit model.
BRepBuilder | A class that allows direct construction of geometry objects (solids, open shells, etc.).
Public class | BRepBuilderEdgeGeometry | An abstract class used by BRepBuilder to represent the geometry of an edge. Specific edge-geometry representations are represented by subclasses.
Public class | BRepBuilderGeometryId | This class is used by the BRepBuilder class to identify objects it creates (faces, edges, etc.).
Public class | BRepBuilderPersistentIds | This class stores a map from ExternalGeometryIds to BRepBuilderGeometryIds.
Public class | BRepBuilderSurfaceGeometry | An abstract class used by BRepBuilder to represent the geometry of a surface. Specific surface-geometry representations are represented by subclasses.
Public class | BrowserOrganization | The organization settings for grouping, sorting, and filtering of items in the project browser.
Public class | BuildingPadType | Represents a specific type of Building Pad.
Public class | BuiltInFailures | Provides a container of all Revit built-in FailureDefinitionId instances.
Public class | BuiltInFailuresAlignmentFailures | Failures related to alignment elements and annotations.
Public class | BuiltInFailuresAnalyticalModelFailures | Failures about AnalyticalModel.
Public class | BuiltInFailuresArrayFailures | Failures about Arrays.
Public class | BuiltInFailuresAssemblyFailures | Failures related to Assemblies.
Public class | BuiltInFailuresAutoJoinFailures | Failures about AutoJoin.
Public class | BuiltInFailuresAutoRouteFailures | Failures about AutoRoute.
Public class | BuiltInFailuresBeamFailures | Failures about Beams.
Public class | BuiltInFailuresBeamSystemFailures | Failures about BeamSystem.
Public class | BuiltInFailuresBendFailures | Failures about Bends.
Public class | BuiltInFailuresBlendFailures | Failures about Blend.
Public class | BuiltInFailuresColorFillFailures | Failures about ColorFill.
Public class | BuiltInFailuresColumnFailures | Failures about Columns.
Public class | BuiltInFailuresColumnInsideWallFailures | Failures description ColumnInsideWall
Public class | BuiltInFailuresComponentRepeaterFailures | Failures related to component repeaters.
Public class | BuiltInFailuresComponentRepeaterSlotFailures | Failures related to component repeater slots.
Public class | BuiltInFailuresConnectorFailures | Failures about Connector.
Public class | BuiltInFailuresConstraintFailures | Failures about Constraint.
Public class | BuiltInFailuresConversionFailures | Failures about conversion of data to a different format.
Public class | BuiltInFailuresCopyMonitorFailures | Failures about CopyWatch.
Public class | BuiltInFailuresCopyPasteFailures | Failures about CopyPasteFailures.
Public class | BuiltInFailuresCreationFailures | Failures about CreationFailures.
Public class | BuiltInFailuresCurtainGridFamilyFailures | Failures about CurtainGrid Family.
Public class | BuiltInFailuresCurtainWallFailures | Failures about CurtainWall.
Public class | BuiltInFailuresCurveByPointFailures | Failures about Curve By Point Element
Public class | BuiltInFailuresCurveFailures | Failures about Curves and Curve-Driven Elements.
Public class | BuiltInFailuresCutFailures | Failures about Cut.
Public class | BuiltInFailuresCutterFailures | Failures about Cutter.
Public class | BuiltInFailuresCuttingFailures | Failures about Cutting.
Public class | BuiltInFailuresDatumPlaneFailures | Failures about DatumPlane.
Public class | BuiltInFailuresDebugTabBindingFailures | Failures related to binding framework demo panel on Ribbon Debug Tab.
Public class | BuiltInFailuresDecalFailures | Failures about Decal.
Public class | BuiltInFailuresDesignOptionFailures | Failures about DesignOptionFailures.
Public class | BuiltInFailuresDetailFailures | Failures about Detail.
Public class | BuiltInFailuresDimensionFailures | Failures about DimensionFailures.
Public class | BuiltInFailuresDirectContext3DFailures
Public class | BuiltInFailuresDirectShapeFailures | Failure definitions related to DirectShapes.
Public class | BuiltInFailuresDisplacementElementFailures | Error messages related to the DisplacementElement.
Public class | BuiltInFailuresDividedPathFailures | Failures related to divided path operations.
Public class | BuiltInFailuresDividedSurfaceFailures | Failures about DividedSurface.
Public class | BuiltInFailuresDocumentFailures | Failures about DocumentFailures.
Public class | BuiltInFailuresDPartFailures | Failures related to parts.
Public class | BuiltInFailuresDuctFailures | Failures about Duct.
Public class | BuiltInFailuresEditingFailures | Failures related to editing operations.
Public class | BuiltInFailuresElectricalFailures | Failures about Electricity.
Public class | BuiltInFailuresElectricityFailures | Failures related to electrical system and circuits.
Public class | BuiltInFailuresElementFailures | Failures about Elements.
Public class | BuiltInFailuresElementTypeFailures | Failures about ElementTypeFailures.
Public class | BuiltInFailuresElevationFailures | Failures about Elevation.
Public class | BuiltInFailuresEnergyAnalysisFailures | Failures about EnergyAnalysis.
Public class | BuiltInFailuresEnergyAnalysisUtilitiesDBFailures | Failures about EnergyAnalysisUtilitiesDBFailures.
Public class | BuiltInFailuresExportFailures | Failures about ExportFailures.
Public class | BuiltInFailuresExternalResourceReferenceFailures
Public class | BuiltInFailuresExtrusionFailures | Failures about Extrusions.
Public class | BuiltInFailuresFabricAreaFailures | Failures related to fabric area elements.
Public class | BuiltInFailuresFabricFailures | Failures about Fabric.
Public class | BuiltInFailuresFabricSheetFailures | Failures related to fabric sheet elements.
Public class | BuiltInFailuresFaceSplitterFailures | Failures about FaceSplitter.
Public class | BuiltInFailuresFamilyFailures | Failures related to families.
Public class | BuiltInFailuresFilledRegionFailures | Failures about FilledRegion.
Public class | BuiltInFailuresFloorFailures | Failures related to floors and slabs.
Public class | BuiltInFailuresFluidFailures | Failures about Fluid.
Public class | BuiltInFailuresForeignFileFailures | Failures about files saved by applications that were not developed or licensed by Autodesk.
Public class | BuiltInFailuresFormFailures | Failures about Form.
Public class | BuiltInFailuresGeneralFailures | Failures about GeneralFailures.
Public class | BuiltInFailuresGenericFailures | Generic failures that may apply to any Revit Element
Public class | BuiltInFailuresGenericMEPFailures | Failures applicable to different mechanical, electrical and piping Elements.
Public class | BuiltInFailuresGeometryFailures | Failures about GeometryFailures.
Public class | BuiltInFailuresGlobalParameterFailures
Public class | BuiltInFailuresGridChainSketchFailures | Failures related to the GridChain sketch.
Public class | BuiltInFailuresGridFailures | Failures about Grid.
Public class | BuiltInFailuresGroupFailures | Failures related to groups and their behavior.
Public class | BuiltInFailuresHostObjFailures | Failures about HostObj.
Public class | BuiltInFailuresHvacFailures | Failures related to HVAC in MEP.
Public class | BuiltInFailuresIlluminationFailures | Failures about Illumination.
Public class | BuiltInFailuresImageFailures | Failures about Image.
Public class | BuiltInFailuresImportExportFailures | Failures about Import and Export.
Public class | BuiltInFailuresImportFailures | Failures about ImportFailures.
Public class | BuiltInFailuresInaccurateFailures | Failures about Inaccurate.
Public class | BuiltInFailuresInfillFailures | Failures about Infill.
Public class | BuiltInFailuresInterferenceFailures | Failures about Interference.
Public class | BuiltInFailuresJoinElementsFailures | Failures about JoinElements.
Public class | BuiltInFailuresKeyBasedTreeEntryFailures | Failures about KeyBasedTreeEntry.
Public class | BuiltInFailuresKeyBasedTreeFileFailures | Failures occurred when reading key based tree text file.
Public class | BuiltInFailuresKeynoteFailures
Public class | BuiltInFailuresKeynoteTagFailures | Failures related to keynote tags.
Public class | BuiltInFailuresLegendFailures | Failures about Legend.
Public class | BuiltInFailuresLevelAssociationFailures | Failures about Level association of Analytical Node.
Public class | BuiltInFailuresLevelFailures | Failures about Level.
Public class | BuiltInFailuresLinkFailures | Failures about LinkFailures.
Public class | BuiltInFailuresLoadFailures | Failures about Load.
Public class | BuiltInFailuresLooseDimensionFailures | Failures about LooseDimension.
Public class | BuiltInFailuresMacroFailures | Failures about module with duplicate name found during reload latest.
Public class | BuiltInFailuresMassFailures | Failures about Mass.
Public class | BuiltInFailuresMatchlineFailures | Failures about Matchline.
Public class | BuiltInFailuresMechanicalFailures | Failures about HVAC.
Public class | BuiltInFailuresMEPCalculationFailures | Failures about Fluid.
Public class | BuiltInFailuresMEPFabricationFailures | Failures about MEP fabrication.
Public class | BuiltInFailuresMEPSupportFailures | Failures about MEP suppor.
Public class | BuiltInFailuresMirrorFailures | Failures about Mirror.
Public class | BuiltInFailuresMultiReferenceAnnotationFailures | Failures about MultiReferenceAnnotations.
Public class | BuiltInFailuresNumberingFailures | Failures related to object numbering operations.
Public class | BuiltInFailuresOffsetFacesCellLegacyFailures | Failures related to offset faces operations.
Public class | BuiltInFailuresOpeningFailures | Failures about Opening.
Public class | BuiltInFailuresOverlapFailures | Failures detected by overlap check.
Public class | BuiltInFailuresParameterFailures | Failures related to parameters and parameter operations.
Public class | BuiltInFailuresPartMakerMethodForMergePartFailures | Failures related to part merge operations.
Public class | BuiltInFailuresPartMakerMethodForWallFailures | Failures related to parts related to walls.
Public class | BuiltInFailuresPathFailures | Failures about Path.
Public class | BuiltInFailuresPathOfTravelFailures | Failures about PathOfTravel.
Public class | BuiltInFailuresPerformanceFailures | Failures which give hints pointing to situations where performance could be improved.
Public class | BuiltInFailuresPipingFailures | Failures about Pipes.
Public class | BuiltInFailuresPlanRegionFailures | Failures about PlanRegion.
Public class | BuiltInFailuresPointFailures | Failures about Point Element.
Public class | BuiltInFailuresProfileFailures | Failures about Profile.
Public class | BuiltInFailuresPropertySetElementFailures | Failures related to property set elements.
Public class | BuiltInFailuresRebarBendingDetailFailures | Failures concerning rebar bending details.
Public class | BuiltInFailuresRebarCouplerFailures | Failures concerning couplers
Public class | BuiltInFailuresRebarFailures | Failures about Rebar.
Public class | BuiltInFailuresRebarShapeFailures | Failures about RebarShape.
Public class | BuiltInFailuresRebarSystemFailures | Failures related to rebar systems.
Public class | BuiltInFailuresRefPlaneFailures | Failures about RefPlane.
Public class | BuiltInFailuresRegenFailures | Failures about RegenFailures.
Public class | BuiltInFailuresRenderFailures | Failures related to rendering.
Public class | BuiltInFailuresRevisionCloudFailures | Failures about RevisionCloud.
Public class | BuiltInFailuresRevisionFailures | Failures about Revision Settings.
Public class | BuiltInFailuresRevolutionFailures | Failures about Revolution.
Public class | BuiltInFailuresRoofFailures | Failures about Roof.
Public class | BuiltInFailuresRoomFailures | Failures about Room.
Public class | BuiltInFailuresScaleFailures | Failures about Scale.
Public class | BuiltInFailuresScheduleViewFailures | Failures about Schedule.
Public class | BuiltInFailuresSculptingFailures | Failures about Sculpting.
Public class | BuiltInFailuresSectionViewFailures | Failures about Section.
Public class | BuiltInFailuresSelectionFailures | Failures about Selections.
Public class | BuiltInFailuresSharedCoordinatesFailures | Failures about shared coordinates.
Public class | BuiltInFailuresSheetCollectionFailures | Failures about SheetCollection.
Public class | BuiltInFailuresSheetFailures | Failures about Sheet.
Public class | BuiltInFailuresSiteFailures | Failures about Site.
Public class | BuiltInFailuresSiteImportFailures | Failures about SiteImport.
Public class | BuiltInFailuresSketchFailures | Failures about Sketch.
Public class | BuiltInFailuresSkylightFailures | Failures about Skylight.
Public class | BuiltInFailuresSlabFailures | Failures about Slab.
Public class | BuiltInFailuresSlabShapeFailures | Failures about SlabShape.
Public class | BuiltInFailuresSlantedColumnFailures | Failures about SlantedColumn.
Public class | BuiltInFailuresSpanDirectionSymbolFailures | Failures about SpanDirectionSymbol.
Public class | BuiltInFailuresSplineFailures | Failures about Spline.
Public class | BuiltInFailuresSplitSketchBasedElementFailures | Failures related to the split sketched based element.
Public class | BuiltInFailuresSplitToposolidFailures
Public class | BuiltInFailuresStairRampFailures | Failures about StairRamp.
Public class | BuiltInFailuresSteelElementFailures | Failures about steel elements
Public class | BuiltInFailuresSteelElementsFailures | Failures about SteelElement module
Public class | BuiltInFailuresStructuralAssetFailures | Failures related to structural materials.
Public class | BuiltInFailuresStructuralConnectionFailures | Failures about StructuralConnectionHandler.
Public class | BuiltInFailuresStructuralCustomConnectionFailures | Failures about StructuralConnectionHandler.
Public class | BuiltInFailuresStructuralLoadFailures | Failures about Load.
Public class | BuiltInFailuresSubRegionFailures
Public class | BuiltInFailuresSweepFailures | Failures about Sweep.
Public class | BuiltInFailuresSweptBlendFailures | Failures about SweptBlend.
Public class | BuiltInFailuresSystemNavigatorFailures | Failures related with the system browser.
Public class | BuiltInFailuresSystemsFailures | Failures about System.
Public class | BuiltInFailuresTagFailures | Failures about Tag.
Public class | BuiltInFailuresTextFailures | Failures about Text.
Public class | BuiltInFailuresTilePatternTileFailures | Failures related to tile pattern tile.
Public class | BuiltInFailuresToggleViewFailures | Failures about ToggleView.
Public class | BuiltInFailuresTrussFailures | Failures about Truss.
Public class | BuiltInFailuresUniqueElementFailures
Public class | BuiltInFailuresViewFailures | Failures about ViewFailures.
Public class | BuiltInFailuresViewSheetFailures | Failures about placing viewports on sheets.
Public class | BuiltInFailuresWallFailures | Failures about Wall.
Public class | BuiltInFailuresWallJoinFailures | Failures about WallJoin.
Public class | BuiltInFailuresWallJoinRoofFailures | Failures about WallJoinRoof.
Public class | BuiltInFailuresWorksharingFailures | Failures about WorksharingFailures.
Public class | BuiltInFailuresZoneFailures | Failures about Zone.
Public class | CADExportOptions | Generic CAD Export options.
Public class | CADLinkOperations | This class is used to extend the IExternalResourceServer interface with methods to support operations specifically related to DWG links.
Public class | CADLinkOptions | This class contains the options in use when or reloading a CAD link type (DWG, DXF, etc.)
Public class | CADLinkType | CADLinkType represents both CAD links and CAD imports. The function IsLink can be used to distinguish between the two. CAD imports are not ExternalFileReferences; they are brought completely into the document and maintain no connection to their original file.
Public class | CameraInfo | An object holding information about the projection mapping of a 3D view.
Public class | CancellationListener | Allows clients to poll the cancellation status of a background operation. Revit instantiates CancellationListener objects for internal background operation implementations only. As such, third-party developers are not expected to instantiate or handle CancellationListener objects.
Categories | The Categories object is a map that contains all the top-level Category objects within the Document.
Category | Represents the category or subcategory to which an element belongs.
Public class | CategoryNameMap | A map that contains a mapping of category name to its category object.
Public class | CategoryNameMapIterator | An iterator to a category name map.
Public class | CategorySet | A set that can contains Category objects.
Public class | CategorySetIterator | An iterator to a category set.
Public class | Ceiling | Represents a ceiling in Autodesk Revit.
Public class | CeilingAndFloor | A base class that provides support for all ceiling and floor objects.
Public class | CeilingType | Represents a ceiling type in Autodesk Revit.
Public class | ChangeType | A class representing a change that can be detected and tracked during Dynamic Update.
City | An object that contains geographical location information for a known city.
Public class | CitySet | An set that contains cities.
Public class | CitySetIterator | An iterator to a city set.
Public class | ClassificationEntries | A collection of ClassificationEntry objects that make up the classification table.
Public class | ClassificationEntry | Represents an entry in the classification table.
Public class | ClosestPointsPairBetweenTwoCurves | This class captures results of computation of closest points between two generic curves.
Public class | Color | Represents a color in Autodesk Revit.
Public class | ColorBackgroundSettings | Represents the rendering color background settings.
Public class | ColorFillLegend | Represents color fill legend.
Public class | ColorFillScheme | Represents a color scheme could be used to colorfy elements in floor plan views and section views.
Public class | ColorFillSchemeEntry | Represents an entry of a [!:Autodesk::Revit::DB::ColorFillScheme].
Public class | ColorOptions | A class providing access to color settings which affect the colors applied to specific views.
Public class | ColorWithTransparency | Color with transparency
Public class | ColumnAttachment | An object representing the attachment of the top or bottom of a column to some target: a floor, roof, ceiling, beam, or brace.
Public class | CombinableElement | An element that can be added to a geometry combination.
Public class | CombinableElementArray | An array that contains CombinableElement objects.
Public class | CombinableElementArrayIterator | An iterator to an CombinableElement array.
Public class | ComponentRepeater | An element that contains and manages a set of repeated components.
Public class | ComponentRepeaterIterator | A slot iterator for ComponentRepeater.
Public class | ComponentRepeaterSlot | Represents a slot that holds one repeated component in a component repeater.
Public class | CompoundStructure | Describes the internal structure of a wall, floor, roof or ceiling.
Public class | CompoundStructureLayer | Describes a single layer in a CompoundStructure.
Public class | ConfigurationReloadInfo | This object contains information returned by a reload of the fabrication configuration.
ConicalFace | A conical face of a 3d solid or open shell.
Public class | ConicalSurface | A Conical Surface.
Public class | ConnectionValidationInfo | This object contains information about fabrication connection validations.
Public class | ConnectionValidationWarning | Contains information about a specific connection validation problem.
Connector | A connector in an Autodesk Revit MEP project document.
Public class | ConnectorElement | A base class that provides support for all connector elements occurring in families.
Public class | ConnectorManager | Provides access to the Connector Manager
Public class | ConnectorSet | A set that can contain any type of object.
Public class | ConnectorSetIterator | An iterator to a set.
Public class | Construction | Construction definition for Project Information.
Public class | ContentNode | This class represents a generic content node in a model-exporting process.
Public class | ContourSetting | Contour setting object that handles the contour information used to draw contours on elements.
Public class | ContourSettingItem | Contour setting item that stores the information of a single contour or a set of contours.
Public class | Control | A control in Autodesk Revit family document.
Public class | CopyPasteOptions | Settings to control the behavior of a copy-paste operation.
Public class | CurtainCell | Represents a CurtainCell within Autodesk Revit.
Public class | CurtainGrid | Represents a curtain grid element within Autodesk Revit.
Public class | CurtainGridLine | Represents a CurtainGridLine within Autodesk Revit.
Public class | CurtainGridSet | A set that can contain any type of object.
Public class | CurtainGridSetIterator | An iterator to a set.
Public class | CurtainSystem | Provides access to the CurtainSystem object in Autodesk Revit.
Public class | CurtainSystemBase | Provides access to the CurtainSystemBase object in Autodesk Revit.
Public class | CurtainSystemType | An object that represents CurtainSystem type.
Public class | Curve | A parametric curve.
Public class | CurveArrArray | An array that can contain any type of object.
Public class | CurveArrArrayIterator | An iterator to a array.
Public class | CurveArray | An array that can contain curves.
Public class | CurveArrayIterator | An iterator to a curve array.
Public class | CurveByPoints | A curve interpolating two or more points.
Public class | CurveByPointsArray | An array that can contain CurveByPoints elements.
Public class | CurveByPointsArrayIterator | An iterator to a CurveByPoints array.
Public class | CurveByPointsUtils | A static class that contains methods for processing curves driven by points.
Public class | CurveElement | Class representing curve elements.
CurveElementFilter | A filter used to pass curve elements which are of a specific type.
Public class | CurveExtents | Represents the start and end parameters for a curve segment.
Public class | CurveLoop | A class that represents a chain of curves.
Public class | CurveLoopIterator | An iterator to a curve loop.
Public class | CurveLoopsProfile | Represents a curve loop based profile for sweep or swept blend elements.
Public class | CurveNode | An output node that represents a model curve.
Public class | CurveUV | A class that encapsulates the notion of a curve in the 2D parameter space of a surface in 3D space.
CustomExporter | A class that allows exporting 3D or 2D views via an export context.
Public class | CustomFieldData | A class that offer access to the information about a custom field.
CylindricalFace | A cylindrical face of a 3d solid or open shell.
Public class | CylindricalHelix | A cylindrical helix.
Public class | CylindricalSurface | A cylindrical surface.
Public class | DataConversionMonitorScope | This class is used to regsiter an application-supplied object that implements IDataConversionMonitor. Creating the object registers an implementation of IDataConversionMonitor supplied as constructor argument. When the scope object is destroyed, that object is unregistered.
Public class | DatumPlane | A base class representing a datum surface (level, grid or reference plane) in Autodesk Revit.
Public class | DefaultDivideSettings | Provides access to project-wide divide settings.
Public class | DefaultOpenFromCloudCallback | A default callback that may be used to control Revit's behavior when opening a model.
Public class | Definition | The Definition object is a base object for all type of parameter definitions within the Autodesk Revit API.
Public class | DefinitionBindingMap | A map that contains mappings of parameter definitions to parameter bindings.
Public class | DefinitionBindingMapIterator | An iterator to a parameter definition to parameter bindings map.
DefinitionFile | The DefinitionFile object represents a shared parameters file on disk.
Public class | DefinitionGroup | The DefinitionGroup is a container that is used to hold shared parameter definitions on disk.
Public class | DefinitionGroups | A specialized set of definition groups that allows creation of new groups.
Public class | Definitions | A base class that supports the addition of new parameter definitions.
Public class | DeleteElements | Deletes element(s) related to the failure.
Public class | DeleteWorksetSettings | This class represents the settings used to delete a workset.
Public class | DesignOption | An element that represents a design alternative.
Public class | DetailArc | Represents a DetailArc within Autodesk Revit.
Public class | DetailCurve | A curve that is used to create a detail drawing. A detail curve is visible only in the view in which it is drawn.
Public class | DetailCurveArray | An array that can contain any type of object.
Public class | DetailCurveArrayIterator | An iterator to a array.
Public class | DetailElementOrderUtils | A utility class that arranges the draw order of the detail elements.
Public class | DetailEllipse | Represents a DetailEllipse within Autodesk Revit.
Public class | DetailLine | Represents a DetailLine within Autodesk Revit.
Public class | DetailNurbSpline | Represents a DetailNurbSpline within Autodesk Revit.
Public class | DGNExportOptions | The export options used by exporting DGN format file.
Public class | DGNImportOptions | The import options used to import DGN format files.
Dimension | An object that represents a dimension within the Revit project.
Public class | DimensionEqualityLabelFormatting | Instances of this class represent individual parameters used to make up a dimension equality formula for continuous linear or angular dimensions.
Public class | DimensionSegment | A segment of a dimension within the Autodesk Revit project.
Public class | DimensionSegmentArray | An array that can contain any number of DimensionSegment objects.
Public class | DimensionSegmentArrayIterator | An iterator to an array of DimensionSegment objects..
Public class | DimensionType | An object that represents a dimension style.
DirectShape | This class is used to store externally created geometric shapes. Primary intended use is for importing shapes from other data formats such as IFC or STEP. A DirectShape object may be assigned a category. That will affect how that object is displayed in Revit.
Public class | DirectShapeLibrary | DirectShapeLibrary is used to store pre-created geometry for further referencing via the definition/instance mechanism. It is not persistent: the scope of a library object is usually a single data creation session. DirectShape::createGeometryInstance and DirectShape::CreateElementInstance will use the current DirectShapeLibrary to look up the definitions. store a collection of GNodes as definition end class DirectShapeDefinition
Public class | DirectShapeOptions | This class is used to control behavior of a DirectShape object.
Public class | DirectShapeReferenceOptions | This class is used to control the behavior of DirectShape and DirectShapeType reference objects.
Public class | DirectShapeType | The type element associated with a DirectShape element. This element includes data reused by DirectShape elements of the same type.
Public class | DirectShapeTypeOptions | This class is used to control behavior of a DirectShapeType object.
Public class | DisableAnalyticalModelCB | Disable the analytical model for a structural wall.
Public class | DisciplineTypeId | This class contains constants identifying disciplines.
Public class | DisplacementElement | A view-specific element that causes other elements to appear to be displaced from their actual locations.
Public class | DisplacementPath | A view-specific annotation related to a DisplacementElement.
Public class | DividedPath | An element that consists of a set of points distributed along a path which consists of a connected set of curves and edges.
DividedSurface | An element that represents a mesh on the surface of another element, a family instance, an import instance or a geometry combination, and a tile pattern built on that mesh.
Public class | Document | An object that represents an open Autodesk Revit project.
Public class | DocumentDifference | DocumentDifference represents the difference (including added elements, modified elements and deleted elements) of a Revit model between different DocumentVersion of the model.
DocumentPreviewSettings | Contains the settings related to the saving of preview images for a given document.
Public class | DocumentSet | A set that can contain any documents.
Public class | DocumentSetIterator | An iterator to a set of documents.
Public class | DocumentValidation | Utility functions with document validation
Public class | DocumentVersion | This class uniquely identifies an edition of a given document.
Public class | DoubleArray | An array that contains doubles.
Public class | DoubleArrayIterator | An iterator to an array of doubles.
Public class | DoubleParameterValue | A class that holds a Double value of a parameter element.
Public class | DuplicateTypeNamesHandlerArgs | A structure that provides information about an attempt to copy types with names that already exist in the destination document.
Public class | DWFExportOptions | DWF Export options.
Public class | DWFImportOptions | The import options used by importing DWF or DWFx format file.
Public class | DWFXExportOptions | DWFX Export options.
Public class | DWGExportOptions | The export options used by exporting DWG format file.
Public class | DWGImportOptions | The import options used by importing DWG or DXF format file.
Public class | DXFExportOptions | The export options used by exporting DXF format file.
Public class | Edge | An edge of a 3d solid.
Public class | EdgeArray | An array that contains edges.
EdgeArrayArray | An array of edge arrays.
Public class | EdgeArrayArrayIterator | An iterator to an array or edge arrays.
Public class | EdgeArrayIterator | An iterator to an edge array.
Public class | EdgeEndPoint | Represents the start or the end point of an Edge.
Public class | EditScope | The base class for a scope object that provides special access and limitations related to editing certain elements.
Public class | Element | Base class for most persistent data within a Revit document.
Public class | ElementArray | An array that contains element objects.
Public class | ElementArrayIterator | An iterator to an element array.
Public class | ElementBinding | A base class for all types of binding that attach to an element.
ElementCategoryFilter | A filter used to match elements by their category.
ElementClassFilter | A filter used to match elements by their class.
ElementDesignOptionFilter | A filter used to find elements contained within a particular design option.
Public class | ElementFilter | A base class for a type of filter that accepts or rejects elements based upon criteria.
Public class | ElementId | The ElementId object is used as a unique identification for an element within a single project.
Public class | ElementIdParameterValue | A class that holds a ElementId value of a parameter element.
Public class | ElementIdSetFilter | A filter wrapping a set of elements.
Public class | ElementIntersectsElementFilter | A filter to find elements that intersect the solid geometry of a given element.
Public class | ElementIntersectsFilter | A base class for filters used to match elements which intersect with geometry.
ElementIntersectsSolidFilter | A filter to find elements that intersect the given solid geometry.
ElementIsCurveDrivenFilter | A filter used to match elements which are curve driven.
Public class | ElementIsElementTypeFilter | A filter used to match elements which are ElementTypes.
ElementLevelFilter | A filter used to match elements by their associated level.
Public class | ElementLogicalFilter | A filter used to logically combine two or more filters.
Public class | ElementMulticategoryFilter | A filter used to find elements whose category matches any of a given set of categories.
Public class | ElementMulticlassFilter | A filter used to match elements by their class, where more than one class of element may be passed.
Public class | ElementNode | A render node that represents an element, including the host document containing the element.
ElementOwnerViewFilter | A filter used to match elements which are owned by a particular view.
ElementParameterFilter | A filter used to match elements by one or more parameter filter rules.
Public class | ElementPhaseStatusFilter | A filter used to match elements that have a given phase status on a given phase.
Public class | ElementQuickFilter | A base class for a type of filter that operates on element records.
Public class | ElementRecord | A record in the Revit database representing an element.
ElementSet | A set that contains element objects.
Public class | ElementSetIterator | An iterator to an element set.
Public class | ElementSlowFilter | A base class for a type of filter that operates on expanded elements.
Public class | ElementStructuralTypeFilter | A filter used to find elements matching a structural type.
Public class | ElementTransformUtils | A collection of utilities allowing transformation of elements (e.g. move, rotate, mirror and copy).
Public class | ElementType | Base class for all Types within Autodesk Revit.
ElementWorksetFilter | A filter used to match elements which reside in a given workset.
Public class | ElevationMarker | ElevationMarkers either host elevation ViewSection views or view references.
Public class | Ellipse | A whole or partial ellipse.
Public class | EvaluatedParameter | Hold the evaluated ParameterValue and Definition of a parameter.
ExclusionFilter | A filter used to exclude a set of elements automatically.
Public class | ExportDGNSettings | This element contains DGN export settings which are saved in a Revit document.
Public class | ExportDWGSettings | This element contains DWG/DXF export settings which are saved in a Revit document.
Public class | ExportFontInfo | A value used to represent the info stored in an ExportFontTable.
Public class | ExportFontKey | A key used to represent an item stored in an ExportFontTable.
Public class | ExportFontTable | A table supporting a mapping of Revit font names to font names that will be set in the target export format.
Public class | ExportFontTableIterator | An iterator to a set of font table.
Public class | ExportIFCCategoryInfo | Represents the mapped IFC information stored in the template.
Public class | ExportIFCCategoryKey | Represents a Revit category item stored in a template.
ExportLayerInfo | A value used to represent the info stored in the ExportLayerTable.
Public class | ExportLayerKey | A key used to represent an item stored in an ExportLayerTable.
Public class | ExportLayerTable | A table supporting a mapping of category and subcategory to layer name and other layer properties that will be set in the target export format.
Public class | ExportLayerTableIterator | An iterator to a set of Layer table.
Public class | ExportLinetypeInfo | A value used to represent the info stored in the ExportLinetypeTable.
Public class | ExportLinetypeKey | A key used to represent an item stored in an ExportLinetypeTable.
Public class | ExportLinetypeTable | A table supporting a mapping of linetypes in Revit to linetype names that will be set in the target export format.
Public class | ExportLinetypeTableIterator | An iterator to a set of line type table.
Public class | ExportLineweightInfo | A value used to represent the info stored in the ExportLineweightTable.
Public class | ExportLineweightKey | A key used to represent an item stored in an ExportLineweightTable.
Public class | ExportLineweightTable | A table supporting a mapping of line weights in Revit to line weight names that will be set in the target export format.
Public class | ExportLineweightTableIterator | An iterator to a set of line weight table.
Public class | ExportPatternInfo | A value used to represent the info stored in the ExportPatternTable.
Public class | ExportPatternKey | A key used to represent an item stored in an ExportPatternTable.
Public class | ExportPatternTable | A table supporting a mapping of FillPatterns in Revit to pattern names that will be set in the target export format.
Public class | ExportPatternTableIterator | An iterator to a set of Pattern table.
Public class | ExportPDFSettings | Settings for PDF export
Public class | ExportUtils | This class provides utilities related to document export.
ExternalDefinition | The ExternalDefinition object adds properties specific to Autodesk Revit shared parameter definitions.
Public class | ExternalDefinitionCreationOptions | An option class used for creating a new shared parameter definition, including options such as name, type, visibility, Guid description and modifiable flag.
Public class | ExternalDefinitions | Supports the creation of new shared parameters definitions.
Public class | ExternalFileReference | A class that contains the details of a reference to a file outside of a given document.
Public class | ExternalFileUtils | A utility class containing functions related to external file references.
Public class | ExternalGeometryId | This class represents an identifier for geometry from external sources.
Public class | ExternallyTaggedBRep | An ExternallyTaggedSolid can hold any shape created by BRepBuilder.
Public class | ExternallyTaggedGeometryObject | Base class for ExternallyTaggedGeometryObject and ExternallyTaggedSolid.
Public class | ExternallyTaggedGeometryValidation | Provides validation for geometry to be stored in an ExternallyTaggedGeometry.
Public class | ExternallyTaggedNonBRep | This class is used to create an externally tagged geometry object.
Public class | ExternallyTaggedNonBReps | Holds a collection of ExternallyTaggedNonBRep instances.
Public class | ExternalResourceBrowserData | Represents a collection of external resources and external resource folders to be presented as the content of a folder in the file browser in Revit.
Public class | ExternalResourceLoadContent | This class contains the actual content data and other results of an external resource load operation that are returned by an IExternalResourceServer to Revit.
Public class | ExternalResourceLoadContext | This class contains data describing the context related to an external resource load operation.
Public class ExternalResourceLoadData

This class contains the input and output data resulting from invoking an IExternalResourceServer's LoadResource method.

After the call to LoadResource, the resulting ExternalResourceLoadData will be passed into IExternalResourceServer.HandleLoadResourceResults() so that appropriate UI can be displayed.

Server providers can inspect the ExternalResourceLoadData to get an ExternalResourceLoadContent object of the subclass appropriate to the external resource. The class also contains a copy of the ExternalResourceReference, and information about the context of the load operation.

Public class | ExternalResourceMatchOptions | Represents match options used to filter external resources when listing them from external resource server.
Public class | ExternalResourceReference | This class identifies an external resource provided by an IExternalResourceServer.
Public class | ExternalResourceServerExtensions | An object that contains overrides for external resource-specific methods.
Public class | ExternalResourceServerUtils | Contains utilities related to external resource server.
Public class | ExternalResourceServiceUtils | Contains utilities related to external resource service.
Public class | ExternalResourceSubFolder | Data that describes a remote folder to be shown in the file browser dialog
Public class | ExternalResourceType | A type class used to distinguish between different kinds of external resource.
Public class | ExternalResourceTypes | Provides a container of all Revit built-in ExternalResourceType instances.
Public class | ExternalResourceTypesBuiltInExternalResourceTypes | A collection of ids of the ExternalResourceTypes provided by Revit.
Public class | ExternalResourceUtils | A utility class containing functions related to external resource references.
Public class | Extrusion | A extrusion solid or void form.
Public class | ExtrusionAnalyzer | This geometry utility allows you to attempt to "fit" a given piece of geometry into the shape of an extrusion.
Public class | ExtrusionRoof | Represents some kinds of Extrusion Roofs.
Public class | FabricationAncillaryUsage | Structure that holds information about the usage of a fabrication ancillary
Public class | FabricationConfiguration | This element contains the information about the fabrication configuration settings used by the project.
Public class | FabricationConfigurationInfo | Represents an MEP object that holds the properties of an MEP fabrication configuration.
Public class | FabricationConnectorInfo | Fabrication connector information.
Public class | FabricationDimensionDefinition | Represents the definition of a single fabrication pattern dimension. Together all dimensions represent the parametric definition of the fabrication part.
Public class | FabricationHostedInfo | The fabrication hosted element information.
Public class | FabricationItemFile | This class holds information about the item file, including whether it is already loaded from disk into Revit.
Public class | FabricationItemFolder | A fabrication item folder that can contain sub folders and access to the FabricationItemFiles contained within.
Public class | FabricationPart | Represents a fabrication component in the Autodesk Revit MEP product.
Public class | FabricationPartType | Represents a fabrication component type in the Autodesk Revit MEP product.
Public class | FabricationRodInfo | The rod information of the fabrication part.
Public class | FabricationService | This object contains information about a fabrication service.
Public class | FabricationServiceButton | The object contains information about a fabricaton button.
Public class | FabricationServiceSettings | Represents the settings related to the fabrication services.
Public class | FabricationVersionInfo | The object contains versioning information about fabrication data.
Public class | Face | A bounded face of a 3d solid or open shell.
Public class | FaceArray | An array that contains faces.
Public class | FaceArrayIterator | An iterator to a face array.
Public class | FaceDetailNode | A base class of output nodes that represent face edges and face silhouettes.
Public class | FaceEdgeNode | An output node that represents a Face edge.
Public class | FaceNode | An output node that represents a Face.
Public class | FaceSecondDerivatives | Contains second partial derivatives of a face at a specified point.
Public class | FaceSilhouetteNode | An output node that represents a Face edge.
Public class | FaceSplitter | Represents an element that splits a face.
Public class | FacetingUtils | This class is used to convertTrianglesToQuads a triangulated structure into a structure in which some of the triangles have been consolidated into quadrilaterals.
Public class | FaceToposolid | An object that represents a face-based Toposolid within the Autodesk Revit project.
Public class | FaceWall | A wall attached to a non-vertical massing face.
Public class | FailureDefinition | Defines persistent information about a failure.
Public class | FailureDefinitionAccessor | A class that provides access to the details of a FailureDefinition after the definition has been defined.
Public class | FailureDefinitionId | The unique identifier of a FailureDefinition.
Public class | FailureDefinitionRegistry | The global registry for all FailureDefinitions in the Revit session.
Public class | FailureHandlingOptions | Options to control how failures (if any occurred during the transaction) should be handled at the time the transaction is being ended.
Public class | FailureMessage | Represents a message describing a failure of an operation in Revit.
Public class | FailureMessageAccessor | Restricted accessor for FailureMessage.
Public class | FailureMessageKey | A unique key assigned to each posted failure message
Public class | FailureResolution | Defines a resolution for a failure.
Public class | FailuresAccessor | An interface class that provides access to failure information posted in a document and methods to resolve these failures.
Family | An element that represents a custom family (not a system family) in Autodesk Revit.
FamilyElementVisibility | Provides access to the visibility parameters of family elements in family document.
FamilyInstance | This object represents a single instance of a family type, such as a single I beam.
FamilyInstanceFilter | A filter used to find elements that are family instances of the given family symbol.
Public class | FamilyManager | The family manager object to manage the family types and parameters in family document.
Public class | FamilyParameter | The family parameter object.
Public class | FamilyParameterSet | A set that contains FamilyParameter objects.
Public class | FamilyParameterSetIterator | An iterator to a FamilyParameter set.
Public class | FamilyPointLocation | Data corresponding to the point locations in certain types of Family Symbols.
Public class | FamilyPointPlacementReference | This object represents data corresponding to the placement references in a certain types of Family Instances (see examples listed below).
Public class | FamilySizeTable | Contains size information for a family.
Public class | FamilySizeTableColumn | Contains column information for a FamilySizeTable.
Public class | FamilySizeTableErrorInfo | Error information generated from the CSV file import of a FamilySizeTable.
Public class | FamilySizeTableManager | Manages importing, exporting, and querying size data through the FamilySizeTable class.
FamilySymbol | An element that represents a single type with a Family.
Public class | FamilySymbolFilter | A filter used to find all family symbols of the given family.
Public class | FamilySymbolProfile | Represents a family symbol based profile for sweep or swept blend elements.
Public class | FamilyThermalProperties | A class that contains thermal properties for specific types of families (doors, windows, and curtain wall panels).
Public class | FamilyType | The family type object provides read access to the values of family parameters for this type.
Public class | FamilyTypeSet | A set that contains FamilyType objects.
Public class | FamilyTypeSetIterator | An iterator to a FamilyType set.
Public class | FamilyUtils | Contains utilities related to family operations.
Public class | FBXExportOptions | 3D-Studio Max (FBX) Export options.
Public class | FilePath | This class represents a path on a disk or network location, but not a path to a Revit server location.
Public class | FilledRegion | A filled region element.
Public class | FilledRegionType | A filled region attributes element. Note, the forground pattern color is stored in the parent class
Public class | FillGrid | Represents a grid line in a fill pattern.
Public class | FillPattern | Represents a fill pattern object.
Public class | FillPatternElement | An element that represents a fill pattern.
Public class | FilterableValueProvider | Defines the interface for classes that extract values from elements in a Revit project for testing against filter rules.
Public class | FilterCategoryRule | A filter rule that matches elements of a set of categories.
Public class | FilterDoubleRule | A filter rule that operates on double-precision numeric values in a Revit project.
Public class | FilteredElementCollector | This class is used to search, filter and iterate through a set of elements.
Public class | FilteredElementIdIterator | An iterator to a set of element ids filtered by the settings of a FilteredElementCollector.
Public class | FilteredElementIterator | An iterator to a set of elements filtered by the settings of a FilteredElementCollector.
Public class | FilteredWorksetCollector | This class is used to search, filter and iterate through a set of worksets.
Public class | FilteredWorksetIdIterator | An iterator to a set of workset ids filtered by the settings of a FilteredWorksetCollector.
Public class | FilteredWorksetIterator | An iterator to a set of worksets filtered by the settings of a FilteredWorksetCollector.
Public class | FilterElement | The base class for filter elements in the document.
Public class | FilterElementIdRule | A filter rule that operates on ElementId values in a Revit project.
Public class | FilterGlobalParameterAssociationRule | A filter rule that operates on global parameters ElementId values in a Revit project.
Public class | FilterIntegerRule | A filter rule that operates on integer values in a Revit project.
Public class | FilterInverseRule | A filter rule that inverts the boolean values returned by the rule it contains.
Public class | FilterNumericEquals | Tests whether numeric values from the document are equal to a certain value
Public class | FilterNumericGreater | Tests whether numeric values from the document are greater than a certain value
Public class | FilterNumericGreaterOrEqual | Tests whether numeric values from the document are greater than or equal to a certain value
Public class | FilterNumericLess | Tests whether numeric values from the document are less than a certain value
Public class | FilterNumericLessOrEqual | Tests whether numeric values from the document are less than or equal to a certain value
Public class | FilterNumericRuleEvaluator | Base for all classes that compare numeric values from Revit to a user-supplied filter value.
Public class | FilterNumericValueRule | Base for all classes that use a FilterNumericRuleEvaluator to perform their comparisons
Public class | FilterOperatorAndTextString | An instance of this class holds a filter operator and a text string that denotes the operator in a particular context. For example, the text string for ScheduleFilterType::LessThan may be "is less than" for a filter rule based on a parameter with numerical values or "is below" for a filter rule based on a parameter representing a Level.
Public class | FilterRule | Defines a boolean operation that can be used to cull elements from a document.
Public class | FilterStringBeginsWith | Tests whether string values from the document begin with a certain string.
Public class | FilterStringContains | Tests whether string values from the document contain a certain string.
Public class | FilterStringEndsWith | Tests whether string values from the document end with a certain string.
Public class | FilterStringEquals | Tests whether string values from the document match a certain string.
Public class | FilterStringGreater | Tests whether string values from the document would sort after a certain string.
Public class | FilterStringGreaterOrEqual | Tests whether string values from the document would sort after or match a certain string.
Public class | FilterStringLess | Tests whether string values from the document would sort before a certain string.
Public class | FilterStringLessOrEqual | Tests whether string values from the document would sort before or match a certain string.
Public class | FilterStringRule | A filter rule that operates on string values in a Revit project.
Public class | FilterStringRuleEvaluator | Base for all classes that compare string values from Revit to a user-supplied filter value
Public class | FilterValueRule | A rule that filters on a particular value of an element.
Floor | An object that represents a Floor within the Autodesk Revit project.
FloorType | An object that specifies the type of a floor in Autodesk Revit.
Public class | FolderItemInfo | Contains data for each folder item in the organization settings of the project browser including folder parameter Id and folder name.
Public class | FootPrintRoof | Represents kinds of FootPrintRoofs.
Public class | ForgeTypeId | This class holds a string that uniquely identifies a Forge schema.
Public class | Form | An object that represents a Form within the Autodesk Revit Massing Family.
Public class | FormArray | An array that contains form objects.
Public class | FormArrayIterator | An iterator to a form array.
Public class | FormatOptions | Options for formatting numbers with units.
FormattedText | FormattedText is used to create, edit and format text in a TextNote or to query the text and format properties of a TextNode
Public class | FormatValueOptions | Options for formatting numbers with units into strings.
Public class | FormulaManager | A class to access and query information about formula engine in Revit models.
Public class | FormUtils | Define Form utility functions
Public class | Frame | A Frame comprises three vectors at a base point in 3D space.
Public class | FreeFormElement | A Free Form Element that contains non-parametric geometry created from an input solid outline.
Public class | GBXMLExportOptions | Green-Building XML Export options.
Public class | GBXMLImportOptions | Import options for Green-Building XML format.
Public class | GenericForm | Provides access to the Generic Form model in Autodesk Revit.
Public class | GenericImportOptions | Generic Import options.
Public class | GeomCombination | An element created by Join and Cut operations applied to combinable elements in an Autodesk Revit family document.
Public class | GeomCombinationSet | A set that contains GeomCombination objects.
Public class | GeomCombinationSetIterator | An iterator to a GeomCombination set.
Public class | GeometryCreationUtilities | A utility that allows construction of basic solid shapes.
Public class | GeometryElement | Geometric representation of an element.
Public class | GeometryInstance | An instance of another element (symbol), specially positioned by this element.
Public class | GeometryObject | The common base class for all geometric primitives.
Public class | GlobalParameter | This class represents a GlobalParameter element in Revit.
GlobalParametersManager | A class to access and query information about global parameters in Revit models.
Public class | GradientBackgroundSettings | Represents the view gradient background settings.
Public class | GraphicsStyle | The graphics style instance in Autodesk Revit document.
Grid | Represents a single grid line within Autodesk Revit.
Public class | GridType | An object that represents a grid type.
Group | An element representing a single instance of a group of elements that may be placed many times in a project or family.
Public class | GroupLoadOptions | A class containing options for loading a group from a file.
Public class | GroupNode | A node that represents set of individual elements grouped together in some form, such as an instance of a family or linked Revit file, or an instance of a part of symbol's geometry.
Public class | GroupSet | An set that contains groups.
Public class | GroupSetIterator | An iterator to a group set.
GroupType | An element representing a group of elements that may be placed many times in a project or family.
Public class | GroupTypeId | This class contains constants identifying parameter groups.
Public class | GuidEnum | Base class of all GUID-based enum classes.
Public class | HasNoValueFilterRule | Tests whether an element's parameter doesn't have a value.
Public class | HasValueFilterRule | Tests whether an element's parameter has a value.
HermiteFace | A cubic hermite spline face of a 3d solid or open shell.
Public class | HermiteSpline | A Hermite spline.
Public class | HermiteSplineTangents | This class indicates tangency at the start, the end, or both ends of the curve.
Public class | HermiteSurface | A Hermite Surface.
Public class | HomeCamera | A structure that contains information about the camera and view for the Home view orientation stored in the model.
Public class | HostedSweep | An object that represents an object hosted by an edge of a roof or floor within the Autodesk Revit project.
Public class | HostedSweepType | An object that represents the attributes for sweep host objects in Autodesk Revit.
Public class | HostObjAttributes | An object that represents characteristics of several kinds of type.
Public class | HostObject | A base class that provides support for all objects that can host other objects, such as walls roofs, and floors.
Public class | HostObjectUtils | These are generic host object utilities.
Public class | IFCBuiltInCategoryKey | A key used to represent an item stored in a template.
Public class | IFCCategoryTemplate | Represents an element that contains an IFC category mapping template stored in a Revit document.
Public class | IFCExportOptions | IFC Export options.
Public class | ImageBackgroundSettings | Represents the rendering image background settings.
Public class | ImageExportOptions | This class defines options for exporting views and sheets as an image.
Public class | ImageInstance | An element that represents an instance of an image placed in a view
Public class | ImagePlacementOptions | ImagePlacementOptions are used to describe where an ImageInstance should be placed in a view
Public class | ImageType | Represents a type containing a raster based image. ImageInstances of this type can be placed in 2D views, sheets, and schedules.
Public class | ImageTypeOptions | Represents the options used in ImageType::Create(Document, ImageTypeOptions) and ImageType.ReloadFrom(ImageTypeOptions) methods.
Public class | ImageView | Class for ImageView views
Public class | ImportIFCOptions | Provides access to settings that control linking and opening IFC files.
Public class | ImportInstance | An element created during either import or link operation. It is an instance of CADLinkType.
Public class | ImportOptions3DM | The import options used to import 3DM format files.
Public class | InCanvasControlData | Represents a collection of data which is used by [!:Autodesk::Revit::DB::TemporaryGraphicsManager] to create and update an in-canvas control.
Public class | IndependentTag | Represents tag annotations in Revit. getBBoxCorers in MultipleAlignmentHelper needs access to some protected members.
Public class | InsertableObject | A base class you all types that are insertable.
Public class | InSessionPrintSetting | Represents the in-session Print Setup (Application Menu->Print->Print Setup) within Autodesk Revit.
Public class | InSessionViewSheetSet | Represents the in-session ViewSheetSet.
Public class | Instance | The base class for all instance objects.
InstanceBinding | The InstanceBinding object is used to signify a binding between a parameter definition and a parameter on each instance of an element, such as a wall.
Public class | InstanceNode | An output node that represents an instance of a geometry. It can be an instance of FamilyInstance, or it can be and instance of a part of symbol's geometry.
Public class | InstanceVoidCutUtils | Utilities for cutting elements by unattached voids in family instances.
Public class | InsulationLiningBase | Acts as the base class for duct insulation, pipe insulation and duct lining elements.
Public class | IntegerParameterValue | A class that holds an Integer value of a parameter element.
Public class | IntegerRange | A class to define a range of a sequence of consecutive integer numbers
Public class | InternalDefinition | This object represents a parameter definition in an Autodesk Revit model.
Public class | InternalDefinitions | This object blocks attempts to create new internal definitions as they are not permitted.
Public class | InternalOrigin | A class representing the origin of internal coordinate system. Each Revit project contains one InternalOrigin.
Public class | IntersectingElementData | Stores information of an element that intersects with another element
Public class | IntersectionResult | This class captures results of intersecting geometric entities. "Intersecting" is meant in generalized sense, so the same class will be used for projection, containment, etc. Refer to the documentation of the method providing the result for the precise meaning of properties.
Public class | IntersectionResultArray | An array that can contain any type of object.
Public class | IntersectionResultArrayIterator | An iterator to a array.
Public class | JoinGeometryUtils | Utilities for joining and unjoining elements, and for managing the order in which elements are joined.
Public class | KeyBasedTreeEntries | A collection of KeyBasedTreeEntry objects that make up the key-based tree.
Public class | KeyBasedTreeEntriesIterator | An iterator to a set of KeyBasedTreeEntry objects.
Public class | KeyBasedTreeEntriesLoadContent | This class is used by IExternalResourceServers to return KeyBasedTreeEntries data to Revit when their LoadResource method is invoked.
Public class | KeyBasedTreeEntriesLoadResults | This class contains the results and status information regarding an attempt to load the KeyBasedTreeEntries from an External Resource.
Public class | KeyBasedTreeEntry | A key-based tree entry, containing the key, parent key, and children keys (if applicable).
Public class | KeyBasedTreeEntryError | This class contains information about a problem encountered while creating a KeyBasedTreeEntries object.
Public class | KeyBasedTreeEntryTable | KeyBasedTreeEntryTable represents the collection of key-based tree entries for a document.
Public class | KeynoteEntries | A collection of KeynoteEntry objects that make up the keynote table.
Public class | KeynoteEntry | Represents an entry in the keynote table, containing the key value, keynote text, and parent key (if applicable).
Public class | KeynoteTable | KeynoteTable represents the collection of keynotes (KeynoteEntries) for a document.
Public class | LabelUtils | Used to obtain user-visible names for enums.
Public class | LayerModifier | A modifier used to designate extra strings to appear in the exported layer name.
Public class | LayoutRule | The LayoutRule object is a base object for all type of layout rules for Beam System within the Autodesk Revit API.
LayoutRuleClearSpacing | This class indicate the layout rule of a Beam System is Clear-Spacing.
LayoutRuleFixedDistance | This class indicate the layout rule of a Beam System is Fixed-Distance.
LayoutRuleFixedNumber | This class indicate the layout rule of a Beam System is Fixed-Number.
LayoutRuleMaximumSpacing | This class indicate the layout rule of a Beam System is Max-Spacing.
Public class | Leader | A leader object that can be attached to annotation elements such as text notes.
Public class | LeaderArray | An array that can contain any number of leaders.
Public class | LeaderArrayIterator | An iterator to an array of leaders.
Level | Represents a Level within Autodesk Revit.
Public class | LevelAssociationData | This class holds information related to Level.
Public class | LevelType | An object that represents a Level type.
Public class | LightNode | This class represents a Light element in a model-exporting process.
Public class | Line | A line in space.
Public class | LineAndTextAttrSymbol | An object that represents a dimension style.
Public class | LinearArray | An object that represents an Array created linearly within the Revit project.
Public class | LinearDimension | LinearDimString
Public class | LinePattern | Represents a line pattern definition.
Public class | LinePatternElement | An element that represents a line pattern.
Public class | LinePatternSegment | Represents a segment in a line pattern.
Public class | LineProperties | A structure that has access to the pen properties of lines/curves that are currently being drawn/exported via an export context during a custom export process.
Public class | LineSegment | An output node that represents a tessellated line segment.
Public class | LinkConversionData | This class contains the information necessary to re-create a Revit document from an external source.
Public class | LinkElementId | LinkElementId represents an element in a linked document.
Public class | LinkLoadContent | This class is used by IExternalResourceServers to return Link data to Revit when their LoadResource method is invoked. It also contains additional information used by IExternalResourceUIServers to display link load status results to the user.
Public class | LinkLoadResult | This class stores the results of trying to load a single linked model.
Public class | LinkNode | An output node that represents a linked Revit document.
Public class | LinkOperations | This class is used to extend the IExternalResourceServer interface with methods to support operations for elements that are LinkTypes.
Public class | LoadedFamilyIntegrityCheck | Functions for checking the integrity of loaded families.
Location | Provides location functionality for all elements.
Public class | LocationCurve | Provides location functionality for all elements that are based upon a curve.
LocationPoint | Provides location functionality for all elements that have a single insertion point.
LogicalAndFilter | A filter that contains a set of filters. The filter passes when all filters in the set pass.
Public class | LogicalOrFilter | A filter that contains a set of filters. The filter passes when any filter in the set passes.
Public class | MassInstanceUtils | A static class that contains methods for processing curves driven by points.
Material | Represents a material element within an Autodesk Revit project.
Public class | MaterialNode | This class represents a change of material during a model-exporting process.
Public class | MathComparisonUtils | This class contains a set of mathematical utilities to compare doubles, using the internal tolerance.
Public class | MEPAnalyticalConnection | Represents an analytical element that connects mechanical equipment to piping network.
Public class | MEPAnalyticalConnectionType | Represents an analytical connection type between mechanical equipment and piping network.
Public class | MEPCalculationServerInfo | a struct to hold the information about a MEP calucation servers
Public class | MEPConnectorInfo | MEP connector information.
Public class | MEPCurve | A curve object for duct or pipe blend elements.
Public class | MEPCurveType | The base type class for MEP curves, such as ducts, pipes, cable trays and conduits.
Public class | MEPFamilyConnectorInfo | MEP family connector information.
Public class | MEPModel | Supports all MEP models that are persistent within the Autodesk Revit project.
Public class | MEPSize | Stores the basic size information for an MEP duct, pipe, cable tray, or conduit.
Public class | MEPSupportUtils | General utility methods for the Autodesk Revit MEP Supporting components.
Public class | MEPSystem | A system in the Autodesk Revit MEP product.
Public class | MEPSystemType | A system type in the Autodesk Revit MEP product.
Public class | Mesh | A triangular mesh.
Public class | MeshFromGeometryOperationResult | Describes what TessellatedShapeBuilder has built.
Public class | MeshTriangle | One triangle of a mesh.
Public class | ModelArc | Represents a ModelArc within Autodesk Revit.
Public class | ModelCurve | A model element that exists in 3D space and is visible in all views of a Revit project.
Public class | ModelCurveArrArray | An array that can contain any type of object.
Public class | ModelCurveArrArrayIterator | An iterator to a array.
Public class | ModelCurveArray | An array that contains model curves.
Public class | ModelCurveArrayIterator | An iterator to a model curve array.
Public class | ModelCurveNode | A base class of output nodes that represent various model curves.
Public class | ModelEllipse | Represents a ModelEllipse within Autodesk Revit.
Public class | ModelHermiteSpline | Represents a ModelHermiteSpline within Autodesk Revit.
Public class | ModelLine | Represents a ModelLine within Autodesk Revit.
Public class | ModelNurbSpline | Represents a ModelNurbSpline within Autodesk Revit.
Public class | ModelPath | A path to a file stored on a disk or on a server.
Public class | ModelPathUtils | Utility functions using ModelPaths
Public class | ModelText | A model text element in an Autodesk Revit family document.
Public class | ModelTextType | A model text type symbol in the Autodesk Revit Family document.
Public class | Mullion | Represents a CurtainGrid within Autodesk Revit.
Public class | MullionType | An object that represents a mullion type.
Public class | MullionTypeSet | A set that contains mullion types.
Public class | MullionTypeSetIterator | An iterator to a mullion type set.
Public class | MultipleValuesIndicationSettings | MultipleValuesIndicationSettings is an element which contains project-wide settings for multiple values indication in Properties Palette and schedules.
Public class | MultiReferenceAnnotation | Multi-reference annotations are annotations pointing to more than one reference, consisting of a dimension and associated tag.
Public class | MultiReferenceAnnotationOptions | Options which control the creation of MultiReferenceAnnotations.
Public class | MultiReferenceAnnotationType | The type for MultiReferenceAnnotation.
Public class | MultiSegmentGrid | This element acts as a multi-segmented Grid. The individual grids associated to the MultiSegmentGrid behave as a single unit and all share the same text. They inherit their type (GridType) from the MultiSegmentGrid.
Public class | NamingUtils | A collection of utilities related to element naming.
Public class | NavisworksExportOptions | Options which controls the Navisworks export.
Public class | NestedFamilyTypeReference | A proxy element representing a nested family type.
Public class | NullParameterValue | A class that represent an empty (null) value of a parameter element.
NumberingSchema | A class to support assigning numbers to elements of a particular kind for the purpose of tagging and scheduling them.
Public class | NumberingSchemaType | A type for identifying a NumberingSchema of a particular kind.
Public class | NumberingSchemaTypes | Provides a container of all Revit built-in NumberingSchemaType instances.
Public class | NumberingSchemaTypesStructuralNumberingSchemas | A collection of types of built-in Numbering Schemas that are used for numbering structure elements.
Public class | NumberSystem | An annotation that consists of a series of numeric tags attached to and describing a host element.
Public class | NumericRevisionSettings | Contains settings that apply to Revisions with the Numeric RevisionNumberType.
Public class | NurbSpline | A nurb spline.
Public class | NurbsSurfaceData | A class used to represent the definition of a NURBS surface.
Public class | OBJExportOptions | The export options used by exporting to OBJ file format.
Public class | OBJImportOptions | The import options used to import OBJ format files.
Public class OffsetSurface A mathematical representation of an offset surface.

Definition of offset surface, quoted from the STEP manual ISO 10303-42:2000(E): This is a procedural definition of a simple offset surface at a normal distance from the originating surface. Distance may be positive, negative, or zero to indicate the preferred side of the surface. The offset surface takes its parametrization directly from that of its basis surface, corresponding points having identical parameter values. The offset surface is parametrized as O(u, v) = S(u, v) + d*N(u, v), where N(u, v) is the oriented unit normal vector of the basis surface S at parameter value (u, v), and d is the signed offset distance.

In Revit, we restrict the types of basis surfaces for which an OffsetSurf can be created for the following reasons:

  • The offsets of Plane, CylindricalSurface, ConicalSurface and RevolvedSurface are of the same type as the original surface and they have closed form solutions. So those surfaces are not taken as basis surfaces of the OffsetSurface class. That leaves HermiteSurface and RuledSurface.
  • As a Revit surface, we require the OffsetSurface to be C2 continuous. That implies that the basis surface should be C3 continuous. That is because the OffsetSurface evaluation involves the normal of the basis surface and the order of continuity of the normal is one less than that of the surface.
  • HermiteSurfaces in general are not C3 continuous, even though some of them can be. A RuledSurface will be C3 continuous if its parametric curves are C3 continuous. So we don't allow a HermiteSurface to be a basis surface and allow only RuledSurfaces whose parametric curves are C3 continuous as basis surfaces of the OffsetSurface class.

The OffsetSurface class will own a copy of the basis surface and use it for many of its methods, which may implicitly assume that the OffsetSurface and the basis surface have the same envelope. So we keep the envelopes of the OffsetSurf and its basis surface in sync.

Opening | An opening in an Autodesk Revit project or family document.
Public class | OpenOptions | This class contains options available for opening a document from disk.
Public class | OptionalFunctionalityUtils | A collection of utilities that can be used to determine if a particular set of functionality is installed and available.
Public class | Options | User preferences for parsing of geometry.
Public class | OrdinateDimensionSetting | Represents a collection of Ordinate Dimension settings that can be associated to an ordinate DimensionType.
Public class | Outline | Outline is a generic object that provides a bounding box/bounding outline. It supports operations to scale and transform. It also supports intersections and contains operations.
Public class | OverrideGraphicSettings | Settings to override display of elements in a view.
Public class | Panel | This object represents a curtain panel.
Public class | PanelType | An object that represents a curtain panel type.
Public class | PanelTypeSet | A set that contains panel types.
Public class | PanelTypeSetIterator | An iterator to a panel type set.
Public class | PaperSize | An object that represents a Paper Size of Print Setup within the Autodesk Revit project.
Public class | PaperSizeSet | A set that can contain any number of paper size objects.
Public class | PaperSizeSetIterator | An iterator to a set of paper size objects.
Public class | PaperSource | An object that represents a Paper Source of Print Setup within the Autodesk Revit project.
Public class | PaperSourceSet | A set that can contain any number of paper source objects.
Public class | PaperSourceSetIterator | An iterator to a set of paper source objects.
Public class | Parameter | The parameter object contains the value data assigned to that parameter.
Public class | ParameterDownloadOptions | An option class used for downloading parameters from the Parameters Service.
Public class | ParameterElement | An Element that stores a user-defined parameter.
ParameterFilterElement Admits elements that satisfy two conditions:
  1. The element's category must be one of a certain set of allowed categories.
  2. The element must pass a series of filter rules.
Public class | ParameterFilterRuleFactory | Contains functions that create appropriate FilterRule objects based on the parameters given.
Public class | ParameterFilterUtilities | Contains static utility functions for enumerating the categories and parameters that are available for use by ParameterFilterElement objects.
Public class | ParameterMap | A map that can contain a mapping of a parameter name (a String) to a parameter.
Public class | ParameterMapIterator | An iterator to a map relating a parameter name (the key, a String) to a parameter.
Public class | ParameterSet | A set that contains parameters.
Public class | ParameterSetIterator | An iterator to a parameter set.
Public class | ParameterTypeId
Public class | ParameterUtils | A utility class of functions related to parameters.
Public class | ParameterValue | A class that holds a value of a parameter element.
Public class | ParameterValuePresenceRule | Tests whether an element's parameter has a value or not.
Public class | ParameterValueProvider | Gets the value of a parameter from any element passed to GetStringValue, GetDoubleValue, GetIntegerValue, or GetElementIdValue.
Public class | Part | This element represents a part of another element.
Public class | PartMaker | PartMaker is an element which takes some source elements (e.g., a wall with all its layers) and creates one or more Parts out of it. The logic according to which these Parts are created is non-trivial and PartMaker uses various PartMakerMethods which represents these logics. This element manages the strategy to make Part elements for one or more original elements.
Public class | PartMakerMethodToDivideVolumes | By-References dividing strategy used by PartMaker element. TODO_REFACTOR("LegacyMechanismOfMovingElements") returns true if - the Host Elements are not floors or walls - OR - the Host Elements that are referenced by this PartMaker are floors or walls - transformation has already been applied on those Host Elements
Public class | PartUtils | General Part utility methods
Public class | Path3d | Provides access to the Generic 3D path object in Autodesk Revit.
Public class | PDFExportOptions | Options for PDF export
PerformanceAdviser | The tool to report performance problems in a given document.
Public class | PerformanceAdviserRuleId | The unique identifier of a PerformanceAdviserRule
Public class | PerformanceAdviserRules | Provides a container of all Revit built-in PerformanceAdviserRuleId instances.
Public class | Phase | Represents a phase in the life of a building.
Public class | PhaseArray | An array that contains phase objects.
Public class | PhaseArrayIterator | An iterator to a phase array.
Public class | PhaseFilter | Represents an phase filter within Autodesk Revit.
PlanarFace | A bounded face of a 3d solid or open shell.
Public class | PlanCircuit | An object that represents an enclosed area in a plan view within the Autodesk Revit project.
Public class | PlanCircuitSet | A set that can contain any number of plan circuit objects.
Public class | PlanCircuitSetIterator | An iterator to a set of plan circuit objects.
Plane | A Planar surface.
Public class | PlanTopology | An object that represents a Plan Topology within the Autodesk Revit project.
Public class | PlanTopologySet | A set that can contain any number of plan topology objects.
Public class | PlanTopologySetIterator | An iterator to a set of plan topology objects.
PlanViewRange | This class represents the view range of a plan view or a plan region. It records the element ids of the levels which a plane is relative to and the offset of each plane from that level.
Public class | Point | A 3D point.
Public class | PointCloudInstance | Represents a single instance of a point cloud in the Revit document.
Public class | PointCloudType | Represents a type of point cloud loaded into a Revit document. Each PointCloudType maps to a single file or identifier (depending upon the type of Point Cloud Engine which governs it).
Public class | PointElementReference | Base class for objects defining a way to constrain a ReferencePoint to one or more other objects in a document.
Public class | PointLocationOnCurve | Defines the measurement parameters necessary to create a point at a specific location on a curve.
Public class | PointNode | An output node that represents a 3D point.
Public class | PointOnEdge | Define a ReferencePoint relative to a referenceable edge or curve on another element.
Public class | PointOnEdgeEdgeIntersection | Define a ReferencePoint at the intersection of two referenceable lines.
Public class | PointOnEdgeFaceIntersection | Define a ReferencePoint at the intersection of a referenceable edge or curve and a referenceable face.
Public class | PointOnFace | Define a ReferencePoint relative to a Face.
Public class | PointOnPlane | Define a ReferencePoint relative to a planar reference.
Public class | PointRelativeToPoint | Represents a point placed relative to another point.
Public class | PolyLine | A polyline.
Public class | PolylineNode | An output node that represents a 3D polyline.
Public class | PolylineSegments | An output node that represents a tessellated polyline segments.
Public class | PolymeshFacet | A class representing one triangular piece - a facet - in a polymesh topology.
Public class | PolymeshTopology | A class representing topology of a polymesh.
PrimaryDesignOptionMemberFilter | A filter used to find elements contained in any primary design option of any design option set.
Public class | PrimarySizeCriterion | This class contains a size criterion for a RoutingPreferenceRule.
PrintManager | The PrintManager object is used to configure the global print settings.
Public class | PrintParameters | An object that contains settings used for printing the document.
Public class | PrintSetting | Represents the Print Setup (Application Menu->Print->Print Setup) within Autodesk Revit.
Public class | PrintSetup | Represents the Print Setup (Application Menu->Print->Print Setup) within Autodesk Revit.
Profile | A geometric profile consisting of a loop of curves.
ProjectInfo | An object that represents a Project Information within the Autodesk Revit project.
ProjectLocation | A representation of a specific instance and location of the current project.
Public class | ProjectLocationSet | An set that contains project locations.
Public class | ProjectLocationSetIterator | An iterator to a project location set.
Public class | ProjectPosition | ProjectPosition is a class used to represent a geographical offset and rotation. It can be used to represent the position of a project.
Public class | PropertyLine | Represents kinds of PropertyLines.
Public class | PropertySetElement | An element that groups together a set of related parameters.
Public class | RadialArray | An object that represents an Array created along a circle arc within the Revit project.
Public class | RadialDimension | An object that represents an Radial Dimension within the Revit project.
Public class | Rectangle | Stores a set of four integers that represent the left, top, right and bottom of a rectangle.
Public class | Reference | A stable reference to a geometric object in a Revit model.
Public class | ReferenceableViewUtils | Utilities related to reference views such as reference sections and reference callouts.
Public class | ReferenceArray | An array that contains reference objects.
Public class | ReferenceArrayArray | An array that contains ReferenceArray objects.
Public class | ReferenceArrayArrayIterator | An iterator to a ReferenceArray array.
Public class | ReferenceArrayIterator | An iterator to a reference array.
ReferenceIntersector | A class used to find and return elements that intersect a ray created from an origin point and direction.
ReferencePlane | Represents a reference plane of Autodesk Revit.
Public class | ReferencePoint | A reference point in an Autodesk Revit family.
Public class | ReferencePointArray | An array that contains reference objects.
Public class | ReferencePointArrayIterator | An iterator to a reference array.
Public class | ReferenceWithContext | An object including a reference to a geometric object and related context, as instance transform etc.
Public class | RelinquishedItems | List of elements and worksets that were relinquished by the current user.
Public class | RelinquishOptions | Options to control behavior of relinquishing ownership of elements and worksets.
Public class | ReloadLatestOptions | Options to control behavior of pure reload latest (not part of synchronize with central).
Public class | ReloadSwapOutInfo | This object contains information about fabrication parts swapped out during reload.
Public class | RenderingImageExposureSettings | Represents the exposure settings of rendering.
Public class | RenderingQualitySettings | Represents the quality settings of rendering.
RenderingSettings | Represents the rendering settings for a 3d view.
Public class | RenderNode | This is the base class of all render nodes in a model-exporting process.
Public class | RepeaterBounds | Represents bounds of the array of repeating references in 0, 1, or 2 dimensions. (See RepeatingReferenceSource).
Public class | RepeaterCoordinates | Represents coordinates in the array of repeating references in 0, 1, or 2 dimensions.
Public class | RepeatingReferenceSource | Represents a collection of repeating references.
Public class | Revision | Represents a single revision in the project.
Public class | RevisionCloud | A RevisionCloud is a graphical "cloud" that can be displayed on a view or sheet to indicate where revisions in the model have occurred.
Public class | RevisionNumberingSequence | Defines the sequences by which numbers are assigned to Revisions.
Public class | RevisionSettings | Provides access to project-wide settings related to revisions.
Public class | RevitLinkGraphicsSettings | Settings to override display of Revit link in a view.
Public class | RevitLinkInstance | Represents an instance of a RevitLinkType.
Public class | RevitLinkOperations | This class is used to extend the IExternalResourceServer interface with methods to support operations specifically related to Revit links.
Public class | RevitLinkOptions | This class contains the options in use when creating or loading a Revit link.
Public class | RevitLinkType | This class represents another Revit Document ("link") brought into the current one ("host").
Public class | Revolution | A revolution solid or void form.
RevolvedFace | A revolved face of a 3d solid or open shell.
Public class | RevolvedSurface | A surface of revolution defined by a profile curve and a local coordinate system. The surface is obtained by rotating the curve around Z axis of the local coordinate system.
Public class | RoofBase | Represents all kinds of Roofs.
Public class | RoofType | Represents a specific type of roof.
Public class | RoutingCondition | RoutingCondition represents routing information that is used as input when determining if a routing criterion, such as minimum or maximum diameter, is met.
Public class | RoutingConditions | RoutingConditions contain routing information that is used as input when determining if a routing criterion, such as minimum or maximum diameter, is met.
Public class | RoutingCriterionBase | RoutingCriteriaBase is the base class for all routing criteria.
Public class | RoutingPreferenceManager | Manages default pipe segments, fittings, and selection criteria for a given MEPCurveType
Public class | RoutingPreferenceRule | A class representing a rule set in MEP routing preferences.
Public class | RPCNode | This class represents an RPC content in a model-exporting process.
RuledFace | A ruled face of a 3d solid or open shell.
Public class | RuledSurface | A ruled surface is created by sweeping a line between two profile curves or between a curve and a point (a point and a curve). Input curve(s) must be bounded or have natural bounds.
Public class | SATExportOptions | The export options used by exporting SAT format file. So far, there is no option in it.
Public class | SATImportOptions | The import options used to import SAT format files.
Public class | SaveAsOptions | This class contains options available for saving a document to disk with a new filename.
Public class | SaveOptions | This class contains options available for saving a document to disk.
Public class | SchedulableField | A non-calculated field eligible to be included in a schedule.
Public class | ScheduleDefinition | Settings that define the contents of a schedule.
Public class | ScheduleField | A field in a schedule.
Public class | ScheduleFieldId | The ScheduleFieldId object is used as a unique identification for a field in a schedule.
Public class | ScheduleFilter | A filter in a schedule.
Public class | ScheduleHeightsOnSheet | Heights information of a schedule on sheet.
Public class | ScheduleSheetInstance | An element that represents a particular placement of a schedule on a sheet.
Public class | ScheduleSortGroupField | A field that is used for sorting and/or grouping in a schedule.
Segment | This element represents a segment of an MEP curve object.
SelectionFilterElement | A filter element that stores an explicit list of ElementIds. Only elements whose ElementIds are in this list will pass the filter.
Public class | ServerPath | This class represents a path to a Revit Server location, rather than a location on disk or a network drive.
Settings | The settings object provides access to general components of the Autodesk Revit application, such as Categories.
Public class | ShapeBuilder | The base class for geometry builder classes.
ShapeImporter | A utility class that supports conversion of geometry stored in an external format into a Revit geometry objects.
Public class | SharedParameterApplicableRule | Tests whether an element supports a shared parameter.
Public class | SharedParameterElement | An element that stores the definition of a shared parameter which is loaded into the document.
Public class | SheetCollection | This class represents a sheet collection in Autodesk Revit.
SiteLocation | Contains the geographical location information for the project's site.
Public class | Sketch | Provides access to the Sketch in Autodesk Revit.
Public class | SketchBase | Provides access to the SketchBase in Autodesk Revit.
SketchEditScope | A SketchEditScope allows an application to create and maintain an editing session for a Sketch.
Public class | SketchedStairsCurveData | Sketched run/landing curves overrides with height and slope
SketchPlane | Represents a sketch plane or work plane.
Public class | SKPImportOptions | The import options used to import SKP format files.
Public class | SkyBackgroundSettings | Represents the rendering sky background settings.
Public class | SlabEdge | An object that represents a slab edge within the Autodesk Revit project.
Public class | SlabEdgeType | An object that represents the slab edge type in Autodesk Revit.
Public class | SlabShapeCrease | Represents a crease of a slab shape edited element.
Public class | SlabShapeCreaseArray | An array that can contain any number of creases used in Slab Shape Editing.
Public class | SlabShapeCreaseArrayIterator | An iterator to an array of creases used for Slab Shape Editing.
Public class | SlabShapeEditor | An object used for Slab Shape Editing.
Public class | SlabShapeVertex | Represents a vertex of a slab shape edited element.
Public class | SlabShapeVertexArray | An array that can contain any number of vertices used in Slab Shape Editing.
Public class | SlabShapeVertexArrayIterator | An iterator to an array of vertices used for Slab Shape Editing.
Solid | A 3d solid.
Public class | SolidCurveIntersection | This class represents the results of a calculation of intersection between a solid volume and a curve.
Public class | SolidCurveIntersectionOptions | This class contains the options used to calculate the intersection between a solid and a curve.
Public class | SolidGeometryOptions | A class containing optional information to control the geometry generation of the Solid by the SolidUtils routines.
Public class | SolidOptions | A class containing optional information to control the properties of the Solid generated by the GeometryCreationUtilities routines.
Public class | SolidOrShellTessellationControls | Controls various aspects of the triangulation produced by [!:SolidUtils::tessellateSolidOrShell()] method.
Public class | SolidSolidCutUtils | Exposes utilities which can cause one solid to cut another.
Public class | SolidUtils | Contains utility functions for solid operations.
Public class | SpacingRule | A rule for specifying a set of equidistant, parallel gridlines within a region.
Public class | SpanDirectionSymbol | Represents an instance of a Span Direction Symbol in Autodesk Revit.
Public class | SpatialElement | Represents an enclosed area or volume in the Revit model.
Public class | SpatialElementBoundaryOptions | Options that can be passed to a SpatialElementBoundaryCalculator to influence the results of the calculation.
Public class | SpatialElementBoundarySubface | SpatialElementBoundarySubface represents the geometry boundary information of spatial element.
Public class | SpatialElementCalculationLocation | The Spatial Element Calculation Location is used to specify the room/space where an element should be considered as placed.
Public class | SpatialElementCalculationPoint | SpatialElementCalculationPoint is used as the search point for family instances placement inside rooms and spaces.
Public class | SpatialElementDomainData | A base class for specific domain requirements for a spatial element.
Public class | SpatialElementFromToCalculationPoints | SpatialElementFromToCalculationPoints is used to specify the search points for a family instance which connects two rooms or spaces, such as a door or window. The points determine which room or space is considered the "from" and which is considered the "to".
SpatialElementGeometryCalculator | Use this class to calculate the geometry of a spatial element and obtain the relationships between the geometry and the element's boundary elements.
Public class | SpatialElementGeometryResults | The results of spatial element geometry calculation.
Public class | SpatialElementTag | A tag attached to a SpatialElement (room, space or area) in Autodesk Revit.
Public class | SpecTypeId | This class contains constants identifying specs.
Public class | SpecTypeIdBoolean | This class contains constants identifying Boolean specs.
Public class | SpecTypeIdInt | This class contains constants identifying integer specs.
Public class | SpecTypeIdReference | This class contains constants identifying reference specs.
Public class | SpecTypeIdString | This class contains constants identifying string specs.
Public class | SpecUtils | A utility class of functions related to specs. A spec describes a data type that parameters can hold.
SpotDimension | Object representing various types of SpotDimension
Public class | SpotDimensionType | A type element containing the properties of a spot elevation.
Public class | SSEPointVisibilitySettings | Represents the settings contained in the document associated to the point display of Floor, Roof and Toposolid. for serialization public api methods
StairsEditScope | StairsEditScope allows user to maintain a stairs-editing session.
Public class | StartingViewSettings | The initial view settings for a document dictate which view will initially be open when this model is opened. These settings are available for all Revit project documents.
Public class | StdPostedWarning | Support for Reviewable Warnings sent from AddOn.
Public class | STEPExportOptions | The export options used by exporting STEP format file.
Public class | STEPImportOptions | The import options used to import STEP format files.
Public class | STLExportOptions | The export options used by exporting STL format file.
Public class | STLImportOptions | The import options used to import STL format files.
Public class | StringParameterValue | A class that holds a String value of a parameter element.
Public class | StructuralAsset | Represents the properties of a material pertinent to structural analysis.
Public class | Subelement | An object that represents an element or a subelement within the Autodesk Revit project.
Public class | SubTransaction | Sub-transactions are objects that provide control over a subset of changes in a document.
SunAndShadowSettings | The SunAndShadowSettings class represents the sun control.
Public class | Surface | A mathematical representation of a surface.
Public class | Sweep | A sweep solid or void form.
Public class | SweepProfile | Represents a profile for sweep or swept blend elements.
Public class | SweptBlend | A swept blend solid or void form.
Public class | SweptProfile | Represents an extruded profile swept along a driving curve.
Public class | SymbolGeometryId | This class is used to identify a piece of geometry managed by a symbol element.
Public class | SymbolicCurve | A curve that provides information but is not intended to represent actual geometry in an element.
Public class | SymbolicCurveArray | An array that contains model curves.
Public class | SymbolicCurveArrayIterator | An iterator to a model curve array.
Public class | SymbolTypeId | This class contains constants identifying symbols.
Public class | SynchronizeWithCentralOptions | Options to control behavior of synchronization with central.
Public class | TableCellCalculatedValueData | The TableCellCalculatedValueData stores the data for calculated value
Public class | TableCellCombinedParameterData | The TableCellCombinedParameterData stores the data for combined parameters
Public class | TableCellStyle | The TableCellStyle class contains the appearance settings for a given table cell, column, or table.
Public class | TableCellStyleOverrideOptions | This helper class represents the overridden characteristics of the associated cell.
Public class | TableData | The TableData class is implemented to hold most of the data that describe the style of the rows, columns, and cells in a table.
Public class | TableMergedCell | The TableMergedCell class defines a merged area of the upper-left and lower-right of a table grid.
Public class | TableSectionData | The TableSectionData class represents a serialized version of an instance of section table data. The class holds row, column and cell data.
Public class | TableView | This represents a view that shows a table. Most of the layout data for the table is contained in the TableData class.
Public class | TemporaryGraphicsManager | A class that provides functionality to create temporary graphics in a Revit model.
TemporaryViewModes | A data structure containing data related to temporary view modes.
Public class | TessellatedBuildIssue | Types of issues encountered while constructing geometrical objects from the tessellated face sets.
Public class | TessellatedFace | Defines a planar face bounded by a polyline in 3d space. A face consists of a single connected component and can have holes.
TessellatedShapeBuilder | A class that permits structured building of geometry or a mesh from a collection of connected faces. Contains all closed face sets and custom precisions.
Public class | TessellatedShapeBuilderResult | Describes what TessellatedShapeBuilder has construct.
Public class | TextElement | Base class representing text elements in Revit.
Public class | TextElementType | An object that represents a text style.
Public class | TextNode | This class represents a text annotation object in a model-exporting process.
Public class | TextNote | A class representing text note annotations in Revit.
TextNoteOptions | Options to use when creating a new text note element.
Public class | TextNoteType | An object that represents a text note style.
Public class | TextRange | An object that is used to identify a range of characters in a FormattedText.
Public class | ThermalAsset | Represents the properties of a material pertinent to energy analysis.
Public class | ThermalProperties | Class specific to thermal properties for assembly types, such as Wall, Floor, Ceiling, Roof and Building Pad.
Public class | TilePattern | An object representing a tile pattern that may be applied to a DividedSurface.
Public class | TilePatterns | The TilePatterns object is an interface for retrieving the TilePattern objects within the Document.
Public class | Toposolid | An object that represents a Toposolid within the Autodesk Revit project.
Public class | ToposolidType | An object that specifies the type of a Toposolid in Autodesk Revit.
Transaction | Transactions are context-like objects that guard any changes made to a Revit model
Public class | TransactionGroup | Transaction groups aggregate a number of transactions.
TransactWithCentralOptions | Options to customize Revit behavior when accessing the central model.
Transform | A transformation of the affine 3-space.
Public class | Transform1D | An affine transform of 1D Euclidean space.
Public class | Transform2D | An affine transform of 2D Euclidean space.
Public class | TransformWithBoundary | This class contains the transform from model space to projection space for a view and the boundary in model space in which the transform is valid.
TransmissionData | A class representing information on all external file references in a document.
Public class | TriangleInShellComponent | This class represents a triangle in a TriangulatedShellComponent object. The triangle is defined by its vertices, which are specified by their indices in the TriangulatedShellComponent's array of vertices.
Public class | TriangulatedShellComponent | This class represents a triangulated boundary component of a solid or a triangulated connected component of a shell.
Public class | TriangulatedSolidOrShell | This class represents a triangulated solid or shell.
Public class | TriangulationInterface | This abstract class provides an interface for querying a triangulation structure (vertices and triangles).
Public class | TriangulationInterfaceForTriangulatedShellComponent | This class is used to call FacetingUtils::convertTrianglesToQuads with a triangulation defined by a TriangulatedShellComponent.
Public class | TriangulationInterfaceForTriangulatedSolidOrShell | This class is used to call FacetingUtils::convertTrianglesToQuads with a triangulation defined by a TriangulatedSolidOrShell.
Public class | TriOrQuadFacet | This class represents a triangle or quadrilateral in a faceted structure.
TypeBinding | TypeBinding objects are used to bind a property to a Revit type, such as a wall type.
Public class | UnitFormatUtils | A utility class for formatting and parsing numbers with units.
Public class | Units | A document's default settings for formatting numbers with units.
Public class | UnitTypeId | This class contains constants identifying units of measurement.
Public class | UnitUtils | A utility class of functions related to units.
Public class | UpdaterData | Service class that is passed to an Updater to prove access to update execution context
Public class | UpdaterId | A unique identifier of an Updater
Public class | UpdaterInfo | Information of an updater, such as: Name, AdditionalInformation, name of the application that owns the updater, etc.
Public class | UpdaterRegistry | An object that stores and manages all updaters registered in the current session.
Public class | UV | Object representing coordinates in 2-dimensional space.
Public class | ValidateCurveLoopsOptions | Options for array of curve loops validation.
Public class | ValueAtPointBase | A base class representing storage of values at a given point.
Public class | ValueParsingOptions | Options for parsing strings into numbers with units.
Public class | VertexIndexPair | Represents a connection between vertices in the top and bottom profile of a blend.
Public class | VertexIndexPairArray | An array that contains VertexIndex pairs.
Public class | VertexIndexPairArrayIterator | An iterator to an array of VertexIndex pairs.
Public class | VertexPair | Indices of a pair of vertices in two CurveLoops(one vertex in each loop).
View | Base class for all types of views in Autodesk Revit.
View3D | Class for 3D views
ViewCropRegionShapeManager | A class that provides access to settings related to the crop assigned to a view or a reference callout.
Public class | ViewDisplayBackground | Set of values that control how background is drawn in a view. Background can only be set for a 3d view or for a section or elevation view.
ViewDisplayDepthCueing | Represents the settings for depth cueing.
Public class | ViewDisplayModel | Represents the settings for displaying model graphics. version 2: m_showHiddenLines type changed bool -> ShowHiddenLinesValues::Enum
Public class | ViewDisplaySketchyLines | Represents the settings for sketchy lines.
Public class | ViewDrafting | ViewDrafting represents a drafting view within the model.
Public class | ViewFamilyType | Represents a type of a Revit view.
Public class | ViewNavigationToolSettings | Represents the settings contained in the document associated to the View Navigation tools (such as the View Cube).
Public class | ViewNode | A render node that represents a view.
Public class | ViewOrientation3D | Container for the point and vectors which define View3D's orientation.
Public class | ViewPlan | Represents floor plan, area plan, ceiling plan, and structural plan views in Revit.
Public class | Viewport | An element that establishes the placement of a view on a sheet.
Public class | ViewSchedule | A schedule view.
Public class | ViewScheduleExportOptions | The export options used to export schedule views.
Public class | ViewSection | ViewSection covers sections, details, elevations, and callouts, all in their reference and non-reference variations.
Public class | ViewSet | A set that contains views.
Public class | ViewSetIterator | An iterator to a view set.
Public class | ViewShapeBuilder | Builds and verifies a view-specific shape representation that would typically be stored in a DirectShape object. Currently limited to curve-based representations for plan and elevation views.
ViewSheet | Class for ViewSheet
Public class | ViewSheetSet | Represents ViewSheetSets stored in a document. ViewSheetSets can be stored so that the same printing task can be executed multiple times.
Public class | ViewSheetSetting | Represents the View/Sheet Set (Application Menu->Print) within Autodesk Revit.
Public class | VisibleInViewFilter | A quick filter that passes elements that are most likely visible in the given view.
Wall | Represents a wall in Autodesk Revit.
WallFoundation | An object that represents a wall foundation element.
Public class | WallFoundationType | An object that represents the type of a wall foundation in Autodesk Revit.
Public class | WallSweep | Represents a wall sweep or reveal.
Public class | WallSweepInfo | Represents a wall sweep or reveal of a vertically compound structure.
WallType | Represents a specific type of wall, such as 'Generic - 8"'.
Public class | WallUtils | General Wall utility methods
Public class | WireframeBuilder | Constructs a shape representation consisting of points and curves. That shape would typically be stored in a DirectShape or a DirectShapeType object.
Workset | Represents a workset in the document.
Public class | WorksetConfiguration | A configuration class that is passed in to methods that open Revit documents to specify which user-created worksets are opened/closed.
Public class | WorksetDefaultVisibilitySettings | An object that manages default visibility of worksets in a document.
Public class | WorksetFilter | A base class for a type of filter that accepts or rejects worksets based upon criteria.
Public class | WorksetId | WorksetId identifies a workset within a single document.
Public class | WorksetKindFilter | A filter used to match worksets of the given WorksetKind.
Public class | WorksetPreview | Represents an accessor for workset data which can be obtained from an unopened document.
Public class | WorksetTable | A table containing references to all the worksets contained in a document.
WorksharingDisplayGraphicSettings | Represents the graphical settings that can be assigned to elements in the worksharing display modes.
Public class | WorksharingDisplaySettings | WorksharingDisplaySettings controls how elements will appear when they are displayed in any of the worksharing display modes.
Public class | WorksharingSaveAsOptions | This class contains options specific to worksharing SaveAs.
Public class | WorksharingTooltipInfo | Worksharing information about a single element suitable for display in an in-canvas tooltip.
WorksharingUtils | A static class that contains utility functions related to worksharing.
Public class | XYZ | Object representing coordinates in 3-dimensional space.
Structures
 | Structure | Description
Public structure | GridNode | A structure that represents a particular location in (U,V) from a grid.
Interfaces
 | Interface | Description
Public interface | ICentralLockedCallback | An interface that may be used to control Revit's behavior when it tries to lock central and is blocked because another user already has locked central.
Public interface | IConnector | An interface which provides access to connector in Autodesk Revit MEP document.
Public interface | ICustomFieldProperties | Represents the base class for the properties of a custom field.
Public interface | IDataConversionMonitor | A base class for an application-specific logger. It should be used to track errors during conversion and/or , track conversion progress, cancel a conversion process if necessary. Implementing a logger class is optional, but highly recommended for all but most basic data converters. The base class is UI- and language-independent. It is up to the using app to implement UI. Language-specifc data may be used to communicate information to application users. English should be used to communicate data of interest to Revit development.
Public interface | IDuplicateTypeNamesHandler | An interface for custom handlers of duplicate type names encountered during a paste operation. When the destination document contains types that have the same names as the types being copied, but different internals, a decision must be made on how to proceed - whether to cancel the operation or continue, but only copy types with unique names.
Public interface | IExportContext | An interface that is used in custom export to process a Revit model.
Public interface | IExportContext2D | An interface that is used in custom export to export 2D views of a Revit model.
Public interface | IExportContextBase | An interface that as common base for IModelExportContext and IExportContext2D.
Public interface | IExtension | An interface that supports the additional operation for Extension Status
Public interface | IExternalDBApplication | An interface that supports addition of DB-level external applications to Revit, to subscribe to DB-level events and updaters.
Public interface | IExternalResourceServer | The interface used to provide custom implementation to provide access to external resources (such as linked files) from arbitrary locations.
 | IFailuresPreprocessor | An interface that may be used to perform a preprocessing step to either filter out anticipated transaction failures or to mark certain failures as non-continuable.
 | IFailuresProcessor | To create your own UI or fully automated tool to process Revit Failures, derive a class from this interface.
Public interface | IFamilyLoadOptions | An interface class which provide the callback for family load options.
Public interface | IGetLocalPathForOpenCallback | The interface used to provide custom support for the "Open (and Unload)" command for Revit Links obtained as external resources.
Public interface | IModelExportContext | An interface that is used in custom export to export 3D views of a Revit model.
Public interface | INavisworksExporter | The interface used to implement a Navisworks exporter.
Public interface | IOnLocalLinkSharedCoordinatesSavedCallback | A callback for notifying an IExternalResourceServer that shared coordinates changes have been saved back to one of the Revit or DWG links provided by that server.
 | IOpenFromCloudCallback | An interface that may be used to control Revit's behavior when opening a cloud model.
Public interface | IPerformanceAdviserRule | Base class to derive specific performance adviser rules from.
Public interface | IPhotoRenderContext | An interface that is used in custom export to render 3D views of a Revit model.
Public interface | IPrintSetting | An interface which represents the Print Setup (Application Menu->Print->Print Setup) within Autodesk Revit.
Public interface | ISaveSharedCoordinatesCallback | An interface that may be used to control Revit when trying to unload or reload a Revit link with changes in shared coordinates.
Public interface | ISaveSharedCoordinatesCallbackForUnloadLocally | An interface that is used to control Revit when trying to unload locally a Revit link with changes in shared coordinates.
Public interface | ITransactionFinalizer | An interface that may be used to perform a custom action at the end of a transaction. A method of the interface will be called when a transaction is either committed or rolled back.
Public interface | ITransientElementMaker | The interface to be implemented by an application that creates transient element(s) in Revit.
 | IUpdater | The interface used to create an updater capable of reacting to changes in the Revit model.
 | IViewSheetSet | This interface represents a selected set of views/sheets which will be used for printing.
Enumerations
 | Enumeration | Description
Public enumeration | ACADVersion | An enumerated type listing available AutoCAD versions, into which a file may be exported.
Public enumeration | ACAObjectPreference | An enumerated type listing possible ways to generate geometry of an ACA object Revit object parameters used to generate geometry of the exported ACA object. Revit object geometry is used to generate geometry of the exported ACA object. That may produce better geometric fidelity in some cases.
Public enumeration | AdaptivePointConstraintType | An enumerated type containing possible constraint types for Adaptive Points.
Public enumeration | AdaptivePointOrientationType | An enumerated type containing possible orientation types for Adaptive Points.
Public enumeration | AdaptivePointType | An enumerated type containing possible types for Adaptive Points.
Public enumeration | AllowedValues | A range of allowed values.
Public enumeration | AlternateUnits | An enumerated type listing the locations where Alternate units may be displayed in dimensions.
Public enumeration | AnalyzesAsType | This enum class is used for the BuiltInParameter STRUCTURAL_ANALYZES_AS.
Public enumeration | AreaElemType | An enumerated type to store type of AreaElement.
Public enumeration | ArrayAnchorMember | Represents the possible choices for how the translation or rotation is used to place each member of the array.
Public enumeration | AssemblyDetailViewOrientation | Orientation of the Assembly Detail View.
Public enumeration | AttachmentType | Enum determining whether a link is an attachment or an overlay
Public enumeration | AutomaticConnectionBehaviorType | Defines behavior of connector with respect to automatic creation of connections
Public enumeration | BackClippingParam | The allowed values for the VIEW_BACK_CLIPPING and VIEWER_BOUND_FAR_CLIPPING parameters.
Public enumeration | BackgroundImageFit | Indicates the background image fit type in rendering settings.
Public enumeration | BackgroundStyle | Indicates the background style in rendering settings.
Public enumeration | BaseLoadOn | An enumerated type listing all the possible power load use types for a space object.
Public enumeration | BeamSystemJustifyType | Describes the justify method of beamsystem.
Public enumeration | BehaviorType | An enumerated type listing all the behavior type for MEP Components.
Public enumeration | BendingDetailPositionOptions | An enumerated type listing the bending detail position options supported by the Bending Detail.
Public enumeration | BooleanOperationsType | An enumerated type listing boolean types that are supported for boolean operation.
Public enumeration | BorderTile | Options for controlling tiles that overlap the face boundary. See DividedSurface.
Public enumeration | BoxPlacement | An enumerated type containing possible constraint types for Adaptive Points.
Public enumeration | BRepBuilderOutcome | This class defines possible outcomes returned by BRepBuilder functions that need to report outcome via a return value.
Public enumeration | BRepBuilderState | This class defines an enumerative type used to specify the state of a BRepBuilder object.
Public enumeration | BRepType | This class defines an enumerative type used to specify the type of output geometry expected from a BRepBuilder.
Public enumeration | BrowserOrganizationType | Enumerated type representing the type of browser organization.
Public enumeration | BuildingType | This enumeration is used for specifying the most predominant building use type.
Public enumeration | BuiltInCategory | A list of all the built in categories within Revit.
Public enumeration | BuiltInParameter | An enumerated type listing all of the built-in parameter IDs supported by Autodesk Revit.
Public enumeration | CategoryType | The type of category.
Public enumeration | CellType | Declares the cell data type.
Public enumeration | ChangePriority | Enum used to specify the priority of an Updater during execution.
Public enumeration | CheckoutStatus | Indicates the ownership status of an element
Public enumeration | ColorDepthType | An enumerated type listing all Color Depth types of Print Setting.
Public enumeration | ColumnAttachmentCutStyle | Control the handling of columns that intersect their targets.
Public enumeration | ColumnAttachmentJustification | Control the column extent in cases where the target is not a uniform height.
Public enumeration | ComponentRotation | ComponentRotation property of DividedSurface. See DividedSurface.
Public enumeration | CompoundStructureError | When CompoundStructure::isValid() returns false, it uses these values to indicate precise nature of defect.
Public enumeration | ConnectionResolution | An enumerated type listing all the possible resolutions for connectivity validation.
Public enumeration | ConnectionWarning | An enumerated type listing all the reasons for connectivity failure.
Public enumeration | ConnectorDomainType | Type of connector domain.
Public enumeration | ConnectorGenderType | Connector gender type enum
Public enumeration | ConnectorJointType | Connector joint type enum
Public enumeration | ConnectorProfileType | An enumerated type listing all connector profile types
Public enumeration | ConnectorType | An enumerated type listing all connector types for a connection
Public enumeration | ContourSettingItemType | The type of a ContourSettingItem
Public enumeration | ControlShape | An enumerated type listing four shapes of control that Autodesk Revit supports.
Public enumeration | CoordinatePlaneVisibility | Visibility settings for ReferencePoint element's coordinate reference planes.
Public enumeration | CurtainGridAlignType | An enumerated to list CurtainGrid patterns.
Public enumeration | CurvedEdgeConditionParam | The allowed values for the HOST_SSE_CURVED_EDGE_CONDITION_PARAM parameter.
Public enumeration | CurveElementType | An enumerated type listing the curve element types that can be used when filtering elements (via CurveElementFilter).
Public enumeration | CurveProjectionType | This attribute indicates how the curve will be projected to the surface if the curve is sketched on the surface.
Public enumeration | CustomSubCategoryId | An enumerated type listing pseudo sub-categories that can appear in a mapping template. These types do not represent an independent category in Revit, but can be mapped to specific IFC entity.
Public enumeration | CutFailureReason | The reason why a solid-solid cut cannot be created.
Public enumeration | DataExchangeMessageId | Predefined message ids for DataExchangeLog.
Public enumeration | DataExchangeMessageSeverity | Error levels for DataExchangeLog
Public enumeration | DataExchangeMessageVerbosity | Predefined verbosity levels for DataExchangeLog
Public enumeration | DatumEnds | An enumerated type representing ends of a datum plane.
Public enumeration | DatumExtentType | Represents the type of datum extent that is displayed in a particular view.
Public enumeration | DecimalSymbol | The symbol used to separate the integer and fractional parts of a number.
Public enumeration | DeleteWorksetOption | This class defines an enumerative type used to specify the option to delete a workset.
Public enumeration | DetachFromCentralOption | Options for workset detachment behavior.
Public enumeration | DGNFileFormat | An enumerated type listing available Microstation versions into which a file may be exported.
Public enumeration | DigitGroupingAmount | The number of digits in each group when numbers are formatted with digit grouping.
Public enumeration | DigitGroupingSymbol | The symbol used to separate groups of digits when numbers are formatted with digit grouping.
Public enumeration | DimensionShape | An enumerated type to list dimension type.
Public enumeration | DimensionStyleType | An enumerated type containing possible style types of dimensions.
Public enumeration | DirectShapeReferencingOption | An enumerated type containing possible referencing options for DirectShapes.
Public enumeration | DirectShapeRoomBoundingOption | An enumerated type containing possible room bounding settings for DirectShapes.
Public enumeration | DirectShapeTargetViewType | View types for which DirectShape objects are allowed to have alternative shape representations
Public enumeration | DirectShapeTypeUserAssignability | Options for a DirectShapeType which affect whether or not it can be assigned as the type of a DirectShape.
Public enumeration | DisplacementPathStyle | Used to control the graphical representation of a DisplacementPath element.
Public enumeration | DisplayStyle | Display type of the view.
Public enumeration | DisplayUnit | Describes the type of Revit display unit, metric or imperial.
Public enumeration | DistanceMeasuredFrom | Indicates if the distance is measured from the top or bottom of the wall.
Public enumeration | DistributionOfNormals | An enumeration containing the choices of how normal vectors are assigned and distributed along the surface of a polymesh. Planar faces would typically have only normal vector associated, but curved faces can have a different normal either for each facet (triangle) or each point of the tessellated polymesh.
Public enumeration | DividedPathMeasurementType | DividedPath measurement type.
Public enumeration | DocumentType | Types of Revit documents.
Public enumeration | Domain | Type of connector domain.
Public enumeration | DoorEvacuationExitType | An enumerated type listing the possible door evacuation types
Public enumeration | DrawLayer | An enumerated type containing possible DrawLayer options.
Public enumeration | DuplicateTypeAction | This enumerated type defines the action to be taken when there are types with the same name being pasted.
Public enumeration | DWFImageFormat | An enumerated type listing possible image format for DWF Export.
Public enumeration | DWFImageQuality | An enumerated type listing possible image quality for DWF Export.
Public enumeration | EaveCutterType | An enumerated type to store type of EaveCutter.
Public enumeration | ElementOnPhaseStatus | The statuses that an element can have with respect to a given phase.
Public enumeration | ElementReferenceType | Element reference types.
Public enumeration | ElementTypeGroup | The element type group.
Public enumeration | EndCapCondition | Used by CompoundStructure to describe which shell layers participate in end wrapping.
Public enumeration | EntryAndSchemeConsistency | Enumeration used to specify why an entry is inconsistent with a scheme or another entry.
Public enumeration | ExportColorMode | An enumerated type listing export color mode.
Public enumeration | ExportColumnHeaders | Options for exporting column headers in schedule view export.
Public enumeration | ExportEnergyModelType | This enum is used to define if energy model used for gbXML export should be based on rooms/spaces, building elements or analysis mode in EnergyDataSettings.
Public enumeration | ExportPaperFormat | Paper formats supported by export
Public enumeration | ExportRange | This enum is used to define what view, part of the view, or list of views will be exported.
Public enumeration | ExportResolution | An enumerated type listing possible options to control the tessellation quality.
Public enumeration | ExportSheetType | An enumerated type listing possible Sheet type.
Public enumeration | ExportTextQualifier | Options for the text qualifier character in schedule view export.
Public enumeration | ExportUnit | An enumerated type listing possible target units for CAD Export.
Public enumeration | ExternalDBApplicationResult | Informs Autodesk Revit of the status of your external db application after execution.
Public enumeration | ExternalFileReferenceType | Enum class indicating kinds of external file references
Public enumeration | ExternallyTaggedNonBRepUsage | The ways in which an ExternallyTaggedNonBRep can be used in Revit.
Public enumeration | ExternalResourceLoadStatus | A flag to indicate the status of an ExternalResource load request.
Public enumeration | ExternalResourceUIBrowseResultType | Describes the type of external resource browsing result.
Public enumeration | ExtrusionAnalyzerFaceAlignment | Indicates whether a face of the solid analyzed by ExtrusionAnalyzer is fully aligned, partially aligned, or unaligned with faces of the extrusion.
Public enumeration | FabricationDimensionType | Fabrication dimension type.
Public enumeration | FabricationDimensionUnitType | Fabrication dimension unit type.
Public enumeration | FabricationMaterialType | An enumerated type listing all fabrication material types.
Public enumeration | FaceIntersectionFaceResult | An enumerated type listing the possible results of a face-face intersection calculation.
Public enumeration | FailureProcessingResult | An enumerated type representing the result achieved by any of the available types of failure handlers: FailuresPreprocessor, the handler of FailuresProcessing event or a FailuresProcessor.
Public enumeration | FailureResolutionType | Enumeration to classify FailureResolutions by nature of operation they perform on failing Elements.
Public enumeration | FailureSeverity | Enum represents severity of a failure.
Public enumeration | FamilyElementVisibilityType | Indicates the Visibility type of generic forms.
Public enumeration | FamilyHostingBehavior | Types of hosts into/onto which a family can be hosted. For informative purposes only. Does not affect anything in Revit!
Public enumeration | FamilyInstanceReferenceType | Corresponds to the possible values of parameter "Is Reference" of reference planes and parameter "Reference" of reference lines in families. This enum is used to identify references of family instances corresponding to reference planes and reference lines in the family.
Public enumeration | FamilyNestingBehavior | This attribute describes the family nesting behavior.
Public enumeration | FamilyPlacementType | The type of placement required for a given family.
Public enumeration | FamilySizeTableErrorType | The set of errors that can be returned when importing a FamilySizeTable from a CSV file.
Public enumeration | FamilySource | Describes which version of the family to be loaded.
Public enumeration | FillPatternHostOrientation | The types of orientations for fill patterns.
Public enumeration | FillPatternTarget | The type of the fill pattern.
Public enumeration | FindReferenceTarget | The type of reference to find from a ReferenceIntersector.
Public enumeration | FitDirectionType | This enum is used to define the direction to fit the number of pixels defined by PixelSize.
Public enumeration | FittingAndAccessoryCalculationType | The MEP fitting and accessory pressure drop calculation type.
Public enumeration | FittingAngleUsage | An enumerated type representing the options for how to limit the angle values applicable to fitting content.
Public enumeration | FloorFace | An enumerated type listing floor face types (top or bottom)
Public enumeration | FlowDirectionType | An enumerated type listing direction types for a connector.
Public enumeration | FormatStatus | An enumerated type indicating the formatting status of a range of characters in FormattedText
Public enumeration | FramingShapeClassification | This enumeration is used to classify MEP Ancillary Framing shape.
Public enumeration | GraphicsStyleType | Describes the type of graphics style.
Public enumeration | GridNodeLocation | Location of a grid node relative to the face boundary. See DividedSurface.
Public enumeration | GridSegmentDirection | Specify one of the four adjacent segments to a GridNode. See DividedSurface.
Public enumeration | HiddenLineViewsType | An enumerated type listing all Hidden Line Views types of Print Setting.
Public enumeration | HorizontalAlign | Horizontal alignment of model text.
Public enumeration | HorizontalAlignmentStyle | Declares the horizontal alignment style of font.
Public enumeration | HorizontalTextAlignment | Supported types of horizontal alignment of a text element and text justification within the text containing box.
Public enumeration | IFCExportElement | An enumerated type defining if an element is exported to IFC or not.
Public enumeration | IFCExportElementType | An enumerated type defining if an element type is exported to IFC or not.
Public enumeration | IFCVersion | An enumerated type listing available IFC file versions into which a file may be exported.
Public enumeration | ImageFileType | This enum is used to define exported file type.
Public enumeration | ImageResolution | This enum is used to define image resolution in order to calculate the image size.
Public enumeration | ImageTypeSource | The source of the data used to generate the image.
Public enumeration | ImageTypeStatus | Indicates the current state of the contents of the ImageType.
Public enumeration | ImportColorMode | An enumerated type listing how colors are handled in an import process.
Public enumeration | ImportExportFileFormat | Describes formats supported by import / export.
Public enumeration | ImportPlacement | An enumerated type listing possible placement modes for imported drawings.
Public enumeration | ImportUnit | An enumerated type listing possible target units for CAD Import.
Public enumeration | InsertOrientation | The allowed values for the INSERT_ORIENTATION parameter.
Public enumeration | IntersectionType | Intersection type.
Public enumeration | JoinType | The type of join at the end of an element. The join type affects only the graphic treatment, i.e. cleaning of the end, not the physical join behavior.
Public enumeration | JunctionType | An enumerated type listing all the junction types for MEP curve types.
Public enumeration | KeyBasedTreeEntryErrorType | An Enum indicating the type of error associated with a KeyBasedTreeEntry.
Public enumeration | LabelType | The label type in dimension equality formats.
Public enumeration | LayerCategoryType | An enumerated type listing category types supported in an ExportLayerTable.
Public enumeration | LeaderAtachement | Supported types of vertical attachments of a leader to a text note.
Public enumeration | LeaderEndCondition | An enumerated type listing Leader end conditions that are supported for IndependentTags.
Public enumeration | LeaderShape | Supported geometric shapes of annotation leaders.
Public enumeration | LeadersPresentationMode | Leaders Presentation Mode.
Public enumeration | LightAndMaterialAccuracyMode | An enumerated type containing possible Light and Material Accuracy modes for Raytracer render.
Public enumeration | LightingSource | Indicates the lighting scheme type in rendering settings.
Public enumeration | LinePatternSegmentType | Represents the type of a line pattern segment.
Public enumeration | LineScaling | An enumerated type listing possible LineType scaling modes.
Public enumeration | LinkedFileStatus | Enum displaying the loaded status of a linked file
Public enumeration | LinkLoadResultType | Enum listing the possible results after loading a linked model.
Public enumeration | LinkOriginFileType | Enum determining whether the source type of a temporary rvt link is an ifc.
Public enumeration | LinkVisibility | Link visibility types.
Public enumeration | ListType | An enumerated type indicating the style of list item for paragraphs that are part of ordered or unordered lists in FormattedText.
Public enumeration | LoadOperationType | An enum indicating whether a resource load operation was triggered by a user action or an automatic process.
Public enumeration | MarginType | An enumerated type listing all Margin types of Print Setting.
Public enumeration | MassDisplayTemporaryOverrideType | This enum identifies the mass display overrides.
Public enumeration | MaterialAspect | A list of all material aspects that a material can store PropertySetElements for.
Public enumeration | MaterialFunctionAssignment | Used in class CompoundStructure to specify the function of a layer.
Public enumeration | MaterialPropertyPathType | Enum class indicating kinds of paths which ExternalFileReferenceType.Material references can have.
Public enumeration | MEPSystemClassification | This enumeration is used to classify MEP connectors and systems and drives certain behavior for a particular system type
Public enumeration | MeshFromGeometryOperationIssue | Issues encountered while constructing meshes as fallbacks for geometrical operations.
Public enumeration | ModelUpdatesStatus | Indicates whether an element in the current model has additional user changes in the central model.
Public enumeration | ModifierType | An enumerated type listing options to appear in the exported layer name.
Public enumeration | NavisworksCoordinates | An enumerated type listing possible Coordinates of Navisworks Exporter.
Public enumeration | NavisworksExportScope | An enumerated type listing possible "Element Scopes" of Navisworks Exporter.
Public enumeration | NavisworksParameters | An enumerated type listing possible "Parameter conversions" of Navisworks Exporter.
Public enumeration | NumberSystemDisplayRule | The available options for display of numeric values in the number system.
Public enumeration | NumberSystemJustifyOption | The available options for justification of the numbers in a number system.
Public enumeration | OpenConflictResult | The result of the open conflict.
Public enumeration | OpenConflictScenario | The kinds of conflicts happened during open.
Public enumeration | OpenForeignOption | Options for opening files saved by an application that was not developed or licensed by Autodesk.
Public enumeration | OpeningWrappingCondition | Used by CompoundStructure to describe which shell layers participate in wrapping at openings.
Public enumeration | OrdinateDimensionLineStyle | The ordinate dimension line style.
Public enumeration | OrdinateOriginVisibility | The ordinate origin visibility.
Public enumeration | OrdinateTextOrientation | The ordinate dimension text orientation.
Public enumeration | OrdinateTextPosition | The ordinate dimension text position.
Public enumeration | OverridePermissions | Types of overrides that can be applied to a category.
Public enumeration | PageOrientationType | An enumerated type listing all Page Orientation types of Print Setting
Public enumeration | PaperPlacementType | An enumerated type listing all Paper Placement types of Print Setting.
Public enumeration | ParametersOrder | The order of the parameters.
Public enumeration | PartEdgeConditionOrientation | Relative orientation of the right/lower and left/upper edge condition profiles.
Public enumeration | PartsVisibility | Indicates the visibility of parts for the view.
Public enumeration | PartType | An enumerated type listing all MEP family part types. A part type typically provides one unique set of type parameters that defines this part.
Public enumeration | PathType | Enum determining what kind of path a given external file reference path is. Paths are valid for all types of external file references unless otherwise specified.
Public enumeration | PDFExportQualityType | An enumerated type listing the options for PDF export quality.
Public enumeration | PhaseStatusPresentation | An enumerated type listing the options for element display in a phase filter.
Public enumeration | PlanViewDirection | This enumerated type represents the possible directions for a plan view.
Public enumeration | PlanViewPlane | Locations where view range offsets can be specified.
Public enumeration | PlanViewRangeError | Describes errors in the location of planes in a PlanViewRange object.
Public enumeration | PlanViewRangeLevel | An enumerated type representing the options for setting the range for a plan view.
Public enumeration | PointCloudColorMode | Color mode of a point cloud or part of a point cloud
Public enumeration | PointCloudFoundStatus | Enumerated type representing the possible states related to searching for a point cloud file.
Public enumeration | PointOnCurveMeasureFrom | Point on curve MeasureFrom - It tells from which end of the host curve the point location is measured.
Public enumeration | PointOnCurveMeasurementType | Point on curve measurement type Defines the types of measurements that may be used when placing a point at a designated distance along a curve.
Public enumeration | PreferredJunctionType | Enumerated type representing the possible options for the preferred junction for a routine preference rule.
Public enumeration | PreviewFamilyVisibilityMode | Modes that control visibility of family elements depending on the currently applied Element Visibility Settings of a view.
Public enumeration | PrinterResolution | Controls the resolution level in rendering settings.
Public enumeration | PrintRange | An enumerated type listing all Print Range types of Print.
Public enumeration | ProfileFamilyUsage | An enumerated type listing all types of profile families.
Public enumeration | ProfilePlaneLocation | Indicates the location of Sweep profile plane on the path curve.
Public enumeration | PropOverrideMode | An enumerated type listing ways how overridden object styles get exported.
Public enumeration | RasterQualityType | An enumerated type listing the options for raster quality.
Public enumeration | RectangularGridSegmentOrientation | The orientation type of rectangular grid segment.
Public enumeration | ReferenceBaseOnHostType | This enumeration is used to classify the Reference Base on Host type .
Public enumeration | ReferenceType | Reference types of curve element.
Public enumeration | RenderDuration | An enumerated type containing possible duration types to do Raytracer render.
Public enumeration | RenderingQuality | Indicates the rendering quality in rendering settings.
Public enumeration | RenderNodeAction | Enumerated actions for processing a render node during custom export.
Public enumeration | ResolutionTarget | Indicates the resolution target(Screen or Printer) used for rendering settings.
Public enumeration | ResourceVersionStatus | An enum indicating whether a resource is current or out of date.
Public enumeration | RevisionNumbering | The options for how revision numbers should be displayed on sheets within a project.
Public enumeration | RevisionNumberType | Determines how a particular revision will be numbered.
Public enumeration | RevisionVisibility | Determines whether Revision Clouds and Revision Tags will be visible in the project.
Public enumeration | RoundingMethod | Rounding methods
Public enumeration | RoutingPreferenceErrorLevel | An enumerated type listing the options for posting errors or warnings when routing preferences are not satisfied.
Public enumeration | RoutingPreferenceRuleGroupType | Add more rule group type here.
Public enumeration | RowHeightOverrideOptions | Describes the options for overriding schedule body row heights (applied when viewed as a ScheduleSheetInstance on a ViewSheet).
Public enumeration | SaveModifiedLinksOptions | Class giving options when saving linked files which have been modified in-memory by shared coordinates operations.
Public enumeration | SaveModifiedLinksOptionsForUnloadLocally | Class giving options when saving linked files which are unloaded locally and have been modified in-memory by shared coordinates operations.
Public enumeration | ScheduleFieldDisplayType | Display type of schedule field.
Public enumeration | ScheduleFieldMultipleValuesDisplayType | Define how the schedule field's multiple value is displayed.
Public enumeration | ScheduleFieldType | The type of data displayed in a schedule field.
Public enumeration | ScheduleFilterType | Type of schedule filter.
Public enumeration | ScheduleHeadingOrientation | Orientation of schedule heading.
Public enumeration | ScheduleHorizontalAlignment | Horizontal alignment of data in a schedule.
Public enumeration | ScheduleSortOrder | Options for sort order of rows in a schedule.
Public enumeration | ScheduleVerticalAlignment | Vertical alignment of data in a schedule.
Public enumeration | SectionType | Declares the section data type.
Public enumeration | SelectionFilterAction | An enumerated type containing the type of actions that may be taken with a selection filter applied to a point cloud.
Public enumeration | ServiceType | This enumeration is used for specifying the most predominant service for the building or space.
Public enumeration | SetComparisonResult | An enumerated type listing all the relationship types between two sets of arbitrary nature.
Public enumeration | ShapeImporterSourceFormat | An enumerated type listing the possible formats supported by the Shapeimporter.
Public enumeration | SheetDuplicateOption | Options for duplicating sheets
Public enumeration | ShellLayerType | Used to distinguish exterior and interior shell layers.
Public enumeration | ShowHiddenLinesValues | Provides options for display of hidden lines in a given view.
Public enumeration | SimpleWorksetConfiguration | Indicates the set of user-created worksets to open in memory
Public enumeration | SlabShapeCreaseType | The type of a SlabShapeCrease
Public enumeration | SlabShapeVertexType | The type of a SlabShapeVertex
Public enumeration | SlantedOrVerticalColumnType | This enum class is used for the BuiltInParameter SLANTED_COLUMN_TYPE_PARAM.
Public enumeration | SolidCurveIntersectionMode | Represents the types of results available for calculating the intersection between a solid and a curve.
Public enumeration | SolidGeometry | An enumerated type listing possible ways of exporting solids in 3D views.
Public enumeration | SortingOrder | Enumerated type representing the sorting order of a collection of objects.
Public enumeration | SpacingRuleJustification | Justification property of spacing rule
Public enumeration | SpacingRuleLayout | Rules for laying out a series of equidistant points or parallel lines
Public enumeration | SpatialElementBoundaryLocation | An enumerated type listing boundary options of spatial element geometry calculation.
Public enumeration | SpatialElementTagOrientation | An enumerated type listing tag orientation options that are supported by SpatialElementTags.
Public enumeration | SpatialElementType | An enumerated type listing types of spaces.
Public enumeration | SpecialType | An enumerated type listing special types that can appear in an ExportLayerTable. These types do not represent an independent category in Revit, but can be mapped to specific layers on export.
Public enumeration | STEPApplicationProtocol | An enumeration for STEP Application Protocols.
Public enumeration | StickSymbolLocation | Indicates the stick symbol location on the UI, which is used for the BuiltInParameter STRUCTURAL_STICK_SYMBOL_LOCATION.
Public enumeration | StiffenerClassification | This enumeration is used to classify the stiffener.
Public enumeration | StorageType | An enumerated type listing all of the internal parameter data storage types that Autodesk Revit supports.
Public enumeration | StripedRowPattern | An enumerated type representing the possible sets of rows of a striped row schedule.
Public enumeration | StructDeckEmbeddingType | Used in class CompoundStructure to specify the usage of a layer whose function is StructuralDeck.
Public enumeration | StructuralAssetClass | Represents the type of material described by a structural asset. This enum value is returned by Autodesk::Revit::DB::StructuralAsset::StructuralAssetClass.
Public enumeration | StructuralBehavior | Specifies whether structural elements behave orthotropically, isotropically, or transverse-isotropically.
Public enumeration | StructuralReleaseType | Type of structural release, which is used for the BuiltIn parameter STRUCTURAL_END_RELEASE_TYPE.
Public enumeration | SubfaceType | Meaning of a subface's type.
Public enumeration | SunAndShadowType | Sun study type enum of SunAndShadowSettings.
Public enumeration | SunStudyTimeInterval | Time interval enum for a single or multi-day sun study.
Public enumeration | TagHeadAlignment | An enumerated type listing the tag-head alignment options supported by the Bending Detail.
Public enumeration | TagHeadPositionOptions | An enumerated type listing the tag-head position options supported by the Bending Detail.
Public enumeration | TagMode | The modes of tag creation that are supported for IndependentTags.
Public enumeration | TagOrientation | An enumerated type listing tag orientation options that are supported by IndependentTags.
Public enumeration | TagOrientationBehavior | This attribute describes the family orientation behavior.
Public enumeration | TemporaryViewMode | Enumeration to represent the various temporary view modes a view can be in.
Public enumeration | TessellatedBuildIssueType | Types of issues encountered while constructing geometrical objects from the tessellatted face sets.
Public enumeration | TessellatedShapeBuilderFallback | Describes what TessellatedShapeBuilder function should do, if it cannot build a requested TessellatedShapeBuilderTarget.
Public enumeration | TessellatedShapeBuilderOutcome | Describes the outcome of TessellatedShapeBuilder attempt to build geometrical objects.
Public enumeration | TessellatedShapeBuilderTarget | Describes what TessellatedShapeBuilder should generate, if possible.
Public enumeration | TextAlignFlags | An enumerated type listing all the Text align flags.
Public enumeration | TextAlignMask | An enumerated type listing all the Text align mask.
Public enumeration | TextBaselineStyle | Supported styles of text position relative to the normal baseline.
Public enumeration | TextElementBackground | An enumerated type listing all the background mode for the built-in parameter TEXT_BACKGROUND.
Public enumeration | TextListStyle | Supported styles of text list paragraphs.
Public enumeration | TextNoteLeaderStyles | An enumerated type listing all the Leader styles.
Public enumeration | TextNoteLeaderTypes | Types of text-note leaders
Public enumeration | TextTreatment | An enumerated type listing possible text treatment modes.
Public enumeration | ThermalMaterialType | Represents the thermal material type.
Public enumeration | TilePatternsBuiltIn | Revit's built-in tile patterns. See TilePattern.
Public enumeration | TransactionStatus | An enumerated type listing the possible statuses associated with a Transaction, TransactionGroup, or SubTransaction, or the result of a particular method call on one of those objects.
Public enumeration | TransmittedModelOptions | Enum giving desired behavior when opening or saving a transmitted workshared model.
Public enumeration | UnderlayOrientation | Indicates how elements in the underlay are viewed.
Public enumeration | UnitSystem | A system of measurement: Metric or Imperial units.
Public enumeration | UVGridlineType | A choice between U-gridlines or V-gridlines of a divided surface U Gridlines V Gridlines
Public enumeration | ValueAtPointFlags | Enumerated type containing flags related to the display on particular points. Enumerated type that stores bit values of flags that can be set at any domain point.
Public enumeration | VerticalAlignmentStyle | Declares the vertical alignment style of font.
Public enumeration | VerticalTextAlignment | Supported types of vertical alignment of a text element.
Public enumeration | ViewDetailLevel | Detail level of the view
Public enumeration | ViewDiscipline | Discipline of the view
Public enumeration | ViewDisplayBackgroundImageFlags | A collection of bit flags that control how the background image is positioned in relation to the crop region (or the view boundary).
Public enumeration | ViewDisplayBackgroundType | A collection of settings defining the type of the view background
Public enumeration | ViewDisplayEdges | A collection of settings defining how visible edges are displayed
Public enumeration | ViewDuplicateOption | Options for duplicating views
Public enumeration | ViewFamily | An enumerated type that corresponds to the type of a Revit view.
Public enumeration | ViewPlacementOnSheetStatus | Indicates whether the View is placed on a Sheet.
Public enumeration | ViewPlanType | An enumerated type listing plan view types.
Public enumeration | ViewportPositioning | An enumerated type listing of viewport positioning options on the sheet when swapped to another view.
Public enumeration | ViewportRotation | Rotation of the viewport
Public enumeration | ViewTemplateApplicationOption | Options for applying view templates
Public enumeration | ViewType | An enumerated type listing available view types.
Public enumeration | VirtualPrinterType | An enumerated to list Virtual Printer Types in Revit.
Public enumeration | Visibility | Describes the visibility of a particular geometry object.
Public enumeration | WallCrossSection | The allowed values for the WALL_CROSS_SECTION parameter.
Public enumeration | WallFunction | Indicates the function of a specified WallType, as specified in the parameter FUNCTION_PARAM on the WallType.
Public enumeration | WallKind | Describes the fundamental type of wall, such as curtain wall or stacked wall.
Public enumeration | WallLocationLine | This enumerated type represents the options for alignment of a wall's location line.
Public enumeration | WallSide | Represents the possible sides of a wall where a sweep or reveal may be attached.
Public enumeration | WallSweepOrientation | Represents the orientation of horizonally placed sweep's profile relative to the wall side face.
Public enumeration | WallSweepType | Represents the possible types for methods affecting wall sweeps or reveals.
Public enumeration | WidthMeasuredAt | The allowed values for the WALL_TYPE_WIDTH_MEASURED_AT parameter.
Public enumeration | WorksetConfigurationOption | A collection of options used to initialize a WorksetConfiguration.
Public enumeration | WorksetKind | Indicates one of the standard kinds of workset (as available in the UI).
Public enumeration | WorksetVisibility | Indicates the visibility settings of a workset in a particular view.
 | WorksharingDisplayMode | Indicates which worksharing display mode a view is in.
Public enumeration | ZoomFitType | This enum is used to define type of zoom.
Public enumeration | ZoomType | An enumerated type listing all Zoom types of Print Setting.


ACADExportOptions Class

The base class for options used to export DWG and DXF format files.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBaseExportOptions
Autodesk.Revit.DBACADExportOptions
Autodesk.Revit.DBDWGExportOptions
Autodesk.Revit.DBDXFExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ACADExportOptions : BaseExportOptions
Public Class ACADExportOptions
    Inherits BaseExportOptions
public ref class ACADExportOptions : public BaseExportOptions
type ACADExportOptions =
    class
        inherit BaseExportOptions
    end

The ACADExportOptions type exposes the following members.

Properties
 | Name | Description
Public property | ACAPreference | The preferred way to generate geometry of ACA objects. Default value is ACAObjectPreference.Object.
Public property | Colors | Export color mode. Default value is ExportColorMode.IndexColors. (Inherited from BaseExportOptions)
Public property | ExportingAreas | True to export area and room geometry, false otherwise. Default value is false.
Public property | ExportOfSolids | The mode used to export solids in 3D views. Default value is SolidGeometry.Polymesh.
Public property | FileVersion | ACADVersion::Default Default value is ACADVersion.Default.
Public property | HatchBackgroundColor | The color that will be set as hatch backgound color on the exported hatch. This color will be used only if useHatchBackgroundColor is true. default value is white
Public property | HatchPatternsFileName | Custom hatch patterns (pat) file name. (Inherited from BaseExportOptions)
Public property | HideReferencePlane | Whether or not to hide reference planes. Default value is false. (Inherited from BaseExportOptions)
Public property | HideScopeBox | Whether or not to hide the scope box. Default value is false. (Inherited from BaseExportOptions)
Public property | HideUnreferenceViewTags | Whether or not to hide unreference view tags. Default value is false. (Inherited from BaseExportOptions)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BaseExportOptions)
Public property | LayerMapping | Name of a layer settings standard or filename (with custom layer settings). Valid standards are: DGNV7 (only for DGN), AIA, CP83, BS1192, and ISO13567. default value is "" (empty) which means if no value is set, if no value is set, Revit will use a default value according to the localization. (Inherited from BaseExportOptions)
Public property | LineScaling | The scaling mode for the line type. Default value is LineScaling.ViewScale.
Public property | LinetypesFileName | The custom linetype file name (*.lin). Default value is empty.
Public property | MarkNonplotLayers | If true and the nonplot layer suffix is not empty, all layers whose names contain that suffix will be marked as non-plot.
Public property | NonplotSuffix | If the MarkNonplotLayers attribute is set to true, all layers with names containing this suffix will be marked as non-plot. No action will be performed if the suffix is empty.
Public property | PreserveCoincidentLines | Whether or not to preserve coincident lines. Default value is false. (Inherited from BaseExportOptions)
Public property | PropOverrides | How to export overridden object styles. Default value is PropOverrideMode.ByEntity. (Inherited from BaseExportOptions)
Public property | SharedCoords | True to use the shared coordinate system's origin, false to use the project origin. Default value is false.
Public property | TargetUnit | The target unit type. Default value is ExportUnit.Default.
Public property | TextTreatment | The text treatment. Deault value is TextTreatment.Exact.
Public property | UseHatchBackgroundColor | Indicates if hatch background color will be used or not. default value is false.
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from BaseExportOptions)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetExportFontTable | Gets font table. (Inherited from BaseExportOptions)
Public method | GetExportLayerTable | Gets the layer table. (Inherited from BaseExportOptions)
Public method | GetExportLinetypeTable | Gets a copy of the line type table. (Inherited from BaseExportOptions)
Public method | GetExportPatternTable | Gets a copy of the pattern table. (Inherited from BaseExportOptions)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetExportFontTable | Sets font table to option. (Inherited from BaseExportOptions)
Public method | SetExportLayerTable | Sets layer table back to option (Inherited from BaseExportOptions)
Public method | SetExportLinetypeTable | Sets the line type table to use during export. (Inherited from BaseExportOptions)
Public method | SetExportPatternTable | Sets the pattern table to use during export. (Inherited from BaseExportOptions)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace


ACADExportOptions Properties

The ACADExportOptions type exposes the following members.

Properties
 | Name | Description
Public property | ACAPreference | The preferred way to generate geometry of ACA objects. Default value is ACAObjectPreference.Object.
Public property | Colors | Export color mode. Default value is ExportColorMode.IndexColors. (Inherited from BaseExportOptions)
Public property | ExportingAreas | True to export area and room geometry, false otherwise. Default value is false.
Public property | ExportOfSolids | The mode used to export solids in 3D views. Default value is SolidGeometry.Polymesh.
Public property | FileVersion | ACADVersion::Default Default value is ACADVersion.Default.
Public property | HatchBackgroundColor | The color that will be set as hatch backgound color on the exported hatch. This color will be used only if useHatchBackgroundColor is true. default value is white
Public property | HatchPatternsFileName | Custom hatch patterns (pat) file name. (Inherited from BaseExportOptions)
Public property | HideReferencePlane | Whether or not to hide reference planes. Default value is false. (Inherited from BaseExportOptions)
Public property | HideScopeBox | Whether or not to hide the scope box. Default value is false. (Inherited from BaseExportOptions)
Public property | HideUnreferenceViewTags | Whether or not to hide unreference view tags. Default value is false. (Inherited from BaseExportOptions)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BaseExportOptions)
Public property | LayerMapping | Name of a layer settings standard or filename (with custom layer settings). Valid standards are: DGNV7 (only for DGN), AIA, CP83, BS1192, and ISO13567. default value is "" (empty) which means if no value is set, if no value is set, Revit will use a default value according to the localization. (Inherited from BaseExportOptions)
Public property | LineScaling | The scaling mode for the line type. Default value is LineScaling.ViewScale.
Public property | LinetypesFileName | The custom linetype file name (*.lin). Default value is empty.
Public property | MarkNonplotLayers | If true and the nonplot layer suffix is not empty, all layers whose names contain that suffix will be marked as non-plot.
Public property | NonplotSuffix | If the MarkNonplotLayers attribute is set to true, all layers with names containing this suffix will be marked as non-plot. No action will be performed if the suffix is empty.
Public property | PreserveCoincidentLines | Whether or not to preserve coincident lines. Default value is false. (Inherited from BaseExportOptions)
Public property | PropOverrides | How to export overridden object styles. Default value is PropOverrideMode.ByEntity. (Inherited from BaseExportOptions)
Public property | SharedCoords | True to use the shared coordinate system's origin, false to use the project origin. Default value is false.
Public property | TargetUnit | The target unit type. Default value is ExportUnit.Default.
Public property | TextTreatment | The text treatment. Deault value is TextTreatment.Exact.
Public property | UseHatchBackgroundColor | Indicates if hatch background color will be used or not. default value is false.
Top
See Also

Reference

ACADExportOptions Class


ACADExportOptions.ACAPreference Property

ACADExportOptionsACAPreference Property

The preferred way to generate geometry of ACA objects. Default value is ACAObjectPreference.Object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ACAObjectPreference ACAPreference { get; set; }
Public Property ACAPreference As ACAObjectPreference
    Get
    Set
public:
property ACAObjectPreference ACAPreference {
    ACAObjectPreference get ();
    void set (ACAObjectPreference value);
}
member ACAPreference : ACAObjectPreference with get, set

Property Value

ACAObjectPreference
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ACADExportOptions Class


ACADExportOptions.ExportingAreas Property

ACADExportOptionsExportingAreas Property

True to export area and room geometry, false otherwise. Default value is false.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ExportingAreas { get; set; }
Public Property ExportingAreas As Boolean
    Get
    Set
public:
property bool ExportingAreas {
    bool get ();
    void set (bool value);
}
member ExportingAreas : bool with get, set

Property Value

Boolean
See Also

Reference

ACADExportOptions Class


ACADExportOptions.ExportOfSolids Property

ACADExportOptionsExportOfSolids Property

The mode used to export solids in 3D views. Default value is SolidGeometry.Polymesh.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SolidGeometry ExportOfSolids { get; set; }
Public Property ExportOfSolids As SolidGeometry
    Get
    Set
public:
property SolidGeometry ExportOfSolids {
    SolidGeometry get ();
    void set (SolidGeometry value);
}
member ExportOfSolids : SolidGeometry with get, set

Property Value

SolidGeometry
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ACADExportOptions Class


ACADExportOptions.FileVersion Property

ACADExportOptionsFileVersion Property

ACADVersion::Default Default value is ACADVersion.Default.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ACADVersion FileVersion { get; set; }
Public Property FileVersion As ACADVersion
    Get
    Set
public:
property ACADVersion FileVersion {
    ACADVersion get ();
    void set (ACADVersion value);
}
member FileVersion : ACADVersion with get, set

Property Value

ACADVersion
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ACADExportOptions Class


ACADExportOptions.HatchBackgroundColor Property

ACADExportOptionsHatchBackgroundColor Property

The color that will be set as hatch backgound color on the exported hatch. This color will be used only if useHatchBackgroundColor is true. default value is white

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color HatchBackgroundColor { get; set; }
Public Property HatchBackgroundColor As Color
    Get
    Set
public:
property Color^ HatchBackgroundColor {
    Color^ get ();
    void set (Color^ value);
}
member HatchBackgroundColor : Color with get, set

Property Value

Color
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ACADExportOptions Class


ACADExportOptions.LineScaling Property

ACADExportOptionsLineScaling Property

The scaling mode for the line type. Default value is LineScaling.ViewScale.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LineScaling LineScaling { get; set; }
Public Property LineScaling As LineScaling
    Get
    Set
public:
property LineScaling LineScaling {
    LineScaling get ();
    void set (LineScaling value);
}
member LineScaling : LineScaling with get, set

Property Value

LineScaling
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ACADExportOptions Class


ACADExportOptions.LinetypesFileName Property

ACADExportOptionsLinetypesFileName Property

The custom linetype file name (*.lin). Default value is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string LinetypesFileName { get; set; }
Public Property LinetypesFileName As String
    Get
    Set
public:
property String^ LinetypesFileName {
    String^ get ();
    void set (String^ value);
}
member LinetypesFileName : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ACADExportOptions Class


ACADExportOptions.MarkNonplotLayers Property

ACADExportOptionsMarkNonplotLayers Property

If true and the nonplot layer suffix is not empty, all layers whose names contain that suffix will be marked as non-plot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool MarkNonplotLayers { get; set; }
Public Property MarkNonplotLayers As Boolean
    Get
    Set
public:
property bool MarkNonplotLayers {
    bool get ();
    void set (bool value);
}
member MarkNonplotLayers : bool with get, set

Property Value

Boolean
Remarks
A typical use would be to mark as non-plot all layers containing -NPLT. Default value is false
See Also

Reference

ACADExportOptions Class


ACADExportOptions.NonplotSuffix Property

ACADExportOptionsNonplotSuffix Property

If the MarkNonplotLayers attribute is set to true, all layers with names containing this suffix will be marked as non-plot. No action will be performed if the suffix is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string NonplotSuffix { get; set; }
Public Property NonplotSuffix As String
    Get
    Set
public:
property String^ NonplotSuffix {
    String^ get ();
    void set (String^ value);
}
member NonplotSuffix : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ACADExportOptions Class


ACADExportOptions.SharedCoords Property

ACADExportOptionsSharedCoords Property

True to use the shared coordinate system's origin, false to use the project origin. Default value is false.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SharedCoords { get; set; }
Public Property SharedCoords As Boolean
    Get
    Set
public:
property bool SharedCoords {
    bool get ();
    void set (bool value);
}
member SharedCoords : bool with get, set

Property Value

Boolean
See Also

Reference

ACADExportOptions Class


ACADExportOptions.TargetUnit Property

ACADExportOptionsTargetUnit Property

The target unit type. Default value is ExportUnit.Default.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportUnit TargetUnit { get; set; }
Public Property TargetUnit As ExportUnit
    Get
    Set
public:
property ExportUnit TargetUnit {
    ExportUnit get ();
    void set (ExportUnit value);
}
member TargetUnit : ExportUnit with get, set

Property Value

ExportUnit
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ACADExportOptions Class


ACADExportOptions.TextTreatment Property

ACADExportOptionsTextTreatment Property

The text treatment. Deault value is TextTreatment.Exact.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TextTreatment TextTreatment { get; set; }
Public Property TextTreatment As TextTreatment
    Get
    Set
public:
property TextTreatment TextTreatment {
    TextTreatment get ();
    void set (TextTreatment value);
}
member TextTreatment : TextTreatment with get, set

Property Value

TextTreatment
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ACADExportOptions Class


ACADExportOptions.UseHatchBackgroundColor Property

ACADExportOptionsUseHatchBackgroundColor Property

Indicates if hatch background color will be used or not. default value is false.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UseHatchBackgroundColor { get; set; }
Public Property UseHatchBackgroundColor As Boolean
    Get
    Set
public:
property bool UseHatchBackgroundColor {
    bool get ();
    void set (bool value);
}
member UseHatchBackgroundColor : bool with get, set

Property Value

Boolean
See Also

Reference

ACADExportOptions Class


ACADExportOptions Methods

The ACADExportOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from BaseExportOptions)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetExportFontTable | Gets font table. (Inherited from BaseExportOptions)
Public method | GetExportLayerTable | Gets the layer table. (Inherited from BaseExportOptions)
Public method | GetExportLinetypeTable | Gets a copy of the line type table. (Inherited from BaseExportOptions)
Public method | GetExportPatternTable | Gets a copy of the pattern table. (Inherited from BaseExportOptions)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetExportFontTable | Sets font table to option. (Inherited from BaseExportOptions)
Public method | SetExportLayerTable | Sets layer table back to option (Inherited from BaseExportOptions)
Public method | SetExportLinetypeTable | Sets the line type table to use during export. (Inherited from BaseExportOptions)
Public method | SetExportPatternTable | Sets the pattern table to use during export. (Inherited from BaseExportOptions)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ACADExportOptions Class


ACADVersion Enumeration

An enumerated type listing available AutoCAD versions, into which a file may be exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ACADVersion
Public Enumeration ACADVersion
public enum class ACADVersion
type ACADVersion
Members
Member name | Value | Description
R2007 | 3 | AutoCAD 2007 file format.
R2010 | 16 | AutoCAD 2010 file format.
R2013 | 22 | AutoCAD 2013 file format.
Default | 28 | The Autodesk Revit application's default export format.
R2018 | 28 | AutoCAD 2018 file format.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ACAObjectPreference Enumeration

An enumerated type listing possible ways to generate geometry of an ACA object Revit object parameters used to generate geometry of the exported ACA object. Revit object geometry is used to generate geometry of the exported ACA object. That may produce better geometric fidelity in some cases.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ACAObjectPreference
Public Enumeration ACAObjectPreference
public enum class ACAObjectPreference
type ACAObjectPreference
Members
Member name | Value | Description
Object | 0 |
Geometry | 1 |
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


AdaptiveComponentFamilyUtils Class

An interface for Adaptive Component Instances.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAdaptiveComponentFamilyUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class AdaptiveComponentFamilyUtils
Public NotInheritable Class AdaptiveComponentFamilyUtils
public ref class AdaptiveComponentFamilyUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type AdaptiveComponentFamilyUtils = class end

The AdaptiveComponentFamilyUtils type exposes the following members.

Methods
Name | Description
GetNumberOfAdaptivePoints | Gets number of Adaptive Point Elements in Adaptive Component Family.
GetNumberOfPlacementPoints | Gets number of Placement Point Elements in Adaptive Component Family.
GetNumberOfShapeHandlePoints | Gets number of Shape Handle Point Elements in Adaptive Component Family.
GetPlacementNumber | Gets Placement number of an Adaptive Placement Point.
GetPointConstraintType | Gets constrain type of an Adaptive Shape Handle Point.
GetPointOrientationType | Gets orientation type of an Adaptive Placement Point.
IsAdaptiveComponentFamily | Verifies if the Family is an Adaptive Component Family.
IsAdaptivePlacementPoint | Verifies if the Reference Point is an Adaptive Placement Point.
IsAdaptivePoint | Verifies if the Reference Point is an Adaptive Point.
IsAdaptiveShapeHandlePoint | Verifies if the Reference Point is an Adaptive Shape Handle Point.
MakeAdaptivePoint | Makes Reference Point an Adaptive Point or makes an Adaptive Point a Reference Point.
SetPlacementNumber | Sets Placement Number of an Adaptive Placement Point.
SetPointConstraintType | Sets constrain type of an Adaptive Shape Handle Point.
SetPointOrientationType | Sets orientation type of an Adaptive Placement Point.
Top
Example
C#
VB
C++
F#
Copy
private void CreateAdaptiveComponentFamily(Document document)
{
    // check if this family is an Adaptive Component family
    if (!(AdaptiveComponentFamilyUtils.IsAdaptiveComponentFamily(document.OwnerFamily))) return;
    using (Transaction transaction = new Transaction(document))
    {
       int placementCtr = 1;
       ReferencePointArray refPointArray = new ReferencePointArray();
       for (int i = 0; i < 10; i++)
       {
           transaction.SetName("Point" + i);
           transaction.Start();
           ReferencePoint referencePoint = document.FamilyCreate.NewReferencePoint(new XYZ(i, 0, 0));
           if (i % 2 == 0)
           // Even-numbered reference points will be Placement Points
           {
               AdaptiveComponentFamilyUtils.MakeAdaptivePoint(document, referencePoint.Id, AdaptivePointType.PlacementPoint);
               transaction.Commit();
               AdaptiveComponentFamilyUtils.SetPlacementNumber(document, referencePoint.Id, placementCtr);
               placementCtr++;
           }
           else
           // Odd-numbered points will be Shape Handle Points
           {
               AdaptiveComponentFamilyUtils.MakeAdaptivePoint(document, referencePoint.Id, AdaptivePointType.ShapeHandlePoint);
               transaction.Commit();
           }
           refPointArray.Append(referencePoint);
       }
       // Create a curve running through all Reference Points
       if (transaction.GetStatus() == TransactionStatus.Committed)
       {
          transaction.SetName("Curve");
          transaction.Start();
          CurveByPoints curve = document.FamilyCreate.NewCurveByPoints(refPointArray);
          transaction.Commit();
       }
    }
}
Private Sub CreateAdaptiveComponentFamily(document As Document)
    ' check if this family is an Adaptive Component family
    If Not (AdaptiveComponentFamilyUtils.IsAdaptiveComponentFamily(document.OwnerFamily)) Then
        Return
    End If
    Using transaction As New Transaction(document)
        Dim placementCtr As Integer = 1
        Dim refPointArray As New ReferencePointArray()
        For i As Integer = 0 To 9
            transaction.SetName("Point" & i)
            transaction.Start()
            Dim referencePoint As ReferencePoint = document.FamilyCreate.NewReferencePoint(New XYZ(i, 0, 0))
            If i Mod 2 = 0 Then
                ' Even-numbered reference points will be Placement Points
                AdaptiveComponentFamilyUtils.MakeAdaptivePoint(document, referencePoint.Id, AdaptivePointType.PlacementPoint)
                transaction.Commit()
                AdaptiveComponentFamilyUtils.SetPlacementNumber(document, referencePoint.Id, placementCtr)
                placementCtr += 1
            Else
                ' Odd-numbered points will be Shape Handle Points
                AdaptiveComponentFamilyUtils.MakeAdaptivePoint(document, referencePoint.Id, AdaptivePointType.ShapeHandlePoint)
                transaction.Commit()
            End If
            refPointArray.Append(referencePoint)
        Next
        ' Create a curve running through all Reference Points
        If transaction.GetStatus() = TransactionStatus.Committed Then
            transaction.SetName("Curve")
            transaction.Start()
            Dim curve As CurveByPoints = document.FamilyCreate.NewCurveByPoints(refPointArray)
            transaction.Commit()
        End If
    End Using
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


AdaptiveComponentFamilyUtils Methods

The AdaptiveComponentFamilyUtils type exposes the following members.

Methods
Name | Description
GetNumberOfAdaptivePoints | Gets number of Adaptive Point Elements in Adaptive Component Family.
GetNumberOfPlacementPoints | Gets number of Placement Point Elements in Adaptive Component Family.
GetNumberOfShapeHandlePoints | Gets number of Shape Handle Point Elements in Adaptive Component Family.
GetPlacementNumber | Gets Placement number of an Adaptive Placement Point.
GetPointConstraintType | Gets constrain type of an Adaptive Shape Handle Point.
GetPointOrientationType | Gets orientation type of an Adaptive Placement Point.
IsAdaptiveComponentFamily | Verifies if the Family is an Adaptive Component Family.
IsAdaptivePlacementPoint | Verifies if the Reference Point is an Adaptive Placement Point.
IsAdaptivePoint | Verifies if the Reference Point is an Adaptive Point.
IsAdaptiveShapeHandlePoint | Verifies if the Reference Point is an Adaptive Shape Handle Point.
MakeAdaptivePoint | Makes Reference Point an Adaptive Point or makes an Adaptive Point a Reference Point.
SetPlacementNumber | Sets Placement Number of an Adaptive Placement Point.
SetPointConstraintType | Sets constrain type of an Adaptive Shape Handle Point.
SetPointOrientationType | Sets orientation type of an Adaptive Placement Point.
Top
See Also

Reference

AdaptiveComponentFamilyUtils Class


AdaptiveComponentFamilyUtils.GetNumberOfAdaptivePoints Method

AdaptiveComponentFamilyUtilsGetNumberOfAdaptivePoints Method

Gets number of Adaptive Point Elements in Adaptive Component Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int GetNumberOfAdaptivePoints(
    Family family
)
Public Shared Function GetNumberOfAdaptivePoints (
    family As Family
) As Integer
public:
static int GetNumberOfAdaptivePoints(
    Family^ family
)
static member GetNumberOfAdaptivePoints :
        family : Family -> int

Parameters

family Family
The Family

Return Value

Int32
Number of Adaptive Point Element References in Adaptive Component Family.
Exceptions
Exception | Condition
ArgumentException | The Family family is not an Adaptive Component Family.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This operation failed.
See Also

Reference

AdaptiveComponentFamilyUtils Class


AdaptiveComponentFamilyUtils.GetNumberOfPlacementPoints Method

AdaptiveComponentFamilyUtilsGetNumberOfPlacementPoints Method

Gets number of Placement Point Elements in Adaptive Component Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int GetNumberOfPlacementPoints(
    Family family
)
Public Shared Function GetNumberOfPlacementPoints (
    family As Family
) As Integer
public:
static int GetNumberOfPlacementPoints(
    Family^ family
)
static member GetNumberOfPlacementPoints :
        family : Family -> int

Parameters

family Family
The Family

Return Value

Int32
Number of Adaptive Placement Point Element References in Adaptive Component Family.
Exceptions
Exception | Condition
ArgumentException | The Family family is not an Adaptive Component Family.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This operation failed.
See Also

Reference

AdaptiveComponentFamilyUtils Class


AdaptiveComponentFamilyUtils.GetNumberOfShapeHandlePoints Method

AdaptiveComponentFamilyUtilsGetNumberOfShapeHandlePoints Method

Gets number of Shape Handle Point Elements in Adaptive Component Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int GetNumberOfShapeHandlePoints(
    Family family
)
Public Shared Function GetNumberOfShapeHandlePoints (
    family As Family
) As Integer
public:
static int GetNumberOfShapeHandlePoints(
    Family^ family
)
static member GetNumberOfShapeHandlePoints :
        family : Family -> int

Parameters

family Family
The Family

Return Value

Int32
Number of Adaptive Shape Handle Point Element References in the Adaptive Component Family.
Exceptions
Exception | Condition
ArgumentException | The Family family is not an Adaptive Component Family.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This operation failed.
See Also

Reference

AdaptiveComponentFamilyUtils Class


AdaptiveComponentFamilyUtils.GetPlacementNumber Method

AdaptiveComponentFamilyUtilsGetPlacementNumber Method

Gets Placement number of an Adaptive Placement Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int GetPlacementNumber(
    Document doc,
    ElementId refPointId
)
Public Shared Function GetPlacementNumber (
    doc As Document,
    refPointId As ElementId
) As Integer
public:
static int GetPlacementNumber(
    Document^ doc,
    ElementId^ refPointId
)
static member GetPlacementNumber :
        doc : Document *
        refPointId : ElementId -> int

Parameters

doc Document
The Document
refPointId ElementId
The ReferencePoint id

Return Value

Int32
Placement number of the Adaptive Placement Point.
Exceptions
Exception | Condition
ArgumentException | The ElementId refPointId does not correspond to a valid ReferencePoint. -or- The Element corresponding to ElementId refPointId does not belong to an Adaptive Family. -or- The ElementId refPointId does not correspond to an Adaptive Placement Point.
ArgumentNullException | A non-optional argument was null
See Also

Reference

AdaptiveComponentFamilyUtils Class


AdaptiveComponentFamilyUtils.GetPointConstraintType Method

AdaptiveComponentFamilyUtilsGetPointConstraintType Method

Gets constrain type of an Adaptive Shape Handle Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static AdaptivePointConstraintType GetPointConstraintType(
    Document doc,
    ElementId refPointId
)
Public Shared Function GetPointConstraintType (
    doc As Document,
    refPointId As ElementId
) As AdaptivePointConstraintType
public:
static AdaptivePointConstraintType GetPointConstraintType(
    Document^ doc,
    ElementId^ refPointId
)
static member GetPointConstraintType :
        doc : Document *
        refPointId : ElementId -> AdaptivePointConstraintType

Parameters

doc Document
The Document
refPointId ElementId
The ReferencePoint id

Return Value

AdaptivePointConstraintType
Constraint type of the Adaptive Shape Handle Point.
Exceptions
Exception | Condition
ArgumentException | The ElementId refPointId does not correspond to a valid ReferencePoint. -or- The Element corresponding to ElementId refPointId does not belong to an Adaptive Family. -or- The ElementId refPointId does not correspond to a Shape Handle Point.
ArgumentNullException | A non-optional argument was null
See Also

Reference

AdaptiveComponentFamilyUtils Class


AdaptiveComponentFamilyUtils.GetPointOrientationType Method

AdaptiveComponentFamilyUtilsGetPointOrientationType Method

Gets orientation type of an Adaptive Placement Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static AdaptivePointOrientationType GetPointOrientationType(
    Document doc,
    ElementId refPointId
)
Public Shared Function GetPointOrientationType (
    doc As Document,
    refPointId As ElementId
) As AdaptivePointOrientationType
public:
static AdaptivePointOrientationType GetPointOrientationType(
    Document^ doc,
    ElementId^ refPointId
)
static member GetPointOrientationType :
        doc : Document *
        refPointId : ElementId -> AdaptivePointOrientationType

Parameters

doc Document
The Document
refPointId ElementId
The ReferencePoint id

Return Value

AdaptivePointOrientationType
Orientation type of Adaptive Placement Point.
Exceptions
Exception | Condition
ArgumentException | The ElementId refPointId does not correspond to a valid ReferencePoint. -or- The Element corresponding to ElementId refPointId does not belong to an Adaptive Family. -or- The ElementId refPointId does not correspond to an Adaptive Placement Point.
ArgumentNullException | A non-optional argument was null
See Also

Reference

AdaptiveComponentFamilyUtils Class


AdaptiveComponentFamilyUtils.IsAdaptiveComponentFamily Method

AdaptiveComponentFamilyUtilsIsAdaptiveComponentFamily Method

Verifies if the Family is an Adaptive Component Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsAdaptiveComponentFamily(
    Family family
)
Public Shared Function IsAdaptiveComponentFamily (
    family As Family
) As Boolean
public:
static bool IsAdaptiveComponentFamily(
    Family^ family
)
static member IsAdaptiveComponentFamily :
        family : Family -> bool

Parameters

family Family
The Family

Return Value

Boolean
True if the Family is an Adaptive Component Family.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

AdaptiveComponentFamilyUtils Class


AdaptiveComponentFamilyUtils.IsAdaptivePlacementPoint Method

AdaptiveComponentFamilyUtilsIsAdaptivePlacementPoint Method

Verifies if the Reference Point is an Adaptive Placement Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsAdaptivePlacementPoint(
    Document doc,
    ElementId refPointId
)
Public Shared Function IsAdaptivePlacementPoint (
    doc As Document,
    refPointId As ElementId
) As Boolean
public:
static bool IsAdaptivePlacementPoint(
    Document^ doc,
    ElementId^ refPointId
)
static member IsAdaptivePlacementPoint :
        doc : Document *
        refPointId : ElementId -> bool

Parameters

doc Document
The Document
refPointId ElementId
The ReferencePoint id

Return Value

Boolean
True if the Point is an Adaptive Placement Point.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

AdaptiveComponentFamilyUtils Class


AdaptiveComponentFamilyUtils.IsAdaptivePoint Method

AdaptiveComponentFamilyUtilsIsAdaptivePoint Method

Verifies if the Reference Point is an Adaptive Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsAdaptivePoint(
    Document doc,
    ElementId refPointId
)
Public Shared Function IsAdaptivePoint (
    doc As Document,
    refPointId As ElementId
) As Boolean
public:
static bool IsAdaptivePoint(
    Document^ doc,
    ElementId^ refPointId
)
static member IsAdaptivePoint :
        doc : Document *
        refPointId : ElementId -> bool

Parameters

doc Document
The Document
refPointId ElementId
The ReferencePoint id

Return Value

Boolean
True if the Point is an Adaptive Point (Placement Point or Shape Handle Point).
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

AdaptiveComponentFamilyUtils Class


AdaptiveComponentFamilyUtils.IsAdaptiveShapeHandlePoint Method

AdaptiveComponentFamilyUtilsIsAdaptiveShapeHandlePoint Method

Verifies if the Reference Point is an Adaptive Shape Handle Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsAdaptiveShapeHandlePoint(
    Document doc,
    ElementId refPointId
)
Public Shared Function IsAdaptiveShapeHandlePoint (
    doc As Document,
    refPointId As ElementId
) As Boolean
public:
static bool IsAdaptiveShapeHandlePoint(
    Document^ doc,
    ElementId^ refPointId
)
static member IsAdaptiveShapeHandlePoint :
        doc : Document *
        refPointId : ElementId -> bool

Parameters

doc Document
The Document
refPointId ElementId
The ReferencePoint id

Return Value

Boolean
True if the Point is an Adaptive Shape Handle Point.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

AdaptiveComponentFamilyUtils Class


AdaptiveComponentFamilyUtils.MakeAdaptivePoint Method

AdaptiveComponentFamilyUtilsMakeAdaptivePoint Method

Makes Reference Point an Adaptive Point or makes an Adaptive Point a Reference Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void MakeAdaptivePoint(
    Document doc,
    ElementId refPointId,
    AdaptivePointType type
)
Public Shared Sub MakeAdaptivePoint (
    doc As Document,
    refPointId As ElementId,
    type As AdaptivePointType
)
public:
static void MakeAdaptivePoint(
    Document^ doc,
    ElementId^ refPointId,
    AdaptivePointType type
)
static member MakeAdaptivePoint :
        doc : Document *
        refPointId : ElementId *
        type : AdaptivePointType -> unit

Parameters

doc Document
The Document
refPointId ElementId
The ReferencePoint id
type AdaptivePointType
The Adaptive Point Type
Exceptions
Exception | Condition
ArgumentException | The ElementId refPointId does not correspond to a valid ReferencePoint. -or- The Element corresponding to ElementId refPointId does not belong to an Adaptive Family.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | This operation failed.
See Also

Reference

AdaptiveComponentFamilyUtils Class


AdaptiveComponentFamilyUtils.SetPlacementNumber Method

AdaptiveComponentFamilyUtilsSetPlacementNumber Method

Sets Placement Number of an Adaptive Placement Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void SetPlacementNumber(
    Document doc,
    ElementId refPointId,
    int placementNumber
)
Public Shared Sub SetPlacementNumber (
    doc As Document,
    refPointId As ElementId,
    placementNumber As Integer
)
public:
static void SetPlacementNumber(
    Document^ doc,
    ElementId^ refPointId,
    int placementNumber
)
static member SetPlacementNumber :
        doc : Document *
        refPointId : ElementId *
        placementNumber : int -> unit

Parameters

doc Document
The Document
refPointId ElementId
The ReferencePoint id
placementNumber Int32
Placement number of the Adaptive Placement Point.
Exceptions
Exception | Condition
ArgumentException | The ElementId refPointId does not correspond to a valid ReferencePoint. -or- The Element corresponding to ElementId refPointId does not belong to an Adaptive Family. -or- The ElementId refPointId does not correspond to an Adaptive Placement Point. -or- The number placementNumber is out of range.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This operation failed.
See Also

Reference

AdaptiveComponentFamilyUtils Class


AdaptiveComponentFamilyUtils.SetPointConstraintType Method

AdaptiveComponentFamilyUtilsSetPointConstraintType Method

Sets constrain type of an Adaptive Shape Handle Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void SetPointConstraintType(
    Document doc,
    ElementId refPointId,
    AdaptivePointConstraintType constraintType
)
Public Shared Sub SetPointConstraintType (
    doc As Document,
    refPointId As ElementId,
    constraintType As AdaptivePointConstraintType
)
public:
static void SetPointConstraintType(
    Document^ doc,
    ElementId^ refPointId,
    AdaptivePointConstraintType constraintType
)
static member SetPointConstraintType :
        doc : Document *
        refPointId : ElementId *
        constraintType : AdaptivePointConstraintType -> unit

Parameters

doc Document
The Document
refPointId ElementId
The ReferencePoint id
constraintType AdaptivePointConstraintType
Constraint type of the Adaptive Shape Handle Point.
Exceptions
Exception | Condition
ArgumentException | The ElementId refPointId does not correspond to a valid ReferencePoint. -or- The Element corresponding to ElementId refPointId does not belong to an Adaptive Family. -or- The ElementId refPointId does not correspond to a Shape Handle Point.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | This operation failed.
See Also

Reference

AdaptiveComponentFamilyUtils Class


AdaptiveComponentFamilyUtils.SetPointOrientationType Method

AdaptiveComponentFamilyUtilsSetPointOrientationType Method

Sets orientation type of an Adaptive Placement Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void SetPointOrientationType(
    Document doc,
    ElementId refPointId,
    AdaptivePointOrientationType orientationType
)
Public Shared Sub SetPointOrientationType (
    doc As Document,
    refPointId As ElementId,
    orientationType As AdaptivePointOrientationType
)
public:
static void SetPointOrientationType(
    Document^ doc,
    ElementId^ refPointId,
    AdaptivePointOrientationType orientationType
)
static member SetPointOrientationType :
        doc : Document *
        refPointId : ElementId *
        orientationType : AdaptivePointOrientationType -> unit

Parameters

doc Document
The Document
refPointId ElementId
The ReferencePoint id
orientationType AdaptivePointOrientationType
Orientation type of the Adaptive Placement Point.
Exceptions
Exception | Condition
ArgumentException | The ElementId refPointId does not correspond to a valid ReferencePoint. -or- The Element corresponding to ElementId refPointId does not belong to an Adaptive Family. -or- The ElementId refPointId does not correspond to an Adaptive Placement Point.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | This operation failed.
See Also

Reference

AdaptiveComponentFamilyUtils Class


AdaptiveComponentInstanceUtils Class

An interface for Adaptive Component Instances.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAdaptiveComponentInstanceUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class AdaptiveComponentInstanceUtils
Public NotInheritable Class AdaptiveComponentInstanceUtils
public ref class AdaptiveComponentInstanceUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type AdaptiveComponentInstanceUtils = class end

The AdaptiveComponentInstanceUtils type exposes the following members.

Methods
Name | Description
CreateAdaptiveComponentInstance | Creates a FamilyInstance of Adaptive Component Family.
GetInstancePlacementPointElementRefIds | Gets Placement Adaptive Point Element Ref ids to which the instance geometry adapts.
GetInstancePointElementRefIds | Gets Adaptive Point Element Ref ids to which the instance geometry adapts.
GetInstanceShapeHandlePointElementRefIds | Gets Shape Handle Adaptive Point Element Ref ids to which the instance geometry adapts.
HasAdaptiveFamilySymbol | Verifies if a FamilyInstance has an Adaptive Family Symbol.
IsAdaptiveComponentInstance | Verifies if a FamilyInstance is an Adaptive Component Instance.
IsAdaptiveFamilySymbol | Verifies if a FamilySymbol is a valid Adaptive Family Symbol.
IsInstanceFlipped | Gets the value of the flip parameter on the adaptive instance.
MoveAdaptiveComponentInstance | Moves Adaptive Component Instance by the specified transformation.
SetInstanceFlipped | Sets the value of the flip parameter on the adaptive instance.
Top
Example
C#
VB
C++
F#
Copy
private void CreateAdaptiveComponentInstance(Document document, FamilySymbol symbol)
{
    // Create a new instance of an adaptive component family
    FamilyInstance instance = AdaptiveComponentInstanceUtils.CreateAdaptiveComponentInstance(document, symbol);

    // Get the placement points of this instance
    IList<ElementId> placePointIds = new List<ElementId>();
    placePointIds = AdaptiveComponentInstanceUtils.GetInstancePlacementPointElementRefIds(instance);
    double x = 0;

    // Set the position of each placement point
    foreach (ElementId id in placePointIds)
    {
        ReferencePoint point = document.GetElement(id) as ReferencePoint;
        point.Position = new Autodesk.Revit.DB.XYZ(10*x, 10*Math.Cos(x), 0);
        x += Math.PI/6;
    }
}
Private Sub CreateAdaptiveComponentInstance(document As Document, symbol As FamilySymbol)
    ' Create a new instance of an adaptive component family
    Dim instance As FamilyInstance = AdaptiveComponentInstanceUtils.CreateAdaptiveComponentInstance(document, symbol)

    ' Get the placement points of this instance
    Dim placePointIds As IList(Of ElementId) = New List(Of ElementId)()
    placePointIds = AdaptiveComponentInstanceUtils.GetInstancePlacementPointElementRefIds(instance)
    Dim x As Double = 0

    ' Set the position of each placement point
    For Each id As ElementId In placePointIds
        Dim point As ReferencePoint = TryCast(document.GetElement(id), ReferencePoint)
        point.Position = New Autodesk.Revit.DB.XYZ(10 * x, 10 * Math.Cos(x), 0)
        x += Math.PI / 6
    Next
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


AdaptiveComponentInstanceUtils Methods

The AdaptiveComponentInstanceUtils type exposes the following members.

Methods
Name | Description
CreateAdaptiveComponentInstance | Creates a FamilyInstance of Adaptive Component Family.
GetInstancePlacementPointElementRefIds | Gets Placement Adaptive Point Element Ref ids to which the instance geometry adapts.
GetInstancePointElementRefIds | Gets Adaptive Point Element Ref ids to which the instance geometry adapts.
GetInstanceShapeHandlePointElementRefIds | Gets Shape Handle Adaptive Point Element Ref ids to which the instance geometry adapts.
HasAdaptiveFamilySymbol | Verifies if a FamilyInstance has an Adaptive Family Symbol.
IsAdaptiveComponentInstance | Verifies if a FamilyInstance is an Adaptive Component Instance.
IsAdaptiveFamilySymbol | Verifies if a FamilySymbol is a valid Adaptive Family Symbol.
IsInstanceFlipped | Gets the value of the flip parameter on the adaptive instance.
MoveAdaptiveComponentInstance | Moves Adaptive Component Instance by the specified transformation.
SetInstanceFlipped | Sets the value of the flip parameter on the adaptive instance.
Top
See Also

Reference

AdaptiveComponentInstanceUtils Class


AdaptiveComponentInstanceUtils.CreateAdaptiveComponentInstance Method

AdaptiveComponentInstanceUtilsCreateAdaptiveComponentInstance Method

Creates a FamilyInstance of Adaptive Component Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FamilyInstance CreateAdaptiveComponentInstance(
    Document doc,
    FamilySymbol famSymb
)
Public Shared Function CreateAdaptiveComponentInstance (
    doc As Document,
    famSymb As FamilySymbol
) As FamilyInstance
public:
static FamilyInstance^ CreateAdaptiveComponentInstance(
    Document^ doc,
    FamilySymbol^ famSymb
)
static member CreateAdaptiveComponentInstance :
        doc : Document *
        famSymb : FamilySymbol -> FamilyInstance

Parameters

doc Document
The Document
famSymb FamilySymbol
The FamilySymbol

Return Value

FamilyInstance
The Family Instance
Exceptions
Exception | Condition
ArgumentException | The element famSymb was not found in the given document. -or- The Symbol famSymb is not an Adaptive Family Symbol.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Unable to create adaptive component instance.
Remarks
This method creates an Adaptive FamilyInstance and its PointElement references. The references can be accessed by methods like GetInstancePointElementRefIds(). The PointElement references can be moved, rehosted or manipulated just like any other PointElements. The FamilyInstance would then 'adapt' to these references.
See Also

Reference

AdaptiveComponentInstanceUtils Class


AdaptiveComponentInstanceUtils.GetInstancePlacementPointElementRefIds Method

AdaptiveComponentInstanceUtilsGetInstancePlacementPointElementRefIds Method

Gets Placement Adaptive Point Element Ref ids to which the instance geometry adapts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<ElementId> GetInstancePlacementPointElementRefIds(
    FamilyInstance famInst
)
Public Shared Function GetInstancePlacementPointElementRefIds (
    famInst As FamilyInstance
) As IList(Of ElementId)
public:
static IList<ElementId^>^ GetInstancePlacementPointElementRefIds(
    FamilyInstance^ famInst
)
static member GetInstancePlacementPointElementRefIds :
        famInst : FamilyInstance -> IList<ElementId>

Parameters

famInst FamilyInstance
The FamilyInstance.

Return Value

IList ElementId
The Placement Adaptive Point Element Ref ids to which the instance geometry adapts.
Exceptions
Exception | Condition
ArgumentException | The FamilyInstance famInst is not an Adaptive Family Instance. -or- The FamilyInstance famInst does not have an Adaptive Family Symbol.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This operation failed.
Remarks
The output contains placement point ref ids. The element ids are sorted in by the placement numbers (increasing order).
See Also

Reference

AdaptiveComponentInstanceUtils Class


AdaptiveComponentInstanceUtils.GetInstancePointElementRefIds Method

AdaptiveComponentInstanceUtilsGetInstancePointElementRefIds Method

Gets Adaptive Point Element Ref ids to which the instance geometry adapts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<ElementId> GetInstancePointElementRefIds(
    FamilyInstance famInst
)
Public Shared Function GetInstancePointElementRefIds (
    famInst As FamilyInstance
) As IList(Of ElementId)
public:
static IList<ElementId^>^ GetInstancePointElementRefIds(
    FamilyInstance^ famInst
)
static member GetInstancePointElementRefIds :
        famInst : FamilyInstance -> IList<ElementId>

Parameters

famInst FamilyInstance
The FamilyInstance.

Return Value

IList ElementId
The Adaptive Point Element Ref ids to which the instance geometry adapts.
Exceptions
Exception | Condition
ArgumentException | The FamilyInstance famInst is not an Adaptive Family Instance. -or- The FamilyInstance famInst does not have an Adaptive Family Symbol.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This operation failed.
Remarks
The output contains both placement point ref ids and the shape handles point ref ids. The order corresponds to the same order as that of the Adaptive Points in the Family (which may not be ordered as per their placement number). Will return an empty array if there are no placement points and shape handles. To manipulate such an instance the following methods can be useful: 1) RehostAdaptiveComponentInstanceWithNoPlacementPoints() 2) MoveAdaptiveComponentInstance()
See Also

Reference

AdaptiveComponentInstanceUtils Class


AdaptiveComponentInstanceUtils.GetInstanceShapeHandlePointElementRefIds Method

AdaptiveComponentInstanceUtilsGetInstanceShapeHandlePointElementRefIds Method

Gets Shape Handle Adaptive Point Element Ref ids to which the instance geometry adapts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<ElementId> GetInstanceShapeHandlePointElementRefIds(
    FamilyInstance famInst
)
Public Shared Function GetInstanceShapeHandlePointElementRefIds (
    famInst As FamilyInstance
) As IList(Of ElementId)
public:
static IList<ElementId^>^ GetInstanceShapeHandlePointElementRefIds(
    FamilyInstance^ famInst
)
static member GetInstanceShapeHandlePointElementRefIds :
        famInst : FamilyInstance -> IList<ElementId>

Parameters

famInst FamilyInstance
The FamilyInstance

Return Value

IList ElementId
The Shape Handle Adaptive Point Element Ref ids to which the instance geometry adapts.
Exceptions
Exception | Condition
ArgumentException | The FamilyInstance famInst is not an Adaptive Family Instance. -or- The FamilyInstance famInst does not have an Adaptive Family Symbol.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This operation failed.
Remarks
The output contains shape handle point ref ids. If there are no shape handle points defined in the Family then the output is empty.
See Also

Reference

AdaptiveComponentInstanceUtils Class


AdaptiveComponentInstanceUtils.HasAdaptiveFamilySymbol Method

AdaptiveComponentInstanceUtilsHasAdaptiveFamilySymbol Method

Verifies if a FamilyInstance has an Adaptive Family Symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool HasAdaptiveFamilySymbol(
    FamilyInstance famInst
)
Public Shared Function HasAdaptiveFamilySymbol (
    famInst As FamilyInstance
) As Boolean
public:
static bool HasAdaptiveFamilySymbol(
    FamilyInstance^ famInst
)
static member HasAdaptiveFamilySymbol :
        famInst : FamilyInstance -> bool

Parameters

famInst FamilyInstance
The FamilyInstance

Return Value

Boolean
True if the FamilyInstance has an Adaptive Family Symbol.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

AdaptiveComponentInstanceUtils Class


AdaptiveComponentInstanceUtils.IsAdaptiveComponentInstance Method

AdaptiveComponentInstanceUtilsIsAdaptiveComponentInstance Method

Verifies if a FamilyInstance is an Adaptive Component Instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsAdaptiveComponentInstance(
    FamilyInstance famInst
)
Public Shared Function IsAdaptiveComponentInstance (
    famInst As FamilyInstance
) As Boolean
public:
static bool IsAdaptiveComponentInstance(
    FamilyInstance^ famInst
)
static member IsAdaptiveComponentInstance :
        famInst : FamilyInstance -> bool

Parameters

famInst FamilyInstance
The FamilyInstance

Return Value

Boolean
True if the FamilyInstance has an Adaptive Component Instances.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

AdaptiveComponentInstanceUtils Class


AdaptiveComponentInstanceUtils.IsAdaptiveFamilySymbol Method

AdaptiveComponentInstanceUtilsIsAdaptiveFamilySymbol Method

Verifies if a FamilySymbol is a valid Adaptive Family Symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsAdaptiveFamilySymbol(
    FamilySymbol famSymb
)
Public Shared Function IsAdaptiveFamilySymbol (
    famSymb As FamilySymbol
) As Boolean
public:
static bool IsAdaptiveFamilySymbol(
    FamilySymbol^ famSymb
)
static member IsAdaptiveFamilySymbol :
        famSymb : FamilySymbol -> bool

Parameters

famSymb FamilySymbol
The FamilySymbol

Return Value

Boolean
True if the FamilySymbol is a valid Adaptive Family Symbol.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

AdaptiveComponentInstanceUtils Class


AdaptiveComponentInstanceUtils.IsInstanceFlipped Method

AdaptiveComponentInstanceUtilsIsInstanceFlipped Method

Gets the value of the flip parameter on the adaptive instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsInstanceFlipped(
    FamilyInstance famInst
)
Public Shared Function IsInstanceFlipped (
    famInst As FamilyInstance
) As Boolean
public:
static bool IsInstanceFlipped(
    FamilyInstance^ famInst
)
static member IsInstanceFlipped :
        famInst : FamilyInstance -> bool

Parameters

famInst FamilyInstance
The FamilyInstance

Return Value

Boolean
True if the instance is flipped.
Exceptions
Exception | Condition
ArgumentException | The FamilyInstance famInst is not an Adaptive Family Instance. -or- The FamilyInstance famInst does not have an Adaptive Family Symbol.
ArgumentNullException | A non-optional argument was null
See Also

Reference

AdaptiveComponentInstanceUtils Class


AdaptiveComponentInstanceUtils.MoveAdaptiveComponentInstance Method

AdaptiveComponentInstanceUtilsMoveAdaptiveComponentInstance Method

Moves Adaptive Component Instance by the specified transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void MoveAdaptiveComponentInstance(
    FamilyInstance famInst,
    Transform trf,
    bool unHost
)
Public Shared Sub MoveAdaptiveComponentInstance (
    famInst As FamilyInstance,
    trf As Transform,
    unHost As Boolean
)
public:
static void MoveAdaptiveComponentInstance(
    FamilyInstance^ famInst,
    Transform^ trf,
    bool unHost
)
static member MoveAdaptiveComponentInstance :
        famInst : FamilyInstance *
        trf : Transform *
        unHost : bool -> unit

Parameters

famInst FamilyInstance
The FamilyInstance
trf Transform
The Transformation
unHost Boolean
True if the move should disassociate the Point Element Refs from their hosts. False if the Point Element Refs remain hosted.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentsInconsistentException | trf is not a rigid body transformation.
InvalidOperationException | Unable to move the adaptive component instance.
Remarks
This method will attempt a rigid body motion of all the individual references and hence the instance itself. However if unHost parameter is 'false' and any of the instance's references are hosted to any geometry, then those references will move within the constraints. The instance then adapts to where its references are moved to.
See Also

Reference

AdaptiveComponentInstanceUtils Class


AdaptiveComponentInstanceUtils.SetInstanceFlipped Method

AdaptiveComponentInstanceUtilsSetInstanceFlipped Method

Sets the value of the flip parameter on the adaptive instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void SetInstanceFlipped(
    FamilyInstance famInst,
    bool flip
)
Public Shared Sub SetInstanceFlipped (
    famInst As FamilyInstance,
    flip As Boolean
)
public:
static void SetInstanceFlipped(
    FamilyInstance^ famInst,
    bool flip
)
static member SetInstanceFlipped :
        famInst : FamilyInstance *
        flip : bool -> unit

Parameters

famInst FamilyInstance
The FamilyInstance
flip Boolean
The flip flag
Exceptions
Exception | Condition
ArgumentException | The FamilyInstance famInst is not an Adaptive Family Instance. -or- The FamilyInstance famInst does not have an Adaptive Family Symbol. -or- The FamilyInstance famInst cannot be flipped or unflipped.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This operation failed.
See Also

Reference

AdaptiveComponentInstanceUtils Class


AdaptivePointConstraintType Enumeration

An enumerated type containing possible constraint types for Adaptive Points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum AdaptivePointConstraintType
Public Enumeration AdaptivePointConstraintType
public enum class AdaptivePointConstraintType
type AdaptivePointConstraintType
Members
Member name | Value | Description
None | 0 | Not constrained.
Plane_YZ | 1 | Constrained to the YZ Plane (x=0).
Plane_ZX | 2 | Constrained to the ZX Plane (y=0).
Plane_XY | 3 | Constrained to the XY Plane (z=0).
Axis_X | 4 | Constrained to the X Axis (y=0, z=0).
Axis_Y | 5 | Constrained to the Y Axis (x=0, z=0).
Axis_Z | 6 | Constrained to the Z Axis (x=0, y=0).
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


AdaptivePointOrientationType Enumeration

An enumerated type containing possible orientation types for Adaptive Points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum AdaptivePointOrientationType
Public Enumeration AdaptivePointOrientationType
public enum class AdaptivePointOrientationType
type AdaptivePointOrientationType
Members
Member name | Value | Description
ToHost | 2 | The adaptive point will be oriented to the coordinate system of the geometry the point is hosted on. This option was previously named: HostReferenceStrictly
ToHostAndLoopSystem | 3 | The adaptive point will be oriented to the coordinate system of the geometry the point is hosted on. However, the orientation of the Z axis is controlled by the order of placed points. If the placed adaptive points of a component are placed in a different order with respect to the host order, (clockwise instead of counter-clockwise), then the Z axis will invert and the planar projection will flip. This option was previously named: HostReferenceAutoFlip.
ToGlobalZthenHost | 6 | The Z axis of the adaptive point will be oriented to the Z axis of the document the instance is placed in. The XY axis are determined by the XY of the geometry the point is hosted on. This option was previously named: PlacementVertical.
ToGlobalXYZ | 7 | The adaptive point will be oriented to the coordinate system of the document the instance is placed in. This option was previously named: PlacementOrthogonal
ToInstanceZthenHost | 8 | The Z axis of the adaptive point will be oriented to the Z axis of the adaptive family instance the point is part of. The XY axis are determined by the XY of the geometry the point is hosted on. This option was previously named: FamilyVertical
ToInstance | 9 | The adaptive point will be oriented to the coordinate system of the adaptive family instance the point is part of. This is the default orientation of adaptive points. This option was previously named: FamilyOrthogonal
Remarks

The default orientation of adaptive points is AdaptivePointOrientationType.ToInstance.

All the items of this enumerated type were renamed for Revit 2016 to better align the names with the corresponding text in the Revit UI. The numeric values of the items weren't modified, allowing existing applications to work. However, to be able to rebuild an application, all point orientations need to be changed to their respective new names.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


AdaptivePointType Enumeration

An enumerated type containing possible types for Adaptive Points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum AdaptivePointType
Public Enumeration AdaptivePointType
public enum class AdaptivePointType
type AdaptivePointType
Members
Member name | Value | Description
ReferencePoint | 0 | Reference Point.
PlacementPoint | 1 | Placement Point.
ShapeHandlePoint | 2 | Shape Handle Point.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


AddInId Class

Identifies an AddIn registered with Revit
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAddInId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AddInId : IDisposable
Public Class AddInId
    Implements IDisposable
public ref class AddInId : IDisposable
type AddInId =
    class
        interface IDisposable
    end

The AddInId type exposes the following members.

Constructors
 | Name | Description
Public method | AddInId | creates an AddInId object with a given GUID
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the AddInId
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAddInName | name of addin associated with this AddInId Attempts to obtain the name from loaded Third Party AddIns
Public method | GetAddInNameFromDocument | name of application associated with this ApplicationId First attempts to obtain the name from AddInIds stored in the document. If unsuccessful, attempts to obtain the name from loaded Third Party AddIns.
Public method | GetGUID | value of the AddInId as a GUID
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


AddInId Constructor

creates an AddInId object with a given GUID

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AddInId(
    Guid val
)
Public Sub New (
    val As Guid
)
public:
AddInId(
    Guid val
)
new :
        val : Guid -> AddInId

Parameters

val Guid
GUID value
See Also

Reference

AddInId Class


AddInId Properties

The AddInId type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

AddInId Class


AddInId.IsValidObject Property

AddInIdIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

AddInId Class


AddInId Methods

The AddInId type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAddInName | name of addin associated with this AddInId Attempts to obtain the name from loaded Third Party AddIns
Public method | GetAddInNameFromDocument | name of application associated with this ApplicationId First attempts to obtain the name from AddInIds stored in the document. If unsuccessful, attempts to obtain the name from loaded Third Party AddIns.
Public method | GetGUID | value of the AddInId as a GUID
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AddInId Class


AddInId.Dispose Method

AddInIdDispose Method

Releases all resources used by the AddInId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

AddInId Class


AddInId.GetAddInName Method

AddInIdGetAddInName Method

name of addin associated with this AddInId Attempts to obtain the name from loaded Third Party AddIns

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetAddInName()
Public Function GetAddInName As String
public:
String^ GetAddInName()
member GetAddInName : unit -> string

Return Value

String
name of addin
See Also

Reference

AddInId Class


AddInId.GetAddInNameFromDocument Method

AddInIdGetAddInNameFromDocument Method

name of application associated with this ApplicationId First attempts to obtain the name from AddInIds stored in the document. If unsuccessful, attempts to obtain the name from loaded Third Party AddIns.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetAddInNameFromDocument(
    Document aDoc
)
Public Function GetAddInNameFromDocument (
    aDoc As Document
) As String
public:
String^ GetAddInNameFromDocument(
    Document^ aDoc
)
member GetAddInNameFromDocument :
        aDoc : Document -> string

Parameters

aDoc Document
target document

Return Value

String
name of application
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was NULL
See Also

Reference

AddInId Class


AddInId.GetGUID Method

AddInIdGetGUID Method

value of the AddInId as a GUID

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid GetGUID()
Public Function GetGUID As Guid
public:
Guid GetGUID()
member GetGUID : unit -> Guid

Return Value

Guid
GUID value of the AddInId
See Also

Reference

AddInId Class


AllowedValues Enumeration

A range of allowed values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum AllowedValues
Public Enumeration AllowedValues
public enum class AllowedValues
type AllowedValues
Members
Member name | Value | Description
NonNegative | 0 | Only non-negative values are allowed. A tolerance of 1.0e-9 is used, so very small negative numbers are accepted.
All | 1 | All values are allowed.
Positive | 2 | Only positive values are allowed. A tolerance of 1.0e-9 is used, so very small positive numbers are rejected.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


AlphanumericRevisionSettings Class

Contains settings that apply to Revisions with the Alphanumeric RevisionNumberType.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAlphanumericRevisionSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AlphanumericRevisionSettings : IDisposable
Public Class AlphanumericRevisionSettings
    Implements IDisposable
public ref class AlphanumericRevisionSettings : IDisposable
type AlphanumericRevisionSettings =
    class
        interface IDisposable
    end

The AlphanumericRevisionSettings type exposes the following members.

Constructors
 | Name | Description
Public method | AlphanumericRevisionSettings | Constructs an AlphanumericRevisionSettings with a simple, default sequence.
Public method | AlphanumericRevisionSettings(AlphanumericRevisionSettings) | Constructs a new copy of the input AlphanumericRevisionSettings object.
Public method | AlphanumericRevisionSettings(IListString, String, String) | Constructs an AlphanumericRevisionSettings object.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Prefix | The prefix string that will be prepended to the number of each revision with Alphanumeric RevisionNumberingType.
Public property | Suffix | The suffix string that will be appended to the number of each revision with Alphanumeric RevisionNumberingType.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the AlphanumericRevisionSettings
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetSequence | Gets a list containing the strings to be used as the numbering sequence for revisions with the Alphanumeric RevisionNumberType.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqual | Determines whether a specified AlphanumericRevisionSettings is the same as 'this'.
Public method | IsValid | Determines whether the AlphanumericRevisionSettings object is in a valid state.
Public method | SetSequence | Sets the sequence of strings to be used as numbers for revisions with the Alphanumeric RevisionNumberType.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


AlphanumericRevisionSettings Constructor

Overload List
 | Name | Description
Public method | AlphanumericRevisionSettings | Constructs an AlphanumericRevisionSettings with a simple, default sequence.
Public method | AlphanumericRevisionSettings(AlphanumericRevisionSettings) | Constructs a new copy of the input AlphanumericRevisionSettings object.
Public method | AlphanumericRevisionSettings(IListString, String, String) | Constructs an AlphanumericRevisionSettings object.
Top
See Also

Reference

AlphanumericRevisionSettings Class


AlphanumericRevisionSettings Constructor

Constructs an AlphanumericRevisionSettings with a simple, default sequence.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AlphanumericRevisionSettings()
Public Sub New
public:
AlphanumericRevisionSettings()
new : unit -> AlphanumericRevisionSettings
Remarks
The default sequence contains each letter of the alphabet (may differ based on language settings).
See Also

Reference

AlphanumericRevisionSettings Class
AlphanumericRevisionSettings Overload


AlphanumericRevisionSettings(AlphanumericRevisionSettings) Constructor

Constructs a new copy of the input AlphanumericRevisionSettings object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AlphanumericRevisionSettings(
    AlphanumericRevisionSettings other
)
Public Sub New (
    other As AlphanumericRevisionSettings
)
public:
AlphanumericRevisionSettings(
    AlphanumericRevisionSettings^ other
)
new :
        other : AlphanumericRevisionSettings -> AlphanumericRevisionSettings

Parameters

other AlphanumericRevisionSettings
Exceptions
Exception | Condition
ArgumentException | other is not a valid AlphanumericRevisionSettings.
ArgumentNullException | A non-optional argument was null
See Also

Reference

AlphanumericRevisionSettings Class
AlphanumericRevisionSettings Overload


AlphanumericRevisionSettings(IList<String>, String, String) Constructor

AlphanumericRevisionSettings(IListString, String, String) Constructor

Constructs an AlphanumericRevisionSettings object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AlphanumericRevisionSettings(
    IList<string> sequence,
    string prefix,
    string suffix
)
Public Sub New (
    sequence As IList(Of String),
    prefix As String,
    suffix As String
)
public:
AlphanumericRevisionSettings(
    IList<String^>^ sequence,
    String^ prefix,
    String^ suffix
)
new :
        sequence : IList<string> *
        prefix : string *
        suffix : string -> AlphanumericRevisionSettings

Parameters

sequence IList String

The custom sequence to be used as numbers for revisions with the Alphanumeric RevisionNumberType.

If there are more alphanumeric revisions than there are strings in the sequence, subsequent alphanumeric revisions will be assigned duplicated characters. For example, if the sequence provided were ["X", "Y"], the first alphanumeric revision would be shown as "X", the second as "Y", the third as "XX", then "YY", "XXX", etc.

prefix String
The prefix string for each revision number in the sequence.
suffix String
The suffix string for each revision number in the sequence.
Exceptions
Exception | Condition
ArgumentException | Input sequence contains invalid entries.
ArgumentNullException | A non-optional argument was null
See Also

Reference

AlphanumericRevisionSettings Class
AlphanumericRevisionSettings Overload


AlphanumericRevisionSettings Properties

The AlphanumericRevisionSettings type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Prefix | The prefix string that will be prepended to the number of each revision with Alphanumeric RevisionNumberingType.
Public property | Suffix | The suffix string that will be appended to the number of each revision with Alphanumeric RevisionNumberingType.
Top
See Also

Reference

AlphanumericRevisionSettings Class


AlphanumericRevisionSettings.IsValidObject Property

AlphanumericRevisionSettingsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

AlphanumericRevisionSettings Class


AlphanumericRevisionSettings.Prefix Property

AlphanumericRevisionSettingsPrefix Property

The prefix string that will be prepended to the number of each revision with Alphanumeric RevisionNumberingType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Prefix { get; set; }
Public Property Prefix As String
    Get
    Set
public:
property String^ Prefix {
    String^ get ();
    void set (String^ value);
}
member Prefix : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

AlphanumericRevisionSettings Class


AlphanumericRevisionSettings.Suffix Property

AlphanumericRevisionSettingsSuffix Property

The suffix string that will be appended to the number of each revision with Alphanumeric RevisionNumberingType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Suffix { get; set; }
Public Property Suffix As String
    Get
    Set
public:
property String^ Suffix {
    String^ get ();
    void set (String^ value);
}
member Suffix : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

AlphanumericRevisionSettings Class


AlphanumericRevisionSettings Methods

The AlphanumericRevisionSettings type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetSequence | Gets a list containing the strings to be used as the numbering sequence for revisions with the Alphanumeric RevisionNumberType.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqual | Determines whether a specified AlphanumericRevisionSettings is the same as 'this'.
Public method | IsValid | Determines whether the AlphanumericRevisionSettings object is in a valid state.
Public method | SetSequence | Sets the sequence of strings to be used as numbers for revisions with the Alphanumeric RevisionNumberType.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AlphanumericRevisionSettings Class


AlphanumericRevisionSettings.Dispose Method

AlphanumericRevisionSettingsDispose Method

Releases all resources used by the AlphanumericRevisionSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

AlphanumericRevisionSettings Class


AlphanumericRevisionSettings.GetSequence Method

AlphanumericRevisionSettingsGetSequence Method

Gets a list containing the strings to be used as the numbering sequence for revisions with the Alphanumeric RevisionNumberType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<string> GetSequence()
Public Function GetSequence As IList(Of String)
public:
IList<String^>^ GetSequence()
member GetSequence : unit -> IList<string>

Return Value

IList String
See Also

Reference

AlphanumericRevisionSettings Class


AlphanumericRevisionSettings.IsEqual Method

AlphanumericRevisionSettingsIsEqual Method

Determines whether a specified AlphanumericRevisionSettings is the same as 'this'.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEqual(
    AlphanumericRevisionSettings other
)
Public Function IsEqual (
    other As AlphanumericRevisionSettings
) As Boolean
public:
bool IsEqual(
    AlphanumericRevisionSettings^ other
)
member IsEqual :
        other : AlphanumericRevisionSettings -> bool

Parameters

other AlphanumericRevisionSettings
The AlphanumericRevisionSettings object to be compared with 'this'.

Return Value

Boolean
True, if two AlphanumericRevisionSettings are the same.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
The two AlphanumericRevisionSettings are regarded as the same only if they have the same revision numbering sequence, and the same prefix and suffix strings.
See Also

Reference

AlphanumericRevisionSettings Class


AlphanumericRevisionSettings.IsValid Method

AlphanumericRevisionSettingsIsValid Method

Determines whether the AlphanumericRevisionSettings object is in a valid state.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValid()
Public Function IsValid As Boolean
public:
bool IsValid()
member IsValid : unit -> bool

Return Value

Boolean
True if the settings are valid.
Remarks
The AlphanumericRevisionSettings should have at least one string in its revision numbering sequence.
See Also

Reference

AlphanumericRevisionSettings Class


AlphanumericRevisionSettings.SetSequence Method

AlphanumericRevisionSettingsSetSequence Method

Sets the sequence of strings to be used as numbers for revisions with the Alphanumeric RevisionNumberType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetSequence(
    IList<string> sequence
)
Public Sub SetSequence (
    sequence As IList(Of String)
)
public:
void SetSequence(
    IList<String^>^ sequence
)
member SetSequence :
        sequence : IList<string> -> unit

Parameters

sequence IList String
The sequence. The sequence strings cannot contain commas.
Exceptions
Exception | Condition
ArgumentException | Input sequence contains invalid entries.
ArgumentNullException | A non-optional argument was null
Remarks

If there are more alphanumeric revisions than there are strings in the sequence, subsequent alphanumeric revisions will be assigned duplicated characters. For example, if the sequence provided were ["X", "Y"], the first alphanumeric revision would be shown as "X", the second as "Y", the third as "XX", then "YY", "XXX", etc.

See Also

Reference

AlphanumericRevisionSettings Class


AlternateUnits Enumeration

An enumerated type listing the locations where Alternate units may be displayed in dimensions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum AlternateUnits
Public Enumeration AlternateUnits
public enum class AlternateUnits
type AlternateUnits
Members
Member name | Value | Description
None | 0 | No alternative units.
Right | 1 | Alternative units display to the right of the primary units.
Below | 2 | Alternative units display below the primary units.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


AnalyzesAsType Enumeration

This enum class is used for the BuiltInParameter STRUCTURAL_ANALYZES_AS.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum AnalyzesAsType
Public Enumeration AnalyzesAsType
public enum class AnalyzesAsType
type AnalyzesAsType
Members
Member name | Value | Description
AA_Hanger | 0 |
AA_Gravity | 1 |
AA_Lateral | 2 |
AA_SlabOneWay | 3 |
AA_Mat | 4 |
AA_SlabOnGrade | 5 |
AA_Not_For_Analysis | 6 |
AA_SlabTwoWay | 7 |
AA_GravityLateral | 8 |
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


AngularDimension Class

An object that represents an Angular Dimension within the Revit project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBDimension
Autodesk.Revit.DBAngularDimension
Autodesk.Revit.DBArcLengthDimension

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AngularDimension : Dimension
Public Class AngularDimension
    Inherits Dimension
public ref class AngularDimension : public Dimension
type AngularDimension =
    class
        inherit Dimension
    end

The AngularDimension type exposes the following members.

Properties
 | Name | Description
Public property | Above | The text shown above the segment's value. (Inherited from Dimension)
Public property | AreReferencesAvailable | Indicates if this dimension's references can be resolved. (Inherited from Dimension)
Public property | AreSegmentsEqual | Indicates if all segments are forced to be equal. (Inherited from Dimension)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | Below | The text shown below the segment's value. (Inherited from Dimension)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | Curve | A curve that represents the dimension line. (Inherited from Dimension)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | DimensionShape | The shape of this dimension. (Inherited from Dimension)
Public property | DimensionType | The dimension style of this dimension. (Inherited from Dimension)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyLabel | The family parameter label of the dimension. (Inherited from Dimension)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HasLeader | True if dimension has leader, false otherwise. (Inherited from Dimension)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsLocked | Indicates if this dimension is locked. (Inherited from Dimension)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValid | Indicates if this dimension is valid. (Inherited from Dimension)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LeaderEndPosition | The position of the dimension's leader end point. (Inherited from Dimension)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Retrieves or changes the name associated with the Dimension. (Inherited from Dimension)
Public property | NumberOfSegments | The number of segments for the dimension. (Inherited from Dimension)
Public property | Origin | The dimension origin. (Inherited from Dimension)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Prefix | The text shown before the segment's value. (Inherited from Dimension)
Public property | References | Returns an array of geometric references to which the dimension is attached. (Inherited from Dimension)
Public property | Segments | The segments in the dimension. (Inherited from Dimension)
Public property | Suffix | The text shown after the segment's value. (Inherited from Dimension)
 | TextPosition | The position of the dimension text's drag point. (Inherited from Dimension)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | Value | The value of the dimension. (Inherited from Dimension)
Public property | ValueOverride | The text that replaces the segment's value. (Inherited from Dimension)
Public property | ValueString | The dimension value as a user visible string. (Inherited from Dimension)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | View | Supplies the view that contains the dimension if the dimension is view specific. (Inherited from Dimension)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new instance of an Angular Dimension element within the project.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasOneSegment | Determines whether a dimension has one segment. (Inherited from Dimension)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsTextPositionAdjustable | Indicates if this dimension is supported to set/get TextPosition/LeaderEndPosition. (Inherited from Dimension)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | ResetTextPosition | Resets the text position of the dimension to the initial position determined by its type and parameters. (Inherited from Dimension)
Public method | SetAngularRadius | Set radius of an Angular Dimension arc. The new radius of the arc.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


AngularDimension Properties

The AngularDimension type exposes the following members.

Properties
 | Name | Description
Public property | Above | The text shown above the segment's value. (Inherited from Dimension)
Public property | AreReferencesAvailable | Indicates if this dimension's references can be resolved. (Inherited from Dimension)
Public property | AreSegmentsEqual | Indicates if all segments are forced to be equal. (Inherited from Dimension)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | Below | The text shown below the segment's value. (Inherited from Dimension)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | Curve | A curve that represents the dimension line. (Inherited from Dimension)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | DimensionShape | The shape of this dimension. (Inherited from Dimension)
Public property | DimensionType | The dimension style of this dimension. (Inherited from Dimension)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyLabel | The family parameter label of the dimension. (Inherited from Dimension)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HasLeader | True if dimension has leader, false otherwise. (Inherited from Dimension)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsLocked | Indicates if this dimension is locked. (Inherited from Dimension)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValid | Indicates if this dimension is valid. (Inherited from Dimension)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LeaderEndPosition | The position of the dimension's leader end point. (Inherited from Dimension)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Retrieves or changes the name associated with the Dimension. (Inherited from Dimension)
Public property | NumberOfSegments | The number of segments for the dimension. (Inherited from Dimension)
Public property | Origin | The dimension origin. (Inherited from Dimension)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Prefix | The text shown before the segment's value. (Inherited from Dimension)
Public property | References | Returns an array of geometric references to which the dimension is attached. (Inherited from Dimension)
Public property | Segments | The segments in the dimension. (Inherited from Dimension)
Public property | Suffix | The text shown after the segment's value. (Inherited from Dimension)
 | TextPosition | The position of the dimension text's drag point. (Inherited from Dimension)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | Value | The value of the dimension. (Inherited from Dimension)
Public property | ValueOverride | The text that replaces the segment's value. (Inherited from Dimension)
Public property | ValueString | The dimension value as a user visible string. (Inherited from Dimension)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | View | Supplies the view that contains the dimension if the dimension is view specific. (Inherited from Dimension)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

AngularDimension Class


AngularDimension Methods

The AngularDimension type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new instance of an Angular Dimension element within the project.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasOneSegment | Determines whether a dimension has one segment. (Inherited from Dimension)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsTextPositionAdjustable | Indicates if this dimension is supported to set/get TextPosition/LeaderEndPosition. (Inherited from Dimension)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | ResetTextPosition | Resets the text position of the dimension to the initial position determined by its type and parameters. (Inherited from Dimension)
Public method | SetAngularRadius | Set radius of an Angular Dimension arc. The new radius of the arc.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AngularDimension Class


AngularDimension.Create Method

AngularDimensionCreate Method

Creates a new instance of an Angular Dimension element within the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static AngularDimension Create(
    Document document,
    View dbView,
    Arc arc,
    IList<Reference> references,
    DimensionType dimensionStyle
)
Public Shared Function Create (
    document As Document,
    dbView As View,
    arc As Arc,
    references As IList(Of Reference),
    dimensionStyle As DimensionType
) As AngularDimension
public:
static AngularDimension^ Create(
    Document^ document,
    View^ dbView,
    Arc^ arc,
    IList<Reference^>^ references,
    DimensionType^ dimensionStyle
)
static member Create :
        document : Document *
        dbView : View *
        arc : Arc *
        references : IList<Reference> *
        dimensionStyle : DimensionType -> AngularDimension

Parameters

document Document
The document where new Angular Dimension is created.
dbView View
The view in which the Angular Dimension will appear.
arc Arc
Arc for the Angular Dimension.
references IList Reference
The references which the Angular Dimension will witness.
dimensionStyle DimensionType
Dimension Style.

Return Value

AngularDimension
The newly created Angular Dimension instance, or if the operation fails.
Exceptions
Exception | Condition
ArgumentException | References should be: at least two, non parallel and rays of the arc passed.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
See Also

Reference

AngularDimension Class


AngularDimension.SetAngularRadius Method

AngularDimensionSetAngularRadius Method

Set radius of an Angular Dimension arc. The new radius of the arc.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetAngularRadius(
    double radius
)
Public Sub SetAngularRadius (
    radius As Double
)
public:
void SetAngularRadius(
    double radius
)
member SetAngularRadius :
        radius : float -> unit

Parameters

radius Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The given value for radius must be non-negative.
See Also

Reference

AngularDimension Class


AnnotationMultipleAlignmentUtils Class

A helper providing functionality related to elements that can be aligned to one another. An element that wants to be able to align to other alignable elements using the Multiple Alignment buttons should implement this helper class.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAnnotationMultipleAlignmentUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AnnotationMultipleAlignmentUtils : IDisposable
Public Class AnnotationMultipleAlignmentUtils
    Implements IDisposable
public ref class AnnotationMultipleAlignmentUtils : IDisposable
type AnnotationMultipleAlignmentUtils =
    class
        interface IDisposable
    end

The AnnotationMultipleAlignmentUtils type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the AnnotationMultipleAlignmentUtils
 | ElementSupportsMultiAlign | Returns true if element can be aligned to other similar elements.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | GetAnnotationOutlineWithoutLeaders | Gets the four corners of the alignable element in model space without its leaders.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | MoveWithAnchoredLeaders | Moves the element while keeping the leader end points anchored.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


AnnotationMultipleAlignmentUtils Properties

The AnnotationMultipleAlignmentUtils type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

AnnotationMultipleAlignmentUtils Class


AnnotationMultipleAlignmentUtils.IsValidObject Property

AnnotationMultipleAlignmentUtilsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

AnnotationMultipleAlignmentUtils Class


AnnotationMultipleAlignmentUtils Methods

The AnnotationMultipleAlignmentUtils type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
 | ElementSupportsMultiAlign | Returns true if element can be aligned to other similar elements.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | GetAnnotationOutlineWithoutLeaders | Gets the four corners of the alignable element in model space without its leaders.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | MoveWithAnchoredLeaders | Moves the element while keeping the leader end points anchored.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AnnotationMultipleAlignmentUtils Class


AnnotationMultipleAlignmentUtils.Dispose Method

AnnotationMultipleAlignmentUtilsDispose Method

Releases all resources used by the AnnotationMultipleAlignmentUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

AnnotationMultipleAlignmentUtils Class


AnnotationMultipleAlignmentUtils.ElementSupportsMultiAlign Method

AnnotationMultipleAlignmentUtilsElementSupportsMultiAlign Method

Returns true if element can be aligned to other similar elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool ElementSupportsMultiAlign(
    Element element
)
Public Shared Function ElementSupportsMultiAlign (
    element As Element
) As Boolean
public:
static bool ElementSupportsMultiAlign(
    Element^ element
)
static member ElementSupportsMultiAlign :
        element : Element -> bool

Parameters

element Element
The element to align.

Return Value

Boolean
True if the element can be aligned using the multiple alignment commands, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

AnnotationMultipleAlignmentUtils Class


AnnotationMultipleAlignmentUtils.GetAnnotationOutlineWithoutLeaders Method

AnnotationMultipleAlignmentUtilsGetAnnotationOutlineWithoutLeaders Method

Gets the four corners of the alignable element in model space without its leaders.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<XYZ> GetAnnotationOutlineWithoutLeaders(
    Element element
)
Public Shared Function GetAnnotationOutlineWithoutLeaders (
    element As Element
) As IList(Of XYZ)
public:
static IList<XYZ^>^ GetAnnotationOutlineWithoutLeaders(
    Element^ element
)
static member GetAnnotationOutlineWithoutLeaders :
        element : Element -> IList<XYZ>

Parameters

element Element
The element for which we are retrieving the outline corners.

Return Value

IList XYZ
The array of the four corner points for the alignable element.
Exceptions
Exception | Condition
ArgumentException | The element element does not support multiple alignment behavior. -or-
ArgumentNullException | A non-optional argument was null
See Also

Reference

AnnotationMultipleAlignmentUtils Class


AnnotationMultipleAlignmentUtils.MoveWithAnchoredLeaders Method

AnnotationMultipleAlignmentUtilsMoveWithAnchoredLeaders Method

Moves the element while keeping the leader end points anchored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void MoveWithAnchoredLeaders(
    Element element,
    XYZ moveVec
)
Public Shared Sub MoveWithAnchoredLeaders (
    element As Element,
    moveVec As XYZ
)
public:
static void MoveWithAnchoredLeaders(
    Element^ element,
    XYZ^ moveVec
)
static member MoveWithAnchoredLeaders :
        element : Element *
        moveVec : XYZ -> unit

Parameters

element Element
The element to be moved.
moveVec XYZ
The move vector for translating the element.
Exceptions
Exception | Condition
ArgumentException | The element element does not support multiple alignment behavior.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Failed to move element.
See Also

Reference

AnnotationMultipleAlignmentUtils Class


AnnotationSymbol Class

This object represents a symbol of the Generic Annotation.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBInstance
Autodesk.Revit.DBFamilyInstance
Autodesk.Revit.DBAnnotationSymbol

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AnnotationSymbol : FamilyInstance
Public Class AnnotationSymbol
    Inherits FamilyInstance
public ref class AnnotationSymbol : public FamilyInstance
type AnnotationSymbol =
    class
        inherit FamilyInstance
    end

The AnnotationSymbol type exposes the following members.

Properties
 | Name | Description
Public property | AnnotationSymbolType | The AnnotationSymbol style of this AnnotationSymbol.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanFlipFacing | Property to test whether the orientation of family instance facing can be flipped. (Inherited from FamilyInstance)
Public property | CanFlipHand | Property to test whether the orientation of family instance hand can be flipped. (Inherited from FamilyInstance)
Public property | CanFlipWorkPlane | Identifies if the instance can flip its work plane. (Inherited from FamilyInstance)
Public property | CanRotate | Property to test whether the family instance can be rotated by 180 degrees. (Inherited from FamilyInstance)
Public property | CanSplit | Identifies whether a particular family instance can be split at a point on it's defining curve (by Split(Double)). (Inherited from FamilyInstance)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | ExtensionUtility | Property to check whether the instance can be extended and return the interface for extension operation. (Inherited from FamilyInstance)
Public property | FacingFlipped | Property to test whether the orientation of family instance facing is flipped. (Inherited from FamilyInstance)
Public property | FacingOrientation | Property to get the orientation of family instance facing. (Inherited from FamilyInstance)
Public property | FromRoom | The "From Room" set for the door or window in the last phase of the project. (Inherited from FamilyInstance)
Public property | FromRoomPhase | (Inherited from FamilyInstance)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HandFlipped | Property to test whether the orientation of family instance hand is flipped. (Inherited from FamilyInstance)
Public property | HandOrientation | Property to get the orientation of family instance hand. (Inherited from FamilyInstance)
Public property | HasSpatialElementCalculationPoint | Identifies if this instance has a single SpatialElementCalculationPoint used as the search point for Revit to identify if the instance is inside a room or space. (Inherited from FamilyInstance)
Public property | HasSpatialElementFromToCalculationPoints | Identifies if this instance has a pair of SpatialElementCalculationPoints used as the search points for Revit to identify if the instance lies between up to two rooms or spaces. (Inherited from FamilyInstance)
Public property | Host | If the instance is contained within another element, this property returns the containing element. An instance that is face hosted will return the element containing the face. (Inherited from FamilyInstance)
Public property | HostFace | Property to get the reference to the host face of family instance. (Inherited from FamilyInstance)
Public property | HostParameter | If the instance is hosted by a wall, this property returns the parameter value of the insertion point of the instance along the wall's location curve, as long as the family of the instance isn't work plane based. (Inherited from FamilyInstance)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | Invisible | Property to test whether the family instance is invisible. (Inherited from FamilyInstance)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsSlantedColumn | Indicates if the family instance is a slanted column. (Inherited from FamilyInstance)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | IsWorkPlaneFlipped | Identifies if the instance's work plane is flipped. (Inherited from FamilyInstance)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | Location | This property is used to find the physical location of an instance within project. (Inherited from FamilyInstance)
Public property | MEPModel | Retrieves the MEP model for the family instance. (Inherited from FamilyInstance)
Public property | Mirrored | Property to test whether the family instance is mirrored. (only one axis is flipped) (Inherited from FamilyInstance)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Room | The room in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance)
Public property | RoomPhase | (Inherited from FamilyInstance)
Public property | Space | The space in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance)
Public property | SpacePhase | (Inherited from FamilyInstance)
Public property | StructuralMaterialId | Identifies the material that defines the instance's structural analysis properties. (Inherited from FamilyInstance)
Public property | StructuralMaterialType | This property returns the physical material from which the instance is made. (Inherited from FamilyInstance)
 | StructuralType | Provides the primary structural type of the instance, such as beam or column etc. (Inherited from FamilyInstance)
Public property | StructuralUsage | Provides the primary structural usage of the instance, such as brace, girder etc. (Inherited from FamilyInstance)
Public property | SuperComponent | Property to get the super component of current family instance. (Inherited from FamilyInstance)
 | Symbol | Returns or changes the FamilySymbol object that represents the type of the instance. (Inherited from FamilyInstance)
Public property | ToRoom | The "To Room" set for the door or window in the last phase of the project. (Inherited from FamilyInstance)
Public property | ToRoomPhase | (Inherited from FamilyInstance)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | AddCoping | Adds a coping (cut) to a steel beam. (Inherited from FamilyInstance)
Public method | addLeader | add a leader to this annotation symbol.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | duplicate | Duplicate this annotation symbol.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | flipFacing | The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance)
Public method | FlipFromToRoom | Flips the settings of "From Room" and "To Room" for the door or window instance. (Inherited from FamilyInstance)
Public method | flipHand | The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance)
Public method | GetCopingIds | Lists the elements currently used as coping cutters for this element. (Inherited from FamilyInstance)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFamilyPointPlacementReferences | Returns the Point Placement References for the Family Instance. (Inherited from FamilyInstance)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLeaders | Returns a collection of leaders currently attached to the annotation.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetOriginalGeometry | Returns the original geometry of the instance, before the instance is modified by joins, cuts, coping, extensions, or other post-processing. (Inherited from FamilyInstance)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetReferenceByName | Gets the family instance reference corresponding to the named reference plane in the instance's family. (Inherited from FamilyInstance)
Public method | GetReferenceName | Gets the name of the reference plane in the family corresponding to the given family instance reference. (Inherited from FamilyInstance)
Public method | GetReferences | Gets family instance references corresponding to the reference planes or reference lines of the given reference type in the instance's family. (Inherited from FamilyInstance)
Public method | GetReferenceType | Gets the type of the reference plane or reference line in the instance's family corresponding to the given family instance reference. (Inherited from FamilyInstance)
Public method | GetSpatialElementCalculationPoint | Gets the location of the calculation point for this instance. (Inherited from FamilyInstance)
Public method | GetSpatialElementFromToCalculationPoints | Gets the locations for the calculation points for this instance. (Inherited from FamilyInstance)
 | GetSubComponentIds | Gets the sub component ElementIds of the current family instance. (Inherited from FamilyInstance)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetSweptProfile | Gets the object that describes the profile that is swept along the driving curve for this instance. (Inherited from FamilyInstance)
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances. (Inherited from Instance)
Public method | GetTransform | Gets the transform of the instance. (Inherited from Instance)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasModifiedGeometry | Identifies if the geometry of this FamilyInstance has been modified from the automatically generated default. (Inherited from FamilyInstance)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasSweptProfile | Indicates if this instance can be represented as a swept profile. (Inherited from FamilyInstance)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveCoping | Removes a coping (cut) from a steel beam. (Inherited from FamilyInstance)
Public method | removeLeader | remove a leader of this annotation symbol.
Public method | rotate | The family instance will be flipped by 180 degrees. If it can not be rotated, return false, otherwise return true. (Inherited from FamilyInstance)
Public method | SetCopingIds | Specifies the set of coping cutters on this element. (Inherited from FamilyInstance)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | Split | Splits the family instance element at a point on its defining curve. (Inherited from FamilyInstance)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


AnnotationSymbol Properties

The AnnotationSymbol type exposes the following members.

Properties
 | Name | Description
Public property | AnnotationSymbolType | The AnnotationSymbol style of this AnnotationSymbol.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanFlipFacing | Property to test whether the orientation of family instance facing can be flipped. (Inherited from FamilyInstance)
Public property | CanFlipHand | Property to test whether the orientation of family instance hand can be flipped. (Inherited from FamilyInstance)
Public property | CanFlipWorkPlane | Identifies if the instance can flip its work plane. (Inherited from FamilyInstance)
Public property | CanRotate | Property to test whether the family instance can be rotated by 180 degrees. (Inherited from FamilyInstance)
Public property | CanSplit | Identifies whether a particular family instance can be split at a point on it's defining curve (by Split(Double)). (Inherited from FamilyInstance)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | ExtensionUtility | Property to check whether the instance can be extended and return the interface for extension operation. (Inherited from FamilyInstance)
Public property | FacingFlipped | Property to test whether the orientation of family instance facing is flipped. (Inherited from FamilyInstance)
Public property | FacingOrientation | Property to get the orientation of family instance facing. (Inherited from FamilyInstance)
Public property | FromRoom | The "From Room" set for the door or window in the last phase of the project. (Inherited from FamilyInstance)
Public property | FromRoomPhase | (Inherited from FamilyInstance)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HandFlipped | Property to test whether the orientation of family instance hand is flipped. (Inherited from FamilyInstance)
Public property | HandOrientation | Property to get the orientation of family instance hand. (Inherited from FamilyInstance)
Public property | HasSpatialElementCalculationPoint | Identifies if this instance has a single SpatialElementCalculationPoint used as the search point for Revit to identify if the instance is inside a room or space. (Inherited from FamilyInstance)
Public property | HasSpatialElementFromToCalculationPoints | Identifies if this instance has a pair of SpatialElementCalculationPoints used as the search points for Revit to identify if the instance lies between up to two rooms or spaces. (Inherited from FamilyInstance)
Public property | Host | If the instance is contained within another element, this property returns the containing element. An instance that is face hosted will return the element containing the face. (Inherited from FamilyInstance)
Public property | HostFace | Property to get the reference to the host face of family instance. (Inherited from FamilyInstance)
Public property | HostParameter | If the instance is hosted by a wall, this property returns the parameter value of the insertion point of the instance along the wall's location curve, as long as the family of the instance isn't work plane based. (Inherited from FamilyInstance)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | Invisible | Property to test whether the family instance is invisible. (Inherited from FamilyInstance)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsSlantedColumn | Indicates if the family instance is a slanted column. (Inherited from FamilyInstance)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | IsWorkPlaneFlipped | Identifies if the instance's work plane is flipped. (Inherited from FamilyInstance)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | Location | This property is used to find the physical location of an instance within project. (Inherited from FamilyInstance)
Public property | MEPModel | Retrieves the MEP model for the family instance. (Inherited from FamilyInstance)
Public property | Mirrored | Property to test whether the family instance is mirrored. (only one axis is flipped) (Inherited from FamilyInstance)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Room | The room in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance)
Public property | RoomPhase | (Inherited from FamilyInstance)
Public property | Space | The space in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance)
Public property | SpacePhase | (Inherited from FamilyInstance)
Public property | StructuralMaterialId | Identifies the material that defines the instance's structural analysis properties. (Inherited from FamilyInstance)
Public property | StructuralMaterialType | This property returns the physical material from which the instance is made. (Inherited from FamilyInstance)
 | StructuralType | Provides the primary structural type of the instance, such as beam or column etc. (Inherited from FamilyInstance)
Public property | StructuralUsage | Provides the primary structural usage of the instance, such as brace, girder etc. (Inherited from FamilyInstance)
Public property | SuperComponent | Property to get the super component of current family instance. (Inherited from FamilyInstance)
 | Symbol | Returns or changes the FamilySymbol object that represents the type of the instance. (Inherited from FamilyInstance)
Public property | ToRoom | The "To Room" set for the door or window in the last phase of the project. (Inherited from FamilyInstance)
Public property | ToRoomPhase | (Inherited from FamilyInstance)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

AnnotationSymbol Class


AnnotationSymbol.AnnotationSymbolType Property

AnnotationSymbolAnnotationSymbolType Property

The AnnotationSymbol style of this AnnotationSymbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AnnotationSymbolType AnnotationSymbolType { get; set; }
Public Property AnnotationSymbolType As AnnotationSymbolType
    Get
    Set
public:
property AnnotationSymbolType^ AnnotationSymbolType {
    AnnotationSymbolType^ get ();
    void set (AnnotationSymbolType^ value);
}
member AnnotationSymbolType : AnnotationSymbolType with get, set

Property Value

AnnotationSymbolType
Remarks
The AnnotationSymbolType property can be used to retrieve the kind of the symbol. This property can also be used to change the type of an annotation by setting it to a different type. All the annotation symbol types in the project can be found using the Document.AnnotationSymbolTypes property.
See Also

Reference

AnnotationSymbol Class


AnnotationSymbol Methods

The AnnotationSymbol type exposes the following members.

Methods
 | Name | Description
Public method | AddCoping | Adds a coping (cut) to a steel beam. (Inherited from FamilyInstance)
Public method | addLeader | add a leader to this annotation symbol.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | duplicate | Duplicate this annotation symbol.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | flipFacing | The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance)
Public method | FlipFromToRoom | Flips the settings of "From Room" and "To Room" for the door or window instance. (Inherited from FamilyInstance)
Public method | flipHand | The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance)
Public method | GetCopingIds | Lists the elements currently used as coping cutters for this element. (Inherited from FamilyInstance)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFamilyPointPlacementReferences | Returns the Point Placement References for the Family Instance. (Inherited from FamilyInstance)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLeaders | Returns a collection of leaders currently attached to the annotation.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetOriginalGeometry | Returns the original geometry of the instance, before the instance is modified by joins, cuts, coping, extensions, or other post-processing. (Inherited from FamilyInstance)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetReferenceByName | Gets the family instance reference corresponding to the named reference plane in the instance's family. (Inherited from FamilyInstance)
Public method | GetReferenceName | Gets the name of the reference plane in the family corresponding to the given family instance reference. (Inherited from FamilyInstance)
Public method | GetReferences | Gets family instance references corresponding to the reference planes or reference lines of the given reference type in the instance's family. (Inherited from FamilyInstance)
Public method | GetReferenceType | Gets the type of the reference plane or reference line in the instance's family corresponding to the given family instance reference. (Inherited from FamilyInstance)
Public method | GetSpatialElementCalculationPoint | Gets the location of the calculation point for this instance. (Inherited from FamilyInstance)
Public method | GetSpatialElementFromToCalculationPoints | Gets the locations for the calculation points for this instance. (Inherited from FamilyInstance)
 | GetSubComponentIds | Gets the sub component ElementIds of the current family instance. (Inherited from FamilyInstance)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetSweptProfile | Gets the object that describes the profile that is swept along the driving curve for this instance. (Inherited from FamilyInstance)
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances. (Inherited from Instance)
Public method | GetTransform | Gets the transform of the instance. (Inherited from Instance)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasModifiedGeometry | Identifies if the geometry of this FamilyInstance has been modified from the automatically generated default. (Inherited from FamilyInstance)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasSweptProfile | Indicates if this instance can be represented as a swept profile. (Inherited from FamilyInstance)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveCoping | Removes a coping (cut) from a steel beam. (Inherited from FamilyInstance)
Public method | removeLeader | remove a leader of this annotation symbol.
Public method | rotate | The family instance will be flipped by 180 degrees. If it can not be rotated, return false, otherwise return true. (Inherited from FamilyInstance)
Public method | SetCopingIds | Specifies the set of coping cutters on this element. (Inherited from FamilyInstance)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | Split | Splits the family instance element at a point on its defining curve. (Inherited from FamilyInstance)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AnnotationSymbol Class


AnnotationSymbol.addLeader Method

AnnotationSymboladdLeader Method

add a leader to this annotation symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void addLeader()
Public Sub addLeader
public:
void addLeader()
member addLeader : unit -> unit
See Also

Reference

AnnotationSymbol Class


AnnotationSymbol.duplicate Method

AnnotationSymbolduplicate Method

Duplicate this annotation symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AnnotationSymbol duplicate()
Public Function duplicate As AnnotationSymbol
public:
AnnotationSymbol^ duplicate()
member duplicate : unit -> AnnotationSymbol

Return Value

AnnotationSymbol
Pointer to the new annotation symbol.
See Also

Reference

AnnotationSymbol Class


AnnotationSymbol.GetLeaders Method

AnnotationSymbolGetLeaders Method

Returns a collection of leaders currently attached to the annotation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<Leader> GetLeaders()
Public Function GetLeaders As IList(Of Leader)
public:
IList<Leader^>^ GetLeaders()
member GetLeaders : unit -> IList<Leader>

Return Value

IList Leader
Remarks
This method supersedes an older Leaders property which has been deprecated.
See Also

Reference

AnnotationSymbol Class


AnnotationSymbol.removeLeader Method

AnnotationSymbolremoveLeader Method

remove a leader of this annotation symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void removeLeader()
Public Sub removeLeader
public:
void removeLeader()
member removeLeader : unit -> unit
See Also

Reference

AnnotationSymbol Class


AnnotationSymbolType Class

An object that represents an annotation style.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBInsertableObject
Autodesk.Revit.DBFamilySymbol
Autodesk.Revit.DBAnnotationSymbolType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AnnotationSymbolType : FamilySymbol
Public Class AnnotationSymbolType
    Inherits FamilySymbol
public ref class AnnotationSymbolType : public FamilySymbol
type AnnotationSymbolType =
    class
        inherit FamilySymbol
    end

The AnnotationSymbolType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | Family | The Family object to which the symbol belongs. (Inherited from FamilySymbol)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsActive | Identifies whether the symbol is active. (Inherited from FamilySymbol)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | StructuralMaterialType | This property returns the physical material from which the type is made. (Inherited from FamilySymbol)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | Activate | Activates the symbol to ensure that its geometry is accessible. (Inherited from FamilySymbol)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveStructuralSection | Identifies if this FamilySymbol can have a structural section. (Inherited from FamilySymbol)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFamilyPointLocations | Returns the Point Locations for the Family Symbol. (Inherited from FamilySymbol)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetStructuralSection | Gets the structural section from element. (Inherited from FamilySymbol)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetThermalProperties | Gets the thermal properties for the given FamilySymbol. (Inherited from FamilySymbol)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasThermalProperties | Identifies if this FamilySymbol can include thermal properties. (Inherited from FamilySymbol)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetStructuralSection | Sets the structural section in element. (Inherited from FamilySymbol)
Public method | SetThermalProperties | Sets the thermal properties for the given FamilySymbol. (Inherited from FamilySymbol)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


AnnotationSymbolType Properties

The AnnotationSymbolType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | Family | The Family object to which the symbol belongs. (Inherited from FamilySymbol)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsActive | Identifies whether the symbol is active. (Inherited from FamilySymbol)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | StructuralMaterialType | This property returns the physical material from which the type is made. (Inherited from FamilySymbol)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

AnnotationSymbolType Class


AnnotationSymbolType Methods

The AnnotationSymbolType type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Activates the symbol to ensure that its geometry is accessible. (Inherited from FamilySymbol)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveStructuralSection | Identifies if this FamilySymbol can have a structural section. (Inherited from FamilySymbol)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFamilyPointLocations | Returns the Point Locations for the Family Symbol. (Inherited from FamilySymbol)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetStructuralSection | Gets the structural section from element. (Inherited from FamilySymbol)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetThermalProperties | Gets the thermal properties for the given FamilySymbol. (Inherited from FamilySymbol)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasThermalProperties | Identifies if this FamilySymbol can include thermal properties. (Inherited from FamilySymbol)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetStructuralSection | Sets the structural section in element. (Inherited from FamilySymbol)
Public method | SetThermalProperties | Sets the thermal properties for the given FamilySymbol. (Inherited from FamilySymbol)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AnnotationSymbolType Class


APIObject Class

Supports all objects in the Autodesk Revit API hierarchy.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class APIObject : IDisposable
Public Class APIObject
    Implements IDisposable
public ref class APIObject : IDisposable
type APIObject =
    class
        interface IDisposable
    end

The APIObject type exposes the following members.

Properties
Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable.
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.CreationApplication
Autodesk.Revit.CreationItemFactoryBase
Autodesk.Revit.DBBinding
Autodesk.Revit.DBBoundingBoxXYZ
Autodesk.Revit.DBCategory
Autodesk.Revit.DBCategoryNameMap
Autodesk.Revit.DBCategoryNameMapIterator
Autodesk.Revit.DBCategorySet
Autodesk.Revit.DBCategorySetIterator
Autodesk.Revit.DBCity
Autodesk.Revit.DBCitySet
Autodesk.Revit.DBCitySetIterator
Autodesk.Revit.DBColor
Autodesk.Revit.DBCombinableElementArray
Autodesk.Revit.DBCombinableElementArrayIterator
Autodesk.Revit.DBConnectorSet
Autodesk.Revit.DBConnectorSetIterator
Autodesk.Revit.DBCurtainCell
Autodesk.Revit.DBCurtainGrid
Autodesk.Revit.DBCurtainGridSet
Autodesk.Revit.DBCurtainGridSetIterator
Autodesk.Revit.DBCurveArrArray
Autodesk.Revit.DBCurveArrArrayIterator
Autodesk.Revit.DBCurveArray
Autodesk.Revit.DBCurveArrayIterator
Autodesk.Revit.DBCurveByPointsArray
Autodesk.Revit.DBCurveByPointsArrayIterator
Autodesk.Revit.DBDefinitionBindingMap
Autodesk.Revit.DBDefinitionBindingMapIterator
Autodesk.Revit.DBDefinitionFile
Autodesk.Revit.DBDefinitionGroup
Autodesk.Revit.DBDetailCurveArray
Autodesk.Revit.DBDetailCurveArrayIterator
Autodesk.Revit.DBDimensionSegment
Autodesk.Revit.DBDimensionSegmentArray
Autodesk.Revit.DBDimensionSegmentArrayIterator
Autodesk.Revit.DBDocumentSet
Autodesk.Revit.DBDocumentSetIterator
Autodesk.Revit.DBDoubleArray
Autodesk.Revit.DBDoubleArrayIterator
Autodesk.Revit.DBEdgeArray
Autodesk.Revit.DBEdgeArrayArray
Autodesk.Revit.DBEdgeArrayArrayIterator
Autodesk.Revit.DBEdgeArrayIterator
Autodesk.Revit.DB.ElectricalCorrectionFactor
Autodesk.Revit.DB.ElectricalCorrectionFactorSet
Autodesk.Revit.DB.ElectricalCorrectionFactorSetIterator
Autodesk.Revit.DB.ElectricalDistributionSysTypeSet
Autodesk.Revit.DB.ElectricalDistributionSysTypeSetIterator
Autodesk.Revit.DB.ElectricalGroundConductorSize
Autodesk.Revit.DB.ElectricalGroundConductorSizeSet
Autodesk.Revit.DB.ElectricalGroundConductorSizeSetIterator
Autodesk.Revit.DB.ElectricalInsulationTypeSet
Autodesk.Revit.DB.ElectricalInsulationTypeSetIterator
Autodesk.Revit.DB.ElectricalTemperatureRatingTypeSet
Autodesk.Revit.DB.ElectricalTemperatureRatingTypeSetIterator
Autodesk.Revit.DB.ElectricalVoltageTypeSet
Autodesk.Revit.DB.ElectricalVoltageTypeSetIterator
Autodesk.Revit.DB.ElectricalWireConduitType
Autodesk.Revit.DB.ElectricalWireConduitTypeSet
Autodesk.Revit.DB.ElectricalWireConduitTypeSetIterator
Autodesk.Revit.DB.ElectricalWireMaterialTypeSet
Autodesk.Revit.DB.ElectricalWireMaterialTypeSetIterator
Autodesk.Revit.DB.ElectricalWireSet
Autodesk.Revit.DB.ElectricalWireSetIterator
Autodesk.Revit.DB.ElectricalWireSize
Autodesk.Revit.DB.ElectricalWireSizeSet
Autodesk.Revit.DB.ElectricalWireSizeSetIterator
Autodesk.Revit.DB.ElectricalWireTypeSet
Autodesk.Revit.DB.ElectricalWireTypeSetIterator
Autodesk.Revit.DBElementArray
Autodesk.Revit.DBElementArrayIterator
Autodesk.Revit.DBElementSet
Autodesk.Revit.DBElementSetIterator
Autodesk.Revit.DBFaceArray
Autodesk.Revit.DBFaceArrayIterator
Autodesk.Revit.DBFamilyElementVisibility
Autodesk.Revit.DBFamilyManager
Autodesk.Revit.DBFamilyParameter
Autodesk.Revit.DBFamilyParameterSet
Autodesk.Revit.DBFamilyParameterSetIterator
Autodesk.Revit.DBFamilyPointLocation
Autodesk.Revit.DBFamilyPointPlacementReference
Autodesk.Revit.DBFamilyType
Autodesk.Revit.DBFamilyTypeSet
Autodesk.Revit.DBFamilyTypeSetIterator
Autodesk.Revit.DBFormArray
Autodesk.Revit.DBFormArrayIterator
Autodesk.Revit.DBGeomCombinationSet
Autodesk.Revit.DBGeomCombinationSetIterator
Autodesk.Revit.DBGeometryObject
Autodesk.Revit.DBGroupSet
Autodesk.Revit.DBGroupSetIterator
Autodesk.Revit.DBIntersectionResult
Autodesk.Revit.DBIntersectionResultArray
Autodesk.Revit.DBIntersectionResultArrayIterator
Autodesk.Revit.DBLayoutRule
Autodesk.Revit.DBLeader
Autodesk.Revit.DBLeaderArray
Autodesk.Revit.DBLeaderArrayIterator
Autodesk.Revit.DBLocation
Autodesk.Revit.DB.MechanicalMEPBuildingConstructionSet
Autodesk.Revit.DB.MechanicalMEPBuildingConstructionSetIterator
Autodesk.Revit.DB.MechanicalSpaceSet
Autodesk.Revit.DB.MechanicalSpaceSetIterator
Autodesk.Revit.DBMEPModel
Autodesk.Revit.DBModelCurveArrArray
Autodesk.Revit.DBModelCurveArrArrayIterator
Autodesk.Revit.DBModelCurveArray
Autodesk.Revit.DBModelCurveArrayIterator
Autodesk.Revit.DBMullionTypeSet
Autodesk.Revit.DBMullionTypeSetIterator
Autodesk.Revit.DBOptions
Autodesk.Revit.DBPanelTypeSet
Autodesk.Revit.DBPanelTypeSetIterator
Autodesk.Revit.DBPaperSize
Autodesk.Revit.DBPaperSizeSet
Autodesk.Revit.DBPaperSizeSetIterator
Autodesk.Revit.DBPaperSource
Autodesk.Revit.DBPaperSourceSet
Autodesk.Revit.DBPaperSourceSetIterator
Autodesk.Revit.DBParameter
Autodesk.Revit.DBParameterMap
Autodesk.Revit.DBParameterMapIterator
Autodesk.Revit.DBParameterSet
Autodesk.Revit.DBParameterSetIterator
Autodesk.Revit.DBPhaseArray
Autodesk.Revit.DBPhaseArrayIterator
Autodesk.Revit.DBPlanCircuit
Autodesk.Revit.DBPlanCircuitSet
Autodesk.Revit.DBPlanCircuitSetIterator
Autodesk.Revit.DBPlanTopology
Autodesk.Revit.DBPlanTopologySet
Autodesk.Revit.DBPlanTopologySetIterator
Autodesk.Revit.DBPrintManager
Autodesk.Revit.DBPrintParameters
Autodesk.Revit.DBPrintSetup
Autodesk.Revit.DBProjectLocationSet
Autodesk.Revit.DBProjectLocationSetIterator
Autodesk.Revit.DBReference
Autodesk.Revit.DBReferenceArray
Autodesk.Revit.DBReferenceArrayArray
Autodesk.Revit.DBReferenceArrayArrayIterator
Autodesk.Revit.DBReferenceArrayIterator
Autodesk.Revit.DBReferencePointArray
Autodesk.Revit.DBReferencePointArrayIterator
Autodesk.Revit.DBSettings
Autodesk.Revit.DBSlabShapeCreaseArray
Autodesk.Revit.DBSlabShapeCreaseArrayIterator
Autodesk.Revit.DBSlabShapeVertexArray
Autodesk.Revit.DBSlabShapeVertexArrayIterator
Autodesk.Revit.DBSpacingRule
Autodesk.Revit.DB.SteelSteelElementProperties
Autodesk.Revit.DBSweepProfile
Autodesk.Revit.DBSymbolicCurveArray
Autodesk.Revit.DBSymbolicCurveArrayIterator
Autodesk.Revit.DBTemporaryViewModes
Autodesk.Revit.DBThermalProperties
Autodesk.Revit.DBTilePatterns
Autodesk.Revit.DBTransform
Autodesk.Revit.DBVertexIndexPairArray
Autodesk.Revit.DBVertexIndexPairArrayIterator
Autodesk.Revit.DBViewSet
Autodesk.Revit.DBViewSetIterator
Autodesk.Revit.DBViewSheetSetting
Autodesk.Revit.DB.VisualAssetSet
Autodesk.Revit.DB.VisualAssetSetIterator
Autodesk.Revit.UI.EventsDialogBoxData
Autodesk.Revit.UIExternalApplicationArray
Autodesk.Revit.UIExternalApplicationArrayIterator
Autodesk.Revit.UIExternalCommandData
Autodesk.Revit.UITaskDialog


APIObject Properties

The APIObject type exposes the following members.

Properties
Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable.
Top
See Also

Reference

APIObject Class


APIObject.IsReadOnly Property

APIObjectIsReadOnly Property

Identifies if the object is read-only or modifiable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsReadOnly { get; }
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get ();
}
abstract IsReadOnly : bool with get
override IsReadOnly : bool with get

Property Value

Boolean
If true, the object may not be modified. If false, the object's contents may be modified.
Example
C#
VB
C++
F#
Copy
Document project = uiApplication.ActiveUIDocument.Document;
Settings settings = project.Settings;
TaskDialog.Show("Revit","Categories: " + settings.Categories.IsReadOnly.ToString());
Dim project As Document = uiApplication.ActiveUIDocument.Document
Dim settings As Settings = project.Settings
TaskDialog.Show("Revit", "Categories: " + settings.Categories.IsReadOnly.ToString())

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

APIObject Class


APIObject Methods

The APIObject type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

APIObject Class


APIObject.Dispose Method

APIObjectDispose Method

Causes the object to release immediately any resources it may be utilizing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
Remarks
This method is usually called implicitly by the programming language when the object is destroyed. After calling this method the object will no longer work correctly.
See Also

Reference

APIObject Class


AppearanceAssetElement Class

An element that contains a rendering asset used as a portion of a material definition.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBAppearanceAssetElement

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AppearanceAssetElement : Element
Public Class AppearanceAssetElement
    Inherits Element
public ref class AppearanceAssetElement : public Element
type AppearanceAssetElement =
    class
        inherit Element
    end

The AppearanceAssetElement type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new AppearanceAssetElement from an existing rendering asset.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
 | Duplicate | Duplicates the appearance asset element.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
 | GetAppearanceAssetElementByName | Gets an AppearanceAssetElement by name.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetRenderingAsset | Gets the rendering asset for the appearance asset element.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetRenderingAsset | Sets the rendering asset for the appearance asset element.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


AppearanceAssetElement Properties

The AppearanceAssetElement type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

AppearanceAssetElement Class


AppearanceAssetElement Methods

The AppearanceAssetElement type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new AppearanceAssetElement from an existing rendering asset.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
 | Duplicate | Duplicates the appearance asset element.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
 | GetAppearanceAssetElementByName | Gets an AppearanceAssetElement by name.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetRenderingAsset | Gets the rendering asset for the appearance asset element.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetRenderingAsset | Sets the rendering asset for the appearance asset element.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AppearanceAssetElement Class


AppearanceAssetElement.Create Method

AppearanceAssetElementCreate Method

Creates a new AppearanceAssetElement from an existing rendering asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static AppearanceAssetElement Create(
    Document document,
    string name,
    Asset asset
)
Public Shared Function Create (
    document As Document,
    name As String,
    asset As Asset
) As AppearanceAssetElement
public:
static AppearanceAssetElement^ Create(
    Document^ document,
    String^ name,
    Asset^ asset
)
static member Create :
        document : Document *
        name : string *
        asset : Asset -> AppearanceAssetElement

Parameters

document Document
The document in which to create the AppearanceAssetElement.
name String
The name of the AppearanceAssetElement.
asset Asset
The rendering asset of the element.

Return Value

AppearanceAssetElement
The new AppearanceAssetElement.
Exceptions
Exception | Condition
ArgumentException | name is an empty string. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- The given value for name is already in use as an appearance asset name.
ArgumentNullException | A non-optional argument was null
See Also

Reference

AppearanceAssetElement Class


AppearanceAssetElement.Duplicate Method

AppearanceAssetElementDuplicate Method

Duplicates the appearance asset element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AppearanceAssetElement Duplicate(
    string name
)
Public Function Duplicate (
    name As String
) As AppearanceAssetElement
public:
AppearanceAssetElement^ Duplicate(
    String^ name
)
member Duplicate :
        name : string -> AppearanceAssetElement

Parameters

name String
Name of the new appearance asset element - this name must be correctly structured for Revit use and not duplicate the name of another appearance asset in the document.

Return Value

AppearanceAssetElement
The new AppearanceAssetElement.
Exceptions
Exception | Condition
ArgumentException | name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- The given value for name is already in use as an appearance asset name.
ArgumentNullException | A non-optional argument was null
Remarks
The asset contained by this element will be duplicated as well. Changes to the duplicated element or its asset do not affect the original element and asset.
Example
C#
VB
C++
F#
Copy
public void DuplicateAndModifyMaterial(Material material)
{
   ElementId appearanceAssetId = material.AppearanceAssetId;

   AppearanceAssetElement assetElem = material.Document.GetElement(appearanceAssetId) as AppearanceAssetElement;

   ElementId duplicateAssetElementId = ElementId.InvalidElementId;

   using (Transaction t = new Transaction(material.Document, "Duplicate Red Carpet Material"))
   {
      t.Start();

      // Duplicate the material
      Material duplicateMaterial = material.Duplicate("Blue Carpet");

      // Duplicate the appearance asset and the asset in it
      AppearanceAssetElement duplicateAssetElement = assetElem.Duplicate("Blue Carpet");

      // Assign the asset element to the material
      duplicateMaterial.AppearanceAssetId = duplicateAssetElement.Id;

      duplicateAssetElementId = duplicateAssetElement.Id;

      t.Commit();
   }

   // Make changes to the duplicate asset
   using (Transaction t2 = new Transaction(material.Document, "Change blue carpet material"))
   {
      t2.Start();

      using (AppearanceAssetEditScope editScope = new AppearanceAssetEditScope(assetElem.Document))
      {
         Asset editableAsset = editScope.Start(duplicateAssetElementId);   // returns an editable copy of the appearance asset

         // Description
         AssetPropertyString descriptionProperty =
            editableAsset.FindByName("description") as AssetPropertyString;
         descriptionProperty.Value = "blue carpet";

         // Diffuse image
         AssetPropertyDoubleArray4d genericDiffuseProperty = editableAsset.FindByName("generic_diffuse") as AssetPropertyDoubleArray4d;

         genericDiffuseProperty.SetValueAsColor(new Color(0x00, 0x00, 0xFF));

         Asset connectedAsset = genericDiffuseProperty.GetSingleConnectedAsset();

         AssetPropertyString bitmapProperty = connectedAsset.FindByName("unifiedbitmap_Bitmap") as AssetPropertyString;

         bitmapProperty.Value = "Finishes.Flooring.Carpet.4.png";

         editScope.Commit(true);
      }

      t2.Commit();
   }
}
Public Sub DuplicateAndModifyMaterial(material As Material)
    Dim appearanceAssetId As ElementId = material.AppearanceAssetId

    Dim assetElem As AppearanceAssetElement = TryCast(material.Document.GetElement(appearanceAssetId), AppearanceAssetElement)

    Dim duplicateAssetElementId As ElementId = ElementId.InvalidElementId

    Using t As New Transaction(material.Document, "Duplicate Red Carpet Material")
        t.Start()

        ' Duplicate the material
        Dim duplicateMaterial As Material = material.Duplicate("Blue Carpet")

        ' Duplicate the appearance asset and the asset in it
        Dim duplicateAssetElement As AppearanceAssetElement = assetElem.Duplicate("Blue Carpet")

        ' Assign the asset element to the material
        duplicateMaterial.AppearanceAssetId = duplicateAssetElement.Id

        duplicateAssetElementId = duplicateAssetElement.Id

        t.Commit()
    End Using

    ' Make changes to the duplicate asset
    Using t2 As New Transaction(material.Document, "Change blue carpet material")
        t2.Start()

        Using editScope As New AppearanceAssetEditScope(assetElem.Document)
            Dim editableAsset As Asset = editScope.Start(duplicateAssetElementId)
       ' returns an editable copy of the appearance asset
       Dim descriptionProperty As AssetPropertyString = TryCast(editableAsset.FindByName("description"), AssetPropertyString)
       descriptionProperty.Value = "blue carpet"

       ' Diffuse image
       Dim genericDiffuseProperty As AssetPropertyDoubleArray4d = TryCast(editableAsset.FindByName("generic_diffuse"), AssetPropertyDoubleArray4d)

       genericDiffuseProperty.SetValueAsColor(New Color(&H0, &H0, &HFF))

            Dim connectedAsset As Asset = genericDiffuseProperty.GetSingleConnectedAsset()

       Dim bitmapProperty As AssetPropertyString = TryCast(connectedAsset.FindByName("unifiedbitmap_Bitmap"), AssetPropertyString)

       bitmapProperty.Value = "Finishes.Flooring.Carpet.4.png"

            editScope.Commit(True)
        End Using

        t2.Commit()
    End Using
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

AppearanceAssetElement Class


AppearanceAssetElement.GetAppearanceAssetElementByName Method

AppearanceAssetElementGetAppearanceAssetElementByName Method

Gets an AppearanceAssetElement by name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static AppearanceAssetElement GetAppearanceAssetElementByName(
    Document doc,
    string name
)
Public Shared Function GetAppearanceAssetElementByName (
    doc As Document,
    name As String
) As AppearanceAssetElement
public:
static AppearanceAssetElement^ GetAppearanceAssetElementByName(
    Document^ doc,
    String^ name
)
static member GetAppearanceAssetElementByName :
        doc : Document *
        name : string -> AppearanceAssetElement

Parameters

doc Document
Document containing the AppearanceAssetElement.
name String
Name of the AppearanceAssetElement.

Return Value

AppearanceAssetElement
The AppearanceAssetElement with the given name, or if this element does not exist.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

AppearanceAssetElement Class


AppearanceAssetElement.GetRenderingAsset Method

AppearanceAssetElementGetRenderingAsset Method

Gets the rendering asset for the appearance asset element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Asset GetRenderingAsset()
Public Function GetRenderingAsset As Asset
public:
Asset^ GetRenderingAsset()
member GetRenderingAsset : unit -> Asset

Return Value

Asset
The rendering asset held by this appearance asset element.
Remarks
The retrieved Asset may be empty if it is loaded from material library without any modification. In this case, you can use Application.GetAssets(AssetType.Appearance) to load all preset appearance assets, and retrieve the asset by its name.
See Also

Reference

AppearanceAssetElement Class


AppearanceAssetElement.SetRenderingAsset Method

AppearanceAssetElementSetRenderingAsset Method

Sets the rendering asset for the appearance asset element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetRenderingAsset(
    Asset asset
)
Public Sub SetRenderingAsset (
    asset As Asset
)
public:
void SetRenderingAsset(
    Asset^ asset
)
member SetRenderingAsset :
        asset : Asset -> unit

Parameters

asset Asset
The new rendering asset. It should be an appearance asset.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | The asset is not an appearance asset.
See Also

Reference

AppearanceAssetElement Class


Arc Class

A circular arc.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGeometryObject
Autodesk.Revit.DBCurve
Autodesk.Revit.DBArc

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Arc : Curve
Public Class Arc
    Inherits Curve
public ref class Arc : public Curve
type Arc =
    class
        inherit Curve
    end

The Arc type exposes the following members.

Properties
 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve)
Public property | Center | Returns the center of the arc.
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve)
Public property | IsClosed | Describes whether the curve is closed. (Inherited from Curve)
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject)
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Length | The exact length of the curve. (Inherited from Curve)
Public property | Normal | Returns the normal to the plane in which the arc is defined.
Public property | Period | The period of this curve. (Inherited from Curve)
Public property | Radius | Returns the radius of the arc.
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve)
Public property | Visibility | The visibility. (Inherited from GeometryObject)
Public property | XDirection | Returns the X direction.
Public property | YDirection | Returns the Y direction.
Top
Methods
 | Name | Description
Public method | Clone | Returns a copy of this curve. (Inherited from Curve)
Public method | ComputeClosestPoints | Find the closest points between two curves. Closest points mean closest pairs of points, each pair consisting of a point on this, say P1, and a point on other curve, say P2. P1 and P2 are closest locally. Each pairs of closest points will be represented by the corresponding parameter values with respect to the two curves and the 3d points. A closest pair is also known as a pair of critical points of the distance function between points of the two curves. If the input parameter returnAllCriticalPoints is set to false, then the function will return only pairs with minimum distance. (Inherited from Curve)
Public method | ComputeDerivatives | Returns the vectors describing the curve at the specified parameter. (Inherited from Curve)
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve)
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve)
 | Create(XYZ, XYZ, XYZ) | Creates a new geometric arc object based on three points.
 | Create(Plane, Double, Double, Double) | Creates a new geometric arc object based on plane, radius, and angles.
 | Create(XYZ, Double, Double, Double, XYZ, XYZ) | Creates a new geometric arc object based on center, radius, unit vectors, and angles.
Public method | CreateOffset | Creates a new curve that is an offset of the existing curve. (Inherited from Curve)
Public method | CreateReversed | Creates a new curve with the opposite orientation of the existing curve. (Inherited from Curve)
Public method | CreateTransformed | Crates a new instance of a curve as a transformation of this curve. (Inherited from Curve)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject)
Public method | Evaluate | Evaluates and returns the point that matches a parameter along the curve. (Inherited from Curve)
Public method | GetEndParameter | Returns the raw parameter value at the start or end of this curve. (Inherited from Curve)
Public method | GetEndPoint | Returns the 3D point at the start or end of this curve. (Inherited from Curve)
Public method | GetEndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve)
Public method | Intersect(Curve, IntersectionResultArray) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve)
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve)
Public method | IsInside(Double, Int32) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve)
Public method | MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve)
Public method | MakeUnbound | Makes this curve unbound. (Inherited from Curve)
Public method | Project | Projects the specified point on this curve. (Inherited from Curve)
Public method | SetGraphicsStyleId | Sets the graphics style id for this curve. (Inherited from Curve)
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The arc lies in the plane defined by center and normal.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Arc Properties

The Arc type exposes the following members.

Properties
 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve)
Public property | Center | Returns the center of the arc.
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve)
Public property | IsClosed | Describes whether the curve is closed. (Inherited from Curve)
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject)
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Length | The exact length of the curve. (Inherited from Curve)
Public property | Normal | Returns the normal to the plane in which the arc is defined.
Public property | Period | The period of this curve. (Inherited from Curve)
Public property | Radius | Returns the radius of the arc.
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve)
Public property | Visibility | The visibility. (Inherited from GeometryObject)
Public property | XDirection | Returns the X direction.
Public property | YDirection | Returns the Y direction.
Top
See Also

Reference

Arc Class


Arc.Center Property

ArcCenter Property

Returns the center of the arc.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Center { get; }
Public ReadOnly Property Center As XYZ
    Get
public:
property XYZ^ Center {
    XYZ^ get ();
}
member Center : XYZ with get

Property Value

XYZ
See Also

Reference

Arc Class


Arc.Normal Property

ArcNormal Property

Returns the normal to the plane in which the arc is defined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Normal { get; }
Public ReadOnly Property Normal As XYZ
    Get
public:
property XYZ^ Normal {
    XYZ^ get ();
}
member Normal : XYZ with get

Property Value

XYZ
See Also

Reference

Arc Class


Arc.Radius Property

ArcRadius Property

Returns the radius of the arc.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Radius { get; }
Public ReadOnly Property Radius As Double
    Get
public:
property double Radius {
    double get ();
}
member Radius : float with get

Property Value

Double
See Also

Reference

Arc Class


Arc.XDirection Property

ArcXDirection Property

Returns the X direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ XDirection { get; }
Public ReadOnly Property XDirection As XYZ
    Get
public:
property XYZ^ XDirection {
    XYZ^ get ();
}
member XDirection : XYZ with get

Property Value

XYZ
See Also

Reference

Arc Class


Arc.YDirection Property

ArcYDirection Property

Returns the Y direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ YDirection { get; }
Public ReadOnly Property YDirection As XYZ
    Get
public:
property XYZ^ YDirection {
    XYZ^ get ();
}
member YDirection : XYZ with get

Property Value

XYZ
See Also

Reference

Arc Class


Arc Methods

The Arc type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Returns a copy of this curve. (Inherited from Curve)
Public method | ComputeClosestPoints | Find the closest points between two curves. Closest points mean closest pairs of points, each pair consisting of a point on this, say P1, and a point on other curve, say P2. P1 and P2 are closest locally. Each pairs of closest points will be represented by the corresponding parameter values with respect to the two curves and the 3d points. A closest pair is also known as a pair of critical points of the distance function between points of the two curves. If the input parameter returnAllCriticalPoints is set to false, then the function will return only pairs with minimum distance. (Inherited from Curve)
Public method | ComputeDerivatives | Returns the vectors describing the curve at the specified parameter. (Inherited from Curve)
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve)
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve)
 | Create(XYZ, XYZ, XYZ) | Creates a new geometric arc object based on three points.
 | Create(Plane, Double, Double, Double) | Creates a new geometric arc object based on plane, radius, and angles.
 | Create(XYZ, Double, Double, Double, XYZ, XYZ) | Creates a new geometric arc object based on center, radius, unit vectors, and angles.
Public method | CreateOffset | Creates a new curve that is an offset of the existing curve. (Inherited from Curve)
Public method | CreateReversed | Creates a new curve with the opposite orientation of the existing curve. (Inherited from Curve)
Public method | CreateTransformed | Crates a new instance of a curve as a transformation of this curve. (Inherited from Curve)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject)
Public method | Evaluate | Evaluates and returns the point that matches a parameter along the curve. (Inherited from Curve)
Public method | GetEndParameter | Returns the raw parameter value at the start or end of this curve. (Inherited from Curve)
Public method | GetEndPoint | Returns the 3D point at the start or end of this curve. (Inherited from Curve)
Public method | GetEndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve)
Public method | Intersect(Curve, IntersectionResultArray) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve)
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve)
Public method | IsInside(Double, Int32) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve)
Public method | MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve)
Public method | MakeUnbound | Makes this curve unbound. (Inherited from Curve)
Public method | Project | Projects the specified point on this curve. (Inherited from Curve)
Public method | SetGraphicsStyleId | Sets the graphics style id for this curve. (Inherited from Curve)
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Arc Class


Arc.Create Method

ArcCreate Method

Overload List
Name | Description
Create(XYZ, XYZ, XYZ) | Creates a new geometric arc object based on three points.
Create(Plane, Double, Double, Double) | Creates a new geometric arc object based on plane, radius, and angles.
Create(XYZ, Double, Double, Double, XYZ, XYZ) | Creates a new geometric arc object based on center, radius, unit vectors, and angles.
Top
See Also

Reference

Arc Class


Arc.Create(XYZ, XYZ, XYZ) Method

ArcCreate(XYZ, XYZ, XYZ) Method

Creates a new geometric arc object based on three points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Arc Create(
    XYZ end0,
    XYZ end1,
    XYZ pointOnArc
)
Public Shared Function Create (
    end0 As XYZ,
    end1 As XYZ,
    pointOnArc As XYZ
) As Arc
public:
static Arc^ Create(
    XYZ^ end0,
    XYZ^ end1,
    XYZ^ pointOnArc
)
static member Create :
        end0 : XYZ *
        end1 : XYZ *
        pointOnArc : XYZ -> Arc

Parameters

end0 XYZ
The start point of the arc.
end1 XYZ
The end point of the arc.
pointOnArc XYZ
A point on the arc.

Return Value

Arc
The new arc.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was NULL
ArgumentsInconsistentException | The vectors end0 and end1 are coincident. -or- The vectors end0 and pointOnArc are coincident. -or- The vectors end1 and pointOnArc are coincident. -or- Cannot create an arc. -or- Curve length is too small for Revit's tolerance (as identified by Application.ShortCurveTolerance).
Example
C#
VB
C++
F#
Copy
// Create a new arc using two ends and a point on the curve
XYZ end0 = new XYZ(1, 0, 0);    // start point of the arc
XYZ end1 = new XYZ(10, 10, 10); // end point of the arc
XYZ pointOnCurve = new XYZ(10, 0, 0);   // point along arc

Arc arc = Arc.Create(end0, end1, pointOnCurve);
' Create a new arc using two ends and a point on the curve
Dim end0 As New XYZ(1, 0, 0)
' start point of the arc
Dim end1 As New XYZ(10, 10, 10)
' end point of the arc
Dim pointOnCurve As New XYZ(10, 0, 0)
' point along arc
Dim arc__1 As Arc = Arc.Create(end0, end1, pointOnCurve)

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Arc Class
Create Overload


Arc.Create(Plane, Double, Double, Double) Method

ArcCreate(Plane, Double, Double, Double) Method

Creates a new geometric arc object based on plane, radius, and angles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Arc Create(
    Plane plane,
    double radius,
    double startAngle,
    double endAngle
)
Public Shared Function Create (
    plane As Plane,
    radius As Double,
    startAngle As Double,
    endAngle As Double
) As Arc
public:
static Arc^ Create(
    Plane^ plane,
    double radius,
    double startAngle,
    double endAngle
)
static member Create :
        plane : Plane *
        radius : float *
        startAngle : float *
        endAngle : float -> Arc

Parameters

plane Plane
The plane which the arc resides. The plane's origin is the center of the arc.
radius Double
The radius of the arc.
startAngle Double
The start angle of the arc (in radians).
endAngle Double
The end angle of the arc (in radians).

Return Value

Arc
The new arc.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was NULL
ArgumentOutOfRangeException | The given value for radius must be greater than 0 and no more than 30000 feet.
ArgumentsInconsistentException | Start angle must be less than end angle. -or- Curve length is too small for Revit's tolerance (as identified by Application.ShortCurveTolerance).
Remarks
If the angle range is equal to or greater than 2 * PI, the curve will be automatically converted to an unbounded circle.
Example
C#
VB
C++
F#
Copy
Arc CreateArcByGivingPlane(Autodesk.Revit.ApplicationServices.Application application, Plane plane)
{
    // Create an arc which is placed on the plane and whose center is the plane's origin
    double radius = 10;
    double startAngle = 0;      // The unit is radian
    double endAngle = 2 * Math.PI;        // this arc will be a circle
    return Arc.Create(plane, radius, startAngle, endAngle);
}
Private Function CreateArcByGivingPlane(application As Autodesk.Revit.ApplicationServices.Application, plane As Plane) As Arc
    ' Create an arc which is placed on the plane and whose center is the plane's origin
    Dim radius As Double = 10
    Dim startAngle As Double = 0
    ' The unit is radian
    Dim endAngle As Double = 2 * Math.PI
    ' this arc will be a circle
    Return Arc.Create(plane, radius, startAngle, endAngle)
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Arc Class
Create Overload


Arc.Create(XYZ, Double, Double, Double, XYZ, XYZ) Method

ArcCreate(XYZ, Double, Double, Double, XYZ, XYZ) Method

Creates a new geometric arc object based on center, radius, unit vectors, and angles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Arc Create(
    XYZ center,
    double radius,
    double startAngle,
    double endAngle,
    XYZ xAxis,
    XYZ yAxis
)
Public Shared Function Create (
    center As XYZ,
    radius As Double,
    startAngle As Double,
    endAngle As Double,
    xAxis As XYZ,
    yAxis As XYZ
) As Arc
public:
static Arc^ Create(
    XYZ^ center,
    double radius,
    double startAngle,
    double endAngle,
    XYZ^ xAxis,
    XYZ^ yAxis
)
static member Create :
        center : XYZ *
        radius : float *
        startAngle : float *
        endAngle : float *
        xAxis : XYZ *
        yAxis : XYZ -> Arc

Parameters

center XYZ
The center of the arc.
radius Double
The radius of the arc.
startAngle Double
The start angle of the arc (in radians).
endAngle Double
The end angle of the arc (in radians).
xAxis XYZ
The x axis to define the arc plane. Must be normalized.
yAxis XYZ
The y axis to define the arc plane. Must be normalized.

Return Value

Arc
The new arc.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was NULL
ArgumentOutOfRangeException | xAxis is not length 1.0. -or- yAxis is not length 1.0. -or- The given value for radius must be between 0 and 30000 feet.
ArgumentsInconsistentException | The vectors xAxis and yAxis are not perpendicular. -or- Start angle must be less than end angle. -or- Curve length is too small for Revit's tolerance (as identified by Application.ShortCurveTolerance).
Remarks
If the angle range is equal to or greater than 2 * PI, the curve will be automatically converted to an unbounded circle.
Example
C#
VB
C++
F#
Copy
// Create a new arc defined by its center, radios, angles and 2 axes
double radius = 10;
double startAngle = 0;      // In radian
double endAngle = Math.PI;        // In radian
XYZ center = new XYZ(5, 0, 0);
XYZ xAxis = new XYZ(1, 0, 0);   // The x axis to define the arc plane. Must be normalized
XYZ yAxis = new XYZ(0, 1, 0);   // The y axis to define the arc plane. Must be normalized

Arc arc = Arc.Create(center, radius, startAngle, endAngle, xAxis, yAxis);
' Create a new arc defined by its center, radios, angles and 2 axes
Dim radius As Double = 10
Dim startAngle As Double = 0
' In radian
Dim endAngle As Double = Math.PI
' In radian
Dim center As New XYZ(5, 0, 0)
Dim xAxis As New XYZ(1, 0, 0)
' The x axis to define the arc plane. Must be normalized
Dim yAxis As New XYZ(0, 1, 0)
' The y axis to define the arc plane. Must be normalized
Dim arc__1 As Arc = Arc.Create(center, radius, startAngle, endAngle, xAxis, yAxis)

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Arc Class
Create Overload


ArcLengthDimension Class

An object that represents an ArcLengthDimension within the Revit Project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBDimension
Autodesk.Revit.DBAngularDimension
Autodesk.Revit.DBArcLengthDimension

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ArcLengthDimension : AngularDimension
Public Class ArcLengthDimension
    Inherits AngularDimension
public ref class ArcLengthDimension : public AngularDimension
type ArcLengthDimension =
    class
        inherit AngularDimension
    end

The ArcLengthDimension type exposes the following members.

Properties
 | Name | Description
Public property | Above | The text shown above the segment's value. (Inherited from Dimension)
Public property | AreReferencesAvailable | Indicates if this dimension's references can be resolved. (Inherited from Dimension)
Public property | AreSegmentsEqual | Indicates if all segments are forced to be equal. (Inherited from Dimension)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | Below | The text shown below the segment's value. (Inherited from Dimension)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | Curve | A curve that represents the dimension line. (Inherited from Dimension)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | DimensionShape | The shape of this dimension. (Inherited from Dimension)
Public property | DimensionType | The dimension style of this dimension. (Inherited from Dimension)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyLabel | The family parameter label of the dimension. (Inherited from Dimension)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HasLeader | True if dimension has leader, false otherwise. (Inherited from Dimension)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsLocked | Indicates if this dimension is locked. (Inherited from Dimension)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValid | Indicates if this dimension is valid. (Inherited from Dimension)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LeaderEndPosition | The position of the dimension's leader end point. (Inherited from Dimension)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Retrieves or changes the name associated with the Dimension. (Inherited from Dimension)
Public property | NumberOfSegments | The number of segments for the dimension. (Inherited from Dimension)
Public property | Origin | The dimension origin. (Inherited from Dimension)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Prefix | The text shown before the segment's value. (Inherited from Dimension)
Public property | References | Returns an array of geometric references to which the dimension is attached. (Inherited from Dimension)
Public property | Segments | The segments in the dimension. (Inherited from Dimension)
Public property | Suffix | The text shown after the segment's value. (Inherited from Dimension)
 | TextPosition | The position of the dimension text's drag point. (Inherited from Dimension)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | Value | The value of the dimension. (Inherited from Dimension)
Public property | ValueOverride | The text that replaces the segment's value. (Inherited from Dimension)
Public property | ValueString | The dimension value as a user visible string. (Inherited from Dimension)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | View | Supplies the view that contains the dimension if the dimension is view specific. (Inherited from Dimension)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new instance of an Arc Length Dimension element within the project.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasOneSegment | Determines whether a dimension has one segment. (Inherited from Dimension)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsTextPositionAdjustable | Indicates if this dimension is supported to set/get TextPosition/LeaderEndPosition. (Inherited from Dimension)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | ResetTextPosition | Resets the text position of the dimension to the initial position determined by its type and parameters. (Inherited from Dimension)
Public method | SetAngularRadius | Set radius of an Angular Dimension arc. The new radius of the arc. (Inherited from AngularDimension)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ArcLengthDimension Properties

The ArcLengthDimension type exposes the following members.

Properties
 | Name | Description
Public property | Above | The text shown above the segment's value. (Inherited from Dimension)
Public property | AreReferencesAvailable | Indicates if this dimension's references can be resolved. (Inherited from Dimension)
Public property | AreSegmentsEqual | Indicates if all segments are forced to be equal. (Inherited from Dimension)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | Below | The text shown below the segment's value. (Inherited from Dimension)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | Curve | A curve that represents the dimension line. (Inherited from Dimension)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | DimensionShape | The shape of this dimension. (Inherited from Dimension)
Public property | DimensionType | The dimension style of this dimension. (Inherited from Dimension)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyLabel | The family parameter label of the dimension. (Inherited from Dimension)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HasLeader | True if dimension has leader, false otherwise. (Inherited from Dimension)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsLocked | Indicates if this dimension is locked. (Inherited from Dimension)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValid | Indicates if this dimension is valid. (Inherited from Dimension)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LeaderEndPosition | The position of the dimension's leader end point. (Inherited from Dimension)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Retrieves or changes the name associated with the Dimension. (Inherited from Dimension)
Public property | NumberOfSegments | The number of segments for the dimension. (Inherited from Dimension)
Public property | Origin | The dimension origin. (Inherited from Dimension)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Prefix | The text shown before the segment's value. (Inherited from Dimension)
Public property | References | Returns an array of geometric references to which the dimension is attached. (Inherited from Dimension)
Public property | Segments | The segments in the dimension. (Inherited from Dimension)
Public property | Suffix | The text shown after the segment's value. (Inherited from Dimension)
 | TextPosition | The position of the dimension text's drag point. (Inherited from Dimension)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | Value | The value of the dimension. (Inherited from Dimension)
Public property | ValueOverride | The text that replaces the segment's value. (Inherited from Dimension)
Public property | ValueString | The dimension value as a user visible string. (Inherited from Dimension)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | View | Supplies the view that contains the dimension if the dimension is view specific. (Inherited from Dimension)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

ArcLengthDimension Class


ArcLengthDimension Methods

The ArcLengthDimension type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new instance of an Arc Length Dimension element within the project.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasOneSegment | Determines whether a dimension has one segment. (Inherited from Dimension)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsTextPositionAdjustable | Indicates if this dimension is supported to set/get TextPosition/LeaderEndPosition. (Inherited from Dimension)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | ResetTextPosition | Resets the text position of the dimension to the initial position determined by its type and parameters. (Inherited from Dimension)
Public method | SetAngularRadius | Set radius of an Angular Dimension arc. The new radius of the arc. (Inherited from AngularDimension)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ArcLengthDimension Class


ArcLengthDimension.Create Method

ArcLengthDimensionCreate Method

Creates a new instance of an Arc Length Dimension element within the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ArcLengthDimension Create(
    Document document,
    View dbView,
    Arc arc,
    Reference ArcRef,
    IList<Reference> references
)
Public Shared Function Create (
    document As Document,
    dbView As View,
    arc As Arc,
    ArcRef As Reference,
    references As IList(Of Reference)
) As ArcLengthDimension
public:
static ArcLengthDimension^ Create(
    Document^ document,
    View^ dbView,
    Arc^ arc,
    Reference^ ArcRef,
    IList<Reference^>^ references
)
static member Create :
        document : Document *
        dbView : View *
        arc : Arc *
        ArcRef : Reference *
        references : IList<Reference> -> ArcLengthDimension

Parameters

document Document
The document where the new Arc Length Dimension is created.
dbView View
The view in which the Arc Length Dimension will appear.
arc Arc
The Arc of the annotation itself
ArcRef Reference
Reference for the arc to be measured
references IList Reference
The segments which the Arc Length Dimension will witness.

Return Value

ArcLengthDimension
The newly created Arc Length Dimension instance, or if the operation fails.
Exceptions
Exception | Condition
ArgumentException | References should be: at least two and intersecting the ends of the arc passed.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
See Also

Reference

ArcLengthDimension Class


Area Class

Provides access to the area topology in Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBSpatialElement
Autodesk.Revit.DBArea

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Area : SpatialElement
Public Class Area
    Inherits SpatialElement
public ref class Area : public SpatialElement
type Area =
    class
        inherit SpatialElement
    end

The Area type exposes the following members.

Properties
 | Name | Description
Public property | Area | The area. (Inherited from SpatialElement)
Public property | AreaScheme | The area scheme.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsGrossInterior | The boolean value that indicates whether the area is gross interior.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | Level | Gets the level of the room. (Inherited from SpatialElement)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | Location | The location of the element. (Inherited from SpatialElement)
Public property | Name | A human readable name for the Element. (Inherited from SpatialElement)
Public property | Number | The number. (Inherited from SpatialElement)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Perimeter | The perimeter. (Inherited from SpatialElement)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SpatialElementType | The spatial element type. (Inherited from SpatialElement)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetBoundarySegments | Returns the boundary segments. (Inherited from SpatialElement)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSpatialElementDomainData | Gets the domain data for the spatial element. The domain data contains information of different spatial elements, such as electrical load area. Currently room/space/area don't have domain data. (Inherited from SpatialElement)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The area object can be queried for its boundary for use in space planning tools.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Area Properties

The Area type exposes the following members.

Properties
 | Name | Description
Public property | Area | The area. (Inherited from SpatialElement)
Public property | AreaScheme | The area scheme.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsGrossInterior | The boolean value that indicates whether the area is gross interior.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | Level | Gets the level of the room. (Inherited from SpatialElement)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | Location | The location of the element. (Inherited from SpatialElement)
Public property | Name | A human readable name for the Element. (Inherited from SpatialElement)
Public property | Number | The number. (Inherited from SpatialElement)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Perimeter | The perimeter. (Inherited from SpatialElement)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SpatialElementType | The spatial element type. (Inherited from SpatialElement)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

Area Class


Area.AreaScheme Property

AreaAreaScheme Property

The area scheme.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AreaScheme AreaScheme { get; }
Public ReadOnly Property AreaScheme As AreaScheme
    Get
public:
property AreaScheme^ AreaScheme {
    AreaScheme^ get ();
}
member AreaScheme : AreaScheme with get

Property Value

AreaScheme
See Also

Reference

Area Class


Area.IsGrossInterior Property

AreaIsGrossInterior Property

The boolean value that indicates whether the area is gross interior.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsGrossInterior { get; }
Public ReadOnly Property IsGrossInterior As Boolean
    Get
public:
property bool IsGrossInterior {
    bool get ();
}
member IsGrossInterior : bool with get

Property Value

Boolean
See Also

Reference

Area Class


Area Methods

The Area type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetBoundarySegments | Returns the boundary segments. (Inherited from SpatialElement)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSpatialElementDomainData | Gets the domain data for the spatial element. The domain data contains information of different spatial elements, such as electrical load area. Currently room/space/area don't have domain data. (Inherited from SpatialElement)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Area Class


AreaElemType Enumeration

An enumerated type to store type of AreaElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum AreaElemType
Public Enumeration AreaElemType
public enum class AreaElemType
type AreaElemType
Members
Member name | Value | Description
GrossArea | 0 | Gross Area Scheme - only 2 types of spaces (internal and external).
BOMAArea | 1 | Office Area Scheme - uses BOMA rules for space classification.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


AreaFilter Class

A filter used to match areas.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementSlowFilter
Autodesk.Revit.DBAreaFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AreaFilter : ElementSlowFilter
Public Class AreaFilter
    Inherits ElementSlowFilter
public ref class AreaFilter : public ElementSlowFilter
type AreaFilter =
    class
        inherit ElementSlowFilter
    end

The AreaFilter type exposes the following members.

Constructors
 | Name | Description
Public method | AreaFilter | Constructs a filter which matches only areas.
Top
Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This filter is a slow filter, but it uses a quick filter to eliminate non-candidate elements before the elements are obtained and expanded. Therefore this filter does not have to be paired with another quick filter to minimize the number of Elements that are expanded.
Example
C#
VB
C++
F#
Copy
// Use a AreaFilter to find all area elements in the document. It is necessary to use the AreaFilter,
// and not an ElementClassFilter or the shortcut method OfClass() because the area class is not
// supported by those methods.
AreaFilter filter = new AreaFilter();

// Apply the filter to the elements in the active document
FilteredElementCollector collector = new FilteredElementCollector(document);
IList<Element> areas = collector.WherePasses(filter).ToElements();
' Use a AreaFilter to find all area elements in the document. It is necessary to use the AreaFilter,
' and not an ElementClassFilter or the shortcut method OfClass() because the area class is not
' supported by those methods.
Dim filter As New AreaFilter()

' Apply the filter to the elements in the active document
Dim collector As New FilteredElementCollector(document)
Dim areas As IList(Of Element) = collector.WherePasses(filter).ToElements()

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


AreaFilter Constructor

Constructs a filter which matches only areas.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AreaFilter()
Public Sub New
public:
AreaFilter()
new : unit -> AreaFilter
See Also

Reference

AreaFilter Class


AreaFilter Properties

The AreaFilter type exposes the following members.

Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
See Also

Reference

AreaFilter Class


AreaFilter Methods

The AreaFilter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AreaFilter Class


AreaScheme Class

The area scheme associated with a particular area plan.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBAreaScheme

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AreaScheme : Element
Public Class AreaScheme
    Inherits Element
public ref class AreaScheme : public Element
type AreaScheme =
    class
        inherit Element
    end

The AreaScheme type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsGrossBuildingArea | Indicates if the area scheme is a Gross Building Area scheme.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


AreaScheme Properties

The AreaScheme type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsGrossBuildingArea | Indicates if the area scheme is a Gross Building Area scheme.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

AreaScheme Class


AreaScheme.IsGrossBuildingArea Property

AreaSchemeIsGrossBuildingArea Property

Indicates if the area scheme is a Gross Building Area scheme.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsGrossBuildingArea { get; }
Public ReadOnly Property IsGrossBuildingArea As Boolean
    Get
public:
property bool IsGrossBuildingArea {
    bool get ();
}
member IsGrossBuildingArea : bool with get

Property Value

Boolean
See Also

Reference

AreaScheme Class


AreaScheme Methods

The AreaScheme type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AreaScheme Class


AreaTag Class

Provides access to the area topology in Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBSpatialElementTag
Autodesk.Revit.DBAreaTag

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AreaTag : SpatialElementTag
Public Class AreaTag
    Inherits SpatialElementTag
public ref class AreaTag : public SpatialElementTag
type AreaTag =
    class
        inherit SpatialElementTag
    end

The AreaTag type exposes the following members.

Properties
 | Name | Description
Public property | Area | The area that the tag is associated with.
Public property | AreaTagType | The tag type.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HasElbow | Identifies if the tag's leader has an elbow point or not. (Inherited from SpatialElementTag)
Public property | HasLeader | Identifies if a leader is displayed for the tag or not. (Inherited from SpatialElementTag)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsOrphaned | Identifies if the tag is orphaned or not. (Inherited from SpatialElementTag)
Public property | IsTaggingLink | Identifies if the tag has reference to a spatial element in a linked document or not. (Inherited from SpatialElementTag)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LeaderElbow | The position of the leader's elbow (middle point). (Inherited from SpatialElementTag)
Public property | LeaderEnd | The position of the leader's end. (Inherited from SpatialElementTag)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | Location | The location of the tag. (Inherited from SpatialElementTag)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | RotationAngle | The rotation angle of the tag relative to its view (Inherited from SpatialElementTag)
Public property | TagHeadPosition | The position of the tag's head. (Inherited from SpatialElementTag)
Public property | TagOrientation | The orientation of the tag. (Inherited from SpatialElementTag)
Public property | TagText | The text displayed by the tag. (Inherited from SpatialElementTag)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | View | The view in which the tag was placed. (Inherited from SpatialElementTag)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The areaTag object can be queried for its boundary for use in space planning tools.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


AreaTag Properties

The AreaTag type exposes the following members.

Properties
 | Name | Description
Public property | Area | The area that the tag is associated with.
Public property | AreaTagType | The tag type.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HasElbow | Identifies if the tag's leader has an elbow point or not. (Inherited from SpatialElementTag)
Public property | HasLeader | Identifies if a leader is displayed for the tag or not. (Inherited from SpatialElementTag)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsOrphaned | Identifies if the tag is orphaned or not. (Inherited from SpatialElementTag)
Public property | IsTaggingLink | Identifies if the tag has reference to a spatial element in a linked document or not. (Inherited from SpatialElementTag)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LeaderElbow | The position of the leader's elbow (middle point). (Inherited from SpatialElementTag)
Public property | LeaderEnd | The position of the leader's end. (Inherited from SpatialElementTag)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | Location | The location of the tag. (Inherited from SpatialElementTag)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | RotationAngle | The rotation angle of the tag relative to its view (Inherited from SpatialElementTag)
Public property | TagHeadPosition | The position of the tag's head. (Inherited from SpatialElementTag)
Public property | TagOrientation | The orientation of the tag. (Inherited from SpatialElementTag)
Public property | TagText | The text displayed by the tag. (Inherited from SpatialElementTag)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | View | The view in which the tag was placed. (Inherited from SpatialElementTag)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

AreaTag Class


AreaTag.Area Property

AreaTagArea Property

The area that the tag is associated with.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Area Area { get; }
Public ReadOnly Property Area As Area
    Get
public:
property Area^ Area {
    Area^ get ();
}
member Area : Area with get

Property Value

Area
Remarks
In rare cases, the tag may not be associated to an area. The property will be in these situations.
See Also

Reference

AreaTag Class


AreaTag.AreaTagType Property

AreaTagAreaTagType Property

The tag type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AreaTagType AreaTagType { get; set; }
Public Property AreaTagType As AreaTagType
    Get
    Set
public:
property AreaTagType^ AreaTagType {
    AreaTagType^ get ();
    void set (AreaTagType^ value);
}
member AreaTagType : AreaTagType with get, set

Property Value

AreaTagType
See Also

Reference

AreaTag Class


AreaTag Methods

The AreaTag type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AreaTag Class


AreaTagFilter Class

A filter used to match area tags.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementSlowFilter
Autodesk.Revit.DBAreaTagFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AreaTagFilter : ElementSlowFilter
Public Class AreaTagFilter
    Inherits ElementSlowFilter
public ref class AreaTagFilter : public ElementSlowFilter
type AreaTagFilter =
    class
        inherit ElementSlowFilter
    end

The AreaTagFilter type exposes the following members.

Constructors
 | Name | Description
Public method | AreaTagFilter | Constructs a filter which matches only areas.
Top
Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This filter is a slow filter, but it uses a quick filter to eliminate non-candidate elements before the elements are obtained and expanded. Therefore this filter does not have to be paired with another quick filter to minimize the number of Elements that are expanded.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


AreaTagFilter Constructor

Constructs a filter which matches only areas.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AreaTagFilter()
Public Sub New
public:
AreaTagFilter()
new : unit -> AreaTagFilter
See Also

Reference

AreaTagFilter Class


AreaTagFilter Properties

The AreaTagFilter type exposes the following members.

Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
See Also

Reference

AreaTagFilter Class


AreaTagFilter Methods

The AreaTagFilter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AreaTagFilter Class


AreaTagType Class

An object that represents an Area Tag style.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBInsertableObject
Autodesk.Revit.DBFamilySymbol
Autodesk.Revit.DBAreaTagType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AreaTagType : FamilySymbol
Public Class AreaTagType
    Inherits FamilySymbol
public ref class AreaTagType : public FamilySymbol
type AreaTagType =
    class
        inherit FamilySymbol
    end

The AreaTagType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | Family | The Family object to which the symbol belongs. (Inherited from FamilySymbol)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsActive | Identifies whether the symbol is active. (Inherited from FamilySymbol)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | StructuralMaterialType | This property returns the physical material from which the type is made. (Inherited from FamilySymbol)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | Activate | Activates the symbol to ensure that its geometry is accessible. (Inherited from FamilySymbol)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveStructuralSection | Identifies if this FamilySymbol can have a structural section. (Inherited from FamilySymbol)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFamilyPointLocations | Returns the Point Locations for the Family Symbol. (Inherited from FamilySymbol)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetStructuralSection | Gets the structural section from element. (Inherited from FamilySymbol)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetThermalProperties | Gets the thermal properties for the given FamilySymbol. (Inherited from FamilySymbol)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasThermalProperties | Identifies if this FamilySymbol can include thermal properties. (Inherited from FamilySymbol)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetStructuralSection | Sets the structural section in element. (Inherited from FamilySymbol)
Public method | SetThermalProperties | Sets the thermal properties for the given FamilySymbol. (Inherited from FamilySymbol)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


AreaTagType Properties

The AreaTagType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | Family | The Family object to which the symbol belongs. (Inherited from FamilySymbol)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsActive | Identifies whether the symbol is active. (Inherited from FamilySymbol)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | StructuralMaterialType | This property returns the physical material from which the type is made. (Inherited from FamilySymbol)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

AreaTagType Class


AreaTagType Methods

The AreaTagType type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Activates the symbol to ensure that its geometry is accessible. (Inherited from FamilySymbol)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveStructuralSection | Identifies if this FamilySymbol can have a structural section. (Inherited from FamilySymbol)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFamilyPointLocations | Returns the Point Locations for the Family Symbol. (Inherited from FamilySymbol)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetStructuralSection | Gets the structural section from element. (Inherited from FamilySymbol)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetThermalProperties | Gets the thermal properties for the given FamilySymbol. (Inherited from FamilySymbol)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasThermalProperties | Identifies if this FamilySymbol can include thermal properties. (Inherited from FamilySymbol)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetStructuralSection | Sets the structural section in element. (Inherited from FamilySymbol)
Public method | SetThermalProperties | Sets the thermal properties for the given FamilySymbol. (Inherited from FamilySymbol)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AreaTagType Class


AreaVolumeSettings Class

This class provides access to settings related to volume and area computations.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBAreaVolumeSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AreaVolumeSettings : Element
Public Class AreaVolumeSettings
    Inherits Element
public ref class AreaVolumeSettings : public Element
type AreaVolumeSettings =
    class
        inherit Element
    end

The AreaVolumeSettings type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | ComputeVolumes | True to enable volume computation. False to disable it.
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
 | GetAreaVolumeSettings | Get the area and volume settings of the project.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSpatialElementBoundaryLocation | Gets the spatial element boundary location based on spatial element type.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetSpatialElementBoundaryLocation | Sets the spatial element boundary location of a spatial element type.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


AreaVolumeSettings Properties

The AreaVolumeSettings type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | ComputeVolumes | True to enable volume computation. False to disable it.
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

AreaVolumeSettings Class


AreaVolumeSettings.ComputeVolumes Property

AreaVolumeSettingsComputeVolumes Property

True to enable volume computation. False to disable it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ComputeVolumes { get; set; }
Public Property ComputeVolumes As Boolean
    Get
    Set
public:
property bool ComputeVolumes {
    bool get ();
    void set (bool value);
}
member ComputeVolumes : bool with get, set

Property Value

Boolean
Remarks
When this setting is False, rooms and spaces will be treated as simple extrusions of their 2d boundaries. The volume parameter will report "not computed". When this setting is True, the geometry of rooms and spaces will be trimmed when it intersects elements such as ceilings, roofs, and floors.
Example
C#
VB
C++
F#
Copy
public void GetRoomDimensions(Document doc, Room room)
{
    String roominfo = "Room dimensions:\n";
    // turn on volume calculations:
    using (Transaction t = new Transaction(doc, "Turn on volume calculation"))
    {
        t.Start();
        AreaVolumeSettings settings = AreaVolumeSettings.GetAreaVolumeSettings(doc);
        settings.ComputeVolumes = true;
        t.Commit();
    }

    roominfo += "Vol: " + room.Volume + "\n";
    roominfo += "Area: " + room.Area + "\n";
    roominfo += "Perimeter: " + room.Perimeter + "\n";
    roominfo += "Unbounded height: " + room.UnboundedHeight + "\n";
    TaskDialog.Show("Revit",roominfo);
}
Public Sub GetRoomDimensions(doc As Document, room As Room)
    Dim roominfo As [String] = "Room dimensions:" & vbLf
    ' turn on volume calculations:
    Using t As New Transaction(doc, "Turn on volume calculation")
        t.Start()
        Dim settings As AreaVolumeSettings = AreaVolumeSettings.GetAreaVolumeSettings(doc)
        settings.ComputeVolumes = True
        t.Commit()
    End Using

    roominfo += "Vol: " & Convert.ToString(room.Volume) & vbLf
    roominfo += "Area: " & Convert.ToString(room.Area) & vbLf
    roominfo += "Perimeter: " & Convert.ToString(room.Perimeter) & vbLf
    roominfo += "Unbounded height: " & Convert.ToString(room.UnboundedHeight) & vbLf
    TaskDialog.Show("Revit", roominfo)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

AreaVolumeSettings Class


AreaVolumeSettings Methods

The AreaVolumeSettings type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
 | GetAreaVolumeSettings | Get the area and volume settings of the project.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSpatialElementBoundaryLocation | Gets the spatial element boundary location based on spatial element type.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetSpatialElementBoundaryLocation | Sets the spatial element boundary location of a spatial element type.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AreaVolumeSettings Class


AreaVolumeSettings.GetAreaVolumeSettings Method

AreaVolumeSettingsGetAreaVolumeSettings Method

Get the area and volume settings of the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static AreaVolumeSettings GetAreaVolumeSettings(
    Document aDoc
)
Public Shared Function GetAreaVolumeSettings (
    aDoc As Document
) As AreaVolumeSettings
public:
static AreaVolumeSettings^ GetAreaVolumeSettings(
    Document^ aDoc
)
static member GetAreaVolumeSettings :
        aDoc : Document -> AreaVolumeSettings

Parameters

aDoc Document
The document.

Return Value

AreaVolumeSettings
The area and volume settings of the project.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

AreaVolumeSettings Class


AreaVolumeSettings.GetSpatialElementBoundaryLocation Method

AreaVolumeSettingsGetSpatialElementBoundaryLocation Method

Gets the spatial element boundary location based on spatial element type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SpatialElementBoundaryLocation GetSpatialElementBoundaryLocation(
    SpatialElementType spType
)
Public Function GetSpatialElementBoundaryLocation (
    spType As SpatialElementType
) As SpatialElementBoundaryLocation
public:
SpatialElementBoundaryLocation GetSpatialElementBoundaryLocation(
    SpatialElementType spType
)
member GetSpatialElementBoundaryLocation :
        spType : SpatialElementType -> SpatialElementBoundaryLocation

Parameters

spType SpatialElementType
The spatial element type.

Return Value

SpatialElementBoundaryLocation
The boundary location.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

AreaVolumeSettings Class


AreaVolumeSettings.SetSpatialElementBoundaryLocation Method

AreaVolumeSettingsSetSpatialElementBoundaryLocation Method

Sets the spatial element boundary location of a spatial element type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetSpatialElementBoundaryLocation(
    SpatialElementBoundaryLocation spatialElementBoundaryLocation,
    SpatialElementType spType
)
Public Sub SetSpatialElementBoundaryLocation (
    spatialElementBoundaryLocation As SpatialElementBoundaryLocation,
    spType As SpatialElementType
)
public:
void SetSpatialElementBoundaryLocation(
    SpatialElementBoundaryLocation spatialElementBoundaryLocation,
    SpatialElementType spType
)
member SetSpatialElementBoundaryLocation :
        spatialElementBoundaryLocation : SpatialElementBoundaryLocation *
        spType : SpatialElementType -> unit

Parameters

spatialElementBoundaryLocation SpatialElementBoundaryLocation
The boundary location.
spType SpatialElementType
The spatial element type.
Exceptions
Exception | Condition
ArgumentException | Currently only SpatialElementType.Room is permitted when setting the boundary location.
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

AreaVolumeSettings Class


ArrayAnchorMember Enumeration

Represents the possible choices for how the translation or rotation is used to place each member of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ArrayAnchorMember
Public Enumeration ArrayAnchorMember
public enum class ArrayAnchorMember
type ArrayAnchorMember
Members
Member name | Value | Description
Second | 0 | The translation or rotation value specifies the location of the second member of the array.
Last | 1 | The translation or rotation value specifies the location of the last member of the array.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


AssemblyCodeTable Class

AssemblyCodeTable represents the collection of ClassificationEntries for a document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBKeyBasedTreeEntryTable
Autodesk.Revit.DBAssemblyCodeTable

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AssemblyCodeTable : KeyBasedTreeEntryTable
Public Class AssemblyCodeTable
    Inherits KeyBasedTreeEntryTable
public ref class AssemblyCodeTable : public KeyBasedTreeEntryTable
type AssemblyCodeTable =
    class
        inherit KeyBasedTreeEntryTable
    end

The AssemblyCodeTable type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
 | GetAssemblyCodeTable | Returns the AssemblyCodeTable for the specified document.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetKeyBasedTreeEntries | Gets the KeyBasedTreeEntries for this table. (Inherited from KeyBasedTreeEntryTable)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LoadFrom | Loads KeyBasedTreeEntries from the specified external resource into this KeyBasedTreeEntryTable. (Inherited from KeyBasedTreeEntryTable)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | Reload | Reloads KeyBasedTreeEntries from their currently-stored location into this KeyBasedTreeEntryTable. (Inherited from KeyBasedTreeEntryTable)
Public method | ServerSupports | Checks if the server referenced by the given ExternalResourceReference supports the ExternalResourceReferenceType of this KeyBasedTreeEntryTable. (Inherited from KeyBasedTreeEntryTable)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


AssemblyCodeTable Properties

The AssemblyCodeTable type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

AssemblyCodeTable Class


AssemblyCodeTable Methods

The AssemblyCodeTable type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
 | GetAssemblyCodeTable | Returns the AssemblyCodeTable for the specified document.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetKeyBasedTreeEntries | Gets the KeyBasedTreeEntries for this table. (Inherited from KeyBasedTreeEntryTable)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LoadFrom | Loads KeyBasedTreeEntries from the specified external resource into this KeyBasedTreeEntryTable. (Inherited from KeyBasedTreeEntryTable)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | Reload | Reloads KeyBasedTreeEntries from their currently-stored location into this KeyBasedTreeEntryTable. (Inherited from KeyBasedTreeEntryTable)
Public method | ServerSupports | Checks if the server referenced by the given ExternalResourceReference supports the ExternalResourceReferenceType of this KeyBasedTreeEntryTable. (Inherited from KeyBasedTreeEntryTable)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AssemblyCodeTable Class


AssemblyCodeTable.GetAssemblyCodeTable Method

AssemblyCodeTableGetAssemblyCodeTable Method

Returns the AssemblyCodeTable for the specified document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static AssemblyCodeTable GetAssemblyCodeTable(
    Document doc
)
Public Shared Function GetAssemblyCodeTable (
    doc As Document
) As AssemblyCodeTable
public:
static AssemblyCodeTable^ GetAssemblyCodeTable(
    Document^ doc
)
static member GetAssemblyCodeTable :
        doc : Document -> AssemblyCodeTable

Parameters

doc Document
The document owns the AssemblyCodeTable.

Return Value

AssemblyCodeTable
The AssemblyCodeTable for the document.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

AssemblyCodeTable Class


AssemblyDetailViewOrientation Enumeration

Orientation of the Assembly Detail View.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum AssemblyDetailViewOrientation
Public Enumeration AssemblyDetailViewOrientation
public enum class AssemblyDetailViewOrientation
type AssemblyDetailViewOrientation
Members
Member name | Value | Description
HorizontalDetail | 0 | The Detail View will be oriented horizontally, looking down.
DetailSectionA | 1 | The Detail View will be oriented vertically, looking north.
DetailSectionB | 2 | The Detail View will be oriented vertically, looking west.
ElevationTop | 3 | The Detail View will be oriented horizontally, with its cut plane along the top face of the assembly's bounding box, looking down into the bounding box.
ElevationBottom | 4 | The Detail View will be oriented horizontally, with its cut plane along the bottom face of the assembly's bounding box, looking up into the bounding box.
ElevationLeft | 5 | The Detail View will be oriented vertically, with its cut plane along the left face of the assembly's bounding box, looking into the bounding box.
ElevationRight | 6 | The Detail View will be oriented vertically, with its cut plane along the right face of the assembly's bounding box, looking into the bounding box.
ElevationFront | 7 | The Detail View will be oriented vertically, with its cut plane along the front face of the assembly's bounding box, looking into the bounding box.
ElevationBack | 8 | The Detail View will be oriented vertically, with its cut plane along the back face of the assembly's bounding box, looking into the bounding box.
Remarks
The orientation can be specified during creation but not modified for existing views.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


AssemblyDifference Class

Class that describes difference between two assemblies.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAssemblyDifference
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AssemblyDifference : IDisposable
Public Class AssemblyDifference
    Implements IDisposable
public ref class AssemblyDifference : IDisposable
type AssemblyDifference =
    class
        interface IDisposable
    end

The AssemblyDifference type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the AssemblyDifference
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The assembly comparison function returns a sub-class of this class. Different sub-classes represent different kinds of differences and contain additional data for each particular kind of difference.
See Also

Reference

Autodesk.Revit.DB Namespace
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAssemblyDifference
Autodesk.Revit.DBAssemblyDifferenceConfiguration
Autodesk.Revit.DBAssemblyDifferenceMemberCount
Autodesk.Revit.DBAssemblyDifferenceMemberDifference
Autodesk.Revit.DBAssemblyDifferenceNamingCategory
Autodesk.Revit.DBAssemblyDifferenceNone


AssemblyDifference Properties

The AssemblyDifference type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

AssemblyDifference Class


AssemblyDifference.IsValidObject Property

AssemblyDifferenceIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

AssemblyDifference Class


AssemblyDifference Methods

The AssemblyDifference type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AssemblyDifference Class


AssemblyDifference.Dispose Method

AssemblyDifferenceDispose Method

Releases all resources used by the AssemblyDifference

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

AssemblyDifference Class


AssemblyDifferenceConfiguration Class

The two assemblies being compared have different spatial configuration
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAssemblyDifference
Autodesk.Revit.DBAssemblyDifferenceConfiguration

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AssemblyDifferenceConfiguration : AssemblyDifference
Public Class AssemblyDifferenceConfiguration
    Inherits AssemblyDifference
public ref class AssemblyDifferenceConfiguration : public AssemblyDifference
type AssemblyDifferenceConfiguration =
    class
        inherit AssemblyDifference
    end

The AssemblyDifferenceConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from AssemblyDifference)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from AssemblyDifference)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Assemblies resulting in this difference might be made up of identical elements, but the elements are not arranged in space relative to each other in the same way.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


AssemblyDifferenceConfiguration Properties

The AssemblyDifferenceConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from AssemblyDifference)
Top
See Also

Reference

AssemblyDifferenceConfiguration Class


AssemblyDifferenceConfiguration Methods

The AssemblyDifferenceConfiguration type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from AssemblyDifference)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AssemblyDifferenceConfiguration Class


AssemblyDifferenceMemberCount Class

The two assemblies being compared have different number of members
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAssemblyDifference
Autodesk.Revit.DBAssemblyDifferenceMemberCount

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AssemblyDifferenceMemberCount : AssemblyDifference
Public Class AssemblyDifferenceMemberCount
    Inherits AssemblyDifference
public ref class AssemblyDifferenceMemberCount : public AssemblyDifference
type AssemblyDifferenceMemberCount =
    class
        inherit AssemblyDifference
    end

The AssemblyDifferenceMemberCount type exposes the following members.

Properties
 | Name | Description
Public property | Count1 | Number of members in the first assembly
Public property | Count2 | Number of members in the second assembly
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from AssemblyDifference)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from AssemblyDifference)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


AssemblyDifferenceMemberCount Properties

The AssemblyDifferenceMemberCount type exposes the following members.

Properties
 | Name | Description
Public property | Count1 | Number of members in the first assembly
Public property | Count2 | Number of members in the second assembly
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from AssemblyDifference)
Top
See Also

Reference

AssemblyDifferenceMemberCount Class


AssemblyDifferenceMemberCount.Count1 Property

AssemblyDifferenceMemberCountCount1 Property

Number of members in the first assembly

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Count1 { get; }
Public ReadOnly Property Count1 As Integer
    Get
public:
property int Count1 {
    int get ();
}
member Count1 : int with get

Property Value

Int32
See Also

Reference

AssemblyDifferenceMemberCount Class


AssemblyDifferenceMemberCount.Count2 Property

AssemblyDifferenceMemberCountCount2 Property

Number of members in the second assembly

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Count2 { get; }
Public ReadOnly Property Count2 As Integer
    Get
public:
property int Count2 {
    int get ();
}
member Count2 : int with get

Property Value

Int32
See Also

Reference

AssemblyDifferenceMemberCount Class


AssemblyDifferenceMemberCount Methods

The AssemblyDifferenceMemberCount type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from AssemblyDifference)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AssemblyDifferenceMemberCount Class


AssemblyDifferenceMemberDifference Class

The two assemblies being compared have different members
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAssemblyDifference
Autodesk.Revit.DBAssemblyDifferenceMemberDifference

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AssemblyDifferenceMemberDifference : AssemblyDifference
Public Class AssemblyDifferenceMemberDifference
    Inherits AssemblyDifference
public ref class AssemblyDifferenceMemberDifference : public AssemblyDifference
type AssemblyDifferenceMemberDifference =
    class
        inherit AssemblyDifference
    end

The AssemblyDifferenceMemberDifference type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from AssemblyDifference)
Public property | MemberDifference | Difference between the assembly members
Public property | MemberId1 | Id of the member in the first assembly
Public property | MemberId2 | Id of the member in the second assembly
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from AssemblyDifference)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This difference means that there is a member of the first assembly which is different from the corresponding member of the second assembly. Details about the difference are in memberDifference.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


AssemblyDifferenceMemberDifference Properties

The AssemblyDifferenceMemberDifference type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from AssemblyDifference)
Public property | MemberDifference | Difference between the assembly members
Public property | MemberId1 | Id of the member in the first assembly
Public property | MemberId2 | Id of the member in the second assembly
Top
See Also

Reference

AssemblyDifferenceMemberDifference Class


AssemblyDifferenceMemberDifference.MemberDifference Property

AssemblyDifferenceMemberDifferenceMemberDifference Property

Difference between the assembly members

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AssemblyMemberDifference MemberDifference { get; }
Public ReadOnly Property MemberDifference As AssemblyMemberDifference
    Get
public:
property AssemblyMemberDifference^ MemberDifference {
    AssemblyMemberDifference^ get ();
}
member MemberDifference : AssemblyMemberDifference with get

Property Value

AssemblyMemberDifference
See Also

Reference

AssemblyDifferenceMemberDifference Class


AssemblyDifferenceMemberDifference.MemberId1 Property

AssemblyDifferenceMemberDifferenceMemberId1 Property

Id of the member in the first assembly

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId MemberId1 { get; }
Public ReadOnly Property MemberId1 As ElementId
    Get
public:
property ElementId^ MemberId1 {
    ElementId^ get ();
}
member MemberId1 : ElementId with get

Property Value

ElementId
See Also

Reference

AssemblyDifferenceMemberDifference Class


AssemblyDifferenceMemberDifference.MemberId2 Property

AssemblyDifferenceMemberDifferenceMemberId2 Property

Id of the member in the second assembly

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId MemberId2 { get; }
Public ReadOnly Property MemberId2 As ElementId
    Get
public:
property ElementId^ MemberId2 {
    ElementId^ get ();
}
member MemberId2 : ElementId with get

Property Value

ElementId
See Also

Reference

AssemblyDifferenceMemberDifference Class


AssemblyDifferenceMemberDifference Methods

The AssemblyDifferenceMemberDifference type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from AssemblyDifference)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AssemblyDifferenceMemberDifference Class


AssemblyDifferenceNamingCategory Class

The two assemblies being compared have different naming categories
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAssemblyDifference
Autodesk.Revit.DBAssemblyDifferenceNamingCategory

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AssemblyDifferenceNamingCategory : AssemblyDifference
Public Class AssemblyDifferenceNamingCategory
    Inherits AssemblyDifference
public ref class AssemblyDifferenceNamingCategory : public AssemblyDifference
type AssemblyDifferenceNamingCategory =
    class
        inherit AssemblyDifference
    end

The AssemblyDifferenceNamingCategory type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from AssemblyDifference)
Public property | NamingCategoryId1 | Naming category id of the first assembly
Public property | NamingCategoryId2 | Naming category id of the second assembly
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from AssemblyDifference)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


AssemblyDifferenceNamingCategory Properties

The AssemblyDifferenceNamingCategory type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from AssemblyDifference)
Public property | NamingCategoryId1 | Naming category id of the first assembly
Public property | NamingCategoryId2 | Naming category id of the second assembly
Top
See Also

Reference

AssemblyDifferenceNamingCategory Class


AssemblyDifferenceNamingCategory.NamingCategoryId1 Property

AssemblyDifferenceNamingCategoryNamingCategoryId1 Property

Naming category id of the first assembly

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId NamingCategoryId1 { get; }
Public ReadOnly Property NamingCategoryId1 As ElementId
    Get
public:
property ElementId^ NamingCategoryId1 {
    ElementId^ get ();
}
member NamingCategoryId1 : ElementId with get

Property Value

ElementId
See Also

Reference

AssemblyDifferenceNamingCategory Class


AssemblyDifferenceNamingCategory.NamingCategoryId2 Property

AssemblyDifferenceNamingCategoryNamingCategoryId2 Property

Naming category id of the second assembly

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId NamingCategoryId2 { get; }
Public ReadOnly Property NamingCategoryId2 As ElementId
    Get
public:
property ElementId^ NamingCategoryId2 {
    ElementId^ get ();
}
member NamingCategoryId2 : ElementId with get

Property Value

ElementId
See Also

Reference

AssemblyDifferenceNamingCategory Class


AssemblyDifferenceNamingCategory Methods

The AssemblyDifferenceNamingCategory type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from AssemblyDifference)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AssemblyDifferenceNamingCategory Class


AssemblyDifferenceNone Class

The two assemblies being compared are identical
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAssemblyDifference
Autodesk.Revit.DBAssemblyDifferenceNone

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AssemblyDifferenceNone : AssemblyDifference
Public Class AssemblyDifferenceNone
    Inherits AssemblyDifference
public ref class AssemblyDifferenceNone : public AssemblyDifference
type AssemblyDifferenceNone =
    class
        inherit AssemblyDifference
    end

The AssemblyDifferenceNone type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from AssemblyDifference)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from AssemblyDifference)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


AssemblyDifferenceNone Properties

The AssemblyDifferenceNone type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from AssemblyDifference)
Top
See Also

Reference

AssemblyDifferenceNone Class


AssemblyDifferenceNone Methods

The AssemblyDifferenceNone type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from AssemblyDifference)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AssemblyDifferenceNone Class


AssemblyInstance Class

Combines multiple elements for tagging, filtering, scheduling and creating isolated assembly views.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBAssemblyInstance

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AssemblyInstance : Element
Public Class AssemblyInstance
    Inherits Element
public ref class AssemblyInstance : public Element
type AssemblyInstance =
    class
        inherit Element
    end

The AssemblyInstance type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | AssemblyTypeName | The name for the assembly type. All matching assembly instances share this name. Unique assembly instances are named automatically based on their naming category.
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | Location | This property is used to find the physical location of the assembly instance within project. (Overrides ElementLocation)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | NamingCategoryId | Id of the category that drives the default naming scheme for the assembly instance.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | AddMemberIds | Adds member element ids for the assembly instance.
Public method | AllowsAssemblyViewCreation | Returns true if assembly views can be created for this Assembly Instance.
 | AreElementsValidForAssembly | Identifies if provided assembly members are valid.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
 | CanRemoveElementsFromAssembly | Identifies if provided assembly members can be removed from the assembly instance.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | CompareAssemblyInstances | Compares two assembly instances and returns a result with details about the differences
 | Create | Creates a new assembly instance.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Disassemble | Removes the assembly instance and releases the member elements.
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetCenter | Returns the center of the bounding box for the assembly instance. This is the default position for placed assembly instances.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMemberIds | Gets member element ids for the assembly instance.
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTransform | Gets the origin of the assembly instance.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMember | Determines whether the given ElementId is a member of this assembly
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
 | IsValidNamingCategory | Identifies if the naming category is valid for an assembly instance.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
 | PlaceInstance | Places an assembly instance of a given assembly type at the specified location.
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveMemberIds | Removes member element ids from the assembly instance.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetMemberIds | Sets member element ids for the assembly instance. All existing members are cleared.
Public method | SetTransform | Sets the origin of the assembly instance.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Example
C#
VB
C++
F#
Copy
// Create assembly instance, name the assembly, and create views of the assembly
AssemblyInstance CreateAssemblyAndViews(Autodesk.Revit.DB.Document doc, ICollection<ElementId> elementIds)
{
    AssemblyInstance assemblyInstance = null;
    using (Transaction transaction = new Transaction(doc))
    {
        ElementId categoryId = doc.GetElement(elementIds.First()).Category.Id; // use category of one of the assembly elements
        if (AssemblyInstance.IsValidNamingCategory(doc, categoryId, elementIds))
        {
            transaction.Start("Create Assembly Instance");
            assemblyInstance = AssemblyInstance.Create(doc, elementIds, categoryId);
            transaction.Commit(); // commit the transaction that creates the assembly instance before modifying the instance's name

            if (transaction.GetStatus() == TransactionStatus.Committed)
            {
                transaction.Start("Set Assembly Name");
                assemblyInstance.AssemblyTypeName = "My Assembly Name";
                transaction.Commit();
            }

            if (assemblyInstance.AllowsAssemblyViewCreation()) // create assembly views for this assembly instance
            {
                if (transaction.GetStatus() == TransactionStatus.Committed)
                {
                    transaction.Start("View Creation");
                    View3D view3d = AssemblyViewUtils.Create3DOrthographic(doc, assemblyInstance.Id);
                    ViewSchedule partList = AssemblyViewUtils.CreatePartList(doc, assemblyInstance.Id);
                    transaction.Commit();
                }
            }
        }
    }

    return assemblyInstance;
}
' Create assembly instance, name the assembly, and create views of the assembly
Private Function CreateAssemblyAndViews(doc As Autodesk.Revit.DB.Document, elementIds As ICollection(Of ElementId)) As AssemblyInstance
    Dim assemblyInstance__1 As AssemblyInstance = Nothing
    Using transaction As New Transaction(doc)
        Dim categoryId As ElementId = doc.GetElement(elementIds.First()).Category.Id
        ' use category of one of the assembly elements
        If AssemblyInstance.IsValidNamingCategory(doc, categoryId, elementIds) Then
            transaction.Start("Create Assembly Instance")
            assemblyInstance__1 = AssemblyInstance.Create(doc, elementIds, categoryId)
            transaction.Commit()
            ' commit the transaction that creates the assembly instance before modifying the instance's name
            If transaction.GetStatus() = TransactionStatus.Committed Then
                transaction.Start("Set Assembly Name")
                assemblyInstance__1.AssemblyTypeName = "My Assembly Name"
                transaction.Commit()
            End If

            If assemblyInstance__1.AllowsAssemblyViewCreation() Then
                ' create assembly views for this assembly instance
                If transaction.GetStatus() = TransactionStatus.Committed Then
                    transaction.Start("View Creation")
                    Dim view3d As View3D = AssemblyViewUtils.Create3DOrthographic(doc, assemblyInstance__1.Id)
                    Dim partList As ViewSchedule = AssemblyViewUtils.CreatePartList(doc, assemblyInstance__1.Id)
                    transaction.Commit()
                End If
            End If
        End If
    End Using

    Return assemblyInstance__1
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


AssemblyInstance Properties

The AssemblyInstance type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | AssemblyTypeName | The name for the assembly type. All matching assembly instances share this name. Unique assembly instances are named automatically based on their naming category.
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | Location | This property is used to find the physical location of the assembly instance within project. (Overrides ElementLocation)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | NamingCategoryId | Id of the category that drives the default naming scheme for the assembly instance.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

AssemblyInstance Class


AssemblyInstance.AssemblyTypeName Property

AssemblyInstanceAssemblyTypeName Property

The name for the assembly type. All matching assembly instances share this name. Unique assembly instances are named automatically based on their naming category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string AssemblyTypeName { get; set; }
Public Property AssemblyTypeName As String
    Get
    Set
public:
property String^ AssemblyTypeName {
    String^ get ();
    void set (String^ value);
}
member AssemblyTypeName : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentException | When setting this property: This assembly type name is not valid for this assembly instance. An assembly type name should be non-empty, should contain valid characters, and should be unique for its naming category.
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

AssemblyInstance Class


AssemblyInstance.Location Property

AssemblyInstanceLocation Property

This property is used to find the physical location of the assembly instance within project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Location Location { get; }
Public Overrides ReadOnly Property Location As Location
    Get
public:
virtual property Location^ Location {
    Location^ get () override;
}
abstract Location : Location with get
override Location : Location with get

Property Value

Location
Remarks
The Location property returns an object that can be used to find the location of an object within the project. Assembly instances return a point location object positioned at the center of the assembly instance.
See Also

Reference

AssemblyInstance Class


AssemblyInstance.NamingCategoryId Property

AssemblyInstanceNamingCategoryId Property

Id of the category that drives the default naming scheme for the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId NamingCategoryId { get; set; }
Public Property NamingCategoryId As ElementId
    Get
    Set
public:
property ElementId^ NamingCategoryId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member NamingCategoryId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentException | When setting this property: This naming category was not valid for an assembly instance containing the proposed members. The naming category should match one of the member element categories.
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

AssemblyInstance Class


AssemblyInstance Methods

The AssemblyInstance type exposes the following members.

Methods
 | Name | Description
Public method | AddMemberIds | Adds member element ids for the assembly instance.
Public method | AllowsAssemblyViewCreation | Returns true if assembly views can be created for this Assembly Instance.
 | AreElementsValidForAssembly | Identifies if provided assembly members are valid.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
 | CanRemoveElementsFromAssembly | Identifies if provided assembly members can be removed from the assembly instance.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | CompareAssemblyInstances | Compares two assembly instances and returns a result with details about the differences
 | Create | Creates a new assembly instance.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Disassemble | Removes the assembly instance and releases the member elements.
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetCenter | Returns the center of the bounding box for the assembly instance. This is the default position for placed assembly instances.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMemberIds | Gets member element ids for the assembly instance.
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTransform | Gets the origin of the assembly instance.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMember | Determines whether the given ElementId is a member of this assembly
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
 | IsValidNamingCategory | Identifies if the naming category is valid for an assembly instance.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
 | PlaceInstance | Places an assembly instance of a given assembly type at the specified location.
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveMemberIds | Removes member element ids from the assembly instance.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetMemberIds | Sets member element ids for the assembly instance. All existing members are cleared.
Public method | SetTransform | Sets the origin of the assembly instance.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AssemblyInstance Class


AssemblyInstance.AddMemberIds Method

AssemblyInstanceAddMemberIds Method

Adds member element ids for the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddMemberIds(
    ICollection<ElementId> memberIds
)
Public Sub AddMemberIds (
    memberIds As ICollection(Of ElementId)
)
public:
void AddMemberIds(
    ICollection<ElementId^>^ memberIds
)
member AddMemberIds :
        memberIds : ICollection<ElementId> -> unit

Parameters

memberIds ICollection ElementId
Element ids to be added to the assembly instance.
Exceptions
Exception | Condition
ArgumentException | One or more element ids was not permitted for membership in the assembly instance. Elements should be of a valid category and should not be a member of an existing assembly. -or- The provided set includes one or more element ids that cannot be added to or removed from the assembly on their own.
ArgumentNullException | A non-optional argument was null
See Also

Reference

AssemblyInstance Class


AssemblyInstance.AllowsAssemblyViewCreation Method

AssemblyInstanceAllowsAssemblyViewCreation Method

Returns true if assembly views can be created for this Assembly Instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AllowsAssemblyViewCreation()
Public Function AllowsAssemblyViewCreation As Boolean
public:
bool AllowsAssemblyViewCreation()
member AllowsAssemblyViewCreation : unit -> bool

Return Value

Boolean
Remarks
Assembly views are allowed when there are no assembly views for any instance of this type, or when the only existing assembly views belong to this instance
See Also

Reference

AssemblyInstance Class


AssemblyInstance.AreElementsValidForAssembly Method

AssemblyInstanceAreElementsValidForAssembly Method

Identifies if provided assembly members are valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool AreElementsValidForAssembly(
    Document document,
    ICollection<ElementId> assemblyMemberIds,
    ElementId assemblyId
)
Public Shared Function AreElementsValidForAssembly (
    document As Document,
    assemblyMemberIds As ICollection(Of ElementId),
    assemblyId As ElementId
) As Boolean
public:
static bool AreElementsValidForAssembly(
    Document^ document,
    ICollection<ElementId^>^ assemblyMemberIds,
    ElementId^ assemblyId
)
static member AreElementsValidForAssembly :
        document : Document *
        assemblyMemberIds : ICollection<ElementId> *
        assemblyId : ElementId -> bool

Parameters

document Document
The document.
assemblyMemberIds ICollection ElementId
Element ids to be tested for validity for membership of an assembly instance.
assemblyId ElementId
Id of the existing assembly to add components to. If invalid, the method return whether the components can be added to a new assembly

Return Value

Boolean
True if all member ids are valid, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

AssemblyInstance Class


AssemblyInstance.CanRemoveElementsFromAssembly Method

AssemblyInstanceCanRemoveElementsFromAssembly Method

Identifies if provided assembly members can be removed from the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CanRemoveElementsFromAssembly(
    AssemblyInstance assemblyInstance,
    ICollection<ElementId> memberIds
)
Public Shared Function CanRemoveElementsFromAssembly (
    assemblyInstance As AssemblyInstance,
    memberIds As ICollection(Of ElementId)
) As Boolean
public:
static bool CanRemoveElementsFromAssembly(
    AssemblyInstance^ assemblyInstance,
    ICollection<ElementId^>^ memberIds
)
static member CanRemoveElementsFromAssembly :
        assemblyInstance : AssemblyInstance *
        memberIds : ICollection<ElementId> -> bool

Parameters

assemblyInstance AssemblyInstance
The assembly instance to remove elements from.
memberIds ICollection ElementId
Element ids to be tested for validity to remove from the assembly instance.

Return Value

Boolean
True if all member ids are valid, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

AssemblyInstance Class


AssemblyInstance.CompareAssemblyInstances Method

AssemblyInstanceCompareAssemblyInstances Method

Compares two assembly instances and returns a result with details about the differences

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static AssemblyDifference CompareAssemblyInstances(
    AssemblyInstance instance1,
    AssemblyInstance instance2
)
Public Shared Function CompareAssemblyInstances (
    instance1 As AssemblyInstance,
    instance2 As AssemblyInstance
) As AssemblyDifference
public:
static AssemblyDifference^ CompareAssemblyInstances(
    AssemblyInstance^ instance1,
    AssemblyInstance^ instance2
)
static member CompareAssemblyInstances :
        instance1 : AssemblyInstance *
        instance2 : AssemblyInstance -> AssemblyDifference

Parameters

instance1 AssemblyInstance
The first assembly instance to compare
instance2 AssemblyInstance
the second assembly instance to compare

Return Value

AssemblyDifference
An object describing the difference between the two instances
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Only the first found difference is returned. If the instances are identical, AssemblyDifferenceNone will be returned.
Example
C#
VB
C++
F#
Copy
// Identify the difference, if any, between two assembly instances
void FindAssemblyDifferences(AssemblyInstance instance1, AssemblyInstance instance2)
{
    Autodesk.Revit.DB.Document doc = instance1.Document;
    AssemblyDifference difference = AssemblyInstance.CompareAssemblyInstances(instance1, instance2);

    AssemblyDifferenceNone diffNone = difference as AssemblyDifferenceNone;
    if (diffNone != null)
    {
        TaskDialog.Show("Revit", "Assemblies are identical");
        return;
    }

    AssemblyDifferenceConfiguration diffConfig = difference as AssemblyDifferenceConfiguration;
    if (diffConfig != null)
    {
        TaskDialog.Show("Revit", "Elements are not arranged in space relative to each other in the same way");
        return;
    }

    AssemblyDifferenceMemberCount diffMemberCount = difference as AssemblyDifferenceMemberCount;
    if (diffMemberCount != null)
    {
        TaskDialog.Show("Revit", "Elements counts differ: " + diffMemberCount.Count1 + " & " + diffMemberCount.Count2);
        return;
    }

    AssemblyDifferenceNamingCategory diffNameCat = difference as AssemblyDifferenceNamingCategory;
    if (diffNameCat != null)
    {
        TaskDialog.Show("Revit", "Naming categories differ: " +
            Category.GetCategory(doc, diffNameCat.NamingCategoryId1).Name + " & " +
            Category.GetCategory(doc, diffNameCat.NamingCategoryId2).Name);
        return;
    }

    AssemblyDifferenceMemberDifference memberDifference = difference as AssemblyDifferenceMemberDifference;
    if (memberDifference != null)
    {
        AssemblyMemberDifference assemblyMemberDifference = memberDifference.MemberDifference as AssemblyMemberDifference;

        AssemblyMemberDifferentCategory differentCategory = assemblyMemberDifference as AssemblyMemberDifferentCategory;
        if (differentCategory != null)
        {
            TaskDialog.Show("Revit", "Element categories differ: " +
                Category.GetCategory(doc, diffNameCat.NamingCategoryId1).Name + " & " +
                Category.GetCategory(doc, diffNameCat.NamingCategoryId2).Name);
            return;
        }
        AssemblyMemberDifferentGeometry differentGeometry = assemblyMemberDifference as AssemblyMemberDifferentGeometry;
        if (differentGeometry != null)
        {
            TaskDialog.Show("Revit", "Member geometry differs");
            return;
        }
        AssemblyMemberDifferentParameters differentParameters = assemblyMemberDifference as AssemblyMemberDifferentParameters;
        if (differentParameters != null)
        {
            TaskDialog.Show("Revit", "Member parameters differs");
            return;
        }
        AssemblyMemberDifferentType differentType = assemblyMemberDifference as AssemblyMemberDifferentType;
        if (differentType != null)
        {
            TaskDialog.Show("Revit", "Element types differ: " + doc.GetElement(differentType.TypeId1).Name + " & " + doc.GetElement(differentType.TypeId2).Name);
            return;
        }
    }
    return;
}
' Identify the difference, if any, between two assembly instances
Private Sub FindAssemblyDifferences(instance1 As AssemblyInstance, instance2 As AssemblyInstance)
    Dim doc As Autodesk.Revit.DB.Document = instance1.Document
    Dim difference As AssemblyDifference = AssemblyInstance.CompareAssemblyInstances(instance1, instance2)

    Dim diffNone As AssemblyDifferenceNone = TryCast(difference, AssemblyDifferenceNone)
    If diffNone IsNot Nothing Then
        TaskDialog.Show("Revit", "Assemblies are identical")
        Return
    End If

    Dim diffConfig As AssemblyDifferenceConfiguration = TryCast(difference, AssemblyDifferenceConfiguration)
    If diffConfig IsNot Nothing Then
        TaskDialog.Show("Revit", "Elements are not arranged in space relative to each other in the same way")
        Return
    End If

    Dim diffMemberCount As AssemblyDifferenceMemberCount = TryCast(difference, AssemblyDifferenceMemberCount)
    If diffMemberCount IsNot Nothing Then
        TaskDialog.Show("Revit", "Elements counts differ: " + diffMemberCount.Count1 + " & " + diffMemberCount.Count2)
        Return
    End If

    Dim diffNameCat As AssemblyDifferenceNamingCategory = TryCast(difference, AssemblyDifferenceNamingCategory)
    If diffNameCat IsNot Nothing Then
        Dim catInt1 As Long = diffNameCat.NamingCategoryId1.Value
        Dim catInt2 As Long = diffNameCat.NamingCategoryId2.Value
        TaskDialog.Show("Revit", "Naming categories differ: " + doc.Settings.Categories.Item(DirectCast(catInt1, BuiltInCategory)).Name + " & " + doc.Settings.Categories.Item(DirectCast(catInt2, BuiltInCategory)).Name)
        Return
    End If

    Dim memberDifference As AssemblyDifferenceMemberDifference = TryCast(difference, AssemblyDifferenceMemberDifference)
    If memberDifference IsNot Nothing Then
        Dim assemblyMemberDifference As AssemblyMemberDifference = TryCast(memberDifference.MemberDifference, AssemblyMemberDifference)

        Dim differentCategory As AssemblyMemberDifferentCategory = TryCast(assemblyMemberDifference, AssemblyMemberDifferentCategory)
        If differentCategory IsNot Nothing Then
            Dim int1 As Long = differentCategory.CategoryId1.Value
            Dim int2 As Long = differentCategory.CategoryId2.Value
            TaskDialog.Show("Revit", "Element categories differ: " + doc.Settings.Categories.Item(DirectCast(int1, BuiltInCategory)).Name + " & " + doc.Settings.Categories.Item(DirectCast(int2, BuiltInCategory)).Name)
            Return
        End If
        Dim differentGeometry As AssemblyMemberDifferentGeometry = TryCast(assemblyMemberDifference, AssemblyMemberDifferentGeometry)
        If differentGeometry IsNot Nothing Then
            TaskDialog.Show("Revit", "Member geometry differs")
            Return
        End If
        Dim differentParameters As AssemblyMemberDifferentParameters = TryCast(assemblyMemberDifference, AssemblyMemberDifferentParameters)
        If differentParameters IsNot Nothing Then
            TaskDialog.Show("Revit", "Member parameters differs")
            Return
        End If
        Dim differentType As AssemblyMemberDifferentType = TryCast(assemblyMemberDifference, AssemblyMemberDifferentType)
        If differentType IsNot Nothing Then
            TaskDialog.Show("Revit", "Element types differ: " + doc.GetElement(differentType.TypeId1).Name + " & " + doc.GetElement(differentType.TypeId2).Name)
            Return
        End If
    End If
    Return
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

AssemblyInstance Class


AssemblyInstance.Create Method

AssemblyInstanceCreate Method

Creates a new assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static AssemblyInstance Create(
    Document document,
    ICollection<ElementId> assemblyMemberIds,
    ElementId namingCategoryId
)
Public Shared Function Create (
    document As Document,
    assemblyMemberIds As ICollection(Of ElementId),
    namingCategoryId As ElementId
) As AssemblyInstance
public:
static AssemblyInstance^ Create(
    Document^ document,
    ICollection<ElementId^>^ assemblyMemberIds,
    ElementId^ namingCategoryId
)
static member Create :
        document : Document *
        assemblyMemberIds : ICollection<ElementId> *
        namingCategoryId : ElementId -> AssemblyInstance

Parameters

document Document
The document containing the elements.
assemblyMemberIds ICollection ElementId
The elements that comprise the assembly.
namingCategoryId ElementId
The naming category for the assembly instance.

Return Value

AssemblyInstance
The newly created assembly instance.
Exceptions
Exception | Condition
ArgumentException | One or more element ids was not permitted for membership in the assembly instance. Elements should be of a valid category and should not be a member of an existing assembly. -or- This naming category was not valid for an assembly instance containing the proposed members. The naming category should match one of the member element categories.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
Transaction must be committed after calling this method before performing any action on the newly created instance. Assembly type is assigned after the transaction for creating assembly instance is complete.
See Also

Reference

AssemblyInstance Class


AssemblyInstance.Disassemble Method

AssemblyInstanceDisassemble Method

Removes the assembly instance and releases the member elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> Disassemble()
Public Function Disassemble As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ Disassemble()
member Disassemble : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
ids of elements previously under the assembly instance.
See Also

Reference

AssemblyInstance Class


AssemblyInstance.GetCenter Method

AssemblyInstanceGetCenter Method

Returns the center of the bounding box for the assembly instance. This is the default position for placed assembly instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ GetCenter()
Public Function GetCenter As XYZ
public:
XYZ^ GetCenter()
member GetCenter : unit -> XYZ

Return Value

XYZ
The position for the center of the assembly instance.
See Also

Reference

AssemblyInstance Class


AssemblyInstance.GetMemberIds Method

AssemblyInstanceGetMemberIds Method

Gets member element ids for the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetMemberIds()
Public Function GetMemberIds As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetMemberIds()
member GetMemberIds : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
Element ids for the members of the assembly instance.
See Also

Reference

AssemblyInstance Class


AssemblyInstance.GetTransform Method

AssemblyInstanceGetTransform Method

Gets the origin of the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Transform GetTransform()
Public Function GetTransform As Transform
public:
Transform^ GetTransform()
member GetTransform : unit -> Transform

Return Value

Transform
The origin of the assembly instance.
See Also

Reference

AssemblyInstance Class


AssemblyInstance.IsMember Method

AssemblyInstanceIsMember Method

Determines whether the given ElementId is a member of this assembly

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsMember(
    ElementId id
)
Public Function IsMember (
    id As ElementId
) As Boolean
public:
bool IsMember(
    ElementId^ id
)
member IsMember :
        id : ElementId -> bool

Parameters

id ElementId

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

AssemblyInstance Class


AssemblyInstance.IsValidNamingCategory Method

AssemblyInstanceIsValidNamingCategory Method

Identifies if the naming category is valid for an assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidNamingCategory(
    Document document,
    ElementId namingCategoryId,
    ICollection<ElementId> assemblyMemberIds
)
Public Shared Function IsValidNamingCategory (
    document As Document,
    namingCategoryId As ElementId,
    assemblyMemberIds As ICollection(Of ElementId)
) As Boolean
public:
static bool IsValidNamingCategory(
    Document^ document,
    ElementId^ namingCategoryId,
    ICollection<ElementId^>^ assemblyMemberIds
)
static member IsValidNamingCategory :
        document : Document *
        namingCategoryId : ElementId *
        assemblyMemberIds : ICollection<ElementId> -> bool

Parameters

document Document
The document for the assembly instance.
namingCategoryId ElementId
The id of the naming category for the assembly instance.
assemblyMemberIds ICollection ElementId
Member ids to check validity of naming category

Return Value

Boolean
True if the naming category is valid, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

AssemblyInstance Class


AssemblyInstance.PlaceInstance Method

AssemblyInstancePlaceInstance Method

Places an assembly instance of a given assembly type at the specified location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static AssemblyInstance PlaceInstance(
    Document document,
    ElementId assemblyTypeId,
    XYZ location
)
Public Shared Function PlaceInstance (
    document As Document,
    assemblyTypeId As ElementId,
    location As XYZ
) As AssemblyInstance
public:
static AssemblyInstance^ PlaceInstance(
    Document^ document,
    ElementId^ assemblyTypeId,
    XYZ^ location
)
static member PlaceInstance :
        document : Document *
        assemblyTypeId : ElementId *
        location : XYZ -> AssemblyInstance

Parameters

document Document
The document for the new assembly instance.
assemblyTypeId ElementId
The id of the assembly type to be used for the instance.
location XYZ
The placement location for the instance in project coordinates.

Return Value

AssemblyInstance
The newly created assembly instance.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

AssemblyInstance Class


AssemblyInstance.RemoveMemberIds Method

AssemblyInstanceRemoveMemberIds Method

Removes member element ids from the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveMemberIds(
    ICollection<ElementId> memberIds
)
Public Sub RemoveMemberIds (
    memberIds As ICollection(Of ElementId)
)
public:
void RemoveMemberIds(
    ICollection<ElementId^>^ memberIds
)
member RemoveMemberIds :
        memberIds : ICollection<ElementId> -> unit

Parameters

memberIds ICollection ElementId
Element ids to be removed from the assembly instance.
Exceptions
Exception | Condition
ArgumentException | One or more element ids was not permitted to be removed from the assembly instance. Provided set should not be empty and all elements should be a member of the assembly instance. -or- The provided set includes one or more element ids that cannot be added to or removed from the assembly on their own.
ArgumentNullException | A non-optional argument was null
See Also

Reference

AssemblyInstance Class


AssemblyInstance.SetMemberIds Method

AssemblyInstanceSetMemberIds Method

Sets member element ids for the assembly instance. All existing members are cleared.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetMemberIds(
    ICollection<ElementId> memberIds
)
Public Sub SetMemberIds (
    memberIds As ICollection(Of ElementId)
)
public:
void SetMemberIds(
    ICollection<ElementId^>^ memberIds
)
member SetMemberIds :
        memberIds : ICollection<ElementId> -> unit

Parameters

memberIds ICollection ElementId
Element ids to set for the assembly instance.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ForbiddenForDynamicUpdateException | This method may not be called during dynamic update.
See Also

Reference

AssemblyInstance Class


AssemblyInstance.SetTransform Method

AssemblyInstanceSetTransform Method

Sets the origin of the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetTransform(
    Transform trf
)
Public Sub SetTransform (
    trf As Transform
)
public:
void SetTransform(
    Transform^ trf
)
member SetTransform :
        trf : Transform -> unit

Parameters

trf Transform
Transform to be set.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentsInconsistentException | trf is not a rigid body transformation.
See Also

Reference

AssemblyInstance Class


AssemblyMemberDifference Class

Class that describes difference between two assembly members
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAssemblyMemberDifference
Autodesk.Revit.DBAssemblyMemberDifferentCategory
Autodesk.Revit.DBAssemblyMemberDifferentGeometry
Autodesk.Revit.DBAssemblyMemberDifferentParameters
Autodesk.Revit.DBAssemblyMemberDifferentType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AssemblyMemberDifference : IDisposable
Public Class AssemblyMemberDifference
    Implements IDisposable
public ref class AssemblyMemberDifference : IDisposable
type AssemblyMemberDifference =
    class
        interface IDisposable
    end

The AssemblyMemberDifference type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the AssemblyMemberDifference
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Different sub-classes of this class represent different kinds of differences between assembly members and contain additional data for each particular kind of difference.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


AssemblyMemberDifference Properties

The AssemblyMemberDifference type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

AssemblyMemberDifference Class


AssemblyMemberDifference.IsValidObject Property

AssemblyMemberDifferenceIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

AssemblyMemberDifference Class


AssemblyMemberDifference Methods

The AssemblyMemberDifference type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AssemblyMemberDifference Class


AssemblyMemberDifference.Dispose Method

AssemblyMemberDifferenceDispose Method

Releases all resources used by the AssemblyMemberDifference

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

AssemblyMemberDifference Class


AssemblyMemberDifferentCategory Class

The two assembly members being compared have different category
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAssemblyMemberDifference
Autodesk.Revit.DBAssemblyMemberDifferentCategory

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AssemblyMemberDifferentCategory : AssemblyMemberDifference
Public Class AssemblyMemberDifferentCategory
    Inherits AssemblyMemberDifference
public ref class AssemblyMemberDifferentCategory : public AssemblyMemberDifference
type AssemblyMemberDifferentCategory =
    class
        inherit AssemblyMemberDifference
    end

The AssemblyMemberDifferentCategory type exposes the following members.

Properties
 | Name | Description
Public property | CategoryId1 | Category id of the first assembly member
Public property | CategoryId2 | Category id of the second assembly member
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from AssemblyMemberDifference)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from AssemblyMemberDifference)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


AssemblyMemberDifferentCategory Properties

The AssemblyMemberDifferentCategory type exposes the following members.

Properties
 | Name | Description
Public property | CategoryId1 | Category id of the first assembly member
Public property | CategoryId2 | Category id of the second assembly member
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from AssemblyMemberDifference)
Top
See Also

Reference

AssemblyMemberDifferentCategory Class


AssemblyMemberDifferentCategory.CategoryId1 Property

AssemblyMemberDifferentCategoryCategoryId1 Property

Category id of the first assembly member

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId CategoryId1 { get; }
Public ReadOnly Property CategoryId1 As ElementId
    Get
public:
property ElementId^ CategoryId1 {
    ElementId^ get ();
}
member CategoryId1 : ElementId with get

Property Value

ElementId
See Also

Reference

AssemblyMemberDifferentCategory Class


AssemblyMemberDifferentCategory.CategoryId2 Property

AssemblyMemberDifferentCategoryCategoryId2 Property

Category id of the second assembly member

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId CategoryId2 { get; }
Public ReadOnly Property CategoryId2 As ElementId
    Get
public:
property ElementId^ CategoryId2 {
    ElementId^ get ();
}
member CategoryId2 : ElementId with get

Property Value

ElementId
See Also

Reference

AssemblyMemberDifferentCategory Class


AssemblyMemberDifferentCategory Methods

The AssemblyMemberDifferentCategory type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from AssemblyMemberDifference)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AssemblyMemberDifferentCategory Class


AssemblyMemberDifferentGeometry Class

The two assembly members being compared have different geometry
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAssemblyMemberDifference
Autodesk.Revit.DBAssemblyMemberDifferentGeometry

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AssemblyMemberDifferentGeometry : AssemblyMemberDifference
Public Class AssemblyMemberDifferentGeometry
    Inherits AssemblyMemberDifference
public ref class AssemblyMemberDifferentGeometry : public AssemblyMemberDifference
type AssemblyMemberDifferentGeometry =
    class
        inherit AssemblyMemberDifference
    end

The AssemblyMemberDifferentGeometry type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from AssemblyMemberDifference)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from AssemblyMemberDifference)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


AssemblyMemberDifferentGeometry Properties

The AssemblyMemberDifferentGeometry type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from AssemblyMemberDifference)
Top
See Also

Reference

AssemblyMemberDifferentGeometry Class


AssemblyMemberDifferentGeometry Methods

The AssemblyMemberDifferentGeometry type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from AssemblyMemberDifference)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AssemblyMemberDifferentGeometry Class


AssemblyMemberDifferentParameters Class

The two assembly members being compared have different parameters
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAssemblyMemberDifference
Autodesk.Revit.DBAssemblyMemberDifferentParameters

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AssemblyMemberDifferentParameters : AssemblyMemberDifference
Public Class AssemblyMemberDifferentParameters
    Inherits AssemblyMemberDifference
public ref class AssemblyMemberDifferentParameters : public AssemblyMemberDifference
type AssemblyMemberDifferentParameters =
    class
        inherit AssemblyMemberDifference
    end

The AssemblyMemberDifferentParameters type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from AssemblyMemberDifference)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from AssemblyMemberDifference)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


AssemblyMemberDifferentParameters Properties

The AssemblyMemberDifferentParameters type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from AssemblyMemberDifference)
Top
See Also

Reference

AssemblyMemberDifferentParameters Class


AssemblyMemberDifferentParameters Methods

The AssemblyMemberDifferentParameters type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from AssemblyMemberDifference)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AssemblyMemberDifferentParameters Class


AssemblyMemberDifferentType Class

The two assembly members being compared have different type
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAssemblyMemberDifference
Autodesk.Revit.DBAssemblyMemberDifferentType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AssemblyMemberDifferentType : AssemblyMemberDifference
Public Class AssemblyMemberDifferentType
    Inherits AssemblyMemberDifference
public ref class AssemblyMemberDifferentType : public AssemblyMemberDifference
type AssemblyMemberDifferentType =
    class
        inherit AssemblyMemberDifference
    end

The AssemblyMemberDifferentType type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from AssemblyMemberDifference)
Public property | TypeId1 | Type id of the first assembly member
Public property | TypeId2 | Type id of the second assembly member
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from AssemblyMemberDifference)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


AssemblyMemberDifferentType Properties

The AssemblyMemberDifferentType type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from AssemblyMemberDifference)
Public property | TypeId1 | Type id of the first assembly member
Public property | TypeId2 | Type id of the second assembly member
Top
See Also

Reference

AssemblyMemberDifferentType Class


AssemblyMemberDifferentType.TypeId1 Property

AssemblyMemberDifferentTypeTypeId1 Property

Type id of the first assembly member

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId TypeId1 { get; }
Public ReadOnly Property TypeId1 As ElementId
    Get
public:
property ElementId^ TypeId1 {
    ElementId^ get ();
}
member TypeId1 : ElementId with get

Property Value

ElementId
See Also

Reference

AssemblyMemberDifferentType Class


AssemblyMemberDifferentType.TypeId2 Property

AssemblyMemberDifferentTypeTypeId2 Property

Type id of the second assembly member

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId TypeId2 { get; }
Public ReadOnly Property TypeId2 As ElementId
    Get
public:
property ElementId^ TypeId2 {
    ElementId^ get ();
}
member TypeId2 : ElementId with get

Property Value

ElementId
See Also

Reference

AssemblyMemberDifferentType Class


AssemblyMemberDifferentType Methods

The AssemblyMemberDifferentType type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from AssemblyMemberDifference)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AssemblyMemberDifferentType Class


AssemblyType Class

Type for construction assembly elements.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBAssemblyType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AssemblyType : ElementType
Public Class AssemblyType
    Inherits ElementType
public ref class AssemblyType : public ElementType
type AssemblyType =
    class
        inherit ElementType
    end

The AssemblyType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


AssemblyType Properties

The AssemblyType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

AssemblyType Class


AssemblyType Methods

The AssemblyType type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AssemblyType Class


AssemblyViewUtils Class

Utilities that provide capabilities related to assembly view creation and validation.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAssemblyViewUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class AssemblyViewUtils
Public NotInheritable Class AssemblyViewUtils
public ref class AssemblyViewUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type AssemblyViewUtils = class end

The AssemblyViewUtils type exposes the following members.

Methods
Name | Description
AcquireAssemblyViews | Transfers the assembly views owned by a source assembly instance to a target sibling assembly instance of the same assembly type.
Create3DOrthographic(Document, ElementId) | Creates a new orthographic 3D assembly view for the assembly instance.
Create3DOrthographic(Document, ElementId, ElementId, Boolean) | Creates a new orthographic 3D assembly view for the assembly instance. The view will have the same orientation as the Default 3D view. The document must be regenerated before using the 3D view.
CreateDetailSection(Document, ElementId, AssemblyDetailViewOrientation) | Creates a new detail section assembly view for the assembly instance.
CreateDetailSection(Document, ElementId, AssemblyDetailViewOrientation, ElementId, Boolean) | Creates a new detail section assembly view for the assembly instance.
CreateMaterialTakeoff(Document, ElementId) | Creates a new material takeoff multicategory schedule assembly view for the assembly instance.
CreateMaterialTakeoff(Document, ElementId, ElementId, Boolean) | Creates a new material takeoff multicategory schedule assembly view for the assembly instance.
CreatePartList(Document, ElementId) | Creates a new part list multicategory schedule assembly view for the assembly instance.
CreatePartList(Document, ElementId, ElementId, Boolean) | Creates a new part list multicategory schedule assembly view for the assembly instance.
CreateSheet | Creates a new sheet assembly view for the assembly instance.
CreateSingleCategorySchedule(Document, ElementId, ElementId) | Creates a new single-category schedule assembly view for the assembly instance.
CreateSingleCategorySchedule(Document, ElementId, ElementId, ElementId, Boolean) | Creates a new single-category schedule assembly view for the assembly instance.
Top
Example
C#
VB
C++
F#
Copy
private ViewSchedule CreateScheduleForAssembly(Document doc, AssemblyInstance assemblyInstance, ElementId viewTemplateId)
{
    ViewSchedule schedule = null;
    if (assemblyInstance.AllowsAssemblyViewCreation()) // create assembly views for this assembly instance
    {
        using (Transaction transaction = new Transaction(doc))
        {
            transaction.Start("Create Schedule");

            // use naming category for the schedule
            if (ViewSchedule.IsValidCategoryForSchedule(assemblyInstance.NamingCategoryId))
            {
                schedule = AssemblyViewUtils.CreateSingleCategorySchedule(doc, assemblyInstance.Id, assemblyInstance.NamingCategoryId, viewTemplateId, false);
            }
            transaction.Commit();

            if (schedule != null && transaction.GetStatus() == TransactionStatus.Committed)
            {
                transaction.Start("Edit Schedule");
                schedule.Name = "AssemblyViewSchedule";
                transaction.Commit();
            }
        }
    }

    return schedule;
}
Private Function CreateScheduleForAssembly(doc As Document, assemblyInstance As AssemblyInstance, viewTemplateId As ElementId) As ViewSchedule
    Dim schedule As ViewSchedule = Nothing
    If assemblyInstance.AllowsAssemblyViewCreation() Then
        ' create assembly views for this assembly instance
        Using transaction As New Transaction(doc)
            transaction.Start("Create Schedule")

            ' use naming category for the schedule
            If ViewSchedule.IsValidCategoryForSchedule(assemblyInstance.NamingCategoryId) Then
                schedule = AssemblyViewUtils.CreateSingleCategorySchedule(doc, assemblyInstance.Id, assemblyInstance.NamingCategoryId, viewTemplateId, False)
            End If
            transaction.Commit()

            If schedule IsNot Nothing AndAlso transaction.GetStatus() = TransactionStatus.Committed Then
                transaction.Start("Edit Schedule")
                schedule.Name = "AssemblyViewSchedule"
                transaction.Commit()
            End If
        End Using
    End If

    Return schedule
End Function

Private Function IExternalCommand_Execute(commandData As ExternalCommandData, ByRef message As String, elements As ElementSet) As Result Implements IExternalCommand.Execute
    Throw New NotImplementedException()
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


AssemblyViewUtils Methods

The AssemblyViewUtils type exposes the following members.

Methods
Name | Description
AcquireAssemblyViews | Transfers the assembly views owned by a source assembly instance to a target sibling assembly instance of the same assembly type.
Create3DOrthographic(Document, ElementId) | Creates a new orthographic 3D assembly view for the assembly instance.
Create3DOrthographic(Document, ElementId, ElementId, Boolean) | Creates a new orthographic 3D assembly view for the assembly instance. The view will have the same orientation as the Default 3D view. The document must be regenerated before using the 3D view.
CreateDetailSection(Document, ElementId, AssemblyDetailViewOrientation) | Creates a new detail section assembly view for the assembly instance.
CreateDetailSection(Document, ElementId, AssemblyDetailViewOrientation, ElementId, Boolean) | Creates a new detail section assembly view for the assembly instance.
CreateMaterialTakeoff(Document, ElementId) | Creates a new material takeoff multicategory schedule assembly view for the assembly instance.
CreateMaterialTakeoff(Document, ElementId, ElementId, Boolean) | Creates a new material takeoff multicategory schedule assembly view for the assembly instance.
CreatePartList(Document, ElementId) | Creates a new part list multicategory schedule assembly view for the assembly instance.
CreatePartList(Document, ElementId, ElementId, Boolean) | Creates a new part list multicategory schedule assembly view for the assembly instance.
CreateSheet | Creates a new sheet assembly view for the assembly instance.
CreateSingleCategorySchedule(Document, ElementId, ElementId) | Creates a new single-category schedule assembly view for the assembly instance.
CreateSingleCategorySchedule(Document, ElementId, ElementId, ElementId, Boolean) | Creates a new single-category schedule assembly view for the assembly instance.
Top
See Also

Reference

AssemblyViewUtils Class


AssemblyViewUtils.AcquireAssemblyViews Method

AssemblyViewUtilsAcquireAssemblyViews Method

Transfers the assembly views owned by a source assembly instance to a target sibling assembly instance of the same assembly type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void AcquireAssemblyViews(
    Document document,
    ElementId sourceAssemblyInstanceId,
    ElementId targetAssemblyInstanceId
)
Public Shared Sub AcquireAssemblyViews (
    document As Document,
    sourceAssemblyInstanceId As ElementId,
    targetAssemblyInstanceId As ElementId
)
public:
static void AcquireAssemblyViews(
    Document^ document,
    ElementId^ sourceAssemblyInstanceId,
    ElementId^ targetAssemblyInstanceId
)
static member AcquireAssemblyViews :
        document : Document *
        sourceAssemblyInstanceId : ElementId *
        targetAssemblyInstanceId : ElementId -> unit

Parameters

document Document
The document in which the assembly instances live.
sourceAssemblyInstanceId ElementId
Id of the assembly instance that currently owns the assembly views.
targetAssemblyInstanceId ElementId
Id of the assembly instance which will become the new owner of the assembly views.
Exceptions
Exception | Condition
ArgumentException | sourceAssemblyInstanceId is not an AssemblyInstance with assembly views. -or- targetAssemblyInstanceId is not an AssemblyInstance. -or- sourceAssemblyInstanceId and targetAssemblyInstanceId are not AssemblyInstances from the same assembly type.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
See Also

Reference

AssemblyViewUtils Class


AssemblyViewUtils.Create3DOrthographic Method

AssemblyViewUtilsCreate3DOrthographic Method

Overload List
Name | Description
Create3DOrthographic(Document, ElementId) | Creates a new orthographic 3D assembly view for the assembly instance.
Create3DOrthographic(Document, ElementId, ElementId, Boolean) | Creates a new orthographic 3D assembly view for the assembly instance. The view will have the same orientation as the Default 3D view. The document must be regenerated before using the 3D view.
Top
See Also

Reference

AssemblyViewUtils Class


AssemblyViewUtils.Create3DOrthographic(Document, ElementId) Method

AssemblyViewUtilsCreate3DOrthographic(Document, ElementId) Method

Creates a new orthographic 3D assembly view for the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static View3D Create3DOrthographic(
    Document document,
    ElementId assemblyInstanceId
)
Public Shared Function Create3DOrthographic (
    document As Document,
    assemblyInstanceId As ElementId
) As View3D
public:
static View3D^ Create3DOrthographic(
    Document^ document,
    ElementId^ assemblyInstanceId
)
static member Create3DOrthographic :
        document : Document *
        assemblyInstanceId : ElementId -> View3D

Parameters

document Document
The document to which the view will be added.
assemblyInstanceId ElementId
Id of the assembly instance that owns the new view.

Return Value

View3D
A new orthographic 3D assembly view.
Exceptions
Exception | Condition
ArgumentException | assemblyInstanceId is not an AssemblyInstance.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
The view will have the same orientation as the Default 3D view. The document must be regenerated before using the 3D view.
See Also

Reference

AssemblyViewUtils Class
Create3DOrthographic Overload


AssemblyViewUtils.Create3DOrthographic(Document, ElementId, ElementId, Boolean) Method

AssemblyViewUtilsCreate3DOrthographic(Document, ElementId, ElementId, Boolean) Method

Creates a new orthographic 3D assembly view for the assembly instance. The view will have the same orientation as the Default 3D view. The document must be regenerated before using the 3D view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static View3D Create3DOrthographic(
    Document document,
    ElementId assemblyInstanceId,
    ElementId viewTemplateId,
    bool isAssigned
)
Public Shared Function Create3DOrthographic (
    document As Document,
    assemblyInstanceId As ElementId,
    viewTemplateId As ElementId,
    isAssigned As Boolean
) As View3D
public:
static View3D^ Create3DOrthographic(
    Document^ document,
    ElementId^ assemblyInstanceId,
    ElementId^ viewTemplateId,
    bool isAssigned
)
static member Create3DOrthographic :
        document : Document *
        assemblyInstanceId : ElementId *
        viewTemplateId : ElementId *
        isAssigned : bool -> View3D

Parameters

document Document
The document to which the view will be added.
assemblyInstanceId ElementId
Id of the assembly instance that owns the new view.
viewTemplateId ElementId
Id of the view template that is used to create the view; if invalidElementId, the view will be created with the default settings.
isAssigned Boolean
If true, the template will be assigned, if false, the template will be applied.

Return Value

View3D
A new orthographic 3D assembly view.
Exceptions
Exception | Condition
ArgumentException | assemblyInstanceId is not an AssemblyInstance. -or- viewTemplateId is not a correct view template for the geom view.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
See Also

Reference

AssemblyViewUtils Class
Create3DOrthographic Overload


AssemblyViewUtils.CreateDetailSection Method

AssemblyViewUtilsCreateDetailSection Method

Overload List
Name | Description
CreateDetailSection(Document, ElementId, AssemblyDetailViewOrientation) | Creates a new detail section assembly view for the assembly instance.
CreateDetailSection(Document, ElementId, AssemblyDetailViewOrientation, ElementId, Boolean) | Creates a new detail section assembly view for the assembly instance.
Top
See Also

Reference

AssemblyViewUtils Class


AssemblyViewUtils.CreateDetailSection(Document, ElementId, AssemblyDetailViewOrientation) Method

AssemblyViewUtilsCreateDetailSection(Document, ElementId, AssemblyDetailViewOrientation) Method

Creates a new detail section assembly view for the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ViewSection CreateDetailSection(
    Document document,
    ElementId assemblyInstanceId,
    AssemblyDetailViewOrientation direction
)
Public Shared Function CreateDetailSection (
    document As Document,
    assemblyInstanceId As ElementId,
    direction As AssemblyDetailViewOrientation
) As ViewSection
public:
static ViewSection^ CreateDetailSection(
    Document^ document,
    ElementId^ assemblyInstanceId,
    AssemblyDetailViewOrientation direction
)
static member CreateDetailSection :
        document : Document *
        assemblyInstanceId : ElementId *
        direction : AssemblyDetailViewOrientation -> ViewSection

Parameters

document Document
The document to which the view will be added.
assemblyInstanceId ElementId
Id of the assembly instance that owns the new view.
direction AssemblyDetailViewOrientation
The direction for the new view.

Return Value

ViewSection
A new detail section assembly view.
Exceptions
Exception | Condition
ArgumentException | assemblyInstanceId is not an AssemblyInstance.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
The detail section will cut through the center of the assembly instance's outline. The document must be regenerated before using the detail section.
See Also

Reference

AssemblyViewUtils Class
CreateDetailSection Overload


AssemblyViewUtils.CreateDetailSection(Document, ElementId, AssemblyDetailViewOrientation, ElementId, Boolean) Method

AssemblyViewUtilsCreateDetailSection(Document, ElementId, AssemblyDetailViewOrientation, ElementId, Boolean) Method

Creates a new detail section assembly view for the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ViewSection CreateDetailSection(
    Document document,
    ElementId assemblyInstanceId,
    AssemblyDetailViewOrientation direction,
    ElementId viewTemplateId,
    bool isAssigned
)
Public Shared Function CreateDetailSection (
    document As Document,
    assemblyInstanceId As ElementId,
    direction As AssemblyDetailViewOrientation,
    viewTemplateId As ElementId,
    isAssigned As Boolean
) As ViewSection
public:
static ViewSection^ CreateDetailSection(
    Document^ document,
    ElementId^ assemblyInstanceId,
    AssemblyDetailViewOrientation direction,
    ElementId^ viewTemplateId,
    bool isAssigned
)
static member CreateDetailSection :
        document : Document *
        assemblyInstanceId : ElementId *
        direction : AssemblyDetailViewOrientation *
        viewTemplateId : ElementId *
        isAssigned : bool -> ViewSection

Parameters

document Document
The document to which the view will be added.
assemblyInstanceId ElementId
Id of the assembly instance that owns the new view.
direction AssemblyDetailViewOrientation
The direction for the new view.
viewTemplateId ElementId
Id of the view template that is used to create the view; if invalidElementId, the view will be created with the default settings.
isAssigned Boolean
If true, the template will be assigned; if false, the template will be applied.

Return Value

ViewSection
A new detail section assembly view.
Exceptions
Exception | Condition
ArgumentException | assemblyInstanceId is not an AssemblyInstance. -or- viewTemplateId is not a correct view template for the geom view.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
The detail section will cut through the center of the assembly instance's outline. The document must be regenerated before using the detail section.
See Also

Reference

AssemblyViewUtils Class
CreateDetailSection Overload


AssemblyViewUtils.CreateMaterialTakeoff Method

AssemblyViewUtilsCreateMaterialTakeoff Method

Overload List
Name | Description
CreateMaterialTakeoff(Document, ElementId) | Creates a new material takeoff multicategory schedule assembly view for the assembly instance.
CreateMaterialTakeoff(Document, ElementId, ElementId, Boolean) | Creates a new material takeoff multicategory schedule assembly view for the assembly instance.
Top
See Also

Reference

AssemblyViewUtils Class


AssemblyViewUtils.CreateMaterialTakeoff(Document, ElementId) Method

AssemblyViewUtilsCreateMaterialTakeoff(Document, ElementId) Method

Creates a new material takeoff multicategory schedule assembly view for the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ViewSchedule CreateMaterialTakeoff(
    Document document,
    ElementId assemblyInstanceId
)
Public Shared Function CreateMaterialTakeoff (
    document As Document,
    assemblyInstanceId As ElementId
) As ViewSchedule
public:
static ViewSchedule^ CreateMaterialTakeoff(
    Document^ document,
    ElementId^ assemblyInstanceId
)
static member CreateMaterialTakeoff :
        document : Document *
        assemblyInstanceId : ElementId -> ViewSchedule

Parameters

document Document
The document to which the view will be added.
assemblyInstanceId ElementId
Id of the assembly instance that owns the new view.

Return Value

ViewSchedule
A new material takeoff multicategory schedule assembly view.
Exceptions
Exception | Condition
ArgumentException | assemblyInstanceId is not an AssemblyInstance.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
The material takeoff schedule will be preloaded with fields "Material: Name" and "Material: Volume". The document must be regenerated before using the schedule.
See Also

Reference

AssemblyViewUtils Class
CreateMaterialTakeoff Overload


AssemblyViewUtils.CreateMaterialTakeoff(Document, ElementId, ElementId, Boolean) Method

AssemblyViewUtilsCreateMaterialTakeoff(Document, ElementId, ElementId, Boolean) Method

Creates a new material takeoff multicategory schedule assembly view for the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ViewSchedule CreateMaterialTakeoff(
    Document document,
    ElementId assemblyInstanceId,
    ElementId viewTemplateId,
    bool isAssigned
)
Public Shared Function CreateMaterialTakeoff (
    document As Document,
    assemblyInstanceId As ElementId,
    viewTemplateId As ElementId,
    isAssigned As Boolean
) As ViewSchedule
public:
static ViewSchedule^ CreateMaterialTakeoff(
    Document^ document,
    ElementId^ assemblyInstanceId,
    ElementId^ viewTemplateId,
    bool isAssigned
)
static member CreateMaterialTakeoff :
        document : Document *
        assemblyInstanceId : ElementId *
        viewTemplateId : ElementId *
        isAssigned : bool -> ViewSchedule

Parameters

document Document
The document to which the view will be added.
assemblyInstanceId ElementId
Id of the assembly instance that owns the new view.
viewTemplateId ElementId
Id of the view template that is used to create the view; if invalidElementId, the view will be created with the default settings.
isAssigned Boolean
If true, the template will be assigned, if false, the template will be applied.

Return Value

ViewSchedule
A new material takeoff multicategory schedule assembly view.
Exceptions
Exception | Condition
ArgumentException | assemblyInstanceId is not an AssemblyInstance. -or- viewTemplateId is not a correct view template for the schedule view.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
The material takeoff schedule will be preloaded with fields "Material: Name" and "Material: Volume". The document must be regenerated before using the schedule.
See Also

Reference

AssemblyViewUtils Class
CreateMaterialTakeoff Overload


AssemblyViewUtils.CreatePartList Method

AssemblyViewUtilsCreatePartList Method

Overload List
Name | Description
CreatePartList(Document, ElementId) | Creates a new part list multicategory schedule assembly view for the assembly instance.
CreatePartList(Document, ElementId, ElementId, Boolean) | Creates a new part list multicategory schedule assembly view for the assembly instance.
Top
See Also

Reference

AssemblyViewUtils Class


AssemblyViewUtils.CreatePartList(Document, ElementId) Method

AssemblyViewUtilsCreatePartList(Document, ElementId) Method

Creates a new part list multicategory schedule assembly view for the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ViewSchedule CreatePartList(
    Document document,
    ElementId assemblyInstanceId
)
Public Shared Function CreatePartList (
    document As Document,
    assemblyInstanceId As ElementId
) As ViewSchedule
public:
static ViewSchedule^ CreatePartList(
    Document^ document,
    ElementId^ assemblyInstanceId
)
static member CreatePartList :
        document : Document *
        assemblyInstanceId : ElementId -> ViewSchedule

Parameters

document Document
The document to which the view will be added.
assemblyInstanceId ElementId
Id of the assembly instance that owns the new view.

Return Value

ViewSchedule
A new part list multicategory schedule assembly view.
Exceptions
Exception | Condition
ArgumentException | assemblyInstanceId is not an AssemblyInstance.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
The new part list schedule will be preloaded with fields "Category", "Family and Type" and "Count". The document must be regenerated before using the schedule.
See Also

Reference

AssemblyViewUtils Class
CreatePartList Overload


AssemblyViewUtils.CreatePartList(Document, ElementId, ElementId, Boolean) Method

AssemblyViewUtilsCreatePartList(Document, ElementId, ElementId, Boolean) Method

Creates a new part list multicategory schedule assembly view for the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ViewSchedule CreatePartList(
    Document document,
    ElementId assemblyInstanceId,
    ElementId viewTemplateId,
    bool isAssigned
)
Public Shared Function CreatePartList (
    document As Document,
    assemblyInstanceId As ElementId,
    viewTemplateId As ElementId,
    isAssigned As Boolean
) As ViewSchedule
public:
static ViewSchedule^ CreatePartList(
    Document^ document,
    ElementId^ assemblyInstanceId,
    ElementId^ viewTemplateId,
    bool isAssigned
)
static member CreatePartList :
        document : Document *
        assemblyInstanceId : ElementId *
        viewTemplateId : ElementId *
        isAssigned : bool -> ViewSchedule

Parameters

document Document
The document to which the view will be added.
assemblyInstanceId ElementId
Id of the assembly instance that owns the new view.
viewTemplateId ElementId
Id of the view template that is used to create the view; if invalidElementId, the view will be created with the default settings.
isAssigned Boolean
If true, the template will be assigned, if false, the template will be applied.

Return Value

ViewSchedule
A new part list multicategory schedule assembly view.
Exceptions
Exception | Condition
ArgumentException | assemblyInstanceId is not an AssemblyInstance. -or- viewTemplateId is not a correct view template for the schedule view.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
The new part list schedule will be preloaded with fields "Category", "Family and Type" and "Count". The document must be regenerated before using the schedule.
See Also

Reference

AssemblyViewUtils Class
CreatePartList Overload


AssemblyViewUtils.CreateSheet Method

AssemblyViewUtilsCreateSheet Method

Creates a new sheet assembly view for the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ViewSheet CreateSheet(
    Document document,
    ElementId assemblyInstanceId,
    ElementId titleBlockId
)
Public Shared Function CreateSheet (
    document As Document,
    assemblyInstanceId As ElementId,
    titleBlockId As ElementId
) As ViewSheet
public:
static ViewSheet^ CreateSheet(
    Document^ document,
    ElementId^ assemblyInstanceId,
    ElementId^ titleBlockId
)
static member CreateSheet :
        document : Document *
        assemblyInstanceId : ElementId *
        titleBlockId : ElementId -> ViewSheet

Parameters

document Document
The document to which the view will be added.
assemblyInstanceId ElementId
Id of the assembly instance that owns the new view.
titleBlockId ElementId
Id of the titleblock family to use. For no titleblock, pass invalidElementId.

Return Value

ViewSheet
A new sheet assembly view.
Exceptions
Exception | Condition
ArgumentException | assemblyInstanceId is not an AssemblyInstance. -or- titleBlockId is not a TitleBlock.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
The document must be regenerated before using the sheet.
See Also

Reference

AssemblyViewUtils Class


AssemblyViewUtils.CreateSingleCategorySchedule Method

AssemblyViewUtilsCreateSingleCategorySchedule Method

Overload List
Name | Description
CreateSingleCategorySchedule(Document, ElementId, ElementId) | Creates a new single-category schedule assembly view for the assembly instance.
CreateSingleCategorySchedule(Document, ElementId, ElementId, ElementId, Boolean) | Creates a new single-category schedule assembly view for the assembly instance.
Top
See Also

Reference

AssemblyViewUtils Class


AssemblyViewUtils.CreateSingleCategorySchedule(Document, ElementId, ElementId) Method

AssemblyViewUtilsCreateSingleCategorySchedule(Document, ElementId, ElementId) Method

Creates a new single-category schedule assembly view for the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ViewSchedule CreateSingleCategorySchedule(
    Document document,
    ElementId assemblyInstanceId,
    ElementId scheduleCategoryId
)
Public Shared Function CreateSingleCategorySchedule (
    document As Document,
    assemblyInstanceId As ElementId,
    scheduleCategoryId As ElementId
) As ViewSchedule
public:
static ViewSchedule^ CreateSingleCategorySchedule(
    Document^ document,
    ElementId^ assemblyInstanceId,
    ElementId^ scheduleCategoryId
)
static member CreateSingleCategorySchedule :
        document : Document *
        assemblyInstanceId : ElementId *
        scheduleCategoryId : ElementId -> ViewSchedule

Parameters

document Document
The document to which the view will be added.
assemblyInstanceId ElementId
Id of the assembly instance that owns the new view.
scheduleCategoryId ElementId
Id of the category for which the schedule will be created. Use ViewSchedule.IsValidCategoryForSchedule() to check if a category can be scheduled.

Return Value

ViewSchedule
A new single-category schedule assembly view.
Exceptions
Exception | Condition
ArgumentException | assemblyInstanceId is not an AssemblyInstance. -or- scheduleCategoryId is not a valid category for a regular schedule.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
The new single-category schedule will be preloaded with fields "Family and Type" and "Count". The schedule will be empty if there are no elements of the specified category in the assembly instance. The document must be regenerated before using the schedule.
See Also

Reference

AssemblyViewUtils Class
CreateSingleCategorySchedule Overload


AssemblyViewUtils.CreateSingleCategorySchedule(Document, ElementId, ElementId, ElementId, Boolean) Method

AssemblyViewUtilsCreateSingleCategorySchedule(Document, ElementId, ElementId, ElementId, Boolean) Method

Creates a new single-category schedule assembly view for the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ViewSchedule CreateSingleCategorySchedule(
    Document document,
    ElementId assemblyInstanceId,
    ElementId scheduleCategoryId,
    ElementId viewTemplateId,
    bool isAssigned
)
Public Shared Function CreateSingleCategorySchedule (
    document As Document,
    assemblyInstanceId As ElementId,
    scheduleCategoryId As ElementId,
    viewTemplateId As ElementId,
    isAssigned As Boolean
) As ViewSchedule
public:
static ViewSchedule^ CreateSingleCategorySchedule(
    Document^ document,
    ElementId^ assemblyInstanceId,
    ElementId^ scheduleCategoryId,
    ElementId^ viewTemplateId,
    bool isAssigned
)
static member CreateSingleCategorySchedule :
        document : Document *
        assemblyInstanceId : ElementId *
        scheduleCategoryId : ElementId *
        viewTemplateId : ElementId *
        isAssigned : bool -> ViewSchedule

Parameters

document Document
The document to which the view will be added.
assemblyInstanceId ElementId
Id of the assembly instance that owns the new view.
scheduleCategoryId ElementId
Id of the category for which the schedule will be created. Use ViewSchedule.IsValidCategoryForSchedule() to check if a category can be scheduled.
viewTemplateId ElementId
Id of the view template that is used to create the view; if invalidElementId, the view will be created with the default settings.
isAssigned Boolean
If true, the template will be assigned, if false, the template will be applied.

Return Value

ViewSchedule
A new single-category schedule assembly view.
Exceptions
Exception | Condition
ArgumentException | assemblyInstanceId is not an AssemblyInstance. -or- scheduleCategoryId is not a valid category for a regular schedule. -or- viewTemplateId is not a correct view template for the schedule view.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
The new single-category schedule will be preloaded with fields "Family and Type" and "Count". The schedule will be empty if there are no elements of the specified category in the assembly instance. The document must be regenerated before using the schedule.
See Also

Reference

AssemblyViewUtils Class
CreateSingleCategorySchedule Overload


AttachmentType Enumeration

Enum determining whether a link is an attachment or an overlay

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum AttachmentType
Public Enumeration AttachmentType
public enum class AttachmentType
type AttachmentType
Members
Member name | Value | Description
Overlay | 2 | The link is an overlay, only meant to be seen in this file. If the host is linked into another file, the link will not be brought along.
Attachment | 3 | The link is an attachment. If the host file is linked into another file, the link will also be brought along.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


AutomaticConnectionBehaviorType Enumeration

Defines behavior of connector with respect to automatic creation of connections

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum AutomaticConnectionBehaviorType
Public Enumeration AutomaticConnectionBehaviorType
public enum class AutomaticConnectionBehaviorType
type AutomaticConnectionBehaviorType
Members
Member name | Value | Description
Exclude | 0 | Connector does not participate in automatic connection
Active | 1 | Connector is actively looking to be connected
Forced | 2 | Connector must establish a connection
Accepting | 3 | Connector accepts more automatic connections if needed, but
Full | 4 | Connector may participate in automatic connection, but at the moment it is fully connected
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


AXMImportOptions Class

The import options used to import AXM format files.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBaseImportOptions
Autodesk.Revit.DBAXMImportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AXMImportOptions : BaseImportOptions
Public Class AXMImportOptions
    Inherits BaseImportOptions
public ref class AXMImportOptions : public BaseImportOptions
type AXMImportOptions =
    class
        inherit BaseImportOptions
    end

The AXMImportOptions type exposes the following members.

Constructors
 | Name | Description
Public method | AXMImportOptions | Constructs a new instance of AXMImportOptions with default values of all properties.
Public method | AXMImportOptions(AXMImportOptions) | Constructs a new instance of AXMImportOptions as a copy of the provided import options.
Top
Properties
 | Name | Description
Public property | AutoCorrectAlmostVHLines | Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines. (Inherited from BaseImportOptions)
Public property | ColorMode | Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors. (Inherited from BaseImportOptions)
Public property | CustomScale | Scaling the import. If this is defined and a valid value (> 0.0), it takes priority over units. (Inherited from BaseImportOptions)
Public property | ImportLevels | Indicate if levels are to be imported. False by default.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BaseImportOptions)
Public property | OrientToView | Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false) (Inherited from BaseImportOptions)
Public property | Placement | Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates. (Inherited from BaseImportOptions)
Public property | ReferencePoint | The 3D point in the document where the imported instance will be inserted. If not explicitly set, the instance will be inserted at the document origin. (Inherited from BaseImportOptions)
Public property | ThisViewOnly | Imports drawings into the view that was passed into the import method. This option is not available in 3D views. (Inherited from BaseImportOptions)
Public property | Unit | The unit of measure for imported geometry. (Inherited from BaseImportOptions)
Public property | VisibleLayersOnly | Only import the visible layers. (Inherited from BaseImportOptions)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from BaseImportOptions)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetDefaultLengthUnit | Get the default length unit used for importing unitless files. (Inherited from BaseImportOptions)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLayerSelection | Get all set layers name which user want to import into Revit. (Inherited from BaseImportOptions)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetDefaultLengthUnit | Set the default length unit used for importing unitless files. (Inherited from BaseImportOptions)
Public method | SetLayerSelection | Set the layers name which user want to import into Revit. (Inherited from BaseImportOptions)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


AXMImportOptions Constructor

Overload List
 | Name | Description
Public method | AXMImportOptions | Constructs a new instance of AXMImportOptions with default values of all properties.
Public method | AXMImportOptions(AXMImportOptions) | Constructs a new instance of AXMImportOptions as a copy of the provided import options.
Top
See Also

Reference

AXMImportOptions Class


AXMImportOptions Constructor

Constructs a new instance of AXMImportOptions with default values of all properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AXMImportOptions()
Public Sub New
public:
AXMImportOptions()
new : unit -> AXMImportOptions
See Also

Reference

AXMImportOptions Class
AXMImportOptions Overload


AXMImportOptions(AXMImportOptions) Constructor

Constructs a new instance of AXMImportOptions as a copy of the provided import options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AXMImportOptions(
    AXMImportOptions option
)
Public Sub New (
    option As AXMImportOptions
)
public:
AXMImportOptions(
    AXMImportOptions^ option
)
new :
        option : AXMImportOptions -> AXMImportOptions

Parameters

option AXMImportOptions
The AXM import options to be copied.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

AXMImportOptions Class
AXMImportOptions Overload


AXMImportOptions Properties

The AXMImportOptions type exposes the following members.

Properties
 | Name | Description
Public property | AutoCorrectAlmostVHLines | Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines. (Inherited from BaseImportOptions)
Public property | ColorMode | Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors. (Inherited from BaseImportOptions)
Public property | CustomScale | Scaling the import. If this is defined and a valid value (> 0.0), it takes priority over units. (Inherited from BaseImportOptions)
Public property | ImportLevels | Indicate if levels are to be imported. False by default.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BaseImportOptions)
Public property | OrientToView | Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false) (Inherited from BaseImportOptions)
Public property | Placement | Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates. (Inherited from BaseImportOptions)
Public property | ReferencePoint | The 3D point in the document where the imported instance will be inserted. If not explicitly set, the instance will be inserted at the document origin. (Inherited from BaseImportOptions)
Public property | ThisViewOnly | Imports drawings into the view that was passed into the import method. This option is not available in 3D views. (Inherited from BaseImportOptions)
Public property | Unit | The unit of measure for imported geometry. (Inherited from BaseImportOptions)
Public property | VisibleLayersOnly | Only import the visible layers. (Inherited from BaseImportOptions)
Top
See Also

Reference

AXMImportOptions Class


AXMImportOptions.ImportLevels Property

AXMImportOptionsImportLevels Property

Indicate if levels are to be imported. False by default.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ImportLevels { get; set; }
Public Property ImportLevels As Boolean
    Get
    Set
public:
property bool ImportLevels {
    bool get ();
    void set (bool value);
}
member ImportLevels : bool with get, set

Property Value

Boolean
See Also

Reference

AXMImportOptions Class


AXMImportOptions Methods

The AXMImportOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from BaseImportOptions)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetDefaultLengthUnit | Get the default length unit used for importing unitless files. (Inherited from BaseImportOptions)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLayerSelection | Get all set layers name which user want to import into Revit. (Inherited from BaseImportOptions)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetDefaultLengthUnit | Set the default length unit used for importing unitless files. (Inherited from BaseImportOptions)
Public method | SetLayerSelection | Set the layers name which user want to import into Revit. (Inherited from BaseImportOptions)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AXMImportOptions Class


BackClippingParam Enumeration

The allowed values for the VIEW_BACK_CLIPPING and VIEWER_BOUND_FAR_CLIPPING parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum BackClippingParam
Public Enumeration BackClippingParam
public enum class BackClippingParam
type BackClippingParam
Members
Member name | Value | Description
NoClip | 0 | No clip
ClipWithLine | 1 | Clip with line.
ClipNoLine | 2 | Clip without line.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


BackgroundImageFit Enumeration

Indicates the background image fit type in rendering settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum BackgroundImageFit
Public Enumeration BackgroundImageFit
public enum class BackgroundImageFit
type BackgroundImageFit
Members
Member name | Value | Description
None | 0 | No scale applied to the image; it will keep its original size.
Vertical | 41 | The image is proportionally resized so its height matches the view's height.
Horizontal | 42 | The image is proportionally resized so its width matches the view's width.
Stretch | 43 | The image is stretched in both directions so it matches the view's size.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


BackgroundSettings Class

Represents the rendering background settings.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBackgroundSettings
Autodesk.Revit.DBColorBackgroundSettings
Autodesk.Revit.DBGradientBackgroundSettings
Autodesk.Revit.DBImageBackgroundSettings
Autodesk.Revit.DBSkyBackgroundSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BackgroundSettings : IDisposable
Public Class BackgroundSettings
    Implements IDisposable
public ref class BackgroundSettings : IDisposable
type BackgroundSettings =
    class
        interface IDisposable
    end

The BackgroundSettings type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the BackgroundSettings
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


BackgroundSettings Properties

The BackgroundSettings type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

BackgroundSettings Class


BackgroundSettings.IsValidObject Property

BackgroundSettingsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

BackgroundSettings Class


BackgroundSettings Methods

The BackgroundSettings type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

BackgroundSettings Class


BackgroundSettings.Dispose Method

BackgroundSettingsDispose Method

Releases all resources used by the BackgroundSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

BackgroundSettings Class


BackgroundStyle Enumeration

Indicates the background style in rendering settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum BackgroundStyle
Public Enumeration BackgroundStyle
public enum class BackgroundStyle
type BackgroundStyle
Members
Member name | Value | Description
SkyNoClouds | 0 | Sky background without clouds.
SkyVeryFewClouds | 1 | Sky background with very few clouds.
SkyFewClouds | 2 | Sky background with few clouds.
SkyCloudy | 3 | Cloudy sky background.
SkyVeryCloudy | 4 | Very cloudy sky background.
Color | 5 | Color background.
Image | 6 | Image background.
Transparent | 7 | Transparent background
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


BarTypeDiameterOptions Class

This class stores the diameter information from the RebarBarType.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBarTypeDiameterOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BarTypeDiameterOptions : IDisposable
Public Class BarTypeDiameterOptions
    Implements IDisposable
public ref class BarTypeDiameterOptions : IDisposable
type BarTypeDiameterOptions =
    class
        interface IDisposable
    end

The BarTypeDiameterOptions type exposes the following members.

Constructors
 | Name | Description
Public method | BarTypeDiameterOptions | Constructs a new BarTypeDiameterOptions with default settings.
Public method | BarTypeDiameterOptions(RebarBarType) | Constructs a new BarTypeDiameterOptions copying the diameter information from the bar type.
Top
Properties
 | Name | Description
Public property | BarModelDiameter | Represents the bar model diameter of the RebarBarType.
Public property | BarNominalDiameter | Represents the bar nominal diameter of the RebarBarType.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | StandardBendDiameter | Represents the standard bar bend diameter of the RebarBarType.
Public property | StandardHookBendDiameter | Represents the standard hook bend diameter of the RebarBarType.
Public property | StirrupTieBendDiameter | Represents the stirrup/tie bar and hook bend diameter of the RebarBarType.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the BarTypeDiameterOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This class can be used to create a whole new set of diameter values for a RebarBarType. It can be used when copying the diameter information as a bulk of data from a RebarBarType to another. The new diameters can be set in the RebarBarType in the following way: 1. Create a BarTypeDiameterOptions object with the new diameters. 2. Set the new diameters in RebarBarType using [!:Autodesk::Revit::DB::Structure::RebarBarType::SetBarTypeDiameters(Autodesk::Revit::DB::BarTypeDiameterOptions ^diametersOpt)]. The method [!:Autodesk::Revit::DB::Structure::RebarBarType::SetBarTypeDiameters(Autodesk::Revit::DB::BarTypeDiameterOptions ^diametersOpt)] is responsible for diameters validation.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


BarTypeDiameterOptions Constructor

Overload List
 | Name | Description
Public method | BarTypeDiameterOptions | Constructs a new BarTypeDiameterOptions with default settings.
Public method | BarTypeDiameterOptions(RebarBarType) | Constructs a new BarTypeDiameterOptions copying the diameter information from the bar type.
Top
See Also

Reference

BarTypeDiameterOptions Class


BarTypeDiameterOptions Constructor

Constructs a new BarTypeDiameterOptions with default settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BarTypeDiameterOptions()
Public Sub New
public:
BarTypeDiameterOptions()
new : unit -> BarTypeDiameterOptions
See Also

Reference

BarTypeDiameterOptions Class
BarTypeDiameterOptions Overload


BarTypeDiameterOptions(RebarBarType) Constructor

Constructs a new BarTypeDiameterOptions copying the diameter information from the bar type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BarTypeDiameterOptions(
    RebarBarType barType
)
Public Sub New (
    barType As RebarBarType
)
public:
BarTypeDiameterOptions(
    RebarBarType^ barType
)
new :
        barType : RebarBarType -> BarTypeDiameterOptions

Parameters

barType RebarBarType
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

BarTypeDiameterOptions Class
BarTypeDiameterOptions Overload


BarTypeDiameterOptions Properties

The BarTypeDiameterOptions type exposes the following members.

Properties
 | Name | Description
Public property | BarModelDiameter | Represents the bar model diameter of the RebarBarType.
Public property | BarNominalDiameter | Represents the bar nominal diameter of the RebarBarType.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | StandardBendDiameter | Represents the standard bar bend diameter of the RebarBarType.
Public property | StandardHookBendDiameter | Represents the standard hook bend diameter of the RebarBarType.
Public property | StirrupTieBendDiameter | Represents the stirrup/tie bar and hook bend diameter of the RebarBarType.
Top
See Also

Reference

BarTypeDiameterOptions Class


BarTypeDiameterOptions.BarModelDiameter Property

BarTypeDiameterOptionsBarModelDiameter Property

Represents the bar model diameter of the RebarBarType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double BarModelDiameter { get; set; }
Public Property BarModelDiameter As Double
    Get
    Set
public:
property double BarModelDiameter {
    double get ();
    void set (double value);
}
member BarModelDiameter : float with get, set

Property Value

Double
See Also

Reference

BarTypeDiameterOptions Class


BarTypeDiameterOptions.BarNominalDiameter Property

BarTypeDiameterOptionsBarNominalDiameter Property

Represents the bar nominal diameter of the RebarBarType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double BarNominalDiameter { get; set; }
Public Property BarNominalDiameter As Double
    Get
    Set
public:
property double BarNominalDiameter {
    double get ();
    void set (double value);
}
member BarNominalDiameter : float with get, set

Property Value

Double
See Also

Reference

BarTypeDiameterOptions Class


BarTypeDiameterOptions.IsValidObject Property

BarTypeDiameterOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

BarTypeDiameterOptions Class


BarTypeDiameterOptions.StandardBendDiameter Property

BarTypeDiameterOptionsStandardBendDiameter Property

Represents the standard bar bend diameter of the RebarBarType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double StandardBendDiameter { get; set; }
Public Property StandardBendDiameter As Double
    Get
    Set
public:
property double StandardBendDiameter {
    double get ();
    void set (double value);
}
member StandardBendDiameter : float with get, set

Property Value

Double
See Also

Reference

BarTypeDiameterOptions Class


BarTypeDiameterOptions.StandardHookBendDiameter Property

BarTypeDiameterOptionsStandardHookBendDiameter Property

Represents the standard hook bend diameter of the RebarBarType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double StandardHookBendDiameter { get; set; }
Public Property StandardHookBendDiameter As Double
    Get
    Set
public:
property double StandardHookBendDiameter {
    double get ();
    void set (double value);
}
member StandardHookBendDiameter : float with get, set

Property Value

Double
See Also

Reference

BarTypeDiameterOptions Class


BarTypeDiameterOptions.StirrupTieBendDiameter Property

BarTypeDiameterOptionsStirrupTieBendDiameter Property

Represents the stirrup/tie bar and hook bend diameter of the RebarBarType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double StirrupTieBendDiameter { get; set; }
Public Property StirrupTieBendDiameter As Double
    Get
    Set
public:
property double StirrupTieBendDiameter {
    double get ();
    void set (double value);
}
member StirrupTieBendDiameter : float with get, set

Property Value

Double
See Also

Reference

BarTypeDiameterOptions Class


BarTypeDiameterOptions Methods

The BarTypeDiameterOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

BarTypeDiameterOptions Class


BarTypeDiameterOptions.Dispose Method

BarTypeDiameterOptionsDispose Method

Releases all resources used by the BarTypeDiameterOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

BarTypeDiameterOptions Class


BaseArray Class

An abstract base class that represents an array within the Revit project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBBaseArray
Autodesk.Revit.DBLinearArray
Autodesk.Revit.DBRadialArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class BaseArray : Element
Public MustInherit Class BaseArray
    Inherits Element
public ref class BaseArray abstract : public Element
[<AbstractClassAttribute>]
type BaseArray =
    class
        inherit Element
    end

The BaseArray type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | Label | The family parameter label of the BaseArray.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Get and Set the Name property (Overrides ElementName)
Public property | NumMembers | Retrieves or changes the number of the arrayed members.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetCopiedMemberIds | Retrieves the copied member Ids of the Array.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetOriginalMemberIds | Retrieves the original member Ids of the Array.
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


BaseArray Properties

The BaseArray type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | Label | The family parameter label of the BaseArray.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Get and Set the Name property (Overrides ElementName)
Public property | NumMembers | Retrieves or changes the number of the arrayed members.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

BaseArray Class


BaseArray.Label Property

BaseArrayLabel Property

The family parameter label of the BaseArray.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyParameter Label { get; set; }
Public Property Label As FamilyParameter
    Get
    Set
public:
property FamilyParameter^ Label {
    FamilyParameter^ get ();
    void set (FamilyParameter^ value);
}
member Label : FamilyParameter with get, set

Property Value

FamilyParameter
Exceptions
Exception | Condition
ArgumentException | Thrown when the family parameter's ParameterType is not ParameterType.Integer.
InvalidOperationException | Thrown when trying to label the BaseArray out of family document.
Remarks
The label associates the number of members of the array with a family parameter. A BaseArray only can be labeled in a family document and only can be labeled to a integer FamilyParameter. To unbind the family parameter, set this property to .
See Also

Reference

BaseArray Class


BaseArray.Name Property

BaseArrayName Property

Get and Set the Name property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string Name { set; }
Public Overrides WriteOnly Property Name As String
    Set
public:
virtual property String^ Name {
    void set (String^ value) override;
}
abstract Name : string with set
override Name : string with set

Property Value

String
Remarks
The method set is override to forbid the user to change the Name. When the user tries to call the method set for BaseArray object, an InvalidOperationException will be thrown.
See Also

Reference

BaseArray Class


BaseArray.NumMembers Property

BaseArrayNumMembers Property

Retrieves or changes the number of the arrayed members.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract int NumMembers { get; set; }
Public MustOverride Property NumMembers As Integer
    Get
    Set
public:
virtual property int NumMembers {
    int get () abstract;
    void set (int value) abstract;
}
abstract NumMembers : int with get, set

Property Value

Int32
Remarks
In projects, the minimum value is 2 for linear arrays and 3 for radial arrays. In families, the minimum value is 0 for all arrays. The maximum value is 200.
See Also

Reference

BaseArray Class


BaseArray Methods

The BaseArray type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetCopiedMemberIds | Retrieves the copied member Ids of the Array.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetOriginalMemberIds | Retrieves the original member Ids of the Array.
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

BaseArray Class


BaseArray.GetCopiedMemberIds Method

BaseArrayGetCopiedMemberIds Method

Retrieves the copied member Ids of the Array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract ICollection<ElementId> GetCopiedMemberIds()
Public MustOverride Function GetCopiedMemberIds As ICollection(Of ElementId)
public:
virtual ICollection<ElementId^>^ GetCopiedMemberIds() abstract
abstract GetCopiedMemberIds : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
The copied member Ids of the Array
See Also

Reference

BaseArray Class


BaseArray.GetOriginalMemberIds Method

BaseArrayGetOriginalMemberIds Method

Retrieves the original member Ids of the Array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract ICollection<ElementId> GetOriginalMemberIds()
Public MustOverride Function GetOriginalMemberIds As ICollection(Of ElementId)
public:
virtual ICollection<ElementId^>^ GetOriginalMemberIds() abstract
abstract GetOriginalMemberIds : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
The original member Ids of the Array
See Also

Reference

BaseArray Class


BaseExportOptions Class

The base class for options used to export DWG, DXF and DGN format files.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBaseExportOptions
Autodesk.Revit.DBACADExportOptions
Autodesk.Revit.DBDGNExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BaseExportOptions : IDisposable
Public Class BaseExportOptions
    Implements IDisposable
public ref class BaseExportOptions : IDisposable
type BaseExportOptions =
    class
        interface IDisposable
    end

The BaseExportOptions type exposes the following members.

Properties
 | Name | Description
Public property | Colors | Export color mode. Default value is ExportColorMode.IndexColors.
Public property | HatchPatternsFileName | Custom hatch patterns (pat) file name.
Public property | HideReferencePlane | Whether or not to hide reference planes. Default value is false.
Public property | HideScopeBox | Whether or not to hide the scope box. Default value is false.
Public property | HideUnreferenceViewTags | Whether or not to hide unreference view tags. Default value is false.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LayerMapping | Name of a layer settings standard or filename (with custom layer settings). Valid standards are: DGNV7 (only for DGN), AIA, CP83, BS1192, and ISO13567. default value is "" (empty) which means if no value is set, if no value is set, Revit will use a default value according to the localization.
Public property | PreserveCoincidentLines | Whether or not to preserve coincident lines. Default value is false.
Public property | PropOverrides | How to export overridden object styles. Default value is PropOverrideMode.ByEntity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the BaseExportOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetExportFontTable | Gets font table.
Public method | GetExportLayerTable | Gets the layer table.
Public method | GetExportLinetypeTable | Gets a copy of the line type table.
Public method | GetExportPatternTable | Gets a copy of the pattern table.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
 | GetPredefinedSetupNames | Returns a list of names of predefined setups of export options.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetExportFontTable | Sets font table to option.
Public method | SetExportLayerTable | Sets layer table back to option
Public method | SetExportLinetypeTable | Sets the line type table to use during export.
Public method | SetExportPatternTable | Sets the pattern table to use during export.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


BaseExportOptions Properties

The BaseExportOptions type exposes the following members.

Properties
 | Name | Description
Public property | Colors | Export color mode. Default value is ExportColorMode.IndexColors.
Public property | HatchPatternsFileName | Custom hatch patterns (pat) file name.
Public property | HideReferencePlane | Whether or not to hide reference planes. Default value is false.
Public property | HideScopeBox | Whether or not to hide the scope box. Default value is false.
Public property | HideUnreferenceViewTags | Whether or not to hide unreference view tags. Default value is false.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LayerMapping | Name of a layer settings standard or filename (with custom layer settings). Valid standards are: DGNV7 (only for DGN), AIA, CP83, BS1192, and ISO13567. default value is "" (empty) which means if no value is set, if no value is set, Revit will use a default value according to the localization.
Public property | PreserveCoincidentLines | Whether or not to preserve coincident lines. Default value is false.
Public property | PropOverrides | How to export overridden object styles. Default value is PropOverrideMode.ByEntity.
Top
See Also

Reference

BaseExportOptions Class


BaseExportOptions.Colors Property

BaseExportOptionsColors Property

Export color mode. Default value is ExportColorMode.IndexColors.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportColorMode Colors { get; set; }
Public Property Colors As ExportColorMode
    Get
    Set
public:
property ExportColorMode Colors {
    ExportColorMode get ();
    void set (ExportColorMode value);
}
member Colors : ExportColorMode with get, set

Property Value

ExportColorMode
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

BaseExportOptions Class


BaseExportOptions.HatchPatternsFileName Property

BaseExportOptionsHatchPatternsFileName Property

Custom hatch patterns (pat) file name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string HatchPatternsFileName { get; set; }
Public Property HatchPatternsFileName As String
    Get
    Set
public:
property String^ HatchPatternsFileName {
    String^ get ();
    void set (String^ value);
}
member HatchPatternsFileName : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

BaseExportOptions Class


BaseExportOptions.HideReferencePlane Property

BaseExportOptionsHideReferencePlane Property

Whether or not to hide reference planes. Default value is false.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HideReferencePlane { get; set; }
Public Property HideReferencePlane As Boolean
    Get
    Set
public:
property bool HideReferencePlane {
    bool get ();
    void set (bool value);
}
member HideReferencePlane : bool with get, set

Property Value

Boolean
See Also

Reference

BaseExportOptions Class


BaseExportOptions.HideScopeBox Property

BaseExportOptionsHideScopeBox Property

Whether or not to hide the scope box. Default value is false.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HideScopeBox { get; set; }
Public Property HideScopeBox As Boolean
    Get
    Set
public:
property bool HideScopeBox {
    bool get ();
    void set (bool value);
}
member HideScopeBox : bool with get, set

Property Value

Boolean
See Also

Reference

BaseExportOptions Class


BaseExportOptions.HideUnreferenceViewTags Property

BaseExportOptionsHideUnreferenceViewTags Property

Whether or not to hide unreference view tags. Default value is false.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HideUnreferenceViewTags { get; set; }
Public Property HideUnreferenceViewTags As Boolean
    Get
    Set
public:
property bool HideUnreferenceViewTags {
    bool get ();
    void set (bool value);
}
member HideUnreferenceViewTags : bool with get, set

Property Value

Boolean
See Also

Reference

BaseExportOptions Class


BaseExportOptions.IsValidObject Property

BaseExportOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

BaseExportOptions Class


BaseExportOptions.LayerMapping Property

BaseExportOptionsLayerMapping Property

Name of a layer settings standard or filename (with custom layer settings). Valid standards are: DGNV7 (only for DGN), AIA, CP83, BS1192, and ISO13567. default value is "" (empty) which means if no value is set, if no value is set, Revit will use a default value according to the localization.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string LayerMapping { get; set; }
Public Property LayerMapping As String
    Get
    Set
public:
property String^ LayerMapping {
    String^ get ();
    void set (String^ value);
}
member LayerMapping : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

BaseExportOptions Class


BaseExportOptions.PreserveCoincidentLines Property

BaseExportOptionsPreserveCoincidentLines Property

Whether or not to preserve coincident lines. Default value is false.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool PreserveCoincidentLines { get; set; }
Public Property PreserveCoincidentLines As Boolean
    Get
    Set
public:
property bool PreserveCoincidentLines {
    bool get ();
    void set (bool value);
}
member PreserveCoincidentLines : bool with get, set

Property Value

Boolean
See Also

Reference

BaseExportOptions Class


BaseExportOptions.PropOverrides Property

BaseExportOptionsPropOverrides Property

How to export overridden object styles. Default value is PropOverrideMode.ByEntity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PropOverrideMode PropOverrides { get; set; }
Public Property PropOverrides As PropOverrideMode
    Get
    Set
public:
property PropOverrideMode PropOverrides {
    PropOverrideMode get ();
    void set (PropOverrideMode value);
}
member PropOverrides : PropOverrideMode with get, set

Property Value

PropOverrideMode
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

BaseExportOptions Class


BaseExportOptions Methods

The BaseExportOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetExportFontTable | Gets font table.
Public method | GetExportLayerTable | Gets the layer table.
Public method | GetExportLinetypeTable | Gets a copy of the line type table.
Public method | GetExportPatternTable | Gets a copy of the pattern table.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
 | GetPredefinedSetupNames | Returns a list of names of predefined setups of export options.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetExportFontTable | Sets font table to option.
Public method | SetExportLayerTable | Sets layer table back to option
Public method | SetExportLinetypeTable | Sets the line type table to use during export.
Public method | SetExportPatternTable | Sets the pattern table to use during export.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

BaseExportOptions Class


BaseExportOptions.Dispose Method

BaseExportOptionsDispose Method

Releases all resources used by the BaseExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

BaseExportOptions Class


BaseExportOptions.GetExportFontTable Method

BaseExportOptionsGetExportFontTable Method

Gets font table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportFontTable GetExportFontTable()
Public Function GetExportFontTable As ExportFontTable
public:
ExportFontTable^ GetExportFontTable()
member GetExportFontTable : unit -> ExportFontTable

Return Value

ExportFontTable
See Also

Reference

BaseExportOptions Class


BaseExportOptions.GetExportLayerTable Method

BaseExportOptionsGetExportLayerTable Method

Gets the layer table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportLayerTable GetExportLayerTable()
Public Function GetExportLayerTable As ExportLayerTable
public:
ExportLayerTable^ GetExportLayerTable()
member GetExportLayerTable : unit -> ExportLayerTable

Return Value

ExportLayerTable
The layer table.
See Also

Reference

BaseExportOptions Class


BaseExportOptions.GetExportLinetypeTable Method

BaseExportOptionsGetExportLinetypeTable Method

Gets a copy of the line type table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportLinetypeTable GetExportLinetypeTable()
Public Function GetExportLinetypeTable As ExportLinetypeTable
public:
ExportLinetypeTable^ GetExportLinetypeTable()
member GetExportLinetypeTable : unit -> ExportLinetypeTable

Return Value

ExportLinetypeTable
The line type table.
See Also

Reference

BaseExportOptions Class


BaseExportOptions.GetExportPatternTable Method

BaseExportOptionsGetExportPatternTable Method

Gets a copy of the pattern table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportPatternTable GetExportPatternTable()
Public Function GetExportPatternTable As ExportPatternTable
public:
ExportPatternTable^ GetExportPatternTable()
member GetExportPatternTable : unit -> ExportPatternTable

Return Value

ExportPatternTable
The pattern table.
See Also

Reference

BaseExportOptions Class


BaseExportOptions.GetPredefinedSetupNames Method

BaseExportOptionsGetPredefinedSetupNames Method

Returns a list of names of predefined setups of export options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<string> GetPredefinedSetupNames(
    Document document
)
Public Shared Function GetPredefinedSetupNames (
    document As Document
) As IList(Of String)
public:
static IList<String^>^ GetPredefinedSetupNames(
    Document^ document
)
static member GetPredefinedSetupNames :
        document : Document -> IList<string>

Parameters

document Document
A Revit document to retrieve names from.

Return Value

IList String
An array of strings representing names of predefined setups.
Exceptions
Exception | Condition
ArgumentException | document is not a project document.
ArgumentNullException | A non-optional argument was null
Remarks
The predefined setups may be used for export to both DWG and DXF formats. To get predefined options in the desired format use the static method getPredefinedOptions defined in DWGExportOptions or DXFExportOptions respectively.
See Also

Reference

BaseExportOptions Class


BaseExportOptions.SetExportFontTable Method

BaseExportOptionsSetExportFontTable Method

Sets font table to option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetExportFontTable(
    ExportFontTable fontTable
)
Public Sub SetExportFontTable (
    fontTable As ExportFontTable
)
public:
void SetExportFontTable(
    ExportFontTable^ fontTable
)
member SetExportFontTable :
        fontTable : ExportFontTable -> unit

Parameters

fontTable ExportFontTable
The font table to be set.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

BaseExportOptions Class


BaseExportOptions.SetExportLayerTable Method

BaseExportOptionsSetExportLayerTable Method

Sets layer table back to option

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetExportLayerTable(
    ExportLayerTable layerTable
)
Public Sub SetExportLayerTable (
    layerTable As ExportLayerTable
)
public:
void SetExportLayerTable(
    ExportLayerTable^ layerTable
)
member SetExportLayerTable :
        layerTable : ExportLayerTable -> unit

Parameters

layerTable ExportLayerTable
The layer table to be set
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

BaseExportOptions Class


BaseExportOptions.SetExportLinetypeTable Method

BaseExportOptionsSetExportLinetypeTable Method

Sets the line type table to use during export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetExportLinetypeTable(
    ExportLinetypeTable linetypeTable
)
Public Sub SetExportLinetypeTable (
    linetypeTable As ExportLinetypeTable
)
public:
void SetExportLinetypeTable(
    ExportLinetypeTable^ linetypeTable
)
member SetExportLinetypeTable :
        linetypeTable : ExportLinetypeTable -> unit

Parameters

linetypeTable ExportLinetypeTable
The line type table to be set.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

BaseExportOptions Class


BaseExportOptions.SetExportPatternTable Method

BaseExportOptionsSetExportPatternTable Method

Sets the pattern table to use during export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetExportPatternTable(
    ExportPatternTable patternTable
)
Public Sub SetExportPatternTable (
    patternTable As ExportPatternTable
)
public:
void SetExportPatternTable(
    ExportPatternTable^ patternTable
)
member SetExportPatternTable :
        patternTable : ExportPatternTable -> unit

Parameters

patternTable ExportPatternTable
The pattern table to be set.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

BaseExportOptions Class


BaseImportOptions Class

A base class containing import options used during import of several formats.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBaseImportOptions
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BaseImportOptions : IDisposable
Public Class BaseImportOptions
    Implements IDisposable
public ref class BaseImportOptions : IDisposable
type BaseImportOptions =
    class
        interface IDisposable
    end

The BaseImportOptions type exposes the following members.

Properties
 | Name | Description
Public property | AutoCorrectAlmostVHLines | Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines.
Public property | ColorMode | Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors.
Public property | CustomScale | Scaling the import. If this is defined and a valid value (> 0.0), it takes priority over units.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OrientToView | Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false)
Public property | Placement | Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates.
Public property | ReferencePoint | The 3D point in the document where the imported instance will be inserted. If not explicitly set, the instance will be inserted at the document origin.
Public property | ThisViewOnly | Imports drawings into the view that was passed into the import method. This option is not available in 3D views.
Public property | Unit | The unit of measure for imported geometry.
Public property | VisibleLayersOnly | Only import the visible layers.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the BaseImportOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetDefaultLengthUnit | Get the default length unit used for importing unitless files.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLayerSelection | Get all set layers name which user want to import into Revit.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetDefaultLengthUnit | Set the default length unit used for importing unitless files.
Public method | SetLayerSelection | Set the layers name which user want to import into Revit.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBaseImportOptions
Autodesk.Revit.DBAXMImportOptions
Autodesk.Revit.DBDGNImportOptions
Autodesk.Revit.DBDWGImportOptions
Autodesk.Revit.DBImportOptions3DM
Autodesk.Revit.DBOBJImportOptions
Autodesk.Revit.DBSATImportOptions
Autodesk.Revit.DBSKPImportOptions
Autodesk.Revit.DBSTEPImportOptions
Autodesk.Revit.DBSTLImportOptions


BaseImportOptions Properties

The BaseImportOptions type exposes the following members.

Properties
 | Name | Description
Public property | AutoCorrectAlmostVHLines | Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines.
Public property | ColorMode | Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors.
Public property | CustomScale | Scaling the import. If this is defined and a valid value (> 0.0), it takes priority over units.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OrientToView | Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false)
Public property | Placement | Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates.
Public property | ReferencePoint | The 3D point in the document where the imported instance will be inserted. If not explicitly set, the instance will be inserted at the document origin.
Public property | ThisViewOnly | Imports drawings into the view that was passed into the import method. This option is not available in 3D views.
Public property | Unit | The unit of measure for imported geometry.
Public property | VisibleLayersOnly | Only import the visible layers.
Top
See Also

Reference

BaseImportOptions Class


BaseImportOptions.AutoCorrectAlmostVHLines Property

BaseImportOptionsAutoCorrectAlmostVHLines Property

Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AutoCorrectAlmostVHLines { get; set; }
Public Property AutoCorrectAlmostVHLines As Boolean
    Get
    Set
public:
property bool AutoCorrectAlmostVHLines {
    bool get ();
    void set (bool value);
}
member AutoCorrectAlmostVHLines : bool with get, set

Property Value

Boolean
See Also

Reference

BaseImportOptions Class


BaseImportOptions.ColorMode Property

BaseImportOptionsColorMode Property

Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImportColorMode ColorMode { get; set; }
Public Property ColorMode As ImportColorMode
    Get
    Set
public:
property ImportColorMode ColorMode {
    ImportColorMode get ();
    void set (ImportColorMode value);
}
member ColorMode : ImportColorMode with get, set

Property Value

ImportColorMode
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

BaseImportOptions Class


BaseImportOptions.CustomScale Property

BaseImportOptionsCustomScale Property

Scaling the import. If this is defined and a valid value (> 0.0), it takes priority over units.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double CustomScale { get; set; }
Public Property CustomScale As Double
    Get
    Set
public:
property double CustomScale {
    double get ();
    void set (double value);
}
member CustomScale : float with get, set

Property Value

Double
See Also

Reference

BaseImportOptions Class


BaseImportOptions.IsValidObject Property

BaseImportOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

BaseImportOptions Class


BaseImportOptions.OrientToView Property

BaseImportOptionsOrientToView Property

Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool OrientToView { get; set; }
Public Property OrientToView As Boolean
    Get
    Set
public:
property bool OrientToView {
    bool get ();
    void set (bool value);
}
member OrientToView : bool with get, set

Property Value

Boolean
See Also

Reference

BaseImportOptions Class


BaseImportOptions.Placement Property

BaseImportOptionsPlacement Property

Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImportPlacement Placement { get; set; }
Public Property Placement As ImportPlacement
    Get
    Set
public:
property ImportPlacement Placement {
    ImportPlacement get ();
    void set (ImportPlacement value);
}
member Placement : ImportPlacement with get, set

Property Value

ImportPlacement
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

BaseImportOptions Class


BaseImportOptions.ReferencePoint Property

BaseImportOptionsReferencePoint Property

The 3D point in the document where the imported instance will be inserted. If not explicitly set, the instance will be inserted at the document origin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ ReferencePoint { get; set; }
Public Property ReferencePoint As XYZ
    Get
    Set
public:
property XYZ^ ReferencePoint {
    XYZ^ get ();
    void set (XYZ^ value);
}
member ReferencePoint : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

BaseImportOptions Class


BaseImportOptions.ThisViewOnly Property

BaseImportOptionsThisViewOnly Property

Imports drawings into the view that was passed into the import method. This option is not available in 3D views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ThisViewOnly { get; set; }
Public Property ThisViewOnly As Boolean
    Get
    Set
public:
property bool ThisViewOnly {
    bool get ();
    void set (bool value);
}
member ThisViewOnly : bool with get, set

Property Value

Boolean
See Also

Reference

BaseImportOptions Class


BaseImportOptions.Unit Property

BaseImportOptionsUnit Property

The unit of measure for imported geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImportUnit Unit { get; set; }
Public Property Unit As ImportUnit
    Get
    Set
public:
property ImportUnit Unit {
    ImportUnit get ();
    void set (ImportUnit value);
}
member Unit : ImportUnit with get, set

Property Value

ImportUnit
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
Units are used to calculate the import scale unless scale is defined explicitly using CustomScale, in which case Units will be ignored. Feet, inches, meters, centimeters, decimeters, millimeters are all supported. If Default unit is set, Revit will read and use the units from the file. If units are not available or accessible there, or if the file contains multiple length units, the data will be imported at the original scale regardless of the unit and default length unit options.
See Also

Reference

BaseImportOptions Class


BaseImportOptions.VisibleLayersOnly Property

BaseImportOptionsVisibleLayersOnly Property

Only import the visible layers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool VisibleLayersOnly { get; set; }
Public Property VisibleLayersOnly As Boolean
    Get
    Set
public:
property bool VisibleLayersOnly {
    bool get ();
    void set (bool value);
}
member VisibleLayersOnly : bool with get, set

Property Value

Boolean
Remarks
If this option is set to true, only visible layers are imported. For dgn import, this option is unsupported.
See Also

Reference

BaseImportOptions Class


BaseImportOptions Methods

The BaseImportOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetDefaultLengthUnit | Get the default length unit used for importing unitless files.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLayerSelection | Get all set layers name which user want to import into Revit.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetDefaultLengthUnit | Set the default length unit used for importing unitless files.
Public method | SetLayerSelection | Set the layers name which user want to import into Revit.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

BaseImportOptions Class


BaseImportOptions.Dispose Method

BaseImportOptionsDispose Method

Releases all resources used by the BaseImportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

BaseImportOptions Class


BaseImportOptions.GetDefaultLengthUnit Method

BaseImportOptionsGetDefaultLengthUnit Method

Get the default length unit used for importing unitless files.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ForgeTypeId GetDefaultLengthUnit()
Public Function GetDefaultLengthUnit As ForgeTypeId
public:
ForgeTypeId^ GetDefaultLengthUnit()
member GetDefaultLengthUnit : unit -> ForgeTypeId

Return Value

ForgeTypeId
See Also

Reference

BaseImportOptions Class


BaseImportOptions.GetLayerSelection Method

BaseImportOptionsGetLayerSelection Method

Get all set layers name which user want to import into Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<string> GetLayerSelection()
Public Function GetLayerSelection As ICollection(Of String)
public:
ICollection<String^>^ GetLayerSelection()
member GetLayerSelection : unit -> ICollection<string>

Return Value

ICollection String
The layers' name.
See Also

Reference

BaseImportOptions Class


BaseImportOptions.SetDefaultLengthUnit Method

BaseImportOptionsSetDefaultLengthUnit Method

Set the default length unit used for importing unitless files.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetDefaultLengthUnit(
    ForgeTypeId specTypeId
)
Public Sub SetDefaultLengthUnit (
    specTypeId As ForgeTypeId
)
public:
void SetDefaultLengthUnit(
    ForgeTypeId^ specTypeId
)
member SetDefaultLengthUnit :
        specTypeId : ForgeTypeId -> unit

Parameters

specTypeId ForgeTypeId
The default length unit.
Exceptions
Exception | Condition
ArgumentException | The given specTypeId is not a supported unit of length.
ArgumentNullException | A non-optional argument was null
See Also

Reference

BaseImportOptions Class


BaseImportOptions.SetLayerSelection Method

BaseImportOptionsSetLayerSelection Method

Set the layers name which user want to import into Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetLayerSelection(
    ICollection<string> layerSelection
)
Public Sub SetLayerSelection (
    layerSelection As ICollection(Of String)
)
public:
void SetLayerSelection(
    ICollection<String^>^ layerSelection
)
member SetLayerSelection :
        layerSelection : ICollection<string> -> unit

Parameters

layerSelection ICollection String
The layers imported into Revit.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
If user don't set any layer selection, all layers would be imported into Revit for dgn. But for dwg|dxf, all layers (or visible layers, it is up to visibleLayersOnly was set or not) would be imported into Revit.
See Also

Reference

BaseImportOptions Class


BaseLoadOn Enumeration

An enumerated type listing all the possible power load use types for a space object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum BaseLoadOn
Public Enumeration BaseLoadOn
public enum class BaseLoadOn
type BaseLoadOn
Members
Member name | Value | Description
kUseEnteredLoad | 0 | Return BaseLoadOn is UseEnteredLoad.
kUseCalculatedLoad | 1 | Return BaseLoadOn is UseCalculatedLoad.
kUseActualLoad | 2 | Return BaseLoadOn is UseActualLoad.
kNoOfBaseLoadOnMethods | 3 | Return BaseLoadOn is NoOfBaseLoadOnMethods.
kBySpaceType | -1 | Return BaseLoadOn is BySpaceType.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


BasePoint Class

A class representing the Project Base Point and Survey Point. Each Revit project contains one project base point and one survey point. The project base point represents the origin of the project coordinate system. The survey point represents the origin of the shared coordinate system.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBBasePoint

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BasePoint : Element
Public Class BasePoint
    Inherits Element
public ref class BasePoint : public Element
type BasePoint =
    class
        inherit Element
    end

The BasePoint type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | Clipped | Clipped state of the survey point (shared BasePoint). Change its state to clipped or unclipped, depending on how you want to move the survey point. To move the survey coordinate system in relation to the model, move the clipped survey point. To change the survey point to another location in the survey coordinate system, move the unclipped survey point. For project base point (non-shared BasePoint), this property will always return false. Trying to set the property will get an InvalidOperationException.
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsShared | Indicates whether the BasePoint is shared. The project's survey point is a BasePoint which is shared.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Position | Position of the BasePoint.
Public property | SharedPosition | Shared position of the BasePoint based on the active ProjectLocation of its belonging Document. To get the shared position under other ProjectLocations, please use ProjectLocation.GetProjectPosition(BasePoint.Position).
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
 | GetProjectBasePoint | Gets the project base point for the document.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
 | GetSurveyPoint | Gets the survey point for the document.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


BasePoint Properties

The BasePoint type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | Clipped | Clipped state of the survey point (shared BasePoint). Change its state to clipped or unclipped, depending on how you want to move the survey point. To move the survey coordinate system in relation to the model, move the clipped survey point. To change the survey point to another location in the survey coordinate system, move the unclipped survey point. For project base point (non-shared BasePoint), this property will always return false. Trying to set the property will get an InvalidOperationException.
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsShared | Indicates whether the BasePoint is shared. The project's survey point is a BasePoint which is shared.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Position | Position of the BasePoint.
Public property | SharedPosition | Shared position of the BasePoint based on the active ProjectLocation of its belonging Document. To get the shared position under other ProjectLocations, please use ProjectLocation.GetProjectPosition(BasePoint.Position).
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

BasePoint Class


BasePoint.Clipped Property

BasePointClipped Property

Clipped state of the survey point (shared BasePoint). Change its state to clipped or unclipped, depending on how you want to move the survey point. To move the survey coordinate system in relation to the model, move the clipped survey point. To change the survey point to another location in the survey coordinate system, move the unclipped survey point. For project base point (non-shared BasePoint), this property will always return false. Trying to set the property will get an InvalidOperationException.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Clipped { get; set; }
Public Property Clipped As Boolean
    Get
    Set
public:
property bool Clipped {
    bool get ();
    void set (bool value);
}
member Clipped : bool with get, set

Property Value

Boolean
Exceptions
Exception | Condition
InvalidOperationException | When setting this property: This operation is only available for a shared BasePoint.
See Also

Reference

BasePoint Class


BasePoint.IsShared Property

BasePointIsShared Property

Indicates whether the BasePoint is shared. The project's survey point is a BasePoint which is shared.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsShared { get; }
Public ReadOnly Property IsShared As Boolean
    Get
public:
property bool IsShared {
    bool get ();
}
member IsShared : bool with get

Property Value

Boolean
See Also

Reference

BasePoint Class


BasePoint.Position Property

BasePointPosition Property

Position of the BasePoint.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Position { get; }
Public ReadOnly Property Position As XYZ
    Get
public:
property XYZ^ Position {
    XYZ^ get ();
}
member Position : XYZ with get

Property Value

XYZ
See Also

Reference

BasePoint Class


BasePoint.SharedPosition Property

BasePointSharedPosition Property

Shared position of the BasePoint based on the active ProjectLocation of its belonging Document. To get the shared position under other ProjectLocations, please use ProjectLocation.GetProjectPosition(BasePoint.Position).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ SharedPosition { get; }
Public ReadOnly Property SharedPosition As XYZ
    Get
public:
property XYZ^ SharedPosition {
    XYZ^ get ();
}
member SharedPosition : XYZ with get

Property Value

XYZ
See Also

Reference

BasePoint Class


BasePoint Methods

The BasePoint type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
 | GetProjectBasePoint | Gets the project base point for the document.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
 | GetSurveyPoint | Gets the survey point for the document.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

BasePoint Class


BasePoint.GetProjectBasePoint Method

BasePointGetProjectBasePoint Method

Gets the project base point for the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static BasePoint GetProjectBasePoint(
    Document cda
)
Public Shared Function GetProjectBasePoint (
    cda As Document
) As BasePoint
public:
static BasePoint^ GetProjectBasePoint(
    Document^ cda
)
static member GetProjectBasePoint :
        cda : Document -> BasePoint

Parameters

cda Document
The document from which to get the project base point.

Return Value

BasePoint
The project base point of the document.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

BasePoint Class


BasePoint.GetSurveyPoint Method

BasePointGetSurveyPoint Method

Gets the survey point for the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static BasePoint GetSurveyPoint(
    Document cda
)
Public Shared Function GetSurveyPoint (
    cda As Document
) As BasePoint
public:
static BasePoint^ GetSurveyPoint(
    Document^ cda
)
static member GetSurveyPoint :
        cda : Document -> BasePoint

Parameters

cda Document
The document from which to get the survey point.

Return Value

BasePoint
The survey point of the document.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

BasePoint Class


BasicFileInfo Class

Encapsulates basic information about a Revit file, including worksharing status, Revit version, username and central path.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBasicFileInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BasicFileInfo : IDisposable
Public Class BasicFileInfo
    Implements IDisposable
public ref class BasicFileInfo : IDisposable
type BasicFileInfo =
    class
        interface IDisposable
    end

The BasicFileInfo type exposes the following members.

Properties
 | Name | Description
Public property | AllLocalChangesSavedToCentral | Are all local changes saved to the central file?
Public property | CentralPath | Returns the central model path.
Public property | Format | The file format indicator (currently, the major release version such as "2019") used for saving the file.
Public property | IsCentral | Checks if the file is workshared and Central.
Public property | IsCreatedLocal | Checks if the file is local and created by RevitServerTool.exe.
Public property | IsInProgress | Checks if the file is workshared and is in process of becoming Central.
Public property | IsLocal | Checks if the file is workshared and Local.
Public property | IsSavedInCurrentVersion | Checks if the file is saved in the current version.
Public property | IsSavedInLaterVersion | Checks if the file is saved in a later version of Revit than the running Revit.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | IsWorkshared | Checks if the file is workshared.
Public property | LanguageWhenSaved | Return the language active for the last save
Public property | LatestCentralEpisodeGUID | This is the central model's episode GUID corresponding to the last reload latest done for this model.
Public property | LatestCentralVersion | This is the central model's version number corresponding to the last reload latest done for this model.
Public property | Username | Returns the username.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the BasicFileInfo
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | Extract | Returns an instance of BasicFileInfo filled with basic information about a Revit file located at the given file-path
Public method | GetDocumentVersion | Gets the DocumentVersion for the file.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This class provides a fast access to get basic information without fully opening a Revit file. The Extract method can initialize a new instance of this class by providing a full path for Revit file, including project (.rvt) and family (.rfa) files. This class can extract information from files of older formats. If the structure of the BasicFileInfo storage has not changed, it can also extract information from files of newer formats (making the method IsSavedInLaterVersion relevant). However, if the structure of the storage has changed in a newer file format, Extract will not be able to extract the information.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


BasicFileInfo Properties

The BasicFileInfo type exposes the following members.

Properties
 | Name | Description
Public property | AllLocalChangesSavedToCentral | Are all local changes saved to the central file?
Public property | CentralPath | Returns the central model path.
Public property | Format | The file format indicator (currently, the major release version such as "2019") used for saving the file.
Public property | IsCentral | Checks if the file is workshared and Central.
Public property | IsCreatedLocal | Checks if the file is local and created by RevitServerTool.exe.
Public property | IsInProgress | Checks if the file is workshared and is in process of becoming Central.
Public property | IsLocal | Checks if the file is workshared and Local.
Public property | IsSavedInCurrentVersion | Checks if the file is saved in the current version.
Public property | IsSavedInLaterVersion | Checks if the file is saved in a later version of Revit than the running Revit.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | IsWorkshared | Checks if the file is workshared.
Public property | LanguageWhenSaved | Return the language active for the last save
Public property | LatestCentralEpisodeGUID | This is the central model's episode GUID corresponding to the last reload latest done for this model.
Public property | LatestCentralVersion | This is the central model's version number corresponding to the last reload latest done for this model.
Public property | Username | Returns the username.
Top
See Also

Reference

BasicFileInfo Class


BasicFileInfo.AllLocalChangesSavedToCentral Property

BasicFileInfoAllLocalChangesSavedToCentral Property

Are all local changes saved to the central file?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AllLocalChangesSavedToCentral { get; }
Public ReadOnly Property AllLocalChangesSavedToCentral As Boolean
    Get
public:
property bool AllLocalChangesSavedToCentral {
    bool get ();
}
member AllLocalChangesSavedToCentral : bool with get

Property Value

Boolean
See Also

Reference

BasicFileInfo Class


BasicFileInfo.CentralPath Property

BasicFileInfoCentralPath Property

Returns the central model path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string CentralPath { get; }
Public ReadOnly Property CentralPath As String
    Get
public:
property String^ CentralPath {
    String^ get ();
}
member CentralPath : string with get

Property Value

String
See Also

Reference

BasicFileInfo Class


BasicFileInfo.Format Property

BasicFileInfoFormat Property

The file format indicator (currently, the major release version such as "2019") used for saving the file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Format { get; }
Public ReadOnly Property Format As String
    Get
public:
property String^ Format {
    String^ get ();
}
member Format : string with get

Property Value

String
See Also

Reference

BasicFileInfo Class


BasicFileInfo.IsCentral Property

BasicFileInfoIsCentral Property

Checks if the file is workshared and Central.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCentral { get; }
Public ReadOnly Property IsCentral As Boolean
    Get
public:
property bool IsCentral {
    bool get ();
}
member IsCentral : bool with get

Property Value

Boolean
See Also

Reference

BasicFileInfo Class


BasicFileInfo.IsCreatedLocal Property

BasicFileInfoIsCreatedLocal Property

Checks if the file is local and created by RevitServerTool.exe.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCreatedLocal { get; }
Public ReadOnly Property IsCreatedLocal As Boolean
    Get
public:
property bool IsCreatedLocal {
    bool get ();
}
member IsCreatedLocal : bool with get

Property Value

Boolean
Remarks
The value will be set to false after the file is saved and IsLocal will become true.
See Also

Reference

BasicFileInfo Class


BasicFileInfo.IsInProgress Property

BasicFileInfoIsInProgress Property

Checks if the file is workshared and is in process of becoming Central.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsInProgress { get; }
Public ReadOnly Property IsInProgress As Boolean
    Get
public:
property bool IsInProgress {
    bool get ();
}
member IsInProgress : bool with get

Property Value

Boolean
See Also

Reference

BasicFileInfo Class


BasicFileInfo.IsLocal Property

BasicFileInfoIsLocal Property

Checks if the file is workshared and Local.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsLocal { get; }
Public ReadOnly Property IsLocal As Boolean
    Get
public:
property bool IsLocal {
    bool get ();
}
member IsLocal : bool with get

Property Value

Boolean
See Also

Reference

BasicFileInfo Class


BasicFileInfo.IsSavedInCurrentVersion Property

BasicFileInfoIsSavedInCurrentVersion Property

Checks if the file is saved in the current version.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSavedInCurrentVersion { get; }
Public ReadOnly Property IsSavedInCurrentVersion As Boolean
    Get
public:
property bool IsSavedInCurrentVersion {
    bool get ();
}
member IsSavedInCurrentVersion : bool with get

Property Value

Boolean
See Also

Reference

BasicFileInfo Class


BasicFileInfo.IsSavedInLaterVersion Property

BasicFileInfoIsSavedInLaterVersion Property

Checks if the file is saved in a later version of Revit than the running Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSavedInLaterVersion { get; }
Public ReadOnly Property IsSavedInLaterVersion As Boolean
    Get
public:
property bool IsSavedInLaterVersion {
    bool get ();
}
member IsSavedInLaterVersion : bool with get

Property Value

Boolean
Remarks
If the structure of the BasicFileInfo storage has not changed in a newer format file, this will indicate that the file format is newer. However, if the structure of the storage has changed in a newer format file, extraction would have failed and this method cannot be used to make that determination.
See Also

Reference

BasicFileInfo Class


BasicFileInfo.IsValidObject Property

BasicFileInfoIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

BasicFileInfo Class


BasicFileInfo.IsWorkshared Property

BasicFileInfoIsWorkshared Property

Checks if the file is workshared.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsWorkshared { get; }
Public ReadOnly Property IsWorkshared As Boolean
    Get
public:
property bool IsWorkshared {
    bool get ();
}
member IsWorkshared : bool with get

Property Value

Boolean
See Also

Reference

BasicFileInfo Class


BasicFileInfo.LanguageWhenSaved Property

BasicFileInfoLanguageWhenSaved Property

Return the language active for the last save

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LanguageType LanguageWhenSaved { get; }
Public ReadOnly Property LanguageWhenSaved As LanguageType
    Get
public:
property LanguageType LanguageWhenSaved {
    LanguageType get ();
}
member LanguageWhenSaved : LanguageType with get

Property Value

LanguageType
See Also

Reference

BasicFileInfo Class


BasicFileInfo.LatestCentralEpisodeGUID Property

BasicFileInfoLatestCentralEpisodeGUID Property

This is the central model's episode GUID corresponding to the last reload latest done for this model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid LatestCentralEpisodeGUID { get; }
Public ReadOnly Property LatestCentralEpisodeGUID As Guid
    Get
public:
property Guid LatestCentralEpisodeGUID {
    Guid get ();
}
member LatestCentralEpisodeGUID : Guid with get

Property Value

Guid
See Also

Reference

BasicFileInfo Class


BasicFileInfo.LatestCentralVersion Property

BasicFileInfoLatestCentralVersion Property

This is the central model's version number corresponding to the last reload latest done for this model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int LatestCentralVersion { get; }
Public ReadOnly Property LatestCentralVersion As Integer
    Get
public:
property int LatestCentralVersion {
    int get ();
}
member LatestCentralVersion : int with get

Property Value

Int32
See Also

Reference

BasicFileInfo Class


BasicFileInfo.Username Property

BasicFileInfoUsername Property

Returns the username.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Username { get; }
Public ReadOnly Property Username As String
    Get
public:
property String^ Username {
    String^ get ();
}
member Username : string with get

Property Value

String
See Also

Reference

BasicFileInfo Class


BasicFileInfo Methods

The BasicFileInfo type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | Extract | Returns an instance of BasicFileInfo filled with basic information about a Revit file located at the given file-path
Public method | GetDocumentVersion | Gets the DocumentVersion for the file.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

BasicFileInfo Class


BasicFileInfo.Dispose Method

BasicFileInfoDispose Method

Releases all resources used by the BasicFileInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

BasicFileInfo Class


BasicFileInfo.Extract Method

BasicFileInfoExtract Method

Returns an instance of BasicFileInfo filled with basic information about a Revit file located at the given file-path

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static BasicFileInfo Extract(
    string file
)
Public Shared Function Extract (
    file As String
) As BasicFileInfo
public:
static BasicFileInfo^ Extract(
    String^ file
)
static member Extract :
        file : string -> BasicFileInfo

Parameters

file String
The full path to the file to be queried, including project (.rvt) and family (.rfa) files.

Return Value

BasicFileInfo
If successful, basic file data.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
FileArgumentNotFoundException | The file doesn't exist.
InvalidOperationException | The file is a newer format file where the structure of the BasicFileInfo storage has changed, or the file is saved in very old version of Revit without basic file data.
See Also

Reference

BasicFileInfo Class


BasicFileInfo.GetDocumentVersion Method

BasicFileInfoGetDocumentVersion Method

Gets the DocumentVersion for the file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocumentVersion GetDocumentVersion()
Public Function GetDocumentVersion As DocumentVersion
public:
DocumentVersion^ GetDocumentVersion()
member GetDocumentVersion : unit -> DocumentVersion

Return Value

DocumentVersion
The DocumentVersion for the file.
See Also

Reference

BasicFileInfo Class


BeamSystem Class

An object that represents a BeamSystem within the Autodesk Revit project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBBeamSystem

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BeamSystem : Element
Public Class BeamSystem
    Inherits Element
public ref class BeamSystem : public Element
type BeamSystem =
    class
        inherit Element
    end

The BeamSystem type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BeamSystemType | Retrieves or changes the type of the BeamSystem.
 | BeamType | Retrieves or changes the Beam Type of the BeamSystem.
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Direction | The Direction of the BeamSystem.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | Elevation | Retrieves or changes the Elevation of the BeamSystem.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LayoutRule | Retrieves or changes the LayoutRule of the BeamSystem.
Public property | Level | Get or change the level of the BeamSystem. When the level is changed, the elevation is changed to make the the BeamSystem remain the location.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Profile | Retrieve or set the profile of the BeamSystem.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
 | BeamBelongsTo | Find out the BeamSystem to which the beam belongs.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create(Document, IListCurve, SketchPlane, Int32) | Creates a 2D BeamSystem with specified profile curves.
 | Create(Document, IListCurve, Level, XYZ, Boolean) | Creates a new BeamSystem with specified profile curves.
 | Create(Document, IListCurve, Level, Int32, Boolean) | Creates a new BeamSystem with specified profile curves.
 | Create(Document, IListCurve, SketchPlane, XYZ, Boolean) | Creates a new BeamSystem with specified profile curves.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
 | DropBeamSystem | Drop beam system, it will disassociate all members from the beam system and delete the beam system.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetBeamIds | Gets all the beams of the BeamSystem.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This object is derived from the Element base object. It can be used to access properties of a BeamSystem, such as elevation, level, etc. It also provides access to the beams (FamilyInstances) that are created by this BeamSystem.
Example
C#
VB
C++
F#
Copy
public void GetInfo_BeamSystem(BeamSystem beamSystem)
{
    string message = "BeamSystem : ";
    // Get BeamSystem family name
    message += "\nBeamSystem Direction is:(" + beamSystem.Direction.X + ", "
        + beamSystem.Direction.Y + ", " + beamSystem.Direction.Z + ")";

    // Get BeamSystem elevation
    message += "\nBeamSystem elevation is: " + beamSystem.Elevation;

    Document document = beamSystem.Document;
    ICollection<ElementId> beamIds = beamSystem.GetBeamIds();
    foreach (ElementId beamId in beamIds)
    {
        Element beam = document.GetElement(beamId);
        // Get Beam name
        message += "\nBeam name: " + beam.Name;
    }

    // Get BeamSystem layout rule
    message += "\nBeamSystem layout rule is: " + beamSystem.LayoutRule;

    // Get BeamSystem level name
    message += "\nBeamSystem level name is: " + beamSystem.Level.Name;

    message += "\nBeamSystem Profile: " + beamSystem.Level.Name;
    foreach (Autodesk.Revit.DB.Curve curve in beamSystem.Profile)
    {
        // Get curve start point
        message += "\nCurve start point:(" + curve.GetEndPoint(0).X + ", "
             + curve.GetEndPoint(0).Y + ", " + curve.GetEndPoint(0).Z + ")";
        // Get curve end point
        message += "; Curve end point:(" + curve.GetEndPoint(1).X + ", "
             + curve.GetEndPoint(1).Y + ", " + curve.GetEndPoint(1).Z + ")";
    }

    TaskDialog.Show("Revit",message);
}
Public Sub GetInfo_BeamSystem(beamSystem As BeamSystem)
    Dim message As String = "BeamSystem : "
    ' Get BeamSystem family name
    message += vbLf & "BeamSystem Direction is:(" & Convert.ToString(beamSystem.Direction.X) & ", " & Convert.ToString(beamSystem.Direction.Y) & ", " & Convert.ToString(beamSystem.Direction.Z) & ")"

    ' Get BeamSystem elevation
    message += vbLf & "BeamSystem elevation is: " & Convert.ToString(beamSystem.Elevation)

    Dim document As Document = beamSystem.Document
    Dim beamIds As ICollection(Of ElementId) = beamSystem.GetBeamIds()
    For Each beamId As ElementId In beamIds
        Dim beam As Element = document.GetElement(beamId)
        ' Get Beam name
        message += vbLf & "Beam name: " + beam.Name
    Next

    ' Get BeamSystem layout rule
    message += vbLf & "BeamSystem layout rule is: " & Convert.ToString(beamSystem.LayoutRule)

    ' Get BeamSystem level name
    message += vbLf & "BeamSystem level name is: " & Convert.ToString(beamSystem.Level.Name)

    message += vbLf & "BeamSystem Profile: " & Convert.ToString(beamSystem.Level.Name)
    For Each curve As Autodesk.Revit.DB.Curve In beamSystem.Profile
        ' Get curve start point
        message += ((vbLf & "Curve start point:(" + curve.GetEndPoint(0).X & ", ") + curve.GetEndPoint(0).Y & ", ") + curve.GetEndPoint(0).Z & ")"
        ' Get curve end point
        message += (("; Curve end point:(" + curve.GetEndPoint(1).X & ", ") + curve.GetEndPoint(1).Y & ", ") + curve.GetEndPoint(1).Z & ")"
    Next

    TaskDialog.Show("Revit", message)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


BeamSystem Properties

The BeamSystem type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BeamSystemType | Retrieves or changes the type of the BeamSystem.
 | BeamType | Retrieves or changes the Beam Type of the BeamSystem.
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Direction | The Direction of the BeamSystem.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | Elevation | Retrieves or changes the Elevation of the BeamSystem.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LayoutRule | Retrieves or changes the LayoutRule of the BeamSystem.
Public property | Level | Get or change the level of the BeamSystem. When the level is changed, the elevation is changed to make the the BeamSystem remain the location.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Profile | Retrieve or set the profile of the BeamSystem.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

BeamSystem Class


BeamSystem.BeamSystemType Property

BeamSystemBeamSystemType Property

Retrieves or changes the type of the BeamSystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BeamSystemType BeamSystemType { get; set; }
Public Property BeamSystemType As BeamSystemType
    Get
    Set
public:
property BeamSystemType^ BeamSystemType {
    BeamSystemType^ get ();
    void set (BeamSystemType^ value);
}
member BeamSystemType : BeamSystemType with get, set

Property Value

BeamSystemType
Example
C#
VB
C++
F#
Copy
public void GetInfo_BeamSystemType(BeamSystem beamSystem)
{
    string message = "BeamSystem : ";
    // Get BeamSystem type name
    message += "\nBeamSystem type name : " + beamSystem.BeamSystemType.Name;

    // Rename the BeamSystem type used by this BeamSystem
    beamSystem.BeamSystemType.Name = "TestBeamSystemTypeName";
    // Get BeamSystem type name
    message += "\nBeamSystem type name after set: " + beamSystem.BeamSystemType.Name;

    TaskDialog.Show("Revit",message);
}
Public Sub GetInfo_BeamSystemType(beamSystem As BeamSystem)
    Dim message As String = "BeamSystem : "
    ' Get BeamSystem type name
    message += vbLf & "BeamSystem type name : " & Convert.ToString(beamSystem.BeamSystemType.Name)

    ' Rename the BeamSystem type used by this BeamSystem
    beamSystem.BeamSystemType.Name = "TestBeamSystemTypeName"
    ' Get BeamSystem type name
    message += vbLf & "BeamSystem type name after set: " & Convert.ToString(beamSystem.BeamSystemType.Name)

    TaskDialog.Show("Revit", message)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

BeamSystem Class


BeamSystem.BeamType Property

BeamSystemBeamType Property

Retrieves or changes the Beam Type of the BeamSystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilySymbol BeamType { get; set; }
Public Property BeamType As FamilySymbol
    Get
    Set
public:
property FamilySymbol^ BeamType {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}
member BeamType : FamilySymbol with get, set

Property Value

FamilySymbol
Example
C#
VB
C++
F#
Copy
public void GetInfo_BeamType(BeamSystem beamSystem)
{
    string message = "BeamSystem : ";
    // Get BeamSystem type name
    message += "\nBeam type name : " + beamSystem.BeamType.Name;
    // Get BeamSystem type material
    foreach (ElementId materialId in beamSystem.BeamType.GetMaterialIds(false))
    {
       Material material = beamSystem.Document.GetElement(materialId) as Material;
       message += "\nBeam type material : " + material.Name;
    }
    // Get BeamSystem family name
    message += "\nBeam family name : " + beamSystem.BeamType.Family.Name;

    // Rename BeamType used by this BeamSystem
    beamSystem.BeamType.Name = "TestBeamTypeName";
    // Rename the Family used by the BeamType that is used by this BeamSystem
    beamSystem.BeamType.Family.Name = "TestBeamTypeFamilyName";

    // Get BeamSystem type name
    message += "\nBeam type name after set : " + beamSystem.BeamType.Name;
    // Get BeamSystem family name
    message += "\nBeam family name after set : " + beamSystem.BeamType.Family.Name;

    TaskDialog.Show("Revit",message);
}
Public Sub GetInfo_BeamType(beamSystem As BeamSystem)
    Dim message As String = "BeamSystem : "
    ' Get BeamSystem type name
    message += vbLf & "Beam type name : " & Convert.ToString(beamSystem.BeamType.Name)
    ' Get BeamSystem type material
    For Each materialId As ElementId In beamSystem.BeamType.GetMaterialIds(False)
        Dim material As Material = TryCast(beamSystem.Document.GetElement(materialId), Material)
        message += vbLf & "Beam type material : " + material.Name
    Next
    ' Get BeamSystem family name
    message += vbLf & "Beam family name : " & Convert.ToString(beamSystem.BeamType.Family.Name)

    ' Rename BeamType used by this BeamSystem
    beamSystem.BeamType.Name = "TestBeamTypeName"
    ' Rename the Family used by the BeamType that is used by this BeamSystem
    beamSystem.BeamType.Family.Name = "TestBeamTypeFamilyName"

    ' Get BeamSystem type name
    message += vbLf & "Beam type name after set : " & Convert.ToString(beamSystem.BeamType.Name)
    ' Get BeamSystem family name
    message += vbLf & "Beam family name after set : " & Convert.ToString(beamSystem.BeamType.Family.Name)

    TaskDialog.Show("Revit", message)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

BeamSystem Class


BeamSystem.Direction Property

BeamSystemDirection Property

The Direction of the BeamSystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Direction { get; }
Public ReadOnly Property Direction As XYZ
    Get
public:
property XYZ^ Direction {
    XYZ^ get ();
}
member Direction : XYZ with get

Property Value

XYZ
See Also

Reference

BeamSystem Class


BeamSystem.Elevation Property

BeamSystemElevation Property

Retrieves or changes the Elevation of the BeamSystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Elevation { get; set; }
Public Property Elevation As Double
    Get
    Set
public:
property double Elevation {
    double get ();
    void set (double value);
}
member Elevation : float with get, set

Property Value

Double
See Also

Reference

BeamSystem Class


BeamSystem.LayoutRule Property

BeamSystemLayoutRule Property

Retrieves or changes the LayoutRule of the BeamSystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LayoutRule LayoutRule { get; set; }
Public Property LayoutRule As LayoutRule
    Get
    Set
public:
property LayoutRule^ LayoutRule {
    LayoutRule^ get ();
    void set (LayoutRule^ value);
}
member LayoutRule : LayoutRule with get, set

Property Value

LayoutRule
See Also

Reference

BeamSystem Class


BeamSystem.Level Property

BeamSystemLevel Property

Get or change the level of the BeamSystem. When the level is changed, the elevation is changed to make the the BeamSystem remain the location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Level Level { get; set; }
Public Property Level As Level
    Get
    Set
public:
property Level^ Level {
    Level^ get ();
    void set (Level^ value);
}
member Level : Level with get, set

Property Value

Level
See Also

Reference

BeamSystem Class


BeamSystem.Profile Property

BeamSystemProfile Property

Retrieve or set the profile of the BeamSystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurveArray Profile { get; set; }
Public Property Profile As CurveArray
    Get
    Set
public:
property CurveArray^ Profile {
    CurveArray^ get ();
    void set (CurveArray^ value);
}
member Profile : CurveArray with get, set

Property Value

CurveArray
See Also

Reference

BeamSystem Class


BeamSystem Methods

The BeamSystem type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
 | BeamBelongsTo | Find out the BeamSystem to which the beam belongs.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create(Document, IListCurve, SketchPlane, Int32) | Creates a 2D BeamSystem with specified profile curves.
 | Create(Document, IListCurve, Level, XYZ, Boolean) | Creates a new BeamSystem with specified profile curves.
 | Create(Document, IListCurve, Level, Int32, Boolean) | Creates a new BeamSystem with specified profile curves.
 | Create(Document, IListCurve, SketchPlane, XYZ, Boolean) | Creates a new BeamSystem with specified profile curves.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
 | DropBeamSystem | Drop beam system, it will disassociate all members from the beam system and delete the beam system.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetBeamIds | Gets all the beams of the BeamSystem.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

BeamSystem Class


BeamSystem.BeamBelongsTo Method

BeamSystemBeamBelongsTo Method

Find out the BeamSystem to which the beam belongs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static BeamSystem BeamBelongsTo(
    FamilyInstance beam
)
Public Shared Function BeamBelongsTo (
    beam As FamilyInstance
) As BeamSystem
public:
static BeamSystem^ BeamBelongsTo(
    FamilyInstance^ beam
)
static member BeamBelongsTo :
        beam : FamilyInstance -> BeamSystem

Parameters

beam FamilyInstance
The beam want to ask.

Return Value

BeamSystem
The BeamSystem.
See Also

Reference

BeamSystem Class


BeamSystem.Create Method

BeamSystemCreate Method

Overload List
Name | Description
Create(Document, IListCurve, SketchPlane, Int32) | Creates a 2D BeamSystem with specified profile curves.
Create(Document, IListCurve, Level, XYZ, Boolean) | Creates a new BeamSystem with specified profile curves.
Create(Document, IListCurve, Level, Int32, Boolean) | Creates a new BeamSystem with specified profile curves.
Create(Document, IListCurve, SketchPlane, XYZ, Boolean) | Creates a new BeamSystem with specified profile curves.
Top
See Also

Reference

BeamSystem Class


BeamSystem.Create(Document, IList<Curve>, SketchPlane, Int32) Method

BeamSystemCreate(Document, IListCurve, SketchPlane, Int32) Method

Creates a 2D BeamSystem with specified profile curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static BeamSystem Create(
    Document document,
    IList<Curve> profile,
    SketchPlane sketchPlane,
    int curveIndexForDirection
)
Public Shared Function Create (
    document As Document,
    profile As IList(Of Curve),
    sketchPlane As SketchPlane,
    curveIndexForDirection As Integer
) As BeamSystem
public:
static BeamSystem^ Create(
    Document^ document,
    IList<Curve^>^ profile,
    SketchPlane^ sketchPlane,
    int curveIndexForDirection
)
static member Create :
        document : Document *
        profile : IList<Curve> *
        sketchPlane : SketchPlane *
        curveIndexForDirection : int -> BeamSystem

Parameters

document Document
The document in which the new BeamSystem is created.
profile IList Curve
The profile of the BeamSystem.
sketchPlane SketchPlane
The work-plane for the BeamSystem.
curveIndexForDirection Int32
Index of the curve in the profile to be used as direction. '0' means the default direction-to use the first curve in profile. The curve from the profile to be used as direction must be a Line.

Return Value

BeamSystem
If successful, a new BeamSystem object will be returned.
Exceptions
Exception | Condition
ArgumentException | SketchPlane is not valid for BeamSystem creation. -or- The input profile contains at least one helical curve and is not supported for this operation. -or- The profile curves must be in the sketch plane. -or- The curve index must be valid and the curve to be used as direction must be a Line.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
See Also

Reference

BeamSystem Class
Create Overload


BeamSystem.Create(Document, IList<Curve>, Level, XYZ, Boolean) Method

BeamSystemCreate(Document, IListCurve, Level, XYZ, Boolean) Method

Creates a new BeamSystem with specified profile curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static BeamSystem Create(
    Document document,
    IList<Curve> profile,
    Level level,
    XYZ direction,
    bool is3d
)
Public Shared Function Create (
    document As Document,
    profile As IList(Of Curve),
    level As Level,
    direction As XYZ,
    is3d As Boolean
) As BeamSystem
public:
static BeamSystem^ Create(
    Document^ document,
    IList<Curve^>^ profile,
    Level^ level,
    XYZ^ direction,
    bool is3d
)
static member Create :
        document : Document *
        profile : IList<Curve> *
        level : Level *
        direction : XYZ *
        is3d : bool -> BeamSystem

Parameters

document Document
The document in which the new BeamSystem is created.
profile IList Curve
The profile of the BeamSystem.
level Level
The level on which the BeamSystem is to be created. The work-plane of the BeamSystem will be the sketch plane associated with the Level. If there is no current sketch plane associated with the level yet, we will create a default one.
direction XYZ
The direction is the direction of the BeamSystem.
is3d Boolean
Whether the BeamSystem is 3D. If the BeamSystem is 3D, the sketchPlane must be a level, otherwise an exception will be thrown.

Return Value

BeamSystem
If successful, a new BeamSystem object will be returned.
Exceptions
Exception | Condition
ArgumentException | The input profile contains at least one helical curve and is not supported for this operation. -or- The input level does not have associated plan view. -or- The plan view associated with the input level is not valid. -or- Can not get valid sketch plane from the input level.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
See Also

Reference

BeamSystem Class
Create Overload


BeamSystem.Create(Document, IList<Curve>, Level, Int32, Boolean) Method

BeamSystemCreate(Document, IListCurve, Level, Int32, Boolean) Method

Creates a new BeamSystem with specified profile curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static BeamSystem Create(
    Document document,
    IList<Curve> profile,
    Level level,
    int curveIndexForDirection,
    bool is3d
)
Public Shared Function Create (
    document As Document,
    profile As IList(Of Curve),
    level As Level,
    curveIndexForDirection As Integer,
    is3d As Boolean
) As BeamSystem
public:
static BeamSystem^ Create(
    Document^ document,
    IList<Curve^>^ profile,
    Level^ level,
    int curveIndexForDirection,
    bool is3d
)
static member Create :
        document : Document *
        profile : IList<Curve> *
        level : Level *
        curveIndexForDirection : int *
        is3d : bool -> BeamSystem

Parameters

document Document
The document in which the new BeamSystem is created.
profile IList Curve
The profile of the BeamSystem.
level Level
The level on which the BeamSystem is to be created. The work-plane of the BeamSystem will be the sketch plane associated with the Level. If there is no current sketch plane associated with the level yet, we will create a default one.
curveIndexForDirection Int32
Index of the curve in the profile to be used as direction. '0' means the direction to use the first curve in profile. The curve from the profile to be used as direction must be a Line.
is3d Boolean
Whether the BeamSystem is 3D. If the BeamSystem is 3D, the sketchPlane must be a level, otherwise an exception will be thrown.

Return Value

BeamSystem
If successful, a new BeamSystem object will be returned.
Exceptions
Exception | Condition
ArgumentException | The input profile contains at least one helical curve and is not supported for this operation. -or- The curve index must be valid and the curve to be used as direction must be a Line. -or- The input level does not have associated plan view. -or- The plan view associated with the input level is not valid. -or- Can not get valid sketch plane from the input level.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Example
C#
VB
C++
F#
Copy
// Build a profile for the beam system creation
XYZ first = new XYZ(0, 0, 0);
XYZ second = new XYZ(40, 0, 0);
XYZ third = new XYZ(40, 25, 0);
XYZ fourth = new XYZ(0, 25, 0);
List<Curve> profile = new List<Curve>();
profile.Add(Line.CreateBound(first, second));
profile.Add(Line.CreateBound(second, third));
profile.Add(Line.CreateBound(third, fourth));
profile.Add(Line.CreateBound(fourth, first));

// Create a beam system
BeamSystem beamSystem = BeamSystem.Create(document, profile, level, 0, false);
if (null != beamSystem)
{
    // Change some properties, such as elevation
    Parameter elevationPara = beamSystem.get_Parameter(BuiltInParameter.INSTANCE_ELEVATION_PARAM);
    if (null != elevationPara)
    {
        elevationPara.Set(10.0);
    }
}
' Build a profile for the beam system creation
Dim first As New XYZ(0, 0, 0)
Dim second As New XYZ(40, 0, 0)
Dim third As New XYZ(40, 25, 0)
Dim fourth As New XYZ(0, 25, 0)
Dim profile As New List(Of Curve)()
profile.Add(Line.CreateBound(first, second))
profile.Add(Line.CreateBound(second, third))
profile.Add(Line.CreateBound(third, fourth))
profile.Add(Line.CreateBound(fourth, first))

' Create a beam system
Dim beamSystem__1 As BeamSystem = BeamSystem.Create(document, profile, level, 0, False)
If beamSystem__1 IsNot Nothing Then
    ' Change some properties, such as elevation
    Dim elevationPara As Parameter = beamSystem__1.Parameter(BuiltInParameter.INSTANCE_ELEVATION_PARAM)
    If elevationPara IsNot Nothing Then
        elevationPara.[Set](10.0)
    End If
End If

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

BeamSystem Class
Create Overload


BeamSystem.Create(Document, IList<Curve>, SketchPlane, XYZ, Boolean) Method

BeamSystemCreate(Document, IListCurve, SketchPlane, XYZ, Boolean) Method

Creates a new BeamSystem with specified profile curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static BeamSystem Create(
    Document document,
    IList<Curve> profile,
    SketchPlane sketchPlane,
    XYZ direction,
    bool is3d
)
Public Shared Function Create (
    document As Document,
    profile As IList(Of Curve),
    sketchPlane As SketchPlane,
    direction As XYZ,
    is3d As Boolean
) As BeamSystem
public:
static BeamSystem^ Create(
    Document^ document,
    IList<Curve^>^ profile,
    SketchPlane^ sketchPlane,
    XYZ^ direction,
    bool is3d
)
static member Create :
        document : Document *
        profile : IList<Curve> *
        sketchPlane : SketchPlane *
        direction : XYZ *
        is3d : bool -> BeamSystem

Parameters

document Document
The document in which the new BeamSystem is created.
profile IList Curve
The profile of the BeamSystem.
sketchPlane SketchPlane
The work-plane for the BeamSystem.
direction XYZ
The direction is the direction of the BeamSystem.
is3d Boolean
Whether the BeamSystem is 3D. If the BeamSystem is 3D, the sketchPlane must be a level, otherwise an exception will be thrown.

Return Value

BeamSystem
If successful, a new BeamSystem object will be returned.
Exceptions
Exception | Condition
ArgumentException | SketchPlane is not valid for BeamSystem creation. -or- The input profile contains at least one helical curve and is not supported for this operation. -or- The profile curves must be in the sketch plane.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The BeamSystem is 3D, but the SketchPlane is not a level.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
See Also

Reference

BeamSystem Class
Create Overload


BeamSystem.DropBeamSystem Method

BeamSystemDropBeamSystem Method

Drop beam system, it will disassociate all members from the beam system and delete the beam system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void DropBeamSystem(
    BeamSystem beamSystem
)
Public Shared Sub DropBeamSystem (
    beamSystem As BeamSystem
)
public:
static void DropBeamSystem(
    BeamSystem^ beamSystem
)
static member DropBeamSystem :
        beamSystem : BeamSystem -> unit

Parameters

beamSystem BeamSystem
The beam system to be deleted.
See Also

Reference

BeamSystem Class


BeamSystem.GetBeamIds Method

BeamSystemGetBeamIds Method

Gets all the beams of the BeamSystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetBeamIds()
Public Function GetBeamIds As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetBeamIds()
member GetBeamIds : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
The beam Ids.
See Also

Reference

BeamSystem Class


BeamSystemJustifyType Enumeration

Describes the justify method of beamsystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum BeamSystemJustifyType
Public Enumeration BeamSystemJustifyType
public enum class BeamSystemJustifyType
type BeamSystemJustifyType
Members
Member name | Value | Description
Center | 1 | Center.
End | 2 | End.
Beginning | 3 | Beginning.
DirectionLine | 4 | DirectionLine.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


BeamSystemType Class

An object that specifies the type of a beam system in Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBBeamSystemType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BeamSystemType : ElementType
Public Class BeamSystemType
    Inherits ElementType
public ref class BeamSystemType : public ElementType
type BeamSystemType =
    class
        inherit ElementType
    end

The BeamSystemType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


BeamSystemType Properties

The BeamSystemType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

BeamSystemType Class


BeamSystemType Methods

The BeamSystemType type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

BeamSystemType Class


BehaviorType Enumeration

An enumerated type listing all the behavior type for MEP Components.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum BehaviorType
Public Enumeration BehaviorType
public enum class BehaviorType
type BehaviorType
Members
Member name | Value | Description
Invalid | 0 | BehaviorType is Invalid
Normal | 1 | BehaviorType is Normal
Bend | 2 | BehaviorType is Bend
Branch | 4 | BehaviorType is Branch
Intersection | 8 | BehaviorType is Intersection
Inline | 16 | BehaviorType is Inline
BreakInto | 32 | BehaviorType is Break Into
OrientToObject | 64 | BehaviorType is Orient to Object
OrientToCenterLine | 128 | BehaviorType is Orient to CenterLine
OrientToFace | 256 | BehaviorType is Orient to Face
SystemMember | 512 | BehaviorType is System Member
BaseObject | 1,024 | BehaviorType is Base Object
EndCap | 2,048 | BehaviorType is End Cap
Valve | 4,096 | BehaviorType is Valve
Flange | 8,192 | BehaviorType is Flange
MechanicalCoupling | 16,384 | BehaviorType is Mechanical Coupling
VerticalBend | 32,768 | BehaviorType is Vertical Bend
ElectricalBaseObject | 65,536 | BehaviorType is Electrical Base Object
Straight | 131,072 | BehaviorType is Straight
Flex | 262,144 | BehaviorType is Flex
Hanger | 524,288 | BehaviorType is Hanger
Flat_Tap | 1,048,576 | BehaviorType is a flat tap on flat surface, eg. rectangular straight or flat-side of oval straight
Coupling | 2,097,152 | BehaviorType is Coupling
Round_CentreLine_Tap | 4,194,304 | BehaviorType is a round centreline tap on round straight/pipe
Oval_CentreLine_Tap | 8,388,608 | BehaviorType is a round centreline tap on oval straight
Damper | 16,777,216 | BehaviorType is a round centreline tap on oval straight
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


BendingDetailPositionOptions Enumeration

An enumerated type listing the bending detail position options supported by the Bending Detail.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum BendingDetailPositionOptions
Public Enumeration BendingDetailPositionOptions
public enum class BendingDetailPositionOptions
type BendingDetailPositionOptions
Members
Member name | Value | Description
Right | 0 | The bending detail position is at the right of the Bending Detial.
Left | 1 | The bending detail position is at the left of the Bending Detial.
Top | 2 | The bending detail position is at the top of the Bending Detial.
Bottom | 3 | The bending detail position is at the bottom of the Bending Detial.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


BIMExportOptions Class

The base class for options used to export using ATF.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBIMExportOptions
Autodesk.Revit.DBOBJExportOptions
Autodesk.Revit.DBSTEPExportOptions
Autodesk.Revit.DBSTLExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BIMExportOptions : IDisposable
Public Class BIMExportOptions
    Implements IDisposable
public ref class BIMExportOptions : IDisposable
type BIMExportOptions =
    class
        interface IDisposable
    end

The BIMExportOptions type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ViewId | The element id of the 3D view to export. InvalidElementId by default.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the BIMExportOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


BIMExportOptions Properties

The BIMExportOptions type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ViewId | The element id of the 3D view to export. InvalidElementId by default.
Top
See Also

Reference

BIMExportOptions Class


BIMExportOptions.IsValidObject Property

BIMExportOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

BIMExportOptions Class


BIMExportOptions.ViewId Property

BIMExportOptionsViewId Property

The element id of the 3D view to export. InvalidElementId by default.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId ViewId { get; set; }
Public Property ViewId As ElementId
    Get
    Set
public:
property ElementId^ ViewId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member ViewId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

BIMExportOptions Class


BIMExportOptions Methods

The BIMExportOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

BIMExportOptions Class


BIMExportOptions.Dispose Method

BIMExportOptionsDispose Method

Releases all resources used by the BIMExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

BIMExportOptions Class


Binding Class

Binding objects are used to take a parameter definition and bind it to one or more categories.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBBinding
Autodesk.Revit.DBElementBinding

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class Binding : APIObject
Public MustInherit Class Binding
    Inherits APIObject
public ref class Binding abstract : public APIObject
[<AbstractClassAttribute>]
type Binding =
    class
        inherit APIObject
    end

The Binding type exposes the following members.

Properties
Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This class is a base class for all types of parameter binding within Autodesk Revit. Once the binding objects are created and added to the document parameters will be added to elements in those categories specified in the binding. There are currently two types of binding available, Instance binding and Type binding. The key difference between the two is that the instance bound parameters appear on all instances of the elements in those categories. Changing the parameter on one does not affect the other instances of the parameter. The Type bound parameters appear only on the type object and is shared by all the instances that use that type. Changing the type bound parameter affects all instances of the elements that use that type. Note, a definition can only be bound to an instance or a type and not both.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Binding Properties

The Binding type exposes the following members.

Properties
Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

Binding Class


Binding Methods

The Binding type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Binding Class


BindingMap Class

The parameters BindingMap contains all the parameter bindings that exist in the Autodesk Revit project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBDefinitionBindingMap
Autodesk.Revit.DBBindingMap

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BindingMap : DefinitionBindingMap
Public Class BindingMap
    Inherits DefinitionBindingMap
public ref class BindingMap : public DefinitionBindingMap
type BindingMap =
    class
        inherit DefinitionBindingMap
    end

The BindingMap type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the map is empty. (Inherited from DefinitionBindingMap)
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | The get_Item method will get the binding item related to the input key. (Overrides DefinitionBindingMapItemDefinition)
Public property | Size | Returns the number of bindings that are in the map. (Inherited from DefinitionBindingMap)
Top
Methods
 | Name | Description
Public method | Clear | This method is used to remove all the items in the map. (Overrides DefinitionBindingMapClear)
Public method | Contains | The Contains method is used to check if the parameter binding exists for one definition. (Overrides DefinitionBindingMapContains(Definition))
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase | This method is used to erase one item in the map. (Overrides DefinitionBindingMapErase(Definition))
Public method | ForwardIterator | Retrieve a forward moving iterator to the map. (Inherited from DefinitionBindingMap)
Public method | GetEnumerator | Retrieve a forward moving iterator to the map. (Inherited from DefinitionBindingMap)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert(Definition, Binding) | Creates a new parameter binding between a parameter and a set of categories. (Overrides DefinitionBindingMapInsert(Definition, Binding))
Public method | Insert(Definition, Binding, ForgeTypeId) | Creates a new parameter binding between a parameter and a set of categories in a specified group.
Public method | ReInsert(Definition, Binding) | Removes an existing parameter and creates a new binding for a given parameter.
Public method | ReInsert(Definition, Binding, ForgeTypeId) | Removes an existing parameter and creates a new binding for a given parameter in a specified group.
Public method | Remove | The Remove method is used to remove a parameter binding.
Public method | ReverseIterator | Retrieve a backward moving iterator to the map. (Inherited from DefinitionBindingMap)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The ParameterBindingsMap is available from the Document.ParameterBindings property. A parameter binding is the way that a parameter definition is bound to elements within one or more categories. This map can be used to interrogate existing bindings, but it can also be used to generate new parameter bindings by using the Insert method.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


BindingMap Properties

The BindingMap type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the map is empty. (Inherited from DefinitionBindingMap)
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | The get_Item method will get the binding item related to the input key. (Overrides DefinitionBindingMapItemDefinition)
Public property | Size | Returns the number of bindings that are in the map. (Inherited from DefinitionBindingMap)
Top
See Also

Reference

BindingMap Class


BindingMap.Item Property

BindingMapItem Property

The get_Item method will get the binding item related to the input key.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Binding this[
    Definition key
] { get; set; }
Public Overrides Property Item (
    key As Definition
) As Binding
    Get
    Set
public:
virtual property Binding^ Item[Definition^ key] {
    Binding^ get (Definition^ key) override;
    void set (Definition^ key, Binding^ value) override;
}
abstract Item : Binding with get, set
override Item : Binding with get, set

Parameters

key Definition
A parameter definition which can be an existing definition or one from a shared parameters file.

Property Value

Binding
The returned value of get_Item is an InstanceBinding or TypeBinding object that contains the set of categories to which the parameter is bound. The input item is an InstanceBinding or TypeBinding object which contains the set of categories to which the parameter should be bound.
Remarks
set_Item is not permitted for this class. A Autodesk::Revit::Exceptions::InvalidOperationException will be thrown. Instead use Insert, Remove and ReInsert to modify the bindings in the document.
See Also

Reference

BindingMap Class


BindingMap Methods

The BindingMap type exposes the following members.

Methods
 | Name | Description
Public method | Clear | This method is used to remove all the items in the map. (Overrides DefinitionBindingMapClear)
Public method | Contains | The Contains method is used to check if the parameter binding exists for one definition. (Overrides DefinitionBindingMapContains(Definition))
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase | This method is used to erase one item in the map. (Overrides DefinitionBindingMapErase(Definition))
Public method | ForwardIterator | Retrieve a forward moving iterator to the map. (Inherited from DefinitionBindingMap)
Public method | GetEnumerator | Retrieve a forward moving iterator to the map. (Inherited from DefinitionBindingMap)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert(Definition, Binding) | Creates a new parameter binding between a parameter and a set of categories. (Overrides DefinitionBindingMapInsert(Definition, Binding))
Public method | Insert(Definition, Binding, ForgeTypeId) | Creates a new parameter binding between a parameter and a set of categories in a specified group.
Public method | ReInsert(Definition, Binding) | Removes an existing parameter and creates a new binding for a given parameter.
Public method | ReInsert(Definition, Binding, ForgeTypeId) | Removes an existing parameter and creates a new binding for a given parameter in a specified group.
Public method | Remove | The Remove method is used to remove a parameter binding.
Public method | ReverseIterator | Retrieve a backward moving iterator to the map. (Inherited from DefinitionBindingMap)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

BindingMap Class


BindingMap.Clear Method

BindingMapClear Method

This method is used to remove all the items in the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void Clear()
Public Overrides Sub Clear
public:
virtual void Clear() override
abstract Clear : unit -> unit
override Clear : unit -> unit
Remarks
The method Clear inherited from base class is not permitted for this class. A Autodesk::Revit::Exceptions::InvalidOperationException will be thrown.
See Also

Reference

BindingMap Class


BindingMap.Contains Method

BindingMapContains Method

The Contains method is used to check if the parameter binding exists for one definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool Contains(
    Definition key
)
Public Overrides Function Contains (
    key As Definition
) As Boolean
public:
virtual bool Contains(
    Definition^ key
) override
abstract Contains :
        key : Definition -> bool
override Contains :
        key : Definition -> bool

Parameters

key Definition
A parameter definition which can be an existing definition or one from a shared parameters file.

Return Value

Boolean
See Also

Reference

BindingMap Class


BindingMap.Erase Method

BindingMapErase Method

This method is used to erase one item in the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int Erase(
    Definition key
)
Public Overrides Function Erase (
    key As Definition
) As Integer
public:
virtual int Erase(
    Definition^ key
) override
abstract Erase :
        key : Definition -> int
override Erase :
        key : Definition -> int

Parameters

key Definition

Return Value

Int32
Remarks
The method Erase inherited from base class is not permitted for this class. A Autodesk::Revit::Exceptions::InvalidOperationException will be thrown. Use Remove() instead to remove the binding from the Revit session and from the map.
See Also

Reference

BindingMap Class


BindingMap.Insert Method

BindingMapInsert Method

Creates a new parameter binding.
Overload List
 | Name | Description
Public method | Insert(Definition, Binding) | Creates a new parameter binding between a parameter and a set of categories.
Public method | Insert(Definition, Binding, ForgeTypeId) | Creates a new parameter binding between a parameter and a set of categories in a specified group.
Top
See Also

Reference

BindingMap Class


BindingMap.Insert(Definition, Binding) Method

BindingMapInsert(Definition, Binding) Method

Creates a new parameter binding between a parameter and a set of categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool Insert(
    Definition key,
    Binding item
)
Public Overrides Function Insert (
    key As Definition,
    item As Binding
) As Boolean
public:
virtual bool Insert(
    Definition^ key,
    Binding^ item
) override
abstract Insert :
        key : Definition *
        item : Binding -> bool
override Insert :
        key : Definition *
        item : Binding -> bool

Parameters

key Definition
A parameter definition which can be an existing definition or one from a shared parameters file.
item Binding
An InstanceBinding or TypeBinding object which contains the set of categories to which the parameter should be bound.

Return Value

Boolean
Remarks
Note the type of the binding object dictates whether the parameter is bound to all instances or just types. A parameter definition cannot be bound to both instances and types. If the parameter binding already exists, post an error and return false.
See Also

Reference

BindingMap Class
Insert Overload


BindingMap.Insert(Definition, Binding, ForgeTypeId) Method

BindingMapInsert(Definition, Binding, ForgeTypeId) Method

Creates a new parameter binding between a parameter and a set of categories in a specified group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Insert(
    Definition key,
    Binding item,
    ForgeTypeId groupTypeId
)
Public Overridable Function Insert (
    key As Definition,
    item As Binding,
    groupTypeId As ForgeTypeId
) As Boolean
public:
virtual bool Insert(
    Definition^ key,
    Binding^ item,
    ForgeTypeId^ groupTypeId
)
abstract Insert :
        key : Definition *
        item : Binding *
        groupTypeId : ForgeTypeId -> bool
override Insert :
        key : Definition *
        item : Binding *
        groupTypeId : ForgeTypeId -> bool

Parameters

key Definition
A parameter definition which can be an existing definition or one from a shared parameters file.
item Binding
An InstanceBinding or TypeBinding object which contains the set of categories to which the parameter should be bound.
groupTypeId ForgeTypeId
The identifier of the parameter definition's parameter group, or empty if the parameter is not to be associated with any predefined group.

Return Value

Boolean
Remarks
Note the type of the binding object dictates whether the parameter is bound to all instances or just types. A parameter definition cannot be bound to both instances and types. If the Parameter binding already exists, post an error and return false
See Also

Reference

BindingMap Class
Insert Overload


BindingMap.ReInsert Method

BindingMapReInsert Method

Removes an existing parameter and creates a new binding for a given parameter.
Overload List
 | Name | Description
Public method | ReInsert(Definition, Binding) | Removes an existing parameter and creates a new binding for a given parameter.
Public method | ReInsert(Definition, Binding, ForgeTypeId) | Removes an existing parameter and creates a new binding for a given parameter in a specified group.
Top
See Also

Reference

BindingMap Class


BindingMap.ReInsert(Definition, Binding) Method

BindingMapReInsert(Definition, Binding) Method

Removes an existing parameter and creates a new binding for a given parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ReInsert(
    Definition key,
    Binding item
)
Public Overridable Function ReInsert (
    key As Definition,
    item As Binding
) As Boolean
public:
virtual bool ReInsert(
    Definition^ key,
    Binding^ item
)
abstract ReInsert :
        key : Definition *
        item : Binding -> bool
override ReInsert :
        key : Definition *
        item : Binding -> bool

Parameters

key Definition
A parameter definition which can be an existing definition or one from a shared parameters file.
item Binding
An InstanceBinding or TypeBinding object which contains the set of categories to which the parameter should be bound.

Return Value

Boolean
Remarks
Note the type of the binding object dictates whether the parameter is bound to all instances or just types. A parameter definition cannot be bound to both instances and types. If the parameter binding already exists, remove the binding, create a new parameter binding.
See Also

Reference

BindingMap Class
ReInsert Overload


BindingMap.ReInsert(Definition, Binding, ForgeTypeId) Method

BindingMapReInsert(Definition, Binding, ForgeTypeId) Method

Removes an existing parameter and creates a new binding for a given parameter in a specified group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool ReInsert(
    Definition key,
    Binding item,
    ForgeTypeId groupTypeId
)
Public Overridable Function ReInsert (
    key As Definition,
    item As Binding,
    groupTypeId As ForgeTypeId
) As Boolean
public:
virtual bool ReInsert(
    Definition^ key,
    Binding^ item,
    ForgeTypeId^ groupTypeId
)
abstract ReInsert :
        key : Definition *
        item : Binding *
        groupTypeId : ForgeTypeId -> bool
override ReInsert :
        key : Definition *
        item : Binding *
        groupTypeId : ForgeTypeId -> bool

Parameters

key Definition
A parameter definition which can be an existing definition or one from a shared parameters file.
item Binding
An InstanceBinding or TypeBinding object which contains the set of categories to which the parameter should be bound.
groupTypeId ForgeTypeId
The identifier of the parameter definition's parameter group, or empty if the parameter is not to be associated with any predefined group.

Return Value

Boolean
Remarks
Note the type of the binding object dictates whether the parameter is bound to all instances or just types. A parameter definition cannot be bound to both instances and types. If the parameter binding already exists, remove the binding, create a new parameter binding. If the parameter binding related to the input key doesn't exist in the database, ReInsert will fail and false will be returned. In this case, Insert should be called.
See Also

Reference

BindingMap Class
ReInsert Overload


BindingMap.Remove Method

BindingMapRemove Method

The Remove method is used to remove a parameter binding.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Remove(
    Definition key
)
Public Overridable Function Remove (
    key As Definition
) As Boolean
public:
virtual bool Remove(
    Definition^ key
)
abstract Remove :
        key : Definition -> bool
override Remove :
        key : Definition -> bool

Parameters

key Definition
A parameter definition which can be an existing definition or one from a shared parameters file.

Return Value

Boolean
See Also

Reference

BindingMap Class


Blend Class

A blend solid or void form.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBCombinableElement
Autodesk.Revit.DBGenericForm
Autodesk.Revit.DBBlend

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Blend : GenericForm
Public Class Blend
    Inherits GenericForm
public ref class Blend : public GenericForm
type Blend =
    class
        inherit GenericForm
    end

The Blend type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | BottomOffset | The offset of the bottom end of the blend relative to the sketch plane.
Public property | BottomProfile | The curves which make up the bottom profile of the sketch.
Public property | BottomSketch | Returns the Bottom Sketch of the Blend.
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Get and Set the Name property (Inherited from GenericForm)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Subcategory | The subcategory. (Inherited from GenericForm)
Public property | TopOffset | The offset of the top end of the blend relative to the sketch plane.
Public property | TopProfile | The curves which make up the top profile of the sketch.
Public property | TopSketch | Returns the Top Sketch of the Blend.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetVertexConnectionMap | Gets the mapping between the vertices in the top and bottom profiles.
Public method | GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetVertexConnectionMap | Sets the mapping between the vertices in the top and bottom profiles.
Public method | SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Blend Properties

The Blend type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | BottomOffset | The offset of the bottom end of the blend relative to the sketch plane.
Public property | BottomProfile | The curves which make up the bottom profile of the sketch.
Public property | BottomSketch | Returns the Bottom Sketch of the Blend.
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Get and Set the Name property (Inherited from GenericForm)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Subcategory | The subcategory. (Inherited from GenericForm)
Public property | TopOffset | The offset of the top end of the blend relative to the sketch plane.
Public property | TopProfile | The curves which make up the top profile of the sketch.
Public property | TopSketch | Returns the Top Sketch of the Blend.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

Blend Class


Blend.BottomOffset Property

BlendBottomOffset Property

The offset of the bottom end of the blend relative to the sketch plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double BottomOffset { get; set; }
Public Property BottomOffset As Double
    Get
    Set
public:
property double BottomOffset {
    double get ();
    void set (double value);
}
member BottomOffset : float with get, set

Property Value

Double
See Also

Reference

Blend Class


Blend.BottomProfile Property

BlendBottomProfile Property

The curves which make up the bottom profile of the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurveArrArray BottomProfile { get; }
Public ReadOnly Property BottomProfile As CurveArrArray
    Get
public:
property CurveArrArray^ BottomProfile {
    CurveArrArray^ get ();
}
member BottomProfile : CurveArrArray with get

Property Value

CurveArrArray
Remarks
The indices of the curves in this array match the indices used in the vertex connection map.
See Also

Reference

Blend Class


Blend.BottomSketch Property

BlendBottomSketch Property

Returns the Bottom Sketch of the Blend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Sketch BottomSketch { get; }
Public ReadOnly Property BottomSketch As Sketch
    Get
public:
property Sketch^ BottomSketch {
    Sketch^ get ();
}
member BottomSketch : Sketch with get

Property Value

Sketch
Remarks
This property is used to retrieve the Bottom Sketch of the Blend.
See Also

Reference

Blend Class


Blend.TopOffset Property

BlendTopOffset Property

The offset of the top end of the blend relative to the sketch plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double TopOffset { get; set; }
Public Property TopOffset As Double
    Get
    Set
public:
property double TopOffset {
    double get ();
    void set (double value);
}
member TopOffset : float with get, set

Property Value

Double
See Also

Reference

Blend Class


Blend.TopProfile Property

BlendTopProfile Property

The curves which make up the top profile of the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurveArrArray TopProfile { get; }
Public ReadOnly Property TopProfile As CurveArrArray
    Get
public:
property CurveArrArray^ TopProfile {
    CurveArrArray^ get ();
}
member TopProfile : CurveArrArray with get

Property Value

CurveArrArray
Remarks
The indices of the curves in this array match the indices used in the vertex connection map.
See Also

Reference

Blend Class


Blend.TopSketch Property

BlendTopSketch Property

Returns the Top Sketch of the Blend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Sketch TopSketch { get; }
Public ReadOnly Property TopSketch As Sketch
    Get
public:
property Sketch^ TopSketch {
    Sketch^ get ();
}
member TopSketch : Sketch with get

Property Value

Sketch
Remarks
This property is used to retrieve the Top Sketch of the Blend.
See Also

Reference

Blend Class


Blend Methods

The Blend type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetVertexConnectionMap | Gets the mapping between the vertices in the top and bottom profiles.
Public method | GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetVertexConnectionMap | Sets the mapping between the vertices in the top and bottom profiles.
Public method | SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Blend Class


Blend.GetVertexConnectionMap Method

BlendGetVertexConnectionMap Method

Gets the mapping between the vertices in the top and bottom profiles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VertexIndexPairArray GetVertexConnectionMap()
Public Function GetVertexConnectionMap As VertexIndexPairArray
public:
VertexIndexPairArray^ GetVertexConnectionMap()
member GetVertexConnectionMap : unit -> VertexIndexPairArray

Return Value

VertexIndexPairArray
Remarks
Each vertex refers to the start point of the curve from the top and bottom profiles.
See Also

Reference

Blend Class


Blend.SetVertexConnectionMap Method

BlendSetVertexConnectionMap Method

Sets the mapping between the vertices in the top and bottom profiles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetVertexConnectionMap(
    VertexIndexPairArray vertexMap
)
Public Sub SetVertexConnectionMap (
    vertexMap As VertexIndexPairArray
)
public:
void SetVertexConnectionMap(
    VertexIndexPairArray^ vertexMap
)
member SetVertexConnectionMap :
        vertexMap : VertexIndexPairArray -> unit

Parameters

vertexMap VertexIndexPairArray
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument-"vertexMap"-is .
ArgumentException | Thrown if the input argument-"vertexMap"-is empty.
InvalidOperationException | Thrown when the document failed to regenerate.
See Also

Reference

Blend Class


BooleanOperationsType Enumeration

An enumerated type listing boolean types that are supported for boolean operation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum BooleanOperationsType
Public Enumeration BooleanOperationsType
public enum class BooleanOperationsType
type BooleanOperationsType
Members
Member name | Value | Description
Union | 0 | Union.
Difference | 1 | Difference.
Intersect | 2 | Intersect.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


BooleanOperationsUtils Class

These utilities are applicable for the geometry created by GeometryCreationUtilities and the geometry of Revit model.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBooleanOperationsUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BooleanOperationsUtils : IDisposable
Public Class BooleanOperationsUtils
    Implements IDisposable
public ref class BooleanOperationsUtils : IDisposable
type BooleanOperationsUtils =
    class
        interface IDisposable
    end

The BooleanOperationsUtils type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
 | CutWithHalfSpace | Creates a new Solid which is the intersection of the input Solid with the half-space on the positive side of the given Plane. The positive side of the plane is the side to which Plane.Normal points.
 | CutWithHalfSpaceModifyingOriginalSolid | Modifies the input Solid preserving only the volume on the positive side of the given Plane. The positive side of the plane is the side to which Plane.Normal points.
Public method | Dispose | Releases all resources used by the BooleanOperationsUtils
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | ExecuteBooleanOperation | Perform a boolean geometric operation between two solids, and return a new solid to represent the result.
 | ExecuteBooleanOperationModifyingOriginalSolid | Perform a boolean geometric operation between two solids, and modify the original solid to represent the result.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


BooleanOperationsUtils Properties

The BooleanOperationsUtils type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

BooleanOperationsUtils Class


BooleanOperationsUtils.IsValidObject Property

BooleanOperationsUtilsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

BooleanOperationsUtils Class


BooleanOperationsUtils Methods

The BooleanOperationsUtils type exposes the following members.

Methods
 | Name | Description
 | CutWithHalfSpace | Creates a new Solid which is the intersection of the input Solid with the half-space on the positive side of the given Plane. The positive side of the plane is the side to which Plane.Normal points.
 | CutWithHalfSpaceModifyingOriginalSolid | Modifies the input Solid preserving only the volume on the positive side of the given Plane. The positive side of the plane is the side to which Plane.Normal points.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | ExecuteBooleanOperation | Perform a boolean geometric operation between two solids, and return a new solid to represent the result.
 | ExecuteBooleanOperationModifyingOriginalSolid | Perform a boolean geometric operation between two solids, and modify the original solid to represent the result.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

BooleanOperationsUtils Class


BooleanOperationsUtils.CutWithHalfSpace Method

BooleanOperationsUtilsCutWithHalfSpace Method

Creates a new Solid which is the intersection of the input Solid with the half-space on the positive side of the given Plane. The positive side of the plane is the side to which Plane.Normal points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Solid CutWithHalfSpace(
    Solid solid,
    Plane plane
)
Public Shared Function CutWithHalfSpace (
    solid As Solid,
    plane As Plane
) As Solid
public:
static Solid^ CutWithHalfSpace(
    Solid^ solid,
    Plane^ plane
)
static member CutWithHalfSpace :
        solid : Solid *
        plane : Plane -> Solid

Parameters

solid Solid
The input Solid to be cut.
plane Plane
The cut plane. The space on the positive side of the normal of the plane will be intersected with the input Solid.

Return Value

Solid
The newly created Solid.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

BooleanOperationsUtils Class


BooleanOperationsUtils.CutWithHalfSpaceModifyingOriginalSolid Method

BooleanOperationsUtilsCutWithHalfSpaceModifyingOriginalSolid Method

Modifies the input Solid preserving only the volume on the positive side of the given Plane. The positive side of the plane is the side to which Plane.Normal points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void CutWithHalfSpaceModifyingOriginalSolid(
    Solid solid,
    Plane plane
)
Public Shared Sub CutWithHalfSpaceModifyingOriginalSolid (
    solid As Solid,
    plane As Plane
)
public:
static void CutWithHalfSpaceModifyingOriginalSolid(
    Solid^ solid,
    Plane^ plane
)
static member CutWithHalfSpaceModifyingOriginalSolid :
        solid : Solid *
        plane : Plane -> unit

Parameters

solid Solid
The input Solid to be cut. This object cannot be obtained directly from a Revit element. This means that IsElementGeometry cannot be true.
plane Plane
The cut plane. The space on the positive side of the normal of the plane will be intersected with the input Solid.
Exceptions
Exception | Condition
ArgumentException | Thrown when the original solid object is the geometry of the Revit model.
ArgumentNullException | A non-optional argument was NULL
Remarks
This operation modifies the original input Geometry objects.
See Also

Reference

BooleanOperationsUtils Class


BooleanOperationsUtils.Dispose Method

BooleanOperationsUtilsDispose Method

Releases all resources used by the BooleanOperationsUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

BooleanOperationsUtils Class


BooleanOperationsUtils.ExecuteBooleanOperation Method

BooleanOperationsUtilsExecuteBooleanOperation Method

Perform a boolean geometric operation between two solids, and return a new solid to represent the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Solid ExecuteBooleanOperation(
    Solid solid0,
    Solid solid1,
    BooleanOperationsType booleanType
)
Public Shared Function ExecuteBooleanOperation (
    solid0 As Solid,
    solid1 As Solid,
    booleanType As BooleanOperationsType
) As Solid
public:
static Solid^ ExecuteBooleanOperation(
    Solid^ solid0,
    Solid^ solid1,
    BooleanOperationsType booleanType
)
static member ExecuteBooleanOperation :
        solid0 : Solid *
        solid1 : Solid *
        booleanType : BooleanOperationsType -> Solid

Parameters

solid0 Solid
The first solid object. A copy will be taken of the input object, so any solid whether obtained from a Revit element or not would be accepted.
solid1 Solid
The second solid object. A copy will be taken of the input object, so any solid whether obtained from a Revit element or not would be accepted.
booleanType BooleanOperationsType
boolean operation type.

Return Value

Solid
The result geometry.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | Failed to perform the Boolean operation for the two solids. This may be due to geometric inaccuracies in the solids, such as slightly misaligned faces or edges. If so, eliminating the inaccuracies by making sure the solids are accurately aligned may solve the problem. This also may be due to one or both solids having complexities such as more than two faces geometrically meeting along a single edge, or two coincident edges, etc. Eliminating such conditions, or performing a sequence of Boolean operations in an order that avoids such conditions, may solve the problem.
Example
C#
VB
C++
F#
Copy
private void ComputeIntersectionVolume(Solid solidA, Solid solidB)
{
    Solid intersection = BooleanOperationsUtils.ExecuteBooleanOperation(solidA, solidB, BooleanOperationsType.Intersect);
    double volumeOfIntersection = intersection.Volume;
}
Private Sub ComputeIntersectionVolume(solidA As Solid, solidB As Solid)
    Dim intersection As Solid = BooleanOperationsUtils.ExecuteBooleanOperation(solidA, solidB, BooleanOperationsType.Intersect)
    Dim volumeOfIntersection As Double = intersection.Volume
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

BooleanOperationsUtils Class


BooleanOperationsUtils.ExecuteBooleanOperationModifyingOriginalSolid Method

BooleanOperationsUtilsExecuteBooleanOperationModifyingOriginalSolid Method

Perform a boolean geometric operation between two solids, and modify the original solid to represent the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void ExecuteBooleanOperationModifyingOriginalSolid(
    Solid solid0,
    Solid solid1,
    BooleanOperationsType booleanType
)
Public Shared Sub ExecuteBooleanOperationModifyingOriginalSolid (
    solid0 As Solid,
    solid1 As Solid,
    booleanType As BooleanOperationsType
)
public:
static void ExecuteBooleanOperationModifyingOriginalSolid(
    Solid^ solid0,
    Solid^ solid1,
    BooleanOperationsType booleanType
)
static member ExecuteBooleanOperationModifyingOriginalSolid :
        solid0 : Solid *
        solid1 : Solid *
        booleanType : BooleanOperationsType -> unit

Parameters

solid0 Solid
The original solid object. This object cannot be obtained directly from a Revit element. This means that IsElementGeometry cannot be true.
solid1 Solid
The second solid object. A copy will be taken of the input object, so any solid whether obtained from a Revit element or not would be accepted.
booleanType BooleanOperationsType
boolean operation type.
Exceptions
Exception | Condition
ArgumentException | Thrown when the original solid object is the geometry of the Revit model.
ArgumentNullException | A non-optional argument was NULL
InvalidOperationException | Failed to perform the Boolean operation for the two solids. This may be due to geometric inaccuracies in the solids, such as slightly misaligned faces or edges. If so, eliminating the inaccuracies by making sure the solids are accurately aligned may solve the problem. This also may be due to one or both solids having complexities such as more than two faces geometrically meeting along a single edge, or two coincident edges, etc. Eliminating such conditions, or performing a sequence of Boolean operations in an order that avoids such conditions, may solve the problem."
Remarks
This operation modifies the original input Geometry objects.
See Also

Reference

BooleanOperationsUtils Class


BorderTile Enumeration

Options for controlling tiles that overlap the face boundary. See DividedSurface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum BorderTile
Public Enumeration BorderTile
public enum class BorderTile
type BorderTile
Members
Member name | Value | Description
Empty | 0 |
Partial | 1 |
Overhanging | 2 |
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


BoundarySegment Class

An object that represents a segment of an area boundary.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBoundarySegment

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BoundarySegment : IDisposable
Public Class BoundarySegment
    Implements IDisposable
public ref class BoundarySegment : IDisposable
type BoundarySegment =
    class
        interface IDisposable
    end

The BoundarySegment type exposes the following members.

Properties
 | Name | Description
Public property | ElementId | Retrieve the id of the element that produces this boundary segment. If the segment is created from an element in a link, this is the id of the RevitLinkInstance.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LinkElementId | Retrieve the element id of the element in a link instance that forms this boundary.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the BoundarySegment
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCurve | Get a copy of the curve that is formed along this boundary.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
These objects define the exterior boundary of an area. The geometry of the segment can be retrieved along with the id of the element that is responsible for producing that boundary.
Example
C#
VB
C++
F#
Copy
public void GetInfo_BoundarySegment(Room room)
{
   IList<IList<Autodesk.Revit.DB.BoundarySegment>> segments = room.GetBoundarySegments(new SpatialElementBoundaryOptions());

   if (null != segments)  //the room may not be bound
   {
      string message = "BoundarySegment";
      foreach (IList<Autodesk.Revit.DB.BoundarySegment> segmentList in segments)
      {
         foreach (Autodesk.Revit.DB.BoundarySegment boundarySegment in segmentList)
         {

            // Get curve start point
            message += "\nCurve start point: (" + boundarySegment.GetCurve().GetEndPoint(0).X + ","
                           + boundarySegment.GetCurve().GetEndPoint(0).Y + "," +
                          boundarySegment.GetCurve().GetEndPoint(0).Z + ")";
            // Get curve end point
            message += ";\nCurve end point: (" + boundarySegment.GetCurve().GetEndPoint(1).X + ","
                 + boundarySegment.GetCurve().GetEndPoint(1).Y + "," +
                 boundarySegment.GetCurve().GetEndPoint(1).Z + ")";
            // Get document path name
            message += ";\nDocument path name: " + room.Document.PathName;
            // Get boundary segment element name
            if (boundarySegment.ElementId != ElementId.InvalidElementId)
            {
               message += ";\nElement name: " + room.Document.GetElement(boundarySegment.ElementId).Name;
            }
         }
      }
      TaskDialog.Show("Revit",message);
   }
}
Public Sub GetInfo_BoundarySegment(room As Room)
    Dim segments As IList(Of IList(Of Autodesk.Revit.DB.BoundarySegment)) = room.GetBoundarySegments(New SpatialElementBoundaryOptions())

    If segments IsNot Nothing Then
        'the room may not be bound
        Dim message As String = "BoundarySegment"
        For Each segmentList As IList(Of Autodesk.Revit.DB.BoundarySegment) In segments
            For Each boundarySegment As Autodesk.Revit.DB.BoundarySegment In segmentList

          ' Get curve start point
          message += ((vbLf & "Curve start point: (" + boundarySegment.GetCurve().GetEndPoint(0).X & ",") + boundarySegment.GetCurve().GetEndPoint(0).Y & ",") + boundarySegment.GetCurve().GetEndPoint(0).Z & ")"
          ' Get curve end point
          message += ((";" & vbLf & "Curve end point: (" + boundarySegment.GetCurve().GetEndPoint(1).X & ",") + boundarySegment.GetCurve().GetEndPoint(1).Y & ",") + boundarySegment.GetCurve().GetEndPoint(1).Z & ")"
          ' Get document path name
          message += ";" & vbLf & "Document path name: " + room.Document.PathName
          ' Get boundary segment element name
          If boundarySegment.ElementId IsNot ElementId.InvalidElementId Then
             message += ";" & vbLf & "Element name: " + room.Document.GetElement(boundarySegment.ElementId).Name
          End If

            Next
        Next
        TaskDialog.Show("Revit", message)
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


BoundarySegment Properties

The BoundarySegment type exposes the following members.

Properties
 | Name | Description
Public property | ElementId | Retrieve the id of the element that produces this boundary segment. If the segment is created from an element in a link, this is the id of the RevitLinkInstance.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LinkElementId | Retrieve the element id of the element in a link instance that forms this boundary.
Top
See Also

Reference

BoundarySegment Class


BoundarySegment.ElementId Property

BoundarySegmentElementId Property

Retrieve the id of the element that produces this boundary segment. If the segment is created from an element in a link, this is the id of the RevitLinkInstance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId ElementId { get; }
Public ReadOnly Property ElementId As ElementId
    Get
public:
property ElementId^ ElementId {
    ElementId^ get ();
}
member ElementId : ElementId with get

Property Value

ElementId
See Also

Reference

BoundarySegment Class


BoundarySegment.IsValidObject Property

BoundarySegmentIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

BoundarySegment Class


BoundarySegment.LinkElementId Property

BoundarySegmentLinkElementId Property

Retrieve the element id of the element in a link instance that forms this boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId LinkElementId { get; }
Public ReadOnly Property LinkElementId As ElementId
    Get
public:
property ElementId^ LinkElementId {
    ElementId^ get ();
}
member LinkElementId : ElementId with get

Property Value

ElementId
See Also

Reference

BoundarySegment Class


BoundarySegment Methods

The BoundarySegment type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCurve | Get a copy of the curve that is formed along this boundary.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

BoundarySegment Class


BoundarySegment.Dispose Method

BoundarySegmentDispose Method

Releases all resources used by the BoundarySegment

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

BoundarySegment Class


BoundarySegment.GetCurve Method

BoundarySegmentGetCurve Method

Get a copy of the curve that is formed along this boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Curve GetCurve()
Public Function GetCurve As Curve
public:
Curve^ GetCurve()
member GetCurve : unit -> Curve

Return Value

Curve
A copy of the curve.
See Also

Reference

BoundarySegment Class


BoundaryValidation Class

Curve loop validators.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBoundaryValidation

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BoundaryValidation : IDisposable
Public Class BoundaryValidation
    Implements IDisposable
public ref class BoundaryValidation : IDisposable
type BoundaryValidation =
    class
        interface IDisposable
    end

The BoundaryValidation type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the BoundaryValidation
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | IsValidBoundaryOnSketchPlane | Indicates if the given curve loops compose a valid boundary on the sketch plane.
 | IsValidBoundaryOnView | Indicates if the given curve loops compose a valid boundary on the view's detail sketch plane.
 | IsValidHorizontalBoundary | Identifies whether the given curve loops compose a valid horizontal boundary.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


BoundaryValidation Properties

The BoundaryValidation type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

BoundaryValidation Class


BoundaryValidation.IsValidObject Property

BoundaryValidationIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

BoundaryValidation Class


BoundaryValidation Methods

The BoundaryValidation type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | IsValidBoundaryOnSketchPlane | Indicates if the given curve loops compose a valid boundary on the sketch plane.
 | IsValidBoundaryOnView | Indicates if the given curve loops compose a valid boundary on the view's detail sketch plane.
 | IsValidHorizontalBoundary | Identifies whether the given curve loops compose a valid horizontal boundary.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

BoundaryValidation Class


BoundaryValidation.Dispose Method

BoundaryValidationDispose Method

Releases all resources used by the BoundaryValidation

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

BoundaryValidation Class


BoundaryValidation.IsValidBoundaryOnSketchPlane Method

BoundaryValidationIsValidBoundaryOnSketchPlane Method

Indicates if the given curve loops compose a valid boundary on the sketch plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidBoundaryOnSketchPlane(
    SketchPlane sketchPlane,
    IList<CurveLoop> curveLoops
)
Public Shared Function IsValidBoundaryOnSketchPlane (
    sketchPlane As SketchPlane,
    curveLoops As IList(Of CurveLoop)
) As Boolean
public:
static bool IsValidBoundaryOnSketchPlane(
    SketchPlane^ sketchPlane,
    IList<CurveLoop^>^ curveLoops
)
static member IsValidBoundaryOnSketchPlane :
        sketchPlane : SketchPlane *
        curveLoops : IList<CurveLoop> -> bool

Parameters

sketchPlane SketchPlane
The sketch plane.
curveLoops IList CurveLoop
The curve loops to be checked.

Return Value

Boolean
True if the given curve loops are valid as described above, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
The curve loops are valid if projections of the loops onto the sketch plane do not intersect each other; each curve loop is closed; input curves do not contain any helical curve; and each loop is planar and lies on a plane parallel to the sketch plane, but not necessarily the same plane.
See Also

Reference

BoundaryValidation Class


BoundaryValidation.IsValidBoundaryOnView Method

BoundaryValidationIsValidBoundaryOnView Method

Indicates if the given curve loops compose a valid boundary on the view's detail sketch plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidBoundaryOnView(
    Document document,
    ElementId viewId,
    IList<CurveLoop> curveLoops
)
Public Shared Function IsValidBoundaryOnView (
    document As Document,
    viewId As ElementId,
    curveLoops As IList(Of CurveLoop)
) As Boolean
public:
static bool IsValidBoundaryOnView(
    Document^ document,
    ElementId^ viewId,
    IList<CurveLoop^>^ curveLoops
)
static member IsValidBoundaryOnView :
        document : Document *
        viewId : ElementId *
        curveLoops : IList<CurveLoop> -> bool

Parameters

document Document
The document.
viewId ElementId
The view Id.
curveLoops IList CurveLoop
The curve loops to be checked.

Return Value

Boolean
True if the given curve loops are valid as described above, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
The curve loops are valid if projections of the loops onto the views's detail sketch plane do not intersect each other; each curve loop is closed; input curves do not contain any helical curve; and each loop is planar and lies on a plane parallel to the views's detail sketch plane, but not necessarily the same plane.
See Also

Reference

BoundaryValidation Class


BoundaryValidation.IsValidHorizontalBoundary Method

BoundaryValidationIsValidHorizontalBoundary Method

Identifies whether the given curve loops compose a valid horizontal boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidHorizontalBoundary(
    IList<CurveLoop> curveLoops
)
Public Shared Function IsValidHorizontalBoundary (
    curveLoops As IList(Of CurveLoop)
) As Boolean
public:
static bool IsValidHorizontalBoundary(
    IList<CurveLoop^>^ curveLoops
)
static member IsValidHorizontalBoundary :
        curveLoops : IList<CurveLoop> -> bool

Parameters

curveLoops IList CurveLoop
The curve loops to be checked.

Return Value

Boolean
True if the given curve loops are valid as described above, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
The curve loops are valid if projections of the loops onto a horizontal(XY) plane do not intersect each other; each curve loop is closed; input curves do not contain any helical curve; and each loop is planar and lies on a plane parallel to the horizontal(XY) plane, but not necessarily the same plane.
See Also

Reference

BoundaryValidation Class


BoundingBoxContainsPointFilter Class

A filter used to match elements with a bounding box that contains the given point.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementQuickFilter
Autodesk.Revit.DBBoundingBoxContainsPointFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BoundingBoxContainsPointFilter : ElementQuickFilter
Public Class BoundingBoxContainsPointFilter
    Inherits ElementQuickFilter
public ref class BoundingBoxContainsPointFilter : public ElementQuickFilter
type BoundingBoxContainsPointFilter =
    class
        inherit ElementQuickFilter
    end

The BoundingBoxContainsPointFilter type exposes the following members.

Constructors
 | Name | Description
Public method | BoundingBoxContainsPointFilter(XYZ) | Constructs a new instance of a filter to match elements with a bounding box that contains the given point.
Public method | BoundingBoxContainsPointFilter(XYZ, Boolean) | Constructs a new instance of a filter to match elements with a bounding box that contains the given point, with the option to invert the filter and match all elements with a bounding box that do not contain the given point.
Public method | BoundingBoxContainsPointFilter(XYZ, Double) | Constructs a new instance of a filter to match elements with a bounding box that contains the given point, while specifying the tolerance to be used in deciding if the point matches the criteria.
Public method | BoundingBoxContainsPointFilter(XYZ, Double, Boolean) | Constructs a new instance of a filter to match elements with a bounding box that contains the given point, while specifying the tolerance to be used in deciding if the point matches the criteria. This constructor includes the option to invert the filter and match all elements with a bounding box that do not contain the given point.
Top
Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Public property | Point | The XYZ point to use when matching element bounding boxes.
Public property | Tolerance | Allows control over the match criteria by using a tolerance in the geometry comparison. It is suggested to use this in cases where trivial differences should be considered when matching elements.
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This filter excludes all objects derived from View and objects derived from ElementType. This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.
Example
C#
VB
C++
F#
Copy
// Use BoundingBoxContainsPoint filter to find elements with a bounding box that contains the
// given point in the document.

// Create a BoundingBoxContainsPoint filter for base point of (0, 0, 0)
XYZ basePnt = new XYZ(0, 0, 0);
BoundingBoxContainsPointFilter filter = new BoundingBoxContainsPointFilter(basePnt);

// Apply the filter to the elements in the active document
// This filter will excludes all objects derived from View and objects derived from ElementType
FilteredElementCollector collector = new FilteredElementCollector(document);
IList<Element> elements = collector.WherePasses(filter).ToElements();

// Find walls that do not contain the given point: use an inverted filter to match elements
// Use shortcut command OfClass() to find walls only
BoundingBoxContainsPointFilter notContainFilter =
    new BoundingBoxContainsPointFilter(basePnt, true); // inverted filter
collector = new FilteredElementCollector(document);
IList<Element> notContainFounds =
    collector.OfClass(typeof(Wall)).WherePasses(notContainFilter).ToElements();
' Use BoundingBoxContainsPoint filter to find elements with a bounding box that contains the
' given point in the document.

' Create a BoundingBoxContainsPoint filter for base point of (0, 0, 0)
Dim basePnt As New XYZ(0, 0, 0)
Dim filter As New BoundingBoxContainsPointFilter(basePnt)

' Apply the filter to the elements in the active document
' This filter will excludes all objects derived from View and objects derived from ElementType
Dim collector As New FilteredElementCollector(document)
Dim elements As IList(Of Element) = collector.WherePasses(filter).ToElements()

' Find walls that do not contain the given point: use an inverted filter to match elements
' Use shortcut command OfClass() to find walls only
Dim notContainFilter As New BoundingBoxContainsPointFilter(basePnt, True)
' inverted filter
collector = New FilteredElementCollector(document)
Dim notContainFounds As IList(Of Element) = collector.OfClass(GetType(Wall)).WherePasses(notContainFilter).ToElements()

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


BoundingBoxContainsPointFilter Constructor

Overload List
 | Name | Description
Public method | BoundingBoxContainsPointFilter(XYZ) | Constructs a new instance of a filter to match elements with a bounding box that contains the given point.
Public method | BoundingBoxContainsPointFilter(XYZ, Boolean) | Constructs a new instance of a filter to match elements with a bounding box that contains the given point, with the option to invert the filter and match all elements with a bounding box that do not contain the given point.
Public method | BoundingBoxContainsPointFilter(XYZ, Double) | Constructs a new instance of a filter to match elements with a bounding box that contains the given point, while specifying the tolerance to be used in deciding if the point matches the criteria.
Public method | BoundingBoxContainsPointFilter(XYZ, Double, Boolean) | Constructs a new instance of a filter to match elements with a bounding box that contains the given point, while specifying the tolerance to be used in deciding if the point matches the criteria. This constructor includes the option to invert the filter and match all elements with a bounding box that do not contain the given point.
Top
See Also

Reference

BoundingBoxContainsPointFilter Class


BoundingBoxContainsPointFilter(XYZ) Constructor

Constructs a new instance of a filter to match elements with a bounding box that contains the given point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BoundingBoxContainsPointFilter(
    XYZ point
)
Public Sub New (
    point As XYZ
)
public:
BoundingBoxContainsPointFilter(
    XYZ^ point
)
new :
        point : XYZ -> BoundingBoxContainsPointFilter

Parameters

point XYZ
The point used to find elements with a bounding box that contains it.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

BoundingBoxContainsPointFilter Class
BoundingBoxContainsPointFilter Overload


BoundingBoxContainsPointFilter(XYZ, Boolean) Constructor

Constructs a new instance of a filter to match elements with a bounding box that contains the given point, with the option to invert the filter and match all elements with a bounding box that do not contain the given point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BoundingBoxContainsPointFilter(
    XYZ point,
    bool inverted
)
Public Sub New (
    point As XYZ,
    inverted As Boolean
)
public:
BoundingBoxContainsPointFilter(
    XYZ^ point,
    bool inverted
)
new :
        point : XYZ *
        inverted : bool -> BoundingBoxContainsPointFilter

Parameters

point XYZ
The point used to find elements with a bounding box containing it.
inverted Boolean
True if the filter should be inverted and match all elements with a bounding box that do not contain the given point.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

BoundingBoxContainsPointFilter Class
BoundingBoxContainsPointFilter Overload


BoundingBoxContainsPointFilter(XYZ, Double) Constructor

Constructs a new instance of a filter to match elements with a bounding box that contains the given point, while specifying the tolerance to be used in deciding if the point matches the criteria.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BoundingBoxContainsPointFilter(
    XYZ point,
    double tolerance
)
Public Sub New (
    point As XYZ,
    tolerance As Double
)
public:
BoundingBoxContainsPointFilter(
    XYZ^ point,
    double tolerance
)
new :
        point : XYZ *
        tolerance : float -> BoundingBoxContainsPointFilter

Parameters

point XYZ
The point used to find elements with a bounding box that contains it.
tolerance Double
The tolerance value to use instead of zero. See the tolerance property for details.
Exceptions
Exception | Condition
ArgumentException | The given value for tolerance is not finite -or- The given value for tolerance is not a number
ArgumentNullException | A non-optional argument was null
See Also

Reference

BoundingBoxContainsPointFilter Class
BoundingBoxContainsPointFilter Overload


BoundingBoxContainsPointFilter(XYZ, Double, Boolean) Constructor

Constructs a new instance of a filter to match elements with a bounding box that contains the given point, while specifying the tolerance to be used in deciding if the point matches the criteria. This constructor includes the option to invert the filter and match all elements with a bounding box that do not contain the given point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BoundingBoxContainsPointFilter(
    XYZ point,
    double tolerance,
    bool inverted
)
Public Sub New (
    point As XYZ,
    tolerance As Double,
    inverted As Boolean
)
public:
BoundingBoxContainsPointFilter(
    XYZ^ point,
    double tolerance,
    bool inverted
)
new :
        point : XYZ *
        tolerance : float *
        inverted : bool -> BoundingBoxContainsPointFilter

Parameters

point XYZ
The point used to find elements with a bounding box containing it.
tolerance Double
The tolerance value to use instead of zero. See the tolerance property for details.
inverted Boolean
True if the filter should be inverted and match all elements with a bounding box that do not contain the given point.
Exceptions
Exception | Condition
ArgumentException | The given value for tolerance is not finite -or- The given value for tolerance is not a number
ArgumentNullException | A non-optional argument was null
See Also

Reference

BoundingBoxContainsPointFilter Class
BoundingBoxContainsPointFilter Overload


BoundingBoxContainsPointFilter Properties

The BoundingBoxContainsPointFilter type exposes the following members.

Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Public property | Point | The XYZ point to use when matching element bounding boxes.
Public property | Tolerance | Allows control over the match criteria by using a tolerance in the geometry comparison. It is suggested to use this in cases where trivial differences should be considered when matching elements.
Top
See Also

Reference

BoundingBoxContainsPointFilter Class


BoundingBoxContainsPointFilter.Point Property

BoundingBoxContainsPointFilterPoint Property

The XYZ point to use when matching element bounding boxes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Point { get; set; }
Public Property Point As XYZ
    Get
    Set
public:
property XYZ^ Point {
    XYZ^ get ();
    void set (XYZ^ value);
}
member Point : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

BoundingBoxContainsPointFilter Class


BoundingBoxContainsPointFilter.Tolerance Property

BoundingBoxContainsPointFilterTolerance Property

Allows control over the match criteria by using a tolerance in the geometry comparison. It is suggested to use this in cases where trivial differences should be considered when matching elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Tolerance { get; set; }
Public Property Tolerance As Double
    Get
    Set
public:
property double Tolerance {
    double get ();
    void set (double value);
}
member Tolerance : float with get, set

Property Value

Double
Remarks
By default this is set to zero, but depending on your units of measure and how close objects may be, it is advised to set this to something more realistic. If the tolerance is positive, the point may lie up to the tolerance amount outside the outline to be matched. If the tolerance is negative, the point must lie at least the tolerance amount inside the outline to be matched.
See Also

Reference

BoundingBoxContainsPointFilter Class


BoundingBoxContainsPointFilter Methods

The BoundingBoxContainsPointFilter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

BoundingBoxContainsPointFilter Class


BoundingBoxIntersectsFilter Class

A filter used to match elements with a bounding box that intersects the given Outline.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementQuickFilter
Autodesk.Revit.DBBoundingBoxIntersectsFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BoundingBoxIntersectsFilter : ElementQuickFilter
Public Class BoundingBoxIntersectsFilter
    Inherits ElementQuickFilter
public ref class BoundingBoxIntersectsFilter : public ElementQuickFilter
type BoundingBoxIntersectsFilter =
    class
        inherit ElementQuickFilter
    end

The BoundingBoxIntersectsFilter type exposes the following members.

Constructors
 | Name | Description
Public method | BoundingBoxIntersectsFilter(Outline) | Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline.
Public method | BoundingBoxIntersectsFilter(Outline, Boolean) | Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline, with the option to invert the filter and match all elements with a bounding box that are not intersecting the given Outline.
Public method | BoundingBoxIntersectsFilter(Outline, Double) | Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline.
Public method | BoundingBoxIntersectsFilter(Outline, Double, Boolean) | Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline, with the option to invert the filter and match all elements with a bounding box that are not intersecting the given Outline.
Top
Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Public property | Tolerance | Allows control over the match criteria by using a tolerance in the geometry comparison. It is suggested to use this in cases where trivial differences should be considered when matching elements.
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBoundingBox | Gets the outline being used for this filter.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This filter excludes all objects derived from View and objects derived from ElementType. This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.
Example
C#
VB
C++
F#
Copy
// Use BoundingBoxIntersects filter to find elements with a bounding box that intersects the
// given Outline in the document.

// Create a Outline, uses a minimum and maximum XYZ point to initialize the outline.
Outline myOutLn = new Outline(new XYZ(0, 0, 0), new XYZ(100, 100, 100));

// Create a BoundingBoxIntersects filter with this Outline
BoundingBoxIntersectsFilter filter = new BoundingBoxIntersectsFilter(myOutLn);

// Apply the filter to the elements in the active document
// This filter excludes all objects derived from View and objects derived from ElementType
FilteredElementCollector collector = new FilteredElementCollector(document);
IList<Element> elements = collector.WherePasses(filter).ToElements();

// Find all walls which don't intersect with BoundingBox: use an inverted filter to match elements
// Use shortcut command OfClass() to find walls only
BoundingBoxIntersectsFilter invertFilter = new BoundingBoxIntersectsFilter(myOutLn, true); // inverted filter
collector = new FilteredElementCollector(document);
IList<Element> notIntersectWalls =
    collector.OfClass(typeof(Wall)).WherePasses(invertFilter).ToElements();
' Use BoundingBoxIntersects filter to find elements with a bounding box that intersects the
' given Outline in the document.

' Create a Outline, uses a minimum and maximum XYZ point to initialize the outline.
Dim myOutLn As New Outline(New XYZ(0, 0, 0), New XYZ(100, 100, 100))

' Create a BoundingBoxIntersects filter with this Outline
Dim filter As New BoundingBoxIntersectsFilter(myOutLn)

' Apply the filter to the elements in the active document
' This filter excludes all objects derived from View and objects derived from ElementType
Dim collector As New FilteredElementCollector(document)
Dim elements As IList(Of Element) = collector.WherePasses(filter).ToElements()

' Find all walls which don't intersect with BoundingBox: use an inverted filter to match elements
' Use shortcut command OfClass() to find walls only
Dim invertFilter As New BoundingBoxIntersectsFilter(myOutLn, True)
' inverted filter
collector = New FilteredElementCollector(document)
Dim notIntersectWalls As IList(Of Element) = collector.OfClass(GetType(Wall)).WherePasses(invertFilter).ToElements()

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


BoundingBoxIntersectsFilter Constructor

Overload List
 | Name | Description
Public method | BoundingBoxIntersectsFilter(Outline) | Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline.
Public method | BoundingBoxIntersectsFilter(Outline, Boolean) | Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline, with the option to invert the filter and match all elements with a bounding box that are not intersecting the given Outline.
Public method | BoundingBoxIntersectsFilter(Outline, Double) | Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline.
Public method | BoundingBoxIntersectsFilter(Outline, Double, Boolean) | Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline, with the option to invert the filter and match all elements with a bounding box that are not intersecting the given Outline.
Top
See Also

Reference

BoundingBoxIntersectsFilter Class


BoundingBoxIntersectsFilter(Outline) Constructor

Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BoundingBoxIntersectsFilter(
    Outline outline
)
Public Sub New (
    outline As Outline
)
public:
BoundingBoxIntersectsFilter(
    Outline^ outline
)
new :
        outline : Outline -> BoundingBoxIntersectsFilter

Parameters

outline Outline
The Outline used to find elements with a bounding box that intersect it.
Exceptions
Exception | Condition
ArgumentException | outline is an empty Outline.
ArgumentNullException | A non-optional argument was null
See Also

Reference

BoundingBoxIntersectsFilter Class
BoundingBoxIntersectsFilter Overload


BoundingBoxIntersectsFilter(Outline, Boolean) Constructor

Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline, with the option to invert the filter and match all elements with a bounding box that are not intersecting the given Outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BoundingBoxIntersectsFilter(
    Outline outline,
    bool inverted
)
Public Sub New (
    outline As Outline,
    inverted As Boolean
)
public:
BoundingBoxIntersectsFilter(
    Outline^ outline,
    bool inverted
)
new :
        outline : Outline *
        inverted : bool -> BoundingBoxIntersectsFilter

Parameters

outline Outline
The Outline used to find elements with a bounding box that intersect it.
inverted Boolean
True if the filter should be inverted and match all elements with a bounding box that are not intersecting the given Outline.
Exceptions
Exception | Condition
ArgumentException | outline is an empty Outline.
ArgumentNullException | A non-optional argument was null
See Also

Reference

BoundingBoxIntersectsFilter Class
BoundingBoxIntersectsFilter Overload


BoundingBoxIntersectsFilter(Outline, Double) Constructor

Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BoundingBoxIntersectsFilter(
    Outline outline,
    double tolerance
)
Public Sub New (
    outline As Outline,
    tolerance As Double
)
public:
BoundingBoxIntersectsFilter(
    Outline^ outline,
    double tolerance
)
new :
        outline : Outline *
        tolerance : float -> BoundingBoxIntersectsFilter

Parameters

outline Outline
The Outline used to find elements with a bounding box that intersect it.
tolerance Double
The tolerance value to use instead of zero. See the tolerance property for details.
Exceptions
Exception | Condition
ArgumentException | outline is an empty Outline. -or- The given value for tolerance is not finite -or- The given value for tolerance is not a number
ArgumentNullException | A non-optional argument was null
See Also

Reference

BoundingBoxIntersectsFilter Class
BoundingBoxIntersectsFilter Overload


BoundingBoxIntersectsFilter(Outline, Double, Boolean) Constructor

Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline, with the option to invert the filter and match all elements with a bounding box that are not intersecting the given Outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BoundingBoxIntersectsFilter(
    Outline outline,
    double tolerance,
    bool inverted
)
Public Sub New (
    outline As Outline,
    tolerance As Double,
    inverted As Boolean
)
public:
BoundingBoxIntersectsFilter(
    Outline^ outline,
    double tolerance,
    bool inverted
)
new :
        outline : Outline *
        tolerance : float *
        inverted : bool -> BoundingBoxIntersectsFilter

Parameters

outline Outline
The Outline used to find elements with a bounding box that intersect it.
tolerance Double
The tolerance value to use instead of zero. See the tolerance property for details.
inverted Boolean
True if the filter should be inverted and match all elements with a bounding box that are not intersecting the given Outline.
Exceptions
Exception | Condition
ArgumentException | outline is an empty Outline. -or- The given value for tolerance is not finite -or- The given value for tolerance is not a number
ArgumentNullException | A non-optional argument was null
See Also

Reference

BoundingBoxIntersectsFilter Class
BoundingBoxIntersectsFilter Overload


BoundingBoxIntersectsFilter Properties

The BoundingBoxIntersectsFilter type exposes the following members.

Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Public property | Tolerance | Allows control over the match criteria by using a tolerance in the geometry comparison. It is suggested to use this in cases where trivial differences should be considered when matching elements.
Top
See Also

Reference

BoundingBoxIntersectsFilter Class


BoundingBoxIntersectsFilter.Tolerance Property

BoundingBoxIntersectsFilterTolerance Property

Allows control over the match criteria by using a tolerance in the geometry comparison. It is suggested to use this in cases where trivial differences should be considered when matching elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Tolerance { get; set; }
Public Property Tolerance As Double
    Get
    Set
public:
property double Tolerance {
    double get ();
    void set (double value);
}
member Tolerance : float with get, set

Property Value

Double
Remarks
By default this is set to zero, but depending on your units of measure and how close objects may be, it is advised to set this to something more realistic. If the tolerance is positive, the outlines may be separated by the tolerance distance in each coordinate. If the tolerance is negative, the outlines must overlap by at least the tolerance distance in each coordinate.
See Also

Reference

BoundingBoxIntersectsFilter Class


BoundingBoxIntersectsFilter Methods

The BoundingBoxIntersectsFilter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBoundingBox | Gets the outline being used for this filter.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

BoundingBoxIntersectsFilter Class


BoundingBoxIntersectsFilter.GetBoundingBox Method

BoundingBoxIntersectsFilterGetBoundingBox Method

Gets the outline being used for this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Outline GetBoundingBox()
Public Function GetBoundingBox As Outline
public:
Outline^ GetBoundingBox()
member GetBoundingBox : unit -> Outline

Return Value

Outline
The outline being used for this filter.
See Also

Reference

BoundingBoxIntersectsFilter Class


BoundingBoxIsInsideFilter Class

A filter used to match elements with a bounding box that is contained by the given Outline.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementQuickFilter
Autodesk.Revit.DBBoundingBoxIsInsideFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BoundingBoxIsInsideFilter : ElementQuickFilter
Public Class BoundingBoxIsInsideFilter
    Inherits ElementQuickFilter
public ref class BoundingBoxIsInsideFilter : public ElementQuickFilter
type BoundingBoxIsInsideFilter =
    class
        inherit ElementQuickFilter
    end

The BoundingBoxIsInsideFilter type exposes the following members.

Constructors
 | Name | Description
Public method | BoundingBoxIsInsideFilter(Outline) | Constructs a new instance of a filter to match elements with a bounding box that is contained by the given Outline.
Public method | BoundingBoxIsInsideFilter(Outline, Boolean) | Constructs a new instance of a filter to match elements with a bounding box is contained by the given Outline, with the option to invert the filter and match all elements with a bounding box that are not contained by the given Outline.
Public method | BoundingBoxIsInsideFilter(Outline, Double) | Constructs a new instance of a filter to match elements with a bounding box that is contained by the given Outline.
Public method | BoundingBoxIsInsideFilter(Outline, Double, Boolean) | Constructs a new instance of a filter to match elements with a bounding box is contained by the given Outline, with the option to invert the filter and match all elements with a bounding box that are not contained by the given Outline.
Top
Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Public property | Tolerance | Allows control over the match criteria by using a tolerance in the geometry comparison. It is suggested to use this in cases where trivial differences should be considered when matching elements.
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBoundingBox | Gets the outline being used for this filter.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This filter excludes all objects derived from View and objects derived from ElementType. This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.
Example
C#
VB
C++
F#
Copy
// Use BoundingBoxIsInside filter to find elements with a bounding box that is contained(inside completely)
// by the given Outline in the document.

// Create a Outline, use a minimum and maximum XYZ point to initialize the outline.
Outline myOutLn = new Outline(new XYZ(0, 0, 0), new XYZ(100, 100, 100));

// Create a BoundingBoxIsInside filter for Outline
BoundingBoxIsInsideFilter filter = new BoundingBoxIsInsideFilter(myOutLn);

// Apply the filter to the elements in the active document
// This filter excludes all objects derived from View and objects derived from ElementType
FilteredElementCollector collector = new FilteredElementCollector(document);
IList<Element> elements = collector.WherePasses(filter).ToElements();

// Find walls outside BoundingBox: use an inverted filter to match elements
// Use shortcut command OfClass() to find walls only
BoundingBoxIsInsideFilter outsideFilter = new BoundingBoxIsInsideFilter(myOutLn, true); // inverted filter
collector = new FilteredElementCollector(document);
IList<Element> outsideFounds = collector.OfClass(typeof(Wall)).WherePasses(outsideFilter).ToElements();
' Use BoundingBoxIsInside filter to find elements with a bounding box that is contained(inside completely)
' by the given Outline in the document.

' Create a Outline, use a minimum and maximum XYZ point to initialize the outline.
Dim myOutLn As New Outline(New XYZ(0, 0, 0), New XYZ(100, 100, 100))

' Create a BoundingBoxIsInside filter for Outline
Dim filter As New BoundingBoxIsInsideFilter(myOutLn)

' Apply the filter to the elements in the active document
' This filter excludes all objects derived from View and objects derived from ElementType
Dim collector As New FilteredElementCollector(document)
Dim elements As IList(Of Element) = collector.WherePasses(filter).ToElements()

' Find walls outside BoundingBox: use an inverted filter to match elements
' Use shortcut command OfClass() to find walls only
Dim outsideFilter As New BoundingBoxIsInsideFilter(myOutLn, True)
' inverted filter
collector = New FilteredElementCollector(document)
Dim outsideFounds As IList(Of Element) = collector.OfClass(GetType(Wall)).WherePasses(outsideFilter).ToElements()

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


BoundingBoxIsInsideFilter Constructor

Overload List
 | Name | Description
Public method | BoundingBoxIsInsideFilter(Outline) | Constructs a new instance of a filter to match elements with a bounding box that is contained by the given Outline.
Public method | BoundingBoxIsInsideFilter(Outline, Boolean) | Constructs a new instance of a filter to match elements with a bounding box is contained by the given Outline, with the option to invert the filter and match all elements with a bounding box that are not contained by the given Outline.
Public method | BoundingBoxIsInsideFilter(Outline, Double) | Constructs a new instance of a filter to match elements with a bounding box that is contained by the given Outline.
Public method | BoundingBoxIsInsideFilter(Outline, Double, Boolean) | Constructs a new instance of a filter to match elements with a bounding box is contained by the given Outline, with the option to invert the filter and match all elements with a bounding box that are not contained by the given Outline.
Top
See Also

Reference

BoundingBoxIsInsideFilter Class


BoundingBoxIsInsideFilter(Outline) Constructor

Constructs a new instance of a filter to match elements with a bounding box that is contained by the given Outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BoundingBoxIsInsideFilter(
    Outline outline
)
Public Sub New (
    outline As Outline
)
public:
BoundingBoxIsInsideFilter(
    Outline^ outline
)
new :
        outline : Outline -> BoundingBoxIsInsideFilter

Parameters

outline Outline
The Outline used to find elements with a bounding box that are contained by it.
Exceptions
Exception | Condition
ArgumentException | outline is an empty Outline.
ArgumentNullException | A non-optional argument was null
See Also

Reference

BoundingBoxIsInsideFilter Class
BoundingBoxIsInsideFilter Overload


BoundingBoxIsInsideFilter(Outline, Boolean) Constructor

Constructs a new instance of a filter to match elements with a bounding box is contained by the given Outline, with the option to invert the filter and match all elements with a bounding box that are not contained by the given Outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BoundingBoxIsInsideFilter(
    Outline outline,
    bool inverted
)
Public Sub New (
    outline As Outline,
    inverted As Boolean
)
public:
BoundingBoxIsInsideFilter(
    Outline^ outline,
    bool inverted
)
new :
        outline : Outline *
        inverted : bool -> BoundingBoxIsInsideFilter

Parameters

outline Outline
The Outline used to find elements with a bounding box that are contained by it.
inverted Boolean
True if the filter should be inverted and match all elements with a bounding box that are not contained by the given Outline.
Exceptions
Exception | Condition
ArgumentException | outline is an empty Outline.
ArgumentNullException | A non-optional argument was null
See Also

Reference

BoundingBoxIsInsideFilter Class
BoundingBoxIsInsideFilter Overload


BoundingBoxIsInsideFilter(Outline, Double) Constructor

Constructs a new instance of a filter to match elements with a bounding box that is contained by the given Outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BoundingBoxIsInsideFilter(
    Outline outline,
    double tolerance
)
Public Sub New (
    outline As Outline,
    tolerance As Double
)
public:
BoundingBoxIsInsideFilter(
    Outline^ outline,
    double tolerance
)
new :
        outline : Outline *
        tolerance : float -> BoundingBoxIsInsideFilter

Parameters

outline Outline
The Outline used to find elements with a bounding box that are contained by it.
tolerance Double
The tolerance value to use instead of zero. See the tolerance property for details.
Exceptions
Exception | Condition
ArgumentException | outline is an empty Outline. -or- The given value for tolerance is not finite -or- The given value for tolerance is not a number
ArgumentNullException | A non-optional argument was null
See Also

Reference

BoundingBoxIsInsideFilter Class
BoundingBoxIsInsideFilter Overload


BoundingBoxIsInsideFilter(Outline, Double, Boolean) Constructor

Constructs a new instance of a filter to match elements with a bounding box is contained by the given Outline, with the option to invert the filter and match all elements with a bounding box that are not contained by the given Outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BoundingBoxIsInsideFilter(
    Outline outline,
    double tolerance,
    bool inverted
)
Public Sub New (
    outline As Outline,
    tolerance As Double,
    inverted As Boolean
)
public:
BoundingBoxIsInsideFilter(
    Outline^ outline,
    double tolerance,
    bool inverted
)
new :
        outline : Outline *
        tolerance : float *
        inverted : bool -> BoundingBoxIsInsideFilter

Parameters

outline Outline
The Outline used to find elements with a bounding box that are contained by it.
tolerance Double
The tolerance value to use instead of zero. See the tolerance property for details.
inverted Boolean
True if the filter should be inverted and match all elements with a bounding box that are not contained by the given Outline.
Exceptions
Exception | Condition
ArgumentException | outline is an empty Outline. -or- The given value for tolerance is not finite -or- The given value for tolerance is not a number
ArgumentNullException | A non-optional argument was null
See Also

Reference

BoundingBoxIsInsideFilter Class
BoundingBoxIsInsideFilter Overload


BoundingBoxIsInsideFilter Properties

The BoundingBoxIsInsideFilter type exposes the following members.

Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Public property | Tolerance | Allows control over the match criteria by using a tolerance in the geometry comparison. It is suggested to use this in cases where trivial differences should be considered when matching elements.
Top
See Also

Reference

BoundingBoxIsInsideFilter Class


BoundingBoxIsInsideFilter.Tolerance Property

BoundingBoxIsInsideFilterTolerance Property

Allows control over the match criteria by using a tolerance in the geometry comparison. It is suggested to use this in cases where trivial differences should be considered when matching elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Tolerance { get; set; }
Public Property Tolerance As Double
    Get
    Set
public:
property double Tolerance {
    double get ();
    void set (double value);
}
member Tolerance : float with get, set

Property Value

Double
Remarks
By default this is set to zero, but depending on your units of measure and how close objects may be, it is advised to set this to something more realistic. If the tolerance is positive, the iterated element's Outline may extend the tolerance distance outside of the given Outline in each coordinate to be a match. If the tolerance is negative, the iterated element's Outline must lie at least the tolerance distance inside the given Outline in each coordinate to be a match.
See Also

Reference

BoundingBoxIsInsideFilter Class


BoundingBoxIsInsideFilter Methods

The BoundingBoxIsInsideFilter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBoundingBox | Gets the outline being used for this filter.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

BoundingBoxIsInsideFilter Class


BoundingBoxIsInsideFilter.GetBoundingBox Method

BoundingBoxIsInsideFilterGetBoundingBox Method

Gets the outline being used for this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Outline GetBoundingBox()
Public Function GetBoundingBox As Outline
public:
Outline^ GetBoundingBox()
member GetBoundingBox : unit -> Outline

Return Value

Outline
The outline being used for this filter.
See Also

Reference

BoundingBoxIsInsideFilter Class


BoundingBoxUV Class

A two-dimensional rectangle, parallel to the coordinate axes.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBoundingBoxUV

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BoundingBoxUV : IDisposable
Public Class BoundingBoxUV
    Implements IDisposable
public ref class BoundingBoxUV : IDisposable
type BoundingBoxUV =
    class
        interface IDisposable
    end

The BoundingBoxUV type exposes the following members.

Constructors
 | Name | Description
Public method | BoundingBoxUV | default constructor
Public method | BoundingBoxUV(Double, Double, Double, Double) | Creates object with supplied values.
Top
Properties
 | Name | Description
Public property | Bounds | Indexed access for loops. Use 0 for Min and 1 for Max.
Public property | IsSet | Indicates whether the BoundingBoxUV is set or not.
Public property | Max | Maximum coordinates (upper-right corner of the box).
Public property | Min | Minimum coordinates (lower-left corner of the box).
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the BoundingBoxUV
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Example
C#
VB
C++
F#
Copy
Document doc = application.ActiveUIDocument.Document;
FilteredElementCollector collector = new FilteredElementCollector(doc);
ICollection<Element> collection = collector.OfClass(typeof(Autodesk.Revit.DB.View)).ToElements();
foreach (Element element in collection)

{
    Autodesk.Revit.DB.View view = element as Autodesk.Revit.DB.View;
    if (null != view)
    {
        string messageInfo = "BoundingBoxUV : ";
        messageInfo += "\nView name : " + view.Name;
        BoundingBoxUV boundingBox = view.Outline;
        // Get max bounding box
        UV max = boundingBox.Max;
        messageInfo += "\nMax boundingbox : (" + max.U + "," + max.V + ")";
        // Get min bounding box
        UV min = boundingBox.Min;
        messageInfo += "\nMin boundingbox : (" + min.U + "," + min.V + ")";
        // Get bounds,
        // Use 0 for Min and 1 for Max
        UV bound = boundingBox.get_Bounds(0);
        messageInfo += "\nBoundingbox bounds : (" + bound.U + "," + bound.V + ")";
        TaskDialog.Show("Revit",messageInfo);
    }
}
Dim doc As Document = application.ActiveUIDocument.Document
Dim collector As New FilteredElementCollector(doc)
Dim collection As ICollection(Of Element) = collector.OfClass(GetType(Autodesk.Revit.DB.View)).ToElements()
For Each element As Element In collection

    Dim view As Autodesk.Revit.DB.View = TryCast(element, Autodesk.Revit.DB.View)
    If view IsNot Nothing Then
        Dim messageInfo As String = "BoundingBoxUV : "
        messageInfo += vbLf & "View name : " + view.Name
        Dim boundingBox As BoundingBoxUV = view.Outline
        ' Get max bounding box
        Dim max As UV = boundingBox.Max
        messageInfo += vbLf & "Max boundingbox : (" + max.U + "," + max.V + ")"
        ' Get min bounding box
        Dim min As UV = boundingBox.Min
        messageInfo += vbLf & "Min boundingbox : (" + min.U + "," + min.V + ")"
        ' Get bounds,
        ' Use 0 for Min and 1 for Max
        Dim bound As UV = boundingBox.Bounds(0)
        messageInfo += vbLf & "Boundingbox bounds : (" + bound.U + "," + bound.V + ")"
        TaskDialog.Show("Revit", messageInfo)
    End If
Next

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


BoundingBoxUV Constructor

Overload List
 | Name | Description
Public method | BoundingBoxUV | default constructor
Public method | BoundingBoxUV(Double, Double, Double, Double) | Creates object with supplied values.
Top
See Also

Reference

BoundingBoxUV Class


BoundingBoxUV Constructor

default constructor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BoundingBoxUV()
Public Sub New
public:
BoundingBoxUV()
new : unit -> BoundingBoxUV
See Also

Reference

BoundingBoxUV Class
BoundingBoxUV Overload


BoundingBoxUV(Double, Double, Double, Double) Constructor

Creates object with supplied values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BoundingBoxUV(
    double min_u,
    double min_v,
    double max_u,
    double max_v
)
Public Sub New (
    min_u As Double,
    min_v As Double,
    max_u As Double,
    max_v As Double
)
public:
BoundingBoxUV(
    double min_u,
    double min_v,
    double max_u,
    double max_v
)
new :
        min_u : float *
        min_v : float *
        max_u : float *
        max_v : float -> BoundingBoxUV

Parameters

min_u Double
The first coordinate of min.
min_v Double
The second coordinate of min.
max_u Double
The first coordinate of max.
max_v Double
The second coordinate of max.
See Also

Reference

BoundingBoxUV Class
BoundingBoxUV Overload


BoundingBoxUV Properties

The BoundingBoxUV type exposes the following members.

Properties
 | Name | Description
Public property | Bounds | Indexed access for loops. Use 0 for Min and 1 for Max.
Public property | IsSet | Indicates whether the BoundingBoxUV is set or not.
Public property | Max | Maximum coordinates (upper-right corner of the box).
Public property | Min | Minimum coordinates (lower-left corner of the box).
Top
See Also

Reference

BoundingBoxUV Class


BoundingBoxUV.Bounds Property

BoundingBoxUVBounds Property

Indexed access for loops. Use 0 for Min and 1 for Max.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public UV this[
    int idx
] { get; }
Public ReadOnly Property Bounds (
    idx As Integer
) As UV
    Get
public:
property UV^ Bounds[int idx] {
    UV^ get (int idx);
}
member Bounds : UV with get

Parameters

idx Int32

Property Value

UV
See Also

Reference

BoundingBoxUV Class


BoundingBoxUV.IsSet Property

BoundingBoxUVIsSet Property

Indicates whether the BoundingBoxUV is set or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSet { get; }
Public ReadOnly Property IsSet As Boolean
    Get
public:
property bool IsSet {
    bool get ();
}
member IsSet : bool with get

Property Value

Boolean
Remarks
An unset BoundingBoxUV has its lower-left corner to the right of (and above) its upper-right corner (this is an arbitrary internal representation). It means that it is empty and has never been initialized. If someone using the API creates a Plane via one of the Plane.Create() methods, for example, the Plane will not have its envelope set, so Surface.GetBoundingBoxUV() would return an empty BoundingBoxUV.
See Also

Reference

BoundingBoxUV Class


BoundingBoxUV.Max Property

BoundingBoxUVMax Property

Maximum coordinates (upper-right corner of the box).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public UV Max { get; set; }
Public Property Max As UV
    Get
    Set
public:
property UV^ Max {
    UV^ get ();
    void set (UV^ value);
}
member Max : UV with get, set

Property Value

UV
See Also

Reference

BoundingBoxUV Class


BoundingBoxUV.Min Property

BoundingBoxUVMin Property

Minimum coordinates (lower-left corner of the box).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public UV Min { get; set; }
Public Property Min As UV
    Get
    Set
public:
property UV^ Min {
    UV^ get ();
    void set (UV^ value);
}
member Min : UV with get, set

Property Value

UV
See Also

Reference

BoundingBoxUV Class


BoundingBoxUV Methods

The BoundingBoxUV type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

BoundingBoxUV Class


BoundingBoxUV.Dispose Method

BoundingBoxUVDispose Method

Releases all resources used by the BoundingBoxUV

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

BoundingBoxUV Class


BoundingBoxXYZ Class

A three-dimensional rectangular box at an arbitrary location and orientation within the Revit model.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBBoundingBoxXYZ

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BoundingBoxXYZ : APIObject
Public Class BoundingBoxXYZ
    Inherits APIObject
public ref class BoundingBoxXYZ : public APIObject
type BoundingBoxXYZ =
    class
        inherit APIObject
    end

The BoundingBoxXYZ type exposes the following members.

Constructors
 | Name | Description
Public method | BoundingBoxXYZ | Constructs a new BoundingBoxXYZ with a default transform and extents of (-100, -100, -100) to (100, 100, 100).
Top
Properties
 | Name | Description
Public property | BoundEnabled | Indexed access for loops.
Public property | Bounds | Indexed access for loops. Use 0 for Min and 1 for Max.
Public property | Enabled | Defines whether the entire bounding box is enabled.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | IsSet | Indicates whether the bounding box is set.
Public property | Max | Maximum coordinates (upper-right-front corner of the box).
Public property | MaxEnabled | Defines whether the maximum bound is active for given dimension.
Public property | Min | Minimum coordinates (lower-left-rear corner of the box).
Public property | MinEnabled | Defines whether the minimum bound is active for given dimension.
 | Transform | The transform from the coordinate space of the box to the model coordinate space.
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

BoundingBoxXYZ objects are used in Revit in several places related to views (for example, the section box of a 3D view or the definition of a section or detail view). BoundingBoxXYZ objects can also be obtained from elements representing the boundary of the element in a given view.

The extents of the box are determined by three orthogonal planes extended through the minimum (Min) and maximum (Max) points, but the coordinates of these points and the orientation of the planes in relation to the coordinates of the source model is determined by the box Transform (Transform).

This class also has the ability to detect and mark certain extents as disabled. Note that in the current Revit API uses of this class it is not expected that Revit will give objects with disabled extents, and disabled extents in objects sent to Revit will likely be ignored.

Example
C#
VB
C++
F#
Copy
public void GetBoundingBoxXYZInfo(View3D view3D)
{
    string message = "BoundingBoxXYZ : ";
    message += "\nView name : " + view3D.Name;
    BoundingBoxXYZ boundingBox = view3D.GetSectionBox();
    // The section box of the 3D view can cut the model.
    if (view3D.IsSectionBoxActive)
    {
        BoundingBoxXYZ sectionBox = view3D.GetSectionBox();

        // Note that the section box can be rotated and transformed.
        // So the min/max corners coordinates relative to the model must be computed via the transform.
        Transform trf = sectionBox.Transform;

        XYZ max = sectionBox.Max; //Maximum coordinates (upper-right-front corner of the box before transform is applied).
        XYZ min = sectionBox.Min; //Minimum coordinates (lower-left-rear corner of the box before transform is applied).

        // Transform the min and max to model coordinates
        XYZ maxInModelCoords = trf.OfPoint(max);
        XYZ minInModelCoords = trf.OfPoint(min);

        message += "\nView has an active section box: ";
        message += "\n'Maximum' coordinates: " + maxInModelCoords;
        message += "\n'Minimum' coordinates: " + minInModelCoords;
    }
    TaskDialog.Show("Revit", message);
}
Public Sub GetBoundingBoxXYZInfo(view3D As View3D)
    Dim message As String = "BoundingBoxXYZ : "
    message += vbLf & "View name : " + view3D.Name
    Dim boundingBox As BoundingBoxXYZ = view3D.GetSectionBox()
    ' The section box of the 3D view can cut the model.
    If view3D.IsSectionBoxActive Then
        Dim sectionBox As BoundingBoxXYZ = view3D.GetSectionBox()

        ' Note that the section box can be rotated and transformed.
        ' So the min/max corners coordinates relative to the model must be computed via the transform.
        Dim trf As Transform = sectionBox.Transform

        Dim max As XYZ = sectionBox.Max
        'Maximum coordinates (upper-right-front corner of the box before transform is applied).
        Dim min As XYZ = sectionBox.Min
        'Minimum coordinates (lower-left-rear corner of the box before transform is applied).
        ' Transform the min and max to model coordinates
        Dim maxInModelCoords As XYZ = trf.OfPoint(max)
        Dim minInModelCoords As XYZ = trf.OfPoint(min)

        message += vbLf & "View has an active section box: "
        message += vbLf & "Maximum' coordinates: " + maxInModelCoords.ToString()
        message += vbLf & "Minimum' coordinates: " + minInModelCoords.ToString()
    End If
    TaskDialog.Show("Revit", message)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


BoundingBoxXYZ Constructor

Constructs a new BoundingBoxXYZ with a default transform and extents of (-100, -100, -100) to (100, 100, 100).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BoundingBoxXYZ()
Public Sub New
public:
BoundingBoxXYZ()
new : unit -> BoundingBoxXYZ
See Also

Reference

BoundingBoxXYZ Class


BoundingBoxXYZ Properties

The BoundingBoxXYZ type exposes the following members.

Properties
 | Name | Description
Public property | BoundEnabled | Indexed access for loops.
Public property | Bounds | Indexed access for loops. Use 0 for Min and 1 for Max.
Public property | Enabled | Defines whether the entire bounding box is enabled.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | IsSet | Indicates whether the bounding box is set.
Public property | Max | Maximum coordinates (upper-right-front corner of the box).
Public property | MaxEnabled | Defines whether the maximum bound is active for given dimension.
Public property | Min | Minimum coordinates (lower-left-rear corner of the box).
Public property | MinEnabled | Defines whether the minimum bound is active for given dimension.
 | Transform | The transform from the coordinate space of the box to the model coordinate space.
Top
See Also

Reference

BoundingBoxXYZ Class


BoundingBoxXYZ.BoundEnabled Property

BoundingBoxXYZBoundEnabled Property

Indexed access for loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool this[
    int bound,
    int dim
] { get; set; }
Public Property BoundEnabled (
    bound As Integer,
    dim As Integer
) As Boolean
    Get
    Set
public:
property bool BoundEnabled[int bound, int dim] {
    bool get (int bound, int dim);
    void set (int bound, int dim, bool value);
}
member BoundEnabled : bool with get, set

Parameters

bound Int32
dim Int32

Property Value

Boolean
Remarks
For bound, use 0 for Min and 1 for Max. For dimension, use 0 for X, 1 for Y and 2 for Z. The entire box must be enabled to have enabled individual bounds.
See Also

Reference

BoundingBoxXYZ Class


BoundingBoxXYZ.Bounds Property

BoundingBoxXYZBounds Property

Indexed access for loops. Use 0 for Min and 1 for Max.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ this[
    int bound
] { get; set; }
Public Property Bounds (
    bound As Integer
) As XYZ
    Get
    Set
public:
property XYZ^ Bounds[int bound] {
    XYZ^ get (int bound);
    void set (int bound, XYZ^ value);
}
member Bounds : XYZ with get, set

Parameters

bound Int32

Property Value

XYZ
Remarks
The bounds are defined in the coordinate space of the box.
See Also

Reference

BoundingBoxXYZ Class


BoundingBoxXYZ.Enabled Property

BoundingBoxXYZEnabled Property

Defines whether the entire bounding box is enabled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
member Enabled : bool with get, set

Property Value

Boolean
Remarks
A disabled bounding box might be used to signal that the corresponding Revit functionality is deactivated. For example, a disabled 3D view section box represents an inactive section box.
See Also

Reference

BoundingBoxXYZ Class


BoundingBoxXYZ.IsSet Property

BoundingBoxXYZIsSet Property

Indicates whether the bounding box is set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSet { get; }
Public ReadOnly Property IsSet As Boolean
    Get
public:
property bool IsSet {
    bool get ();
}
member IsSet : bool with get

Property Value

Boolean
Remarks
Bounding box is considered set when it contains at least one point and "Enabled" is set to "true".
See Also

Reference

BoundingBoxXYZ Class


BoundingBoxXYZ.Max Property

BoundingBoxXYZMax Property

Maximum coordinates (upper-right-front corner of the box).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Max { get; set; }
Public Property Max As XYZ
    Get
    Set
public:
property XYZ^ Max {
    XYZ^ get ();
    void set (XYZ^ value);
}
member Max : XYZ with get, set

Property Value

XYZ
Remarks
The bounds are defined in the coordinate space of the box.
See Also

Reference

BoundingBoxXYZ Class


BoundingBoxXYZ.MaxEnabled Property

BoundingBoxXYZMaxEnabled Property

Defines whether the maximum bound is active for given dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool this[
    int dim
] { get; set; }
Public Property MaxEnabled (
    dim As Integer
) As Boolean
    Get
    Set
public:
property bool MaxEnabled[int dim] {
    bool get (int dim);
    void set (int dim, bool value);
}
member MaxEnabled : bool with get, set

Parameters

dim Int32

Property Value

Boolean
Remarks
Use 0 for X, 1 for Y and 2 for Z. The entire box must be enabled to have enabled individual bounds.
See Also

Reference

BoundingBoxXYZ Class


BoundingBoxXYZ.Min Property

BoundingBoxXYZMin Property

Minimum coordinates (lower-left-rear corner of the box).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Min { get; set; }
Public Property Min As XYZ
    Get
    Set
public:
property XYZ^ Min {
    XYZ^ get ();
    void set (XYZ^ value);
}
member Min : XYZ with get, set

Property Value

XYZ
Remarks
The bounds are defined in the coordinate space of the box.
See Also

Reference

BoundingBoxXYZ Class


BoundingBoxXYZ.MinEnabled Property

BoundingBoxXYZMinEnabled Property

Defines whether the minimum bound is active for given dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool this[
    int dim
] { get; set; }
Public Property MinEnabled (
    dim As Integer
) As Boolean
    Get
    Set
public:
property bool MinEnabled[int dim] {
    bool get (int dim);
    void set (int dim, bool value);
}
member MinEnabled : bool with get, set

Parameters

dim Int32

Property Value

Boolean
Remarks
Use 0 for X, 1 for Y and 2 for Z. The entire box must be enabled to have enabled individual bounds.
See Also

Reference

BoundingBoxXYZ Class


BoundingBoxXYZ.Transform Property

BoundingBoxXYZTransform Property

The transform from the coordinate space of the box to the model coordinate space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Transform Transform { get; set; }
Public Property Transform As Transform
    Get
    Set
public:
property Transform^ Transform {
    Transform^ get ();
    void set (Transform^ value);
}
member Transform : Transform with get, set

Property Value

Transform
Remarks
The transform must always be right-handed and orthonormal.
Example
C#
VB
C++
F#
Copy
private void RotateBoundingBox(View3D view3d)
{
    if (!view3d.IsSectionBoxActive)
    {
        TaskDialog.Show("Revit","The section box for View3D isn't active.");
        return;
    }
    BoundingBoxXYZ box = view3d.GetSectionBox();

    // Create a rotation transform to apply to the section box
    XYZ origin = new XYZ(0, 0, 0);
    XYZ axis = new XYZ(0, 0, 1);

    // Rotate 30 degrees
    Transform rotate = Transform.CreateRotationAtPoint(axis, Math.PI/6.0, origin);

    // Transform the View3D's section box with the rotation transform
    box.Transform = box.Transform.Multiply(rotate);

    // Set the section box back to the view (requires an open transaction)
    view3d.SetSectionBox(box);
}
Private Sub RotateBoundingBox(view3d As View3D)
    If Not view3d.IsSectionBoxActive Then
        TaskDialog.Show("Revit", "The section box for View3D isn't active.")
        Return
    End If
    Dim box As BoundingBoxXYZ = view3d.GetSectionBox()

    ' Create a rotation transform to apply to the section box
    Dim origin As New XYZ(0, 0, 0)
    Dim axis As New XYZ(0, 0, 1)

    ' Rotate 30 degrees
    Dim rotate As Transform = Transform.CreateRotationAtPoint(axis, Math.PI / 6.0, origin)

    ' Transform the View3D's section box with the rotation transform
    box.Transform = box.Transform.Multiply(rotate)

    ' Set the section box back to the view (requires an open transaction)
    view3d.SetSectionBox(box)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

BoundingBoxXYZ Class


BoundingBoxXYZ Methods

The BoundingBoxXYZ type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

BoundingBoxXYZ Class


BoxPlacement Enumeration

An enumerated type containing possible constraint types for Adaptive Points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum BoxPlacement
Public Enumeration BoxPlacement
public enum class BoxPlacement
type BoxPlacement
Members
Member name | Value | Description
Center | 0 | Placement of a box by its center point
TopLeft | 1 | Placement of a box by its top left corner.
TopRight | 2 | Placement of a box by its top right corner.
BottomRight | 3 | Placement of a box by its bottom right corner.
BottomLeft | 4 | Placement of a box by its bottom left corner.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


BRepBuilder Class

A class that allows direct construction of geometry objects (solids, open shells, etc.).
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBShapeBuilder
Autodesk.Revit.DBBRepBuilder

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BRepBuilder : ShapeBuilder
Public Class BRepBuilder
    Inherits ShapeBuilder
public ref class BRepBuilder : public ShapeBuilder
type BRepBuilder =
    class
        inherit ShapeBuilder
    end

The BRepBuilder type exposes the following members.

Constructors
 | Name | Description
Public method | BRepBuilder | Construct a BRepBuilder to use in constructing geometry.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ShapeBuilder)
Top
Methods
 | Name | Description
Public method | AddCoEdge | Add a co-edge associated to a previously added edge. A co-edge represents the use of an edge on one of the edge's faces. BrepBuilder allows at most two faces per edge, hence at most two co-edges per edge, and the co-edges must have opposite bCoEdgeIsReversed flags. The co-edges in a loop must be added in the order in which they occur in the loop (i.e., in their topological order).
Public method | AddEdge | Add a new edge to the geometry being built. The BRepBuilder uses edges only to store edge geometry and to track pairs of co-edges that share an edge.
Public method | AddFace | Creates an empty face in the geometry being built. Other BRepBuilder methods are used to add loops to the face.
Public method | AddLoop | Creates an empty loop in a given face of the geometry being built. Other BRepBuilder methods are used to add co-edges to the loop.
Public method | AllowRemovalOfProblematicFaces | Allow BRepBuilder to remove problematic faces (e.g., due to inaccurate edge geometry). If this option is enabled and BRepBuilder removes some faces, the output geometry's type will be OpenShell regardless of the expected type specified when the BRepBuilder was created.
Public method | CanAddGeometry | A validator function that checks the state of this BRepBuilder object. Returns true if this BRepBuilder object is accepting b-rep data, false otherwise.
Public method | Dispose | (Inherited from ShapeBuilder)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Finish | Complete construction of the geometry. The geometry will be validated and, if valid, stored in this BRepBuilder. Otherwise it will be deleted.
Public method | FinishFace | Indicates that the caller has finished defining the given face.
Public method | FinishLoop | Indicates that the caller has finished defining the given loop.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetResult | Get the Solid built by this BRepBuilder. This will clear the built geometry stored in the BRepBuilder. This function will throw if this BRepBuilder hasn't completed building the b-rep. Use IsResultAvailable() to verify that this BRepBuilder contains a valid result.
Public method | GetResult(ExternalGeometryId, BRepBuilderPersistentIds) | Get the ExternallyTaggedBRep built by this BRepBuilder. This will clear the built geometry stored in the BRepBuilder. This function will throw if this BRepBuilder hasn't completed building the b-rep. Use IsResultAvailable() to verify that this BRepBuilder contains a valid result.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | IsPermittedSurfaceType | A validator function that checks whether the surface object is of type supported as face surface by BRepBuilder.
Public method | IsResultAvailable | A validator function that checks the state of this BRepBuilder object. Returns true if this BRepBuilder object has successfully built a b-rep.
Public method | IsValidEdgeId | A validator function that checks whether the edge id corresponds to an edge previously added to this BRepBuilder object.
Public method | IsValidFaceId | A validator function that checks whether the face id corresponds to a face previously added to this BRepBuilder object.
Public method | IsValidLoopId | A validator function that checks whether the loop id corresponds to a loop previously added to this BRepBuilder object.
Public method | IsValidPersistentIdsMap | A validator function that makes sure that all BRepBuilderGeometryIds in the input map can be found in this BRepBuilder object.
Public method | RemovedSomeFaces | Returns 'true' if BRepBuilder removed some problematic faces from the output geometry, 'false' if not. If allowRemovalOfProblematicFaces was not called to enable removal of problematic faces, this function will return 'false'. Note that if some faces were removed, the output geometry's type will be OpenShell regardless of the expected type that was specified when the BRepBuilder was created.
Public method | SetAllowShortEdges | Make BRepBuilder allow edges that it would normally disallow as being too short for Revit geometry.
Public method | SetFaceMaterialId | Sets material id to a face.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Example
C#
VB
C++
F#
Copy
private void CreateDirectShapeFromCylinder(Document doc)
{
    // Naming convention for faces and edges: we assume that x is to the left and pointing down, y is horizontal and pointing to the right, z is up
    BRepBuilder brepBuilder = new BRepBuilder(BRepType.Solid);

    // The surfaces of the four faces.
    Frame basis = new Frame(new XYZ(50, -100, 0), new XYZ(0, 1, 0), new XYZ(-1, 0, 0), new XYZ(0, 0, 1));
    CylindricalSurface cylSurf = CylindricalSurface.Create(basis, 50);
    Plane top = Plane.CreateByNormalAndOrigin(new XYZ(0, 0, 1), new XYZ(0, 0, 100));  // normal points outside the cylinder
    Plane bottom = Plane.CreateByNormalAndOrigin(new XYZ(0, 0, 1), new XYZ(0, 0, 0)); // normal points inside the cylinder

    // Add the four faces
    BRepBuilderGeometryId frontCylFaceId = brepBuilder.AddFace(BRepBuilderSurfaceGeometry.Create(cylSurf, null), false);
    BRepBuilderGeometryId backCylFaceId = brepBuilder.AddFace(BRepBuilderSurfaceGeometry.Create(cylSurf, null), false);
    BRepBuilderGeometryId topFaceId = brepBuilder.AddFace(BRepBuilderSurfaceGeometry.Create(top, null), false);
    BRepBuilderGeometryId bottomFaceId = brepBuilder.AddFace(BRepBuilderSurfaceGeometry.Create(bottom, null), true);

    // Geometry for the four semi-circular edges and two vertical linear edges
    BRepBuilderEdgeGeometry frontEdgeBottom = BRepBuilderEdgeGeometry.Create(Arc.Create(new XYZ(0, -100, 0), new XYZ(100, -100, 0), new XYZ(50, -50, 0)));
    BRepBuilderEdgeGeometry backEdgeBottom = BRepBuilderEdgeGeometry.Create(Arc.Create(new XYZ(100, -100, 0), new XYZ(0, -100, 0), new XYZ(50, -150, 0)));

    BRepBuilderEdgeGeometry frontEdgeTop = BRepBuilderEdgeGeometry.Create(Arc.Create(new XYZ(0, -100, 100), new XYZ(100, -100, 100), new XYZ(50, -50, 100)));
    BRepBuilderEdgeGeometry backEdgeTop = BRepBuilderEdgeGeometry.Create(Arc.Create(new XYZ(0, -100, 100), new XYZ(100, -100, 100), new XYZ(50, -150, 100)));

    BRepBuilderEdgeGeometry linearEdgeFront = BRepBuilderEdgeGeometry.Create(new XYZ(100, -100, 0), new XYZ(100, -100, 100));
    BRepBuilderEdgeGeometry linearEdgeBack = BRepBuilderEdgeGeometry.Create(new XYZ(0, -100, 0), new XYZ(0, -100, 100));

    // Add the six edges
    BRepBuilderGeometryId frontEdgeBottomId = brepBuilder.AddEdge(frontEdgeBottom);
    BRepBuilderGeometryId frontEdgeTopId = brepBuilder.AddEdge(frontEdgeTop);
    BRepBuilderGeometryId linearEdgeFrontId = brepBuilder.AddEdge(linearEdgeFront);
    BRepBuilderGeometryId linearEdgeBackId = brepBuilder.AddEdge(linearEdgeBack);
    BRepBuilderGeometryId backEdgeBottomId = brepBuilder.AddEdge(backEdgeBottom);
    BRepBuilderGeometryId backEdgeTopId = brepBuilder.AddEdge(backEdgeTop);

    // Loops of the four faces
    BRepBuilderGeometryId loopId_Top = brepBuilder.AddLoop(topFaceId);
    BRepBuilderGeometryId loopId_Bottom = brepBuilder.AddLoop(bottomFaceId);
    BRepBuilderGeometryId loopId_Front = brepBuilder.AddLoop(frontCylFaceId);
    BRepBuilderGeometryId loopId_Back = brepBuilder.AddLoop(backCylFaceId);

    // Add coedges for the loop of the front face
    brepBuilder.AddCoEdge(loopId_Front, linearEdgeBackId, false);
    brepBuilder.AddCoEdge(loopId_Front, frontEdgeTopId, false);
    brepBuilder.AddCoEdge(loopId_Front, linearEdgeFrontId, true);
    brepBuilder.AddCoEdge(loopId_Front, frontEdgeBottomId, true);
    brepBuilder.FinishLoop(loopId_Front);
    brepBuilder.FinishFace(frontCylFaceId);

    // Add coedges for the loop of the back face
    brepBuilder.AddCoEdge(loopId_Back, linearEdgeBackId, true);
    brepBuilder.AddCoEdge(loopId_Back, backEdgeBottomId, true);
    brepBuilder.AddCoEdge(loopId_Back, linearEdgeFrontId, false);
    brepBuilder.AddCoEdge(loopId_Back, backEdgeTopId, true);
    brepBuilder.FinishLoop(loopId_Back);
    brepBuilder.FinishFace(backCylFaceId);

    // Add coedges for the loop of the top face
    brepBuilder.AddCoEdge(loopId_Top, backEdgeTopId, false);
    brepBuilder.AddCoEdge(loopId_Top, frontEdgeTopId, true);
    brepBuilder.FinishLoop(loopId_Top);
    brepBuilder.FinishFace(topFaceId);

    // Add coedges for the loop of the bottom face
    brepBuilder.AddCoEdge(loopId_Bottom, frontEdgeBottomId, false);
    brepBuilder.AddCoEdge(loopId_Bottom, backEdgeBottomId, false);
    brepBuilder.FinishLoop(loopId_Bottom);
    brepBuilder.FinishFace(bottomFaceId);

    brepBuilder.Finish();

    using (Transaction tr = new Transaction(doc, "Create a DirectShape"))
    {
        tr.Start();
        DirectShape ds = DirectShape.CreateElement(doc, new ElementId(BuiltInCategory.OST_GenericModel));
        ds.SetShape(brepBuilder);
        tr.Commit();
    }
}
Private Sub CreateDirectShapeFromCylinder(doc As Document)
    ' Naming convention for faces and edges: we assume that x is to the left and pointing down, y is horizontal and pointing to the right, z is up
    Dim brepBuilder As New BRepBuilder(BRepType.Solid)

    ' The surfaces of the four faces.
    Dim basis As New Frame(New XYZ(50, -100, 0), New XYZ(0, 1, 0), New XYZ(-1, 0, 0), New XYZ(0, 0, 1))
    Dim cylSurf As CylindricalSurface = CylindricalSurface.Create(basis, 50)
    Dim top As Plane = Plane.CreateByNormalAndOrigin(New XYZ(0, 0, 1), New XYZ(0, 0, 100))
    ' normal points outside the cylinder
    Dim bottom As Plane = Plane.CreateByNormalAndOrigin(New XYZ(0, 0, 1), New XYZ(0, 0, 0))
    ' normal points inside the cylinder
    ' Add the four faces
    Dim frontCylFaceId As BRepBuilderGeometryId = brepBuilder.AddFace(BRepBuilderSurfaceGeometry.Create(cylSurf, Nothing), False)
    Dim backCylFaceId As BRepBuilderGeometryId = brepBuilder.AddFace(BRepBuilderSurfaceGeometry.Create(cylSurf, Nothing), False)
    Dim topFaceId As BRepBuilderGeometryId = brepBuilder.AddFace(BRepBuilderSurfaceGeometry.Create(top, Nothing), False)
    Dim bottomFaceId As BRepBuilderGeometryId = brepBuilder.AddFace(BRepBuilderSurfaceGeometry.Create(bottom, Nothing), True)

    ' Geometry for the four semi-circular edges and two vertical linear edges
    Dim frontEdgeBottom As BRepBuilderEdgeGeometry = BRepBuilderEdgeGeometry.Create(Arc.Create(New XYZ(0, -100, 0), New XYZ(100, -100, 0), New XYZ(50, -50, 0)))
    Dim backEdgeBottom As BRepBuilderEdgeGeometry = BRepBuilderEdgeGeometry.Create(Arc.Create(New XYZ(100, -100, 0), New XYZ(0, -100, 0), New XYZ(50, -150, 0)))

    Dim frontEdgeTop As BRepBuilderEdgeGeometry = BRepBuilderEdgeGeometry.Create(Arc.Create(New XYZ(0, -100, 100), New XYZ(100, -100, 100), New XYZ(50, -50, 100)))
    Dim backEdgeTop As BRepBuilderEdgeGeometry = BRepBuilderEdgeGeometry.Create(Arc.Create(New XYZ(0, -100, 100), New XYZ(100, -100, 100), New XYZ(50, -150, 100)))

    Dim linearEdgeFront As BRepBuilderEdgeGeometry = BRepBuilderEdgeGeometry.Create(New XYZ(100, -100, 0), New XYZ(100, -100, 100))
    Dim linearEdgeBack As BRepBuilderEdgeGeometry = BRepBuilderEdgeGeometry.Create(New XYZ(0, -100, 0), New XYZ(0, -100, 100))

    ' Add the six edges
    Dim frontEdgeBottomId As BRepBuilderGeometryId = brepBuilder.AddEdge(frontEdgeBottom)
    Dim frontEdgeTopId As BRepBuilderGeometryId = brepBuilder.AddEdge(frontEdgeTop)
    Dim linearEdgeFrontId As BRepBuilderGeometryId = brepBuilder.AddEdge(linearEdgeFront)
    Dim linearEdgeBackId As BRepBuilderGeometryId = brepBuilder.AddEdge(linearEdgeBack)
    Dim backEdgeBottomId As BRepBuilderGeometryId = brepBuilder.AddEdge(backEdgeBottom)
    Dim backEdgeTopId As BRepBuilderGeometryId = brepBuilder.AddEdge(backEdgeTop)

    ' Loops of the four faces
    Dim loopId_Top As BRepBuilderGeometryId = brepBuilder.AddLoop(topFaceId)
    Dim loopId_Bottom As BRepBuilderGeometryId = brepBuilder.AddLoop(bottomFaceId)
    Dim loopId_Front As BRepBuilderGeometryId = brepBuilder.AddLoop(frontCylFaceId)
    Dim loopId_Back As BRepBuilderGeometryId = brepBuilder.AddLoop(backCylFaceId)

    ' Add coedges for the loop of the front face
    brepBuilder.AddCoEdge(loopId_Front, linearEdgeBackId, False)
    brepBuilder.AddCoEdge(loopId_Front, frontEdgeTopId, False)
    brepBuilder.AddCoEdge(loopId_Front, linearEdgeFrontId, True)
    brepBuilder.AddCoEdge(loopId_Front, frontEdgeBottomId, True)
    brepBuilder.FinishLoop(loopId_Front)
    brepBuilder.FinishFace(frontCylFaceId)

    ' Add coedges for the loop of the back face
    brepBuilder.AddCoEdge(loopId_Back, linearEdgeBackId, True)
    brepBuilder.AddCoEdge(loopId_Back, backEdgeBottomId, True)
    brepBuilder.AddCoEdge(loopId_Back, linearEdgeFrontId, False)
    brepBuilder.AddCoEdge(loopId_Back, backEdgeTopId, True)
    brepBuilder.FinishLoop(loopId_Back)
    brepBuilder.FinishFace(backCylFaceId)

    ' Add coedges for the loop of the top face
    brepBuilder.AddCoEdge(loopId_Top, backEdgeTopId, False)
    brepBuilder.AddCoEdge(loopId_Top, frontEdgeTopId, True)
    brepBuilder.FinishLoop(loopId_Top)
    brepBuilder.FinishFace(topFaceId)

    ' Add coedges for the loop of the bottom face
    brepBuilder.AddCoEdge(loopId_Bottom, frontEdgeBottomId, False)
    brepBuilder.AddCoEdge(loopId_Bottom, backEdgeBottomId, False)
    brepBuilder.FinishLoop(loopId_Bottom)
    brepBuilder.FinishFace(bottomFaceId)

    brepBuilder.Finish()

    Using tr As New Transaction(doc, "Create a DirectShape")
        tr.Start()
        Dim ds As DirectShape = DirectShape.CreateElement(doc, New ElementId(BuiltInCategory.OST_GenericModel))
        ds.SetShape(brepBuilder)
        tr.Commit()
    End Using
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


BRepBuilder Constructor

Construct a BRepBuilder to use in constructing geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BRepBuilder(
    BRepType geomType
)
Public Sub New (
    geomType As BRepType
)
public:
BRepBuilder(
    BRepType geomType
)
new :
        geomType : BRepType -> BRepBuilder

Parameters

geomType BRepType
Specifies the expected type of the output geometry.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

BRepBuilder Class


BRepBuilder Properties

The BRepBuilder type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ShapeBuilder)
Top
See Also

Reference

BRepBuilder Class


BRepBuilder Methods

The BRepBuilder type exposes the following members.

Methods
 | Name | Description
Public method | AddCoEdge | Add a co-edge associated to a previously added edge. A co-edge represents the use of an edge on one of the edge's faces. BrepBuilder allows at most two faces per edge, hence at most two co-edges per edge, and the co-edges must have opposite bCoEdgeIsReversed flags. The co-edges in a loop must be added in the order in which they occur in the loop (i.e., in their topological order).
Public method | AddEdge | Add a new edge to the geometry being built. The BRepBuilder uses edges only to store edge geometry and to track pairs of co-edges that share an edge.
Public method | AddFace | Creates an empty face in the geometry being built. Other BRepBuilder methods are used to add loops to the face.
Public method | AddLoop | Creates an empty loop in a given face of the geometry being built. Other BRepBuilder methods are used to add co-edges to the loop.
Public method | AllowRemovalOfProblematicFaces | Allow BRepBuilder to remove problematic faces (e.g., due to inaccurate edge geometry). If this option is enabled and BRepBuilder removes some faces, the output geometry's type will be OpenShell regardless of the expected type specified when the BRepBuilder was created.
Public method | CanAddGeometry | A validator function that checks the state of this BRepBuilder object. Returns true if this BRepBuilder object is accepting b-rep data, false otherwise.
Public method | Dispose | (Inherited from ShapeBuilder)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Finish | Complete construction of the geometry. The geometry will be validated and, if valid, stored in this BRepBuilder. Otherwise it will be deleted.
Public method | FinishFace | Indicates that the caller has finished defining the given face.
Public method | FinishLoop | Indicates that the caller has finished defining the given loop.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetResult | Get the Solid built by this BRepBuilder. This will clear the built geometry stored in the BRepBuilder. This function will throw if this BRepBuilder hasn't completed building the b-rep. Use IsResultAvailable() to verify that this BRepBuilder contains a valid result.
Public method | GetResult(ExternalGeometryId, BRepBuilderPersistentIds) | Get the ExternallyTaggedBRep built by this BRepBuilder. This will clear the built geometry stored in the BRepBuilder. This function will throw if this BRepBuilder hasn't completed building the b-rep. Use IsResultAvailable() to verify that this BRepBuilder contains a valid result.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | IsPermittedSurfaceType | A validator function that checks whether the surface object is of type supported as face surface by BRepBuilder.
Public method | IsResultAvailable | A validator function that checks the state of this BRepBuilder object. Returns true if this BRepBuilder object has successfully built a b-rep.
Public method | IsValidEdgeId | A validator function that checks whether the edge id corresponds to an edge previously added to this BRepBuilder object.
Public method | IsValidFaceId | A validator function that checks whether the face id corresponds to a face previously added to this BRepBuilder object.
Public method | IsValidLoopId | A validator function that checks whether the loop id corresponds to a loop previously added to this BRepBuilder object.
Public method | IsValidPersistentIdsMap | A validator function that makes sure that all BRepBuilderGeometryIds in the input map can be found in this BRepBuilder object.
Public method | RemovedSomeFaces | Returns 'true' if BRepBuilder removed some problematic faces from the output geometry, 'false' if not. If allowRemovalOfProblematicFaces was not called to enable removal of problematic faces, this function will return 'false'. Note that if some faces were removed, the output geometry's type will be OpenShell regardless of the expected type that was specified when the BRepBuilder was created.
Public method | SetAllowShortEdges | Make BRepBuilder allow edges that it would normally disallow as being too short for Revit geometry.
Public method | SetFaceMaterialId | Sets material id to a face.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

BRepBuilder Class


BRepBuilder.AddCoEdge Method

BRepBuilderAddCoEdge Method

Add a co-edge associated to a previously added edge. A co-edge represents the use of an edge on one of the edge's faces. BrepBuilder allows at most two faces per edge, hence at most two co-edges per edge, and the co-edges must have opposite bCoEdgeIsReversed flags. The co-edges in a loop must be added in the order in which they occur in the loop (i.e., in their topological order).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BRepBuilderGeometryId AddCoEdge(
    BRepBuilderGeometryId loopId,
    BRepBuilderGeometryId edgeId,
    bool bCoEdgeIsReversed
)
Public Function AddCoEdge (
    loopId As BRepBuilderGeometryId,
    edgeId As BRepBuilderGeometryId,
    bCoEdgeIsReversed As Boolean
) As BRepBuilderGeometryId
public:
BRepBuilderGeometryId^ AddCoEdge(
    BRepBuilderGeometryId^ loopId,
    BRepBuilderGeometryId^ edgeId,
    bool bCoEdgeIsReversed
)
member AddCoEdge :
        loopId : BRepBuilderGeometryId *
        edgeId : BRepBuilderGeometryId *
        bCoEdgeIsReversed : bool -> BRepBuilderGeometryId

Parameters

loopId BRepBuilderGeometryId
Id of the loop containing the new co-edge.
edgeId BRepBuilderGeometryId
Id of the co-edge's edge, previously created by a call to addEdge().
bCoEdgeIsReversed Boolean
True if the co-edge's topological direction in its face is opposite to the edge's parametric direction, false otherwise. The topological directions of the co-edges in a loop must be consistent with the direction in which the loop co-edges appear in the loop, and the loop orientations so defined must follow the convention that outer loops are oriented counter-clockwise and inner loops are oriented clockwise, with respect to the face's orientation.

Return Value

BRepBuilderGeometryId
Id of the edge, to be used in calls to other BRepBuilder methods such as AddCoEdge().
Exceptions
Exception | Condition
ArgumentException | The supplied loop id doesn't correspond to a loop stored in this BRepBuilder object. -or- The supplied edge id doesn't correspond to an edge stored in this BRepBuilder object. -or- FinishLoop() has already been called on loopId. -or- The edge already has two coedges associated to it. -or- Inconsistent use of the edge by co-edges is detected: both co-edges have the same bCoedgeIsReversed parameter. -or- The edge has already been added to this face. -or- There is a gap between this co-edge and the previous co-edge in the loop.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This BRepBuilder object isn't accepting new data, either because it has already been used to build geometry, or because of an error. Consult the State property of the BRepBuilder object for more details.
See Also

Reference

BRepBuilder Class


BRepBuilder.AddEdge Method

BRepBuilderAddEdge Method

Add a new edge to the geometry being built. The BRepBuilder uses edges only to store edge geometry and to track pairs of co-edges that share an edge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BRepBuilderGeometryId AddEdge(
    BRepBuilderEdgeGeometry edgeGeom
)
Public Function AddEdge (
    edgeGeom As BRepBuilderEdgeGeometry
) As BRepBuilderGeometryId
public:
BRepBuilderGeometryId^ AddEdge(
    BRepBuilderEdgeGeometry^ edgeGeom
)
member AddEdge :
        edgeGeom : BRepBuilderEdgeGeometry -> BRepBuilderGeometryId

Parameters

edgeGeom BRepBuilderEdgeGeometry
Information specifying the edge's geometry.

Return Value

BRepBuilderGeometryId
Id of the edge, to be used in calls to other BRepBuilder methods such as AddCoEdge().
Exceptions
Exception | Condition
ArgumentException | The input edge geometry was invalid.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This BRepBuilder object isn't accepting new data, either because it has already been used to build geometry, or because of an error. Consult the State property of the BRepBuilder object for more details.
See Also

Reference

BRepBuilder Class


BRepBuilder.AddFace Method

BRepBuilderAddFace Method

Creates an empty face in the geometry being built. Other BRepBuilder methods are used to add loops to the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BRepBuilderGeometryId AddFace(
    BRepBuilderSurfaceGeometry surfaceGeom,
    bool bFaceIsReversed
)
Public Function AddFace (
    surfaceGeom As BRepBuilderSurfaceGeometry,
    bFaceIsReversed As Boolean
) As BRepBuilderGeometryId
public:
BRepBuilderGeometryId^ AddFace(
    BRepBuilderSurfaceGeometry^ surfaceGeom,
    bool bFaceIsReversed
)
member AddFace :
        surfaceGeom : BRepBuilderSurfaceGeometry *
        bFaceIsReversed : bool -> BRepBuilderGeometryId

Parameters

surfaceGeom BRepBuilderSurfaceGeometry
The face's support surface.
bFaceIsReversed Boolean
True if the face's orientation is opposite to that of the surface, false if the orientations agree. The faces of each shell must be consistently oriented. For a solid (BRepType == Solid), the oriented face normals must point out of the solid; for a void (BRepType == Void), the face normals must point into the void. See the description of the bCoEdgeIsReversed input for AddCoEdge() for a discussion of the loop and co-edge orientation conventions to use with the BRepBuilder.

Return Value

BRepBuilderGeometryId
An id that can be used to identify the face while the BRepBuilder is actively building geometry (e.g., to add a loop to a face).
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This BRepBuilder object isn't accepting new data, either because it has already been used to build geometry, or because of an error. Consult the State property of the BRepBuilder object for more details.
See Also

Reference

BRepBuilder Class


BRepBuilder.AddLoop Method

BRepBuilderAddLoop Method

Creates an empty loop in a given face of the geometry being built. Other BRepBuilder methods are used to add co-edges to the loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BRepBuilderGeometryId AddLoop(
    BRepBuilderGeometryId faceId
)
Public Function AddLoop (
    faceId As BRepBuilderGeometryId
) As BRepBuilderGeometryId
public:
BRepBuilderGeometryId^ AddLoop(
    BRepBuilderGeometryId^ faceId
)
member AddLoop :
        faceId : BRepBuilderGeometryId -> BRepBuilderGeometryId

Parameters

faceId BRepBuilderGeometryId
Id of the face to which the loop should be added. faceId was returned by a call to AddFace().

Return Value

BRepBuilderGeometryId
An id that can be used to identify the loop while the BRepBuilder is actively building geometry (e.g., to add co-edges to the loop).
Exceptions
Exception | Condition
ArgumentException | The supplied face id doesn't correspond to a face stored in this BRepBuilder object. -or- FinishFace() has already been called on faceId. -or- Please finish the previous loop by calling FinishLoop() before adding a new one.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This BRepBuilder object isn't accepting new data, either because it has already been used to build geometry, or because of an error. Consult the State property of the BRepBuilder object for more details.
See Also

Reference

BRepBuilder Class


BRepBuilder.AllowRemovalOfProblematicFaces Method

BRepBuilderAllowRemovalOfProblematicFaces Method

Allow BRepBuilder to remove problematic faces (e.g., due to inaccurate edge geometry). If this option is enabled and BRepBuilder removes some faces, the output geometry's type will be OpenShell regardless of the expected type specified when the BRepBuilder was created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AllowRemovalOfProblematicFaces()
Public Sub AllowRemovalOfProblematicFaces
public:
void AllowRemovalOfProblematicFaces()
member AllowRemovalOfProblematicFaces : unit -> unit
See Also

Reference

BRepBuilder Class


BRepBuilder.CanAddGeometry Method

BRepBuilderCanAddGeometry Method

A validator function that checks the state of this BRepBuilder object. Returns true if this BRepBuilder object is accepting b-rep data, false otherwise.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanAddGeometry()
Public Function CanAddGeometry As Boolean
public:
bool CanAddGeometry()
member CanAddGeometry : unit -> bool

Return Value

Boolean
True if this BRepBuilder object is accepting b-rep data, false otherwise.
Remarks
Use this function before calling AddFace(), AddEdge(), etc. to avoid an exception being thrown.
See Also

Reference

BRepBuilder Class


BRepBuilder.Finish Method

BRepBuilderFinish Method

Complete construction of the geometry. The geometry will be validated and, if valid, stored in this BRepBuilder. Otherwise it will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BRepBuilderOutcome Finish()
Public Function Finish As BRepBuilderOutcome
public:
BRepBuilderOutcome Finish()
member Finish : unit -> BRepBuilderOutcome

Return Value

BRepBuilderOutcome
BRepBuilderOutcome.Success if successful, BRepBuilderOutcome.Failure otherwise.
Exceptions
Exception | Condition
InvalidOperationException | This BRepBuilder object isn't accepting new data, either because it has already been used to build geometry, or because of an error. Consult the State property of the BRepBuilder object for more details. -or- BRep doesn't have enough faces. -or- FinishFace() must be called on all the faces of the BRepBuilder.
Remarks
If this function returned anything but BRepBuilderOutcome.Success, this BrepBuilder object should be discarded. An attempt to retrieve the built b-rep via GetBRep() will cause an exception to be thrown.
See Also

Reference

BRepBuilder Class


BRepBuilder.FinishFace Method

BRepBuilderFinishFace Method

Indicates that the caller has finished defining the given face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void FinishFace(
    BRepBuilderGeometryId faceId
)
Public Sub FinishFace (
    faceId As BRepBuilderGeometryId
)
public:
void FinishFace(
    BRepBuilderGeometryId^ faceId
)
member FinishFace :
        faceId : BRepBuilderGeometryId -> unit

Parameters

faceId BRepBuilderGeometryId
Id of the face.
Exceptions
Exception | Condition
ArgumentException | The supplied face id doesn't correspond to a face stored in this BRepBuilder object. -or- FinishFace() has already been called on faceId. -or- The face has no edge loops. -or- FinishLoop() must be called on all the edge loops of faceId.
ArgumentNullException | A non-optional argument was null
Remarks
No functions that modify the given face's definition should be called after calling this function (e.g., AddLoop(BRepBuilderGeometryId), SetFaceMaterialId(BRepBuilderGeometryId, ElementId)). The BRepBuilder may take the opportunity to validate some of the face's data and report any problems it finds.
See Also

Reference

BRepBuilder Class


BRepBuilder.FinishLoop Method

BRepBuilderFinishLoop Method

Indicates that the caller has finished defining the given loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void FinishLoop(
    BRepBuilderGeometryId loopId
)
Public Sub FinishLoop (
    loopId As BRepBuilderGeometryId
)
public:
void FinishLoop(
    BRepBuilderGeometryId^ loopId
)
member FinishLoop :
        loopId : BRepBuilderGeometryId -> unit

Parameters

loopId BRepBuilderGeometryId
Id of the loop.
Exceptions
Exception | Condition
ArgumentException | The supplied loop id doesn't correspond to a loop stored in this BRepBuilder object. -or- FinishLoop() has already been called on loopId. -or- The edge loop has fewer than two co-edges.
ArgumentNullException | A non-optional argument was null
Remarks
No functions that modify the given loop's definition should be called after calling this function (e.g., AddCoEdge(BRepBuilderGeometryId, BRepBuilderGeometryId, Boolean)). The BRepBuilder may take the opportunity to validate some of the loop's data and report any problems it finds.
See Also

Reference

BRepBuilder Class


BRepBuilder.GetResult Method

BRepBuilderGetResult Method

Overload List
 | Name | Description
Public method | GetResult | Get the Solid built by this BRepBuilder. This will clear the built geometry stored in the BRepBuilder. This function will throw if this BRepBuilder hasn't completed building the b-rep. Use IsResultAvailable() to verify that this BRepBuilder contains a valid result.
Public method | GetResult(ExternalGeometryId, BRepBuilderPersistentIds) | Get the ExternallyTaggedBRep built by this BRepBuilder. This will clear the built geometry stored in the BRepBuilder. This function will throw if this BRepBuilder hasn't completed building the b-rep. Use IsResultAvailable() to verify that this BRepBuilder contains a valid result.
Top
See Also

Reference

BRepBuilder Class


BRepBuilder.GetResult Method

BRepBuilderGetResult Method

Get the Solid built by this BRepBuilder. This will clear the built geometry stored in the BRepBuilder. This function will throw if this BRepBuilder hasn't completed building the b-rep. Use IsResultAvailable() to verify that this BRepBuilder contains a valid result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Solid GetResult()
Public Function GetResult As Solid
public:
Solid^ GetResult()
member GetResult : unit -> Solid

Return Value

Solid
The Solid built by this BRepBuilder.
Exceptions
Exception | Condition
InvalidOperationException | This BRepBuilder object hasn't completed building data or was unsuccessful building it. Built Geometry is unavailable. In order to access the built Geometry, Finish() must be called first. That will set the state to completed.
See Also

Reference

BRepBuilder Class
GetResult Overload


BRepBuilder.GetResult(ExternalGeometryId, BRepBuilderPersistentIds) Method

BRepBuilderGetResult(ExternalGeometryId, BRepBuilderPersistentIds) Method

Get the ExternallyTaggedBRep built by this BRepBuilder. This will clear the built geometry stored in the BRepBuilder. This function will throw if this BRepBuilder hasn't completed building the b-rep. Use IsResultAvailable() to verify that this BRepBuilder contains a valid result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExternallyTaggedBRep GetResult(
    ExternalGeometryId externalId,
    BRepBuilderPersistentIds brepPersistentIds
)
Public Function GetResult (
    externalId As ExternalGeometryId,
    brepPersistentIds As BRepBuilderPersistentIds
) As ExternallyTaggedBRep
public:
ExternallyTaggedBRep^ GetResult(
    ExternalGeometryId^ externalId,
    BRepBuilderPersistentIds^ brepPersistentIds
)
member GetResult :
        externalId : ExternalGeometryId *
        brepPersistentIds : BRepBuilderPersistentIds -> ExternallyTaggedBRep

Parameters

externalId ExternalGeometryId
The external Id of the GeometryObject built by this BRepBuilder.
brepPersistentIds BRepBuilderPersistentIds
An object storing the relationship between ExternalGeometryIds and BRepBuilderGeometryIds.

Return Value

ExternallyTaggedBRep
The ExternallyTaggedBRep built by this BRepBuilder.
Exceptions
Exception | Condition
ArgumentException | At least one BRepBuilderGeometryId in the supplied BRepBuilderPersistentIds map could not be found in this BRepBuilder object.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This BRepBuilder object hasn't completed building data or was unsuccessful building it. Built Geometry is unavailable. In order to access the built Geometry, Finish() must be called first. That will set the state to completed.
See Also

Reference

BRepBuilder Class
GetResult Overload


BRepBuilder.IsPermittedSurfaceType Method

BRepBuilderIsPermittedSurfaceType Method

A validator function that checks whether the surface object is of type supported as face surface by BRepBuilder.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsPermittedSurfaceType(
    Surface surface
)
Public Shared Function IsPermittedSurfaceType (
    surface As Surface
) As Boolean
public:
static bool IsPermittedSurfaceType(
    Surface^ surface
)
static member IsPermittedSurfaceType :
        surface : Surface -> bool

Parameters

surface Surface
Surface object intended to be used as a face surface.

Return Value

Boolean
True if a surface of this type may be used as a face surface, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
The allowed surface types are ConicalSurface, CylindricalSurface, Plane, RevolvedSurface, RuledSurface, and HermiteSurface.
See Also

Reference

BRepBuilder Class


BRepBuilder.IsResultAvailable Method

BRepBuilderIsResultAvailable Method

A validator function that checks the state of this BRepBuilder object. Returns true if this BRepBuilder object has successfully built a b-rep.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsResultAvailable()
Public Function IsResultAvailable As Boolean
public:
bool IsResultAvailable()
member IsResultAvailable : unit -> bool

Return Value

Boolean
True if this BRepBuilder object has successfully built a b-rep.
Remarks
The b-rep object may be retrieved via GetResult(). Use this function before calling GetResult() to avoid an exception being thrown.
See Also

Reference

BRepBuilder Class


BRepBuilder.IsValidEdgeId Method

BRepBuilderIsValidEdgeId Method

A validator function that checks whether the edge id corresponds to an edge previously added to this BRepBuilder object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidEdgeId(
    BRepBuilderGeometryId edgeId
)
Public Function IsValidEdgeId (
    edgeId As BRepBuilderGeometryId
) As Boolean
public:
bool IsValidEdgeId(
    BRepBuilderGeometryId^ edgeId
)
member IsValidEdgeId :
        edgeId : BRepBuilderGeometryId -> bool

Parameters

edgeId BRepBuilderGeometryId
Edge id to be validated.

Return Value

Boolean
True if edgeId corresponds to an edge previously added to this BRepBuilder, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

BRepBuilder Class


BRepBuilder.IsValidFaceId Method

BRepBuilderIsValidFaceId Method

A validator function that checks whether the face id corresponds to a face previously added to this BRepBuilder object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidFaceId(
    BRepBuilderGeometryId faceId
)
Public Function IsValidFaceId (
    faceId As BRepBuilderGeometryId
) As Boolean
public:
bool IsValidFaceId(
    BRepBuilderGeometryId^ faceId
)
member IsValidFaceId :
        faceId : BRepBuilderGeometryId -> bool

Parameters

faceId BRepBuilderGeometryId
Face id to be validated.

Return Value

Boolean
True if faceId corresponds to a face previously added to this BRepBuilder, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

BRepBuilder Class


BRepBuilder.IsValidLoopId Method

BRepBuilderIsValidLoopId Method

A validator function that checks whether the loop id corresponds to a loop previously added to this BRepBuilder object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidLoopId(
    BRepBuilderGeometryId loopId
)
Public Function IsValidLoopId (
    loopId As BRepBuilderGeometryId
) As Boolean
public:
bool IsValidLoopId(
    BRepBuilderGeometryId^ loopId
)
member IsValidLoopId :
        loopId : BRepBuilderGeometryId -> bool

Parameters

loopId BRepBuilderGeometryId
Loop id to be validated.

Return Value

Boolean
True if loopId corresponds to a loop previously added to this BRepBuilder, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

BRepBuilder Class


BRepBuilder.IsValidPersistentIdsMap Method

BRepBuilderIsValidPersistentIdsMap Method

A validator function that makes sure that all BRepBuilderGeometryIds in the input map can be found in this BRepBuilder object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidPersistentIdsMap(
    BRepBuilderPersistentIds brepPersistentIds
)
Public Function IsValidPersistentIdsMap (
    brepPersistentIds As BRepBuilderPersistentIds
) As Boolean
public:
bool IsValidPersistentIdsMap(
    BRepBuilderPersistentIds^ brepPersistentIds
)
member IsValidPersistentIdsMap :
        brepPersistentIds : BRepBuilderPersistentIds -> bool

Parameters

brepPersistentIds BRepBuilderPersistentIds
The map that associates ExternalGeometryIds to BRepBuilderGeometryIds.

Return Value

Boolean
True if all BRepBuilderGeometryIds in the input map can be found in this BRepBuilder object, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

BRepBuilder Class


BRepBuilder.RemovedSomeFaces Method

BRepBuilderRemovedSomeFaces Method

Returns 'true' if BRepBuilder removed some problematic faces from the output geometry, 'false' if not. If allowRemovalOfProblematicFaces was not called to enable removal of problematic faces, this function will return 'false'. Note that if some faces were removed, the output geometry's type will be OpenShell regardless of the expected type that was specified when the BRepBuilder was created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool RemovedSomeFaces()
Public Function RemovedSomeFaces As Boolean
public:
bool RemovedSomeFaces()
member RemovedSomeFaces : unit -> bool

Return Value

Boolean
True if BRepBuilder removed some faces, false if not.
See Also

Reference

BRepBuilder Class


BRepBuilder.SetAllowShortEdges Method

BRepBuilderSetAllowShortEdges Method

Make BRepBuilder allow edges that it would normally disallow as being too short for Revit geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetAllowShortEdges()
Public Sub SetAllowShortEdges
public:
void SetAllowShortEdges()
member SetAllowShortEdges : unit -> unit
Exceptions
Exception | Condition
InvalidOperationException | This function was called after the geometry had been defined (e.g. by calls to addFace).
Remarks
When used, this function must be called before any geometry is defined (e.g., just after constructing a BRepBuilder object). Geometry with short edges may not be as reliable as fully valid geometry. This option is intended to allow the construction of geometry such as mechanical items with small features that is not expected to interact much with other Revit elements.
See Also

Reference

BRepBuilder Class


BRepBuilder.SetFaceMaterialId Method

BRepBuilderSetFaceMaterialId Method

Sets material id to a face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetFaceMaterialId(
    BRepBuilderGeometryId faceId,
    ElementId materialId
)
Public Sub SetFaceMaterialId (
    faceId As BRepBuilderGeometryId,
    materialId As ElementId
)
public:
void SetFaceMaterialId(
    BRepBuilderGeometryId^ faceId,
    ElementId^ materialId
)
member SetFaceMaterialId :
        faceId : BRepBuilderGeometryId *
        materialId : ElementId -> unit

Parameters

faceId BRepBuilderGeometryId
Id of the face to which material id will be added. faceId was returned by a call to AddFace().
materialId ElementId
The material id associated with the face, or invalidElementId if none. It is not verified that materialId corresponds to a valid Material element.
Exceptions
Exception | Condition
ArgumentException | The supplied face id doesn't correspond to a face stored in this BRepBuilder object.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This BRepBuilder object isn't accepting new data, either because it has already been used to build geometry, or because of an error. Consult the State property of the BRepBuilder object for more details.
See Also

Reference

BRepBuilder Class


BRepBuilderEdgeGeometry Class

An abstract class used by BRepBuilder to represent the geometry of an edge. Specific edge-geometry representations are represented by subclasses.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBRepBuilderEdgeGeometry

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BRepBuilderEdgeGeometry : IDisposable
Public Class BRepBuilderEdgeGeometry
    Implements IDisposable
public ref class BRepBuilderEdgeGeometry : IDisposable
type BRepBuilderEdgeGeometry =
    class
        interface IDisposable
    end

The BRepBuilderEdgeGeometry type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
 | Create(Curve) | Construct BRepBuilderEdgeGeometry based on any Revit Curve, including Line and Arc. The curve will be simplified if possible.
 | Create(XYZ, XYZ) | Constructs a BRepBuilderEdgeGeometry representing a straight line between the two given points.
Public method | Dispose | Releases all resources used by the BRepBuilderEdgeGeometry
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


BRepBuilderEdgeGeometry Properties

The BRepBuilderEdgeGeometry type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

BRepBuilderEdgeGeometry Class


BRepBuilderEdgeGeometry.IsValidObject Property

BRepBuilderEdgeGeometryIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

BRepBuilderEdgeGeometry Class


BRepBuilderEdgeGeometry Methods

The BRepBuilderEdgeGeometry type exposes the following members.

Methods
 | Name | Description
 | Create(Curve) | Construct BRepBuilderEdgeGeometry based on any Revit Curve, including Line and Arc. The curve will be simplified if possible.
 | Create(XYZ, XYZ) | Constructs a BRepBuilderEdgeGeometry representing a straight line between the two given points.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

BRepBuilderEdgeGeometry Class


BRepBuilderEdgeGeometry.Create Method

BRepBuilderEdgeGeometryCreate Method

Overload List
Name | Description
Create(Curve) | Construct BRepBuilderEdgeGeometry based on any Revit Curve, including Line and Arc. The curve will be simplified if possible.
Create(XYZ, XYZ) | Constructs a BRepBuilderEdgeGeometry representing a straight line between the two given points.
Top
See Also

Reference

BRepBuilderEdgeGeometry Class


BRepBuilderEdgeGeometry.Create(Curve) Method

BRepBuilderEdgeGeometryCreate(Curve) Method

Construct BRepBuilderEdgeGeometry based on any Revit Curve, including Line and Arc. The curve will be simplified if possible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static BRepBuilderEdgeGeometry Create(
    Curve curve
)
Public Shared Function Create (
    curve As Curve
) As BRepBuilderEdgeGeometry
public:
static BRepBuilderEdgeGeometry^ Create(
    Curve^ curve
)
static member Create :
        curve : Curve -> BRepBuilderEdgeGeometry

Parameters

curve Curve
The 3D curve for this edge. This BRepBuilderEdgeGeometry stores a copy of the input curve.

Return Value

BRepBuilderEdgeGeometry
Exceptions
Exception | Condition
ArgumentException | The input curve is not bound. -or- The curve is degenerate (its length is too close to zero). -or- The endpoints of the curve are close enough that Revit considers it a closed curve.
ArgumentNullException | A non-optional argument was null
See Also

Reference

BRepBuilderEdgeGeometry Class
Create Overload


BRepBuilderEdgeGeometry.Create(XYZ, XYZ) Method

BRepBuilderEdgeGeometryCreate(XYZ, XYZ) Method

Constructs a BRepBuilderEdgeGeometry representing a straight line between the two given points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static BRepBuilderEdgeGeometry Create(
    XYZ startPoint,
    XYZ endPoint
)
Public Shared Function Create (
    startPoint As XYZ,
    endPoint As XYZ
) As BRepBuilderEdgeGeometry
public:
static BRepBuilderEdgeGeometry^ Create(
    XYZ^ startPoint,
    XYZ^ endPoint
)
static member Create :
        startPoint : XYZ *
        endPoint : XYZ -> BRepBuilderEdgeGeometry

Parameters

startPoint XYZ
endPoint XYZ

Return Value

BRepBuilderEdgeGeometry
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentsInconsistentException | The vectors startPoint and endPoint are coincident.
See Also

Reference

BRepBuilderEdgeGeometry Class
Create Overload


BRepBuilderEdgeGeometry.Dispose Method

BRepBuilderEdgeGeometryDispose Method

Releases all resources used by the BRepBuilderEdgeGeometry

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

BRepBuilderEdgeGeometry Class


BRepBuilderGeometryId Class

This class is used by the BRepBuilder class to identify objects it creates (faces, edges, etc.).
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBRepBuilderGeometryId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BRepBuilderGeometryId : IDisposable
Public Class BRepBuilderGeometryId
    Implements IDisposable
public ref class BRepBuilderGeometryId : IDisposable
type BRepBuilderGeometryId =
    class
        interface IDisposable
    end

The BRepBuilderGeometryId type exposes the following members.

Constructors
 | Name | Description
Public method | BRepBuilderGeometryId | Copy constructor
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the BRepBuilderGeometryId
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | InvalidGeometryId | Returns an invalid BRepBuilderGeometryId, used as a return value to indicate an error.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The user should use these ids to organize the calls to BRepBuilder methods (e.g., addLoop() takes a face id as input, referring to a face that was previously added by a call to AddFace()). The ids are only valid while the BRepBuilder is in use.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


BRepBuilderGeometryId Constructor

Copy constructor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BRepBuilderGeometryId(
    BRepBuilderGeometryId other
)
Public Sub New (
    other As BRepBuilderGeometryId
)
public:
BRepBuilderGeometryId(
    BRepBuilderGeometryId^ other
)
new :
        other : BRepBuilderGeometryId -> BRepBuilderGeometryId

Parameters

other BRepBuilderGeometryId
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

BRepBuilderGeometryId Class


BRepBuilderGeometryId Properties

The BRepBuilderGeometryId type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

BRepBuilderGeometryId Class


BRepBuilderGeometryId.IsValidObject Property

BRepBuilderGeometryIdIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

BRepBuilderGeometryId Class


BRepBuilderGeometryId Methods

The BRepBuilderGeometryId type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | InvalidGeometryId | Returns an invalid BRepBuilderGeometryId, used as a return value to indicate an error.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

BRepBuilderGeometryId Class


BRepBuilderGeometryId.Dispose Method

BRepBuilderGeometryIdDispose Method

Releases all resources used by the BRepBuilderGeometryId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

BRepBuilderGeometryId Class


BRepBuilderGeometryId.InvalidGeometryId Method

BRepBuilderGeometryIdInvalidGeometryId Method

Returns an invalid BRepBuilderGeometryId, used as a return value to indicate an error.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static BRepBuilderGeometryId InvalidGeometryId()
Public Shared Function InvalidGeometryId As BRepBuilderGeometryId
public:
static BRepBuilderGeometryId^ InvalidGeometryId()
static member InvalidGeometryId : unit -> BRepBuilderGeometryId

Return Value

BRepBuilderGeometryId
See Also

Reference

BRepBuilderGeometryId Class


BRepBuilderOutcome Enumeration

This class defines possible outcomes returned by BRepBuilder functions that need to report outcome via a return value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum BRepBuilderOutcome
Public Enumeration BRepBuilderOutcome
public enum class BRepBuilderOutcome
type BRepBuilderOutcome
Members
Member name | Value | Description
Success | 0 | The function has completed successfully.
Failure | 1 | Unspecified failure. BRepBuilder object is in invalid state and should not be used.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


BRepBuilderPersistentIds Class

This class stores a map from ExternalGeometryIds to BRepBuilderGeometryIds.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBRepBuilderPersistentIds

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BRepBuilderPersistentIds : IDisposable
Public Class BRepBuilderPersistentIds
    Implements IDisposable
public ref class BRepBuilderPersistentIds : IDisposable
type BRepBuilderPersistentIds =
    class
        interface IDisposable
    end

The BRepBuilderPersistentIds type exposes the following members.

Constructors
 | Name | Description
Public method | BRepBuilderPersistentIds | Constructs a new BRepBuilderPersistentIds and associates the existing BRepBuilder to it.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | AddSubTag | Adds a correspondence between an ExternalGeometryId and a BRepBuilderGeometryId. Note that an existing correspondence in the map cannot be updated and that a particular BRepBuilderGeometryId may be related to at most one ExternalGeometryId.
Public method | Dispose | Releases all resources used by the BRepBuilderPersistentIds
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsAssociatedBRepBuilderValid | Validates the associated (in the constructor) BRepBuilder for this BRepBuilderPersistentIds.
Public method | IsBRepBuilderGeometryIdFaceOrEdge | Validates the input BRepBuilderGeometryId that will be used to create a correspondence. In order to be valid, the input BRepBuilderGeometryId must represent the ID of either a Face or an Edge.
Public method | IsValidBRepBuilderGeometryIdForNewCorrespondence | Validates the input BRepBuilderGeometryId that will be used to create a correspondence. In order to be valid, a correspondence for the input BRepBuilderGeometryId must not already exist.
Public method | IsValidExternalGeometryIdForNewCorrespondence | Validates the input ExternalGeometryId that will be used to create a correspondence. In order to be valid, a correspondence for the input ExternalGeometryId must not already exist.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


BRepBuilderPersistentIds Constructor

Constructs a new BRepBuilderPersistentIds and associates the existing BRepBuilder to it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BRepBuilderPersistentIds(
    BRepBuilder bRepBuilder
)
Public Sub New (
    bRepBuilder As BRepBuilder
)
public:
BRepBuilderPersistentIds(
    BRepBuilder^ bRepBuilder
)
new :
        bRepBuilder : BRepBuilder -> BRepBuilderPersistentIds

Parameters

bRepBuilder BRepBuilder
The existing BRepBuilder.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

BRepBuilderPersistentIds Class


BRepBuilderPersistentIds Properties

The BRepBuilderPersistentIds type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

BRepBuilderPersistentIds Class


BRepBuilderPersistentIds.IsValidObject Property

BRepBuilderPersistentIdsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

BRepBuilderPersistentIds Class


BRepBuilderPersistentIds Methods

The BRepBuilderPersistentIds type exposes the following members.

Methods
 | Name | Description
Public method | AddSubTag | Adds a correspondence between an ExternalGeometryId and a BRepBuilderGeometryId. Note that an existing correspondence in the map cannot be updated and that a particular BRepBuilderGeometryId may be related to at most one ExternalGeometryId.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsAssociatedBRepBuilderValid | Validates the associated (in the constructor) BRepBuilder for this BRepBuilderPersistentIds.
Public method | IsBRepBuilderGeometryIdFaceOrEdge | Validates the input BRepBuilderGeometryId that will be used to create a correspondence. In order to be valid, the input BRepBuilderGeometryId must represent the ID of either a Face or an Edge.
Public method | IsValidBRepBuilderGeometryIdForNewCorrespondence | Validates the input BRepBuilderGeometryId that will be used to create a correspondence. In order to be valid, a correspondence for the input BRepBuilderGeometryId must not already exist.
Public method | IsValidExternalGeometryIdForNewCorrespondence | Validates the input ExternalGeometryId that will be used to create a correspondence. In order to be valid, a correspondence for the input ExternalGeometryId must not already exist.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

BRepBuilderPersistentIds Class


BRepBuilderPersistentIds.AddSubTag Method

BRepBuilderPersistentIdsAddSubTag Method

Adds a correspondence between an ExternalGeometryId and a BRepBuilderGeometryId. Note that an existing correspondence in the map cannot be updated and that a particular BRepBuilderGeometryId may be related to at most one ExternalGeometryId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddSubTag(
    ExternalGeometryId externalGeometryId,
    BRepBuilderGeometryId brepBuilderGeometryId
)
Public Sub AddSubTag (
    externalGeometryId As ExternalGeometryId,
    brepBuilderGeometryId As BRepBuilderGeometryId
)
public:
void AddSubTag(
    ExternalGeometryId^ externalGeometryId,
    BRepBuilderGeometryId^ brepBuilderGeometryId
)
member AddSubTag :
        externalGeometryId : ExternalGeometryId *
        brepBuilderGeometryId : BRepBuilderGeometryId -> unit

Parameters

externalGeometryId ExternalGeometryId
An external geometry object Id.
brepBuilderGeometryId BRepBuilderGeometryId
A BRepBuilder geometry object Id. It must represent the ID of either a Face or an Edge.
Exceptions
Exception | Condition
ArgumentException | externalGeometryId cannot be used to create a new correspondence because it is already used. -or- brepBuilderGeometryId cannot be used to create a new correspondence because it is already used. -or- brepBuilderGeometryId cannot be used to create a new correspondence because it doesn't represent the ID of either a Face or an Edge.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The associated BRepBuilder doesn't exist or is not valid (has no Faces and no Edges).
See Also

Reference

BRepBuilderPersistentIds Class


BRepBuilderPersistentIds.Dispose Method

BRepBuilderPersistentIdsDispose Method

Releases all resources used by the BRepBuilderPersistentIds

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

BRepBuilderPersistentIds Class


BRepBuilderPersistentIds.IsAssociatedBRepBuilderValid Method

BRepBuilderPersistentIdsIsAssociatedBRepBuilderValid Method

Validates the associated (in the constructor) BRepBuilder for this BRepBuilderPersistentIds.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsAssociatedBRepBuilderValid()
Public Function IsAssociatedBRepBuilderValid As Boolean
public:
bool IsAssociatedBRepBuilderValid()
member IsAssociatedBRepBuilderValid : unit -> bool

Return Value

Boolean
True if the associated BRepBuilder exists, false otherwise.
See Also

Reference

BRepBuilderPersistentIds Class


BRepBuilderPersistentIds.IsBRepBuilderGeometryIdFaceOrEdge Method

BRepBuilderPersistentIdsIsBRepBuilderGeometryIdFaceOrEdge Method

Validates the input BRepBuilderGeometryId that will be used to create a correspondence. In order to be valid, the input BRepBuilderGeometryId must represent the ID of either a Face or an Edge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsBRepBuilderGeometryIdFaceOrEdge(
    BRepBuilderGeometryId brepBuilderGeometryId
)
Public Function IsBRepBuilderGeometryIdFaceOrEdge (
    brepBuilderGeometryId As BRepBuilderGeometryId
) As Boolean
public:
bool IsBRepBuilderGeometryIdFaceOrEdge(
    BRepBuilderGeometryId^ brepBuilderGeometryId
)
member IsBRepBuilderGeometryIdFaceOrEdge :
        brepBuilderGeometryId : BRepBuilderGeometryId -> bool

Parameters

brepBuilderGeometryId BRepBuilderGeometryId
The BRepBuilderGeometryId to be used in a new correspondence.

Return Value

Boolean
True if the input BRepBuilderGeometryId represents the ID of either a Face or an Edge, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
This method returns false also in the case when the associated BRepBuilder is not valid. Call IsAssociatedBRepBuilderValid to check the associated BRepBuilder.
See Also

Reference

BRepBuilderPersistentIds Class


BRepBuilderPersistentIds.IsValidBRepBuilderGeometryIdForNewCorrespondence Method

BRepBuilderPersistentIdsIsValidBRepBuilderGeometryIdForNewCorrespondence Method

Validates the input BRepBuilderGeometryId that will be used to create a correspondence. In order to be valid, a correspondence for the input BRepBuilderGeometryId must not already exist.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidBRepBuilderGeometryIdForNewCorrespondence(
    BRepBuilderGeometryId brepBuilderGeometryId
)
Public Function IsValidBRepBuilderGeometryIdForNewCorrespondence (
    brepBuilderGeometryId As BRepBuilderGeometryId
) As Boolean
public:
bool IsValidBRepBuilderGeometryIdForNewCorrespondence(
    BRepBuilderGeometryId^ brepBuilderGeometryId
)
member IsValidBRepBuilderGeometryIdForNewCorrespondence :
        brepBuilderGeometryId : BRepBuilderGeometryId -> bool

Parameters

brepBuilderGeometryId BRepBuilderGeometryId
The BRepBuilderGeometryId to be used in a new correspondence.

Return Value

Boolean
True if the input BRepBuilderGeometryId can be used to create a new correspondence.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

BRepBuilderPersistentIds Class


BRepBuilderPersistentIds.IsValidExternalGeometryIdForNewCorrespondence Method

BRepBuilderPersistentIdsIsValidExternalGeometryIdForNewCorrespondence Method

Validates the input ExternalGeometryId that will be used to create a correspondence. In order to be valid, a correspondence for the input ExternalGeometryId must not already exist.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidExternalGeometryIdForNewCorrespondence(
    ExternalGeometryId externalGeometryId
)
Public Function IsValidExternalGeometryIdForNewCorrespondence (
    externalGeometryId As ExternalGeometryId
) As Boolean
public:
bool IsValidExternalGeometryIdForNewCorrespondence(
    ExternalGeometryId^ externalGeometryId
)
member IsValidExternalGeometryIdForNewCorrespondence :
        externalGeometryId : ExternalGeometryId -> bool

Parameters

externalGeometryId ExternalGeometryId
The ExternalGeometryId to be used in a new correspondence.

Return Value

Boolean
True if the input ExternalGeometryId can be used to create a new correspondence.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

BRepBuilderPersistentIds Class


BRepBuilderState Enumeration

This class defines an enumerative type used to specify the state of a BRepBuilder object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum BRepBuilderState
Public Enumeration BRepBuilderState
public enum class BRepBuilderState
type BRepBuilderState
Members
Member name | Value | Description
InvalidState | 0 | BRepBuilder is in an invalid state. No further productive use is possible.
AcceptingData | 1 | BRepBuilder is accumulating data. New b-rep components such as edges or faces may be added.
Completed | 2 | Finish() successfully created a valid Geometry object. No new data may be added.The built object may be retrieved via GetResult().
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


BRepBuilderSurfaceGeometry Class

An abstract class used by BRepBuilder to represent the geometry of a surface. Specific surface-geometry representations are represented by subclasses.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBRepBuilderSurfaceGeometry

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BRepBuilderSurfaceGeometry : IDisposable
Public Class BRepBuilderSurfaceGeometry
    Implements IDisposable
public ref class BRepBuilderSurfaceGeometry : IDisposable
type BRepBuilderSurfaceGeometry =
    class
        interface IDisposable
    end

The BRepBuilderSurfaceGeometry type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
 | Create | Construct BRepBuilderSurfaceGeometry based on a permitted Revit Surface.
 | CreateNURBSSurface(Int32, Int32, IListDouble, IListDouble, IListXYZ, Boolean, BoundingBoxUV) | Construct a BRepBuilderSurfaceGeometry based on NURBS surface data, where the weights are not supplied. In this case, the NURBS surface will be a piecewise polynomial surface.
 | CreateNURBSSurface(Int32, Int32, IListDouble, IListDouble, IListXYZ, IListDouble, Boolean, BoundingBoxUV) | Construct BRepBuilderSurfaceGeometry based on NURBS surface data, where the weights are supplied. In this case, the NURBS surface will be a piecewise rational polynomial surface.
Public method | Dispose | Releases all resources used by the BRepBuilderSurfaceGeometry
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


BRepBuilderSurfaceGeometry Properties

The BRepBuilderSurfaceGeometry type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

BRepBuilderSurfaceGeometry Class


BRepBuilderSurfaceGeometry.IsValidObject Property

BRepBuilderSurfaceGeometryIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

BRepBuilderSurfaceGeometry Class


BRepBuilderSurfaceGeometry Methods

The BRepBuilderSurfaceGeometry type exposes the following members.

Methods
 | Name | Description
 | Create | Construct BRepBuilderSurfaceGeometry based on a permitted Revit Surface.
 | CreateNURBSSurface(Int32, Int32, IListDouble, IListDouble, IListXYZ, Boolean, BoundingBoxUV) | Construct a BRepBuilderSurfaceGeometry based on NURBS surface data, where the weights are not supplied. In this case, the NURBS surface will be a piecewise polynomial surface.
 | CreateNURBSSurface(Int32, Int32, IListDouble, IListDouble, IListXYZ, IListDouble, Boolean, BoundingBoxUV) | Construct BRepBuilderSurfaceGeometry based on NURBS surface data, where the weights are supplied. In this case, the NURBS surface will be a piecewise rational polynomial surface.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

BRepBuilderSurfaceGeometry Class


BRepBuilderSurfaceGeometry.Create Method

BRepBuilderSurfaceGeometryCreate Method

Construct BRepBuilderSurfaceGeometry based on a permitted Revit Surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static BRepBuilderSurfaceGeometry Create(
    Surface surface,
    BoundingBoxUV surfaceEnvelope
)
Public Shared Function Create (
    surface As Surface,
    surfaceEnvelope As BoundingBoxUV
) As BRepBuilderSurfaceGeometry
public:
static BRepBuilderSurfaceGeometry^ Create(
    Surface^ surface,
    BoundingBoxUV^ surfaceEnvelope
)
static member Create :
        surface : Surface *
        surfaceEnvelope : BoundingBoxUV -> BRepBuilderSurfaceGeometry

Parameters

surface Surface
The Revit surface defining the geometry. This BRepBuilderSurfaceGeometry stores a copy of the input surface.
surfaceEnvelope BoundingBoxUV
Envelope of the surface in the uv parametric domain. Defines the domain of interest for the created surface. This is typically used to identify the domain of the face that references the surface in question. Expected to either be null or define a valid domain.

Return Value

BRepBuilderSurfaceGeometry
Exceptions
Exception | Condition
ArgumentException | A surface of this type cannot be used as a part of the geometry generated by BRepBuilder.
ArgumentNullException | A non-optional argument was null
Remarks
Permitted Surface types are those for which IsPermittedSurfaceType(Surface) returns true.
See Also

Reference

BRepBuilderSurfaceGeometry Class


BRepBuilderSurfaceGeometry.CreateNURBSSurface Method

BRepBuilderSurfaceGeometryCreateNURBSSurface Method

Overload List
Name | Description
CreateNURBSSurface(Int32, Int32, IListDouble, IListDouble, IListXYZ, Boolean, BoundingBoxUV) | Construct a BRepBuilderSurfaceGeometry based on NURBS surface data, where the weights are not supplied. In this case, the NURBS surface will be a piecewise polynomial surface.
CreateNURBSSurface(Int32, Int32, IListDouble, IListDouble, IListXYZ, IListDouble, Boolean, BoundingBoxUV) | Construct BRepBuilderSurfaceGeometry based on NURBS surface data, where the weights are supplied. In this case, the NURBS surface will be a piecewise rational polynomial surface.
Top
See Also

Reference

BRepBuilderSurfaceGeometry Class


BRepBuilderSurfaceGeometry.CreateNURBSSurface(Int32, Int32, IList<Double>, IList<Double>, IList<XYZ>, Boolean, BoundingBoxUV) Method

BRepBuilderSurfaceGeometryCreateNURBSSurface(Int32, Int32, IListDouble, IListDouble, IListXYZ, Boolean, BoundingBoxUV) Method

Construct a BRepBuilderSurfaceGeometry based on NURBS surface data, where the weights are not supplied. In this case, the NURBS surface will be a piecewise polynomial surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static BRepBuilderSurfaceGeometry CreateNURBSSurface(
    int degreeU,
    int degreeV,
    IList<double> knotsU,
    IList<double> knotsV,
    IList<XYZ> controlPoints,
    bool bReverseOrientation,
    BoundingBoxUV surfaceEnvelope
)
Public Shared Function CreateNURBSSurface (
    degreeU As Integer,
    degreeV As Integer,
    knotsU As IList(Of Double),
    knotsV As IList(Of Double),
    controlPoints As IList(Of XYZ),
    bReverseOrientation As Boolean,
    surfaceEnvelope As BoundingBoxUV
) As BRepBuilderSurfaceGeometry
public:
static BRepBuilderSurfaceGeometry^ CreateNURBSSurface(
    int degreeU,
    int degreeV,
    IList<double>^ knotsU,
    IList<double>^ knotsV,
    IList<XYZ^>^ controlPoints,
    bool bReverseOrientation,
    BoundingBoxUV^ surfaceEnvelope
)
static member CreateNURBSSurface :
        degreeU : int *
        degreeV : int *
        knotsU : IList<float> *
        knotsV : IList<float> *
        controlPoints : IList<XYZ> *
        bReverseOrientation : bool *
        surfaceEnvelope : BoundingBoxUV -> BRepBuilderSurfaceGeometry

Parameters

degreeU Int32
The degree of the spline in the u-direction; must be positive.
degreeV Int32
The degree of the spline in the v-direction; must be positive.
knotsU IList Double
Knot values in the u-direction. The number of knots in the u-direction must be at least 2 * (degreeU + 1).
knotsV IList Double
Knot values in the v-direction. The number of knots in the v-direction must be at least 2 * (degreeV + 1).
controlPoints IList XYZ
One dimensional array of points representing the two dimensional net of control points of the NURBS surface in u and v directions.

The total number of control points must equal numControlPtsU times numControlPtsV, where numControlPtsU and numControlPtsV are the numbers of control points in u and v directions, and they must satisfy the following conditions:

  • numControlPtsU = number of knots in u - degreeU - 1.
  • numControlPtsV = number of knots in v - degreeV - 1.
The convention for 2d (idxU, idxV) to 1d (idx) conversion of array indexes: idxV first. That is, idxU is outer loop and idxV is inner loop. In other words, idx = idxU * numControlPtsV + idxV.

bReverseOrientation Boolean
If true, the surface's orientation is opposite to the canonical parametric orientation, otherwise it is the same. The canonical parametric orientation is a counter-clockwise sense of rotation in the uv-parameter plane. Extrinsically, the oriented normal vector for the canonical parametric orientation points in the direction of the cross product dS/du x dS/dv, which S(u, v) is the parameterized surface.
surfaceEnvelope BoundingBoxUV
Envelope of the surface in the uv parametric domain. Defines the domain of interest for the created surface. This is typically used to identify the domain of the face that references the surface in question. Expected to either be null or define a valid domain.

Return Value

BRepBuilderSurfaceGeometry
Exceptions
Exception | Condition
ArgumentException | The U-degree value must be at least 1. -or- The V-degree value must be at least 1. -or- The number of knots in the U direction must be at least 2 * (U-degree + 1). -or- The number of knots in the V direction must be at least 2 * (V-degree + 1). -or- The number of control points must equal (number of U-knots - U-degree - 1) * (number of V-knots - V-degree - 1). -or- The input data does not define a valid Nurbs surface.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The Nurbs surface could not be converted for use in Revit. It may have C2-discontinuities or be too large.
Remarks
This function does not handle periodic Nurbs surfaces.
See Also

Reference

BRepBuilderSurfaceGeometry Class
CreateNURBSSurface Overload


BRepBuilderSurfaceGeometry.CreateNURBSSurface(Int32, Int32, IList<Double>, IList<Double>, IList<XYZ>, IList<Double>, Boolean, BoundingBoxUV) Method

BRepBuilderSurfaceGeometryCreateNURBSSurface(Int32, Int32, IListDouble, IListDouble, IListXYZ, IListDouble, Boolean, BoundingBoxUV) Method

Construct BRepBuilderSurfaceGeometry based on NURBS surface data, where the weights are supplied. In this case, the NURBS surface will be a piecewise rational polynomial surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static BRepBuilderSurfaceGeometry CreateNURBSSurface(
    int degreeU,
    int degreeV,
    IList<double> knotsU,
    IList<double> knotsV,
    IList<XYZ> controlPoints,
    IList<double> weights,
    bool bReverseOrientation,
    BoundingBoxUV surfaceEnvelope
)
Public Shared Function CreateNURBSSurface (
    degreeU As Integer,
    degreeV As Integer,
    knotsU As IList(Of Double),
    knotsV As IList(Of Double),
    controlPoints As IList(Of XYZ),
    weights As IList(Of Double),
    bReverseOrientation As Boolean,
    surfaceEnvelope As BoundingBoxUV
) As BRepBuilderSurfaceGeometry
public:
static BRepBuilderSurfaceGeometry^ CreateNURBSSurface(
    int degreeU,
    int degreeV,
    IList<double>^ knotsU,
    IList<double>^ knotsV,
    IList<XYZ^>^ controlPoints,
    IList<double>^ weights,
    bool bReverseOrientation,
    BoundingBoxUV^ surfaceEnvelope
)
static member CreateNURBSSurface :
        degreeU : int *
        degreeV : int *
        knotsU : IList<float> *
        knotsV : IList<float> *
        controlPoints : IList<XYZ> *
        weights : IList<float> *
        bReverseOrientation : bool *
        surfaceEnvelope : BoundingBoxUV -> BRepBuilderSurfaceGeometry

Parameters

degreeU Int32
The degree of the spline in the u-direction; must be positive.
degreeV Int32
The degree of the spline in the v-direction; must be positive.
knotsU IList Double
Knot values in the u-direction. The number of knots in the u-direction must be at least 2 * (degreeU + 1).
knotsV IList Double
Knot values in the v-direction. The number of knots in the v-direction must be at least 2 * (degreeV + 1).
controlPoints IList XYZ
One dimensional array of points representing the two dimensional net of control points of the NURBS surface in u and v directions.

The total number of control points must equal numControlPtsU times numControlPtsV, where numControlPtsU and numControlPtsV are the numbers of control points in u and v directions, and they must satisfy the following conditions:

  • numControlPtsU = number of knots in u - degreeU - 1.
  • numControlPtsV = number of knots in v - degreeV - 1.
The convention for 2d (idxU, idxV) to 1d (idx) conversion of array indexes: idxV first. That is, idxU is outer loop and idxV is inner loop. In other words, idx = idxU * numControlPtsV + idxV.

weights IList Double
Array of weights assigned to the control points. The number of weights must equal the number of control points. All weights should be greater than zero.
bReverseOrientation Boolean
If true, the surface's orientation is opposite to the canonical parametric orientation, otherwise it is the same. The canonical parametric orientation is a counter-clockwise sense of rotation in the uv-parameter plane. Extrinsically, the oriented normal vector for the canonical parametric orientation points in the direction of the cross product dS/du x dS/dv, which S(u, v) is the parameterized surface.
surfaceEnvelope BoundingBoxUV
Envelope of the surface in the uv parametric domain. Defines the domain of interest for the created surface. This is typically used to identify the domain of the face that references the surface in question. Expected to either be null or define a valid domain.

Return Value

BRepBuilderSurfaceGeometry
Exceptions
Exception | Condition
ArgumentException | The U-degree value must be at least 1. -or- The V-degree value must be at least 1. -or- The number of knots in the U direction must be at least 2 times the U-degree plus 1. -or- The number of knots in the V direction must be at least 2 times the V-degree plus 1. -or- The number of control points must equal (number of U-knots - U-degree - 1) * (number of V-knots - V-degree - 1). -or- The number of weights must be the same as the number of control points and all weights must be positive or all zero. -or- The input data does not define a valid Nurbs surface.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The Nurbs surface could not be converted for use in Revit. It may have C2-discontinuities or be too large.
Remarks
  • A rational polynomial is a quotient of two polynomials; this includes a polynomial, which can be thought of as a quotient with denominator equal to 1. If all the weights are equal, then the NURBS surface will be a piecewise polynomial surface.
  • This class does not handle periodic Nurbs surfaces.
See Also

Reference

BRepBuilderSurfaceGeometry Class
CreateNURBSSurface Overload


BRepBuilderSurfaceGeometry.Dispose Method

BRepBuilderSurfaceGeometryDispose Method

Releases all resources used by the BRepBuilderSurfaceGeometry

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

BRepBuilderSurfaceGeometry Class


BRepType Enumeration

This class defines an enumerative type used to specify the type of output geometry expected from a BRepBuilder.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum BRepType
Public Enumeration BRepType
public enum class BRepType
type BRepType
Members
Member name | Value | Description
OpenShell | 0 | The output geometry is expected to represent an open shell.
Solid | 1 | The output geometry is expected to represent a (possibly disconnected) solid.
Void | 2 | The output geometry is expected to represent a (possibly disconnected) void (i.e., an inverted solid).
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


BrowserOrganization Class

The organization settings for grouping, sorting, and filtering of items in the project browser.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBBrowserOrganization

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BrowserOrganization : ElementType
Public Class BrowserOrganization
    Inherits ElementType
public ref class BrowserOrganization : public ElementType
type BrowserOrganization =
    class
        inherit ElementType
    end

The BrowserOrganization type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SortingOrder | The sorting order if sorting of items is applicable in the browser.
Public property | SortingParameterId | The Id of the parameter used to determine the sorting order of items in the browser.
Public property | Type | Get BrowserOrganizationType.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | AreFiltersSatisfied | Determines if the given element satisfies the filters defined by the browser organization.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
 | GetCurrentBrowserOrganizationForSchedules | Gets the BrowserOrganization that applies to the Schedules section of the project browser.
 | GetCurrentBrowserOrganizationForSheets | Gets the BrowserOrganization that applies to the Sheets section of the project browser.
 | GetCurrentBrowserOrganizationForViews | Gets the BrowserOrganization that applies to the Views section of the project browser.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFolderItems | Returns a collection of leaf FolderItemInfo objects each containing the given element Id.
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


BrowserOrganization Properties

The BrowserOrganization type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SortingOrder | The sorting order if sorting of items is applicable in the browser.
Public property | SortingParameterId | The Id of the parameter used to determine the sorting order of items in the browser.
Public property | Type | Get BrowserOrganizationType.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

BrowserOrganization Class


BrowserOrganization.SortingOrder Property

BrowserOrganizationSortingOrder Property

The sorting order if sorting of items is applicable in the browser.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SortingOrder SortingOrder { get; }
Public ReadOnly Property SortingOrder As SortingOrder
    Get
public:
property SortingOrder SortingOrder {
    SortingOrder get ();
}
member SortingOrder : SortingOrder with get

Property Value

SortingOrder
See Also

Reference

BrowserOrganization Class


BrowserOrganization.SortingParameterId Property

BrowserOrganizationSortingParameterId Property

The Id of the parameter used to determine the sorting order of items in the browser.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId SortingParameterId { get; }
Public ReadOnly Property SortingParameterId As ElementId
    Get
public:
property ElementId^ SortingParameterId {
    ElementId^ get ();
}
member SortingParameterId : ElementId with get

Property Value

ElementId
See Also

Reference

BrowserOrganization Class


BrowserOrganization.Type Property

BrowserOrganizationType Property

Get BrowserOrganizationType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BrowserOrganizationType Type { get; }
Public ReadOnly Property Type As BrowserOrganizationType
    Get
public:
property BrowserOrganizationType Type {
    BrowserOrganizationType get ();
}
member Type : BrowserOrganizationType with get

Property Value

BrowserOrganizationType
See Also

Reference

BrowserOrganization Class


BrowserOrganization Methods

The BrowserOrganization type exposes the following members.

Methods
 | Name | Description
Public method | AreFiltersSatisfied | Determines if the given element satisfies the filters defined by the browser organization.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
 | GetCurrentBrowserOrganizationForSchedules | Gets the BrowserOrganization that applies to the Schedules section of the project browser.
 | GetCurrentBrowserOrganizationForSheets | Gets the BrowserOrganization that applies to the Sheets section of the project browser.
 | GetCurrentBrowserOrganizationForViews | Gets the BrowserOrganization that applies to the Views section of the project browser.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFolderItems | Returns a collection of leaf FolderItemInfo objects each containing the given element Id.
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

BrowserOrganization Class


BrowserOrganization.AreFiltersSatisfied Method

BrowserOrganizationAreFiltersSatisfied Method

Determines if the given element satisfies the filters defined by the browser organization.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AreFiltersSatisfied(
    ElementId elementId
)
Public Function AreFiltersSatisfied (
    elementId As ElementId
) As Boolean
public:
bool AreFiltersSatisfied(
    ElementId^ elementId
)
member AreFiltersSatisfied :
        elementId : ElementId -> bool

Parameters

elementId ElementId
The element to check.

Return Value

Boolean
True if the given element satisfies the filter.
Exceptions
Exception | Condition
ArgumentException | elementId is not a valid Element identifier.
ArgumentNullException | A non-optional argument was null
See Also

Reference

BrowserOrganization Class


BrowserOrganization.GetCurrentBrowserOrganizationForSchedules Method

BrowserOrganizationGetCurrentBrowserOrganizationForSchedules Method

Gets the BrowserOrganization that applies to the Schedules section of the project browser.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static BrowserOrganization GetCurrentBrowserOrganizationForSchedules(
    Document document
)
Public Shared Function GetCurrentBrowserOrganizationForSchedules (
    document As Document
) As BrowserOrganization
public:
static BrowserOrganization^ GetCurrentBrowserOrganizationForSchedules(
    Document^ document
)
static member GetCurrentBrowserOrganizationForSchedules :
        document : Document -> BrowserOrganization

Parameters

document Document
Revit document from which to get the organization data.

Return Value

BrowserOrganization
The BrowserOrganization for schedules, or null if no schedules sections exist
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

BrowserOrganization Class


BrowserOrganization.GetCurrentBrowserOrganizationForSheets Method

BrowserOrganizationGetCurrentBrowserOrganizationForSheets Method

Gets the BrowserOrganization that applies to the Sheets section of the project browser.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static BrowserOrganization GetCurrentBrowserOrganizationForSheets(
    Document document
)
Public Shared Function GetCurrentBrowserOrganizationForSheets (
    document As Document
) As BrowserOrganization
public:
static BrowserOrganization^ GetCurrentBrowserOrganizationForSheets(
    Document^ document
)
static member GetCurrentBrowserOrganizationForSheets :
        document : Document -> BrowserOrganization

Parameters

document Document
Revit document from which to get the organization data.

Return Value

BrowserOrganization
The BrowserOrganization for sheets, or null if no sheets exist.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

BrowserOrganization Class


BrowserOrganization.GetCurrentBrowserOrganizationForViews Method

BrowserOrganizationGetCurrentBrowserOrganizationForViews Method

Gets the BrowserOrganization that applies to the Views section of the project browser.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static BrowserOrganization GetCurrentBrowserOrganizationForViews(
    Document document
)
Public Shared Function GetCurrentBrowserOrganizationForViews (
    document As Document
) As BrowserOrganization
public:
static BrowserOrganization^ GetCurrentBrowserOrganizationForViews(
    Document^ document
)
static member GetCurrentBrowserOrganizationForViews :
        document : Document -> BrowserOrganization

Parameters

document Document
Revit document from which to get the organization data.

Return Value

BrowserOrganization
The BrowserOrganization for views, or null if no view sections exist
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

BrowserOrganization Class


BrowserOrganization.GetFolderItems Method

BrowserOrganizationGetFolderItems Method

Returns a collection of leaf FolderItemInfo objects each containing the given element Id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<FolderItemInfo> GetFolderItems(
    ElementId elementId
)
Public Function GetFolderItems (
    elementId As ElementId
) As IList(Of FolderItemInfo)
public:
IList<FolderItemInfo^>^ GetFolderItems(
    ElementId^ elementId
)
member GetFolderItems :
        elementId : ElementId -> IList<FolderItemInfo>

Parameters

elementId ElementId
Element id located at a leaf position in the project browser.

Return Value

IList FolderItemInfo
An array of FolderItemInfo objects.
Exceptions
Exception | Condition
ArgumentException | elementId is not a valid Element identifier.
ArgumentNullException | A non-optional argument was null
Remarks
Each returned FolderItemInfo includes the folder name and the corresponding folder parameter Id.
See Also

Reference

BrowserOrganization Class


BrowserOrganizationType Enumeration

Enumerated type representing the type of browser organization.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum BrowserOrganizationType
Public Enumeration BrowserOrganizationType
public enum class BrowserOrganizationType
type BrowserOrganizationType
Members
Member name | Value | Description
Views | 0 | The browser organization definition for views.
Sheets | 1 | The browser organization definition for sheets.
Schedules | 3 | The browser organization definition for schedules.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


BuildingPadType Class

Represents a specific type of Building Pad.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBHostObjAttributes
Autodesk.Revit.DBBuildingPadType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BuildingPadType : HostObjAttributes
Public Class BuildingPadType
    Inherits HostObjAttributes
public ref class BuildingPadType : public HostObjAttributes
type BuildingPadType =
    class
        inherit HostObjAttributes
    end

The BuildingPadType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ThermalProperties | The calculated and settable thermal properties of the BuildingPadType
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | CreateDefault | Creates a BuildingPadType element and adds it to the document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


BuildingPadType Properties

The BuildingPadType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ThermalProperties | The calculated and settable thermal properties of the BuildingPadType
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

BuildingPadType Class


BuildingPadType.ThermalProperties Property

BuildingPadTypeThermalProperties Property

The calculated and settable thermal properties of the BuildingPadType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ThermalProperties ThermalProperties { get; }
Public ReadOnly Property ThermalProperties As ThermalProperties
    Get
public:
property ThermalProperties^ ThermalProperties {
    ThermalProperties^ get ();
}
member ThermalProperties : ThermalProperties with get

Property Value

ThermalProperties
Exceptions
Exception | Condition
InvalidOperationException | the building pad does not have thermal properties.
See Also

Reference

BuildingPadType Class


BuildingPadType Methods

The BuildingPadType type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | CreateDefault | Creates a BuildingPadType element and adds it to the document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

BuildingPadType Class


BuildingPadType.CreateDefault Method

BuildingPadTypeCreateDefault Method

Creates a BuildingPadType element and adds it to the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static BuildingPadType CreateDefault(
    Document document
)
Public Shared Function CreateDefault (
    document As Document
) As BuildingPadType
public:
static BuildingPadType^ CreateDefault(
    Document^ document
)
static member CreateDefault :
        document : Document -> BuildingPadType

Parameters

document Document
The document to be modified.

Return Value

BuildingPadType
The new BuildingPadType element.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
The default BuildiPadType adopts the value of 1.0 for the paremeter of thickness. If there is no BuildingPadType existing, will create a new one; otherwise, an exception will be thrown.
See Also

Reference

BuildingPadType Class


BuildingType Enumeration

This enumeration is used for specifying the most predominant building use type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum BuildingType
Public Enumeration BuildingType
public enum class BuildingType
type BuildingType
Members
Member name | Value | Description
kAutomotiveFacility | 0 | Building Type is AutomotiveFacility.
kConventionCenter | 1 | Building Type is ConventionCenter.
kCourthouse | 2 | Building Type is Courthouse.
kDiningBarLoungeOrLeisure | 3 | Building Type is DiningBarLoungeOrLeisure.
kDiningCafeteriaFastFood | 4 | Building Type is DiningCafeteriaFastFood.
kDiningFamily | 5 | Building Type is DiningFamily.
kDormitory | 6 | Building Type is Dormitory.
kExerciseCenter | 7 | Building Type is ExerciseCenter.
kFireStation | 8 | Building Type is FireStation.
kGymnasium | 9 | Building Type is Gymnasium.
kNoOfBuildingTypes | -1 | Building Type is NoOfBuildingTypes.
kHospitalOrHealthcare | 10 | Building Type is HospitalOrHealthcare.
kHotel | 11 | Building Type is Hotel.
kLibrary | 12 | Building Type is Library.
kManufacturing | 13 | Building Type is Manufacturing.
kMotel | 14 | Building Type is Motel.
kMotionPictureTheatre | 15 | Building Type is MotionPictureTheatre.
kMultiFamily | 16 | Building Type is MultiFamily.
kMuseum | 17 | Building Type is Museum.
kOffice | 18 | Building Type is Office.
kParkingGarage | 19 | Building Type is ParkingGarage.
kPenitentiary | 20 | Building Type is Penitentiary.
kPerformingArtsTheater | 21 | Building Type is PerformingArtsTheater.
kPoliceStation | 22 | Building Type is PoliceStation.
kPostOffice | 23 | Building Type is PostOffice.
kReligiousBuilding | 24 | Building Type is ReligiousBuilding.
kRetail | 25 | Building Type is Retail.
kSchoolOrUniversity | 26 | Building Type is SchoolOrUniversity.
kSportsArena | 27 | Building Type is SportsArena.
kTownHall | 28 | Building Type is TownHall.
kTransportation | 29 | Building Type is Transportation.
kWarehouse | 30 | Building Type is Warehouse.
kWorkshop | 31 | Building Type is Workshop.
Remarks
This enumerated list corresponds to the buildingType attribute in the gbXML (Green Building XML) schema and is primarily used for energy analysis.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


BuiltInCategory Enumeration

A list of all the built in categories within Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum BuiltInCategory
Public Enumeration BuiltInCategory
public enum class BuiltInCategory
type BuiltInCategory
Members
Member name | Value | Description
INVALID | -1 |
OST_MatchAll | -2,000,002 |
OST_MatchModel | -2,000,003 |
OST_MatchAnnotation | -2,000,004 |
OST_MatchDetail | -2,000,005 |
OST_MatchProfile | -2,000,006 |
OST_MatchSiteComponent | -2,000,007 |
OST_ScheduleViewParamGroup | -2,000,008 |
OST_IOSRegenerationFailure | -2,000,010 |
OST_Walls | -2,000,011 |
OST_WallsCutOutlines | -2,000,012 |
OST_WallsProjectionOutlines | -2,000,013 |
OST_Windows | -2,000,014 |
OST_WindowsGlassCut | -2,000,015 |
OST_WindowsGlassProjection | -2,000,016 |
OST_WindowsFrameMullionCut | -2,000,017 |
OST_WindowsFrameMullionProjection | -2,000,018 |
OST_WindowsSillHeadCut | -2,000,019 |
OST_WindowsSillHeadProjection | -2,000,020 |
OST_WindowsOpeningCut | -2,000,021 |
OST_WindowsOpeningProjection | -2,000,022 |
OST_Doors | -2,000,023 |
OST_DoorsPanelCut | -2,000,024 |
OST_DoorsPanelProjection | -2,000,025 |
OST_DoorsOpeningCut | -2,000,026 |
OST_DoorsOpeningProjection | -2,000,027 |
OST_DoorsFrameMullionCut | -2,000,028 |
OST_DoorsFrameMullionProjection | -2,000,029 |
OST_DoorsGlassCut | -2,000,030 |
OST_DoorsGlassProjection | -2,000,031 |
OST_Floors | -2,000,032 |
OST_FloorsCut | -2,000,033 |
OST_FloorsProjection | -2,000,034 |
OST_Roofs | -2,000,035 |
OST_RoofsCut | -2,000,036 |
OST_RoofsProjection | -2,000,037 |
OST_Ceilings | -2,000,038 |
OST_CeilingsCut | -2,000,039 |
OST_CeilingsProjection | -2,000,040 |
OST_Curves | -2,000,041 |
OST_CurvesThinLines | -2,000,042 |
OST_CurvesMediumLines | -2,000,043 |
OST_CurvesWideLines | -2,000,044 |
OST_SketchLines | -2,000,045 |
OST_IOSRegeneratedElements | -2,000,046 |
OST_IOSBackedUpElements | -2,000,047 |
OST_IOSAligningLine | -2,000,048 |
OST_IOSAlignmentGraphics | -2,000,049 |
OST_IOSConstructionLine | -2,000,050 |
OST_Lines | -2,000,051 |
OST_IOSDatumPlane | -2,000,052 |
OST_IOSFreeSnapLine | -2,000,053 |
OST_IOSSuspendedSketch_obsolete | -2,000,054 |
OST_IOSSketchGrid | -2,000,055 |
OST_IOSFlipControl | -2,000,056 |
OST_IOSThinPixel | -2,000,057 |
OST_CutOutlines | -2,000,058 |
OST_IOS | -2,000,059 |
OST_Extrusions | -2,000,060 |
OST_IOSThinPixel_Dot | -2,000,061 |
OST_IOSThinPixel_Dash | -2,000,062 |
OST_IOSThinPixel_DashDot | -2,000,063 |
OST_InvisibleLines | -2,000,064 |
OST_AxisOfRotation | -2,000,065 |
OST_RoomSeparationLines | -2,000,066 |
OST_StairsSketchBoundaryLines | -2,000,067 |
OST_StairsSketchRiserLines | -2,000,068 |
OST_StairsSketchRunLines | -2,000,069 |
OST_StairsSketchLandingCenterLines | -2,000,070 |
OST_IOSGhost | -2,000,071 |
OST_IOSGroups | -2,000,072 |
OST_IOSCrashGraphics | -2,000,073 |
OST_IOSCuttingGeometry | -2,000,074 |
OST_IOSRoomPerimeterLines | -2,000,075 |
OST_CloudLines | -2,000,076 |
OST_InsulationLines | -2,000,077 |
OST_GenericLines | -2,000,078 |
OST_AreaSchemeLines | -2,000,079 |
OST_Furniture | -2,000,080 |
OST_FillPatterns | -2,000,081 |
OST_IOSNotSilhouette | -2,000,082 |
OST_ReferenceLines | -2,000,083 |
OST_IOSSlabShapeEditorExplitCrease | -2,000,084 |
OST_IOSSlabShapeEditorAutoCrease | -2,000,085 |
OST_IOSSlabShapeEditorBoundary | -2,000,086 |
OST_IOSSlabShapeEditorPointBoundary | -2,000,087 |
OST_IOSSlabShapeEditorPointInterior | -2,000,088 |
OST_IOSBBoxScreenSize | -2,000,089 |
OST_Curtain_Systems | -2,000,090 |
OST_IOSArrays | -2,000,091 |
OST_IOSMeasureLine | -2,000,092 |
OST_IOSWallCoreBoundary | -2,000,093 |
OST_IOSSuspendedSketch | -2,000,094 |
OST_IOSModelGroups | -2,000,095 |
OST_IOSDetailGroups | -2,000,096 |
OST_IOSAttachedDetailGroups | -2,000,097 |
OST_IOSRoomTagToRoomLines | -2,000,098 |
OST_IOSRebarSystemSpanSymbolCtrl | -2,000,099 |
OST_Columns | -2,000,100 |
OST_IOSMeasureLineScreenSize | -2,000,101 |
OST_EPS_Existing | -2,000,102 |
OST_EPS_Demolished | -2,000,103 |
OST_EPS_New | -2,000,104 |
OST_EPS_Temporary | -2,000,105 |
OST_EPS_Future | -2,000,106 |
OST_GuideGrid | -2,000,107 |
OST_IOSFabricReinSpanSymbolCtrl | -2,000,109 |
OST_IOS_GeoLocations | -2,000,110 |
OST_IOS_GeoSite | -2,000,111 |
OST_Phases | -2,000,112 |
OST_IOSDragBox | -2,000,113 |
OST_IOSDragBoxInverted | -2,000,114 |
OST_IOSRoomUpperLowerLines | -2,000,115 |
OST_IOSRoomComputationHeight | -2,000,116 |
OST_IOSNavWheelPivotBall | -2,000,117 |
OST_Stairs | -2,000,120 |
OST_StairsIncomplete_Deprecated | -2,000,121 |
OST_StairsAboveCut_ToBeDeprecated | -2,000,122 |
OST_StairsStringerCarriage | -2,000,123 |
OST_StairsSupportsAboveCut | -2,000,124 |
OST_StairsUpText | -2,000,125 |
OST_StairsRailing | -2,000,126 |
OST_StairsRailingBaluster | -2,000,127 |
OST_StairsRailingRail | -2,000,128 |
OST_StairsDownText | -2,000,129 |
OST_StairsUpArrows | -2,000,130 |
OST_StairsDownArrows | -2,000,131 |
OST_StairsRailingAboveCut | -2,000,132 |
OST_StairsRailingTags | -2,000,133 |
OST_Fixtures | -2,000,140 |
OST_GenericAnnotation | -2,000,150 |
OST_GenericModel | -2,000,151 |
OST_Rooms | -2,000,160 |
OST_RoomInteriorFillVisibility | -2,000,161 |
OST_RoomReferenceVisibility | -2,000,162 |
OST_AreaInteriorFillVisibility | -2,000,163 |
OST_AreaReferenceVisibility | -2,000,164 |
OST_AreaColorFill | -2,000,165 |
OST_RoomInteriorFill | -2,000,166 |
OST_RoomReference | -2,000,167 |
OST_AreaInteriorFill | -2,000,168 |
OST_AreaReference | -2,000,169 |
OST_CurtainWallPanels | -2,000,170 |
OST_CurtainWallMullions | -2,000,171 |
OST_CurtainWallMullionsCut | -2,000,172 |
OST_CurtainGrids | -2,000,173 |
OST_Railings | -2,000,175 |
OST_RailingBalusterRail | -2,000,176 |
OST_RailingBalusterRailCut | -2,000,177 |
OST_Ramps | -2,000,180 |
OST_Cornices | -2,000,181 |
OST_Reveals | -2,000,182 |
OST_Massing | -2,000,185 |
OST_MassingCutOutlines | -2,000,186 |
OST_MassingProjectionOutlines | -2,000,187 |
OST_FilledRegion | -2,000,190 |
OST_PlanRegion | -2,000,191 |
OST_FaceSplitter | -2,000,192 |
OST_Matchline | -2,000,193 |
OST_MaskingRegion | -2,000,194 |
OST_ModelText | -2,000,195 |
OST_ImportObjectStyles | -2,000,196 |
OST_ReferenceViewerSymbol | -2,000,197 |
OST_ReferenceViewer | -2,000,198 |
OST_Sections | -2,000,200 |
OST_SectionLine | -2,000,201 |
OST_BrokenSectionLine | -2,000,202 |
OST_Grids | -2,000,220 |
OST_GridChains | -2,000,221 |
OST_DisplacementElements | -2,000,222 |
OST_DisplacementPath | -2,000,223 |
OST_Levels | -2,000,240 |
OST_Dimensions | -2,000,260 |
OST_WeakDims | -2,000,261 |
OST_Constraints | -2,000,262 |
OST_SpotElevations | -2,000,263 |
OST_SpotCoordinates | -2,000,264 |
OST_SpotSlopes | -2,000,265 |
OST_RoofTags | -2,000,266 |
OST_Assemblies | -2,000,267 |
OST_AssemblyTags | -2,000,268 |
OST_Parts | -2,000,269 |
OST_PartTags | -2,000,270 |
OST_PartHiddenLines | -2,000,271 |
OST_Viewers | -2,000,278 |
OST_Views | -2,000,279 |
OST_TitleBlocks | -2,000,280 |
OST_TitleBlockThinLines | -2,000,281 |
OST_TitleBlockMediumLines | -2,000,282 |
OST_TitleBlockWideLines | -2,000,283 |
OST_OverheadLines | -2,000,284 |
OST_DemolishedLines | -2,000,285 |
OST_HiddenLines | -2,000,286 |
OST_LinesBeyond | -2,000,287 |
OST_CenterLines | -2,000,288 |
OST_DirectionEdgeLines | -2,000,289 |
OST_Catalogs | -2,000,290 |
OST_Divisions | -2,000,291 |
OST_TextNotes | -2,000,300 |
OST_SectionBox | -2,000,301 |
OST_RenderRegions | -2,000,302 |
OST_AnalysisResults | -2,000,303 |
OST_AnalysisDisplayStyle | -2,000,304 |
OST_HostFin | -2,000,310 |
OST_HostFinFloor | -2,000,311 |
OST_HostFinRoof | -2,000,312 |
OST_HostFinCeiling | -2,000,313 |
OST_HostFinWall | -2,000,314 |
OST_HostFinHF | -2,000,315 |
OST_CurtainGridsRoof | -2,000,320 |
OST_CurtainGridsWall | -2,000,321 |
OST_CurtainGridsSystem | -2,000,322 |
OST_CurtainGridsCurtaSystem | -2,000,323 |
OST_AreaReport_Triangle | -2,000,325 |
OST_AreaReport_Boundary | -2,000,326 |
OST_AreaReport_Arc_Plus | -2,000,327 |
OST_AreaReport_Arc_Minus | -2,000,328 |
OST_CurtaSystem | -2,000,340 |
OST_CurtaSystemFaceManager | -2,000,341 |
OST_ContourLabels | -2,000,350 |
OST_SectionHeads | -2,000,400 |
OST_SectionHeadThinLines | -2,000,401 |
OST_SectionHeadMediumLines | -2,000,403 |
OST_SectionHeadWideLines | -2,000,404 |
OST_WindowTags | -2,000,450 |
OST_DoorTags | -2,000,460 |
OST_RoomTags | -2,000,480 |
OST_MEPSpaceTags | -2,000,485 |
OST_Cameras | -2,000,500 |
OST_Camera_Lines | -2,000,501 |
OST_Viewports | -2,000,510 |
OST_ViewportLabel | -2,000,515 |
OST_Lights | -2,000,520 |
OST_CLines | -2,000,530 |
OST_AxisX | -2,000,531 |
OST_AxisY | -2,000,532 |
OST_AxisZ | -2,000,533 |
OST_Elev | -2,000,535 |
OST_CropBoundary | -2,000,536 |
OST_Callouts | -2,000,537 |
OST_CalloutHeads | -2,000,538 |
OST_CalloutBoundary | -2,000,539 |
OST_WallsSurfacePattern | -2,000,540 |
OST_FloorsSurfacePattern | -2,000,541 |
OST_RoofsSurfacePattern | -2,000,542 |
OST_CeilingsSurfacePattern | -2,000,543 |
OST_CalloutLeaderLine | -2,000,544 |
OST_WallsAnalyticalGeometry | -2,000,545 |
OST_FloorsAnalyticalGeometry | -2,000,546 |
OST_AnnotationCrop | -2,000,547 |
OST_CropBoundarySpecial | -2,000,548 |
OST_AnnotationCropSpecial | -2,000,549 |
OST_ColorFillLegends | -2,000,550 |
OST_RoomColorFill | -2,000,551 |
OST_ColorFillSchema | -2,000,552 |
OST_RasterImages | -2,000,560 |
OST_ScheduleGraphics | -2,000,570 |
OST_Schedules | -2,000,573 |
OST_LegendComponents | -2,000,575 |
OST_PreviewLegendComponents | -2,000,576 |
OST_WallsMembrane | -2,000,580 |
OST_WallsStructure | -2,000,581 |
OST_WallsInsulation | -2,000,582 |
OST_WallsSubstrate | -2,000,583 |
OST_WallsFinish1 | -2,000,584 |
OST_WallsFinish2 | -2,000,585 |
OST_WallsDefault | -2,000,586 |
OST_HiddenWallLines | -2,000,587 |
OST_WallsCutPattern | -2,000,588 |
OST_RoofsMembrane | -2,000,590 |
OST_RoofsStructure | -2,000,591 |
OST_RoofsInsulation | -2,000,592 |
OST_RoofsSubstrate | -2,000,593 |
OST_RoofsFinish1 | -2,000,594 |
OST_RoofsFinish2 | -2,000,595 |
OST_RoofsDefault | -2,000,596 |
OST_RoofsCutPattern | -2,000,597 |
OST_RoofsInteriorEdges | -2,000,598 |
OST_FloorsMembrane | -2,000,600 |
OST_FloorsStructure | -2,000,601 |
OST_FloorsInsulation | -2,000,602 |
OST_FloorsSubstrate | -2,000,603 |
OST_FloorsFinish1 | -2,000,604 |
OST_FloorsFinish2 | -2,000,605 |
OST_FloorsDefault | -2,000,606 |
OST_HiddenFloorLines | -2,000,607 |
OST_FloorsCutPattern | -2,000,608 |
OST_FloorsInteriorEdges | -2,000,609 |
OST_CeilingsMembrane | -2,000,610 |
OST_CeilingsStructure | -2,000,611 |
OST_CeilingsInsulation | -2,000,612 |
OST_CeilingsSubstrate | -2,000,613 |
OST_CeilingsFinish1 | -2,000,614 |
OST_CeilingsFinish2 | -2,000,615 |
OST_CeilingsDefault | -2,000,616 |
OST_CeilingsCutPattern | -2,000,617 |
OST_Materials | -2,000,700 |
OST_ReferencePoints | -2,000,710 |
OST_ReferencePoints_Points | -2,000,711 |
OST_ReferencePoints_Planes | -2,000,712 |
OST_ReferencePoints_Lines | -2,000,713 |
OST_ReferencePoints_HiddenLines | -2,000,714 |
OST_XRayProfileEdge | -2,000,715 |
OST_XRaySideEdge | -2,000,716 |
OST_XRayPathCurve | -2,000,717 |
OST_XRayPathPoint | -2,000,718 |
OST_XRayImplicitPathCurve | -2,000,719 |
OST_XRayConstrainedProfileEdge | -2,000,720 |
OST_ControlAxisX | -2,000,721 |
OST_ControlAxisY | -2,000,772 |
OST_ControlAxisZ | -2,000,773 |
OST_ControlLocal | -2,000,774 |
OST_IOSTilePatternGrid | -2,000,800 |
OST_IOSOpening | -2,000,810 |
OST_RemovedGridSeg | -2,000,827 |
OST_InstanceDrivenLineStyle | -2,000,828 |
OST_RoomPolylines | -2,000,829 |
OST_AreaPolylines | -2,000,830 |
OST_MEPSpaceSeparationLines | -2,000,831 |
OST_DimLockControlLeader | -2,000,832 |
OST_PathOfTravelLines | -2,000,833 |
OST_PathOfTravelTags | -2,000,834 |
OST_StructLocationLineControl | -2,000,880 |
OST_WallRefPlanes | -2,000,896 |
OST_RoofOpening | -2,000,897 |
OST_FloorOpening | -2,000,898 |
OST_CeilingOpening | -2,000,899 |
OST_AdaptivePoints | -2,000,900 |
OST_AdaptivePoints_Points | -2,000,901 |
OST_AdaptivePoints_Planes | -2,000,902 |
OST_AdaptivePoints_Lines | -2,000,903 |
OST_AdaptivePoints_HiddenLines | -2,000,904 |
OST_RailingSystem | -2,000,905 |
OST_RailingSystemSegment | -2,000,906 |
OST_RailingSystemPost | -2,000,907 |
OST_RailingSystemBaluster | -2,000,908 |
OST_RailingSystemPanel | -2,000,909 |
OST_RailingSystemHardware | -2,000,910 |
OST_RailingSystemHandRail | -2,000,911 |
OST_RailingSystemHandRailBracket | -2,000,912 |
OST_RailingSystemTopRail | -2,000,913 |
OST_RailingSystemRail | -2,000,914 |
OST_RailingSystemTermination | -2,000,915 |
OST_RailingSystemTransition | -2,000,916 |
OST_RailingSystemTags | -2,000,917 |
OST_Stair2012_Deprecated | -2,000,918 |
OST_StairsRuns | -2,000,919 |
OST_StairsLandings | -2,000,920 |
OST_StairsTrisers | -2,000,921 |
OST_StairStringer2012_Deprecated | -2,000,922 |
OST_AppearanceAsset | -2,000,923 |
OST_PropertySet | -2,000,924 |
OST_IOSRoomCalculationPoint | -2,000,925 |
OST_DividedPath | -2,000,926 |
OST_ComponentRepeater | -2,000,927 |
OST_ComponentRepeaterSlot | -2,000,928 |
OST_StairsCutMarks | -2,000,930 |
OST_StairsCutMarksAboveCut | -2,000,931 |
OST_StairsNosingLines | -2,000,932 |
OST_StairsNosingLinesAboveCut | -2,000,933 |
OST_StairsOutlines | -2,000,934 |
OST_StairsOutlinesAboveCut | -2,000,935 |
OST_StairsRiserLines | -2,000,936 |
OST_StairsRiserLinesAboveCut | -2,000,937 |
OST_StairsPaths | -2,000,938 |
OST_StairsPathsAboveCut | -2,000,939 |
OST_StairsRunTags | -2,000,940 |
OST_StairsLandingTags | -2,000,941 |
OST_StairsSupportTags | -2,000,942 |
OST_StairsTriserTags | -2,000,943 |
OST_StairsTriserNumbers | -2,000,944 |
OST_StairsSketchPathLines | -2,000,945 |
OST_RailingTopRail | -2,000,946 |
OST_RailingHandRail | -2,000,947 |
OST_RailingSupport | -2,000,948 |
OST_RailingTermination | -2,000,949 |
OST_RailingTopRailAboveCut | -2,000,950 |
OST_RailingHandRailAboveCut | -2,000,951 |
OST_StairsSupports | -2,000,952 |
OST_RailingRailPathLines | -2,000,953 |
OST_RailingRailPathExtensionLines | -2,000,954 |
OST_LinkAnalyticalTags | -2,000,955 |
OST_NodeAnalyticalTags | -2,000,956 |
OST_AnalyticalPanelTags | -2,000,957 |
OST_AnalyticalOpeningTags | -2,000,958 |
OST_DSR_LineAndTextAttrCategoryId | -2,000,960 |
OST_DSR_LineAndTextAttrFontId | -2,000,961 |
OST_DSR_DimStyleTickCategoryId | -2,000,962 |
OST_DSR_DimStyleHeavyEndCatId | -2,000,963 |
OST_DSR_DimStyleHeavyEndCategoryId | -2,000,964 |
OST_DSR_CenterlinePatternCatId | -2,000,965 |
OST_DSR_CenterlineTickMarkStyleId | -2,000,966 |
OST_DSR_ArrowHeadStyleId | -2,000,967 |
OST_DSR_InteriorTickMarkStyleId | -2,000,968 |
OST_DSR_LeaderTickMarkStyleId | -2,000,969 |
OST_MultiReferenceAnnotations | -2,000,970 |
OST_BeamLocalCoordSys | -2,000,971 |
OST_ColumnLocalCoordSys | -2,000,972 |
OST_BraceLocalCoordSys | -2,000,973 |
OST_WallLocalCoordSys | -2,000,974 |
OST_FloorLocalCoordSys | -2,000,975 |
OST_FndSlabLocalCoordSys | -2,000,976 |
OST_CoordinateSystem | -2,000,977 |
OST_StructuralConnectionHandler_Deprecated | -2,000,978 |
OST_HiddenStructuralConnectionLines_Deprecated | -2,000,979 |
OST_MultistoryStairs | -2,000,980 |
OST_Coordination_Model | -2,000,982 |
OST_AnalyticalPipeConnections | -2,000,983 |
OST_AnalyticalPipeConnectionLineSymbol | -2,000,984 |
OST_MechanicalEquipmentSet | -2,000,985 |
OST_MechanicalEquipmentSetTags | -2,000,986 |
OST_MechanicalEquipmentSetBoundaryLines | -2,000,987 |
OST_PipeHydronicSeparationSymbols | -2,000,988 |
OST_RiseDropSymbols | -2,000,989 |
OST_ColumnOpening | -2,000,994 |
OST_StructuralFramingOpening | -2,000,995 |
OST_ShaftOpening | -2,000,996 |
OST_SWallRectOpening | -2,000,997 |
OST_DormerOpeningIncomplete | -2,000,998 |
OST_ArcWallRectOpening | -2,000,999 |
OST_Casework | -2,001,000 |
OST_MEPSystemZone | -2,001,001 |
OST_MEPSystemZoneBoundary | -2,001,002 |
OST_MEPSystemZoneInteriorFill | -2,001,003 |
OST_MEPSystemZoneReferenceLines | -2,001,004 |
OST_MEPSystemZoneInteriorFillVisibility | -2,001,005 |
OST_MEPSystemZoneReferenceLinesVisibility | -2,001,006 |
OST_MEPSystemZoneTags | -2,001,007 |
OST_MEPAnalyticalAirLoop | -2,001,008 |
OST_MEPAnalyticalWaterLoop | -2,001,009 |
OST_ZoneEquipment | -2,001,010 |
OST_ElectricalCircuitNaming | -2,001,011 |
OST_Alignments | -2,001,012 |
OST_MajorStations_Deprecated | -2,001,013 |
OST_MinorStations_Deprecated | -2,001,014 |
OST_AlignmentsTags | -2,001,015 |
OST_AlignmentStationLabelSets | -2,001,016 |
OST_AlignmentStationLabels | -2,001,017 |
OST_ElectricalZoneEquipment_Obsolete | -2,001,018 |
OST_ElectricalLoadZoneType | -2,001,019 |
OST_ElectricalLoadZoneInstance | -2,001,020 |
OST_MEPAnalyticalBus | -2,001,021 |
OST_OBSOLETE_MEPAnalyticalElectricalBranch | -2,001,022 |
OST_MEPAnalyticalTransferSwitch | -2,001,023 |
OST_MEPLoadAreas | -2,001,024 |
OST_MEPLoadAreaTags_OBSOLETE | -2,001,025 |
OST_ElectricalPowerSource | -2,001,026 |
OST_MEPLoadAreaColorFill | -2,001,027 |
OST_MEPLoadAreaInteriorFill | -2,001,028 |
OST_MEPLoadAreaReference | -2,001,029 |
OST_MEPLoadAreaInteriorFillVisibility | -2,001,030 |
OST_MEPLoadAreaReferenceVisibility | -2,001,031 |
OST_MEPLoadAreaSeparationLines | -2,001,033 |
OST_WallNonCoreLayer | -2,001,034 |
OST_WallCoreLayer | -2,001,035 |
OST_Hardscape | -2,001,036 |
OST_HardscapeHiddenLines | -2,001,037 |
OST_HardscapeTags | -2,001,038 |
OST_TemporaryStructure | -2,001,039 |
OST_ElectricalEquipment | -2,001,040 |
OST_TemporaryStructureHiddenLines | -2,001,041 |
OST_TemporaryStructureTags | -2,001,042 |
OST_FoodServiceEquipment | -2,001,043 |
OST_FoodServiceEquipmentHiddenLines | -2,001,044 |
OST_FoodServiceEquipmentTags | -2,001,045 |
OST_MedicalEquipment | -2,001,046 |
OST_MedicalEquipmentHiddenLines | -2,001,047 |
OST_MedicalEquipmentTags | -2,001,048 |
OST_FireProtection | -2,001,049 |
OST_FireProtectionHiddenLines | -2,001,050 |
OST_FireProtectionTags | -2,001,051 |
OST_VerticalCirculation | -2,001,052 |
OST_VerticalCirculationHiddenLines | -2,001,053 |
OST_VerticalCirculationTags | -2,001,054 |
OST_AudioVisualDevices | -2,001,055 |
OST_AudioVisualDevicesHiddenLines | -2,001,056 |
OST_AudioVisualDeviceTags | -2,001,057 |
OST_Signage | -2,001,058 |
OST_SignageHiddenLines | -2,001,059 |
OST_ElectricalFixtures | -2,001,060 |
OST_SignageTags | -2,001,061 |
OST_FasciaTags | -2,001,062 |
OST_ColumnTags | -2,001,063 |
OST_EntourageTags | -2,001,064 |
OST_GutterTags | -2,001,065 |
OST_HandrailTags | -2,001,066 |
OST_PadTags | -2,001,067 |
OST_RampTags | -2,001,068 |
OST_RoofSoffitTags | -2,001,069 |
OST_SlabEdgeTags | -2,001,070 |
OST_TopRailTags | -2,001,071 |
OST_WallSweepTags | -2,001,072 |
OST_ModelGroupTags | -2,001,073 |
OST_RvtLinksTags | -2,001,074 |
OST_AnalyticalMemberCrossSection | -2,001,075 |
OST_FloorsSplitLines | -2,001,076 |
OST_ElectricalAnalyticalTransformer | -2,001,077 |
OST_ELECTRICAL_AreaBasedLoads_Tags | -2,001,078 |
OST_Toposolid | -2,001,079 |
OST_ToposolidHiddenLines | -2,001,080 |
OST_ToposolidContours | -2,001,081 |
OST_ToposolidSecondaryContours | -2,001,082 |
OST_ToposolidFoldingLines | -2,001,083 |
OST_ToposolidSplitLines | -2,001,084 |
OST_ToposolidDefault | -2,001,085 |
OST_ToposolidCutPattern | -2,001,086 |
OST_ToposolidMembrane | -2,001,087 |
OST_ToposolidStructure | -2,001,088 |
OST_ToposolidSubstrate | -2,001,089 |
OST_ToposolidFinish1 | -2,001,090 |
OST_ToposolidFinish2 | -2,001,091 |
OST_ToposolidSurfacePattern | -2,001,092 |
OST_ToposolidInsulation | -2,001,093 |
OST_ToposolidTags | -2,001,094 |
OST_ToposolidOpening | -2,001,095 |
OST_ElectricalAnalyticalFeeder | -2,001,096 |
OST_ToposolidLink | -2,001,097 |
OST_ElectricalLoadSet | -2,001,098 |
OST_ElectricalLoadCase | -2,001,099 |
OST_FurnitureSystems | -2,001,100 |
OST_ElectricalConnector | -2,001,101 |
OST_ElectricalConnectorTags | -2,001,102 |
OST_ToposolidLinkTags | -2,001,103 |
OST_RebarBendingDetails | -2,001,104 |
OST_WallLayers | -2,001,105 |
OST_FloorLayers | -2,001,106 |
OST_DataExchanges | -2,001,107 |
OST_RebarSpliceLines | -2,001,108 |
OST_RebarSpliceType | -2,001,109 |
OST_PipeFlowDirectionSymbols_Obsolete | -2,001,110 |
OST_DuctFlowDirectionSymbols_Obsolete | -2,001,111 |
OST_SheetCollections | -2,001,112 |
OST_PipeAnalyticalSegments | -2,001,113 |
OST_PipeAnalyticalSegmentTags | -2,001,114 |
OST_DuctAnalyticalSegments | -2,001,115 |
OST_DuctAnalyticalSegmentTags | -2,001,116 |
OST_LightingFixtures | -2,001,120 |
OST_LightingFixtureSource | -2,001,121 |
OST_MechanicalEquipment | -2,001,140 |
OST_PlumbingFixtures | -2,001,160 |
OST_Parking | -2,001,180 |
OST_Property | -2,001,200 |
OST_Roads | -2,001,220 |
OST_RoadTags | -2,001,221 |
OST_Sewer | -2,001,240 |
OST_Site | -2,001,260 |
OST_SiteSurface | -2,001,261 |
OST_SitePoint | -2,001,262 |
OST_BuildingPad | -2,001,263 |
OST_SiteProperty | -2,001,265 |
OST_SitePointBoundary | -2,001,266 |
OST_SitePropertyTags | -2,001,267 |
OST_SitePropertyLineSegment | -2,001,268 |
OST_SitePropertyLineSegmentTags | -2,001,269 |
OST_SiteRegion | -2,001,270 |
OST_ProjectBasePoint | -2,001,271 |
OST_SharedBasePoint | -2,001,272 |
OST_BasePointAxisX | -2,001,273 |
OST_BasePointAxisY | -2,001,274 |
OST_BasePointAxisZ | -2,001,275 |
OST_LinkBasePoint | -2,001,276 |
OST_StructuralFoundation | -2,001,300 |
OST_HiddenStructuralFoundationLines | -2,001,302 |
OST_StructuralFraming | -2,001,320 |
OST_StructuralFramingOther | -2,001,321 |
OST_Girder | -2,001,322 |
OST_Joist | -2,001,323 |
OST_Purlin | -2,001,324 |
OST_HorizontalBracing | -2,001,325 |
OST_VerticalBracing | -2,001,326 |
OST_StructuralFramingSystem | -2,001,327 |
OST_KickerBracing | -2,001,328 |
OST_HiddenStructuralFramingLines | -2,001,329 |
OST_StructuralColumns | -2,001,330 |
OST_FramingAnalyticalGeometry | -2,001,331 |
OST_ColumnAnalyticalGeometry | -2,001,332 |
OST_AnalyticalRigidLinks | -2,001,333 |
OST_HiddenStructuralColumnLines | -2,001,334 |
OST_StructuralColumnStickSymbols | -2,001,335 |
OST_StructuralTruss | -2,001,336 |
OST_TopographyLink | -2,001,339 |
OST_Topography | -2,001,340 |
OST_TopographySurface | -2,001,341 |
OST_TopographyContours | -2,001,342 |
OST_SecondaryTopographyContours | -2,001,343 |
OST_ColumnAnalyticalRigidLinks | -2,001,344 |
OST_SpecialityEquipment | -2,001,350 |
OST_Automatic | -2,001,351 |
OST_RvtLinks | -2,001,352 |
OST_FootingAnalyticalGeometry | -2,001,353 |
OST_StructuralStiffener | -2,001,354 |
OST_StructuralStiffenerTags | -2,001,355 |
OST_StructuralFramingLocationLine | -2,001,356 |
OST_StructuralColumnLocationLine | -2,001,357 |
OST_StructuralStiffenerHiddenLines | -2,001,358 |
OST_Blocks | -2,001,359 |
OST_Planting | -2,001,360 |
OST_Entourage | -2,001,370 |
OST_Fascia | -2,001,390 |
OST_Gutter | -2,001,391 |
OST_EdgeSlab | -2,001,392 |
OST_RoofSoffit | -2,001,393 |
OST_DetailComponents | -2,002,000 |
OST_ProfileFamilies | -2,003,000 |
OST_Sheets | -2,003,100 |
OST_ProjectInformation | -2,003,101 |
OST_Areas | -2,003,200 |
OST_AreaSchemes | -2,003,201 |
OST_ZoneSchemes | -2,003,225 |
OST_TrussDummy | -2,003,300 |
OST_RampsIncomplete | -2,003,301 |
OST_RampsAboveCut | -2,003,302 |
OST_RampsStringer | -2,003,303 |
OST_RampsStringerAboveCut | -2,003,304 |
OST_RampsUpText | -2,003,305 |
OST_RampsDownText | -2,003,306 |
OST_RampsUpArrow | -2,003,307 |
OST_RampsDownArrow | -2,003,308 |
OST_RepeatingDetailLines | -2,003,321 |
OST_DividedSurface | -2,003,323 |
OST_DividedSurface_Nodes | -2,003,324 |
OST_DividedSurface_Gridlines | -2,003,325 |
OST_DividedSurface_PatternLines | -2,003,326 |
OST_DividedSurface_PatternFill | -2,003,327 |
OST_DividedSurface_PreDividedSurface | -2,003,328 |
OST_DividedSurface_TransparentFace | -2,003,329 |
OST_AlwaysExcludedInAllViews | -2,003,330 |
OST_TilePatterns | -2,003,331 |
OST_DividedSurfaceBelt | -2,003,332 |
OST_DividedSurface_DiscardedDivisionLines | -2,003,333 |
OST_Mass | -2,003,400 |
OST_MassFloor | -2,003,403 |
OST_MassForm | -2,003,404 |
OST_MassTags | -2,003,405 |
OST_ZoningEnvelope | -2,003,406 |
OST_MassCutter | -2,003,407 |
OST_MassFaceSplitter | -2,003,408 |
OST_HostTemplate | -2,003,409 |
OST_MassAreaFaceTags | -2,003,410 |
OST_MassZone | -2,003,411 |
OST_MassInteriorWall | -2,003,412 |
OST_MassExteriorWall | -2,003,413 |
OST_MassRoof | -2,003,414 |
OST_MassGlazing | -2,003,415 |
OST_MassSkylights | -2,003,416 |
OST_MassOpening | -2,003,417 |
OST_MassShade | -2,003,418 |
OST_MassSlab | -2,003,419 |
OST_MassExteriorWallUnderground | -2,003,420 |
OST_MassWallsAll | -2,003,421 |
OST_MassFloorsAll | -2,003,422 |
OST_MassGlazingAll | -2,003,423 |
OST_StackedWalls | -2,003,500 |
OST_MEPSpaces | -2,003,600 |
OST_MEPSpaceInteriorFillVisibility | -2,003,601 |
OST_MEPSpaceReferenceVisibility | -2,003,602 |
OST_MEPSpaceInteriorFill | -2,003,603 |
OST_MEPSpaceReference | -2,003,604 |
OST_MEPSpaceColorFill | -2,003,605 |
OST_Tags | -2,005,000 |
OST_CaseworkTags | -2,005,001 |
OST_CeilingTags | -2,005,002 |
OST_ElectricalEquipmentTags | -2,005,003 |
OST_ElectricalFixtureTags | -2,005,004 |
OST_FurnitureTags | -2,005,006 |
OST_FurnitureSystemTags | -2,005,007 |
OST_LightingFixtureTags | -2,005,008 |
OST_MechanicalEquipmentTags | -2,005,009 |
OST_PlumbingFixtureTags | -2,005,010 |
OST_WallTags | -2,005,011 |
OST_CurtainWallPanelTags | -2,005,012 |
OST_GenericModelTags | -2,005,013 |
OST_SpecialityEquipmentTags | -2,005,014 |
OST_StructuralFramingTags | -2,005,015 |
OST_SiteTags | -2,005,016 |
OST_ParkingTags | -2,005,017 |
OST_StructuralColumnTags | -2,005,018 |
OST_StructuralFoundationTags | -2,005,019 |
OST_AreaTags | -2,005,020 |
OST_PlantingTags | -2,005,021 |
OST_MultiCategoryTags | -2,005,022 |
OST_StairsTags | -2,005,023 |
OST_HostFinTags | -2,005,024 |
OST_CurtaSystemTags | -2,005,025 |
OST_FloorTags | -2,005,026 |
OST_MaterialTags | -2,005,027 |
OST_DetailComponentTags | -2,005,028 |
OST_KeynoteTags | -2,005,029 |
OST_TrussTags | -2,005,030 |
OST_StructuralConnectionHandlerTags_Deprecated | -2,005,031 |
OST_CurtainWallMullionTags | -2,005,032 |
OST_MultiLeaderTag | -2,005,033 |
OST_SpotElevSymbols | -2,005,100 |
OST_SpotCoordinateSymbols | -2,005,101 |
OST_SpotSlopesSymbols | -2,005,102 |
OST_SpanDirectionSymbol | -2,005,110 |
OST_FootingSpanDirectionSymbol | -2,005,111 |
OST_BeamSystemTags | -2,005,130 |
OST_Loads | -2,005,200 |
OST_PointLoads | -2,005,201 |
OST_LineLoads | -2,005,202 |
OST_AreaLoads | -2,005,203 |
OST_InternalLoads | -2,005,204 |
OST_InternalPointLoads | -2,005,205 |
OST_InternalLineLoads | -2,005,206 |
OST_InternalAreaLoads | -2,005,207 |
OST_LoadCases | -2,005,210 |
OST_LoadCasesDead | -2,005,211 |
OST_LoadCasesLive | -2,005,212 |
OST_LoadCasesWind | -2,005,213 |
OST_LoadCasesSnow | -2,005,214 |
OST_LoadCasesRoofLive | -2,005,215 |
OST_LoadCasesAccidental | -2,005,216 |
OST_LoadCasesTemperature | -2,005,217 |
OST_LoadCasesSeismic | -2,005,218 |
OST_PointLoadTags | -2,005,250 |
OST_LineLoadTags | -2,005,251 |
OST_AreaLoadTags | -2,005,252 |
OST_InternalPointLoadTags | -2,005,253 |
OST_InternalLineLoadTags | -2,005,254 |
OST_InternalAreaLoadTags | -2,005,255 |
OST_BoundaryConditions | -2,005,301 |
OST_VolumeOfInterest | -2,006,000 |
OST_DecalElement | -2,006,001 |
OST_DecalType | -2,006,002 |
OST_LevelHeads | -2,006,020 |
OST_GridHeads | -2,006,040 |
OST_ElevationMarks | -2,006,045 |
OST_EditCutProfile | -2,006,050 |
OST_RevisionClouds | -2,006,060 |
OST_Revisions | -2,006,070 |
OST_RevisionNumberingSequences | -2,006,071 |
OST_RevisionCloudTags | -2,006,080 |
OST_StructuralAnnotations | -2,006,090 |
OST_StructConnectionSymbols | -2,006,100 |
OST_StructuralBracePlanReps | -2,006,110 |
OST_DesignOptionSets | -2,006,112 |
OST_DesignOptions | -2,006,114 |
OST_BridgeAbutments | -2,006,130 |
OST_BridgePiers | -2,006,131 |
OST_BridgeTowers | -2,006,132 |
OST_BridgeCables | -2,006,133 |
OST_BridgeArches | -2,006,134 |
OST_BridgeDecks | -2,006,135 |
OST_BridgeFoundations | -2,006,136 |
OST_BridgeGirders | -2,006,137 |
OST_BridgeBearings | -2,006,138 |
OST_BridgeAbutmentHiddenLines | -2,006,150 |
OST_BridgePierHiddenLines | -2,006,151 |
OST_BridgeTowerHiddenLines2021_Deprecated | -2,006,152 |
OST_BridgeCableHiddenLines2021_Deprecated | -2,006,153 |
OST_BridgeArchHiddenLines2021_Deprecated | -2,006,154 |
OST_BridgeDeckHiddenLines | -2,006,155 |
OST_BridgeFoundationHiddenLines2021_Deprecated | -2,006,156 |
OST_BridgeGirderHiddenLines2021_Deprecated | -2,006,157 |
OST_BridgeBearingHiddenLines | -2,006,158 |
OST_BridgeAbutmentTags | -2,006,170 |
OST_BridgePierTags | -2,006,171 |
OST_BridgeTowerTags | -2,006,172 |
OST_BridgeCableTags | -2,006,173 |
OST_BridgeArchTags | -2,006,174 |
OST_BridgeDeckTags | -2,006,175 |
OST_BridgeFoundationTags | -2,006,176 |
OST_BridgeGirderTags | -2,006,177 |
OST_BridgeBearingTags | -2,006,178 |
OST_AbutmentFoundations | -2,006,202 |
OST_AbutmentPiles | -2,006,203 |
OST_AbutmentWalls | -2,006,204 |
OST_ApproachSlabs | -2,006,205 |
OST_AbutmentFoundationTags | -2,006,208 |
OST_AbutmentPileTags | -2,006,209 |
OST_AbutmentWallTags | -2,006,210 |
OST_ApproachSlabTags | -2,006,211 |
OST_PierCaps | -2,006,219 |
OST_PierCapTags | -2,006,220 |
OST_PierColumns | -2,006,221 |
OST_PierColumnTags | -2,006,222 |
OST_PierPiles | -2,006,225 |
OST_PierPileTags | -2,006,226 |
OST_PierWalls | -2,006,229 |
OST_PierWallTags | -2,006,230 |
OST_BridgeFraming | -2,006,241 |
OST_BridgeFramingHiddenLines | -2,006,242 |
OST_BridgeFramingTags | -2,006,243 |
OST_BridgeFramingCrossBracing | -2,006,245 |
OST_BridgeFramingDiaphragms | -2,006,246 |
OST_BridgeFramingTrusses | -2,006,248 |
OST_VibrationManagement | -2,006,261 |
OST_VibrationManagementHiddenLines | -2,006,262 |
OST_VibrationDampers | -2,006,263 |
OST_VibrationDamperTags | -2,006,264 |
OST_VibrationIsolators | -2,006,265 |
OST_VibrationIsolatorTags | -2,006,266 |
OST_ExpansionJoints | -2,006,271 |
OST_ExpansionJointHiddenLines | -2,006,272 |
OST_ExpansionJointTags | -2,006,273 |
OST_StructuralTendons | -2,006,274 |
OST_StructuralTendonHiddenLines | -2,006,275 |
OST_StructuralTendonTags | -2,006,276 |
OST_BridgeFramingCrossBracingTags | -2,006,278 |
OST_BridgeFramingDiaphragmTags | -2,006,279 |
OST_BridgeFramingTrussTags | -2,006,281 |
OST_VibrationManagementTags | -2,006,282 |
OST_ConnectorElem | -2,007,000 |
OST_ConnectorElemXAxis | -2,007,001 |
OST_ConnectorElemYAxis | -2,007,002 |
OST_ConnectorElemZAxis | -2,007,003 |
OST_DuctColorFillLegends | -2,007,004 |
OST_DuctCurves | -2,008,000 |
OST_DuctCurvesCenterLine | -2,008,001 |
OST_DuctCurvesContour | -2,008,002 |
OST_DuctTags | -2,008,003 |
OST_FlexDuctTags | -2,008,004 |
OST_DuctColorFills | -2,008,005 |
OST_DuctFitting | -2,008,010 |
OST_DuctTerminal | -2,008,013 |
OST_DuctTerminalTags | -2,008,014 |
OST_DuctSystem | -2,008,015 |
OST_DuctAccessory | -2,008,016 |
OST_DuctAccessoryTags | -2,008,017 |
OST_FlexDuctCurves | -2,008,020 |
OST_FlexDuctCurvesCenterLine | -2,008,021 |
OST_FlexDuctCurvesContour | -2,008,022 |
OST_FlexDuctCurvesPattern | -2,008,023 |
OST_DuctCurvesRiseDrop | -2,008,036 |
OST_ElectricalCircuit | -2,008,037 |
OST_ElectricalCircuitTags | -2,008,038 |
OST_Wire | -2,008,039 |
OST_ElectricalVoltage | -2,008,040 |
OST_ElecDistributionSys | -2,008,041 |
OST_ElectricalDemandFactor | -2,008,042 |
OST_PipingSystem | -2,008,043 |
OST_PipeCurves | -2,008,044 |
OST_PipeCurvesCenterLine | -2,008,045 |
OST_PipeCurvesContour | -2,008,046 |
OST_PipeTags | -2,008,047 |
OST_FlexPipeTags | -2,008,048 |
OST_PipeFitting | -2,008,049 |
OST_FlexPipeCurves | -2,008,050 |
OST_FlexPipeCurvesCenterLine | -2,008,051 |
OST_FlexPipeCurvesContour | -2,008,052 |
OST_FlexPipeCurvesPattern | -2,008,053 |
OST_PipeCurvesRiseDrop | -2,008,054 |
OST_PipeAccessory | -2,008,055 |
OST_PipeAccessoryTags | -2,008,056 |
OST_WireTags | -2,008,057 |
OST_PipeColorFillLegends | -2,008,058 |
OST_PipeColorFills | -2,008,059 |
OST_PipeFittingTags | -2,008,060 |
OST_DuctFittingTags | -2,008,061 |
OST_DuctCurvesDrop | -2,008,062 |
OST_DuctCurvesInsulation | -2,008,063 |
OST_DuctCurvesLining | -2,008,064 |
OST_FlexDuctCurvesInsulation | -2,008,065 |
OST_DuctFittingCenterLine | -2,008,066 |
OST_DuctFittingInsulation | -2,008,067 |
OST_DuctFittingLining | -2,008,068 |
OST_PipeCurvesDrop | -2,008,069 |
OST_PipeCurvesInsulation | -2,008,070 |
OST_FlexPipeCurvesInsulation | -2,008,071 |
OST_PipeFittingCenterLine | -2,008,072 |
OST_PipeFittingInsulation | -2,008,073 |
OST_WireTickMarks | -2,008,074 |
OST_TelephoneDevices | -2,008,075 |
OST_TelephoneDeviceTags | -2,008,076 |
OST_NurseCallDevices | -2,008,077 |
OST_NurseCallDeviceTags | -2,008,078 |
OST_SecurityDevices | -2,008,079 |
OST_SecurityDeviceTags | -2,008,080 |
OST_CommunicationDevices | -2,008,081 |
OST_CommunicationDeviceTags | -2,008,082 |
OST_DataDevices | -2,008,083 |
OST_DataDeviceTags | -2,008,084 |
OST_FireAlarmDevices | -2,008,085 |
OST_FireAlarmDeviceTags | -2,008,086 |
OST_LightingDevices | -2,008,087 |
OST_LightingDeviceTags | -2,008,088 |
OST_WireHomeRunArrows | -2,008,089 |
OST_GbXMLFaces | -2,008,090 |
OST_GbXML_SType_Interior | -2,008,091 |
OST_GbXML_SType_Exterior | -2,008,092 |
OST_GbXML_SType_Shade | -2,008,093 |
OST_GbXML_SType_Underground | -2,008,094 |
OST_GbXML_Opening | -2,008,095 |
OST_RouteCurve | -2,008,096 |
OST_RouteCurveMain | -2,008,097 |
OST_RouteCurveBranch | -2,008,098 |
OST_Sprinklers | -2,008,099 |
OST_SprinklerTags | -2,008,100 |
OST_SwitchSystem | -2,008,101 |
OST_EAConstructions | -2,008,102 |
OST_PipeConnections | -2,008,103 |
OST_PipeMaterials | -2,008,104 |
OST_PipeSchedules | -2,008,105 |
OST_Fluids | -2,008,106 |
OST_HVAC_Zones | -2,008,107 |
OST_HVAC_Zones_Boundary | -2,008,108 |
OST_HVAC_Zones_InteriorFill | -2,008,109 |
OST_HVAC_Zones_Reference | -2,008,110 |
OST_WireMaterials | -2,008,111 |
OST_WireInsulations | -2,008,112 |
OST_WireTemperatureRatings | -2,008,113 |
OST_LayoutPath_Bases | -2,008,114 |
OST_ZoneTags | -2,008,115 |
OST_HVAC_Zones_ColorFill | -2,008,116 |
OST_HVAC_Zones_InteriorFill_Visibility | -2,008,117 |
OST_HVAC_Zones_Reference_Visibility | -2,008,118 |
OST_HVAC_Load_Space_Types | -2,008,119 |
OST_HVAC_Load_Building_Types | -2,008,120 |
OST_HVAC_Load_Schedules | -2,008,121 |
OST_PipeInsulations | -2,008,122 |
OST_DuctInsulations | -2,008,123 |
OST_DuctLinings | -2,008,124 |
OST_RoutingPreferences | -2,008,125 |
OST_CableTrayFitting | -2,008,126 |
OST_CableTrayFittingTags | -2,008,127 |
OST_ConduitFitting | -2,008,128 |
OST_ConduitFittingTags | -2,008,129 |
OST_CableTray | -2,008,130 |
OST_CableTrayTags | -2,008,131 |
OST_Conduit | -2,008,132 |
OST_ConduitTags | -2,008,133 |
OST_CableTrayRiseDrop | -2,008,134 |
OST_CableTrayDrop | -2,008,135 |
OST_CableTrayCenterLine | -2,008,136 |
OST_ConduitRiseDrop | -2,008,137 |
OST_ConduitDrop | -2,008,138 |
OST_ConduitCenterLine | -2,008,139 |
OST_CableTrayFittingCenterLine | -2,008,140 |
OST_ConduitFittingCenterLine | -2,008,141 |
OST_ElectricalDemandFactorDefinitions | -2,008,142 |
OST_ElectricalLoadClassifications | -2,008,143 |
OST_ConduitStandards | -2,008,144 |
OST_BranchPanelScheduleTemplates | -2,008,145 |
OST_SwitchboardScheduleTemplates | -2,008,146 |
OST_DataPanelScheduleTemplates | -2,008,147 |
OST_ParamElemElectricalLoadClassification | -2,008,148 |
OST_ConduitRun | -2,008,149 |
OST_CableTrayRun | -2,008,150 |
OST_PanelScheduleGraphics | -2,008,151 |
OST_ElectricalInternalCircuits | -2,008,152 |
OST_DuctInsulationsTags | -2,008,153 |
OST_DuctLiningsTags | -2,008,154 |
OST_PipeInsulationsTags | -2,008,155 |
OST_DuctSystem_Reference | -2,008,156 |
OST_DuctSystem_Reference_Visibility | -2,008,157 |
OST_PipingSystem_Reference | -2,008,158 |
OST_PipingSystem_Reference_Visibility | -2,008,159 |
OST_PlaceHolderDucts | -2,008,160 |
OST_PlaceHolderPipes | -2,008,161 |
OST_GraphicalWarning_OpenConnector | -2,008,162 |
OST_PipeSegments | -2,008,163 |
OST_SplitterProfile | -2,008,164 |
OST_DivisionProfile | -2,008,165 |
OST_gbXML_ExteriorWall | -2,008,167 |
OST_gbXML_Roof | -2,008,168 |
OST_gbXML_RaisedFloor | -2,008,169 |
OST_gbXML_SlabOnGrade | -2,008,170 |
OST_gbXML_InteriorWall | -2,008,171 |
OST_gbXML_InteriorFloor | -2,008,172 |
OST_gbXML_Ceiling | -2,008,173 |
OST_gbXML_SurfaceAir | -2,008,174 |
OST_gbXML_UndergroundWall | -2,008,175 |
OST_gbXML_UndergroundSlab | -2,008,176 |
OST_gbXML_UndergroundCeiling | -2,008,177 |
OST_gbXML_FixedWindow | -2,008,178 |
OST_gbXML_OperableWindow | -2,008,179 |
OST_gbXML_FixedSkylight | -2,008,180 |
OST_gbXML_OperableSkylight | -2,008,181 |
OST_gbXML_SlidingDoor | -2,008,182 |
OST_gbXML_NonSlidingDoor | -2,008,183 |
OST_gbXML_OpeningAir | -2,008,184 |
OST_AnalyticSpaces | -2,008,185 |
OST_AnalyticSurfaces | -2,008,186 |
OST_gbXML_Shade | -2,008,187 |
OST_DivisionRules | -2,008,190 |
OST_NumberingSchemas | -2,008,191 |
OST_LayoutPathBase_Pipings | -2,008,192 |
OST_FabricationDuctwork | -2,008,193 |
OST_FabricationDuctworkTags | -2,008,194 |
OST_FabricationServiceElements | -2,008,195 |
OST_FabricationDuctworkCenterLine | -2,008,196 |
OST_LayoutNodes | -2,008,197 |
OST_FabricationDuctworkInsulation | -2,008,198 |
OST_FabricationPartsTmpGraphicEnd | -2,008,199 |
OST_OBSOLETE_FabricationPartsTmpGraphicDrop | -2,008,200 |
OST_FabricationPartsTmpGraphicDrag | -2,008,201 |
OST_OBSOLETE_FabricationPartsTmpGraphicDropDrag | -2,008,202 |
OST_FabricationHangers | -2,008,203 |
OST_FabricationHangerTags | -2,008,204 |
OST_FabricationDuctworkRise | -2,008,205 |
OST_FabricationDuctworkDrop | -2,008,206 |
OST_FabricationDuctworkSymbology | -2,008,207 |
OST_FabricationPipework | -2,008,208 |
OST_FabricationPipeworkTags | -2,008,209 |
OST_FabricationPipeworkCenterLine | -2,008,210 |
OST_FabricationPipeworkSymbology | -2,008,211 |
OST_FabricationContainment | -2,008,212 |
OST_FabricationContainmentTags | -2,008,213 |
OST_FabricationContainmentCenterLine | -2,008,214 |
OST_FabricationContainmentSymbology | -2,008,215 |
OST_FabricationPipeworkRise | -2,008,216 |
OST_FabricationPipeworkDrop | -2,008,217 |
OST_FabricationContainmentRise | -2,008,218 |
OST_FabricationContainmentDrop | -2,008,219 |
OST_FabricationDuctworkLining | -2,008,220 |
OST_FabricationPipeworkInsulation | -2,008,221 |
OST_ELECTRICAL_AreaBasedLoads_Boundary | -2,008,222 |
OST_ELECTRICAL_AreaBasedLoads_InteriorFill | -2,008,223 |
OST_ELECTRICAL_AreaBasedLoads_Reference | -2,008,224 |
OST_ELECTRICAL_AreaBasedLoads_ColorFill_Obsolete | -2,008,225 |
OST_ELECTRICAL_AreaBasedLoads_InteriorFill_Visibility | -2,008,226 |
OST_ELECTRICAL_AreaBasedLoads_Reference_Visibility | -2,008,227 |
OST_FabricationDuctworkStiffeners | -2,008,228 |
OST_FabricationDuctworkStiffenerTags | -2,008,229 |
OST_MEPAncillaries_Obsolete | -2,008,230 |
OST_MEPAncillaryFraming | -2,008,231 |
OST_MechanicalControlDevices | -2,008,232 |
OST_MechanicalControlDeviceTags | -2,008,233 |
OST_PlumbingEquipment | -2,008,234 |
OST_PlumbingEquipmentTags | -2,008,235 |
OST_MEPAncillaryFramingTags | -2,008,236 |
OST_Rebar | -2,009,000 |
OST_RebarSketchLines | -2,009,001 |
OST_RebarLines | -2,009,002 |
OST_AreaRein | -2,009,003 |
OST_AreaReinSketchOverride | -2,009,004 |
OST_AreaReinSpanSymbol | -2,009,005 |
OST_AreaReinBoundary | -2,009,006 |
OST_AreaReinXVisibility | -2,009,007 |
OST_Cage | -2,009,008 |
OST_PathRein | -2,009,009 |
OST_PathReinSpanSymbol | -2,009,010 |
OST_PathReinTags | -2,009,011 |
OST_PathReinBoundary | -2,009,012 |
OST_RebarShape | -2,009,013 |
OST_CoverType | -2,009,014 |
OST_RebarCover | -2,009,015 |
OST_FabricReinforcement | -2,009,016 |
OST_FabricAreas | -2,009,017 |
OST_FabricAreaSketchEnvelopeLines | -2,009,018 |
OST_FabricAreaSketchSheetsLines | -2,009,019 |
OST_RebarTags | -2,009,020 |
OST_AreaReinTags | -2,009,021 |
OST_FabricReinforcementTags | -2,009,022 |
OST_FabricAreaTags | -2,009,023 |
OST_RebarSetToggle | -2,009,025 |
OST_FabricReinforcementBoundary | -2,009,026 |
OST_FabricReinforcementWire | -2,009,027 |
OST_FabricReinSpanSymbol | -2,009,028 |
OST_FabricAreaBoundary | -2,009,029 |
OST_StructConnections | -2,009,030 |
OST_StructWeldLines | -2,009,031 |
OST_StructConnectionHiddenLines | -2,009,032 |
OST_StructConnectionSymbol | -2,009,033 |
OST_StructConnectionStale | -2,009,034 |
OST_StructConnectionFailed | -2,009,035 |
OST_StructConnectionReference | -2,009,036 |
OST_StructConnectionProfiles | -2,009,037 |
OST_StructConnectionPlates | -2,009,038 |
OST_StructConnectionAnchors | -2,009,039 |
OST_StructConnectionTags | -2,009,040 |
OST_StructConnectionBolts | -2,009,041 |
OST_StructConnectionOthers | -2,009,042 |
OST_StructConnectionNobleWarning | -2,009,043 |
OST_StructConnectionShearStuds | -2,009,044 |
OST_StructConnectionHoles | -2,009,045 |
OST_StructConnectionWelds | -2,009,046 |
OST_StructConnectionModifiers | -2,009,047 |
OST_SteelElementStale | -2,009,048 |
OST_StructSubConnections | -2,009,049 |
OST_RebarHiddenLines | -2,009,050 |
OST_StructConnectionPlateTags | -2,009,055 |
OST_StructConnectionBoltTags | -2,009,056 |
OST_StructConnectionAnchorTags | -2,009,057 |
OST_StructConnectionShearStudTags | -2,009,058 |
OST_StructConnectionWeldTags | -2,009,059 |
OST_Coupler | -2,009,060 |
OST_CouplerTags | -2,009,061 |
OST_CouplerHiddenLines | -2,009,062 |
OST_StructConnectionHoleTags | -2,009,063 |
OST_StructConnectionProfilesTags | -2,009,064 |
OST_WindowsHiddenLines | -2,009,500 |
OST_DoorsHiddenLines | -2,009,501 |
OST_RoofsHiddenLines | -2,009,502 |
OST_CeilingsHiddenLines | -2,009,503 |
OST_LinesHiddenLines | -2,009,504 |
OST_FurnitureHiddenLines | -2,009,505 |
OST_ColumnsHiddenLines | -2,009,506 |
OST_StairsHiddenLines | -2,009,507 |
OST_StairsRailingHiddenLines | -2,009,508 |
OST_RampsHiddenLines | -2,009,509 |
OST_CurtainWallPanelsHiddenLines | -2,009,510 |
OST_CurtainWallMullionsHiddenLines | -2,009,511 |
OST_GenericModelHiddenLines | -2,009,512 |
OST_ShaftOpeningHiddenLines | -2,009,513 |
OST_DetailComponentsHiddenLines | -2,009,514 |
OST_CaseworkHiddenLines | -2,009,515 |
OST_ElectricalEquipmentHiddenLines | -2,009,516 |
OST_ElectricalFixturesHiddenLines | -2,009,517 |
OST_FurnitureSystemsHiddenLines | -2,009,518 |
OST_LightingFixturesHiddenLines | -2,009,519 |
OST_MechanicalEquipmentHiddenLines | -2,009,520 |
OST_PlumbingFixturesHiddenLines | -2,009,521 |
OST_ParkingHiddenLines | -2,009,522 |
OST_RoadsHiddenLines | -2,009,523 |
OST_SiteHiddenLines | -2,009,524 |
OST_StructuralFramingSystemHiddenLines_Obsolete | -2,009,525 |
OST_TopographyHiddenLines | -2,009,526 |
OST_SpecialityEquipmentHiddenLines | -2,009,527 |
OST_PlantingHiddenLines | -2,009,528 |
OST_EntourageHiddenLines | -2,009,529 |
OST_OBSOLETE_ElemArrayHiddenLines | -2,009,530 |
OST_CurtaSystemHiddenLines | -2,009,531 |
OST_MassHiddenLines | -2,009,532 |
OST_Stairs2012HiddenLines_Deprecated | -2,009,533 |
OST_StairRun2012HiddenLines_Deprecated | -2,009,534 |
OST_StairLanding2012HiddenLines_Deprecated | -2,009,535 |
OST_StairTread2012HiddenLines_Deprecated | -2,009,536 |
OST_StairStringer2012HiddenLines_Deprecated | -2,009,537 |
OST_RailingSystemHiddenLines_Deprecated | -2,009,538 |
OST_RailingSystemSegmentHiddenLines_Deprecated | -2,009,539 |
OST_RailingSystemPostHiddenLines_Deprecated | -2,009,540 |
OST_RailingSystemBalusterHiddenLines_Deprecated | -2,009,541 |
OST_RailingSystemPanelHiddenLines_Deprecated | -2,009,542 |
OST_RailingSystemPanelBracketHiddenLines_Deprecated | -2,009,543 |
OST_RailingSystemHandRailHiddenLines_Deprecated | -2,009,544 |
OST_RailingSystemHandRailBracketHiddenLines_Deprecated | -2,009,545 |
OST_RailingSystemTopRailHiddenLines_Deprecated | -2,009,546 |
OST_RailingSystemRailHiddenLines_Deprecated | -2,009,547 |
OST_RailingSystemTerminationHiddenLines_Deprecated | -2,009,548 |
OST_RailingSystemTransitionHiddenLines_Deprecated | -2,009,549 |
OST_MechanicalControlDevicesHiddenLines | -2,009,550 |
OST_PlumbingEquipmentHiddenLines | -2,009,551 |
OST_Truss | -2,009,600 |
OST_TrussDiagWebCurve | -2,009,601 |
OST_TrussVertWebCurve | -2,009,602 |
OST_TrussTopChordCurve | -2,009,603 |
OST_TrussBottomChordCurve | -2,009,604 |
OST_TrussWeb | -2,009,605 |
OST_TrussChord | -2,009,606 |
OST_StructuralTrussHiddenLines | -2,009,607 |
OST_StructuralTrussStickSymbols | -2,009,608 |
OST_SunStudy | -2,009,609 |
OST_Sun | -2,009,610 |
OST_SunPath1 | -2,009,611 |
OST_SunPath2 | -2,009,612 |
OST_CompassInner | -2,009,613 |
OST_SunriseText | -2,009,614 |
OST_CompassOuter | -2,009,615 |
OST_CompassSection | -2,009,616 |
OST_SunsetText | -2,009,617 |
OST_Analemma | -2,009,618 |
OST_SunSurface | -2,009,619 |
OST_MultiSurface | -2,009,620 |
OST_LightLine | -2,009,621 |
OST_CompassSectionFilled | -2,009,622 |
OST_CompassPrimaryMonth | -2,009,623 |
OST_CompassSecondaryMonth | -2,009,624 |
OST_BeamAnalytical | -2,009,630 |
OST_BeamStartSegment | -2,009,631 |
OST_BeamEndSegment | -2,009,632 |
OST_BraceAnalytical | -2,009,633 |
OST_BraceStartSegment | -2,009,634 |
OST_BraceEndSegment | -2,009,635 |
OST_ColumnAnalytical | -2,009,636 |
OST_ColumnStartSegment | -2,009,637 |
OST_ColumnEndSegment | -2,009,638 |
OST_FloorAnalytical | -2,009,639 |
OST_WallAnalytical | -2,009,640 |
OST_IsolatedFoundationAnalytical | -2,009,641 |
OST_WallFoundationAnalytical | -2,009,642 |
OST_FoundationSlabAnalytical | -2,009,643 |
OST_RigidLinksAnalytical | -2,009,644 |
OST_AnalyticalNodes | -2,009,645 |
OST_AnalyticalNodes_Points | -2,009,646 |
OST_AnalyticalNodes_Planes | -2,009,647 |
OST_AnalyticalNodes_Lines | -2,009,648 |
OST_BeamAnalyticalTags | -2,009,649 |
OST_BraceAnalyticalTags | -2,009,650 |
OST_ColumnAnalyticalTags | -2,009,651 |
OST_FloorAnalyticalTags | -2,009,652 |
OST_WallAnalyticalTags | -2,009,653 |
OST_IsolatedFoundationAnalyticalTags | -2,009,654 |
OST_WallFoundationAnalyticalTags | -2,009,655 |
OST_FoundationSlabAnalyticalTags | -2,009,656 |
OST_LinksAnalytical | -2,009,657 |
OST_AssemblyOrigin | -2,009,658 |
OST_AssemblyOrigin_Points | -2,009,659 |
OST_AssemblyOrigin_Planes | -2,009,660 |
OST_AssemblyOrigin_Lines | -2,009,661 |
OST_AnalyticalMember | -2,009,662 |
OST_AnalyticalMemberTags | -2,009,663 |
OST_AnalyticalPanel | -2,009,664 |
OST_AnalyticalOpening | -2,009,665 |
OST_AnalyticalMemberLocalCoordSys | -2,009,666 |
OST_AnalyticalPanelLocalCoordSys | -2,009,667 |
OST_PointClouds | -2,010,001 |
OST_RemovedGridSeg_Obsolete_IdInWrongRange | -20,000,827 |
OST_StickSymbols_Obsolete_IdInWrongRange | -20,000,828 |
OST_WallRefPlanes_Obsolete_IdInWrongRange | -20,000,896 |
OST_Mass_Obsolete_IdInWrongRange | -20,034,000 |
OST_MassFloor_Obsolete_IdInWrongRange | -20,034,003 |
OST_MassSurface_Obsolete_IdInWrongRange | -20,034,004 |
OST_MassTags_Obsolete_IdInWrongRange | -20,034,005 |
OST_StackedWalls_Obsolete_IdInWrongRange | -20,034,100 |
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


BuiltInFailures Class

Provides a container of all Revit built-in FailureDefinitionId instances.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class BuiltInFailures
Public NotInheritable Class BuiltInFailures
public ref class BuiltInFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type BuiltInFailures = class end
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


BuiltInFailures.AlignmentFailures Class

BuiltInFailuresAlignmentFailures Class

Failures related to alignment elements and annotations.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresAlignmentFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class AlignmentFailures
Public NotInheritable Class AlignmentFailures
public ref class AlignmentFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type AlignmentFailures = class end

The BuiltInFailuresAlignmentFailures type exposes the following members.

Properties
Name | Description
AlignmentCheckStationLabels | A change to an Infrastructure Alignment or its Stationing Units may have affected the associated Alignment Station Labels. Please check the labels to ensure proper placement.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


AlignmentFailures Properties

The BuiltInFailuresAlignmentFailures type exposes the following members.

Properties
Name | Description
AlignmentCheckStationLabels | A change to an Infrastructure Alignment or its Stationing Units may have affected the associated Alignment Station Labels. Please check the labels to ensure proper placement.
Top
See Also

Reference

BuiltInFailuresAlignmentFailures Class


BuiltInFailures.AlignmentFailures.AlignmentCheckStationLabels Property

BuiltInFailuresAlignmentFailuresAlignmentCheckStationLabels Property

A change to an Infrastructure Alignment or its Stationing Units may have affected the associated Alignment Station Labels. Please check the labels to ensure proper placement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AlignmentCheckStationLabels { get; }
Public Shared ReadOnly Property AlignmentCheckStationLabels As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AlignmentCheckStationLabels {
    FailureDefinitionId^ get ();
}
static member AlignmentCheckStationLabels : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAlignmentFailures Class


BuiltInFailures.AnalyticalModelFailures Class

BuiltInFailuresAnalyticalModelFailures Class

Failures about AnalyticalModel.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresAnalyticalModelFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class AnalyticalModelFailures
Public NotInheritable Class AnalyticalModelFailures
public ref class AnalyticalModelFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type AnalyticalModelFailures = class end

The BuiltInFailuresAnalyticalModelFailures type exposes the following members.

Properties
Name | Description
AdjustCurveTooShort | AdjustCurve is too short.
AdjustEdgeTooShort | AdjustEdge is too short.
AdjustEdgeTooShortErr | AdjustEdge is too short - continuable error version.
AdjustEdgeTooShortWarn | AdjustEdge is too short.
AnalyticalBeamSlabWarning | Beam and Slab Analytical Models do not have the same Analytical Projection Plane.
AnalyticalCurvedPanelNotValid | Analytical Curved Panel is not valid.
AnalyticalDiscrepancyWarning | Distance between Analytical and Physical Models of Structural Element is beyond tolerance of [Value]
AnalyticalElementsInvalidAfterUpgrade | One or several analytical elements have become invalid during the upgrade process and will be deleted.
AnalyticalGapWarning | Detected physical connection between Structural Elements, but did not detect Analytical intersection.
AnalyticalLinkJoinedNodes | Analitycal Link is invalid. Reference nodes have been joined.
AnalyticalLinkNotConnected | Analytical Link has lost one or more references.
AnalyticalMemberInstability | Possible Member Instability, based on Release Conditions
AnalyticalModelInstability | Possible Model Instability
AnalyticalModelIsIncorrect | Analytical Model is not created for the structural element.
AnalyticalPanelNotPlanar | Analytical Panel is not planar.
AnalyticalPanelNotVisible | Analytical Panel is not visible in the current view.
AnalyticalPhysicalCheckDone | Analytical / Physical Model Consistency check is complete.
AnalyticalSupportCycleWarning | Circular support chain detected
AnalyticalSurfaceCannotMove | Cannot move analytical surface.
AnalyticalSurfaceCannotMoveByConnector | Cannot move analytical surface because it will disconnect the analytical nodes.
AnalyticalTopBottomPlanesReversed | Analytical Top Projection Plane is partially or completely below Analytical Bottom Projection Plane. Please reset top and/or bottom planes to valid values.
AutoDetectIgnoreLeaderWarning | Analytical Model for Structural Element has reset to its default location.
BoundaryLinesIntersect | Boundary lines intersect.
CannotCreateAnalyticalGeometry | Cannot construct Analytical Geometry.
CannotKeepAnalyticalAdjustment | Analytical model Adjustment distance exceeds current Adjustment Snapping Distance. To adjust snap settings, go to the Structural Settings Dialog.
CannotMakeAnalyticalGeometry | Cannot construct Analytical Geometry.
CannotSlantAnalyticalWallError | Cannot slant a wall with an Analytical Model. Please disable the Analytical Model first.
ContextualAnalyticalModelModeNotEnabled | Contextual Analytical Model not enabled. File open was canceled.
HighestAssociatedLevelBelowLowestAssociatedLevel | The Highest Associated Level is set below the Lowest Associated Level
LoadsMayBeNotUpToDate | Reactions defined as Internal Load (Is Reaction) may no longer be valid since the analytical model has changed.
LowestAssociatedLevelAboveHighestAssociatedLevel | The Lowest Associated Level is set above the Highest Associated Level
ProjectionPlaneInvalidWall | Projection plane becomes invalid for this wall.
ProjectionPlanesNotIntersect | Can't project Analytical Model. Planes do not intersect each other.
ProjectionPlanesParallel | Can't project Analytical Model. Two or more projection planes are parallel.
StructAnalyticalErrorProjection | Can't project Analytical Model to Analytical Projection Surface
StructuralElementMayNotBeSupported | Structural Element may not be supported -- verify support for Element.
StructWallAnalyticalErrorAlign | Can't align Analytical Model with joined Walls.
StructWallAnalyticalErrorConversion | Can't convert Edges to Analytical Model curves.
SupportCheckDone | Member support check is complete. No unsupported elements detected.
UnableToUpgradeAnalyticalElementGeometry | Unable to upgrade analytical element with incorrect geometry. To keep the elements, open Revit 2022 and correct the elements.
WallAMLostAdjustmentReference | Wall Analytical Model has lost its adjustment reference.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


AnalyticalModelFailures Properties

The BuiltInFailuresAnalyticalModelFailures type exposes the following members.

Properties
Name | Description
AdjustCurveTooShort | AdjustCurve is too short.
AdjustEdgeTooShort | AdjustEdge is too short.
AdjustEdgeTooShortErr | AdjustEdge is too short - continuable error version.
AdjustEdgeTooShortWarn | AdjustEdge is too short.
AnalyticalBeamSlabWarning | Beam and Slab Analytical Models do not have the same Analytical Projection Plane.
AnalyticalCurvedPanelNotValid | Analytical Curved Panel is not valid.
AnalyticalDiscrepancyWarning | Distance between Analytical and Physical Models of Structural Element is beyond tolerance of [Value]
AnalyticalElementsInvalidAfterUpgrade | One or several analytical elements have become invalid during the upgrade process and will be deleted.
AnalyticalGapWarning | Detected physical connection between Structural Elements, but did not detect Analytical intersection.
AnalyticalLinkJoinedNodes | Analitycal Link is invalid. Reference nodes have been joined.
AnalyticalLinkNotConnected | Analytical Link has lost one or more references.
AnalyticalMemberInstability | Possible Member Instability, based on Release Conditions
AnalyticalModelInstability | Possible Model Instability
AnalyticalModelIsIncorrect | Analytical Model is not created for the structural element.
AnalyticalPanelNotPlanar | Analytical Panel is not planar.
AnalyticalPanelNotVisible | Analytical Panel is not visible in the current view.
AnalyticalPhysicalCheckDone | Analytical / Physical Model Consistency check is complete.
AnalyticalSupportCycleWarning | Circular support chain detected
AnalyticalSurfaceCannotMove | Cannot move analytical surface.
AnalyticalSurfaceCannotMoveByConnector | Cannot move analytical surface because it will disconnect the analytical nodes.
AnalyticalTopBottomPlanesReversed | Analytical Top Projection Plane is partially or completely below Analytical Bottom Projection Plane. Please reset top and/or bottom planes to valid values.
AutoDetectIgnoreLeaderWarning | Analytical Model for Structural Element has reset to its default location.
BoundaryLinesIntersect | Boundary lines intersect.
CannotCreateAnalyticalGeometry | Cannot construct Analytical Geometry.
CannotKeepAnalyticalAdjustment | Analytical model Adjustment distance exceeds current Adjustment Snapping Distance. To adjust snap settings, go to the Structural Settings Dialog.
CannotMakeAnalyticalGeometry | Cannot construct Analytical Geometry.
CannotSlantAnalyticalWallError | Cannot slant a wall with an Analytical Model. Please disable the Analytical Model first.
ContextualAnalyticalModelModeNotEnabled | Contextual Analytical Model not enabled. File open was canceled.
HighestAssociatedLevelBelowLowestAssociatedLevel | The Highest Associated Level is set below the Lowest Associated Level
LoadsMayBeNotUpToDate | Reactions defined as Internal Load (Is Reaction) may no longer be valid since the analytical model has changed.
LowestAssociatedLevelAboveHighestAssociatedLevel | The Lowest Associated Level is set above the Highest Associated Level
ProjectionPlaneInvalidWall | Projection plane becomes invalid for this wall.
ProjectionPlanesNotIntersect | Can't project Analytical Model. Planes do not intersect each other.
ProjectionPlanesParallel | Can't project Analytical Model. Two or more projection planes are parallel.
StructAnalyticalErrorProjection | Can't project Analytical Model to Analytical Projection Surface
StructuralElementMayNotBeSupported | Structural Element may not be supported -- verify support for Element.
StructWallAnalyticalErrorAlign | Can't align Analytical Model with joined Walls.
StructWallAnalyticalErrorConversion | Can't convert Edges to Analytical Model curves.
SupportCheckDone | Member support check is complete. No unsupported elements detected.
UnableToUpgradeAnalyticalElementGeometry | Unable to upgrade analytical element with incorrect geometry. To keep the elements, open Revit 2022 and correct the elements.
WallAMLostAdjustmentReference | Wall Analytical Model has lost its adjustment reference.
Top
See Also

Reference

BuiltInFailuresAnalyticalModelFailures Class


BuiltInFailures.AnalyticalModelFailures.AdjustCurveTooShort Property

BuiltInFailuresAnalyticalModelFailuresAdjustCurveTooShort Property

AdjustCurve is too short.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AdjustCurveTooShort { get; }
Public Shared ReadOnly Property AdjustCurveTooShort As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AdjustCurveTooShort {
    FailureDefinitionId^ get ();
}
static member AdjustCurveTooShort : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAnalyticalModelFailures Class


BuiltInFailures.AnalyticalModelFailures.AdjustEdgeTooShort Property

BuiltInFailuresAnalyticalModelFailuresAdjustEdgeTooShort Property

AdjustEdge is too short.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AdjustEdgeTooShort { get; }
Public Shared ReadOnly Property AdjustEdgeTooShort As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AdjustEdgeTooShort {
    FailureDefinitionId^ get ();
}
static member AdjustEdgeTooShort : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAnalyticalModelFailures Class


BuiltInFailures.AnalyticalModelFailures.AdjustEdgeTooShortErr Property

BuiltInFailuresAnalyticalModelFailuresAdjustEdgeTooShortErr Property

AdjustEdge is too short - continuable error version.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AdjustEdgeTooShortErr { get; }
Public Shared ReadOnly Property AdjustEdgeTooShortErr As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AdjustEdgeTooShortErr {
    FailureDefinitionId^ get ();
}
static member AdjustEdgeTooShortErr : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAnalyticalModelFailures Class


BuiltInFailures.AnalyticalModelFailures.AdjustEdgeTooShortWarn Property

BuiltInFailuresAnalyticalModelFailuresAdjustEdgeTooShortWarn Property

AdjustEdge is too short.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AdjustEdgeTooShortWarn { get; }
Public Shared ReadOnly Property AdjustEdgeTooShortWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AdjustEdgeTooShortWarn {
    FailureDefinitionId^ get ();
}
static member AdjustEdgeTooShortWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAnalyticalModelFailures Class


BuiltInFailures.AnalyticalModelFailures.AnalyticalBeamSlabWarning Property

BuiltInFailuresAnalyticalModelFailuresAnalyticalBeamSlabWarning Property

Beam and Slab Analytical Models do not have the same Analytical Projection Plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AnalyticalBeamSlabWarning { get; }
Public Shared ReadOnly Property AnalyticalBeamSlabWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AnalyticalBeamSlabWarning {
    FailureDefinitionId^ get ();
}
static member AnalyticalBeamSlabWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAnalyticalModelFailures Class


BuiltInFailures.AnalyticalModelFailures.AnalyticalCurvedPanelNotValid Property

BuiltInFailuresAnalyticalModelFailuresAnalyticalCurvedPanelNotValid Property

Analytical Curved Panel is not valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AnalyticalCurvedPanelNotValid { get; }
Public Shared ReadOnly Property AnalyticalCurvedPanelNotValid As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AnalyticalCurvedPanelNotValid {
    FailureDefinitionId^ get ();
}
static member AnalyticalCurvedPanelNotValid : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAnalyticalModelFailures Class


BuiltInFailures.AnalyticalModelFailures.AnalyticalDiscrepancyWarning Property

BuiltInFailuresAnalyticalModelFailuresAnalyticalDiscrepancyWarning Property

Distance between Analytical and Physical Models of Structural Element is beyond tolerance of [Value]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AnalyticalDiscrepancyWarning { get; }
Public Shared ReadOnly Property AnalyticalDiscrepancyWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AnalyticalDiscrepancyWarning {
    FailureDefinitionId^ get ();
}
static member AnalyticalDiscrepancyWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAnalyticalModelFailures Class


BuiltInFailures.AnalyticalModelFailures.AnalyticalElementsInvalidAfterUpgrade Property

BuiltInFailuresAnalyticalModelFailuresAnalyticalElementsInvalidAfterUpgrade Property

One or several analytical elements have become invalid during the upgrade process and will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AnalyticalElementsInvalidAfterUpgrade { get; }
Public Shared ReadOnly Property AnalyticalElementsInvalidAfterUpgrade As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AnalyticalElementsInvalidAfterUpgrade {
    FailureDefinitionId^ get ();
}
static member AnalyticalElementsInvalidAfterUpgrade : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAnalyticalModelFailures Class


BuiltInFailures.AnalyticalModelFailures.AnalyticalGapWarning Property

BuiltInFailuresAnalyticalModelFailuresAnalyticalGapWarning Property

Detected physical connection between Structural Elements, but did not detect Analytical intersection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AnalyticalGapWarning { get; }
Public Shared ReadOnly Property AnalyticalGapWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AnalyticalGapWarning {
    FailureDefinitionId^ get ();
}
static member AnalyticalGapWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAnalyticalModelFailures Class


BuiltInFailures.AnalyticalModelFailures.AnalyticalLinkJoinedNodes Property

BuiltInFailuresAnalyticalModelFailuresAnalyticalLinkJoinedNodes Property

Analitycal Link is invalid. Reference nodes have been joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AnalyticalLinkJoinedNodes { get; }
Public Shared ReadOnly Property AnalyticalLinkJoinedNodes As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AnalyticalLinkJoinedNodes {
    FailureDefinitionId^ get ();
}
static member AnalyticalLinkJoinedNodes : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAnalyticalModelFailures Class


BuiltInFailures.AnalyticalModelFailures.AnalyticalLinkNotConnected Property

BuiltInFailuresAnalyticalModelFailuresAnalyticalLinkNotConnected Property

Analytical Link has lost one or more references.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AnalyticalLinkNotConnected { get; }
Public Shared ReadOnly Property AnalyticalLinkNotConnected As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AnalyticalLinkNotConnected {
    FailureDefinitionId^ get ();
}
static member AnalyticalLinkNotConnected : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAnalyticalModelFailures Class


BuiltInFailures.AnalyticalModelFailures.AnalyticalMemberInstability Property

BuiltInFailuresAnalyticalModelFailuresAnalyticalMemberInstability Property

Possible Member Instability, based on Release Conditions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AnalyticalMemberInstability { get; }
Public Shared ReadOnly Property AnalyticalMemberInstability As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AnalyticalMemberInstability {
    FailureDefinitionId^ get ();
}
static member AnalyticalMemberInstability : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAnalyticalModelFailures Class


BuiltInFailures.AnalyticalModelFailures.AnalyticalModelInstability Property

BuiltInFailuresAnalyticalModelFailuresAnalyticalModelInstability Property

Possible Model Instability

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AnalyticalModelInstability { get; }
Public Shared ReadOnly Property AnalyticalModelInstability As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AnalyticalModelInstability {
    FailureDefinitionId^ get ();
}
static member AnalyticalModelInstability : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAnalyticalModelFailures Class


BuiltInFailures.AnalyticalModelFailures.AnalyticalModelIsIncorrect Property

BuiltInFailuresAnalyticalModelFailuresAnalyticalModelIsIncorrect Property

Analytical Model is not created for the structural element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AnalyticalModelIsIncorrect { get; }
Public Shared ReadOnly Property AnalyticalModelIsIncorrect As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AnalyticalModelIsIncorrect {
    FailureDefinitionId^ get ();
}
static member AnalyticalModelIsIncorrect : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAnalyticalModelFailures Class


BuiltInFailures.AnalyticalModelFailures.AnalyticalPanelNotPlanar Property

BuiltInFailuresAnalyticalModelFailuresAnalyticalPanelNotPlanar Property

Analytical Panel is not planar.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AnalyticalPanelNotPlanar { get; }
Public Shared ReadOnly Property AnalyticalPanelNotPlanar As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AnalyticalPanelNotPlanar {
    FailureDefinitionId^ get ();
}
static member AnalyticalPanelNotPlanar : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAnalyticalModelFailures Class


BuiltInFailures.AnalyticalModelFailures.AnalyticalPanelNotVisible Property

BuiltInFailuresAnalyticalModelFailuresAnalyticalPanelNotVisible Property

Analytical Panel is not visible in the current view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AnalyticalPanelNotVisible { get; }
Public Shared ReadOnly Property AnalyticalPanelNotVisible As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AnalyticalPanelNotVisible {
    FailureDefinitionId^ get ();
}
static member AnalyticalPanelNotVisible : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAnalyticalModelFailures Class


BuiltInFailures.AnalyticalModelFailures.AnalyticalPhysicalCheckDone Property

BuiltInFailuresAnalyticalModelFailuresAnalyticalPhysicalCheckDone Property

Analytical / Physical Model Consistency check is complete.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AnalyticalPhysicalCheckDone { get; }
Public Shared ReadOnly Property AnalyticalPhysicalCheckDone As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AnalyticalPhysicalCheckDone {
    FailureDefinitionId^ get ();
}
static member AnalyticalPhysicalCheckDone : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAnalyticalModelFailures Class


BuiltInFailures.AnalyticalModelFailures.AnalyticalSupportCycleWarning Property

BuiltInFailuresAnalyticalModelFailuresAnalyticalSupportCycleWarning Property

Circular support chain detected

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AnalyticalSupportCycleWarning { get; }
Public Shared ReadOnly Property AnalyticalSupportCycleWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AnalyticalSupportCycleWarning {
    FailureDefinitionId^ get ();
}
static member AnalyticalSupportCycleWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAnalyticalModelFailures Class


BuiltInFailures.AnalyticalModelFailures.AnalyticalSurfaceCannotMove Property

BuiltInFailuresAnalyticalModelFailuresAnalyticalSurfaceCannotMove Property

Cannot move analytical surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AnalyticalSurfaceCannotMove { get; }
Public Shared ReadOnly Property AnalyticalSurfaceCannotMove As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AnalyticalSurfaceCannotMove {
    FailureDefinitionId^ get ();
}
static member AnalyticalSurfaceCannotMove : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAnalyticalModelFailures Class


BuiltInFailures.AnalyticalModelFailures.AnalyticalSurfaceCannotMoveByConnector Property

BuiltInFailuresAnalyticalModelFailuresAnalyticalSurfaceCannotMoveByConnector Property

Cannot move analytical surface because it will disconnect the analytical nodes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AnalyticalSurfaceCannotMoveByConnector { get; }
Public Shared ReadOnly Property AnalyticalSurfaceCannotMoveByConnector As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AnalyticalSurfaceCannotMoveByConnector {
    FailureDefinitionId^ get ();
}
static member AnalyticalSurfaceCannotMoveByConnector : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAnalyticalModelFailures Class


BuiltInFailures.AnalyticalModelFailures.AnalyticalTopBottomPlanesReversed Property

BuiltInFailuresAnalyticalModelFailuresAnalyticalTopBottomPlanesReversed Property

Analytical Top Projection Plane is partially or completely below Analytical Bottom Projection Plane. Please reset top and/or bottom planes to valid values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AnalyticalTopBottomPlanesReversed { get; }
Public Shared ReadOnly Property AnalyticalTopBottomPlanesReversed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AnalyticalTopBottomPlanesReversed {
    FailureDefinitionId^ get ();
}
static member AnalyticalTopBottomPlanesReversed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAnalyticalModelFailures Class


BuiltInFailures.AnalyticalModelFailures.AutoDetectIgnoreLeaderWarning Property

BuiltInFailuresAnalyticalModelFailuresAutoDetectIgnoreLeaderWarning Property

Analytical Model for Structural Element has reset to its default location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AutoDetectIgnoreLeaderWarning { get; }
Public Shared ReadOnly Property AutoDetectIgnoreLeaderWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AutoDetectIgnoreLeaderWarning {
    FailureDefinitionId^ get ();
}
static member AutoDetectIgnoreLeaderWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAnalyticalModelFailures Class


BuiltInFailures.AnalyticalModelFailures.BoundaryLinesIntersect Property

BuiltInFailuresAnalyticalModelFailuresBoundaryLinesIntersect Property

Boundary lines intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BoundaryLinesIntersect { get; }
Public Shared ReadOnly Property BoundaryLinesIntersect As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BoundaryLinesIntersect {
    FailureDefinitionId^ get ();
}
static member BoundaryLinesIntersect : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAnalyticalModelFailures Class


BuiltInFailures.AnalyticalModelFailures.CannotCreateAnalyticalGeometry Property

BuiltInFailuresAnalyticalModelFailuresCannotCreateAnalyticalGeometry Property

Cannot construct Analytical Geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateAnalyticalGeometry { get; }
Public Shared ReadOnly Property CannotCreateAnalyticalGeometry As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateAnalyticalGeometry {
    FailureDefinitionId^ get ();
}
static member CannotCreateAnalyticalGeometry : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAnalyticalModelFailures Class


BuiltInFailures.AnalyticalModelFailures.CannotKeepAnalyticalAdjustment Property

BuiltInFailuresAnalyticalModelFailuresCannotKeepAnalyticalAdjustment Property

Analytical model Adjustment distance exceeds current Adjustment Snapping Distance. To adjust snap settings, go to the Structural Settings Dialog.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotKeepAnalyticalAdjustment { get; }
Public Shared ReadOnly Property CannotKeepAnalyticalAdjustment As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotKeepAnalyticalAdjustment {
    FailureDefinitionId^ get ();
}
static member CannotKeepAnalyticalAdjustment : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAnalyticalModelFailures Class


BuiltInFailures.AnalyticalModelFailures.CannotMakeAnalyticalGeometry Property

BuiltInFailuresAnalyticalModelFailuresCannotMakeAnalyticalGeometry Property

Cannot construct Analytical Geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotMakeAnalyticalGeometry { get; }
Public Shared ReadOnly Property CannotMakeAnalyticalGeometry As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotMakeAnalyticalGeometry {
    FailureDefinitionId^ get ();
}
static member CannotMakeAnalyticalGeometry : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAnalyticalModelFailures Class


BuiltInFailures.AnalyticalModelFailures.CannotSlantAnalyticalWallError Property

BuiltInFailuresAnalyticalModelFailuresCannotSlantAnalyticalWallError Property

Cannot slant a wall with an Analytical Model. Please disable the Analytical Model first.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotSlantAnalyticalWallError { get; }
Public Shared ReadOnly Property CannotSlantAnalyticalWallError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotSlantAnalyticalWallError {
    FailureDefinitionId^ get ();
}
static member CannotSlantAnalyticalWallError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAnalyticalModelFailures Class


BuiltInFailures.AnalyticalModelFailures.ContextualAnalyticalModelModeNotEnabled Property

BuiltInFailuresAnalyticalModelFailuresContextualAnalyticalModelModeNotEnabled Property

Contextual Analytical Model not enabled. File open was canceled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ContextualAnalyticalModelModeNotEnabled { get; }
Public Shared ReadOnly Property ContextualAnalyticalModelModeNotEnabled As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ContextualAnalyticalModelModeNotEnabled {
    FailureDefinitionId^ get ();
}
static member ContextualAnalyticalModelModeNotEnabled : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAnalyticalModelFailures Class


BuiltInFailures.AnalyticalModelFailures.HighestAssociatedLevelBelowLowestAssociatedLevel Property

BuiltInFailuresAnalyticalModelFailuresHighestAssociatedLevelBelowLowestAssociatedLevel Property

The Highest Associated Level is set below the Lowest Associated Level

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId HighestAssociatedLevelBelowLowestAssociatedLevel { get; }
Public Shared ReadOnly Property HighestAssociatedLevelBelowLowestAssociatedLevel As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ HighestAssociatedLevelBelowLowestAssociatedLevel {
    FailureDefinitionId^ get ();
}
static member HighestAssociatedLevelBelowLowestAssociatedLevel : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAnalyticalModelFailures Class


BuiltInFailures.AnalyticalModelFailures.LoadsMayBeNotUpToDate Property

BuiltInFailuresAnalyticalModelFailuresLoadsMayBeNotUpToDate Property

Reactions defined as Internal Load (Is Reaction) may no longer be valid since the analytical model has changed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LoadsMayBeNotUpToDate { get; }
Public Shared ReadOnly Property LoadsMayBeNotUpToDate As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LoadsMayBeNotUpToDate {
    FailureDefinitionId^ get ();
}
static member LoadsMayBeNotUpToDate : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAnalyticalModelFailures Class


BuiltInFailures.AnalyticalModelFailures.LowestAssociatedLevelAboveHighestAssociatedLevel Property

BuiltInFailuresAnalyticalModelFailuresLowestAssociatedLevelAboveHighestAssociatedLevel Property

The Lowest Associated Level is set above the Highest Associated Level

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LowestAssociatedLevelAboveHighestAssociatedLevel { get; }
Public Shared ReadOnly Property LowestAssociatedLevelAboveHighestAssociatedLevel As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LowestAssociatedLevelAboveHighestAssociatedLevel {
    FailureDefinitionId^ get ();
}
static member LowestAssociatedLevelAboveHighestAssociatedLevel : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAnalyticalModelFailures Class


BuiltInFailures.AnalyticalModelFailures.ProjectionPlaneInvalidWall Property

BuiltInFailuresAnalyticalModelFailuresProjectionPlaneInvalidWall Property

Projection plane becomes invalid for this wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ProjectionPlaneInvalidWall { get; }
Public Shared ReadOnly Property ProjectionPlaneInvalidWall As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ProjectionPlaneInvalidWall {
    FailureDefinitionId^ get ();
}
static member ProjectionPlaneInvalidWall : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAnalyticalModelFailures Class


BuiltInFailures.AnalyticalModelFailures.ProjectionPlanesNotIntersect Property

BuiltInFailuresAnalyticalModelFailuresProjectionPlanesNotIntersect Property

Can't project Analytical Model. Planes do not intersect each other.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ProjectionPlanesNotIntersect { get; }
Public Shared ReadOnly Property ProjectionPlanesNotIntersect As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ProjectionPlanesNotIntersect {
    FailureDefinitionId^ get ();
}
static member ProjectionPlanesNotIntersect : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAnalyticalModelFailures Class


BuiltInFailures.AnalyticalModelFailures.ProjectionPlanesParallel Property

BuiltInFailuresAnalyticalModelFailuresProjectionPlanesParallel Property

Can't project Analytical Model. Two or more projection planes are parallel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ProjectionPlanesParallel { get; }
Public Shared ReadOnly Property ProjectionPlanesParallel As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ProjectionPlanesParallel {
    FailureDefinitionId^ get ();
}
static member ProjectionPlanesParallel : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAnalyticalModelFailures Class


BuiltInFailures.AnalyticalModelFailures.StructAnalyticalErrorProjection Property

BuiltInFailuresAnalyticalModelFailuresStructAnalyticalErrorProjection Property

Can't project Analytical Model to Analytical Projection Surface

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StructAnalyticalErrorProjection { get; }
Public Shared ReadOnly Property StructAnalyticalErrorProjection As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StructAnalyticalErrorProjection {
    FailureDefinitionId^ get ();
}
static member StructAnalyticalErrorProjection : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAnalyticalModelFailures Class


BuiltInFailures.AnalyticalModelFailures.StructuralElementMayNotBeSupported Property

BuiltInFailuresAnalyticalModelFailuresStructuralElementMayNotBeSupported Property

Structural Element may not be supported -- verify support for Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StructuralElementMayNotBeSupported { get; }
Public Shared ReadOnly Property StructuralElementMayNotBeSupported As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StructuralElementMayNotBeSupported {
    FailureDefinitionId^ get ();
}
static member StructuralElementMayNotBeSupported : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAnalyticalModelFailures Class


BuiltInFailures.AnalyticalModelFailures.StructWallAnalyticalErrorAlign Property

BuiltInFailuresAnalyticalModelFailuresStructWallAnalyticalErrorAlign Property

Can't align Analytical Model with joined Walls.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StructWallAnalyticalErrorAlign { get; }
Public Shared ReadOnly Property StructWallAnalyticalErrorAlign As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StructWallAnalyticalErrorAlign {
    FailureDefinitionId^ get ();
}
static member StructWallAnalyticalErrorAlign : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAnalyticalModelFailures Class


BuiltInFailures.AnalyticalModelFailures.StructWallAnalyticalErrorConversion Property

BuiltInFailuresAnalyticalModelFailuresStructWallAnalyticalErrorConversion Property

Can't convert Edges to Analytical Model curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StructWallAnalyticalErrorConversion { get; }
Public Shared ReadOnly Property StructWallAnalyticalErrorConversion As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StructWallAnalyticalErrorConversion {
    FailureDefinitionId^ get ();
}
static member StructWallAnalyticalErrorConversion : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAnalyticalModelFailures Class


BuiltInFailures.AnalyticalModelFailures.SupportCheckDone Property

BuiltInFailuresAnalyticalModelFailuresSupportCheckDone Property

Member support check is complete. No unsupported elements detected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SupportCheckDone { get; }
Public Shared ReadOnly Property SupportCheckDone As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SupportCheckDone {
    FailureDefinitionId^ get ();
}
static member SupportCheckDone : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAnalyticalModelFailures Class


BuiltInFailures.AnalyticalModelFailures.UnableToUpgradeAnalyticalElementGeometry Property

BuiltInFailuresAnalyticalModelFailuresUnableToUpgradeAnalyticalElementGeometry Property

Unable to upgrade analytical element with incorrect geometry. To keep the elements, open Revit 2022 and correct the elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnableToUpgradeAnalyticalElementGeometry { get; }
Public Shared ReadOnly Property UnableToUpgradeAnalyticalElementGeometry As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnableToUpgradeAnalyticalElementGeometry {
    FailureDefinitionId^ get ();
}
static member UnableToUpgradeAnalyticalElementGeometry : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAnalyticalModelFailures Class


BuiltInFailures.AnalyticalModelFailures.WallAMLostAdjustmentReference Property

BuiltInFailuresAnalyticalModelFailuresWallAMLostAdjustmentReference Property

Wall Analytical Model has lost its adjustment reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WallAMLostAdjustmentReference { get; }
Public Shared ReadOnly Property WallAMLostAdjustmentReference As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WallAMLostAdjustmentReference {
    FailureDefinitionId^ get ();
}
static member WallAMLostAdjustmentReference : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAnalyticalModelFailures Class


BuiltInFailures.ArrayFailures Class

BuiltInFailuresArrayFailures Class

Failures about Arrays.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresArrayFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ArrayFailures
Public NotInheritable Class ArrayFailures
public ref class ArrayFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ArrayFailures = class end

The BuiltInFailuresArrayFailures type exposes the following members.

Properties
Name | Description
ArrayingNotSupportedForElements | Arraying is not currently supported for the selected elements.
ArrayMixedModAndViewSpecElemsCorruption | Unable to array this mixture of modeling and view specific elements.
ArrayMixedModAndViewSpecElemsWarning | You have selected a mixture of modeling and view specific elements to array in an associative manner. Only the model elements will remain grouped and associative.
CannotCreateArraySelectionIsGrouped | Can't create an array because the selection cannot be grouped.
ConstraintsNotSatisfied | Constraints are not satisfied
CouldntFindNewHostsForElements | Couldn't find new hosts for elements in array.
IdenticalGeometryCopiesInArray | This array contains multiple copies of some identical geometry. Performance might be improved by using a nested family and arraying copies of its instances.
RadiusTooSmall | Radius is too small.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ArrayFailures Properties

The BuiltInFailuresArrayFailures type exposes the following members.

Properties
Name | Description
ArrayingNotSupportedForElements | Arraying is not currently supported for the selected elements.
ArrayMixedModAndViewSpecElemsCorruption | Unable to array this mixture of modeling and view specific elements.
ArrayMixedModAndViewSpecElemsWarning | You have selected a mixture of modeling and view specific elements to array in an associative manner. Only the model elements will remain grouped and associative.
CannotCreateArraySelectionIsGrouped | Can't create an array because the selection cannot be grouped.
ConstraintsNotSatisfied | Constraints are not satisfied
CouldntFindNewHostsForElements | Couldn't find new hosts for elements in array.
IdenticalGeometryCopiesInArray | This array contains multiple copies of some identical geometry. Performance might be improved by using a nested family and arraying copies of its instances.
RadiusTooSmall | Radius is too small.
Top
See Also

Reference

BuiltInFailuresArrayFailures Class


BuiltInFailures.ArrayFailures.ArrayingNotSupportedForElements Property

BuiltInFailuresArrayFailuresArrayingNotSupportedForElements Property

Arraying is not currently supported for the selected elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ArrayingNotSupportedForElements { get; }
Public Shared ReadOnly Property ArrayingNotSupportedForElements As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ArrayingNotSupportedForElements {
    FailureDefinitionId^ get ();
}
static member ArrayingNotSupportedForElements : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresArrayFailures Class


BuiltInFailures.ArrayFailures.ArrayMixedModAndViewSpecElemsCorruption Property

BuiltInFailuresArrayFailuresArrayMixedModAndViewSpecElemsCorruption Property

Unable to array this mixture of modeling and view specific elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ArrayMixedModAndViewSpecElemsCorruption { get; }
Public Shared ReadOnly Property ArrayMixedModAndViewSpecElemsCorruption As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ArrayMixedModAndViewSpecElemsCorruption {
    FailureDefinitionId^ get ();
}
static member ArrayMixedModAndViewSpecElemsCorruption : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresArrayFailures Class


BuiltInFailures.ArrayFailures.ArrayMixedModAndViewSpecElemsWarning Property

BuiltInFailuresArrayFailuresArrayMixedModAndViewSpecElemsWarning Property

You have selected a mixture of modeling and view specific elements to array in an associative manner. Only the model elements will remain grouped and associative.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ArrayMixedModAndViewSpecElemsWarning { get; }
Public Shared ReadOnly Property ArrayMixedModAndViewSpecElemsWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ArrayMixedModAndViewSpecElemsWarning {
    FailureDefinitionId^ get ();
}
static member ArrayMixedModAndViewSpecElemsWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresArrayFailures Class


BuiltInFailures.ArrayFailures.CannotCreateArraySelectionIsGrouped Property

BuiltInFailuresArrayFailuresCannotCreateArraySelectionIsGrouped Property

Can't create an array because the selection cannot be grouped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateArraySelectionIsGrouped { get; }
Public Shared ReadOnly Property CannotCreateArraySelectionIsGrouped As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateArraySelectionIsGrouped {
    FailureDefinitionId^ get ();
}
static member CannotCreateArraySelectionIsGrouped : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresArrayFailures Class


BuiltInFailures.ArrayFailures.ConstraintsNotSatisfied Property

BuiltInFailuresArrayFailuresConstraintsNotSatisfied Property

Constraints are not satisfied

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ConstraintsNotSatisfied { get; }
Public Shared ReadOnly Property ConstraintsNotSatisfied As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ConstraintsNotSatisfied {
    FailureDefinitionId^ get ();
}
static member ConstraintsNotSatisfied : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresArrayFailures Class


BuiltInFailures.ArrayFailures.CouldntFindNewHostsForElements Property

BuiltInFailuresArrayFailuresCouldntFindNewHostsForElements Property

Couldn't find new hosts for elements in array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CouldntFindNewHostsForElements { get; }
Public Shared ReadOnly Property CouldntFindNewHostsForElements As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CouldntFindNewHostsForElements {
    FailureDefinitionId^ get ();
}
static member CouldntFindNewHostsForElements : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresArrayFailures Class


BuiltInFailures.ArrayFailures.IdenticalGeometryCopiesInArray Property

BuiltInFailuresArrayFailuresIdenticalGeometryCopiesInArray Property

This array contains multiple copies of some identical geometry. Performance might be improved by using a nested family and arraying copies of its instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId IdenticalGeometryCopiesInArray { get; }
Public Shared ReadOnly Property IdenticalGeometryCopiesInArray As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ IdenticalGeometryCopiesInArray {
    FailureDefinitionId^ get ();
}
static member IdenticalGeometryCopiesInArray : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresArrayFailures Class


BuiltInFailures.ArrayFailures.RadiusTooSmall Property

BuiltInFailuresArrayFailuresRadiusTooSmall Property

Radius is too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RadiusTooSmall { get; }
Public Shared ReadOnly Property RadiusTooSmall As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RadiusTooSmall {
    FailureDefinitionId^ get ();
}
static member RadiusTooSmall : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresArrayFailures Class


BuiltInFailures.AssemblyFailures Class

BuiltInFailuresAssemblyFailures Class

Failures related to Assemblies.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresAssemblyFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class AssemblyFailures
Public NotInheritable Class AssemblyFailures
public ref class AssemblyFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type AssemblyFailures = class end

The BuiltInFailuresAssemblyFailures type exposes the following members.

Properties
Name | Description
AddedElementsNotSamePhaseAsAssembly | Selected Element(s) cannot be added to the assembly. Elements must have the same phases as the assembly to be included in the assembly.
AssemblyDeleteTypeWarn | Edits to these assemblies changed the naming category and name of these assemblies.
AssemblyDidNotMatchRequestedTypeWarn | Assembly was changed to a new type, but did not match the type. Geometry could have been changed due to a join condition.
AssemblyDisassembleInstanceWarn | Edits to these assemblies changed the naming category and name of these assemblies.
AssemblyInheritTypeWarn | Edits to these assemblies do not match existing types, new type will be created.
AssemblyInvalidMember | Some elements became ineligible to be included in an assembly and were removed.
AssemblyNewTypeWarn | Edits to these assemblies match existing type and will inherit that name.
AssemblyRenameTypeWarn | Edits to these assemblies changed the naming category and name of these assemblies.
CouldNotAcquireAssemblyViews | The assembly instance could not acquire the assembly views.
CouldNotChangeTypeOfAssembly | Assembly cannot be changed to selected type.
DeleteAssemblyInstWithViewsWarn | Deleting this assembly will remove the assembly from the project and any views associated with that assembly.
DeleteShopDrawingsWarn | The assembly instance has associated views and cannot be merged with assembly type '%1!s!'. Delete the views to continue.\n\nViews:%2!s!
ElementsNotAllowedAreNotAddedToAssembly | Elements not allowed in Assembly were not added to it, but only in the document
IneligibleElementsInAssembly | Ineligible elements in assembly.
MixedPhasesInAssembly | Assembly cannot be created. All elements must have the same phases to be included in an assembly.
NoElementsAddedtoNewAssembly | No elements were added to the assembly. No assembly will be created.
NoElementsLeftInExistingAssembly | There are no elements left in the assembly. It will be disassembled.
NoEligibleElementsInAssembly | No eligible elements in assembly.
SomeElementsPreventAssemblyTypeChange | Assembly cannot be changed to selected type. Some elements in the target assembly prevent the type change from occurring. These tend to be parts and nested elements such as mullion, curtain panels, and members of trusses.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


AssemblyFailures Properties

The BuiltInFailuresAssemblyFailures type exposes the following members.

Properties
Name | Description
AddedElementsNotSamePhaseAsAssembly | Selected Element(s) cannot be added to the assembly. Elements must have the same phases as the assembly to be included in the assembly.
AssemblyDeleteTypeWarn | Edits to these assemblies changed the naming category and name of these assemblies.
AssemblyDidNotMatchRequestedTypeWarn | Assembly was changed to a new type, but did not match the type. Geometry could have been changed due to a join condition.
AssemblyDisassembleInstanceWarn | Edits to these assemblies changed the naming category and name of these assemblies.
AssemblyInheritTypeWarn | Edits to these assemblies do not match existing types, new type will be created.
AssemblyInvalidMember | Some elements became ineligible to be included in an assembly and were removed.
AssemblyNewTypeWarn | Edits to these assemblies match existing type and will inherit that name.
AssemblyRenameTypeWarn | Edits to these assemblies changed the naming category and name of these assemblies.
CouldNotAcquireAssemblyViews | The assembly instance could not acquire the assembly views.
CouldNotChangeTypeOfAssembly | Assembly cannot be changed to selected type.
DeleteAssemblyInstWithViewsWarn | Deleting this assembly will remove the assembly from the project and any views associated with that assembly.
DeleteShopDrawingsWarn | The assembly instance has associated views and cannot be merged with assembly type '%1!s!'. Delete the views to continue.\n\nViews:%2!s!
ElementsNotAllowedAreNotAddedToAssembly | Elements not allowed in Assembly were not added to it, but only in the document
IneligibleElementsInAssembly | Ineligible elements in assembly.
MixedPhasesInAssembly | Assembly cannot be created. All elements must have the same phases to be included in an assembly.
NoElementsAddedtoNewAssembly | No elements were added to the assembly. No assembly will be created.
NoElementsLeftInExistingAssembly | There are no elements left in the assembly. It will be disassembled.
NoEligibleElementsInAssembly | No eligible elements in assembly.
SomeElementsPreventAssemblyTypeChange | Assembly cannot be changed to selected type. Some elements in the target assembly prevent the type change from occurring. These tend to be parts and nested elements such as mullion, curtain panels, and members of trusses.
Top
See Also

Reference

BuiltInFailuresAssemblyFailures Class


BuiltInFailures.AssemblyFailures.AddedElementsNotSamePhaseAsAssembly Property

BuiltInFailuresAssemblyFailuresAddedElementsNotSamePhaseAsAssembly Property

Selected Element(s) cannot be added to the assembly. Elements must have the same phases as the assembly to be included in the assembly.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AddedElementsNotSamePhaseAsAssembly { get; }
Public Shared ReadOnly Property AddedElementsNotSamePhaseAsAssembly As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AddedElementsNotSamePhaseAsAssembly {
    FailureDefinitionId^ get ();
}
static member AddedElementsNotSamePhaseAsAssembly : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAssemblyFailures Class


BuiltInFailures.AssemblyFailures.AssemblyDeleteTypeWarn Property

BuiltInFailuresAssemblyFailuresAssemblyDeleteTypeWarn Property

Edits to these assemblies changed the naming category and name of these assemblies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AssemblyDeleteTypeWarn { get; }
Public Shared ReadOnly Property AssemblyDeleteTypeWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AssemblyDeleteTypeWarn {
    FailureDefinitionId^ get ();
}
static member AssemblyDeleteTypeWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAssemblyFailures Class


BuiltInFailures.AssemblyFailures.AssemblyDidNotMatchRequestedTypeWarn Property

BuiltInFailuresAssemblyFailuresAssemblyDidNotMatchRequestedTypeWarn Property

Assembly was changed to a new type, but did not match the type. Geometry could have been changed due to a join condition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AssemblyDidNotMatchRequestedTypeWarn { get; }
Public Shared ReadOnly Property AssemblyDidNotMatchRequestedTypeWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AssemblyDidNotMatchRequestedTypeWarn {
    FailureDefinitionId^ get ();
}
static member AssemblyDidNotMatchRequestedTypeWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAssemblyFailures Class


BuiltInFailures.AssemblyFailures.AssemblyDisassembleInstanceWarn Property

BuiltInFailuresAssemblyFailuresAssemblyDisassembleInstanceWarn Property

Edits to these assemblies changed the naming category and name of these assemblies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AssemblyDisassembleInstanceWarn { get; }
Public Shared ReadOnly Property AssemblyDisassembleInstanceWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AssemblyDisassembleInstanceWarn {
    FailureDefinitionId^ get ();
}
static member AssemblyDisassembleInstanceWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAssemblyFailures Class


BuiltInFailures.AssemblyFailures.AssemblyInheritTypeWarn Property

BuiltInFailuresAssemblyFailuresAssemblyInheritTypeWarn Property

Edits to these assemblies do not match existing types, new type will be created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AssemblyInheritTypeWarn { get; }
Public Shared ReadOnly Property AssemblyInheritTypeWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AssemblyInheritTypeWarn {
    FailureDefinitionId^ get ();
}
static member AssemblyInheritTypeWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAssemblyFailures Class


BuiltInFailures.AssemblyFailures.AssemblyInvalidMember Property

BuiltInFailuresAssemblyFailuresAssemblyInvalidMember Property

Some elements became ineligible to be included in an assembly and were removed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AssemblyInvalidMember { get; }
Public Shared ReadOnly Property AssemblyInvalidMember As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AssemblyInvalidMember {
    FailureDefinitionId^ get ();
}
static member AssemblyInvalidMember : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAssemblyFailures Class


BuiltInFailures.AssemblyFailures.AssemblyNewTypeWarn Property

BuiltInFailuresAssemblyFailuresAssemblyNewTypeWarn Property

Edits to these assemblies match existing type and will inherit that name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AssemblyNewTypeWarn { get; }
Public Shared ReadOnly Property AssemblyNewTypeWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AssemblyNewTypeWarn {
    FailureDefinitionId^ get ();
}
static member AssemblyNewTypeWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAssemblyFailures Class


BuiltInFailures.AssemblyFailures.AssemblyRenameTypeWarn Property

BuiltInFailuresAssemblyFailuresAssemblyRenameTypeWarn Property

Edits to these assemblies changed the naming category and name of these assemblies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AssemblyRenameTypeWarn { get; }
Public Shared ReadOnly Property AssemblyRenameTypeWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AssemblyRenameTypeWarn {
    FailureDefinitionId^ get ();
}
static member AssemblyRenameTypeWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAssemblyFailures Class


BuiltInFailures.AssemblyFailures.CouldNotAcquireAssemblyViews Property

BuiltInFailuresAssemblyFailuresCouldNotAcquireAssemblyViews Property

The assembly instance could not acquire the assembly views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CouldNotAcquireAssemblyViews { get; }
Public Shared ReadOnly Property CouldNotAcquireAssemblyViews As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CouldNotAcquireAssemblyViews {
    FailureDefinitionId^ get ();
}
static member CouldNotAcquireAssemblyViews : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAssemblyFailures Class


BuiltInFailures.AssemblyFailures.CouldNotChangeTypeOfAssembly Property

BuiltInFailuresAssemblyFailuresCouldNotChangeTypeOfAssembly Property

Assembly cannot be changed to selected type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CouldNotChangeTypeOfAssembly { get; }
Public Shared ReadOnly Property CouldNotChangeTypeOfAssembly As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CouldNotChangeTypeOfAssembly {
    FailureDefinitionId^ get ();
}
static member CouldNotChangeTypeOfAssembly : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAssemblyFailures Class


BuiltInFailures.AssemblyFailures.DeleteAssemblyInstWithViewsWarn Property

BuiltInFailuresAssemblyFailuresDeleteAssemblyInstWithViewsWarn Property

Deleting this assembly will remove the assembly from the project and any views associated with that assembly.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DeleteAssemblyInstWithViewsWarn { get; }
Public Shared ReadOnly Property DeleteAssemblyInstWithViewsWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DeleteAssemblyInstWithViewsWarn {
    FailureDefinitionId^ get ();
}
static member DeleteAssemblyInstWithViewsWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAssemblyFailures Class


BuiltInFailures.AssemblyFailures.DeleteShopDrawingsWarn Property

BuiltInFailuresAssemblyFailuresDeleteShopDrawingsWarn Property

The assembly instance has associated views and cannot be merged with assembly type '%1!s!'. Delete the views to continue.\n\nViews:%2!s!

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DeleteShopDrawingsWarn { get; }
Public Shared ReadOnly Property DeleteShopDrawingsWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DeleteShopDrawingsWarn {
    FailureDefinitionId^ get ();
}
static member DeleteShopDrawingsWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAssemblyFailures Class


BuiltInFailures.AssemblyFailures.ElementsNotAllowedAreNotAddedToAssembly Property

BuiltInFailuresAssemblyFailuresElementsNotAllowedAreNotAddedToAssembly Property

Elements not allowed in Assembly were not added to it, but only in the document

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ElementsNotAllowedAreNotAddedToAssembly { get; }
Public Shared ReadOnly Property ElementsNotAllowedAreNotAddedToAssembly As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ElementsNotAllowedAreNotAddedToAssembly {
    FailureDefinitionId^ get ();
}
static member ElementsNotAllowedAreNotAddedToAssembly : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAssemblyFailures Class


BuiltInFailures.AssemblyFailures.IneligibleElementsInAssembly Property

BuiltInFailuresAssemblyFailuresIneligibleElementsInAssembly Property

Ineligible elements in assembly.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId IneligibleElementsInAssembly { get; }
Public Shared ReadOnly Property IneligibleElementsInAssembly As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ IneligibleElementsInAssembly {
    FailureDefinitionId^ get ();
}
static member IneligibleElementsInAssembly : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAssemblyFailures Class


BuiltInFailures.AssemblyFailures.MixedPhasesInAssembly Property

BuiltInFailuresAssemblyFailuresMixedPhasesInAssembly Property

Assembly cannot be created. All elements must have the same phases to be included in an assembly.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MixedPhasesInAssembly { get; }
Public Shared ReadOnly Property MixedPhasesInAssembly As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MixedPhasesInAssembly {
    FailureDefinitionId^ get ();
}
static member MixedPhasesInAssembly : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAssemblyFailures Class


BuiltInFailures.AssemblyFailures.NoElementsAddedtoNewAssembly Property

BuiltInFailuresAssemblyFailuresNoElementsAddedtoNewAssembly Property

No elements were added to the assembly. No assembly will be created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoElementsAddedtoNewAssembly { get; }
Public Shared ReadOnly Property NoElementsAddedtoNewAssembly As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoElementsAddedtoNewAssembly {
    FailureDefinitionId^ get ();
}
static member NoElementsAddedtoNewAssembly : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAssemblyFailures Class


BuiltInFailures.AssemblyFailures.NoElementsLeftInExistingAssembly Property

BuiltInFailuresAssemblyFailuresNoElementsLeftInExistingAssembly Property

There are no elements left in the assembly. It will be disassembled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoElementsLeftInExistingAssembly { get; }
Public Shared ReadOnly Property NoElementsLeftInExistingAssembly As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoElementsLeftInExistingAssembly {
    FailureDefinitionId^ get ();
}
static member NoElementsLeftInExistingAssembly : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAssemblyFailures Class


BuiltInFailures.AssemblyFailures.NoEligibleElementsInAssembly Property

BuiltInFailuresAssemblyFailuresNoEligibleElementsInAssembly Property

No eligible elements in assembly.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoEligibleElementsInAssembly { get; }
Public Shared ReadOnly Property NoEligibleElementsInAssembly As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoEligibleElementsInAssembly {
    FailureDefinitionId^ get ();
}
static member NoEligibleElementsInAssembly : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAssemblyFailures Class


BuiltInFailures.AssemblyFailures.SomeElementsPreventAssemblyTypeChange Property

BuiltInFailuresAssemblyFailuresSomeElementsPreventAssemblyTypeChange Property

Assembly cannot be changed to selected type. Some elements in the target assembly prevent the type change from occurring. These tend to be parts and nested elements such as mullion, curtain panels, and members of trusses.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SomeElementsPreventAssemblyTypeChange { get; }
Public Shared ReadOnly Property SomeElementsPreventAssemblyTypeChange As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SomeElementsPreventAssemblyTypeChange {
    FailureDefinitionId^ get ();
}
static member SomeElementsPreventAssemblyTypeChange : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAssemblyFailures Class


BuiltInFailures.AutoJoinFailures Class

BuiltInFailuresAutoJoinFailures Class

Failures about AutoJoin.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresAutoJoinFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class AutoJoinFailures
Public NotInheritable Class AutoJoinFailures
public ref class AutoJoinFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type AutoJoinFailures = class end

The BuiltInFailuresAutoJoinFailures type exposes the following members.

Properties
Name | Description
DesignOptionAndWorksetViolation | Can't make the expected join because of editability and design option restrictions.
DesignOptionCannotReference | Design Option ' [Name] ' cannot reference Design Option ' [Name] '.
OtherNonEditJoinFailure | Two elements were not automatically joined because other elements at join are not editable.
UnexpectedJoinFailure | Join failure caused by editability or design option related problem.
Unknown | Unknown
WorksetJoinWarn | Two elements were not automatically joined because one or both is not editable.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


AutoJoinFailures Properties

The BuiltInFailuresAutoJoinFailures type exposes the following members.

Properties
Name | Description
DesignOptionAndWorksetViolation | Can't make the expected join because of editability and design option restrictions.
DesignOptionCannotReference | Design Option ' [Name] ' cannot reference Design Option ' [Name] '.
OtherNonEditJoinFailure | Two elements were not automatically joined because other elements at join are not editable.
UnexpectedJoinFailure | Join failure caused by editability or design option related problem.
Unknown | Unknown
WorksetJoinWarn | Two elements were not automatically joined because one or both is not editable.
Top
See Also

Reference

BuiltInFailuresAutoJoinFailures Class


BuiltInFailures.AutoJoinFailures.DesignOptionAndWorksetViolation Property

BuiltInFailuresAutoJoinFailuresDesignOptionAndWorksetViolation Property

Can't make the expected join because of editability and design option restrictions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DesignOptionAndWorksetViolation { get; }
Public Shared ReadOnly Property DesignOptionAndWorksetViolation As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DesignOptionAndWorksetViolation {
    FailureDefinitionId^ get ();
}
static member DesignOptionAndWorksetViolation : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoJoinFailures Class


BuiltInFailures.AutoJoinFailures.DesignOptionCannotReference Property

BuiltInFailuresAutoJoinFailuresDesignOptionCannotReference Property

Design Option ' [Name] ' cannot reference Design Option ' [Name] '.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DesignOptionCannotReference { get; }
Public Shared ReadOnly Property DesignOptionCannotReference As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DesignOptionCannotReference {
    FailureDefinitionId^ get ();
}
static member DesignOptionCannotReference : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoJoinFailures Class


BuiltInFailures.AutoJoinFailures.OtherNonEditJoinFailure Property

BuiltInFailuresAutoJoinFailuresOtherNonEditJoinFailure Property

Two elements were not automatically joined because other elements at join are not editable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId OtherNonEditJoinFailure { get; }
Public Shared ReadOnly Property OtherNonEditJoinFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ OtherNonEditJoinFailure {
    FailureDefinitionId^ get ();
}
static member OtherNonEditJoinFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoJoinFailures Class


BuiltInFailures.AutoJoinFailures.UnexpectedJoinFailure Property

BuiltInFailuresAutoJoinFailuresUnexpectedJoinFailure Property

Join failure caused by editability or design option related problem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnexpectedJoinFailure { get; }
Public Shared ReadOnly Property UnexpectedJoinFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnexpectedJoinFailure {
    FailureDefinitionId^ get ();
}
static member UnexpectedJoinFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoJoinFailures Class


BuiltInFailures.AutoJoinFailures.Unknown Property

BuiltInFailuresAutoJoinFailuresUnknown Property

Unknown

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId Unknown { get; }
Public Shared ReadOnly Property Unknown As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ Unknown {
    FailureDefinitionId^ get ();
}
static member Unknown : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoJoinFailures Class


BuiltInFailures.AutoJoinFailures.WorksetJoinWarn Property

BuiltInFailuresAutoJoinFailuresWorksetJoinWarn Property

Two elements were not automatically joined because one or both is not editable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WorksetJoinWarn { get; }
Public Shared ReadOnly Property WorksetJoinWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WorksetJoinWarn {
    FailureDefinitionId^ get ();
}
static member WorksetJoinWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoJoinFailures Class


BuiltInFailures.AutoRouteFailures Class

BuiltInFailuresAutoRouteFailures Class

Failures about AutoRoute.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresAutoRouteFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class AutoRouteFailures
Public NotInheritable Class AutoRouteFailures
public ref class AutoRouteFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type AutoRouteFailures = class end

The BuiltInFailuresAutoRouteFailures type exposes the following members.

Properties
Name | Description
AttemptToConnectNonSlopingElementToSlopedPipeError | You have specified that sloped pipe be drawn, but are trying to connect to an element that doesn't support sloping connections.
AttemptToConnectNonSlopingElementToSlopedPipeWarning | You have specified that sloped pipe be drawn, but are trying to connect to an element that doesn't support sloping connections.
DesignOptionConflictError | The solution is failing to do the elements are not in the same Design Option.
DesignOptionConflictWarning | The solution is failing to do the elements are not in the same Design Option.
DistributionTypeInvalid | Selected distribution system type is invalid!
ElementHasFlowCalculation | This element has an open connection. This may not be an error, but for flow calculations to work correctly all connections should be sealed with an end cap.
ElementHasOpenConnection | This element has an open connection. This may not be an error, but all open connections should be sealed with an end cap.
FailedDowngradeCrossToElbow | Failed to downgrade tee type to elbow type.
FailedDowngradeCrossToTee | Failed to downgrade cross type to tee type.
FailedDowngradeTeeToCross | Failed to upgrade tee type to cross type.
FailToDoCompatiblePhaseError | The solution is failing to do the elements Phases are compatible.
FailToDoCompatiblePhaseWarning | The solution is failing to do the elements Phases are compatible.
FailToIntersectParallelSegmentsError | The solution is failing to do segments which are parallel and should intersect.
FailToIntersectParallelSegmentsWarning | The solution is failing to do segments which are parallel and should intersect.
FittingParamsCauseGeometryToFailError | The one of parameters for the fitting is causing the geometry to fail.
FittingParamsCauseGeometryToFailWarning | The one of parameters for the fitting is causing the geometry to fail.
HighlightedElementDisconnected | The highlighted element has been disconnected.
InappropriateSlopeForPipe | The slope that you specified could not be applied to this pipe. Please check the items that it is connected to and make sure that they aren't constraining the slope of them.
MismatchedSystemClassificationHasSystemWarning | The selected fixture is part of a system with different classification. System calculations (e.g. flow analysis) are not possible between systems with different classifications.
MismatchedSystemClassificationNoSystemWarning | The selected fixture is assigned to a system with different classification.
MismatchedSystemTypeWarning | The selected fixture is part of a different system. You may want to edit the system type and merge two systems.
NoAutoRouteSolutionFoundError | No auto-route solution was found.
NoAutoRouteSolutionFoundWarning | No auto-route solution was found.
NoFittingInProjectError | The routing solution failed because there is no default fitting type specified or the fitting cannot be found in the project. Ensure the fitting is loaded in the project and try again.
NoFittingInProjectWarning | The routing solution failed because there is no default fitting type specified or the fitting cannot be found in the project. Ensure the fitting is loaded in the project and try again.
NoFittingInRoutingError | The fitting that is converted to was not defined. Please assign one in the routing preference.
NoFittingLoadedInProjectError | The fitting that is converted to was not defined. Please load one fitting family and assign it in the routing preference.
NoSolutionInView | There is no solution for this view. All the elements have been filtered for this view, select another view, and select solutions.
NotAllPartsWereConvertedCannotAddPlaceholderWarning | Not all parts were converted. Placeholders could not be added to fill the gap (the gap was too small). Check the fabrication service definition for the system.
NotAllPartsWereConvertedPlaceholdersWereAddedWarning | Not all parts were converted. Placeholders were added to fill the gaps. Check the fabrication service definition for the system.
NotEnoughRoomForFittingsError | There was not enough room to place the required fittings. Consider increasing the length of the segments, or moving them farther apart to generate a solution.
NotEnoughRoomForFittingsWarning | There was not enough room to place the required fittings. Consider increasing the length of the segments, or moving them farther apart to generate a solution.
NoValidSolutionAtSelectedPoint | No valid auto-route solution at selected point.
OverrideFabricationPartFailed | The fabrication part cannot be overridden. The button code you specified does not match the fabrication service. Please specify a different button code or check the fabrication service and try again.
SegmentDrawnFromWrongSideError | The segment is being drawn from the wrong side to connect to the location you indicated.
SegmentDrawnFromWrongSideWarning | The segment is being drawn from the wrong side to connect to the location you indicated.
SegmentsAngleTooGreatError | The resulting angle between the segments is too great.
SegmentsAngleTooGreatWarning | The resulting angle between the segments is too great.
SolutionIsOppositeToConnectionError | The solution is in the opposite direction of the connection direction.
SolutionIsOppositeToConnectionWarning | The solution is in the opposite direction of the connection direction.
SpecifiedAnglesNotCompatibleWithLayoutError | The specified angles are not compatible with current layout.
SpecifiedAnglesNotCompatibleWithLayoutWarning | The specified angles are not compatible with current layout.
UnableToMakeConnectionInDirection | The application is unable to make a connection in that direction. If the connectors are pointing up, make sure that the elevations of the segments (ducts and pipes) are above them. If the connectors are pointing down, make sure that the elevations of the segments (ducts and pipes) are below them.
UtilizationCoefficientOutOfRange | The value for Coefficient of Utilization must be between 0 and 1.
ZeroLengthSegmentError | The solution is failing to do segments which are zero length.
ZeroLengthSegmentWarning | The solution is failing to do segments which are zero length.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


AutoRouteFailures Properties

The BuiltInFailuresAutoRouteFailures type exposes the following members.

Properties
Name | Description
AttemptToConnectNonSlopingElementToSlopedPipeError | You have specified that sloped pipe be drawn, but are trying to connect to an element that doesn't support sloping connections.
AttemptToConnectNonSlopingElementToSlopedPipeWarning | You have specified that sloped pipe be drawn, but are trying to connect to an element that doesn't support sloping connections.
DesignOptionConflictError | The solution is failing to do the elements are not in the same Design Option.
DesignOptionConflictWarning | The solution is failing to do the elements are not in the same Design Option.
DistributionTypeInvalid | Selected distribution system type is invalid!
ElementHasFlowCalculation | This element has an open connection. This may not be an error, but for flow calculations to work correctly all connections should be sealed with an end cap.
ElementHasOpenConnection | This element has an open connection. This may not be an error, but all open connections should be sealed with an end cap.
FailedDowngradeCrossToElbow | Failed to downgrade tee type to elbow type.
FailedDowngradeCrossToTee | Failed to downgrade cross type to tee type.
FailedDowngradeTeeToCross | Failed to upgrade tee type to cross type.
FailToDoCompatiblePhaseError | The solution is failing to do the elements Phases are compatible.
FailToDoCompatiblePhaseWarning | The solution is failing to do the elements Phases are compatible.
FailToIntersectParallelSegmentsError | The solution is failing to do segments which are parallel and should intersect.
FailToIntersectParallelSegmentsWarning | The solution is failing to do segments which are parallel and should intersect.
FittingParamsCauseGeometryToFailError | The one of parameters for the fitting is causing the geometry to fail.
FittingParamsCauseGeometryToFailWarning | The one of parameters for the fitting is causing the geometry to fail.
HighlightedElementDisconnected | The highlighted element has been disconnected.
InappropriateSlopeForPipe | The slope that you specified could not be applied to this pipe. Please check the items that it is connected to and make sure that they aren't constraining the slope of them.
MismatchedSystemClassificationHasSystemWarning | The selected fixture is part of a system with different classification. System calculations (e.g. flow analysis) are not possible between systems with different classifications.
MismatchedSystemClassificationNoSystemWarning | The selected fixture is assigned to a system with different classification.
MismatchedSystemTypeWarning | The selected fixture is part of a different system. You may want to edit the system type and merge two systems.
NoAutoRouteSolutionFoundError | No auto-route solution was found.
NoAutoRouteSolutionFoundWarning | No auto-route solution was found.
NoFittingInProjectError | The routing solution failed because there is no default fitting type specified or the fitting cannot be found in the project. Ensure the fitting is loaded in the project and try again.
NoFittingInProjectWarning | The routing solution failed because there is no default fitting type specified or the fitting cannot be found in the project. Ensure the fitting is loaded in the project and try again.
NoFittingInRoutingError | The fitting that is converted to was not defined. Please assign one in the routing preference.
NoFittingLoadedInProjectError | The fitting that is converted to was not defined. Please load one fitting family and assign it in the routing preference.
NoSolutionInView | There is no solution for this view. All the elements have been filtered for this view, select another view, and select solutions.
NotAllPartsWereConvertedCannotAddPlaceholderWarning | Not all parts were converted. Placeholders could not be added to fill the gap (the gap was too small). Check the fabrication service definition for the system.
NotAllPartsWereConvertedPlaceholdersWereAddedWarning | Not all parts were converted. Placeholders were added to fill the gaps. Check the fabrication service definition for the system.
NotEnoughRoomForFittingsError | There was not enough room to place the required fittings. Consider increasing the length of the segments, or moving them farther apart to generate a solution.
NotEnoughRoomForFittingsWarning | There was not enough room to place the required fittings. Consider increasing the length of the segments, or moving them farther apart to generate a solution.
NoValidSolutionAtSelectedPoint | No valid auto-route solution at selected point.
OverrideFabricationPartFailed | The fabrication part cannot be overridden. The button code you specified does not match the fabrication service. Please specify a different button code or check the fabrication service and try again.
SegmentDrawnFromWrongSideError | The segment is being drawn from the wrong side to connect to the location you indicated.
SegmentDrawnFromWrongSideWarning | The segment is being drawn from the wrong side to connect to the location you indicated.
SegmentsAngleTooGreatError | The resulting angle between the segments is too great.
SegmentsAngleTooGreatWarning | The resulting angle between the segments is too great.
SolutionIsOppositeToConnectionError | The solution is in the opposite direction of the connection direction.
SolutionIsOppositeToConnectionWarning | The solution is in the opposite direction of the connection direction.
SpecifiedAnglesNotCompatibleWithLayoutError | The specified angles are not compatible with current layout.
SpecifiedAnglesNotCompatibleWithLayoutWarning | The specified angles are not compatible with current layout.
UnableToMakeConnectionInDirection | The application is unable to make a connection in that direction. If the connectors are pointing up, make sure that the elevations of the segments (ducts and pipes) are above them. If the connectors are pointing down, make sure that the elevations of the segments (ducts and pipes) are below them.
UtilizationCoefficientOutOfRange | The value for Coefficient of Utilization must be between 0 and 1.
ZeroLengthSegmentError | The solution is failing to do segments which are zero length.
ZeroLengthSegmentWarning | The solution is failing to do segments which are zero length.
Top
See Also

Reference

BuiltInFailuresAutoRouteFailures Class


BuiltInFailures.AutoRouteFailures.AttemptToConnectNonSlopingElementToSlopedPipeError Property

BuiltInFailuresAutoRouteFailuresAttemptToConnectNonSlopingElementToSlopedPipeError Property

You have specified that sloped pipe be drawn, but are trying to connect to an element that doesn't support sloping connections.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AttemptToConnectNonSlopingElementToSlopedPipeError { get; }
Public Shared ReadOnly Property AttemptToConnectNonSlopingElementToSlopedPipeError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AttemptToConnectNonSlopingElementToSlopedPipeError {
    FailureDefinitionId^ get ();
}
static member AttemptToConnectNonSlopingElementToSlopedPipeError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoRouteFailures Class


BuiltInFailures.AutoRouteFailures.AttemptToConnectNonSlopingElementToSlopedPipeWarning Property

BuiltInFailuresAutoRouteFailuresAttemptToConnectNonSlopingElementToSlopedPipeWarning Property

You have specified that sloped pipe be drawn, but are trying to connect to an element that doesn't support sloping connections.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AttemptToConnectNonSlopingElementToSlopedPipeWarning { get; }
Public Shared ReadOnly Property AttemptToConnectNonSlopingElementToSlopedPipeWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AttemptToConnectNonSlopingElementToSlopedPipeWarning {
    FailureDefinitionId^ get ();
}
static member AttemptToConnectNonSlopingElementToSlopedPipeWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoRouteFailures Class


BuiltInFailures.AutoRouteFailures.DesignOptionConflictError Property

BuiltInFailuresAutoRouteFailuresDesignOptionConflictError Property

The solution is failing to do the elements are not in the same Design Option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DesignOptionConflictError { get; }
Public Shared ReadOnly Property DesignOptionConflictError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DesignOptionConflictError {
    FailureDefinitionId^ get ();
}
static member DesignOptionConflictError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoRouteFailures Class


BuiltInFailures.AutoRouteFailures.DesignOptionConflictWarning Property

BuiltInFailuresAutoRouteFailuresDesignOptionConflictWarning Property

The solution is failing to do the elements are not in the same Design Option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DesignOptionConflictWarning { get; }
Public Shared ReadOnly Property DesignOptionConflictWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DesignOptionConflictWarning {
    FailureDefinitionId^ get ();
}
static member DesignOptionConflictWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoRouteFailures Class


BuiltInFailures.AutoRouteFailures.DistributionTypeInvalid Property

BuiltInFailuresAutoRouteFailuresDistributionTypeInvalid Property

Selected distribution system type is invalid!

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DistributionTypeInvalid { get; }
Public Shared ReadOnly Property DistributionTypeInvalid As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DistributionTypeInvalid {
    FailureDefinitionId^ get ();
}
static member DistributionTypeInvalid : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoRouteFailures Class


BuiltInFailures.AutoRouteFailures.ElementHasFlowCalculation Property

BuiltInFailuresAutoRouteFailuresElementHasFlowCalculation Property

This element has an open connection. This may not be an error, but for flow calculations to work correctly all connections should be sealed with an end cap.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ElementHasFlowCalculation { get; }
Public Shared ReadOnly Property ElementHasFlowCalculation As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ElementHasFlowCalculation {
    FailureDefinitionId^ get ();
}
static member ElementHasFlowCalculation : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoRouteFailures Class


BuiltInFailures.AutoRouteFailures.ElementHasOpenConnection Property

BuiltInFailuresAutoRouteFailuresElementHasOpenConnection Property

This element has an open connection. This may not be an error, but all open connections should be sealed with an end cap.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ElementHasOpenConnection { get; }
Public Shared ReadOnly Property ElementHasOpenConnection As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ElementHasOpenConnection {
    FailureDefinitionId^ get ();
}
static member ElementHasOpenConnection : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoRouteFailures Class


BuiltInFailures.AutoRouteFailures.FailedDowngradeCrossToElbow Property

BuiltInFailuresAutoRouteFailuresFailedDowngradeCrossToElbow Property

Failed to downgrade tee type to elbow type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FailedDowngradeCrossToElbow { get; }
Public Shared ReadOnly Property FailedDowngradeCrossToElbow As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FailedDowngradeCrossToElbow {
    FailureDefinitionId^ get ();
}
static member FailedDowngradeCrossToElbow : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoRouteFailures Class


BuiltInFailures.AutoRouteFailures.FailedDowngradeCrossToTee Property

BuiltInFailuresAutoRouteFailuresFailedDowngradeCrossToTee Property

Failed to downgrade cross type to tee type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FailedDowngradeCrossToTee { get; }
Public Shared ReadOnly Property FailedDowngradeCrossToTee As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FailedDowngradeCrossToTee {
    FailureDefinitionId^ get ();
}
static member FailedDowngradeCrossToTee : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoRouteFailures Class


BuiltInFailures.AutoRouteFailures.FailedDowngradeTeeToCross Property

BuiltInFailuresAutoRouteFailuresFailedDowngradeTeeToCross Property

Failed to upgrade tee type to cross type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FailedDowngradeTeeToCross { get; }
Public Shared ReadOnly Property FailedDowngradeTeeToCross As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FailedDowngradeTeeToCross {
    FailureDefinitionId^ get ();
}
static member FailedDowngradeTeeToCross : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoRouteFailures Class


BuiltInFailures.AutoRouteFailures.FailToDoCompatiblePhaseError Property

BuiltInFailuresAutoRouteFailuresFailToDoCompatiblePhaseError Property

The solution is failing to do the elements Phases are compatible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FailToDoCompatiblePhaseError { get; }
Public Shared ReadOnly Property FailToDoCompatiblePhaseError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FailToDoCompatiblePhaseError {
    FailureDefinitionId^ get ();
}
static member FailToDoCompatiblePhaseError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoRouteFailures Class


BuiltInFailures.AutoRouteFailures.FailToDoCompatiblePhaseWarning Property

BuiltInFailuresAutoRouteFailuresFailToDoCompatiblePhaseWarning Property

The solution is failing to do the elements Phases are compatible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FailToDoCompatiblePhaseWarning { get; }
Public Shared ReadOnly Property FailToDoCompatiblePhaseWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FailToDoCompatiblePhaseWarning {
    FailureDefinitionId^ get ();
}
static member FailToDoCompatiblePhaseWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoRouteFailures Class


BuiltInFailures.AutoRouteFailures.FailToIntersectParallelSegmentsError Property

BuiltInFailuresAutoRouteFailuresFailToIntersectParallelSegmentsError Property

The solution is failing to do segments which are parallel and should intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FailToIntersectParallelSegmentsError { get; }
Public Shared ReadOnly Property FailToIntersectParallelSegmentsError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FailToIntersectParallelSegmentsError {
    FailureDefinitionId^ get ();
}
static member FailToIntersectParallelSegmentsError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoRouteFailures Class


BuiltInFailures.AutoRouteFailures.FailToIntersectParallelSegmentsWarning Property

BuiltInFailuresAutoRouteFailuresFailToIntersectParallelSegmentsWarning Property

The solution is failing to do segments which are parallel and should intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FailToIntersectParallelSegmentsWarning { get; }
Public Shared ReadOnly Property FailToIntersectParallelSegmentsWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FailToIntersectParallelSegmentsWarning {
    FailureDefinitionId^ get ();
}
static member FailToIntersectParallelSegmentsWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoRouteFailures Class


BuiltInFailures.AutoRouteFailures.FittingParamsCauseGeometryToFailError Property

BuiltInFailuresAutoRouteFailuresFittingParamsCauseGeometryToFailError Property

The one of parameters for the fitting is causing the geometry to fail.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FittingParamsCauseGeometryToFailError { get; }
Public Shared ReadOnly Property FittingParamsCauseGeometryToFailError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FittingParamsCauseGeometryToFailError {
    FailureDefinitionId^ get ();
}
static member FittingParamsCauseGeometryToFailError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoRouteFailures Class


BuiltInFailures.AutoRouteFailures.FittingParamsCauseGeometryToFailWarning Property

BuiltInFailuresAutoRouteFailuresFittingParamsCauseGeometryToFailWarning Property

The one of parameters for the fitting is causing the geometry to fail.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FittingParamsCauseGeometryToFailWarning { get; }
Public Shared ReadOnly Property FittingParamsCauseGeometryToFailWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FittingParamsCauseGeometryToFailWarning {
    FailureDefinitionId^ get ();
}
static member FittingParamsCauseGeometryToFailWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoRouteFailures Class


BuiltInFailures.AutoRouteFailures.HighlightedElementDisconnected Property

BuiltInFailuresAutoRouteFailuresHighlightedElementDisconnected Property

The highlighted element has been disconnected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId HighlightedElementDisconnected { get; }
Public Shared ReadOnly Property HighlightedElementDisconnected As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ HighlightedElementDisconnected {
    FailureDefinitionId^ get ();
}
static member HighlightedElementDisconnected : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoRouteFailures Class


BuiltInFailures.AutoRouteFailures.InappropriateSlopeForPipe Property

BuiltInFailuresAutoRouteFailuresInappropriateSlopeForPipe Property

The slope that you specified could not be applied to this pipe. Please check the items that it is connected to and make sure that they aren't constraining the slope of them.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InappropriateSlopeForPipe { get; }
Public Shared ReadOnly Property InappropriateSlopeForPipe As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InappropriateSlopeForPipe {
    FailureDefinitionId^ get ();
}
static member InappropriateSlopeForPipe : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoRouteFailures Class


BuiltInFailures.AutoRouteFailures.MismatchedSystemClassificationHasSystemWarning Property

BuiltInFailuresAutoRouteFailuresMismatchedSystemClassificationHasSystemWarning Property

The selected fixture is part of a system with different classification. System calculations (e.g. flow analysis) are not possible between systems with different classifications.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MismatchedSystemClassificationHasSystemWarning { get; }
Public Shared ReadOnly Property MismatchedSystemClassificationHasSystemWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MismatchedSystemClassificationHasSystemWarning {
    FailureDefinitionId^ get ();
}
static member MismatchedSystemClassificationHasSystemWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoRouteFailures Class


BuiltInFailures.AutoRouteFailures.MismatchedSystemClassificationNoSystemWarning Property

BuiltInFailuresAutoRouteFailuresMismatchedSystemClassificationNoSystemWarning Property

The selected fixture is assigned to a system with different classification.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MismatchedSystemClassificationNoSystemWarning { get; }
Public Shared ReadOnly Property MismatchedSystemClassificationNoSystemWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MismatchedSystemClassificationNoSystemWarning {
    FailureDefinitionId^ get ();
}
static member MismatchedSystemClassificationNoSystemWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoRouteFailures Class


BuiltInFailures.AutoRouteFailures.MismatchedSystemTypeWarning Property

BuiltInFailuresAutoRouteFailuresMismatchedSystemTypeWarning Property

The selected fixture is part of a different system. You may want to edit the system type and merge two systems.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MismatchedSystemTypeWarning { get; }
Public Shared ReadOnly Property MismatchedSystemTypeWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MismatchedSystemTypeWarning {
    FailureDefinitionId^ get ();
}
static member MismatchedSystemTypeWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoRouteFailures Class


BuiltInFailures.AutoRouteFailures.NoAutoRouteSolutionFoundError Property

BuiltInFailuresAutoRouteFailuresNoAutoRouteSolutionFoundError Property

No auto-route solution was found.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoAutoRouteSolutionFoundError { get; }
Public Shared ReadOnly Property NoAutoRouteSolutionFoundError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoAutoRouteSolutionFoundError {
    FailureDefinitionId^ get ();
}
static member NoAutoRouteSolutionFoundError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoRouteFailures Class


BuiltInFailures.AutoRouteFailures.NoAutoRouteSolutionFoundWarning Property

BuiltInFailuresAutoRouteFailuresNoAutoRouteSolutionFoundWarning Property

No auto-route solution was found.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoAutoRouteSolutionFoundWarning { get; }
Public Shared ReadOnly Property NoAutoRouteSolutionFoundWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoAutoRouteSolutionFoundWarning {
    FailureDefinitionId^ get ();
}
static member NoAutoRouteSolutionFoundWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoRouteFailures Class


BuiltInFailures.AutoRouteFailures.NoFittingInProjectError Property

BuiltInFailuresAutoRouteFailuresNoFittingInProjectError Property

The routing solution failed because there is no default fitting type specified or the fitting cannot be found in the project. Ensure the fitting is loaded in the project and try again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoFittingInProjectError { get; }
Public Shared ReadOnly Property NoFittingInProjectError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoFittingInProjectError {
    FailureDefinitionId^ get ();
}
static member NoFittingInProjectError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoRouteFailures Class


BuiltInFailures.AutoRouteFailures.NoFittingInProjectWarning Property

BuiltInFailuresAutoRouteFailuresNoFittingInProjectWarning Property

The routing solution failed because there is no default fitting type specified or the fitting cannot be found in the project. Ensure the fitting is loaded in the project and try again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoFittingInProjectWarning { get; }
Public Shared ReadOnly Property NoFittingInProjectWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoFittingInProjectWarning {
    FailureDefinitionId^ get ();
}
static member NoFittingInProjectWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoRouteFailures Class


BuiltInFailures.AutoRouteFailures.NoFittingInRoutingError Property

BuiltInFailuresAutoRouteFailuresNoFittingInRoutingError Property

The fitting that is converted to was not defined. Please assign one in the routing preference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoFittingInRoutingError { get; }
Public Shared ReadOnly Property NoFittingInRoutingError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoFittingInRoutingError {
    FailureDefinitionId^ get ();
}
static member NoFittingInRoutingError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoRouteFailures Class


BuiltInFailures.AutoRouteFailures.NoFittingLoadedInProjectError Property

BuiltInFailuresAutoRouteFailuresNoFittingLoadedInProjectError Property

The fitting that is converted to was not defined. Please load one fitting family and assign it in the routing preference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoFittingLoadedInProjectError { get; }
Public Shared ReadOnly Property NoFittingLoadedInProjectError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoFittingLoadedInProjectError {
    FailureDefinitionId^ get ();
}
static member NoFittingLoadedInProjectError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoRouteFailures Class


BuiltInFailures.AutoRouteFailures.NoSolutionInView Property

BuiltInFailuresAutoRouteFailuresNoSolutionInView Property

There is no solution for this view. All the elements have been filtered for this view, select another view, and select solutions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoSolutionInView { get; }
Public Shared ReadOnly Property NoSolutionInView As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoSolutionInView {
    FailureDefinitionId^ get ();
}
static member NoSolutionInView : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoRouteFailures Class


BuiltInFailures.AutoRouteFailures.NotAllPartsWereConvertedCannotAddPlaceholderWarning Property

BuiltInFailuresAutoRouteFailuresNotAllPartsWereConvertedCannotAddPlaceholderWarning Property

Not all parts were converted. Placeholders could not be added to fill the gap (the gap was too small). Check the fabrication service definition for the system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotAllPartsWereConvertedCannotAddPlaceholderWarning { get; }
Public Shared ReadOnly Property NotAllPartsWereConvertedCannotAddPlaceholderWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotAllPartsWereConvertedCannotAddPlaceholderWarning {
    FailureDefinitionId^ get ();
}
static member NotAllPartsWereConvertedCannotAddPlaceholderWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoRouteFailures Class


BuiltInFailures.AutoRouteFailures.NotAllPartsWereConvertedPlaceholdersWereAddedWarning Property

BuiltInFailuresAutoRouteFailuresNotAllPartsWereConvertedPlaceholdersWereAddedWarning Property

Not all parts were converted. Placeholders were added to fill the gaps. Check the fabrication service definition for the system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotAllPartsWereConvertedPlaceholdersWereAddedWarning { get; }
Public Shared ReadOnly Property NotAllPartsWereConvertedPlaceholdersWereAddedWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotAllPartsWereConvertedPlaceholdersWereAddedWarning {
    FailureDefinitionId^ get ();
}
static member NotAllPartsWereConvertedPlaceholdersWereAddedWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoRouteFailures Class


BuiltInFailures.AutoRouteFailures.NotEnoughRoomForFittingsError Property

BuiltInFailuresAutoRouteFailuresNotEnoughRoomForFittingsError Property

There was not enough room to place the required fittings. Consider increasing the length of the segments, or moving them farther apart to generate a solution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotEnoughRoomForFittingsError { get; }
Public Shared ReadOnly Property NotEnoughRoomForFittingsError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotEnoughRoomForFittingsError {
    FailureDefinitionId^ get ();
}
static member NotEnoughRoomForFittingsError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoRouteFailures Class


BuiltInFailures.AutoRouteFailures.NotEnoughRoomForFittingsWarning Property

BuiltInFailuresAutoRouteFailuresNotEnoughRoomForFittingsWarning Property

There was not enough room to place the required fittings. Consider increasing the length of the segments, or moving them farther apart to generate a solution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotEnoughRoomForFittingsWarning { get; }
Public Shared ReadOnly Property NotEnoughRoomForFittingsWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotEnoughRoomForFittingsWarning {
    FailureDefinitionId^ get ();
}
static member NotEnoughRoomForFittingsWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoRouteFailures Class


BuiltInFailures.AutoRouteFailures.NoValidSolutionAtSelectedPoint Property

BuiltInFailuresAutoRouteFailuresNoValidSolutionAtSelectedPoint Property

No valid auto-route solution at selected point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoValidSolutionAtSelectedPoint { get; }
Public Shared ReadOnly Property NoValidSolutionAtSelectedPoint As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoValidSolutionAtSelectedPoint {
    FailureDefinitionId^ get ();
}
static member NoValidSolutionAtSelectedPoint : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoRouteFailures Class


BuiltInFailures.AutoRouteFailures.OverrideFabricationPartFailed Property

BuiltInFailuresAutoRouteFailuresOverrideFabricationPartFailed Property

The fabrication part cannot be overridden. The button code you specified does not match the fabrication service. Please specify a different button code or check the fabrication service and try again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId OverrideFabricationPartFailed { get; }
Public Shared ReadOnly Property OverrideFabricationPartFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ OverrideFabricationPartFailed {
    FailureDefinitionId^ get ();
}
static member OverrideFabricationPartFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoRouteFailures Class


BuiltInFailures.AutoRouteFailures.SegmentDrawnFromWrongSideError Property

BuiltInFailuresAutoRouteFailuresSegmentDrawnFromWrongSideError Property

The segment is being drawn from the wrong side to connect to the location you indicated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SegmentDrawnFromWrongSideError { get; }
Public Shared ReadOnly Property SegmentDrawnFromWrongSideError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SegmentDrawnFromWrongSideError {
    FailureDefinitionId^ get ();
}
static member SegmentDrawnFromWrongSideError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoRouteFailures Class


BuiltInFailures.AutoRouteFailures.SegmentDrawnFromWrongSideWarning Property

BuiltInFailuresAutoRouteFailuresSegmentDrawnFromWrongSideWarning Property

The segment is being drawn from the wrong side to connect to the location you indicated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SegmentDrawnFromWrongSideWarning { get; }
Public Shared ReadOnly Property SegmentDrawnFromWrongSideWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SegmentDrawnFromWrongSideWarning {
    FailureDefinitionId^ get ();
}
static member SegmentDrawnFromWrongSideWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoRouteFailures Class


BuiltInFailures.AutoRouteFailures.SegmentsAngleTooGreatError Property

BuiltInFailuresAutoRouteFailuresSegmentsAngleTooGreatError Property

The resulting angle between the segments is too great.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SegmentsAngleTooGreatError { get; }
Public Shared ReadOnly Property SegmentsAngleTooGreatError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SegmentsAngleTooGreatError {
    FailureDefinitionId^ get ();
}
static member SegmentsAngleTooGreatError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoRouteFailures Class


BuiltInFailures.AutoRouteFailures.SegmentsAngleTooGreatWarning Property

BuiltInFailuresAutoRouteFailuresSegmentsAngleTooGreatWarning Property

The resulting angle between the segments is too great.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SegmentsAngleTooGreatWarning { get; }
Public Shared ReadOnly Property SegmentsAngleTooGreatWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SegmentsAngleTooGreatWarning {
    FailureDefinitionId^ get ();
}
static member SegmentsAngleTooGreatWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoRouteFailures Class


BuiltInFailures.AutoRouteFailures.SolutionIsOppositeToConnectionError Property

BuiltInFailuresAutoRouteFailuresSolutionIsOppositeToConnectionError Property

The solution is in the opposite direction of the connection direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SolutionIsOppositeToConnectionError { get; }
Public Shared ReadOnly Property SolutionIsOppositeToConnectionError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SolutionIsOppositeToConnectionError {
    FailureDefinitionId^ get ();
}
static member SolutionIsOppositeToConnectionError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoRouteFailures Class


BuiltInFailures.AutoRouteFailures.SolutionIsOppositeToConnectionWarning Property

BuiltInFailuresAutoRouteFailuresSolutionIsOppositeToConnectionWarning Property

The solution is in the opposite direction of the connection direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SolutionIsOppositeToConnectionWarning { get; }
Public Shared ReadOnly Property SolutionIsOppositeToConnectionWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SolutionIsOppositeToConnectionWarning {
    FailureDefinitionId^ get ();
}
static member SolutionIsOppositeToConnectionWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoRouteFailures Class


BuiltInFailures.AutoRouteFailures.SpecifiedAnglesNotCompatibleWithLayoutError Property

BuiltInFailuresAutoRouteFailuresSpecifiedAnglesNotCompatibleWithLayoutError Property

The specified angles are not compatible with current layout.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SpecifiedAnglesNotCompatibleWithLayoutError { get; }
Public Shared ReadOnly Property SpecifiedAnglesNotCompatibleWithLayoutError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SpecifiedAnglesNotCompatibleWithLayoutError {
    FailureDefinitionId^ get ();
}
static member SpecifiedAnglesNotCompatibleWithLayoutError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoRouteFailures Class


BuiltInFailures.AutoRouteFailures.SpecifiedAnglesNotCompatibleWithLayoutWarning Property

BuiltInFailuresAutoRouteFailuresSpecifiedAnglesNotCompatibleWithLayoutWarning Property

The specified angles are not compatible with current layout.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SpecifiedAnglesNotCompatibleWithLayoutWarning { get; }
Public Shared ReadOnly Property SpecifiedAnglesNotCompatibleWithLayoutWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SpecifiedAnglesNotCompatibleWithLayoutWarning {
    FailureDefinitionId^ get ();
}
static member SpecifiedAnglesNotCompatibleWithLayoutWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoRouteFailures Class


BuiltInFailures.AutoRouteFailures.UnableToMakeConnectionInDirection Property

BuiltInFailuresAutoRouteFailuresUnableToMakeConnectionInDirection Property

The application is unable to make a connection in that direction. If the connectors are pointing up, make sure that the elevations of the segments (ducts and pipes) are above them. If the connectors are pointing down, make sure that the elevations of the segments (ducts and pipes) are below them.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnableToMakeConnectionInDirection { get; }
Public Shared ReadOnly Property UnableToMakeConnectionInDirection As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnableToMakeConnectionInDirection {
    FailureDefinitionId^ get ();
}
static member UnableToMakeConnectionInDirection : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoRouteFailures Class


BuiltInFailures.AutoRouteFailures.UtilizationCoefficientOutOfRange Property

BuiltInFailuresAutoRouteFailuresUtilizationCoefficientOutOfRange Property

The value for Coefficient of Utilization must be between 0 and 1.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UtilizationCoefficientOutOfRange { get; }
Public Shared ReadOnly Property UtilizationCoefficientOutOfRange As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UtilizationCoefficientOutOfRange {
    FailureDefinitionId^ get ();
}
static member UtilizationCoefficientOutOfRange : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoRouteFailures Class


BuiltInFailures.AutoRouteFailures.ZeroLengthSegmentError Property

BuiltInFailuresAutoRouteFailuresZeroLengthSegmentError Property

The solution is failing to do segments which are zero length.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ZeroLengthSegmentError { get; }
Public Shared ReadOnly Property ZeroLengthSegmentError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ZeroLengthSegmentError {
    FailureDefinitionId^ get ();
}
static member ZeroLengthSegmentError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoRouteFailures Class


BuiltInFailures.AutoRouteFailures.ZeroLengthSegmentWarning Property

BuiltInFailuresAutoRouteFailuresZeroLengthSegmentWarning Property

The solution is failing to do segments which are zero length.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ZeroLengthSegmentWarning { get; }
Public Shared ReadOnly Property ZeroLengthSegmentWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ZeroLengthSegmentWarning {
    FailureDefinitionId^ get ();
}
static member ZeroLengthSegmentWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresAutoRouteFailures Class


BuiltInFailures.BeamFailures Class

BuiltInFailuresBeamFailures Class

Failures about Beams.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresBeamFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class BeamFailures
Public NotInheritable Class BeamFailures
public ref class BeamFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type BeamFailures = class end

The BuiltInFailuresBeamFailures type exposes the following members.

Properties
Name | Description
CannotBendBeamType | Can't bend beam type "[Type Name]" along its location line. The beam is either too large or its curve is too sharp. You may be able to resolve the problem by reducing the beam's width in the bending direction, or by reducing acute angles in the curve.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


BeamFailures Properties

The BuiltInFailuresBeamFailures type exposes the following members.

Properties
Name | Description
CannotBendBeamType | Can't bend beam type "[Type Name]" along its location line. The beam is either too large or its curve is too sharp. You may be able to resolve the problem by reducing the beam's width in the bending direction, or by reducing acute angles in the curve.
Top
See Also

Reference

BuiltInFailuresBeamFailures Class


BuiltInFailures.BeamFailures.CannotBendBeamType Property

BuiltInFailuresBeamFailuresCannotBendBeamType Property

Can't bend beam type "[Type Name]" along its location line. The beam is either too large or its curve is too sharp. You may be able to resolve the problem by reducing the beam's width in the bending direction, or by reducing acute angles in the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotBendBeamType { get; }
Public Shared ReadOnly Property CannotBendBeamType As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotBendBeamType {
    FailureDefinitionId^ get ();
}
static member CannotBendBeamType : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresBeamFailures Class


BuiltInFailures.BeamSystemFailures Class

BuiltInFailuresBeamSystemFailures Class

Failures about BeamSystem.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresBeamSystemFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class BeamSystemFailures
Public NotInheritable Class BeamSystemFailures
public ref class BeamSystemFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type BeamSystemFailures = class end

The BuiltInFailuresBeamSystemFailures type exposes the following members.

Properties
Name | Description
BeamSystemEdgeBeamTooWide | Beam of user-defined type does not fit into beam system with clear spacing layout rule. Beam type is reset to default.
BeamSystemHasTooManyBeams | A beam system is trying to create more than 500 beams. Please use multiple beam systems if more than 500 beams are desired.
BeamSystemTagBadView | Beam System Tags can only be placed in plan , elevation and 3D views.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


BeamSystemFailures Properties

The BuiltInFailuresBeamSystemFailures type exposes the following members.

Properties
Name | Description
BeamSystemEdgeBeamTooWide | Beam of user-defined type does not fit into beam system with clear spacing layout rule. Beam type is reset to default.
BeamSystemHasTooManyBeams | A beam system is trying to create more than 500 beams. Please use multiple beam systems if more than 500 beams are desired.
BeamSystemTagBadView | Beam System Tags can only be placed in plan , elevation and 3D views.
Top
See Also

Reference

BuiltInFailuresBeamSystemFailures Class


BuiltInFailures.BeamSystemFailures.BeamSystemEdgeBeamTooWide Property

BuiltInFailuresBeamSystemFailuresBeamSystemEdgeBeamTooWide Property

Beam of user-defined type does not fit into beam system with clear spacing layout rule. Beam type is reset to default.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BeamSystemEdgeBeamTooWide { get; }
Public Shared ReadOnly Property BeamSystemEdgeBeamTooWide As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BeamSystemEdgeBeamTooWide {
    FailureDefinitionId^ get ();
}
static member BeamSystemEdgeBeamTooWide : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresBeamSystemFailures Class


BuiltInFailures.BeamSystemFailures.BeamSystemHasTooManyBeams Property

BuiltInFailuresBeamSystemFailuresBeamSystemHasTooManyBeams Property

A beam system is trying to create more than 500 beams. Please use multiple beam systems if more than 500 beams are desired.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BeamSystemHasTooManyBeams { get; }
Public Shared ReadOnly Property BeamSystemHasTooManyBeams As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BeamSystemHasTooManyBeams {
    FailureDefinitionId^ get ();
}
static member BeamSystemHasTooManyBeams : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresBeamSystemFailures Class


BuiltInFailures.BeamSystemFailures.BeamSystemTagBadView Property

BuiltInFailuresBeamSystemFailuresBeamSystemTagBadView Property

Beam System Tags can only be placed in plan , elevation and 3D views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BeamSystemTagBadView { get; }
Public Shared ReadOnly Property BeamSystemTagBadView As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BeamSystemTagBadView {
    FailureDefinitionId^ get ();
}
static member BeamSystemTagBadView : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresBeamSystemFailures Class


BuiltInFailures.BendFailures Class

BuiltInFailuresBendFailures Class

Failures about Bends.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresBendFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class BendFailures
Public NotInheritable Class BendFailures
public ref class BendFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type BendFailures = class end

The BuiltInFailuresBendFailures type exposes the following members.

Properties
Name | Description
BendAngleIsUnacceptable | The angle of the bend/elbow is unacceptable
DeleteMiddleBendNotAllowed | Delete a middle bend in a bank is not allowed
DeleteSegmentInBankNotAllowed | Delete a segment in a bank is not allowed
NotBentControl | While making curved beam type "[Type Name]" some Control elements were not created
NotBentDetailComponent | While making curved beam type "[Type Name]" 2D Detail Component elements were not created
NotBentFilledRegion | While making curved beam type "[Type Name]" Filled Region elements were not created
NotBentImage | While making curved beam type "[Type Name]" Image elements were not created
NotBentImport | While making curved beam type "[Type Name]" CAD File elements were not created
NotBentMaskingRegion | While making curved beam type "[Type Name]" Masking Region elements were not created
NotBentModelLine | While making curved beam type "[Type Name]" some Model Line elements were not created
NotBentOpening | While making curved beam type "[Type Name]" Opening elements were not created
NotBentRefLine | While making curved beam type "[Type Name]" some Reference Line elements were not created
NotBentRefPlane | While making curved beam type "[Type Name]" some Reference Plane elements were not created
NotBentSharedFamily | While making curved beam type "[Type Name]" Shared Family Instances were not created
NotBentSymbol | While making curved beam type "[Type Name]" Symbol elements were not created
NotBentSymbolicLine | While making curved beam type "[Type Name]" some Symbolic Line elements were not created
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


BendFailures Properties

The BuiltInFailuresBendFailures type exposes the following members.

Properties
Name | Description
BendAngleIsUnacceptable | The angle of the bend/elbow is unacceptable
DeleteMiddleBendNotAllowed | Delete a middle bend in a bank is not allowed
DeleteSegmentInBankNotAllowed | Delete a segment in a bank is not allowed
NotBentControl | While making curved beam type "[Type Name]" some Control elements were not created
NotBentDetailComponent | While making curved beam type "[Type Name]" 2D Detail Component elements were not created
NotBentFilledRegion | While making curved beam type "[Type Name]" Filled Region elements were not created
NotBentImage | While making curved beam type "[Type Name]" Image elements were not created
NotBentImport | While making curved beam type "[Type Name]" CAD File elements were not created
NotBentMaskingRegion | While making curved beam type "[Type Name]" Masking Region elements were not created
NotBentModelLine | While making curved beam type "[Type Name]" some Model Line elements were not created
NotBentOpening | While making curved beam type "[Type Name]" Opening elements were not created
NotBentRefLine | While making curved beam type "[Type Name]" some Reference Line elements were not created
NotBentRefPlane | While making curved beam type "[Type Name]" some Reference Plane elements were not created
NotBentSharedFamily | While making curved beam type "[Type Name]" Shared Family Instances were not created
NotBentSymbol | While making curved beam type "[Type Name]" Symbol elements were not created
NotBentSymbolicLine | While making curved beam type "[Type Name]" some Symbolic Line elements were not created
Top
See Also

Reference

BuiltInFailuresBendFailures Class


BuiltInFailures.BendFailures.BendAngleIsUnacceptable Property

BuiltInFailuresBendFailuresBendAngleIsUnacceptable Property

The angle of the bend/elbow is unacceptable

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BendAngleIsUnacceptable { get; }
Public Shared ReadOnly Property BendAngleIsUnacceptable As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BendAngleIsUnacceptable {
    FailureDefinitionId^ get ();
}
static member BendAngleIsUnacceptable : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresBendFailures Class


BuiltInFailures.BendFailures.DeleteMiddleBendNotAllowed Property

BuiltInFailuresBendFailuresDeleteMiddleBendNotAllowed Property

Delete a middle bend in a bank is not allowed

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DeleteMiddleBendNotAllowed { get; }
Public Shared ReadOnly Property DeleteMiddleBendNotAllowed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DeleteMiddleBendNotAllowed {
    FailureDefinitionId^ get ();
}
static member DeleteMiddleBendNotAllowed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresBendFailures Class


BuiltInFailures.BendFailures.DeleteSegmentInBankNotAllowed Property

BuiltInFailuresBendFailuresDeleteSegmentInBankNotAllowed Property

Delete a segment in a bank is not allowed

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DeleteSegmentInBankNotAllowed { get; }
Public Shared ReadOnly Property DeleteSegmentInBankNotAllowed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DeleteSegmentInBankNotAllowed {
    FailureDefinitionId^ get ();
}
static member DeleteSegmentInBankNotAllowed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresBendFailures Class


BuiltInFailures.BendFailures.NotBentControl Property

BuiltInFailuresBendFailuresNotBentControl Property

While making curved beam type "[Type Name]" some Control elements were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotBentControl { get; }
Public Shared ReadOnly Property NotBentControl As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotBentControl {
    FailureDefinitionId^ get ();
}
static member NotBentControl : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresBendFailures Class


BuiltInFailures.BendFailures.NotBentDetailComponent Property

BuiltInFailuresBendFailuresNotBentDetailComponent Property

While making curved beam type "[Type Name]" 2D Detail Component elements were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotBentDetailComponent { get; }
Public Shared ReadOnly Property NotBentDetailComponent As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotBentDetailComponent {
    FailureDefinitionId^ get ();
}
static member NotBentDetailComponent : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresBendFailures Class


BuiltInFailures.BendFailures.NotBentFilledRegion Property

BuiltInFailuresBendFailuresNotBentFilledRegion Property

While making curved beam type "[Type Name]" Filled Region elements were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotBentFilledRegion { get; }
Public Shared ReadOnly Property NotBentFilledRegion As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotBentFilledRegion {
    FailureDefinitionId^ get ();
}
static member NotBentFilledRegion : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresBendFailures Class


BuiltInFailures.BendFailures.NotBentImage Property

BuiltInFailuresBendFailuresNotBentImage Property

While making curved beam type "[Type Name]" Image elements were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotBentImage { get; }
Public Shared ReadOnly Property NotBentImage As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotBentImage {
    FailureDefinitionId^ get ();
}
static member NotBentImage : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresBendFailures Class


BuiltInFailures.BendFailures.NotBentImport Property

BuiltInFailuresBendFailuresNotBentImport Property

While making curved beam type "[Type Name]" CAD File elements were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotBentImport { get; }
Public Shared ReadOnly Property NotBentImport As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotBentImport {
    FailureDefinitionId^ get ();
}
static member NotBentImport : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresBendFailures Class


BuiltInFailures.BendFailures.NotBentMaskingRegion Property

BuiltInFailuresBendFailuresNotBentMaskingRegion Property

While making curved beam type "[Type Name]" Masking Region elements were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotBentMaskingRegion { get; }
Public Shared ReadOnly Property NotBentMaskingRegion As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotBentMaskingRegion {
    FailureDefinitionId^ get ();
}
static member NotBentMaskingRegion : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresBendFailures Class


BuiltInFailures.BendFailures.NotBentModelLine Property

BuiltInFailuresBendFailuresNotBentModelLine Property

While making curved beam type "[Type Name]" some Model Line elements were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotBentModelLine { get; }
Public Shared ReadOnly Property NotBentModelLine As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotBentModelLine {
    FailureDefinitionId^ get ();
}
static member NotBentModelLine : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresBendFailures Class


BuiltInFailures.BendFailures.NotBentOpening Property

BuiltInFailuresBendFailuresNotBentOpening Property

While making curved beam type "[Type Name]" Opening elements were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotBentOpening { get; }
Public Shared ReadOnly Property NotBentOpening As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotBentOpening {
    FailureDefinitionId^ get ();
}
static member NotBentOpening : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresBendFailures Class


BuiltInFailures.BendFailures.NotBentRefLine Property

BuiltInFailuresBendFailuresNotBentRefLine Property

While making curved beam type "[Type Name]" some Reference Line elements were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotBentRefLine { get; }
Public Shared ReadOnly Property NotBentRefLine As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotBentRefLine {
    FailureDefinitionId^ get ();
}
static member NotBentRefLine : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresBendFailures Class


BuiltInFailures.BendFailures.NotBentRefPlane Property

BuiltInFailuresBendFailuresNotBentRefPlane Property

While making curved beam type "[Type Name]" some Reference Plane elements were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotBentRefPlane { get; }
Public Shared ReadOnly Property NotBentRefPlane As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotBentRefPlane {
    FailureDefinitionId^ get ();
}
static member NotBentRefPlane : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresBendFailures Class


BuiltInFailures.BendFailures.NotBentSharedFamily Property

BuiltInFailuresBendFailuresNotBentSharedFamily Property

While making curved beam type "[Type Name]" Shared Family Instances were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotBentSharedFamily { get; }
Public Shared ReadOnly Property NotBentSharedFamily As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotBentSharedFamily {
    FailureDefinitionId^ get ();
}
static member NotBentSharedFamily : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresBendFailures Class


BuiltInFailures.BendFailures.NotBentSymbol Property

BuiltInFailuresBendFailuresNotBentSymbol Property

While making curved beam type "[Type Name]" Symbol elements were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotBentSymbol { get; }
Public Shared ReadOnly Property NotBentSymbol As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotBentSymbol {
    FailureDefinitionId^ get ();
}
static member NotBentSymbol : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresBendFailures Class


BuiltInFailures.BendFailures.NotBentSymbolicLine Property

BuiltInFailuresBendFailuresNotBentSymbolicLine Property

While making curved beam type "[Type Name]" some Symbolic Line elements were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotBentSymbolicLine { get; }
Public Shared ReadOnly Property NotBentSymbolicLine As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotBentSymbolicLine {
    FailureDefinitionId^ get ();
}
static member NotBentSymbolicLine : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresBendFailures Class


BuiltInFailures.BlendFailures Class

BuiltInFailuresBlendFailures Class

Failures about Blend.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresBlendFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class BlendFailures
Public NotInheritable Class BlendFailures
public ref class BlendFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type BlendFailures = class end

The BuiltInFailuresBlendFailures type exposes the following members.

Properties
Name | Description
CannotDrawBlend | Can't create blend.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


BlendFailures Properties

The BuiltInFailuresBlendFailures type exposes the following members.

Properties
Name | Description
CannotDrawBlend | Can't create blend.
Top
See Also

Reference

BuiltInFailuresBlendFailures Class


BuiltInFailures.BlendFailures.CannotDrawBlend Property

BuiltInFailuresBlendFailuresCannotDrawBlend Property

Can't create blend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotDrawBlend { get; }
Public Shared ReadOnly Property CannotDrawBlend As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotDrawBlend {
    FailureDefinitionId^ get ();
}
static member CannotDrawBlend : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresBlendFailures Class


BuiltInFailures.ColorFillFailures Class

BuiltInFailuresColorFillFailures Class

Failures about ColorFill.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresColorFillFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ColorFillFailures
Public NotInheritable Class ColorFillFailures
public ref class ColorFillFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ColorFillFailures = class end

The BuiltInFailuresColorFillFailures type exposes the following members.

Properties
Name | Description
OnlyOneColorFillNonPlan | A Color Fill Legend can only be placed in a Floor Plan View or a Section View.
SymtemColorFillLegendNotAllowed | [Category name] Color Fill Legend can only be placed in a Floor Plan View.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ColorFillFailures Properties

The BuiltInFailuresColorFillFailures type exposes the following members.

Properties
Name | Description
OnlyOneColorFillNonPlan | A Color Fill Legend can only be placed in a Floor Plan View or a Section View.
SymtemColorFillLegendNotAllowed | [Category name] Color Fill Legend can only be placed in a Floor Plan View.
Top
See Also

Reference

BuiltInFailuresColorFillFailures Class


BuiltInFailures.ColorFillFailures.OnlyOneColorFillNonPlan Property

BuiltInFailuresColorFillFailuresOnlyOneColorFillNonPlan Property

A Color Fill Legend can only be placed in a Floor Plan View or a Section View.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId OnlyOneColorFillNonPlan { get; }
Public Shared ReadOnly Property OnlyOneColorFillNonPlan As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ OnlyOneColorFillNonPlan {
    FailureDefinitionId^ get ();
}
static member OnlyOneColorFillNonPlan : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresColorFillFailures Class


BuiltInFailures.ColorFillFailures.SymtemColorFillLegendNotAllowed Property

BuiltInFailuresColorFillFailuresSymtemColorFillLegendNotAllowed Property

[Category name] Color Fill Legend can only be placed in a Floor Plan View.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SymtemColorFillLegendNotAllowed { get; }
Public Shared ReadOnly Property SymtemColorFillLegendNotAllowed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SymtemColorFillLegendNotAllowed {
    FailureDefinitionId^ get ();
}
static member SymtemColorFillLegendNotAllowed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresColorFillFailures Class


BuiltInFailures.ColumnFailures Class

BuiltInFailuresColumnFailures Class

Failures about Columns.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresColumnFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ColumnFailures
Public NotInheritable Class ColumnFailures
public ref class ColumnFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ColumnFailures = class end

The BuiltInFailuresColumnFailures type exposes the following members.

Properties
Name | Description
ColumnAndTargetAreConcrete | Column and target are both concrete. Geometries have been joined.
ColumnBaseAboveTopError | The column base can't be moved above its top.
ColumnBaseAboveTopFailure | The column base can't be moved above its top.
ColumnJoinNonhitFailure | The highlighted column can't maintain attachment to the target. It will be treated as unattached until it can intersect.
ColumnTopBelowBaseError | The column top can't be moved below its base.
ColumnTopBelowBaseFailure | The column top can't be moved below its base.
ColumnZeroHeightError | The column can't have zero height
ColumnZeroHeightFailure | The column can't have zero height
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ColumnFailures Properties

The BuiltInFailuresColumnFailures type exposes the following members.

Properties
Name | Description
ColumnAndTargetAreConcrete | Column and target are both concrete. Geometries have been joined.
ColumnBaseAboveTopError | The column base can't be moved above its top.
ColumnBaseAboveTopFailure | The column base can't be moved above its top.
ColumnJoinNonhitFailure | The highlighted column can't maintain attachment to the target. It will be treated as unattached until it can intersect.
ColumnTopBelowBaseError | The column top can't be moved below its base.
ColumnTopBelowBaseFailure | The column top can't be moved below its base.
ColumnZeroHeightError | The column can't have zero height
ColumnZeroHeightFailure | The column can't have zero height
Top
See Also

Reference

BuiltInFailuresColumnFailures Class


BuiltInFailures.ColumnFailures.ColumnAndTargetAreConcrete Property

BuiltInFailuresColumnFailuresColumnAndTargetAreConcrete Property

Column and target are both concrete. Geometries have been joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ColumnAndTargetAreConcrete { get; }
Public Shared ReadOnly Property ColumnAndTargetAreConcrete As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ColumnAndTargetAreConcrete {
    FailureDefinitionId^ get ();
}
static member ColumnAndTargetAreConcrete : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresColumnFailures Class


BuiltInFailures.ColumnFailures.ColumnBaseAboveTopError Property

BuiltInFailuresColumnFailuresColumnBaseAboveTopError Property

The column base can't be moved above its top.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ColumnBaseAboveTopError { get; }
Public Shared ReadOnly Property ColumnBaseAboveTopError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ColumnBaseAboveTopError {
    FailureDefinitionId^ get ();
}
static member ColumnBaseAboveTopError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresColumnFailures Class


BuiltInFailures.ColumnFailures.ColumnBaseAboveTopFailure Property

BuiltInFailuresColumnFailuresColumnBaseAboveTopFailure Property

The column base can't be moved above its top.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ColumnBaseAboveTopFailure { get; }
Public Shared ReadOnly Property ColumnBaseAboveTopFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ColumnBaseAboveTopFailure {
    FailureDefinitionId^ get ();
}
static member ColumnBaseAboveTopFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresColumnFailures Class


BuiltInFailures.ColumnFailures.ColumnJoinNonhitFailure Property

BuiltInFailuresColumnFailuresColumnJoinNonhitFailure Property

The highlighted column can't maintain attachment to the target. It will be treated as unattached until it can intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ColumnJoinNonhitFailure { get; }
Public Shared ReadOnly Property ColumnJoinNonhitFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ColumnJoinNonhitFailure {
    FailureDefinitionId^ get ();
}
static member ColumnJoinNonhitFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresColumnFailures Class


BuiltInFailures.ColumnFailures.ColumnTopBelowBaseError Property

BuiltInFailuresColumnFailuresColumnTopBelowBaseError Property

The column top can't be moved below its base.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ColumnTopBelowBaseError { get; }
Public Shared ReadOnly Property ColumnTopBelowBaseError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ColumnTopBelowBaseError {
    FailureDefinitionId^ get ();
}
static member ColumnTopBelowBaseError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresColumnFailures Class


BuiltInFailures.ColumnFailures.ColumnTopBelowBaseFailure Property

BuiltInFailuresColumnFailuresColumnTopBelowBaseFailure Property

The column top can't be moved below its base.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ColumnTopBelowBaseFailure { get; }
Public Shared ReadOnly Property ColumnTopBelowBaseFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ColumnTopBelowBaseFailure {
    FailureDefinitionId^ get ();
}
static member ColumnTopBelowBaseFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresColumnFailures Class


BuiltInFailures.ColumnFailures.ColumnZeroHeightError Property

BuiltInFailuresColumnFailuresColumnZeroHeightError Property

The column can't have zero height

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ColumnZeroHeightError { get; }
Public Shared ReadOnly Property ColumnZeroHeightError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ColumnZeroHeightError {
    FailureDefinitionId^ get ();
}
static member ColumnZeroHeightError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresColumnFailures Class


BuiltInFailures.ColumnFailures.ColumnZeroHeightFailure Property

BuiltInFailuresColumnFailuresColumnZeroHeightFailure Property

The column can't have zero height

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ColumnZeroHeightFailure { get; }
Public Shared ReadOnly Property ColumnZeroHeightFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ColumnZeroHeightFailure {
    FailureDefinitionId^ get ();
}
static member ColumnZeroHeightFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresColumnFailures Class


BuiltInFailures.ColumnInsideWallFailures Class

BuiltInFailuresColumnInsideWallFailures Class

Failures description ColumnInsideWall
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresColumnInsideWallFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ColumnInsideWallFailures
Public NotInheritable Class ColumnInsideWallFailures
public ref class ColumnInsideWallFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ColumnInsideWallFailures = class end

The BuiltInFailuresColumnInsideWallFailures type exposes the following members.

Properties
Name | Description
ColumnInsideWall | One element is completely inside another.
CopingWarningExtension | Coping applied, but no cut was made. Adjust Coping Distance or Extension parameters.
CopingWarningIgnored | Cuts on concrete members are ignored.
CopingWarningMedium | Coping applied, but only in Medium Detail Level.
CopingWarningOffset | Coping applied, but no cut was made. Adjust Coping Distance or Offset parameters.
StartCutShadowJoin | Two joined walls are in a position to allow automatic insert copying.
StopCutShadowJoin | Two joined walls are no longer in a position to allow automatic insert copying. They are either non-parallel or non-overlapping.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ColumnInsideWallFailures Properties

The BuiltInFailuresColumnInsideWallFailures type exposes the following members.

Properties
Name | Description
ColumnInsideWall | One element is completely inside another.
CopingWarningExtension | Coping applied, but no cut was made. Adjust Coping Distance or Extension parameters.
CopingWarningIgnored | Cuts on concrete members are ignored.
CopingWarningMedium | Coping applied, but only in Medium Detail Level.
CopingWarningOffset | Coping applied, but no cut was made. Adjust Coping Distance or Offset parameters.
StartCutShadowJoin | Two joined walls are in a position to allow automatic insert copying.
StopCutShadowJoin | Two joined walls are no longer in a position to allow automatic insert copying. They are either non-parallel or non-overlapping.
Top
See Also

Reference

BuiltInFailuresColumnInsideWallFailures Class


BuiltInFailures.ColumnInsideWallFailures.ColumnInsideWall Property

BuiltInFailuresColumnInsideWallFailuresColumnInsideWall Property

One element is completely inside another.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ColumnInsideWall { get; }
Public Shared ReadOnly Property ColumnInsideWall As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ColumnInsideWall {
    FailureDefinitionId^ get ();
}
static member ColumnInsideWall : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresColumnInsideWallFailures Class


BuiltInFailures.ColumnInsideWallFailures.CopingWarningExtension Property

BuiltInFailuresColumnInsideWallFailuresCopingWarningExtension Property

Coping applied, but no cut was made. Adjust Coping Distance or Extension parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CopingWarningExtension { get; }
Public Shared ReadOnly Property CopingWarningExtension As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CopingWarningExtension {
    FailureDefinitionId^ get ();
}
static member CopingWarningExtension : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresColumnInsideWallFailures Class


BuiltInFailures.ColumnInsideWallFailures.CopingWarningIgnored Property

BuiltInFailuresColumnInsideWallFailuresCopingWarningIgnored Property

Cuts on concrete members are ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CopingWarningIgnored { get; }
Public Shared ReadOnly Property CopingWarningIgnored As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CopingWarningIgnored {
    FailureDefinitionId^ get ();
}
static member CopingWarningIgnored : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresColumnInsideWallFailures Class


BuiltInFailures.ColumnInsideWallFailures.CopingWarningMedium Property

BuiltInFailuresColumnInsideWallFailuresCopingWarningMedium Property

Coping applied, but only in Medium Detail Level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CopingWarningMedium { get; }
Public Shared ReadOnly Property CopingWarningMedium As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CopingWarningMedium {
    FailureDefinitionId^ get ();
}
static member CopingWarningMedium : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresColumnInsideWallFailures Class


BuiltInFailures.ColumnInsideWallFailures.CopingWarningOffset Property

BuiltInFailuresColumnInsideWallFailuresCopingWarningOffset Property

Coping applied, but no cut was made. Adjust Coping Distance or Offset parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CopingWarningOffset { get; }
Public Shared ReadOnly Property CopingWarningOffset As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CopingWarningOffset {
    FailureDefinitionId^ get ();
}
static member CopingWarningOffset : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresColumnInsideWallFailures Class


BuiltInFailures.ColumnInsideWallFailures.StartCutShadowJoin Property

BuiltInFailuresColumnInsideWallFailuresStartCutShadowJoin Property

Two joined walls are in a position to allow automatic insert copying.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StartCutShadowJoin { get; }
Public Shared ReadOnly Property StartCutShadowJoin As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StartCutShadowJoin {
    FailureDefinitionId^ get ();
}
static member StartCutShadowJoin : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresColumnInsideWallFailures Class


BuiltInFailures.ColumnInsideWallFailures.StopCutShadowJoin Property

BuiltInFailuresColumnInsideWallFailuresStopCutShadowJoin Property

Two joined walls are no longer in a position to allow automatic insert copying. They are either non-parallel or non-overlapping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StopCutShadowJoin { get; }
Public Shared ReadOnly Property StopCutShadowJoin As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StopCutShadowJoin {
    FailureDefinitionId^ get ();
}
static member StopCutShadowJoin : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresColumnInsideWallFailures Class


BuiltInFailures.ComponentRepeaterFailures Class

BuiltInFailuresComponentRepeaterFailures Class

Failures related to component repeaters.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresComponentRepeaterFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ComponentRepeaterFailures
Public NotInheritable Class ComponentRepeaterFailures
public ref class ComponentRepeaterFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ComponentRepeaterFailures = class end

The BuiltInFailuresComponentRepeaterFailures type exposes the following members.

Properties
Name | Description
ComponentRepeater_InvalidFamilyOnReload | Reloaded family not appropriate for repeater.
ComponentRepeater_ThereIsOnlyOneInstanceInThisRepeater | There is only one component in this repeater.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ComponentRepeaterFailures Properties

The BuiltInFailuresComponentRepeaterFailures type exposes the following members.

Properties
Name | Description
ComponentRepeater_InvalidFamilyOnReload | Reloaded family not appropriate for repeater.
ComponentRepeater_ThereIsOnlyOneInstanceInThisRepeater | There is only one component in this repeater.
Top
See Also

Reference

BuiltInFailuresComponentRepeaterFailures Class


BuiltInFailures.ComponentRepeaterFailures.ComponentRepeater_InvalidFamilyOnReload Property

BuiltInFailuresComponentRepeaterFailuresComponentRepeater_InvalidFamilyOnReload Property

Reloaded family not appropriate for repeater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ComponentRepeater_InvalidFamilyOnReload { get; }
Public Shared ReadOnly Property ComponentRepeater_InvalidFamilyOnReload As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ComponentRepeater_InvalidFamilyOnReload {
    FailureDefinitionId^ get ();
}
static member ComponentRepeater_InvalidFamilyOnReload : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresComponentRepeaterFailures Class


BuiltInFailures.ComponentRepeaterFailures.ComponentRepeater_ThereIsOnlyOneInstanceInThisRepeater Property

BuiltInFailuresComponentRepeaterFailuresComponentRepeater_ThereIsOnlyOneInstanceInThisRepeater Property

There is only one component in this repeater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ComponentRepeater_ThereIsOnlyOneInstanceInThisRepeater { get; }
Public Shared ReadOnly Property ComponentRepeater_ThereIsOnlyOneInstanceInThisRepeater As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ComponentRepeater_ThereIsOnlyOneInstanceInThisRepeater {
    FailureDefinitionId^ get ();
}
static member ComponentRepeater_ThereIsOnlyOneInstanceInThisRepeater : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresComponentRepeaterFailures Class


BuiltInFailures.ComponentRepeaterSlotFailures Class

BuiltInFailuresComponentRepeaterSlotFailures Class

Failures related to component repeater slots.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresComponentRepeaterSlotFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ComponentRepeaterSlotFailures
Public NotInheritable Class ComponentRepeaterSlotFailures
public ref class ComponentRepeaterSlotFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ComponentRepeaterSlotFailures = class end

The BuiltInFailuresComponentRepeaterSlotFailures type exposes the following members.

Properties
Name | Description
ComponentRepeaterSlot_InvalidFamilyOnReload | Reloaded family not appropriate for repeated component.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ComponentRepeaterSlotFailures Properties

The BuiltInFailuresComponentRepeaterSlotFailures type exposes the following members.

Properties
Name | Description
ComponentRepeaterSlot_InvalidFamilyOnReload | Reloaded family not appropriate for repeated component.
Top
See Also

Reference

BuiltInFailuresComponentRepeaterSlotFailures Class


BuiltInFailures.ComponentRepeaterSlotFailures.ComponentRepeaterSlot_InvalidFamilyOnReload Property

BuiltInFailuresComponentRepeaterSlotFailuresComponentRepeaterSlot_InvalidFamilyOnReload Property

Reloaded family not appropriate for repeated component.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ComponentRepeaterSlot_InvalidFamilyOnReload { get; }
Public Shared ReadOnly Property ComponentRepeaterSlot_InvalidFamilyOnReload As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ComponentRepeaterSlot_InvalidFamilyOnReload {
    FailureDefinitionId^ get ();
}
static member ComponentRepeaterSlot_InvalidFamilyOnReload : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresComponentRepeaterSlotFailures Class


BuiltInFailures.ConnectorFailures Class

BuiltInFailuresConnectorFailures Class

Failures about Connector.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresConnectorFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ConnectorFailures
Public NotInheritable Class ConnectorFailures
public ref class ConnectorFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ConnectorFailures = class end

The BuiltInFailuresConnectorFailures type exposes the following members.

Properties
Name | Description
AirTerminalCenterNotAligned | The center of the Air Terminal doesn't align at (0,0,0): align the Air Terminal Center to the Origin Defining Reference Planes could help to solve the problem.
AllElementsRemovedFromCircuitGroup | [System] is empty and will be deleted.
DisconnectedElements | Elements are disconnected!
ElementAssignedToDefaultSystem | At least one connector on the highlighted element is currently assigned to the [Element Name]. In general items shouldn't be assigned to the Default Systems, but should be assigned as equipments or elements of a non-default system. Click the More Info button below for additional information on System Creation.
ElementHasMultipleConnectors | Revit found one or more elements with multiple connectors. Select each element and then select the connectors to use for the analytical connection.
ElementsAreDisconnected | Elements need to be disconnected.
ElementsConnectedToParent | You have selected elements that are connected to a parent object in a System. These elements cannot be removed from the System.
ElementsNeedToBeDisconnected | Elements need to be disconnected.
ExistsForSelectedElement | Connections already exists for selected element.
FittingMustBeOnDuct | The [Tap] must be attached to duct.
FittingMustBeOnDuctWarn | The [Tap] must be attached to duct.
FittingMustBeOnPipe | The [Tap] must be attached to pipe.
FittingMustBeOnPipeWarn | The [Tap] must be attached to pipe.
InvalidConnectionRef | The selected fitting has invalid connections and must be deleted to continue.
InvalidConnector | The connector is invalid, the size cannot be determined from the connector.
InvalidLoadClassificationValue | The load classification parameter cannot be empty. Please select a valid load classification element for the connector parameter and the associated family parameter.
InvalidPowerFactorValue | The value for Power Factor must be between 0 and 1.
JointGenderMismatch | The element has a connector with a fitting joint gender mismatch
JointShapeMismatch | The element has a connector with a fitting joint shape mismatch
JointSizeMismatch | The element has a connector with a fitting joint size mismatch
JointTypeMismatch | The element has a connector with a fitting joint type mismatch
LayoutConnector | [Unassigned System Type] on Connector [Index Number].
MismatchNoAvailableConnector | Cannot add [Element] to System. There is no available connector matching the System Type ([Type Name]) for the System.
MultipleNetwork | Elements in [System Name] are not connected in a single physical network due to one or both of the following:\n- There are disconnects in the system's physical network.\n- Elements in the system are connected to more than one physical network.
NetworkValidityError | The family is connected in a network and can no longer keep the connectivity. Disconnect the family from the network?
NetworkValidityErrorWasDisconnected | The family is connected in a network and can no longer keep the connectivity. Disconnect the family from the network?
NoLossDefined | No Loss Defined
NoSupportKCoefficientTable | "K Coefficient from table" is not supported on connector for the element
NotAllowedToModifyGroupElementsError | Connection to a group failed. Modification of elements within a group is not allowed.
NotAllowedToModifyGroupElementsWarning | Connection to a group failed. Modification of elements within a group is not allowed.
OpenConnector | The element has an open connector
RbsNetworkValidityError | The family is connected in a network and can no longer keep the connectivity.
RemoveConnectorLinksWarn | The links between connector [Index] and connector [Index], connector [Index] and connector [Index] are removed.
RemoveConnectorLinkWarn | The link between connector [Index] and connector [Index] is removed.
ShapesNotMatch | Shapes do not match. A connection could not be made.
SizingCalculationFlowOnlyWarn | Some elements are not sized because the system calculation is flow only. You may change the system calculation level to size them again.
SizingCalculationNoneWarn | Some elements are not sized because the system calculation level is none or performance. You may change the system calculation level to size them again.
SizingFailed | Sizing failed.
UnconnectedCircuit | The element has an unconnected circuit on its connector
UnconnectedDevice | Device has an unconnected [Type Name] connector (index = [Index Number]).
UndefinedConnector | Revit does not support Undefined connectors. The following have been replaced by the default connector: [Connector Element]
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ConnectorFailures Properties

The BuiltInFailuresConnectorFailures type exposes the following members.

Properties
Name | Description
AirTerminalCenterNotAligned | The center of the Air Terminal doesn't align at (0,0,0): align the Air Terminal Center to the Origin Defining Reference Planes could help to solve the problem.
AllElementsRemovedFromCircuitGroup | [System] is empty and will be deleted.
DisconnectedElements | Elements are disconnected!
ElementAssignedToDefaultSystem | At least one connector on the highlighted element is currently assigned to the [Element Name]. In general items shouldn't be assigned to the Default Systems, but should be assigned as equipments or elements of a non-default system. Click the More Info button below for additional information on System Creation.
ElementHasMultipleConnectors | Revit found one or more elements with multiple connectors. Select each element and then select the connectors to use for the analytical connection.
ElementsAreDisconnected | Elements need to be disconnected.
ElementsConnectedToParent | You have selected elements that are connected to a parent object in a System. These elements cannot be removed from the System.
ElementsNeedToBeDisconnected | Elements need to be disconnected.
ExistsForSelectedElement | Connections already exists for selected element.
FittingMustBeOnDuct | The [Tap] must be attached to duct.
FittingMustBeOnDuctWarn | The [Tap] must be attached to duct.
FittingMustBeOnPipe | The [Tap] must be attached to pipe.
FittingMustBeOnPipeWarn | The [Tap] must be attached to pipe.
InvalidConnectionRef | The selected fitting has invalid connections and must be deleted to continue.
InvalidConnector | The connector is invalid, the size cannot be determined from the connector.
InvalidLoadClassificationValue | The load classification parameter cannot be empty. Please select a valid load classification element for the connector parameter and the associated family parameter.
InvalidPowerFactorValue | The value for Power Factor must be between 0 and 1.
JointGenderMismatch | The element has a connector with a fitting joint gender mismatch
JointShapeMismatch | The element has a connector with a fitting joint shape mismatch
JointSizeMismatch | The element has a connector with a fitting joint size mismatch
JointTypeMismatch | The element has a connector with a fitting joint type mismatch
LayoutConnector | [Unassigned System Type] on Connector [Index Number].
MismatchNoAvailableConnector | Cannot add [Element] to System. There is no available connector matching the System Type ([Type Name]) for the System.
MultipleNetwork | Elements in [System Name] are not connected in a single physical network due to one or both of the following:\n- There are disconnects in the system's physical network.\n- Elements in the system are connected to more than one physical network.
NetworkValidityError | The family is connected in a network and can no longer keep the connectivity. Disconnect the family from the network?
NetworkValidityErrorWasDisconnected | The family is connected in a network and can no longer keep the connectivity. Disconnect the family from the network?
NoLossDefined | No Loss Defined
NoSupportKCoefficientTable | "K Coefficient from table" is not supported on connector for the element
NotAllowedToModifyGroupElementsError | Connection to a group failed. Modification of elements within a group is not allowed.
NotAllowedToModifyGroupElementsWarning | Connection to a group failed. Modification of elements within a group is not allowed.
OpenConnector | The element has an open connector
RbsNetworkValidityError | The family is connected in a network and can no longer keep the connectivity.
RemoveConnectorLinksWarn | The links between connector [Index] and connector [Index], connector [Index] and connector [Index] are removed.
RemoveConnectorLinkWarn | The link between connector [Index] and connector [Index] is removed.
ShapesNotMatch | Shapes do not match. A connection could not be made.
SizingCalculationFlowOnlyWarn | Some elements are not sized because the system calculation is flow only. You may change the system calculation level to size them again.
SizingCalculationNoneWarn | Some elements are not sized because the system calculation level is none or performance. You may change the system calculation level to size them again.
SizingFailed | Sizing failed.
UnconnectedCircuit | The element has an unconnected circuit on its connector
UnconnectedDevice | Device has an unconnected [Type Name] connector (index = [Index Number]).
UndefinedConnector | Revit does not support Undefined connectors. The following have been replaced by the default connector: [Connector Element]
Top
See Also

Reference

BuiltInFailuresConnectorFailures Class


BuiltInFailures.ConnectorFailures.AirTerminalCenterNotAligned Property

BuiltInFailuresConnectorFailuresAirTerminalCenterNotAligned Property

The center of the Air Terminal doesn't align at (0,0,0): align the Air Terminal Center to the Origin Defining Reference Planes could help to solve the problem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AirTerminalCenterNotAligned { get; }
Public Shared ReadOnly Property AirTerminalCenterNotAligned As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AirTerminalCenterNotAligned {
    FailureDefinitionId^ get ();
}
static member AirTerminalCenterNotAligned : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConnectorFailures Class


BuiltInFailures.ConnectorFailures.AllElementsRemovedFromCircuitGroup Property

BuiltInFailuresConnectorFailuresAllElementsRemovedFromCircuitGroup Property

[System] is empty and will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AllElementsRemovedFromCircuitGroup { get; }
Public Shared ReadOnly Property AllElementsRemovedFromCircuitGroup As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AllElementsRemovedFromCircuitGroup {
    FailureDefinitionId^ get ();
}
static member AllElementsRemovedFromCircuitGroup : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConnectorFailures Class


BuiltInFailures.ConnectorFailures.DisconnectedElements Property

BuiltInFailuresConnectorFailuresDisconnectedElements Property

Elements are disconnected!

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DisconnectedElements { get; }
Public Shared ReadOnly Property DisconnectedElements As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DisconnectedElements {
    FailureDefinitionId^ get ();
}
static member DisconnectedElements : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConnectorFailures Class


BuiltInFailures.ConnectorFailures.ElementAssignedToDefaultSystem Property

BuiltInFailuresConnectorFailuresElementAssignedToDefaultSystem Property

At least one connector on the highlighted element is currently assigned to the [Element Name]. In general items shouldn't be assigned to the Default Systems, but should be assigned as equipments or elements of a non-default system. Click the More Info button below for additional information on System Creation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ElementAssignedToDefaultSystem { get; }
Public Shared ReadOnly Property ElementAssignedToDefaultSystem As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ElementAssignedToDefaultSystem {
    FailureDefinitionId^ get ();
}
static member ElementAssignedToDefaultSystem : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConnectorFailures Class


BuiltInFailures.ConnectorFailures.ElementHasMultipleConnectors Property

BuiltInFailuresConnectorFailuresElementHasMultipleConnectors Property

Revit found one or more elements with multiple connectors. Select each element and then select the connectors to use for the analytical connection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ElementHasMultipleConnectors { get; }
Public Shared ReadOnly Property ElementHasMultipleConnectors As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ElementHasMultipleConnectors {
    FailureDefinitionId^ get ();
}
static member ElementHasMultipleConnectors : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConnectorFailures Class


BuiltInFailures.ConnectorFailures.ElementsAreDisconnected Property

BuiltInFailuresConnectorFailuresElementsAreDisconnected Property

Elements need to be disconnected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ElementsAreDisconnected { get; }
Public Shared ReadOnly Property ElementsAreDisconnected As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ElementsAreDisconnected {
    FailureDefinitionId^ get ();
}
static member ElementsAreDisconnected : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConnectorFailures Class


BuiltInFailures.ConnectorFailures.ElementsConnectedToParent Property

BuiltInFailuresConnectorFailuresElementsConnectedToParent Property

You have selected elements that are connected to a parent object in a System. These elements cannot be removed from the System.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ElementsConnectedToParent { get; }
Public Shared ReadOnly Property ElementsConnectedToParent As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ElementsConnectedToParent {
    FailureDefinitionId^ get ();
}
static member ElementsConnectedToParent : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConnectorFailures Class


BuiltInFailures.ConnectorFailures.ElementsNeedToBeDisconnected Property

BuiltInFailuresConnectorFailuresElementsNeedToBeDisconnected Property

Elements need to be disconnected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ElementsNeedToBeDisconnected { get; }
Public Shared ReadOnly Property ElementsNeedToBeDisconnected As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ElementsNeedToBeDisconnected {
    FailureDefinitionId^ get ();
}
static member ElementsNeedToBeDisconnected : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConnectorFailures Class


BuiltInFailures.ConnectorFailures.ExistsForSelectedElement Property

BuiltInFailuresConnectorFailuresExistsForSelectedElement Property

Connections already exists for selected element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ExistsForSelectedElement { get; }
Public Shared ReadOnly Property ExistsForSelectedElement As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ExistsForSelectedElement {
    FailureDefinitionId^ get ();
}
static member ExistsForSelectedElement : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConnectorFailures Class


BuiltInFailures.ConnectorFailures.FittingMustBeOnDuct Property

BuiltInFailuresConnectorFailuresFittingMustBeOnDuct Property

The [Tap] must be attached to duct.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FittingMustBeOnDuct { get; }
Public Shared ReadOnly Property FittingMustBeOnDuct As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FittingMustBeOnDuct {
    FailureDefinitionId^ get ();
}
static member FittingMustBeOnDuct : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConnectorFailures Class


BuiltInFailures.ConnectorFailures.FittingMustBeOnDuctWarn Property

BuiltInFailuresConnectorFailuresFittingMustBeOnDuctWarn Property

The [Tap] must be attached to duct.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FittingMustBeOnDuctWarn { get; }
Public Shared ReadOnly Property FittingMustBeOnDuctWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FittingMustBeOnDuctWarn {
    FailureDefinitionId^ get ();
}
static member FittingMustBeOnDuctWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConnectorFailures Class


BuiltInFailures.ConnectorFailures.FittingMustBeOnPipe Property

BuiltInFailuresConnectorFailuresFittingMustBeOnPipe Property

The [Tap] must be attached to pipe.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FittingMustBeOnPipe { get; }
Public Shared ReadOnly Property FittingMustBeOnPipe As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FittingMustBeOnPipe {
    FailureDefinitionId^ get ();
}
static member FittingMustBeOnPipe : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConnectorFailures Class


BuiltInFailures.ConnectorFailures.FittingMustBeOnPipeWarn Property

BuiltInFailuresConnectorFailuresFittingMustBeOnPipeWarn Property

The [Tap] must be attached to pipe.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FittingMustBeOnPipeWarn { get; }
Public Shared ReadOnly Property FittingMustBeOnPipeWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FittingMustBeOnPipeWarn {
    FailureDefinitionId^ get ();
}
static member FittingMustBeOnPipeWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConnectorFailures Class


BuiltInFailures.ConnectorFailures.InvalidConnectionRef Property

BuiltInFailuresConnectorFailuresInvalidConnectionRef Property

The selected fitting has invalid connections and must be deleted to continue.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidConnectionRef { get; }
Public Shared ReadOnly Property InvalidConnectionRef As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidConnectionRef {
    FailureDefinitionId^ get ();
}
static member InvalidConnectionRef : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConnectorFailures Class


BuiltInFailures.ConnectorFailures.InvalidConnector Property

BuiltInFailuresConnectorFailuresInvalidConnector Property

The connector is invalid, the size cannot be determined from the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidConnector { get; }
Public Shared ReadOnly Property InvalidConnector As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidConnector {
    FailureDefinitionId^ get ();
}
static member InvalidConnector : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConnectorFailures Class


BuiltInFailures.ConnectorFailures.InvalidLoadClassificationValue Property

BuiltInFailuresConnectorFailuresInvalidLoadClassificationValue Property

The load classification parameter cannot be empty. Please select a valid load classification element for the connector parameter and the associated family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidLoadClassificationValue { get; }
Public Shared ReadOnly Property InvalidLoadClassificationValue As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidLoadClassificationValue {
    FailureDefinitionId^ get ();
}
static member InvalidLoadClassificationValue : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConnectorFailures Class


BuiltInFailures.ConnectorFailures.InvalidPowerFactorValue Property

BuiltInFailuresConnectorFailuresInvalidPowerFactorValue Property

The value for Power Factor must be between 0 and 1.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidPowerFactorValue { get; }
Public Shared ReadOnly Property InvalidPowerFactorValue As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidPowerFactorValue {
    FailureDefinitionId^ get ();
}
static member InvalidPowerFactorValue : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConnectorFailures Class


BuiltInFailures.ConnectorFailures.JointGenderMismatch Property

BuiltInFailuresConnectorFailuresJointGenderMismatch Property

The element has a connector with a fitting joint gender mismatch

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId JointGenderMismatch { get; }
Public Shared ReadOnly Property JointGenderMismatch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ JointGenderMismatch {
    FailureDefinitionId^ get ();
}
static member JointGenderMismatch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConnectorFailures Class


BuiltInFailures.ConnectorFailures.JointShapeMismatch Property

BuiltInFailuresConnectorFailuresJointShapeMismatch Property

The element has a connector with a fitting joint shape mismatch

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId JointShapeMismatch { get; }
Public Shared ReadOnly Property JointShapeMismatch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ JointShapeMismatch {
    FailureDefinitionId^ get ();
}
static member JointShapeMismatch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConnectorFailures Class


BuiltInFailures.ConnectorFailures.JointSizeMismatch Property

BuiltInFailuresConnectorFailuresJointSizeMismatch Property

The element has a connector with a fitting joint size mismatch

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId JointSizeMismatch { get; }
Public Shared ReadOnly Property JointSizeMismatch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ JointSizeMismatch {
    FailureDefinitionId^ get ();
}
static member JointSizeMismatch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConnectorFailures Class


BuiltInFailures.ConnectorFailures.JointTypeMismatch Property

BuiltInFailuresConnectorFailuresJointTypeMismatch Property

The element has a connector with a fitting joint type mismatch

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId JointTypeMismatch { get; }
Public Shared ReadOnly Property JointTypeMismatch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ JointTypeMismatch {
    FailureDefinitionId^ get ();
}
static member JointTypeMismatch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConnectorFailures Class


BuiltInFailures.ConnectorFailures.LayoutConnector Property

BuiltInFailuresConnectorFailuresLayoutConnector Property

[Unassigned System Type] on Connector [Index Number].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LayoutConnector { get; }
Public Shared ReadOnly Property LayoutConnector As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LayoutConnector {
    FailureDefinitionId^ get ();
}
static member LayoutConnector : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConnectorFailures Class


BuiltInFailures.ConnectorFailures.MismatchNoAvailableConnector Property

BuiltInFailuresConnectorFailuresMismatchNoAvailableConnector Property

Cannot add [Element] to System. There is no available connector matching the System Type ([Type Name]) for the System.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MismatchNoAvailableConnector { get; }
Public Shared ReadOnly Property MismatchNoAvailableConnector As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MismatchNoAvailableConnector {
    FailureDefinitionId^ get ();
}
static member MismatchNoAvailableConnector : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConnectorFailures Class


BuiltInFailures.ConnectorFailures.MultipleNetwork Property

BuiltInFailuresConnectorFailuresMultipleNetwork Property

Elements in [System Name] are not connected in a single physical network due to one or both of the following:\n- There are disconnects in the system's physical network.\n- Elements in the system are connected to more than one physical network.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MultipleNetwork { get; }
Public Shared ReadOnly Property MultipleNetwork As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MultipleNetwork {
    FailureDefinitionId^ get ();
}
static member MultipleNetwork : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConnectorFailures Class


BuiltInFailures.ConnectorFailures.NetworkValidityError Property

BuiltInFailuresConnectorFailuresNetworkValidityError Property

The family is connected in a network and can no longer keep the connectivity. Disconnect the family from the network?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NetworkValidityError { get; }
Public Shared ReadOnly Property NetworkValidityError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NetworkValidityError {
    FailureDefinitionId^ get ();
}
static member NetworkValidityError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConnectorFailures Class


BuiltInFailures.ConnectorFailures.NetworkValidityErrorWasDisconnected Property

BuiltInFailuresConnectorFailuresNetworkValidityErrorWasDisconnected Property

The family is connected in a network and can no longer keep the connectivity. Disconnect the family from the network?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NetworkValidityErrorWasDisconnected { get; }
Public Shared ReadOnly Property NetworkValidityErrorWasDisconnected As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NetworkValidityErrorWasDisconnected {
    FailureDefinitionId^ get ();
}
static member NetworkValidityErrorWasDisconnected : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConnectorFailures Class


BuiltInFailures.ConnectorFailures.NoLossDefined Property

BuiltInFailuresConnectorFailuresNoLossDefined Property

No Loss Defined

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoLossDefined { get; }
Public Shared ReadOnly Property NoLossDefined As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoLossDefined {
    FailureDefinitionId^ get ();
}
static member NoLossDefined : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConnectorFailures Class


BuiltInFailures.ConnectorFailures.NoSupportKCoefficientTable Property

BuiltInFailuresConnectorFailuresNoSupportKCoefficientTable Property

"K Coefficient from table" is not supported on connector for the element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoSupportKCoefficientTable { get; }
Public Shared ReadOnly Property NoSupportKCoefficientTable As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoSupportKCoefficientTable {
    FailureDefinitionId^ get ();
}
static member NoSupportKCoefficientTable : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConnectorFailures Class


BuiltInFailures.ConnectorFailures.NotAllowedToModifyGroupElementsError Property

BuiltInFailuresConnectorFailuresNotAllowedToModifyGroupElementsError Property

Connection to a group failed. Modification of elements within a group is not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotAllowedToModifyGroupElementsError { get; }
Public Shared ReadOnly Property NotAllowedToModifyGroupElementsError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotAllowedToModifyGroupElementsError {
    FailureDefinitionId^ get ();
}
static member NotAllowedToModifyGroupElementsError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConnectorFailures Class


BuiltInFailures.ConnectorFailures.NotAllowedToModifyGroupElementsWarning Property

BuiltInFailuresConnectorFailuresNotAllowedToModifyGroupElementsWarning Property

Connection to a group failed. Modification of elements within a group is not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotAllowedToModifyGroupElementsWarning { get; }
Public Shared ReadOnly Property NotAllowedToModifyGroupElementsWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotAllowedToModifyGroupElementsWarning {
    FailureDefinitionId^ get ();
}
static member NotAllowedToModifyGroupElementsWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConnectorFailures Class


BuiltInFailures.ConnectorFailures.OpenConnector Property

BuiltInFailuresConnectorFailuresOpenConnector Property

The element has an open connector

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId OpenConnector { get; }
Public Shared ReadOnly Property OpenConnector As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ OpenConnector {
    FailureDefinitionId^ get ();
}
static member OpenConnector : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConnectorFailures Class


BuiltInFailures.ConnectorFailures.RbsNetworkValidityError Property

BuiltInFailuresConnectorFailuresRbsNetworkValidityError Property

The family is connected in a network and can no longer keep the connectivity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RbsNetworkValidityError { get; }
Public Shared ReadOnly Property RbsNetworkValidityError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RbsNetworkValidityError {
    FailureDefinitionId^ get ();
}
static member RbsNetworkValidityError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConnectorFailures Class


BuiltInFailures.ConnectorFailures.RemoveConnectorLinksWarn Property

BuiltInFailuresConnectorFailuresRemoveConnectorLinksWarn Property

The links between connector [Index] and connector [Index], connector [Index] and connector [Index] are removed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RemoveConnectorLinksWarn { get; }
Public Shared ReadOnly Property RemoveConnectorLinksWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RemoveConnectorLinksWarn {
    FailureDefinitionId^ get ();
}
static member RemoveConnectorLinksWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConnectorFailures Class


BuiltInFailures.ConnectorFailures.RemoveConnectorLinkWarn Property

BuiltInFailuresConnectorFailuresRemoveConnectorLinkWarn Property

The link between connector [Index] and connector [Index] is removed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RemoveConnectorLinkWarn { get; }
Public Shared ReadOnly Property RemoveConnectorLinkWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RemoveConnectorLinkWarn {
    FailureDefinitionId^ get ();
}
static member RemoveConnectorLinkWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConnectorFailures Class


BuiltInFailures.ConnectorFailures.ShapesNotMatch Property

BuiltInFailuresConnectorFailuresShapesNotMatch Property

Shapes do not match. A connection could not be made.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ShapesNotMatch { get; }
Public Shared ReadOnly Property ShapesNotMatch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ShapesNotMatch {
    FailureDefinitionId^ get ();
}
static member ShapesNotMatch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConnectorFailures Class


BuiltInFailures.ConnectorFailures.SizingCalculationFlowOnlyWarn Property

BuiltInFailuresConnectorFailuresSizingCalculationFlowOnlyWarn Property

Some elements are not sized because the system calculation is flow only. You may change the system calculation level to size them again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SizingCalculationFlowOnlyWarn { get; }
Public Shared ReadOnly Property SizingCalculationFlowOnlyWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SizingCalculationFlowOnlyWarn {
    FailureDefinitionId^ get ();
}
static member SizingCalculationFlowOnlyWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConnectorFailures Class


BuiltInFailures.ConnectorFailures.SizingCalculationNoneWarn Property

BuiltInFailuresConnectorFailuresSizingCalculationNoneWarn Property

Some elements are not sized because the system calculation level is none or performance. You may change the system calculation level to size them again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SizingCalculationNoneWarn { get; }
Public Shared ReadOnly Property SizingCalculationNoneWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SizingCalculationNoneWarn {
    FailureDefinitionId^ get ();
}
static member SizingCalculationNoneWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConnectorFailures Class


BuiltInFailures.ConnectorFailures.SizingFailed Property

BuiltInFailuresConnectorFailuresSizingFailed Property

Sizing failed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SizingFailed { get; }
Public Shared ReadOnly Property SizingFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SizingFailed {
    FailureDefinitionId^ get ();
}
static member SizingFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConnectorFailures Class


BuiltInFailures.ConnectorFailures.UnconnectedCircuit Property

BuiltInFailuresConnectorFailuresUnconnectedCircuit Property

The element has an unconnected circuit on its connector

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnconnectedCircuit { get; }
Public Shared ReadOnly Property UnconnectedCircuit As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnconnectedCircuit {
    FailureDefinitionId^ get ();
}
static member UnconnectedCircuit : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConnectorFailures Class


BuiltInFailures.ConnectorFailures.UnconnectedDevice Property

BuiltInFailuresConnectorFailuresUnconnectedDevice Property

Device has an unconnected [Type Name] connector (index = [Index Number]).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnconnectedDevice { get; }
Public Shared ReadOnly Property UnconnectedDevice As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnconnectedDevice {
    FailureDefinitionId^ get ();
}
static member UnconnectedDevice : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConnectorFailures Class


BuiltInFailures.ConnectorFailures.UndefinedConnector Property

BuiltInFailuresConnectorFailuresUndefinedConnector Property

Revit does not support Undefined connectors. The following have been replaced by the default connector: [Connector Element]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UndefinedConnector { get; }
Public Shared ReadOnly Property UndefinedConnector As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UndefinedConnector {
    FailureDefinitionId^ get ();
}
static member UndefinedConnector : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConnectorFailures Class


BuiltInFailures.ConstraintFailures Class

BuiltInFailuresConstraintFailures Class

Failures about Constraint.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresConstraintFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ConstraintFailures
Public NotInheritable Class ConstraintFailures
public ref class ConstraintFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ConstraintFailures = class end

The BuiltInFailuresConstraintFailures type exposes the following members.

Properties
Name | Description
UndeletedConstraints | A dimension that has lock constraints is being deleted, but the elements will still be constrained. Push "Unconstrain" to remove the constraints or "OK" to leave elements constrained..
UndeletedConstraintsEQ | A dimension that has EQ constraints is being deleted, but the elements will still be constrained. Push "Unconstrain" to remove the constraints or "OK" to leave elements constrained..
UndeletedConstraintsInGroup | A labeled dimension is being deleted, but the corresponding constraint belongs to a group and will not be changed. You can change it in group edit mode later.
UndeletedConstraintsLabel | A dimension labeled by a parameter is being deleted, but the elements will still be constrained. Push "Unconstrain" to remove the constraints or "OK" to leave elements constrained..
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ConstraintFailures Properties

The BuiltInFailuresConstraintFailures type exposes the following members.

Properties
Name | Description
UndeletedConstraints | A dimension that has lock constraints is being deleted, but the elements will still be constrained. Push "Unconstrain" to remove the constraints or "OK" to leave elements constrained..
UndeletedConstraintsEQ | A dimension that has EQ constraints is being deleted, but the elements will still be constrained. Push "Unconstrain" to remove the constraints or "OK" to leave elements constrained..
UndeletedConstraintsInGroup | A labeled dimension is being deleted, but the corresponding constraint belongs to a group and will not be changed. You can change it in group edit mode later.
UndeletedConstraintsLabel | A dimension labeled by a parameter is being deleted, but the elements will still be constrained. Push "Unconstrain" to remove the constraints or "OK" to leave elements constrained..
Top
See Also

Reference

BuiltInFailuresConstraintFailures Class


BuiltInFailures.ConstraintFailures.UndeletedConstraints Property

BuiltInFailuresConstraintFailuresUndeletedConstraints Property

A dimension that has lock constraints is being deleted, but the elements will still be constrained. Push "Unconstrain" to remove the constraints or "OK" to leave elements constrained..

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UndeletedConstraints { get; }
Public Shared ReadOnly Property UndeletedConstraints As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UndeletedConstraints {
    FailureDefinitionId^ get ();
}
static member UndeletedConstraints : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConstraintFailures Class


BuiltInFailures.ConstraintFailures.UndeletedConstraintsEQ Property

BuiltInFailuresConstraintFailuresUndeletedConstraintsEQ Property

A dimension that has EQ constraints is being deleted, but the elements will still be constrained. Push "Unconstrain" to remove the constraints or "OK" to leave elements constrained..

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UndeletedConstraintsEQ { get; }
Public Shared ReadOnly Property UndeletedConstraintsEQ As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UndeletedConstraintsEQ {
    FailureDefinitionId^ get ();
}
static member UndeletedConstraintsEQ : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConstraintFailures Class


BuiltInFailures.ConstraintFailures.UndeletedConstraintsInGroup Property

BuiltInFailuresConstraintFailuresUndeletedConstraintsInGroup Property

A labeled dimension is being deleted, but the corresponding constraint belongs to a group and will not be changed. You can change it in group edit mode later.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UndeletedConstraintsInGroup { get; }
Public Shared ReadOnly Property UndeletedConstraintsInGroup As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UndeletedConstraintsInGroup {
    FailureDefinitionId^ get ();
}
static member UndeletedConstraintsInGroup : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConstraintFailures Class


BuiltInFailures.ConstraintFailures.UndeletedConstraintsLabel Property

BuiltInFailuresConstraintFailuresUndeletedConstraintsLabel Property

A dimension labeled by a parameter is being deleted, but the elements will still be constrained. Push "Unconstrain" to remove the constraints or "OK" to leave elements constrained..

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UndeletedConstraintsLabel { get; }
Public Shared ReadOnly Property UndeletedConstraintsLabel As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UndeletedConstraintsLabel {
    FailureDefinitionId^ get ();
}
static member UndeletedConstraintsLabel : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConstraintFailures Class


BuiltInFailures.ConversionFailures Class

BuiltInFailuresConversionFailures Class

Failures about conversion of data to a different format.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresConversionFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ConversionFailures
Public NotInheritable Class ConversionFailures
public ref class ConversionFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ConversionFailures = class end

The BuiltInFailuresConversionFailures type exposes the following members.

Properties
Name | Description
CannotConvertPercentToDouble | Cannot convert concentration percent ' [Percentage Value] ' to double value
CannotConvertTempToDouble | Cannot convert temperature '[Temperate Value]' to double value
CannotConvertToDouble | Cannot convert '[Text] ' to double value
UndefinedFluidUnit | Undefined fluid unit: '[Fluid Unit Type Name]'
UndefinedTemperatureUnit | Undefined temperature unit: '[Temperature Unit Type Name]'
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ConversionFailures Properties

The BuiltInFailuresConversionFailures type exposes the following members.

Properties
Name | Description
CannotConvertPercentToDouble | Cannot convert concentration percent ' [Percentage Value] ' to double value
CannotConvertTempToDouble | Cannot convert temperature '[Temperate Value]' to double value
CannotConvertToDouble | Cannot convert '[Text] ' to double value
UndefinedFluidUnit | Undefined fluid unit: '[Fluid Unit Type Name]'
UndefinedTemperatureUnit | Undefined temperature unit: '[Temperature Unit Type Name]'
Top
See Also

Reference

BuiltInFailuresConversionFailures Class


BuiltInFailures.ConversionFailures.CannotConvertPercentToDouble Property

BuiltInFailuresConversionFailuresCannotConvertPercentToDouble Property

Cannot convert concentration percent ' [Percentage Value] ' to double value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotConvertPercentToDouble { get; }
Public Shared ReadOnly Property CannotConvertPercentToDouble As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotConvertPercentToDouble {
    FailureDefinitionId^ get ();
}
static member CannotConvertPercentToDouble : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConversionFailures Class


BuiltInFailures.ConversionFailures.CannotConvertTempToDouble Property

BuiltInFailuresConversionFailuresCannotConvertTempToDouble Property

Cannot convert temperature '[Temperate Value]' to double value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotConvertTempToDouble { get; }
Public Shared ReadOnly Property CannotConvertTempToDouble As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotConvertTempToDouble {
    FailureDefinitionId^ get ();
}
static member CannotConvertTempToDouble : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConversionFailures Class


BuiltInFailures.ConversionFailures.CannotConvertToDouble Property

BuiltInFailuresConversionFailuresCannotConvertToDouble Property

Cannot convert '[Text] ' to double value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotConvertToDouble { get; }
Public Shared ReadOnly Property CannotConvertToDouble As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotConvertToDouble {
    FailureDefinitionId^ get ();
}
static member CannotConvertToDouble : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConversionFailures Class


BuiltInFailures.ConversionFailures.UndefinedFluidUnit Property

BuiltInFailuresConversionFailuresUndefinedFluidUnit Property

Undefined fluid unit: '[Fluid Unit Type Name]'

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UndefinedFluidUnit { get; }
Public Shared ReadOnly Property UndefinedFluidUnit As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UndefinedFluidUnit {
    FailureDefinitionId^ get ();
}
static member UndefinedFluidUnit : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConversionFailures Class


BuiltInFailures.ConversionFailures.UndefinedTemperatureUnit Property

BuiltInFailuresConversionFailuresUndefinedTemperatureUnit Property

Undefined temperature unit: '[Temperature Unit Type Name]'

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UndefinedTemperatureUnit { get; }
Public Shared ReadOnly Property UndefinedTemperatureUnit As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UndefinedTemperatureUnit {
    FailureDefinitionId^ get ();
}
static member UndefinedTemperatureUnit : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresConversionFailures Class


BuiltInFailures.CopyMonitorFailures Class

BuiltInFailuresCopyMonitorFailures Class

Failures about CopyWatch.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresCopyMonitorFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class CopyMonitorFailures
Public NotInheritable Class CopyMonitorFailures
public ref class CopyMonitorFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CopyMonitorFailures = class end

The BuiltInFailuresCopyMonitorFailures type exposes the following members.

Properties
Name | Description
AlreadyCopiedAndStopWatch | Element has already been copied. Stop existing monitoring to copy again.
AlreadyWatched | Elements already monitored.
CannotCopyCuttingInsert | Copy/Monitor does not support cutting inserts in floors. Some openings were not copied.
CannotMoveHostedFixtureViaCopyMonitor | The fixture is hosted and cannot be moved. Use the Move command to relocate the fixture in the host file as required.
CopyWatchAlert | Coordination Monitor alert : [Description]
GridDeletedSameName | Grid cannot be copied because grid with desired name '[Name]' already exist in a target document.
LevelDeletedSameName | Level cannot be copied because level with desired name '[Name]' already exist in a target document.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CopyMonitorFailures Properties

The BuiltInFailuresCopyMonitorFailures type exposes the following members.

Properties
Name | Description
AlreadyCopiedAndStopWatch | Element has already been copied. Stop existing monitoring to copy again.
AlreadyWatched | Elements already monitored.
CannotCopyCuttingInsert | Copy/Monitor does not support cutting inserts in floors. Some openings were not copied.
CannotMoveHostedFixtureViaCopyMonitor | The fixture is hosted and cannot be moved. Use the Move command to relocate the fixture in the host file as required.
CopyWatchAlert | Coordination Monitor alert : [Description]
GridDeletedSameName | Grid cannot be copied because grid with desired name '[Name]' already exist in a target document.
LevelDeletedSameName | Level cannot be copied because level with desired name '[Name]' already exist in a target document.
Top
See Also

Reference

BuiltInFailuresCopyMonitorFailures Class


BuiltInFailures.CopyMonitorFailures.AlreadyCopiedAndStopWatch Property

BuiltInFailuresCopyMonitorFailuresAlreadyCopiedAndStopWatch Property

Element has already been copied. Stop existing monitoring to copy again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AlreadyCopiedAndStopWatch { get; }
Public Shared ReadOnly Property AlreadyCopiedAndStopWatch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AlreadyCopiedAndStopWatch {
    FailureDefinitionId^ get ();
}
static member AlreadyCopiedAndStopWatch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyMonitorFailures Class


BuiltInFailures.CopyMonitorFailures.AlreadyWatched Property

BuiltInFailuresCopyMonitorFailuresAlreadyWatched Property

Elements already monitored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AlreadyWatched { get; }
Public Shared ReadOnly Property AlreadyWatched As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AlreadyWatched {
    FailureDefinitionId^ get ();
}
static member AlreadyWatched : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyMonitorFailures Class


BuiltInFailures.CopyMonitorFailures.CannotCopyCuttingInsert Property

BuiltInFailuresCopyMonitorFailuresCannotCopyCuttingInsert Property

Copy/Monitor does not support cutting inserts in floors. Some openings were not copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyCuttingInsert { get; }
Public Shared ReadOnly Property CannotCopyCuttingInsert As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyCuttingInsert {
    FailureDefinitionId^ get ();
}
static member CannotCopyCuttingInsert : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyMonitorFailures Class


BuiltInFailures.CopyMonitorFailures.CannotMoveHostedFixtureViaCopyMonitor Property

BuiltInFailuresCopyMonitorFailuresCannotMoveHostedFixtureViaCopyMonitor Property

The fixture is hosted and cannot be moved. Use the Move command to relocate the fixture in the host file as required.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotMoveHostedFixtureViaCopyMonitor { get; }
Public Shared ReadOnly Property CannotMoveHostedFixtureViaCopyMonitor As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotMoveHostedFixtureViaCopyMonitor {
    FailureDefinitionId^ get ();
}
static member CannotMoveHostedFixtureViaCopyMonitor : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyMonitorFailures Class


BuiltInFailures.CopyMonitorFailures.CopyWatchAlert Property

BuiltInFailuresCopyMonitorFailuresCopyWatchAlert Property

Coordination Monitor alert : [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CopyWatchAlert { get; }
Public Shared ReadOnly Property CopyWatchAlert As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CopyWatchAlert {
    FailureDefinitionId^ get ();
}
static member CopyWatchAlert : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyMonitorFailures Class


BuiltInFailures.CopyMonitorFailures.GridDeletedSameName Property

BuiltInFailuresCopyMonitorFailuresGridDeletedSameName Property

Grid cannot be copied because grid with desired name '[Name]' already exist in a target document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId GridDeletedSameName { get; }
Public Shared ReadOnly Property GridDeletedSameName As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ GridDeletedSameName {
    FailureDefinitionId^ get ();
}
static member GridDeletedSameName : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyMonitorFailures Class


BuiltInFailures.CopyMonitorFailures.LevelDeletedSameName Property

BuiltInFailuresCopyMonitorFailuresLevelDeletedSameName Property

Level cannot be copied because level with desired name '[Name]' already exist in a target document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LevelDeletedSameName { get; }
Public Shared ReadOnly Property LevelDeletedSameName As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LevelDeletedSameName {
    FailureDefinitionId^ get ();
}
static member LevelDeletedSameName : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyMonitorFailures Class


BuiltInFailures.CopyPasteFailures Class

BuiltInFailuresCopyPasteFailures Class

Failures about CopyPasteFailures.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresCopyPasteFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class CopyPasteFailures
Public NotInheritable Class CopyPasteFailures
public ref class CopyPasteFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CopyPasteFailures = class end

The BuiltInFailuresCopyPasteFailures type exposes the following members.

Properties
Name | Description
CannotCopyAttachedType | Cannot copy attached detail group type without copying the model group type it refers to.
CannotCopyAttachedTypeWarn | Cannot copy attached detail group type without copying the model group type it refers to.
CannotCopyBetweenFamilyAndProjectCorruption | Can't copy between Family and Project.
CannotCopyBetweenFamilyAndProjectError | Can't copy between Family and Project.
CannotCopyCurtainWallGridLines | Curtain wall grid lines currently cannot be copied.
CannotCopyDependentView | Dependent views cannot be copied.
CannotCopyDetails | Can't copy some or all of the detailing with the view.
CannotCopyDueToBackgroundCalculation | Cannot copy dragged elements while background calculations are in progress.
CannotCopyDuplicates | Can't paste duplicate types. Only non duplicate types will be pasted.
CannotCopyElevationArrow | To duplicate Elevations, copy the elevation symbol in a plan view.
CannotCopyElevationArrowWarn | To duplicate Elevations, copy the elevation symbol in a plan view.
CannotCopyFamilyName | Can't [Action] because Family '[Family Name]' is different in the two documents. Update the documents to contain the same version of the Family.
CannotCopyFromProjectAndLink | Can't Copy to Clipboard elements from the project and a link instance at the same time. Only elements from the project will be copied.
CannotCopyGridLines | Curtain grid lines cannot be copied. If you are trying to copy the curtain wall, try using tab to select entire wall.
CannotCopyGridLinesWarn | Curtain grid lines cannot be copied. If you are trying to copy the curtain wall, try using tab to select entire wall.
CannotCopyImportInstancesAcrossProjects | Linked Imported Files cannot be copied across projects. All non-RVT linked files will be pasted as imports instead.
CannotCopyIncompleteElement | Can't copy part of element
CannotCopyIncompleteElementWarn | Can't copy part of element
CannotCopyJoinedGeometry | Joined solid geometry cannot be copied as a whole. Instead, select the individual extrusions, etc., using Pick box or Ctrl-select and copy them.
CannotCopyJoinedGeometryWarn | Joined solid geometry cannot be copied as a whole. Instead, select the individual extrusions, etc., using Pick box or Ctrl-select and copy them.
CannotCopyLocked | Can't copy pinned element.
CannotCopyLockedWarn | Can't copy pinned element.
CannotCopyMassing | A massing cannot be copied. Copy the elements within the massing instead.
CannotCopyMassingWarn | A massing cannot be copied. Copy the elements within the massing instead.
CannotCopyMullions | Mullions and panels cannot be copied without copying the entire curtain wall.
CannotCopyMullionsError | Mullions and panels cannot be copied without copying the entire curtain wall.
CannotCopyMullionsWarn | Mullions and panels cannot be copied without copying the entire curtain wall.
CannotCopyMultipleSketchParents | Copying elements from unrelated Workplanes together is not supported in families. Try copying elements separately.
CannotCopyMustBeUnique | Element must be unique.
CannotCopyMustBeUniqueWarn | Element must be unique.
CannotCopyNestedLinks | To copy a nested link, use Copy to Clipboard or Move Copy.
CannotCopyNoAttachedParent | Attached Detail Group can't be copied without its Model Group
CannotCopyNoAttachedParentWarn | Attached Detail Group can't be copied without its Model Group
CannotCopyNoParents | Can't Copy to Clipboard because of relationships between Elements
CannotCopyNoReferences | Elements can't be copied because they will lose their References.
CannotCopyRevolveAxis | The axis cannot be copied.
CannotCopyRevolveAxisWarn | The axis cannot be copied.
CannotCopySelectedPick | The element being dragged can't be copied.
CannotCopySelection | Cannot copy selection.[Description]
CannotCopySketchGrid | Work Planes cannot be copied.
CannotCopySketchGridWarn | Work Planes cannot be copied.
CannotCopySunAndShadowSettings | SunAndShadowSettings cannot be copied.
CannotCopySunAndShadowSettingsWarn | SunAndShadowSettings cannot be copied.
CannotCopyWallPanels | Cannot copy wall panels unless their parent wall is also being copied.
CannotCopyWallPanelsWarn | Cannot copy wall panels unless their parent wall is also being copied.
CannotCopyZone | A Zone cannot be copied.
CannotCopyZoneWarn | A Zone cannot be copied.
CannotDuplicate | Elements can't be duplicated
CannotDuplicateDesignOption | Can't duplicate Design Option.
CannotDuplicateInOption | Elements can't be duplicated in a secondary Option
CannotDuplicateInOptionWarn | Elements can't be duplicated in a secondary Option
CannotDuplicateType | Cannot Duplicate Type.
CannotDuplicateWarn | Elements can't be duplicated
CannotFinalizeClusterInconsistency | Can't finalize because dependent element failed to finalize.
CannotFinalizeOrphanSerf | Can't finalize Group member without finalizing the entire Group.
CannotPasteAlignedAny | Can't Paste Aligned.
CannotPasteAlignedCorruption | Can't Paste Aligned these elements in this view.
CannotPasteAlignedError | Can't Paste Align these elements in this view.
CannotPasteAlignedSomeLevels | Can't Paste Aligned to some views.
CannotPasteAssemblyView | Can't paste assembly view because its associated assembly instance is not available.
CannotPasteCircularLinks | The pasted selection includes a linked instance of this file '[Name]'. A file cannot link itself, so the link was not pasted.
CannotPasteCurtainGridLine | Can't paste Curtain Grid Line.
CannotPasteDifferentViewSpecificElements | Cannot paste view-specific elements from different views.
CannotPasteElemInViewError | Cannot paste the contents into %1!s! view. Attempt to paste into an appropriate view.
CannotPasteInSketch | Can't paste elements into sketch.
CannotPasteInView | Cannot paste the contents into %1!s! view. Attempt to paste into an appropriate view.
CannotPasteInViewError | Cannot paste the contents into %1!s! view. Attempt to paste into an appropriate view.
CannotPasteModelPlusViewSpecificElementsIntoView | Cannot paste view-specific model plus into view.
CannotPasteNoLevelAbove | Can't paste these elements at this height because there is no Level above to Reference.
CannotPasteNoLevelBelow | Can't paste these elements at this height because there is no Level below to reference.
CannotPasteNoWorkplane | Can't paste because there is no corresponding Work Plane. Set workplane or switch to view with appropriate workplane.
CannotPasteRoomsInNonPlanViews | [Rooms] can only be pasted in Plan or Ceiling Plan views.
CannotPasteToSheet | Elements copied to Sheets can only be copied from other Sheets.
CannotPasteViewSpecElemsFromDiffViews | Cannot paste view-specific elements from different views.
CannotPasteViewSpecificElementsIntoPerspectiveView | Can't paste view specific elements into perspective view.
CannotTransferProjectStandards | These Project Standards cannot be transferred.[Description]
CantCopyBetweenModelAndAnnotFam | Can't copy element(s) between Model and Annotation families.
CantCopyElemsToInplaceFam | Can't copy element(s) to In Place family.
CantCopyFrom2dTo3dFam | Can't copy 2D element(s) into a 3D family.
CantCopyFrom3dTo2dFam | Can't copy 3D element(s) into a 2D family.
CantCopyFromDetailToProfileFam | Can't copy Detail element(s) into a Profile family.
CantCopyLevelsOrRefPlanesToNonMassFamily | Can't copy levels or reference planes to families that are not Mass families.
CantCopyStairsLevelHeightNotMatchInMS | Can't copy stairs in Multistory Stairs due to level height doesn't match.
CantCopySymbolicElementToSelfOrientingFamily | Cannot copy symbolic elements sketched in non-horizontal planes.
CopingColumnBeamFailure | The support order for a beam/column connection has been changed. When a beam is supported by a column that same beam cannot be coped by the column. The existing coping has been removed.
CopyImposterContentError | Cannot copy Render Appearance.
CopyImposterContentWarn | Cannot copy Render Appearance.
CopyImposterLightError | Light source cannot be copied!
CopyImposterLightWarn | Light source cannot be copied!
ElementRenamedOnPaste | The loaded type "[Name]" has been renamed to "[New Name]" to avoid conflicts with the existing type.
FinalizedElementsWillBeDeleted | Can't find new hosts for this Element.\nIt will be deleted on Finish Paste unless repositioned or rehosted.
FinalizedElementsWillBeDeletedWarn | Can't find new hosts for this Element.\nIt will be deleted on Finish Paste unless repositioned or rehosted.
FinalizedElementsWillBeModified | Can't find some new hosts for this Element.\nIt will lose references on Finish Paste unless repositioned or rehosted.
FinalizedElementsWillBeModifiedWarn | Can't find some new hosts for this Element.\nIt will lose references on Finish Paste unless repositioned or rehosted.
LostReference | A relationship between Elements in [Option Name] and [Reference Option Name] has been deleted. There is no corresponding relationship in the Primary [New Primary Option Name].
NoSketchPlane | Can't paste because no Work Plane is defined in the View.
PasteInvisibleInView | Selection is invisible in this view.
SomeElementsNotCopiedWarn | Some elements were not copied.[Description]
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CopyPasteFailures Properties

The BuiltInFailuresCopyPasteFailures type exposes the following members.

Properties
Name | Description
CannotCopyAttachedType | Cannot copy attached detail group type without copying the model group type it refers to.
CannotCopyAttachedTypeWarn | Cannot copy attached detail group type without copying the model group type it refers to.
CannotCopyBetweenFamilyAndProjectCorruption | Can't copy between Family and Project.
CannotCopyBetweenFamilyAndProjectError | Can't copy between Family and Project.
CannotCopyCurtainWallGridLines | Curtain wall grid lines currently cannot be copied.
CannotCopyDependentView | Dependent views cannot be copied.
CannotCopyDetails | Can't copy some or all of the detailing with the view.
CannotCopyDueToBackgroundCalculation | Cannot copy dragged elements while background calculations are in progress.
CannotCopyDuplicates | Can't paste duplicate types. Only non duplicate types will be pasted.
CannotCopyElevationArrow | To duplicate Elevations, copy the elevation symbol in a plan view.
CannotCopyElevationArrowWarn | To duplicate Elevations, copy the elevation symbol in a plan view.
CannotCopyFamilyName | Can't [Action] because Family '[Family Name]' is different in the two documents. Update the documents to contain the same version of the Family.
CannotCopyFromProjectAndLink | Can't Copy to Clipboard elements from the project and a link instance at the same time. Only elements from the project will be copied.
CannotCopyGridLines | Curtain grid lines cannot be copied. If you are trying to copy the curtain wall, try using tab to select entire wall.
CannotCopyGridLinesWarn | Curtain grid lines cannot be copied. If you are trying to copy the curtain wall, try using tab to select entire wall.
CannotCopyImportInstancesAcrossProjects | Linked Imported Files cannot be copied across projects. All non-RVT linked files will be pasted as imports instead.
CannotCopyIncompleteElement | Can't copy part of element
CannotCopyIncompleteElementWarn | Can't copy part of element
CannotCopyJoinedGeometry | Joined solid geometry cannot be copied as a whole. Instead, select the individual extrusions, etc., using Pick box or Ctrl-select and copy them.
CannotCopyJoinedGeometryWarn | Joined solid geometry cannot be copied as a whole. Instead, select the individual extrusions, etc., using Pick box or Ctrl-select and copy them.
CannotCopyLocked | Can't copy pinned element.
CannotCopyLockedWarn | Can't copy pinned element.
CannotCopyMassing | A massing cannot be copied. Copy the elements within the massing instead.
CannotCopyMassingWarn | A massing cannot be copied. Copy the elements within the massing instead.
CannotCopyMullions | Mullions and panels cannot be copied without copying the entire curtain wall.
CannotCopyMullionsError | Mullions and panels cannot be copied without copying the entire curtain wall.
CannotCopyMullionsWarn | Mullions and panels cannot be copied without copying the entire curtain wall.
CannotCopyMultipleSketchParents | Copying elements from unrelated Workplanes together is not supported in families. Try copying elements separately.
CannotCopyMustBeUnique | Element must be unique.
CannotCopyMustBeUniqueWarn | Element must be unique.
CannotCopyNestedLinks | To copy a nested link, use Copy to Clipboard or Move Copy.
CannotCopyNoAttachedParent | Attached Detail Group can't be copied without its Model Group
CannotCopyNoAttachedParentWarn | Attached Detail Group can't be copied without its Model Group
CannotCopyNoParents | Can't Copy to Clipboard because of relationships between Elements
CannotCopyNoReferences | Elements can't be copied because they will lose their References.
CannotCopyRevolveAxis | The axis cannot be copied.
CannotCopyRevolveAxisWarn | The axis cannot be copied.
CannotCopySelectedPick | The element being dragged can't be copied.
CannotCopySelection | Cannot copy selection.[Description]
CannotCopySketchGrid | Work Planes cannot be copied.
CannotCopySketchGridWarn | Work Planes cannot be copied.
CannotCopySunAndShadowSettings | SunAndShadowSettings cannot be copied.
CannotCopySunAndShadowSettingsWarn | SunAndShadowSettings cannot be copied.
CannotCopyWallPanels | Cannot copy wall panels unless their parent wall is also being copied.
CannotCopyWallPanelsWarn | Cannot copy wall panels unless their parent wall is also being copied.
CannotCopyZone | A Zone cannot be copied.
CannotCopyZoneWarn | A Zone cannot be copied.
CannotDuplicate | Elements can't be duplicated
CannotDuplicateDesignOption | Can't duplicate Design Option.
CannotDuplicateInOption | Elements can't be duplicated in a secondary Option
CannotDuplicateInOptionWarn | Elements can't be duplicated in a secondary Option
CannotDuplicateType | Cannot Duplicate Type.
CannotDuplicateWarn | Elements can't be duplicated
CannotFinalizeClusterInconsistency | Can't finalize because dependent element failed to finalize.
CannotFinalizeOrphanSerf | Can't finalize Group member without finalizing the entire Group.
CannotPasteAlignedAny | Can't Paste Aligned.
CannotPasteAlignedCorruption | Can't Paste Aligned these elements in this view.
CannotPasteAlignedError | Can't Paste Align these elements in this view.
CannotPasteAlignedSomeLevels | Can't Paste Aligned to some views.
CannotPasteAssemblyView | Can't paste assembly view because its associated assembly instance is not available.
CannotPasteCircularLinks | The pasted selection includes a linked instance of this file '[Name]'. A file cannot link itself, so the link was not pasted.
CannotPasteCurtainGridLine | Can't paste Curtain Grid Line.
CannotPasteDifferentViewSpecificElements | Cannot paste view-specific elements from different views.
CannotPasteElemInViewError | Cannot paste the contents into %1!s! view. Attempt to paste into an appropriate view.
CannotPasteInSketch | Can't paste elements into sketch.
CannotPasteInView | Cannot paste the contents into %1!s! view. Attempt to paste into an appropriate view.
CannotPasteInViewError | Cannot paste the contents into %1!s! view. Attempt to paste into an appropriate view.
CannotPasteModelPlusViewSpecificElementsIntoView | Cannot paste view-specific model plus into view.
CannotPasteNoLevelAbove | Can't paste these elements at this height because there is no Level above to Reference.
CannotPasteNoLevelBelow | Can't paste these elements at this height because there is no Level below to reference.
CannotPasteNoWorkplane | Can't paste because there is no corresponding Work Plane. Set workplane or switch to view with appropriate workplane.
CannotPasteRoomsInNonPlanViews | [Rooms] can only be pasted in Plan or Ceiling Plan views.
CannotPasteToSheet | Elements copied to Sheets can only be copied from other Sheets.
CannotPasteViewSpecElemsFromDiffViews | Cannot paste view-specific elements from different views.
CannotPasteViewSpecificElementsIntoPerspectiveView | Can't paste view specific elements into perspective view.
CannotTransferProjectStandards | These Project Standards cannot be transferred.[Description]
CantCopyBetweenModelAndAnnotFam | Can't copy element(s) between Model and Annotation families.
CantCopyElemsToInplaceFam | Can't copy element(s) to In Place family.
CantCopyFrom2dTo3dFam | Can't copy 2D element(s) into a 3D family.
CantCopyFrom3dTo2dFam | Can't copy 3D element(s) into a 2D family.
CantCopyFromDetailToProfileFam | Can't copy Detail element(s) into a Profile family.
CantCopyLevelsOrRefPlanesToNonMassFamily | Can't copy levels or reference planes to families that are not Mass families.
CantCopyStairsLevelHeightNotMatchInMS | Can't copy stairs in Multistory Stairs due to level height doesn't match.
CantCopySymbolicElementToSelfOrientingFamily | Cannot copy symbolic elements sketched in non-horizontal planes.
CopingColumnBeamFailure | The support order for a beam/column connection has been changed. When a beam is supported by a column that same beam cannot be coped by the column. The existing coping has been removed.
CopyImposterContentError | Cannot copy Render Appearance.
CopyImposterContentWarn | Cannot copy Render Appearance.
CopyImposterLightError | Light source cannot be copied!
CopyImposterLightWarn | Light source cannot be copied!
ElementRenamedOnPaste | The loaded type "[Name]" has been renamed to "[New Name]" to avoid conflicts with the existing type.
FinalizedElementsWillBeDeleted | Can't find new hosts for this Element.\nIt will be deleted on Finish Paste unless repositioned or rehosted.
FinalizedElementsWillBeDeletedWarn | Can't find new hosts for this Element.\nIt will be deleted on Finish Paste unless repositioned or rehosted.
FinalizedElementsWillBeModified | Can't find some new hosts for this Element.\nIt will lose references on Finish Paste unless repositioned or rehosted.
FinalizedElementsWillBeModifiedWarn | Can't find some new hosts for this Element.\nIt will lose references on Finish Paste unless repositioned or rehosted.
LostReference | A relationship between Elements in [Option Name] and [Reference Option Name] has been deleted. There is no corresponding relationship in the Primary [New Primary Option Name].
NoSketchPlane | Can't paste because no Work Plane is defined in the View.
PasteInvisibleInView | Selection is invisible in this view.
SomeElementsNotCopiedWarn | Some elements were not copied.[Description]
Top
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotCopyAttachedType Property

BuiltInFailuresCopyPasteFailuresCannotCopyAttachedType Property

Cannot copy attached detail group type without copying the model group type it refers to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyAttachedType { get; }
Public Shared ReadOnly Property CannotCopyAttachedType As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyAttachedType {
    FailureDefinitionId^ get ();
}
static member CannotCopyAttachedType : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotCopyAttachedTypeWarn Property

BuiltInFailuresCopyPasteFailuresCannotCopyAttachedTypeWarn Property

Cannot copy attached detail group type without copying the model group type it refers to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyAttachedTypeWarn { get; }
Public Shared ReadOnly Property CannotCopyAttachedTypeWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyAttachedTypeWarn {
    FailureDefinitionId^ get ();
}
static member CannotCopyAttachedTypeWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotCopyBetweenFamilyAndProjectCorruption Property

BuiltInFailuresCopyPasteFailuresCannotCopyBetweenFamilyAndProjectCorruption Property

Can't copy between Family and Project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyBetweenFamilyAndProjectCorruption { get; }
Public Shared ReadOnly Property CannotCopyBetweenFamilyAndProjectCorruption As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyBetweenFamilyAndProjectCorruption {
    FailureDefinitionId^ get ();
}
static member CannotCopyBetweenFamilyAndProjectCorruption : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotCopyBetweenFamilyAndProjectError Property

BuiltInFailuresCopyPasteFailuresCannotCopyBetweenFamilyAndProjectError Property

Can't copy between Family and Project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyBetweenFamilyAndProjectError { get; }
Public Shared ReadOnly Property CannotCopyBetweenFamilyAndProjectError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyBetweenFamilyAndProjectError {
    FailureDefinitionId^ get ();
}
static member CannotCopyBetweenFamilyAndProjectError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotCopyCurtainWallGridLines Property

BuiltInFailuresCopyPasteFailuresCannotCopyCurtainWallGridLines Property

Curtain wall grid lines currently cannot be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyCurtainWallGridLines { get; }
Public Shared ReadOnly Property CannotCopyCurtainWallGridLines As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyCurtainWallGridLines {
    FailureDefinitionId^ get ();
}
static member CannotCopyCurtainWallGridLines : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotCopyDependentView Property

BuiltInFailuresCopyPasteFailuresCannotCopyDependentView Property

Dependent views cannot be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyDependentView { get; }
Public Shared ReadOnly Property CannotCopyDependentView As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyDependentView {
    FailureDefinitionId^ get ();
}
static member CannotCopyDependentView : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotCopyDetails Property

BuiltInFailuresCopyPasteFailuresCannotCopyDetails Property

Can't copy some or all of the detailing with the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyDetails { get; }
Public Shared ReadOnly Property CannotCopyDetails As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyDetails {
    FailureDefinitionId^ get ();
}
static member CannotCopyDetails : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotCopyDueToBackgroundCalculation Property

BuiltInFailuresCopyPasteFailuresCannotCopyDueToBackgroundCalculation Property

Cannot copy dragged elements while background calculations are in progress.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyDueToBackgroundCalculation { get; }
Public Shared ReadOnly Property CannotCopyDueToBackgroundCalculation As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyDueToBackgroundCalculation {
    FailureDefinitionId^ get ();
}
static member CannotCopyDueToBackgroundCalculation : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotCopyDuplicates Property

BuiltInFailuresCopyPasteFailuresCannotCopyDuplicates Property

Can't paste duplicate types. Only non duplicate types will be pasted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyDuplicates { get; }
Public Shared ReadOnly Property CannotCopyDuplicates As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyDuplicates {
    FailureDefinitionId^ get ();
}
static member CannotCopyDuplicates : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotCopyElevationArrow Property

BuiltInFailuresCopyPasteFailuresCannotCopyElevationArrow Property

To duplicate Elevations, copy the elevation symbol in a plan view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyElevationArrow { get; }
Public Shared ReadOnly Property CannotCopyElevationArrow As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyElevationArrow {
    FailureDefinitionId^ get ();
}
static member CannotCopyElevationArrow : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotCopyElevationArrowWarn Property

BuiltInFailuresCopyPasteFailuresCannotCopyElevationArrowWarn Property

To duplicate Elevations, copy the elevation symbol in a plan view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyElevationArrowWarn { get; }
Public Shared ReadOnly Property CannotCopyElevationArrowWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyElevationArrowWarn {
    FailureDefinitionId^ get ();
}
static member CannotCopyElevationArrowWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotCopyFamilyName Property

BuiltInFailuresCopyPasteFailuresCannotCopyFamilyName Property

Can't [Action] because Family '[Family Name]' is different in the two documents. Update the documents to contain the same version of the Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyFamilyName { get; }
Public Shared ReadOnly Property CannotCopyFamilyName As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyFamilyName {
    FailureDefinitionId^ get ();
}
static member CannotCopyFamilyName : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotCopyFromProjectAndLink Property

BuiltInFailuresCopyPasteFailuresCannotCopyFromProjectAndLink Property

Can't Copy to Clipboard elements from the project and a link instance at the same time. Only elements from the project will be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyFromProjectAndLink { get; }
Public Shared ReadOnly Property CannotCopyFromProjectAndLink As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyFromProjectAndLink {
    FailureDefinitionId^ get ();
}
static member CannotCopyFromProjectAndLink : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotCopyGridLines Property

BuiltInFailuresCopyPasteFailuresCannotCopyGridLines Property

Curtain grid lines cannot be copied. If you are trying to copy the curtain wall, try using tab to select entire wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyGridLines { get; }
Public Shared ReadOnly Property CannotCopyGridLines As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyGridLines {
    FailureDefinitionId^ get ();
}
static member CannotCopyGridLines : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotCopyGridLinesWarn Property

BuiltInFailuresCopyPasteFailuresCannotCopyGridLinesWarn Property

Curtain grid lines cannot be copied. If you are trying to copy the curtain wall, try using tab to select entire wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyGridLinesWarn { get; }
Public Shared ReadOnly Property CannotCopyGridLinesWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyGridLinesWarn {
    FailureDefinitionId^ get ();
}
static member CannotCopyGridLinesWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotCopyImportInstancesAcrossProjects Property

BuiltInFailuresCopyPasteFailuresCannotCopyImportInstancesAcrossProjects Property

Linked Imported Files cannot be copied across projects. All non-RVT linked files will be pasted as imports instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyImportInstancesAcrossProjects { get; }
Public Shared ReadOnly Property CannotCopyImportInstancesAcrossProjects As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyImportInstancesAcrossProjects {
    FailureDefinitionId^ get ();
}
static member CannotCopyImportInstancesAcrossProjects : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotCopyIncompleteElement Property

BuiltInFailuresCopyPasteFailuresCannotCopyIncompleteElement Property

Can't copy part of element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyIncompleteElement { get; }
Public Shared ReadOnly Property CannotCopyIncompleteElement As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyIncompleteElement {
    FailureDefinitionId^ get ();
}
static member CannotCopyIncompleteElement : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotCopyIncompleteElementWarn Property

BuiltInFailuresCopyPasteFailuresCannotCopyIncompleteElementWarn Property

Can't copy part of element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyIncompleteElementWarn { get; }
Public Shared ReadOnly Property CannotCopyIncompleteElementWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyIncompleteElementWarn {
    FailureDefinitionId^ get ();
}
static member CannotCopyIncompleteElementWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotCopyJoinedGeometry Property

BuiltInFailuresCopyPasteFailuresCannotCopyJoinedGeometry Property

Joined solid geometry cannot be copied as a whole. Instead, select the individual extrusions, etc., using Pick box or Ctrl-select and copy them.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyJoinedGeometry { get; }
Public Shared ReadOnly Property CannotCopyJoinedGeometry As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyJoinedGeometry {
    FailureDefinitionId^ get ();
}
static member CannotCopyJoinedGeometry : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotCopyJoinedGeometryWarn Property

BuiltInFailuresCopyPasteFailuresCannotCopyJoinedGeometryWarn Property

Joined solid geometry cannot be copied as a whole. Instead, select the individual extrusions, etc., using Pick box or Ctrl-select and copy them.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyJoinedGeometryWarn { get; }
Public Shared ReadOnly Property CannotCopyJoinedGeometryWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyJoinedGeometryWarn {
    FailureDefinitionId^ get ();
}
static member CannotCopyJoinedGeometryWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotCopyLocked Property

BuiltInFailuresCopyPasteFailuresCannotCopyLocked Property

Can't copy pinned element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyLocked { get; }
Public Shared ReadOnly Property CannotCopyLocked As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyLocked {
    FailureDefinitionId^ get ();
}
static member CannotCopyLocked : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotCopyLockedWarn Property

BuiltInFailuresCopyPasteFailuresCannotCopyLockedWarn Property

Can't copy pinned element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyLockedWarn { get; }
Public Shared ReadOnly Property CannotCopyLockedWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyLockedWarn {
    FailureDefinitionId^ get ();
}
static member CannotCopyLockedWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotCopyMassing Property

BuiltInFailuresCopyPasteFailuresCannotCopyMassing Property

A massing cannot be copied. Copy the elements within the massing instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyMassing { get; }
Public Shared ReadOnly Property CannotCopyMassing As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyMassing {
    FailureDefinitionId^ get ();
}
static member CannotCopyMassing : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotCopyMassingWarn Property

BuiltInFailuresCopyPasteFailuresCannotCopyMassingWarn Property

A massing cannot be copied. Copy the elements within the massing instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyMassingWarn { get; }
Public Shared ReadOnly Property CannotCopyMassingWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyMassingWarn {
    FailureDefinitionId^ get ();
}
static member CannotCopyMassingWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotCopyMullions Property

BuiltInFailuresCopyPasteFailuresCannotCopyMullions Property

Mullions and panels cannot be copied without copying the entire curtain wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyMullions { get; }
Public Shared ReadOnly Property CannotCopyMullions As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyMullions {
    FailureDefinitionId^ get ();
}
static member CannotCopyMullions : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotCopyMullionsError Property

BuiltInFailuresCopyPasteFailuresCannotCopyMullionsError Property

Mullions and panels cannot be copied without copying the entire curtain wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyMullionsError { get; }
Public Shared ReadOnly Property CannotCopyMullionsError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyMullionsError {
    FailureDefinitionId^ get ();
}
static member CannotCopyMullionsError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotCopyMullionsWarn Property

BuiltInFailuresCopyPasteFailuresCannotCopyMullionsWarn Property

Mullions and panels cannot be copied without copying the entire curtain wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyMullionsWarn { get; }
Public Shared ReadOnly Property CannotCopyMullionsWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyMullionsWarn {
    FailureDefinitionId^ get ();
}
static member CannotCopyMullionsWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotCopyMultipleSketchParents Property

BuiltInFailuresCopyPasteFailuresCannotCopyMultipleSketchParents Property

Copying elements from unrelated Workplanes together is not supported in families. Try copying elements separately.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyMultipleSketchParents { get; }
Public Shared ReadOnly Property CannotCopyMultipleSketchParents As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyMultipleSketchParents {
    FailureDefinitionId^ get ();
}
static member CannotCopyMultipleSketchParents : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotCopyMustBeUnique Property

BuiltInFailuresCopyPasteFailuresCannotCopyMustBeUnique Property

Element must be unique.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyMustBeUnique { get; }
Public Shared ReadOnly Property CannotCopyMustBeUnique As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyMustBeUnique {
    FailureDefinitionId^ get ();
}
static member CannotCopyMustBeUnique : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotCopyMustBeUniqueWarn Property

BuiltInFailuresCopyPasteFailuresCannotCopyMustBeUniqueWarn Property

Element must be unique.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyMustBeUniqueWarn { get; }
Public Shared ReadOnly Property CannotCopyMustBeUniqueWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyMustBeUniqueWarn {
    FailureDefinitionId^ get ();
}
static member CannotCopyMustBeUniqueWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotCopyNestedLinks Property

BuiltInFailuresCopyPasteFailuresCannotCopyNestedLinks Property

To copy a nested link, use Copy to Clipboard or Move Copy.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyNestedLinks { get; }
Public Shared ReadOnly Property CannotCopyNestedLinks As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyNestedLinks {
    FailureDefinitionId^ get ();
}
static member CannotCopyNestedLinks : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotCopyNoAttachedParent Property

BuiltInFailuresCopyPasteFailuresCannotCopyNoAttachedParent Property

Attached Detail Group can't be copied without its Model Group

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyNoAttachedParent { get; }
Public Shared ReadOnly Property CannotCopyNoAttachedParent As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyNoAttachedParent {
    FailureDefinitionId^ get ();
}
static member CannotCopyNoAttachedParent : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotCopyNoAttachedParentWarn Property

BuiltInFailuresCopyPasteFailuresCannotCopyNoAttachedParentWarn Property

Attached Detail Group can't be copied without its Model Group

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyNoAttachedParentWarn { get; }
Public Shared ReadOnly Property CannotCopyNoAttachedParentWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyNoAttachedParentWarn {
    FailureDefinitionId^ get ();
}
static member CannotCopyNoAttachedParentWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotCopyNoParents Property

BuiltInFailuresCopyPasteFailuresCannotCopyNoParents Property

Can't Copy to Clipboard because of relationships between Elements

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyNoParents { get; }
Public Shared ReadOnly Property CannotCopyNoParents As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyNoParents {
    FailureDefinitionId^ get ();
}
static member CannotCopyNoParents : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotCopyNoReferences Property

BuiltInFailuresCopyPasteFailuresCannotCopyNoReferences Property

Elements can't be copied because they will lose their References.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyNoReferences { get; }
Public Shared ReadOnly Property CannotCopyNoReferences As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyNoReferences {
    FailureDefinitionId^ get ();
}
static member CannotCopyNoReferences : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotCopyRevolveAxis Property

BuiltInFailuresCopyPasteFailuresCannotCopyRevolveAxis Property

The axis cannot be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyRevolveAxis { get; }
Public Shared ReadOnly Property CannotCopyRevolveAxis As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyRevolveAxis {
    FailureDefinitionId^ get ();
}
static member CannotCopyRevolveAxis : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotCopyRevolveAxisWarn Property

BuiltInFailuresCopyPasteFailuresCannotCopyRevolveAxisWarn Property

The axis cannot be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyRevolveAxisWarn { get; }
Public Shared ReadOnly Property CannotCopyRevolveAxisWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyRevolveAxisWarn {
    FailureDefinitionId^ get ();
}
static member CannotCopyRevolveAxisWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotCopySelectedPick Property

BuiltInFailuresCopyPasteFailuresCannotCopySelectedPick Property

The element being dragged can't be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopySelectedPick { get; }
Public Shared ReadOnly Property CannotCopySelectedPick As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopySelectedPick {
    FailureDefinitionId^ get ();
}
static member CannotCopySelectedPick : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotCopySelection Property

BuiltInFailuresCopyPasteFailuresCannotCopySelection Property

Cannot copy selection.[Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopySelection { get; }
Public Shared ReadOnly Property CannotCopySelection As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopySelection {
    FailureDefinitionId^ get ();
}
static member CannotCopySelection : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotCopySketchGrid Property

BuiltInFailuresCopyPasteFailuresCannotCopySketchGrid Property

Work Planes cannot be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopySketchGrid { get; }
Public Shared ReadOnly Property CannotCopySketchGrid As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopySketchGrid {
    FailureDefinitionId^ get ();
}
static member CannotCopySketchGrid : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotCopySketchGridWarn Property

BuiltInFailuresCopyPasteFailuresCannotCopySketchGridWarn Property

Work Planes cannot be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopySketchGridWarn { get; }
Public Shared ReadOnly Property CannotCopySketchGridWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopySketchGridWarn {
    FailureDefinitionId^ get ();
}
static member CannotCopySketchGridWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotCopySunAndShadowSettings Property

BuiltInFailuresCopyPasteFailuresCannotCopySunAndShadowSettings Property

SunAndShadowSettings cannot be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopySunAndShadowSettings { get; }
Public Shared ReadOnly Property CannotCopySunAndShadowSettings As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopySunAndShadowSettings {
    FailureDefinitionId^ get ();
}
static member CannotCopySunAndShadowSettings : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotCopySunAndShadowSettingsWarn Property

BuiltInFailuresCopyPasteFailuresCannotCopySunAndShadowSettingsWarn Property

SunAndShadowSettings cannot be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopySunAndShadowSettingsWarn { get; }
Public Shared ReadOnly Property CannotCopySunAndShadowSettingsWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopySunAndShadowSettingsWarn {
    FailureDefinitionId^ get ();
}
static member CannotCopySunAndShadowSettingsWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotCopyWallPanels Property

BuiltInFailuresCopyPasteFailuresCannotCopyWallPanels Property

Cannot copy wall panels unless their parent wall is also being copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyWallPanels { get; }
Public Shared ReadOnly Property CannotCopyWallPanels As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyWallPanels {
    FailureDefinitionId^ get ();
}
static member CannotCopyWallPanels : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotCopyWallPanelsWarn Property

BuiltInFailuresCopyPasteFailuresCannotCopyWallPanelsWarn Property

Cannot copy wall panels unless their parent wall is also being copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyWallPanelsWarn { get; }
Public Shared ReadOnly Property CannotCopyWallPanelsWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyWallPanelsWarn {
    FailureDefinitionId^ get ();
}
static member CannotCopyWallPanelsWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotCopyZone Property

BuiltInFailuresCopyPasteFailuresCannotCopyZone Property

A Zone cannot be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyZone { get; }
Public Shared ReadOnly Property CannotCopyZone As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyZone {
    FailureDefinitionId^ get ();
}
static member CannotCopyZone : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotCopyZoneWarn Property

BuiltInFailuresCopyPasteFailuresCannotCopyZoneWarn Property

A Zone cannot be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyZoneWarn { get; }
Public Shared ReadOnly Property CannotCopyZoneWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyZoneWarn {
    FailureDefinitionId^ get ();
}
static member CannotCopyZoneWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotDuplicate Property

BuiltInFailuresCopyPasteFailuresCannotDuplicate Property

Elements can't be duplicated

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotDuplicate { get; }
Public Shared ReadOnly Property CannotDuplicate As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotDuplicate {
    FailureDefinitionId^ get ();
}
static member CannotDuplicate : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotDuplicateDesignOption Property

BuiltInFailuresCopyPasteFailuresCannotDuplicateDesignOption Property

Can't duplicate Design Option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotDuplicateDesignOption { get; }
Public Shared ReadOnly Property CannotDuplicateDesignOption As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotDuplicateDesignOption {
    FailureDefinitionId^ get ();
}
static member CannotDuplicateDesignOption : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotDuplicateInOption Property

BuiltInFailuresCopyPasteFailuresCannotDuplicateInOption Property

Elements can't be duplicated in a secondary Option

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotDuplicateInOption { get; }
Public Shared ReadOnly Property CannotDuplicateInOption As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotDuplicateInOption {
    FailureDefinitionId^ get ();
}
static member CannotDuplicateInOption : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotDuplicateInOptionWarn Property

BuiltInFailuresCopyPasteFailuresCannotDuplicateInOptionWarn Property

Elements can't be duplicated in a secondary Option

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotDuplicateInOptionWarn { get; }
Public Shared ReadOnly Property CannotDuplicateInOptionWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotDuplicateInOptionWarn {
    FailureDefinitionId^ get ();
}
static member CannotDuplicateInOptionWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotDuplicateType Property

BuiltInFailuresCopyPasteFailuresCannotDuplicateType Property

Cannot Duplicate Type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotDuplicateType { get; }
Public Shared ReadOnly Property CannotDuplicateType As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotDuplicateType {
    FailureDefinitionId^ get ();
}
static member CannotDuplicateType : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotDuplicateWarn Property

BuiltInFailuresCopyPasteFailuresCannotDuplicateWarn Property

Elements can't be duplicated

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotDuplicateWarn { get; }
Public Shared ReadOnly Property CannotDuplicateWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotDuplicateWarn {
    FailureDefinitionId^ get ();
}
static member CannotDuplicateWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotFinalizeClusterInconsistency Property

BuiltInFailuresCopyPasteFailuresCannotFinalizeClusterInconsistency Property

Can't finalize because dependent element failed to finalize.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotFinalizeClusterInconsistency { get; }
Public Shared ReadOnly Property CannotFinalizeClusterInconsistency As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotFinalizeClusterInconsistency {
    FailureDefinitionId^ get ();
}
static member CannotFinalizeClusterInconsistency : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotFinalizeOrphanSerf Property

BuiltInFailuresCopyPasteFailuresCannotFinalizeOrphanSerf Property

Can't finalize Group member without finalizing the entire Group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotFinalizeOrphanSerf { get; }
Public Shared ReadOnly Property CannotFinalizeOrphanSerf As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotFinalizeOrphanSerf {
    FailureDefinitionId^ get ();
}
static member CannotFinalizeOrphanSerf : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotPasteAlignedAny Property

BuiltInFailuresCopyPasteFailuresCannotPasteAlignedAny Property

Can't Paste Aligned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPasteAlignedAny { get; }
Public Shared ReadOnly Property CannotPasteAlignedAny As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPasteAlignedAny {
    FailureDefinitionId^ get ();
}
static member CannotPasteAlignedAny : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotPasteAlignedCorruption Property

BuiltInFailuresCopyPasteFailuresCannotPasteAlignedCorruption Property

Can't Paste Aligned these elements in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPasteAlignedCorruption { get; }
Public Shared ReadOnly Property CannotPasteAlignedCorruption As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPasteAlignedCorruption {
    FailureDefinitionId^ get ();
}
static member CannotPasteAlignedCorruption : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotPasteAlignedError Property

BuiltInFailuresCopyPasteFailuresCannotPasteAlignedError Property

Can't Paste Align these elements in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPasteAlignedError { get; }
Public Shared ReadOnly Property CannotPasteAlignedError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPasteAlignedError {
    FailureDefinitionId^ get ();
}
static member CannotPasteAlignedError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotPasteAlignedSomeLevels Property

BuiltInFailuresCopyPasteFailuresCannotPasteAlignedSomeLevels Property

Can't Paste Aligned to some views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPasteAlignedSomeLevels { get; }
Public Shared ReadOnly Property CannotPasteAlignedSomeLevels As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPasteAlignedSomeLevels {
    FailureDefinitionId^ get ();
}
static member CannotPasteAlignedSomeLevels : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotPasteAssemblyView Property

BuiltInFailuresCopyPasteFailuresCannotPasteAssemblyView Property

Can't paste assembly view because its associated assembly instance is not available.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPasteAssemblyView { get; }
Public Shared ReadOnly Property CannotPasteAssemblyView As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPasteAssemblyView {
    FailureDefinitionId^ get ();
}
static member CannotPasteAssemblyView : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotPasteCircularLinks Property

BuiltInFailuresCopyPasteFailuresCannotPasteCircularLinks Property

The pasted selection includes a linked instance of this file '[Name]'. A file cannot link itself, so the link was not pasted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPasteCircularLinks { get; }
Public Shared ReadOnly Property CannotPasteCircularLinks As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPasteCircularLinks {
    FailureDefinitionId^ get ();
}
static member CannotPasteCircularLinks : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotPasteCurtainGridLine Property

BuiltInFailuresCopyPasteFailuresCannotPasteCurtainGridLine Property

Can't paste Curtain Grid Line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPasteCurtainGridLine { get; }
Public Shared ReadOnly Property CannotPasteCurtainGridLine As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPasteCurtainGridLine {
    FailureDefinitionId^ get ();
}
static member CannotPasteCurtainGridLine : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotPasteDifferentViewSpecificElements Property

BuiltInFailuresCopyPasteFailuresCannotPasteDifferentViewSpecificElements Property

Cannot paste view-specific elements from different views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPasteDifferentViewSpecificElements { get; }
Public Shared ReadOnly Property CannotPasteDifferentViewSpecificElements As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPasteDifferentViewSpecificElements {
    FailureDefinitionId^ get ();
}
static member CannotPasteDifferentViewSpecificElements : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotPasteElemInViewError Property

BuiltInFailuresCopyPasteFailuresCannotPasteElemInViewError Property

Cannot paste the contents into %1!s! view. Attempt to paste into an appropriate view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPasteElemInViewError { get; }
Public Shared ReadOnly Property CannotPasteElemInViewError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPasteElemInViewError {
    FailureDefinitionId^ get ();
}
static member CannotPasteElemInViewError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotPasteInSketch Property

BuiltInFailuresCopyPasteFailuresCannotPasteInSketch Property

Can't paste elements into sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPasteInSketch { get; }
Public Shared ReadOnly Property CannotPasteInSketch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPasteInSketch {
    FailureDefinitionId^ get ();
}
static member CannotPasteInSketch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotPasteInView Property

BuiltInFailuresCopyPasteFailuresCannotPasteInView Property

Cannot paste the contents into %1!s! view. Attempt to paste into an appropriate view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPasteInView { get; }
Public Shared ReadOnly Property CannotPasteInView As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPasteInView {
    FailureDefinitionId^ get ();
}
static member CannotPasteInView : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotPasteInViewError Property

BuiltInFailuresCopyPasteFailuresCannotPasteInViewError Property

Cannot paste the contents into %1!s! view. Attempt to paste into an appropriate view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPasteInViewError { get; }
Public Shared ReadOnly Property CannotPasteInViewError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPasteInViewError {
    FailureDefinitionId^ get ();
}
static member CannotPasteInViewError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotPasteModelPlusViewSpecificElementsIntoView Property

BuiltInFailuresCopyPasteFailuresCannotPasteModelPlusViewSpecificElementsIntoView Property

Cannot paste view-specific model plus into view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPasteModelPlusViewSpecificElementsIntoView { get; }
Public Shared ReadOnly Property CannotPasteModelPlusViewSpecificElementsIntoView As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPasteModelPlusViewSpecificElementsIntoView {
    FailureDefinitionId^ get ();
}
static member CannotPasteModelPlusViewSpecificElementsIntoView : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotPasteNoLevelAbove Property

BuiltInFailuresCopyPasteFailuresCannotPasteNoLevelAbove Property

Can't paste these elements at this height because there is no Level above to Reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPasteNoLevelAbove { get; }
Public Shared ReadOnly Property CannotPasteNoLevelAbove As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPasteNoLevelAbove {
    FailureDefinitionId^ get ();
}
static member CannotPasteNoLevelAbove : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotPasteNoLevelBelow Property

BuiltInFailuresCopyPasteFailuresCannotPasteNoLevelBelow Property

Can't paste these elements at this height because there is no Level below to reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPasteNoLevelBelow { get; }
Public Shared ReadOnly Property CannotPasteNoLevelBelow As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPasteNoLevelBelow {
    FailureDefinitionId^ get ();
}
static member CannotPasteNoLevelBelow : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotPasteNoWorkplane Property

BuiltInFailuresCopyPasteFailuresCannotPasteNoWorkplane Property

Can't paste because there is no corresponding Work Plane. Set workplane or switch to view with appropriate workplane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPasteNoWorkplane { get; }
Public Shared ReadOnly Property CannotPasteNoWorkplane As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPasteNoWorkplane {
    FailureDefinitionId^ get ();
}
static member CannotPasteNoWorkplane : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotPasteRoomsInNonPlanViews Property

BuiltInFailuresCopyPasteFailuresCannotPasteRoomsInNonPlanViews Property

[Rooms] can only be pasted in Plan or Ceiling Plan views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPasteRoomsInNonPlanViews { get; }
Public Shared ReadOnly Property CannotPasteRoomsInNonPlanViews As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPasteRoomsInNonPlanViews {
    FailureDefinitionId^ get ();
}
static member CannotPasteRoomsInNonPlanViews : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotPasteToSheet Property

BuiltInFailuresCopyPasteFailuresCannotPasteToSheet Property

Elements copied to Sheets can only be copied from other Sheets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPasteToSheet { get; }
Public Shared ReadOnly Property CannotPasteToSheet As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPasteToSheet {
    FailureDefinitionId^ get ();
}
static member CannotPasteToSheet : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotPasteViewSpecElemsFromDiffViews Property

BuiltInFailuresCopyPasteFailuresCannotPasteViewSpecElemsFromDiffViews Property

Cannot paste view-specific elements from different views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPasteViewSpecElemsFromDiffViews { get; }
Public Shared ReadOnly Property CannotPasteViewSpecElemsFromDiffViews As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPasteViewSpecElemsFromDiffViews {
    FailureDefinitionId^ get ();
}
static member CannotPasteViewSpecElemsFromDiffViews : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotPasteViewSpecificElementsIntoPerspectiveView Property

BuiltInFailuresCopyPasteFailuresCannotPasteViewSpecificElementsIntoPerspectiveView Property

Can't paste view specific elements into perspective view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPasteViewSpecificElementsIntoPerspectiveView { get; }
Public Shared ReadOnly Property CannotPasteViewSpecificElementsIntoPerspectiveView As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPasteViewSpecificElementsIntoPerspectiveView {
    FailureDefinitionId^ get ();
}
static member CannotPasteViewSpecificElementsIntoPerspectiveView : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CannotTransferProjectStandards Property

BuiltInFailuresCopyPasteFailuresCannotTransferProjectStandards Property

These Project Standards cannot be transferred.[Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotTransferProjectStandards { get; }
Public Shared ReadOnly Property CannotTransferProjectStandards As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotTransferProjectStandards {
    FailureDefinitionId^ get ();
}
static member CannotTransferProjectStandards : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CantCopyBetweenModelAndAnnotFam Property

BuiltInFailuresCopyPasteFailuresCantCopyBetweenModelAndAnnotFam Property

Can't copy element(s) between Model and Annotation families.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CantCopyBetweenModelAndAnnotFam { get; }
Public Shared ReadOnly Property CantCopyBetweenModelAndAnnotFam As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CantCopyBetweenModelAndAnnotFam {
    FailureDefinitionId^ get ();
}
static member CantCopyBetweenModelAndAnnotFam : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CantCopyElemsToInplaceFam Property

BuiltInFailuresCopyPasteFailuresCantCopyElemsToInplaceFam Property

Can't copy element(s) to In Place family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CantCopyElemsToInplaceFam { get; }
Public Shared ReadOnly Property CantCopyElemsToInplaceFam As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CantCopyElemsToInplaceFam {
    FailureDefinitionId^ get ();
}
static member CantCopyElemsToInplaceFam : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CantCopyFrom2dTo3dFam Property

BuiltInFailuresCopyPasteFailuresCantCopyFrom2dTo3dFam Property

Can't copy 2D element(s) into a 3D family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CantCopyFrom2dTo3dFam { get; }
Public Shared ReadOnly Property CantCopyFrom2dTo3dFam As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CantCopyFrom2dTo3dFam {
    FailureDefinitionId^ get ();
}
static member CantCopyFrom2dTo3dFam : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CantCopyFrom3dTo2dFam Property

BuiltInFailuresCopyPasteFailuresCantCopyFrom3dTo2dFam Property

Can't copy 3D element(s) into a 2D family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CantCopyFrom3dTo2dFam { get; }
Public Shared ReadOnly Property CantCopyFrom3dTo2dFam As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CantCopyFrom3dTo2dFam {
    FailureDefinitionId^ get ();
}
static member CantCopyFrom3dTo2dFam : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CantCopyFromDetailToProfileFam Property

BuiltInFailuresCopyPasteFailuresCantCopyFromDetailToProfileFam Property

Can't copy Detail element(s) into a Profile family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CantCopyFromDetailToProfileFam { get; }
Public Shared ReadOnly Property CantCopyFromDetailToProfileFam As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CantCopyFromDetailToProfileFam {
    FailureDefinitionId^ get ();
}
static member CantCopyFromDetailToProfileFam : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CantCopyLevelsOrRefPlanesToNonMassFamily Property

BuiltInFailuresCopyPasteFailuresCantCopyLevelsOrRefPlanesToNonMassFamily Property

Can't copy levels or reference planes to families that are not Mass families.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CantCopyLevelsOrRefPlanesToNonMassFamily { get; }
Public Shared ReadOnly Property CantCopyLevelsOrRefPlanesToNonMassFamily As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CantCopyLevelsOrRefPlanesToNonMassFamily {
    FailureDefinitionId^ get ();
}
static member CantCopyLevelsOrRefPlanesToNonMassFamily : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CantCopyStairsLevelHeightNotMatchInMS Property

BuiltInFailuresCopyPasteFailuresCantCopyStairsLevelHeightNotMatchInMS Property

Can't copy stairs in Multistory Stairs due to level height doesn't match.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CantCopyStairsLevelHeightNotMatchInMS { get; }
Public Shared ReadOnly Property CantCopyStairsLevelHeightNotMatchInMS As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CantCopyStairsLevelHeightNotMatchInMS {
    FailureDefinitionId^ get ();
}
static member CantCopyStairsLevelHeightNotMatchInMS : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CantCopySymbolicElementToSelfOrientingFamily Property

BuiltInFailuresCopyPasteFailuresCantCopySymbolicElementToSelfOrientingFamily Property

Cannot copy symbolic elements sketched in non-horizontal planes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CantCopySymbolicElementToSelfOrientingFamily { get; }
Public Shared ReadOnly Property CantCopySymbolicElementToSelfOrientingFamily As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CantCopySymbolicElementToSelfOrientingFamily {
    FailureDefinitionId^ get ();
}
static member CantCopySymbolicElementToSelfOrientingFamily : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CopingColumnBeamFailure Property

BuiltInFailuresCopyPasteFailuresCopingColumnBeamFailure Property

The support order for a beam/column connection has been changed. When a beam is supported by a column that same beam cannot be coped by the column. The existing coping has been removed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CopingColumnBeamFailure { get; }
Public Shared ReadOnly Property CopingColumnBeamFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CopingColumnBeamFailure {
    FailureDefinitionId^ get ();
}
static member CopingColumnBeamFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CopyImposterContentError Property

BuiltInFailuresCopyPasteFailuresCopyImposterContentError Property

Cannot copy Render Appearance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CopyImposterContentError { get; }
Public Shared ReadOnly Property CopyImposterContentError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CopyImposterContentError {
    FailureDefinitionId^ get ();
}
static member CopyImposterContentError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CopyImposterContentWarn Property

BuiltInFailuresCopyPasteFailuresCopyImposterContentWarn Property

Cannot copy Render Appearance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CopyImposterContentWarn { get; }
Public Shared ReadOnly Property CopyImposterContentWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CopyImposterContentWarn {
    FailureDefinitionId^ get ();
}
static member CopyImposterContentWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CopyImposterLightError Property

BuiltInFailuresCopyPasteFailuresCopyImposterLightError Property

Light source cannot be copied!

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CopyImposterLightError { get; }
Public Shared ReadOnly Property CopyImposterLightError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CopyImposterLightError {
    FailureDefinitionId^ get ();
}
static member CopyImposterLightError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.CopyImposterLightWarn Property

BuiltInFailuresCopyPasteFailuresCopyImposterLightWarn Property

Light source cannot be copied!

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CopyImposterLightWarn { get; }
Public Shared ReadOnly Property CopyImposterLightWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CopyImposterLightWarn {
    FailureDefinitionId^ get ();
}
static member CopyImposterLightWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.ElementRenamedOnPaste Property

BuiltInFailuresCopyPasteFailuresElementRenamedOnPaste Property

The loaded type "[Name]" has been renamed to "[New Name]" to avoid conflicts with the existing type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ElementRenamedOnPaste { get; }
Public Shared ReadOnly Property ElementRenamedOnPaste As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ElementRenamedOnPaste {
    FailureDefinitionId^ get ();
}
static member ElementRenamedOnPaste : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.FinalizedElementsWillBeDeleted Property

BuiltInFailuresCopyPasteFailuresFinalizedElementsWillBeDeleted Property

Can't find new hosts for this Element.\nIt will be deleted on Finish Paste unless repositioned or rehosted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FinalizedElementsWillBeDeleted { get; }
Public Shared ReadOnly Property FinalizedElementsWillBeDeleted As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FinalizedElementsWillBeDeleted {
    FailureDefinitionId^ get ();
}
static member FinalizedElementsWillBeDeleted : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.FinalizedElementsWillBeDeletedWarn Property

BuiltInFailuresCopyPasteFailuresFinalizedElementsWillBeDeletedWarn Property

Can't find new hosts for this Element.\nIt will be deleted on Finish Paste unless repositioned or rehosted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FinalizedElementsWillBeDeletedWarn { get; }
Public Shared ReadOnly Property FinalizedElementsWillBeDeletedWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FinalizedElementsWillBeDeletedWarn {
    FailureDefinitionId^ get ();
}
static member FinalizedElementsWillBeDeletedWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.FinalizedElementsWillBeModified Property

BuiltInFailuresCopyPasteFailuresFinalizedElementsWillBeModified Property

Can't find some new hosts for this Element.\nIt will lose references on Finish Paste unless repositioned or rehosted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FinalizedElementsWillBeModified { get; }
Public Shared ReadOnly Property FinalizedElementsWillBeModified As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FinalizedElementsWillBeModified {
    FailureDefinitionId^ get ();
}
static member FinalizedElementsWillBeModified : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.FinalizedElementsWillBeModifiedWarn Property

BuiltInFailuresCopyPasteFailuresFinalizedElementsWillBeModifiedWarn Property

Can't find some new hosts for this Element.\nIt will lose references on Finish Paste unless repositioned or rehosted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FinalizedElementsWillBeModifiedWarn { get; }
Public Shared ReadOnly Property FinalizedElementsWillBeModifiedWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FinalizedElementsWillBeModifiedWarn {
    FailureDefinitionId^ get ();
}
static member FinalizedElementsWillBeModifiedWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.LostReference Property

BuiltInFailuresCopyPasteFailuresLostReference Property

A relationship between Elements in [Option Name] and [Reference Option Name] has been deleted. There is no corresponding relationship in the Primary [New Primary Option Name].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LostReference { get; }
Public Shared ReadOnly Property LostReference As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LostReference {
    FailureDefinitionId^ get ();
}
static member LostReference : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.NoSketchPlane Property

BuiltInFailuresCopyPasteFailuresNoSketchPlane Property

Can't paste because no Work Plane is defined in the View.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoSketchPlane { get; }
Public Shared ReadOnly Property NoSketchPlane As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoSketchPlane {
    FailureDefinitionId^ get ();
}
static member NoSketchPlane : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.PasteInvisibleInView Property

BuiltInFailuresCopyPasteFailuresPasteInvisibleInView Property

Selection is invisible in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PasteInvisibleInView { get; }
Public Shared ReadOnly Property PasteInvisibleInView As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PasteInvisibleInView {
    FailureDefinitionId^ get ();
}
static member PasteInvisibleInView : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CopyPasteFailures.SomeElementsNotCopiedWarn Property

BuiltInFailuresCopyPasteFailuresSomeElementsNotCopiedWarn Property

Some elements were not copied.[Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SomeElementsNotCopiedWarn { get; }
Public Shared ReadOnly Property SomeElementsNotCopiedWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SomeElementsNotCopiedWarn {
    FailureDefinitionId^ get ();
}
static member SomeElementsNotCopiedWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCopyPasteFailures Class


BuiltInFailures.CreationFailures Class

BuiltInFailuresCreationFailures Class

Failures about CreationFailures.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresCreationFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class CreationFailures
Public NotInheritable Class CreationFailures
public ref class CreationFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CreationFailures = class end

The BuiltInFailuresCreationFailures type exposes the following members.

Properties
Name | Description
CannotCreateCornice | Could not create Wall Sweep. [Description]
CannotCreateCorniceError | Could not create Wall Sweep. [Description]
CannotCreateCorniceIntegral | Could not create integral wall sweep for wall instance. [Description]
CannotCreateCorniceIntegralError | Could not create integral wall sweep for wall instance. [Description]
CannotCreateCorniceIntegralWarn | Could not create integral wall sweep for wall instance. [Description]
CannotCreateCorniceWarn | Could not create Wall Sweep. [Description]
CannotCreateCurtainGrid | Can't create Curtain Wall Grid Line.
CannotCreateCutout | Can't make cut-out.
CannotCreateCutoutError | Can't make cut-out.
CannotCreateCutoutWarn | Can't make cut-out.
CannotCreateElementInFamily | Can't create element in this family.
CannotCreateElementInView | Can't create this kind of element in this view in the current mode.
CannotCreateExplicitCrease | Cannot create a new split line based on the picked support.
CannotCreateFascia | Could not create Fascia. [Description]
CannotCreateFasciaError | Could not create Fascia. [Description]
CannotCreateFasciaWarn | Could not create Fascia. [Description]
CannotCreateGutter | Could not create Gutter. [Description]
CannotCreateGutterError | Could not create Gutter. [Description]
CannotCreateGutterWarn | Could not create Gutter. [Description]
CannotCreateMullion | Can't create Mullion.
CannotCreateMullionError | Can't create Mullion.
CannotCreateMullionReference | Can't create Curtain Wall Mullion. The grid segment for the Mullion is probably too small.
CannotCreateMullionReferenceNoGeometry | Can't create Curtain Wall Mullion. The portion of the curtain grid it was placed on no longer exists.
CannotCreateNewDesignOption | Cannot create a new empty design option
CannotCreateOldCornerMullion | Cannot change the type of a mullion created prior to release 4.0 to a corner mullion type. Try deleting the existing mullion and placing a new one.
CannotCreateOpening | Cannot create opening.
CannotCreateOpeningCutOut | Can't create Opening cut.
CannotCreateOpeningRectangularArcWall | Creation of a Rectangular Arc Wall Opening failed.
CannotCreateReveal | Could not create Reveal. [Description]
CannotCreateRevealError | Could not create Reveal. [Description]
CannotCreateRevealIntegral | Could not create integral reveal for wall instance. [Description]
CannotCreateRevealIntegralError | Could not create integral reveal for wall instance. [Description]
CannotCreateRevealIntegralWarn | Could not create integral reveal for wall instance. [Description]
CannotCreateRevealWarn | Could not create Reveal. [Description]
CannotCreateSlabEdge | Could not create Slab Edge. [Description]
CannotCreateSlabEdgeError | Could not create Slab Edge. [Description]
CannotCreateSlabEdgeWarn | Could not create Slab Edge. [Description]
CannotCreateSlantedWallWithSingularLayers | Cannot create wall - its layers would degenerate or intersect. Reduce the wall's height or slant.
CannotCreateSlantedWallWithSingularLayersError | Cannot create wall - its layers would degenerate or. Reduce the wall's height or slant.
CannotCreateSystemPanel | Can't create Curtain Panel in opening. The opening is probably too small.
CannotCreateTaperedWallForWallType | Cannot create tapered wall - the Wall Type is unacceptable. Be sure to choose a variable-thickness layer in the Wall Type.
CannotCreateTaperedWallForWallTypeError | Cannot create tapered wall - the Wall Type is unacceptable. Be sure to choose a variable-thickness layer in the Wall Type.
CannotCreateThis | Can't create [Element].
CannotDrawProfileRoof | Can't make footprint roof.
CannotDrawRoof | Can't make roof.
CannotDrawRoofError | Can't make roof.
CannotDrawRoofWall | Can't make roof.
CannotDrawSingularSlantedWall | Cannot create wall - it would intersect itself. Reduce the wall's height or slant.
CannotDrawSingularSlantedWallError | Cannot create wall - it would intersect itself. Reduce the wall's height or slant.
CannotDrawToposolid | Can't make toposolid.
CannotDrawToposolidError | Can't make toposolid.
CannotDrawWalls | Can't make Wall.
CannotDrawWallsError | Can't make Wall.
CannotMakeRoofFromVerticalFace | Can't make roof from vertical face.
CannotMakeRoofFromVerticalFaceError | Can't make roof from vertical face.
CannotMakeSurface | Can't construct surface.
CannotMakeSurfaceError | Can't construct surface.
CannotMakeSurfaceWarn | Can't construct surface.
CannotMakeToposolid | Can't construct toposolid.
CannotMakeToposolidFromVerticalFace | Can't make toposolid from vertical face.
CannotMakeToposolidFromVerticalFaceError | Can't make toposolid from vertical face.
CannotMakeWall | Can't make Wall.
CannotUpdateWall | Can't update Wall.
SwitchFromLegendBeforeCreateSimilar | To Create Similar from a Legend View, first select the element, then activate the target view, then invoke Create Similar.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CreationFailures Properties

The BuiltInFailuresCreationFailures type exposes the following members.

Properties
Name | Description
CannotCreateCornice | Could not create Wall Sweep. [Description]
CannotCreateCorniceError | Could not create Wall Sweep. [Description]
CannotCreateCorniceIntegral | Could not create integral wall sweep for wall instance. [Description]
CannotCreateCorniceIntegralError | Could not create integral wall sweep for wall instance. [Description]
CannotCreateCorniceIntegralWarn | Could not create integral wall sweep for wall instance. [Description]
CannotCreateCorniceWarn | Could not create Wall Sweep. [Description]
CannotCreateCurtainGrid | Can't create Curtain Wall Grid Line.
CannotCreateCutout | Can't make cut-out.
CannotCreateCutoutError | Can't make cut-out.
CannotCreateCutoutWarn | Can't make cut-out.
CannotCreateElementInFamily | Can't create element in this family.
CannotCreateElementInView | Can't create this kind of element in this view in the current mode.
CannotCreateExplicitCrease | Cannot create a new split line based on the picked support.
CannotCreateFascia | Could not create Fascia. [Description]
CannotCreateFasciaError | Could not create Fascia. [Description]
CannotCreateFasciaWarn | Could not create Fascia. [Description]
CannotCreateGutter | Could not create Gutter. [Description]
CannotCreateGutterError | Could not create Gutter. [Description]
CannotCreateGutterWarn | Could not create Gutter. [Description]
CannotCreateMullion | Can't create Mullion.
CannotCreateMullionError | Can't create Mullion.
CannotCreateMullionReference | Can't create Curtain Wall Mullion. The grid segment for the Mullion is probably too small.
CannotCreateMullionReferenceNoGeometry | Can't create Curtain Wall Mullion. The portion of the curtain grid it was placed on no longer exists.
CannotCreateNewDesignOption | Cannot create a new empty design option
CannotCreateOldCornerMullion | Cannot change the type of a mullion created prior to release 4.0 to a corner mullion type. Try deleting the existing mullion and placing a new one.
CannotCreateOpening | Cannot create opening.
CannotCreateOpeningCutOut | Can't create Opening cut.
CannotCreateOpeningRectangularArcWall | Creation of a Rectangular Arc Wall Opening failed.
CannotCreateReveal | Could not create Reveal. [Description]
CannotCreateRevealError | Could not create Reveal. [Description]
CannotCreateRevealIntegral | Could not create integral reveal for wall instance. [Description]
CannotCreateRevealIntegralError | Could not create integral reveal for wall instance. [Description]
CannotCreateRevealIntegralWarn | Could not create integral reveal for wall instance. [Description]
CannotCreateRevealWarn | Could not create Reveal. [Description]
CannotCreateSlabEdge | Could not create Slab Edge. [Description]
CannotCreateSlabEdgeError | Could not create Slab Edge. [Description]
CannotCreateSlabEdgeWarn | Could not create Slab Edge. [Description]
CannotCreateSlantedWallWithSingularLayers | Cannot create wall - its layers would degenerate or intersect. Reduce the wall's height or slant.
CannotCreateSlantedWallWithSingularLayersError | Cannot create wall - its layers would degenerate or. Reduce the wall's height or slant.
CannotCreateSystemPanel | Can't create Curtain Panel in opening. The opening is probably too small.
CannotCreateTaperedWallForWallType | Cannot create tapered wall - the Wall Type is unacceptable. Be sure to choose a variable-thickness layer in the Wall Type.
CannotCreateTaperedWallForWallTypeError | Cannot create tapered wall - the Wall Type is unacceptable. Be sure to choose a variable-thickness layer in the Wall Type.
CannotCreateThis | Can't create [Element].
CannotDrawProfileRoof | Can't make footprint roof.
CannotDrawRoof | Can't make roof.
CannotDrawRoofError | Can't make roof.
CannotDrawRoofWall | Can't make roof.
CannotDrawSingularSlantedWall | Cannot create wall - it would intersect itself. Reduce the wall's height or slant.
CannotDrawSingularSlantedWallError | Cannot create wall - it would intersect itself. Reduce the wall's height or slant.
CannotDrawToposolid | Can't make toposolid.
CannotDrawToposolidError | Can't make toposolid.
CannotDrawWalls | Can't make Wall.
CannotDrawWallsError | Can't make Wall.
CannotMakeRoofFromVerticalFace | Can't make roof from vertical face.
CannotMakeRoofFromVerticalFaceError | Can't make roof from vertical face.
CannotMakeSurface | Can't construct surface.
CannotMakeSurfaceError | Can't construct surface.
CannotMakeSurfaceWarn | Can't construct surface.
CannotMakeToposolid | Can't construct toposolid.
CannotMakeToposolidFromVerticalFace | Can't make toposolid from vertical face.
CannotMakeToposolidFromVerticalFaceError | Can't make toposolid from vertical face.
CannotMakeWall | Can't make Wall.
CannotUpdateWall | Can't update Wall.
SwitchFromLegendBeforeCreateSimilar | To Create Similar from a Legend View, first select the element, then activate the target view, then invoke Create Similar.
Top
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotCreateCornice Property

BuiltInFailuresCreationFailuresCannotCreateCornice Property

Could not create Wall Sweep. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateCornice { get; }
Public Shared ReadOnly Property CannotCreateCornice As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateCornice {
    FailureDefinitionId^ get ();
}
static member CannotCreateCornice : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotCreateCorniceError Property

BuiltInFailuresCreationFailuresCannotCreateCorniceError Property

Could not create Wall Sweep. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateCorniceError { get; }
Public Shared ReadOnly Property CannotCreateCorniceError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateCorniceError {
    FailureDefinitionId^ get ();
}
static member CannotCreateCorniceError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotCreateCorniceIntegral Property

BuiltInFailuresCreationFailuresCannotCreateCorniceIntegral Property

Could not create integral wall sweep for wall instance. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateCorniceIntegral { get; }
Public Shared ReadOnly Property CannotCreateCorniceIntegral As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateCorniceIntegral {
    FailureDefinitionId^ get ();
}
static member CannotCreateCorniceIntegral : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotCreateCorniceIntegralError Property

BuiltInFailuresCreationFailuresCannotCreateCorniceIntegralError Property

Could not create integral wall sweep for wall instance. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateCorniceIntegralError { get; }
Public Shared ReadOnly Property CannotCreateCorniceIntegralError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateCorniceIntegralError {
    FailureDefinitionId^ get ();
}
static member CannotCreateCorniceIntegralError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotCreateCorniceIntegralWarn Property

BuiltInFailuresCreationFailuresCannotCreateCorniceIntegralWarn Property

Could not create integral wall sweep for wall instance. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateCorniceIntegralWarn { get; }
Public Shared ReadOnly Property CannotCreateCorniceIntegralWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateCorniceIntegralWarn {
    FailureDefinitionId^ get ();
}
static member CannotCreateCorniceIntegralWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotCreateCorniceWarn Property

BuiltInFailuresCreationFailuresCannotCreateCorniceWarn Property

Could not create Wall Sweep. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateCorniceWarn { get; }
Public Shared ReadOnly Property CannotCreateCorniceWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateCorniceWarn {
    FailureDefinitionId^ get ();
}
static member CannotCreateCorniceWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotCreateCurtainGrid Property

BuiltInFailuresCreationFailuresCannotCreateCurtainGrid Property

Can't create Curtain Wall Grid Line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateCurtainGrid { get; }
Public Shared ReadOnly Property CannotCreateCurtainGrid As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateCurtainGrid {
    FailureDefinitionId^ get ();
}
static member CannotCreateCurtainGrid : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotCreateCutout Property

BuiltInFailuresCreationFailuresCannotCreateCutout Property

Can't make cut-out.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateCutout { get; }
Public Shared ReadOnly Property CannotCreateCutout As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateCutout {
    FailureDefinitionId^ get ();
}
static member CannotCreateCutout : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotCreateCutoutError Property

BuiltInFailuresCreationFailuresCannotCreateCutoutError Property

Can't make cut-out.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateCutoutError { get; }
Public Shared ReadOnly Property CannotCreateCutoutError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateCutoutError {
    FailureDefinitionId^ get ();
}
static member CannotCreateCutoutError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotCreateCutoutWarn Property

BuiltInFailuresCreationFailuresCannotCreateCutoutWarn Property

Can't make cut-out.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateCutoutWarn { get; }
Public Shared ReadOnly Property CannotCreateCutoutWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateCutoutWarn {
    FailureDefinitionId^ get ();
}
static member CannotCreateCutoutWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotCreateElementInFamily Property

BuiltInFailuresCreationFailuresCannotCreateElementInFamily Property

Can't create element in this family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateElementInFamily { get; }
Public Shared ReadOnly Property CannotCreateElementInFamily As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateElementInFamily {
    FailureDefinitionId^ get ();
}
static member CannotCreateElementInFamily : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotCreateElementInView Property

BuiltInFailuresCreationFailuresCannotCreateElementInView Property

Can't create this kind of element in this view in the current mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateElementInView { get; }
Public Shared ReadOnly Property CannotCreateElementInView As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateElementInView {
    FailureDefinitionId^ get ();
}
static member CannotCreateElementInView : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotCreateExplicitCrease Property

BuiltInFailuresCreationFailuresCannotCreateExplicitCrease Property

Cannot create a new split line based on the picked support.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateExplicitCrease { get; }
Public Shared ReadOnly Property CannotCreateExplicitCrease As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateExplicitCrease {
    FailureDefinitionId^ get ();
}
static member CannotCreateExplicitCrease : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotCreateFascia Property

BuiltInFailuresCreationFailuresCannotCreateFascia Property

Could not create Fascia. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateFascia { get; }
Public Shared ReadOnly Property CannotCreateFascia As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateFascia {
    FailureDefinitionId^ get ();
}
static member CannotCreateFascia : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotCreateFasciaError Property

BuiltInFailuresCreationFailuresCannotCreateFasciaError Property

Could not create Fascia. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateFasciaError { get; }
Public Shared ReadOnly Property CannotCreateFasciaError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateFasciaError {
    FailureDefinitionId^ get ();
}
static member CannotCreateFasciaError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotCreateFasciaWarn Property

BuiltInFailuresCreationFailuresCannotCreateFasciaWarn Property

Could not create Fascia. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateFasciaWarn { get; }
Public Shared ReadOnly Property CannotCreateFasciaWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateFasciaWarn {
    FailureDefinitionId^ get ();
}
static member CannotCreateFasciaWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotCreateGutter Property

BuiltInFailuresCreationFailuresCannotCreateGutter Property

Could not create Gutter. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateGutter { get; }
Public Shared ReadOnly Property CannotCreateGutter As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateGutter {
    FailureDefinitionId^ get ();
}
static member CannotCreateGutter : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotCreateGutterError Property

BuiltInFailuresCreationFailuresCannotCreateGutterError Property

Could not create Gutter. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateGutterError { get; }
Public Shared ReadOnly Property CannotCreateGutterError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateGutterError {
    FailureDefinitionId^ get ();
}
static member CannotCreateGutterError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotCreateGutterWarn Property

BuiltInFailuresCreationFailuresCannotCreateGutterWarn Property

Could not create Gutter. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateGutterWarn { get; }
Public Shared ReadOnly Property CannotCreateGutterWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateGutterWarn {
    FailureDefinitionId^ get ();
}
static member CannotCreateGutterWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotCreateMullion Property

BuiltInFailuresCreationFailuresCannotCreateMullion Property

Can't create Mullion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateMullion { get; }
Public Shared ReadOnly Property CannotCreateMullion As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateMullion {
    FailureDefinitionId^ get ();
}
static member CannotCreateMullion : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotCreateMullionError Property

BuiltInFailuresCreationFailuresCannotCreateMullionError Property

Can't create Mullion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateMullionError { get; }
Public Shared ReadOnly Property CannotCreateMullionError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateMullionError {
    FailureDefinitionId^ get ();
}
static member CannotCreateMullionError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotCreateMullionReference Property

BuiltInFailuresCreationFailuresCannotCreateMullionReference Property

Can't create Curtain Wall Mullion. The grid segment for the Mullion is probably too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateMullionReference { get; }
Public Shared ReadOnly Property CannotCreateMullionReference As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateMullionReference {
    FailureDefinitionId^ get ();
}
static member CannotCreateMullionReference : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotCreateMullionReferenceNoGeometry Property

BuiltInFailuresCreationFailuresCannotCreateMullionReferenceNoGeometry Property

Can't create Curtain Wall Mullion. The portion of the curtain grid it was placed on no longer exists.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateMullionReferenceNoGeometry { get; }
Public Shared ReadOnly Property CannotCreateMullionReferenceNoGeometry As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateMullionReferenceNoGeometry {
    FailureDefinitionId^ get ();
}
static member CannotCreateMullionReferenceNoGeometry : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotCreateNewDesignOption Property

BuiltInFailuresCreationFailuresCannotCreateNewDesignOption Property

Cannot create a new empty design option

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateNewDesignOption { get; }
Public Shared ReadOnly Property CannotCreateNewDesignOption As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateNewDesignOption {
    FailureDefinitionId^ get ();
}
static member CannotCreateNewDesignOption : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotCreateOldCornerMullion Property

BuiltInFailuresCreationFailuresCannotCreateOldCornerMullion Property

Cannot change the type of a mullion created prior to release 4.0 to a corner mullion type. Try deleting the existing mullion and placing a new one.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateOldCornerMullion { get; }
Public Shared ReadOnly Property CannotCreateOldCornerMullion As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateOldCornerMullion {
    FailureDefinitionId^ get ();
}
static member CannotCreateOldCornerMullion : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotCreateOpening Property

BuiltInFailuresCreationFailuresCannotCreateOpening Property

Cannot create opening.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateOpening { get; }
Public Shared ReadOnly Property CannotCreateOpening As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateOpening {
    FailureDefinitionId^ get ();
}
static member CannotCreateOpening : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotCreateOpeningCutOut Property

BuiltInFailuresCreationFailuresCannotCreateOpeningCutOut Property

Can't create Opening cut.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateOpeningCutOut { get; }
Public Shared ReadOnly Property CannotCreateOpeningCutOut As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateOpeningCutOut {
    FailureDefinitionId^ get ();
}
static member CannotCreateOpeningCutOut : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotCreateOpeningRectangularArcWall Property

BuiltInFailuresCreationFailuresCannotCreateOpeningRectangularArcWall Property

Creation of a Rectangular Arc Wall Opening failed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateOpeningRectangularArcWall { get; }
Public Shared ReadOnly Property CannotCreateOpeningRectangularArcWall As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateOpeningRectangularArcWall {
    FailureDefinitionId^ get ();
}
static member CannotCreateOpeningRectangularArcWall : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotCreateReveal Property

BuiltInFailuresCreationFailuresCannotCreateReveal Property

Could not create Reveal. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateReveal { get; }
Public Shared ReadOnly Property CannotCreateReveal As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateReveal {
    FailureDefinitionId^ get ();
}
static member CannotCreateReveal : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotCreateRevealError Property

BuiltInFailuresCreationFailuresCannotCreateRevealError Property

Could not create Reveal. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateRevealError { get; }
Public Shared ReadOnly Property CannotCreateRevealError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateRevealError {
    FailureDefinitionId^ get ();
}
static member CannotCreateRevealError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotCreateRevealIntegral Property

BuiltInFailuresCreationFailuresCannotCreateRevealIntegral Property

Could not create integral reveal for wall instance. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateRevealIntegral { get; }
Public Shared ReadOnly Property CannotCreateRevealIntegral As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateRevealIntegral {
    FailureDefinitionId^ get ();
}
static member CannotCreateRevealIntegral : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotCreateRevealIntegralError Property

BuiltInFailuresCreationFailuresCannotCreateRevealIntegralError Property

Could not create integral reveal for wall instance. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateRevealIntegralError { get; }
Public Shared ReadOnly Property CannotCreateRevealIntegralError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateRevealIntegralError {
    FailureDefinitionId^ get ();
}
static member CannotCreateRevealIntegralError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotCreateRevealIntegralWarn Property

BuiltInFailuresCreationFailuresCannotCreateRevealIntegralWarn Property

Could not create integral reveal for wall instance. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateRevealIntegralWarn { get; }
Public Shared ReadOnly Property CannotCreateRevealIntegralWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateRevealIntegralWarn {
    FailureDefinitionId^ get ();
}
static member CannotCreateRevealIntegralWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotCreateRevealWarn Property

BuiltInFailuresCreationFailuresCannotCreateRevealWarn Property

Could not create Reveal. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateRevealWarn { get; }
Public Shared ReadOnly Property CannotCreateRevealWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateRevealWarn {
    FailureDefinitionId^ get ();
}
static member CannotCreateRevealWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotCreateSlabEdge Property

BuiltInFailuresCreationFailuresCannotCreateSlabEdge Property

Could not create Slab Edge. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateSlabEdge { get; }
Public Shared ReadOnly Property CannotCreateSlabEdge As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateSlabEdge {
    FailureDefinitionId^ get ();
}
static member CannotCreateSlabEdge : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotCreateSlabEdgeError Property

BuiltInFailuresCreationFailuresCannotCreateSlabEdgeError Property

Could not create Slab Edge. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateSlabEdgeError { get; }
Public Shared ReadOnly Property CannotCreateSlabEdgeError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateSlabEdgeError {
    FailureDefinitionId^ get ();
}
static member CannotCreateSlabEdgeError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotCreateSlabEdgeWarn Property

BuiltInFailuresCreationFailuresCannotCreateSlabEdgeWarn Property

Could not create Slab Edge. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateSlabEdgeWarn { get; }
Public Shared ReadOnly Property CannotCreateSlabEdgeWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateSlabEdgeWarn {
    FailureDefinitionId^ get ();
}
static member CannotCreateSlabEdgeWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotCreateSlantedWallWithSingularLayers Property

BuiltInFailuresCreationFailuresCannotCreateSlantedWallWithSingularLayers Property

Cannot create wall - its layers would degenerate or intersect. Reduce the wall's height or slant.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateSlantedWallWithSingularLayers { get; }
Public Shared ReadOnly Property CannotCreateSlantedWallWithSingularLayers As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateSlantedWallWithSingularLayers {
    FailureDefinitionId^ get ();
}
static member CannotCreateSlantedWallWithSingularLayers : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotCreateSlantedWallWithSingularLayersError Property

BuiltInFailuresCreationFailuresCannotCreateSlantedWallWithSingularLayersError Property

Cannot create wall - its layers would degenerate or. Reduce the wall's height or slant.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateSlantedWallWithSingularLayersError { get; }
Public Shared ReadOnly Property CannotCreateSlantedWallWithSingularLayersError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateSlantedWallWithSingularLayersError {
    FailureDefinitionId^ get ();
}
static member CannotCreateSlantedWallWithSingularLayersError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotCreateSystemPanel Property

BuiltInFailuresCreationFailuresCannotCreateSystemPanel Property

Can't create Curtain Panel in opening. The opening is probably too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateSystemPanel { get; }
Public Shared ReadOnly Property CannotCreateSystemPanel As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateSystemPanel {
    FailureDefinitionId^ get ();
}
static member CannotCreateSystemPanel : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotCreateTaperedWallForWallType Property

BuiltInFailuresCreationFailuresCannotCreateTaperedWallForWallType Property

Cannot create tapered wall - the Wall Type is unacceptable. Be sure to choose a variable-thickness layer in the Wall Type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateTaperedWallForWallType { get; }
Public Shared ReadOnly Property CannotCreateTaperedWallForWallType As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateTaperedWallForWallType {
    FailureDefinitionId^ get ();
}
static member CannotCreateTaperedWallForWallType : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotCreateTaperedWallForWallTypeError Property

BuiltInFailuresCreationFailuresCannotCreateTaperedWallForWallTypeError Property

Cannot create tapered wall - the Wall Type is unacceptable. Be sure to choose a variable-thickness layer in the Wall Type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateTaperedWallForWallTypeError { get; }
Public Shared ReadOnly Property CannotCreateTaperedWallForWallTypeError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateTaperedWallForWallTypeError {
    FailureDefinitionId^ get ();
}
static member CannotCreateTaperedWallForWallTypeError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotCreateThis Property

BuiltInFailuresCreationFailuresCannotCreateThis Property

Can't create [Element].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateThis { get; }
Public Shared ReadOnly Property CannotCreateThis As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateThis {
    FailureDefinitionId^ get ();
}
static member CannotCreateThis : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotDrawProfileRoof Property

BuiltInFailuresCreationFailuresCannotDrawProfileRoof Property

Can't make footprint roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotDrawProfileRoof { get; }
Public Shared ReadOnly Property CannotDrawProfileRoof As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotDrawProfileRoof {
    FailureDefinitionId^ get ();
}
static member CannotDrawProfileRoof : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotDrawRoof Property

BuiltInFailuresCreationFailuresCannotDrawRoof Property

Can't make roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotDrawRoof { get; }
Public Shared ReadOnly Property CannotDrawRoof As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotDrawRoof {
    FailureDefinitionId^ get ();
}
static member CannotDrawRoof : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotDrawRoofError Property

BuiltInFailuresCreationFailuresCannotDrawRoofError Property

Can't make roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotDrawRoofError { get; }
Public Shared ReadOnly Property CannotDrawRoofError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotDrawRoofError {
    FailureDefinitionId^ get ();
}
static member CannotDrawRoofError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotDrawRoofWall Property

BuiltInFailuresCreationFailuresCannotDrawRoofWall Property

Can't make roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotDrawRoofWall { get; }
Public Shared ReadOnly Property CannotDrawRoofWall As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotDrawRoofWall {
    FailureDefinitionId^ get ();
}
static member CannotDrawRoofWall : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotDrawSingularSlantedWall Property

BuiltInFailuresCreationFailuresCannotDrawSingularSlantedWall Property

Cannot create wall - it would intersect itself. Reduce the wall's height or slant.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotDrawSingularSlantedWall { get; }
Public Shared ReadOnly Property CannotDrawSingularSlantedWall As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotDrawSingularSlantedWall {
    FailureDefinitionId^ get ();
}
static member CannotDrawSingularSlantedWall : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotDrawSingularSlantedWallError Property

BuiltInFailuresCreationFailuresCannotDrawSingularSlantedWallError Property

Cannot create wall - it would intersect itself. Reduce the wall's height or slant.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotDrawSingularSlantedWallError { get; }
Public Shared ReadOnly Property CannotDrawSingularSlantedWallError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotDrawSingularSlantedWallError {
    FailureDefinitionId^ get ();
}
static member CannotDrawSingularSlantedWallError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotDrawToposolid Property

BuiltInFailuresCreationFailuresCannotDrawToposolid Property

Can't make toposolid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotDrawToposolid { get; }
Public Shared ReadOnly Property CannotDrawToposolid As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotDrawToposolid {
    FailureDefinitionId^ get ();
}
static member CannotDrawToposolid : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotDrawToposolidError Property

BuiltInFailuresCreationFailuresCannotDrawToposolidError Property

Can't make toposolid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotDrawToposolidError { get; }
Public Shared ReadOnly Property CannotDrawToposolidError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotDrawToposolidError {
    FailureDefinitionId^ get ();
}
static member CannotDrawToposolidError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotDrawWalls Property

BuiltInFailuresCreationFailuresCannotDrawWalls Property

Can't make Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotDrawWalls { get; }
Public Shared ReadOnly Property CannotDrawWalls As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotDrawWalls {
    FailureDefinitionId^ get ();
}
static member CannotDrawWalls : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotDrawWallsError Property

BuiltInFailuresCreationFailuresCannotDrawWallsError Property

Can't make Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotDrawWallsError { get; }
Public Shared ReadOnly Property CannotDrawWallsError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotDrawWallsError {
    FailureDefinitionId^ get ();
}
static member CannotDrawWallsError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotMakeRoofFromVerticalFace Property

BuiltInFailuresCreationFailuresCannotMakeRoofFromVerticalFace Property

Can't make roof from vertical face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotMakeRoofFromVerticalFace { get; }
Public Shared ReadOnly Property CannotMakeRoofFromVerticalFace As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotMakeRoofFromVerticalFace {
    FailureDefinitionId^ get ();
}
static member CannotMakeRoofFromVerticalFace : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotMakeRoofFromVerticalFaceError Property

BuiltInFailuresCreationFailuresCannotMakeRoofFromVerticalFaceError Property

Can't make roof from vertical face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotMakeRoofFromVerticalFaceError { get; }
Public Shared ReadOnly Property CannotMakeRoofFromVerticalFaceError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotMakeRoofFromVerticalFaceError {
    FailureDefinitionId^ get ();
}
static member CannotMakeRoofFromVerticalFaceError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotMakeSurface Property

BuiltInFailuresCreationFailuresCannotMakeSurface Property

Can't construct surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotMakeSurface { get; }
Public Shared ReadOnly Property CannotMakeSurface As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotMakeSurface {
    FailureDefinitionId^ get ();
}
static member CannotMakeSurface : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotMakeSurfaceError Property

BuiltInFailuresCreationFailuresCannotMakeSurfaceError Property

Can't construct surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotMakeSurfaceError { get; }
Public Shared ReadOnly Property CannotMakeSurfaceError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotMakeSurfaceError {
    FailureDefinitionId^ get ();
}
static member CannotMakeSurfaceError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotMakeSurfaceWarn Property

BuiltInFailuresCreationFailuresCannotMakeSurfaceWarn Property

Can't construct surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotMakeSurfaceWarn { get; }
Public Shared ReadOnly Property CannotMakeSurfaceWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotMakeSurfaceWarn {
    FailureDefinitionId^ get ();
}
static member CannotMakeSurfaceWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotMakeToposolid Property

BuiltInFailuresCreationFailuresCannotMakeToposolid Property

Can't construct toposolid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotMakeToposolid { get; }
Public Shared ReadOnly Property CannotMakeToposolid As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotMakeToposolid {
    FailureDefinitionId^ get ();
}
static member CannotMakeToposolid : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotMakeToposolidFromVerticalFace Property

BuiltInFailuresCreationFailuresCannotMakeToposolidFromVerticalFace Property

Can't make toposolid from vertical face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotMakeToposolidFromVerticalFace { get; }
Public Shared ReadOnly Property CannotMakeToposolidFromVerticalFace As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotMakeToposolidFromVerticalFace {
    FailureDefinitionId^ get ();
}
static member CannotMakeToposolidFromVerticalFace : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotMakeToposolidFromVerticalFaceError Property

BuiltInFailuresCreationFailuresCannotMakeToposolidFromVerticalFaceError Property

Can't make toposolid from vertical face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotMakeToposolidFromVerticalFaceError { get; }
Public Shared ReadOnly Property CannotMakeToposolidFromVerticalFaceError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotMakeToposolidFromVerticalFaceError {
    FailureDefinitionId^ get ();
}
static member CannotMakeToposolidFromVerticalFaceError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotMakeWall Property

BuiltInFailuresCreationFailuresCannotMakeWall Property

Can't make Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotMakeWall { get; }
Public Shared ReadOnly Property CannotMakeWall As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotMakeWall {
    FailureDefinitionId^ get ();
}
static member CannotMakeWall : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.CannotUpdateWall Property

BuiltInFailuresCreationFailuresCannotUpdateWall Property

Can't update Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotUpdateWall { get; }
Public Shared ReadOnly Property CannotUpdateWall As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotUpdateWall {
    FailureDefinitionId^ get ();
}
static member CannotUpdateWall : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CreationFailures.SwitchFromLegendBeforeCreateSimilar Property

BuiltInFailuresCreationFailuresSwitchFromLegendBeforeCreateSimilar Property

To Create Similar from a Legend View, first select the element, then activate the target view, then invoke Create Similar.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SwitchFromLegendBeforeCreateSimilar { get; }
Public Shared ReadOnly Property SwitchFromLegendBeforeCreateSimilar As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SwitchFromLegendBeforeCreateSimilar {
    FailureDefinitionId^ get ();
}
static member SwitchFromLegendBeforeCreateSimilar : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCreationFailures Class


BuiltInFailures.CurtainGridFamilyFailures Class

BuiltInFailuresCurtainGridFamilyFailures Class

Failures about CurtainGrid Family.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresCurtainGridFamilyFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class CurtainGridFamilyFailures
Public NotInheritable Class CurtainGridFamilyFailures
public ref class CurtainGridFamilyFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CurtainGridFamilyFailures = class end

The BuiltInFailuresCurtainGridFamilyFailures type exposes the following members.

Properties
Name | Description
AllMullionsAreTooShort | The mullion(s) you are trying to place is too short for his type, and was not placed on the grid.
CannotCreateCornerMullionDueAngle | Can't create Corner Mullion due to the angle between the neighboring panels. Try changing the Parameters in the Curtain Wall Mullion Family.
CannotCreateCurtainPanelCorruption | Can't create Curtain Panel. A Panel or a Mullion is probably too small.
CannotCreateCurtainPanelError |
CannotCreateCurtainPanelInOpeningCorruption | Can't create Curtain Panel in opening. The opening is probably too small.
CannotCreateCurtainPanelInOpeningWarning |
CannotGenerateAllNecessaryElements | Unable to regenerate all necessary elements.
CannotPlaceSystemMullionFamilyOnCurtainWall | Can't place System Mullion Family on this Curtain Wall.
CannotPlaceSystemPanelsInOldArcedCurtainWalls | Can't place System Panels in arced Curtain Walls created prior to 3.0, nor in straight Curtain Walls created prior to version 2.0.
CornerMullionOverlapsOtherOnePlacedOnNeighboringRegion | Corner Mullion overlaps Mullion placed on neighboring Curtain region.
CornerMullionsNeighborsMustBeTangent | Corner Mullions must be placed at a location that can have neighboring Panels that are not tangent. With the exception of Wall Join locations, Corner Mullions are not currently supported on the external boundaries of Curtain elements.
CurtainPanelNotBelongsToElement | Curtain element Panel doesn't belong to Curtain element. In merging, you must select the version of a Curtain element that has had Panels added to it.
CurtainPanelsParamDefinedTypeDefinedCirculary | Parameter-defined type of curtain panels defined in a circular way and default panel type will be used instead.
CurtainSystemCouldnotReacquireFaces | Curtain System could not reacquire [Number] faces out of [Number].
InvalidCurtainPanelInModel | There is an invalid Curtain Panel in the model. This is probably caused by two Grid Lines almost meeting at a border of the Curtain Wall or Sloped Glazing, but not exactly at a point. The Curtain Panel can't be displayed.
MullionProfileContainsOpenLoop | The selected mullion profile contains an open profile loop and cannot be used. Valid profiles can only have closed profile loop(s).
NonSystemPanelFamiliesCannotBeUsed | Non-system panel families cannot be used for non-rectangular panels. If your panel is simple, create an appropriate panel type derived from the system panel family. If not, try making the panel in the wall or roof rectangular, and then using a panel family of the desired (non-rectangular) shape. The wall will then conform to the non-rectangular shape of the panel.
PanelsSlightlyMalformedCorruption | Some panels in this curtain system are slightly malformed. The problem is most likely ignorable. This problem usually occurs when a panel or parts of a panel have been divided so that they are very narrow. To better see the malformed panels, temporarily hide the mullion category and set display of lines to ""thin lines"" (using the command on the view menu).
PanelsSlightlyMalformedWarning | Some panels in this curtain system are slightly malformed. The problem is most likely ignorable. This problem usually occurs when a panel or parts of a panel have been divided so that they are very narrow. To better see the malformed panels, temporarily hide the mullion category and set display of lines to ""thin lines"" (using the command on the view menu).
SomeMullionsAreTooShort | Some of the mullions you are trying to place are too short for its types, and were not placed on the grid.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CurtainGridFamilyFailures Properties

The BuiltInFailuresCurtainGridFamilyFailures type exposes the following members.

Properties
Name | Description
AllMullionsAreTooShort | The mullion(s) you are trying to place is too short for his type, and was not placed on the grid.
CannotCreateCornerMullionDueAngle | Can't create Corner Mullion due to the angle between the neighboring panels. Try changing the Parameters in the Curtain Wall Mullion Family.
CannotCreateCurtainPanelCorruption | Can't create Curtain Panel. A Panel or a Mullion is probably too small.
CannotCreateCurtainPanelError |
CannotCreateCurtainPanelInOpeningCorruption | Can't create Curtain Panel in opening. The opening is probably too small.
CannotCreateCurtainPanelInOpeningWarning |
CannotGenerateAllNecessaryElements | Unable to regenerate all necessary elements.
CannotPlaceSystemMullionFamilyOnCurtainWall | Can't place System Mullion Family on this Curtain Wall.
CannotPlaceSystemPanelsInOldArcedCurtainWalls | Can't place System Panels in arced Curtain Walls created prior to 3.0, nor in straight Curtain Walls created prior to version 2.0.
CornerMullionOverlapsOtherOnePlacedOnNeighboringRegion | Corner Mullion overlaps Mullion placed on neighboring Curtain region.
CornerMullionsNeighborsMustBeTangent | Corner Mullions must be placed at a location that can have neighboring Panels that are not tangent. With the exception of Wall Join locations, Corner Mullions are not currently supported on the external boundaries of Curtain elements.
CurtainPanelNotBelongsToElement | Curtain element Panel doesn't belong to Curtain element. In merging, you must select the version of a Curtain element that has had Panels added to it.
CurtainPanelsParamDefinedTypeDefinedCirculary | Parameter-defined type of curtain panels defined in a circular way and default panel type will be used instead.
CurtainSystemCouldnotReacquireFaces | Curtain System could not reacquire [Number] faces out of [Number].
InvalidCurtainPanelInModel | There is an invalid Curtain Panel in the model. This is probably caused by two Grid Lines almost meeting at a border of the Curtain Wall or Sloped Glazing, but not exactly at a point. The Curtain Panel can't be displayed.
MullionProfileContainsOpenLoop | The selected mullion profile contains an open profile loop and cannot be used. Valid profiles can only have closed profile loop(s).
NonSystemPanelFamiliesCannotBeUsed | Non-system panel families cannot be used for non-rectangular panels. If your panel is simple, create an appropriate panel type derived from the system panel family. If not, try making the panel in the wall or roof rectangular, and then using a panel family of the desired (non-rectangular) shape. The wall will then conform to the non-rectangular shape of the panel.
PanelsSlightlyMalformedCorruption | Some panels in this curtain system are slightly malformed. The problem is most likely ignorable. This problem usually occurs when a panel or parts of a panel have been divided so that they are very narrow. To better see the malformed panels, temporarily hide the mullion category and set display of lines to ""thin lines"" (using the command on the view menu).
PanelsSlightlyMalformedWarning | Some panels in this curtain system are slightly malformed. The problem is most likely ignorable. This problem usually occurs when a panel or parts of a panel have been divided so that they are very narrow. To better see the malformed panels, temporarily hide the mullion category and set display of lines to ""thin lines"" (using the command on the view menu).
SomeMullionsAreTooShort | Some of the mullions you are trying to place are too short for its types, and were not placed on the grid.
Top
See Also

Reference

BuiltInFailuresCurtainGridFamilyFailures Class


BuiltInFailures.CurtainGridFamilyFailures.AllMullionsAreTooShort Property

BuiltInFailuresCurtainGridFamilyFailuresAllMullionsAreTooShort Property

The mullion(s) you are trying to place is too short for his type, and was not placed on the grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AllMullionsAreTooShort { get; }
Public Shared ReadOnly Property AllMullionsAreTooShort As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AllMullionsAreTooShort {
    FailureDefinitionId^ get ();
}
static member AllMullionsAreTooShort : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainGridFamilyFailures Class


BuiltInFailures.CurtainGridFamilyFailures.CannotCreateCornerMullionDueAngle Property

BuiltInFailuresCurtainGridFamilyFailuresCannotCreateCornerMullionDueAngle Property

Can't create Corner Mullion due to the angle between the neighboring panels. Try changing the Parameters in the Curtain Wall Mullion Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateCornerMullionDueAngle { get; }
Public Shared ReadOnly Property CannotCreateCornerMullionDueAngle As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateCornerMullionDueAngle {
    FailureDefinitionId^ get ();
}
static member CannotCreateCornerMullionDueAngle : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainGridFamilyFailures Class


BuiltInFailures.CurtainGridFamilyFailures.CannotCreateCurtainPanelCorruption Property

BuiltInFailuresCurtainGridFamilyFailuresCannotCreateCurtainPanelCorruption Property

Can't create Curtain Panel. A Panel or a Mullion is probably too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateCurtainPanelCorruption { get; }
Public Shared ReadOnly Property CannotCreateCurtainPanelCorruption As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateCurtainPanelCorruption {
    FailureDefinitionId^ get ();
}
static member CannotCreateCurtainPanelCorruption : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainGridFamilyFailures Class


BuiltInFailures.CurtainGridFamilyFailures.CannotCreateCurtainPanelError Property

BuiltInFailuresCurtainGridFamilyFailuresCannotCreateCurtainPanelError Property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateCurtainPanelError { get; }
Public Shared ReadOnly Property CannotCreateCurtainPanelError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateCurtainPanelError {
    FailureDefinitionId^ get ();
}
static member CannotCreateCurtainPanelError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainGridFamilyFailures Class


BuiltInFailures.CurtainGridFamilyFailures.CannotCreateCurtainPanelInOpeningCorruption Property

BuiltInFailuresCurtainGridFamilyFailuresCannotCreateCurtainPanelInOpeningCorruption Property

Can't create Curtain Panel in opening. The opening is probably too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateCurtainPanelInOpeningCorruption { get; }
Public Shared ReadOnly Property CannotCreateCurtainPanelInOpeningCorruption As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateCurtainPanelInOpeningCorruption {
    FailureDefinitionId^ get ();
}
static member CannotCreateCurtainPanelInOpeningCorruption : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainGridFamilyFailures Class


BuiltInFailures.CurtainGridFamilyFailures.CannotCreateCurtainPanelInOpeningWarning Property

BuiltInFailuresCurtainGridFamilyFailuresCannotCreateCurtainPanelInOpeningWarning Property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateCurtainPanelInOpeningWarning { get; }
Public Shared ReadOnly Property CannotCreateCurtainPanelInOpeningWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateCurtainPanelInOpeningWarning {
    FailureDefinitionId^ get ();
}
static member CannotCreateCurtainPanelInOpeningWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainGridFamilyFailures Class


BuiltInFailures.CurtainGridFamilyFailures.CannotGenerateAllNecessaryElements Property

BuiltInFailuresCurtainGridFamilyFailuresCannotGenerateAllNecessaryElements Property

Unable to regenerate all necessary elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotGenerateAllNecessaryElements { get; }
Public Shared ReadOnly Property CannotGenerateAllNecessaryElements As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotGenerateAllNecessaryElements {
    FailureDefinitionId^ get ();
}
static member CannotGenerateAllNecessaryElements : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainGridFamilyFailures Class


BuiltInFailures.CurtainGridFamilyFailures.CannotPlaceSystemMullionFamilyOnCurtainWall Property

BuiltInFailuresCurtainGridFamilyFailuresCannotPlaceSystemMullionFamilyOnCurtainWall Property

Can't place System Mullion Family on this Curtain Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPlaceSystemMullionFamilyOnCurtainWall { get; }
Public Shared ReadOnly Property CannotPlaceSystemMullionFamilyOnCurtainWall As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPlaceSystemMullionFamilyOnCurtainWall {
    FailureDefinitionId^ get ();
}
static member CannotPlaceSystemMullionFamilyOnCurtainWall : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainGridFamilyFailures Class


BuiltInFailures.CurtainGridFamilyFailures.CannotPlaceSystemPanelsInOldArcedCurtainWalls Property

BuiltInFailuresCurtainGridFamilyFailuresCannotPlaceSystemPanelsInOldArcedCurtainWalls Property

Can't place System Panels in arced Curtain Walls created prior to 3.0, nor in straight Curtain Walls created prior to version 2.0.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPlaceSystemPanelsInOldArcedCurtainWalls { get; }
Public Shared ReadOnly Property CannotPlaceSystemPanelsInOldArcedCurtainWalls As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPlaceSystemPanelsInOldArcedCurtainWalls {
    FailureDefinitionId^ get ();
}
static member CannotPlaceSystemPanelsInOldArcedCurtainWalls : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainGridFamilyFailures Class


BuiltInFailures.CurtainGridFamilyFailures.CornerMullionOverlapsOtherOnePlacedOnNeighboringRegion Property

BuiltInFailuresCurtainGridFamilyFailuresCornerMullionOverlapsOtherOnePlacedOnNeighboringRegion Property

Corner Mullion overlaps Mullion placed on neighboring Curtain region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CornerMullionOverlapsOtherOnePlacedOnNeighboringRegion { get; }
Public Shared ReadOnly Property CornerMullionOverlapsOtherOnePlacedOnNeighboringRegion As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CornerMullionOverlapsOtherOnePlacedOnNeighboringRegion {
    FailureDefinitionId^ get ();
}
static member CornerMullionOverlapsOtherOnePlacedOnNeighboringRegion : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainGridFamilyFailures Class


BuiltInFailures.CurtainGridFamilyFailures.CornerMullionsNeighborsMustBeTangent Property

BuiltInFailuresCurtainGridFamilyFailuresCornerMullionsNeighborsMustBeTangent Property

Corner Mullions must be placed at a location that can have neighboring Panels that are not tangent. With the exception of Wall Join locations, Corner Mullions are not currently supported on the external boundaries of Curtain elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CornerMullionsNeighborsMustBeTangent { get; }
Public Shared ReadOnly Property CornerMullionsNeighborsMustBeTangent As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CornerMullionsNeighborsMustBeTangent {
    FailureDefinitionId^ get ();
}
static member CornerMullionsNeighborsMustBeTangent : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainGridFamilyFailures Class


BuiltInFailures.CurtainGridFamilyFailures.CurtainPanelNotBelongsToElement Property

BuiltInFailuresCurtainGridFamilyFailuresCurtainPanelNotBelongsToElement Property

Curtain element Panel doesn't belong to Curtain element. In merging, you must select the version of a Curtain element that has had Panels added to it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CurtainPanelNotBelongsToElement { get; }
Public Shared ReadOnly Property CurtainPanelNotBelongsToElement As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CurtainPanelNotBelongsToElement {
    FailureDefinitionId^ get ();
}
static member CurtainPanelNotBelongsToElement : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainGridFamilyFailures Class


BuiltInFailures.CurtainGridFamilyFailures.CurtainPanelsParamDefinedTypeDefinedCirculary Property

BuiltInFailuresCurtainGridFamilyFailuresCurtainPanelsParamDefinedTypeDefinedCirculary Property

Parameter-defined type of curtain panels defined in a circular way and default panel type will be used instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CurtainPanelsParamDefinedTypeDefinedCirculary { get; }
Public Shared ReadOnly Property CurtainPanelsParamDefinedTypeDefinedCirculary As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CurtainPanelsParamDefinedTypeDefinedCirculary {
    FailureDefinitionId^ get ();
}
static member CurtainPanelsParamDefinedTypeDefinedCirculary : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainGridFamilyFailures Class


BuiltInFailures.CurtainGridFamilyFailures.CurtainSystemCouldnotReacquireFaces Property

BuiltInFailuresCurtainGridFamilyFailuresCurtainSystemCouldnotReacquireFaces Property

Curtain System could not reacquire [Number] faces out of [Number].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CurtainSystemCouldnotReacquireFaces { get; }
Public Shared ReadOnly Property CurtainSystemCouldnotReacquireFaces As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CurtainSystemCouldnotReacquireFaces {
    FailureDefinitionId^ get ();
}
static member CurtainSystemCouldnotReacquireFaces : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainGridFamilyFailures Class


BuiltInFailures.CurtainGridFamilyFailures.InvalidCurtainPanelInModel Property

BuiltInFailuresCurtainGridFamilyFailuresInvalidCurtainPanelInModel Property

There is an invalid Curtain Panel in the model. This is probably caused by two Grid Lines almost meeting at a border of the Curtain Wall or Sloped Glazing, but not exactly at a point. The Curtain Panel can't be displayed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidCurtainPanelInModel { get; }
Public Shared ReadOnly Property InvalidCurtainPanelInModel As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidCurtainPanelInModel {
    FailureDefinitionId^ get ();
}
static member InvalidCurtainPanelInModel : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainGridFamilyFailures Class


BuiltInFailures.CurtainGridFamilyFailures.MullionProfileContainsOpenLoop Property

BuiltInFailuresCurtainGridFamilyFailuresMullionProfileContainsOpenLoop Property

The selected mullion profile contains an open profile loop and cannot be used. Valid profiles can only have closed profile loop(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MullionProfileContainsOpenLoop { get; }
Public Shared ReadOnly Property MullionProfileContainsOpenLoop As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MullionProfileContainsOpenLoop {
    FailureDefinitionId^ get ();
}
static member MullionProfileContainsOpenLoop : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainGridFamilyFailures Class


BuiltInFailures.CurtainGridFamilyFailures.NonSystemPanelFamiliesCannotBeUsed Property

BuiltInFailuresCurtainGridFamilyFailuresNonSystemPanelFamiliesCannotBeUsed Property

Non-system panel families cannot be used for non-rectangular panels. If your panel is simple, create an appropriate panel type derived from the system panel family. If not, try making the panel in the wall or roof rectangular, and then using a panel family of the desired (non-rectangular) shape. The wall will then conform to the non-rectangular shape of the panel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NonSystemPanelFamiliesCannotBeUsed { get; }
Public Shared ReadOnly Property NonSystemPanelFamiliesCannotBeUsed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NonSystemPanelFamiliesCannotBeUsed {
    FailureDefinitionId^ get ();
}
static member NonSystemPanelFamiliesCannotBeUsed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainGridFamilyFailures Class


BuiltInFailures.CurtainGridFamilyFailures.PanelsSlightlyMalformedCorruption Property

BuiltInFailuresCurtainGridFamilyFailuresPanelsSlightlyMalformedCorruption Property

Some panels in this curtain system are slightly malformed. The problem is most likely ignorable. This problem usually occurs when a panel or parts of a panel have been divided so that they are very narrow. To better see the malformed panels, temporarily hide the mullion category and set display of lines to ""thin lines"" (using the command on the view menu).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PanelsSlightlyMalformedCorruption { get; }
Public Shared ReadOnly Property PanelsSlightlyMalformedCorruption As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PanelsSlightlyMalformedCorruption {
    FailureDefinitionId^ get ();
}
static member PanelsSlightlyMalformedCorruption : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainGridFamilyFailures Class


BuiltInFailures.CurtainGridFamilyFailures.PanelsSlightlyMalformedWarning Property

BuiltInFailuresCurtainGridFamilyFailuresPanelsSlightlyMalformedWarning Property

Some panels in this curtain system are slightly malformed. The problem is most likely ignorable. This problem usually occurs when a panel or parts of a panel have been divided so that they are very narrow. To better see the malformed panels, temporarily hide the mullion category and set display of lines to ""thin lines"" (using the command on the view menu).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PanelsSlightlyMalformedWarning { get; }
Public Shared ReadOnly Property PanelsSlightlyMalformedWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PanelsSlightlyMalformedWarning {
    FailureDefinitionId^ get ();
}
static member PanelsSlightlyMalformedWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainGridFamilyFailures Class


BuiltInFailures.CurtainGridFamilyFailures.SomeMullionsAreTooShort Property

BuiltInFailuresCurtainGridFamilyFailuresSomeMullionsAreTooShort Property

Some of the mullions you are trying to place are too short for its types, and were not placed on the grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SomeMullionsAreTooShort { get; }
Public Shared ReadOnly Property SomeMullionsAreTooShort As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SomeMullionsAreTooShort {
    FailureDefinitionId^ get ();
}
static member SomeMullionsAreTooShort : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainGridFamilyFailures Class


BuiltInFailures.CurtainWallFailures Class

BuiltInFailuresCurtainWallFailures Class

Failures about CurtainWall.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresCurtainWallFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class CurtainWallFailures
Public NotInheritable Class CurtainWallFailures
public ref class CurtainWallFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CurtainWallFailures = class end

The BuiltInFailuresCurtainWallFailures type exposes the following members.

Properties
Name | Description
AdjustEndCurtainWallParameterNoCorners | Can't put Corner Mullion at end joined to non-Curtain Wall.
AllGridSegmentsRemoved | Curtain grid lines must have at least one segment.
CannotApplyGridSpecification | It is not possible to apply the host family's grid specification to this instance.
CannotDivideCurtainGrid | Can't divide Curtain Grid by Grid Line.
CannotGroupCurtainGridHost | Curtain grid based elements cannot be grouped.
CannotHaveIndependentOverlappingGrids | Overlapping independent type associated gridlines are not allowed.
CannotPlaceSplitMullions | Could not determine how to place the highlighted mullions after the wall was split.
CannotSplitOldMullions | Split does not work on curtain walls containing mullions created in Revit prior to version 4.0. You may delete the mullions, place them again, and then proceed with splitting the wall.
CannotSwitchToCurtainWall | Can't switch type to Curtain Wall after Edit Elevation Profile.
CannotUseCornerMullion | Corner Mullions must be placed at a location that can have neighboring Panels that are not tangent. With the exception of Wall Join locations, Corner Mullions are not currently supported on the external boundaries of Curtain elements.
CurtainGridFaceCannotBeReparamForGridRotation | Curtain grids cannot be rotated exactly as requested. Push "Adjust Grids" to get the nearest valid rotation.
CurtainGridOffHost | Curtain grid has left its host.
CurtainSystemHostInvisible | Element defining the Curtain System is invisible in the current view.
DanglingCurtainWallCorner | A Corner Mullion has been placed at the end of a Curtain Wall that is not joined to another Curtain Wall. The angle of the Corner Mullion will default to 90 degrees.
DeletingCurtainSystemFaceGridLines | Deleting Grid Lines residing on faces that no longer are part of a Curtain System.
DependentGridlineMayBeDeleted | Type generated gridlines will become non-associated due to changes in the type. Press delete if you wish to remove them instead.
ExceedMaxDrivenGridlines | Changes have been made that cause a curtain wall with type driven grid lines to exceed the maximum allowed number of type driven lines (200 in direction (1) and 200 in direction (2)). If you really need this many type driven grid lines, please split the affected wall before proceeding.
ExessiveBeltDistance | The requested Measurement Line Offset would place the put the Measurement Line of the face boundaries.
GridlinesOutOfBounds | Manually placed curtain grid lines are on the wall edges or outside the wall boundaries.
GridlinesOutOfBoundsWarn | Manually placed curtain grid lines are on the wall edges or outside the wall boundaries.
GridlinesOutsideWillBeRedependent | Type associated curtain grid lines outside of the edited wall boundaries will be made dependent again in order that they remain on the wall.
GridlinesOverlap | Overlapping gridlines should be avoided, unless there are only two and one is host type dependent and the other is not.
GridlinesWerePushed | Panels and mullions created by a curtain grid were created with slight inaccuracies.
GridOutOfOrder | Curtain wall grid lines have changed order.
GridOutOfOrderError | Curtain wall grid lines have changed order.
GridOutsideWall | Curtain wall grid lines are outside wall. If you are trying to shorten the wall, please remove grid lines, including mullions on top of them.
InvalidSkipSegments | A curtain grid line had invalid removed segment data. When correcting data, Revit may have split curtain panels that should be combined.
MullionLostRefReorder | Mullions have lost references as a result of gridlines changing order. These mullions must be deleted.
MullionsWillBeDeleted | The Mullions between the Panels being joined will be deleted.
MultipleDominatingMullions | Multiple dominating mullions on a grid face may cause ambiguous automatic adjustment of margins.
MultipleIdsInCurtainSystem | A Curtain System cannot be based on faces from multiple elements.
MustReplacePanels | Missing Curtain Panels will be replaced with System Panels to complete command.
NegativeBeltDistance | Measurement Line Offset cannot be negative.
NonSupportedCurtainWall | Currently, only straight Walls with straight or arc edges are supported for non-rectangular Curtain Walls.
NoPanelsLoaded | No Curtain Panel Families loaded. Can't make arced Curtain Wall.
RequestOrphanMullionDeletion | Due to the changes in parameters of their hosts some mullions became non-type driven.
RuledCurtainElementLostCurves | Ruled Curtain System cannot be built. The Lines or Edges used to create it cannot be found.
TypePanelsFronNonRectCellsUnlocked | Loaded family curtain panels cannot be used in non-rectangular cells of the curtain host. Type-driven panels from non-rectangular cells were unlocked and left unchanged.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CurtainWallFailures Properties

The BuiltInFailuresCurtainWallFailures type exposes the following members.

Properties
Name | Description
AdjustEndCurtainWallParameterNoCorners | Can't put Corner Mullion at end joined to non-Curtain Wall.
AllGridSegmentsRemoved | Curtain grid lines must have at least one segment.
CannotApplyGridSpecification | It is not possible to apply the host family's grid specification to this instance.
CannotDivideCurtainGrid | Can't divide Curtain Grid by Grid Line.
CannotGroupCurtainGridHost | Curtain grid based elements cannot be grouped.
CannotHaveIndependentOverlappingGrids | Overlapping independent type associated gridlines are not allowed.
CannotPlaceSplitMullions | Could not determine how to place the highlighted mullions after the wall was split.
CannotSplitOldMullions | Split does not work on curtain walls containing mullions created in Revit prior to version 4.0. You may delete the mullions, place them again, and then proceed with splitting the wall.
CannotSwitchToCurtainWall | Can't switch type to Curtain Wall after Edit Elevation Profile.
CannotUseCornerMullion | Corner Mullions must be placed at a location that can have neighboring Panels that are not tangent. With the exception of Wall Join locations, Corner Mullions are not currently supported on the external boundaries of Curtain elements.
CurtainGridFaceCannotBeReparamForGridRotation | Curtain grids cannot be rotated exactly as requested. Push "Adjust Grids" to get the nearest valid rotation.
CurtainGridOffHost | Curtain grid has left its host.
CurtainSystemHostInvisible | Element defining the Curtain System is invisible in the current view.
DanglingCurtainWallCorner | A Corner Mullion has been placed at the end of a Curtain Wall that is not joined to another Curtain Wall. The angle of the Corner Mullion will default to 90 degrees.
DeletingCurtainSystemFaceGridLines | Deleting Grid Lines residing on faces that no longer are part of a Curtain System.
DependentGridlineMayBeDeleted | Type generated gridlines will become non-associated due to changes in the type. Press delete if you wish to remove them instead.
ExceedMaxDrivenGridlines | Changes have been made that cause a curtain wall with type driven grid lines to exceed the maximum allowed number of type driven lines (200 in direction (1) and 200 in direction (2)). If you really need this many type driven grid lines, please split the affected wall before proceeding.
ExessiveBeltDistance | The requested Measurement Line Offset would place the put the Measurement Line of the face boundaries.
GridlinesOutOfBounds | Manually placed curtain grid lines are on the wall edges or outside the wall boundaries.
GridlinesOutOfBoundsWarn | Manually placed curtain grid lines are on the wall edges or outside the wall boundaries.
GridlinesOutsideWillBeRedependent | Type associated curtain grid lines outside of the edited wall boundaries will be made dependent again in order that they remain on the wall.
GridlinesOverlap | Overlapping gridlines should be avoided, unless there are only two and one is host type dependent and the other is not.
GridlinesWerePushed | Panels and mullions created by a curtain grid were created with slight inaccuracies.
GridOutOfOrder | Curtain wall grid lines have changed order.
GridOutOfOrderError | Curtain wall grid lines have changed order.
GridOutsideWall | Curtain wall grid lines are outside wall. If you are trying to shorten the wall, please remove grid lines, including mullions on top of them.
InvalidSkipSegments | A curtain grid line had invalid removed segment data. When correcting data, Revit may have split curtain panels that should be combined.
MullionLostRefReorder | Mullions have lost references as a result of gridlines changing order. These mullions must be deleted.
MullionsWillBeDeleted | The Mullions between the Panels being joined will be deleted.
MultipleDominatingMullions | Multiple dominating mullions on a grid face may cause ambiguous automatic adjustment of margins.
MultipleIdsInCurtainSystem | A Curtain System cannot be based on faces from multiple elements.
MustReplacePanels | Missing Curtain Panels will be replaced with System Panels to complete command.
NegativeBeltDistance | Measurement Line Offset cannot be negative.
NonSupportedCurtainWall | Currently, only straight Walls with straight or arc edges are supported for non-rectangular Curtain Walls.
NoPanelsLoaded | No Curtain Panel Families loaded. Can't make arced Curtain Wall.
RequestOrphanMullionDeletion | Due to the changes in parameters of their hosts some mullions became non-type driven.
RuledCurtainElementLostCurves | Ruled Curtain System cannot be built. The Lines or Edges used to create it cannot be found.
TypePanelsFronNonRectCellsUnlocked | Loaded family curtain panels cannot be used in non-rectangular cells of the curtain host. Type-driven panels from non-rectangular cells were unlocked and left unchanged.
Top
See Also

Reference

BuiltInFailuresCurtainWallFailures Class


BuiltInFailures.CurtainWallFailures.AdjustEndCurtainWallParameterNoCorners Property

BuiltInFailuresCurtainWallFailuresAdjustEndCurtainWallParameterNoCorners Property

Can't put Corner Mullion at end joined to non-Curtain Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AdjustEndCurtainWallParameterNoCorners { get; }
Public Shared ReadOnly Property AdjustEndCurtainWallParameterNoCorners As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AdjustEndCurtainWallParameterNoCorners {
    FailureDefinitionId^ get ();
}
static member AdjustEndCurtainWallParameterNoCorners : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainWallFailures Class


BuiltInFailures.CurtainWallFailures.AllGridSegmentsRemoved Property

BuiltInFailuresCurtainWallFailuresAllGridSegmentsRemoved Property

Curtain grid lines must have at least one segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AllGridSegmentsRemoved { get; }
Public Shared ReadOnly Property AllGridSegmentsRemoved As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AllGridSegmentsRemoved {
    FailureDefinitionId^ get ();
}
static member AllGridSegmentsRemoved : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainWallFailures Class


BuiltInFailures.CurtainWallFailures.CannotApplyGridSpecification Property

BuiltInFailuresCurtainWallFailuresCannotApplyGridSpecification Property

It is not possible to apply the host family's grid specification to this instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotApplyGridSpecification { get; }
Public Shared ReadOnly Property CannotApplyGridSpecification As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotApplyGridSpecification {
    FailureDefinitionId^ get ();
}
static member CannotApplyGridSpecification : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainWallFailures Class


BuiltInFailures.CurtainWallFailures.CannotDivideCurtainGrid Property

BuiltInFailuresCurtainWallFailuresCannotDivideCurtainGrid Property

Can't divide Curtain Grid by Grid Line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotDivideCurtainGrid { get; }
Public Shared ReadOnly Property CannotDivideCurtainGrid As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotDivideCurtainGrid {
    FailureDefinitionId^ get ();
}
static member CannotDivideCurtainGrid : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainWallFailures Class


BuiltInFailures.CurtainWallFailures.CannotGroupCurtainGridHost Property

BuiltInFailuresCurtainWallFailuresCannotGroupCurtainGridHost Property

Curtain grid based elements cannot be grouped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotGroupCurtainGridHost { get; }
Public Shared ReadOnly Property CannotGroupCurtainGridHost As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotGroupCurtainGridHost {
    FailureDefinitionId^ get ();
}
static member CannotGroupCurtainGridHost : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainWallFailures Class


BuiltInFailures.CurtainWallFailures.CannotHaveIndependentOverlappingGrids Property

BuiltInFailuresCurtainWallFailuresCannotHaveIndependentOverlappingGrids Property

Overlapping independent type associated gridlines are not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotHaveIndependentOverlappingGrids { get; }
Public Shared ReadOnly Property CannotHaveIndependentOverlappingGrids As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotHaveIndependentOverlappingGrids {
    FailureDefinitionId^ get ();
}
static member CannotHaveIndependentOverlappingGrids : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainWallFailures Class


BuiltInFailures.CurtainWallFailures.CannotPlaceSplitMullions Property

BuiltInFailuresCurtainWallFailuresCannotPlaceSplitMullions Property

Could not determine how to place the highlighted mullions after the wall was split.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPlaceSplitMullions { get; }
Public Shared ReadOnly Property CannotPlaceSplitMullions As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPlaceSplitMullions {
    FailureDefinitionId^ get ();
}
static member CannotPlaceSplitMullions : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainWallFailures Class


BuiltInFailures.CurtainWallFailures.CannotSplitOldMullions Property

BuiltInFailuresCurtainWallFailuresCannotSplitOldMullions Property

Split does not work on curtain walls containing mullions created in Revit prior to version 4.0. You may delete the mullions, place them again, and then proceed with splitting the wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotSplitOldMullions { get; }
Public Shared ReadOnly Property CannotSplitOldMullions As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotSplitOldMullions {
    FailureDefinitionId^ get ();
}
static member CannotSplitOldMullions : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainWallFailures Class


BuiltInFailures.CurtainWallFailures.CannotSwitchToCurtainWall Property

BuiltInFailuresCurtainWallFailuresCannotSwitchToCurtainWall Property

Can't switch type to Curtain Wall after Edit Elevation Profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotSwitchToCurtainWall { get; }
Public Shared ReadOnly Property CannotSwitchToCurtainWall As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotSwitchToCurtainWall {
    FailureDefinitionId^ get ();
}
static member CannotSwitchToCurtainWall : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainWallFailures Class


BuiltInFailures.CurtainWallFailures.CannotUseCornerMullion Property

BuiltInFailuresCurtainWallFailuresCannotUseCornerMullion Property

Corner Mullions must be placed at a location that can have neighboring Panels that are not tangent. With the exception of Wall Join locations, Corner Mullions are not currently supported on the external boundaries of Curtain elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotUseCornerMullion { get; }
Public Shared ReadOnly Property CannotUseCornerMullion As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotUseCornerMullion {
    FailureDefinitionId^ get ();
}
static member CannotUseCornerMullion : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainWallFailures Class


BuiltInFailures.CurtainWallFailures.CurtainGridFaceCannotBeReparamForGridRotation Property

BuiltInFailuresCurtainWallFailuresCurtainGridFaceCannotBeReparamForGridRotation Property

Curtain grids cannot be rotated exactly as requested. Push "Adjust Grids" to get the nearest valid rotation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CurtainGridFaceCannotBeReparamForGridRotation { get; }
Public Shared ReadOnly Property CurtainGridFaceCannotBeReparamForGridRotation As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CurtainGridFaceCannotBeReparamForGridRotation {
    FailureDefinitionId^ get ();
}
static member CurtainGridFaceCannotBeReparamForGridRotation : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainWallFailures Class


BuiltInFailures.CurtainWallFailures.CurtainGridOffHost Property

BuiltInFailuresCurtainWallFailuresCurtainGridOffHost Property

Curtain grid has left its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CurtainGridOffHost { get; }
Public Shared ReadOnly Property CurtainGridOffHost As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CurtainGridOffHost {
    FailureDefinitionId^ get ();
}
static member CurtainGridOffHost : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainWallFailures Class


BuiltInFailures.CurtainWallFailures.CurtainSystemHostInvisible Property

BuiltInFailuresCurtainWallFailuresCurtainSystemHostInvisible Property

Element defining the Curtain System is invisible in the current view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CurtainSystemHostInvisible { get; }
Public Shared ReadOnly Property CurtainSystemHostInvisible As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CurtainSystemHostInvisible {
    FailureDefinitionId^ get ();
}
static member CurtainSystemHostInvisible : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainWallFailures Class


BuiltInFailures.CurtainWallFailures.DanglingCurtainWallCorner Property

BuiltInFailuresCurtainWallFailuresDanglingCurtainWallCorner Property

A Corner Mullion has been placed at the end of a Curtain Wall that is not joined to another Curtain Wall. The angle of the Corner Mullion will default to 90 degrees.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DanglingCurtainWallCorner { get; }
Public Shared ReadOnly Property DanglingCurtainWallCorner As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DanglingCurtainWallCorner {
    FailureDefinitionId^ get ();
}
static member DanglingCurtainWallCorner : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainWallFailures Class


BuiltInFailures.CurtainWallFailures.DeletingCurtainSystemFaceGridLines Property

BuiltInFailuresCurtainWallFailuresDeletingCurtainSystemFaceGridLines Property

Deleting Grid Lines residing on faces that no longer are part of a Curtain System.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DeletingCurtainSystemFaceGridLines { get; }
Public Shared ReadOnly Property DeletingCurtainSystemFaceGridLines As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DeletingCurtainSystemFaceGridLines {
    FailureDefinitionId^ get ();
}
static member DeletingCurtainSystemFaceGridLines : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainWallFailures Class


BuiltInFailures.CurtainWallFailures.DependentGridlineMayBeDeleted Property

BuiltInFailuresCurtainWallFailuresDependentGridlineMayBeDeleted Property

Type generated gridlines will become non-associated due to changes in the type. Press delete if you wish to remove them instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DependentGridlineMayBeDeleted { get; }
Public Shared ReadOnly Property DependentGridlineMayBeDeleted As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DependentGridlineMayBeDeleted {
    FailureDefinitionId^ get ();
}
static member DependentGridlineMayBeDeleted : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainWallFailures Class


BuiltInFailures.CurtainWallFailures.ExceedMaxDrivenGridlines Property

BuiltInFailuresCurtainWallFailuresExceedMaxDrivenGridlines Property

Changes have been made that cause a curtain wall with type driven grid lines to exceed the maximum allowed number of type driven lines (200 in direction (1) and 200 in direction (2)). If you really need this many type driven grid lines, please split the affected wall before proceeding.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ExceedMaxDrivenGridlines { get; }
Public Shared ReadOnly Property ExceedMaxDrivenGridlines As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ExceedMaxDrivenGridlines {
    FailureDefinitionId^ get ();
}
static member ExceedMaxDrivenGridlines : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainWallFailures Class


BuiltInFailures.CurtainWallFailures.ExessiveBeltDistance Property

BuiltInFailuresCurtainWallFailuresExessiveBeltDistance Property

The requested Measurement Line Offset would place the put the Measurement Line of the face boundaries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ExessiveBeltDistance { get; }
Public Shared ReadOnly Property ExessiveBeltDistance As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ExessiveBeltDistance {
    FailureDefinitionId^ get ();
}
static member ExessiveBeltDistance : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainWallFailures Class


BuiltInFailures.CurtainWallFailures.GridlinesOutOfBounds Property

BuiltInFailuresCurtainWallFailuresGridlinesOutOfBounds Property

Manually placed curtain grid lines are on the wall edges or outside the wall boundaries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId GridlinesOutOfBounds { get; }
Public Shared ReadOnly Property GridlinesOutOfBounds As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ GridlinesOutOfBounds {
    FailureDefinitionId^ get ();
}
static member GridlinesOutOfBounds : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainWallFailures Class


BuiltInFailures.CurtainWallFailures.GridlinesOutOfBoundsWarn Property

BuiltInFailuresCurtainWallFailuresGridlinesOutOfBoundsWarn Property

Manually placed curtain grid lines are on the wall edges or outside the wall boundaries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId GridlinesOutOfBoundsWarn { get; }
Public Shared ReadOnly Property GridlinesOutOfBoundsWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ GridlinesOutOfBoundsWarn {
    FailureDefinitionId^ get ();
}
static member GridlinesOutOfBoundsWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainWallFailures Class


BuiltInFailures.CurtainWallFailures.GridlinesOutsideWillBeRedependent Property

BuiltInFailuresCurtainWallFailuresGridlinesOutsideWillBeRedependent Property

Type associated curtain grid lines outside of the edited wall boundaries will be made dependent again in order that they remain on the wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId GridlinesOutsideWillBeRedependent { get; }
Public Shared ReadOnly Property GridlinesOutsideWillBeRedependent As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ GridlinesOutsideWillBeRedependent {
    FailureDefinitionId^ get ();
}
static member GridlinesOutsideWillBeRedependent : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainWallFailures Class


BuiltInFailures.CurtainWallFailures.GridlinesOverlap Property

BuiltInFailuresCurtainWallFailuresGridlinesOverlap Property

Overlapping gridlines should be avoided, unless there are only two and one is host type dependent and the other is not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId GridlinesOverlap { get; }
Public Shared ReadOnly Property GridlinesOverlap As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ GridlinesOverlap {
    FailureDefinitionId^ get ();
}
static member GridlinesOverlap : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainWallFailures Class


BuiltInFailures.CurtainWallFailures.GridlinesWerePushed Property

BuiltInFailuresCurtainWallFailuresGridlinesWerePushed Property

Panels and mullions created by a curtain grid were created with slight inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId GridlinesWerePushed { get; }
Public Shared ReadOnly Property GridlinesWerePushed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ GridlinesWerePushed {
    FailureDefinitionId^ get ();
}
static member GridlinesWerePushed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainWallFailures Class


BuiltInFailures.CurtainWallFailures.GridOutOfOrder Property

BuiltInFailuresCurtainWallFailuresGridOutOfOrder Property

Curtain wall grid lines have changed order.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId GridOutOfOrder { get; }
Public Shared ReadOnly Property GridOutOfOrder As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ GridOutOfOrder {
    FailureDefinitionId^ get ();
}
static member GridOutOfOrder : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainWallFailures Class


BuiltInFailures.CurtainWallFailures.GridOutOfOrderError Property

BuiltInFailuresCurtainWallFailuresGridOutOfOrderError Property

Curtain wall grid lines have changed order.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId GridOutOfOrderError { get; }
Public Shared ReadOnly Property GridOutOfOrderError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ GridOutOfOrderError {
    FailureDefinitionId^ get ();
}
static member GridOutOfOrderError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainWallFailures Class


BuiltInFailures.CurtainWallFailures.GridOutsideWall Property

BuiltInFailuresCurtainWallFailuresGridOutsideWall Property

Curtain wall grid lines are outside wall. If you are trying to shorten the wall, please remove grid lines, including mullions on top of them.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId GridOutsideWall { get; }
Public Shared ReadOnly Property GridOutsideWall As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ GridOutsideWall {
    FailureDefinitionId^ get ();
}
static member GridOutsideWall : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainWallFailures Class


BuiltInFailures.CurtainWallFailures.InvalidSkipSegments Property

BuiltInFailuresCurtainWallFailuresInvalidSkipSegments Property

A curtain grid line had invalid removed segment data. When correcting data, Revit may have split curtain panels that should be combined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidSkipSegments { get; }
Public Shared ReadOnly Property InvalidSkipSegments As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidSkipSegments {
    FailureDefinitionId^ get ();
}
static member InvalidSkipSegments : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainWallFailures Class


BuiltInFailures.CurtainWallFailures.MullionLostRefReorder Property

BuiltInFailuresCurtainWallFailuresMullionLostRefReorder Property

Mullions have lost references as a result of gridlines changing order. These mullions must be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MullionLostRefReorder { get; }
Public Shared ReadOnly Property MullionLostRefReorder As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MullionLostRefReorder {
    FailureDefinitionId^ get ();
}
static member MullionLostRefReorder : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainWallFailures Class


BuiltInFailures.CurtainWallFailures.MullionsWillBeDeleted Property

BuiltInFailuresCurtainWallFailuresMullionsWillBeDeleted Property

The Mullions between the Panels being joined will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MullionsWillBeDeleted { get; }
Public Shared ReadOnly Property MullionsWillBeDeleted As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MullionsWillBeDeleted {
    FailureDefinitionId^ get ();
}
static member MullionsWillBeDeleted : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainWallFailures Class


BuiltInFailures.CurtainWallFailures.MultipleDominatingMullions Property

BuiltInFailuresCurtainWallFailuresMultipleDominatingMullions Property

Multiple dominating mullions on a grid face may cause ambiguous automatic adjustment of margins.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MultipleDominatingMullions { get; }
Public Shared ReadOnly Property MultipleDominatingMullions As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MultipleDominatingMullions {
    FailureDefinitionId^ get ();
}
static member MultipleDominatingMullions : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainWallFailures Class


BuiltInFailures.CurtainWallFailures.MultipleIdsInCurtainSystem Property

BuiltInFailuresCurtainWallFailuresMultipleIdsInCurtainSystem Property

A Curtain System cannot be based on faces from multiple elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MultipleIdsInCurtainSystem { get; }
Public Shared ReadOnly Property MultipleIdsInCurtainSystem As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MultipleIdsInCurtainSystem {
    FailureDefinitionId^ get ();
}
static member MultipleIdsInCurtainSystem : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainWallFailures Class


BuiltInFailures.CurtainWallFailures.MustReplacePanels Property

BuiltInFailuresCurtainWallFailuresMustReplacePanels Property

Missing Curtain Panels will be replaced with System Panels to complete command.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MustReplacePanels { get; }
Public Shared ReadOnly Property MustReplacePanels As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MustReplacePanels {
    FailureDefinitionId^ get ();
}
static member MustReplacePanels : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainWallFailures Class


BuiltInFailures.CurtainWallFailures.NegativeBeltDistance Property

BuiltInFailuresCurtainWallFailuresNegativeBeltDistance Property

Measurement Line Offset cannot be negative.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NegativeBeltDistance { get; }
Public Shared ReadOnly Property NegativeBeltDistance As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NegativeBeltDistance {
    FailureDefinitionId^ get ();
}
static member NegativeBeltDistance : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainWallFailures Class


BuiltInFailures.CurtainWallFailures.NonSupportedCurtainWall Property

BuiltInFailuresCurtainWallFailuresNonSupportedCurtainWall Property

Currently, only straight Walls with straight or arc edges are supported for non-rectangular Curtain Walls.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NonSupportedCurtainWall { get; }
Public Shared ReadOnly Property NonSupportedCurtainWall As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NonSupportedCurtainWall {
    FailureDefinitionId^ get ();
}
static member NonSupportedCurtainWall : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainWallFailures Class


BuiltInFailures.CurtainWallFailures.NoPanelsLoaded Property

BuiltInFailuresCurtainWallFailuresNoPanelsLoaded Property

No Curtain Panel Families loaded. Can't make arced Curtain Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoPanelsLoaded { get; }
Public Shared ReadOnly Property NoPanelsLoaded As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoPanelsLoaded {
    FailureDefinitionId^ get ();
}
static member NoPanelsLoaded : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainWallFailures Class


BuiltInFailures.CurtainWallFailures.RequestOrphanMullionDeletion Property

BuiltInFailuresCurtainWallFailuresRequestOrphanMullionDeletion Property

Due to the changes in parameters of their hosts some mullions became non-type driven.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RequestOrphanMullionDeletion { get; }
Public Shared ReadOnly Property RequestOrphanMullionDeletion As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RequestOrphanMullionDeletion {
    FailureDefinitionId^ get ();
}
static member RequestOrphanMullionDeletion : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainWallFailures Class


BuiltInFailures.CurtainWallFailures.RuledCurtainElementLostCurves Property

BuiltInFailuresCurtainWallFailuresRuledCurtainElementLostCurves Property

Ruled Curtain System cannot be built. The Lines or Edges used to create it cannot be found.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RuledCurtainElementLostCurves { get; }
Public Shared ReadOnly Property RuledCurtainElementLostCurves As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RuledCurtainElementLostCurves {
    FailureDefinitionId^ get ();
}
static member RuledCurtainElementLostCurves : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainWallFailures Class


BuiltInFailures.CurtainWallFailures.TypePanelsFronNonRectCellsUnlocked Property

BuiltInFailuresCurtainWallFailuresTypePanelsFronNonRectCellsUnlocked Property

Loaded family curtain panels cannot be used in non-rectangular cells of the curtain host. Type-driven panels from non-rectangular cells were unlocked and left unchanged.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TypePanelsFronNonRectCellsUnlocked { get; }
Public Shared ReadOnly Property TypePanelsFronNonRectCellsUnlocked As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TypePanelsFronNonRectCellsUnlocked {
    FailureDefinitionId^ get ();
}
static member TypePanelsFronNonRectCellsUnlocked : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurtainWallFailures Class


BuiltInFailures.CurveByPointFailures Class

BuiltInFailuresCurveByPointFailures Class

Failures about Curve By Point Element
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresCurveByPointFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class CurveByPointFailures
Public NotInheritable Class CurveByPointFailures
public ref class CurveByPointFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CurveByPointFailures = class end

The BuiltInFailuresCurveByPointFailures type exposes the following members.

Properties
Name | Description
UnableToGenerateCurve | Unable to generate valid curve geometry from the driving points. The line by points will be dissolved.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CurveByPointFailures Properties

The BuiltInFailuresCurveByPointFailures type exposes the following members.

Properties
Name | Description
UnableToGenerateCurve | Unable to generate valid curve geometry from the driving points. The line by points will be dissolved.
Top
See Also

Reference

BuiltInFailuresCurveByPointFailures Class


BuiltInFailures.CurveByPointFailures.UnableToGenerateCurve Property

BuiltInFailuresCurveByPointFailuresUnableToGenerateCurve Property

Unable to generate valid curve geometry from the driving points. The line by points will be dissolved.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnableToGenerateCurve { get; }
Public Shared ReadOnly Property UnableToGenerateCurve As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnableToGenerateCurve {
    FailureDefinitionId^ get ();
}
static member UnableToGenerateCurve : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurveByPointFailures Class


BuiltInFailures.CurveFailures Class

BuiltInFailuresCurveFailures Class

Failures about Curves and Curve-Driven Elements.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresCurveFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class CurveFailures
Public NotInheritable Class CurveFailures
public ref class CurveFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CurveFailures = class end

The BuiltInFailuresCurveFailures type exposes the following members.

Properties
Name | Description
CannotFindAreaScheme | Can't find new Area Scheme for Area Boundary.
CantKeepJoinTangent | Can't keep curve join tangent.
CurveNotEditable | Lines created by massing or picking 3d path are not editable.
CurveNotEditableWarn | Lines created by massing or picking 3d path are not editable.
InvalidCurveForElement | End positions are invalid.
LineTooShortError | Line is too short.
LineTooShortWarning | Line is too short.
PeriodicCurveBadParams | End positions are invalid.
SelfIntersectingSpline | Self intersecting splines are not allowed in sketches.
TooShort | Line is too short.
TopLevelBelowBottomLevel | For curveElem support multiple levels, top level belows curve bottom level.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CurveFailures Properties

The BuiltInFailuresCurveFailures type exposes the following members.

Properties
Name | Description
CannotFindAreaScheme | Can't find new Area Scheme for Area Boundary.
CantKeepJoinTangent | Can't keep curve join tangent.
CurveNotEditable | Lines created by massing or picking 3d path are not editable.
CurveNotEditableWarn | Lines created by massing or picking 3d path are not editable.
InvalidCurveForElement | End positions are invalid.
LineTooShortError | Line is too short.
LineTooShortWarning | Line is too short.
PeriodicCurveBadParams | End positions are invalid.
SelfIntersectingSpline | Self intersecting splines are not allowed in sketches.
TooShort | Line is too short.
TopLevelBelowBottomLevel | For curveElem support multiple levels, top level belows curve bottom level.
Top
See Also

Reference

BuiltInFailuresCurveFailures Class


BuiltInFailures.CurveFailures.CannotFindAreaScheme Property

BuiltInFailuresCurveFailuresCannotFindAreaScheme Property

Can't find new Area Scheme for Area Boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotFindAreaScheme { get; }
Public Shared ReadOnly Property CannotFindAreaScheme As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotFindAreaScheme {
    FailureDefinitionId^ get ();
}
static member CannotFindAreaScheme : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurveFailures Class


BuiltInFailures.CurveFailures.CantKeepJoinTangent Property

BuiltInFailuresCurveFailuresCantKeepJoinTangent Property

Can't keep curve join tangent.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CantKeepJoinTangent { get; }
Public Shared ReadOnly Property CantKeepJoinTangent As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CantKeepJoinTangent {
    FailureDefinitionId^ get ();
}
static member CantKeepJoinTangent : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurveFailures Class


BuiltInFailures.CurveFailures.CurveNotEditable Property

BuiltInFailuresCurveFailuresCurveNotEditable Property

Lines created by massing or picking 3d path are not editable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CurveNotEditable { get; }
Public Shared ReadOnly Property CurveNotEditable As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CurveNotEditable {
    FailureDefinitionId^ get ();
}
static member CurveNotEditable : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurveFailures Class


BuiltInFailures.CurveFailures.CurveNotEditableWarn Property

BuiltInFailuresCurveFailuresCurveNotEditableWarn Property

Lines created by massing or picking 3d path are not editable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CurveNotEditableWarn { get; }
Public Shared ReadOnly Property CurveNotEditableWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CurveNotEditableWarn {
    FailureDefinitionId^ get ();
}
static member CurveNotEditableWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurveFailures Class


BuiltInFailures.CurveFailures.InvalidCurveForElement Property

BuiltInFailuresCurveFailuresInvalidCurveForElement Property

End positions are invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidCurveForElement { get; }
Public Shared ReadOnly Property InvalidCurveForElement As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidCurveForElement {
    FailureDefinitionId^ get ();
}
static member InvalidCurveForElement : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurveFailures Class


BuiltInFailures.CurveFailures.LineTooShortError Property

BuiltInFailuresCurveFailuresLineTooShortError Property

Line is too short.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LineTooShortError { get; }
Public Shared ReadOnly Property LineTooShortError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LineTooShortError {
    FailureDefinitionId^ get ();
}
static member LineTooShortError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurveFailures Class


BuiltInFailures.CurveFailures.LineTooShortWarning Property

BuiltInFailuresCurveFailuresLineTooShortWarning Property

Line is too short.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LineTooShortWarning { get; }
Public Shared ReadOnly Property LineTooShortWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LineTooShortWarning {
    FailureDefinitionId^ get ();
}
static member LineTooShortWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurveFailures Class


BuiltInFailures.CurveFailures.PeriodicCurveBadParams Property

BuiltInFailuresCurveFailuresPeriodicCurveBadParams Property

End positions are invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PeriodicCurveBadParams { get; }
Public Shared ReadOnly Property PeriodicCurveBadParams As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PeriodicCurveBadParams {
    FailureDefinitionId^ get ();
}
static member PeriodicCurveBadParams : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurveFailures Class


BuiltInFailures.CurveFailures.SelfIntersectingSpline Property

BuiltInFailuresCurveFailuresSelfIntersectingSpline Property

Self intersecting splines are not allowed in sketches.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SelfIntersectingSpline { get; }
Public Shared ReadOnly Property SelfIntersectingSpline As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SelfIntersectingSpline {
    FailureDefinitionId^ get ();
}
static member SelfIntersectingSpline : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurveFailures Class


BuiltInFailures.CurveFailures.TooShort Property

BuiltInFailuresCurveFailuresTooShort Property

Line is too short.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TooShort { get; }
Public Shared ReadOnly Property TooShort As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TooShort {
    FailureDefinitionId^ get ();
}
static member TooShort : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurveFailures Class


BuiltInFailures.CurveFailures.TopLevelBelowBottomLevel Property

BuiltInFailuresCurveFailuresTopLevelBelowBottomLevel Property

For curveElem support multiple levels, top level belows curve bottom level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TopLevelBelowBottomLevel { get; }
Public Shared ReadOnly Property TopLevelBelowBottomLevel As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TopLevelBelowBottomLevel {
    FailureDefinitionId^ get ();
}
static member TopLevelBelowBottomLevel : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCurveFailures Class


BuiltInFailures.CutFailures Class

BuiltInFailuresCutFailures Class

Failures about Cut.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresCutFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class CutFailures
Public NotInheritable Class CutFailures
public ref class CutFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CutFailures = class end

The BuiltInFailuresCutFailures type exposes the following members.

Properties
Name | Description
CannotCutGeometry | Elements do not intersect.
CannotCutGeometryWarn | Elements do not intersect.
CannotCutInstanceOut | Can't cut instance of [Symbol] out of Wall.
CannotCutInstanceOutError | Can't cut instance of [Symbol] out of Wall.
CannotCutInstanceOutGen | Can't cut instance(s) of [Symbol] out of its host.
CannotCutInstanceOutGenError | Can't cut instance(s) of [Symbol] out of its host.
CannotCutInstanceOutGenWarn | Can't cut instance(s) of [Symbol] out of its host.
CannotCutInstanceOutWarn | Can't cut instance of [Symbol] out of Wall.
CannotCutJoinedElement | Can't cut joined element.
CannotCutRoof | The roof couldn't be cut.
CannotCutRoofError | The roof couldn't be cut.
CantCutHostWithInstance | Can't cut host with instance.
CutExactlyHalf | Can't cut in half. Move plane towards either end.
CutoutNotCuttingAnything | Opening not cutting anything.
CutoutNotCuttingAnythingDeleteOpening | Opening not cutting anything.
DormerCutProblem | Dormer Opening Cut is not fully defined. Cut was not performed.
DormerCutProblemWarn | Dormer Opening Cut is not fully defined. Cut was not performed.
HostCutoutForInsertionFailure | Can't cut host for inserted objects
InstanceNotCuttingAnything | Instance(s) of [Symbol] not cutting anything.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CutFailures Properties

The BuiltInFailuresCutFailures type exposes the following members.

Properties
Name | Description
CannotCutGeometry | Elements do not intersect.
CannotCutGeometryWarn | Elements do not intersect.
CannotCutInstanceOut | Can't cut instance of [Symbol] out of Wall.
CannotCutInstanceOutError | Can't cut instance of [Symbol] out of Wall.
CannotCutInstanceOutGen | Can't cut instance(s) of [Symbol] out of its host.
CannotCutInstanceOutGenError | Can't cut instance(s) of [Symbol] out of its host.
CannotCutInstanceOutGenWarn | Can't cut instance(s) of [Symbol] out of its host.
CannotCutInstanceOutWarn | Can't cut instance of [Symbol] out of Wall.
CannotCutJoinedElement | Can't cut joined element.
CannotCutRoof | The roof couldn't be cut.
CannotCutRoofError | The roof couldn't be cut.
CantCutHostWithInstance | Can't cut host with instance.
CutExactlyHalf | Can't cut in half. Move plane towards either end.
CutoutNotCuttingAnything | Opening not cutting anything.
CutoutNotCuttingAnythingDeleteOpening | Opening not cutting anything.
DormerCutProblem | Dormer Opening Cut is not fully defined. Cut was not performed.
DormerCutProblemWarn | Dormer Opening Cut is not fully defined. Cut was not performed.
HostCutoutForInsertionFailure | Can't cut host for inserted objects
InstanceNotCuttingAnything | Instance(s) of [Symbol] not cutting anything.
Top
See Also

Reference

BuiltInFailuresCutFailures Class


BuiltInFailures.CutFailures.CannotCutGeometry Property

BuiltInFailuresCutFailuresCannotCutGeometry Property

Elements do not intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCutGeometry { get; }
Public Shared ReadOnly Property CannotCutGeometry As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCutGeometry {
    FailureDefinitionId^ get ();
}
static member CannotCutGeometry : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCutFailures Class


BuiltInFailures.CutFailures.CannotCutGeometryWarn Property

BuiltInFailuresCutFailuresCannotCutGeometryWarn Property

Elements do not intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCutGeometryWarn { get; }
Public Shared ReadOnly Property CannotCutGeometryWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCutGeometryWarn {
    FailureDefinitionId^ get ();
}
static member CannotCutGeometryWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCutFailures Class


BuiltInFailures.CutFailures.CannotCutInstanceOut Property

BuiltInFailuresCutFailuresCannotCutInstanceOut Property

Can't cut instance of [Symbol] out of Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCutInstanceOut { get; }
Public Shared ReadOnly Property CannotCutInstanceOut As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCutInstanceOut {
    FailureDefinitionId^ get ();
}
static member CannotCutInstanceOut : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCutFailures Class


BuiltInFailures.CutFailures.CannotCutInstanceOutError Property

BuiltInFailuresCutFailuresCannotCutInstanceOutError Property

Can't cut instance of [Symbol] out of Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCutInstanceOutError { get; }
Public Shared ReadOnly Property CannotCutInstanceOutError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCutInstanceOutError {
    FailureDefinitionId^ get ();
}
static member CannotCutInstanceOutError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCutFailures Class


BuiltInFailures.CutFailures.CannotCutInstanceOutGen Property

BuiltInFailuresCutFailuresCannotCutInstanceOutGen Property

Can't cut instance(s) of [Symbol] out of its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCutInstanceOutGen { get; }
Public Shared ReadOnly Property CannotCutInstanceOutGen As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCutInstanceOutGen {
    FailureDefinitionId^ get ();
}
static member CannotCutInstanceOutGen : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCutFailures Class


BuiltInFailures.CutFailures.CannotCutInstanceOutGenError Property

BuiltInFailuresCutFailuresCannotCutInstanceOutGenError Property

Can't cut instance(s) of [Symbol] out of its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCutInstanceOutGenError { get; }
Public Shared ReadOnly Property CannotCutInstanceOutGenError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCutInstanceOutGenError {
    FailureDefinitionId^ get ();
}
static member CannotCutInstanceOutGenError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCutFailures Class


BuiltInFailures.CutFailures.CannotCutInstanceOutGenWarn Property

BuiltInFailuresCutFailuresCannotCutInstanceOutGenWarn Property

Can't cut instance(s) of [Symbol] out of its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCutInstanceOutGenWarn { get; }
Public Shared ReadOnly Property CannotCutInstanceOutGenWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCutInstanceOutGenWarn {
    FailureDefinitionId^ get ();
}
static member CannotCutInstanceOutGenWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCutFailures Class


BuiltInFailures.CutFailures.CannotCutInstanceOutWarn Property

BuiltInFailuresCutFailuresCannotCutInstanceOutWarn Property

Can't cut instance of [Symbol] out of Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCutInstanceOutWarn { get; }
Public Shared ReadOnly Property CannotCutInstanceOutWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCutInstanceOutWarn {
    FailureDefinitionId^ get ();
}
static member CannotCutInstanceOutWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCutFailures Class


BuiltInFailures.CutFailures.CannotCutJoinedElement Property

BuiltInFailuresCutFailuresCannotCutJoinedElement Property

Can't cut joined element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCutJoinedElement { get; }
Public Shared ReadOnly Property CannotCutJoinedElement As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCutJoinedElement {
    FailureDefinitionId^ get ();
}
static member CannotCutJoinedElement : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCutFailures Class


BuiltInFailures.CutFailures.CannotCutRoof Property

BuiltInFailuresCutFailuresCannotCutRoof Property

The roof couldn't be cut.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCutRoof { get; }
Public Shared ReadOnly Property CannotCutRoof As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCutRoof {
    FailureDefinitionId^ get ();
}
static member CannotCutRoof : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCutFailures Class


BuiltInFailures.CutFailures.CannotCutRoofError Property

BuiltInFailuresCutFailuresCannotCutRoofError Property

The roof couldn't be cut.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCutRoofError { get; }
Public Shared ReadOnly Property CannotCutRoofError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCutRoofError {
    FailureDefinitionId^ get ();
}
static member CannotCutRoofError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCutFailures Class


BuiltInFailures.CutFailures.CantCutHostWithInstance Property

BuiltInFailuresCutFailuresCantCutHostWithInstance Property

Can't cut host with instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CantCutHostWithInstance { get; }
Public Shared ReadOnly Property CantCutHostWithInstance As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CantCutHostWithInstance {
    FailureDefinitionId^ get ();
}
static member CantCutHostWithInstance : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCutFailures Class


BuiltInFailures.CutFailures.CutExactlyHalf Property

BuiltInFailuresCutFailuresCutExactlyHalf Property

Can't cut in half. Move plane towards either end.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CutExactlyHalf { get; }
Public Shared ReadOnly Property CutExactlyHalf As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CutExactlyHalf {
    FailureDefinitionId^ get ();
}
static member CutExactlyHalf : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCutFailures Class


BuiltInFailures.CutFailures.CutoutNotCuttingAnything Property

BuiltInFailuresCutFailuresCutoutNotCuttingAnything Property

Opening not cutting anything.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CutoutNotCuttingAnything { get; }
Public Shared ReadOnly Property CutoutNotCuttingAnything As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CutoutNotCuttingAnything {
    FailureDefinitionId^ get ();
}
static member CutoutNotCuttingAnything : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCutFailures Class


BuiltInFailures.CutFailures.CutoutNotCuttingAnythingDeleteOpening Property

BuiltInFailuresCutFailuresCutoutNotCuttingAnythingDeleteOpening Property

Opening not cutting anything.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CutoutNotCuttingAnythingDeleteOpening { get; }
Public Shared ReadOnly Property CutoutNotCuttingAnythingDeleteOpening As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CutoutNotCuttingAnythingDeleteOpening {
    FailureDefinitionId^ get ();
}
static member CutoutNotCuttingAnythingDeleteOpening : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCutFailures Class


BuiltInFailures.CutFailures.DormerCutProblem Property

BuiltInFailuresCutFailuresDormerCutProblem Property

Dormer Opening Cut is not fully defined. Cut was not performed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DormerCutProblem { get; }
Public Shared ReadOnly Property DormerCutProblem As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DormerCutProblem {
    FailureDefinitionId^ get ();
}
static member DormerCutProblem : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCutFailures Class


BuiltInFailures.CutFailures.DormerCutProblemWarn Property

BuiltInFailuresCutFailuresDormerCutProblemWarn Property

Dormer Opening Cut is not fully defined. Cut was not performed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DormerCutProblemWarn { get; }
Public Shared ReadOnly Property DormerCutProblemWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DormerCutProblemWarn {
    FailureDefinitionId^ get ();
}
static member DormerCutProblemWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCutFailures Class


BuiltInFailures.CutFailures.HostCutoutForInsertionFailure Property

BuiltInFailuresCutFailuresHostCutoutForInsertionFailure Property

Can't cut host for inserted objects

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId HostCutoutForInsertionFailure { get; }
Public Shared ReadOnly Property HostCutoutForInsertionFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ HostCutoutForInsertionFailure {
    FailureDefinitionId^ get ();
}
static member HostCutoutForInsertionFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCutFailures Class


BuiltInFailures.CutFailures.InstanceNotCuttingAnything Property

BuiltInFailuresCutFailuresInstanceNotCuttingAnything Property

Instance(s) of [Symbol] not cutting anything.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InstanceNotCuttingAnything { get; }
Public Shared ReadOnly Property InstanceNotCuttingAnything As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InstanceNotCuttingAnything {
    FailureDefinitionId^ get ();
}
static member InstanceNotCuttingAnything : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCutFailures Class


BuiltInFailures.CutterFailures Class

BuiltInFailuresCutterFailures Class

Failures about Cutter.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresCutterFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class CutterFailures
Public NotInheritable Class CutterFailures
public ref class CutterFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CutterFailures = class end

The BuiltInFailuresCutterFailures type exposes the following members.

Properties
Name | Description
MakeCutterForPlanRegionsGStepFailed | Failed to make cutter for plan view with plan regions. Try deleting one or more plan regions.
MakeCutterForSectionGStepFailed | Attempt to create or manipulate a segmented section has failed.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CutterFailures Properties

The BuiltInFailuresCutterFailures type exposes the following members.

Properties
Name | Description
MakeCutterForPlanRegionsGStepFailed | Failed to make cutter for plan view with plan regions. Try deleting one or more plan regions.
MakeCutterForSectionGStepFailed | Attempt to create or manipulate a segmented section has failed.
Top
See Also

Reference

BuiltInFailuresCutterFailures Class


BuiltInFailures.CutterFailures.MakeCutterForPlanRegionsGStepFailed Property

BuiltInFailuresCutterFailuresMakeCutterForPlanRegionsGStepFailed Property

Failed to make cutter for plan view with plan regions. Try deleting one or more plan regions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MakeCutterForPlanRegionsGStepFailed { get; }
Public Shared ReadOnly Property MakeCutterForPlanRegionsGStepFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MakeCutterForPlanRegionsGStepFailed {
    FailureDefinitionId^ get ();
}
static member MakeCutterForPlanRegionsGStepFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCutterFailures Class


BuiltInFailures.CutterFailures.MakeCutterForSectionGStepFailed Property

BuiltInFailuresCutterFailuresMakeCutterForSectionGStepFailed Property

Attempt to create or manipulate a segmented section has failed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MakeCutterForSectionGStepFailed { get; }
Public Shared ReadOnly Property MakeCutterForSectionGStepFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MakeCutterForSectionGStepFailed {
    FailureDefinitionId^ get ();
}
static member MakeCutterForSectionGStepFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCutterFailures Class


BuiltInFailures.CuttingFailures Class

BuiltInFailuresCuttingFailures Class

Failures about Cutting.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresCuttingFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class CuttingFailures
Public NotInheritable Class CuttingFailures
public ref class CuttingFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CuttingFailures = class end

The BuiltInFailuresCuttingFailures type exposes the following members.

Properties
Name | Description
CannotCopyFromMultipleLinks | Elements cannot be copied from multiple links at the same time.
ElementsWithNotCopiedParentsDeleted | Some elements were deleted because elements that they require for references were not copied.
NoFileSaved | No file has been saved.
NoSupported2DElementsToCopyFromView | None of the elements in the view you have selected are supported for the insert 2D operation.
UnableToCopyElementsFromFile | Unable to copy elements from file.
UnableToPasteToFile | Unable to paste current clipboard contents to file.
UnableToReplaceWithLink | Selected elements were copied to new file but Revit was unable to replace them with link to that file.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CuttingFailures Properties

The BuiltInFailuresCuttingFailures type exposes the following members.

Properties
Name | Description
CannotCopyFromMultipleLinks | Elements cannot be copied from multiple links at the same time.
ElementsWithNotCopiedParentsDeleted | Some elements were deleted because elements that they require for references were not copied.
NoFileSaved | No file has been saved.
NoSupported2DElementsToCopyFromView | None of the elements in the view you have selected are supported for the insert 2D operation.
UnableToCopyElementsFromFile | Unable to copy elements from file.
UnableToPasteToFile | Unable to paste current clipboard contents to file.
UnableToReplaceWithLink | Selected elements were copied to new file but Revit was unable to replace them with link to that file.
Top
See Also

Reference

BuiltInFailuresCuttingFailures Class


BuiltInFailures.CuttingFailures.CannotCopyFromMultipleLinks Property

BuiltInFailuresCuttingFailuresCannotCopyFromMultipleLinks Property

Elements cannot be copied from multiple links at the same time.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyFromMultipleLinks { get; }
Public Shared ReadOnly Property CannotCopyFromMultipleLinks As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyFromMultipleLinks {
    FailureDefinitionId^ get ();
}
static member CannotCopyFromMultipleLinks : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCuttingFailures Class


BuiltInFailures.CuttingFailures.ElementsWithNotCopiedParentsDeleted Property

BuiltInFailuresCuttingFailuresElementsWithNotCopiedParentsDeleted Property

Some elements were deleted because elements that they require for references were not copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ElementsWithNotCopiedParentsDeleted { get; }
Public Shared ReadOnly Property ElementsWithNotCopiedParentsDeleted As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ElementsWithNotCopiedParentsDeleted {
    FailureDefinitionId^ get ();
}
static member ElementsWithNotCopiedParentsDeleted : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCuttingFailures Class


BuiltInFailures.CuttingFailures.NoFileSaved Property

BuiltInFailuresCuttingFailuresNoFileSaved Property

No file has been saved.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoFileSaved { get; }
Public Shared ReadOnly Property NoFileSaved As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoFileSaved {
    FailureDefinitionId^ get ();
}
static member NoFileSaved : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCuttingFailures Class


BuiltInFailures.CuttingFailures.NoSupported2DElementsToCopyFromView Property

BuiltInFailuresCuttingFailuresNoSupported2DElementsToCopyFromView Property

None of the elements in the view you have selected are supported for the insert 2D operation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoSupported2DElementsToCopyFromView { get; }
Public Shared ReadOnly Property NoSupported2DElementsToCopyFromView As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoSupported2DElementsToCopyFromView {
    FailureDefinitionId^ get ();
}
static member NoSupported2DElementsToCopyFromView : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCuttingFailures Class


BuiltInFailures.CuttingFailures.UnableToCopyElementsFromFile Property

BuiltInFailuresCuttingFailuresUnableToCopyElementsFromFile Property

Unable to copy elements from file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnableToCopyElementsFromFile { get; }
Public Shared ReadOnly Property UnableToCopyElementsFromFile As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnableToCopyElementsFromFile {
    FailureDefinitionId^ get ();
}
static member UnableToCopyElementsFromFile : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCuttingFailures Class


BuiltInFailures.CuttingFailures.UnableToPasteToFile Property

BuiltInFailuresCuttingFailuresUnableToPasteToFile Property

Unable to paste current clipboard contents to file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnableToPasteToFile { get; }
Public Shared ReadOnly Property UnableToPasteToFile As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnableToPasteToFile {
    FailureDefinitionId^ get ();
}
static member UnableToPasteToFile : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCuttingFailures Class


BuiltInFailures.CuttingFailures.UnableToReplaceWithLink Property

BuiltInFailuresCuttingFailuresUnableToReplaceWithLink Property

Selected elements were copied to new file but Revit was unable to replace them with link to that file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnableToReplaceWithLink { get; }
Public Shared ReadOnly Property UnableToReplaceWithLink As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnableToReplaceWithLink {
    FailureDefinitionId^ get ();
}
static member UnableToReplaceWithLink : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresCuttingFailures Class


BuiltInFailures.DatumPlaneFailures Class

BuiltInFailuresDatumPlaneFailures Class

Failures about DatumPlane.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresDatumPlaneFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class DatumPlaneFailures
Public NotInheritable Class DatumPlaneFailures
public ref class DatumPlaneFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DatumPlaneFailures = class end

The BuiltInFailuresDatumPlaneFailures type exposes the following members.

Properties
Name | Description
ScopeBoxWrongPosition | The Highlighted Datum cannot be associated with the specified Scope Box because the Datum plane does not intersect the Scope Box.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DatumPlaneFailures Properties

The BuiltInFailuresDatumPlaneFailures type exposes the following members.

Properties
Name | Description
ScopeBoxWrongPosition | The Highlighted Datum cannot be associated with the specified Scope Box because the Datum plane does not intersect the Scope Box.
Top
See Also

Reference

BuiltInFailuresDatumPlaneFailures Class


BuiltInFailures.DatumPlaneFailures.ScopeBoxWrongPosition Property

BuiltInFailuresDatumPlaneFailuresScopeBoxWrongPosition Property

The Highlighted Datum cannot be associated with the specified Scope Box because the Datum plane does not intersect the Scope Box.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ScopeBoxWrongPosition { get; }
Public Shared ReadOnly Property ScopeBoxWrongPosition As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ScopeBoxWrongPosition {
    FailureDefinitionId^ get ();
}
static member ScopeBoxWrongPosition : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDatumPlaneFailures Class


BuiltInFailures.DebugTabBindingFailures Class

BuiltInFailuresDebugTabBindingFailures Class

Failures related to binding framework demo panel on Ribbon Debug Tab.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresDebugTabBindingFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class DebugTabBindingFailures
Public NotInheritable Class DebugTabBindingFailures
public ref class DebugTabBindingFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DebugTabBindingFailures = class end

The BuiltInFailuresDebugTabBindingFailures type exposes the following members.

Properties
Name | Description
OptionValueOutOfRange | Value out of range for Options enum.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DebugTabBindingFailures Properties

The BuiltInFailuresDebugTabBindingFailures type exposes the following members.

Properties
Name | Description
OptionValueOutOfRange | Value out of range for Options enum.
Top
See Also

Reference

BuiltInFailuresDebugTabBindingFailures Class


BuiltInFailures.DebugTabBindingFailures.OptionValueOutOfRange Property

BuiltInFailuresDebugTabBindingFailuresOptionValueOutOfRange Property

Value out of range for Options enum.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId OptionValueOutOfRange { get; }
Public Shared ReadOnly Property OptionValueOutOfRange As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ OptionValueOutOfRange {
    FailureDefinitionId^ get ();
}
static member OptionValueOutOfRange : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDebugTabBindingFailures Class


BuiltInFailures.DecalFailures Class

BuiltInFailuresDecalFailures Class

Failures about Decal.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresDecalFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class DecalFailures
Public NotInheritable Class DecalFailures
public ref class DecalFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DecalFailures = class end

The BuiltInFailuresDecalFailures type exposes the following members.

Properties
Name | Description
CannotPaste | Can't place Decal at new position.
LongerThanPossible | Decal element is longer than the circumference of the surface.
OutsideHost | Decal does not lie on host.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DecalFailures Properties

The BuiltInFailuresDecalFailures type exposes the following members.

Properties
Name | Description
CannotPaste | Can't place Decal at new position.
LongerThanPossible | Decal element is longer than the circumference of the surface.
OutsideHost | Decal does not lie on host.
Top
See Also

Reference

BuiltInFailuresDecalFailures Class


BuiltInFailures.DecalFailures.CannotPaste Property

BuiltInFailuresDecalFailuresCannotPaste Property

Can't place Decal at new position.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPaste { get; }
Public Shared ReadOnly Property CannotPaste As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPaste {
    FailureDefinitionId^ get ();
}
static member CannotPaste : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDecalFailures Class


BuiltInFailures.DecalFailures.LongerThanPossible Property

BuiltInFailuresDecalFailuresLongerThanPossible Property

Decal element is longer than the circumference of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LongerThanPossible { get; }
Public Shared ReadOnly Property LongerThanPossible As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LongerThanPossible {
    FailureDefinitionId^ get ();
}
static member LongerThanPossible : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDecalFailures Class


BuiltInFailures.DecalFailures.OutsideHost Property

BuiltInFailuresDecalFailuresOutsideHost Property

Decal does not lie on host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId OutsideHost { get; }
Public Shared ReadOnly Property OutsideHost As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ OutsideHost {
    FailureDefinitionId^ get ();
}
static member OutsideHost : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDecalFailures Class


BuiltInFailures.DesignOptionFailures Class

BuiltInFailuresDesignOptionFailures Class

Failures about DesignOptionFailures.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresDesignOptionFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class DesignOptionFailures
Public NotInheritable Class DesignOptionFailures
public ref class DesignOptionFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DesignOptionFailures = class end

The BuiltInFailuresDesignOptionFailures type exposes the following members.

Properties
Name | Description
AreaTagLineCannotBeInDesignOption | Areas and Area Boundaries are not allowed in Design Options. Make an Area Scheme and an Area Plan for this Option then draw all Areas and Area Boundaries in that view.
BadReferenceBetweenOptions | An element may not reference an element in another Option of the same Option Set.
BadReferenceBetweenOptionsWarn | An element may not reference an element in another Option of the same Option Set.
BadReferenceToSecondary | No element in a secondary Option can be referenced by an element outside that Option.
BadReferenceToSecondaryWarn | No element in a secondary Option can be referenced by an element outside that Option.
CannotAddToOptions | Elements can't be added to Option Set
CannotAddToOptionsWarn | Elements can't be added to Option Set
CannotPutELAInOption | Electrical Load Areas must be in the Main Model.
CannotPutELZInOption | Area Based Loads must be in the Main Model.
CannotPutSpaceInOption | MEP space must be in the Main Model
CannotPutZoneInOption | HVAC Zones must be in the Main Model.
ConfusingHostByElementsInAnotherDesignOption | An insert in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].
ConfusingHostByElementsInAnotherDesignOptionWarn | An insert in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].
ConfusingHostByElementsInDesignOption | An insert in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].
ConfusingHostByElementsInDesignOptionWarn | An insert in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].
ConfusingHostByElementsInMainModel | An insert in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].
ConfusingHostByElementsInMainModelWarn | An insert in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInAnotherDesignOption | A pad in a Design Option cannot be hosted by a topography in another Design Option [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInAnotherDesignOptionWarn | A pad in a Design Option cannot be hosted by a topography in another Design Option [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInDesignOption | A pad in the main model cannot be hosted by topography in a Design Option [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInDesignOptionWarn | A pad in the main model cannot be hosted by topography in a Design Option [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInMainModel | A pad in a design option cannot be hosted by topography in the Main Model [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInMainModelWarn | A pad in a design option cannot be hosted by topography in the Main Model [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInAnotherDesignOption | A sweep in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInAnotherDesignOptionWarn | A sweep in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInDesignOption | A sweep in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInDesignOptionWarn | A sweep in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInMainModel | A sweep in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInMainModelWarn | A sweep in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].
DebugLevelsInOptionsError | This is an internal diagnostic message.
DebugLevelsInOptionsWarn | This is an internal diagnostic message.
ElementsWillBeDeletedNoOption | Elements will be deleted
FabricationCannotBeInDesignOption | Structural steel connections or individual structural steel fabrication elements are not allowed in Design Options.
KingNeverInOption | A selected "[Serf]" belongs to a "[King]" which cannot be added to an Option--it was not added to the Option Set.
KingNeverInOptionWarn | A selected "[Serf]" belongs to a "[King]" which cannot be added to an Option--it was not added to the Option Set.
MustAddKing | In order to add this '[Serf]' to the Option Set, you must also add its '[King]'--if you continue it will not be added to the Option Set
MustAddKingWarn | In order to add this '[Serf]' to the Option Set, you must also add its '[King]'--if you continue it will not be added to the Option Set
MustBeInMainModel | Element must be in Main Model
NeverInOption | Some types of elements can't belong to an Option. Elements of these types were not added to this Option Set.
NeverInOptionWarn | Some types of elements can't belong to an Option. Elements of these types were not added to this Option Set.
NoSelectedInOption | None of the selected elements can be added to this Option Set. The following warnings provide additional information.
OptionElementsDeleted | Elements in [option] were deleted
SelectionIncludesOptionItems | Elements that were already in a Design Option were selected. These will not be added to the Option Set.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DesignOptionFailures Properties

The BuiltInFailuresDesignOptionFailures type exposes the following members.

Properties
Name | Description
AreaTagLineCannotBeInDesignOption | Areas and Area Boundaries are not allowed in Design Options. Make an Area Scheme and an Area Plan for this Option then draw all Areas and Area Boundaries in that view.
BadReferenceBetweenOptions | An element may not reference an element in another Option of the same Option Set.
BadReferenceBetweenOptionsWarn | An element may not reference an element in another Option of the same Option Set.
BadReferenceToSecondary | No element in a secondary Option can be referenced by an element outside that Option.
BadReferenceToSecondaryWarn | No element in a secondary Option can be referenced by an element outside that Option.
CannotAddToOptions | Elements can't be added to Option Set
CannotAddToOptionsWarn | Elements can't be added to Option Set
CannotPutELAInOption | Electrical Load Areas must be in the Main Model.
CannotPutELZInOption | Area Based Loads must be in the Main Model.
CannotPutSpaceInOption | MEP space must be in the Main Model
CannotPutZoneInOption | HVAC Zones must be in the Main Model.
ConfusingHostByElementsInAnotherDesignOption | An insert in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].
ConfusingHostByElementsInAnotherDesignOptionWarn | An insert in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].
ConfusingHostByElementsInDesignOption | An insert in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].
ConfusingHostByElementsInDesignOptionWarn | An insert in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].
ConfusingHostByElementsInMainModel | An insert in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].
ConfusingHostByElementsInMainModelWarn | An insert in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInAnotherDesignOption | A pad in a Design Option cannot be hosted by a topography in another Design Option [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInAnotherDesignOptionWarn | A pad in a Design Option cannot be hosted by a topography in another Design Option [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInDesignOption | A pad in the main model cannot be hosted by topography in a Design Option [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInDesignOptionWarn | A pad in the main model cannot be hosted by topography in a Design Option [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInMainModel | A pad in a design option cannot be hosted by topography in the Main Model [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInMainModelWarn | A pad in a design option cannot be hosted by topography in the Main Model [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInAnotherDesignOption | A sweep in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInAnotherDesignOptionWarn | A sweep in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInDesignOption | A sweep in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInDesignOptionWarn | A sweep in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInMainModel | A sweep in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInMainModelWarn | A sweep in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].
DebugLevelsInOptionsError | This is an internal diagnostic message.
DebugLevelsInOptionsWarn | This is an internal diagnostic message.
ElementsWillBeDeletedNoOption | Elements will be deleted
FabricationCannotBeInDesignOption | Structural steel connections or individual structural steel fabrication elements are not allowed in Design Options.
KingNeverInOption | A selected "[Serf]" belongs to a "[King]" which cannot be added to an Option--it was not added to the Option Set.
KingNeverInOptionWarn | A selected "[Serf]" belongs to a "[King]" which cannot be added to an Option--it was not added to the Option Set.
MustAddKing | In order to add this '[Serf]' to the Option Set, you must also add its '[King]'--if you continue it will not be added to the Option Set
MustAddKingWarn | In order to add this '[Serf]' to the Option Set, you must also add its '[King]'--if you continue it will not be added to the Option Set
MustBeInMainModel | Element must be in Main Model
NeverInOption | Some types of elements can't belong to an Option. Elements of these types were not added to this Option Set.
NeverInOptionWarn | Some types of elements can't belong to an Option. Elements of these types were not added to this Option Set.
NoSelectedInOption | None of the selected elements can be added to this Option Set. The following warnings provide additional information.
OptionElementsDeleted | Elements in [option] were deleted
SelectionIncludesOptionItems | Elements that were already in a Design Option were selected. These will not be added to the Option Set.
Top
See Also

Reference

BuiltInFailuresDesignOptionFailures Class


BuiltInFailures.DesignOptionFailures.AreaTagLineCannotBeInDesignOption Property

BuiltInFailuresDesignOptionFailuresAreaTagLineCannotBeInDesignOption Property

Areas and Area Boundaries are not allowed in Design Options. Make an Area Scheme and an Area Plan for this Option then draw all Areas and Area Boundaries in that view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AreaTagLineCannotBeInDesignOption { get; }
Public Shared ReadOnly Property AreaTagLineCannotBeInDesignOption As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AreaTagLineCannotBeInDesignOption {
    FailureDefinitionId^ get ();
}
static member AreaTagLineCannotBeInDesignOption : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDesignOptionFailures Class


BuiltInFailures.DesignOptionFailures.BadReferenceBetweenOptions Property

BuiltInFailuresDesignOptionFailuresBadReferenceBetweenOptions Property

An element may not reference an element in another Option of the same Option Set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BadReferenceBetweenOptions { get; }
Public Shared ReadOnly Property BadReferenceBetweenOptions As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BadReferenceBetweenOptions {
    FailureDefinitionId^ get ();
}
static member BadReferenceBetweenOptions : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDesignOptionFailures Class


BuiltInFailures.DesignOptionFailures.BadReferenceBetweenOptionsWarn Property

BuiltInFailuresDesignOptionFailuresBadReferenceBetweenOptionsWarn Property

An element may not reference an element in another Option of the same Option Set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BadReferenceBetweenOptionsWarn { get; }
Public Shared ReadOnly Property BadReferenceBetweenOptionsWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BadReferenceBetweenOptionsWarn {
    FailureDefinitionId^ get ();
}
static member BadReferenceBetweenOptionsWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDesignOptionFailures Class


BuiltInFailures.DesignOptionFailures.BadReferenceToSecondary Property

BuiltInFailuresDesignOptionFailuresBadReferenceToSecondary Property

No element in a secondary Option can be referenced by an element outside that Option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BadReferenceToSecondary { get; }
Public Shared ReadOnly Property BadReferenceToSecondary As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BadReferenceToSecondary {
    FailureDefinitionId^ get ();
}
static member BadReferenceToSecondary : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDesignOptionFailures Class


BuiltInFailures.DesignOptionFailures.BadReferenceToSecondaryWarn Property

BuiltInFailuresDesignOptionFailuresBadReferenceToSecondaryWarn Property

No element in a secondary Option can be referenced by an element outside that Option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BadReferenceToSecondaryWarn { get; }
Public Shared ReadOnly Property BadReferenceToSecondaryWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BadReferenceToSecondaryWarn {
    FailureDefinitionId^ get ();
}
static member BadReferenceToSecondaryWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDesignOptionFailures Class


BuiltInFailures.DesignOptionFailures.CannotAddToOptions Property

BuiltInFailuresDesignOptionFailuresCannotAddToOptions Property

Elements can't be added to Option Set

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotAddToOptions { get; }
Public Shared ReadOnly Property CannotAddToOptions As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotAddToOptions {
    FailureDefinitionId^ get ();
}
static member CannotAddToOptions : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDesignOptionFailures Class


BuiltInFailures.DesignOptionFailures.CannotAddToOptionsWarn Property

BuiltInFailuresDesignOptionFailuresCannotAddToOptionsWarn Property

Elements can't be added to Option Set

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotAddToOptionsWarn { get; }
Public Shared ReadOnly Property CannotAddToOptionsWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotAddToOptionsWarn {
    FailureDefinitionId^ get ();
}
static member CannotAddToOptionsWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDesignOptionFailures Class


BuiltInFailures.DesignOptionFailures.CannotPutELAInOption Property

BuiltInFailuresDesignOptionFailuresCannotPutELAInOption Property

Electrical Load Areas must be in the Main Model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPutELAInOption { get; }
Public Shared ReadOnly Property CannotPutELAInOption As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPutELAInOption {
    FailureDefinitionId^ get ();
}
static member CannotPutELAInOption : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDesignOptionFailures Class


BuiltInFailures.DesignOptionFailures.CannotPutELZInOption Property

BuiltInFailuresDesignOptionFailuresCannotPutELZInOption Property

Area Based Loads must be in the Main Model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPutELZInOption { get; }
Public Shared ReadOnly Property CannotPutELZInOption As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPutELZInOption {
    FailureDefinitionId^ get ();
}
static member CannotPutELZInOption : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDesignOptionFailures Class


BuiltInFailures.DesignOptionFailures.CannotPutSpaceInOption Property

BuiltInFailuresDesignOptionFailuresCannotPutSpaceInOption Property

MEP space must be in the Main Model

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPutSpaceInOption { get; }
Public Shared ReadOnly Property CannotPutSpaceInOption As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPutSpaceInOption {
    FailureDefinitionId^ get ();
}
static member CannotPutSpaceInOption : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDesignOptionFailures Class


BuiltInFailures.DesignOptionFailures.CannotPutZoneInOption Property

BuiltInFailuresDesignOptionFailuresCannotPutZoneInOption Property

HVAC Zones must be in the Main Model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPutZoneInOption { get; }
Public Shared ReadOnly Property CannotPutZoneInOption As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPutZoneInOption {
    FailureDefinitionId^ get ();
}
static member CannotPutZoneInOption : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDesignOptionFailures Class


BuiltInFailures.DesignOptionFailures.ConfusingHostByElementsInAnotherDesignOption Property

BuiltInFailuresDesignOptionFailuresConfusingHostByElementsInAnotherDesignOption Property

An insert in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ConfusingHostByElementsInAnotherDesignOption { get; }
Public Shared ReadOnly Property ConfusingHostByElementsInAnotherDesignOption As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ConfusingHostByElementsInAnotherDesignOption {
    FailureDefinitionId^ get ();
}
static member ConfusingHostByElementsInAnotherDesignOption : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDesignOptionFailures Class


BuiltInFailures.DesignOptionFailures.ConfusingHostByElementsInAnotherDesignOptionWarn Property

BuiltInFailuresDesignOptionFailuresConfusingHostByElementsInAnotherDesignOptionWarn Property

An insert in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ConfusingHostByElementsInAnotherDesignOptionWarn { get; }
Public Shared ReadOnly Property ConfusingHostByElementsInAnotherDesignOptionWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ConfusingHostByElementsInAnotherDesignOptionWarn {
    FailureDefinitionId^ get ();
}
static member ConfusingHostByElementsInAnotherDesignOptionWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDesignOptionFailures Class


BuiltInFailures.DesignOptionFailures.ConfusingHostByElementsInDesignOption Property

BuiltInFailuresDesignOptionFailuresConfusingHostByElementsInDesignOption Property

An insert in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ConfusingHostByElementsInDesignOption { get; }
Public Shared ReadOnly Property ConfusingHostByElementsInDesignOption As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ConfusingHostByElementsInDesignOption {
    FailureDefinitionId^ get ();
}
static member ConfusingHostByElementsInDesignOption : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDesignOptionFailures Class


BuiltInFailures.DesignOptionFailures.ConfusingHostByElementsInDesignOptionWarn Property

BuiltInFailuresDesignOptionFailuresConfusingHostByElementsInDesignOptionWarn Property

An insert in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ConfusingHostByElementsInDesignOptionWarn { get; }
Public Shared ReadOnly Property ConfusingHostByElementsInDesignOptionWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ConfusingHostByElementsInDesignOptionWarn {
    FailureDefinitionId^ get ();
}
static member ConfusingHostByElementsInDesignOptionWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDesignOptionFailures Class


BuiltInFailures.DesignOptionFailures.ConfusingHostByElementsInMainModel Property

BuiltInFailuresDesignOptionFailuresConfusingHostByElementsInMainModel Property

An insert in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ConfusingHostByElementsInMainModel { get; }
Public Shared ReadOnly Property ConfusingHostByElementsInMainModel As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ConfusingHostByElementsInMainModel {
    FailureDefinitionId^ get ();
}
static member ConfusingHostByElementsInMainModel : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDesignOptionFailures Class


BuiltInFailures.DesignOptionFailures.ConfusingHostByElementsInMainModelWarn Property

BuiltInFailuresDesignOptionFailuresConfusingHostByElementsInMainModelWarn Property

An insert in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ConfusingHostByElementsInMainModelWarn { get; }
Public Shared ReadOnly Property ConfusingHostByElementsInMainModelWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ConfusingHostByElementsInMainModelWarn {
    FailureDefinitionId^ get ();
}
static member ConfusingHostByElementsInMainModelWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDesignOptionFailures Class


BuiltInFailures.DesignOptionFailures.ConfusingPadByElementsInAnotherDesignOption Property

BuiltInFailuresDesignOptionFailuresConfusingPadByElementsInAnotherDesignOption Property

A pad in a Design Option cannot be hosted by a topography in another Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ConfusingPadByElementsInAnotherDesignOption { get; }
Public Shared ReadOnly Property ConfusingPadByElementsInAnotherDesignOption As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ConfusingPadByElementsInAnotherDesignOption {
    FailureDefinitionId^ get ();
}
static member ConfusingPadByElementsInAnotherDesignOption : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDesignOptionFailures Class


BuiltInFailures.DesignOptionFailures.ConfusingPadByElementsInAnotherDesignOptionWarn Property

BuiltInFailuresDesignOptionFailuresConfusingPadByElementsInAnotherDesignOptionWarn Property

A pad in a Design Option cannot be hosted by a topography in another Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ConfusingPadByElementsInAnotherDesignOptionWarn { get; }
Public Shared ReadOnly Property ConfusingPadByElementsInAnotherDesignOptionWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ConfusingPadByElementsInAnotherDesignOptionWarn {
    FailureDefinitionId^ get ();
}
static member ConfusingPadByElementsInAnotherDesignOptionWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDesignOptionFailures Class


BuiltInFailures.DesignOptionFailures.ConfusingPadByElementsInDesignOption Property

BuiltInFailuresDesignOptionFailuresConfusingPadByElementsInDesignOption Property

A pad in the main model cannot be hosted by topography in a Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ConfusingPadByElementsInDesignOption { get; }
Public Shared ReadOnly Property ConfusingPadByElementsInDesignOption As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ConfusingPadByElementsInDesignOption {
    FailureDefinitionId^ get ();
}
static member ConfusingPadByElementsInDesignOption : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDesignOptionFailures Class


BuiltInFailures.DesignOptionFailures.ConfusingPadByElementsInDesignOptionWarn Property

BuiltInFailuresDesignOptionFailuresConfusingPadByElementsInDesignOptionWarn Property

A pad in the main model cannot be hosted by topography in a Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ConfusingPadByElementsInDesignOptionWarn { get; }
Public Shared ReadOnly Property ConfusingPadByElementsInDesignOptionWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ConfusingPadByElementsInDesignOptionWarn {
    FailureDefinitionId^ get ();
}
static member ConfusingPadByElementsInDesignOptionWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDesignOptionFailures Class


BuiltInFailures.DesignOptionFailures.ConfusingPadByElementsInMainModel Property

BuiltInFailuresDesignOptionFailuresConfusingPadByElementsInMainModel Property

A pad in a design option cannot be hosted by topography in the Main Model [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ConfusingPadByElementsInMainModel { get; }
Public Shared ReadOnly Property ConfusingPadByElementsInMainModel As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ConfusingPadByElementsInMainModel {
    FailureDefinitionId^ get ();
}
static member ConfusingPadByElementsInMainModel : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDesignOptionFailures Class


BuiltInFailures.DesignOptionFailures.ConfusingPadByElementsInMainModelWarn Property

BuiltInFailuresDesignOptionFailuresConfusingPadByElementsInMainModelWarn Property

A pad in a design option cannot be hosted by topography in the Main Model [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ConfusingPadByElementsInMainModelWarn { get; }
Public Shared ReadOnly Property ConfusingPadByElementsInMainModelWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ConfusingPadByElementsInMainModelWarn {
    FailureDefinitionId^ get ();
}
static member ConfusingPadByElementsInMainModelWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDesignOptionFailures Class


BuiltInFailures.DesignOptionFailures.ConfusingSweepByElementsInAnotherDesignOption Property

BuiltInFailuresDesignOptionFailuresConfusingSweepByElementsInAnotherDesignOption Property

A sweep in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ConfusingSweepByElementsInAnotherDesignOption { get; }
Public Shared ReadOnly Property ConfusingSweepByElementsInAnotherDesignOption As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ConfusingSweepByElementsInAnotherDesignOption {
    FailureDefinitionId^ get ();
}
static member ConfusingSweepByElementsInAnotherDesignOption : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDesignOptionFailures Class


BuiltInFailures.DesignOptionFailures.ConfusingSweepByElementsInAnotherDesignOptionWarn Property

BuiltInFailuresDesignOptionFailuresConfusingSweepByElementsInAnotherDesignOptionWarn Property

A sweep in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ConfusingSweepByElementsInAnotherDesignOptionWarn { get; }
Public Shared ReadOnly Property ConfusingSweepByElementsInAnotherDesignOptionWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ConfusingSweepByElementsInAnotherDesignOptionWarn {
    FailureDefinitionId^ get ();
}
static member ConfusingSweepByElementsInAnotherDesignOptionWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDesignOptionFailures Class


BuiltInFailures.DesignOptionFailures.ConfusingSweepByElementsInDesignOption Property

BuiltInFailuresDesignOptionFailuresConfusingSweepByElementsInDesignOption Property

A sweep in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ConfusingSweepByElementsInDesignOption { get; }
Public Shared ReadOnly Property ConfusingSweepByElementsInDesignOption As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ConfusingSweepByElementsInDesignOption {
    FailureDefinitionId^ get ();
}
static member ConfusingSweepByElementsInDesignOption : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDesignOptionFailures Class


BuiltInFailures.DesignOptionFailures.ConfusingSweepByElementsInDesignOptionWarn Property

BuiltInFailuresDesignOptionFailuresConfusingSweepByElementsInDesignOptionWarn Property

A sweep in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ConfusingSweepByElementsInDesignOptionWarn { get; }
Public Shared ReadOnly Property ConfusingSweepByElementsInDesignOptionWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ConfusingSweepByElementsInDesignOptionWarn {
    FailureDefinitionId^ get ();
}
static member ConfusingSweepByElementsInDesignOptionWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDesignOptionFailures Class


BuiltInFailures.DesignOptionFailures.ConfusingSweepByElementsInMainModel Property

BuiltInFailuresDesignOptionFailuresConfusingSweepByElementsInMainModel Property

A sweep in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ConfusingSweepByElementsInMainModel { get; }
Public Shared ReadOnly Property ConfusingSweepByElementsInMainModel As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ConfusingSweepByElementsInMainModel {
    FailureDefinitionId^ get ();
}
static member ConfusingSweepByElementsInMainModel : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDesignOptionFailures Class


BuiltInFailures.DesignOptionFailures.ConfusingSweepByElementsInMainModelWarn Property

BuiltInFailuresDesignOptionFailuresConfusingSweepByElementsInMainModelWarn Property

A sweep in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ConfusingSweepByElementsInMainModelWarn { get; }
Public Shared ReadOnly Property ConfusingSweepByElementsInMainModelWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ConfusingSweepByElementsInMainModelWarn {
    FailureDefinitionId^ get ();
}
static member ConfusingSweepByElementsInMainModelWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDesignOptionFailures Class


BuiltInFailures.DesignOptionFailures.DebugLevelsInOptionsError Property

BuiltInFailuresDesignOptionFailuresDebugLevelsInOptionsError Property

This is an internal diagnostic message.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DebugLevelsInOptionsError { get; }
Public Shared ReadOnly Property DebugLevelsInOptionsError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DebugLevelsInOptionsError {
    FailureDefinitionId^ get ();
}
static member DebugLevelsInOptionsError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDesignOptionFailures Class


BuiltInFailures.DesignOptionFailures.DebugLevelsInOptionsWarn Property

BuiltInFailuresDesignOptionFailuresDebugLevelsInOptionsWarn Property

This is an internal diagnostic message.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DebugLevelsInOptionsWarn { get; }
Public Shared ReadOnly Property DebugLevelsInOptionsWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DebugLevelsInOptionsWarn {
    FailureDefinitionId^ get ();
}
static member DebugLevelsInOptionsWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDesignOptionFailures Class


BuiltInFailures.DesignOptionFailures.ElementsWillBeDeletedNoOption Property

BuiltInFailuresDesignOptionFailuresElementsWillBeDeletedNoOption Property

Elements will be deleted

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ElementsWillBeDeletedNoOption { get; }
Public Shared ReadOnly Property ElementsWillBeDeletedNoOption As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ElementsWillBeDeletedNoOption {
    FailureDefinitionId^ get ();
}
static member ElementsWillBeDeletedNoOption : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDesignOptionFailures Class


BuiltInFailures.DesignOptionFailures.FabricationCannotBeInDesignOption Property

BuiltInFailuresDesignOptionFailuresFabricationCannotBeInDesignOption Property

Structural steel connections or individual structural steel fabrication elements are not allowed in Design Options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricationCannotBeInDesignOption { get; }
Public Shared ReadOnly Property FabricationCannotBeInDesignOption As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricationCannotBeInDesignOption {
    FailureDefinitionId^ get ();
}
static member FabricationCannotBeInDesignOption : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDesignOptionFailures Class


BuiltInFailures.DesignOptionFailures.KingNeverInOption Property

BuiltInFailuresDesignOptionFailuresKingNeverInOption Property

A selected "[Serf]" belongs to a "[King]" which cannot be added to an Option--it was not added to the Option Set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId KingNeverInOption { get; }
Public Shared ReadOnly Property KingNeverInOption As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ KingNeverInOption {
    FailureDefinitionId^ get ();
}
static member KingNeverInOption : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDesignOptionFailures Class


BuiltInFailures.DesignOptionFailures.KingNeverInOptionWarn Property

BuiltInFailuresDesignOptionFailuresKingNeverInOptionWarn Property

A selected "[Serf]" belongs to a "[King]" which cannot be added to an Option--it was not added to the Option Set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId KingNeverInOptionWarn { get; }
Public Shared ReadOnly Property KingNeverInOptionWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ KingNeverInOptionWarn {
    FailureDefinitionId^ get ();
}
static member KingNeverInOptionWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDesignOptionFailures Class


BuiltInFailures.DesignOptionFailures.MustAddKing Property

BuiltInFailuresDesignOptionFailuresMustAddKing Property

In order to add this '[Serf]' to the Option Set, you must also add its '[King]'--if you continue it will not be added to the Option Set

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MustAddKing { get; }
Public Shared ReadOnly Property MustAddKing As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MustAddKing {
    FailureDefinitionId^ get ();
}
static member MustAddKing : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDesignOptionFailures Class


BuiltInFailures.DesignOptionFailures.MustAddKingWarn Property

BuiltInFailuresDesignOptionFailuresMustAddKingWarn Property

In order to add this '[Serf]' to the Option Set, you must also add its '[King]'--if you continue it will not be added to the Option Set

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MustAddKingWarn { get; }
Public Shared ReadOnly Property MustAddKingWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MustAddKingWarn {
    FailureDefinitionId^ get ();
}
static member MustAddKingWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDesignOptionFailures Class


BuiltInFailures.DesignOptionFailures.MustBeInMainModel Property

BuiltInFailuresDesignOptionFailuresMustBeInMainModel Property

Element must be in Main Model

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MustBeInMainModel { get; }
Public Shared ReadOnly Property MustBeInMainModel As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MustBeInMainModel {
    FailureDefinitionId^ get ();
}
static member MustBeInMainModel : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDesignOptionFailures Class


BuiltInFailures.DesignOptionFailures.NeverInOption Property

BuiltInFailuresDesignOptionFailuresNeverInOption Property

Some types of elements can't belong to an Option. Elements of these types were not added to this Option Set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NeverInOption { get; }
Public Shared ReadOnly Property NeverInOption As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NeverInOption {
    FailureDefinitionId^ get ();
}
static member NeverInOption : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDesignOptionFailures Class


BuiltInFailures.DesignOptionFailures.NeverInOptionWarn Property

BuiltInFailuresDesignOptionFailuresNeverInOptionWarn Property

Some types of elements can't belong to an Option. Elements of these types were not added to this Option Set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NeverInOptionWarn { get; }
Public Shared ReadOnly Property NeverInOptionWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NeverInOptionWarn {
    FailureDefinitionId^ get ();
}
static member NeverInOptionWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDesignOptionFailures Class


BuiltInFailures.DesignOptionFailures.NoSelectedInOption Property

BuiltInFailuresDesignOptionFailuresNoSelectedInOption Property

None of the selected elements can be added to this Option Set. The following warnings provide additional information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoSelectedInOption { get; }
Public Shared ReadOnly Property NoSelectedInOption As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoSelectedInOption {
    FailureDefinitionId^ get ();
}
static member NoSelectedInOption : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDesignOptionFailures Class


BuiltInFailures.DesignOptionFailures.OptionElementsDeleted Property

BuiltInFailuresDesignOptionFailuresOptionElementsDeleted Property

Elements in [option] were deleted

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId OptionElementsDeleted { get; }
Public Shared ReadOnly Property OptionElementsDeleted As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ OptionElementsDeleted {
    FailureDefinitionId^ get ();
}
static member OptionElementsDeleted : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDesignOptionFailures Class


BuiltInFailures.DesignOptionFailures.SelectionIncludesOptionItems Property

BuiltInFailuresDesignOptionFailuresSelectionIncludesOptionItems Property

Elements that were already in a Design Option were selected. These will not be added to the Option Set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SelectionIncludesOptionItems { get; }
Public Shared ReadOnly Property SelectionIncludesOptionItems As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SelectionIncludesOptionItems {
    FailureDefinitionId^ get ();
}
static member SelectionIncludesOptionItems : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDesignOptionFailures Class


BuiltInFailures.DetailFailures Class

BuiltInFailuresDetailFailures Class

Failures about Detail.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresDetailFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class DetailFailures
Public NotInheritable Class DetailFailures
public ref class DetailFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DetailFailures = class end

The BuiltInFailuresDetailFailures type exposes the following members.

Properties
Name | Description
EavesAreAligned | All eaves are already aligned.
NeedsTwoToAlignEaves | At least two Slope Defining Lines are needed to perform Align Eaves.
RepeatingDetailSpacingZeroError | Spacing must be greater than 0
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DetailFailures Properties

The BuiltInFailuresDetailFailures type exposes the following members.

Properties
Name | Description
EavesAreAligned | All eaves are already aligned.
NeedsTwoToAlignEaves | At least two Slope Defining Lines are needed to perform Align Eaves.
RepeatingDetailSpacingZeroError | Spacing must be greater than 0
Top
See Also

Reference

BuiltInFailuresDetailFailures Class


BuiltInFailures.DetailFailures.EavesAreAligned Property

BuiltInFailuresDetailFailuresEavesAreAligned Property

All eaves are already aligned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId EavesAreAligned { get; }
Public Shared ReadOnly Property EavesAreAligned As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ EavesAreAligned {
    FailureDefinitionId^ get ();
}
static member EavesAreAligned : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDetailFailures Class


BuiltInFailures.DetailFailures.NeedsTwoToAlignEaves Property

BuiltInFailuresDetailFailuresNeedsTwoToAlignEaves Property

At least two Slope Defining Lines are needed to perform Align Eaves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NeedsTwoToAlignEaves { get; }
Public Shared ReadOnly Property NeedsTwoToAlignEaves As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NeedsTwoToAlignEaves {
    FailureDefinitionId^ get ();
}
static member NeedsTwoToAlignEaves : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDetailFailures Class


BuiltInFailures.DetailFailures.RepeatingDetailSpacingZeroError Property

BuiltInFailuresDetailFailuresRepeatingDetailSpacingZeroError Property

Spacing must be greater than 0

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RepeatingDetailSpacingZeroError { get; }
Public Shared ReadOnly Property RepeatingDetailSpacingZeroError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RepeatingDetailSpacingZeroError {
    FailureDefinitionId^ get ();
}
static member RepeatingDetailSpacingZeroError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDetailFailures Class


BuiltInFailures.DimensionFailures Class

BuiltInFailuresDimensionFailures Class

Failures about DimensionFailures.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresDimensionFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class DimensionFailures
Public NotInheritable Class DimensionFailures
public ref class DimensionFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DimensionFailures = class end

The BuiltInFailuresDimensionFailures type exposes the following members.

Properties
Name | Description
AngularDimensionRegenFailed | Can't form Angular Dimension.
ArcAlignmentRegenFailed | Can't form arc alignment.
ArcLengthDimensionNoReferencesOnArc | None of the segment references of this Arc Length Dimension intersects the bounded arc of the arc reference.
ArcLengthDimensionReferencesNotIntersect | One or more dimension references of this Arc Length dimension no longer intersect the circle needed for arc length computation.
AssocpropNeedJog | Need to add jog in order to satisfy constraints
CannotConstrainBasePointAlignments | Alignments to base points cannot be constrained.
CannotConstrainBasePointDimensions | Dimensions to base points cannot be constrained.
CannotCreateDimensionNotParallel | Can't create dimension. Highlighted references are not parallel to first selection.
CannotDragWitnessLine | Moving the Witness Line conflicts with other Constraints in the Sketch.
CannotLockThisDimension | Can't lock this Dimension because it breaks formulas
CannotToggleDimensionEquality | Toggling the dimension's equality constraint would overconstrain the sketch.
ChangeDimensionSegmentFailed | Can't change dimension segment to this value.
ChangeSpotElevationFailed | Can't change Spot Elevation to the desired value.
DifferentLabelsInMultiSegmentDim | All segments of a multi-segment dimension must be labeled the same.
DimensionOverconstrained | The Dimension would overconstrain the Sketch.
DimensionOverconstrainedError | The Dimension would overconstrain the Sketch.
DimensionOverrideNearByIsLost | The dimension segment containing the override(s) shown below has been removed. The override text will no longer appear. [Description]
DimensionPerpendicularToView | The Dimension is perpendicular to the current view, and no longer valid.
DimensionReferencesInvalid | One or more dimension references are or have become invalid.
DimensionUnequaled | Dimension had to be unlocked and un-EQed in order to remove sketch over-constraining.
DimensionUnlocked | Dimension had to be un-EQed in order to remove sketch over-constraining.
DimensionUnlockedAndUnequaled | Dimension had to be unlocked in order to remove sketch over-constraining.
EqualityConstraintsUnsatisfied | Equality constraints are not satisfied. The action either violates a locked constraint or tries to modify a sketch based object outside of the sketch mode.
EqualityConstraintsUnsatisfiedWarn | Equality constraints are not satisfied. The action either violates a locked constraint or tries to modify a sketch based object outside of the sketch mode.
ForbiddenGroupConstraint | You may not create sketch or family constraints between group members and elements which are not members of the same group.
LabelingDimWithGroupReferences | Labeled constraints cannot participate in groups.
LabelingMultiSegmentWithReporting | Cannot label multi-segment dimensions with reporting parameters.
LabelOverconstrained | Labeling this dimension would overconstrain the sketch.
LinearConstraintBadDirection | Bad direction vector in dimension element.
LinearConstraintNotParallel | The References of the highlighted Dimension are no longer parallel.
LinearDimensionReferenceNotOrthogonalToView | The planes of one or more references are not exactly orthogonal to this view. The dimension to these reference cannot be created.
LockOverconstrained | Locking this dimension would overconstrain the sketch.
LockOverconstrainedAlignment | Locking this alignment would overconstrain the sketch.
LooseLabeledDimensionRegenFailure | Failed to Regenerate Family
MoreThanOneDimsLabelToOneReportingParameter | Reporting parameters can only exist on a single dimension/constraint.
NoConstraintsInProperSketch | You are creating a constraint inside the sketch of a property line. Constraints inside a sketch can only drive elements within the sketch. Usually you do not want property lines driven by other elements. If you would like to constrain other elements to the property lines, you should add the constraints outside of sketch mode.
NoConstraintsToLinks | Constraints may not be created to linked instances using Shared Locations.
RadialDimensionCannotProjectToArc | Cannot form radial dimension.
RadialDimensionChangeRadiusFailed | Can't change radius.
RegenConstraintUnsatisfied | Constraints are not satisfied
RegenConstraintUnsatisfiedWarn | Constraints are not satisfied
ReportingParamAlreadyLabelsToAnotherDim | Cannot label multi-dimensions to one reporting parameter.
SomeDimensionsLostOnPaste | Some Dimensions were not copied because some References were lost.
SomeDimensionsLostWitnessLines | Some Dimensions lost some of their References on paste.
SomeSpotDimensionsLostOnPaste | Some Spot Dimensions were not copied because some References were lost.
SpotDimensionFloatingPointError | Some spot dimensions contain invalid floating-point values.
SpotDimensionFormerSetMoribundCall | One or more Spot Dimension references are no longer valid.
SpotDimensionReferencesNoLongerHorizontal | One or more Spot Dimension references are no longer valid. Spot Dimensions can generally reference only those references which have valid coordinates in the view.
SpotElevationLostEdgeReferences | Some Spot Dimensions lost their References. Those Spot Dimensions will be deleted.
SpotElevationMissesReference | Spot Dimension does not lie on its reference.
SpotSlopeReferenceIsVertical | The highlighted Spot Slope references an element that is vertical.
SpotSlopeReferencePointIsSingular | The highlighted Spot Slope references an element point that is singular.
UnavailableDimensionHostReference | A dimension reference could not be resolved on the host element.
UnstableConstraintInFamily | Constraints between geometry in the family can behave unpredictably on parameter modification. To make the family reliable, constrain geometry to levels, reference planes, or reference lines.
WrongConstraintInGridChainSketch | Curve in a GridChain sketch cannot be constrained to a sub-grid
WrongConstraintInJoistSystemSketch | Structural Beam System sketch can't be constrained to its beam.
WrongConstraintInSkeletonSketch | Reference Lines can only be constrained to Reference Planes, Levels, Family Host, and other Reference Lines.
WrongConstraintInTrussSketch | Structural Truss sketch can't be constrained to its members.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DimensionFailures Properties

The BuiltInFailuresDimensionFailures type exposes the following members.

Properties
Name | Description
AngularDimensionRegenFailed | Can't form Angular Dimension.
ArcAlignmentRegenFailed | Can't form arc alignment.
ArcLengthDimensionNoReferencesOnArc | None of the segment references of this Arc Length Dimension intersects the bounded arc of the arc reference.
ArcLengthDimensionReferencesNotIntersect | One or more dimension references of this Arc Length dimension no longer intersect the circle needed for arc length computation.
AssocpropNeedJog | Need to add jog in order to satisfy constraints
CannotConstrainBasePointAlignments | Alignments to base points cannot be constrained.
CannotConstrainBasePointDimensions | Dimensions to base points cannot be constrained.
CannotCreateDimensionNotParallel | Can't create dimension. Highlighted references are not parallel to first selection.
CannotDragWitnessLine | Moving the Witness Line conflicts with other Constraints in the Sketch.
CannotLockThisDimension | Can't lock this Dimension because it breaks formulas
CannotToggleDimensionEquality | Toggling the dimension's equality constraint would overconstrain the sketch.
ChangeDimensionSegmentFailed | Can't change dimension segment to this value.
ChangeSpotElevationFailed | Can't change Spot Elevation to the desired value.
DifferentLabelsInMultiSegmentDim | All segments of a multi-segment dimension must be labeled the same.
DimensionOverconstrained | The Dimension would overconstrain the Sketch.
DimensionOverconstrainedError | The Dimension would overconstrain the Sketch.
DimensionOverrideNearByIsLost | The dimension segment containing the override(s) shown below has been removed. The override text will no longer appear. [Description]
DimensionPerpendicularToView | The Dimension is perpendicular to the current view, and no longer valid.
DimensionReferencesInvalid | One or more dimension references are or have become invalid.
DimensionUnequaled | Dimension had to be unlocked and un-EQed in order to remove sketch over-constraining.
DimensionUnlocked | Dimension had to be un-EQed in order to remove sketch over-constraining.
DimensionUnlockedAndUnequaled | Dimension had to be unlocked in order to remove sketch over-constraining.
EqualityConstraintsUnsatisfied | Equality constraints are not satisfied. The action either violates a locked constraint or tries to modify a sketch based object outside of the sketch mode.
EqualityConstraintsUnsatisfiedWarn | Equality constraints are not satisfied. The action either violates a locked constraint or tries to modify a sketch based object outside of the sketch mode.
ForbiddenGroupConstraint | You may not create sketch or family constraints between group members and elements which are not members of the same group.
LabelingDimWithGroupReferences | Labeled constraints cannot participate in groups.
LabelingMultiSegmentWithReporting | Cannot label multi-segment dimensions with reporting parameters.
LabelOverconstrained | Labeling this dimension would overconstrain the sketch.
LinearConstraintBadDirection | Bad direction vector in dimension element.
LinearConstraintNotParallel | The References of the highlighted Dimension are no longer parallel.
LinearDimensionReferenceNotOrthogonalToView | The planes of one or more references are not exactly orthogonal to this view. The dimension to these reference cannot be created.
LockOverconstrained | Locking this dimension would overconstrain the sketch.
LockOverconstrainedAlignment | Locking this alignment would overconstrain the sketch.
LooseLabeledDimensionRegenFailure | Failed to Regenerate Family
MoreThanOneDimsLabelToOneReportingParameter | Reporting parameters can only exist on a single dimension/constraint.
NoConstraintsInProperSketch | You are creating a constraint inside the sketch of a property line. Constraints inside a sketch can only drive elements within the sketch. Usually you do not want property lines driven by other elements. If you would like to constrain other elements to the property lines, you should add the constraints outside of sketch mode.
NoConstraintsToLinks | Constraints may not be created to linked instances using Shared Locations.
RadialDimensionCannotProjectToArc | Cannot form radial dimension.
RadialDimensionChangeRadiusFailed | Can't change radius.
RegenConstraintUnsatisfied | Constraints are not satisfied
RegenConstraintUnsatisfiedWarn | Constraints are not satisfied
ReportingParamAlreadyLabelsToAnotherDim | Cannot label multi-dimensions to one reporting parameter.
SomeDimensionsLostOnPaste | Some Dimensions were not copied because some References were lost.
SomeDimensionsLostWitnessLines | Some Dimensions lost some of their References on paste.
SomeSpotDimensionsLostOnPaste | Some Spot Dimensions were not copied because some References were lost.
SpotDimensionFloatingPointError | Some spot dimensions contain invalid floating-point values.
SpotDimensionFormerSetMoribundCall | One or more Spot Dimension references are no longer valid.
SpotDimensionReferencesNoLongerHorizontal | One or more Spot Dimension references are no longer valid. Spot Dimensions can generally reference only those references which have valid coordinates in the view.
SpotElevationLostEdgeReferences | Some Spot Dimensions lost their References. Those Spot Dimensions will be deleted.
SpotElevationMissesReference | Spot Dimension does not lie on its reference.
SpotSlopeReferenceIsVertical | The highlighted Spot Slope references an element that is vertical.
SpotSlopeReferencePointIsSingular | The highlighted Spot Slope references an element point that is singular.
UnavailableDimensionHostReference | A dimension reference could not be resolved on the host element.
UnstableConstraintInFamily | Constraints between geometry in the family can behave unpredictably on parameter modification. To make the family reliable, constrain geometry to levels, reference planes, or reference lines.
WrongConstraintInGridChainSketch | Curve in a GridChain sketch cannot be constrained to a sub-grid
WrongConstraintInJoistSystemSketch | Structural Beam System sketch can't be constrained to its beam.
WrongConstraintInSkeletonSketch | Reference Lines can only be constrained to Reference Planes, Levels, Family Host, and other Reference Lines.
WrongConstraintInTrussSketch | Structural Truss sketch can't be constrained to its members.
Top
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.AngularDimensionRegenFailed Property

BuiltInFailuresDimensionFailuresAngularDimensionRegenFailed Property

Can't form Angular Dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AngularDimensionRegenFailed { get; }
Public Shared ReadOnly Property AngularDimensionRegenFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AngularDimensionRegenFailed {
    FailureDefinitionId^ get ();
}
static member AngularDimensionRegenFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.ArcAlignmentRegenFailed Property

BuiltInFailuresDimensionFailuresArcAlignmentRegenFailed Property

Can't form arc alignment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ArcAlignmentRegenFailed { get; }
Public Shared ReadOnly Property ArcAlignmentRegenFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ArcAlignmentRegenFailed {
    FailureDefinitionId^ get ();
}
static member ArcAlignmentRegenFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.ArcLengthDimensionNoReferencesOnArc Property

BuiltInFailuresDimensionFailuresArcLengthDimensionNoReferencesOnArc Property

None of the segment references of this Arc Length Dimension intersects the bounded arc of the arc reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ArcLengthDimensionNoReferencesOnArc { get; }
Public Shared ReadOnly Property ArcLengthDimensionNoReferencesOnArc As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ArcLengthDimensionNoReferencesOnArc {
    FailureDefinitionId^ get ();
}
static member ArcLengthDimensionNoReferencesOnArc : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.ArcLengthDimensionReferencesNotIntersect Property

BuiltInFailuresDimensionFailuresArcLengthDimensionReferencesNotIntersect Property

One or more dimension references of this Arc Length dimension no longer intersect the circle needed for arc length computation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ArcLengthDimensionReferencesNotIntersect { get; }
Public Shared ReadOnly Property ArcLengthDimensionReferencesNotIntersect As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ArcLengthDimensionReferencesNotIntersect {
    FailureDefinitionId^ get ();
}
static member ArcLengthDimensionReferencesNotIntersect : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.AssocpropNeedJog Property

BuiltInFailuresDimensionFailuresAssocpropNeedJog Property

Need to add jog in order to satisfy constraints

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AssocpropNeedJog { get; }
Public Shared ReadOnly Property AssocpropNeedJog As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AssocpropNeedJog {
    FailureDefinitionId^ get ();
}
static member AssocpropNeedJog : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.CannotConstrainBasePointAlignments Property

BuiltInFailuresDimensionFailuresCannotConstrainBasePointAlignments Property

Alignments to base points cannot be constrained.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotConstrainBasePointAlignments { get; }
Public Shared ReadOnly Property CannotConstrainBasePointAlignments As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotConstrainBasePointAlignments {
    FailureDefinitionId^ get ();
}
static member CannotConstrainBasePointAlignments : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.CannotConstrainBasePointDimensions Property

BuiltInFailuresDimensionFailuresCannotConstrainBasePointDimensions Property

Dimensions to base points cannot be constrained.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotConstrainBasePointDimensions { get; }
Public Shared ReadOnly Property CannotConstrainBasePointDimensions As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotConstrainBasePointDimensions {
    FailureDefinitionId^ get ();
}
static member CannotConstrainBasePointDimensions : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.CannotCreateDimensionNotParallel Property

BuiltInFailuresDimensionFailuresCannotCreateDimensionNotParallel Property

Can't create dimension. Highlighted references are not parallel to first selection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateDimensionNotParallel { get; }
Public Shared ReadOnly Property CannotCreateDimensionNotParallel As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateDimensionNotParallel {
    FailureDefinitionId^ get ();
}
static member CannotCreateDimensionNotParallel : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.CannotDragWitnessLine Property

BuiltInFailuresDimensionFailuresCannotDragWitnessLine Property

Moving the Witness Line conflicts with other Constraints in the Sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotDragWitnessLine { get; }
Public Shared ReadOnly Property CannotDragWitnessLine As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotDragWitnessLine {
    FailureDefinitionId^ get ();
}
static member CannotDragWitnessLine : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.CannotLockThisDimension Property

BuiltInFailuresDimensionFailuresCannotLockThisDimension Property

Can't lock this Dimension because it breaks formulas

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotLockThisDimension { get; }
Public Shared ReadOnly Property CannotLockThisDimension As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotLockThisDimension {
    FailureDefinitionId^ get ();
}
static member CannotLockThisDimension : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.CannotToggleDimensionEquality Property

BuiltInFailuresDimensionFailuresCannotToggleDimensionEquality Property

Toggling the dimension's equality constraint would overconstrain the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotToggleDimensionEquality { get; }
Public Shared ReadOnly Property CannotToggleDimensionEquality As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotToggleDimensionEquality {
    FailureDefinitionId^ get ();
}
static member CannotToggleDimensionEquality : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.ChangeDimensionSegmentFailed Property

BuiltInFailuresDimensionFailuresChangeDimensionSegmentFailed Property

Can't change dimension segment to this value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ChangeDimensionSegmentFailed { get; }
Public Shared ReadOnly Property ChangeDimensionSegmentFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ChangeDimensionSegmentFailed {
    FailureDefinitionId^ get ();
}
static member ChangeDimensionSegmentFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.ChangeSpotElevationFailed Property

BuiltInFailuresDimensionFailuresChangeSpotElevationFailed Property

Can't change Spot Elevation to the desired value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ChangeSpotElevationFailed { get; }
Public Shared ReadOnly Property ChangeSpotElevationFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ChangeSpotElevationFailed {
    FailureDefinitionId^ get ();
}
static member ChangeSpotElevationFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.DifferentLabelsInMultiSegmentDim Property

BuiltInFailuresDimensionFailuresDifferentLabelsInMultiSegmentDim Property

All segments of a multi-segment dimension must be labeled the same.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DifferentLabelsInMultiSegmentDim { get; }
Public Shared ReadOnly Property DifferentLabelsInMultiSegmentDim As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DifferentLabelsInMultiSegmentDim {
    FailureDefinitionId^ get ();
}
static member DifferentLabelsInMultiSegmentDim : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.DimensionOverconstrained Property

BuiltInFailuresDimensionFailuresDimensionOverconstrained Property

The Dimension would overconstrain the Sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DimensionOverconstrained { get; }
Public Shared ReadOnly Property DimensionOverconstrained As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DimensionOverconstrained {
    FailureDefinitionId^ get ();
}
static member DimensionOverconstrained : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.DimensionOverconstrainedError Property

BuiltInFailuresDimensionFailuresDimensionOverconstrainedError Property

The Dimension would overconstrain the Sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DimensionOverconstrainedError { get; }
Public Shared ReadOnly Property DimensionOverconstrainedError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DimensionOverconstrainedError {
    FailureDefinitionId^ get ();
}
static member DimensionOverconstrainedError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.DimensionOverrideNearByIsLost Property

BuiltInFailuresDimensionFailuresDimensionOverrideNearByIsLost Property

The dimension segment containing the override(s) shown below has been removed. The override text will no longer appear. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DimensionOverrideNearByIsLost { get; }
Public Shared ReadOnly Property DimensionOverrideNearByIsLost As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DimensionOverrideNearByIsLost {
    FailureDefinitionId^ get ();
}
static member DimensionOverrideNearByIsLost : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.DimensionPerpendicularToView Property

BuiltInFailuresDimensionFailuresDimensionPerpendicularToView Property

The Dimension is perpendicular to the current view, and no longer valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DimensionPerpendicularToView { get; }
Public Shared ReadOnly Property DimensionPerpendicularToView As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DimensionPerpendicularToView {
    FailureDefinitionId^ get ();
}
static member DimensionPerpendicularToView : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.DimensionReferencesInvalid Property

BuiltInFailuresDimensionFailuresDimensionReferencesInvalid Property

One or more dimension references are or have become invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DimensionReferencesInvalid { get; }
Public Shared ReadOnly Property DimensionReferencesInvalid As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DimensionReferencesInvalid {
    FailureDefinitionId^ get ();
}
static member DimensionReferencesInvalid : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.DimensionUnequaled Property

BuiltInFailuresDimensionFailuresDimensionUnequaled Property

Dimension had to be unlocked and un-EQed in order to remove sketch over-constraining.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DimensionUnequaled { get; }
Public Shared ReadOnly Property DimensionUnequaled As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DimensionUnequaled {
    FailureDefinitionId^ get ();
}
static member DimensionUnequaled : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.DimensionUnlocked Property

BuiltInFailuresDimensionFailuresDimensionUnlocked Property

Dimension had to be un-EQed in order to remove sketch over-constraining.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DimensionUnlocked { get; }
Public Shared ReadOnly Property DimensionUnlocked As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DimensionUnlocked {
    FailureDefinitionId^ get ();
}
static member DimensionUnlocked : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.DimensionUnlockedAndUnequaled Property

BuiltInFailuresDimensionFailuresDimensionUnlockedAndUnequaled Property

Dimension had to be unlocked in order to remove sketch over-constraining.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DimensionUnlockedAndUnequaled { get; }
Public Shared ReadOnly Property DimensionUnlockedAndUnequaled As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DimensionUnlockedAndUnequaled {
    FailureDefinitionId^ get ();
}
static member DimensionUnlockedAndUnequaled : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.EqualityConstraintsUnsatisfied Property

BuiltInFailuresDimensionFailuresEqualityConstraintsUnsatisfied Property

Equality constraints are not satisfied. The action either violates a locked constraint or tries to modify a sketch based object outside of the sketch mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId EqualityConstraintsUnsatisfied { get; }
Public Shared ReadOnly Property EqualityConstraintsUnsatisfied As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ EqualityConstraintsUnsatisfied {
    FailureDefinitionId^ get ();
}
static member EqualityConstraintsUnsatisfied : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.EqualityConstraintsUnsatisfiedWarn Property

BuiltInFailuresDimensionFailuresEqualityConstraintsUnsatisfiedWarn Property

Equality constraints are not satisfied. The action either violates a locked constraint or tries to modify a sketch based object outside of the sketch mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId EqualityConstraintsUnsatisfiedWarn { get; }
Public Shared ReadOnly Property EqualityConstraintsUnsatisfiedWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ EqualityConstraintsUnsatisfiedWarn {
    FailureDefinitionId^ get ();
}
static member EqualityConstraintsUnsatisfiedWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.ForbiddenGroupConstraint Property

BuiltInFailuresDimensionFailuresForbiddenGroupConstraint Property

You may not create sketch or family constraints between group members and elements which are not members of the same group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ForbiddenGroupConstraint { get; }
Public Shared ReadOnly Property ForbiddenGroupConstraint As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ForbiddenGroupConstraint {
    FailureDefinitionId^ get ();
}
static member ForbiddenGroupConstraint : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.LabelingDimWithGroupReferences Property

BuiltInFailuresDimensionFailuresLabelingDimWithGroupReferences Property

Labeled constraints cannot participate in groups.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LabelingDimWithGroupReferences { get; }
Public Shared ReadOnly Property LabelingDimWithGroupReferences As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LabelingDimWithGroupReferences {
    FailureDefinitionId^ get ();
}
static member LabelingDimWithGroupReferences : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.LabelingMultiSegmentWithReporting Property

BuiltInFailuresDimensionFailuresLabelingMultiSegmentWithReporting Property

Cannot label multi-segment dimensions with reporting parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LabelingMultiSegmentWithReporting { get; }
Public Shared ReadOnly Property LabelingMultiSegmentWithReporting As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LabelingMultiSegmentWithReporting {
    FailureDefinitionId^ get ();
}
static member LabelingMultiSegmentWithReporting : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.LabelOverconstrained Property

BuiltInFailuresDimensionFailuresLabelOverconstrained Property

Labeling this dimension would overconstrain the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LabelOverconstrained { get; }
Public Shared ReadOnly Property LabelOverconstrained As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LabelOverconstrained {
    FailureDefinitionId^ get ();
}
static member LabelOverconstrained : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.LinearConstraintBadDirection Property

BuiltInFailuresDimensionFailuresLinearConstraintBadDirection Property

Bad direction vector in dimension element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LinearConstraintBadDirection { get; }
Public Shared ReadOnly Property LinearConstraintBadDirection As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LinearConstraintBadDirection {
    FailureDefinitionId^ get ();
}
static member LinearConstraintBadDirection : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.LinearConstraintNotParallel Property

BuiltInFailuresDimensionFailuresLinearConstraintNotParallel Property

The References of the highlighted Dimension are no longer parallel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LinearConstraintNotParallel { get; }
Public Shared ReadOnly Property LinearConstraintNotParallel As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LinearConstraintNotParallel {
    FailureDefinitionId^ get ();
}
static member LinearConstraintNotParallel : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.LinearDimensionReferenceNotOrthogonalToView Property

BuiltInFailuresDimensionFailuresLinearDimensionReferenceNotOrthogonalToView Property

The planes of one or more references are not exactly orthogonal to this view. The dimension to these reference cannot be created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LinearDimensionReferenceNotOrthogonalToView { get; }
Public Shared ReadOnly Property LinearDimensionReferenceNotOrthogonalToView As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LinearDimensionReferenceNotOrthogonalToView {
    FailureDefinitionId^ get ();
}
static member LinearDimensionReferenceNotOrthogonalToView : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.LockOverconstrained Property

BuiltInFailuresDimensionFailuresLockOverconstrained Property

Locking this dimension would overconstrain the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LockOverconstrained { get; }
Public Shared ReadOnly Property LockOverconstrained As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LockOverconstrained {
    FailureDefinitionId^ get ();
}
static member LockOverconstrained : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.LockOverconstrainedAlignment Property

BuiltInFailuresDimensionFailuresLockOverconstrainedAlignment Property

Locking this alignment would overconstrain the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LockOverconstrainedAlignment { get; }
Public Shared ReadOnly Property LockOverconstrainedAlignment As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LockOverconstrainedAlignment {
    FailureDefinitionId^ get ();
}
static member LockOverconstrainedAlignment : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.LooseLabeledDimensionRegenFailure Property

BuiltInFailuresDimensionFailuresLooseLabeledDimensionRegenFailure Property

Failed to Regenerate Family

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LooseLabeledDimensionRegenFailure { get; }
Public Shared ReadOnly Property LooseLabeledDimensionRegenFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LooseLabeledDimensionRegenFailure {
    FailureDefinitionId^ get ();
}
static member LooseLabeledDimensionRegenFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.MoreThanOneDimsLabelToOneReportingParameter Property

BuiltInFailuresDimensionFailuresMoreThanOneDimsLabelToOneReportingParameter Property

Reporting parameters can only exist on a single dimension/constraint.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MoreThanOneDimsLabelToOneReportingParameter { get; }
Public Shared ReadOnly Property MoreThanOneDimsLabelToOneReportingParameter As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MoreThanOneDimsLabelToOneReportingParameter {
    FailureDefinitionId^ get ();
}
static member MoreThanOneDimsLabelToOneReportingParameter : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.NoConstraintsInProperSketch Property

BuiltInFailuresDimensionFailuresNoConstraintsInProperSketch Property

You are creating a constraint inside the sketch of a property line. Constraints inside a sketch can only drive elements within the sketch. Usually you do not want property lines driven by other elements. If you would like to constrain other elements to the property lines, you should add the constraints outside of sketch mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoConstraintsInProperSketch { get; }
Public Shared ReadOnly Property NoConstraintsInProperSketch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoConstraintsInProperSketch {
    FailureDefinitionId^ get ();
}
static member NoConstraintsInProperSketch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.NoConstraintsToLinks Property

BuiltInFailuresDimensionFailuresNoConstraintsToLinks Property

Constraints may not be created to linked instances using Shared Locations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoConstraintsToLinks { get; }
Public Shared ReadOnly Property NoConstraintsToLinks As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoConstraintsToLinks {
    FailureDefinitionId^ get ();
}
static member NoConstraintsToLinks : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.RadialDimensionCannotProjectToArc Property

BuiltInFailuresDimensionFailuresRadialDimensionCannotProjectToArc Property

Cannot form radial dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RadialDimensionCannotProjectToArc { get; }
Public Shared ReadOnly Property RadialDimensionCannotProjectToArc As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RadialDimensionCannotProjectToArc {
    FailureDefinitionId^ get ();
}
static member RadialDimensionCannotProjectToArc : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.RadialDimensionChangeRadiusFailed Property

BuiltInFailuresDimensionFailuresRadialDimensionChangeRadiusFailed Property

Can't change radius.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RadialDimensionChangeRadiusFailed { get; }
Public Shared ReadOnly Property RadialDimensionChangeRadiusFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RadialDimensionChangeRadiusFailed {
    FailureDefinitionId^ get ();
}
static member RadialDimensionChangeRadiusFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.RegenConstraintUnsatisfied Property

BuiltInFailuresDimensionFailuresRegenConstraintUnsatisfied Property

Constraints are not satisfied

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RegenConstraintUnsatisfied { get; }
Public Shared ReadOnly Property RegenConstraintUnsatisfied As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RegenConstraintUnsatisfied {
    FailureDefinitionId^ get ();
}
static member RegenConstraintUnsatisfied : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.RegenConstraintUnsatisfiedWarn Property

BuiltInFailuresDimensionFailuresRegenConstraintUnsatisfiedWarn Property

Constraints are not satisfied

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RegenConstraintUnsatisfiedWarn { get; }
Public Shared ReadOnly Property RegenConstraintUnsatisfiedWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RegenConstraintUnsatisfiedWarn {
    FailureDefinitionId^ get ();
}
static member RegenConstraintUnsatisfiedWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.ReportingParamAlreadyLabelsToAnotherDim Property

BuiltInFailuresDimensionFailuresReportingParamAlreadyLabelsToAnotherDim Property

Cannot label multi-dimensions to one reporting parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ReportingParamAlreadyLabelsToAnotherDim { get; }
Public Shared ReadOnly Property ReportingParamAlreadyLabelsToAnotherDim As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ReportingParamAlreadyLabelsToAnotherDim {
    FailureDefinitionId^ get ();
}
static member ReportingParamAlreadyLabelsToAnotherDim : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.SomeDimensionsLostOnPaste Property

BuiltInFailuresDimensionFailuresSomeDimensionsLostOnPaste Property

Some Dimensions were not copied because some References were lost.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SomeDimensionsLostOnPaste { get; }
Public Shared ReadOnly Property SomeDimensionsLostOnPaste As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SomeDimensionsLostOnPaste {
    FailureDefinitionId^ get ();
}
static member SomeDimensionsLostOnPaste : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.SomeDimensionsLostWitnessLines Property

BuiltInFailuresDimensionFailuresSomeDimensionsLostWitnessLines Property

Some Dimensions lost some of their References on paste.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SomeDimensionsLostWitnessLines { get; }
Public Shared ReadOnly Property SomeDimensionsLostWitnessLines As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SomeDimensionsLostWitnessLines {
    FailureDefinitionId^ get ();
}
static member SomeDimensionsLostWitnessLines : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.SomeSpotDimensionsLostOnPaste Property

BuiltInFailuresDimensionFailuresSomeSpotDimensionsLostOnPaste Property

Some Spot Dimensions were not copied because some References were lost.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SomeSpotDimensionsLostOnPaste { get; }
Public Shared ReadOnly Property SomeSpotDimensionsLostOnPaste As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SomeSpotDimensionsLostOnPaste {
    FailureDefinitionId^ get ();
}
static member SomeSpotDimensionsLostOnPaste : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.SpotDimensionFloatingPointError Property

BuiltInFailuresDimensionFailuresSpotDimensionFloatingPointError Property

Some spot dimensions contain invalid floating-point values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SpotDimensionFloatingPointError { get; }
Public Shared ReadOnly Property SpotDimensionFloatingPointError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SpotDimensionFloatingPointError {
    FailureDefinitionId^ get ();
}
static member SpotDimensionFloatingPointError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.SpotDimensionFormerSetMoribundCall Property

BuiltInFailuresDimensionFailuresSpotDimensionFormerSetMoribundCall Property

One or more Spot Dimension references are no longer valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SpotDimensionFormerSetMoribundCall { get; }
Public Shared ReadOnly Property SpotDimensionFormerSetMoribundCall As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SpotDimensionFormerSetMoribundCall {
    FailureDefinitionId^ get ();
}
static member SpotDimensionFormerSetMoribundCall : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.SpotDimensionReferencesNoLongerHorizontal Property

BuiltInFailuresDimensionFailuresSpotDimensionReferencesNoLongerHorizontal Property

One or more Spot Dimension references are no longer valid. Spot Dimensions can generally reference only those references which have valid coordinates in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SpotDimensionReferencesNoLongerHorizontal { get; }
Public Shared ReadOnly Property SpotDimensionReferencesNoLongerHorizontal As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SpotDimensionReferencesNoLongerHorizontal {
    FailureDefinitionId^ get ();
}
static member SpotDimensionReferencesNoLongerHorizontal : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.SpotElevationLostEdgeReferences Property

BuiltInFailuresDimensionFailuresSpotElevationLostEdgeReferences Property

Some Spot Dimensions lost their References. Those Spot Dimensions will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SpotElevationLostEdgeReferences { get; }
Public Shared ReadOnly Property SpotElevationLostEdgeReferences As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SpotElevationLostEdgeReferences {
    FailureDefinitionId^ get ();
}
static member SpotElevationLostEdgeReferences : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.SpotElevationMissesReference Property

BuiltInFailuresDimensionFailuresSpotElevationMissesReference Property

Spot Dimension does not lie on its reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SpotElevationMissesReference { get; }
Public Shared ReadOnly Property SpotElevationMissesReference As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SpotElevationMissesReference {
    FailureDefinitionId^ get ();
}
static member SpotElevationMissesReference : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.SpotSlopeReferenceIsVertical Property

BuiltInFailuresDimensionFailuresSpotSlopeReferenceIsVertical Property

The highlighted Spot Slope references an element that is vertical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SpotSlopeReferenceIsVertical { get; }
Public Shared ReadOnly Property SpotSlopeReferenceIsVertical As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SpotSlopeReferenceIsVertical {
    FailureDefinitionId^ get ();
}
static member SpotSlopeReferenceIsVertical : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.SpotSlopeReferencePointIsSingular Property

BuiltInFailuresDimensionFailuresSpotSlopeReferencePointIsSingular Property

The highlighted Spot Slope references an element point that is singular.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SpotSlopeReferencePointIsSingular { get; }
Public Shared ReadOnly Property SpotSlopeReferencePointIsSingular As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SpotSlopeReferencePointIsSingular {
    FailureDefinitionId^ get ();
}
static member SpotSlopeReferencePointIsSingular : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.UnavailableDimensionHostReference Property

BuiltInFailuresDimensionFailuresUnavailableDimensionHostReference Property

A dimension reference could not be resolved on the host element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnavailableDimensionHostReference { get; }
Public Shared ReadOnly Property UnavailableDimensionHostReference As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnavailableDimensionHostReference {
    FailureDefinitionId^ get ();
}
static member UnavailableDimensionHostReference : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.UnstableConstraintInFamily Property

BuiltInFailuresDimensionFailuresUnstableConstraintInFamily Property

Constraints between geometry in the family can behave unpredictably on parameter modification. To make the family reliable, constrain geometry to levels, reference planes, or reference lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnstableConstraintInFamily { get; }
Public Shared ReadOnly Property UnstableConstraintInFamily As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnstableConstraintInFamily {
    FailureDefinitionId^ get ();
}
static member UnstableConstraintInFamily : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.WrongConstraintInGridChainSketch Property

BuiltInFailuresDimensionFailuresWrongConstraintInGridChainSketch Property

Curve in a GridChain sketch cannot be constrained to a sub-grid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WrongConstraintInGridChainSketch { get; }
Public Shared ReadOnly Property WrongConstraintInGridChainSketch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WrongConstraintInGridChainSketch {
    FailureDefinitionId^ get ();
}
static member WrongConstraintInGridChainSketch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.WrongConstraintInJoistSystemSketch Property

BuiltInFailuresDimensionFailuresWrongConstraintInJoistSystemSketch Property

Structural Beam System sketch can't be constrained to its beam.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WrongConstraintInJoistSystemSketch { get; }
Public Shared ReadOnly Property WrongConstraintInJoistSystemSketch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WrongConstraintInJoistSystemSketch {
    FailureDefinitionId^ get ();
}
static member WrongConstraintInJoistSystemSketch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.WrongConstraintInSkeletonSketch Property

BuiltInFailuresDimensionFailuresWrongConstraintInSkeletonSketch Property

Reference Lines can only be constrained to Reference Planes, Levels, Family Host, and other Reference Lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WrongConstraintInSkeletonSketch { get; }
Public Shared ReadOnly Property WrongConstraintInSkeletonSketch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WrongConstraintInSkeletonSketch {
    FailureDefinitionId^ get ();
}
static member WrongConstraintInSkeletonSketch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DimensionFailures.WrongConstraintInTrussSketch Property

BuiltInFailuresDimensionFailuresWrongConstraintInTrussSketch Property

Structural Truss sketch can't be constrained to its members.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WrongConstraintInTrussSketch { get; }
Public Shared ReadOnly Property WrongConstraintInTrussSketch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WrongConstraintInTrussSketch {
    FailureDefinitionId^ get ();
}
static member WrongConstraintInTrussSketch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDimensionFailures Class


BuiltInFailures.DirectContext3DFailures Class

BuiltInFailuresDirectContext3DFailures Class

Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresDirectContext3DFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class DirectContext3DFailures
Public NotInheritable Class DirectContext3DFailures
public ref class DirectContext3DFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DirectContext3DFailures = class end

The BuiltInFailuresDirectContext3DFailures type exposes the following members.

Properties
Name | Description
NoMoreExternalDataTypeInstances | No more instances of the Coordination Model.
UnableToLoadCoordinationModel | Unable to load Coordination Model.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DirectContext3DFailures Properties

The BuiltInFailuresDirectContext3DFailures type exposes the following members.

Properties
Name | Description
NoMoreExternalDataTypeInstances | No more instances of the Coordination Model.
UnableToLoadCoordinationModel | Unable to load Coordination Model.
Top
See Also

Reference

BuiltInFailuresDirectContext3DFailures Class


BuiltInFailures.DirectContext3DFailures.NoMoreExternalDataTypeInstances Property

BuiltInFailuresDirectContext3DFailuresNoMoreExternalDataTypeInstances Property

No more instances of the Coordination Model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoMoreExternalDataTypeInstances { get; }
Public Shared ReadOnly Property NoMoreExternalDataTypeInstances As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoMoreExternalDataTypeInstances {
    FailureDefinitionId^ get ();
}
static member NoMoreExternalDataTypeInstances : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDirectContext3DFailures Class


BuiltInFailures.DirectContext3DFailures.UnableToLoadCoordinationModel Property

BuiltInFailuresDirectContext3DFailuresUnableToLoadCoordinationModel Property

Unable to load Coordination Model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnableToLoadCoordinationModel { get; }
Public Shared ReadOnly Property UnableToLoadCoordinationModel As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnableToLoadCoordinationModel {
    FailureDefinitionId^ get ();
}
static member UnableToLoadCoordinationModel : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDirectContext3DFailures Class


BuiltInFailures.DirectShapeFailures Class

BuiltInFailuresDirectShapeFailures Class

Failure definitions related to DirectShapes.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresDirectShapeFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class DirectShapeFailures
Public NotInheritable Class DirectShapeFailures
public ref class DirectShapeFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DirectShapeFailures = class end

The BuiltInFailuresDirectShapeFailures type exposes the following members.

Properties
Name | Description
CannotCreateDirectShapeOrTypeDocumentCorruption | Cannot create a DirectShape or DirectShapeType.
CannotCreateDirectShapeOrTypeError | Cannot create a DirectShape or DirectShapeType.
CannotCreateDirectShapeOrTypeWarning | Cannot create a DirectShape or DirectShapeType.
CannotCreateDirectShapeRefsWarning | Cannot create reference objects for a DirectShape.
CannotCreateDirectShapeTypeRefsWarning | Cannot create reference objects for a DirectShapeType.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DirectShapeFailures Properties

The BuiltInFailuresDirectShapeFailures type exposes the following members.

Properties
Name | Description
CannotCreateDirectShapeOrTypeDocumentCorruption | Cannot create a DirectShape or DirectShapeType.
CannotCreateDirectShapeOrTypeError | Cannot create a DirectShape or DirectShapeType.
CannotCreateDirectShapeOrTypeWarning | Cannot create a DirectShape or DirectShapeType.
CannotCreateDirectShapeRefsWarning | Cannot create reference objects for a DirectShape.
CannotCreateDirectShapeTypeRefsWarning | Cannot create reference objects for a DirectShapeType.
Top
See Also

Reference

BuiltInFailuresDirectShapeFailures Class


BuiltInFailures.DirectShapeFailures.CannotCreateDirectShapeOrTypeDocumentCorruption Property

BuiltInFailuresDirectShapeFailuresCannotCreateDirectShapeOrTypeDocumentCorruption Property

Cannot create a DirectShape or DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateDirectShapeOrTypeDocumentCorruption { get; }
Public Shared ReadOnly Property CannotCreateDirectShapeOrTypeDocumentCorruption As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateDirectShapeOrTypeDocumentCorruption {
    FailureDefinitionId^ get ();
}
static member CannotCreateDirectShapeOrTypeDocumentCorruption : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDirectShapeFailures Class


BuiltInFailures.DirectShapeFailures.CannotCreateDirectShapeOrTypeError Property

BuiltInFailuresDirectShapeFailuresCannotCreateDirectShapeOrTypeError Property

Cannot create a DirectShape or DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateDirectShapeOrTypeError { get; }
Public Shared ReadOnly Property CannotCreateDirectShapeOrTypeError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateDirectShapeOrTypeError {
    FailureDefinitionId^ get ();
}
static member CannotCreateDirectShapeOrTypeError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDirectShapeFailures Class


BuiltInFailures.DirectShapeFailures.CannotCreateDirectShapeOrTypeWarning Property

BuiltInFailuresDirectShapeFailuresCannotCreateDirectShapeOrTypeWarning Property

Cannot create a DirectShape or DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateDirectShapeOrTypeWarning { get; }
Public Shared ReadOnly Property CannotCreateDirectShapeOrTypeWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateDirectShapeOrTypeWarning {
    FailureDefinitionId^ get ();
}
static member CannotCreateDirectShapeOrTypeWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDirectShapeFailures Class


BuiltInFailures.DirectShapeFailures.CannotCreateDirectShapeRefsWarning Property

BuiltInFailuresDirectShapeFailuresCannotCreateDirectShapeRefsWarning Property

Cannot create reference objects for a DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateDirectShapeRefsWarning { get; }
Public Shared ReadOnly Property CannotCreateDirectShapeRefsWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateDirectShapeRefsWarning {
    FailureDefinitionId^ get ();
}
static member CannotCreateDirectShapeRefsWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDirectShapeFailures Class


BuiltInFailures.DirectShapeFailures.CannotCreateDirectShapeTypeRefsWarning Property

BuiltInFailuresDirectShapeFailuresCannotCreateDirectShapeTypeRefsWarning Property

Cannot create reference objects for a DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateDirectShapeTypeRefsWarning { get; }
Public Shared ReadOnly Property CannotCreateDirectShapeTypeRefsWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateDirectShapeTypeRefsWarning {
    FailureDefinitionId^ get ();
}
static member CannotCreateDirectShapeTypeRefsWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDirectShapeFailures Class


BuiltInFailures.DisplacementElementFailures Class

BuiltInFailuresDisplacementElementFailures Class

Error messages related to the DisplacementElement.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresDisplacementElementFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class DisplacementElementFailures
Public NotInheritable Class DisplacementElementFailures
public ref class DisplacementElementFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DisplacementElementFailures = class end

The BuiltInFailuresDisplacementElementFailures type exposes the following members.

Properties
Name | Description
CannotCopyDisplacementSetIntoOtherDocument | A Displacement Set can only be pasted into a view in the same document in which it was created.
CannotRemoveLastDisplacedElement | A Displacement Set can only be pasted into a view in the same document in which it was created.
DetectedCycleInDisplacedElementParents | Invalid parent relationship for a Displacement element. No cycles are allowed.
ElementsAlreadyDisplacedInView | You cannot copy a displacement set into a view if one or several of its elements already belong to another displacement set.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DisplacementElementFailures Properties

The BuiltInFailuresDisplacementElementFailures type exposes the following members.

Properties
Name | Description
CannotCopyDisplacementSetIntoOtherDocument | A Displacement Set can only be pasted into a view in the same document in which it was created.
CannotRemoveLastDisplacedElement | A Displacement Set can only be pasted into a view in the same document in which it was created.
DetectedCycleInDisplacedElementParents | Invalid parent relationship for a Displacement element. No cycles are allowed.
ElementsAlreadyDisplacedInView | You cannot copy a displacement set into a view if one or several of its elements already belong to another displacement set.
Top
See Also

Reference

BuiltInFailuresDisplacementElementFailures Class


BuiltInFailures.DisplacementElementFailures.CannotCopyDisplacementSetIntoOtherDocument Property

BuiltInFailuresDisplacementElementFailuresCannotCopyDisplacementSetIntoOtherDocument Property

A Displacement Set can only be pasted into a view in the same document in which it was created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyDisplacementSetIntoOtherDocument { get; }
Public Shared ReadOnly Property CannotCopyDisplacementSetIntoOtherDocument As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyDisplacementSetIntoOtherDocument {
    FailureDefinitionId^ get ();
}
static member CannotCopyDisplacementSetIntoOtherDocument : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDisplacementElementFailures Class


BuiltInFailures.DisplacementElementFailures.CannotRemoveLastDisplacedElement Property

BuiltInFailuresDisplacementElementFailuresCannotRemoveLastDisplacedElement Property

A Displacement Set can only be pasted into a view in the same document in which it was created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotRemoveLastDisplacedElement { get; }
Public Shared ReadOnly Property CannotRemoveLastDisplacedElement As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotRemoveLastDisplacedElement {
    FailureDefinitionId^ get ();
}
static member CannotRemoveLastDisplacedElement : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDisplacementElementFailures Class


BuiltInFailures.DisplacementElementFailures.DetectedCycleInDisplacedElementParents Property

BuiltInFailuresDisplacementElementFailuresDetectedCycleInDisplacedElementParents Property

Invalid parent relationship for a Displacement element. No cycles are allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DetectedCycleInDisplacedElementParents { get; }
Public Shared ReadOnly Property DetectedCycleInDisplacedElementParents As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DetectedCycleInDisplacedElementParents {
    FailureDefinitionId^ get ();
}
static member DetectedCycleInDisplacedElementParents : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDisplacementElementFailures Class


BuiltInFailures.DisplacementElementFailures.ElementsAlreadyDisplacedInView Property

BuiltInFailuresDisplacementElementFailuresElementsAlreadyDisplacedInView Property

You cannot copy a displacement set into a view if one or several of its elements already belong to another displacement set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ElementsAlreadyDisplacedInView { get; }
Public Shared ReadOnly Property ElementsAlreadyDisplacedInView As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ElementsAlreadyDisplacedInView {
    FailureDefinitionId^ get ();
}
static member ElementsAlreadyDisplacedInView : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDisplacementElementFailures Class


BuiltInFailures.DividedPathFailures Class

BuiltInFailuresDividedPathFailures Class

Failures related to divided path operations.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresDividedPathFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class DividedPathFailures
Public NotInheritable Class DividedPathFailures
public ref class DividedPathFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DividedPathFailures = class end

The BuiltInFailuresDividedPathFailures type exposes the following members.

Properties
Name | Description
DividedPathCannotApplyDivideSettings | Default Divide settings cannot be applied to Divided Path.
DividedPathCannotBeMirroredWithoutItsCurves | Divided path cannot be mirrored without its curves.
DividedPathCannotCreateFromGeometry | Highlighted geometry contains a path or edge that could not be divided.
DividedPathDistanceTooSmall | Distance is too small.
DividedPathIndentsOverlap | Beginning indent and end indent overlap.
DividedPathIntersectionPolycurveParamsStepFailed | Intersection failed.
DividedPathInvalidNumberOfPoints | End indent is too large.
DividedPathLayoutStepFailed | Layout algorithm failed.
DividedPathUpdateMergedPointKeysStepFailed | Merging failed.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DividedPathFailures Properties

The BuiltInFailuresDividedPathFailures type exposes the following members.

Properties
Name | Description
DividedPathCannotApplyDivideSettings | Default Divide settings cannot be applied to Divided Path.
DividedPathCannotBeMirroredWithoutItsCurves | Divided path cannot be mirrored without its curves.
DividedPathCannotCreateFromGeometry | Highlighted geometry contains a path or edge that could not be divided.
DividedPathDistanceTooSmall | Distance is too small.
DividedPathIndentsOverlap | Beginning indent and end indent overlap.
DividedPathIntersectionPolycurveParamsStepFailed | Intersection failed.
DividedPathInvalidNumberOfPoints | End indent is too large.
DividedPathLayoutStepFailed | Layout algorithm failed.
DividedPathUpdateMergedPointKeysStepFailed | Merging failed.
Top
See Also

Reference

BuiltInFailuresDividedPathFailures Class


BuiltInFailures.DividedPathFailures.DividedPathCannotApplyDivideSettings Property

BuiltInFailuresDividedPathFailuresDividedPathCannotApplyDivideSettings Property

Default Divide settings cannot be applied to Divided Path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DividedPathCannotApplyDivideSettings { get; }
Public Shared ReadOnly Property DividedPathCannotApplyDivideSettings As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DividedPathCannotApplyDivideSettings {
    FailureDefinitionId^ get ();
}
static member DividedPathCannotApplyDivideSettings : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDividedPathFailures Class


BuiltInFailures.DividedPathFailures.DividedPathCannotBeMirroredWithoutItsCurves Property

BuiltInFailuresDividedPathFailuresDividedPathCannotBeMirroredWithoutItsCurves Property

Divided path cannot be mirrored without its curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DividedPathCannotBeMirroredWithoutItsCurves { get; }
Public Shared ReadOnly Property DividedPathCannotBeMirroredWithoutItsCurves As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DividedPathCannotBeMirroredWithoutItsCurves {
    FailureDefinitionId^ get ();
}
static member DividedPathCannotBeMirroredWithoutItsCurves : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDividedPathFailures Class


BuiltInFailures.DividedPathFailures.DividedPathCannotCreateFromGeometry Property

BuiltInFailuresDividedPathFailuresDividedPathCannotCreateFromGeometry Property

Highlighted geometry contains a path or edge that could not be divided.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DividedPathCannotCreateFromGeometry { get; }
Public Shared ReadOnly Property DividedPathCannotCreateFromGeometry As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DividedPathCannotCreateFromGeometry {
    FailureDefinitionId^ get ();
}
static member DividedPathCannotCreateFromGeometry : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDividedPathFailures Class


BuiltInFailures.DividedPathFailures.DividedPathDistanceTooSmall Property

BuiltInFailuresDividedPathFailuresDividedPathDistanceTooSmall Property

Distance is too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DividedPathDistanceTooSmall { get; }
Public Shared ReadOnly Property DividedPathDistanceTooSmall As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DividedPathDistanceTooSmall {
    FailureDefinitionId^ get ();
}
static member DividedPathDistanceTooSmall : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDividedPathFailures Class


BuiltInFailures.DividedPathFailures.DividedPathIndentsOverlap Property

BuiltInFailuresDividedPathFailuresDividedPathIndentsOverlap Property

Beginning indent and end indent overlap.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DividedPathIndentsOverlap { get; }
Public Shared ReadOnly Property DividedPathIndentsOverlap As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DividedPathIndentsOverlap {
    FailureDefinitionId^ get ();
}
static member DividedPathIndentsOverlap : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDividedPathFailures Class


BuiltInFailures.DividedPathFailures.DividedPathIntersectionPolycurveParamsStepFailed Property

BuiltInFailuresDividedPathFailuresDividedPathIntersectionPolycurveParamsStepFailed Property

Intersection failed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DividedPathIntersectionPolycurveParamsStepFailed { get; }
Public Shared ReadOnly Property DividedPathIntersectionPolycurveParamsStepFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DividedPathIntersectionPolycurveParamsStepFailed {
    FailureDefinitionId^ get ();
}
static member DividedPathIntersectionPolycurveParamsStepFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDividedPathFailures Class


BuiltInFailures.DividedPathFailures.DividedPathInvalidNumberOfPoints Property

BuiltInFailuresDividedPathFailuresDividedPathInvalidNumberOfPoints Property

End indent is too large.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DividedPathInvalidNumberOfPoints { get; }
Public Shared ReadOnly Property DividedPathInvalidNumberOfPoints As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DividedPathInvalidNumberOfPoints {
    FailureDefinitionId^ get ();
}
static member DividedPathInvalidNumberOfPoints : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDividedPathFailures Class


BuiltInFailures.DividedPathFailures.DividedPathLayoutStepFailed Property

BuiltInFailuresDividedPathFailuresDividedPathLayoutStepFailed Property

Layout algorithm failed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DividedPathLayoutStepFailed { get; }
Public Shared ReadOnly Property DividedPathLayoutStepFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DividedPathLayoutStepFailed {
    FailureDefinitionId^ get ();
}
static member DividedPathLayoutStepFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDividedPathFailures Class


BuiltInFailures.DividedPathFailures.DividedPathUpdateMergedPointKeysStepFailed Property

BuiltInFailuresDividedPathFailuresDividedPathUpdateMergedPointKeysStepFailed Property

Merging failed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DividedPathUpdateMergedPointKeysStepFailed { get; }
Public Shared ReadOnly Property DividedPathUpdateMergedPointKeysStepFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DividedPathUpdateMergedPointKeysStepFailed {
    FailureDefinitionId^ get ();
}
static member DividedPathUpdateMergedPointKeysStepFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDividedPathFailures Class


BuiltInFailures.DividedSurfaceFailures Class

BuiltInFailuresDividedSurfaceFailures Class

Failures about DividedSurface.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresDividedSurfaceFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class DividedSurfaceFailures
Public NotInheritable Class DividedSurfaceFailures
public ref class DividedSurfaceFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DividedSurfaceFailures = class end

The BuiltInFailuresDividedSurfaceFailures type exposes the following members.

Properties
Name | Description
DividedSurfaceCannotApplyDivideSettings | Default Divide settings were not applied to Divided Surface. Please adjust grid spacing values manually.
DividedSurfaceCoincidingSplittingWorkplanes | Coinciding splitting workplanes are encountered
DividedSurfaceCurveChainBelongsToMultipleBeltIntervals | A chain formed by these curve elements defines a splitter belonging to multiple belt intervals and will be ignored
DividedSurfaceCurveChainBothUandV | A chain formed by these curve elements is trying to be both U- and V- splitter
DividedSurfaceCurveChainDoesNotEngageUorV | A chain formed by these curve elements does engage any gridlines on the face to be divided and will be ignored
DividedSurfaceCurveChainGeneralProblem | The chain formed by these curve elements cannot be processed and will be ignored.
DividedSurfaceCurveChainIntersection | A chain formed by these curve elements intersects other chain with the same grid orientation. Both chains will be ignored
DividedSurfaceCurveChainIsTooClosedToGridlines | A chain formed by these curve elements defines a splitter which lies too close to gridlines and will be ignored
DividedSurfaceCurveChainMultipleSeqIntersWithDivLine | The chain formed by these curve elements has multiple sequential intersections with a gridline and so the chain will be ignored
DividedSurfaceCurveChainNonSeqIntersWithDivLines | The chain formed by these curve elements has multiple non-sequential intersections with the same gridline and will be ignored
DividedSurfaceCurveChainUnsortableBucket | The chains formed by these curve elements cannot be ordered consistently in the their grid interval and will be ignored
DividedSurfaceCurveFromChainMultipleIntersWithDivLine | A curve from the chain formed by these curve elements either intersects a gridline more than once or coincides with it and so the chain will be ignored
DividedSurfaceCurveLoopChainIntersectedByExtensions | Curve elements forming a chain which is intersected by extensions of the chain ends cannot be used as splitters and are ignored.
DividedSurfaceCuttingSurfaceDoesNotCutMeshFace | The surface-based splitter does not intersect a face to be divided and will be ignored
DividedSurfaceCuttingSurfaceGeneralProblem | Cannot process a surface-based splitter
DividedSurfaceCuttingSurfaceMakesMultipleCuts | The surface-based splitter intersects a face to be divided in multiple places and this case is not currently supported
DividedSurfaceDidNotRegenerateProperly | Divided Surface gridlines could not be generated.
DividedSurfaceDiscardedSplittersWarning | Not all intersecting references (levels, reference planes or lines) could be used to intersect the surface
DividedSurfaceIgnoresSplitters | Revit cannot create a rectangular grid by intersecting the current selection of elements (levels, reference planes, or curves drawn on reference planes) with the surface. Make sure that curves do not form closed loops. It is helpful if curves start and end outside the surface, rather than inside it.
DividedSurfaceInvalidSpacing | Constraints not satisfied, cannot generate gridlines.
DividedSurfaceLoopsOfSplittingCurves | Curve elements forming a closed loop currently cannot be used as splitters and are ignored.
DividedSurfaceMultipleIntersBetweenOppositeVirtualGrids | There are multiple intersections between splitting chain of virtual splitters defined by these elements and so one of the virtual splitters will be ignored
DividedSurfaceSelfIntersectingCurveLoopChain | Curve elements forming a self-intersecting chain cannot be used as splitters and are ignored.
DividedSurfaceSingleCurveLoopsAsSplitters | Curve elements forming a single curve loop cannot be used as splitters and are ignored.
DividedSurfaceSingleCurveMultipleIntersBetweenOppositeVirtualGrids | There are curves in splitting chain of virtual splitters defined by these elements which intersect each other multiple times and so one of the virtual splitters will be ignored
DividedSurfaceSplitManagerProblem1dNonWPCurve | Divided Surface cannot be split by a one dimensional curve without workplane
DividedSurfaceSplitManagerProblemClosedArcOrEllipse | Divided Surface cannot be split by a closed arc or ellipse.
DividedSurfaceSplitRefInvisible | Some of the splitting references of this Divided Surface are invisible in the current view.
DividedSurfaceSplittingCurveChainsBetweenMultipleNeighbors | Curve elements which form chains connecting points shared by more than two curve elements are ignored.
DividedSurfaceSplittingCurvesWithMultipleNeighbors | A point cannot coincide with end points of more than two curve elements. All curve elements adjacent to such a point are ignored.
DividedSurfaceZeroLengthSplittingCurve | Curve element with zero length cannot be used as a splitter and ignored.
MeshTopologicalSortFailed | Splitters and grids do not define a consistent rectangular mesh on the face.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DividedSurfaceFailures Properties

The BuiltInFailuresDividedSurfaceFailures type exposes the following members.

Properties
Name | Description
DividedSurfaceCannotApplyDivideSettings | Default Divide settings were not applied to Divided Surface. Please adjust grid spacing values manually.
DividedSurfaceCoincidingSplittingWorkplanes | Coinciding splitting workplanes are encountered
DividedSurfaceCurveChainBelongsToMultipleBeltIntervals | A chain formed by these curve elements defines a splitter belonging to multiple belt intervals and will be ignored
DividedSurfaceCurveChainBothUandV | A chain formed by these curve elements is trying to be both U- and V- splitter
DividedSurfaceCurveChainDoesNotEngageUorV | A chain formed by these curve elements does engage any gridlines on the face to be divided and will be ignored
DividedSurfaceCurveChainGeneralProblem | The chain formed by these curve elements cannot be processed and will be ignored.
DividedSurfaceCurveChainIntersection | A chain formed by these curve elements intersects other chain with the same grid orientation. Both chains will be ignored
DividedSurfaceCurveChainIsTooClosedToGridlines | A chain formed by these curve elements defines a splitter which lies too close to gridlines and will be ignored
DividedSurfaceCurveChainMultipleSeqIntersWithDivLine | The chain formed by these curve elements has multiple sequential intersections with a gridline and so the chain will be ignored
DividedSurfaceCurveChainNonSeqIntersWithDivLines | The chain formed by these curve elements has multiple non-sequential intersections with the same gridline and will be ignored
DividedSurfaceCurveChainUnsortableBucket | The chains formed by these curve elements cannot be ordered consistently in the their grid interval and will be ignored
DividedSurfaceCurveFromChainMultipleIntersWithDivLine | A curve from the chain formed by these curve elements either intersects a gridline more than once or coincides with it and so the chain will be ignored
DividedSurfaceCurveLoopChainIntersectedByExtensions | Curve elements forming a chain which is intersected by extensions of the chain ends cannot be used as splitters and are ignored.
DividedSurfaceCuttingSurfaceDoesNotCutMeshFace | The surface-based splitter does not intersect a face to be divided and will be ignored
DividedSurfaceCuttingSurfaceGeneralProblem | Cannot process a surface-based splitter
DividedSurfaceCuttingSurfaceMakesMultipleCuts | The surface-based splitter intersects a face to be divided in multiple places and this case is not currently supported
DividedSurfaceDidNotRegenerateProperly | Divided Surface gridlines could not be generated.
DividedSurfaceDiscardedSplittersWarning | Not all intersecting references (levels, reference planes or lines) could be used to intersect the surface
DividedSurfaceIgnoresSplitters | Revit cannot create a rectangular grid by intersecting the current selection of elements (levels, reference planes, or curves drawn on reference planes) with the surface. Make sure that curves do not form closed loops. It is helpful if curves start and end outside the surface, rather than inside it.
DividedSurfaceInvalidSpacing | Constraints not satisfied, cannot generate gridlines.
DividedSurfaceLoopsOfSplittingCurves | Curve elements forming a closed loop currently cannot be used as splitters and are ignored.
DividedSurfaceMultipleIntersBetweenOppositeVirtualGrids | There are multiple intersections between splitting chain of virtual splitters defined by these elements and so one of the virtual splitters will be ignored
DividedSurfaceSelfIntersectingCurveLoopChain | Curve elements forming a self-intersecting chain cannot be used as splitters and are ignored.
DividedSurfaceSingleCurveLoopsAsSplitters | Curve elements forming a single curve loop cannot be used as splitters and are ignored.
DividedSurfaceSingleCurveMultipleIntersBetweenOppositeVirtualGrids | There are curves in splitting chain of virtual splitters defined by these elements which intersect each other multiple times and so one of the virtual splitters will be ignored
DividedSurfaceSplitManagerProblem1dNonWPCurve | Divided Surface cannot be split by a one dimensional curve without workplane
DividedSurfaceSplitManagerProblemClosedArcOrEllipse | Divided Surface cannot be split by a closed arc or ellipse.
DividedSurfaceSplitRefInvisible | Some of the splitting references of this Divided Surface are invisible in the current view.
DividedSurfaceSplittingCurveChainsBetweenMultipleNeighbors | Curve elements which form chains connecting points shared by more than two curve elements are ignored.
DividedSurfaceSplittingCurvesWithMultipleNeighbors | A point cannot coincide with end points of more than two curve elements. All curve elements adjacent to such a point are ignored.
DividedSurfaceZeroLengthSplittingCurve | Curve element with zero length cannot be used as a splitter and ignored.
MeshTopologicalSortFailed | Splitters and grids do not define a consistent rectangular mesh on the face.
Top
See Also

Reference

BuiltInFailuresDividedSurfaceFailures Class


BuiltInFailures.DividedSurfaceFailures.DividedSurfaceCannotApplyDivideSettings Property

BuiltInFailuresDividedSurfaceFailuresDividedSurfaceCannotApplyDivideSettings Property

Default Divide settings were not applied to Divided Surface. Please adjust grid spacing values manually.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DividedSurfaceCannotApplyDivideSettings { get; }
Public Shared ReadOnly Property DividedSurfaceCannotApplyDivideSettings As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DividedSurfaceCannotApplyDivideSettings {
    FailureDefinitionId^ get ();
}
static member DividedSurfaceCannotApplyDivideSettings : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDividedSurfaceFailures Class


BuiltInFailures.DividedSurfaceFailures.DividedSurfaceCoincidingSplittingWorkplanes Property

BuiltInFailuresDividedSurfaceFailuresDividedSurfaceCoincidingSplittingWorkplanes Property

Coinciding splitting workplanes are encountered

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DividedSurfaceCoincidingSplittingWorkplanes { get; }
Public Shared ReadOnly Property DividedSurfaceCoincidingSplittingWorkplanes As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DividedSurfaceCoincidingSplittingWorkplanes {
    FailureDefinitionId^ get ();
}
static member DividedSurfaceCoincidingSplittingWorkplanes : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDividedSurfaceFailures Class


BuiltInFailures.DividedSurfaceFailures.DividedSurfaceCurveChainBelongsToMultipleBeltIntervals Property

BuiltInFailuresDividedSurfaceFailuresDividedSurfaceCurveChainBelongsToMultipleBeltIntervals Property

A chain formed by these curve elements defines a splitter belonging to multiple belt intervals and will be ignored

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DividedSurfaceCurveChainBelongsToMultipleBeltIntervals { get; }
Public Shared ReadOnly Property DividedSurfaceCurveChainBelongsToMultipleBeltIntervals As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DividedSurfaceCurveChainBelongsToMultipleBeltIntervals {
    FailureDefinitionId^ get ();
}
static member DividedSurfaceCurveChainBelongsToMultipleBeltIntervals : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDividedSurfaceFailures Class


BuiltInFailures.DividedSurfaceFailures.DividedSurfaceCurveChainBothUandV Property

BuiltInFailuresDividedSurfaceFailuresDividedSurfaceCurveChainBothUandV Property

A chain formed by these curve elements is trying to be both U- and V- splitter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DividedSurfaceCurveChainBothUandV { get; }
Public Shared ReadOnly Property DividedSurfaceCurveChainBothUandV As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DividedSurfaceCurveChainBothUandV {
    FailureDefinitionId^ get ();
}
static member DividedSurfaceCurveChainBothUandV : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDividedSurfaceFailures Class


BuiltInFailures.DividedSurfaceFailures.DividedSurfaceCurveChainDoesNotEngageUorV Property

BuiltInFailuresDividedSurfaceFailuresDividedSurfaceCurveChainDoesNotEngageUorV Property

A chain formed by these curve elements does engage any gridlines on the face to be divided and will be ignored

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DividedSurfaceCurveChainDoesNotEngageUorV { get; }
Public Shared ReadOnly Property DividedSurfaceCurveChainDoesNotEngageUorV As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DividedSurfaceCurveChainDoesNotEngageUorV {
    FailureDefinitionId^ get ();
}
static member DividedSurfaceCurveChainDoesNotEngageUorV : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDividedSurfaceFailures Class


BuiltInFailures.DividedSurfaceFailures.DividedSurfaceCurveChainGeneralProblem Property

BuiltInFailuresDividedSurfaceFailuresDividedSurfaceCurveChainGeneralProblem Property

The chain formed by these curve elements cannot be processed and will be ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DividedSurfaceCurveChainGeneralProblem { get; }
Public Shared ReadOnly Property DividedSurfaceCurveChainGeneralProblem As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DividedSurfaceCurveChainGeneralProblem {
    FailureDefinitionId^ get ();
}
static member DividedSurfaceCurveChainGeneralProblem : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDividedSurfaceFailures Class


BuiltInFailures.DividedSurfaceFailures.DividedSurfaceCurveChainIntersection Property

BuiltInFailuresDividedSurfaceFailuresDividedSurfaceCurveChainIntersection Property

A chain formed by these curve elements intersects other chain with the same grid orientation. Both chains will be ignored

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DividedSurfaceCurveChainIntersection { get; }
Public Shared ReadOnly Property DividedSurfaceCurveChainIntersection As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DividedSurfaceCurveChainIntersection {
    FailureDefinitionId^ get ();
}
static member DividedSurfaceCurveChainIntersection : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDividedSurfaceFailures Class


BuiltInFailures.DividedSurfaceFailures.DividedSurfaceCurveChainIsTooClosedToGridlines Property

BuiltInFailuresDividedSurfaceFailuresDividedSurfaceCurveChainIsTooClosedToGridlines Property

A chain formed by these curve elements defines a splitter which lies too close to gridlines and will be ignored

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DividedSurfaceCurveChainIsTooClosedToGridlines { get; }
Public Shared ReadOnly Property DividedSurfaceCurveChainIsTooClosedToGridlines As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DividedSurfaceCurveChainIsTooClosedToGridlines {
    FailureDefinitionId^ get ();
}
static member DividedSurfaceCurveChainIsTooClosedToGridlines : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDividedSurfaceFailures Class


BuiltInFailures.DividedSurfaceFailures.DividedSurfaceCurveChainMultipleSeqIntersWithDivLine Property

BuiltInFailuresDividedSurfaceFailuresDividedSurfaceCurveChainMultipleSeqIntersWithDivLine Property

The chain formed by these curve elements has multiple sequential intersections with a gridline and so the chain will be ignored

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DividedSurfaceCurveChainMultipleSeqIntersWithDivLine { get; }
Public Shared ReadOnly Property DividedSurfaceCurveChainMultipleSeqIntersWithDivLine As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DividedSurfaceCurveChainMultipleSeqIntersWithDivLine {
    FailureDefinitionId^ get ();
}
static member DividedSurfaceCurveChainMultipleSeqIntersWithDivLine : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDividedSurfaceFailures Class


BuiltInFailures.DividedSurfaceFailures.DividedSurfaceCurveChainNonSeqIntersWithDivLines Property

BuiltInFailuresDividedSurfaceFailuresDividedSurfaceCurveChainNonSeqIntersWithDivLines Property

The chain formed by these curve elements has multiple non-sequential intersections with the same gridline and will be ignored

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DividedSurfaceCurveChainNonSeqIntersWithDivLines { get; }
Public Shared ReadOnly Property DividedSurfaceCurveChainNonSeqIntersWithDivLines As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DividedSurfaceCurveChainNonSeqIntersWithDivLines {
    FailureDefinitionId^ get ();
}
static member DividedSurfaceCurveChainNonSeqIntersWithDivLines : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDividedSurfaceFailures Class


BuiltInFailures.DividedSurfaceFailures.DividedSurfaceCurveChainUnsortableBucket Property

BuiltInFailuresDividedSurfaceFailuresDividedSurfaceCurveChainUnsortableBucket Property

The chains formed by these curve elements cannot be ordered consistently in the their grid interval and will be ignored

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DividedSurfaceCurveChainUnsortableBucket { get; }
Public Shared ReadOnly Property DividedSurfaceCurveChainUnsortableBucket As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DividedSurfaceCurveChainUnsortableBucket {
    FailureDefinitionId^ get ();
}
static member DividedSurfaceCurveChainUnsortableBucket : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDividedSurfaceFailures Class


BuiltInFailures.DividedSurfaceFailures.DividedSurfaceCurveFromChainMultipleIntersWithDivLine Property

BuiltInFailuresDividedSurfaceFailuresDividedSurfaceCurveFromChainMultipleIntersWithDivLine Property

A curve from the chain formed by these curve elements either intersects a gridline more than once or coincides with it and so the chain will be ignored

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DividedSurfaceCurveFromChainMultipleIntersWithDivLine { get; }
Public Shared ReadOnly Property DividedSurfaceCurveFromChainMultipleIntersWithDivLine As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DividedSurfaceCurveFromChainMultipleIntersWithDivLine {
    FailureDefinitionId^ get ();
}
static member DividedSurfaceCurveFromChainMultipleIntersWithDivLine : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDividedSurfaceFailures Class


BuiltInFailures.DividedSurfaceFailures.DividedSurfaceCurveLoopChainIntersectedByExtensions Property

BuiltInFailuresDividedSurfaceFailuresDividedSurfaceCurveLoopChainIntersectedByExtensions Property

Curve elements forming a chain which is intersected by extensions of the chain ends cannot be used as splitters and are ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DividedSurfaceCurveLoopChainIntersectedByExtensions { get; }
Public Shared ReadOnly Property DividedSurfaceCurveLoopChainIntersectedByExtensions As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DividedSurfaceCurveLoopChainIntersectedByExtensions {
    FailureDefinitionId^ get ();
}
static member DividedSurfaceCurveLoopChainIntersectedByExtensions : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDividedSurfaceFailures Class


BuiltInFailures.DividedSurfaceFailures.DividedSurfaceCuttingSurfaceDoesNotCutMeshFace Property

BuiltInFailuresDividedSurfaceFailuresDividedSurfaceCuttingSurfaceDoesNotCutMeshFace Property

The surface-based splitter does not intersect a face to be divided and will be ignored

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DividedSurfaceCuttingSurfaceDoesNotCutMeshFace { get; }
Public Shared ReadOnly Property DividedSurfaceCuttingSurfaceDoesNotCutMeshFace As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DividedSurfaceCuttingSurfaceDoesNotCutMeshFace {
    FailureDefinitionId^ get ();
}
static member DividedSurfaceCuttingSurfaceDoesNotCutMeshFace : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDividedSurfaceFailures Class


BuiltInFailures.DividedSurfaceFailures.DividedSurfaceCuttingSurfaceGeneralProblem Property

BuiltInFailuresDividedSurfaceFailuresDividedSurfaceCuttingSurfaceGeneralProblem Property

Cannot process a surface-based splitter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DividedSurfaceCuttingSurfaceGeneralProblem { get; }
Public Shared ReadOnly Property DividedSurfaceCuttingSurfaceGeneralProblem As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DividedSurfaceCuttingSurfaceGeneralProblem {
    FailureDefinitionId^ get ();
}
static member DividedSurfaceCuttingSurfaceGeneralProblem : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDividedSurfaceFailures Class


BuiltInFailures.DividedSurfaceFailures.DividedSurfaceCuttingSurfaceMakesMultipleCuts Property

BuiltInFailuresDividedSurfaceFailuresDividedSurfaceCuttingSurfaceMakesMultipleCuts Property

The surface-based splitter intersects a face to be divided in multiple places and this case is not currently supported

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DividedSurfaceCuttingSurfaceMakesMultipleCuts { get; }
Public Shared ReadOnly Property DividedSurfaceCuttingSurfaceMakesMultipleCuts As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DividedSurfaceCuttingSurfaceMakesMultipleCuts {
    FailureDefinitionId^ get ();
}
static member DividedSurfaceCuttingSurfaceMakesMultipleCuts : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDividedSurfaceFailures Class


BuiltInFailures.DividedSurfaceFailures.DividedSurfaceDidNotRegenerateProperly Property

BuiltInFailuresDividedSurfaceFailuresDividedSurfaceDidNotRegenerateProperly Property

Divided Surface gridlines could not be generated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DividedSurfaceDidNotRegenerateProperly { get; }
Public Shared ReadOnly Property DividedSurfaceDidNotRegenerateProperly As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DividedSurfaceDidNotRegenerateProperly {
    FailureDefinitionId^ get ();
}
static member DividedSurfaceDidNotRegenerateProperly : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDividedSurfaceFailures Class


BuiltInFailures.DividedSurfaceFailures.DividedSurfaceDiscardedSplittersWarning Property

BuiltInFailuresDividedSurfaceFailuresDividedSurfaceDiscardedSplittersWarning Property

Not all intersecting references (levels, reference planes or lines) could be used to intersect the surface

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DividedSurfaceDiscardedSplittersWarning { get; }
Public Shared ReadOnly Property DividedSurfaceDiscardedSplittersWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DividedSurfaceDiscardedSplittersWarning {
    FailureDefinitionId^ get ();
}
static member DividedSurfaceDiscardedSplittersWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDividedSurfaceFailures Class


BuiltInFailures.DividedSurfaceFailures.DividedSurfaceIgnoresSplitters Property

BuiltInFailuresDividedSurfaceFailuresDividedSurfaceIgnoresSplitters Property

Revit cannot create a rectangular grid by intersecting the current selection of elements (levels, reference planes, or curves drawn on reference planes) with the surface. Make sure that curves do not form closed loops. It is helpful if curves start and end outside the surface, rather than inside it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DividedSurfaceIgnoresSplitters { get; }
Public Shared ReadOnly Property DividedSurfaceIgnoresSplitters As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DividedSurfaceIgnoresSplitters {
    FailureDefinitionId^ get ();
}
static member DividedSurfaceIgnoresSplitters : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDividedSurfaceFailures Class


BuiltInFailures.DividedSurfaceFailures.DividedSurfaceInvalidSpacing Property

BuiltInFailuresDividedSurfaceFailuresDividedSurfaceInvalidSpacing Property

Constraints not satisfied, cannot generate gridlines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DividedSurfaceInvalidSpacing { get; }
Public Shared ReadOnly Property DividedSurfaceInvalidSpacing As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DividedSurfaceInvalidSpacing {
    FailureDefinitionId^ get ();
}
static member DividedSurfaceInvalidSpacing : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDividedSurfaceFailures Class


BuiltInFailures.DividedSurfaceFailures.DividedSurfaceLoopsOfSplittingCurves Property

BuiltInFailuresDividedSurfaceFailuresDividedSurfaceLoopsOfSplittingCurves Property

Curve elements forming a closed loop currently cannot be used as splitters and are ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DividedSurfaceLoopsOfSplittingCurves { get; }
Public Shared ReadOnly Property DividedSurfaceLoopsOfSplittingCurves As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DividedSurfaceLoopsOfSplittingCurves {
    FailureDefinitionId^ get ();
}
static member DividedSurfaceLoopsOfSplittingCurves : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDividedSurfaceFailures Class


BuiltInFailures.DividedSurfaceFailures.DividedSurfaceMultipleIntersBetweenOppositeVirtualGrids Property

BuiltInFailuresDividedSurfaceFailuresDividedSurfaceMultipleIntersBetweenOppositeVirtualGrids Property

There are multiple intersections between splitting chain of virtual splitters defined by these elements and so one of the virtual splitters will be ignored

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DividedSurfaceMultipleIntersBetweenOppositeVirtualGrids { get; }
Public Shared ReadOnly Property DividedSurfaceMultipleIntersBetweenOppositeVirtualGrids As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DividedSurfaceMultipleIntersBetweenOppositeVirtualGrids {
    FailureDefinitionId^ get ();
}
static member DividedSurfaceMultipleIntersBetweenOppositeVirtualGrids : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDividedSurfaceFailures Class


BuiltInFailures.DividedSurfaceFailures.DividedSurfaceSelfIntersectingCurveLoopChain Property

BuiltInFailuresDividedSurfaceFailuresDividedSurfaceSelfIntersectingCurveLoopChain Property

Curve elements forming a self-intersecting chain cannot be used as splitters and are ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DividedSurfaceSelfIntersectingCurveLoopChain { get; }
Public Shared ReadOnly Property DividedSurfaceSelfIntersectingCurveLoopChain As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DividedSurfaceSelfIntersectingCurveLoopChain {
    FailureDefinitionId^ get ();
}
static member DividedSurfaceSelfIntersectingCurveLoopChain : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDividedSurfaceFailures Class


BuiltInFailures.DividedSurfaceFailures.DividedSurfaceSingleCurveLoopsAsSplitters Property

BuiltInFailuresDividedSurfaceFailuresDividedSurfaceSingleCurveLoopsAsSplitters Property

Curve elements forming a single curve loop cannot be used as splitters and are ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DividedSurfaceSingleCurveLoopsAsSplitters { get; }
Public Shared ReadOnly Property DividedSurfaceSingleCurveLoopsAsSplitters As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DividedSurfaceSingleCurveLoopsAsSplitters {
    FailureDefinitionId^ get ();
}
static member DividedSurfaceSingleCurveLoopsAsSplitters : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDividedSurfaceFailures Class


BuiltInFailures.DividedSurfaceFailures.DividedSurfaceSingleCurveMultipleIntersBetweenOppositeVirtualGrids Property

BuiltInFailuresDividedSurfaceFailuresDividedSurfaceSingleCurveMultipleIntersBetweenOppositeVirtualGrids Property

There are curves in splitting chain of virtual splitters defined by these elements which intersect each other multiple times and so one of the virtual splitters will be ignored

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DividedSurfaceSingleCurveMultipleIntersBetweenOppositeVirtualGrids { get; }
Public Shared ReadOnly Property DividedSurfaceSingleCurveMultipleIntersBetweenOppositeVirtualGrids As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DividedSurfaceSingleCurveMultipleIntersBetweenOppositeVirtualGrids {
    FailureDefinitionId^ get ();
}
static member DividedSurfaceSingleCurveMultipleIntersBetweenOppositeVirtualGrids : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDividedSurfaceFailures Class


BuiltInFailures.DividedSurfaceFailures.DividedSurfaceSplitManagerProblem1dNonWPCurve Property

BuiltInFailuresDividedSurfaceFailuresDividedSurfaceSplitManagerProblem1dNonWPCurve Property

Divided Surface cannot be split by a one dimensional curve without workplane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DividedSurfaceSplitManagerProblem1dNonWPCurve { get; }
Public Shared ReadOnly Property DividedSurfaceSplitManagerProblem1dNonWPCurve As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DividedSurfaceSplitManagerProblem1dNonWPCurve {
    FailureDefinitionId^ get ();
}
static member DividedSurfaceSplitManagerProblem1dNonWPCurve : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDividedSurfaceFailures Class


BuiltInFailures.DividedSurfaceFailures.DividedSurfaceSplitManagerProblemClosedArcOrEllipse Property

BuiltInFailuresDividedSurfaceFailuresDividedSurfaceSplitManagerProblemClosedArcOrEllipse Property

Divided Surface cannot be split by a closed arc or ellipse.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DividedSurfaceSplitManagerProblemClosedArcOrEllipse { get; }
Public Shared ReadOnly Property DividedSurfaceSplitManagerProblemClosedArcOrEllipse As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DividedSurfaceSplitManagerProblemClosedArcOrEllipse {
    FailureDefinitionId^ get ();
}
static member DividedSurfaceSplitManagerProblemClosedArcOrEllipse : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDividedSurfaceFailures Class


BuiltInFailures.DividedSurfaceFailures.DividedSurfaceSplitRefInvisible Property

BuiltInFailuresDividedSurfaceFailuresDividedSurfaceSplitRefInvisible Property

Some of the splitting references of this Divided Surface are invisible in the current view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DividedSurfaceSplitRefInvisible { get; }
Public Shared ReadOnly Property DividedSurfaceSplitRefInvisible As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DividedSurfaceSplitRefInvisible {
    FailureDefinitionId^ get ();
}
static member DividedSurfaceSplitRefInvisible : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDividedSurfaceFailures Class


BuiltInFailures.DividedSurfaceFailures.DividedSurfaceSplittingCurveChainsBetweenMultipleNeighbors Property

BuiltInFailuresDividedSurfaceFailuresDividedSurfaceSplittingCurveChainsBetweenMultipleNeighbors Property

Curve elements which form chains connecting points shared by more than two curve elements are ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DividedSurfaceSplittingCurveChainsBetweenMultipleNeighbors { get; }
Public Shared ReadOnly Property DividedSurfaceSplittingCurveChainsBetweenMultipleNeighbors As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DividedSurfaceSplittingCurveChainsBetweenMultipleNeighbors {
    FailureDefinitionId^ get ();
}
static member DividedSurfaceSplittingCurveChainsBetweenMultipleNeighbors : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDividedSurfaceFailures Class


BuiltInFailures.DividedSurfaceFailures.DividedSurfaceSplittingCurvesWithMultipleNeighbors Property

BuiltInFailuresDividedSurfaceFailuresDividedSurfaceSplittingCurvesWithMultipleNeighbors Property

A point cannot coincide with end points of more than two curve elements. All curve elements adjacent to such a point are ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DividedSurfaceSplittingCurvesWithMultipleNeighbors { get; }
Public Shared ReadOnly Property DividedSurfaceSplittingCurvesWithMultipleNeighbors As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DividedSurfaceSplittingCurvesWithMultipleNeighbors {
    FailureDefinitionId^ get ();
}
static member DividedSurfaceSplittingCurvesWithMultipleNeighbors : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDividedSurfaceFailures Class


BuiltInFailures.DividedSurfaceFailures.DividedSurfaceZeroLengthSplittingCurve Property

BuiltInFailuresDividedSurfaceFailuresDividedSurfaceZeroLengthSplittingCurve Property

Curve element with zero length cannot be used as a splitter and ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DividedSurfaceZeroLengthSplittingCurve { get; }
Public Shared ReadOnly Property DividedSurfaceZeroLengthSplittingCurve As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DividedSurfaceZeroLengthSplittingCurve {
    FailureDefinitionId^ get ();
}
static member DividedSurfaceZeroLengthSplittingCurve : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDividedSurfaceFailures Class


BuiltInFailures.DividedSurfaceFailures.MeshTopologicalSortFailed Property

BuiltInFailuresDividedSurfaceFailuresMeshTopologicalSortFailed Property

Splitters and grids do not define a consistent rectangular mesh on the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MeshTopologicalSortFailed { get; }
Public Shared ReadOnly Property MeshTopologicalSortFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MeshTopologicalSortFailed {
    FailureDefinitionId^ get ();
}
static member MeshTopologicalSortFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDividedSurfaceFailures Class


BuiltInFailures.DocumentFailures Class

BuiltInFailuresDocumentFailures Class

Failures about DocumentFailures.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresDocumentFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class DocumentFailures
Public NotInheritable Class DocumentFailures
public ref class DocumentFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DocumentFailures = class end

The BuiltInFailuresDocumentFailures type exposes the following members.

Properties
Name | Description
ApiDelayedUpdateFailed | Delayed Updating Failed. Please contact the 3rd Party Application vendor.
CannotAutoUpdate | Coordination Monitor can't update element
CannotLoadLink | Can't load Linked File [Name] due to errors. Open it separately to investigate the problem.
DUExcessiveRegeneration | Third party updater '[Name]' has caused an infinite loop and its action had to be canceled.
DUMisbehavingUpdater | Third party updater '[Name]' has experienced a problem and its action had to be canceled.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DocumentFailures Properties

The BuiltInFailuresDocumentFailures type exposes the following members.

Properties
Name | Description
ApiDelayedUpdateFailed | Delayed Updating Failed. Please contact the 3rd Party Application vendor.
CannotAutoUpdate | Coordination Monitor can't update element
CannotLoadLink | Can't load Linked File [Name] due to errors. Open it separately to investigate the problem.
DUExcessiveRegeneration | Third party updater '[Name]' has caused an infinite loop and its action had to be canceled.
DUMisbehavingUpdater | Third party updater '[Name]' has experienced a problem and its action had to be canceled.
Top
See Also

Reference

BuiltInFailuresDocumentFailures Class


BuiltInFailures.DocumentFailures.ApiDelayedUpdateFailed Property

BuiltInFailuresDocumentFailuresApiDelayedUpdateFailed Property

Delayed Updating Failed. Please contact the 3rd Party Application vendor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ApiDelayedUpdateFailed { get; }
Public Shared ReadOnly Property ApiDelayedUpdateFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ApiDelayedUpdateFailed {
    FailureDefinitionId^ get ();
}
static member ApiDelayedUpdateFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDocumentFailures Class


BuiltInFailures.DocumentFailures.CannotAutoUpdate Property

BuiltInFailuresDocumentFailuresCannotAutoUpdate Property

Coordination Monitor can't update element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotAutoUpdate { get; }
Public Shared ReadOnly Property CannotAutoUpdate As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotAutoUpdate {
    FailureDefinitionId^ get ();
}
static member CannotAutoUpdate : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDocumentFailures Class


BuiltInFailures.DocumentFailures.CannotLoadLink Property

BuiltInFailuresDocumentFailuresCannotLoadLink Property

Can't load Linked File [Name] due to errors. Open it separately to investigate the problem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotLoadLink { get; }
Public Shared ReadOnly Property CannotLoadLink As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotLoadLink {
    FailureDefinitionId^ get ();
}
static member CannotLoadLink : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDocumentFailures Class


BuiltInFailures.DocumentFailures.DUExcessiveRegeneration Property

BuiltInFailuresDocumentFailuresDUExcessiveRegeneration Property

Third party updater '[Name]' has caused an infinite loop and its action had to be canceled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DUExcessiveRegeneration { get; }
Public Shared ReadOnly Property DUExcessiveRegeneration As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DUExcessiveRegeneration {
    FailureDefinitionId^ get ();
}
static member DUExcessiveRegeneration : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDocumentFailures Class


BuiltInFailures.DocumentFailures.DUMisbehavingUpdater Property

BuiltInFailuresDocumentFailuresDUMisbehavingUpdater Property

Third party updater '[Name]' has experienced a problem and its action had to be canceled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DUMisbehavingUpdater { get; }
Public Shared ReadOnly Property DUMisbehavingUpdater As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DUMisbehavingUpdater {
    FailureDefinitionId^ get ();
}
static member DUMisbehavingUpdater : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDocumentFailures Class


BuiltInFailures.DPartFailures Class

BuiltInFailuresDPartFailures Class

Failures related to parts.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresDPartFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class DPartFailures
Public NotInheritable Class DPartFailures
public ref class DPartFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DPartFailures = class end

The BuiltInFailuresDPartFailures type exposes the following members.

Properties
Name | Description
BindLinkWillDeleteAllPartsWarning | Bind Link will delete its associated Parts.
DeletingDPartWillDeleteAllPartsWarning | Deleting a Part will delete all associated Parts and the original Element will be made visible.
DeletingDPartWillDeleteMorePartsError | Deleting a Part will delete all associated Parts and the original Element will be made visible.
DeletingOriginalWillDeleteParts | Deletion of this element will delete its associated Parts.
DivideVolumesProfilesEdgeMatchForWidthAll | Division family cannot be used with the selected edge condition for all widths of hosts
DivideVolumesProfilesEdgeMatchForWidthSome | Division family cannot be used with the selected edge condition for some widths of hosts
DivideVolumesProfilesForWidthAll | Division family cannot be used for all widths of hosts
DivideVolumesProfilesForWidthSome | Division family cannot be used for some widths of hosts
DivideVolumesProfilesGapForWidthAll | Division family cannot be used with the selected division gap for all widths of hosts
DivideVolumesProfilesGapForWidthSome | Division family cannot be used with the selected division gap for some widths of hosts
DivideVolumesProfilesNonSlabSources | Some sources of a volume divider are non-slab like.
DivideVolumesSketchesWithProfileUnfriendlyCurves | Sketch contains curves to which profiles cannot be applied or chains of curves.
DivisionContainsNoParts | The division contains no parts.
DivisionContainsNoReferences | The division contains no dividing references.
ElementsAlreadyHaveParts | Some elements already have parts
IneligibleElementsForParts | Creating parts from ineligible elements
NoPartMakerCreatedInEditMode | Nothing will be divided.
PartPhaseParametersConflictWithOriginal | The creation and demolition phases of a part must lie between the corresponding phases of the original.
PartsCannotBeCreatedFromInvalidGeom | Post failure when attempts to create parts from invalid geometry.
RemovingInvalidDPartParents | Can't make Parts out of these Elements.
RemovingUndividedDPartParents | These parts are not intersected by any dividing references. They will be removed from the division.
SourceInUnloadedLink | Some elements already have parts
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DPartFailures Properties

The BuiltInFailuresDPartFailures type exposes the following members.

Properties
Name | Description
BindLinkWillDeleteAllPartsWarning | Bind Link will delete its associated Parts.
DeletingDPartWillDeleteAllPartsWarning | Deleting a Part will delete all associated Parts and the original Element will be made visible.
DeletingDPartWillDeleteMorePartsError | Deleting a Part will delete all associated Parts and the original Element will be made visible.
DeletingOriginalWillDeleteParts | Deletion of this element will delete its associated Parts.
DivideVolumesProfilesEdgeMatchForWidthAll | Division family cannot be used with the selected edge condition for all widths of hosts
DivideVolumesProfilesEdgeMatchForWidthSome | Division family cannot be used with the selected edge condition for some widths of hosts
DivideVolumesProfilesForWidthAll | Division family cannot be used for all widths of hosts
DivideVolumesProfilesForWidthSome | Division family cannot be used for some widths of hosts
DivideVolumesProfilesGapForWidthAll | Division family cannot be used with the selected division gap for all widths of hosts
DivideVolumesProfilesGapForWidthSome | Division family cannot be used with the selected division gap for some widths of hosts
DivideVolumesProfilesNonSlabSources | Some sources of a volume divider are non-slab like.
DivideVolumesSketchesWithProfileUnfriendlyCurves | Sketch contains curves to which profiles cannot be applied or chains of curves.
DivisionContainsNoParts | The division contains no parts.
DivisionContainsNoReferences | The division contains no dividing references.
ElementsAlreadyHaveParts | Some elements already have parts
IneligibleElementsForParts | Creating parts from ineligible elements
NoPartMakerCreatedInEditMode | Nothing will be divided.
PartPhaseParametersConflictWithOriginal | The creation and demolition phases of a part must lie between the corresponding phases of the original.
PartsCannotBeCreatedFromInvalidGeom | Post failure when attempts to create parts from invalid geometry.
RemovingInvalidDPartParents | Can't make Parts out of these Elements.
RemovingUndividedDPartParents | These parts are not intersected by any dividing references. They will be removed from the division.
SourceInUnloadedLink | Some elements already have parts
Top
See Also

Reference

BuiltInFailuresDPartFailures Class


BuiltInFailures.DPartFailures.BindLinkWillDeleteAllPartsWarning Property

BuiltInFailuresDPartFailuresBindLinkWillDeleteAllPartsWarning Property

Bind Link will delete its associated Parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BindLinkWillDeleteAllPartsWarning { get; }
Public Shared ReadOnly Property BindLinkWillDeleteAllPartsWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BindLinkWillDeleteAllPartsWarning {
    FailureDefinitionId^ get ();
}
static member BindLinkWillDeleteAllPartsWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDPartFailures Class


BuiltInFailures.DPartFailures.DeletingDPartWillDeleteAllPartsWarning Property

BuiltInFailuresDPartFailuresDeletingDPartWillDeleteAllPartsWarning Property

Deleting a Part will delete all associated Parts and the original Element will be made visible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DeletingDPartWillDeleteAllPartsWarning { get; }
Public Shared ReadOnly Property DeletingDPartWillDeleteAllPartsWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DeletingDPartWillDeleteAllPartsWarning {
    FailureDefinitionId^ get ();
}
static member DeletingDPartWillDeleteAllPartsWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDPartFailures Class


BuiltInFailures.DPartFailures.DeletingDPartWillDeleteMorePartsError Property

BuiltInFailuresDPartFailuresDeletingDPartWillDeleteMorePartsError Property

Deleting a Part will delete all associated Parts and the original Element will be made visible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DeletingDPartWillDeleteMorePartsError { get; }
Public Shared ReadOnly Property DeletingDPartWillDeleteMorePartsError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DeletingDPartWillDeleteMorePartsError {
    FailureDefinitionId^ get ();
}
static member DeletingDPartWillDeleteMorePartsError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDPartFailures Class


BuiltInFailures.DPartFailures.DeletingOriginalWillDeleteParts Property

BuiltInFailuresDPartFailuresDeletingOriginalWillDeleteParts Property

Deletion of this element will delete its associated Parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DeletingOriginalWillDeleteParts { get; }
Public Shared ReadOnly Property DeletingOriginalWillDeleteParts As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DeletingOriginalWillDeleteParts {
    FailureDefinitionId^ get ();
}
static member DeletingOriginalWillDeleteParts : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDPartFailures Class


BuiltInFailures.DPartFailures.DivideVolumesProfilesEdgeMatchForWidthAll Property

BuiltInFailuresDPartFailuresDivideVolumesProfilesEdgeMatchForWidthAll Property

Division family cannot be used with the selected edge condition for all widths of hosts

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DivideVolumesProfilesEdgeMatchForWidthAll { get; }
Public Shared ReadOnly Property DivideVolumesProfilesEdgeMatchForWidthAll As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DivideVolumesProfilesEdgeMatchForWidthAll {
    FailureDefinitionId^ get ();
}
static member DivideVolumesProfilesEdgeMatchForWidthAll : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDPartFailures Class


BuiltInFailures.DPartFailures.DivideVolumesProfilesEdgeMatchForWidthSome Property

BuiltInFailuresDPartFailuresDivideVolumesProfilesEdgeMatchForWidthSome Property

Division family cannot be used with the selected edge condition for some widths of hosts

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DivideVolumesProfilesEdgeMatchForWidthSome { get; }
Public Shared ReadOnly Property DivideVolumesProfilesEdgeMatchForWidthSome As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DivideVolumesProfilesEdgeMatchForWidthSome {
    FailureDefinitionId^ get ();
}
static member DivideVolumesProfilesEdgeMatchForWidthSome : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDPartFailures Class


BuiltInFailures.DPartFailures.DivideVolumesProfilesForWidthAll Property

BuiltInFailuresDPartFailuresDivideVolumesProfilesForWidthAll Property

Division family cannot be used for all widths of hosts

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DivideVolumesProfilesForWidthAll { get; }
Public Shared ReadOnly Property DivideVolumesProfilesForWidthAll As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DivideVolumesProfilesForWidthAll {
    FailureDefinitionId^ get ();
}
static member DivideVolumesProfilesForWidthAll : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDPartFailures Class


BuiltInFailures.DPartFailures.DivideVolumesProfilesForWidthSome Property

BuiltInFailuresDPartFailuresDivideVolumesProfilesForWidthSome Property

Division family cannot be used for some widths of hosts

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DivideVolumesProfilesForWidthSome { get; }
Public Shared ReadOnly Property DivideVolumesProfilesForWidthSome As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DivideVolumesProfilesForWidthSome {
    FailureDefinitionId^ get ();
}
static member DivideVolumesProfilesForWidthSome : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDPartFailures Class


BuiltInFailures.DPartFailures.DivideVolumesProfilesGapForWidthAll Property

BuiltInFailuresDPartFailuresDivideVolumesProfilesGapForWidthAll Property

Division family cannot be used with the selected division gap for all widths of hosts

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DivideVolumesProfilesGapForWidthAll { get; }
Public Shared ReadOnly Property DivideVolumesProfilesGapForWidthAll As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DivideVolumesProfilesGapForWidthAll {
    FailureDefinitionId^ get ();
}
static member DivideVolumesProfilesGapForWidthAll : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDPartFailures Class


BuiltInFailures.DPartFailures.DivideVolumesProfilesGapForWidthSome Property

BuiltInFailuresDPartFailuresDivideVolumesProfilesGapForWidthSome Property

Division family cannot be used with the selected division gap for some widths of hosts

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DivideVolumesProfilesGapForWidthSome { get; }
Public Shared ReadOnly Property DivideVolumesProfilesGapForWidthSome As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DivideVolumesProfilesGapForWidthSome {
    FailureDefinitionId^ get ();
}
static member DivideVolumesProfilesGapForWidthSome : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDPartFailures Class


BuiltInFailures.DPartFailures.DivideVolumesProfilesNonSlabSources Property

BuiltInFailuresDPartFailuresDivideVolumesProfilesNonSlabSources Property

Some sources of a volume divider are non-slab like.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DivideVolumesProfilesNonSlabSources { get; }
Public Shared ReadOnly Property DivideVolumesProfilesNonSlabSources As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DivideVolumesProfilesNonSlabSources {
    FailureDefinitionId^ get ();
}
static member DivideVolumesProfilesNonSlabSources : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDPartFailures Class


BuiltInFailures.DPartFailures.DivideVolumesSketchesWithProfileUnfriendlyCurves Property

BuiltInFailuresDPartFailuresDivideVolumesSketchesWithProfileUnfriendlyCurves Property

Sketch contains curves to which profiles cannot be applied or chains of curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DivideVolumesSketchesWithProfileUnfriendlyCurves { get; }
Public Shared ReadOnly Property DivideVolumesSketchesWithProfileUnfriendlyCurves As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DivideVolumesSketchesWithProfileUnfriendlyCurves {
    FailureDefinitionId^ get ();
}
static member DivideVolumesSketchesWithProfileUnfriendlyCurves : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDPartFailures Class


BuiltInFailures.DPartFailures.DivisionContainsNoParts Property

BuiltInFailuresDPartFailuresDivisionContainsNoParts Property

The division contains no parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DivisionContainsNoParts { get; }
Public Shared ReadOnly Property DivisionContainsNoParts As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DivisionContainsNoParts {
    FailureDefinitionId^ get ();
}
static member DivisionContainsNoParts : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDPartFailures Class


BuiltInFailures.DPartFailures.DivisionContainsNoReferences Property

BuiltInFailuresDPartFailuresDivisionContainsNoReferences Property

The division contains no dividing references.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DivisionContainsNoReferences { get; }
Public Shared ReadOnly Property DivisionContainsNoReferences As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DivisionContainsNoReferences {
    FailureDefinitionId^ get ();
}
static member DivisionContainsNoReferences : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDPartFailures Class


BuiltInFailures.DPartFailures.ElementsAlreadyHaveParts Property

BuiltInFailuresDPartFailuresElementsAlreadyHaveParts Property

Some elements already have parts

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ElementsAlreadyHaveParts { get; }
Public Shared ReadOnly Property ElementsAlreadyHaveParts As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ElementsAlreadyHaveParts {
    FailureDefinitionId^ get ();
}
static member ElementsAlreadyHaveParts : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDPartFailures Class


BuiltInFailures.DPartFailures.IneligibleElementsForParts Property

BuiltInFailuresDPartFailuresIneligibleElementsForParts Property

Creating parts from ineligible elements

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId IneligibleElementsForParts { get; }
Public Shared ReadOnly Property IneligibleElementsForParts As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ IneligibleElementsForParts {
    FailureDefinitionId^ get ();
}
static member IneligibleElementsForParts : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDPartFailures Class


BuiltInFailures.DPartFailures.NoPartMakerCreatedInEditMode Property

BuiltInFailuresDPartFailuresNoPartMakerCreatedInEditMode Property

Nothing will be divided.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoPartMakerCreatedInEditMode { get; }
Public Shared ReadOnly Property NoPartMakerCreatedInEditMode As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoPartMakerCreatedInEditMode {
    FailureDefinitionId^ get ();
}
static member NoPartMakerCreatedInEditMode : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDPartFailures Class


BuiltInFailures.DPartFailures.PartPhaseParametersConflictWithOriginal Property

BuiltInFailuresDPartFailuresPartPhaseParametersConflictWithOriginal Property

The creation and demolition phases of a part must lie between the corresponding phases of the original.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PartPhaseParametersConflictWithOriginal { get; }
Public Shared ReadOnly Property PartPhaseParametersConflictWithOriginal As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PartPhaseParametersConflictWithOriginal {
    FailureDefinitionId^ get ();
}
static member PartPhaseParametersConflictWithOriginal : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDPartFailures Class


BuiltInFailures.DPartFailures.PartsCannotBeCreatedFromInvalidGeom Property

BuiltInFailuresDPartFailuresPartsCannotBeCreatedFromInvalidGeom Property

Post failure when attempts to create parts from invalid geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PartsCannotBeCreatedFromInvalidGeom { get; }
Public Shared ReadOnly Property PartsCannotBeCreatedFromInvalidGeom As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PartsCannotBeCreatedFromInvalidGeom {
    FailureDefinitionId^ get ();
}
static member PartsCannotBeCreatedFromInvalidGeom : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDPartFailures Class


BuiltInFailures.DPartFailures.RemovingInvalidDPartParents Property

BuiltInFailuresDPartFailuresRemovingInvalidDPartParents Property

Can't make Parts out of these Elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RemovingInvalidDPartParents { get; }
Public Shared ReadOnly Property RemovingInvalidDPartParents As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RemovingInvalidDPartParents {
    FailureDefinitionId^ get ();
}
static member RemovingInvalidDPartParents : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDPartFailures Class


BuiltInFailures.DPartFailures.RemovingUndividedDPartParents Property

BuiltInFailuresDPartFailuresRemovingUndividedDPartParents Property

These parts are not intersected by any dividing references. They will be removed from the division.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RemovingUndividedDPartParents { get; }
Public Shared ReadOnly Property RemovingUndividedDPartParents As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RemovingUndividedDPartParents {
    FailureDefinitionId^ get ();
}
static member RemovingUndividedDPartParents : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDPartFailures Class


BuiltInFailures.DPartFailures.SourceInUnloadedLink Property

BuiltInFailuresDPartFailuresSourceInUnloadedLink Property

Some elements already have parts

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SourceInUnloadedLink { get; }
Public Shared ReadOnly Property SourceInUnloadedLink As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SourceInUnloadedLink {
    FailureDefinitionId^ get ();
}
static member SourceInUnloadedLink : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDPartFailures Class


BuiltInFailures.DuctFailures Class

BuiltInFailuresDuctFailures Class

Failures about Duct.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresDuctFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class DuctFailures
Public NotInheritable Class DuctFailures
public ref class DuctFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DuctFailures = class end

The BuiltInFailuresDuctFailures type exposes the following members.

Properties
Name | Description
CannotCreateGeometryForDuct | Cannot create geometry for flex duct. The flex duct is intersecting itself or the start and end are too close together.
FlexDuctLengthOutOfLimits | The flex duct length of [Length Value] exceeds the maximum specified length of [Maximum Flex Duct Length Value]
NoDuctFittingsInProject | There are no duct fittings defined in project. The default duct type for fittings will be set to none.
PartNotFoundDueToNoDuctConnectedError | "In order to find a matching part, the fitting has to be connected to a duct."
PartNotFoundDueToNoDuctConnectedWarning | "In order to find a matching part, the fitting has to be connected to a duct."
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DuctFailures Properties

The BuiltInFailuresDuctFailures type exposes the following members.

Properties
Name | Description
CannotCreateGeometryForDuct | Cannot create geometry for flex duct. The flex duct is intersecting itself or the start and end are too close together.
FlexDuctLengthOutOfLimits | The flex duct length of [Length Value] exceeds the maximum specified length of [Maximum Flex Duct Length Value]
NoDuctFittingsInProject | There are no duct fittings defined in project. The default duct type for fittings will be set to none.
PartNotFoundDueToNoDuctConnectedError | "In order to find a matching part, the fitting has to be connected to a duct."
PartNotFoundDueToNoDuctConnectedWarning | "In order to find a matching part, the fitting has to be connected to a duct."
Top
See Also

Reference

BuiltInFailuresDuctFailures Class


BuiltInFailures.DuctFailures.CannotCreateGeometryForDuct Property

BuiltInFailuresDuctFailuresCannotCreateGeometryForDuct Property

Cannot create geometry for flex duct. The flex duct is intersecting itself or the start and end are too close together.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateGeometryForDuct { get; }
Public Shared ReadOnly Property CannotCreateGeometryForDuct As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateGeometryForDuct {
    FailureDefinitionId^ get ();
}
static member CannotCreateGeometryForDuct : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDuctFailures Class


BuiltInFailures.DuctFailures.FlexDuctLengthOutOfLimits Property

BuiltInFailuresDuctFailuresFlexDuctLengthOutOfLimits Property

The flex duct length of [Length Value] exceeds the maximum specified length of [Maximum Flex Duct Length Value]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FlexDuctLengthOutOfLimits { get; }
Public Shared ReadOnly Property FlexDuctLengthOutOfLimits As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FlexDuctLengthOutOfLimits {
    FailureDefinitionId^ get ();
}
static member FlexDuctLengthOutOfLimits : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDuctFailures Class


BuiltInFailures.DuctFailures.NoDuctFittingsInProject Property

BuiltInFailuresDuctFailuresNoDuctFittingsInProject Property

There are no duct fittings defined in project. The default duct type for fittings will be set to none.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoDuctFittingsInProject { get; }
Public Shared ReadOnly Property NoDuctFittingsInProject As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoDuctFittingsInProject {
    FailureDefinitionId^ get ();
}
static member NoDuctFittingsInProject : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDuctFailures Class


BuiltInFailures.DuctFailures.PartNotFoundDueToNoDuctConnectedError Property

BuiltInFailuresDuctFailuresPartNotFoundDueToNoDuctConnectedError Property

"In order to find a matching part, the fitting has to be connected to a duct."

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PartNotFoundDueToNoDuctConnectedError { get; }
Public Shared ReadOnly Property PartNotFoundDueToNoDuctConnectedError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PartNotFoundDueToNoDuctConnectedError {
    FailureDefinitionId^ get ();
}
static member PartNotFoundDueToNoDuctConnectedError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDuctFailures Class


BuiltInFailures.DuctFailures.PartNotFoundDueToNoDuctConnectedWarning Property

BuiltInFailuresDuctFailuresPartNotFoundDueToNoDuctConnectedWarning Property

"In order to find a matching part, the fitting has to be connected to a duct."

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PartNotFoundDueToNoDuctConnectedWarning { get; }
Public Shared ReadOnly Property PartNotFoundDueToNoDuctConnectedWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PartNotFoundDueToNoDuctConnectedWarning {
    FailureDefinitionId^ get ();
}
static member PartNotFoundDueToNoDuctConnectedWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresDuctFailures Class


BuiltInFailures.EditingFailures Class

BuiltInFailuresEditingFailures Class

Failures related to editing operations.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresEditingFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class EditingFailures
Public NotInheritable Class EditingFailures
public ref class EditingFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type EditingFailures = class end

The BuiltInFailuresEditingFailures type exposes the following members.

Properties
Name | Description
AllInvisibleInPlanViewWarn | None of the created elements are visible in [View Type] View. You may want to check the active view, its Parameters, and Visibility settings, as well as any Plan Regions and their settings.
AllInvisibleInViewWarn | None of the created elements are visible in [View Type] View. You may want to check the active view, its Parameters, and Visibility settings.
BorrowElementsAtRisk | Can't obtain permission to edit the element: The Central Model is inaccessible. You can check out worksets at risk, but consider carefully!
CannotBorrowBusyContention | Can't obtain permission to edit the element. The Central Model is busy.
CannotCheckoutWorksets | Can't make workset editable. User '[Borrowers]' has already checked it out.
CannotDeleteEditedElement | Can't delete element that is being edited.
CannotDeleteEditedElementError | Can't delete element that is being edited.
CannotDeletePredefinedFamilyElement | Element is a built-in part of the family definition and cannot be deleted or added to groups.
CannotDrawInCurrentView | Can't draw because Work Plane is at a very sharp angle in this view. Go to another view or redefine the Work Plane.
CannotDuplicateType | Cannot Duplicate Type
CannotEditDeletedElements | Can't edit the element. It was deleted in the Central Model.
CannotEditDeletedWorkset | This action has caused deletion of non-editable Workset ' [Name] '.
CannotEditEditingElements | Can't obtain permission to edit the element: The Central Model is inaccessible and another user is editing the element.
CannotEditElements | Workset is editable, but you can't edit the element until '[Borrowers]' resaves the element to central and relinquishes it and you Reload Latest.
CannotEditRenamedWorkset | Can't edit workset ' [Name] '.
CannotMirrorInView | Must specify Work Plane to mirror in a 3d View.
CannotMoveElement | Can't move element.
CannotMoveElementWarn | Can't move element.
CannotMoveElementWithoutWorkplane | Element(s) need a workplane to be moved in. There's no workplane defined in this view.
CannotMoveHereInViewError | Can't move here at this view angle. Set another Work Plane or adjust the view.
CannotMoveInView | Can't move element because the move plane is seen at a very sharp angle in this View
CannotMoveInViewError | Can't move element because the move plane is seen at a very sharp angle in this View
CannotMoveLocked | Can't move pinned element.
CannotMoveTogether | Can't move these elements at the same time. One of them is restricted to moving in one direction while the other is restricted to moving in a conflicting direction.
CannotPickHereInCurrentView | Can't pick here at this view angle. Set another Work Plane or adjust the view.
CannotRotateLocked | Can't rotate pinned element.
CannotScaleInView | Can't scale because Move Plane is at a very sharp angle in this view. Change view angle or go to another view.
DeletedRequestedWarn | You have deleted elements that other users requested.
DeleteElementsError | [Description]
DeleteElementsWarn | [Description]
DeletePreventedByGroup | Grouped elements can only be deleted when the group is being edited. To delete a member select the group and then click the Edit Group button on the toolbar, then delete the member.
ElementNotEditable | One or more elements are not editable.
ElementReversed | Element is reversed.
ElementsDeleted | Elements were deleted.
ElementsDeletedPastedToKeep | Elements were deleted. Use Edit Pasted Elements to keep them.
ElementsNotInPlane | Elements don't lie on the same plane.
ElementsWillBeDeleted | Elements in [Design Option] will be deleted
ExtendToOtherCrash | Can't keep [Type Name] extended to [Type Name].
ExtendToOthersWarn | Can't keep [Type Name] extended to [Type Name].
ExtendToOtherWarn | Can't keep [Type Name] extended to [Type Name].
GeneratedByMassing | Selected element(s) produced from Massing shape. Once deleted, the selected element(s) will not be regenerated
HaveNoPermissionToEdit | You do not have permission to edit the element.
HiddenBeamsEditingWarning | The beam join being modified contains beam that are not visible. Geometry of visible beams may be affected by hidden beams.
InvalidArrayObject | Some or all of the selected objects can't be created in an Array (for example, a Camera object for a 3D View).
InvalidElemsInSelection | Can't scale elements together.
LockedDeleted | Pinned objects deleted.
LockedDeletedWarn | Pinned objects deleted.
MirrorProjectSuccess | [Action] command has successfully processed [Number] elements
NElementsDeleted | [Number] elements were deleted
NElementsWrongPosition | Review [Number] elements for correct position and shape
NoRotateMirrorZ | Element cannot be mirrored or rotated in a manner that changes its angle relative to the ground.
NoRotateMirrorZError | Element cannot be mirrored or rotated in a manner that changes its angle relative to the ground.
OutOfDateElements | Workset is editable, but you must Reload Latest before editing the element.
OwnedByOther | Can't edit the element until '[Partition Name]' resaves the element to central and relinquishes it and you Reload Latest.
OwnElementsOutOfDate | You now own the element, but your file is out of date. You must Reload Latest before editing the element.
PinnedObjectHostDeleted | Some pinned objects were deleted because their parent or host object was deleted.
PinnedObjectNotDeleted | Pinned objects were not deleted. To delete them, unpin them before using delete.
PinnedObjectSomeDeleted | Some pinned objects were deleted while others were not.
PlacementFailed | Failed to place component.
PressShowToSee | Press Show to see the element(s); then Ignore or Cancel
ReloadBeforeMakeEditable | You must Reload Latest before editing the element.
ReloadNoGood | You must Reload Latest before editing the element, but the Central Model is inaccessible or being accessed by another user.
RPCTurnOffInRealisticWarn | None of the placed RPC elements are visible when the visual style is set to Realistic. To see the elements, change VisualStyle of the current view, or change RPC visibility in Graphic Display Options.
SourceInEditMode | Can't transfer project standards while source document is in an edit mode. Please exit all edit modes(In-Place Family Edit Mode, Group Edit Mode, Sketch Edit Mode, etc.) and try again.
TargetInEditMode | Can't transfer project standards while target document is in an edit mode. Please exit all edit modes(In-Place Family Edit Mode, Group Edit Mode, Sketch Edit Mode, etc.) and try again.
TemporaryChangesOutOfDate | You must Reload Latest before editing the element. Changes will be temporary, and will not be saved.
TemporaryChangesTransparentPermissions | Permission to edit the element cannot be obtained. Changes will be temporary, and will not be saved.
TooManyElementsToCheckout | Too many elements were attempted to be marked as editable, prompt user to mark workset(s) editable instead
UnableFilletSpecifiedRadius | Unable to create Fillet with the specified radius.
UnableToMakeSourceWorksetEditable | Unable to make the necessary Workset ([Name]) editable in the Linked File in order to change the Shared Coordinates.
UnableToTransformElement | Attempted an invalid element rotate, mirror, or move.
UnableToTransformElementError | Attempted an invalid element rotate, mirror, or move.
WorksetHasChangedInCentralFile | This workset has changed in the Central Model. Please Reload Latest before making this workset editable.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


EditingFailures Properties

The BuiltInFailuresEditingFailures type exposes the following members.

Properties
Name | Description
AllInvisibleInPlanViewWarn | None of the created elements are visible in [View Type] View. You may want to check the active view, its Parameters, and Visibility settings, as well as any Plan Regions and their settings.
AllInvisibleInViewWarn | None of the created elements are visible in [View Type] View. You may want to check the active view, its Parameters, and Visibility settings.
BorrowElementsAtRisk | Can't obtain permission to edit the element: The Central Model is inaccessible. You can check out worksets at risk, but consider carefully!
CannotBorrowBusyContention | Can't obtain permission to edit the element. The Central Model is busy.
CannotCheckoutWorksets | Can't make workset editable. User '[Borrowers]' has already checked it out.
CannotDeleteEditedElement | Can't delete element that is being edited.
CannotDeleteEditedElementError | Can't delete element that is being edited.
CannotDeletePredefinedFamilyElement | Element is a built-in part of the family definition and cannot be deleted or added to groups.
CannotDrawInCurrentView | Can't draw because Work Plane is at a very sharp angle in this view. Go to another view or redefine the Work Plane.
CannotDuplicateType | Cannot Duplicate Type
CannotEditDeletedElements | Can't edit the element. It was deleted in the Central Model.
CannotEditDeletedWorkset | This action has caused deletion of non-editable Workset ' [Name] '.
CannotEditEditingElements | Can't obtain permission to edit the element: The Central Model is inaccessible and another user is editing the element.
CannotEditElements | Workset is editable, but you can't edit the element until '[Borrowers]' resaves the element to central and relinquishes it and you Reload Latest.
CannotEditRenamedWorkset | Can't edit workset ' [Name] '.
CannotMirrorInView | Must specify Work Plane to mirror in a 3d View.
CannotMoveElement | Can't move element.
CannotMoveElementWarn | Can't move element.
CannotMoveElementWithoutWorkplane | Element(s) need a workplane to be moved in. There's no workplane defined in this view.
CannotMoveHereInViewError | Can't move here at this view angle. Set another Work Plane or adjust the view.
CannotMoveInView | Can't move element because the move plane is seen at a very sharp angle in this View
CannotMoveInViewError | Can't move element because the move plane is seen at a very sharp angle in this View
CannotMoveLocked | Can't move pinned element.
CannotMoveTogether | Can't move these elements at the same time. One of them is restricted to moving in one direction while the other is restricted to moving in a conflicting direction.
CannotPickHereInCurrentView | Can't pick here at this view angle. Set another Work Plane or adjust the view.
CannotRotateLocked | Can't rotate pinned element.
CannotScaleInView | Can't scale because Move Plane is at a very sharp angle in this view. Change view angle or go to another view.
DeletedRequestedWarn | You have deleted elements that other users requested.
DeleteElementsError | [Description]
DeleteElementsWarn | [Description]
DeletePreventedByGroup | Grouped elements can only be deleted when the group is being edited. To delete a member select the group and then click the Edit Group button on the toolbar, then delete the member.
ElementNotEditable | One or more elements are not editable.
ElementReversed | Element is reversed.
ElementsDeleted | Elements were deleted.
ElementsDeletedPastedToKeep | Elements were deleted. Use Edit Pasted Elements to keep them.
ElementsNotInPlane | Elements don't lie on the same plane.
ElementsWillBeDeleted | Elements in [Design Option] will be deleted
ExtendToOtherCrash | Can't keep [Type Name] extended to [Type Name].
ExtendToOthersWarn | Can't keep [Type Name] extended to [Type Name].
ExtendToOtherWarn | Can't keep [Type Name] extended to [Type Name].
GeneratedByMassing | Selected element(s) produced from Massing shape. Once deleted, the selected element(s) will not be regenerated
HaveNoPermissionToEdit | You do not have permission to edit the element.
HiddenBeamsEditingWarning | The beam join being modified contains beam that are not visible. Geometry of visible beams may be affected by hidden beams.
InvalidArrayObject | Some or all of the selected objects can't be created in an Array (for example, a Camera object for a 3D View).
InvalidElemsInSelection | Can't scale elements together.
LockedDeleted | Pinned objects deleted.
LockedDeletedWarn | Pinned objects deleted.
MirrorProjectSuccess | [Action] command has successfully processed [Number] elements
NElementsDeleted | [Number] elements were deleted
NElementsWrongPosition | Review [Number] elements for correct position and shape
NoRotateMirrorZ | Element cannot be mirrored or rotated in a manner that changes its angle relative to the ground.
NoRotateMirrorZError | Element cannot be mirrored or rotated in a manner that changes its angle relative to the ground.
OutOfDateElements | Workset is editable, but you must Reload Latest before editing the element.
OwnedByOther | Can't edit the element until '[Partition Name]' resaves the element to central and relinquishes it and you Reload Latest.
OwnElementsOutOfDate | You now own the element, but your file is out of date. You must Reload Latest before editing the element.
PinnedObjectHostDeleted | Some pinned objects were deleted because their parent or host object was deleted.
PinnedObjectNotDeleted | Pinned objects were not deleted. To delete them, unpin them before using delete.
PinnedObjectSomeDeleted | Some pinned objects were deleted while others were not.
PlacementFailed | Failed to place component.
PressShowToSee | Press Show to see the element(s); then Ignore or Cancel
ReloadBeforeMakeEditable | You must Reload Latest before editing the element.
ReloadNoGood | You must Reload Latest before editing the element, but the Central Model is inaccessible or being accessed by another user.
RPCTurnOffInRealisticWarn | None of the placed RPC elements are visible when the visual style is set to Realistic. To see the elements, change VisualStyle of the current view, or change RPC visibility in Graphic Display Options.
SourceInEditMode | Can't transfer project standards while source document is in an edit mode. Please exit all edit modes(In-Place Family Edit Mode, Group Edit Mode, Sketch Edit Mode, etc.) and try again.
TargetInEditMode | Can't transfer project standards while target document is in an edit mode. Please exit all edit modes(In-Place Family Edit Mode, Group Edit Mode, Sketch Edit Mode, etc.) and try again.
TemporaryChangesOutOfDate | You must Reload Latest before editing the element. Changes will be temporary, and will not be saved.
TemporaryChangesTransparentPermissions | Permission to edit the element cannot be obtained. Changes will be temporary, and will not be saved.
TooManyElementsToCheckout | Too many elements were attempted to be marked as editable, prompt user to mark workset(s) editable instead
UnableFilletSpecifiedRadius | Unable to create Fillet with the specified radius.
UnableToMakeSourceWorksetEditable | Unable to make the necessary Workset ([Name]) editable in the Linked File in order to change the Shared Coordinates.
UnableToTransformElement | Attempted an invalid element rotate, mirror, or move.
UnableToTransformElementError | Attempted an invalid element rotate, mirror, or move.
WorksetHasChangedInCentralFile | This workset has changed in the Central Model. Please Reload Latest before making this workset editable.
Top
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.AllInvisibleInPlanViewWarn Property

BuiltInFailuresEditingFailuresAllInvisibleInPlanViewWarn Property

None of the created elements are visible in [View Type] View. You may want to check the active view, its Parameters, and Visibility settings, as well as any Plan Regions and their settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AllInvisibleInPlanViewWarn { get; }
Public Shared ReadOnly Property AllInvisibleInPlanViewWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AllInvisibleInPlanViewWarn {
    FailureDefinitionId^ get ();
}
static member AllInvisibleInPlanViewWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.AllInvisibleInViewWarn Property

BuiltInFailuresEditingFailuresAllInvisibleInViewWarn Property

None of the created elements are visible in [View Type] View. You may want to check the active view, its Parameters, and Visibility settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AllInvisibleInViewWarn { get; }
Public Shared ReadOnly Property AllInvisibleInViewWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AllInvisibleInViewWarn {
    FailureDefinitionId^ get ();
}
static member AllInvisibleInViewWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.BorrowElementsAtRisk Property

BuiltInFailuresEditingFailuresBorrowElementsAtRisk Property

Can't obtain permission to edit the element: The Central Model is inaccessible. You can check out worksets at risk, but consider carefully!

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BorrowElementsAtRisk { get; }
Public Shared ReadOnly Property BorrowElementsAtRisk As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BorrowElementsAtRisk {
    FailureDefinitionId^ get ();
}
static member BorrowElementsAtRisk : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.CannotBorrowBusyContention Property

BuiltInFailuresEditingFailuresCannotBorrowBusyContention Property

Can't obtain permission to edit the element. The Central Model is busy.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotBorrowBusyContention { get; }
Public Shared ReadOnly Property CannotBorrowBusyContention As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotBorrowBusyContention {
    FailureDefinitionId^ get ();
}
static member CannotBorrowBusyContention : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.CannotCheckoutWorksets Property

BuiltInFailuresEditingFailuresCannotCheckoutWorksets Property

Can't make workset editable. User '[Borrowers]' has already checked it out.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCheckoutWorksets { get; }
Public Shared ReadOnly Property CannotCheckoutWorksets As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCheckoutWorksets {
    FailureDefinitionId^ get ();
}
static member CannotCheckoutWorksets : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.CannotDeleteEditedElement Property

BuiltInFailuresEditingFailuresCannotDeleteEditedElement Property

Can't delete element that is being edited.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotDeleteEditedElement { get; }
Public Shared ReadOnly Property CannotDeleteEditedElement As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotDeleteEditedElement {
    FailureDefinitionId^ get ();
}
static member CannotDeleteEditedElement : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.CannotDeleteEditedElementError Property

BuiltInFailuresEditingFailuresCannotDeleteEditedElementError Property

Can't delete element that is being edited.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotDeleteEditedElementError { get; }
Public Shared ReadOnly Property CannotDeleteEditedElementError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotDeleteEditedElementError {
    FailureDefinitionId^ get ();
}
static member CannotDeleteEditedElementError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.CannotDeletePredefinedFamilyElement Property

BuiltInFailuresEditingFailuresCannotDeletePredefinedFamilyElement Property

Element is a built-in part of the family definition and cannot be deleted or added to groups.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotDeletePredefinedFamilyElement { get; }
Public Shared ReadOnly Property CannotDeletePredefinedFamilyElement As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotDeletePredefinedFamilyElement {
    FailureDefinitionId^ get ();
}
static member CannotDeletePredefinedFamilyElement : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.CannotDrawInCurrentView Property

BuiltInFailuresEditingFailuresCannotDrawInCurrentView Property

Can't draw because Work Plane is at a very sharp angle in this view. Go to another view or redefine the Work Plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotDrawInCurrentView { get; }
Public Shared ReadOnly Property CannotDrawInCurrentView As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotDrawInCurrentView {
    FailureDefinitionId^ get ();
}
static member CannotDrawInCurrentView : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.CannotDuplicateType Property

BuiltInFailuresEditingFailuresCannotDuplicateType Property

Cannot Duplicate Type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotDuplicateType { get; }
Public Shared ReadOnly Property CannotDuplicateType As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotDuplicateType {
    FailureDefinitionId^ get ();
}
static member CannotDuplicateType : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.CannotEditDeletedElements Property

BuiltInFailuresEditingFailuresCannotEditDeletedElements Property

Can't edit the element. It was deleted in the Central Model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotEditDeletedElements { get; }
Public Shared ReadOnly Property CannotEditDeletedElements As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotEditDeletedElements {
    FailureDefinitionId^ get ();
}
static member CannotEditDeletedElements : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.CannotEditDeletedWorkset Property

BuiltInFailuresEditingFailuresCannotEditDeletedWorkset Property

This action has caused deletion of non-editable Workset ' [Name] '.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotEditDeletedWorkset { get; }
Public Shared ReadOnly Property CannotEditDeletedWorkset As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotEditDeletedWorkset {
    FailureDefinitionId^ get ();
}
static member CannotEditDeletedWorkset : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.CannotEditEditingElements Property

BuiltInFailuresEditingFailuresCannotEditEditingElements Property

Can't obtain permission to edit the element: The Central Model is inaccessible and another user is editing the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotEditEditingElements { get; }
Public Shared ReadOnly Property CannotEditEditingElements As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotEditEditingElements {
    FailureDefinitionId^ get ();
}
static member CannotEditEditingElements : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.CannotEditElements Property

BuiltInFailuresEditingFailuresCannotEditElements Property

Workset is editable, but you can't edit the element until '[Borrowers]' resaves the element to central and relinquishes it and you Reload Latest.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotEditElements { get; }
Public Shared ReadOnly Property CannotEditElements As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotEditElements {
    FailureDefinitionId^ get ();
}
static member CannotEditElements : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.CannotEditRenamedWorkset Property

BuiltInFailuresEditingFailuresCannotEditRenamedWorkset Property

Can't edit workset ' [Name] '.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotEditRenamedWorkset { get; }
Public Shared ReadOnly Property CannotEditRenamedWorkset As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotEditRenamedWorkset {
    FailureDefinitionId^ get ();
}
static member CannotEditRenamedWorkset : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.CannotMirrorInView Property

BuiltInFailuresEditingFailuresCannotMirrorInView Property

Must specify Work Plane to mirror in a 3d View.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotMirrorInView { get; }
Public Shared ReadOnly Property CannotMirrorInView As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotMirrorInView {
    FailureDefinitionId^ get ();
}
static member CannotMirrorInView : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.CannotMoveElement Property

BuiltInFailuresEditingFailuresCannotMoveElement Property

Can't move element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotMoveElement { get; }
Public Shared ReadOnly Property CannotMoveElement As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotMoveElement {
    FailureDefinitionId^ get ();
}
static member CannotMoveElement : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.CannotMoveElementWarn Property

BuiltInFailuresEditingFailuresCannotMoveElementWarn Property

Can't move element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotMoveElementWarn { get; }
Public Shared ReadOnly Property CannotMoveElementWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotMoveElementWarn {
    FailureDefinitionId^ get ();
}
static member CannotMoveElementWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.CannotMoveElementWithoutWorkplane Property

BuiltInFailuresEditingFailuresCannotMoveElementWithoutWorkplane Property

Element(s) need a workplane to be moved in. There's no workplane defined in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotMoveElementWithoutWorkplane { get; }
Public Shared ReadOnly Property CannotMoveElementWithoutWorkplane As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotMoveElementWithoutWorkplane {
    FailureDefinitionId^ get ();
}
static member CannotMoveElementWithoutWorkplane : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.CannotMoveHereInViewError Property

BuiltInFailuresEditingFailuresCannotMoveHereInViewError Property

Can't move here at this view angle. Set another Work Plane or adjust the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotMoveHereInViewError { get; }
Public Shared ReadOnly Property CannotMoveHereInViewError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotMoveHereInViewError {
    FailureDefinitionId^ get ();
}
static member CannotMoveHereInViewError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.CannotMoveInView Property

BuiltInFailuresEditingFailuresCannotMoveInView Property

Can't move element because the move plane is seen at a very sharp angle in this View

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotMoveInView { get; }
Public Shared ReadOnly Property CannotMoveInView As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotMoveInView {
    FailureDefinitionId^ get ();
}
static member CannotMoveInView : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.CannotMoveInViewError Property

BuiltInFailuresEditingFailuresCannotMoveInViewError Property

Can't move element because the move plane is seen at a very sharp angle in this View

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotMoveInViewError { get; }
Public Shared ReadOnly Property CannotMoveInViewError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotMoveInViewError {
    FailureDefinitionId^ get ();
}
static member CannotMoveInViewError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.CannotMoveLocked Property

BuiltInFailuresEditingFailuresCannotMoveLocked Property

Can't move pinned element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotMoveLocked { get; }
Public Shared ReadOnly Property CannotMoveLocked As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotMoveLocked {
    FailureDefinitionId^ get ();
}
static member CannotMoveLocked : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.CannotMoveTogether Property

BuiltInFailuresEditingFailuresCannotMoveTogether Property

Can't move these elements at the same time. One of them is restricted to moving in one direction while the other is restricted to moving in a conflicting direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotMoveTogether { get; }
Public Shared ReadOnly Property CannotMoveTogether As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotMoveTogether {
    FailureDefinitionId^ get ();
}
static member CannotMoveTogether : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.CannotPickHereInCurrentView Property

BuiltInFailuresEditingFailuresCannotPickHereInCurrentView Property

Can't pick here at this view angle. Set another Work Plane or adjust the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPickHereInCurrentView { get; }
Public Shared ReadOnly Property CannotPickHereInCurrentView As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPickHereInCurrentView {
    FailureDefinitionId^ get ();
}
static member CannotPickHereInCurrentView : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.CannotRotateLocked Property

BuiltInFailuresEditingFailuresCannotRotateLocked Property

Can't rotate pinned element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotRotateLocked { get; }
Public Shared ReadOnly Property CannotRotateLocked As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotRotateLocked {
    FailureDefinitionId^ get ();
}
static member CannotRotateLocked : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.CannotScaleInView Property

BuiltInFailuresEditingFailuresCannotScaleInView Property

Can't scale because Move Plane is at a very sharp angle in this view. Change view angle or go to another view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotScaleInView { get; }
Public Shared ReadOnly Property CannotScaleInView As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotScaleInView {
    FailureDefinitionId^ get ();
}
static member CannotScaleInView : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.DeletedRequestedWarn Property

BuiltInFailuresEditingFailuresDeletedRequestedWarn Property

You have deleted elements that other users requested.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DeletedRequestedWarn { get; }
Public Shared ReadOnly Property DeletedRequestedWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DeletedRequestedWarn {
    FailureDefinitionId^ get ();
}
static member DeletedRequestedWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.DeleteElementsError Property

BuiltInFailuresEditingFailuresDeleteElementsError Property

[Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DeleteElementsError { get; }
Public Shared ReadOnly Property DeleteElementsError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DeleteElementsError {
    FailureDefinitionId^ get ();
}
static member DeleteElementsError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.DeleteElementsWarn Property

BuiltInFailuresEditingFailuresDeleteElementsWarn Property

[Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DeleteElementsWarn { get; }
Public Shared ReadOnly Property DeleteElementsWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DeleteElementsWarn {
    FailureDefinitionId^ get ();
}
static member DeleteElementsWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.DeletePreventedByGroup Property

BuiltInFailuresEditingFailuresDeletePreventedByGroup Property

Grouped elements can only be deleted when the group is being edited. To delete a member select the group and then click the Edit Group button on the toolbar, then delete the member.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DeletePreventedByGroup { get; }
Public Shared ReadOnly Property DeletePreventedByGroup As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DeletePreventedByGroup {
    FailureDefinitionId^ get ();
}
static member DeletePreventedByGroup : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.ElementNotEditable Property

BuiltInFailuresEditingFailuresElementNotEditable Property

One or more elements are not editable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ElementNotEditable { get; }
Public Shared ReadOnly Property ElementNotEditable As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ElementNotEditable {
    FailureDefinitionId^ get ();
}
static member ElementNotEditable : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.ElementReversed Property

BuiltInFailuresEditingFailuresElementReversed Property

Element is reversed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ElementReversed { get; }
Public Shared ReadOnly Property ElementReversed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ElementReversed {
    FailureDefinitionId^ get ();
}
static member ElementReversed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.ElementsDeleted Property

BuiltInFailuresEditingFailuresElementsDeleted Property

Elements were deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ElementsDeleted { get; }
Public Shared ReadOnly Property ElementsDeleted As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ElementsDeleted {
    FailureDefinitionId^ get ();
}
static member ElementsDeleted : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.ElementsDeletedPastedToKeep Property

BuiltInFailuresEditingFailuresElementsDeletedPastedToKeep Property

Elements were deleted. Use Edit Pasted Elements to keep them.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ElementsDeletedPastedToKeep { get; }
Public Shared ReadOnly Property ElementsDeletedPastedToKeep As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ElementsDeletedPastedToKeep {
    FailureDefinitionId^ get ();
}
static member ElementsDeletedPastedToKeep : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.ElementsNotInPlane Property

BuiltInFailuresEditingFailuresElementsNotInPlane Property

Elements don't lie on the same plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ElementsNotInPlane { get; }
Public Shared ReadOnly Property ElementsNotInPlane As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ElementsNotInPlane {
    FailureDefinitionId^ get ();
}
static member ElementsNotInPlane : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.ElementsWillBeDeleted Property

BuiltInFailuresEditingFailuresElementsWillBeDeleted Property

Elements in [Design Option] will be deleted

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ElementsWillBeDeleted { get; }
Public Shared ReadOnly Property ElementsWillBeDeleted As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ElementsWillBeDeleted {
    FailureDefinitionId^ get ();
}
static member ElementsWillBeDeleted : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.ExtendToOtherCrash Property

BuiltInFailuresEditingFailuresExtendToOtherCrash Property

Can't keep [Type Name] extended to [Type Name].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ExtendToOtherCrash { get; }
Public Shared ReadOnly Property ExtendToOtherCrash As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ExtendToOtherCrash {
    FailureDefinitionId^ get ();
}
static member ExtendToOtherCrash : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.ExtendToOthersWarn Property

BuiltInFailuresEditingFailuresExtendToOthersWarn Property

Can't keep [Type Name] extended to [Type Name].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ExtendToOthersWarn { get; }
Public Shared ReadOnly Property ExtendToOthersWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ExtendToOthersWarn {
    FailureDefinitionId^ get ();
}
static member ExtendToOthersWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.ExtendToOtherWarn Property

BuiltInFailuresEditingFailuresExtendToOtherWarn Property

Can't keep [Type Name] extended to [Type Name].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ExtendToOtherWarn { get; }
Public Shared ReadOnly Property ExtendToOtherWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ExtendToOtherWarn {
    FailureDefinitionId^ get ();
}
static member ExtendToOtherWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.GeneratedByMassing Property

BuiltInFailuresEditingFailuresGeneratedByMassing Property

Selected element(s) produced from Massing shape. Once deleted, the selected element(s) will not be regenerated

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId GeneratedByMassing { get; }
Public Shared ReadOnly Property GeneratedByMassing As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ GeneratedByMassing {
    FailureDefinitionId^ get ();
}
static member GeneratedByMassing : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.HaveNoPermissionToEdit Property

BuiltInFailuresEditingFailuresHaveNoPermissionToEdit Property

You do not have permission to edit the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId HaveNoPermissionToEdit { get; }
Public Shared ReadOnly Property HaveNoPermissionToEdit As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ HaveNoPermissionToEdit {
    FailureDefinitionId^ get ();
}
static member HaveNoPermissionToEdit : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.HiddenBeamsEditingWarning Property

BuiltInFailuresEditingFailuresHiddenBeamsEditingWarning Property

The beam join being modified contains beam that are not visible. Geometry of visible beams may be affected by hidden beams.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId HiddenBeamsEditingWarning { get; }
Public Shared ReadOnly Property HiddenBeamsEditingWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ HiddenBeamsEditingWarning {
    FailureDefinitionId^ get ();
}
static member HiddenBeamsEditingWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.InvalidArrayObject Property

BuiltInFailuresEditingFailuresInvalidArrayObject Property

Some or all of the selected objects can't be created in an Array (for example, a Camera object for a 3D View).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidArrayObject { get; }
Public Shared ReadOnly Property InvalidArrayObject As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidArrayObject {
    FailureDefinitionId^ get ();
}
static member InvalidArrayObject : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.InvalidElemsInSelection Property

BuiltInFailuresEditingFailuresInvalidElemsInSelection Property

Can't scale elements together.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidElemsInSelection { get; }
Public Shared ReadOnly Property InvalidElemsInSelection As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidElemsInSelection {
    FailureDefinitionId^ get ();
}
static member InvalidElemsInSelection : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.LockedDeleted Property

BuiltInFailuresEditingFailuresLockedDeleted Property

Pinned objects deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LockedDeleted { get; }
Public Shared ReadOnly Property LockedDeleted As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LockedDeleted {
    FailureDefinitionId^ get ();
}
static member LockedDeleted : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.LockedDeletedWarn Property

BuiltInFailuresEditingFailuresLockedDeletedWarn Property

Pinned objects deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LockedDeletedWarn { get; }
Public Shared ReadOnly Property LockedDeletedWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LockedDeletedWarn {
    FailureDefinitionId^ get ();
}
static member LockedDeletedWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.MirrorProjectSuccess Property

BuiltInFailuresEditingFailuresMirrorProjectSuccess Property

[Action] command has successfully processed [Number] elements

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MirrorProjectSuccess { get; }
Public Shared ReadOnly Property MirrorProjectSuccess As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MirrorProjectSuccess {
    FailureDefinitionId^ get ();
}
static member MirrorProjectSuccess : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.NElementsDeleted Property

BuiltInFailuresEditingFailuresNElementsDeleted Property

[Number] elements were deleted

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NElementsDeleted { get; }
Public Shared ReadOnly Property NElementsDeleted As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NElementsDeleted {
    FailureDefinitionId^ get ();
}
static member NElementsDeleted : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.NElementsWrongPosition Property

BuiltInFailuresEditingFailuresNElementsWrongPosition Property

Review [Number] elements for correct position and shape

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NElementsWrongPosition { get; }
Public Shared ReadOnly Property NElementsWrongPosition As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NElementsWrongPosition {
    FailureDefinitionId^ get ();
}
static member NElementsWrongPosition : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.NoRotateMirrorZ Property

BuiltInFailuresEditingFailuresNoRotateMirrorZ Property

Element cannot be mirrored or rotated in a manner that changes its angle relative to the ground.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoRotateMirrorZ { get; }
Public Shared ReadOnly Property NoRotateMirrorZ As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoRotateMirrorZ {
    FailureDefinitionId^ get ();
}
static member NoRotateMirrorZ : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.NoRotateMirrorZError Property

BuiltInFailuresEditingFailuresNoRotateMirrorZError Property

Element cannot be mirrored or rotated in a manner that changes its angle relative to the ground.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoRotateMirrorZError { get; }
Public Shared ReadOnly Property NoRotateMirrorZError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoRotateMirrorZError {
    FailureDefinitionId^ get ();
}
static member NoRotateMirrorZError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.OutOfDateElements Property

BuiltInFailuresEditingFailuresOutOfDateElements Property

Workset is editable, but you must Reload Latest before editing the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId OutOfDateElements { get; }
Public Shared ReadOnly Property OutOfDateElements As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ OutOfDateElements {
    FailureDefinitionId^ get ();
}
static member OutOfDateElements : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.OwnedByOther Property

BuiltInFailuresEditingFailuresOwnedByOther Property

Can't edit the element until '[Partition Name]' resaves the element to central and relinquishes it and you Reload Latest.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId OwnedByOther { get; }
Public Shared ReadOnly Property OwnedByOther As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ OwnedByOther {
    FailureDefinitionId^ get ();
}
static member OwnedByOther : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.OwnElementsOutOfDate Property

BuiltInFailuresEditingFailuresOwnElementsOutOfDate Property

You now own the element, but your file is out of date. You must Reload Latest before editing the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId OwnElementsOutOfDate { get; }
Public Shared ReadOnly Property OwnElementsOutOfDate As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ OwnElementsOutOfDate {
    FailureDefinitionId^ get ();
}
static member OwnElementsOutOfDate : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.PinnedObjectHostDeleted Property

BuiltInFailuresEditingFailuresPinnedObjectHostDeleted Property

Some pinned objects were deleted because their parent or host object was deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PinnedObjectHostDeleted { get; }
Public Shared ReadOnly Property PinnedObjectHostDeleted As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PinnedObjectHostDeleted {
    FailureDefinitionId^ get ();
}
static member PinnedObjectHostDeleted : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.PinnedObjectNotDeleted Property

BuiltInFailuresEditingFailuresPinnedObjectNotDeleted Property

Pinned objects were not deleted. To delete them, unpin them before using delete.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PinnedObjectNotDeleted { get; }
Public Shared ReadOnly Property PinnedObjectNotDeleted As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PinnedObjectNotDeleted {
    FailureDefinitionId^ get ();
}
static member PinnedObjectNotDeleted : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.PinnedObjectSomeDeleted Property

BuiltInFailuresEditingFailuresPinnedObjectSomeDeleted Property

Some pinned objects were deleted while others were not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PinnedObjectSomeDeleted { get; }
Public Shared ReadOnly Property PinnedObjectSomeDeleted As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PinnedObjectSomeDeleted {
    FailureDefinitionId^ get ();
}
static member PinnedObjectSomeDeleted : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.PlacementFailed Property

BuiltInFailuresEditingFailuresPlacementFailed Property

Failed to place component.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PlacementFailed { get; }
Public Shared ReadOnly Property PlacementFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PlacementFailed {
    FailureDefinitionId^ get ();
}
static member PlacementFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.PressShowToSee Property

BuiltInFailuresEditingFailuresPressShowToSee Property

Press Show to see the element(s); then Ignore or Cancel

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PressShowToSee { get; }
Public Shared ReadOnly Property PressShowToSee As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PressShowToSee {
    FailureDefinitionId^ get ();
}
static member PressShowToSee : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.ReloadBeforeMakeEditable Property

BuiltInFailuresEditingFailuresReloadBeforeMakeEditable Property

You must Reload Latest before editing the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ReloadBeforeMakeEditable { get; }
Public Shared ReadOnly Property ReloadBeforeMakeEditable As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ReloadBeforeMakeEditable {
    FailureDefinitionId^ get ();
}
static member ReloadBeforeMakeEditable : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.ReloadNoGood Property

BuiltInFailuresEditingFailuresReloadNoGood Property

You must Reload Latest before editing the element, but the Central Model is inaccessible or being accessed by another user.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ReloadNoGood { get; }
Public Shared ReadOnly Property ReloadNoGood As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ReloadNoGood {
    FailureDefinitionId^ get ();
}
static member ReloadNoGood : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.RPCTurnOffInRealisticWarn Property

BuiltInFailuresEditingFailuresRPCTurnOffInRealisticWarn Property

None of the placed RPC elements are visible when the visual style is set to Realistic. To see the elements, change VisualStyle of the current view, or change RPC visibility in Graphic Display Options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RPCTurnOffInRealisticWarn { get; }
Public Shared ReadOnly Property RPCTurnOffInRealisticWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RPCTurnOffInRealisticWarn {
    FailureDefinitionId^ get ();
}
static member RPCTurnOffInRealisticWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.SourceInEditMode Property

BuiltInFailuresEditingFailuresSourceInEditMode Property

Can't transfer project standards while source document is in an edit mode. Please exit all edit modes(In-Place Family Edit Mode, Group Edit Mode, Sketch Edit Mode, etc.) and try again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SourceInEditMode { get; }
Public Shared ReadOnly Property SourceInEditMode As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SourceInEditMode {
    FailureDefinitionId^ get ();
}
static member SourceInEditMode : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.TargetInEditMode Property

BuiltInFailuresEditingFailuresTargetInEditMode Property

Can't transfer project standards while target document is in an edit mode. Please exit all edit modes(In-Place Family Edit Mode, Group Edit Mode, Sketch Edit Mode, etc.) and try again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TargetInEditMode { get; }
Public Shared ReadOnly Property TargetInEditMode As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TargetInEditMode {
    FailureDefinitionId^ get ();
}
static member TargetInEditMode : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.TemporaryChangesOutOfDate Property

BuiltInFailuresEditingFailuresTemporaryChangesOutOfDate Property

You must Reload Latest before editing the element. Changes will be temporary, and will not be saved.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TemporaryChangesOutOfDate { get; }
Public Shared ReadOnly Property TemporaryChangesOutOfDate As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TemporaryChangesOutOfDate {
    FailureDefinitionId^ get ();
}
static member TemporaryChangesOutOfDate : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.TemporaryChangesTransparentPermissions Property

BuiltInFailuresEditingFailuresTemporaryChangesTransparentPermissions Property

Permission to edit the element cannot be obtained. Changes will be temporary, and will not be saved.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TemporaryChangesTransparentPermissions { get; }
Public Shared ReadOnly Property TemporaryChangesTransparentPermissions As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TemporaryChangesTransparentPermissions {
    FailureDefinitionId^ get ();
}
static member TemporaryChangesTransparentPermissions : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.TooManyElementsToCheckout Property

BuiltInFailuresEditingFailuresTooManyElementsToCheckout Property

Too many elements were attempted to be marked as editable, prompt user to mark workset(s) editable instead

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TooManyElementsToCheckout { get; }
Public Shared ReadOnly Property TooManyElementsToCheckout As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TooManyElementsToCheckout {
    FailureDefinitionId^ get ();
}
static member TooManyElementsToCheckout : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.UnableFilletSpecifiedRadius Property

BuiltInFailuresEditingFailuresUnableFilletSpecifiedRadius Property

Unable to create Fillet with the specified radius.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnableFilletSpecifiedRadius { get; }
Public Shared ReadOnly Property UnableFilletSpecifiedRadius As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnableFilletSpecifiedRadius {
    FailureDefinitionId^ get ();
}
static member UnableFilletSpecifiedRadius : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.UnableToMakeSourceWorksetEditable Property

BuiltInFailuresEditingFailuresUnableToMakeSourceWorksetEditable Property

Unable to make the necessary Workset ([Name]) editable in the Linked File in order to change the Shared Coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnableToMakeSourceWorksetEditable { get; }
Public Shared ReadOnly Property UnableToMakeSourceWorksetEditable As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnableToMakeSourceWorksetEditable {
    FailureDefinitionId^ get ();
}
static member UnableToMakeSourceWorksetEditable : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.UnableToTransformElement Property

BuiltInFailuresEditingFailuresUnableToTransformElement Property

Attempted an invalid element rotate, mirror, or move.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnableToTransformElement { get; }
Public Shared ReadOnly Property UnableToTransformElement As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnableToTransformElement {
    FailureDefinitionId^ get ();
}
static member UnableToTransformElement : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.UnableToTransformElementError Property

BuiltInFailuresEditingFailuresUnableToTransformElementError Property

Attempted an invalid element rotate, mirror, or move.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnableToTransformElementError { get; }
Public Shared ReadOnly Property UnableToTransformElementError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnableToTransformElementError {
    FailureDefinitionId^ get ();
}
static member UnableToTransformElementError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.EditingFailures.WorksetHasChangedInCentralFile Property

BuiltInFailuresEditingFailuresWorksetHasChangedInCentralFile Property

This workset has changed in the Central Model. Please Reload Latest before making this workset editable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WorksetHasChangedInCentralFile { get; }
Public Shared ReadOnly Property WorksetHasChangedInCentralFile As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WorksetHasChangedInCentralFile {
    FailureDefinitionId^ get ();
}
static member WorksetHasChangedInCentralFile : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEditingFailures Class


BuiltInFailures.ElectricalFailures Class

BuiltInFailuresElectricalFailures Class

Failures about Electricity.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresElectricalFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ElectricalFailures
Public NotInheritable Class ElectricalFailures
public ref class ElectricalFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ElectricalFailures = class end

The BuiltInFailuresElectricalFailures type exposes the following members.

Properties
Name | Description
AllSlotsOnPanelOccupied | All slots on panel: [Panel Name] are occupied. Some circuits will be disconnected from this panel.
BankDistanceSmallerThanDiameter | The distance value is smaller than the conduit diameter, please enter a larger value
CableTrayModified | The cable tray has been modified to be in the opposite direction or insufficient space to create the required fittings.
CannotAddMorePolesToCircuit | Empty slots are unavailable to hold the number of poles you specified for this spare. \nTo add more poles to this spare, you must free up slots by moving the circuits below the spare.
CannotAssignSecondaryDistSysToCircuit | Cannot assign or add [Element] to Circuit. There is no assigned secondary distribution system for [Element].
CannotConnectDifferentDesignOptsObjects | Cannot add or assign [Element] to circuit. Electrical objects belonging to different design options cannot be connected.
CannotCreatePanelScheduleDuetoNoDefaultTemplate | A panel schedule cannot be created for these panels. A default panel schedule template must be assigned for this template type.
CannotRemoveMembersInCircuitHavingParent | You have selected elements that are connected to a Panel object in a Circuit. These elements cannot be removed from the Circuit.
CircuitOverload | Total connected apparent power for Circuit [Name] is exceeding 80% of the defined rating ([Rating Value]).
CircuitsOverlapAndDeleteSpareSpace | More than one Spare/Space falls onto the same slot. These Spares/Spaces will be deleted.
CircuitsOverlapDisconnectCircuits | More than one circuit falls onto the same slot. These circuits will be disconnected.
ConduitModified | The conduit has been modified to be in the opposite direction or insufficient space to create the required fittings.
ElementsBelongToOtherCircuit | You have selected elements that are already part of other Circuits that have assigned Panels. The elements you selected cannot be added to this Circuit.
FamilyMismatchCircuit | The family no longer matches the properties for the Circuit. Disconnect the family from the Circuit?
FeedThroughLugsIsDisabled | The feed through lugs option is unchecked.
FeedThroughLugsIsNotEnabledAndBindFormulaInFamily | Can't change connection type to Feed Through Lugs because Feed Through Lugs is unchecked. Enable Feed Through Lugs with related formula in family editor the Feed Through Lugs is mapped to. Select the panel -> Edit Family -> Family Types.
FeedThroughLugsIsNotEnabledAndBindGlobalParam | Can't change connection type to Feed Through Lugs because Feed Through Lugs is not enabled. Enable Feed Through Lugs by enabling the global parameter that Feed Through Lugs is mapping. Click Manage tab -> Settings panel -> Global Parameters.
FeedThroughLugsIsOccupied | The feed through lugs is in use by circuit [Element].
FeedThroughLugsIsOccupiedAndDisconnectOtherCircuits | The feed through lugs is occupied, so other circuits connected with feed through lugs will be disconnected from this panel [Panel Name].
InvalidApparentPowerDensity | The Apparent Power Density is invalid. Edit the Power Density and/or Power Factor to recalculate the Apparent Power Density.
InvalidNumberOfCircuitValueForDataPanel | The number of circuits on the data panel currently exceeds the value you entered for Maximum Amount of Circuits parameter. Reduce the number of circuits on the equipment before changing this value.
InvalidNumberOfCircuitValueForSwitchPanel | The number of circuits on the switchboard currently exceeds the value you entered. Reduce the number of circuits on the equipment before changing this value.
InvalidNumwiresSinglephase | Invalid number of wires for single phase, only 2 and 3 are valid.
InvalidPathOfParallelConduits | Invalid path of parallel conduits
MaximumNumberOfPolesExceeded | You cannot add more poles to this spare, as doing so would exceed the maximum number of poles set for this equipment.
MismatchConnectorDistSysToCircuit | Cannot add [Element] to Circuit. The Type for the available connector does not match the Type ([Name]) for the Circuit.
MismatchDistributionSystem | [Name1] and [Name2] cannot connect with each other due to mismatched voltage or number of phases.
MismatchNmbAssignedDistSysToCircuit | Cannot assign or add [Element] to Circuit. There is no assigned distribution system for [Element].
MismatchNmbOfPolesToCircuit | Cannot add [Element] to Circuit. The Number of Poles for [Element] does not match the Number of Poles ([Name]) for the Circuit.
MismatchPoleBrakesSlotsNumbers | The number of pole breakers may not be less than the number of occupied slots.
MismatchVoltageLineToLine | Cannot assign or add [Element] to Circuit. The Voltage ([Voltage Value]) for the Circuit is out of range for the Line to Line Voltage for [Element] (The Line to Line Voltage is specified in the assigned Distribution System).
MismatchVoltageToCircuit | Cannot add [Element] to Circuit. The Voltage for [Element] is out of range for the Voltage ([Voltage Value]) for the Circuit.
MissingOrInvalidWireSizeTable | Wire Size Table "[Fail Name]" is missing or invalid. Use Electrical Settings to select a valid Wire Size Table.
NoAvailableMatchingConnector | Cannot add [Element] to Circuit. There is no available connector matching the Type ([Type Name]) for the Circuit.
NoDistributionSystem | The distribution system of [CategoryName] [Name] is set to None. Assign a distribution system.
NotAllowedCableTrayConduitRotation | Don't allow to rotate a horizontal cable tray/conduit like this
NotEnoughAvailSlotsAndLugsOnPanel | You can't connect to panel [Panel Name] because there aren't enough slots and Feed Through Lugs is occupied. \nYou can increase the [ParameterName] to be greater than [Number] to connect through breaker slots or you can disconnect existing Feed Through Lugs connection.
NotEnoughAvailSlotsAndLugsOnSwitchPanel | You can't connect to switchboard [Panel Name] because there aren't enough space and circuit [Circuit Name] is set to Feed Through Lugs. \nYou can increase the number of circuits to be greater than [Number] to connect through breakers or you can disconnect circuit and select Feed Through Lugs again.
NotEnoughAvailSlotsOnDataPanel | You can't connect to data panel [Panel Name] because there isn't enough space \nYou can increase the number of circuits to be greater than [Number].
NotEnoughAvailSlotsOnPanel | You can't change the connection type to Breakers connect to panel [Panel Name] because there aren't enough slots. \nYou can increase the [ParameterName] to be greater than [Number] to connect through breaker slots or open the panel schedule and manually reshuffle non - consecutive slots.
NotEnoughRoomForParallelConduits | Due to changes in elevation, there is not enough room to generate all of the parallel conduits. As a result, some conduit segments have not been generated.
NotEnoughRoomForParallelPipes | Due to changes in elevation, there is not enough room to generate all of the parallel pipes. As a result, some pipe segments have not been generated.
NotEnoughSlotsOnlyLugAvailable | There aren't enough slots on panel [Panel Name], so the circuit will connect through Feed Through Lugs.
NotEnoughSlotsOnlyLugAvailableForSwitchPanel | There aren't enough space on switchboard [Panel Name], so the circuit will connect through Feed Through Lugs.
NotPositiveBendRadius | The value you entered for the bend radius is zero or a negative value. Enter a positive value.
NotSupportConcentricBend | Conduit with Fittings do not support Concentric Bend Radius, the bend radius of the conduit fittings will be same.
NumberOfCircuitFullOnSwitchPanel | You can't change the connection type to Breakers and connect to switchboard [Panel Name] because there aren't enough space. \nYou can increase the number of circuits to be greater than [Number] to connect through breakers.
ObjsDemolished | Cannot assign [Element] to circuit. Objects that are demolished cannot be added to a circuit.
PanelMismatchCircuitType | Cannot assign [Element] to Circuit. The Type for the panel does not match the Type ([Name]) for the Circuit.
PanelMismatchDistSysWhenCircuitAssigned | The selected circuit was added to panel [Element], but the distribution system for the panel does not match the power connector definition on the panel.
PrimaryNumOfPhasesNotEqualWithSecondary | Number of Phases of the primary distribution system isn't equal with the secondary distribution system's
ReplaceSpareSpaceOnPanelBoard | Need to replace spare or space on panelboard.
ReplaceSpareSpaceOnSwitchBoard | Need to replace spare or space on switchboard.
SecondaryNumOfPhasesNotEqualWithPrimary | Number of Phases of the secondary distribution system isn't equal with the primary distribution system's
SelectedElementsArePartOfOtherCircuit | You have selected elements that are already part of other Circuits. They will be removed from the original Circuits and added to this one.
SmallBendRadius | The value you entered for the bend radius for conduit is too small. Enter a larger value.
TransformerNoDistributionSystem | At least one of the distribution systems of Electrical Analytical Transformer [Name] is set to None. Assign distribution systems to the transformer.
UnsignedCircuit | Circuit is not assigned to a panel
UnsupportedTransformerPrimaryDS | [Distribution System Name] cannot appear on the primary side of the transformer.
VoltageIsOutOfRange | Cannot assign or add [Element] to Circuit. The Voltage ([Voltage Value]) for the Circuit is out of range for the Line to Ground Voltage for [Element] (The Line to Ground Voltage is specified in the assigned Distribution System)."
WireMaxSizeNonexistent | Cannot find max size in current wire type's material table.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ElectricalFailures Properties

The BuiltInFailuresElectricalFailures type exposes the following members.

Properties
Name | Description
AllSlotsOnPanelOccupied | All slots on panel: [Panel Name] are occupied. Some circuits will be disconnected from this panel.
BankDistanceSmallerThanDiameter | The distance value is smaller than the conduit diameter, please enter a larger value
CableTrayModified | The cable tray has been modified to be in the opposite direction or insufficient space to create the required fittings.
CannotAddMorePolesToCircuit | Empty slots are unavailable to hold the number of poles you specified for this spare. \nTo add more poles to this spare, you must free up slots by moving the circuits below the spare.
CannotAssignSecondaryDistSysToCircuit | Cannot assign or add [Element] to Circuit. There is no assigned secondary distribution system for [Element].
CannotConnectDifferentDesignOptsObjects | Cannot add or assign [Element] to circuit. Electrical objects belonging to different design options cannot be connected.
CannotCreatePanelScheduleDuetoNoDefaultTemplate | A panel schedule cannot be created for these panels. A default panel schedule template must be assigned for this template type.
CannotRemoveMembersInCircuitHavingParent | You have selected elements that are connected to a Panel object in a Circuit. These elements cannot be removed from the Circuit.
CircuitOverload | Total connected apparent power for Circuit [Name] is exceeding 80% of the defined rating ([Rating Value]).
CircuitsOverlapAndDeleteSpareSpace | More than one Spare/Space falls onto the same slot. These Spares/Spaces will be deleted.
CircuitsOverlapDisconnectCircuits | More than one circuit falls onto the same slot. These circuits will be disconnected.
ConduitModified | The conduit has been modified to be in the opposite direction or insufficient space to create the required fittings.
ElementsBelongToOtherCircuit | You have selected elements that are already part of other Circuits that have assigned Panels. The elements you selected cannot be added to this Circuit.
FamilyMismatchCircuit | The family no longer matches the properties for the Circuit. Disconnect the family from the Circuit?
FeedThroughLugsIsDisabled | The feed through lugs option is unchecked.
FeedThroughLugsIsNotEnabledAndBindFormulaInFamily | Can't change connection type to Feed Through Lugs because Feed Through Lugs is unchecked. Enable Feed Through Lugs with related formula in family editor the Feed Through Lugs is mapped to. Select the panel -> Edit Family -> Family Types.
FeedThroughLugsIsNotEnabledAndBindGlobalParam | Can't change connection type to Feed Through Lugs because Feed Through Lugs is not enabled. Enable Feed Through Lugs by enabling the global parameter that Feed Through Lugs is mapping. Click Manage tab -> Settings panel -> Global Parameters.
FeedThroughLugsIsOccupied | The feed through lugs is in use by circuit [Element].
FeedThroughLugsIsOccupiedAndDisconnectOtherCircuits | The feed through lugs is occupied, so other circuits connected with feed through lugs will be disconnected from this panel [Panel Name].
InvalidApparentPowerDensity | The Apparent Power Density is invalid. Edit the Power Density and/or Power Factor to recalculate the Apparent Power Density.
InvalidNumberOfCircuitValueForDataPanel | The number of circuits on the data panel currently exceeds the value you entered for Maximum Amount of Circuits parameter. Reduce the number of circuits on the equipment before changing this value.
InvalidNumberOfCircuitValueForSwitchPanel | The number of circuits on the switchboard currently exceeds the value you entered. Reduce the number of circuits on the equipment before changing this value.
InvalidNumwiresSinglephase | Invalid number of wires for single phase, only 2 and 3 are valid.
InvalidPathOfParallelConduits | Invalid path of parallel conduits
MaximumNumberOfPolesExceeded | You cannot add more poles to this spare, as doing so would exceed the maximum number of poles set for this equipment.
MismatchConnectorDistSysToCircuit | Cannot add [Element] to Circuit. The Type for the available connector does not match the Type ([Name]) for the Circuit.
MismatchDistributionSystem | [Name1] and [Name2] cannot connect with each other due to mismatched voltage or number of phases.
MismatchNmbAssignedDistSysToCircuit | Cannot assign or add [Element] to Circuit. There is no assigned distribution system for [Element].
MismatchNmbOfPolesToCircuit | Cannot add [Element] to Circuit. The Number of Poles for [Element] does not match the Number of Poles ([Name]) for the Circuit.
MismatchPoleBrakesSlotsNumbers | The number of pole breakers may not be less than the number of occupied slots.
MismatchVoltageLineToLine | Cannot assign or add [Element] to Circuit. The Voltage ([Voltage Value]) for the Circuit is out of range for the Line to Line Voltage for [Element] (The Line to Line Voltage is specified in the assigned Distribution System).
MismatchVoltageToCircuit | Cannot add [Element] to Circuit. The Voltage for [Element] is out of range for the Voltage ([Voltage Value]) for the Circuit.
MissingOrInvalidWireSizeTable | Wire Size Table "[Fail Name]" is missing or invalid. Use Electrical Settings to select a valid Wire Size Table.
NoAvailableMatchingConnector | Cannot add [Element] to Circuit. There is no available connector matching the Type ([Type Name]) for the Circuit.
NoDistributionSystem | The distribution system of [CategoryName] [Name] is set to None. Assign a distribution system.
NotAllowedCableTrayConduitRotation | Don't allow to rotate a horizontal cable tray/conduit like this
NotEnoughAvailSlotsAndLugsOnPanel | You can't connect to panel [Panel Name] because there aren't enough slots and Feed Through Lugs is occupied. \nYou can increase the [ParameterName] to be greater than [Number] to connect through breaker slots or you can disconnect existing Feed Through Lugs connection.
NotEnoughAvailSlotsAndLugsOnSwitchPanel | You can't connect to switchboard [Panel Name] because there aren't enough space and circuit [Circuit Name] is set to Feed Through Lugs. \nYou can increase the number of circuits to be greater than [Number] to connect through breakers or you can disconnect circuit and select Feed Through Lugs again.
NotEnoughAvailSlotsOnDataPanel | You can't connect to data panel [Panel Name] because there isn't enough space \nYou can increase the number of circuits to be greater than [Number].
NotEnoughAvailSlotsOnPanel | You can't change the connection type to Breakers connect to panel [Panel Name] because there aren't enough slots. \nYou can increase the [ParameterName] to be greater than [Number] to connect through breaker slots or open the panel schedule and manually reshuffle non - consecutive slots.
NotEnoughRoomForParallelConduits | Due to changes in elevation, there is not enough room to generate all of the parallel conduits. As a result, some conduit segments have not been generated.
NotEnoughRoomForParallelPipes | Due to changes in elevation, there is not enough room to generate all of the parallel pipes. As a result, some pipe segments have not been generated.
NotEnoughSlotsOnlyLugAvailable | There aren't enough slots on panel [Panel Name], so the circuit will connect through Feed Through Lugs.
NotEnoughSlotsOnlyLugAvailableForSwitchPanel | There aren't enough space on switchboard [Panel Name], so the circuit will connect through Feed Through Lugs.
NotPositiveBendRadius | The value you entered for the bend radius is zero or a negative value. Enter a positive value.
NotSupportConcentricBend | Conduit with Fittings do not support Concentric Bend Radius, the bend radius of the conduit fittings will be same.
NumberOfCircuitFullOnSwitchPanel | You can't change the connection type to Breakers and connect to switchboard [Panel Name] because there aren't enough space. \nYou can increase the number of circuits to be greater than [Number] to connect through breakers.
ObjsDemolished | Cannot assign [Element] to circuit. Objects that are demolished cannot be added to a circuit.
PanelMismatchCircuitType | Cannot assign [Element] to Circuit. The Type for the panel does not match the Type ([Name]) for the Circuit.
PanelMismatchDistSysWhenCircuitAssigned | The selected circuit was added to panel [Element], but the distribution system for the panel does not match the power connector definition on the panel.
PrimaryNumOfPhasesNotEqualWithSecondary | Number of Phases of the primary distribution system isn't equal with the secondary distribution system's
ReplaceSpareSpaceOnPanelBoard | Need to replace spare or space on panelboard.
ReplaceSpareSpaceOnSwitchBoard | Need to replace spare or space on switchboard.
SecondaryNumOfPhasesNotEqualWithPrimary | Number of Phases of the secondary distribution system isn't equal with the primary distribution system's
SelectedElementsArePartOfOtherCircuit | You have selected elements that are already part of other Circuits. They will be removed from the original Circuits and added to this one.
SmallBendRadius | The value you entered for the bend radius for conduit is too small. Enter a larger value.
TransformerNoDistributionSystem | At least one of the distribution systems of Electrical Analytical Transformer [Name] is set to None. Assign distribution systems to the transformer.
UnsignedCircuit | Circuit is not assigned to a panel
UnsupportedTransformerPrimaryDS | [Distribution System Name] cannot appear on the primary side of the transformer.
VoltageIsOutOfRange | Cannot assign or add [Element] to Circuit. The Voltage ([Voltage Value]) for the Circuit is out of range for the Line to Ground Voltage for [Element] (The Line to Ground Voltage is specified in the assigned Distribution System)."
WireMaxSizeNonexistent | Cannot find max size in current wire type's material table.
Top
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.AllSlotsOnPanelOccupied Property

BuiltInFailuresElectricalFailuresAllSlotsOnPanelOccupied Property

All slots on panel: [Panel Name] are occupied. Some circuits will be disconnected from this panel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AllSlotsOnPanelOccupied { get; }
Public Shared ReadOnly Property AllSlotsOnPanelOccupied As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AllSlotsOnPanelOccupied {
    FailureDefinitionId^ get ();
}
static member AllSlotsOnPanelOccupied : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.BankDistanceSmallerThanDiameter Property

BuiltInFailuresElectricalFailuresBankDistanceSmallerThanDiameter Property

The distance value is smaller than the conduit diameter, please enter a larger value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BankDistanceSmallerThanDiameter { get; }
Public Shared ReadOnly Property BankDistanceSmallerThanDiameter As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BankDistanceSmallerThanDiameter {
    FailureDefinitionId^ get ();
}
static member BankDistanceSmallerThanDiameter : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.CableTrayModified Property

BuiltInFailuresElectricalFailuresCableTrayModified Property

The cable tray has been modified to be in the opposite direction or insufficient space to create the required fittings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CableTrayModified { get; }
Public Shared ReadOnly Property CableTrayModified As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CableTrayModified {
    FailureDefinitionId^ get ();
}
static member CableTrayModified : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.CannotAddMorePolesToCircuit Property

BuiltInFailuresElectricalFailuresCannotAddMorePolesToCircuit Property

Empty slots are unavailable to hold the number of poles you specified for this spare. \nTo add more poles to this spare, you must free up slots by moving the circuits below the spare.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotAddMorePolesToCircuit { get; }
Public Shared ReadOnly Property CannotAddMorePolesToCircuit As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotAddMorePolesToCircuit {
    FailureDefinitionId^ get ();
}
static member CannotAddMorePolesToCircuit : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.CannotAssignSecondaryDistSysToCircuit Property

BuiltInFailuresElectricalFailuresCannotAssignSecondaryDistSysToCircuit Property

Cannot assign or add [Element] to Circuit. There is no assigned secondary distribution system for [Element].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotAssignSecondaryDistSysToCircuit { get; }
Public Shared ReadOnly Property CannotAssignSecondaryDistSysToCircuit As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotAssignSecondaryDistSysToCircuit {
    FailureDefinitionId^ get ();
}
static member CannotAssignSecondaryDistSysToCircuit : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.CannotConnectDifferentDesignOptsObjects Property

BuiltInFailuresElectricalFailuresCannotConnectDifferentDesignOptsObjects Property

Cannot add or assign [Element] to circuit. Electrical objects belonging to different design options cannot be connected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotConnectDifferentDesignOptsObjects { get; }
Public Shared ReadOnly Property CannotConnectDifferentDesignOptsObjects As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotConnectDifferentDesignOptsObjects {
    FailureDefinitionId^ get ();
}
static member CannotConnectDifferentDesignOptsObjects : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.CannotCreatePanelScheduleDuetoNoDefaultTemplate Property

BuiltInFailuresElectricalFailuresCannotCreatePanelScheduleDuetoNoDefaultTemplate Property

A panel schedule cannot be created for these panels. A default panel schedule template must be assigned for this template type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreatePanelScheduleDuetoNoDefaultTemplate { get; }
Public Shared ReadOnly Property CannotCreatePanelScheduleDuetoNoDefaultTemplate As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreatePanelScheduleDuetoNoDefaultTemplate {
    FailureDefinitionId^ get ();
}
static member CannotCreatePanelScheduleDuetoNoDefaultTemplate : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.CannotRemoveMembersInCircuitHavingParent Property

BuiltInFailuresElectricalFailuresCannotRemoveMembersInCircuitHavingParent Property

You have selected elements that are connected to a Panel object in a Circuit. These elements cannot be removed from the Circuit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotRemoveMembersInCircuitHavingParent { get; }
Public Shared ReadOnly Property CannotRemoveMembersInCircuitHavingParent As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotRemoveMembersInCircuitHavingParent {
    FailureDefinitionId^ get ();
}
static member CannotRemoveMembersInCircuitHavingParent : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.CircuitOverload Property

BuiltInFailuresElectricalFailuresCircuitOverload Property

Total connected apparent power for Circuit [Name] is exceeding 80% of the defined rating ([Rating Value]).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CircuitOverload { get; }
Public Shared ReadOnly Property CircuitOverload As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CircuitOverload {
    FailureDefinitionId^ get ();
}
static member CircuitOverload : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.CircuitsOverlapAndDeleteSpareSpace Property

BuiltInFailuresElectricalFailuresCircuitsOverlapAndDeleteSpareSpace Property

More than one Spare/Space falls onto the same slot. These Spares/Spaces will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CircuitsOverlapAndDeleteSpareSpace { get; }
Public Shared ReadOnly Property CircuitsOverlapAndDeleteSpareSpace As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CircuitsOverlapAndDeleteSpareSpace {
    FailureDefinitionId^ get ();
}
static member CircuitsOverlapAndDeleteSpareSpace : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.CircuitsOverlapDisconnectCircuits Property

BuiltInFailuresElectricalFailuresCircuitsOverlapDisconnectCircuits Property

More than one circuit falls onto the same slot. These circuits will be disconnected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CircuitsOverlapDisconnectCircuits { get; }
Public Shared ReadOnly Property CircuitsOverlapDisconnectCircuits As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CircuitsOverlapDisconnectCircuits {
    FailureDefinitionId^ get ();
}
static member CircuitsOverlapDisconnectCircuits : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.ConduitModified Property

BuiltInFailuresElectricalFailuresConduitModified Property

The conduit has been modified to be in the opposite direction or insufficient space to create the required fittings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ConduitModified { get; }
Public Shared ReadOnly Property ConduitModified As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ConduitModified {
    FailureDefinitionId^ get ();
}
static member ConduitModified : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.ElementsBelongToOtherCircuit Property

BuiltInFailuresElectricalFailuresElementsBelongToOtherCircuit Property

You have selected elements that are already part of other Circuits that have assigned Panels. The elements you selected cannot be added to this Circuit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ElementsBelongToOtherCircuit { get; }
Public Shared ReadOnly Property ElementsBelongToOtherCircuit As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ElementsBelongToOtherCircuit {
    FailureDefinitionId^ get ();
}
static member ElementsBelongToOtherCircuit : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.FamilyMismatchCircuit Property

BuiltInFailuresElectricalFailuresFamilyMismatchCircuit Property

The family no longer matches the properties for the Circuit. Disconnect the family from the Circuit?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FamilyMismatchCircuit { get; }
Public Shared ReadOnly Property FamilyMismatchCircuit As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FamilyMismatchCircuit {
    FailureDefinitionId^ get ();
}
static member FamilyMismatchCircuit : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.FeedThroughLugsIsDisabled Property

BuiltInFailuresElectricalFailuresFeedThroughLugsIsDisabled Property

The feed through lugs option is unchecked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FeedThroughLugsIsDisabled { get; }
Public Shared ReadOnly Property FeedThroughLugsIsDisabled As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FeedThroughLugsIsDisabled {
    FailureDefinitionId^ get ();
}
static member FeedThroughLugsIsDisabled : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.FeedThroughLugsIsNotEnabledAndBindFormulaInFamily Property

BuiltInFailuresElectricalFailuresFeedThroughLugsIsNotEnabledAndBindFormulaInFamily Property

Can't change connection type to Feed Through Lugs because Feed Through Lugs is unchecked. Enable Feed Through Lugs with related formula in family editor the Feed Through Lugs is mapped to. Select the panel -> Edit Family -> Family Types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FeedThroughLugsIsNotEnabledAndBindFormulaInFamily { get; }
Public Shared ReadOnly Property FeedThroughLugsIsNotEnabledAndBindFormulaInFamily As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FeedThroughLugsIsNotEnabledAndBindFormulaInFamily {
    FailureDefinitionId^ get ();
}
static member FeedThroughLugsIsNotEnabledAndBindFormulaInFamily : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.FeedThroughLugsIsNotEnabledAndBindGlobalParam Property

BuiltInFailuresElectricalFailuresFeedThroughLugsIsNotEnabledAndBindGlobalParam Property

Can't change connection type to Feed Through Lugs because Feed Through Lugs is not enabled. Enable Feed Through Lugs by enabling the global parameter that Feed Through Lugs is mapping. Click Manage tab -> Settings panel -> Global Parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FeedThroughLugsIsNotEnabledAndBindGlobalParam { get; }
Public Shared ReadOnly Property FeedThroughLugsIsNotEnabledAndBindGlobalParam As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FeedThroughLugsIsNotEnabledAndBindGlobalParam {
    FailureDefinitionId^ get ();
}
static member FeedThroughLugsIsNotEnabledAndBindGlobalParam : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.FeedThroughLugsIsOccupied Property

BuiltInFailuresElectricalFailuresFeedThroughLugsIsOccupied Property

The feed through lugs is in use by circuit [Element].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FeedThroughLugsIsOccupied { get; }
Public Shared ReadOnly Property FeedThroughLugsIsOccupied As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FeedThroughLugsIsOccupied {
    FailureDefinitionId^ get ();
}
static member FeedThroughLugsIsOccupied : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.FeedThroughLugsIsOccupiedAndDisconnectOtherCircuits Property

BuiltInFailuresElectricalFailuresFeedThroughLugsIsOccupiedAndDisconnectOtherCircuits Property

The feed through lugs is occupied, so other circuits connected with feed through lugs will be disconnected from this panel [Panel Name].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FeedThroughLugsIsOccupiedAndDisconnectOtherCircuits { get; }
Public Shared ReadOnly Property FeedThroughLugsIsOccupiedAndDisconnectOtherCircuits As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FeedThroughLugsIsOccupiedAndDisconnectOtherCircuits {
    FailureDefinitionId^ get ();
}
static member FeedThroughLugsIsOccupiedAndDisconnectOtherCircuits : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.InvalidApparentPowerDensity Property

BuiltInFailuresElectricalFailuresInvalidApparentPowerDensity Property

The Apparent Power Density is invalid. Edit the Power Density and/or Power Factor to recalculate the Apparent Power Density.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidApparentPowerDensity { get; }
Public Shared ReadOnly Property InvalidApparentPowerDensity As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidApparentPowerDensity {
    FailureDefinitionId^ get ();
}
static member InvalidApparentPowerDensity : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.InvalidNumberOfCircuitValueForDataPanel Property

BuiltInFailuresElectricalFailuresInvalidNumberOfCircuitValueForDataPanel Property

The number of circuits on the data panel currently exceeds the value you entered for Maximum Amount of Circuits parameter. Reduce the number of circuits on the equipment before changing this value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidNumberOfCircuitValueForDataPanel { get; }
Public Shared ReadOnly Property InvalidNumberOfCircuitValueForDataPanel As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidNumberOfCircuitValueForDataPanel {
    FailureDefinitionId^ get ();
}
static member InvalidNumberOfCircuitValueForDataPanel : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.InvalidNumberOfCircuitValueForSwitchPanel Property

BuiltInFailuresElectricalFailuresInvalidNumberOfCircuitValueForSwitchPanel Property

The number of circuits on the switchboard currently exceeds the value you entered. Reduce the number of circuits on the equipment before changing this value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidNumberOfCircuitValueForSwitchPanel { get; }
Public Shared ReadOnly Property InvalidNumberOfCircuitValueForSwitchPanel As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidNumberOfCircuitValueForSwitchPanel {
    FailureDefinitionId^ get ();
}
static member InvalidNumberOfCircuitValueForSwitchPanel : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.InvalidNumwiresSinglephase Property

BuiltInFailuresElectricalFailuresInvalidNumwiresSinglephase Property

Invalid number of wires for single phase, only 2 and 3 are valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidNumwiresSinglephase { get; }
Public Shared ReadOnly Property InvalidNumwiresSinglephase As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidNumwiresSinglephase {
    FailureDefinitionId^ get ();
}
static member InvalidNumwiresSinglephase : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.InvalidPathOfParallelConduits Property

BuiltInFailuresElectricalFailuresInvalidPathOfParallelConduits Property

Invalid path of parallel conduits

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidPathOfParallelConduits { get; }
Public Shared ReadOnly Property InvalidPathOfParallelConduits As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidPathOfParallelConduits {
    FailureDefinitionId^ get ();
}
static member InvalidPathOfParallelConduits : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.MaximumNumberOfPolesExceeded Property

BuiltInFailuresElectricalFailuresMaximumNumberOfPolesExceeded Property

You cannot add more poles to this spare, as doing so would exceed the maximum number of poles set for this equipment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MaximumNumberOfPolesExceeded { get; }
Public Shared ReadOnly Property MaximumNumberOfPolesExceeded As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MaximumNumberOfPolesExceeded {
    FailureDefinitionId^ get ();
}
static member MaximumNumberOfPolesExceeded : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.MismatchConnectorDistSysToCircuit Property

BuiltInFailuresElectricalFailuresMismatchConnectorDistSysToCircuit Property

Cannot add [Element] to Circuit. The Type for the available connector does not match the Type ([Name]) for the Circuit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MismatchConnectorDistSysToCircuit { get; }
Public Shared ReadOnly Property MismatchConnectorDistSysToCircuit As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MismatchConnectorDistSysToCircuit {
    FailureDefinitionId^ get ();
}
static member MismatchConnectorDistSysToCircuit : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.MismatchDistributionSystem Property

BuiltInFailuresElectricalFailuresMismatchDistributionSystem Property

[Name1] and [Name2] cannot connect with each other due to mismatched voltage or number of phases.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MismatchDistributionSystem { get; }
Public Shared ReadOnly Property MismatchDistributionSystem As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MismatchDistributionSystem {
    FailureDefinitionId^ get ();
}
static member MismatchDistributionSystem : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.MismatchNmbAssignedDistSysToCircuit Property

BuiltInFailuresElectricalFailuresMismatchNmbAssignedDistSysToCircuit Property

Cannot assign or add [Element] to Circuit. There is no assigned distribution system for [Element].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MismatchNmbAssignedDistSysToCircuit { get; }
Public Shared ReadOnly Property MismatchNmbAssignedDistSysToCircuit As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MismatchNmbAssignedDistSysToCircuit {
    FailureDefinitionId^ get ();
}
static member MismatchNmbAssignedDistSysToCircuit : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.MismatchNmbOfPolesToCircuit Property

BuiltInFailuresElectricalFailuresMismatchNmbOfPolesToCircuit Property

Cannot add [Element] to Circuit. The Number of Poles for [Element] does not match the Number of Poles ([Name]) for the Circuit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MismatchNmbOfPolesToCircuit { get; }
Public Shared ReadOnly Property MismatchNmbOfPolesToCircuit As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MismatchNmbOfPolesToCircuit {
    FailureDefinitionId^ get ();
}
static member MismatchNmbOfPolesToCircuit : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.MismatchPoleBrakesSlotsNumbers Property

BuiltInFailuresElectricalFailuresMismatchPoleBrakesSlotsNumbers Property

The number of pole breakers may not be less than the number of occupied slots.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MismatchPoleBrakesSlotsNumbers { get; }
Public Shared ReadOnly Property MismatchPoleBrakesSlotsNumbers As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MismatchPoleBrakesSlotsNumbers {
    FailureDefinitionId^ get ();
}
static member MismatchPoleBrakesSlotsNumbers : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.MismatchVoltageLineToLine Property

BuiltInFailuresElectricalFailuresMismatchVoltageLineToLine Property

Cannot assign or add [Element] to Circuit. The Voltage ([Voltage Value]) for the Circuit is out of range for the Line to Line Voltage for [Element] (The Line to Line Voltage is specified in the assigned Distribution System).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MismatchVoltageLineToLine { get; }
Public Shared ReadOnly Property MismatchVoltageLineToLine As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MismatchVoltageLineToLine {
    FailureDefinitionId^ get ();
}
static member MismatchVoltageLineToLine : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.MismatchVoltageToCircuit Property

BuiltInFailuresElectricalFailuresMismatchVoltageToCircuit Property

Cannot add [Element] to Circuit. The Voltage for [Element] is out of range for the Voltage ([Voltage Value]) for the Circuit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MismatchVoltageToCircuit { get; }
Public Shared ReadOnly Property MismatchVoltageToCircuit As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MismatchVoltageToCircuit {
    FailureDefinitionId^ get ();
}
static member MismatchVoltageToCircuit : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.MissingOrInvalidWireSizeTable Property

BuiltInFailuresElectricalFailuresMissingOrInvalidWireSizeTable Property

Wire Size Table "[Fail Name]" is missing or invalid. Use Electrical Settings to select a valid Wire Size Table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MissingOrInvalidWireSizeTable { get; }
Public Shared ReadOnly Property MissingOrInvalidWireSizeTable As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MissingOrInvalidWireSizeTable {
    FailureDefinitionId^ get ();
}
static member MissingOrInvalidWireSizeTable : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.NoAvailableMatchingConnector Property

BuiltInFailuresElectricalFailuresNoAvailableMatchingConnector Property

Cannot add [Element] to Circuit. There is no available connector matching the Type ([Type Name]) for the Circuit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoAvailableMatchingConnector { get; }
Public Shared ReadOnly Property NoAvailableMatchingConnector As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoAvailableMatchingConnector {
    FailureDefinitionId^ get ();
}
static member NoAvailableMatchingConnector : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.NoDistributionSystem Property

BuiltInFailuresElectricalFailuresNoDistributionSystem Property

The distribution system of [CategoryName] [Name] is set to None. Assign a distribution system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoDistributionSystem { get; }
Public Shared ReadOnly Property NoDistributionSystem As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoDistributionSystem {
    FailureDefinitionId^ get ();
}
static member NoDistributionSystem : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.NotAllowedCableTrayConduitRotation Property

BuiltInFailuresElectricalFailuresNotAllowedCableTrayConduitRotation Property

Don't allow to rotate a horizontal cable tray/conduit like this

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotAllowedCableTrayConduitRotation { get; }
Public Shared ReadOnly Property NotAllowedCableTrayConduitRotation As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotAllowedCableTrayConduitRotation {
    FailureDefinitionId^ get ();
}
static member NotAllowedCableTrayConduitRotation : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.NotEnoughAvailSlotsAndLugsOnPanel Property

BuiltInFailuresElectricalFailuresNotEnoughAvailSlotsAndLugsOnPanel Property

You can't connect to panel [Panel Name] because there aren't enough slots and Feed Through Lugs is occupied. \nYou can increase the [ParameterName] to be greater than [Number] to connect through breaker slots or you can disconnect existing Feed Through Lugs connection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotEnoughAvailSlotsAndLugsOnPanel { get; }
Public Shared ReadOnly Property NotEnoughAvailSlotsAndLugsOnPanel As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotEnoughAvailSlotsAndLugsOnPanel {
    FailureDefinitionId^ get ();
}
static member NotEnoughAvailSlotsAndLugsOnPanel : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.NotEnoughAvailSlotsAndLugsOnSwitchPanel Property

BuiltInFailuresElectricalFailuresNotEnoughAvailSlotsAndLugsOnSwitchPanel Property

You can't connect to switchboard [Panel Name] because there aren't enough space and circuit [Circuit Name] is set to Feed Through Lugs. \nYou can increase the number of circuits to be greater than [Number] to connect through breakers or you can disconnect circuit and select Feed Through Lugs again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotEnoughAvailSlotsAndLugsOnSwitchPanel { get; }
Public Shared ReadOnly Property NotEnoughAvailSlotsAndLugsOnSwitchPanel As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotEnoughAvailSlotsAndLugsOnSwitchPanel {
    FailureDefinitionId^ get ();
}
static member NotEnoughAvailSlotsAndLugsOnSwitchPanel : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.NotEnoughAvailSlotsOnDataPanel Property

BuiltInFailuresElectricalFailuresNotEnoughAvailSlotsOnDataPanel Property

You can't connect to data panel [Panel Name] because there isn't enough space \nYou can increase the number of circuits to be greater than [Number].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotEnoughAvailSlotsOnDataPanel { get; }
Public Shared ReadOnly Property NotEnoughAvailSlotsOnDataPanel As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotEnoughAvailSlotsOnDataPanel {
    FailureDefinitionId^ get ();
}
static member NotEnoughAvailSlotsOnDataPanel : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.NotEnoughAvailSlotsOnPanel Property

BuiltInFailuresElectricalFailuresNotEnoughAvailSlotsOnPanel Property

You can't change the connection type to Breakers connect to panel [Panel Name] because there aren't enough slots. \nYou can increase the [ParameterName] to be greater than [Number] to connect through breaker slots or open the panel schedule and manually reshuffle non - consecutive slots.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotEnoughAvailSlotsOnPanel { get; }
Public Shared ReadOnly Property NotEnoughAvailSlotsOnPanel As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotEnoughAvailSlotsOnPanel {
    FailureDefinitionId^ get ();
}
static member NotEnoughAvailSlotsOnPanel : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.NotEnoughRoomForParallelConduits Property

BuiltInFailuresElectricalFailuresNotEnoughRoomForParallelConduits Property

Due to changes in elevation, there is not enough room to generate all of the parallel conduits. As a result, some conduit segments have not been generated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotEnoughRoomForParallelConduits { get; }
Public Shared ReadOnly Property NotEnoughRoomForParallelConduits As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotEnoughRoomForParallelConduits {
    FailureDefinitionId^ get ();
}
static member NotEnoughRoomForParallelConduits : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.NotEnoughRoomForParallelPipes Property

BuiltInFailuresElectricalFailuresNotEnoughRoomForParallelPipes Property

Due to changes in elevation, there is not enough room to generate all of the parallel pipes. As a result, some pipe segments have not been generated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotEnoughRoomForParallelPipes { get; }
Public Shared ReadOnly Property NotEnoughRoomForParallelPipes As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotEnoughRoomForParallelPipes {
    FailureDefinitionId^ get ();
}
static member NotEnoughRoomForParallelPipes : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.NotEnoughSlotsOnlyLugAvailable Property

BuiltInFailuresElectricalFailuresNotEnoughSlotsOnlyLugAvailable Property

There aren't enough slots on panel [Panel Name], so the circuit will connect through Feed Through Lugs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotEnoughSlotsOnlyLugAvailable { get; }
Public Shared ReadOnly Property NotEnoughSlotsOnlyLugAvailable As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotEnoughSlotsOnlyLugAvailable {
    FailureDefinitionId^ get ();
}
static member NotEnoughSlotsOnlyLugAvailable : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.NotEnoughSlotsOnlyLugAvailableForSwitchPanel Property

BuiltInFailuresElectricalFailuresNotEnoughSlotsOnlyLugAvailableForSwitchPanel Property

There aren't enough space on switchboard [Panel Name], so the circuit will connect through Feed Through Lugs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotEnoughSlotsOnlyLugAvailableForSwitchPanel { get; }
Public Shared ReadOnly Property NotEnoughSlotsOnlyLugAvailableForSwitchPanel As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotEnoughSlotsOnlyLugAvailableForSwitchPanel {
    FailureDefinitionId^ get ();
}
static member NotEnoughSlotsOnlyLugAvailableForSwitchPanel : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.NotPositiveBendRadius Property

BuiltInFailuresElectricalFailuresNotPositiveBendRadius Property

The value you entered for the bend radius is zero or a negative value. Enter a positive value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotPositiveBendRadius { get; }
Public Shared ReadOnly Property NotPositiveBendRadius As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotPositiveBendRadius {
    FailureDefinitionId^ get ();
}
static member NotPositiveBendRadius : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.NotSupportConcentricBend Property

BuiltInFailuresElectricalFailuresNotSupportConcentricBend Property

Conduit with Fittings do not support Concentric Bend Radius, the bend radius of the conduit fittings will be same.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotSupportConcentricBend { get; }
Public Shared ReadOnly Property NotSupportConcentricBend As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotSupportConcentricBend {
    FailureDefinitionId^ get ();
}
static member NotSupportConcentricBend : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.NumberOfCircuitFullOnSwitchPanel Property

BuiltInFailuresElectricalFailuresNumberOfCircuitFullOnSwitchPanel Property

You can't change the connection type to Breakers and connect to switchboard [Panel Name] because there aren't enough space. \nYou can increase the number of circuits to be greater than [Number] to connect through breakers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NumberOfCircuitFullOnSwitchPanel { get; }
Public Shared ReadOnly Property NumberOfCircuitFullOnSwitchPanel As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NumberOfCircuitFullOnSwitchPanel {
    FailureDefinitionId^ get ();
}
static member NumberOfCircuitFullOnSwitchPanel : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.ObjsDemolished Property

BuiltInFailuresElectricalFailuresObjsDemolished Property

Cannot assign [Element] to circuit. Objects that are demolished cannot be added to a circuit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ObjsDemolished { get; }
Public Shared ReadOnly Property ObjsDemolished As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ObjsDemolished {
    FailureDefinitionId^ get ();
}
static member ObjsDemolished : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.PanelMismatchCircuitType Property

BuiltInFailuresElectricalFailuresPanelMismatchCircuitType Property

Cannot assign [Element] to Circuit. The Type for the panel does not match the Type ([Name]) for the Circuit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PanelMismatchCircuitType { get; }
Public Shared ReadOnly Property PanelMismatchCircuitType As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PanelMismatchCircuitType {
    FailureDefinitionId^ get ();
}
static member PanelMismatchCircuitType : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.PanelMismatchDistSysWhenCircuitAssigned Property

BuiltInFailuresElectricalFailuresPanelMismatchDistSysWhenCircuitAssigned Property

The selected circuit was added to panel [Element], but the distribution system for the panel does not match the power connector definition on the panel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PanelMismatchDistSysWhenCircuitAssigned { get; }
Public Shared ReadOnly Property PanelMismatchDistSysWhenCircuitAssigned As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PanelMismatchDistSysWhenCircuitAssigned {
    FailureDefinitionId^ get ();
}
static member PanelMismatchDistSysWhenCircuitAssigned : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.PrimaryNumOfPhasesNotEqualWithSecondary Property

BuiltInFailuresElectricalFailuresPrimaryNumOfPhasesNotEqualWithSecondary Property

Number of Phases of the primary distribution system isn't equal with the secondary distribution system's

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PrimaryNumOfPhasesNotEqualWithSecondary { get; }
Public Shared ReadOnly Property PrimaryNumOfPhasesNotEqualWithSecondary As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PrimaryNumOfPhasesNotEqualWithSecondary {
    FailureDefinitionId^ get ();
}
static member PrimaryNumOfPhasesNotEqualWithSecondary : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.ReplaceSpareSpaceOnPanelBoard Property

BuiltInFailuresElectricalFailuresReplaceSpareSpaceOnPanelBoard Property

Need to replace spare or space on panelboard.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ReplaceSpareSpaceOnPanelBoard { get; }
Public Shared ReadOnly Property ReplaceSpareSpaceOnPanelBoard As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ReplaceSpareSpaceOnPanelBoard {
    FailureDefinitionId^ get ();
}
static member ReplaceSpareSpaceOnPanelBoard : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.ReplaceSpareSpaceOnSwitchBoard Property

BuiltInFailuresElectricalFailuresReplaceSpareSpaceOnSwitchBoard Property

Need to replace spare or space on switchboard.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ReplaceSpareSpaceOnSwitchBoard { get; }
Public Shared ReadOnly Property ReplaceSpareSpaceOnSwitchBoard As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ReplaceSpareSpaceOnSwitchBoard {
    FailureDefinitionId^ get ();
}
static member ReplaceSpareSpaceOnSwitchBoard : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.SecondaryNumOfPhasesNotEqualWithPrimary Property

BuiltInFailuresElectricalFailuresSecondaryNumOfPhasesNotEqualWithPrimary Property

Number of Phases of the secondary distribution system isn't equal with the primary distribution system's

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SecondaryNumOfPhasesNotEqualWithPrimary { get; }
Public Shared ReadOnly Property SecondaryNumOfPhasesNotEqualWithPrimary As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SecondaryNumOfPhasesNotEqualWithPrimary {
    FailureDefinitionId^ get ();
}
static member SecondaryNumOfPhasesNotEqualWithPrimary : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.SelectedElementsArePartOfOtherCircuit Property

BuiltInFailuresElectricalFailuresSelectedElementsArePartOfOtherCircuit Property

You have selected elements that are already part of other Circuits. They will be removed from the original Circuits and added to this one.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SelectedElementsArePartOfOtherCircuit { get; }
Public Shared ReadOnly Property SelectedElementsArePartOfOtherCircuit As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SelectedElementsArePartOfOtherCircuit {
    FailureDefinitionId^ get ();
}
static member SelectedElementsArePartOfOtherCircuit : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.SmallBendRadius Property

BuiltInFailuresElectricalFailuresSmallBendRadius Property

The value you entered for the bend radius for conduit is too small. Enter a larger value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SmallBendRadius { get; }
Public Shared ReadOnly Property SmallBendRadius As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SmallBendRadius {
    FailureDefinitionId^ get ();
}
static member SmallBendRadius : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.TransformerNoDistributionSystem Property

BuiltInFailuresElectricalFailuresTransformerNoDistributionSystem Property

At least one of the distribution systems of Electrical Analytical Transformer [Name] is set to None. Assign distribution systems to the transformer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TransformerNoDistributionSystem { get; }
Public Shared ReadOnly Property TransformerNoDistributionSystem As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TransformerNoDistributionSystem {
    FailureDefinitionId^ get ();
}
static member TransformerNoDistributionSystem : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.UnsignedCircuit Property

BuiltInFailuresElectricalFailuresUnsignedCircuit Property

Circuit is not assigned to a panel

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnsignedCircuit { get; }
Public Shared ReadOnly Property UnsignedCircuit As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnsignedCircuit {
    FailureDefinitionId^ get ();
}
static member UnsignedCircuit : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.UnsupportedTransformerPrimaryDS Property

BuiltInFailuresElectricalFailuresUnsupportedTransformerPrimaryDS Property

[Distribution System Name] cannot appear on the primary side of the transformer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnsupportedTransformerPrimaryDS { get; }
Public Shared ReadOnly Property UnsupportedTransformerPrimaryDS As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnsupportedTransformerPrimaryDS {
    FailureDefinitionId^ get ();
}
static member UnsupportedTransformerPrimaryDS : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.VoltageIsOutOfRange Property

BuiltInFailuresElectricalFailuresVoltageIsOutOfRange Property

Cannot assign or add [Element] to Circuit. The Voltage ([Voltage Value]) for the Circuit is out of range for the Line to Ground Voltage for [Element] (The Line to Ground Voltage is specified in the assigned Distribution System)."

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId VoltageIsOutOfRange { get; }
Public Shared ReadOnly Property VoltageIsOutOfRange As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ VoltageIsOutOfRange {
    FailureDefinitionId^ get ();
}
static member VoltageIsOutOfRange : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricalFailures.WireMaxSizeNonexistent Property

BuiltInFailuresElectricalFailuresWireMaxSizeNonexistent Property

Cannot find max size in current wire type's material table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WireMaxSizeNonexistent { get; }
Public Shared ReadOnly Property WireMaxSizeNonexistent As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WireMaxSizeNonexistent {
    FailureDefinitionId^ get ();
}
static member WireMaxSizeNonexistent : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricalFailures Class


BuiltInFailures.ElectricityFailures Class

BuiltInFailuresElectricityFailures Class

Failures related to electrical system and circuits.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresElectricityFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ElectricityFailures
Public NotInheritable Class ElectricityFailures
public ref class ElectricityFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ElectricityFailures = class end

The BuiltInFailuresElectricityFailures type exposes the following members.

Properties
Name | Description
FamilyMismatchCircuitDisconnected | The family no longer matches the properties for the Circuit. Disconnect the family from the Circuit?
InvalidPoleNumber | The panel is single phase [wire] wires. The number of poles can not be larger than [value].
InvalidPoleNumberInIsolatedPanel | The panel is an isolated panel. The number of poles should equal to [value].
InvalidSpareLoad | The spare/space assigned to panel '[Panel Name]' has an invalid load property. To correct this issue, remove and add the spare/space to the panel again.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ElectricityFailures Properties

The BuiltInFailuresElectricityFailures type exposes the following members.

Properties
Name | Description
FamilyMismatchCircuitDisconnected | The family no longer matches the properties for the Circuit. Disconnect the family from the Circuit?
InvalidPoleNumber | The panel is single phase [wire] wires. The number of poles can not be larger than [value].
InvalidPoleNumberInIsolatedPanel | The panel is an isolated panel. The number of poles should equal to [value].
InvalidSpareLoad | The spare/space assigned to panel '[Panel Name]' has an invalid load property. To correct this issue, remove and add the spare/space to the panel again.
Top
See Also

Reference

BuiltInFailuresElectricityFailures Class


BuiltInFailures.ElectricityFailures.FamilyMismatchCircuitDisconnected Property

BuiltInFailuresElectricityFailuresFamilyMismatchCircuitDisconnected Property

The family no longer matches the properties for the Circuit. Disconnect the family from the Circuit?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FamilyMismatchCircuitDisconnected { get; }
Public Shared ReadOnly Property FamilyMismatchCircuitDisconnected As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FamilyMismatchCircuitDisconnected {
    FailureDefinitionId^ get ();
}
static member FamilyMismatchCircuitDisconnected : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricityFailures Class


BuiltInFailures.ElectricityFailures.InvalidPoleNumber Property

BuiltInFailuresElectricityFailuresInvalidPoleNumber Property

The panel is single phase [wire] wires. The number of poles can not be larger than [value].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidPoleNumber { get; }
Public Shared ReadOnly Property InvalidPoleNumber As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidPoleNumber {
    FailureDefinitionId^ get ();
}
static member InvalidPoleNumber : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricityFailures Class


BuiltInFailures.ElectricityFailures.InvalidPoleNumberInIsolatedPanel Property

BuiltInFailuresElectricityFailuresInvalidPoleNumberInIsolatedPanel Property

The panel is an isolated panel. The number of poles should equal to [value].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidPoleNumberInIsolatedPanel { get; }
Public Shared ReadOnly Property InvalidPoleNumberInIsolatedPanel As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidPoleNumberInIsolatedPanel {
    FailureDefinitionId^ get ();
}
static member InvalidPoleNumberInIsolatedPanel : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricityFailures Class


BuiltInFailures.ElectricityFailures.InvalidSpareLoad Property

BuiltInFailuresElectricityFailuresInvalidSpareLoad Property

The spare/space assigned to panel '[Panel Name]' has an invalid load property. To correct this issue, remove and add the spare/space to the panel again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidSpareLoad { get; }
Public Shared ReadOnly Property InvalidSpareLoad As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidSpareLoad {
    FailureDefinitionId^ get ();
}
static member InvalidSpareLoad : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElectricityFailures Class


BuiltInFailures.ElementFailures Class

BuiltInFailuresElementFailures Class

Failures about Elements.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresElementFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ElementFailures
Public NotInheritable Class ElementFailures
public ref class ElementFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ElementFailures = class end

The BuiltInFailuresElementFailures type exposes the following members.

Properties
Name | Description
FailedToRemoveElement | Element cannot be removed from the solution. The solution is required to have at least two elements to be valid.
NotAllowedToRemoveAllElements | You cannot removed all the elements from current solution. At least there should be two elements in the solution.
SplitElementHasTagsWithoutLeaders | The split element has one or more Tags without Leaders enabled and needs to be checked.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ElementFailures Properties

The BuiltInFailuresElementFailures type exposes the following members.

Properties
Name | Description
FailedToRemoveElement | Element cannot be removed from the solution. The solution is required to have at least two elements to be valid.
NotAllowedToRemoveAllElements | You cannot removed all the elements from current solution. At least there should be two elements in the solution.
SplitElementHasTagsWithoutLeaders | The split element has one or more Tags without Leaders enabled and needs to be checked.
Top
See Also

Reference

BuiltInFailuresElementFailures Class


BuiltInFailures.ElementFailures.FailedToRemoveElement Property

BuiltInFailuresElementFailuresFailedToRemoveElement Property

Element cannot be removed from the solution. The solution is required to have at least two elements to be valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FailedToRemoveElement { get; }
Public Shared ReadOnly Property FailedToRemoveElement As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FailedToRemoveElement {
    FailureDefinitionId^ get ();
}
static member FailedToRemoveElement : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElementFailures Class


BuiltInFailures.ElementFailures.NotAllowedToRemoveAllElements Property

BuiltInFailuresElementFailuresNotAllowedToRemoveAllElements Property

You cannot removed all the elements from current solution. At least there should be two elements in the solution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotAllowedToRemoveAllElements { get; }
Public Shared ReadOnly Property NotAllowedToRemoveAllElements As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotAllowedToRemoveAllElements {
    FailureDefinitionId^ get ();
}
static member NotAllowedToRemoveAllElements : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElementFailures Class


BuiltInFailures.ElementFailures.SplitElementHasTagsWithoutLeaders Property

BuiltInFailuresElementFailuresSplitElementHasTagsWithoutLeaders Property

The split element has one or more Tags without Leaders enabled and needs to be checked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SplitElementHasTagsWithoutLeaders { get; }
Public Shared ReadOnly Property SplitElementHasTagsWithoutLeaders As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SplitElementHasTagsWithoutLeaders {
    FailureDefinitionId^ get ();
}
static member SplitElementHasTagsWithoutLeaders : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElementFailures Class


BuiltInFailures.ElementTypeFailures Class

BuiltInFailuresElementTypeFailures Class

Failures about ElementTypeFailures.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresElementTypeFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ElementTypeFailures
Public NotInheritable Class ElementTypeFailures
public ref class ElementTypeFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ElementTypeFailures = class end

The BuiltInFailuresElementTypeFailures type exposes the following members.

Properties
Name | Description
NoDefaultType | As a result of Reloading Latest, there are no types of [User Name] left. Create a new type by duplicating an existing [User Name] type in the Project Browser.
WarnLastType1 | Last type in system family '[Name]' cannot be deleted.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ElementTypeFailures Properties

The BuiltInFailuresElementTypeFailures type exposes the following members.

Properties
Name | Description
NoDefaultType | As a result of Reloading Latest, there are no types of [User Name] left. Create a new type by duplicating an existing [User Name] type in the Project Browser.
WarnLastType1 | Last type in system family '[Name]' cannot be deleted.
Top
See Also

Reference

BuiltInFailuresElementTypeFailures Class


BuiltInFailures.ElementTypeFailures.NoDefaultType Property

BuiltInFailuresElementTypeFailuresNoDefaultType Property

As a result of Reloading Latest, there are no types of [User Name] left. Create a new type by duplicating an existing [User Name] type in the Project Browser.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoDefaultType { get; }
Public Shared ReadOnly Property NoDefaultType As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoDefaultType {
    FailureDefinitionId^ get ();
}
static member NoDefaultType : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElementTypeFailures Class


BuiltInFailures.ElementTypeFailures.WarnLastType1 Property

BuiltInFailuresElementTypeFailuresWarnLastType1 Property

Last type in system family '[Name]' cannot be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WarnLastType1 { get; }
Public Shared ReadOnly Property WarnLastType1 As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WarnLastType1 {
    FailureDefinitionId^ get ();
}
static member WarnLastType1 : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElementTypeFailures Class


BuiltInFailures.ElevationFailures Class

BuiltInFailuresElevationFailures Class

Failures about Elevation.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresElevationFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ElevationFailures
Public NotInheritable Class ElevationFailures
public ref class ElevationFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ElevationFailures = class end

The BuiltInFailuresElevationFailures type exposes the following members.

Properties
Name | Description
ElevationDetach | An Elevation arrow can't keep its Crop Region extents attached.
IncompatibleElevationTagFamily | Attempt to change elevation tag families to one with incompatible view directions.
WarnElevSheet | An elevation symbol references views on more than one sheet. It will show a blank sheet reference. To show the correct references, use a separate elevation symbol for the views on each sheet.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ElevationFailures Properties

The BuiltInFailuresElevationFailures type exposes the following members.

Properties
Name | Description
ElevationDetach | An Elevation arrow can't keep its Crop Region extents attached.
IncompatibleElevationTagFamily | Attempt to change elevation tag families to one with incompatible view directions.
WarnElevSheet | An elevation symbol references views on more than one sheet. It will show a blank sheet reference. To show the correct references, use a separate elevation symbol for the views on each sheet.
Top
See Also

Reference

BuiltInFailuresElevationFailures Class


BuiltInFailures.ElevationFailures.ElevationDetach Property

BuiltInFailuresElevationFailuresElevationDetach Property

An Elevation arrow can't keep its Crop Region extents attached.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ElevationDetach { get; }
Public Shared ReadOnly Property ElevationDetach As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ElevationDetach {
    FailureDefinitionId^ get ();
}
static member ElevationDetach : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElevationFailures Class


BuiltInFailures.ElevationFailures.IncompatibleElevationTagFamily Property

BuiltInFailuresElevationFailuresIncompatibleElevationTagFamily Property

Attempt to change elevation tag families to one with incompatible view directions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId IncompatibleElevationTagFamily { get; }
Public Shared ReadOnly Property IncompatibleElevationTagFamily As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ IncompatibleElevationTagFamily {
    FailureDefinitionId^ get ();
}
static member IncompatibleElevationTagFamily : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElevationFailures Class


BuiltInFailures.ElevationFailures.WarnElevSheet Property

BuiltInFailuresElevationFailuresWarnElevSheet Property

An elevation symbol references views on more than one sheet. It will show a blank sheet reference. To show the correct references, use a separate elevation symbol for the views on each sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WarnElevSheet { get; }
Public Shared ReadOnly Property WarnElevSheet As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WarnElevSheet {
    FailureDefinitionId^ get ();
}
static member WarnElevSheet : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresElevationFailures Class


BuiltInFailures.EnergyAnalysisFailures Class

BuiltInFailuresEnergyAnalysisFailures Class

Failures about EnergyAnalysis.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresEnergyAnalysisFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class EnergyAnalysisFailures
Public NotInheritable Class EnergyAnalysisFailures
public ref class EnergyAnalysisFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type EnergyAnalysisFailures = class end

The BuiltInFailuresEnergyAnalysisFailures type exposes the following members.

Properties
Name | Description
ComputeRoomVolumeNotCheckedWarn | The setting for calculation of Volume Computations is not on. The analysis model produced will be approximate without the computation of Areas and Volumes
ModelWithNoConditionedSpacesWarn | The model has no conditioned spaces.
ModelWithNoOccupiedSpacesWarn | The model has no occupiable spaces.
NoRoofsRoomBoundingWarn | The energy analysis model does not contain any roof surfaces! If there are roofs in your model, please verify that they are room bounding, and make sure that the room offsets are high enough to include the roofs.
NoRoofsSpacesBoundingWarn | The energy analysis model does not contain any roof surfaces! If there are roofs in your model, please verify that they are space bounding, and make sure that the space offsets are high enough to include the roofs.
NoRoomBoundingElements | Can't create any energy analysis surfaces. There are no Room bounding elements defined in the current phase. Please check the Project Information settings.
NoRoomBoundingElementsWarn | Can't create any energy analysis surfaces. There are no Room bounding elements defined in the current phase. Please check the Project Information settings.
NoRoomsWarn | Revit was unable to identify any rooms. If you are sure that rooms have been created in the project, please check the Project Phase setting to verify that the Project Phase matches the phase in which rooms have been defined in your project.
NoSpaceBoundingElements | Can't create any energy analysis surfaces. There are no Space bounding elements defined in the current phase. Please check the Project Information settings.
NoSpaceBoundingElementsWarn | Can't create any energy analysis surfaces. There are no Space bounding elements defined in the current phase. Please check the Project Information settings.
NoSpaces | Revit was unable to identify any spaces. If you are sure that spaces have been created in the project, please check the Project Phase setting to verify that the Project Phase matches the phase in which spaces have been defined in your project.
NoSpacesWarn | Revit was unable to identify any spaces. If you are sure that spaces have been created in the project, please check the Project Phase setting to verify that the Project Phase matches the phase in which spaces have been defined in your project.
PlenumWithNoCeilingWarn | [Room] has Space Type set to Plenum but has no ceiling surface. A plenum must be separated from the space it serves by a ceiling.
ProblemWithLightingLoadWarn | [Room]'s lighting load is too high. This may be caused by an incorrect density value and must be corrected before this space can be included in the load calculations.
ProblemWithPeopleLoadWarn | [Room]'s number of people or people load (sensible or latent) is too high. This may be caused by an incorrect density value and must be corrected before this space can be included in the load calculations.
ProblemWithPowerLoadWarn | [Room]'s power load is too high. This may be caused by an incorrect density value and must be corrected before this space can be included in the load calculations.
RoomGeometryCannotFindFreeFacesBoundingElement | An error occurred while trying to find the free part of a face of the bounding geometry for [Room] when processing the room-bounding element [Name]. The free part of the face is found by subtracting the portions of the face that overlap various room-bounding element faces.
RoomGeometryCannotOverlapBoundingElement | An error occurred while trying to find the region where a face of the bounding geometry for [Room] overlaps a face of a room-bounding element [Name].
RoomGeometryCannotTrimBoundingElement | An error occurred while trimming the vertical shadow of a room-bounding element [Name] of the bounding geometry for [Room].
RoomNotPlacedWarn | [Family] is not placed. Physical properties such as area will display as "Not Placed" in schedules. You can place the [Family] using the option bar in the [Family] tool, or you can delete the [Family] in a schedule. [Room] will be ignored in the energy analysis model.
RoomNotUpperBoundedByElement | [Family] is not upper bounded by a roof, ceiling or floor element. This can result in incorrect adjacencies and voids in the analytical model. Please ensure that Upper Limit and Limit Offset for [Room] is set correctly.
RoomVolumeNegativeWarn | [Room] has a negative volume? [Room] will be ignored in the energy analysis model.
RoomVolumeNotComputedWarn | [Family] volume can't be computed. The bounding geometry (in 3D) can't be found for [Room]. [Room] will be ignored in the energy analysis model.
SpaceResolutionOutOfRange | Voxel size is out of range.
SurfaceResolutionOutOfRange | Pixel size is out of range.
UndefinedRooms | There are undefined Rooms in the model! Recommend creating a Room schedule and checking the Area parameter of each Room for warnings.
UndefinedSpaces | There are undefined Spaces in the model! Recommend creating a Space schedule and checking the Area parameter of each Space for warnings.
ZoneWithoutSpacesWarn | This zone has no spaces.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


EnergyAnalysisFailures Properties

The BuiltInFailuresEnergyAnalysisFailures type exposes the following members.

Properties
Name | Description
ComputeRoomVolumeNotCheckedWarn | The setting for calculation of Volume Computations is not on. The analysis model produced will be approximate without the computation of Areas and Volumes
ModelWithNoConditionedSpacesWarn | The model has no conditioned spaces.
ModelWithNoOccupiedSpacesWarn | The model has no occupiable spaces.
NoRoofsRoomBoundingWarn | The energy analysis model does not contain any roof surfaces! If there are roofs in your model, please verify that they are room bounding, and make sure that the room offsets are high enough to include the roofs.
NoRoofsSpacesBoundingWarn | The energy analysis model does not contain any roof surfaces! If there are roofs in your model, please verify that they are space bounding, and make sure that the space offsets are high enough to include the roofs.
NoRoomBoundingElements | Can't create any energy analysis surfaces. There are no Room bounding elements defined in the current phase. Please check the Project Information settings.
NoRoomBoundingElementsWarn | Can't create any energy analysis surfaces. There are no Room bounding elements defined in the current phase. Please check the Project Information settings.
NoRoomsWarn | Revit was unable to identify any rooms. If you are sure that rooms have been created in the project, please check the Project Phase setting to verify that the Project Phase matches the phase in which rooms have been defined in your project.
NoSpaceBoundingElements | Can't create any energy analysis surfaces. There are no Space bounding elements defined in the current phase. Please check the Project Information settings.
NoSpaceBoundingElementsWarn | Can't create any energy analysis surfaces. There are no Space bounding elements defined in the current phase. Please check the Project Information settings.
NoSpaces | Revit was unable to identify any spaces. If you are sure that spaces have been created in the project, please check the Project Phase setting to verify that the Project Phase matches the phase in which spaces have been defined in your project.
NoSpacesWarn | Revit was unable to identify any spaces. If you are sure that spaces have been created in the project, please check the Project Phase setting to verify that the Project Phase matches the phase in which spaces have been defined in your project.
PlenumWithNoCeilingWarn | [Room] has Space Type set to Plenum but has no ceiling surface. A plenum must be separated from the space it serves by a ceiling.
ProblemWithLightingLoadWarn | [Room]'s lighting load is too high. This may be caused by an incorrect density value and must be corrected before this space can be included in the load calculations.
ProblemWithPeopleLoadWarn | [Room]'s number of people or people load (sensible or latent) is too high. This may be caused by an incorrect density value and must be corrected before this space can be included in the load calculations.
ProblemWithPowerLoadWarn | [Room]'s power load is too high. This may be caused by an incorrect density value and must be corrected before this space can be included in the load calculations.
RoomGeometryCannotFindFreeFacesBoundingElement | An error occurred while trying to find the free part of a face of the bounding geometry for [Room] when processing the room-bounding element [Name]. The free part of the face is found by subtracting the portions of the face that overlap various room-bounding element faces.
RoomGeometryCannotOverlapBoundingElement | An error occurred while trying to find the region where a face of the bounding geometry for [Room] overlaps a face of a room-bounding element [Name].
RoomGeometryCannotTrimBoundingElement | An error occurred while trimming the vertical shadow of a room-bounding element [Name] of the bounding geometry for [Room].
RoomNotPlacedWarn | [Family] is not placed. Physical properties such as area will display as "Not Placed" in schedules. You can place the [Family] using the option bar in the [Family] tool, or you can delete the [Family] in a schedule. [Room] will be ignored in the energy analysis model.
RoomNotUpperBoundedByElement | [Family] is not upper bounded by a roof, ceiling or floor element. This can result in incorrect adjacencies and voids in the analytical model. Please ensure that Upper Limit and Limit Offset for [Room] is set correctly.
RoomVolumeNegativeWarn | [Room] has a negative volume? [Room] will be ignored in the energy analysis model.
RoomVolumeNotComputedWarn | [Family] volume can't be computed. The bounding geometry (in 3D) can't be found for [Room]. [Room] will be ignored in the energy analysis model.
SpaceResolutionOutOfRange | Voxel size is out of range.
SurfaceResolutionOutOfRange | Pixel size is out of range.
UndefinedRooms | There are undefined Rooms in the model! Recommend creating a Room schedule and checking the Area parameter of each Room for warnings.
UndefinedSpaces | There are undefined Spaces in the model! Recommend creating a Space schedule and checking the Area parameter of each Space for warnings.
ZoneWithoutSpacesWarn | This zone has no spaces.
Top
See Also

Reference

BuiltInFailuresEnergyAnalysisFailures Class


BuiltInFailures.EnergyAnalysisFailures.ComputeRoomVolumeNotCheckedWarn Property

BuiltInFailuresEnergyAnalysisFailuresComputeRoomVolumeNotCheckedWarn Property

The setting for calculation of Volume Computations is not on. The analysis model produced will be approximate without the computation of Areas and Volumes

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ComputeRoomVolumeNotCheckedWarn { get; }
Public Shared ReadOnly Property ComputeRoomVolumeNotCheckedWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ComputeRoomVolumeNotCheckedWarn {
    FailureDefinitionId^ get ();
}
static member ComputeRoomVolumeNotCheckedWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEnergyAnalysisFailures Class


BuiltInFailures.EnergyAnalysisFailures.ModelWithNoConditionedSpacesWarn Property

BuiltInFailuresEnergyAnalysisFailuresModelWithNoConditionedSpacesWarn Property

The model has no conditioned spaces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ModelWithNoConditionedSpacesWarn { get; }
Public Shared ReadOnly Property ModelWithNoConditionedSpacesWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ModelWithNoConditionedSpacesWarn {
    FailureDefinitionId^ get ();
}
static member ModelWithNoConditionedSpacesWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEnergyAnalysisFailures Class


BuiltInFailures.EnergyAnalysisFailures.ModelWithNoOccupiedSpacesWarn Property

BuiltInFailuresEnergyAnalysisFailuresModelWithNoOccupiedSpacesWarn Property

The model has no occupiable spaces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ModelWithNoOccupiedSpacesWarn { get; }
Public Shared ReadOnly Property ModelWithNoOccupiedSpacesWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ModelWithNoOccupiedSpacesWarn {
    FailureDefinitionId^ get ();
}
static member ModelWithNoOccupiedSpacesWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEnergyAnalysisFailures Class


BuiltInFailures.EnergyAnalysisFailures.NoRoofsRoomBoundingWarn Property

BuiltInFailuresEnergyAnalysisFailuresNoRoofsRoomBoundingWarn Property

The energy analysis model does not contain any roof surfaces! If there are roofs in your model, please verify that they are room bounding, and make sure that the room offsets are high enough to include the roofs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoRoofsRoomBoundingWarn { get; }
Public Shared ReadOnly Property NoRoofsRoomBoundingWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoRoofsRoomBoundingWarn {
    FailureDefinitionId^ get ();
}
static member NoRoofsRoomBoundingWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEnergyAnalysisFailures Class


BuiltInFailures.EnergyAnalysisFailures.NoRoofsSpacesBoundingWarn Property

BuiltInFailuresEnergyAnalysisFailuresNoRoofsSpacesBoundingWarn Property

The energy analysis model does not contain any roof surfaces! If there are roofs in your model, please verify that they are space bounding, and make sure that the space offsets are high enough to include the roofs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoRoofsSpacesBoundingWarn { get; }
Public Shared ReadOnly Property NoRoofsSpacesBoundingWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoRoofsSpacesBoundingWarn {
    FailureDefinitionId^ get ();
}
static member NoRoofsSpacesBoundingWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEnergyAnalysisFailures Class


BuiltInFailures.EnergyAnalysisFailures.NoRoomBoundingElements Property

BuiltInFailuresEnergyAnalysisFailuresNoRoomBoundingElements Property

Can't create any energy analysis surfaces. There are no Room bounding elements defined in the current phase. Please check the Project Information settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoRoomBoundingElements { get; }
Public Shared ReadOnly Property NoRoomBoundingElements As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoRoomBoundingElements {
    FailureDefinitionId^ get ();
}
static member NoRoomBoundingElements : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEnergyAnalysisFailures Class


BuiltInFailures.EnergyAnalysisFailures.NoRoomBoundingElementsWarn Property

BuiltInFailuresEnergyAnalysisFailuresNoRoomBoundingElementsWarn Property

Can't create any energy analysis surfaces. There are no Room bounding elements defined in the current phase. Please check the Project Information settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoRoomBoundingElementsWarn { get; }
Public Shared ReadOnly Property NoRoomBoundingElementsWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoRoomBoundingElementsWarn {
    FailureDefinitionId^ get ();
}
static member NoRoomBoundingElementsWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEnergyAnalysisFailures Class


BuiltInFailures.EnergyAnalysisFailures.NoRoomsWarn Property

BuiltInFailuresEnergyAnalysisFailuresNoRoomsWarn Property

Revit was unable to identify any rooms. If you are sure that rooms have been created in the project, please check the Project Phase setting to verify that the Project Phase matches the phase in which rooms have been defined in your project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoRoomsWarn { get; }
Public Shared ReadOnly Property NoRoomsWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoRoomsWarn {
    FailureDefinitionId^ get ();
}
static member NoRoomsWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEnergyAnalysisFailures Class


BuiltInFailures.EnergyAnalysisFailures.NoSpaceBoundingElements Property

BuiltInFailuresEnergyAnalysisFailuresNoSpaceBoundingElements Property

Can't create any energy analysis surfaces. There are no Space bounding elements defined in the current phase. Please check the Project Information settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoSpaceBoundingElements { get; }
Public Shared ReadOnly Property NoSpaceBoundingElements As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoSpaceBoundingElements {
    FailureDefinitionId^ get ();
}
static member NoSpaceBoundingElements : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEnergyAnalysisFailures Class


BuiltInFailures.EnergyAnalysisFailures.NoSpaceBoundingElementsWarn Property

BuiltInFailuresEnergyAnalysisFailuresNoSpaceBoundingElementsWarn Property

Can't create any energy analysis surfaces. There are no Space bounding elements defined in the current phase. Please check the Project Information settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoSpaceBoundingElementsWarn { get; }
Public Shared ReadOnly Property NoSpaceBoundingElementsWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoSpaceBoundingElementsWarn {
    FailureDefinitionId^ get ();
}
static member NoSpaceBoundingElementsWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEnergyAnalysisFailures Class


BuiltInFailures.EnergyAnalysisFailures.NoSpaces Property

BuiltInFailuresEnergyAnalysisFailuresNoSpaces Property

Revit was unable to identify any spaces. If you are sure that spaces have been created in the project, please check the Project Phase setting to verify that the Project Phase matches the phase in which spaces have been defined in your project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoSpaces { get; }
Public Shared ReadOnly Property NoSpaces As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoSpaces {
    FailureDefinitionId^ get ();
}
static member NoSpaces : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEnergyAnalysisFailures Class


BuiltInFailures.EnergyAnalysisFailures.NoSpacesWarn Property

BuiltInFailuresEnergyAnalysisFailuresNoSpacesWarn Property

Revit was unable to identify any spaces. If you are sure that spaces have been created in the project, please check the Project Phase setting to verify that the Project Phase matches the phase in which spaces have been defined in your project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoSpacesWarn { get; }
Public Shared ReadOnly Property NoSpacesWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoSpacesWarn {
    FailureDefinitionId^ get ();
}
static member NoSpacesWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEnergyAnalysisFailures Class


BuiltInFailures.EnergyAnalysisFailures.PlenumWithNoCeilingWarn Property

BuiltInFailuresEnergyAnalysisFailuresPlenumWithNoCeilingWarn Property

[Room] has Space Type set to Plenum but has no ceiling surface. A plenum must be separated from the space it serves by a ceiling.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PlenumWithNoCeilingWarn { get; }
Public Shared ReadOnly Property PlenumWithNoCeilingWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PlenumWithNoCeilingWarn {
    FailureDefinitionId^ get ();
}
static member PlenumWithNoCeilingWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEnergyAnalysisFailures Class


BuiltInFailures.EnergyAnalysisFailures.ProblemWithLightingLoadWarn Property

BuiltInFailuresEnergyAnalysisFailuresProblemWithLightingLoadWarn Property

[Room]'s lighting load is too high. This may be caused by an incorrect density value and must be corrected before this space can be included in the load calculations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ProblemWithLightingLoadWarn { get; }
Public Shared ReadOnly Property ProblemWithLightingLoadWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ProblemWithLightingLoadWarn {
    FailureDefinitionId^ get ();
}
static member ProblemWithLightingLoadWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEnergyAnalysisFailures Class


BuiltInFailures.EnergyAnalysisFailures.ProblemWithPeopleLoadWarn Property

BuiltInFailuresEnergyAnalysisFailuresProblemWithPeopleLoadWarn Property

[Room]'s number of people or people load (sensible or latent) is too high. This may be caused by an incorrect density value and must be corrected before this space can be included in the load calculations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ProblemWithPeopleLoadWarn { get; }
Public Shared ReadOnly Property ProblemWithPeopleLoadWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ProblemWithPeopleLoadWarn {
    FailureDefinitionId^ get ();
}
static member ProblemWithPeopleLoadWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEnergyAnalysisFailures Class


BuiltInFailures.EnergyAnalysisFailures.ProblemWithPowerLoadWarn Property

BuiltInFailuresEnergyAnalysisFailuresProblemWithPowerLoadWarn Property

[Room]'s power load is too high. This may be caused by an incorrect density value and must be corrected before this space can be included in the load calculations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ProblemWithPowerLoadWarn { get; }
Public Shared ReadOnly Property ProblemWithPowerLoadWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ProblemWithPowerLoadWarn {
    FailureDefinitionId^ get ();
}
static member ProblemWithPowerLoadWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEnergyAnalysisFailures Class


BuiltInFailures.EnergyAnalysisFailures.RoomGeometryCannotFindFreeFacesBoundingElement Property

BuiltInFailuresEnergyAnalysisFailuresRoomGeometryCannotFindFreeFacesBoundingElement Property

An error occurred while trying to find the free part of a face of the bounding geometry for [Room] when processing the room-bounding element [Name]. The free part of the face is found by subtracting the portions of the face that overlap various room-bounding element faces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RoomGeometryCannotFindFreeFacesBoundingElement { get; }
Public Shared ReadOnly Property RoomGeometryCannotFindFreeFacesBoundingElement As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RoomGeometryCannotFindFreeFacesBoundingElement {
    FailureDefinitionId^ get ();
}
static member RoomGeometryCannotFindFreeFacesBoundingElement : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEnergyAnalysisFailures Class


BuiltInFailures.EnergyAnalysisFailures.RoomGeometryCannotOverlapBoundingElement Property

BuiltInFailuresEnergyAnalysisFailuresRoomGeometryCannotOverlapBoundingElement Property

An error occurred while trying to find the region where a face of the bounding geometry for [Room] overlaps a face of a room-bounding element [Name].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RoomGeometryCannotOverlapBoundingElement { get; }
Public Shared ReadOnly Property RoomGeometryCannotOverlapBoundingElement As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RoomGeometryCannotOverlapBoundingElement {
    FailureDefinitionId^ get ();
}
static member RoomGeometryCannotOverlapBoundingElement : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEnergyAnalysisFailures Class


BuiltInFailures.EnergyAnalysisFailures.RoomGeometryCannotTrimBoundingElement Property

BuiltInFailuresEnergyAnalysisFailuresRoomGeometryCannotTrimBoundingElement Property

An error occurred while trimming the vertical shadow of a room-bounding element [Name] of the bounding geometry for [Room].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RoomGeometryCannotTrimBoundingElement { get; }
Public Shared ReadOnly Property RoomGeometryCannotTrimBoundingElement As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RoomGeometryCannotTrimBoundingElement {
    FailureDefinitionId^ get ();
}
static member RoomGeometryCannotTrimBoundingElement : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEnergyAnalysisFailures Class


BuiltInFailures.EnergyAnalysisFailures.RoomNotPlacedWarn Property

BuiltInFailuresEnergyAnalysisFailuresRoomNotPlacedWarn Property

[Family] is not placed. Physical properties such as area will display as "Not Placed" in schedules. You can place the [Family] using the option bar in the [Family] tool, or you can delete the [Family] in a schedule. [Room] will be ignored in the energy analysis model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RoomNotPlacedWarn { get; }
Public Shared ReadOnly Property RoomNotPlacedWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RoomNotPlacedWarn {
    FailureDefinitionId^ get ();
}
static member RoomNotPlacedWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEnergyAnalysisFailures Class


BuiltInFailures.EnergyAnalysisFailures.RoomNotUpperBoundedByElement Property

BuiltInFailuresEnergyAnalysisFailuresRoomNotUpperBoundedByElement Property

[Family] is not upper bounded by a roof, ceiling or floor element. This can result in incorrect adjacencies and voids in the analytical model. Please ensure that Upper Limit and Limit Offset for [Room] is set correctly.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RoomNotUpperBoundedByElement { get; }
Public Shared ReadOnly Property RoomNotUpperBoundedByElement As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RoomNotUpperBoundedByElement {
    FailureDefinitionId^ get ();
}
static member RoomNotUpperBoundedByElement : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEnergyAnalysisFailures Class


BuiltInFailures.EnergyAnalysisFailures.RoomVolumeNegativeWarn Property

BuiltInFailuresEnergyAnalysisFailuresRoomVolumeNegativeWarn Property

[Room] has a negative volume? [Room] will be ignored in the energy analysis model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RoomVolumeNegativeWarn { get; }
Public Shared ReadOnly Property RoomVolumeNegativeWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RoomVolumeNegativeWarn {
    FailureDefinitionId^ get ();
}
static member RoomVolumeNegativeWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEnergyAnalysisFailures Class


BuiltInFailures.EnergyAnalysisFailures.RoomVolumeNotComputedWarn Property

BuiltInFailuresEnergyAnalysisFailuresRoomVolumeNotComputedWarn Property

[Family] volume can't be computed. The bounding geometry (in 3D) can't be found for [Room]. [Room] will be ignored in the energy analysis model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RoomVolumeNotComputedWarn { get; }
Public Shared ReadOnly Property RoomVolumeNotComputedWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RoomVolumeNotComputedWarn {
    FailureDefinitionId^ get ();
}
static member RoomVolumeNotComputedWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEnergyAnalysisFailures Class


BuiltInFailures.EnergyAnalysisFailures.SpaceResolutionOutOfRange Property

BuiltInFailuresEnergyAnalysisFailuresSpaceResolutionOutOfRange Property

Voxel size is out of range.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SpaceResolutionOutOfRange { get; }
Public Shared ReadOnly Property SpaceResolutionOutOfRange As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SpaceResolutionOutOfRange {
    FailureDefinitionId^ get ();
}
static member SpaceResolutionOutOfRange : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEnergyAnalysisFailures Class


BuiltInFailures.EnergyAnalysisFailures.SurfaceResolutionOutOfRange Property

BuiltInFailuresEnergyAnalysisFailuresSurfaceResolutionOutOfRange Property

Pixel size is out of range.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SurfaceResolutionOutOfRange { get; }
Public Shared ReadOnly Property SurfaceResolutionOutOfRange As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SurfaceResolutionOutOfRange {
    FailureDefinitionId^ get ();
}
static member SurfaceResolutionOutOfRange : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEnergyAnalysisFailures Class


BuiltInFailures.EnergyAnalysisFailures.UndefinedRooms Property

BuiltInFailuresEnergyAnalysisFailuresUndefinedRooms Property

There are undefined Rooms in the model! Recommend creating a Room schedule and checking the Area parameter of each Room for warnings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UndefinedRooms { get; }
Public Shared ReadOnly Property UndefinedRooms As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UndefinedRooms {
    FailureDefinitionId^ get ();
}
static member UndefinedRooms : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEnergyAnalysisFailures Class


BuiltInFailures.EnergyAnalysisFailures.UndefinedSpaces Property

BuiltInFailuresEnergyAnalysisFailuresUndefinedSpaces Property

There are undefined Spaces in the model! Recommend creating a Space schedule and checking the Area parameter of each Space for warnings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UndefinedSpaces { get; }
Public Shared ReadOnly Property UndefinedSpaces As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UndefinedSpaces {
    FailureDefinitionId^ get ();
}
static member UndefinedSpaces : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEnergyAnalysisFailures Class


BuiltInFailures.EnergyAnalysisFailures.ZoneWithoutSpacesWarn Property

BuiltInFailuresEnergyAnalysisFailuresZoneWithoutSpacesWarn Property

This zone has no spaces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ZoneWithoutSpacesWarn { get; }
Public Shared ReadOnly Property ZoneWithoutSpacesWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ZoneWithoutSpacesWarn {
    FailureDefinitionId^ get ();
}
static member ZoneWithoutSpacesWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEnergyAnalysisFailures Class


BuiltInFailures.EnergyAnalysisUtilitiesDBFailures Class

BuiltInFailuresEnergyAnalysisUtilitiesDBFailures Class

Failures about EnergyAnalysisUtilitiesDBFailures.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresEnergyAnalysisUtilitiesDBFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class EnergyAnalysisUtilitiesDBFailures
Public NotInheritable Class EnergyAnalysisUtilitiesDBFailures
public ref class EnergyAnalysisUtilitiesDBFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type EnergyAnalysisUtilitiesDBFailures = class end

The BuiltInFailuresEnergyAnalysisUtilitiesDBFailures type exposes the following members.

Properties
Name | Description
AimErrEmptyName | MassZone '%1' has empty name and id values which cannot be used as gbXML identifiers.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


EnergyAnalysisUtilitiesDBFailures Properties

The BuiltInFailuresEnergyAnalysisUtilitiesDBFailures type exposes the following members.

Properties
Name | Description
AimErrEmptyName | MassZone '%1' has empty name and id values which cannot be used as gbXML identifiers.
Top
See Also

Reference

BuiltInFailuresEnergyAnalysisUtilitiesDBFailures Class


BuiltInFailures.EnergyAnalysisUtilitiesDBFailures.AimErrEmptyName Property

BuiltInFailuresEnergyAnalysisUtilitiesDBFailuresAimErrEmptyName Property

MassZone '%1' has empty name and id values which cannot be used as gbXML identifiers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AimErrEmptyName { get; }
Public Shared ReadOnly Property AimErrEmptyName As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AimErrEmptyName {
    FailureDefinitionId^ get ();
}
static member AimErrEmptyName : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresEnergyAnalysisUtilitiesDBFailures Class


BuiltInFailures.ExportFailures Class

BuiltInFailuresExportFailures Class

Failures about ExportFailures.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresExportFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ExportFailures
Public NotInheritable Class ExportFailures
public ref class ExportFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ExportFailures = class end

The BuiltInFailuresExportFailures type exposes the following members.

Properties
Name | Description
IFCFatalExportError | There has been an unrecoverable error during export. Export will now be aborted.
IFCFatalToolkitExportError | There has been an unrecoverable error during export. Export will now be aborted.
IFCGenericExportWarning | Unexpected errors occurred while exporting these elements to the IFC file.
SwitchToRasterProcessingInsteadOfVectorWarning | Some of the views have been switched to raster processing though vector processing is selected.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExportFailures Properties

The BuiltInFailuresExportFailures type exposes the following members.

Properties
Name | Description
IFCFatalExportError | There has been an unrecoverable error during export. Export will now be aborted.
IFCFatalToolkitExportError | There has been an unrecoverable error during export. Export will now be aborted.
IFCGenericExportWarning | Unexpected errors occurred while exporting these elements to the IFC file.
SwitchToRasterProcessingInsteadOfVectorWarning | Some of the views have been switched to raster processing though vector processing is selected.
Top
See Also

Reference

BuiltInFailuresExportFailures Class


BuiltInFailures.ExportFailures.IFCFatalExportError Property

BuiltInFailuresExportFailuresIFCFatalExportError Property

There has been an unrecoverable error during export. Export will now be aborted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId IFCFatalExportError { get; }
Public Shared ReadOnly Property IFCFatalExportError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ IFCFatalExportError {
    FailureDefinitionId^ get ();
}
static member IFCFatalExportError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresExportFailures Class


BuiltInFailures.ExportFailures.IFCFatalToolkitExportError Property

BuiltInFailuresExportFailuresIFCFatalToolkitExportError Property

There has been an unrecoverable error during export. Export will now be aborted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId IFCFatalToolkitExportError { get; }
Public Shared ReadOnly Property IFCFatalToolkitExportError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ IFCFatalToolkitExportError {
    FailureDefinitionId^ get ();
}
static member IFCFatalToolkitExportError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresExportFailures Class


BuiltInFailures.ExportFailures.IFCGenericExportWarning Property

BuiltInFailuresExportFailuresIFCGenericExportWarning Property

Unexpected errors occurred while exporting these elements to the IFC file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId IFCGenericExportWarning { get; }
Public Shared ReadOnly Property IFCGenericExportWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ IFCGenericExportWarning {
    FailureDefinitionId^ get ();
}
static member IFCGenericExportWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresExportFailures Class


BuiltInFailures.ExportFailures.SwitchToRasterProcessingInsteadOfVectorWarning Property

BuiltInFailuresExportFailuresSwitchToRasterProcessingInsteadOfVectorWarning Property

Some of the views have been switched to raster processing though vector processing is selected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SwitchToRasterProcessingInsteadOfVectorWarning { get; }
Public Shared ReadOnly Property SwitchToRasterProcessingInsteadOfVectorWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SwitchToRasterProcessingInsteadOfVectorWarning {
    FailureDefinitionId^ get ();
}
static member SwitchToRasterProcessingInsteadOfVectorWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresExportFailures Class


BuiltInFailures.ExternalResourceReferenceFailures Class

BuiltInFailuresExternalResourceReferenceFailures Class

Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresExternalResourceReferenceFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ExternalResourceReferenceFailures
Public NotInheritable Class ExternalResourceReferenceFailures
public ref class ExternalResourceReferenceFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ExternalResourceReferenceFailures = class end

The BuiltInFailuresExternalResourceReferenceFailures type exposes the following members.

Properties
Name | Description
ReferenceToLocalFile | The External Resource refers to a local file that may not be available to workshared users.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExternalResourceReferenceFailures Properties

The BuiltInFailuresExternalResourceReferenceFailures type exposes the following members.

Properties
Name | Description
ReferenceToLocalFile | The External Resource refers to a local file that may not be available to workshared users.
Top
See Also

Reference

BuiltInFailuresExternalResourceReferenceFailures Class


BuiltInFailures.ExternalResourceReferenceFailures.ReferenceToLocalFile Property

BuiltInFailuresExternalResourceReferenceFailuresReferenceToLocalFile Property

The External Resource refers to a local file that may not be available to workshared users.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ReferenceToLocalFile { get; }
Public Shared ReadOnly Property ReferenceToLocalFile As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ReferenceToLocalFile {
    FailureDefinitionId^ get ();
}
static member ReferenceToLocalFile : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresExternalResourceReferenceFailures Class


BuiltInFailures.ExtrusionFailures Class

BuiltInFailuresExtrusionFailures Class

Failures about Extrusions.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresExtrusionFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ExtrusionFailures
Public NotInheritable Class ExtrusionFailures
public ref class ExtrusionFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ExtrusionFailures = class end

The BuiltInFailuresExtrusionFailures type exposes the following members.

Properties
Name | Description
CannotDrawExtrusions | Can't make Extrusion.
CannotDrawExtrusionsError | Can't make Extrusion.
ExtrusionTooThin | Extrusion is too thin.
InvalidExtrusionCurveloop | Base sketch for extrusion is invalid.
InvalidExtrusionCurveloopError | Base sketch for extrusion is invalid.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExtrusionFailures Properties

The BuiltInFailuresExtrusionFailures type exposes the following members.

Properties
Name | Description
CannotDrawExtrusions | Can't make Extrusion.
CannotDrawExtrusionsError | Can't make Extrusion.
ExtrusionTooThin | Extrusion is too thin.
InvalidExtrusionCurveloop | Base sketch for extrusion is invalid.
InvalidExtrusionCurveloopError | Base sketch for extrusion is invalid.
Top
See Also

Reference

BuiltInFailuresExtrusionFailures Class


BuiltInFailures.ExtrusionFailures.CannotDrawExtrusions Property

BuiltInFailuresExtrusionFailuresCannotDrawExtrusions Property

Can't make Extrusion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotDrawExtrusions { get; }
Public Shared ReadOnly Property CannotDrawExtrusions As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotDrawExtrusions {
    FailureDefinitionId^ get ();
}
static member CannotDrawExtrusions : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresExtrusionFailures Class


BuiltInFailures.ExtrusionFailures.CannotDrawExtrusionsError Property

BuiltInFailuresExtrusionFailuresCannotDrawExtrusionsError Property

Can't make Extrusion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotDrawExtrusionsError { get; }
Public Shared ReadOnly Property CannotDrawExtrusionsError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotDrawExtrusionsError {
    FailureDefinitionId^ get ();
}
static member CannotDrawExtrusionsError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresExtrusionFailures Class


BuiltInFailures.ExtrusionFailures.ExtrusionTooThin Property

BuiltInFailuresExtrusionFailuresExtrusionTooThin Property

Extrusion is too thin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ExtrusionTooThin { get; }
Public Shared ReadOnly Property ExtrusionTooThin As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ExtrusionTooThin {
    FailureDefinitionId^ get ();
}
static member ExtrusionTooThin : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresExtrusionFailures Class


BuiltInFailures.ExtrusionFailures.InvalidExtrusionCurveloop Property

BuiltInFailuresExtrusionFailuresInvalidExtrusionCurveloop Property

Base sketch for extrusion is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidExtrusionCurveloop { get; }
Public Shared ReadOnly Property InvalidExtrusionCurveloop As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidExtrusionCurveloop {
    FailureDefinitionId^ get ();
}
static member InvalidExtrusionCurveloop : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresExtrusionFailures Class


BuiltInFailures.ExtrusionFailures.InvalidExtrusionCurveloopError Property

BuiltInFailuresExtrusionFailuresInvalidExtrusionCurveloopError Property

Base sketch for extrusion is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidExtrusionCurveloopError { get; }
Public Shared ReadOnly Property InvalidExtrusionCurveloopError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidExtrusionCurveloopError {
    FailureDefinitionId^ get ();
}
static member InvalidExtrusionCurveloopError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresExtrusionFailures Class


BuiltInFailures.FabricAreaFailures Class

BuiltInFailuresFabricAreaFailures Class

Failures related to fabric area elements.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresFabricAreaFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class FabricAreaFailures
Public NotInheritable Class FabricAreaFailures
public ref class FabricAreaFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type FabricAreaFailures = class end

The BuiltInFailuresFabricAreaFailures type exposes the following members.

Properties
Name | Description
FabricAreaLapSplicesIncorrect | Fabric Area lap splice is incorrect.
FabricAreaOutSideOfHost | Fabric Area is sketched completely outside of its host.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FabricAreaFailures Properties

The BuiltInFailuresFabricAreaFailures type exposes the following members.

Properties
Name | Description
FabricAreaLapSplicesIncorrect | Fabric Area lap splice is incorrect.
FabricAreaOutSideOfHost | Fabric Area is sketched completely outside of its host.
Top
See Also

Reference

BuiltInFailuresFabricAreaFailures Class


BuiltInFailures.FabricAreaFailures.FabricAreaLapSplicesIncorrect Property

BuiltInFailuresFabricAreaFailuresFabricAreaLapSplicesIncorrect Property

Fabric Area lap splice is incorrect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricAreaLapSplicesIncorrect { get; }
Public Shared ReadOnly Property FabricAreaLapSplicesIncorrect As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricAreaLapSplicesIncorrect {
    FailureDefinitionId^ get ();
}
static member FabricAreaLapSplicesIncorrect : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFabricAreaFailures Class


BuiltInFailures.FabricAreaFailures.FabricAreaOutSideOfHost Property

BuiltInFailuresFabricAreaFailuresFabricAreaOutSideOfHost Property

Fabric Area is sketched completely outside of its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricAreaOutSideOfHost { get; }
Public Shared ReadOnly Property FabricAreaOutSideOfHost As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricAreaOutSideOfHost {
    FailureDefinitionId^ get ();
}
static member FabricAreaOutSideOfHost : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFabricAreaFailures Class


BuiltInFailures.FabricFailures Class

BuiltInFailuresFabricFailures Class

Failures about Fabric.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresFabricFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class FabricFailures
Public NotInheritable Class FabricFailures
public ref class FabricFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type FabricFailures = class end

The BuiltInFailuresFabricFailures type exposes the following members.

Properties
Name | Description
BendDiameterNegative | Fabric Bend Diameter is negative.
BendPolylineInvalid | The bend profile contains too short of a segment to apply the wire bend diameter. Cannot create a bent fabric sheet for this type.
BentHiddenWires | The wires of this custom fabric sheet type are longer than the bending sketch. The linear quantities shown in schedules and tags are not accurate.
CannotPlaceFabricArea | Can't find a host for Fabric Area.
CannotPlaceFabricAreaWarn | Can't find a host for Fabric Area.
CannotPlaceFabricSheet | Can't find a host for Fabric Sheet.
CannotPlaceFabricSheetWarn | Can't find a host for Fabric Sheet.
CoverOffsetTooLong | Cover offset is greater than host thickness.
CoverOffsetTooLongTemp | Cover offset is greater than host thickness - support for transient Single Fabric Sheet in editor.
FabricAreaWrongHost | Fabric Area can be placed only in Structural Floors and straight Structural Walls.
FabricAreaWrongLapSplice | Fabric Area Sheet lap splice is incorrect. Can't create Fabric Area.
FabricAreaWrongSheetAlignment | Fabric Area Sheet Alignment is incorrect. Can't create Fabric Area.
FabricSheetWrongHost | Fabric Sheet can be placed only in Structural Floors and straight Structural Walls.
MajorLapSpliceFailure | The lap splice in the major direction is greater than the half of the overall length.
MajorOverhangFailure | At least one of the overhangs in the major direction is lower than radius of the wire in the minor direction.
MajorSpacingFailure | The spacing in the major direction is lower than diameter of the wire in the minor direction.
MinorLapSpliceFailure | The lap splice in the minor direction is greater than the half of the overall width.
MinorOverhangFailure | At least one of the overhangs in the minor direction is lower than radius of the wire in the major direction.
MinorSpacingFailure | The spacing in the minor direction is lower than diameter of the wire in the major direction.
NoSurfPatternOnWire | Wire elements do not support surface patterns. The surface pattern associated with this material will not be displayed on the indicated Fabric Sheet Type.
NoWireMaterialDensity | Material does not have a density defined. The weight of the Fabric Sheet cannot be computed.
WireDiameterTooLarge | Fabric Wire Diameter is too large.
WrongFabricSheetEndOverhang | Wrong Start Overhang of the Fabric Sheet Type.
WrongFabricSheetLayoutPattern | The Layout Pattern cannot accommodate the current data. Try decreasing the Number of Wires/Spacing.
WrongFabricSheetNumberOfWires | Wrong Number of Wires of the Fabric Sheet Type.
WrongFabricSheetOverallLength | Wrong Overall Length/Width of the Fabric Sheet Type.
WrongFabricSheetSpacing | Wrong Spacing of the Fabric Sheet Type.
WrongFabricSheetStartOverhang | Wrong Start Overhang of the Fabric Sheet Type.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FabricFailures Properties

The BuiltInFailuresFabricFailures type exposes the following members.

Properties
Name | Description
BendDiameterNegative | Fabric Bend Diameter is negative.
BendPolylineInvalid | The bend profile contains too short of a segment to apply the wire bend diameter. Cannot create a bent fabric sheet for this type.
BentHiddenWires | The wires of this custom fabric sheet type are longer than the bending sketch. The linear quantities shown in schedules and tags are not accurate.
CannotPlaceFabricArea | Can't find a host for Fabric Area.
CannotPlaceFabricAreaWarn | Can't find a host for Fabric Area.
CannotPlaceFabricSheet | Can't find a host for Fabric Sheet.
CannotPlaceFabricSheetWarn | Can't find a host for Fabric Sheet.
CoverOffsetTooLong | Cover offset is greater than host thickness.
CoverOffsetTooLongTemp | Cover offset is greater than host thickness - support for transient Single Fabric Sheet in editor.
FabricAreaWrongHost | Fabric Area can be placed only in Structural Floors and straight Structural Walls.
FabricAreaWrongLapSplice | Fabric Area Sheet lap splice is incorrect. Can't create Fabric Area.
FabricAreaWrongSheetAlignment | Fabric Area Sheet Alignment is incorrect. Can't create Fabric Area.
FabricSheetWrongHost | Fabric Sheet can be placed only in Structural Floors and straight Structural Walls.
MajorLapSpliceFailure | The lap splice in the major direction is greater than the half of the overall length.
MajorOverhangFailure | At least one of the overhangs in the major direction is lower than radius of the wire in the minor direction.
MajorSpacingFailure | The spacing in the major direction is lower than diameter of the wire in the minor direction.
MinorLapSpliceFailure | The lap splice in the minor direction is greater than the half of the overall width.
MinorOverhangFailure | At least one of the overhangs in the minor direction is lower than radius of the wire in the major direction.
MinorSpacingFailure | The spacing in the minor direction is lower than diameter of the wire in the major direction.
NoSurfPatternOnWire | Wire elements do not support surface patterns. The surface pattern associated with this material will not be displayed on the indicated Fabric Sheet Type.
NoWireMaterialDensity | Material does not have a density defined. The weight of the Fabric Sheet cannot be computed.
WireDiameterTooLarge | Fabric Wire Diameter is too large.
WrongFabricSheetEndOverhang | Wrong Start Overhang of the Fabric Sheet Type.
WrongFabricSheetLayoutPattern | The Layout Pattern cannot accommodate the current data. Try decreasing the Number of Wires/Spacing.
WrongFabricSheetNumberOfWires | Wrong Number of Wires of the Fabric Sheet Type.
WrongFabricSheetOverallLength | Wrong Overall Length/Width of the Fabric Sheet Type.
WrongFabricSheetSpacing | Wrong Spacing of the Fabric Sheet Type.
WrongFabricSheetStartOverhang | Wrong Start Overhang of the Fabric Sheet Type.
Top
See Also

Reference

BuiltInFailuresFabricFailures Class


BuiltInFailures.FabricFailures.BendDiameterNegative Property

BuiltInFailuresFabricFailuresBendDiameterNegative Property

Fabric Bend Diameter is negative.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BendDiameterNegative { get; }
Public Shared ReadOnly Property BendDiameterNegative As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BendDiameterNegative {
    FailureDefinitionId^ get ();
}
static member BendDiameterNegative : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFabricFailures Class


BuiltInFailures.FabricFailures.BendPolylineInvalid Property

BuiltInFailuresFabricFailuresBendPolylineInvalid Property

The bend profile contains too short of a segment to apply the wire bend diameter. Cannot create a bent fabric sheet for this type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BendPolylineInvalid { get; }
Public Shared ReadOnly Property BendPolylineInvalid As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BendPolylineInvalid {
    FailureDefinitionId^ get ();
}
static member BendPolylineInvalid : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFabricFailures Class


BuiltInFailures.FabricFailures.BentHiddenWires Property

BuiltInFailuresFabricFailuresBentHiddenWires Property

The wires of this custom fabric sheet type are longer than the bending sketch. The linear quantities shown in schedules and tags are not accurate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BentHiddenWires { get; }
Public Shared ReadOnly Property BentHiddenWires As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BentHiddenWires {
    FailureDefinitionId^ get ();
}
static member BentHiddenWires : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFabricFailures Class


BuiltInFailures.FabricFailures.CannotPlaceFabricArea Property

BuiltInFailuresFabricFailuresCannotPlaceFabricArea Property

Can't find a host for Fabric Area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPlaceFabricArea { get; }
Public Shared ReadOnly Property CannotPlaceFabricArea As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPlaceFabricArea {
    FailureDefinitionId^ get ();
}
static member CannotPlaceFabricArea : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFabricFailures Class


BuiltInFailures.FabricFailures.CannotPlaceFabricAreaWarn Property

BuiltInFailuresFabricFailuresCannotPlaceFabricAreaWarn Property

Can't find a host for Fabric Area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPlaceFabricAreaWarn { get; }
Public Shared ReadOnly Property CannotPlaceFabricAreaWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPlaceFabricAreaWarn {
    FailureDefinitionId^ get ();
}
static member CannotPlaceFabricAreaWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFabricFailures Class


BuiltInFailures.FabricFailures.CannotPlaceFabricSheet Property

BuiltInFailuresFabricFailuresCannotPlaceFabricSheet Property

Can't find a host for Fabric Sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPlaceFabricSheet { get; }
Public Shared ReadOnly Property CannotPlaceFabricSheet As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPlaceFabricSheet {
    FailureDefinitionId^ get ();
}
static member CannotPlaceFabricSheet : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFabricFailures Class


BuiltInFailures.FabricFailures.CannotPlaceFabricSheetWarn Property

BuiltInFailuresFabricFailuresCannotPlaceFabricSheetWarn Property

Can't find a host for Fabric Sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPlaceFabricSheetWarn { get; }
Public Shared ReadOnly Property CannotPlaceFabricSheetWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPlaceFabricSheetWarn {
    FailureDefinitionId^ get ();
}
static member CannotPlaceFabricSheetWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFabricFailures Class


BuiltInFailures.FabricFailures.CoverOffsetTooLong Property

BuiltInFailuresFabricFailuresCoverOffsetTooLong Property

Cover offset is greater than host thickness.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CoverOffsetTooLong { get; }
Public Shared ReadOnly Property CoverOffsetTooLong As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CoverOffsetTooLong {
    FailureDefinitionId^ get ();
}
static member CoverOffsetTooLong : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFabricFailures Class


BuiltInFailures.FabricFailures.CoverOffsetTooLongTemp Property

BuiltInFailuresFabricFailuresCoverOffsetTooLongTemp Property

Cover offset is greater than host thickness - support for transient Single Fabric Sheet in editor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CoverOffsetTooLongTemp { get; }
Public Shared ReadOnly Property CoverOffsetTooLongTemp As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CoverOffsetTooLongTemp {
    FailureDefinitionId^ get ();
}
static member CoverOffsetTooLongTemp : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFabricFailures Class


BuiltInFailures.FabricFailures.FabricAreaWrongHost Property

BuiltInFailuresFabricFailuresFabricAreaWrongHost Property

Fabric Area can be placed only in Structural Floors and straight Structural Walls.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricAreaWrongHost { get; }
Public Shared ReadOnly Property FabricAreaWrongHost As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricAreaWrongHost {
    FailureDefinitionId^ get ();
}
static member FabricAreaWrongHost : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFabricFailures Class


BuiltInFailures.FabricFailures.FabricAreaWrongLapSplice Property

BuiltInFailuresFabricFailuresFabricAreaWrongLapSplice Property

Fabric Area Sheet lap splice is incorrect. Can't create Fabric Area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricAreaWrongLapSplice { get; }
Public Shared ReadOnly Property FabricAreaWrongLapSplice As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricAreaWrongLapSplice {
    FailureDefinitionId^ get ();
}
static member FabricAreaWrongLapSplice : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFabricFailures Class


BuiltInFailures.FabricFailures.FabricAreaWrongSheetAlignment Property

BuiltInFailuresFabricFailuresFabricAreaWrongSheetAlignment Property

Fabric Area Sheet Alignment is incorrect. Can't create Fabric Area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricAreaWrongSheetAlignment { get; }
Public Shared ReadOnly Property FabricAreaWrongSheetAlignment As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricAreaWrongSheetAlignment {
    FailureDefinitionId^ get ();
}
static member FabricAreaWrongSheetAlignment : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFabricFailures Class


BuiltInFailures.FabricFailures.FabricSheetWrongHost Property

BuiltInFailuresFabricFailuresFabricSheetWrongHost Property

Fabric Sheet can be placed only in Structural Floors and straight Structural Walls.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricSheetWrongHost { get; }
Public Shared ReadOnly Property FabricSheetWrongHost As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricSheetWrongHost {
    FailureDefinitionId^ get ();
}
static member FabricSheetWrongHost : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFabricFailures Class


BuiltInFailures.FabricFailures.MajorLapSpliceFailure Property

BuiltInFailuresFabricFailuresMajorLapSpliceFailure Property

The lap splice in the major direction is greater than the half of the overall length.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MajorLapSpliceFailure { get; }
Public Shared ReadOnly Property MajorLapSpliceFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MajorLapSpliceFailure {
    FailureDefinitionId^ get ();
}
static member MajorLapSpliceFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFabricFailures Class


BuiltInFailures.FabricFailures.MajorOverhangFailure Property

BuiltInFailuresFabricFailuresMajorOverhangFailure Property

At least one of the overhangs in the major direction is lower than radius of the wire in the minor direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MajorOverhangFailure { get; }
Public Shared ReadOnly Property MajorOverhangFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MajorOverhangFailure {
    FailureDefinitionId^ get ();
}
static member MajorOverhangFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFabricFailures Class


BuiltInFailures.FabricFailures.MajorSpacingFailure Property

BuiltInFailuresFabricFailuresMajorSpacingFailure Property

The spacing in the major direction is lower than diameter of the wire in the minor direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MajorSpacingFailure { get; }
Public Shared ReadOnly Property MajorSpacingFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MajorSpacingFailure {
    FailureDefinitionId^ get ();
}
static member MajorSpacingFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFabricFailures Class


BuiltInFailures.FabricFailures.MinorLapSpliceFailure Property

BuiltInFailuresFabricFailuresMinorLapSpliceFailure Property

The lap splice in the minor direction is greater than the half of the overall width.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MinorLapSpliceFailure { get; }
Public Shared ReadOnly Property MinorLapSpliceFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MinorLapSpliceFailure {
    FailureDefinitionId^ get ();
}
static member MinorLapSpliceFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFabricFailures Class


BuiltInFailures.FabricFailures.MinorOverhangFailure Property

BuiltInFailuresFabricFailuresMinorOverhangFailure Property

At least one of the overhangs in the minor direction is lower than radius of the wire in the major direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MinorOverhangFailure { get; }
Public Shared ReadOnly Property MinorOverhangFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MinorOverhangFailure {
    FailureDefinitionId^ get ();
}
static member MinorOverhangFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFabricFailures Class


BuiltInFailures.FabricFailures.MinorSpacingFailure Property

BuiltInFailuresFabricFailuresMinorSpacingFailure Property

The spacing in the minor direction is lower than diameter of the wire in the major direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MinorSpacingFailure { get; }
Public Shared ReadOnly Property MinorSpacingFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MinorSpacingFailure {
    FailureDefinitionId^ get ();
}
static member MinorSpacingFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFabricFailures Class


BuiltInFailures.FabricFailures.NoSurfPatternOnWire Property

BuiltInFailuresFabricFailuresNoSurfPatternOnWire Property

Wire elements do not support surface patterns. The surface pattern associated with this material will not be displayed on the indicated Fabric Sheet Type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoSurfPatternOnWire { get; }
Public Shared ReadOnly Property NoSurfPatternOnWire As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoSurfPatternOnWire {
    FailureDefinitionId^ get ();
}
static member NoSurfPatternOnWire : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFabricFailures Class


BuiltInFailures.FabricFailures.NoWireMaterialDensity Property

BuiltInFailuresFabricFailuresNoWireMaterialDensity Property

Material does not have a density defined. The weight of the Fabric Sheet cannot be computed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoWireMaterialDensity { get; }
Public Shared ReadOnly Property NoWireMaterialDensity As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoWireMaterialDensity {
    FailureDefinitionId^ get ();
}
static member NoWireMaterialDensity : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFabricFailures Class


BuiltInFailures.FabricFailures.WireDiameterTooLarge Property

BuiltInFailuresFabricFailuresWireDiameterTooLarge Property

Fabric Wire Diameter is too large.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WireDiameterTooLarge { get; }
Public Shared ReadOnly Property WireDiameterTooLarge As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WireDiameterTooLarge {
    FailureDefinitionId^ get ();
}
static member WireDiameterTooLarge : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFabricFailures Class


BuiltInFailures.FabricFailures.WrongFabricSheetEndOverhang Property

BuiltInFailuresFabricFailuresWrongFabricSheetEndOverhang Property

Wrong Start Overhang of the Fabric Sheet Type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WrongFabricSheetEndOverhang { get; }
Public Shared ReadOnly Property WrongFabricSheetEndOverhang As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WrongFabricSheetEndOverhang {
    FailureDefinitionId^ get ();
}
static member WrongFabricSheetEndOverhang : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFabricFailures Class


BuiltInFailures.FabricFailures.WrongFabricSheetLayoutPattern Property

BuiltInFailuresFabricFailuresWrongFabricSheetLayoutPattern Property

The Layout Pattern cannot accommodate the current data. Try decreasing the Number of Wires/Spacing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WrongFabricSheetLayoutPattern { get; }
Public Shared ReadOnly Property WrongFabricSheetLayoutPattern As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WrongFabricSheetLayoutPattern {
    FailureDefinitionId^ get ();
}
static member WrongFabricSheetLayoutPattern : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFabricFailures Class


BuiltInFailures.FabricFailures.WrongFabricSheetNumberOfWires Property

BuiltInFailuresFabricFailuresWrongFabricSheetNumberOfWires Property

Wrong Number of Wires of the Fabric Sheet Type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WrongFabricSheetNumberOfWires { get; }
Public Shared ReadOnly Property WrongFabricSheetNumberOfWires As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WrongFabricSheetNumberOfWires {
    FailureDefinitionId^ get ();
}
static member WrongFabricSheetNumberOfWires : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFabricFailures Class


BuiltInFailures.FabricFailures.WrongFabricSheetOverallLength Property

BuiltInFailuresFabricFailuresWrongFabricSheetOverallLength Property

Wrong Overall Length/Width of the Fabric Sheet Type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WrongFabricSheetOverallLength { get; }
Public Shared ReadOnly Property WrongFabricSheetOverallLength As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WrongFabricSheetOverallLength {
    FailureDefinitionId^ get ();
}
static member WrongFabricSheetOverallLength : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFabricFailures Class


BuiltInFailures.FabricFailures.WrongFabricSheetSpacing Property

BuiltInFailuresFabricFailuresWrongFabricSheetSpacing Property

Wrong Spacing of the Fabric Sheet Type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WrongFabricSheetSpacing { get; }
Public Shared ReadOnly Property WrongFabricSheetSpacing As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WrongFabricSheetSpacing {
    FailureDefinitionId^ get ();
}
static member WrongFabricSheetSpacing : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFabricFailures Class


BuiltInFailures.FabricFailures.WrongFabricSheetStartOverhang Property

BuiltInFailuresFabricFailuresWrongFabricSheetStartOverhang Property

Wrong Start Overhang of the Fabric Sheet Type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WrongFabricSheetStartOverhang { get; }
Public Shared ReadOnly Property WrongFabricSheetStartOverhang As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WrongFabricSheetStartOverhang {
    FailureDefinitionId^ get ();
}
static member WrongFabricSheetStartOverhang : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFabricFailures Class


BuiltInFailures.FabricSheetFailures Class

BuiltInFailuresFabricSheetFailures Class

Failures related to fabric sheet elements.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresFabricSheetFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class FabricSheetFailures
Public NotInheritable Class FabricSheetFailures
public ref class FabricSheetFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type FabricSheetFailures = class end

The BuiltInFailuresFabricSheetFailures type exposes the following members.

Properties
Name | Description
BentFabricSheetTooLongBendingProfile | The bent edge is shorter than the bend profile for this fabric sheet type.
FabricSheetOutSideOfHostError | Fabric Sheet is placed completely outside of its host.
FabricSheetOutSideOfHostWarning | Fabric Sheet is placed completely outside of its host.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FabricSheetFailures Properties

The BuiltInFailuresFabricSheetFailures type exposes the following members.

Properties
Name | Description
BentFabricSheetTooLongBendingProfile | The bent edge is shorter than the bend profile for this fabric sheet type.
FabricSheetOutSideOfHostError | Fabric Sheet is placed completely outside of its host.
FabricSheetOutSideOfHostWarning | Fabric Sheet is placed completely outside of its host.
Top
See Also

Reference

BuiltInFailuresFabricSheetFailures Class


BuiltInFailures.FabricSheetFailures.BentFabricSheetTooLongBendingProfile Property

BuiltInFailuresFabricSheetFailuresBentFabricSheetTooLongBendingProfile Property

The bent edge is shorter than the bend profile for this fabric sheet type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BentFabricSheetTooLongBendingProfile { get; }
Public Shared ReadOnly Property BentFabricSheetTooLongBendingProfile As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BentFabricSheetTooLongBendingProfile {
    FailureDefinitionId^ get ();
}
static member BentFabricSheetTooLongBendingProfile : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFabricSheetFailures Class


BuiltInFailures.FabricSheetFailures.FabricSheetOutSideOfHostError Property

BuiltInFailuresFabricSheetFailuresFabricSheetOutSideOfHostError Property

Fabric Sheet is placed completely outside of its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricSheetOutSideOfHostError { get; }
Public Shared ReadOnly Property FabricSheetOutSideOfHostError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricSheetOutSideOfHostError {
    FailureDefinitionId^ get ();
}
static member FabricSheetOutSideOfHostError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFabricSheetFailures Class


BuiltInFailures.FabricSheetFailures.FabricSheetOutSideOfHostWarning Property

BuiltInFailuresFabricSheetFailuresFabricSheetOutSideOfHostWarning Property

Fabric Sheet is placed completely outside of its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricSheetOutSideOfHostWarning { get; }
Public Shared ReadOnly Property FabricSheetOutSideOfHostWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricSheetOutSideOfHostWarning {
    FailureDefinitionId^ get ();
}
static member FabricSheetOutSideOfHostWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFabricSheetFailures Class


BuiltInFailures.FaceSplitterFailures Class

BuiltInFailuresFaceSplitterFailures Class

Failures about FaceSplitter.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresFaceSplitterFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class FaceSplitterFailures
Public NotInheritable Class FaceSplitterFailures
public ref class FaceSplitterFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type FaceSplitterFailures = class end

The BuiltInFailuresFaceSplitterFailures type exposes the following members.

Properties
Name | Description
CannotUseCurvesForFaceSplit | The sketch cannot split the face of the highlighted element.
EndsNotOnEdgeError | Ends of an open loop in sketch splitting face do not lie on an edge of the face to split.
InvalidClosedLoopsForFaceSplit | The closed loop used to split the face must lie completely within the face and cannot intersect or overlap any of the face's edges. To split a face at its border, use an open loop that ends on the boundary of the face.
InvalidOpenLoopsForFaceSplit | The open loops used to split the face must lie completely within the face and cannot intersect or overlap any of the face's edges.
LoopsDoNotSubdivideFace | Sketched loops must sub-divide the face into two or more completely enclosed regions.
LoopsOutsideFaceSplitError | Some of the lines drawn lie outside of the boundary of the face being split. All lines used to split a face must be contained within the face being split and cannot intersect or overlap any of the boundaries of that face.
NoFaceForSplit | The highlighted element no longer contains a face that has been split by highlighted sketch.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FaceSplitterFailures Properties

The BuiltInFailuresFaceSplitterFailures type exposes the following members.

Properties
Name | Description
CannotUseCurvesForFaceSplit | The sketch cannot split the face of the highlighted element.
EndsNotOnEdgeError | Ends of an open loop in sketch splitting face do not lie on an edge of the face to split.
InvalidClosedLoopsForFaceSplit | The closed loop used to split the face must lie completely within the face and cannot intersect or overlap any of the face's edges. To split a face at its border, use an open loop that ends on the boundary of the face.
InvalidOpenLoopsForFaceSplit | The open loops used to split the face must lie completely within the face and cannot intersect or overlap any of the face's edges.
LoopsDoNotSubdivideFace | Sketched loops must sub-divide the face into two or more completely enclosed regions.
LoopsOutsideFaceSplitError | Some of the lines drawn lie outside of the boundary of the face being split. All lines used to split a face must be contained within the face being split and cannot intersect or overlap any of the boundaries of that face.
NoFaceForSplit | The highlighted element no longer contains a face that has been split by highlighted sketch.
Top
See Also

Reference

BuiltInFailuresFaceSplitterFailures Class


BuiltInFailures.FaceSplitterFailures.CannotUseCurvesForFaceSplit Property

BuiltInFailuresFaceSplitterFailuresCannotUseCurvesForFaceSplit Property

The sketch cannot split the face of the highlighted element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotUseCurvesForFaceSplit { get; }
Public Shared ReadOnly Property CannotUseCurvesForFaceSplit As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotUseCurvesForFaceSplit {
    FailureDefinitionId^ get ();
}
static member CannotUseCurvesForFaceSplit : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFaceSplitterFailures Class


BuiltInFailures.FaceSplitterFailures.EndsNotOnEdgeError Property

BuiltInFailuresFaceSplitterFailuresEndsNotOnEdgeError Property

Ends of an open loop in sketch splitting face do not lie on an edge of the face to split.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId EndsNotOnEdgeError { get; }
Public Shared ReadOnly Property EndsNotOnEdgeError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ EndsNotOnEdgeError {
    FailureDefinitionId^ get ();
}
static member EndsNotOnEdgeError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFaceSplitterFailures Class


BuiltInFailures.FaceSplitterFailures.InvalidClosedLoopsForFaceSplit Property

BuiltInFailuresFaceSplitterFailuresInvalidClosedLoopsForFaceSplit Property

The closed loop used to split the face must lie completely within the face and cannot intersect or overlap any of the face's edges. To split a face at its border, use an open loop that ends on the boundary of the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidClosedLoopsForFaceSplit { get; }
Public Shared ReadOnly Property InvalidClosedLoopsForFaceSplit As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidClosedLoopsForFaceSplit {
    FailureDefinitionId^ get ();
}
static member InvalidClosedLoopsForFaceSplit : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFaceSplitterFailures Class


BuiltInFailures.FaceSplitterFailures.InvalidOpenLoopsForFaceSplit Property

BuiltInFailuresFaceSplitterFailuresInvalidOpenLoopsForFaceSplit Property

The open loops used to split the face must lie completely within the face and cannot intersect or overlap any of the face's edges.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidOpenLoopsForFaceSplit { get; }
Public Shared ReadOnly Property InvalidOpenLoopsForFaceSplit As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidOpenLoopsForFaceSplit {
    FailureDefinitionId^ get ();
}
static member InvalidOpenLoopsForFaceSplit : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFaceSplitterFailures Class


BuiltInFailures.FaceSplitterFailures.LoopsDoNotSubdivideFace Property

BuiltInFailuresFaceSplitterFailuresLoopsDoNotSubdivideFace Property

Sketched loops must sub-divide the face into two or more completely enclosed regions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LoopsDoNotSubdivideFace { get; }
Public Shared ReadOnly Property LoopsDoNotSubdivideFace As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LoopsDoNotSubdivideFace {
    FailureDefinitionId^ get ();
}
static member LoopsDoNotSubdivideFace : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFaceSplitterFailures Class


BuiltInFailures.FaceSplitterFailures.LoopsOutsideFaceSplitError Property

BuiltInFailuresFaceSplitterFailuresLoopsOutsideFaceSplitError Property

Some of the lines drawn lie outside of the boundary of the face being split. All lines used to split a face must be contained within the face being split and cannot intersect or overlap any of the boundaries of that face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LoopsOutsideFaceSplitError { get; }
Public Shared ReadOnly Property LoopsOutsideFaceSplitError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LoopsOutsideFaceSplitError {
    FailureDefinitionId^ get ();
}
static member LoopsOutsideFaceSplitError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFaceSplitterFailures Class


BuiltInFailures.FaceSplitterFailures.NoFaceForSplit Property

BuiltInFailuresFaceSplitterFailuresNoFaceForSplit Property

The highlighted element no longer contains a face that has been split by highlighted sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoFaceForSplit { get; }
Public Shared ReadOnly Property NoFaceForSplit As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoFaceForSplit {
    FailureDefinitionId^ get ();
}
static member NoFaceForSplit : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFaceSplitterFailures Class


BuiltInFailures.FamilyFailures Class

BuiltInFailuresFamilyFailures Class

Failures related to families.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresFamilyFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class FamilyFailures
Public NotInheritable Class FamilyFailures
public ref class FamilyFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type FamilyFailures = class end

The BuiltInFailuresFamilyFailures type exposes the following members.

Properties
Name | Description
CannotAddParameterToFamily | Parameter '[Parameter]' cannot be added to the family.
CannotApplySplitWithGap | Can't make structural element.
CannotChangeCategory | Can't change category of Family Instance
CannotChangeInstFam | Can't change Instance's Family. Try changing Instance's Host to a Level first.
CannotConvertInstHostToWorkPlane | Can't convert Instance's Host to Work Plane. Try resetting Host to a Level.
CannotConvertInstWorkPlaneToHost | Can't convert Instance's Work Plane to Host. Try resetting Work Plane to a Level.
CannotCopyByPatternFamilies | Can't copy between Mass or Curtain Panel by Pattern families, and other families or Revit projects.
CannotCopyInplaceFamily | In-place family groups cannot be copied between in-place families of the same project.
CannotCopyWatchCurveBasedFixture |
CannotCutRefPlane | Can't cut reference plane.
CannotFindHost | Couldn't find an appropriate Host. Try selecting a different Host Face or switch Placement Mode.
CannotLoadImperialFamilyToMetricProject | Can't load an imperial Family into a metric Project.
CannotLoadMetricFamilyToImperialProject | Can't load a metric Family into an imperial Project.
CannotMakeType |
CannotMakeTypeCB | Can't make type "[Family Name]".
CannotMakeTypeFamilySaved | Can't make type "[Family Name]". Failing family has been saved to "[File Name]"
CannotPasteLabelsAcrossFamilies | Can't paste Labels across Families of different Categories.
CannotPasteObject | Can't paste some or all of the selected objects.
CannotRegenerateCorruptFamily | Family [Family Name] is corrupt and its instances cannot be updated. Please reload the family to repair the project..
CannotRotateElement | Can't rotate element into this position.
CannotSetFamilyTypeToNone | Cannot set Family Type to 'None';.
CannotSplitElement | Can't split structural element
CannotSplitWhileBackgroundTasksAreInProgress | Cannot split element while background tasks are in progress.
CannotUnlockFamilyTemplate | Can't unlock alignments from Family Template.
CantCopySelectionToNonStory | Can't copy this selection to a non-story Level.
CantEditWhileGrouped | You may not edit this parameter while the element is grouped.
CantMirrorInstWoHost | Can't mirror an instance without its host.
CantMoveFrozenInstance | A family instance placed on a curved surface of a linked file can't be moved while the link is unloaded. To move the instance, reload the link or rehost the instance.
CantPasteSelection | Can't paste selection.
CantPlaceATOnDuctError | The air terminal cannot be placed in an elevation or section view unless it is attached to a duct.
CantPlaceInsertsError | Can't place inserts outside of hosts. These elements won't be copied.
CantPlaceInsertsWarning | Can't place inserts outside of hosts. These elements won't be copied.
CantPlaceInstanceError | Can't place instance of [Symbol]
CantPlaceInstanceWarning | Can't place instance of [Symbol]
CantSetSlantedColumnEndPlane | Unable to determine slanted column end cut plane.
CantSolve | Can't find solution for formulas for Type '[Type Name]'.
CircularRefsForInstParams | "Instance parameter '%1!s!' generates circular references."
ColumnAlreadyAttachedWillBeReattached | The column is already attached. It will be detached and attached to the new target.
ColumnAndTargetAlreadyJoined | The column and target are joined, remove that join before attaching them.
ColumnHeightZeroBecauseOfInvalidOffset | Change Offset Value so that Column height is not 0.0.
ColumnTooLong | This column is too long. Maximum length is 30,000 ft.
ContainsSharedSameNameFamily | Family '[Family Name]' contains a shared family of the same name. Please rename one of the two families before loading!
CouldNotGenerateReferencesForFamilyInstance | Could not generate references for Family Instance.
CouldNotPlaceAdaptiveFamInst | Could not place Adaptive Family Instance.
CustomFittingCreated | Custom fitting was created.
DeletingBadFamElemCorruption | Family contains invalid elements. They will be deleted.
DeletingBadFamElemError | Family contains invalid elements. They will be deleted.
DeletingBadFamType | Can't make type "[Family Name]". It will be deleted.
DeletingBadFamTypeDumped | Can't make type "[Family Name]". It will be deleted. Failing family has been saved to "[File Name]"
DummyHostMustBePerpendicularToXY | Dummy host must be perpendicular to Z or Y axis.
DuplicateFamilyParameterNameWithSharedParameter | Parameter '[Parameter]' has the same name with an existing shared parameter.
DuplicateParamName | Family parameters have duplicate names.
DuplicateTypeName | "Ignoring attempt to add family type '%1!s!' for a second time."
ElementTypeParameterized | The type(s) of the selected element(s) are driven by family parameter(s). Changing the type directly will break the association.
FailedToBecomeNonParametric | Family failed to become non-parametric!
FailedToSetParameters | Failed to apply family parameters.
FailedWhenLoadingFamily | Some unlocked labeled dimensions prevent family from loading. Please try to lock unlocked labeled dimensions and load again.
FamilyBadUnattachedVoids | Family '[Family Name]' contains unattached voids that can't be combined for cutting. Try fixing the voids or unset the Cut with Voids parameter in the family.
FamilyCannotBeUpgraded | "Family '[Name]' cannot be upgraded and must be deleted. To fix the file in the older version of Revit, try loading newer versions of these families: [Names]."
FamilyConnectorDeletedError | The family Connector has been modified so the connection is invalid.
FamilyConnectorDeletedWarning | The family Connector has been modified so the connection is invalid.
FamilyDoesntMatchSystemPropertiesDisconnected | The family no longer matches the properties for the System. Disconnect the family from the System?
FamilyIsCorruptError | Some families have become unusable. Reload the families, or delete them from the model.
FamilyIsCorruptWarning | Some families have become unusable. Reload the families, or delete them from the model.
FamilyMembersReferToOutsideFamily | Memebrs of Family '[Name]' or a nested family thereof illegally refer to Elements outside the family.
FamilyNoExternalParametersError | Family's Category can't be changed because the Family contains Shared Parameters which are not permitted in the new Category.
FamilyNoExternalParametersWarning | Family's Category can't be changed because the Family contains Shared Parameters which are not permitted in the new Category.
FamilyNotFitHostShape | The host shape has changed and the family is no longer appropriate.
FamilyOverconstraint | Dimension overconstrains the Family. Cannot set Family Type to <None>.
FamilyOverconstraintCB | Dimension overconstrains the Family.
FamilyParameterNoExist | The parameter [Name] doesn't exist in the Family. It will be ignored.
FamilyValidationResult | Family Validation Warning(s): [Description]
FormulaBasedParameterCannotBeChanged | Parameter '[Caption]' cannot be changed because it is defined by formula '[Formula]'
FormulasFailedForType | "Can't satisfy formulas for type [Family Symbol].
FrozenBecauseFaceGone | This family instance was hosted by a curved face that is no longer present in the linked file. To move the family instance, rehost it.
FrozenBecauseMonitorRelationshipGone | The position of this element was determined by copy/monitor but the monitor relationship has been removed. To move this instance, use pick new host to select a valid host.
HighlightedElementFamRefsInvalidError | One or more references of the highlighted element have become invalid.
HighlightedElementFamRefsInvalidWarning | One or more references of the highlighted element have become invalid.
InstMayCutMoreOrFewerHosts | Insert may be cutting fewer or more hosts than needed. The problem may be solved by forcing regeneration, e.g. by moving the insert out and back by a tiny distance in any direction.
InstOutsideFaceBoundary | Instance origin does not lie on host face. Instance will lose association to host.
InvalidContextForAdaptivePlacement | The component '%1!s!' cannot be directly placed in the project environment. Place it in either an In-Place Mass, a Conceptual Mass Family, a Curtain Panel by Pattern Family, or an Adaptive Component.
InvalidFamilyType | Invalid family type "[Type Name]".
InvalidFormularFoundInParameter | Invalid formular found in parameter '[Param Name]' in type '[Type Name]'.
InvalidInsertOrientation | The insert orientation is incompatible with the wall's cross-section.
InvalidParameterValue | Parameter [Caption] has an invalid value.
InvalidSlantedColumnOffsets | The column's base (Base Level + Base Offset) must be below its top (Top Level + Top Offset).
InvalidSlantedColumnOffsetsInNestedFamily | Instance of family [Family Name] can't be updated because in nested family the column's base (Base Level + Base Offset) must be below its top (Top Level + Top Offset).
MightntPlaceInsertsWarning | There exist geometry collision. These elements might not be copied.
NoInstparamFormulas | Instance Parameters can't be used in Type Parameter formulas.\n\n[Description]
NonGenericAnnotationsOutsideLegend | Only Generic Annotations may be copied between Legends and other Views
NotFamilyFile | The selected file is not a Family File.
ProfileContainsNoLoops | Profile type '[Family Symbol]' contains no loops.
ReferencePlanesOverconstrained | Reference Planes are overconstrained.
SetbackTooLarge | Setback computations are too large for this element.
SharedParameterReplacedByBuiltInOne | Shared parameter [Name] will be replaced by a built-in parameter with the same name. This may affect scheduling!
SizeLookupTableIsNotAvailableForType | Size Lookup Table is not available for type [Family Symbol].
SketchCannotBeAutomaticallyDimensioned | Sketch can't be Automatically Dimensioned - this is a prerequisite for Labeled Dimensions to work properly.
SlantedColumnEndCutPlaneIsParallelToGeometry | Cut plane of slanted column end is parallel to the location curve.
SlantedColumnEndPlanesHaveFlipped | Position of end cut planes has resulted in a slanted column without any geometry.
StructuralColumnAttachedToNonStructuralTarget | The structural column is attached to a non-structural target.
TitleblockBadViewType | Titleblocks can only be placed on sheets.
TryingToAttachWhenJoined | The column and target are joined. The attachment has been removed.
TypeRecursiveElementIdParameter | Type's parameter cannot recursively point to the type itself.
UnableGenerateTrussByFamilyAndOrientation | Revit is unable to generate a truss using the current Layout Family and Truss orientation.
UnableToUpgradeDueToCorruptFamilies | Some families have become unusable. Reload the families, or delete them from the model.
UnexpectedFamilyChangeResultsError | Changing the family for a MEP fitting might cause unexpected results.
UnexpectedFamilyChangeResultsWarning | Changing the family for a MEP fitting might cause unexpected results.
ValueOutOfRange | The value must be from 0.0 to 1.0
WhileLoadingFamily | While loading family '[Family Name]': [Description]
WhileLoadingFamilyShared | While loading shared family '[Family Name]' from family '[Family Name]': [Description]
WhileScanningParametersForType | While loading Type '[Name]', parameter '[Name]': [Description]
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FamilyFailures Properties

The BuiltInFailuresFamilyFailures type exposes the following members.

Properties
Name | Description
CannotAddParameterToFamily | Parameter '[Parameter]' cannot be added to the family.
CannotApplySplitWithGap | Can't make structural element.
CannotChangeCategory | Can't change category of Family Instance
CannotChangeInstFam | Can't change Instance's Family. Try changing Instance's Host to a Level first.
CannotConvertInstHostToWorkPlane | Can't convert Instance's Host to Work Plane. Try resetting Host to a Level.
CannotConvertInstWorkPlaneToHost | Can't convert Instance's Work Plane to Host. Try resetting Work Plane to a Level.
CannotCopyByPatternFamilies | Can't copy between Mass or Curtain Panel by Pattern families, and other families or Revit projects.
CannotCopyInplaceFamily | In-place family groups cannot be copied between in-place families of the same project.
CannotCopyWatchCurveBasedFixture |
CannotCutRefPlane | Can't cut reference plane.
CannotFindHost | Couldn't find an appropriate Host. Try selecting a different Host Face or switch Placement Mode.
CannotLoadImperialFamilyToMetricProject | Can't load an imperial Family into a metric Project.
CannotLoadMetricFamilyToImperialProject | Can't load a metric Family into an imperial Project.
CannotMakeType |
CannotMakeTypeCB | Can't make type "[Family Name]".
CannotMakeTypeFamilySaved | Can't make type "[Family Name]". Failing family has been saved to "[File Name]"
CannotPasteLabelsAcrossFamilies | Can't paste Labels across Families of different Categories.
CannotPasteObject | Can't paste some or all of the selected objects.
CannotRegenerateCorruptFamily | Family [Family Name] is corrupt and its instances cannot be updated. Please reload the family to repair the project..
CannotRotateElement | Can't rotate element into this position.
CannotSetFamilyTypeToNone | Cannot set Family Type to 'None';.
CannotSplitElement | Can't split structural element
CannotSplitWhileBackgroundTasksAreInProgress | Cannot split element while background tasks are in progress.
CannotUnlockFamilyTemplate | Can't unlock alignments from Family Template.
CantCopySelectionToNonStory | Can't copy this selection to a non-story Level.
CantEditWhileGrouped | You may not edit this parameter while the element is grouped.
CantMirrorInstWoHost | Can't mirror an instance without its host.
CantMoveFrozenInstance | A family instance placed on a curved surface of a linked file can't be moved while the link is unloaded. To move the instance, reload the link or rehost the instance.
CantPasteSelection | Can't paste selection.
CantPlaceATOnDuctError | The air terminal cannot be placed in an elevation or section view unless it is attached to a duct.
CantPlaceInsertsError | Can't place inserts outside of hosts. These elements won't be copied.
CantPlaceInsertsWarning | Can't place inserts outside of hosts. These elements won't be copied.
CantPlaceInstanceError | Can't place instance of [Symbol]
CantPlaceInstanceWarning | Can't place instance of [Symbol]
CantSetSlantedColumnEndPlane | Unable to determine slanted column end cut plane.
CantSolve | Can't find solution for formulas for Type '[Type Name]'.
CircularRefsForInstParams | "Instance parameter '%1!s!' generates circular references."
ColumnAlreadyAttachedWillBeReattached | The column is already attached. It will be detached and attached to the new target.
ColumnAndTargetAlreadyJoined | The column and target are joined, remove that join before attaching them.
ColumnHeightZeroBecauseOfInvalidOffset | Change Offset Value so that Column height is not 0.0.
ColumnTooLong | This column is too long. Maximum length is 30,000 ft.
ContainsSharedSameNameFamily | Family '[Family Name]' contains a shared family of the same name. Please rename one of the two families before loading!
CouldNotGenerateReferencesForFamilyInstance | Could not generate references for Family Instance.
CouldNotPlaceAdaptiveFamInst | Could not place Adaptive Family Instance.
CustomFittingCreated | Custom fitting was created.
DeletingBadFamElemCorruption | Family contains invalid elements. They will be deleted.
DeletingBadFamElemError | Family contains invalid elements. They will be deleted.
DeletingBadFamType | Can't make type "[Family Name]". It will be deleted.
DeletingBadFamTypeDumped | Can't make type "[Family Name]". It will be deleted. Failing family has been saved to "[File Name]"
DummyHostMustBePerpendicularToXY | Dummy host must be perpendicular to Z or Y axis.
DuplicateFamilyParameterNameWithSharedParameter | Parameter '[Parameter]' has the same name with an existing shared parameter.
DuplicateParamName | Family parameters have duplicate names.
DuplicateTypeName | "Ignoring attempt to add family type '%1!s!' for a second time."
ElementTypeParameterized | The type(s) of the selected element(s) are driven by family parameter(s). Changing the type directly will break the association.
FailedToBecomeNonParametric | Family failed to become non-parametric!
FailedToSetParameters | Failed to apply family parameters.
FailedWhenLoadingFamily | Some unlocked labeled dimensions prevent family from loading. Please try to lock unlocked labeled dimensions and load again.
FamilyBadUnattachedVoids | Family '[Family Name]' contains unattached voids that can't be combined for cutting. Try fixing the voids or unset the Cut with Voids parameter in the family.
FamilyCannotBeUpgraded | "Family '[Name]' cannot be upgraded and must be deleted. To fix the file in the older version of Revit, try loading newer versions of these families: [Names]."
FamilyConnectorDeletedError | The family Connector has been modified so the connection is invalid.
FamilyConnectorDeletedWarning | The family Connector has been modified so the connection is invalid.
FamilyDoesntMatchSystemPropertiesDisconnected | The family no longer matches the properties for the System. Disconnect the family from the System?
FamilyIsCorruptError | Some families have become unusable. Reload the families, or delete them from the model.
FamilyIsCorruptWarning | Some families have become unusable. Reload the families, or delete them from the model.
FamilyMembersReferToOutsideFamily | Memebrs of Family '[Name]' or a nested family thereof illegally refer to Elements outside the family.
FamilyNoExternalParametersError | Family's Category can't be changed because the Family contains Shared Parameters which are not permitted in the new Category.
FamilyNoExternalParametersWarning | Family's Category can't be changed because the Family contains Shared Parameters which are not permitted in the new Category.
FamilyNotFitHostShape | The host shape has changed and the family is no longer appropriate.
FamilyOverconstraint | Dimension overconstrains the Family. Cannot set Family Type to <None>.
FamilyOverconstraintCB | Dimension overconstrains the Family.
FamilyParameterNoExist | The parameter [Name] doesn't exist in the Family. It will be ignored.
FamilyValidationResult | Family Validation Warning(s): [Description]
FormulaBasedParameterCannotBeChanged | Parameter '[Caption]' cannot be changed because it is defined by formula '[Formula]'
FormulasFailedForType | "Can't satisfy formulas for type [Family Symbol].
FrozenBecauseFaceGone | This family instance was hosted by a curved face that is no longer present in the linked file. To move the family instance, rehost it.
FrozenBecauseMonitorRelationshipGone | The position of this element was determined by copy/monitor but the monitor relationship has been removed. To move this instance, use pick new host to select a valid host.
HighlightedElementFamRefsInvalidError | One or more references of the highlighted element have become invalid.
HighlightedElementFamRefsInvalidWarning | One or more references of the highlighted element have become invalid.
InstMayCutMoreOrFewerHosts | Insert may be cutting fewer or more hosts than needed. The problem may be solved by forcing regeneration, e.g. by moving the insert out and back by a tiny distance in any direction.
InstOutsideFaceBoundary | Instance origin does not lie on host face. Instance will lose association to host.
InvalidContextForAdaptivePlacement | The component '%1!s!' cannot be directly placed in the project environment. Place it in either an In-Place Mass, a Conceptual Mass Family, a Curtain Panel by Pattern Family, or an Adaptive Component.
InvalidFamilyType | Invalid family type "[Type Name]".
InvalidFormularFoundInParameter | Invalid formular found in parameter '[Param Name]' in type '[Type Name]'.
InvalidInsertOrientation | The insert orientation is incompatible with the wall's cross-section.
InvalidParameterValue | Parameter [Caption] has an invalid value.
InvalidSlantedColumnOffsets | The column's base (Base Level + Base Offset) must be below its top (Top Level + Top Offset).
InvalidSlantedColumnOffsetsInNestedFamily | Instance of family [Family Name] can't be updated because in nested family the column's base (Base Level + Base Offset) must be below its top (Top Level + Top Offset).
MightntPlaceInsertsWarning | There exist geometry collision. These elements might not be copied.
NoInstparamFormulas | Instance Parameters can't be used in Type Parameter formulas.\n\n[Description]
NonGenericAnnotationsOutsideLegend | Only Generic Annotations may be copied between Legends and other Views
NotFamilyFile | The selected file is not a Family File.
ProfileContainsNoLoops | Profile type '[Family Symbol]' contains no loops.
ReferencePlanesOverconstrained | Reference Planes are overconstrained.
SetbackTooLarge | Setback computations are too large for this element.
SharedParameterReplacedByBuiltInOne | Shared parameter [Name] will be replaced by a built-in parameter with the same name. This may affect scheduling!
SizeLookupTableIsNotAvailableForType | Size Lookup Table is not available for type [Family Symbol].
SketchCannotBeAutomaticallyDimensioned | Sketch can't be Automatically Dimensioned - this is a prerequisite for Labeled Dimensions to work properly.
SlantedColumnEndCutPlaneIsParallelToGeometry | Cut plane of slanted column end is parallel to the location curve.
SlantedColumnEndPlanesHaveFlipped | Position of end cut planes has resulted in a slanted column without any geometry.
StructuralColumnAttachedToNonStructuralTarget | The structural column is attached to a non-structural target.
TitleblockBadViewType | Titleblocks can only be placed on sheets.
TryingToAttachWhenJoined | The column and target are joined. The attachment has been removed.
TypeRecursiveElementIdParameter | Type's parameter cannot recursively point to the type itself.
UnableGenerateTrussByFamilyAndOrientation | Revit is unable to generate a truss using the current Layout Family and Truss orientation.
UnableToUpgradeDueToCorruptFamilies | Some families have become unusable. Reload the families, or delete them from the model.
UnexpectedFamilyChangeResultsError | Changing the family for a MEP fitting might cause unexpected results.
UnexpectedFamilyChangeResultsWarning | Changing the family for a MEP fitting might cause unexpected results.
ValueOutOfRange | The value must be from 0.0 to 1.0
WhileLoadingFamily | While loading family '[Family Name]': [Description]
WhileLoadingFamilyShared | While loading shared family '[Family Name]' from family '[Family Name]': [Description]
WhileScanningParametersForType | While loading Type '[Name]', parameter '[Name]': [Description]
Top
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.CannotAddParameterToFamily Property

BuiltInFailuresFamilyFailuresCannotAddParameterToFamily Property

Parameter '[Parameter]' cannot be added to the family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotAddParameterToFamily { get; }
Public Shared ReadOnly Property CannotAddParameterToFamily As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotAddParameterToFamily {
    FailureDefinitionId^ get ();
}
static member CannotAddParameterToFamily : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.CannotApplySplitWithGap Property

BuiltInFailuresFamilyFailuresCannotApplySplitWithGap Property

Can't make structural element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotApplySplitWithGap { get; }
Public Shared ReadOnly Property CannotApplySplitWithGap As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotApplySplitWithGap {
    FailureDefinitionId^ get ();
}
static member CannotApplySplitWithGap : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.CannotChangeCategory Property

BuiltInFailuresFamilyFailuresCannotChangeCategory Property

Can't change category of Family Instance

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotChangeCategory { get; }
Public Shared ReadOnly Property CannotChangeCategory As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotChangeCategory {
    FailureDefinitionId^ get ();
}
static member CannotChangeCategory : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.CannotChangeInstFam Property

BuiltInFailuresFamilyFailuresCannotChangeInstFam Property

Can't change Instance's Family. Try changing Instance's Host to a Level first.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotChangeInstFam { get; }
Public Shared ReadOnly Property CannotChangeInstFam As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotChangeInstFam {
    FailureDefinitionId^ get ();
}
static member CannotChangeInstFam : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.CannotConvertInstHostToWorkPlane Property

BuiltInFailuresFamilyFailuresCannotConvertInstHostToWorkPlane Property

Can't convert Instance's Host to Work Plane. Try resetting Host to a Level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotConvertInstHostToWorkPlane { get; }
Public Shared ReadOnly Property CannotConvertInstHostToWorkPlane As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotConvertInstHostToWorkPlane {
    FailureDefinitionId^ get ();
}
static member CannotConvertInstHostToWorkPlane : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.CannotConvertInstWorkPlaneToHost Property

BuiltInFailuresFamilyFailuresCannotConvertInstWorkPlaneToHost Property

Can't convert Instance's Work Plane to Host. Try resetting Work Plane to a Level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotConvertInstWorkPlaneToHost { get; }
Public Shared ReadOnly Property CannotConvertInstWorkPlaneToHost As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotConvertInstWorkPlaneToHost {
    FailureDefinitionId^ get ();
}
static member CannotConvertInstWorkPlaneToHost : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.CannotCopyByPatternFamilies Property

BuiltInFailuresFamilyFailuresCannotCopyByPatternFamilies Property

Can't copy between Mass or Curtain Panel by Pattern families, and other families or Revit projects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyByPatternFamilies { get; }
Public Shared ReadOnly Property CannotCopyByPatternFamilies As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyByPatternFamilies {
    FailureDefinitionId^ get ();
}
static member CannotCopyByPatternFamilies : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.CannotCopyInplaceFamily Property

BuiltInFailuresFamilyFailuresCannotCopyInplaceFamily Property

In-place family groups cannot be copied between in-place families of the same project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyInplaceFamily { get; }
Public Shared ReadOnly Property CannotCopyInplaceFamily As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyInplaceFamily {
    FailureDefinitionId^ get ();
}
static member CannotCopyInplaceFamily : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.CannotCopyWatchCurveBasedFixture Property

BuiltInFailuresFamilyFailuresCannotCopyWatchCurveBasedFixture Property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyWatchCurveBasedFixture { get; }
Public Shared ReadOnly Property CannotCopyWatchCurveBasedFixture As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyWatchCurveBasedFixture {
    FailureDefinitionId^ get ();
}
static member CannotCopyWatchCurveBasedFixture : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.CannotCutRefPlane Property

BuiltInFailuresFamilyFailuresCannotCutRefPlane Property

Can't cut reference plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCutRefPlane { get; }
Public Shared ReadOnly Property CannotCutRefPlane As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCutRefPlane {
    FailureDefinitionId^ get ();
}
static member CannotCutRefPlane : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.CannotFindHost Property

BuiltInFailuresFamilyFailuresCannotFindHost Property

Couldn't find an appropriate Host. Try selecting a different Host Face or switch Placement Mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotFindHost { get; }
Public Shared ReadOnly Property CannotFindHost As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotFindHost {
    FailureDefinitionId^ get ();
}
static member CannotFindHost : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.CannotLoadImperialFamilyToMetricProject Property

BuiltInFailuresFamilyFailuresCannotLoadImperialFamilyToMetricProject Property

Can't load an imperial Family into a metric Project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotLoadImperialFamilyToMetricProject { get; }
Public Shared ReadOnly Property CannotLoadImperialFamilyToMetricProject As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotLoadImperialFamilyToMetricProject {
    FailureDefinitionId^ get ();
}
static member CannotLoadImperialFamilyToMetricProject : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.CannotLoadMetricFamilyToImperialProject Property

BuiltInFailuresFamilyFailuresCannotLoadMetricFamilyToImperialProject Property

Can't load a metric Family into an imperial Project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotLoadMetricFamilyToImperialProject { get; }
Public Shared ReadOnly Property CannotLoadMetricFamilyToImperialProject As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotLoadMetricFamilyToImperialProject {
    FailureDefinitionId^ get ();
}
static member CannotLoadMetricFamilyToImperialProject : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.CannotMakeType Property

BuiltInFailuresFamilyFailuresCannotMakeType Property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotMakeType { get; }
Public Shared ReadOnly Property CannotMakeType As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotMakeType {
    FailureDefinitionId^ get ();
}
static member CannotMakeType : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.CannotMakeTypeCB Property

BuiltInFailuresFamilyFailuresCannotMakeTypeCB Property

Can't make type "[Family Name]".

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotMakeTypeCB { get; }
Public Shared ReadOnly Property CannotMakeTypeCB As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotMakeTypeCB {
    FailureDefinitionId^ get ();
}
static member CannotMakeTypeCB : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.CannotMakeTypeFamilySaved Property

BuiltInFailuresFamilyFailuresCannotMakeTypeFamilySaved Property

Can't make type "[Family Name]". Failing family has been saved to "[File Name]"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotMakeTypeFamilySaved { get; }
Public Shared ReadOnly Property CannotMakeTypeFamilySaved As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotMakeTypeFamilySaved {
    FailureDefinitionId^ get ();
}
static member CannotMakeTypeFamilySaved : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.CannotPasteLabelsAcrossFamilies Property

BuiltInFailuresFamilyFailuresCannotPasteLabelsAcrossFamilies Property

Can't paste Labels across Families of different Categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPasteLabelsAcrossFamilies { get; }
Public Shared ReadOnly Property CannotPasteLabelsAcrossFamilies As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPasteLabelsAcrossFamilies {
    FailureDefinitionId^ get ();
}
static member CannotPasteLabelsAcrossFamilies : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.CannotPasteObject Property

BuiltInFailuresFamilyFailuresCannotPasteObject Property

Can't paste some or all of the selected objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPasteObject { get; }
Public Shared ReadOnly Property CannotPasteObject As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPasteObject {
    FailureDefinitionId^ get ();
}
static member CannotPasteObject : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.CannotRegenerateCorruptFamily Property

BuiltInFailuresFamilyFailuresCannotRegenerateCorruptFamily Property

Family [Family Name] is corrupt and its instances cannot be updated. Please reload the family to repair the project..

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotRegenerateCorruptFamily { get; }
Public Shared ReadOnly Property CannotRegenerateCorruptFamily As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotRegenerateCorruptFamily {
    FailureDefinitionId^ get ();
}
static member CannotRegenerateCorruptFamily : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.CannotRotateElement Property

BuiltInFailuresFamilyFailuresCannotRotateElement Property

Can't rotate element into this position.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotRotateElement { get; }
Public Shared ReadOnly Property CannotRotateElement As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotRotateElement {
    FailureDefinitionId^ get ();
}
static member CannotRotateElement : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.CannotSetFamilyTypeToNone Property

BuiltInFailuresFamilyFailuresCannotSetFamilyTypeToNone Property

Cannot set Family Type to 'None';.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotSetFamilyTypeToNone { get; }
Public Shared ReadOnly Property CannotSetFamilyTypeToNone As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotSetFamilyTypeToNone {
    FailureDefinitionId^ get ();
}
static member CannotSetFamilyTypeToNone : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.CannotSplitElement Property

BuiltInFailuresFamilyFailuresCannotSplitElement Property

Can't split structural element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotSplitElement { get; }
Public Shared ReadOnly Property CannotSplitElement As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotSplitElement {
    FailureDefinitionId^ get ();
}
static member CannotSplitElement : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.CannotSplitWhileBackgroundTasksAreInProgress Property

BuiltInFailuresFamilyFailuresCannotSplitWhileBackgroundTasksAreInProgress Property

Cannot split element while background tasks are in progress.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotSplitWhileBackgroundTasksAreInProgress { get; }
Public Shared ReadOnly Property CannotSplitWhileBackgroundTasksAreInProgress As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotSplitWhileBackgroundTasksAreInProgress {
    FailureDefinitionId^ get ();
}
static member CannotSplitWhileBackgroundTasksAreInProgress : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.CannotUnlockFamilyTemplate Property

BuiltInFailuresFamilyFailuresCannotUnlockFamilyTemplate Property

Can't unlock alignments from Family Template.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotUnlockFamilyTemplate { get; }
Public Shared ReadOnly Property CannotUnlockFamilyTemplate As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotUnlockFamilyTemplate {
    FailureDefinitionId^ get ();
}
static member CannotUnlockFamilyTemplate : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.CantCopySelectionToNonStory Property

BuiltInFailuresFamilyFailuresCantCopySelectionToNonStory Property

Can't copy this selection to a non-story Level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CantCopySelectionToNonStory { get; }
Public Shared ReadOnly Property CantCopySelectionToNonStory As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CantCopySelectionToNonStory {
    FailureDefinitionId^ get ();
}
static member CantCopySelectionToNonStory : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.CantEditWhileGrouped Property

BuiltInFailuresFamilyFailuresCantEditWhileGrouped Property

You may not edit this parameter while the element is grouped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CantEditWhileGrouped { get; }
Public Shared ReadOnly Property CantEditWhileGrouped As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CantEditWhileGrouped {
    FailureDefinitionId^ get ();
}
static member CantEditWhileGrouped : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.CantMirrorInstWoHost Property

BuiltInFailuresFamilyFailuresCantMirrorInstWoHost Property

Can't mirror an instance without its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CantMirrorInstWoHost { get; }
Public Shared ReadOnly Property CantMirrorInstWoHost As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CantMirrorInstWoHost {
    FailureDefinitionId^ get ();
}
static member CantMirrorInstWoHost : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.CantMoveFrozenInstance Property

BuiltInFailuresFamilyFailuresCantMoveFrozenInstance Property

A family instance placed on a curved surface of a linked file can't be moved while the link is unloaded. To move the instance, reload the link or rehost the instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CantMoveFrozenInstance { get; }
Public Shared ReadOnly Property CantMoveFrozenInstance As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CantMoveFrozenInstance {
    FailureDefinitionId^ get ();
}
static member CantMoveFrozenInstance : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.CantPasteSelection Property

BuiltInFailuresFamilyFailuresCantPasteSelection Property

Can't paste selection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CantPasteSelection { get; }
Public Shared ReadOnly Property CantPasteSelection As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CantPasteSelection {
    FailureDefinitionId^ get ();
}
static member CantPasteSelection : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.CantPlaceATOnDuctError Property

BuiltInFailuresFamilyFailuresCantPlaceATOnDuctError Property

The air terminal cannot be placed in an elevation or section view unless it is attached to a duct.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CantPlaceATOnDuctError { get; }
Public Shared ReadOnly Property CantPlaceATOnDuctError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CantPlaceATOnDuctError {
    FailureDefinitionId^ get ();
}
static member CantPlaceATOnDuctError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.CantPlaceInsertsError Property

BuiltInFailuresFamilyFailuresCantPlaceInsertsError Property

Can't place inserts outside of hosts. These elements won't be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CantPlaceInsertsError { get; }
Public Shared ReadOnly Property CantPlaceInsertsError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CantPlaceInsertsError {
    FailureDefinitionId^ get ();
}
static member CantPlaceInsertsError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.CantPlaceInsertsWarning Property

BuiltInFailuresFamilyFailuresCantPlaceInsertsWarning Property

Can't place inserts outside of hosts. These elements won't be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CantPlaceInsertsWarning { get; }
Public Shared ReadOnly Property CantPlaceInsertsWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CantPlaceInsertsWarning {
    FailureDefinitionId^ get ();
}
static member CantPlaceInsertsWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.CantPlaceInstanceError Property

BuiltInFailuresFamilyFailuresCantPlaceInstanceError Property

Can't place instance of [Symbol]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CantPlaceInstanceError { get; }
Public Shared ReadOnly Property CantPlaceInstanceError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CantPlaceInstanceError {
    FailureDefinitionId^ get ();
}
static member CantPlaceInstanceError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.CantPlaceInstanceWarning Property

BuiltInFailuresFamilyFailuresCantPlaceInstanceWarning Property

Can't place instance of [Symbol]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CantPlaceInstanceWarning { get; }
Public Shared ReadOnly Property CantPlaceInstanceWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CantPlaceInstanceWarning {
    FailureDefinitionId^ get ();
}
static member CantPlaceInstanceWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.CantSetSlantedColumnEndPlane Property

BuiltInFailuresFamilyFailuresCantSetSlantedColumnEndPlane Property

Unable to determine slanted column end cut plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CantSetSlantedColumnEndPlane { get; }
Public Shared ReadOnly Property CantSetSlantedColumnEndPlane As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CantSetSlantedColumnEndPlane {
    FailureDefinitionId^ get ();
}
static member CantSetSlantedColumnEndPlane : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.CantSolve Property

BuiltInFailuresFamilyFailuresCantSolve Property

Can't find solution for formulas for Type '[Type Name]'.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CantSolve { get; }
Public Shared ReadOnly Property CantSolve As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CantSolve {
    FailureDefinitionId^ get ();
}
static member CantSolve : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.CircularRefsForInstParams Property

BuiltInFailuresFamilyFailuresCircularRefsForInstParams Property

"Instance parameter '%1!s!' generates circular references."

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CircularRefsForInstParams { get; }
Public Shared ReadOnly Property CircularRefsForInstParams As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CircularRefsForInstParams {
    FailureDefinitionId^ get ();
}
static member CircularRefsForInstParams : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.ColumnAlreadyAttachedWillBeReattached Property

BuiltInFailuresFamilyFailuresColumnAlreadyAttachedWillBeReattached Property

The column is already attached. It will be detached and attached to the new target.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ColumnAlreadyAttachedWillBeReattached { get; }
Public Shared ReadOnly Property ColumnAlreadyAttachedWillBeReattached As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ColumnAlreadyAttachedWillBeReattached {
    FailureDefinitionId^ get ();
}
static member ColumnAlreadyAttachedWillBeReattached : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.ColumnAndTargetAlreadyJoined Property

BuiltInFailuresFamilyFailuresColumnAndTargetAlreadyJoined Property

The column and target are joined, remove that join before attaching them.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ColumnAndTargetAlreadyJoined { get; }
Public Shared ReadOnly Property ColumnAndTargetAlreadyJoined As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ColumnAndTargetAlreadyJoined {
    FailureDefinitionId^ get ();
}
static member ColumnAndTargetAlreadyJoined : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.ColumnHeightZeroBecauseOfInvalidOffset Property

BuiltInFailuresFamilyFailuresColumnHeightZeroBecauseOfInvalidOffset Property

Change Offset Value so that Column height is not 0.0.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ColumnHeightZeroBecauseOfInvalidOffset { get; }
Public Shared ReadOnly Property ColumnHeightZeroBecauseOfInvalidOffset As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ColumnHeightZeroBecauseOfInvalidOffset {
    FailureDefinitionId^ get ();
}
static member ColumnHeightZeroBecauseOfInvalidOffset : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.ColumnTooLong Property

BuiltInFailuresFamilyFailuresColumnTooLong Property

This column is too long. Maximum length is 30,000 ft.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ColumnTooLong { get; }
Public Shared ReadOnly Property ColumnTooLong As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ColumnTooLong {
    FailureDefinitionId^ get ();
}
static member ColumnTooLong : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.ContainsSharedSameNameFamily Property

BuiltInFailuresFamilyFailuresContainsSharedSameNameFamily Property

Family '[Family Name]' contains a shared family of the same name. Please rename one of the two families before loading!

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ContainsSharedSameNameFamily { get; }
Public Shared ReadOnly Property ContainsSharedSameNameFamily As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ContainsSharedSameNameFamily {
    FailureDefinitionId^ get ();
}
static member ContainsSharedSameNameFamily : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.CouldNotGenerateReferencesForFamilyInstance Property

BuiltInFailuresFamilyFailuresCouldNotGenerateReferencesForFamilyInstance Property

Could not generate references for Family Instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CouldNotGenerateReferencesForFamilyInstance { get; }
Public Shared ReadOnly Property CouldNotGenerateReferencesForFamilyInstance As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CouldNotGenerateReferencesForFamilyInstance {
    FailureDefinitionId^ get ();
}
static member CouldNotGenerateReferencesForFamilyInstance : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.CouldNotPlaceAdaptiveFamInst Property

BuiltInFailuresFamilyFailuresCouldNotPlaceAdaptiveFamInst Property

Could not place Adaptive Family Instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CouldNotPlaceAdaptiveFamInst { get; }
Public Shared ReadOnly Property CouldNotPlaceAdaptiveFamInst As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CouldNotPlaceAdaptiveFamInst {
    FailureDefinitionId^ get ();
}
static member CouldNotPlaceAdaptiveFamInst : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.CustomFittingCreated Property

BuiltInFailuresFamilyFailuresCustomFittingCreated Property

Custom fitting was created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CustomFittingCreated { get; }
Public Shared ReadOnly Property CustomFittingCreated As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CustomFittingCreated {
    FailureDefinitionId^ get ();
}
static member CustomFittingCreated : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.DeletingBadFamElemCorruption Property

BuiltInFailuresFamilyFailuresDeletingBadFamElemCorruption Property

Family contains invalid elements. They will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DeletingBadFamElemCorruption { get; }
Public Shared ReadOnly Property DeletingBadFamElemCorruption As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DeletingBadFamElemCorruption {
    FailureDefinitionId^ get ();
}
static member DeletingBadFamElemCorruption : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.DeletingBadFamElemError Property

BuiltInFailuresFamilyFailuresDeletingBadFamElemError Property

Family contains invalid elements. They will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DeletingBadFamElemError { get; }
Public Shared ReadOnly Property DeletingBadFamElemError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DeletingBadFamElemError {
    FailureDefinitionId^ get ();
}
static member DeletingBadFamElemError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.DeletingBadFamType Property

BuiltInFailuresFamilyFailuresDeletingBadFamType Property

Can't make type "[Family Name]". It will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DeletingBadFamType { get; }
Public Shared ReadOnly Property DeletingBadFamType As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DeletingBadFamType {
    FailureDefinitionId^ get ();
}
static member DeletingBadFamType : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.DeletingBadFamTypeDumped Property

BuiltInFailuresFamilyFailuresDeletingBadFamTypeDumped Property

Can't make type "[Family Name]". It will be deleted. Failing family has been saved to "[File Name]"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DeletingBadFamTypeDumped { get; }
Public Shared ReadOnly Property DeletingBadFamTypeDumped As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DeletingBadFamTypeDumped {
    FailureDefinitionId^ get ();
}
static member DeletingBadFamTypeDumped : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.DummyHostMustBePerpendicularToXY Property

BuiltInFailuresFamilyFailuresDummyHostMustBePerpendicularToXY Property

Dummy host must be perpendicular to Z or Y axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DummyHostMustBePerpendicularToXY { get; }
Public Shared ReadOnly Property DummyHostMustBePerpendicularToXY As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DummyHostMustBePerpendicularToXY {
    FailureDefinitionId^ get ();
}
static member DummyHostMustBePerpendicularToXY : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.DuplicateFamilyParameterNameWithSharedParameter Property

BuiltInFailuresFamilyFailuresDuplicateFamilyParameterNameWithSharedParameter Property

Parameter '[Parameter]' has the same name with an existing shared parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DuplicateFamilyParameterNameWithSharedParameter { get; }
Public Shared ReadOnly Property DuplicateFamilyParameterNameWithSharedParameter As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DuplicateFamilyParameterNameWithSharedParameter {
    FailureDefinitionId^ get ();
}
static member DuplicateFamilyParameterNameWithSharedParameter : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.DuplicateParamName Property

BuiltInFailuresFamilyFailuresDuplicateParamName Property

Family parameters have duplicate names.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DuplicateParamName { get; }
Public Shared ReadOnly Property DuplicateParamName As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DuplicateParamName {
    FailureDefinitionId^ get ();
}
static member DuplicateParamName : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.DuplicateTypeName Property

BuiltInFailuresFamilyFailuresDuplicateTypeName Property

"Ignoring attempt to add family type '%1!s!' for a second time."

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DuplicateTypeName { get; }
Public Shared ReadOnly Property DuplicateTypeName As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DuplicateTypeName {
    FailureDefinitionId^ get ();
}
static member DuplicateTypeName : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.ElementTypeParameterized Property

BuiltInFailuresFamilyFailuresElementTypeParameterized Property

The type(s) of the selected element(s) are driven by family parameter(s). Changing the type directly will break the association.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ElementTypeParameterized { get; }
Public Shared ReadOnly Property ElementTypeParameterized As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ElementTypeParameterized {
    FailureDefinitionId^ get ();
}
static member ElementTypeParameterized : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.FailedToBecomeNonParametric Property

BuiltInFailuresFamilyFailuresFailedToBecomeNonParametric Property

Family failed to become non-parametric!

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FailedToBecomeNonParametric { get; }
Public Shared ReadOnly Property FailedToBecomeNonParametric As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FailedToBecomeNonParametric {
    FailureDefinitionId^ get ();
}
static member FailedToBecomeNonParametric : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.FailedToSetParameters Property

BuiltInFailuresFamilyFailuresFailedToSetParameters Property

Failed to apply family parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FailedToSetParameters { get; }
Public Shared ReadOnly Property FailedToSetParameters As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FailedToSetParameters {
    FailureDefinitionId^ get ();
}
static member FailedToSetParameters : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.FailedWhenLoadingFamily Property

BuiltInFailuresFamilyFailuresFailedWhenLoadingFamily Property

Some unlocked labeled dimensions prevent family from loading. Please try to lock unlocked labeled dimensions and load again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FailedWhenLoadingFamily { get; }
Public Shared ReadOnly Property FailedWhenLoadingFamily As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FailedWhenLoadingFamily {
    FailureDefinitionId^ get ();
}
static member FailedWhenLoadingFamily : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.FamilyBadUnattachedVoids Property

BuiltInFailuresFamilyFailuresFamilyBadUnattachedVoids Property

Family '[Family Name]' contains unattached voids that can't be combined for cutting. Try fixing the voids or unset the Cut with Voids parameter in the family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FamilyBadUnattachedVoids { get; }
Public Shared ReadOnly Property FamilyBadUnattachedVoids As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FamilyBadUnattachedVoids {
    FailureDefinitionId^ get ();
}
static member FamilyBadUnattachedVoids : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.FamilyCannotBeUpgraded Property

BuiltInFailuresFamilyFailuresFamilyCannotBeUpgraded Property

"Family '[Name]' cannot be upgraded and must be deleted. To fix the file in the older version of Revit, try loading newer versions of these families: [Names]."

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FamilyCannotBeUpgraded { get; }
Public Shared ReadOnly Property FamilyCannotBeUpgraded As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FamilyCannotBeUpgraded {
    FailureDefinitionId^ get ();
}
static member FamilyCannotBeUpgraded : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.FamilyConnectorDeletedError Property

BuiltInFailuresFamilyFailuresFamilyConnectorDeletedError Property

The family Connector has been modified so the connection is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FamilyConnectorDeletedError { get; }
Public Shared ReadOnly Property FamilyConnectorDeletedError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FamilyConnectorDeletedError {
    FailureDefinitionId^ get ();
}
static member FamilyConnectorDeletedError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.FamilyConnectorDeletedWarning Property

BuiltInFailuresFamilyFailuresFamilyConnectorDeletedWarning Property

The family Connector has been modified so the connection is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FamilyConnectorDeletedWarning { get; }
Public Shared ReadOnly Property FamilyConnectorDeletedWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FamilyConnectorDeletedWarning {
    FailureDefinitionId^ get ();
}
static member FamilyConnectorDeletedWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.FamilyDoesntMatchSystemPropertiesDisconnected Property

BuiltInFailuresFamilyFailuresFamilyDoesntMatchSystemPropertiesDisconnected Property

The family no longer matches the properties for the System. Disconnect the family from the System?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FamilyDoesntMatchSystemPropertiesDisconnected { get; }
Public Shared ReadOnly Property FamilyDoesntMatchSystemPropertiesDisconnected As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FamilyDoesntMatchSystemPropertiesDisconnected {
    FailureDefinitionId^ get ();
}
static member FamilyDoesntMatchSystemPropertiesDisconnected : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.FamilyIsCorruptError Property

BuiltInFailuresFamilyFailuresFamilyIsCorruptError Property

Some families have become unusable. Reload the families, or delete them from the model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FamilyIsCorruptError { get; }
Public Shared ReadOnly Property FamilyIsCorruptError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FamilyIsCorruptError {
    FailureDefinitionId^ get ();
}
static member FamilyIsCorruptError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.FamilyIsCorruptWarning Property

BuiltInFailuresFamilyFailuresFamilyIsCorruptWarning Property

Some families have become unusable. Reload the families, or delete them from the model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FamilyIsCorruptWarning { get; }
Public Shared ReadOnly Property FamilyIsCorruptWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FamilyIsCorruptWarning {
    FailureDefinitionId^ get ();
}
static member FamilyIsCorruptWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.FamilyMembersReferToOutsideFamily Property

BuiltInFailuresFamilyFailuresFamilyMembersReferToOutsideFamily Property

Memebrs of Family '[Name]' or a nested family thereof illegally refer to Elements outside the family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FamilyMembersReferToOutsideFamily { get; }
Public Shared ReadOnly Property FamilyMembersReferToOutsideFamily As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FamilyMembersReferToOutsideFamily {
    FailureDefinitionId^ get ();
}
static member FamilyMembersReferToOutsideFamily : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.FamilyNoExternalParametersError Property

BuiltInFailuresFamilyFailuresFamilyNoExternalParametersError Property

Family's Category can't be changed because the Family contains Shared Parameters which are not permitted in the new Category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FamilyNoExternalParametersError { get; }
Public Shared ReadOnly Property FamilyNoExternalParametersError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FamilyNoExternalParametersError {
    FailureDefinitionId^ get ();
}
static member FamilyNoExternalParametersError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.FamilyNoExternalParametersWarning Property

BuiltInFailuresFamilyFailuresFamilyNoExternalParametersWarning Property

Family's Category can't be changed because the Family contains Shared Parameters which are not permitted in the new Category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FamilyNoExternalParametersWarning { get; }
Public Shared ReadOnly Property FamilyNoExternalParametersWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FamilyNoExternalParametersWarning {
    FailureDefinitionId^ get ();
}
static member FamilyNoExternalParametersWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.FamilyNotFitHostShape Property

BuiltInFailuresFamilyFailuresFamilyNotFitHostShape Property

The host shape has changed and the family is no longer appropriate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FamilyNotFitHostShape { get; }
Public Shared ReadOnly Property FamilyNotFitHostShape As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FamilyNotFitHostShape {
    FailureDefinitionId^ get ();
}
static member FamilyNotFitHostShape : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.FamilyOverconstraint Property

BuiltInFailuresFamilyFailuresFamilyOverconstraint Property

Dimension overconstrains the Family. Cannot set Family Type to <None>.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FamilyOverconstraint { get; }
Public Shared ReadOnly Property FamilyOverconstraint As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FamilyOverconstraint {
    FailureDefinitionId^ get ();
}
static member FamilyOverconstraint : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.FamilyOverconstraintCB Property

BuiltInFailuresFamilyFailuresFamilyOverconstraintCB Property

Dimension overconstrains the Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FamilyOverconstraintCB { get; }
Public Shared ReadOnly Property FamilyOverconstraintCB As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FamilyOverconstraintCB {
    FailureDefinitionId^ get ();
}
static member FamilyOverconstraintCB : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.FamilyParameterNoExist Property

BuiltInFailuresFamilyFailuresFamilyParameterNoExist Property

The parameter [Name] doesn't exist in the Family. It will be ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FamilyParameterNoExist { get; }
Public Shared ReadOnly Property FamilyParameterNoExist As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FamilyParameterNoExist {
    FailureDefinitionId^ get ();
}
static member FamilyParameterNoExist : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.FamilyValidationResult Property

BuiltInFailuresFamilyFailuresFamilyValidationResult Property

Family Validation Warning(s): [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FamilyValidationResult { get; }
Public Shared ReadOnly Property FamilyValidationResult As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FamilyValidationResult {
    FailureDefinitionId^ get ();
}
static member FamilyValidationResult : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.FormulaBasedParameterCannotBeChanged Property

BuiltInFailuresFamilyFailuresFormulaBasedParameterCannotBeChanged Property

Parameter '[Caption]' cannot be changed because it is defined by formula '[Formula]'

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FormulaBasedParameterCannotBeChanged { get; }
Public Shared ReadOnly Property FormulaBasedParameterCannotBeChanged As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FormulaBasedParameterCannotBeChanged {
    FailureDefinitionId^ get ();
}
static member FormulaBasedParameterCannotBeChanged : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.FormulasFailedForType Property

BuiltInFailuresFamilyFailuresFormulasFailedForType Property

"Can't satisfy formulas for type [Family Symbol].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FormulasFailedForType { get; }
Public Shared ReadOnly Property FormulasFailedForType As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FormulasFailedForType {
    FailureDefinitionId^ get ();
}
static member FormulasFailedForType : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.FrozenBecauseFaceGone Property

BuiltInFailuresFamilyFailuresFrozenBecauseFaceGone Property

This family instance was hosted by a curved face that is no longer present in the linked file. To move the family instance, rehost it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FrozenBecauseFaceGone { get; }
Public Shared ReadOnly Property FrozenBecauseFaceGone As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FrozenBecauseFaceGone {
    FailureDefinitionId^ get ();
}
static member FrozenBecauseFaceGone : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.FrozenBecauseMonitorRelationshipGone Property

BuiltInFailuresFamilyFailuresFrozenBecauseMonitorRelationshipGone Property

The position of this element was determined by copy/monitor but the monitor relationship has been removed. To move this instance, use pick new host to select a valid host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FrozenBecauseMonitorRelationshipGone { get; }
Public Shared ReadOnly Property FrozenBecauseMonitorRelationshipGone As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FrozenBecauseMonitorRelationshipGone {
    FailureDefinitionId^ get ();
}
static member FrozenBecauseMonitorRelationshipGone : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.HighlightedElementFamRefsInvalidError Property

BuiltInFailuresFamilyFailuresHighlightedElementFamRefsInvalidError Property

One or more references of the highlighted element have become invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId HighlightedElementFamRefsInvalidError { get; }
Public Shared ReadOnly Property HighlightedElementFamRefsInvalidError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ HighlightedElementFamRefsInvalidError {
    FailureDefinitionId^ get ();
}
static member HighlightedElementFamRefsInvalidError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.HighlightedElementFamRefsInvalidWarning Property

BuiltInFailuresFamilyFailuresHighlightedElementFamRefsInvalidWarning Property

One or more references of the highlighted element have become invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId HighlightedElementFamRefsInvalidWarning { get; }
Public Shared ReadOnly Property HighlightedElementFamRefsInvalidWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ HighlightedElementFamRefsInvalidWarning {
    FailureDefinitionId^ get ();
}
static member HighlightedElementFamRefsInvalidWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.InstMayCutMoreOrFewerHosts Property

BuiltInFailuresFamilyFailuresInstMayCutMoreOrFewerHosts Property

Insert may be cutting fewer or more hosts than needed. The problem may be solved by forcing regeneration, e.g. by moving the insert out and back by a tiny distance in any direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InstMayCutMoreOrFewerHosts { get; }
Public Shared ReadOnly Property InstMayCutMoreOrFewerHosts As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InstMayCutMoreOrFewerHosts {
    FailureDefinitionId^ get ();
}
static member InstMayCutMoreOrFewerHosts : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.InstOutsideFaceBoundary Property

BuiltInFailuresFamilyFailuresInstOutsideFaceBoundary Property

Instance origin does not lie on host face. Instance will lose association to host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InstOutsideFaceBoundary { get; }
Public Shared ReadOnly Property InstOutsideFaceBoundary As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InstOutsideFaceBoundary {
    FailureDefinitionId^ get ();
}
static member InstOutsideFaceBoundary : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.InvalidContextForAdaptivePlacement Property

BuiltInFailuresFamilyFailuresInvalidContextForAdaptivePlacement Property

The component '%1!s!' cannot be directly placed in the project environment. Place it in either an In-Place Mass, a Conceptual Mass Family, a Curtain Panel by Pattern Family, or an Adaptive Component.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidContextForAdaptivePlacement { get; }
Public Shared ReadOnly Property InvalidContextForAdaptivePlacement As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidContextForAdaptivePlacement {
    FailureDefinitionId^ get ();
}
static member InvalidContextForAdaptivePlacement : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.InvalidFamilyType Property

BuiltInFailuresFamilyFailuresInvalidFamilyType Property

Invalid family type "[Type Name]".

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidFamilyType { get; }
Public Shared ReadOnly Property InvalidFamilyType As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidFamilyType {
    FailureDefinitionId^ get ();
}
static member InvalidFamilyType : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.InvalidFormularFoundInParameter Property

BuiltInFailuresFamilyFailuresInvalidFormularFoundInParameter Property

Invalid formular found in parameter '[Param Name]' in type '[Type Name]'.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidFormularFoundInParameter { get; }
Public Shared ReadOnly Property InvalidFormularFoundInParameter As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidFormularFoundInParameter {
    FailureDefinitionId^ get ();
}
static member InvalidFormularFoundInParameter : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.InvalidInsertOrientation Property

BuiltInFailuresFamilyFailuresInvalidInsertOrientation Property

The insert orientation is incompatible with the wall's cross-section.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidInsertOrientation { get; }
Public Shared ReadOnly Property InvalidInsertOrientation As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidInsertOrientation {
    FailureDefinitionId^ get ();
}
static member InvalidInsertOrientation : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.InvalidParameterValue Property

BuiltInFailuresFamilyFailuresInvalidParameterValue Property

Parameter [Caption] has an invalid value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidParameterValue { get; }
Public Shared ReadOnly Property InvalidParameterValue As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidParameterValue {
    FailureDefinitionId^ get ();
}
static member InvalidParameterValue : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.InvalidSlantedColumnOffsets Property

BuiltInFailuresFamilyFailuresInvalidSlantedColumnOffsets Property

The column's base (Base Level + Base Offset) must be below its top (Top Level + Top Offset).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidSlantedColumnOffsets { get; }
Public Shared ReadOnly Property InvalidSlantedColumnOffsets As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidSlantedColumnOffsets {
    FailureDefinitionId^ get ();
}
static member InvalidSlantedColumnOffsets : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.InvalidSlantedColumnOffsetsInNestedFamily Property

BuiltInFailuresFamilyFailuresInvalidSlantedColumnOffsetsInNestedFamily Property

Instance of family [Family Name] can't be updated because in nested family the column's base (Base Level + Base Offset) must be below its top (Top Level + Top Offset).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidSlantedColumnOffsetsInNestedFamily { get; }
Public Shared ReadOnly Property InvalidSlantedColumnOffsetsInNestedFamily As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidSlantedColumnOffsetsInNestedFamily {
    FailureDefinitionId^ get ();
}
static member InvalidSlantedColumnOffsetsInNestedFamily : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.MightntPlaceInsertsWarning Property

BuiltInFailuresFamilyFailuresMightntPlaceInsertsWarning Property

There exist geometry collision. These elements might not be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MightntPlaceInsertsWarning { get; }
Public Shared ReadOnly Property MightntPlaceInsertsWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MightntPlaceInsertsWarning {
    FailureDefinitionId^ get ();
}
static member MightntPlaceInsertsWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.NoInstparamFormulas Property

BuiltInFailuresFamilyFailuresNoInstparamFormulas Property

Instance Parameters can't be used in Type Parameter formulas.\n\n[Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoInstparamFormulas { get; }
Public Shared ReadOnly Property NoInstparamFormulas As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoInstparamFormulas {
    FailureDefinitionId^ get ();
}
static member NoInstparamFormulas : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.NonGenericAnnotationsOutsideLegend Property

BuiltInFailuresFamilyFailuresNonGenericAnnotationsOutsideLegend Property

Only Generic Annotations may be copied between Legends and other Views

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NonGenericAnnotationsOutsideLegend { get; }
Public Shared ReadOnly Property NonGenericAnnotationsOutsideLegend As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NonGenericAnnotationsOutsideLegend {
    FailureDefinitionId^ get ();
}
static member NonGenericAnnotationsOutsideLegend : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.NotFamilyFile Property

BuiltInFailuresFamilyFailuresNotFamilyFile Property

The selected file is not a Family File.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotFamilyFile { get; }
Public Shared ReadOnly Property NotFamilyFile As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotFamilyFile {
    FailureDefinitionId^ get ();
}
static member NotFamilyFile : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.ProfileContainsNoLoops Property

BuiltInFailuresFamilyFailuresProfileContainsNoLoops Property

Profile type '[Family Symbol]' contains no loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ProfileContainsNoLoops { get; }
Public Shared ReadOnly Property ProfileContainsNoLoops As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ProfileContainsNoLoops {
    FailureDefinitionId^ get ();
}
static member ProfileContainsNoLoops : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.ReferencePlanesOverconstrained Property

BuiltInFailuresFamilyFailuresReferencePlanesOverconstrained Property

Reference Planes are overconstrained.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ReferencePlanesOverconstrained { get; }
Public Shared ReadOnly Property ReferencePlanesOverconstrained As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ReferencePlanesOverconstrained {
    FailureDefinitionId^ get ();
}
static member ReferencePlanesOverconstrained : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.SetbackTooLarge Property

BuiltInFailuresFamilyFailuresSetbackTooLarge Property

Setback computations are too large for this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SetbackTooLarge { get; }
Public Shared ReadOnly Property SetbackTooLarge As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SetbackTooLarge {
    FailureDefinitionId^ get ();
}
static member SetbackTooLarge : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.SharedParameterReplacedByBuiltInOne Property

BuiltInFailuresFamilyFailuresSharedParameterReplacedByBuiltInOne Property

Shared parameter [Name] will be replaced by a built-in parameter with the same name. This may affect scheduling!

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SharedParameterReplacedByBuiltInOne { get; }
Public Shared ReadOnly Property SharedParameterReplacedByBuiltInOne As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SharedParameterReplacedByBuiltInOne {
    FailureDefinitionId^ get ();
}
static member SharedParameterReplacedByBuiltInOne : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.SizeLookupTableIsNotAvailableForType Property

BuiltInFailuresFamilyFailuresSizeLookupTableIsNotAvailableForType Property

Size Lookup Table is not available for type [Family Symbol].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SizeLookupTableIsNotAvailableForType { get; }
Public Shared ReadOnly Property SizeLookupTableIsNotAvailableForType As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SizeLookupTableIsNotAvailableForType {
    FailureDefinitionId^ get ();
}
static member SizeLookupTableIsNotAvailableForType : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.SketchCannotBeAutomaticallyDimensioned Property

BuiltInFailuresFamilyFailuresSketchCannotBeAutomaticallyDimensioned Property

Sketch can't be Automatically Dimensioned - this is a prerequisite for Labeled Dimensions to work properly.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SketchCannotBeAutomaticallyDimensioned { get; }
Public Shared ReadOnly Property SketchCannotBeAutomaticallyDimensioned As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SketchCannotBeAutomaticallyDimensioned {
    FailureDefinitionId^ get ();
}
static member SketchCannotBeAutomaticallyDimensioned : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.SlantedColumnEndCutPlaneIsParallelToGeometry Property

BuiltInFailuresFamilyFailuresSlantedColumnEndCutPlaneIsParallelToGeometry Property

Cut plane of slanted column end is parallel to the location curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SlantedColumnEndCutPlaneIsParallelToGeometry { get; }
Public Shared ReadOnly Property SlantedColumnEndCutPlaneIsParallelToGeometry As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SlantedColumnEndCutPlaneIsParallelToGeometry {
    FailureDefinitionId^ get ();
}
static member SlantedColumnEndCutPlaneIsParallelToGeometry : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.SlantedColumnEndPlanesHaveFlipped Property

BuiltInFailuresFamilyFailuresSlantedColumnEndPlanesHaveFlipped Property

Position of end cut planes has resulted in a slanted column without any geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SlantedColumnEndPlanesHaveFlipped { get; }
Public Shared ReadOnly Property SlantedColumnEndPlanesHaveFlipped As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SlantedColumnEndPlanesHaveFlipped {
    FailureDefinitionId^ get ();
}
static member SlantedColumnEndPlanesHaveFlipped : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.StructuralColumnAttachedToNonStructuralTarget Property

BuiltInFailuresFamilyFailuresStructuralColumnAttachedToNonStructuralTarget Property

The structural column is attached to a non-structural target.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StructuralColumnAttachedToNonStructuralTarget { get; }
Public Shared ReadOnly Property StructuralColumnAttachedToNonStructuralTarget As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StructuralColumnAttachedToNonStructuralTarget {
    FailureDefinitionId^ get ();
}
static member StructuralColumnAttachedToNonStructuralTarget : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.TitleblockBadViewType Property

BuiltInFailuresFamilyFailuresTitleblockBadViewType Property

Titleblocks can only be placed on sheets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TitleblockBadViewType { get; }
Public Shared ReadOnly Property TitleblockBadViewType As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TitleblockBadViewType {
    FailureDefinitionId^ get ();
}
static member TitleblockBadViewType : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.TryingToAttachWhenJoined Property

BuiltInFailuresFamilyFailuresTryingToAttachWhenJoined Property

The column and target are joined. The attachment has been removed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TryingToAttachWhenJoined { get; }
Public Shared ReadOnly Property TryingToAttachWhenJoined As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TryingToAttachWhenJoined {
    FailureDefinitionId^ get ();
}
static member TryingToAttachWhenJoined : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.TypeRecursiveElementIdParameter Property

BuiltInFailuresFamilyFailuresTypeRecursiveElementIdParameter Property

Type's parameter cannot recursively point to the type itself.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TypeRecursiveElementIdParameter { get; }
Public Shared ReadOnly Property TypeRecursiveElementIdParameter As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TypeRecursiveElementIdParameter {
    FailureDefinitionId^ get ();
}
static member TypeRecursiveElementIdParameter : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.UnableGenerateTrussByFamilyAndOrientation Property

BuiltInFailuresFamilyFailuresUnableGenerateTrussByFamilyAndOrientation Property

Revit is unable to generate a truss using the current Layout Family and Truss orientation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnableGenerateTrussByFamilyAndOrientation { get; }
Public Shared ReadOnly Property UnableGenerateTrussByFamilyAndOrientation As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnableGenerateTrussByFamilyAndOrientation {
    FailureDefinitionId^ get ();
}
static member UnableGenerateTrussByFamilyAndOrientation : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.UnableToUpgradeDueToCorruptFamilies Property

BuiltInFailuresFamilyFailuresUnableToUpgradeDueToCorruptFamilies Property

Some families have become unusable. Reload the families, or delete them from the model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnableToUpgradeDueToCorruptFamilies { get; }
Public Shared ReadOnly Property UnableToUpgradeDueToCorruptFamilies As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnableToUpgradeDueToCorruptFamilies {
    FailureDefinitionId^ get ();
}
static member UnableToUpgradeDueToCorruptFamilies : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.UnexpectedFamilyChangeResultsError Property

BuiltInFailuresFamilyFailuresUnexpectedFamilyChangeResultsError Property

Changing the family for a MEP fitting might cause unexpected results.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnexpectedFamilyChangeResultsError { get; }
Public Shared ReadOnly Property UnexpectedFamilyChangeResultsError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnexpectedFamilyChangeResultsError {
    FailureDefinitionId^ get ();
}
static member UnexpectedFamilyChangeResultsError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.UnexpectedFamilyChangeResultsWarning Property

BuiltInFailuresFamilyFailuresUnexpectedFamilyChangeResultsWarning Property

Changing the family for a MEP fitting might cause unexpected results.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnexpectedFamilyChangeResultsWarning { get; }
Public Shared ReadOnly Property UnexpectedFamilyChangeResultsWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnexpectedFamilyChangeResultsWarning {
    FailureDefinitionId^ get ();
}
static member UnexpectedFamilyChangeResultsWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.ValueOutOfRange Property

BuiltInFailuresFamilyFailuresValueOutOfRange Property

The value must be from 0.0 to 1.0

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ValueOutOfRange { get; }
Public Shared ReadOnly Property ValueOutOfRange As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ValueOutOfRange {
    FailureDefinitionId^ get ();
}
static member ValueOutOfRange : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.WhileLoadingFamily Property

BuiltInFailuresFamilyFailuresWhileLoadingFamily Property

While loading family '[Family Name]': [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WhileLoadingFamily { get; }
Public Shared ReadOnly Property WhileLoadingFamily As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WhileLoadingFamily {
    FailureDefinitionId^ get ();
}
static member WhileLoadingFamily : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.WhileLoadingFamilyShared Property

BuiltInFailuresFamilyFailuresWhileLoadingFamilyShared Property

While loading shared family '[Family Name]' from family '[Family Name]': [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WhileLoadingFamilyShared { get; }
Public Shared ReadOnly Property WhileLoadingFamilyShared As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WhileLoadingFamilyShared {
    FailureDefinitionId^ get ();
}
static member WhileLoadingFamilyShared : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FamilyFailures.WhileScanningParametersForType Property

BuiltInFailuresFamilyFailuresWhileScanningParametersForType Property

While loading Type '[Name]', parameter '[Name]': [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WhileScanningParametersForType { get; }
Public Shared ReadOnly Property WhileScanningParametersForType As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WhileScanningParametersForType {
    FailureDefinitionId^ get ();
}
static member WhileScanningParametersForType : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFamilyFailures Class


BuiltInFailures.FilledRegionFailures Class

BuiltInFailuresFilledRegionFailures Class

Failures about FilledRegion.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresFilledRegionFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class FilledRegionFailures
Public NotInheritable Class FilledRegionFailures
public ref class FilledRegionFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type FilledRegionFailures = class end

The BuiltInFailuresFilledRegionFailures type exposes the following members.

Properties
Name | Description
BadViewType | [Filled Region Name] can't be placed in 3D Views.
CannotDrawFilledRegion | Can't draw [Filled Region Name].
CannotDrawFilledRegionError | Can't draw [Filled Region Name].
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FilledRegionFailures Properties

The BuiltInFailuresFilledRegionFailures type exposes the following members.

Properties
Name | Description
BadViewType | [Filled Region Name] can't be placed in 3D Views.
CannotDrawFilledRegion | Can't draw [Filled Region Name].
CannotDrawFilledRegionError | Can't draw [Filled Region Name].
Top
See Also

Reference

BuiltInFailuresFilledRegionFailures Class


BuiltInFailures.FilledRegionFailures.BadViewType Property

BuiltInFailuresFilledRegionFailuresBadViewType Property

[Filled Region Name] can't be placed in 3D Views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BadViewType { get; }
Public Shared ReadOnly Property BadViewType As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BadViewType {
    FailureDefinitionId^ get ();
}
static member BadViewType : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFilledRegionFailures Class


BuiltInFailures.FilledRegionFailures.CannotDrawFilledRegion Property

BuiltInFailuresFilledRegionFailuresCannotDrawFilledRegion Property

Can't draw [Filled Region Name].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotDrawFilledRegion { get; }
Public Shared ReadOnly Property CannotDrawFilledRegion As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotDrawFilledRegion {
    FailureDefinitionId^ get ();
}
static member CannotDrawFilledRegion : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFilledRegionFailures Class


BuiltInFailures.FilledRegionFailures.CannotDrawFilledRegionError Property

BuiltInFailuresFilledRegionFailuresCannotDrawFilledRegionError Property

Can't draw [Filled Region Name].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotDrawFilledRegionError { get; }
Public Shared ReadOnly Property CannotDrawFilledRegionError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotDrawFilledRegionError {
    FailureDefinitionId^ get ();
}
static member CannotDrawFilledRegionError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFilledRegionFailures Class


BuiltInFailures.FloorFailures Class

BuiltInFailuresFloorFailures Class

Failures related to floors and slabs.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresFloorFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class FloorFailures
Public NotInheritable Class FloorFailures
public ref class FloorFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type FloorFailures = class end

The BuiltInFailuresFloorFailures type exposes the following members.

Properties
Name | Description
FloorSlopeExceedsThreshold | Thickness of this Floor may be slightly inaccurate due to extreme Shape Editing. Dimensions to this element in sections and details may not accurately indicate the Thickness shown in Type Properties.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FloorFailures Properties

The BuiltInFailuresFloorFailures type exposes the following members.

Properties
Name | Description
FloorSlopeExceedsThreshold | Thickness of this Floor may be slightly inaccurate due to extreme Shape Editing. Dimensions to this element in sections and details may not accurately indicate the Thickness shown in Type Properties.
Top
See Also

Reference

BuiltInFailuresFloorFailures Class


BuiltInFailures.FloorFailures.FloorSlopeExceedsThreshold Property

BuiltInFailuresFloorFailuresFloorSlopeExceedsThreshold Property

Thickness of this Floor may be slightly inaccurate due to extreme Shape Editing. Dimensions to this element in sections and details may not accurately indicate the Thickness shown in Type Properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FloorSlopeExceedsThreshold { get; }
Public Shared ReadOnly Property FloorSlopeExceedsThreshold As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FloorSlopeExceedsThreshold {
    FailureDefinitionId^ get ();
}
static member FloorSlopeExceedsThreshold : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFloorFailures Class


BuiltInFailures.FluidFailures Class

BuiltInFailuresFluidFailures Class

Failures about Fluid.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresFluidFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class FluidFailures
Public NotInheritable Class FluidFailures
public ref class FluidFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type FluidFailures = class end

The BuiltInFailuresFluidFailures type exposes the following members.

Properties
Name | Description
UndefinedFluidType | The fluid type '[Type Name]' is not defined
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FluidFailures Properties

The BuiltInFailuresFluidFailures type exposes the following members.

Properties
Name | Description
UndefinedFluidType | The fluid type '[Type Name]' is not defined
Top
See Also

Reference

BuiltInFailuresFluidFailures Class


BuiltInFailures.FluidFailures.UndefinedFluidType Property

BuiltInFailuresFluidFailuresUndefinedFluidType Property

The fluid type '[Type Name]' is not defined

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UndefinedFluidType { get; }
Public Shared ReadOnly Property UndefinedFluidType As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UndefinedFluidType {
    FailureDefinitionId^ get ();
}
static member UndefinedFluidType : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFluidFailures Class


BuiltInFailures.ForeignFileFailures Class

BuiltInFailuresForeignFileFailures Class

Failures about files saved by applications that were not developed or licensed by Autodesk.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresForeignFileFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ForeignFileFailures
Public NotInheritable Class ForeignFileFailures
public ref class ForeignFileFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ForeignFileFailures = class end

The BuiltInFailuresForeignFileFailures type exposes the following members.

Properties
Name | Description
ForeignFile | This file [FamilyName] was saved by an application that was not developed or licensed by Autodesk.
ForeignLink | This file [RvtLinkName] was saved by an application that was not developed or licensed by Autodesk.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ForeignFileFailures Properties

The BuiltInFailuresForeignFileFailures type exposes the following members.

Properties
Name | Description
ForeignFile | This file [FamilyName] was saved by an application that was not developed or licensed by Autodesk.
ForeignLink | This file [RvtLinkName] was saved by an application that was not developed or licensed by Autodesk.
Top
See Also

Reference

BuiltInFailuresForeignFileFailures Class


BuiltInFailures.ForeignFileFailures.ForeignFile Property

BuiltInFailuresForeignFileFailuresForeignFile Property

This file [FamilyName] was saved by an application that was not developed or licensed by Autodesk.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ForeignFile { get; }
Public Shared ReadOnly Property ForeignFile As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ForeignFile {
    FailureDefinitionId^ get ();
}
static member ForeignFile : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresForeignFileFailures Class


BuiltInFailures.ForeignFileFailures.ForeignLink Property

BuiltInFailuresForeignFileFailuresForeignLink Property

This file [RvtLinkName] was saved by an application that was not developed or licensed by Autodesk.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ForeignLink { get; }
Public Shared ReadOnly Property ForeignLink As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ForeignLink {
    FailureDefinitionId^ get ();
}
static member ForeignLink : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresForeignFileFailures Class


BuiltInFailures.FormFailures Class

BuiltInFailuresFormFailures Class

Failures about Form.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresFormFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class FormFailures
Public NotInheritable Class FormFailures
public ref class FormFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type FormFailures = class end

The BuiltInFailuresFormFailures type exposes the following members.

Properties
Name | Description
AddProfileFailure | Failed to Add Profile
DissolveNoValidInputs | No form elements selected to dissolve.
DissolveUnableToDissolveForm | Unable to dissolve form element.
FormCreationInvalidGeomCombination | Cannot remake form that is currently cut or joined to other geometry. Please uncut or unjoin first.
FormElemRegenFailure | Unable to create form element
FormElemRegenFailureError | Unable to create form element
FormElemRegenSelfIntersection | Unable to create form element: self-intersecting or singular geometry would result.
FormElemRegenSelfIntersectionReorderProfiles | This form cannot be created due to self-intersecting geometry. Clicking the Reorder Profiles button will attempt to solve this problem.
FormElemRegenSelfIntersectionResetConnections | This form cannot be created due to self-intersecting geometry. Clicking the Reset Connections button will attempt to solve this problem.
OpenProfileMultiSegmentSweepsNotSupported | An open profile cannot be swept along a multi-segment path.
VoidFormsNotUsed | Some Void Forms of this family do not cut anything and will be deleted. To make a Void Form cut something else use the Cut Geometry tool.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FormFailures Properties

The BuiltInFailuresFormFailures type exposes the following members.

Properties
Name | Description
AddProfileFailure | Failed to Add Profile
DissolveNoValidInputs | No form elements selected to dissolve.
DissolveUnableToDissolveForm | Unable to dissolve form element.
FormCreationInvalidGeomCombination | Cannot remake form that is currently cut or joined to other geometry. Please uncut or unjoin first.
FormElemRegenFailure | Unable to create form element
FormElemRegenFailureError | Unable to create form element
FormElemRegenSelfIntersection | Unable to create form element: self-intersecting or singular geometry would result.
FormElemRegenSelfIntersectionReorderProfiles | This form cannot be created due to self-intersecting geometry. Clicking the Reorder Profiles button will attempt to solve this problem.
FormElemRegenSelfIntersectionResetConnections | This form cannot be created due to self-intersecting geometry. Clicking the Reset Connections button will attempt to solve this problem.
OpenProfileMultiSegmentSweepsNotSupported | An open profile cannot be swept along a multi-segment path.
VoidFormsNotUsed | Some Void Forms of this family do not cut anything and will be deleted. To make a Void Form cut something else use the Cut Geometry tool.
Top
See Also

Reference

BuiltInFailuresFormFailures Class


BuiltInFailures.FormFailures.AddProfileFailure Property

BuiltInFailuresFormFailuresAddProfileFailure Property

Failed to Add Profile

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AddProfileFailure { get; }
Public Shared ReadOnly Property AddProfileFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AddProfileFailure {
    FailureDefinitionId^ get ();
}
static member AddProfileFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFormFailures Class


BuiltInFailures.FormFailures.DissolveNoValidInputs Property

BuiltInFailuresFormFailuresDissolveNoValidInputs Property

No form elements selected to dissolve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DissolveNoValidInputs { get; }
Public Shared ReadOnly Property DissolveNoValidInputs As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DissolveNoValidInputs {
    FailureDefinitionId^ get ();
}
static member DissolveNoValidInputs : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFormFailures Class


BuiltInFailures.FormFailures.DissolveUnableToDissolveForm Property

BuiltInFailuresFormFailuresDissolveUnableToDissolveForm Property

Unable to dissolve form element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DissolveUnableToDissolveForm { get; }
Public Shared ReadOnly Property DissolveUnableToDissolveForm As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DissolveUnableToDissolveForm {
    FailureDefinitionId^ get ();
}
static member DissolveUnableToDissolveForm : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFormFailures Class


BuiltInFailures.FormFailures.FormCreationInvalidGeomCombination Property

BuiltInFailuresFormFailuresFormCreationInvalidGeomCombination Property

Cannot remake form that is currently cut or joined to other geometry. Please uncut or unjoin first.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FormCreationInvalidGeomCombination { get; }
Public Shared ReadOnly Property FormCreationInvalidGeomCombination As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FormCreationInvalidGeomCombination {
    FailureDefinitionId^ get ();
}
static member FormCreationInvalidGeomCombination : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFormFailures Class


BuiltInFailures.FormFailures.FormElemRegenFailure Property

BuiltInFailuresFormFailuresFormElemRegenFailure Property

Unable to create form element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FormElemRegenFailure { get; }
Public Shared ReadOnly Property FormElemRegenFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FormElemRegenFailure {
    FailureDefinitionId^ get ();
}
static member FormElemRegenFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFormFailures Class


BuiltInFailures.FormFailures.FormElemRegenFailureError Property

BuiltInFailuresFormFailuresFormElemRegenFailureError Property

Unable to create form element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FormElemRegenFailureError { get; }
Public Shared ReadOnly Property FormElemRegenFailureError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FormElemRegenFailureError {
    FailureDefinitionId^ get ();
}
static member FormElemRegenFailureError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFormFailures Class


BuiltInFailures.FormFailures.FormElemRegenSelfIntersection Property

BuiltInFailuresFormFailuresFormElemRegenSelfIntersection Property

Unable to create form element: self-intersecting or singular geometry would result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FormElemRegenSelfIntersection { get; }
Public Shared ReadOnly Property FormElemRegenSelfIntersection As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FormElemRegenSelfIntersection {
    FailureDefinitionId^ get ();
}
static member FormElemRegenSelfIntersection : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFormFailures Class


BuiltInFailures.FormFailures.FormElemRegenSelfIntersectionReorderProfiles Property

BuiltInFailuresFormFailuresFormElemRegenSelfIntersectionReorderProfiles Property

This form cannot be created due to self-intersecting geometry. Clicking the Reorder Profiles button will attempt to solve this problem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FormElemRegenSelfIntersectionReorderProfiles { get; }
Public Shared ReadOnly Property FormElemRegenSelfIntersectionReorderProfiles As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FormElemRegenSelfIntersectionReorderProfiles {
    FailureDefinitionId^ get ();
}
static member FormElemRegenSelfIntersectionReorderProfiles : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFormFailures Class


BuiltInFailures.FormFailures.FormElemRegenSelfIntersectionResetConnections Property

BuiltInFailuresFormFailuresFormElemRegenSelfIntersectionResetConnections Property

This form cannot be created due to self-intersecting geometry. Clicking the Reset Connections button will attempt to solve this problem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FormElemRegenSelfIntersectionResetConnections { get; }
Public Shared ReadOnly Property FormElemRegenSelfIntersectionResetConnections As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FormElemRegenSelfIntersectionResetConnections {
    FailureDefinitionId^ get ();
}
static member FormElemRegenSelfIntersectionResetConnections : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFormFailures Class


BuiltInFailures.FormFailures.OpenProfileMultiSegmentSweepsNotSupported Property

BuiltInFailuresFormFailuresOpenProfileMultiSegmentSweepsNotSupported Property

An open profile cannot be swept along a multi-segment path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId OpenProfileMultiSegmentSweepsNotSupported { get; }
Public Shared ReadOnly Property OpenProfileMultiSegmentSweepsNotSupported As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ OpenProfileMultiSegmentSweepsNotSupported {
    FailureDefinitionId^ get ();
}
static member OpenProfileMultiSegmentSweepsNotSupported : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFormFailures Class


BuiltInFailures.FormFailures.VoidFormsNotUsed Property

BuiltInFailuresFormFailuresVoidFormsNotUsed Property

Some Void Forms of this family do not cut anything and will be deleted. To make a Void Form cut something else use the Cut Geometry tool.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId VoidFormsNotUsed { get; }
Public Shared ReadOnly Property VoidFormsNotUsed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ VoidFormsNotUsed {
    FailureDefinitionId^ get ();
}
static member VoidFormsNotUsed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresFormFailures Class


BuiltInFailures.GeneralFailures Class

BuiltInFailuresGeneralFailures Class

Failures about GeneralFailures.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresGeneralFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class GeneralFailures
Public NotInheritable Class GeneralFailures
public ref class GeneralFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type GeneralFailures = class end

The BuiltInFailuresGeneralFailures type exposes the following members.

Properties
Name | Description
CannotFixProblem | Failed to fix problem. Action has to be cancelled.
CannotSetParameter | Cant set parameter
CharactersNotAllowed | Name cannot contain any of the following characters:\n[{}[]|;<>?`~]\nor any of the non-printable characters.
ContentDocTreeCorruption | Problems with the Content Doc Tree structure - e.g. orphaned Content Docs, Families w/o docs, missing Owner Fam, what-not
ConvertingOldAxisToNormal | This operation will convert the existing axis of revolution to a normal line.
CoreElemTestingError | Core element testing error (internal).
DuplicateValue | Elements have duplicate '[Value]' values.
EnterNonNegativeValue | Enter a non-negative value.
EnterValidRealGreaterThan | Enter a number greater than [Value].
EnterValueBetween | Please enter a value between [Value] and [Value].
ErrorInFamilyResolved | An error occurred in family "[Name]" and was automatically resolved. Please review changes made to the family.\nError Information:\n"[Text]"\nError Resolution: [Resolution]
ErrorInSymbolFamilyResolved | An error occurred in family "[Name]" and was automatically resolved, but may require review by the family creator.\nError Information:\n"[Text]"\nError Resolution: [Resolution]
ErrorResolved | Error "[Text]" was automatically resolved by "[Resolution]"
FailedToOpenFile | Failed to open file.
FailedToReadLine | Failed to read line.
FamilySeparationTestingError | Family separation testing error (internal).
GenericCorruption | A generic error has occurred.
GenericError | Error.
GenericErrorNone | None.
GenericFatalError | A fatal error has occurred. The application will be terminated. You will be given the opportunity to save recovery files for all of your changed projects.\tWould you like to save a recovery file for [Project Name]?
GenericNonFatalError | A serious error has occurred. It is strongly recommended that you use Save As to save your work in a new file before continuing.
GenericWarning | A generic error has occurred.
InaccuracyDetected | A geometric inaccuracy was found in the element.
InternalProblemsParameter | Parameter cannot be changed due to internal problems.
InvalidInput | Invalid Input
InvalidInputWarn | Invalid Input
InvalidOrderOfPhases | Invalid order of phases: [Type Name] cannot be demolished before it was created.
InvalidValue | Invalid value.
NameInUse | The name "[Name]" is already in use.
NameIsEmpty | Name is empty
NameNotUnique | The name entered is already in use. Enter a unique name.
NoRelatedWarnings | Document doesn't contain any warnings related to these elements.
ParameterValueNotInRange | The value for [Parameter Name] must be between [Value] and [Value].
ParameterValuesConflict | The value for [Parameter Name] must be at least [Value] below the value for [Parameter Name].
SeriousElementReferenceCorruption | Element references are seriously corrupt.
TransactionFailed | [Description]
TransactionFailedWarn | [Description]
UnresolvableErrorInFamily | An error occurred in family "[Name]" that cannot be automatically resolved.\nError Information:\n"[Text]"
UnresolvableErrorInFamilyWarn | An error occurred in family "[Name]" that cannot be automatically resolved.\nError Information:\n"[Text]"
UnspecifiedError | Revit has experienced an unexpected error. The operation has been cancelled to protect your project from corruption.
ValueOutOfRange | Value is out of range ! Please enter a number between [Value] and [Value].
WarningInFamilyDismissed | A warning in family "[Name]" was dismissed. Please review warning information to determine if any changes are necessary\nWarning Information:\n"[Text]"
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


GeneralFailures Properties

The BuiltInFailuresGeneralFailures type exposes the following members.

Properties
Name | Description
CannotFixProblem | Failed to fix problem. Action has to be cancelled.
CannotSetParameter | Cant set parameter
CharactersNotAllowed | Name cannot contain any of the following characters:\n[{}[]|;<>?`~]\nor any of the non-printable characters.
ContentDocTreeCorruption | Problems with the Content Doc Tree structure - e.g. orphaned Content Docs, Families w/o docs, missing Owner Fam, what-not
ConvertingOldAxisToNormal | This operation will convert the existing axis of revolution to a normal line.
CoreElemTestingError | Core element testing error (internal).
DuplicateValue | Elements have duplicate '[Value]' values.
EnterNonNegativeValue | Enter a non-negative value.
EnterValidRealGreaterThan | Enter a number greater than [Value].
EnterValueBetween | Please enter a value between [Value] and [Value].
ErrorInFamilyResolved | An error occurred in family "[Name]" and was automatically resolved. Please review changes made to the family.\nError Information:\n"[Text]"\nError Resolution: [Resolution]
ErrorInSymbolFamilyResolved | An error occurred in family "[Name]" and was automatically resolved, but may require review by the family creator.\nError Information:\n"[Text]"\nError Resolution: [Resolution]
ErrorResolved | Error "[Text]" was automatically resolved by "[Resolution]"
FailedToOpenFile | Failed to open file.
FailedToReadLine | Failed to read line.
FamilySeparationTestingError | Family separation testing error (internal).
GenericCorruption | A generic error has occurred.
GenericError | Error.
GenericErrorNone | None.
GenericFatalError | A fatal error has occurred. The application will be terminated. You will be given the opportunity to save recovery files for all of your changed projects.\tWould you like to save a recovery file for [Project Name]?
GenericNonFatalError | A serious error has occurred. It is strongly recommended that you use Save As to save your work in a new file before continuing.
GenericWarning | A generic error has occurred.
InaccuracyDetected | A geometric inaccuracy was found in the element.
InternalProblemsParameter | Parameter cannot be changed due to internal problems.
InvalidInput | Invalid Input
InvalidInputWarn | Invalid Input
InvalidOrderOfPhases | Invalid order of phases: [Type Name] cannot be demolished before it was created.
InvalidValue | Invalid value.
NameInUse | The name "[Name]" is already in use.
NameIsEmpty | Name is empty
NameNotUnique | The name entered is already in use. Enter a unique name.
NoRelatedWarnings | Document doesn't contain any warnings related to these elements.
ParameterValueNotInRange | The value for [Parameter Name] must be between [Value] and [Value].
ParameterValuesConflict | The value for [Parameter Name] must be at least [Value] below the value for [Parameter Name].
SeriousElementReferenceCorruption | Element references are seriously corrupt.
TransactionFailed | [Description]
TransactionFailedWarn | [Description]
UnresolvableErrorInFamily | An error occurred in family "[Name]" that cannot be automatically resolved.\nError Information:\n"[Text]"
UnresolvableErrorInFamilyWarn | An error occurred in family "[Name]" that cannot be automatically resolved.\nError Information:\n"[Text]"
UnspecifiedError | Revit has experienced an unexpected error. The operation has been cancelled to protect your project from corruption.
ValueOutOfRange | Value is out of range ! Please enter a number between [Value] and [Value].
WarningInFamilyDismissed | A warning in family "[Name]" was dismissed. Please review warning information to determine if any changes are necessary\nWarning Information:\n"[Text]"
Top
See Also

Reference

BuiltInFailuresGeneralFailures Class


BuiltInFailures.GeneralFailures.CannotFixProblem Property

BuiltInFailuresGeneralFailuresCannotFixProblem Property

Failed to fix problem. Action has to be cancelled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotFixProblem { get; }
Public Shared ReadOnly Property CannotFixProblem As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotFixProblem {
    FailureDefinitionId^ get ();
}
static member CannotFixProblem : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeneralFailures Class


BuiltInFailures.GeneralFailures.CannotSetParameter Property

BuiltInFailuresGeneralFailuresCannotSetParameter Property

Cant set parameter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotSetParameter { get; }
Public Shared ReadOnly Property CannotSetParameter As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotSetParameter {
    FailureDefinitionId^ get ();
}
static member CannotSetParameter : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeneralFailures Class


BuiltInFailures.GeneralFailures.CharactersNotAllowed Property

BuiltInFailuresGeneralFailuresCharactersNotAllowed Property

Name cannot contain any of the following characters:\n[{}[]|;<>?`~]\nor any of the non-printable characters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CharactersNotAllowed { get; }
Public Shared ReadOnly Property CharactersNotAllowed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CharactersNotAllowed {
    FailureDefinitionId^ get ();
}
static member CharactersNotAllowed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeneralFailures Class


BuiltInFailures.GeneralFailures.ContentDocTreeCorruption Property

BuiltInFailuresGeneralFailuresContentDocTreeCorruption Property

Problems with the Content Doc Tree structure - e.g. orphaned Content Docs, Families w/o docs, missing Owner Fam, what-not

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ContentDocTreeCorruption { get; }
Public Shared ReadOnly Property ContentDocTreeCorruption As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ContentDocTreeCorruption {
    FailureDefinitionId^ get ();
}
static member ContentDocTreeCorruption : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeneralFailures Class


BuiltInFailures.GeneralFailures.ConvertingOldAxisToNormal Property

BuiltInFailuresGeneralFailuresConvertingOldAxisToNormal Property

This operation will convert the existing axis of revolution to a normal line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ConvertingOldAxisToNormal { get; }
Public Shared ReadOnly Property ConvertingOldAxisToNormal As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ConvertingOldAxisToNormal {
    FailureDefinitionId^ get ();
}
static member ConvertingOldAxisToNormal : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeneralFailures Class


BuiltInFailures.GeneralFailures.CoreElemTestingError Property

BuiltInFailuresGeneralFailuresCoreElemTestingError Property

Core element testing error (internal).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CoreElemTestingError { get; }
Public Shared ReadOnly Property CoreElemTestingError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CoreElemTestingError {
    FailureDefinitionId^ get ();
}
static member CoreElemTestingError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeneralFailures Class


BuiltInFailures.GeneralFailures.DuplicateValue Property

BuiltInFailuresGeneralFailuresDuplicateValue Property

Elements have duplicate '[Value]' values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DuplicateValue { get; }
Public Shared ReadOnly Property DuplicateValue As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DuplicateValue {
    FailureDefinitionId^ get ();
}
static member DuplicateValue : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeneralFailures Class


BuiltInFailures.GeneralFailures.EnterNonNegativeValue Property

BuiltInFailuresGeneralFailuresEnterNonNegativeValue Property

Enter a non-negative value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId EnterNonNegativeValue { get; }
Public Shared ReadOnly Property EnterNonNegativeValue As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ EnterNonNegativeValue {
    FailureDefinitionId^ get ();
}
static member EnterNonNegativeValue : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeneralFailures Class


BuiltInFailures.GeneralFailures.EnterValidRealGreaterThan Property

BuiltInFailuresGeneralFailuresEnterValidRealGreaterThan Property

Enter a number greater than [Value].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId EnterValidRealGreaterThan { get; }
Public Shared ReadOnly Property EnterValidRealGreaterThan As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ EnterValidRealGreaterThan {
    FailureDefinitionId^ get ();
}
static member EnterValidRealGreaterThan : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeneralFailures Class


BuiltInFailures.GeneralFailures.EnterValueBetween Property

BuiltInFailuresGeneralFailuresEnterValueBetween Property

Please enter a value between [Value] and [Value].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId EnterValueBetween { get; }
Public Shared ReadOnly Property EnterValueBetween As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ EnterValueBetween {
    FailureDefinitionId^ get ();
}
static member EnterValueBetween : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeneralFailures Class


BuiltInFailures.GeneralFailures.ErrorInFamilyResolved Property

BuiltInFailuresGeneralFailuresErrorInFamilyResolved Property

An error occurred in family "[Name]" and was automatically resolved. Please review changes made to the family.\nError Information:\n"[Text]"\nError Resolution: [Resolution]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ErrorInFamilyResolved { get; }
Public Shared ReadOnly Property ErrorInFamilyResolved As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ErrorInFamilyResolved {
    FailureDefinitionId^ get ();
}
static member ErrorInFamilyResolved : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeneralFailures Class


BuiltInFailures.GeneralFailures.ErrorInSymbolFamilyResolved Property

BuiltInFailuresGeneralFailuresErrorInSymbolFamilyResolved Property

An error occurred in family "[Name]" and was automatically resolved, but may require review by the family creator.\nError Information:\n"[Text]"\nError Resolution: [Resolution]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ErrorInSymbolFamilyResolved { get; }
Public Shared ReadOnly Property ErrorInSymbolFamilyResolved As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ErrorInSymbolFamilyResolved {
    FailureDefinitionId^ get ();
}
static member ErrorInSymbolFamilyResolved : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeneralFailures Class


BuiltInFailures.GeneralFailures.ErrorResolved Property

BuiltInFailuresGeneralFailuresErrorResolved Property

Error "[Text]" was automatically resolved by "[Resolution]"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ErrorResolved { get; }
Public Shared ReadOnly Property ErrorResolved As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ErrorResolved {
    FailureDefinitionId^ get ();
}
static member ErrorResolved : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeneralFailures Class


BuiltInFailures.GeneralFailures.FailedToOpenFile Property

BuiltInFailuresGeneralFailuresFailedToOpenFile Property

Failed to open file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FailedToOpenFile { get; }
Public Shared ReadOnly Property FailedToOpenFile As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FailedToOpenFile {
    FailureDefinitionId^ get ();
}
static member FailedToOpenFile : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeneralFailures Class


BuiltInFailures.GeneralFailures.FailedToReadLine Property

BuiltInFailuresGeneralFailuresFailedToReadLine Property

Failed to read line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FailedToReadLine { get; }
Public Shared ReadOnly Property FailedToReadLine As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FailedToReadLine {
    FailureDefinitionId^ get ();
}
static member FailedToReadLine : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeneralFailures Class


BuiltInFailures.GeneralFailures.FamilySeparationTestingError Property

BuiltInFailuresGeneralFailuresFamilySeparationTestingError Property

Family separation testing error (internal).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FamilySeparationTestingError { get; }
Public Shared ReadOnly Property FamilySeparationTestingError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FamilySeparationTestingError {
    FailureDefinitionId^ get ();
}
static member FamilySeparationTestingError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeneralFailures Class


BuiltInFailures.GeneralFailures.GenericCorruption Property

BuiltInFailuresGeneralFailuresGenericCorruption Property

A generic error has occurred.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId GenericCorruption { get; }
Public Shared ReadOnly Property GenericCorruption As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ GenericCorruption {
    FailureDefinitionId^ get ();
}
static member GenericCorruption : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeneralFailures Class


BuiltInFailures.GeneralFailures.GenericError Property

BuiltInFailuresGeneralFailuresGenericError Property

Error.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId GenericError { get; }
Public Shared ReadOnly Property GenericError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ GenericError {
    FailureDefinitionId^ get ();
}
static member GenericError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeneralFailures Class


BuiltInFailures.GeneralFailures.GenericErrorNone Property

BuiltInFailuresGeneralFailuresGenericErrorNone Property

None.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId GenericErrorNone { get; }
Public Shared ReadOnly Property GenericErrorNone As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ GenericErrorNone {
    FailureDefinitionId^ get ();
}
static member GenericErrorNone : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeneralFailures Class


BuiltInFailures.GeneralFailures.GenericFatalError Property

BuiltInFailuresGeneralFailuresGenericFatalError Property

A fatal error has occurred. The application will be terminated. You will be given the opportunity to save recovery files for all of your changed projects.\tWould you like to save a recovery file for [Project Name]?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId GenericFatalError { get; }
Public Shared ReadOnly Property GenericFatalError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ GenericFatalError {
    FailureDefinitionId^ get ();
}
static member GenericFatalError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeneralFailures Class


BuiltInFailures.GeneralFailures.GenericNonFatalError Property

BuiltInFailuresGeneralFailuresGenericNonFatalError Property

A serious error has occurred. It is strongly recommended that you use Save As to save your work in a new file before continuing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId GenericNonFatalError { get; }
Public Shared ReadOnly Property GenericNonFatalError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ GenericNonFatalError {
    FailureDefinitionId^ get ();
}
static member GenericNonFatalError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeneralFailures Class


BuiltInFailures.GeneralFailures.GenericWarning Property

BuiltInFailuresGeneralFailuresGenericWarning Property

A generic error has occurred.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId GenericWarning { get; }
Public Shared ReadOnly Property GenericWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ GenericWarning {
    FailureDefinitionId^ get ();
}
static member GenericWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeneralFailures Class


BuiltInFailures.GeneralFailures.InaccuracyDetected Property

BuiltInFailuresGeneralFailuresInaccuracyDetected Property

A geometric inaccuracy was found in the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InaccuracyDetected { get; }
Public Shared ReadOnly Property InaccuracyDetected As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InaccuracyDetected {
    FailureDefinitionId^ get ();
}
static member InaccuracyDetected : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeneralFailures Class


BuiltInFailures.GeneralFailures.InternalProblemsParameter Property

BuiltInFailuresGeneralFailuresInternalProblemsParameter Property

Parameter cannot be changed due to internal problems.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InternalProblemsParameter { get; }
Public Shared ReadOnly Property InternalProblemsParameter As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InternalProblemsParameter {
    FailureDefinitionId^ get ();
}
static member InternalProblemsParameter : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeneralFailures Class


BuiltInFailures.GeneralFailures.InvalidInput Property

BuiltInFailuresGeneralFailuresInvalidInput Property

Invalid Input

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidInput { get; }
Public Shared ReadOnly Property InvalidInput As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidInput {
    FailureDefinitionId^ get ();
}
static member InvalidInput : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeneralFailures Class


BuiltInFailures.GeneralFailures.InvalidInputWarn Property

BuiltInFailuresGeneralFailuresInvalidInputWarn Property

Invalid Input

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidInputWarn { get; }
Public Shared ReadOnly Property InvalidInputWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidInputWarn {
    FailureDefinitionId^ get ();
}
static member InvalidInputWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeneralFailures Class


BuiltInFailures.GeneralFailures.InvalidOrderOfPhases Property

BuiltInFailuresGeneralFailuresInvalidOrderOfPhases Property

Invalid order of phases: [Type Name] cannot be demolished before it was created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidOrderOfPhases { get; }
Public Shared ReadOnly Property InvalidOrderOfPhases As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidOrderOfPhases {
    FailureDefinitionId^ get ();
}
static member InvalidOrderOfPhases : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeneralFailures Class


BuiltInFailures.GeneralFailures.InvalidValue Property

BuiltInFailuresGeneralFailuresInvalidValue Property

Invalid value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidValue { get; }
Public Shared ReadOnly Property InvalidValue As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidValue {
    FailureDefinitionId^ get ();
}
static member InvalidValue : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeneralFailures Class


BuiltInFailures.GeneralFailures.NameInUse Property

BuiltInFailuresGeneralFailuresNameInUse Property

The name "[Name]" is already in use.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NameInUse { get; }
Public Shared ReadOnly Property NameInUse As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NameInUse {
    FailureDefinitionId^ get ();
}
static member NameInUse : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeneralFailures Class


BuiltInFailures.GeneralFailures.NameIsEmpty Property

BuiltInFailuresGeneralFailuresNameIsEmpty Property

Name is empty

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NameIsEmpty { get; }
Public Shared ReadOnly Property NameIsEmpty As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NameIsEmpty {
    FailureDefinitionId^ get ();
}
static member NameIsEmpty : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeneralFailures Class


BuiltInFailures.GeneralFailures.NameNotUnique Property

BuiltInFailuresGeneralFailuresNameNotUnique Property

The name entered is already in use. Enter a unique name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NameNotUnique { get; }
Public Shared ReadOnly Property NameNotUnique As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NameNotUnique {
    FailureDefinitionId^ get ();
}
static member NameNotUnique : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeneralFailures Class


BuiltInFailures.GeneralFailures.NoRelatedWarnings Property

BuiltInFailuresGeneralFailuresNoRelatedWarnings Property

Document doesn't contain any warnings related to these elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoRelatedWarnings { get; }
Public Shared ReadOnly Property NoRelatedWarnings As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoRelatedWarnings {
    FailureDefinitionId^ get ();
}
static member NoRelatedWarnings : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeneralFailures Class


BuiltInFailures.GeneralFailures.ParameterValueNotInRange Property

BuiltInFailuresGeneralFailuresParameterValueNotInRange Property

The value for [Parameter Name] must be between [Value] and [Value].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ParameterValueNotInRange { get; }
Public Shared ReadOnly Property ParameterValueNotInRange As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ParameterValueNotInRange {
    FailureDefinitionId^ get ();
}
static member ParameterValueNotInRange : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeneralFailures Class


BuiltInFailures.GeneralFailures.ParameterValuesConflict Property

BuiltInFailuresGeneralFailuresParameterValuesConflict Property

The value for [Parameter Name] must be at least [Value] below the value for [Parameter Name].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ParameterValuesConflict { get; }
Public Shared ReadOnly Property ParameterValuesConflict As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ParameterValuesConflict {
    FailureDefinitionId^ get ();
}
static member ParameterValuesConflict : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeneralFailures Class


BuiltInFailures.GeneralFailures.SeriousElementReferenceCorruption Property

BuiltInFailuresGeneralFailuresSeriousElementReferenceCorruption Property

Element references are seriously corrupt.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SeriousElementReferenceCorruption { get; }
Public Shared ReadOnly Property SeriousElementReferenceCorruption As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SeriousElementReferenceCorruption {
    FailureDefinitionId^ get ();
}
static member SeriousElementReferenceCorruption : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeneralFailures Class


BuiltInFailures.GeneralFailures.TransactionFailed Property

BuiltInFailuresGeneralFailuresTransactionFailed Property

[Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TransactionFailed { get; }
Public Shared ReadOnly Property TransactionFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TransactionFailed {
    FailureDefinitionId^ get ();
}
static member TransactionFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeneralFailures Class


BuiltInFailures.GeneralFailures.TransactionFailedWarn Property

BuiltInFailuresGeneralFailuresTransactionFailedWarn Property

[Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TransactionFailedWarn { get; }
Public Shared ReadOnly Property TransactionFailedWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TransactionFailedWarn {
    FailureDefinitionId^ get ();
}
static member TransactionFailedWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeneralFailures Class


BuiltInFailures.GeneralFailures.UnresolvableErrorInFamily Property

BuiltInFailuresGeneralFailuresUnresolvableErrorInFamily Property

An error occurred in family "[Name]" that cannot be automatically resolved.\nError Information:\n"[Text]"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnresolvableErrorInFamily { get; }
Public Shared ReadOnly Property UnresolvableErrorInFamily As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnresolvableErrorInFamily {
    FailureDefinitionId^ get ();
}
static member UnresolvableErrorInFamily : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeneralFailures Class


BuiltInFailures.GeneralFailures.UnresolvableErrorInFamilyWarn Property

BuiltInFailuresGeneralFailuresUnresolvableErrorInFamilyWarn Property

An error occurred in family "[Name]" that cannot be automatically resolved.\nError Information:\n"[Text]"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnresolvableErrorInFamilyWarn { get; }
Public Shared ReadOnly Property UnresolvableErrorInFamilyWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnresolvableErrorInFamilyWarn {
    FailureDefinitionId^ get ();
}
static member UnresolvableErrorInFamilyWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeneralFailures Class


BuiltInFailures.GeneralFailures.UnspecifiedError Property

BuiltInFailuresGeneralFailuresUnspecifiedError Property

Revit has experienced an unexpected error. The operation has been cancelled to protect your project from corruption.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnspecifiedError { get; }
Public Shared ReadOnly Property UnspecifiedError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnspecifiedError {
    FailureDefinitionId^ get ();
}
static member UnspecifiedError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeneralFailures Class


BuiltInFailures.GeneralFailures.ValueOutOfRange Property

BuiltInFailuresGeneralFailuresValueOutOfRange Property

Value is out of range ! Please enter a number between [Value] and [Value].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ValueOutOfRange { get; }
Public Shared ReadOnly Property ValueOutOfRange As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ValueOutOfRange {
    FailureDefinitionId^ get ();
}
static member ValueOutOfRange : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeneralFailures Class


BuiltInFailures.GeneralFailures.WarningInFamilyDismissed Property

BuiltInFailuresGeneralFailuresWarningInFamilyDismissed Property

A warning in family "[Name]" was dismissed. Please review warning information to determine if any changes are necessary\nWarning Information:\n"[Text]"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WarningInFamilyDismissed { get; }
Public Shared ReadOnly Property WarningInFamilyDismissed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WarningInFamilyDismissed {
    FailureDefinitionId^ get ();
}
static member WarningInFamilyDismissed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeneralFailures Class


BuiltInFailures.GenericFailures Class

BuiltInFailuresGenericFailures Class

Generic failures that may apply to any Revit Element
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresGenericFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class GenericFailures
Public NotInheritable Class GenericFailures
public ref class GenericFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type GenericFailures = class end

The BuiltInFailuresGenericFailures type exposes the following members.

Properties
Name | Description
ElementsInInvalidContext | There are elements in the document that exist in a context they should not. These elements must be deleted to continue using this project or family.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


GenericFailures Properties

The BuiltInFailuresGenericFailures type exposes the following members.

Properties
Name | Description
ElementsInInvalidContext | There are elements in the document that exist in a context they should not. These elements must be deleted to continue using this project or family.
Top
See Also

Reference

BuiltInFailuresGenericFailures Class


BuiltInFailures.GenericFailures.ElementsInInvalidContext Property

BuiltInFailuresGenericFailuresElementsInInvalidContext Property

There are elements in the document that exist in a context they should not. These elements must be deleted to continue using this project or family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ElementsInInvalidContext { get; }
Public Shared ReadOnly Property ElementsInInvalidContext As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ElementsInInvalidContext {
    FailureDefinitionId^ get ();
}
static member ElementsInInvalidContext : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGenericFailures Class


BuiltInFailures.GenericMEPFailures Class

BuiltInFailuresGenericMEPFailures Class

Failures applicable to different mechanical, electrical and piping Elements.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresGenericMEPFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class GenericMEPFailures
Public NotInheritable Class GenericMEPFailures
public ref class GenericMEPFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type GenericMEPFailures = class end

The BuiltInFailuresGenericMEPFailures type exposes the following members.

Properties
Name | Description
CapsWereAddedWarning | X caps were added.
CapWasAddedWarning | 1 cap was added.
FailedToPlaceCapWarning | Failed to place cap on the open connector.
FlowConfigMismatch | [Element Name]: It is not possible to calculate the flow since all the components in this system have the flow configuration set to Preset or System. At least one component is required to have the flow configuration set to Calculated.
FlowDirectionMismatch | [Element Name]: It is not possible to calculate the flow since the flow direction mismatch. Please check flow direction on all equipment in this system.
InlineEndoflineMismatch | [Element Name]: It is not possible to calculate the flow since there is inline equipment that is configured as end of line. Please check equipment in this system and make sure that the equipment connectors used inline have a global system classification and a calculated flow configuration. Global equipment connectors used inline should always be linked to each other.
MaxWidthAndHeightReached | Maximum width and height reached during sizing
SegmentIsTooShort | The segment is too short.
SizingFailedZeroFlow | Sizing failed. Flow for section is 0.
SplitElementDeletionWarning | The value specified for the Joint Gap exceeds the length of the split segment, so the segment will be deleted.
ValidatePHSegmentConnWarning | The placeholder curve will not be able to connect to the required fittings for placeholder convert
ValidatePHSegmentLengthWarning | The placeholder curve is not long enough to support the required fittings for placeholder convert
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


GenericMEPFailures Properties

The BuiltInFailuresGenericMEPFailures type exposes the following members.

Properties
Name | Description
CapsWereAddedWarning | X caps were added.
CapWasAddedWarning | 1 cap was added.
FailedToPlaceCapWarning | Failed to place cap on the open connector.
FlowConfigMismatch | [Element Name]: It is not possible to calculate the flow since all the components in this system have the flow configuration set to Preset or System. At least one component is required to have the flow configuration set to Calculated.
FlowDirectionMismatch | [Element Name]: It is not possible to calculate the flow since the flow direction mismatch. Please check flow direction on all equipment in this system.
InlineEndoflineMismatch | [Element Name]: It is not possible to calculate the flow since there is inline equipment that is configured as end of line. Please check equipment in this system and make sure that the equipment connectors used inline have a global system classification and a calculated flow configuration. Global equipment connectors used inline should always be linked to each other.
MaxWidthAndHeightReached | Maximum width and height reached during sizing
SegmentIsTooShort | The segment is too short.
SizingFailedZeroFlow | Sizing failed. Flow for section is 0.
SplitElementDeletionWarning | The value specified for the Joint Gap exceeds the length of the split segment, so the segment will be deleted.
ValidatePHSegmentConnWarning | The placeholder curve will not be able to connect to the required fittings for placeholder convert
ValidatePHSegmentLengthWarning | The placeholder curve is not long enough to support the required fittings for placeholder convert
Top
See Also

Reference

BuiltInFailuresGenericMEPFailures Class


BuiltInFailures.GenericMEPFailures.CapsWereAddedWarning Property

BuiltInFailuresGenericMEPFailuresCapsWereAddedWarning Property

X caps were added.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CapsWereAddedWarning { get; }
Public Shared ReadOnly Property CapsWereAddedWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CapsWereAddedWarning {
    FailureDefinitionId^ get ();
}
static member CapsWereAddedWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGenericMEPFailures Class


BuiltInFailures.GenericMEPFailures.CapWasAddedWarning Property

BuiltInFailuresGenericMEPFailuresCapWasAddedWarning Property

1 cap was added.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CapWasAddedWarning { get; }
Public Shared ReadOnly Property CapWasAddedWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CapWasAddedWarning {
    FailureDefinitionId^ get ();
}
static member CapWasAddedWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGenericMEPFailures Class


BuiltInFailures.GenericMEPFailures.FailedToPlaceCapWarning Property

BuiltInFailuresGenericMEPFailuresFailedToPlaceCapWarning Property

Failed to place cap on the open connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FailedToPlaceCapWarning { get; }
Public Shared ReadOnly Property FailedToPlaceCapWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FailedToPlaceCapWarning {
    FailureDefinitionId^ get ();
}
static member FailedToPlaceCapWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGenericMEPFailures Class


BuiltInFailures.GenericMEPFailures.FlowConfigMismatch Property

BuiltInFailuresGenericMEPFailuresFlowConfigMismatch Property

[Element Name]: It is not possible to calculate the flow since all the components in this system have the flow configuration set to Preset or System. At least one component is required to have the flow configuration set to Calculated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FlowConfigMismatch { get; }
Public Shared ReadOnly Property FlowConfigMismatch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FlowConfigMismatch {
    FailureDefinitionId^ get ();
}
static member FlowConfigMismatch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGenericMEPFailures Class


BuiltInFailures.GenericMEPFailures.FlowDirectionMismatch Property

BuiltInFailuresGenericMEPFailuresFlowDirectionMismatch Property

[Element Name]: It is not possible to calculate the flow since the flow direction mismatch. Please check flow direction on all equipment in this system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FlowDirectionMismatch { get; }
Public Shared ReadOnly Property FlowDirectionMismatch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FlowDirectionMismatch {
    FailureDefinitionId^ get ();
}
static member FlowDirectionMismatch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGenericMEPFailures Class


BuiltInFailures.GenericMEPFailures.InlineEndoflineMismatch Property

BuiltInFailuresGenericMEPFailuresInlineEndoflineMismatch Property

[Element Name]: It is not possible to calculate the flow since there is inline equipment that is configured as end of line. Please check equipment in this system and make sure that the equipment connectors used inline have a global system classification and a calculated flow configuration. Global equipment connectors used inline should always be linked to each other.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InlineEndoflineMismatch { get; }
Public Shared ReadOnly Property InlineEndoflineMismatch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InlineEndoflineMismatch {
    FailureDefinitionId^ get ();
}
static member InlineEndoflineMismatch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGenericMEPFailures Class


BuiltInFailures.GenericMEPFailures.MaxWidthAndHeightReached Property

BuiltInFailuresGenericMEPFailuresMaxWidthAndHeightReached Property

Maximum width and height reached during sizing

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MaxWidthAndHeightReached { get; }
Public Shared ReadOnly Property MaxWidthAndHeightReached As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MaxWidthAndHeightReached {
    FailureDefinitionId^ get ();
}
static member MaxWidthAndHeightReached : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGenericMEPFailures Class


BuiltInFailures.GenericMEPFailures.SegmentIsTooShort Property

BuiltInFailuresGenericMEPFailuresSegmentIsTooShort Property

The segment is too short.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SegmentIsTooShort { get; }
Public Shared ReadOnly Property SegmentIsTooShort As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SegmentIsTooShort {
    FailureDefinitionId^ get ();
}
static member SegmentIsTooShort : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGenericMEPFailures Class


BuiltInFailures.GenericMEPFailures.SizingFailedZeroFlow Property

BuiltInFailuresGenericMEPFailuresSizingFailedZeroFlow Property

Sizing failed. Flow for section is 0.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SizingFailedZeroFlow { get; }
Public Shared ReadOnly Property SizingFailedZeroFlow As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SizingFailedZeroFlow {
    FailureDefinitionId^ get ();
}
static member SizingFailedZeroFlow : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGenericMEPFailures Class


BuiltInFailures.GenericMEPFailures.SplitElementDeletionWarning Property

BuiltInFailuresGenericMEPFailuresSplitElementDeletionWarning Property

The value specified for the Joint Gap exceeds the length of the split segment, so the segment will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SplitElementDeletionWarning { get; }
Public Shared ReadOnly Property SplitElementDeletionWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SplitElementDeletionWarning {
    FailureDefinitionId^ get ();
}
static member SplitElementDeletionWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGenericMEPFailures Class


BuiltInFailures.GenericMEPFailures.ValidatePHSegmentConnWarning Property

BuiltInFailuresGenericMEPFailuresValidatePHSegmentConnWarning Property

The placeholder curve will not be able to connect to the required fittings for placeholder convert

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ValidatePHSegmentConnWarning { get; }
Public Shared ReadOnly Property ValidatePHSegmentConnWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ValidatePHSegmentConnWarning {
    FailureDefinitionId^ get ();
}
static member ValidatePHSegmentConnWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGenericMEPFailures Class


BuiltInFailures.GenericMEPFailures.ValidatePHSegmentLengthWarning Property

BuiltInFailuresGenericMEPFailuresValidatePHSegmentLengthWarning Property

The placeholder curve is not long enough to support the required fittings for placeholder convert

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ValidatePHSegmentLengthWarning { get; }
Public Shared ReadOnly Property ValidatePHSegmentLengthWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ValidatePHSegmentLengthWarning {
    FailureDefinitionId^ get ();
}
static member ValidatePHSegmentLengthWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGenericMEPFailures Class


BuiltInFailures.GeometryFailures Class

BuiltInFailuresGeometryFailures Class

Failures about GeometryFailures.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresGeometryFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class GeometryFailures
Public NotInheritable Class GeometryFailures
public ref class GeometryFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type GeometryFailures = class end

The BuiltInFailuresGeometryFailures type exposes the following members.

Properties
Name | Description
CannotFindClosest | Cannot find closest points within lines.
ConvertFaceRegionsToFacesCrashed | Failed to replace an instance face with its face regions.
ConvertFaceRegionsToFacesFailed | Failed to replace an instance face with its face regions.
CurveAndSurfaceDoNotIntersect | Curve and Surface do not intersect.
CurveDriverError | Element's internal join data is corrupt.
CurveProjectTooShort | The projection of the line in this view is too short to create a new Line
ElementIsTooThin | [Element] is too thin.
ElementTooSmall | Element is too small on screen
FailedReplaceCurveElemCurveDriver | Failed to replace curve elem curve driver.
FailedUpdateCurveChain | Failed to update curve chain.
FailToConvertLine | Unable to convert lines
LineArcTangentFailure | Can't keep arc element and straight line element tangent.
OffsetFaceFailed | Failed to offset the face.
PolygonSegmentTooShort | Polygon segment too short
SiteInvisible | Topographic elements are not visible in your current view. You can modify View Range settings in the view's Properties or Visibility settings in Visibility/Graphics.
SuccessToConvertLine | Success to convert lines
SymbolicLineInvalidPlane | Symbolic Element refers to a Work Plane with unacceptable normal.
TooManyFacesEdges | This family instance has too many [Edges and Faces]. Remove unnecessary geometry or split the instance into multiple instances.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


GeometryFailures Properties

The BuiltInFailuresGeometryFailures type exposes the following members.

Properties
Name | Description
CannotFindClosest | Cannot find closest points within lines.
ConvertFaceRegionsToFacesCrashed | Failed to replace an instance face with its face regions.
ConvertFaceRegionsToFacesFailed | Failed to replace an instance face with its face regions.
CurveAndSurfaceDoNotIntersect | Curve and Surface do not intersect.
CurveDriverError | Element's internal join data is corrupt.
CurveProjectTooShort | The projection of the line in this view is too short to create a new Line
ElementIsTooThin | [Element] is too thin.
ElementTooSmall | Element is too small on screen
FailedReplaceCurveElemCurveDriver | Failed to replace curve elem curve driver.
FailedUpdateCurveChain | Failed to update curve chain.
FailToConvertLine | Unable to convert lines
LineArcTangentFailure | Can't keep arc element and straight line element tangent.
OffsetFaceFailed | Failed to offset the face.
PolygonSegmentTooShort | Polygon segment too short
SiteInvisible | Topographic elements are not visible in your current view. You can modify View Range settings in the view's Properties or Visibility settings in Visibility/Graphics.
SuccessToConvertLine | Success to convert lines
SymbolicLineInvalidPlane | Symbolic Element refers to a Work Plane with unacceptable normal.
TooManyFacesEdges | This family instance has too many [Edges and Faces]. Remove unnecessary geometry or split the instance into multiple instances.
Top
See Also

Reference

BuiltInFailuresGeometryFailures Class


BuiltInFailures.GeometryFailures.CannotFindClosest Property

BuiltInFailuresGeometryFailuresCannotFindClosest Property

Cannot find closest points within lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotFindClosest { get; }
Public Shared ReadOnly Property CannotFindClosest As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotFindClosest {
    FailureDefinitionId^ get ();
}
static member CannotFindClosest : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeometryFailures Class


BuiltInFailures.GeometryFailures.ConvertFaceRegionsToFacesCrashed Property

BuiltInFailuresGeometryFailuresConvertFaceRegionsToFacesCrashed Property

Failed to replace an instance face with its face regions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ConvertFaceRegionsToFacesCrashed { get; }
Public Shared ReadOnly Property ConvertFaceRegionsToFacesCrashed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ConvertFaceRegionsToFacesCrashed {
    FailureDefinitionId^ get ();
}
static member ConvertFaceRegionsToFacesCrashed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeometryFailures Class


BuiltInFailures.GeometryFailures.ConvertFaceRegionsToFacesFailed Property

BuiltInFailuresGeometryFailuresConvertFaceRegionsToFacesFailed Property

Failed to replace an instance face with its face regions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ConvertFaceRegionsToFacesFailed { get; }
Public Shared ReadOnly Property ConvertFaceRegionsToFacesFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ConvertFaceRegionsToFacesFailed {
    FailureDefinitionId^ get ();
}
static member ConvertFaceRegionsToFacesFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeometryFailures Class


BuiltInFailures.GeometryFailures.CurveAndSurfaceDoNotIntersect Property

BuiltInFailuresGeometryFailuresCurveAndSurfaceDoNotIntersect Property

Curve and Surface do not intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CurveAndSurfaceDoNotIntersect { get; }
Public Shared ReadOnly Property CurveAndSurfaceDoNotIntersect As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CurveAndSurfaceDoNotIntersect {
    FailureDefinitionId^ get ();
}
static member CurveAndSurfaceDoNotIntersect : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeometryFailures Class


BuiltInFailures.GeometryFailures.CurveDriverError Property

BuiltInFailuresGeometryFailuresCurveDriverError Property

Element's internal join data is corrupt.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CurveDriverError { get; }
Public Shared ReadOnly Property CurveDriverError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CurveDriverError {
    FailureDefinitionId^ get ();
}
static member CurveDriverError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeometryFailures Class


BuiltInFailures.GeometryFailures.CurveProjectTooShort Property

BuiltInFailuresGeometryFailuresCurveProjectTooShort Property

The projection of the line in this view is too short to create a new Line

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CurveProjectTooShort { get; }
Public Shared ReadOnly Property CurveProjectTooShort As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CurveProjectTooShort {
    FailureDefinitionId^ get ();
}
static member CurveProjectTooShort : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeometryFailures Class


BuiltInFailures.GeometryFailures.ElementIsTooThin Property

BuiltInFailuresGeometryFailuresElementIsTooThin Property

[Element] is too thin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ElementIsTooThin { get; }
Public Shared ReadOnly Property ElementIsTooThin As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ElementIsTooThin {
    FailureDefinitionId^ get ();
}
static member ElementIsTooThin : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeometryFailures Class


BuiltInFailures.GeometryFailures.ElementTooSmall Property

BuiltInFailuresGeometryFailuresElementTooSmall Property

Element is too small on screen

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ElementTooSmall { get; }
Public Shared ReadOnly Property ElementTooSmall As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ElementTooSmall {
    FailureDefinitionId^ get ();
}
static member ElementTooSmall : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeometryFailures Class


BuiltInFailures.GeometryFailures.FailedReplaceCurveElemCurveDriver Property

BuiltInFailuresGeometryFailuresFailedReplaceCurveElemCurveDriver Property

Failed to replace curve elem curve driver.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FailedReplaceCurveElemCurveDriver { get; }
Public Shared ReadOnly Property FailedReplaceCurveElemCurveDriver As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FailedReplaceCurveElemCurveDriver {
    FailureDefinitionId^ get ();
}
static member FailedReplaceCurveElemCurveDriver : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeometryFailures Class


BuiltInFailures.GeometryFailures.FailedUpdateCurveChain Property

BuiltInFailuresGeometryFailuresFailedUpdateCurveChain Property

Failed to update curve chain.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FailedUpdateCurveChain { get; }
Public Shared ReadOnly Property FailedUpdateCurveChain As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FailedUpdateCurveChain {
    FailureDefinitionId^ get ();
}
static member FailedUpdateCurveChain : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeometryFailures Class


BuiltInFailures.GeometryFailures.FailToConvertLine Property

BuiltInFailuresGeometryFailuresFailToConvertLine Property

Unable to convert lines

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FailToConvertLine { get; }
Public Shared ReadOnly Property FailToConvertLine As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FailToConvertLine {
    FailureDefinitionId^ get ();
}
static member FailToConvertLine : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeometryFailures Class


BuiltInFailures.GeometryFailures.LineArcTangentFailure Property

BuiltInFailuresGeometryFailuresLineArcTangentFailure Property

Can't keep arc element and straight line element tangent.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LineArcTangentFailure { get; }
Public Shared ReadOnly Property LineArcTangentFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LineArcTangentFailure {
    FailureDefinitionId^ get ();
}
static member LineArcTangentFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeometryFailures Class


BuiltInFailures.GeometryFailures.OffsetFaceFailed Property

BuiltInFailuresGeometryFailuresOffsetFaceFailed Property

Failed to offset the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId OffsetFaceFailed { get; }
Public Shared ReadOnly Property OffsetFaceFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ OffsetFaceFailed {
    FailureDefinitionId^ get ();
}
static member OffsetFaceFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeometryFailures Class


BuiltInFailures.GeometryFailures.PolygonSegmentTooShort Property

BuiltInFailuresGeometryFailuresPolygonSegmentTooShort Property

Polygon segment too short

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PolygonSegmentTooShort { get; }
Public Shared ReadOnly Property PolygonSegmentTooShort As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PolygonSegmentTooShort {
    FailureDefinitionId^ get ();
}
static member PolygonSegmentTooShort : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeometryFailures Class


BuiltInFailures.GeometryFailures.SiteInvisible Property

BuiltInFailuresGeometryFailuresSiteInvisible Property

Topographic elements are not visible in your current view. You can modify View Range settings in the view's Properties or Visibility settings in Visibility/Graphics.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SiteInvisible { get; }
Public Shared ReadOnly Property SiteInvisible As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SiteInvisible {
    FailureDefinitionId^ get ();
}
static member SiteInvisible : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeometryFailures Class


BuiltInFailures.GeometryFailures.SuccessToConvertLine Property

BuiltInFailuresGeometryFailuresSuccessToConvertLine Property

Success to convert lines

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SuccessToConvertLine { get; }
Public Shared ReadOnly Property SuccessToConvertLine As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SuccessToConvertLine {
    FailureDefinitionId^ get ();
}
static member SuccessToConvertLine : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeometryFailures Class


BuiltInFailures.GeometryFailures.SymbolicLineInvalidPlane Property

BuiltInFailuresGeometryFailuresSymbolicLineInvalidPlane Property

Symbolic Element refers to a Work Plane with unacceptable normal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SymbolicLineInvalidPlane { get; }
Public Shared ReadOnly Property SymbolicLineInvalidPlane As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SymbolicLineInvalidPlane {
    FailureDefinitionId^ get ();
}
static member SymbolicLineInvalidPlane : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeometryFailures Class


BuiltInFailures.GeometryFailures.TooManyFacesEdges Property

BuiltInFailuresGeometryFailuresTooManyFacesEdges Property

This family instance has too many [Edges and Faces]. Remove unnecessary geometry or split the instance into multiple instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TooManyFacesEdges { get; }
Public Shared ReadOnly Property TooManyFacesEdges As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TooManyFacesEdges {
    FailureDefinitionId^ get ();
}
static member TooManyFacesEdges : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGeometryFailures Class


BuiltInFailures.GlobalParameterFailures Class

BuiltInFailuresGlobalParameterFailures Class

Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresGlobalParameterFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class GlobalParameterFailures
Public NotInheritable Class GlobalParameterFailures
public ref class GlobalParameterFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type GlobalParameterFailures = class end

The BuiltInFailuresGlobalParameterFailures type exposes the following members.

Properties
Name | Description
ElementPropLinkCircularChain | Linked properties in highlighted elements cause a circular chain of references.
ElementPropLinkCircularChainError | Linked properties in highlighted elements cause a circular chain of references.
GlobalParamFormulaCircularChain | A formula in a global parameter causes a circular chain of references between highlighted elements.
GlobalParamFormulaCircularChainError | A formula in a global parameter causes a circular chain of references between highlighted elements.
GlobalParamInvalidElemParamValue | Invalid value of parameter %1!s! in highlighted element.
InvalidElementPropToGlobalParamLink | The following parameters of the highlighted element can no longer be linked to global parameters: %1!s!.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


GlobalParameterFailures Properties

The BuiltInFailuresGlobalParameterFailures type exposes the following members.

Properties
Name | Description
ElementPropLinkCircularChain | Linked properties in highlighted elements cause a circular chain of references.
ElementPropLinkCircularChainError | Linked properties in highlighted elements cause a circular chain of references.
GlobalParamFormulaCircularChain | A formula in a global parameter causes a circular chain of references between highlighted elements.
GlobalParamFormulaCircularChainError | A formula in a global parameter causes a circular chain of references between highlighted elements.
GlobalParamInvalidElemParamValue | Invalid value of parameter %1!s! in highlighted element.
InvalidElementPropToGlobalParamLink | The following parameters of the highlighted element can no longer be linked to global parameters: %1!s!.
Top
See Also

Reference

BuiltInFailuresGlobalParameterFailures Class


BuiltInFailures.GlobalParameterFailures.ElementPropLinkCircularChain Property

BuiltInFailuresGlobalParameterFailuresElementPropLinkCircularChain Property

Linked properties in highlighted elements cause a circular chain of references.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ElementPropLinkCircularChain { get; }
Public Shared ReadOnly Property ElementPropLinkCircularChain As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ElementPropLinkCircularChain {
    FailureDefinitionId^ get ();
}
static member ElementPropLinkCircularChain : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGlobalParameterFailures Class


BuiltInFailures.GlobalParameterFailures.ElementPropLinkCircularChainError Property

BuiltInFailuresGlobalParameterFailuresElementPropLinkCircularChainError Property

Linked properties in highlighted elements cause a circular chain of references.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ElementPropLinkCircularChainError { get; }
Public Shared ReadOnly Property ElementPropLinkCircularChainError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ElementPropLinkCircularChainError {
    FailureDefinitionId^ get ();
}
static member ElementPropLinkCircularChainError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGlobalParameterFailures Class


BuiltInFailures.GlobalParameterFailures.GlobalParamFormulaCircularChain Property

BuiltInFailuresGlobalParameterFailuresGlobalParamFormulaCircularChain Property

A formula in a global parameter causes a circular chain of references between highlighted elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId GlobalParamFormulaCircularChain { get; }
Public Shared ReadOnly Property GlobalParamFormulaCircularChain As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ GlobalParamFormulaCircularChain {
    FailureDefinitionId^ get ();
}
static member GlobalParamFormulaCircularChain : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGlobalParameterFailures Class


BuiltInFailures.GlobalParameterFailures.GlobalParamFormulaCircularChainError Property

BuiltInFailuresGlobalParameterFailuresGlobalParamFormulaCircularChainError Property

A formula in a global parameter causes a circular chain of references between highlighted elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId GlobalParamFormulaCircularChainError { get; }
Public Shared ReadOnly Property GlobalParamFormulaCircularChainError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ GlobalParamFormulaCircularChainError {
    FailureDefinitionId^ get ();
}
static member GlobalParamFormulaCircularChainError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGlobalParameterFailures Class


BuiltInFailures.GlobalParameterFailures.GlobalParamInvalidElemParamValue Property

BuiltInFailuresGlobalParameterFailuresGlobalParamInvalidElemParamValue Property

Invalid value of parameter %1!s! in highlighted element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId GlobalParamInvalidElemParamValue { get; }
Public Shared ReadOnly Property GlobalParamInvalidElemParamValue As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ GlobalParamInvalidElemParamValue {
    FailureDefinitionId^ get ();
}
static member GlobalParamInvalidElemParamValue : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGlobalParameterFailures Class


BuiltInFailures.GlobalParameterFailures.InvalidElementPropToGlobalParamLink Property

BuiltInFailuresGlobalParameterFailuresInvalidElementPropToGlobalParamLink Property

The following parameters of the highlighted element can no longer be linked to global parameters: %1!s!.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidElementPropToGlobalParamLink { get; }
Public Shared ReadOnly Property InvalidElementPropToGlobalParamLink As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidElementPropToGlobalParamLink {
    FailureDefinitionId^ get ();
}
static member InvalidElementPropToGlobalParamLink : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGlobalParameterFailures Class


BuiltInFailures.GridChainSketchFailures Class

BuiltInFailuresGridChainSketchFailures Class

Failures related to the GridChain sketch.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresGridChainSketchFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class GridChainSketchFailures
Public NotInheritable Class GridChainSketchFailures
public ref class GridChainSketchFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type GridChainSketchFailures = class end

The BuiltInFailuresGridChainSketchFailures type exposes the following members.

Properties
Name | Description
ClosedLoop | GridChain sketch contains a closed loop.
InvalidSketch | Sketch is invalid. Grid sketch must consist of a single open loop with no intersecting lines.
MoreThanOneLoop | GridChain sketch contains more than one loop.
OverlappingLines | GridChain sketch contains lines which overlap.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


GridChainSketchFailures Properties

The BuiltInFailuresGridChainSketchFailures type exposes the following members.

Properties
Name | Description
ClosedLoop | GridChain sketch contains a closed loop.
InvalidSketch | Sketch is invalid. Grid sketch must consist of a single open loop with no intersecting lines.
MoreThanOneLoop | GridChain sketch contains more than one loop.
OverlappingLines | GridChain sketch contains lines which overlap.
Top
See Also

Reference

BuiltInFailuresGridChainSketchFailures Class


BuiltInFailures.GridChainSketchFailures.ClosedLoop Property

BuiltInFailuresGridChainSketchFailuresClosedLoop Property

GridChain sketch contains a closed loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ClosedLoop { get; }
Public Shared ReadOnly Property ClosedLoop As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ClosedLoop {
    FailureDefinitionId^ get ();
}
static member ClosedLoop : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGridChainSketchFailures Class


BuiltInFailures.GridChainSketchFailures.InvalidSketch Property

BuiltInFailuresGridChainSketchFailuresInvalidSketch Property

Sketch is invalid. Grid sketch must consist of a single open loop with no intersecting lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidSketch { get; }
Public Shared ReadOnly Property InvalidSketch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidSketch {
    FailureDefinitionId^ get ();
}
static member InvalidSketch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGridChainSketchFailures Class


BuiltInFailures.GridChainSketchFailures.MoreThanOneLoop Property

BuiltInFailuresGridChainSketchFailuresMoreThanOneLoop Property

GridChain sketch contains more than one loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MoreThanOneLoop { get; }
Public Shared ReadOnly Property MoreThanOneLoop As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MoreThanOneLoop {
    FailureDefinitionId^ get ();
}
static member MoreThanOneLoop : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGridChainSketchFailures Class


BuiltInFailures.GridChainSketchFailures.OverlappingLines Property

BuiltInFailuresGridChainSketchFailuresOverlappingLines Property

GridChain sketch contains lines which overlap.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId OverlappingLines { get; }
Public Shared ReadOnly Property OverlappingLines As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ OverlappingLines {
    FailureDefinitionId^ get ();
}
static member OverlappingLines : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGridChainSketchFailures Class


BuiltInFailures.GridFailures Class

BuiltInFailuresGridFailures Class

Failures about Grid.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresGridFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class GridFailures
Public NotInheritable Class GridFailures
public ref class GridFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type GridFailures = class end

The BuiltInFailuresGridFailures type exposes the following members.

Properties
Name | Description
GridEndSegmentsLengthTooShort | The end segment length for a grid must be at least [Length Value]
GridInGridChainCannotMirror | A grid that is a sub-grid of a multi-segment grid can only be mirrored if the entire multi-segment grid is being mirrored.
GridlineAxisTooClose | Axis of gridlines should not change order or be closer than [Value] to each other.
GridlineAxisTooFar | Axis of gridlines should not be further than [Value] to each other.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


GridFailures Properties

The BuiltInFailuresGridFailures type exposes the following members.

Properties
Name | Description
GridEndSegmentsLengthTooShort | The end segment length for a grid must be at least [Length Value]
GridInGridChainCannotMirror | A grid that is a sub-grid of a multi-segment grid can only be mirrored if the entire multi-segment grid is being mirrored.
GridlineAxisTooClose | Axis of gridlines should not change order or be closer than [Value] to each other.
GridlineAxisTooFar | Axis of gridlines should not be further than [Value] to each other.
Top
See Also

Reference

BuiltInFailuresGridFailures Class


BuiltInFailures.GridFailures.GridEndSegmentsLengthTooShort Property

BuiltInFailuresGridFailuresGridEndSegmentsLengthTooShort Property

The end segment length for a grid must be at least [Length Value]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId GridEndSegmentsLengthTooShort { get; }
Public Shared ReadOnly Property GridEndSegmentsLengthTooShort As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ GridEndSegmentsLengthTooShort {
    FailureDefinitionId^ get ();
}
static member GridEndSegmentsLengthTooShort : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGridFailures Class


BuiltInFailures.GridFailures.GridInGridChainCannotMirror Property

BuiltInFailuresGridFailuresGridInGridChainCannotMirror Property

A grid that is a sub-grid of a multi-segment grid can only be mirrored if the entire multi-segment grid is being mirrored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId GridInGridChainCannotMirror { get; }
Public Shared ReadOnly Property GridInGridChainCannotMirror As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ GridInGridChainCannotMirror {
    FailureDefinitionId^ get ();
}
static member GridInGridChainCannotMirror : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGridFailures Class


BuiltInFailures.GridFailures.GridlineAxisTooClose Property

BuiltInFailuresGridFailuresGridlineAxisTooClose Property

Axis of gridlines should not change order or be closer than [Value] to each other.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId GridlineAxisTooClose { get; }
Public Shared ReadOnly Property GridlineAxisTooClose As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ GridlineAxisTooClose {
    FailureDefinitionId^ get ();
}
static member GridlineAxisTooClose : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGridFailures Class


BuiltInFailures.GridFailures.GridlineAxisTooFar Property

BuiltInFailuresGridFailuresGridlineAxisTooFar Property

Axis of gridlines should not be further than [Value] to each other.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId GridlineAxisTooFar { get; }
Public Shared ReadOnly Property GridlineAxisTooFar As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ GridlineAxisTooFar {
    FailureDefinitionId^ get ();
}
static member GridlineAxisTooFar : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGridFailures Class


BuiltInFailures.GroupFailures Class

BuiltInFailuresGroupFailures Class

Failures related to groups and their behavior.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresGroupFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class GroupFailures
Public NotInheritable Class GroupFailures
public ref class GroupFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type GroupFailures = class end

The BuiltInFailuresGroupFailures type exposes the following members.

Properties
Name | Description
AdditionalElementsRequired | Grouping the selected elements requires that additional element(s) also be grouped. [Description] To satisfy the grouping requirement, these additional element(s) will be automatically added to the group as well.
AdditionalElementsRequiredRemove | To be able to remove the selected elements from the group the following additional element(s) will also be removed: [Description]
AllElementsRemovedFromGroup | Group "[Type Name]" is now empty and will be deleted.
AtomTouchedNotAllowed | Changes to groups are only allowed during Edit Group mode. Use Edit Group to make this change.
AtomTouchedNotAllowedDelete | Changes to groups are only allowed during Edit Group mode. Use Edit Group to make this change.
AtomViolationWhenMultiPlacedInstances | Changes to groups are allowed only in group edit mode. Use the Edit Group command to change to all instances of a group type. You may use the "Ungroup" option to proceed with this change by ungrouping the changed group instances.
AtomViolationWhenOnePlaceInstance | A group has been changed outside group edit mode. The change is being allowed because there is only one instance of the type.
AttachedGroupNoMirror | Attached detail groups cannot be mirrored without also mirroring their parent group.
AttachedGroupNoPasteToView | An attached group cannot be pasted into the selected view type and has been omitted from the elements being pasted.
BadProblemWithGroup | The operation performed affects groups in an unacceptable manner.
BadViewForAttachedGroup | Attached groups can only be created for view specific elements belonging to non-3d model views.
BadViewForAttachedGroupWarn | Attached groups can only be created for view specific elements belonging to non-3d model views.
CannotAddAlreadyMemberToDiffGroup | Elements that are already members of one group cannot be added to another group.
CannotAddToGroupFormat | [Element] cannot be added to the instance of [Group]
CannotAddToGroupFormatWarn | [Element] cannot be added to the instance of [Group]
CannotCopyGroup | Unable to copy the selected group.
CannotCreateGroup | Cannot create group of these elements.
CannotCreateGroupWithInvalidReferences | The elements you have selected for grouping contain dimensions or tags which do not reference a common model group. No detail group has been created.
CannotFinishGroupInSketchMode | Can't Finish Group while in Sketch Mode.
CannotLinkAnnotationsForSomeViews | Annotations for some views cannot be displayed from linked file.
CannotPlaceGroup | Can't place Group from browser. Try copy/pasting existing copy of the Group instead.
CannotReloadWithFile | Group [Type Name] cannot be reloaded from file [File Name].
CannotRemoveGroupMemberConstraint | Constraints between group members cannot be removed or excluded from the group.
CannotRemoveGroupMemberConstraintWarn | Constraints between group members cannot be removed or excluded from the group.
CannotRemoveSubordFromGroup | Element can't be removed or excluded from the Group because it is required by another Group element.
CannotRemoveSubordFromGroupWarn | Element can't be removed or excluded from the Group because it is required by another Group element.
CannotSaveGroup | Can't save Group.
CannotSwapNestedGroups | Can't replace because one Group is contained in the other.
ChildrenDeletedOnGroupSwap | Some dependent elements were deleted by changing group type and cannot be retained.
ChildrenLostOnGroupSwap | Some elements could not find new hosts after changing group type and will be deleted.
DetailsOfNestedGroupsLost | Details will be deleted if they reference group members being ungrouped in other instances of this containing group.
DimensionsOrTagsReferecedRemoved | Dimensions or Tags that reference non-group members have been removed from group [Name].
DimRefsGroupMemberSketch | A group member's sketch or family is constrained to an element that is not a member of the group. These constraints have been removed.
DontEditNestedGroup | Cannot edit nested Groups while inside Edit Group mode for its host Group. To edit the nested Group finish editing all Groups. Use the Tab key to select the nested Group and edit it directly.
ElementChangedMoreThanAllowed | The Grouped element has changed length enough to make it substantially different from other Group instances. To make this degree of change Edit Group and make the change again.
ElementsContainsFabricationData | Unable to load models containing elements with fabrication data as group.
ExcludedElementsRestoredInLink | Excluded elements restored in the link.
FailedToChangeGroupLevelRef | Unable to change group level ref.
FailedToSetLeaderGroupId | Unable to set id of group type.
FailedToTransformAttachedGroup | Attached group could not be properly relocated.
GroupAmongstLoadedRenamed | A group or groups that was loaded was renamed because its name was not unique amongst the groups in the file being loaded. Most likely a model subgroup had the same name as the loaded file.
GroupCannotMixBackAndForegroundDetail | This detail group contains some elements which display in the background and some which display in the foreground. Detail groups must be able to be displayed as a unit in either the foreground or background, so this type of mixture is not allowed.
GroupCannotSave | The group cannot be saved at this time because one of its instances is being edited.
GroupCannotSaveWarn | The group cannot be saved at this time because one of its instances is being edited.
GroupChangeNoPlaceElements | Elements cannot be placed as a result of changes to groups.
GroupEditModeNoDuplicates | Can't create duplicates in Edit Group mode.
GroupedModelElemHasViewSpecificSubordinates | Unable to group the selected elements. Model element in group has view specific subordinates or view specific element in group has non-view specific subordinates.
GroupHadFailedElementsWhileUpdating | Group members failed while updating group.
GroupPropagationFailedSketch | Can't change Group"[Name]" with more than one instance because it has a Sketch-based element. Edit the Sketch of the element instead.
GroupPropagationFailedUngroup | Can't make change to Group "[Type Name]" with more than one instance. To resolve: Ungroup and Group again under a new name. Edit and make change, then change all instances of the original Group to the new Group.
GroupPropagationUserCancelled | Changes to Group "[Type Name]" have been cancelled.
GroupsHasCycle | Can't create Group because it contains multiple copies of same Group.
GroupsHaveDifferentMembers | Group instances of the same type do not contain identical members. Press "Fix Groups..." to select from options to make the groups consistent.\nCorresponding group members in different group instances diverge in the following respects:[Description]
GroupsNotCompatibleForTypeChange | Some of the selected groups are not compatible with the new group type that was chosen.
GroupViewSpecificDiffViews | You may not create a detail group with view specific elements from different views.
InvalidGroup | This group is invalid.
LastCopyOfGroupDeleted | Last copy of Group "[Name]" deleted. Group type removed from project.
LastGroupMemberExcluded | Last member of group instance was excluded (deleted), removed, or moved to the project. Group instance has been deleted.
LinkVisibilityLost | Link visibility overrides will be lost.
LoadOfGroupAbortedByUser | You have aborted loading file '[File Name]' as a group.
MembersAlignWarn | User parameter values for group members have been aligned.
MembersExcluded | Group members have been excluded from this group instance.
MembersExcludedWarn | Group members have been excluded from this group instance.
MembersMovedToProjectToMakeConsistent | Group members had to be "moved to the project" (removed from their group instance) because they were not consistent with the group type definition.
ModifyingMultiGroups | Multiple groups of the same type are being edited simultaneously outside group edit mode in an unacceptable manner.
MoveElemFailed | Unable to move element.
NoAppropriateGroup | There is no Group that can be placed in the current view.
NoDetailGroups | There are no Detail Groups in this Project or Family.
NoModelGroups | There are no Model Groups in this Project or Family.
NoneOfSelElemsGroupable | None of the selected elements can be grouped. The elements may already be grouped or may be element types which are not allowed for grouping.
NoSwapGroupBeingEdited | You may not change the type of the group that is currently being edited.
NotAGroupFile | This is not a Group File.
NotAllGroupsFullyRestored | Not all of the excluded members of the select groups were fully restored. You may be able to restore the remaining members individually or by performing "restore all excluded members" on sub-groups of the selected groups.
PlaceGroupFailed | Unable to place group instances.
ProblemRegeneratingInGroupUpdate | Unable to regenerate while updating groups at end of transaction.
ReferencesOutsideGroupAreNotAllowed | The elements you have selected for grouping contain dimensions or tags whose references are not all included in the selection being grouped and are not all included in a common model group. As a result, some of the selected elements have not been included in the new group.
RemoveGroupSketchConstraintParent | You are removing an element from the group which is involved in a sketch or family constraint with another element of the same group. Either remove the constraint or cancel the removal of this element from the group.
RemovingElemCannotBeGrouped | Elements that cannot be grouped were removed from groups of type '[Type Name]'.
RemovingReferencesFromGroupedCurve | References to elements outside the group were removed from a grouped curve element.
RevitUnableToUpadateGroups | Unable to update groups for changes.
SomeGroupInstsBecameEmpty | Group instances have had all their group members deleted and will also be deleted.
SomeMembersNotRestored | Revit was not able to restore all of the requested group members. The members may depend on elements that are still excluded.
UnableToBindLink | Unable to bind the selected links.
UnableToBindLinkInstances | Unable to bind some link instances. Either linked file contains no 3d elements or there was an error loading its elements into the current project.
UnableToConvertGroupsToLinks | Unable to convert the selected groups to links.
UnableToCreateAttachedGroup | Unable to create attached detail group in view '[View Name]' for the selected elements.
UnableToDetachGroup | Unable to detach the selected attached detail group(s).
UnableToExcludeElems | Unable to exclude the selected group members.
UnableToGroupElems | Revit does not allow grouping of some of the selected elements. These elements will not be included in the group.
UnableToLoadAttachedGroup | Unable to load attached detail group '[Type Name]'.
UnableToLoadDetailGroup | Unable to load detail group '[Type Name]'.
UnableToLoadGroup | Unable to load file '[File Name]' as a group.
UnableToMaintainExclusions | Unable to maintain exclusion of some group members. Some excluded members have been restored.
UnableToMaintainExclusionsWarn | Unable to maintain exclusion of some group members. Some excluded members have been restored.
UnableToMoveElemsToProject | Revit is unable to move the selected group members to the project.
UnableToRemapDetails | Unable to create attached detail group in view '[View Name]' for the selected elements.
UnableToReplaceSelectedGroups | Unable to change the types of the groups you have selected and the related groups. You might try deleting the groups you wish to change and placing or copy/pasting new groups of the desired type.
UnableToRestoreAllMembersOfGroups | Revit is unable to restore the members of the selected groups.
UnableToSaveGroupType | Unable to save group type.
UnableToTransferAttachedGroup | Unable to load attached group [Type Name] of model group [Type Name].
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


GroupFailures Properties

The BuiltInFailuresGroupFailures type exposes the following members.

Properties
Name | Description
AdditionalElementsRequired | Grouping the selected elements requires that additional element(s) also be grouped. [Description] To satisfy the grouping requirement, these additional element(s) will be automatically added to the group as well.
AdditionalElementsRequiredRemove | To be able to remove the selected elements from the group the following additional element(s) will also be removed: [Description]
AllElementsRemovedFromGroup | Group "[Type Name]" is now empty and will be deleted.
AtomTouchedNotAllowed | Changes to groups are only allowed during Edit Group mode. Use Edit Group to make this change.
AtomTouchedNotAllowedDelete | Changes to groups are only allowed during Edit Group mode. Use Edit Group to make this change.
AtomViolationWhenMultiPlacedInstances | Changes to groups are allowed only in group edit mode. Use the Edit Group command to change to all instances of a group type. You may use the "Ungroup" option to proceed with this change by ungrouping the changed group instances.
AtomViolationWhenOnePlaceInstance | A group has been changed outside group edit mode. The change is being allowed because there is only one instance of the type.
AttachedGroupNoMirror | Attached detail groups cannot be mirrored without also mirroring their parent group.
AttachedGroupNoPasteToView | An attached group cannot be pasted into the selected view type and has been omitted from the elements being pasted.
BadProblemWithGroup | The operation performed affects groups in an unacceptable manner.
BadViewForAttachedGroup | Attached groups can only be created for view specific elements belonging to non-3d model views.
BadViewForAttachedGroupWarn | Attached groups can only be created for view specific elements belonging to non-3d model views.
CannotAddAlreadyMemberToDiffGroup | Elements that are already members of one group cannot be added to another group.
CannotAddToGroupFormat | [Element] cannot be added to the instance of [Group]
CannotAddToGroupFormatWarn | [Element] cannot be added to the instance of [Group]
CannotCopyGroup | Unable to copy the selected group.
CannotCreateGroup | Cannot create group of these elements.
CannotCreateGroupWithInvalidReferences | The elements you have selected for grouping contain dimensions or tags which do not reference a common model group. No detail group has been created.
CannotFinishGroupInSketchMode | Can't Finish Group while in Sketch Mode.
CannotLinkAnnotationsForSomeViews | Annotations for some views cannot be displayed from linked file.
CannotPlaceGroup | Can't place Group from browser. Try copy/pasting existing copy of the Group instead.
CannotReloadWithFile | Group [Type Name] cannot be reloaded from file [File Name].
CannotRemoveGroupMemberConstraint | Constraints between group members cannot be removed or excluded from the group.
CannotRemoveGroupMemberConstraintWarn | Constraints between group members cannot be removed or excluded from the group.
CannotRemoveSubordFromGroup | Element can't be removed or excluded from the Group because it is required by another Group element.
CannotRemoveSubordFromGroupWarn | Element can't be removed or excluded from the Group because it is required by another Group element.
CannotSaveGroup | Can't save Group.
CannotSwapNestedGroups | Can't replace because one Group is contained in the other.
ChildrenDeletedOnGroupSwap | Some dependent elements were deleted by changing group type and cannot be retained.
ChildrenLostOnGroupSwap | Some elements could not find new hosts after changing group type and will be deleted.
DetailsOfNestedGroupsLost | Details will be deleted if they reference group members being ungrouped in other instances of this containing group.
DimensionsOrTagsReferecedRemoved | Dimensions or Tags that reference non-group members have been removed from group [Name].
DimRefsGroupMemberSketch | A group member's sketch or family is constrained to an element that is not a member of the group. These constraints have been removed.
DontEditNestedGroup | Cannot edit nested Groups while inside Edit Group mode for its host Group. To edit the nested Group finish editing all Groups. Use the Tab key to select the nested Group and edit it directly.
ElementChangedMoreThanAllowed | The Grouped element has changed length enough to make it substantially different from other Group instances. To make this degree of change Edit Group and make the change again.
ElementsContainsFabricationData | Unable to load models containing elements with fabrication data as group.
ExcludedElementsRestoredInLink | Excluded elements restored in the link.
FailedToChangeGroupLevelRef | Unable to change group level ref.
FailedToSetLeaderGroupId | Unable to set id of group type.
FailedToTransformAttachedGroup | Attached group could not be properly relocated.
GroupAmongstLoadedRenamed | A group or groups that was loaded was renamed because its name was not unique amongst the groups in the file being loaded. Most likely a model subgroup had the same name as the loaded file.
GroupCannotMixBackAndForegroundDetail | This detail group contains some elements which display in the background and some which display in the foreground. Detail groups must be able to be displayed as a unit in either the foreground or background, so this type of mixture is not allowed.
GroupCannotSave | The group cannot be saved at this time because one of its instances is being edited.
GroupCannotSaveWarn | The group cannot be saved at this time because one of its instances is being edited.
GroupChangeNoPlaceElements | Elements cannot be placed as a result of changes to groups.
GroupEditModeNoDuplicates | Can't create duplicates in Edit Group mode.
GroupedModelElemHasViewSpecificSubordinates | Unable to group the selected elements. Model element in group has view specific subordinates or view specific element in group has non-view specific subordinates.
GroupHadFailedElementsWhileUpdating | Group members failed while updating group.
GroupPropagationFailedSketch | Can't change Group"[Name]" with more than one instance because it has a Sketch-based element. Edit the Sketch of the element instead.
GroupPropagationFailedUngroup | Can't make change to Group "[Type Name]" with more than one instance. To resolve: Ungroup and Group again under a new name. Edit and make change, then change all instances of the original Group to the new Group.
GroupPropagationUserCancelled | Changes to Group "[Type Name]" have been cancelled.
GroupsHasCycle | Can't create Group because it contains multiple copies of same Group.
GroupsHaveDifferentMembers | Group instances of the same type do not contain identical members. Press "Fix Groups..." to select from options to make the groups consistent.\nCorresponding group members in different group instances diverge in the following respects:[Description]
GroupsNotCompatibleForTypeChange | Some of the selected groups are not compatible with the new group type that was chosen.
GroupViewSpecificDiffViews | You may not create a detail group with view specific elements from different views.
InvalidGroup | This group is invalid.
LastCopyOfGroupDeleted | Last copy of Group "[Name]" deleted. Group type removed from project.
LastGroupMemberExcluded | Last member of group instance was excluded (deleted), removed, or moved to the project. Group instance has been deleted.
LinkVisibilityLost | Link visibility overrides will be lost.
LoadOfGroupAbortedByUser | You have aborted loading file '[File Name]' as a group.
MembersAlignWarn | User parameter values for group members have been aligned.
MembersExcluded | Group members have been excluded from this group instance.
MembersExcludedWarn | Group members have been excluded from this group instance.
MembersMovedToProjectToMakeConsistent | Group members had to be "moved to the project" (removed from their group instance) because they were not consistent with the group type definition.
ModifyingMultiGroups | Multiple groups of the same type are being edited simultaneously outside group edit mode in an unacceptable manner.
MoveElemFailed | Unable to move element.
NoAppropriateGroup | There is no Group that can be placed in the current view.
NoDetailGroups | There are no Detail Groups in this Project or Family.
NoModelGroups | There are no Model Groups in this Project or Family.
NoneOfSelElemsGroupable | None of the selected elements can be grouped. The elements may already be grouped or may be element types which are not allowed for grouping.
NoSwapGroupBeingEdited | You may not change the type of the group that is currently being edited.
NotAGroupFile | This is not a Group File.
NotAllGroupsFullyRestored | Not all of the excluded members of the select groups were fully restored. You may be able to restore the remaining members individually or by performing "restore all excluded members" on sub-groups of the selected groups.
PlaceGroupFailed | Unable to place group instances.
ProblemRegeneratingInGroupUpdate | Unable to regenerate while updating groups at end of transaction.
ReferencesOutsideGroupAreNotAllowed | The elements you have selected for grouping contain dimensions or tags whose references are not all included in the selection being grouped and are not all included in a common model group. As a result, some of the selected elements have not been included in the new group.
RemoveGroupSketchConstraintParent | You are removing an element from the group which is involved in a sketch or family constraint with another element of the same group. Either remove the constraint or cancel the removal of this element from the group.
RemovingElemCannotBeGrouped | Elements that cannot be grouped were removed from groups of type '[Type Name]'.
RemovingReferencesFromGroupedCurve | References to elements outside the group were removed from a grouped curve element.
RevitUnableToUpadateGroups | Unable to update groups for changes.
SomeGroupInstsBecameEmpty | Group instances have had all their group members deleted and will also be deleted.
SomeMembersNotRestored | Revit was not able to restore all of the requested group members. The members may depend on elements that are still excluded.
UnableToBindLink | Unable to bind the selected links.
UnableToBindLinkInstances | Unable to bind some link instances. Either linked file contains no 3d elements or there was an error loading its elements into the current project.
UnableToConvertGroupsToLinks | Unable to convert the selected groups to links.
UnableToCreateAttachedGroup | Unable to create attached detail group in view '[View Name]' for the selected elements.
UnableToDetachGroup | Unable to detach the selected attached detail group(s).
UnableToExcludeElems | Unable to exclude the selected group members.
UnableToGroupElems | Revit does not allow grouping of some of the selected elements. These elements will not be included in the group.
UnableToLoadAttachedGroup | Unable to load attached detail group '[Type Name]'.
UnableToLoadDetailGroup | Unable to load detail group '[Type Name]'.
UnableToLoadGroup | Unable to load file '[File Name]' as a group.
UnableToMaintainExclusions | Unable to maintain exclusion of some group members. Some excluded members have been restored.
UnableToMaintainExclusionsWarn | Unable to maintain exclusion of some group members. Some excluded members have been restored.
UnableToMoveElemsToProject | Revit is unable to move the selected group members to the project.
UnableToRemapDetails | Unable to create attached detail group in view '[View Name]' for the selected elements.
UnableToReplaceSelectedGroups | Unable to change the types of the groups you have selected and the related groups. You might try deleting the groups you wish to change and placing or copy/pasting new groups of the desired type.
UnableToRestoreAllMembersOfGroups | Revit is unable to restore the members of the selected groups.
UnableToSaveGroupType | Unable to save group type.
UnableToTransferAttachedGroup | Unable to load attached group [Type Name] of model group [Type Name].
Top
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.AdditionalElementsRequired Property

BuiltInFailuresGroupFailuresAdditionalElementsRequired Property

Grouping the selected elements requires that additional element(s) also be grouped. [Description] To satisfy the grouping requirement, these additional element(s) will be automatically added to the group as well.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AdditionalElementsRequired { get; }
Public Shared ReadOnly Property AdditionalElementsRequired As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AdditionalElementsRequired {
    FailureDefinitionId^ get ();
}
static member AdditionalElementsRequired : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.AdditionalElementsRequiredRemove Property

BuiltInFailuresGroupFailuresAdditionalElementsRequiredRemove Property

To be able to remove the selected elements from the group the following additional element(s) will also be removed: [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AdditionalElementsRequiredRemove { get; }
Public Shared ReadOnly Property AdditionalElementsRequiredRemove As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AdditionalElementsRequiredRemove {
    FailureDefinitionId^ get ();
}
static member AdditionalElementsRequiredRemove : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.AllElementsRemovedFromGroup Property

BuiltInFailuresGroupFailuresAllElementsRemovedFromGroup Property

Group "[Type Name]" is now empty and will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AllElementsRemovedFromGroup { get; }
Public Shared ReadOnly Property AllElementsRemovedFromGroup As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AllElementsRemovedFromGroup {
    FailureDefinitionId^ get ();
}
static member AllElementsRemovedFromGroup : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.AtomTouchedNotAllowed Property

BuiltInFailuresGroupFailuresAtomTouchedNotAllowed Property

Changes to groups are only allowed during Edit Group mode. Use Edit Group to make this change.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AtomTouchedNotAllowed { get; }
Public Shared ReadOnly Property AtomTouchedNotAllowed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AtomTouchedNotAllowed {
    FailureDefinitionId^ get ();
}
static member AtomTouchedNotAllowed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.AtomTouchedNotAllowedDelete Property

BuiltInFailuresGroupFailuresAtomTouchedNotAllowedDelete Property

Changes to groups are only allowed during Edit Group mode. Use Edit Group to make this change.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AtomTouchedNotAllowedDelete { get; }
Public Shared ReadOnly Property AtomTouchedNotAllowedDelete As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AtomTouchedNotAllowedDelete {
    FailureDefinitionId^ get ();
}
static member AtomTouchedNotAllowedDelete : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.AtomViolationWhenMultiPlacedInstances Property

BuiltInFailuresGroupFailuresAtomViolationWhenMultiPlacedInstances Property

Changes to groups are allowed only in group edit mode. Use the Edit Group command to change to all instances of a group type. You may use the "Ungroup" option to proceed with this change by ungrouping the changed group instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AtomViolationWhenMultiPlacedInstances { get; }
Public Shared ReadOnly Property AtomViolationWhenMultiPlacedInstances As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AtomViolationWhenMultiPlacedInstances {
    FailureDefinitionId^ get ();
}
static member AtomViolationWhenMultiPlacedInstances : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.AtomViolationWhenOnePlaceInstance Property

BuiltInFailuresGroupFailuresAtomViolationWhenOnePlaceInstance Property

A group has been changed outside group edit mode. The change is being allowed because there is only one instance of the type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AtomViolationWhenOnePlaceInstance { get; }
Public Shared ReadOnly Property AtomViolationWhenOnePlaceInstance As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AtomViolationWhenOnePlaceInstance {
    FailureDefinitionId^ get ();
}
static member AtomViolationWhenOnePlaceInstance : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.AttachedGroupNoMirror Property

BuiltInFailuresGroupFailuresAttachedGroupNoMirror Property

Attached detail groups cannot be mirrored without also mirroring their parent group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AttachedGroupNoMirror { get; }
Public Shared ReadOnly Property AttachedGroupNoMirror As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AttachedGroupNoMirror {
    FailureDefinitionId^ get ();
}
static member AttachedGroupNoMirror : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.AttachedGroupNoPasteToView Property

BuiltInFailuresGroupFailuresAttachedGroupNoPasteToView Property

An attached group cannot be pasted into the selected view type and has been omitted from the elements being pasted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AttachedGroupNoPasteToView { get; }
Public Shared ReadOnly Property AttachedGroupNoPasteToView As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AttachedGroupNoPasteToView {
    FailureDefinitionId^ get ();
}
static member AttachedGroupNoPasteToView : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.BadProblemWithGroup Property

BuiltInFailuresGroupFailuresBadProblemWithGroup Property

The operation performed affects groups in an unacceptable manner.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BadProblemWithGroup { get; }
Public Shared ReadOnly Property BadProblemWithGroup As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BadProblemWithGroup {
    FailureDefinitionId^ get ();
}
static member BadProblemWithGroup : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.BadViewForAttachedGroup Property

BuiltInFailuresGroupFailuresBadViewForAttachedGroup Property

Attached groups can only be created for view specific elements belonging to non-3d model views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BadViewForAttachedGroup { get; }
Public Shared ReadOnly Property BadViewForAttachedGroup As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BadViewForAttachedGroup {
    FailureDefinitionId^ get ();
}
static member BadViewForAttachedGroup : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.BadViewForAttachedGroupWarn Property

BuiltInFailuresGroupFailuresBadViewForAttachedGroupWarn Property

Attached groups can only be created for view specific elements belonging to non-3d model views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BadViewForAttachedGroupWarn { get; }
Public Shared ReadOnly Property BadViewForAttachedGroupWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BadViewForAttachedGroupWarn {
    FailureDefinitionId^ get ();
}
static member BadViewForAttachedGroupWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.CannotAddAlreadyMemberToDiffGroup Property

BuiltInFailuresGroupFailuresCannotAddAlreadyMemberToDiffGroup Property

Elements that are already members of one group cannot be added to another group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotAddAlreadyMemberToDiffGroup { get; }
Public Shared ReadOnly Property CannotAddAlreadyMemberToDiffGroup As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotAddAlreadyMemberToDiffGroup {
    FailureDefinitionId^ get ();
}
static member CannotAddAlreadyMemberToDiffGroup : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.CannotAddToGroupFormat Property

BuiltInFailuresGroupFailuresCannotAddToGroupFormat Property

[Element] cannot be added to the instance of [Group]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotAddToGroupFormat { get; }
Public Shared ReadOnly Property CannotAddToGroupFormat As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotAddToGroupFormat {
    FailureDefinitionId^ get ();
}
static member CannotAddToGroupFormat : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.CannotAddToGroupFormatWarn Property

BuiltInFailuresGroupFailuresCannotAddToGroupFormatWarn Property

[Element] cannot be added to the instance of [Group]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotAddToGroupFormatWarn { get; }
Public Shared ReadOnly Property CannotAddToGroupFormatWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotAddToGroupFormatWarn {
    FailureDefinitionId^ get ();
}
static member CannotAddToGroupFormatWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.CannotCopyGroup Property

BuiltInFailuresGroupFailuresCannotCopyGroup Property

Unable to copy the selected group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyGroup { get; }
Public Shared ReadOnly Property CannotCopyGroup As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyGroup {
    FailureDefinitionId^ get ();
}
static member CannotCopyGroup : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.CannotCreateGroup Property

BuiltInFailuresGroupFailuresCannotCreateGroup Property

Cannot create group of these elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateGroup { get; }
Public Shared ReadOnly Property CannotCreateGroup As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateGroup {
    FailureDefinitionId^ get ();
}
static member CannotCreateGroup : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.CannotCreateGroupWithInvalidReferences Property

BuiltInFailuresGroupFailuresCannotCreateGroupWithInvalidReferences Property

The elements you have selected for grouping contain dimensions or tags which do not reference a common model group. No detail group has been created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateGroupWithInvalidReferences { get; }
Public Shared ReadOnly Property CannotCreateGroupWithInvalidReferences As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateGroupWithInvalidReferences {
    FailureDefinitionId^ get ();
}
static member CannotCreateGroupWithInvalidReferences : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.CannotFinishGroupInSketchMode Property

BuiltInFailuresGroupFailuresCannotFinishGroupInSketchMode Property

Can't Finish Group while in Sketch Mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotFinishGroupInSketchMode { get; }
Public Shared ReadOnly Property CannotFinishGroupInSketchMode As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotFinishGroupInSketchMode {
    FailureDefinitionId^ get ();
}
static member CannotFinishGroupInSketchMode : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.CannotLinkAnnotationsForSomeViews Property

BuiltInFailuresGroupFailuresCannotLinkAnnotationsForSomeViews Property

Annotations for some views cannot be displayed from linked file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotLinkAnnotationsForSomeViews { get; }
Public Shared ReadOnly Property CannotLinkAnnotationsForSomeViews As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotLinkAnnotationsForSomeViews {
    FailureDefinitionId^ get ();
}
static member CannotLinkAnnotationsForSomeViews : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.CannotPlaceGroup Property

BuiltInFailuresGroupFailuresCannotPlaceGroup Property

Can't place Group from browser. Try copy/pasting existing copy of the Group instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPlaceGroup { get; }
Public Shared ReadOnly Property CannotPlaceGroup As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPlaceGroup {
    FailureDefinitionId^ get ();
}
static member CannotPlaceGroup : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.CannotReloadWithFile Property

BuiltInFailuresGroupFailuresCannotReloadWithFile Property

Group [Type Name] cannot be reloaded from file [File Name].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotReloadWithFile { get; }
Public Shared ReadOnly Property CannotReloadWithFile As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotReloadWithFile {
    FailureDefinitionId^ get ();
}
static member CannotReloadWithFile : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.CannotRemoveGroupMemberConstraint Property

BuiltInFailuresGroupFailuresCannotRemoveGroupMemberConstraint Property

Constraints between group members cannot be removed or excluded from the group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotRemoveGroupMemberConstraint { get; }
Public Shared ReadOnly Property CannotRemoveGroupMemberConstraint As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotRemoveGroupMemberConstraint {
    FailureDefinitionId^ get ();
}
static member CannotRemoveGroupMemberConstraint : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.CannotRemoveGroupMemberConstraintWarn Property

BuiltInFailuresGroupFailuresCannotRemoveGroupMemberConstraintWarn Property

Constraints between group members cannot be removed or excluded from the group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotRemoveGroupMemberConstraintWarn { get; }
Public Shared ReadOnly Property CannotRemoveGroupMemberConstraintWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotRemoveGroupMemberConstraintWarn {
    FailureDefinitionId^ get ();
}
static member CannotRemoveGroupMemberConstraintWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.CannotRemoveSubordFromGroup Property

BuiltInFailuresGroupFailuresCannotRemoveSubordFromGroup Property

Element can't be removed or excluded from the Group because it is required by another Group element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotRemoveSubordFromGroup { get; }
Public Shared ReadOnly Property CannotRemoveSubordFromGroup As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotRemoveSubordFromGroup {
    FailureDefinitionId^ get ();
}
static member CannotRemoveSubordFromGroup : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.CannotRemoveSubordFromGroupWarn Property

BuiltInFailuresGroupFailuresCannotRemoveSubordFromGroupWarn Property

Element can't be removed or excluded from the Group because it is required by another Group element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotRemoveSubordFromGroupWarn { get; }
Public Shared ReadOnly Property CannotRemoveSubordFromGroupWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotRemoveSubordFromGroupWarn {
    FailureDefinitionId^ get ();
}
static member CannotRemoveSubordFromGroupWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.CannotSaveGroup Property

BuiltInFailuresGroupFailuresCannotSaveGroup Property

Can't save Group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotSaveGroup { get; }
Public Shared ReadOnly Property CannotSaveGroup As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotSaveGroup {
    FailureDefinitionId^ get ();
}
static member CannotSaveGroup : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.CannotSwapNestedGroups Property

BuiltInFailuresGroupFailuresCannotSwapNestedGroups Property

Can't replace because one Group is contained in the other.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotSwapNestedGroups { get; }
Public Shared ReadOnly Property CannotSwapNestedGroups As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotSwapNestedGroups {
    FailureDefinitionId^ get ();
}
static member CannotSwapNestedGroups : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.ChildrenDeletedOnGroupSwap Property

BuiltInFailuresGroupFailuresChildrenDeletedOnGroupSwap Property

Some dependent elements were deleted by changing group type and cannot be retained.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ChildrenDeletedOnGroupSwap { get; }
Public Shared ReadOnly Property ChildrenDeletedOnGroupSwap As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ChildrenDeletedOnGroupSwap {
    FailureDefinitionId^ get ();
}
static member ChildrenDeletedOnGroupSwap : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.ChildrenLostOnGroupSwap Property

BuiltInFailuresGroupFailuresChildrenLostOnGroupSwap Property

Some elements could not find new hosts after changing group type and will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ChildrenLostOnGroupSwap { get; }
Public Shared ReadOnly Property ChildrenLostOnGroupSwap As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ChildrenLostOnGroupSwap {
    FailureDefinitionId^ get ();
}
static member ChildrenLostOnGroupSwap : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.DetailsOfNestedGroupsLost Property

BuiltInFailuresGroupFailuresDetailsOfNestedGroupsLost Property

Details will be deleted if they reference group members being ungrouped in other instances of this containing group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DetailsOfNestedGroupsLost { get; }
Public Shared ReadOnly Property DetailsOfNestedGroupsLost As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DetailsOfNestedGroupsLost {
    FailureDefinitionId^ get ();
}
static member DetailsOfNestedGroupsLost : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.DimensionsOrTagsReferecedRemoved Property

BuiltInFailuresGroupFailuresDimensionsOrTagsReferecedRemoved Property

Dimensions or Tags that reference non-group members have been removed from group [Name].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DimensionsOrTagsReferecedRemoved { get; }
Public Shared ReadOnly Property DimensionsOrTagsReferecedRemoved As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DimensionsOrTagsReferecedRemoved {
    FailureDefinitionId^ get ();
}
static member DimensionsOrTagsReferecedRemoved : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.DimRefsGroupMemberSketch Property

BuiltInFailuresGroupFailuresDimRefsGroupMemberSketch Property

A group member's sketch or family is constrained to an element that is not a member of the group. These constraints have been removed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DimRefsGroupMemberSketch { get; }
Public Shared ReadOnly Property DimRefsGroupMemberSketch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DimRefsGroupMemberSketch {
    FailureDefinitionId^ get ();
}
static member DimRefsGroupMemberSketch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.DontEditNestedGroup Property

BuiltInFailuresGroupFailuresDontEditNestedGroup Property

Cannot edit nested Groups while inside Edit Group mode for its host Group. To edit the nested Group finish editing all Groups. Use the Tab key to select the nested Group and edit it directly.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DontEditNestedGroup { get; }
Public Shared ReadOnly Property DontEditNestedGroup As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DontEditNestedGroup {
    FailureDefinitionId^ get ();
}
static member DontEditNestedGroup : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.ElementChangedMoreThanAllowed Property

BuiltInFailuresGroupFailuresElementChangedMoreThanAllowed Property

The Grouped element has changed length enough to make it substantially different from other Group instances. To make this degree of change Edit Group and make the change again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ElementChangedMoreThanAllowed { get; }
Public Shared ReadOnly Property ElementChangedMoreThanAllowed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ElementChangedMoreThanAllowed {
    FailureDefinitionId^ get ();
}
static member ElementChangedMoreThanAllowed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.ElementsContainsFabricationData Property

BuiltInFailuresGroupFailuresElementsContainsFabricationData Property

Unable to load models containing elements with fabrication data as group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ElementsContainsFabricationData { get; }
Public Shared ReadOnly Property ElementsContainsFabricationData As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ElementsContainsFabricationData {
    FailureDefinitionId^ get ();
}
static member ElementsContainsFabricationData : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.ExcludedElementsRestoredInLink Property

BuiltInFailuresGroupFailuresExcludedElementsRestoredInLink Property

Excluded elements restored in the link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ExcludedElementsRestoredInLink { get; }
Public Shared ReadOnly Property ExcludedElementsRestoredInLink As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ExcludedElementsRestoredInLink {
    FailureDefinitionId^ get ();
}
static member ExcludedElementsRestoredInLink : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.FailedToChangeGroupLevelRef Property

BuiltInFailuresGroupFailuresFailedToChangeGroupLevelRef Property

Unable to change group level ref.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FailedToChangeGroupLevelRef { get; }
Public Shared ReadOnly Property FailedToChangeGroupLevelRef As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FailedToChangeGroupLevelRef {
    FailureDefinitionId^ get ();
}
static member FailedToChangeGroupLevelRef : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.FailedToSetLeaderGroupId Property

BuiltInFailuresGroupFailuresFailedToSetLeaderGroupId Property

Unable to set id of group type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FailedToSetLeaderGroupId { get; }
Public Shared ReadOnly Property FailedToSetLeaderGroupId As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FailedToSetLeaderGroupId {
    FailureDefinitionId^ get ();
}
static member FailedToSetLeaderGroupId : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.FailedToTransformAttachedGroup Property

BuiltInFailuresGroupFailuresFailedToTransformAttachedGroup Property

Attached group could not be properly relocated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FailedToTransformAttachedGroup { get; }
Public Shared ReadOnly Property FailedToTransformAttachedGroup As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FailedToTransformAttachedGroup {
    FailureDefinitionId^ get ();
}
static member FailedToTransformAttachedGroup : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.GroupAmongstLoadedRenamed Property

BuiltInFailuresGroupFailuresGroupAmongstLoadedRenamed Property

A group or groups that was loaded was renamed because its name was not unique amongst the groups in the file being loaded. Most likely a model subgroup had the same name as the loaded file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId GroupAmongstLoadedRenamed { get; }
Public Shared ReadOnly Property GroupAmongstLoadedRenamed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ GroupAmongstLoadedRenamed {
    FailureDefinitionId^ get ();
}
static member GroupAmongstLoadedRenamed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.GroupCannotMixBackAndForegroundDetail Property

BuiltInFailuresGroupFailuresGroupCannotMixBackAndForegroundDetail Property

This detail group contains some elements which display in the background and some which display in the foreground. Detail groups must be able to be displayed as a unit in either the foreground or background, so this type of mixture is not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId GroupCannotMixBackAndForegroundDetail { get; }
Public Shared ReadOnly Property GroupCannotMixBackAndForegroundDetail As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ GroupCannotMixBackAndForegroundDetail {
    FailureDefinitionId^ get ();
}
static member GroupCannotMixBackAndForegroundDetail : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.GroupCannotSave Property

BuiltInFailuresGroupFailuresGroupCannotSave Property

The group cannot be saved at this time because one of its instances is being edited.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId GroupCannotSave { get; }
Public Shared ReadOnly Property GroupCannotSave As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ GroupCannotSave {
    FailureDefinitionId^ get ();
}
static member GroupCannotSave : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.GroupCannotSaveWarn Property

BuiltInFailuresGroupFailuresGroupCannotSaveWarn Property

The group cannot be saved at this time because one of its instances is being edited.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId GroupCannotSaveWarn { get; }
Public Shared ReadOnly Property GroupCannotSaveWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ GroupCannotSaveWarn {
    FailureDefinitionId^ get ();
}
static member GroupCannotSaveWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.GroupChangeNoPlaceElements Property

BuiltInFailuresGroupFailuresGroupChangeNoPlaceElements Property

Elements cannot be placed as a result of changes to groups.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId GroupChangeNoPlaceElements { get; }
Public Shared ReadOnly Property GroupChangeNoPlaceElements As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ GroupChangeNoPlaceElements {
    FailureDefinitionId^ get ();
}
static member GroupChangeNoPlaceElements : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.GroupEditModeNoDuplicates Property

BuiltInFailuresGroupFailuresGroupEditModeNoDuplicates Property

Can't create duplicates in Edit Group mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId GroupEditModeNoDuplicates { get; }
Public Shared ReadOnly Property GroupEditModeNoDuplicates As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ GroupEditModeNoDuplicates {
    FailureDefinitionId^ get ();
}
static member GroupEditModeNoDuplicates : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.GroupedModelElemHasViewSpecificSubordinates Property

BuiltInFailuresGroupFailuresGroupedModelElemHasViewSpecificSubordinates Property

Unable to group the selected elements. Model element in group has view specific subordinates or view specific element in group has non-view specific subordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId GroupedModelElemHasViewSpecificSubordinates { get; }
Public Shared ReadOnly Property GroupedModelElemHasViewSpecificSubordinates As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ GroupedModelElemHasViewSpecificSubordinates {
    FailureDefinitionId^ get ();
}
static member GroupedModelElemHasViewSpecificSubordinates : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.GroupHadFailedElementsWhileUpdating Property

BuiltInFailuresGroupFailuresGroupHadFailedElementsWhileUpdating Property

Group members failed while updating group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId GroupHadFailedElementsWhileUpdating { get; }
Public Shared ReadOnly Property GroupHadFailedElementsWhileUpdating As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ GroupHadFailedElementsWhileUpdating {
    FailureDefinitionId^ get ();
}
static member GroupHadFailedElementsWhileUpdating : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.GroupPropagationFailedSketch Property

BuiltInFailuresGroupFailuresGroupPropagationFailedSketch Property

Can't change Group"[Name]" with more than one instance because it has a Sketch-based element. Edit the Sketch of the element instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId GroupPropagationFailedSketch { get; }
Public Shared ReadOnly Property GroupPropagationFailedSketch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ GroupPropagationFailedSketch {
    FailureDefinitionId^ get ();
}
static member GroupPropagationFailedSketch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.GroupPropagationFailedUngroup Property

BuiltInFailuresGroupFailuresGroupPropagationFailedUngroup Property

Can't make change to Group "[Type Name]" with more than one instance. To resolve: Ungroup and Group again under a new name. Edit and make change, then change all instances of the original Group to the new Group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId GroupPropagationFailedUngroup { get; }
Public Shared ReadOnly Property GroupPropagationFailedUngroup As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ GroupPropagationFailedUngroup {
    FailureDefinitionId^ get ();
}
static member GroupPropagationFailedUngroup : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.GroupPropagationUserCancelled Property

BuiltInFailuresGroupFailuresGroupPropagationUserCancelled Property

Changes to Group "[Type Name]" have been cancelled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId GroupPropagationUserCancelled { get; }
Public Shared ReadOnly Property GroupPropagationUserCancelled As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ GroupPropagationUserCancelled {
    FailureDefinitionId^ get ();
}
static member GroupPropagationUserCancelled : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.GroupsHasCycle Property

BuiltInFailuresGroupFailuresGroupsHasCycle Property

Can't create Group because it contains multiple copies of same Group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId GroupsHasCycle { get; }
Public Shared ReadOnly Property GroupsHasCycle As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ GroupsHasCycle {
    FailureDefinitionId^ get ();
}
static member GroupsHasCycle : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.GroupsHaveDifferentMembers Property

BuiltInFailuresGroupFailuresGroupsHaveDifferentMembers Property

Group instances of the same type do not contain identical members. Press "Fix Groups..." to select from options to make the groups consistent.\nCorresponding group members in different group instances diverge in the following respects:[Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId GroupsHaveDifferentMembers { get; }
Public Shared ReadOnly Property GroupsHaveDifferentMembers As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ GroupsHaveDifferentMembers {
    FailureDefinitionId^ get ();
}
static member GroupsHaveDifferentMembers : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.GroupsNotCompatibleForTypeChange Property

BuiltInFailuresGroupFailuresGroupsNotCompatibleForTypeChange Property

Some of the selected groups are not compatible with the new group type that was chosen.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId GroupsNotCompatibleForTypeChange { get; }
Public Shared ReadOnly Property GroupsNotCompatibleForTypeChange As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ GroupsNotCompatibleForTypeChange {
    FailureDefinitionId^ get ();
}
static member GroupsNotCompatibleForTypeChange : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.GroupViewSpecificDiffViews Property

BuiltInFailuresGroupFailuresGroupViewSpecificDiffViews Property

You may not create a detail group with view specific elements from different views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId GroupViewSpecificDiffViews { get; }
Public Shared ReadOnly Property GroupViewSpecificDiffViews As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ GroupViewSpecificDiffViews {
    FailureDefinitionId^ get ();
}
static member GroupViewSpecificDiffViews : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.InvalidGroup Property

BuiltInFailuresGroupFailuresInvalidGroup Property

This group is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidGroup { get; }
Public Shared ReadOnly Property InvalidGroup As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidGroup {
    FailureDefinitionId^ get ();
}
static member InvalidGroup : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.LastCopyOfGroupDeleted Property

BuiltInFailuresGroupFailuresLastCopyOfGroupDeleted Property

Last copy of Group "[Name]" deleted. Group type removed from project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LastCopyOfGroupDeleted { get; }
Public Shared ReadOnly Property LastCopyOfGroupDeleted As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LastCopyOfGroupDeleted {
    FailureDefinitionId^ get ();
}
static member LastCopyOfGroupDeleted : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.LastGroupMemberExcluded Property

BuiltInFailuresGroupFailuresLastGroupMemberExcluded Property

Last member of group instance was excluded (deleted), removed, or moved to the project. Group instance has been deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LastGroupMemberExcluded { get; }
Public Shared ReadOnly Property LastGroupMemberExcluded As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LastGroupMemberExcluded {
    FailureDefinitionId^ get ();
}
static member LastGroupMemberExcluded : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.LinkVisibilityLost Property

BuiltInFailuresGroupFailuresLinkVisibilityLost Property

Link visibility overrides will be lost.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LinkVisibilityLost { get; }
Public Shared ReadOnly Property LinkVisibilityLost As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LinkVisibilityLost {
    FailureDefinitionId^ get ();
}
static member LinkVisibilityLost : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.LoadOfGroupAbortedByUser Property

BuiltInFailuresGroupFailuresLoadOfGroupAbortedByUser Property

You have aborted loading file '[File Name]' as a group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LoadOfGroupAbortedByUser { get; }
Public Shared ReadOnly Property LoadOfGroupAbortedByUser As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LoadOfGroupAbortedByUser {
    FailureDefinitionId^ get ();
}
static member LoadOfGroupAbortedByUser : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.MembersAlignWarn Property

BuiltInFailuresGroupFailuresMembersAlignWarn Property

User parameter values for group members have been aligned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MembersAlignWarn { get; }
Public Shared ReadOnly Property MembersAlignWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MembersAlignWarn {
    FailureDefinitionId^ get ();
}
static member MembersAlignWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.MembersExcluded Property

BuiltInFailuresGroupFailuresMembersExcluded Property

Group members have been excluded from this group instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MembersExcluded { get; }
Public Shared ReadOnly Property MembersExcluded As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MembersExcluded {
    FailureDefinitionId^ get ();
}
static member MembersExcluded : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.MembersExcludedWarn Property

BuiltInFailuresGroupFailuresMembersExcludedWarn Property

Group members have been excluded from this group instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MembersExcludedWarn { get; }
Public Shared ReadOnly Property MembersExcludedWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MembersExcludedWarn {
    FailureDefinitionId^ get ();
}
static member MembersExcludedWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.MembersMovedToProjectToMakeConsistent Property

BuiltInFailuresGroupFailuresMembersMovedToProjectToMakeConsistent Property

Group members had to be "moved to the project" (removed from their group instance) because they were not consistent with the group type definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MembersMovedToProjectToMakeConsistent { get; }
Public Shared ReadOnly Property MembersMovedToProjectToMakeConsistent As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MembersMovedToProjectToMakeConsistent {
    FailureDefinitionId^ get ();
}
static member MembersMovedToProjectToMakeConsistent : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.ModifyingMultiGroups Property

BuiltInFailuresGroupFailuresModifyingMultiGroups Property

Multiple groups of the same type are being edited simultaneously outside group edit mode in an unacceptable manner.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ModifyingMultiGroups { get; }
Public Shared ReadOnly Property ModifyingMultiGroups As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ModifyingMultiGroups {
    FailureDefinitionId^ get ();
}
static member ModifyingMultiGroups : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.MoveElemFailed Property

BuiltInFailuresGroupFailuresMoveElemFailed Property

Unable to move element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MoveElemFailed { get; }
Public Shared ReadOnly Property MoveElemFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MoveElemFailed {
    FailureDefinitionId^ get ();
}
static member MoveElemFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.NoAppropriateGroup Property

BuiltInFailuresGroupFailuresNoAppropriateGroup Property

There is no Group that can be placed in the current view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoAppropriateGroup { get; }
Public Shared ReadOnly Property NoAppropriateGroup As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoAppropriateGroup {
    FailureDefinitionId^ get ();
}
static member NoAppropriateGroup : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.NoDetailGroups Property

BuiltInFailuresGroupFailuresNoDetailGroups Property

There are no Detail Groups in this Project or Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoDetailGroups { get; }
Public Shared ReadOnly Property NoDetailGroups As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoDetailGroups {
    FailureDefinitionId^ get ();
}
static member NoDetailGroups : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.NoModelGroups Property

BuiltInFailuresGroupFailuresNoModelGroups Property

There are no Model Groups in this Project or Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoModelGroups { get; }
Public Shared ReadOnly Property NoModelGroups As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoModelGroups {
    FailureDefinitionId^ get ();
}
static member NoModelGroups : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.NoneOfSelElemsGroupable Property

BuiltInFailuresGroupFailuresNoneOfSelElemsGroupable Property

None of the selected elements can be grouped. The elements may already be grouped or may be element types which are not allowed for grouping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoneOfSelElemsGroupable { get; }
Public Shared ReadOnly Property NoneOfSelElemsGroupable As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoneOfSelElemsGroupable {
    FailureDefinitionId^ get ();
}
static member NoneOfSelElemsGroupable : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.NoSwapGroupBeingEdited Property

BuiltInFailuresGroupFailuresNoSwapGroupBeingEdited Property

You may not change the type of the group that is currently being edited.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoSwapGroupBeingEdited { get; }
Public Shared ReadOnly Property NoSwapGroupBeingEdited As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoSwapGroupBeingEdited {
    FailureDefinitionId^ get ();
}
static member NoSwapGroupBeingEdited : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.NotAGroupFile Property

BuiltInFailuresGroupFailuresNotAGroupFile Property

This is not a Group File.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotAGroupFile { get; }
Public Shared ReadOnly Property NotAGroupFile As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotAGroupFile {
    FailureDefinitionId^ get ();
}
static member NotAGroupFile : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.NotAllGroupsFullyRestored Property

BuiltInFailuresGroupFailuresNotAllGroupsFullyRestored Property

Not all of the excluded members of the select groups were fully restored. You may be able to restore the remaining members individually or by performing "restore all excluded members" on sub-groups of the selected groups.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotAllGroupsFullyRestored { get; }
Public Shared ReadOnly Property NotAllGroupsFullyRestored As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotAllGroupsFullyRestored {
    FailureDefinitionId^ get ();
}
static member NotAllGroupsFullyRestored : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.PlaceGroupFailed Property

BuiltInFailuresGroupFailuresPlaceGroupFailed Property

Unable to place group instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PlaceGroupFailed { get; }
Public Shared ReadOnly Property PlaceGroupFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PlaceGroupFailed {
    FailureDefinitionId^ get ();
}
static member PlaceGroupFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.ProblemRegeneratingInGroupUpdate Property

BuiltInFailuresGroupFailuresProblemRegeneratingInGroupUpdate Property

Unable to regenerate while updating groups at end of transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ProblemRegeneratingInGroupUpdate { get; }
Public Shared ReadOnly Property ProblemRegeneratingInGroupUpdate As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ProblemRegeneratingInGroupUpdate {
    FailureDefinitionId^ get ();
}
static member ProblemRegeneratingInGroupUpdate : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.ReferencesOutsideGroupAreNotAllowed Property

BuiltInFailuresGroupFailuresReferencesOutsideGroupAreNotAllowed Property

The elements you have selected for grouping contain dimensions or tags whose references are not all included in the selection being grouped and are not all included in a common model group. As a result, some of the selected elements have not been included in the new group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ReferencesOutsideGroupAreNotAllowed { get; }
Public Shared ReadOnly Property ReferencesOutsideGroupAreNotAllowed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ReferencesOutsideGroupAreNotAllowed {
    FailureDefinitionId^ get ();
}
static member ReferencesOutsideGroupAreNotAllowed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.RemoveGroupSketchConstraintParent Property

BuiltInFailuresGroupFailuresRemoveGroupSketchConstraintParent Property

You are removing an element from the group which is involved in a sketch or family constraint with another element of the same group. Either remove the constraint or cancel the removal of this element from the group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RemoveGroupSketchConstraintParent { get; }
Public Shared ReadOnly Property RemoveGroupSketchConstraintParent As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RemoveGroupSketchConstraintParent {
    FailureDefinitionId^ get ();
}
static member RemoveGroupSketchConstraintParent : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.RemovingElemCannotBeGrouped Property

BuiltInFailuresGroupFailuresRemovingElemCannotBeGrouped Property

Elements that cannot be grouped were removed from groups of type '[Type Name]'.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RemovingElemCannotBeGrouped { get; }
Public Shared ReadOnly Property RemovingElemCannotBeGrouped As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RemovingElemCannotBeGrouped {
    FailureDefinitionId^ get ();
}
static member RemovingElemCannotBeGrouped : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.RemovingReferencesFromGroupedCurve Property

BuiltInFailuresGroupFailuresRemovingReferencesFromGroupedCurve Property

References to elements outside the group were removed from a grouped curve element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RemovingReferencesFromGroupedCurve { get; }
Public Shared ReadOnly Property RemovingReferencesFromGroupedCurve As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RemovingReferencesFromGroupedCurve {
    FailureDefinitionId^ get ();
}
static member RemovingReferencesFromGroupedCurve : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.RevitUnableToUpadateGroups Property

BuiltInFailuresGroupFailuresRevitUnableToUpadateGroups Property

Unable to update groups for changes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RevitUnableToUpadateGroups { get; }
Public Shared ReadOnly Property RevitUnableToUpadateGroups As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RevitUnableToUpadateGroups {
    FailureDefinitionId^ get ();
}
static member RevitUnableToUpadateGroups : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.SomeGroupInstsBecameEmpty Property

BuiltInFailuresGroupFailuresSomeGroupInstsBecameEmpty Property

Group instances have had all their group members deleted and will also be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SomeGroupInstsBecameEmpty { get; }
Public Shared ReadOnly Property SomeGroupInstsBecameEmpty As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SomeGroupInstsBecameEmpty {
    FailureDefinitionId^ get ();
}
static member SomeGroupInstsBecameEmpty : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.SomeMembersNotRestored Property

BuiltInFailuresGroupFailuresSomeMembersNotRestored Property

Revit was not able to restore all of the requested group members. The members may depend on elements that are still excluded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SomeMembersNotRestored { get; }
Public Shared ReadOnly Property SomeMembersNotRestored As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SomeMembersNotRestored {
    FailureDefinitionId^ get ();
}
static member SomeMembersNotRestored : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.UnableToBindLink Property

BuiltInFailuresGroupFailuresUnableToBindLink Property

Unable to bind the selected links.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnableToBindLink { get; }
Public Shared ReadOnly Property UnableToBindLink As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnableToBindLink {
    FailureDefinitionId^ get ();
}
static member UnableToBindLink : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.UnableToBindLinkInstances Property

BuiltInFailuresGroupFailuresUnableToBindLinkInstances Property

Unable to bind some link instances. Either linked file contains no 3d elements or there was an error loading its elements into the current project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnableToBindLinkInstances { get; }
Public Shared ReadOnly Property UnableToBindLinkInstances As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnableToBindLinkInstances {
    FailureDefinitionId^ get ();
}
static member UnableToBindLinkInstances : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.UnableToConvertGroupsToLinks Property

BuiltInFailuresGroupFailuresUnableToConvertGroupsToLinks Property

Unable to convert the selected groups to links.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnableToConvertGroupsToLinks { get; }
Public Shared ReadOnly Property UnableToConvertGroupsToLinks As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnableToConvertGroupsToLinks {
    FailureDefinitionId^ get ();
}
static member UnableToConvertGroupsToLinks : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.UnableToCreateAttachedGroup Property

BuiltInFailuresGroupFailuresUnableToCreateAttachedGroup Property

Unable to create attached detail group in view '[View Name]' for the selected elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnableToCreateAttachedGroup { get; }
Public Shared ReadOnly Property UnableToCreateAttachedGroup As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnableToCreateAttachedGroup {
    FailureDefinitionId^ get ();
}
static member UnableToCreateAttachedGroup : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.UnableToDetachGroup Property

BuiltInFailuresGroupFailuresUnableToDetachGroup Property

Unable to detach the selected attached detail group(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnableToDetachGroup { get; }
Public Shared ReadOnly Property UnableToDetachGroup As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnableToDetachGroup {
    FailureDefinitionId^ get ();
}
static member UnableToDetachGroup : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.UnableToExcludeElems Property

BuiltInFailuresGroupFailuresUnableToExcludeElems Property

Unable to exclude the selected group members.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnableToExcludeElems { get; }
Public Shared ReadOnly Property UnableToExcludeElems As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnableToExcludeElems {
    FailureDefinitionId^ get ();
}
static member UnableToExcludeElems : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.UnableToGroupElems Property

BuiltInFailuresGroupFailuresUnableToGroupElems Property

Revit does not allow grouping of some of the selected elements. These elements will not be included in the group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnableToGroupElems { get; }
Public Shared ReadOnly Property UnableToGroupElems As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnableToGroupElems {
    FailureDefinitionId^ get ();
}
static member UnableToGroupElems : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.UnableToLoadAttachedGroup Property

BuiltInFailuresGroupFailuresUnableToLoadAttachedGroup Property

Unable to load attached detail group '[Type Name]'.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnableToLoadAttachedGroup { get; }
Public Shared ReadOnly Property UnableToLoadAttachedGroup As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnableToLoadAttachedGroup {
    FailureDefinitionId^ get ();
}
static member UnableToLoadAttachedGroup : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.UnableToLoadDetailGroup Property

BuiltInFailuresGroupFailuresUnableToLoadDetailGroup Property

Unable to load detail group '[Type Name]'.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnableToLoadDetailGroup { get; }
Public Shared ReadOnly Property UnableToLoadDetailGroup As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnableToLoadDetailGroup {
    FailureDefinitionId^ get ();
}
static member UnableToLoadDetailGroup : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.UnableToLoadGroup Property

BuiltInFailuresGroupFailuresUnableToLoadGroup Property

Unable to load file '[File Name]' as a group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnableToLoadGroup { get; }
Public Shared ReadOnly Property UnableToLoadGroup As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnableToLoadGroup {
    FailureDefinitionId^ get ();
}
static member UnableToLoadGroup : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.UnableToMaintainExclusions Property

BuiltInFailuresGroupFailuresUnableToMaintainExclusions Property

Unable to maintain exclusion of some group members. Some excluded members have been restored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnableToMaintainExclusions { get; }
Public Shared ReadOnly Property UnableToMaintainExclusions As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnableToMaintainExclusions {
    FailureDefinitionId^ get ();
}
static member UnableToMaintainExclusions : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.UnableToMaintainExclusionsWarn Property

BuiltInFailuresGroupFailuresUnableToMaintainExclusionsWarn Property

Unable to maintain exclusion of some group members. Some excluded members have been restored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnableToMaintainExclusionsWarn { get; }
Public Shared ReadOnly Property UnableToMaintainExclusionsWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnableToMaintainExclusionsWarn {
    FailureDefinitionId^ get ();
}
static member UnableToMaintainExclusionsWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.UnableToMoveElemsToProject Property

BuiltInFailuresGroupFailuresUnableToMoveElemsToProject Property

Revit is unable to move the selected group members to the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnableToMoveElemsToProject { get; }
Public Shared ReadOnly Property UnableToMoveElemsToProject As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnableToMoveElemsToProject {
    FailureDefinitionId^ get ();
}
static member UnableToMoveElemsToProject : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.UnableToRemapDetails Property

BuiltInFailuresGroupFailuresUnableToRemapDetails Property

Unable to create attached detail group in view '[View Name]' for the selected elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnableToRemapDetails { get; }
Public Shared ReadOnly Property UnableToRemapDetails As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnableToRemapDetails {
    FailureDefinitionId^ get ();
}
static member UnableToRemapDetails : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.UnableToReplaceSelectedGroups Property

BuiltInFailuresGroupFailuresUnableToReplaceSelectedGroups Property

Unable to change the types of the groups you have selected and the related groups. You might try deleting the groups you wish to change and placing or copy/pasting new groups of the desired type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnableToReplaceSelectedGroups { get; }
Public Shared ReadOnly Property UnableToReplaceSelectedGroups As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnableToReplaceSelectedGroups {
    FailureDefinitionId^ get ();
}
static member UnableToReplaceSelectedGroups : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.UnableToRestoreAllMembersOfGroups Property

BuiltInFailuresGroupFailuresUnableToRestoreAllMembersOfGroups Property

Revit is unable to restore the members of the selected groups.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnableToRestoreAllMembersOfGroups { get; }
Public Shared ReadOnly Property UnableToRestoreAllMembersOfGroups As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnableToRestoreAllMembersOfGroups {
    FailureDefinitionId^ get ();
}
static member UnableToRestoreAllMembersOfGroups : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.UnableToSaveGroupType Property

BuiltInFailuresGroupFailuresUnableToSaveGroupType Property

Unable to save group type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnableToSaveGroupType { get; }
Public Shared ReadOnly Property UnableToSaveGroupType As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnableToSaveGroupType {
    FailureDefinitionId^ get ();
}
static member UnableToSaveGroupType : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.GroupFailures.UnableToTransferAttachedGroup Property

BuiltInFailuresGroupFailuresUnableToTransferAttachedGroup Property

Unable to load attached group [Type Name] of model group [Type Name].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnableToTransferAttachedGroup { get; }
Public Shared ReadOnly Property UnableToTransferAttachedGroup As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnableToTransferAttachedGroup {
    FailureDefinitionId^ get ();
}
static member UnableToTransferAttachedGroup : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresGroupFailures Class


BuiltInFailures.HostObjFailures Class

BuiltInFailuresHostObjFailures Class

Failures about HostObj.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresHostObjFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class HostObjFailures
Public NotInheritable Class HostObjFailures
public ref class HostObjFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type HostObjFailures = class end

The BuiltInFailuresHostObjFailures type exposes the following members.

Properties
Name | Description
HostMismatch | Can't use this type in this host.
ReferencesNulled | One or more references are or have become invalid.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


HostObjFailures Properties

The BuiltInFailuresHostObjFailures type exposes the following members.

Properties
Name | Description
HostMismatch | Can't use this type in this host.
ReferencesNulled | One or more references are or have become invalid.
Top
See Also

Reference

BuiltInFailuresHostObjFailures Class


BuiltInFailures.HostObjFailures.HostMismatch Property

BuiltInFailuresHostObjFailuresHostMismatch Property

Can't use this type in this host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId HostMismatch { get; }
Public Shared ReadOnly Property HostMismatch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ HostMismatch {
    FailureDefinitionId^ get ();
}
static member HostMismatch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresHostObjFailures Class


BuiltInFailures.HostObjFailures.ReferencesNulled Property

BuiltInFailuresHostObjFailuresReferencesNulled Property

One or more references are or have become invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ReferencesNulled { get; }
Public Shared ReadOnly Property ReferencesNulled As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ReferencesNulled {
    FailureDefinitionId^ get ();
}
static member ReferencesNulled : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresHostObjFailures Class


BuiltInFailures.HvacFailures Class

BuiltInFailuresHvacFailures Class

Failures related to HVAC in MEP.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresHvacFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class HvacFailures
Public NotInheritable Class HvacFailures
public ref class HvacFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type HvacFailures = class end

The BuiltInFailuresHvacFailures type exposes the following members.

Properties
Name | Description
PanelDoesntMatchCircuitPropertiesDisconnected | The panel no longer matches the properties for the Circuit. Disconnect the panel from the Circuit?
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


HvacFailures Properties

The BuiltInFailuresHvacFailures type exposes the following members.

Properties
Name | Description
PanelDoesntMatchCircuitPropertiesDisconnected | The panel no longer matches the properties for the Circuit. Disconnect the panel from the Circuit?
Top
See Also

Reference

BuiltInFailuresHvacFailures Class


BuiltInFailures.HvacFailures.PanelDoesntMatchCircuitPropertiesDisconnected Property

BuiltInFailuresHvacFailuresPanelDoesntMatchCircuitPropertiesDisconnected Property

The panel no longer matches the properties for the Circuit. Disconnect the panel from the Circuit?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PanelDoesntMatchCircuitPropertiesDisconnected { get; }
Public Shared ReadOnly Property PanelDoesntMatchCircuitPropertiesDisconnected As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PanelDoesntMatchCircuitPropertiesDisconnected {
    FailureDefinitionId^ get ();
}
static member PanelDoesntMatchCircuitPropertiesDisconnected : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresHvacFailures Class


BuiltInFailures.IlluminationFailures Class

BuiltInFailuresIlluminationFailures Class

Failures about Illumination.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresIlluminationFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class IlluminationFailures
Public NotInheritable Class IlluminationFailures
public ref class IlluminationFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type IlluminationFailures = class end

The BuiltInFailuresIlluminationFailures type exposes the following members.

Properties
Name | Description
IESFileNotFoundWarning | Estimated Illumination failed. IES file not found for lighting fixture.
LightingFixtureLumensWarning | Estimated Illumination failed. Lumens not set for lighting fixture.
RoomCoefficientUtilizationWarning | Estimated Illumination failed. Coefficient of utilization not set for lighting fixture.
RoomLightLossFactorWarning | Estimated Illumination failed. Light Loss factor not set for lighting fixture.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


IlluminationFailures Properties

The BuiltInFailuresIlluminationFailures type exposes the following members.

Properties
Name | Description
IESFileNotFoundWarning | Estimated Illumination failed. IES file not found for lighting fixture.
LightingFixtureLumensWarning | Estimated Illumination failed. Lumens not set for lighting fixture.
RoomCoefficientUtilizationWarning | Estimated Illumination failed. Coefficient of utilization not set for lighting fixture.
RoomLightLossFactorWarning | Estimated Illumination failed. Light Loss factor not set for lighting fixture.
Top
See Also

Reference

BuiltInFailuresIlluminationFailures Class


BuiltInFailures.IlluminationFailures.IESFileNotFoundWarning Property

BuiltInFailuresIlluminationFailuresIESFileNotFoundWarning Property

Estimated Illumination failed. IES file not found for lighting fixture.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId IESFileNotFoundWarning { get; }
Public Shared ReadOnly Property IESFileNotFoundWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ IESFileNotFoundWarning {
    FailureDefinitionId^ get ();
}
static member IESFileNotFoundWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresIlluminationFailures Class


BuiltInFailures.IlluminationFailures.LightingFixtureLumensWarning Property

BuiltInFailuresIlluminationFailuresLightingFixtureLumensWarning Property

Estimated Illumination failed. Lumens not set for lighting fixture.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LightingFixtureLumensWarning { get; }
Public Shared ReadOnly Property LightingFixtureLumensWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LightingFixtureLumensWarning {
    FailureDefinitionId^ get ();
}
static member LightingFixtureLumensWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresIlluminationFailures Class


BuiltInFailures.IlluminationFailures.RoomCoefficientUtilizationWarning Property

BuiltInFailuresIlluminationFailuresRoomCoefficientUtilizationWarning Property

Estimated Illumination failed. Coefficient of utilization not set for lighting fixture.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RoomCoefficientUtilizationWarning { get; }
Public Shared ReadOnly Property RoomCoefficientUtilizationWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RoomCoefficientUtilizationWarning {
    FailureDefinitionId^ get ();
}
static member RoomCoefficientUtilizationWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresIlluminationFailures Class


BuiltInFailures.IlluminationFailures.RoomLightLossFactorWarning Property

BuiltInFailuresIlluminationFailuresRoomLightLossFactorWarning Property

Estimated Illumination failed. Light Loss factor not set for lighting fixture.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RoomLightLossFactorWarning { get; }
Public Shared ReadOnly Property RoomLightLossFactorWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RoomLightLossFactorWarning {
    FailureDefinitionId^ get ();
}
static member RoomLightLossFactorWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresIlluminationFailures Class


BuiltInFailures.ImageFailures Class

BuiltInFailuresImageFailures Class

Failures about Image.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresImageFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ImageFailures
Public NotInheritable Class ImageFailures
public ref class ImageFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ImageFailures = class end

The BuiltInFailuresImageFailures type exposes the following members.

Properties
Name | Description
BadViewType | Image Instances can't be placed in 3D Views.
InvalidHeight | The image height must be must be no more than 30000 feet.
InvalidWidth | The image width must be must be no more than 30000 feet.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ImageFailures Properties

The BuiltInFailuresImageFailures type exposes the following members.

Properties
Name | Description
BadViewType | Image Instances can't be placed in 3D Views.
InvalidHeight | The image height must be must be no more than 30000 feet.
InvalidWidth | The image width must be must be no more than 30000 feet.
Top
See Also

Reference

BuiltInFailuresImageFailures Class


BuiltInFailures.ImageFailures.BadViewType Property

BuiltInFailuresImageFailuresBadViewType Property

Image Instances can't be placed in 3D Views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BadViewType { get; }
Public Shared ReadOnly Property BadViewType As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BadViewType {
    FailureDefinitionId^ get ();
}
static member BadViewType : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresImageFailures Class


BuiltInFailures.ImageFailures.InvalidHeight Property

BuiltInFailuresImageFailuresInvalidHeight Property

The image height must be must be no more than 30000 feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidHeight { get; }
Public Shared ReadOnly Property InvalidHeight As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidHeight {
    FailureDefinitionId^ get ();
}
static member InvalidHeight : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresImageFailures Class


BuiltInFailures.ImageFailures.InvalidWidth Property

BuiltInFailuresImageFailuresInvalidWidth Property

The image width must be must be no more than 30000 feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidWidth { get; }
Public Shared ReadOnly Property InvalidWidth As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidWidth {
    FailureDefinitionId^ get ();
}
static member InvalidWidth : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresImageFailures Class


BuiltInFailures.ImportExportFailures Class

BuiltInFailuresImportExportFailures Class

Failures about Import and Export.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresImportExportFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ImportExportFailures
Public NotInheritable Class ImportExportFailures
public ref class ImportExportFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ImportExportFailures = class end

The BuiltInFailuresImportExportFailures type exposes the following members.

Properties
Name | Description
ViewBoundariesTooLarge | The view boundaries are too large to export the view..
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ImportExportFailures Properties

The BuiltInFailuresImportExportFailures type exposes the following members.

Properties
Name | Description
ViewBoundariesTooLarge | The view boundaries are too large to export the view..
Top
See Also

Reference

BuiltInFailuresImportExportFailures Class


BuiltInFailures.ImportExportFailures.ViewBoundariesTooLarge Property

BuiltInFailuresImportExportFailuresViewBoundariesTooLarge Property

The view boundaries are too large to export the view..

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ViewBoundariesTooLarge { get; }
Public Shared ReadOnly Property ViewBoundariesTooLarge As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ViewBoundariesTooLarge {
    FailureDefinitionId^ get ();
}
static member ViewBoundariesTooLarge : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresImportExportFailures Class


BuiltInFailures.ImportFailures Class

BuiltInFailuresImportFailures Class

Failures about ImportFailures.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresImportFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ImportFailures
Public NotInheritable Class ImportFailures
public ref class ImportFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ImportFailures = class end

The BuiltInFailuresImportFailures type exposes the following members.

Properties
Name | Description
ATFContainedUnsupportedGeometricData | The original model contains unsupported geometric data.
ATFNonUniformScalingTransform | The imported geometry contains non-uniform scaling transformations which Revit does not support. Some objects may be displaced or distorted.
BadFaceFoundInDwg | One or more hatch regions were found in the imported file with unconnected boundaries. These hatch regions will be ignored.
CannotChangeImportSymbol | Can't change an imported or linked element's symbol type.
CannotExplodeElement | Can't explode the imported object.
CannotImportFile | Can't import file.
ElementRenamedOnImport | There were duplicate names between the active model and the imported element. To avoid duplicate names, the imported element has been renamed.
FailedToSetWorkplane | Could not set Work Plane of [Import].\n\nPlease use the Work Plane tool to set a Work Plane for this view.
IFCCantUpdateLinkedFile | The cached version of this IFC file is already loaded into another document in this session, and can't be updated. To update the IFC file, please close all other documents containing the link, and then update.
IFCGenericImportWarning | The following problems were encountered in the IFC file: [Description]
IFCGenericRevitImportWarning | Revit had the following problems importing the IFC file: [Description]
IFCPartialSchemaSupport | IFC versions 4 and above are only partially supported by Open IFC. Consider using Link IFC instead.
ImportedModelIsEmpty | Imported model is empty.
ImportedModelWithDifferentLengthUnits | The imported model uses different length units, Revit will default to auto-detect.
ImportModelOutOfRange | The imported model is out of range.
ImportModelTooLarge | The imported model is too large.
ImportScaleTooLarge | This scale factor would make the imported object too large. Reverting to the previous scale factor.
ImportSymbolBaseLevelInvalid |
ImportTooFarAway | Imported objects located a large distance from the model might not display properly. The 'Center-to-Center' option will be used.
ImportTooManyElmentsToExplode | Import Instance has [Number] elements. Imports with more than 10,000 elements cannot be exploded.
LevelRenamedOnImport | This level has been renamed from [SourceLevelName] to avoid duplication.
LostAcisObjectsOnImport | Some ACIS objects could not be imported. To import them, use AutoCAD to convert them into polymesh objects and reimport.
SomeObjectsNotExploded | Import contained some 3D data or points which can't be exploded.
TextNotImported | Text is only imported if the "Current View Only" option is selected. To see the text in the original file, import again with this check box selected in the Import Dialog.
TooManyPickFaces | Too many faces were created from imported meshes. Host by Face tools may not select the imported meshes correctly. Decrease the complexity of the file or try importing only selected layers to resolve.
ViewDoesNotSupportCenterToCenter | The "Center to Center" option is not supported by this view because it is empty. "Origin to Internal Origin" has been used instead.
WorksetCreatedForLinkWarning | Newly created link types and instances were placed in new workset [workset name]
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ImportFailures Properties

The BuiltInFailuresImportFailures type exposes the following members.

Properties
Name | Description
ATFContainedUnsupportedGeometricData | The original model contains unsupported geometric data.
ATFNonUniformScalingTransform | The imported geometry contains non-uniform scaling transformations which Revit does not support. Some objects may be displaced or distorted.
BadFaceFoundInDwg | One or more hatch regions were found in the imported file with unconnected boundaries. These hatch regions will be ignored.
CannotChangeImportSymbol | Can't change an imported or linked element's symbol type.
CannotExplodeElement | Can't explode the imported object.
CannotImportFile | Can't import file.
ElementRenamedOnImport | There were duplicate names between the active model and the imported element. To avoid duplicate names, the imported element has been renamed.
FailedToSetWorkplane | Could not set Work Plane of [Import].\n\nPlease use the Work Plane tool to set a Work Plane for this view.
IFCCantUpdateLinkedFile | The cached version of this IFC file is already loaded into another document in this session, and can't be updated. To update the IFC file, please close all other documents containing the link, and then update.
IFCGenericImportWarning | The following problems were encountered in the IFC file: [Description]
IFCGenericRevitImportWarning | Revit had the following problems importing the IFC file: [Description]
IFCPartialSchemaSupport | IFC versions 4 and above are only partially supported by Open IFC. Consider using Link IFC instead.
ImportedModelIsEmpty | Imported model is empty.
ImportedModelWithDifferentLengthUnits | The imported model uses different length units, Revit will default to auto-detect.
ImportModelOutOfRange | The imported model is out of range.
ImportModelTooLarge | The imported model is too large.
ImportScaleTooLarge | This scale factor would make the imported object too large. Reverting to the previous scale factor.
ImportSymbolBaseLevelInvalid |
ImportTooFarAway | Imported objects located a large distance from the model might not display properly. The 'Center-to-Center' option will be used.
ImportTooManyElmentsToExplode | Import Instance has [Number] elements. Imports with more than 10,000 elements cannot be exploded.
LevelRenamedOnImport | This level has been renamed from [SourceLevelName] to avoid duplication.
LostAcisObjectsOnImport | Some ACIS objects could not be imported. To import them, use AutoCAD to convert them into polymesh objects and reimport.
SomeObjectsNotExploded | Import contained some 3D data or points which can't be exploded.
TextNotImported | Text is only imported if the "Current View Only" option is selected. To see the text in the original file, import again with this check box selected in the Import Dialog.
TooManyPickFaces | Too many faces were created from imported meshes. Host by Face tools may not select the imported meshes correctly. Decrease the complexity of the file or try importing only selected layers to resolve.
ViewDoesNotSupportCenterToCenter | The "Center to Center" option is not supported by this view because it is empty. "Origin to Internal Origin" has been used instead.
WorksetCreatedForLinkWarning | Newly created link types and instances were placed in new workset [workset name]
Top
See Also

Reference

BuiltInFailuresImportFailures Class


BuiltInFailures.ImportFailures.ATFContainedUnsupportedGeometricData Property

BuiltInFailuresImportFailuresATFContainedUnsupportedGeometricData Property

The original model contains unsupported geometric data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ATFContainedUnsupportedGeometricData { get; }
Public Shared ReadOnly Property ATFContainedUnsupportedGeometricData As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ATFContainedUnsupportedGeometricData {
    FailureDefinitionId^ get ();
}
static member ATFContainedUnsupportedGeometricData : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresImportFailures Class


BuiltInFailures.ImportFailures.ATFNonUniformScalingTransform Property

BuiltInFailuresImportFailuresATFNonUniformScalingTransform Property

The imported geometry contains non-uniform scaling transformations which Revit does not support. Some objects may be displaced or distorted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ATFNonUniformScalingTransform { get; }
Public Shared ReadOnly Property ATFNonUniformScalingTransform As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ATFNonUniformScalingTransform {
    FailureDefinitionId^ get ();
}
static member ATFNonUniformScalingTransform : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresImportFailures Class


BuiltInFailures.ImportFailures.BadFaceFoundInDwg Property

BuiltInFailuresImportFailuresBadFaceFoundInDwg Property

One or more hatch regions were found in the imported file with unconnected boundaries. These hatch regions will be ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BadFaceFoundInDwg { get; }
Public Shared ReadOnly Property BadFaceFoundInDwg As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BadFaceFoundInDwg {
    FailureDefinitionId^ get ();
}
static member BadFaceFoundInDwg : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresImportFailures Class


BuiltInFailures.ImportFailures.CannotChangeImportSymbol Property

BuiltInFailuresImportFailuresCannotChangeImportSymbol Property

Can't change an imported or linked element's symbol type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotChangeImportSymbol { get; }
Public Shared ReadOnly Property CannotChangeImportSymbol As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotChangeImportSymbol {
    FailureDefinitionId^ get ();
}
static member CannotChangeImportSymbol : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresImportFailures Class


BuiltInFailures.ImportFailures.CannotExplodeElement Property

BuiltInFailuresImportFailuresCannotExplodeElement Property

Can't explode the imported object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotExplodeElement { get; }
Public Shared ReadOnly Property CannotExplodeElement As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotExplodeElement {
    FailureDefinitionId^ get ();
}
static member CannotExplodeElement : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresImportFailures Class


BuiltInFailures.ImportFailures.CannotImportFile Property

BuiltInFailuresImportFailuresCannotImportFile Property

Can't import file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotImportFile { get; }
Public Shared ReadOnly Property CannotImportFile As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotImportFile {
    FailureDefinitionId^ get ();
}
static member CannotImportFile : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresImportFailures Class


BuiltInFailures.ImportFailures.ElementRenamedOnImport Property

BuiltInFailuresImportFailuresElementRenamedOnImport Property

There were duplicate names between the active model and the imported element. To avoid duplicate names, the imported element has been renamed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ElementRenamedOnImport { get; }
Public Shared ReadOnly Property ElementRenamedOnImport As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ElementRenamedOnImport {
    FailureDefinitionId^ get ();
}
static member ElementRenamedOnImport : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresImportFailures Class


BuiltInFailures.ImportFailures.FailedToSetWorkplane Property

BuiltInFailuresImportFailuresFailedToSetWorkplane Property

Could not set Work Plane of [Import].\n\nPlease use the Work Plane tool to set a Work Plane for this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FailedToSetWorkplane { get; }
Public Shared ReadOnly Property FailedToSetWorkplane As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FailedToSetWorkplane {
    FailureDefinitionId^ get ();
}
static member FailedToSetWorkplane : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresImportFailures Class


BuiltInFailures.ImportFailures.IFCCantUpdateLinkedFile Property

BuiltInFailuresImportFailuresIFCCantUpdateLinkedFile Property

The cached version of this IFC file is already loaded into another document in this session, and can't be updated. To update the IFC file, please close all other documents containing the link, and then update.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId IFCCantUpdateLinkedFile { get; }
Public Shared ReadOnly Property IFCCantUpdateLinkedFile As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ IFCCantUpdateLinkedFile {
    FailureDefinitionId^ get ();
}
static member IFCCantUpdateLinkedFile : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresImportFailures Class


BuiltInFailures.ImportFailures.IFCGenericImportWarning Property

BuiltInFailuresImportFailuresIFCGenericImportWarning Property

The following problems were encountered in the IFC file: [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId IFCGenericImportWarning { get; }
Public Shared ReadOnly Property IFCGenericImportWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ IFCGenericImportWarning {
    FailureDefinitionId^ get ();
}
static member IFCGenericImportWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresImportFailures Class


BuiltInFailures.ImportFailures.IFCGenericRevitImportWarning Property

BuiltInFailuresImportFailuresIFCGenericRevitImportWarning Property

Revit had the following problems importing the IFC file: [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId IFCGenericRevitImportWarning { get; }
Public Shared ReadOnly Property IFCGenericRevitImportWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ IFCGenericRevitImportWarning {
    FailureDefinitionId^ get ();
}
static member IFCGenericRevitImportWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresImportFailures Class


BuiltInFailures.ImportFailures.IFCPartialSchemaSupport Property

BuiltInFailuresImportFailuresIFCPartialSchemaSupport Property

IFC versions 4 and above are only partially supported by Open IFC. Consider using Link IFC instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId IFCPartialSchemaSupport { get; }
Public Shared ReadOnly Property IFCPartialSchemaSupport As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ IFCPartialSchemaSupport {
    FailureDefinitionId^ get ();
}
static member IFCPartialSchemaSupport : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresImportFailures Class


BuiltInFailures.ImportFailures.ImportedModelIsEmpty Property

BuiltInFailuresImportFailuresImportedModelIsEmpty Property

Imported model is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ImportedModelIsEmpty { get; }
Public Shared ReadOnly Property ImportedModelIsEmpty As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ImportedModelIsEmpty {
    FailureDefinitionId^ get ();
}
static member ImportedModelIsEmpty : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresImportFailures Class


BuiltInFailures.ImportFailures.ImportedModelWithDifferentLengthUnits Property

BuiltInFailuresImportFailuresImportedModelWithDifferentLengthUnits Property

The imported model uses different length units, Revit will default to auto-detect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ImportedModelWithDifferentLengthUnits { get; }
Public Shared ReadOnly Property ImportedModelWithDifferentLengthUnits As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ImportedModelWithDifferentLengthUnits {
    FailureDefinitionId^ get ();
}
static member ImportedModelWithDifferentLengthUnits : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresImportFailures Class


BuiltInFailures.ImportFailures.ImportModelOutOfRange Property

BuiltInFailuresImportFailuresImportModelOutOfRange Property

The imported model is out of range.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ImportModelOutOfRange { get; }
Public Shared ReadOnly Property ImportModelOutOfRange As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ImportModelOutOfRange {
    FailureDefinitionId^ get ();
}
static member ImportModelOutOfRange : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresImportFailures Class


BuiltInFailures.ImportFailures.ImportModelTooLarge Property

BuiltInFailuresImportFailuresImportModelTooLarge Property

The imported model is too large.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ImportModelTooLarge { get; }
Public Shared ReadOnly Property ImportModelTooLarge As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ImportModelTooLarge {
    FailureDefinitionId^ get ();
}
static member ImportModelTooLarge : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresImportFailures Class


BuiltInFailures.ImportFailures.ImportScaleTooLarge Property

BuiltInFailuresImportFailuresImportScaleTooLarge Property

This scale factor would make the imported object too large. Reverting to the previous scale factor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ImportScaleTooLarge { get; }
Public Shared ReadOnly Property ImportScaleTooLarge As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ImportScaleTooLarge {
    FailureDefinitionId^ get ();
}
static member ImportScaleTooLarge : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresImportFailures Class


BuiltInFailures.ImportFailures.ImportSymbolBaseLevelInvalid Property

BuiltInFailuresImportFailuresImportSymbolBaseLevelInvalid Property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ImportSymbolBaseLevelInvalid { get; }
Public Shared ReadOnly Property ImportSymbolBaseLevelInvalid As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ImportSymbolBaseLevelInvalid {
    FailureDefinitionId^ get ();
}
static member ImportSymbolBaseLevelInvalid : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresImportFailures Class


BuiltInFailures.ImportFailures.ImportTooFarAway Property

BuiltInFailuresImportFailuresImportTooFarAway Property

Imported objects located a large distance from the model might not display properly. The 'Center-to-Center' option will be used.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ImportTooFarAway { get; }
Public Shared ReadOnly Property ImportTooFarAway As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ImportTooFarAway {
    FailureDefinitionId^ get ();
}
static member ImportTooFarAway : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresImportFailures Class


BuiltInFailures.ImportFailures.ImportTooManyElmentsToExplode Property

BuiltInFailuresImportFailuresImportTooManyElmentsToExplode Property

Import Instance has [Number] elements. Imports with more than 10,000 elements cannot be exploded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ImportTooManyElmentsToExplode { get; }
Public Shared ReadOnly Property ImportTooManyElmentsToExplode As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ImportTooManyElmentsToExplode {
    FailureDefinitionId^ get ();
}
static member ImportTooManyElmentsToExplode : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresImportFailures Class


BuiltInFailures.ImportFailures.LevelRenamedOnImport Property

BuiltInFailuresImportFailuresLevelRenamedOnImport Property

This level has been renamed from [SourceLevelName] to avoid duplication.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LevelRenamedOnImport { get; }
Public Shared ReadOnly Property LevelRenamedOnImport As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LevelRenamedOnImport {
    FailureDefinitionId^ get ();
}
static member LevelRenamedOnImport : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresImportFailures Class


BuiltInFailures.ImportFailures.LostAcisObjectsOnImport Property

BuiltInFailuresImportFailuresLostAcisObjectsOnImport Property

Some ACIS objects could not be imported. To import them, use AutoCAD to convert them into polymesh objects and reimport.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LostAcisObjectsOnImport { get; }
Public Shared ReadOnly Property LostAcisObjectsOnImport As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LostAcisObjectsOnImport {
    FailureDefinitionId^ get ();
}
static member LostAcisObjectsOnImport : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresImportFailures Class


BuiltInFailures.ImportFailures.SomeObjectsNotExploded Property

BuiltInFailuresImportFailuresSomeObjectsNotExploded Property

Import contained some 3D data or points which can't be exploded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SomeObjectsNotExploded { get; }
Public Shared ReadOnly Property SomeObjectsNotExploded As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SomeObjectsNotExploded {
    FailureDefinitionId^ get ();
}
static member SomeObjectsNotExploded : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresImportFailures Class


BuiltInFailures.ImportFailures.TextNotImported Property

BuiltInFailuresImportFailuresTextNotImported Property

Text is only imported if the "Current View Only" option is selected. To see the text in the original file, import again with this check box selected in the Import Dialog.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TextNotImported { get; }
Public Shared ReadOnly Property TextNotImported As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TextNotImported {
    FailureDefinitionId^ get ();
}
static member TextNotImported : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresImportFailures Class


BuiltInFailures.ImportFailures.TooManyPickFaces Property

BuiltInFailuresImportFailuresTooManyPickFaces Property

Too many faces were created from imported meshes. Host by Face tools may not select the imported meshes correctly. Decrease the complexity of the file or try importing only selected layers to resolve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TooManyPickFaces { get; }
Public Shared ReadOnly Property TooManyPickFaces As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TooManyPickFaces {
    FailureDefinitionId^ get ();
}
static member TooManyPickFaces : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresImportFailures Class


BuiltInFailures.ImportFailures.ViewDoesNotSupportCenterToCenter Property

BuiltInFailuresImportFailuresViewDoesNotSupportCenterToCenter Property

The "Center to Center" option is not supported by this view because it is empty. "Origin to Internal Origin" has been used instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ViewDoesNotSupportCenterToCenter { get; }
Public Shared ReadOnly Property ViewDoesNotSupportCenterToCenter As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ViewDoesNotSupportCenterToCenter {
    FailureDefinitionId^ get ();
}
static member ViewDoesNotSupportCenterToCenter : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresImportFailures Class


BuiltInFailures.ImportFailures.WorksetCreatedForLinkWarning Property

BuiltInFailuresImportFailuresWorksetCreatedForLinkWarning Property

Newly created link types and instances were placed in new workset [workset name]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WorksetCreatedForLinkWarning { get; }
Public Shared ReadOnly Property WorksetCreatedForLinkWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WorksetCreatedForLinkWarning {
    FailureDefinitionId^ get ();
}
static member WorksetCreatedForLinkWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresImportFailures Class


BuiltInFailures.InaccurateFailures Class

BuiltInFailuresInaccurateFailures Class

Failures about Inaccurate.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresInaccurateFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class InaccurateFailures
Public NotInheritable Class InaccurateFailures
public ref class InaccurateFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type InaccurateFailures = class end

The BuiltInFailuresInaccurateFailures type exposes the following members.

Properties
Name | Description
InaccurateAreaLine | Area separation line is slightly off axis and may cause inaccuracies.
InaccurateBeamOrBrace | Beam or Brace is slightly off axis and may cause inaccuracies.
InaccurateCurveBasedFamily | Curve-Based Family is slightly off axis and may cause inaccuracies.
InaccurateDriveCurve | Element is slightly off axis and may cause inaccuracies.
InaccurateGrid | Grid is slightly off axis and may cause inaccuracies.
InaccurateLevel | Level is slightly off axis and may cause inaccuracies.
InaccurateLine | Line is slightly off axis and may cause inaccuracies.
InaccurateMassingSketchLine | Line in Massing Sketch is slightly off axis and may cause inaccuracies.
InaccurateRefPlane | Ref Plane is slightly off axis and may cause inaccuracies.
InaccurateRoomSeparation | Room separation line is slightly off axis and may cause inaccuracies.
InaccurateSketchLine | Line in Sketch is slightly off axis and may cause inaccuracies.
InaccurateSpaceSeparation | Space separation line is slightly off axis and may cause inaccuracies.
InaccurateWall | Wall is slightly off axis and may cause inaccuracies.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


InaccurateFailures Properties

The BuiltInFailuresInaccurateFailures type exposes the following members.

Properties
Name | Description
InaccurateAreaLine | Area separation line is slightly off axis and may cause inaccuracies.
InaccurateBeamOrBrace | Beam or Brace is slightly off axis and may cause inaccuracies.
InaccurateCurveBasedFamily | Curve-Based Family is slightly off axis and may cause inaccuracies.
InaccurateDriveCurve | Element is slightly off axis and may cause inaccuracies.
InaccurateGrid | Grid is slightly off axis and may cause inaccuracies.
InaccurateLevel | Level is slightly off axis and may cause inaccuracies.
InaccurateLine | Line is slightly off axis and may cause inaccuracies.
InaccurateMassingSketchLine | Line in Massing Sketch is slightly off axis and may cause inaccuracies.
InaccurateRefPlane | Ref Plane is slightly off axis and may cause inaccuracies.
InaccurateRoomSeparation | Room separation line is slightly off axis and may cause inaccuracies.
InaccurateSketchLine | Line in Sketch is slightly off axis and may cause inaccuracies.
InaccurateSpaceSeparation | Space separation line is slightly off axis and may cause inaccuracies.
InaccurateWall | Wall is slightly off axis and may cause inaccuracies.
Top
See Also

Reference

BuiltInFailuresInaccurateFailures Class


BuiltInFailures.InaccurateFailures.InaccurateAreaLine Property

BuiltInFailuresInaccurateFailuresInaccurateAreaLine Property

Area separation line is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InaccurateAreaLine { get; }
Public Shared ReadOnly Property InaccurateAreaLine As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InaccurateAreaLine {
    FailureDefinitionId^ get ();
}
static member InaccurateAreaLine : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresInaccurateFailures Class


BuiltInFailures.InaccurateFailures.InaccurateBeamOrBrace Property

BuiltInFailuresInaccurateFailuresInaccurateBeamOrBrace Property

Beam or Brace is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InaccurateBeamOrBrace { get; }
Public Shared ReadOnly Property InaccurateBeamOrBrace As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InaccurateBeamOrBrace {
    FailureDefinitionId^ get ();
}
static member InaccurateBeamOrBrace : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresInaccurateFailures Class


BuiltInFailures.InaccurateFailures.InaccurateCurveBasedFamily Property

BuiltInFailuresInaccurateFailuresInaccurateCurveBasedFamily Property

Curve-Based Family is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InaccurateCurveBasedFamily { get; }
Public Shared ReadOnly Property InaccurateCurveBasedFamily As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InaccurateCurveBasedFamily {
    FailureDefinitionId^ get ();
}
static member InaccurateCurveBasedFamily : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresInaccurateFailures Class


BuiltInFailures.InaccurateFailures.InaccurateDriveCurve Property

BuiltInFailuresInaccurateFailuresInaccurateDriveCurve Property

Element is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InaccurateDriveCurve { get; }
Public Shared ReadOnly Property InaccurateDriveCurve As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InaccurateDriveCurve {
    FailureDefinitionId^ get ();
}
static member InaccurateDriveCurve : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresInaccurateFailures Class


BuiltInFailures.InaccurateFailures.InaccurateGrid Property

BuiltInFailuresInaccurateFailuresInaccurateGrid Property

Grid is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InaccurateGrid { get; }
Public Shared ReadOnly Property InaccurateGrid As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InaccurateGrid {
    FailureDefinitionId^ get ();
}
static member InaccurateGrid : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresInaccurateFailures Class


BuiltInFailures.InaccurateFailures.InaccurateLevel Property

BuiltInFailuresInaccurateFailuresInaccurateLevel Property

Level is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InaccurateLevel { get; }
Public Shared ReadOnly Property InaccurateLevel As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InaccurateLevel {
    FailureDefinitionId^ get ();
}
static member InaccurateLevel : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresInaccurateFailures Class


BuiltInFailures.InaccurateFailures.InaccurateLine Property

BuiltInFailuresInaccurateFailuresInaccurateLine Property

Line is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InaccurateLine { get; }
Public Shared ReadOnly Property InaccurateLine As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InaccurateLine {
    FailureDefinitionId^ get ();
}
static member InaccurateLine : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresInaccurateFailures Class


BuiltInFailures.InaccurateFailures.InaccurateMassingSketchLine Property

BuiltInFailuresInaccurateFailuresInaccurateMassingSketchLine Property

Line in Massing Sketch is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InaccurateMassingSketchLine { get; }
Public Shared ReadOnly Property InaccurateMassingSketchLine As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InaccurateMassingSketchLine {
    FailureDefinitionId^ get ();
}
static member InaccurateMassingSketchLine : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresInaccurateFailures Class


BuiltInFailures.InaccurateFailures.InaccurateRefPlane Property

BuiltInFailuresInaccurateFailuresInaccurateRefPlane Property

Ref Plane is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InaccurateRefPlane { get; }
Public Shared ReadOnly Property InaccurateRefPlane As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InaccurateRefPlane {
    FailureDefinitionId^ get ();
}
static member InaccurateRefPlane : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresInaccurateFailures Class


BuiltInFailures.InaccurateFailures.InaccurateRoomSeparation Property

BuiltInFailuresInaccurateFailuresInaccurateRoomSeparation Property

Room separation line is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InaccurateRoomSeparation { get; }
Public Shared ReadOnly Property InaccurateRoomSeparation As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InaccurateRoomSeparation {
    FailureDefinitionId^ get ();
}
static member InaccurateRoomSeparation : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresInaccurateFailures Class


BuiltInFailures.InaccurateFailures.InaccurateSketchLine Property

BuiltInFailuresInaccurateFailuresInaccurateSketchLine Property

Line in Sketch is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InaccurateSketchLine { get; }
Public Shared ReadOnly Property InaccurateSketchLine As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InaccurateSketchLine {
    FailureDefinitionId^ get ();
}
static member InaccurateSketchLine : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresInaccurateFailures Class


BuiltInFailures.InaccurateFailures.InaccurateSpaceSeparation Property

BuiltInFailuresInaccurateFailuresInaccurateSpaceSeparation Property

Space separation line is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InaccurateSpaceSeparation { get; }
Public Shared ReadOnly Property InaccurateSpaceSeparation As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InaccurateSpaceSeparation {
    FailureDefinitionId^ get ();
}
static member InaccurateSpaceSeparation : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresInaccurateFailures Class


BuiltInFailures.InaccurateFailures.InaccurateWall Property

BuiltInFailuresInaccurateFailuresInaccurateWall Property

Wall is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InaccurateWall { get; }
Public Shared ReadOnly Property InaccurateWall As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InaccurateWall {
    FailureDefinitionId^ get ();
}
static member InaccurateWall : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresInaccurateFailures Class


BuiltInFailures.InfillFailures Class

BuiltInFailuresInfillFailures Class

Failures about Infill.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresInfillFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class InfillFailures
Public NotInheritable Class InfillFailures
public ref class InfillFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type InfillFailures = class end

The BuiltInFailuresInfillFailures type exposes the following members.

Properties
Name | Description
CannotDeleteInfill | Can't delete infilling element without deleting its insert or host.
FamilyInstanceIsNotCuttingHost | Instance is not cutting host.
InfillCannotChangeType | Infilling element replaced by a later phase insert must be the same type as the insert's host.
InfillCannotHaveDiffThickness | This infilling element must have the same thickness as its host.
InfillDifferentPhase | Wall and instance have different phasing settings. Automatic creation of the infilling wall fails.
InfillLost | Standalone infilling Wall is separated from its insert.
InfillNoSlopeGlazing | Could not change type due to highlighted infilling element. 'Sloped glazing' infills are not allowed.
InfillNoThicknessCeiling | Could not change type due to highlighted infilling element. 'Basic Ceiling' infills are only compatible with 'Basic Ceiling' hosts.
InfillNoThicknessMultiface | Highlighted infilling element could not have thickness different from its host because it spans multiple faces.
InPlaceFamilyNotCuttingHost | Instance of in-place family is not cutting host.
InsertJoinedWall | Insert conflicts with joined Wall.
InsertOverlapsOrOut | Highlighted inserts overlap with other inserts or completely miss their hosts.
MovedInfillToHost | Infilling element was automatically moved to keep it aligned to host.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


InfillFailures Properties

The BuiltInFailuresInfillFailures type exposes the following members.

Properties
Name | Description
CannotDeleteInfill | Can't delete infilling element without deleting its insert or host.
FamilyInstanceIsNotCuttingHost | Instance is not cutting host.
InfillCannotChangeType | Infilling element replaced by a later phase insert must be the same type as the insert's host.
InfillCannotHaveDiffThickness | This infilling element must have the same thickness as its host.
InfillDifferentPhase | Wall and instance have different phasing settings. Automatic creation of the infilling wall fails.
InfillLost | Standalone infilling Wall is separated from its insert.
InfillNoSlopeGlazing | Could not change type due to highlighted infilling element. 'Sloped glazing' infills are not allowed.
InfillNoThicknessCeiling | Could not change type due to highlighted infilling element. 'Basic Ceiling' infills are only compatible with 'Basic Ceiling' hosts.
InfillNoThicknessMultiface | Highlighted infilling element could not have thickness different from its host because it spans multiple faces.
InPlaceFamilyNotCuttingHost | Instance of in-place family is not cutting host.
InsertJoinedWall | Insert conflicts with joined Wall.
InsertOverlapsOrOut | Highlighted inserts overlap with other inserts or completely miss their hosts.
MovedInfillToHost | Infilling element was automatically moved to keep it aligned to host.
Top
See Also

Reference

BuiltInFailuresInfillFailures Class


BuiltInFailures.InfillFailures.CannotDeleteInfill Property

BuiltInFailuresInfillFailuresCannotDeleteInfill Property

Can't delete infilling element without deleting its insert or host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotDeleteInfill { get; }
Public Shared ReadOnly Property CannotDeleteInfill As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotDeleteInfill {
    FailureDefinitionId^ get ();
}
static member CannotDeleteInfill : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresInfillFailures Class


BuiltInFailures.InfillFailures.FamilyInstanceIsNotCuttingHost Property

BuiltInFailuresInfillFailuresFamilyInstanceIsNotCuttingHost Property

Instance is not cutting host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FamilyInstanceIsNotCuttingHost { get; }
Public Shared ReadOnly Property FamilyInstanceIsNotCuttingHost As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FamilyInstanceIsNotCuttingHost {
    FailureDefinitionId^ get ();
}
static member FamilyInstanceIsNotCuttingHost : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresInfillFailures Class


BuiltInFailures.InfillFailures.InfillCannotChangeType Property

BuiltInFailuresInfillFailuresInfillCannotChangeType Property

Infilling element replaced by a later phase insert must be the same type as the insert's host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InfillCannotChangeType { get; }
Public Shared ReadOnly Property InfillCannotChangeType As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InfillCannotChangeType {
    FailureDefinitionId^ get ();
}
static member InfillCannotChangeType : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresInfillFailures Class


BuiltInFailures.InfillFailures.InfillCannotHaveDiffThickness Property

BuiltInFailuresInfillFailuresInfillCannotHaveDiffThickness Property

This infilling element must have the same thickness as its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InfillCannotHaveDiffThickness { get; }
Public Shared ReadOnly Property InfillCannotHaveDiffThickness As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InfillCannotHaveDiffThickness {
    FailureDefinitionId^ get ();
}
static member InfillCannotHaveDiffThickness : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresInfillFailures Class


BuiltInFailures.InfillFailures.InfillDifferentPhase Property

BuiltInFailuresInfillFailuresInfillDifferentPhase Property

Wall and instance have different phasing settings. Automatic creation of the infilling wall fails.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InfillDifferentPhase { get; }
Public Shared ReadOnly Property InfillDifferentPhase As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InfillDifferentPhase {
    FailureDefinitionId^ get ();
}
static member InfillDifferentPhase : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresInfillFailures Class


BuiltInFailures.InfillFailures.InfillLost Property

BuiltInFailuresInfillFailuresInfillLost Property

Standalone infilling Wall is separated from its insert.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InfillLost { get; }
Public Shared ReadOnly Property InfillLost As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InfillLost {
    FailureDefinitionId^ get ();
}
static member InfillLost : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresInfillFailures Class


BuiltInFailures.InfillFailures.InfillNoSlopeGlazing Property

BuiltInFailuresInfillFailuresInfillNoSlopeGlazing Property

Could not change type due to highlighted infilling element. 'Sloped glazing' infills are not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InfillNoSlopeGlazing { get; }
Public Shared ReadOnly Property InfillNoSlopeGlazing As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InfillNoSlopeGlazing {
    FailureDefinitionId^ get ();
}
static member InfillNoSlopeGlazing : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresInfillFailures Class


BuiltInFailures.InfillFailures.InfillNoThicknessCeiling Property

BuiltInFailuresInfillFailuresInfillNoThicknessCeiling Property

Could not change type due to highlighted infilling element. 'Basic Ceiling' infills are only compatible with 'Basic Ceiling' hosts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InfillNoThicknessCeiling { get; }
Public Shared ReadOnly Property InfillNoThicknessCeiling As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InfillNoThicknessCeiling {
    FailureDefinitionId^ get ();
}
static member InfillNoThicknessCeiling : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresInfillFailures Class


BuiltInFailures.InfillFailures.InfillNoThicknessMultiface Property

BuiltInFailuresInfillFailuresInfillNoThicknessMultiface Property

Highlighted infilling element could not have thickness different from its host because it spans multiple faces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InfillNoThicknessMultiface { get; }
Public Shared ReadOnly Property InfillNoThicknessMultiface As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InfillNoThicknessMultiface {
    FailureDefinitionId^ get ();
}
static member InfillNoThicknessMultiface : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresInfillFailures Class


BuiltInFailures.InfillFailures.InPlaceFamilyNotCuttingHost Property

BuiltInFailuresInfillFailuresInPlaceFamilyNotCuttingHost Property

Instance of in-place family is not cutting host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InPlaceFamilyNotCuttingHost { get; }
Public Shared ReadOnly Property InPlaceFamilyNotCuttingHost As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InPlaceFamilyNotCuttingHost {
    FailureDefinitionId^ get ();
}
static member InPlaceFamilyNotCuttingHost : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresInfillFailures Class


BuiltInFailures.InfillFailures.InsertJoinedWall Property

BuiltInFailuresInfillFailuresInsertJoinedWall Property

Insert conflicts with joined Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InsertJoinedWall { get; }
Public Shared ReadOnly Property InsertJoinedWall As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InsertJoinedWall {
    FailureDefinitionId^ get ();
}
static member InsertJoinedWall : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresInfillFailures Class


BuiltInFailures.InfillFailures.InsertOverlapsOrOut Property

BuiltInFailuresInfillFailuresInsertOverlapsOrOut Property

Highlighted inserts overlap with other inserts or completely miss their hosts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InsertOverlapsOrOut { get; }
Public Shared ReadOnly Property InsertOverlapsOrOut As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InsertOverlapsOrOut {
    FailureDefinitionId^ get ();
}
static member InsertOverlapsOrOut : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresInfillFailures Class


BuiltInFailures.InfillFailures.MovedInfillToHost Property

BuiltInFailuresInfillFailuresMovedInfillToHost Property

Infilling element was automatically moved to keep it aligned to host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MovedInfillToHost { get; }
Public Shared ReadOnly Property MovedInfillToHost As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MovedInfillToHost {
    FailureDefinitionId^ get ();
}
static member MovedInfillToHost : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresInfillFailures Class


BuiltInFailures.InterferenceFailures Class

BuiltInFailuresInterferenceFailures Class

Failures about Interference.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresInterferenceFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class InterferenceFailures
Public NotInheritable Class InterferenceFailures
public ref class InterferenceFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type InterferenceFailures = class end

The BuiltInFailuresInterferenceFailures type exposes the following members.

Properties
Name | Description
GeometryWarning | A geometrical error has occurred while checking for Interference. Reported interference may not be accurate.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


InterferenceFailures Properties

The BuiltInFailuresInterferenceFailures type exposes the following members.

Properties
Name | Description
GeometryWarning | A geometrical error has occurred while checking for Interference. Reported interference may not be accurate.
Top
See Also

Reference

BuiltInFailuresInterferenceFailures Class


BuiltInFailures.InterferenceFailures.GeometryWarning Property

BuiltInFailuresInterferenceFailuresGeometryWarning Property

A geometrical error has occurred while checking for Interference. Reported interference may not be accurate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId GeometryWarning { get; }
Public Shared ReadOnly Property GeometryWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ GeometryWarning {
    FailureDefinitionId^ get ();
}
static member GeometryWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresInterferenceFailures Class


BuiltInFailures.JoinElementsFailures Class

BuiltInFailuresJoinElementsFailures Class

Failures about JoinElements.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresJoinElementsFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class JoinElementsFailures
Public NotInheritable Class JoinElementsFailures
public ref class JoinElementsFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type JoinElementsFailures = class end

The BuiltInFailuresJoinElementsFailures type exposes the following members.

Properties
Name | Description
CannotCope | Can't apply Coping.
CannotCutJoinedGeometry | Element could not be cut by joined element.
CannotJoinDesignOptions | An element cannot join to an element in a secondary Design Option unless it is in the same secondary Design Option.
CannotJoinElements | Can't keep elements joined.
CannotJoinElementsError | Can't keep elements joined.
CannotJoinElementsMultiPlaneError | Can't keep elements joined.
CannotJoinElementsStructural | Can't keep elements joined.
CannotJoinElementsStructuralError | Can't keep elements joined.
CannotJoinElementsWarn | Can't keep elements joined.
CannotJoinRoof | The roof cannot be joined.
CannotJoinRoofError | The roof cannot be joined.
CannotKeepJoined | Can't keep elements joined.
CannotKeepReferenceOfJoinedElement | Can't keep reference of joined element.
CannotKeepReferenceOfJoinedElementWarning | Can't keep reference of joined element.
CannotKeepTrussJoined | Can't keep the highlighted [Element]s joined.
CannotKeepWallJoinToRoof | Can't keep wall and [target] joined
CannotKeepWallJoinToRoofError | Can't keep wall and [target] joined
ElementWillBeDetachedFromPlane | Element will be detached from its associated plane
FootingWillMoveToBottom | An attached Structural Foundation will be moved to the bottom of the Column.
JoiningDisjoint | Highlighted elements are joined but do not intersect.
JoiningDisjointWarn | Highlighted elements are joined but do not intersect.
StairsComponentTypeUnsupportedError | The selected stair type/shape isn't supported for attaching a wall to a stair. To continue, detach the wall from the stairs' components.
StructGroupMemberWillDetachFromGrid | A structural element will be detached from grid(s) due to inconsistent group membership.
WallTypeUnsupportedError | The selected wall type/shape isn't supported for attaching a wall to a stair. To continue, detach the wall from the stairs' components.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


JoinElementsFailures Properties

The BuiltInFailuresJoinElementsFailures type exposes the following members.

Properties
Name | Description
CannotCope | Can't apply Coping.
CannotCutJoinedGeometry | Element could not be cut by joined element.
CannotJoinDesignOptions | An element cannot join to an element in a secondary Design Option unless it is in the same secondary Design Option.
CannotJoinElements | Can't keep elements joined.
CannotJoinElementsError | Can't keep elements joined.
CannotJoinElementsMultiPlaneError | Can't keep elements joined.
CannotJoinElementsStructural | Can't keep elements joined.
CannotJoinElementsStructuralError | Can't keep elements joined.
CannotJoinElementsWarn | Can't keep elements joined.
CannotJoinRoof | The roof cannot be joined.
CannotJoinRoofError | The roof cannot be joined.
CannotKeepJoined | Can't keep elements joined.
CannotKeepReferenceOfJoinedElement | Can't keep reference of joined element.
CannotKeepReferenceOfJoinedElementWarning | Can't keep reference of joined element.
CannotKeepTrussJoined | Can't keep the highlighted [Element]s joined.
CannotKeepWallJoinToRoof | Can't keep wall and [target] joined
CannotKeepWallJoinToRoofError | Can't keep wall and [target] joined
ElementWillBeDetachedFromPlane | Element will be detached from its associated plane
FootingWillMoveToBottom | An attached Structural Foundation will be moved to the bottom of the Column.
JoiningDisjoint | Highlighted elements are joined but do not intersect.
JoiningDisjointWarn | Highlighted elements are joined but do not intersect.
StairsComponentTypeUnsupportedError | The selected stair type/shape isn't supported for attaching a wall to a stair. To continue, detach the wall from the stairs' components.
StructGroupMemberWillDetachFromGrid | A structural element will be detached from grid(s) due to inconsistent group membership.
WallTypeUnsupportedError | The selected wall type/shape isn't supported for attaching a wall to a stair. To continue, detach the wall from the stairs' components.
Top
See Also

Reference

BuiltInFailuresJoinElementsFailures Class


BuiltInFailures.JoinElementsFailures.CannotCope Property

BuiltInFailuresJoinElementsFailuresCannotCope Property

Can't apply Coping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCope { get; }
Public Shared ReadOnly Property CannotCope As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCope {
    FailureDefinitionId^ get ();
}
static member CannotCope : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresJoinElementsFailures Class


BuiltInFailures.JoinElementsFailures.CannotCutJoinedGeometry Property

BuiltInFailuresJoinElementsFailuresCannotCutJoinedGeometry Property

Element could not be cut by joined element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCutJoinedGeometry { get; }
Public Shared ReadOnly Property CannotCutJoinedGeometry As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCutJoinedGeometry {
    FailureDefinitionId^ get ();
}
static member CannotCutJoinedGeometry : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresJoinElementsFailures Class


BuiltInFailures.JoinElementsFailures.CannotJoinDesignOptions Property

BuiltInFailuresJoinElementsFailuresCannotJoinDesignOptions Property

An element cannot join to an element in a secondary Design Option unless it is in the same secondary Design Option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotJoinDesignOptions { get; }
Public Shared ReadOnly Property CannotJoinDesignOptions As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotJoinDesignOptions {
    FailureDefinitionId^ get ();
}
static member CannotJoinDesignOptions : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresJoinElementsFailures Class


BuiltInFailures.JoinElementsFailures.CannotJoinElements Property

BuiltInFailuresJoinElementsFailuresCannotJoinElements Property

Can't keep elements joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotJoinElements { get; }
Public Shared ReadOnly Property CannotJoinElements As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotJoinElements {
    FailureDefinitionId^ get ();
}
static member CannotJoinElements : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresJoinElementsFailures Class


BuiltInFailures.JoinElementsFailures.CannotJoinElementsError Property

BuiltInFailuresJoinElementsFailuresCannotJoinElementsError Property

Can't keep elements joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotJoinElementsError { get; }
Public Shared ReadOnly Property CannotJoinElementsError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotJoinElementsError {
    FailureDefinitionId^ get ();
}
static member CannotJoinElementsError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresJoinElementsFailures Class


BuiltInFailures.JoinElementsFailures.CannotJoinElementsMultiPlaneError Property

BuiltInFailuresJoinElementsFailuresCannotJoinElementsMultiPlaneError Property

Can't keep elements joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotJoinElementsMultiPlaneError { get; }
Public Shared ReadOnly Property CannotJoinElementsMultiPlaneError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotJoinElementsMultiPlaneError {
    FailureDefinitionId^ get ();
}
static member CannotJoinElementsMultiPlaneError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresJoinElementsFailures Class


BuiltInFailures.JoinElementsFailures.CannotJoinElementsStructural Property

BuiltInFailuresJoinElementsFailuresCannotJoinElementsStructural Property

Can't keep elements joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotJoinElementsStructural { get; }
Public Shared ReadOnly Property CannotJoinElementsStructural As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotJoinElementsStructural {
    FailureDefinitionId^ get ();
}
static member CannotJoinElementsStructural : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresJoinElementsFailures Class


BuiltInFailures.JoinElementsFailures.CannotJoinElementsStructuralError Property

BuiltInFailuresJoinElementsFailuresCannotJoinElementsStructuralError Property

Can't keep elements joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotJoinElementsStructuralError { get; }
Public Shared ReadOnly Property CannotJoinElementsStructuralError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotJoinElementsStructuralError {
    FailureDefinitionId^ get ();
}
static member CannotJoinElementsStructuralError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresJoinElementsFailures Class


BuiltInFailures.JoinElementsFailures.CannotJoinElementsWarn Property

BuiltInFailuresJoinElementsFailuresCannotJoinElementsWarn Property

Can't keep elements joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotJoinElementsWarn { get; }
Public Shared ReadOnly Property CannotJoinElementsWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotJoinElementsWarn {
    FailureDefinitionId^ get ();
}
static member CannotJoinElementsWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresJoinElementsFailures Class


BuiltInFailures.JoinElementsFailures.CannotJoinRoof Property

BuiltInFailuresJoinElementsFailuresCannotJoinRoof Property

The roof cannot be joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotJoinRoof { get; }
Public Shared ReadOnly Property CannotJoinRoof As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotJoinRoof {
    FailureDefinitionId^ get ();
}
static member CannotJoinRoof : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresJoinElementsFailures Class


BuiltInFailures.JoinElementsFailures.CannotJoinRoofError Property

BuiltInFailuresJoinElementsFailuresCannotJoinRoofError Property

The roof cannot be joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotJoinRoofError { get; }
Public Shared ReadOnly Property CannotJoinRoofError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotJoinRoofError {
    FailureDefinitionId^ get ();
}
static member CannotJoinRoofError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresJoinElementsFailures Class


BuiltInFailures.JoinElementsFailures.CannotKeepJoined Property

BuiltInFailuresJoinElementsFailuresCannotKeepJoined Property

Can't keep elements joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotKeepJoined { get; }
Public Shared ReadOnly Property CannotKeepJoined As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotKeepJoined {
    FailureDefinitionId^ get ();
}
static member CannotKeepJoined : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresJoinElementsFailures Class


BuiltInFailures.JoinElementsFailures.CannotKeepReferenceOfJoinedElement Property

BuiltInFailuresJoinElementsFailuresCannotKeepReferenceOfJoinedElement Property

Can't keep reference of joined element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotKeepReferenceOfJoinedElement { get; }
Public Shared ReadOnly Property CannotKeepReferenceOfJoinedElement As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotKeepReferenceOfJoinedElement {
    FailureDefinitionId^ get ();
}
static member CannotKeepReferenceOfJoinedElement : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresJoinElementsFailures Class


BuiltInFailures.JoinElementsFailures.CannotKeepReferenceOfJoinedElementWarning Property

BuiltInFailuresJoinElementsFailuresCannotKeepReferenceOfJoinedElementWarning Property

Can't keep reference of joined element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotKeepReferenceOfJoinedElementWarning { get; }
Public Shared ReadOnly Property CannotKeepReferenceOfJoinedElementWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotKeepReferenceOfJoinedElementWarning {
    FailureDefinitionId^ get ();
}
static member CannotKeepReferenceOfJoinedElementWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresJoinElementsFailures Class


BuiltInFailures.JoinElementsFailures.CannotKeepTrussJoined Property

BuiltInFailuresJoinElementsFailuresCannotKeepTrussJoined Property

Can't keep the highlighted [Element]s joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotKeepTrussJoined { get; }
Public Shared ReadOnly Property CannotKeepTrussJoined As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotKeepTrussJoined {
    FailureDefinitionId^ get ();
}
static member CannotKeepTrussJoined : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresJoinElementsFailures Class


BuiltInFailures.JoinElementsFailures.CannotKeepWallJoinToRoof Property

BuiltInFailuresJoinElementsFailuresCannotKeepWallJoinToRoof Property

Can't keep wall and [target] joined

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotKeepWallJoinToRoof { get; }
Public Shared ReadOnly Property CannotKeepWallJoinToRoof As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotKeepWallJoinToRoof {
    FailureDefinitionId^ get ();
}
static member CannotKeepWallJoinToRoof : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresJoinElementsFailures Class


BuiltInFailures.JoinElementsFailures.CannotKeepWallJoinToRoofError Property

BuiltInFailuresJoinElementsFailuresCannotKeepWallJoinToRoofError Property

Can't keep wall and [target] joined

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotKeepWallJoinToRoofError { get; }
Public Shared ReadOnly Property CannotKeepWallJoinToRoofError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotKeepWallJoinToRoofError {
    FailureDefinitionId^ get ();
}
static member CannotKeepWallJoinToRoofError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresJoinElementsFailures Class


BuiltInFailures.JoinElementsFailures.ElementWillBeDetachedFromPlane Property

BuiltInFailuresJoinElementsFailuresElementWillBeDetachedFromPlane Property

Element will be detached from its associated plane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ElementWillBeDetachedFromPlane { get; }
Public Shared ReadOnly Property ElementWillBeDetachedFromPlane As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ElementWillBeDetachedFromPlane {
    FailureDefinitionId^ get ();
}
static member ElementWillBeDetachedFromPlane : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresJoinElementsFailures Class


BuiltInFailures.JoinElementsFailures.FootingWillMoveToBottom Property

BuiltInFailuresJoinElementsFailuresFootingWillMoveToBottom Property

An attached Structural Foundation will be moved to the bottom of the Column.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FootingWillMoveToBottom { get; }
Public Shared ReadOnly Property FootingWillMoveToBottom As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FootingWillMoveToBottom {
    FailureDefinitionId^ get ();
}
static member FootingWillMoveToBottom : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresJoinElementsFailures Class


BuiltInFailures.JoinElementsFailures.JoiningDisjoint Property

BuiltInFailuresJoinElementsFailuresJoiningDisjoint Property

Highlighted elements are joined but do not intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId JoiningDisjoint { get; }
Public Shared ReadOnly Property JoiningDisjoint As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ JoiningDisjoint {
    FailureDefinitionId^ get ();
}
static member JoiningDisjoint : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresJoinElementsFailures Class


BuiltInFailures.JoinElementsFailures.JoiningDisjointWarn Property

BuiltInFailuresJoinElementsFailuresJoiningDisjointWarn Property

Highlighted elements are joined but do not intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId JoiningDisjointWarn { get; }
Public Shared ReadOnly Property JoiningDisjointWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ JoiningDisjointWarn {
    FailureDefinitionId^ get ();
}
static member JoiningDisjointWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresJoinElementsFailures Class


BuiltInFailures.JoinElementsFailures.StairsComponentTypeUnsupportedError Property

BuiltInFailuresJoinElementsFailuresStairsComponentTypeUnsupportedError Property

The selected stair type/shape isn't supported for attaching a wall to a stair. To continue, detach the wall from the stairs' components.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StairsComponentTypeUnsupportedError { get; }
Public Shared ReadOnly Property StairsComponentTypeUnsupportedError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StairsComponentTypeUnsupportedError {
    FailureDefinitionId^ get ();
}
static member StairsComponentTypeUnsupportedError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresJoinElementsFailures Class


BuiltInFailures.JoinElementsFailures.StructGroupMemberWillDetachFromGrid Property

BuiltInFailuresJoinElementsFailuresStructGroupMemberWillDetachFromGrid Property

A structural element will be detached from grid(s) due to inconsistent group membership.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StructGroupMemberWillDetachFromGrid { get; }
Public Shared ReadOnly Property StructGroupMemberWillDetachFromGrid As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StructGroupMemberWillDetachFromGrid {
    FailureDefinitionId^ get ();
}
static member StructGroupMemberWillDetachFromGrid : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresJoinElementsFailures Class


BuiltInFailures.JoinElementsFailures.WallTypeUnsupportedError Property

BuiltInFailuresJoinElementsFailuresWallTypeUnsupportedError Property

The selected wall type/shape isn't supported for attaching a wall to a stair. To continue, detach the wall from the stairs' components.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WallTypeUnsupportedError { get; }
Public Shared ReadOnly Property WallTypeUnsupportedError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WallTypeUnsupportedError {
    FailureDefinitionId^ get ();
}
static member WallTypeUnsupportedError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresJoinElementsFailures Class


BuiltInFailures.KeyBasedTreeEntryFailures Class

BuiltInFailuresKeyBasedTreeEntryFailures Class

Failures about KeyBasedTreeEntry.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresKeyBasedTreeEntryFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class KeyBasedTreeEntryFailures
Public NotInheritable Class KeyBasedTreeEntryFailures
public ref class KeyBasedTreeEntryFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type KeyBasedTreeEntryFailures = class end

The BuiltInFailuresKeyBasedTreeEntryFailures type exposes the following members.

Properties
Name | Description
BadClassificationLevel | Level [Level] of Classification [Code] is not an integer from 1 to 5.
CircularParentage | A sub-[EntryType] '[Code]' specified as parent for its current ancestor '[Code]'
DuplicateEntry | Duplicate code '[Code]', description: '[Description]'
MissingParent | No parent [EntryType] '[Code]' for '[Code]'
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


KeyBasedTreeEntryFailures Properties

The BuiltInFailuresKeyBasedTreeEntryFailures type exposes the following members.

Properties
Name | Description
BadClassificationLevel | Level [Level] of Classification [Code] is not an integer from 1 to 5.
CircularParentage | A sub-[EntryType] '[Code]' specified as parent for its current ancestor '[Code]'
DuplicateEntry | Duplicate code '[Code]', description: '[Description]'
MissingParent | No parent [EntryType] '[Code]' for '[Code]'
Top
See Also

Reference

BuiltInFailuresKeyBasedTreeEntryFailures Class


BuiltInFailures.KeyBasedTreeEntryFailures.BadClassificationLevel Property

BuiltInFailuresKeyBasedTreeEntryFailuresBadClassificationLevel Property

Level [Level] of Classification [Code] is not an integer from 1 to 5.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BadClassificationLevel { get; }
Public Shared ReadOnly Property BadClassificationLevel As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BadClassificationLevel {
    FailureDefinitionId^ get ();
}
static member BadClassificationLevel : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresKeyBasedTreeEntryFailures Class


BuiltInFailures.KeyBasedTreeEntryFailures.CircularParentage Property

BuiltInFailuresKeyBasedTreeEntryFailuresCircularParentage Property

A sub-[EntryType] '[Code]' specified as parent for its current ancestor '[Code]'

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CircularParentage { get; }
Public Shared ReadOnly Property CircularParentage As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CircularParentage {
    FailureDefinitionId^ get ();
}
static member CircularParentage : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresKeyBasedTreeEntryFailures Class


BuiltInFailures.KeyBasedTreeEntryFailures.DuplicateEntry Property

BuiltInFailuresKeyBasedTreeEntryFailuresDuplicateEntry Property

Duplicate code '[Code]', description: '[Description]'

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DuplicateEntry { get; }
Public Shared ReadOnly Property DuplicateEntry As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DuplicateEntry {
    FailureDefinitionId^ get ();
}
static member DuplicateEntry : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresKeyBasedTreeEntryFailures Class


BuiltInFailures.KeyBasedTreeEntryFailures.MissingParent Property

BuiltInFailuresKeyBasedTreeEntryFailuresMissingParent Property

No parent [EntryType] '[Code]' for '[Code]'

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MissingParent { get; }
Public Shared ReadOnly Property MissingParent As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MissingParent {
    FailureDefinitionId^ get ();
}
static member MissingParent : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresKeyBasedTreeEntryFailures Class


BuiltInFailures.KeyBasedTreeFileFailures Class

BuiltInFailuresKeyBasedTreeFileFailures Class

Failures occurred when reading key based tree text file.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresKeyBasedTreeFileFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class KeyBasedTreeFileFailures
Public NotInheritable Class KeyBasedTreeFileFailures
public ref class KeyBasedTreeFileFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type KeyBasedTreeFileFailures = class end

The BuiltInFailuresKeyBasedTreeFileFailures type exposes the following members.

Properties
Name | Description
CannotOpenFileForRead | Cannot open file [FileName].
CannotUnderstandAtLine | Cannot understand [EntryType] line '[Number]'
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


KeyBasedTreeFileFailures Properties

The BuiltInFailuresKeyBasedTreeFileFailures type exposes the following members.

Properties
Name | Description
CannotOpenFileForRead | Cannot open file [FileName].
CannotUnderstandAtLine | Cannot understand [EntryType] line '[Number]'
Top
See Also

Reference

BuiltInFailuresKeyBasedTreeFileFailures Class


BuiltInFailures.KeyBasedTreeFileFailures.CannotOpenFileForRead Property

BuiltInFailuresKeyBasedTreeFileFailuresCannotOpenFileForRead Property

Cannot open file [FileName].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotOpenFileForRead { get; }
Public Shared ReadOnly Property CannotOpenFileForRead As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotOpenFileForRead {
    FailureDefinitionId^ get ();
}
static member CannotOpenFileForRead : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresKeyBasedTreeFileFailures Class


BuiltInFailures.KeyBasedTreeFileFailures.CannotUnderstandAtLine Property

BuiltInFailuresKeyBasedTreeFileFailuresCannotUnderstandAtLine Property

Cannot understand [EntryType] line '[Number]'

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotUnderstandAtLine { get; }
Public Shared ReadOnly Property CannotUnderstandAtLine As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotUnderstandAtLine {
    FailureDefinitionId^ get ();
}
static member CannotUnderstandAtLine : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresKeyBasedTreeFileFailures Class


BuiltInFailures.KeynoteFailures Class

BuiltInFailuresKeynoteFailures Class

Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresKeynoteFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class KeynoteFailures
Public NotInheritable Class KeynoteFailures
public ref class KeynoteFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type KeynoteFailures = class end

The BuiltInFailuresKeynoteFailures type exposes the following members.

Properties
Name | Description
MissKeynoteParameter | No Keynote Parameter.\nTo resolve, select key value parameter in keynoting system.
MissKeynotingSystem | No Keynoting System associated with Tag Family.\nTo resolve, select keynoting system for the tag family.
NotAssociatedKeynoteParameter | Current tag keynoting system uses key value parameter that is not associated with this element category.\nTo resolve, associate parameter with category or change keynoting system.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


KeynoteFailures Properties

The BuiltInFailuresKeynoteFailures type exposes the following members.

Properties
Name | Description
MissKeynoteParameter | No Keynote Parameter.\nTo resolve, select key value parameter in keynoting system.
MissKeynotingSystem | No Keynoting System associated with Tag Family.\nTo resolve, select keynoting system for the tag family.
NotAssociatedKeynoteParameter | Current tag keynoting system uses key value parameter that is not associated with this element category.\nTo resolve, associate parameter with category or change keynoting system.
Top
See Also

Reference

BuiltInFailuresKeynoteFailures Class


BuiltInFailures.KeynoteFailures.MissKeynoteParameter Property

BuiltInFailuresKeynoteFailuresMissKeynoteParameter Property

No Keynote Parameter.\nTo resolve, select key value parameter in keynoting system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MissKeynoteParameter { get; }
Public Shared ReadOnly Property MissKeynoteParameter As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MissKeynoteParameter {
    FailureDefinitionId^ get ();
}
static member MissKeynoteParameter : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresKeynoteFailures Class


BuiltInFailures.KeynoteFailures.MissKeynotingSystem Property

BuiltInFailuresKeynoteFailuresMissKeynotingSystem Property

No Keynoting System associated with Tag Family.\nTo resolve, select keynoting system for the tag family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MissKeynotingSystem { get; }
Public Shared ReadOnly Property MissKeynotingSystem As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MissKeynotingSystem {
    FailureDefinitionId^ get ();
}
static member MissKeynotingSystem : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresKeynoteFailures Class


BuiltInFailures.KeynoteFailures.NotAssociatedKeynoteParameter Property

BuiltInFailuresKeynoteFailuresNotAssociatedKeynoteParameter Property

Current tag keynoting system uses key value parameter that is not associated with this element category.\nTo resolve, associate parameter with category or change keynoting system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotAssociatedKeynoteParameter { get; }
Public Shared ReadOnly Property NotAssociatedKeynoteParameter As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotAssociatedKeynoteParameter {
    FailureDefinitionId^ get ();
}
static member NotAssociatedKeynoteParameter : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresKeynoteFailures Class


BuiltInFailures.KeynoteTagFailures Class

BuiltInFailuresKeynoteTagFailures Class

Failures related to keynote tags.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresKeynoteTagFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class KeynoteTagFailures
Public NotInheritable Class KeynoteTagFailures
public ref class KeynoteTagFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type KeynoteTagFailures = class end

The BuiltInFailuresKeynoteTagFailures type exposes the following members.

Properties
Name | Description
KeynoteOnLinkWithDifferentKeynoteFile | The parameters of the keynote tag are empty because the keynoted linked element uses a different keynote file.
NoKeynoteAssignedToLinkedElement | The parameters of the keynote tag are empty because the keynoted linked element uses a different keynote file.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


KeynoteTagFailures Properties

The BuiltInFailuresKeynoteTagFailures type exposes the following members.

Properties
Name | Description
KeynoteOnLinkWithDifferentKeynoteFile | The parameters of the keynote tag are empty because the keynoted linked element uses a different keynote file.
NoKeynoteAssignedToLinkedElement | The parameters of the keynote tag are empty because the keynoted linked element uses a different keynote file.
Top
See Also

Reference

BuiltInFailuresKeynoteTagFailures Class


BuiltInFailures.KeynoteTagFailures.KeynoteOnLinkWithDifferentKeynoteFile Property

BuiltInFailuresKeynoteTagFailuresKeynoteOnLinkWithDifferentKeynoteFile Property

The parameters of the keynote tag are empty because the keynoted linked element uses a different keynote file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId KeynoteOnLinkWithDifferentKeynoteFile { get; }
Public Shared ReadOnly Property KeynoteOnLinkWithDifferentKeynoteFile As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ KeynoteOnLinkWithDifferentKeynoteFile {
    FailureDefinitionId^ get ();
}
static member KeynoteOnLinkWithDifferentKeynoteFile : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresKeynoteTagFailures Class


BuiltInFailures.KeynoteTagFailures.NoKeynoteAssignedToLinkedElement Property

BuiltInFailuresKeynoteTagFailuresNoKeynoteAssignedToLinkedElement Property

The parameters of the keynote tag are empty because the keynoted linked element uses a different keynote file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoKeynoteAssignedToLinkedElement { get; }
Public Shared ReadOnly Property NoKeynoteAssignedToLinkedElement As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoKeynoteAssignedToLinkedElement {
    FailureDefinitionId^ get ();
}
static member NoKeynoteAssignedToLinkedElement : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresKeynoteTagFailures Class


BuiltInFailures.LegendFailures Class

BuiltInFailuresLegendFailures Class

Failures about Legend.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresLegendFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class LegendFailures
Public NotInheritable Class LegendFailures
public ref class LegendFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type LegendFailures = class end

The BuiltInFailuresLegendFailures type exposes the following members.

Properties
Name | Description
LegendComponentBadViewType | Legend Components may only be placed in Legends
LegendComponentNotVisible | The component you have selected is not visible in the selected view.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LegendFailures Properties

The BuiltInFailuresLegendFailures type exposes the following members.

Properties
Name | Description
LegendComponentBadViewType | Legend Components may only be placed in Legends
LegendComponentNotVisible | The component you have selected is not visible in the selected view.
Top
See Also

Reference

BuiltInFailuresLegendFailures Class


BuiltInFailures.LegendFailures.LegendComponentBadViewType Property

BuiltInFailuresLegendFailuresLegendComponentBadViewType Property

Legend Components may only be placed in Legends

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LegendComponentBadViewType { get; }
Public Shared ReadOnly Property LegendComponentBadViewType As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LegendComponentBadViewType {
    FailureDefinitionId^ get ();
}
static member LegendComponentBadViewType : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresLegendFailures Class


BuiltInFailures.LegendFailures.LegendComponentNotVisible Property

BuiltInFailuresLegendFailuresLegendComponentNotVisible Property

The component you have selected is not visible in the selected view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LegendComponentNotVisible { get; }
Public Shared ReadOnly Property LegendComponentNotVisible As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LegendComponentNotVisible {
    FailureDefinitionId^ get ();
}
static member LegendComponentNotVisible : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresLegendFailures Class


BuiltInFailures.LevelAssociationFailures Class

BuiltInFailuresLevelAssociationFailures Class

Failures about Level association of Analytical Node.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresLevelAssociationFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class LevelAssociationFailures
Public NotInheritable Class LevelAssociationFailures
public ref class LevelAssociationFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type LevelAssociationFailures = class end

The BuiltInFailuresLevelAssociationFailures type exposes the following members.

Properties
Name | Description
AllLevelsDeleted | All Levels from model were deleted
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LevelAssociationFailures Properties

The BuiltInFailuresLevelAssociationFailures type exposes the following members.

Properties
Name | Description
AllLevelsDeleted | All Levels from model were deleted
Top
See Also

Reference

BuiltInFailuresLevelAssociationFailures Class


BuiltInFailures.LevelAssociationFailures.AllLevelsDeleted Property

BuiltInFailuresLevelAssociationFailuresAllLevelsDeleted Property

All Levels from model were deleted

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AllLevelsDeleted { get; }
Public Shared ReadOnly Property AllLevelsDeleted As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AllLevelsDeleted {
    FailureDefinitionId^ get ();
}
static member AllLevelsDeleted : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresLevelAssociationFailures Class


BuiltInFailures.LevelFailures Class

BuiltInFailuresLevelFailures Class

Failures about Level.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresLevelFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class LevelFailures
Public NotInheritable Class LevelFailures
public ref class LevelFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type LevelFailures = class end

The BuiltInFailuresLevelFailures type exposes the following members.

Properties
Name | Description
NoLevelsLeft | There are no levels or plan views remaining in the project.
NoLevelsLeftReloading | As a result of Reloading Latest, there are no Levels left. Create a new Level, and then Reload Latest again.
StoryAboveDeleted | The level set as the Story Above for these levels is being deleted. This change will cause these levels to revert to the default Story Above.
StoryAboveMoved | The level set as the Story Above for these levels has moved below these levels. This change will cause these levels to revert to the default Story Above.
StoryAboveNonStoryLevel | The level set as the Story Above for these levels is no longer a story level. This change will cause these levels to revert to the default Story Above.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LevelFailures Properties

The BuiltInFailuresLevelFailures type exposes the following members.

Properties
Name | Description
NoLevelsLeft | There are no levels or plan views remaining in the project.
NoLevelsLeftReloading | As a result of Reloading Latest, there are no Levels left. Create a new Level, and then Reload Latest again.
StoryAboveDeleted | The level set as the Story Above for these levels is being deleted. This change will cause these levels to revert to the default Story Above.
StoryAboveMoved | The level set as the Story Above for these levels has moved below these levels. This change will cause these levels to revert to the default Story Above.
StoryAboveNonStoryLevel | The level set as the Story Above for these levels is no longer a story level. This change will cause these levels to revert to the default Story Above.
Top
See Also

Reference

BuiltInFailuresLevelFailures Class


BuiltInFailures.LevelFailures.NoLevelsLeft Property

BuiltInFailuresLevelFailuresNoLevelsLeft Property

There are no levels or plan views remaining in the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoLevelsLeft { get; }
Public Shared ReadOnly Property NoLevelsLeft As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoLevelsLeft {
    FailureDefinitionId^ get ();
}
static member NoLevelsLeft : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresLevelFailures Class


BuiltInFailures.LevelFailures.NoLevelsLeftReloading Property

BuiltInFailuresLevelFailuresNoLevelsLeftReloading Property

As a result of Reloading Latest, there are no Levels left. Create a new Level, and then Reload Latest again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoLevelsLeftReloading { get; }
Public Shared ReadOnly Property NoLevelsLeftReloading As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoLevelsLeftReloading {
    FailureDefinitionId^ get ();
}
static member NoLevelsLeftReloading : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresLevelFailures Class


BuiltInFailures.LevelFailures.StoryAboveDeleted Property

BuiltInFailuresLevelFailuresStoryAboveDeleted Property

The level set as the Story Above for these levels is being deleted. This change will cause these levels to revert to the default Story Above.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StoryAboveDeleted { get; }
Public Shared ReadOnly Property StoryAboveDeleted As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StoryAboveDeleted {
    FailureDefinitionId^ get ();
}
static member StoryAboveDeleted : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresLevelFailures Class


BuiltInFailures.LevelFailures.StoryAboveMoved Property

BuiltInFailuresLevelFailuresStoryAboveMoved Property

The level set as the Story Above for these levels has moved below these levels. This change will cause these levels to revert to the default Story Above.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StoryAboveMoved { get; }
Public Shared ReadOnly Property StoryAboveMoved As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StoryAboveMoved {
    FailureDefinitionId^ get ();
}
static member StoryAboveMoved : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresLevelFailures Class


BuiltInFailures.LevelFailures.StoryAboveNonStoryLevel Property

BuiltInFailuresLevelFailuresStoryAboveNonStoryLevel Property

The level set as the Story Above for these levels is no longer a story level. This change will cause these levels to revert to the default Story Above.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StoryAboveNonStoryLevel { get; }
Public Shared ReadOnly Property StoryAboveNonStoryLevel As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StoryAboveNonStoryLevel {
    FailureDefinitionId^ get ();
}
static member StoryAboveNonStoryLevel : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresLevelFailures Class


BuiltInFailures.LinkFailures Class

BuiltInFailuresLinkFailures Class

Failures about LinkFailures.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresLinkFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class LinkFailures
Public NotInheritable Class LinkFailures
public ref class LinkFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type LinkFailures = class end

The BuiltInFailuresLinkFailures type exposes the following members.

Properties
Name | Description
CannotModifyLinkedFile | Shared Sites in the link ""%1!s!"" cannot be modified.
CannotOpenLinkedFileServerFound | Cannot open the linked model using Open and Unload because the plugin [name] provided by [vendor] experienced an error. For more information please contact [vendor].
CannotOpenLinkedFileServerNotFound | Cannot open the linked model using Open and Unload because the plugin [name] cannot be accessed. Please check plugin [name], which has server Id [serverId]
CannotPublishSharedCoordinatesToMirroredNonRevitLinks | Shared coordinates cannot be published to mirrored, non Revit, links.
CannotReloadFile | Can't reload file.
CannotUnlinkFile | Can't unlink file.
DataDictionaryDifferentInLink | Linked file [Name] was last saved in a previous version of Revit. Changes to it cannot be saved until it is upgraded.
DeleteLinkSymbolPrompt | All instances of Linked Model '[Name]' have been deleted, but the file itself is still loaded. Remove the Linked File using Manage Links dialog to save memory unless you are going to reuse it in this project. Removing the Link cannot be undone.
LinkedFileOpenInOtherDoc | Linked file cannot be reloaded because it is loaded into another open document.
LinkInstanceNeedsReconcile | Instance of linked .rvt file needs Coordination Review
ModifiedLinkedFile | Shared Sites in the link have been modified, use move instance to reset the change.
ModifyingLinkedFile | Shared Locations in the Linked Model '[Name]' have been modified, but not saved back to the Linked File. Upon reopening, instances of the Linked Model will return to their last Saved Positions. You can Save the Linked Model later via the Manage Links dialog.
MultipleLinks | Can't complete operation. Linked Files have the same name.
NoConstraintsToLinks1 | Constraints may not be created to linked instances using Shared Locations. Constraints will be removed.
SourceFileDrivenByOtherTarget | Linked Model's Shared Coordinates have been modified via another host model in this session. In order to be able to change the Linked File via the active host model, Save and open it again in a new session.
WatchedLinkMoved | Monitored Link moved.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LinkFailures Properties

The BuiltInFailuresLinkFailures type exposes the following members.

Properties
Name | Description
CannotModifyLinkedFile | Shared Sites in the link ""%1!s!"" cannot be modified.
CannotOpenLinkedFileServerFound | Cannot open the linked model using Open and Unload because the plugin [name] provided by [vendor] experienced an error. For more information please contact [vendor].
CannotOpenLinkedFileServerNotFound | Cannot open the linked model using Open and Unload because the plugin [name] cannot be accessed. Please check plugin [name], which has server Id [serverId]
CannotPublishSharedCoordinatesToMirroredNonRevitLinks | Shared coordinates cannot be published to mirrored, non Revit, links.
CannotReloadFile | Can't reload file.
CannotUnlinkFile | Can't unlink file.
DataDictionaryDifferentInLink | Linked file [Name] was last saved in a previous version of Revit. Changes to it cannot be saved until it is upgraded.
DeleteLinkSymbolPrompt | All instances of Linked Model '[Name]' have been deleted, but the file itself is still loaded. Remove the Linked File using Manage Links dialog to save memory unless you are going to reuse it in this project. Removing the Link cannot be undone.
LinkedFileOpenInOtherDoc | Linked file cannot be reloaded because it is loaded into another open document.
LinkInstanceNeedsReconcile | Instance of linked .rvt file needs Coordination Review
ModifiedLinkedFile | Shared Sites in the link have been modified, use move instance to reset the change.
ModifyingLinkedFile | Shared Locations in the Linked Model '[Name]' have been modified, but not saved back to the Linked File. Upon reopening, instances of the Linked Model will return to their last Saved Positions. You can Save the Linked Model later via the Manage Links dialog.
MultipleLinks | Can't complete operation. Linked Files have the same name.
NoConstraintsToLinks1 | Constraints may not be created to linked instances using Shared Locations. Constraints will be removed.
SourceFileDrivenByOtherTarget | Linked Model's Shared Coordinates have been modified via another host model in this session. In order to be able to change the Linked File via the active host model, Save and open it again in a new session.
WatchedLinkMoved | Monitored Link moved.
Top
See Also

Reference

BuiltInFailuresLinkFailures Class


BuiltInFailures.LinkFailures.CannotModifyLinkedFile Property

BuiltInFailuresLinkFailuresCannotModifyLinkedFile Property

Shared Sites in the link ""%1!s!"" cannot be modified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotModifyLinkedFile { get; }
Public Shared ReadOnly Property CannotModifyLinkedFile As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotModifyLinkedFile {
    FailureDefinitionId^ get ();
}
static member CannotModifyLinkedFile : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresLinkFailures Class


BuiltInFailures.LinkFailures.CannotOpenLinkedFileServerFound Property

BuiltInFailuresLinkFailuresCannotOpenLinkedFileServerFound Property

Cannot open the linked model using Open and Unload because the plugin [name] provided by [vendor] experienced an error. For more information please contact [vendor].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotOpenLinkedFileServerFound { get; }
Public Shared ReadOnly Property CannotOpenLinkedFileServerFound As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotOpenLinkedFileServerFound {
    FailureDefinitionId^ get ();
}
static member CannotOpenLinkedFileServerFound : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresLinkFailures Class


BuiltInFailures.LinkFailures.CannotOpenLinkedFileServerNotFound Property

BuiltInFailuresLinkFailuresCannotOpenLinkedFileServerNotFound Property

Cannot open the linked model using Open and Unload because the plugin [name] cannot be accessed. Please check plugin [name], which has server Id [serverId]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotOpenLinkedFileServerNotFound { get; }
Public Shared ReadOnly Property CannotOpenLinkedFileServerNotFound As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotOpenLinkedFileServerNotFound {
    FailureDefinitionId^ get ();
}
static member CannotOpenLinkedFileServerNotFound : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresLinkFailures Class


BuiltInFailures.LinkFailures.CannotPublishSharedCoordinatesToMirroredNonRevitLinks Property

BuiltInFailuresLinkFailuresCannotPublishSharedCoordinatesToMirroredNonRevitLinks Property

Shared coordinates cannot be published to mirrored, non Revit, links.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPublishSharedCoordinatesToMirroredNonRevitLinks { get; }
Public Shared ReadOnly Property CannotPublishSharedCoordinatesToMirroredNonRevitLinks As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPublishSharedCoordinatesToMirroredNonRevitLinks {
    FailureDefinitionId^ get ();
}
static member CannotPublishSharedCoordinatesToMirroredNonRevitLinks : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresLinkFailures Class


BuiltInFailures.LinkFailures.CannotReloadFile Property

BuiltInFailuresLinkFailuresCannotReloadFile Property

Can't reload file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotReloadFile { get; }
Public Shared ReadOnly Property CannotReloadFile As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotReloadFile {
    FailureDefinitionId^ get ();
}
static member CannotReloadFile : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresLinkFailures Class


BuiltInFailures.LinkFailures.CannotUnlinkFile Property

BuiltInFailuresLinkFailuresCannotUnlinkFile Property

Can't unlink file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotUnlinkFile { get; }
Public Shared ReadOnly Property CannotUnlinkFile As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotUnlinkFile {
    FailureDefinitionId^ get ();
}
static member CannotUnlinkFile : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresLinkFailures Class


BuiltInFailures.LinkFailures.DataDictionaryDifferentInLink Property

BuiltInFailuresLinkFailuresDataDictionaryDifferentInLink Property

Linked file [Name] was last saved in a previous version of Revit. Changes to it cannot be saved until it is upgraded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DataDictionaryDifferentInLink { get; }
Public Shared ReadOnly Property DataDictionaryDifferentInLink As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DataDictionaryDifferentInLink {
    FailureDefinitionId^ get ();
}
static member DataDictionaryDifferentInLink : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresLinkFailures Class


BuiltInFailures.LinkFailures.DeleteLinkSymbolPrompt Property

BuiltInFailuresLinkFailuresDeleteLinkSymbolPrompt Property

All instances of Linked Model '[Name]' have been deleted, but the file itself is still loaded. Remove the Linked File using Manage Links dialog to save memory unless you are going to reuse it in this project. Removing the Link cannot be undone.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DeleteLinkSymbolPrompt { get; }
Public Shared ReadOnly Property DeleteLinkSymbolPrompt As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DeleteLinkSymbolPrompt {
    FailureDefinitionId^ get ();
}
static member DeleteLinkSymbolPrompt : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresLinkFailures Class


BuiltInFailures.LinkFailures.LinkedFileOpenInOtherDoc Property

BuiltInFailuresLinkFailuresLinkedFileOpenInOtherDoc Property

Linked file cannot be reloaded because it is loaded into another open document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LinkedFileOpenInOtherDoc { get; }
Public Shared ReadOnly Property LinkedFileOpenInOtherDoc As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LinkedFileOpenInOtherDoc {
    FailureDefinitionId^ get ();
}
static member LinkedFileOpenInOtherDoc : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresLinkFailures Class


BuiltInFailures.LinkFailures.LinkInstanceNeedsReconcile Property

BuiltInFailuresLinkFailuresLinkInstanceNeedsReconcile Property

Instance of linked .rvt file needs Coordination Review

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LinkInstanceNeedsReconcile { get; }
Public Shared ReadOnly Property LinkInstanceNeedsReconcile As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LinkInstanceNeedsReconcile {
    FailureDefinitionId^ get ();
}
static member LinkInstanceNeedsReconcile : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresLinkFailures Class


BuiltInFailures.LinkFailures.ModifiedLinkedFile Property

BuiltInFailuresLinkFailuresModifiedLinkedFile Property

Shared Sites in the link have been modified, use move instance to reset the change.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ModifiedLinkedFile { get; }
Public Shared ReadOnly Property ModifiedLinkedFile As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ModifiedLinkedFile {
    FailureDefinitionId^ get ();
}
static member ModifiedLinkedFile : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresLinkFailures Class


BuiltInFailures.LinkFailures.ModifyingLinkedFile Property

BuiltInFailuresLinkFailuresModifyingLinkedFile Property

Shared Locations in the Linked Model '[Name]' have been modified, but not saved back to the Linked File. Upon reopening, instances of the Linked Model will return to their last Saved Positions. You can Save the Linked Model later via the Manage Links dialog.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ModifyingLinkedFile { get; }
Public Shared ReadOnly Property ModifyingLinkedFile As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ModifyingLinkedFile {
    FailureDefinitionId^ get ();
}
static member ModifyingLinkedFile : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresLinkFailures Class


BuiltInFailures.LinkFailures.MultipleLinks Property

BuiltInFailuresLinkFailuresMultipleLinks Property

Can't complete operation. Linked Files have the same name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MultipleLinks { get; }
Public Shared ReadOnly Property MultipleLinks As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MultipleLinks {
    FailureDefinitionId^ get ();
}
static member MultipleLinks : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresLinkFailures Class


BuiltInFailures.LinkFailures.NoConstraintsToLinks1 Property

BuiltInFailuresLinkFailuresNoConstraintsToLinks1 Property

Constraints may not be created to linked instances using Shared Locations. Constraints will be removed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoConstraintsToLinks1 { get; }
Public Shared ReadOnly Property NoConstraintsToLinks1 As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoConstraintsToLinks1 {
    FailureDefinitionId^ get ();
}
static member NoConstraintsToLinks1 : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresLinkFailures Class


BuiltInFailures.LinkFailures.SourceFileDrivenByOtherTarget Property

BuiltInFailuresLinkFailuresSourceFileDrivenByOtherTarget Property

Linked Model's Shared Coordinates have been modified via another host model in this session. In order to be able to change the Linked File via the active host model, Save and open it again in a new session.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SourceFileDrivenByOtherTarget { get; }
Public Shared ReadOnly Property SourceFileDrivenByOtherTarget As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SourceFileDrivenByOtherTarget {
    FailureDefinitionId^ get ();
}
static member SourceFileDrivenByOtherTarget : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresLinkFailures Class


BuiltInFailures.LinkFailures.WatchedLinkMoved Property

BuiltInFailuresLinkFailuresWatchedLinkMoved Property

Monitored Link moved.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WatchedLinkMoved { get; }
Public Shared ReadOnly Property WatchedLinkMoved As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WatchedLinkMoved {
    FailureDefinitionId^ get ();
}
static member WatchedLinkMoved : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresLinkFailures Class


BuiltInFailures.LoadFailures Class

BuiltInFailuresLoadFailures Class

Failures about Load.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresLoadFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class LoadFailures
Public NotInheritable Class LoadFailures
public ref class LoadFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type LoadFailures = class end

The BuiltInFailuresLoadFailures type exposes the following members.

Properties
Name | Description
AreaLoadNotOverlappingHost | Area load is not overlapping with its entire distribution its host.
CannotCopyHostedLoad | Can't copy Load based on the Host Element.
CannotMirrorHostedLoad | Can't mirror Load based on the Host Element.
CannotMirrorLoad | Can't mirror Load because mirror plane is not perpendicular to sketch plane.
CannotMoveHostedLoad | Can't move Load based on the Host Element.
CannotRotateLoad | Can't rotate Load because rotation axis is not perpendicular to sketch plane.
InvalidAreaLoadSketchError | Area Load has invalid Sketch.
LineLoadAllZero | Line Load can't have all force components and moment components to be zero.
LineLoadNotOverlappingHost | Line load is not overlapping with its entire distribution its host.
OpenAreaLoadLoopError | Area Load Sketch can't contain open loops.
PointLoadAllZero | Point Load can't have all force components and moment components to be zero.
PointLoadNotOverlappingHost | Point load is not overlapping with its entire distribution its host.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LoadFailures Properties

The BuiltInFailuresLoadFailures type exposes the following members.

Properties
Name | Description
AreaLoadNotOverlappingHost | Area load is not overlapping with its entire distribution its host.
CannotCopyHostedLoad | Can't copy Load based on the Host Element.
CannotMirrorHostedLoad | Can't mirror Load based on the Host Element.
CannotMirrorLoad | Can't mirror Load because mirror plane is not perpendicular to sketch plane.
CannotMoveHostedLoad | Can't move Load based on the Host Element.
CannotRotateLoad | Can't rotate Load because rotation axis is not perpendicular to sketch plane.
InvalidAreaLoadSketchError | Area Load has invalid Sketch.
LineLoadAllZero | Line Load can't have all force components and moment components to be zero.
LineLoadNotOverlappingHost | Line load is not overlapping with its entire distribution its host.
OpenAreaLoadLoopError | Area Load Sketch can't contain open loops.
PointLoadAllZero | Point Load can't have all force components and moment components to be zero.
PointLoadNotOverlappingHost | Point load is not overlapping with its entire distribution its host.
Top
See Also

Reference

BuiltInFailuresLoadFailures Class


BuiltInFailures.LoadFailures.AreaLoadNotOverlappingHost Property

BuiltInFailuresLoadFailuresAreaLoadNotOverlappingHost Property

Area load is not overlapping with its entire distribution its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AreaLoadNotOverlappingHost { get; }
Public Shared ReadOnly Property AreaLoadNotOverlappingHost As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AreaLoadNotOverlappingHost {
    FailureDefinitionId^ get ();
}
static member AreaLoadNotOverlappingHost : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresLoadFailures Class


BuiltInFailures.LoadFailures.CannotCopyHostedLoad Property

BuiltInFailuresLoadFailuresCannotCopyHostedLoad Property

Can't copy Load based on the Host Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyHostedLoad { get; }
Public Shared ReadOnly Property CannotCopyHostedLoad As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyHostedLoad {
    FailureDefinitionId^ get ();
}
static member CannotCopyHostedLoad : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresLoadFailures Class


BuiltInFailures.LoadFailures.CannotMirrorHostedLoad Property

BuiltInFailuresLoadFailuresCannotMirrorHostedLoad Property

Can't mirror Load based on the Host Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotMirrorHostedLoad { get; }
Public Shared ReadOnly Property CannotMirrorHostedLoad As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotMirrorHostedLoad {
    FailureDefinitionId^ get ();
}
static member CannotMirrorHostedLoad : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresLoadFailures Class


BuiltInFailures.LoadFailures.CannotMirrorLoad Property

BuiltInFailuresLoadFailuresCannotMirrorLoad Property

Can't mirror Load because mirror plane is not perpendicular to sketch plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotMirrorLoad { get; }
Public Shared ReadOnly Property CannotMirrorLoad As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotMirrorLoad {
    FailureDefinitionId^ get ();
}
static member CannotMirrorLoad : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresLoadFailures Class


BuiltInFailures.LoadFailures.CannotMoveHostedLoad Property

BuiltInFailuresLoadFailuresCannotMoveHostedLoad Property

Can't move Load based on the Host Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotMoveHostedLoad { get; }
Public Shared ReadOnly Property CannotMoveHostedLoad As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotMoveHostedLoad {
    FailureDefinitionId^ get ();
}
static member CannotMoveHostedLoad : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresLoadFailures Class


BuiltInFailures.LoadFailures.CannotRotateLoad Property

BuiltInFailuresLoadFailuresCannotRotateLoad Property

Can't rotate Load because rotation axis is not perpendicular to sketch plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotRotateLoad { get; }
Public Shared ReadOnly Property CannotRotateLoad As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotRotateLoad {
    FailureDefinitionId^ get ();
}
static member CannotRotateLoad : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresLoadFailures Class


BuiltInFailures.LoadFailures.InvalidAreaLoadSketchError Property

BuiltInFailuresLoadFailuresInvalidAreaLoadSketchError Property

Area Load has invalid Sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidAreaLoadSketchError { get; }
Public Shared ReadOnly Property InvalidAreaLoadSketchError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidAreaLoadSketchError {
    FailureDefinitionId^ get ();
}
static member InvalidAreaLoadSketchError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresLoadFailures Class


BuiltInFailures.LoadFailures.LineLoadAllZero Property

BuiltInFailuresLoadFailuresLineLoadAllZero Property

Line Load can't have all force components and moment components to be zero.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LineLoadAllZero { get; }
Public Shared ReadOnly Property LineLoadAllZero As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LineLoadAllZero {
    FailureDefinitionId^ get ();
}
static member LineLoadAllZero : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresLoadFailures Class


BuiltInFailures.LoadFailures.LineLoadNotOverlappingHost Property

BuiltInFailuresLoadFailuresLineLoadNotOverlappingHost Property

Line load is not overlapping with its entire distribution its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LineLoadNotOverlappingHost { get; }
Public Shared ReadOnly Property LineLoadNotOverlappingHost As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LineLoadNotOverlappingHost {
    FailureDefinitionId^ get ();
}
static member LineLoadNotOverlappingHost : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresLoadFailures Class


BuiltInFailures.LoadFailures.OpenAreaLoadLoopError Property

BuiltInFailuresLoadFailuresOpenAreaLoadLoopError Property

Area Load Sketch can't contain open loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId OpenAreaLoadLoopError { get; }
Public Shared ReadOnly Property OpenAreaLoadLoopError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ OpenAreaLoadLoopError {
    FailureDefinitionId^ get ();
}
static member OpenAreaLoadLoopError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresLoadFailures Class


BuiltInFailures.LoadFailures.PointLoadAllZero Property

BuiltInFailuresLoadFailuresPointLoadAllZero Property

Point Load can't have all force components and moment components to be zero.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PointLoadAllZero { get; }
Public Shared ReadOnly Property PointLoadAllZero As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PointLoadAllZero {
    FailureDefinitionId^ get ();
}
static member PointLoadAllZero : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresLoadFailures Class


BuiltInFailures.LoadFailures.PointLoadNotOverlappingHost Property

BuiltInFailuresLoadFailuresPointLoadNotOverlappingHost Property

Point load is not overlapping with its entire distribution its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PointLoadNotOverlappingHost { get; }
Public Shared ReadOnly Property PointLoadNotOverlappingHost As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PointLoadNotOverlappingHost {
    FailureDefinitionId^ get ();
}
static member PointLoadNotOverlappingHost : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresLoadFailures Class


BuiltInFailures.LooseDimensionFailures Class

BuiltInFailuresLooseDimensionFailures Class

Failures about LooseDimension.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresLooseDimensionFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class LooseDimensionFailures
Public NotInheritable Class LooseDimensionFailures
public ref class LooseDimensionFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type LooseDimensionFailures = class end

The BuiltInFailuresLooseDimensionFailures type exposes the following members.

Properties
Name | Description
LooseCurtainWallData | Switching element type to a non-Curtain element Family type. All data about Mullions, Grid Lines, and design units for the Curtain element will be lost.
LooseDimensionsForCurtainWall | Switching wall type to Family Curtain Wall. All Dimension References to the side faces of the Wall will be deleted.
LooseFaceSplitsForCurtainWall | Switching element type to Curtain Family. All Split Face Regions in the element will be deleted.
LooseInsertsForCurtainWall | Switching element type to Curtain element. All inserts in the element will be deleted.
LooseWallsweepsForCurtainWall | Switching element type to Curtain Family. All Wall Sweeps or Reveals hosted by this instance will be deleted.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LooseDimensionFailures Properties

The BuiltInFailuresLooseDimensionFailures type exposes the following members.

Properties
Name | Description
LooseCurtainWallData | Switching element type to a non-Curtain element Family type. All data about Mullions, Grid Lines, and design units for the Curtain element will be lost.
LooseDimensionsForCurtainWall | Switching wall type to Family Curtain Wall. All Dimension References to the side faces of the Wall will be deleted.
LooseFaceSplitsForCurtainWall | Switching element type to Curtain Family. All Split Face Regions in the element will be deleted.
LooseInsertsForCurtainWall | Switching element type to Curtain element. All inserts in the element will be deleted.
LooseWallsweepsForCurtainWall | Switching element type to Curtain Family. All Wall Sweeps or Reveals hosted by this instance will be deleted.
Top
See Also

Reference

BuiltInFailuresLooseDimensionFailures Class


BuiltInFailures.LooseDimensionFailures.LooseCurtainWallData Property

BuiltInFailuresLooseDimensionFailuresLooseCurtainWallData Property

Switching element type to a non-Curtain element Family type. All data about Mullions, Grid Lines, and design units for the Curtain element will be lost.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LooseCurtainWallData { get; }
Public Shared ReadOnly Property LooseCurtainWallData As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LooseCurtainWallData {
    FailureDefinitionId^ get ();
}
static member LooseCurtainWallData : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresLooseDimensionFailures Class


BuiltInFailures.LooseDimensionFailures.LooseDimensionsForCurtainWall Property

BuiltInFailuresLooseDimensionFailuresLooseDimensionsForCurtainWall Property

Switching wall type to Family Curtain Wall. All Dimension References to the side faces of the Wall will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LooseDimensionsForCurtainWall { get; }
Public Shared ReadOnly Property LooseDimensionsForCurtainWall As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LooseDimensionsForCurtainWall {
    FailureDefinitionId^ get ();
}
static member LooseDimensionsForCurtainWall : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresLooseDimensionFailures Class


BuiltInFailures.LooseDimensionFailures.LooseFaceSplitsForCurtainWall Property

BuiltInFailuresLooseDimensionFailuresLooseFaceSplitsForCurtainWall Property

Switching element type to Curtain Family. All Split Face Regions in the element will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LooseFaceSplitsForCurtainWall { get; }
Public Shared ReadOnly Property LooseFaceSplitsForCurtainWall As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LooseFaceSplitsForCurtainWall {
    FailureDefinitionId^ get ();
}
static member LooseFaceSplitsForCurtainWall : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresLooseDimensionFailures Class


BuiltInFailures.LooseDimensionFailures.LooseInsertsForCurtainWall Property

BuiltInFailuresLooseDimensionFailuresLooseInsertsForCurtainWall Property

Switching element type to Curtain element. All inserts in the element will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LooseInsertsForCurtainWall { get; }
Public Shared ReadOnly Property LooseInsertsForCurtainWall As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LooseInsertsForCurtainWall {
    FailureDefinitionId^ get ();
}
static member LooseInsertsForCurtainWall : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresLooseDimensionFailures Class


BuiltInFailures.LooseDimensionFailures.LooseWallsweepsForCurtainWall Property

BuiltInFailuresLooseDimensionFailuresLooseWallsweepsForCurtainWall Property

Switching element type to Curtain Family. All Wall Sweeps or Reveals hosted by this instance will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LooseWallsweepsForCurtainWall { get; }
Public Shared ReadOnly Property LooseWallsweepsForCurtainWall As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LooseWallsweepsForCurtainWall {
    FailureDefinitionId^ get ();
}
static member LooseWallsweepsForCurtainWall : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresLooseDimensionFailures Class


BuiltInFailures.MacroFailures Class

BuiltInFailuresMacroFailures Class

Failures about module with duplicate name found during reload latest.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresMacroFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class MacroFailures
Public NotInheritable Class MacroFailures
public ref class MacroFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type MacroFailures = class end

The BuiltInFailuresMacroFailures type exposes the following members.

Properties
Name | Description
DuplicateModuleName | Macro project with name [MacroModuleName] duplicates with central file. Delete the macro project or re-create it with another name to proceed.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


MacroFailures Properties

The BuiltInFailuresMacroFailures type exposes the following members.

Properties
Name | Description
DuplicateModuleName | Macro project with name [MacroModuleName] duplicates with central file. Delete the macro project or re-create it with another name to proceed.
Top
See Also

Reference

BuiltInFailuresMacroFailures Class


BuiltInFailures.MacroFailures.DuplicateModuleName Property

BuiltInFailuresMacroFailuresDuplicateModuleName Property

Macro project with name [MacroModuleName] duplicates with central file. Delete the macro project or re-create it with another name to proceed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DuplicateModuleName { get; }
Public Shared ReadOnly Property DuplicateModuleName As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DuplicateModuleName {
    FailureDefinitionId^ get ();
}
static member DuplicateModuleName : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMacroFailures Class


BuiltInFailures.MassFailures Class

BuiltInFailuresMassFailures Class

Failures about Mass.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresMassFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class MassFailures
Public NotInheritable Class MassFailures
public ref class MassFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type MassFailures = class end

The BuiltInFailuresMassFailures type exposes the following members.

Properties
Name | Description
AutoGlazingFailed | Failure in Auto-Glazing region computation.
AutoGlazingFailedError | Failure in Auto-Glazing region computation.
BooleanUnionFailed | Failed to merge overlapping solids
CannotIntegrate | In order to restore an element's 'Constrain to Massing' property to 'Dependent', it must be in the main model with the massing.
CannotMergeGeometry | The Mass contains geometry that cannot be combined. Mass Floors, volume, and surface area, won't be computed.
CannotMoveMassing | Can't move whole Massing. Move the elements within the Massing instead.
CreateCoreGeometryFailed | Failed to create core geometries.
DividePerimeterZoneFailed | Failed to divide perimeter zone.
FaceRegionCreationFailed | Failure in face region creation.
FaceSplitFailed | A face of a joined (i.e. one cuts another) mass could not be split into interior and exterior faces. Remove the cut to resolve.
FloorAreaFaceFailed | Failed to create a Mass Floor.
FloorMightLookWrong | Mass Floors may appear incorrect since the Mass contains mesh and solid geometry.
FloorRecreateFailed | The floor cannot be created.
FloorRecreateFailedWarning | The floor cannot be created because no suitable level in the target document can be found.
MinSkylightWidthImperial | The minimum skylight width is 8 inches.
MinSkylightWidthMetric | The minimum skylight width is 203.2 millimeters.
MultipleMassing | Can't complete operation. Massing can only exist in one Workset. Change Workset of Massing to match in Local and Central Models.
NoCurtainRoofsInMassing | Massing cannot be created with a curtain roof. Please change the default roof type and try again.
NonOccupiableMassZone | For mass zone, if the bottom level ref does not intersect, then this zone is going to be "not occupiable" and a warning is posted for it.
NoSolidInMass | Mass contains no solid geometry. Mass Floors, volume, and surface area, won't be computed.
OpenAndSolidGeometry | Mass contains both solid and mesh geometry. Mass Floors, volume, and surface area, may appear incorrect.
OpenGeometryOnly | Mass contains only mesh geometry, which can't be used to compute Mass Floors, volume, or surface area.
OverlappingSolids | Found volumetric overlap between solids. They will be merged into one
SketchCurveNotModelable | This action cannot be completed. An element created by massing has a sketch line that cannot be modeled.
SplitFacesByGroundPlaneCrashed | Failed to split face by ground plane.
SplitFacesByGroundPlaneFailed | Failed to split face by ground plane.
SplitOverlappingFacesFailed | Failed to resolve all overlaps between faces of the same Mass Energy Analytical Model.
TooManyGeometries | The geometry in this Mass instance is too complex to take advantage of the capabilities a Mass provides. Please break it down into multiple Mass and family instances that are less complex.
UpgradedMassingWarning | Your document contained a Massing element which has been upgraded to a Mass instance. Please review the documentation on the new enhanced Mass capabilities to understand the implications of this change.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


MassFailures Properties

The BuiltInFailuresMassFailures type exposes the following members.

Properties
Name | Description
AutoGlazingFailed | Failure in Auto-Glazing region computation.
AutoGlazingFailedError | Failure in Auto-Glazing region computation.
BooleanUnionFailed | Failed to merge overlapping solids
CannotIntegrate | In order to restore an element's 'Constrain to Massing' property to 'Dependent', it must be in the main model with the massing.
CannotMergeGeometry | The Mass contains geometry that cannot be combined. Mass Floors, volume, and surface area, won't be computed.
CannotMoveMassing | Can't move whole Massing. Move the elements within the Massing instead.
CreateCoreGeometryFailed | Failed to create core geometries.
DividePerimeterZoneFailed | Failed to divide perimeter zone.
FaceRegionCreationFailed | Failure in face region creation.
FaceSplitFailed | A face of a joined (i.e. one cuts another) mass could not be split into interior and exterior faces. Remove the cut to resolve.
FloorAreaFaceFailed | Failed to create a Mass Floor.
FloorMightLookWrong | Mass Floors may appear incorrect since the Mass contains mesh and solid geometry.
FloorRecreateFailed | The floor cannot be created.
FloorRecreateFailedWarning | The floor cannot be created because no suitable level in the target document can be found.
MinSkylightWidthImperial | The minimum skylight width is 8 inches.
MinSkylightWidthMetric | The minimum skylight width is 203.2 millimeters.
MultipleMassing | Can't complete operation. Massing can only exist in one Workset. Change Workset of Massing to match in Local and Central Models.
NoCurtainRoofsInMassing | Massing cannot be created with a curtain roof. Please change the default roof type and try again.
NonOccupiableMassZone | For mass zone, if the bottom level ref does not intersect, then this zone is going to be "not occupiable" and a warning is posted for it.
NoSolidInMass | Mass contains no solid geometry. Mass Floors, volume, and surface area, won't be computed.
OpenAndSolidGeometry | Mass contains both solid and mesh geometry. Mass Floors, volume, and surface area, may appear incorrect.
OpenGeometryOnly | Mass contains only mesh geometry, which can't be used to compute Mass Floors, volume, or surface area.
OverlappingSolids | Found volumetric overlap between solids. They will be merged into one
SketchCurveNotModelable | This action cannot be completed. An element created by massing has a sketch line that cannot be modeled.
SplitFacesByGroundPlaneCrashed | Failed to split face by ground plane.
SplitFacesByGroundPlaneFailed | Failed to split face by ground plane.
SplitOverlappingFacesFailed | Failed to resolve all overlaps between faces of the same Mass Energy Analytical Model.
TooManyGeometries | The geometry in this Mass instance is too complex to take advantage of the capabilities a Mass provides. Please break it down into multiple Mass and family instances that are less complex.
UpgradedMassingWarning | Your document contained a Massing element which has been upgraded to a Mass instance. Please review the documentation on the new enhanced Mass capabilities to understand the implications of this change.
Top
See Also

Reference

BuiltInFailuresMassFailures Class


BuiltInFailures.MassFailures.AutoGlazingFailed Property

BuiltInFailuresMassFailuresAutoGlazingFailed Property

Failure in Auto-Glazing region computation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AutoGlazingFailed { get; }
Public Shared ReadOnly Property AutoGlazingFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AutoGlazingFailed {
    FailureDefinitionId^ get ();
}
static member AutoGlazingFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMassFailures Class


BuiltInFailures.MassFailures.AutoGlazingFailedError Property

BuiltInFailuresMassFailuresAutoGlazingFailedError Property

Failure in Auto-Glazing region computation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AutoGlazingFailedError { get; }
Public Shared ReadOnly Property AutoGlazingFailedError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AutoGlazingFailedError {
    FailureDefinitionId^ get ();
}
static member AutoGlazingFailedError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMassFailures Class


BuiltInFailures.MassFailures.BooleanUnionFailed Property

BuiltInFailuresMassFailuresBooleanUnionFailed Property

Failed to merge overlapping solids

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BooleanUnionFailed { get; }
Public Shared ReadOnly Property BooleanUnionFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BooleanUnionFailed {
    FailureDefinitionId^ get ();
}
static member BooleanUnionFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMassFailures Class


BuiltInFailures.MassFailures.CannotIntegrate Property

BuiltInFailuresMassFailuresCannotIntegrate Property

In order to restore an element's 'Constrain to Massing' property to 'Dependent', it must be in the main model with the massing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotIntegrate { get; }
Public Shared ReadOnly Property CannotIntegrate As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotIntegrate {
    FailureDefinitionId^ get ();
}
static member CannotIntegrate : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMassFailures Class


BuiltInFailures.MassFailures.CannotMergeGeometry Property

BuiltInFailuresMassFailuresCannotMergeGeometry Property

The Mass contains geometry that cannot be combined. Mass Floors, volume, and surface area, won't be computed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotMergeGeometry { get; }
Public Shared ReadOnly Property CannotMergeGeometry As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotMergeGeometry {
    FailureDefinitionId^ get ();
}
static member CannotMergeGeometry : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMassFailures Class


BuiltInFailures.MassFailures.CannotMoveMassing Property

BuiltInFailuresMassFailuresCannotMoveMassing Property

Can't move whole Massing. Move the elements within the Massing instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotMoveMassing { get; }
Public Shared ReadOnly Property CannotMoveMassing As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotMoveMassing {
    FailureDefinitionId^ get ();
}
static member CannotMoveMassing : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMassFailures Class


BuiltInFailures.MassFailures.CreateCoreGeometryFailed Property

BuiltInFailuresMassFailuresCreateCoreGeometryFailed Property

Failed to create core geometries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CreateCoreGeometryFailed { get; }
Public Shared ReadOnly Property CreateCoreGeometryFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CreateCoreGeometryFailed {
    FailureDefinitionId^ get ();
}
static member CreateCoreGeometryFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMassFailures Class


BuiltInFailures.MassFailures.DividePerimeterZoneFailed Property

BuiltInFailuresMassFailuresDividePerimeterZoneFailed Property

Failed to divide perimeter zone.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DividePerimeterZoneFailed { get; }
Public Shared ReadOnly Property DividePerimeterZoneFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DividePerimeterZoneFailed {
    FailureDefinitionId^ get ();
}
static member DividePerimeterZoneFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMassFailures Class


BuiltInFailures.MassFailures.FaceRegionCreationFailed Property

BuiltInFailuresMassFailuresFaceRegionCreationFailed Property

Failure in face region creation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FaceRegionCreationFailed { get; }
Public Shared ReadOnly Property FaceRegionCreationFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FaceRegionCreationFailed {
    FailureDefinitionId^ get ();
}
static member FaceRegionCreationFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMassFailures Class


BuiltInFailures.MassFailures.FaceSplitFailed Property

BuiltInFailuresMassFailuresFaceSplitFailed Property

A face of a joined (i.e. one cuts another) mass could not be split into interior and exterior faces. Remove the cut to resolve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FaceSplitFailed { get; }
Public Shared ReadOnly Property FaceSplitFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FaceSplitFailed {
    FailureDefinitionId^ get ();
}
static member FaceSplitFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMassFailures Class


BuiltInFailures.MassFailures.FloorAreaFaceFailed Property

BuiltInFailuresMassFailuresFloorAreaFaceFailed Property

Failed to create a Mass Floor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FloorAreaFaceFailed { get; }
Public Shared ReadOnly Property FloorAreaFaceFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FloorAreaFaceFailed {
    FailureDefinitionId^ get ();
}
static member FloorAreaFaceFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMassFailures Class


BuiltInFailures.MassFailures.FloorMightLookWrong Property

BuiltInFailuresMassFailuresFloorMightLookWrong Property

Mass Floors may appear incorrect since the Mass contains mesh and solid geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FloorMightLookWrong { get; }
Public Shared ReadOnly Property FloorMightLookWrong As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FloorMightLookWrong {
    FailureDefinitionId^ get ();
}
static member FloorMightLookWrong : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMassFailures Class


BuiltInFailures.MassFailures.FloorRecreateFailed Property

BuiltInFailuresMassFailuresFloorRecreateFailed Property

The floor cannot be created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FloorRecreateFailed { get; }
Public Shared ReadOnly Property FloorRecreateFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FloorRecreateFailed {
    FailureDefinitionId^ get ();
}
static member FloorRecreateFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMassFailures Class


BuiltInFailures.MassFailures.FloorRecreateFailedWarning Property

BuiltInFailuresMassFailuresFloorRecreateFailedWarning Property

The floor cannot be created because no suitable level in the target document can be found.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FloorRecreateFailedWarning { get; }
Public Shared ReadOnly Property FloorRecreateFailedWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FloorRecreateFailedWarning {
    FailureDefinitionId^ get ();
}
static member FloorRecreateFailedWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMassFailures Class


BuiltInFailures.MassFailures.MinSkylightWidthImperial Property

BuiltInFailuresMassFailuresMinSkylightWidthImperial Property

The minimum skylight width is 8 inches.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MinSkylightWidthImperial { get; }
Public Shared ReadOnly Property MinSkylightWidthImperial As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MinSkylightWidthImperial {
    FailureDefinitionId^ get ();
}
static member MinSkylightWidthImperial : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMassFailures Class


BuiltInFailures.MassFailures.MinSkylightWidthMetric Property

BuiltInFailuresMassFailuresMinSkylightWidthMetric Property

The minimum skylight width is 203.2 millimeters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MinSkylightWidthMetric { get; }
Public Shared ReadOnly Property MinSkylightWidthMetric As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MinSkylightWidthMetric {
    FailureDefinitionId^ get ();
}
static member MinSkylightWidthMetric : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMassFailures Class


BuiltInFailures.MassFailures.MultipleMassing Property

BuiltInFailuresMassFailuresMultipleMassing Property

Can't complete operation. Massing can only exist in one Workset. Change Workset of Massing to match in Local and Central Models.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MultipleMassing { get; }
Public Shared ReadOnly Property MultipleMassing As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MultipleMassing {
    FailureDefinitionId^ get ();
}
static member MultipleMassing : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMassFailures Class


BuiltInFailures.MassFailures.NoCurtainRoofsInMassing Property

BuiltInFailuresMassFailuresNoCurtainRoofsInMassing Property

Massing cannot be created with a curtain roof. Please change the default roof type and try again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoCurtainRoofsInMassing { get; }
Public Shared ReadOnly Property NoCurtainRoofsInMassing As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoCurtainRoofsInMassing {
    FailureDefinitionId^ get ();
}
static member NoCurtainRoofsInMassing : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMassFailures Class


BuiltInFailures.MassFailures.NonOccupiableMassZone Property

BuiltInFailuresMassFailuresNonOccupiableMassZone Property

For mass zone, if the bottom level ref does not intersect, then this zone is going to be "not occupiable" and a warning is posted for it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NonOccupiableMassZone { get; }
Public Shared ReadOnly Property NonOccupiableMassZone As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NonOccupiableMassZone {
    FailureDefinitionId^ get ();
}
static member NonOccupiableMassZone : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMassFailures Class


BuiltInFailures.MassFailures.NoSolidInMass Property

BuiltInFailuresMassFailuresNoSolidInMass Property

Mass contains no solid geometry. Mass Floors, volume, and surface area, won't be computed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoSolidInMass { get; }
Public Shared ReadOnly Property NoSolidInMass As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoSolidInMass {
    FailureDefinitionId^ get ();
}
static member NoSolidInMass : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMassFailures Class


BuiltInFailures.MassFailures.OpenAndSolidGeometry Property

BuiltInFailuresMassFailuresOpenAndSolidGeometry Property

Mass contains both solid and mesh geometry. Mass Floors, volume, and surface area, may appear incorrect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId OpenAndSolidGeometry { get; }
Public Shared ReadOnly Property OpenAndSolidGeometry As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ OpenAndSolidGeometry {
    FailureDefinitionId^ get ();
}
static member OpenAndSolidGeometry : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMassFailures Class


BuiltInFailures.MassFailures.OpenGeometryOnly Property

BuiltInFailuresMassFailuresOpenGeometryOnly Property

Mass contains only mesh geometry, which can't be used to compute Mass Floors, volume, or surface area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId OpenGeometryOnly { get; }
Public Shared ReadOnly Property OpenGeometryOnly As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ OpenGeometryOnly {
    FailureDefinitionId^ get ();
}
static member OpenGeometryOnly : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMassFailures Class


BuiltInFailures.MassFailures.OverlappingSolids Property

BuiltInFailuresMassFailuresOverlappingSolids Property

Found volumetric overlap between solids. They will be merged into one

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId OverlappingSolids { get; }
Public Shared ReadOnly Property OverlappingSolids As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ OverlappingSolids {
    FailureDefinitionId^ get ();
}
static member OverlappingSolids : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMassFailures Class


BuiltInFailures.MassFailures.SketchCurveNotModelable Property

BuiltInFailuresMassFailuresSketchCurveNotModelable Property

This action cannot be completed. An element created by massing has a sketch line that cannot be modeled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SketchCurveNotModelable { get; }
Public Shared ReadOnly Property SketchCurveNotModelable As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SketchCurveNotModelable {
    FailureDefinitionId^ get ();
}
static member SketchCurveNotModelable : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMassFailures Class


BuiltInFailures.MassFailures.SplitFacesByGroundPlaneCrashed Property

BuiltInFailuresMassFailuresSplitFacesByGroundPlaneCrashed Property

Failed to split face by ground plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SplitFacesByGroundPlaneCrashed { get; }
Public Shared ReadOnly Property SplitFacesByGroundPlaneCrashed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SplitFacesByGroundPlaneCrashed {
    FailureDefinitionId^ get ();
}
static member SplitFacesByGroundPlaneCrashed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMassFailures Class


BuiltInFailures.MassFailures.SplitFacesByGroundPlaneFailed Property

BuiltInFailuresMassFailuresSplitFacesByGroundPlaneFailed Property

Failed to split face by ground plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SplitFacesByGroundPlaneFailed { get; }
Public Shared ReadOnly Property SplitFacesByGroundPlaneFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SplitFacesByGroundPlaneFailed {
    FailureDefinitionId^ get ();
}
static member SplitFacesByGroundPlaneFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMassFailures Class


BuiltInFailures.MassFailures.SplitOverlappingFacesFailed Property

BuiltInFailuresMassFailuresSplitOverlappingFacesFailed Property

Failed to resolve all overlaps between faces of the same Mass Energy Analytical Model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SplitOverlappingFacesFailed { get; }
Public Shared ReadOnly Property SplitOverlappingFacesFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SplitOverlappingFacesFailed {
    FailureDefinitionId^ get ();
}
static member SplitOverlappingFacesFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMassFailures Class


BuiltInFailures.MassFailures.TooManyGeometries Property

BuiltInFailuresMassFailuresTooManyGeometries Property

The geometry in this Mass instance is too complex to take advantage of the capabilities a Mass provides. Please break it down into multiple Mass and family instances that are less complex.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TooManyGeometries { get; }
Public Shared ReadOnly Property TooManyGeometries As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TooManyGeometries {
    FailureDefinitionId^ get ();
}
static member TooManyGeometries : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMassFailures Class


BuiltInFailures.MassFailures.UpgradedMassingWarning Property

BuiltInFailuresMassFailuresUpgradedMassingWarning Property

Your document contained a Massing element which has been upgraded to a Mass instance. Please review the documentation on the new enhanced Mass capabilities to understand the implications of this change.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UpgradedMassingWarning { get; }
Public Shared ReadOnly Property UpgradedMassingWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UpgradedMassingWarning {
    FailureDefinitionId^ get ();
}
static member UpgradedMassingWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMassFailures Class


BuiltInFailures.MatchlineFailures Class

BuiltInFailuresMatchlineFailures Class

Failures about Matchline.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresMatchlineFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class MatchlineFailures
Public NotInheritable Class MatchlineFailures
public ref class MatchlineFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type MatchlineFailures = class end

The BuiltInFailuresMatchlineFailures type exposes the following members.

Properties
Name | Description
CreationFailed | Matchline top extent should be higher than its bottom.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


MatchlineFailures Properties

The BuiltInFailuresMatchlineFailures type exposes the following members.

Properties
Name | Description
CreationFailed | Matchline top extent should be higher than its bottom.
Top
See Also

Reference

BuiltInFailuresMatchlineFailures Class


BuiltInFailures.MatchlineFailures.CreationFailed Property

BuiltInFailuresMatchlineFailuresCreationFailed Property

Matchline top extent should be higher than its bottom.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CreationFailed { get; }
Public Shared ReadOnly Property CreationFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CreationFailed {
    FailureDefinitionId^ get ();
}
static member CreationFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMatchlineFailures Class


BuiltInFailures.MechanicalFailures Class

BuiltInFailuresMechanicalFailures Class

Failures about HVAC.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresMechanicalFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class MechanicalFailures
Public NotInheritable Class MechanicalFailures
public ref class MechanicalFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type MechanicalFailures = class end

The BuiltInFailuresMechanicalFailures type exposes the following members.

Properties
Name | Description
InitialEqualFrictionSizingFailed | Initial Equal Friction Sizing failed.
LiningThicknessIsLargeForDiameter | Lining Thickness ([Lining Thickness Value]) is too large for current Diameter ([Diameter Value]).
LiningThicknessIsLargeForHeight | Lining Thickness ([Lining Thickness Value]) is too large for current Height ([Height Value]).
LiningThicknessIsLargeForWidth | Lining Thickness ([Lining Thickness Value]) is too large for current Width ([Width Value]).
PanelDoesntMatchCircuitProperties | The panel no longer matches the properties for the Circuit. Disconnect the panel from the Circuit?
PanelValidateConfigurationError | More than one circuit falls onto the same slot. Disconnect the circuits from the panel?
TwoPointsSelectedBeforeEdit | Two points have to be selected before existing the edit mode.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


MechanicalFailures Properties

The BuiltInFailuresMechanicalFailures type exposes the following members.

Properties
Name | Description
InitialEqualFrictionSizingFailed | Initial Equal Friction Sizing failed.
LiningThicknessIsLargeForDiameter | Lining Thickness ([Lining Thickness Value]) is too large for current Diameter ([Diameter Value]).
LiningThicknessIsLargeForHeight | Lining Thickness ([Lining Thickness Value]) is too large for current Height ([Height Value]).
LiningThicknessIsLargeForWidth | Lining Thickness ([Lining Thickness Value]) is too large for current Width ([Width Value]).
PanelDoesntMatchCircuitProperties | The panel no longer matches the properties for the Circuit. Disconnect the panel from the Circuit?
PanelValidateConfigurationError | More than one circuit falls onto the same slot. Disconnect the circuits from the panel?
TwoPointsSelectedBeforeEdit | Two points have to be selected before existing the edit mode.
Top
See Also

Reference

BuiltInFailuresMechanicalFailures Class


BuiltInFailures.MechanicalFailures.InitialEqualFrictionSizingFailed Property

BuiltInFailuresMechanicalFailuresInitialEqualFrictionSizingFailed Property

Initial Equal Friction Sizing failed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InitialEqualFrictionSizingFailed { get; }
Public Shared ReadOnly Property InitialEqualFrictionSizingFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InitialEqualFrictionSizingFailed {
    FailureDefinitionId^ get ();
}
static member InitialEqualFrictionSizingFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMechanicalFailures Class


BuiltInFailures.MechanicalFailures.LiningThicknessIsLargeForDiameter Property

BuiltInFailuresMechanicalFailuresLiningThicknessIsLargeForDiameter Property

Lining Thickness ([Lining Thickness Value]) is too large for current Diameter ([Diameter Value]).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LiningThicknessIsLargeForDiameter { get; }
Public Shared ReadOnly Property LiningThicknessIsLargeForDiameter As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LiningThicknessIsLargeForDiameter {
    FailureDefinitionId^ get ();
}
static member LiningThicknessIsLargeForDiameter : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMechanicalFailures Class


BuiltInFailures.MechanicalFailures.LiningThicknessIsLargeForHeight Property

BuiltInFailuresMechanicalFailuresLiningThicknessIsLargeForHeight Property

Lining Thickness ([Lining Thickness Value]) is too large for current Height ([Height Value]).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LiningThicknessIsLargeForHeight { get; }
Public Shared ReadOnly Property LiningThicknessIsLargeForHeight As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LiningThicknessIsLargeForHeight {
    FailureDefinitionId^ get ();
}
static member LiningThicknessIsLargeForHeight : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMechanicalFailures Class


BuiltInFailures.MechanicalFailures.LiningThicknessIsLargeForWidth Property

BuiltInFailuresMechanicalFailuresLiningThicknessIsLargeForWidth Property

Lining Thickness ([Lining Thickness Value]) is too large for current Width ([Width Value]).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LiningThicknessIsLargeForWidth { get; }
Public Shared ReadOnly Property LiningThicknessIsLargeForWidth As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LiningThicknessIsLargeForWidth {
    FailureDefinitionId^ get ();
}
static member LiningThicknessIsLargeForWidth : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMechanicalFailures Class


BuiltInFailures.MechanicalFailures.PanelDoesntMatchCircuitProperties Property

BuiltInFailuresMechanicalFailuresPanelDoesntMatchCircuitProperties Property

The panel no longer matches the properties for the Circuit. Disconnect the panel from the Circuit?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PanelDoesntMatchCircuitProperties { get; }
Public Shared ReadOnly Property PanelDoesntMatchCircuitProperties As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PanelDoesntMatchCircuitProperties {
    FailureDefinitionId^ get ();
}
static member PanelDoesntMatchCircuitProperties : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMechanicalFailures Class


BuiltInFailures.MechanicalFailures.PanelValidateConfigurationError Property

BuiltInFailuresMechanicalFailuresPanelValidateConfigurationError Property

More than one circuit falls onto the same slot. Disconnect the circuits from the panel?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PanelValidateConfigurationError { get; }
Public Shared ReadOnly Property PanelValidateConfigurationError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PanelValidateConfigurationError {
    FailureDefinitionId^ get ();
}
static member PanelValidateConfigurationError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMechanicalFailures Class


BuiltInFailures.MechanicalFailures.TwoPointsSelectedBeforeEdit Property

BuiltInFailuresMechanicalFailuresTwoPointsSelectedBeforeEdit Property

Two points have to be selected before existing the edit mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TwoPointsSelectedBeforeEdit { get; }
Public Shared ReadOnly Property TwoPointsSelectedBeforeEdit As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TwoPointsSelectedBeforeEdit {
    FailureDefinitionId^ get ();
}
static member TwoPointsSelectedBeforeEdit : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMechanicalFailures Class


BuiltInFailures.MEPCalculationFailures Class

BuiltInFailuresMEPCalculationFailures Class

Failures about Fluid.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresMEPCalculationFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class MEPCalculationFailures
Public NotInheritable Class MEPCalculationFailures
public ref class MEPCalculationFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type MEPCalculationFailures = class end

The BuiltInFailuresMEPCalculationFailures type exposes the following members.

Properties
Name | Description
AtLeastOneEquipmentOnDuty | There should be at least one equipment on duty.
ClassificationNotSetInFamily | A calculation did not complete because the Classification parameter in the Mechanical Equipment family is not set.
DemandFlowNotSetInLossFamily | A calculation did not complete because the Demand Flow for the element is not set.
DuctFittingAndAccessoryPressureDropCalculatorNotAvailable | Duct Fitting/Accessory Pressure Drop Calculator Not Available: [Calculator Name]
DuctPressureDropCalculatorNotAvailable | Duct Pressure Drop Calculator Not Available: [Calculator Name]
ExtraPumpSet | More than one parallel pump set defined for the same loop. Verify the flow distribution and delete the extra set, if desired.
FlowAndPressureCalculationMethodHasBeenImproved | During upgrade pressure drop calculations for hydronic piping systems using Simplified Colebrook or Custom Calculation methods have been recalculated using the Colebrook equation.
HydraulicSeparationAmbiguity | Unable to hydraulically separate until the system has flow.
HydraulicSeparationOfOneSystem | Unable to hydraulically separate the loop when both supply and return are assigned to the same system. Try again with both start and end selected.
InvalidFluidProperty | Some network components may have a flow value of 0 (zero), due to invalid value settings for fluid Dynamic Viscosity or Density. \nVerify that you have selected the correct fluid type and that the fluid Dynamic Viscosity and Density values are set correctly in the Mechanical Settings dialog.
InvalidNumberOfMechanicalEquipmentOnDuty | The number of on duty equipment must be less than or equal to the number of available equipments.
LoopSeparationNotCompleted | The loop separation is not completed yet. Only one side of the secondary/tertiary loop is separated. In order to correctly calculate the flow and pressure loss, please check and separate the other end of the loop.
MechanicalEquipmentSetBeingDeleted | The mechanical equipment set was deleted because it no longer contained any members.
Network_ElementNodeIsNotPartOfNetwork | The calculation could not be executed as configured. At least one of the elements in this network uses a node that is not part of the network.
Network_NodePropertyNotSet | The calculation could not be executed as configured. Specify a constraint property set for the following input or output node(s).
Network_NoInputNode | The calculation could not be executed as configured. Select an input node before analyzing this network.
Network_NoOutputNode | The calculation could not be executed as configured. Select an output node before analyzing this network.
Network_NoPressureConstraint | The calculation could not be executed as configured. Each network requires at least 1 pressure constraint. Specify the pressure constraint.
Network_NotEnoughElements | The calculation could not be executed as configured. Specify at least 3 elements before analyzing this network.
Network_NotEnoughNodes | The calculation could not be executed as configured. Specify at least 4 elements before analyzing this network.
Network_NotFullyConnected | The network is not well connected. Some elements may have unexpected flow and pressure loss values.
Network_OverConstrained | The calculation could not be executed as configured. The Pressure and Flow Rate combined constraint requires at least 2 other pressure or flow constraints. Specify additional constraints.
NetworkCanNotDeterminCriticalPath | The calculation has completed, but there may be an error in determining the critical path. Verify that demand flow is specified for all required elements.
NetworkDefaultToPressure | The network uses the default pressure.
NetworkDefaultToReynolds | The network uses the default Reynolds number.
NetworkEnergyEquationNotConverge | The energy calculation could not be performed.
NetworkErrorCalculatingPressure | The pressure calculation could not be performed.
NetworkErrorElementWithDownUpStreamNode | The network needs an input or output element to perform the calculation.
NetworkErrorExtractCurveData | The calculation could not be performed. Verify the pump curve data.
NetworkErrorModelTooBig | The size of the network exceeds the current limit for flow/pressure analysis. In the Mechanical Settings dialog, under Pipe Settings - Calculation, disable the option to Use analysis for closed loop hydronic networks.
NetworkErrorOverConstrained | The calculation could not be performed due to overconstrained flow condition in the network.
NetworkExtraPumpOutsideSet | Flow calculations do not calculate this pump together with the other pumps as one equipment set. Verify the flow distribution and add the pump to the equipment set, if desired.
NetworkInconsistentDemandFlow | The specified flow on this equipment is inconsistent with the other equipment in this branch. The branch flow is calculated based on the maximum specified value.
NetworkMinorLossNotConverge | The minor loss calculation could not be performed.
NetworkPressureNotConverge | The calculation could not be performed. Verify the pressure on the input element.
NetworkUnderConstrained | The network is under constrained. You may specify the design flow value in the missing branches, or cap the open ends.
PipeConnectorsAreNotLined | A calculation did not complete because the connectors used by this family to connect to the network are not linked.
PipeFittingAndAccessoryPressureDropCalculatorNotAvailable | Pipe Fitting/Accessory Pressure Drop Calculator Not Available: [Calculator Name]
PipePressureDropCalculatorNotAvailable | Pipe Pressure Drop Calculator Not Available: [Calculator Name]
PlumbingFlowCalculatorNotAvailable | Plumbing Flow Calculator Not Available: [Calculator Name]
PumpPressureNotComputed | The calculated pressure drop of this pump is not computed because the critical path is not a closed loop. Check to see if there are other pumps intended for use within a secondary/tertiary loop. Use the Add Separation tool to define the secondary/tertiary loop.
SeparationNotAtJunction | This hydraulic loop is not separated at any junction. Use the Remove Separation tool to clean up undesired hydraulic separations.
SeparationWithOddJunction | Hydraulic separation requires an even number of junctions on the header pipe for accurate calculations. Add or remove junctions to complete the separation.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


MEPCalculationFailures Properties

The BuiltInFailuresMEPCalculationFailures type exposes the following members.

Properties
Name | Description
AtLeastOneEquipmentOnDuty | There should be at least one equipment on duty.
ClassificationNotSetInFamily | A calculation did not complete because the Classification parameter in the Mechanical Equipment family is not set.
DemandFlowNotSetInLossFamily | A calculation did not complete because the Demand Flow for the element is not set.
DuctFittingAndAccessoryPressureDropCalculatorNotAvailable | Duct Fitting/Accessory Pressure Drop Calculator Not Available: [Calculator Name]
DuctPressureDropCalculatorNotAvailable | Duct Pressure Drop Calculator Not Available: [Calculator Name]
ExtraPumpSet | More than one parallel pump set defined for the same loop. Verify the flow distribution and delete the extra set, if desired.
FlowAndPressureCalculationMethodHasBeenImproved | During upgrade pressure drop calculations for hydronic piping systems using Simplified Colebrook or Custom Calculation methods have been recalculated using the Colebrook equation.
HydraulicSeparationAmbiguity | Unable to hydraulically separate until the system has flow.
HydraulicSeparationOfOneSystem | Unable to hydraulically separate the loop when both supply and return are assigned to the same system. Try again with both start and end selected.
InvalidFluidProperty | Some network components may have a flow value of 0 (zero), due to invalid value settings for fluid Dynamic Viscosity or Density. \nVerify that you have selected the correct fluid type and that the fluid Dynamic Viscosity and Density values are set correctly in the Mechanical Settings dialog.
InvalidNumberOfMechanicalEquipmentOnDuty | The number of on duty equipment must be less than or equal to the number of available equipments.
LoopSeparationNotCompleted | The loop separation is not completed yet. Only one side of the secondary/tertiary loop is separated. In order to correctly calculate the flow and pressure loss, please check and separate the other end of the loop.
MechanicalEquipmentSetBeingDeleted | The mechanical equipment set was deleted because it no longer contained any members.
Network_ElementNodeIsNotPartOfNetwork | The calculation could not be executed as configured. At least one of the elements in this network uses a node that is not part of the network.
Network_NodePropertyNotSet | The calculation could not be executed as configured. Specify a constraint property set for the following input or output node(s).
Network_NoInputNode | The calculation could not be executed as configured. Select an input node before analyzing this network.
Network_NoOutputNode | The calculation could not be executed as configured. Select an output node before analyzing this network.
Network_NoPressureConstraint | The calculation could not be executed as configured. Each network requires at least 1 pressure constraint. Specify the pressure constraint.
Network_NotEnoughElements | The calculation could not be executed as configured. Specify at least 3 elements before analyzing this network.
Network_NotEnoughNodes | The calculation could not be executed as configured. Specify at least 4 elements before analyzing this network.
Network_NotFullyConnected | The network is not well connected. Some elements may have unexpected flow and pressure loss values.
Network_OverConstrained | The calculation could not be executed as configured. The Pressure and Flow Rate combined constraint requires at least 2 other pressure or flow constraints. Specify additional constraints.
NetworkCanNotDeterminCriticalPath | The calculation has completed, but there may be an error in determining the critical path. Verify that demand flow is specified for all required elements.
NetworkDefaultToPressure | The network uses the default pressure.
NetworkDefaultToReynolds | The network uses the default Reynolds number.
NetworkEnergyEquationNotConverge | The energy calculation could not be performed.
NetworkErrorCalculatingPressure | The pressure calculation could not be performed.
NetworkErrorElementWithDownUpStreamNode | The network needs an input or output element to perform the calculation.
NetworkErrorExtractCurveData | The calculation could not be performed. Verify the pump curve data.
NetworkErrorModelTooBig | The size of the network exceeds the current limit for flow/pressure analysis. In the Mechanical Settings dialog, under Pipe Settings - Calculation, disable the option to Use analysis for closed loop hydronic networks.
NetworkErrorOverConstrained | The calculation could not be performed due to overconstrained flow condition in the network.
NetworkExtraPumpOutsideSet | Flow calculations do not calculate this pump together with the other pumps as one equipment set. Verify the flow distribution and add the pump to the equipment set, if desired.
NetworkInconsistentDemandFlow | The specified flow on this equipment is inconsistent with the other equipment in this branch. The branch flow is calculated based on the maximum specified value.
NetworkMinorLossNotConverge | The minor loss calculation could not be performed.
NetworkPressureNotConverge | The calculation could not be performed. Verify the pressure on the input element.
NetworkUnderConstrained | The network is under constrained. You may specify the design flow value in the missing branches, or cap the open ends.
PipeConnectorsAreNotLined | A calculation did not complete because the connectors used by this family to connect to the network are not linked.
PipeFittingAndAccessoryPressureDropCalculatorNotAvailable | Pipe Fitting/Accessory Pressure Drop Calculator Not Available: [Calculator Name]
PipePressureDropCalculatorNotAvailable | Pipe Pressure Drop Calculator Not Available: [Calculator Name]
PlumbingFlowCalculatorNotAvailable | Plumbing Flow Calculator Not Available: [Calculator Name]
PumpPressureNotComputed | The calculated pressure drop of this pump is not computed because the critical path is not a closed loop. Check to see if there are other pumps intended for use within a secondary/tertiary loop. Use the Add Separation tool to define the secondary/tertiary loop.
SeparationNotAtJunction | This hydraulic loop is not separated at any junction. Use the Remove Separation tool to clean up undesired hydraulic separations.
SeparationWithOddJunction | Hydraulic separation requires an even number of junctions on the header pipe for accurate calculations. Add or remove junctions to complete the separation.
Top
See Also

Reference

BuiltInFailuresMEPCalculationFailures Class


BuiltInFailures.MEPCalculationFailures.AtLeastOneEquipmentOnDuty Property

BuiltInFailuresMEPCalculationFailuresAtLeastOneEquipmentOnDuty Property

There should be at least one equipment on duty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AtLeastOneEquipmentOnDuty { get; }
Public Shared ReadOnly Property AtLeastOneEquipmentOnDuty As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AtLeastOneEquipmentOnDuty {
    FailureDefinitionId^ get ();
}
static member AtLeastOneEquipmentOnDuty : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPCalculationFailures Class


BuiltInFailures.MEPCalculationFailures.ClassificationNotSetInFamily Property

BuiltInFailuresMEPCalculationFailuresClassificationNotSetInFamily Property

A calculation did not complete because the Classification parameter in the Mechanical Equipment family is not set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ClassificationNotSetInFamily { get; }
Public Shared ReadOnly Property ClassificationNotSetInFamily As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ClassificationNotSetInFamily {
    FailureDefinitionId^ get ();
}
static member ClassificationNotSetInFamily : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPCalculationFailures Class


BuiltInFailures.MEPCalculationFailures.DemandFlowNotSetInLossFamily Property

BuiltInFailuresMEPCalculationFailuresDemandFlowNotSetInLossFamily Property

A calculation did not complete because the Demand Flow for the element is not set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DemandFlowNotSetInLossFamily { get; }
Public Shared ReadOnly Property DemandFlowNotSetInLossFamily As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DemandFlowNotSetInLossFamily {
    FailureDefinitionId^ get ();
}
static member DemandFlowNotSetInLossFamily : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPCalculationFailures Class


BuiltInFailures.MEPCalculationFailures.DuctFittingAndAccessoryPressureDropCalculatorNotAvailable Property

BuiltInFailuresMEPCalculationFailuresDuctFittingAndAccessoryPressureDropCalculatorNotAvailable Property

Duct Fitting/Accessory Pressure Drop Calculator Not Available: [Calculator Name]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DuctFittingAndAccessoryPressureDropCalculatorNotAvailable { get; }
Public Shared ReadOnly Property DuctFittingAndAccessoryPressureDropCalculatorNotAvailable As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DuctFittingAndAccessoryPressureDropCalculatorNotAvailable {
    FailureDefinitionId^ get ();
}
static member DuctFittingAndAccessoryPressureDropCalculatorNotAvailable : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPCalculationFailures Class


BuiltInFailures.MEPCalculationFailures.DuctPressureDropCalculatorNotAvailable Property

BuiltInFailuresMEPCalculationFailuresDuctPressureDropCalculatorNotAvailable Property

Duct Pressure Drop Calculator Not Available: [Calculator Name]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DuctPressureDropCalculatorNotAvailable { get; }
Public Shared ReadOnly Property DuctPressureDropCalculatorNotAvailable As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DuctPressureDropCalculatorNotAvailable {
    FailureDefinitionId^ get ();
}
static member DuctPressureDropCalculatorNotAvailable : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPCalculationFailures Class


BuiltInFailures.MEPCalculationFailures.ExtraPumpSet Property

BuiltInFailuresMEPCalculationFailuresExtraPumpSet Property

More than one parallel pump set defined for the same loop. Verify the flow distribution and delete the extra set, if desired.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ExtraPumpSet { get; }
Public Shared ReadOnly Property ExtraPumpSet As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ExtraPumpSet {
    FailureDefinitionId^ get ();
}
static member ExtraPumpSet : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPCalculationFailures Class


BuiltInFailures.MEPCalculationFailures.FlowAndPressureCalculationMethodHasBeenImproved Property

BuiltInFailuresMEPCalculationFailuresFlowAndPressureCalculationMethodHasBeenImproved Property

During upgrade pressure drop calculations for hydronic piping systems using Simplified Colebrook or Custom Calculation methods have been recalculated using the Colebrook equation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FlowAndPressureCalculationMethodHasBeenImproved { get; }
Public Shared ReadOnly Property FlowAndPressureCalculationMethodHasBeenImproved As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FlowAndPressureCalculationMethodHasBeenImproved {
    FailureDefinitionId^ get ();
}
static member FlowAndPressureCalculationMethodHasBeenImproved : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPCalculationFailures Class


BuiltInFailures.MEPCalculationFailures.HydraulicSeparationAmbiguity Property

BuiltInFailuresMEPCalculationFailuresHydraulicSeparationAmbiguity Property

Unable to hydraulically separate until the system has flow.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId HydraulicSeparationAmbiguity { get; }
Public Shared ReadOnly Property HydraulicSeparationAmbiguity As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ HydraulicSeparationAmbiguity {
    FailureDefinitionId^ get ();
}
static member HydraulicSeparationAmbiguity : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPCalculationFailures Class


BuiltInFailures.MEPCalculationFailures.HydraulicSeparationOfOneSystem Property

BuiltInFailuresMEPCalculationFailuresHydraulicSeparationOfOneSystem Property

Unable to hydraulically separate the loop when both supply and return are assigned to the same system. Try again with both start and end selected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId HydraulicSeparationOfOneSystem { get; }
Public Shared ReadOnly Property HydraulicSeparationOfOneSystem As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ HydraulicSeparationOfOneSystem {
    FailureDefinitionId^ get ();
}
static member HydraulicSeparationOfOneSystem : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPCalculationFailures Class


BuiltInFailures.MEPCalculationFailures.InvalidFluidProperty Property

BuiltInFailuresMEPCalculationFailuresInvalidFluidProperty Property

Some network components may have a flow value of 0 (zero), due to invalid value settings for fluid Dynamic Viscosity or Density. \nVerify that you have selected the correct fluid type and that the fluid Dynamic Viscosity and Density values are set correctly in the Mechanical Settings dialog.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidFluidProperty { get; }
Public Shared ReadOnly Property InvalidFluidProperty As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidFluidProperty {
    FailureDefinitionId^ get ();
}
static member InvalidFluidProperty : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPCalculationFailures Class


BuiltInFailures.MEPCalculationFailures.InvalidNumberOfMechanicalEquipmentOnDuty Property

BuiltInFailuresMEPCalculationFailuresInvalidNumberOfMechanicalEquipmentOnDuty Property

The number of on duty equipment must be less than or equal to the number of available equipments.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidNumberOfMechanicalEquipmentOnDuty { get; }
Public Shared ReadOnly Property InvalidNumberOfMechanicalEquipmentOnDuty As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidNumberOfMechanicalEquipmentOnDuty {
    FailureDefinitionId^ get ();
}
static member InvalidNumberOfMechanicalEquipmentOnDuty : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPCalculationFailures Class


BuiltInFailures.MEPCalculationFailures.LoopSeparationNotCompleted Property

BuiltInFailuresMEPCalculationFailuresLoopSeparationNotCompleted Property

The loop separation is not completed yet. Only one side of the secondary/tertiary loop is separated. In order to correctly calculate the flow and pressure loss, please check and separate the other end of the loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LoopSeparationNotCompleted { get; }
Public Shared ReadOnly Property LoopSeparationNotCompleted As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LoopSeparationNotCompleted {
    FailureDefinitionId^ get ();
}
static member LoopSeparationNotCompleted : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPCalculationFailures Class


BuiltInFailures.MEPCalculationFailures.MechanicalEquipmentSetBeingDeleted Property

BuiltInFailuresMEPCalculationFailuresMechanicalEquipmentSetBeingDeleted Property

The mechanical equipment set was deleted because it no longer contained any members.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MechanicalEquipmentSetBeingDeleted { get; }
Public Shared ReadOnly Property MechanicalEquipmentSetBeingDeleted As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MechanicalEquipmentSetBeingDeleted {
    FailureDefinitionId^ get ();
}
static member MechanicalEquipmentSetBeingDeleted : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPCalculationFailures Class


BuiltInFailures.MEPCalculationFailures.Network_ElementNodeIsNotPartOfNetwork Property

BuiltInFailuresMEPCalculationFailuresNetwork_ElementNodeIsNotPartOfNetwork Property

The calculation could not be executed as configured. At least one of the elements in this network uses a node that is not part of the network.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId Network_ElementNodeIsNotPartOfNetwork { get; }
Public Shared ReadOnly Property Network_ElementNodeIsNotPartOfNetwork As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ Network_ElementNodeIsNotPartOfNetwork {
    FailureDefinitionId^ get ();
}
static member Network_ElementNodeIsNotPartOfNetwork : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPCalculationFailures Class


BuiltInFailures.MEPCalculationFailures.Network_NodePropertyNotSet Property

BuiltInFailuresMEPCalculationFailuresNetwork_NodePropertyNotSet Property

The calculation could not be executed as configured. Specify a constraint property set for the following input or output node(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId Network_NodePropertyNotSet { get; }
Public Shared ReadOnly Property Network_NodePropertyNotSet As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ Network_NodePropertyNotSet {
    FailureDefinitionId^ get ();
}
static member Network_NodePropertyNotSet : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPCalculationFailures Class


BuiltInFailures.MEPCalculationFailures.Network_NoInputNode Property

BuiltInFailuresMEPCalculationFailuresNetwork_NoInputNode Property

The calculation could not be executed as configured. Select an input node before analyzing this network.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId Network_NoInputNode { get; }
Public Shared ReadOnly Property Network_NoInputNode As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ Network_NoInputNode {
    FailureDefinitionId^ get ();
}
static member Network_NoInputNode : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPCalculationFailures Class


BuiltInFailures.MEPCalculationFailures.Network_NoOutputNode Property

BuiltInFailuresMEPCalculationFailuresNetwork_NoOutputNode Property

The calculation could not be executed as configured. Select an output node before analyzing this network.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId Network_NoOutputNode { get; }
Public Shared ReadOnly Property Network_NoOutputNode As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ Network_NoOutputNode {
    FailureDefinitionId^ get ();
}
static member Network_NoOutputNode : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPCalculationFailures Class


BuiltInFailures.MEPCalculationFailures.Network_NoPressureConstraint Property

BuiltInFailuresMEPCalculationFailuresNetwork_NoPressureConstraint Property

The calculation could not be executed as configured. Each network requires at least 1 pressure constraint. Specify the pressure constraint.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId Network_NoPressureConstraint { get; }
Public Shared ReadOnly Property Network_NoPressureConstraint As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ Network_NoPressureConstraint {
    FailureDefinitionId^ get ();
}
static member Network_NoPressureConstraint : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPCalculationFailures Class


BuiltInFailures.MEPCalculationFailures.Network_NotEnoughElements Property

BuiltInFailuresMEPCalculationFailuresNetwork_NotEnoughElements Property

The calculation could not be executed as configured. Specify at least 3 elements before analyzing this network.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId Network_NotEnoughElements { get; }
Public Shared ReadOnly Property Network_NotEnoughElements As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ Network_NotEnoughElements {
    FailureDefinitionId^ get ();
}
static member Network_NotEnoughElements : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPCalculationFailures Class


BuiltInFailures.MEPCalculationFailures.Network_NotEnoughNodes Property

BuiltInFailuresMEPCalculationFailuresNetwork_NotEnoughNodes Property

The calculation could not be executed as configured. Specify at least 4 elements before analyzing this network.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId Network_NotEnoughNodes { get; }
Public Shared ReadOnly Property Network_NotEnoughNodes As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ Network_NotEnoughNodes {
    FailureDefinitionId^ get ();
}
static member Network_NotEnoughNodes : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPCalculationFailures Class


BuiltInFailures.MEPCalculationFailures.Network_NotFullyConnected Property

BuiltInFailuresMEPCalculationFailuresNetwork_NotFullyConnected Property

The network is not well connected. Some elements may have unexpected flow and pressure loss values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId Network_NotFullyConnected { get; }
Public Shared ReadOnly Property Network_NotFullyConnected As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ Network_NotFullyConnected {
    FailureDefinitionId^ get ();
}
static member Network_NotFullyConnected : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPCalculationFailures Class


BuiltInFailures.MEPCalculationFailures.Network_OverConstrained Property

BuiltInFailuresMEPCalculationFailuresNetwork_OverConstrained Property

The calculation could not be executed as configured. The Pressure and Flow Rate combined constraint requires at least 2 other pressure or flow constraints. Specify additional constraints.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId Network_OverConstrained { get; }
Public Shared ReadOnly Property Network_OverConstrained As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ Network_OverConstrained {
    FailureDefinitionId^ get ();
}
static member Network_OverConstrained : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPCalculationFailures Class


BuiltInFailures.MEPCalculationFailures.NetworkCanNotDeterminCriticalPath Property

BuiltInFailuresMEPCalculationFailuresNetworkCanNotDeterminCriticalPath Property

The calculation has completed, but there may be an error in determining the critical path. Verify that demand flow is specified for all required elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NetworkCanNotDeterminCriticalPath { get; }
Public Shared ReadOnly Property NetworkCanNotDeterminCriticalPath As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NetworkCanNotDeterminCriticalPath {
    FailureDefinitionId^ get ();
}
static member NetworkCanNotDeterminCriticalPath : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPCalculationFailures Class


BuiltInFailures.MEPCalculationFailures.NetworkDefaultToPressure Property

BuiltInFailuresMEPCalculationFailuresNetworkDefaultToPressure Property

The network uses the default pressure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NetworkDefaultToPressure { get; }
Public Shared ReadOnly Property NetworkDefaultToPressure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NetworkDefaultToPressure {
    FailureDefinitionId^ get ();
}
static member NetworkDefaultToPressure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPCalculationFailures Class


BuiltInFailures.MEPCalculationFailures.NetworkDefaultToReynolds Property

BuiltInFailuresMEPCalculationFailuresNetworkDefaultToReynolds Property

The network uses the default Reynolds number.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NetworkDefaultToReynolds { get; }
Public Shared ReadOnly Property NetworkDefaultToReynolds As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NetworkDefaultToReynolds {
    FailureDefinitionId^ get ();
}
static member NetworkDefaultToReynolds : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPCalculationFailures Class


BuiltInFailures.MEPCalculationFailures.NetworkEnergyEquationNotConverge Property

BuiltInFailuresMEPCalculationFailuresNetworkEnergyEquationNotConverge Property

The energy calculation could not be performed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NetworkEnergyEquationNotConverge { get; }
Public Shared ReadOnly Property NetworkEnergyEquationNotConverge As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NetworkEnergyEquationNotConverge {
    FailureDefinitionId^ get ();
}
static member NetworkEnergyEquationNotConverge : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPCalculationFailures Class


BuiltInFailures.MEPCalculationFailures.NetworkErrorCalculatingPressure Property

BuiltInFailuresMEPCalculationFailuresNetworkErrorCalculatingPressure Property

The pressure calculation could not be performed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NetworkErrorCalculatingPressure { get; }
Public Shared ReadOnly Property NetworkErrorCalculatingPressure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NetworkErrorCalculatingPressure {
    FailureDefinitionId^ get ();
}
static member NetworkErrorCalculatingPressure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPCalculationFailures Class


BuiltInFailures.MEPCalculationFailures.NetworkErrorElementWithDownUpStreamNode Property

BuiltInFailuresMEPCalculationFailuresNetworkErrorElementWithDownUpStreamNode Property

The network needs an input or output element to perform the calculation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NetworkErrorElementWithDownUpStreamNode { get; }
Public Shared ReadOnly Property NetworkErrorElementWithDownUpStreamNode As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NetworkErrorElementWithDownUpStreamNode {
    FailureDefinitionId^ get ();
}
static member NetworkErrorElementWithDownUpStreamNode : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPCalculationFailures Class


BuiltInFailures.MEPCalculationFailures.NetworkErrorExtractCurveData Property

BuiltInFailuresMEPCalculationFailuresNetworkErrorExtractCurveData Property

The calculation could not be performed. Verify the pump curve data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NetworkErrorExtractCurveData { get; }
Public Shared ReadOnly Property NetworkErrorExtractCurveData As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NetworkErrorExtractCurveData {
    FailureDefinitionId^ get ();
}
static member NetworkErrorExtractCurveData : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPCalculationFailures Class


BuiltInFailures.MEPCalculationFailures.NetworkErrorModelTooBig Property

BuiltInFailuresMEPCalculationFailuresNetworkErrorModelTooBig Property

The size of the network exceeds the current limit for flow/pressure analysis. In the Mechanical Settings dialog, under Pipe Settings - Calculation, disable the option to Use analysis for closed loop hydronic networks.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NetworkErrorModelTooBig { get; }
Public Shared ReadOnly Property NetworkErrorModelTooBig As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NetworkErrorModelTooBig {
    FailureDefinitionId^ get ();
}
static member NetworkErrorModelTooBig : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPCalculationFailures Class


BuiltInFailures.MEPCalculationFailures.NetworkErrorOverConstrained Property

BuiltInFailuresMEPCalculationFailuresNetworkErrorOverConstrained Property

The calculation could not be performed due to overconstrained flow condition in the network.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NetworkErrorOverConstrained { get; }
Public Shared ReadOnly Property NetworkErrorOverConstrained As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NetworkErrorOverConstrained {
    FailureDefinitionId^ get ();
}
static member NetworkErrorOverConstrained : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPCalculationFailures Class


BuiltInFailures.MEPCalculationFailures.NetworkExtraPumpOutsideSet Property

BuiltInFailuresMEPCalculationFailuresNetworkExtraPumpOutsideSet Property

Flow calculations do not calculate this pump together with the other pumps as one equipment set. Verify the flow distribution and add the pump to the equipment set, if desired.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NetworkExtraPumpOutsideSet { get; }
Public Shared ReadOnly Property NetworkExtraPumpOutsideSet As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NetworkExtraPumpOutsideSet {
    FailureDefinitionId^ get ();
}
static member NetworkExtraPumpOutsideSet : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPCalculationFailures Class


BuiltInFailures.MEPCalculationFailures.NetworkInconsistentDemandFlow Property

BuiltInFailuresMEPCalculationFailuresNetworkInconsistentDemandFlow Property

The specified flow on this equipment is inconsistent with the other equipment in this branch. The branch flow is calculated based on the maximum specified value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NetworkInconsistentDemandFlow { get; }
Public Shared ReadOnly Property NetworkInconsistentDemandFlow As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NetworkInconsistentDemandFlow {
    FailureDefinitionId^ get ();
}
static member NetworkInconsistentDemandFlow : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPCalculationFailures Class


BuiltInFailures.MEPCalculationFailures.NetworkMinorLossNotConverge Property

BuiltInFailuresMEPCalculationFailuresNetworkMinorLossNotConverge Property

The minor loss calculation could not be performed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NetworkMinorLossNotConverge { get; }
Public Shared ReadOnly Property NetworkMinorLossNotConverge As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NetworkMinorLossNotConverge {
    FailureDefinitionId^ get ();
}
static member NetworkMinorLossNotConverge : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPCalculationFailures Class


BuiltInFailures.MEPCalculationFailures.NetworkPressureNotConverge Property

BuiltInFailuresMEPCalculationFailuresNetworkPressureNotConverge Property

The calculation could not be performed. Verify the pressure on the input element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NetworkPressureNotConverge { get; }
Public Shared ReadOnly Property NetworkPressureNotConverge As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NetworkPressureNotConverge {
    FailureDefinitionId^ get ();
}
static member NetworkPressureNotConverge : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPCalculationFailures Class


BuiltInFailures.MEPCalculationFailures.NetworkUnderConstrained Property

BuiltInFailuresMEPCalculationFailuresNetworkUnderConstrained Property

The network is under constrained. You may specify the design flow value in the missing branches, or cap the open ends.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NetworkUnderConstrained { get; }
Public Shared ReadOnly Property NetworkUnderConstrained As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NetworkUnderConstrained {
    FailureDefinitionId^ get ();
}
static member NetworkUnderConstrained : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPCalculationFailures Class


BuiltInFailures.MEPCalculationFailures.PipeConnectorsAreNotLined Property

BuiltInFailuresMEPCalculationFailuresPipeConnectorsAreNotLined Property

A calculation did not complete because the connectors used by this family to connect to the network are not linked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PipeConnectorsAreNotLined { get; }
Public Shared ReadOnly Property PipeConnectorsAreNotLined As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PipeConnectorsAreNotLined {
    FailureDefinitionId^ get ();
}
static member PipeConnectorsAreNotLined : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPCalculationFailures Class


BuiltInFailures.MEPCalculationFailures.PipeFittingAndAccessoryPressureDropCalculatorNotAvailable Property

BuiltInFailuresMEPCalculationFailuresPipeFittingAndAccessoryPressureDropCalculatorNotAvailable Property

Pipe Fitting/Accessory Pressure Drop Calculator Not Available: [Calculator Name]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PipeFittingAndAccessoryPressureDropCalculatorNotAvailable { get; }
Public Shared ReadOnly Property PipeFittingAndAccessoryPressureDropCalculatorNotAvailable As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PipeFittingAndAccessoryPressureDropCalculatorNotAvailable {
    FailureDefinitionId^ get ();
}
static member PipeFittingAndAccessoryPressureDropCalculatorNotAvailable : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPCalculationFailures Class


BuiltInFailures.MEPCalculationFailures.PipePressureDropCalculatorNotAvailable Property

BuiltInFailuresMEPCalculationFailuresPipePressureDropCalculatorNotAvailable Property

Pipe Pressure Drop Calculator Not Available: [Calculator Name]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PipePressureDropCalculatorNotAvailable { get; }
Public Shared ReadOnly Property PipePressureDropCalculatorNotAvailable As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PipePressureDropCalculatorNotAvailable {
    FailureDefinitionId^ get ();
}
static member PipePressureDropCalculatorNotAvailable : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPCalculationFailures Class


BuiltInFailures.MEPCalculationFailures.PlumbingFlowCalculatorNotAvailable Property

BuiltInFailuresMEPCalculationFailuresPlumbingFlowCalculatorNotAvailable Property

Plumbing Flow Calculator Not Available: [Calculator Name]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PlumbingFlowCalculatorNotAvailable { get; }
Public Shared ReadOnly Property PlumbingFlowCalculatorNotAvailable As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PlumbingFlowCalculatorNotAvailable {
    FailureDefinitionId^ get ();
}
static member PlumbingFlowCalculatorNotAvailable : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPCalculationFailures Class


BuiltInFailures.MEPCalculationFailures.PumpPressureNotComputed Property

BuiltInFailuresMEPCalculationFailuresPumpPressureNotComputed Property

The calculated pressure drop of this pump is not computed because the critical path is not a closed loop. Check to see if there are other pumps intended for use within a secondary/tertiary loop. Use the Add Separation tool to define the secondary/tertiary loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PumpPressureNotComputed { get; }
Public Shared ReadOnly Property PumpPressureNotComputed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PumpPressureNotComputed {
    FailureDefinitionId^ get ();
}
static member PumpPressureNotComputed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPCalculationFailures Class


BuiltInFailures.MEPCalculationFailures.SeparationNotAtJunction Property

BuiltInFailuresMEPCalculationFailuresSeparationNotAtJunction Property

This hydraulic loop is not separated at any junction. Use the Remove Separation tool to clean up undesired hydraulic separations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SeparationNotAtJunction { get; }
Public Shared ReadOnly Property SeparationNotAtJunction As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SeparationNotAtJunction {
    FailureDefinitionId^ get ();
}
static member SeparationNotAtJunction : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPCalculationFailures Class


BuiltInFailures.MEPCalculationFailures.SeparationWithOddJunction Property

BuiltInFailuresMEPCalculationFailuresSeparationWithOddJunction Property

Hydraulic separation requires an even number of junctions on the header pipe for accurate calculations. Add or remove junctions to complete the separation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SeparationWithOddJunction { get; }
Public Shared ReadOnly Property SeparationWithOddJunction As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SeparationWithOddJunction {
    FailureDefinitionId^ get ();
}
static member SeparationWithOddJunction : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPCalculationFailures Class


BuiltInFailures.MEPFabricationFailures Class

BuiltInFailuresMEPFabricationFailures Class

Failures about MEP fabrication.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresMEPFabricationFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class MEPFabricationFailures
Public NotInheritable Class MEPFabricationFailures
public ref class MEPFabricationFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type MEPFabricationFailures = class end

The BuiltInFailuresMEPFabricationFailures type exposes the following members.

Properties
Name | Description
AdditionalPartNotLoaded | An additional part was not loaded.
CannotConvertFlexPipeToPart | Cannot convert flex pipe to fabrication part.
CannotMatchFabricationHangerSizeToHost | The hanger cannot be re-sized to match the re-sized host.
FabDbChangeConn | Fabrication Database changes altered connectivity
FabDbOpenJobConn | Fabrication job imported had bad connectivity
FabDbSwapOut | Fabrication Database reload could not swap out for newer parts.
FabricationConfigurationCorrupted | It looks that the Fabrication Configuration %1!s! was corrupted, please check it at %2!s!.
FabricationHangerCannotBeSloped | A hanger cannot be sloped or placed on a sloped element.
FabricationHangerHostNotFound | The hanger will disconnect because we can't find the suitable host.
FabricationHangerNotConnectToHost | Fabrication Hanger didn't connect to the %s host.
FabricationHangerOutOfHost | The hanger is out of its host and will be disconnected.
FabricationHangerSizeNotMatch | The hanger size does not match the size of the host, so it can not be connected.
FabricationOutOfSizeCondition | The fabrication part size is not within the correct size range for the service button condition.
FabricationOverSizedCheck | Fabrication part is too large to fit on the sheet metal. Replace the part with multiple smaller parts, or notify the CAM operator.
FabricationPartBadConnectionAlignmentWarning | The connection invalid due to the connector are not aligned and/or this is a gap between the connectors.
FabricationPartBadConnectionConnectivityWarning | The connection invalid due to connection types associated to the connectors are not compatible.
FabricationPartBadConnectionSizeWarning | The connection invalid due to connectors sizes are not the same.
FabricationPartCannotBeMirrored |
FabricationPartCannotChangeServiceSizeWarning | The selected fitting(s) cannot successfully change service or change size. You must disconnect the connections on the fitting(s) and try again.
FabricationPartCannotChangeSlopeError | The connected fitting(s) cannot successfully change to the new slope value. You may try to disconnect the connections on the fitting(s) and try again.
FabricationPartCannotChangeTypeBadDimError | The selected fitting(s) cannot successfully change the type. The newly selected fabrication part may have badly configured dimensions or be constrained due to connected fitting(s). You may try to disconnect the connections on the fitting(s) and try again.
FabricationPartCannotChangeTypeBadDimUnConnError | The selected fitting(s) cannot successfully change the type. The newly selected fabrication part may have badly configured dimensions, resulting in bad geometry.
FabricationPartCannotChangeTypeError | The selected fitting(s) cannot successfully change the type. You must disconnect the connections on the fitting(s) and try again.
FabricationPartCannotChangeTypeIncompatError | The selected fitting(s) cannot successfully change the type. The newly selected fabrication part type either has no material or has badly configured dimensions, resulting in bad geometry. You may try to disconnect the connections on the fitting(s) and try again.
FabricationPartCannotChangeTypeIncompatUnConnError | The selected fitting(s) cannot successfully change the type. The newly selected fabrication part type either has no material or has badly configured dimensions, resulting in bad geometry.
FabricationPartCannotChangeTypeMisalignedError | The selected fitting(s) cannot successfully change the type. The newly selected fabrication part type has a problem with the angle dimension of the current fitting(s), resulting in bad geometry. You may try to disconnect the connections on the fitting(s) and try again.
FabricationPartCannotChangeTypeMisalignedUnConnError | The selected fitting(s) cannot successfully change the type. The newly selected fabrication part type has a problem with the angle dimension of the current fitting(s), resulting in bad geometry.
FabricationPartCannotChangeTypeUnConnError | The selected fitting(s) cannot successfully change the type.
FabricationPartCannotChangeTypeWarning | The selected fitting(s) cannot maintain connections to existing fabrication parts due to size, direction or angle differences. You must manually reconnect the open connections.
FabricationPartExceededAngleFlexToleranceWarning | The angle flex is greater than the maximum angle flex tolerance defined by the fabrication part. Connections with this part may not be properly aligned and may appear to be skewed.
FabricationPartExcludedPartWarning | There were fabrication parts needed to the make the connection that were excluded from the fabrication service causing the connection to fail. You may try to inlcude these fitting(s) and try again.
FabricationPartFitFailure | Fabrication Part Fitting Failed to Fit
FabricationPartFitFailWarning | Fabrication Part Fitting Failed to Fit
FabricationPartHasInvalidGeometry | The fabrication part either has no material or has badly configured dimensions, resulting in bad geometry.
FabricationPartInvalidConnection | Fabrication Part connection invalid and could not be automatically coupled.
FabricationPartInvalidSpecification | The part specification is invalid.
FabricationPartNoPartTypeFound | There are no fabrication part types found for the current Configuration and Service. Please select settings and reload the service to create the fabrication part types.
FabricationPartNotAttachedToStraight | The part must be attached to straight.
FabricationPartOptimizeInvalidConnection | No available couplings to connect standard lengths for this instance of straight.
FabricationRodDetachFromHangerError | The rod need to be detached from hanger.
FabricationRodsConnectionChangedWarning | The structural component that the hanger is attached to has changed to a different element.
FabricationRodsDisconnectedError | The hanger rod was disconnected because there is no structural component above.
FabricationRodsDisconnectedWarning | The hanger rod was disconnected because there is no structural component above.
FabricationServiceMismatch | Attempting to connect fabrication parts from different services.
FabricationStraigtLengthOversized | Fabrication straight exceeds the standard length. Use the Optimize Length command to adjust the length.
FixedFabricationPartNotChangeLength | Failed to change length of fixed part.
GroupedFabricationPartNotReposition | Failed to reposition part.
HangerProfileNotMatchWithHost | The defined hanger profile does not match with the host.
HangerWidthOutOfRange | The hanger width is too large to show.
InvalidConnectionsHaveBeenDisconnected | Invalid connections have been disconnected. Please reconnect them manually or use different fittings.
InvalidSelectionThereCannotBeOpenConnectors | Invalid selection there cannot be any open connectors for the design to fabrication part tool.
NoStructuralHostToAttachWarning | There is no structural component to attach the hanger rod to.
NotAllPartsWereConvertedUnsuportedFittingOffsets | Not all parts were converted. Eccentric transitions and taps that have offsets from the center line are unsupported and cannot be converted.
PinnedFabricationPartNotChangeExtension | Failed to change extension of part.
PinnedFabricationPartNotReposition | Failed to reposition part.
PlaceCutinFittingFailed | Failed to insert part.
SizeNotAvailableInFabricationService | Sizes:%1!s! in system %2!s! are not available in fabrication service:%3!s!, All available sizes are:\n%4!s!.
UneditableFabricationPartNotReposition | Failed to reposition part.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


MEPFabricationFailures Properties

The BuiltInFailuresMEPFabricationFailures type exposes the following members.

Properties
Name | Description
AdditionalPartNotLoaded | An additional part was not loaded.
CannotConvertFlexPipeToPart | Cannot convert flex pipe to fabrication part.
CannotMatchFabricationHangerSizeToHost | The hanger cannot be re-sized to match the re-sized host.
FabDbChangeConn | Fabrication Database changes altered connectivity
FabDbOpenJobConn | Fabrication job imported had bad connectivity
FabDbSwapOut | Fabrication Database reload could not swap out for newer parts.
FabricationConfigurationCorrupted | It looks that the Fabrication Configuration %1!s! was corrupted, please check it at %2!s!.
FabricationHangerCannotBeSloped | A hanger cannot be sloped or placed on a sloped element.
FabricationHangerHostNotFound | The hanger will disconnect because we can't find the suitable host.
FabricationHangerNotConnectToHost | Fabrication Hanger didn't connect to the %s host.
FabricationHangerOutOfHost | The hanger is out of its host and will be disconnected.
FabricationHangerSizeNotMatch | The hanger size does not match the size of the host, so it can not be connected.
FabricationOutOfSizeCondition | The fabrication part size is not within the correct size range for the service button condition.
FabricationOverSizedCheck | Fabrication part is too large to fit on the sheet metal. Replace the part with multiple smaller parts, or notify the CAM operator.
FabricationPartBadConnectionAlignmentWarning | The connection invalid due to the connector are not aligned and/or this is a gap between the connectors.
FabricationPartBadConnectionConnectivityWarning | The connection invalid due to connection types associated to the connectors are not compatible.
FabricationPartBadConnectionSizeWarning | The connection invalid due to connectors sizes are not the same.
FabricationPartCannotBeMirrored |
FabricationPartCannotChangeServiceSizeWarning | The selected fitting(s) cannot successfully change service or change size. You must disconnect the connections on the fitting(s) and try again.
FabricationPartCannotChangeSlopeError | The connected fitting(s) cannot successfully change to the new slope value. You may try to disconnect the connections on the fitting(s) and try again.
FabricationPartCannotChangeTypeBadDimError | The selected fitting(s) cannot successfully change the type. The newly selected fabrication part may have badly configured dimensions or be constrained due to connected fitting(s). You may try to disconnect the connections on the fitting(s) and try again.
FabricationPartCannotChangeTypeBadDimUnConnError | The selected fitting(s) cannot successfully change the type. The newly selected fabrication part may have badly configured dimensions, resulting in bad geometry.
FabricationPartCannotChangeTypeError | The selected fitting(s) cannot successfully change the type. You must disconnect the connections on the fitting(s) and try again.
FabricationPartCannotChangeTypeIncompatError | The selected fitting(s) cannot successfully change the type. The newly selected fabrication part type either has no material or has badly configured dimensions, resulting in bad geometry. You may try to disconnect the connections on the fitting(s) and try again.
FabricationPartCannotChangeTypeIncompatUnConnError | The selected fitting(s) cannot successfully change the type. The newly selected fabrication part type either has no material or has badly configured dimensions, resulting in bad geometry.
FabricationPartCannotChangeTypeMisalignedError | The selected fitting(s) cannot successfully change the type. The newly selected fabrication part type has a problem with the angle dimension of the current fitting(s), resulting in bad geometry. You may try to disconnect the connections on the fitting(s) and try again.
FabricationPartCannotChangeTypeMisalignedUnConnError | The selected fitting(s) cannot successfully change the type. The newly selected fabrication part type has a problem with the angle dimension of the current fitting(s), resulting in bad geometry.
FabricationPartCannotChangeTypeUnConnError | The selected fitting(s) cannot successfully change the type.
FabricationPartCannotChangeTypeWarning | The selected fitting(s) cannot maintain connections to existing fabrication parts due to size, direction or angle differences. You must manually reconnect the open connections.
FabricationPartExceededAngleFlexToleranceWarning | The angle flex is greater than the maximum angle flex tolerance defined by the fabrication part. Connections with this part may not be properly aligned and may appear to be skewed.
FabricationPartExcludedPartWarning | There were fabrication parts needed to the make the connection that were excluded from the fabrication service causing the connection to fail. You may try to inlcude these fitting(s) and try again.
FabricationPartFitFailure | Fabrication Part Fitting Failed to Fit
FabricationPartFitFailWarning | Fabrication Part Fitting Failed to Fit
FabricationPartHasInvalidGeometry | The fabrication part either has no material or has badly configured dimensions, resulting in bad geometry.
FabricationPartInvalidConnection | Fabrication Part connection invalid and could not be automatically coupled.
FabricationPartInvalidSpecification | The part specification is invalid.
FabricationPartNoPartTypeFound | There are no fabrication part types found for the current Configuration and Service. Please select settings and reload the service to create the fabrication part types.
FabricationPartNotAttachedToStraight | The part must be attached to straight.
FabricationPartOptimizeInvalidConnection | No available couplings to connect standard lengths for this instance of straight.
FabricationRodDetachFromHangerError | The rod need to be detached from hanger.
FabricationRodsConnectionChangedWarning | The structural component that the hanger is attached to has changed to a different element.
FabricationRodsDisconnectedError | The hanger rod was disconnected because there is no structural component above.
FabricationRodsDisconnectedWarning | The hanger rod was disconnected because there is no structural component above.
FabricationServiceMismatch | Attempting to connect fabrication parts from different services.
FabricationStraigtLengthOversized | Fabrication straight exceeds the standard length. Use the Optimize Length command to adjust the length.
FixedFabricationPartNotChangeLength | Failed to change length of fixed part.
GroupedFabricationPartNotReposition | Failed to reposition part.
HangerProfileNotMatchWithHost | The defined hanger profile does not match with the host.
HangerWidthOutOfRange | The hanger width is too large to show.
InvalidConnectionsHaveBeenDisconnected | Invalid connections have been disconnected. Please reconnect them manually or use different fittings.
InvalidSelectionThereCannotBeOpenConnectors | Invalid selection there cannot be any open connectors for the design to fabrication part tool.
NoStructuralHostToAttachWarning | There is no structural component to attach the hanger rod to.
NotAllPartsWereConvertedUnsuportedFittingOffsets | Not all parts were converted. Eccentric transitions and taps that have offsets from the center line are unsupported and cannot be converted.
PinnedFabricationPartNotChangeExtension | Failed to change extension of part.
PinnedFabricationPartNotReposition | Failed to reposition part.
PlaceCutinFittingFailed | Failed to insert part.
SizeNotAvailableInFabricationService | Sizes:%1!s! in system %2!s! are not available in fabrication service:%3!s!, All available sizes are:\n%4!s!.
UneditableFabricationPartNotReposition | Failed to reposition part.
Top
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.AdditionalPartNotLoaded Property

BuiltInFailuresMEPFabricationFailuresAdditionalPartNotLoaded Property

An additional part was not loaded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AdditionalPartNotLoaded { get; }
Public Shared ReadOnly Property AdditionalPartNotLoaded As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AdditionalPartNotLoaded {
    FailureDefinitionId^ get ();
}
static member AdditionalPartNotLoaded : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.CannotConvertFlexPipeToPart Property

BuiltInFailuresMEPFabricationFailuresCannotConvertFlexPipeToPart Property

Cannot convert flex pipe to fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotConvertFlexPipeToPart { get; }
Public Shared ReadOnly Property CannotConvertFlexPipeToPart As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotConvertFlexPipeToPart {
    FailureDefinitionId^ get ();
}
static member CannotConvertFlexPipeToPart : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.CannotMatchFabricationHangerSizeToHost Property

BuiltInFailuresMEPFabricationFailuresCannotMatchFabricationHangerSizeToHost Property

The hanger cannot be re-sized to match the re-sized host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotMatchFabricationHangerSizeToHost { get; }
Public Shared ReadOnly Property CannotMatchFabricationHangerSizeToHost As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotMatchFabricationHangerSizeToHost {
    FailureDefinitionId^ get ();
}
static member CannotMatchFabricationHangerSizeToHost : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.FabDbChangeConn Property

BuiltInFailuresMEPFabricationFailuresFabDbChangeConn Property

Fabrication Database changes altered connectivity

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabDbChangeConn { get; }
Public Shared ReadOnly Property FabDbChangeConn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabDbChangeConn {
    FailureDefinitionId^ get ();
}
static member FabDbChangeConn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.FabDbOpenJobConn Property

BuiltInFailuresMEPFabricationFailuresFabDbOpenJobConn Property

Fabrication job imported had bad connectivity

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabDbOpenJobConn { get; }
Public Shared ReadOnly Property FabDbOpenJobConn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabDbOpenJobConn {
    FailureDefinitionId^ get ();
}
static member FabDbOpenJobConn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.FabDbSwapOut Property

BuiltInFailuresMEPFabricationFailuresFabDbSwapOut Property

Fabrication Database reload could not swap out for newer parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabDbSwapOut { get; }
Public Shared ReadOnly Property FabDbSwapOut As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabDbSwapOut {
    FailureDefinitionId^ get ();
}
static member FabDbSwapOut : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.FabricationConfigurationCorrupted Property

BuiltInFailuresMEPFabricationFailuresFabricationConfigurationCorrupted Property

It looks that the Fabrication Configuration %1!s! was corrupted, please check it at %2!s!.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricationConfigurationCorrupted { get; }
Public Shared ReadOnly Property FabricationConfigurationCorrupted As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricationConfigurationCorrupted {
    FailureDefinitionId^ get ();
}
static member FabricationConfigurationCorrupted : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.FabricationHangerCannotBeSloped Property

BuiltInFailuresMEPFabricationFailuresFabricationHangerCannotBeSloped Property

A hanger cannot be sloped or placed on a sloped element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricationHangerCannotBeSloped { get; }
Public Shared ReadOnly Property FabricationHangerCannotBeSloped As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricationHangerCannotBeSloped {
    FailureDefinitionId^ get ();
}
static member FabricationHangerCannotBeSloped : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.FabricationHangerHostNotFound Property

BuiltInFailuresMEPFabricationFailuresFabricationHangerHostNotFound Property

The hanger will disconnect because we can't find the suitable host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricationHangerHostNotFound { get; }
Public Shared ReadOnly Property FabricationHangerHostNotFound As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricationHangerHostNotFound {
    FailureDefinitionId^ get ();
}
static member FabricationHangerHostNotFound : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.FabricationHangerNotConnectToHost Property

BuiltInFailuresMEPFabricationFailuresFabricationHangerNotConnectToHost Property

Fabrication Hanger didn't connect to the %s host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricationHangerNotConnectToHost { get; }
Public Shared ReadOnly Property FabricationHangerNotConnectToHost As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricationHangerNotConnectToHost {
    FailureDefinitionId^ get ();
}
static member FabricationHangerNotConnectToHost : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.FabricationHangerOutOfHost Property

BuiltInFailuresMEPFabricationFailuresFabricationHangerOutOfHost Property

The hanger is out of its host and will be disconnected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricationHangerOutOfHost { get; }
Public Shared ReadOnly Property FabricationHangerOutOfHost As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricationHangerOutOfHost {
    FailureDefinitionId^ get ();
}
static member FabricationHangerOutOfHost : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.FabricationHangerSizeNotMatch Property

BuiltInFailuresMEPFabricationFailuresFabricationHangerSizeNotMatch Property

The hanger size does not match the size of the host, so it can not be connected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricationHangerSizeNotMatch { get; }
Public Shared ReadOnly Property FabricationHangerSizeNotMatch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricationHangerSizeNotMatch {
    FailureDefinitionId^ get ();
}
static member FabricationHangerSizeNotMatch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.FabricationOutOfSizeCondition Property

BuiltInFailuresMEPFabricationFailuresFabricationOutOfSizeCondition Property

The fabrication part size is not within the correct size range for the service button condition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricationOutOfSizeCondition { get; }
Public Shared ReadOnly Property FabricationOutOfSizeCondition As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricationOutOfSizeCondition {
    FailureDefinitionId^ get ();
}
static member FabricationOutOfSizeCondition : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.FabricationOverSizedCheck Property

BuiltInFailuresMEPFabricationFailuresFabricationOverSizedCheck Property

Fabrication part is too large to fit on the sheet metal. Replace the part with multiple smaller parts, or notify the CAM operator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricationOverSizedCheck { get; }
Public Shared ReadOnly Property FabricationOverSizedCheck As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricationOverSizedCheck {
    FailureDefinitionId^ get ();
}
static member FabricationOverSizedCheck : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.FabricationPartBadConnectionAlignmentWarning Property

BuiltInFailuresMEPFabricationFailuresFabricationPartBadConnectionAlignmentWarning Property

The connection invalid due to the connector are not aligned and/or this is a gap between the connectors.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricationPartBadConnectionAlignmentWarning { get; }
Public Shared ReadOnly Property FabricationPartBadConnectionAlignmentWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricationPartBadConnectionAlignmentWarning {
    FailureDefinitionId^ get ();
}
static member FabricationPartBadConnectionAlignmentWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.FabricationPartBadConnectionConnectivityWarning Property

BuiltInFailuresMEPFabricationFailuresFabricationPartBadConnectionConnectivityWarning Property

The connection invalid due to connection types associated to the connectors are not compatible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricationPartBadConnectionConnectivityWarning { get; }
Public Shared ReadOnly Property FabricationPartBadConnectionConnectivityWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricationPartBadConnectionConnectivityWarning {
    FailureDefinitionId^ get ();
}
static member FabricationPartBadConnectionConnectivityWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.FabricationPartBadConnectionSizeWarning Property

BuiltInFailuresMEPFabricationFailuresFabricationPartBadConnectionSizeWarning Property

The connection invalid due to connectors sizes are not the same.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricationPartBadConnectionSizeWarning { get; }
Public Shared ReadOnly Property FabricationPartBadConnectionSizeWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricationPartBadConnectionSizeWarning {
    FailureDefinitionId^ get ();
}
static member FabricationPartBadConnectionSizeWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.FabricationPartCannotBeMirrored Property

BuiltInFailuresMEPFabricationFailuresFabricationPartCannotBeMirrored Property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricationPartCannotBeMirrored { get; }
Public Shared ReadOnly Property FabricationPartCannotBeMirrored As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricationPartCannotBeMirrored {
    FailureDefinitionId^ get ();
}
static member FabricationPartCannotBeMirrored : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.FabricationPartCannotChangeServiceSizeWarning Property

BuiltInFailuresMEPFabricationFailuresFabricationPartCannotChangeServiceSizeWarning Property

The selected fitting(s) cannot successfully change service or change size. You must disconnect the connections on the fitting(s) and try again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricationPartCannotChangeServiceSizeWarning { get; }
Public Shared ReadOnly Property FabricationPartCannotChangeServiceSizeWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricationPartCannotChangeServiceSizeWarning {
    FailureDefinitionId^ get ();
}
static member FabricationPartCannotChangeServiceSizeWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.FabricationPartCannotChangeSlopeError Property

BuiltInFailuresMEPFabricationFailuresFabricationPartCannotChangeSlopeError Property

The connected fitting(s) cannot successfully change to the new slope value. You may try to disconnect the connections on the fitting(s) and try again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricationPartCannotChangeSlopeError { get; }
Public Shared ReadOnly Property FabricationPartCannotChangeSlopeError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricationPartCannotChangeSlopeError {
    FailureDefinitionId^ get ();
}
static member FabricationPartCannotChangeSlopeError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.FabricationPartCannotChangeTypeBadDimError Property

BuiltInFailuresMEPFabricationFailuresFabricationPartCannotChangeTypeBadDimError Property

The selected fitting(s) cannot successfully change the type. The newly selected fabrication part may have badly configured dimensions or be constrained due to connected fitting(s). You may try to disconnect the connections on the fitting(s) and try again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricationPartCannotChangeTypeBadDimError { get; }
Public Shared ReadOnly Property FabricationPartCannotChangeTypeBadDimError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricationPartCannotChangeTypeBadDimError {
    FailureDefinitionId^ get ();
}
static member FabricationPartCannotChangeTypeBadDimError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.FabricationPartCannotChangeTypeBadDimUnConnError Property

BuiltInFailuresMEPFabricationFailuresFabricationPartCannotChangeTypeBadDimUnConnError Property

The selected fitting(s) cannot successfully change the type. The newly selected fabrication part may have badly configured dimensions, resulting in bad geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricationPartCannotChangeTypeBadDimUnConnError { get; }
Public Shared ReadOnly Property FabricationPartCannotChangeTypeBadDimUnConnError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricationPartCannotChangeTypeBadDimUnConnError {
    FailureDefinitionId^ get ();
}
static member FabricationPartCannotChangeTypeBadDimUnConnError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.FabricationPartCannotChangeTypeError Property

BuiltInFailuresMEPFabricationFailuresFabricationPartCannotChangeTypeError Property

The selected fitting(s) cannot successfully change the type. You must disconnect the connections on the fitting(s) and try again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricationPartCannotChangeTypeError { get; }
Public Shared ReadOnly Property FabricationPartCannotChangeTypeError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricationPartCannotChangeTypeError {
    FailureDefinitionId^ get ();
}
static member FabricationPartCannotChangeTypeError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.FabricationPartCannotChangeTypeIncompatError Property

BuiltInFailuresMEPFabricationFailuresFabricationPartCannotChangeTypeIncompatError Property

The selected fitting(s) cannot successfully change the type. The newly selected fabrication part type either has no material or has badly configured dimensions, resulting in bad geometry. You may try to disconnect the connections on the fitting(s) and try again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricationPartCannotChangeTypeIncompatError { get; }
Public Shared ReadOnly Property FabricationPartCannotChangeTypeIncompatError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricationPartCannotChangeTypeIncompatError {
    FailureDefinitionId^ get ();
}
static member FabricationPartCannotChangeTypeIncompatError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.FabricationPartCannotChangeTypeIncompatUnConnError Property

BuiltInFailuresMEPFabricationFailuresFabricationPartCannotChangeTypeIncompatUnConnError Property

The selected fitting(s) cannot successfully change the type. The newly selected fabrication part type either has no material or has badly configured dimensions, resulting in bad geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricationPartCannotChangeTypeIncompatUnConnError { get; }
Public Shared ReadOnly Property FabricationPartCannotChangeTypeIncompatUnConnError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricationPartCannotChangeTypeIncompatUnConnError {
    FailureDefinitionId^ get ();
}
static member FabricationPartCannotChangeTypeIncompatUnConnError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.FabricationPartCannotChangeTypeMisalignedError Property

BuiltInFailuresMEPFabricationFailuresFabricationPartCannotChangeTypeMisalignedError Property

The selected fitting(s) cannot successfully change the type. The newly selected fabrication part type has a problem with the angle dimension of the current fitting(s), resulting in bad geometry. You may try to disconnect the connections on the fitting(s) and try again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricationPartCannotChangeTypeMisalignedError { get; }
Public Shared ReadOnly Property FabricationPartCannotChangeTypeMisalignedError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricationPartCannotChangeTypeMisalignedError {
    FailureDefinitionId^ get ();
}
static member FabricationPartCannotChangeTypeMisalignedError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.FabricationPartCannotChangeTypeMisalignedUnConnError Property

BuiltInFailuresMEPFabricationFailuresFabricationPartCannotChangeTypeMisalignedUnConnError Property

The selected fitting(s) cannot successfully change the type. The newly selected fabrication part type has a problem with the angle dimension of the current fitting(s), resulting in bad geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricationPartCannotChangeTypeMisalignedUnConnError { get; }
Public Shared ReadOnly Property FabricationPartCannotChangeTypeMisalignedUnConnError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricationPartCannotChangeTypeMisalignedUnConnError {
    FailureDefinitionId^ get ();
}
static member FabricationPartCannotChangeTypeMisalignedUnConnError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.FabricationPartCannotChangeTypeUnConnError Property

BuiltInFailuresMEPFabricationFailuresFabricationPartCannotChangeTypeUnConnError Property

The selected fitting(s) cannot successfully change the type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricationPartCannotChangeTypeUnConnError { get; }
Public Shared ReadOnly Property FabricationPartCannotChangeTypeUnConnError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricationPartCannotChangeTypeUnConnError {
    FailureDefinitionId^ get ();
}
static member FabricationPartCannotChangeTypeUnConnError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.FabricationPartCannotChangeTypeWarning Property

BuiltInFailuresMEPFabricationFailuresFabricationPartCannotChangeTypeWarning Property

The selected fitting(s) cannot maintain connections to existing fabrication parts due to size, direction or angle differences. You must manually reconnect the open connections.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricationPartCannotChangeTypeWarning { get; }
Public Shared ReadOnly Property FabricationPartCannotChangeTypeWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricationPartCannotChangeTypeWarning {
    FailureDefinitionId^ get ();
}
static member FabricationPartCannotChangeTypeWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.FabricationPartExceededAngleFlexToleranceWarning Property

BuiltInFailuresMEPFabricationFailuresFabricationPartExceededAngleFlexToleranceWarning Property

The angle flex is greater than the maximum angle flex tolerance defined by the fabrication part. Connections with this part may not be properly aligned and may appear to be skewed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricationPartExceededAngleFlexToleranceWarning { get; }
Public Shared ReadOnly Property FabricationPartExceededAngleFlexToleranceWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricationPartExceededAngleFlexToleranceWarning {
    FailureDefinitionId^ get ();
}
static member FabricationPartExceededAngleFlexToleranceWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.FabricationPartExcludedPartWarning Property

BuiltInFailuresMEPFabricationFailuresFabricationPartExcludedPartWarning Property

There were fabrication parts needed to the make the connection that were excluded from the fabrication service causing the connection to fail. You may try to inlcude these fitting(s) and try again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricationPartExcludedPartWarning { get; }
Public Shared ReadOnly Property FabricationPartExcludedPartWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricationPartExcludedPartWarning {
    FailureDefinitionId^ get ();
}
static member FabricationPartExcludedPartWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.FabricationPartFitFailure Property

BuiltInFailuresMEPFabricationFailuresFabricationPartFitFailure Property

Fabrication Part Fitting Failed to Fit

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricationPartFitFailure { get; }
Public Shared ReadOnly Property FabricationPartFitFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricationPartFitFailure {
    FailureDefinitionId^ get ();
}
static member FabricationPartFitFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.FabricationPartFitFailWarning Property

BuiltInFailuresMEPFabricationFailuresFabricationPartFitFailWarning Property

Fabrication Part Fitting Failed to Fit

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricationPartFitFailWarning { get; }
Public Shared ReadOnly Property FabricationPartFitFailWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricationPartFitFailWarning {
    FailureDefinitionId^ get ();
}
static member FabricationPartFitFailWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.FabricationPartHasInvalidGeometry Property

BuiltInFailuresMEPFabricationFailuresFabricationPartHasInvalidGeometry Property

The fabrication part either has no material or has badly configured dimensions, resulting in bad geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricationPartHasInvalidGeometry { get; }
Public Shared ReadOnly Property FabricationPartHasInvalidGeometry As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricationPartHasInvalidGeometry {
    FailureDefinitionId^ get ();
}
static member FabricationPartHasInvalidGeometry : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.FabricationPartInvalidConnection Property

BuiltInFailuresMEPFabricationFailuresFabricationPartInvalidConnection Property

Fabrication Part connection invalid and could not be automatically coupled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricationPartInvalidConnection { get; }
Public Shared ReadOnly Property FabricationPartInvalidConnection As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricationPartInvalidConnection {
    FailureDefinitionId^ get ();
}
static member FabricationPartInvalidConnection : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.FabricationPartInvalidSpecification Property

BuiltInFailuresMEPFabricationFailuresFabricationPartInvalidSpecification Property

The part specification is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricationPartInvalidSpecification { get; }
Public Shared ReadOnly Property FabricationPartInvalidSpecification As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricationPartInvalidSpecification {
    FailureDefinitionId^ get ();
}
static member FabricationPartInvalidSpecification : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.FabricationPartNoPartTypeFound Property

BuiltInFailuresMEPFabricationFailuresFabricationPartNoPartTypeFound Property

There are no fabrication part types found for the current Configuration and Service. Please select settings and reload the service to create the fabrication part types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricationPartNoPartTypeFound { get; }
Public Shared ReadOnly Property FabricationPartNoPartTypeFound As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricationPartNoPartTypeFound {
    FailureDefinitionId^ get ();
}
static member FabricationPartNoPartTypeFound : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.FabricationPartNotAttachedToStraight Property

BuiltInFailuresMEPFabricationFailuresFabricationPartNotAttachedToStraight Property

The part must be attached to straight.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricationPartNotAttachedToStraight { get; }
Public Shared ReadOnly Property FabricationPartNotAttachedToStraight As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricationPartNotAttachedToStraight {
    FailureDefinitionId^ get ();
}
static member FabricationPartNotAttachedToStraight : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.FabricationPartOptimizeInvalidConnection Property

BuiltInFailuresMEPFabricationFailuresFabricationPartOptimizeInvalidConnection Property

No available couplings to connect standard lengths for this instance of straight.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricationPartOptimizeInvalidConnection { get; }
Public Shared ReadOnly Property FabricationPartOptimizeInvalidConnection As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricationPartOptimizeInvalidConnection {
    FailureDefinitionId^ get ();
}
static member FabricationPartOptimizeInvalidConnection : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.FabricationRodDetachFromHangerError Property

BuiltInFailuresMEPFabricationFailuresFabricationRodDetachFromHangerError Property

The rod need to be detached from hanger.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricationRodDetachFromHangerError { get; }
Public Shared ReadOnly Property FabricationRodDetachFromHangerError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricationRodDetachFromHangerError {
    FailureDefinitionId^ get ();
}
static member FabricationRodDetachFromHangerError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.FabricationRodsConnectionChangedWarning Property

BuiltInFailuresMEPFabricationFailuresFabricationRodsConnectionChangedWarning Property

The structural component that the hanger is attached to has changed to a different element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricationRodsConnectionChangedWarning { get; }
Public Shared ReadOnly Property FabricationRodsConnectionChangedWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricationRodsConnectionChangedWarning {
    FailureDefinitionId^ get ();
}
static member FabricationRodsConnectionChangedWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.FabricationRodsDisconnectedError Property

BuiltInFailuresMEPFabricationFailuresFabricationRodsDisconnectedError Property

The hanger rod was disconnected because there is no structural component above.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricationRodsDisconnectedError { get; }
Public Shared ReadOnly Property FabricationRodsDisconnectedError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricationRodsDisconnectedError {
    FailureDefinitionId^ get ();
}
static member FabricationRodsDisconnectedError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.FabricationRodsDisconnectedWarning Property

BuiltInFailuresMEPFabricationFailuresFabricationRodsDisconnectedWarning Property

The hanger rod was disconnected because there is no structural component above.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricationRodsDisconnectedWarning { get; }
Public Shared ReadOnly Property FabricationRodsDisconnectedWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricationRodsDisconnectedWarning {
    FailureDefinitionId^ get ();
}
static member FabricationRodsDisconnectedWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.FabricationServiceMismatch Property

BuiltInFailuresMEPFabricationFailuresFabricationServiceMismatch Property

Attempting to connect fabrication parts from different services.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricationServiceMismatch { get; }
Public Shared ReadOnly Property FabricationServiceMismatch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricationServiceMismatch {
    FailureDefinitionId^ get ();
}
static member FabricationServiceMismatch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.FabricationStraigtLengthOversized Property

BuiltInFailuresMEPFabricationFailuresFabricationStraigtLengthOversized Property

Fabrication straight exceeds the standard length. Use the Optimize Length command to adjust the length.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabricationStraigtLengthOversized { get; }
Public Shared ReadOnly Property FabricationStraigtLengthOversized As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabricationStraigtLengthOversized {
    FailureDefinitionId^ get ();
}
static member FabricationStraigtLengthOversized : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.FixedFabricationPartNotChangeLength Property

BuiltInFailuresMEPFabricationFailuresFixedFabricationPartNotChangeLength Property

Failed to change length of fixed part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FixedFabricationPartNotChangeLength { get; }
Public Shared ReadOnly Property FixedFabricationPartNotChangeLength As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FixedFabricationPartNotChangeLength {
    FailureDefinitionId^ get ();
}
static member FixedFabricationPartNotChangeLength : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.GroupedFabricationPartNotReposition Property

BuiltInFailuresMEPFabricationFailuresGroupedFabricationPartNotReposition Property

Failed to reposition part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId GroupedFabricationPartNotReposition { get; }
Public Shared ReadOnly Property GroupedFabricationPartNotReposition As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ GroupedFabricationPartNotReposition {
    FailureDefinitionId^ get ();
}
static member GroupedFabricationPartNotReposition : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.HangerProfileNotMatchWithHost Property

BuiltInFailuresMEPFabricationFailuresHangerProfileNotMatchWithHost Property

The defined hanger profile does not match with the host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId HangerProfileNotMatchWithHost { get; }
Public Shared ReadOnly Property HangerProfileNotMatchWithHost As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ HangerProfileNotMatchWithHost {
    FailureDefinitionId^ get ();
}
static member HangerProfileNotMatchWithHost : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.HangerWidthOutOfRange Property

BuiltInFailuresMEPFabricationFailuresHangerWidthOutOfRange Property

The hanger width is too large to show.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId HangerWidthOutOfRange { get; }
Public Shared ReadOnly Property HangerWidthOutOfRange As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ HangerWidthOutOfRange {
    FailureDefinitionId^ get ();
}
static member HangerWidthOutOfRange : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.InvalidConnectionsHaveBeenDisconnected Property

BuiltInFailuresMEPFabricationFailuresInvalidConnectionsHaveBeenDisconnected Property

Invalid connections have been disconnected. Please reconnect them manually or use different fittings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidConnectionsHaveBeenDisconnected { get; }
Public Shared ReadOnly Property InvalidConnectionsHaveBeenDisconnected As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidConnectionsHaveBeenDisconnected {
    FailureDefinitionId^ get ();
}
static member InvalidConnectionsHaveBeenDisconnected : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.InvalidSelectionThereCannotBeOpenConnectors Property

BuiltInFailuresMEPFabricationFailuresInvalidSelectionThereCannotBeOpenConnectors Property

Invalid selection there cannot be any open connectors for the design to fabrication part tool.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidSelectionThereCannotBeOpenConnectors { get; }
Public Shared ReadOnly Property InvalidSelectionThereCannotBeOpenConnectors As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidSelectionThereCannotBeOpenConnectors {
    FailureDefinitionId^ get ();
}
static member InvalidSelectionThereCannotBeOpenConnectors : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.NoStructuralHostToAttachWarning Property

BuiltInFailuresMEPFabricationFailuresNoStructuralHostToAttachWarning Property

There is no structural component to attach the hanger rod to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoStructuralHostToAttachWarning { get; }
Public Shared ReadOnly Property NoStructuralHostToAttachWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoStructuralHostToAttachWarning {
    FailureDefinitionId^ get ();
}
static member NoStructuralHostToAttachWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.NotAllPartsWereConvertedUnsuportedFittingOffsets Property

BuiltInFailuresMEPFabricationFailuresNotAllPartsWereConvertedUnsuportedFittingOffsets Property

Not all parts were converted. Eccentric transitions and taps that have offsets from the center line are unsupported and cannot be converted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotAllPartsWereConvertedUnsuportedFittingOffsets { get; }
Public Shared ReadOnly Property NotAllPartsWereConvertedUnsuportedFittingOffsets As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotAllPartsWereConvertedUnsuportedFittingOffsets {
    FailureDefinitionId^ get ();
}
static member NotAllPartsWereConvertedUnsuportedFittingOffsets : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.PinnedFabricationPartNotChangeExtension Property

BuiltInFailuresMEPFabricationFailuresPinnedFabricationPartNotChangeExtension Property

Failed to change extension of part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PinnedFabricationPartNotChangeExtension { get; }
Public Shared ReadOnly Property PinnedFabricationPartNotChangeExtension As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PinnedFabricationPartNotChangeExtension {
    FailureDefinitionId^ get ();
}
static member PinnedFabricationPartNotChangeExtension : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.PinnedFabricationPartNotReposition Property

BuiltInFailuresMEPFabricationFailuresPinnedFabricationPartNotReposition Property

Failed to reposition part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PinnedFabricationPartNotReposition { get; }
Public Shared ReadOnly Property PinnedFabricationPartNotReposition As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PinnedFabricationPartNotReposition {
    FailureDefinitionId^ get ();
}
static member PinnedFabricationPartNotReposition : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.PlaceCutinFittingFailed Property

BuiltInFailuresMEPFabricationFailuresPlaceCutinFittingFailed Property

Failed to insert part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PlaceCutinFittingFailed { get; }
Public Shared ReadOnly Property PlaceCutinFittingFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PlaceCutinFittingFailed {
    FailureDefinitionId^ get ();
}
static member PlaceCutinFittingFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.SizeNotAvailableInFabricationService Property

BuiltInFailuresMEPFabricationFailuresSizeNotAvailableInFabricationService Property

Sizes:%1!s! in system %2!s! are not available in fabrication service:%3!s!, All available sizes are:\n%4!s!.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SizeNotAvailableInFabricationService { get; }
Public Shared ReadOnly Property SizeNotAvailableInFabricationService As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SizeNotAvailableInFabricationService {
    FailureDefinitionId^ get ();
}
static member SizeNotAvailableInFabricationService : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPFabricationFailures.UneditableFabricationPartNotReposition Property

BuiltInFailuresMEPFabricationFailuresUneditableFabricationPartNotReposition Property

Failed to reposition part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UneditableFabricationPartNotReposition { get; }
Public Shared ReadOnly Property UneditableFabricationPartNotReposition As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UneditableFabricationPartNotReposition {
    FailureDefinitionId^ get ();
}
static member UneditableFabricationPartNotReposition : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPFabricationFailures Class


BuiltInFailures.MEPSupportFailures Class

BuiltInFailuresMEPSupportFailures Class

Failures about MEP suppor.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresMEPSupportFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class MEPSupportFailures
Public NotInheritable Class MEPSupportFailures
public ref class MEPSupportFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type MEPSupportFailures = class end

The BuiltInFailuresMEPSupportFailures type exposes the following members.

Properties
Name | Description
CannotMatchInstanceSizeToHostError | The instance of [Symbol] cannot be re-sized to match the host.
InstanceOutOfHostError | The instance of [Symbol] lost its host and will be deleted.
InstanceProfileNotMatchWithHostError | The [Symbol]'s profile does not match the host. Instances of [Symbol] will be deleted.
TypeSizeNotMatchWithHostError | The [Symbol] does not match the size of the host.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


MEPSupportFailures Properties

The BuiltInFailuresMEPSupportFailures type exposes the following members.

Properties
Name | Description
CannotMatchInstanceSizeToHostError | The instance of [Symbol] cannot be re-sized to match the host.
InstanceOutOfHostError | The instance of [Symbol] lost its host and will be deleted.
InstanceProfileNotMatchWithHostError | The [Symbol]'s profile does not match the host. Instances of [Symbol] will be deleted.
TypeSizeNotMatchWithHostError | The [Symbol] does not match the size of the host.
Top
See Also

Reference

BuiltInFailuresMEPSupportFailures Class


BuiltInFailures.MEPSupportFailures.CannotMatchInstanceSizeToHostError Property

BuiltInFailuresMEPSupportFailuresCannotMatchInstanceSizeToHostError Property

The instance of [Symbol] cannot be re-sized to match the host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotMatchInstanceSizeToHostError { get; }
Public Shared ReadOnly Property CannotMatchInstanceSizeToHostError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotMatchInstanceSizeToHostError {
    FailureDefinitionId^ get ();
}
static member CannotMatchInstanceSizeToHostError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPSupportFailures Class


BuiltInFailures.MEPSupportFailures.InstanceOutOfHostError Property

BuiltInFailuresMEPSupportFailuresInstanceOutOfHostError Property

The instance of [Symbol] lost its host and will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InstanceOutOfHostError { get; }
Public Shared ReadOnly Property InstanceOutOfHostError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InstanceOutOfHostError {
    FailureDefinitionId^ get ();
}
static member InstanceOutOfHostError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPSupportFailures Class


BuiltInFailures.MEPSupportFailures.InstanceProfileNotMatchWithHostError Property

BuiltInFailuresMEPSupportFailuresInstanceProfileNotMatchWithHostError Property

The [Symbol]'s profile does not match the host. Instances of [Symbol] will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InstanceProfileNotMatchWithHostError { get; }
Public Shared ReadOnly Property InstanceProfileNotMatchWithHostError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InstanceProfileNotMatchWithHostError {
    FailureDefinitionId^ get ();
}
static member InstanceProfileNotMatchWithHostError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPSupportFailures Class


BuiltInFailures.MEPSupportFailures.TypeSizeNotMatchWithHostError Property

BuiltInFailuresMEPSupportFailuresTypeSizeNotMatchWithHostError Property

The [Symbol] does not match the size of the host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TypeSizeNotMatchWithHostError { get; }
Public Shared ReadOnly Property TypeSizeNotMatchWithHostError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TypeSizeNotMatchWithHostError {
    FailureDefinitionId^ get ();
}
static member TypeSizeNotMatchWithHostError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMEPSupportFailures Class


BuiltInFailures.MirrorFailures Class

BuiltInFailuresMirrorFailures Class

Failures about Mirror.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresMirrorFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class MirrorFailures
Public NotInheritable Class MirrorFailures
public ref class MirrorFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type MirrorFailures = class end

The BuiltInFailuresMirrorFailures type exposes the following members.

Properties
Name | Description
BadMirror | Can't mirror element into this position.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


MirrorFailures Properties

The BuiltInFailuresMirrorFailures type exposes the following members.

Properties
Name | Description
BadMirror | Can't mirror element into this position.
Top
See Also

Reference

BuiltInFailuresMirrorFailures Class


BuiltInFailures.MirrorFailures.BadMirror Property

BuiltInFailuresMirrorFailuresBadMirror Property

Can't mirror element into this position.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BadMirror { get; }
Public Shared ReadOnly Property BadMirror As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BadMirror {
    FailureDefinitionId^ get ();
}
static member BadMirror : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMirrorFailures Class


BuiltInFailures.MultiReferenceAnnotationFailures Class

BuiltInFailuresMultiReferenceAnnotationFailures Class

Failures about MultiReferenceAnnotations.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresMultiReferenceAnnotationFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class MultiReferenceAnnotationFailures
Public NotInheritable Class MultiReferenceAnnotationFailures
public ref class MultiReferenceAnnotationFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type MultiReferenceAnnotationFailures = class end

The BuiltInFailuresMultiReferenceAnnotationFailures type exposes the following members.

Properties
Name | Description
ElementCategoryChangeInvalidatesMultiReferenceAnnotation | Elements have changed category. Multi-rebar annotations for these elements are now of the wrong category and will be deleted.
MultiReferenceAnnotationReferenceCategoryForcesDeletion | Changing the reference category will cause instances of this annotation type to be deleted, because they no longer match their references.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


MultiReferenceAnnotationFailures Properties

The BuiltInFailuresMultiReferenceAnnotationFailures type exposes the following members.

Properties
Name | Description
ElementCategoryChangeInvalidatesMultiReferenceAnnotation | Elements have changed category. Multi-rebar annotations for these elements are now of the wrong category and will be deleted.
MultiReferenceAnnotationReferenceCategoryForcesDeletion | Changing the reference category will cause instances of this annotation type to be deleted, because they no longer match their references.
Top
See Also

Reference

BuiltInFailuresMultiReferenceAnnotationFailures Class


BuiltInFailures.MultiReferenceAnnotationFailures.ElementCategoryChangeInvalidatesMultiReferenceAnnotation Property

BuiltInFailuresMultiReferenceAnnotationFailuresElementCategoryChangeInvalidatesMultiReferenceAnnotation Property

Elements have changed category. Multi-rebar annotations for these elements are now of the wrong category and will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ElementCategoryChangeInvalidatesMultiReferenceAnnotation { get; }
Public Shared ReadOnly Property ElementCategoryChangeInvalidatesMultiReferenceAnnotation As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ElementCategoryChangeInvalidatesMultiReferenceAnnotation {
    FailureDefinitionId^ get ();
}
static member ElementCategoryChangeInvalidatesMultiReferenceAnnotation : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMultiReferenceAnnotationFailures Class


BuiltInFailures.MultiReferenceAnnotationFailures.MultiReferenceAnnotationReferenceCategoryForcesDeletion Property

BuiltInFailuresMultiReferenceAnnotationFailuresMultiReferenceAnnotationReferenceCategoryForcesDeletion Property

Changing the reference category will cause instances of this annotation type to be deleted, because they no longer match their references.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MultiReferenceAnnotationReferenceCategoryForcesDeletion { get; }
Public Shared ReadOnly Property MultiReferenceAnnotationReferenceCategoryForcesDeletion As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MultiReferenceAnnotationReferenceCategoryForcesDeletion {
    FailureDefinitionId^ get ();
}
static member MultiReferenceAnnotationReferenceCategoryForcesDeletion : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresMultiReferenceAnnotationFailures Class


BuiltInFailures.NumberingFailures Class

BuiltInFailuresNumberingFailures Class

Failures related to object numbering operations.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresNumberingFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class NumberingFailures
Public NotInheritable Class NumberingFailures
public ref class NumberingFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type NumberingFailures = class end

The BuiltInFailuresNumberingFailures type exposes the following members.

Properties
Name | Description
SampleNumberingError | Replace this with the first real one
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


NumberingFailures Properties

The BuiltInFailuresNumberingFailures type exposes the following members.

Properties
Name | Description
SampleNumberingError | Replace this with the first real one
Top
See Also

Reference

BuiltInFailuresNumberingFailures Class


BuiltInFailures.NumberingFailures.SampleNumberingError Property

BuiltInFailuresNumberingFailuresSampleNumberingError Property

Replace this with the first real one

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SampleNumberingError { get; }
Public Shared ReadOnly Property SampleNumberingError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SampleNumberingError {
    FailureDefinitionId^ get ();
}
static member SampleNumberingError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresNumberingFailures Class


BuiltInFailures.OffsetFacesCellLegacyFailures Class

BuiltInFailuresOffsetFacesCellLegacyFailures Class

Failures related to offset faces operations.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresOffsetFacesCellLegacyFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class OffsetFacesCellLegacyFailures
Public NotInheritable Class OffsetFacesCellLegacyFailures
public ref class OffsetFacesCellLegacyFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type OffsetFacesCellLegacyFailures = class end

The BuiltInFailuresOffsetFacesCellLegacyFailures type exposes the following members.

Properties
Name | Description
OffsetFaceFailed |
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


OffsetFacesCellLegacyFailures Properties

The BuiltInFailuresOffsetFacesCellLegacyFailures type exposes the following members.

Properties
Name | Description
OffsetFaceFailed |
Top
See Also

Reference

BuiltInFailuresOffsetFacesCellLegacyFailures Class


BuiltInFailures.OffsetFacesCellLegacyFailures.OffsetFaceFailed Property

BuiltInFailuresOffsetFacesCellLegacyFailuresOffsetFaceFailed Property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId OffsetFaceFailed { get; }
Public Shared ReadOnly Property OffsetFaceFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ OffsetFaceFailed {
    FailureDefinitionId^ get ();
}
static member OffsetFaceFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresOffsetFacesCellLegacyFailures Class


BuiltInFailures.OpeningFailures Class

BuiltInFailuresOpeningFailures Class

Failures about Opening.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresOpeningFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class OpeningFailures
Public NotInheritable Class OpeningFailures
public ref class OpeningFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type OpeningFailures = class end

The BuiltInFailuresOpeningFailures type exposes the following members.

Properties
Name | Description
HostForCutHasNoGeometry | Host can't be cut because it has no geometry.
HostForCutHasNoGeometryWarn | Host can't be cut because it has no geometry.
InvalidComplexCut | The family [Family Name] was containing one or more invalid cuts, which have been removed (most likely it was cutting a curtain wall). Please examine the family and make changes as needed.\r\nHint 1: If you are trying to cut a Curtain Wall, you may be able to achieve the desired result by editing the Elevation Profile or the curtain panel.\r\n Hint 2: If you can't see the family, you can still select it from the Project Browser.\r\nHint 3: This warning will disappear after you edit and then finish the family.
ModelAlreadyCheckedOutByUser | The Cloud WorkSharing Model is already checked out by the current user.
OpeningCutAll | Opening completely removes its host
OpeningDoesnotCutHost | Opening does not cut its host.
OpeningDoesnotCutHostDelete | Opening does not cut its host.
OpeningNegativeHeight | The top of the Opening is lower than the bottom of the Opening or coincident with it.
OpeningPartiallyCutsHost | Opening partially cuts its host.
OpeningRectDoesnotCutHost | Rectangular opening doesn't cut its host.
OpeningRemovesHost | Opening completely removes its host.
OpenStringerConflictNosing | Open stringer can't be created for selected nosing profile. Set nosing profile to default to get open stringers created.
PropertyNotClosed | Property lines do not form a closed loop. Area will not be computed.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


OpeningFailures Properties

The BuiltInFailuresOpeningFailures type exposes the following members.

Properties
Name | Description
HostForCutHasNoGeometry | Host can't be cut because it has no geometry.
HostForCutHasNoGeometryWarn | Host can't be cut because it has no geometry.
InvalidComplexCut | The family [Family Name] was containing one or more invalid cuts, which have been removed (most likely it was cutting a curtain wall). Please examine the family and make changes as needed.\r\nHint 1: If you are trying to cut a Curtain Wall, you may be able to achieve the desired result by editing the Elevation Profile or the curtain panel.\r\n Hint 2: If you can't see the family, you can still select it from the Project Browser.\r\nHint 3: This warning will disappear after you edit and then finish the family.
ModelAlreadyCheckedOutByUser | The Cloud WorkSharing Model is already checked out by the current user.
OpeningCutAll | Opening completely removes its host
OpeningDoesnotCutHost | Opening does not cut its host.
OpeningDoesnotCutHostDelete | Opening does not cut its host.
OpeningNegativeHeight | The top of the Opening is lower than the bottom of the Opening or coincident with it.
OpeningPartiallyCutsHost | Opening partially cuts its host.
OpeningRectDoesnotCutHost | Rectangular opening doesn't cut its host.
OpeningRemovesHost | Opening completely removes its host.
OpenStringerConflictNosing | Open stringer can't be created for selected nosing profile. Set nosing profile to default to get open stringers created.
PropertyNotClosed | Property lines do not form a closed loop. Area will not be computed.
Top
See Also

Reference

BuiltInFailuresOpeningFailures Class


BuiltInFailures.OpeningFailures.HostForCutHasNoGeometry Property

BuiltInFailuresOpeningFailuresHostForCutHasNoGeometry Property

Host can't be cut because it has no geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId HostForCutHasNoGeometry { get; }
Public Shared ReadOnly Property HostForCutHasNoGeometry As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ HostForCutHasNoGeometry {
    FailureDefinitionId^ get ();
}
static member HostForCutHasNoGeometry : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresOpeningFailures Class


BuiltInFailures.OpeningFailures.HostForCutHasNoGeometryWarn Property

BuiltInFailuresOpeningFailuresHostForCutHasNoGeometryWarn Property

Host can't be cut because it has no geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId HostForCutHasNoGeometryWarn { get; }
Public Shared ReadOnly Property HostForCutHasNoGeometryWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ HostForCutHasNoGeometryWarn {
    FailureDefinitionId^ get ();
}
static member HostForCutHasNoGeometryWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresOpeningFailures Class


BuiltInFailures.OpeningFailures.InvalidComplexCut Property

BuiltInFailuresOpeningFailuresInvalidComplexCut Property

The family [Family Name] was containing one or more invalid cuts, which have been removed (most likely it was cutting a curtain wall). Please examine the family and make changes as needed.\r\nHint 1: If you are trying to cut a Curtain Wall, you may be able to achieve the desired result by editing the Elevation Profile or the curtain panel.\r\n Hint 2: If you can't see the family, you can still select it from the Project Browser.\r\nHint 3: This warning will disappear after you edit and then finish the family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidComplexCut { get; }
Public Shared ReadOnly Property InvalidComplexCut As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidComplexCut {
    FailureDefinitionId^ get ();
}
static member InvalidComplexCut : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresOpeningFailures Class


BuiltInFailures.OpeningFailures.ModelAlreadyCheckedOutByUser Property

BuiltInFailuresOpeningFailuresModelAlreadyCheckedOutByUser Property

The Cloud WorkSharing Model is already checked out by the current user.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ModelAlreadyCheckedOutByUser { get; }
Public Shared ReadOnly Property ModelAlreadyCheckedOutByUser As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ModelAlreadyCheckedOutByUser {
    FailureDefinitionId^ get ();
}
static member ModelAlreadyCheckedOutByUser : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresOpeningFailures Class


BuiltInFailures.OpeningFailures.OpeningCutAll Property

BuiltInFailuresOpeningFailuresOpeningCutAll Property

Opening completely removes its host

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId OpeningCutAll { get; }
Public Shared ReadOnly Property OpeningCutAll As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ OpeningCutAll {
    FailureDefinitionId^ get ();
}
static member OpeningCutAll : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresOpeningFailures Class


BuiltInFailures.OpeningFailures.OpeningDoesnotCutHost Property

BuiltInFailuresOpeningFailuresOpeningDoesnotCutHost Property

Opening does not cut its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId OpeningDoesnotCutHost { get; }
Public Shared ReadOnly Property OpeningDoesnotCutHost As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ OpeningDoesnotCutHost {
    FailureDefinitionId^ get ();
}
static member OpeningDoesnotCutHost : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresOpeningFailures Class


BuiltInFailures.OpeningFailures.OpeningDoesnotCutHostDelete Property

BuiltInFailuresOpeningFailuresOpeningDoesnotCutHostDelete Property

Opening does not cut its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId OpeningDoesnotCutHostDelete { get; }
Public Shared ReadOnly Property OpeningDoesnotCutHostDelete As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ OpeningDoesnotCutHostDelete {
    FailureDefinitionId^ get ();
}
static member OpeningDoesnotCutHostDelete : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresOpeningFailures Class


BuiltInFailures.OpeningFailures.OpeningNegativeHeight Property

BuiltInFailuresOpeningFailuresOpeningNegativeHeight Property

The top of the Opening is lower than the bottom of the Opening or coincident with it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId OpeningNegativeHeight { get; }
Public Shared ReadOnly Property OpeningNegativeHeight As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ OpeningNegativeHeight {
    FailureDefinitionId^ get ();
}
static member OpeningNegativeHeight : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresOpeningFailures Class


BuiltInFailures.OpeningFailures.OpeningPartiallyCutsHost Property

BuiltInFailuresOpeningFailuresOpeningPartiallyCutsHost Property

Opening partially cuts its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId OpeningPartiallyCutsHost { get; }
Public Shared ReadOnly Property OpeningPartiallyCutsHost As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ OpeningPartiallyCutsHost {
    FailureDefinitionId^ get ();
}
static member OpeningPartiallyCutsHost : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresOpeningFailures Class


BuiltInFailures.OpeningFailures.OpeningRectDoesnotCutHost Property

BuiltInFailuresOpeningFailuresOpeningRectDoesnotCutHost Property

Rectangular opening doesn't cut its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId OpeningRectDoesnotCutHost { get; }
Public Shared ReadOnly Property OpeningRectDoesnotCutHost As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ OpeningRectDoesnotCutHost {
    FailureDefinitionId^ get ();
}
static member OpeningRectDoesnotCutHost : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresOpeningFailures Class


BuiltInFailures.OpeningFailures.OpeningRemovesHost Property

BuiltInFailuresOpeningFailuresOpeningRemovesHost Property

Opening completely removes its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId OpeningRemovesHost { get; }
Public Shared ReadOnly Property OpeningRemovesHost As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ OpeningRemovesHost {
    FailureDefinitionId^ get ();
}
static member OpeningRemovesHost : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresOpeningFailures Class


BuiltInFailures.OpeningFailures.OpenStringerConflictNosing Property

BuiltInFailuresOpeningFailuresOpenStringerConflictNosing Property

Open stringer can't be created for selected nosing profile. Set nosing profile to default to get open stringers created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId OpenStringerConflictNosing { get; }
Public Shared ReadOnly Property OpenStringerConflictNosing As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ OpenStringerConflictNosing {
    FailureDefinitionId^ get ();
}
static member OpenStringerConflictNosing : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresOpeningFailures Class


BuiltInFailures.OpeningFailures.PropertyNotClosed Property

BuiltInFailuresOpeningFailuresPropertyNotClosed Property

Property lines do not form a closed loop. Area will not be computed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PropertyNotClosed { get; }
Public Shared ReadOnly Property PropertyNotClosed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PropertyNotClosed {
    FailureDefinitionId^ get ();
}
static member PropertyNotClosed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresOpeningFailures Class


BuiltInFailures.OverlapFailures Class

BuiltInFailuresOverlapFailures Class

Failures detected by overlap check.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresOverlapFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class OverlapFailures
Public NotInheritable Class OverlapFailures
public ref class OverlapFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type OverlapFailures = class end

The BuiltInFailuresOverlapFailures type exposes the following members.

Properties
Name | Description
AreaBoundaryLinesOverlap | Highlighted area boundary lines overlap. Color fills, area tags, and areas may not behave correctly.
CurvesOverlap | Highlighted lines overlap. Lines may not form closed loops.
DivisionSketchOverlap | Curves in the sketch of the Division overlap.
DuplicateFabricSheet | There are identical Fabric sheets in the same place. This will result in double counting in schedules.
DuplicateInstances | There are identical instances in the same place. This will result in double counting in schedules.
DuplicatePoints | There are identical points in the same place. Lines created from points may not work as expected.
DuplicateRebar | There are identical rebar in the same place. This will result in double counting in schedules.
ELASeparationLinesOverlap | Highlighted area based load boundary lines overlap. One of them may be ignored when Revit finds load area boundaries. Delete one of the lines.
FloorsOverlap | Highlighted floors overlap.
LevelsOverlap | Highlighted levels overlap.
OverlappingElementsTest | There are overlapping structural framing elements of the same type in the project found by Dynamic Update.
RoomSeparationLinesOverlap | Highlighted room separation lines overlap. One of them may be ignored when Revit finds room boundaries. Delete one of the lines.
SpaceSeparationLinesOverlap | Highlighted space separation lines overlap. One of them may be ignored when Revit finds space boundaries. Delete one of the lines.
SubregionOverlap | Highlighted sub-division overlap.
ToposolidFloorOverlap | Highlighted toposolid and floor overlap.
ToposolidOverlap | Highlighted toposolid overlap.
ToposolidSubregionOverlap | Highlighted toposolid and sub-division overlap.
WallAreaBoundaryOverlap | Wall and area boundary line overlap. Color fills, area tags and areas may not behave correctly.
WallRoomSeparationOverlap | A wall and a room separation line overlap. One of them may be ignored when Revit finds room boundaries. Shorten or delete the room separation line to remove the overlap.
WallsOverlap | Highlighted walls overlap. One of them may be ignored when Revit finds room boundaries. Use Cut Geometry to embed one wall within the other.
WallSpaceSeparationOverlap | A wall and a space separation line overlap. One of them may be ignored when Revit finds space boundaries. Shorten or delete the space separation line to remove the overlap.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


OverlapFailures Properties

The BuiltInFailuresOverlapFailures type exposes the following members.

Properties
Name | Description
AreaBoundaryLinesOverlap | Highlighted area boundary lines overlap. Color fills, area tags, and areas may not behave correctly.
CurvesOverlap | Highlighted lines overlap. Lines may not form closed loops.
DivisionSketchOverlap | Curves in the sketch of the Division overlap.
DuplicateFabricSheet | There are identical Fabric sheets in the same place. This will result in double counting in schedules.
DuplicateInstances | There are identical instances in the same place. This will result in double counting in schedules.
DuplicatePoints | There are identical points in the same place. Lines created from points may not work as expected.
DuplicateRebar | There are identical rebar in the same place. This will result in double counting in schedules.
ELASeparationLinesOverlap | Highlighted area based load boundary lines overlap. One of them may be ignored when Revit finds load area boundaries. Delete one of the lines.
FloorsOverlap | Highlighted floors overlap.
LevelsOverlap | Highlighted levels overlap.
OverlappingElementsTest | There are overlapping structural framing elements of the same type in the project found by Dynamic Update.
RoomSeparationLinesOverlap | Highlighted room separation lines overlap. One of them may be ignored when Revit finds room boundaries. Delete one of the lines.
SpaceSeparationLinesOverlap | Highlighted space separation lines overlap. One of them may be ignored when Revit finds space boundaries. Delete one of the lines.
SubregionOverlap | Highlighted sub-division overlap.
ToposolidFloorOverlap | Highlighted toposolid and floor overlap.
ToposolidOverlap | Highlighted toposolid overlap.
ToposolidSubregionOverlap | Highlighted toposolid and sub-division overlap.
WallAreaBoundaryOverlap | Wall and area boundary line overlap. Color fills, area tags and areas may not behave correctly.
WallRoomSeparationOverlap | A wall and a room separation line overlap. One of them may be ignored when Revit finds room boundaries. Shorten or delete the room separation line to remove the overlap.
WallsOverlap | Highlighted walls overlap. One of them may be ignored when Revit finds room boundaries. Use Cut Geometry to embed one wall within the other.
WallSpaceSeparationOverlap | A wall and a space separation line overlap. One of them may be ignored when Revit finds space boundaries. Shorten or delete the space separation line to remove the overlap.
Top
See Also

Reference

BuiltInFailuresOverlapFailures Class


BuiltInFailures.OverlapFailures.AreaBoundaryLinesOverlap Property

BuiltInFailuresOverlapFailuresAreaBoundaryLinesOverlap Property

Highlighted area boundary lines overlap. Color fills, area tags, and areas may not behave correctly.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AreaBoundaryLinesOverlap { get; }
Public Shared ReadOnly Property AreaBoundaryLinesOverlap As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AreaBoundaryLinesOverlap {
    FailureDefinitionId^ get ();
}
static member AreaBoundaryLinesOverlap : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresOverlapFailures Class


BuiltInFailures.OverlapFailures.CurvesOverlap Property

BuiltInFailuresOverlapFailuresCurvesOverlap Property

Highlighted lines overlap. Lines may not form closed loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CurvesOverlap { get; }
Public Shared ReadOnly Property CurvesOverlap As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CurvesOverlap {
    FailureDefinitionId^ get ();
}
static member CurvesOverlap : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresOverlapFailures Class


BuiltInFailures.OverlapFailures.DivisionSketchOverlap Property

BuiltInFailuresOverlapFailuresDivisionSketchOverlap Property

Curves in the sketch of the Division overlap.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DivisionSketchOverlap { get; }
Public Shared ReadOnly Property DivisionSketchOverlap As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DivisionSketchOverlap {
    FailureDefinitionId^ get ();
}
static member DivisionSketchOverlap : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresOverlapFailures Class


BuiltInFailures.OverlapFailures.DuplicateFabricSheet Property

BuiltInFailuresOverlapFailuresDuplicateFabricSheet Property

There are identical Fabric sheets in the same place. This will result in double counting in schedules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DuplicateFabricSheet { get; }
Public Shared ReadOnly Property DuplicateFabricSheet As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DuplicateFabricSheet {
    FailureDefinitionId^ get ();
}
static member DuplicateFabricSheet : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresOverlapFailures Class


BuiltInFailures.OverlapFailures.DuplicateInstances Property

BuiltInFailuresOverlapFailuresDuplicateInstances Property

There are identical instances in the same place. This will result in double counting in schedules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DuplicateInstances { get; }
Public Shared ReadOnly Property DuplicateInstances As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DuplicateInstances {
    FailureDefinitionId^ get ();
}
static member DuplicateInstances : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresOverlapFailures Class


BuiltInFailures.OverlapFailures.DuplicatePoints Property

BuiltInFailuresOverlapFailuresDuplicatePoints Property

There are identical points in the same place. Lines created from points may not work as expected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DuplicatePoints { get; }
Public Shared ReadOnly Property DuplicatePoints As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DuplicatePoints {
    FailureDefinitionId^ get ();
}
static member DuplicatePoints : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresOverlapFailures Class


BuiltInFailures.OverlapFailures.DuplicateRebar Property

BuiltInFailuresOverlapFailuresDuplicateRebar Property

There are identical rebar in the same place. This will result in double counting in schedules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DuplicateRebar { get; }
Public Shared ReadOnly Property DuplicateRebar As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DuplicateRebar {
    FailureDefinitionId^ get ();
}
static member DuplicateRebar : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresOverlapFailures Class


BuiltInFailures.OverlapFailures.ELASeparationLinesOverlap Property

BuiltInFailuresOverlapFailuresELASeparationLinesOverlap Property

Highlighted area based load boundary lines overlap. One of them may be ignored when Revit finds load area boundaries. Delete one of the lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ELASeparationLinesOverlap { get; }
Public Shared ReadOnly Property ELASeparationLinesOverlap As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ELASeparationLinesOverlap {
    FailureDefinitionId^ get ();
}
static member ELASeparationLinesOverlap : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresOverlapFailures Class


BuiltInFailures.OverlapFailures.FloorsOverlap Property

BuiltInFailuresOverlapFailuresFloorsOverlap Property

Highlighted floors overlap.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FloorsOverlap { get; }
Public Shared ReadOnly Property FloorsOverlap As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FloorsOverlap {
    FailureDefinitionId^ get ();
}
static member FloorsOverlap : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresOverlapFailures Class


BuiltInFailures.OverlapFailures.LevelsOverlap Property

BuiltInFailuresOverlapFailuresLevelsOverlap Property

Highlighted levels overlap.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LevelsOverlap { get; }
Public Shared ReadOnly Property LevelsOverlap As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LevelsOverlap {
    FailureDefinitionId^ get ();
}
static member LevelsOverlap : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresOverlapFailures Class


BuiltInFailures.OverlapFailures.OverlappingElementsTest Property

BuiltInFailuresOverlapFailuresOverlappingElementsTest Property

There are overlapping structural framing elements of the same type in the project found by Dynamic Update.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId OverlappingElementsTest { get; }
Public Shared ReadOnly Property OverlappingElementsTest As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ OverlappingElementsTest {
    FailureDefinitionId^ get ();
}
static member OverlappingElementsTest : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresOverlapFailures Class


BuiltInFailures.OverlapFailures.RoomSeparationLinesOverlap Property

BuiltInFailuresOverlapFailuresRoomSeparationLinesOverlap Property

Highlighted room separation lines overlap. One of them may be ignored when Revit finds room boundaries. Delete one of the lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RoomSeparationLinesOverlap { get; }
Public Shared ReadOnly Property RoomSeparationLinesOverlap As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RoomSeparationLinesOverlap {
    FailureDefinitionId^ get ();
}
static member RoomSeparationLinesOverlap : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresOverlapFailures Class


BuiltInFailures.OverlapFailures.SpaceSeparationLinesOverlap Property

BuiltInFailuresOverlapFailuresSpaceSeparationLinesOverlap Property

Highlighted space separation lines overlap. One of them may be ignored when Revit finds space boundaries. Delete one of the lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SpaceSeparationLinesOverlap { get; }
Public Shared ReadOnly Property SpaceSeparationLinesOverlap As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SpaceSeparationLinesOverlap {
    FailureDefinitionId^ get ();
}
static member SpaceSeparationLinesOverlap : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresOverlapFailures Class


BuiltInFailures.OverlapFailures.SubregionOverlap Property

BuiltInFailuresOverlapFailuresSubregionOverlap Property

Highlighted sub-division overlap.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SubregionOverlap { get; }
Public Shared ReadOnly Property SubregionOverlap As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SubregionOverlap {
    FailureDefinitionId^ get ();
}
static member SubregionOverlap : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresOverlapFailures Class


BuiltInFailures.OverlapFailures.ToposolidFloorOverlap Property

BuiltInFailuresOverlapFailuresToposolidFloorOverlap Property

Highlighted toposolid and floor overlap.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ToposolidFloorOverlap { get; }
Public Shared ReadOnly Property ToposolidFloorOverlap As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ToposolidFloorOverlap {
    FailureDefinitionId^ get ();
}
static member ToposolidFloorOverlap : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresOverlapFailures Class


BuiltInFailures.OverlapFailures.ToposolidOverlap Property

BuiltInFailuresOverlapFailuresToposolidOverlap Property

Highlighted toposolid overlap.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ToposolidOverlap { get; }
Public Shared ReadOnly Property ToposolidOverlap As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ToposolidOverlap {
    FailureDefinitionId^ get ();
}
static member ToposolidOverlap : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresOverlapFailures Class


BuiltInFailures.OverlapFailures.ToposolidSubregionOverlap Property

BuiltInFailuresOverlapFailuresToposolidSubregionOverlap Property

Highlighted toposolid and sub-division overlap.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ToposolidSubregionOverlap { get; }
Public Shared ReadOnly Property ToposolidSubregionOverlap As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ToposolidSubregionOverlap {
    FailureDefinitionId^ get ();
}
static member ToposolidSubregionOverlap : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresOverlapFailures Class


BuiltInFailures.OverlapFailures.WallAreaBoundaryOverlap Property

BuiltInFailuresOverlapFailuresWallAreaBoundaryOverlap Property

Wall and area boundary line overlap. Color fills, area tags and areas may not behave correctly.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WallAreaBoundaryOverlap { get; }
Public Shared ReadOnly Property WallAreaBoundaryOverlap As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WallAreaBoundaryOverlap {
    FailureDefinitionId^ get ();
}
static member WallAreaBoundaryOverlap : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresOverlapFailures Class


BuiltInFailures.OverlapFailures.WallRoomSeparationOverlap Property

BuiltInFailuresOverlapFailuresWallRoomSeparationOverlap Property

A wall and a room separation line overlap. One of them may be ignored when Revit finds room boundaries. Shorten or delete the room separation line to remove the overlap.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WallRoomSeparationOverlap { get; }
Public Shared ReadOnly Property WallRoomSeparationOverlap As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WallRoomSeparationOverlap {
    FailureDefinitionId^ get ();
}
static member WallRoomSeparationOverlap : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresOverlapFailures Class


BuiltInFailures.OverlapFailures.WallsOverlap Property

BuiltInFailuresOverlapFailuresWallsOverlap Property

Highlighted walls overlap. One of them may be ignored when Revit finds room boundaries. Use Cut Geometry to embed one wall within the other.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WallsOverlap { get; }
Public Shared ReadOnly Property WallsOverlap As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WallsOverlap {
    FailureDefinitionId^ get ();
}
static member WallsOverlap : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresOverlapFailures Class


BuiltInFailures.OverlapFailures.WallSpaceSeparationOverlap Property

BuiltInFailuresOverlapFailuresWallSpaceSeparationOverlap Property

A wall and a space separation line overlap. One of them may be ignored when Revit finds space boundaries. Shorten or delete the space separation line to remove the overlap.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WallSpaceSeparationOverlap { get; }
Public Shared ReadOnly Property WallSpaceSeparationOverlap As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WallSpaceSeparationOverlap {
    FailureDefinitionId^ get ();
}
static member WallSpaceSeparationOverlap : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresOverlapFailures Class


BuiltInFailures.ParameterFailures Class

BuiltInFailuresParameterFailures Class

Failures related to parameters and parameter operations.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresParameterFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ParameterFailures
Public NotInheritable Class ParameterFailures
public ref class ParameterFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ParameterFailures = class end

The BuiltInFailuresParameterFailures type exposes the following members.

Properties
Name | Description
InconsistentSharedParameterDefinitions | The shared parameter '...' cannot be added with name '...' and type '...' because it conflicts with the existing name '...' and type '...'.
UnrecognizedSharedParameterDataType | The shared parameter '...' with name '...' cannot be added because its data type is not recognized.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ParameterFailures Properties

The BuiltInFailuresParameterFailures type exposes the following members.

Properties
Name | Description
InconsistentSharedParameterDefinitions | The shared parameter '...' cannot be added with name '...' and type '...' because it conflicts with the existing name '...' and type '...'.
UnrecognizedSharedParameterDataType | The shared parameter '...' with name '...' cannot be added because its data type is not recognized.
Top
See Also

Reference

BuiltInFailuresParameterFailures Class


BuiltInFailures.ParameterFailures.InconsistentSharedParameterDefinitions Property

BuiltInFailuresParameterFailuresInconsistentSharedParameterDefinitions Property

The shared parameter '...' cannot be added with name '...' and type '...' because it conflicts with the existing name '...' and type '...'.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InconsistentSharedParameterDefinitions { get; }
Public Shared ReadOnly Property InconsistentSharedParameterDefinitions As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InconsistentSharedParameterDefinitions {
    FailureDefinitionId^ get ();
}
static member InconsistentSharedParameterDefinitions : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresParameterFailures Class


BuiltInFailures.ParameterFailures.UnrecognizedSharedParameterDataType Property

BuiltInFailuresParameterFailuresUnrecognizedSharedParameterDataType Property

The shared parameter '...' with name '...' cannot be added because its data type is not recognized.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnrecognizedSharedParameterDataType { get; }
Public Shared ReadOnly Property UnrecognizedSharedParameterDataType As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnrecognizedSharedParameterDataType {
    FailureDefinitionId^ get ();
}
static member UnrecognizedSharedParameterDataType : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresParameterFailures Class


BuiltInFailures.PartMakerMethodForMergePartFailures Class

BuiltInFailuresPartMakerMethodForMergePartFailures Class

Failures related to part merge operations.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresPartMakerMethodForMergePartFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class PartMakerMethodForMergePartFailures
Public NotInheritable Class PartMakerMethodForMergePartFailures
public ref class PartMakerMethodForMergePartFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type PartMakerMethodForMergePartFailures = class end

The BuiltInFailuresPartMakerMethodForMergePartFailures type exposes the following members.

Properties
Name | Description
MergedPartHasDisConnectedGeometries | A merged part geometry has dis-connected components.
NeedTwoPartsToMerge | Attempt to merge fewer than two parts. There must be at least two. No part will be produced.
PartNotIncludedInMerge | This part is not geometrically coincident with another part of the same material. No merge possible.
PartsCannotBeMerged | This PartMaker refers to parts which cannot be merged.
UnableToIncludePartInMerge | Attempt to merge this Part results in failure of boolean operation. Cannot compute combined geometry.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PartMakerMethodForMergePartFailures Properties

The BuiltInFailuresPartMakerMethodForMergePartFailures type exposes the following members.

Properties
Name | Description
MergedPartHasDisConnectedGeometries | A merged part geometry has dis-connected components.
NeedTwoPartsToMerge | Attempt to merge fewer than two parts. There must be at least two. No part will be produced.
PartNotIncludedInMerge | This part is not geometrically coincident with another part of the same material. No merge possible.
PartsCannotBeMerged | This PartMaker refers to parts which cannot be merged.
UnableToIncludePartInMerge | Attempt to merge this Part results in failure of boolean operation. Cannot compute combined geometry.
Top
See Also

Reference

BuiltInFailuresPartMakerMethodForMergePartFailures Class


BuiltInFailures.PartMakerMethodForMergePartFailures.MergedPartHasDisConnectedGeometries Property

BuiltInFailuresPartMakerMethodForMergePartFailuresMergedPartHasDisConnectedGeometries Property

A merged part geometry has dis-connected components.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MergedPartHasDisConnectedGeometries { get; }
Public Shared ReadOnly Property MergedPartHasDisConnectedGeometries As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MergedPartHasDisConnectedGeometries {
    FailureDefinitionId^ get ();
}
static member MergedPartHasDisConnectedGeometries : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPartMakerMethodForMergePartFailures Class


BuiltInFailures.PartMakerMethodForMergePartFailures.NeedTwoPartsToMerge Property

BuiltInFailuresPartMakerMethodForMergePartFailuresNeedTwoPartsToMerge Property

Attempt to merge fewer than two parts. There must be at least two. No part will be produced.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NeedTwoPartsToMerge { get; }
Public Shared ReadOnly Property NeedTwoPartsToMerge As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NeedTwoPartsToMerge {
    FailureDefinitionId^ get ();
}
static member NeedTwoPartsToMerge : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPartMakerMethodForMergePartFailures Class


BuiltInFailures.PartMakerMethodForMergePartFailures.PartNotIncludedInMerge Property

BuiltInFailuresPartMakerMethodForMergePartFailuresPartNotIncludedInMerge Property

This part is not geometrically coincident with another part of the same material. No merge possible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PartNotIncludedInMerge { get; }
Public Shared ReadOnly Property PartNotIncludedInMerge As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PartNotIncludedInMerge {
    FailureDefinitionId^ get ();
}
static member PartNotIncludedInMerge : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPartMakerMethodForMergePartFailures Class


BuiltInFailures.PartMakerMethodForMergePartFailures.PartsCannotBeMerged Property

BuiltInFailuresPartMakerMethodForMergePartFailuresPartsCannotBeMerged Property

This PartMaker refers to parts which cannot be merged.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PartsCannotBeMerged { get; }
Public Shared ReadOnly Property PartsCannotBeMerged As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PartsCannotBeMerged {
    FailureDefinitionId^ get ();
}
static member PartsCannotBeMerged : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPartMakerMethodForMergePartFailures Class


BuiltInFailures.PartMakerMethodForMergePartFailures.UnableToIncludePartInMerge Property

BuiltInFailuresPartMakerMethodForMergePartFailuresUnableToIncludePartInMerge Property

Attempt to merge this Part results in failure of boolean operation. Cannot compute combined geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnableToIncludePartInMerge { get; }
Public Shared ReadOnly Property UnableToIncludePartInMerge As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnableToIncludePartInMerge {
    FailureDefinitionId^ get ();
}
static member UnableToIncludePartInMerge : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPartMakerMethodForMergePartFailures Class


BuiltInFailures.PartMakerMethodForWallFailures Class

BuiltInFailuresPartMakerMethodForWallFailures Class

Failures related to parts related to walls.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresPartMakerMethodForWallFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class PartMakerMethodForWallFailures
Public NotInheritable Class PartMakerMethodForWallFailures
public ref class PartMakerMethodForWallFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type PartMakerMethodForWallFailures = class end

The BuiltInFailuresPartMakerMethodForWallFailures type exposes the following members.

Properties
Name | Description
CouldNotAdjustWallPartsAtJoin | Failed to extend or trim some layer at an end join
CouldNotCreateWallPart | Failed to create basic layer geometry. Probably a failure either to create the cutter or to intersect the cutter with the wall geometry.
CouldNotCreateWallPartDueToWallJoin | Failed to create basic layer geometry due to an excessively short edge created by wall join.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PartMakerMethodForWallFailures Properties

The BuiltInFailuresPartMakerMethodForWallFailures type exposes the following members.

Properties
Name | Description
CouldNotAdjustWallPartsAtJoin | Failed to extend or trim some layer at an end join
CouldNotCreateWallPart | Failed to create basic layer geometry. Probably a failure either to create the cutter or to intersect the cutter with the wall geometry.
CouldNotCreateWallPartDueToWallJoin | Failed to create basic layer geometry due to an excessively short edge created by wall join.
Top
See Also

Reference

BuiltInFailuresPartMakerMethodForWallFailures Class


BuiltInFailures.PartMakerMethodForWallFailures.CouldNotAdjustWallPartsAtJoin Property

BuiltInFailuresPartMakerMethodForWallFailuresCouldNotAdjustWallPartsAtJoin Property

Failed to extend or trim some layer at an end join

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CouldNotAdjustWallPartsAtJoin { get; }
Public Shared ReadOnly Property CouldNotAdjustWallPartsAtJoin As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CouldNotAdjustWallPartsAtJoin {
    FailureDefinitionId^ get ();
}
static member CouldNotAdjustWallPartsAtJoin : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPartMakerMethodForWallFailures Class


BuiltInFailures.PartMakerMethodForWallFailures.CouldNotCreateWallPart Property

BuiltInFailuresPartMakerMethodForWallFailuresCouldNotCreateWallPart Property

Failed to create basic layer geometry. Probably a failure either to create the cutter or to intersect the cutter with the wall geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CouldNotCreateWallPart { get; }
Public Shared ReadOnly Property CouldNotCreateWallPart As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CouldNotCreateWallPart {
    FailureDefinitionId^ get ();
}
static member CouldNotCreateWallPart : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPartMakerMethodForWallFailures Class


BuiltInFailures.PartMakerMethodForWallFailures.CouldNotCreateWallPartDueToWallJoin Property

BuiltInFailuresPartMakerMethodForWallFailuresCouldNotCreateWallPartDueToWallJoin Property

Failed to create basic layer geometry due to an excessively short edge created by wall join.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CouldNotCreateWallPartDueToWallJoin { get; }
Public Shared ReadOnly Property CouldNotCreateWallPartDueToWallJoin As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CouldNotCreateWallPartDueToWallJoin {
    FailureDefinitionId^ get ();
}
static member CouldNotCreateWallPartDueToWallJoin : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPartMakerMethodForWallFailures Class


BuiltInFailures.PathFailures Class

BuiltInFailuresPathFailures Class

Failures about Path.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresPathFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class PathFailures
Public NotInheritable Class PathFailures
public ref class PathFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type PathFailures = class end

The BuiltInFailuresPathFailures type exposes the following members.

Properties
Name | Description
Path3dRegenError | Picked Path could not be regenerated.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PathFailures Properties

The BuiltInFailuresPathFailures type exposes the following members.

Properties
Name | Description
Path3dRegenError | Picked Path could not be regenerated.
Top
See Also

Reference

BuiltInFailuresPathFailures Class


BuiltInFailures.PathFailures.Path3dRegenError Property

BuiltInFailuresPathFailuresPath3dRegenError Property

Picked Path could not be regenerated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId Path3dRegenError { get; }
Public Shared ReadOnly Property Path3dRegenError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ Path3dRegenError {
    FailureDefinitionId^ get ();
}
static member Path3dRegenError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPathFailures Class


BuiltInFailures.PathOfTravelFailures Class

BuiltInFailuresPathOfTravelFailures Class

Failures about PathOfTravel.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresPathOfTravelFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class PathOfTravelFailures
Public NotInheritable Class PathOfTravelFailures
public ref class PathOfTravelFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type PathOfTravelFailures = class end

The BuiltInFailuresPathOfTravelFailures type exposes the following members.

Properties
Name | Description
CannotBePasted | Path of Travel cannot be pasted into this view.
ResultAffectedByCrop | A crop region is enabled in the view. The Path of Travel may not be the optimized route because it is calculating only inside the crop region. Consider uncropping the view and placing another Path of Travel to ensure you see the optimized route.
UpdateFailureMultiple | [Number] Path of Travel lines failed to update. [Reason for failure]
UpdateFailureSingle | Path of Travel failed to update.
UpdateSummary | [Number] Path of Travel lines successfully updated. [Number] Path of Travel lines failed to update.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PathOfTravelFailures Properties

The BuiltInFailuresPathOfTravelFailures type exposes the following members.

Properties
Name | Description
CannotBePasted | Path of Travel cannot be pasted into this view.
ResultAffectedByCrop | A crop region is enabled in the view. The Path of Travel may not be the optimized route because it is calculating only inside the crop region. Consider uncropping the view and placing another Path of Travel to ensure you see the optimized route.
UpdateFailureMultiple | [Number] Path of Travel lines failed to update. [Reason for failure]
UpdateFailureSingle | Path of Travel failed to update.
UpdateSummary | [Number] Path of Travel lines successfully updated. [Number] Path of Travel lines failed to update.
Top
See Also

Reference

BuiltInFailuresPathOfTravelFailures Class


BuiltInFailures.PathOfTravelFailures.CannotBePasted Property

BuiltInFailuresPathOfTravelFailuresCannotBePasted Property

Path of Travel cannot be pasted into this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotBePasted { get; }
Public Shared ReadOnly Property CannotBePasted As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotBePasted {
    FailureDefinitionId^ get ();
}
static member CannotBePasted : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPathOfTravelFailures Class


BuiltInFailures.PathOfTravelFailures.ResultAffectedByCrop Property

BuiltInFailuresPathOfTravelFailuresResultAffectedByCrop Property

A crop region is enabled in the view. The Path of Travel may not be the optimized route because it is calculating only inside the crop region. Consider uncropping the view and placing another Path of Travel to ensure you see the optimized route.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ResultAffectedByCrop { get; }
Public Shared ReadOnly Property ResultAffectedByCrop As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ResultAffectedByCrop {
    FailureDefinitionId^ get ();
}
static member ResultAffectedByCrop : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPathOfTravelFailures Class


BuiltInFailures.PathOfTravelFailures.UpdateFailureMultiple Property

BuiltInFailuresPathOfTravelFailuresUpdateFailureMultiple Property

[Number] Path of Travel lines failed to update. [Reason for failure]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UpdateFailureMultiple { get; }
Public Shared ReadOnly Property UpdateFailureMultiple As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UpdateFailureMultiple {
    FailureDefinitionId^ get ();
}
static member UpdateFailureMultiple : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPathOfTravelFailures Class


BuiltInFailures.PathOfTravelFailures.UpdateFailureSingle Property

BuiltInFailuresPathOfTravelFailuresUpdateFailureSingle Property

Path of Travel failed to update.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UpdateFailureSingle { get; }
Public Shared ReadOnly Property UpdateFailureSingle As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UpdateFailureSingle {
    FailureDefinitionId^ get ();
}
static member UpdateFailureSingle : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPathOfTravelFailures Class


BuiltInFailures.PathOfTravelFailures.UpdateSummary Property

BuiltInFailuresPathOfTravelFailuresUpdateSummary Property

[Number] Path of Travel lines successfully updated. [Number] Path of Travel lines failed to update.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UpdateSummary { get; }
Public Shared ReadOnly Property UpdateSummary As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UpdateSummary {
    FailureDefinitionId^ get ();
}
static member UpdateSummary : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPathOfTravelFailures Class


BuiltInFailures.PerformanceFailures Class

BuiltInFailuresPerformanceFailures Class

Failures which give hints pointing to situations where performance could be improved.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresPerformanceFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class PerformanceFailures
Public NotInheritable Class PerformanceFailures
public ref class PerformanceFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type PerformanceFailures = class end

The BuiltInFailuresPerformanceFailures type exposes the following members.

Properties
Name | Description
ClippingIsDisabled | View has clipping disabled. It causes view to draw too many elements.
DisjoinedSolidsInInPlaceFamily | In-place family contains multiple disjoined solids. Consider splitting in several in-place families.
DuplicateInstances | There are duplicate instances of the same family in the same place. Delete duplicate instances to improve performance.
FamilyContainsViewSpecificImports | Family definition contains view-specific imports. Such imports are inaccessible in the project - consider removal.
HostHasTooManyInserts | Host object contains too many cutting inserts - it may take long time to update. Consider splitting host object into smaller pieces or using stacked walls.
InteriorCategoriesEnabledInLargeView | Interior categories are enabled in a large view. Even though these objects may be obscured and invisible, they still have negative impact on performance.
LargeFamilyFile | Family occupies XXX kilobytes of memory. Consider simplification of the family.
ManyElementInFamily | Family definition contains too many elements. Consider simplification of the family.
ManyUnusedNestedFamilies | Family contains other families loaded into it but not used. Consider purging family document from unused families and types.
MultipleLoopsInSketch | Sketch of <element> contains multiple independent loops - splitting it in few independent elements might improve performance.
TooLargeSketch | Sketch of <element> has large area - it may slow down selection, drawing and geometric computations.
TooManyAreaBoundaryLinesFound | There are too many area boundary lines in area scheme <element> might result in increased model sizes on disk and in memory. Please investigate if area scheme is used in a proper way.
TooManyElementsInSketch | Sketch of <element> contains too many objects - it may take long time to solve.
UnjoinedRoomSeparationLinesFound | Room Separation of <element> is not joined, might cause performance issue with room boundaries computations.
UnusedTypesInTheProject | Project contains unused families and/or types. Consider purging them out.
ViewDetailLevelIsHighInLargeView | A large view has view detail level set to medium or coarse. Generation of extraneous details harms performance.
WallsOverlap | Walls overlap. Consider embedding walls, editing their extents or profile to avoid overlapping.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PerformanceFailures Properties

The BuiltInFailuresPerformanceFailures type exposes the following members.

Properties
Name | Description
ClippingIsDisabled | View has clipping disabled. It causes view to draw too many elements.
DisjoinedSolidsInInPlaceFamily | In-place family contains multiple disjoined solids. Consider splitting in several in-place families.
DuplicateInstances | There are duplicate instances of the same family in the same place. Delete duplicate instances to improve performance.
FamilyContainsViewSpecificImports | Family definition contains view-specific imports. Such imports are inaccessible in the project - consider removal.
HostHasTooManyInserts | Host object contains too many cutting inserts - it may take long time to update. Consider splitting host object into smaller pieces or using stacked walls.
InteriorCategoriesEnabledInLargeView | Interior categories are enabled in a large view. Even though these objects may be obscured and invisible, they still have negative impact on performance.
LargeFamilyFile | Family occupies XXX kilobytes of memory. Consider simplification of the family.
ManyElementInFamily | Family definition contains too many elements. Consider simplification of the family.
ManyUnusedNestedFamilies | Family contains other families loaded into it but not used. Consider purging family document from unused families and types.
MultipleLoopsInSketch | Sketch of <element> contains multiple independent loops - splitting it in few independent elements might improve performance.
TooLargeSketch | Sketch of <element> has large area - it may slow down selection, drawing and geometric computations.
TooManyAreaBoundaryLinesFound | There are too many area boundary lines in area scheme <element> might result in increased model sizes on disk and in memory. Please investigate if area scheme is used in a proper way.
TooManyElementsInSketch | Sketch of <element> contains too many objects - it may take long time to solve.
UnjoinedRoomSeparationLinesFound | Room Separation of <element> is not joined, might cause performance issue with room boundaries computations.
UnusedTypesInTheProject | Project contains unused families and/or types. Consider purging them out.
ViewDetailLevelIsHighInLargeView | A large view has view detail level set to medium or coarse. Generation of extraneous details harms performance.
WallsOverlap | Walls overlap. Consider embedding walls, editing their extents or profile to avoid overlapping.
Top
See Also

Reference

BuiltInFailuresPerformanceFailures Class


BuiltInFailures.PerformanceFailures.ClippingIsDisabled Property

BuiltInFailuresPerformanceFailuresClippingIsDisabled Property

View has clipping disabled. It causes view to draw too many elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ClippingIsDisabled { get; }
Public Shared ReadOnly Property ClippingIsDisabled As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ClippingIsDisabled {
    FailureDefinitionId^ get ();
}
static member ClippingIsDisabled : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPerformanceFailures Class


BuiltInFailures.PerformanceFailures.DisjoinedSolidsInInPlaceFamily Property

BuiltInFailuresPerformanceFailuresDisjoinedSolidsInInPlaceFamily Property

In-place family contains multiple disjoined solids. Consider splitting in several in-place families.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DisjoinedSolidsInInPlaceFamily { get; }
Public Shared ReadOnly Property DisjoinedSolidsInInPlaceFamily As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DisjoinedSolidsInInPlaceFamily {
    FailureDefinitionId^ get ();
}
static member DisjoinedSolidsInInPlaceFamily : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPerformanceFailures Class


BuiltInFailures.PerformanceFailures.DuplicateInstances Property

BuiltInFailuresPerformanceFailuresDuplicateInstances Property

There are duplicate instances of the same family in the same place. Delete duplicate instances to improve performance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DuplicateInstances { get; }
Public Shared ReadOnly Property DuplicateInstances As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DuplicateInstances {
    FailureDefinitionId^ get ();
}
static member DuplicateInstances : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPerformanceFailures Class


BuiltInFailures.PerformanceFailures.FamilyContainsViewSpecificImports Property

BuiltInFailuresPerformanceFailuresFamilyContainsViewSpecificImports Property

Family definition contains view-specific imports. Such imports are inaccessible in the project - consider removal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FamilyContainsViewSpecificImports { get; }
Public Shared ReadOnly Property FamilyContainsViewSpecificImports As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FamilyContainsViewSpecificImports {
    FailureDefinitionId^ get ();
}
static member FamilyContainsViewSpecificImports : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPerformanceFailures Class


BuiltInFailures.PerformanceFailures.HostHasTooManyInserts Property

BuiltInFailuresPerformanceFailuresHostHasTooManyInserts Property

Host object contains too many cutting inserts - it may take long time to update. Consider splitting host object into smaller pieces or using stacked walls.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId HostHasTooManyInserts { get; }
Public Shared ReadOnly Property HostHasTooManyInserts As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ HostHasTooManyInserts {
    FailureDefinitionId^ get ();
}
static member HostHasTooManyInserts : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPerformanceFailures Class


BuiltInFailures.PerformanceFailures.InteriorCategoriesEnabledInLargeView Property

BuiltInFailuresPerformanceFailuresInteriorCategoriesEnabledInLargeView Property

Interior categories are enabled in a large view. Even though these objects may be obscured and invisible, they still have negative impact on performance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InteriorCategoriesEnabledInLargeView { get; }
Public Shared ReadOnly Property InteriorCategoriesEnabledInLargeView As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InteriorCategoriesEnabledInLargeView {
    FailureDefinitionId^ get ();
}
static member InteriorCategoriesEnabledInLargeView : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPerformanceFailures Class


BuiltInFailures.PerformanceFailures.LargeFamilyFile Property

BuiltInFailuresPerformanceFailuresLargeFamilyFile Property

Family occupies XXX kilobytes of memory. Consider simplification of the family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LargeFamilyFile { get; }
Public Shared ReadOnly Property LargeFamilyFile As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LargeFamilyFile {
    FailureDefinitionId^ get ();
}
static member LargeFamilyFile : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPerformanceFailures Class


BuiltInFailures.PerformanceFailures.ManyElementInFamily Property

BuiltInFailuresPerformanceFailuresManyElementInFamily Property

Family definition contains too many elements. Consider simplification of the family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ManyElementInFamily { get; }
Public Shared ReadOnly Property ManyElementInFamily As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ManyElementInFamily {
    FailureDefinitionId^ get ();
}
static member ManyElementInFamily : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPerformanceFailures Class


BuiltInFailures.PerformanceFailures.ManyUnusedNestedFamilies Property

BuiltInFailuresPerformanceFailuresManyUnusedNestedFamilies Property

Family contains other families loaded into it but not used. Consider purging family document from unused families and types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ManyUnusedNestedFamilies { get; }
Public Shared ReadOnly Property ManyUnusedNestedFamilies As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ManyUnusedNestedFamilies {
    FailureDefinitionId^ get ();
}
static member ManyUnusedNestedFamilies : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPerformanceFailures Class


BuiltInFailures.PerformanceFailures.MultipleLoopsInSketch Property

BuiltInFailuresPerformanceFailuresMultipleLoopsInSketch Property

Sketch of <element> contains multiple independent loops - splitting it in few independent elements might improve performance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MultipleLoopsInSketch { get; }
Public Shared ReadOnly Property MultipleLoopsInSketch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MultipleLoopsInSketch {
    FailureDefinitionId^ get ();
}
static member MultipleLoopsInSketch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPerformanceFailures Class


BuiltInFailures.PerformanceFailures.TooLargeSketch Property

BuiltInFailuresPerformanceFailuresTooLargeSketch Property

Sketch of <element> has large area - it may slow down selection, drawing and geometric computations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TooLargeSketch { get; }
Public Shared ReadOnly Property TooLargeSketch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TooLargeSketch {
    FailureDefinitionId^ get ();
}
static member TooLargeSketch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPerformanceFailures Class


BuiltInFailures.PerformanceFailures.TooManyAreaBoundaryLinesFound Property

BuiltInFailuresPerformanceFailuresTooManyAreaBoundaryLinesFound Property

There are too many area boundary lines in area scheme <element> might result in increased model sizes on disk and in memory. Please investigate if area scheme is used in a proper way.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TooManyAreaBoundaryLinesFound { get; }
Public Shared ReadOnly Property TooManyAreaBoundaryLinesFound As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TooManyAreaBoundaryLinesFound {
    FailureDefinitionId^ get ();
}
static member TooManyAreaBoundaryLinesFound : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPerformanceFailures Class


BuiltInFailures.PerformanceFailures.TooManyElementsInSketch Property

BuiltInFailuresPerformanceFailuresTooManyElementsInSketch Property

Sketch of <element> contains too many objects - it may take long time to solve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TooManyElementsInSketch { get; }
Public Shared ReadOnly Property TooManyElementsInSketch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TooManyElementsInSketch {
    FailureDefinitionId^ get ();
}
static member TooManyElementsInSketch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPerformanceFailures Class


BuiltInFailures.PerformanceFailures.UnjoinedRoomSeparationLinesFound Property

BuiltInFailuresPerformanceFailuresUnjoinedRoomSeparationLinesFound Property

Room Separation of <element> is not joined, might cause performance issue with room boundaries computations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnjoinedRoomSeparationLinesFound { get; }
Public Shared ReadOnly Property UnjoinedRoomSeparationLinesFound As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnjoinedRoomSeparationLinesFound {
    FailureDefinitionId^ get ();
}
static member UnjoinedRoomSeparationLinesFound : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPerformanceFailures Class


BuiltInFailures.PerformanceFailures.UnusedTypesInTheProject Property

BuiltInFailuresPerformanceFailuresUnusedTypesInTheProject Property

Project contains unused families and/or types. Consider purging them out.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnusedTypesInTheProject { get; }
Public Shared ReadOnly Property UnusedTypesInTheProject As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnusedTypesInTheProject {
    FailureDefinitionId^ get ();
}
static member UnusedTypesInTheProject : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPerformanceFailures Class


BuiltInFailures.PerformanceFailures.ViewDetailLevelIsHighInLargeView Property

BuiltInFailuresPerformanceFailuresViewDetailLevelIsHighInLargeView Property

A large view has view detail level set to medium or coarse. Generation of extraneous details harms performance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ViewDetailLevelIsHighInLargeView { get; }
Public Shared ReadOnly Property ViewDetailLevelIsHighInLargeView As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ViewDetailLevelIsHighInLargeView {
    FailureDefinitionId^ get ();
}
static member ViewDetailLevelIsHighInLargeView : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPerformanceFailures Class


BuiltInFailures.PerformanceFailures.WallsOverlap Property

BuiltInFailuresPerformanceFailuresWallsOverlap Property

Walls overlap. Consider embedding walls, editing their extents or profile to avoid overlapping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WallsOverlap { get; }
Public Shared ReadOnly Property WallsOverlap As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WallsOverlap {
    FailureDefinitionId^ get ();
}
static member WallsOverlap : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPerformanceFailures Class


BuiltInFailures.PipingFailures Class

BuiltInFailuresPipingFailures Class

Failures about Pipes.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresPipingFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class PipingFailures
Public NotInheritable Class PipingFailures
public ref class PipingFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type PipingFailures = class end

The BuiltInFailuresPipingFailures type exposes the following members.

Properties
Name | Description
CannotCreateGeometryForPipe | Cannot create geometry for flex pipe. The flex pipe is intersecting itself or the start and end are too close together.
CircularLoopInPipeSizing | Circular loop detected during pipe sizing. The loop may be avoided by modifying segment settings in the pipe routing preference.
DuctPipeModified | The duct/pipe has been modified to be in the opposite direction causing the connections to be invalid.
DuctPipeSizeMismatch | The duct/pipe size is invalid for the service definition
FabFittingFailed | The Fabrication Fitting was invalid
InvalidPipeSize | Pipe Size Table "[File Name]" is missing or invalid.
MaxPipeSizeReached | Maximum pipe size diameter reached during sizing
PartNotFoundDueToNoPipeConnectedError | "In order to find a matching part, the fitting has to be connected to a pipe."
PartNotFoundDueToNoPipeConnectedWarning | "In order to find a matching part, the fitting has to be connected to a pipe."
PartNotFoundInRoutingPreferenceError | "%1s is not found. Please review the routing preference of %2s."
PartNotFoundInRoutingPreferenceWarning | "%1s is not found. Please review the routing preference of %2s."
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PipingFailures Properties

The BuiltInFailuresPipingFailures type exposes the following members.

Properties
Name | Description
CannotCreateGeometryForPipe | Cannot create geometry for flex pipe. The flex pipe is intersecting itself or the start and end are too close together.
CircularLoopInPipeSizing | Circular loop detected during pipe sizing. The loop may be avoided by modifying segment settings in the pipe routing preference.
DuctPipeModified | The duct/pipe has been modified to be in the opposite direction causing the connections to be invalid.
DuctPipeSizeMismatch | The duct/pipe size is invalid for the service definition
FabFittingFailed | The Fabrication Fitting was invalid
InvalidPipeSize | Pipe Size Table "[File Name]" is missing or invalid.
MaxPipeSizeReached | Maximum pipe size diameter reached during sizing
PartNotFoundDueToNoPipeConnectedError | "In order to find a matching part, the fitting has to be connected to a pipe."
PartNotFoundDueToNoPipeConnectedWarning | "In order to find a matching part, the fitting has to be connected to a pipe."
PartNotFoundInRoutingPreferenceError | "%1s is not found. Please review the routing preference of %2s."
PartNotFoundInRoutingPreferenceWarning | "%1s is not found. Please review the routing preference of %2s."
Top
See Also

Reference

BuiltInFailuresPipingFailures Class


BuiltInFailures.PipingFailures.CannotCreateGeometryForPipe Property

BuiltInFailuresPipingFailuresCannotCreateGeometryForPipe Property

Cannot create geometry for flex pipe. The flex pipe is intersecting itself or the start and end are too close together.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateGeometryForPipe { get; }
Public Shared ReadOnly Property CannotCreateGeometryForPipe As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateGeometryForPipe {
    FailureDefinitionId^ get ();
}
static member CannotCreateGeometryForPipe : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPipingFailures Class


BuiltInFailures.PipingFailures.CircularLoopInPipeSizing Property

BuiltInFailuresPipingFailuresCircularLoopInPipeSizing Property

Circular loop detected during pipe sizing. The loop may be avoided by modifying segment settings in the pipe routing preference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CircularLoopInPipeSizing { get; }
Public Shared ReadOnly Property CircularLoopInPipeSizing As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CircularLoopInPipeSizing {
    FailureDefinitionId^ get ();
}
static member CircularLoopInPipeSizing : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPipingFailures Class


BuiltInFailures.PipingFailures.DuctPipeModified Property

BuiltInFailuresPipingFailuresDuctPipeModified Property

The duct/pipe has been modified to be in the opposite direction causing the connections to be invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DuctPipeModified { get; }
Public Shared ReadOnly Property DuctPipeModified As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DuctPipeModified {
    FailureDefinitionId^ get ();
}
static member DuctPipeModified : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPipingFailures Class


BuiltInFailures.PipingFailures.DuctPipeSizeMismatch Property

BuiltInFailuresPipingFailuresDuctPipeSizeMismatch Property

The duct/pipe size is invalid for the service definition

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DuctPipeSizeMismatch { get; }
Public Shared ReadOnly Property DuctPipeSizeMismatch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DuctPipeSizeMismatch {
    FailureDefinitionId^ get ();
}
static member DuctPipeSizeMismatch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPipingFailures Class


BuiltInFailures.PipingFailures.FabFittingFailed Property

BuiltInFailuresPipingFailuresFabFittingFailed Property

The Fabrication Fitting was invalid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FabFittingFailed { get; }
Public Shared ReadOnly Property FabFittingFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FabFittingFailed {
    FailureDefinitionId^ get ();
}
static member FabFittingFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPipingFailures Class


BuiltInFailures.PipingFailures.InvalidPipeSize Property

BuiltInFailuresPipingFailuresInvalidPipeSize Property

Pipe Size Table "[File Name]" is missing or invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidPipeSize { get; }
Public Shared ReadOnly Property InvalidPipeSize As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidPipeSize {
    FailureDefinitionId^ get ();
}
static member InvalidPipeSize : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPipingFailures Class


BuiltInFailures.PipingFailures.MaxPipeSizeReached Property

BuiltInFailuresPipingFailuresMaxPipeSizeReached Property

Maximum pipe size diameter reached during sizing

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MaxPipeSizeReached { get; }
Public Shared ReadOnly Property MaxPipeSizeReached As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MaxPipeSizeReached {
    FailureDefinitionId^ get ();
}
static member MaxPipeSizeReached : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPipingFailures Class


BuiltInFailures.PipingFailures.PartNotFoundDueToNoPipeConnectedError Property

BuiltInFailuresPipingFailuresPartNotFoundDueToNoPipeConnectedError Property

"In order to find a matching part, the fitting has to be connected to a pipe."

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PartNotFoundDueToNoPipeConnectedError { get; }
Public Shared ReadOnly Property PartNotFoundDueToNoPipeConnectedError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PartNotFoundDueToNoPipeConnectedError {
    FailureDefinitionId^ get ();
}
static member PartNotFoundDueToNoPipeConnectedError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPipingFailures Class


BuiltInFailures.PipingFailures.PartNotFoundDueToNoPipeConnectedWarning Property

BuiltInFailuresPipingFailuresPartNotFoundDueToNoPipeConnectedWarning Property

"In order to find a matching part, the fitting has to be connected to a pipe."

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PartNotFoundDueToNoPipeConnectedWarning { get; }
Public Shared ReadOnly Property PartNotFoundDueToNoPipeConnectedWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PartNotFoundDueToNoPipeConnectedWarning {
    FailureDefinitionId^ get ();
}
static member PartNotFoundDueToNoPipeConnectedWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPipingFailures Class


BuiltInFailures.PipingFailures.PartNotFoundInRoutingPreferenceError Property

BuiltInFailuresPipingFailuresPartNotFoundInRoutingPreferenceError Property

"%1s is not found. Please review the routing preference of %2s."

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PartNotFoundInRoutingPreferenceError { get; }
Public Shared ReadOnly Property PartNotFoundInRoutingPreferenceError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PartNotFoundInRoutingPreferenceError {
    FailureDefinitionId^ get ();
}
static member PartNotFoundInRoutingPreferenceError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPipingFailures Class


BuiltInFailures.PipingFailures.PartNotFoundInRoutingPreferenceWarning Property

BuiltInFailuresPipingFailuresPartNotFoundInRoutingPreferenceWarning Property

"%1s is not found. Please review the routing preference of %2s."

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PartNotFoundInRoutingPreferenceWarning { get; }
Public Shared ReadOnly Property PartNotFoundInRoutingPreferenceWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PartNotFoundInRoutingPreferenceWarning {
    FailureDefinitionId^ get ();
}
static member PartNotFoundInRoutingPreferenceWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPipingFailures Class


BuiltInFailures.PlanRegionFailures Class

BuiltInFailuresPlanRegionFailures Class

Failures about PlanRegion.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresPlanRegionFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class PlanRegionFailures
Public NotInheritable Class PlanRegionFailures
public ref class PlanRegionFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type PlanRegionFailures = class end

The BuiltInFailuresPlanRegionFailures type exposes the following members.

Properties
Name | Description
DeletedViewRangeLevel | Deleted level was used to define plan region's view range.\r\nReplace deleted level by level of parent view and adjust offset?
Intersecting | The boundaries of the highlighted Plan Regions overlap.
InvalidPlanRegion | Plan region is invalid. The sketch of a plan region may not contain intersecting, overlapping or nested loops.
InvalidPlanRegionError | Plan region is invalid. The sketch of a plan region may not contain intersecting, overlapping or nested loops.
Nested | Cannot have nested Plan Regions.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PlanRegionFailures Properties

The BuiltInFailuresPlanRegionFailures type exposes the following members.

Properties
Name | Description
DeletedViewRangeLevel | Deleted level was used to define plan region's view range.\r\nReplace deleted level by level of parent view and adjust offset?
Intersecting | The boundaries of the highlighted Plan Regions overlap.
InvalidPlanRegion | Plan region is invalid. The sketch of a plan region may not contain intersecting, overlapping or nested loops.
InvalidPlanRegionError | Plan region is invalid. The sketch of a plan region may not contain intersecting, overlapping or nested loops.
Nested | Cannot have nested Plan Regions.
Top
See Also

Reference

BuiltInFailuresPlanRegionFailures Class


BuiltInFailures.PlanRegionFailures.DeletedViewRangeLevel Property

BuiltInFailuresPlanRegionFailuresDeletedViewRangeLevel Property

Deleted level was used to define plan region's view range.\r\nReplace deleted level by level of parent view and adjust offset?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DeletedViewRangeLevel { get; }
Public Shared ReadOnly Property DeletedViewRangeLevel As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DeletedViewRangeLevel {
    FailureDefinitionId^ get ();
}
static member DeletedViewRangeLevel : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPlanRegionFailures Class


BuiltInFailures.PlanRegionFailures.Intersecting Property

BuiltInFailuresPlanRegionFailuresIntersecting Property

The boundaries of the highlighted Plan Regions overlap.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId Intersecting { get; }
Public Shared ReadOnly Property Intersecting As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ Intersecting {
    FailureDefinitionId^ get ();
}
static member Intersecting : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPlanRegionFailures Class


BuiltInFailures.PlanRegionFailures.InvalidPlanRegion Property

BuiltInFailuresPlanRegionFailuresInvalidPlanRegion Property

Plan region is invalid. The sketch of a plan region may not contain intersecting, overlapping or nested loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidPlanRegion { get; }
Public Shared ReadOnly Property InvalidPlanRegion As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidPlanRegion {
    FailureDefinitionId^ get ();
}
static member InvalidPlanRegion : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPlanRegionFailures Class


BuiltInFailures.PlanRegionFailures.InvalidPlanRegionError Property

BuiltInFailuresPlanRegionFailuresInvalidPlanRegionError Property

Plan region is invalid. The sketch of a plan region may not contain intersecting, overlapping or nested loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidPlanRegionError { get; }
Public Shared ReadOnly Property InvalidPlanRegionError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidPlanRegionError {
    FailureDefinitionId^ get ();
}
static member InvalidPlanRegionError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPlanRegionFailures Class


BuiltInFailures.PlanRegionFailures.Nested Property

BuiltInFailuresPlanRegionFailuresNested Property

Cannot have nested Plan Regions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId Nested { get; }
Public Shared ReadOnly Property Nested As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ Nested {
    FailureDefinitionId^ get ();
}
static member Nested : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPlanRegionFailures Class


BuiltInFailures.PointFailures Class

BuiltInFailuresPointFailures Class

Failures about Point Element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresPointFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class PointFailures
Public NotInheritable Class PointFailures
public ref class PointFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type PointFailures = class end

The BuiltInFailuresPointFailures type exposes the following members.

Properties
Name | Description
CannotMakePointHostedByIntersection | Cannot make point hosted by intersection.
CantChangeParamFlip | Can't flip Element.
CantChangeParamMirror | Can't mirror Element.
CantChangeParamRotate | Can't rotate Element.
EdgeHostedPointToBeUnhosted | A point element in a family was hosted on an edge outside its family and the edge no longer exists. The point will remain placed but with no host.
HostMeasurementError | Invalid host curve measurement type or value or justification
HostParameterRangeError | Hosted Parameter must be between 0 and 1
RegenFailure | Regeneration Failure.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PointFailures Properties

The BuiltInFailuresPointFailures type exposes the following members.

Properties
Name | Description
CannotMakePointHostedByIntersection | Cannot make point hosted by intersection.
CantChangeParamFlip | Can't flip Element.
CantChangeParamMirror | Can't mirror Element.
CantChangeParamRotate | Can't rotate Element.
EdgeHostedPointToBeUnhosted | A point element in a family was hosted on an edge outside its family and the edge no longer exists. The point will remain placed but with no host.
HostMeasurementError | Invalid host curve measurement type or value or justification
HostParameterRangeError | Hosted Parameter must be between 0 and 1
RegenFailure | Regeneration Failure.
Top
See Also

Reference

BuiltInFailuresPointFailures Class


BuiltInFailures.PointFailures.CannotMakePointHostedByIntersection Property

BuiltInFailuresPointFailuresCannotMakePointHostedByIntersection Property

Cannot make point hosted by intersection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotMakePointHostedByIntersection { get; }
Public Shared ReadOnly Property CannotMakePointHostedByIntersection As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotMakePointHostedByIntersection {
    FailureDefinitionId^ get ();
}
static member CannotMakePointHostedByIntersection : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPointFailures Class


BuiltInFailures.PointFailures.CantChangeParamFlip Property

BuiltInFailuresPointFailuresCantChangeParamFlip Property

Can't flip Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CantChangeParamFlip { get; }
Public Shared ReadOnly Property CantChangeParamFlip As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CantChangeParamFlip {
    FailureDefinitionId^ get ();
}
static member CantChangeParamFlip : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPointFailures Class


BuiltInFailures.PointFailures.CantChangeParamMirror Property

BuiltInFailuresPointFailuresCantChangeParamMirror Property

Can't mirror Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CantChangeParamMirror { get; }
Public Shared ReadOnly Property CantChangeParamMirror As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CantChangeParamMirror {
    FailureDefinitionId^ get ();
}
static member CantChangeParamMirror : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPointFailures Class


BuiltInFailures.PointFailures.CantChangeParamRotate Property

BuiltInFailuresPointFailuresCantChangeParamRotate Property

Can't rotate Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CantChangeParamRotate { get; }
Public Shared ReadOnly Property CantChangeParamRotate As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CantChangeParamRotate {
    FailureDefinitionId^ get ();
}
static member CantChangeParamRotate : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPointFailures Class


BuiltInFailures.PointFailures.EdgeHostedPointToBeUnhosted Property

BuiltInFailuresPointFailuresEdgeHostedPointToBeUnhosted Property

A point element in a family was hosted on an edge outside its family and the edge no longer exists. The point will remain placed but with no host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId EdgeHostedPointToBeUnhosted { get; }
Public Shared ReadOnly Property EdgeHostedPointToBeUnhosted As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ EdgeHostedPointToBeUnhosted {
    FailureDefinitionId^ get ();
}
static member EdgeHostedPointToBeUnhosted : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPointFailures Class


BuiltInFailures.PointFailures.HostMeasurementError Property

BuiltInFailuresPointFailuresHostMeasurementError Property

Invalid host curve measurement type or value or justification

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId HostMeasurementError { get; }
Public Shared ReadOnly Property HostMeasurementError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ HostMeasurementError {
    FailureDefinitionId^ get ();
}
static member HostMeasurementError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPointFailures Class


BuiltInFailures.PointFailures.HostParameterRangeError Property

BuiltInFailuresPointFailuresHostParameterRangeError Property

Hosted Parameter must be between 0 and 1

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId HostParameterRangeError { get; }
Public Shared ReadOnly Property HostParameterRangeError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ HostParameterRangeError {
    FailureDefinitionId^ get ();
}
static member HostParameterRangeError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPointFailures Class


BuiltInFailures.PointFailures.RegenFailure Property

BuiltInFailuresPointFailuresRegenFailure Property

Regeneration Failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RegenFailure { get; }
Public Shared ReadOnly Property RegenFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RegenFailure {
    FailureDefinitionId^ get ();
}
static member RegenFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPointFailures Class


BuiltInFailures.ProfileFailures Class

BuiltInFailuresProfileFailures Class

Failures about Profile.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresProfileFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ProfileFailures
Public NotInheritable Class ProfileFailures
public ref class ProfileFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ProfileFailures = class end

The BuiltInFailuresProfileFailures type exposes the following members.

Properties
Name | Description
SketchNotEmpty | Can't move the Profile Plane because the Profile Sketch is not empty. This operation is not supported at this time.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ProfileFailures Properties

The BuiltInFailuresProfileFailures type exposes the following members.

Properties
Name | Description
SketchNotEmpty | Can't move the Profile Plane because the Profile Sketch is not empty. This operation is not supported at this time.
Top
See Also

Reference

BuiltInFailuresProfileFailures Class


BuiltInFailures.ProfileFailures.SketchNotEmpty Property

BuiltInFailuresProfileFailuresSketchNotEmpty Property

Can't move the Profile Plane because the Profile Sketch is not empty. This operation is not supported at this time.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SketchNotEmpty { get; }
Public Shared ReadOnly Property SketchNotEmpty As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SketchNotEmpty {
    FailureDefinitionId^ get ();
}
static member SketchNotEmpty : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresProfileFailures Class


BuiltInFailures.PropertySetElementFailures Class

BuiltInFailuresPropertySetElementFailures Class

Failures related to property set elements.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresPropertySetElementFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class PropertySetElementFailures
Public NotInheritable Class PropertySetElementFailures
public ref class PropertySetElementFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type PropertySetElementFailures = class end

The BuiltInFailuresPropertySetElementFailures type exposes the following members.

Properties
Name | Description
EmptyPropertySetName | A property set name cannot be an empty string.
NonStringParameterValue | The given parameter requires a string value.
NonUniquePropertySetName | The value of the given parameter is already in use as a property set name.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PropertySetElementFailures Properties

The BuiltInFailuresPropertySetElementFailures type exposes the following members.

Properties
Name | Description
EmptyPropertySetName | A property set name cannot be an empty string.
NonStringParameterValue | The given parameter requires a string value.
NonUniquePropertySetName | The value of the given parameter is already in use as a property set name.
Top
See Also

Reference

BuiltInFailuresPropertySetElementFailures Class


BuiltInFailures.PropertySetElementFailures.EmptyPropertySetName Property

BuiltInFailuresPropertySetElementFailuresEmptyPropertySetName Property

A property set name cannot be an empty string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId EmptyPropertySetName { get; }
Public Shared ReadOnly Property EmptyPropertySetName As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ EmptyPropertySetName {
    FailureDefinitionId^ get ();
}
static member EmptyPropertySetName : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPropertySetElementFailures Class


BuiltInFailures.PropertySetElementFailures.NonStringParameterValue Property

BuiltInFailuresPropertySetElementFailuresNonStringParameterValue Property

The given parameter requires a string value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NonStringParameterValue { get; }
Public Shared ReadOnly Property NonStringParameterValue As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NonStringParameterValue {
    FailureDefinitionId^ get ();
}
static member NonStringParameterValue : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPropertySetElementFailures Class


BuiltInFailures.PropertySetElementFailures.NonUniquePropertySetName Property

BuiltInFailuresPropertySetElementFailuresNonUniquePropertySetName Property

The value of the given parameter is already in use as a property set name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NonUniquePropertySetName { get; }
Public Shared ReadOnly Property NonUniquePropertySetName As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NonUniquePropertySetName {
    FailureDefinitionId^ get ();
}
static member NonUniquePropertySetName : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresPropertySetElementFailures Class


BuiltInFailures.RebarBendingDetailFailures Class

BuiltInFailuresRebarBendingDetailFailures Class

Failures concerning rebar bending details.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresRebarBendingDetailFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class RebarBendingDetailFailures
Public NotInheritable Class RebarBendingDetailFailures
public ref class RebarBendingDetailFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type RebarBendingDetailFailures = class end

The BuiltInFailuresRebarBendingDetailFailures type exposes the following members.

Properties
Name | Description
RemoveBendingDetailWithInvalidRebarElement | The reinforcement element is no longer supporting bending details. The associated bending detail elements have been deleted.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RebarBendingDetailFailures Properties

The BuiltInFailuresRebarBendingDetailFailures type exposes the following members.

Properties
Name | Description
RemoveBendingDetailWithInvalidRebarElement | The reinforcement element is no longer supporting bending details. The associated bending detail elements have been deleted.
Top
See Also

Reference

BuiltInFailuresRebarBendingDetailFailures Class


BuiltInFailures.RebarBendingDetailFailures.RemoveBendingDetailWithInvalidRebarElement Property

BuiltInFailuresRebarBendingDetailFailuresRemoveBendingDetailWithInvalidRebarElement Property

The reinforcement element is no longer supporting bending details. The associated bending detail elements have been deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RemoveBendingDetailWithInvalidRebarElement { get; }
Public Shared ReadOnly Property RemoveBendingDetailWithInvalidRebarElement As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RemoveBendingDetailWithInvalidRebarElement {
    FailureDefinitionId^ get ();
}
static member RemoveBendingDetailWithInvalidRebarElement : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarBendingDetailFailures Class


BuiltInFailures.RebarCouplerFailures Class

BuiltInFailuresRebarCouplerFailures Class

Failures concerning couplers
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresRebarCouplerFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class RebarCouplerFailures
Public NotInheritable Class RebarCouplerFailures
public ref class RebarCouplerFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type RebarCouplerFailures = class end

The BuiltInFailuresRebarCouplerFailures type exposes the following members.

Properties
Name | Description
CantKeepConstraintsToBars | The constraints between the coupler and the two connected bars are no longer satisfied. Post error to delete the coupler.
CouplerRequiredRemoveFromGroup | The coupler is invalid in group.
CouplerTypeInvalid | This coupler type does not fit on the selected bar(s). Post error to delete the coupler.
DisconnectElements | Disconnect the coupler from the connected bar.
DistanceBetweenBarsError | This is used to post error. The distance between the connected ends of the bars exceeds 10 bar diameters.
DistanceBetweenBarsWarning | This is used to post warning. The distance between the connected ends of the bars exceeds 10 bar diameters.
EngagementBiggerThanLengthError | This is used to post error. The sum of bar engagements is greater than the total coupler length.
EngagementBiggerThanLengthWarning | This is used to post warning. The sum of bar engagements is greater than the total coupler length.
LengthParameterError | This is used to post error. The "Total Length" parameter must be set to a strictly positive value.
LengthParameterWarning | This is used to post warning. The "Total Length" parameter must be set to a strictly positive value.
MainEngagementParameterError | This is used to post error. "Bar Engagement 1" has an incorrect value.
MainEngagementParameterWarning | This is used to post warning. "Bar Engagement 1" has an incorrect value.
NewCouplerTypeCreated | A new coupler type was automatically created to fit the bar diameters.
NoBarSizeError | This is used to post error. At least Bar Size 1 or Bar Size 2 should have another value than "None".
NoBarSizeWarning | This is used to post warning. At least Bar Size 1 or Bar Size 2 should have a value other than "None".
NoTypeParamsDefinedWarning | The parameters of the default type have no values.
SecondaryEngagementParameterError | This is used to post error. "Bar Engagement 2" has an incorrect value.
SecondaryEngagementParameterWarning | This is used to post warning. "Bar Engagement 2" has an incorrect value.
WidthParameterError | This is used to post error.The "External Diameter" parameter must be set to a strictly positive value.
WidthParameterWarning | This is used to post warning. The "External Diameter" parameter must be set to a strictly positive value.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RebarCouplerFailures Properties

The BuiltInFailuresRebarCouplerFailures type exposes the following members.

Properties
Name | Description
CantKeepConstraintsToBars | The constraints between the coupler and the two connected bars are no longer satisfied. Post error to delete the coupler.
CouplerRequiredRemoveFromGroup | The coupler is invalid in group.
CouplerTypeInvalid | This coupler type does not fit on the selected bar(s). Post error to delete the coupler.
DisconnectElements | Disconnect the coupler from the connected bar.
DistanceBetweenBarsError | This is used to post error. The distance between the connected ends of the bars exceeds 10 bar diameters.
DistanceBetweenBarsWarning | This is used to post warning. The distance between the connected ends of the bars exceeds 10 bar diameters.
EngagementBiggerThanLengthError | This is used to post error. The sum of bar engagements is greater than the total coupler length.
EngagementBiggerThanLengthWarning | This is used to post warning. The sum of bar engagements is greater than the total coupler length.
LengthParameterError | This is used to post error. The "Total Length" parameter must be set to a strictly positive value.
LengthParameterWarning | This is used to post warning. The "Total Length" parameter must be set to a strictly positive value.
MainEngagementParameterError | This is used to post error. "Bar Engagement 1" has an incorrect value.
MainEngagementParameterWarning | This is used to post warning. "Bar Engagement 1" has an incorrect value.
NewCouplerTypeCreated | A new coupler type was automatically created to fit the bar diameters.
NoBarSizeError | This is used to post error. At least Bar Size 1 or Bar Size 2 should have another value than "None".
NoBarSizeWarning | This is used to post warning. At least Bar Size 1 or Bar Size 2 should have a value other than "None".
NoTypeParamsDefinedWarning | The parameters of the default type have no values.
SecondaryEngagementParameterError | This is used to post error. "Bar Engagement 2" has an incorrect value.
SecondaryEngagementParameterWarning | This is used to post warning. "Bar Engagement 2" has an incorrect value.
WidthParameterError | This is used to post error.The "External Diameter" parameter must be set to a strictly positive value.
WidthParameterWarning | This is used to post warning. The "External Diameter" parameter must be set to a strictly positive value.
Top
See Also

Reference

BuiltInFailuresRebarCouplerFailures Class


BuiltInFailures.RebarCouplerFailures.CantKeepConstraintsToBars Property

BuiltInFailuresRebarCouplerFailuresCantKeepConstraintsToBars Property

The constraints between the coupler and the two connected bars are no longer satisfied. Post error to delete the coupler.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CantKeepConstraintsToBars { get; }
Public Shared ReadOnly Property CantKeepConstraintsToBars As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CantKeepConstraintsToBars {
    FailureDefinitionId^ get ();
}
static member CantKeepConstraintsToBars : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarCouplerFailures Class


BuiltInFailures.RebarCouplerFailures.CouplerRequiredRemoveFromGroup Property

BuiltInFailuresRebarCouplerFailuresCouplerRequiredRemoveFromGroup Property

The coupler is invalid in group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CouplerRequiredRemoveFromGroup { get; }
Public Shared ReadOnly Property CouplerRequiredRemoveFromGroup As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CouplerRequiredRemoveFromGroup {
    FailureDefinitionId^ get ();
}
static member CouplerRequiredRemoveFromGroup : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarCouplerFailures Class


BuiltInFailures.RebarCouplerFailures.CouplerTypeInvalid Property

BuiltInFailuresRebarCouplerFailuresCouplerTypeInvalid Property

This coupler type does not fit on the selected bar(s). Post error to delete the coupler.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CouplerTypeInvalid { get; }
Public Shared ReadOnly Property CouplerTypeInvalid As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CouplerTypeInvalid {
    FailureDefinitionId^ get ();
}
static member CouplerTypeInvalid : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarCouplerFailures Class


BuiltInFailures.RebarCouplerFailures.DisconnectElements Property

BuiltInFailuresRebarCouplerFailuresDisconnectElements Property

Disconnect the coupler from the connected bar.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DisconnectElements { get; }
Public Shared ReadOnly Property DisconnectElements As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DisconnectElements {
    FailureDefinitionId^ get ();
}
static member DisconnectElements : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarCouplerFailures Class


BuiltInFailures.RebarCouplerFailures.DistanceBetweenBarsError Property

BuiltInFailuresRebarCouplerFailuresDistanceBetweenBarsError Property

This is used to post error. The distance between the connected ends of the bars exceeds 10 bar diameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DistanceBetweenBarsError { get; }
Public Shared ReadOnly Property DistanceBetweenBarsError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DistanceBetweenBarsError {
    FailureDefinitionId^ get ();
}
static member DistanceBetweenBarsError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarCouplerFailures Class


BuiltInFailures.RebarCouplerFailures.DistanceBetweenBarsWarning Property

BuiltInFailuresRebarCouplerFailuresDistanceBetweenBarsWarning Property

This is used to post warning. The distance between the connected ends of the bars exceeds 10 bar diameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DistanceBetweenBarsWarning { get; }
Public Shared ReadOnly Property DistanceBetweenBarsWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DistanceBetweenBarsWarning {
    FailureDefinitionId^ get ();
}
static member DistanceBetweenBarsWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarCouplerFailures Class


BuiltInFailures.RebarCouplerFailures.EngagementBiggerThanLengthError Property

BuiltInFailuresRebarCouplerFailuresEngagementBiggerThanLengthError Property

This is used to post error. The sum of bar engagements is greater than the total coupler length.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId EngagementBiggerThanLengthError { get; }
Public Shared ReadOnly Property EngagementBiggerThanLengthError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ EngagementBiggerThanLengthError {
    FailureDefinitionId^ get ();
}
static member EngagementBiggerThanLengthError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarCouplerFailures Class


BuiltInFailures.RebarCouplerFailures.EngagementBiggerThanLengthWarning Property

BuiltInFailuresRebarCouplerFailuresEngagementBiggerThanLengthWarning Property

This is used to post warning. The sum of bar engagements is greater than the total coupler length.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId EngagementBiggerThanLengthWarning { get; }
Public Shared ReadOnly Property EngagementBiggerThanLengthWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ EngagementBiggerThanLengthWarning {
    FailureDefinitionId^ get ();
}
static member EngagementBiggerThanLengthWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarCouplerFailures Class


BuiltInFailures.RebarCouplerFailures.LengthParameterError Property

BuiltInFailuresRebarCouplerFailuresLengthParameterError Property

This is used to post error. The "Total Length" parameter must be set to a strictly positive value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LengthParameterError { get; }
Public Shared ReadOnly Property LengthParameterError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LengthParameterError {
    FailureDefinitionId^ get ();
}
static member LengthParameterError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarCouplerFailures Class


BuiltInFailures.RebarCouplerFailures.LengthParameterWarning Property

BuiltInFailuresRebarCouplerFailuresLengthParameterWarning Property

This is used to post warning. The "Total Length" parameter must be set to a strictly positive value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LengthParameterWarning { get; }
Public Shared ReadOnly Property LengthParameterWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LengthParameterWarning {
    FailureDefinitionId^ get ();
}
static member LengthParameterWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarCouplerFailures Class


BuiltInFailures.RebarCouplerFailures.MainEngagementParameterError Property

BuiltInFailuresRebarCouplerFailuresMainEngagementParameterError Property

This is used to post error. "Bar Engagement 1" has an incorrect value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MainEngagementParameterError { get; }
Public Shared ReadOnly Property MainEngagementParameterError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MainEngagementParameterError {
    FailureDefinitionId^ get ();
}
static member MainEngagementParameterError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarCouplerFailures Class


BuiltInFailures.RebarCouplerFailures.MainEngagementParameterWarning Property

BuiltInFailuresRebarCouplerFailuresMainEngagementParameterWarning Property

This is used to post warning. "Bar Engagement 1" has an incorrect value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MainEngagementParameterWarning { get; }
Public Shared ReadOnly Property MainEngagementParameterWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MainEngagementParameterWarning {
    FailureDefinitionId^ get ();
}
static member MainEngagementParameterWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarCouplerFailures Class


BuiltInFailures.RebarCouplerFailures.NewCouplerTypeCreated Property

BuiltInFailuresRebarCouplerFailuresNewCouplerTypeCreated Property

A new coupler type was automatically created to fit the bar diameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NewCouplerTypeCreated { get; }
Public Shared ReadOnly Property NewCouplerTypeCreated As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NewCouplerTypeCreated {
    FailureDefinitionId^ get ();
}
static member NewCouplerTypeCreated : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarCouplerFailures Class


BuiltInFailures.RebarCouplerFailures.NoBarSizeError Property

BuiltInFailuresRebarCouplerFailuresNoBarSizeError Property

This is used to post error. At least Bar Size 1 or Bar Size 2 should have another value than "None".

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoBarSizeError { get; }
Public Shared ReadOnly Property NoBarSizeError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoBarSizeError {
    FailureDefinitionId^ get ();
}
static member NoBarSizeError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarCouplerFailures Class


BuiltInFailures.RebarCouplerFailures.NoBarSizeWarning Property

BuiltInFailuresRebarCouplerFailuresNoBarSizeWarning Property

This is used to post warning. At least Bar Size 1 or Bar Size 2 should have a value other than "None".

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoBarSizeWarning { get; }
Public Shared ReadOnly Property NoBarSizeWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoBarSizeWarning {
    FailureDefinitionId^ get ();
}
static member NoBarSizeWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarCouplerFailures Class


BuiltInFailures.RebarCouplerFailures.NoTypeParamsDefinedWarning Property

BuiltInFailuresRebarCouplerFailuresNoTypeParamsDefinedWarning Property

The parameters of the default type have no values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoTypeParamsDefinedWarning { get; }
Public Shared ReadOnly Property NoTypeParamsDefinedWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoTypeParamsDefinedWarning {
    FailureDefinitionId^ get ();
}
static member NoTypeParamsDefinedWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarCouplerFailures Class


BuiltInFailures.RebarCouplerFailures.SecondaryEngagementParameterError Property

BuiltInFailuresRebarCouplerFailuresSecondaryEngagementParameterError Property

This is used to post error. "Bar Engagement 2" has an incorrect value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SecondaryEngagementParameterError { get; }
Public Shared ReadOnly Property SecondaryEngagementParameterError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SecondaryEngagementParameterError {
    FailureDefinitionId^ get ();
}
static member SecondaryEngagementParameterError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarCouplerFailures Class


BuiltInFailures.RebarCouplerFailures.SecondaryEngagementParameterWarning Property

BuiltInFailuresRebarCouplerFailuresSecondaryEngagementParameterWarning Property

This is used to post warning. "Bar Engagement 2" has an incorrect value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SecondaryEngagementParameterWarning { get; }
Public Shared ReadOnly Property SecondaryEngagementParameterWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SecondaryEngagementParameterWarning {
    FailureDefinitionId^ get ();
}
static member SecondaryEngagementParameterWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarCouplerFailures Class


BuiltInFailures.RebarCouplerFailures.WidthParameterError Property

BuiltInFailuresRebarCouplerFailuresWidthParameterError Property

This is used to post error.The "External Diameter" parameter must be set to a strictly positive value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WidthParameterError { get; }
Public Shared ReadOnly Property WidthParameterError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WidthParameterError {
    FailureDefinitionId^ get ();
}
static member WidthParameterError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarCouplerFailures Class


BuiltInFailures.RebarCouplerFailures.WidthParameterWarning Property

BuiltInFailuresRebarCouplerFailuresWidthParameterWarning Property

This is used to post warning. The "External Diameter" parameter must be set to a strictly positive value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WidthParameterWarning { get; }
Public Shared ReadOnly Property WidthParameterWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WidthParameterWarning {
    FailureDefinitionId^ get ();
}
static member WidthParameterWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarCouplerFailures Class


BuiltInFailures.RebarFailures Class

BuiltInFailuresRebarFailures Class

Failures about Rebar.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresRebarFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class RebarFailures
Public NotInheritable Class RebarFailures
public ref class RebarFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type RebarFailures = class end

The BuiltInFailuresRebarFailures type exposes the following members.

Properties
Name | Description
BarDiameterTooLarge | Rebar Bar Diameter is too large.
BarTypeDoesNotAllowHooksOfCurrentShape | You have selected a Bar Type which does not allow the Hooks used by the current shape. Please select a different Shape / Bar Type combination, or change the Hook permissions for the desired Bar Type (see Hook Lengths under Rebar Bar properties).
BendDiameterTooLarge | Rebar Bend Diameter is too large.
BendDiameterTooSmall | Rebar Bend Diameter is too small.
CannotCreateFreeFormSetDueToShortBar | Cannot create the rebar set using the current references because at least one bar is below the minimum allowed length. Edit the covers and extents of the set and try the desired layout options again.
CannotKeepVariabilityOfRebarInGroup | Modifications to the rebar set might cause it to revert to a uniform distribution and reset all disabled constraints. This can occur for layout changes as well as modifications to the geometry.
CannotPlaceRebar | Can't find a host for Rebar.
CannotPlaceRebarWarn | Can't find a host for Rebar.
CannotSolveRebarShapeUsingDataFromDimension | Cannot solve rebar shape using the current constraints.
CannotSolveRebarWithDelayedConstraints | There are rebar handles with invalid selected targets to constrain. The bar preview corresponds to latest valid constraints.
CantMakeFillets | The bar cannot be bent in that shape. Check the bending diameter and the bar type.
ChangeUnitsFormatWarn | The modification of the unit will cause the change of the Reinforcement rounding format. Do you want to continue?
ClearPresentationForAllBarsInRebarSet | All Bars in a Free Form Rebar Set have been hidden.
ConstraintForHandleIsDisabled | The constriant for current handle is disabled.
CoverTooLong | Rebar Cover length is too large for host thickness.
DelayedConstraintForHandle | The selected constraint targets do not satisfy a valid constraint. The rebar preview corresponds to latest valid rebar constraints.
HideAllBarsInRebarSet | All Bars in Rebar Set have been hidden.
HostTopologyChange | A reinforced host has undergone a major change. The reinforcement must be removed.
IncompleteShape | Rebar Shape [Family Name] is not fully defined and cannot be loaded into the project.
InvalidRebarHost | Rebar can be placed only in Concrete Structural elements.
InvalidRebarHostFamilyCanHostRebarParam | Rebar can't be placed in this Generic Model element because rebar hosting is disabled in the family [Name].
InvalidRebarHostNonConcrete | Rebar can't be placed in a structural family unless its [Material Type] is [Concrete].
InvalidRebarHostNonStructural | Rebar can't be placed in a non-structural element.
InvalidRebarHostWrongCategory | Rebar can't be placed in a family of category [Name].
Inverted3dShape | The Rebar Shape XX cannot be inverted.
MaxHookExtensionMultiplierWarn | The allowable range of values for the Rebar Hook Extension Multiplier is from 0.01 to 99.0.
MissingCurrentConstraintForHandle | The current handle has no constraint. Please select a valid target to apply a new constraint.
NoRebarSelected | At least one Rebar should be selected.
NoSurfPatternOnRebar | Rebar elements do not support surface patterns. The surface pattern associated with this material will not be displayed on the indicated Rebar Type.
NoVisibleRebarHandle | Editing of the constraints for the selected rebar with free form geometry is not available. However, the default automatic constraints may still work.
NoVisibleTargetsForCurrentConstraint | There are no visible constraint targets in the current view. Please switch to another view.
OutOfPlaneBendDiameterTooSmall | The Out of Plane Bend Diameter for Rebar Shape XX is too small for Rebar Bar Type YY.
OutSideOfHost | Rebar is placed completely outside of its host.
PathShapeFailure | Can't solve Rebar Shape in Path Reinforcement.
RebarArrayTooShort | Rebar Set can't have coincident Bars.
RebarBendRadiusTooBig | Rebar Bend Radius is too big. Ignoring bend.
RebarBendRadiusTooBigWarn | Rebar Bend Radius is too big. Ignoring bend.
RebarConstraintWarning | Structural rebar have automatic constraints that may conflict with dimensional constraints. Using dimensional constraints with structural rebar is not recommended and should be avoided.\nGrouped structural rebar is the only exception to this recommendation, since the automatic constraints are removed on grouped rebar.
RebarContainerOutSideOfHostWarning | Rebar Container is placed completely outside of its host.
RebarDimensionalConstraintLost | Dimensional constraint on Rebar element was lost on upgrade.
RebarEndTreatmentOverHook | Cannot set end treatment at an end that has hook.
RebarHookOverEndTreatment | Cannot set hook at an end that has end treatment.
RebarHooksDontMatchShape | The Rebar's hooks do not match its Rebar Shape.
RebarIllegalBarType | There is Structural Rebar present in the project that no longer meet the criteria defined in Allowable Rebar Bar types parameter. Please review all existing Structural Rebar created with this Shape.
RebarInvalidDiameterRemoved | Invalid RebarBarType was removed on upgrade.
RebarMovedBarsOverlapped | There are identical overlapping bars in the rebar set. This will result in double counting in schedules.
RebarNoConstraints | The constraints for the rebar with free form geometry are not set or modifications have caused the automatic constraints to be deleted. You can use Edit Constraints to assign new bar constraints.
RebarNoMatchingHooks | The Rebar Shape '[Family Name]' has no matching hooks.
RebarShapeFailure | Can't solve Rebar Shape.
RebarShapeFailureCustomError | '[ErrorMessage]'
RebarShapeFailureCustomWarning | '[ErrorMessage]'
RebarShapeFailureDueToStaggerOffset | Can't solve Rebar Shape using the exisintg stagger offsets.
RebarSpacingTooSmall | Bar Spacing is too small.
RebarTooShortImperial | The minimum length of rebar shape is 1 inch.
RebarTooShortMetric | The minimum length of rebar shape is 25 mm.
RemoveSpliceBetweenBars | Splice cannot be maintained.
SketchDimensionsRemoved | The sketch dimensions, that were used to create the sketch, have been removed from the completed rebar shape definition.
SketchDimsBWFRemoved | The sketch dimensions, that were used to create the sketch, have been removed from the completed bend profile definition.
SketchFreeFormSet | Sketching of a free form set produces only a single bar.
SketchNonPlanarFreeForm | The selected free form rebar is not planar. Sketching it will discard the current geometry.
SpliceTypeWasDeleted | Splice type was deleted.
StandardHookBendDiameterTooLarge | Rebar Standard Hook Bend Diameter is too large.
StandardHookBendDiameterTooSmall | Rebar Standard Hook Bend Diameter is too small.
TooLargeNumberOfBars | Rebar Set must contain at most 1002 bar locations.
TooSmallNumberOfBars | Rebar Set must contain at least two bar locations.
TrySmallerBarType | Rebar Bend Diameter is too large. Try a smaller Bar Type.
UnconstrainableRebarHandle | The rebar handle does not have any constraint targets.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RebarFailures Properties

The BuiltInFailuresRebarFailures type exposes the following members.

Properties
Name | Description
BarDiameterTooLarge | Rebar Bar Diameter is too large.
BarTypeDoesNotAllowHooksOfCurrentShape | You have selected a Bar Type which does not allow the Hooks used by the current shape. Please select a different Shape / Bar Type combination, or change the Hook permissions for the desired Bar Type (see Hook Lengths under Rebar Bar properties).
BendDiameterTooLarge | Rebar Bend Diameter is too large.
BendDiameterTooSmall | Rebar Bend Diameter is too small.
CannotCreateFreeFormSetDueToShortBar | Cannot create the rebar set using the current references because at least one bar is below the minimum allowed length. Edit the covers and extents of the set and try the desired layout options again.
CannotKeepVariabilityOfRebarInGroup | Modifications to the rebar set might cause it to revert to a uniform distribution and reset all disabled constraints. This can occur for layout changes as well as modifications to the geometry.
CannotPlaceRebar | Can't find a host for Rebar.
CannotPlaceRebarWarn | Can't find a host for Rebar.
CannotSolveRebarShapeUsingDataFromDimension | Cannot solve rebar shape using the current constraints.
CannotSolveRebarWithDelayedConstraints | There are rebar handles with invalid selected targets to constrain. The bar preview corresponds to latest valid constraints.
CantMakeFillets | The bar cannot be bent in that shape. Check the bending diameter and the bar type.
ChangeUnitsFormatWarn | The modification of the unit will cause the change of the Reinforcement rounding format. Do you want to continue?
ClearPresentationForAllBarsInRebarSet | All Bars in a Free Form Rebar Set have been hidden.
ConstraintForHandleIsDisabled | The constriant for current handle is disabled.
CoverTooLong | Rebar Cover length is too large for host thickness.
DelayedConstraintForHandle | The selected constraint targets do not satisfy a valid constraint. The rebar preview corresponds to latest valid rebar constraints.
HideAllBarsInRebarSet | All Bars in Rebar Set have been hidden.
HostTopologyChange | A reinforced host has undergone a major change. The reinforcement must be removed.
IncompleteShape | Rebar Shape [Family Name] is not fully defined and cannot be loaded into the project.
InvalidRebarHost | Rebar can be placed only in Concrete Structural elements.
InvalidRebarHostFamilyCanHostRebarParam | Rebar can't be placed in this Generic Model element because rebar hosting is disabled in the family [Name].
InvalidRebarHostNonConcrete | Rebar can't be placed in a structural family unless its [Material Type] is [Concrete].
InvalidRebarHostNonStructural | Rebar can't be placed in a non-structural element.
InvalidRebarHostWrongCategory | Rebar can't be placed in a family of category [Name].
Inverted3dShape | The Rebar Shape XX cannot be inverted.
MaxHookExtensionMultiplierWarn | The allowable range of values for the Rebar Hook Extension Multiplier is from 0.01 to 99.0.
MissingCurrentConstraintForHandle | The current handle has no constraint. Please select a valid target to apply a new constraint.
NoRebarSelected | At least one Rebar should be selected.
NoSurfPatternOnRebar | Rebar elements do not support surface patterns. The surface pattern associated with this material will not be displayed on the indicated Rebar Type.
NoVisibleRebarHandle | Editing of the constraints for the selected rebar with free form geometry is not available. However, the default automatic constraints may still work.
NoVisibleTargetsForCurrentConstraint | There are no visible constraint targets in the current view. Please switch to another view.
OutOfPlaneBendDiameterTooSmall | The Out of Plane Bend Diameter for Rebar Shape XX is too small for Rebar Bar Type YY.
OutSideOfHost | Rebar is placed completely outside of its host.
PathShapeFailure | Can't solve Rebar Shape in Path Reinforcement.
RebarArrayTooShort | Rebar Set can't have coincident Bars.
RebarBendRadiusTooBig | Rebar Bend Radius is too big. Ignoring bend.
RebarBendRadiusTooBigWarn | Rebar Bend Radius is too big. Ignoring bend.
RebarConstraintWarning | Structural rebar have automatic constraints that may conflict with dimensional constraints. Using dimensional constraints with structural rebar is not recommended and should be avoided.\nGrouped structural rebar is the only exception to this recommendation, since the automatic constraints are removed on grouped rebar.
RebarContainerOutSideOfHostWarning | Rebar Container is placed completely outside of its host.
RebarDimensionalConstraintLost | Dimensional constraint on Rebar element was lost on upgrade.
RebarEndTreatmentOverHook | Cannot set end treatment at an end that has hook.
RebarHookOverEndTreatment | Cannot set hook at an end that has end treatment.
RebarHooksDontMatchShape | The Rebar's hooks do not match its Rebar Shape.
RebarIllegalBarType | There is Structural Rebar present in the project that no longer meet the criteria defined in Allowable Rebar Bar types parameter. Please review all existing Structural Rebar created with this Shape.
RebarInvalidDiameterRemoved | Invalid RebarBarType was removed on upgrade.
RebarMovedBarsOverlapped | There are identical overlapping bars in the rebar set. This will result in double counting in schedules.
RebarNoConstraints | The constraints for the rebar with free form geometry are not set or modifications have caused the automatic constraints to be deleted. You can use Edit Constraints to assign new bar constraints.
RebarNoMatchingHooks | The Rebar Shape '[Family Name]' has no matching hooks.
RebarShapeFailure | Can't solve Rebar Shape.
RebarShapeFailureCustomError | '[ErrorMessage]'
RebarShapeFailureCustomWarning | '[ErrorMessage]'
RebarShapeFailureDueToStaggerOffset | Can't solve Rebar Shape using the exisintg stagger offsets.
RebarSpacingTooSmall | Bar Spacing is too small.
RebarTooShortImperial | The minimum length of rebar shape is 1 inch.
RebarTooShortMetric | The minimum length of rebar shape is 25 mm.
RemoveSpliceBetweenBars | Splice cannot be maintained.
SketchDimensionsRemoved | The sketch dimensions, that were used to create the sketch, have been removed from the completed rebar shape definition.
SketchDimsBWFRemoved | The sketch dimensions, that were used to create the sketch, have been removed from the completed bend profile definition.
SketchFreeFormSet | Sketching of a free form set produces only a single bar.
SketchNonPlanarFreeForm | The selected free form rebar is not planar. Sketching it will discard the current geometry.
SpliceTypeWasDeleted | Splice type was deleted.
StandardHookBendDiameterTooLarge | Rebar Standard Hook Bend Diameter is too large.
StandardHookBendDiameterTooSmall | Rebar Standard Hook Bend Diameter is too small.
TooLargeNumberOfBars | Rebar Set must contain at most 1002 bar locations.
TooSmallNumberOfBars | Rebar Set must contain at least two bar locations.
TrySmallerBarType | Rebar Bend Diameter is too large. Try a smaller Bar Type.
UnconstrainableRebarHandle | The rebar handle does not have any constraint targets.
Top
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.BarDiameterTooLarge Property

BuiltInFailuresRebarFailuresBarDiameterTooLarge Property

Rebar Bar Diameter is too large.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BarDiameterTooLarge { get; }
Public Shared ReadOnly Property BarDiameterTooLarge As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BarDiameterTooLarge {
    FailureDefinitionId^ get ();
}
static member BarDiameterTooLarge : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.BarTypeDoesNotAllowHooksOfCurrentShape Property

BuiltInFailuresRebarFailuresBarTypeDoesNotAllowHooksOfCurrentShape Property

You have selected a Bar Type which does not allow the Hooks used by the current shape. Please select a different Shape / Bar Type combination, or change the Hook permissions for the desired Bar Type (see Hook Lengths under Rebar Bar properties).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BarTypeDoesNotAllowHooksOfCurrentShape { get; }
Public Shared ReadOnly Property BarTypeDoesNotAllowHooksOfCurrentShape As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BarTypeDoesNotAllowHooksOfCurrentShape {
    FailureDefinitionId^ get ();
}
static member BarTypeDoesNotAllowHooksOfCurrentShape : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.BendDiameterTooLarge Property

BuiltInFailuresRebarFailuresBendDiameterTooLarge Property

Rebar Bend Diameter is too large.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BendDiameterTooLarge { get; }
Public Shared ReadOnly Property BendDiameterTooLarge As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BendDiameterTooLarge {
    FailureDefinitionId^ get ();
}
static member BendDiameterTooLarge : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.BendDiameterTooSmall Property

BuiltInFailuresRebarFailuresBendDiameterTooSmall Property

Rebar Bend Diameter is too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BendDiameterTooSmall { get; }
Public Shared ReadOnly Property BendDiameterTooSmall As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BendDiameterTooSmall {
    FailureDefinitionId^ get ();
}
static member BendDiameterTooSmall : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.CannotCreateFreeFormSetDueToShortBar Property

BuiltInFailuresRebarFailuresCannotCreateFreeFormSetDueToShortBar Property

Cannot create the rebar set using the current references because at least one bar is below the minimum allowed length. Edit the covers and extents of the set and try the desired layout options again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateFreeFormSetDueToShortBar { get; }
Public Shared ReadOnly Property CannotCreateFreeFormSetDueToShortBar As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateFreeFormSetDueToShortBar {
    FailureDefinitionId^ get ();
}
static member CannotCreateFreeFormSetDueToShortBar : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.CannotKeepVariabilityOfRebarInGroup Property

BuiltInFailuresRebarFailuresCannotKeepVariabilityOfRebarInGroup Property

Modifications to the rebar set might cause it to revert to a uniform distribution and reset all disabled constraints. This can occur for layout changes as well as modifications to the geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotKeepVariabilityOfRebarInGroup { get; }
Public Shared ReadOnly Property CannotKeepVariabilityOfRebarInGroup As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotKeepVariabilityOfRebarInGroup {
    FailureDefinitionId^ get ();
}
static member CannotKeepVariabilityOfRebarInGroup : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.CannotPlaceRebar Property

BuiltInFailuresRebarFailuresCannotPlaceRebar Property

Can't find a host for Rebar.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPlaceRebar { get; }
Public Shared ReadOnly Property CannotPlaceRebar As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPlaceRebar {
    FailureDefinitionId^ get ();
}
static member CannotPlaceRebar : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.CannotPlaceRebarWarn Property

BuiltInFailuresRebarFailuresCannotPlaceRebarWarn Property

Can't find a host for Rebar.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPlaceRebarWarn { get; }
Public Shared ReadOnly Property CannotPlaceRebarWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPlaceRebarWarn {
    FailureDefinitionId^ get ();
}
static member CannotPlaceRebarWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.CannotSolveRebarShapeUsingDataFromDimension Property

BuiltInFailuresRebarFailuresCannotSolveRebarShapeUsingDataFromDimension Property

Cannot solve rebar shape using the current constraints.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotSolveRebarShapeUsingDataFromDimension { get; }
Public Shared ReadOnly Property CannotSolveRebarShapeUsingDataFromDimension As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotSolveRebarShapeUsingDataFromDimension {
    FailureDefinitionId^ get ();
}
static member CannotSolveRebarShapeUsingDataFromDimension : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.CannotSolveRebarWithDelayedConstraints Property

BuiltInFailuresRebarFailuresCannotSolveRebarWithDelayedConstraints Property

There are rebar handles with invalid selected targets to constrain. The bar preview corresponds to latest valid constraints.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotSolveRebarWithDelayedConstraints { get; }
Public Shared ReadOnly Property CannotSolveRebarWithDelayedConstraints As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotSolveRebarWithDelayedConstraints {
    FailureDefinitionId^ get ();
}
static member CannotSolveRebarWithDelayedConstraints : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.CantMakeFillets Property

BuiltInFailuresRebarFailuresCantMakeFillets Property

The bar cannot be bent in that shape. Check the bending diameter and the bar type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CantMakeFillets { get; }
Public Shared ReadOnly Property CantMakeFillets As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CantMakeFillets {
    FailureDefinitionId^ get ();
}
static member CantMakeFillets : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.ChangeUnitsFormatWarn Property

BuiltInFailuresRebarFailuresChangeUnitsFormatWarn Property

The modification of the unit will cause the change of the Reinforcement rounding format. Do you want to continue?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ChangeUnitsFormatWarn { get; }
Public Shared ReadOnly Property ChangeUnitsFormatWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ChangeUnitsFormatWarn {
    FailureDefinitionId^ get ();
}
static member ChangeUnitsFormatWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.ClearPresentationForAllBarsInRebarSet Property

BuiltInFailuresRebarFailuresClearPresentationForAllBarsInRebarSet Property

All Bars in a Free Form Rebar Set have been hidden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ClearPresentationForAllBarsInRebarSet { get; }
Public Shared ReadOnly Property ClearPresentationForAllBarsInRebarSet As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ClearPresentationForAllBarsInRebarSet {
    FailureDefinitionId^ get ();
}
static member ClearPresentationForAllBarsInRebarSet : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.ConstraintForHandleIsDisabled Property

BuiltInFailuresRebarFailuresConstraintForHandleIsDisabled Property

The constriant for current handle is disabled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ConstraintForHandleIsDisabled { get; }
Public Shared ReadOnly Property ConstraintForHandleIsDisabled As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ConstraintForHandleIsDisabled {
    FailureDefinitionId^ get ();
}
static member ConstraintForHandleIsDisabled : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.CoverTooLong Property

BuiltInFailuresRebarFailuresCoverTooLong Property

Rebar Cover length is too large for host thickness.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CoverTooLong { get; }
Public Shared ReadOnly Property CoverTooLong As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CoverTooLong {
    FailureDefinitionId^ get ();
}
static member CoverTooLong : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.DelayedConstraintForHandle Property

BuiltInFailuresRebarFailuresDelayedConstraintForHandle Property

The selected constraint targets do not satisfy a valid constraint. The rebar preview corresponds to latest valid rebar constraints.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DelayedConstraintForHandle { get; }
Public Shared ReadOnly Property DelayedConstraintForHandle As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DelayedConstraintForHandle {
    FailureDefinitionId^ get ();
}
static member DelayedConstraintForHandle : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.HideAllBarsInRebarSet Property

BuiltInFailuresRebarFailuresHideAllBarsInRebarSet Property

All Bars in Rebar Set have been hidden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId HideAllBarsInRebarSet { get; }
Public Shared ReadOnly Property HideAllBarsInRebarSet As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ HideAllBarsInRebarSet {
    FailureDefinitionId^ get ();
}
static member HideAllBarsInRebarSet : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.HostTopologyChange Property

BuiltInFailuresRebarFailuresHostTopologyChange Property

A reinforced host has undergone a major change. The reinforcement must be removed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId HostTopologyChange { get; }
Public Shared ReadOnly Property HostTopologyChange As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ HostTopologyChange {
    FailureDefinitionId^ get ();
}
static member HostTopologyChange : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.IncompleteShape Property

BuiltInFailuresRebarFailuresIncompleteShape Property

Rebar Shape [Family Name] is not fully defined and cannot be loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId IncompleteShape { get; }
Public Shared ReadOnly Property IncompleteShape As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ IncompleteShape {
    FailureDefinitionId^ get ();
}
static member IncompleteShape : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.InvalidRebarHost Property

BuiltInFailuresRebarFailuresInvalidRebarHost Property

Rebar can be placed only in Concrete Structural elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidRebarHost { get; }
Public Shared ReadOnly Property InvalidRebarHost As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidRebarHost {
    FailureDefinitionId^ get ();
}
static member InvalidRebarHost : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.InvalidRebarHostFamilyCanHostRebarParam Property

BuiltInFailuresRebarFailuresInvalidRebarHostFamilyCanHostRebarParam Property

Rebar can't be placed in this Generic Model element because rebar hosting is disabled in the family [Name].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidRebarHostFamilyCanHostRebarParam { get; }
Public Shared ReadOnly Property InvalidRebarHostFamilyCanHostRebarParam As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidRebarHostFamilyCanHostRebarParam {
    FailureDefinitionId^ get ();
}
static member InvalidRebarHostFamilyCanHostRebarParam : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.InvalidRebarHostNonConcrete Property

BuiltInFailuresRebarFailuresInvalidRebarHostNonConcrete Property

Rebar can't be placed in a structural family unless its [Material Type] is [Concrete].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidRebarHostNonConcrete { get; }
Public Shared ReadOnly Property InvalidRebarHostNonConcrete As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidRebarHostNonConcrete {
    FailureDefinitionId^ get ();
}
static member InvalidRebarHostNonConcrete : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.InvalidRebarHostNonStructural Property

BuiltInFailuresRebarFailuresInvalidRebarHostNonStructural Property

Rebar can't be placed in a non-structural element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidRebarHostNonStructural { get; }
Public Shared ReadOnly Property InvalidRebarHostNonStructural As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidRebarHostNonStructural {
    FailureDefinitionId^ get ();
}
static member InvalidRebarHostNonStructural : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.InvalidRebarHostWrongCategory Property

BuiltInFailuresRebarFailuresInvalidRebarHostWrongCategory Property

Rebar can't be placed in a family of category [Name].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidRebarHostWrongCategory { get; }
Public Shared ReadOnly Property InvalidRebarHostWrongCategory As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidRebarHostWrongCategory {
    FailureDefinitionId^ get ();
}
static member InvalidRebarHostWrongCategory : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.Inverted3dShape Property

BuiltInFailuresRebarFailuresInverted3dShape Property

The Rebar Shape XX cannot be inverted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId Inverted3dShape { get; }
Public Shared ReadOnly Property Inverted3dShape As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ Inverted3dShape {
    FailureDefinitionId^ get ();
}
static member Inverted3dShape : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.MaxHookExtensionMultiplierWarn Property

BuiltInFailuresRebarFailuresMaxHookExtensionMultiplierWarn Property

The allowable range of values for the Rebar Hook Extension Multiplier is from 0.01 to 99.0.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MaxHookExtensionMultiplierWarn { get; }
Public Shared ReadOnly Property MaxHookExtensionMultiplierWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MaxHookExtensionMultiplierWarn {
    FailureDefinitionId^ get ();
}
static member MaxHookExtensionMultiplierWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.MissingCurrentConstraintForHandle Property

BuiltInFailuresRebarFailuresMissingCurrentConstraintForHandle Property

The current handle has no constraint. Please select a valid target to apply a new constraint.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MissingCurrentConstraintForHandle { get; }
Public Shared ReadOnly Property MissingCurrentConstraintForHandle As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MissingCurrentConstraintForHandle {
    FailureDefinitionId^ get ();
}
static member MissingCurrentConstraintForHandle : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.NoRebarSelected Property

BuiltInFailuresRebarFailuresNoRebarSelected Property

At least one Rebar should be selected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoRebarSelected { get; }
Public Shared ReadOnly Property NoRebarSelected As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoRebarSelected {
    FailureDefinitionId^ get ();
}
static member NoRebarSelected : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.NoSurfPatternOnRebar Property

BuiltInFailuresRebarFailuresNoSurfPatternOnRebar Property

Rebar elements do not support surface patterns. The surface pattern associated with this material will not be displayed on the indicated Rebar Type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoSurfPatternOnRebar { get; }
Public Shared ReadOnly Property NoSurfPatternOnRebar As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoSurfPatternOnRebar {
    FailureDefinitionId^ get ();
}
static member NoSurfPatternOnRebar : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.NoVisibleRebarHandle Property

BuiltInFailuresRebarFailuresNoVisibleRebarHandle Property

Editing of the constraints for the selected rebar with free form geometry is not available. However, the default automatic constraints may still work.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoVisibleRebarHandle { get; }
Public Shared ReadOnly Property NoVisibleRebarHandle As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoVisibleRebarHandle {
    FailureDefinitionId^ get ();
}
static member NoVisibleRebarHandle : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.NoVisibleTargetsForCurrentConstraint Property

BuiltInFailuresRebarFailuresNoVisibleTargetsForCurrentConstraint Property

There are no visible constraint targets in the current view. Please switch to another view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoVisibleTargetsForCurrentConstraint { get; }
Public Shared ReadOnly Property NoVisibleTargetsForCurrentConstraint As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoVisibleTargetsForCurrentConstraint {
    FailureDefinitionId^ get ();
}
static member NoVisibleTargetsForCurrentConstraint : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.OutOfPlaneBendDiameterTooSmall Property

BuiltInFailuresRebarFailuresOutOfPlaneBendDiameterTooSmall Property

The Out of Plane Bend Diameter for Rebar Shape XX is too small for Rebar Bar Type YY.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId OutOfPlaneBendDiameterTooSmall { get; }
Public Shared ReadOnly Property OutOfPlaneBendDiameterTooSmall As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ OutOfPlaneBendDiameterTooSmall {
    FailureDefinitionId^ get ();
}
static member OutOfPlaneBendDiameterTooSmall : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.OutSideOfHost Property

BuiltInFailuresRebarFailuresOutSideOfHost Property

Rebar is placed completely outside of its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId OutSideOfHost { get; }
Public Shared ReadOnly Property OutSideOfHost As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ OutSideOfHost {
    FailureDefinitionId^ get ();
}
static member OutSideOfHost : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.PathShapeFailure Property

BuiltInFailuresRebarFailuresPathShapeFailure Property

Can't solve Rebar Shape in Path Reinforcement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PathShapeFailure { get; }
Public Shared ReadOnly Property PathShapeFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PathShapeFailure {
    FailureDefinitionId^ get ();
}
static member PathShapeFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.RebarArrayTooShort Property

BuiltInFailuresRebarFailuresRebarArrayTooShort Property

Rebar Set can't have coincident Bars.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RebarArrayTooShort { get; }
Public Shared ReadOnly Property RebarArrayTooShort As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RebarArrayTooShort {
    FailureDefinitionId^ get ();
}
static member RebarArrayTooShort : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.RebarBendRadiusTooBig Property

BuiltInFailuresRebarFailuresRebarBendRadiusTooBig Property

Rebar Bend Radius is too big. Ignoring bend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RebarBendRadiusTooBig { get; }
Public Shared ReadOnly Property RebarBendRadiusTooBig As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RebarBendRadiusTooBig {
    FailureDefinitionId^ get ();
}
static member RebarBendRadiusTooBig : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.RebarBendRadiusTooBigWarn Property

BuiltInFailuresRebarFailuresRebarBendRadiusTooBigWarn Property

Rebar Bend Radius is too big. Ignoring bend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RebarBendRadiusTooBigWarn { get; }
Public Shared ReadOnly Property RebarBendRadiusTooBigWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RebarBendRadiusTooBigWarn {
    FailureDefinitionId^ get ();
}
static member RebarBendRadiusTooBigWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.RebarConstraintWarning Property

BuiltInFailuresRebarFailuresRebarConstraintWarning Property

Structural rebar have automatic constraints that may conflict with dimensional constraints. Using dimensional constraints with structural rebar is not recommended and should be avoided.\nGrouped structural rebar is the only exception to this recommendation, since the automatic constraints are removed on grouped rebar.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RebarConstraintWarning { get; }
Public Shared ReadOnly Property RebarConstraintWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RebarConstraintWarning {
    FailureDefinitionId^ get ();
}
static member RebarConstraintWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.RebarContainerOutSideOfHostWarning Property

BuiltInFailuresRebarFailuresRebarContainerOutSideOfHostWarning Property

Rebar Container is placed completely outside of its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RebarContainerOutSideOfHostWarning { get; }
Public Shared ReadOnly Property RebarContainerOutSideOfHostWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RebarContainerOutSideOfHostWarning {
    FailureDefinitionId^ get ();
}
static member RebarContainerOutSideOfHostWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.RebarDimensionalConstraintLost Property

BuiltInFailuresRebarFailuresRebarDimensionalConstraintLost Property

Dimensional constraint on Rebar element was lost on upgrade.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RebarDimensionalConstraintLost { get; }
Public Shared ReadOnly Property RebarDimensionalConstraintLost As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RebarDimensionalConstraintLost {
    FailureDefinitionId^ get ();
}
static member RebarDimensionalConstraintLost : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.RebarEndTreatmentOverHook Property

BuiltInFailuresRebarFailuresRebarEndTreatmentOverHook Property

Cannot set end treatment at an end that has hook.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RebarEndTreatmentOverHook { get; }
Public Shared ReadOnly Property RebarEndTreatmentOverHook As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RebarEndTreatmentOverHook {
    FailureDefinitionId^ get ();
}
static member RebarEndTreatmentOverHook : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.RebarHookOverEndTreatment Property

BuiltInFailuresRebarFailuresRebarHookOverEndTreatment Property

Cannot set hook at an end that has end treatment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RebarHookOverEndTreatment { get; }
Public Shared ReadOnly Property RebarHookOverEndTreatment As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RebarHookOverEndTreatment {
    FailureDefinitionId^ get ();
}
static member RebarHookOverEndTreatment : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.RebarHooksDontMatchShape Property

BuiltInFailuresRebarFailuresRebarHooksDontMatchShape Property

The Rebar's hooks do not match its Rebar Shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RebarHooksDontMatchShape { get; }
Public Shared ReadOnly Property RebarHooksDontMatchShape As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RebarHooksDontMatchShape {
    FailureDefinitionId^ get ();
}
static member RebarHooksDontMatchShape : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.RebarIllegalBarType Property

BuiltInFailuresRebarFailuresRebarIllegalBarType Property

There is Structural Rebar present in the project that no longer meet the criteria defined in Allowable Rebar Bar types parameter. Please review all existing Structural Rebar created with this Shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RebarIllegalBarType { get; }
Public Shared ReadOnly Property RebarIllegalBarType As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RebarIllegalBarType {
    FailureDefinitionId^ get ();
}
static member RebarIllegalBarType : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.RebarInvalidDiameterRemoved Property

BuiltInFailuresRebarFailuresRebarInvalidDiameterRemoved Property

Invalid RebarBarType was removed on upgrade.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RebarInvalidDiameterRemoved { get; }
Public Shared ReadOnly Property RebarInvalidDiameterRemoved As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RebarInvalidDiameterRemoved {
    FailureDefinitionId^ get ();
}
static member RebarInvalidDiameterRemoved : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.RebarMovedBarsOverlapped Property

BuiltInFailuresRebarFailuresRebarMovedBarsOverlapped Property

There are identical overlapping bars in the rebar set. This will result in double counting in schedules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RebarMovedBarsOverlapped { get; }
Public Shared ReadOnly Property RebarMovedBarsOverlapped As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RebarMovedBarsOverlapped {
    FailureDefinitionId^ get ();
}
static member RebarMovedBarsOverlapped : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.RebarNoConstraints Property

BuiltInFailuresRebarFailuresRebarNoConstraints Property

The constraints for the rebar with free form geometry are not set or modifications have caused the automatic constraints to be deleted. You can use Edit Constraints to assign new bar constraints.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RebarNoConstraints { get; }
Public Shared ReadOnly Property RebarNoConstraints As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RebarNoConstraints {
    FailureDefinitionId^ get ();
}
static member RebarNoConstraints : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.RebarNoMatchingHooks Property

BuiltInFailuresRebarFailuresRebarNoMatchingHooks Property

The Rebar Shape '[Family Name]' has no matching hooks.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RebarNoMatchingHooks { get; }
Public Shared ReadOnly Property RebarNoMatchingHooks As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RebarNoMatchingHooks {
    FailureDefinitionId^ get ();
}
static member RebarNoMatchingHooks : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.RebarShapeFailure Property

BuiltInFailuresRebarFailuresRebarShapeFailure Property

Can't solve Rebar Shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RebarShapeFailure { get; }
Public Shared ReadOnly Property RebarShapeFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RebarShapeFailure {
    FailureDefinitionId^ get ();
}
static member RebarShapeFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.RebarShapeFailureCustomError Property

BuiltInFailuresRebarFailuresRebarShapeFailureCustomError Property

'[ErrorMessage]'

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RebarShapeFailureCustomError { get; }
Public Shared ReadOnly Property RebarShapeFailureCustomError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RebarShapeFailureCustomError {
    FailureDefinitionId^ get ();
}
static member RebarShapeFailureCustomError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.RebarShapeFailureCustomWarning Property

BuiltInFailuresRebarFailuresRebarShapeFailureCustomWarning Property

'[ErrorMessage]'

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RebarShapeFailureCustomWarning { get; }
Public Shared ReadOnly Property RebarShapeFailureCustomWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RebarShapeFailureCustomWarning {
    FailureDefinitionId^ get ();
}
static member RebarShapeFailureCustomWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.RebarShapeFailureDueToStaggerOffset Property

BuiltInFailuresRebarFailuresRebarShapeFailureDueToStaggerOffset Property

Can't solve Rebar Shape using the exisintg stagger offsets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RebarShapeFailureDueToStaggerOffset { get; }
Public Shared ReadOnly Property RebarShapeFailureDueToStaggerOffset As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RebarShapeFailureDueToStaggerOffset {
    FailureDefinitionId^ get ();
}
static member RebarShapeFailureDueToStaggerOffset : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.RebarSpacingTooSmall Property

BuiltInFailuresRebarFailuresRebarSpacingTooSmall Property

Bar Spacing is too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RebarSpacingTooSmall { get; }
Public Shared ReadOnly Property RebarSpacingTooSmall As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RebarSpacingTooSmall {
    FailureDefinitionId^ get ();
}
static member RebarSpacingTooSmall : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.RebarTooShortImperial Property

BuiltInFailuresRebarFailuresRebarTooShortImperial Property

The minimum length of rebar shape is 1 inch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RebarTooShortImperial { get; }
Public Shared ReadOnly Property RebarTooShortImperial As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RebarTooShortImperial {
    FailureDefinitionId^ get ();
}
static member RebarTooShortImperial : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.RebarTooShortMetric Property

BuiltInFailuresRebarFailuresRebarTooShortMetric Property

The minimum length of rebar shape is 25 mm.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RebarTooShortMetric { get; }
Public Shared ReadOnly Property RebarTooShortMetric As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RebarTooShortMetric {
    FailureDefinitionId^ get ();
}
static member RebarTooShortMetric : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.RemoveSpliceBetweenBars Property

BuiltInFailuresRebarFailuresRemoveSpliceBetweenBars Property

Splice cannot be maintained.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RemoveSpliceBetweenBars { get; }
Public Shared ReadOnly Property RemoveSpliceBetweenBars As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RemoveSpliceBetweenBars {
    FailureDefinitionId^ get ();
}
static member RemoveSpliceBetweenBars : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.SketchDimensionsRemoved Property

BuiltInFailuresRebarFailuresSketchDimensionsRemoved Property

The sketch dimensions, that were used to create the sketch, have been removed from the completed rebar shape definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SketchDimensionsRemoved { get; }
Public Shared ReadOnly Property SketchDimensionsRemoved As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SketchDimensionsRemoved {
    FailureDefinitionId^ get ();
}
static member SketchDimensionsRemoved : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.SketchDimsBWFRemoved Property

BuiltInFailuresRebarFailuresSketchDimsBWFRemoved Property

The sketch dimensions, that were used to create the sketch, have been removed from the completed bend profile definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SketchDimsBWFRemoved { get; }
Public Shared ReadOnly Property SketchDimsBWFRemoved As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SketchDimsBWFRemoved {
    FailureDefinitionId^ get ();
}
static member SketchDimsBWFRemoved : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.SketchFreeFormSet Property

BuiltInFailuresRebarFailuresSketchFreeFormSet Property

Sketching of a free form set produces only a single bar.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SketchFreeFormSet { get; }
Public Shared ReadOnly Property SketchFreeFormSet As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SketchFreeFormSet {
    FailureDefinitionId^ get ();
}
static member SketchFreeFormSet : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.SketchNonPlanarFreeForm Property

BuiltInFailuresRebarFailuresSketchNonPlanarFreeForm Property

The selected free form rebar is not planar. Sketching it will discard the current geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SketchNonPlanarFreeForm { get; }
Public Shared ReadOnly Property SketchNonPlanarFreeForm As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SketchNonPlanarFreeForm {
    FailureDefinitionId^ get ();
}
static member SketchNonPlanarFreeForm : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.SpliceTypeWasDeleted Property

BuiltInFailuresRebarFailuresSpliceTypeWasDeleted Property

Splice type was deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SpliceTypeWasDeleted { get; }
Public Shared ReadOnly Property SpliceTypeWasDeleted As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SpliceTypeWasDeleted {
    FailureDefinitionId^ get ();
}
static member SpliceTypeWasDeleted : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.StandardHookBendDiameterTooLarge Property

BuiltInFailuresRebarFailuresStandardHookBendDiameterTooLarge Property

Rebar Standard Hook Bend Diameter is too large.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StandardHookBendDiameterTooLarge { get; }
Public Shared ReadOnly Property StandardHookBendDiameterTooLarge As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StandardHookBendDiameterTooLarge {
    FailureDefinitionId^ get ();
}
static member StandardHookBendDiameterTooLarge : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.StandardHookBendDiameterTooSmall Property

BuiltInFailuresRebarFailuresStandardHookBendDiameterTooSmall Property

Rebar Standard Hook Bend Diameter is too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StandardHookBendDiameterTooSmall { get; }
Public Shared ReadOnly Property StandardHookBendDiameterTooSmall As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StandardHookBendDiameterTooSmall {
    FailureDefinitionId^ get ();
}
static member StandardHookBendDiameterTooSmall : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.TooLargeNumberOfBars Property

BuiltInFailuresRebarFailuresTooLargeNumberOfBars Property

Rebar Set must contain at most 1002 bar locations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TooLargeNumberOfBars { get; }
Public Shared ReadOnly Property TooLargeNumberOfBars As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TooLargeNumberOfBars {
    FailureDefinitionId^ get ();
}
static member TooLargeNumberOfBars : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.TooSmallNumberOfBars Property

BuiltInFailuresRebarFailuresTooSmallNumberOfBars Property

Rebar Set must contain at least two bar locations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TooSmallNumberOfBars { get; }
Public Shared ReadOnly Property TooSmallNumberOfBars As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TooSmallNumberOfBars {
    FailureDefinitionId^ get ();
}
static member TooSmallNumberOfBars : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.TrySmallerBarType Property

BuiltInFailuresRebarFailuresTrySmallerBarType Property

Rebar Bend Diameter is too large. Try a smaller Bar Type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TrySmallerBarType { get; }
Public Shared ReadOnly Property TrySmallerBarType As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TrySmallerBarType {
    FailureDefinitionId^ get ();
}
static member TrySmallerBarType : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarFailures.UnconstrainableRebarHandle Property

BuiltInFailuresRebarFailuresUnconstrainableRebarHandle Property

The rebar handle does not have any constraint targets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnconstrainableRebarHandle { get; }
Public Shared ReadOnly Property UnconstrainableRebarHandle As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnconstrainableRebarHandle {
    FailureDefinitionId^ get ();
}
static member UnconstrainableRebarHandle : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarFailures Class


BuiltInFailures.RebarShapeFailures Class

BuiltInFailuresRebarShapeFailures Class

Failures about RebarShape.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresRebarShapeFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class RebarShapeFailures
Public NotInheritable Class RebarShapeFailures
public ref class RebarShapeFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type RebarShapeFailures = class end

The BuiltInFailuresRebarShapeFailures type exposes the following members.

Properties
Name | Description
CircleMultiPlanarShape | A circle can't be converted to multiplanar shape.
CircleUnbounded | An unbounded circle can only be used to construct a spiral shape.
CurveOverconstrained | Segment is overconstrained. It has at least one parameterized dimension that conflicts with another dimension.
CurvesCollinear | Collinear segments are not allowed in a Rebar Shape definition.
CurvesUnlooped | Segments defining the Rebar Shape must be in a continuous loop.
CurveUnderconstrained | Segment is underconstrained. It requires additional parameterized dimensions.
DefaultParamaterValuesIncorrect | Default parameters have incorrect values. One reason for failure might be an edge length that is too short (it's smaller than bent radius).
DepthDimensionNotExisted | Multi-planar shape's depth dimension has been deleted. Please assign a new one to multi-planar depth.
DiagonalEdgesAreUnderconstrained | Shape is underconstrained. Please add additional dimension constraints to the shape's diagonal edges. (Diagonal segments with only one dimension constraint are automatically given a second constraint to lie at an angle of exactly 45 degrees, regardless of how they are drawn. The current shape has more than one such segment in sequence, and the resulting constrained edges are co-linear.)
DimensionLoose | This dimension cannot be used to parameterize the Rebar Shape.
DimensionWithCommonLengthUnit | A shape dimension is labelled with a parameter that uses the Common Length unit.
DimensionWithoutParameter | Dimension has no parameter assigned to it.
FormulaDrivenDimension | Dimension can't be driven by a formula parameter.
HooksAndEndTreatmentAtTheSameEnd | Cannot add hooks and end treatments at the same end.
MultiPlanarDepth | Multi-planar depth of Rebar Shape can't be too small.
MultipleArcsMustOverlap | Multiple arcs are supported only if they are concentric and form a circle with an overlap.
ParameterValueNotDefined | Parameter assigned to the dimension has no value defined.
PlanarMultiPlanarShape | The current shape is only bent in a single plane. A multi-planar definition is not required. Please redefine the shape on the top plane only.
ShapeFailure | The displayed Rebar Shape is created using a 'Rebar Bar for Preview'. This bar defines the bend radius displayed in the family. Using this preview bar the drawn shape cannot be completed.
WrongDepthDimensionLabel | Multi-planar depth dimension label is already used for one of the planar shape parameters.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RebarShapeFailures Properties

The BuiltInFailuresRebarShapeFailures type exposes the following members.

Properties
Name | Description
CircleMultiPlanarShape | A circle can't be converted to multiplanar shape.
CircleUnbounded | An unbounded circle can only be used to construct a spiral shape.
CurveOverconstrained | Segment is overconstrained. It has at least one parameterized dimension that conflicts with another dimension.
CurvesCollinear | Collinear segments are not allowed in a Rebar Shape definition.
CurvesUnlooped | Segments defining the Rebar Shape must be in a continuous loop.
CurveUnderconstrained | Segment is underconstrained. It requires additional parameterized dimensions.
DefaultParamaterValuesIncorrect | Default parameters have incorrect values. One reason for failure might be an edge length that is too short (it's smaller than bent radius).
DepthDimensionNotExisted | Multi-planar shape's depth dimension has been deleted. Please assign a new one to multi-planar depth.
DiagonalEdgesAreUnderconstrained | Shape is underconstrained. Please add additional dimension constraints to the shape's diagonal edges. (Diagonal segments with only one dimension constraint are automatically given a second constraint to lie at an angle of exactly 45 degrees, regardless of how they are drawn. The current shape has more than one such segment in sequence, and the resulting constrained edges are co-linear.)
DimensionLoose | This dimension cannot be used to parameterize the Rebar Shape.
DimensionWithCommonLengthUnit | A shape dimension is labelled with a parameter that uses the Common Length unit.
DimensionWithoutParameter | Dimension has no parameter assigned to it.
FormulaDrivenDimension | Dimension can't be driven by a formula parameter.
HooksAndEndTreatmentAtTheSameEnd | Cannot add hooks and end treatments at the same end.
MultiPlanarDepth | Multi-planar depth of Rebar Shape can't be too small.
MultipleArcsMustOverlap | Multiple arcs are supported only if they are concentric and form a circle with an overlap.
ParameterValueNotDefined | Parameter assigned to the dimension has no value defined.
PlanarMultiPlanarShape | The current shape is only bent in a single plane. A multi-planar definition is not required. Please redefine the shape on the top plane only.
ShapeFailure | The displayed Rebar Shape is created using a 'Rebar Bar for Preview'. This bar defines the bend radius displayed in the family. Using this preview bar the drawn shape cannot be completed.
WrongDepthDimensionLabel | Multi-planar depth dimension label is already used for one of the planar shape parameters.
Top
See Also

Reference

BuiltInFailuresRebarShapeFailures Class


BuiltInFailures.RebarShapeFailures.CircleMultiPlanarShape Property

BuiltInFailuresRebarShapeFailuresCircleMultiPlanarShape Property

A circle can't be converted to multiplanar shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CircleMultiPlanarShape { get; }
Public Shared ReadOnly Property CircleMultiPlanarShape As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CircleMultiPlanarShape {
    FailureDefinitionId^ get ();
}
static member CircleMultiPlanarShape : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarShapeFailures Class


BuiltInFailures.RebarShapeFailures.CircleUnbounded Property

BuiltInFailuresRebarShapeFailuresCircleUnbounded Property

An unbounded circle can only be used to construct a spiral shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CircleUnbounded { get; }
Public Shared ReadOnly Property CircleUnbounded As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CircleUnbounded {
    FailureDefinitionId^ get ();
}
static member CircleUnbounded : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarShapeFailures Class


BuiltInFailures.RebarShapeFailures.CurveOverconstrained Property

BuiltInFailuresRebarShapeFailuresCurveOverconstrained Property

Segment is overconstrained. It has at least one parameterized dimension that conflicts with another dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CurveOverconstrained { get; }
Public Shared ReadOnly Property CurveOverconstrained As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CurveOverconstrained {
    FailureDefinitionId^ get ();
}
static member CurveOverconstrained : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarShapeFailures Class


BuiltInFailures.RebarShapeFailures.CurvesCollinear Property

BuiltInFailuresRebarShapeFailuresCurvesCollinear Property

Collinear segments are not allowed in a Rebar Shape definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CurvesCollinear { get; }
Public Shared ReadOnly Property CurvesCollinear As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CurvesCollinear {
    FailureDefinitionId^ get ();
}
static member CurvesCollinear : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarShapeFailures Class


BuiltInFailures.RebarShapeFailures.CurvesUnlooped Property

BuiltInFailuresRebarShapeFailuresCurvesUnlooped Property

Segments defining the Rebar Shape must be in a continuous loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CurvesUnlooped { get; }
Public Shared ReadOnly Property CurvesUnlooped As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CurvesUnlooped {
    FailureDefinitionId^ get ();
}
static member CurvesUnlooped : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarShapeFailures Class


BuiltInFailures.RebarShapeFailures.CurveUnderconstrained Property

BuiltInFailuresRebarShapeFailuresCurveUnderconstrained Property

Segment is underconstrained. It requires additional parameterized dimensions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CurveUnderconstrained { get; }
Public Shared ReadOnly Property CurveUnderconstrained As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CurveUnderconstrained {
    FailureDefinitionId^ get ();
}
static member CurveUnderconstrained : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarShapeFailures Class


BuiltInFailures.RebarShapeFailures.DefaultParamaterValuesIncorrect Property

BuiltInFailuresRebarShapeFailuresDefaultParamaterValuesIncorrect Property

Default parameters have incorrect values. One reason for failure might be an edge length that is too short (it's smaller than bent radius).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DefaultParamaterValuesIncorrect { get; }
Public Shared ReadOnly Property DefaultParamaterValuesIncorrect As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DefaultParamaterValuesIncorrect {
    FailureDefinitionId^ get ();
}
static member DefaultParamaterValuesIncorrect : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarShapeFailures Class


BuiltInFailures.RebarShapeFailures.DepthDimensionNotExisted Property

BuiltInFailuresRebarShapeFailuresDepthDimensionNotExisted Property

Multi-planar shape's depth dimension has been deleted. Please assign a new one to multi-planar depth.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DepthDimensionNotExisted { get; }
Public Shared ReadOnly Property DepthDimensionNotExisted As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DepthDimensionNotExisted {
    FailureDefinitionId^ get ();
}
static member DepthDimensionNotExisted : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarShapeFailures Class


BuiltInFailures.RebarShapeFailures.DiagonalEdgesAreUnderconstrained Property

BuiltInFailuresRebarShapeFailuresDiagonalEdgesAreUnderconstrained Property

Shape is underconstrained. Please add additional dimension constraints to the shape's diagonal edges. (Diagonal segments with only one dimension constraint are automatically given a second constraint to lie at an angle of exactly 45 degrees, regardless of how they are drawn. The current shape has more than one such segment in sequence, and the resulting constrained edges are co-linear.)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DiagonalEdgesAreUnderconstrained { get; }
Public Shared ReadOnly Property DiagonalEdgesAreUnderconstrained As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DiagonalEdgesAreUnderconstrained {
    FailureDefinitionId^ get ();
}
static member DiagonalEdgesAreUnderconstrained : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarShapeFailures Class


BuiltInFailures.RebarShapeFailures.DimensionLoose Property

BuiltInFailuresRebarShapeFailuresDimensionLoose Property

This dimension cannot be used to parameterize the Rebar Shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DimensionLoose { get; }
Public Shared ReadOnly Property DimensionLoose As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DimensionLoose {
    FailureDefinitionId^ get ();
}
static member DimensionLoose : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarShapeFailures Class


BuiltInFailures.RebarShapeFailures.DimensionWithCommonLengthUnit Property

BuiltInFailuresRebarShapeFailuresDimensionWithCommonLengthUnit Property

A shape dimension is labelled with a parameter that uses the Common Length unit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DimensionWithCommonLengthUnit { get; }
Public Shared ReadOnly Property DimensionWithCommonLengthUnit As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DimensionWithCommonLengthUnit {
    FailureDefinitionId^ get ();
}
static member DimensionWithCommonLengthUnit : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarShapeFailures Class


BuiltInFailures.RebarShapeFailures.DimensionWithoutParameter Property

BuiltInFailuresRebarShapeFailuresDimensionWithoutParameter Property

Dimension has no parameter assigned to it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DimensionWithoutParameter { get; }
Public Shared ReadOnly Property DimensionWithoutParameter As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DimensionWithoutParameter {
    FailureDefinitionId^ get ();
}
static member DimensionWithoutParameter : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarShapeFailures Class


BuiltInFailures.RebarShapeFailures.FormulaDrivenDimension Property

BuiltInFailuresRebarShapeFailuresFormulaDrivenDimension Property

Dimension can't be driven by a formula parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FormulaDrivenDimension { get; }
Public Shared ReadOnly Property FormulaDrivenDimension As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FormulaDrivenDimension {
    FailureDefinitionId^ get ();
}
static member FormulaDrivenDimension : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarShapeFailures Class


BuiltInFailures.RebarShapeFailures.HooksAndEndTreatmentAtTheSameEnd Property

BuiltInFailuresRebarShapeFailuresHooksAndEndTreatmentAtTheSameEnd Property

Cannot add hooks and end treatments at the same end.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId HooksAndEndTreatmentAtTheSameEnd { get; }
Public Shared ReadOnly Property HooksAndEndTreatmentAtTheSameEnd As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ HooksAndEndTreatmentAtTheSameEnd {
    FailureDefinitionId^ get ();
}
static member HooksAndEndTreatmentAtTheSameEnd : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarShapeFailures Class


BuiltInFailures.RebarShapeFailures.MultiPlanarDepth Property

BuiltInFailuresRebarShapeFailuresMultiPlanarDepth Property

Multi-planar depth of Rebar Shape can't be too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MultiPlanarDepth { get; }
Public Shared ReadOnly Property MultiPlanarDepth As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MultiPlanarDepth {
    FailureDefinitionId^ get ();
}
static member MultiPlanarDepth : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarShapeFailures Class


BuiltInFailures.RebarShapeFailures.MultipleArcsMustOverlap Property

BuiltInFailuresRebarShapeFailuresMultipleArcsMustOverlap Property

Multiple arcs are supported only if they are concentric and form a circle with an overlap.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MultipleArcsMustOverlap { get; }
Public Shared ReadOnly Property MultipleArcsMustOverlap As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MultipleArcsMustOverlap {
    FailureDefinitionId^ get ();
}
static member MultipleArcsMustOverlap : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarShapeFailures Class


BuiltInFailures.RebarShapeFailures.ParameterValueNotDefined Property

BuiltInFailuresRebarShapeFailuresParameterValueNotDefined Property

Parameter assigned to the dimension has no value defined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ParameterValueNotDefined { get; }
Public Shared ReadOnly Property ParameterValueNotDefined As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ParameterValueNotDefined {
    FailureDefinitionId^ get ();
}
static member ParameterValueNotDefined : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarShapeFailures Class


BuiltInFailures.RebarShapeFailures.PlanarMultiPlanarShape Property

BuiltInFailuresRebarShapeFailuresPlanarMultiPlanarShape Property

The current shape is only bent in a single plane. A multi-planar definition is not required. Please redefine the shape on the top plane only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PlanarMultiPlanarShape { get; }
Public Shared ReadOnly Property PlanarMultiPlanarShape As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PlanarMultiPlanarShape {
    FailureDefinitionId^ get ();
}
static member PlanarMultiPlanarShape : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarShapeFailures Class


BuiltInFailures.RebarShapeFailures.ShapeFailure Property

BuiltInFailuresRebarShapeFailuresShapeFailure Property

The displayed Rebar Shape is created using a 'Rebar Bar for Preview'. This bar defines the bend radius displayed in the family. Using this preview bar the drawn shape cannot be completed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ShapeFailure { get; }
Public Shared ReadOnly Property ShapeFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ShapeFailure {
    FailureDefinitionId^ get ();
}
static member ShapeFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarShapeFailures Class


BuiltInFailures.RebarShapeFailures.WrongDepthDimensionLabel Property

BuiltInFailuresRebarShapeFailuresWrongDepthDimensionLabel Property

Multi-planar depth dimension label is already used for one of the planar shape parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WrongDepthDimensionLabel { get; }
Public Shared ReadOnly Property WrongDepthDimensionLabel As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WrongDepthDimensionLabel {
    FailureDefinitionId^ get ();
}
static member WrongDepthDimensionLabel : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarShapeFailures Class


BuiltInFailures.RebarSystemFailures Class

BuiltInFailuresRebarSystemFailures Class

Failures related to rebar systems.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresRebarSystemFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class RebarSystemFailures
Public NotInheritable Class RebarSystemFailures
public ref class RebarSystemFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type RebarSystemFailures = class end

The BuiltInFailuresRebarSystemFailures type exposes the following members.

Properties
Name | Description
AreaReinforcementOutSideOfHost | Area Reinforcement is sketched completely outside of its host.
AreaReinforcementRegenFail | Can't regenerate Area Reinforcement.
AreaReinforcementsCollision | Area Reinforcements are colliding. Aligning the Major Directions, or changing the Additional Offsets, can prevent collision.
AreaReinforcementWrongHost | Area Reinforcement can be placed only in Structural Floors and straight Structural Walls.
BarsTooCloseNumber | Bars are too close together. Decrease the Number Of Lines parameter.
BarsTooCloseSpacing | Bars are too close together. Increase the Maximum Spacing parameter.
BarsTooSparseSpacing | Bar spacing is greater than the size of the reinforced region. Decrease the Maximum Spacing parameter.
CannotPlaceAreaReinforcement | Can't find a host for Area Reinforcement.
CannotPlaceAreaReinforcementWarn | Can't find a host for Area Reinforcement.
CannotPlaceAreaReininforcement | Can't find a host for Area Reinforcement.
CannotPlaceAreaReininforcementWarn | Can't find a host for Area Reinforcement.
CannotPlacePathReinforcement | Can't find a host for Path Reinforcement.
CannotPlacePathReinforcementWarn | Can't find a host for Path Reinforcement.
CannotPlacePathReininforcement | Can't find a host for Path Reinforcement.
CannotPlacePathReininforcementWarn | Can't find a host for Path Reinforcement.
CannotUseAreaReinforcementHookTypeStyle | At least one of the bars in the Area Reinforcement has a Bar Type or Shape that is incompatible with the Hook type. Check the Hook permissions for the Bar Type (see Hook Lengths) and the Hook and Rebar Shape styles.
CannotUsePathReinforcementHookTypeStyle | At least one of the bars in the Path Reinforcement has a Bar Type or Shape that is incompatible with the Hook type. Check the Hook permissions for the Bar Type (see Hook Lengths) and the Hook and Rebar Shape styles.
DPartReinfDeletedEditDivision | Edits to the model will cause some Reinforcement hosted on Parts to be deleted.
DPartReinforcementDeleted | Reinforcement hosted on highlighted Parts will be deleted.
HostFlagAreaOff |
HostFlagAreaOn | The Area Reinforcement element was created in a document with the Host Structural Rebar setting on, and cannot be transferred into this document, which has the setting off.
HostFlagPathOff |
HostFlagPathOn |
InvalidLapSpliceInAreaReinforcement | The instance major/minor lap lengths must be smaller than 1/2 of the overall length from the type in major and minor directions, respectively. The default values set for this parameters did not respect this criteria so they were automatically reset to the type values.
LessThanTwoBars | Each reinforcement direction requires at least 2 bars. Please increase the number of bars.
PathReinforcementWrongHost | Path Reinforcement can be placed only in Structural Floors and straight Structural Walls.
RebarSystemOffset | Rebar Cover Side/Edge is too large for sketch. Bar placement may be inaccurate.
ThinHostFloor | Rebar Cover Top and Bottom are too large for host.
ThinHostFloorError | Rebar Cover Top and Bottom are too large for host.
ThinHostWall | Rebar Cover Interior and Exterior are too large for host.
ThinHostWallError | Rebar Cover Interior and Exterior are too large for host.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RebarSystemFailures Properties

The BuiltInFailuresRebarSystemFailures type exposes the following members.

Properties
Name | Description
AreaReinforcementOutSideOfHost | Area Reinforcement is sketched completely outside of its host.
AreaReinforcementRegenFail | Can't regenerate Area Reinforcement.
AreaReinforcementsCollision | Area Reinforcements are colliding. Aligning the Major Directions, or changing the Additional Offsets, can prevent collision.
AreaReinforcementWrongHost | Area Reinforcement can be placed only in Structural Floors and straight Structural Walls.
BarsTooCloseNumber | Bars are too close together. Decrease the Number Of Lines parameter.
BarsTooCloseSpacing | Bars are too close together. Increase the Maximum Spacing parameter.
BarsTooSparseSpacing | Bar spacing is greater than the size of the reinforced region. Decrease the Maximum Spacing parameter.
CannotPlaceAreaReinforcement | Can't find a host for Area Reinforcement.
CannotPlaceAreaReinforcementWarn | Can't find a host for Area Reinforcement.
CannotPlaceAreaReininforcement | Can't find a host for Area Reinforcement.
CannotPlaceAreaReininforcementWarn | Can't find a host for Area Reinforcement.
CannotPlacePathReinforcement | Can't find a host for Path Reinforcement.
CannotPlacePathReinforcementWarn | Can't find a host for Path Reinforcement.
CannotPlacePathReininforcement | Can't find a host for Path Reinforcement.
CannotPlacePathReininforcementWarn | Can't find a host for Path Reinforcement.
CannotUseAreaReinforcementHookTypeStyle | At least one of the bars in the Area Reinforcement has a Bar Type or Shape that is incompatible with the Hook type. Check the Hook permissions for the Bar Type (see Hook Lengths) and the Hook and Rebar Shape styles.
CannotUsePathReinforcementHookTypeStyle | At least one of the bars in the Path Reinforcement has a Bar Type or Shape that is incompatible with the Hook type. Check the Hook permissions for the Bar Type (see Hook Lengths) and the Hook and Rebar Shape styles.
DPartReinfDeletedEditDivision | Edits to the model will cause some Reinforcement hosted on Parts to be deleted.
DPartReinforcementDeleted | Reinforcement hosted on highlighted Parts will be deleted.
HostFlagAreaOff |
HostFlagAreaOn | The Area Reinforcement element was created in a document with the Host Structural Rebar setting on, and cannot be transferred into this document, which has the setting off.
HostFlagPathOff |
HostFlagPathOn |
InvalidLapSpliceInAreaReinforcement | The instance major/minor lap lengths must be smaller than 1/2 of the overall length from the type in major and minor directions, respectively. The default values set for this parameters did not respect this criteria so they were automatically reset to the type values.
LessThanTwoBars | Each reinforcement direction requires at least 2 bars. Please increase the number of bars.
PathReinforcementWrongHost | Path Reinforcement can be placed only in Structural Floors and straight Structural Walls.
RebarSystemOffset | Rebar Cover Side/Edge is too large for sketch. Bar placement may be inaccurate.
ThinHostFloor | Rebar Cover Top and Bottom are too large for host.
ThinHostFloorError | Rebar Cover Top and Bottom are too large for host.
ThinHostWall | Rebar Cover Interior and Exterior are too large for host.
ThinHostWallError | Rebar Cover Interior and Exterior are too large for host.
Top
See Also

Reference

BuiltInFailuresRebarSystemFailures Class


BuiltInFailures.RebarSystemFailures.AreaReinforcementOutSideOfHost Property

BuiltInFailuresRebarSystemFailuresAreaReinforcementOutSideOfHost Property

Area Reinforcement is sketched completely outside of its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AreaReinforcementOutSideOfHost { get; }
Public Shared ReadOnly Property AreaReinforcementOutSideOfHost As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AreaReinforcementOutSideOfHost {
    FailureDefinitionId^ get ();
}
static member AreaReinforcementOutSideOfHost : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarSystemFailures Class


BuiltInFailures.RebarSystemFailures.AreaReinforcementRegenFail Property

BuiltInFailuresRebarSystemFailuresAreaReinforcementRegenFail Property

Can't regenerate Area Reinforcement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AreaReinforcementRegenFail { get; }
Public Shared ReadOnly Property AreaReinforcementRegenFail As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AreaReinforcementRegenFail {
    FailureDefinitionId^ get ();
}
static member AreaReinforcementRegenFail : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarSystemFailures Class


BuiltInFailures.RebarSystemFailures.AreaReinforcementsCollision Property

BuiltInFailuresRebarSystemFailuresAreaReinforcementsCollision Property

Area Reinforcements are colliding. Aligning the Major Directions, or changing the Additional Offsets, can prevent collision.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AreaReinforcementsCollision { get; }
Public Shared ReadOnly Property AreaReinforcementsCollision As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AreaReinforcementsCollision {
    FailureDefinitionId^ get ();
}
static member AreaReinforcementsCollision : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarSystemFailures Class


BuiltInFailures.RebarSystemFailures.AreaReinforcementWrongHost Property

BuiltInFailuresRebarSystemFailuresAreaReinforcementWrongHost Property

Area Reinforcement can be placed only in Structural Floors and straight Structural Walls.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AreaReinforcementWrongHost { get; }
Public Shared ReadOnly Property AreaReinforcementWrongHost As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AreaReinforcementWrongHost {
    FailureDefinitionId^ get ();
}
static member AreaReinforcementWrongHost : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarSystemFailures Class


BuiltInFailures.RebarSystemFailures.BarsTooCloseNumber Property

BuiltInFailuresRebarSystemFailuresBarsTooCloseNumber Property

Bars are too close together. Decrease the Number Of Lines parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BarsTooCloseNumber { get; }
Public Shared ReadOnly Property BarsTooCloseNumber As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BarsTooCloseNumber {
    FailureDefinitionId^ get ();
}
static member BarsTooCloseNumber : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarSystemFailures Class


BuiltInFailures.RebarSystemFailures.BarsTooCloseSpacing Property

BuiltInFailuresRebarSystemFailuresBarsTooCloseSpacing Property

Bars are too close together. Increase the Maximum Spacing parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BarsTooCloseSpacing { get; }
Public Shared ReadOnly Property BarsTooCloseSpacing As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BarsTooCloseSpacing {
    FailureDefinitionId^ get ();
}
static member BarsTooCloseSpacing : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarSystemFailures Class


BuiltInFailures.RebarSystemFailures.BarsTooSparseSpacing Property

BuiltInFailuresRebarSystemFailuresBarsTooSparseSpacing Property

Bar spacing is greater than the size of the reinforced region. Decrease the Maximum Spacing parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BarsTooSparseSpacing { get; }
Public Shared ReadOnly Property BarsTooSparseSpacing As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BarsTooSparseSpacing {
    FailureDefinitionId^ get ();
}
static member BarsTooSparseSpacing : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarSystemFailures Class


BuiltInFailures.RebarSystemFailures.CannotPlaceAreaReinforcement Property

BuiltInFailuresRebarSystemFailuresCannotPlaceAreaReinforcement Property

Can't find a host for Area Reinforcement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPlaceAreaReinforcement { get; }
Public Shared ReadOnly Property CannotPlaceAreaReinforcement As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPlaceAreaReinforcement {
    FailureDefinitionId^ get ();
}
static member CannotPlaceAreaReinforcement : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarSystemFailures Class


BuiltInFailures.RebarSystemFailures.CannotPlaceAreaReinforcementWarn Property

BuiltInFailuresRebarSystemFailuresCannotPlaceAreaReinforcementWarn Property

Can't find a host for Area Reinforcement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPlaceAreaReinforcementWarn { get; }
Public Shared ReadOnly Property CannotPlaceAreaReinforcementWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPlaceAreaReinforcementWarn {
    FailureDefinitionId^ get ();
}
static member CannotPlaceAreaReinforcementWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarSystemFailures Class


BuiltInFailures.RebarSystemFailures.CannotPlaceAreaReininforcement Property

BuiltInFailuresRebarSystemFailuresCannotPlaceAreaReininforcement Property

Can't find a host for Area Reinforcement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPlaceAreaReininforcement { get; }
Public Shared ReadOnly Property CannotPlaceAreaReininforcement As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPlaceAreaReininforcement {
    FailureDefinitionId^ get ();
}
static member CannotPlaceAreaReininforcement : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarSystemFailures Class


BuiltInFailures.RebarSystemFailures.CannotPlaceAreaReininforcementWarn Property

BuiltInFailuresRebarSystemFailuresCannotPlaceAreaReininforcementWarn Property

Can't find a host for Area Reinforcement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPlaceAreaReininforcementWarn { get; }
Public Shared ReadOnly Property CannotPlaceAreaReininforcementWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPlaceAreaReininforcementWarn {
    FailureDefinitionId^ get ();
}
static member CannotPlaceAreaReininforcementWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarSystemFailures Class


BuiltInFailures.RebarSystemFailures.CannotPlacePathReinforcement Property

BuiltInFailuresRebarSystemFailuresCannotPlacePathReinforcement Property

Can't find a host for Path Reinforcement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPlacePathReinforcement { get; }
Public Shared ReadOnly Property CannotPlacePathReinforcement As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPlacePathReinforcement {
    FailureDefinitionId^ get ();
}
static member CannotPlacePathReinforcement : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarSystemFailures Class


BuiltInFailures.RebarSystemFailures.CannotPlacePathReinforcementWarn Property

BuiltInFailuresRebarSystemFailuresCannotPlacePathReinforcementWarn Property

Can't find a host for Path Reinforcement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPlacePathReinforcementWarn { get; }
Public Shared ReadOnly Property CannotPlacePathReinforcementWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPlacePathReinforcementWarn {
    FailureDefinitionId^ get ();
}
static member CannotPlacePathReinforcementWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarSystemFailures Class


BuiltInFailures.RebarSystemFailures.CannotPlacePathReininforcement Property

BuiltInFailuresRebarSystemFailuresCannotPlacePathReininforcement Property

Can't find a host for Path Reinforcement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPlacePathReininforcement { get; }
Public Shared ReadOnly Property CannotPlacePathReininforcement As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPlacePathReininforcement {
    FailureDefinitionId^ get ();
}
static member CannotPlacePathReininforcement : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarSystemFailures Class


BuiltInFailures.RebarSystemFailures.CannotPlacePathReininforcementWarn Property

BuiltInFailuresRebarSystemFailuresCannotPlacePathReininforcementWarn Property

Can't find a host for Path Reinforcement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPlacePathReininforcementWarn { get; }
Public Shared ReadOnly Property CannotPlacePathReininforcementWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPlacePathReininforcementWarn {
    FailureDefinitionId^ get ();
}
static member CannotPlacePathReininforcementWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarSystemFailures Class


BuiltInFailures.RebarSystemFailures.CannotUseAreaReinforcementHookTypeStyle Property

BuiltInFailuresRebarSystemFailuresCannotUseAreaReinforcementHookTypeStyle Property

At least one of the bars in the Area Reinforcement has a Bar Type or Shape that is incompatible with the Hook type. Check the Hook permissions for the Bar Type (see Hook Lengths) and the Hook and Rebar Shape styles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotUseAreaReinforcementHookTypeStyle { get; }
Public Shared ReadOnly Property CannotUseAreaReinforcementHookTypeStyle As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotUseAreaReinforcementHookTypeStyle {
    FailureDefinitionId^ get ();
}
static member CannotUseAreaReinforcementHookTypeStyle : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarSystemFailures Class


BuiltInFailures.RebarSystemFailures.CannotUsePathReinforcementHookTypeStyle Property

BuiltInFailuresRebarSystemFailuresCannotUsePathReinforcementHookTypeStyle Property

At least one of the bars in the Path Reinforcement has a Bar Type or Shape that is incompatible with the Hook type. Check the Hook permissions for the Bar Type (see Hook Lengths) and the Hook and Rebar Shape styles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotUsePathReinforcementHookTypeStyle { get; }
Public Shared ReadOnly Property CannotUsePathReinforcementHookTypeStyle As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotUsePathReinforcementHookTypeStyle {
    FailureDefinitionId^ get ();
}
static member CannotUsePathReinforcementHookTypeStyle : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarSystemFailures Class


BuiltInFailures.RebarSystemFailures.DPartReinfDeletedEditDivision Property

BuiltInFailuresRebarSystemFailuresDPartReinfDeletedEditDivision Property

Edits to the model will cause some Reinforcement hosted on Parts to be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DPartReinfDeletedEditDivision { get; }
Public Shared ReadOnly Property DPartReinfDeletedEditDivision As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DPartReinfDeletedEditDivision {
    FailureDefinitionId^ get ();
}
static member DPartReinfDeletedEditDivision : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarSystemFailures Class


BuiltInFailures.RebarSystemFailures.DPartReinforcementDeleted Property

BuiltInFailuresRebarSystemFailuresDPartReinforcementDeleted Property

Reinforcement hosted on highlighted Parts will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DPartReinforcementDeleted { get; }
Public Shared ReadOnly Property DPartReinforcementDeleted As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DPartReinforcementDeleted {
    FailureDefinitionId^ get ();
}
static member DPartReinforcementDeleted : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarSystemFailures Class


BuiltInFailures.RebarSystemFailures.HostFlagAreaOff Property

BuiltInFailuresRebarSystemFailuresHostFlagAreaOff Property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId HostFlagAreaOff { get; }
Public Shared ReadOnly Property HostFlagAreaOff As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ HostFlagAreaOff {
    FailureDefinitionId^ get ();
}
static member HostFlagAreaOff : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarSystemFailures Class


BuiltInFailures.RebarSystemFailures.HostFlagAreaOn Property

BuiltInFailuresRebarSystemFailuresHostFlagAreaOn Property

The Area Reinforcement element was created in a document with the Host Structural Rebar setting on, and cannot be transferred into this document, which has the setting off.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId HostFlagAreaOn { get; }
Public Shared ReadOnly Property HostFlagAreaOn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ HostFlagAreaOn {
    FailureDefinitionId^ get ();
}
static member HostFlagAreaOn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarSystemFailures Class


BuiltInFailures.RebarSystemFailures.HostFlagPathOff Property

BuiltInFailuresRebarSystemFailuresHostFlagPathOff Property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId HostFlagPathOff { get; }
Public Shared ReadOnly Property HostFlagPathOff As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ HostFlagPathOff {
    FailureDefinitionId^ get ();
}
static member HostFlagPathOff : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarSystemFailures Class


BuiltInFailures.RebarSystemFailures.HostFlagPathOn Property

BuiltInFailuresRebarSystemFailuresHostFlagPathOn Property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId HostFlagPathOn { get; }
Public Shared ReadOnly Property HostFlagPathOn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ HostFlagPathOn {
    FailureDefinitionId^ get ();
}
static member HostFlagPathOn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarSystemFailures Class


BuiltInFailures.RebarSystemFailures.InvalidLapSpliceInAreaReinforcement Property

BuiltInFailuresRebarSystemFailuresInvalidLapSpliceInAreaReinforcement Property

The instance major/minor lap lengths must be smaller than 1/2 of the overall length from the type in major and minor directions, respectively. The default values set for this parameters did not respect this criteria so they were automatically reset to the type values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidLapSpliceInAreaReinforcement { get; }
Public Shared ReadOnly Property InvalidLapSpliceInAreaReinforcement As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidLapSpliceInAreaReinforcement {
    FailureDefinitionId^ get ();
}
static member InvalidLapSpliceInAreaReinforcement : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarSystemFailures Class


BuiltInFailures.RebarSystemFailures.LessThanTwoBars Property

BuiltInFailuresRebarSystemFailuresLessThanTwoBars Property

Each reinforcement direction requires at least 2 bars. Please increase the number of bars.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LessThanTwoBars { get; }
Public Shared ReadOnly Property LessThanTwoBars As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LessThanTwoBars {
    FailureDefinitionId^ get ();
}
static member LessThanTwoBars : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarSystemFailures Class


BuiltInFailures.RebarSystemFailures.PathReinforcementWrongHost Property

BuiltInFailuresRebarSystemFailuresPathReinforcementWrongHost Property

Path Reinforcement can be placed only in Structural Floors and straight Structural Walls.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PathReinforcementWrongHost { get; }
Public Shared ReadOnly Property PathReinforcementWrongHost As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PathReinforcementWrongHost {
    FailureDefinitionId^ get ();
}
static member PathReinforcementWrongHost : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarSystemFailures Class


BuiltInFailures.RebarSystemFailures.RebarSystemOffset Property

BuiltInFailuresRebarSystemFailuresRebarSystemOffset Property

Rebar Cover Side/Edge is too large for sketch. Bar placement may be inaccurate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RebarSystemOffset { get; }
Public Shared ReadOnly Property RebarSystemOffset As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RebarSystemOffset {
    FailureDefinitionId^ get ();
}
static member RebarSystemOffset : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarSystemFailures Class


BuiltInFailures.RebarSystemFailures.ThinHostFloor Property

BuiltInFailuresRebarSystemFailuresThinHostFloor Property

Rebar Cover Top and Bottom are too large for host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ThinHostFloor { get; }
Public Shared ReadOnly Property ThinHostFloor As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ThinHostFloor {
    FailureDefinitionId^ get ();
}
static member ThinHostFloor : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarSystemFailures Class


BuiltInFailures.RebarSystemFailures.ThinHostFloorError Property

BuiltInFailuresRebarSystemFailuresThinHostFloorError Property

Rebar Cover Top and Bottom are too large for host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ThinHostFloorError { get; }
Public Shared ReadOnly Property ThinHostFloorError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ThinHostFloorError {
    FailureDefinitionId^ get ();
}
static member ThinHostFloorError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarSystemFailures Class


BuiltInFailures.RebarSystemFailures.ThinHostWall Property

BuiltInFailuresRebarSystemFailuresThinHostWall Property

Rebar Cover Interior and Exterior are too large for host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ThinHostWall { get; }
Public Shared ReadOnly Property ThinHostWall As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ThinHostWall {
    FailureDefinitionId^ get ();
}
static member ThinHostWall : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarSystemFailures Class


BuiltInFailures.RebarSystemFailures.ThinHostWallError Property

BuiltInFailuresRebarSystemFailuresThinHostWallError Property

Rebar Cover Interior and Exterior are too large for host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ThinHostWallError { get; }
Public Shared ReadOnly Property ThinHostWallError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ThinHostWallError {
    FailureDefinitionId^ get ();
}
static member ThinHostWallError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRebarSystemFailures Class


BuiltInFailures.RefPlaneFailures Class

BuiltInFailuresRefPlaneFailures Class

Failures about RefPlane.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresRefPlaneFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class RefPlaneFailures
Public NotInheritable Class RefPlaneFailures
public ref class RefPlaneFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type RefPlaneFailures = class end

The BuiltInFailuresRefPlaneFailures type exposes the following members.

Properties
Name | Description
AlreadyHaveTwoClosurePlanes | No more than two closure planes are allowed.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RefPlaneFailures Properties

The BuiltInFailuresRefPlaneFailures type exposes the following members.

Properties
Name | Description
AlreadyHaveTwoClosurePlanes | No more than two closure planes are allowed.
Top
See Also

Reference

BuiltInFailuresRefPlaneFailures Class


BuiltInFailures.RefPlaneFailures.AlreadyHaveTwoClosurePlanes Property

BuiltInFailuresRefPlaneFailuresAlreadyHaveTwoClosurePlanes Property

No more than two closure planes are allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AlreadyHaveTwoClosurePlanes { get; }
Public Shared ReadOnly Property AlreadyHaveTwoClosurePlanes As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AlreadyHaveTwoClosurePlanes {
    FailureDefinitionId^ get ();
}
static member AlreadyHaveTwoClosurePlanes : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRefPlaneFailures Class


BuiltInFailures.RegenFailures Class

BuiltInFailuresRegenFailures Class

Failures about RegenFailures.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresRegenFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class RegenFailures
Public NotInheritable Class RegenFailures
public ref class RegenFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type RegenFailures = class end

The BuiltInFailuresRegenFailures type exposes the following members.

Properties
Name | Description
CannotRegenFamily | Can't regenerate Family [Family Name]. Edit Family to modify it.
CircularDependency | There is a circular chain of references among the highlighted elements.
CircularDependencyAssocProp | There is a circular dependency between a Line created with Pick Support and the supporting member.
CircularDependencyAssocPropError | There is a circular dependency between a Line created with Pick Support and the supporting member.
CircularDependencyConstraint | Highlighted constraints cause a circular chain of references.
CircularDependencyConstraintError | Highlighted constraints cause a circular chain of references.
CircularDependencyError | There is a circular chain of references among the highlighted elements.
CircularDependencyResolved | There was a circular chain of references among the highlighted elements that was attempted to resolve. User-visible text will depend on original error returned by offending element.
CircularDependencySketch | Constraints in sketches of highlighted elements cause a circular chain of references.
CircularDependencySketchError | There is a circular chain of references among the highlighted elements.
CircularDependencyUncut | There is a circular chain of references among the highlighted elements.
CircularDependencyUncutError | There is a circular chain of references among the highlighted elements.
CircularDependencyWall | There is a circular chain of references among the highlighted elements.
CircularDependencyWallError | There is a circular chain of references among the highlighted elements.
ForceRegenSketch | Regen Sketch
GeomStepFailed | Can't rebuild geometry.
GeomStepFailedError | Can't rebuild geometry.
RegenElements | Regenerating elements.
RegeneratedElements | Elements regenerated in pass [Regen Index]
RegenFailure | Regeneration Failure.
UserCancelled | Operation is cancelled by the user.
UserCancelledError | Operation is cancelled by the user.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RegenFailures Properties

The BuiltInFailuresRegenFailures type exposes the following members.

Properties
Name | Description
CannotRegenFamily | Can't regenerate Family [Family Name]. Edit Family to modify it.
CircularDependency | There is a circular chain of references among the highlighted elements.
CircularDependencyAssocProp | There is a circular dependency between a Line created with Pick Support and the supporting member.
CircularDependencyAssocPropError | There is a circular dependency between a Line created with Pick Support and the supporting member.
CircularDependencyConstraint | Highlighted constraints cause a circular chain of references.
CircularDependencyConstraintError | Highlighted constraints cause a circular chain of references.
CircularDependencyError | There is a circular chain of references among the highlighted elements.
CircularDependencyResolved | There was a circular chain of references among the highlighted elements that was attempted to resolve. User-visible text will depend on original error returned by offending element.
CircularDependencySketch | Constraints in sketches of highlighted elements cause a circular chain of references.
CircularDependencySketchError | There is a circular chain of references among the highlighted elements.
CircularDependencyUncut | There is a circular chain of references among the highlighted elements.
CircularDependencyUncutError | There is a circular chain of references among the highlighted elements.
CircularDependencyWall | There is a circular chain of references among the highlighted elements.
CircularDependencyWallError | There is a circular chain of references among the highlighted elements.
ForceRegenSketch | Regen Sketch
GeomStepFailed | Can't rebuild geometry.
GeomStepFailedError | Can't rebuild geometry.
RegenElements | Regenerating elements.
RegeneratedElements | Elements regenerated in pass [Regen Index]
RegenFailure | Regeneration Failure.
UserCancelled | Operation is cancelled by the user.
UserCancelledError | Operation is cancelled by the user.
Top
See Also

Reference

BuiltInFailuresRegenFailures Class


BuiltInFailures.RegenFailures.CannotRegenFamily Property

BuiltInFailuresRegenFailuresCannotRegenFamily Property

Can't regenerate Family [Family Name]. Edit Family to modify it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotRegenFamily { get; }
Public Shared ReadOnly Property CannotRegenFamily As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotRegenFamily {
    FailureDefinitionId^ get ();
}
static member CannotRegenFamily : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRegenFailures Class


BuiltInFailures.RegenFailures.CircularDependency Property

BuiltInFailuresRegenFailuresCircularDependency Property

There is a circular chain of references among the highlighted elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CircularDependency { get; }
Public Shared ReadOnly Property CircularDependency As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CircularDependency {
    FailureDefinitionId^ get ();
}
static member CircularDependency : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRegenFailures Class


BuiltInFailures.RegenFailures.CircularDependencyAssocProp Property

BuiltInFailuresRegenFailuresCircularDependencyAssocProp Property

There is a circular dependency between a Line created with Pick Support and the supporting member.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CircularDependencyAssocProp { get; }
Public Shared ReadOnly Property CircularDependencyAssocProp As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CircularDependencyAssocProp {
    FailureDefinitionId^ get ();
}
static member CircularDependencyAssocProp : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRegenFailures Class


BuiltInFailures.RegenFailures.CircularDependencyAssocPropError Property

BuiltInFailuresRegenFailuresCircularDependencyAssocPropError Property

There is a circular dependency between a Line created with Pick Support and the supporting member.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CircularDependencyAssocPropError { get; }
Public Shared ReadOnly Property CircularDependencyAssocPropError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CircularDependencyAssocPropError {
    FailureDefinitionId^ get ();
}
static member CircularDependencyAssocPropError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRegenFailures Class


BuiltInFailures.RegenFailures.CircularDependencyConstraint Property

BuiltInFailuresRegenFailuresCircularDependencyConstraint Property

Highlighted constraints cause a circular chain of references.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CircularDependencyConstraint { get; }
Public Shared ReadOnly Property CircularDependencyConstraint As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CircularDependencyConstraint {
    FailureDefinitionId^ get ();
}
static member CircularDependencyConstraint : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRegenFailures Class


BuiltInFailures.RegenFailures.CircularDependencyConstraintError Property

BuiltInFailuresRegenFailuresCircularDependencyConstraintError Property

Highlighted constraints cause a circular chain of references.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CircularDependencyConstraintError { get; }
Public Shared ReadOnly Property CircularDependencyConstraintError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CircularDependencyConstraintError {
    FailureDefinitionId^ get ();
}
static member CircularDependencyConstraintError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRegenFailures Class


BuiltInFailures.RegenFailures.CircularDependencyError Property

BuiltInFailuresRegenFailuresCircularDependencyError Property

There is a circular chain of references among the highlighted elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CircularDependencyError { get; }
Public Shared ReadOnly Property CircularDependencyError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CircularDependencyError {
    FailureDefinitionId^ get ();
}
static member CircularDependencyError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRegenFailures Class


BuiltInFailures.RegenFailures.CircularDependencyResolved Property

BuiltInFailuresRegenFailuresCircularDependencyResolved Property

There was a circular chain of references among the highlighted elements that was attempted to resolve. User-visible text will depend on original error returned by offending element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CircularDependencyResolved { get; }
Public Shared ReadOnly Property CircularDependencyResolved As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CircularDependencyResolved {
    FailureDefinitionId^ get ();
}
static member CircularDependencyResolved : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRegenFailures Class


BuiltInFailures.RegenFailures.CircularDependencySketch Property

BuiltInFailuresRegenFailuresCircularDependencySketch Property

Constraints in sketches of highlighted elements cause a circular chain of references.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CircularDependencySketch { get; }
Public Shared ReadOnly Property CircularDependencySketch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CircularDependencySketch {
    FailureDefinitionId^ get ();
}
static member CircularDependencySketch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRegenFailures Class


BuiltInFailures.RegenFailures.CircularDependencySketchError Property

BuiltInFailuresRegenFailuresCircularDependencySketchError Property

There is a circular chain of references among the highlighted elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CircularDependencySketchError { get; }
Public Shared ReadOnly Property CircularDependencySketchError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CircularDependencySketchError {
    FailureDefinitionId^ get ();
}
static member CircularDependencySketchError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRegenFailures Class


BuiltInFailures.RegenFailures.CircularDependencyUncut Property

BuiltInFailuresRegenFailuresCircularDependencyUncut Property

There is a circular chain of references among the highlighted elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CircularDependencyUncut { get; }
Public Shared ReadOnly Property CircularDependencyUncut As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CircularDependencyUncut {
    FailureDefinitionId^ get ();
}
static member CircularDependencyUncut : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRegenFailures Class


BuiltInFailures.RegenFailures.CircularDependencyUncutError Property

BuiltInFailuresRegenFailuresCircularDependencyUncutError Property

There is a circular chain of references among the highlighted elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CircularDependencyUncutError { get; }
Public Shared ReadOnly Property CircularDependencyUncutError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CircularDependencyUncutError {
    FailureDefinitionId^ get ();
}
static member CircularDependencyUncutError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRegenFailures Class


BuiltInFailures.RegenFailures.CircularDependencyWall Property

BuiltInFailuresRegenFailuresCircularDependencyWall Property

There is a circular chain of references among the highlighted elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CircularDependencyWall { get; }
Public Shared ReadOnly Property CircularDependencyWall As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CircularDependencyWall {
    FailureDefinitionId^ get ();
}
static member CircularDependencyWall : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRegenFailures Class


BuiltInFailures.RegenFailures.CircularDependencyWallError Property

BuiltInFailuresRegenFailuresCircularDependencyWallError Property

There is a circular chain of references among the highlighted elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CircularDependencyWallError { get; }
Public Shared ReadOnly Property CircularDependencyWallError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CircularDependencyWallError {
    FailureDefinitionId^ get ();
}
static member CircularDependencyWallError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRegenFailures Class


BuiltInFailures.RegenFailures.ForceRegenSketch Property

BuiltInFailuresRegenFailuresForceRegenSketch Property

Regen Sketch

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ForceRegenSketch { get; }
Public Shared ReadOnly Property ForceRegenSketch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ForceRegenSketch {
    FailureDefinitionId^ get ();
}
static member ForceRegenSketch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRegenFailures Class


BuiltInFailures.RegenFailures.GeomStepFailed Property

BuiltInFailuresRegenFailuresGeomStepFailed Property

Can't rebuild geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId GeomStepFailed { get; }
Public Shared ReadOnly Property GeomStepFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ GeomStepFailed {
    FailureDefinitionId^ get ();
}
static member GeomStepFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRegenFailures Class


BuiltInFailures.RegenFailures.GeomStepFailedError Property

BuiltInFailuresRegenFailuresGeomStepFailedError Property

Can't rebuild geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId GeomStepFailedError { get; }
Public Shared ReadOnly Property GeomStepFailedError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ GeomStepFailedError {
    FailureDefinitionId^ get ();
}
static member GeomStepFailedError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRegenFailures Class


BuiltInFailures.RegenFailures.RegenElements Property

BuiltInFailuresRegenFailuresRegenElements Property

Regenerating elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RegenElements { get; }
Public Shared ReadOnly Property RegenElements As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RegenElements {
    FailureDefinitionId^ get ();
}
static member RegenElements : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRegenFailures Class


BuiltInFailures.RegenFailures.RegeneratedElements Property

BuiltInFailuresRegenFailuresRegeneratedElements Property

Elements regenerated in pass [Regen Index]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RegeneratedElements { get; }
Public Shared ReadOnly Property RegeneratedElements As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RegeneratedElements {
    FailureDefinitionId^ get ();
}
static member RegeneratedElements : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRegenFailures Class


BuiltInFailures.RegenFailures.RegenFailure Property

BuiltInFailuresRegenFailuresRegenFailure Property

Regeneration Failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RegenFailure { get; }
Public Shared ReadOnly Property RegenFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RegenFailure {
    FailureDefinitionId^ get ();
}
static member RegenFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRegenFailures Class


BuiltInFailures.RegenFailures.UserCancelled Property

BuiltInFailuresRegenFailuresUserCancelled Property

Operation is cancelled by the user.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UserCancelled { get; }
Public Shared ReadOnly Property UserCancelled As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UserCancelled {
    FailureDefinitionId^ get ();
}
static member UserCancelled : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRegenFailures Class


BuiltInFailures.RegenFailures.UserCancelledError Property

BuiltInFailuresRegenFailuresUserCancelledError Property

Operation is cancelled by the user.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UserCancelledError { get; }
Public Shared ReadOnly Property UserCancelledError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UserCancelledError {
    FailureDefinitionId^ get ();
}
static member UserCancelledError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRegenFailures Class


BuiltInFailures.RenderFailures Class

BuiltInFailuresRenderFailures Class

Failures related to rendering.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresRenderFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class RenderFailures
Public NotInheritable Class RenderFailures
public ref class RenderFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type RenderFailures = class end

The BuiltInFailuresRenderFailures type exposes the following members.

Properties
Name | Description
LightParametersNotInRange | The value should be in range of [Value] and [Value].
LightSourceInsideGeometry | Light source is inside solid geometry. No light will be emitted during rendering.
ProhibitDeletionLightSource | The light source cannot be deleted with UI.
RenderLibNotInstalledWarn | Rendering library has not been installed, so the third party geometry cannot be created.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RenderFailures Properties

The BuiltInFailuresRenderFailures type exposes the following members.

Properties
Name | Description
LightParametersNotInRange | The value should be in range of [Value] and [Value].
LightSourceInsideGeometry | Light source is inside solid geometry. No light will be emitted during rendering.
ProhibitDeletionLightSource | The light source cannot be deleted with UI.
RenderLibNotInstalledWarn | Rendering library has not been installed, so the third party geometry cannot be created.
Top
See Also

Reference

BuiltInFailuresRenderFailures Class


BuiltInFailures.RenderFailures.LightParametersNotInRange Property

BuiltInFailuresRenderFailuresLightParametersNotInRange Property

The value should be in range of [Value] and [Value].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LightParametersNotInRange { get; }
Public Shared ReadOnly Property LightParametersNotInRange As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LightParametersNotInRange {
    FailureDefinitionId^ get ();
}
static member LightParametersNotInRange : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRenderFailures Class


BuiltInFailures.RenderFailures.LightSourceInsideGeometry Property

BuiltInFailuresRenderFailuresLightSourceInsideGeometry Property

Light source is inside solid geometry. No light will be emitted during rendering.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LightSourceInsideGeometry { get; }
Public Shared ReadOnly Property LightSourceInsideGeometry As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LightSourceInsideGeometry {
    FailureDefinitionId^ get ();
}
static member LightSourceInsideGeometry : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRenderFailures Class


BuiltInFailures.RenderFailures.ProhibitDeletionLightSource Property

BuiltInFailuresRenderFailuresProhibitDeletionLightSource Property

The light source cannot be deleted with UI.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ProhibitDeletionLightSource { get; }
Public Shared ReadOnly Property ProhibitDeletionLightSource As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ProhibitDeletionLightSource {
    FailureDefinitionId^ get ();
}
static member ProhibitDeletionLightSource : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRenderFailures Class


BuiltInFailures.RenderFailures.RenderLibNotInstalledWarn Property

BuiltInFailuresRenderFailuresRenderLibNotInstalledWarn Property

Rendering library has not been installed, so the third party geometry cannot be created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RenderLibNotInstalledWarn { get; }
Public Shared ReadOnly Property RenderLibNotInstalledWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RenderLibNotInstalledWarn {
    FailureDefinitionId^ get ();
}
static member RenderLibNotInstalledWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRenderFailures Class


BuiltInFailures.RevisionCloudFailures Class

BuiltInFailuresRevisionCloudFailures Class

Failures about RevisionCloud.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresRevisionCloudFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class RevisionCloudFailures
Public NotInheritable Class RevisionCloudFailures
public ref class RevisionCloudFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type RevisionCloudFailures = class end

The BuiltInFailuresRevisionCloudFailures type exposes the following members.

Properties
Name | Description
ModifyingIssuedRevisionCloudOnUpgrade | During upgrade, an issued revision cloud was moved. Please double check the revision cloud to ensure it is located in the correct place.
ProhibitCreationInIssued | The most current project revision has been issued. No new revision clouds can be created in it. Please add a new revision to the global revision table.
ProhibitModificationOfIssuedRevisionCloud | Issued Revision Clouds can't be modified.
ProhibitSwitchFromIssuedRevision | Can't remove cloud from an Issued Revision.
ProhibitSwitchToIssuedRevision | Can't add cloud to an Issued Revision.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RevisionCloudFailures Properties

The BuiltInFailuresRevisionCloudFailures type exposes the following members.

Properties
Name | Description
ModifyingIssuedRevisionCloudOnUpgrade | During upgrade, an issued revision cloud was moved. Please double check the revision cloud to ensure it is located in the correct place.
ProhibitCreationInIssued | The most current project revision has been issued. No new revision clouds can be created in it. Please add a new revision to the global revision table.
ProhibitModificationOfIssuedRevisionCloud | Issued Revision Clouds can't be modified.
ProhibitSwitchFromIssuedRevision | Can't remove cloud from an Issued Revision.
ProhibitSwitchToIssuedRevision | Can't add cloud to an Issued Revision.
Top
See Also

Reference

BuiltInFailuresRevisionCloudFailures Class


BuiltInFailures.RevisionCloudFailures.ModifyingIssuedRevisionCloudOnUpgrade Property

BuiltInFailuresRevisionCloudFailuresModifyingIssuedRevisionCloudOnUpgrade Property

During upgrade, an issued revision cloud was moved. Please double check the revision cloud to ensure it is located in the correct place.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ModifyingIssuedRevisionCloudOnUpgrade { get; }
Public Shared ReadOnly Property ModifyingIssuedRevisionCloudOnUpgrade As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ModifyingIssuedRevisionCloudOnUpgrade {
    FailureDefinitionId^ get ();
}
static member ModifyingIssuedRevisionCloudOnUpgrade : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRevisionCloudFailures Class


BuiltInFailures.RevisionCloudFailures.ProhibitCreationInIssued Property

BuiltInFailuresRevisionCloudFailuresProhibitCreationInIssued Property

The most current project revision has been issued. No new revision clouds can be created in it. Please add a new revision to the global revision table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ProhibitCreationInIssued { get; }
Public Shared ReadOnly Property ProhibitCreationInIssued As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ProhibitCreationInIssued {
    FailureDefinitionId^ get ();
}
static member ProhibitCreationInIssued : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRevisionCloudFailures Class


BuiltInFailures.RevisionCloudFailures.ProhibitModificationOfIssuedRevisionCloud Property

BuiltInFailuresRevisionCloudFailuresProhibitModificationOfIssuedRevisionCloud Property

Issued Revision Clouds can't be modified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ProhibitModificationOfIssuedRevisionCloud { get; }
Public Shared ReadOnly Property ProhibitModificationOfIssuedRevisionCloud As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ProhibitModificationOfIssuedRevisionCloud {
    FailureDefinitionId^ get ();
}
static member ProhibitModificationOfIssuedRevisionCloud : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRevisionCloudFailures Class


BuiltInFailures.RevisionCloudFailures.ProhibitSwitchFromIssuedRevision Property

BuiltInFailuresRevisionCloudFailuresProhibitSwitchFromIssuedRevision Property

Can't remove cloud from an Issued Revision.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ProhibitSwitchFromIssuedRevision { get; }
Public Shared ReadOnly Property ProhibitSwitchFromIssuedRevision As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ProhibitSwitchFromIssuedRevision {
    FailureDefinitionId^ get ();
}
static member ProhibitSwitchFromIssuedRevision : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRevisionCloudFailures Class


BuiltInFailures.RevisionCloudFailures.ProhibitSwitchToIssuedRevision Property

BuiltInFailuresRevisionCloudFailuresProhibitSwitchToIssuedRevision Property

Can't add cloud to an Issued Revision.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ProhibitSwitchToIssuedRevision { get; }
Public Shared ReadOnly Property ProhibitSwitchToIssuedRevision As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ProhibitSwitchToIssuedRevision {
    FailureDefinitionId^ get ();
}
static member ProhibitSwitchToIssuedRevision : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRevisionCloudFailures Class


BuiltInFailures.RevisionFailures Class

BuiltInFailuresRevisionFailures Class

Failures about Revision Settings.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresRevisionFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class RevisionFailures
Public NotInheritable Class RevisionFailures
public ref class RevisionFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type RevisionFailures = class end

The BuiltInFailuresRevisionFailures type exposes the following members.

Properties
Name | Description
RevisionSettingsDuplicateName | More than one Revisons have the same name %1!s!.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RevisionFailures Properties

The BuiltInFailuresRevisionFailures type exposes the following members.

Properties
Name | Description
RevisionSettingsDuplicateName | More than one Revisons have the same name %1!s!.
Top
See Also

Reference

BuiltInFailuresRevisionFailures Class


BuiltInFailures.RevisionFailures.RevisionSettingsDuplicateName Property

BuiltInFailuresRevisionFailuresRevisionSettingsDuplicateName Property

More than one Revisons have the same name %1!s!.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RevisionSettingsDuplicateName { get; }
Public Shared ReadOnly Property RevisionSettingsDuplicateName As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RevisionSettingsDuplicateName {
    FailureDefinitionId^ get ();
}
static member RevisionSettingsDuplicateName : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRevisionFailures Class


BuiltInFailures.RevolutionFailures Class

BuiltInFailuresRevolutionFailures Class

Failures about Revolution.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresRevolutionFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class RevolutionFailures
Public NotInheritable Class RevolutionFailures
public ref class RevolutionFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type RevolutionFailures = class end

The BuiltInFailuresRevolutionFailures type exposes the following members.

Properties
Name | Description
CannotDrawRevolution | Can't create surface of revolution.
ProfileCrossesRevolutionAxis | The profile must not cross the axis of revolution.
ProfileNotPlanar | The Profile must lie in a plane.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RevolutionFailures Properties

The BuiltInFailuresRevolutionFailures type exposes the following members.

Properties
Name | Description
CannotDrawRevolution | Can't create surface of revolution.
ProfileCrossesRevolutionAxis | The profile must not cross the axis of revolution.
ProfileNotPlanar | The Profile must lie in a plane.
Top
See Also

Reference

BuiltInFailuresRevolutionFailures Class


BuiltInFailures.RevolutionFailures.CannotDrawRevolution Property

BuiltInFailuresRevolutionFailuresCannotDrawRevolution Property

Can't create surface of revolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotDrawRevolution { get; }
Public Shared ReadOnly Property CannotDrawRevolution As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotDrawRevolution {
    FailureDefinitionId^ get ();
}
static member CannotDrawRevolution : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRevolutionFailures Class


BuiltInFailures.RevolutionFailures.ProfileCrossesRevolutionAxis Property

BuiltInFailuresRevolutionFailuresProfileCrossesRevolutionAxis Property

The profile must not cross the axis of revolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ProfileCrossesRevolutionAxis { get; }
Public Shared ReadOnly Property ProfileCrossesRevolutionAxis As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ProfileCrossesRevolutionAxis {
    FailureDefinitionId^ get ();
}
static member ProfileCrossesRevolutionAxis : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRevolutionFailures Class


BuiltInFailures.RevolutionFailures.ProfileNotPlanar Property

BuiltInFailuresRevolutionFailuresProfileNotPlanar Property

The Profile must lie in a plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ProfileNotPlanar { get; }
Public Shared ReadOnly Property ProfileNotPlanar As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ProfileNotPlanar {
    FailureDefinitionId^ get ();
}
static member ProfileNotPlanar : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRevolutionFailures Class


BuiltInFailures.RoofFailures Class

BuiltInFailuresRoofFailures Class

Failures about Roof.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresRoofFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class RoofFailures
Public NotInheritable Class RoofFailures
public ref class RoofFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type RoofFailures = class end

The BuiltInFailuresRoofFailures type exposes the following members.

Properties
Name | Description
CurveRoofSkippedLoops | Some loops were skipped
CurveRoofSkippedLoopsError | Some loops were skipped
CurveRoofSkippedLoopsWarn | Some loops were skipped
ExtrudedRoofCutBySketch | Entire extruded Roof is cut by cut Sketch.
HadToAlignEaves | Adjacent slope-defining lines must have identical eave heights. Eaves were aligned to higher location automatically to avoid failure. Use the Align Eaves tool to specify desired location.
HoleInRoofFailed | Hole(s) could not be cut in roof.
InvalidArcSegmentation | A segmented slope-defining arc has too few segments.
JoinedRoofMissesTarget | Part of the roof to be joined misses the target face.
JoinedRoofMissesTargetError | Part of the roof to be joined misses the target face.
NoFlatCurtainRoofs | A Sloped Glazing with no slope is not allowed.
OnlyOneSlopeCurtainRoof | Only one slope in curtain roof.
OnlyUpwardFacesUsed | The selected faces contain both upward and downward pointing faces. Only the upward pointing faces were used.
RoofCutoffRemoved | The roof's cutoff failed and was removed; make sure the cutoff height is not below the roof.
RoofExceedsMaxHeight | Roof exceeds user-specified maximum height
RoofMeetsRoofTangentially | The roofs cannot be joined because the roof being joined meets the target roof tangentially.
RoofMeetsRoofTangentiallyError | The roofs cannot be joined because the roof being joined meets the target roof tangentially.
RoofSlopeExceedsThreshold | Thickness of this Roof may be slightly inaccurate due to extreme Shape Editing. Dimensions to this element in sections and details may not accurately indicate the Thickness shown in Type Properties.
RoofToRefPlanes | Roof cannot be joined to more than one reference plane.
RoofToRefPlanesError | Roof cannot be joined to more than one reference plane.
UnusedSlopeArrow | The tails of all slope arrows must lie on the roof boundary.
UptoHeightTooLow | Cutoff Level cannot be below bottom of roof.
UserCancelledRoof | Cancelled.
WorkplaneShouldBeLevel | Can't use Workplane that is not a Level. Set the desired Level as current Workplane.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RoofFailures Properties

The BuiltInFailuresRoofFailures type exposes the following members.

Properties
Name | Description
CurveRoofSkippedLoops | Some loops were skipped
CurveRoofSkippedLoopsError | Some loops were skipped
CurveRoofSkippedLoopsWarn | Some loops were skipped
ExtrudedRoofCutBySketch | Entire extruded Roof is cut by cut Sketch.
HadToAlignEaves | Adjacent slope-defining lines must have identical eave heights. Eaves were aligned to higher location automatically to avoid failure. Use the Align Eaves tool to specify desired location.
HoleInRoofFailed | Hole(s) could not be cut in roof.
InvalidArcSegmentation | A segmented slope-defining arc has too few segments.
JoinedRoofMissesTarget | Part of the roof to be joined misses the target face.
JoinedRoofMissesTargetError | Part of the roof to be joined misses the target face.
NoFlatCurtainRoofs | A Sloped Glazing with no slope is not allowed.
OnlyOneSlopeCurtainRoof | Only one slope in curtain roof.
OnlyUpwardFacesUsed | The selected faces contain both upward and downward pointing faces. Only the upward pointing faces were used.
RoofCutoffRemoved | The roof's cutoff failed and was removed; make sure the cutoff height is not below the roof.
RoofExceedsMaxHeight | Roof exceeds user-specified maximum height
RoofMeetsRoofTangentially | The roofs cannot be joined because the roof being joined meets the target roof tangentially.
RoofMeetsRoofTangentiallyError | The roofs cannot be joined because the roof being joined meets the target roof tangentially.
RoofSlopeExceedsThreshold | Thickness of this Roof may be slightly inaccurate due to extreme Shape Editing. Dimensions to this element in sections and details may not accurately indicate the Thickness shown in Type Properties.
RoofToRefPlanes | Roof cannot be joined to more than one reference plane.
RoofToRefPlanesError | Roof cannot be joined to more than one reference plane.
UnusedSlopeArrow | The tails of all slope arrows must lie on the roof boundary.
UptoHeightTooLow | Cutoff Level cannot be below bottom of roof.
UserCancelledRoof | Cancelled.
WorkplaneShouldBeLevel | Can't use Workplane that is not a Level. Set the desired Level as current Workplane.
Top
See Also

Reference

BuiltInFailuresRoofFailures Class


BuiltInFailures.RoofFailures.CurveRoofSkippedLoops Property

BuiltInFailuresRoofFailuresCurveRoofSkippedLoops Property

Some loops were skipped

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CurveRoofSkippedLoops { get; }
Public Shared ReadOnly Property CurveRoofSkippedLoops As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CurveRoofSkippedLoops {
    FailureDefinitionId^ get ();
}
static member CurveRoofSkippedLoops : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoofFailures Class


BuiltInFailures.RoofFailures.CurveRoofSkippedLoopsError Property

BuiltInFailuresRoofFailuresCurveRoofSkippedLoopsError Property

Some loops were skipped

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CurveRoofSkippedLoopsError { get; }
Public Shared ReadOnly Property CurveRoofSkippedLoopsError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CurveRoofSkippedLoopsError {
    FailureDefinitionId^ get ();
}
static member CurveRoofSkippedLoopsError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoofFailures Class


BuiltInFailures.RoofFailures.CurveRoofSkippedLoopsWarn Property

BuiltInFailuresRoofFailuresCurveRoofSkippedLoopsWarn Property

Some loops were skipped

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CurveRoofSkippedLoopsWarn { get; }
Public Shared ReadOnly Property CurveRoofSkippedLoopsWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CurveRoofSkippedLoopsWarn {
    FailureDefinitionId^ get ();
}
static member CurveRoofSkippedLoopsWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoofFailures Class


BuiltInFailures.RoofFailures.ExtrudedRoofCutBySketch Property

BuiltInFailuresRoofFailuresExtrudedRoofCutBySketch Property

Entire extruded Roof is cut by cut Sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ExtrudedRoofCutBySketch { get; }
Public Shared ReadOnly Property ExtrudedRoofCutBySketch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ExtrudedRoofCutBySketch {
    FailureDefinitionId^ get ();
}
static member ExtrudedRoofCutBySketch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoofFailures Class


BuiltInFailures.RoofFailures.HadToAlignEaves Property

BuiltInFailuresRoofFailuresHadToAlignEaves Property

Adjacent slope-defining lines must have identical eave heights. Eaves were aligned to higher location automatically to avoid failure. Use the Align Eaves tool to specify desired location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId HadToAlignEaves { get; }
Public Shared ReadOnly Property HadToAlignEaves As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ HadToAlignEaves {
    FailureDefinitionId^ get ();
}
static member HadToAlignEaves : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoofFailures Class


BuiltInFailures.RoofFailures.HoleInRoofFailed Property

BuiltInFailuresRoofFailuresHoleInRoofFailed Property

Hole(s) could not be cut in roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId HoleInRoofFailed { get; }
Public Shared ReadOnly Property HoleInRoofFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ HoleInRoofFailed {
    FailureDefinitionId^ get ();
}
static member HoleInRoofFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoofFailures Class


BuiltInFailures.RoofFailures.InvalidArcSegmentation Property

BuiltInFailuresRoofFailuresInvalidArcSegmentation Property

A segmented slope-defining arc has too few segments.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidArcSegmentation { get; }
Public Shared ReadOnly Property InvalidArcSegmentation As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidArcSegmentation {
    FailureDefinitionId^ get ();
}
static member InvalidArcSegmentation : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoofFailures Class


BuiltInFailures.RoofFailures.JoinedRoofMissesTarget Property

BuiltInFailuresRoofFailuresJoinedRoofMissesTarget Property

Part of the roof to be joined misses the target face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId JoinedRoofMissesTarget { get; }
Public Shared ReadOnly Property JoinedRoofMissesTarget As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ JoinedRoofMissesTarget {
    FailureDefinitionId^ get ();
}
static member JoinedRoofMissesTarget : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoofFailures Class


BuiltInFailures.RoofFailures.JoinedRoofMissesTargetError Property

BuiltInFailuresRoofFailuresJoinedRoofMissesTargetError Property

Part of the roof to be joined misses the target face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId JoinedRoofMissesTargetError { get; }
Public Shared ReadOnly Property JoinedRoofMissesTargetError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ JoinedRoofMissesTargetError {
    FailureDefinitionId^ get ();
}
static member JoinedRoofMissesTargetError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoofFailures Class


BuiltInFailures.RoofFailures.NoFlatCurtainRoofs Property

BuiltInFailuresRoofFailuresNoFlatCurtainRoofs Property

A Sloped Glazing with no slope is not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoFlatCurtainRoofs { get; }
Public Shared ReadOnly Property NoFlatCurtainRoofs As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoFlatCurtainRoofs {
    FailureDefinitionId^ get ();
}
static member NoFlatCurtainRoofs : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoofFailures Class


BuiltInFailures.RoofFailures.OnlyOneSlopeCurtainRoof Property

BuiltInFailuresRoofFailuresOnlyOneSlopeCurtainRoof Property

Only one slope in curtain roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId OnlyOneSlopeCurtainRoof { get; }
Public Shared ReadOnly Property OnlyOneSlopeCurtainRoof As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ OnlyOneSlopeCurtainRoof {
    FailureDefinitionId^ get ();
}
static member OnlyOneSlopeCurtainRoof : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoofFailures Class


BuiltInFailures.RoofFailures.OnlyUpwardFacesUsed Property

BuiltInFailuresRoofFailuresOnlyUpwardFacesUsed Property

The selected faces contain both upward and downward pointing faces. Only the upward pointing faces were used.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId OnlyUpwardFacesUsed { get; }
Public Shared ReadOnly Property OnlyUpwardFacesUsed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ OnlyUpwardFacesUsed {
    FailureDefinitionId^ get ();
}
static member OnlyUpwardFacesUsed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoofFailures Class


BuiltInFailures.RoofFailures.RoofCutoffRemoved Property

BuiltInFailuresRoofFailuresRoofCutoffRemoved Property

The roof's cutoff failed and was removed; make sure the cutoff height is not below the roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RoofCutoffRemoved { get; }
Public Shared ReadOnly Property RoofCutoffRemoved As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RoofCutoffRemoved {
    FailureDefinitionId^ get ();
}
static member RoofCutoffRemoved : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoofFailures Class


BuiltInFailures.RoofFailures.RoofExceedsMaxHeight Property

BuiltInFailuresRoofFailuresRoofExceedsMaxHeight Property

Roof exceeds user-specified maximum height

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RoofExceedsMaxHeight { get; }
Public Shared ReadOnly Property RoofExceedsMaxHeight As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RoofExceedsMaxHeight {
    FailureDefinitionId^ get ();
}
static member RoofExceedsMaxHeight : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoofFailures Class


BuiltInFailures.RoofFailures.RoofMeetsRoofTangentially Property

BuiltInFailuresRoofFailuresRoofMeetsRoofTangentially Property

The roofs cannot be joined because the roof being joined meets the target roof tangentially.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RoofMeetsRoofTangentially { get; }
Public Shared ReadOnly Property RoofMeetsRoofTangentially As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RoofMeetsRoofTangentially {
    FailureDefinitionId^ get ();
}
static member RoofMeetsRoofTangentially : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoofFailures Class


BuiltInFailures.RoofFailures.RoofMeetsRoofTangentiallyError Property

BuiltInFailuresRoofFailuresRoofMeetsRoofTangentiallyError Property

The roofs cannot be joined because the roof being joined meets the target roof tangentially.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RoofMeetsRoofTangentiallyError { get; }
Public Shared ReadOnly Property RoofMeetsRoofTangentiallyError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RoofMeetsRoofTangentiallyError {
    FailureDefinitionId^ get ();
}
static member RoofMeetsRoofTangentiallyError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoofFailures Class


BuiltInFailures.RoofFailures.RoofSlopeExceedsThreshold Property

BuiltInFailuresRoofFailuresRoofSlopeExceedsThreshold Property

Thickness of this Roof may be slightly inaccurate due to extreme Shape Editing. Dimensions to this element in sections and details may not accurately indicate the Thickness shown in Type Properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RoofSlopeExceedsThreshold { get; }
Public Shared ReadOnly Property RoofSlopeExceedsThreshold As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RoofSlopeExceedsThreshold {
    FailureDefinitionId^ get ();
}
static member RoofSlopeExceedsThreshold : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoofFailures Class


BuiltInFailures.RoofFailures.RoofToRefPlanes Property

BuiltInFailuresRoofFailuresRoofToRefPlanes Property

Roof cannot be joined to more than one reference plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RoofToRefPlanes { get; }
Public Shared ReadOnly Property RoofToRefPlanes As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RoofToRefPlanes {
    FailureDefinitionId^ get ();
}
static member RoofToRefPlanes : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoofFailures Class


BuiltInFailures.RoofFailures.RoofToRefPlanesError Property

BuiltInFailuresRoofFailuresRoofToRefPlanesError Property

Roof cannot be joined to more than one reference plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RoofToRefPlanesError { get; }
Public Shared ReadOnly Property RoofToRefPlanesError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RoofToRefPlanesError {
    FailureDefinitionId^ get ();
}
static member RoofToRefPlanesError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoofFailures Class


BuiltInFailures.RoofFailures.UnusedSlopeArrow Property

BuiltInFailuresRoofFailuresUnusedSlopeArrow Property

The tails of all slope arrows must lie on the roof boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnusedSlopeArrow { get; }
Public Shared ReadOnly Property UnusedSlopeArrow As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnusedSlopeArrow {
    FailureDefinitionId^ get ();
}
static member UnusedSlopeArrow : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoofFailures Class


BuiltInFailures.RoofFailures.UptoHeightTooLow Property

BuiltInFailuresRoofFailuresUptoHeightTooLow Property

Cutoff Level cannot be below bottom of roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UptoHeightTooLow { get; }
Public Shared ReadOnly Property UptoHeightTooLow As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UptoHeightTooLow {
    FailureDefinitionId^ get ();
}
static member UptoHeightTooLow : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoofFailures Class


BuiltInFailures.RoofFailures.UserCancelledRoof Property

BuiltInFailuresRoofFailuresUserCancelledRoof Property

Cancelled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UserCancelledRoof { get; }
Public Shared ReadOnly Property UserCancelledRoof As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UserCancelledRoof {
    FailureDefinitionId^ get ();
}
static member UserCancelledRoof : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoofFailures Class


BuiltInFailures.RoofFailures.WorkplaneShouldBeLevel Property

BuiltInFailuresRoofFailuresWorkplaneShouldBeLevel Property

Can't use Workplane that is not a Level. Set the desired Level as current Workplane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WorkplaneShouldBeLevel { get; }
Public Shared ReadOnly Property WorkplaneShouldBeLevel As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WorkplaneShouldBeLevel {
    FailureDefinitionId^ get ();
}
static member WorkplaneShouldBeLevel : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoofFailures Class


BuiltInFailures.RoomFailures Class

BuiltInFailuresRoomFailures Class

Failures about Room.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresRoomFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class RoomFailures
Public NotInheritable Class RoomFailures
public ref class RoomFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type RoomFailures = class end

The BuiltInFailuresRoomFailures type exposes the following members.

Properties
Name | Description
AreaTagBadViewType | Can't Copy Area Tags. The target view doesn't have the same Area Scheme as the original view.
AreaUnplaceWarning | An Area was deleted from all model views but still remains in this project. \n The area can be removed from any schedule or placed back in the model using the Area command.
CannotMakeRoomsGeometry | Could not create geometry for [Room].
ExtensionsOverlapWarning | Vertical Extensions on these Walls overlap. This can cause undesirable Joins. Try starting with no overlap and extend the Walls toward one another.
InvalidReflectivityPercentage | The value for Reflectivity must be between 0 and 1.
InvisibleRoomBoundElemement | [Room] Bounding element is invisible in current view.
LoadareaRecovered | The boundary encloses the region for area based load:[Areabasedload].
OptionConflictBoundariesVaryMainAddToOptionSet | Option Conflict between Rooms.\nRoom boundary in the Main Model differs from the apparent boundary in view '[View Name]'.\nTo resolve, select the Main Model Room and use the Add to Design Option Set command.
OptionConflictBoundariesVaryMainSeparate | Option Conflict between Rooms.\nRoom boundary in the Main Model differs from the apparent boundary in view '[View Name]'.\nTo resolve, divide space with Room Separation Lines in the Main Model.
OptionConflictBoundariesVaryOptionSeparate | Option Conflict between Rooms.\nRoom boundary differs from the apparent boundary in view '[View Name]'.\nTo resolve, divide space with Room Separation Lines in the Main Model.
OptionConflictInLinkBoundariesVaryMainAddToOptionSet | Option conflict between rooms in the Revit link '[Link Instance Name]'.\nThe room boundary in the main model of the Revit link differs from the apparent boundary in the linked view '[View Name from Link]'.\nTo resolve the issue, open the Revit link file for editing, select the main model room, and use the Add to Design Option Set tool.
OptionConflictInLinkBoundariesVaryMainSeparate | Option conflict between rooms in the Revit link '[Link Instance Name]'.\nThe room boundary in the main model of the Revit link differs from the apparent boundary in the linked view '[View Name from Link]'.\nTo resolve the issue, open the Revit link file for editing, and use room separation lines to divide the space in the main model.
OptionConflictInLinkBoundariesVaryOptionSeparate | Option conflict between rooms in the Revit link '[Link Instance Name]'.\nThe room boundary differs from the apparent boundary in the linked view '[View Name from Link]'.\nTo resolve the issue, open the Revit link file for editing, and use room separation lines to divide the space in the main model.
OptionConflictInLinkRoomOverlapMain | Option conflict between rooms in the Revit link '[Link Instance Name]'.\nThe room in the Revit link's option '[Option Name in Link]' overlaps a room in the main model.\nTo resolve the issue, open the Revit link file for editing, select the main model room, and use the Add to Design Option Set tool.
OptionConflictInLinkRoomOverlapOption | Option conflict between rooms in the Revit link '[Link Instance Name]'.\nA room in the Revit link's option '[Option #1 Name in Link]' overlaps a room in the Revit link's option '[Option #2 Name in Link]'.\nTo resolve the issue, open the Revit link file for editing, and delete the duplicate room or use room separation lines to divide the space in the main model.
OptionConflictRoomOverlapMain | Option Conflict between Rooms.\nRoom in Option '[Option Name]' overlaps Room in the Main Model.\nTo resolve, select the Main Model Room and use the Add to Design Option Set command.
OptionConflictRoomOverlapOption | Option Conflict between Rooms.\nRoom in Option '[Option Name]' overlaps Room in Option '[Option Name]'.\nTo resolve, delete the duplicate Room or divide space with Room Separation Lines in the Main Model.
RoomBaseAboveComputationHeight | [RoomBase]'s lower offset is above the Computation Height
RoomBelowCompHeight | [Room] Volume is being calculated above the Upper Limit of this [Room]. Change the Upper Limit and Offset or change the height of volume calculations.
RoomBoundaryMisalignment | [Room] bounding element might be misaligned.
RoomHeightNegative | [Room] must have a height greater than 0.
RoomLevelElevs | A [Room]s Upper Limit must be above its Base Level.
RoomNotEnclosed | [Room] is not in a properly enclosed region
RoomNotEnclosedAreas | [Room] is not in a properly enclosed region
RoomNotEnclosedLoadAreas | [Room] is not in a properly enclosed region
RoomNotEnclosedRooms | [Room] is not in a properly enclosed region
RoomNotEnclosedSpaces | [Room] is not in a properly enclosed region
RoomsCreatedAutomatically | [Room] [Room] created automatically.
RoomsFailed | [Room] computations only succeeded without considering the following elements.
RoomsInSameRegion | Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.
RoomsInSameRegionAreas | Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.
RoomsInSameRegionLoadAreas | Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.
RoomsInSameRegionRooms | Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.
RoomsInSameRegionSpaces | Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.
RoomsOverlapInHeight | [Room] volumes overlap. Adjust the Upper Limit and Limit Offset properties of the [rooms].
RoomsReallyFailed | [Room] computations failed. Try to modify the following elements.
RoomTagBadViewType | [Room] Tags can only be placed in Floor Plan, Reflected Ceiling Plan and Section Views.
RoomTagDeleted | A [Room] Tag was deleted, but the corresponding [Room] still exists. You can place another tag for the [Room] using the [Room] Tag tool or select the [Room] and delete it.
RoomTagNotInRoom | [Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].
RoomTagNotInRoomToArea | [Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].
RoomTagNotInRoomToRoom | [Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].
RoomTagNotInRoomToSpace | [Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].
RoomTagVolumeNotComputed | [Room] Tag is displaying volume that can't be computed.
RoomTooShort | [Room] is very short. If this is not intended, change its Upper Limit and Offset.
RoomUnplaceWarning | A Room was deleted from all model views but still remains in this project. \n The room can be removed from any schedule or placed back in the model using the Room command.
ShowRoomBoundingElements | [Room] Bounding elements are highlighted.
SpaceUnplaceWarning | A Space was deleted from all model views but still remains in this project. \n The Space can be removed from any schedule or placed back in the model using the Space command.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RoomFailures Properties

The BuiltInFailuresRoomFailures type exposes the following members.

Properties
Name | Description
AreaTagBadViewType | Can't Copy Area Tags. The target view doesn't have the same Area Scheme as the original view.
AreaUnplaceWarning | An Area was deleted from all model views but still remains in this project. \n The area can be removed from any schedule or placed back in the model using the Area command.
CannotMakeRoomsGeometry | Could not create geometry for [Room].
ExtensionsOverlapWarning | Vertical Extensions on these Walls overlap. This can cause undesirable Joins. Try starting with no overlap and extend the Walls toward one another.
InvalidReflectivityPercentage | The value for Reflectivity must be between 0 and 1.
InvisibleRoomBoundElemement | [Room] Bounding element is invisible in current view.
LoadareaRecovered | The boundary encloses the region for area based load:[Areabasedload].
OptionConflictBoundariesVaryMainAddToOptionSet | Option Conflict between Rooms.\nRoom boundary in the Main Model differs from the apparent boundary in view '[View Name]'.\nTo resolve, select the Main Model Room and use the Add to Design Option Set command.
OptionConflictBoundariesVaryMainSeparate | Option Conflict between Rooms.\nRoom boundary in the Main Model differs from the apparent boundary in view '[View Name]'.\nTo resolve, divide space with Room Separation Lines in the Main Model.
OptionConflictBoundariesVaryOptionSeparate | Option Conflict between Rooms.\nRoom boundary differs from the apparent boundary in view '[View Name]'.\nTo resolve, divide space with Room Separation Lines in the Main Model.
OptionConflictInLinkBoundariesVaryMainAddToOptionSet | Option conflict between rooms in the Revit link '[Link Instance Name]'.\nThe room boundary in the main model of the Revit link differs from the apparent boundary in the linked view '[View Name from Link]'.\nTo resolve the issue, open the Revit link file for editing, select the main model room, and use the Add to Design Option Set tool.
OptionConflictInLinkBoundariesVaryMainSeparate | Option conflict between rooms in the Revit link '[Link Instance Name]'.\nThe room boundary in the main model of the Revit link differs from the apparent boundary in the linked view '[View Name from Link]'.\nTo resolve the issue, open the Revit link file for editing, and use room separation lines to divide the space in the main model.
OptionConflictInLinkBoundariesVaryOptionSeparate | Option conflict between rooms in the Revit link '[Link Instance Name]'.\nThe room boundary differs from the apparent boundary in the linked view '[View Name from Link]'.\nTo resolve the issue, open the Revit link file for editing, and use room separation lines to divide the space in the main model.
OptionConflictInLinkRoomOverlapMain | Option conflict between rooms in the Revit link '[Link Instance Name]'.\nThe room in the Revit link's option '[Option Name in Link]' overlaps a room in the main model.\nTo resolve the issue, open the Revit link file for editing, select the main model room, and use the Add to Design Option Set tool.
OptionConflictInLinkRoomOverlapOption | Option conflict between rooms in the Revit link '[Link Instance Name]'.\nA room in the Revit link's option '[Option #1 Name in Link]' overlaps a room in the Revit link's option '[Option #2 Name in Link]'.\nTo resolve the issue, open the Revit link file for editing, and delete the duplicate room or use room separation lines to divide the space in the main model.
OptionConflictRoomOverlapMain | Option Conflict between Rooms.\nRoom in Option '[Option Name]' overlaps Room in the Main Model.\nTo resolve, select the Main Model Room and use the Add to Design Option Set command.
OptionConflictRoomOverlapOption | Option Conflict between Rooms.\nRoom in Option '[Option Name]' overlaps Room in Option '[Option Name]'.\nTo resolve, delete the duplicate Room or divide space with Room Separation Lines in the Main Model.
RoomBaseAboveComputationHeight | [RoomBase]'s lower offset is above the Computation Height
RoomBelowCompHeight | [Room] Volume is being calculated above the Upper Limit of this [Room]. Change the Upper Limit and Offset or change the height of volume calculations.
RoomBoundaryMisalignment | [Room] bounding element might be misaligned.
RoomHeightNegative | [Room] must have a height greater than 0.
RoomLevelElevs | A [Room]s Upper Limit must be above its Base Level.
RoomNotEnclosed | [Room] is not in a properly enclosed region
RoomNotEnclosedAreas | [Room] is not in a properly enclosed region
RoomNotEnclosedLoadAreas | [Room] is not in a properly enclosed region
RoomNotEnclosedRooms | [Room] is not in a properly enclosed region
RoomNotEnclosedSpaces | [Room] is not in a properly enclosed region
RoomsCreatedAutomatically | [Room] [Room] created automatically.
RoomsFailed | [Room] computations only succeeded without considering the following elements.
RoomsInSameRegion | Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.
RoomsInSameRegionAreas | Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.
RoomsInSameRegionLoadAreas | Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.
RoomsInSameRegionRooms | Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.
RoomsInSameRegionSpaces | Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.
RoomsOverlapInHeight | [Room] volumes overlap. Adjust the Upper Limit and Limit Offset properties of the [rooms].
RoomsReallyFailed | [Room] computations failed. Try to modify the following elements.
RoomTagBadViewType | [Room] Tags can only be placed in Floor Plan, Reflected Ceiling Plan and Section Views.
RoomTagDeleted | A [Room] Tag was deleted, but the corresponding [Room] still exists. You can place another tag for the [Room] using the [Room] Tag tool or select the [Room] and delete it.
RoomTagNotInRoom | [Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].
RoomTagNotInRoomToArea | [Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].
RoomTagNotInRoomToRoom | [Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].
RoomTagNotInRoomToSpace | [Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].
RoomTagVolumeNotComputed | [Room] Tag is displaying volume that can't be computed.
RoomTooShort | [Room] is very short. If this is not intended, change its Upper Limit and Offset.
RoomUnplaceWarning | A Room was deleted from all model views but still remains in this project. \n The room can be removed from any schedule or placed back in the model using the Room command.
ShowRoomBoundingElements | [Room] Bounding elements are highlighted.
SpaceUnplaceWarning | A Space was deleted from all model views but still remains in this project. \n The Space can be removed from any schedule or placed back in the model using the Space command.
Top
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.RoomFailures.AreaTagBadViewType Property

BuiltInFailuresRoomFailuresAreaTagBadViewType Property

Can't Copy Area Tags. The target view doesn't have the same Area Scheme as the original view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AreaTagBadViewType { get; }
Public Shared ReadOnly Property AreaTagBadViewType As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AreaTagBadViewType {
    FailureDefinitionId^ get ();
}
static member AreaTagBadViewType : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.RoomFailures.AreaUnplaceWarning Property

BuiltInFailuresRoomFailuresAreaUnplaceWarning Property

An Area was deleted from all model views but still remains in this project. \n The area can be removed from any schedule or placed back in the model using the Area command.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AreaUnplaceWarning { get; }
Public Shared ReadOnly Property AreaUnplaceWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AreaUnplaceWarning {
    FailureDefinitionId^ get ();
}
static member AreaUnplaceWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.RoomFailures.CannotMakeRoomsGeometry Property

BuiltInFailuresRoomFailuresCannotMakeRoomsGeometry Property

Could not create geometry for [Room].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotMakeRoomsGeometry { get; }
Public Shared ReadOnly Property CannotMakeRoomsGeometry As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotMakeRoomsGeometry {
    FailureDefinitionId^ get ();
}
static member CannotMakeRoomsGeometry : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.RoomFailures.ExtensionsOverlapWarning Property

BuiltInFailuresRoomFailuresExtensionsOverlapWarning Property

Vertical Extensions on these Walls overlap. This can cause undesirable Joins. Try starting with no overlap and extend the Walls toward one another.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ExtensionsOverlapWarning { get; }
Public Shared ReadOnly Property ExtensionsOverlapWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ExtensionsOverlapWarning {
    FailureDefinitionId^ get ();
}
static member ExtensionsOverlapWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.RoomFailures.InvalidReflectivityPercentage Property

BuiltInFailuresRoomFailuresInvalidReflectivityPercentage Property

The value for Reflectivity must be between 0 and 1.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidReflectivityPercentage { get; }
Public Shared ReadOnly Property InvalidReflectivityPercentage As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidReflectivityPercentage {
    FailureDefinitionId^ get ();
}
static member InvalidReflectivityPercentage : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.RoomFailures.InvisibleRoomBoundElemement Property

BuiltInFailuresRoomFailuresInvisibleRoomBoundElemement Property

[Room] Bounding element is invisible in current view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvisibleRoomBoundElemement { get; }
Public Shared ReadOnly Property InvisibleRoomBoundElemement As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvisibleRoomBoundElemement {
    FailureDefinitionId^ get ();
}
static member InvisibleRoomBoundElemement : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.RoomFailures.LoadareaRecovered Property

BuiltInFailuresRoomFailuresLoadareaRecovered Property

The boundary encloses the region for area based load:[Areabasedload].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LoadareaRecovered { get; }
Public Shared ReadOnly Property LoadareaRecovered As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LoadareaRecovered {
    FailureDefinitionId^ get ();
}
static member LoadareaRecovered : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.RoomFailures.OptionConflictBoundariesVaryMainAddToOptionSet Property

BuiltInFailuresRoomFailuresOptionConflictBoundariesVaryMainAddToOptionSet Property

Option Conflict between Rooms.\nRoom boundary in the Main Model differs from the apparent boundary in view '[View Name]'.\nTo resolve, select the Main Model Room and use the Add to Design Option Set command.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId OptionConflictBoundariesVaryMainAddToOptionSet { get; }
Public Shared ReadOnly Property OptionConflictBoundariesVaryMainAddToOptionSet As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ OptionConflictBoundariesVaryMainAddToOptionSet {
    FailureDefinitionId^ get ();
}
static member OptionConflictBoundariesVaryMainAddToOptionSet : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.RoomFailures.OptionConflictBoundariesVaryMainSeparate Property

BuiltInFailuresRoomFailuresOptionConflictBoundariesVaryMainSeparate Property

Option Conflict between Rooms.\nRoom boundary in the Main Model differs from the apparent boundary in view '[View Name]'.\nTo resolve, divide space with Room Separation Lines in the Main Model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId OptionConflictBoundariesVaryMainSeparate { get; }
Public Shared ReadOnly Property OptionConflictBoundariesVaryMainSeparate As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ OptionConflictBoundariesVaryMainSeparate {
    FailureDefinitionId^ get ();
}
static member OptionConflictBoundariesVaryMainSeparate : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.RoomFailures.OptionConflictBoundariesVaryOptionSeparate Property

BuiltInFailuresRoomFailuresOptionConflictBoundariesVaryOptionSeparate Property

Option Conflict between Rooms.\nRoom boundary differs from the apparent boundary in view '[View Name]'.\nTo resolve, divide space with Room Separation Lines in the Main Model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId OptionConflictBoundariesVaryOptionSeparate { get; }
Public Shared ReadOnly Property OptionConflictBoundariesVaryOptionSeparate As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ OptionConflictBoundariesVaryOptionSeparate {
    FailureDefinitionId^ get ();
}
static member OptionConflictBoundariesVaryOptionSeparate : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.RoomFailures.OptionConflictInLinkBoundariesVaryMainAddToOptionSet Property

BuiltInFailuresRoomFailuresOptionConflictInLinkBoundariesVaryMainAddToOptionSet Property

Option conflict between rooms in the Revit link '[Link Instance Name]'.\nThe room boundary in the main model of the Revit link differs from the apparent boundary in the linked view '[View Name from Link]'.\nTo resolve the issue, open the Revit link file for editing, select the main model room, and use the Add to Design Option Set tool.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId OptionConflictInLinkBoundariesVaryMainAddToOptionSet { get; }
Public Shared ReadOnly Property OptionConflictInLinkBoundariesVaryMainAddToOptionSet As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ OptionConflictInLinkBoundariesVaryMainAddToOptionSet {
    FailureDefinitionId^ get ();
}
static member OptionConflictInLinkBoundariesVaryMainAddToOptionSet : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.RoomFailures.OptionConflictInLinkBoundariesVaryMainSeparate Property

BuiltInFailuresRoomFailuresOptionConflictInLinkBoundariesVaryMainSeparate Property

Option conflict between rooms in the Revit link '[Link Instance Name]'.\nThe room boundary in the main model of the Revit link differs from the apparent boundary in the linked view '[View Name from Link]'.\nTo resolve the issue, open the Revit link file for editing, and use room separation lines to divide the space in the main model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId OptionConflictInLinkBoundariesVaryMainSeparate { get; }
Public Shared ReadOnly Property OptionConflictInLinkBoundariesVaryMainSeparate As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ OptionConflictInLinkBoundariesVaryMainSeparate {
    FailureDefinitionId^ get ();
}
static member OptionConflictInLinkBoundariesVaryMainSeparate : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.RoomFailures.OptionConflictInLinkBoundariesVaryOptionSeparate Property

BuiltInFailuresRoomFailuresOptionConflictInLinkBoundariesVaryOptionSeparate Property

Option conflict between rooms in the Revit link '[Link Instance Name]'.\nThe room boundary differs from the apparent boundary in the linked view '[View Name from Link]'.\nTo resolve the issue, open the Revit link file for editing, and use room separation lines to divide the space in the main model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId OptionConflictInLinkBoundariesVaryOptionSeparate { get; }
Public Shared ReadOnly Property OptionConflictInLinkBoundariesVaryOptionSeparate As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ OptionConflictInLinkBoundariesVaryOptionSeparate {
    FailureDefinitionId^ get ();
}
static member OptionConflictInLinkBoundariesVaryOptionSeparate : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.RoomFailures.OptionConflictInLinkRoomOverlapMain Property

BuiltInFailuresRoomFailuresOptionConflictInLinkRoomOverlapMain Property

Option conflict between rooms in the Revit link '[Link Instance Name]'.\nThe room in the Revit link's option '[Option Name in Link]' overlaps a room in the main model.\nTo resolve the issue, open the Revit link file for editing, select the main model room, and use the Add to Design Option Set tool.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId OptionConflictInLinkRoomOverlapMain { get; }
Public Shared ReadOnly Property OptionConflictInLinkRoomOverlapMain As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ OptionConflictInLinkRoomOverlapMain {
    FailureDefinitionId^ get ();
}
static member OptionConflictInLinkRoomOverlapMain : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.RoomFailures.OptionConflictInLinkRoomOverlapOption Property

BuiltInFailuresRoomFailuresOptionConflictInLinkRoomOverlapOption Property

Option conflict between rooms in the Revit link '[Link Instance Name]'.\nA room in the Revit link's option '[Option #1 Name in Link]' overlaps a room in the Revit link's option '[Option #2 Name in Link]'.\nTo resolve the issue, open the Revit link file for editing, and delete the duplicate room or use room separation lines to divide the space in the main model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId OptionConflictInLinkRoomOverlapOption { get; }
Public Shared ReadOnly Property OptionConflictInLinkRoomOverlapOption As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ OptionConflictInLinkRoomOverlapOption {
    FailureDefinitionId^ get ();
}
static member OptionConflictInLinkRoomOverlapOption : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.RoomFailures.OptionConflictRoomOverlapMain Property

BuiltInFailuresRoomFailuresOptionConflictRoomOverlapMain Property

Option Conflict between Rooms.\nRoom in Option '[Option Name]' overlaps Room in the Main Model.\nTo resolve, select the Main Model Room and use the Add to Design Option Set command.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId OptionConflictRoomOverlapMain { get; }
Public Shared ReadOnly Property OptionConflictRoomOverlapMain As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ OptionConflictRoomOverlapMain {
    FailureDefinitionId^ get ();
}
static member OptionConflictRoomOverlapMain : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.RoomFailures.OptionConflictRoomOverlapOption Property

BuiltInFailuresRoomFailuresOptionConflictRoomOverlapOption Property

Option Conflict between Rooms.\nRoom in Option '[Option Name]' overlaps Room in Option '[Option Name]'.\nTo resolve, delete the duplicate Room or divide space with Room Separation Lines in the Main Model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId OptionConflictRoomOverlapOption { get; }
Public Shared ReadOnly Property OptionConflictRoomOverlapOption As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ OptionConflictRoomOverlapOption {
    FailureDefinitionId^ get ();
}
static member OptionConflictRoomOverlapOption : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.RoomFailures.RoomBaseAboveComputationHeight Property

BuiltInFailuresRoomFailuresRoomBaseAboveComputationHeight Property

[RoomBase]'s lower offset is above the Computation Height

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RoomBaseAboveComputationHeight { get; }
Public Shared ReadOnly Property RoomBaseAboveComputationHeight As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RoomBaseAboveComputationHeight {
    FailureDefinitionId^ get ();
}
static member RoomBaseAboveComputationHeight : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.RoomFailures.RoomBelowCompHeight Property

BuiltInFailuresRoomFailuresRoomBelowCompHeight Property

[Room] Volume is being calculated above the Upper Limit of this [Room]. Change the Upper Limit and Offset or change the height of volume calculations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RoomBelowCompHeight { get; }
Public Shared ReadOnly Property RoomBelowCompHeight As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RoomBelowCompHeight {
    FailureDefinitionId^ get ();
}
static member RoomBelowCompHeight : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.RoomFailures.RoomBoundaryMisalignment Property

BuiltInFailuresRoomFailuresRoomBoundaryMisalignment Property

[Room] bounding element might be misaligned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RoomBoundaryMisalignment { get; }
Public Shared ReadOnly Property RoomBoundaryMisalignment As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RoomBoundaryMisalignment {
    FailureDefinitionId^ get ();
}
static member RoomBoundaryMisalignment : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.RoomFailures.RoomHeightNegative Property

BuiltInFailuresRoomFailuresRoomHeightNegative Property

[Room] must have a height greater than 0.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RoomHeightNegative { get; }
Public Shared ReadOnly Property RoomHeightNegative As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RoomHeightNegative {
    FailureDefinitionId^ get ();
}
static member RoomHeightNegative : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.RoomFailures.RoomLevelElevs Property

BuiltInFailuresRoomFailuresRoomLevelElevs Property

A [Room]s Upper Limit must be above its Base Level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RoomLevelElevs { get; }
Public Shared ReadOnly Property RoomLevelElevs As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RoomLevelElevs {
    FailureDefinitionId^ get ();
}
static member RoomLevelElevs : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.RoomFailures.RoomNotEnclosed Property

BuiltInFailuresRoomFailuresRoomNotEnclosed Property

[Room] is not in a properly enclosed region

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RoomNotEnclosed { get; }
Public Shared ReadOnly Property RoomNotEnclosed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RoomNotEnclosed {
    FailureDefinitionId^ get ();
}
static member RoomNotEnclosed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.RoomFailures.RoomNotEnclosedAreas Property

BuiltInFailuresRoomFailuresRoomNotEnclosedAreas Property

[Room] is not in a properly enclosed region

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RoomNotEnclosedAreas { get; }
Public Shared ReadOnly Property RoomNotEnclosedAreas As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RoomNotEnclosedAreas {
    FailureDefinitionId^ get ();
}
static member RoomNotEnclosedAreas : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.RoomFailures.RoomNotEnclosedLoadAreas Property

BuiltInFailuresRoomFailuresRoomNotEnclosedLoadAreas Property

[Room] is not in a properly enclosed region

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RoomNotEnclosedLoadAreas { get; }
Public Shared ReadOnly Property RoomNotEnclosedLoadAreas As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RoomNotEnclosedLoadAreas {
    FailureDefinitionId^ get ();
}
static member RoomNotEnclosedLoadAreas : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.RoomFailures.RoomNotEnclosedRooms Property

BuiltInFailuresRoomFailuresRoomNotEnclosedRooms Property

[Room] is not in a properly enclosed region

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RoomNotEnclosedRooms { get; }
Public Shared ReadOnly Property RoomNotEnclosedRooms As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RoomNotEnclosedRooms {
    FailureDefinitionId^ get ();
}
static member RoomNotEnclosedRooms : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.RoomFailures.RoomNotEnclosedSpaces Property

BuiltInFailuresRoomFailuresRoomNotEnclosedSpaces Property

[Room] is not in a properly enclosed region

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RoomNotEnclosedSpaces { get; }
Public Shared ReadOnly Property RoomNotEnclosedSpaces As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RoomNotEnclosedSpaces {
    FailureDefinitionId^ get ();
}
static member RoomNotEnclosedSpaces : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.RoomFailures.RoomsCreatedAutomatically Property

BuiltInFailuresRoomFailuresRoomsCreatedAutomatically Property

[Room] [Room] created automatically.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RoomsCreatedAutomatically { get; }
Public Shared ReadOnly Property RoomsCreatedAutomatically As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RoomsCreatedAutomatically {
    FailureDefinitionId^ get ();
}
static member RoomsCreatedAutomatically : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.RoomFailures.RoomsFailed Property

BuiltInFailuresRoomFailuresRoomsFailed Property

[Room] computations only succeeded without considering the following elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RoomsFailed { get; }
Public Shared ReadOnly Property RoomsFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RoomsFailed {
    FailureDefinitionId^ get ();
}
static member RoomsFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.RoomFailures.RoomsInSameRegion Property

BuiltInFailuresRoomFailuresRoomsInSameRegion Property

Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RoomsInSameRegion { get; }
Public Shared ReadOnly Property RoomsInSameRegion As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RoomsInSameRegion {
    FailureDefinitionId^ get ();
}
static member RoomsInSameRegion : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.RoomFailures.RoomsInSameRegionAreas Property

BuiltInFailuresRoomFailuresRoomsInSameRegionAreas Property

Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RoomsInSameRegionAreas { get; }
Public Shared ReadOnly Property RoomsInSameRegionAreas As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RoomsInSameRegionAreas {
    FailureDefinitionId^ get ();
}
static member RoomsInSameRegionAreas : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.RoomFailures.RoomsInSameRegionLoadAreas Property

BuiltInFailuresRoomFailuresRoomsInSameRegionLoadAreas Property

Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RoomsInSameRegionLoadAreas { get; }
Public Shared ReadOnly Property RoomsInSameRegionLoadAreas As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RoomsInSameRegionLoadAreas {
    FailureDefinitionId^ get ();
}
static member RoomsInSameRegionLoadAreas : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.RoomFailures.RoomsInSameRegionRooms Property

BuiltInFailuresRoomFailuresRoomsInSameRegionRooms Property

Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RoomsInSameRegionRooms { get; }
Public Shared ReadOnly Property RoomsInSameRegionRooms As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RoomsInSameRegionRooms {
    FailureDefinitionId^ get ();
}
static member RoomsInSameRegionRooms : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.RoomFailures.RoomsInSameRegionSpaces Property

BuiltInFailuresRoomFailuresRoomsInSameRegionSpaces Property

Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RoomsInSameRegionSpaces { get; }
Public Shared ReadOnly Property RoomsInSameRegionSpaces As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RoomsInSameRegionSpaces {
    FailureDefinitionId^ get ();
}
static member RoomsInSameRegionSpaces : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.RoomFailures.RoomsOverlapInHeight Property

BuiltInFailuresRoomFailuresRoomsOverlapInHeight Property

[Room] volumes overlap. Adjust the Upper Limit and Limit Offset properties of the [rooms].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RoomsOverlapInHeight { get; }
Public Shared ReadOnly Property RoomsOverlapInHeight As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RoomsOverlapInHeight {
    FailureDefinitionId^ get ();
}
static member RoomsOverlapInHeight : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.RoomFailures.RoomsReallyFailed Property

BuiltInFailuresRoomFailuresRoomsReallyFailed Property

[Room] computations failed. Try to modify the following elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RoomsReallyFailed { get; }
Public Shared ReadOnly Property RoomsReallyFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RoomsReallyFailed {
    FailureDefinitionId^ get ();
}
static member RoomsReallyFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.RoomFailures.RoomTagBadViewType Property

BuiltInFailuresRoomFailuresRoomTagBadViewType Property

[Room] Tags can only be placed in Floor Plan, Reflected Ceiling Plan and Section Views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RoomTagBadViewType { get; }
Public Shared ReadOnly Property RoomTagBadViewType As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RoomTagBadViewType {
    FailureDefinitionId^ get ();
}
static member RoomTagBadViewType : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.RoomFailures.RoomTagDeleted Property

BuiltInFailuresRoomFailuresRoomTagDeleted Property

A [Room] Tag was deleted, but the corresponding [Room] still exists. You can place another tag for the [Room] using the [Room] Tag tool or select the [Room] and delete it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RoomTagDeleted { get; }
Public Shared ReadOnly Property RoomTagDeleted As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RoomTagDeleted {
    FailureDefinitionId^ get ();
}
static member RoomTagDeleted : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.RoomFailures.RoomTagNotInRoom Property

BuiltInFailuresRoomFailuresRoomTagNotInRoom Property

[Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RoomTagNotInRoom { get; }
Public Shared ReadOnly Property RoomTagNotInRoom As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RoomTagNotInRoom {
    FailureDefinitionId^ get ();
}
static member RoomTagNotInRoom : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.RoomFailures.RoomTagNotInRoomToArea Property

BuiltInFailuresRoomFailuresRoomTagNotInRoomToArea Property

[Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RoomTagNotInRoomToArea { get; }
Public Shared ReadOnly Property RoomTagNotInRoomToArea As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RoomTagNotInRoomToArea {
    FailureDefinitionId^ get ();
}
static member RoomTagNotInRoomToArea : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.RoomFailures.RoomTagNotInRoomToRoom Property

BuiltInFailuresRoomFailuresRoomTagNotInRoomToRoom Property

[Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RoomTagNotInRoomToRoom { get; }
Public Shared ReadOnly Property RoomTagNotInRoomToRoom As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RoomTagNotInRoomToRoom {
    FailureDefinitionId^ get ();
}
static member RoomTagNotInRoomToRoom : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.RoomFailures.RoomTagNotInRoomToSpace Property

BuiltInFailuresRoomFailuresRoomTagNotInRoomToSpace Property

[Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RoomTagNotInRoomToSpace { get; }
Public Shared ReadOnly Property RoomTagNotInRoomToSpace As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RoomTagNotInRoomToSpace {
    FailureDefinitionId^ get ();
}
static member RoomTagNotInRoomToSpace : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.RoomFailures.RoomTagVolumeNotComputed Property

BuiltInFailuresRoomFailuresRoomTagVolumeNotComputed Property

[Room] Tag is displaying volume that can't be computed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RoomTagVolumeNotComputed { get; }
Public Shared ReadOnly Property RoomTagVolumeNotComputed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RoomTagVolumeNotComputed {
    FailureDefinitionId^ get ();
}
static member RoomTagVolumeNotComputed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.RoomFailures.RoomTooShort Property

BuiltInFailuresRoomFailuresRoomTooShort Property

[Room] is very short. If this is not intended, change its Upper Limit and Offset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RoomTooShort { get; }
Public Shared ReadOnly Property RoomTooShort As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RoomTooShort {
    FailureDefinitionId^ get ();
}
static member RoomTooShort : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.RoomFailures.RoomUnplaceWarning Property

BuiltInFailuresRoomFailuresRoomUnplaceWarning Property

A Room was deleted from all model views but still remains in this project. \n The room can be removed from any schedule or placed back in the model using the Room command.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RoomUnplaceWarning { get; }
Public Shared ReadOnly Property RoomUnplaceWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RoomUnplaceWarning {
    FailureDefinitionId^ get ();
}
static member RoomUnplaceWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.RoomFailures.ShowRoomBoundingElements Property

BuiltInFailuresRoomFailuresShowRoomBoundingElements Property

[Room] Bounding elements are highlighted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ShowRoomBoundingElements { get; }
Public Shared ReadOnly Property ShowRoomBoundingElements As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ShowRoomBoundingElements {
    FailureDefinitionId^ get ();
}
static member ShowRoomBoundingElements : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.RoomFailures.SpaceUnplaceWarning Property

BuiltInFailuresRoomFailuresSpaceUnplaceWarning Property

A Space was deleted from all model views but still remains in this project. \n The Space can be removed from any schedule or placed back in the model using the Space command.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SpaceUnplaceWarning { get; }
Public Shared ReadOnly Property SpaceUnplaceWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SpaceUnplaceWarning {
    FailureDefinitionId^ get ();
}
static member SpaceUnplaceWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresRoomFailures Class


BuiltInFailures.ScaleFailures Class

BuiltInFailuresScaleFailures Class

Failures about Scale.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresScaleFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ScaleFailures
Public NotInheritable Class ScaleFailures
public ref class ScaleFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ScaleFailures = class end

The BuiltInFailuresScaleFailures type exposes the following members.

Properties
Name | Description
CannotScaleLinkWithSharedCoordinates | Can't scale link that shares coordinates with host model
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ScaleFailures Properties

The BuiltInFailuresScaleFailures type exposes the following members.

Properties
Name | Description
CannotScaleLinkWithSharedCoordinates | Can't scale link that shares coordinates with host model
Top
See Also

Reference

BuiltInFailuresScaleFailures Class


BuiltInFailures.ScaleFailures.CannotScaleLinkWithSharedCoordinates Property

BuiltInFailuresScaleFailuresCannotScaleLinkWithSharedCoordinates Property

Can't scale link that shares coordinates with host model

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotScaleLinkWithSharedCoordinates { get; }
Public Shared ReadOnly Property CannotScaleLinkWithSharedCoordinates As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotScaleLinkWithSharedCoordinates {
    FailureDefinitionId^ get ();
}
static member CannotScaleLinkWithSharedCoordinates : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresScaleFailures Class


BuiltInFailures.ScheduleViewFailures Class

BuiltInFailuresScheduleViewFailures Class

Failures about Schedule.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresScheduleViewFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ScheduleViewFailures
Public NotInheritable Class ScheduleViewFailures
public ref class ScheduleViewFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ScheduleViewFailures = class end

The BuiltInFailuresScheduleViewFailures type exposes the following members.

Properties
Name | Description
BadViewType | Schedules can only be placed on Sheets.
CannotResizeColumn | Can't resize column.
ColumnsExceedSegment | Some columns in Graphical Column Schedule exceed the segment's upper/lower bounds. You can add levels or adjust the view parameters.
ColumnsExcluded | Some columns in the project are excluded from the graphical column schedule view.
CustomFieldNecessaryIdDeleted | An element that is needed to compute the field [field name] from [schedule name] schedule was deleted.
DuplicateFieldRemovedFromKeySchedule | Duplicate fields across key schedules will be removed after paste.
NoColumnsJoinedToGridLines | No columns are joined to grid lines, or view parameters exclude all columns.
NotGridName | '[Text]' is not a Grid line name
PanelScheduleDataPanelSlotInconsistency | The template applied to this panel schedule is set to display fewer space than what is needed to display the max amount of circuits set on the equipment.
PanelScheduleLoadClassInconsistency | You have one or more loads connected to this panel that are not displayed in the panel schedule. Add the load classification(s) to the associated template to report this information in the Loads Summary.
PanelScheduleSlotInconsistency | The template applied to this panel schedule is set to display fewer slots than what is needed to display the maximum number of 1-pole breakers set on the equipment.
PanelScheduleSwitchboardSlotInconsistency | The template applied to this panel schedule is set to display fewer space than what is needed to display the max number of circuits set on the equipment.
SchedulesCanBePlacedOnSheetsOnly | Schedules can only be placed on Sheets.
SegmentsStartIsGreaterThanSegmentsEnd | Change values so Segments End is greater than or equal to Segments Start.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ScheduleViewFailures Properties

The BuiltInFailuresScheduleViewFailures type exposes the following members.

Properties
Name | Description
BadViewType | Schedules can only be placed on Sheets.
CannotResizeColumn | Can't resize column.
ColumnsExceedSegment | Some columns in Graphical Column Schedule exceed the segment's upper/lower bounds. You can add levels or adjust the view parameters.
ColumnsExcluded | Some columns in the project are excluded from the graphical column schedule view.
CustomFieldNecessaryIdDeleted | An element that is needed to compute the field [field name] from [schedule name] schedule was deleted.
DuplicateFieldRemovedFromKeySchedule | Duplicate fields across key schedules will be removed after paste.
NoColumnsJoinedToGridLines | No columns are joined to grid lines, or view parameters exclude all columns.
NotGridName | '[Text]' is not a Grid line name
PanelScheduleDataPanelSlotInconsistency | The template applied to this panel schedule is set to display fewer space than what is needed to display the max amount of circuits set on the equipment.
PanelScheduleLoadClassInconsistency | You have one or more loads connected to this panel that are not displayed in the panel schedule. Add the load classification(s) to the associated template to report this information in the Loads Summary.
PanelScheduleSlotInconsistency | The template applied to this panel schedule is set to display fewer slots than what is needed to display the maximum number of 1-pole breakers set on the equipment.
PanelScheduleSwitchboardSlotInconsistency | The template applied to this panel schedule is set to display fewer space than what is needed to display the max number of circuits set on the equipment.
SchedulesCanBePlacedOnSheetsOnly | Schedules can only be placed on Sheets.
SegmentsStartIsGreaterThanSegmentsEnd | Change values so Segments End is greater than or equal to Segments Start.
Top
See Also

Reference

BuiltInFailuresScheduleViewFailures Class


BuiltInFailures.ScheduleViewFailures.BadViewType Property

BuiltInFailuresScheduleViewFailuresBadViewType Property

Schedules can only be placed on Sheets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BadViewType { get; }
Public Shared ReadOnly Property BadViewType As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BadViewType {
    FailureDefinitionId^ get ();
}
static member BadViewType : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresScheduleViewFailures Class


BuiltInFailures.ScheduleViewFailures.CannotResizeColumn Property

BuiltInFailuresScheduleViewFailuresCannotResizeColumn Property

Can't resize column.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotResizeColumn { get; }
Public Shared ReadOnly Property CannotResizeColumn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotResizeColumn {
    FailureDefinitionId^ get ();
}
static member CannotResizeColumn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresScheduleViewFailures Class


BuiltInFailures.ScheduleViewFailures.ColumnsExceedSegment Property

BuiltInFailuresScheduleViewFailuresColumnsExceedSegment Property

Some columns in Graphical Column Schedule exceed the segment's upper/lower bounds. You can add levels or adjust the view parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ColumnsExceedSegment { get; }
Public Shared ReadOnly Property ColumnsExceedSegment As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ColumnsExceedSegment {
    FailureDefinitionId^ get ();
}
static member ColumnsExceedSegment : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresScheduleViewFailures Class


BuiltInFailures.ScheduleViewFailures.ColumnsExcluded Property

BuiltInFailuresScheduleViewFailuresColumnsExcluded Property

Some columns in the project are excluded from the graphical column schedule view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ColumnsExcluded { get; }
Public Shared ReadOnly Property ColumnsExcluded As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ColumnsExcluded {
    FailureDefinitionId^ get ();
}
static member ColumnsExcluded : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresScheduleViewFailures Class


BuiltInFailures.ScheduleViewFailures.CustomFieldNecessaryIdDeleted Property

BuiltInFailuresScheduleViewFailuresCustomFieldNecessaryIdDeleted Property

An element that is needed to compute the field [field name] from [schedule name] schedule was deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CustomFieldNecessaryIdDeleted { get; }
Public Shared ReadOnly Property CustomFieldNecessaryIdDeleted As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CustomFieldNecessaryIdDeleted {
    FailureDefinitionId^ get ();
}
static member CustomFieldNecessaryIdDeleted : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresScheduleViewFailures Class


BuiltInFailures.ScheduleViewFailures.DuplicateFieldRemovedFromKeySchedule Property

BuiltInFailuresScheduleViewFailuresDuplicateFieldRemovedFromKeySchedule Property

Duplicate fields across key schedules will be removed after paste.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DuplicateFieldRemovedFromKeySchedule { get; }
Public Shared ReadOnly Property DuplicateFieldRemovedFromKeySchedule As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DuplicateFieldRemovedFromKeySchedule {
    FailureDefinitionId^ get ();
}
static member DuplicateFieldRemovedFromKeySchedule : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresScheduleViewFailures Class


BuiltInFailures.ScheduleViewFailures.NoColumnsJoinedToGridLines Property

BuiltInFailuresScheduleViewFailuresNoColumnsJoinedToGridLines Property

No columns are joined to grid lines, or view parameters exclude all columns.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoColumnsJoinedToGridLines { get; }
Public Shared ReadOnly Property NoColumnsJoinedToGridLines As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoColumnsJoinedToGridLines {
    FailureDefinitionId^ get ();
}
static member NoColumnsJoinedToGridLines : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresScheduleViewFailures Class


BuiltInFailures.ScheduleViewFailures.NotGridName Property

BuiltInFailuresScheduleViewFailuresNotGridName Property

'[Text]' is not a Grid line name

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotGridName { get; }
Public Shared ReadOnly Property NotGridName As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotGridName {
    FailureDefinitionId^ get ();
}
static member NotGridName : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresScheduleViewFailures Class


BuiltInFailures.ScheduleViewFailures.PanelScheduleDataPanelSlotInconsistency Property

BuiltInFailuresScheduleViewFailuresPanelScheduleDataPanelSlotInconsistency Property

The template applied to this panel schedule is set to display fewer space than what is needed to display the max amount of circuits set on the equipment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PanelScheduleDataPanelSlotInconsistency { get; }
Public Shared ReadOnly Property PanelScheduleDataPanelSlotInconsistency As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PanelScheduleDataPanelSlotInconsistency {
    FailureDefinitionId^ get ();
}
static member PanelScheduleDataPanelSlotInconsistency : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresScheduleViewFailures Class


BuiltInFailures.ScheduleViewFailures.PanelScheduleLoadClassInconsistency Property

BuiltInFailuresScheduleViewFailuresPanelScheduleLoadClassInconsistency Property

You have one or more loads connected to this panel that are not displayed in the panel schedule. Add the load classification(s) to the associated template to report this information in the Loads Summary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PanelScheduleLoadClassInconsistency { get; }
Public Shared ReadOnly Property PanelScheduleLoadClassInconsistency As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PanelScheduleLoadClassInconsistency {
    FailureDefinitionId^ get ();
}
static member PanelScheduleLoadClassInconsistency : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresScheduleViewFailures Class


BuiltInFailures.ScheduleViewFailures.PanelScheduleSlotInconsistency Property

BuiltInFailuresScheduleViewFailuresPanelScheduleSlotInconsistency Property

The template applied to this panel schedule is set to display fewer slots than what is needed to display the maximum number of 1-pole breakers set on the equipment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PanelScheduleSlotInconsistency { get; }
Public Shared ReadOnly Property PanelScheduleSlotInconsistency As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PanelScheduleSlotInconsistency {
    FailureDefinitionId^ get ();
}
static member PanelScheduleSlotInconsistency : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresScheduleViewFailures Class


BuiltInFailures.ScheduleViewFailures.PanelScheduleSwitchboardSlotInconsistency Property

BuiltInFailuresScheduleViewFailuresPanelScheduleSwitchboardSlotInconsistency Property

The template applied to this panel schedule is set to display fewer space than what is needed to display the max number of circuits set on the equipment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PanelScheduleSwitchboardSlotInconsistency { get; }
Public Shared ReadOnly Property PanelScheduleSwitchboardSlotInconsistency As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PanelScheduleSwitchboardSlotInconsistency {
    FailureDefinitionId^ get ();
}
static member PanelScheduleSwitchboardSlotInconsistency : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresScheduleViewFailures Class


BuiltInFailures.ScheduleViewFailures.SchedulesCanBePlacedOnSheetsOnly Property

BuiltInFailuresScheduleViewFailuresSchedulesCanBePlacedOnSheetsOnly Property

Schedules can only be placed on Sheets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SchedulesCanBePlacedOnSheetsOnly { get; }
Public Shared ReadOnly Property SchedulesCanBePlacedOnSheetsOnly As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SchedulesCanBePlacedOnSheetsOnly {
    FailureDefinitionId^ get ();
}
static member SchedulesCanBePlacedOnSheetsOnly : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresScheduleViewFailures Class


BuiltInFailures.ScheduleViewFailures.SegmentsStartIsGreaterThanSegmentsEnd Property

BuiltInFailuresScheduleViewFailuresSegmentsStartIsGreaterThanSegmentsEnd Property

Change values so Segments End is greater than or equal to Segments Start.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SegmentsStartIsGreaterThanSegmentsEnd { get; }
Public Shared ReadOnly Property SegmentsStartIsGreaterThanSegmentsEnd As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SegmentsStartIsGreaterThanSegmentsEnd {
    FailureDefinitionId^ get ();
}
static member SegmentsStartIsGreaterThanSegmentsEnd : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresScheduleViewFailures Class


BuiltInFailures.SculptingFailures Class

BuiltInFailuresSculptingFailures Class

Failures about Sculpting.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresSculptingFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class SculptingFailures
Public NotInheritable Class SculptingFailures
public ref class SculptingFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SculptingFailures = class end

The BuiltInFailuresSculptingFailures type exposes the following members.

Properties
Name | Description
FaceSculptEditFailed | Face Sculpt Edit failed.
FaceSculptingFaceLoss | The original sculpted face is lost.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SculptingFailures Properties

The BuiltInFailuresSculptingFailures type exposes the following members.

Properties
Name | Description
FaceSculptEditFailed | Face Sculpt Edit failed.
FaceSculptingFaceLoss | The original sculpted face is lost.
Top
See Also

Reference

BuiltInFailuresSculptingFailures Class


BuiltInFailures.SculptingFailures.FaceSculptEditFailed Property

BuiltInFailuresSculptingFailuresFaceSculptEditFailed Property

Face Sculpt Edit failed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FaceSculptEditFailed { get; }
Public Shared ReadOnly Property FaceSculptEditFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FaceSculptEditFailed {
    FailureDefinitionId^ get ();
}
static member FaceSculptEditFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSculptingFailures Class


BuiltInFailures.SculptingFailures.FaceSculptingFaceLoss Property

BuiltInFailuresSculptingFailuresFaceSculptingFaceLoss Property

The original sculpted face is lost.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FaceSculptingFaceLoss { get; }
Public Shared ReadOnly Property FaceSculptingFaceLoss As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FaceSculptingFaceLoss {
    FailureDefinitionId^ get ();
}
static member FaceSculptingFaceLoss : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSculptingFailures Class


BuiltInFailures.SectionViewFailures Class

BuiltInFailuresSectionViewFailures Class

Failures about Section.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresSectionViewFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class SectionViewFailures
Public NotInheritable Class SectionViewFailures
public ref class SectionViewFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SectionViewFailures = class end

The BuiltInFailuresSectionViewFailures type exposes the following members.

Properties
Name | Description
ScopeBoxBehindSection | Section may not be associated to a scope box which lies behind it.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SectionViewFailures Properties

The BuiltInFailuresSectionViewFailures type exposes the following members.

Properties
Name | Description
ScopeBoxBehindSection | Section may not be associated to a scope box which lies behind it.
Top
See Also

Reference

BuiltInFailuresSectionViewFailures Class


BuiltInFailures.SectionViewFailures.ScopeBoxBehindSection Property

BuiltInFailuresSectionViewFailuresScopeBoxBehindSection Property

Section may not be associated to a scope box which lies behind it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ScopeBoxBehindSection { get; }
Public Shared ReadOnly Property ScopeBoxBehindSection As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ScopeBoxBehindSection {
    FailureDefinitionId^ get ();
}
static member ScopeBoxBehindSection : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSectionViewFailures Class


BuiltInFailures.SelectionFailures Class

BuiltInFailuresSelectionFailures Class

Failures about Selections.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresSelectionFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class SelectionFailures
Public NotInheritable Class SelectionFailures
public ref class SelectionFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SelectionFailures = class end

The BuiltInFailuresSelectionFailures type exposes the following members.

Properties
Name | Description
NoElementSelected | No element selected.
NoValidElementSelected | No valid element selected.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SelectionFailures Properties

The BuiltInFailuresSelectionFailures type exposes the following members.

Properties
Name | Description
NoElementSelected | No element selected.
NoValidElementSelected | No valid element selected.
Top
See Also

Reference

BuiltInFailuresSelectionFailures Class


BuiltInFailures.SelectionFailures.NoElementSelected Property

BuiltInFailuresSelectionFailuresNoElementSelected Property

No element selected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoElementSelected { get; }
Public Shared ReadOnly Property NoElementSelected As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoElementSelected {
    FailureDefinitionId^ get ();
}
static member NoElementSelected : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSelectionFailures Class


BuiltInFailures.SelectionFailures.NoValidElementSelected Property

BuiltInFailuresSelectionFailuresNoValidElementSelected Property

No valid element selected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoValidElementSelected { get; }
Public Shared ReadOnly Property NoValidElementSelected As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoValidElementSelected {
    FailureDefinitionId^ get ();
}
static member NoValidElementSelected : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSelectionFailures Class


BuiltInFailures.SharedCoordinatesFailures Class

BuiltInFailuresSharedCoordinatesFailures Class

Failures about shared coordinates.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresSharedCoordinatesFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class SharedCoordinatesFailures
Public NotInheritable Class SharedCoordinatesFailures
public ref class SharedCoordinatesFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SharedCoordinatesFailures = class end

The BuiltInFailuresSharedCoordinatesFailures type exposes the following members.

Properties
Name | Description
CannotAcquireCoordinatesFromLinkWithScaledLocation | Can't acquire coordiantes from a link that has a scaled location.
CannotAcquireCoordinatesFromScaledLink | Can't acquire coordinates from a link that is scaled.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SharedCoordinatesFailures Properties

The BuiltInFailuresSharedCoordinatesFailures type exposes the following members.

Properties
Name | Description
CannotAcquireCoordinatesFromLinkWithScaledLocation | Can't acquire coordiantes from a link that has a scaled location.
CannotAcquireCoordinatesFromScaledLink | Can't acquire coordinates from a link that is scaled.
Top
See Also

Reference

BuiltInFailuresSharedCoordinatesFailures Class


BuiltInFailures.SharedCoordinatesFailures.CannotAcquireCoordinatesFromLinkWithScaledLocation Property

BuiltInFailuresSharedCoordinatesFailuresCannotAcquireCoordinatesFromLinkWithScaledLocation Property

Can't acquire coordiantes from a link that has a scaled location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotAcquireCoordinatesFromLinkWithScaledLocation { get; }
Public Shared ReadOnly Property CannotAcquireCoordinatesFromLinkWithScaledLocation As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotAcquireCoordinatesFromLinkWithScaledLocation {
    FailureDefinitionId^ get ();
}
static member CannotAcquireCoordinatesFromLinkWithScaledLocation : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSharedCoordinatesFailures Class


BuiltInFailures.SharedCoordinatesFailures.CannotAcquireCoordinatesFromScaledLink Property

BuiltInFailuresSharedCoordinatesFailuresCannotAcquireCoordinatesFromScaledLink Property

Can't acquire coordinates from a link that is scaled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotAcquireCoordinatesFromScaledLink { get; }
Public Shared ReadOnly Property CannotAcquireCoordinatesFromScaledLink As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotAcquireCoordinatesFromScaledLink {
    FailureDefinitionId^ get ();
}
static member CannotAcquireCoordinatesFromScaledLink : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSharedCoordinatesFailures Class


BuiltInFailures.SheetCollectionFailures Class

BuiltInFailuresSheetCollectionFailures Class

Failures about SheetCollection.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresSheetCollectionFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class SheetCollectionFailures
Public NotInheritable Class SheetCollectionFailures
public ref class SheetCollectionFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SheetCollectionFailures = class end

The BuiltInFailuresSheetCollectionFailures type exposes the following members.

Properties
Name | Description
SheetCollectionDuplicateName | Sheet Collection name is already in use. Provide a unique name.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SheetCollectionFailures Properties

The BuiltInFailuresSheetCollectionFailures type exposes the following members.

Properties
Name | Description
SheetCollectionDuplicateName | Sheet Collection name is already in use. Provide a unique name.
Top
See Also

Reference

BuiltInFailuresSheetCollectionFailures Class


BuiltInFailures.SheetCollectionFailures.SheetCollectionDuplicateName Property

BuiltInFailuresSheetCollectionFailuresSheetCollectionDuplicateName Property

Sheet Collection name is already in use. Provide a unique name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SheetCollectionDuplicateName { get; }
Public Shared ReadOnly Property SheetCollectionDuplicateName As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SheetCollectionDuplicateName {
    FailureDefinitionId^ get ();
}
static member SheetCollectionDuplicateName : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSheetCollectionFailures Class


BuiltInFailures.SheetFailures Class

BuiltInFailuresSheetFailures Class

Failures about Sheet.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresSheetFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class SheetFailures
Public NotInheritable Class SheetFailures
public ref class SheetFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SheetFailures = class end

The BuiltInFailuresSheetFailures type exposes the following members.

Properties
Name | Description
SheetNumberDuplicated | Sheet Number is already in use. Enter a unique number.
SheetNumberDuplicatedPerSheetCollection | Sheet Number is already in use. The same Sheet Number value can be used once for all sheets directly in the model, and once for all sheets per Sheet Collection.
SheetNumberEmpty | Sheet Number is empty
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SheetFailures Properties

The BuiltInFailuresSheetFailures type exposes the following members.

Properties
Name | Description
SheetNumberDuplicated | Sheet Number is already in use. Enter a unique number.
SheetNumberDuplicatedPerSheetCollection | Sheet Number is already in use. The same Sheet Number value can be used once for all sheets directly in the model, and once for all sheets per Sheet Collection.
SheetNumberEmpty | Sheet Number is empty
Top
See Also

Reference

BuiltInFailuresSheetFailures Class


BuiltInFailures.SheetFailures.SheetNumberDuplicated Property

BuiltInFailuresSheetFailuresSheetNumberDuplicated Property

Sheet Number is already in use. Enter a unique number.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SheetNumberDuplicated { get; }
Public Shared ReadOnly Property SheetNumberDuplicated As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SheetNumberDuplicated {
    FailureDefinitionId^ get ();
}
static member SheetNumberDuplicated : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSheetFailures Class


BuiltInFailures.SheetFailures.SheetNumberDuplicatedPerSheetCollection Property

BuiltInFailuresSheetFailuresSheetNumberDuplicatedPerSheetCollection Property

Sheet Number is already in use. The same Sheet Number value can be used once for all sheets directly in the model, and once for all sheets per Sheet Collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SheetNumberDuplicatedPerSheetCollection { get; }
Public Shared ReadOnly Property SheetNumberDuplicatedPerSheetCollection As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SheetNumberDuplicatedPerSheetCollection {
    FailureDefinitionId^ get ();
}
static member SheetNumberDuplicatedPerSheetCollection : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSheetFailures Class


BuiltInFailures.SheetFailures.SheetNumberEmpty Property

BuiltInFailuresSheetFailuresSheetNumberEmpty Property

Sheet Number is empty

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SheetNumberEmpty { get; }
Public Shared ReadOnly Property SheetNumberEmpty As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SheetNumberEmpty {
    FailureDefinitionId^ get ();
}
static member SheetNumberEmpty : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSheetFailures Class


BuiltInFailures.SiteFailures Class

BuiltInFailuresSiteFailures Class

Failures about Site.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresSiteFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class SiteFailures
Public NotInheritable Class SiteFailures
public ref class SiteFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SiteFailures = class end

The BuiltInFailuresSiteFailures type exposes the following members.

Properties
Name | Description
BuildingPadNotConnected | Can't create a single Pad with several connected regions.
BuildingPadOverlap | Pads can't overlap (but can share edges).
CannotComputeProperArea | Property Lines must close. Area will not be computed.
CannotIntersectSiteRegions | Subregions cannot intersect.
CannotMakeSurface | Can't construct surface.
ContourLabelEmpty | Contour Label doesn't intersect any contours.
EnterValueOrFormula | Enter a value or a formula starting with '='.
GradingInSamePhase | The Surface being Graded was created in the current Phase. Grading it will result in it being created and destroyed in the same Phase.
NoHostForSubregion | This Subregion now does not appear to overlap any Toposurface with an appropriate Phase and Design Option.
NoHostForSubregionWarn | This Subregion now does not appear to overlap any Toposurface with an appropriate Phase and Design Option.
NotEnoughPointsInSurface | The surface must have at least three distinct Points.
PointNotInSurface | A Point is outside of the Surface boundary. Insert the Point on the boundary instead, and then drag it to the desired location.
PointRelativeOutside | In order to place Points relative to the existing Surface, the Point must be placed within the area of the existing Surface. The height of the new Point will be relative to the current Surface elevation at that Point.
PropertyIntersect | Property lines intersect. Area calculations will not be precise.
RegionPhaseMismatch | Subregions must have the same Phase Created parameter and Phase Demolished parameter as the host Toposurface. Subregion phase will be set to match the Toposurface.
ResetToposurfacePhaseCreated | The parameter Phase Created of the Toposurface is not set to the first Phase. No pre-existing toposurface were detected. The parameter will be reset to the first Phase unless Keep Phase Created option is picked.
SiteEditPointsClipped | Portions of the topographic surface or points on the surface may not be visible in this view due to clipping by the view.
SiteEditPointsInvisible | Topographic elements are not visible in your current view. You can modify View Range settings in the view's Properties or Visibility settings in Visibility/Graphics. It is often easier to edit topography in a Site view or a 3D view.
SiteMergeDisconnected | The two surfaces you are trying to merge are disconnected from one another. They should overlap, or at least share edges.
SitePhasesDontOverlap | The phases of the two surfaces you are merging do not overlap. You can continue the operation, or cancel it and select a different pair of surfaces.
SiteRegionOptionConflict | Subregions must be in the same Design Option as their Toposurface.
SurfaceSelfIntersection | The splitting boundary drawn would result in a self-intersection of the surface boundary. Please edit your splitting lines to correct the problem.
SurfaceSplit | The splitting boundary must split the Surface into exactly two pieces.
SurfaceSplitError | The splitting boundary must split the Surface into exactly two pieces.
SurfaceSplitNoIntersection | The splitting boundary must divide the Surface into separate pieces. There may be a gap in the splitting Lines or the Sketch may be incomplete.
SurfaceTriangulationFailed | The Site Surface failed to triangulate.
ToposolidSlopeExceedsThreshold | Thickness of this Toposolid may be slightly inaccurate due to extreme Shape Editing. Dimensions to this element in sections and details may not accurately indicate the Thickness shown in Type Properties.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SiteFailures Properties

The BuiltInFailuresSiteFailures type exposes the following members.

Properties
Name | Description
BuildingPadNotConnected | Can't create a single Pad with several connected regions.
BuildingPadOverlap | Pads can't overlap (but can share edges).
CannotComputeProperArea | Property Lines must close. Area will not be computed.
CannotIntersectSiteRegions | Subregions cannot intersect.
CannotMakeSurface | Can't construct surface.
ContourLabelEmpty | Contour Label doesn't intersect any contours.
EnterValueOrFormula | Enter a value or a formula starting with '='.
GradingInSamePhase | The Surface being Graded was created in the current Phase. Grading it will result in it being created and destroyed in the same Phase.
NoHostForSubregion | This Subregion now does not appear to overlap any Toposurface with an appropriate Phase and Design Option.
NoHostForSubregionWarn | This Subregion now does not appear to overlap any Toposurface with an appropriate Phase and Design Option.
NotEnoughPointsInSurface | The surface must have at least three distinct Points.
PointNotInSurface | A Point is outside of the Surface boundary. Insert the Point on the boundary instead, and then drag it to the desired location.
PointRelativeOutside | In order to place Points relative to the existing Surface, the Point must be placed within the area of the existing Surface. The height of the new Point will be relative to the current Surface elevation at that Point.
PropertyIntersect | Property lines intersect. Area calculations will not be precise.
RegionPhaseMismatch | Subregions must have the same Phase Created parameter and Phase Demolished parameter as the host Toposurface. Subregion phase will be set to match the Toposurface.
ResetToposurfacePhaseCreated | The parameter Phase Created of the Toposurface is not set to the first Phase. No pre-existing toposurface were detected. The parameter will be reset to the first Phase unless Keep Phase Created option is picked.
SiteEditPointsClipped | Portions of the topographic surface or points on the surface may not be visible in this view due to clipping by the view.
SiteEditPointsInvisible | Topographic elements are not visible in your current view. You can modify View Range settings in the view's Properties or Visibility settings in Visibility/Graphics. It is often easier to edit topography in a Site view or a 3D view.
SiteMergeDisconnected | The two surfaces you are trying to merge are disconnected from one another. They should overlap, or at least share edges.
SitePhasesDontOverlap | The phases of the two surfaces you are merging do not overlap. You can continue the operation, or cancel it and select a different pair of surfaces.
SiteRegionOptionConflict | Subregions must be in the same Design Option as their Toposurface.
SurfaceSelfIntersection | The splitting boundary drawn would result in a self-intersection of the surface boundary. Please edit your splitting lines to correct the problem.
SurfaceSplit | The splitting boundary must split the Surface into exactly two pieces.
SurfaceSplitError | The splitting boundary must split the Surface into exactly two pieces.
SurfaceSplitNoIntersection | The splitting boundary must divide the Surface into separate pieces. There may be a gap in the splitting Lines or the Sketch may be incomplete.
SurfaceTriangulationFailed | The Site Surface failed to triangulate.
ToposolidSlopeExceedsThreshold | Thickness of this Toposolid may be slightly inaccurate due to extreme Shape Editing. Dimensions to this element in sections and details may not accurately indicate the Thickness shown in Type Properties.
Top
See Also

Reference

BuiltInFailuresSiteFailures Class


BuiltInFailures.SiteFailures.BuildingPadNotConnected Property

BuiltInFailuresSiteFailuresBuildingPadNotConnected Property

Can't create a single Pad with several connected regions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BuildingPadNotConnected { get; }
Public Shared ReadOnly Property BuildingPadNotConnected As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BuildingPadNotConnected {
    FailureDefinitionId^ get ();
}
static member BuildingPadNotConnected : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSiteFailures Class


BuiltInFailures.SiteFailures.BuildingPadOverlap Property

BuiltInFailuresSiteFailuresBuildingPadOverlap Property

Pads can't overlap (but can share edges).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BuildingPadOverlap { get; }
Public Shared ReadOnly Property BuildingPadOverlap As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BuildingPadOverlap {
    FailureDefinitionId^ get ();
}
static member BuildingPadOverlap : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSiteFailures Class


BuiltInFailures.SiteFailures.CannotComputeProperArea Property

BuiltInFailuresSiteFailuresCannotComputeProperArea Property

Property Lines must close. Area will not be computed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotComputeProperArea { get; }
Public Shared ReadOnly Property CannotComputeProperArea As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotComputeProperArea {
    FailureDefinitionId^ get ();
}
static member CannotComputeProperArea : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSiteFailures Class


BuiltInFailures.SiteFailures.CannotIntersectSiteRegions Property

BuiltInFailuresSiteFailuresCannotIntersectSiteRegions Property

Subregions cannot intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotIntersectSiteRegions { get; }
Public Shared ReadOnly Property CannotIntersectSiteRegions As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotIntersectSiteRegions {
    FailureDefinitionId^ get ();
}
static member CannotIntersectSiteRegions : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSiteFailures Class


BuiltInFailures.SiteFailures.CannotMakeSurface Property

BuiltInFailuresSiteFailuresCannotMakeSurface Property

Can't construct surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotMakeSurface { get; }
Public Shared ReadOnly Property CannotMakeSurface As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotMakeSurface {
    FailureDefinitionId^ get ();
}
static member CannotMakeSurface : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSiteFailures Class


BuiltInFailures.SiteFailures.ContourLabelEmpty Property

BuiltInFailuresSiteFailuresContourLabelEmpty Property

Contour Label doesn't intersect any contours.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ContourLabelEmpty { get; }
Public Shared ReadOnly Property ContourLabelEmpty As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ContourLabelEmpty {
    FailureDefinitionId^ get ();
}
static member ContourLabelEmpty : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSiteFailures Class


BuiltInFailures.SiteFailures.EnterValueOrFormula Property

BuiltInFailuresSiteFailuresEnterValueOrFormula Property

Enter a value or a formula starting with '='.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId EnterValueOrFormula { get; }
Public Shared ReadOnly Property EnterValueOrFormula As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ EnterValueOrFormula {
    FailureDefinitionId^ get ();
}
static member EnterValueOrFormula : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSiteFailures Class


BuiltInFailures.SiteFailures.GradingInSamePhase Property

BuiltInFailuresSiteFailuresGradingInSamePhase Property

The Surface being Graded was created in the current Phase. Grading it will result in it being created and destroyed in the same Phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId GradingInSamePhase { get; }
Public Shared ReadOnly Property GradingInSamePhase As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ GradingInSamePhase {
    FailureDefinitionId^ get ();
}
static member GradingInSamePhase : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSiteFailures Class


BuiltInFailures.SiteFailures.NoHostForSubregion Property

BuiltInFailuresSiteFailuresNoHostForSubregion Property

This Subregion now does not appear to overlap any Toposurface with an appropriate Phase and Design Option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoHostForSubregion { get; }
Public Shared ReadOnly Property NoHostForSubregion As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoHostForSubregion {
    FailureDefinitionId^ get ();
}
static member NoHostForSubregion : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSiteFailures Class


BuiltInFailures.SiteFailures.NoHostForSubregionWarn Property

BuiltInFailuresSiteFailuresNoHostForSubregionWarn Property

This Subregion now does not appear to overlap any Toposurface with an appropriate Phase and Design Option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoHostForSubregionWarn { get; }
Public Shared ReadOnly Property NoHostForSubregionWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoHostForSubregionWarn {
    FailureDefinitionId^ get ();
}
static member NoHostForSubregionWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSiteFailures Class


BuiltInFailures.SiteFailures.NotEnoughPointsInSurface Property

BuiltInFailuresSiteFailuresNotEnoughPointsInSurface Property

The surface must have at least three distinct Points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotEnoughPointsInSurface { get; }
Public Shared ReadOnly Property NotEnoughPointsInSurface As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotEnoughPointsInSurface {
    FailureDefinitionId^ get ();
}
static member NotEnoughPointsInSurface : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSiteFailures Class


BuiltInFailures.SiteFailures.PointNotInSurface Property

BuiltInFailuresSiteFailuresPointNotInSurface Property

A Point is outside of the Surface boundary. Insert the Point on the boundary instead, and then drag it to the desired location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PointNotInSurface { get; }
Public Shared ReadOnly Property PointNotInSurface As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PointNotInSurface {
    FailureDefinitionId^ get ();
}
static member PointNotInSurface : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSiteFailures Class


BuiltInFailures.SiteFailures.PointRelativeOutside Property

BuiltInFailuresSiteFailuresPointRelativeOutside Property

In order to place Points relative to the existing Surface, the Point must be placed within the area of the existing Surface. The height of the new Point will be relative to the current Surface elevation at that Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PointRelativeOutside { get; }
Public Shared ReadOnly Property PointRelativeOutside As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PointRelativeOutside {
    FailureDefinitionId^ get ();
}
static member PointRelativeOutside : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSiteFailures Class


BuiltInFailures.SiteFailures.PropertyIntersect Property

BuiltInFailuresSiteFailuresPropertyIntersect Property

Property lines intersect. Area calculations will not be precise.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PropertyIntersect { get; }
Public Shared ReadOnly Property PropertyIntersect As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PropertyIntersect {
    FailureDefinitionId^ get ();
}
static member PropertyIntersect : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSiteFailures Class


BuiltInFailures.SiteFailures.RegionPhaseMismatch Property

BuiltInFailuresSiteFailuresRegionPhaseMismatch Property

Subregions must have the same Phase Created parameter and Phase Demolished parameter as the host Toposurface. Subregion phase will be set to match the Toposurface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RegionPhaseMismatch { get; }
Public Shared ReadOnly Property RegionPhaseMismatch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RegionPhaseMismatch {
    FailureDefinitionId^ get ();
}
static member RegionPhaseMismatch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSiteFailures Class


BuiltInFailures.SiteFailures.ResetToposurfacePhaseCreated Property

BuiltInFailuresSiteFailuresResetToposurfacePhaseCreated Property

The parameter Phase Created of the Toposurface is not set to the first Phase. No pre-existing toposurface were detected. The parameter will be reset to the first Phase unless Keep Phase Created option is picked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ResetToposurfacePhaseCreated { get; }
Public Shared ReadOnly Property ResetToposurfacePhaseCreated As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ResetToposurfacePhaseCreated {
    FailureDefinitionId^ get ();
}
static member ResetToposurfacePhaseCreated : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSiteFailures Class


BuiltInFailures.SiteFailures.SiteEditPointsClipped Property

BuiltInFailuresSiteFailuresSiteEditPointsClipped Property

Portions of the topographic surface or points on the surface may not be visible in this view due to clipping by the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SiteEditPointsClipped { get; }
Public Shared ReadOnly Property SiteEditPointsClipped As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SiteEditPointsClipped {
    FailureDefinitionId^ get ();
}
static member SiteEditPointsClipped : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSiteFailures Class


BuiltInFailures.SiteFailures.SiteEditPointsInvisible Property

BuiltInFailuresSiteFailuresSiteEditPointsInvisible Property

Topographic elements are not visible in your current view. You can modify View Range settings in the view's Properties or Visibility settings in Visibility/Graphics. It is often easier to edit topography in a Site view or a 3D view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SiteEditPointsInvisible { get; }
Public Shared ReadOnly Property SiteEditPointsInvisible As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SiteEditPointsInvisible {
    FailureDefinitionId^ get ();
}
static member SiteEditPointsInvisible : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSiteFailures Class


BuiltInFailures.SiteFailures.SiteMergeDisconnected Property

BuiltInFailuresSiteFailuresSiteMergeDisconnected Property

The two surfaces you are trying to merge are disconnected from one another. They should overlap, or at least share edges.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SiteMergeDisconnected { get; }
Public Shared ReadOnly Property SiteMergeDisconnected As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SiteMergeDisconnected {
    FailureDefinitionId^ get ();
}
static member SiteMergeDisconnected : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSiteFailures Class


BuiltInFailures.SiteFailures.SitePhasesDontOverlap Property

BuiltInFailuresSiteFailuresSitePhasesDontOverlap Property

The phases of the two surfaces you are merging do not overlap. You can continue the operation, or cancel it and select a different pair of surfaces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SitePhasesDontOverlap { get; }
Public Shared ReadOnly Property SitePhasesDontOverlap As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SitePhasesDontOverlap {
    FailureDefinitionId^ get ();
}
static member SitePhasesDontOverlap : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSiteFailures Class


BuiltInFailures.SiteFailures.SiteRegionOptionConflict Property

BuiltInFailuresSiteFailuresSiteRegionOptionConflict Property

Subregions must be in the same Design Option as their Toposurface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SiteRegionOptionConflict { get; }
Public Shared ReadOnly Property SiteRegionOptionConflict As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SiteRegionOptionConflict {
    FailureDefinitionId^ get ();
}
static member SiteRegionOptionConflict : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSiteFailures Class


BuiltInFailures.SiteFailures.SurfaceSelfIntersection Property

BuiltInFailuresSiteFailuresSurfaceSelfIntersection Property

The splitting boundary drawn would result in a self-intersection of the surface boundary. Please edit your splitting lines to correct the problem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SurfaceSelfIntersection { get; }
Public Shared ReadOnly Property SurfaceSelfIntersection As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SurfaceSelfIntersection {
    FailureDefinitionId^ get ();
}
static member SurfaceSelfIntersection : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSiteFailures Class


BuiltInFailures.SiteFailures.SurfaceSplit Property

BuiltInFailuresSiteFailuresSurfaceSplit Property

The splitting boundary must split the Surface into exactly two pieces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SurfaceSplit { get; }
Public Shared ReadOnly Property SurfaceSplit As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SurfaceSplit {
    FailureDefinitionId^ get ();
}
static member SurfaceSplit : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSiteFailures Class


BuiltInFailures.SiteFailures.SurfaceSplitError Property

BuiltInFailuresSiteFailuresSurfaceSplitError Property

The splitting boundary must split the Surface into exactly two pieces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SurfaceSplitError { get; }
Public Shared ReadOnly Property SurfaceSplitError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SurfaceSplitError {
    FailureDefinitionId^ get ();
}
static member SurfaceSplitError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSiteFailures Class


BuiltInFailures.SiteFailures.SurfaceSplitNoIntersection Property

BuiltInFailuresSiteFailuresSurfaceSplitNoIntersection Property

The splitting boundary must divide the Surface into separate pieces. There may be a gap in the splitting Lines or the Sketch may be incomplete.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SurfaceSplitNoIntersection { get; }
Public Shared ReadOnly Property SurfaceSplitNoIntersection As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SurfaceSplitNoIntersection {
    FailureDefinitionId^ get ();
}
static member SurfaceSplitNoIntersection : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSiteFailures Class


BuiltInFailures.SiteFailures.SurfaceTriangulationFailed Property

BuiltInFailuresSiteFailuresSurfaceTriangulationFailed Property

The Site Surface failed to triangulate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SurfaceTriangulationFailed { get; }
Public Shared ReadOnly Property SurfaceTriangulationFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SurfaceTriangulationFailed {
    FailureDefinitionId^ get ();
}
static member SurfaceTriangulationFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSiteFailures Class


BuiltInFailures.SiteFailures.ToposolidSlopeExceedsThreshold Property

BuiltInFailuresSiteFailuresToposolidSlopeExceedsThreshold Property

Thickness of this Toposolid may be slightly inaccurate due to extreme Shape Editing. Dimensions to this element in sections and details may not accurately indicate the Thickness shown in Type Properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ToposolidSlopeExceedsThreshold { get; }
Public Shared ReadOnly Property ToposolidSlopeExceedsThreshold As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ToposolidSlopeExceedsThreshold {
    FailureDefinitionId^ get ();
}
static member ToposolidSlopeExceedsThreshold : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSiteFailures Class


BuiltInFailures.SiteImportFailures Class

BuiltInFailuresSiteImportFailures Class

Failures about SiteImport.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresSiteImportFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class SiteImportFailures
Public NotInheritable Class SiteImportFailures
public ref class SiteImportFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SiteImportFailures = class end

The BuiltInFailuresSiteImportFailures type exposes the following members.

Properties
Name | Description
BoundaryDetectError | A boundary on this surface could not be autodetected. Revit will impose one, but it may be larger than you want.
ContoursNoncontours | The layers you have selected contain both contour lines and non-contour lines (lines of non-constant elevation). You may want to go back and select fewer layers, or you can continue, but the boundary of the site may be larger than you want.
DifferentEntityTypes | Can't auto-detect boundary. The layers selected contain data that may make the Toposurface look incorrect. For better results, try selecting only those layers that contain relevant 3D info.
InvalidBoundaryError | Failed to get a valid boundary.
NoPoints | No points were found in the file.
NoViewSpecificSiteImports | Can't make Toposurface from View Specific Imports.
SurfaceExists | You are importing data into a surface that already contains points. You may want to go back, create a new surface, and import the data into that instead. You can continue, and Revit will sew the meshes together, but the boundary may be larger than you want.
TooFarAway | Imported Toposolid Points are located a large distance from the model and might not display properly. Points will be centered on the model instead.
TooFewPoints | The toposolid must have at least three distinct points
TooLarge | There are too many points on the selected layers of this dataset to place into the toposolid. Try selecting fewer layers to create the toposolid
TooManyMeshes | The layers you have selected contain more than one mesh. You may want to go back and import the meshes separately. If you continue, the meshes will be combined and a new boundary will be created.
UnusedPoints | Some rows from the file could not be used.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SiteImportFailures Properties

The BuiltInFailuresSiteImportFailures type exposes the following members.

Properties
Name | Description
BoundaryDetectError | A boundary on this surface could not be autodetected. Revit will impose one, but it may be larger than you want.
ContoursNoncontours | The layers you have selected contain both contour lines and non-contour lines (lines of non-constant elevation). You may want to go back and select fewer layers, or you can continue, but the boundary of the site may be larger than you want.
DifferentEntityTypes | Can't auto-detect boundary. The layers selected contain data that may make the Toposurface look incorrect. For better results, try selecting only those layers that contain relevant 3D info.
InvalidBoundaryError | Failed to get a valid boundary.
NoPoints | No points were found in the file.
NoViewSpecificSiteImports | Can't make Toposurface from View Specific Imports.
SurfaceExists | You are importing data into a surface that already contains points. You may want to go back, create a new surface, and import the data into that instead. You can continue, and Revit will sew the meshes together, but the boundary may be larger than you want.
TooFarAway | Imported Toposolid Points are located a large distance from the model and might not display properly. Points will be centered on the model instead.
TooFewPoints | The toposolid must have at least three distinct points
TooLarge | There are too many points on the selected layers of this dataset to place into the toposolid. Try selecting fewer layers to create the toposolid
TooManyMeshes | The layers you have selected contain more than one mesh. You may want to go back and import the meshes separately. If you continue, the meshes will be combined and a new boundary will be created.
UnusedPoints | Some rows from the file could not be used.
Top
See Also

Reference

BuiltInFailuresSiteImportFailures Class


BuiltInFailures.SiteImportFailures.BoundaryDetectError Property

BuiltInFailuresSiteImportFailuresBoundaryDetectError Property

A boundary on this surface could not be autodetected. Revit will impose one, but it may be larger than you want.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BoundaryDetectError { get; }
Public Shared ReadOnly Property BoundaryDetectError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BoundaryDetectError {
    FailureDefinitionId^ get ();
}
static member BoundaryDetectError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSiteImportFailures Class


BuiltInFailures.SiteImportFailures.ContoursNoncontours Property

BuiltInFailuresSiteImportFailuresContoursNoncontours Property

The layers you have selected contain both contour lines and non-contour lines (lines of non-constant elevation). You may want to go back and select fewer layers, or you can continue, but the boundary of the site may be larger than you want.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ContoursNoncontours { get; }
Public Shared ReadOnly Property ContoursNoncontours As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ContoursNoncontours {
    FailureDefinitionId^ get ();
}
static member ContoursNoncontours : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSiteImportFailures Class


BuiltInFailures.SiteImportFailures.DifferentEntityTypes Property

BuiltInFailuresSiteImportFailuresDifferentEntityTypes Property

Can't auto-detect boundary. The layers selected contain data that may make the Toposurface look incorrect. For better results, try selecting only those layers that contain relevant 3D info.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DifferentEntityTypes { get; }
Public Shared ReadOnly Property DifferentEntityTypes As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DifferentEntityTypes {
    FailureDefinitionId^ get ();
}
static member DifferentEntityTypes : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSiteImportFailures Class


BuiltInFailures.SiteImportFailures.InvalidBoundaryError Property

BuiltInFailuresSiteImportFailuresInvalidBoundaryError Property

Failed to get a valid boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidBoundaryError { get; }
Public Shared ReadOnly Property InvalidBoundaryError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidBoundaryError {
    FailureDefinitionId^ get ();
}
static member InvalidBoundaryError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSiteImportFailures Class


BuiltInFailures.SiteImportFailures.NoPoints Property

BuiltInFailuresSiteImportFailuresNoPoints Property

No points were found in the file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoPoints { get; }
Public Shared ReadOnly Property NoPoints As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoPoints {
    FailureDefinitionId^ get ();
}
static member NoPoints : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSiteImportFailures Class


BuiltInFailures.SiteImportFailures.NoViewSpecificSiteImports Property

BuiltInFailuresSiteImportFailuresNoViewSpecificSiteImports Property

Can't make Toposurface from View Specific Imports.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoViewSpecificSiteImports { get; }
Public Shared ReadOnly Property NoViewSpecificSiteImports As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoViewSpecificSiteImports {
    FailureDefinitionId^ get ();
}
static member NoViewSpecificSiteImports : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSiteImportFailures Class


BuiltInFailures.SiteImportFailures.SurfaceExists Property

BuiltInFailuresSiteImportFailuresSurfaceExists Property

You are importing data into a surface that already contains points. You may want to go back, create a new surface, and import the data into that instead. You can continue, and Revit will sew the meshes together, but the boundary may be larger than you want.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SurfaceExists { get; }
Public Shared ReadOnly Property SurfaceExists As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SurfaceExists {
    FailureDefinitionId^ get ();
}
static member SurfaceExists : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSiteImportFailures Class


BuiltInFailures.SiteImportFailures.TooFarAway Property

BuiltInFailuresSiteImportFailuresTooFarAway Property

Imported Toposolid Points are located a large distance from the model and might not display properly. Points will be centered on the model instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TooFarAway { get; }
Public Shared ReadOnly Property TooFarAway As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TooFarAway {
    FailureDefinitionId^ get ();
}
static member TooFarAway : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSiteImportFailures Class


BuiltInFailures.SiteImportFailures.TooFewPoints Property

BuiltInFailuresSiteImportFailuresTooFewPoints Property

The toposolid must have at least three distinct points

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TooFewPoints { get; }
Public Shared ReadOnly Property TooFewPoints As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TooFewPoints {
    FailureDefinitionId^ get ();
}
static member TooFewPoints : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSiteImportFailures Class


BuiltInFailures.SiteImportFailures.TooLarge Property

BuiltInFailuresSiteImportFailuresTooLarge Property

There are too many points on the selected layers of this dataset to place into the toposolid. Try selecting fewer layers to create the toposolid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TooLarge { get; }
Public Shared ReadOnly Property TooLarge As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TooLarge {
    FailureDefinitionId^ get ();
}
static member TooLarge : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSiteImportFailures Class


BuiltInFailures.SiteImportFailures.TooManyMeshes Property

BuiltInFailuresSiteImportFailuresTooManyMeshes Property

The layers you have selected contain more than one mesh. You may want to go back and import the meshes separately. If you continue, the meshes will be combined and a new boundary will be created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TooManyMeshes { get; }
Public Shared ReadOnly Property TooManyMeshes As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TooManyMeshes {
    FailureDefinitionId^ get ();
}
static member TooManyMeshes : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSiteImportFailures Class


BuiltInFailures.SiteImportFailures.UnusedPoints Property

BuiltInFailuresSiteImportFailuresUnusedPoints Property

Some rows from the file could not be used.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnusedPoints { get; }
Public Shared ReadOnly Property UnusedPoints As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnusedPoints {
    FailureDefinitionId^ get ();
}
static member UnusedPoints : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSiteImportFailures Class


BuiltInFailures.SketchFailures Class

BuiltInFailuresSketchFailures Class

Failures about Sketch.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresSketchFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class SketchFailures
Public NotInheritable Class SketchFailures
public ref class SketchFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SketchFailures = class end

The BuiltInFailuresSketchFailures type exposes the following members.

Properties
Name | Description
AreaLoadNoForce | Area Load can't have all force components equal to zero.
AxisNotSpecified | Axis of revolution not specified.
BadNosingProfile | Stairs nosing profile must have one loop. Wrong profile will not be shown in profiles list in Stairs Type properties.
BadRailingsProfile | Rail profile must have one closed loop. Wrong profile will not be shown in profiles list for rail definition.
BeamDirectionNotSpecified | Beam direction not specified.
BeamDirectionNotSpecifiedError | Beam direction not specified.
BentFabricSheetClosedLoopInSketch | The bend profile cannot contain a closed loop. Click Continue to correct the profile or Click Quit sketching to exit the bend profile editor.
BentFabricSheetEmptySketch | The bend profile requires at least one segment to be placed in a host. Click Continue to correct the profile or Click Quit sketching to exit the bend profile editor.
BentFabricSheetInvalidElementInSketch | Arcs in a bend profile must be separated from one another with a connected straight segment. The bend profile cannot start or end with an arc. Click Continue to correct the profile or Click Quit sketching to exit the bend profile editor.
BentFabricSheetLinesOverlapOrIntersect | Segments in a bend profile cannot overlap, intersect, or be collinearly contiguous. Click Continue to correct the profile or Click Quit sketching to exit the bend profile editor.
BentFabricSheetManyLoopsInSketch | The bend profile cannot contain two or more disconnected segments. Click Continue to correct the profile or Click Quit sketching to exit the bend profile editor.
BentFabricSheetTooShortSegments | A segment in the bend profile is too short to apply the wire bend diameter. The bent fabric sheet of the selected type cannot be placed in a host. Click Continue to correct the profile or Click Quit sketching to exit the bend profile editor.
BoundaryNoOverlap | The split sketch is out of the boundary of split element sketch..
BuildingPadNoSurface | A Pad can't extend beyond the edge of a Toposurface.
BuildingPadNoSurfaceError | A Pad can't extend beyond the edge of a Toposurface.
CannotChangeUserSketchPlane | Can't change plane of [Element Name] Sketch.
CannotChangeUserSketchPlaneError | Can't change plane of [Element Name] Sketch.
CannotChangeWorkplaneVisibility | Can't change Work Plane Visibility.
CannotComputeRailingsElevation | Can't compute Railings Elevation Profile.
CannotComputeRailingsElevationError | Can't compute Railings Elevation Profile.
CannotComputeRailingsElevationWarn | Can't compute Railings Elevation Profile
CannotConvertSketch | Can't convert Sketch to Rebar Shape.
CannotDrawExtrusionRoof | Can't make extruded roof.
CannotDrawProfileRoof | Can't make footprint roof.
CannotGetSketchReferences | Cannot find references to dimension sketch.
CannotHaveArcs | Sorry, we can't use arcs here.
CannotHaveArcsPath3d | Sorry, we can't use arcs here.
CircleMultiPlanarShapeInSketch | A circle can't be converted to multiplanar shape.
ClosedProfileRoof | Extrusion roof sketch must be open. The roof's thickness and material composition are defined in its type.
ConstantHeightNotParallel | Constant-height-defining lines must be parallel.
ConstantHeightNotParallelError | Constant-height-defining lines must be parallel.
ContainedInOtherLoops | When creating an opening, you cannot sketch loops within other loops. The highlighted loop(s) are contained within another loop.
ConvertSplineToLineFailed | Failed to convert spline to straight line
CurveFromPickedFailed | Can't create boundary from pick.
CurveIntersectsCutFace | The highlighted line intersects the boundary of the face being modified. To modify a cut face, use open loops that end on the existing boundary without intersecting or overlapping existing edges.
CurveIntersectsSplitFace | The highlighted line intersects the boundary of the face being split. To split a face at its border, use an open loop that ends on the boundary of the face.
CurveTooShort | Line is too short.
DifferentOffsets | Adjacent slope-defining lines must have identical eave heights; the highlighted lines do not. You can use the Align Eaves tool to have the eaves aligned for you.
ElementsSketchTooLarge | The sketch defining the highlighted element is too large.
ElevationSketchNotAllowed | Wall in a family can't have an elevation profile.
EndsNotOnCutFace | Ends of the sketched loop do not lie on the boundary of the face being modified.
EndsNotOnEdge | Ends of an open loop in sketch splitting face do not lie on an edge of the face to split.
FloorCannotAddDirectionCurve | Cannot add the direction curve in the floor sketch.
FloorCannotAddDirectionCurveError | Cannot add the direction curve in the floor sketch.
FloorDirectionNotSpecified | Structural floor span direction not specified.
FloorManyDirectionCurves | More than one span direction curve specified.
InvalidAreaLoadSketch | Area Load has invalid Sketch.
InvalidCropAreaSketch | Crop area sketch can either be empty or include one closed, not self-intersecting loop.
InvalidCropAreaSketchRegen | Crop area sketch can either be empty or include one closed, not self-intersecting loop.
InvalidElevationSketch | Elevation Profile sketch is invalid.
InvalidElevationSketchError | Elevation Profile sketch is invalid.
InvalidProfile | One or more profiles are invalid. Make sure that every used profile is a closed loop of non-intersecting lines.
InvalidProfileError | One or more profiles are invalid. Make sure that every used profile is a closed loop of non-intersecting lines.
InvalidRoofCurveloop | Base sketch for roof is invalid.
InvalidRoofCurveloopError | Base sketch for roof is invalid
InvalidRoofCurveloopFailure | Base sketch for roof is invalid
InvalidSketch | Sketch is invalid.
InvalidSketchError | Sketch is invalid.
InvalidSketchForBuildingpad | Pad sketch is invalid.
InvalidSketchForCeiling | Ceiling sketch is invalid.
InvalidSketchForFloor | Floor sketch is invalid.
InvalidSketchForRoofsoffit | Roof Soffit sketch is invalid.
InvalidSketchForToposolid | Toposolid sketch is invalid.
InvalidSketchPath3d | Sketch is invalid.
LandingNotEnoughBoundaryCurves | Sketch landing require boundaries
LandingTwoManyLoops | Sketch landing can only have one closed loop
LinesOverlap | Cannot have overlapping lines.
LinesOverlapError | Cannot have overlapping lines.
LinesOverlapPath3d | Cannot have overlapping lines.
LoopIntersect | Lines cannot intersect each other. The highlighted lines currently intersect.
LoopIntersectError | Lines cannot intersect each other. The highlighted lines currently intersect.
LoopIntersectPath3d | Lines cannot intersect each other. The highlighted lines currently intersect.
LoopsOutsideFaceSplit | Some of the lines drawn lie outside of the boundary of the face being split. All lines used to split a face must be contained within the face being split and cannot intersect or overlap any of the boundaries of that face.
LoopsOutsideFaceSplitterTooShort | Some of the lines drawn lie outside of the boundary of the face being split. All lines used to split a face must be contained within the face being split and cannot intersect or overlap any of the boundaries of that face.
ManyCCWLoops | Area defined by sketch must be connected.
ManyCCWLoopsError | Area defined by sketch must be connected.
ManyDirectionCurves | More than one direction curve specified.
ManyDirectionCurvesError | More than one direction curve specified.
MissingLapInSketch | Rebar Sketch does not have lapped lengths. A circular shaped Rebar needs overlapping legths. Please overlap one of the ends of the circular Rebar Sketch.
MoreThanOneAxis | More than one axes of revolution.
MutipleStairsPathInOneRunFailure | Each stairs run can only have one stairs path.
NestedLoops | Cannot have nested loops.
NoLoops | Sketch is empty.
NoLoopsError | Sketch is empty.
NoLoopsPath3d | Sketch is empty.
NonMonotoneRoof | All parts of an extruded roof must face upward. Make sure that no part of the sketch lies below any other part of the sketch.
NoPlane | Highlighted geometry no longer determines a plane
NotOneCCWLoop | This sketch defines more than one footprint. Make sure the sketch contains only one outermost loop and that there are no loops inside inner loops.
NotOneCurve | More than one curve not allowed.
NotOneCurveError | More than one curve not allowed.
NotOneCurvePath3d | More than one curve not allowed.
NotOneLoop | More than one loop not allowed.
NotOneLoopPath3d | More than one loop not allowed.
OpenAreaLoadLoop | Area Load Sketch can't contain open loops.
OpenLoop | Lines must be in closed loops. The highlighted lines are open on one end.
OpenLoopError | Lines must be in closed loops. The highlighted lines are open on one end.
OpenLoopPath3d | Lines must be in closed loops. The highlighted lines are open on one end.
PathCannotBeClosedLoop | Path cannot be a closed loop.
PathCannotBeClosedLoopPath3d | Path cannot be a closed loop.
PathReinforcementClosedLoop | Sketch contains a closed loop. Can't create Path Reinforcement.
PathReinforcementEmptySketch | Sketch is empty. Can't create Path Reinforcement.
PathReinforcementManyLoops | Sketch contains more than one chain. Can't create Path Reinforcement.
PlanarMultiPlanarShapeInSketch | The current shape is only bent in a single plane. A multi-planar definition is not required. Please redefine the shape on the top plane only.
RailingDoublyConnected | Railings hosted on Stairs must form a single, open, connected line.
RailingDoublyConnectedError | Railings hosted on Stairs must form a single, open, connected line.
RailingNotConnected | The Railing line must be a single connected Sketch. If you want separate pieces of Railing, create two or more separate Railings.
RailingNotConnectedError | The Railing line must be a single connected Sketch. If you want separate pieces of Railing, create two or more separate Railings.
RebarEmptySketch | Rebar Sketch is empty. Can't create Rebar.
RebarEmptySketchError | Rebar Sketch is empty. Can't create Rebar.
RebarManyLoops | Rebar Sketch contains more than one loop. Can't create Rebar.
RebarManyLoopsError | Rebar Sketch contains more than one loop. Can't create Rebar.
RebarSystemDirectionNotSpecified | Major direction not specified.
RebarSystemDirectionNotSpecifiedError | Major direction not specified.
RunInvalidSketch | Invalid sketch, can't create run by this sketch
RunNotEnoughBoundaryCurves | Sketch run require boundaries (chains of one or more Boundary Lines)
SculptingCurvesCannotFormClosedLoop | Curves cannot form a closed loop.
SculptingCurvesCrossAxis | The highlighted curves cross the axis.
SculptingCurvesTouchAxis | The highlighted curves touch the axis.
SculptingLoopsOnBothSidesOfAxis | All curves must be on the same side of the axis.
SculptingSingleLineLoopLiesOnAxis | The highlighted lines lie on the axis.
ShortCurveInSketch | The sketch contains an extremely short line.
ShortCurveInSketchRoof | The sketch contains an extremely short line.
SiteCannotDrawSurfaceBoundary | Cannot make surface with specified boundary.
SketchedRunInvalidPath | Invalid stair path. Stair path should connect both start and end riser, and cross all other risers.
SketchedShapeNotAvailable | Skeched shape is not available for this type of element.
SketchFailurePlanes | Sketch is no longer parallel to its defining plane
SketchingInTheWrongView | Detail sketch is only editable in [View Type].
SketchingInWrongView | Detail sketch is not editable in this view.
SketchOverconstrained | Sketch is overconstrained.
SketchOverconstrainedError | Sketch is overconstrained.
SketchOverconstrainedWarn | Sketch is overconstrained.
SketchTooLarge | Sketch is too large.
SketchWasDeleted | Sketch was deleted.
StairClosedBoundaries | Stairs Boundaries (chains of one or more Boundary Lines) should not form closed loops.
StairClosedBoundariesError | Stairs Boundaries (chains of one or more Boundary Lines) should not form closed loops.
StairNotEnoughBoundaryCurves | Stairs require boundaries (chains of one or more Boundary Lines) on each side of the Stair.
StairNotEnoughBoundaryCurvesError | Stairs require boundaries (chains of one or more Boundary Lines) on each side of the Stair.
StairNotEnoughRiserCurves | Boundaries (chains of one or more Boundary Lines) must be connected by at least two Riser Lines.
StairNotEnoughRiserCurvesError | Boundaries (chains of one or more Boundary Lines) must be connected by at least two Riser Lines.
StairOnlyOneConnectedBoundary | Stairs require no less than two boundaries (chains of one or more Boundary Lines)."
StairOnlyOneConnectedBoundaryError | Stairs require no less than two boundaries (chains of one or more Boundary Lines).
StairRiserDoesntIntersectBoundary | The line representing the top of a riser does not intersect one or both of the boundary lines.
StairRiserDoesntIntersectBoundaryError | The line representing the top of a riser does not intersect one or both of the boundary lines.
StairTooManyConnectedBoundaries | Stairs require no more than two boundaries (chains of one or more Boundary Lines).
StairTooManyConnectedBoundariesError | Stairs require no more than two boundaries (chains of one or more Boundary Lines).
SubregionNoHostSurf | A Subregion cannot be created outside the boundary of a Toposurface. A Subregion should be completely inside a Toposurface or overlap a Toposurface.
SuggestMakingFamilyNonParametric | Performance Warning: This family now contains both labeled dimensions and sketches with many segments. This may hurt performance. To improve performance, create elements that require complex sketches as nested families.
SuspendedSketchWarn | Highlighted element's sketch could not regenerate and has been suspended. Select the element and edit its sketch to fix the problem. The element will display in magenta until you fix the problem
TooFewParamsForSketch | The sketched Structural Rebar element has too many segments to be properly parameterized. Please reduce the number of segments.
TooManyElementsInSketch | This sketch is large. Performance will improve if constructed as several independent sketches.
TooManySlopes | There is more than one slope defined.
TooManySlopesError | There is more than one slope defined.
TrussClosedReference | Truss references (chains of one or more reference lines) should not form closed loops."
TrussCrossingReferences | Truss top and bottom references cannot cross.
TrussMissingReference | Trusses require both a top and a bottom chord reference (chain of one or more reference lines).
TrussOverlappingReference | Truss references (chains of one or more reference lines) cannot overlap themselves in the vertical direction.
TrussSegmentedReference | Truss reference must form a continuous chain of one or more sketch lines.
TrussShiftedReferences | Truss top and bottom references (chains of one or more reference lines) must overlap at least partially in the vertical direction.
TrussSwappedReferences | Truss top reference must be above the bottom reference.
UnsatisfiedSupportAssocProp | Constraint between a Line created with Pick Support and the Support is not satisfied.
UnsatisfiedWallAssocProp | Constraint between a Line created with Pick Wall and the Wall is not satisfied.
VarSketchFailure | Constraints defined by highlighted Lines and Dimensions can't be satisfied.
VarSketchInElementFailure | The constraints of the sketch defining the highlighted element cannot be satisfied.
WrongCutBoundaryLoops | Only open loops can be used for Edit Cut Profile. All open ends must lie on the boundary of the cut profile, and the loop may not touch the boundary anywhere except at its ends.
WrongFaceSplitterLoopTypesNum | Sketch for splitting the face is invalid. Faces may be split either by a single closed loop that is contained within the face or by one or more open loops whose ends lie on the boundary of the face. None of the lines in the sketch are allowed to overlap or intersect the boundaries of the face.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SketchFailures Properties

The BuiltInFailuresSketchFailures type exposes the following members.

Properties
Name | Description
AreaLoadNoForce | Area Load can't have all force components equal to zero.
AxisNotSpecified | Axis of revolution not specified.
BadNosingProfile | Stairs nosing profile must have one loop. Wrong profile will not be shown in profiles list in Stairs Type properties.
BadRailingsProfile | Rail profile must have one closed loop. Wrong profile will not be shown in profiles list for rail definition.
BeamDirectionNotSpecified | Beam direction not specified.
BeamDirectionNotSpecifiedError | Beam direction not specified.
BentFabricSheetClosedLoopInSketch | The bend profile cannot contain a closed loop. Click Continue to correct the profile or Click Quit sketching to exit the bend profile editor.
BentFabricSheetEmptySketch | The bend profile requires at least one segment to be placed in a host. Click Continue to correct the profile or Click Quit sketching to exit the bend profile editor.
BentFabricSheetInvalidElementInSketch | Arcs in a bend profile must be separated from one another with a connected straight segment. The bend profile cannot start or end with an arc. Click Continue to correct the profile or Click Quit sketching to exit the bend profile editor.
BentFabricSheetLinesOverlapOrIntersect | Segments in a bend profile cannot overlap, intersect, or be collinearly contiguous. Click Continue to correct the profile or Click Quit sketching to exit the bend profile editor.
BentFabricSheetManyLoopsInSketch | The bend profile cannot contain two or more disconnected segments. Click Continue to correct the profile or Click Quit sketching to exit the bend profile editor.
BentFabricSheetTooShortSegments | A segment in the bend profile is too short to apply the wire bend diameter. The bent fabric sheet of the selected type cannot be placed in a host. Click Continue to correct the profile or Click Quit sketching to exit the bend profile editor.
BoundaryNoOverlap | The split sketch is out of the boundary of split element sketch..
BuildingPadNoSurface | A Pad can't extend beyond the edge of a Toposurface.
BuildingPadNoSurfaceError | A Pad can't extend beyond the edge of a Toposurface.
CannotChangeUserSketchPlane | Can't change plane of [Element Name] Sketch.
CannotChangeUserSketchPlaneError | Can't change plane of [Element Name] Sketch.
CannotChangeWorkplaneVisibility | Can't change Work Plane Visibility.
CannotComputeRailingsElevation | Can't compute Railings Elevation Profile.
CannotComputeRailingsElevationError | Can't compute Railings Elevation Profile.
CannotComputeRailingsElevationWarn | Can't compute Railings Elevation Profile
CannotConvertSketch | Can't convert Sketch to Rebar Shape.
CannotDrawExtrusionRoof | Can't make extruded roof.
CannotDrawProfileRoof | Can't make footprint roof.
CannotGetSketchReferences | Cannot find references to dimension sketch.
CannotHaveArcs | Sorry, we can't use arcs here.
CannotHaveArcsPath3d | Sorry, we can't use arcs here.
CircleMultiPlanarShapeInSketch | A circle can't be converted to multiplanar shape.
ClosedProfileRoof | Extrusion roof sketch must be open. The roof's thickness and material composition are defined in its type.
ConstantHeightNotParallel | Constant-height-defining lines must be parallel.
ConstantHeightNotParallelError | Constant-height-defining lines must be parallel.
ContainedInOtherLoops | When creating an opening, you cannot sketch loops within other loops. The highlighted loop(s) are contained within another loop.
ConvertSplineToLineFailed | Failed to convert spline to straight line
CurveFromPickedFailed | Can't create boundary from pick.
CurveIntersectsCutFace | The highlighted line intersects the boundary of the face being modified. To modify a cut face, use open loops that end on the existing boundary without intersecting or overlapping existing edges.
CurveIntersectsSplitFace | The highlighted line intersects the boundary of the face being split. To split a face at its border, use an open loop that ends on the boundary of the face.
CurveTooShort | Line is too short.
DifferentOffsets | Adjacent slope-defining lines must have identical eave heights; the highlighted lines do not. You can use the Align Eaves tool to have the eaves aligned for you.
ElementsSketchTooLarge | The sketch defining the highlighted element is too large.
ElevationSketchNotAllowed | Wall in a family can't have an elevation profile.
EndsNotOnCutFace | Ends of the sketched loop do not lie on the boundary of the face being modified.
EndsNotOnEdge | Ends of an open loop in sketch splitting face do not lie on an edge of the face to split.
FloorCannotAddDirectionCurve | Cannot add the direction curve in the floor sketch.
FloorCannotAddDirectionCurveError | Cannot add the direction curve in the floor sketch.
FloorDirectionNotSpecified | Structural floor span direction not specified.
FloorManyDirectionCurves | More than one span direction curve specified.
InvalidAreaLoadSketch | Area Load has invalid Sketch.
InvalidCropAreaSketch | Crop area sketch can either be empty or include one closed, not self-intersecting loop.
InvalidCropAreaSketchRegen | Crop area sketch can either be empty or include one closed, not self-intersecting loop.
InvalidElevationSketch | Elevation Profile sketch is invalid.
InvalidElevationSketchError | Elevation Profile sketch is invalid.
InvalidProfile | One or more profiles are invalid. Make sure that every used profile is a closed loop of non-intersecting lines.
InvalidProfileError | One or more profiles are invalid. Make sure that every used profile is a closed loop of non-intersecting lines.
InvalidRoofCurveloop | Base sketch for roof is invalid.
InvalidRoofCurveloopError | Base sketch for roof is invalid
InvalidRoofCurveloopFailure | Base sketch for roof is invalid
InvalidSketch | Sketch is invalid.
InvalidSketchError | Sketch is invalid.
InvalidSketchForBuildingpad | Pad sketch is invalid.
InvalidSketchForCeiling | Ceiling sketch is invalid.
InvalidSketchForFloor | Floor sketch is invalid.
InvalidSketchForRoofsoffit | Roof Soffit sketch is invalid.
InvalidSketchForToposolid | Toposolid sketch is invalid.
InvalidSketchPath3d | Sketch is invalid.
LandingNotEnoughBoundaryCurves | Sketch landing require boundaries
LandingTwoManyLoops | Sketch landing can only have one closed loop
LinesOverlap | Cannot have overlapping lines.
LinesOverlapError | Cannot have overlapping lines.
LinesOverlapPath3d | Cannot have overlapping lines.
LoopIntersect | Lines cannot intersect each other. The highlighted lines currently intersect.
LoopIntersectError | Lines cannot intersect each other. The highlighted lines currently intersect.
LoopIntersectPath3d | Lines cannot intersect each other. The highlighted lines currently intersect.
LoopsOutsideFaceSplit | Some of the lines drawn lie outside of the boundary of the face being split. All lines used to split a face must be contained within the face being split and cannot intersect or overlap any of the boundaries of that face.
LoopsOutsideFaceSplitterTooShort | Some of the lines drawn lie outside of the boundary of the face being split. All lines used to split a face must be contained within the face being split and cannot intersect or overlap any of the boundaries of that face.
ManyCCWLoops | Area defined by sketch must be connected.
ManyCCWLoopsError | Area defined by sketch must be connected.
ManyDirectionCurves | More than one direction curve specified.
ManyDirectionCurvesError | More than one direction curve specified.
MissingLapInSketch | Rebar Sketch does not have lapped lengths. A circular shaped Rebar needs overlapping legths. Please overlap one of the ends of the circular Rebar Sketch.
MoreThanOneAxis | More than one axes of revolution.
MutipleStairsPathInOneRunFailure | Each stairs run can only have one stairs path.
NestedLoops | Cannot have nested loops.
NoLoops | Sketch is empty.
NoLoopsError | Sketch is empty.
NoLoopsPath3d | Sketch is empty.
NonMonotoneRoof | All parts of an extruded roof must face upward. Make sure that no part of the sketch lies below any other part of the sketch.
NoPlane | Highlighted geometry no longer determines a plane
NotOneCCWLoop | This sketch defines more than one footprint. Make sure the sketch contains only one outermost loop and that there are no loops inside inner loops.
NotOneCurve | More than one curve not allowed.
NotOneCurveError | More than one curve not allowed.
NotOneCurvePath3d | More than one curve not allowed.
NotOneLoop | More than one loop not allowed.
NotOneLoopPath3d | More than one loop not allowed.
OpenAreaLoadLoop | Area Load Sketch can't contain open loops.
OpenLoop | Lines must be in closed loops. The highlighted lines are open on one end.
OpenLoopError | Lines must be in closed loops. The highlighted lines are open on one end.
OpenLoopPath3d | Lines must be in closed loops. The highlighted lines are open on one end.
PathCannotBeClosedLoop | Path cannot be a closed loop.
PathCannotBeClosedLoopPath3d | Path cannot be a closed loop.
PathReinforcementClosedLoop | Sketch contains a closed loop. Can't create Path Reinforcement.
PathReinforcementEmptySketch | Sketch is empty. Can't create Path Reinforcement.
PathReinforcementManyLoops | Sketch contains more than one chain. Can't create Path Reinforcement.
PlanarMultiPlanarShapeInSketch | The current shape is only bent in a single plane. A multi-planar definition is not required. Please redefine the shape on the top plane only.
RailingDoublyConnected | Railings hosted on Stairs must form a single, open, connected line.
RailingDoublyConnectedError | Railings hosted on Stairs must form a single, open, connected line.
RailingNotConnected | The Railing line must be a single connected Sketch. If you want separate pieces of Railing, create two or more separate Railings.
RailingNotConnectedError | The Railing line must be a single connected Sketch. If you want separate pieces of Railing, create two or more separate Railings.
RebarEmptySketch | Rebar Sketch is empty. Can't create Rebar.
RebarEmptySketchError | Rebar Sketch is empty. Can't create Rebar.
RebarManyLoops | Rebar Sketch contains more than one loop. Can't create Rebar.
RebarManyLoopsError | Rebar Sketch contains more than one loop. Can't create Rebar.
RebarSystemDirectionNotSpecified | Major direction not specified.
RebarSystemDirectionNotSpecifiedError | Major direction not specified.
RunInvalidSketch | Invalid sketch, can't create run by this sketch
RunNotEnoughBoundaryCurves | Sketch run require boundaries (chains of one or more Boundary Lines)
SculptingCurvesCannotFormClosedLoop | Curves cannot form a closed loop.
SculptingCurvesCrossAxis | The highlighted curves cross the axis.
SculptingCurvesTouchAxis | The highlighted curves touch the axis.
SculptingLoopsOnBothSidesOfAxis | All curves must be on the same side of the axis.
SculptingSingleLineLoopLiesOnAxis | The highlighted lines lie on the axis.
ShortCurveInSketch | The sketch contains an extremely short line.
ShortCurveInSketchRoof | The sketch contains an extremely short line.
SiteCannotDrawSurfaceBoundary | Cannot make surface with specified boundary.
SketchedRunInvalidPath | Invalid stair path. Stair path should connect both start and end riser, and cross all other risers.
SketchedShapeNotAvailable | Skeched shape is not available for this type of element.
SketchFailurePlanes | Sketch is no longer parallel to its defining plane
SketchingInTheWrongView | Detail sketch is only editable in [View Type].
SketchingInWrongView | Detail sketch is not editable in this view.
SketchOverconstrained | Sketch is overconstrained.
SketchOverconstrainedError | Sketch is overconstrained.
SketchOverconstrainedWarn | Sketch is overconstrained.
SketchTooLarge | Sketch is too large.
SketchWasDeleted | Sketch was deleted.
StairClosedBoundaries | Stairs Boundaries (chains of one or more Boundary Lines) should not form closed loops.
StairClosedBoundariesError | Stairs Boundaries (chains of one or more Boundary Lines) should not form closed loops.
StairNotEnoughBoundaryCurves | Stairs require boundaries (chains of one or more Boundary Lines) on each side of the Stair.
StairNotEnoughBoundaryCurvesError | Stairs require boundaries (chains of one or more Boundary Lines) on each side of the Stair.
StairNotEnoughRiserCurves | Boundaries (chains of one or more Boundary Lines) must be connected by at least two Riser Lines.
StairNotEnoughRiserCurvesError | Boundaries (chains of one or more Boundary Lines) must be connected by at least two Riser Lines.
StairOnlyOneConnectedBoundary | Stairs require no less than two boundaries (chains of one or more Boundary Lines)."
StairOnlyOneConnectedBoundaryError | Stairs require no less than two boundaries (chains of one or more Boundary Lines).
StairRiserDoesntIntersectBoundary | The line representing the top of a riser does not intersect one or both of the boundary lines.
StairRiserDoesntIntersectBoundaryError | The line representing the top of a riser does not intersect one or both of the boundary lines.
StairTooManyConnectedBoundaries | Stairs require no more than two boundaries (chains of one or more Boundary Lines).
StairTooManyConnectedBoundariesError | Stairs require no more than two boundaries (chains of one or more Boundary Lines).
SubregionNoHostSurf | A Subregion cannot be created outside the boundary of a Toposurface. A Subregion should be completely inside a Toposurface or overlap a Toposurface.
SuggestMakingFamilyNonParametric | Performance Warning: This family now contains both labeled dimensions and sketches with many segments. This may hurt performance. To improve performance, create elements that require complex sketches as nested families.
SuspendedSketchWarn | Highlighted element's sketch could not regenerate and has been suspended. Select the element and edit its sketch to fix the problem. The element will display in magenta until you fix the problem
TooFewParamsForSketch | The sketched Structural Rebar element has too many segments to be properly parameterized. Please reduce the number of segments.
TooManyElementsInSketch | This sketch is large. Performance will improve if constructed as several independent sketches.
TooManySlopes | There is more than one slope defined.
TooManySlopesError | There is more than one slope defined.
TrussClosedReference | Truss references (chains of one or more reference lines) should not form closed loops."
TrussCrossingReferences | Truss top and bottom references cannot cross.
TrussMissingReference | Trusses require both a top and a bottom chord reference (chain of one or more reference lines).
TrussOverlappingReference | Truss references (chains of one or more reference lines) cannot overlap themselves in the vertical direction.
TrussSegmentedReference | Truss reference must form a continuous chain of one or more sketch lines.
TrussShiftedReferences | Truss top and bottom references (chains of one or more reference lines) must overlap at least partially in the vertical direction.
TrussSwappedReferences | Truss top reference must be above the bottom reference.
UnsatisfiedSupportAssocProp | Constraint between a Line created with Pick Support and the Support is not satisfied.
UnsatisfiedWallAssocProp | Constraint between a Line created with Pick Wall and the Wall is not satisfied.
VarSketchFailure | Constraints defined by highlighted Lines and Dimensions can't be satisfied.
VarSketchInElementFailure | The constraints of the sketch defining the highlighted element cannot be satisfied.
WrongCutBoundaryLoops | Only open loops can be used for Edit Cut Profile. All open ends must lie on the boundary of the cut profile, and the loop may not touch the boundary anywhere except at its ends.
WrongFaceSplitterLoopTypesNum | Sketch for splitting the face is invalid. Faces may be split either by a single closed loop that is contained within the face or by one or more open loops whose ends lie on the boundary of the face. None of the lines in the sketch are allowed to overlap or intersect the boundaries of the face.
Top
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.AreaLoadNoForce Property

BuiltInFailuresSketchFailuresAreaLoadNoForce Property

Area Load can't have all force components equal to zero.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AreaLoadNoForce { get; }
Public Shared ReadOnly Property AreaLoadNoForce As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AreaLoadNoForce {
    FailureDefinitionId^ get ();
}
static member AreaLoadNoForce : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.AxisNotSpecified Property

BuiltInFailuresSketchFailuresAxisNotSpecified Property

Axis of revolution not specified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AxisNotSpecified { get; }
Public Shared ReadOnly Property AxisNotSpecified As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AxisNotSpecified {
    FailureDefinitionId^ get ();
}
static member AxisNotSpecified : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.BadNosingProfile Property

BuiltInFailuresSketchFailuresBadNosingProfile Property

Stairs nosing profile must have one loop. Wrong profile will not be shown in profiles list in Stairs Type properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BadNosingProfile { get; }
Public Shared ReadOnly Property BadNosingProfile As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BadNosingProfile {
    FailureDefinitionId^ get ();
}
static member BadNosingProfile : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.BadRailingsProfile Property

BuiltInFailuresSketchFailuresBadRailingsProfile Property

Rail profile must have one closed loop. Wrong profile will not be shown in profiles list for rail definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BadRailingsProfile { get; }
Public Shared ReadOnly Property BadRailingsProfile As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BadRailingsProfile {
    FailureDefinitionId^ get ();
}
static member BadRailingsProfile : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.BeamDirectionNotSpecified Property

BuiltInFailuresSketchFailuresBeamDirectionNotSpecified Property

Beam direction not specified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BeamDirectionNotSpecified { get; }
Public Shared ReadOnly Property BeamDirectionNotSpecified As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BeamDirectionNotSpecified {
    FailureDefinitionId^ get ();
}
static member BeamDirectionNotSpecified : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.BeamDirectionNotSpecifiedError Property

BuiltInFailuresSketchFailuresBeamDirectionNotSpecifiedError Property

Beam direction not specified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BeamDirectionNotSpecifiedError { get; }
Public Shared ReadOnly Property BeamDirectionNotSpecifiedError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BeamDirectionNotSpecifiedError {
    FailureDefinitionId^ get ();
}
static member BeamDirectionNotSpecifiedError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.BentFabricSheetClosedLoopInSketch Property

BuiltInFailuresSketchFailuresBentFabricSheetClosedLoopInSketch Property

The bend profile cannot contain a closed loop. Click Continue to correct the profile or Click Quit sketching to exit the bend profile editor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BentFabricSheetClosedLoopInSketch { get; }
Public Shared ReadOnly Property BentFabricSheetClosedLoopInSketch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BentFabricSheetClosedLoopInSketch {
    FailureDefinitionId^ get ();
}
static member BentFabricSheetClosedLoopInSketch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.BentFabricSheetEmptySketch Property

BuiltInFailuresSketchFailuresBentFabricSheetEmptySketch Property

The bend profile requires at least one segment to be placed in a host. Click Continue to correct the profile or Click Quit sketching to exit the bend profile editor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BentFabricSheetEmptySketch { get; }
Public Shared ReadOnly Property BentFabricSheetEmptySketch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BentFabricSheetEmptySketch {
    FailureDefinitionId^ get ();
}
static member BentFabricSheetEmptySketch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.BentFabricSheetInvalidElementInSketch Property

BuiltInFailuresSketchFailuresBentFabricSheetInvalidElementInSketch Property

Arcs in a bend profile must be separated from one another with a connected straight segment. The bend profile cannot start or end with an arc. Click Continue to correct the profile or Click Quit sketching to exit the bend profile editor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BentFabricSheetInvalidElementInSketch { get; }
Public Shared ReadOnly Property BentFabricSheetInvalidElementInSketch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BentFabricSheetInvalidElementInSketch {
    FailureDefinitionId^ get ();
}
static member BentFabricSheetInvalidElementInSketch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.BentFabricSheetLinesOverlapOrIntersect Property

BuiltInFailuresSketchFailuresBentFabricSheetLinesOverlapOrIntersect Property

Segments in a bend profile cannot overlap, intersect, or be collinearly contiguous. Click Continue to correct the profile or Click Quit sketching to exit the bend profile editor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BentFabricSheetLinesOverlapOrIntersect { get; }
Public Shared ReadOnly Property BentFabricSheetLinesOverlapOrIntersect As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BentFabricSheetLinesOverlapOrIntersect {
    FailureDefinitionId^ get ();
}
static member BentFabricSheetLinesOverlapOrIntersect : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.BentFabricSheetManyLoopsInSketch Property

BuiltInFailuresSketchFailuresBentFabricSheetManyLoopsInSketch Property

The bend profile cannot contain two or more disconnected segments. Click Continue to correct the profile or Click Quit sketching to exit the bend profile editor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BentFabricSheetManyLoopsInSketch { get; }
Public Shared ReadOnly Property BentFabricSheetManyLoopsInSketch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BentFabricSheetManyLoopsInSketch {
    FailureDefinitionId^ get ();
}
static member BentFabricSheetManyLoopsInSketch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.BentFabricSheetTooShortSegments Property

BuiltInFailuresSketchFailuresBentFabricSheetTooShortSegments Property

A segment in the bend profile is too short to apply the wire bend diameter. The bent fabric sheet of the selected type cannot be placed in a host. Click Continue to correct the profile or Click Quit sketching to exit the bend profile editor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BentFabricSheetTooShortSegments { get; }
Public Shared ReadOnly Property BentFabricSheetTooShortSegments As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BentFabricSheetTooShortSegments {
    FailureDefinitionId^ get ();
}
static member BentFabricSheetTooShortSegments : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.BoundaryNoOverlap Property

BuiltInFailuresSketchFailuresBoundaryNoOverlap Property

The split sketch is out of the boundary of split element sketch..

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BoundaryNoOverlap { get; }
Public Shared ReadOnly Property BoundaryNoOverlap As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BoundaryNoOverlap {
    FailureDefinitionId^ get ();
}
static member BoundaryNoOverlap : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.BuildingPadNoSurface Property

BuiltInFailuresSketchFailuresBuildingPadNoSurface Property

A Pad can't extend beyond the edge of a Toposurface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BuildingPadNoSurface { get; }
Public Shared ReadOnly Property BuildingPadNoSurface As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BuildingPadNoSurface {
    FailureDefinitionId^ get ();
}
static member BuildingPadNoSurface : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.BuildingPadNoSurfaceError Property

BuiltInFailuresSketchFailuresBuildingPadNoSurfaceError Property

A Pad can't extend beyond the edge of a Toposurface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BuildingPadNoSurfaceError { get; }
Public Shared ReadOnly Property BuildingPadNoSurfaceError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BuildingPadNoSurfaceError {
    FailureDefinitionId^ get ();
}
static member BuildingPadNoSurfaceError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.CannotChangeUserSketchPlane Property

BuiltInFailuresSketchFailuresCannotChangeUserSketchPlane Property

Can't change plane of [Element Name] Sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotChangeUserSketchPlane { get; }
Public Shared ReadOnly Property CannotChangeUserSketchPlane As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotChangeUserSketchPlane {
    FailureDefinitionId^ get ();
}
static member CannotChangeUserSketchPlane : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.CannotChangeUserSketchPlaneError Property

BuiltInFailuresSketchFailuresCannotChangeUserSketchPlaneError Property

Can't change plane of [Element Name] Sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotChangeUserSketchPlaneError { get; }
Public Shared ReadOnly Property CannotChangeUserSketchPlaneError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotChangeUserSketchPlaneError {
    FailureDefinitionId^ get ();
}
static member CannotChangeUserSketchPlaneError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.CannotChangeWorkplaneVisibility Property

BuiltInFailuresSketchFailuresCannotChangeWorkplaneVisibility Property

Can't change Work Plane Visibility.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotChangeWorkplaneVisibility { get; }
Public Shared ReadOnly Property CannotChangeWorkplaneVisibility As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotChangeWorkplaneVisibility {
    FailureDefinitionId^ get ();
}
static member CannotChangeWorkplaneVisibility : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.CannotComputeRailingsElevation Property

BuiltInFailuresSketchFailuresCannotComputeRailingsElevation Property

Can't compute Railings Elevation Profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotComputeRailingsElevation { get; }
Public Shared ReadOnly Property CannotComputeRailingsElevation As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotComputeRailingsElevation {
    FailureDefinitionId^ get ();
}
static member CannotComputeRailingsElevation : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.CannotComputeRailingsElevationError Property

BuiltInFailuresSketchFailuresCannotComputeRailingsElevationError Property

Can't compute Railings Elevation Profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotComputeRailingsElevationError { get; }
Public Shared ReadOnly Property CannotComputeRailingsElevationError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotComputeRailingsElevationError {
    FailureDefinitionId^ get ();
}
static member CannotComputeRailingsElevationError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.CannotComputeRailingsElevationWarn Property

BuiltInFailuresSketchFailuresCannotComputeRailingsElevationWarn Property

Can't compute Railings Elevation Profile

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotComputeRailingsElevationWarn { get; }
Public Shared ReadOnly Property CannotComputeRailingsElevationWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotComputeRailingsElevationWarn {
    FailureDefinitionId^ get ();
}
static member CannotComputeRailingsElevationWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.CannotConvertSketch Property

BuiltInFailuresSketchFailuresCannotConvertSketch Property

Can't convert Sketch to Rebar Shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotConvertSketch { get; }
Public Shared ReadOnly Property CannotConvertSketch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotConvertSketch {
    FailureDefinitionId^ get ();
}
static member CannotConvertSketch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.CannotDrawExtrusionRoof Property

BuiltInFailuresSketchFailuresCannotDrawExtrusionRoof Property

Can't make extruded roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotDrawExtrusionRoof { get; }
Public Shared ReadOnly Property CannotDrawExtrusionRoof As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotDrawExtrusionRoof {
    FailureDefinitionId^ get ();
}
static member CannotDrawExtrusionRoof : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.CannotDrawProfileRoof Property

BuiltInFailuresSketchFailuresCannotDrawProfileRoof Property

Can't make footprint roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotDrawProfileRoof { get; }
Public Shared ReadOnly Property CannotDrawProfileRoof As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotDrawProfileRoof {
    FailureDefinitionId^ get ();
}
static member CannotDrawProfileRoof : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.CannotGetSketchReferences Property

BuiltInFailuresSketchFailuresCannotGetSketchReferences Property

Cannot find references to dimension sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotGetSketchReferences { get; }
Public Shared ReadOnly Property CannotGetSketchReferences As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotGetSketchReferences {
    FailureDefinitionId^ get ();
}
static member CannotGetSketchReferences : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.CannotHaveArcs Property

BuiltInFailuresSketchFailuresCannotHaveArcs Property

Sorry, we can't use arcs here.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotHaveArcs { get; }
Public Shared ReadOnly Property CannotHaveArcs As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotHaveArcs {
    FailureDefinitionId^ get ();
}
static member CannotHaveArcs : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.CannotHaveArcsPath3d Property

BuiltInFailuresSketchFailuresCannotHaveArcsPath3d Property

Sorry, we can't use arcs here.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotHaveArcsPath3d { get; }
Public Shared ReadOnly Property CannotHaveArcsPath3d As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotHaveArcsPath3d {
    FailureDefinitionId^ get ();
}
static member CannotHaveArcsPath3d : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.CircleMultiPlanarShapeInSketch Property

BuiltInFailuresSketchFailuresCircleMultiPlanarShapeInSketch Property

A circle can't be converted to multiplanar shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CircleMultiPlanarShapeInSketch { get; }
Public Shared ReadOnly Property CircleMultiPlanarShapeInSketch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CircleMultiPlanarShapeInSketch {
    FailureDefinitionId^ get ();
}
static member CircleMultiPlanarShapeInSketch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.ClosedProfileRoof Property

BuiltInFailuresSketchFailuresClosedProfileRoof Property

Extrusion roof sketch must be open. The roof's thickness and material composition are defined in its type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ClosedProfileRoof { get; }
Public Shared ReadOnly Property ClosedProfileRoof As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ClosedProfileRoof {
    FailureDefinitionId^ get ();
}
static member ClosedProfileRoof : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.ConstantHeightNotParallel Property

BuiltInFailuresSketchFailuresConstantHeightNotParallel Property

Constant-height-defining lines must be parallel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ConstantHeightNotParallel { get; }
Public Shared ReadOnly Property ConstantHeightNotParallel As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ConstantHeightNotParallel {
    FailureDefinitionId^ get ();
}
static member ConstantHeightNotParallel : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.ConstantHeightNotParallelError Property

BuiltInFailuresSketchFailuresConstantHeightNotParallelError Property

Constant-height-defining lines must be parallel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ConstantHeightNotParallelError { get; }
Public Shared ReadOnly Property ConstantHeightNotParallelError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ConstantHeightNotParallelError {
    FailureDefinitionId^ get ();
}
static member ConstantHeightNotParallelError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.ContainedInOtherLoops Property

BuiltInFailuresSketchFailuresContainedInOtherLoops Property

When creating an opening, you cannot sketch loops within other loops. The highlighted loop(s) are contained within another loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ContainedInOtherLoops { get; }
Public Shared ReadOnly Property ContainedInOtherLoops As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ContainedInOtherLoops {
    FailureDefinitionId^ get ();
}
static member ContainedInOtherLoops : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.ConvertSplineToLineFailed Property

BuiltInFailuresSketchFailuresConvertSplineToLineFailed Property

Failed to convert spline to straight line

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ConvertSplineToLineFailed { get; }
Public Shared ReadOnly Property ConvertSplineToLineFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ConvertSplineToLineFailed {
    FailureDefinitionId^ get ();
}
static member ConvertSplineToLineFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.CurveFromPickedFailed Property

BuiltInFailuresSketchFailuresCurveFromPickedFailed Property

Can't create boundary from pick.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CurveFromPickedFailed { get; }
Public Shared ReadOnly Property CurveFromPickedFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CurveFromPickedFailed {
    FailureDefinitionId^ get ();
}
static member CurveFromPickedFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.CurveIntersectsCutFace Property

BuiltInFailuresSketchFailuresCurveIntersectsCutFace Property

The highlighted line intersects the boundary of the face being modified. To modify a cut face, use open loops that end on the existing boundary without intersecting or overlapping existing edges.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CurveIntersectsCutFace { get; }
Public Shared ReadOnly Property CurveIntersectsCutFace As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CurveIntersectsCutFace {
    FailureDefinitionId^ get ();
}
static member CurveIntersectsCutFace : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.CurveIntersectsSplitFace Property

BuiltInFailuresSketchFailuresCurveIntersectsSplitFace Property

The highlighted line intersects the boundary of the face being split. To split a face at its border, use an open loop that ends on the boundary of the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CurveIntersectsSplitFace { get; }
Public Shared ReadOnly Property CurveIntersectsSplitFace As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CurveIntersectsSplitFace {
    FailureDefinitionId^ get ();
}
static member CurveIntersectsSplitFace : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.CurveTooShort Property

BuiltInFailuresSketchFailuresCurveTooShort Property

Line is too short.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CurveTooShort { get; }
Public Shared ReadOnly Property CurveTooShort As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CurveTooShort {
    FailureDefinitionId^ get ();
}
static member CurveTooShort : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.DifferentOffsets Property

BuiltInFailuresSketchFailuresDifferentOffsets Property

Adjacent slope-defining lines must have identical eave heights; the highlighted lines do not. You can use the Align Eaves tool to have the eaves aligned for you.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DifferentOffsets { get; }
Public Shared ReadOnly Property DifferentOffsets As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DifferentOffsets {
    FailureDefinitionId^ get ();
}
static member DifferentOffsets : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.ElementsSketchTooLarge Property

BuiltInFailuresSketchFailuresElementsSketchTooLarge Property

The sketch defining the highlighted element is too large.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ElementsSketchTooLarge { get; }
Public Shared ReadOnly Property ElementsSketchTooLarge As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ElementsSketchTooLarge {
    FailureDefinitionId^ get ();
}
static member ElementsSketchTooLarge : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.ElevationSketchNotAllowed Property

BuiltInFailuresSketchFailuresElevationSketchNotAllowed Property

Wall in a family can't have an elevation profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ElevationSketchNotAllowed { get; }
Public Shared ReadOnly Property ElevationSketchNotAllowed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ElevationSketchNotAllowed {
    FailureDefinitionId^ get ();
}
static member ElevationSketchNotAllowed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.EndsNotOnCutFace Property

BuiltInFailuresSketchFailuresEndsNotOnCutFace Property

Ends of the sketched loop do not lie on the boundary of the face being modified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId EndsNotOnCutFace { get; }
Public Shared ReadOnly Property EndsNotOnCutFace As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ EndsNotOnCutFace {
    FailureDefinitionId^ get ();
}
static member EndsNotOnCutFace : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.EndsNotOnEdge Property

BuiltInFailuresSketchFailuresEndsNotOnEdge Property

Ends of an open loop in sketch splitting face do not lie on an edge of the face to split.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId EndsNotOnEdge { get; }
Public Shared ReadOnly Property EndsNotOnEdge As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ EndsNotOnEdge {
    FailureDefinitionId^ get ();
}
static member EndsNotOnEdge : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.FloorCannotAddDirectionCurve Property

BuiltInFailuresSketchFailuresFloorCannotAddDirectionCurve Property

Cannot add the direction curve in the floor sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FloorCannotAddDirectionCurve { get; }
Public Shared ReadOnly Property FloorCannotAddDirectionCurve As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FloorCannotAddDirectionCurve {
    FailureDefinitionId^ get ();
}
static member FloorCannotAddDirectionCurve : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.FloorCannotAddDirectionCurveError Property

BuiltInFailuresSketchFailuresFloorCannotAddDirectionCurveError Property

Cannot add the direction curve in the floor sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FloorCannotAddDirectionCurveError { get; }
Public Shared ReadOnly Property FloorCannotAddDirectionCurveError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FloorCannotAddDirectionCurveError {
    FailureDefinitionId^ get ();
}
static member FloorCannotAddDirectionCurveError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.FloorDirectionNotSpecified Property

BuiltInFailuresSketchFailuresFloorDirectionNotSpecified Property

Structural floor span direction not specified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FloorDirectionNotSpecified { get; }
Public Shared ReadOnly Property FloorDirectionNotSpecified As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FloorDirectionNotSpecified {
    FailureDefinitionId^ get ();
}
static member FloorDirectionNotSpecified : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.FloorManyDirectionCurves Property

BuiltInFailuresSketchFailuresFloorManyDirectionCurves Property

More than one span direction curve specified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FloorManyDirectionCurves { get; }
Public Shared ReadOnly Property FloorManyDirectionCurves As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FloorManyDirectionCurves {
    FailureDefinitionId^ get ();
}
static member FloorManyDirectionCurves : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.InvalidAreaLoadSketch Property

BuiltInFailuresSketchFailuresInvalidAreaLoadSketch Property

Area Load has invalid Sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidAreaLoadSketch { get; }
Public Shared ReadOnly Property InvalidAreaLoadSketch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidAreaLoadSketch {
    FailureDefinitionId^ get ();
}
static member InvalidAreaLoadSketch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.InvalidCropAreaSketch Property

BuiltInFailuresSketchFailuresInvalidCropAreaSketch Property

Crop area sketch can either be empty or include one closed, not self-intersecting loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidCropAreaSketch { get; }
Public Shared ReadOnly Property InvalidCropAreaSketch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidCropAreaSketch {
    FailureDefinitionId^ get ();
}
static member InvalidCropAreaSketch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.InvalidCropAreaSketchRegen Property

BuiltInFailuresSketchFailuresInvalidCropAreaSketchRegen Property

Crop area sketch can either be empty or include one closed, not self-intersecting loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidCropAreaSketchRegen { get; }
Public Shared ReadOnly Property InvalidCropAreaSketchRegen As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidCropAreaSketchRegen {
    FailureDefinitionId^ get ();
}
static member InvalidCropAreaSketchRegen : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.InvalidElevationSketch Property

BuiltInFailuresSketchFailuresInvalidElevationSketch Property

Elevation Profile sketch is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidElevationSketch { get; }
Public Shared ReadOnly Property InvalidElevationSketch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidElevationSketch {
    FailureDefinitionId^ get ();
}
static member InvalidElevationSketch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.InvalidElevationSketchError Property

BuiltInFailuresSketchFailuresInvalidElevationSketchError Property

Elevation Profile sketch is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidElevationSketchError { get; }
Public Shared ReadOnly Property InvalidElevationSketchError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidElevationSketchError {
    FailureDefinitionId^ get ();
}
static member InvalidElevationSketchError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.InvalidProfile Property

BuiltInFailuresSketchFailuresInvalidProfile Property

One or more profiles are invalid. Make sure that every used profile is a closed loop of non-intersecting lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidProfile { get; }
Public Shared ReadOnly Property InvalidProfile As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidProfile {
    FailureDefinitionId^ get ();
}
static member InvalidProfile : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.InvalidProfileError Property

BuiltInFailuresSketchFailuresInvalidProfileError Property

One or more profiles are invalid. Make sure that every used profile is a closed loop of non-intersecting lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidProfileError { get; }
Public Shared ReadOnly Property InvalidProfileError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidProfileError {
    FailureDefinitionId^ get ();
}
static member InvalidProfileError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.InvalidRoofCurveloop Property

BuiltInFailuresSketchFailuresInvalidRoofCurveloop Property

Base sketch for roof is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidRoofCurveloop { get; }
Public Shared ReadOnly Property InvalidRoofCurveloop As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidRoofCurveloop {
    FailureDefinitionId^ get ();
}
static member InvalidRoofCurveloop : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.InvalidRoofCurveloopError Property

BuiltInFailuresSketchFailuresInvalidRoofCurveloopError Property

Base sketch for roof is invalid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidRoofCurveloopError { get; }
Public Shared ReadOnly Property InvalidRoofCurveloopError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidRoofCurveloopError {
    FailureDefinitionId^ get ();
}
static member InvalidRoofCurveloopError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.InvalidRoofCurveloopFailure Property

BuiltInFailuresSketchFailuresInvalidRoofCurveloopFailure Property

Base sketch for roof is invalid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidRoofCurveloopFailure { get; }
Public Shared ReadOnly Property InvalidRoofCurveloopFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidRoofCurveloopFailure {
    FailureDefinitionId^ get ();
}
static member InvalidRoofCurveloopFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.InvalidSketch Property

BuiltInFailuresSketchFailuresInvalidSketch Property

Sketch is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidSketch { get; }
Public Shared ReadOnly Property InvalidSketch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidSketch {
    FailureDefinitionId^ get ();
}
static member InvalidSketch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.InvalidSketchError Property

BuiltInFailuresSketchFailuresInvalidSketchError Property

Sketch is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidSketchError { get; }
Public Shared ReadOnly Property InvalidSketchError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidSketchError {
    FailureDefinitionId^ get ();
}
static member InvalidSketchError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.InvalidSketchForBuildingpad Property

BuiltInFailuresSketchFailuresInvalidSketchForBuildingpad Property

Pad sketch is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidSketchForBuildingpad { get; }
Public Shared ReadOnly Property InvalidSketchForBuildingpad As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidSketchForBuildingpad {
    FailureDefinitionId^ get ();
}
static member InvalidSketchForBuildingpad : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.InvalidSketchForCeiling Property

BuiltInFailuresSketchFailuresInvalidSketchForCeiling Property

Ceiling sketch is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidSketchForCeiling { get; }
Public Shared ReadOnly Property InvalidSketchForCeiling As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidSketchForCeiling {
    FailureDefinitionId^ get ();
}
static member InvalidSketchForCeiling : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.InvalidSketchForFloor Property

BuiltInFailuresSketchFailuresInvalidSketchForFloor Property

Floor sketch is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidSketchForFloor { get; }
Public Shared ReadOnly Property InvalidSketchForFloor As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidSketchForFloor {
    FailureDefinitionId^ get ();
}
static member InvalidSketchForFloor : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.InvalidSketchForRoofsoffit Property

BuiltInFailuresSketchFailuresInvalidSketchForRoofsoffit Property

Roof Soffit sketch is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidSketchForRoofsoffit { get; }
Public Shared ReadOnly Property InvalidSketchForRoofsoffit As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidSketchForRoofsoffit {
    FailureDefinitionId^ get ();
}
static member InvalidSketchForRoofsoffit : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.InvalidSketchForToposolid Property

BuiltInFailuresSketchFailuresInvalidSketchForToposolid Property

Toposolid sketch is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidSketchForToposolid { get; }
Public Shared ReadOnly Property InvalidSketchForToposolid As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidSketchForToposolid {
    FailureDefinitionId^ get ();
}
static member InvalidSketchForToposolid : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.InvalidSketchPath3d Property

BuiltInFailuresSketchFailuresInvalidSketchPath3d Property

Sketch is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidSketchPath3d { get; }
Public Shared ReadOnly Property InvalidSketchPath3d As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidSketchPath3d {
    FailureDefinitionId^ get ();
}
static member InvalidSketchPath3d : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.LandingNotEnoughBoundaryCurves Property

BuiltInFailuresSketchFailuresLandingNotEnoughBoundaryCurves Property

Sketch landing require boundaries

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LandingNotEnoughBoundaryCurves { get; }
Public Shared ReadOnly Property LandingNotEnoughBoundaryCurves As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LandingNotEnoughBoundaryCurves {
    FailureDefinitionId^ get ();
}
static member LandingNotEnoughBoundaryCurves : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.LandingTwoManyLoops Property

BuiltInFailuresSketchFailuresLandingTwoManyLoops Property

Sketch landing can only have one closed loop

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LandingTwoManyLoops { get; }
Public Shared ReadOnly Property LandingTwoManyLoops As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LandingTwoManyLoops {
    FailureDefinitionId^ get ();
}
static member LandingTwoManyLoops : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.LinesOverlap Property

BuiltInFailuresSketchFailuresLinesOverlap Property

Cannot have overlapping lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LinesOverlap { get; }
Public Shared ReadOnly Property LinesOverlap As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LinesOverlap {
    FailureDefinitionId^ get ();
}
static member LinesOverlap : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.LinesOverlapError Property

BuiltInFailuresSketchFailuresLinesOverlapError Property

Cannot have overlapping lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LinesOverlapError { get; }
Public Shared ReadOnly Property LinesOverlapError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LinesOverlapError {
    FailureDefinitionId^ get ();
}
static member LinesOverlapError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.LinesOverlapPath3d Property

BuiltInFailuresSketchFailuresLinesOverlapPath3d Property

Cannot have overlapping lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LinesOverlapPath3d { get; }
Public Shared ReadOnly Property LinesOverlapPath3d As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LinesOverlapPath3d {
    FailureDefinitionId^ get ();
}
static member LinesOverlapPath3d : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.LoopIntersect Property

BuiltInFailuresSketchFailuresLoopIntersect Property

Lines cannot intersect each other. The highlighted lines currently intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LoopIntersect { get; }
Public Shared ReadOnly Property LoopIntersect As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LoopIntersect {
    FailureDefinitionId^ get ();
}
static member LoopIntersect : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.LoopIntersectError Property

BuiltInFailuresSketchFailuresLoopIntersectError Property

Lines cannot intersect each other. The highlighted lines currently intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LoopIntersectError { get; }
Public Shared ReadOnly Property LoopIntersectError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LoopIntersectError {
    FailureDefinitionId^ get ();
}
static member LoopIntersectError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.LoopIntersectPath3d Property

BuiltInFailuresSketchFailuresLoopIntersectPath3d Property

Lines cannot intersect each other. The highlighted lines currently intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LoopIntersectPath3d { get; }
Public Shared ReadOnly Property LoopIntersectPath3d As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LoopIntersectPath3d {
    FailureDefinitionId^ get ();
}
static member LoopIntersectPath3d : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.LoopsOutsideFaceSplit Property

BuiltInFailuresSketchFailuresLoopsOutsideFaceSplit Property

Some of the lines drawn lie outside of the boundary of the face being split. All lines used to split a face must be contained within the face being split and cannot intersect or overlap any of the boundaries of that face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LoopsOutsideFaceSplit { get; }
Public Shared ReadOnly Property LoopsOutsideFaceSplit As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LoopsOutsideFaceSplit {
    FailureDefinitionId^ get ();
}
static member LoopsOutsideFaceSplit : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.LoopsOutsideFaceSplitterTooShort Property

BuiltInFailuresSketchFailuresLoopsOutsideFaceSplitterTooShort Property

Some of the lines drawn lie outside of the boundary of the face being split. All lines used to split a face must be contained within the face being split and cannot intersect or overlap any of the boundaries of that face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LoopsOutsideFaceSplitterTooShort { get; }
Public Shared ReadOnly Property LoopsOutsideFaceSplitterTooShort As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LoopsOutsideFaceSplitterTooShort {
    FailureDefinitionId^ get ();
}
static member LoopsOutsideFaceSplitterTooShort : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.ManyCCWLoops Property

BuiltInFailuresSketchFailuresManyCCWLoops Property

Area defined by sketch must be connected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ManyCCWLoops { get; }
Public Shared ReadOnly Property ManyCCWLoops As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ManyCCWLoops {
    FailureDefinitionId^ get ();
}
static member ManyCCWLoops : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.ManyCCWLoopsError Property

BuiltInFailuresSketchFailuresManyCCWLoopsError Property

Area defined by sketch must be connected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ManyCCWLoopsError { get; }
Public Shared ReadOnly Property ManyCCWLoopsError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ManyCCWLoopsError {
    FailureDefinitionId^ get ();
}
static member ManyCCWLoopsError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.ManyDirectionCurves Property

BuiltInFailuresSketchFailuresManyDirectionCurves Property

More than one direction curve specified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ManyDirectionCurves { get; }
Public Shared ReadOnly Property ManyDirectionCurves As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ManyDirectionCurves {
    FailureDefinitionId^ get ();
}
static member ManyDirectionCurves : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.ManyDirectionCurvesError Property

BuiltInFailuresSketchFailuresManyDirectionCurvesError Property

More than one direction curve specified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ManyDirectionCurvesError { get; }
Public Shared ReadOnly Property ManyDirectionCurvesError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ManyDirectionCurvesError {
    FailureDefinitionId^ get ();
}
static member ManyDirectionCurvesError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.MissingLapInSketch Property

BuiltInFailuresSketchFailuresMissingLapInSketch Property

Rebar Sketch does not have lapped lengths. A circular shaped Rebar needs overlapping legths. Please overlap one of the ends of the circular Rebar Sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MissingLapInSketch { get; }
Public Shared ReadOnly Property MissingLapInSketch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MissingLapInSketch {
    FailureDefinitionId^ get ();
}
static member MissingLapInSketch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.MoreThanOneAxis Property

BuiltInFailuresSketchFailuresMoreThanOneAxis Property

More than one axes of revolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MoreThanOneAxis { get; }
Public Shared ReadOnly Property MoreThanOneAxis As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MoreThanOneAxis {
    FailureDefinitionId^ get ();
}
static member MoreThanOneAxis : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.MutipleStairsPathInOneRunFailure Property

BuiltInFailuresSketchFailuresMutipleStairsPathInOneRunFailure Property

Each stairs run can only have one stairs path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MutipleStairsPathInOneRunFailure { get; }
Public Shared ReadOnly Property MutipleStairsPathInOneRunFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MutipleStairsPathInOneRunFailure {
    FailureDefinitionId^ get ();
}
static member MutipleStairsPathInOneRunFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.NestedLoops Property

BuiltInFailuresSketchFailuresNestedLoops Property

Cannot have nested loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NestedLoops { get; }
Public Shared ReadOnly Property NestedLoops As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NestedLoops {
    FailureDefinitionId^ get ();
}
static member NestedLoops : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.NoLoops Property

BuiltInFailuresSketchFailuresNoLoops Property

Sketch is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoLoops { get; }
Public Shared ReadOnly Property NoLoops As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoLoops {
    FailureDefinitionId^ get ();
}
static member NoLoops : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.NoLoopsError Property

BuiltInFailuresSketchFailuresNoLoopsError Property

Sketch is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoLoopsError { get; }
Public Shared ReadOnly Property NoLoopsError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoLoopsError {
    FailureDefinitionId^ get ();
}
static member NoLoopsError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.NoLoopsPath3d Property

BuiltInFailuresSketchFailuresNoLoopsPath3d Property

Sketch is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoLoopsPath3d { get; }
Public Shared ReadOnly Property NoLoopsPath3d As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoLoopsPath3d {
    FailureDefinitionId^ get ();
}
static member NoLoopsPath3d : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.NonMonotoneRoof Property

BuiltInFailuresSketchFailuresNonMonotoneRoof Property

All parts of an extruded roof must face upward. Make sure that no part of the sketch lies below any other part of the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NonMonotoneRoof { get; }
Public Shared ReadOnly Property NonMonotoneRoof As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NonMonotoneRoof {
    FailureDefinitionId^ get ();
}
static member NonMonotoneRoof : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.NoPlane Property

BuiltInFailuresSketchFailuresNoPlane Property

Highlighted geometry no longer determines a plane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoPlane { get; }
Public Shared ReadOnly Property NoPlane As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoPlane {
    FailureDefinitionId^ get ();
}
static member NoPlane : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.NotOneCCWLoop Property

BuiltInFailuresSketchFailuresNotOneCCWLoop Property

This sketch defines more than one footprint. Make sure the sketch contains only one outermost loop and that there are no loops inside inner loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotOneCCWLoop { get; }
Public Shared ReadOnly Property NotOneCCWLoop As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotOneCCWLoop {
    FailureDefinitionId^ get ();
}
static member NotOneCCWLoop : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.NotOneCurve Property

BuiltInFailuresSketchFailuresNotOneCurve Property

More than one curve not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotOneCurve { get; }
Public Shared ReadOnly Property NotOneCurve As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotOneCurve {
    FailureDefinitionId^ get ();
}
static member NotOneCurve : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.NotOneCurveError Property

BuiltInFailuresSketchFailuresNotOneCurveError Property

More than one curve not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotOneCurveError { get; }
Public Shared ReadOnly Property NotOneCurveError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotOneCurveError {
    FailureDefinitionId^ get ();
}
static member NotOneCurveError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.NotOneCurvePath3d Property

BuiltInFailuresSketchFailuresNotOneCurvePath3d Property

More than one curve not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotOneCurvePath3d { get; }
Public Shared ReadOnly Property NotOneCurvePath3d As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotOneCurvePath3d {
    FailureDefinitionId^ get ();
}
static member NotOneCurvePath3d : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.NotOneLoop Property

BuiltInFailuresSketchFailuresNotOneLoop Property

More than one loop not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotOneLoop { get; }
Public Shared ReadOnly Property NotOneLoop As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotOneLoop {
    FailureDefinitionId^ get ();
}
static member NotOneLoop : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.NotOneLoopPath3d Property

BuiltInFailuresSketchFailuresNotOneLoopPath3d Property

More than one loop not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotOneLoopPath3d { get; }
Public Shared ReadOnly Property NotOneLoopPath3d As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotOneLoopPath3d {
    FailureDefinitionId^ get ();
}
static member NotOneLoopPath3d : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.OpenAreaLoadLoop Property

BuiltInFailuresSketchFailuresOpenAreaLoadLoop Property

Area Load Sketch can't contain open loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId OpenAreaLoadLoop { get; }
Public Shared ReadOnly Property OpenAreaLoadLoop As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ OpenAreaLoadLoop {
    FailureDefinitionId^ get ();
}
static member OpenAreaLoadLoop : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.OpenLoop Property

BuiltInFailuresSketchFailuresOpenLoop Property

Lines must be in closed loops. The highlighted lines are open on one end.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId OpenLoop { get; }
Public Shared ReadOnly Property OpenLoop As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ OpenLoop {
    FailureDefinitionId^ get ();
}
static member OpenLoop : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.OpenLoopError Property

BuiltInFailuresSketchFailuresOpenLoopError Property

Lines must be in closed loops. The highlighted lines are open on one end.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId OpenLoopError { get; }
Public Shared ReadOnly Property OpenLoopError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ OpenLoopError {
    FailureDefinitionId^ get ();
}
static member OpenLoopError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.OpenLoopPath3d Property

BuiltInFailuresSketchFailuresOpenLoopPath3d Property

Lines must be in closed loops. The highlighted lines are open on one end.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId OpenLoopPath3d { get; }
Public Shared ReadOnly Property OpenLoopPath3d As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ OpenLoopPath3d {
    FailureDefinitionId^ get ();
}
static member OpenLoopPath3d : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.PathCannotBeClosedLoop Property

BuiltInFailuresSketchFailuresPathCannotBeClosedLoop Property

Path cannot be a closed loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PathCannotBeClosedLoop { get; }
Public Shared ReadOnly Property PathCannotBeClosedLoop As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PathCannotBeClosedLoop {
    FailureDefinitionId^ get ();
}
static member PathCannotBeClosedLoop : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.PathCannotBeClosedLoopPath3d Property

BuiltInFailuresSketchFailuresPathCannotBeClosedLoopPath3d Property

Path cannot be a closed loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PathCannotBeClosedLoopPath3d { get; }
Public Shared ReadOnly Property PathCannotBeClosedLoopPath3d As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PathCannotBeClosedLoopPath3d {
    FailureDefinitionId^ get ();
}
static member PathCannotBeClosedLoopPath3d : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.PathReinforcementClosedLoop Property

BuiltInFailuresSketchFailuresPathReinforcementClosedLoop Property

Sketch contains a closed loop. Can't create Path Reinforcement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PathReinforcementClosedLoop { get; }
Public Shared ReadOnly Property PathReinforcementClosedLoop As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PathReinforcementClosedLoop {
    FailureDefinitionId^ get ();
}
static member PathReinforcementClosedLoop : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.PathReinforcementEmptySketch Property

BuiltInFailuresSketchFailuresPathReinforcementEmptySketch Property

Sketch is empty. Can't create Path Reinforcement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PathReinforcementEmptySketch { get; }
Public Shared ReadOnly Property PathReinforcementEmptySketch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PathReinforcementEmptySketch {
    FailureDefinitionId^ get ();
}
static member PathReinforcementEmptySketch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.PathReinforcementManyLoops Property

BuiltInFailuresSketchFailuresPathReinforcementManyLoops Property

Sketch contains more than one chain. Can't create Path Reinforcement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PathReinforcementManyLoops { get; }
Public Shared ReadOnly Property PathReinforcementManyLoops As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PathReinforcementManyLoops {
    FailureDefinitionId^ get ();
}
static member PathReinforcementManyLoops : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.PlanarMultiPlanarShapeInSketch Property

BuiltInFailuresSketchFailuresPlanarMultiPlanarShapeInSketch Property

The current shape is only bent in a single plane. A multi-planar definition is not required. Please redefine the shape on the top plane only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PlanarMultiPlanarShapeInSketch { get; }
Public Shared ReadOnly Property PlanarMultiPlanarShapeInSketch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PlanarMultiPlanarShapeInSketch {
    FailureDefinitionId^ get ();
}
static member PlanarMultiPlanarShapeInSketch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.RailingDoublyConnected Property

BuiltInFailuresSketchFailuresRailingDoublyConnected Property

Railings hosted on Stairs must form a single, open, connected line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RailingDoublyConnected { get; }
Public Shared ReadOnly Property RailingDoublyConnected As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RailingDoublyConnected {
    FailureDefinitionId^ get ();
}
static member RailingDoublyConnected : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.RailingDoublyConnectedError Property

BuiltInFailuresSketchFailuresRailingDoublyConnectedError Property

Railings hosted on Stairs must form a single, open, connected line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RailingDoublyConnectedError { get; }
Public Shared ReadOnly Property RailingDoublyConnectedError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RailingDoublyConnectedError {
    FailureDefinitionId^ get ();
}
static member RailingDoublyConnectedError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.RailingNotConnected Property

BuiltInFailuresSketchFailuresRailingNotConnected Property

The Railing line must be a single connected Sketch. If you want separate pieces of Railing, create two or more separate Railings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RailingNotConnected { get; }
Public Shared ReadOnly Property RailingNotConnected As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RailingNotConnected {
    FailureDefinitionId^ get ();
}
static member RailingNotConnected : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.RailingNotConnectedError Property

BuiltInFailuresSketchFailuresRailingNotConnectedError Property

The Railing line must be a single connected Sketch. If you want separate pieces of Railing, create two or more separate Railings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RailingNotConnectedError { get; }
Public Shared ReadOnly Property RailingNotConnectedError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RailingNotConnectedError {
    FailureDefinitionId^ get ();
}
static member RailingNotConnectedError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.RebarEmptySketch Property

BuiltInFailuresSketchFailuresRebarEmptySketch Property

Rebar Sketch is empty. Can't create Rebar.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RebarEmptySketch { get; }
Public Shared ReadOnly Property RebarEmptySketch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RebarEmptySketch {
    FailureDefinitionId^ get ();
}
static member RebarEmptySketch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.RebarEmptySketchError Property

BuiltInFailuresSketchFailuresRebarEmptySketchError Property

Rebar Sketch is empty. Can't create Rebar.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RebarEmptySketchError { get; }
Public Shared ReadOnly Property RebarEmptySketchError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RebarEmptySketchError {
    FailureDefinitionId^ get ();
}
static member RebarEmptySketchError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.RebarManyLoops Property

BuiltInFailuresSketchFailuresRebarManyLoops Property

Rebar Sketch contains more than one loop. Can't create Rebar.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RebarManyLoops { get; }
Public Shared ReadOnly Property RebarManyLoops As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RebarManyLoops {
    FailureDefinitionId^ get ();
}
static member RebarManyLoops : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.RebarManyLoopsError Property

BuiltInFailuresSketchFailuresRebarManyLoopsError Property

Rebar Sketch contains more than one loop. Can't create Rebar.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RebarManyLoopsError { get; }
Public Shared ReadOnly Property RebarManyLoopsError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RebarManyLoopsError {
    FailureDefinitionId^ get ();
}
static member RebarManyLoopsError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.RebarSystemDirectionNotSpecified Property

BuiltInFailuresSketchFailuresRebarSystemDirectionNotSpecified Property

Major direction not specified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RebarSystemDirectionNotSpecified { get; }
Public Shared ReadOnly Property RebarSystemDirectionNotSpecified As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RebarSystemDirectionNotSpecified {
    FailureDefinitionId^ get ();
}
static member RebarSystemDirectionNotSpecified : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.RebarSystemDirectionNotSpecifiedError Property

BuiltInFailuresSketchFailuresRebarSystemDirectionNotSpecifiedError Property

Major direction not specified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RebarSystemDirectionNotSpecifiedError { get; }
Public Shared ReadOnly Property RebarSystemDirectionNotSpecifiedError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RebarSystemDirectionNotSpecifiedError {
    FailureDefinitionId^ get ();
}
static member RebarSystemDirectionNotSpecifiedError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.RunInvalidSketch Property

BuiltInFailuresSketchFailuresRunInvalidSketch Property

Invalid sketch, can't create run by this sketch

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RunInvalidSketch { get; }
Public Shared ReadOnly Property RunInvalidSketch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RunInvalidSketch {
    FailureDefinitionId^ get ();
}
static member RunInvalidSketch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.RunNotEnoughBoundaryCurves Property

BuiltInFailuresSketchFailuresRunNotEnoughBoundaryCurves Property

Sketch run require boundaries (chains of one or more Boundary Lines)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RunNotEnoughBoundaryCurves { get; }
Public Shared ReadOnly Property RunNotEnoughBoundaryCurves As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RunNotEnoughBoundaryCurves {
    FailureDefinitionId^ get ();
}
static member RunNotEnoughBoundaryCurves : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.SculptingCurvesCannotFormClosedLoop Property

BuiltInFailuresSketchFailuresSculptingCurvesCannotFormClosedLoop Property

Curves cannot form a closed loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SculptingCurvesCannotFormClosedLoop { get; }
Public Shared ReadOnly Property SculptingCurvesCannotFormClosedLoop As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SculptingCurvesCannotFormClosedLoop {
    FailureDefinitionId^ get ();
}
static member SculptingCurvesCannotFormClosedLoop : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.SculptingCurvesCrossAxis Property

BuiltInFailuresSketchFailuresSculptingCurvesCrossAxis Property

The highlighted curves cross the axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SculptingCurvesCrossAxis { get; }
Public Shared ReadOnly Property SculptingCurvesCrossAxis As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SculptingCurvesCrossAxis {
    FailureDefinitionId^ get ();
}
static member SculptingCurvesCrossAxis : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.SculptingCurvesTouchAxis Property

BuiltInFailuresSketchFailuresSculptingCurvesTouchAxis Property

The highlighted curves touch the axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SculptingCurvesTouchAxis { get; }
Public Shared ReadOnly Property SculptingCurvesTouchAxis As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SculptingCurvesTouchAxis {
    FailureDefinitionId^ get ();
}
static member SculptingCurvesTouchAxis : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.SculptingLoopsOnBothSidesOfAxis Property

BuiltInFailuresSketchFailuresSculptingLoopsOnBothSidesOfAxis Property

All curves must be on the same side of the axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SculptingLoopsOnBothSidesOfAxis { get; }
Public Shared ReadOnly Property SculptingLoopsOnBothSidesOfAxis As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SculptingLoopsOnBothSidesOfAxis {
    FailureDefinitionId^ get ();
}
static member SculptingLoopsOnBothSidesOfAxis : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.SculptingSingleLineLoopLiesOnAxis Property

BuiltInFailuresSketchFailuresSculptingSingleLineLoopLiesOnAxis Property

The highlighted lines lie on the axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SculptingSingleLineLoopLiesOnAxis { get; }
Public Shared ReadOnly Property SculptingSingleLineLoopLiesOnAxis As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SculptingSingleLineLoopLiesOnAxis {
    FailureDefinitionId^ get ();
}
static member SculptingSingleLineLoopLiesOnAxis : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.ShortCurveInSketch Property

BuiltInFailuresSketchFailuresShortCurveInSketch Property

The sketch contains an extremely short line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ShortCurveInSketch { get; }
Public Shared ReadOnly Property ShortCurveInSketch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ShortCurveInSketch {
    FailureDefinitionId^ get ();
}
static member ShortCurveInSketch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.ShortCurveInSketchRoof Property

BuiltInFailuresSketchFailuresShortCurveInSketchRoof Property

The sketch contains an extremely short line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ShortCurveInSketchRoof { get; }
Public Shared ReadOnly Property ShortCurveInSketchRoof As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ShortCurveInSketchRoof {
    FailureDefinitionId^ get ();
}
static member ShortCurveInSketchRoof : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.SiteCannotDrawSurfaceBoundary Property

BuiltInFailuresSketchFailuresSiteCannotDrawSurfaceBoundary Property

Cannot make surface with specified boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SiteCannotDrawSurfaceBoundary { get; }
Public Shared ReadOnly Property SiteCannotDrawSurfaceBoundary As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SiteCannotDrawSurfaceBoundary {
    FailureDefinitionId^ get ();
}
static member SiteCannotDrawSurfaceBoundary : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.SketchedRunInvalidPath Property

BuiltInFailuresSketchFailuresSketchedRunInvalidPath Property

Invalid stair path. Stair path should connect both start and end riser, and cross all other risers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SketchedRunInvalidPath { get; }
Public Shared ReadOnly Property SketchedRunInvalidPath As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SketchedRunInvalidPath {
    FailureDefinitionId^ get ();
}
static member SketchedRunInvalidPath : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.SketchedShapeNotAvailable Property

BuiltInFailuresSketchFailuresSketchedShapeNotAvailable Property

Skeched shape is not available for this type of element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SketchedShapeNotAvailable { get; }
Public Shared ReadOnly Property SketchedShapeNotAvailable As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SketchedShapeNotAvailable {
    FailureDefinitionId^ get ();
}
static member SketchedShapeNotAvailable : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.SketchFailurePlanes Property

BuiltInFailuresSketchFailuresSketchFailurePlanes Property

Sketch is no longer parallel to its defining plane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SketchFailurePlanes { get; }
Public Shared ReadOnly Property SketchFailurePlanes As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SketchFailurePlanes {
    FailureDefinitionId^ get ();
}
static member SketchFailurePlanes : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.SketchingInTheWrongView Property

BuiltInFailuresSketchFailuresSketchingInTheWrongView Property

Detail sketch is only editable in [View Type].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SketchingInTheWrongView { get; }
Public Shared ReadOnly Property SketchingInTheWrongView As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SketchingInTheWrongView {
    FailureDefinitionId^ get ();
}
static member SketchingInTheWrongView : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.SketchingInWrongView Property

BuiltInFailuresSketchFailuresSketchingInWrongView Property

Detail sketch is not editable in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SketchingInWrongView { get; }
Public Shared ReadOnly Property SketchingInWrongView As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SketchingInWrongView {
    FailureDefinitionId^ get ();
}
static member SketchingInWrongView : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.SketchOverconstrained Property

BuiltInFailuresSketchFailuresSketchOverconstrained Property

Sketch is overconstrained.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SketchOverconstrained { get; }
Public Shared ReadOnly Property SketchOverconstrained As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SketchOverconstrained {
    FailureDefinitionId^ get ();
}
static member SketchOverconstrained : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.SketchOverconstrainedError Property

BuiltInFailuresSketchFailuresSketchOverconstrainedError Property

Sketch is overconstrained.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SketchOverconstrainedError { get; }
Public Shared ReadOnly Property SketchOverconstrainedError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SketchOverconstrainedError {
    FailureDefinitionId^ get ();
}
static member SketchOverconstrainedError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.SketchOverconstrainedWarn Property

BuiltInFailuresSketchFailuresSketchOverconstrainedWarn Property

Sketch is overconstrained.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SketchOverconstrainedWarn { get; }
Public Shared ReadOnly Property SketchOverconstrainedWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SketchOverconstrainedWarn {
    FailureDefinitionId^ get ();
}
static member SketchOverconstrainedWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.SketchTooLarge Property

BuiltInFailuresSketchFailuresSketchTooLarge Property

Sketch is too large.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SketchTooLarge { get; }
Public Shared ReadOnly Property SketchTooLarge As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SketchTooLarge {
    FailureDefinitionId^ get ();
}
static member SketchTooLarge : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.SketchWasDeleted Property

BuiltInFailuresSketchFailuresSketchWasDeleted Property

Sketch was deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SketchWasDeleted { get; }
Public Shared ReadOnly Property SketchWasDeleted As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SketchWasDeleted {
    FailureDefinitionId^ get ();
}
static member SketchWasDeleted : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.StairClosedBoundaries Property

BuiltInFailuresSketchFailuresStairClosedBoundaries Property

Stairs Boundaries (chains of one or more Boundary Lines) should not form closed loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StairClosedBoundaries { get; }
Public Shared ReadOnly Property StairClosedBoundaries As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StairClosedBoundaries {
    FailureDefinitionId^ get ();
}
static member StairClosedBoundaries : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.StairClosedBoundariesError Property

BuiltInFailuresSketchFailuresStairClosedBoundariesError Property

Stairs Boundaries (chains of one or more Boundary Lines) should not form closed loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StairClosedBoundariesError { get; }
Public Shared ReadOnly Property StairClosedBoundariesError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StairClosedBoundariesError {
    FailureDefinitionId^ get ();
}
static member StairClosedBoundariesError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.StairNotEnoughBoundaryCurves Property

BuiltInFailuresSketchFailuresStairNotEnoughBoundaryCurves Property

Stairs require boundaries (chains of one or more Boundary Lines) on each side of the Stair.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StairNotEnoughBoundaryCurves { get; }
Public Shared ReadOnly Property StairNotEnoughBoundaryCurves As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StairNotEnoughBoundaryCurves {
    FailureDefinitionId^ get ();
}
static member StairNotEnoughBoundaryCurves : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.StairNotEnoughBoundaryCurvesError Property

BuiltInFailuresSketchFailuresStairNotEnoughBoundaryCurvesError Property

Stairs require boundaries (chains of one or more Boundary Lines) on each side of the Stair.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StairNotEnoughBoundaryCurvesError { get; }
Public Shared ReadOnly Property StairNotEnoughBoundaryCurvesError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StairNotEnoughBoundaryCurvesError {
    FailureDefinitionId^ get ();
}
static member StairNotEnoughBoundaryCurvesError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.StairNotEnoughRiserCurves Property

BuiltInFailuresSketchFailuresStairNotEnoughRiserCurves Property

Boundaries (chains of one or more Boundary Lines) must be connected by at least two Riser Lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StairNotEnoughRiserCurves { get; }
Public Shared ReadOnly Property StairNotEnoughRiserCurves As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StairNotEnoughRiserCurves {
    FailureDefinitionId^ get ();
}
static member StairNotEnoughRiserCurves : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.StairNotEnoughRiserCurvesError Property

BuiltInFailuresSketchFailuresStairNotEnoughRiserCurvesError Property

Boundaries (chains of one or more Boundary Lines) must be connected by at least two Riser Lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StairNotEnoughRiserCurvesError { get; }
Public Shared ReadOnly Property StairNotEnoughRiserCurvesError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StairNotEnoughRiserCurvesError {
    FailureDefinitionId^ get ();
}
static member StairNotEnoughRiserCurvesError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.StairOnlyOneConnectedBoundary Property

BuiltInFailuresSketchFailuresStairOnlyOneConnectedBoundary Property

Stairs require no less than two boundaries (chains of one or more Boundary Lines)."

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StairOnlyOneConnectedBoundary { get; }
Public Shared ReadOnly Property StairOnlyOneConnectedBoundary As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StairOnlyOneConnectedBoundary {
    FailureDefinitionId^ get ();
}
static member StairOnlyOneConnectedBoundary : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.StairOnlyOneConnectedBoundaryError Property

BuiltInFailuresSketchFailuresStairOnlyOneConnectedBoundaryError Property

Stairs require no less than two boundaries (chains of one or more Boundary Lines).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StairOnlyOneConnectedBoundaryError { get; }
Public Shared ReadOnly Property StairOnlyOneConnectedBoundaryError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StairOnlyOneConnectedBoundaryError {
    FailureDefinitionId^ get ();
}
static member StairOnlyOneConnectedBoundaryError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.StairRiserDoesntIntersectBoundary Property

BuiltInFailuresSketchFailuresStairRiserDoesntIntersectBoundary Property

The line representing the top of a riser does not intersect one or both of the boundary lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StairRiserDoesntIntersectBoundary { get; }
Public Shared ReadOnly Property StairRiserDoesntIntersectBoundary As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StairRiserDoesntIntersectBoundary {
    FailureDefinitionId^ get ();
}
static member StairRiserDoesntIntersectBoundary : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.StairRiserDoesntIntersectBoundaryError Property

BuiltInFailuresSketchFailuresStairRiserDoesntIntersectBoundaryError Property

The line representing the top of a riser does not intersect one or both of the boundary lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StairRiserDoesntIntersectBoundaryError { get; }
Public Shared ReadOnly Property StairRiserDoesntIntersectBoundaryError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StairRiserDoesntIntersectBoundaryError {
    FailureDefinitionId^ get ();
}
static member StairRiserDoesntIntersectBoundaryError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.StairTooManyConnectedBoundaries Property

BuiltInFailuresSketchFailuresStairTooManyConnectedBoundaries Property

Stairs require no more than two boundaries (chains of one or more Boundary Lines).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StairTooManyConnectedBoundaries { get; }
Public Shared ReadOnly Property StairTooManyConnectedBoundaries As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StairTooManyConnectedBoundaries {
    FailureDefinitionId^ get ();
}
static member StairTooManyConnectedBoundaries : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.StairTooManyConnectedBoundariesError Property

BuiltInFailuresSketchFailuresStairTooManyConnectedBoundariesError Property

Stairs require no more than two boundaries (chains of one or more Boundary Lines).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StairTooManyConnectedBoundariesError { get; }
Public Shared ReadOnly Property StairTooManyConnectedBoundariesError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StairTooManyConnectedBoundariesError {
    FailureDefinitionId^ get ();
}
static member StairTooManyConnectedBoundariesError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.SubregionNoHostSurf Property

BuiltInFailuresSketchFailuresSubregionNoHostSurf Property

A Subregion cannot be created outside the boundary of a Toposurface. A Subregion should be completely inside a Toposurface or overlap a Toposurface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SubregionNoHostSurf { get; }
Public Shared ReadOnly Property SubregionNoHostSurf As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SubregionNoHostSurf {
    FailureDefinitionId^ get ();
}
static member SubregionNoHostSurf : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.SuggestMakingFamilyNonParametric Property

BuiltInFailuresSketchFailuresSuggestMakingFamilyNonParametric Property

Performance Warning: This family now contains both labeled dimensions and sketches with many segments. This may hurt performance. To improve performance, create elements that require complex sketches as nested families.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SuggestMakingFamilyNonParametric { get; }
Public Shared ReadOnly Property SuggestMakingFamilyNonParametric As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SuggestMakingFamilyNonParametric {
    FailureDefinitionId^ get ();
}
static member SuggestMakingFamilyNonParametric : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.SuspendedSketchWarn Property

BuiltInFailuresSketchFailuresSuspendedSketchWarn Property

Highlighted element's sketch could not regenerate and has been suspended. Select the element and edit its sketch to fix the problem. The element will display in magenta until you fix the problem

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SuspendedSketchWarn { get; }
Public Shared ReadOnly Property SuspendedSketchWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SuspendedSketchWarn {
    FailureDefinitionId^ get ();
}
static member SuspendedSketchWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.TooFewParamsForSketch Property

BuiltInFailuresSketchFailuresTooFewParamsForSketch Property

The sketched Structural Rebar element has too many segments to be properly parameterized. Please reduce the number of segments.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TooFewParamsForSketch { get; }
Public Shared ReadOnly Property TooFewParamsForSketch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TooFewParamsForSketch {
    FailureDefinitionId^ get ();
}
static member TooFewParamsForSketch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.TooManyElementsInSketch Property

BuiltInFailuresSketchFailuresTooManyElementsInSketch Property

This sketch is large. Performance will improve if constructed as several independent sketches.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TooManyElementsInSketch { get; }
Public Shared ReadOnly Property TooManyElementsInSketch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TooManyElementsInSketch {
    FailureDefinitionId^ get ();
}
static member TooManyElementsInSketch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.TooManySlopes Property

BuiltInFailuresSketchFailuresTooManySlopes Property

There is more than one slope defined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TooManySlopes { get; }
Public Shared ReadOnly Property TooManySlopes As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TooManySlopes {
    FailureDefinitionId^ get ();
}
static member TooManySlopes : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.TooManySlopesError Property

BuiltInFailuresSketchFailuresTooManySlopesError Property

There is more than one slope defined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TooManySlopesError { get; }
Public Shared ReadOnly Property TooManySlopesError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TooManySlopesError {
    FailureDefinitionId^ get ();
}
static member TooManySlopesError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.TrussClosedReference Property

BuiltInFailuresSketchFailuresTrussClosedReference Property

Truss references (chains of one or more reference lines) should not form closed loops."

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TrussClosedReference { get; }
Public Shared ReadOnly Property TrussClosedReference As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TrussClosedReference {
    FailureDefinitionId^ get ();
}
static member TrussClosedReference : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.TrussCrossingReferences Property

BuiltInFailuresSketchFailuresTrussCrossingReferences Property

Truss top and bottom references cannot cross.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TrussCrossingReferences { get; }
Public Shared ReadOnly Property TrussCrossingReferences As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TrussCrossingReferences {
    FailureDefinitionId^ get ();
}
static member TrussCrossingReferences : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.TrussMissingReference Property

BuiltInFailuresSketchFailuresTrussMissingReference Property

Trusses require both a top and a bottom chord reference (chain of one or more reference lines).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TrussMissingReference { get; }
Public Shared ReadOnly Property TrussMissingReference As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TrussMissingReference {
    FailureDefinitionId^ get ();
}
static member TrussMissingReference : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.TrussOverlappingReference Property

BuiltInFailuresSketchFailuresTrussOverlappingReference Property

Truss references (chains of one or more reference lines) cannot overlap themselves in the vertical direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TrussOverlappingReference { get; }
Public Shared ReadOnly Property TrussOverlappingReference As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TrussOverlappingReference {
    FailureDefinitionId^ get ();
}
static member TrussOverlappingReference : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.TrussSegmentedReference Property

BuiltInFailuresSketchFailuresTrussSegmentedReference Property

Truss reference must form a continuous chain of one or more sketch lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TrussSegmentedReference { get; }
Public Shared ReadOnly Property TrussSegmentedReference As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TrussSegmentedReference {
    FailureDefinitionId^ get ();
}
static member TrussSegmentedReference : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.TrussShiftedReferences Property

BuiltInFailuresSketchFailuresTrussShiftedReferences Property

Truss top and bottom references (chains of one or more reference lines) must overlap at least partially in the vertical direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TrussShiftedReferences { get; }
Public Shared ReadOnly Property TrussShiftedReferences As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TrussShiftedReferences {
    FailureDefinitionId^ get ();
}
static member TrussShiftedReferences : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.TrussSwappedReferences Property

BuiltInFailuresSketchFailuresTrussSwappedReferences Property

Truss top reference must be above the bottom reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TrussSwappedReferences { get; }
Public Shared ReadOnly Property TrussSwappedReferences As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TrussSwappedReferences {
    FailureDefinitionId^ get ();
}
static member TrussSwappedReferences : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.UnsatisfiedSupportAssocProp Property

BuiltInFailuresSketchFailuresUnsatisfiedSupportAssocProp Property

Constraint between a Line created with Pick Support and the Support is not satisfied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnsatisfiedSupportAssocProp { get; }
Public Shared ReadOnly Property UnsatisfiedSupportAssocProp As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnsatisfiedSupportAssocProp {
    FailureDefinitionId^ get ();
}
static member UnsatisfiedSupportAssocProp : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.UnsatisfiedWallAssocProp Property

BuiltInFailuresSketchFailuresUnsatisfiedWallAssocProp Property

Constraint between a Line created with Pick Wall and the Wall is not satisfied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnsatisfiedWallAssocProp { get; }
Public Shared ReadOnly Property UnsatisfiedWallAssocProp As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnsatisfiedWallAssocProp {
    FailureDefinitionId^ get ();
}
static member UnsatisfiedWallAssocProp : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.VarSketchFailure Property

BuiltInFailuresSketchFailuresVarSketchFailure Property

Constraints defined by highlighted Lines and Dimensions can't be satisfied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId VarSketchFailure { get; }
Public Shared ReadOnly Property VarSketchFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ VarSketchFailure {
    FailureDefinitionId^ get ();
}
static member VarSketchFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.VarSketchInElementFailure Property

BuiltInFailuresSketchFailuresVarSketchInElementFailure Property

The constraints of the sketch defining the highlighted element cannot be satisfied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId VarSketchInElementFailure { get; }
Public Shared ReadOnly Property VarSketchInElementFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ VarSketchInElementFailure {
    FailureDefinitionId^ get ();
}
static member VarSketchInElementFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.WrongCutBoundaryLoops Property

BuiltInFailuresSketchFailuresWrongCutBoundaryLoops Property

Only open loops can be used for Edit Cut Profile. All open ends must lie on the boundary of the cut profile, and the loop may not touch the boundary anywhere except at its ends.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WrongCutBoundaryLoops { get; }
Public Shared ReadOnly Property WrongCutBoundaryLoops As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WrongCutBoundaryLoops {
    FailureDefinitionId^ get ();
}
static member WrongCutBoundaryLoops : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SketchFailures.WrongFaceSplitterLoopTypesNum Property

BuiltInFailuresSketchFailuresWrongFaceSplitterLoopTypesNum Property

Sketch for splitting the face is invalid. Faces may be split either by a single closed loop that is contained within the face or by one or more open loops whose ends lie on the boundary of the face. None of the lines in the sketch are allowed to overlap or intersect the boundaries of the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WrongFaceSplitterLoopTypesNum { get; }
Public Shared ReadOnly Property WrongFaceSplitterLoopTypesNum As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WrongFaceSplitterLoopTypesNum {
    FailureDefinitionId^ get ();
}
static member WrongFaceSplitterLoopTypesNum : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSketchFailures Class


BuiltInFailures.SkylightFailures Class

BuiltInFailuresSkylightFailures Class

Failures about Skylight.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresSkylightFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class SkylightFailures
Public NotInheritable Class SkylightFailures
public ref class SkylightFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SkylightFailures = class end

The BuiltInFailuresSkylightFailures type exposes the following members.

Properties
Name | Description
MinSkylightWidthImperial | The minimum skylight width is 8 inches.
MinSkylightWidthMetric | The minimum skylight width is 203.2 millimeters.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SkylightFailures Properties

The BuiltInFailuresSkylightFailures type exposes the following members.

Properties
Name | Description
MinSkylightWidthImperial | The minimum skylight width is 8 inches.
MinSkylightWidthMetric | The minimum skylight width is 203.2 millimeters.
Top
See Also

Reference

BuiltInFailuresSkylightFailures Class


BuiltInFailures.SkylightFailures.MinSkylightWidthImperial Property

BuiltInFailuresSkylightFailuresMinSkylightWidthImperial Property

The minimum skylight width is 8 inches.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MinSkylightWidthImperial { get; }
Public Shared ReadOnly Property MinSkylightWidthImperial As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MinSkylightWidthImperial {
    FailureDefinitionId^ get ();
}
static member MinSkylightWidthImperial : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSkylightFailures Class


BuiltInFailures.SkylightFailures.MinSkylightWidthMetric Property

BuiltInFailuresSkylightFailuresMinSkylightWidthMetric Property

The minimum skylight width is 203.2 millimeters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MinSkylightWidthMetric { get; }
Public Shared ReadOnly Property MinSkylightWidthMetric As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MinSkylightWidthMetric {
    FailureDefinitionId^ get ();
}
static member MinSkylightWidthMetric : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSkylightFailures Class


BuiltInFailures.SlabFailures Class

BuiltInFailuresSlabFailures Class

Failures about Slab.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresSlabFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class SlabFailures
Public NotInheritable Class SlabFailures
public ref class SlabFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SlabFailures = class end

The BuiltInFailuresSlabFailures type exposes the following members.

Properties
Name | Description
CantileverValueTooBig | Cantilever value is too big.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SlabFailures Properties

The BuiltInFailuresSlabFailures type exposes the following members.

Properties
Name | Description
CantileverValueTooBig | Cantilever value is too big.
Top
See Also

Reference

BuiltInFailuresSlabFailures Class


BuiltInFailures.SlabFailures.CantileverValueTooBig Property

BuiltInFailuresSlabFailuresCantileverValueTooBig Property

Cantilever value is too big.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CantileverValueTooBig { get; }
Public Shared ReadOnly Property CantileverValueTooBig As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CantileverValueTooBig {
    FailureDefinitionId^ get ();
}
static member CantileverValueTooBig : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSlabFailures Class


BuiltInFailures.SlabShapeFailures Class

BuiltInFailuresSlabShapeFailures Class

Failures about SlabShape.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresSlabShapeFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class SlabShapeFailures
Public NotInheritable Class SlabShapeFailures
public ref class SlabShapeFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SlabShapeFailures = class end

The BuiltInFailuresSlabShapeFailures type exposes the following members.

Properties
Name | Description
SlabShapeEditFailed | Slab Shape Edit failed. [Description]
SlabShapeEditFailedError | Slab Shape Edit failed. [Description]
SlabShapeFailedNotHorz | The Floor or Roof or Toposolid is no longer horizontal.
SlabShapeFailedNotOnlyLines | The Floor or Roof or Toposolid may only contain straight lines.
SlabShapeFailedTooThin | The Floor or Roof or Toposolid is too thin for its given type.
SlabShapeWarnVerticesCoincident | Some slab shape edit vertices were too close to each other or too close to an edge.
SlabShapeWarnVerticesDeleted | Some slab shape edit vertices were deleted because the Floor or Roof or Toposolid has changed its shape.
SlopedInnerEdge | Inner loops of a footprint sketch may not have slope-defining lines.
SlopeTailInsideSlopeLine | The tails of slope arrows must not lie in interior of slope defining lines.
SlopeZero | Adjusting this Line's Overhang will not affect its height because its slope is zero.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SlabShapeFailures Properties

The BuiltInFailuresSlabShapeFailures type exposes the following members.

Properties
Name | Description
SlabShapeEditFailed | Slab Shape Edit failed. [Description]
SlabShapeEditFailedError | Slab Shape Edit failed. [Description]
SlabShapeFailedNotHorz | The Floor or Roof or Toposolid is no longer horizontal.
SlabShapeFailedNotOnlyLines | The Floor or Roof or Toposolid may only contain straight lines.
SlabShapeFailedTooThin | The Floor or Roof or Toposolid is too thin for its given type.
SlabShapeWarnVerticesCoincident | Some slab shape edit vertices were too close to each other or too close to an edge.
SlabShapeWarnVerticesDeleted | Some slab shape edit vertices were deleted because the Floor or Roof or Toposolid has changed its shape.
SlopedInnerEdge | Inner loops of a footprint sketch may not have slope-defining lines.
SlopeTailInsideSlopeLine | The tails of slope arrows must not lie in interior of slope defining lines.
SlopeZero | Adjusting this Line's Overhang will not affect its height because its slope is zero.
Top
See Also

Reference

BuiltInFailuresSlabShapeFailures Class


BuiltInFailures.SlabShapeFailures.SlabShapeEditFailed Property

BuiltInFailuresSlabShapeFailuresSlabShapeEditFailed Property

Slab Shape Edit failed. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SlabShapeEditFailed { get; }
Public Shared ReadOnly Property SlabShapeEditFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SlabShapeEditFailed {
    FailureDefinitionId^ get ();
}
static member SlabShapeEditFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSlabShapeFailures Class


BuiltInFailures.SlabShapeFailures.SlabShapeEditFailedError Property

BuiltInFailuresSlabShapeFailuresSlabShapeEditFailedError Property

Slab Shape Edit failed. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SlabShapeEditFailedError { get; }
Public Shared ReadOnly Property SlabShapeEditFailedError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SlabShapeEditFailedError {
    FailureDefinitionId^ get ();
}
static member SlabShapeEditFailedError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSlabShapeFailures Class


BuiltInFailures.SlabShapeFailures.SlabShapeFailedNotHorz Property

BuiltInFailuresSlabShapeFailuresSlabShapeFailedNotHorz Property

The Floor or Roof or Toposolid is no longer horizontal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SlabShapeFailedNotHorz { get; }
Public Shared ReadOnly Property SlabShapeFailedNotHorz As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SlabShapeFailedNotHorz {
    FailureDefinitionId^ get ();
}
static member SlabShapeFailedNotHorz : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSlabShapeFailures Class


BuiltInFailures.SlabShapeFailures.SlabShapeFailedNotOnlyLines Property

BuiltInFailuresSlabShapeFailuresSlabShapeFailedNotOnlyLines Property

The Floor or Roof or Toposolid may only contain straight lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SlabShapeFailedNotOnlyLines { get; }
Public Shared ReadOnly Property SlabShapeFailedNotOnlyLines As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SlabShapeFailedNotOnlyLines {
    FailureDefinitionId^ get ();
}
static member SlabShapeFailedNotOnlyLines : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSlabShapeFailures Class


BuiltInFailures.SlabShapeFailures.SlabShapeFailedTooThin Property

BuiltInFailuresSlabShapeFailuresSlabShapeFailedTooThin Property

The Floor or Roof or Toposolid is too thin for its given type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SlabShapeFailedTooThin { get; }
Public Shared ReadOnly Property SlabShapeFailedTooThin As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SlabShapeFailedTooThin {
    FailureDefinitionId^ get ();
}
static member SlabShapeFailedTooThin : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSlabShapeFailures Class


BuiltInFailures.SlabShapeFailures.SlabShapeWarnVerticesCoincident Property

BuiltInFailuresSlabShapeFailuresSlabShapeWarnVerticesCoincident Property

Some slab shape edit vertices were too close to each other or too close to an edge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SlabShapeWarnVerticesCoincident { get; }
Public Shared ReadOnly Property SlabShapeWarnVerticesCoincident As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SlabShapeWarnVerticesCoincident {
    FailureDefinitionId^ get ();
}
static member SlabShapeWarnVerticesCoincident : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSlabShapeFailures Class


BuiltInFailures.SlabShapeFailures.SlabShapeWarnVerticesDeleted Property

BuiltInFailuresSlabShapeFailuresSlabShapeWarnVerticesDeleted Property

Some slab shape edit vertices were deleted because the Floor or Roof or Toposolid has changed its shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SlabShapeWarnVerticesDeleted { get; }
Public Shared ReadOnly Property SlabShapeWarnVerticesDeleted As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SlabShapeWarnVerticesDeleted {
    FailureDefinitionId^ get ();
}
static member SlabShapeWarnVerticesDeleted : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSlabShapeFailures Class


BuiltInFailures.SlabShapeFailures.SlopedInnerEdge Property

BuiltInFailuresSlabShapeFailuresSlopedInnerEdge Property

Inner loops of a footprint sketch may not have slope-defining lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SlopedInnerEdge { get; }
Public Shared ReadOnly Property SlopedInnerEdge As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SlopedInnerEdge {
    FailureDefinitionId^ get ();
}
static member SlopedInnerEdge : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSlabShapeFailures Class


BuiltInFailures.SlabShapeFailures.SlopeTailInsideSlopeLine Property

BuiltInFailuresSlabShapeFailuresSlopeTailInsideSlopeLine Property

The tails of slope arrows must not lie in interior of slope defining lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SlopeTailInsideSlopeLine { get; }
Public Shared ReadOnly Property SlopeTailInsideSlopeLine As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SlopeTailInsideSlopeLine {
    FailureDefinitionId^ get ();
}
static member SlopeTailInsideSlopeLine : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSlabShapeFailures Class


BuiltInFailures.SlabShapeFailures.SlopeZero Property

BuiltInFailuresSlabShapeFailuresSlopeZero Property

Adjusting this Line's Overhang will not affect its height because its slope is zero.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SlopeZero { get; }
Public Shared ReadOnly Property SlopeZero As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SlopeZero {
    FailureDefinitionId^ get ();
}
static member SlopeZero : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSlabShapeFailures Class


BuiltInFailures.SlantedColumnFailures Class

BuiltInFailuresSlantedColumnFailures Class

Failures about SlantedColumn.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresSlantedColumnFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class SlantedColumnFailures
Public NotInheritable Class SlantedColumnFailures
public ref class SlantedColumnFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SlantedColumnFailures = class end

The BuiltInFailuresSlantedColumnFailures type exposes the following members.

Properties
Name | Description
CannotCutParallelToLocationCurve | Cut plane of slanted column end is parallel to the location curve.
SlantedColumnCannotCutEnd | Unable to trim slanted column end geometry to desired condition.
SlantedColumnCannotCutEndWarn | Unable to trim slanted column end geometry to desired condition.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SlantedColumnFailures Properties

The BuiltInFailuresSlantedColumnFailures type exposes the following members.

Properties
Name | Description
CannotCutParallelToLocationCurve | Cut plane of slanted column end is parallel to the location curve.
SlantedColumnCannotCutEnd | Unable to trim slanted column end geometry to desired condition.
SlantedColumnCannotCutEndWarn | Unable to trim slanted column end geometry to desired condition.
Top
See Also

Reference

BuiltInFailuresSlantedColumnFailures Class


BuiltInFailures.SlantedColumnFailures.CannotCutParallelToLocationCurve Property

BuiltInFailuresSlantedColumnFailuresCannotCutParallelToLocationCurve Property

Cut plane of slanted column end is parallel to the location curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCutParallelToLocationCurve { get; }
Public Shared ReadOnly Property CannotCutParallelToLocationCurve As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCutParallelToLocationCurve {
    FailureDefinitionId^ get ();
}
static member CannotCutParallelToLocationCurve : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSlantedColumnFailures Class


BuiltInFailures.SlantedColumnFailures.SlantedColumnCannotCutEnd Property

BuiltInFailuresSlantedColumnFailuresSlantedColumnCannotCutEnd Property

Unable to trim slanted column end geometry to desired condition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SlantedColumnCannotCutEnd { get; }
Public Shared ReadOnly Property SlantedColumnCannotCutEnd As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SlantedColumnCannotCutEnd {
    FailureDefinitionId^ get ();
}
static member SlantedColumnCannotCutEnd : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSlantedColumnFailures Class


BuiltInFailures.SlantedColumnFailures.SlantedColumnCannotCutEndWarn Property

BuiltInFailuresSlantedColumnFailuresSlantedColumnCannotCutEndWarn Property

Unable to trim slanted column end geometry to desired condition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SlantedColumnCannotCutEndWarn { get; }
Public Shared ReadOnly Property SlantedColumnCannotCutEndWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SlantedColumnCannotCutEndWarn {
    FailureDefinitionId^ get ();
}
static member SlantedColumnCannotCutEndWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSlantedColumnFailures Class


BuiltInFailures.SpanDirectionSymbolFailures Class

BuiltInFailuresSpanDirectionSymbolFailures Class

Failures about SpanDirectionSymbol.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresSpanDirectionSymbolFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class SpanDirectionSymbolFailures
Public NotInheritable Class SpanDirectionSymbolFailures
public ref class SpanDirectionSymbolFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SpanDirectionSymbolFailures = class end

The BuiltInFailuresSpanDirectionSymbolFailures type exposes the following members.

Properties
Name | Description
NonPlanView | Span Direction Symbol can only be placed in a Floor Plan View.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SpanDirectionSymbolFailures Properties

The BuiltInFailuresSpanDirectionSymbolFailures type exposes the following members.

Properties
Name | Description
NonPlanView | Span Direction Symbol can only be placed in a Floor Plan View.
Top
See Also

Reference

BuiltInFailuresSpanDirectionSymbolFailures Class


BuiltInFailures.SpanDirectionSymbolFailures.NonPlanView Property

BuiltInFailuresSpanDirectionSymbolFailuresNonPlanView Property

Span Direction Symbol can only be placed in a Floor Plan View.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NonPlanView { get; }
Public Shared ReadOnly Property NonPlanView As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NonPlanView {
    FailureDefinitionId^ get ();
}
static member NonPlanView : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSpanDirectionSymbolFailures Class


BuiltInFailures.SplineFailures Class

BuiltInFailuresSplineFailures Class

Failures about Spline.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresSplineFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class SplineFailures
Public NotInheritable Class SplineFailures
public ref class SplineFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SplineFailures = class end

The BuiltInFailuresSplineFailures type exposes the following members.

Properties
Name | Description
CannotCreateSpline | Can't make Spline.
ClosedSpline | Closed or self-intersecting splines are not allowed.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SplineFailures Properties

The BuiltInFailuresSplineFailures type exposes the following members.

Properties
Name | Description
CannotCreateSpline | Can't make Spline.
ClosedSpline | Closed or self-intersecting splines are not allowed.
Top
See Also

Reference

BuiltInFailuresSplineFailures Class


BuiltInFailures.SplineFailures.CannotCreateSpline Property

BuiltInFailuresSplineFailuresCannotCreateSpline Property

Can't make Spline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateSpline { get; }
Public Shared ReadOnly Property CannotCreateSpline As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateSpline {
    FailureDefinitionId^ get ();
}
static member CannotCreateSpline : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSplineFailures Class


BuiltInFailures.SplineFailures.ClosedSpline Property

BuiltInFailuresSplineFailuresClosedSpline Property

Closed or self-intersecting splines are not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ClosedSpline { get; }
Public Shared ReadOnly Property ClosedSpline As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ClosedSpline {
    FailureDefinitionId^ get ();
}
static member ClosedSpline : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSplineFailures Class


BuiltInFailures.SplitSketchBasedElementFailures Class

BuiltInFailuresSplitSketchBasedElementFailures Class

Failures related to the split sketched based element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresSplitSketchBasedElementFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class SplitSketchBasedElementFailures
Public NotInheritable Class SplitSketchBasedElementFailures
public ref class SplitSketchBasedElementFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SplitSketchBasedElementFailures = class end

The BuiltInFailuresSplitSketchBasedElementFailures type exposes the following members.

Properties
Name | Description
NotSplitValidRegions | The split failed. There may be a gap in the boundary loop or the sketch may be incomplete.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SplitSketchBasedElementFailures Properties

The BuiltInFailuresSplitSketchBasedElementFailures type exposes the following members.

Properties
Name | Description
NotSplitValidRegions | The split failed. There may be a gap in the boundary loop or the sketch may be incomplete.
Top
See Also

Reference

BuiltInFailuresSplitSketchBasedElementFailures Class


BuiltInFailures.SplitSketchBasedElementFailures.NotSplitValidRegions Property

BuiltInFailuresSplitSketchBasedElementFailuresNotSplitValidRegions Property

The split failed. There may be a gap in the boundary loop or the sketch may be incomplete.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotSplitValidRegions { get; }
Public Shared ReadOnly Property NotSplitValidRegions As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotSplitValidRegions {
    FailureDefinitionId^ get ();
}
static member NotSplitValidRegions : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSplitSketchBasedElementFailures Class


BuiltInFailures.SplitToposolidFailures Class

BuiltInFailuresSplitToposolidFailures Class

Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresSplitToposolidFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class SplitToposolidFailures
Public NotInheritable Class SplitToposolidFailures
public ref class SplitToposolidFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SplitToposolidFailures = class end

The BuiltInFailuresSplitToposolidFailures type exposes the following members.

Properties
Name | Description
GenerateNewSplitTopoFailed | Failed to generate new toposolid after split.
SplitToposolidFailed | Split toposolid failed.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SplitToposolidFailures Properties

The BuiltInFailuresSplitToposolidFailures type exposes the following members.

Properties
Name | Description
GenerateNewSplitTopoFailed | Failed to generate new toposolid after split.
SplitToposolidFailed | Split toposolid failed.
Top
See Also

Reference

BuiltInFailuresSplitToposolidFailures Class


BuiltInFailures.SplitToposolidFailures.GenerateNewSplitTopoFailed Property

BuiltInFailuresSplitToposolidFailuresGenerateNewSplitTopoFailed Property

Failed to generate new toposolid after split.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId GenerateNewSplitTopoFailed { get; }
Public Shared ReadOnly Property GenerateNewSplitTopoFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ GenerateNewSplitTopoFailed {
    FailureDefinitionId^ get ();
}
static member GenerateNewSplitTopoFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSplitToposolidFailures Class


BuiltInFailures.SplitToposolidFailures.SplitToposolidFailed Property

BuiltInFailuresSplitToposolidFailuresSplitToposolidFailed Property

Split toposolid failed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SplitToposolidFailed { get; }
Public Shared ReadOnly Property SplitToposolidFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SplitToposolidFailed {
    FailureDefinitionId^ get ();
}
static member SplitToposolidFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSplitToposolidFailures Class


BuiltInFailures.StairRampFailures Class

BuiltInFailuresStairRampFailures Class

Failures about StairRamp.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresStairRampFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class StairRampFailures
Public NotInheritable Class StairRampFailures
public ref class StairRampFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type StairRampFailures = class end

The BuiltInFailuresStairRampFailures type exposes the following members.

Properties
Name | Description
ActualRiserHeightChanged | The actual riser height for one or more stairs violates the maximum set in the type.
AntiparallelRampRisers | Riser lines are parallel but not collinear. Can't build Run between these Risers.
AntiparallelRampRisersError | Riser lines are parallel but not collinear. Can't build Run between these Risers.
ArcRunRadiusTooSmall | Can't create Run. Run radius is too small.
ArcRunWidthTooLongFailure | Arc run width is too long.
AutomaticLandingConvertedToSketchedLandingWarning | Some run(s) are deleted, so automatic landing is converted to sketched landing.
BadBalustersPerTread | Number of Balusters per Tread must be an integer greater than zero.
BadFillingSpacing | Spacing for Excess Length Fill is too small.
BadRailings | Can't create Railings.
BadRailingsError | Can't create Railings.
BadRailProfile | One or more Profile Loops are invalid, probably because of self-intersection.
BadTreadRiserProfile | Tread/Riser profile is invalid.
BalustersTooClose | Baluster Separation must be equal to or greater than the Baluster widths.
BalustersTooCloseAbsolute | Baluster Separation is too small.
BalusterUpsideDown | Top reference is below Bottom reference for one or more Balusters. These Balusters are not created.
CannotAlignSupportOnPosts | Cannot align the support on the posts.
CannotComputeRailElevation | Can't compute elevation profile for one or more Rails
CannotCreateBaluster | Can't create Balusters for given Width and Height.
CannotCreateBalusterPatterns | Can't create Baluster Patterns for Railings
CannotCreateCornerBalusters | Can't create corner Baluster
CannotCreateLandingStringer | Can't create stringer at landing.
CannotCreateMiddleStringer | Can't create one or more Middle Stringers.
CannotCreateMonolithicStairs | Can't make monolithic Stairs.
CannotCreateNosing | Can't create nosing on one or more treads.
CannotCreateOneOrMoreBaluster | Can't create one or more Balusters
CannotCreateOneOrMoreTreads | Can't create geometry for one or more treads.
CannotCreateOpenMiddleStringers | Can't cut open/middle stringers geometry.
CannotCreateRail | Can't create Railing. Thickness of Rail or Balusters might be too small. If you don't want Balusters, specify "None" for Baluster Shape.
CannotCreateRailGeom | Can't create geometry for one or more Rails
CannotCreateRailWarn | Can't create Railing. Thickness of Rail or Balusters might be too small. If you don't want Balusters, specify "None" for Baluster Shape.
CannotCreateRiser | Can't create geometry for one or more risers.
CannotCreateSideStringer | Can't create one or more Side Stringers.
CannotCreateStairForLevelOverlapping | Some of the multistory stairs couldn't be created due to the overlapped levels.
CannotCreateStringers | Can't create stringers geometry.
CannotDrawStairs | Can't make stairs
CannotDrawStairsError | Can't make stairs
CannotEndWithZeroRiser | Can't end Stairs with Riser because Riser Thickness is too small.
CannotGenerateFaces | Couldn't generate surfaces for stairs.
CannotGenerateFacesError | Couldn't generate surfaces for stairs.
CannotGenerateRamp | Couldn't generate surfaces for ramp.
CannotGenerateRampError | Couldn't generate surfaces for ramp.
CannotMakeLanding | Can't make landing.
CannotOffsetBoundary | Can't create Boundary as an offset of Run Curve
CannotOffsetRail | Can't create one or more Rails with desired offset
CannotPlaceBalusterOffset | Can't place Balusters and/or Rails with desired offset
CannotPlaceBalusterPatterns | Can't place Baluster Patterns
CannotPlaceRailingOnStringerWarning | Railing is placed on tread because there is no stringer.
CannotProcessInStairsSketchEditMode | Cannot process when stair(s) in sketch edit mode.
CannotSplitRailingWithExtensions | Railings with extensions cannot be split.
ContinuousRailFilletCreationError | Cannot create specified fillet at rail path corner.
ContinuousRailFilletCreationParallel | Cannot create specified fillet at rail path corner because of the curves are already smoothed.
ContinuousRailFilletCreationWarning | Cannot create specified fillet at rail path corner.
ContinuousRailGometryCreationFailure | Cannot create the continuous rail geometry.
ContinuousRailNotContinuous | The rail is non-continuous.
ContinuousRailSupportPlacementFailure | Cannot place the supports along the rail path.
ContinuousRailTransitionFailure | Cannot create specified transition at rail path turn, hand Rail/Top Rail cannot maintain continuous.
ExtendBelowBaseGreaterThanLandingBaseElevation | Extend Below Base needs to be less than Landing Base Elevation.
ExtendBelowBaseGreaterThanRunTopElevation | Extend Below Base needs to be less than Run Top Elevation.
FailToReOrientSketchCurvesFailure | Failed to orient sketch curves.
HeightOfRunIsTooSmall | Height of run is too small.
IntermediateLandingHigherThanTopRunFailure | Run is reversed.
InvalidBalustersPattern | Invalid Balusters Pattern
InvalidLocationLineJustificationFailure | Modify the location justification to a invalid value.
InvalidParameters | Stairs run or landing has invalid parameter(s).
InvalidRailProfile | Profiles for one or more of the Rails are invalid. Make sure that every used Profile is a closed series of non-intersecting Lines.
InvalidStairsPathFailure | Invalid stairs path provided.
InvalidStartLevel | The start level and end level for this staircase must be at different elevations.
InvalidStartLevelRamp | The start level and end level for this ramp must be at different elevations.
LandingDepthIsLessThanRunWidthWarning | Landing depth is less than run width.
LandingHeightUnderStairsBottom | Cannot make landing because height of landing is equal or less than to bottom height of the stair.
LandingShapeHandleOnPinnedRunFailure | Cannot Drag the automatic landing shape handle control because the connected run is pinned.
MayUnjoinRailAndSupports | Fillet may cause the supports unjoin with the rail.
MultistoryLevelBelowTopbottomLevel | Multistory top level must be above the stair/ramp top and bottom levels.
MultistoryLevelBelowTopbottomLevelError | Multistory top level must be above the stair/ramp top and bottom levels.
MultistoryStairDoesntReach | The multistory stair/ramp could not reach its top level with integral number of flights. Maximum number of flights below the top level is created.
MultistoryStairsAutomaticLevelLandingsDeleted | Level landings are deleted because the connected stairs have been regenerated.
MultistoryStairsComponentJoinFailure | Can't keep elements joined. Avoid converting stairs to skeched-based component in Multistory stairs.
MultistoryStairsHideTopLevelParameter | You have set the stair's multistory top level to None, and Revit will remove this parameter, if you want to create a multistory stair, please use Create Multistory Stair feature.
MultistoryStandardStairBottomEndExceedsOrNotReach | One of the stairs inside multistory stairs bottom ends exceeds or cannot reach the base elevation of the stair.
MultistoryStandardStairTopEndExceedsOrNotReach | One of the stairs inside multistory stairs top ends exceed or cannot reach the top elevation of the stair.
MultusegmentRampRiser | Ramp can't have multisegment Riser.
MultusegmentRampRiserError | Ramp can't have multisegment Riser.
NoCurvesInRailing | Railing Sketch has no Lines.
NoProfileForRail | Must specify Profiles for every Rail.
NoRailingsStringer | Railings and Stringers will not be automatically generated due to bad Runs. This message may be incorrect if you have Edited the Sketch and modified some dimensions.
NoRisersInPureMonolithicStairs | Monolithic Stairs with zero tread thickness can't have risers
NoRunsRamp | Ramp has no Runs. Can't create Ramp.
NoRunsRampError | Ramp has no Runs. Can't create Ramp.
NotALineRiserRamp | Riser line must be a straight line for Ramps.
NotALineRiserRampError | Riser line must be a straight line for Ramps.
NotchThicknessIsLargerThanLandingWarning | The notch thickness is larger than landing.
NotEnoughRisers | Actual Number of Risers is different from Desired Number of Risers. Add/remove Risers or change Desired Number of Risers in Stairs Properties.
OnlyMonolithicStairs | Tread thickness can't be zero for non-monolithic stairs
PartOfRiserLiesOnBoundaryFailure | Part of the riser lies on the boundary is not allowed.
PathDoesntJoinToBorderRisersFailure | Path doesn't join to border risers is not allowed.
RailCurveTooShort | Curve in rail sketch is too short for rail creation and ignored.
RailingBadOffset | An arc in the railing sketch has a radius that conflicts with the current rail widths and offsets. Please either increase the radius or modify rail profiles and offsets.
RailingCurvesNotSplitRamp | The slope of this railing will not parallel the ramp at landings. To get a parallel railing, split the railing sketch at the ends of landings.
RailingCurvesNotSplitStairs | The slope of this railing may not parallel the stairs at runs and landings. To get a parallel railing, split the railing sketch at the ends of landings.
RailingDoublyConnected | Railings hosted on Stairs must form a single, open, connected line.
RailingNotConnected | The Railing line must be a single connected Sketch. If you want separate pieces of Railing, create two or more separate Railings.
RailPathCloseLoopForExtensionWarning | The rail path is closed at the start and end path point for extension creation.
RailPlacedOutsideOfHost | Railings are placed completely outside the host. It may change the adjustment of the railing to the host and its vertical position.
RailProfileLowerThanFilletError | Fillet cannot be created between rail segment since the radius is lower than the profile size.
RailProfileLowerThanFilletFailure | Fillet cannot be created between rail segment since the radius is lower than the profile size.
RailProfileOpen | Open Profile Loop can't be used as a Rail Profile
RailTypeChangeInconsistancyWarningWithResetBtn | Some rail type changes are not consistent with your rail instances customization in this project, you can reset them to make them corresponding with your changes.
RampDoesntReach | The ramp is not long enough to reach the top constraint. Change the slope or increase the length of the ramp.
RampDoesntReachOffset | The ramp is not long enough to reach the top constraint plus top offset. Change the slope or increase the length of the ramp.
RampLandingNotCreated | Beginning of run coincide with the end of previous run. Landing is not created between runs.
RampRunTooComplex | Ramp Run has complex boundary and may produce unreasonable geometry. Split it into few Runs by inserting Riser Lines at the end of each Run and at the beginning of the next one. If you want to create Ramp with arc an straight section you can do it using a Run tool.
RampStartHigherThanEnd | The ramp's base (base level + base offset) must be below its top (top level + top offset).
RiserCurveTooShort | Riser curve is too short to create nosing on it.
RiserHeightIsTooSmall | Riser height is too small.
RiserIntWithBoundaryMoreThanOnceFailure | Riser intersects with boundary more than once.
RisersAtSameLocation | The highlighted risers have the same location along the boundary line. Please move one of the two risers.
RiserThicknesssResetToZero | Monolithic Stairs without Treads can't have Risers. Riser Thickness for Stairs Type was automatically set to zero.
RunBottomHigherThanTopFailure | The base elevation for the run is higher than the top elevation for the run.
RunBottomUnderStairsBottomFailure | Run bottom elevation should not be below the stairs bottom elevation.
RunIsJoiningLandingWithRiserSoNotchDoesNotWorkWarning | Run is joining landing with riser, so notch configuration does not take effect. Try to set run as begin/end with tread to make a notch.
RunTopLowerThanBottomFailure | The top elevation for the run is lower than the base elevation for the run.
SpiralRunRadiusTooSmallFailure | The radius value for the run is too small.
StairIncompleteFailure | Stair element is incomplete, not all components are logic connected.
StairsActualRiserHeightGreaterThanMaximumFailure | Computed actual riser height of stairs is greater than maximum riser height defined in stairs type.
StairsActualRunWidthLessThanMinimumFailure | Actual run width is less than minimum run width defined in stairs type.
StairsActualTreadDepthLessThanMinimumFailure | Computed actual tread depth of stairs is less than minimum tread depth defined in stairs type.
StairsAlreadyAttachedToCurrentLevel | Mutistory Stairs already have a Stair attaching to this level.
StairsAreUpdatedDueToLevelHeightChange | Stair component(s) in the multistory stair are updated due to the level height changes.
StairsAutomaticLandingLayoutFailure | Fail to generate the automatic landing layout
StairsAutomaticLandingLayoutWarn | Fail to generate the automatic landing layout
StairsBottomEndExceedsOrNotReachWarning | Stair bottom end exceeds or cannot reach the base elevation of the stair. Add/remove risers at the bottom end or change base elevation settings in Stair Properties.
StairsCannotExtendToFloorStructureLayerWarning | Stairs cannot extend to floor structure layer.
StairsCommonRunGenerateLayoutFailure | Fail to get base line thus fail to generate run layout
StairsComponentJoinFailure | Can't keep elements joined.
StairsCrossingRisersDisallowedFailure | Crossing risers are not allowed
StairsGenericFailure | Stairs generic failure
StairsGenericTransformFailure | Cannot change base elevation of Stairs
StairsIllegalDesiredNumRisers | Desired Number of Risers is too small. Computed Actual Riser Height is greater than Maximum Riser Height allowed by type.
StairsInMultistoryExceedTopConstraint | Stairs in MultistoryStairs after adjusting still exceed the top constraint.
StairsOnlySingleBoundaryHasRiserWithBothEndsOnBoundaryFailure | Only single boundary case may have riser with its both ends on boundary.
StairsOtherThan2IntsByRiserAndBoundaryFailure | More than 2 intersection points between riser segment and boundary encountered
StairsPathPositionResetWarning | The stairs path doesn't intersect with riser lines.
StairsRunRunJoinNotAllowedFailure | Run-Run join is not allowed of they have same "Start With Riser"/"End With Riser" configuration at the joined end.
StairsStartHigherThanEnd | The stairs' base (Base Level + Base Offset) must be below its top (Top Level + Top Offset).
StairsStringerCannotBeCreated | The stairs stringer cannot be created.
StairsSubElementsNotConnectedWarning | Stair sub-elements are not connected
StairsSupportOverlapFailure | Some supports overlap with others
StairsSupportTooShort | A short support is being created.
StairsTopEndExceedsOrNotReachWarning | Stair top end exceeds or cannot reach the top elevation of the stair. Add/remove risers at the top end or change top elevation settings in Stair Properties.
StairsTopLowerThanBaseFailure | The top of the Stair is lower than the base of the Stair
StairStringerCantOffset | Inside stringer could not be created because of insufficient space. Please disable the inside stringer or decrease its width.
StairsWinderGenLayoutFailure | Fail to generate run layout and then cannot make winder run
StairsWinderInvalidParamsFailure | Cannot create the winder run because some values for the instance properties cannot be satisfied.
StairsZeroDesiredRisers | The number of desired risers for a staircase cannot be 0.
StringerCurvesNotSplitStairs | The slope of stringer may not parallel runs and landings. To get a parallel stringer, split boundary lines at the ends of landings.
StringerCurveTooShort | A piece of boundary is too short to create stringer on it.
TooShortCurveDowngradeGeometry | Curve is too short and may downgrade the geometry.
TreadDepthBelowMin | The Actual Tread Depth for one or more Stairs violates the Minimum Depth set in the type.
TreadDepthFailsEq | The actual tread depth and riser height for one or more stairs of this type violates the stair equation.
TreadDepthTooBigFailure | The tread depth is too large for the spiral run.
TreadFrontProfileInvalid | This profile cannot be used for the front of treads. Please choose a profile composed of a closed loop of lines with exactly one lines coincident with the y-axis. This lines will define the connection of this profile to the tread.
UnableToCreateMultistoryStairs | Unable to create Multistory stairs.
UnexpectedCurveIntersectionFailure | Computing curve intersection and find the invalid result.
WinderFilletRadiusTooLargeFailure | The value for Fillet Radius is too large to satisfy the Minimum Inside Width value.
WinderFirstLegTooShortOrRunWidthTooGreatFailure | The first leg of winder run is too short or the runwidth is too great.
WinderGenericError | Cannot make winder.
WinderLegIsTooShortFailure | A winder leg is too short.
WinderLegsAngleTooGreatOrRunWidthTooSmallFailure | The angle between two consecutive legs are too great or the runwidth is too small.
WinderLegTooShortOrRunWidthTooGreatFailure | One leg of the winder run is too small or the runwidth is too great.
WinderMinWidthTooLargeFailure | The value for Minimum Width on Inside Boundary is too large.
WinderMinWidthTooLargeForParallelTreadsFailure | The value for Minimum Width on Inside Boundary is too large to satisfy the number of Parallel Treads at the Start or End as specified in the Run Instance properties.
WinderParallelLegsFailure | Two consecutive legs are parallel.
WinderParallelTreadsNumberFailure | Cannot satisfy the number of Parallel Treads at the Start or End as specified in the Run Instance properties
WinderRunCreationFailure | The relationship between the current values of Actual Run Width, Minimum Width at Inside Boundary, and Parallel Treads at Start or End does not support the creation of the winder run.
WinderRunInsideMinTreadDepthFailure | Please enter a positive value less than Actual Tread Depth on Stair Path (%Actual Tread Depth%).
WinderRunInsideWalklineOffsetFailure | Please enter a value between 0 and half of Actual Run Width (%1/2 Actual Run Width%).
WinderRunWidthLessThan2TimesMinWidthFailure | The value for Minimum Width on Inside Boundary is too large to satisfy the number of Parallel Treads at the Start or End as specified in the Run Instance properties.
WinderRunWidthLessThanWalkLineOffsetFailure | The value for Run Width is less than two times of value of the inside walkline offset.
WinderRunWidthOrMinWidthOrTooGreatParallelTreadsFailure | The parameter runwidth is great or the parameter min width at inside boundary is too great, or number of parallel treads at both ends is too great.
WinderRunWidthOrMinWidthOrTooShortFailure | The parameter runwidth is too great or the parameter min width at inside boundary is too great, or one leg of winder run is too short.
WinderSecondLegTooShortOrRunwidthTooGreatFailure | The second leg of winder run is too short or the runwidth is too great.
WinderStraightStepsNumberFailure | The current layout cannot allow the specified number of treads. Increase the length of the run leg in the model or reduce the value for Parallel Treads at Start or Parallel Treads at End.
WinderThirdLegTooShortOrRunWidthTooGreatFailure | The third leg of winder run is too short or the runwidth is too great.
WinderTooManyEndParallelTreadsOrRunWidthFailure | The number of parallel treads at end is too great or the run width is too great.
WinderTooManyParallelTreadsAtEndFailure | The number of parallel treads at end is too great.
WinderTooManyParallelTreadsAtHeadFailure | The number of parallel treads at start is too great.
WinderTooManyStartParallelTreadsOrRunWidthFailure | The number of parallel treads at start is too great or the run width is too great.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


StairRampFailures Properties

The BuiltInFailuresStairRampFailures type exposes the following members.

Properties
Name | Description
ActualRiserHeightChanged | The actual riser height for one or more stairs violates the maximum set in the type.
AntiparallelRampRisers | Riser lines are parallel but not collinear. Can't build Run between these Risers.
AntiparallelRampRisersError | Riser lines are parallel but not collinear. Can't build Run between these Risers.
ArcRunRadiusTooSmall | Can't create Run. Run radius is too small.
ArcRunWidthTooLongFailure | Arc run width is too long.
AutomaticLandingConvertedToSketchedLandingWarning | Some run(s) are deleted, so automatic landing is converted to sketched landing.
BadBalustersPerTread | Number of Balusters per Tread must be an integer greater than zero.
BadFillingSpacing | Spacing for Excess Length Fill is too small.
BadRailings | Can't create Railings.
BadRailingsError | Can't create Railings.
BadRailProfile | One or more Profile Loops are invalid, probably because of self-intersection.
BadTreadRiserProfile | Tread/Riser profile is invalid.
BalustersTooClose | Baluster Separation must be equal to or greater than the Baluster widths.
BalustersTooCloseAbsolute | Baluster Separation is too small.
BalusterUpsideDown | Top reference is below Bottom reference for one or more Balusters. These Balusters are not created.
CannotAlignSupportOnPosts | Cannot align the support on the posts.
CannotComputeRailElevation | Can't compute elevation profile for one or more Rails
CannotCreateBaluster | Can't create Balusters for given Width and Height.
CannotCreateBalusterPatterns | Can't create Baluster Patterns for Railings
CannotCreateCornerBalusters | Can't create corner Baluster
CannotCreateLandingStringer | Can't create stringer at landing.
CannotCreateMiddleStringer | Can't create one or more Middle Stringers.
CannotCreateMonolithicStairs | Can't make monolithic Stairs.
CannotCreateNosing | Can't create nosing on one or more treads.
CannotCreateOneOrMoreBaluster | Can't create one or more Balusters
CannotCreateOneOrMoreTreads | Can't create geometry for one or more treads.
CannotCreateOpenMiddleStringers | Can't cut open/middle stringers geometry.
CannotCreateRail | Can't create Railing. Thickness of Rail or Balusters might be too small. If you don't want Balusters, specify "None" for Baluster Shape.
CannotCreateRailGeom | Can't create geometry for one or more Rails
CannotCreateRailWarn | Can't create Railing. Thickness of Rail or Balusters might be too small. If you don't want Balusters, specify "None" for Baluster Shape.
CannotCreateRiser | Can't create geometry for one or more risers.
CannotCreateSideStringer | Can't create one or more Side Stringers.
CannotCreateStairForLevelOverlapping | Some of the multistory stairs couldn't be created due to the overlapped levels.
CannotCreateStringers | Can't create stringers geometry.
CannotDrawStairs | Can't make stairs
CannotDrawStairsError | Can't make stairs
CannotEndWithZeroRiser | Can't end Stairs with Riser because Riser Thickness is too small.
CannotGenerateFaces | Couldn't generate surfaces for stairs.
CannotGenerateFacesError | Couldn't generate surfaces for stairs.
CannotGenerateRamp | Couldn't generate surfaces for ramp.
CannotGenerateRampError | Couldn't generate surfaces for ramp.
CannotMakeLanding | Can't make landing.
CannotOffsetBoundary | Can't create Boundary as an offset of Run Curve
CannotOffsetRail | Can't create one or more Rails with desired offset
CannotPlaceBalusterOffset | Can't place Balusters and/or Rails with desired offset
CannotPlaceBalusterPatterns | Can't place Baluster Patterns
CannotPlaceRailingOnStringerWarning | Railing is placed on tread because there is no stringer.
CannotProcessInStairsSketchEditMode | Cannot process when stair(s) in sketch edit mode.
CannotSplitRailingWithExtensions | Railings with extensions cannot be split.
ContinuousRailFilletCreationError | Cannot create specified fillet at rail path corner.
ContinuousRailFilletCreationParallel | Cannot create specified fillet at rail path corner because of the curves are already smoothed.
ContinuousRailFilletCreationWarning | Cannot create specified fillet at rail path corner.
ContinuousRailGometryCreationFailure | Cannot create the continuous rail geometry.
ContinuousRailNotContinuous | The rail is non-continuous.
ContinuousRailSupportPlacementFailure | Cannot place the supports along the rail path.
ContinuousRailTransitionFailure | Cannot create specified transition at rail path turn, hand Rail/Top Rail cannot maintain continuous.
ExtendBelowBaseGreaterThanLandingBaseElevation | Extend Below Base needs to be less than Landing Base Elevation.
ExtendBelowBaseGreaterThanRunTopElevation | Extend Below Base needs to be less than Run Top Elevation.
FailToReOrientSketchCurvesFailure | Failed to orient sketch curves.
HeightOfRunIsTooSmall | Height of run is too small.
IntermediateLandingHigherThanTopRunFailure | Run is reversed.
InvalidBalustersPattern | Invalid Balusters Pattern
InvalidLocationLineJustificationFailure | Modify the location justification to a invalid value.
InvalidParameters | Stairs run or landing has invalid parameter(s).
InvalidRailProfile | Profiles for one or more of the Rails are invalid. Make sure that every used Profile is a closed series of non-intersecting Lines.
InvalidStairsPathFailure | Invalid stairs path provided.
InvalidStartLevel | The start level and end level for this staircase must be at different elevations.
InvalidStartLevelRamp | The start level and end level for this ramp must be at different elevations.
LandingDepthIsLessThanRunWidthWarning | Landing depth is less than run width.
LandingHeightUnderStairsBottom | Cannot make landing because height of landing is equal or less than to bottom height of the stair.
LandingShapeHandleOnPinnedRunFailure | Cannot Drag the automatic landing shape handle control because the connected run is pinned.
MayUnjoinRailAndSupports | Fillet may cause the supports unjoin with the rail.
MultistoryLevelBelowTopbottomLevel | Multistory top level must be above the stair/ramp top and bottom levels.
MultistoryLevelBelowTopbottomLevelError | Multistory top level must be above the stair/ramp top and bottom levels.
MultistoryStairDoesntReach | The multistory stair/ramp could not reach its top level with integral number of flights. Maximum number of flights below the top level is created.
MultistoryStairsAutomaticLevelLandingsDeleted | Level landings are deleted because the connected stairs have been regenerated.
MultistoryStairsComponentJoinFailure | Can't keep elements joined. Avoid converting stairs to skeched-based component in Multistory stairs.
MultistoryStairsHideTopLevelParameter | You have set the stair's multistory top level to None, and Revit will remove this parameter, if you want to create a multistory stair, please use Create Multistory Stair feature.
MultistoryStandardStairBottomEndExceedsOrNotReach | One of the stairs inside multistory stairs bottom ends exceeds or cannot reach the base elevation of the stair.
MultistoryStandardStairTopEndExceedsOrNotReach | One of the stairs inside multistory stairs top ends exceed or cannot reach the top elevation of the stair.
MultusegmentRampRiser | Ramp can't have multisegment Riser.
MultusegmentRampRiserError | Ramp can't have multisegment Riser.
NoCurvesInRailing | Railing Sketch has no Lines.
NoProfileForRail | Must specify Profiles for every Rail.
NoRailingsStringer | Railings and Stringers will not be automatically generated due to bad Runs. This message may be incorrect if you have Edited the Sketch and modified some dimensions.
NoRisersInPureMonolithicStairs | Monolithic Stairs with zero tread thickness can't have risers
NoRunsRamp | Ramp has no Runs. Can't create Ramp.
NoRunsRampError | Ramp has no Runs. Can't create Ramp.
NotALineRiserRamp | Riser line must be a straight line for Ramps.
NotALineRiserRampError | Riser line must be a straight line for Ramps.
NotchThicknessIsLargerThanLandingWarning | The notch thickness is larger than landing.
NotEnoughRisers | Actual Number of Risers is different from Desired Number of Risers. Add/remove Risers or change Desired Number of Risers in Stairs Properties.
OnlyMonolithicStairs | Tread thickness can't be zero for non-monolithic stairs
PartOfRiserLiesOnBoundaryFailure | Part of the riser lies on the boundary is not allowed.
PathDoesntJoinToBorderRisersFailure | Path doesn't join to border risers is not allowed.
RailCurveTooShort | Curve in rail sketch is too short for rail creation and ignored.
RailingBadOffset | An arc in the railing sketch has a radius that conflicts with the current rail widths and offsets. Please either increase the radius or modify rail profiles and offsets.
RailingCurvesNotSplitRamp | The slope of this railing will not parallel the ramp at landings. To get a parallel railing, split the railing sketch at the ends of landings.
RailingCurvesNotSplitStairs | The slope of this railing may not parallel the stairs at runs and landings. To get a parallel railing, split the railing sketch at the ends of landings.
RailingDoublyConnected | Railings hosted on Stairs must form a single, open, connected line.
RailingNotConnected | The Railing line must be a single connected Sketch. If you want separate pieces of Railing, create two or more separate Railings.
RailPathCloseLoopForExtensionWarning | The rail path is closed at the start and end path point for extension creation.
RailPlacedOutsideOfHost | Railings are placed completely outside the host. It may change the adjustment of the railing to the host and its vertical position.
RailProfileLowerThanFilletError | Fillet cannot be created between rail segment since the radius is lower than the profile size.
RailProfileLowerThanFilletFailure | Fillet cannot be created between rail segment since the radius is lower than the profile size.
RailProfileOpen | Open Profile Loop can't be used as a Rail Profile
RailTypeChangeInconsistancyWarningWithResetBtn | Some rail type changes are not consistent with your rail instances customization in this project, you can reset them to make them corresponding with your changes.
RampDoesntReach | The ramp is not long enough to reach the top constraint. Change the slope or increase the length of the ramp.
RampDoesntReachOffset | The ramp is not long enough to reach the top constraint plus top offset. Change the slope or increase the length of the ramp.
RampLandingNotCreated | Beginning of run coincide with the end of previous run. Landing is not created between runs.
RampRunTooComplex | Ramp Run has complex boundary and may produce unreasonable geometry. Split it into few Runs by inserting Riser Lines at the end of each Run and at the beginning of the next one. If you want to create Ramp with arc an straight section you can do it using a Run tool.
RampStartHigherThanEnd | The ramp's base (base level + base offset) must be below its top (top level + top offset).
RiserCurveTooShort | Riser curve is too short to create nosing on it.
RiserHeightIsTooSmall | Riser height is too small.
RiserIntWithBoundaryMoreThanOnceFailure | Riser intersects with boundary more than once.
RisersAtSameLocation | The highlighted risers have the same location along the boundary line. Please move one of the two risers.
RiserThicknesssResetToZero | Monolithic Stairs without Treads can't have Risers. Riser Thickness for Stairs Type was automatically set to zero.
RunBottomHigherThanTopFailure | The base elevation for the run is higher than the top elevation for the run.
RunBottomUnderStairsBottomFailure | Run bottom elevation should not be below the stairs bottom elevation.
RunIsJoiningLandingWithRiserSoNotchDoesNotWorkWarning | Run is joining landing with riser, so notch configuration does not take effect. Try to set run as begin/end with tread to make a notch.
RunTopLowerThanBottomFailure | The top elevation for the run is lower than the base elevation for the run.
SpiralRunRadiusTooSmallFailure | The radius value for the run is too small.
StairIncompleteFailure | Stair element is incomplete, not all components are logic connected.
StairsActualRiserHeightGreaterThanMaximumFailure | Computed actual riser height of stairs is greater than maximum riser height defined in stairs type.
StairsActualRunWidthLessThanMinimumFailure | Actual run width is less than minimum run width defined in stairs type.
StairsActualTreadDepthLessThanMinimumFailure | Computed actual tread depth of stairs is less than minimum tread depth defined in stairs type.
StairsAlreadyAttachedToCurrentLevel | Mutistory Stairs already have a Stair attaching to this level.
StairsAreUpdatedDueToLevelHeightChange | Stair component(s) in the multistory stair are updated due to the level height changes.
StairsAutomaticLandingLayoutFailure | Fail to generate the automatic landing layout
StairsAutomaticLandingLayoutWarn | Fail to generate the automatic landing layout
StairsBottomEndExceedsOrNotReachWarning | Stair bottom end exceeds or cannot reach the base elevation of the stair. Add/remove risers at the bottom end or change base elevation settings in Stair Properties.
StairsCannotExtendToFloorStructureLayerWarning | Stairs cannot extend to floor structure layer.
StairsCommonRunGenerateLayoutFailure | Fail to get base line thus fail to generate run layout
StairsComponentJoinFailure | Can't keep elements joined.
StairsCrossingRisersDisallowedFailure | Crossing risers are not allowed
StairsGenericFailure | Stairs generic failure
StairsGenericTransformFailure | Cannot change base elevation of Stairs
StairsIllegalDesiredNumRisers | Desired Number of Risers is too small. Computed Actual Riser Height is greater than Maximum Riser Height allowed by type.
StairsInMultistoryExceedTopConstraint | Stairs in MultistoryStairs after adjusting still exceed the top constraint.
StairsOnlySingleBoundaryHasRiserWithBothEndsOnBoundaryFailure | Only single boundary case may have riser with its both ends on boundary.
StairsOtherThan2IntsByRiserAndBoundaryFailure | More than 2 intersection points between riser segment and boundary encountered
StairsPathPositionResetWarning | The stairs path doesn't intersect with riser lines.
StairsRunRunJoinNotAllowedFailure | Run-Run join is not allowed of they have same "Start With Riser"/"End With Riser" configuration at the joined end.
StairsStartHigherThanEnd | The stairs' base (Base Level + Base Offset) must be below its top (Top Level + Top Offset).
StairsStringerCannotBeCreated | The stairs stringer cannot be created.
StairsSubElementsNotConnectedWarning | Stair sub-elements are not connected
StairsSupportOverlapFailure | Some supports overlap with others
StairsSupportTooShort | A short support is being created.
StairsTopEndExceedsOrNotReachWarning | Stair top end exceeds or cannot reach the top elevation of the stair. Add/remove risers at the top end or change top elevation settings in Stair Properties.
StairsTopLowerThanBaseFailure | The top of the Stair is lower than the base of the Stair
StairStringerCantOffset | Inside stringer could not be created because of insufficient space. Please disable the inside stringer or decrease its width.
StairsWinderGenLayoutFailure | Fail to generate run layout and then cannot make winder run
StairsWinderInvalidParamsFailure | Cannot create the winder run because some values for the instance properties cannot be satisfied.
StairsZeroDesiredRisers | The number of desired risers for a staircase cannot be 0.
StringerCurvesNotSplitStairs | The slope of stringer may not parallel runs and landings. To get a parallel stringer, split boundary lines at the ends of landings.
StringerCurveTooShort | A piece of boundary is too short to create stringer on it.
TooShortCurveDowngradeGeometry | Curve is too short and may downgrade the geometry.
TreadDepthBelowMin | The Actual Tread Depth for one or more Stairs violates the Minimum Depth set in the type.
TreadDepthFailsEq | The actual tread depth and riser height for one or more stairs of this type violates the stair equation.
TreadDepthTooBigFailure | The tread depth is too large for the spiral run.
TreadFrontProfileInvalid | This profile cannot be used for the front of treads. Please choose a profile composed of a closed loop of lines with exactly one lines coincident with the y-axis. This lines will define the connection of this profile to the tread.
UnableToCreateMultistoryStairs | Unable to create Multistory stairs.
UnexpectedCurveIntersectionFailure | Computing curve intersection and find the invalid result.
WinderFilletRadiusTooLargeFailure | The value for Fillet Radius is too large to satisfy the Minimum Inside Width value.
WinderFirstLegTooShortOrRunWidthTooGreatFailure | The first leg of winder run is too short or the runwidth is too great.
WinderGenericError | Cannot make winder.
WinderLegIsTooShortFailure | A winder leg is too short.
WinderLegsAngleTooGreatOrRunWidthTooSmallFailure | The angle between two consecutive legs are too great or the runwidth is too small.
WinderLegTooShortOrRunWidthTooGreatFailure | One leg of the winder run is too small or the runwidth is too great.
WinderMinWidthTooLargeFailure | The value for Minimum Width on Inside Boundary is too large.
WinderMinWidthTooLargeForParallelTreadsFailure | The value for Minimum Width on Inside Boundary is too large to satisfy the number of Parallel Treads at the Start or End as specified in the Run Instance properties.
WinderParallelLegsFailure | Two consecutive legs are parallel.
WinderParallelTreadsNumberFailure | Cannot satisfy the number of Parallel Treads at the Start or End as specified in the Run Instance properties
WinderRunCreationFailure | The relationship between the current values of Actual Run Width, Minimum Width at Inside Boundary, and Parallel Treads at Start or End does not support the creation of the winder run.
WinderRunInsideMinTreadDepthFailure | Please enter a positive value less than Actual Tread Depth on Stair Path (%Actual Tread Depth%).
WinderRunInsideWalklineOffsetFailure | Please enter a value between 0 and half of Actual Run Width (%1/2 Actual Run Width%).
WinderRunWidthLessThan2TimesMinWidthFailure | The value for Minimum Width on Inside Boundary is too large to satisfy the number of Parallel Treads at the Start or End as specified in the Run Instance properties.
WinderRunWidthLessThanWalkLineOffsetFailure | The value for Run Width is less than two times of value of the inside walkline offset.
WinderRunWidthOrMinWidthOrTooGreatParallelTreadsFailure | The parameter runwidth is great or the parameter min width at inside boundary is too great, or number of parallel treads at both ends is too great.
WinderRunWidthOrMinWidthOrTooShortFailure | The parameter runwidth is too great or the parameter min width at inside boundary is too great, or one leg of winder run is too short.
WinderSecondLegTooShortOrRunwidthTooGreatFailure | The second leg of winder run is too short or the runwidth is too great.
WinderStraightStepsNumberFailure | The current layout cannot allow the specified number of treads. Increase the length of the run leg in the model or reduce the value for Parallel Treads at Start or Parallel Treads at End.
WinderThirdLegTooShortOrRunWidthTooGreatFailure | The third leg of winder run is too short or the runwidth is too great.
WinderTooManyEndParallelTreadsOrRunWidthFailure | The number of parallel treads at end is too great or the run width is too great.
WinderTooManyParallelTreadsAtEndFailure | The number of parallel treads at end is too great.
WinderTooManyParallelTreadsAtHeadFailure | The number of parallel treads at start is too great.
WinderTooManyStartParallelTreadsOrRunWidthFailure | The number of parallel treads at start is too great or the run width is too great.
Top
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.ActualRiserHeightChanged Property

BuiltInFailuresStairRampFailuresActualRiserHeightChanged Property

The actual riser height for one or more stairs violates the maximum set in the type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ActualRiserHeightChanged { get; }
Public Shared ReadOnly Property ActualRiserHeightChanged As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ActualRiserHeightChanged {
    FailureDefinitionId^ get ();
}
static member ActualRiserHeightChanged : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.AntiparallelRampRisers Property

BuiltInFailuresStairRampFailuresAntiparallelRampRisers Property

Riser lines are parallel but not collinear. Can't build Run between these Risers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AntiparallelRampRisers { get; }
Public Shared ReadOnly Property AntiparallelRampRisers As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AntiparallelRampRisers {
    FailureDefinitionId^ get ();
}
static member AntiparallelRampRisers : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.AntiparallelRampRisersError Property

BuiltInFailuresStairRampFailuresAntiparallelRampRisersError Property

Riser lines are parallel but not collinear. Can't build Run between these Risers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AntiparallelRampRisersError { get; }
Public Shared ReadOnly Property AntiparallelRampRisersError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AntiparallelRampRisersError {
    FailureDefinitionId^ get ();
}
static member AntiparallelRampRisersError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.ArcRunRadiusTooSmall Property

BuiltInFailuresStairRampFailuresArcRunRadiusTooSmall Property

Can't create Run. Run radius is too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ArcRunRadiusTooSmall { get; }
Public Shared ReadOnly Property ArcRunRadiusTooSmall As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ArcRunRadiusTooSmall {
    FailureDefinitionId^ get ();
}
static member ArcRunRadiusTooSmall : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.ArcRunWidthTooLongFailure Property

BuiltInFailuresStairRampFailuresArcRunWidthTooLongFailure Property

Arc run width is too long.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ArcRunWidthTooLongFailure { get; }
Public Shared ReadOnly Property ArcRunWidthTooLongFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ArcRunWidthTooLongFailure {
    FailureDefinitionId^ get ();
}
static member ArcRunWidthTooLongFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.AutomaticLandingConvertedToSketchedLandingWarning Property

BuiltInFailuresStairRampFailuresAutomaticLandingConvertedToSketchedLandingWarning Property

Some run(s) are deleted, so automatic landing is converted to sketched landing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AutomaticLandingConvertedToSketchedLandingWarning { get; }
Public Shared ReadOnly Property AutomaticLandingConvertedToSketchedLandingWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AutomaticLandingConvertedToSketchedLandingWarning {
    FailureDefinitionId^ get ();
}
static member AutomaticLandingConvertedToSketchedLandingWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.BadBalustersPerTread Property

BuiltInFailuresStairRampFailuresBadBalustersPerTread Property

Number of Balusters per Tread must be an integer greater than zero.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BadBalustersPerTread { get; }
Public Shared ReadOnly Property BadBalustersPerTread As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BadBalustersPerTread {
    FailureDefinitionId^ get ();
}
static member BadBalustersPerTread : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.BadFillingSpacing Property

BuiltInFailuresStairRampFailuresBadFillingSpacing Property

Spacing for Excess Length Fill is too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BadFillingSpacing { get; }
Public Shared ReadOnly Property BadFillingSpacing As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BadFillingSpacing {
    FailureDefinitionId^ get ();
}
static member BadFillingSpacing : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.BadRailings Property

BuiltInFailuresStairRampFailuresBadRailings Property

Can't create Railings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BadRailings { get; }
Public Shared ReadOnly Property BadRailings As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BadRailings {
    FailureDefinitionId^ get ();
}
static member BadRailings : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.BadRailingsError Property

BuiltInFailuresStairRampFailuresBadRailingsError Property

Can't create Railings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BadRailingsError { get; }
Public Shared ReadOnly Property BadRailingsError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BadRailingsError {
    FailureDefinitionId^ get ();
}
static member BadRailingsError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.BadRailProfile Property

BuiltInFailuresStairRampFailuresBadRailProfile Property

One or more Profile Loops are invalid, probably because of self-intersection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BadRailProfile { get; }
Public Shared ReadOnly Property BadRailProfile As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BadRailProfile {
    FailureDefinitionId^ get ();
}
static member BadRailProfile : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.BadTreadRiserProfile Property

BuiltInFailuresStairRampFailuresBadTreadRiserProfile Property

Tread/Riser profile is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BadTreadRiserProfile { get; }
Public Shared ReadOnly Property BadTreadRiserProfile As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BadTreadRiserProfile {
    FailureDefinitionId^ get ();
}
static member BadTreadRiserProfile : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.BalustersTooClose Property

BuiltInFailuresStairRampFailuresBalustersTooClose Property

Baluster Separation must be equal to or greater than the Baluster widths.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BalustersTooClose { get; }
Public Shared ReadOnly Property BalustersTooClose As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BalustersTooClose {
    FailureDefinitionId^ get ();
}
static member BalustersTooClose : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.BalustersTooCloseAbsolute Property

BuiltInFailuresStairRampFailuresBalustersTooCloseAbsolute Property

Baluster Separation is too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BalustersTooCloseAbsolute { get; }
Public Shared ReadOnly Property BalustersTooCloseAbsolute As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BalustersTooCloseAbsolute {
    FailureDefinitionId^ get ();
}
static member BalustersTooCloseAbsolute : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.BalusterUpsideDown Property

BuiltInFailuresStairRampFailuresBalusterUpsideDown Property

Top reference is below Bottom reference for one or more Balusters. These Balusters are not created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BalusterUpsideDown { get; }
Public Shared ReadOnly Property BalusterUpsideDown As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BalusterUpsideDown {
    FailureDefinitionId^ get ();
}
static member BalusterUpsideDown : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.CannotAlignSupportOnPosts Property

BuiltInFailuresStairRampFailuresCannotAlignSupportOnPosts Property

Cannot align the support on the posts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotAlignSupportOnPosts { get; }
Public Shared ReadOnly Property CannotAlignSupportOnPosts As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotAlignSupportOnPosts {
    FailureDefinitionId^ get ();
}
static member CannotAlignSupportOnPosts : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.CannotComputeRailElevation Property

BuiltInFailuresStairRampFailuresCannotComputeRailElevation Property

Can't compute elevation profile for one or more Rails

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotComputeRailElevation { get; }
Public Shared ReadOnly Property CannotComputeRailElevation As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotComputeRailElevation {
    FailureDefinitionId^ get ();
}
static member CannotComputeRailElevation : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.CannotCreateBaluster Property

BuiltInFailuresStairRampFailuresCannotCreateBaluster Property

Can't create Balusters for given Width and Height.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateBaluster { get; }
Public Shared ReadOnly Property CannotCreateBaluster As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateBaluster {
    FailureDefinitionId^ get ();
}
static member CannotCreateBaluster : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.CannotCreateBalusterPatterns Property

BuiltInFailuresStairRampFailuresCannotCreateBalusterPatterns Property

Can't create Baluster Patterns for Railings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateBalusterPatterns { get; }
Public Shared ReadOnly Property CannotCreateBalusterPatterns As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateBalusterPatterns {
    FailureDefinitionId^ get ();
}
static member CannotCreateBalusterPatterns : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.CannotCreateCornerBalusters Property

BuiltInFailuresStairRampFailuresCannotCreateCornerBalusters Property

Can't create corner Baluster

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateCornerBalusters { get; }
Public Shared ReadOnly Property CannotCreateCornerBalusters As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateCornerBalusters {
    FailureDefinitionId^ get ();
}
static member CannotCreateCornerBalusters : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.CannotCreateLandingStringer Property

BuiltInFailuresStairRampFailuresCannotCreateLandingStringer Property

Can't create stringer at landing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateLandingStringer { get; }
Public Shared ReadOnly Property CannotCreateLandingStringer As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateLandingStringer {
    FailureDefinitionId^ get ();
}
static member CannotCreateLandingStringer : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.CannotCreateMiddleStringer Property

BuiltInFailuresStairRampFailuresCannotCreateMiddleStringer Property

Can't create one or more Middle Stringers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateMiddleStringer { get; }
Public Shared ReadOnly Property CannotCreateMiddleStringer As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateMiddleStringer {
    FailureDefinitionId^ get ();
}
static member CannotCreateMiddleStringer : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.CannotCreateMonolithicStairs Property

BuiltInFailuresStairRampFailuresCannotCreateMonolithicStairs Property

Can't make monolithic Stairs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateMonolithicStairs { get; }
Public Shared ReadOnly Property CannotCreateMonolithicStairs As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateMonolithicStairs {
    FailureDefinitionId^ get ();
}
static member CannotCreateMonolithicStairs : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.CannotCreateNosing Property

BuiltInFailuresStairRampFailuresCannotCreateNosing Property

Can't create nosing on one or more treads.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateNosing { get; }
Public Shared ReadOnly Property CannotCreateNosing As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateNosing {
    FailureDefinitionId^ get ();
}
static member CannotCreateNosing : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.CannotCreateOneOrMoreBaluster Property

BuiltInFailuresStairRampFailuresCannotCreateOneOrMoreBaluster Property

Can't create one or more Balusters

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateOneOrMoreBaluster { get; }
Public Shared ReadOnly Property CannotCreateOneOrMoreBaluster As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateOneOrMoreBaluster {
    FailureDefinitionId^ get ();
}
static member CannotCreateOneOrMoreBaluster : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.CannotCreateOneOrMoreTreads Property

BuiltInFailuresStairRampFailuresCannotCreateOneOrMoreTreads Property

Can't create geometry for one or more treads.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateOneOrMoreTreads { get; }
Public Shared ReadOnly Property CannotCreateOneOrMoreTreads As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateOneOrMoreTreads {
    FailureDefinitionId^ get ();
}
static member CannotCreateOneOrMoreTreads : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.CannotCreateOpenMiddleStringers Property

BuiltInFailuresStairRampFailuresCannotCreateOpenMiddleStringers Property

Can't cut open/middle stringers geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateOpenMiddleStringers { get; }
Public Shared ReadOnly Property CannotCreateOpenMiddleStringers As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateOpenMiddleStringers {
    FailureDefinitionId^ get ();
}
static member CannotCreateOpenMiddleStringers : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.CannotCreateRail Property

BuiltInFailuresStairRampFailuresCannotCreateRail Property

Can't create Railing. Thickness of Rail or Balusters might be too small. If you don't want Balusters, specify "None" for Baluster Shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateRail { get; }
Public Shared ReadOnly Property CannotCreateRail As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateRail {
    FailureDefinitionId^ get ();
}
static member CannotCreateRail : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.CannotCreateRailGeom Property

BuiltInFailuresStairRampFailuresCannotCreateRailGeom Property

Can't create geometry for one or more Rails

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateRailGeom { get; }
Public Shared ReadOnly Property CannotCreateRailGeom As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateRailGeom {
    FailureDefinitionId^ get ();
}
static member CannotCreateRailGeom : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.CannotCreateRailWarn Property

BuiltInFailuresStairRampFailuresCannotCreateRailWarn Property

Can't create Railing. Thickness of Rail or Balusters might be too small. If you don't want Balusters, specify "None" for Baluster Shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateRailWarn { get; }
Public Shared ReadOnly Property CannotCreateRailWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateRailWarn {
    FailureDefinitionId^ get ();
}
static member CannotCreateRailWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.CannotCreateRiser Property

BuiltInFailuresStairRampFailuresCannotCreateRiser Property

Can't create geometry for one or more risers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateRiser { get; }
Public Shared ReadOnly Property CannotCreateRiser As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateRiser {
    FailureDefinitionId^ get ();
}
static member CannotCreateRiser : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.CannotCreateSideStringer Property

BuiltInFailuresStairRampFailuresCannotCreateSideStringer Property

Can't create one or more Side Stringers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateSideStringer { get; }
Public Shared ReadOnly Property CannotCreateSideStringer As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateSideStringer {
    FailureDefinitionId^ get ();
}
static member CannotCreateSideStringer : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.CannotCreateStairForLevelOverlapping Property

BuiltInFailuresStairRampFailuresCannotCreateStairForLevelOverlapping Property

Some of the multistory stairs couldn't be created due to the overlapped levels.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateStairForLevelOverlapping { get; }
Public Shared ReadOnly Property CannotCreateStairForLevelOverlapping As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateStairForLevelOverlapping {
    FailureDefinitionId^ get ();
}
static member CannotCreateStairForLevelOverlapping : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.CannotCreateStringers Property

BuiltInFailuresStairRampFailuresCannotCreateStringers Property

Can't create stringers geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateStringers { get; }
Public Shared ReadOnly Property CannotCreateStringers As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateStringers {
    FailureDefinitionId^ get ();
}
static member CannotCreateStringers : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.CannotDrawStairs Property

BuiltInFailuresStairRampFailuresCannotDrawStairs Property

Can't make stairs

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotDrawStairs { get; }
Public Shared ReadOnly Property CannotDrawStairs As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotDrawStairs {
    FailureDefinitionId^ get ();
}
static member CannotDrawStairs : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.CannotDrawStairsError Property

BuiltInFailuresStairRampFailuresCannotDrawStairsError Property

Can't make stairs

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotDrawStairsError { get; }
Public Shared ReadOnly Property CannotDrawStairsError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotDrawStairsError {
    FailureDefinitionId^ get ();
}
static member CannotDrawStairsError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.CannotEndWithZeroRiser Property

BuiltInFailuresStairRampFailuresCannotEndWithZeroRiser Property

Can't end Stairs with Riser because Riser Thickness is too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotEndWithZeroRiser { get; }
Public Shared ReadOnly Property CannotEndWithZeroRiser As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotEndWithZeroRiser {
    FailureDefinitionId^ get ();
}
static member CannotEndWithZeroRiser : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.CannotGenerateFaces Property

BuiltInFailuresStairRampFailuresCannotGenerateFaces Property

Couldn't generate surfaces for stairs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotGenerateFaces { get; }
Public Shared ReadOnly Property CannotGenerateFaces As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotGenerateFaces {
    FailureDefinitionId^ get ();
}
static member CannotGenerateFaces : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.CannotGenerateFacesError Property

BuiltInFailuresStairRampFailuresCannotGenerateFacesError Property

Couldn't generate surfaces for stairs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotGenerateFacesError { get; }
Public Shared ReadOnly Property CannotGenerateFacesError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotGenerateFacesError {
    FailureDefinitionId^ get ();
}
static member CannotGenerateFacesError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.CannotGenerateRamp Property

BuiltInFailuresStairRampFailuresCannotGenerateRamp Property

Couldn't generate surfaces for ramp.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotGenerateRamp { get; }
Public Shared ReadOnly Property CannotGenerateRamp As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotGenerateRamp {
    FailureDefinitionId^ get ();
}
static member CannotGenerateRamp : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.CannotGenerateRampError Property

BuiltInFailuresStairRampFailuresCannotGenerateRampError Property

Couldn't generate surfaces for ramp.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotGenerateRampError { get; }
Public Shared ReadOnly Property CannotGenerateRampError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotGenerateRampError {
    FailureDefinitionId^ get ();
}
static member CannotGenerateRampError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.CannotMakeLanding Property

BuiltInFailuresStairRampFailuresCannotMakeLanding Property

Can't make landing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotMakeLanding { get; }
Public Shared ReadOnly Property CannotMakeLanding As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotMakeLanding {
    FailureDefinitionId^ get ();
}
static member CannotMakeLanding : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.CannotOffsetBoundary Property

BuiltInFailuresStairRampFailuresCannotOffsetBoundary Property

Can't create Boundary as an offset of Run Curve

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotOffsetBoundary { get; }
Public Shared ReadOnly Property CannotOffsetBoundary As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotOffsetBoundary {
    FailureDefinitionId^ get ();
}
static member CannotOffsetBoundary : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.CannotOffsetRail Property

BuiltInFailuresStairRampFailuresCannotOffsetRail Property

Can't create one or more Rails with desired offset

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotOffsetRail { get; }
Public Shared ReadOnly Property CannotOffsetRail As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotOffsetRail {
    FailureDefinitionId^ get ();
}
static member CannotOffsetRail : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.CannotPlaceBalusterOffset Property

BuiltInFailuresStairRampFailuresCannotPlaceBalusterOffset Property

Can't place Balusters and/or Rails with desired offset

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPlaceBalusterOffset { get; }
Public Shared ReadOnly Property CannotPlaceBalusterOffset As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPlaceBalusterOffset {
    FailureDefinitionId^ get ();
}
static member CannotPlaceBalusterOffset : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.CannotPlaceBalusterPatterns Property

BuiltInFailuresStairRampFailuresCannotPlaceBalusterPatterns Property

Can't place Baluster Patterns

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPlaceBalusterPatterns { get; }
Public Shared ReadOnly Property CannotPlaceBalusterPatterns As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPlaceBalusterPatterns {
    FailureDefinitionId^ get ();
}
static member CannotPlaceBalusterPatterns : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.CannotPlaceRailingOnStringerWarning Property

BuiltInFailuresStairRampFailuresCannotPlaceRailingOnStringerWarning Property

Railing is placed on tread because there is no stringer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPlaceRailingOnStringerWarning { get; }
Public Shared ReadOnly Property CannotPlaceRailingOnStringerWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPlaceRailingOnStringerWarning {
    FailureDefinitionId^ get ();
}
static member CannotPlaceRailingOnStringerWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.CannotProcessInStairsSketchEditMode Property

BuiltInFailuresStairRampFailuresCannotProcessInStairsSketchEditMode Property

Cannot process when stair(s) in sketch edit mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotProcessInStairsSketchEditMode { get; }
Public Shared ReadOnly Property CannotProcessInStairsSketchEditMode As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotProcessInStairsSketchEditMode {
    FailureDefinitionId^ get ();
}
static member CannotProcessInStairsSketchEditMode : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.CannotSplitRailingWithExtensions Property

BuiltInFailuresStairRampFailuresCannotSplitRailingWithExtensions Property

Railings with extensions cannot be split.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotSplitRailingWithExtensions { get; }
Public Shared ReadOnly Property CannotSplitRailingWithExtensions As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotSplitRailingWithExtensions {
    FailureDefinitionId^ get ();
}
static member CannotSplitRailingWithExtensions : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.ContinuousRailFilletCreationError Property

BuiltInFailuresStairRampFailuresContinuousRailFilletCreationError Property

Cannot create specified fillet at rail path corner.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ContinuousRailFilletCreationError { get; }
Public Shared ReadOnly Property ContinuousRailFilletCreationError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ContinuousRailFilletCreationError {
    FailureDefinitionId^ get ();
}
static member ContinuousRailFilletCreationError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.ContinuousRailFilletCreationParallel Property

BuiltInFailuresStairRampFailuresContinuousRailFilletCreationParallel Property

Cannot create specified fillet at rail path corner because of the curves are already smoothed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ContinuousRailFilletCreationParallel { get; }
Public Shared ReadOnly Property ContinuousRailFilletCreationParallel As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ContinuousRailFilletCreationParallel {
    FailureDefinitionId^ get ();
}
static member ContinuousRailFilletCreationParallel : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.ContinuousRailFilletCreationWarning Property

BuiltInFailuresStairRampFailuresContinuousRailFilletCreationWarning Property

Cannot create specified fillet at rail path corner.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ContinuousRailFilletCreationWarning { get; }
Public Shared ReadOnly Property ContinuousRailFilletCreationWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ContinuousRailFilletCreationWarning {
    FailureDefinitionId^ get ();
}
static member ContinuousRailFilletCreationWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.ContinuousRailGometryCreationFailure Property

BuiltInFailuresStairRampFailuresContinuousRailGometryCreationFailure Property

Cannot create the continuous rail geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ContinuousRailGometryCreationFailure { get; }
Public Shared ReadOnly Property ContinuousRailGometryCreationFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ContinuousRailGometryCreationFailure {
    FailureDefinitionId^ get ();
}
static member ContinuousRailGometryCreationFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.ContinuousRailNotContinuous Property

BuiltInFailuresStairRampFailuresContinuousRailNotContinuous Property

The rail is non-continuous.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ContinuousRailNotContinuous { get; }
Public Shared ReadOnly Property ContinuousRailNotContinuous As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ContinuousRailNotContinuous {
    FailureDefinitionId^ get ();
}
static member ContinuousRailNotContinuous : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.ContinuousRailSupportPlacementFailure Property

BuiltInFailuresStairRampFailuresContinuousRailSupportPlacementFailure Property

Cannot place the supports along the rail path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ContinuousRailSupportPlacementFailure { get; }
Public Shared ReadOnly Property ContinuousRailSupportPlacementFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ContinuousRailSupportPlacementFailure {
    FailureDefinitionId^ get ();
}
static member ContinuousRailSupportPlacementFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.ContinuousRailTransitionFailure Property

BuiltInFailuresStairRampFailuresContinuousRailTransitionFailure Property

Cannot create specified transition at rail path turn, hand Rail/Top Rail cannot maintain continuous.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ContinuousRailTransitionFailure { get; }
Public Shared ReadOnly Property ContinuousRailTransitionFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ContinuousRailTransitionFailure {
    FailureDefinitionId^ get ();
}
static member ContinuousRailTransitionFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.ExtendBelowBaseGreaterThanLandingBaseElevation Property

BuiltInFailuresStairRampFailuresExtendBelowBaseGreaterThanLandingBaseElevation Property

Extend Below Base needs to be less than Landing Base Elevation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ExtendBelowBaseGreaterThanLandingBaseElevation { get; }
Public Shared ReadOnly Property ExtendBelowBaseGreaterThanLandingBaseElevation As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ExtendBelowBaseGreaterThanLandingBaseElevation {
    FailureDefinitionId^ get ();
}
static member ExtendBelowBaseGreaterThanLandingBaseElevation : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.ExtendBelowBaseGreaterThanRunTopElevation Property

BuiltInFailuresStairRampFailuresExtendBelowBaseGreaterThanRunTopElevation Property

Extend Below Base needs to be less than Run Top Elevation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ExtendBelowBaseGreaterThanRunTopElevation { get; }
Public Shared ReadOnly Property ExtendBelowBaseGreaterThanRunTopElevation As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ExtendBelowBaseGreaterThanRunTopElevation {
    FailureDefinitionId^ get ();
}
static member ExtendBelowBaseGreaterThanRunTopElevation : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.FailToReOrientSketchCurvesFailure Property

BuiltInFailuresStairRampFailuresFailToReOrientSketchCurvesFailure Property

Failed to orient sketch curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FailToReOrientSketchCurvesFailure { get; }
Public Shared ReadOnly Property FailToReOrientSketchCurvesFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FailToReOrientSketchCurvesFailure {
    FailureDefinitionId^ get ();
}
static member FailToReOrientSketchCurvesFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.HeightOfRunIsTooSmall Property

BuiltInFailuresStairRampFailuresHeightOfRunIsTooSmall Property

Height of run is too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId HeightOfRunIsTooSmall { get; }
Public Shared ReadOnly Property HeightOfRunIsTooSmall As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ HeightOfRunIsTooSmall {
    FailureDefinitionId^ get ();
}
static member HeightOfRunIsTooSmall : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.IntermediateLandingHigherThanTopRunFailure Property

BuiltInFailuresStairRampFailuresIntermediateLandingHigherThanTopRunFailure Property

Run is reversed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId IntermediateLandingHigherThanTopRunFailure { get; }
Public Shared ReadOnly Property IntermediateLandingHigherThanTopRunFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ IntermediateLandingHigherThanTopRunFailure {
    FailureDefinitionId^ get ();
}
static member IntermediateLandingHigherThanTopRunFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.InvalidBalustersPattern Property

BuiltInFailuresStairRampFailuresInvalidBalustersPattern Property

Invalid Balusters Pattern

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidBalustersPattern { get; }
Public Shared ReadOnly Property InvalidBalustersPattern As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidBalustersPattern {
    FailureDefinitionId^ get ();
}
static member InvalidBalustersPattern : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.InvalidLocationLineJustificationFailure Property

BuiltInFailuresStairRampFailuresInvalidLocationLineJustificationFailure Property

Modify the location justification to a invalid value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidLocationLineJustificationFailure { get; }
Public Shared ReadOnly Property InvalidLocationLineJustificationFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidLocationLineJustificationFailure {
    FailureDefinitionId^ get ();
}
static member InvalidLocationLineJustificationFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.InvalidParameters Property

BuiltInFailuresStairRampFailuresInvalidParameters Property

Stairs run or landing has invalid parameter(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidParameters { get; }
Public Shared ReadOnly Property InvalidParameters As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidParameters {
    FailureDefinitionId^ get ();
}
static member InvalidParameters : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.InvalidRailProfile Property

BuiltInFailuresStairRampFailuresInvalidRailProfile Property

Profiles for one or more of the Rails are invalid. Make sure that every used Profile is a closed series of non-intersecting Lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidRailProfile { get; }
Public Shared ReadOnly Property InvalidRailProfile As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidRailProfile {
    FailureDefinitionId^ get ();
}
static member InvalidRailProfile : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.InvalidStairsPathFailure Property

BuiltInFailuresStairRampFailuresInvalidStairsPathFailure Property

Invalid stairs path provided.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidStairsPathFailure { get; }
Public Shared ReadOnly Property InvalidStairsPathFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidStairsPathFailure {
    FailureDefinitionId^ get ();
}
static member InvalidStairsPathFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.InvalidStartLevel Property

BuiltInFailuresStairRampFailuresInvalidStartLevel Property

The start level and end level for this staircase must be at different elevations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidStartLevel { get; }
Public Shared ReadOnly Property InvalidStartLevel As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidStartLevel {
    FailureDefinitionId^ get ();
}
static member InvalidStartLevel : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.InvalidStartLevelRamp Property

BuiltInFailuresStairRampFailuresInvalidStartLevelRamp Property

The start level and end level for this ramp must be at different elevations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidStartLevelRamp { get; }
Public Shared ReadOnly Property InvalidStartLevelRamp As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidStartLevelRamp {
    FailureDefinitionId^ get ();
}
static member InvalidStartLevelRamp : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.LandingDepthIsLessThanRunWidthWarning Property

BuiltInFailuresStairRampFailuresLandingDepthIsLessThanRunWidthWarning Property

Landing depth is less than run width.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LandingDepthIsLessThanRunWidthWarning { get; }
Public Shared ReadOnly Property LandingDepthIsLessThanRunWidthWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LandingDepthIsLessThanRunWidthWarning {
    FailureDefinitionId^ get ();
}
static member LandingDepthIsLessThanRunWidthWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.LandingHeightUnderStairsBottom Property

BuiltInFailuresStairRampFailuresLandingHeightUnderStairsBottom Property

Cannot make landing because height of landing is equal or less than to bottom height of the stair.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LandingHeightUnderStairsBottom { get; }
Public Shared ReadOnly Property LandingHeightUnderStairsBottom As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LandingHeightUnderStairsBottom {
    FailureDefinitionId^ get ();
}
static member LandingHeightUnderStairsBottom : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.LandingShapeHandleOnPinnedRunFailure Property

BuiltInFailuresStairRampFailuresLandingShapeHandleOnPinnedRunFailure Property

Cannot Drag the automatic landing shape handle control because the connected run is pinned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LandingShapeHandleOnPinnedRunFailure { get; }
Public Shared ReadOnly Property LandingShapeHandleOnPinnedRunFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LandingShapeHandleOnPinnedRunFailure {
    FailureDefinitionId^ get ();
}
static member LandingShapeHandleOnPinnedRunFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.MayUnjoinRailAndSupports Property

BuiltInFailuresStairRampFailuresMayUnjoinRailAndSupports Property

Fillet may cause the supports unjoin with the rail.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MayUnjoinRailAndSupports { get; }
Public Shared ReadOnly Property MayUnjoinRailAndSupports As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MayUnjoinRailAndSupports {
    FailureDefinitionId^ get ();
}
static member MayUnjoinRailAndSupports : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.MultistoryLevelBelowTopbottomLevel Property

BuiltInFailuresStairRampFailuresMultistoryLevelBelowTopbottomLevel Property

Multistory top level must be above the stair/ramp top and bottom levels.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MultistoryLevelBelowTopbottomLevel { get; }
Public Shared ReadOnly Property MultistoryLevelBelowTopbottomLevel As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MultistoryLevelBelowTopbottomLevel {
    FailureDefinitionId^ get ();
}
static member MultistoryLevelBelowTopbottomLevel : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.MultistoryLevelBelowTopbottomLevelError Property

BuiltInFailuresStairRampFailuresMultistoryLevelBelowTopbottomLevelError Property

Multistory top level must be above the stair/ramp top and bottom levels.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MultistoryLevelBelowTopbottomLevelError { get; }
Public Shared ReadOnly Property MultistoryLevelBelowTopbottomLevelError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MultistoryLevelBelowTopbottomLevelError {
    FailureDefinitionId^ get ();
}
static member MultistoryLevelBelowTopbottomLevelError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.MultistoryStairDoesntReach Property

BuiltInFailuresStairRampFailuresMultistoryStairDoesntReach Property

The multistory stair/ramp could not reach its top level with integral number of flights. Maximum number of flights below the top level is created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MultistoryStairDoesntReach { get; }
Public Shared ReadOnly Property MultistoryStairDoesntReach As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MultistoryStairDoesntReach {
    FailureDefinitionId^ get ();
}
static member MultistoryStairDoesntReach : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.MultistoryStairsAutomaticLevelLandingsDeleted Property

BuiltInFailuresStairRampFailuresMultistoryStairsAutomaticLevelLandingsDeleted Property

Level landings are deleted because the connected stairs have been regenerated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MultistoryStairsAutomaticLevelLandingsDeleted { get; }
Public Shared ReadOnly Property MultistoryStairsAutomaticLevelLandingsDeleted As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MultistoryStairsAutomaticLevelLandingsDeleted {
    FailureDefinitionId^ get ();
}
static member MultistoryStairsAutomaticLevelLandingsDeleted : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.MultistoryStairsComponentJoinFailure Property

BuiltInFailuresStairRampFailuresMultistoryStairsComponentJoinFailure Property

Can't keep elements joined. Avoid converting stairs to skeched-based component in Multistory stairs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MultistoryStairsComponentJoinFailure { get; }
Public Shared ReadOnly Property MultistoryStairsComponentJoinFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MultistoryStairsComponentJoinFailure {
    FailureDefinitionId^ get ();
}
static member MultistoryStairsComponentJoinFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.MultistoryStairsHideTopLevelParameter Property

BuiltInFailuresStairRampFailuresMultistoryStairsHideTopLevelParameter Property

You have set the stair's multistory top level to None, and Revit will remove this parameter, if you want to create a multistory stair, please use Create Multistory Stair feature.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MultistoryStairsHideTopLevelParameter { get; }
Public Shared ReadOnly Property MultistoryStairsHideTopLevelParameter As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MultistoryStairsHideTopLevelParameter {
    FailureDefinitionId^ get ();
}
static member MultistoryStairsHideTopLevelParameter : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.MultistoryStandardStairBottomEndExceedsOrNotReach Property

BuiltInFailuresStairRampFailuresMultistoryStandardStairBottomEndExceedsOrNotReach Property

One of the stairs inside multistory stairs bottom ends exceeds or cannot reach the base elevation of the stair.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MultistoryStandardStairBottomEndExceedsOrNotReach { get; }
Public Shared ReadOnly Property MultistoryStandardStairBottomEndExceedsOrNotReach As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MultistoryStandardStairBottomEndExceedsOrNotReach {
    FailureDefinitionId^ get ();
}
static member MultistoryStandardStairBottomEndExceedsOrNotReach : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.MultistoryStandardStairTopEndExceedsOrNotReach Property

BuiltInFailuresStairRampFailuresMultistoryStandardStairTopEndExceedsOrNotReach Property

One of the stairs inside multistory stairs top ends exceed or cannot reach the top elevation of the stair.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MultistoryStandardStairTopEndExceedsOrNotReach { get; }
Public Shared ReadOnly Property MultistoryStandardStairTopEndExceedsOrNotReach As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MultistoryStandardStairTopEndExceedsOrNotReach {
    FailureDefinitionId^ get ();
}
static member MultistoryStandardStairTopEndExceedsOrNotReach : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.MultusegmentRampRiser Property

BuiltInFailuresStairRampFailuresMultusegmentRampRiser Property

Ramp can't have multisegment Riser.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MultusegmentRampRiser { get; }
Public Shared ReadOnly Property MultusegmentRampRiser As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MultusegmentRampRiser {
    FailureDefinitionId^ get ();
}
static member MultusegmentRampRiser : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.MultusegmentRampRiserError Property

BuiltInFailuresStairRampFailuresMultusegmentRampRiserError Property

Ramp can't have multisegment Riser.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MultusegmentRampRiserError { get; }
Public Shared ReadOnly Property MultusegmentRampRiserError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MultusegmentRampRiserError {
    FailureDefinitionId^ get ();
}
static member MultusegmentRampRiserError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.NoCurvesInRailing Property

BuiltInFailuresStairRampFailuresNoCurvesInRailing Property

Railing Sketch has no Lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoCurvesInRailing { get; }
Public Shared ReadOnly Property NoCurvesInRailing As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoCurvesInRailing {
    FailureDefinitionId^ get ();
}
static member NoCurvesInRailing : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.NoProfileForRail Property

BuiltInFailuresStairRampFailuresNoProfileForRail Property

Must specify Profiles for every Rail.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoProfileForRail { get; }
Public Shared ReadOnly Property NoProfileForRail As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoProfileForRail {
    FailureDefinitionId^ get ();
}
static member NoProfileForRail : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.NoRailingsStringer Property

BuiltInFailuresStairRampFailuresNoRailingsStringer Property

Railings and Stringers will not be automatically generated due to bad Runs. This message may be incorrect if you have Edited the Sketch and modified some dimensions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoRailingsStringer { get; }
Public Shared ReadOnly Property NoRailingsStringer As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoRailingsStringer {
    FailureDefinitionId^ get ();
}
static member NoRailingsStringer : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.NoRisersInPureMonolithicStairs Property

BuiltInFailuresStairRampFailuresNoRisersInPureMonolithicStairs Property

Monolithic Stairs with zero tread thickness can't have risers

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoRisersInPureMonolithicStairs { get; }
Public Shared ReadOnly Property NoRisersInPureMonolithicStairs As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoRisersInPureMonolithicStairs {
    FailureDefinitionId^ get ();
}
static member NoRisersInPureMonolithicStairs : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.NoRunsRamp Property

BuiltInFailuresStairRampFailuresNoRunsRamp Property

Ramp has no Runs. Can't create Ramp.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoRunsRamp { get; }
Public Shared ReadOnly Property NoRunsRamp As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoRunsRamp {
    FailureDefinitionId^ get ();
}
static member NoRunsRamp : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.NoRunsRampError Property

BuiltInFailuresStairRampFailuresNoRunsRampError Property

Ramp has no Runs. Can't create Ramp.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoRunsRampError { get; }
Public Shared ReadOnly Property NoRunsRampError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoRunsRampError {
    FailureDefinitionId^ get ();
}
static member NoRunsRampError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.NotALineRiserRamp Property

BuiltInFailuresStairRampFailuresNotALineRiserRamp Property

Riser line must be a straight line for Ramps.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotALineRiserRamp { get; }
Public Shared ReadOnly Property NotALineRiserRamp As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotALineRiserRamp {
    FailureDefinitionId^ get ();
}
static member NotALineRiserRamp : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.NotALineRiserRampError Property

BuiltInFailuresStairRampFailuresNotALineRiserRampError Property

Riser line must be a straight line for Ramps.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotALineRiserRampError { get; }
Public Shared ReadOnly Property NotALineRiserRampError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotALineRiserRampError {
    FailureDefinitionId^ get ();
}
static member NotALineRiserRampError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.NotchThicknessIsLargerThanLandingWarning Property

BuiltInFailuresStairRampFailuresNotchThicknessIsLargerThanLandingWarning Property

The notch thickness is larger than landing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotchThicknessIsLargerThanLandingWarning { get; }
Public Shared ReadOnly Property NotchThicknessIsLargerThanLandingWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotchThicknessIsLargerThanLandingWarning {
    FailureDefinitionId^ get ();
}
static member NotchThicknessIsLargerThanLandingWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.NotEnoughRisers Property

BuiltInFailuresStairRampFailuresNotEnoughRisers Property

Actual Number of Risers is different from Desired Number of Risers. Add/remove Risers or change Desired Number of Risers in Stairs Properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotEnoughRisers { get; }
Public Shared ReadOnly Property NotEnoughRisers As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotEnoughRisers {
    FailureDefinitionId^ get ();
}
static member NotEnoughRisers : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.OnlyMonolithicStairs Property

BuiltInFailuresStairRampFailuresOnlyMonolithicStairs Property

Tread thickness can't be zero for non-monolithic stairs

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId OnlyMonolithicStairs { get; }
Public Shared ReadOnly Property OnlyMonolithicStairs As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ OnlyMonolithicStairs {
    FailureDefinitionId^ get ();
}
static member OnlyMonolithicStairs : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.PartOfRiserLiesOnBoundaryFailure Property

BuiltInFailuresStairRampFailuresPartOfRiserLiesOnBoundaryFailure Property

Part of the riser lies on the boundary is not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PartOfRiserLiesOnBoundaryFailure { get; }
Public Shared ReadOnly Property PartOfRiserLiesOnBoundaryFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PartOfRiserLiesOnBoundaryFailure {
    FailureDefinitionId^ get ();
}
static member PartOfRiserLiesOnBoundaryFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.PathDoesntJoinToBorderRisersFailure Property

BuiltInFailuresStairRampFailuresPathDoesntJoinToBorderRisersFailure Property

Path doesn't join to border risers is not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PathDoesntJoinToBorderRisersFailure { get; }
Public Shared ReadOnly Property PathDoesntJoinToBorderRisersFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PathDoesntJoinToBorderRisersFailure {
    FailureDefinitionId^ get ();
}
static member PathDoesntJoinToBorderRisersFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.RailCurveTooShort Property

BuiltInFailuresStairRampFailuresRailCurveTooShort Property

Curve in rail sketch is too short for rail creation and ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RailCurveTooShort { get; }
Public Shared ReadOnly Property RailCurveTooShort As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RailCurveTooShort {
    FailureDefinitionId^ get ();
}
static member RailCurveTooShort : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.RailingBadOffset Property

BuiltInFailuresStairRampFailuresRailingBadOffset Property

An arc in the railing sketch has a radius that conflicts with the current rail widths and offsets. Please either increase the radius or modify rail profiles and offsets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RailingBadOffset { get; }
Public Shared ReadOnly Property RailingBadOffset As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RailingBadOffset {
    FailureDefinitionId^ get ();
}
static member RailingBadOffset : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.RailingCurvesNotSplitRamp Property

BuiltInFailuresStairRampFailuresRailingCurvesNotSplitRamp Property

The slope of this railing will not parallel the ramp at landings. To get a parallel railing, split the railing sketch at the ends of landings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RailingCurvesNotSplitRamp { get; }
Public Shared ReadOnly Property RailingCurvesNotSplitRamp As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RailingCurvesNotSplitRamp {
    FailureDefinitionId^ get ();
}
static member RailingCurvesNotSplitRamp : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.RailingCurvesNotSplitStairs Property

BuiltInFailuresStairRampFailuresRailingCurvesNotSplitStairs Property

The slope of this railing may not parallel the stairs at runs and landings. To get a parallel railing, split the railing sketch at the ends of landings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RailingCurvesNotSplitStairs { get; }
Public Shared ReadOnly Property RailingCurvesNotSplitStairs As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RailingCurvesNotSplitStairs {
    FailureDefinitionId^ get ();
}
static member RailingCurvesNotSplitStairs : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.RailingDoublyConnected Property

BuiltInFailuresStairRampFailuresRailingDoublyConnected Property

Railings hosted on Stairs must form a single, open, connected line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RailingDoublyConnected { get; }
Public Shared ReadOnly Property RailingDoublyConnected As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RailingDoublyConnected {
    FailureDefinitionId^ get ();
}
static member RailingDoublyConnected : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.RailingNotConnected Property

BuiltInFailuresStairRampFailuresRailingNotConnected Property

The Railing line must be a single connected Sketch. If you want separate pieces of Railing, create two or more separate Railings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RailingNotConnected { get; }
Public Shared ReadOnly Property RailingNotConnected As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RailingNotConnected {
    FailureDefinitionId^ get ();
}
static member RailingNotConnected : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.RailPathCloseLoopForExtensionWarning Property

BuiltInFailuresStairRampFailuresRailPathCloseLoopForExtensionWarning Property

The rail path is closed at the start and end path point for extension creation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RailPathCloseLoopForExtensionWarning { get; }
Public Shared ReadOnly Property RailPathCloseLoopForExtensionWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RailPathCloseLoopForExtensionWarning {
    FailureDefinitionId^ get ();
}
static member RailPathCloseLoopForExtensionWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.RailPlacedOutsideOfHost Property

BuiltInFailuresStairRampFailuresRailPlacedOutsideOfHost Property

Railings are placed completely outside the host. It may change the adjustment of the railing to the host and its vertical position.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RailPlacedOutsideOfHost { get; }
Public Shared ReadOnly Property RailPlacedOutsideOfHost As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RailPlacedOutsideOfHost {
    FailureDefinitionId^ get ();
}
static member RailPlacedOutsideOfHost : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.RailProfileLowerThanFilletError Property

BuiltInFailuresStairRampFailuresRailProfileLowerThanFilletError Property

Fillet cannot be created between rail segment since the radius is lower than the profile size.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RailProfileLowerThanFilletError { get; }
Public Shared ReadOnly Property RailProfileLowerThanFilletError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RailProfileLowerThanFilletError {
    FailureDefinitionId^ get ();
}
static member RailProfileLowerThanFilletError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.RailProfileLowerThanFilletFailure Property

BuiltInFailuresStairRampFailuresRailProfileLowerThanFilletFailure Property

Fillet cannot be created between rail segment since the radius is lower than the profile size.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RailProfileLowerThanFilletFailure { get; }
Public Shared ReadOnly Property RailProfileLowerThanFilletFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RailProfileLowerThanFilletFailure {
    FailureDefinitionId^ get ();
}
static member RailProfileLowerThanFilletFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.RailProfileOpen Property

BuiltInFailuresStairRampFailuresRailProfileOpen Property

Open Profile Loop can't be used as a Rail Profile

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RailProfileOpen { get; }
Public Shared ReadOnly Property RailProfileOpen As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RailProfileOpen {
    FailureDefinitionId^ get ();
}
static member RailProfileOpen : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.RailTypeChangeInconsistancyWarningWithResetBtn Property

BuiltInFailuresStairRampFailuresRailTypeChangeInconsistancyWarningWithResetBtn Property

Some rail type changes are not consistent with your rail instances customization in this project, you can reset them to make them corresponding with your changes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RailTypeChangeInconsistancyWarningWithResetBtn { get; }
Public Shared ReadOnly Property RailTypeChangeInconsistancyWarningWithResetBtn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RailTypeChangeInconsistancyWarningWithResetBtn {
    FailureDefinitionId^ get ();
}
static member RailTypeChangeInconsistancyWarningWithResetBtn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.RampDoesntReach Property

BuiltInFailuresStairRampFailuresRampDoesntReach Property

The ramp is not long enough to reach the top constraint. Change the slope or increase the length of the ramp.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RampDoesntReach { get; }
Public Shared ReadOnly Property RampDoesntReach As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RampDoesntReach {
    FailureDefinitionId^ get ();
}
static member RampDoesntReach : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.RampDoesntReachOffset Property

BuiltInFailuresStairRampFailuresRampDoesntReachOffset Property

The ramp is not long enough to reach the top constraint plus top offset. Change the slope or increase the length of the ramp.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RampDoesntReachOffset { get; }
Public Shared ReadOnly Property RampDoesntReachOffset As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RampDoesntReachOffset {
    FailureDefinitionId^ get ();
}
static member RampDoesntReachOffset : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.RampLandingNotCreated Property

BuiltInFailuresStairRampFailuresRampLandingNotCreated Property

Beginning of run coincide with the end of previous run. Landing is not created between runs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RampLandingNotCreated { get; }
Public Shared ReadOnly Property RampLandingNotCreated As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RampLandingNotCreated {
    FailureDefinitionId^ get ();
}
static member RampLandingNotCreated : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.RampRunTooComplex Property

BuiltInFailuresStairRampFailuresRampRunTooComplex Property

Ramp Run has complex boundary and may produce unreasonable geometry. Split it into few Runs by inserting Riser Lines at the end of each Run and at the beginning of the next one. If you want to create Ramp with arc an straight section you can do it using a Run tool.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RampRunTooComplex { get; }
Public Shared ReadOnly Property RampRunTooComplex As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RampRunTooComplex {
    FailureDefinitionId^ get ();
}
static member RampRunTooComplex : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.RampStartHigherThanEnd Property

BuiltInFailuresStairRampFailuresRampStartHigherThanEnd Property

The ramp's base (base level + base offset) must be below its top (top level + top offset).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RampStartHigherThanEnd { get; }
Public Shared ReadOnly Property RampStartHigherThanEnd As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RampStartHigherThanEnd {
    FailureDefinitionId^ get ();
}
static member RampStartHigherThanEnd : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.RiserCurveTooShort Property

BuiltInFailuresStairRampFailuresRiserCurveTooShort Property

Riser curve is too short to create nosing on it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RiserCurveTooShort { get; }
Public Shared ReadOnly Property RiserCurveTooShort As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RiserCurveTooShort {
    FailureDefinitionId^ get ();
}
static member RiserCurveTooShort : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.RiserHeightIsTooSmall Property

BuiltInFailuresStairRampFailuresRiserHeightIsTooSmall Property

Riser height is too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RiserHeightIsTooSmall { get; }
Public Shared ReadOnly Property RiserHeightIsTooSmall As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RiserHeightIsTooSmall {
    FailureDefinitionId^ get ();
}
static member RiserHeightIsTooSmall : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.RiserIntWithBoundaryMoreThanOnceFailure Property

BuiltInFailuresStairRampFailuresRiserIntWithBoundaryMoreThanOnceFailure Property

Riser intersects with boundary more than once.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RiserIntWithBoundaryMoreThanOnceFailure { get; }
Public Shared ReadOnly Property RiserIntWithBoundaryMoreThanOnceFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RiserIntWithBoundaryMoreThanOnceFailure {
    FailureDefinitionId^ get ();
}
static member RiserIntWithBoundaryMoreThanOnceFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.RisersAtSameLocation Property

BuiltInFailuresStairRampFailuresRisersAtSameLocation Property

The highlighted risers have the same location along the boundary line. Please move one of the two risers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RisersAtSameLocation { get; }
Public Shared ReadOnly Property RisersAtSameLocation As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RisersAtSameLocation {
    FailureDefinitionId^ get ();
}
static member RisersAtSameLocation : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.RiserThicknesssResetToZero Property

BuiltInFailuresStairRampFailuresRiserThicknesssResetToZero Property

Monolithic Stairs without Treads can't have Risers. Riser Thickness for Stairs Type was automatically set to zero.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RiserThicknesssResetToZero { get; }
Public Shared ReadOnly Property RiserThicknesssResetToZero As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RiserThicknesssResetToZero {
    FailureDefinitionId^ get ();
}
static member RiserThicknesssResetToZero : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.RunBottomHigherThanTopFailure Property

BuiltInFailuresStairRampFailuresRunBottomHigherThanTopFailure Property

The base elevation for the run is higher than the top elevation for the run.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RunBottomHigherThanTopFailure { get; }
Public Shared ReadOnly Property RunBottomHigherThanTopFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RunBottomHigherThanTopFailure {
    FailureDefinitionId^ get ();
}
static member RunBottomHigherThanTopFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.RunBottomUnderStairsBottomFailure Property

BuiltInFailuresStairRampFailuresRunBottomUnderStairsBottomFailure Property

Run bottom elevation should not be below the stairs bottom elevation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RunBottomUnderStairsBottomFailure { get; }
Public Shared ReadOnly Property RunBottomUnderStairsBottomFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RunBottomUnderStairsBottomFailure {
    FailureDefinitionId^ get ();
}
static member RunBottomUnderStairsBottomFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.RunIsJoiningLandingWithRiserSoNotchDoesNotWorkWarning Property

BuiltInFailuresStairRampFailuresRunIsJoiningLandingWithRiserSoNotchDoesNotWorkWarning Property

Run is joining landing with riser, so notch configuration does not take effect. Try to set run as begin/end with tread to make a notch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RunIsJoiningLandingWithRiserSoNotchDoesNotWorkWarning { get; }
Public Shared ReadOnly Property RunIsJoiningLandingWithRiserSoNotchDoesNotWorkWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RunIsJoiningLandingWithRiserSoNotchDoesNotWorkWarning {
    FailureDefinitionId^ get ();
}
static member RunIsJoiningLandingWithRiserSoNotchDoesNotWorkWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.RunTopLowerThanBottomFailure Property

BuiltInFailuresStairRampFailuresRunTopLowerThanBottomFailure Property

The top elevation for the run is lower than the base elevation for the run.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RunTopLowerThanBottomFailure { get; }
Public Shared ReadOnly Property RunTopLowerThanBottomFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RunTopLowerThanBottomFailure {
    FailureDefinitionId^ get ();
}
static member RunTopLowerThanBottomFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.SpiralRunRadiusTooSmallFailure Property

BuiltInFailuresStairRampFailuresSpiralRunRadiusTooSmallFailure Property

The radius value for the run is too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SpiralRunRadiusTooSmallFailure { get; }
Public Shared ReadOnly Property SpiralRunRadiusTooSmallFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SpiralRunRadiusTooSmallFailure {
    FailureDefinitionId^ get ();
}
static member SpiralRunRadiusTooSmallFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.StairIncompleteFailure Property

BuiltInFailuresStairRampFailuresStairIncompleteFailure Property

Stair element is incomplete, not all components are logic connected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StairIncompleteFailure { get; }
Public Shared ReadOnly Property StairIncompleteFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StairIncompleteFailure {
    FailureDefinitionId^ get ();
}
static member StairIncompleteFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.StairsActualRiserHeightGreaterThanMaximumFailure Property

BuiltInFailuresStairRampFailuresStairsActualRiserHeightGreaterThanMaximumFailure Property

Computed actual riser height of stairs is greater than maximum riser height defined in stairs type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StairsActualRiserHeightGreaterThanMaximumFailure { get; }
Public Shared ReadOnly Property StairsActualRiserHeightGreaterThanMaximumFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StairsActualRiserHeightGreaterThanMaximumFailure {
    FailureDefinitionId^ get ();
}
static member StairsActualRiserHeightGreaterThanMaximumFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.StairsActualRunWidthLessThanMinimumFailure Property

BuiltInFailuresStairRampFailuresStairsActualRunWidthLessThanMinimumFailure Property

Actual run width is less than minimum run width defined in stairs type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StairsActualRunWidthLessThanMinimumFailure { get; }
Public Shared ReadOnly Property StairsActualRunWidthLessThanMinimumFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StairsActualRunWidthLessThanMinimumFailure {
    FailureDefinitionId^ get ();
}
static member StairsActualRunWidthLessThanMinimumFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.StairsActualTreadDepthLessThanMinimumFailure Property

BuiltInFailuresStairRampFailuresStairsActualTreadDepthLessThanMinimumFailure Property

Computed actual tread depth of stairs is less than minimum tread depth defined in stairs type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StairsActualTreadDepthLessThanMinimumFailure { get; }
Public Shared ReadOnly Property StairsActualTreadDepthLessThanMinimumFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StairsActualTreadDepthLessThanMinimumFailure {
    FailureDefinitionId^ get ();
}
static member StairsActualTreadDepthLessThanMinimumFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.StairsAlreadyAttachedToCurrentLevel Property

BuiltInFailuresStairRampFailuresStairsAlreadyAttachedToCurrentLevel Property

Mutistory Stairs already have a Stair attaching to this level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StairsAlreadyAttachedToCurrentLevel { get; }
Public Shared ReadOnly Property StairsAlreadyAttachedToCurrentLevel As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StairsAlreadyAttachedToCurrentLevel {
    FailureDefinitionId^ get ();
}
static member StairsAlreadyAttachedToCurrentLevel : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.StairsAreUpdatedDueToLevelHeightChange Property

BuiltInFailuresStairRampFailuresStairsAreUpdatedDueToLevelHeightChange Property

Stair component(s) in the multistory stair are updated due to the level height changes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StairsAreUpdatedDueToLevelHeightChange { get; }
Public Shared ReadOnly Property StairsAreUpdatedDueToLevelHeightChange As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StairsAreUpdatedDueToLevelHeightChange {
    FailureDefinitionId^ get ();
}
static member StairsAreUpdatedDueToLevelHeightChange : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.StairsAutomaticLandingLayoutFailure Property

BuiltInFailuresStairRampFailuresStairsAutomaticLandingLayoutFailure Property

Fail to generate the automatic landing layout

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StairsAutomaticLandingLayoutFailure { get; }
Public Shared ReadOnly Property StairsAutomaticLandingLayoutFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StairsAutomaticLandingLayoutFailure {
    FailureDefinitionId^ get ();
}
static member StairsAutomaticLandingLayoutFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.StairsAutomaticLandingLayoutWarn Property

BuiltInFailuresStairRampFailuresStairsAutomaticLandingLayoutWarn Property

Fail to generate the automatic landing layout

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StairsAutomaticLandingLayoutWarn { get; }
Public Shared ReadOnly Property StairsAutomaticLandingLayoutWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StairsAutomaticLandingLayoutWarn {
    FailureDefinitionId^ get ();
}
static member StairsAutomaticLandingLayoutWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.StairsBottomEndExceedsOrNotReachWarning Property

BuiltInFailuresStairRampFailuresStairsBottomEndExceedsOrNotReachWarning Property

Stair bottom end exceeds or cannot reach the base elevation of the stair. Add/remove risers at the bottom end or change base elevation settings in Stair Properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StairsBottomEndExceedsOrNotReachWarning { get; }
Public Shared ReadOnly Property StairsBottomEndExceedsOrNotReachWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StairsBottomEndExceedsOrNotReachWarning {
    FailureDefinitionId^ get ();
}
static member StairsBottomEndExceedsOrNotReachWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.StairsCannotExtendToFloorStructureLayerWarning Property

BuiltInFailuresStairRampFailuresStairsCannotExtendToFloorStructureLayerWarning Property

Stairs cannot extend to floor structure layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StairsCannotExtendToFloorStructureLayerWarning { get; }
Public Shared ReadOnly Property StairsCannotExtendToFloorStructureLayerWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StairsCannotExtendToFloorStructureLayerWarning {
    FailureDefinitionId^ get ();
}
static member StairsCannotExtendToFloorStructureLayerWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.StairsCommonRunGenerateLayoutFailure Property

BuiltInFailuresStairRampFailuresStairsCommonRunGenerateLayoutFailure Property

Fail to get base line thus fail to generate run layout

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StairsCommonRunGenerateLayoutFailure { get; }
Public Shared ReadOnly Property StairsCommonRunGenerateLayoutFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StairsCommonRunGenerateLayoutFailure {
    FailureDefinitionId^ get ();
}
static member StairsCommonRunGenerateLayoutFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.StairsComponentJoinFailure Property

BuiltInFailuresStairRampFailuresStairsComponentJoinFailure Property

Can't keep elements joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StairsComponentJoinFailure { get; }
Public Shared ReadOnly Property StairsComponentJoinFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StairsComponentJoinFailure {
    FailureDefinitionId^ get ();
}
static member StairsComponentJoinFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.StairsCrossingRisersDisallowedFailure Property

BuiltInFailuresStairRampFailuresStairsCrossingRisersDisallowedFailure Property

Crossing risers are not allowed

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StairsCrossingRisersDisallowedFailure { get; }
Public Shared ReadOnly Property StairsCrossingRisersDisallowedFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StairsCrossingRisersDisallowedFailure {
    FailureDefinitionId^ get ();
}
static member StairsCrossingRisersDisallowedFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.StairsGenericFailure Property

BuiltInFailuresStairRampFailuresStairsGenericFailure Property

Stairs generic failure

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StairsGenericFailure { get; }
Public Shared ReadOnly Property StairsGenericFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StairsGenericFailure {
    FailureDefinitionId^ get ();
}
static member StairsGenericFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.StairsGenericTransformFailure Property

BuiltInFailuresStairRampFailuresStairsGenericTransformFailure Property

Cannot change base elevation of Stairs

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StairsGenericTransformFailure { get; }
Public Shared ReadOnly Property StairsGenericTransformFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StairsGenericTransformFailure {
    FailureDefinitionId^ get ();
}
static member StairsGenericTransformFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.StairsIllegalDesiredNumRisers Property

BuiltInFailuresStairRampFailuresStairsIllegalDesiredNumRisers Property

Desired Number of Risers is too small. Computed Actual Riser Height is greater than Maximum Riser Height allowed by type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StairsIllegalDesiredNumRisers { get; }
Public Shared ReadOnly Property StairsIllegalDesiredNumRisers As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StairsIllegalDesiredNumRisers {
    FailureDefinitionId^ get ();
}
static member StairsIllegalDesiredNumRisers : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.StairsInMultistoryExceedTopConstraint Property

BuiltInFailuresStairRampFailuresStairsInMultistoryExceedTopConstraint Property

Stairs in MultistoryStairs after adjusting still exceed the top constraint.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StairsInMultistoryExceedTopConstraint { get; }
Public Shared ReadOnly Property StairsInMultistoryExceedTopConstraint As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StairsInMultistoryExceedTopConstraint {
    FailureDefinitionId^ get ();
}
static member StairsInMultistoryExceedTopConstraint : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.StairsOnlySingleBoundaryHasRiserWithBothEndsOnBoundaryFailure Property

BuiltInFailuresStairRampFailuresStairsOnlySingleBoundaryHasRiserWithBothEndsOnBoundaryFailure Property

Only single boundary case may have riser with its both ends on boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StairsOnlySingleBoundaryHasRiserWithBothEndsOnBoundaryFailure { get; }
Public Shared ReadOnly Property StairsOnlySingleBoundaryHasRiserWithBothEndsOnBoundaryFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StairsOnlySingleBoundaryHasRiserWithBothEndsOnBoundaryFailure {
    FailureDefinitionId^ get ();
}
static member StairsOnlySingleBoundaryHasRiserWithBothEndsOnBoundaryFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.StairsOtherThan2IntsByRiserAndBoundaryFailure Property

BuiltInFailuresStairRampFailuresStairsOtherThan2IntsByRiserAndBoundaryFailure Property

More than 2 intersection points between riser segment and boundary encountered

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StairsOtherThan2IntsByRiserAndBoundaryFailure { get; }
Public Shared ReadOnly Property StairsOtherThan2IntsByRiserAndBoundaryFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StairsOtherThan2IntsByRiserAndBoundaryFailure {
    FailureDefinitionId^ get ();
}
static member StairsOtherThan2IntsByRiserAndBoundaryFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.StairsPathPositionResetWarning Property

BuiltInFailuresStairRampFailuresStairsPathPositionResetWarning Property

The stairs path doesn't intersect with riser lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StairsPathPositionResetWarning { get; }
Public Shared ReadOnly Property StairsPathPositionResetWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StairsPathPositionResetWarning {
    FailureDefinitionId^ get ();
}
static member StairsPathPositionResetWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.StairsRunRunJoinNotAllowedFailure Property

BuiltInFailuresStairRampFailuresStairsRunRunJoinNotAllowedFailure Property

Run-Run join is not allowed of they have same "Start With Riser"/"End With Riser" configuration at the joined end.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StairsRunRunJoinNotAllowedFailure { get; }
Public Shared ReadOnly Property StairsRunRunJoinNotAllowedFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StairsRunRunJoinNotAllowedFailure {
    FailureDefinitionId^ get ();
}
static member StairsRunRunJoinNotAllowedFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.StairsStartHigherThanEnd Property

BuiltInFailuresStairRampFailuresStairsStartHigherThanEnd Property

The stairs' base (Base Level + Base Offset) must be below its top (Top Level + Top Offset).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StairsStartHigherThanEnd { get; }
Public Shared ReadOnly Property StairsStartHigherThanEnd As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StairsStartHigherThanEnd {
    FailureDefinitionId^ get ();
}
static member StairsStartHigherThanEnd : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.StairsStringerCannotBeCreated Property

BuiltInFailuresStairRampFailuresStairsStringerCannotBeCreated Property

The stairs stringer cannot be created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StairsStringerCannotBeCreated { get; }
Public Shared ReadOnly Property StairsStringerCannotBeCreated As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StairsStringerCannotBeCreated {
    FailureDefinitionId^ get ();
}
static member StairsStringerCannotBeCreated : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.StairsSubElementsNotConnectedWarning Property

BuiltInFailuresStairRampFailuresStairsSubElementsNotConnectedWarning Property

Stair sub-elements are not connected

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StairsSubElementsNotConnectedWarning { get; }
Public Shared ReadOnly Property StairsSubElementsNotConnectedWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StairsSubElementsNotConnectedWarning {
    FailureDefinitionId^ get ();
}
static member StairsSubElementsNotConnectedWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.StairsSupportOverlapFailure Property

BuiltInFailuresStairRampFailuresStairsSupportOverlapFailure Property

Some supports overlap with others

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StairsSupportOverlapFailure { get; }
Public Shared ReadOnly Property StairsSupportOverlapFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StairsSupportOverlapFailure {
    FailureDefinitionId^ get ();
}
static member StairsSupportOverlapFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.StairsSupportTooShort Property

BuiltInFailuresStairRampFailuresStairsSupportTooShort Property

A short support is being created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StairsSupportTooShort { get; }
Public Shared ReadOnly Property StairsSupportTooShort As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StairsSupportTooShort {
    FailureDefinitionId^ get ();
}
static member StairsSupportTooShort : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.StairsTopEndExceedsOrNotReachWarning Property

BuiltInFailuresStairRampFailuresStairsTopEndExceedsOrNotReachWarning Property

Stair top end exceeds or cannot reach the top elevation of the stair. Add/remove risers at the top end or change top elevation settings in Stair Properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StairsTopEndExceedsOrNotReachWarning { get; }
Public Shared ReadOnly Property StairsTopEndExceedsOrNotReachWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StairsTopEndExceedsOrNotReachWarning {
    FailureDefinitionId^ get ();
}
static member StairsTopEndExceedsOrNotReachWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.StairsTopLowerThanBaseFailure Property

BuiltInFailuresStairRampFailuresStairsTopLowerThanBaseFailure Property

The top of the Stair is lower than the base of the Stair

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StairsTopLowerThanBaseFailure { get; }
Public Shared ReadOnly Property StairsTopLowerThanBaseFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StairsTopLowerThanBaseFailure {
    FailureDefinitionId^ get ();
}
static member StairsTopLowerThanBaseFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.StairStringerCantOffset Property

BuiltInFailuresStairRampFailuresStairStringerCantOffset Property

Inside stringer could not be created because of insufficient space. Please disable the inside stringer or decrease its width.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StairStringerCantOffset { get; }
Public Shared ReadOnly Property StairStringerCantOffset As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StairStringerCantOffset {
    FailureDefinitionId^ get ();
}
static member StairStringerCantOffset : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.StairsWinderGenLayoutFailure Property

BuiltInFailuresStairRampFailuresStairsWinderGenLayoutFailure Property

Fail to generate run layout and then cannot make winder run

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StairsWinderGenLayoutFailure { get; }
Public Shared ReadOnly Property StairsWinderGenLayoutFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StairsWinderGenLayoutFailure {
    FailureDefinitionId^ get ();
}
static member StairsWinderGenLayoutFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.StairsWinderInvalidParamsFailure Property

BuiltInFailuresStairRampFailuresStairsWinderInvalidParamsFailure Property

Cannot create the winder run because some values for the instance properties cannot be satisfied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StairsWinderInvalidParamsFailure { get; }
Public Shared ReadOnly Property StairsWinderInvalidParamsFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StairsWinderInvalidParamsFailure {
    FailureDefinitionId^ get ();
}
static member StairsWinderInvalidParamsFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.StairsZeroDesiredRisers Property

BuiltInFailuresStairRampFailuresStairsZeroDesiredRisers Property

The number of desired risers for a staircase cannot be 0.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StairsZeroDesiredRisers { get; }
Public Shared ReadOnly Property StairsZeroDesiredRisers As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StairsZeroDesiredRisers {
    FailureDefinitionId^ get ();
}
static member StairsZeroDesiredRisers : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.StringerCurvesNotSplitStairs Property

BuiltInFailuresStairRampFailuresStringerCurvesNotSplitStairs Property

The slope of stringer may not parallel runs and landings. To get a parallel stringer, split boundary lines at the ends of landings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StringerCurvesNotSplitStairs { get; }
Public Shared ReadOnly Property StringerCurvesNotSplitStairs As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StringerCurvesNotSplitStairs {
    FailureDefinitionId^ get ();
}
static member StringerCurvesNotSplitStairs : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.StringerCurveTooShort Property

BuiltInFailuresStairRampFailuresStringerCurveTooShort Property

A piece of boundary is too short to create stringer on it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StringerCurveTooShort { get; }
Public Shared ReadOnly Property StringerCurveTooShort As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StringerCurveTooShort {
    FailureDefinitionId^ get ();
}
static member StringerCurveTooShort : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.TooShortCurveDowngradeGeometry Property

BuiltInFailuresStairRampFailuresTooShortCurveDowngradeGeometry Property

Curve is too short and may downgrade the geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TooShortCurveDowngradeGeometry { get; }
Public Shared ReadOnly Property TooShortCurveDowngradeGeometry As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TooShortCurveDowngradeGeometry {
    FailureDefinitionId^ get ();
}
static member TooShortCurveDowngradeGeometry : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.TreadDepthBelowMin Property

BuiltInFailuresStairRampFailuresTreadDepthBelowMin Property

The Actual Tread Depth for one or more Stairs violates the Minimum Depth set in the type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TreadDepthBelowMin { get; }
Public Shared ReadOnly Property TreadDepthBelowMin As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TreadDepthBelowMin {
    FailureDefinitionId^ get ();
}
static member TreadDepthBelowMin : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.TreadDepthFailsEq Property

BuiltInFailuresStairRampFailuresTreadDepthFailsEq Property

The actual tread depth and riser height for one or more stairs of this type violates the stair equation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TreadDepthFailsEq { get; }
Public Shared ReadOnly Property TreadDepthFailsEq As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TreadDepthFailsEq {
    FailureDefinitionId^ get ();
}
static member TreadDepthFailsEq : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.TreadDepthTooBigFailure Property

BuiltInFailuresStairRampFailuresTreadDepthTooBigFailure Property

The tread depth is too large for the spiral run.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TreadDepthTooBigFailure { get; }
Public Shared ReadOnly Property TreadDepthTooBigFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TreadDepthTooBigFailure {
    FailureDefinitionId^ get ();
}
static member TreadDepthTooBigFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.TreadFrontProfileInvalid Property

BuiltInFailuresStairRampFailuresTreadFrontProfileInvalid Property

This profile cannot be used for the front of treads. Please choose a profile composed of a closed loop of lines with exactly one lines coincident with the y-axis. This lines will define the connection of this profile to the tread.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TreadFrontProfileInvalid { get; }
Public Shared ReadOnly Property TreadFrontProfileInvalid As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TreadFrontProfileInvalid {
    FailureDefinitionId^ get ();
}
static member TreadFrontProfileInvalid : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.UnableToCreateMultistoryStairs Property

BuiltInFailuresStairRampFailuresUnableToCreateMultistoryStairs Property

Unable to create Multistory stairs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnableToCreateMultistoryStairs { get; }
Public Shared ReadOnly Property UnableToCreateMultistoryStairs As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnableToCreateMultistoryStairs {
    FailureDefinitionId^ get ();
}
static member UnableToCreateMultistoryStairs : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.UnexpectedCurveIntersectionFailure Property

BuiltInFailuresStairRampFailuresUnexpectedCurveIntersectionFailure Property

Computing curve intersection and find the invalid result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnexpectedCurveIntersectionFailure { get; }
Public Shared ReadOnly Property UnexpectedCurveIntersectionFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnexpectedCurveIntersectionFailure {
    FailureDefinitionId^ get ();
}
static member UnexpectedCurveIntersectionFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.WinderFilletRadiusTooLargeFailure Property

BuiltInFailuresStairRampFailuresWinderFilletRadiusTooLargeFailure Property

The value for Fillet Radius is too large to satisfy the Minimum Inside Width value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WinderFilletRadiusTooLargeFailure { get; }
Public Shared ReadOnly Property WinderFilletRadiusTooLargeFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WinderFilletRadiusTooLargeFailure {
    FailureDefinitionId^ get ();
}
static member WinderFilletRadiusTooLargeFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.WinderFirstLegTooShortOrRunWidthTooGreatFailure Property

BuiltInFailuresStairRampFailuresWinderFirstLegTooShortOrRunWidthTooGreatFailure Property

The first leg of winder run is too short or the runwidth is too great.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WinderFirstLegTooShortOrRunWidthTooGreatFailure { get; }
Public Shared ReadOnly Property WinderFirstLegTooShortOrRunWidthTooGreatFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WinderFirstLegTooShortOrRunWidthTooGreatFailure {
    FailureDefinitionId^ get ();
}
static member WinderFirstLegTooShortOrRunWidthTooGreatFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.WinderGenericError Property

BuiltInFailuresStairRampFailuresWinderGenericError Property

Cannot make winder.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WinderGenericError { get; }
Public Shared ReadOnly Property WinderGenericError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WinderGenericError {
    FailureDefinitionId^ get ();
}
static member WinderGenericError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.WinderLegIsTooShortFailure Property

BuiltInFailuresStairRampFailuresWinderLegIsTooShortFailure Property

A winder leg is too short.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WinderLegIsTooShortFailure { get; }
Public Shared ReadOnly Property WinderLegIsTooShortFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WinderLegIsTooShortFailure {
    FailureDefinitionId^ get ();
}
static member WinderLegIsTooShortFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.WinderLegsAngleTooGreatOrRunWidthTooSmallFailure Property

BuiltInFailuresStairRampFailuresWinderLegsAngleTooGreatOrRunWidthTooSmallFailure Property

The angle between two consecutive legs are too great or the runwidth is too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WinderLegsAngleTooGreatOrRunWidthTooSmallFailure { get; }
Public Shared ReadOnly Property WinderLegsAngleTooGreatOrRunWidthTooSmallFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WinderLegsAngleTooGreatOrRunWidthTooSmallFailure {
    FailureDefinitionId^ get ();
}
static member WinderLegsAngleTooGreatOrRunWidthTooSmallFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.WinderLegTooShortOrRunWidthTooGreatFailure Property

BuiltInFailuresStairRampFailuresWinderLegTooShortOrRunWidthTooGreatFailure Property

One leg of the winder run is too small or the runwidth is too great.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WinderLegTooShortOrRunWidthTooGreatFailure { get; }
Public Shared ReadOnly Property WinderLegTooShortOrRunWidthTooGreatFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WinderLegTooShortOrRunWidthTooGreatFailure {
    FailureDefinitionId^ get ();
}
static member WinderLegTooShortOrRunWidthTooGreatFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.WinderMinWidthTooLargeFailure Property

BuiltInFailuresStairRampFailuresWinderMinWidthTooLargeFailure Property

The value for Minimum Width on Inside Boundary is too large.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WinderMinWidthTooLargeFailure { get; }
Public Shared ReadOnly Property WinderMinWidthTooLargeFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WinderMinWidthTooLargeFailure {
    FailureDefinitionId^ get ();
}
static member WinderMinWidthTooLargeFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.WinderMinWidthTooLargeForParallelTreadsFailure Property

BuiltInFailuresStairRampFailuresWinderMinWidthTooLargeForParallelTreadsFailure Property

The value for Minimum Width on Inside Boundary is too large to satisfy the number of Parallel Treads at the Start or End as specified in the Run Instance properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WinderMinWidthTooLargeForParallelTreadsFailure { get; }
Public Shared ReadOnly Property WinderMinWidthTooLargeForParallelTreadsFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WinderMinWidthTooLargeForParallelTreadsFailure {
    FailureDefinitionId^ get ();
}
static member WinderMinWidthTooLargeForParallelTreadsFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.WinderParallelLegsFailure Property

BuiltInFailuresStairRampFailuresWinderParallelLegsFailure Property

Two consecutive legs are parallel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WinderParallelLegsFailure { get; }
Public Shared ReadOnly Property WinderParallelLegsFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WinderParallelLegsFailure {
    FailureDefinitionId^ get ();
}
static member WinderParallelLegsFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.WinderParallelTreadsNumberFailure Property

BuiltInFailuresStairRampFailuresWinderParallelTreadsNumberFailure Property

Cannot satisfy the number of Parallel Treads at the Start or End as specified in the Run Instance properties

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WinderParallelTreadsNumberFailure { get; }
Public Shared ReadOnly Property WinderParallelTreadsNumberFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WinderParallelTreadsNumberFailure {
    FailureDefinitionId^ get ();
}
static member WinderParallelTreadsNumberFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.WinderRunCreationFailure Property

BuiltInFailuresStairRampFailuresWinderRunCreationFailure Property

The relationship between the current values of Actual Run Width, Minimum Width at Inside Boundary, and Parallel Treads at Start or End does not support the creation of the winder run.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WinderRunCreationFailure { get; }
Public Shared ReadOnly Property WinderRunCreationFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WinderRunCreationFailure {
    FailureDefinitionId^ get ();
}
static member WinderRunCreationFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.WinderRunInsideMinTreadDepthFailure Property

BuiltInFailuresStairRampFailuresWinderRunInsideMinTreadDepthFailure Property

Please enter a positive value less than Actual Tread Depth on Stair Path (%Actual Tread Depth%).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WinderRunInsideMinTreadDepthFailure { get; }
Public Shared ReadOnly Property WinderRunInsideMinTreadDepthFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WinderRunInsideMinTreadDepthFailure {
    FailureDefinitionId^ get ();
}
static member WinderRunInsideMinTreadDepthFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.WinderRunInsideWalklineOffsetFailure Property

BuiltInFailuresStairRampFailuresWinderRunInsideWalklineOffsetFailure Property

Please enter a value between 0 and half of Actual Run Width (%1/2 Actual Run Width%).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WinderRunInsideWalklineOffsetFailure { get; }
Public Shared ReadOnly Property WinderRunInsideWalklineOffsetFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WinderRunInsideWalklineOffsetFailure {
    FailureDefinitionId^ get ();
}
static member WinderRunInsideWalklineOffsetFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.WinderRunWidthLessThan2TimesMinWidthFailure Property

BuiltInFailuresStairRampFailuresWinderRunWidthLessThan2TimesMinWidthFailure Property

The value for Minimum Width on Inside Boundary is too large to satisfy the number of Parallel Treads at the Start or End as specified in the Run Instance properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WinderRunWidthLessThan2TimesMinWidthFailure { get; }
Public Shared ReadOnly Property WinderRunWidthLessThan2TimesMinWidthFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WinderRunWidthLessThan2TimesMinWidthFailure {
    FailureDefinitionId^ get ();
}
static member WinderRunWidthLessThan2TimesMinWidthFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.WinderRunWidthLessThanWalkLineOffsetFailure Property

BuiltInFailuresStairRampFailuresWinderRunWidthLessThanWalkLineOffsetFailure Property

The value for Run Width is less than two times of value of the inside walkline offset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WinderRunWidthLessThanWalkLineOffsetFailure { get; }
Public Shared ReadOnly Property WinderRunWidthLessThanWalkLineOffsetFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WinderRunWidthLessThanWalkLineOffsetFailure {
    FailureDefinitionId^ get ();
}
static member WinderRunWidthLessThanWalkLineOffsetFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.WinderRunWidthOrMinWidthOrTooGreatParallelTreadsFailure Property

BuiltInFailuresStairRampFailuresWinderRunWidthOrMinWidthOrTooGreatParallelTreadsFailure Property

The parameter runwidth is great or the parameter min width at inside boundary is too great, or number of parallel treads at both ends is too great.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WinderRunWidthOrMinWidthOrTooGreatParallelTreadsFailure { get; }
Public Shared ReadOnly Property WinderRunWidthOrMinWidthOrTooGreatParallelTreadsFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WinderRunWidthOrMinWidthOrTooGreatParallelTreadsFailure {
    FailureDefinitionId^ get ();
}
static member WinderRunWidthOrMinWidthOrTooGreatParallelTreadsFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.WinderRunWidthOrMinWidthOrTooShortFailure Property

BuiltInFailuresStairRampFailuresWinderRunWidthOrMinWidthOrTooShortFailure Property

The parameter runwidth is too great or the parameter min width at inside boundary is too great, or one leg of winder run is too short.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WinderRunWidthOrMinWidthOrTooShortFailure { get; }
Public Shared ReadOnly Property WinderRunWidthOrMinWidthOrTooShortFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WinderRunWidthOrMinWidthOrTooShortFailure {
    FailureDefinitionId^ get ();
}
static member WinderRunWidthOrMinWidthOrTooShortFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.WinderSecondLegTooShortOrRunwidthTooGreatFailure Property

BuiltInFailuresStairRampFailuresWinderSecondLegTooShortOrRunwidthTooGreatFailure Property

The second leg of winder run is too short or the runwidth is too great.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WinderSecondLegTooShortOrRunwidthTooGreatFailure { get; }
Public Shared ReadOnly Property WinderSecondLegTooShortOrRunwidthTooGreatFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WinderSecondLegTooShortOrRunwidthTooGreatFailure {
    FailureDefinitionId^ get ();
}
static member WinderSecondLegTooShortOrRunwidthTooGreatFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.WinderStraightStepsNumberFailure Property

BuiltInFailuresStairRampFailuresWinderStraightStepsNumberFailure Property

The current layout cannot allow the specified number of treads. Increase the length of the run leg in the model or reduce the value for Parallel Treads at Start or Parallel Treads at End.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WinderStraightStepsNumberFailure { get; }
Public Shared ReadOnly Property WinderStraightStepsNumberFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WinderStraightStepsNumberFailure {
    FailureDefinitionId^ get ();
}
static member WinderStraightStepsNumberFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.WinderThirdLegTooShortOrRunWidthTooGreatFailure Property

BuiltInFailuresStairRampFailuresWinderThirdLegTooShortOrRunWidthTooGreatFailure Property

The third leg of winder run is too short or the runwidth is too great.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WinderThirdLegTooShortOrRunWidthTooGreatFailure { get; }
Public Shared ReadOnly Property WinderThirdLegTooShortOrRunWidthTooGreatFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WinderThirdLegTooShortOrRunWidthTooGreatFailure {
    FailureDefinitionId^ get ();
}
static member WinderThirdLegTooShortOrRunWidthTooGreatFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.WinderTooManyEndParallelTreadsOrRunWidthFailure Property

BuiltInFailuresStairRampFailuresWinderTooManyEndParallelTreadsOrRunWidthFailure Property

The number of parallel treads at end is too great or the run width is too great.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WinderTooManyEndParallelTreadsOrRunWidthFailure { get; }
Public Shared ReadOnly Property WinderTooManyEndParallelTreadsOrRunWidthFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WinderTooManyEndParallelTreadsOrRunWidthFailure {
    FailureDefinitionId^ get ();
}
static member WinderTooManyEndParallelTreadsOrRunWidthFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.WinderTooManyParallelTreadsAtEndFailure Property

BuiltInFailuresStairRampFailuresWinderTooManyParallelTreadsAtEndFailure Property

The number of parallel treads at end is too great.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WinderTooManyParallelTreadsAtEndFailure { get; }
Public Shared ReadOnly Property WinderTooManyParallelTreadsAtEndFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WinderTooManyParallelTreadsAtEndFailure {
    FailureDefinitionId^ get ();
}
static member WinderTooManyParallelTreadsAtEndFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.WinderTooManyParallelTreadsAtHeadFailure Property

BuiltInFailuresStairRampFailuresWinderTooManyParallelTreadsAtHeadFailure Property

The number of parallel treads at start is too great.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WinderTooManyParallelTreadsAtHeadFailure { get; }
Public Shared ReadOnly Property WinderTooManyParallelTreadsAtHeadFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WinderTooManyParallelTreadsAtHeadFailure {
    FailureDefinitionId^ get ();
}
static member WinderTooManyParallelTreadsAtHeadFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.StairRampFailures.WinderTooManyStartParallelTreadsOrRunWidthFailure Property

BuiltInFailuresStairRampFailuresWinderTooManyStartParallelTreadsOrRunWidthFailure Property

The number of parallel treads at start is too great or the run width is too great.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WinderTooManyStartParallelTreadsOrRunWidthFailure { get; }
Public Shared ReadOnly Property WinderTooManyStartParallelTreadsOrRunWidthFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WinderTooManyStartParallelTreadsOrRunWidthFailure {
    FailureDefinitionId^ get ();
}
static member WinderTooManyStartParallelTreadsOrRunWidthFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStairRampFailures Class


BuiltInFailures.SteelElementFailures Class

BuiltInFailuresSteelElementFailures Class

Failures about steel elements
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresSteelElementFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class SteelElementFailures
Public NotInheritable Class SteelElementFailures
public ref class SteelElementFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SteelElementFailures = class end

The BuiltInFailuresSteelElementFailures type exposes the following members.

Properties
Name | Description
SteelElementModifyParametersTaskNotFinished | Cannot modify parameters while background calculations are in progress.
SteelElementModifyRangesTaskNotFinished | Cannot modify ranges while background calculations are in progress.
SteelElementPreviewTaskNotFinished | Cannot create preview while background calculations are in progress.
SteelElementPropagationTaskNotFinished | Advance Steel propagation tasks not finished.
SteelElementTaskNotFinished | Advance Steel tasks not finished.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SteelElementFailures Properties

The BuiltInFailuresSteelElementFailures type exposes the following members.

Properties
Name | Description
SteelElementModifyParametersTaskNotFinished | Cannot modify parameters while background calculations are in progress.
SteelElementModifyRangesTaskNotFinished | Cannot modify ranges while background calculations are in progress.
SteelElementPreviewTaskNotFinished | Cannot create preview while background calculations are in progress.
SteelElementPropagationTaskNotFinished | Advance Steel propagation tasks not finished.
SteelElementTaskNotFinished | Advance Steel tasks not finished.
Top
See Also

Reference

BuiltInFailuresSteelElementFailures Class


BuiltInFailures.SteelElementFailures.SteelElementModifyParametersTaskNotFinished Property

BuiltInFailuresSteelElementFailuresSteelElementModifyParametersTaskNotFinished Property

Cannot modify parameters while background calculations are in progress.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SteelElementModifyParametersTaskNotFinished { get; }
Public Shared ReadOnly Property SteelElementModifyParametersTaskNotFinished As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SteelElementModifyParametersTaskNotFinished {
    FailureDefinitionId^ get ();
}
static member SteelElementModifyParametersTaskNotFinished : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSteelElementFailures Class


BuiltInFailures.SteelElementFailures.SteelElementModifyRangesTaskNotFinished Property

BuiltInFailuresSteelElementFailuresSteelElementModifyRangesTaskNotFinished Property

Cannot modify ranges while background calculations are in progress.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SteelElementModifyRangesTaskNotFinished { get; }
Public Shared ReadOnly Property SteelElementModifyRangesTaskNotFinished As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SteelElementModifyRangesTaskNotFinished {
    FailureDefinitionId^ get ();
}
static member SteelElementModifyRangesTaskNotFinished : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSteelElementFailures Class


BuiltInFailures.SteelElementFailures.SteelElementPreviewTaskNotFinished Property

BuiltInFailuresSteelElementFailuresSteelElementPreviewTaskNotFinished Property

Cannot create preview while background calculations are in progress.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SteelElementPreviewTaskNotFinished { get; }
Public Shared ReadOnly Property SteelElementPreviewTaskNotFinished As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SteelElementPreviewTaskNotFinished {
    FailureDefinitionId^ get ();
}
static member SteelElementPreviewTaskNotFinished : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSteelElementFailures Class


BuiltInFailures.SteelElementFailures.SteelElementPropagationTaskNotFinished Property

BuiltInFailuresSteelElementFailuresSteelElementPropagationTaskNotFinished Property

Advance Steel propagation tasks not finished.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SteelElementPropagationTaskNotFinished { get; }
Public Shared ReadOnly Property SteelElementPropagationTaskNotFinished As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SteelElementPropagationTaskNotFinished {
    FailureDefinitionId^ get ();
}
static member SteelElementPropagationTaskNotFinished : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSteelElementFailures Class


BuiltInFailures.SteelElementFailures.SteelElementTaskNotFinished Property

BuiltInFailuresSteelElementFailuresSteelElementTaskNotFinished Property

Advance Steel tasks not finished.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SteelElementTaskNotFinished { get; }
Public Shared ReadOnly Property SteelElementTaskNotFinished As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SteelElementTaskNotFinished {
    FailureDefinitionId^ get ();
}
static member SteelElementTaskNotFinished : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSteelElementFailures Class


BuiltInFailures.SteelElementsFailures Class

BuiltInFailuresSteelElementsFailures Class

Failures about SteelElement module
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresSteelElementsFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class SteelElementsFailures
Public NotInheritable Class SteelElementsFailures
public ref class SteelElementsFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SteelElementsFailures = class end

The BuiltInFailuresSteelElementsFailures type exposes the following members.

Properties
Name | Description
SteelElementInvisibleInCurrentLevelOfDetailWarn | The created elements are only visible in Detail Level: Fine.
SteelElementModifiersWillBeIgnoredWarn | The copes and cuts (by face, with voids, by reference plane) of the element are no longer modifying the geometry.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SteelElementsFailures Properties

The BuiltInFailuresSteelElementsFailures type exposes the following members.

Properties
Name | Description
SteelElementInvisibleInCurrentLevelOfDetailWarn | The created elements are only visible in Detail Level: Fine.
SteelElementModifiersWillBeIgnoredWarn | The copes and cuts (by face, with voids, by reference plane) of the element are no longer modifying the geometry.
Top
See Also

Reference

BuiltInFailuresSteelElementsFailures Class


BuiltInFailures.SteelElementsFailures.SteelElementInvisibleInCurrentLevelOfDetailWarn Property

BuiltInFailuresSteelElementsFailuresSteelElementInvisibleInCurrentLevelOfDetailWarn Property

The created elements are only visible in Detail Level: Fine.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SteelElementInvisibleInCurrentLevelOfDetailWarn { get; }
Public Shared ReadOnly Property SteelElementInvisibleInCurrentLevelOfDetailWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SteelElementInvisibleInCurrentLevelOfDetailWarn {
    FailureDefinitionId^ get ();
}
static member SteelElementInvisibleInCurrentLevelOfDetailWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSteelElementsFailures Class


BuiltInFailures.SteelElementsFailures.SteelElementModifiersWillBeIgnoredWarn Property

BuiltInFailuresSteelElementsFailuresSteelElementModifiersWillBeIgnoredWarn Property

The copes and cuts (by face, with voids, by reference plane) of the element are no longer modifying the geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SteelElementModifiersWillBeIgnoredWarn { get; }
Public Shared ReadOnly Property SteelElementModifiersWillBeIgnoredWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SteelElementModifiersWillBeIgnoredWarn {
    FailureDefinitionId^ get ();
}
static member SteelElementModifiersWillBeIgnoredWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSteelElementsFailures Class


BuiltInFailures.StructuralAssetFailures Class

BuiltInFailuresStructuralAssetFailures Class

Failures related to structural materials.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresStructuralAssetFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class StructuralAssetFailures
Public NotInheritable Class StructuralAssetFailures
public ref class StructuralAssetFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type StructuralAssetFailures = class end

The BuiltInFailuresStructuralAssetFailures type exposes the following members.

Properties
Name | Description
StructuralMaterialAssetInvalid | Material assigned to the Analytical Element does not contain Structure parameters - verify material content.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


StructuralAssetFailures Properties

The BuiltInFailuresStructuralAssetFailures type exposes the following members.

Properties
Name | Description
StructuralMaterialAssetInvalid | Material assigned to the Analytical Element does not contain Structure parameters - verify material content.
Top
See Also

Reference

BuiltInFailuresStructuralAssetFailures Class


BuiltInFailures.StructuralAssetFailures.StructuralMaterialAssetInvalid Property

BuiltInFailuresStructuralAssetFailuresStructuralMaterialAssetInvalid Property

Material assigned to the Analytical Element does not contain Structure parameters - verify material content.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StructuralMaterialAssetInvalid { get; }
Public Shared ReadOnly Property StructuralMaterialAssetInvalid As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StructuralMaterialAssetInvalid {
    FailureDefinitionId^ get ();
}
static member StructuralMaterialAssetInvalid : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStructuralAssetFailures Class


BuiltInFailures.StructuralConnectionFailures Class

BuiltInFailuresStructuralConnectionFailures Class

Failures about StructuralConnectionHandler.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresStructuralConnectionFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class StructuralConnectionFailures
Public NotInheritable Class StructuralConnectionFailures
public ref class StructuralConnectionFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type StructuralConnectionFailures = class end

The BuiltInFailuresStructuralConnectionFailures type exposes the following members.

Properties
Name | Description
StructuralConnectionCannotGenerate | Could not create Structural Connection Handler
StructuralConnectionCannotReplaceRefs | Structural Connection cannot replace elements
StructuralConnectionForbiddenElementInGroup | Fabrication element can not be a group member.
StructuralConnectionNoSingleRef | Summary: Structural Connection Handler lost connected element.
StructuralConnectionNotEnoughRefs | Structural Connection Handler cannot connect fewer than two elements.
StructuralConnectionSetOfRefsChanged | The set of input elements was changed and the connection has been adjusted.
StructuralConnectionTooFarNotEnoughRefs | Structural Connection Handler cannot connect too far elements
StructuralConnectionTooFarRefs | Structural Connection Handler cannot connect too far elements
StructuralConnectionTypeChangedToGeneric | Structural Connection had an inappropriate type, which has been changed to 'Generic Connection'.
StructuralConnectionTypeInfoNotAvailable | There is no add-on installed which supports Structural Connection type.
StructuralConnectionWrongType | Structural Connection has an inappropriate type assigned.
StructuralSectionHasIncompleteDefinition | Structural Section has incomplete definition
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


StructuralConnectionFailures Properties

The BuiltInFailuresStructuralConnectionFailures type exposes the following members.

Properties
Name | Description
StructuralConnectionCannotGenerate | Could not create Structural Connection Handler
StructuralConnectionCannotReplaceRefs | Structural Connection cannot replace elements
StructuralConnectionForbiddenElementInGroup | Fabrication element can not be a group member.
StructuralConnectionNoSingleRef | Summary: Structural Connection Handler lost connected element.
StructuralConnectionNotEnoughRefs | Structural Connection Handler cannot connect fewer than two elements.
StructuralConnectionSetOfRefsChanged | The set of input elements was changed and the connection has been adjusted.
StructuralConnectionTooFarNotEnoughRefs | Structural Connection Handler cannot connect too far elements
StructuralConnectionTooFarRefs | Structural Connection Handler cannot connect too far elements
StructuralConnectionTypeChangedToGeneric | Structural Connection had an inappropriate type, which has been changed to 'Generic Connection'.
StructuralConnectionTypeInfoNotAvailable | There is no add-on installed which supports Structural Connection type.
StructuralConnectionWrongType | Structural Connection has an inappropriate type assigned.
StructuralSectionHasIncompleteDefinition | Structural Section has incomplete definition
Top
See Also

Reference

BuiltInFailuresStructuralConnectionFailures Class


BuiltInFailures.StructuralConnectionFailures.StructuralConnectionCannotGenerate Property

BuiltInFailuresStructuralConnectionFailuresStructuralConnectionCannotGenerate Property

Could not create Structural Connection Handler

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StructuralConnectionCannotGenerate { get; }
Public Shared ReadOnly Property StructuralConnectionCannotGenerate As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StructuralConnectionCannotGenerate {
    FailureDefinitionId^ get ();
}
static member StructuralConnectionCannotGenerate : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStructuralConnectionFailures Class


BuiltInFailures.StructuralConnectionFailures.StructuralConnectionCannotReplaceRefs Property

BuiltInFailuresStructuralConnectionFailuresStructuralConnectionCannotReplaceRefs Property

Structural Connection cannot replace elements

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StructuralConnectionCannotReplaceRefs { get; }
Public Shared ReadOnly Property StructuralConnectionCannotReplaceRefs As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StructuralConnectionCannotReplaceRefs {
    FailureDefinitionId^ get ();
}
static member StructuralConnectionCannotReplaceRefs : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStructuralConnectionFailures Class


BuiltInFailures.StructuralConnectionFailures.StructuralConnectionForbiddenElementInGroup Property

BuiltInFailuresStructuralConnectionFailuresStructuralConnectionForbiddenElementInGroup Property

Fabrication element can not be a group member.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StructuralConnectionForbiddenElementInGroup { get; }
Public Shared ReadOnly Property StructuralConnectionForbiddenElementInGroup As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StructuralConnectionForbiddenElementInGroup {
    FailureDefinitionId^ get ();
}
static member StructuralConnectionForbiddenElementInGroup : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStructuralConnectionFailures Class


BuiltInFailures.StructuralConnectionFailures.StructuralConnectionNoSingleRef Property

BuiltInFailuresStructuralConnectionFailuresStructuralConnectionNoSingleRef Property

Summary: Structural Connection Handler lost connected element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StructuralConnectionNoSingleRef { get; }
Public Shared ReadOnly Property StructuralConnectionNoSingleRef As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StructuralConnectionNoSingleRef {
    FailureDefinitionId^ get ();
}
static member StructuralConnectionNoSingleRef : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStructuralConnectionFailures Class


BuiltInFailures.StructuralConnectionFailures.StructuralConnectionNotEnoughRefs Property

BuiltInFailuresStructuralConnectionFailuresStructuralConnectionNotEnoughRefs Property

Structural Connection Handler cannot connect fewer than two elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StructuralConnectionNotEnoughRefs { get; }
Public Shared ReadOnly Property StructuralConnectionNotEnoughRefs As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StructuralConnectionNotEnoughRefs {
    FailureDefinitionId^ get ();
}
static member StructuralConnectionNotEnoughRefs : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStructuralConnectionFailures Class


BuiltInFailures.StructuralConnectionFailures.StructuralConnectionSetOfRefsChanged Property

BuiltInFailuresStructuralConnectionFailuresStructuralConnectionSetOfRefsChanged Property

The set of input elements was changed and the connection has been adjusted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StructuralConnectionSetOfRefsChanged { get; }
Public Shared ReadOnly Property StructuralConnectionSetOfRefsChanged As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StructuralConnectionSetOfRefsChanged {
    FailureDefinitionId^ get ();
}
static member StructuralConnectionSetOfRefsChanged : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStructuralConnectionFailures Class


BuiltInFailures.StructuralConnectionFailures.StructuralConnectionTooFarNotEnoughRefs Property

BuiltInFailuresStructuralConnectionFailuresStructuralConnectionTooFarNotEnoughRefs Property

Structural Connection Handler cannot connect too far elements

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StructuralConnectionTooFarNotEnoughRefs { get; }
Public Shared ReadOnly Property StructuralConnectionTooFarNotEnoughRefs As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StructuralConnectionTooFarNotEnoughRefs {
    FailureDefinitionId^ get ();
}
static member StructuralConnectionTooFarNotEnoughRefs : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStructuralConnectionFailures Class


BuiltInFailures.StructuralConnectionFailures.StructuralConnectionTooFarRefs Property

BuiltInFailuresStructuralConnectionFailuresStructuralConnectionTooFarRefs Property

Structural Connection Handler cannot connect too far elements

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StructuralConnectionTooFarRefs { get; }
Public Shared ReadOnly Property StructuralConnectionTooFarRefs As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StructuralConnectionTooFarRefs {
    FailureDefinitionId^ get ();
}
static member StructuralConnectionTooFarRefs : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStructuralConnectionFailures Class


BuiltInFailures.StructuralConnectionFailures.StructuralConnectionTypeChangedToGeneric Property

BuiltInFailuresStructuralConnectionFailuresStructuralConnectionTypeChangedToGeneric Property

Structural Connection had an inappropriate type, which has been changed to 'Generic Connection'.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StructuralConnectionTypeChangedToGeneric { get; }
Public Shared ReadOnly Property StructuralConnectionTypeChangedToGeneric As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StructuralConnectionTypeChangedToGeneric {
    FailureDefinitionId^ get ();
}
static member StructuralConnectionTypeChangedToGeneric : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStructuralConnectionFailures Class


BuiltInFailures.StructuralConnectionFailures.StructuralConnectionTypeInfoNotAvailable Property

BuiltInFailuresStructuralConnectionFailuresStructuralConnectionTypeInfoNotAvailable Property

There is no add-on installed which supports Structural Connection type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StructuralConnectionTypeInfoNotAvailable { get; }
Public Shared ReadOnly Property StructuralConnectionTypeInfoNotAvailable As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StructuralConnectionTypeInfoNotAvailable {
    FailureDefinitionId^ get ();
}
static member StructuralConnectionTypeInfoNotAvailable : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStructuralConnectionFailures Class


BuiltInFailures.StructuralConnectionFailures.StructuralConnectionWrongType Property

BuiltInFailuresStructuralConnectionFailuresStructuralConnectionWrongType Property

Structural Connection has an inappropriate type assigned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StructuralConnectionWrongType { get; }
Public Shared ReadOnly Property StructuralConnectionWrongType As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StructuralConnectionWrongType {
    FailureDefinitionId^ get ();
}
static member StructuralConnectionWrongType : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStructuralConnectionFailures Class


BuiltInFailures.StructuralConnectionFailures.StructuralSectionHasIncompleteDefinition Property

BuiltInFailuresStructuralConnectionFailuresStructuralSectionHasIncompleteDefinition Property

Structural Section has incomplete definition

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StructuralSectionHasIncompleteDefinition { get; }
Public Shared ReadOnly Property StructuralSectionHasIncompleteDefinition As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StructuralSectionHasIncompleteDefinition {
    FailureDefinitionId^ get ();
}
static member StructuralSectionHasIncompleteDefinition : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStructuralConnectionFailures Class


BuiltInFailures.StructuralCustomConnectionFailures Class

BuiltInFailuresStructuralCustomConnectionFailures Class

Failures about StructuralConnectionHandler.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresStructuralCustomConnectionFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class StructuralCustomConnectionFailures
Public NotInheritable Class StructuralCustomConnectionFailures
public ref class StructuralCustomConnectionFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type StructuralCustomConnectionFailures = class end

The BuiltInFailuresStructuralCustomConnectionFailures type exposes the following members.

Properties
Name | Description
SimpleConnectionTooFarRefs | Simple Structural Connection Handler cannot connect too far elements
StructuralCannotCreateCustomConnection | Could not create a custom connection.
StructuralCustomConnectionComponentsRelationship | Cannot create custom connection due to relationships to external elements.
StructuralCustomConnectionEmpty | Structural Custom Connection cannot be empty.
StructuralCustomConnectionWrongType | Structural Custom Connection has an inappropriate type assigned.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


StructuralCustomConnectionFailures Properties

The BuiltInFailuresStructuralCustomConnectionFailures type exposes the following members.

Properties
Name | Description
SimpleConnectionTooFarRefs | Simple Structural Connection Handler cannot connect too far elements
StructuralCannotCreateCustomConnection | Could not create a custom connection.
StructuralCustomConnectionComponentsRelationship | Cannot create custom connection due to relationships to external elements.
StructuralCustomConnectionEmpty | Structural Custom Connection cannot be empty.
StructuralCustomConnectionWrongType | Structural Custom Connection has an inappropriate type assigned.
Top
See Also

Reference

BuiltInFailuresStructuralCustomConnectionFailures Class


BuiltInFailures.StructuralCustomConnectionFailures.SimpleConnectionTooFarRefs Property

BuiltInFailuresStructuralCustomConnectionFailuresSimpleConnectionTooFarRefs Property

Simple Structural Connection Handler cannot connect too far elements

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SimpleConnectionTooFarRefs { get; }
Public Shared ReadOnly Property SimpleConnectionTooFarRefs As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SimpleConnectionTooFarRefs {
    FailureDefinitionId^ get ();
}
static member SimpleConnectionTooFarRefs : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStructuralCustomConnectionFailures Class


BuiltInFailures.StructuralCustomConnectionFailures.StructuralCannotCreateCustomConnection Property

BuiltInFailuresStructuralCustomConnectionFailuresStructuralCannotCreateCustomConnection Property

Could not create a custom connection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StructuralCannotCreateCustomConnection { get; }
Public Shared ReadOnly Property StructuralCannotCreateCustomConnection As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StructuralCannotCreateCustomConnection {
    FailureDefinitionId^ get ();
}
static member StructuralCannotCreateCustomConnection : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStructuralCustomConnectionFailures Class


BuiltInFailures.StructuralCustomConnectionFailures.StructuralCustomConnectionComponentsRelationship Property

BuiltInFailuresStructuralCustomConnectionFailuresStructuralCustomConnectionComponentsRelationship Property

Cannot create custom connection due to relationships to external elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StructuralCustomConnectionComponentsRelationship { get; }
Public Shared ReadOnly Property StructuralCustomConnectionComponentsRelationship As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StructuralCustomConnectionComponentsRelationship {
    FailureDefinitionId^ get ();
}
static member StructuralCustomConnectionComponentsRelationship : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStructuralCustomConnectionFailures Class


BuiltInFailures.StructuralCustomConnectionFailures.StructuralCustomConnectionEmpty Property

BuiltInFailuresStructuralCustomConnectionFailuresStructuralCustomConnectionEmpty Property

Structural Custom Connection cannot be empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StructuralCustomConnectionEmpty { get; }
Public Shared ReadOnly Property StructuralCustomConnectionEmpty As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StructuralCustomConnectionEmpty {
    FailureDefinitionId^ get ();
}
static member StructuralCustomConnectionEmpty : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStructuralCustomConnectionFailures Class


BuiltInFailures.StructuralCustomConnectionFailures.StructuralCustomConnectionWrongType Property

BuiltInFailuresStructuralCustomConnectionFailuresStructuralCustomConnectionWrongType Property

Structural Custom Connection has an inappropriate type assigned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StructuralCustomConnectionWrongType { get; }
Public Shared ReadOnly Property StructuralCustomConnectionWrongType As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StructuralCustomConnectionWrongType {
    FailureDefinitionId^ get ();
}
static member StructuralCustomConnectionWrongType : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStructuralCustomConnectionFailures Class


BuiltInFailures.StructuralLoadFailures Class

BuiltInFailuresStructuralLoadFailures Class

Failures about Load.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresStructuralLoadFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class StructuralLoadFailures
Public NotInheritable Class StructuralLoadFailures
public ref class StructuralLoadFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type StructuralLoadFailures = class end

The BuiltInFailuresStructuralLoadFailures type exposes the following members.

Properties
Name | Description
CannotMirrorBoundaryCondition | Can't mirror Boundary Conditions
CannotMoveBoundaryCondition | Can't move Boundary Conditions
CannotPlaceBoundaryConditions | A boundary condition is already created on the selected element. Duplicate boundary conditions are not allowed. Click the Replace button to delete previous definition of boundary condition or cancel the operation.
HostChangeDisallowsLoadOrBoundaryConditions | Some Hosted Loads or BoundaryConditions lost their References. They will be deleted.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


StructuralLoadFailures Properties

The BuiltInFailuresStructuralLoadFailures type exposes the following members.

Properties
Name | Description
CannotMirrorBoundaryCondition | Can't mirror Boundary Conditions
CannotMoveBoundaryCondition | Can't move Boundary Conditions
CannotPlaceBoundaryConditions | A boundary condition is already created on the selected element. Duplicate boundary conditions are not allowed. Click the Replace button to delete previous definition of boundary condition or cancel the operation.
HostChangeDisallowsLoadOrBoundaryConditions | Some Hosted Loads or BoundaryConditions lost their References. They will be deleted.
Top
See Also

Reference

BuiltInFailuresStructuralLoadFailures Class


BuiltInFailures.StructuralLoadFailures.CannotMirrorBoundaryCondition Property

BuiltInFailuresStructuralLoadFailuresCannotMirrorBoundaryCondition Property

Can't mirror Boundary Conditions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotMirrorBoundaryCondition { get; }
Public Shared ReadOnly Property CannotMirrorBoundaryCondition As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotMirrorBoundaryCondition {
    FailureDefinitionId^ get ();
}
static member CannotMirrorBoundaryCondition : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStructuralLoadFailures Class


BuiltInFailures.StructuralLoadFailures.CannotMoveBoundaryCondition Property

BuiltInFailuresStructuralLoadFailuresCannotMoveBoundaryCondition Property

Can't move Boundary Conditions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotMoveBoundaryCondition { get; }
Public Shared ReadOnly Property CannotMoveBoundaryCondition As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotMoveBoundaryCondition {
    FailureDefinitionId^ get ();
}
static member CannotMoveBoundaryCondition : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStructuralLoadFailures Class


BuiltInFailures.StructuralLoadFailures.CannotPlaceBoundaryConditions Property

BuiltInFailuresStructuralLoadFailuresCannotPlaceBoundaryConditions Property

A boundary condition is already created on the selected element. Duplicate boundary conditions are not allowed. Click the Replace button to delete previous definition of boundary condition or cancel the operation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPlaceBoundaryConditions { get; }
Public Shared ReadOnly Property CannotPlaceBoundaryConditions As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPlaceBoundaryConditions {
    FailureDefinitionId^ get ();
}
static member CannotPlaceBoundaryConditions : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStructuralLoadFailures Class


BuiltInFailures.StructuralLoadFailures.HostChangeDisallowsLoadOrBoundaryConditions Property

BuiltInFailuresStructuralLoadFailuresHostChangeDisallowsLoadOrBoundaryConditions Property

Some Hosted Loads or BoundaryConditions lost their References. They will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId HostChangeDisallowsLoadOrBoundaryConditions { get; }
Public Shared ReadOnly Property HostChangeDisallowsLoadOrBoundaryConditions As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ HostChangeDisallowsLoadOrBoundaryConditions {
    FailureDefinitionId^ get ();
}
static member HostChangeDisallowsLoadOrBoundaryConditions : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresStructuralLoadFailures Class


BuiltInFailures.SubRegionFailures Class

BuiltInFailuresSubRegionFailures Class

Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresSubRegionFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class SubRegionFailures
Public NotInheritable Class SubRegionFailures
public ref class SubRegionFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SubRegionFailures = class end

The BuiltInFailuresSubRegionFailures type exposes the following members.

Properties
Name | Description
CreateSubRegionFailed | Create sub-division failed.
NoHostForToposolidSubregion | This sub-division now does not appear to overlap any Toposolid with an appropriate Phase and Design Option.
SubDivisionPhaseMismatch | Sub-division must have the same Phase Created parameter and Phase Demolished parameter as the host Toposolid. Sub-division phase will be set to match the Toposolid.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SubRegionFailures Properties

The BuiltInFailuresSubRegionFailures type exposes the following members.

Properties
Name | Description
CreateSubRegionFailed | Create sub-division failed.
NoHostForToposolidSubregion | This sub-division now does not appear to overlap any Toposolid with an appropriate Phase and Design Option.
SubDivisionPhaseMismatch | Sub-division must have the same Phase Created parameter and Phase Demolished parameter as the host Toposolid. Sub-division phase will be set to match the Toposolid.
Top
See Also

Reference

BuiltInFailuresSubRegionFailures Class


BuiltInFailures.SubRegionFailures.CreateSubRegionFailed Property

BuiltInFailuresSubRegionFailuresCreateSubRegionFailed Property

Create sub-division failed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CreateSubRegionFailed { get; }
Public Shared ReadOnly Property CreateSubRegionFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CreateSubRegionFailed {
    FailureDefinitionId^ get ();
}
static member CreateSubRegionFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSubRegionFailures Class


BuiltInFailures.SubRegionFailures.NoHostForToposolidSubregion Property

BuiltInFailuresSubRegionFailuresNoHostForToposolidSubregion Property

This sub-division now does not appear to overlap any Toposolid with an appropriate Phase and Design Option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoHostForToposolidSubregion { get; }
Public Shared ReadOnly Property NoHostForToposolidSubregion As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoHostForToposolidSubregion {
    FailureDefinitionId^ get ();
}
static member NoHostForToposolidSubregion : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSubRegionFailures Class


BuiltInFailures.SubRegionFailures.SubDivisionPhaseMismatch Property

BuiltInFailuresSubRegionFailuresSubDivisionPhaseMismatch Property

Sub-division must have the same Phase Created parameter and Phase Demolished parameter as the host Toposolid. Sub-division phase will be set to match the Toposolid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SubDivisionPhaseMismatch { get; }
Public Shared ReadOnly Property SubDivisionPhaseMismatch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SubDivisionPhaseMismatch {
    FailureDefinitionId^ get ();
}
static member SubDivisionPhaseMismatch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSubRegionFailures Class


BuiltInFailures.SweepFailures Class

BuiltInFailuresSweepFailures Class

Failures about Sweep.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresSweepFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class SweepFailures
Public NotInheritable Class SweepFailures
public ref class SweepFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SweepFailures = class end

The BuiltInFailuresSweepFailures type exposes the following members.

Properties
Name | Description
CannotDrawSweep | Can't create sweep.
ComplexPathWithComplexProfile | Sweep cannot have a path with ellipse or spline segments and a profile with non-straight lines.
ProfileLoopEmpty | Profile sketch is empty!
SweepFailed | Proper sweep geometry creation failed.
SweepFailedError | Proper sweep geometry creation failed.
WallSweepInconsistent | The model contains corrupt elements. Delete the corrupt elements to proceed or cancel the action without deleting the elements.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SweepFailures Properties

The BuiltInFailuresSweepFailures type exposes the following members.

Properties
Name | Description
CannotDrawSweep | Can't create sweep.
ComplexPathWithComplexProfile | Sweep cannot have a path with ellipse or spline segments and a profile with non-straight lines.
ProfileLoopEmpty | Profile sketch is empty!
SweepFailed | Proper sweep geometry creation failed.
SweepFailedError | Proper sweep geometry creation failed.
WallSweepInconsistent | The model contains corrupt elements. Delete the corrupt elements to proceed or cancel the action without deleting the elements.
Top
See Also

Reference

BuiltInFailuresSweepFailures Class


BuiltInFailures.SweepFailures.CannotDrawSweep Property

BuiltInFailuresSweepFailuresCannotDrawSweep Property

Can't create sweep.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotDrawSweep { get; }
Public Shared ReadOnly Property CannotDrawSweep As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotDrawSweep {
    FailureDefinitionId^ get ();
}
static member CannotDrawSweep : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSweepFailures Class


BuiltInFailures.SweepFailures.ComplexPathWithComplexProfile Property

BuiltInFailuresSweepFailuresComplexPathWithComplexProfile Property

Sweep cannot have a path with ellipse or spline segments and a profile with non-straight lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ComplexPathWithComplexProfile { get; }
Public Shared ReadOnly Property ComplexPathWithComplexProfile As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ComplexPathWithComplexProfile {
    FailureDefinitionId^ get ();
}
static member ComplexPathWithComplexProfile : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSweepFailures Class


BuiltInFailures.SweepFailures.ProfileLoopEmpty Property

BuiltInFailuresSweepFailuresProfileLoopEmpty Property

Profile sketch is empty!

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ProfileLoopEmpty { get; }
Public Shared ReadOnly Property ProfileLoopEmpty As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ProfileLoopEmpty {
    FailureDefinitionId^ get ();
}
static member ProfileLoopEmpty : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSweepFailures Class


BuiltInFailures.SweepFailures.SweepFailed Property

BuiltInFailuresSweepFailuresSweepFailed Property

Proper sweep geometry creation failed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SweepFailed { get; }
Public Shared ReadOnly Property SweepFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SweepFailed {
    FailureDefinitionId^ get ();
}
static member SweepFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSweepFailures Class


BuiltInFailures.SweepFailures.SweepFailedError Property

BuiltInFailuresSweepFailuresSweepFailedError Property

Proper sweep geometry creation failed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SweepFailedError { get; }
Public Shared ReadOnly Property SweepFailedError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SweepFailedError {
    FailureDefinitionId^ get ();
}
static member SweepFailedError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSweepFailures Class


BuiltInFailures.SweepFailures.WallSweepInconsistent Property

BuiltInFailuresSweepFailuresWallSweepInconsistent Property

The model contains corrupt elements. Delete the corrupt elements to proceed or cancel the action without deleting the elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WallSweepInconsistent { get; }
Public Shared ReadOnly Property WallSweepInconsistent As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WallSweepInconsistent {
    FailureDefinitionId^ get ();
}
static member WallSweepInconsistent : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSweepFailures Class


BuiltInFailures.SweptBlendFailures Class

BuiltInFailuresSweptBlendFailures Class

Failures about SweptBlend.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresSweptBlendFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class SweptBlendFailures
Public NotInheritable Class SweptBlendFailures
public ref class SweptBlendFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SweptBlendFailures = class end

The BuiltInFailuresSweptBlendFailures type exposes the following members.

Properties
Name | Description
CannotDrawSweptblend | Can't create swept blend.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SweptBlendFailures Properties

The BuiltInFailuresSweptBlendFailures type exposes the following members.

Properties
Name | Description
CannotDrawSweptblend | Can't create swept blend.
Top
See Also

Reference

BuiltInFailuresSweptBlendFailures Class


BuiltInFailures.SweptBlendFailures.CannotDrawSweptblend Property

BuiltInFailuresSweptBlendFailuresCannotDrawSweptblend Property

Can't create swept blend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotDrawSweptblend { get; }
Public Shared ReadOnly Property CannotDrawSweptblend As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotDrawSweptblend {
    FailureDefinitionId^ get ();
}
static member CannotDrawSweptblend : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSweptBlendFailures Class


BuiltInFailures.SystemNavigatorFailures Class

BuiltInFailuresSystemNavigatorFailures Class

Failures related with the system browser.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresSystemNavigatorFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class SystemNavigatorFailures
Public NotInheritable Class SystemNavigatorFailures
public ref class SystemNavigatorFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SystemNavigatorFailures = class end

The BuiltInFailuresSystemNavigatorFailures type exposes the following members.

Properties
Name | Description
CannottFindCorrectTreeNode | Can't find the correct tree node in system browser according to the node index.
MultipleSelectNumberIsWrong | The selected tree nodes number of system browser is wrong.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SystemNavigatorFailures Properties

The BuiltInFailuresSystemNavigatorFailures type exposes the following members.

Properties
Name | Description
CannottFindCorrectTreeNode | Can't find the correct tree node in system browser according to the node index.
MultipleSelectNumberIsWrong | The selected tree nodes number of system browser is wrong.
Top
See Also

Reference

BuiltInFailuresSystemNavigatorFailures Class


BuiltInFailures.SystemNavigatorFailures.CannottFindCorrectTreeNode Property

BuiltInFailuresSystemNavigatorFailuresCannottFindCorrectTreeNode Property

Can't find the correct tree node in system browser according to the node index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannottFindCorrectTreeNode { get; }
Public Shared ReadOnly Property CannottFindCorrectTreeNode As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannottFindCorrectTreeNode {
    FailureDefinitionId^ get ();
}
static member CannottFindCorrectTreeNode : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSystemNavigatorFailures Class


BuiltInFailures.SystemNavigatorFailures.MultipleSelectNumberIsWrong Property

BuiltInFailuresSystemNavigatorFailuresMultipleSelectNumberIsWrong Property

The selected tree nodes number of system browser is wrong.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MultipleSelectNumberIsWrong { get; }
Public Shared ReadOnly Property MultipleSelectNumberIsWrong As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MultipleSelectNumberIsWrong {
    FailureDefinitionId^ get ();
}
static member MultipleSelectNumberIsWrong : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSystemNavigatorFailures Class


BuiltInFailures.SystemsFailures Class

BuiltInFailuresSystemsFailures Class

Failures about System.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresSystemsFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class SystemsFailures
Public NotInheritable Class SystemsFailures
public ref class SystemsFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SystemsFailures = class end

The BuiltInFailuresSystemsFailures type exposes the following members.

Properties
Name | Description
AddingOtherConnectedMembersToSystem | "You have selected elements that are connected to other elements. These elements will also be added to the System."
CircuitWorksetClosedWarning | The workset of the circuit is closed so the circuit path will not be displayed.
CreatePartsWithInvalidService | Parts were not created because a system's service is undefined.
CreatePartsWithInvalidSystem | Parts were not created because the element does not have a valid system.
CreatePartsWithoutDabasebase | Parts were not created because fabrication configuration is not available.
DefaultSystemOver50Elems | The default system "[Element Name]" is now over 50 elements. To improve performance, Revit is no longer calculating the critical path pressure drop and the more complex duct sizing has been disabled. If you want to use these features, you must define logical systems in the model instead of using the default system.
ElementsBelongToOtherSystem | You have selected elements that are already part of other Systems that have assigned Equipment. The elements you selected cannot be added to this System.
FamilyDoesntMatchSystemProperties | The family no longer matches the properties for the System. Disconnect the family from the System?
FamilyDoesntMatchSystemPropertiesWasDisconnected | The family no longer matches the properties for the System. Disconnect the family from the System?
MismatchSystemType | Cannot add [Element] to System. The System Type for the available connector does not match the System Type ([Type Name]) for the System.
PastePartsWithInvalidService | Parts were not pasted because fabrication configuration is not available or service is not valid in the type properties for the system.
SelectedElementsArePartOfOtherSystem | You have selected elements that are already part of other System. They will be removed from the original Systems and added to this one.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SystemsFailures Properties

The BuiltInFailuresSystemsFailures type exposes the following members.

Properties
Name | Description
AddingOtherConnectedMembersToSystem | "You have selected elements that are connected to other elements. These elements will also be added to the System."
CircuitWorksetClosedWarning | The workset of the circuit is closed so the circuit path will not be displayed.
CreatePartsWithInvalidService | Parts were not created because a system's service is undefined.
CreatePartsWithInvalidSystem | Parts were not created because the element does not have a valid system.
CreatePartsWithoutDabasebase | Parts were not created because fabrication configuration is not available.
DefaultSystemOver50Elems | The default system "[Element Name]" is now over 50 elements. To improve performance, Revit is no longer calculating the critical path pressure drop and the more complex duct sizing has been disabled. If you want to use these features, you must define logical systems in the model instead of using the default system.
ElementsBelongToOtherSystem | You have selected elements that are already part of other Systems that have assigned Equipment. The elements you selected cannot be added to this System.
FamilyDoesntMatchSystemProperties | The family no longer matches the properties for the System. Disconnect the family from the System?
FamilyDoesntMatchSystemPropertiesWasDisconnected | The family no longer matches the properties for the System. Disconnect the family from the System?
MismatchSystemType | Cannot add [Element] to System. The System Type for the available connector does not match the System Type ([Type Name]) for the System.
PastePartsWithInvalidService | Parts were not pasted because fabrication configuration is not available or service is not valid in the type properties for the system.
SelectedElementsArePartOfOtherSystem | You have selected elements that are already part of other System. They will be removed from the original Systems and added to this one.
Top
See Also

Reference

BuiltInFailuresSystemsFailures Class


BuiltInFailures.SystemsFailures.AddingOtherConnectedMembersToSystem Property

BuiltInFailuresSystemsFailuresAddingOtherConnectedMembersToSystem Property

"You have selected elements that are connected to other elements. These elements will also be added to the System."

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId AddingOtherConnectedMembersToSystem { get; }
Public Shared ReadOnly Property AddingOtherConnectedMembersToSystem As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ AddingOtherConnectedMembersToSystem {
    FailureDefinitionId^ get ();
}
static member AddingOtherConnectedMembersToSystem : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSystemsFailures Class


BuiltInFailures.SystemsFailures.CircuitWorksetClosedWarning Property

BuiltInFailuresSystemsFailuresCircuitWorksetClosedWarning Property

The workset of the circuit is closed so the circuit path will not be displayed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CircuitWorksetClosedWarning { get; }
Public Shared ReadOnly Property CircuitWorksetClosedWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CircuitWorksetClosedWarning {
    FailureDefinitionId^ get ();
}
static member CircuitWorksetClosedWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSystemsFailures Class


BuiltInFailures.SystemsFailures.CreatePartsWithInvalidService Property

BuiltInFailuresSystemsFailuresCreatePartsWithInvalidService Property

Parts were not created because a system's service is undefined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CreatePartsWithInvalidService { get; }
Public Shared ReadOnly Property CreatePartsWithInvalidService As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CreatePartsWithInvalidService {
    FailureDefinitionId^ get ();
}
static member CreatePartsWithInvalidService : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSystemsFailures Class


BuiltInFailures.SystemsFailures.CreatePartsWithInvalidSystem Property

BuiltInFailuresSystemsFailuresCreatePartsWithInvalidSystem Property

Parts were not created because the element does not have a valid system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CreatePartsWithInvalidSystem { get; }
Public Shared ReadOnly Property CreatePartsWithInvalidSystem As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CreatePartsWithInvalidSystem {
    FailureDefinitionId^ get ();
}
static member CreatePartsWithInvalidSystem : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSystemsFailures Class


BuiltInFailures.SystemsFailures.CreatePartsWithoutDabasebase Property

BuiltInFailuresSystemsFailuresCreatePartsWithoutDabasebase Property

Parts were not created because fabrication configuration is not available.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CreatePartsWithoutDabasebase { get; }
Public Shared ReadOnly Property CreatePartsWithoutDabasebase As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CreatePartsWithoutDabasebase {
    FailureDefinitionId^ get ();
}
static member CreatePartsWithoutDabasebase : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSystemsFailures Class


BuiltInFailures.SystemsFailures.DefaultSystemOver50Elems Property

BuiltInFailuresSystemsFailuresDefaultSystemOver50Elems Property

The default system "[Element Name]" is now over 50 elements. To improve performance, Revit is no longer calculating the critical path pressure drop and the more complex duct sizing has been disabled. If you want to use these features, you must define logical systems in the model instead of using the default system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DefaultSystemOver50Elems { get; }
Public Shared ReadOnly Property DefaultSystemOver50Elems As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DefaultSystemOver50Elems {
    FailureDefinitionId^ get ();
}
static member DefaultSystemOver50Elems : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSystemsFailures Class


BuiltInFailures.SystemsFailures.ElementsBelongToOtherSystem Property

BuiltInFailuresSystemsFailuresElementsBelongToOtherSystem Property

You have selected elements that are already part of other Systems that have assigned Equipment. The elements you selected cannot be added to this System.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ElementsBelongToOtherSystem { get; }
Public Shared ReadOnly Property ElementsBelongToOtherSystem As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ElementsBelongToOtherSystem {
    FailureDefinitionId^ get ();
}
static member ElementsBelongToOtherSystem : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSystemsFailures Class


BuiltInFailures.SystemsFailures.FamilyDoesntMatchSystemProperties Property

BuiltInFailuresSystemsFailuresFamilyDoesntMatchSystemProperties Property

The family no longer matches the properties for the System. Disconnect the family from the System?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FamilyDoesntMatchSystemProperties { get; }
Public Shared ReadOnly Property FamilyDoesntMatchSystemProperties As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FamilyDoesntMatchSystemProperties {
    FailureDefinitionId^ get ();
}
static member FamilyDoesntMatchSystemProperties : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSystemsFailures Class


BuiltInFailures.SystemsFailures.FamilyDoesntMatchSystemPropertiesWasDisconnected Property

BuiltInFailuresSystemsFailuresFamilyDoesntMatchSystemPropertiesWasDisconnected Property

The family no longer matches the properties for the System. Disconnect the family from the System?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FamilyDoesntMatchSystemPropertiesWasDisconnected { get; }
Public Shared ReadOnly Property FamilyDoesntMatchSystemPropertiesWasDisconnected As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FamilyDoesntMatchSystemPropertiesWasDisconnected {
    FailureDefinitionId^ get ();
}
static member FamilyDoesntMatchSystemPropertiesWasDisconnected : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSystemsFailures Class


BuiltInFailures.SystemsFailures.MismatchSystemType Property

BuiltInFailuresSystemsFailuresMismatchSystemType Property

Cannot add [Element] to System. The System Type for the available connector does not match the System Type ([Type Name]) for the System.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MismatchSystemType { get; }
Public Shared ReadOnly Property MismatchSystemType As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MismatchSystemType {
    FailureDefinitionId^ get ();
}
static member MismatchSystemType : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSystemsFailures Class


BuiltInFailures.SystemsFailures.PastePartsWithInvalidService Property

BuiltInFailuresSystemsFailuresPastePartsWithInvalidService Property

Parts were not pasted because fabrication configuration is not available or service is not valid in the type properties for the system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId PastePartsWithInvalidService { get; }
Public Shared ReadOnly Property PastePartsWithInvalidService As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ PastePartsWithInvalidService {
    FailureDefinitionId^ get ();
}
static member PastePartsWithInvalidService : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSystemsFailures Class


BuiltInFailures.SystemsFailures.SelectedElementsArePartOfOtherSystem Property

BuiltInFailuresSystemsFailuresSelectedElementsArePartOfOtherSystem Property

You have selected elements that are already part of other System. They will be removed from the original Systems and added to this one.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SelectedElementsArePartOfOtherSystem { get; }
Public Shared ReadOnly Property SelectedElementsArePartOfOtherSystem As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SelectedElementsArePartOfOtherSystem {
    FailureDefinitionId^ get ();
}
static member SelectedElementsArePartOfOtherSystem : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresSystemsFailures Class


BuiltInFailures.TagFailures Class

BuiltInFailuresTagFailures Class

Failures about Tag.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresTagFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class TagFailures
Public NotInheritable Class TagFailures
public ref class TagFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type TagFailures = class end

The BuiltInFailuresTagFailures type exposes the following members.

Properties
Name | Description
CannotCopyTag | A tag cannot be arrayed without copying the associated element.
CannotCopyTagWarn | A tag cannot be arrayed without copying the associated element.
CannotPasteAssociate | Can't find new associated element. Element won't be copied.
CannotPasteOrphanTags | Orphaned tags cannot be pasted.
CannotPasteOrphanTagsWarn | Orphaned tags cannot be pasted.
CannotPasteTag | Can't find new element to tag. Tag won't be copied.
CannotRemapTagReference | The tag reference was not remapped.
ElementCategoryChangeInvalidatesTag | Elements have changed category. Tags for these elements are now of the wrong category and will be deleted.
ElementCategoryChangeInvalidatesTagUpgrade | During upgrade, Revit discovered that the highlighted elements were marked with tags of the wrong category. These tags were deleted.
MultiCategoryTagFilterParamNotFoundInElement | The filter specified by Multi-Category Tag can't be used with the tagged object.
RemoveTagWithNoLeaders | The Tag was deleted because it was no longer pointing to any elements.
TagsCannotBePlacedInUnlocked3dViews | Tags can't be pasted into Unlocked 3D views.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TagFailures Properties

The BuiltInFailuresTagFailures type exposes the following members.

Properties
Name | Description
CannotCopyTag | A tag cannot be arrayed without copying the associated element.
CannotCopyTagWarn | A tag cannot be arrayed without copying the associated element.
CannotPasteAssociate | Can't find new associated element. Element won't be copied.
CannotPasteOrphanTags | Orphaned tags cannot be pasted.
CannotPasteOrphanTagsWarn | Orphaned tags cannot be pasted.
CannotPasteTag | Can't find new element to tag. Tag won't be copied.
CannotRemapTagReference | The tag reference was not remapped.
ElementCategoryChangeInvalidatesTag | Elements have changed category. Tags for these elements are now of the wrong category and will be deleted.
ElementCategoryChangeInvalidatesTagUpgrade | During upgrade, Revit discovered that the highlighted elements were marked with tags of the wrong category. These tags were deleted.
MultiCategoryTagFilterParamNotFoundInElement | The filter specified by Multi-Category Tag can't be used with the tagged object.
RemoveTagWithNoLeaders | The Tag was deleted because it was no longer pointing to any elements.
TagsCannotBePlacedInUnlocked3dViews | Tags can't be pasted into Unlocked 3D views.
Top
See Also

Reference

BuiltInFailuresTagFailures Class


BuiltInFailures.TagFailures.CannotCopyTag Property

BuiltInFailuresTagFailuresCannotCopyTag Property

A tag cannot be arrayed without copying the associated element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyTag { get; }
Public Shared ReadOnly Property CannotCopyTag As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyTag {
    FailureDefinitionId^ get ();
}
static member CannotCopyTag : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresTagFailures Class


BuiltInFailures.TagFailures.CannotCopyTagWarn Property

BuiltInFailuresTagFailuresCannotCopyTagWarn Property

A tag cannot be arrayed without copying the associated element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCopyTagWarn { get; }
Public Shared ReadOnly Property CannotCopyTagWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCopyTagWarn {
    FailureDefinitionId^ get ();
}
static member CannotCopyTagWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresTagFailures Class


BuiltInFailures.TagFailures.CannotPasteAssociate Property

BuiltInFailuresTagFailuresCannotPasteAssociate Property

Can't find new associated element. Element won't be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPasteAssociate { get; }
Public Shared ReadOnly Property CannotPasteAssociate As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPasteAssociate {
    FailureDefinitionId^ get ();
}
static member CannotPasteAssociate : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresTagFailures Class


BuiltInFailures.TagFailures.CannotPasteOrphanTags Property

BuiltInFailuresTagFailuresCannotPasteOrphanTags Property

Orphaned tags cannot be pasted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPasteOrphanTags { get; }
Public Shared ReadOnly Property CannotPasteOrphanTags As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPasteOrphanTags {
    FailureDefinitionId^ get ();
}
static member CannotPasteOrphanTags : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresTagFailures Class


BuiltInFailures.TagFailures.CannotPasteOrphanTagsWarn Property

BuiltInFailuresTagFailuresCannotPasteOrphanTagsWarn Property

Orphaned tags cannot be pasted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPasteOrphanTagsWarn { get; }
Public Shared ReadOnly Property CannotPasteOrphanTagsWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPasteOrphanTagsWarn {
    FailureDefinitionId^ get ();
}
static member CannotPasteOrphanTagsWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresTagFailures Class


BuiltInFailures.TagFailures.CannotPasteTag Property

BuiltInFailuresTagFailuresCannotPasteTag Property

Can't find new element to tag. Tag won't be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPasteTag { get; }
Public Shared ReadOnly Property CannotPasteTag As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPasteTag {
    FailureDefinitionId^ get ();
}
static member CannotPasteTag : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresTagFailures Class


BuiltInFailures.TagFailures.CannotRemapTagReference Property

BuiltInFailuresTagFailuresCannotRemapTagReference Property

The tag reference was not remapped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotRemapTagReference { get; }
Public Shared ReadOnly Property CannotRemapTagReference As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotRemapTagReference {
    FailureDefinitionId^ get ();
}
static member CannotRemapTagReference : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresTagFailures Class


BuiltInFailures.TagFailures.ElementCategoryChangeInvalidatesTag Property

BuiltInFailuresTagFailuresElementCategoryChangeInvalidatesTag Property

Elements have changed category. Tags for these elements are now of the wrong category and will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ElementCategoryChangeInvalidatesTag { get; }
Public Shared ReadOnly Property ElementCategoryChangeInvalidatesTag As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ElementCategoryChangeInvalidatesTag {
    FailureDefinitionId^ get ();
}
static member ElementCategoryChangeInvalidatesTag : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresTagFailures Class


BuiltInFailures.TagFailures.ElementCategoryChangeInvalidatesTagUpgrade Property

BuiltInFailuresTagFailuresElementCategoryChangeInvalidatesTagUpgrade Property

During upgrade, Revit discovered that the highlighted elements were marked with tags of the wrong category. These tags were deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ElementCategoryChangeInvalidatesTagUpgrade { get; }
Public Shared ReadOnly Property ElementCategoryChangeInvalidatesTagUpgrade As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ElementCategoryChangeInvalidatesTagUpgrade {
    FailureDefinitionId^ get ();
}
static member ElementCategoryChangeInvalidatesTagUpgrade : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresTagFailures Class


BuiltInFailures.TagFailures.MultiCategoryTagFilterParamNotFoundInElement Property

BuiltInFailuresTagFailuresMultiCategoryTagFilterParamNotFoundInElement Property

The filter specified by Multi-Category Tag can't be used with the tagged object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MultiCategoryTagFilterParamNotFoundInElement { get; }
Public Shared ReadOnly Property MultiCategoryTagFilterParamNotFoundInElement As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MultiCategoryTagFilterParamNotFoundInElement {
    FailureDefinitionId^ get ();
}
static member MultiCategoryTagFilterParamNotFoundInElement : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresTagFailures Class


BuiltInFailures.TagFailures.RemoveTagWithNoLeaders Property

BuiltInFailuresTagFailuresRemoveTagWithNoLeaders Property

The Tag was deleted because it was no longer pointing to any elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RemoveTagWithNoLeaders { get; }
Public Shared ReadOnly Property RemoveTagWithNoLeaders As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RemoveTagWithNoLeaders {
    FailureDefinitionId^ get ();
}
static member RemoveTagWithNoLeaders : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresTagFailures Class


BuiltInFailures.TagFailures.TagsCannotBePlacedInUnlocked3dViews Property

BuiltInFailuresTagFailuresTagsCannotBePlacedInUnlocked3dViews Property

Tags can't be pasted into Unlocked 3D views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TagsCannotBePlacedInUnlocked3dViews { get; }
Public Shared ReadOnly Property TagsCannotBePlacedInUnlocked3dViews As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TagsCannotBePlacedInUnlocked3dViews {
    FailureDefinitionId^ get ();
}
static member TagsCannotBePlacedInUnlocked3dViews : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresTagFailures Class


BuiltInFailures.TextFailures Class

BuiltInFailuresTextFailures Class

Failures about Text.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresTextFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class TextFailures
Public NotInheritable Class TextFailures
public ref class TextFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type TextFailures = class end

The BuiltInFailuresTextFailures type exposes the following members.

Properties
Name | Description
CannotCreateModeltext | Can't create Model Text.
ModeltextIsEmpty | Model Text deleted because it consists entirely of spaces and/or carriage returns.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TextFailures Properties

The BuiltInFailuresTextFailures type exposes the following members.

Properties
Name | Description
CannotCreateModeltext | Can't create Model Text.
ModeltextIsEmpty | Model Text deleted because it consists entirely of spaces and/or carriage returns.
Top
See Also

Reference

BuiltInFailuresTextFailures Class


BuiltInFailures.TextFailures.CannotCreateModeltext Property

BuiltInFailuresTextFailuresCannotCreateModeltext Property

Can't create Model Text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotCreateModeltext { get; }
Public Shared ReadOnly Property CannotCreateModeltext As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotCreateModeltext {
    FailureDefinitionId^ get ();
}
static member CannotCreateModeltext : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresTextFailures Class


BuiltInFailures.TextFailures.ModeltextIsEmpty Property

BuiltInFailuresTextFailuresModeltextIsEmpty Property

Model Text deleted because it consists entirely of spaces and/or carriage returns.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ModeltextIsEmpty { get; }
Public Shared ReadOnly Property ModeltextIsEmpty As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ModeltextIsEmpty {
    FailureDefinitionId^ get ();
}
static member ModeltextIsEmpty : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresTextFailures Class


BuiltInFailures.TilePatternTileFailures Class

BuiltInFailuresTilePatternTileFailures Class

Failures related to tile pattern tile.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresTilePatternTileFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class TilePatternTileFailures
Public NotInheritable Class TilePatternTileFailures
public ref class TilePatternTileFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type TilePatternTileFailures = class end

The BuiltInFailuresTilePatternTileFailures type exposes the following members.

Properties
Name | Description
TilePatternTile_InvalidFamily | Family not appropriate for Divided Surface component.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TilePatternTileFailures Properties

The BuiltInFailuresTilePatternTileFailures type exposes the following members.

Properties
Name | Description
TilePatternTile_InvalidFamily | Family not appropriate for Divided Surface component.
Top
See Also

Reference

BuiltInFailuresTilePatternTileFailures Class


BuiltInFailures.TilePatternTileFailures.TilePatternTile_InvalidFamily Property

BuiltInFailuresTilePatternTileFailuresTilePatternTile_InvalidFamily Property

Family not appropriate for Divided Surface component.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TilePatternTile_InvalidFamily { get; }
Public Shared ReadOnly Property TilePatternTile_InvalidFamily As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TilePatternTile_InvalidFamily {
    FailureDefinitionId^ get ();
}
static member TilePatternTile_InvalidFamily : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresTilePatternTileFailures Class


BuiltInFailures.ToggleViewFailures Class

BuiltInFailuresToggleViewFailures Class

Failures about ToggleView.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresToggleViewFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ToggleViewFailures
Public NotInheritable Class ToggleViewFailures
public ref class ToggleViewFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ToggleViewFailures = class end

The BuiltInFailuresToggleViewFailures type exposes the following members.

Properties
Name | Description
LoseSavedOrientation | The stored orientation will be lost.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ToggleViewFailures Properties

The BuiltInFailuresToggleViewFailures type exposes the following members.

Properties
Name | Description
LoseSavedOrientation | The stored orientation will be lost.
Top
See Also

Reference

BuiltInFailuresToggleViewFailures Class


BuiltInFailures.ToggleViewFailures.LoseSavedOrientation Property

BuiltInFailuresToggleViewFailuresLoseSavedOrientation Property

The stored orientation will be lost.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LoseSavedOrientation { get; }
Public Shared ReadOnly Property LoseSavedOrientation As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LoseSavedOrientation {
    FailureDefinitionId^ get ();
}
static member LoseSavedOrientation : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresToggleViewFailures Class


BuiltInFailures.TrussFailures Class

BuiltInFailuresTrussFailures Class

Failures about Truss.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresTrussFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class TrussFailures
Public NotInheritable Class TrussFailures
public ref class TrussFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type TrussFailures = class end

The BuiltInFailuresTrussFailures type exposes the following members.

Properties
Name | Description
IncorrectWallUsageWithAttachedStruct | A structural framing element is attached to a wall whose Structural Usage is set to [Usage].
InvalidWorkplaneForStructuralFraming | Workplane not valid for Structural Framing component "[Family Name]"
RemoveTrussSketch | Remove Sketch
TrussBadTransformation | Revit cannot transform the truss Layout Family to the Truss as oriented in the project.
TrussChordUntransformable | Unable to maintain user changes to unpinned Chord. Restoring Truss-defined shape.
TrussDuplicateEngineeringType | Elements have duplicate 'Engineering Type' values.
TrussInvalidSymbolGeom | Truss is unable to generate any members due to layout family error.
TrussIsAttachedTo | Revit cannot attach to the chosen Roof/Slab. The truss cannot project to a surface or the attachment creates an invalid profile.
TrussLayoutNonSympleTopChord | This truss layout family defines an offset or non horizontal top chord. This may conflict with attachment or profile editing.
TrussLayoutOverlapedCurves | The current transformation of this specific truss layout will some sub members to overlap.
TrussNotJoinedWebs | The current edits are causing some webs to disjoin. The truss layout family requires additional constraints to maintain these joins.
TrussUserDefinedMemberDeleted | A user-defined structural member was deleted due to missing or deleted references.
TrussUserDefinedMemberNotJoined | Both start and end of web must intersect the truss.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TrussFailures Properties

The BuiltInFailuresTrussFailures type exposes the following members.

Properties
Name | Description
IncorrectWallUsageWithAttachedStruct | A structural framing element is attached to a wall whose Structural Usage is set to [Usage].
InvalidWorkplaneForStructuralFraming | Workplane not valid for Structural Framing component "[Family Name]"
RemoveTrussSketch | Remove Sketch
TrussBadTransformation | Revit cannot transform the truss Layout Family to the Truss as oriented in the project.
TrussChordUntransformable | Unable to maintain user changes to unpinned Chord. Restoring Truss-defined shape.
TrussDuplicateEngineeringType | Elements have duplicate 'Engineering Type' values.
TrussInvalidSymbolGeom | Truss is unable to generate any members due to layout family error.
TrussIsAttachedTo | Revit cannot attach to the chosen Roof/Slab. The truss cannot project to a surface or the attachment creates an invalid profile.
TrussLayoutNonSympleTopChord | This truss layout family defines an offset or non horizontal top chord. This may conflict with attachment or profile editing.
TrussLayoutOverlapedCurves | The current transformation of this specific truss layout will some sub members to overlap.
TrussNotJoinedWebs | The current edits are causing some webs to disjoin. The truss layout family requires additional constraints to maintain these joins.
TrussUserDefinedMemberDeleted | A user-defined structural member was deleted due to missing or deleted references.
TrussUserDefinedMemberNotJoined | Both start and end of web must intersect the truss.
Top
See Also

Reference

BuiltInFailuresTrussFailures Class


BuiltInFailures.TrussFailures.IncorrectWallUsageWithAttachedStruct Property

BuiltInFailuresTrussFailuresIncorrectWallUsageWithAttachedStruct Property

A structural framing element is attached to a wall whose Structural Usage is set to [Usage].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId IncorrectWallUsageWithAttachedStruct { get; }
Public Shared ReadOnly Property IncorrectWallUsageWithAttachedStruct As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ IncorrectWallUsageWithAttachedStruct {
    FailureDefinitionId^ get ();
}
static member IncorrectWallUsageWithAttachedStruct : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresTrussFailures Class


BuiltInFailures.TrussFailures.InvalidWorkplaneForStructuralFraming Property

BuiltInFailuresTrussFailuresInvalidWorkplaneForStructuralFraming Property

Workplane not valid for Structural Framing component "[Family Name]"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidWorkplaneForStructuralFraming { get; }
Public Shared ReadOnly Property InvalidWorkplaneForStructuralFraming As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidWorkplaneForStructuralFraming {
    FailureDefinitionId^ get ();
}
static member InvalidWorkplaneForStructuralFraming : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresTrussFailures Class


BuiltInFailures.TrussFailures.RemoveTrussSketch Property

BuiltInFailuresTrussFailuresRemoveTrussSketch Property

Remove Sketch

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RemoveTrussSketch { get; }
Public Shared ReadOnly Property RemoveTrussSketch As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RemoveTrussSketch {
    FailureDefinitionId^ get ();
}
static member RemoveTrussSketch : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresTrussFailures Class


BuiltInFailures.TrussFailures.TrussBadTransformation Property

BuiltInFailuresTrussFailuresTrussBadTransformation Property

Revit cannot transform the truss Layout Family to the Truss as oriented in the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TrussBadTransformation { get; }
Public Shared ReadOnly Property TrussBadTransformation As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TrussBadTransformation {
    FailureDefinitionId^ get ();
}
static member TrussBadTransformation : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresTrussFailures Class


BuiltInFailures.TrussFailures.TrussChordUntransformable Property

BuiltInFailuresTrussFailuresTrussChordUntransformable Property

Unable to maintain user changes to unpinned Chord. Restoring Truss-defined shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TrussChordUntransformable { get; }
Public Shared ReadOnly Property TrussChordUntransformable As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TrussChordUntransformable {
    FailureDefinitionId^ get ();
}
static member TrussChordUntransformable : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresTrussFailures Class


BuiltInFailures.TrussFailures.TrussDuplicateEngineeringType Property

BuiltInFailuresTrussFailuresTrussDuplicateEngineeringType Property

Elements have duplicate 'Engineering Type' values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TrussDuplicateEngineeringType { get; }
Public Shared ReadOnly Property TrussDuplicateEngineeringType As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TrussDuplicateEngineeringType {
    FailureDefinitionId^ get ();
}
static member TrussDuplicateEngineeringType : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresTrussFailures Class


BuiltInFailures.TrussFailures.TrussInvalidSymbolGeom Property

BuiltInFailuresTrussFailuresTrussInvalidSymbolGeom Property

Truss is unable to generate any members due to layout family error.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TrussInvalidSymbolGeom { get; }
Public Shared ReadOnly Property TrussInvalidSymbolGeom As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TrussInvalidSymbolGeom {
    FailureDefinitionId^ get ();
}
static member TrussInvalidSymbolGeom : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresTrussFailures Class


BuiltInFailures.TrussFailures.TrussIsAttachedTo Property

BuiltInFailuresTrussFailuresTrussIsAttachedTo Property

Revit cannot attach to the chosen Roof/Slab. The truss cannot project to a surface or the attachment creates an invalid profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TrussIsAttachedTo { get; }
Public Shared ReadOnly Property TrussIsAttachedTo As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TrussIsAttachedTo {
    FailureDefinitionId^ get ();
}
static member TrussIsAttachedTo : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresTrussFailures Class


BuiltInFailures.TrussFailures.TrussLayoutNonSympleTopChord Property

BuiltInFailuresTrussFailuresTrussLayoutNonSympleTopChord Property

This truss layout family defines an offset or non horizontal top chord. This may conflict with attachment or profile editing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TrussLayoutNonSympleTopChord { get; }
Public Shared ReadOnly Property TrussLayoutNonSympleTopChord As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TrussLayoutNonSympleTopChord {
    FailureDefinitionId^ get ();
}
static member TrussLayoutNonSympleTopChord : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresTrussFailures Class


BuiltInFailures.TrussFailures.TrussLayoutOverlapedCurves Property

BuiltInFailuresTrussFailuresTrussLayoutOverlapedCurves Property

The current transformation of this specific truss layout will some sub members to overlap.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TrussLayoutOverlapedCurves { get; }
Public Shared ReadOnly Property TrussLayoutOverlapedCurves As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TrussLayoutOverlapedCurves {
    FailureDefinitionId^ get ();
}
static member TrussLayoutOverlapedCurves : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresTrussFailures Class


BuiltInFailures.TrussFailures.TrussNotJoinedWebs Property

BuiltInFailuresTrussFailuresTrussNotJoinedWebs Property

The current edits are causing some webs to disjoin. The truss layout family requires additional constraints to maintain these joins.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TrussNotJoinedWebs { get; }
Public Shared ReadOnly Property TrussNotJoinedWebs As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TrussNotJoinedWebs {
    FailureDefinitionId^ get ();
}
static member TrussNotJoinedWebs : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresTrussFailures Class


BuiltInFailures.TrussFailures.TrussUserDefinedMemberDeleted Property

BuiltInFailuresTrussFailuresTrussUserDefinedMemberDeleted Property

A user-defined structural member was deleted due to missing or deleted references.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TrussUserDefinedMemberDeleted { get; }
Public Shared ReadOnly Property TrussUserDefinedMemberDeleted As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TrussUserDefinedMemberDeleted {
    FailureDefinitionId^ get ();
}
static member TrussUserDefinedMemberDeleted : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresTrussFailures Class


BuiltInFailures.TrussFailures.TrussUserDefinedMemberNotJoined Property

BuiltInFailuresTrussFailuresTrussUserDefinedMemberNotJoined Property

Both start and end of web must intersect the truss.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TrussUserDefinedMemberNotJoined { get; }
Public Shared ReadOnly Property TrussUserDefinedMemberNotJoined As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TrussUserDefinedMemberNotJoined {
    FailureDefinitionId^ get ();
}
static member TrussUserDefinedMemberNotJoined : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresTrussFailures Class


BuiltInFailures.UniqueElementFailures Class

BuiltInFailuresUniqueElementFailures Class

Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresUniqueElementFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class UniqueElementFailures
Public NotInheritable Class UniqueElementFailures
public ref class UniqueElementFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type UniqueElementFailures = class end

The BuiltInFailuresUniqueElementFailures type exposes the following members.

Properties
Name | Description
ProhibitUniqueElementDeletion | Internal setting '%1!s!' is required by Revit and has been deleted.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


UniqueElementFailures Properties

The BuiltInFailuresUniqueElementFailures type exposes the following members.

Properties
Name | Description
ProhibitUniqueElementDeletion | Internal setting '%1!s!' is required by Revit and has been deleted.
Top
See Also

Reference

BuiltInFailuresUniqueElementFailures Class


BuiltInFailures.UniqueElementFailures.ProhibitUniqueElementDeletion Property

BuiltInFailuresUniqueElementFailuresProhibitUniqueElementDeletion Property

Internal setting '%1!s!' is required by Revit and has been deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ProhibitUniqueElementDeletion { get; }
Public Shared ReadOnly Property ProhibitUniqueElementDeletion As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ProhibitUniqueElementDeletion {
    FailureDefinitionId^ get ();
}
static member ProhibitUniqueElementDeletion : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresUniqueElementFailures Class


BuiltInFailures.ViewFailures Class

BuiltInFailuresViewFailures Class

Failures about ViewFailures.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresViewFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ViewFailures
Public NotInheritable Class ViewFailures
public ref class ViewFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ViewFailures = class end

The BuiltInFailuresViewFailures type exposes the following members.

Properties
Name | Description
BadViewDirectionSetting | Plan view DBViewType has invalid view direction parameter.
CanNotDeleteLastOpenView | Deleting of all open views in a project is not allowed.
CannotPasteViewReferences | Cannot paste view references into the view they reference or into unrelated views
CannotToggleToPerspective | Cannot toggle to perspective view because the view contains annotations.
DetailNumberDuplicate | Detail Number is already in use. Enter a unique number.
DetailNumberEmpty | Detail Number is empty
InitialViewDeleted | The starting view for the project has been deleted.
InsertColumnViewError | Column cannot be placed in Elevation or Section view
InsertColumnViewFailure | Column cannot be placed in Elevation or Section view
InsertComponentViewError | This type of Component cannot be placed in Elevation or Section view
InsertComponentViewFailure | This type of Component cannot be placed in Elevation or Section view
InvalidDBviewScopeBox | The scope box and view must have parallel vertical axes.
NoTargetsForDependentViewPropagation | There are no valid views. Only views without dependents can be used.
NothingToApplyError | Start and end elevations are the same, nothing to Apply.
NothingToApplyWarning | Start and end elevations are the same, nothing to Apply.
ReloadLatestDeletedLastOpenView | The only open view has been deleted because of changes from the Central Model. Open another view and Reload Latest or Synchronize with Central again.
TurnCropRegionOffRemovesViewBreaks | Turning off the Crop Region of the view will remove all View Breaks. If the Crop Region is turned on at a later time, any desired View Breaks must be created again.
ViewPublishFailed | The following views could not be published.
ZeroLengthViewBreaksRemoved | Some View Regions were consolidated. When the size of a View Break between View Regions becomes zero, the View Break is removed and the adjacent View Regions are joined.
ZeroLengthViewRegionsRemoved | Some View Regions were removed. When the size of a View Region becomes zero, it is removed from the view.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ViewFailures Properties

The BuiltInFailuresViewFailures type exposes the following members.

Properties
Name | Description
BadViewDirectionSetting | Plan view DBViewType has invalid view direction parameter.
CanNotDeleteLastOpenView | Deleting of all open views in a project is not allowed.
CannotPasteViewReferences | Cannot paste view references into the view they reference or into unrelated views
CannotToggleToPerspective | Cannot toggle to perspective view because the view contains annotations.
DetailNumberDuplicate | Detail Number is already in use. Enter a unique number.
DetailNumberEmpty | Detail Number is empty
InitialViewDeleted | The starting view for the project has been deleted.
InsertColumnViewError | Column cannot be placed in Elevation or Section view
InsertColumnViewFailure | Column cannot be placed in Elevation or Section view
InsertComponentViewError | This type of Component cannot be placed in Elevation or Section view
InsertComponentViewFailure | This type of Component cannot be placed in Elevation or Section view
InvalidDBviewScopeBox | The scope box and view must have parallel vertical axes.
NoTargetsForDependentViewPropagation | There are no valid views. Only views without dependents can be used.
NothingToApplyError | Start and end elevations are the same, nothing to Apply.
NothingToApplyWarning | Start and end elevations are the same, nothing to Apply.
ReloadLatestDeletedLastOpenView | The only open view has been deleted because of changes from the Central Model. Open another view and Reload Latest or Synchronize with Central again.
TurnCropRegionOffRemovesViewBreaks | Turning off the Crop Region of the view will remove all View Breaks. If the Crop Region is turned on at a later time, any desired View Breaks must be created again.
ViewPublishFailed | The following views could not be published.
ZeroLengthViewBreaksRemoved | Some View Regions were consolidated. When the size of a View Break between View Regions becomes zero, the View Break is removed and the adjacent View Regions are joined.
ZeroLengthViewRegionsRemoved | Some View Regions were removed. When the size of a View Region becomes zero, it is removed from the view.
Top
See Also

Reference

BuiltInFailuresViewFailures Class


BuiltInFailures.ViewFailures.BadViewDirectionSetting Property

BuiltInFailuresViewFailuresBadViewDirectionSetting Property

Plan view DBViewType has invalid view direction parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId BadViewDirectionSetting { get; }
Public Shared ReadOnly Property BadViewDirectionSetting As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ BadViewDirectionSetting {
    FailureDefinitionId^ get ();
}
static member BadViewDirectionSetting : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresViewFailures Class


BuiltInFailures.ViewFailures.CanNotDeleteLastOpenView Property

BuiltInFailuresViewFailuresCanNotDeleteLastOpenView Property

Deleting of all open views in a project is not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CanNotDeleteLastOpenView { get; }
Public Shared ReadOnly Property CanNotDeleteLastOpenView As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CanNotDeleteLastOpenView {
    FailureDefinitionId^ get ();
}
static member CanNotDeleteLastOpenView : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresViewFailures Class


BuiltInFailures.ViewFailures.CannotPasteViewReferences Property

BuiltInFailuresViewFailuresCannotPasteViewReferences Property

Cannot paste view references into the view they reference or into unrelated views

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotPasteViewReferences { get; }
Public Shared ReadOnly Property CannotPasteViewReferences As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotPasteViewReferences {
    FailureDefinitionId^ get ();
}
static member CannotPasteViewReferences : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresViewFailures Class


BuiltInFailures.ViewFailures.CannotToggleToPerspective Property

BuiltInFailuresViewFailuresCannotToggleToPerspective Property

Cannot toggle to perspective view because the view contains annotations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotToggleToPerspective { get; }
Public Shared ReadOnly Property CannotToggleToPerspective As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotToggleToPerspective {
    FailureDefinitionId^ get ();
}
static member CannotToggleToPerspective : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresViewFailures Class


BuiltInFailures.ViewFailures.DetailNumberDuplicate Property

BuiltInFailuresViewFailuresDetailNumberDuplicate Property

Detail Number is already in use. Enter a unique number.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DetailNumberDuplicate { get; }
Public Shared ReadOnly Property DetailNumberDuplicate As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DetailNumberDuplicate {
    FailureDefinitionId^ get ();
}
static member DetailNumberDuplicate : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresViewFailures Class


BuiltInFailures.ViewFailures.DetailNumberEmpty Property

BuiltInFailuresViewFailuresDetailNumberEmpty Property

Detail Number is empty

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DetailNumberEmpty { get; }
Public Shared ReadOnly Property DetailNumberEmpty As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DetailNumberEmpty {
    FailureDefinitionId^ get ();
}
static member DetailNumberEmpty : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresViewFailures Class


BuiltInFailures.ViewFailures.InitialViewDeleted Property

BuiltInFailuresViewFailuresInitialViewDeleted Property

The starting view for the project has been deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InitialViewDeleted { get; }
Public Shared ReadOnly Property InitialViewDeleted As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InitialViewDeleted {
    FailureDefinitionId^ get ();
}
static member InitialViewDeleted : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresViewFailures Class


BuiltInFailures.ViewFailures.InsertColumnViewError Property

BuiltInFailuresViewFailuresInsertColumnViewError Property

Column cannot be placed in Elevation or Section view

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InsertColumnViewError { get; }
Public Shared ReadOnly Property InsertColumnViewError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InsertColumnViewError {
    FailureDefinitionId^ get ();
}
static member InsertColumnViewError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresViewFailures Class


BuiltInFailures.ViewFailures.InsertColumnViewFailure Property

BuiltInFailuresViewFailuresInsertColumnViewFailure Property

Column cannot be placed in Elevation or Section view

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InsertColumnViewFailure { get; }
Public Shared ReadOnly Property InsertColumnViewFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InsertColumnViewFailure {
    FailureDefinitionId^ get ();
}
static member InsertColumnViewFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresViewFailures Class


BuiltInFailures.ViewFailures.InsertComponentViewError Property

BuiltInFailuresViewFailuresInsertComponentViewError Property

This type of Component cannot be placed in Elevation or Section view

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InsertComponentViewError { get; }
Public Shared ReadOnly Property InsertComponentViewError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InsertComponentViewError {
    FailureDefinitionId^ get ();
}
static member InsertComponentViewError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresViewFailures Class


BuiltInFailures.ViewFailures.InsertComponentViewFailure Property

BuiltInFailuresViewFailuresInsertComponentViewFailure Property

This type of Component cannot be placed in Elevation or Section view

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InsertComponentViewFailure { get; }
Public Shared ReadOnly Property InsertComponentViewFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InsertComponentViewFailure {
    FailureDefinitionId^ get ();
}
static member InsertComponentViewFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresViewFailures Class


BuiltInFailures.ViewFailures.InvalidDBviewScopeBox Property

BuiltInFailuresViewFailuresInvalidDBviewScopeBox Property

The scope box and view must have parallel vertical axes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidDBviewScopeBox { get; }
Public Shared ReadOnly Property InvalidDBviewScopeBox As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidDBviewScopeBox {
    FailureDefinitionId^ get ();
}
static member InvalidDBviewScopeBox : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresViewFailures Class


BuiltInFailures.ViewFailures.NoTargetsForDependentViewPropagation Property

BuiltInFailuresViewFailuresNoTargetsForDependentViewPropagation Property

There are no valid views. Only views without dependents can be used.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoTargetsForDependentViewPropagation { get; }
Public Shared ReadOnly Property NoTargetsForDependentViewPropagation As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoTargetsForDependentViewPropagation {
    FailureDefinitionId^ get ();
}
static member NoTargetsForDependentViewPropagation : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresViewFailures Class


BuiltInFailures.ViewFailures.NothingToApplyError Property

BuiltInFailuresViewFailuresNothingToApplyError Property

Start and end elevations are the same, nothing to Apply.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NothingToApplyError { get; }
Public Shared ReadOnly Property NothingToApplyError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NothingToApplyError {
    FailureDefinitionId^ get ();
}
static member NothingToApplyError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresViewFailures Class


BuiltInFailures.ViewFailures.NothingToApplyWarning Property

BuiltInFailuresViewFailuresNothingToApplyWarning Property

Start and end elevations are the same, nothing to Apply.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NothingToApplyWarning { get; }
Public Shared ReadOnly Property NothingToApplyWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NothingToApplyWarning {
    FailureDefinitionId^ get ();
}
static member NothingToApplyWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresViewFailures Class


BuiltInFailures.ViewFailures.ReloadLatestDeletedLastOpenView Property

BuiltInFailuresViewFailuresReloadLatestDeletedLastOpenView Property

The only open view has been deleted because of changes from the Central Model. Open another view and Reload Latest or Synchronize with Central again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ReloadLatestDeletedLastOpenView { get; }
Public Shared ReadOnly Property ReloadLatestDeletedLastOpenView As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ReloadLatestDeletedLastOpenView {
    FailureDefinitionId^ get ();
}
static member ReloadLatestDeletedLastOpenView : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresViewFailures Class


BuiltInFailures.ViewFailures.TurnCropRegionOffRemovesViewBreaks Property

BuiltInFailuresViewFailuresTurnCropRegionOffRemovesViewBreaks Property

Turning off the Crop Region of the view will remove all View Breaks. If the Crop Region is turned on at a later time, any desired View Breaks must be created again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TurnCropRegionOffRemovesViewBreaks { get; }
Public Shared ReadOnly Property TurnCropRegionOffRemovesViewBreaks As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TurnCropRegionOffRemovesViewBreaks {
    FailureDefinitionId^ get ();
}
static member TurnCropRegionOffRemovesViewBreaks : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresViewFailures Class


BuiltInFailures.ViewFailures.ViewPublishFailed Property

BuiltInFailuresViewFailuresViewPublishFailed Property

The following views could not be published.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ViewPublishFailed { get; }
Public Shared ReadOnly Property ViewPublishFailed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ViewPublishFailed {
    FailureDefinitionId^ get ();
}
static member ViewPublishFailed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresViewFailures Class


BuiltInFailures.ViewFailures.ZeroLengthViewBreaksRemoved Property

BuiltInFailuresViewFailuresZeroLengthViewBreaksRemoved Property

Some View Regions were consolidated. When the size of a View Break between View Regions becomes zero, the View Break is removed and the adjacent View Regions are joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ZeroLengthViewBreaksRemoved { get; }
Public Shared ReadOnly Property ZeroLengthViewBreaksRemoved As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ZeroLengthViewBreaksRemoved {
    FailureDefinitionId^ get ();
}
static member ZeroLengthViewBreaksRemoved : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresViewFailures Class


BuiltInFailures.ViewFailures.ZeroLengthViewRegionsRemoved Property

BuiltInFailuresViewFailuresZeroLengthViewRegionsRemoved Property

Some View Regions were removed. When the size of a View Region becomes zero, it is removed from the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ZeroLengthViewRegionsRemoved { get; }
Public Shared ReadOnly Property ZeroLengthViewRegionsRemoved As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ZeroLengthViewRegionsRemoved {
    FailureDefinitionId^ get ();
}
static member ZeroLengthViewRegionsRemoved : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresViewFailures Class


BuiltInFailures.ViewSheetFailures Class

BuiltInFailuresViewSheetFailures Class

Failures about placing viewports on sheets.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresViewSheetFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ViewSheetFailures
Public NotInheritable Class ViewSheetFailures
public ref class ViewSheetFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ViewSheetFailures = class end

The BuiltInFailuresViewSheetFailures type exposes the following members.

Properties
Name | Description
ViewInAModelMustBeUnique | Sheet views in this model cannot contain more than one instance of "%1!s!."
ViewInAModelMustBeUniqueWarn | Sheet views in this model cannot contain more than one instance of "%1!s!."
ViewOnASheetCannotBeUncropped3DPerspectiveView | Sheets do not support uncropped perspective views.
ViewOnASheetMustBeUnique | Sheet views cannot contain more than one instance of "%1!s!."
ViewOnASheetMustBeUniqueWarn | Sheet views cannot contain more than one instance of "%1!s!."
ViewportCantContainEmptyView | Sheet views cannot contain empty view "%1!s!".
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ViewSheetFailures Properties

The BuiltInFailuresViewSheetFailures type exposes the following members.

Properties
Name | Description
ViewInAModelMustBeUnique | Sheet views in this model cannot contain more than one instance of "%1!s!."
ViewInAModelMustBeUniqueWarn | Sheet views in this model cannot contain more than one instance of "%1!s!."
ViewOnASheetCannotBeUncropped3DPerspectiveView | Sheets do not support uncropped perspective views.
ViewOnASheetMustBeUnique | Sheet views cannot contain more than one instance of "%1!s!."
ViewOnASheetMustBeUniqueWarn | Sheet views cannot contain more than one instance of "%1!s!."
ViewportCantContainEmptyView | Sheet views cannot contain empty view "%1!s!".
Top
See Also

Reference

BuiltInFailuresViewSheetFailures Class


BuiltInFailures.ViewSheetFailures.ViewInAModelMustBeUnique Property

BuiltInFailuresViewSheetFailuresViewInAModelMustBeUnique Property

Sheet views in this model cannot contain more than one instance of "%1!s!."

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ViewInAModelMustBeUnique { get; }
Public Shared ReadOnly Property ViewInAModelMustBeUnique As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ViewInAModelMustBeUnique {
    FailureDefinitionId^ get ();
}
static member ViewInAModelMustBeUnique : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresViewSheetFailures Class


BuiltInFailures.ViewSheetFailures.ViewInAModelMustBeUniqueWarn Property

BuiltInFailuresViewSheetFailuresViewInAModelMustBeUniqueWarn Property

Sheet views in this model cannot contain more than one instance of "%1!s!."

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ViewInAModelMustBeUniqueWarn { get; }
Public Shared ReadOnly Property ViewInAModelMustBeUniqueWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ViewInAModelMustBeUniqueWarn {
    FailureDefinitionId^ get ();
}
static member ViewInAModelMustBeUniqueWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresViewSheetFailures Class


BuiltInFailures.ViewSheetFailures.ViewOnASheetCannotBeUncropped3DPerspectiveView Property

BuiltInFailuresViewSheetFailuresViewOnASheetCannotBeUncropped3DPerspectiveView Property

Sheets do not support uncropped perspective views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ViewOnASheetCannotBeUncropped3DPerspectiveView { get; }
Public Shared ReadOnly Property ViewOnASheetCannotBeUncropped3DPerspectiveView As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ViewOnASheetCannotBeUncropped3DPerspectiveView {
    FailureDefinitionId^ get ();
}
static member ViewOnASheetCannotBeUncropped3DPerspectiveView : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresViewSheetFailures Class


BuiltInFailures.ViewSheetFailures.ViewOnASheetMustBeUnique Property

BuiltInFailuresViewSheetFailuresViewOnASheetMustBeUnique Property

Sheet views cannot contain more than one instance of "%1!s!."

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ViewOnASheetMustBeUnique { get; }
Public Shared ReadOnly Property ViewOnASheetMustBeUnique As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ViewOnASheetMustBeUnique {
    FailureDefinitionId^ get ();
}
static member ViewOnASheetMustBeUnique : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresViewSheetFailures Class


BuiltInFailures.ViewSheetFailures.ViewOnASheetMustBeUniqueWarn Property

BuiltInFailuresViewSheetFailuresViewOnASheetMustBeUniqueWarn Property

Sheet views cannot contain more than one instance of "%1!s!."

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ViewOnASheetMustBeUniqueWarn { get; }
Public Shared ReadOnly Property ViewOnASheetMustBeUniqueWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ViewOnASheetMustBeUniqueWarn {
    FailureDefinitionId^ get ();
}
static member ViewOnASheetMustBeUniqueWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresViewSheetFailures Class


BuiltInFailures.ViewSheetFailures.ViewportCantContainEmptyView Property

BuiltInFailuresViewSheetFailuresViewportCantContainEmptyView Property

Sheet views cannot contain empty view "%1!s!".

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ViewportCantContainEmptyView { get; }
Public Shared ReadOnly Property ViewportCantContainEmptyView As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ViewportCantContainEmptyView {
    FailureDefinitionId^ get ();
}
static member ViewportCantContainEmptyView : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresViewSheetFailures Class


BuiltInFailures.WallFailures Class

BuiltInFailuresWallFailures Class

Failures about Wall.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresWallFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class WallFailures
Public NotInheritable Class WallFailures
public ref class WallFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type WallFailures = class end

The BuiltInFailuresWallFailures type exposes the following members.

Properties
Name | Description
CannotChangeSubwall | Changing the type of a subwall is not allowed. Edit the stacked wall type instead.
CannotChangeTypeOfOldCurtainPanel | Cannot change the type of curtain panels in walls created with early versions of Revit. To change the panels of this curtain wall, wall must be recreated.
CannotMaintainKeyReference | Can't maintain the position of the Location Line in this Wall.
CannotMirrorWallPanel | Cannot mirror wall panels.
CannotRedoFaceBased | Faces defining this Element cannot be reacquired.
CannotRedoFaceBasedWarn | Faces defining this Element cannot be reacquired.
CannotRedoFaceRoof | "Faces defining this Roof cannot be reacquired. Either delete the Roof or leave as it is.
CannotRedoFaceToposolid | "Faces defining this Roof cannot be reacquired. Either delete the Roof or leave as it is.
CannotSlantStackedWallError | Cannot slant a stacked wall with rectangular openings. Please delete the openings first.
CannotSplitJoinHostsInplaceFamilies | Can't split/join this host because there are instances of In-place Families that cut openings into it. Edit or delete instances first so they don't cut into the host to be split or joined.
CannotSplitVerticallyCompoundWall | Can't divide Wall's face to assign different materials to a vertically compound Wall.
CannotToSplitWallPanels | Unable to split wall panel(s).
CannotUpdateWallPanel | Unable to update wall panel.
ChangingWallsweepType | This wall sweep instance has different profile or material than its type. You may delete the sweep, or if you ignore this warning, it will be regenerated according to its type.
ConstrainedToWall | Sketch Lines created with Pick Wall must remain parallel to the Wall.
ConstrainedToWallError | Sketch Lines created with Pick Wall must remain parallel to the Wall.
ContFootingCannotJoin | Miter plane for Wall Foundation join is too far away; Bisecting plane will be used instead.
ContFootingRadiusTooSmall | Can't display the Wall Foundation, because the Wall's radius is too small. Please increase the radius to display the Wall Foundation.
CurtainOrStackedWallDisallowedForCrossSectionType | Curtain wall types and Stacked wall types are not allowed for this wall's cross-section type.
DisallowedPathCurve | Cannot create stacked elliptical wall with offsets.
EmbeddedButShouldNotBe | Conditions for wall embedding are no longer satisfied.
ExtrudedWallDisallowedForCrossSectionType | Edited profiles are not allowed for this wall's cross-section type.
FaceBecameVertical | Face defining this non-vertical Wall is vertical.
FaceIsNoGoodForWall | Defining face is not suitable for walls.
FaceIsNoLongerVertical | Face defining this vertical Wall is no longer vertical.
FaceWallBadType | Wall type '[Type Name]' is incompatible with picked face. Only basic wall types are accepted.
FaceWallComplexType | Vertically compound wall type features sweeps, reveals, or split layers are not supported on non-vertical face. Consider using a simplified type.
FaceWallFailedToMake | Can't make Face Wall shape.
FaceWallMissingFace | No picked face found.
FailedConvertWallToPanel | Unable to convert wall to panel.
FailedToChangeInstSymbol | Failed to change symbol of instance.
FailedToStoreSideFace | Failed to store wall side face. Wall sweeps on this wall will fail to regenerate.
InvalidBaseConstraintForLevel | Base Constraint is invalid for the Level.
InvalidCompoundStructure | Invalid compound structure.
InvalidTargetPosition | Joining the highlighted wall to the highlighted element moves the wall's top below its bottom or its bottom above its top, or interferes with wall joins or holes in the wall.
InvalidTargetPositionError | Joining the highlighted wall to the highlighted element moves the wall's top below its bottom or its bottom above its top, or interferes with wall joins or holes in the wall.
InvalidTopConstraintForLevel | Top Constraint is invalid for the Level.
LostEditsJoinsRedoFaceBased | Previous edits and /or wall joins will not be preserved on this operation.
ParameterChangeNotAffectingGeometry | Changing this element's parameter has no effect on its current position or geometry. Check to see if the element is constrained either in the project view or in the element's sketch.
RecursionParameterIgnored | Parameter-defined type of curtain panels defined in a circular way and will be ignored.
RemapConstrainLocationLine | Existing locked constraints to the Location Line will be transferred to the new Location Line position. Press "Unconstrain" to remove the constraint rather than transferring it.
ShorterThanMinWall | Wall is shorter than minimum height allowed by its type.\nIt is [Length] and must be at least [Length].
ShorterThanMinWallError | Wall is shorter than minimum height allowed by its type.\nIt is [Length] and must be at least [Length].
ShorterThanMinWallFailure | Wall is shorter than minimum height allowed by its type.\nIt is [Length] and must be at least [Length].
ShouldAdjustWallParameters | The best way to control top and base of the Wall is to modify the Constraints and Offset Parameters in Properties dialog.
StackedWallNeedsUnjoin | A subwall of this stacked wall is unjoined from its neighbors because it was pulled too far.
SubwallOfStackedWallDeleted | This stacked wall will be deleted because a subwall could not be created.
TaperedWallAnglesControlledByType | Cannot set angles on a tapered wall which has angles controlled by the type.
TooShortStackedWall | Stacked wall instance is too short.
UnableToCreateWallForPanel | Unable to create wall for curtain wall panel.
UnableToDeleteWallForPanel | Unable to delete curtain panel wall.
UnjoinOnEditWallChange | Line associated with a joined face has been moved. This action will cause the other walls to become disjoined from this face. [Description]
VerticalLayerExtensionFailure | Cannot extend layer(s) of the highlighted vertically compound wall.
VerticalLayerExtensionFailureError | Cannot extend layer(s) of the highlighted vertically compound wall.
WallCutoutForInsertionFailure | Can't cut wall for inserted objects
WallLacksCurve | Wall does not have both a curve driver and a curve!!!!
WallNegativeHeight | The top of the Wall is lower than the base of the Wall.
WallSettingsChanged | Default wall settings will be changed (Base Constraint: [Base Level], Base Offset: [Base Offset], Top Constraint: [Top Level], Top Offset: [Top Offset])
WallTypeIncompatibleWithTapered | This wall's type is not compatible with the Tapered cross-section. Tapered walls require a variable thickness layer.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


WallFailures Properties

The BuiltInFailuresWallFailures type exposes the following members.

Properties
Name | Description
CannotChangeSubwall | Changing the type of a subwall is not allowed. Edit the stacked wall type instead.
CannotChangeTypeOfOldCurtainPanel | Cannot change the type of curtain panels in walls created with early versions of Revit. To change the panels of this curtain wall, wall must be recreated.
CannotMaintainKeyReference | Can't maintain the position of the Location Line in this Wall.
CannotMirrorWallPanel | Cannot mirror wall panels.
CannotRedoFaceBased | Faces defining this Element cannot be reacquired.
CannotRedoFaceBasedWarn | Faces defining this Element cannot be reacquired.
CannotRedoFaceRoof | "Faces defining this Roof cannot be reacquired. Either delete the Roof or leave as it is.
CannotRedoFaceToposolid | "Faces defining this Roof cannot be reacquired. Either delete the Roof or leave as it is.
CannotSlantStackedWallError | Cannot slant a stacked wall with rectangular openings. Please delete the openings first.
CannotSplitJoinHostsInplaceFamilies | Can't split/join this host because there are instances of In-place Families that cut openings into it. Edit or delete instances first so they don't cut into the host to be split or joined.
CannotSplitVerticallyCompoundWall | Can't divide Wall's face to assign different materials to a vertically compound Wall.
CannotToSplitWallPanels | Unable to split wall panel(s).
CannotUpdateWallPanel | Unable to update wall panel.
ChangingWallsweepType | This wall sweep instance has different profile or material than its type. You may delete the sweep, or if you ignore this warning, it will be regenerated according to its type.
ConstrainedToWall | Sketch Lines created with Pick Wall must remain parallel to the Wall.
ConstrainedToWallError | Sketch Lines created with Pick Wall must remain parallel to the Wall.
ContFootingCannotJoin | Miter plane for Wall Foundation join is too far away; Bisecting plane will be used instead.
ContFootingRadiusTooSmall | Can't display the Wall Foundation, because the Wall's radius is too small. Please increase the radius to display the Wall Foundation.
CurtainOrStackedWallDisallowedForCrossSectionType | Curtain wall types and Stacked wall types are not allowed for this wall's cross-section type.
DisallowedPathCurve | Cannot create stacked elliptical wall with offsets.
EmbeddedButShouldNotBe | Conditions for wall embedding are no longer satisfied.
ExtrudedWallDisallowedForCrossSectionType | Edited profiles are not allowed for this wall's cross-section type.
FaceBecameVertical | Face defining this non-vertical Wall is vertical.
FaceIsNoGoodForWall | Defining face is not suitable for walls.
FaceIsNoLongerVertical | Face defining this vertical Wall is no longer vertical.
FaceWallBadType | Wall type '[Type Name]' is incompatible with picked face. Only basic wall types are accepted.
FaceWallComplexType | Vertically compound wall type features sweeps, reveals, or split layers are not supported on non-vertical face. Consider using a simplified type.
FaceWallFailedToMake | Can't make Face Wall shape.
FaceWallMissingFace | No picked face found.
FailedConvertWallToPanel | Unable to convert wall to panel.
FailedToChangeInstSymbol | Failed to change symbol of instance.
FailedToStoreSideFace | Failed to store wall side face. Wall sweeps on this wall will fail to regenerate.
InvalidBaseConstraintForLevel | Base Constraint is invalid for the Level.
InvalidCompoundStructure | Invalid compound structure.
InvalidTargetPosition | Joining the highlighted wall to the highlighted element moves the wall's top below its bottom or its bottom above its top, or interferes with wall joins or holes in the wall.
InvalidTargetPositionError | Joining the highlighted wall to the highlighted element moves the wall's top below its bottom or its bottom above its top, or interferes with wall joins or holes in the wall.
InvalidTopConstraintForLevel | Top Constraint is invalid for the Level.
LostEditsJoinsRedoFaceBased | Previous edits and /or wall joins will not be preserved on this operation.
ParameterChangeNotAffectingGeometry | Changing this element's parameter has no effect on its current position or geometry. Check to see if the element is constrained either in the project view or in the element's sketch.
RecursionParameterIgnored | Parameter-defined type of curtain panels defined in a circular way and will be ignored.
RemapConstrainLocationLine | Existing locked constraints to the Location Line will be transferred to the new Location Line position. Press "Unconstrain" to remove the constraint rather than transferring it.
ShorterThanMinWall | Wall is shorter than minimum height allowed by its type.\nIt is [Length] and must be at least [Length].
ShorterThanMinWallError | Wall is shorter than minimum height allowed by its type.\nIt is [Length] and must be at least [Length].
ShorterThanMinWallFailure | Wall is shorter than minimum height allowed by its type.\nIt is [Length] and must be at least [Length].
ShouldAdjustWallParameters | The best way to control top and base of the Wall is to modify the Constraints and Offset Parameters in Properties dialog.
StackedWallNeedsUnjoin | A subwall of this stacked wall is unjoined from its neighbors because it was pulled too far.
SubwallOfStackedWallDeleted | This stacked wall will be deleted because a subwall could not be created.
TaperedWallAnglesControlledByType | Cannot set angles on a tapered wall which has angles controlled by the type.
TooShortStackedWall | Stacked wall instance is too short.
UnableToCreateWallForPanel | Unable to create wall for curtain wall panel.
UnableToDeleteWallForPanel | Unable to delete curtain panel wall.
UnjoinOnEditWallChange | Line associated with a joined face has been moved. This action will cause the other walls to become disjoined from this face. [Description]
VerticalLayerExtensionFailure | Cannot extend layer(s) of the highlighted vertically compound wall.
VerticalLayerExtensionFailureError | Cannot extend layer(s) of the highlighted vertically compound wall.
WallCutoutForInsertionFailure | Can't cut wall for inserted objects
WallLacksCurve | Wall does not have both a curve driver and a curve!!!!
WallNegativeHeight | The top of the Wall is lower than the base of the Wall.
WallSettingsChanged | Default wall settings will be changed (Base Constraint: [Base Level], Base Offset: [Base Offset], Top Constraint: [Top Level], Top Offset: [Top Offset])
WallTypeIncompatibleWithTapered | This wall's type is not compatible with the Tapered cross-section. Tapered walls require a variable thickness layer.
Top
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.CannotChangeSubwall Property

BuiltInFailuresWallFailuresCannotChangeSubwall Property

Changing the type of a subwall is not allowed. Edit the stacked wall type instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotChangeSubwall { get; }
Public Shared ReadOnly Property CannotChangeSubwall As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotChangeSubwall {
    FailureDefinitionId^ get ();
}
static member CannotChangeSubwall : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.CannotChangeTypeOfOldCurtainPanel Property

BuiltInFailuresWallFailuresCannotChangeTypeOfOldCurtainPanel Property

Cannot change the type of curtain panels in walls created with early versions of Revit. To change the panels of this curtain wall, wall must be recreated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotChangeTypeOfOldCurtainPanel { get; }
Public Shared ReadOnly Property CannotChangeTypeOfOldCurtainPanel As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotChangeTypeOfOldCurtainPanel {
    FailureDefinitionId^ get ();
}
static member CannotChangeTypeOfOldCurtainPanel : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.CannotMaintainKeyReference Property

BuiltInFailuresWallFailuresCannotMaintainKeyReference Property

Can't maintain the position of the Location Line in this Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotMaintainKeyReference { get; }
Public Shared ReadOnly Property CannotMaintainKeyReference As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotMaintainKeyReference {
    FailureDefinitionId^ get ();
}
static member CannotMaintainKeyReference : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.CannotMirrorWallPanel Property

BuiltInFailuresWallFailuresCannotMirrorWallPanel Property

Cannot mirror wall panels.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotMirrorWallPanel { get; }
Public Shared ReadOnly Property CannotMirrorWallPanel As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotMirrorWallPanel {
    FailureDefinitionId^ get ();
}
static member CannotMirrorWallPanel : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.CannotRedoFaceBased Property

BuiltInFailuresWallFailuresCannotRedoFaceBased Property

Faces defining this Element cannot be reacquired.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotRedoFaceBased { get; }
Public Shared ReadOnly Property CannotRedoFaceBased As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotRedoFaceBased {
    FailureDefinitionId^ get ();
}
static member CannotRedoFaceBased : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.CannotRedoFaceBasedWarn Property

BuiltInFailuresWallFailuresCannotRedoFaceBasedWarn Property

Faces defining this Element cannot be reacquired.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotRedoFaceBasedWarn { get; }
Public Shared ReadOnly Property CannotRedoFaceBasedWarn As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotRedoFaceBasedWarn {
    FailureDefinitionId^ get ();
}
static member CannotRedoFaceBasedWarn : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.CannotRedoFaceRoof Property

BuiltInFailuresWallFailuresCannotRedoFaceRoof Property

"Faces defining this Roof cannot be reacquired. Either delete the Roof or leave as it is.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotRedoFaceRoof { get; }
Public Shared ReadOnly Property CannotRedoFaceRoof As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotRedoFaceRoof {
    FailureDefinitionId^ get ();
}
static member CannotRedoFaceRoof : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.CannotRedoFaceToposolid Property

BuiltInFailuresWallFailuresCannotRedoFaceToposolid Property

"Faces defining this Roof cannot be reacquired. Either delete the Roof or leave as it is.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotRedoFaceToposolid { get; }
Public Shared ReadOnly Property CannotRedoFaceToposolid As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotRedoFaceToposolid {
    FailureDefinitionId^ get ();
}
static member CannotRedoFaceToposolid : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.CannotSlantStackedWallError Property

BuiltInFailuresWallFailuresCannotSlantStackedWallError Property

Cannot slant a stacked wall with rectangular openings. Please delete the openings first.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotSlantStackedWallError { get; }
Public Shared ReadOnly Property CannotSlantStackedWallError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotSlantStackedWallError {
    FailureDefinitionId^ get ();
}
static member CannotSlantStackedWallError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.CannotSplitJoinHostsInplaceFamilies Property

BuiltInFailuresWallFailuresCannotSplitJoinHostsInplaceFamilies Property

Can't split/join this host because there are instances of In-place Families that cut openings into it. Edit or delete instances first so they don't cut into the host to be split or joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotSplitJoinHostsInplaceFamilies { get; }
Public Shared ReadOnly Property CannotSplitJoinHostsInplaceFamilies As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotSplitJoinHostsInplaceFamilies {
    FailureDefinitionId^ get ();
}
static member CannotSplitJoinHostsInplaceFamilies : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.CannotSplitVerticallyCompoundWall Property

BuiltInFailuresWallFailuresCannotSplitVerticallyCompoundWall Property

Can't divide Wall's face to assign different materials to a vertically compound Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotSplitVerticallyCompoundWall { get; }
Public Shared ReadOnly Property CannotSplitVerticallyCompoundWall As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotSplitVerticallyCompoundWall {
    FailureDefinitionId^ get ();
}
static member CannotSplitVerticallyCompoundWall : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.CannotToSplitWallPanels Property

BuiltInFailuresWallFailuresCannotToSplitWallPanels Property

Unable to split wall panel(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotToSplitWallPanels { get; }
Public Shared ReadOnly Property CannotToSplitWallPanels As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotToSplitWallPanels {
    FailureDefinitionId^ get ();
}
static member CannotToSplitWallPanels : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.CannotUpdateWallPanel Property

BuiltInFailuresWallFailuresCannotUpdateWallPanel Property

Unable to update wall panel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CannotUpdateWallPanel { get; }
Public Shared ReadOnly Property CannotUpdateWallPanel As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CannotUpdateWallPanel {
    FailureDefinitionId^ get ();
}
static member CannotUpdateWallPanel : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.ChangingWallsweepType Property

BuiltInFailuresWallFailuresChangingWallsweepType Property

This wall sweep instance has different profile or material than its type. You may delete the sweep, or if you ignore this warning, it will be regenerated according to its type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ChangingWallsweepType { get; }
Public Shared ReadOnly Property ChangingWallsweepType As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ChangingWallsweepType {
    FailureDefinitionId^ get ();
}
static member ChangingWallsweepType : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.ConstrainedToWall Property

BuiltInFailuresWallFailuresConstrainedToWall Property

Sketch Lines created with Pick Wall must remain parallel to the Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ConstrainedToWall { get; }
Public Shared ReadOnly Property ConstrainedToWall As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ConstrainedToWall {
    FailureDefinitionId^ get ();
}
static member ConstrainedToWall : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.ConstrainedToWallError Property

BuiltInFailuresWallFailuresConstrainedToWallError Property

Sketch Lines created with Pick Wall must remain parallel to the Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ConstrainedToWallError { get; }
Public Shared ReadOnly Property ConstrainedToWallError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ConstrainedToWallError {
    FailureDefinitionId^ get ();
}
static member ConstrainedToWallError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.ContFootingCannotJoin Property

BuiltInFailuresWallFailuresContFootingCannotJoin Property

Miter plane for Wall Foundation join is too far away; Bisecting plane will be used instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ContFootingCannotJoin { get; }
Public Shared ReadOnly Property ContFootingCannotJoin As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ContFootingCannotJoin {
    FailureDefinitionId^ get ();
}
static member ContFootingCannotJoin : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.ContFootingRadiusTooSmall Property

BuiltInFailuresWallFailuresContFootingRadiusTooSmall Property

Can't display the Wall Foundation, because the Wall's radius is too small. Please increase the radius to display the Wall Foundation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ContFootingRadiusTooSmall { get; }
Public Shared ReadOnly Property ContFootingRadiusTooSmall As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ContFootingRadiusTooSmall {
    FailureDefinitionId^ get ();
}
static member ContFootingRadiusTooSmall : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.CurtainOrStackedWallDisallowedForCrossSectionType Property

BuiltInFailuresWallFailuresCurtainOrStackedWallDisallowedForCrossSectionType Property

Curtain wall types and Stacked wall types are not allowed for this wall's cross-section type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId CurtainOrStackedWallDisallowedForCrossSectionType { get; }
Public Shared ReadOnly Property CurtainOrStackedWallDisallowedForCrossSectionType As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ CurtainOrStackedWallDisallowedForCrossSectionType {
    FailureDefinitionId^ get ();
}
static member CurtainOrStackedWallDisallowedForCrossSectionType : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.DisallowedPathCurve Property

BuiltInFailuresWallFailuresDisallowedPathCurve Property

Cannot create stacked elliptical wall with offsets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DisallowedPathCurve { get; }
Public Shared ReadOnly Property DisallowedPathCurve As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DisallowedPathCurve {
    FailureDefinitionId^ get ();
}
static member DisallowedPathCurve : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.EmbeddedButShouldNotBe Property

BuiltInFailuresWallFailuresEmbeddedButShouldNotBe Property

Conditions for wall embedding are no longer satisfied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId EmbeddedButShouldNotBe { get; }
Public Shared ReadOnly Property EmbeddedButShouldNotBe As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ EmbeddedButShouldNotBe {
    FailureDefinitionId^ get ();
}
static member EmbeddedButShouldNotBe : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.ExtrudedWallDisallowedForCrossSectionType Property

BuiltInFailuresWallFailuresExtrudedWallDisallowedForCrossSectionType Property

Edited profiles are not allowed for this wall's cross-section type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ExtrudedWallDisallowedForCrossSectionType { get; }
Public Shared ReadOnly Property ExtrudedWallDisallowedForCrossSectionType As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ExtrudedWallDisallowedForCrossSectionType {
    FailureDefinitionId^ get ();
}
static member ExtrudedWallDisallowedForCrossSectionType : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.FaceBecameVertical Property

BuiltInFailuresWallFailuresFaceBecameVertical Property

Face defining this non-vertical Wall is vertical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FaceBecameVertical { get; }
Public Shared ReadOnly Property FaceBecameVertical As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FaceBecameVertical {
    FailureDefinitionId^ get ();
}
static member FaceBecameVertical : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.FaceIsNoGoodForWall Property

BuiltInFailuresWallFailuresFaceIsNoGoodForWall Property

Defining face is not suitable for walls.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FaceIsNoGoodForWall { get; }
Public Shared ReadOnly Property FaceIsNoGoodForWall As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FaceIsNoGoodForWall {
    FailureDefinitionId^ get ();
}
static member FaceIsNoGoodForWall : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.FaceIsNoLongerVertical Property

BuiltInFailuresWallFailuresFaceIsNoLongerVertical Property

Face defining this vertical Wall is no longer vertical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FaceIsNoLongerVertical { get; }
Public Shared ReadOnly Property FaceIsNoLongerVertical As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FaceIsNoLongerVertical {
    FailureDefinitionId^ get ();
}
static member FaceIsNoLongerVertical : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.FaceWallBadType Property

BuiltInFailuresWallFailuresFaceWallBadType Property

Wall type '[Type Name]' is incompatible with picked face. Only basic wall types are accepted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FaceWallBadType { get; }
Public Shared ReadOnly Property FaceWallBadType As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FaceWallBadType {
    FailureDefinitionId^ get ();
}
static member FaceWallBadType : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.FaceWallComplexType Property

BuiltInFailuresWallFailuresFaceWallComplexType Property

Vertically compound wall type features sweeps, reveals, or split layers are not supported on non-vertical face. Consider using a simplified type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FaceWallComplexType { get; }
Public Shared ReadOnly Property FaceWallComplexType As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FaceWallComplexType {
    FailureDefinitionId^ get ();
}
static member FaceWallComplexType : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.FaceWallFailedToMake Property

BuiltInFailuresWallFailuresFaceWallFailedToMake Property

Can't make Face Wall shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FaceWallFailedToMake { get; }
Public Shared ReadOnly Property FaceWallFailedToMake As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FaceWallFailedToMake {
    FailureDefinitionId^ get ();
}
static member FaceWallFailedToMake : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.FaceWallMissingFace Property

BuiltInFailuresWallFailuresFaceWallMissingFace Property

No picked face found.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FaceWallMissingFace { get; }
Public Shared ReadOnly Property FaceWallMissingFace As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FaceWallMissingFace {
    FailureDefinitionId^ get ();
}
static member FaceWallMissingFace : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.FailedConvertWallToPanel Property

BuiltInFailuresWallFailuresFailedConvertWallToPanel Property

Unable to convert wall to panel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FailedConvertWallToPanel { get; }
Public Shared ReadOnly Property FailedConvertWallToPanel As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FailedConvertWallToPanel {
    FailureDefinitionId^ get ();
}
static member FailedConvertWallToPanel : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.FailedToChangeInstSymbol Property

BuiltInFailuresWallFailuresFailedToChangeInstSymbol Property

Failed to change symbol of instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FailedToChangeInstSymbol { get; }
Public Shared ReadOnly Property FailedToChangeInstSymbol As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FailedToChangeInstSymbol {
    FailureDefinitionId^ get ();
}
static member FailedToChangeInstSymbol : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.FailedToStoreSideFace Property

BuiltInFailuresWallFailuresFailedToStoreSideFace Property

Failed to store wall side face. Wall sweeps on this wall will fail to regenerate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FailedToStoreSideFace { get; }
Public Shared ReadOnly Property FailedToStoreSideFace As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FailedToStoreSideFace {
    FailureDefinitionId^ get ();
}
static member FailedToStoreSideFace : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.InvalidBaseConstraintForLevel Property

BuiltInFailuresWallFailuresInvalidBaseConstraintForLevel Property

Base Constraint is invalid for the Level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidBaseConstraintForLevel { get; }
Public Shared ReadOnly Property InvalidBaseConstraintForLevel As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidBaseConstraintForLevel {
    FailureDefinitionId^ get ();
}
static member InvalidBaseConstraintForLevel : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.InvalidCompoundStructure Property

BuiltInFailuresWallFailuresInvalidCompoundStructure Property

Invalid compound structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidCompoundStructure { get; }
Public Shared ReadOnly Property InvalidCompoundStructure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidCompoundStructure {
    FailureDefinitionId^ get ();
}
static member InvalidCompoundStructure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.InvalidTargetPosition Property

BuiltInFailuresWallFailuresInvalidTargetPosition Property

Joining the highlighted wall to the highlighted element moves the wall's top below its bottom or its bottom above its top, or interferes with wall joins or holes in the wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidTargetPosition { get; }
Public Shared ReadOnly Property InvalidTargetPosition As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidTargetPosition {
    FailureDefinitionId^ get ();
}
static member InvalidTargetPosition : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.InvalidTargetPositionError Property

BuiltInFailuresWallFailuresInvalidTargetPositionError Property

Joining the highlighted wall to the highlighted element moves the wall's top below its bottom or its bottom above its top, or interferes with wall joins or holes in the wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidTargetPositionError { get; }
Public Shared ReadOnly Property InvalidTargetPositionError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidTargetPositionError {
    FailureDefinitionId^ get ();
}
static member InvalidTargetPositionError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.InvalidTopConstraintForLevel Property

BuiltInFailuresWallFailuresInvalidTopConstraintForLevel Property

Top Constraint is invalid for the Level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId InvalidTopConstraintForLevel { get; }
Public Shared ReadOnly Property InvalidTopConstraintForLevel As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ InvalidTopConstraintForLevel {
    FailureDefinitionId^ get ();
}
static member InvalidTopConstraintForLevel : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.LostEditsJoinsRedoFaceBased Property

BuiltInFailuresWallFailuresLostEditsJoinsRedoFaceBased Property

Previous edits and /or wall joins will not be preserved on this operation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId LostEditsJoinsRedoFaceBased { get; }
Public Shared ReadOnly Property LostEditsJoinsRedoFaceBased As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ LostEditsJoinsRedoFaceBased {
    FailureDefinitionId^ get ();
}
static member LostEditsJoinsRedoFaceBased : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.ParameterChangeNotAffectingGeometry Property

BuiltInFailuresWallFailuresParameterChangeNotAffectingGeometry Property

Changing this element's parameter has no effect on its current position or geometry. Check to see if the element is constrained either in the project view or in the element's sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ParameterChangeNotAffectingGeometry { get; }
Public Shared ReadOnly Property ParameterChangeNotAffectingGeometry As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ParameterChangeNotAffectingGeometry {
    FailureDefinitionId^ get ();
}
static member ParameterChangeNotAffectingGeometry : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.RecursionParameterIgnored Property

BuiltInFailuresWallFailuresRecursionParameterIgnored Property

Parameter-defined type of curtain panels defined in a circular way and will be ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RecursionParameterIgnored { get; }
Public Shared ReadOnly Property RecursionParameterIgnored As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RecursionParameterIgnored {
    FailureDefinitionId^ get ();
}
static member RecursionParameterIgnored : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.RemapConstrainLocationLine Property

BuiltInFailuresWallFailuresRemapConstrainLocationLine Property

Existing locked constraints to the Location Line will be transferred to the new Location Line position. Press "Unconstrain" to remove the constraint rather than transferring it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId RemapConstrainLocationLine { get; }
Public Shared ReadOnly Property RemapConstrainLocationLine As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ RemapConstrainLocationLine {
    FailureDefinitionId^ get ();
}
static member RemapConstrainLocationLine : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.ShorterThanMinWall Property

BuiltInFailuresWallFailuresShorterThanMinWall Property

Wall is shorter than minimum height allowed by its type.\nIt is [Length] and must be at least [Length].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ShorterThanMinWall { get; }
Public Shared ReadOnly Property ShorterThanMinWall As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ShorterThanMinWall {
    FailureDefinitionId^ get ();
}
static member ShorterThanMinWall : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.ShorterThanMinWallError Property

BuiltInFailuresWallFailuresShorterThanMinWallError Property

Wall is shorter than minimum height allowed by its type.\nIt is [Length] and must be at least [Length].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ShorterThanMinWallError { get; }
Public Shared ReadOnly Property ShorterThanMinWallError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ShorterThanMinWallError {
    FailureDefinitionId^ get ();
}
static member ShorterThanMinWallError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.ShorterThanMinWallFailure Property

BuiltInFailuresWallFailuresShorterThanMinWallFailure Property

Wall is shorter than minimum height allowed by its type.\nIt is [Length] and must be at least [Length].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ShorterThanMinWallFailure { get; }
Public Shared ReadOnly Property ShorterThanMinWallFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ShorterThanMinWallFailure {
    FailureDefinitionId^ get ();
}
static member ShorterThanMinWallFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.ShouldAdjustWallParameters Property

BuiltInFailuresWallFailuresShouldAdjustWallParameters Property

The best way to control top and base of the Wall is to modify the Constraints and Offset Parameters in Properties dialog.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ShouldAdjustWallParameters { get; }
Public Shared ReadOnly Property ShouldAdjustWallParameters As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ShouldAdjustWallParameters {
    FailureDefinitionId^ get ();
}
static member ShouldAdjustWallParameters : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.StackedWallNeedsUnjoin Property

BuiltInFailuresWallFailuresStackedWallNeedsUnjoin Property

A subwall of this stacked wall is unjoined from its neighbors because it was pulled too far.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId StackedWallNeedsUnjoin { get; }
Public Shared ReadOnly Property StackedWallNeedsUnjoin As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ StackedWallNeedsUnjoin {
    FailureDefinitionId^ get ();
}
static member StackedWallNeedsUnjoin : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.SubwallOfStackedWallDeleted Property

BuiltInFailuresWallFailuresSubwallOfStackedWallDeleted Property

This stacked wall will be deleted because a subwall could not be created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SubwallOfStackedWallDeleted { get; }
Public Shared ReadOnly Property SubwallOfStackedWallDeleted As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SubwallOfStackedWallDeleted {
    FailureDefinitionId^ get ();
}
static member SubwallOfStackedWallDeleted : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.TaperedWallAnglesControlledByType Property

BuiltInFailuresWallFailuresTaperedWallAnglesControlledByType Property

Cannot set angles on a tapered wall which has angles controlled by the type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TaperedWallAnglesControlledByType { get; }
Public Shared ReadOnly Property TaperedWallAnglesControlledByType As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TaperedWallAnglesControlledByType {
    FailureDefinitionId^ get ();
}
static member TaperedWallAnglesControlledByType : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.TooShortStackedWall Property

BuiltInFailuresWallFailuresTooShortStackedWall Property

Stacked wall instance is too short.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId TooShortStackedWall { get; }
Public Shared ReadOnly Property TooShortStackedWall As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ TooShortStackedWall {
    FailureDefinitionId^ get ();
}
static member TooShortStackedWall : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.UnableToCreateWallForPanel Property

BuiltInFailuresWallFailuresUnableToCreateWallForPanel Property

Unable to create wall for curtain wall panel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnableToCreateWallForPanel { get; }
Public Shared ReadOnly Property UnableToCreateWallForPanel As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnableToCreateWallForPanel {
    FailureDefinitionId^ get ();
}
static member UnableToCreateWallForPanel : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.UnableToDeleteWallForPanel Property

BuiltInFailuresWallFailuresUnableToDeleteWallForPanel Property

Unable to delete curtain panel wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnableToDeleteWallForPanel { get; }
Public Shared ReadOnly Property UnableToDeleteWallForPanel As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnableToDeleteWallForPanel {
    FailureDefinitionId^ get ();
}
static member UnableToDeleteWallForPanel : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.UnjoinOnEditWallChange Property

BuiltInFailuresWallFailuresUnjoinOnEditWallChange Property

Line associated with a joined face has been moved. This action will cause the other walls to become disjoined from this face. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId UnjoinOnEditWallChange { get; }
Public Shared ReadOnly Property UnjoinOnEditWallChange As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ UnjoinOnEditWallChange {
    FailureDefinitionId^ get ();
}
static member UnjoinOnEditWallChange : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.VerticalLayerExtensionFailure Property

BuiltInFailuresWallFailuresVerticalLayerExtensionFailure Property

Cannot extend layer(s) of the highlighted vertically compound wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId VerticalLayerExtensionFailure { get; }
Public Shared ReadOnly Property VerticalLayerExtensionFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ VerticalLayerExtensionFailure {
    FailureDefinitionId^ get ();
}
static member VerticalLayerExtensionFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.VerticalLayerExtensionFailureError Property

BuiltInFailuresWallFailuresVerticalLayerExtensionFailureError Property

Cannot extend layer(s) of the highlighted vertically compound wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId VerticalLayerExtensionFailureError { get; }
Public Shared ReadOnly Property VerticalLayerExtensionFailureError As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ VerticalLayerExtensionFailureError {
    FailureDefinitionId^ get ();
}
static member VerticalLayerExtensionFailureError : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.WallCutoutForInsertionFailure Property

BuiltInFailuresWallFailuresWallCutoutForInsertionFailure Property

Can't cut wall for inserted objects

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WallCutoutForInsertionFailure { get; }
Public Shared ReadOnly Property WallCutoutForInsertionFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WallCutoutForInsertionFailure {
    FailureDefinitionId^ get ();
}
static member WallCutoutForInsertionFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.WallLacksCurve Property

BuiltInFailuresWallFailuresWallLacksCurve Property

Wall does not have both a curve driver and a curve!!!!

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WallLacksCurve { get; }
Public Shared ReadOnly Property WallLacksCurve As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WallLacksCurve {
    FailureDefinitionId^ get ();
}
static member WallLacksCurve : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.WallNegativeHeight Property

BuiltInFailuresWallFailuresWallNegativeHeight Property

The top of the Wall is lower than the base of the Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WallNegativeHeight { get; }
Public Shared ReadOnly Property WallNegativeHeight As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WallNegativeHeight {
    FailureDefinitionId^ get ();
}
static member WallNegativeHeight : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.WallSettingsChanged Property

BuiltInFailuresWallFailuresWallSettingsChanged Property

Default wall settings will be changed (Base Constraint: [Base Level], Base Offset: [Base Offset], Top Constraint: [Top Level], Top Offset: [Top Offset])

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WallSettingsChanged { get; }
Public Shared ReadOnly Property WallSettingsChanged As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WallSettingsChanged {
    FailureDefinitionId^ get ();
}
static member WallSettingsChanged : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallFailures.WallTypeIncompatibleWithTapered Property

BuiltInFailuresWallFailuresWallTypeIncompatibleWithTapered Property

This wall's type is not compatible with the Tapered cross-section. Tapered walls require a variable thickness layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WallTypeIncompatibleWithTapered { get; }
Public Shared ReadOnly Property WallTypeIncompatibleWithTapered As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WallTypeIncompatibleWithTapered {
    FailureDefinitionId^ get ();
}
static member WallTypeIncompatibleWithTapered : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallFailures Class


BuiltInFailures.WallJoinFailures Class

BuiltInFailuresWallJoinFailures Class

Failures about WallJoin.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresWallJoinFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class WallJoinFailures
Public NotInheritable Class WallJoinFailures
public ref class WallJoinFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type WallJoinFailures = class end

The BuiltInFailuresWallJoinFailures type exposes the following members.

Properties
Name | Description
FailedToChangeWallJointsTypeFailure | Some of the joints you have selected can only have one wall joint type, so these joints haven't been changed.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


WallJoinFailures Properties

The BuiltInFailuresWallJoinFailures type exposes the following members.

Properties
Name | Description
FailedToChangeWallJointsTypeFailure | Some of the joints you have selected can only have one wall joint type, so these joints haven't been changed.
Top
See Also

Reference

BuiltInFailuresWallJoinFailures Class


BuiltInFailures.WallJoinFailures.FailedToChangeWallJointsTypeFailure Property

BuiltInFailuresWallJoinFailuresFailedToChangeWallJointsTypeFailure Property

Some of the joints you have selected can only have one wall joint type, so these joints haven't been changed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId FailedToChangeWallJointsTypeFailure { get; }
Public Shared ReadOnly Property FailedToChangeWallJointsTypeFailure As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ FailedToChangeWallJointsTypeFailure {
    FailureDefinitionId^ get ();
}
static member FailedToChangeWallJointsTypeFailure : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallJoinFailures Class


BuiltInFailures.WallJoinRoofFailures Class

BuiltInFailuresWallJoinRoofFailures Class

Failures about WallJoinRoof.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresWallJoinRoofFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class WallJoinRoofFailures
Public NotInheritable Class WallJoinRoofFailures
public ref class WallJoinRoofFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type WallJoinRoofFailures = class end

The BuiltInFailuresWallJoinRoofFailures type exposes the following members.

Properties
Name | Description
NoFromRoofForWall | Highlighted wall is set to be "From roof", however there is no roof below it that can be used.
NotCoveredAtAllByTarget | Highlighted walls are attached to, but miss, the highlighted targets.
NoUptoRoofForWall | Highlighted wall is set to be "Up to roof", however there is no roof above it that can be used.
WallMeetsRoofTangentially | The highlighted wall cannot be joined to the highlighted roof because the wall meets the roof tangentially.
WallNotCoveredByRoof | The highlighted wall(s) cannot be joined to the highlighted roof because the roof does not entirely cover the wall(s).
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


WallJoinRoofFailures Properties

The BuiltInFailuresWallJoinRoofFailures type exposes the following members.

Properties
Name | Description
NoFromRoofForWall | Highlighted wall is set to be "From roof", however there is no roof below it that can be used.
NotCoveredAtAllByTarget | Highlighted walls are attached to, but miss, the highlighted targets.
NoUptoRoofForWall | Highlighted wall is set to be "Up to roof", however there is no roof above it that can be used.
WallMeetsRoofTangentially | The highlighted wall cannot be joined to the highlighted roof because the wall meets the roof tangentially.
WallNotCoveredByRoof | The highlighted wall(s) cannot be joined to the highlighted roof because the roof does not entirely cover the wall(s).
Top
See Also

Reference

BuiltInFailuresWallJoinRoofFailures Class


BuiltInFailures.WallJoinRoofFailures.NoFromRoofForWall Property

BuiltInFailuresWallJoinRoofFailuresNoFromRoofForWall Property

Highlighted wall is set to be "From roof", however there is no roof below it that can be used.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoFromRoofForWall { get; }
Public Shared ReadOnly Property NoFromRoofForWall As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoFromRoofForWall {
    FailureDefinitionId^ get ();
}
static member NoFromRoofForWall : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallJoinRoofFailures Class


BuiltInFailures.WallJoinRoofFailures.NotCoveredAtAllByTarget Property

BuiltInFailuresWallJoinRoofFailuresNotCoveredAtAllByTarget Property

Highlighted walls are attached to, but miss, the highlighted targets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NotCoveredAtAllByTarget { get; }
Public Shared ReadOnly Property NotCoveredAtAllByTarget As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NotCoveredAtAllByTarget {
    FailureDefinitionId^ get ();
}
static member NotCoveredAtAllByTarget : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallJoinRoofFailures Class


BuiltInFailures.WallJoinRoofFailures.NoUptoRoofForWall Property

BuiltInFailuresWallJoinRoofFailuresNoUptoRoofForWall Property

Highlighted wall is set to be "Up to roof", however there is no roof above it that can be used.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId NoUptoRoofForWall { get; }
Public Shared ReadOnly Property NoUptoRoofForWall As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ NoUptoRoofForWall {
    FailureDefinitionId^ get ();
}
static member NoUptoRoofForWall : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallJoinRoofFailures Class


BuiltInFailures.WallJoinRoofFailures.WallMeetsRoofTangentially Property

BuiltInFailuresWallJoinRoofFailuresWallMeetsRoofTangentially Property

The highlighted wall cannot be joined to the highlighted roof because the wall meets the roof tangentially.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WallMeetsRoofTangentially { get; }
Public Shared ReadOnly Property WallMeetsRoofTangentially As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WallMeetsRoofTangentially {
    FailureDefinitionId^ get ();
}
static member WallMeetsRoofTangentially : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallJoinRoofFailures Class


BuiltInFailures.WallJoinRoofFailures.WallNotCoveredByRoof Property

BuiltInFailuresWallJoinRoofFailuresWallNotCoveredByRoof Property

The highlighted wall(s) cannot be joined to the highlighted roof because the roof does not entirely cover the wall(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId WallNotCoveredByRoof { get; }
Public Shared ReadOnly Property WallNotCoveredByRoof As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ WallNotCoveredByRoof {
    FailureDefinitionId^ get ();
}
static member WallNotCoveredByRoof : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWallJoinRoofFailures Class


BuiltInFailures.WorksharingFailures Class

BuiltInFailuresWorksharingFailures Class

Failures about WorksharingFailures.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresWorksharingFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class WorksharingFailures
Public NotInheritable Class WorksharingFailures
public ref class WorksharingFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type WorksharingFailures = class end

The BuiltInFailuresWorksharingFailures type exposes the following members.

Properties
Name | Description
DuplicateNamesChanged | These elements' names were automatically changed to eliminate duplicates.
MissingUpdaterLatestOrCentralPlural | The file [File Name] you are trying to synchronize was modified by the third-party updaters [Updater Name(s)] which are not currently installed. \n\r \n\r If you continue to Synchronize with Central or Reload Latest, data maintained by these updaters will not be updated properly. This may create problems when [File Name] is later opened when [Updater Name(s)] are present.
MissingUpdaterLatestOrCentralSingular | The file [File Name] you are trying to synchronize was modified by the third-party updater [Updater Name(s)] which is not currently installed. \n\r \n\r If you continue to Synchronize with Central or Reload Latest, data maintained by this updater will not be updated properly. This may create problems when [File Name] is later opened when [Updater Name(s)] is present.
SeriousElementReferenceCorruption | Element references are seriously corrupt.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


WorksharingFailures Properties

The BuiltInFailuresWorksharingFailures type exposes the following members.

Properties
Name | Description
DuplicateNamesChanged | These elements' names were automatically changed to eliminate duplicates.
MissingUpdaterLatestOrCentralPlural | The file [File Name] you are trying to synchronize was modified by the third-party updaters [Updater Name(s)] which are not currently installed. \n\r \n\r If you continue to Synchronize with Central or Reload Latest, data maintained by these updaters will not be updated properly. This may create problems when [File Name] is later opened when [Updater Name(s)] are present.
MissingUpdaterLatestOrCentralSingular | The file [File Name] you are trying to synchronize was modified by the third-party updater [Updater Name(s)] which is not currently installed. \n\r \n\r If you continue to Synchronize with Central or Reload Latest, data maintained by this updater will not be updated properly. This may create problems when [File Name] is later opened when [Updater Name(s)] is present.
SeriousElementReferenceCorruption | Element references are seriously corrupt.
Top
See Also

Reference

BuiltInFailuresWorksharingFailures Class


BuiltInFailures.WorksharingFailures.DuplicateNamesChanged Property

BuiltInFailuresWorksharingFailuresDuplicateNamesChanged Property

These elements' names were automatically changed to eliminate duplicates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId DuplicateNamesChanged { get; }
Public Shared ReadOnly Property DuplicateNamesChanged As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ DuplicateNamesChanged {
    FailureDefinitionId^ get ();
}
static member DuplicateNamesChanged : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWorksharingFailures Class


BuiltInFailures.WorksharingFailures.MissingUpdaterLatestOrCentralPlural Property

BuiltInFailuresWorksharingFailuresMissingUpdaterLatestOrCentralPlural Property

The file [File Name] you are trying to synchronize was modified by the third-party updaters [Updater Name(s)] which are not currently installed. \n\r \n\r If you continue to Synchronize with Central or Reload Latest, data maintained by these updaters will not be updated properly. This may create problems when [File Name] is later opened when [Updater Name(s)] are present.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MissingUpdaterLatestOrCentralPlural { get; }
Public Shared ReadOnly Property MissingUpdaterLatestOrCentralPlural As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MissingUpdaterLatestOrCentralPlural {
    FailureDefinitionId^ get ();
}
static member MissingUpdaterLatestOrCentralPlural : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWorksharingFailures Class


BuiltInFailures.WorksharingFailures.MissingUpdaterLatestOrCentralSingular Property

BuiltInFailuresWorksharingFailuresMissingUpdaterLatestOrCentralSingular Property

The file [File Name] you are trying to synchronize was modified by the third-party updater [Updater Name(s)] which is not currently installed. \n\r \n\r If you continue to Synchronize with Central or Reload Latest, data maintained by this updater will not be updated properly. This may create problems when [File Name] is later opened when [Updater Name(s)] is present.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId MissingUpdaterLatestOrCentralSingular { get; }
Public Shared ReadOnly Property MissingUpdaterLatestOrCentralSingular As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ MissingUpdaterLatestOrCentralSingular {
    FailureDefinitionId^ get ();
}
static member MissingUpdaterLatestOrCentralSingular : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWorksharingFailures Class


BuiltInFailures.WorksharingFailures.SeriousElementReferenceCorruption Property

BuiltInFailuresWorksharingFailuresSeriousElementReferenceCorruption Property

Element references are seriously corrupt.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId SeriousElementReferenceCorruption { get; }
Public Shared ReadOnly Property SeriousElementReferenceCorruption As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ SeriousElementReferenceCorruption {
    FailureDefinitionId^ get ();
}
static member SeriousElementReferenceCorruption : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresWorksharingFailures Class


BuiltInFailures.ZoneFailures Class

BuiltInFailuresZoneFailures Class

Failures about Zone.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBuiltInFailuresZoneFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ZoneFailures
Public NotInheritable Class ZoneFailures
public ref class ZoneFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ZoneFailures = class end

The BuiltInFailuresZoneFailures type exposes the following members.

Properties
Name | Description
ZoneExistsNotEnclosedRoom | Zone has a room not enclosed.
ZoneNotEnclosed | Zone not enclosed totally.
ZonesOverlapWarning | Zone overlap to another zone or another room.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ZoneFailures Properties

The BuiltInFailuresZoneFailures type exposes the following members.

Properties
Name | Description
ZoneExistsNotEnclosedRoom | Zone has a room not enclosed.
ZoneNotEnclosed | Zone not enclosed totally.
ZonesOverlapWarning | Zone overlap to another zone or another room.
Top
See Also

Reference

BuiltInFailuresZoneFailures Class


BuiltInFailures.ZoneFailures.ZoneExistsNotEnclosedRoom Property

BuiltInFailuresZoneFailuresZoneExistsNotEnclosedRoom Property

Zone has a room not enclosed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ZoneExistsNotEnclosedRoom { get; }
Public Shared ReadOnly Property ZoneExistsNotEnclosedRoom As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ZoneExistsNotEnclosedRoom {
    FailureDefinitionId^ get ();
}
static member ZoneExistsNotEnclosedRoom : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresZoneFailures Class


BuiltInFailures.ZoneFailures.ZoneNotEnclosed Property

BuiltInFailuresZoneFailuresZoneNotEnclosed Property

Zone not enclosed totally.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ZoneNotEnclosed { get; }
Public Shared ReadOnly Property ZoneNotEnclosed As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ZoneNotEnclosed {
    FailureDefinitionId^ get ();
}
static member ZoneNotEnclosed : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresZoneFailures Class


BuiltInFailures.ZoneFailures.ZonesOverlapWarning Property

BuiltInFailuresZoneFailuresZonesOverlapWarning Property

Zone overlap to another zone or another room.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinitionId ZonesOverlapWarning { get; }
Public Shared ReadOnly Property ZonesOverlapWarning As FailureDefinitionId
    Get
public:
static property FailureDefinitionId^ ZonesOverlapWarning {
    FailureDefinitionId^ get ();
}
static member ZonesOverlapWarning : FailureDefinitionId with get

Property Value

FailureDefinitionId
See Also

Reference

BuiltInFailuresZoneFailures Class


BuiltInParameter Enumeration

An enumerated type listing all of the built-in parameter IDs supported by Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum BuiltInParameter
Public Enumeration BuiltInParameter
public enum class BuiltInParameter
type BuiltInParameter
Members
Member name | Value | Description
INVALID | -1 |
WALL_ATTR_WIDTH_PARAM | -1,001,000 | "Width"
WALL_ATTR_HEIGHT_PARAM | -1,001,001 | "Height"
WALL_ATTR_DEFHEIGHT_PARAM | -1,001,002 | "Default height"
FUNCTION_PARAM | -1,001,006 | "Function"
WALL_ATTR_ROOM_BOUNDING | -1,001,007 | "Room Bounding"
ALLOW_AUTO_EMBED | -1,001,009 | "Automatically Embed"
SCALE_FACTOR_PARAM | -1,001,010 | "Scale"
WALL_BASE_HEIGHT_PARAM | -1,001,102 | "Base height"
WALL_HEIGHT_TYPE | -1,001,103 | "Top Constraint"
WALL_USER_HEIGHT_PARAM | -1,001,105 | "Unconnected Height"
WALL_BASE_CONSTRAINT | -1,001,107 | "Base Constraint"
WALL_BASE_OFFSET | -1,001,108 | "Base Offset"
WALL_TOP_OFFSET | -1,001,109 | "Top Offset"
WALL_TOP_IS_ATTACHED | -1,001,117 | "Top is Attached"
WALL_BOTTOM_IS_ATTACHED | -1,001,118 | "Base is Attached"
WALL_STRUCTURAL_USAGE_PARAM | -1,001,119 | "Structural Usage"
MEASURE_FROM_STRUCTURE | -1,001,120 | "Extend into wall (to core)"
WALL_KEY_REF_PARAM | -1,001,122 | "Location Line"
WALL_LOCATION_LINE_OFFSET_PARAM | -1,001,123 | "Location Line Offset"
HOST_PANEL_SCHEDULE_AS_PANEL_PARAM | -1,001,124 | "Categorize as"
DPART_ORIGINAL_CATEGORY | -1,001,125 | "Original Category"
DPART_ORIGINAL_FAMILY | -1,001,126 | "Original Family"
DPART_MATERIAL_ID_PARAM | -1,001,127 | "Material"
DPART_MATERIAL_BY_ORIGINAL | -1,001,128 | "Material By Original"
DPART_VOLUME_COMPUTED | -1,001,129 | "Volume"
DPART_LAYER_FUNCTION | -1,001,130 | "Layer Function"
OFFSETFACES_SHOW_SHAPE_HANDLES | -1,001,131 | "Show Shape Handles"
DPART_ORIGINAL_TYPE | -1,001,132 | "Original Type"
DPART_AREA_COMPUTED | -1,001,133 | "Area"
DPART_LAYER_WIDTH | -1,001,134 | "Thickness"
DPART_HEIGHT_COMPUTED | -1,001,135 | "Height"
DPART_LENGTH_COMPUTED | -1,001,136 | "Length"
DPART_PHASE_CREATED_BY_ORIGINAL | -1,001,137 | "Phase Created By Original"
DPART_PHASE_DEMOLISHED_BY_ORIGINAL | -1,001,138 | "Phase Demolished By Original"
DPART_LAYER_CONSTRUCTION | -1,001,139 | "Construction"
DPART_ORIGINAL_CATEGORY_ID | -1,001,140 | "Original Category"
DOOR_NUMBER | -1,001,203 | "Mark"
ALL_MODEL_MARK | -1,001,203 | "Mark"
DOOR_COST | -1,001,205 | "Cost"
ALL_MODEL_COST | -1,001,205 | "Cost"
FIRE_RATING | -1,001,206 | "Fire Rating"
DOOR_FIRE_RATING | -1,001,206 | "Fire Rating"
DOOR_CONSTRUCTION_TYPE | -1,001,207 | "Construction Type"
CASEWORK_CONSTRUCTION_TYPE | -1,001,207 | "Construction Type"
CURTAIN_WALL_PANELS_CONSTRUCTION_TYPE | -1,001,207 | "Construction Type"
GENERIC_CONSTRUCTION_TYPE | -1,001,207 | "Construction Type"
WINDOW_CONSTRUCTION_TYPE | -1,001,207 | "Construction Type"
DOOR_FINISH | -1,001,208 | "Finish"
CASEWORK_FINISH | -1,001,208 | "Finish"
CURTAIN_WALL_PANELS_FINISH | -1,001,208 | "Finish"
GENERIC_FINISH | -1,001,208 | "Finish"
DOOR_FRAME_TYPE | -1,001,209 | "Frame Type"
DOOR_FRAME_MATERIAL | -1,001,210 | "Frame Material"
DOOR_OPERATION_TYPE | -1,001,211 | "Operation"
WINDOW_OPERATION_TYPE | -1,001,211 | "Operation"
DOOR_EVACUATION_EXIT_TYPE | -1,001,212 | "Exit Access"
FAMILY_HEIGHT_PARAM | -1,001,300 | "Height"
CASEWORK_HEIGHT | -1,001,300 | "Height"
DOOR_HEIGHT | -1,001,300 | "Height"
FURNITURE_HEIGHT | -1,001,300 | "Height"
GENERIC_HEIGHT | -1,001,300 | "Height"
WINDOW_HEIGHT | -1,001,300 | "Height"
FAMILY_WIDTH_PARAM | -1,001,301 | "Width"
CASEWORK_WIDTH | -1,001,301 | "Width"
DOOR_WIDTH | -1,001,301 | "Width"
FURNITURE_WIDTH | -1,001,301 | "Width"
GENERIC_WIDTH | -1,001,301 | "Width"
WINDOW_WIDTH | -1,001,301 | "Width"
FAMILY_THICKNESS_PARAM | -1,001,302 | "Thickness"
DOOR_THICKNESS | -1,001,302 | "Thickness"
FURNITURE_THICKNESS | -1,001,302 | "Thickness"
GENERIC_THICKNESS | -1,001,302 | "Thickness"
WINDOW_THICKNESS | -1,001,302 | "Thickness"
FAMILY_WINDOW_INSET_PARAM | -1,001,303 | "Inset"
WINDOW_INSET | -1,001,303 | "Inset"
FAMILY_ROUGH_HEIGHT_PARAM | -1,001,304 | "Rough Height"
FAMILY_ROUGH_WIDTH_PARAM | -1,001,305 | "Rough Width"
FAMILY_LINE_LENGTH_PARAM | -1,001,306 | "Length"
FAMILY_WPB_DEFAULT_ELEVATION | -1,001,320 | "Default Elevation"
FAMILY_USAGE_PSEUDO_PARAM | -1,001,335 | "Usage"
FAMILY_NAME_PSEUDO_PARAM | -1,001,336 | "Family"
FAMILY_CATEGORY_PSEUDO_PARAM | -1,001,337 | "Category"
FAMILY_RFA_PATH_PSEUDO_PARAM | -1,001,338 | "File Path"
FAMILY_BASE_LEVEL_PARAM | -1,001,350 | "Base Level"
FAMILY_TOP_LEVEL_PARAM | -1,001,351 | "Top Level"
FAMILY_LEVEL_PARAM | -1,001,352 | "Level"
FAMILY_BASE_LEVEL_OFFSET_PARAM | -1,001,357 | "Base Offset"
FAMILY_TOP_LEVEL_OFFSET_PARAM | -1,001,358 | "Top Offset"
INSTANCE_ELEVATION_PARAM | -1,001,360 | "Elevation from Level"
INSTANCE_SILL_HEIGHT_PARAM | -1,001,361 | "Sill Height"
INSTANCE_HEAD_HEIGHT_PARAM | -1,001,362 | "Head Height"
INSTANCE_FREE_HOST_PARAM | -1,001,363 | "Host"
INSTANCE_FREE_HOST_OFFSET_PARAM | -1,001,364 | "Offset from Host"
INSTANCE_SCHEDULE_ONLY_LEVEL_PARAM | -1,001,365 | "Schedule Level"
INSTANCE_OFFSET_POS_PARAM | -1,001,370 | "Moves With Nearby Elements"
INSTANCE_MOVES_WITH_GRID_PARAM | -1,001,371 | "Moves With Grids"
INSTANCE_LENGTH_PARAM | -1,001,375 | "Length"
SKETCH_PLANE_PARAM | -1,001,380 | "Work Plane"
INSTANCE_STRUCT_USAGE_PARAM | -1,001,381 | "Structural Usage"
INSTANCE_REFERENCE_LEVEL_PARAM | -1,001,383 | "Reference Level"
STRUCTURAL_FRAME_CUT_LENGTH | -1,001,384 | "Cut Length"
STRUCTURAL_ATTACHMENT_START_TYPE | -1,001,385 | "Start Attachment Type"
STRUCTURAL_ATTACHMENT_END_TYPE | -1,001,386 | "End Attachment Type"
STRUCTURAL_ATTACHMENT_START_VALUE_DISTANCE | -1,001,387 | "Start Attachment Distance"
STRUCTURAL_ATTACHMENT_END_VALUE_DISTANCE | -1,001,388 | "End Attachment Distance"
STRUCTURAL_ATTACHMENT_START_REFELEMENT_END | -1,001,389 | "Start of Attachment to Reference Element"
TYPE_WALL_CLOSURE | -1,001,390 | "Wall Closure"
STRUCTURAL_ATTACHMENT_END_REFELEMENT_END | -1,001,391 | "End of Attachment to Reference Element"
STRUCTURAL_ATTACHMENT_START_VALUE_RATIO | -1,001,392 | "Start Attachment Ratio"
STRUCTURAL_ATTACHMENT_END_VALUE_RATIO | -1,001,393 | "End attachment ratio"
STRUCTURAL_ATTACHMENT_START_LEVEL_REFERENCE | -1,001,395 | "Start Attachment Level Reference"
STRUCTURAL_ATTACHMENT_END_LEVEL_REFERENCE | -1,001,396 | "End Attachment Level Reference"
STRUCTURAL_ATTACHMENT_START_VALUE_ELEVATION | -1,001,397 | "Start Attachment Elevation"
STRUCTURAL_ATTACHMENT_END_VALUE_ELEVATION | -1,001,398 | "End Attachment Elevation"
WALL_SWEEP_ORIENTATION | -1,001,399 | "Orientation"
WINDOW_TYPE_ID | -1,001,405 | "Type Mark"
ALL_MODEL_TYPE_MARK | -1,001,405 | "Type Mark"
STRUCTURAL_BEAM_START_SUPPORT | -1,001,501 | "Beam Start Pocket Seat"
STRUCTURAL_BEAM_END_SUPPORT | -1,001,502 | "Beam End Pocket Seat"
STRUCTURAL_STICK_SYMBOL_LOCATION | -1,001,503 | "Stick Symbol Location"
STRUCTURAL_BRACE_REPRESENTATION | -1,001,507 | "Representation Type"
STRUCTURAL_ANALYTICAL_PROJECT_MEMBER_PLANE | -1,001,508 | "Vertical Projection"
STRUCTURAL_ANALYTICAL_PROJECT_FLOOR_PLANE | -1,001,510 | "Vertical Projection"
STRUCTURAL_WALL_PROJECTION_SURFACE | -1,001,512 | "Horizontal Projection"
STRUCTURAL_WALL_TOP_PROJECTION_PLANE | -1,001,513 | "Top Vertical Projection"
STRUCTURAL_WALL_BOTTOM_PROJECTION_PLANE | -1,001,514 | "Bottom Vertical Projection"
STRUCTURAL_START_RELEASE_TYPE | -1,001,515 | "Start Release"
STRUCTURAL_END_RELEASE_TYPE | -1,001,516 | "End Release"
STRUCTURAL_START_RELEASE_FX | -1,001,517 | "Start Fx"
STRUCTURAL_START_RELEASE_FY | -1,001,518 | "Start Fy"
STRUCTURAL_START_RELEASE_FZ | -1,001,519 | "Start Fz"
STRUCTURAL_START_RELEASE_MX | -1,001,520 | "Start Mx"
STRUCTURAL_START_RELEASE_MY | -1,001,521 | "Start My"
STRUCTURAL_START_RELEASE_MZ | -1,001,522 | "Start Mz"
STRUCTURAL_END_RELEASE_FX | -1,001,523 | "End Fx"
STRUCTURAL_END_RELEASE_FY | -1,001,524 | "End Fy"
STRUCTURAL_END_RELEASE_FZ | -1,001,525 | "End Fz"
STRUCTURAL_END_RELEASE_MX | -1,001,526 | "End Mx"
STRUCTURAL_END_RELEASE_MY | -1,001,527 | "End My"
STRUCTURAL_END_RELEASE_MZ | -1,001,528 | "End Mz"
STRUCTURAL_NUMBER_OF_STUDS | -1,001,529 | "Number of studs"
STRUCTURAL_CAMBER | -1,001,530 | "Camber Size"
STRUCTURAL_MATERIAL_TYPE | -1,001,531 | "Structural Material Type"
STRUCTURAL_ANALYTICAL_PROJECT_MEMBER_PLANE_COLUMN_TOP | -1,001,534 | "Top Vertical Projection"
STRUCTURAL_ANALYTICAL_PROJECT_MEMBER_PLANE_COLUMN_BOTTOM | -1,001,535 | "Bottom Vertical Projection"
STRUCTURAL_TOP_RELEASE_TYPE | -1,001,536 | "Top Release"
STRUCTURAL_BOTTOM_RELEASE_TYPE | -1,001,537 | "Base Release"
STRUCTURAL_TOP_RELEASE_FX | -1,001,538 | "Top Fx"
STRUCTURAL_TOP_RELEASE_FY | -1,001,539 | "Top Fy"
STRUCTURAL_TOP_RELEASE_FZ | -1,001,540 | "Top Fz"
STRUCTURAL_TOP_RELEASE_MX | -1,001,541 | "Top Mx"
STRUCTURAL_TOP_RELEASE_MY | -1,001,542 | "Top My"
STRUCTURAL_TOP_RELEASE_MZ | -1,001,543 | "Top Mz"
STRUCTURAL_BOTTOM_RELEASE_FX | -1,001,544 | "Base Fx"
STRUCTURAL_BOTTOM_RELEASE_FY | -1,001,545 | "Base Fy"
STRUCTURAL_BOTTOM_RELEASE_FZ | -1,001,546 | "Base Fz"
STRUCTURAL_BOTTOM_RELEASE_MX | -1,001,547 | "Base Mx"
STRUCTURAL_BOTTOM_RELEASE_MY | -1,001,548 | "Base My"
STRUCTURAL_BOTTOM_RELEASE_MZ | -1,001,549 | "Base Mz"
FAMILY_STRUCT_MATERIAL_TYPE | -1,001,550 | "Material for Model Behavior"
STRUCTURAL_ANALYTICAL_COLUMN_RIGID_LINK | -1,001,551 | "Analytical Links"
STRUCTURAL_ANALYTICAL_MODEL | -1,001,552 | "Enable Analytical Model"
CONTINUOUS_FOOTING_TOP_TOE | -1,001,553 | "Toe Length"
CONTINUOUS_FOOTING_BOTTOM_TOE | -1,001,554 | "Bottom Toe Length"
CONTINUOUS_FOOTING_TOP_HEEL | -1,001,555 | "Heel Length"
CONTINUOUS_FOOTING_BOTTOM_HEEL | -1,001,556 | "Bottom Heel Length"
STRUCTURAL_FOUNDATION_THICKNESS | -1,001,557 | "Foundation Thickness"
CONTINUOUS_FOOTING_WIDTH | -1,001,558 | "Width"
STRUCTURAL_COPING_DISTANCE | -1,001,559 | "Coping Distance"
FAMILY_STRUCT_FOOTING_USE_CAP_TOP | -1,001,560 | "Cap"
STRUCTURAL_ELEVATION_AT_BOTTOM | -1,001,561 | "Elevation at Bottom"
CONTINUOUS_FOOTING_BEARING_WIDTH | -1,001,562 | "Width"
CONTINUOUS_FOOTING_STRUCTURAL_USAGE | -1,001,563 | "Structural Usage"
CONTINUOUS_FOOTING_ECCENTRICITY | -1,001,564 | "Eccentricity"
CONTINUOUS_FOOTING_LENGTH | -1,001,567 | "Length"
STRUCTURAL_FOUNDATION_WIDTH | -1,001,568 | "Width"
STRUCTURAL_FOUNDATION_LENGTH | -1,001,569 | "Length"
FAMILY_EXPORT_AS_GEOMETRY | -1,001,570 | "Always export as geometry"
STRUCTURAL_BEAM_END0_ELEVATION | -1,001,571 | "Start Level Offset"
STRUCTURAL_BEAM_END1_ELEVATION | -1,001,572 | "End Level Offset"
STRUCTURAL_BEAM_ORIENTATION | -1,001,573 | "Orientation"
BEAM_V_JUSTIFICATION_OTHER_VALUE | -1,001,574 | "z-Direction Offset Value"
STRUCTURAL_BEAM_CUTBACK_FOR_COLUMN | -1,001,575 | "Beam cutback in plan"
STRUCTURAL_ANALYZES_AS | -1,001,576 | "Analyze As"
STRUCTURAL_FLOOR_ANALYZES_AS | -1,001,577 | "Analyze As"
STRUCTURAL_DISPLAY_IN_HIDDEN_VIEWS_FRAMING | -1,001,584 | "Display in Hidden Views"
STRUCTURAL_DISPLAY_IN_HIDDEN_VIEWS_COLUMN | -1,001,585 | "Display in Hidden Views"
STRUCTURAL_BEND_DIR_ANGLE | -1,001,586 | "Cross-Section Rotation"
STRUCTURAL_ANALYTICAL_HARD_POINTS | -1,001,587 | "Use hard-points"
STRUCTURAL_ANALYTICAL_TESS_DEVIATION | -1,001,588 | "Maximum discretized offset"
STRUCTURAL_ANALYTICAL_TESSELLATE | -1,001,589 | "Approximate curve"
CONTINUOUS_FOOTING_DEFAULT_END_EXTENSION_LENGTH | -1,001,591 | "Default End Extension Length"
CONTINUOUS_FOOTING_BREAK_AT_INSERTS_DISABLE | -1,001,592 | "Do Not Break At Inserts"
STRUCTURAL_ANALYTICAL_BEAM_HORIZONTAL_PROJECTION_PLANE | -1,001,593 | "Horizontal Projection"
STRUCTURAL_ANALYTICAL_COLUMN_HORIZONTAL_PROJECTION_PLANE | -1,001,594 | "Horizontal Projection"
STRUCTURAL_ANALYTICAL_BEAM_RIGID_LINK | -1,001,595 | "Analytical Links"
WALL_STRUCTURAL_SIGNIFICANT | -1,001,596 | "Structural"
NODE_CONNECTION_STATUS | -1,001,597 | "Connection Status"
STRUCTURAL_ELEVATION_AT_TOP | -1,001,598 | "Elevation at Top"
ROOF_ATTR_DEFAULT_THICKNESS_PARAM | -1,001,600 | "Default Thickness"
ROOF_ATTR_THICKNESS_PARAM | -1,001,601 | "Thickness"
HOST_SSE_CURVED_EDGE_CONDITION_PARAM | -1,001,603 | "Curved Edge Condition"
ROOF_CONSTRAINT_LEVEL_PARAM | -1,001,651 | "Reference Level"
ROOF_CONSTRAINT_OFFSET_PARAM | -1,001,652 | "Level Offset"
STRUCTURAL_REFERENCE_LEVEL_ELEVATION | -1,001,653 | "Reference Level Elevation"
STRUCTURAL_ELEVATION_AT_TOP_CORE | -1,001,654 | "Elevation at Top Core"
STRUCTURAL_ELEVATION_AT_BOTTOM_CORE | -1,001,655 | "Elevation at Bottom Core"
STRUCTURAL_FLOOR_CORE_THICKNESS | -1,001,656 | "Core Thickness"
STRUCTURAL_ELEVATION_AT_TOP_SURVEY | -1,001,657 | "Elevation at Top Survey"
STRUCTURAL_ELEVATION_AT_BOTTOM_SURVEY | -1,001,658 | "Elevation at Bottom Survey"
ROOF_LEVEL_OFFSET_PARAM | -1,001,701 | "Base Offset From Level"
ROOF_UPTO_LEVEL_PARAM | -1,001,702 | "Cutoff Level"
ROOF_UPTO_LEVEL_OFFSET_PARAM | -1,001,703 | "Cutoff Offset"
ACTUAL_MAX_RIDGE_HEIGHT_PARAM | -1,001,705 | "Maximum Ridge Height"
CURVE_WALL_OFFSET | -1,001,706 | "Wall offset"
CURVE_WALL_OFFSET_ROOFS | -1,001,707 | "Overhang"
ROOF_BASE_LEVEL_PARAM | -1,001,708 | "Base Level"
ROOF_RAFTER_OR_TRUSS_PARAM | -1,001,709 | "Rafter or Truss"
ROOF_EAVE_CUT_PARAM | -1,001,710 | "Rafter Cut"
FASCIA_DEPTH_PARAM | -1,001,711 | "Fascia Depth"
RELATED_TO_MASS | -1,001,713 | "Related to Mass"
ROOF_FACES_LOCATION | -1,001,714 | "Picked Faces Location"
FACEROOF_LEVEL_PARAM | -1,001,715 | "Reference Level"
FACEROOF_OFFSET_PARAM | -1,001,716 | "Level Offset"
SCHEDULE_CATEGORY | -1,001,717 | "Category"
SCHEDULE_TYPE_FOR_BROWSER | -1,001,718 | "Schedule Type"
EXTRUSION_DEPTH_PARAM | -1,001,799 | "Depth"
EXTRUSION_START_PARAM | -1,001,800 | "Extrusion Start"
EXTRUSION_END_PARAM | -1,001,801 | "Extrusion End"
REVOLUTION_START_ANGLE | -1,001,802 | "Start Angle"
REVOLUTION_END_ANGLE | -1,001,803 | "End Angle"
BLEND_START_PARAM | -1,001,804 | "First End"
BLEND_END_PARAM | -1,001,805 | "Second End"
EXTRUSION_AUTO_PARAMS | -1,001,806 | "Auto ends"
ELEMENT_IS_CUTTING | -1,001,807 | "Solid/Void"
GEOM_VISIBILITY_PARAM | -1,001,808 | "Visibility/Graphics Overrides"
CURVE_VISIBILITY_PARAM | -1,001,809 | "Visibility/Graphics Overrides"
EXTRUSION_LENGTH | -1,001,812 | "Depth"
PROFILE_OFFSET_X | -1,001,813 | "Horizontal Profile Offset"
PROFILE_OFFSET_Y | -1,001,814 | "Vertical Profile Offset"
PROFILE_FLIPPED_HOR | -1,001,815 | "Profile Is Flipped"
PROFILE_FAM_TYPE | -1,001,816 | "Profile"
PROFILE_ANGLE | -1,001,817 | "Angle"
MODEL_OR_SYMBOLIC | -1,001,818 | "Model or Symbolic"
SWEEP_MAX_SEG_ANGLE | -1,001,819 | "Maximum Segment Angle"
SWEEP_TRAJ_SEGMENTED | -1,001,820 | "Trajectory Segmentation"
FAM_PROFILE_USAGE | -1,001,821 | "Profile Usage"
PROFILE1_OFFSET_X | -1,001,822 | "Horizontal Profile Offset"
PROFILE1_OFFSET_Y | -1,001,823 | "Vertical Profile Offset"
PROFILE1_FLIPPED_HOR | -1,001,824 | "Profile Is Flipped"
PROFILE1_FAM_TYPE | -1,001,825 | "Profile"
PROFILE1_ANGLE | -1,001,826 | "Angle"
PROFILE2_OFFSET_X | -1,001,827 | "Horizontal Profile Offset"
PROFILE2_OFFSET_Y | -1,001,828 | "Vertical Profile Offset"
PROFILE2_FLIPPED_HOR | -1,001,829 | "Profile Is Flipped"
PROFILE2_FAM_TYPE | -1,001,830 | "Profile"
PROFILE2_ANGLE | -1,001,831 | "Angle"
PROFILE_FAM_TYPE_PLUS_NONE | -1,001,832 | "Profile"
PROFILE_PARAM_ALONG_PATH | -1,001,833 | "Parameter along path"
INSERT_ORIENTATION | -1,001,834 | "Orientation"
FLOOR_ATTR_THICKNESS_PARAM | -1,001,900 | "Thickness"
FLOOR_ATTR_DEFAULT_THICKNESS_PARAM | -1,001,902 | "Default Thickness"
FLOOR_ATTR_DEFAULT_HEIGHT_PARAM | -1,001,903 | "Default Height above level"
FLOOR_HEIGHTABOVELEVEL_PARAM | -1,001,951 | "Height Offset From Level"
LEVEL_PARAM | -1,001,952 | "Level"
HOST_PERIMETER_COMPUTED | -1,001,953 | "Perimeter"
FLOOR_PARAM_IS_STRUCTURAL | -1,001,954 | "Structural"
FLOOR_PARAM_SPAN_DIRECTION | -1,001,955 | "Span Direction"
STRUCTURAL_DISPLAY_IN_HIDDEN_VIEWS | -1,001,956 | "Display in Hidden Views"
SYMBOL_ID_PARAM | -1,002,000 | "Type Id"
SYMBOL_NAME_PARAM | -1,002,001 | "Type Name"
ALL_MODEL_TYPE_NAME | -1,002,001 | "Type Name"
SYMBOL_FAMILY_NAME_PARAM | -1,002,002 | "Family Name"
ALL_MODEL_FAMILY_NAME | -1,002,002 | "Family Name"
SYMBOL_FAMILY_AND_TYPE_NAMES_PARAM | -1,002,003 | "Family and Type"
BR_ORG_FOLDERS | -1,002,006 | "Folders"
BR_ORG_FILTER | -1,002,007 | "Filter"
ELEM_TYPE_LABEL | -1,002,008 | "Label"
ELEM_TYPE_PARAM | -1,002,050 | "Type"
ELEM_FAMILY_PARAM | -1,002,051 | "Family"
ELEM_FAMILY_AND_TYPE_PARAM | -1,002,052 | "Family and Type"
ELEM_PARTITION_PARAM | -1,002,053 | "Workset"
ELEM_ROOM_NUMBER | -1,002,059 | "Room Number"
ELEM_ROOM_NAME | -1,002,060 | "Room Name"
ELEM_ROOM_ID | -1,002,061 | "Room Id"
SCHEDULE_LEVEL_PARAM | -1,002,062 | "Level"
SCHEDULE_BASE_LEVEL_PARAM | -1,002,063 | "Base Level"
SCHEDULE_TOP_LEVEL_PARAM | -1,002,064 | "Top Level"
SCHEDULE_BASE_LEVEL_OFFSET_PARAM | -1,002,065 | "Base Offset"
SCHEDULE_TOP_LEVEL_OFFSET_PARAM | -1,002,066 | "Top Offset"
EDITED_BY | -1,002,067 | "Edited by"
SELECTION_EDITABLE_ONLY | -1,002,072 | "Editable only"
ID_PARAM | -1,002,100 | "Id"
FILL_PATTERN_ID_PARAM | -1,002,101 | "Cut fill pattern"
SURFACE_PATTERN_ID_PARAM | -1,002,102 | "Surface fill pattern"
WALL_STRUCTURE_ID_PARAM | -1,002,103 | "Structure"
ANY_PATTERN_ID_PARAM | -1,002,105 | "Fill Pattern"
COARSE_SCALE_FILL_PATTERN_ID_PARAM | -1,002,106 | "Coarse Scale Fill Pattern"
MATERIAL_ID_PARAM | -1,002,107 | "Material"
HOST_ID_PARAM | -1,002,108 | "Host Id"
MODEL_CATEGORY_ID_PARAM | -1,002,109 | "Subcategory"
COARSE_SCALE_FILL_PATTERN_COLOR | -1,002,110 | "Coarse Scale Fill Color"
WRAPPING_AT_ENDS_PARAM | -1,002,111 | "Wrapping at Ends"
WRAPPING_AT_INSERTS_PARAM | -1,002,112 | "Wrapping at Inserts"
OBJECT_STYLE_MATERIAL_ID_PARAM | -1,002,113 | "Object Style Material"
FILL_PATTERN_ID_PARAM_NO_NO | -1,002,114 | "Fill Pattern"
ANY_PATTERN_ID_PARAM_NO_NO | -1,002,115 | "Fill Pattern"
FLOOR_STRUCTURE_ID_PARAM | -1,002,116 | "Structure"
ROOF_STRUCTURE_ID_PARAM | -1,002,117 | "Structure"
CEILING_STRUCTURE_ID_PARAM | -1,002,118 | "Structure"
BUILIDING_PAD_STRUCTURE_ID_PARAM | -1,002,119 | "Structure"
FOREGROUND_DRAFT_PATTERN_ID_PARAM | -1,002,120 | "Foreground Fill Pattern"
FOREGROUND_ANY_PATTERN_ID_PARAM | -1,002,121 | "Foreground Fill Pattern"
BACKGROUND_DRAFT_PATTERN_ID_PARAM | -1,002,122 | "Background Fill Pattern"
FOREGROUND_PATTERN_COLOR_PARAM | -1,002,123 | "Foreground Pattern Color"
BACKGROUND_PATTERN_COLOR_PARAM | -1,002,124 | "Background Pattern Color"
FILLED_REGION_MASKING | -1,002,125 | "Masking"
CEILING_ATTR_DEFAULT_HEIGHT_PARAM | -1,002,200 | "Default Height above level"
CEILING_ATTR_PATTERN_PARAM | -1,002,201 | "Pattern"
CEILING_ATTR_SPACING1_PARAM | -1,002,202 | "Spacing Axis 1"
CEILING_ATTR_SPACING2_PARAM | -1,002,203 | "Spacing Axis 2"
CEILING_ATTR_SYSTEMNAME_PARAM | -1,002,204 | "System"
CEILING_THICKNESS | -1,002,206 | "Thickness"
CEILING_HEIGHTABOVELEVEL_PARAM | -1,002,300 | "Height Offset From Level"
CEILING_THICKNESS_PARAM | -1,002,301 | "Thickness"
CEILING_HAS_THICKNESS_PARAM | -1,002,302 | "Has Thickness"
SLOPE_START_HEIGHT | -1,002,400 | "Height Offset at Tail"
SLOPE_END_HEIGHT | -1,002,401 | "Height Offset at Head"
UNIFORMAT_CODE | -1,002,500 | "Assembly Code"
UNIFORMAT_DESCRIPTION | -1,002,501 | "Assembly Description"
OMNICLASS_CODE | -1,002,502 | "OmniClass Number"
OMNICLASS_DESCRIPTION | -1,002,503 | "OmniClass Title"
SEEK_ITEM_ID | -1,002,504 | "Seek Item ID"
MATERIAL_PARAM_COLOR | -1,002,550 | "Color"
MATERIAL_PARAM_TRANSPARENCY | -1,002,551 | "Transparency"
MATERIAL_PARAM_GLOW | -1,002,552 | "Glow"
MATERIAL_PARAM_SMOOTHNESS | -1,002,553 | "Smoothness"
MATERIAL_PARAM_SHININESS | -1,002,554 | "Shininess"
COLUMN_TOP_ATTACH_JUSTIFICATION_PARAM | -1,002,555 | "Attachment Justification At Top"
COLUMN_BASE_ATTACH_JUSTIFICATION_PARAM | -1,002,556 | "Attachment Justification At Base"
COLUMN_TOP_ATTACHMENT_OFFSET_PARAM | -1,002,557 | "Offset From Attachment At Top"
COLUMN_BASE_ATTACHMENT_OFFSET_PARAM | -1,002,558 | "Offset From Attachment At Base"
COLUMN_TOP_ATTACHED_PARAM | -1,002,559 | "Top is Attached"
COLUMN_BASE_ATTACHED_PARAM | -1,002,560 | "Base is Attached"
COLUMN_BASE_ATTACH_CUT_PARAM | -1,002,561 | "Base Attachment Cut"
COLUMN_TOP_ATTACH_CUT_PARAM | -1,002,562 | "Top Attachment Cut"
COLUMN_LOCATION_MARK | -1,002,563 | "Column Location Mark"
ASSOCIATED_LEVEL | -1,002,564 | "Associated Level": The level associated with this cell.
ASSOCIATED_LEVEL_OFFSET | -1,002,565 | "Associated Level Offset": The offset from the associated level.
ELEM_IS_REFERENCE | -1,004,001 | "Reference"
DATUM_PLANE_DEFINES_ORIGIN | -1,004,002 | "Defines Origin"
ELEM_REFERENCE_NAME | -1,004,003 | "Is Reference"
ELEM_DELETABLE_IN_FAMILY | -1,004,004 | "Deletable"
CURVE_ELEM_LENGTH | -1,004,005 | "Length"
CURVE_ELEM_LINE_ANGLE | -1,004,006 | "Angle"
CURVE_ELEM_ARC_START_ANGLE | -1,004,007 | "Angle 1"
CURVE_ELEM_ARC_END_ANGLE | -1,004,008 | "Angle 2"
CURVE_ELEM_ARC_RANGE | -1,004,009 | "Range"
CURVE_ELEM_ARC_RADIUS | -1,004,010 | "Radius"
CURVE_IS_DETAIL | -1,004,011 | "Detail Line"
DATUM_PLANE_DEFINES_WALL_CLOSURE | -1,004,012 | "Wall Closure"
CURVE_DETERMINES_ORIENTATION | -1,004,013 | "Determines Orientation"
RADIAL_ARRAY_ARC_RADIUS | -1,004,014 | "Radius"
CURVE_ELEM_DEFINES_SLOPE | -1,004,015 | "Defines Beam System Slope"
ELEM_REFERENCE_NAME_2D_XZ | -1,004,016 | "Is Reference"
DIM_VALUE_LENGTH | -1,004,500 | "Value"
DIM_VALUE_ANGLE | -1,004,501 | "Value"
DIM_LABEL_GP_SHOW | -1,004,502 | "Show Label in View"
DIM_LABEL | -1,004,510 | "Label"
DIM_NOT_MODIFIABLE | -1,004,513 | "Non-modifiable"
DIM_DISPLAY_EQ | -1,004,514 | "Equality Display"
DIM_LEADER | -1,004,515 | "Leader"
DIM_ISREPORTING | -1,004,516 | "Is Reporting"
DIM_LABEL_IS_INSTANCE | -1,004,518 | "Is Instance Parameter"
VIEWER_EYE_ELEVATION | -1,005,000 | "Eye Elevation"
VIEWER_OPTION_VISIBILITY | -1,005,001 | "Visible In Option"
VIEWER_TARGET_ELEVATION | -1,005,002 | "Target Elevation"
VIEWER_PERSPECTIVE | -1,005,050 | "Projection Mode"
VIEWER_CROP_REGION | -1,005,090 | "Crop View"
VIEWER_CROP_REGION_VISIBLE | -1,005,091 | "Crop Region Visible"
VIEWER_CROP_REGION_DISABLED | -1,005,092 | "Crop View"
VIEWER_SHOW_UNCROPPED | -1,005,093 | "Show uncropped"
VIEWER_ANNOTATION_CROP_ACTIVE | -1,005,094 | "Annotation Crop"
VIEWER_BOUND_OFFSET_RIGHT | -1,005,100 | "Right Clip Offset"
VIEWER_BOUND_OFFSET_LEFT | -1,005,101 | "Left Clip Offset"
VIEWER_BOUND_OFFSET_TOP | -1,005,102 | "Top Clip Offset"
VIEWER_BOUND_OFFSET_BOTTOM | -1,005,103 | "Bottom Clip Offset"
VIEWER_BOUND_OFFSET_FAR | -1,005,104 | "Far Clip Offset"
VIEWER_BOUND_OFFSET_NEAR | -1,005,105 | "Near Clip Offset"
VIEWER_BOUND_ACTIVE_RIGHT | -1,005,106 | "Right Clip Active"
VIEWER_BOUND_ACTIVE_LEFT | -1,005,107 | "Left Clip Active"
VIEWER_BOUND_ACTIVE_TOP | -1,005,108 | "Top Clip Active"
VIEWER_BOUND_ACTIVE_BOTTOM | -1,005,109 | "Bottom Clip Active"
VIEWER_BOUND_ACTIVE_FAR | -1,005,110 | "Far Clip Active"
VIEWER_BOUND_ACTIVE_NEAR | -1,005,111 | "Near Clip Active"
VIEW_NAME | -1,005,112 | "View Name"
VIEWER_MODEL_CLIP_BOX_ACTIVE | -1,005,113 | "Section Box"
VIEW_DESCRIPTION | -1,005,114 | "Title on Sheet"
VIEWER_REFERENCE_LABEL | -1,005,120 | "Reference Label"
VIEWER_IS_REFERENCE | -1,005,121 | "Is a Reference"
VIEWER_REFERENCE_LABEL_TEXT | -1,005,122 | "Reference Label"
VIEWER_BOUND_FAR_CLIPPING | -1,005,123 | "Far Clipping"
VIEWER3D_RENDER_SETTINGS | -1,005,124 | "Rendering Settings"
GRAPHIC_DISPLAY_OPTIONS_MODEL | -1,005,131 | "Model Display"
GRAPHIC_DISPLAY_OPTIONS_SHADOWS | -1,005,132 | "Shadows"
GRAPHIC_DISPLAY_OPTIONS_LIGHTING | -1,005,133 | "Lighting"
GRAPHIC_DISPLAY_OPTIONS_SS_INTENSITY | -1,005,134 | "Sun and Shadow Intensity"
GRAPHIC_DISPLAY_OPTIONS_BACKGROUND | -1,005,135 | "Background"
GRAPHIC_DISPLAY_OPTIONS_FOG | -1,005,136 | "Depth Cueing"
GRAPHIC_DISPLAY_OPTIONS_PHOTO_EXPOSURE | -1,005,137 | "Photographic Exposure"
VIEW_FIXED_SKETCH_PLANE | -1,005,147 | "None"
VIEW_SCHEMA_SETTING_FOR_BUILDING | -1,005,148 | "Color Scheme"
VIEW_SCHEMA_SETTING_FOR_SYSTEM | -1,005,149 | "System Color Schemes"
VIEW_SCALE | -1,005,150 | "Scale Value 1:"
VIEW_SCALE_PULLDOWN_METRIC | -1,005,151 | "View Scale"
VIEW_SCALE_PULLDOWN_IMPERIAL | -1,005,152 | "View Scale"
VIEW_UNDERLAY_BOTTOM_ID | -1,005,153 | "Range: Base Level"
VIEW_DEPTH | -1,005,154 | "View Depth"
PLAN_VIEW_CUT_PLANE_HEIGHT | -1,005,155 | "Cut Plane Height"
VIEW_SHEET_VIEWPORT_INFO | -1,005,157 | "Viewport"
VIEW_CLEAN_JOINS | -1,005,158 | "Wall Join Display"
PLAN_VIEW_TOP_CLIP_HEIGHT | -1,005,159 | "Top Clip Height"
VIEW_SHOW_MASSING | -1,005,160 | "Show Mass"
VIEW_MODEL_DISPLAY_MODE | -1,005,161 | "Display Model"
PLAN_VIEW_RANGE | -1,005,162 | "View Range"
VIEW_DISCIPLINE | -1,005,163 | "Discipline"
VIEW_VISIBLE_CATEGORIES | -1,005,164 | "Visibility/Graphics Overrides"
MODEL_GRAPHICS_STYLE | -1,005,165 | "Visual Style"
PLAN_VIEW_LEVEL | -1,005,166 | "Associated Level"
WALKTHROUGH_FRAMES_COUNT | -1,005,167 | "Walkthrough Frames"
PLAN_VIEW_NORTH | -1,005,168 | "Orientation"
VIEW_CAMERA_POSITION | -1,005,169 | "Camera Position"
VIEW_REFERENCING_SHEET | -1,005,170 | "Referencing Sheet"
VIEW_REFERENCING_DETAIL | -1,005,171 | "Referencing Detail"
MODEL_GRAPHICS_STYLE_ANON_DRAFT | -1,005,172 | "Visual Style"
GRAPHIC_DISPLAY_OPTIONS | -1,005,173 | "Graphic Display Options"
VIEW_GRAPH_SCHED_NUMBER_COLUMNS | -1,005,175 | "Column Locations per Segment"
VIEW_TEMPLATE | -1,005,176 | "View Template"
VIEW_UNDERLAY_ORIENTATION | -1,005,177 | "Underlay Orientation"
VIEW_GRAPH_SCHED_TOTAL_COLUMNS | -1,005,178 | "Total Column Locations"
VIEW_ASSOCIATED_ASSEMBLY_INSTANCE_ID | -1,005,179 | "Associated Assembly Instance"
VIEW_BACK_CLIPPING | -1,005,181 | "Depth Clipping"
VIEW_DEPENDENCY | -1,005,182 | "Dependency"
COLOR_SCHEME_LOCATION | -1,005,183 | "Color Scheme Location"
VIEW_CAMERA_ORIENTATION | -1,005,184 | "Locked Orientation"
RENDER_PLANT_NAME | -1,005,192 | "Plant Name"
RENDER_PLANT_HEIGHT | -1,005,193 | "Height"
RENDER_PLANT_TRIM_HEIGHT | -1,005,194 | "Plant Trim Height"
RENDER_RPC_FILENAME | -1,005,195 | "Render Appearance"
FAMILY_RENDERING_TYPE | -1,005,196 | "Render Appearance Source"
FAMILY_SYMBOLIC_REP | -1,005,197 | "Symbolic Representation"
RENDER_RPC_PROPERTIES | -1,005,198 | "Render Appearance Properties"
VIEW_TEMPLATE_FOR_SCHEDULE | -1,005,199 | "View Template"
VIEWPORT_DETAIL_NUMBER | -1,005,201 | "Detail Number"
VIEWPORT_VIEW | -1,005,202 | "View"
VIEWPORT_VIEW_NAME | -1,005,203 | "View Name"
VIEWPORT_SCALE | -1,005,204 | "View Scale"
VIEWPORT_SHEET_NUMBER | -1,005,206 | "Sheet Number"
VIEWPORT_SHEET_NAME | -1,005,207 | "Sheet Name"
VIEW_GRAPH_SCHED_UNITS_FORMAT | -1,005,208 | "Off-Grid Units Format"
VIEW_GRAPH_SCHED_OFF_GRID | -1,005,209 | "Include Off-Grid Columns"
VIEWPORT_POSITIONING | -1,005,210 | "Viewport Positioning"
VIEWPORT_ATTR_PRESERVE_TITLE_POSITION | -1,005,211 | "Preserve Title Position"
VIEWPORT_SHEET_COLLECTION | -1,005,221 | "Sheet Collection"
VIEW_REFERENCING_SHEET_COLLECTION | -1,005,222 | "Referencing Sheet Collection"
VIEWER_SHEET_NAME | -1,005,223 | "Sheet Name"
VIEWER_SHEET_COLLECTION | -1,005,224 | "Sheet Collection"
VIEW_SCALE_CUSTOMNAME | -1,005,230 | "Display Name"
VIEW_SCALE_HAVENAME | -1,005,231 | "Display Name"
VIEWPORT_ATTR_LABEL_TAG | -1,005,250 | "Title"
VIEWPORT_ATTR_SHOW_LABEL | -1,005,251 | "Show Title"
VIEWPORT_ATTR_SHOW_EXTENSION_LINE | -1,005,252 | "Show Extension Line"
VIEWPORT_ATTR_SHOW_BOX | -1,005,253 | "Show Box"
VIEWPORT_ATTR_ORIENTATION_ON_SHEET | -1,005,254 | "Rotation on Sheet"
VIEW_GRAPH_SCHED_TOP_LEVEL | -1,005,313 | "Top Level"
VIEW_GRAPH_SCHED_BOTTOM_LEVEL | -1,005,314 | "Bottom Level"
VIEW_GRAPH_SCHED_LOCATIONS_LOW | -1,005,315 | "Column Locations Start"
VIEW_GRAPH_SCHED_LOCATIONS_HIGH | -1,005,316 | "Column Locations End"
VIEW_GRAPH_SCHED_MATERIAL_TYPES | -1,005,317 | "Material Types"
VIEW_GRAPH_SCHED_GROUP_SIMILAR | -1,005,318 | "Group Similar Locations"
VIEW_GRAPH_SCHED_ROWS_FROM | -1,005,319 | "Segment Start in Viewport"
VIEW_GRAPH_SCHED_TITLE | -1,005,325 | "Title"
VIEW_GRAPH_SCHED_TEXT_APPEARANCE | -1,005,326 | "Text Appearance"
VIEW_GRAPH_SCHED_GRID_APPEARANCE | -1,005,327 | "Grid Appearance"
VIEW_GRAPH_SCHED_ROWS_COUNT | -1,005,328 | "Segments in Viewport"
VIEW_GRAPH_SCHED_TOTAL_ROWS | -1,005,329 | "Total Segments"
VIEW_GRAPH_SCHED_HIDDEN_LEVELS | -1,005,330 | "Hidden Levels"
VIEW_GRAPH_SCHED_LEVEL_RELATIVE_BASE_TYPE | -1,005,331 | "Elevation Base for Levels"
VIEW_ANALYSIS_DISPLAY_STYLE | -1,005,332 | "Default Analysis Display Style"
VIEW_GRAPH_SUN_PATH | -1,005,333 | "Sun Path"
VIEW_GRAPH_SUN_PATH_SIZE | -1,005,334 | "Sun path size (%)"
VIEW_UNDERLAY_TOP_ID | -1,005,335 | "Range: Top Level"
VIEW_SOLARSTUDY_CURRENT_STUDY_TYPE_INDEX | -1,005,350 | "Study type"
VIEW_SOLARSTUDY_IS_STILLIMAGE_STUDY_TYPE | -1,005,351 | "Still image study"
VIEW_SOLARSTUDY_IS_SINGLEDAY_STUDY_TYPE | -1,005,352 | "Single day study"
VIEW_SOLARSTUDY_IS_MULTIDAY_STUDY_TYPE | -1,005,353 | "Multi-day study"
VIEW_SOLARSTUDY_IS_LIGHTING_STUDY_TYPE | -1,005,354 | "Lighting study"
VIEW_SOLARSTUDY_ANIMATION_SPEED_VALUE | -1,005,355 | "Loop animation speed"
VIEW_SOLARSTUDY_ANIMATION_SPEED_TEXT | -1,005,356 | "Loop animation speed"
VIEW_SOLARSTUDY_SUN_INTENSITY_VALUE | -1,005,357 | "Sun intensity"
VIEW_SOLARSTUDY_SUN_INTENSITY_TEXT | -1,005,358 | "Sun intensity text"
VIEW_SOLARSTUDY_SHADOWS_INTENSITY_VALUE | -1,005,359 | "Shadows intensity"
VIEW_SOLARSTUDY_SHADOWS_INTENSITY_TEXT | -1,005,360 | "Shadows intensity text"
VIEW_SOLARSTUDY_STILL_PRESET_INDEX | -1,005,361 | "Still presets combo"
VIEW_SOLARSTUDY_SINGLEDAY_PRESET_INDEX | -1,005,362 | "Single day presets combo"
VIEW_SOLARSTUDY_MULTIDAY_PRESET_INDEX | -1,005,363 | "Multi-day presets combo"
VIEW_SOLARSTUDY_LIGHTING_PRESET_INDEX | -1,005,364 | "Lighting presets combo"
VIEW_SOLARSTUDY_STILL_DATE_VALUE | -1,005,365 | "Still date"
VIEW_SOLARSTUDY_STILL_DATE_TEXT | -1,005,366 | "Still date text"
VIEW_SOLARSTUDY_STILL_TIME_VALUE | -1,005,367 | "Still time"
VIEW_SOLARSTUDY_STILL_TIME_TEXT | -1,005,368 | "Still time text"
VIEW_SOLARSTUDY_SINGLEDAY_FRAME_VALUE | -1,005,369 | "Single day frame"
VIEW_SOLARSTUDY_SINGLEDAY_FRAME_TEXT | -1,005,370 | "Single day frame text"
VIEW_SOLARSTUDY_SINGLEDAY_DATETIME_TEXT | -1,005,371 | "Single day date and time text"
VIEW_SOLARSTUDY_MULTIDAY_FRAME_VALUE | -1,005,372 | "Multi-day frame"
VIEW_SOLARSTUDY_MULTIDAY_FRAME_TEXT | -1,005,373 | "Multi-day frame text"
VIEW_SOLARSTUDY_MULTIDAY_DATETIME_TEXT | -1,005,374 | "Multi-day date and time text"
VIEW_SOLARSTUDY_LIGHTING_AZIMUTH_VALUE | -1,005,375 | "Lighting azimuth"
VIEW_SOLARSTUDY_LIGHTING_AZIMUTH_TEXT | -1,005,376 | "Lighting azimuth text"
VIEW_SOLARSTUDY_LIGHTING_ALTITUDE_VALUE | -1,005,377 | "Lighting altitude"
VIEW_SOLARSTUDY_LIGHTING_ALTITUDE_TEXT | -1,005,378 | "Lighting altitude text"
VIEW_DESIGN_OPTIONS_CONFIG | -1,005,400 | "Design Option Configuration"
ANALYTICAL_HEAT_TRANSFER_COEFFICIENT | -1,005,430 | "Heat Transfer Coefficient (U)"
ANALYTICAL_THERMAL_RESISTANCE | -1,005,431 | "Thermal Resistance (R)"
ANALYTICAL_SOLAR_HEAT_GAIN_COEFFICIENT | -1,005,432 | "Solar Heat Gain Coefficient"
ANALYTICAL_VISUAL_LIGHT_TRANSMITTANCE | -1,005,433 | "Visual Light Transmittance"
ANALYTICAL_THERMAL_MASS | -1,005,434 | "Thermal Mass"
ANALYTICAL_ABSORPTANCE | -1,005,435 | "Absorptance"
ANALYTICAL_ROUGHNESS | -1,005,436 | "Roughness"
ANALYTIC_CONSTRUCTION_LOOKUP_TABLE | -1,005,437 | "Analytic Construction"
ANALYTIC_CONSTRUCTION_GBXML_TYPEID | -1,005,438 | "Construction Type Id"
ANALYTICAL_DEFINE_THERMAL_PROPERTIES_BY | -1,005,439 | "Define Thermal Properties by"
STRUCTURAL_MATERIAL_PARAM | -1,005,500 | "Structural Material"
STRUCTURAL_SECTION_SHAPE | -1,005,501 | "Section Shape"
STRUCTURAL_SECTION_COMMON_WIDTH | -1,005,502 | "Width"
STRUCTURAL_SECTION_COMMON_HEIGHT | -1,005,503 | "Height"
STRUCTURAL_SECTION_COMMON_DIAMETER | -1,005,504 | "Diameter"
STRUCTURAL_SECTION_PIPESTANDARD_WALLNOMINALTHICKNESS | -1,005,505 | "Wall Nominal Thickness"
STRUCTURAL_SECTION_PIPESTANDARD_WALLDESIGNTHICKNESS | -1,005,506 | "Wall Design Thickness"
STRUCTURAL_SECTION_AREA | -1,005,507 | "Section Area"
STRUCTURAL_SECTION_COMMON_CENTROID_HORIZ | -1,005,508 | "Centroid Horizontal"
STRUCTURAL_SECTION_COMMON_CENTROID_VERTICAL | -1,005,509 | "Centroid Vertical"
STRUCTURAL_SECTION_COMMON_ALPHA | -1,005,510 | "Principal Axes Angle"
STRUCTURAL_SECTION_COMMON_PERIMETER | -1,005,511 | "Perimeter"
STRUCTURAL_SECTION_COMMON_NOMINAL_WEIGHT | -1,005,512 | "Nominal Weight"
STRUCTURAL_SECTION_COMMON_MOMENT_OF_INERTIA_STRONG_AXIS | -1,005,513 | "Moment of Inertia strong axis"
STRUCTURAL_SECTION_COMMON_MOMENT_OF_INERTIA_WEAK_AXIS | -1,005,514 | "Moment of Inertia weak axis"
STRUCTURAL_SECTION_COMMON_ELASTIC_MODULUS_STRONG_AXIS | -1,005,515 | "Elastic Modulus strong axis"
STRUCTURAL_SECTION_COMMON_ELASTIC_MODULUS_WEAK_AXIS | -1,005,516 | "Elastic Modulus weak axis"
STRUCTURAL_SECTION_COMMON_PLASTIC_MODULUS_STRONG_AXIS | -1,005,517 | "Plastic Modulus strong axis"
STRUCTURAL_SECTION_COMMON_PLASTIC_MODULUS_WEAK_AXIS | -1,005,518 | "Plastic Modulus weak axis"
STRUCTURAL_SECTION_COMMON_TORSIONAL_MOMENT_OF_INERTIA | -1,005,519 | "Torsional Moment of Inertia"
STRUCTURAL_SECTION_COMMON_TORSIONAL_MODULUS | -1,005,520 | "Torsional Modulus"
STRUCTURAL_SECTION_COMMON_WARPING_CONSTANT | -1,005,521 | "Warping Constant"
STRUCTURAL_SECTION_COMMON_SHEAR_AREA_STRONG_AXIS | -1,005,522 | "Shear Area strong axis"
STRUCTURAL_SECTION_COMMON_SHEAR_AREA_WEAK_AXIS | -1,005,523 | "Shear Area weak axis"
STRUCTURAL_SECTION_ISHAPE_FLANGETHICKNESS | -1,005,524 | "Flange Thickness"
STRUCTURAL_SECTION_ISHAPE_WEBTHICKNESS | -1,005,525 | "Web Thickness"
STRUCTURAL_SECTION_ISHAPE_WEBHEIGHT | -1,005,526 | "Web Height"
STRUCTURAL_SECTION_ISHAPE_FLANGEFILLET | -1,005,527 | "Flange Fillet"
STRUCTURAL_SECTION_ISHAPE_WEBFILLET | -1,005,528 | "Web Fillet"
STRUCTURAL_SECTION_HSS_INNERFILLET | -1,005,529 | "Inner Fillet"
STRUCTURAL_SECTION_HSS_OUTERFILLET | -1,005,530 | "Outer Fillet"
STRUCTURAL_SECTION_IWELDED_TOPFLANGETHICKNESS | -1,005,531 | "Top Flange Thickness"
STRUCTURAL_SECTION_IWELDED_TOPFLANGEWIDTH | -1,005,532 | "Top Flange Width"
STRUCTURAL_SECTION_IWELDED_BOTTOMFLANGETHICKNESS | -1,005,533 | "Bottom Flange Thickness"
STRUCTURAL_SECTION_IWELDED_BOTTOMFLANGEWIDTH | -1,005,534 | "Bottom Flange Width"
STRUCTURAL_SECTION_ISHAPE_CLEAR_WEB_HEIGHT | -1,005,535 | "Clear Web Height"
STRUCTURAL_SECTION_ISHAPE_FLANGE_TOE_OF_FILLET | -1,005,536 | "Flange Toe of Fillet"
STRUCTURAL_SECTION_ISHAPE_WEB_TOE_OF_FILLET | -1,005,537 | "Web Toe of Fillet"
STRUCTURAL_SECTION_ISHAPE_BOLT_SPACING | -1,005,538 | "Bolt Spacing"
STRUCTURAL_SECTION_ISHAPE_BOLT_DIAMETER | -1,005,539 | "Bolt Diameter"
STRUCTURAL_SECTION_ISHAPE_BOLT_SPACING_TWO_ROWS | -1,005,540 | "Bolt Spacing Two Rows"
STRUCTURAL_SECTION_ISHAPE_BOLT_SPACING_BETWEEN_ROWS | -1,005,541 | "Bolt Spacing between Rows"
STRUCTURAL_SECTION_ISHAPE_BOLT_SPACING_WEB | -1,005,542 | "Bolt Spacing web"
STRUCTURAL_SECTION_LANGLE_BOLT_SPACING_1_LONGER_FLANGE | -1,005,543 | "Bolt Spacing 1 Longer Flange"
STRUCTURAL_SECTION_LANGLE_BOLT_SPACING_2_LONGER_FLANGE | -1,005,544 | "Bolt Spacing 2 Longer Flange"
STRUCTURAL_SECTION_LANGLE_BOLT_SPACING_SHORTER_FLANGE | -1,005,545 | "Bolt Spacing Shorter Flange"
STRUCTURAL_SECTION_LANGLE_BOLT_DIAMETER_LONGER_FLANGE | -1,005,546 | "Bolt Diameter Longer Flange"
STRUCTURAL_SECTION_LANGLE_BOLT_DIAMETER_SHORTER_FLANGE | -1,005,547 | "Bolt Diameter Shorter Flange"
STRUCTURAL_SECTION_LPROFILE_LIP_LENGTH | -1,005,548 | "Lip Length"
STRUCTURAL_SECTION_CPROFILE_FOLD_LENGTH | -1,005,549 | "Fold Length"
STRUCTURAL_SECTION_ZPROFILE_BOTTOM_FLANGE_LENGTH | -1,005,550 | "Bottom Flange Length"
STRUCTURAL_SECTION_SIGMA_PROFILE_BEND_WIDTH | -1,005,551 | "Bend Width"
STRUCTURAL_SECTION_SIGMA_PROFILE_MIDDLE_BEND_WIDTH | -1,005,552 | "Middle Bend Length"
STRUCTURAL_SECTION_SIGMA_PROFILE_TOP_BEND_WIDTH | -1,005,553 | "Top Bend Length"
STRUCTURAL_SECTION_NAME_KEY | -1,005,554 | "Section Name Key"
STRUCTURAL_FAMILY_NAME_KEY | -1,005,555 | "Family Name Key"
STRUCTURAL_FAMILY_CODE_NAME | -1,005,556 | "Code Name"
STRUCTURAL_SECTION_TOP_CUT_WIDTH | -1,005,557 | "Top Cut Width"
STRUCTURAL_SECTION_TOP_CUT_HEIGHT | -1,005,558 | "Top Cut Height"
STRUCTURAL_SECTION_BOTTOM_CUT_WIDTH | -1,005,559 | "Bottom Cut Width"
STRUCTURAL_SECTION_BOTTOM_CUT_HEIGHT | -1,005,560 | "Bottom Cut Height"
STRUCTURAL_SECTION_CANTILEVER_LENGTH | -1,005,561 | "Cantilever Length"
STRUCTURAL_SECTION_CANTILEVER_HEIGHT | -1,005,562 | "Cantilever Height"
STRUCTURAL_SECTION_SLOPED_FLANGE_ANGLE | -1,005,563 | "Sloped Flange Angle"
STRUCTURAL_SECTION_SLOPED_WEB_ANGLE | -1,005,564 | "Sloped Web Angle"
STRUCTURAL_SECTION_TOP_WEB_FILLET | -1,005,565 | "Top Web Fillet"
STRUCTURAL_SECTION_ISHAPE_FLANGETHICKNESS_LOCATION | -1,005,566 | "Flange Thickness Location"
STRUCTURAL_SECTION_ISHAPE_WEBTHICKNESS_LOCATION | -1,005,567 | "Web Thickness Location"
ROOF_CURVE_IS_SLOPE_DEFINING | -1,006,000 | "Defines Roof Slope"
ROOF_CURVE_HEIGHT_OFFSET | -1,006,001 | "Offset From Roof Base"
ROOF_CURVE_HEIGHT_AT_WALL | -1,006,005 | "Plate Offset From Base"
DEFINES_CONSTANT_HEIGHT | -1,006,006 | "Defines Constant Height"
CURVE_IS_SLOPE_DEFINING | -1,006,007 | "Defines Slope"
CURVE_HEIGHT_OFFSET | -1,006,008 | "Offset From Base"
CURVE_LEVEL | -1,006,009 | "Level"
SLOPE_ARROW_LEVEL_START | -1,006,010 | "Level at Tail"
SLOPE_ARROW_LEVEL_END | -1,006,011 | "Level at Head"
SPECIFY_SLOPE_OR_OFFSET | -1,006,012 | "Specify "
CURVE_NUMBER_OF_SEGMENTS | -1,006,013 | "Number of Full Segments"
CURVE_PARAM_CONCRETE_CANTILEVER | -1,006,014 | "Concrete Cantilever"
CURVE_PARAM_STEEL_CANTILEVER | -1,006,015 | "Steel Cantilever"
ROOF_SLOPE | -1,006,016 | "Slope"
STAIRS_CURVE_TYPE | -1,006,100 | "Stairs Line Type"
FAMILY_ELEM_SUBCATEGORY | -1,006,200 | "Subcategory"
FAMILY_CURVE_GSTYLE_PLUS_INVISIBLE | -1,006,201 | "Subcategory"
FAMILY_CURVE_GSTYLE_PLUS_INVISIBLE_PLUS_STICK_SYM | -1,006,202 | "Subcategory"
FAMILY_CURVE_GSTYLE_PLUS_INVISIBLE_MINUS_ANALYTICAL | -1,006,203 | "Subcategory"
FAMILY_CURVE_GSTYLE_PLUS_INVISIBLE_PLUS_STICK_SYM_MINUS_ANALYTICAL | -1,006,204 | "Subcategory"
IS_VISIBLE_PARAM | -1,006,205 | "Visible"
HEAD_ON_PLACEMENT_METHOD | -1,006,206 | "Draw in Foreground"
FAMILY_CURVE_GSTYLE_FOR_2010_MASS | -1,006,207 | "Subcategory"
BUILDING_CURVE_GSTYLE | -1,006,210 | "Line Style"
BUILDING_CURVE_GSTYLE_PLUS_INVISIBLE | -1,006,211 | "Subcategory"
EDGE_LINEWORK | -1,006,212 | "Line Style"
CLINE_SUBCATEGORY | -1,006,220 | "Subcategory"
REFERENCE_LINE_SUBCATEGORY | -1,006,221 | "Subcategory"
TEXT_FONT | -1,006,300 | "Text Font"
TEXT_SIZE | -1,006,301 | "Text Size"
TEXT_COLOR | -1,006,302 | "Color"
LINE_PEN | -1,006,303 | "Line Weight"
LINE_COLOR | -1,006,304 | "Color"
LINE_PATTERN | -1,006,305 | "Line Pattern"
TEXT_TEXT | -1,006,307 | "Text"
TEXT_ALIGN_HORZ | -1,006,308 | "Horizontal Align"
TEXT_ALIGN_VERT | -1,006,309 | "Vertical Align"
CURVE_IS_FILLED | -1,006,310 | "Filled"
TEXT_STYLE_BOLD | -1,006,311 | "Bold"
TEXT_STYLE_ITALIC | -1,006,312 | "Italic"
TEXT_STYLE_UNDERLINE | -1,006,313 | "Underline"
TEXT_BACKGROUND | -1,006,314 | "Background"
LEADER_ARROWHEAD | -1,006,315 | "Leader Arrowhead"
PROJECT_NUMBER | -1,006,316 | "Project Number"
PROJECT_NAME | -1,006,317 | "Project Name"
PROJECT_ADDRESS | -1,006,318 | "Project Address"
CLIENT_NAME | -1,006,319 | "Client Name"
PROJECT_STATUS | -1,006,320 | "Project Status"
PROJECT_ISSUE_DATE | -1,006,321 | "Project Issue Date"
SHEET_ISSUE_DATE | -1,006,322 | "Sheet Issue Date"
DIM_LEADER_ARROWHEAD | -1,006,323 | "Tick Mark"
ARC_LEADER_PARAM | -1,006,325 | "Arc Leaders"
TEXT_TAB_SIZE | -1,006,326 | "Tab Size"
TEXT_WIDTH_SCALE | -1,006,327 | "Width Factor"
TITLE_FONT | -1,006,328 | "Font"
TITLE_SIZE | -1,006,329 | "Size"
TITLE_STYLE_BOLD | -1,006,330 | "Bold"
TITLE_STYLE_ITALIC | -1,006,331 | "Italic"
TITLE_STYLE_UNDERLINE | -1,006,332 | "Underline"
SHOW_TITLE | -1,006,333 | "Show Title"
TEXT_STYLE_FONT | -1,006,334 | "Font"
TEXT_STYLE_SIZE | -1,006,335 | "Size"
MODEL_TEXT_SIZE | -1,006,336 | "Text Size"
TEXT_ALIGNMENT | -1,006,400 | "Text Alignment"
TEXT_DIST_TO_LINE | -1,006,401 | "Text Offset"
WITNS_LINE_EXTENSION | -1,006,404 | "Witness Line Extension"
WITNS_LINE_GAP_TO_ELT | -1,006,405 | "Witness Line Gap to Element"
ARC_CENTER_MARK | -1,006,406 | "Center Marks"
CENTER_MARK_SIZE | -1,006,407 | "Center Mark Size"
RADIUS_SYMBOL_LOCATION | -1,006,408 | "Radius Symbol Location"
TEXT_POSITION | -1,006,411 | "Text Position"
TICK_MARK_PEN | -1,006,412 | "Tick Mark Line Weight"
ARROW_TYPE | -1,006,413 | "Arrow Style"
ARROW_SIZE | -1,006,414 | "Tick Size"
HEAVY_TICK_MARK_PEN | -1,006,420 | "Heavy End Pen Weight"
ARROW_FILLED | -1,006,425 | "Fill Tick"
LEADER_ARROW_WIDTH | -1,006,426 | "Arrow Width Angle"
DIM_STYLE_LINEAR_UNITS | -1,006,427 | "Units Format"
DIM_STYLE_ANGULAR_UNITS | -1,006,428 | "Units Format"
DIM_TEXT_BACKGROUND | -1,006,429 | "Text Background"
DIM_STYLE_CENTERLINE_SYMBOL | -1,006,430 | "Centerline Symbol"
DIM_LINE_EXTENSION | -1,006,431 | "Dimension Line Extension"
DIM_WITNS_LINE_CNTRL | -1,006,432 | "Witness Line Control"
DIM_WITNS_LINE_EXTENSION_BELOW | -1,006,433 | "Witness Line Length"
DIM_STYLE_CENTERLINE_PATTERN | -1,006,434 | "Centerline Pattern"
DIM_STYLE_SHOW_OPENING_HT | -1,006,435 | "Show Opening Height"
SPOT_ELEV_SYMBOL | -1,006,436 | "Symbol"
SPOT_ELEV_BASE | -1,006,437 | "Elevation Base"
SPOT_ELEV_TEXT_HORIZ_OFFSET | -1,006,439 | "Text Offset from Symbol"
SPOT_ELEV_FLIP_TEXT_VERT | -1,006,440 | "Auto Mirror"
SPOT_ELEV_RELATIVE_BASE | -1,006,441 | "Relative Base"
SPOT_ELEV_LEADER_ARROWHEAD | -1,006,442 | "Leader Arrowhead"
SPOT_ELEV_TICK_MARK_PEN | -1,006,443 | "Leader Arrowhead Line Weight"
SPOT_ELEV_LINE_PEN | -1,006,444 | "Leader Line Weight"
DIM_STYLE_CENTERLINE_TICK_MARK | -1,006,445 | "Centerline Tick Mark"
DIM_STYLE_DIM_LINE_SNAP_DIST | -1,006,446 | "Dimension Line Snap Distance"
HEAVY_END_PEN | -1,006,447 | "Heavy End Pen Weight"
DIM_STYLE_READ_CONVENTION | -1,006,448 | "Read Convention"
ARROW_CLOSED | -1,006,449 | "Arrow Closed"
SPOT_ELEV_IND_NS | -1,006,450 | "North / South Indicator"
SPOT_ELEV_IND_EW | -1,006,451 | "East / West Indicator"
SPOT_ELEV_IND_ELEVATION | -1,006,452 | "Elevation Indicator"
SPOT_ELEV_TEXT_ORIENTATION | -1,006,453 | "Text Orientation"
DIM_STYLE_LINEAR_UNITS_ALT | -1,006,454 | "Alternate Units Format"
SPOT_ELEV_TOP_VALUE | -1,006,455 | "Top Coordinate"
ALTERNATE_UNITS | -1,006,456 | "Alternate Units"
SPOT_ELEV_BOT_VALUE | -1,006,457 | "Bottom Coordinate"
SPOT_ELEV_IND_TYPE | -1,006,458 | "Indicator as Prefix / Suffix"
DIM_STYLE_ANGULAR_UNITS_ALT | -1,006,460 | "Alternate Units Format"
SPOT_COORDINATE_BASE | -1,006,461 | "Coordinate Base"
SPOT_TEXT_FROM_LEADER | -1,006,462 | "Text Offset from Leader"
DIM_STYLE_INTERIOR_TICK_MARK | -1,006,464 | "Interior Tick Mark"
DIM_STYLE_FLIPPED_DIM_LINE_EXTENSION | -1,006,465 | "Flipped Dimension Line Extension"
SPOT_DIM_LEADER | -1,006,466 | "Leader"
LINEAR_DIM_TYPE | -1,006,467 | "Dimension String Type"
ORDINATE_DIM_SETTING | -1,006,468 | "Ordinate Dimension Settings"
SPOT_ELEV_DISPLAY_ELEVATIONS | -1,006,469 | "Display Elevations"
SPOT_ELEV_ROTATE_WITH_COMPONENT | -1,006,470 | "Rotate with Component"
SPOT_ELEV_TEXT_LOCATION | -1,006,471 | "Text Location"
SPOT_ELEV_IND_TOP | -1,006,472 | "Top Indicator"
SPOT_ELEV_IND_BOTTOM | -1,006,473 | "Bottom Indicator"
SPOT_ELEV_IND_TYPE_TOP | -1,006,474 | "Top Indicator as Prefix/Suffix"
SPOT_ELEV_IND_TYPE_BOTTOM | -1,006,475 | "Bottom Indicator as Prefix/Suffix"
SPOT_ELEV_BEND_LEADER | -1,006,476 | "Leader Shoulder"
BASELINE_DIM_OFFSET | -1,006,477 | "Baseline Offset"
SPOT_ELEV_SINGLE_OR_UPPER_PREFIX | -1,006,478 | "Single/Upper Value Prefix"
SPOT_ELEV_SINGLE_OR_UPPER_SUFFIX | -1,006,479 | "Single/Upper Value Suffix"
SPOT_ELEV_LOWER_PREFIX | -1,006,480 | "Lower Value Prefix"
SPOT_ELEV_LOWER_SUFFIX | -1,006,481 | "Lower Value Suffix"
SPOT_COORDINATE_TOP_PREFIX | -1,006,482 | "Top Coordinate Prefix"
SPOT_COORDINATE_TOP_SUFFIX | -1,006,483 | "Top Coordinate Suffix"
SPOT_COORDINATE_BOTTOM_PREFIX | -1,006,484 | "Bottom Coordinate Prefix"
SPOT_COORDINATE_BOTTOM_SUFFIX | -1,006,485 | "Bottom Coordinate Suffix"
SPOT_COORDINATE_ELEVATION_PREFIX | -1,006,486 | "Elevation Prefix"
SPOT_COORDINATE_ELEVATION_SUFFIX | -1,006,487 | "Elevation Suffix"
SPOT_COORDINATE_INCLUDE_ELEVATION | -1,006,488 | "Include Elevation"
SPOT_ELEV_IND_TYPE_ELEVATION | -1,006,489 | "Elevation Indicator as Prefix/Suffix"
SPOT_ELEV_SINGLE_OR_UPPER_VALUE | -1,006,490 | "Single/Upper Value"
SPOT_ELEV_LOWER_VALUE | -1,006,491 | "Lower Value"
SPOT_SLOPE_SLOPE_DIRECTION | -1,006,492 | "Slope Direction"
SPOT_SLOPE_SLOPE_REPRESENTATION | -1,006,493 | "Slope Representation"
SPOT_SLOPE_OFFSET_FROM_REFERENCE | -1,006,494 | "Offset from Reference"
DIM_TO_INSERTS | -1,006,500 | "Dimension To Openings"
LEADER_OFFSET_SHEET | -1,006,501 | "Leader/Border Offset"
LEADER_LINE | -1,006,502 | "Leader Line"
KEEP_READABLE | -1,006,503 | "Keep Readable"
FIXED_ROTATION | -1,006,504 | "Fixed Rotation"
DIM_TO_INSERT_TYPE | -1,006,505 | "Dimension To Opening Type"
DIM_TO_INTERSECTING_WALLS | -1,006,506 | "Dimension To Intersecting Walls"
DIM_TO_INTERSECTING_GRIDS | -1,006,507 | "Dimension To Intersecting Grids"
DIM_LEADER_TYPE | -1,006,508 | "Leader Type"
DIM_LEADER_SHOULDER_LENGTH | -1,006,509 | "Shoulder Length"
DIM_LEADER_DISPLAY_CONDITION | -1,006,510 | "Show Leader When Text Moves"
DIM_TEXT_LOCATION_FOR_LEADER | -1,006,511 | "Text Location"
EQUALITY_TEXT_FOR_CONTINUOUS_LINEAR_DIM | -1,006,512 | "Equality Text"
EQUALITY_TEXT_FOR_ANGULAR_DIM | -1,006,513 | "Equality Text"
DIM_STYLE_LEADER_TICK_MARK | -1,006,514 | "Leader Tick Mark"
EQUALITY_FORMULA | -1,006,515 | "Equality Formula"
DIM_STYLE_SUPPRESS_SPACES | -1,006,516 | "Suppress Spaces"
EQUALITY_WITNESS_DISPLAY | -1,006,517 | "Equality Witness Display"
ALTERNATE_UNITS_PREFIX | -1,006,518 | "Alternate Units Prefix"
ALTERNATE_UNITS_SUFFIX | -1,006,519 | "Alternate Units Suffix"
DIM_REFERENCE_COUNT | -1,006,520 | "Count"
DIM_TOTAL_LENGTH | -1,006,521 | "Total Length"
WITNS_LINE_TICK_MARK | -1,006,522 | "Witness Line Tick Mark"
INTERIOR_TICK_DISPLAY | -1,006,523 | "Interior Tick Mark Display"
ARROW_CENTERED | -1,006,524 | "Tick Mark Centered"
DIM_PREFIX | -1,006,525 | "Dimension Prefix"
DIM_SUFFIX | -1,006,526 | "Dimension Suffix"
ALIGNMENT_STATION_PREFIX | -1,006,593 | "Station Prefix"
ALIGNMENT_STATION_SUFFIX | -1,006,594 | "Station Suffix"
ALIGNMENT_STATION_LABEL_DISTANCE | -1,006,595 | "Distance": Currently not in use
SPOT_DIM_LEADER_LINE | -1,006,596 | "Leader Line"
ALIGNMENT_STATION_LABEL_INCLUDE_STATION | -1,006,597 | "Include Station"
ALIGNMENT_STATION_LABEL_IND_STATION | -1,006,598 | "Station Indicator"
ALIGNMENT_STATION_LABEL_STATION_VALUE | -1,006,599 | "Station Value"
SECTION_ATTR_HEAD_TAG | -1,006,600 | "Section Head"
VIEWER_SHEET_NUMBER | -1,006,601 | "Sheet Number"
VIEWER_DETAIL_NUMBER | -1,006,602 | "Detail Number"
SECTION_ATTR_TAIL_LENGTH | -1,006,603 | "Tail length"
SECTION_ATTR_TAIL_WIDTH | -1,006,604 | "Tail width"
SECTION_ATTR_TAIL_TAG | -1,006,608 | "Section Tail"
SECTION_SHOW_IN_ONE_VIEW_ONLY | -1,006,609 | "Show in"
SECTION_PARENT_VIEW_NAME | -1,006,612 | "Parent View"
SECTION_COARSER_SCALE_PULLDOWN_METRIC | -1,006,613 | "Hide at scales coarser than"
SECTION_COARSER_SCALE_PULLDOWN_IMPERIAL | -1,006,614 | "Hide at scales coarser than"
SECTION_BROKEN_DISPLAY_STYLE | -1,006,615 | "Broken Section Display Style"
CUT_MARK_SYMBOL | -1,006,616 | "Cut Mark Symbol"
CUT_LINE_DISTANCE | -1,006,617 | "Cut Line Distance"
CUT_LINE_EXTENSION | -1,006,618 | "Cut Line Extension"
CUT_LINE_ANGLE | -1,006,619 | "Cut Line Angle"
CUT_LINE_TYPE | -1,006,620 | "Cut Line Type"
CUT_MARK_SYMBOL_SIZE | -1,006,621 | "Cut Mark Symbol Size"
START_SYMBOL_TYPE | -1,006,622 | "Start Symbol Type"
ARROWHEAD_TYPE | -1,006,623 | "Arrowhead Type"
LINE_SHAPE_AT_CORNER | -1,006,624 | "Line Shape at Landing Corner"
DISTANCE_TO_CUT_MARK | -1,006,625 | "Distance to Cut Mark"
STAIRS_PATH_START_FROM_RISER | -1,006,626 | "Start from Riser"
ARROWHEAD_END_AT_RISER | -1,006,627 | "End at Riser"
DRAW_FOR_EACH_RUN | -1,006,628 | "Draw for Each Run"
SHOW_ARROWHEAD_TO_CUT_MARK | -1,006,630 | "Show Arrowhead to Cut Mark"
STAIRS_SHOW_UP_TEXT | -1,006,631 | "Show Up Text"
STAIRS_UP_TEXT | -1,006,632 | "Up Text"
STAIRS_SHOW_DOWN_TEXT | -1,006,633 | "Show Down Text"
STAIRS_DOWN_TEXT | -1,006,634 | "Down Text"
STAIRS_TEXT_TYPE | -1,006,635 | "Text Type"
STAIRS_TEXT_ORIENTATION | -1,006,636 | "Orientation"
NUMBER_SYSTEM_JUSTIFY_OFFSET | -1,006,637 | "Justify Offset"
NUMBER_SYSTEM_REFERENCE_OFFSET | -1,006,638 | "Offset from Reference"
NUMBER_SYSTEM_ORIENTATION | -1,006,639 | "Orientation"
NUMBER_SYSTEM_JUSTIFY | -1,006,641 | "Justify"
NUMBER_SYSTEM_REFERENCE | -1,006,642 | "Reference"
NUMBER_SYSTEM_DISPLAY_RULE | -1,006,643 | "Display Rule"
NUMBER_SYSTEM_TAG_TYPE | -1,006,644 | "Tag Type"
NUMBER_SYSTEM_TEXT_SIZE | -1,006,645 | "Number Size"
STAIRS_PATH_START_EXTENSION | -1,006,660 | "Start Extension"
STAIRS_PATH_FULL_STEP_ARROW | -1,006,661 | "Full Step Arrow"
GRID_HEAD_TAG | -1,006,700 | "Symbol"
GRID_BUBBLE_LINE_PEN | -1,006,703 | "Bubble Weight Number\n"
GRID_CENTER_SEGMENT_STYLE | -1,006,704 | "Center Segment"
GRID_CENTER_SEGMENT_WEIGHT | -1,006,705 | "Center Segment Weight"
GRID_CENTER_SEGMENT_COLOR | -1,006,706 | "Center Segment Color"
GRID_CENTER_SEGMENT_PATTERN | -1,006,707 | "Center Segment Pattern"
GRID_END_SEGMENT_WEIGHT | -1,006,708 | "End Segment Weight"
GRID_END_SEGMENT_COLOR | -1,006,709 | "End Segment Color"
GRID_END_SEGMENT_PATTERN | -1,006,710 | "End Segment Pattern"
GRID_END_SEGMENTS_LENGTH | -1,006,711 | "End Segments Length"
SPATIAL_FIELD_MGR_RANGE | -1,006,850 | "Data Range"
SPATIAL_FIELD_MGR_CURRENT_NAME | -1,006,851 | "Analysis Configuration"
SPATIAL_FIELD_MGR_DESCRIPTION | -1,006,852 | "Description"
SPATIAL_FIELD_MGR_LEGEND_SHOW_CONFIG_NAME | -1,006,853 | "Show Configuration Name"
SPATIAL_FIELD_MGR_LEGEND_SHOW_DESCRIPTION | -1,006,854 | "Show Description"
SPATIAL_FIELD_MGR_RESULTS_VISIBILITY | -1,006,855 | "Results Visibility"
SPATIAL_FIELD_MGR_LEGEND_TEXT_TYPE | -1,006,856 | "Overall Legend Text"
VIEW_ANALYSIS_RESULTS_VISIBILITY | -1,006,857 | "Analysis Display Settings"
SPATIAL_FIELD_MGR_LEGEND_HEIGHT | -1,006,858 | "Legend Height"
SPATIAL_FIELD_MGR_LEGEND_WIDTH | -1,006,859 | "Legend Width"
SPATIAL_FIELD_MGR_LEGEND_VERT_ORIGIN_GAP | -1,006,860 | "Legend Vertical Origin Gap"
SPATIAL_FIELD_MGR_LEGEND_HOR_ORIGIN_GAP | -1,006,861 | "Legend Horizontal Origin Gap"
ROOM_NAME | -1,006,900 | "Name"
ROOM_NUMBER | -1,006,901 | "Number"
ROOM_AREA | -1,006,902 | "Area"
ROOM_FINISH_FLOOR | -1,006,903 | "Floor Finish"
ROOM_FINISH_WALL | -1,006,904 | "Wall Finish"
ROOM_FINISH_CEILING | -1,006,905 | "Ceiling Finish"
ROOM_FINISH_BASE | -1,006,906 | "Base Finish"
ROOM_DEPARTMENT | -1,006,907 | "Department"
ROOM_OCCUPANCY | -1,006,909 | "Occupancy"
ROOM_LEVEL_ID | -1,006,916 | "Level"
ROOM_PERIMETER | -1,006,917 | "Perimeter"
ROOM_HEIGHT | -1,006,920 | "Unbounded Height"
ROOM_VOLUME | -1,006,921 | "Volume"
ROOM_UPPER_LEVEL | -1,006,922 | "Upper Limit"
ROOM_UPPER_OFFSET | -1,006,924 | "Limit Offset"
ROOM_LOWER_OFFSET | -1,006,925 | "Base Offset"
ROOM_COMPUTATION_METHOD | -1,006,926 | "Computation"
ALWAYS_ZERO_LENGTH | -1,006,927 | "Base Offset"
ROOM_COMPUTATION_HEIGHT | -1,006,928 | "Computation Height"
LEVEL_ROOM_COMPUTATION_HEIGHT | -1,006,939 | "Computation Height"
LEVEL_ATTR_ROOM_COMPUTATION_HEIGHT | -1,006,940 | "Computation Height"
LEVEL_ATTR_ROOM_COMPUTATION_AUTOMATIC | -1,006,941 | "Automatic Room Computation Height"
VIS_GRAPHICS_MODEL | -1,006,961 | "V/G Overrides Model"
VIS_GRAPHICS_ANNOTATION | -1,006,962 | "V/G Overrides Annotation"
VIS_GRAPHICS_IMPORT | -1,006,963 | "V/G Overrides Import"
VIS_GRAPHICS_FILTERS | -1,006,964 | "V/G Overrides Filters"
VIS_GRAPHICS_RVT_LINKS | -1,006,965 | "V/G Overrides RVT Links"
VIS_GRAPHICS_DESIGNOPTIONS | -1,006,966 | "V/G Overrides Design Options"
VIS_GRAPHICS_ANALYTICAL_MODEL | -1,006,967 | "V/G Overrides Analytical Model"
VIS_GRAPHICS_WORKSETS | -1,006,968 | "V/G Overrides Worksets"
VIS_GRAPHICS_POINT_CLOUDS | -1,006,969 | "V/G Overrides Point Clouds"
VIS_GRAPHICS_COORDINATION_MODEL | -1,006,970 | "V/G Overrides Coordination Model"
RADIUS_SYMBOL_TEXT | -1,006,997 | "Radius Symbol Text"
DIAMETER_SYMBOL_LOCATION | -1,006,998 | "Diameter Symbol Location"
DIAMETER_SYMBOL_TEXT | -1,006,999 | "Diameter Symbol Text"
TAG_TAG | -1,007,000 | "Label"
TAG_SAMPLE_TEXT | -1,007,001 | "Sample Text"
TAG_ORIENTATION_PARAM | -1,007,003 | "Orientation"
ROOM_TAG_ORIENTATION_PARAM | -1,007,004 | "Orientation"
TAG_NO_BREAK_PARAM_STRINGS | -1,007,005 | "Wrap between parameters only"
TAG_LEADER_TYPE | -1,007,006 | "Leader Type"
TAG_ANGLE_PARAM | -1,007,007 | "Angle"
TAG_ELEMENT_COUNT | -1,007,008 | "Host Count"
TAG_ELEVATION_BASE | -1,007,010 | "Elevation Base"
MULTI_REFERENCE_ANNOTATION_REFERENCE_CATEGORY | -1,007,050 | "Reference Category"
MULTI_REFERENCE_ANNOTATION_TAG_TYPE | -1,007,051 | "Tag Family"
MULTI_REFERENCE_ANNOTATION_GROUP_TAG_HEADS | -1,007,052 | "Group Matching Tag Heads"
MULTI_REFERENCE_ANNOTATION_DIMENSION_STYLE | -1,007,053 | "Dimension Style"
MULTI_REFERENCE_ANNOTATION_SHOW_DIMENSION_TEXT | -1,007,054 | "Show Dimension Text"
SHEET_COLLECTION_NAME | -1,007,071 | "Name"
LEVEL_HEAD_TAG | -1,007,100 | "Symbol"
LEVEL_NAME | -1,007,101 | "Level"
LEVEL_ELEV | -1,007,102 | "Elevation"
LEVEL_RELATIVE_BASE_TYPE | -1,007,109 | "Elevation Base"
LEVEL_UP_TO_LEVEL | -1,007,110 | "Story Above"
LEVEL_IS_BUILDING_STORY | -1,007,111 | "Building Story"
LEVEL_IS_STRUCTURAL | -1,007,112 | "Structural"
STAIRS_BASE_LEVEL_PARAM | -1,007,200 | "Base Level"
STAIRS_TOP_LEVEL_PARAM | -1,007,201 | "Top Level"
STAIRS_ATTR_MAX_RISER_HEIGHT | -1,007,202 | "Maximum Riser Height"
STAIRS_ATTR_MINIMUM_TREAD_DEPTH | -1,007,203 | "Minimum Tread Depth"
STAIRS_ATTR_TREAD_WIDTH | -1,007,204 | "Width"
STAIRS_DESIRED_NUM_RISERS | -1,007,205 | "Desired Number of Risers"
STAIRS_ACTUAL_RISER_HEIGHT | -1,007,206 | "Actual Riser Height"
STAIRS_ATTR_RISERS_PRESENT | -1,007,208 | "Risers Present"
STAIRS_ATTR_STRINGER_HEIGHT | -1,007,209 | "Stringer Height"
STAIRS_ATTR_STRINGER_THICKNESS | -1,007,210 | "Stringer Thickness"
STAIRS_ATTR_TREAD_THICKNESS | -1,007,211 | "Tread Thickness"
STAIRS_ATTR_RISER_ANGLE | -1,007,212 | "Riser Angle"
STAIRS_BASE_OFFSET | -1,007,218 | "Base Offset"
STAIRS_TOP_OFFSET | -1,007,219 | "Top Offset"
STAIRS_STRINGERS_PRESENT | -1,007,234 | "Stringer Position"
STAIRS_MULTISTORY_TOP_LEVEL_PARAM | -1,007,235 | "Multistory Top Level"
STAIRS_ATTR_SIDE_STRINGER_TYPE_PARAM | -1,007,236 | "Type of Side Stringers"
STAIRS_ATTR_STRINGER_CARRIAGE | -1,007,237 | "Stringer Carriage Height"
STAIRS_ATTR_STRINGER_OFFSET | -1,007,238 | "Open Stringer Offset"
STAIRS_ATTR_STRINGER_MATERIAL | -1,007,239 | "Stringer Material"
STAIRS_ATTR_TREAD_FRONT_PROFILE | -1,007,240 | "Nosing Profile"
STAIRS_ATTR_NOSING_LENGTH | -1,007,241 | "Nosing Length"
STAIRS_ATTR_TREAD_MATERIAL | -1,007,242 | "Tread Material"
STAIRS_ATTR_RISER_TYPE | -1,007,243 | "Riser Type"
STAIRS_ATTR_RISER_MATERIAL | -1,007,244 | "Riser Material"
STAIRS_ATTR_BREAK_SYM_IN_CUTLINE | -1,007,245 | "Break Symbol in Plan"
STAIRS_ACTUAL_NUM_RISERS | -1,007,246 | "Actual Number of Risers"
STAIRS_ATTR_STAIR_CALCULATOR | -1,007,247 | "Calculation Rules"
STAIRS_ATTR_RISER_MULT | -1,007,248 | "Riser Multiplier"
STAIRS_ATTR_TREAD_MULT | -1,007,249 | "Tread Multiplier"
STAIRS_ACTUAL_TREAD_DEPTH | -1,007,250 | "Actual Tread Depth"
STAIRS_ATTR_EQ_RESULT | -1,007,251 | "Calculation Rules"
STAIRS_ATTR_CALC_MIN | -1,007,252 | "Calculation Rules"
STAIRS_ATTR_CALC_MAX | -1,007,253 | "Calculation Rules"
STAIRS_ATTR_CALC_ENABLED | -1,007,254 | "Calculation Rules"
STAIRS_ATTR_MONOLITHIC_STAIRS | -1,007,255 | "Monolithic Stairs"
STAIRS_ATTR_STAIRS_BOTTOM | -1,007,256 | "Underside of Winder"
STAIRS_ATTR_FIRST_RISER | -1,007,257 | "Begin with Riser"
STAIRS_ATTR_LAST_RISER | -1,007,258 | "End with Riser"
STAIRS_ATTR_STAIRS_CUT_OFFSET | -1,007,259 | "Extend Below Base"
STAIRS_ATTR_NUM_MID_STRINGERS | -1,007,260 | "Middle Stringers"
STAIRS_ATTR_RISER_THICKNESS | -1,007,261 | "Riser Thickness"
STAIRS_ATTR_RISER_TREAD_CONNECT | -1,007,262 | "Riser to Tread Connection"
STAIRS_ATTR_NOSING_PLACEMENT | -1,007,263 | "Apply Nosing Profile"
STAIRS_ATTR_LEFT_SIDE_STRINGER | -1,007,264 | "Left Stringer"
STAIRS_ATTR_RIGHT_SIDE_STRINGER | -1,007,265 | "Right Stringer"
STAIRS_ATTR_LANDINGS_OVERLAPPING | -1,007,266 | "Landing Overlap"
STAIRS_ATTR_LANDING_CARRIAGE | -1,007,267 | "Landing Carriage Height"
STAIRS_ATTR_BODY_MATERIAL | -1,007,268 | "Monolithic Material"
STAIRS_ATTR_TEXT_FONT | -1,007,269 | "Text Font"
STAIRS_ATTR_TEXT_SIZE | -1,007,270 | "Text Size"
STAIRS_INST_UP_LABEL_ON | -1,007,271 | "Up label"
STAIRS_INST_UP_LABEL_TEXT | -1,007,272 | "Up text"
STAIRS_INST_UP_ARROW_ON | -1,007,273 | "Up arrow"
STAIRS_INST_DOWN_LABEL_ON | -1,007,274 | "Down label"
STAIRS_INST_DOWN_LABEL_TEXT | -1,007,275 | "Down text"
STAIRS_INST_DOWN_ARROW_ON | -1,007,276 | "Down arrow"
STAIRS_ATTR_TRIM_TOP | -1,007,277 | "Trim Stringers at Top"
STAIRS_INST_ALWAYS_UP | -1,007,278 | "Show Up arrow in all views"
RECT_MULLION_WIDTH1 | -1,007,300 | "Width on side 1"
RECT_MULLION_WIDTH2 | -1,007,301 | "Width on side 2"
RECT_MULLION_THICK | -1,007,304 | "Thickness"
CUST_MULLION_WIDTH1 | -1,007,320 | "Width on side 1"
CUST_MULLION_WIDTH2 | -1,007,321 | "Width on side 2"
CUST_MULLION_THICK | -1,007,322 | "Thickness"
CIRC_MULLION_RADIUS | -1,007,350 | "Radius"
MULLION_OFFSET | -1,007,351 | "Offset"
MULLION_FAM_TYPE | -1,007,352 | "Mullion Family General Shape"
MULLION_CORNER_TYPE | -1,007,353 | "Corner Mullion"
LV_MULLION_LEG1 | -1,007,354 | "Leg 1"
LV_MULLION_LEG2 | -1,007,355 | "Leg 2"
MULLION_DEPTH | -1,007,356 | "Depth"
MULLION_DEPTH1 | -1,007,357 | "Depth 1"
MULLION_DEPTH2 | -1,007,358 | "Depth 2"
TRAP_MULL_WIDTH | -1,007,359 | "Center Width"
MULLION_PROFILE | -1,007,361 | "Profile"
MULLION_POSITION | -1,007,362 | "Position"
MULLION_ANGLE | -1,007,363 | "Angle"
CURTAIN_GRID_BASE_ORIENTATION | -1,007,364 | "Grid Base Orientation"
AUTO_MULLION_INTERIOR_GRID1 | -1,007,380 | "Interior Type"
AUTO_MULLION_INTERIOR_GRID2 | -1,007,381 | "Interior Type"
AUTO_MULLION_BORDER1_GRID1 | -1,007,382 | "Border 1 Type"
AUTO_MULLION_BORDER2_GRID1 | -1,007,383 | "Border 2 Type"
AUTO_MULLION_BORDER1_GRID2 | -1,007,384 | "Border 1 Type"
AUTO_MULLION_BORDER2_GRID2 | -1,007,385 | "Border 2 Type"
AUTO_PANEL | -1,007,386 | "Curtain Panel"
AUTO_JOIN_CONDITION | -1,007,387 | "Join Condition"
AUTO_PANEL_WALL | -1,007,388 | "Curtain Panel"
AUTO_MULLION_INTERIOR_VERT | -1,007,389 | "Interior Type"
AUTO_MULLION_INTERIOR_HORIZ | -1,007,390 | "Interior Type"
AUTO_MULLION_BORDER1_VERT | -1,007,391 | "Border 1 Type"
AUTO_MULLION_BORDER2_VERT | -1,007,392 | "Border 2 Type"
AUTO_MULLION_BORDER1_HORIZ | -1,007,393 | "Border 1 Type"
AUTO_MULLION_BORDER2_HORIZ | -1,007,394 | "Border 2 Type"
AUTO_JOIN_CONDITION_WALL | -1,007,395 | "Join Condition"
SPACING_APPEND | -1,007,398 | "Append Position"
SHEET_NAME | -1,007,400 | "Sheet Name"
SHEET_NUMBER | -1,007,401 | "Sheet Number"
SHEET_SCALE | -1,007,402 | "Scale"
SHEET_DATE | -1,007,403 | "Date/Time Stamp"
SHEET_DRAWN_BY | -1,007,404 | "Drawn By"
SHEET_CHECKED_BY | -1,007,405 | "Checked By"
SHEET_SCHEDULED | -1,007,406 | "Appears In Sheet List"
SHEET_DESIGNED_BY | -1,007,407 | "Designed By"
SHEET_APPROVED_BY | -1,007,408 | "Approved By"
SHEET_FILE_PATH | -1,007,409 | "File Path"
SHEET_WIDTH | -1,007,410 | "Sheet Width"
SHEET_HEIGHT | -1,007,411 | "Sheet Height"
SHEET_CURRENT_REVISION | -1,007,412 | "Current Revision"
SHEET_REVISIONS_ON_SHEET | -1,007,413 | "Revisions on Sheet"
SHEET_CURRENT_REVISION_DESCRIPTION | -1,007,414 | "Current Revision Description"
SHEET_CURRENT_REVISION_DATE | -1,007,415 | "Current Revision Date"
SHEET_CURRENT_REVISION_ISSUED_TO | -1,007,416 | "Current Revision Issued To"
SHEET_CURRENT_REVISION_ISSUED_BY | -1,007,417 | "Current Revision Issued By"
SHEET_CURRENT_REVISION_ISSUED | -1,007,418 | "Current Revision Issued"
SHEET_GUIDE_GRID | -1,007,419 | "Guide Grid"
SHEET_COLLECTION | -1,007,421 | "Sheet Collection"
COLOR_FILL_FILTERED_PARAM | -1,007,502 | "Values Displayed"
COLOR_FILL_SWATCH_WIDTH_PARAM | -1,007,503 | "Swatch Width"
COLOR_FILL_SWATCH_HEIGHT_PARAM | -1,007,504 | "Swatch Height"
ELEV_WIDTH | -1,007,600 | "Width"
ELEV_SHAPE | -1,007,601 | "Shape"
ELEV_ARROW_ANGLE | -1,007,602 | "Arrow Angle"
ELEV_ARROW_FILLED | -1,007,603 | "Filled"
ELEV_TEXT_POS | -1,007,604 | "Text Position"
ELEV_SHOW_VIEW_NAME | -1,007,605 | "Show View Name"
ELEV_VIEW_NAME_POS | -1,007,607 | "View Name Position"
ELEV_ASSOC_DATUM | -1,007,608 | "Associated Datum"
ELEV_REFERENCE_LABEL_POS | -1,007,609 | "Reference Label Position"
ELEV_SYMBOL_ID | -1,007,610 | "Elevation Mark"
IMPORT_SYMBOL_NAME | -1,007,700 | "Name"
IMPORT_SCALE | -1,007,701 | "Scale Factor"
IMPORT_BASE_LEVEL | -1,007,702 | "Work Plane"
IMPORT_BASE_LEVEL_OFFSET | -1,007,703 | "Offset from Work Plane"
IMPORT_DISPLAY_UNITS | -1,007,704 | "Import Units"
IMPORT_BACKGROUND | -1,007,705 | "Draw Layer"
IMPORT_INSTANCE_SCALE | -1,007,706 | "Instance Scale"
IMPORT_INSTANCE_CUTTING_IN_VIEW | -1,007,707 | "Enable Cutting in Views"
GEO_LOCATION | -1,007,720 | "Shared Site"
RVT_LINK_INSTANCE_NAME | -1,007,721 | "Name"
RVT_SOURCE_LEVEL | -1,007,723 | "Map Levels..."
RVT_HOST_LEVEL | -1,007,724 | "Map Levels..."
RVT_LEVEL_OFFSET | -1,007,725 | "Map Levels..."
RVT_LINK_FILE_NAME_WITHOUT_EXT | -1,007,726 | "File Name"
RVT_LINK_REFERENCE_TYPE | -1,007,727 | "Reference Type"
RVT_LINK_PHASE_MAP | -1,007,728 | "Phase Mapping"
RVT_LINK_INSTANCE_PROJECT_INFORMATION | -1,007,729 | "Project Information"
IMPORT_ADT_ENTITY_TYPE | -1,007,730 | "Type Name"
IMPORT_ADT_ENTITY_STRUCT_TYPE | -1,007,731 | "Structural Type Name"
IMPORT_ADT_ENTITY_STYLE | -1,007,732 | "Style Name"
IMPORT_ADT_COMPONENTS_DESC | -1,007,733 | "Component Description"
IMPORT_ADT_ENTITY_HEIGHT | -1,007,734 | "Height"
IMPORT_ADT_ENTITY_WIDTH | -1,007,735 | "Width"
IMPORT_ADT_ENTITY_LENGTH | -1,007,736 | "Length"
IMPORT_ADT_ENTITY_THICKNESS | -1,007,737 | "Thickness"
IMPORT_ADT_ENTITY_ROLL | -1,007,738 | "Roll"
RASTER_SHEETWIDTH | -1,007,750 | "Width"
RASTER_SHEETHEIGHT | -1,007,751 | "Height"
RASTER_LOCK_PROPORTIONS | -1,007,752 | "Lock Proportions"
RASTER_SYMBOL_PIXELWIDTH | -1,007,760 | "Width (pixels)"
RASTER_SYMBOL_PIXELHEIGHT | -1,007,761 | "Height (pixels)"
RASTER_SYMBOL_VIEWNAME | -1,007,762 | "View Name"
RASTER_SYMBOL_FILENAME | -1,007,763 | "Loaded from file"
RASTER_SYMBOL_RESOLUTION | -1,007,764 | "Resolution (dpi)"
RASTER_SYMBOL_WIDTH | -1,007,765 | "Width"
RASTER_SYMBOL_HEIGHT | -1,007,766 | "Height"
RASTER_VERTICAL_SCALE | -1,007,767 | "Vertical Scale"
RASTER_HORIZONTAL_SCALE | -1,007,768 | "Horizontal Scale"
RASTER_SYMBOL_PAGENUMBER | -1,007,769 | "Page Number"
RASTER_ENABLE_SNAPS | -1,007,770 | "Enable Snaps"
RASTER_SYMBOL_LINKLOAD_STATUS | -1,007,771 | "Link Status"
SCHEDULE_FIELDS_PARAM | -1,007,800 | "Fields"
SCHEDULE_FILTER_PARAM | -1,007,801 | "Filter"
SCHEDULE_GROUP_PARAM | -1,007,803 | "Sorting/Grouping"
SCHEDULE_FORMAT_PARAM | -1,007,804 | "Formatting"
SCHEDULE_SHEET_APPEARANCE_PARAM | -1,007,805 | "Appearance"
SCHEDULE_EMBEDDED_PARAM | -1,007,806 | "Embedded Schedule"
RBS_PANEL_SCHEDULE_SHEET_APPEARANCE_PARAM | -1,007,807 | "Appearance On Sheet"
RBS_PANEL_SCHEDULE_SHEET_APPEARANCE_INST_PARAM | -1,007,808 | "Appearance"
REF_TABLE_ELEM_NAME | -1,007,850 | "Key Name"
REF_TABLE_PARAM_NAME | -1,007,851 | "Parameter Name"
ARC_WALL_CNTR_MRK_VISIBLE | -1,007,900 | "Center Mark Visible"
ARC_CURVE_CNTR_MRK_VISIBLE | -1,007,900 | "Center Mark Visible"
ELLIPSE_FOCUS_MRK_VISIBLE | -1,007,905 | "Focus Marks Visible"
CURVE_TOP_LEVEL | -1,007,906 | "Top Level"
CURVE_BOTTOM_LEVEL | -1,007,907 | "Bottom Level"
CURVE_BASE_LEVEL | -1,007,907 | "Bottom Level"
CURVE_IS_MULTILEVEL | -1,007,908 | "Multilevel Boundary"
DATUM_TEXT | -1,008,000 | "Name"
DATUM_BUBBLE_END_2 | -1,008,001 | "Symbol at End 2 Default"
DATUM_BUBBLE_END_1 | -1,008,002 | "Symbol at End 1 Default"
DATUM_BUBBLE_LOCATION_IN_ELEV | -1,008,003 | "Non-Plan View Symbols (Default)"
GRID_BUBBLE_END_1 | -1,008,004 | "Plan View Symbols End 1 (Default)"
GRID_BUBBLE_END_2 | -1,008,005 | "Plan View Symbols End 2 (Default)"
CALLOUT_ATTR_HEAD_TAG | -1,008,200 | "Callout Head"
CALLOUT_CORNER_SHEET_RADIUS | -1,008,201 | "Corner Radius"
CALLOUT_SYNCRONIZE_BOUND_OFFSET_FAR | -1,008,203 | "Far Clip Settings"
SECTION_TAG | -1,008,205 | "Section Tag"
CALLOUT_TAG | -1,008,206 | "Callout Tag"
ELEVATN_TAG | -1,008,207 | "Elevation Tag"
POCHE_MAT_ID | -1,008,208 | "Coarse Poche Material"
PLAN_VIEW_VIEW_DIR | -1,008,209 | "View Direction"
DEFAULT_VIEW_TEMPLATE | -1,008,210 | "View Template applied to new views"
ASSIGN_TEMPLATE_ON_VIEW_CREATION | -1,008,211 | "New views are dependent on template"
RAMP_ATTR_MIN_INV_SLOPE | -1,008,301 | "Ramp Max Slope (1/x)"
RAMP_MAX_RUN_LENGTH | -1,008,303 | "Maximum Incline Length"
RAMP_ATTR_THICKNESS | -1,008,304 | "Thickness"
RAMP_ATTR_SHAPE | -1,008,305 | "Shape"
RAMP_ATTR_LEFT_BALUSTER_ATTACH_PT | -1,008,306 | "Left Baluster Location"
RAMP_ATTR_RIGHT_BALUSTER_ATTACH_PT | -1,008,307 | "Right Baluster Location"
RAMP_ATTR_MATERIAL | -1,008,308 | "Ramp Material"
RAMP_ATTR_TEXT_FONT | -1,008,309 | "Text Font"
RAMP_ATTR_TEXT_SIZE | -1,008,310 | "Text Size"
STAIRS_RAILING_HEIGHT | -1,008,602 | "Railing Height"
STAIRS_RAILING_WIDTH | -1,008,603 | "Railing Width"
STAIRS_RAILING_THICKNESS | -1,008,604 | "Railing Thickness"
STAIRS_RAILING_BALUSTER_SHAPE | -1,008,605 | "Baluster Shape"
STAIRS_RAILING_BALUSTER_SPACING_TYPE | -1,008,608 | "Baluster Spacing Type (Stair Railing Only)"
STAIRS_RAILING_BALUSTER_SPACING | -1,008,609 | "Baluster Separation"
STAIRS_RAILING_BALUSTERS_PER_TREAD | -1,008,610 | "Balusters Per Tread (Stair Railing Only)"
STAIRS_RAILING_BALUSTER_WIDTH | -1,008,611 | "Baluster Width"
STAIRS_RAILING_BALUSTER_LENGTH | -1,008,612 | "Baluster Length"
STAIRS_RAILING_SHAPE | -1,008,614 | "Rail Shape"
STAIRS_RAILING_RAIL_STRUCTURE | -1,008,615 | "Rail Structure (Non-Continuous)"
STAIRS_RAILING_RAIL_HEIGHT | -1,008,616 | "Rail Height"
STAIRS_RAILING_RAIL_OFFSET | -1,008,617 | "Rail Offset"
STAIRS_RAILING_BALUSTER_FAMILY | -1,008,618 | "Baluster Family"
STAIRS_RAILING_BALUSTER_OFFSET | -1,008,619 | "Baluster Offset"
STAIRS_RAILING_BASE_LEVEL_PARAM | -1,008,620 | "Base Level"
STAIRS_RAILING_HEIGHT_OFFSET | -1,008,621 | "Base Offset"
STAIRS_RAILING_BALUSTER_HEIGHT | -1,008,622 | "Baluster Height"
STAIRS_RAILING_BALUSTER_TOP_ANGLE | -1,008,623 | "Top Cut Angle"
STAIRS_RAILING_BALUSTER_BOTTOM_ANGLE | -1,008,624 | "Bottom Cut Angle"
STAIRS_RAILING_BALUSTER_SLOPE_ANGLE | -1,008,625 | "Slope Angle"
STAIRS_RAILING_BALUSTER_PLACEMENT | -1,008,626 | "Baluster Placement"
STAIRS_RAILING_RAIL_NAME | -1,008,627 | "Name"
STAIRS_RAILING_HEIGHT_SHIFT_TYPE | -1,008,628 | "Use Landing Height Adjustment"
STAIRS_RAILING_HEIGHT_SHIFT_VAL | -1,008,629 | "Landing Height Adjustment"
STAIRS_RAILING_TANGENT_CONNECTION | -1,008,630 | "Tangent Joins"
STAIRS_RAILING_ANGLED_CONNECTION | -1,008,631 | "Angled Joins"
STAIRS_RAILING_CONNECTION | -1,008,632 | "Rail Connections"
STAIRS_RAILING_BALUSTER_IS_POST | -1,008,633 | "Post"
ELEMENT_LOCKED_PARAM | -1,009,000 | "Locked"
ANALYTICAL_MODEL_START_ALIGNMENT_METHOD | -1,009,500 | "Start Alignment Method"
ANALYTICAL_MODEL_START_Y_PROJECTION | -1,009,501 | "Start y Projection"
ANALYTICAL_MODEL_START_Z_PROJECTION | -1,009,502 | "Start z Projection"
ANALYTICAL_MODEL_END_ALIGNMENT_METHOD | -1,009,503 | "End Alignment Method"
ANALYTICAL_MODEL_END_Y_PROJECTION | -1,009,504 | "End y Projection"
ANALYTICAL_MODEL_END_Z_PROJECTION | -1,009,505 | "End z Projection"
ANALYTICAL_MODEL_BASE_ALIGNMENT_METHOD | -1,009,506 | "Base Alignment Method"
ANALYTICAL_MODEL_BASE_Z_PROJECTION | -1,009,507 | "Base z Projection"
ANALYTICAL_MODEL_BASE_Y_PROJECTION | -1,009,508 | "Base y Projection"
ANALYTICAL_MODEL_TOP_ALIGNMENT_METHOD | -1,009,509 | "Top Alignment Method"
ANALYTICAL_MODEL_TOP_Z_PROJECTION | -1,009,510 | "Top z Projection"
ANALYTICAL_MODEL_TOP_Y_PROJECTION | -1,009,511 | "Top y Projection"
ANALYTICAL_MODEL_TOP_EXTENSION_METHOD | -1,009,512 | "Top Extension Method"
ANALYTICAL_MODEL_COLUMN_TOP_EXTENSION | -1,009,513 | "Top x Projection"
ANALYTICAL_MODEL_BASE_EXTENSION_METHOD | -1,009,514 | "Base Extension Method"
ANALYTICAL_MODEL_COLUMN_BASE_EXTENSION | -1,009,515 | "Base x Projection"
ANALYTICAL_MODEL_FLOOR_ALIGNMENT_METHOD | -1,009,516 | "Alignment Method"
ANALYTICAL_MODEL_FLOOR_PROJECTION | -1,009,517 | "z Projection"
ANALYTICAL_MODEL_WALL_ALIGNMENT_METHOD | -1,009,518 | "Alignment Method"
ANALYTICAL_MODEL_WALL_PROJECTION | -1,009,519 | "z Projection"
ANALYTICAL_MODEL_WALL_TOP_PROJECTION | -1,009,520 | "Top y Projection"
ANALYTICAL_MODEL_WALL_BASE_PROJECTION | -1,009,521 | "Base y Projection"
ANALYTICAL_MODEL_SKETCH_ALIGNMENT_METHOD | -1,009,522 | "Alignment Method"
ANALYTICAL_MODEL_SKETCH_PROJECTION | -1,009,523 | "In-Plane Projection"
ANALYTICAL_MODEL_PHYSICAL_TYPE | -1,009,524 | "Family Type": the Family Type of the physical element associated with the Analytical Model
ANALYTICAL_LINK_RELEASE_TRANSLATION_X | -1,009,525 | "X Translation"
ANALYTICAL_LINK_RELEASE_TRANSLATION_Y | -1,009,526 | "Y Translation"
ANALYTICAL_LINK_RELEASE_TRANSLATION_Z | -1,009,527 | "Z Translation"
ANALYTICAL_LINK_RELEASE_ROTATION_X | -1,009,528 | "X Rotation"
ANALYTICAL_LINK_RELEASE_ROTATION_Y | -1,009,529 | "Y Rotation"
ANALYTICAL_LINK_RELEASE_ROTATION_Z | -1,009,530 | "Z Rotation"
ANALYTICAL_MODEL_START_PROJECTION_ORTHOGONAL | -1,009,531 | "Start Projection Orthogonal"
ANALYTICAL_MODEL_END_PROJECTION_ORTHOGONAL | -1,009,532 | "End Projection Orthogonal"
ANALYTICAL_MEMBER_SECTION_TYPE | -1,009,533 | "Section Type": The id of the type from the structural Family assigned to the analytical member.
GENERIC_DEPTH | -1,010,003 | "Depth"
CASEWORK_DEPTH | -1,010,003 | "Depth"
SHOW_ICON_PARAM | -1,010,016 | "Flag to display icon in Ribbon Combo Item"
ICON_INDEX_PARAM | -1,010,017 | "Index Into Image File Name Array (for Use with XAML)"
GROUPNAME_PARAM | -1,010,018 | "Group Name for Ribbon Combo Items (for Use with XAML)"
ELLIPSE_X_PARAM | -1,010,020 | "X-Radius Value for Ellipse (for Use with XAML Data Template example)"
ELLIPSE_Y_PARAM | -1,010,021 | "Y-Radius Value for Ellipse (for Use with XAML Data Template example)"
RGB_R_PARAM | -1,010,022 | "Red value for RGB color spec. (for Use with XAML Data Template example)"
RGB_G_PARAM | -1,010,023 | "Green value for RGB color spec. (for Use with XAML Data Template example)"
RGB_B_PARAM | -1,010,024 | "Blue value for RGB color spec. (for Use with XAML Data Template example)"
ALL_MODEL_DESCRIPTION | -1,010,103 | "Description"
ALL_MODEL_URL | -1,010,104 | "URL"
ALL_MODEL_TYPE_COMMENTS | -1,010,105 | "Type Comments"
ALL_MODEL_INSTANCE_COMMENTS | -1,010,106 | "Comments"
ALL_MODEL_MANUFACTURER | -1,010,108 | "Manufacturer"
ALL_MODEL_MODEL | -1,010,109 | "Model"
CURTAIN_WALL_PANELS_HEIGHT | -1,010,300 | "Height"
CURTAIN_WALL_PANELS_WIDTH | -1,010,301 | "Width"
CURTAIN_WALL_SYSPANEL_OFFSET | -1,010,302 | "Offset"
CURTAIN_WALL_PANEL_HOST_ID | -1,010,303 | "Host Id"
CURTAIN_WALL_SYSPANEL_THICKNESS | -1,010,304 | "Thickness"
ELECTICAL_EQUIP_WATTAGE | -1,010,400 | "Wattage Comments"
ELECTICAL_EQUIP_VOLTAGE | -1,010,401 | "Voltage Comments"
LIGHTING_FIXTURE_WATTAGE | -1,010,500 | "Wattage Comments"
LIGHTING_FIXTURE_LAMP | -1,010,501 | "Lamp"
FBX_LIGHT_LIMUNOUS_FLUX | -1,010,503 | "Luminous Flux"
FBX_LIGHT_SPOT_TILT_ANGLE | -1,010,505 | "Tilt Angle"
FBX_LIGHT_SPOT_BEAM_ANGLE | -1,010,506 | "Spot Beam Angle"
FBX_LIGHT_SPOT_FIELD_ANGLE | -1,010,507 | "Spot Field Angle"
LIGHTING_FIXTURE_LIGHT_EMITTER | -1,010,508 | "Light Emitter"
PLUMBING_FIXTURES_SUPPLY_FITTING | -1,010,700 | "Supply Fitting"
PLUMBING_FIXTURES_SUPPLY_PIPE | -1,010,701 | "Supply Pipe"
PLUMBING_FIXTURES_DRAIN | -1,010,702 | "Drain"
PLUMBING_FIXTURES_TRAP | -1,010,703 | "Trap"
PLUMBING_FIXTURES_HW_CONNECTION | -1,010,704 | "HW Connection"
PLUMBING_FIXTURES_CW_CONNECTION | -1,010,705 | "CW Connection"
PLUMBING_FIXTURES_WASTE_CONNECTION | -1,010,706 | "Waste Connection"
PLUMBING_FIXTURES_VENT_CONNECTION | -1,010,707 | "Vent Connection"
VIEW_DETAIL_LEVEL | -1,011,002 | "Detail Level"
VIEW_PARTS_VISIBILITY | -1,011,003 | "Parts Visibility"
INSULATION_WIDTH | -1,011,100 | "Insulation Width"
INSULATION_SCALE | -1,011,101 | "Insulation Bulge to Width Ratio (1/x)"
REPEATING_DETAIL_NUMBER | -1,011,103 | "Number"
REPEATING_DETAIL_SPACING | -1,011,104 | "Spacing"
REPEATING_DETAIL_LAYOUT | -1,011,105 | "Layout"
REPEATING_DETAIL_ELEMENT | -1,011,106 | "Detail"
REPEATING_DETAIL_INSIDE | -1,011,107 | "Inside"
REPEATING_DETAIL_ROTATION | -1,011,109 | "Detail Rotation"
REVISION_CLOUD_REVISION | -1,011,900 | "Revision"
REVISION_CLOUD_REVISION_NUM | -1,011,901 | "Revision Number"
REVISION_CLOUD_REVISION_DESCRIPTION | -1,011,902 | "Revision Description"
REVISION_CLOUD_REVISION_DATE | -1,011,903 | "Revision Date"
REVISION_CLOUD_REVISION_ISSUED_TO | -1,011,904 | "Issued to"
REVISION_CLOUD_REVISION_ISSUED_BY | -1,011,906 | "Issued by"
PROJECT_REVISION_SEQUENCE_NUM | -1,011,950 | "Revision Sequence": read_only Make this read-only again when NewSchedules_DisplayTags is cleaned up
PROJECT_REVISION_REVISION_NUM | -1,011,951 | "Revision Number"
PROJECT_REVISION_REVISION_DESCRIPTION | -1,011,952 | "Revision Description"
PROJECT_REVISION_REVISION_DATE | -1,011,953 | "Revision Date"
PROJECT_REVISION_REVISION_ISSUED_TO | -1,011,954 | "Issued to"
PROJECT_REVISION_REVISION_ISSUED_BY | -1,011,955 | "Issued by"
PROJECT_REVISION_ENUMERATION | -1,011,956 | "Numbering"
PROJECT_REVISION_REVISION_ISSUED | -1,011,957 | "Issued"
MASSING_INTEGRATION_LEVEL | -1,012,000 | "Constrain to Massing"
MASS_GROSS_AREA | -1,012,004 | "Gross Floor Area"
MASS_FLOOR_AREA_LEVELS | -1,012,005 | "Mass Floors"
MASS_GROSS_SURFACE_AREA | -1,012,006 | "Gross Surface Area"
MASS_GROSS_VOLUME | -1,012,007 | "Gross Volume"
LEVEL_DATA_FLOOR_PERIMETER | -1,012,009 | "Floor Perimeter"
LEVEL_DATA_FLOOR_AREA | -1,012,010 | "Floor Area"
LEVEL_DATA_SURFACE_AREA | -1,012,011 | "Exterior Surface Area"
LEVEL_DATA_VOLUME | -1,012,012 | "Floor Volume"
LEVEL_DATA_MASS_TYPE_PARAM | -1,012,013 | "Mass: Type"
LEVEL_DATA_OWNING_LEVEL | -1,012,014 | "Level"
LEVEL_DATA_SPACE_USAGE | -1,012,015 | "Usage"
LEVEL_DATA_MASS_FAMILY_PARAM | -1,012,016 | "Mass: Family"
LEVEL_DATA_MASS_FAMILY_AND_TYPE_PARAM | -1,012,017 | "Mass: Family and Type"
LEVEL_DATA_MASS_TYPE_COMMENTS | -1,012,018 | "Mass: Type Comments"
LEVEL_DATA_MASS_INSTANCE_COMMENTS | -1,012,019 | "Mass: Comments"
LEVEL_DATA_MASS_TYPE_DESCRIPTION | -1,012,020 | "Mass: Description"
MASS_ZONE_VOLUME | -1,012,021 | "Mass Zone Volume"
MASS_ZONE_MATERIAL | -1,012,022 | "Graphical Appearance"
MASS_SURFACEDATA_MATERIAL | -1,012,023 | "Graphical Appearance"
CONCEPTUAL_CONSTRUCTION_MATERIAL | -1,012,024 | "Graphical Appearance"
MASS_ZONE_FLOOR_AREA | -1,012,025 | "Mass Floor Area"
MASS_ZONE_SPACE_TYPE_PARAM | -1,012,026 | "Space Type"
MASS_ZONE_CONDITION_TYPE_PARAM | -1,012,027 | "Condition Type"
MASS_DATA_CONCEPTUAL_CONSTRUCTION | -1,012,030 | "Conceptual Types"
MASS_DATA_SUBCATEGORY | -1,012,031 | "Subcategory"
MASS_DATA_MASS_EXTERIOR_WALL_AREA | -1,012,032 | "Mass Exterior Wall Area"
MASS_DATA_MASS_INTERIOR_WALL_AREA | -1,012,033 | "Mass Interior Wall Area"
MASS_DATA_MASS_ROOF_AREA | -1,012,034 | "Mass Roof Area"
MASS_DATA_MASS_WINDOW_AREA | -1,012,035 | "Mass Window Area"
MASS_DATA_MASS_SKYLIGHT_AREA | -1,012,036 | "Mass Skylight Area"
MASS_DATA_MASS_OPENING_AREA | -1,012,037 | "Mass Opening Area"
MASS_DATA_UNDERGROUND | -1,012,038 | "Underground"
MASS_DATA_PERCENTAGE_GLAZING | -1,012,039 | "Target Percentage Glazing"
MASS_DATA_GLAZING_IS_SHADED | -1,012,040 | "Glazing is Shaded"
MASS_DATA_SHADE_DEPTH | -1,012,041 | "Shade Depth"
MASS_DATA_SILL_HEIGHT | -1,012,042 | "Target Sill Height"
MASS_DATA_PERCENTAGE_SKYLIGHTS | -1,012,043 | "Target Percentage Skylights"
MASS_DATA_SKYLIGHT_WIDTH | -1,012,044 | "Skylight Width & Depth"
MASS_DATA_SURFACE_DATA_SOURCE | -1,012,045 | "Values"
ENERGY_ANALYSIS_CREATE_ANALYTICAL_MODEL | -1,012,046 | "Create Energy Model"
ENERGY_ANALYSIS_BUILDING_OPERATING_SCHEDULE | -1,012,047 | "Building Operating Schedule"
ENERGY_ANALYSIS_MASS_ZONING | -1,012,050 | "Mass Zoning"
ENERGY_ANALYSIS_PERCENTAGE_GLAZING | -1,012,051 | "Target Percentage Glazing"
ENERGY_ANALYSIS_SILL_HEIGHT | -1,012,052 | "Target Sill Height"
ENERGY_ANALYSIS_GLAZING_IS_SHADED | -1,012,053 | "Glazing is Shaded"
ENERGY_ANALYSIS_PERCENTAGE_SKYLIGHTS | -1,012,054 | "Target Percentage Skylights"
ENERGY_ANALYSIS_SKYLIGHT_WIDTH | -1,012,055 | "Skylight Width & Depth"
ENERGY_ANALYSIS_CONCEPTUAL_CONSTRUCTION | -1,012,056 | "Conceptual Types"
ENERGY_ANALYSIS_SHADE_DEPTH | -1,012,057 | "Shade Depth"
ENERGY_ANALYSIS_MASSZONE_COREOFFSET | -1,012,058 | "Perimeter Zone Depth"
ENERGY_ANALYSIS_MASSZONE_DIVIDEPERIMETER | -1,012,059 | "Perimeter Zone Division"
ENERGY_ANALYSIS_MASSZONE_USEENERGYDATASETTINGS | -1,012,060 | "Use Energy Data"
ENERGY_ANALYSIS_OUTDOOR_AIR_INFORMATION_PARAM | -1,012,061 | "Outdoor Air Information"
ENERGY_ANALYSIS_HVAC_SYSTEM | -1,012,062 | "HVAC System"
MASS_DATA_SLAB | -1,012,098 | "Slab"
PHASE_CREATED | -1,012,100 | "Phase Created"
PHASE_DEMOLISHED | -1,012,101 | "Phase Demolished"
VIEW_PHASE | -1,012,102 | "Phase"
VIEW_PHASE_FILTER | -1,012,103 | "Phase Filter"
VIEW_TYPE | -1,012,106 | "Family and Type"
VIEW_FAMILY | -1,012,109 | "Family"
PHASE_NAME | -1,012,110 | "Name"
PHASE_SEQUENCE_NUMBER | -1,012,111 | "Sequence Number"
ROOM_PHASE_ID | -1,012,112 | "Phase Id"
ROOM_PHASE | -1,012,113 | "Phase"
VOLUME_OF_INTEREST_HEIGHT | -1,012,114 | "Height"
ORIENT_BY_VIEW | -1,012,200 | "Rotate With Text"
DATUM_VOLUME_OF_INTEREST | -1,012,201 | "Scope Box"
VIEWER_VOLUME_OF_INTEREST_CROP | -1,012,202 | "Scope Box"
VOLUME_OF_INTEREST_VIEWS_VISIBLE | -1,012,203 | "Views Visible"
VOLUME_OF_INTEREST_NAME | -1,012,205 | "Name"
POINT_ELEVATION | -1,012,400 | "Elevation"
CONTOUR_ELEVATION | -1,012,401 | "Elevation"
CONTOUR_ELEVATION_STEP | -1,012,402 | "Increment"
BOUNDARY_DISTANCE | -1,012,403 | "Distance"
BOUNDARY_BEARING | -1,012,404 | "Bearing"
TOPOSURFACE_CONTOUR_SUBCATEGORY_ID | -1,012,405 | "Subcategory"
BOUNDARY_RADIUS | -1,012,407 | "Radius"
TOPOGRAPHY_LINK_NAME | -1,012,408 | "Link Name"
TOPOGRAPHY_LINK_PATH | -1,012,409 | "Saved Path"
BUILDINGPAD_THICKNESS | -1,012,501 | "Thickness"
BUILDINGPAD_HEIGHTABOVELEVEL_PARAM | -1,012,502 | "Height Offset From Level"
PROPERTY_AREA | -1,012,600 | "Area"
SURFACE_AREA | -1,012,601 | "Surface Area"
SURFACE_PERIMETER | -1,012,602 | "Perimeter"
VOLUME_CUT | -1,012,603 | "Cut"
VOLUME_FILL | -1,012,604 | "Fill"
PROPERTY_AREA_OPEN | -1,012,606 | "Area"
PROPERTY_SUBCATEGORY_ID | -1,012,607 | "Subcategory"
CONTOUR_LABELS_PRIMARY_ONLY | -1,012,608 | "Label primary contours only"
CONTOUR_LABELS_LINEAR_UNITS | -1,012,609 | "Units Format"
PROJECTED_SURFACE_AREA | -1,012,610 | "Projected Area"
VOLUME_NET | -1,012,611 | "Net cut/fill"
PROPERTY_AREA_UNITS | -1,012,612 | "Area Units, Format"
PROPERTY_LENGTH_UNITS | -1,012,613 | "Units Format"
PROPERTY_SEGMENT_DISTANCE | -1,012,614 | "Distance"
PROPERTY_SEGMENT_N_S | -1,012,615 | "N/S"
PROPERTY_SEGMENT_BEARING | -1,012,616 | "Bearing"
PROPERTY_SEGMENT_E_W | -1,012,617 | "E/W"
PROPERTY_SEGMENT_RADIUS | -1,012,618 | "Radius"
PROPERTY_SEGMENT_L_R | -1,012,619 | "L/R"
PROPERTY_SEGMENT_SUBCATEGORY_ID | -1,012,620 | "Subcategory"
CONTOUR_LABELS_ELEV_BASE_TYPE | -1,012,621 | "Elevation Base"
CONTOUR_LABELS_RELATIVE_BASE | -1,012,622 | "Relative Base"
AREA_TYPE | -1,012,701 | "Area Type"
AREA_TYPE_TEXT | -1,012,703 | "Area Type"
AREA_SCHEME_ID | -1,012,704 | "Area Scheme Id"
AREA_SCHEME_NAME | -1,012,705 | "Name"
FAMILY_ROTATE_TEXT_WITH_COMPONENT | -1,012,706 | "Rotate text with component"
WALL_SWEEP_PROFILE_PARAM | -1,012,800 | "Profile"
WALL_SWEEP_LEVEL_PARAM | -1,012,801 | "Level"
WALL_SWEEP_OFFSET_PARAM | -1,012,802 | "Offset From Level"
WALL_SWEEP_WALL_OFFSET_PARAM | -1,012,804 | "Offset From Wall"
HOST_AREA_COMPUTED | -1,012,805 | "Area"
HOST_VOLUME_COMPUTED | -1,012,806 | "Volume"
FAMILY_ROTATE_WITH_COMPONENT | -1,012,807 | "Rotate with component"
FAMILY_ALWAYS_VERTICAL | -1,012,808 | "Always vertical"
WALL_SWEEP_WALL_SUBCATEGORY_ID | -1,012,809 | "Subcategory of Walls"
FAMILY_KEY_EXT_PARAM | -1,012,810 | "Filter Parameter"
FAMILY_ALLOW_CUT_WITH_VOIDS | -1,012,811 | "Cut with Voids When Loaded"
DECAL_ATTRIBUTES | -1,012,812 | "Decal Attributes"
DECAL_LOCK_PROPORTIONS | -1,012,813 | "Lock Proportions"
DECAL_WIDTH | -1,012,814 | "Width"
DECAL_HEIGHT | -1,012,815 | "Height"
DECAL_SUBCATEGORY_ID | -1,012,818 | "Subcategory"
FASCIA_PROFILE_PARAM | -1,012,819 | "Profile"
SWEEP_BASE_ROOF_SUBCATEGORY_ID | -1,012,820 | "Subcategory of Roofs"
SWEEP_BASE_FLOOR_SUBCATEGORY_ID | -1,012,821 | "Subcategory of Floors"
FASCIA_MATERIAL_PARAM | -1,012,822 | "Material"
GUTTER_MATERIAL_PARAM | -1,012,823 | "Material"
SLAB_EDGE_MATERIAL_PARAM | -1,012,824 | "Material"
SWEEP_BASE_OFFSET | -1,012,825 | "Horizontal Profile Offset"
SWEEP_BASE_VERT_OFFSET | -1,012,827 | "Vertical Profile Offset"
WALL_TOP_EXTENSION_DIST_PARAM | -1,012,828 | "Top Extension Distance"
WALL_BOTTOM_EXTENSION_DIST_PARAM | -1,012,829 | "Base Extension Distance"
FAMILY_KEEP_TEXT_READABLE | -1,012,830 | "Keep text readable"
FAMILY_IS_PARAMETRIC | -1,012,831 | "Is parametric"
FAMILY_AUTOJOIN | -1,012,832 | "Automatically joins geometry to walls"
FAMILY_WORK_PLANE_BASED | -1,012,833 | "Work Plane-Based"
FAMILY_SHARED | -1,012,834 | "Shared"
REVEAL_PROFILE_PARAM | -1,012,835 | "Profile"
GUTTER_PROFILE_PARAM | -1,012,836 | "Profile"
SLAB_EDGE_PROFILE_PARAM | -1,012,837 | "Profile"
WALL_SWEEP_CUT_BY_INSERTS_PARAM | -1,012,838 | "Cut by Inserts"
WALL_SWEEP_CUTS_WALL_PARAM | -1,012,839 | "Cuts Wall"
WALL_SWEEP_DEFAULT_SETBACK_PARAM | -1,012,840 | "Default Setback"
FAMILY_USE_PRECUT_SHAPE | -1,012,841 | "Show family pre-cut in plan views"
FAMILY_IS_ELEVATION_MARK_BODY | -1,012,842 | "Elevation Mark Use"
FAMILY_HOSTING_BEHAVIOR | -1,012,843 | "Host"
JOIN_STRENGTH_ORDER | -1,012,870 | "Abstract Join Strength Order"
SKETCH_GRID_SPACING_PARAM | -1,013,000 | "Work Plane Grid Spacing"
GUIDE_GRID_SPACING_PARAM | -1,013,001 | "Guide Spacing"
GUIDE_GRID_NAME_PARAM | -1,013,002 | "Name"
PLAN_REGION_VIEW_RANGE | -1,013,103 | "View Range"
DESIGN_OPTION_PARAM | -1,013,200 | "Design Option"
DESIGN_OPTION_ID | -1,013,201 | "Design Option"
SPACING_LAYOUT_VERT | -1,013,300 | "Layout"
SPACING_LAYOUT_HORIZ | -1,013,301 | "Layout"
SPACING_LENGTH_VERT | -1,013,302 | "Spacing"
SPACING_LENGTH_HORIZ | -1,013,303 | "Spacing"
SPACING_JUSTIFICATION_VERT | -1,013,304 | "Justification"
SPACING_JUSTIFICATION_HORIZ | -1,013,305 | "Justification"
SPACING_NUM_DIVISIONS_VERT | -1,013,306 | "Number"
SPACING_NUM_DIVISIONS_HORIZ | -1,013,307 | "Number"
GRIDLINE_SPEC_STATUS | -1,013,308 | "Type Association"
CURTAINGRID_ANGLE_VERT | -1,013,309 | "Angle"
CURTAINGRID_ANGLE_HORIZ | -1,013,310 | "Angle"
CURTAINGRID_ORIGIN_VERT | -1,013,312 | "Offset"
CURTAINGRID_ORIGIN_HORIZ | -1,013,313 | "Offset"
CURTAINGRID_BELT_VERT | -1,013,314 | "Measurement Line"
CURTAINGRID_BELT_HORIZ | -1,013,315 | "Measurement Line"
CURTAINGRID_ADJUST_BORDER_VERT | -1,013,316 | "Adjust for Mullion Size"
CURTAINGRID_ADJUST_BORDER_HORIZ | -1,013,317 | "Adjust for Mullion Size"
CURTAINGRID_USE_CURVE_DIST_VERT | -1,013,318 | "Use Curve Distance"
CURTAINGRID_USE_CURVE_DIST_HORIZ | -1,013,319 | "Use Curve Distance"
SPACING_LAYOUT_1 | -1,013,330 | "Layout"
SPACING_LAYOUT_2 | -1,013,331 | "Layout"
SPACING_LENGTH_1 | -1,013,332 | "Spacing"
SPACING_LENGTH_2 | -1,013,333 | "Spacing"
SPACING_JUSTIFICATION_1 | -1,013,334 | "Justification"
SPACING_JUSTIFICATION_2 | -1,013,335 | "Justification"
SPACING_NUM_DIVISIONS_1 | -1,013,336 | "Number"
SPACING_NUM_DIVISIONS_2 | -1,013,337 | "Number"
CURTAINGRID_ANGLE_1 | -1,013,339 | "Angle"
CURTAINGRID_ANGLE_2 | -1,013,340 | "Angle"
CURTAINGRID_ORIGIN_1 | -1,013,342 | "Offset"
CURTAINGRID_ORIGIN_2 | -1,013,343 | "Offset"
CURTAINGRID_BELT_1 | -1,013,344 | "Measurement Line"
CURTAINGRID_BELT_2 | -1,013,345 | "Measurement Line"
CURTAINGRID_ADJUST_BORDER_1 | -1,013,346 | "Adjust for Mullion Size"
CURTAINGRID_ADJUST_BORDER_2 | -1,013,347 | "Adjust for Mullion Size"
CURTAINGRID_USE_CURVE_DIST_1 | -1,013,348 | "Use Curve Distance"
CURTAINGRID_USE_CURVE_DIST_2 | -1,013,349 | "Use Curve Distance"
SPACING_LAYOUT | -1,013,350 | "Layout"
SPACING_LENGTH | -1,013,351 | "Spacing"
SPACING_NUM_DIVISIONS | -1,013,352 | "Number"
SPACING_JUSTIFICATION | -1,013,353 | "Justification"
CURTAINGRID_USE_CURVE_DIST | -1,013,354 | "Use Curve Distance"
PADDING_LENGTH | -1,013,366 | "Padding"
CURTAIN_VERSION_PARAM | -1,013,367 | "Curtain version"
CURTAINGRID_BELT_RATIO_1 | -1,013,368 | "Measurement Line"
CURTAINGRID_BELT_RATIO_2 | -1,013,369 | "Measurement Line"
SPACING_LAYOUT_U | -1,013,370 | "Layout"
SPACING_LAYOUT_V | -1,013,371 | "Layout"
SPACING_LENGTH_U | -1,013,372 | "Distance"
SPACING_LENGTH_V | -1,013,373 | "Distance"
SPACING_JUSTIFICATION_U | -1,013,374 | "Justification"
SPACING_JUSTIFICATION_V | -1,013,375 | "Justification"
SPACING_NUM_DIVISIONS_U | -1,013,376 | "Number"
SPACING_NUM_DIVISIONS_V | -1,013,377 | "Number"
CURTAINGRID_ANGLE_U | -1,013,379 | "Grid Rotation"
CURTAINGRID_ANGLE_V | -1,013,380 | "Grid Rotation"
CURTAINGRID_ORIGIN_U | -1,013,382 | "Offset"
CURTAINGRID_ORIGIN_V | -1,013,383 | "Offset"
CURTAINGRID_BELT_U | -1,013,384 | "Belt Measurement"
CURTAINGRID_BELT_V | -1,013,385 | "Belt Measurement"
CURTAINGRID_ADJUST_BORDER_U | -1,013,386 | "Adjust for Mullion Size"
CURTAINGRID_ADJUST_BORDER_V | -1,013,387 | "Adjust for Mullion Size"
CURTAINGRID_USE_CURVE_DIST_U | -1,013,388 | "Use Curve Distance"
CURTAINGRID_USE_CURVE_DIST_V | -1,013,389 | "Use Curve Distance"
CURTAINGRID_BELT_RATIO_U | -1,013,390 | "Belt Measurement"
CURTAINGRID_BELT_RATIO_V | -1,013,391 | "Belt Measurement"
RBS_DUCT_FLOW_PARAM | -1,013,405 | "Flow"
JOIST_SYSTEM_NUMBER_OF_LINES_PARAM | -1,013,407 | "Number of Lines"
JOIST_SYSTEM_SPACING_PARAM | -1,013,408 | "Centerline Spacing"
JOIST_SYSTEM_JUSTIFICATION_PARAM | -1,013,409 | "Justification"
JOIST_SYSTEM_LAYOUT_RULE_PARAM | -1,013,410 | "Layout Rule"
JOIST_SYSTEM_NEW_BEAM_TYPE_PARAM | -1,013,411 | "Beam Type"
CURVE_SUPPORT_OFFSET | -1,013,412 | "Wall offset"
BEAM_V_JUSTIFICATION | -1,013,413 | "z-Direction Justification"
BEAM_H_JUSTIFICATION | -1,013,414 | "Lateral Justification"
JOIST_SYSTEM_NUM_BEAMS_SAME_TYPE | -1,013,415 | "Num. of Beams With Same Type"
BEAM_SYSTEM_TAG_PARAM_LEFT | -1,013,416 | "Left"
BEAM_SYSTEM_TAG_PARAM_RIGHT | -1,013,417 | "Right"
BEAM_SYSTEM_TAG_INST_PARAM_ANGLE | -1,013,418 | "Beam System Tag Direction"
JOIST_SYSTEM_NEW_BEAM_TYPE_NO_FAM_NAME_PARAM | -1,013,419 | "Beam Type (No Family Name)"
BEAM_SYSTEM_3D_PARAM | -1,013,427 | "3D"
CURVE_EDGE_OFFSET | -1,013,429 | "Wall offset"
JOIST_SYSTEM_MAXIMUM_SPACING_PARAM | -1,013,430 | "Maximum Spacing"
JOIST_SYSTEM_FIXED_SPACING_PARAM | -1,013,431 | "Fixed Spacing"
JOIST_SYSTEM_CLEAR_SPACING_PARAM | -1,013,432 | "Clear Spacing"
COVER_TYPE_NAME | -1,013,433 | "Name"
COVER_TYPE_LENGTH | -1,013,434 | "Length"
CLEAR_COVER_EXTERIOR | -1,013,435 | "Rebar Cover - Exterior Face"
CLEAR_COVER_INTERIOR | -1,013,436 | "Rebar Cover - Interior Face"
CLEAR_COVER_OTHER | -1,013,437 | "Rebar Cover - Other Faces"
CLEAR_COVER_TOP | -1,013,438 | "Rebar Cover - Top Face"
CLEAR_COVER_BOTTOM | -1,013,439 | "Rebar Cover - Bottom Face"
CLEAR_COVER | -1,013,440 | "Rebar Cover"
FAMILY_CAN_HOST_REBAR | -1,013,441 | "Can host rebar"
FAMILY_ENABLE_CUTTING_IN_VIEWS | -1,013,442 | "Enable Cutting in Views"
ANALYTICAL_MODEL_STICK_ELEMENTS_MARK | -1,013,443 | "Member Number": Used for beams, braces, columns
ANALYTICAL_MODEL_SURFACE_ELEMENTS_MARK | -1,013,444 | "Surface Number": Used for floors, slabs, walls
ANALYTICAL_MODEL_FOUNDATIONS_MARK | -1,013,445 | "Foundation Number": Used for isolated, wall foundations
ANALYTICAL_MODEL_NODES_MARK | -1,013,446 | "Node Number": Used for nodes
ANALYTICAL_MODEL_CODE_CHECKING | -1,013,447 | "Code Checking": Used for Analytical wall, Analytical beam, Analytical column, Analytical floor, Analytical wall foundations, Analytical isolated foundations, Analytical foundations slab, Anaytical brace
GRID_NET_LOCATION_MARK | -1,013,448 | "Location Mark": Provides grid system association information
ANALYTICAL_ELEMENT_HAS_ASSOCIATION | -1,013,449 | "Has Association": Used for Analytical Member, Analytical Panel, Structural Columns, Structural Framing, Floors, Walls, Structural Foundation
STRUCTURAL_ASSET_PARAM | -1,013,450 | "Physical Material Asset"
ANALYTICAL_GEOMETRY_IS_VALID | -1,013,451 | "Analytical Model Correct"
ANALYTICAL_ELEMENT_PHYSICAL_ASSET | -1,013,452 | "Physical Material Asset": Used for Analytical Elements.
ANALYTICAL_ELEMENT_STRUCTURAL_ROLE | -1,013,453 | "Structural Role": Used for Analytical Elements
ANALYTICAL_PANEL_THICKNESS | -1,013,455 | "Thickness": Used for Analytical Panel
ANALYTICAL_MEMBER_ROTATION | -1,013,456 | "Cross-Section Rotation": Used for Analytical Member
ANALYTICAL_NODE_CONNECTION_STATUS | -1,013,457 | "Connection Status"
SPAN_DIR_INST_PARAM_ANGLE | -1,014,000 | "Span Direction"
SPAN_DIR_SYM_PARAM_TOP | -1,014,001 | "Top"
SPAN_DIR_SYM_PARAM_BOTTOM | -1,014,002 | "Bottom"
SPAN_DIR_SYM_PARAM_LEFT | -1,014,003 | "Left"
SPAN_DIR_SYM_PARAM_RIGHT | -1,014,004 | "Right"
LOAD_CASE_ID | -1,015,000 | "Load Case"
LOAD_USE_LOCAL_COORDINATE_SYSTEM | -1,015,001 | "Orient to"
LOAD_IS_UNIFORM | -1,015,003 | "Uniform Load"
LOAD_IS_REACTION | -1,015,005 | "Is Reaction"
LOAD_IS_HOSTED | -1,015,006 | "Is Hosted"
LOAD_FORCE_FX | -1,015,010 | "Fx"
LOAD_FORCE_FY | -1,015,011 | "Fy"
LOAD_FORCE_FZ | -1,015,012 | "Fz"
LOAD_MOMENT_MX | -1,015,013 | "Mx"
LOAD_MOMENT_MY | -1,015,014 | "My"
LOAD_MOMENT_MZ | -1,015,015 | "Mz"
LOAD_LINEAR_FORCE_FX1 | -1,015,030 | "Fx 1"
LOAD_LINEAR_FORCE_FY1 | -1,015,031 | "Fy 1"
LOAD_LINEAR_FORCE_FZ1 | -1,015,032 | "Fz 1"
LOAD_LINEAR_FORCE_FX2 | -1,015,033 | "Fx 2"
LOAD_LINEAR_FORCE_FY2 | -1,015,034 | "Fy 2"
LOAD_LINEAR_FORCE_FZ2 | -1,015,035 | "Fz 2"
LOAD_MOMENT_MX1 | -1,015,036 | "Mx 1"
LOAD_MOMENT_MY1 | -1,015,037 | "My 1"
LOAD_MOMENT_MZ1 | -1,015,038 | "Mz 1"
LOAD_MOMENT_MX2 | -1,015,039 | "Mx 2"
LOAD_MOMENT_MY2 | -1,015,040 | "My 2"
LOAD_MOMENT_MZ2 | -1,015,041 | "Mz 2"
LOAD_IS_PROJECTED | -1,015,042 | "Projected Load"
LOAD_LINEAR_LENGTH | -1,015,043 | "Length"
LOAD_AREA_FORCE_FX1 | -1,015,060 | "Fx 1"
LOAD_AREA_FORCE_FY1 | -1,015,061 | "Fy 1"
LOAD_AREA_FORCE_FZ1 | -1,015,062 | "Fz 1"
LOAD_AREA_FORCE_FX2 | -1,015,063 | "Fx 2"
LOAD_AREA_FORCE_FY2 | -1,015,064 | "Fy 2"
LOAD_AREA_FORCE_FZ2 | -1,015,065 | "Fz 2"
LOAD_AREA_FORCE_FX3 | -1,015,066 | "Fx 3"
LOAD_AREA_FORCE_FY3 | -1,015,067 | "Fy 3"
LOAD_AREA_FORCE_FZ3 | -1,015,068 | "Fz 3"
LOAD_AREA_AREA | -1,015,069 | "Area"
LOAD_AREA_IS_PROJECTED | -1,015,070 | "Projected Load"
LOAD_ALL_NON_0_LOADS | -1,015,080 | "All non 0 loads"
LOAD_CASE_NATURE_TEXT | -1,015,082 | "Nature"
LOAD_COMMENTS | -1,015,083 | "Comments"
LOAD_DESCRIPTION | -1,015,084 | "Description"
LOAD_ATTR_FORCE_ARROW_TYPE | -1,015,200 | "Force arrowhead"
LOAD_ATTR_FORCE_SCALE_FACTOR | -1,015,201 | "Force scale"
LOAD_ATTR_MOMENT_ARROW_ARC | -1,015,202 | "Moment arrowhead"
LOAD_ATTR_MOMENT_ARROW_LINE | -1,015,203 | "Moment arrowhead (alternate)"
LOAD_ATTR_MOMENT_SCALE_FACTOR | -1,015,204 | "Moment scale"
LOAD_ARROW_SEPARATION | -1,015,205 | "Distance between arrows"
LOAD_ATTR_LINEAR_FORCE_SCALE_FACTOR | -1,015,206 | "Linear force scale"
LOAD_ATTR_AREA_FORCE_SCALE_FACTOR | -1,015,207 | "Area force scale"
LOAD_CASE_NAME | -1,015,250 | "Name"
LOAD_CASE_NUMBER | -1,015,251 | "Case Number"
LOAD_CASE_NATURE | -1,015,252 | "Nature"
LOAD_CASE_SUBCATEGORY | -1,015,253 | "Category"
LOAD_NATURE_NAME | -1,015,254 | "Name"
LOAD_COMBINATION_NAME | -1,015,255 | "Name"
LOAD_COMBINATION_FACTOR | -1,015,256 | "Factor"
LOAD_USAGE_NAME | -1,015,259 | "Name"
CWP_ADD_GRID_PREFIX | -1,016,002 | "Add prefix to Grid Name"
CWP_ADD_GRID_SUFFIX | -1,016,003 | "Add suffix to Grid Name"
CWP_ADD_LEVEL_PREFIX | -1,016,004 | "Add prefix to Level Name"
CWP_ADD_LEVEL_SUFFIX | -1,016,005 | "Add suffix to Level Name"
CWP_LEVEL_OFFSET | -1,016,006 | "Offset Level"
CWP_REUSE_EXISTING_LEVELS | -1,016,007 | "Reuse matching Levels"
CWP_REUSE_EXISTING_GRIDS | -1,016,008 | "Reuse matching Grids"
CWP_SPLIT_COLUMNS_AT_LEVELS | -1,016,009 | "Split Columns by Levels"
CWP_REUSE_LEVELS_SAME_NAME | -1,016,010 | "Reuse Levels with the same name"
CWP_REUSE_GRIDS_SAME_NAME | -1,016,011 | "Reuse Grids with the same name"
CWP_LINKED_ROOM_PHASES | -1,016,015 | "Phases"
CWP_LINKED_ROOM_PARAMS | -1,016,016 | "Parameters"
CWP_COPY_WALL_INSERTS | -1,016,017 | "Copy windows/doors/openings"
CWP_COPY_FLOOR_INSERTS | -1,016,018 | "Copy openings/inserts"
CWP_COPY_ROOF_INSERTS | -1,016,019 | "Copy openings"
WALL_ALIGN_KEY_REF_PARAM | -1,016,021 | "Location line to align"
REBAR_BAR_DIAMETER | -1,017,000 | "Bar Diameter"
REBAR_BAR_STYLE | -1,017,002 | "Subcategory"
REBAR_HOOK_ANGLE | -1,017,003 | "Hook Angle"
REBAR_HOOK_LINE_LEN_FACTOR | -1,017,004 | "Extension Multiplier"
REBAR_ELEM_TOTAL_LENGTH | -1,017,005 | "Total Bar Length"
REBAR_ELEM_HOOK_START_TYPE | -1,017,006 | "Hook At Start"
REBAR_ELEM_HOOK_START_ORIENT | -1,017,007 | "Hook Orientation At Start"
REBAR_ELEM_HOOK_END_TYPE | -1,017,008 | "Hook At End"
REBAR_ELEM_HOOK_END_ORIENT | -1,017,009 | "Hook Orientation At End"
REBAR_STANDARD_BEND_DIAMETER | -1,017,010 | "Standard Bend Diameter"
REBAR_ELEM_LAYOUT_RULE | -1,017,011 | "Layout Rule"
REBAR_ELEM_QUANTITY_OF_BARS | -1,017,012 | "Quantity"
REBAR_ELEM_BAR_SPACING | -1,017,013 | "Spacing"
REBAR_ELEMENT_VISIBILITY | -1,017,014 | "View Visibility States"
REBAR_SHAPE | -1,017,015 | "Shape"
REBAR_ELEM_LENGTH | -1,017,016 | "Bar Length"
REBAR_HOOK_STYLE | -1,017,017 | "Style"
REBAR_BAR_HOOK_LENGTHS | -1,017,018 | "Hook Lengths"
REBAR_BAR_STIRRUP_BEND_DIAMETER | -1,017,019 | "Stirrup/Tie Bend Diameter"
REBAR_BAR_MAXIMUM_BEND_RADIUS | -1,017,020 | "Maximum Bend Radius"
REBAR_SHAPE_ALLOWED_BAR_TYPES | -1,017,021 | "Allowable Rebar Bar Types"
REBAR_BAR_ALLOWED_BAR_TYPES | -1,017,021 | "Allowable Rebar Bar Types"
REBAR_SHAPE_HOOK_STYLE | -1,017,022 | "Style"
REBAR_SHAPE_HOOK_START_TYPE | -1,017,023 | "Hook At Start"
REBAR_SHAPE_HOOK_END_TYPE | -1,017,024 | "Hook At End"
REBAR_ELEM_HOOK_STYLE | -1,017,026 | "Style"
REBAR_ELEMENT_ROUNDING | -1,017,027 | "Rounding Overrides"
FABRIC_PARAM_ROUNDING | -1,017,028 | "Rounding Overrides"
REBAR_ELEM_SCHEDULE_MARK | -1,017,032 | "Schedule Mark"
REBAR_SHAPE_START_HOOK_LENGTH | -1,017,033 | "Start Hook Length"
REBAR_SHAPE_START_HOOK_OFFSET | -1,017,034 | "Start Hook Offset Length"
REBAR_SHAPE_END_HOOK_LENGTH | -1,017,035 | "End Hook Length"
REBAR_SHAPE_END_HOOK_OFFSET | -1,017,036 | "End Hook Offset Length"
REBAR_INSTANCE_BAR_DIAMETER | -1,017,037 | "Bar Diameter"
REBAR_INSTANCE_BEND_DIAMETER | -1,017,038 | "Bend Diameter"
REBAR_INCLUDE_FIRST_BAR | -1,017,039 | "Include First Bar"
REBAR_INCLUDE_LAST_BAR | -1,017,040 | "Include Last Bar"
REBAR_STANDARD_HOOK_BEND_DIAMETER | -1,017,041 | "Standard Hook Bend Diameter"
REBAR_SHAPE_SPIRAL_PITCH | -1,017,042 | "Pitch"
REBAR_SHAPE_SPIRAL_HEIGHT | -1,017,043 | "Height"
REBAR_SHAPE_SPIRAL_TOP_FINISHING_TURNS | -1,017,044 | "Top Finishing Turns"
REBAR_SHAPE_SPIRAL_BASE_FINISHING_TURNS | -1,017,045 | "Base Finishing Turns"
REBAR_SHAPE_STIRRUP_TIE_ATTACHMENT | -1,017,046 | "Stirrup/Tie Attachment"
REBAR_INSTANCE_STIRRUP_TIE_ATTACHMENT | -1,017,047 | "Stirrup/Tie Attachment"
REBAR_SHAPE_OUT_OF_PLANE_BEND_DIAMETER | -1,017,048 | "Out of Plane Bend Diameter"
REBAR_INTERNAL_MULTIPLANAR | -1,017,049 | "INTERNAL: Multiplanar"
REBAR_INTERNAL_MULTIPLANAR_DUPLICATE | -1,017,050 | "INTERNAL: Multiplanar Duplicate"
REBAR_INTERNAL_MULTIPLANAR_START_CONNECTOR | -1,017,051 | "INTERNAL: Multiplanar Start Connector"
REBAR_INTERNAL_MULTIPLANAR_END_CONNECTOR | -1,017,052 | "INTERNAL: Multiplanar End Connector"
REBAR_SHAPE_PARAM_START_HOOK_TAN_LEN | -1,017,053 | "Start Tangent Hook Length"
REBAR_SHAPE_PARAM_END_HOOK_TAN_LEN | -1,017,054 | "End Tangent Hook Length"
REBAR_HOST_CATEGORY | -1,017,055 | "Host Category"
DPART_CAN_HOST_REBAR | -1,017,056 | "Can host rebar"
REBAR_DISTRIBUTION_TYPE | -1,017,057 | "Distribution Type"
REBAR_NUMBER_SUFFIX | -1,017,060 | "Rebar Number Suffix"
REBAR_MINIM_SUFFIX | -1,017,061 | "Minimum Suffix"
REBAR_MAXIM_SUFFIX | -1,017,062 | "Maximum Suffix"
REBAR_MAX_LENGTH | -1,017,063 | "Maximum Bar Length"
REBAR_MIN_LENGTH | -1,017,064 | "Minimum Bar Length"
REBAR_QUANITY_BY_DISTRIB | -1,017,065 | "Quantity By Rebar Set"
FABRIC_WIRE_DIAMETER | -1,017,601 | "Nominal Diameter": Nominal Diameter of Fabric Wire.
FABRIC_SHEET_PHYSICAL_MATERIAL_ASSET | -1,017,602 | "Physical Material Asset": Physical Material Asset
FABRIC_SHEET_MAJOR_DIRECTION_WIRE_TYPE | -1,017,603 | "Major Direction Wire Type": Major Direction Wire Type
FABRIC_SHEET_MINOR_DIRECTION_WIRE_TYPE | -1,017,604 | "Minor Direction Wire Type": Minor Direction Wire Type
FABRIC_SHEET_DEFAULT_MAJOR_LAPSPLICE_LENGTH | -1,017,605 | "Default Major Lap Splice Length": Default Major Lap Splice Length
FABRIC_SHEET_DEFAULT_MINOR_LAPSPLICE_LENGTH | -1,017,606 | "Default Minor Lap Splice Length": Default Minor Lap Splice Length
FABRIC_SHEET_OVERALL_LENGTH | -1,017,607 | "Overall Length": Overall Length
FABRIC_SHEET_LENGTH | -1,017,608 | "Length": Length
FABRIC_SHEET_MAJOR_START_OVERHANG | -1,017,609 | "Major Start Overhang": Major Start Overhang
FABRIC_SHEET_MAJOR_END_OVERHANG | -1,017,610 | "Major End Overhang": Major End Overhang
FABRIC_SHEET_MAJOR_LAYOUT_PATTERN | -1,017,611 | "Major Layout Pattern": Major Layout Pattern
FABRIC_SHEET_MAJOR_NUMBER_OF_WIRES | -1,017,612 | "Major Number of Wires": Major Number of Wires
FABRIC_SHEET_MAJOR_SPACING | -1,017,613 | "Major Spacing": Major Spacing
FABRIC_SHEET_OVERALL_WIDTH | -1,017,614 | "Overall Width": Overall Width
FABRIC_SHEET_WIDTH | -1,017,615 | "Width": Width
FABRIC_SHEET_MINOR_START_OVERHANG | -1,017,616 | "Minor Start Overhang": Minor Start Overhang
FABRIC_SHEET_MINOR_END_OVERHANG | -1,017,617 | "Minor End Overhang": Minor End Overhang
FABRIC_SHEET_MINOR_LAYOUT_PATTERN | -1,017,618 | "Minor Layout Pattern": Minor Layout Pattern
FABRIC_SHEET_MINOR_NUMBER_OF_WIRES | -1,017,619 | "Minor Number of Wires": Minor Number of Wires
FABRIC_SHEET_MINOR_SPACING | -1,017,620 | "Minor Spacing": Minor Spacing
FABRIC_SHEET_MASS | -1,017,621 | "Sheet Mass": Sheet Mass
FABRIC_SHEET_MAJOR_REINFORCEMENT_AREA | -1,017,622 | "Major Reinforcement Area": Major Reinforcement Area
FABRIC_SHEET_MINOR_REINFORCEMENT_AREA | -1,017,623 | "Minor Reinforcement Area": Minor Reinforcement Area
FABRIC_SHEET_MASSUNIT | -1,017,624 | "Sheet Mass per Unit Area": Structural Sheet Mass per Unit Area [Sheet Mass / (Overall Length * Overall Width)]
FABRIC_BEND_DIAMETER | -1,017,625 | "Bend Diameter": Standard Bend Diameter of Fabric Wire.
FABRIC_PARAM_SHEET_TYPE | -1,017,701 | "Fabric Sheet": List all Fabric Sheet types
FABRIC_PARAM_LOCATION_SLAB | -1,017,702 | "Location": Fabric location in the slab
FABRIC_PARAM_LOCATION_WALL | -1,017,703 | "Location": Fabric location in the wall
FABRIC_PARAM_LAPSPLICE_POSITION | -1,017,704 | "Lap Splice Position": Fabric lap splice position in the fabric distribution
FABRIC_PARAM_LOCATION_GENERIC | -1,017,705 | "Location": Fabric location in the host.
FABRIC_PARAM_MAJOR_LAPSPLICE_LENGTH | -1,017,706 | "Major Lap Splice Length": Fabric lap splice length in major direction in the fabric distribution.
FABRIC_PARAM_MINOR_LAPSPLICE_LENGTH | -1,017,707 | "Minor Lap Splice Length": Fabric lap splice length in minor direction in the fabric distribution.
FABRIC_PARAM_COVER_OFFSET | -1,017,708 | "Additional Cover Offset": Additional cover offset of the fabric distribution.
FABRIC_PARAM_CUT_OVERALL_LENGTH | -1,017,709 | "Cut Overall Length": Provides a real sheet Length after definition
FABRIC_PARAM_CUT_OVERALL_WIDTH | -1,017,710 | "Cut Overall Width": Provides a real sheet Width after definition
FABRIC_PARAM_TOTAL_SHEET_MASS | -1,017,711 | "Total Sheet Mass": Calculated all sheet mass: Volume of Wire * Unit Weight.
FABRIC_PARAM_CUT_SHEET_MASS | -1,017,712 | "Cut Sheet Mass": Calculated cut sheet mass [Sheet Mass per Unit Area * (Cut Overall Length * Cut Overall Width)]
FABRIC_PARAM_TAG_VIEW | -1,017,713 | "Tag new members in view": List of all Plan Views and None.
FABRIC_PARAM_SPAN_SYM_TOP | -1,017,720 | "Top"
FABRIC_PARAM_SPAN_SYM_BOTTOM | -1,017,721 | "Bottom"
FABRIC_PARAM_SPAN_SYM_LEFT | -1,017,722 | "Left"
FABRIC_PARAM_SPAN_SYM_RIGHT | -1,017,723 | "Right"
FABRIC_PARAM_SPAN_SYM_D_TOP | -1,017,724 | "D_Top"
FABRIC_PARAM_SPAN_SYM_D_BOTTOM | -1,017,725 | "D_Bottom"
FABRIC_PARAM_SPAN_SYM_D_LEFT | -1,017,726 | "D_Left"
FABRIC_PARAM_SPAN_SYM_D_RIGHT | -1,017,727 | "D_Right"
FABRIC_PARAM_SPAN_TAG_COMPONENT_REFERENCE | -1,017,728 | "Tag Component Reference"
BENT_FABRIC_PARAM_BEND_DIRECTION | -1,017,729 | "Bend Direction": Direction in which FabricSheet is bent.
BENT_FABRIC_PARAM_STRAIGHT_WIRES_LOCATION | -1,017,731 | "Straight Wires Location": Location of straight wires in a bent fabric.
FABRIC_PARAM_CUT_BY_HOST | -1,017,732 | "Cut by Host Cover": Single Fabric Sheet is cut or not cut by the Host Cover.
FABRIC_PARAM_SHARED_FAMILY_KEY | -1,017,733 | "Shared family key"
BENT_FABRIC_PARAM_LONGITUDINAL_CUT_LENGTH | -1,017,734 | "Longitudinal Cut Length": Bent fabric longitudinal cut length.
FABRIC_WIRE_TYPE | -1,017,736 | "Wire type": The wire type assigned
FABRIC_WIRE_LENGTH | -1,017,737 | "Wire length": The wire length
FABRIC_WIRE_DISTANCE | -1,017,738 | "Wire distance": The distance between wires
FABRIC_WIRE_OFFSET | -1,017,739 | "Offset along wire direction": Offset along wire direction
ENERGY_ANALYSIS_CURRENT_VIEW_ONLY | -1,017,750 | "Use Only Elements Visible In Current View"
REBAR_SYSTEM_COVER_SIDE | -1,018,000 | "Rebar Cover Side/Edge"
REBAR_SYSTEM_LAYOUT_RULE | -1,018,001 | "Layout Rule"
REBAR_SYSTEM_LAYER_SUMMARY_WITH_SPACING | -1,018,002 | "Layer Summary"
REBAR_SYSTEM_LAYER_SUMMARY_NO_SPACING | -1,018,003 | "Layer Summary (Brief)"
REBAR_SYSTEM_OVERRIDE | -1,018,005 | "Override Area Reinforcement Settings"
REBAR_SYSTEM_COVER_TOP | -1,018,006 | "Rebar Cover Top/Exterior"
REBAR_SYSTEM_COVER_BOTTOM | -1,018,007 | "Rebar Cover Bottom/Interior"
REBAR_SYSTEM_LAYER_SUMMARY_TOP_DIR_1_WITH_SPACING | -1,018,008 | "Top/Exterior Major"
REBAR_SYSTEM_LAYER_SUMMARY_TOP_DIR_1_NO_SPACING | -1,018,009 | "Top/Exterior Major (Brief)"
REBAR_SYSTEM_LAYER_SUMMARY_TOP_DIR_2_WITH_SPACING | -1,018,010 | "Top/Exterior Minor"
REBAR_SYSTEM_LAYER_SUMMARY_TOP_DIR_2_NO_SPACING | -1,018,011 | "Top/Exterior Minor (Brief)"
REBAR_SYSTEM_LAYER_SUMMARY_BOTTOM_DIR_1_WITH_SPACING | -1,018,012 | "Bottom/Interior Major"
REBAR_SYSTEM_LAYER_SUMMARY_BOTTOM_DIR_1_NO_SPACING | -1,018,013 | "Bottom/Interior Major (Brief)"
REBAR_SYSTEM_LAYER_SUMMARY_BOTTOM_DIR_2_WITH_SPACING | -1,018,014 | "Bottom/Interior Minor"
REBAR_SYSTEM_LAYER_SUMMARY_BOTTOM_DIR_2_NO_SPACING | -1,018,015 | "Bottom/Interior Minor (Brief)"
REBAR_SYSTEM_LAYER_SUMMARY_DIR_1_WITH_SPACING | -1,018,016 | "Major, Both Faces"
REBAR_SYSTEM_LAYER_SUMMARY_DIR_1_NO_SPACING | -1,018,017 | "Major, Both Faces (Brief)"
REBAR_SYSTEM_LAYER_SUMMARY_DIR_2_WITH_SPACING | -1,018,018 | "Minor, Both Faces"
REBAR_SYSTEM_LAYER_SUMMARY_DIR_2_NO_SPACING | -1,018,019 | "Minor, Both Faces (Brief)"
REBAR_SYSTEM_TOP_MAJOR_MATCHES_TOP_MINOR | -1,018,020 | "Top Major and Minor Layers Match"
REBAR_SYSTEM_BOTTOM_MAJOR_MATCHES_BOTTOM_MINOR | -1,018,021 | "Bottom Major and Minor Layers Match"
REBAR_SYSTEM_TOP_MAJOR_MATCHES_BOTTOM_MAJOR | -1,018,022 | "Top and Bottom Major Layers Match"
REBAR_SYSTEM_TOP_MINOR_MATCHES_BOTTOM_MINOR | -1,018,023 | "Top and Bottom Minor Layers Match"
REBAR_SYSTEM_ADDL_TOP_OFFSET | -1,018,024 | "Additional Top Cover Offset"
REBAR_SYSTEM_ADDL_BOTTOM_OFFSET | -1,018,025 | "Additional Bottom Cover Offset"
REBAR_SYSTEM_ADDL_EXTERIOR_OFFSET | -1,018,026 | "Additional Exterior Cover Offset"
REBAR_SYSTEM_ADDL_INTERIOR_OFFSET | -1,018,027 | "Additional Interior Cover Offset"
REBAR_SYSTEM_SPANACTIVE_DIR_1 | -1,018,050 | "Bars In Major Direction"
REBAR_SYSTEM_SPANACTIVE_DIR_2 | -1,018,051 | "Bars In Minor Direction"
REBAR_SYSTEM_SPANHOOK_LEFT_DIR_1 | -1,018,052 | "Hook Angle Left"
REBAR_SYSTEM_SPANHOOK_RIGHT_DIR_1 | -1,018,053 | "Hook Angle Right"
REBAR_SYSTEM_SPANHOOK_BOTTOM_DIR_2 | -1,018,054 | "Hook Angle Bottom"
REBAR_SYSTEM_SPANHOOK_TOP_DIR_2 | -1,018,055 | "Hook Angle Top"
REBAR_SYSTEM_ACTIVE_TOP_DIR_1 | -1,018,100 | "Top Major Direction"
REBAR_SYSTEM_ACTIVE_TOP_DIR_2 | -1,018,102 | "Top Minor Direction"
REBAR_SYSTEM_ACTIVE_BOTTOM_DIR_1 | -1,018,103 | "Bottom Major Direction"
REBAR_SYSTEM_ACTIVE_BOTTOM_DIR_2 | -1,018,104 | "Bottom Minor Direction"
REBAR_SYSTEM_BAR_TYPE_TOP_DIR_1 | -1,018,105 | "Top Major Bar Type"
REBAR_SYSTEM_BAR_TYPE_TOP_DIR_2 | -1,018,106 | "Top Minor Bar Type"
REBAR_SYSTEM_BAR_TYPE_BOTTOM_DIR_1 | -1,018,107 | "Bottom Major Bar Type"
REBAR_SYSTEM_BAR_TYPE_BOTTOM_DIR_2 | -1,018,108 | "Bottom Minor Bar Type"
REBAR_SYSTEM_HOOK_ORIENT_TOP_DIR_1 | -1,018,109 | "Top Major Hook Orientation"
REBAR_SYSTEM_HOOK_ORIENT_TOP_DIR_2 | -1,018,110 | "Top Minor Hook Orientation"
REBAR_SYSTEM_HOOK_ORIENT_BOTTOM_DIR_1 | -1,018,111 | "Bottom Major Hook Orientation"
REBAR_SYSTEM_HOOK_ORIENT_BOTTOM_DIR_2 | -1,018,112 | "Bottom Minor Hook Orientation"
REBAR_SYSTEM_HOOK_TYPE_TOP_DIR_1 | -1,018,113 | "Top Major Hook Type"
REBAR_SYSTEM_HOOK_TYPE_TOP_DIR_2 | -1,018,114 | "Top Minor Hook Type"
REBAR_SYSTEM_HOOK_TYPE_BOTTOM_DIR_1 | -1,018,115 | "Bottom Major Hook Type"
REBAR_SYSTEM_HOOK_TYPE_BOTTOM_DIR_2 | -1,018,116 | "Bottom Minor Hook Type"
REBAR_SYSTEM_NUMBER_OF_LINES_TOP_DIR_1 | -1,018,117 | "Top Major Number Of Lines"
REBAR_SYSTEM_NUMBER_OF_LINES_TOP_DIR_2 | -1,018,118 | "Top Minor Number Of Lines"
REBAR_SYSTEM_NUMBER_OF_LINES_BOTTOM_DIR_1 | -1,018,119 | "Bottom Major Number Of Lines"
REBAR_SYSTEM_NUMBER_OF_LINES_BOTTOM_DIR_2 | -1,018,120 | "Bottom Minor Number Of Lines"
REBAR_SYSTEM_SPACING_TOP_DIR_1 | -1,018,121 | "Top Major Spacing"
REBAR_SYSTEM_SPACING_TOP_DIR_2 | -1,018,122 | "Top Minor Spacing"
REBAR_SYSTEM_SPACING_BOTTOM_DIR_1 | -1,018,123 | "Bottom Major Spacing"
REBAR_SYSTEM_SPACING_BOTTOM_DIR_2 | -1,018,124 | "Bottom Minor Spacing"
REBAR_SYSTEM_ACTIVE_FRONT_DIR_1 | -1,018,200 | "Exterior Major Direction"
REBAR_SYSTEM_ACTIVE_FRONT_DIR_2 | -1,018,203 | "Exterior Minor Direction"
REBAR_SYSTEM_ACTIVE_BACK_DIR_1 | -1,018,204 | "Interior Major Direction"
REBAR_SYSTEM_ACTIVE_BACK_DIR_2 | -1,018,205 | "Interior Minor Direction"
REBAR_SYSTEM_BAR_TYPE_FRONT_DIR_1 | -1,018,206 | "Exterior Major Bar Type"
REBAR_SYSTEM_BAR_TYPE_FRONT_DIR_2 | -1,018,207 | "Exterior Minor Bar Type"
REBAR_SYSTEM_BAR_TYPE_BACK_DIR_1 | -1,018,208 | "Interior Major Bar Type"
REBAR_SYSTEM_BAR_TYPE_BACK_DIR_2 | -1,018,209 | "Interior Minor Bar Type"
REBAR_SYSTEM_HOOK_ORIENT_FRONT_DIR_1 | -1,018,210 | "Exterior Major Hook Orientation"
REBAR_SYSTEM_HOOK_ORIENT_FRONT_DIR_2 | -1,018,211 | "Exterior Minor Hook Orientation"
REBAR_SYSTEM_HOOK_ORIENT_BACK_DIR_1 | -1,018,212 | "Interior Major Hook Orientation"
REBAR_SYSTEM_HOOK_ORIENT_BACK_DIR_2 | -1,018,213 | "Interior Minor Hook Orientation"
REBAR_SYSTEM_HOOK_TYPE_FRONT_DIR_1 | -1,018,214 | "Exterior Major Hook Type"
REBAR_SYSTEM_HOOK_TYPE_FRONT_DIR_2 | -1,018,215 | "Exterior Minor Hook Type"
REBAR_SYSTEM_HOOK_TYPE_BACK_DIR_1 | -1,018,216 | "Interior Major Hook Type"
REBAR_SYSTEM_HOOK_TYPE_BACK_DIR_2 | -1,018,217 | "Interior Minor Hook Type"
REBAR_SYSTEM_NUMBER_OF_LINES_FRONT_DIR_1 | -1,018,218 | "Exterior Major Number Of Lines"
REBAR_SYSTEM_NUMBER_OF_LINES_FRONT_DIR_2 | -1,018,219 | "Exterior Minor Number Of Lines"
REBAR_SYSTEM_NUMBER_OF_LINES_BACK_DIR_1 | -1,018,220 | "Interior Major Number Of Lines"
REBAR_SYSTEM_NUMBER_OF_LINES_BACK_DIR_2 | -1,018,221 | "Interior Minor Number Of Lines"
REBAR_SYSTEM_SPACING_FRONT_DIR_1 | -1,018,222 | "Exterior Major Spacing"
REBAR_SYSTEM_SPACING_FRONT_DIR_2 | -1,018,223 | "Exterior Minor Spacing"
REBAR_SYSTEM_SPACING_BACK_DIR_1 | -1,018,224 | "Interior Major Spacing"
REBAR_SYSTEM_SPACING_BACK_DIR_2 | -1,018,225 | "Interior Minor Spacing"
REBAR_SYSTEM_ACTIVE_TOP_DIR_1_GENERIC | -1,018,250 | "Top/Exterior Major Direction"
REBAR_SYSTEM_ACTIVE_TOP_DIR_2_GENERIC | -1,018,251 | "Top/Exterior Minor Direction"
REBAR_SYSTEM_ACTIVE_BOTTOM_DIR_1_GENERIC | -1,018,252 | "Bottom/Interior Major Direction"
REBAR_SYSTEM_ACTIVE_BOTTOM_DIR_2_GENERIC | -1,018,253 | "Bottom/Interior Minor Direction"
REBAR_SYSTEM_BAR_TYPE_TOP_DIR_1_GENERIC | -1,018,254 | "Top/Exterior Major Bar Type"
REBAR_SYSTEM_BAR_TYPE_TOP_DIR_2_GENERIC | -1,018,255 | "Top/Exterior Minor Bar Type"
REBAR_SYSTEM_BAR_TYPE_BOTTOM_DIR_1_GENERIC | -1,018,256 | "Bottom/Interior Major Bar Type"
REBAR_SYSTEM_BAR_TYPE_BOTTOM_DIR_2_GENERIC | -1,018,257 | "Bottom/Interior Minor Bar Type"
REBAR_SYSTEM_NUMBER_OF_LINES_TOP_DIR_1_GENERIC | -1,018,266 | "Top/Exterior Major Number Of Lines"
REBAR_SYSTEM_NUMBER_OF_LINES_TOP_DIR_2_GENERIC | -1,018,267 | "Top/Exterior Minor Number Of Lines"
REBAR_SYSTEM_NUMBER_OF_LINES_BOTTOM_DIR_1_GENERIC | -1,018,268 | "Bottom/Interior Major Number Of Lines"
REBAR_SYSTEM_NUMBER_OF_LINES_BOTTOM_DIR_2_GENERIC | -1,018,269 | "Bottom/Interior Minor Number Of Lines"
REBAR_SYSTEM_SPACING_TOP_DIR_1_GENERIC | -1,018,270 | "Top/Exterior Major Spacing"
REBAR_SYSTEM_SPACING_TOP_DIR_2_GENERIC | -1,018,271 | "Top/Exterior Minor Spacing"
REBAR_SYSTEM_SPACING_BOTTOM_DIR_1_GENERIC | -1,018,272 | "Bottom/Interior Major Spacing"
REBAR_SYSTEM_SPACING_BOTTOM_DIR_2_GENERIC | -1,018,273 | "Bottom/Interior Minor Spacing"
REBAR_BAR_DEFORMATION_TYPE | -1,018,274 | "Deformation"
PATH_REIN_FACE_SLAB | -1,018,300 | "Face"
PATH_REIN_FACE_WALL | -1,018,301 | "Face"
PATH_REIN_SPACING | -1,018,302 | "Bar Spacing"
PATH_REIN_NUMBER_OF_BARS | -1,018,303 | "Number Of Bars"
PATH_REIN_ALTERNATING | -1,018,304 | "Alternating Bars"
PATH_REIN_TYPE_1 | -1,018,305 | "Primary Bar - Type"
PATH_REIN_TYPE_2 | -1,018,306 | "Alternating Bar - Type"
PATH_REIN_LENGTH_1 | -1,018,307 | "Primary Bar - Length"
PATH_REIN_LENGTH_2 | -1,018,308 | "Alternating Bar - Length"
PATH_REIN_HOOK_TYPE_1 | -1,018,309 | "Primary Bar - Start Hook Type"
PATH_REIN_HOOK_TYPE_2 | -1,018,310 | "Alternating Bar - Start Hook Type"
PATH_REIN_HOOK_ORIENT_1_SLAB | -1,018,311 | "Primary Bar - Hook Orientation"
PATH_REIN_HOOK_ORIENT_2_SLAB | -1,018,312 | "Alternating Bar - Hook Orientation"
PATH_REIN_HOOK_ORIENT_1_WALL | -1,018,313 | "Primary Bar - Hook Orientation"
PATH_REIN_HOOK_ORIENT_2_WALL | -1,018,314 | "Alternating Bar - Hook Orientation"
PATH_REIN_END_HOOK_TYPE_1 | -1,018,315 | "Primary Bar - End Hook Type"
PATH_REIN_END_HOOK_TYPE_2 | -1,018,316 | "Alternating Bar - End Hook Type"
PATH_REIN_END_HOOK_ORIENT_1_SLAB | -1,018,317 | "Primary Bar - End Hook Orientation"
PATH_REIN_END_HOOK_ORIENT_2_SLAB | -1,018,318 | "Alternating Bar - End Hook Orientation"
PATH_REIN_END_HOOK_ORIENT_1_WALL | -1,018,319 | "Primary Bar - End Hook Orientation"
PATH_REIN_END_HOOK_ORIENT_2_WALL | -1,018,320 | "Alternating Bar - End Hook Orientation"
PATH_REIN_ALT_OFFSET | -1,018,321 | "Alternating Bar - Offset"
PATH_REIN_ADDL_OFFSET | -1,018,322 | "Additional Offset"
PATH_REIN_SPANHOOK_PRIM | -1,018,350 | "Start Hook Angle Primary"
PATH_REIN_SPANHOOK_ALT | -1,018,351 | "Start Hook Angle Alternating"
PATH_REIN_SPANLENGTH_BOTTOM_PRIM | -1,018,352 | "Bottom (Primary Bar)"
PATH_REIN_SPANLENGTH_BOTTOM_ALT | -1,018,353 | "Bottom (Alternating Bar)"
PATH_REIN_SUMMARY | -1,018,354 | "Summary"
PATH_REIN_END_SPANHOOK_PRIM | -1,018,355 | "End Hook Angle Primary"
PATH_REIN_END_SPANHOOK_ALT | -1,018,356 | "End Hook Angle Alternating"
PATH_REIN_SPANLENGTH_TOP_ALT | -1,018,357 | "Top (Alternating Bar)"
PATH_REIN_SPANLENGTH_BARLENGTH_PRIM | -1,018,358 | "Length (Primary Bar)"
PATH_REIN_SPANLENGTH_BARLENGTH_ALT | -1,018,359 | "Length (Alternating Bar)"
PATH_REIN_SPANLENGTH_ALT_OFFSET | -1,018,360 | "Offset"
PATH_REIN_SHAPE_1 | -1,018,361 | "Primary Bar - Shape"
PATH_REIN_SHAPE_2 | -1,018,362 | "Alternating Bar - Shape"
REIN_EST_NUMBER_OF_BARS | -1,018,500 | "Estimated Number of Bars"
REIN_EST_BAR_LENGTH | -1,018,501 | "Estimated Total Bar Length"
REIN_EST_BAR_VOLUME | -1,018,502 | "Estimated Reinforcement Volume"
REINFORCEMENT_VOLUME | -1,018,503 | "Reinforcement Volume"
REBAR_CONTAINER_BAR_TYPE | -1,018,505 | "Bar Type"
LEADER_LENGTH | -1,018,705 | "Leader Length"
STRUCT_CONNECTION_APPLY_TO | -1,018,800 | "Apply to"
STRUCT_CONNECTION_BEAM_START | -1,018,801 | "Start Connection"
STRUCT_CONNECTION_BEAM_END | -1,018,802 | "End Connection"
STRUCT_CONNECTION_COLUMN_TOP | -1,018,803 | "Top Connection"
STRUCT_CONNECTION_COLUMN_BASE | -1,018,804 | "Base Connection"
STRUCT_CONNECTION_CUTBACK | -1,018,805 | "Automatic Cutback for Beams and Braces"
STRUCT_CONNECTION_TYPE_NAME | -1,018,850 | "Name"
IFC_GUID | -1,019,000 | "IfcGUID"
IFC_TYPE_GUID | -1,019,001 | "Type IfcGUID"
IFC_PROJECT_GUID | -1,019,002 | "IfcProject GUID"
IFC_BUILDING_GUID | -1,019,003 | "IfcBuilding GUID"
IFC_SITE_GUID | -1,019,004 | "IfcSite GUID"
PROJECT_AUTHOR | -1,019,005 | "Author"
PROJECT_BUILDING_NAME | -1,019,006 | "Building Name"
PROJECT_ORGANIZATION_DESCRIPTION | -1,019,007 | "Organization Description"
PROJECT_ORGANIZATION_NAME | -1,019,008 | "Organization Name"
IFC_APPLICATION_NAME | -1,019,009 | "IfcApplicationName"
IFC_APPLICATION_VERSION | -1,019,010 | "IfcApplicationVersion"
IFC_ORGANIZATION | -1,019,011 | "IfcOrganization"
IFC_EXPORT_ELEMENT | -1,019,012 | "Export to IFC"
IFC_EXPORT_ELEMENT_TYPE | -1,019,013 | "Export Type to IFC"
IFC_EXPORT_ELEMENT_AS | -1,019,014 | "Export to IFC As"
IFC_EXPORT_ELEMENT_TYPE_AS | -1,019,015 | "Export Type to IFC As"
IFC_EXPORT_PREDEFINEDTYPE | -1,019,016 | "IFC Predefined Type"
IFC_EXPORT_PREDEFINEDTYPE_TYPE | -1,019,017 | "Type IFC Predefined Type"
IFC_IMPORT_MATERIAL_NAME | -1,019,018 | "IFC Material Name"
WALL_CROSS_SECTION | -1,019,100 | "Cross-Section"
WALL_SINGLE_SLANT_ANGLE_FROM_VERTICAL | -1,019,101 | "Angle From Vertical"
WALL_TAPERED_EXTERIOR_INWARD_ANGLE | -1,019,102 | "Exterior Angle"
WALL_TAPERED_INTERIOR_INWARD_ANGLE | -1,019,103 | "Interior Angle"
WALL_TYPE_DEFAULT_TAPERED_EXTERIOR_INWARD_ANGLE | -1,019,105 | "Default Exterior Angle"
WALL_TYPE_DEFAULT_TAPERED_INTERIOR_INWARD_ANGLE | -1,019,106 | "Default Interior Angle"
WALL_TYPE_WIDTH_MEASURED_AT | -1,019,107 | "Width Measured At"
WALL_TAPERED_USE_INSTANCE_ANGLES | -1,019,110 | "Enable Angle Overrides"
WALL_TAPERED_WIDTH_AT_TOP | -1,019,120 | "Top Width"
WALL_TAPERED_WIDTH_AT_BOTTOM | -1,019,121 | "Bottom Width"
ALIGNMENT_STATION_LABEL_SET_OFFSET | -1,019,200 | "Alignment Station Label Set Offset": The text is not used directly anywhere in the UI, instead the XAML specifies its own string for the value's label.
ALIGNMENT_STATION_LABEL_SET_INTERVAL | -1,019,201 | "Alignment Station Label Set Interval": The text is not used directly anywhere in the UI, instead the XAML specifies its own string for the value's label.
ALIGNMENT_STATION_LABEL_SET_START_STATION | -1,019,202 | "Alignment Label Set Start Station"
ALIGNMENT_STATION_LABEL_SET_END_STATION | -1,019,203 | "Alignment Label Set End Station"
DIVIDEDPATH_LAYOUT | -1,050,426 | "Layout"
DIVIDEDPATH_DISTANCE | -1,050,427 | "Distance"
DIVIDEDPATH_BEGINNING_INDENT | -1,050,428 | "Beginning Indent"
DIVIDEDPATH_END_INDENT | -1,050,429 | "End Indent"
DIVIDEDPATH_MIN_DISTANCE | -1,050,430 | "Minimum Distance"
DIVIDEDPATH_MAX_DISTANCE | -1,050,431 | "Maximum Distance"
DIVIDEDPATH_MEASUREMENT_TYPE | -1,050,432 | "Measurement Type"
DIVIDEDPATH_FLIP_DIRECTION | -1,050,433 | "Flip Direction"
DIVIDEDPATH_LAYOUT_FIXED_NUM_POINT | -1,050,434 | "Number"
DIVIDEDPATH_JUSTIFICATION | -1,050,435 | "Justification"
DIVIDEDPATH_DISPLAY_REFERENCE_CURVES | -1,050,436 | "Display Path"
DIVIDEDPATH_DISPLAY_NODES | -1,050,437 | "Display Nodes"
DIVIDEDPATH_MERGED_POINT_NUM | -1,050,439 | "Total Number of Nodes"
DIVIDEDPATH_DISPLAY_NODE_NUMBERS | -1,050,440 | "Show Node Numbers"
DIVIDEDPATH_TOTAL_PATH_LENGTH | -1,050,441 | "Path Length"
ANALYTICAL_MEMBER_FORCE_START_FX | -1,060,000 | "Start Fx"
ANALYTICAL_MEMBER_FORCE_START_FY | -1,060,001 | "Start Fy"
ANALYTICAL_MEMBER_FORCE_START_FZ | -1,060,002 | "Start Fz"
ANALYTICAL_MEMBER_FORCE_START_MX | -1,060,003 | "Start Mx"
ANALYTICAL_MEMBER_FORCE_START_MY | -1,060,004 | "Start My"
ANALYTICAL_MEMBER_FORCE_START_MZ | -1,060,005 | "Start Mz"
ANALYTICAL_MEMBER_FORCE_END_FX | -1,060,006 | "End Fx"
ANALYTICAL_MEMBER_FORCE_END_FY | -1,060,007 | "End Fy"
ANALYTICAL_MEMBER_FORCE_END_FZ | -1,060,008 | "End Fz"
ANALYTICAL_MEMBER_FORCE_END_MX | -1,060,009 | "End Mx"
ANALYTICAL_MEMBER_FORCE_END_MY | -1,060,010 | "End My"
ANALYTICAL_MEMBER_FORCE_END_MZ | -1,060,011 | "End Mz"
STRUCTURAL_MEMBER_FORCES | -1,060,012 | "Member Forces"
ANALYTICAL_MEMBER_FORCE_START_ALL_NON_ZERO | -1,060,013 | "All non 0 forces at start"
ANALYTICAL_MEMBER_FORCE_END_ALL_NON_ZERO | -1,060,014 | "All non 0 forces at end"
RBS_START_LEVEL_PARAM | -1,114,000 | "Reference Level"
RBS_END_LEVEL_PARAM | -1,114,001 | "End Level"
RBS_START_OFFSET_PARAM | -1,114,002 | "Start Middle Elevation"
RBS_END_OFFSET_PARAM | -1,114,003 | "End Middle Elevation"
RBS_FLEX_PATTERN_PARAM | -1,114,005 | "Flex Pattern"
RBS_CURVE_WIDTH_PARAM | -1,114,101 | "Width"
RBS_CURVE_HEIGHT_PARAM | -1,114,102 | "Height"
RBS_CURVE_DIAMETER_PARAM | -1,114,103 | "Diameter"
RBS_FLOW_OBSOLETE | -1,114,104 | "Flow"
RBS_CURVE_HOR_OFFSET_PARAM | -1,114,105 | "Horizontal Justification"
RBS_CURVE_VERT_OFFSET_PARAM | -1,114,106 | "Vertical Justification"
RBS_VELOCITY | -1,114,107 | "Velocity"
RBS_PRESSURE_DROP | -1,114,108 | "Pressure Drop"
RBS_CURVETYPE_DEFAULT_ELBOW_PARAM | -1,114,110 | "Elbow"
RBS_CURVETYPE_DEFAULT_TEE_PARAM | -1,114,111 | "Tee"
RBS_CURVETYPE_DEFAULT_CROSS_PARAM | -1,114,112 | "Cross"
RBS_CURVETYPE_DEFAULT_TRANSITION_PARAM | -1,114,113 | "Transition"
DUCT_ROUGHNESS | -1,114,114 | "Roughness"
RBS_FRICTION | -1,114,116 | "Friction"
RBS_INSULATION_THICKNESS | -1,114,117 | "Insulation Thickness"
RBS_LINING_THICKNESS | -1,114,118 | "Lining Thickness"
RBS_CURVETYPE_MAX_HEIGHT_PARAM | -1,114,119 | "Max Height"
RBS_CURVE_SURFACE_AREA | -1,114,120 | "Area"
RBS_VELOCITY_PRESSURE | -1,114,121 | "Velocity Pressure"
RBS_MIN_FLOW | -1,114,122 | "Min Flow"
RBS_MAX_FLOW | -1,114,123 | "Max Flow"
RBS_LOSS_COEFFICIENT | -1,114,124 | "Loss Coefficient"
RBS_SECTION | -1,114,125 | "Section"
RBS_CURVETYPE_MULTISHAPE_TRANSITION_PARAM | -1,114,126 | "Multi Shape Transition Rect to Round"
RBS_EQ_DIAMETER_PARAM | -1,114,127 | "Equivalent Diameter"
RBS_REYNOLDSNUMBER_PARAM | -1,114,128 | "Reynolds number"
RBS_HYDRAULIC_DIAMETER_PARAM | -1,114,129 | "Hydraulic Diameter"
RBS_CURVETYPE_DEFAULT_UNION_PARAM | -1,114,131 | "Union"
RBS_OFFSET_PARAM | -1,114,132 | "Middle Elevation"
RBS_CURVETYPE_DEFAULT_TAKEOFF_PARAM | -1,114,133 | "Tap"
RBS_CURVETYPE_PREFERRED_BRANCH_PARAM | -1,114,134 | "Preferred Junction Type"
RBS_FLEXDUCT_ROUNDTYPE_PARAM | -1,114,135 | "Flex Duct Type"
RBS_DUCT_FITTING_LOSS_METHOD_PARAM | -1,114,136 | "Loss Method"
RBS_DUCT_FITTING_LOSS_TABLE_PARAM | -1,114,137 | "ASHRAE Table"
RBS_DUCT_TYPE_PARAM | -1,114,138 | "Duct Type"
RBS_FLEX_DUCT_TYPE_PARAM | -1,114,139 | "Flex Duct Type"
RBS_PIPE_TYPE_PARAM | -1,114,140 | "Pipe Type"
RBS_FLEX_PIPE_TYPE_PARAM | -1,114,141 | "Flex Pipe"
RBS_DUCT_STATIC_PRESSURE | -1,114,142 | "Static Pressure"
RBS_DUCT_SIZE_FORMATTED_PARAM | -1,114,143 | "Size"
RBS_PIPE_SIZE_FORMATTED_PARAM | -1,114,144 | "Size"
RBS_CURVETYPE_DEFAULT_MECHJOINT_PARAM | -1,114,145 | "Flange"
RBS_DUCT_FITTING_LOSS_METHOD_SERVER_PARAM | -1,114,146 | "Loss Method"
RBS_PIPE_FITTING_LOSS_METHOD_SERVER_PARAM | -1,114,147 | "Loss Method"
RBS_CURVETYPE_DEFAULT_CAP_PARAM | -1,114,148 | "Cap"
RBS_DUCT_FITTING_LOSS_METHOD_SETTINGS | -1,114,149 | "Loss Method Settings"
RBS_PIPE_FITTING_LOSS_METHOD_SETTINGS | -1,114,150 | "Loss Method Settings"
RBS_CURVETYPE_MAX_WIDTH_PARAM | -1,114,165 | "Max Width"
RBS_ADDITIONAL_FLOW | -1,114,166 | "Additional Flow"
RBS_SIZE_LOCK | -1,114,167 | "Size Lock"
PROJECT_BUILDING_TYPE | -1,114,168 | "Building Type"
PROJECT_POSTAL_CODE | -1,114,169 | "Postal Code"
ROOM_CONDITION_TYPE_PARAM | -1,114,171 | "Condition Type"
ROOM_SPACE_TYPE_PARAM | -1,114,172 | "Space Type"
ROOM_OCCUPANCY_UNIT_PARAM | -1,114,173 | "Occupancy Unit"
ROOM_NUMBER_OF_PEOPLE_PARAM | -1,114,174 | "Number of People"
ROOM_AREA_PER_PERSON_PARAM | -1,114,175 | "Area per Person"
ROOM_DESIGN_SUPPLY_AIRFLOW_PARAM | -1,114,176 | "Specified Supply Airflow"
ROOM_DESIGN_RETURN_AIRFLOW_PARAM | -1,114,177 | "Specified Return Airflow"
ROOM_DESIGN_EXHAUST_AIRFLOW_PARAM | -1,114,178 | "Specified Exhaust Airflow"
ROOM_CALCULATED_SUPPLY_AIRFLOW_PARAM | -1,114,180 | "Calculated Supply Airflow"
ROOM_PEOPLE_TOTAL_HEAT_GAIN_PER_PERSON_PARAM | -1,114,188 | "Total Heat Gain per person"
ROOM_PEOPLE_LATENT_HEAT_GAIN_PER_PERSON_PARAM | -1,114,189 | "Latent Heat Gain per person"
ROOM_ACTUAL_SUPPLY_AIRFLOW_PARAM | -1,114,194 | "Actual Supply Airflow"
ROOM_ACTUAL_RETURN_AIRFLOW_PARAM | -1,114,195 | "Actual Return Airflow"
ROOM_ACTUAL_EXHAUST_AIRFLOW_PARAM | -1,114,196 | "Actual Exhaust Airflow"
GBXML_EDIT_DATA_PARAM | -1,114,197 | "Energy Settings"
FAMILY_CONTENT_PART_TYPE | -1,114,206 | "Part Type"
RBS_FAMILY_CONTENT_OFFSET_WIDTH | -1,114,211 | "OffsetWidth"
RBS_FAMILY_CONTENT_OFFSET_HEIGHT | -1,114,212 | "OffsetHeight"
RBS_FAMILY_CONTENT_TAKEOFF_LENGTH | -1,114,213 | "Takeoff Length"
RBS_FAMILY_CONTENT_TAKEOFF_PROJLENGTH | -1,114,214 | "Takeoff Length Projection"
RBS_FAMILY_CONTENT_TAKEOFF_FIXED_LENGTH | -1,114,215 | "Takeoff Fixed Length"
RBS_ROOM_COEFFICIENT_UTILIZATION | -1,114,216 | "Coefficient of Utilization"
FBX_LIGHT_TOTAL_LIGHT_LOSS | -1,114,217 | "Total Light Loss Factor"
FBX_LIGHT_BALLAST_LOSS | -1,114,218 | "Ballast Loss"
ROOM_DESIGN_POWER_LOAD_PER_AREA_PARAM | -1,114,219 | "Specified Power Load per area"
ROOM_DESIGN_LIGHTING_LOAD_PER_AREA_PARAM | -1,114,220 | "Specified Lighting Load per area"
ROOM_DESIGN_MECHANICAL_LOAD_PER_AREA_PARAM | -1,114,221 | "Design HVAC Load per area"
ROOM_DESIGN_OTHER_LOAD_PER_AREA_PARAM | -1,114,222 | "Design Other Load per area"
ROOM_BASE_POWER_LOAD_ON_PARAM | -1,114,223 | "Base Power Load on"
ROOM_BASE_LIGHTING_LOAD_ON_PARAM | -1,114,224 | "Base Lighting Load on"
ROOM_ACTUAL_POWER_LOAD_PARAM | -1,114,225 | "Actual Power Load"
ROOM_ACTUAL_LIGHTING_LOAD_PARAM | -1,114,226 | "Actual Lighting Load"
ROOM_DESIGN_POWER_LOAD_PARAM | -1,114,229 | "Specified Power Load"
ROOM_DESIGN_LIGHTING_LOAD_PARAM | -1,114,230 | "Specified Lighting Load"
RBS_LOOKUP_TABLE_NAME | -1,114,236 | "Lookup Table Name"
RBS_CONNECTOR_OFFSET_OBSOLETE | -1,114,237 | "Connector Offset"
RBS_IS_CUSTOM_FITTING | -1,114,238 | "IsCustom"
ROOM_PEOPLE_SENSIBLE_HEAT_GAIN_PER_PERSON_PARAM | -1,114,239 | "Sensible Heat Gain per person"
RBS_CALCULATED_SIZE | -1,114,240 | "Size"
RBS_ELECTRICAL_DATA | -1,114,241 | "Electrical Data"
RBS_FAMILY_CONTENT_ANNOTATION_DISPLAY | -1,114,242 | "Use Annotation Scale"
FAMILY_ELECTRICAL_MAINTAIN_ANNOTATION_ORIENTATION | -1,114,243 | "Maintain Annotation Orientation"
RBS_GBXML_SURFACE_NAME | -1,114,245 | "Surface Name"
RBS_GBXML_SURFACE_TYPE | -1,114,246 | "Surface Type"
RBS_GBXML_SURFACE_AREA | -1,114,247 | "Area"
RBS_SERVICE_TYPE_PARAM | -1,114,248 | "Building Service"
RBS_CONSTRUCTION_SET_PARAM | -1,114,249 | "Schematic Types"
ROOM_CONSTRUCTION_SET_PARAM | -1,114,251 | "Construction Type"
ROOM_BASE_RETURN_AIRFLOW_ON_PARAM | -1,114,252 | "Return Airflow"
ROOM_CALCULATED_HEATING_LOAD_PARAM | -1,114,253 | "Calculated Heating Load"
ROOM_DESIGN_HEATING_LOAD_PARAM | -1,114,254 | "Design Heating Load"
ROOM_CALCULATED_COOLING_LOAD_PARAM | -1,114,255 | "Calculated Cooling Load"
ROOM_DESIGN_COOLING_LOAD_PARAM | -1,114,256 | "Design Cooling Load"
ROOM_POWER_LOAD_UNITS_PARAM | -1,114,257 | "Power Load Units"
ROOM_LIGHTING_LOAD_UNITS_PARAM | -1,114,258 | "Lighting Load Units"
ROOM_BASE_HEAT_LOAD_ON_PARAM | -1,114,259 | "Heat Load Values"
ROOM_ACTUAL_POWER_LOAD_PER_AREA_PARAM | -1,114,260 | "Actual Power Load per area"
ROOM_ACTUAL_LIGHTING_LOAD_PER_AREA_PARAM | -1,114,261 | "Actual Lighting Load per area"
RBS_PROJECT_LOCATION_PARAM | -1,114,282 | "Location"
ROOM_EDIT_PEOPLE_LOADS_PARAM | -1,114,283 | "People"
ROOM_EDIT_ELECTRICAL_LOADS_PARAM | -1,114,284 | "Electrical Loads"
RBS_ENERGY_ANALYSIS_SURFACE_ADJACENT_SPACE_ID1 | -1,114,285 | "Adjacent Space Id (1)"
RBS_ENERGY_ANALYSIS_SURFACE_ADJACENT_SPACE_ID2 | -1,114,286 | "Adjacent Space Id (2)"
RBS_ENERGY_ANALYSIS_SURFACE_CADOBJECTID | -1,114,287 | "CADObjectID"
RBS_ENERGY_ANALYSIS_SURFACE_TILT | -1,114,288 | "Tilt"
RBS_ENERGY_ANALYSIS_SURFACE_AZIMUTH | -1,114,289 | "Azimuth"
RBS_ENERGY_ANALYSIS_SURFACE_ORIGIN_X | -1,114,290 | "Origin (X)"
RBS_ENERGY_ANALYSIS_SURFACE_ORIGIN_Y | -1,114,291 | "Origin (Y)"
RBS_ENERGY_ANALYSIS_SURFACE_ORIGIN_Z | -1,114,292 | "Origin (Z)"
RBS_ENERGY_ANALYSIS_GROUND_PLANE_PARAM | -1,114,293 | "Ground Plane"
RBS_CONSTRUCTION_TYPE_SHADINGFACTOR_PARAM | -1,114,295 | "Internal Shading Factor"
RBS_PROJECT_CONSTRUCTION_TYPE_SHADINGFACTOR_PARAM | -1,114,296 | "Internal Shading Factor"
RBS_ENERGY_ANALYSIS_VIEW_UPDATE_SURFACES | -1,114,299 | "Update Surfaces"
ZONE_NAME | -1,114,300 | "Name"
ZONE_AREA | -1,114,301 | "Occupied Area"
ZONE_PERIMETER | -1,114,302 | "Perimeter"
ZONE_VOLUME | -1,114,303 | "Occupied Volume"
ZONE_SERVICE_TYPE_PARAM | -1,114,304 | "Service Type"
ZONE_CALCULATED_HEATING_LOAD_PARAM | -1,114,305 | "Calculated Heating Load"
ZONE_CALCULATED_COOLING_LOAD_PARAM | -1,114,306 | "Calculated Cooling Load"
ZONE_CALCULATED_SUPPLY_AIRFLOW_PARAM | -1,114,307 | "Calculated Supply Airflow"
ZONE_HEATING_SET_POINT_PARAM | -1,114,308 | "Heating Set Point"
ZONE_COOLING_SET_POINT_PARAM | -1,114,309 | "Cooling Set Point"
ZONE_HEATING_AIR_TEMPERATURE_PARAM | -1,114,310 | "Heating Air Temperature"
ZONE_COOLING_AIR_TEMPERATURE_PARAM | -1,114,311 | "Cooling Air Temperature"
ZONE_HUMIDIFICATION_SET_POINT_PARAM | -1,114,312 | "Humidification Set Point"
ZONE_DEHUMIDIFICATION_SET_POINT_PARAM | -1,114,313 | "Dehumidification Set Point"
ZONE_OUTSIDE_AIR_PER_PERSON_PARAM | -1,114,314 | "Outdoor Air per Person"
ZONE_OUTSIDE_AIR_PER_AREA_PARAM | -1,114,315 | "Outdoor Air per Area"
ZONE_OA_RATE_PER_ACH_PARAM | -1,114,316 | "Outdoor Air Rate / Air Changes per Hour"
ZONE_LEVEL_ID | -1,114,317 | "Level"
ZONE_CALCULATED_HEATING_LOAD_PER_AREA_PARAM | -1,114,318 | "Calculated Heating Load per area"
ZONE_CALCULATED_COOLING_LOAD_PER_AREA_PARAM | -1,114,319 | "Calculated Cooling Load per area"
ZONE_CALCULATED_SUPPLY_AIRFLOW_PER_AREA_PARAM | -1,114,320 | "Calculated Supply Airflow per area"
ROOM_CALCULATED_HEATING_LOAD_PER_AREA_PARAM | -1,114,321 | "Calculated Heating Load per area"
ROOM_CALCULATED_COOLING_LOAD_PER_AREA_PARAM | -1,114,322 | "Calculated Cooling Load per area"
ROOM_CALCULATED_SUPPLY_AIRFLOW_PER_AREA_PARAM | -1,114,323 | "Calculated Supply Airflow per area"
RBS_ENERGY_ANALYSIS_PROJECT_PHASE_PARAM | -1,114,324 | "Project Phase"
ZONE_PHASE_ID | -1,114,325 | "Phase Id"
ZONE_PHASE | -1,114,326 | "Phase"
SPACE_ASSOC_ROOM_NAME | -1,114,327 | "Room Name"
SPACE_ASSOC_ROOM_NUMBER | -1,114,328 | "Room Number"
SPACE_IS_OCCUPIABLE | -1,114,329 | "Occupiable"
SPACE_IS_PLENUM | -1,114,330 | "Plenum"
ZONE_VOLUME_GROSS | -1,114,331 | "Gross Volume"
ZONE_AREA_GROSS | -1,114,332 | "Gross Area"
RBS_ENERGY_ANALYSIS_SLIVER_SPACE_TOLERANCE | -1,114,333 | "Sliver Space Tolerance"
ZONE_HEATING_INFORMATION_PARAM | -1,114,334 | "Heating Information"
ZONE_COOLING_INFORMATION_PARAM | -1,114,335 | "Cooling Information"
ZONE_OUTDOOR_AIR_INFORMATION_PARAM | -1,114,336 | "Outdoor Air Information"
ZONE_USE_HUMIDIFICATION_SETPOINT_PARAM | -1,114,337 | "Use Humidification Set Point"
ZONE_USE_DEHUMIDIFICATION_SETPOINT_PARAM | -1,114,338 | "Use Dehumidification Set Point"
ZONE_USE_OUTSIDE_AIR_PER_PERSON_PARAM | -1,114,339 | "Use Outside Air Per Person"
ZONE_USE_OUTSIDE_AIR_PER_AREA_PARAM | -1,114,340 | "Use Outside Air Per Area"
ZONE_USE_AIR_CHANGES_PER_HOUR_PARAM | -1,114,341 | "Use Air Changes Per Hour"
ZONE_CALCULATED_AREA_PER_HEATING_LOAD_PARAM | -1,114,342 | "Calculated Area per Heating Load"
ZONE_CALCULATED_AREA_PER_COOLING_LOAD_PARAM | -1,114,343 | "Calculated Area per Cooling Load"
ZONE_COIL_BYPASS_PERCENTAGE_PARAM | -1,114,344 | "Coil Bypass"
ZONE_AIR_VOLUME_CALCULATION_TYPE_PARAM | -1,114,345 | "Air Volume Calculation Type"
SPACE_CARPETING_PARAM | -1,114,347 | "Carpeting"
SPACE_INFILTRATION_PARAM | -1,114,348 | "Infiltration Airflow per area"
SPACE_OCCUPANCY_SCHEDULE_PARAM | -1,114,349 | "Occupancy Schedule"
SPACE_LIGHTING_SCHEDULE_PARAM | -1,114,350 | "Lighting Schedule"
SPACE_POWER_SCHEDULE_PARAM | -1,114,351 | "Power Schedule"
SPACE_ELEC_EQUIPMENT_RADIANT_PERCENTAGE_PARAM | -1,114,353 | "Electrical Equipment Radiant"
SPACE_PEOPLE_ACTIVITY_LEVEL_PARAM | -1,114,354 | "People Activity Level"
BUILDING_OPENING_TIME_PARAM | -1,114,355 | "Opening Time"
BUILDING_CLOSING_TIME_PARAM | -1,114,356 | "Closing Time"
BUILDING_UNOCCUPIED_COOLING_SET_POINT_PARAM | -1,114,357 | "Unoccupied Cooling Set Point"
RBS_INSULATION_THICKNESS_FOR_DUCT | -1,114,358 | "Insulation Thickness"
RBS_INSULATION_THICKNESS_FOR_PIPE | -1,114,359 | "Insulation Thickness"
RBS_LINING_THICKNESS_FOR_DUCT | -1,114,360 | "Lining Thickness"
RBS_ENERGY_ANALYSIS_VIEW_BUILDING_SHELL_MODE | -1,114,361 | "Show Analytical Building Shell"
RBS_ENERGY_ANALYSIS_VIEW_OUTER_SHELL_MODE | -1,114,362 | "Show Analytical Space Shells"
RBS_ENERGY_ANALYSIS_VIEW_INNER_SHELL_MODE | -1,114,363 | "Show Inner Space Shells"
RBS_ENERGY_ANALYSIS_VIEW_SURFACES_MODE | -1,114,364 | "Show Surfaces"
RBS_ENERGY_ANALYSIS_VIEW_TRANSPARENT_MODE | -1,114,365 | "Show Surfaces Transparent"
RBS_ENERGY_ANALYSIS_VIEW_SHADING_SURFACES_MODE | -1,114,366 | "Show Shading Surfaces"
RBS_ENERGY_ANALYSIS_VIEW_RBE_MODE | -1,114,367 | "Show Room Bounding Elements Dimmed and Underlay"
RBS_ENERGY_ANALYSIS_VIEW_COORD_AXIS_MODE | -1,114,368 | "Show a Coordinate System Symbol for each Surface"
RBS_HVACLOAD_ROOF_AREA_PARAM | -1,114,369 | "Roof Area"
RBS_HVACLOAD_WALL_AREA_PARAM | -1,114,370 | "Wall Area"
RBS_HVACLOAD_WINDOW_AREA_PARAM | -1,114,371 | "Window Area"
RBS_HVACLOAD_DOOR_AREA_PARAM | -1,114,372 | "Door Area"
RBS_HVACLOAD_FLOOR_AREA_PARAM | -1,114,373 | "Floor Area"
RBS_HVACLOAD_PARTITION_AREA_PARAM | -1,114,374 | "Partition Area"
RBS_HVACLOAD_SKYLIGHT_AREA_PARAM | -1,114,375 | "Skylight Area"
RBS_HVACLOAD_ROOF_COOLING_LOAD_PARAM | -1,114,376 | "Roof Cooling Load"
RBS_HVACLOAD_WALL_COOLING_LOAD_PARAM | -1,114,377 | "Wall Cooling Load"
RBS_HVACLOAD_WINDOW_COOLING_LOAD_PARAM | -1,114,378 | "Window Cooling Load"
RBS_HVACLOAD_DOOR_COOLING_LOAD_PARAM | -1,114,379 | "Door Cooling Load"
RBS_HVACLOAD_PARTITION_COOLING_LOAD_PARAM | -1,114,380 | "Partition Cooling Load"
RBS_HVACLOAD_SKYLIGHT_COOLING_LOAD_PARAM | -1,114,381 | "Skylight Cooling Load"
RBS_HVACLOAD_PLENUM_COOLING_LOAD_PARAM | -1,114,382 | "Plenum Cooling Load"
RBS_ENERGY_ANALYSIS_EXPORT_GBXML_DEFAULTS_PARAM | -1,114,383 | "Export Default Values"
SPACE_ZONE_NAME | -1,114,384 | "Zone"
RBS_ENERGY_ANALYSIS_EXPORT_COMPLEXITY_PARAM | -1,114,385 | "Export Complexity"
RBS_ENERGY_ANALYSIS_EXPORT_CATEGORY_PARAM | -1,114,386 | "Export Category"
RBS_CURVETYPE_DEFAULT_ELBOWUP_PARAM | -1,114,387 | "Vertical Inside Bend"
RBS_CURVETYPE_DEFAULT_ELBOWDOWN_PARAM | -1,114,388 | "Vertical Outside Bend"
RBS_CURVETYPE_DEFAULT_TEEUP_PARAM | -1,114,389 | "Tee Up"
RBS_CURVETYPE_DEFAULT_TEEDOWN_PARAM | -1,114,390 | "Tee Down"
RBS_CURVETYPE_MULTISHAPE_TRANSITION_RECTOVAL_PARAM | -1,114,391 | "Multi Shape Transition Rect to Oval"
RBS_CURVETYPE_MULTISHAPE_TRANSITION_OVALROUND_PARAM | -1,114,392 | "Multi Shape Transition Oval to Round"
RBS_CURVETYPE_DEFAULT_HORIZONTAL_BEND_PARAM | -1,114,393 | "Horizontal Bend"
RBS_CURVETYPE_DEFAULT_BEND_PARAM | -1,114,394 | "Bend"
GRID_BANK_ROW_NUM | -1,114,395 | "Row"
GRID_BANK_COL_NUM | -1,114,396 | "Column"
GRID_BANK_ROW_HEIGHT | -1,114,397 | "Row Distance"
GRID_BANK_COL_WIDTH | -1,114,398 | "Column Distance"
ROOM_CALCULATION_POINT | -1,114,399 | "Room Calculation Point"
RBS_GBXML_OPENING_TYPE | -1,114,400 | "Opening Type"
ZONE_SPACE_OUTDOOR_AIR_OPTION_PARAM | -1,114,700 | "Space Outdoor Air Option"
ZONE_CALCULATED_HYDRONIC_HEATINGFLOW_PARAM | -1,114,701 | "Calculated Hydronic Heating Flow"
ZONE_CALCULATED_HYDRONIC_COOLINGFLOW_PARAM | -1,114,702 | "Calculated Hydronic Cooling Flow"
SYSTEM_ZONE_LEVEL_ID | -1,114,705 | "Level"
ZONE_LEVEL_OFFSET | -1,114,706 | "Level Offset"
ZONE_LEVEL_OFFSET_TOP | -1,114,707 | "Top Offset"
SPACE_HEATING_SET_POINT | -1,114,708 | "Heating Set Point"
SPACE_COOLING_SET_POINT | -1,114,709 | "Cooling Set Point"
SPACE_HUMIDIFICATION_SET_POINT | -1,114,710 | "Humidification Set Point"
SPACE_DEHUMIDIFICATION_SET_POINT | -1,114,711 | "Dehumidification Set Point"
PEAK_HEATING_LOAD_PARAM | -1,114,800 | "Peak Heating Load"
PEAK_COOLING_LOAD_PARAM | -1,114,801 | "Peak Cooling Load"
SPACE_AIRFLOW_PER_AREA_PARAM | -1,114,802 | "Airflow per area"
SPACE_AREA_PER_PERSON_PARAM | -1,114,803 | "Area per person"
SPACE_PEOPLE_SENSIBLE_HEAT_GAIN_PER_PERSON_PARAM | -1,114,804 | "Sensible Heat Gain per person"
SPACE_PEOPLE_LATENT_HEAT_GAIN_PER_PERSON_PARAM | -1,114,805 | "Latent Heat Gain per person"
SPACE_LIGHTING_LOAD_PER_AREA_PARAM | -1,114,806 | "Lighting Load per area"
SPACE_POWER_LOAD_PER_AREA_PARAM | -1,114,807 | "Power Load per area"
SPACE_PEOPLE_LOAD_PARAM | -1,114,808 | "Occupancy Load"
SPACE_LIGHTING_LOAD_PARAM | -1,114,809 | "Lighting Load"
SPACE_POWER_LOAD_PARAM | -1,114,810 | "Power Load"
SPACE_AIR_CHANGES_PER_HOUR | -1,114,811 | "Air Changes per Hour"
SPACE_OUTDOOR_AIRFLOW_PER_AREA | -1,114,812 | "Outdoor Airflow per area"
SPACE_OUTDOOR_AIRFLOW_PER_PERSON | -1,114,813 | "Outdoor Airflow per person"
SPACE_OUTDOOR_AIRFLOW | -1,114,814 | "Outdoor Airflow"
SPACE_INFILTRATION_AIRFLOW_PER_AREA | -1,114,815 | "Infiltration Airflow per area"
SPACE_INFILTRATION_AIRFLOW | -1,114,816 | "Infiltration Airflow"
SPACE_REFERENCE_LEVEL_PARAM | -1,114,817 | "Reference Level"
PEAK_AIRFLOW_PARAM | -1,114,818 | "Peak Airflow"
PEAK_LATENT_COOLING_LOAD | -1,114,819 | "Peak Latent Cooling Load"
SPACE_AREA | -1,114,820 | "Area"
SPACE_VOLUME | -1,114,821 | "Volume"
ENERGY_ANALYSIS_PROJECT_PHASE | -1,114,822 | "Phase"
SYSTEMS_ANALYSIS_REPORT_STYLE | -1,114,823 | "Report Style"
SYSTEMS_ANALYSIS_REPORT_FOLDER | -1,114,824 | "Reports Folder Path"
SPACE_NAME_PARAM | -1,114,825 | "Name"
ANALYTICAL_SPACE | -1,114,826 | "Analytical Space"
ANALYTICAL_ADJACENT_SPACE | -1,114,827 | "Adjacent Analytical Space"
AZIMUTH | -1,114,828 | "Azimuth"
TILT | -1,114,829 | "Tilt"
ANALYTIC_CONSTRUCTION | -1,114,830 | "Analytic Construction"
CONSTRUCTION_NAME | -1,114,831 | "Name"
WINDOW_TYPE_NAME | -1,114,832 | "Name"
ORIGINATING_ELEMENT_NAME | -1,114,833 | "Originating Element"
SURFACE_NAME | -1,114,834 | "Name"
ANALYTICAL_SURFACE | -1,114,835 | "Analytical Surface"
SPACE_TYPE_GBXML | -1,114,836 | "Space Type (gbXML)"
SPACE_CONDITION_TYPE | -1,114,837 | "Condition Type"
SPACE_NUMBER_OF_PEOPLE | -1,114,838 | "Number of People"
ANALYTICAL_ZONE | -1,114,839 | "Analytical Zone"
ZONE_AIR_CHANGES_PER_HOUR | -1,114,840 | "Air Changes per Hour"
ZONE_OUTSIDE_AIR_FLOW_PER_AREA | -1,114,841 | "Outside Air Flow per Area"
ZONE_OUTSIDE_AIR_FLOW_PER_PERSON | -1,114,842 | "Outside Air Flow per Person"
ZONE_DESIGN_HEAT_TEMPERATURE | -1,114,843 | "Design Temperature for Heating"
ZONE_DESIGN_COOL_TEMPERATURE | -1,114,844 | "Design Temperature for Cooling"
ANALYTICAL_ZONE_NAME | -1,114,845 | "Name"
CONSTRUCTION_IS_SCHEMATIC | -1,114,846 | "Schematic"
SPACE_NUMBER_PARAM | -1,114,847 | "Number"
SPACE_COMPOSEDNAME_PARAM | -1,114,848 | "Composed Name"
THERMAL_MATERIAL_NAME | -1,114,849 | "Name"
THERMAL_MATERIAL_DESCRIPTION | -1,114,850 | "Description"
THERMAL_MATERIAL_THICKNESS | -1,114,851 | "Thickness"
THERMAL_MATERIAL_CONDUCTIVITY | -1,114,852 | "Thermal Conductivity"
THERMAL_MATERIAL_DENSITY | -1,114,853 | "Density"
THERMAL_MATERIAL_SPECIFIC_HEAT_CAPACITY | -1,114,854 | "Specific Heat Capacity"
WINDOWTYPE_IS_SCHEMATIC | -1,114,855 | "Schematic"
STRUCTURAL_CONNECTION_EDIT_RANGES_OF_APPLICABILITY | -1,115,520 | "Modify Ranges of applicability"
RBS_PART_TYPE | -1,115,958 | "Part Type"
PIPING_CONNECTION_TYPE | -1,115,973 | "Connection Type"
PIPING_GENDER_TYPE | -1,115,974 | "Gender Type"
ARC_ELEM_FIX_KEEP_CONCENTRIC | -1,123,512 | "Keep Concentric"
USE_3D_SNAPPING | -1,123,513 | "3D Snapping"
CONNECTOR_PROFILE_TYPE | -1,133,400 | "Shape"
CONNECTOR_RADIUS | -1,133,401 | "Radius"
CONNECTOR_WIDTH | -1,133,403 | "Width"
CONNECTOR_HEIGHT | -1,133,404 | "Height"
CONNECTOR_VISIBLE_SIZE | -1,133,405 | "Size on screen"
CONNECTOR_INDEX | -1,133,406 | "Index"
RBS_DUCT_CONNECTOR_SYSTEM_CLASSIFICATION_PARAM | -1,133,408 | "System Classification"
CONNECTOR_ANGLE | -1,133,409 | "Angle"
RBS_PIPE_CONNECTOR_SYSTEM_CLASSIFICATION_PARAM | -1,133,410 | "System Classification"
CONNECTOR_REFERENCE_INDEX | -1,133,411 | "Link Connector Index"
RBS_CONNECTOR_ISPRIMARY | -1,133,412 | "Primary Connector"
RBS_CABLETRAYCONDUIT_SYSTEM_TYPE | -1,133,413 | "System Type"
RBS_CABLETRAYCONDUIT_CONNECTORELEM_TYPE | -1,133,414 | "Connector Type"
CONNECTOR_DIAMETER | -1,133,415 | "Diameter"
CONNECTOR_INSIDE_DIAMETER | -1,133,416 | "Inside Diameter"
DUCT_TERMINAL_ENGAGEMENT_LENGTH | -1,133,417 | "Engagement Length"
MEP_SYSTEM_FILL_GRAPHICS_OVERRIDES_PARAM | -1,133,418 | "Fill Pattern Graphics Overrides"
GROUP_LEVEL | -1,133,500 | "Reference Level"
GROUP_OFFSET_FROM_LEVEL | -1,133,501 | "Origin Level Offset"
GROUP_ALLOWED_VIEW_TYPES | -1,133,502 | "Allowed View Types"
GROUP_ATTACHED_PARENT_NAME | -1,133,503 | "Attached to"
OPTION_SET_NAME | -1,133,600 | "Name"
PRIMARY_OPTION_ID | -1,133,601 | "Primary Option Id"
OPTION_NAME | -1,133,602 | "Name"
OPTION_SET_ID | -1,133,603 | "Design Option Set Id"
LEGEND_COMPONENT | -1,133,750 | "Component Type"
LEGEND_COMPONENT_VIEW | -1,133,751 | "View Direction"
LEGEND_COMPONENT_LENGTH | -1,133,752 | "Host Length"
LEGEND_COMPONENT_DETAIL_LEVEL | -1,133,753 | "Detail Level"
VIEW_SCHEMA_SETTING_FOR_SYSTEM_TEMPLATE | -1,133,900 | "System Color Schemes"
MARKUPS_MODIFIED | -1,133,901 | "Modified"
MARKUPS_CREATED | -1,133,902 | "Created"
MARKUPS_CREATOR | -1,133,903 | "Creator"
MARKUPS_LABEL | -1,133,904 | "Label"
MARKUPS_STATUS | -1,133,905 | "Status"
MARKUPS_HISTORY | -1,133,906 | "History"
MARKUPS_NOTES | -1,133,907 | "Notes"
MARKUPS_PRIVATE | -1,133,908 | "Private"
VIEW_TYPE_SCHEDULES | -1,139,997 | "Type"
VIEW_FAMILY_AND_TYPE_SCHEDULES | -1,139,998 | "Family and Type"
VIEW_FAMILY_SCHEDULES | -1,139,999 | "Family"
RBS_CONNECTOR_DESCRIPTION | -1,140,000 | "Connector Description"
RBS_ELEC_NUMBER_OF_POLES | -1,140,001 | "Number of Poles"
RBS_ELEC_VOLTAGE | -1,140,002 | "Voltage"
RBS_ELEC_BALANCED_LOAD | -1,140,003 | "Balanced Load"
RBS_ELEC_APPARENT_LOAD | -1,140,004 | "Apparent Power"
RBS_ELEC_APPARENT_LOAD_PHASE1 | -1,140,005 | "Apparent Power Phase 1"
RBS_ELEC_APPARENT_LOAD_PHASE2 | -1,140,006 | "Apparent Power Phase 2"
RBS_ELEC_APPARENT_LOAD_PHASE3 | -1,140,007 | "Apparent Power Phase 3"
RBS_ELEC_POWER_FACTOR | -1,140,008 | "Power Factor"
RBS_ELEC_POWER_FACTOR_STATE | -1,140,009 | "Power Factor State"
RBS_ELEC_TRUE_LOAD | -1,140,010 | "True Power"
RBS_ELEC_TRUE_LOAD_PHASE1 | -1,140,011 | "True Power Phase 1"
RBS_ELEC_TRUE_LOAD_PHASE2 | -1,140,012 | "True Power Phase 2"
RBS_ELEC_TRUE_LOAD_PHASE3 | -1,140,013 | "True Power Phase 3"
RBS_ELEC_LOAD_CLASSIFICATION | -1,140,014 | "Load Classification"
RBS_ELEC_CIRCUIT_TYPE | -1,140,018 | "System Type"
RBS_ELEC_AMBIENT_TEMPERATURE | -1,140,020 | "Ambient Temperature"
RBS_WIRE_CONDUIT_TYPE_PARAM | -1,140,021 | "Conduit Type"
RBS_WIRE_NEUTRAL_MODE_PARAM | -1,140,022 | "Neutral Size"
RBS_WIRE_NEUTRAL_INCLUDED_IN_BALANCED_LOAD_PARAM | -1,140,023 | "Neutral Included in Balanced Load"
RBS_WIRE_NEUTRAL_MULTIPLIER_PARAM | -1,140,024 | "Neutral Multiplier"
RBS_WIRE_MAX_CONDUCTOR_SIZE_PARAM | -1,140,025 | "Max Size"
RBS_WIRE_INSULATION_PARAM | -1,140,026 | "Insulation"
RBS_WIRE_TEMPERATURE_RATING_PARAM | -1,140,027 | "Temperature Rating"
RBS_WIRE_MATERIAL_PARAM | -1,140,028 | "Material"
RBS_ELEC_ROOM_LIGHTING_CALC_WORKPLANE | -1,140,029 | "Lighting Calculation Workplane"
RBS_ELEC_ROOM_REFLECTIVITY_CEILING | -1,140,030 | "Ceiling Reflectance"
RBS_ELEC_ROOM_REFLECTIVITY_WALLS | -1,140,031 | "Wall Reflectance"
RBS_ELEC_ROOM_REFLECTIVITY_FLOOR | -1,140,032 | "Floor Reflectance"
RBS_ELEC_ROOM_AVERAGE_ILLUMINATION | -1,140,033 | "Average Estimated Illumination"
FBX_LIGHT_PHOTOMETRIC_FILE | -1,140,034 | "Photometric Web File"
RBS_ELEC_ROOM_CAVITY_RATIO | -1,140,035 | "Room Cavity Ratio"
RBS_ELEC_CIRCUIT_WIRE_TYPE_PARAM | -1,140,036 | "Wire Type"
RBS_ELEC_CIRCUIT_WIRE_SIZE_PARAM | -1,140,037 | "Wire Size"
RBS_ELEC_CIRCUIT_RATING_PARAM | -1,140,038 | "Rating"
RBS_ELEC_CIRCUIT_LENGTH_PARAM | -1,140,039 | "Length"
RBS_ELEC_CALC_COEFFICIENT_UTILIZATION | -1,140,040 | "Calculate Coefficient of Utilization"
RBS_ELEC_VOLTAGE_DROP_PARAM | -1,140,041 | "Voltage Drop"
RBS_ELEC_APPARENT_CURRENT_PHASEC_PARAM | -1,140,042 | "Apparent Current Phase C"
RBS_ELEC_APPARENT_CURRENT_PHASEB_PARAM | -1,140,043 | "Apparent Current Phase B"
RBS_ELEC_APPARENT_CURRENT_PHASEA_PARAM | -1,140,044 | "Apparent Current Phase A"
RBS_ELEC_APPARENT_CURRENT_PARAM | -1,140,045 | "Apparent Current"
RBS_ELEC_TRUE_CURRENT_PHASEC_PARAM | -1,140,046 | "True Current Phase C"
RBS_ELEC_TRUE_CURRENT_PHASEB_PARAM | -1,140,047 | "True Current Phase B"
RBS_ELEC_TRUE_CURRENT_PHASEA_PARAM | -1,140,048 | "True Current Phase A"
RBS_ELEC_TRUE_CURRENT_PARAM | -1,140,049 | "True Current"
RBS_ELEC_TRUE_LOAD_PHASEA | -1,140,050 | "True Power Phase A"
RBS_ELEC_TRUE_LOAD_PHASEB | -1,140,051 | "True Power Phase B"
RBS_ELEC_TRUE_LOAD_PHASEC | -1,140,052 | "True Power Phase C"
RBS_ELEC_APPARENT_LOAD_PHASEA | -1,140,053 | "Apparent Power Phase A"
RBS_ELEC_APPARENT_LOAD_PHASEB | -1,140,054 | "Apparent Power Phase B"
RBS_ELEC_APPARENT_LOAD_PHASEC | -1,140,055 | "Apparent Power Phase C"
RBS_VOLTAGETYPE_MAXVOLTAGE_PARAM | -1,140,056 | "Maximum Voltage"
RBS_VOLTAGETYPE_MINVOLTAGE_PARAM | -1,140,057 | "Minimum Voltage"
RBS_VOLTAGETYPE_VOLTAGE_PARAM | -1,140,058 | "Actual Voltage"
RBS_DISTRIBUTIONSYS_NUMWIRES_PARAM | -1,140,059 | "Wires"
RBS_DISTRIBUTIONSYS_CONFIG_PARAM | -1,140,060 | "Configuration"
RBS_DISTRIBUTIONSYS_PHASE_PARAM | -1,140,061 | "Phase"
RBS_DISTRIBUTIONSYS_VLG_PARAM | -1,140,062 | "Line to Ground Voltage"
RBS_DISTRIBUTIONSYS_VLL_PARAM | -1,140,063 | "Line to Line Voltage"
RBS_FAMILY_CONTENT_DISTRIBUTION_SYSTEM | -1,140,064 | "Distribution System"
RBS_ELEC_DEMANDFACTOR_DEMANDLOAD_PARAM | -1,140,065 | "Demand Apparent Power"
RBS_ELEC_DEMANDFACTOR_LOAD_PARAM | -1,140,066 | "Connected Apparent Power"
RBS_ELEC_DEMANDFACTOR_LOADCLASSIFICATION_PARAM | -1,140,067 | "Load Classification"
RBS_ELEC_PANEL_TOTALLOAD_PARAM | -1,140,068 | "Total Connected Apparent Power"
RBS_ELEC_PANEL_TOTALESTLOAD_PARAM | -1,140,069 | "Total Demand Apparent Power"
RBS_ELEC_PANEL_TOTALLOAD_OTHER_PARAM | -1,140,070 | "Other Total Connected Apparent Power"
RBS_ELEC_PANEL_TOTALESTLOAD_OTHER_PARAM | -1,140,071 | "Other Total Demand Apparent Power"
RBS_ELEC_PANEL_TOTALLOAD_POWER_PARAM | -1,140,072 | "Power Total Connected Apparent Power"
RBS_ELEC_PANEL_TOTALESTLOAD_POWER_PARAM | -1,140,073 | "Power Total Demand Apparent Power"
RBS_ELEC_PANEL_TOTALLOAD_LIGHT_PARAM | -1,140,074 | "Lighting Total Connected Apparent Power"
RBS_ELEC_PANEL_TOTALESTLOAD_LIGHT_PARAM | -1,140,075 | "Lighting Total Demand Apparent Power"
RBS_ELEC_PANEL_TOTALLOAD_HVAC_PARAM | -1,140,076 | "HVAC Total Connected Apparent Power"
RBS_ELEC_PANEL_TOTALESTLOAD_HVAC_PARAM | -1,140,077 | "HVAC Total Demand Apparent Power"
RBS_ELEC_PANEL_NAME | -1,140,078 | "Panel Name"
RBS_ELEC_MAX_POLE_BREAKERS | -1,140,079 | "Max Number of Single Pole Breakers"
RBS_ELEC_SHORT_CIRCUIT_RATING | -1,140,080 | "Short Circuit Rating Comments"
RBS_ELEC_MOUNTING | -1,140,081 | "Mounting"
RBS_ELEC_MAINS | -1,140,082 | "Mains"
RBS_ELEC_ENCLOSURE | -1,140,083 | "Enclosure"
RBS_ELEC_MODIFICATIONS | -1,140,084 | "Modifications"
RBS_ELEC_CIRCUIT_PREFIX | -1,140,085 | "Circuit Prefix"
RBS_ELEC_CIRCUIT_PREFIX_SEPARATOR | -1,140,086 | "Circuit Prefix Separator"
RBS_ELEC_CIRCUIT_NAMING | -1,140,087 | "Circuit Naming"
RBS_FAMILY_CONTENT_SECONDARY_DISTRIBSYS | -1,140,088 | "Secondary Distribution System"
RBS_ELEC_CIRCUIT_NAME | -1,140,089 | "Load Name"
RBS_ELEC_WIRE_SHARE_GROUND | -1,140,090 | "Share Ground Conductor"
RBS_ELEC_WIRE_SHARE_NEUTRAL | -1,140,091 | "Share Neutral Conductor"
RBS_ELEC_WIRE_GROUND_ADJUSTMENT | -1,140,092 | "Ground Conductors"
RBS_ELEC_WIRE_NEUTRAL_ADJUSTMENT | -1,140,093 | "Neutral Conductors"
RBS_ELEC_WIRE_HOT_ADJUSTMENT | -1,140,094 | "Hot Conductors"
RBS_ELEC_WIRE_ELEVATION | -1,140,096 | "Elevation"
RBS_ELEC_WIRE_TYPE | -1,140,097 | "Type"
RBS_ELEC_CIRCUIT_WIRE_NUM_GROUNDS_PARAM | -1,140,098 | "# of Ground Conductors"
RBS_ELEC_CIRCUIT_WIRE_NUM_NEUTRALS_PARAM | -1,140,099 | "# of Neutral Conductors"
RBS_ELEC_CIRCUIT_WIRE_NUM_HOTS_PARAM | -1,140,100 | "# of Hot Conductors"
RBS_ELEC_CIRCUIT_WIRE_NUM_RUNS_PARAM | -1,140,101 | "# of Runs"
RBS_ELEC_WIRE_CIRCUITS | -1,140,102 | "Circuits"
RBS_ELEC_CIRCUIT_NUMBER | -1,140,103 | "Circuit Number"
RBS_ELEC_CIRCUIT_PANEL_PARAM | -1,140,104 | "Panel"
RBS_ELEC_WIRE_TICKMARK_STATE | -1,140,106 | "Tick Marks"
RBS_WIRE_NUM_CONDUCTORS_PARAM | -1,140,107 | "Number of Conductors"
RBS_WIRE_CIRCUIT_LOAD_NAME | -1,140,108 | "Circuit Load Name"
RBS_WIRE_CIRCUIT_DESCRIPTION | -1,140,109 | "Circuit Description"
RBS_ELEC_SWITCH_ID_PARAM | -1,140,110 | "Switch ID"
RBS_CABLETRAY_THICKNESS | -1,140,111 | "Thickness"
RBS_CABLETRAY_RUNGSPACE | -1,140,112 | "Rung Space"
RBS_CABLETRAY_RUNGWIDTH | -1,140,113 | "Rung Width"
RBS_CABLETRAY_RUNGHEIGHT | -1,140,114 | "Rung Height"
RBS_CABLETRAY_BENDRADIUS | -1,140,115 | "Bend Radius"
RBS_CONDUIT_BENDRADIUS | -1,140,116 | "Bend Radius"
RBS_CONDUIT_TRADESIZE | -1,140,117 | "Conduit Size Lookup"
CONDUIT_STANDARD_TYPE_PARAM | -1,140,118 | "Standard"
CABLETRAY_MINBENDMULTIPLIER_PARAM | -1,140,119 | "Bend Radius Multiplier"
CIRCUIT_LOAD_CLASSIFICATION_PARAM | -1,140,120 | "Load Classification"
RBS_CABLETRAY_HEIGHT_PARAM | -1,140,121 | "Height"
RBS_CABLETRAY_WIDTH_PARAM | -1,140,122 | "Width"
RBS_CONDUIT_DIAMETER_PARAM | -1,140,123 | "Diameter(Trade Size)"
RBS_CTC_TOP_ELEVATION | -1,140,124 | "Upper End Top Elevation"
RBS_CTC_BOTTOM_ELEVATION | -1,140,125 | "Lower End Bottom Elevation"
RBS_CONDUIT_INNER_DIAM_PARAM | -1,140,126 | "Inside Diameter"
RBS_CONDUIT_OUTER_DIAM_PARAM | -1,140,127 | "Outside Diameter"
RBS_CTC_SERVICE_TYPE | -1,140,128 | "Service Type"
RBS_CABLETRAYCONDUIT_BENDORFITTING | -1,140,129 | "Bend or Fitting"
RBS_CABLETRAY_SHAPETYPE | -1,140,130 | "Shape"
RBS_LOAD_SUB_CLASSIFICATION_MOTOR | -1,140,131 | "Load Sub-Classification Motor"
RBS_CABLETRAYCONDUITRUN_LENGTH_PARAM | -1,140,132 | "Length"
RBS_CABLETRAYRUN_HEIGHT_PARAM | -1,140,133 | "Height"
RBS_CABLETRAYRUN_WIDTH_PARAM | -1,140,134 | "Width"
RBS_CONDUITRUN_DIAMETER_PARAM | -1,140,135 | "Diameter(Trade Size)"
RBS_CONDUITRUN_INNER_DIAM_PARAM | -1,140,136 | "Inside Diameter"
RBS_CONDUITRUN_OUTER_DIAM_PARAM | -1,140,137 | "Outside Diameter"
RBS_ELEC_PANEL_FEED_PARAM | -1,140,138 | "Feed"
RBS_ELEC_PANEL_MAINSTYPE_PARAM | -1,140,139 | "Mains Type"
RBS_ELEC_PANEL_MCB_RATING_PARAM | -1,140,140 | "MCB Rating"
RBS_ELEC_PANEL_SUPPLY_FROM_PARAM | -1,140,141 | "Supply From"
RBS_ELEC_PANEL_SUBFEED_LUGS_PARAM | -1,140,142 | "SubFeed Lugs"
RBS_ELEC_PANEL_BUSSING_PARAM | -1,140,143 | "Bussing"
RBS_ELEC_PANEL_GROUND_BUS_PARAM | -1,140,144 | "Ground Bus"
RBS_ELEC_PANEL_NEUTRAL_BUS_PARAM | -1,140,145 | "Neutral Bus"
RBS_ELEC_PANEL_NEUTRAL_RATING_PARAM | -1,140,146 | "Neutral Rating"
RBS_ELEC_PANEL_NUMPHASES_PARAM | -1,140,147 | "Number of Phases"
RBS_ELEC_PANEL_NUMWIRES_PARAM | -1,140,148 | "Number of Wires"
RBS_ELEC_PANEL_SCHEDULE_HEADER_NOTES_PARAM | -1,140,149 | "Schedule Header Notes"
RBS_ELEC_PANEL_SCHEDULE_FOOTER_NOTES_PARAM | -1,140,150 | "Schedule Footer Notes"
RBS_ELEC_PANEL_TOTAL_DEMAND_FACTOR_PARAM | -1,140,151 | "Total Demand Factor"
RBS_ELEC_PANEL_TOTAL_CONNECTED_CURRENT_PARAM | -1,140,152 | "Total Connected Current"
RBS_ELEC_PANEL_TOTAL_DEMAND_CURRENT_PARAM | -1,140,153 | "Total Estimated Demand Current"
RBS_ELEC_CIRCUIT_FRAME_PARAM | -1,140,154 | "Frame"
RBS_ELEC_CIRCUIT_NUMBER_OF_ELEMENTS_PARAM | -1,140,155 | "Number of Elements"
RBS_ELEC_CIRCUIT_NOTES_PARAM | -1,140,156 | "Schedule Circuit Notes"
RBS_ELEC_LOADSUMMARY_LOADCLASSIFICATION_PARAM | -1,140,157 | "Load Classification"
RBS_ELEC_LOADSUMMARY_CONNECTED_LOAD_PARAM | -1,140,158 | "Connected Apparent Power"
RBS_ELEC_LOADSUMMARY_DEMAND_FACTOR_PARAM | -1,140,159 | "Demand Factor"
RBS_ELEC_LOADSUMMARY_DEMAND_LOAD_PARAM | -1,140,160 | "Demand Apparent Power"
RBS_ELEC_LOADSUMMARY_CONNECTED_CURRENT_PARAM | -1,140,161 | "Connected Current"
RBS_ELEC_LOADSUMMARY_DEMAND_CURRENT_PARAM | -1,140,162 | "Estimated Demand Current"
RBS_ELEC_LOADSUMMARY_DEMAND_FACTOR_RULE_PARAM | -1,140,163 | "Description"
RBS_ELEC_PANEL_CURRENT_PHASEA_PARAM | -1,140,164 | "Current Phase A"
RBS_ELEC_PANEL_CURRENT_PHASEB_PARAM | -1,140,165 | "Current Phase B"
RBS_ELEC_PANEL_CURRENT_PHASEC_PARAM | -1,140,166 | "Current Phase C"
TEMPLATE_NAME | -1,140,167 | "Template"
PANEL_SCHEDULE_NAME | -1,140,168 | "Panel Schedule Name"
RBS_ELEC_PANEL_LOCATION_PARAM | -1,140,169 | "Location"
RBS_ELEC_PANEL_CONFIGURATION_PARAM | -1,140,170 | "Panel Configuration"
CONNECTOR_JOINT_TYPE | -1,140,171 | "Connector Joint Type"
CONNECTOR_GENDER_TYPE | -1,140,172 | "Connector Gender Type"
RBS_ELEC_CIRCUIT_START_SLOT | -1,140,173 | "Start Slot"
RBS_ELEC_CIRCUIT_PATH_MODE_PARAM | -1,140,174 | "Path Mode"
RBS_ELEC_CIRCUIT_PATH_OFFSET_PARAM | -1,140,175 | "Offset"
RBS_ELEC_CIRCUIT_CONNECTION_TYPE_PARAM | -1,140,176 | "Connection Type"
RBS_ELEC_CIRCUIT_NAMING_INDEX | -1,140,177 | "Circuit Naming Index"
CIRCUIT_PHASE_PARAM | -1,140,178 | "Phase Label"
CIRCUIT_LOAD_CLASSIFICATION_ABBREVIATION_PARAM | -1,140,179 | "Load Classification Abbreviation"
CIRCUIT_WAYS_PARAM | -1,140,180 | "Ways"
RBS_ELEC_CIRCUIT_SLOT_INDEX | -1,140,181 | "Slot Index"
RBS_ELEC_DEMAND_LOAD_PHASEA | -1,140,182 | "Demand Apparent Power Phase A"
RBS_ELEC_DEMAND_LOAD_PHASEB | -1,140,183 | "Demand Apparent Power Phase B"
RBS_ELEC_DEMAND_LOAD_PHASEC | -1,140,184 | "Demand Apparent Power Phase C"
RBS_ELEC_DEMAND_CURRENT_PHASEA | -1,140,185 | "Demand Current Phase A"
RBS_ELEC_DEMAND_CURRENT_PHASEB | -1,140,186 | "Demand Current Phase B"
RBS_ELEC_DEMAND_CURRENT_PHASEC | -1,140,187 | "Demand Current Phase C"
RBS_PIPE_CLASS_PARAM | -1,140,200 | "Schedule/Type"
RBS_PIPE_CONNECTIONTYPE_PARAM | -1,140,201 | "Connection Type"
RBS_PIPE_MATERIAL_PARAM | -1,140,202 | "Material"
PIPE_ROUGHNESS | -1,140,204 | "Roughness"
RBS_PIPE_PRESSUREDROP_PARAM | -1,140,205 | "Pressure Drop"
RBS_PIPE_FRICTION_PARAM | -1,140,206 | "Friction"
RBS_PIPE_VELOCITY_PARAM | -1,140,207 | "Velocity"
FRICTION_FACTOR | -1,140,208 | "Friction Factor"
RBS_PIPE_FLOW_STATE_PARAM | -1,140,209 | "Flow State"
RELATIVE_ROUGHNESS | -1,140,210 | "Relative Roughness"
RBS_PIPE_REYNOLDS_NUMBER_PARAM | -1,140,211 | "Reynolds Number"
RBS_PIPE_INNER_DIAM_PARAM | -1,140,212 | "Inside Diameter"
RBS_PIPE_FLOW_PARAM | -1,140,213 | "Flow"
RBS_PIPE_FLUID_DENSITY_PARAM | -1,140,214 | "Fluid Density"
RBS_PIPE_FLUID_VISCOSITY_PARAM | -1,140,215 | "Fluid Dynamic Viscosity"
RBS_PIPE_FLUID_TEMPERATURE_PARAM | -1,140,217 | "Fluid Temperature"
RBS_PIPE_FLUID_TYPE_PARAM | -1,140,218 | "Fluid Type"
RBS_DUCT_FLOW_DIRECTION_PARAM | -1,140,219 | "Flow Direction"
RBS_DUCT_FLOW_CONFIGURATION_PARAM | -1,140,221 | "Flow Configuration"
RBS_FLOW_FACTOR_PARAM | -1,140,222 | "Flow Factor"
RBS_ADJUSTABLE_CONNECTOR | -1,140,223 | "Allow Slope Adjustments"
RBS_CURVE_SLOPE | -1,140,224 | "Slope Percentage (%)"
RBS_PIPE_DIAMETER_PARAM | -1,140,225 | "Diameter"
RBS_PIPE_ADDITIONAL_FLOW_PARAM | -1,140,226 | "Additional Flow"
RBS_PIPE_VALVE_LOSS_CVFACTOR_PARAM | -1,140,227 | "Cv Coefficient"
RBS_PIPE_FITTING_LOSS_KFACTOR_PARAM | -1,140,228 | "K Coefficient"
RBS_PIPE_FITTING_LOSS_TABLE_PARAM | -1,140,229 | "K Coefficient Table"
RBS_PIPE_FITTING_LOSS_METHOD_PARAM | -1,140,230 | "Loss Method"
RBS_PIPE_TYPE_VALVE_LOSS_CVFACTOR_PARAM | -1,140,231 | "Cv Coefficient"
RBS_PIPE_TYPE_FITTING_LOSS_KFACTOR_PARAM | -1,140,232 | "K Coefficient"
RBS_PIPE_TYPE_FITTING_LOSS_TABLE_PARAM | -1,140,233 | "K Coefficient Table"
RBS_PIPE_TYPE_FITTING_LOSS_METHOD_PARAM | -1,140,234 | "Loss Method"
RBS_PIPE_INVERT_ELEVATION | -1,140,237 | "Invert Elevation": This parameter is obsolete. It exists only for compatibility.
RBS_PIPE_OUTER_DIAMETER | -1,140,238 | "Outside Diameter"
RBS_DUCT_TOP_ELEVATION | -1,140,239 | "Upper End Top Elevation"
RBS_DUCT_BOTTOM_ELEVATION | -1,140,240 | "Lower End Bottom Elevation"
RBS_PIPE_INSULATION_THICKNESS | -1,140,241 | "Insulation Thickness"
RBS_PIPE_STATIC_PRESSURE | -1,140,242 | "Static Pressure"
RBS_PIPE_FIXTURE_UNITS_PARAM | -1,140,246 | "Fixture Units"
RBS_PIPE_FLOW_DIRECTION_PARAM | -1,140,248 | "Flow Direction"
RBS_PIPE_FLOW_CONFIGURATION_PARAM | -1,140,249 | "Flow Configuration"
RBS_PIPE_CWFU_PARAM | -1,140,250 | "CWFU"
RBS_PIPE_HWFU_PARAM | -1,140,251 | "HWFU"
RBS_PIPE_WFU_PARAM | -1,140,252 | "WFU"
RBS_PIPE_VOLUME_PARAM | -1,140,253 | "Volume"
RBS_CURVE_UTSLOPE | -1,140,254 | "Slope"
RBS_DUCT_SLOPE | -1,140,255 | "Slope"
RBS_PIPE_SLOPE | -1,140,256 | "Slope"
RBS_PIPE_SYSTEM_FIXTURE_UNIT_PARAM | -1,140,257 | "Fixture Units"
RBS_SHOW_PROFILE_TYPE | -1,140,258 | "Show Round"
MEP_PROFILE_TYPE_PARAM | -1,140,259 | "Shape"
RBS_FP_SPRINKLER_RESPONSE_PARAM | -1,140,260 | "Response"
RBS_FP_SPRINKLER_COVERAGE_PARAM | -1,140,261 | "Coverage"
RBS_FP_SPRINKLER_ORIFICE_PARAM | -1,140,262 | "Orifice"
RBS_FP_SPRINKLER_PRESSURE_CLASS_PARAM | -1,140,263 | "Pressure Class"
RBS_FP_SPRINKLER_K_FACTOR_PARAM | -1,140,264 | "K-Factor"
RBS_FP_SPRINKLER_TEMPERATURE_RATING_PARAM | -1,140,265 | "Temperature Rating"
RBS_FP_SPRINKLER_ORIFICE_SIZE_PARAM | -1,140,266 | "Orifice Size"
RBS_PARALLELCONDUITS_HORIZONTAL_NUMBER | -1,140,268 | "Horizontal Number for parallel conduits"
RBS_PARALLELCONDUITS_VERTICAL_NUMBER | -1,140,269 | "Vertical Number for parallel conduits"
RBS_PARALLELCONDUITS_HORIZONTAL_OFFSET_VALUE | -1,140,270 | "Horizontal Offset value for parallel conduits"
RBS_PARALLELCONDUITS_VERTICAL_OFFSET_VALUE | -1,140,271 | "Vertical Offset value for parallel conduits"
RBS_PARALLELPIPES_HORIZONTAL_NUMBER | -1,140,272 | "Horizontal Number for parallel pipes"
RBS_PARALLELPIPES_VERTICAL_NUMBER | -1,140,273 | "Vertical Number for parallel pipes"
RBS_PARALLELPIPES_HORIZONTAL_OFFSET_VALUE | -1,140,274 | "Horizontal Offset value for parallel pipes"
RBS_PARALLELPIPES_VERTICAL_OFFSET_VALUE | -1,140,275 | "Vertical Offset value for parallel pipes"
RBS_ROUTING_PREFERENCE_PARAM | -1,140,276 | "Routing Preferences"
RBS_PIPE_SEGMENT_PARAM | -1,140,277 | "Pipe Segment"
RBS_PIPE_JOINTTYPE_PARAM | -1,140,278 | "Connection Type"
RBS_SEGMENT_DESCRIPTION_PARAM | -1,140,279 | "Segment Description"
RBS_DUCT_ROUTING_PREFERENCE_PARAM | -1,140,280 | "Routing Preferences"
ROUTING_PREFERENCE_PARAM | -1,140,281 | "Routing Preference"
RBS_DUCT_PRESSURE_DROP | -1,140,282 | "Pressure Drop"
RBS_PIPE_SIZE_MINIMUM | -1,140,283 | "Minimum Size"
RBS_PIPE_SIZE_MAXIMUM | -1,140,284 | "Maximum Size"
PIPE_VELOCITY_PRESSURE | -1,140,285 | "Velocity Pressure"
PHY_MATERIAL_PARAM_YOUNG_MOD1 | -1,140,300 | "Young modulus X"
PHY_MATERIAL_PARAM_YOUNG_MOD2 | -1,140,301 | "Young modulus Y"
PHY_MATERIAL_PARAM_YOUNG_MOD3 | -1,140,302 | "Young modulus Z"
PHY_MATERIAL_PARAM_POISSON_MOD1 | -1,140,303 | "Poisson ratio X"
PHY_MATERIAL_PARAM_POISSON_MOD2 | -1,140,304 | "Poisson ratio Y"
PHY_MATERIAL_PARAM_POISSON_MOD3 | -1,140,305 | "Poisson ratio Z"
PHY_MATERIAL_PARAM_SHEAR_MOD1 | -1,140,306 | "Shear modulus X"
PHY_MATERIAL_PARAM_SHEAR_MOD2 | -1,140,307 | "Shear modulus Y"
PHY_MATERIAL_PARAM_SHEAR_MOD3 | -1,140,308 | "Shear modulus Z"
PHY_MATERIAL_PARAM_UNIT_WEIGHT | -1,140,309 | "Unit weight"
PHY_MATERIAL_PARAM_EXP_COEFF1 | -1,140,310 | "Thermal expansion coefficient X"
PHY_MATERIAL_PARAM_EXP_COEFF2 | -1,140,311 | "Thermal expansion coefficient Y"
PHY_MATERIAL_PARAM_EXP_COEFF3 | -1,140,312 | "Thermal expansion coefficient Z"
PHY_MATERIAL_PARAM_CONCRETE_COMPRESSION | -1,140,314 | "Concrete compression"
PHY_MATERIAL_PARAM_BENDING_REINFORCEMENT | -1,140,315 | "Bending reinforcement"
PHY_MATERIAL_PARAM_SHEAR_REINFORCEMENT | -1,140,316 | "Shear reinforcement yield stress"
PHY_MATERIAL_PARAM_SHEAR_STRENGTH_REDUCTION | -1,140,317 | "Shear strength modification"
PHY_MATERIAL_PARAM_MINIMUM_YIELD_STRESS | -1,140,318 | "Minimum yield stress"
PHY_MATERIAL_PARAM_MINIMUM_TENSILE_STRENGTH | -1,140,319 | "Minimum tensile strength"
PHY_MATERIAL_PARAM_REDUCTION_FACTOR | -1,140,320 | "Reduction factor for shear"
PHY_MATERIAL_PARAM_RESISTANCE_CALC_STRENGTH | -1,140,321 | "Resistance calculation strength"
PHY_MATERIAL_PARAM_BEHAVIOR | -1,140,322 | "Behavior"
PHY_MATERIAL_PARAM_LIGHT_WEIGHT | -1,140,323 | "Lightweight"
RBS_SYSTEM_NAME_PARAM | -1,140,324 | "System Name"
RBS_SYSTEM_CLASSIFICATION_PARAM | -1,140,325 | "System Classification"
RBS_SYSTEM_BASE_ELEMENT_PARAM | -1,140,326 | "System Equipment"
RBS_SYSTEM_NUM_ELEMENTS_PARAM | -1,140,327 | "Number of Elements"
RBS_SYSTEM_FLOW_CONVERSION_METHOD_PARAM | -1,140,328 | "Flow Conversion Method"
CONNECTOR_ENGAGEMENT_LENGTH | -1,140,329 | "Engagement Length"
RBS_PIPE_SLOPE_DEF_PARAM | -1,140,330 | "Pipe Slope Definitions"
MEP_SYSTEM_LINE_GRAPHICS_OVERRIDES_PARAM | -1,140,331 | "Graphic Overrides"
RBS_SYSTEM_ABBREVIATION_PARAM | -1,140,332 | "Abbreviation"
RBS_DUCT_SYSTEM_TYPE_PARAM | -1,140,333 | "System Type"
RBS_PIPING_SYSTEM_TYPE_PARAM | -1,140,334 | "System Type"
RBS_PIPE_SYSTEM_CALCULATION_PARAM | -1,140,335 | "Calculations"
RBS_DUCT_SYSTEM_CALCULATION_PARAM | -1,140,336 | "Calculations"
CONNECTOR_LENGTH | -1,140,337 | "Length"
CONNECTOR_ANGLE_OF_DEFLECTION | -1,140,338 | "Angle of Deflection"
FABRICATION_SERVICE_PARAM | -1,140,339 | "Fabrication Service"
RBS_PIPE_SLOPE_OPTIONS_DEF_PARAM | -1,140,340 | "Pipe Slope Options"
MATERIAL_NAME | -1,140,355 | "Name"
MATERIAL_ASPAINT | -1,140,359 | "As Paint"
MATERIAL_AREA | -1,140,360 | "Area"
MATERIAL_VOLUME | -1,140,361 | "Volume"
ELEM_CATEGORY_PARAM | -1,140,362 | "Category"
ELEM_CATEGORY_PARAM_MT | -1,140,363 | "Category"
PHY_MATERIAL_PARAM_TYPE | -1,140,400 | "Material Type"
PHY_MATERIAL_PARAM_YOUNG_MOD | -1,140,401 | "Young modulus"
PHY_MATERIAL_PARAM_COMPRESSION_PARALLEL | -1,140,407 | "Compression parallel to grain"
PHY_MATERIAL_PARAM_COMPRESSION_PERPENDICULAR | -1,140,408 | "Compression perpendicular to grain"
PHY_MATERIAL_PARAM_SHEAR_PARALLEL | -1,140,409 | "Shear parallel to grain"
PHY_MATERIAL_PARAM_SHEAR_PERPENDICULAR | -1,140,410 | "Shear perpendicular to grain"
PHY_MATERIAL_PARAM_POISSON_MOD | -1,140,412 | "Poisson ratio"
PHY_MATERIAL_PARAM_SHEAR_MOD | -1,140,413 | "Shear modulus"
PHY_MATERIAL_PARAM_BENDING | -1,140,414 | "Bending"
PHY_MATERIAL_PARAM_EXP_COEFF | -1,140,415 | "Thermal expansion coefficient"
PHY_MATERIAL_PARAM_SPECIES | -1,140,416 | "Species"
PHY_MATERIAL_PARAM_GRADE | -1,140,417 | "Grade"
KEY_VALUE | -1,140,418 | "Key Value"
KEYNOTE_TEXT | -1,140,419 | "Keynote Text"
SHEET_KEY_NUMBER | -1,140,420 | "Sheet Key Number"
KEYNOTE_NUMBER | -1,140,421 | "Key Value"
KEYNOTE_PARAM | -1,140,422 | "Keynote"
KEY_SOURCE_PARAM | -1,140,423 | "Key Source"
BOUNDARY_CONDITIONS_TYPE | -1,140,500 | "Boundary Conditions Type"
BOUNDARY_CONDITIONS_IS_EXT | -1,140,501 | "Is Boundary Conditions External?"
BOUNDARY_DIRECTION_X | -1,140,502 | "X Translation"
BOUNDARY_DIRECTION_Y | -1,140,503 | "Y Translation"
BOUNDARY_DIRECTION_Z | -1,140,504 | "Z Translation"
BOUNDARY_DIRECTION_ROT_X | -1,140,505 | "X Rotation"
BOUNDARY_DIRECTION_ROT_Y | -1,140,506 | "Y Rotation"
BOUNDARY_DIRECTION_ROT_Z | -1,140,507 | "Z Rotation"
BOUNDARY_RESTRAINT_X | -1,140,508 | "X Spring Modulus"
BOUNDARY_RESTRAINT_Y | -1,140,509 | "Y Spring Modulus"
BOUNDARY_RESTRAINT_Z | -1,140,510 | "Z Spring Modulus"
BOUNDARY_RESTRAINT_ROT_X | -1,140,511 | "X Spring Modulus"
BOUNDARY_RESTRAINT_ROT_Y | -1,140,512 | "Y Spring Modulus"
BOUNDARY_RESTRAINT_ROT_Z | -1,140,513 | "Z Spring Modulus"
BOUNDARY_LINEAR_RESTRAINT_X | -1,140,514 | "X Spring Modulus"
BOUNDARY_LINEAR_RESTRAINT_Y | -1,140,515 | "Y Spring Modulus"
BOUNDARY_LINEAR_RESTRAINT_Z | -1,140,516 | "Z Spring Modulus"
BOUNDARY_LINEAR_RESTRAINT_ROT_X | -1,140,517 | "X Spring Modulus"
BOUNDARY_AREA_RESTRAINT_X | -1,140,518 | "X Spring Modulus"
BOUNDARY_AREA_RESTRAINT_Y | -1,140,519 | "Y Spring Modulus"
BOUNDARY_AREA_RESTRAINT_Z | -1,140,520 | "Z Spring Modulus"
BOUNDARY_X_ROTATION_FIXED | -1,140,521 | "X Rotation - Fixed"
BOUNDARY_X_ROTATION_SPRING | -1,140,522 | "X Rotation - Spring"
BOUNDARY_X_TRANSLATION_FIXED | -1,140,523 | "X Translation - Fixed"
BOUNDARY_X_TRANSLATION_SPRING | -1,140,524 | "X Translation - Spring"
BOUNDARY_Y_ROTATION_FIXED | -1,140,525 | "Y Rotation - Fixed"
BOUNDARY_Y_ROTATION_SPRING | -1,140,526 | "Y Rotation - Spring"
BOUNDARY_Y_TRANSLATION_FIXED | -1,140,527 | "Y Translation - Fixed"
BOUNDARY_Y_TRANSLATION_SPRING | -1,140,528 | "Y Translation - Spring"
BOUNDARY_Z_ROTATION_FIXED | -1,140,529 | "Z Rotation - Fixed"
BOUNDARY_Z_ROTATION_SPRING | -1,140,530 | "Z Rotation - Spring"
BOUNDARY_Z_TRANSLATION_FIXED | -1,140,531 | "Z Translation - Fixed"
BOUNDARY_Z_TRANSLATION_SPRING | -1,140,532 | "Z Translation - Spring"
BOUNDARY_PARAM_PRESET | -1,140,633 | "State"
BOUNDARY_PARAM_PRESET_LINEAR | -1,140,634 | "State"
BOUNDARY_PARAM_PRESET_AREA | -1,140,635 | "State"
TRUSS_LENGTH | -1,140,700 | "Truss Length"
TRUSS_ELEMENT_CLASS_PARAM | -1,140,702 | "Engineering Type"
TRUSS_ELEMENT_ANGLE_PARAM | -1,140,703 | "Rotation Angle"
TRUSS_ELEMENT_CREATE_TOP_PARAM | -1,140,704 | "Create Top Chord"
TRUSS_ELEMENT_CREATE_BOTTOM_PARAM | -1,140,705 | "Create Bottom Chord"
TRUSS_ELEMENT_BEARING_JUST_PARAM | -1,140,706 | "Bearing Vertical Justification"
TRUSS_ELEMENT_END0_ELEVATION | -1,140,707 | "Start Level Offset"
TRUSS_ELEMENT_END1_ELEVATION | -1,140,708 | "End Level Offset"
TRUSS_ELEMENT_REFERENCE_LEVEL_PARAM | -1,140,709 | "Reference Level"
TRUSS_ELEMENT_ROTATE_CHORDS_WITH_TRUSS | -1,140,710 | "Rotate Chords With Truss"
TRUSS_FAMILY_TRANSFORMATION_PARAM | -1,140,711 | "Web Orientation"
TRUSS_HEIGHT | -1,140,712 | "Truss Height"
TRUSS_FAMILY_WEBS_HAVE_SYMBOLIC_CUTBACK_PARAM | -1,140,713 | "Webs have symbolic cutback"
TRUSS_ELEMENT_STICK_JUST_PARAM | -1,140,714 | "Stick Symbol Location"
TRUSS_ELEMENT_SPAN_PARAM | -1,140,715 | "Span"
TRUSS_BEARING_CHORD_TOP_BOTTOM_PARAM | -1,140,716 | "Bearing Chord"
TRUSS_NON_BEARING_OFFSET_PARAM | -1,140,717 | "Non Bearing Offset"
TRUSS_ELEMENT_TAG_NEW_MEMBERS_VIEW | -1,140,718 | "Tag new members in view"
TRUSS_FAMILY_VERT_WEB_END_RELEASE_TYPE | -1,140,721 | "End Release"
TRUSS_FAMILY_VERT_WEB_START_RELEASE_TYPE | -1,140,722 | "Start Release"
TRUSS_FAMILY_VERT_WEB_ANGLE_PARAM | -1,140,724 | "Angle"
TRUSS_FAMILY_VERT_WEB_STRUCTURAL_TYPES_PARAM | -1,140,726 | "Structural Framing Type"
TRUSS_FAMILY_DIAG_WEB_END_RELEASE_TYPE | -1,140,731 | "End Release"
TRUSS_FAMILY_DIAG_WEB_START_RELEASE_TYPE | -1,140,732 | "Start Release"
TRUSS_FAMILY_DIAG_WEB_ANGLE_PARAM | -1,140,734 | "Angle"
TRUSS_FAMILY_DIAG_WEB_STRUCTURAL_TYPES_PARAM | -1,140,736 | "Structural Framing Type"
TRUSS_FAMILY_TOP_CHORD_END_RELEASE_TYPE | -1,140,741 | "End Release"
TRUSS_FAMILY_TOP_CHORD_START_RELEASE_TYPE | -1,140,742 | "Start Release"
TRUSS_FAMILY_TOP_CHORD_VERTICAL_PROJECTION_PARAM | -1,140,743 | "Analytical Vertical Projection"
TRUSS_FAMILY_TOP_CHORD_ANGLE_PARAM | -1,140,744 | "Angle"
TRUSS_FAMILY_TOP_CHORD_STRUCTURAL_TYPES_PARAM | -1,140,746 | "Structural Framing Type"
MATCHLINE_TOP_OFFSET | -1,140,751 | "Top Offset"
MATCHLINE_BOTTOM_OFFSET | -1,140,752 | "Bottom Offset"
MATCHLINE_TOP_PLANE | -1,140,753 | "Top Constraint"
MATCHLINE_BOTTOM_PLANE | -1,140,754 | "Bottom Constraint"
REFERENCE_VIEWER_TARGET_VIEW | -1,140,755 | "Target view"
REFERENCE_VIEWER_ATTR_TAG | -1,140,756 | "View Reference Tag"
JOIST_SYSTEM_ELEM_TAG_NEW_MEMBERS_VIEW | -1,140,757 | "Tag new members in view"
REFERENCE_OTHER_VIEW_UI_TOGGLE | -1,140,758 | "Reference Other View": This is used to determine whether reference other view is enable or not.
REFERENCE_OTHER_VIEW_UI_REF_VIEW | -1,140,759 | "Reference View": This is used by the UI to allow selection of view reference.
TRUSS_FAMILY_BOTTOM_CHORD_END_RELEASE_TYPE | -1,140,761 | "End Release"
TRUSS_FAMILY_BOTTOM_CHORD_START_RELEASE_TYPE | -1,140,762 | "Start Release"
TRUSS_FAMILY_BOTTOM_CHORD_VERTICAL_PROJECTION_PARAM | -1,140,763 | "Analytical Vertical Projection"
TRUSS_FAMILY_BOTTOM_CHORD_ANGLE_PARAM | -1,140,764 | "Angle"
TRUSS_FAMILY_BOTTOM_CHORD_STRUCTURAL_TYPES_PARAM | -1,140,766 | "Structural Framing Type"
FABRICATION_PRODUCT_DATA_FINISH_DESCRIPTION | -1,140,900 | "Product Finish Description"
FABRICATION_PRODUCT_DATA_RANGE | -1,140,901 | "Product Range"
FABRICATION_PRODUCT_DATA_LONG_DESCRIPTION | -1,140,902 | "Product Long Description"
FABRICATION_PRODUCT_DATA_SPECIFICATION | -1,140,903 | "Product Specification Description"
FABRICATION_PRODUCT_DATA_MATERIAL_DESCRIPTION | -1,140,904 | "Product Material Description"
FABRICATION_PRODUCT_DATA_SIZE_DESCRIPTION | -1,140,905 | "Product Size Description"
FABRICATION_PRODUCT_DATA_ITEM_DESCRIPTION | -1,140,906 | "Product Short Description"
FABRICATION_PRODUCT_DATA_PRODUCT | -1,140,907 | "Product Name"
FABRICATION_PRODUCT_DATA_OEM | -1,140,908 | "OEM"
FABRICATION_PART_MATERIAL | -1,140,909 | "Part Material"
FABRICATION_PRODUCT_DATA_INSTALL_TYPE | -1,140,910 | "Install Type"
FABRICATION_PART_ANGLE | -1,140,911 | "Angle"
FABRICATION_PART_DIAMETER_IN | -1,140,912 | "Main Primary Diameter"
FABRICATION_PART_WEIGHT | -1,140,913 | "Weight"
FABRICATION_VENDOR_CODE | -1,140,914 | "Vendor Code"
FABRICATION_SPECIFICATION | -1,140,915 | "Specification"
FABRICATION_LEVEL_PARAM | -1,140,916 | "Reference Level"
FABRICATION_OFFSET_PARAM | -1,140,917 | "Middle Elevation"
FABRICATION_TOP_OF_PART | -1,140,918 | "Upper End Top of Insulation Elevation"
FABRICATION_BOTTOM_OF_PART | -1,140,919 | "Lower End Bottom of Insulation Elevation"
FABRICATION_VENDOR | -1,140,920 | "Vendor"
FABRICATION_RELATIVE_FILENAME | -1,140,921 | "Relative File Name"
FABRICATION_SLOPE_PARAM | -1,140,923 | "Slope"
FABRICATION_START_OFFSET_PARAM | -1,140,924 | "Start Middle Elevation"
FABRICATION_END_OFFSET_PARAM | -1,140,925 | "End Middle Elevation"
FABRICATION_PART_WIDTH_IN | -1,140,929 | "Main Primary Width"
FABRICATION_PART_DEPTH_IN | -1,140,930 | "Main Primary Depth"
FABRICATION_PART_DIAMETER_OUT | -1,140,933 | "Main Secondary Diameter"
FABRICATION_PART_WIDTH_OUT | -1,140,934 | "Main Secondary Width"
FABRICATION_PART_DEPTH_OUT | -1,140,935 | "Main Secondary Depth"
FABRICATION_PRODUCT_ENTRY | -1,140,943 | "Product Entry"
FABRICATION_PART_LENGTH | -1,140,944 | "Length"
FABRICATION_INSULATION_SPEC | -1,140,947 | "Insulation Specification"
FABRICATION_PART_LENGTH_OPTION | -1,140,948 | "Length Option"
FABRICATION_PART_ANGLE_OPTION | -1,140,949 | "Angle Option"
FABRICATION_PART_WIDTH_IN_OPTION | -1,140,950 | "Main Primary Width Option"
FABRICATION_PART_DEPTH_IN_OPTION | -1,140,951 | "Main Primary Depth Option"
FABRICATION_PART_DIAMETER_IN_OPTION | -1,140,952 | "Main Primary Diameter Option"
FABRICATION_PART_DIAMETER_OUT_OPTION | -1,140,955 | "Main Secondary Diameter Option"
FABRICATION_PART_WIDTH_OUT_OPTION | -1,140,956 | "Main Secondary Width Option"
FABRICATION_PART_DEPTH_OUT_OPTION | -1,140,957 | "Main Secondary Depth Option"
FABRICATION_PART_TAKEOFF_DIALOG_PARAM | -1,140,965 | "More Parameters"
FABRICATION_PRODUCT_CODE | -1,140,966 | "Product Code"
FABRICATION_ROUTING_SOLUTIONS_UI_PARAM | -1,140,967 | "x of XX"
FABRICATION_PART_ALIAS | -1,140,968 | "Alias"
FABRICATION_PART_BOUGHT_OUT | -1,140,969 | "Bought Out"
FABRICATION_PART_CUT_TYPE | -1,140,970 | "Cut Type"
FABRICATION_PART_DOUBLEWALL_MATERIAL | -1,140,971 | "Double Wall Material"
FABRICATION_PART_DOUBLEWALL_MATERIAL_THICKNESS | -1,140,972 | "Double Wall Material Thickness"
FABRICATION_SERVICE_NAME | -1,140,973 | "Fabrication Service Name"
FABRICATION_PART_INSULATION_AREA | -1,140,974 | "Insulation Area"
FABRICATION_PART_ITEM_NUMBER | -1,140,975 | "Item Number"
FABRICATION_PART_LINING_AREA | -1,140,976 | "Lining Area"
FABRICATION_PART_NOTES | -1,140,977 | "Fabrication Notes"
FABRICATION_PART_MATERIAL_THICKNESS | -1,140,978 | "Part Material Thickness"
FABRICATION_SERVICE_ABBREVIATION | -1,140,979 | "Fabrication Service Abbreviation"
FABRICATION_PART_SHEETMETAL_AREA | -1,140,981 | "Part Sheet Metal Area"
FABRICATION_SET_UP_DOWN_TAG | -1,140,982 | "SU/SD from Top"
FABRICATION_PART_DOUBLEWALL_MATERIAL_AREA | -1,140,983 | "Double Wall Material Area"
MEP_SPOT_TOP_ELEVATION | -1,140,984 | "Spot Top Elevation": used for both design and fabrication components
FABRICATION_SPOT_TOP_ELEVATION_OF_PART | -1,140,984 | "Spot Top Elevation": used for both design and fabrication components
MEP_SPOT_TOP_ELEVATION_INCLUDE_INSULATION | -1,140,985 | "Spot Top of Insulation Elevation"
FABRICATION_SPOT_TOP_ELEVATION_INCLUDE_INSULATION_OF_PART | -1,140,985 | "Spot Top of Insulation Elevation"
MEP_SPOT_BOTTOM_ELEVATION | -1,140,986 | "Spot Bottom Elevation": used for both design and fabrication components
FABRICATION_SPOT_BOTTOM_ELEVATION_OF_PART | -1,140,986 | "Spot Bottom Elevation": used for both design and fabrication components
MEP_SPOT_BOTTOM_ELEVATION_INCLUDE_INSULATION | -1,140,987 | "Spot Bottom of Insulation Elevation"
FABRICATION_SPOT_BOTTOM_ELEVATION_INCLUDE_INSULATION_OF_PART | -1,140,987 | "Spot Bottom of Insulation Elevation"
MEP_SPOT_CENTERLINE_ELEVATION | -1,140,988 | "Spot Centerline Elevation": used for both design and fabrication components
FABRICATION_CENTERLINE_ELEVATION_OF_PART | -1,140,988 | "Spot Centerline Elevation": used for both design and fabrication components
FABRICATION_TOP_ELEVATION_OF_PART | -1,140,989 | "Top Elevation"
FABRICATION_TOP_ELEVATION_INCLUDE_INSULATION_OF_PART | -1,140,990 | "Top Elevation with Insulation"
FABRICATION_BOTTOM_ELEVATION_OF_PART | -1,140,991 | "Bottom Elevation"
FABRICATION_BOTTOM_ELEVATION_INCLUDE_INSULATION_OF_PART | -1,140,992 | "Bottom Elevation with Insulation"
FABRICATION_PIPE_INVERT_ELEVATION | -1,140,993 | "Pipe Invert Elevation": This parameter is obsolete. It exists only for compatibility.
FABRICATION_SPECIFICATION_ABBREVIATION | -1,140,994 | "Specification Abbreviation"
FABRICATION_INSULATION_ABBREVIATION | -1,140,995 | "Insulation Abbreviation"
FABRICATION_INSULATION_SPECIFICATION_ABBREVIATION | -1,140,996 | "Insulation Specification Abbreviation"
FABRICATION_MATERIAL_ABBREVIATION | -1,140,997 | "Material Abbreviation"
FABRICATION_DOUBLEWALL_MATERIAL_ABBREVIATION | -1,140,998 | "Double Wall Material Abbreviation"
FABRICATION_FITTING_DESCRIPTION | -1,140,999 | "Fabrication Fitting Description"
REFERENCE_VIEWER_UI_TARGET_FILTER | -1,141,000 | "Filter": This is used by the UI to filter the list of target views.
REFERENCE_VIEWER_UI_TARGET_VIEW | -1,141,001 | "Target view": This is used by the UI to allow selection of target view. It allows the UI to set a filter that is incompatible with the current target view (REFERENCE_VIEWER_TARGET_VIEW).
DISPLACEMENT_PATH_DEPTH | -1,141,002 | "Depth"
DISPLACEMENT_PATH_STYLE | -1,141,003 | "Style"
DISPLACED_ELEMENT_DISPLACEMENT_X | -1,141,004 | "X Displacement"
DISPLACED_ELEMENT_DISPLACEMENT_Y | -1,141,005 | "Y Displacement"
DISPLACED_ELEMENT_DISPLACEMENT_Z | -1,141,006 | "Z Displacement"
FABRICATION_INSULATION_MATERIAL_FINISH | -1,141,007 | "Insulation Material"
FABRICATION_SET_UP_DOWN_TAG_FROM_BOTTOM | -1,141,008 | "SU/SD from Bottom"
FABRICATION_CHANGE_SERVICE_PARAM | -1,141,009 | "Change Service"
FABRICATION_PRIMARY_SIZE | -1,141,010 | "Size of Primary End"
FABRICATION_PRI_SIZE | -1,141,010 | "Size of Primary End"
FABRICATION_SECONDARY_SIZE | -1,141,011 | "Size of Secondary End"
FABRICATION_SEC_SIZE | -1,141,011 | "Size of Secondary End"
FABRICATION_BRANCH_SIZE | -1,141,012 | "Size of Primary Branch End"
FABRICATION_END_SIZE | -1,141,013 | "Size of Connector End"
FABRICATION_PART_PAT_NO | -1,141,014 | "Part Pattern Number"
FABRICATION_DUCTWORK_STIFFENER_SPEC | -1,141,017 | "Stiffener Specification"
FABRICATION_MATERIAL_GAUGE | -1,141,018 | "Material Gauge"
MEP_UPPER_CENTERLINE_ELEVATION | -1,141,020 | "Upper End Centerline Elevation"
MEP_LOWER_CENTERLINE_ELEVATION | -1,141,021 | "Lower End Centerline Elevation"
MEP_UPPER_TOP_ELEVATION | -1,141,022 | "Upper End Top Elevation"
MEP_UPPER_BOTTOM_ELEVATION | -1,141,023 | "Upper End Bottom Elevation"
MEP_LOWER_TOP_ELEVATION | -1,141,024 | "Lower End Top Elevation"
MEP_LOWER_BOTTOM_ELEVATION | -1,141,025 | "Lower End Bottom Elevation"
MEP_UPPER_TOP_ELEVATION_INCLUDE_INSULATION | -1,141,026 | "Upper End Top of Insulation Elevation"
MEP_UPPER_BOTTOM_ELEVATION_INCLUDE_INSULATION | -1,141,027 | "Upper End Bottom of Insulation Elevation"
MEP_LOWER_TOP_ELEVATION_INCLUDE_INSULATION | -1,141,028 | "Lower End Top of Insulation Elevation"
MEP_LOWER_BOTTOM_ELEVATION_INCLUDE_INSULATION | -1,141,029 | "Lower End Bottom of Insulation Elevation"
MEP_PIPE_UPPER_OBVERT_ELEVATION | -1,141,030 | "Upper End Obvert Elevation"
MEP_PIPE_LOWER_OBVERT_ELEVATION | -1,141,031 | "Lower End Obvert Elevation"
MEP_PIPE_UPPER_INVERT_ELEVATION | -1,141,032 | "Upper End Invert Elevation"
MEP_PIPE_LOWER_INVERT_ELEVATION | -1,141,033 | "Lower End Invert Elevation"
RBS_PIPE_WALL_THICKNESS | -1,141,040 | "Wall Thickness"
RBS_DISTRIBUTIONSYS_HL_PHASE_PARAM | -1,141,050 | "High-leg Phase"
LAYOUTNODE_CURVETYPE_PARAM | -1,142,000 | "Curve Type Reference"
RBS_ELEC_ROOM_LIGHTING_CALC_LUMINAIREPLANE | -1,144,331 | "Lighting Calculation Luminaire Plane"
DIVIDED_SURFACE_SURFACE_AREA | -1,150,050 | "Divided Surface Area"
DIVIDED_SURFACE_FACET_NUMBER | -1,150,051 | "Facet number"
DIVIDED_SURFACE_POINT_NUMBER | -1,150,052 | "Point number"
DIVIDED_SURFACE_EDGE_NUMBER | -1,150,053 | "Edge number"
DIVIDED_SURFACE_TOTAL_EDGE_LENGTH | -1,150,054 | "Total edge length"
DIVIDED_SURFACE_OFFSET_FROM_SURFACE | -1,150,055 | "Offset from surface"
DIVIDED_SURFACE_COVER_FACE_COMPLETELY | -1,150,056 | "Cover face completely"
DIVIDED_SURFACE_PATTERN_INDENT_1 | -1,150,057 | "Indent 1"
DIVIDED_SURFACE_PATTERN_INDENT_2 | -1,150,058 | "Indent 2"
DIVIDED_SURFACE_PATTERN_ROTATION_ANGLE | -1,150,059 | "Component Rotation"
DIVIDED_SURFACE_PATTERN_FLIP | -1,150,060 | "Component Flip"
DIVIDED_SURFACE_PATTERN | -1,150,061 | "Tile Pattern"
DIVIDED_SURFACE_ALL_POINTS | -1,150,062 | "Show all points"
DIVIDED_SURFACE_TILE_BORDER | -1,150,067 | "Border Tile"
DIVIDED_SURFACE_ALL_GRID_ROTATION | -1,150,068 | "All Grid Rotation"
DIVIDED_SURFACE_DISPLAY_SURFACE_OPTION | -1,150,069 | "Display Surface Option"
DIVIDED_SURFACE_DISPLAY_ORIGINAL_SURFACE | -1,150,070 | "Surface"
DIVIDED_SURFACE_ORIGINAL_SURFACE_MATERIAL | -1,150,071 | "Surface Material"
DIVIDED_SURFACE_DISPLAY_NODES | -1,150,072 | "Nodes"
DIVIDED_SURFACE_DISPLAY_GRIDLINES | -1,150,073 | "Gridlines"
DIVIDED_SURFACE_GRIDLINES_STYLE | -1,150,074 | "Gridlines Style"
DIVIDED_SURFACE_DISPLAY_PATTERN_LINES | -1,150,075 | "Pattern Lines"
DIVIDED_SURFACE_PATTERN_LINES_STYLE | -1,150,076 | "Pattern Lines Style"
DIVIDED_SURFACE_DISPLAY_PATTERN_FILL | -1,150,077 | "Pattern Fill"
DIVIDED_SURFACE_PATTERN_FILL_MATERIAL | -1,150,078 | "Pattern Fill Material"
DIVIDED_SURFACE_DISPLAY_COMPONENTS | -1,150,079 | "Components"
DIVIDED_SURFACE_RULE_1_SUSPENSION | -1,150,080 | "Is grid 1 suspended?"
DIVIDED_SURFACE_RULE_2_SUSPENSION | -1,150,081 | "Is grid 2 suspended?"
DIVIDED_SURFACE_PATTERN_MIRROR | -1,150,082 | "Component Mirror"
DIVIDED_SURFACE_COMPONENT_TRIM_TYPE | -1,150,083 | "Component Trim"
DIVIDED_SURFACE_DISPLAY_DISCARDEDDIVISIONLINES | -1,150,084 | "Discarded Division Lines"
DIVIDED_SURFACE_GRID_OPTION_PARAM_1 | -1,150,085 | "Option 1"
DIVIDED_SURFACE_GRID_OPTION_PARAM_2 | -1,150,086 | "Option 2"
FBX_ASSET_TYPE | -1,150,100 | "Light Source"
FBX_LIGHT_PHOTOMETRICS | -1,150,101 | "Light Source Definition"
FBX_LIGHT_INITIAL_INTENSITY | -1,150,102 | "Initial Intensity"
FBX_LIGHT_WATTAGE | -1,150,103 | "Wattage"
FBX_LIGHT_EFFICACY | -1,150,104 | "Efficacy"
FBX_LIGHT_LIMUNOUS_INTENSITY | -1,150,105 | "Luminous Intensity"
FBX_LIGHT_ILLUMINANCE | -1,150,106 | "Illuminance"
FBX_LIGHT_INITIAL_COLOR_TEMPERATURE | -1,150,107 | "Initial Color Temperature"
FBX_LIGHT_COLOR_FILTER | -1,150,108 | "Color Filter"
FBX_LIGHT_TEMPERATURE_LOSS | -1,150,109 | "Temperature Loss"
FBX_LIGHT_VOLTAGE_LOSS | -1,150,110 | "Voltage Loss"
FBX_LIGHT_LAMP_TILT_LOSS | -1,150,112 | "Lamp Tilt Loss"
FBX_LIGHT_SURFACE_LOSS | -1,150,113 | "Surface Depreciation Loss"
FBX_LIGHT_LAMP_LUMEN_DEPR | -1,150,114 | "Lamp Lumen Depreciation"
FBX_LIGHT_LUMENAIRE_DIRT | -1,150,115 | "Luminaire Dirt Depreciation"
FBX_LIGHT_DIMMING_LIGHT_COLOR | -1,150,117 | "Dimming Lamp Color Temperature Shift"
FBX_LIGHT_EMIT_SHAPE_VISIBLE | -1,150,118 | "Emit Shape Visible in Rendering"
FBX_LIGHT_EMIT_LINE_LENGTH | -1,150,126 | "Emit from Line Length"
FBX_LIGHT_EMIT_RECTANGLE_WIDTH | -1,150,127 | "Emit from Rectangle Width"
FBX_LIGHT_EMIT_RECTANGLE_LENGTH | -1,150,128 | "Emit from Rectangle Length"
FBX_LIGHT_EMIT_CIRCLE_DIAMETER | -1,150,129 | "Emit from Circle Diameter"
FBX_LIGHT_SOURCE_DIAMETER | -1,150,130 | "Light Source Symbol Size"
FBX_LIGHT_SOURCE_LENGTH | -1,150,131 | "Light Source Symbol Length"
FBX_LIGHT_INITIAL_INTENSITY_INPUT_METHOD | -1,150,132 | "Initial Light Intensity Input Method"
FBX_LIGHT_AT_A_DISTANCE | -1,150,133 | "At a distance"
FBX_LIGHT_INITIAL_COLOR_NAME | -1,150,134 | "Temperature Color"
FBX_LIGHT_LOSS_FACTOR_METHOD | -1,150,137 | "Light Loss Input Method"
FBX_LIGHT_INITIAL_COLOR_CTRL | -1,150,138 | "Initial Color"
FBX_LIGHT_LOSS_FACTOR_CTRL | -1,150,139 | "Light Loss Factor"
FAMILY_CURVE_ATTACHMENT_PROPORTION | -1,150,140 | "Attachment Point"
FBX_LIGHT_PHOTOMETRICS_FAM | -1,150,141 | "Light Source Definition (family)"
FBX_LIGHT_PHOTOMETRIC_FILE_CACHE | -1,150,142 | "None"
SPOT_DIM_STYLE_SLOPE_UNITS_ALT | -1,150,143 | "Alternate Units Format"
POINT_ELEMENT_OFFSET | -1,150,144 | "Offset"
POINT_ELEMENT_DRIVEN | -1,150,145 | "Driven by Host"
POINT_ELEMENT_HOSTED_PARAM | -1,150,146 | "Hosted Parameter"
CURVE_IS_REFERENCE_LINE | -1,150,147 | "Is Reference Line"
POINT_ELEMENT_SHOW_PLANES | -1,150,148 | "Show Reference Planes"
POINT_VISIBILITY_PARAM | -1,150,149 | "Visibility/Graphics Overrides"
SPOT_SLOPE_PREFIX | -1,150,150 | "Prefix"
SPOT_SLOPE_SUFFIX | -1,150,151 | "Suffix"
SPOT_SLOPE_LEADER_LENGTH | -1,150,152 | "Leader Line Length"
POINT_ELEMENT_DRIVING | -1,150,153 | "Driving Curve(s)"
SPOT_DIM_STYLE_SLOPE_UNITS | -1,150,154 | "Units Format"
POINT_ADAPTIVE_TYPE_PARAM | -1,150,155 | "Point"
POINT_NAME_PARAM | -1,150,156 | "Name"
POINT_FLEXIBLE_CONSTRAINED | -1,150,157 | "Constrained"
POINT_FLEXIBLE_SHOW_NUMBER | -1,150,158 | "Show Placement Number"
CONNECTOR_UTILITY_PARAM | -1,150,159 | "Utility"
RBS_BUILDING_CONSTRUCTIONCLASS | -1,150,160 | "Building Infiltration Class"
RBS_PROJECT_REPORTTYPE_PARAM | -1,150,161 | "Report Type"
LOCKED_TOP_OFFSET | -1,150,162 | "Positive Offset"
LOCKED_BASE_OFFSET | -1,150,163 | "Negative Offset"
LOCKED_START_OFFSET | -1,150,164 | "Negative Offset"
LOCKED_END_OFFSET | -1,150,165 | "Positive Offset"
POINT_ELEMENT_HOSTED_ON_FACE_U_PARAM | -1,150,166 | "Hosted U Parameter"
POINT_ELEMENT_HOSTED_ON_FACE_V_PARAM | -1,150,167 | "Hosted V Parameter"
POINT_ELEMENT_ZFLIPPED | -1,150,168 | "Flipped"
POINT_ELEMENT_MIRRORED | -1,150,169 | "Mirrored"
VIEW_SLANTED_COLUMN_SYMBOL_OFFSET | -1,150,170 | "Column Symbolic Offset"
SLANTED_COLUMN_TYPE_PARAM | -1,150,171 | "Column Style"
INSTANCE_MOVE_TOP_WITH_GRIDS | -1,150,172 | "Move Top With Grids"
INSTANCE_MOVE_BASE_WITH_GRIDS | -1,150,173 | "Move Base With Grids"
STRUCTURAL_ATTACHMENT_BASE_TYPE | -1,150,176 | "Base Attachment Type"
STRUCTURAL_ATTACHMENT_BASE_DISTANCE | -1,150,177 | "Base Attachment Distance"
STRUCTURAL_ATTACHMENT_BASE_RATIO | -1,150,178 | "Base Attachment Ratio"
STRUCTURAL_ATTACHMENT_BASE_REFERENCEDEND | -1,150,179 | "Base Attachment Referenced End"
STRUCTURAL_ATTACHMENT_TOP_TYPE | -1,150,180 | "Top Attachment Type"
STRUCTURAL_ATTACHMENT_TOP_DISTANCE | -1,150,181 | "Top Attachment Distance"
STRUCTURAL_ATTACHMENT_TOP_RATIO | -1,150,182 | "Top Attachment Ratio"
STRUCTURAL_ATTACHMENT_TOP_REFERENCEDEND | -1,150,183 | "Top Attachment Referenced End"
ROOM_PLENUM_LIGHTING_PARAM | -1,150,188 | "Plenum Lighting Contribution"
SLANTED_COLUMN_GEOMETRY_TREATMENT_TOP | -1,150,189 | "Top Geometry Alignment"
SLANTED_COLUMN_GEOMETRY_TREATMENT_BASE | -1,150,190 | "Base Geometry Alignment"
BASEPOINT_NORTHSOUTH_PARAM | -1,150,191 | "N/S"
BASEPOINT_EASTWEST_PARAM | -1,150,192 | "E/W"
BASEPOINT_ELEVATION_PARAM | -1,150,193 | "Elev"
BASEPOINT_ANGLETON_PARAM | -1,150,194 | "Angle to True North"
LEVEL_IS_GROUND_PLANE | -1,150,195 | "Is ground plane"
POINT_ELEMENT_SHOW_NORMAL_PLANE_ONLY | -1,150,197 | "Show Normal Reference Plane Only"
TILE_PATTERN_GRID_UNIT_X | -1,150,198 | "Horizontal spacing"
TILE_PATTERN_GRID_UNIT_Y | -1,150,199 | "Vertical spacing"
TILE_PATTERN_GRID_CELLS_X | -1,150,200 | "Number of horizontal cells"
TILE_PATTERN_GRID_CELLS_Y | -1,150,201 | "Number of vertical cells"
TILE_PATTERN_FAMREF_COMPONENT_EXTENTS | -1,150,202 | "Component Extents"
RBS_BUILDING_USELOADCREDITS | -1,150,203 | "Use Load Credits"
SLANTED_COLUMN_TOP_CUT_STYLE | -1,150,204 | "Top Cut Style"
SLANTED_COLUMN_BASE_CUT_STYLE | -1,150,205 | "Base Cut Style"
SLANTED_COLUMN_TOP_EXTENSION | -1,150,206 | "Top Extension"
SLANTED_COLUMN_BASE_EXTENSION | -1,150,207 | "Base Extension"
FRAMING_LENGTH_ROUNDOFF | -1,150,208 | "Structural Framing Length Roundoff"
POINT_FLEXIBLE_NUM_PARAM | -1,150,209 | "Number"
RBS_ENERGY_ANALYSIS_INCLUDE_THERMAL_PROPERTIES | -1,150,210 | "Detailed Elements"
FOLLOW_SURFACE | -1,150,211 | "Follow Surface"
CURVE_BY_POINTS_PROJECTION_TYPE | -1,150,212 | "Projection Type"
TEXT_BOX_VISIBILITY | -1,150,213 | "Show Border"
STRUCTURAL_BEAM_START_ATTACHMENT_TYPE | -1,150,214 | "Start Attachment Type"
STRUCTURAL_BEAM_END_ATTACHMENT_TYPE | -1,150,215 | "End Attachment Type"
STRUCTURAL_BEAM_START_ATTACHMENT_DISTANCE | -1,150,216 | "Start Attachment Distance"
STRUCTURAL_BEAM_END_ATTACHMENT_DISTANCE | -1,150,217 | "End Attachment Distance"
STRUCTURAL_BEAM_START_ATTACHMENT_REFCOLUMN_END | -1,150,218 | "Start of Attachment to Reference Column"
STRUCTURAL_BEAM_END_ATTACHMENT_REFCOLUMN_END | -1,150,219 | "End of Attachment to Reference Column"
POINT_ELEMENT_MEASUREMENT_TYPE | -1,150,220 | "Measurement Type"
POINT_ELEMENT_NON_NORMALIZED_CURVE_PARAMATER | -1,150,221 | "Non-Normalized Curve Parameter"
POINT_ELEMENT_NORMALIZED_CURVE_PARAMATER | -1,150,222 | "Normalized Curve Parameter"
POINT_ELEMENT_SEGMENT_LENGTH | -1,150,223 | "Segment Length"
POINT_ELEMENT_NORMALIZED_SEGMENT_LENGTH | -1,150,224 | "Normalized Segment Length"
POINT_ELEMENT_CHORD_LENGTH | -1,150,225 | "Chord Length"
POINT_ELEMENT_ANGLE | -1,150,226 | "Angle"
POINT_ELEMENT_MEASURE_FROM | -1,150,227 | "Measure From"
LEADER_LEFT_ATTACHMENT | -1,150,230 | "Left Attachment"
LEADER_RIGHT_ATTACHMENT | -1,150,231 | "Right Attachment"
RBS_ENERGY_ANALYSIS_BUILDING_ENVELOPE_DETERMINATION_PARAM | -1,150,232 | "Building Envelope"
RBS_ENERGY_ANALYSIS_BUILDING_ENVELOPE_ANALYTICAL_GRID_CELL_SIZE | -1,150,233 | "Analytical Grid Cell Size"
ENERGY_ANALYSIS_VERTICAL_VOID_THRESHOLD | -1,150,234 | "Average Vertical Void Height Threshold"
ENERGY_ANALYSIS_HORIZONTAL_VOID_THRESHOLD | -1,150,235 | "Horizontal Void/Chase Area Threshold"
ENERGY_ANALYSIS_SPACE_BOUNDING_PARAM | -1,150,236 | "Analytical Space Bounding"
DEFAULT_CONSTRUCTION_MASS_EXTERIOR_WALL | -1,150,300 | "Mass Exterior Wall"
DEFAULT_CONSTRUCTION_MASS_INTERIOR_WALL | -1,150,301 | "Mass Interior Wall"
DEFAULT_CONSTRUCTION_MASS_ROOF | -1,150,302 | "Mass Roof"
DEFAULT_CONSTRUCTION_MASS_SHADE | -1,150,303 | "Mass Shade"
DEFAULT_CONSTRUCTION_MASS_SLAB | -1,150,304 | "Mass Slab"
DEFAULT_CONSTRUCTION_EXT_WALL_UNDERGROUND | -1,150,305 | "Mass Exterior Wall - Underground"
DEFAULT_CONSTRUCTION_MASS_GLAZING | -1,150,306 | "Mass Glazing"
DEFAULT_CONSTRUCTION_MASS_SKYLIGHT | -1,150,307 | "Mass Skylight"
DEFAULT_CONSTRUCTION_MASS_OPENING | -1,150,309 | "Mass Opening"
DEFAULT_CONSTRUCTION_MASS_FLOOR | -1,150,310 | "Mass Floor"
POINT_FLEXIBLE_ORIENTATION_TYPE | -1,150,320 | "Orientation"
FLEXIBLE_INSTANCE_FLIP | -1,150,321 | "Flip"
POINT_ELEMENT_ROTATION_ANGLE | -1,150,322 | "Rotation Angle"
RAILING_SYSTEM_TOP_RAIL_TYPES_PARAM | -1,150,327 | "Type"
RAILING_SYSTEM_TOP_RAIL_HEIGHT_PARAM | -1,150,328 | "Height"
RAILING_SYSTEM_HANDRAILS_TYPES_PARAM | -1,150,329 | "Type"
RAILING_SYSTEM_HANDRAILS_POSITION_PARAM | -1,150,330 | "Position"
RAILING_SYSTEM_HANDRAILS_HEIGHT_PARAM | -1,150,331 | "Height"
RAILING_SYSTEM_HANDRAILS_LATTERAL_OFFSET | -1,150,332 | "Lateral Offset"
RAILING_SYSTEM_SECONDARY_HANDRAILS_TYPES_PARAM | -1,150,333 | "Type"
RAILING_SYSTEM_SECONDARY_HANDRAILS_POSITION_PARAM | -1,150,334 | "Position"
RAILING_SYSTEM_SECONDARY_HANDRAILS_HEIGHT_PARAM | -1,150,335 | "Height"
RAILING_SYSTEM_SECONDARY_HANDRAILS_LATTERAL_OFFSET | -1,150,336 | "Lateral Offset"
CONTINUOUSRAIL_DEFAULT_JOIN_TYPE_PARAM | -1,150,337 | "Default Join"
CONTINUOUSRAIL_FILLET_RADIUS_PARAM | -1,150,338 | "Fillet Radius"
CONTINUOUSRAIL_PROFILE_TYPE_PARAM | -1,150,339 | "Profile"
HANDRAIL_HEIGHT_PARAM | -1,150,340 | "Height"
HANDRAIL_PROJECTION_PARAM | -1,150,341 | "Projection"
HANDRAIL_HAND_CLEARANCE_PARAM | -1,150,342 | "Hand Clearance"
CONTINUOUSRAIL_TRANSITION_TYPE_PARAM | -1,150,343 | "Transitions"
CONTINUOUSRAIL_MATERIALS_PARAM | -1,150,344 | "Material"
CONTINUOUSRAIL_BEGINNING_TERMINATION_TYPE_PARAM | -1,150,345 | "Beginning/Bottom Termination"
CONTINUOUSRAIL_END_TERMINATION_TYPE_PARAM | -1,150,346 | "End/Top Termination"
CONTINUOUSRAIL_BEGINNING_TERMINATION_ATTACHMENT_PARAM | -1,150,347 | "Extension Style"
CONTINUOUSRAIL_EXTENSION_LENGTH_PARAM | -1,150,348 | "Length"
CONTINUOUSRAIL_END_TERMINATION_ATTACHMENT_PARAM | -1,150,349 | "Extension Style"
CONTINUOUSRAIL_END_EXTENSION_LENGTH_PARAM | -1,150,350 | "Length"
HANDRAIL_SUPPORTS_TYPE_PARAM | -1,150,351 | "Family"
HANDRAIL_SUPPORTS_LAYOUT_PARAM | -1,150,352 | "Layout"
HANDRAIL_SUPPORTS_SPACING_PARAM | -1,150,353 | "Spacing"
HANDRAIL_SUPPORTS_NUMBER_PARAM | -1,150,354 | "Number"
HANDRAIL_SUPPORTS_JUSTIFICATION_PARAM | -1,150,355 | "Justification"
CONTINUOUSRAIL_LENGTH_PARAM | -1,150,360 | "Length"
CONTINUOUSRAIL_PLUS_TREAD_DEPTH_PARAM | -1,150,361 | "Plus Tread Depth"
CONTINUOUSRAIL_JOIN_TYPE_PARAM | -1,150,373 | "Rail Path Join"
RAILING_SYSTEM_HAS_TOP_RAIL | -1,150,380 | "Use Top Rail": Whether railing has top rail
ASSEMBLY_NAMING_CATEGORY | -1,150,403 | "Naming Category"
RBS_SYSTEM_RISEDROP_1LINETEEDOWNSYMBOL_PARAM | -1,150,405 | "Single Line Tee Down Symbol"
RBS_SYSTEM_RISEDROP_1LINETEEUPSYMBOL_PARAM | -1,150,406 | "Single Line Tee Up Symbol"
RBS_SYSTEM_RISEDROP_1LINERISESYMBOL_PARAM | -1,150,407 | "Single Line Rise Symbol"
RBS_SYSTEM_RISEDROP_1LINEDROPSYMBOL_PARAM | -1,150,408 | "Single Line Drop Symbol"
RBS_SYSTEM_RISEDROP_2LINERISESYMBOL_PARAM | -1,150,409 | "Two Line Rise Symbol"
RBS_SYSTEM_RISEDROP_2LINEDROPSYMBOL_PARAM | -1,150,410 | "Two Line Drop Symbol"
RBS_SYSTEM_RISEDROP_PARAM | -1,150,411 | "Rise / Drop Symbol"
RBS_COMPONENT_CLASSIFICATION_PARAM | -1,150,412 | "Component Classification"
ASSEMBLY_NAME | -1,150,420 | "Assembly Name"
RBS_INSULATION_LINING_VOLUME | -1,150,425 | "Volume"
RBS_DUCT_CALCULATED_SIZE | -1,150,426 | "Duct Size"
RBS_PIPE_CALCULATED_SIZE | -1,150,427 | "Pipe Size"
RBS_REFERENCE_INSULATION_TYPE | -1,150,430 | "Insulation Type"
RBS_REFERENCE_INSULATION_THICKNESS | -1,150,431 | "Insulation Thickness": This parameter is obsolete. Use DUCT_INSULATION_THICKNESS and PIPE_INSULATION_THICKNESS.
RBS_REFERENCE_LINING_TYPE | -1,150,432 | "Lining Type"
RBS_REFERENCE_LINING_THICKNESS | -1,150,433 | "Lining Thickness"
RBS_REFERENCE_OVERALLSIZE | -1,150,434 | "Overall Size"
RBS_REFERENCE_FREESIZE | -1,150,435 | "Free Size"
DUCT_INSULATION_THICKNESS | -1,150,436 | "Insulation Thickness"
PIPE_INSULATION_THICKNESS | -1,150,437 | "Insulation Thickness"
SHEET_ASSEMBLY_NAME | -1,150,450 | "Assembly: Name"
SHEET_ASSEMBLY_MODEL | -1,150,451 | "Assembly: Model"
SHEET_ASSEMBLY_MANUFACTURER | -1,150,452 | "Assembly: Manufacturer"
SHEET_ASSEMBLY_TYPE_COMMENTS | -1,150,453 | "Assembly: Type Comments"
SHEET_ASSEMBLY_URL | -1,150,454 | "Assembly: URL"
SHEET_ASSEMBLY_DESCRIPTION | -1,150,455 | "Assembly: Description"
SHEET_ASSEMBLY_ASSEMBLY_CODE | -1,150,456 | "Assembly: Assembly Code"
SHEET_ASSEMBLY_TYPE_MARK | -1,150,457 | "Assembly: Type Mark"
SHEET_ASSEMBLY_COST | -1,150,458 | "Assembly: Cost"
SHEET_ASSEMBLY_ASSEMBLY_DESCRIPTION | -1,150,459 | "Assembly: Assembly Description"
SHEET_ASSEMBLY_KEYNOTE | -1,150,460 | "Assembly: Keynote"
ANALYTICAL_MODEL_LENGTH | -1,150,461 | "Length": The length of Analytical Model
ANALYTICAL_MODEL_AREA | -1,150,462 | "Area": The Area of Analytical Model
ANALYTICAL_MODEL_PERIMETER | -1,150,463 | "Perimeter": The Perimeter of Analytical Model
PHY_MATERIAL_PARAM_CLASS | -1,150,464 | "Class"
PHY_MATERIAL_PARAM_SUBCLASS | -1,150,465 | "Subclass"
PROPERTY_SET_NAME | -1,150,466 | "Property Set Name"
PHY_MATERIAL_PROPERTIES | -1,150,467 | "Properties"
RBS_DUCT_PIPE_SYSTEM_ABBREVIATION_PARAM | -1,150,468 | "System Abbreviation"
PROPERTY_SET_MATERIAL_ASPECT | -1,150,480 | "Material aspect"
PROPERTY_SET_DESCRIPTION | -1,150,481 | "Description"
POINTCLOUDTYPE_SCALE | -1,150,500 | "Scale": The scale for this instance
ANALYTICAL_MODEL_ROTATION | -1,150,501 | "Cross-Section Rotation": The rotation of Analytical Model
POINTCLOUDINSTANCE_NAME | -1,150,600 | "Name": The name of the instance as it will show in the Property Palette
PARTMAKER_PARAM_DIVISION_GAP | -1,150,601 | "Gap"
FAMILY_KEYWORD_PROTECTED | -1,150,602 | "Content protection enabled"
PART_MAKER_SPLITTER_PROFILE | -1,150,603 | "Division Profile"
PART_MAKER_SPLITTER_PROFILE_FLIP_ACROSS | -1,150,604 | "Profile Across Flip"
PART_MAKER_SPLITTER_PROFILE_FLIP_ALONG | -1,150,605 | "Profile Along Flip"
PART_MAKER_SPLITTER_PROFILE_EDGE_MATCH | -1,150,622 | "Edge Match"
DIVISION_PROFILE_WIDTH | -1,150,623 | "Width": Width
PART_MAKER_DIVISION_PROFILE_OFFSET | -1,150,624 | "Profile Offset"
STAIRS_BASE_LEVEL | -1,151,101 | "Base Level": The base level of stairs
STAIRS_TOP_LEVEL | -1,151,103 | "Top Level": The top level of stairs
STAIRS_STAIRS_HEIGHT | -1,151,105 | "Desired Stair Height": Stairs unconnected height
STAIRS_MULTISTORY_UP_TO_LEVEL | -1,151,106 | "Multistory Top Level": The top level of multi-story stairs
STAIRS_DESIRED_NUMBER_OF_RISERS | -1,151,110 | "Desired Number of Risers": The number of risers is calculated based on stairs height
STAIRS_ACTUAL_NUMBER_OF_RISERS | -1,151,111 | "Actual Number of Risers": The total number of actually created risers in model
STAIRS_TOTAL_NUMBER_OF_RISERS | -1,151,112 | "Total Number of Risers": Total number of risers
STAIRS_TOTAL_NUMBER_OF_TREADS | -1,151,113 | "Total Number of Treads": Total number of treads
STAIRS_RUN_WIDTH_MEASUREMENT | -1,151,116 | "Run Width Measurement": Run Width Measurement
STAIRS_MIN_AUTOMATIC_LANDING_DEPTH | -1,151,117 | "Minimum Automatic Landing Depth": The minimum depth of automatic landing
STAIRS_ENABLE_CALCULATION_RULE_CHECKING | -1,151,118 | "Enable Calculator Rules Check": Enable calculation rule checking
STAIRS_DBG_SHOW_TREAD_FACES | -1,151,131 | "Show Run's Tread Faces"
STAIRS_DBG_SHOW_LANDING_FACES | -1,151,132 | "Show Landing Faces"
STAIRS_DBG_SHOW_LEFT_RUN_BOUNDARY_2D | -1,151,133 | "Show Run's Left Boundary 2D"
STAIRS_DBG_SHOW_RIGHT_RUN_BOUNDARY_2D | -1,151,134 | "Show Run's Right Boundary 2D"
STAIRS_DBG_SHOW_LEFT_RUN_BOUNDARY_3D | -1,151,135 | "Show Run's Left Boundary 3D"
STAIRS_DBG_SHOW_RIGHT_RUN_BOUNDARY_3D | -1,151,136 | "Show Run's Right Boundary 3D"
STAIRS_DBG_SHOW_RUN_PATH_2D | -1,151,137 | "Show Run's Path 2D"
STAIRS_DBG_SHOW_RUN_PATH_3D | -1,151,138 | "Show Run's Path 3D"
STAIRS_DBG_SHOW_RUN_RISER | -1,151,139 | "Show Run's Risers"
STAIRS_DBG_SHOW_RUN_NOSING | -1,151,140 | "Show Run's Nosings"
STAIRS_DBG_SHOW_RUN_OUTLINE_FOR_PLAN | -1,151,141 | "Show Run Outline For Plan"
STAIRS_DBG_SHOW_LANDING_BOUNDARY | -1,151,142 | "Show Landing Boundary"
STAIRS_DBG_SHOW_LANDING_PATH | -1,151,143 | "Show Landing Path"
STAIRS_DBG_SHOW_BOUNDARY_2D | -1,151,144 | "Show Stairs' Boundary 2D"
STAIRS_DBG_SHOW_BOUNDARY_3D | -1,151,145 | "Show Stairs' Boundary 3D"
STAIRS_DBG_SHOW_SUPPORT_PATH | -1,151,146 | "Show Support Path"
STAIRS_DBG_SHOW_RUN_GEOM | -1,151,147 | "Show Run Geometry"
STAIRS_DBG_SHOW_TRISER_GEOM | -1,151,148 | "Show Triser Geometry"
STAIRS_DBG_SHOW_MONOLITHIC_SUPPORT_GEOM | -1,151,149 | "Show Monolithic Support Geometry"
STAIRS_DBG_SHOW_RUN_CORSE_GEOM | -1,151,150 | "Show Run Corse Geometry"
STAIRS_DBG_SHOW_TRISER_CORSE_GEOM | -1,151,151 | "Show Triser Corse Geometry"
STAIRS_DBG_SHOW_MONOLITHIC_SUPPORT_CORSE_GEOM | -1,151,152 | "Show Monolithic Support Corse Geometry"
STAIRS_DBG_SHOW_ANNOTATION_CUT_MARK | -1,151,153 | "Cut by Cut Plane"
STAIRS_TRISER_NUMBER_BASE_INDEX | -1,151,154 | "Tread/Riser Start Number":
STAIRSTYPE_MAXIMUM_RISER_HEIGHT | -1,151,203 | "Max. Riser Height": Maximum Riser Height
STAIRSTYPE_MINIMUM_TREAD_DEPTH | -1,151,204 | "Min. Tread Depth": Minimum Tread Depth
STAIRSTYPE_MINIMUM_TREAD_WIDTH_INSIDE_BOUNDARY | -1,151,205 | "Min. Tread Depth on Winder Inner Boundary": Minimum Tread Width on Inside Boundary
STAIRSTYPE_CALCULATION_RULES | -1,151,206 | "Calculation Rules": Calculation Rules
STAIRSTYPE_RUN_TYPE | -1,151,207 | "Run Type": Run Type
STAIRSTYPE_LANDING_TYPE | -1,151,208 | "Landing Type": Landing Type
STAIRSTYPE_RIGHT_SIDE_SUPPORT_TYPE | -1,151,209 | "Right Support Type": Right Side Support Type
STAIRSTYPE_LEFT_SIDE_SUPPORT_TYPE | -1,151,210 | "Left Support Type": Left Side Support Type
STAIRSTYPE_INTERMEDIATE_SUPPORT_TYPE | -1,151,211 | "Middle Support Type": Intermediate Support Type
STAIRSTYPE_SHOW_CUTLINE | -1,151,212 | "Show Cut Line in Plan": Show Cut Line in Plan
STAIRSTYPE_SHOW_STAIR_PATH | -1,151,213 | "Show Stair Path in Plan": Show Stair Path in Plan
STAIRSTYPE_SHOW_UPDOWN | -1,151,214 | "Show Up/Down in Plan": Show Up/Down in Plan
STAIRSTYPE_WINDER_STEP_FRONT_MEASUREMENT | -1,151,215 | "Winder Algorithm": Winder Algorithm
STAIRSTYPE_MINIMUM_RUN_WIDTH | -1,151,216 | "Minimum Run Width": Minimum Run Width
STAIRSTYPE_NUMBER_OF_INTERMEDIATE_SUPPORTS | -1,151,217 | "Middle Support Number": Number of intermediate supports
STAIRSTYPE_IS_ASSEMBLED_STAIRS | -1,151,218 | "Assembled Stair": Whether stairs is assembled
STAIRSTYPE_CALC_RULE_RISER_MULTIPLIER | -1,151,219 | "Riser Multiplier": Calculation Rule Riser Multiplier
STAIRSTYPE_CALC_RULE_TREAD_MULTIPLIER | -1,151,220 | "Tread Multiplier": Calculation Rule Tread Multiplier
STAIRSTYPE_CALC_RULE_MAX_RESULT | -1,151,221 | "Max. Result": Calculation Rule Max Result
STAIRSTYPE_CALC_RULE_MIN_RESULT | -1,151,222 | "Min. Result": Calculation Rule Min Result
STAIRSTYPE_CALC_RULE_TARGET_RESULT | -1,151,223 | "Target Result": Calculation Rule Target Result
STAIRSTYPE_GEOMUNJOINED_END_CUT_STYLE | -1,151,224 | "Connection Method": Cut Style for Geometrically Unjoined End
STAIRSTYPE_NOTCH_EXTENSION | -1,151,225 | "Notch Extension":
STAIRSTYPE_NOTCH_THICKNESS | -1,151,226 | "Notch Thickness":
STAIRSTYPE_NOTCH_CUSTOM_WIDTH | -1,151,227 | "Custom":
STAIRSTYPE_NOTCH_HORIZONTAL_GAP | -1,151,228 | "Horizontal Gap Distance":
STAIRSTYPE_NOTCH_VERTICAL_GAP | -1,151,229 | "Vertical Gap Distance":
STAIRSTYPE_NOTCH_WIDTH | -1,151,230 | "Notch Width":
STAIRSTYPE_HAS_LEFT_SUPPORT | -1,151,231 | "Left Support":
STAIRSTYPE_HAS_RIGHT_SUPPORT | -1,151,232 | "Right Support":
STAIRSTYPE_CONSTRUCTION_METHOD | -1,151,233 | "Construction Method":
STAIRSTYPE_CUTMARK_TYPE | -1,151,234 | "Cut Mark Type": Cut Mark Type
STAIRSTYPE_RIGHT_SUPPORT_LATERAL_OFFSET | -1,151,235 | "Right Lateral Offset":
STAIRSTYPE_LEFT_SUPPORT_LATERAL_OFFSET | -1,151,236 | "Left Lateral Offset":
STAIRSTYPE_HAS_INTERMEDIATE_SUPPORT | -1,151,237 | "Middle Support": Whether stairs is assembled
STAIRS_RUN_BOTTOM_ELEVATION | -1,151,301 | "Relative Base Height": Relative height to stairs bottom elevation
STAIRS_RUN_TOP_ELEVATION | -1,151,302 | "Relative Top Height": Top height of run
STAIRS_RUN_HEIGHT | -1,151,303 | "Run Height": Run Height
STAIRS_RUN_EXTEND_BELOW_RISER_BASE | -1,151,304 | "Extend Below Riser Base": Extend Below Base
STAIRS_RUN_ACTUAL_NUMBER_OF_RISERS | -1,151,305 | "Actual Number of Risers": Actual Number of Risers
STAIRS_RUN_ACTUAL_NUMBER_OF_TREADS | -1,151,306 | "Actual Number of Treads": Actual Number of Treads
STAIRS_RUN_ACTUAL_RISER_HEIGHT | -1,151,307 | "Actual Riser Height": Actual Riser Height
STAIRS_RUN_ACTUAL_TREAD_DEPTH | -1,151,308 | "Actual Tread Depth": Actual Tread Depth
STAIRS_RUN_ACTUAL_RUN_WIDTH | -1,151,309 | "Actual Run Width": Actual Run Width
STAIRS_RUN_CENTER_MARK_VISIBLE | -1,151,313 | "Center Mark Visible": Center Mark Visible
STAIRS_RUN_STRUCTURAL | -1,151,314 | "Structural": Structural
STAIRS_RUN_OVERRIDDEN | -1,151,315 | "Overridden": Overridden
STAIRS_RUN_BEGIN_WITH_RISER | -1,151,316 | "Begin with Riser": Begin with Riser
STAIRS_RUN_END_WITH_RISER | -1,151,317 | "End with Riser": End with Riser
STAIRS_RUN_LOCATIONPATH_JUSTFICATION | -1,151,318 | "Location Line": Location Line
STAIRS_RUN_WINDER_BEGIN_WITH_STRAIGHT | -1,151,319 | "Begin with Straight Run": Winder begin with straight run
STAIRS_RUN_WINDER_END_WITH_STRAIGHT | -1,151,320 | "End with Straight Run": Winder end with straight run
STAIRS_RUN_CREATE_AUTO_LANDING | -1,151,321 | "With Automatic Landing": Create automatic landing
STAIRS_RUN_CCW | -1,151,322 | "CCW": Revert the run preview
STAIRS_RUN_EXTEND_BELOW_TREAD_BASE | -1,151,323 | "Extend Below Tread Base": Extend Below Tread Base
STAIRS_RUNTYPE_HAS_MONOLITHIC_SUPPORT | -1,151,401 | "Monolithic Support": Monolithic Support
STAIRS_RUNTYPE_UNDERSIDE_SURFACE_TYPE | -1,151,402 | "Underside Surface": Underside Surface
STAIRS_RUNTYPE_STRUCTURE | -1,151,403 | "Structure": Structure
STAIRS_RUNTYPE_STRUCTURAL_DEPTH | -1,151,404 | "Structural Depth": Structural Depth
STAIRS_RUNTYPE_TOTAL_DEPTH | -1,151,405 | "Total Depth": Total Depth
STAIRS_RUNTYPE_RUN_MATERIAL | -1,151,406 | "Monolithic Material": Material
STAIRS_LANDING_BASE_ELEVATION | -1,151,501 | "Relative Height": Height
STAIRS_LANDING_STRUCTURAL | -1,151,502 | "Structural": Structural
STAIRS_LANDING_THICKNESS | -1,151,507 | "Total Thickness": Thickness
STAIRS_LANDING_OVERRIDDEN | -1,151,508 | "Overridden": Overridden
STAIRS_LANDINGTYPE_HAS_MONOLITHIC_SUPPORT | -1,151,601 | "Monolithic Support": Monolithic Support
STAIRS_LANDINGTYPE_STRUCTURE | -1,151,602 | "Structure": Structure
STAIRS_LANDINGTYPE_THICKNESS | -1,151,603 | "Monolithic Thickness": Default thickness
STAIRS_LANDINGTYPE_USE_SAME_TRISER_AS_RUN | -1,151,604 | "Same as Run": Same as Run
STAIRS_LANDINGTYPE_TREADRISER_TYPE | -1,151,605 | "Type": Tread/Riser Type
STAIRS_LANDINGTYPE_LANDING_MATERIAL | -1,151,606 | "Monolithic Material": Landing Material
STAIRS_SUPPORT_HORIZONTAL_OFFSET | -1,151,701 | "Lateral Offset": Distance from center or edge of boundary
STAIRS_SUPPORT_VERTICAL_OFFSET | -1,151,702 | "Vertical Offset": Distance of top plane of edge stringer relative to the plane connecting tread nosing
STAIRS_SUPPORT_LOWER_END_CUT | -1,151,705 | "Lower End Cut": Lower End Cut
STAIRS_SUPPORT_UPPER_END_CUT | -1,151,706 | "Upper End Cut": Upper End Cut
STAIRS_SUPPORT_TRIM_SUPPORT_UPPER | -1,151,708 | "Trim Support at Upper": Trim Support at Upper
STAIRS_SUPPORT_OVERRIDDEN | -1,151,709 | "Overridden": Overridden
STAIRS_SUPPORT_LANDINGSUPPORT_TYPE | -1,151,710 | "Landing Support Type": Landing Support Type
STAIRS_SUPPORTTYPE_SECTION_PROFILE | -1,151,801 | "Section Profile": Section Profile
STAIRS_SUPPORTTYPE_TOPSIDE_SURFACE | -1,151,803 | "Topside Surface": Topside Surface
STAIRS_SUPPORTTYPE_UNDERSIDE_SURFACE | -1,151,804 | "Underside Surface": Underside Surface
STAIRS_SUPPORTTYPE_STRUCTURAL_DEPTH | -1,151,805 | "Structural Depth": Structural Depth
STAIRS_SUPPORTTYPE_TOTAL_DEPTH | -1,151,806 | "Total Depth": Total Depth
STAIRS_SUPPORTTYPE_WIDTH | -1,151,807 | "Width": Width
STAIRS_SUPPORTTYPE_MATERIAL | -1,151,808 | "Material": Material
STAIRS_SUPPORTTYPE_STRUCTURAL_DEPTH_ON_RUN | -1,151,809 | "Structural Depth On Run": Structural Depth
STAIRS_SUPPORTTYPE_STRUCTURAL_DEPTH_ON_LANDING | -1,151,810 | "Structural Depth On Landing": Structural Depth
STAIRS_SUPPORTTYPE_FLIP_SECTION_PROFILE | -1,151,811 | "Flip Section Profile": Flip Section Profile
STAIRS_WINDERPATTERN_WINDER_STYLE | -1,151,901 | "Winder Style": Winder Style
STAIRS_WINDERPATTERN_MINIMUM_WIDTH_CORNER | -1,151,902 | "Minimum Width on Inside Boundary": Minimum Width on Inside Boundary
STAIRS_WINDERPATTERN_MINIMUM_WIDTH_INSIDE_WALKLINE | -1,151,903 | "Minimum Width on Inside Walk Line": Minimum width on inside walkline
STAIRS_WINDERPATTERN_STAIR_PATH_OFFSET | -1,151,904 | "Inside Walk Line Offset": The offset from inside walk line to interior boundary
STAIRS_WINDERPATTERN_FILLET_INSIDE_CORNER | -1,151,905 | "Fillet on Corner": Fillet on inside corner
STAIRS_WINDERPATTERN_RADIUS_INTERIOR | -1,151,906 | "Fillet Radius": The fillet corner radius on the interior boundary
STAIRS_WINDERPATTERN_NUMBER_OF_STRAIGHT_STEPS_AT_BEGIN | -1,151,907 | "Parallel Treads at Start": Number of straight steps at the begin of winder
STAIRS_WINDERPATTERN_NUMBER_OF_STRAIGHT_STEPS_AT_END | -1,151,908 | "Parallel Treads at End": Number of straight steps at the begin of winder
STAIRS_TRISER_IS_TYPE_OVERRIDDEN | -1,152,101 | "Overridden": (OBSOLETE) Indicate whether selected individual step is governed by default type setting.
STAIRS_TRISER_TREAD_NUMBER | -1,152,102 | "Tread Number": Count the sequential number of tread in the stair.
STAIRS_TRISER_RISER_NUMBER | -1,152,103 | "Riser Number": Count the sequential number of riser in the stair.
STAIRS_TRISER_TREAD_MARK | -1,152,104 | "Tread Mark": (OBSOLETE)
STAIRS_TRISER_RISER_MARK | -1,152,105 | "Riser Mark": (OBSOLETE)
STAIRS_TRISERTYPE_TREAD | -1,152,151 | "Tread"
STAIRS_TRISERTYPE_TREAD_THICKNESS | -1,152,152 | "Tread Thickness"
STAIRS_TRISERTYPE_NOSING_PROFILE | -1,152,153 | "Nosing Profile"
STAIRS_TRISERTYPE_NOSING_LENGTH | -1,152,154 | "Nosing Length"
STAIRS_TRISERTYPE_FRONT_NOSING | -1,152,155 | "Front Nosing": (OBSOLETE)
STAIRS_TRISERTYPE_RIGHT_NOSING | -1,152,156 | "Right Nosing": (OBSOLETE)
STAIRS_TRISERTYPE_LEFT_NOSING | -1,152,157 | "Left Nosing": (OBSOLETE)
STAIRS_TRISERTYPE_BACK_NOSING | -1,152,158 | "Back Nosing": (OBSOLETE)
STAIRS_TRISERTYPE_RISER_STYLE | -1,152,159 | "Riser Type": (OBSOLETE)
STAIRS_TRISERTYPE_RISER_THICKNESS | -1,152,160 | "Riser Thickness"
STAIRS_TRISERTYPE_RISER_TREAD_CONNECTION | -1,152,161 | "Riser To Tread Connection"
STAIRS_TRISERTYPE_TREAD_MATERIAL | -1,152,162 | "Tread Material"
STAIRS_TRISERTYPE_RISER_MATERIAL | -1,152,163 | "Riser Material"
STAIRS_TRISERTYPE_TREAD_PROFILE | -1,152,164 | "Tread Profile"
SUPPORT_HAND_CLEARANCE | -1,152,165 | "Hand Clearance"
SUPPORT_HEIGHT | -1,152,166 | "Height"
TERMINATION_EXTENSION_LENGTH | -1,152,167 | "Extension Length"
STAIRS_TRISERTYPE_RISER_PROFILE | -1,152,174 | "Riser Profile"
STAIRS_TRISERTYPE_NOSING_PLACEMENT | -1,152,175 | "Apply Nosing Profile"
STAIRS_TRISERTYPE_RISER | -1,152,176 | "Riser"
STAIRS_TRISERTYPE_RISER_IS_SLANTED | -1,152,177 | "Slanted"
STAIRS_RAILING_PLACEMENT_OFFSET | -1,152,300 | "Offset from Path"
PHY_MATERIAL_PARAM_YOUNG_MOD_1 | -1,152,301 | "Young's Modulus 1"
PHY_MATERIAL_PARAM_YOUNG_MOD_2 | -1,152,302 | "Young's Modulus 2"
PHY_MATERIAL_PARAM_POISSON_MOD_12 | -1,152,303 | "Poisson Ratio 12"
PHY_MATERIAL_PARAM_POISSON_MOD_23 | -1,152,304 | "Poisson Ratio 23"
PHY_MATERIAL_PARAM_SHEAR_MOD_12 | -1,152,305 | "Shear Modulus 12"
PHY_MATERIAL_PARAM_EXP_COEFF_1 | -1,152,306 | "Thermal Expansion Coefficient 1"
PHY_MATERIAL_PARAM_EXP_COEFF_2 | -1,152,307 | "Thermal Expansion Coefficient 2"
PHY_MATERIAL_PARAM_THERMAL_CONDUCTIVITY | -1,152,308 | "Thermal Conductivity"
PHY_MATERIAL_PARAM_THERMAL_CONDUCTIVITY_X | -1,152,309 | "Thermal Conductivity X"
PHY_MATERIAL_PARAM_THERMAL_CONDUCTIVITY_Y | -1,152,310 | "Thermal Conductivity Y"
PHY_MATERIAL_PARAM_THERMAL_CONDUCTIVITY_Z | -1,152,311 | "Thermal Conductivity Z"
PHY_MATERIAL_PARAM_STRUCTURAL_SPECIFIC_HEAT | -1,152,312 | "Specific Heat"
PHY_MATERIAL_PARAM_STRUCTURAL_DENSITY | -1,152,313 | "Density"
PHY_MATERIAL_PARAM_STRUCTURAL_THERMAL_TREATED | -1,152,314 | "Thermally Treated"
PHY_MATERIAL_PARAM_TENSION_PARALLEL | -1,152,315 | "Tension Parallel to Grain"
PHY_MATERIAL_PARAM_TENSION_PERPENDICULAR | -1,152,316 | "Tension Perpendicular to Grain"
PHY_MATERIAL_PARAM_AVERAGE_MODULUS | -1,152,317 | "Average Modulus"
PHY_MATERIAL_PARAM_FIVEPERCENT_MODULUS_OF_ELACTICITY | -1,152,318 | "5% Modulus of Elasticity"
PHY_MATERIAL_PARAM_WOOD_CONSTRUCTION | -1,152,319 | "Construction"
THERMAL_MATERIAL_PARAM_EMISSIVITY | -1,152,320 | "Emissivity"
THERMAL_MATERIAL_PARAM_GAS_VISCOSITY | -1,152,321 | "Gas Viscosity"
THERMAL_MATERIAL_PARAM_COMPRESSIBILITY | -1,152,322 | "Compressibility"
THERMAL_MATERIAL_PARAM_LIQUID_VISCOSITY | -1,152,323 | "Liquid Viscosity"
THERMAL_MATERIAL_PARAM_SPECIFIC_HEAT_OF_VAPORIZATION | -1,152,324 | "Specific Heat of Vaporization"
THERMAL_MATERIAL_PARAM_VAPOR_PRESSURE | -1,152,325 | "Vapor Pressure"
THERMAL_MATERIAL_PARAM_TRANSMITS_LIGHT | -1,152,326 | "Transmits Light"
THERMAL_MATERIAL_PARAM_PERMEABILITY | -1,152,327 | "Permeability"
THERMAL_MATERIAL_PARAM_POROSITY | -1,152,328 | "Porosity"
THERMAL_MATERIAL_PARAM_REFLECTIVITY | -1,152,329 | "Reflectivity"
THERMAL_MATERIAL_PARAM_ELECTRICAL_RESISTIVITY | -1,152,330 | "Electrical Resistivity"
POINT_ADAPTIVE_ORIENTATION_TYPE | -1,152,331 | "Orients to"
POINT_ADAPTIVE_CONSTRAINED | -1,152,332 | "Constrained"
POINT_ADAPTIVE_SHOW_NUMBER | -1,152,333 | "Show Placement Number"
POINT_ADAPTIVE_NUM_PARAM | -1,152,334 | "Number"
DPART_BASE_LEVEL | -1,152,335 | "Base Level"
DPART_BASE_LEVEL_BY_ORIGINAL | -1,152,336 | "Base Level By Original"
MATERIAL_ASSET_PARAM_ASSET_LIB_ID | -1,152,337 | "Asset library id"
MATERIAL_ASSET_PARAM_COMMON_SHARED_ASSET | -1,152,338 | "Sharing"
MATERIAL_ASSET_PARAM_EXTERNAL_MATERIAL_ID | -1,152,339 | "External Material ID"
MATERIAL_ASSET_PARAM_SOURCE | -1,152,340 | "Source"
MATERIAL_ASSET_PARAM_SOURCE_URL | -1,152,341 | "Source URL"
PROPERTY_SET_KEYWORDS | -1,152,342 | "Keywords"
ANALYTICAL_MODEL_MANUALLY_ADJUSTED | -1,152,343 | "Manually Adjusted"
DPART_EXCLUDED | -1,152,344 | "Excluded"
DPART_SHAPE_MODIFIED | -1,152,345 | "Shape is modified"
DIVISION_PATTERN | -1,152,346 | "Division Pattern"
PATTERN_INDENT_1_FOR_DIVISION_RULE | -1,152,347 | "Indent 1"
PATTERN_INDENT_2_FOR_DIVISION_RULE | -1,152,348 | "Indent 2"
ALL_GRID_ROTATION_FOR_DIVISION_RULE | -1,152,349 | "All Grid Rotation"
PATTERN_MIRROR_FOR_DIVISION_RULE | -1,152,350 | "Mirror"
DIVISION_RULE_PARAM | -1,152,351 | "Division Rule"
DIVISION_SKETCH_CURVE_EXTENTD_TO_SILH_PARAM | -1,152,352 | "Extend to Silhouette"
DIVISION_SKETCH_CURVE_DIVISION_PARAMS_OVERRIDE_PARAM | -1,152,356 | "Profile Override"
START_EXTENSION | -1,152,357 | "Start Extension"
END_EXTENSION | -1,152,358 | "End Extension"
START_JOIN_CUTBACK | -1,152,359 | "Start Join Cutback"
END_JOIN_CUTBACK | -1,152,360 | "End Join Cutback"
YZ_JUSTIFICATION | -1,152,361 | "yz Justification"
Y_JUSTIFICATION | -1,152,362 | "y Justification"
Y_OFFSET_VALUE | -1,152,363 | "y Offset Value"
Z_JUSTIFICATION | -1,152,364 | "z Justification"
Z_OFFSET_VALUE | -1,152,365 | "z Offset Value"
START_Y_JUSTIFICATION | -1,152,366 | "Start y Justification"
START_Y_OFFSET_VALUE | -1,152,367 | "Start y Offset Value"
START_Z_JUSTIFICATION | -1,152,368 | "Start z Justification"
START_Z_OFFSET_VALUE | -1,152,369 | "Start z Offset Value"
END_Y_JUSTIFICATION | -1,152,370 | "End y Justification"
END_Y_OFFSET_VALUE | -1,152,371 | "End y Offset Value"
END_Z_JUSTIFICATION | -1,152,372 | "End z Justification"
END_Z_OFFSET_VALUE | -1,152,373 | "End z Offset Value"
FAM_PROFILE_DEFINITION | -1,152,374 | "Profile Definition"
FAMILY_ROUNDCONNECTOR_DIMENSIONTYPE | -1,152,375 | "Round Connector Dimension"
RBS_ENERGY_ANALYSIS_BUILDING_ENVELOPE_ANALYTICAL_SPACE_IDENTIFICATION_RESOLUTION | -1,152,376 | "Analytical Space Resolution"
RBS_ENERGY_ANALYSIS_BUILDING_ENVELOPE_ANALYTICAL_SURFACE_IDENTIFICATION_RESOLUTION | -1,152,377 | "Analytical Surface Resolution"
RBS_ENERGY_ANALYSIS_MODE | -1,152,378 | "Mode"
ENERGY_ANALYSIS_ADVANCED_OPTIONS | -1,152,379 | "Other Options"
REFERENCED_VIEW | -1,152,380 | "Referenced View": The view referenced by a section or callout.
STRUCT_FRAM_JOIN_STATUS | -1,152,383 | "Join Status"
ALL_MODEL_TYPE_IMAGE | -1,152,384 | "Type Image"
ALL_MODEL_IMAGE | -1,152,385 | "Image"
STRUCTURAL_CONNECTION_SYMBOL | -1,152,999 | "Connection Symbol"
STRUCTURAL_CONNECTION_MODIFY_CONNECTION_PARAMETERS | -1,153,000 | "Detailed Parameters"
STRUCTURAL_CONNECTION_APPROVAL_STATUS | -1,153,001 | "Approval Status"
STRUCTURAL_CONNECTION_CODE_CHECKING_STATUS | -1,153,002 | "Code Checking Status"
STRUCTURAL_CONNECTION_NOBLE_STATUS | -1,153,003 | "Noble Status"
STRUCTURAL_CONNECTION_INPUT_ELEMENTS | -1,153,004 | "Input Elements"
MEP_EQUIPMENT_CLASSIFICATION | -1,153,100 | "Classification"
MEP_EQUIPMENT_CALC_PIPINGFLOW_PARAM | -1,153,103 | "Calculated Flow"
MEP_EQUIPMENT_CALC_PIPINGPRESSUREDROP_PARAM | -1,153,104 | "Calculated Pressure Drop"
MEP_ANALYTICAL_PIPE_DESIGNFLOW | -1,153,105 | "Design Flow"
MEP_ANALYTICAL_CRITICALPATH_PARAM | -1,153,106 | "Critical Path"
MECHANICAL_EQUIPMENT_SET_ON_DUTY | -1,153,109 | "On Duty"
MECHANICAL_EQUIPMENT_SET_ON_STANDBY | -1,153,110 | "On Standby"
MECHANICAL_EQUIPMENT_SET_NAME | -1,153,111 | "Name"
MECHANICAL_EQUIPMENT_SET_ID_PARAM | -1,153,112 | "Mechanical Equipment Set"
MEP_ANALYTICAL_LOOP_BOUNDARY_PARAM | -1,153,113 | "Loop Boundary"
MEP_IGNORE_FLOW_ANALYSIS | -1,153,114 | "Ignore Flow Analysis"
SYSTEM_EQUIPMENT_SETS | -1,153,115 | "Equipment Sets"
MEP_ANALYTICAL_ELEC_CURRENT_RATING | -1,153,116 | "Current Rating"
MEP_ANALYTICAL_ELEC_VOLTAGE | -1,153,117 | "Voltage"
MEP_ANALYTICAL_ELEC_CURRENT | -1,153,118 | "Current"
MEP_ANALYTICAL_NETWORK | -1,153,119 | "Network Id"
MEP_ANALYTICAL_HEADERSEGMENT | -1,153,120 | "Header"
MEP_ANALYTICAL_CRITICALSEQUENCE | -1,153,121 | "Critical Sequence"
MEP_ANALYTICAL_HYDRAULICLOOP | -1,153,122 | "Hydraulic Loop"
MEP_ANALYTICAL_ELEC_APPARENT_POWER_RATING | -1,153,123 | "Apparent Power Rating"
MEP_SEGMENT_LENGTH | -1,153,124 | "Analytical Length"
MEP_SEGMENT_SYSTEMORSERVICE | -1,153,125 | "System Type/Service Name"
MEP_SEGMENT_FAMILYNAME | -1,153,126 | "Family Name"
MEP_SEGMENT_ELEMENT_TYPENAME | -1,153,127 | "Type Name"
MEP_ANALYTICAL_LOOP_NAME | -1,153,500 | "Name"
MEP_WATERLOOP_TYPE | -1,153,501 | "Loop Type"
MEP_WATERLOOP_CHILLERTYPE | -1,153,502 | "Chiller Type"
MEP_CONDENSER_WATER_LOOP | -1,153,503 | "Condenser Water Loop"
MEP_AIRLOOP_HEATEXCHANGER_TYPE | -1,153,504 | "Heat Exchanger"
MEP_AIRLOOP_PREHEAT_COILTYPE | -1,153,505 | "Preheat Coil"
MEP_PREHEAT_HOTWATER_LOOP | -1,153,506 | "Preheat Hot Water Loop"
MEP_HEATING_COIL_TYPE | -1,153,507 | "Heating Coil"
MEP_HEATING_HOTWATER_LOOP | -1,153,508 | "Heating Hot Water Loop"
MEP_COOLING_COIL_TYPE | -1,153,509 | "Cooling Coil"
MEP_CHILLED_WATER_LOOP | -1,153,510 | "Chilled Water Loop"
MEP_AIRLOOP_FANTYPE | -1,153,511 | "Fan"
MEP_ZONE_EQUIPMENT_TYPE | -1,153,512 | "Equipment Type"
MEP_ZONE_EQUIPMENT_BEHAVIOR | -1,153,513 | "Behavior"
MEP_REHEAT_COIL_TYPE | -1,153,514 | "Reheat Coil"
MEP_ZONE_AIR_LOOP | -1,153,516 | "Air System"
MEP_ZONE_HOTWATER_LOOP | -1,153,517 | "Heating Hot Water Loop"
MEP_ANALYTICAL_EQUIPMENT_NAME | -1,153,518 | "Name"
MEP_ZONE_EQUIPMENT | -1,153,519 | "Zone Equipment"
MEP_REHEAT_HOTWATER_LOOP | -1,153,526 | "Reheat Hot Water Loop"
MEP_VRF_LOOP | -1,153,527 | "Variable Refrigerant Flow Loop"
MEP_ZONE_EQUIPMENT_DRAW_VENTILATION | -1,153,528 | "Draw Ventilation"
MEP_ELEC_ZONE_EQUIPMENT_TYPE | -1,153,529 | "Equipment Type"
RBS_ELEC_ANALYTICAL_LOAD_DENSITY | -1,153,532 | "Power Density"
RBS_AREA_BASED_LOAD_TYPE | -1,153,533 | "Area Based Load Type"
RBS_ELEC_ANALYTICAL_LOAD_TYPE_PARAM | -1,153,535 | "Load Type"
RBS_ELEC_ANALYTICAL_LOAD_NAME_PARAM | -1,153,537 | "Name"
RBS_ELEC_ANALYTICAL_LOAD_SET_ON_TOTAL | -1,153,538 | "Total Quantity"
RBS_ELEC_DISTRIBUTION_NODE_SUPPLY_FROM1 | -1,153,539 | "Supply From 1"
RBS_ELEC_DISTRIBUTION_NODE_SUPPLY_FROM | -1,153,541 | "Supply From"
RBS_ELEC_DISTRIBUTION_NODE_SUPPLY_FROM2 | -1,153,542 | "Supply From 2"
RBS_ELEC_APPARENT_POWER_DENSITY | -1,153,543 | "Apparent Power Density"
RBS_ELEC_ANALYTICAL_LEVEL_ID | -1,153,544 | "Level"
RBS_ELEC_ANALYTICAL_FEEDER_LENGTH | -1,153,545 | "Length"
RBS_ELEC_DISTRIBUTION_NODE_SUPPLY_TO | -1,153,546 | "Supply To"
RBS_ELEC_DISTRIBUTION_NODE_LOAD_SET | -1,153,547 | "Load Set"
RBS_ELEC_ANALYTICAL_LOAD_SET_ON_DUTY | -1,153,548 | "Quantity of Prime"
RBS_ELEC_ANALYTICAL_LOAD_SET_ON_STANDBY | -1,153,549 | "Quantity on Standby"
RBS_ELEC_ANALYTICAL_LOADS_IN_SET | -1,153,550 | "Loads in Set"
RBS_ELEC_ANALYTICAL_AREA | -1,153,551 | "Area"
RBS_ELEC_ANALYTICAL_NUMPHASES | -1,153,552 | "Number of Phases"
RBS_ELEC_ANALYTICAL_CONNECTED_PHASE | -1,153,553 | "Connected Phases"
RBS_ELEC_ANALYTICAL_HIGH_LEG_PHASE | -1,153,554 | "High-leg Phase"
RBS_ELEC_ANALYTICAL_SECONDARY_HIGH_LEG_PHASE | -1,153,555 | "Secondary High-leg Phase"
RBS_ELEC_ANALYTICAL_DOWNSTREAM_CONNECTED_PHASES | -1,153,556 | "Downstream Connected Phases"
VIEW_SHOW_HIDDEN_LINES | -1,154,613 | "Show Hidden Lines"
NUMBER_PARTITION_PARAM | -1,154,614 | "Partition"
GRAPHIC_DISPLAY_OPTIONS_SKETCHY_LINES | -1,154,615 | "Sketchy Lines"
REBAR_NUMBER | -1,154,616 | "Rebar Number"
FABRIC_NUMBER | -1,154,617 | "Fabric Number"
REBAR_SHAPE_IMAGE | -1,154,618 | "Shape Image"
REBAR_ELEM_HOST_MARK | -1,154,619 | "Host Mark"
MULTISTORY_STAIRS_REF_LEVEL | -1,154,630 | "Reference Level": The reference level of stairs
MULTISTORY_STAIRS_ACTUAL_TREAD_DEPTH | -1,154,634 | "Actual Tread Depth"
COUPLER_CODE | -1,154,638 | "Part Number"
COUPLER_MAIN_BAR_SIZE | -1,154,639 | "Bar Size 1"
COUPLER_COUPLED_BAR_SIZE | -1,154,640 | "Bar Size 2"
COUPLER_QUANTITY | -1,154,641 | "Quantity"
COUPLER_NUMBER | -1,154,642 | "Coupler Number"
COUPLER_WEIGHT | -1,154,643 | "Mass"
COUPLER_LENGTH | -1,154,644 | "Total Length"
COUPLER_MAIN_ENGAGEMENT | -1,154,645 | "Bar Engagement 1"
COUPLER_COUPLED_ENGAGEMENT | -1,154,646 | "Bar Engagement 2"
FAMILY_FREEINST_DEFAULT_ELEVATION | -1,154,647 | "Default Elevation"
COUPLER_MARK | -1,154,649 | "Schedule Mark"
COUPLER_WIDTH | -1,154,651 | "External Diameter"
COUPLER_MAIN_ENDTREATMENT | -1,154,652 | "End Treatment 1"
COUPLER_COUPLED_ENDTREATMENT | -1,154,653 | "End Treatment 2"
END_TREATMENT | -1,154,654 | "End Treatment"
REBAR_ELEM_ENDTREATMENT_START | -1,154,655 | "End Treatment At Start"
REBAR_ELEM_ENDTREATMENT_END | -1,154,656 | "End Treatment At End"
REBAR_SHAPE_ENDTREATMENT_START_TYPE | -1,154,657 | "End Treatment At Start"
REBAR_SHAPE_ENDTREATMENT_END_TYPE | -1,154,658 | "End Treatment At End"
REBAR_INTERNAL_MULTIPLANAR_ARC_CONNECTOR | -1,154,659 | "INTERNAL: Multiplanar Arc Connector"
ROOM_OUTDOOR_AIR_INFO_PARAM | -1,154,662 | "Outdoor Air Information"
ROOM_OUTDOOR_AIR_PER_PERSON_PARAM | -1,154,665 | "Outdoor Air per Person"
ROOM_OUTDOOR_AIR_PER_AREA_PARAM | -1,154,668 | "Outdoor Air per Area"
ROOM_AIR_CHANGES_PER_HOUR_PARAM | -1,154,671 | "Air Changes per Hour"
DIRECTCONTEXT3D_NAME | -1,154,675 | "Name"
DIRECTCONTEXT3D_SERVER_ID | -1,154,676 | "ServerId"
DIRECTCONTEXT3D_LOADED | -1,154,677 | "Loaded"
DIRECTCONTEXT3D_APPLICATION_ID | -1,154,685 | "ApplicationId"
DIRECTCONTEXT3D_SOURCE_ID | -1,154,686 | "Path"
ROOM_OUTDOOR_AIRFLOW_STANDARD_PARAM | -1,154,687 | "Outdoor Air Method"
ROOM_OUTDOOR_AIRFLOW_PARAM | -1,154,689 | "Outdoor Airflow"
REBAR_FREE_FORM_HOOK_START_PLANE_ANGLE | -1,154,690 | "Hook Orientation At Start"
REBAR_FREE_FORM_HOOK_END_PLANE_ANGLE | -1,154,691 | "Hook Orientation At End"
BASEPOINT_LONGITUDE_PARAM | -1,154,692 | "Lon"
BASEPOINT_LATITUDE_PARAM | -1,154,693 | "Lat"
REBAR_GEOMETRY_TYPE | -1,154,694 | "Geometry"
REBAR_WORKSHOP_INSTRUCTIONS | -1,154,695 | "Workshop Instructions"
STEEL_ELEM_PLATE_THICKNESS | -1,155,003 | "Thickness"
STEEL_ELEM_BOLT_STANDARD | -1,155,005 | "Standard"
STEEL_ELEM_BOLT_GRADE | -1,155,006 | "Grade"
STEEL_ELEM_BOLT_ASSEMBLY | -1,155,007 | "Assembly"
STEEL_ELEM_BOLT_DIAMETER | -1,155,008 | "Diameter"
STEEL_ELEM_COATING | -1,155,009 | "Coating"
STEEL_ELEM_ANCHOR_STANDARD | -1,155,010 | "Standard"
STEEL_ELEM_ANCHOR_GRADE | -1,155,011 | "Grade"
STEEL_ELEM_ANCHOR_ASSEMBLY | -1,155,012 | "Assembly"
STEEL_ELEM_ANCHOR_DIAMETER | -1,155,013 | "Diameter"
STEEL_ELEM_SHEARSTUD_STANDARD | -1,155,014 | "Standard"
STEEL_ELEM_SHEARSTUD_GRADE | -1,155,015 | "Grade"
STEEL_ELEM_SHEARSTUD_DIAMETER | -1,155,016 | "Diameter"
STEEL_ELEM_ANCHOR_LENGTH | -1,155,017 | "Length"
STEEL_ELEM_BOLT_COATING | -1,155,018 | "Coating"
STEEL_ELEM_SHEARSTUD_LENGTH | -1,155,019 | "Length"
STEEL_ELEM_SHORTEN_REFLENGTH | -1,155,020 | "Length"
STEEL_ELEM_SHORTEN_ANGLEY | -1,155,021 | "Angle along height"
STEEL_ELEM_SHORTEN_ANGLEZ | -1,155,022 | "Angle along width"
STEEL_ELEM_CONTOUR_GAP_WIDTH | -1,155,023 | "Gap Width"
STEEL_ELEM_CONTOUR_SIDE1DIST | -1,155,026 | "Boundary distance 1"
STEEL_ELEM_CONTOUR_SIDE2DIST | -1,155,027 | "Boundary distance 2"
STEEL_ELEM_PARAM_RADIUS | -1,155,028 | "Radius"
STEEL_ELEM_PARAM_BORINGOUT | -1,155,029 | "Boring out"
STEEL_ELEM_WELD_MAIN_TYPE | -1,155,031 | "Main Type"
STEEL_ELEM_WELD_MAIN_THICKNESS | -1,155,032 | "Main Thickness"
STEEL_ELEM_WELD_LENGTH | -1,155,033 | "Length"
STEEL_ELEM_WELD_LOCATION | -1,155,034 | "Location"
STEEL_ELEM_WELD_CONTINUOUS | -1,155,035 | "Continuous"
STEEL_ELEM_WELD_PITCH | -1,155,036 | "Pitch"
STEEL_ELEM_WELD_MAIN_TEXT | -1,155,037 | "Main Text"
STEEL_ELEM_WELD_MAIN_SURFACESHAPE | -1,155,038 | "Surface Shape"
STEEL_ELEM_WELD_MAIN_WELDPREP | -1,155,039 | "Main Weld preparation"
STEEL_ELEM_WELD_MAIN_ROOTOPENING | -1,155,040 | "Main Root Opening"
STEEL_ELEM_WELD_MAIN_EFFECTIVETHROAT | -1,155,041 | "Main Effective Throat"
STEEL_ELEM_WELD_MAIN_PREPDEPTH | -1,155,042 | "Main Preparation Depth"
STEEL_ELEM_WELD_DOUBLE_TYPE | -1,155,043 | "Double Type"
STEEL_ELEM_WELD_DOUBLE_THICKNESS | -1,155,044 | "Double Thickness"
STEEL_ELEM_WELD_DOUBLE_TEXT | -1,155,045 | "Double Text"
STEEL_ELEM_WELD_DOUBLE_SURFACESHAPE | -1,155,046 | "Double Surface Shape"
STEEL_ELEM_WELD_DOUBLE_WELDPREP | -1,155,047 | "Double Weld preparation"
STEEL_ELEM_WELD_DOUBLE_ROOTOPENING | -1,155,048 | "Double Root Opening"
STEEL_ELEM_WELD_DOUBLE_EFFECTIVETHROAT | -1,155,049 | "Double Effective Throat"
STEEL_ELEM_WELD_DOUBLE_PREPDEPTH | -1,155,050 | "Double Preparation Depth"
STEEL_ELEM_PATTERN_NUMBER_X | -1,155,051 | "Number on side 1"
STEEL_ELEM_PATTERN_NUMBER_Y | -1,155,052 | "Number on side 2"
STEEL_ELEM_PATTERN_TOTAL_LENGTH | -1,155,053 | "Length on side 1"
STEEL_ELEM_PATTERN_TOTAL_WIDTH | -1,155,054 | "Length on side 2"
STEEL_ELEM_PATTERN_INTERMEDIATE_DISTANCE_X | -1,155,055 | "Intermediate distance on side 1"
STEEL_ELEM_PATTERN_INTERMEDIATE_DISTANCE_Y | -1,155,056 | "Intermediate distance on side 2"
STEEL_ELEM_PATTERN_EDGE_DISTANCE_X | -1,155,057 | "Edge distance on side 1"
STEEL_ELEM_PATTERN_EDGE_DISTANCE_Y | -1,155,058 | "Edge distance on side 2"
STEEL_ELEM_PATTERN_RADIUS | -1,155,059 | "Radius"
STEEL_ELEM_PATTERN_NUMBER | -1,155,060 | "Number"
STEEL_ELEM_HOLE_DIAMETER | -1,155,061 | "Diameter"
STEEL_ELEM_HOLE_TYPE | -1,155,062 | "Type"
STEEL_ELEM_HOLE_SLOT_LENGTH | -1,155,063 | "Length of the slot"
STEEL_ELEM_HOLE_SLOT_DIRECTION | -1,155,064 | "Along side 1"
STEEL_ELEM_HOLE_DEPTH | -1,155,065 | "Hole Depth"
STEEL_ELEM_HOLE_ALPHA | -1,155,066 | "Taper Angle"
STEEL_ELEM_HOLE_ANGLE | -1,155,067 | "Chamfer angle"
STEEL_ELEM_HOLE_HEAD_DIAMETER | -1,155,068 | "Head diameter"
STEEL_ELEM_HOLE_TAPPING_HOLE | -1,155,069 | "Tapping hole"
STEEL_ELEM_HOLE_BACK_TAPER_THREAD | -1,155,070 | "Back taper thread"
STEEL_ELEM_HOLE_TAPPING | -1,155,071 | "Right-handed thread"
STEEL_ELEM_HOLE_DEPTH_OF_BOLT_HEAD | -1,155,072 | "Depth of bolt head"
STEEL_ELEM_WELD_TEXT_MODULE | -1,155,073 | "Text module"
STEEL_ELEM_WELD_PREFIX | -1,155,074 | "Prefix"
STEEL_ELEM_PLATE_SHORTEN_ANGLE | -1,155,075 | "Angle"
STEEL_ELEM_PLATE_SHORTEN_SUCTION | -1,155,076 | "Suction"
STEEL_ELEM_PLATE_SHORTEN_CUTSTRAIGHT | -1,155,077 | "Cut straight"
STEEL_ELEM_CUT_TYPE | -1,155,078 | "Type"
STEEL_ELEM_X_DISTANCE | -1,155,079 | "Side 1"
STEEL_ELEM_Y_DISTANCE | -1,155,080 | "Side 2"
STEEL_ELEM_COPE_WIDTHX | -1,155,081 | "Cutback"
STEEL_ELEM_COPE_DISTANCE_AXIS | -1,155,082 | "Distance from axis"
STEEL_ELEM_COPE_X_ANGLE | -1,155,083 | "Cross-section rotation"
STEEL_ELEM_COPE_Z_ANGLE | -1,155,084 | "Plan rotation"
STEEL_ELEM_COPE_AXIS_ANGLE | -1,155,085 | "Tilt angle"
STEEL_ELEM_COPE_AROUND_AXIS | -1,155,086 | "Around beam axis"
STEEL_ELEM_ZCLIP_TYPE | -1,155,087 | "Boundary"
PATH_OF_TRAVEL_TIME | -1,155,090 | "Time"
STRUCTURAL_CONNECTION_EDIT_TYPE | -1,155,091 | "Modify Parameters"
STRUCTURAL_CONNECTION_OVERRIDE_TYPE | -1,155,092 | "Override by Instance"
PATH_OF_TRAVEL_LEVEL_NAME | -1,155,093 | "Level"
PATH_OF_TRAVEL_VIEW_NAME | -1,155,094 | "View Name"
ROUTE_ANALYSIS_SETTINGS_PARAM | -1,155,095 | "Route Analysis Settings"
TAG_ON_PLACEMENT_UI | -1,155,096 | "Tag on Placement"
RBS_ELEC_CIRCUIT_NUMBERING_TYPE | -1,155,099 | "Circuit Numbering Option"
RBS_ELEC_PANEL_FEED_THRU_LUGS_PARAM | -1,155,100 | "Feed Through Lugs"
STEEL_ELEM_HOLE_DEFINITION | -1,155,101 | "Hole Definition"
RBS_ELEC_PANEL_BRANCH_CIRCUIT_APPARENT_LOAD_PHASEA | -1,155,102 | "Branch Circuit Apparent Power Phase A"
RBS_ELEC_PANEL_BRANCH_CIRCUIT_APPARENT_LOAD_PHASEB | -1,155,103 | "Branch Circuit Apparent Power Phase B"
RBS_ELEC_PANEL_BRANCH_CIRCUIT_APPARENT_LOAD_PHASEC | -1,155,104 | "Branch Circuit Apparent Power Phase C"
RBS_ELEC_PANEL_BRANCH_CIRCUIT_CURRENT_PHASEA | -1,155,105 | "Branch Circuit Current Phase A"
RBS_ELEC_PANEL_BRANCH_CIRCUIT_CURRENT_PHASEB | -1,155,106 | "Branch Circuit Current Phase B"
RBS_ELEC_PANEL_BRANCH_CIRCUIT_CURRENT_PHASEC | -1,155,107 | "Branch Circuit Current Phase C"
RBS_ELEC_PANEL_FEED_THRU_LUGS_APPARENT_LOAD_PHASEA | -1,155,108 | "Feed Through Lugs Apparent Power Phase A"
RBS_ELEC_PANEL_FEED_THRU_LUGS_APPARENT_LOAD_PHASEB | -1,155,109 | "Feed Through Lugs Apparent Power Phase B"
RBS_ELEC_PANEL_FEED_THRU_LUGS_APPARENT_LOAD_PHASEC | -1,155,110 | "Feed Through Lugs Apparent Power Phase C"
RBS_ELEC_PANEL_FEED_THRU_LUGS_CURRENT_PHASEA | -1,155,111 | "Feed Through Lugs Current Phase A"
RBS_ELEC_PANEL_FEED_THRU_LUGS_CURRENT_PHASEB | -1,155,112 | "Feed Through Lugs Current Phase B"
RBS_ELEC_PANEL_FEED_THRU_LUGS_CURRENT_PHASEC | -1,155,113 | "Feed Through Lugs Current Phase C"
RBS_PIPE_TOP_ELEVATION | -1,155,114 | "Upper End Top Elevation"
RBS_PIPE_BOTTOM_ELEVATION | -1,155,115 | "Lower End Bottom Elevation"
GENERIC_ZONE_NAME | -1,155,116 | "Name"
STEEL_ELEM_BOLT_LENGTH | -1,155,117 | "Bolt Length"
STEEL_ELEM_BOLT_GRIP_LENGTH | -1,155,118 | "Grip Length"
STEEL_ELEM_BOLT_GRIP_LENGTH_INCREASE | -1,155,119 | "Grip Length Increase"
STEEL_ELEM_BOLT_INVERTED | -1,155,120 | "Inverted"
STEEL_ELEM_BOLT_FINISH_CALCULATION_AT_GAP | -1,155,121 | "Finish Calculation At Gap"
STEEL_ELEM_BOLT_LOCATION | -1,155,122 | "Location"
PATH_OF_TRAVEL_SPEED | -1,155,123 | "Speed"
STEEL_ELEM_WEIGHT | -1,155,124 | "Weight"
STEEL_ELEM_PAINT_AREA | -1,155,125 | "Paint Area"
STEEL_ELEM_EXACT_WEIGHT | -1,155,127 | "Exact Weight"
STEEL_ELEM_CUT_LENGTH | -1,155,128 | "Cut Length"
STEEL_ELEM_ANCHOR_ORIENTATION | -1,155,130 | "Anchor Orientation"
STEEL_ELEM_ANCHOR_TOTAL_WEIGHT | -1,155,132 | "Total Weight"
STEEL_ELEM_SHEARSTUD_TOTAL_WEIGHT | -1,155,134 | "Total Weight"
STEEL_ELEM_BOLT_TOTAL_WEIGHT | -1,155,135 | "Total Weight"
STEEL_ELEM_PLATE_TYPE | -1,155,136 | "Type"
STEEL_ELEM_PLATE_LENGTH | -1,155,137 | "Length"
STEEL_ELEM_PLATE_WIDTH | -1,155,138 | "Width"
STEEL_ELEM_PLATE_AREA | -1,155,139 | "Area"
STEEL_ELEM_PLATE_VOLUME | -1,155,140 | "Volume"
STEEL_ELEM_PLATE_WEIGHT | -1,155,141 | "Weight"
STEEL_ELEM_PLATE_EXACT_WEIGHT | -1,155,142 | "Exact Weight"
STEEL_ELEM_PLATE_PAINT_AREA | -1,155,143 | "Paint Area"
STEEL_ELEM_PLATE_JUSTIFICATION | -1,155,144 | "Justification"
RBS_ELEC_EDIT_CIRCUIT_NAMING_SETTINGS_PARAM | -1,155,145 | "Circuit Naming Settings"
STEEL_ELEM_PROFILE_TYPE | -1,155,146 | "Profile Type"
STEEL_ELEM_PROFILE_LENGTH | -1,155,147 | "Length"
STEEL_ELEM_PROFILE_VOLUME | -1,155,148 | "Volume"
RBS_ELEC_NUMBER_OF_CIRCUITS | -1,155,150 | "Max Number of Circuits"
RBS_ELEC_ANALYTICAL_TOTAL_COINCIDENT_LOAD | -1,155,151 | "Total Coincident Loads"
RBS_ELEC_MAX_CIRCUITS_DATA_PANEL | -1,155,152 | "Maximum Amount of Circuits"
PATH_OF_TRAVEL_TO_ROOM | -1,155,201 | "To Room"
PATH_OF_TRAVEL_FROM_ROOM | -1,155,202 | "From Room"
REBAR_SHAPE_HOOK_ROTATION_AT_START | -1,155,203 | "Hook Rotation At Start"
REBAR_SHAPE_HOOK_ROTATION_AT_END | -1,155,204 | "Hook Rotation At End"
REBAR_HOOK_ROTATION_AT_START | -1,155,205 | "Hook Rotation At Start"
REBAR_HOOK_ROTATION_AT_END | -1,155,206 | "Hook Rotation At End"
ASSEMBLY_PRECAST_FREEZE | -1,155,210 | "Disable Precast Updates"
INFRASTRUCTURE_ALIGNMENT_DISPLAYED_END_STATION | -1,155,211 | "Displayed End Station"
INFRASTRUCTURE_ALIGNMENT_DISPLAYED_START_STATION | -1,155,212 | "Displayed Start Station"
INFRASTRUCTURE_ALIGNMENT_DESCRIPTION | -1,155,213 | "Description"
INFRASTRUCTURE_ALIGNMENT_NAME | -1,155,214 | "Name"
REBAR_HOOK_LENGTH_OVERRIDE | -1,155,215 | "Override Hook Lengths"
REBAR_HOOK_ROTATION_AT_START_SCHEDULES_TAGS_FILTERS | -1,155,216 | "Hook Rotation At Start"
REBAR_HOOK_ROTATION_AT_END_SCHEDULES_TAGS_FILTERS | -1,155,217 | "Hook Rotation At End"
VOID_CUTS_GEOMETRY | -1,155,218 | "Cuts Geometry"
DPART_LAYER_INDEX | -1,155,219 | "Layer Index"
MOVES_WITH_GRID_PARAM | -1,155,220 | "Moves With Grids": Disable attachment from grids.
REBAR_MODIFIED_SET | -1,155,221 | "Modified Rebar Set"
VIEW_SHOW_GRIDS | -1,155,222 | "Show Grids"
REBAR_MODEL_BAR_DIAMETER | -1,155,223 | "Model Bar Diameter"
REBAR_INSTANCE_BAR_MODEL_DIAMETER | -1,155,224 | "Model Bar Diameter"
LAYER_ELEM_TOP_CONSTRAINT | -1,155,228 | "Top Constraint"
LAYER_ELEM_BASE_CONSTRAINT | -1,155,229 | "Base Constraint"
LAYER_TYPE_THICKNESS | -1,155,230 | "Thickness": Thickness
LAYER_TYPE_MATERIALS | -1,155,231 | "Material": Material
LAYER_ELEM_VOLUME_COMPUTED | -1,155,232 | "Volume"
LAYER_ELEM_OFFSET_FROM_HOST | -1,155,233 | "Offset From Host"
LAYER_ELEM_AREA_COMPUTED | -1,155,234 | "Area"
LAYER_ELEM_THICKNESS | -1,155,235 | "Thickness": Thickness
LAYER_ELEM_MATERIALS | -1,155,236 | "Material": Material
LAYER_ELEM_FUNCTION | -1,155,237 | "Function": Function
LAYER_ELEM_TOP_EXTENSION_DIS | -1,155,238 | "Top Extension Distance"
LAYER_ELEM_BASE_EXTENSION_DIS | -1,155,239 | "Base Extension Distance"
LOCK_ALIGNMENT_UI_TOGGLE | -1,155,240 | "Lock": This is used by the UI to allow selection of lock alignment.
MULTIPLE_ALIGNMENT_UI_TOGGLE | -1,155,241 | "Multiple Alignment": This is used by the UI to allow selection of multiple elements.
PREFER_DIM_SIDE_UI_FILTER | -1,155,242 | "Prefer:": This is used by the UI to allow select prefer dimension side.
COUPLER_ROTATION_ANGLE | -1,155,243 | "Coupler Rotation"
FAMILY_SELF_ORIENTING | -1,155,244 | "Align to View"
STIFFENER_CLASSIFICATION | -1,155,245 | "Classification"
FRAMING_SHAPE_CLASSIFICATION | -1,155,246 | "Framing Shape"
LINEAR_FRAMING_LENGTH | -1,155,247 | "Length"
CIRCULAR_FRAMING_DIAMETER | -1,155,248 | "Circular Diameter"
OVAL_FRAMING_WIDTH | -1,155,249 | "Oval Width"
OVAL_FRAMING_HEIGHT | -1,155,250 | "Oval Height"
REFERENCE_BASE_ON_HOST | -1,155,251 | "Reference Base on Host"
OFFSET_FROM_REFERENCE_BASE | -1,155,252 | "Offset from Reference Base"
TOPOSOLID_TYPE_DEFAULT_THICKNESS_PARAM | -1,155,253 | "Default Thickness"
TOPOSOLID_ATTR_THICKNESS_PARAM | -1,155,254 | "Thickness"
TOPOSOLID_HEIGHTABOVELEVEL_PARAM | -1,155,255 | "Height Offset From Level"
HIGHEST_ASSOCIATED_LEVEL | -1,155,256 | "Highest Associated Level": The highest level associated with this Analytical Element.
LOWEST_ASSOCIATED_LEVEL | -1,155,257 | "Lowest Associated Level": The lowest level associated with this Analytical Element.
TOPOSOLID_STRUCTURE_ID_PARAM | -1,155,259 | "Structure"
TOPOSOLID_ELEVATION_AT_BOTTOM | -1,155,260 | "Elevation at Bottom"
TOPOSOLID_ELEVATION_AT_TOP | -1,155,261 | "Elevation at Top"
PREFER_PATTERN_ALIGN_UI_FILTER | -1,155,263 | "Pattern:": This is used by the UI to allow to select the preferred preference of aligning pattern.
TOPOSOLID_FUNCTION_PARAM | -1,155,264 | "Function"
TOPOSOLID_INHERIT_CONTOURS | -1,155,265 | "Inherit Contours"
TOPOSOLID_SUBDIVIDE_HEIGHT | -1,155,266 | "Sub-divide Height"
TOPOSOLID_SUBDIVIDE_MATERIAL | -1,155,267 | "Material"
TOPOSOLID_CONTOUR_DISPLAY_SETTINGS_ID_PARAM | -1,155,268 | "Contour Display"
TOPOSOLID_CONTOUR_SUBCATEGORY_ID | -1,155,269 | "Subcategory"
SSE_POINT_BASETYPE_ENUM | -1,155,270 | "Point Base Type"
SSE_POINT_OFFSET_FROM_SURFACE | -1,155,271 | "Offset from Surface"
SSE_POINT_ELEVATION | -1,155,272 | "Elevation"
SSE_POINT_ELEVATION_BASE_TYPE | -1,155,273 | "Elevation Base Type"
LAYER_ELEM_COMPOUND_ELEM_FAMILY | -1,155,274 | "Compound Element Family"
LAYER_ELEM_COMPOUND_ELEM_TYPE | -1,155,275 | "Compound Element Type"
LAYER_ELEM_IS_CORE_LAYER | -1,155,276 | "Is Core Layer"
LAYER_ELEM_IS_STRUCTURAL_MATERIAL | -1,155,277 | "Is Structural Material"
LAYER_ELEM_IS_VARIABLE | -1,155,278 | "Is Variable"
LAYER_ELEM_SCHEDULE_FAMILY | -1,155,279 | "Family"
SCHEDULE_ROTATION_ON_SHEET | -1,155,280 | "Rotation on Sheet"
SCHEDULE_RESIZE_ROWS | -1,155,281 | "Resize Rows"
SCHEDULE_ROW_HEIGHT_INPUT | -1,155,282 | "Row Height"
REBAR_ALIGNMENT_OPTIONS | -1,155,283 | "Bar Alignment"
LOAD_IS_CONSTRAINED_ON_HOST | -1,155,284 | "Is constrained on host"
SSE_POINT_OFFSET_FROM_SNAPS | -1,155,285 | "Offset from Snaps"
BENDING_DETAIL_TYPE_SEGMENT_LENGTH_DIMENSIONS_ENABLED | -1,155,288 | "Segment Length Dimensions"
BENDING_DETAIL_TYPE_SEGMENT_LENGTH_DIMENSION_TYPE_ID | -1,155,289 | "Linear Dimension Style"
BENDING_DETAIL_TYPE_SEGMENT_LENGTHS_FOR_ARCS_DISPLAY_OPTION | -1,155,290 | "Arc Segment Lengths"
BENDING_DETAIL_TYPE_SEGMENT_LENGTHS_DISPLAY_OPTION | -1,155,291 | "Straight Segment Lengths"
BENDING_DETAIL_TYPE_SEGMENT_LENGTH_DIMENSIONS_OFFSET | -1,155,292 | "Dimension Offset"
BENDING_DETAIL_TYPE_SEGMENT_LENGTH_DIMENSIONS_FOR_HOOKS_ENABLED | -1,155,293 | "Hook Lengths"
BENDING_DETAIL_TYPE_ORTHOGONAL_AND_OVERALL_DIMESIONS_ENABLED | -1,155,294 | "Other Dimensions"
BENDING_DETAIL_TYPE_ANGULAR_DIMENSIONS_ENABLED | -1,155,295 | "Angular Dimensions"
BENDING_DETAIL_TYPE_ANGULAR_DIMENSION_TYPE_ID | -1,155,296 | "Angular Dimension Style"
BENDING_DETAIL_TYPE_SHOW_ANGULAR_DIMENSIONS_FOR | -1,155,297 | "Show for Angles"
BENDING_DETAIL_TYPE_ANGULAR_DIMENSION_OFFSET | -1,155,298 | "Angular Dimension Offset"
BENDING_DETAIL_TYPE_BEND_DIAMETER_DIMENSIONS_ENABLED | -1,155,299 | "Bend Diameter Dimensions"
BENDING_DETAIL_TYPE_RADIAL_DIMENSION_TYPE_ID | -1,155,300 | "Radial Dimension Style"
BENDING_DETAIL_TYPE_DIAMETER_DIMENSION_TYPE_ID | -1,155,301 | "Diameter Dimension Style"
BENDING_DETAIL_TYPE_SHOW_BAR_BENDING_USING | -1,155,302 | "Dimension Type"
BENDING_DETAIL_TYPE_BEND_DIAMETER_DIMENSIONS_FOR_SEGMENTS_ENABLED | -1,155,304 | "Segment Bends"
BENDING_DETAIL_TYPE_BEND_DIAMETER_DIMENSIONS_FOR_HOOKS_ENABLED | -1,155,305 | "Hook Bends"
BENDING_DETAIL_TYPE_ANGULAR_DIMENSIONS_FOR_HOOKS_ENABLED | -1,155,306 | "Hook Angles"
BENDING_DETAIL_TYPE_ANGULAR_DIMENSIONS_MEASUREMENT | -1,155,307 | "Angle Measurement"
BENDING_DETAIL_REPRESENTATION_FOR_3D_BARS | -1,155,308 | "View for 3D Shape"
BENDING_DETAIL_VARYING_REBAR_DIMENSION | -1,155,309 | "Varying Rebar Set Dimensions"
BENDING_DETAIL_SEGMENT_REPRESENTATION | -1,155,310 | "Representation"
BENDING_DETAIL_SEGMENT_LENGTH_DIMENSION_TEXT_POSITION | -1,155,311 | "Dimension Text Position"
BENDING_DETAIL_ANGULAR_DIMENSION_TEXT_POSITION | -1,155,312 | "Angle Text Position"
BENDING_DETAIL_DETAIL_LEVEL | -1,155,313 | "Detail Level"
BLEND_DEPTH_PARAM | -1,155,314 | "Depth"
BENDING_DETAIL_TYPE_TAG_TYPE_ID | -1,155,315 | "Tag Type"
BENDING_DETAIL_TYPE_SCHEMATIC_WIDTH | -1,155,317 | "Width"
BENDING_DETAIL_TYPE_SCHEMATIC_HEIGHT | -1,155,318 | "Height"
FAMILY_NESTING_BEHAVIOR | -1,155,320 | "Family Nesting Behavior"
TAG_ORIENTATION_BEHAVIOR | -1,155,321 | "Tag Orientation"
EXCHANGE_ID | -1,155,400 | "Exchange ID"
EXCHANGE_ENTITY_ID | -1,155,401 | "Exchange Entity ID"
PLACEMENT_PARAMS_SHOW | -1,166,000 | "Enable Position Parameters"
PLACEMENT_CENTER_X | -1,166,001 | "Center X"
PLACEMENT_CENTER_Y | -1,166,002 | "Center Y"
PLACEMENT_LEFT | -1,166,003 | "Left"
PLACEMENT_BOTTOM | -1,166,004 | "Bottom"
PLACEMENT_RIGHT | -1,166,005 | "Right"
PLACEMENT_TOP | -1,166,006 | "Top"
USING_MULTIPLE | -1,180,000 | "Multiple Join"
FAMILY_USING_MULTIPLE | -1,180,200 | "Multiple Join"
TOPOSOLID_FACES_LOCATION | -1,180,201 | "Picked Faces Location"
REBAR_CONSTRAINTS_STATUS | -1,180,301 | "Rebar Constraint Status"
TAG_HEAD_POSITION | -1,180,302 | "Tag Position"
INDIVIDUAL_EXCAVATION_VOLUME | -1,180,303 | "Individual Excavation Volume"
EXCAVATION_ELEMENT_ID | -1,180,304 | "Element Id"
EXCAVATION_ELEMENT_FAMILY_AND_TYPE | -1,180,305 | "Element Family and Type"
EXCAVATION_VOLUME | -1,180,306 | "Excavation Volume"
TOTAL_EXCAVATION_VOLUME | -1,180,307 | "Total Excavation Volume"
EXCAVATION_VOLUME_ON_TOPOSOLID | -1,180,308 | "Excavation Volume on Toposolid"
REBAR_BAR_SPLICE_LENGTHS | -1,180,309 | "Splice Lengths"
TAG_HEAD_ALIGNMENT | -1,180,310 | "Tag Alignment"
BENDINGDETAIL_POSITION | -1,180,317 | "Bending Detail Position"
STEEL_ELEM_MARK | -1,180,318 | "Assembly Mark"
STEEL_ELEM_SINGLE_PART_MARK | -1,180,319 | "Single Part Mark"
REBAR_SPLICE_LAP_LENGTH_MULTIPLIER | -1,180,400 | "Lap Length Multiplier"
REBAR_SPLICE_SPLICE_LINE_POSITION | -1,180,401 | "Splice Position"
SPLICE_BY_RULES_MAX_LENGTH | -1,180,402 | "Maximum bar length"
SPLICE_BY_RULES_MIN_LENGTH | -1,180,403 | "Minimum bar length"
SPLICE_BY_RULES_RUNOUT | -1,180,404 | "Runout"
SPLICE_LAP_LENGTH_AT_START | -1,180,405 | "Lap Length at Start"
SPLICE_LAP_LENGTH_AT_END | -1,180,406 | "Lap Length at End"
SPLICE_TYPE_AT_START | -1,180,407 | "Splice at Start"
SPLICE_TYPE_AT_END | -1,180,408 | "Splice at End"
REBAR_STAGGER_OFFSET_AT_START | -1,180,409 | "Offset At Start"
REBAR_STAGGER_OFFSET_AT_END | -1,180,410 | "Offset At End"
REBAR_SPLICE_STAGGER_LENGTH_MULTIPLIER | -1,180,411 | "Stagger Length Multiplier"
REBAR_SPLICE_SHIFT_BARS | -1,180,412 | "Shift Bars"
REBAR_MINIMUM_NUMBER | -1,180,413 | "Minimum Rebar Number"
REBAR_MAXIMUM_NUMBER | -1,180,414 | "Maximum Rebar Number"
REBAR_STAGGERED_SET | -1,180,415 | "Staggered Set"
ANALYTICAL_NODE_TYPE | -1,180,420 | "Node Type": Specifies the type of the Analytical Node: hosted or not.
ANALYTICAL_NODE_CAN_BE_HOSTED | -1,180,421 | "Can Be Hosted": Specifies of the Analytical Node can be hosted or not.
ELLIPSE_MODIFICATION_KEEPS_RATIO | -1,612,354 | "Keep Ratio"
ALLOW_MULTIPLE_SELECTION | -1,612,357 | "Allow Multiple Selection": This is used by the UI to allow selection of multiple elements.
Remarks
The ID of the parameter can be used to retrieve property values from an Element by using the Element.Parameter property. The documentation for each ID includes the parameter name, as found in the Element Properties dialog in the English version of Autodesk Revit. Note that multiple distinct parameter ids may map to the same English name; in those case you must examine the parameters associated with a specific element to determine which parameter id to use.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CADExportOptions Class

Generic CAD Export options.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBCADExportOptions
Autodesk.Revit.DBDWFExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class CADExportOptions
Public MustInherit Class CADExportOptions
public ref class CADExportOptions abstract
[<AbstractClassAttribute>]
type CADExportOptions = class end

The CADExportOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CADExportOptions Methods

The CADExportOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CADExportOptions Class


CADLinkOperations Class

This class is used to extend the IExternalResourceServer interface with methods to support operations specifically related to DWG links.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBLinkOperations
Autodesk.Revit.DBCADLinkOperations

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CADLinkOperations : LinkOperations
Public Class CADLinkOperations
    Inherits LinkOperations
public ref class CADLinkOperations : public LinkOperations
type CADLinkOperations =
    class
        inherit LinkOperations
    end

The CADLinkOperations type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from LinkOperations)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from LinkOperations)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetOnLocalLinkSharedCoordinatesSavedCallback | Sets the callback that will be called when the Revit user saves new shared coordinate settings to a linked document obtained from an IExternalResourceServer. (Inherited from LinkOperations)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

The class owns single-method interfaces which are used as callbacks to perform specific operations on DWG link external resources.

An empty CADLinkOperations instance is passed to an IExternalResourceServer (inside an ExternalResourceServerExtensions object) via the GetTypeSpecificServerOperations method. The server provider can then add their own implemented interface objects to the CADLinkOperations, thus making them available to Revit to use as callbacks.

Supporting these additional, type-specific operations is not absolutely required, but is strongly recommended in order for users to be able to perform all the same operations they would with locally-accessed links.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CADLinkOperations Properties

The CADLinkOperations type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from LinkOperations)
Top
See Also

Reference

CADLinkOperations Class


CADLinkOperations Methods

The CADLinkOperations type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from LinkOperations)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetOnLocalLinkSharedCoordinatesSavedCallback | Sets the callback that will be called when the Revit user saves new shared coordinate settings to a linked document obtained from an IExternalResourceServer. (Inherited from LinkOperations)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CADLinkOperations Class


CADLinkOptions Class

This class contains the options in use when or reloading a CAD link type (DWG, DXF, etc.)
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBCADLinkOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CADLinkOptions : IDisposable
Public Class CADLinkOptions
    Implements IDisposable
public ref class CADLinkOptions : IDisposable
type CADLinkOptions =
    class
        interface IDisposable
    end

The CADLinkOptions type exposes the following members.

Constructors
 | Name | Description
Public method | CADLinkOptions(CADLinkOptions) | Constructs a new copy of the input CADLinkOptions object.
Public method | CADLinkOptions(Boolean, ElementId) | Creates a CADLinkOptions object, specifying whether to preserve graphic overrides, and what view to use if the link's view has been deleted.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | PreserveOverrides | Whether Revit should preserve the link's graphic overrides on reload.
Public property | ViewId | The id of the view to use as the link's reference view, if the reference view has been deleted.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the CADLinkOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CADLinkOptions Constructor

Overload List
 | Name | Description
Public method | CADLinkOptions(CADLinkOptions) | Constructs a new copy of the input CADLinkOptions object.
Public method | CADLinkOptions(Boolean, ElementId) | Creates a CADLinkOptions object, specifying whether to preserve graphic overrides, and what view to use if the link's view has been deleted.
Top
See Also

Reference

CADLinkOptions Class


CADLinkOptions(CADLinkOptions) Constructor

Constructs a new copy of the input CADLinkOptions object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CADLinkOptions(
    CADLinkOptions other
)
Public Sub New (
    other As CADLinkOptions
)
public:
CADLinkOptions(
    CADLinkOptions^ other
)
new :
        other : CADLinkOptions -> CADLinkOptions

Parameters

other CADLinkOptions
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

CADLinkOptions Class
CADLinkOptions Overload


CADLinkOptions(Boolean, ElementId) Constructor

Creates a CADLinkOptions object, specifying whether to preserve graphic overrides, and what view to use if the link's view has been deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CADLinkOptions(
    bool preserveOverrides,
    ElementId viewId
)
Public Sub New (
    preserveOverrides As Boolean,
    viewId As ElementId
)
public:
CADLinkOptions(
    bool preserveOverrides,
    ElementId^ viewId
)
new :
        preserveOverrides : bool *
        viewId : ElementId -> CADLinkOptions

Parameters

preserveOverrides Boolean
True if Revit should preserve the link's graphic overrides on reload. False otherwise.
viewId ElementId

The id of the view to use as the link's reference view, if the reference view has been deleted. Revit will ignore this value if the reference view is still in place.

The value may be ElementId.InvalidElementId, although Revit will cancel the load if the reference view is deleted.

Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

CADLinkOptions Class
CADLinkOptions Overload


CADLinkOptions Properties

The CADLinkOptions type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | PreserveOverrides | Whether Revit should preserve the link's graphic overrides on reload.
Public property | ViewId | The id of the view to use as the link's reference view, if the reference view has been deleted.
Top
See Also

Reference

CADLinkOptions Class


CADLinkOptions.IsValidObject Property

CADLinkOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

CADLinkOptions Class


CADLinkOptions.PreserveOverrides Property

CADLinkOptionsPreserveOverrides Property

Whether Revit should preserve the link's graphic overrides on reload.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool PreserveOverrides { get; set; }
Public Property PreserveOverrides As Boolean
    Get
    Set
public:
property bool PreserveOverrides {
    bool get ();
    void set (bool value);
}
member PreserveOverrides : bool with get, set

Property Value

Boolean
See Also

Reference

CADLinkOptions Class


CADLinkOptions.ViewId Property

CADLinkOptionsViewId Property

The id of the view to use as the link's reference view, if the reference view has been deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId ViewId { get; set; }
Public Property ViewId As ElementId
    Get
    Set
public:
property ElementId^ ViewId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member ViewId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

CADLinkOptions Class


CADLinkOptions Methods

The CADLinkOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CADLinkOptions Class


CADLinkOptions.Dispose Method

CADLinkOptionsDispose Method

Releases all resources used by the CADLinkOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

CADLinkOptions Class


CADLinkType Class

CADLinkType represents both CAD links and CAD imports. The function IsLink can be used to distinguish between the two. CAD imports are not ExternalFileReferences; they are brought completely into the document and maintain no connection to their original file.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBCADLinkType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CADLinkType : ElementType
Public Class CADLinkType
    Inherits ElementType
public ref class CADLinkType : public ElementType
type CADLinkType =
    class
        inherit ElementType
    end

The CADLinkType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LoadFrom(ExternalResourceReference) | Loads or reloads the DWG link from the given external resource reference.
Public method | LoadFrom(String) | Loads or reloads the DWG link from the given file path.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | Reload | Loads or reloads the link from its currently-stored location. If the link is an external resource, Revit will contact the IExternalResourceServer to get the latest version of the link.
Public method | Reload(CADLinkOptions) | Loads or reloads the link from its currently-stored location. If the link is an external resource, Revit will contact the IExternalResourceServer to get the latest version of the link.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CADLinkType Properties

The CADLinkType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

CADLinkType Class


CADLinkType Methods

The CADLinkType type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LoadFrom(ExternalResourceReference) | Loads or reloads the DWG link from the given external resource reference.
Public method | LoadFrom(String) | Loads or reloads the DWG link from the given file path.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | Reload | Loads or reloads the link from its currently-stored location. If the link is an external resource, Revit will contact the IExternalResourceServer to get the latest version of the link.
Public method | Reload(CADLinkOptions) | Loads or reloads the link from its currently-stored location. If the link is an external resource, Revit will contact the IExternalResourceServer to get the latest version of the link.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CADLinkType Class


CADLinkType.LoadFrom Method

CADLinkTypeLoadFrom Method

Overload List
 | Name | Description
Public method | LoadFrom(ExternalResourceReference) | Loads or reloads the DWG link from the given external resource reference.
Public method | LoadFrom(String) | Loads or reloads the DWG link from the given file path.
Top
See Also

Reference

CADLinkType Class


CADLinkType.LoadFrom(ExternalResourceReference) Method

CADLinkTypeLoadFrom(ExternalResourceReference) Method

Loads or reloads the DWG link from the given external resource reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LinkLoadResult LoadFrom(
    ExternalResourceReference resourceReference
)
Public Function LoadFrom (
    resourceReference As ExternalResourceReference
) As LinkLoadResult
public:
LinkLoadResult^ LoadFrom(
    ExternalResourceReference^ resourceReference
)
member LoadFrom :
        resourceReference : ExternalResourceReference -> LinkLoadResult

Parameters

resourceReference ExternalResourceReference
An ExternalResourceReference giving the location of the link. This method can be used to load the link from a file on disk. See [!:Autodesk::Revit::DB::ExternalResourceReference::CreateLocalResource()].

Return Value

LinkLoadResult
An object containing the ElementId of the link and an enum value indicating any errors which occurred while trying to load.
Exceptions
Exception | Condition
ArgumentException | The server referenced by the ExternalResourceReference does not exist or does not implement IExternalResourceServer. -or- The server referenced by the ExternalResourceReference cannot support CAD links. -or- The ExternalResourceReference (resourceReference) is not in a format that is supported by its server.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This CADLinkType represents an import and cannot be used as a link. -or- The element "this CADLinkType" is in a read-only document. -or- The link does not represent a DWG.
Remarks

If the link is currently loaded, any changes made in-memory to the link's shared coordinates will be discarded.

Graphic overrides will be preserved on reload.

If the original view used to bring in this link has been deleted, Revit will cancel the load.

If there is already another link, not current link itself, using the given external resource reference, the loading will not happen. The element id of the link using the external resource reference will be contained in the LinkLoadResult.

This function checks the actual resource path that the IExternalResourceServer returns. If the link type identified by the resource path doesn't match DWG, the load will not proceed.

See Also

Reference

CADLinkType Class
LoadFrom Overload


CADLinkType.LoadFrom(String) Method

CADLinkTypeLoadFrom(String) Method

Loads or reloads the DWG link from the given file path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LinkLoadResult LoadFrom(
    string path
)
Public Function LoadFrom (
    path As String
) As LinkLoadResult
public:
LinkLoadResult^ LoadFrom(
    String^ path
)
member LoadFrom :
        path : string -> LinkLoadResult

Parameters

path String
A path on disk giving the location of the linked file. This path must be absolute. The link's path will remain PathType.Absolute or PathType.Relative, whichever it was before. If the link was previously to an external server location, the path type will be relative.

Return Value

LinkLoadResult
An object containing the ElementId of the link and an enum value indicating any errors which occurred while trying to load.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
FileArgumentNotFoundException | The given path does not exist.
InvalidOperationException | This CADLinkType represents an import and cannot be used as a link. -or- The element "this CADLinkType" is in a read-only document. -or- The link does not represent a DWG.
Remarks

If the link is currently loaded, any changes made in-memory to the link's shared coordinates will be discarded.

Graphic overrides will be preserved on reload.

If the original view used to bring in this link has been deleted, Revit will cancel the load.

If there is already another link, not current link itself, using the given file path, the loading will not happen. The element id of the link using the file path will be contained in the LinkLoadResult.

If the link type identified by the given path doesn't match DWG, the load will not proceed.

See Also

Reference

CADLinkType Class
LoadFrom Overload


CADLinkType.Reload Method

CADLinkTypeReload Method

Overload List
 | Name | Description
Public method | Reload | Loads or reloads the link from its currently-stored location. If the link is an external resource, Revit will contact the IExternalResourceServer to get the latest version of the link.
Public method | Reload(CADLinkOptions) | Loads or reloads the link from its currently-stored location. If the link is an external resource, Revit will contact the IExternalResourceServer to get the latest version of the link.
Top
See Also

Reference

CADLinkType Class


CADLinkType.Reload Method

CADLinkTypeReload Method

Loads or reloads the link from its currently-stored location. If the link is an external resource, Revit will contact the IExternalResourceServer to get the latest version of the link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LinkLoadResult Reload()
Public Function Reload As LinkLoadResult
public:
LinkLoadResult^ Reload()
member Reload : unit -> LinkLoadResult

Return Value

LinkLoadResult
An object containing the ElementId of the link and an enum value indicating any errors which occurred while trying to load.
Exceptions
Exception | Condition
InvalidOperationException | This CADLinkType represents an import and cannot be used as a link. -or- The element "this CADLinkType" is in a read-only document.
Remarks

If the link is currently loaded, any changes made in-memory to the link's shared coordinates will be discarded.

Graphic overrides will be preserved on reload.

If the original view used to bring in this link has been deleted, Revit will cancel the load.

See Also

Reference

CADLinkType Class
Reload Overload


CADLinkType.Reload(CADLinkOptions) Method

CADLinkTypeReload(CADLinkOptions) Method

Loads or reloads the link from its currently-stored location. If the link is an external resource, Revit will contact the IExternalResourceServer to get the latest version of the link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LinkLoadResult Reload(
    CADLinkOptions options
)
Public Function Reload (
    options As CADLinkOptions
) As LinkLoadResult
public:
LinkLoadResult^ Reload(
    CADLinkOptions^ options
)
member Reload :
        options : CADLinkOptions -> LinkLoadResult

Parameters

options CADLinkOptions
Options for reloading the link. Options include the ability to preserve graphic overrides on reload.

Return Value

LinkLoadResult
An object containing the ElementId of the link and an enum value indicating any errors which occurred while trying to load.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This CADLinkType represents an import and cannot be used as a link. -or- The element "this CADLinkType" is in a read-only document.
Remarks

If the link is currently loaded, any changes made in-memory to the link's shared coordinates will be discarded.

See Also

Reference

CADLinkType Class
Reload Overload


CameraInfo Class

An object holding information about the projection mapping of a 3D view.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBCameraInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CameraInfo : IDisposable
Public Class CameraInfo
    Implements IDisposable
public ref class CameraInfo : IDisposable
type CameraInfo =
    class
        interface IDisposable
    end

The CameraInfo type exposes the following members.

Properties
 | Name | Description
Public property | FarDistance | Distance from eye point to far plane of view frustum along the view direction.
Public property | HorizontalExtent | Distance between left and right planes on the target plane.
Public property | IsPerspective | Identifies whether the projection is orthographic or perspective
Public property | IsPespective | Identifies whether the projection is orthographic or perspective
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NearDistance | Distance from eye point to near plane of view frustum along the view direction.
Public property | RightOffset | Distance that the target plane is offset towards the right where right is normal to both Up direction and View direction. This offset shifts both left and right planes.
Public property | TargetDistance | Distance from eye point along view direction to target plane.
Public property | UpOffset | Distance that the target plane is offset in the direction of the Up direction. This offset shifts both top and bottom planes.
Public property | VerticalExtent | Distance between top and bottom planes on the target plane.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the CameraInfo
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

CameraInfo can be obtained directly from a ViewNode If camera info is not available, an orthographic view should be assumed.

See also: OnViewBegin(ViewNode).

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CameraInfo Properties

The CameraInfo type exposes the following members.

Properties
 | Name | Description
Public property | FarDistance | Distance from eye point to far plane of view frustum along the view direction.
Public property | HorizontalExtent | Distance between left and right planes on the target plane.
Public property | IsPerspective | Identifies whether the projection is orthographic or perspective
Public property | IsPespective | Identifies whether the projection is orthographic or perspective
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NearDistance | Distance from eye point to near plane of view frustum along the view direction.
Public property | RightOffset | Distance that the target plane is offset towards the right where right is normal to both Up direction and View direction. This offset shifts both left and right planes.
Public property | TargetDistance | Distance from eye point along view direction to target plane.
Public property | UpOffset | Distance that the target plane is offset in the direction of the Up direction. This offset shifts both top and bottom planes.
Public property | VerticalExtent | Distance between top and bottom planes on the target plane.
Top
See Also

Reference

CameraInfo Class


CameraInfo.FarDistance Property

CameraInfoFarDistance Property

Distance from eye point to far plane of view frustum along the view direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double FarDistance { get; }
Public ReadOnly Property FarDistance As Double
    Get
public:
property double FarDistance {
    double get ();
}
member FarDistance : float with get

Property Value

Double
Remarks
This property together with NearDistance determines the depth restrictions of a view frustum.
See Also

Reference

CameraInfo Class


CameraInfo.HorizontalExtent Property

CameraInfoHorizontalExtent Property

Distance between left and right planes on the target plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double HorizontalExtent { get; }
Public ReadOnly Property HorizontalExtent As Double
    Get
public:
property double HorizontalExtent {
    double get ();
}
member HorizontalExtent : float with get

Property Value

Double
See Also

Reference

CameraInfo Class


CameraInfo.IsPerspective Property

CameraInfoIsPerspective Property

Identifies whether the projection is orthographic or perspective

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsPerspective { get; }
Public ReadOnly Property IsPerspective As Boolean
    Get
public:
property bool IsPerspective {
    bool get ();
}
member IsPerspective : bool with get

Property Value

Boolean
See Also

Reference

CameraInfo Class


CameraInfo.IsPespective Property

CameraInfoIsPespective Property

Identifies whether the projection is orthographic or perspective

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsPespective { get; }
Public ReadOnly Property IsPespective As Boolean
    Get
public:
property bool IsPespective {
    bool get ();
}
member IsPespective : bool with get

Property Value

Boolean
See Also

Reference

CameraInfo Class


CameraInfo.IsValidObject Property

CameraInfoIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

CameraInfo Class


CameraInfo.NearDistance Property

CameraInfoNearDistance Property

Distance from eye point to near plane of view frustum along the view direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double NearDistance { get; }
Public ReadOnly Property NearDistance As Double
    Get
public:
property double NearDistance {
    double get ();
}
member NearDistance : float with get

Property Value

Double
Remarks
This property together with FarDistance determines the depth restrictions of a view frustum.
See Also

Reference

CameraInfo Class


CameraInfo.RightOffset Property

CameraInfoRightOffset Property

Distance that the target plane is offset towards the right where right is normal to both Up direction and View direction. This offset shifts both left and right planes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double RightOffset { get; }
Public ReadOnly Property RightOffset As Double
    Get
public:
property double RightOffset {
    double get ();
}
member RightOffset : float with get

Property Value

Double
See Also

Reference

CameraInfo Class


CameraInfo.TargetDistance Property

CameraInfoTargetDistance Property

Distance from eye point along view direction to target plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double TargetDistance { get; }
Public ReadOnly Property TargetDistance As Double
    Get
public:
property double TargetDistance {
    double get ();
}
member TargetDistance : float with get

Property Value

Double
Remarks
This value is appropriate for perspective views only. Attempts to get this value for an orthographic view can be made, but the obtained value is to be ignored.
See Also

Reference

CameraInfo Class


CameraInfo.UpOffset Property

CameraInfoUpOffset Property

Distance that the target plane is offset in the direction of the Up direction. This offset shifts both top and bottom planes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double UpOffset { get; }
Public ReadOnly Property UpOffset As Double
    Get
public:
property double UpOffset {
    double get ();
}
member UpOffset : float with get

Property Value

Double
See Also

Reference

CameraInfo Class


CameraInfo.VerticalExtent Property

CameraInfoVerticalExtent Property

Distance between top and bottom planes on the target plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double VerticalExtent { get; }
Public ReadOnly Property VerticalExtent As Double
    Get
public:
property double VerticalExtent {
    double get ();
}
member VerticalExtent : float with get

Property Value

Double
See Also

Reference

CameraInfo Class


CameraInfo Methods

The CameraInfo type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CameraInfo Class


CameraInfo.Dispose Method

CameraInfoDispose Method

Releases all resources used by the CameraInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

CameraInfo Class


CancellationListener Class

Allows clients to poll the cancellation status of a background operation. Revit instantiates CancellationListener objects for internal background operation implementations only. As such, third-party developers are not expected to instantiate or handle CancellationListener objects.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBCancellationListener

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CancellationListener : IDisposable
Public Class CancellationListener
    Implements IDisposable
public ref class CancellationListener : IDisposable
type CancellationListener =
    class
        interface IDisposable
    end

The CancellationListener type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the CancellationListener
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsCancelled | Returns true if the operation associated with this instance has been cancelled.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CancellationListener Properties

The CancellationListener type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

CancellationListener Class


CancellationListener.IsValidObject Property

CancellationListenerIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

CancellationListener Class


CancellationListener Methods

The CancellationListener type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsCancelled | Returns true if the operation associated with this instance has been cancelled.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CancellationListener Class


CancellationListener.Dispose Method

CancellationListenerDispose Method

Releases all resources used by the CancellationListener

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

CancellationListener Class


CancellationListener.IsCancelled Method

CancellationListenerIsCancelled Method

Returns true if the operation associated with this instance has been cancelled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCancelled()
Public Function IsCancelled As Boolean
public:
bool IsCancelled()
member IsCancelled : unit -> bool

Return Value

Boolean
See Also

Reference

CancellationListener Class


Categories Class

The Categories object is a map that contains all the top-level Category objects within the Document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBCategoryNameMap
Autodesk.Revit.DBCategories

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Categories : CategoryNameMap
Public Class Categories
    Inherits CategoryNameMap
public ref class Categories : public CategoryNameMap
type Categories =
    class
        inherit CategoryNameMap
    end

The Categories type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Whether or not the list of top-level categories is empty. (Overrides CategoryNameMapIsEmpty)
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | ItemBuiltInCategory | Retrieves a category object corresponding to a BuiltInCategory id.
Public property | ItemString | Gets a category which has the specified name from this list of top-level categories. (Overrides CategoryNameMapItemString)
Public property | Size | The total number of top-level categories in the document. (Overrides CategoryNameMapSize)
Top
Methods
 | Name | Description
Public method | Clear | Removes every category from the map, rendering it empty. (Inherited from CategoryNameMap)
Public method | Contains | Identifies if a category which has the specified name is in the list of top-level categories. (Overrides CategoryNameMapContains(String))
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase | Removes a category with the specified name from the map. (Inherited from CategoryNameMap)
Public method | ForwardIterator | Retrieves a forward moving iterator to the map. (Overrides CategoryNameMapForwardIterator)
Public method | GetEnumerator | Retrieves a forward moving iterator to the map. (Overrides CategoryNameMapGetEnumerator)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Inserts the specified category with the specified name into the map. (Overrides CategoryNameMapInsert(String, Category))
 | NewSubcategory | Add a new subcategory into the Autodesk Revit document.
Public method | ReverseIterator | Retrieves a backward moving iterator to the map. (Overrides CategoryNameMapReverseIterator)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Use this object to retrieve categories by name or by BuiltInCategory id.
Example
C#
VB
C++
F#
Copy
// Get settings of current document
Settings documentSettings = document.Settings;

// Get all categories of current document
Categories groups = documentSettings.Categories;

// Show the number of all the categories to the user
String prompt = "Number of all categories in current Revit document:" + groups.Size;

// get Floor category according to OST_Floors and show its name
Category floorCategory = groups.get_Item(BuiltInCategory.OST_Floors);
prompt += floorCategory.Name;

// Give the user some information
TaskDialog.Show("Revit",prompt);
' Get settings of current document
Dim documentSettings As Settings = document.Settings

' Get all categories of current document
Dim groups As Categories = documentSettings.Categories

' Show the number of all the categories to the user
Dim prompt As [String] = "Number of all categories in current Revit document:" + groups.Size

' get Floor category according to OST_Floors and show its name
Dim floorCategory As Category = groups.Item(BuiltInCategory.OST_Floors)
prompt += floorCategory.Name

' Give the user some information
TaskDialog.Show("Revit", prompt)

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Categories Properties

The Categories type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Whether or not the list of top-level categories is empty. (Overrides CategoryNameMapIsEmpty)
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | ItemBuiltInCategory | Retrieves a category object corresponding to a BuiltInCategory id.
Public property | ItemString | Gets a category which has the specified name from this list of top-level categories. (Overrides CategoryNameMapItemString)
Public property | Size | The total number of top-level categories in the document. (Overrides CategoryNameMapSize)
Top
See Also

Reference

Categories Class


Categories.IsEmpty Property

CategoriesIsEmpty Property

Whether or not the list of top-level categories is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool IsEmpty { get; }
Public Overrides ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get () override;
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Boolean
See Also

Reference

Categories Class


Categories.Item Property

CategoriesItem Property

Retrieves a category object matching an identifier.
Overload List
 | Name | Description
Public property | ItemBuiltInCategory | Retrieves a category object corresponding to a BuiltInCategory id.
Public property | ItemString | Gets a category which has the specified name from this list of top-level categories.
Top
See Also

Reference

Categories Class


Categories.Item(BuiltInCategory) Property

CategoriesItem(BuiltInCategory) Property

Retrieves a category object corresponding to a BuiltInCategory id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Category this[
    BuiltInCategory categoryId
] { get; }
Public Overridable ReadOnly Property Item (
    categoryId As BuiltInCategory
) As Category
    Get
public:
virtual property Category^ Item[BuiltInCategory categoryId] {
    Category^ get (BuiltInCategory categoryId);
}
abstract Item : Category with get
override Item : Category with get

Parameters

categoryId BuiltInCategory

Property Value

Category
Remarks
Unlike the method that obtains categories by name, this routine will obtain the handle even of built-in subcategories. Since 2016 it is advised to use either [!:​Autodesk::​Revit::DB::​Category::​GetCategory(​Document,​BuiltIn​Category)] or [!:​Autodesk::​Revit::DB::​Category::​GetCategory(​Document,​ElementId)]​ method from Category class.
See Also

Reference

Categories Class
Item Overload


Categories.Item(String) Property

CategoriesItem(String) Property

Gets a category which has the specified name from this list of top-level categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Category this[
    string name
] { get; set; }
Public Overrides Property Item (
    name As String
) As Category
    Get
    Set
public:
virtual property Category^ Item[String^ name] {
    Category^ get (String^ name) override;
    void set (String^ name, Category^ value) override;
}
abstract Item : Category with get, set
override Item : Category with get, set

Parameters

name String
The name of the category to be retrieved.

Property Value

Category
The category with the specified name.
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the category list does not contain the category with this name. Thrown when trying to set an item to this list of categories; this list is read only.
See Also

Reference

Categories Class
Item Overload


Categories.Size Property

CategoriesSize Property

The total number of top-level categories in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int Size { get; }
Public Overrides ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get () override;
}
abstract Size : int with get
override Size : int with get

Property Value

Int32
See Also

Reference

Categories Class


Categories Methods

The Categories type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Removes every category from the map, rendering it empty. (Inherited from CategoryNameMap)
Public method | Contains | Identifies if a category which has the specified name is in the list of top-level categories. (Overrides CategoryNameMapContains(String))
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase | Removes a category with the specified name from the map. (Inherited from CategoryNameMap)
Public method | ForwardIterator | Retrieves a forward moving iterator to the map. (Overrides CategoryNameMapForwardIterator)
Public method | GetEnumerator | Retrieves a forward moving iterator to the map. (Overrides CategoryNameMapGetEnumerator)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Inserts the specified category with the specified name into the map. (Overrides CategoryNameMapInsert(String, Category))
 | NewSubcategory | Add a new subcategory into the Autodesk Revit document.
Public method | ReverseIterator | Retrieves a backward moving iterator to the map. (Overrides CategoryNameMapReverseIterator)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Categories Class


Categories.Contains Method

CategoriesContains Method

Identifies if a category which has the specified name is in the list of top-level categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool Contains(
    string name
)
Public Overrides Function Contains (
    name As String
) As Boolean
public:
virtual bool Contains(
    String^ name
) override
abstract Contains :
        name : string -> bool
override Contains :
        name : string -> bool

Parameters

name String
The name of the category to be retrieved.

Field Value

Boolean
Whether the category exists in the list of top-level categories.
See Also

Reference

Categories Class


Categories.ForwardIterator Method

CategoriesForwardIterator Method

Retrieves a forward moving iterator to the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override CategoryNameMapIterator ForwardIterator()
Public Overrides Function ForwardIterator As CategoryNameMapIterator
public:
virtual CategoryNameMapIterator^ ForwardIterator() override
abstract ForwardIterator : unit -> CategoryNameMapIterator
override ForwardIterator : unit -> CategoryNameMapIterator

Return Value

CategoryNameMapIterator
A forward moving iterator to the map.
See Also

Reference

Categories Class


Categories.GetEnumerator Method

CategoriesGetEnumerator Method

Retrieves a forward moving iterator to the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override IEnumerator GetEnumerator()
Public Overrides Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator() override
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

IEnumerator
A forward moving iterator to the map.

Implements

IEnumerableGetEnumerator
See Also

Reference

Categories Class


Categories.Insert Method

CategoriesInsert Method

Inserts the specified category with the specified name into the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool Insert(
    string key,
    Category item
)
Public Overrides Function Insert (
    key As String,
    item As Category
) As Boolean
public:
virtual bool Insert(
    String^ key,
    Category^ item
) override
abstract Insert :
        key : string *
        item : Category -> bool
override Insert :
        key : string *
        item : Category -> bool

Parameters

key String
The name to be used for inserting the category into the map.
item Category
The category to be inserted into the map.

Return Value

Boolean
Whether or not the category was inserted into the map.
Exceptions
Exception | Condition
InvalidOperationException | Always thrown; this list is read only.
See Also

Reference

Categories Class


Categories.NewSubcategory Method

CategoriesNewSubcategory Method

Add a new subcategory into the Autodesk Revit document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Category NewSubcategory(
    Category parentCategory,
    string name
)
Public Function NewSubcategory (
    parentCategory As Category,
    name As String
) As Category
public:
Category^ NewSubcategory(
    Category^ parentCategory,
    String^ name
)
member NewSubcategory :
        parentCategory : Category *
        name : string -> Category

Parameters

parentCategory Category
The parent category.
name String
The new category name.

Return Value

Category
If successful, the newly created subcategory.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument-"parentCategory" or "name"-is .
ArgumentException | Thrown when the input argument-"parentCategory"-cannot add subcategory. Thrown when the input argument-"name"-is an illegal name.
InvalidOperationException | Thrown when subcategory creation failed.
Example
C#
VB
C++
F#
Copy
public void AssignSubCategory(Document document, GenericForm extrusion)
{
    // create a new subcategory
    Category cat = document.OwnerFamily.FamilyCategory;
    Category subCat = document.Settings.Categories.NewSubcategory(cat, "NewSubCat");

    // create a new material and assign it to the subcategory
    ElementId materialId = Material.Create(document, "Wood Material");
    subCat.Material = document.GetElement(materialId) as Material;

    // assign the subcategory to the element
    extrusion.Subcategory = subCat;
}
Public Sub AssignSubCategory(document As Document, extrusion As GenericForm)
    ' create a new subcategory
    Dim cat As Category = document.OwnerFamily.FamilyCategory
    Dim subCat As Category = document.Settings.Categories.NewSubcategory(cat, "NewSubCat")

    ' create a new material and assign it to the subcategory
    Dim materialId As ElementId = Material.Create(document, "Wood Material")
    subCat.Material = TryCast(document.GetElement(materialId), Material)

    ' assign the subcategory to the element
    extrusion.Subcategory = subCat
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Categories Class


Categories.ReverseIterator Method

CategoriesReverseIterator Method

Retrieves a backward moving iterator to the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override CategoryNameMapIterator ReverseIterator()
Public Overrides Function ReverseIterator As CategoryNameMapIterator
public:
virtual CategoryNameMapIterator^ ReverseIterator() override
abstract ReverseIterator : unit -> CategoryNameMapIterator
override ReverseIterator : unit -> CategoryNameMapIterator

Return Value

CategoryNameMapIterator
A backward moving iterator to the map.
See Also

Reference

Categories Class


Category Class

Represents the category or subcategory to which an element belongs.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBCategory

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Category : APIObject
Public Class Category
    Inherits APIObject
public ref class Category : public APIObject
type Category =
    class
        inherit APIObject
    end

The Category type exposes the following members.

Properties
 | Name | Description
Public property | AllowsBoundParameters | To check if the category can have project parameters.
Public property | AllowsVisibilityControl | Whether the visibility can be controlled by the user for this category in this view.
Public property | BuiltInCategory | Gets the BuiltInCategory value for this category.
Public property | CanAddSubcategory | Indicates if subcategories can be assigned to the category.
Public property | CategoryType | Gets the category type of this category.
Public property | HasMaterialQuantities | Identifies if elements of the category are able to report what materials they contain in what quantities.
Public property | Id | Returns the category id associated with the category object.
Public property | IsCuttable | Indicates if the category is cuttable or not.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | IsTagCategory | Identifies if the category is associated with a type of tag for a different category.
Public property | IsValid | Indicates if the Category is valid or not.
Public property | IsVisibleInUI | Identifies if the category is visible to the user and should be displayed in UI.
Public property | LineColor | The color of lines shown for elements of this category.
Public property | Material | Retrieves or changes the material of the category.
Public property | Name | The category name.
Public property | Parent | Returns the parent category of this category.
Public property | SubCategories | Returns a map containing all of the subcategories of this category.
Public property | Visible | Retrieves or changes the visibility of the category in the active view.
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | GetBuiltInCategory | Gets the BuiltInCategory value corresponding to the given built-in category identifier.
 | GetBuiltInCategoryTypeId | Gets the ForgeTypeId identifying the given built-in category.
 | GetCategory(Document, BuiltInCategory) | Retrieves a category object corresponding to a BuiltInCategory id.
 | GetCategory(Document, ElementId) | Retrieves a category object corresponding to the category id.
Public method | GetGraphicsStyle | Gets the graphics style associated with this category for the given graphics style type.
Public method | GetHashCode | (Overrides ObjectGetHashCode)
Public method | GetLinePatternId | Gets the line pattern id associated with this category for the given graphics style type.
Public method | GetLineWeight | Retrieves the line weight assigned to the category for the given graphics style type.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | IsBuiltInCategory | Checks whether a ForgeTypeId identifies a built-in category.
 | IsBuiltInCategoryValid | Checks if a Category exists for a given BuiltInCategory.
Public method | SetLinePatternId | Sets the line pattern id associated with this category for the given graphics style type.
Public method | SetLineWeight | Sets the line weight for the given graphics style type.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Categories are an important tool within Revit for identifying the inferred type of an element, such as anything in the Walls category should be considered as a wall. The API exposes access to the built in categories within Revit via the Document.Settings.Categories property.
Example
C#
VB
C++
F#
Copy
Element selectedElement = null;
foreach (ElementId id in uidoc.Selection.GetElementIds())
{
    selectedElement = document.GetElement(id);
    break;  // just get one selected element
}

// Get the category instance from the Category property
Category category = selectedElement.Category;

BuiltInCategory enumCategory = category.BuiltInCategory;

// Format the prompt string, which contains the category information
String prompt = "The category information of the selected element is: ";
prompt += "\n\tName:\t" + category.Name;   // Name information

prompt += "\n\tId:\t" + enumCategory.ToString();    // Id information
prompt += "\n\tParent:\t";
if (null == category.Parent)
{
    prompt += "No Parent Category";   // Parent information, it may be null
}
else
{
    prompt += category.Parent.Name;
}

prompt += "\n\tSubCategories:"; // SubCategories information,
CategoryNameMap subCategories = category.SubCategories;
if (null == subCategories || 0 == subCategories.Size) // It may be null or has no item in it
{
    prompt += "No SubCategories;";
}
else
{
    foreach (Category ii in subCategories)
    {
        prompt += "\n\t\t" + ii.Name;
    }
}

// Give the user some information
TaskDialog.Show("Revit",prompt);
Dim selectedElement As Element = Nothing
For Each id As ElementId In uidoc.Selection.GetElementIds()
    selectedElement = document.GetElement(id)
    ' just get one selected element
    Exit For
Next

' Get the category instance from the Category property
Dim category As Category = selectedElement.Category

Dim enumCategory As BuiltInCategory = category.BuiltInCategory

' Format the prompt string, which contains the category information
Dim prompt As [String] = "The category information of the selected element is: "
prompt += vbLf & vbTab & "Name:" & vbTab + category.Name
' Name information
prompt += vbLf & vbTab & "Id:" & vbTab & enumCategory.ToString()
' Id information
prompt += vbLf & vbTab & "Parent:" & vbTab
If category.Parent Is Nothing Then
    ' Parent information, it may be null
    prompt += "No Parent Category"
Else
    prompt += category.Parent.Name
End If

prompt += vbLf & vbTab & "SubCategories:"
' SubCategories information,
Dim subCategories As CategoryNameMap = category.SubCategories
If subCategories Is Nothing OrElse 0 = subCategories.Size Then
    ' It may be null or has no item in it
    prompt += "No SubCategories;"
Else
    For Each ii As Category In subCategories
        prompt += vbLf & vbTab & vbTab + ii.Name
    Next
End If

' Give the user some information
TaskDialog.Show("Revit", prompt)

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Category Properties

The Category type exposes the following members.

Properties
 | Name | Description
Public property | AllowsBoundParameters | To check if the category can have project parameters.
Public property | AllowsVisibilityControl | Whether the visibility can be controlled by the user for this category in this view.
Public property | BuiltInCategory | Gets the BuiltInCategory value for this category.
Public property | CanAddSubcategory | Indicates if subcategories can be assigned to the category.
Public property | CategoryType | Gets the category type of this category.
Public property | HasMaterialQuantities | Identifies if elements of the category are able to report what materials they contain in what quantities.
Public property | Id | Returns the category id associated with the category object.
Public property | IsCuttable | Indicates if the category is cuttable or not.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | IsTagCategory | Identifies if the category is associated with a type of tag for a different category.
Public property | IsValid | Indicates if the Category is valid or not.
Public property | IsVisibleInUI | Identifies if the category is visible to the user and should be displayed in UI.
Public property | LineColor | The color of lines shown for elements of this category.
Public property | Material | Retrieves or changes the material of the category.
Public property | Name | The category name.
Public property | Parent | Returns the parent category of this category.
Public property | SubCategories | Returns a map containing all of the subcategories of this category.
Public property | Visible | Retrieves or changes the visibility of the category in the active view.
Top
See Also

Reference

Category Class


Category.AllowsBoundParameters Property

CategoryAllowsBoundParameters Property

To check if the category can have project parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AllowsBoundParameters { get; }
Public ReadOnly Property AllowsBoundParameters As Boolean
    Get
public:
property bool AllowsBoundParameters {
    bool get ();
}
member AllowsBoundParameters : bool with get

Property Value

Boolean
See Also

Reference

Category Class


Category.AllowsVisibilityControl Property

CategoryAllowsVisibilityControl Property

Whether the visibility can be controlled by the user for this category in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool this[
    View view
] { get; }
Public ReadOnly Property AllowsVisibilityControl (
    view As View
) As Boolean
    Get
public:
property bool AllowsVisibilityControl[View^ view] {
    bool get (View^ view);
}
member AllowsVisibilityControl : bool with get

Parameters

view View
The view where visibility control might be allowed.

Property Value

Boolean
Remarks
There are some categories in Revit that are hidden to users in the Object Styles and Visibility dialog. Their visibility cannot be controlled for a particular view. This property identifies if the category allows visibility control (and thus allows the Visible property to be set).
See Also

Reference

Category Class


Category.BuiltInCategory Property

CategoryBuiltInCategory Property

Gets the BuiltInCategory value for this category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BuiltInCategory BuiltInCategory { get; }
Public ReadOnly Property BuiltInCategory As BuiltInCategory
    Get
public:
property BuiltInCategory BuiltInCategory {
    BuiltInCategory get ();
}
member BuiltInCategory : BuiltInCategory with get

Property Value

BuiltInCategory
BuiltInCategory value for the category or INVALID if the category is not a built-in category.
See Also

Reference

Category Class


Category.CanAddSubcategory Property

CategoryCanAddSubcategory Property

Indicates if subcategories can be assigned to the category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanAddSubcategory { get; }
Public ReadOnly Property CanAddSubcategory As Boolean
    Get
public:
property bool CanAddSubcategory {
    bool get ();
}
member CanAddSubcategory : bool with get

Property Value

Boolean
See Also

Reference

Category Class


Category.CategoryType Property

CategoryCategoryType Property

Gets the category type of this category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CategoryType CategoryType { get; }
Public ReadOnly Property CategoryType As CategoryType
    Get
public:
property CategoryType CategoryType {
    CategoryType get ();
}
member CategoryType : CategoryType with get

Property Value

CategoryType
Remarks
The category type determines if the category is shown in the Visibility/Graphics settings grouped with the model,annotation, or analytical model categories. Note that import categories are also "model" but will be shown separately in the dialog. Some categories not shown in the dialog and will return Internal for the category type.
See Also

Reference

Category Class


Category.HasMaterialQuantities Property

CategoryHasMaterialQuantities Property

Identifies if elements of the category are able to report what materials they contain in what quantities.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasMaterialQuantities { get; }
Public ReadOnly Property HasMaterialQuantities As Boolean
    Get
public:
property bool HasMaterialQuantities {
    bool get ();
}
member HasMaterialQuantities : bool with get

Property Value

Boolean
Remarks
Get materials via the Element' property Materials; Get quantities via methods GetMaterialArea and GetMaterialVolume.
See Also

Reference

Category Class


Category.Id Property

CategoryId Property

Returns the category id associated with the category object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId Id { get; }
Public ReadOnly Property Id As ElementId
    Get
public:
property ElementId^ Id {
    ElementId^ get ();
}
member Id : ElementId with get

Property Value

ElementId
See Also

Reference

Category Class


Category.IsCuttable Property

CategoryIsCuttable Property

Indicates if the category is cuttable or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCuttable { get; }
Public ReadOnly Property IsCuttable As Boolean
    Get
public:
property bool IsCuttable {
    bool get ();
}
member IsCuttable : bool with get

Property Value

Boolean
See Also

Reference

Category Class


Category.IsTagCategory Property

CategoryIsTagCategory Property

Identifies if the category is associated with a type of tag for a different category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsTagCategory { get; }
Public ReadOnly Property IsTagCategory As Boolean
    Get
public:
property bool IsTagCategory {
    bool get ();
}
member IsTagCategory : bool with get

Property Value

Boolean
True if the category is associated with a type of tag for a different category, false if not.
See Also

Reference

Category Class


Category.IsValid Property

CategoryIsValid Property

Indicates if the Category is valid or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValid { get; }
Public ReadOnly Property IsValid As Boolean
    Get
public:
property bool IsValid {
    bool get ();
}
member IsValid : bool with get

Property Value

Boolean
Remarks
A valid Category is one which is present in the Document's Categories.
See Also

Reference

Category Class


Category.IsVisibleInUI Property

CategoryIsVisibleInUI Property

Identifies if the category is visible to the user and should be displayed in UI.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsVisibleInUI { get; }
Public ReadOnly Property IsVisibleInUI As Boolean
    Get
public:
property bool IsVisibleInUI {
    bool get ();
}
member IsVisibleInUI : bool with get

Property Value

Boolean
True if the category should be displayed in UI.
See Also

Reference

Category Class


Category.LineColor Property

CategoryLineColor Property

The color of lines shown for elements of this category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color LineColor { get; set; }
Public Property LineColor As Color
    Get
    Set
public:
property Color^ LineColor {
    Color^ get ();
    void set (Color^ value);
}
member LineColor : Color with get, set

Property Value

Color
See Also

Reference

Category Class


Category.Material Property

CategoryMaterial Property

Retrieves or changes the material of the category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Material Material { get; set; }
Public Property Material As Material
    Get
    Set
public:
property Material^ Material {
    Material^ get ();
    void set (Material^ value);
}
member Material : Material with get, set

Property Value

Material
if this category does not have a material.
Exceptions
Exception | Condition
InvalidOperationException | When setting this property: material cannot be set for annotation categories.
See Also

Reference

Category Class


Category.Name Property

CategoryName Property

The category name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

String
See Also

Reference

Category Class


Category.Parent Property

CategoryParent Property

Returns the parent category of this category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Category Parent { get; }
Public ReadOnly Property Parent As Category
    Get
public:
property Category^ Parent {
    Category^ get ();
}
member Parent : Category with get

Return Value

Category
if this category a not a subcategory
See Also

Reference

Category Class


Category.SubCategories Property

CategorySubCategories Property

Returns a map containing all of the subcategories of this category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CategoryNameMap SubCategories { get; }
Public ReadOnly Property SubCategories As CategoryNameMap
    Get
public:
property CategoryNameMap^ SubCategories {
    CategoryNameMap^ get ();
}
member SubCategories : CategoryNameMap with get

Return Value

CategoryNameMap
An empty map if the category has no subcategories.
See Also

Reference

Category Class


Category.Visible Property

CategoryVisible Property

Retrieves or changes the visibility of the category in the active view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool this[
    View view
] { get; set; }
Public Property Visible (
    view As View
) As Boolean
    Get
    Set
public:
property bool Visible[View^ view] {
    bool get (View^ view);
    void set (View^ view, bool value);
}
member Visible : bool with get, set

Parameters

view View

Property Value

Boolean
Remarks
This affects only if the category is set visible or invisible individually. Other Revit mechanisms may also affect the visibility of elements of this category, including:
  • the category classes settings for model categories, annotation categories, import categories or analytical model categories.
  • view filters
Thus setting this value may not affect the actual visibility of elements of this category in the view.
See Also

Reference

Category Class


Category Methods

The Category type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | GetBuiltInCategory | Gets the BuiltInCategory value corresponding to the given built-in category identifier.
 | GetBuiltInCategoryTypeId | Gets the ForgeTypeId identifying the given built-in category.
 | GetCategory(Document, BuiltInCategory) | Retrieves a category object corresponding to a BuiltInCategory id.
 | GetCategory(Document, ElementId) | Retrieves a category object corresponding to the category id.
Public method | GetGraphicsStyle | Gets the graphics style associated with this category for the given graphics style type.
Public method | GetHashCode | (Overrides ObjectGetHashCode)
Public method | GetLinePatternId | Gets the line pattern id associated with this category for the given graphics style type.
Public method | GetLineWeight | Retrieves the line weight assigned to the category for the given graphics style type.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | IsBuiltInCategory | Checks whether a ForgeTypeId identifies a built-in category.
 | IsBuiltInCategoryValid | Checks if a Category exists for a given BuiltInCategory.
Public method | SetLinePatternId | Sets the line pattern id associated with this category for the given graphics style type.
Public method | SetLineWeight | Sets the line weight for the given graphics style type.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Category Class


Category.GetBuiltInCategory Method

CategoryGetBuiltInCategory Method

Gets the BuiltInCategory value corresponding to the given built-in category identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static BuiltInCategory GetBuiltInCategory(
    ForgeTypeId categoryTypeId
)
Public Shared Function GetBuiltInCategory (
    categoryTypeId As ForgeTypeId
) As BuiltInCategory
public:
static BuiltInCategory GetBuiltInCategory(
    ForgeTypeId^ categoryTypeId
)
static member GetBuiltInCategory :
        categoryTypeId : ForgeTypeId -> BuiltInCategory

Parameters

categoryTypeId ForgeTypeId
The built-in category identifier.

Return Value

BuiltInCategory
The BuiltInCategory value corresponding to the given built-in category identifier.
Exceptions
Exception | Condition
ArgumentException | categoryTypeId is not a built-in category identifier. See Category.IsBuiltInCategory(ForgeTypeId) and Category.GetBuiltInCategoryTypeId(BuiltInCategory).
ArgumentNullException | A non-optional argument was null
Remarks
A ForgeTypeId identifies a built-in category if it corresponds to a valid BuiltInCategory value according to Category.IsBuiltInCategory(ForgeTypeId) and Category.GetBuiltInCategoryTypeId(BuiltInCategory).
See Also

Reference

Category Class


Category.GetBuiltInCategoryTypeId Method

CategoryGetBuiltInCategoryTypeId Method

Gets the ForgeTypeId identifying the given built-in category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GetBuiltInCategoryTypeId(
    BuiltInCategory categoryId
)
Public Shared Function GetBuiltInCategoryTypeId (
    categoryId As BuiltInCategory
) As ForgeTypeId
public:
static ForgeTypeId^ GetBuiltInCategoryTypeId(
    BuiltInCategory categoryId
)
static member GetBuiltInCategoryTypeId :
        categoryId : BuiltInCategory -> ForgeTypeId

Parameters

categoryId BuiltInCategory
The built-in category.

Return Value

ForgeTypeId
The identifier of the given built-in category.
Exceptions
Exception | Condition
ArgumentException | categoryId is not a valid built-in category. See Category.IsBuiltInCategoryValid(BuiltInCategory).
Remarks
The given BuiltInCategory value must be valid according to Category.IsBuiltInCategoryValid(BuiltInCategory).
See Also

Reference

Category Class


Category.GetCategory Method

CategoryGetCategory Method

Overload List
Name | Description
GetCategory(Document, BuiltInCategory) | Retrieves a category object corresponding to a BuiltInCategory id.
GetCategory(Document, ElementId) | Retrieves a category object corresponding to the category id.
Top
See Also

Reference

Category Class


Category.GetCategory(Document, BuiltInCategory) Method

CategoryGetCategory(Document, BuiltInCategory) Method

Retrieves a category object corresponding to a BuiltInCategory id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Category GetCategory(
    Document document,
    BuiltInCategory categoryId
)
Public Shared Function GetCategory (
    document As Document,
    categoryId As BuiltInCategory
) As Category
public:
static Category^ GetCategory(
    Document^ document,
    BuiltInCategory categoryId
)
static member GetCategory :
        document : Document *
        categoryId : BuiltInCategory -> Category

Parameters

document Document
The document.
categoryId BuiltInCategory
A built in category id.

Return Value

Category
Returns a category object corresponding to a BuiltInCategory id.
See Also

Reference

Category Class
GetCategory Overload


Category.GetCategory(Document, ElementId) Method

CategoryGetCategory(Document, ElementId) Method

Retrieves a category object corresponding to the category id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Category GetCategory(
    Document document,
    ElementId categoryId
)
Public Shared Function GetCategory (
    document As Document,
    categoryId As ElementId
) As Category
public:
static Category^ GetCategory(
    Document^ document,
    ElementId^ categoryId
)
static member GetCategory :
        document : Document *
        categoryId : ElementId -> Category

Parameters

document Document
The document.
categoryId ElementId
An category id.

Return Value

Category
Returns a category object corresponding to the category id.
See Also

Reference

Category Class
GetCategory Overload


Category.GetGraphicsStyle Method

CategoryGetGraphicsStyle Method

Gets the graphics style associated with this category for the given graphics style type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GraphicsStyle GetGraphicsStyle(
    GraphicsStyleType graphicsStyleType
)
Public Function GetGraphicsStyle (
    graphicsStyleType As GraphicsStyleType
) As GraphicsStyle
public:
GraphicsStyle^ GetGraphicsStyle(
    GraphicsStyleType graphicsStyleType
)
member GetGraphicsStyle :
        graphicsStyleType : GraphicsStyleType -> GraphicsStyle

Parameters

graphicsStyleType GraphicsStyleType
The type of graphics style.

Return Value

GraphicsStyle
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown when the input argument-"graphicsStyleType"-is out of range.
See Also

Reference

Category Class


Category.GetHashCode Method

CategoryGetHashCode Method

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Int32
See Also

Reference

Category Class


Category.GetLinePatternId Method

CategoryGetLinePatternId Method

Gets the line pattern id associated with this category for the given graphics style type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GetLinePatternId(
    GraphicsStyleType graphicsStyleType
)
Public Function GetLinePatternId (
    graphicsStyleType As GraphicsStyleType
) As ElementId
public:
ElementId^ GetLinePatternId(
    GraphicsStyleType graphicsStyleType
)
member GetLinePatternId :
        graphicsStyleType : GraphicsStyleType -> ElementId

Parameters

graphicsStyleType GraphicsStyleType
The type of graphics style.

Return Value

ElementId
Returns the line pattern id associated with this category for the given graphics style type.
Remarks
  • The line pattern id will be one of the following:
  • A negative value (representing a built-in line pattern)
  • The id of a LinePatternElement
  • InvalidElementId, indicating that this category does not have a stored line pattern id for this graphics style type.
See Also

Reference

Category Class


Category.GetLineWeight Method

CategoryGetLineWeight Method

Retrieves the line weight assigned to the category for the given graphics style type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int? GetLineWeight(
    GraphicsStyleType graphicsStyleType
)
Public Function GetLineWeight (
    graphicsStyleType As GraphicsStyleType
) As Integer?
public:
Nullable<int> GetLineWeight(
    GraphicsStyleType graphicsStyleType
)
member GetLineWeight :
        graphicsStyleType : GraphicsStyleType -> Nullable<int>

Parameters

graphicsStyleType GraphicsStyleType
The type of graphics style.

Return Value

Nullable Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown when the input argument-"graphicsStyleType"-is out of range.
See Also

Reference

Category Class


Category.IsBuiltInCategory Method

CategoryIsBuiltInCategory Method

Checks whether a ForgeTypeId identifies a built-in category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsBuiltInCategory(
    ForgeTypeId categoryTypeId
)
Public Shared Function IsBuiltInCategory (
    categoryTypeId As ForgeTypeId
) As Boolean
public:
static bool IsBuiltInCategory(
    ForgeTypeId^ categoryTypeId
)
static member IsBuiltInCategory :
        categoryTypeId : ForgeTypeId -> bool

Parameters

categoryTypeId ForgeTypeId
The identifier to check.

Return Value

Boolean
True if the ForgeTypeId identifies a built-in category, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
A ForgeTypeId identifies a built-in category if it corresponds to a valid BuiltInCategory value according to Category.IsBuiltInCategoryValid(BuiltInCategory) and Category.GetBuiltInCategoryTypeId(BuiltInCategory).
See Also

Reference

Category Class


Category.IsBuiltInCategoryValid Method

CategoryIsBuiltInCategoryValid Method

Checks if a Category exists for a given BuiltInCategory.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsBuiltInCategoryValid(
    BuiltInCategory builtInCategory
)
Public Shared Function IsBuiltInCategoryValid (
    builtInCategory As BuiltInCategory
) As Boolean
public:
static bool IsBuiltInCategoryValid(
    BuiltInCategory builtInCategory
)
static member IsBuiltInCategoryValid :
        builtInCategory : BuiltInCategory -> bool

Parameters

builtInCategory BuiltInCategory
The BuiltInCategory to check.

Return Value

Boolean
Remarks
Some BuiltInCategory values are obsolete and are kept for upgrade reasons. For those no Category exists.
See Also

Reference

Category Class


Category.SetLinePatternId Method

CategorySetLinePatternId Method

Sets the line pattern id associated with this category for the given graphics style type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetLinePatternId(
    ElementId linePatternId,
    GraphicsStyleType graphicsStyleType
)
Public Sub SetLinePatternId (
    linePatternId As ElementId,
    graphicsStyleType As GraphicsStyleType
)
public:
void SetLinePatternId(
    ElementId^ linePatternId,
    GraphicsStyleType graphicsStyleType
)
member SetLinePatternId :
        linePatternId : ElementId *
        graphicsStyleType : GraphicsStyleType -> unit

Parameters

linePatternId ElementId
The line pattern id for the graphics style.
graphicsStyleType GraphicsStyleType
The type of graphics style.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown when the input argument "linePatternId" is an illegal id.
InvalidOperationException | Thrown when this category does not have stored line pattern id for this graphics style type.
Remarks
  • The line pattern id will be one of the following:
  • A negative value (representing a built-in line pattern); this value can only be obtained via GetLinePatternId
  • The id of a LinePatternElement
See Also

Reference

Category Class


Category.SetLineWeight Method

CategorySetLineWeight Method

Sets the line weight for the given graphics style type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetLineWeight(
    int lineWeight,
    GraphicsStyleType graphicsStyleType
)
Public Sub SetLineWeight (
    lineWeight As Integer,
    graphicsStyleType As GraphicsStyleType
)
public:
void SetLineWeight(
    int lineWeight,
    GraphicsStyleType graphicsStyleType
)
member SetLineWeight :
        lineWeight : int *
        graphicsStyleType : GraphicsStyleType -> unit

Parameters

lineWeight Int32
graphicsStyleType GraphicsStyleType
The type of graphics style.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown when the input argument-"lineWeight" or "graphicsStyleType"-is out of range.
See Also

Reference

Category Class


CategoryNameMap Class

A map that contains a mapping of category name to its category object.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBCategoryNameMap
Autodesk.Revit.DBCategories

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CategoryNameMap : APIObject,
    IEnumerable
Public Class CategoryNameMap
    Inherits APIObject
    Implements IEnumerable
public ref class CategoryNameMap : public APIObject,
    IEnumerable
type CategoryNameMap =
    class
        inherit APIObject
        interface IEnumerable
    end

The CategoryNameMap type exposes the following members.

Constructors
 | Name | Description
Public method | CategoryNameMap | Initializes a new instance of the CategoryNameMap class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the map is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets a category at a specified name within the map.
Public property | Size | Returns the number of categories that are in the map.
Top
Methods
 | Name | Description
Public method | Clear | Removes every category from the map, rendering it empty.
Public method | Contains | Tests for the existence of a category with that name within the map.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase | Removes a category with the specified name from the map.
Public method | ForwardIterator | Retrieve a forward moving iterator to the map.
Public method | GetEnumerator | Retrieve a forward moving iterator to the map.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified category with the specified name into the map.
Public method | ReverseIterator | Retrieve a backward moving iterator to the map.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CategoryNameMap Constructor

Initializes a new instance of the CategoryNameMap class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CategoryNameMap()
Public Sub New
public:
CategoryNameMap()
new : unit -> CategoryNameMap
See Also

Reference

CategoryNameMap Class


CategoryNameMap Properties

The CategoryNameMap type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the map is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets a category at a specified name within the map.
Public property | Size | Returns the number of categories that are in the map.
Top
See Also

Reference

CategoryNameMap Class


CategoryNameMap.IsEmpty Property

CategoryNameMapIsEmpty Property

Test to see if the map is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Boolean
Remarks
If the map is empty then True will be returned, otherwise False.
See Also

Reference

CategoryNameMap Class


CategoryNameMap.Item Property

CategoryNameMapItem Property

Gets or sets a category at a specified name within the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Category this[
    string key
] { get; set; }
Public Overridable Property Item (
    key As String
) As Category
    Get
    Set
public:
virtual property Category^ Item[String^ key] {
    Category^ get (String^ key);
    void set (String^ key, Category^ value);
}
abstract Item : Category with get, set
override Item : Category with get, set

Parameters

key String
The name of the category to be set or retrieved.

Return Value

Category
Returns the category at the specified name.
See Also

Reference

CategoryNameMap Class


CategoryNameMap.Size Property

CategoryNameMapSize Property

Returns the number of categories that are in the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
abstract Size : int with get
override Size : int with get

Property Value

Int32
See Also

Reference

CategoryNameMap Class


CategoryNameMap Methods

The CategoryNameMap type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Removes every category from the map, rendering it empty.
Public method | Contains | Tests for the existence of a category with that name within the map.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase | Removes a category with the specified name from the map.
Public method | ForwardIterator | Retrieve a forward moving iterator to the map.
Public method | GetEnumerator | Retrieve a forward moving iterator to the map.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified category with the specified name into the map.
Public method | ReverseIterator | Retrieve a backward moving iterator to the map.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CategoryNameMap Class


CategoryNameMap.Clear Method

CategoryNameMapClear Method

Removes every category from the map, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

CategoryNameMap Class


CategoryNameMap.Contains Method

CategoryNameMapContains Method

Tests for the existence of a category with that name within the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Contains(
    string key
)
Public Overridable Function Contains (
    key As String
) As Boolean
public:
virtual bool Contains(
    String^ key
)
abstract Contains :
        key : string -> bool
override Contains :
        key : string -> bool

Parameters

key String
The category name to be searched for.

Return Value

Boolean
The Contains method returns True if the name is within the map, otherwise False.
See Also

Reference

CategoryNameMap Class


CategoryNameMap.Erase Method

CategoryNameMapErase Method

Removes a category with the specified name from the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Erase(
    string key
)
Public Overridable Function Erase (
    key As String
) As Integer
public:
virtual int Erase(
    String^ key
)
abstract Erase :
        key : string -> int
override Erase :
        key : string -> int

Parameters

key String
The name of the category to be erased.

Return Value

Int32
The number of categories that were erased from the map.
See Also

Reference

CategoryNameMap Class


CategoryNameMap.ForwardIterator Method

CategoryNameMapForwardIterator Method

Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual CategoryNameMapIterator ForwardIterator()
Public Overridable Function ForwardIterator As CategoryNameMapIterator
public:
virtual CategoryNameMapIterator^ ForwardIterator()
abstract ForwardIterator : unit -> CategoryNameMapIterator
override ForwardIterator : unit -> CategoryNameMapIterator

Return Value

CategoryNameMapIterator
Returns a forward moving iterator to the map.
See Also

Reference

CategoryNameMap Class


CategoryNameMap.GetEnumerator Method

CategoryNameMapGetEnumerator Method

Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

IEnumerator
Returns a forward moving iterator to the map.

Implements

IEnumerableGetEnumerator
See Also

Reference

CategoryNameMap Class


CategoryNameMap.Insert Method

CategoryNameMapInsert Method

Insert the specified category with the specified name into the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Insert(
    string key,
    Category item
)
Public Overridable Function Insert (
    key As String,
    item As Category
) As Boolean
public:
virtual bool Insert(
    String^ key,
    Category^ item
)
abstract Insert :
        key : string *
        item : Category -> bool
override Insert :
        key : string *
        item : Category -> bool

Parameters

key String
The name to be used for inserting the category into the map.
item Category
The category to be inserted into the map.

Return Value

Boolean
Returns whether the category was inserted into the map.
See Also

Reference

CategoryNameMap Class


CategoryNameMap.ReverseIterator Method

CategoryNameMapReverseIterator Method

Retrieve a backward moving iterator to the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual CategoryNameMapIterator ReverseIterator()
Public Overridable Function ReverseIterator As CategoryNameMapIterator
public:
virtual CategoryNameMapIterator^ ReverseIterator()
abstract ReverseIterator : unit -> CategoryNameMapIterator
override ReverseIterator : unit -> CategoryNameMapIterator

Return Value

CategoryNameMapIterator
Returns a backward moving iterator to the map.
See Also

Reference

CategoryNameMap Class


CategoryNameMapIterator Class

An iterator to a category name map.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBCategoryNameMapIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class CategoryNameMapIterator : APIObject,
    IEnumerator
Public MustInherit Class CategoryNameMapIterator
    Inherits APIObject
    Implements IEnumerator
public ref class CategoryNameMapIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type CategoryNameMapIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The CategoryNameMapIterator type exposes the following members.

Constructors
 | Name | Description
Public method | CategoryNameMapIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the category that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Key | Retrieves the category name that is the current focus of the iterator.
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the map.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CategoryNameMapIterator Constructor

For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CategoryNameMapIterator()
Public Sub New
public:
CategoryNameMapIterator()
new : unit -> CategoryNameMapIterator
Remarks
This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.
See Also

Reference

CategoryNameMapIterator Class


CategoryNameMapIterator Properties

The CategoryNameMapIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Retrieves the category that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Key | Retrieves the category name that is the current focus of the iterator.
Top
See Also

Reference

CategoryNameMapIterator Class


CategoryNameMapIterator.Current Property

CategoryNameMapIteratorCurrent Property

Retrieves the category that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}
abstract Current : Object with get
override Current : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.
See Also

Reference

CategoryNameMapIterator Class


CategoryNameMapIterator.Key Property

CategoryNameMapIteratorKey Property

Retrieves the category name that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Key { get; }
Public Overridable ReadOnly Property Key As String
    Get
public:
virtual property String^ Key {
    String^ get ();
}
abstract Key : string with get
override Key : string with get

Property Value

String
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid key as per expected behavior of IEnumerator.
See Also

Reference

CategoryNameMapIterator Class


CategoryNameMapIterator Methods

The CategoryNameMapIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the map.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CategoryNameMapIterator Class


CategoryNameMapIterator.MoveNext Method

CategoryNameMapIteratorMoveNext Method

Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the map.

Implements

IEnumeratorMoveNext
Remarks
MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.
See Also

Reference

CategoryNameMapIterator Class


CategoryNameMapIterator.Reset Method

CategoryNameMapIteratorReset Method

Bring the iterator back to the start of the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
Remarks
The Reset method will return the iterator back to the start of the map in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.
See Also

Reference

CategoryNameMapIterator Class


CategorySet Class

A set that can contains Category objects.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBCategorySet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CategorySet : APIObject,
    IEnumerable
Public Class CategorySet
    Inherits APIObject
    Implements IEnumerable
public ref class CategorySet : public APIObject,
    IEnumerable
type CategorySet =
    class
        inherit APIObject
        interface IEnumerable
    end

The CategorySet type exposes the following members.

Constructors
 | Name | Description
Public method | CategorySet | Initializes a new instance of the CategorySet class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Size | Returns the number of categories that are in the set.
Top
Methods
 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of a category within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase | Removes a specified category from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified category into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CategorySet Constructor

Initializes a new instance of the CategorySet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CategorySet()
Public Sub New
public:
CategorySet()
new : unit -> CategorySet
See Also

Reference

CategorySet Class


CategorySet Properties

The CategorySet type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Size | Returns the number of categories that are in the set.
Top
See Also

Reference

CategorySet Class


CategorySet.IsEmpty Property

CategorySetIsEmpty Property

Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Boolean
Remarks
If the set is empty then True will be returned, otherwise False.
See Also

Reference

CategorySet Class


CategorySet.Size Property

CategorySetSize Property

Returns the number of categories that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
abstract Size : int with get
override Size : int with get

Property Value

Int32
See Also

Reference

CategorySet Class


CategorySet Methods

The CategorySet type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of a category within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase | Removes a specified category from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified category into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CategorySet Class


CategorySet.Clear Method

CategorySetClear Method

Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

CategorySet Class


CategorySet.Contains Method

CategorySetContains Method

Tests for the existence of a category within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Contains(
    Category item
)
Public Overridable Function Contains (
    item As Category
) As Boolean
public:
virtual bool Contains(
    Category^ item
)
abstract Contains :
        item : Category -> bool
override Contains :
        item : Category -> bool

Parameters

item Category
The category to be searched for.

Return Value

Boolean
The Contains method returns True if the category is within the set, otherwise False.
See Also

Reference

CategorySet Class


CategorySet.Erase Method

CategorySetErase Method

Removes a specified category from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Erase(
    Category item
)
Public Overridable Function Erase (
    item As Category
) As Integer
public:
virtual int Erase(
    Category^ item
)
abstract Erase :
        item : Category -> int
override Erase :
        item : Category -> int

Parameters

item Category
The category to be erased.

Return Value

Int32
The number of items that were erased from the set.
See Also

Reference

CategorySet Class


CategorySet.ForwardIterator Method

CategorySetForwardIterator Method

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual CategorySetIterator ForwardIterator()
Public Overridable Function ForwardIterator As CategorySetIterator
public:
virtual CategorySetIterator^ ForwardIterator()
abstract ForwardIterator : unit -> CategorySetIterator
override ForwardIterator : unit -> CategorySetIterator

Return Value

CategorySetIterator
Returns a forward moving iterator to the set.
See Also

Reference

CategorySet Class


CategorySet.GetEnumerator Method

CategorySetGetEnumerator Method

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

IEnumerator
Returns a forward moving iterator to the set.

Implements

IEnumerableGetEnumerator
See Also

Reference

CategorySet Class


CategorySet.Insert Method

CategorySetInsert Method

Insert the specified category into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Insert(
    Category item
)
Public Overridable Function Insert (
    item As Category
) As Boolean
public:
virtual bool Insert(
    Category^ item
)
abstract Insert :
        item : Category -> bool
override Insert :
        item : Category -> bool

Parameters

item Category
The item to be inserted into the set.

Return Value

Boolean
Returns whether the item was inserted into the set.
See Also

Reference

CategorySet Class


CategorySet.ReverseIterator Method

CategorySetReverseIterator Method

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual CategorySetIterator ReverseIterator()
Public Overridable Function ReverseIterator As CategorySetIterator
public:
virtual CategorySetIterator^ ReverseIterator()
abstract ReverseIterator : unit -> CategorySetIterator
override ReverseIterator : unit -> CategorySetIterator

Return Value

CategorySetIterator
Returns a backward moving iterator to the set.
See Also

Reference

CategorySet Class


CategorySetIterator Class

An iterator to a category set.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBCategorySetIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class CategorySetIterator : APIObject,
    IEnumerator
Public MustInherit Class CategorySetIterator
    Inherits APIObject
    Implements IEnumerator
public ref class CategorySetIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type CategorySetIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The CategorySetIterator type exposes the following members.

Constructors
 | Name | Description
Public method | CategorySetIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CategorySetIterator Constructor

For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CategorySetIterator()
Public Sub New
public:
CategorySetIterator()
new : unit -> CategorySetIterator
Remarks
This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.
See Also

Reference

CategorySetIterator Class


CategorySetIterator Properties

The CategorySetIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

CategorySetIterator Class


CategorySetIterator.Current Property

CategorySetIteratorCurrent Property

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}
abstract Current : Object with get
override Current : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.
See Also

Reference

CategorySetIterator Class


CategorySetIterator Methods

The CategorySetIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CategorySetIterator Class


CategorySetIterator.MoveNext Method

CategorySetIteratorMoveNext Method

Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumeratorMoveNext
Remarks
MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.
See Also

Reference

CategorySetIterator Class


CategorySetIterator.Reset Method

CategorySetIteratorReset Method

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
Remarks
The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.
See Also

Reference

CategorySetIterator Class


CategoryType Enumeration

The type of category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum CategoryType
Public Enumeration CategoryType
public enum class CategoryType
type CategoryType
Members
Member name | Value | Description
Invalid | 0 | The category type is invalid.
Model | 1 | A model element category.
Annotation | 2 | An annotation element category.
Internal | 4 | The category is for internal usage.
AnalyticalModel | 5 | An analytical model element category.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Ceiling Class

Represents a ceiling in Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBHostObject
Autodesk.Revit.DBCeilingAndFloor
Autodesk.Revit.DBCeiling

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Ceiling : CeilingAndFloor
Public Class Ceiling
    Inherits CeilingAndFloor
public ref class Ceiling : public CeilingAndFloor
type Ceiling =
    class
        inherit CeilingAndFloor
    end

The Ceiling type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SketchId | Returns id of the sketch.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create(Document, IListCurveLoop, ElementId, ElementId) | Creates a new instance of ceiling within the project.
 | Create(Document, IListCurveLoop, ElementId, ElementId, Line, Double) | Creates a new instance of ceiling within the project.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Ceiling Properties

The Ceiling type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SketchId | Returns id of the sketch.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

Ceiling Class


Ceiling.SketchId Property

CeilingSketchId Property

Returns id of the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId SketchId { get; }
Public ReadOnly Property SketchId As ElementId
    Get
public:
property ElementId^ SketchId {
    ElementId^ get ();
}
member SketchId : ElementId with get

Property Value

ElementId
See Also

Reference

Ceiling Class


Ceiling Methods

The Ceiling type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create(Document, IListCurveLoop, ElementId, ElementId) | Creates a new instance of ceiling within the project.
 | Create(Document, IListCurveLoop, ElementId, ElementId, Line, Double) | Creates a new instance of ceiling within the project.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Ceiling Class


Ceiling.Create Method

CeilingCreate Method

Overload List
Name | Description
Create(Document, IListCurveLoop, ElementId, ElementId) | Creates a new instance of ceiling within the project.
Create(Document, IListCurveLoop, ElementId, ElementId, Line, Double) | Creates a new instance of ceiling within the project.
Top
See Also

Reference

Ceiling Class


Ceiling.Create(Document, IList<CurveLoop>, ElementId, ElementId) Method

CeilingCreate(Document, IListCurveLoop, ElementId, ElementId) Method

Creates a new instance of ceiling within the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Ceiling Create(
    Document document,
    IList<CurveLoop> curveLoops,
    ElementId ceilingTypeId,
    ElementId levelId
)
Public Shared Function Create (
    document As Document,
    curveLoops As IList(Of CurveLoop),
    ceilingTypeId As ElementId,
    levelId As ElementId
) As Ceiling
public:
static Ceiling^ Create(
    Document^ document,
    IList<CurveLoop^>^ curveLoops,
    ElementId^ ceilingTypeId,
    ElementId^ levelId
)
static member Create :
        document : Document *
        curveLoops : IList<CurveLoop> *
        ceilingTypeId : ElementId *
        levelId : ElementId -> Ceiling

Parameters

document Document
The document in which the new ceiling is created.
curveLoops IList CurveLoop
An array of planar curve loops that represent the profile of the ceiling.
ceilingTypeId ElementId
Id of the ceiling type to be used by the new ceiling. If InvalidElementId is passed, the default type will be used.
levelId ElementId
Id of the level on which the ceiling is to be placed.

Return Value

Ceiling
If successful a new ceiling object within the project.
Exceptions
Exception | Condition
ArgumentException | The ElementId levelId is not a Level. -or- The ElementId ceilingTypeId does not correspond to a CeilingType. -or- The input curve loops cannot compose a valid boundary, that means: the "curveLoops" collection is empty; or some curve loops intersect with each other; or each curve loop is not closed individually; or each curve loop is not planar; or each curve loop is not in a plane parallel to the horizontal(XY) plane; or input curves contain at least one helical curve. -or- Input curves build invalid sketch. -or- Failed to create curve elements.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Cannot generate a sketch. -or- Failed to create new element.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
To validate curve loop profile use BoundaryValidation.
Example
C#
VB
C++
F#
Copy
Ceiling CreateCeilingAtElevation(Document document, Level level, double elevation)
{
   XYZ first = new XYZ(0, 0, 0);
   XYZ second = new XYZ(20, 0, 0);
   XYZ third = new XYZ(20, 15, 0);
   XYZ fourth = new XYZ(0, 15, 0);
   CurveLoop profile = new CurveLoop();
   profile.Append(Line.CreateBound(first, second));
   profile.Append(Line.CreateBound(second, third));
   profile.Append(Line.CreateBound(third, fourth));
   profile.Append(Line.CreateBound(fourth, first));

   var ceiling = Ceiling.Create(document, new List<CurveLoop> { profile }, ElementId.InvalidElementId, level.Id);
   Parameter param = ceiling.get_Parameter(BuiltInParameter.CEILING_HEIGHTABOVELEVEL_PARAM);
   param.Set(elevation);

   return ceiling;
}
Private Function CreateCeilingAtElevation(ByVal document As Document, ByVal level As Level, ByVal elevation As Double) As Ceiling
    Dim first As XYZ = New XYZ(0, 0, 0)
    Dim second As XYZ = New XYZ(20, 0, 0)
    Dim third As XYZ = New XYZ(20, 15, 0)
    Dim fourth As XYZ = New XYZ(0, 15, 0)
    Dim profile As CurveLoop = New CurveLoop()
    profile.Append(Line.CreateBound(first, second))
    profile.Append(Line.CreateBound(second, third))
    profile.Append(Line.CreateBound(third, fourth))
    profile.Append(Line.CreateBound(fourth, first))
    Dim ceiling = Autodesk.Revit.DB.Ceiling.Create(document, New List(Of CurveLoop) From {
        profile
    }, ElementId.InvalidElementId, level.Id)
    Dim param As Parameter = ceiling.Parameter(BuiltInParameter.CEILING_HEIGHTABOVELEVEL_PARAM)
    param.[Set](elevation)
    Return ceiling
End Function

Private Function IExternalCommand_Execute(commandData As ExternalCommandData, ByRef message As String, elements As ElementSet) As Result Implements IExternalCommand.Execute
    Throw New NotImplementedException()
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Ceiling Class
Create Overload


Ceiling.Create(Document, IList<CurveLoop>, ElementId, ElementId, Line, Double) Method

CeilingCreate(Document, IListCurveLoop, ElementId, ElementId, Line, Double) Method

Creates a new instance of ceiling within the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Ceiling Create(
    Document document,
    IList<CurveLoop> curveLoops,
    ElementId ceilingTypeId,
    ElementId levelId,
    Line slopeArrow,
    double slope
)
Public Shared Function Create (
    document As Document,
    curveLoops As IList(Of CurveLoop),
    ceilingTypeId As ElementId,
    levelId As ElementId,
    slopeArrow As Line,
    slope As Double
) As Ceiling
public:
static Ceiling^ Create(
    Document^ document,
    IList<CurveLoop^>^ curveLoops,
    ElementId^ ceilingTypeId,
    ElementId^ levelId,
    Line^ slopeArrow,
    double slope
)
static member Create :
        document : Document *
        curveLoops : IList<CurveLoop> *
        ceilingTypeId : ElementId *
        levelId : ElementId *
        slopeArrow : Line *
        slope : float -> Ceiling

Parameters

document Document
The document in which the new ceiling is created.
curveLoops IList CurveLoop
An array of planar curve loops that represent the profile of the ceiling.
ceilingTypeId ElementId
Id of the ceiling type to be used by the new ceiling. If InvalidElementId is passed, the default type will be used.
levelId ElementId
Id of the level on which the ceiling is to be placed.
slopeArrow Line
A line used to control the slope angle of the Ceiling. It must be horizontal.
slope Double
The slope angle.

Return Value

Ceiling
If successful a new ceiling object within the project.
Exceptions
Exception | Condition
ArgumentException | The ElementId levelId is not a Level. -or- The ElementId ceilingTypeId does not correspond to a CeilingType. -or- The input curve loops cannot compose a valid boundary, that means: the "curveLoops" collection is empty; or some curve loops intersect with each other; or each curve loop is not closed individually; or each curve loop is not planar; or each curve loop is not in a plane parallel to the horizontal(XY) plane; or input curves contain at least one helical curve. -or- The slopeArrow must be a horizontal line. -or- Input curves build invalid sketch. -or- Failed to create curve elements.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Cannot generate a sketch. -or- Failed to create new element.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
To validate curve loop profile use BoundaryValidation.
Example
C#
VB
C++
F#
Copy
Ceiling CreateSlopedCeiling(Document document, Level level)
{
   XYZ first = new XYZ(0, 0, 0);
   XYZ second = new XYZ(20, 0, 0);
   XYZ third = new XYZ(20, 20, 0);
   XYZ fourth = new XYZ(0, 20, 0);
   CurveLoop profile = new CurveLoop();
   profile.Append(Line.CreateBound(first, second));
   profile.Append(Line.CreateBound(second, third));
   profile.Append(Line.CreateBound(third, fourth));
   profile.Append(Line.CreateBound(fourth, first));

   Line slopeArrow = Line.CreateBound(new XYZ(10, 10, 0), new XYZ(11, 10, 0));
   return Ceiling.Create(document, new List<CurveLoop> { profile }, ElementId.InvalidElementId, level.Id, slopeArrow, Math.PI / 2);
}
Private Function CreateSlopedCeiling(ByVal document As Document, ByVal level As Level) As Ceiling
    Dim first As XYZ = New XYZ(0, 0, 0)
    Dim second As XYZ = New XYZ(20, 0, 0)
    Dim third As XYZ = New XYZ(20, 20, 0)
    Dim fourth As XYZ = New XYZ(0, 20, 0)
    Dim profile As CurveLoop = New CurveLoop()
    profile.Append(Line.CreateBound(first, second))
    profile.Append(Line.CreateBound(second, third))
    profile.Append(Line.CreateBound(third, fourth))
    profile.Append(Line.CreateBound(fourth, first))
    Dim slopeArrow As Line = Line.CreateBound(New XYZ(10, 10, 0), New XYZ(11, 10, 0))
    Return Ceiling.Create(document, New List(Of CurveLoop) From {
        profile
    }, ElementId.InvalidElementId, level.Id, slopeArrow, Math.PI / 2)
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Ceiling Class
Create Overload


CeilingAndFloor Class

A base class that provides support for all ceiling and floor objects.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBHostObject
Autodesk.Revit.DBCeilingAndFloor
Autodesk.Revit.DB.ArchitectureBuildingPad
Autodesk.Revit.DBCeiling
Autodesk.Revit.DBFloor
Autodesk.Revit.DBToposolid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CeilingAndFloor : HostObject
Public Class CeilingAndFloor
    Inherits HostObject
public ref class CeilingAndFloor : public HostObject
type CeilingAndFloor =
    class
        inherit HostObject
    end

The CeilingAndFloor type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CeilingAndFloor Properties

The CeilingAndFloor type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

CeilingAndFloor Class


CeilingAndFloor Methods

The CeilingAndFloor type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CeilingAndFloor Class


CeilingType Class

Represents a ceiling type in Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBHostObjAttributes
Autodesk.Revit.DBCeilingType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CeilingType : HostObjAttributes
Public Class CeilingType
    Inherits HostObjAttributes
public ref class CeilingType : public HostObjAttributes
type CeilingType =
    class
        inherit HostObjAttributes
    end

The CeilingType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ThermalProperties | The calculated and settable thermal properties of the CeilingType
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CeilingType Properties

The CeilingType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ThermalProperties | The calculated and settable thermal properties of the CeilingType
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

CeilingType Class


CeilingType.ThermalProperties Property

CeilingTypeThermalProperties Property

The calculated and settable thermal properties of the CeilingType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ThermalProperties ThermalProperties { get; }
Public ReadOnly Property ThermalProperties As ThermalProperties
    Get
public:
property ThermalProperties^ ThermalProperties {
    ThermalProperties^ get ();
}
member ThermalProperties : ThermalProperties with get

Property Value

ThermalProperties
Exceptions
Exception | Condition
InvalidOperationException | The ceiling does not have thermal properties.
See Also

Reference

CeilingType Class


CeilingType Methods

The CeilingType type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CeilingType Class


CellType Enumeration

Declares the cell data type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum CellType
Public Enumeration CellType
public enum class CellType
type CellType
Members
Member name | Value | Description
Text | 0 | Simple text
Graphic | 1 | Embedded graphic
Parameter | 2 | Data bound parameter
Inherited | 3 | the type is inherited from the column or section if appropriate
CombinedParameter | 4 | The type is combined parameter
CalculatedValue | 5 | The type is a calculated value
ParameterText | 6 | Read only parameter which only show formatted string
CustomField | 7 | Data bounded to a Schedule Custom Field.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ChangePriority Enumeration

Enum used to specify the priority of an Updater during execution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ChangePriority
Public Enumeration ChangePriority
public enum class ChangePriority
type ChangePriority
Members
Member name | Value | Description
GridsLevelsReferencePlanes | 0 | Updater will modify core datums and major reference planes
Masses | 1 | Updater will modify masses
FloorsRoofsStructuralWalls | 2 | Updater will modify exterior shell of the building or floor slabs
Structure | 3 | Updater will modify structural elements like beams, braces, columns and trusses
InteriorWalls | 4 | Updater will modify interior/partition walls
DoorsOpeningsWindows | 5 | Updater will modify family instances that cut their hosts like doors and windows
MEPFixtures | 6 | Updater will modify MEP fixtures such as lights, sinks, equipment, etc.
RoomsSpacesZones | 7 | Updater will modify Rooms, MEP spaces or zones
MEPCalculations | 8 | Updater will update MEP calculated values
FreeStandingComponents | 9 | Updater will modify standalone components
Connections | 10 | Updater will modify connections
Rebar | 11 | Updater will modify rebar
MEPAccessoriesFittingsSegmentsWires | 12 | Updater will modify MEP elements such as segments, fittings and wires
MEPSystems | 13 | Updater will modify MEP systems or circuits
Views | 14 | Updater will modify views
DetailComponents | 15 | Updater will modify detail components and symbolic lines
Annotations | 16 | Updater will modify annotations
Remarks
The enumeration values are ordered in the order in which updaters associated to each priority will be run. For example, updaters associated to priority GridsLevelsReferencePlanes will run first, while updaters associated to priority Annotations will run last.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ChangeType Class

A class representing a change that can be detected and tracked during Dynamic Update.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBChangeType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ChangeType : IDisposable
Public Class ChangeType
    Implements IDisposable
public ref class ChangeType : IDisposable
type ChangeType =
    class
        interface IDisposable
    end

The ChangeType type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
 | ConcatenateChangeTypes | Creates a ChangeType that is a union of the two input ChangeTypes
Public method | Contains | Checks whether this ChangeType contains the input ChangeType
Public method | Dispose | Releases all resources used by the ChangeType
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsIdentical | Compares if two ChangeTypes are identical
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
ChangeTypes for specific changes can be obtained from the static methods available on Element.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ChangeType Properties

The ChangeType type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

ChangeType Class


ChangeType.IsValidObject Property

ChangeTypeIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ChangeType Class


ChangeType Methods

The ChangeType type exposes the following members.

Methods
 | Name | Description
 | ConcatenateChangeTypes | Creates a ChangeType that is a union of the two input ChangeTypes
Public method | Contains | Checks whether this ChangeType contains the input ChangeType
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsIdentical | Compares if two ChangeTypes are identical
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ChangeType Class


ChangeType.ConcatenateChangeTypes Method

ChangeTypeConcatenateChangeTypes Method

Creates a ChangeType that is a union of the two input ChangeTypes

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ChangeType ConcatenateChangeTypes(
    ChangeType changeType1,
    ChangeType changeType2
)
Public Shared Function ConcatenateChangeTypes (
    changeType1 As ChangeType,
    changeType2 As ChangeType
) As ChangeType
public:
static ChangeType^ ConcatenateChangeTypes(
    ChangeType^ changeType1,
    ChangeType^ changeType2
)
static member ConcatenateChangeTypes :
        changeType1 : ChangeType *
        changeType2 : ChangeType -> ChangeType

Parameters

changeType1 ChangeType
First input ChangeType to be concatenated
changeType2 ChangeType
Second input ChangeType to be concatenated

Return Value

ChangeType
A new ChangeType that is a concatenation/union of the input change types
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ChangeType Class


ChangeType.Contains Method

ChangeTypeContains Method

Checks whether this ChangeType contains the input ChangeType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Contains(
    ChangeType changeType
)
Public Function Contains (
    changeType As ChangeType
) As Boolean
public:
bool Contains(
    ChangeType^ changeType
)
member Contains :
        changeType : ChangeType -> bool

Parameters

changeType ChangeType

Return Value

Boolean
True if input changeType is contained by this ChangeType
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ChangeType Class


ChangeType.Dispose Method

ChangeTypeDispose Method

Releases all resources used by the ChangeType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ChangeType Class


ChangeType.IsIdentical Method

ChangeTypeIsIdentical Method

Compares if two ChangeTypes are identical

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsIdentical(
    ChangeType changeType
)
Public Function IsIdentical (
    changeType As ChangeType
) As Boolean
public:
bool IsIdentical(
    ChangeType^ changeType
)
member IsIdentical :
        changeType : ChangeType -> bool

Parameters

changeType ChangeType
Input ChangeType to be compared

Return Value

Boolean
True if the this ChangeType and input ChangeType are identical
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ChangeType Class


CheckoutStatus Enumeration

Indicates the ownership status of an element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum CheckoutStatus
Public Enumeration CheckoutStatus
public enum class CheckoutStatus
type CheckoutStatus
Members
Member name | Value | Description
OwnedByCurrentUser | 0 | The element is owned by the current user.
OwnedByOtherUser | 1 | The element is owned by some user other than the current user.
NotOwned | 2 | The element is not owned by any user.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


City Class

An object that contains geographical location information for a known city.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBCity

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class City : APIObject
Public Class City
    Inherits APIObject
public ref class City : public APIObject
type City =
    class
        inherit APIObject
    end

The City type exposes the following members.

Properties
 | Name | Description
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Latitude | Latitude of the city
Public property | Longitude | Longitude of the city
Public property | Name | The name of the city
Public property | TimeZone | Time-zone in which the city resides
Public property | WeatherStation | An identifier for the nearest weather station
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This object contains longitude, latitude, time zone information for a city already known by Revit. Currently Revit does not the ability to add cities to the existing list. The list of known cities can be retrieved using the Cities property on the application object.
Example
C#
VB
C++
F#
Copy
double angleRatio = Math.PI / 180;   // ratio of Angle

// Get the Latitude information
double latiude = city.Latitude / angleRatio;
String latiudeInfo = "Latitude:      " + latiude.ToString();

// Get the Longitude information
double longitude = city.Longitude / angleRatio;
String longitudeInfo = "Longitude:   " + longitude.ToString();

// Get the TimeZone information
String timeZoneInfo = "TimeZone:   " + city.TimeZone.ToString();

// Set the information text box.
string cityInfo = latiudeInfo + "\n" + longitudeInfo
                            + "\n" + timeZoneInfo;
Dim angleRatio As Double = Math.PI / 180
' ratio of Angle
' Get the Latitude information
Dim latiude As Double = city.Latitude / angleRatio
Dim latiudeInfo As [String] = "Latitude:      " & latiude.ToString()

' Get the Longitude information
Dim longitude As Double = city.Longitude / angleRatio
Dim longitudeInfo As [String] = "Longitude:   " & longitude.ToString()

' Get the TimeZone information
Dim timeZoneInfo As [String] = "TimeZone:   " & city.TimeZone.ToString()

' Set the information text box.
Dim cityInfo As String = latiudeInfo & vbLf & longitudeInfo & vbLf & timeZoneInfo

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


City Properties

The City type exposes the following members.

Properties
 | Name | Description
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Latitude | Latitude of the city
Public property | Longitude | Longitude of the city
Public property | Name | The name of the city
Public property | TimeZone | Time-zone in which the city resides
Public property | WeatherStation | An identifier for the nearest weather station
Top
See Also

Reference

City Class


City.Latitude Property

CityLatitude Property

Latitude of the city

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Latitude { get; }
Public ReadOnly Property Latitude As Double
    Get
public:
property double Latitude {
    double get ();
}
member Latitude : float with get

Property Value

Double
Remarks
A read only property that contains the latitude of the city. The value returned is in radians, ranging from -PI to +PI.
See Also

Reference

City Class


City.Longitude Property

CityLongitude Property

Longitude of the city

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Longitude { get; }
Public ReadOnly Property Longitude As Double
    Get
public:
property double Longitude {
    double get ();
}
member Longitude : float with get

Property Value

Double
Remarks
A read only property that contains the longitude of the city. The value returned is in radians, ranging from -PI to +PI.
See Also

Reference

City Class


City.Name Property

CityName Property

The name of the city

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

String
Remarks
A read only string property that contains the name of the city, such as Boston.
See Also

Reference

City Class


City.TimeZone Property

CityTimeZone Property

Time-zone in which the city resides

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double TimeZone { get; }
Public ReadOnly Property TimeZone As Double
    Get
public:
property double TimeZone {
    double get ();
}
member TimeZone : float with get

Property Value

Double
Remarks
A read only property that returns the time zone in which the city resides. The value is in hours, ranging from +12 hours to -12 hours with 0 being GMT.
See Also

Reference

City Class


City.WeatherStation Property

CityWeatherStation Property

An identifier for the nearest weather station

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string WeatherStation { get; }
Public ReadOnly Property WeatherStation As String
    Get
public:
property String^ WeatherStation {
    String^ get ();
}
member WeatherStation : string with get

Property Value

String
Remarks
A read only string property that contains an identifier of the nearest weather station.
See Also

Reference

City Class


City Methods

The City type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

City Class


CitySet Class

An set that contains cities.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBCitySet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CitySet : APIObject, IEnumerable
Public Class CitySet
    Inherits APIObject
    Implements IEnumerable
public ref class CitySet : public APIObject,
    IEnumerable
type CitySet =
    class
        inherit APIObject
        interface IEnumerable
    end

The CitySet type exposes the following members.

Constructors
 | Name | Description
Public method | CitySet | Initializes a new instance of the CitySet class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Size | Returns the number of cities that are in the set.
Top
Methods
 | Name | Description
Public method | Clear | Removes every city from the set, rendering it empty.
Public method | Contains | Tests for the existence of a city within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase | Removes a specified city from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified city into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CitySet Constructor

Initializes a new instance of the CitySet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CitySet()
Public Sub New
public:
CitySet()
new : unit -> CitySet
See Also

Reference

CitySet Class


CitySet Properties

The CitySet type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Size | Returns the number of cities that are in the set.
Top
See Also

Reference

CitySet Class


CitySet.IsEmpty Property

CitySetIsEmpty Property

Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Boolean
Remarks
If the set is empty then True will be returned, otherwise False.
See Also

Reference

CitySet Class


CitySet.Size Property

CitySetSize Property

Returns the number of cities that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
abstract Size : int with get
override Size : int with get

Property Value

Int32
See Also

Reference

CitySet Class


CitySet Methods

The CitySet type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Removes every city from the set, rendering it empty.
Public method | Contains | Tests for the existence of a city within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase | Removes a specified city from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified city into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CitySet Class


CitySet.Clear Method

CitySetClear Method

Removes every city from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

CitySet Class


CitySet.Contains Method

CitySetContains Method

Tests for the existence of a city within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Contains(
    City item
)
Public Overridable Function Contains (
    item As City
) As Boolean
public:
virtual bool Contains(
    City^ item
)
abstract Contains :
        item : City -> bool
override Contains :
        item : City -> bool

Parameters

item City
The city to be searched for.

Return Value

Boolean
The Contains method returns True if the city is within the set, otherwise False.
See Also

Reference

CitySet Class


CitySet.Erase Method

CitySetErase Method

Removes a specified city from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Erase(
    City item
)
Public Overridable Function Erase (
    item As City
) As Integer
public:
virtual int Erase(
    City^ item
)
abstract Erase :
        item : City -> int
override Erase :
        item : City -> int

Parameters

item City
The city to be erased.

Return Value

Int32
The number of cities that were erased from the set.
See Also

Reference

CitySet Class


CitySet.ForwardIterator Method

CitySetForwardIterator Method

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual CitySetIterator ForwardIterator()
Public Overridable Function ForwardIterator As CitySetIterator
public:
virtual CitySetIterator^ ForwardIterator()
abstract ForwardIterator : unit -> CitySetIterator
override ForwardIterator : unit -> CitySetIterator

Return Value

CitySetIterator
Returns a forward moving iterator to the set.
See Also

Reference

CitySet Class


CitySet.GetEnumerator Method

CitySetGetEnumerator Method

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

IEnumerator
Returns a forward moving iterator to the set.

Implements

IEnumerableGetEnumerator
See Also

Reference

CitySet Class


CitySet.Insert Method

CitySetInsert Method

Insert the specified city into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Insert(
    City item
)
Public Overridable Function Insert (
    item As City
) As Boolean
public:
virtual bool Insert(
    City^ item
)
abstract Insert :
        item : City -> bool
override Insert :
        item : City -> bool

Parameters

item City
The city to be inserted into the set.

Return Value

Boolean
Returns whether the city was inserted into the set.
See Also

Reference

CitySet Class


CitySet.ReverseIterator Method

CitySetReverseIterator Method

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual CitySetIterator ReverseIterator()
Public Overridable Function ReverseIterator As CitySetIterator
public:
virtual CitySetIterator^ ReverseIterator()
abstract ReverseIterator : unit -> CitySetIterator
override ReverseIterator : unit -> CitySetIterator

Return Value

CitySetIterator
Returns a backward moving iterator to the set.
See Also

Reference

CitySet Class


CitySetIterator Class

An iterator to a city set.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBCitySetIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class CitySetIterator : APIObject,
    IEnumerator
Public MustInherit Class CitySetIterator
    Inherits APIObject
    Implements IEnumerator
public ref class CitySetIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type CitySetIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The CitySetIterator type exposes the following members.

Constructors
 | Name | Description
Public method | CitySetIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CitySetIterator Constructor

For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CitySetIterator()
Public Sub New
public:
CitySetIterator()
new : unit -> CitySetIterator
Remarks
This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.
See Also

Reference

CitySetIterator Class


CitySetIterator Properties

The CitySetIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

CitySetIterator Class


CitySetIterator.Current Property

CitySetIteratorCurrent Property

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}
abstract Current : Object with get
override Current : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.
See Also

Reference

CitySetIterator Class


CitySetIterator Methods

The CitySetIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CitySetIterator Class


CitySetIterator.MoveNext Method

CitySetIteratorMoveNext Method

Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumeratorMoveNext
Remarks
MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.
See Also

Reference

CitySetIterator Class


CitySetIterator.Reset Method

CitySetIteratorReset Method

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
Remarks
The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.
See Also

Reference

CitySetIterator Class


ClassificationEntries Class

A collection of ClassificationEntry objects that make up the classification table.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBKeyBasedTreeEntries
Autodesk.Revit.DBClassificationEntries

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ClassificationEntries : KeyBasedTreeEntries
Public Class ClassificationEntries
    Inherits KeyBasedTreeEntries
public ref class ClassificationEntries : public KeyBasedTreeEntries
type ClassificationEntries =
    class
        inherit KeyBasedTreeEntries
    end

The ClassificationEntries type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from KeyBasedTreeEntries)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from KeyBasedTreeEntries)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | FindEntry | Finds the KeyBasedTreeEntry associated with the given key value. (Inherited from KeyBasedTreeEntries)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection. (Inherited from KeyBasedTreeEntries)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from KeyBasedTreeEntries)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetKeyBasedTreeEntriesIterator | Returns a KeyBasedTreeEntriesIterator that iterates through the collection. (Inherited from KeyBasedTreeEntries)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | LoadClassificationEntriesFromFile | Loads the contents of a classification text file into the provided KeyBasedTreeEntriesLoadContent.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ClassificationEntries Properties

The ClassificationEntries type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from KeyBasedTreeEntries)
Top
See Also

Reference

ClassificationEntries Class


ClassificationEntries Methods

The ClassificationEntries type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from KeyBasedTreeEntries)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | FindEntry | Finds the KeyBasedTreeEntry associated with the given key value. (Inherited from KeyBasedTreeEntries)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection. (Inherited from KeyBasedTreeEntries)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from KeyBasedTreeEntries)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetKeyBasedTreeEntriesIterator | Returns a KeyBasedTreeEntriesIterator that iterates through the collection. (Inherited from KeyBasedTreeEntries)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | LoadClassificationEntriesFromFile | Loads the contents of a classification text file into the provided KeyBasedTreeEntriesLoadContent.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ClassificationEntries Class


ClassificationEntries.LoadClassificationEntriesFromFile Method

ClassificationEntriesLoadClassificationEntriesFromFile Method

Loads the contents of a classification text file into the provided KeyBasedTreeEntriesLoadContent.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool LoadClassificationEntriesFromFile(
    string filePath,
    KeyBasedTreeEntriesLoadContent loadContent
)
Public Shared Function LoadClassificationEntriesFromFile (
    filePath As String,
    loadContent As KeyBasedTreeEntriesLoadContent
) As Boolean
public:
static bool LoadClassificationEntriesFromFile(
    String^ filePath,
    KeyBasedTreeEntriesLoadContent^ loadContent
)
static member LoadClassificationEntriesFromFile :
        filePath : string *
        loadContent : KeyBasedTreeEntriesLoadContent -> bool

Parameters

filePath String
The full path of the existing classification file.
loadContent KeyBasedTreeEntriesLoadContent
The classification entries read from the filePath will be added to this object. A KeyBasedTreeEntriesLoadContent object will also be updated to contain status information, including information about any errors that occurred while reading the keynote entries from the specified file.

Return Value

Boolean
True if reading the keynote file succeeds; False if the classification file cannot be read.
Exceptions
Exception | Condition
ArgumentException | filePath is an empty string. -or- The KeyBasedTreeEntries object owned by this KeyBasedTreeEntriesLoadContent object is built already. Adding more KeyBasedTreeEntries as well as repeated building, is not supported.
ArgumentNullException | A non-optional argument was null
InvalidPathArgumentException | The destination file name includes one or more invalid characters.
Remarks
The entries read from the file will be added to any existing entries read from other files before this reading operation in the provided KeyBasedTreeEntriesLoadContent. if file A was read, and then file B was failed to read, all the entries from file A will still be there to build KeynoteEntries object.
See Also

Reference

ClassificationEntries Class


ClassificationEntry Class

Represents an entry in the classification table.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBKeyBasedTreeEntry
Autodesk.Revit.DBClassificationEntry

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ClassificationEntry : KeyBasedTreeEntry
Public Class ClassificationEntry
    Inherits KeyBasedTreeEntry
public ref class ClassificationEntry : public KeyBasedTreeEntry
type ClassificationEntry =
    class
        inherit KeyBasedTreeEntry
    end

The ClassificationEntry type exposes the following members.

Constructors
 | Name | Description
Public method | ClassificationEntry | Constructs a ClassificationEntry object
Top
Properties
 | Name | Description
Public property | CategoryId | The id of the category associated with this entry.
Public property | Description | The description associated with this entry.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from KeyBasedTreeEntry)
Public property | Key | The key of this entry. (Inherited from KeyBasedTreeEntry)
Public property | Level | The entry level in the classification table. The expected range is between 1 and 5 inclusive.
Public property | ParentKey | The parent key of this entry. (Inherited from KeyBasedTreeEntry)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from KeyBasedTreeEntry)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetChildrenKeys | Gets a collection containing the keys of all children entry objects from this entry. (Inherited from KeyBasedTreeEntry)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HasBadCategoryId | Checks if the category id is Revit BuiltInCategory id.
Public method | HasBadLevel | Checks if the level is an integer in range between 1 and 5 inclusive.
Public method | HasInvalidKey | Checks if the key matches the level and parent key.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ClassificationEntry Constructor

Constructs a ClassificationEntry object

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ClassificationEntry(
    string key,
    string parentKey,
    string description,
    int level,
    ElementId categoryId
)
Public Sub New (
    key As String,
    parentKey As String,
    description As String,
    level As Integer,
    categoryId As ElementId
)
public:
ClassificationEntry(
    String^ key,
    String^ parentKey,
    String^ description,
    int level,
    ElementId^ categoryId
)
new :
        key : string *
        parentKey : string *
        description : string *
        level : int *
        categoryId : ElementId -> ClassificationEntry

Parameters

key String
The key of this ClassificationEntry.
parentKey String
The parent key of this ClassificationEntry.
description String
The description associated with this ClassificationEntry.
level Int32
The level of this ClassficationEntry.
categoryId ElementId
The category id of this ClassificationEntry. The category can be invalidElementId, otherwise it must represent Revit existing category.
Exceptions
Exception | Condition
ArgumentException | key is an empty string. -or- The categoryId is not appropriate category id for classfication entry.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ClassificationEntry Class


ClassificationEntry Properties

The ClassificationEntry type exposes the following members.

Properties
 | Name | Description
Public property | CategoryId | The id of the category associated with this entry.
Public property | Description | The description associated with this entry.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from KeyBasedTreeEntry)
Public property | Key | The key of this entry. (Inherited from KeyBasedTreeEntry)
Public property | Level | The entry level in the classification table. The expected range is between 1 and 5 inclusive.
Public property | ParentKey | The parent key of this entry. (Inherited from KeyBasedTreeEntry)
Top
See Also

Reference

ClassificationEntry Class


ClassificationEntry.CategoryId Property

ClassificationEntryCategoryId Property

The id of the category associated with this entry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId CategoryId { get; }
Public ReadOnly Property CategoryId As ElementId
    Get
public:
property ElementId^ CategoryId {
    ElementId^ get ();
}
member CategoryId : ElementId with get

Property Value

ElementId
See Also

Reference

ClassificationEntry Class


ClassificationEntry.Description Property

ClassificationEntryDescription Property

The description associated with this entry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get
public:
property String^ Description {
    String^ get ();
}
member Description : string with get

Property Value

String
See Also

Reference

ClassificationEntry Class


ClassificationEntry.Level Property

ClassificationEntryLevel Property

The entry level in the classification table. The expected range is between 1 and 5 inclusive.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Level { get; }
Public ReadOnly Property Level As Integer
    Get
public:
property int Level {
    int get ();
}
member Level : int with get

Property Value

Int32
See Also

Reference

ClassificationEntry Class


ClassificationEntry Methods

The ClassificationEntry type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from KeyBasedTreeEntry)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetChildrenKeys | Gets a collection containing the keys of all children entry objects from this entry. (Inherited from KeyBasedTreeEntry)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HasBadCategoryId | Checks if the category id is Revit BuiltInCategory id.
Public method | HasBadLevel | Checks if the level is an integer in range between 1 and 5 inclusive.
Public method | HasInvalidKey | Checks if the key matches the level and parent key.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ClassificationEntry Class


ClassificationEntry.HasBadCategoryId Method

ClassificationEntryHasBadCategoryId Method

Checks if the category id is Revit BuiltInCategory id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasBadCategoryId()
Public Function HasBadCategoryId As Boolean
public:
bool HasBadCategoryId()
member HasBadCategoryId : unit -> bool

Return Value

Boolean
True if the category id is not Revit BuiltInCategory id. False otherwise.
See Also

Reference

ClassificationEntry Class


ClassificationEntry.HasBadLevel Method

ClassificationEntryHasBadLevel Method

Checks if the level is an integer in range between 1 and 5 inclusive.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasBadLevel()
Public Function HasBadLevel As Boolean
public:
bool HasBadLevel()
member HasBadLevel : unit -> bool

Return Value

Boolean
True if the level is not an integer from 1 to 5 inclusive. False otherwise.
See Also

Reference

ClassificationEntry Class


ClassificationEntry.HasInvalidKey Method

ClassificationEntryHasInvalidKey Method

Checks if the key matches the level and parent key.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasInvalidKey()
Public Function HasInvalidKey As Boolean
public:
bool HasInvalidKey()
member HasInvalidKey : unit -> bool

Return Value

Boolean
True if the key doesn't matach the level and parent key. False otherwise.
See Also

Reference

ClassificationEntry Class


ClosestPointsPairBetweenTwoCurves Class

This class captures results of computation of closest points between two generic curves.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBClosestPointsPairBetweenTwoCurves

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ClosestPointsPairBetweenTwoCurves : IDisposable
Public Class ClosestPointsPairBetweenTwoCurves
    Implements IDisposable
public ref class ClosestPointsPairBetweenTwoCurves : IDisposable
type ClosestPointsPairBetweenTwoCurves =
    class
        interface IDisposable
    end

The ClosestPointsPairBetweenTwoCurves type exposes the following members.

Constructors
 | Name | Description
Public method | ClosestPointsPairBetweenTwoCurves | Obtain a new instance of ClosestPointsPairBetweenTwoCurves class.
Public method | ClosestPointsPairBetweenTwoCurves(ClosestPointsPairBetweenTwoCurves) | Creates a copy of the ClosestPointsPairBetweenTwoCurves.
Top
Properties
 | Name | Description
Public property | Distance | Distance from point on first curve to the point on second curve.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ParameterOnFirstCurve | 1d raw (not normalized) parameter of the point on the first curve.
Public property | ParameterOnSecondCurve | 1d raw (not normalized) parameter of the point on the second curve.
Public property | XYZPointOnFirstCurve | Point on the first curve in 3d coordinates.
Public property | XYZPointOnSecondCurve | Point on the second curve in 3d coordinates.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ClosestPointsPairBetweenTwoCurves
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ClosestPointsPairBetweenTwoCurves Constructor

Overload List
 | Name | Description
Public method | ClosestPointsPairBetweenTwoCurves | Obtain a new instance of ClosestPointsPairBetweenTwoCurves class.
Public method | ClosestPointsPairBetweenTwoCurves(ClosestPointsPairBetweenTwoCurves) | Creates a copy of the ClosestPointsPairBetweenTwoCurves.
Top
See Also

Reference

ClosestPointsPairBetweenTwoCurves Class


ClosestPointsPairBetweenTwoCurves Constructor

Obtain a new instance of ClosestPointsPairBetweenTwoCurves class.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ClosestPointsPairBetweenTwoCurves()
Public Sub New
public:
ClosestPointsPairBetweenTwoCurves()
new : unit -> ClosestPointsPairBetweenTwoCurves
See Also

Reference

ClosestPointsPairBetweenTwoCurves Class
ClosestPointsPairBetweenTwoCurves Overload


ClosestPointsPairBetweenTwoCurves(ClosestPointsPairBetweenTwoCurves) Constructor

Creates a copy of the ClosestPointsPairBetweenTwoCurves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ClosestPointsPairBetweenTwoCurves(
    ClosestPointsPairBetweenTwoCurves other
)
Public Sub New (
    other As ClosestPointsPairBetweenTwoCurves
)
public:
ClosestPointsPairBetweenTwoCurves(
    ClosestPointsPairBetweenTwoCurves^ other
)
new :
        other : ClosestPointsPairBetweenTwoCurves -> ClosestPointsPairBetweenTwoCurves

Parameters

other ClosestPointsPairBetweenTwoCurves
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ClosestPointsPairBetweenTwoCurves Class
ClosestPointsPairBetweenTwoCurves Overload


ClosestPointsPairBetweenTwoCurves Properties

The ClosestPointsPairBetweenTwoCurves type exposes the following members.

Properties
 | Name | Description
Public property | Distance | Distance from point on first curve to the point on second curve.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ParameterOnFirstCurve | 1d raw (not normalized) parameter of the point on the first curve.
Public property | ParameterOnSecondCurve | 1d raw (not normalized) parameter of the point on the second curve.
Public property | XYZPointOnFirstCurve | Point on the first curve in 3d coordinates.
Public property | XYZPointOnSecondCurve | Point on the second curve in 3d coordinates.
Top
See Also

Reference

ClosestPointsPairBetweenTwoCurves Class


ClosestPointsPairBetweenTwoCurves.Distance Property

ClosestPointsPairBetweenTwoCurvesDistance Property

Distance from point on first curve to the point on second curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Distance { get; set; }
Public Property Distance As Double
    Get
    Set
public:
property double Distance {
    double get ();
    void set (double value);
}
member Distance : float with get, set

Property Value

Double
Exceptions
Exception | Condition
InvalidOperationException | The property has not been set by the method providing the result.
See Also

Reference

ClosestPointsPairBetweenTwoCurves Class


ClosestPointsPairBetweenTwoCurves.IsValidObject Property

ClosestPointsPairBetweenTwoCurvesIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ClosestPointsPairBetweenTwoCurves Class


ClosestPointsPairBetweenTwoCurves.ParameterOnFirstCurve Property

ClosestPointsPairBetweenTwoCurvesParameterOnFirstCurve Property

1d raw (not normalized) parameter of the point on the first curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double ParameterOnFirstCurve { get; set; }
Public Property ParameterOnFirstCurve As Double
    Get
    Set
public:
property double ParameterOnFirstCurve {
    double get ();
    void set (double value);
}
member ParameterOnFirstCurve : float with get, set

Property Value

Double
Exceptions
Exception | Condition
InvalidOperationException | The property has not been set by the method providing the result.
See Also

Reference

ClosestPointsPairBetweenTwoCurves Class


ClosestPointsPairBetweenTwoCurves.ParameterOnSecondCurve Property

ClosestPointsPairBetweenTwoCurvesParameterOnSecondCurve Property

1d raw (not normalized) parameter of the point on the second curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double ParameterOnSecondCurve { get; set; }
Public Property ParameterOnSecondCurve As Double
    Get
    Set
public:
property double ParameterOnSecondCurve {
    double get ();
    void set (double value);
}
member ParameterOnSecondCurve : float with get, set

Property Value

Double
Exceptions
Exception | Condition
InvalidOperationException | The property has not been set by the method providing the result.
See Also

Reference

ClosestPointsPairBetweenTwoCurves Class


ClosestPointsPairBetweenTwoCurves.XYZPointOnFirstCurve Property

ClosestPointsPairBetweenTwoCurvesXYZPointOnFirstCurve Property

Point on the first curve in 3d coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ XYZPointOnFirstCurve { get; set; }
Public Property XYZPointOnFirstCurve As XYZ
    Get
    Set
public:
property XYZ^ XYZPointOnFirstCurve {
    XYZ^ get ();
    void set (XYZ^ value);
}
member XYZPointOnFirstCurve : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
InvalidOperationException | The property has not been set by the method providing the result.
See Also

Reference

ClosestPointsPairBetweenTwoCurves Class


ClosestPointsPairBetweenTwoCurves.XYZPointOnSecondCurve Property

ClosestPointsPairBetweenTwoCurvesXYZPointOnSecondCurve Property

Point on the second curve in 3d coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ XYZPointOnSecondCurve { get; set; }
Public Property XYZPointOnSecondCurve As XYZ
    Get
    Set
public:
property XYZ^ XYZPointOnSecondCurve {
    XYZ^ get ();
    void set (XYZ^ value);
}
member XYZPointOnSecondCurve : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
InvalidOperationException | The property has not been set by the method providing the result.
See Also

Reference

ClosestPointsPairBetweenTwoCurves Class


ClosestPointsPairBetweenTwoCurves Methods

The ClosestPointsPairBetweenTwoCurves type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ClosestPointsPairBetweenTwoCurves Class


ClosestPointsPairBetweenTwoCurves.Dispose Method

ClosestPointsPairBetweenTwoCurvesDispose Method

Releases all resources used by the ClosestPointsPairBetweenTwoCurves

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ClosestPointsPairBetweenTwoCurves Class


Color Class

Represents a color in Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBColor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Color : APIObject
Public Class Color
    Inherits APIObject
public ref class Color : public APIObject
type Color =
    class
        inherit APIObject
    end

The Color type exposes the following members.

Constructors
 | Name | Description
Public method | Color | Constructor that takes the red, green and blue channels of the color.
Top
Properties
 | Name | Description
Public property | Blue | Get the blue channel of the color. Setting a channel is obsolete in Autodesk Revit 2013. Please create a new color instead.
Public property | Green | Get the green channel of the color. Setting a channel is obsolete in Autodesk Revit 2013. Please create a new color instead.
 | InvalidColorValue | Get the invalid Color whose IntegerValue is -1.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | IsValid | Identifies if the color represents a valid color, or an uninitialized/invalid value.
Public property | Red | Get the red channel of the color. Setting a channel is obsolete in Autodesk Revit 2013. Please create a new color instead.
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Colors obtained from some API methods may represent an uninitialized/invalid color. You can identify these using the IsValid property.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Color Constructor

Constructor that takes the red, green and blue channels of the color.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color(
    byte red,
    byte green,
    byte blue
)
Public Sub New (
    red As Byte,
    green As Byte,
    blue As Byte
)
public:
Color(
    unsigned char red,
    unsigned char green,
    unsigned char blue
)
new :
        red : byte *
        green : byte *
        blue : byte -> Color

Parameters

red Byte
The red channel of the color that ranges from 0 to 255.
green Byte
The green channel of the color that ranges from 0 to 255.
blue Byte
The blue channel of the color that ranges from 0 to 255.
See Also

Reference

Color Class


Color Properties

The Color type exposes the following members.

Properties
 | Name | Description
Public property | Blue | Get the blue channel of the color. Setting a channel is obsolete in Autodesk Revit 2013. Please create a new color instead.
Public property | Green | Get the green channel of the color. Setting a channel is obsolete in Autodesk Revit 2013. Please create a new color instead.
 | InvalidColorValue | Get the invalid Color whose IntegerValue is -1.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | IsValid | Identifies if the color represents a valid color, or an uninitialized/invalid value.
Public property | Red | Get the red channel of the color. Setting a channel is obsolete in Autodesk Revit 2013. Please create a new color instead.
Top
See Also

Reference

Color Class


Color.Blue Property

ColorBlue Property

Get the blue channel of the color. Setting a channel is obsolete in Autodesk Revit 2013. Please create a new color instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte Blue { get; set; }
Public Property Blue As Byte
    Get
    Set
public:
property unsigned char Blue {
    unsigned char get ();
    void set (unsigned char value);
}
member Blue : byte with get, set

Property Value

Byte
Exceptions
Exception | Condition
InvalidOperationException | When getting the value: the color is invalid or uninitialized.
See Also

Reference

Color Class


Color.Green Property

ColorGreen Property

Get the green channel of the color. Setting a channel is obsolete in Autodesk Revit 2013. Please create a new color instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte Green { get; set; }
Public Property Green As Byte
    Get
    Set
public:
property unsigned char Green {
    unsigned char get ();
    void set (unsigned char value);
}
member Green : byte with get, set

Property Value

Byte
Exceptions
Exception | Condition
InvalidOperationException | When getting the value: the color is invalid or uninitialized.
See Also

Reference

Color Class


Color.InvalidColorValue Property

ColorInvalidColorValue Property

Get the invalid Color whose IntegerValue is -1.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Color InvalidColorValue { get; }
Public Shared ReadOnly Property InvalidColorValue As Color
    Get
public:
static property Color^ InvalidColorValue {
    Color^ get ();
}
static member InvalidColorValue : Color with get

Property Value

Color
See Also

Reference

Color Class


Color.IsValid Property

ColorIsValid Property

Identifies if the color represents a valid color, or an uninitialized/invalid value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValid { get; }
Public ReadOnly Property IsValid As Boolean
    Get
public:
property bool IsValid {
    bool get ();
}
member IsValid : bool with get

Property Value

Boolean
See Also

Reference

Color Class


Color.Red Property

ColorRed Property

Get the red channel of the color. Setting a channel is obsolete in Autodesk Revit 2013. Please create a new color instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte Red { get; set; }
Public Property Red As Byte
    Get
    Set
public:
property unsigned char Red {
    unsigned char get ();
    void set (unsigned char value);
}
member Red : byte with get, set

Property Value

Byte
Exceptions
Exception | Condition
InvalidOperationException | When getting the value: the color is invalid or uninitialized.
See Also

Reference

Color Class


Color Methods

The Color type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Color Class


ColorBackgroundSettings Class

Represents the rendering color background settings.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBackgroundSettings
Autodesk.Revit.DBColorBackgroundSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ColorBackgroundSettings : BackgroundSettings
Public Class ColorBackgroundSettings
    Inherits BackgroundSettings
public ref class ColorBackgroundSettings : public BackgroundSettings
type ColorBackgroundSettings =
    class
        inherit BackgroundSettings
    end

The ColorBackgroundSettings type exposes the following members.

Properties
 | Name | Description
Public property | Color | The color of the rendering background.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BackgroundSettings)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from BackgroundSettings)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ColorBackgroundSettings Properties

The ColorBackgroundSettings type exposes the following members.

Properties
 | Name | Description
Public property | Color | The color of the rendering background.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BackgroundSettings)
Top
See Also

Reference

ColorBackgroundSettings Class


ColorBackgroundSettings.Color Property

ColorBackgroundSettingsColor Property

The color of the rendering background.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color Color { get; set; }
Public Property Color As Color
    Get
    Set
public:
property Color^ Color {
    Color^ get ();
    void set (Color^ value);
}
member Color : Color with get, set

Property Value

Color
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ColorBackgroundSettings Class


ColorBackgroundSettings Methods

The ColorBackgroundSettings type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from BackgroundSettings)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ColorBackgroundSettings Class


ColorDepthType Enumeration

An enumerated type listing all Color Depth types of Print Setting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ColorDepthType
Public Enumeration ColorDepthType
public enum class ColorDepthType
type ColorDepthType
Members
Member name | Value | Description
BlackLine | 0 | The type of Color Depth is Black Line.
GrayScale | 1 | The type of Color Depth is Gray Scale.
Color | 2 | The type of Color Depth is Color.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ColorFillLegend Class

Represents color fill legend.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBColorFillLegend

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ColorFillLegend : Element
Public Class ColorFillLegend
    Inherits Element
public ref class ColorFillLegend : public Element
type ColorFillLegend =
    class
        inherit Element
    end

The ColorFillLegend type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | ColorFillCategoryId | Returns the id of color fill category that this legend is created for.
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | Height | The height of the legend.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | Origin | The top left corner of the color fill legend.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates new instance of ColorFillLegend.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetColumnWidths | Returns array of column widths in the legend.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetColumnWidths | Sets array of column widths.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

Color fill legend is a 2D annotation element, it can be created through Create(Document, ElementId, ElementId, XYZ) with specified category of color fill scheme, if there exists a valid color fill scheme activated for the category in the view. After a legend is created, its content and layout will keep consistent with the active color fill scheme of the view. You can adjust its position through Origin property, or manually maintain its layout through Height property andGetColumnWidths/[M:Autodesk.Revit.DB.ColorFillLegend.SetColumnWidths(System.Collections.Generic.IList`1{System.Double})] methods.

Notes:

  1. GetColorFillSchemeId(ElementId) could be used to retrieve the corresponding color fill scheme of this legend, through the [!:Autodesk::Revit::DB::View::ColorFillCategoryId] and OwnerViewId properties. Note that there could only exist one active scheme for all spatial categories (rooms, areas, and zones) in one view.
  2. Once the height and column widths are explicitly set, they will be fixed even if the contents of the legend change.
  3. To retrieve correct height and column widths, it's better to manually retrieve the geometry of legend for nonvisible views. (Because color fill legend is a view specific element.)
  4. The value of Height property does not contain the line that displays "Calculating...".
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ColorFillLegend Properties

The ColorFillLegend type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | ColorFillCategoryId | Returns the id of color fill category that this legend is created for.
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | Height | The height of the legend.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | Origin | The top left corner of the color fill legend.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

ColorFillLegend Class


ColorFillLegend.ColorFillCategoryId Property

ColorFillLegendColorFillCategoryId Property

Returns the id of color fill category that this legend is created for.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId ColorFillCategoryId { get; }
Public ReadOnly Property ColorFillCategoryId As ElementId
    Get
public:
property ElementId^ ColorFillCategoryId {
    ElementId^ get ();
}
member ColorFillCategoryId : ElementId with get

Property Value

ElementId
See Also

Reference

ColorFillLegend Class


ColorFillLegend.Height Property

ColorFillLegendHeight Property

The height of the legend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Height { get; set; }
Public Property Height As Double
    Get
    Set
public:
property double Height {
    double get ();
    void set (double value);
}
member Height : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The given value for height must be positive.
Remarks
Changing the height may result in a change in the count of columns.
See Also

Reference

ColorFillLegend Class


ColorFillLegend.Origin Property

ColorFillLegendOrigin Property

The top left corner of the color fill legend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Origin { get; set; }
Public Property Origin As XYZ
    Get
    Set
public:
property XYZ^ Origin {
    XYZ^ get ();
    void set (XYZ^ value);
}
member Origin : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
ArgumentException | When setting this property: The origin is not on the view plane that this legend is placed on.
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
The origin point must be on the view plane this legend is placed on.
See Also

Reference

ColorFillLegend Class


ColorFillLegend Methods

The ColorFillLegend type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates new instance of ColorFillLegend.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetColumnWidths | Returns array of column widths in the legend.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetColumnWidths | Sets array of column widths.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ColorFillLegend Class


ColorFillLegend.Create Method

ColorFillLegendCreate Method

Creates new instance of ColorFillLegend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ColorFillLegend Create(
    Document document,
    ElementId viewId,
    ElementId catetoryId,
    XYZ origin
)
Public Shared Function Create (
    document As Document,
    viewId As ElementId,
    catetoryId As ElementId,
    origin As XYZ
) As ColorFillLegend
public:
static ColorFillLegend^ Create(
    Document^ document,
    ElementId^ viewId,
    ElementId^ catetoryId,
    XYZ^ origin
)
static member Create :
        document : Document *
        viewId : ElementId *
        catetoryId : ElementId *
        origin : XYZ -> ColorFillLegend

Parameters

document Document
The document.
viewId ElementId
The id of the view to place legend in.
catetoryId ElementId
The id of category that color fill scheme belongs to.
origin XYZ
The origin point of the legend, must be on the view plane.

Return Value

ColorFillLegend
Exceptions
Exception | Condition
ArgumentException | document is not a project document. -or- There's no valid color fill scheme applied for catetoryId in viewId. -or- The origin is not on the view plane.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
Use SupportedColorFillCategoryIds to get list of supported categories.
See Also

Reference

ColorFillLegend Class


ColorFillLegend.GetColumnWidths Method

ColorFillLegendGetColumnWidths Method

Returns array of column widths in the legend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<double> GetColumnWidths()
Public Function GetColumnWidths As IList(Of Double)
public:
IList<double>^ GetColumnWidths()
member GetColumnWidths : unit -> IList<float>

Return Value

IList Double
See Also

Reference

ColorFillLegend Class


ColorFillLegend.SetColumnWidths Method

ColorFillLegendSetColumnWidths Method

Sets array of column widths.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetColumnWidths(
    IList<double> widths
)
Public Sub SetColumnWidths (
    widths As IList(Of Double)
)
public:
void SetColumnWidths(
    IList<double>^ widths
)
member SetColumnWidths :
        widths : IList<float> -> unit

Parameters

widths IList Double
Exceptions
Exception | Condition
ArgumentException | Array is not valid.
ArgumentNullException | A non-optional argument was null
Remarks
Input array length must be the same as what GetColumnWidths returns. It can only contain positive values.
See Also

Reference

ColorFillLegend Class


ColorFillScheme Class

Represents a color scheme could be used to colorfy elements in floor plan views and section views.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBColorFillScheme

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ColorFillScheme : Element
Public Class ColorFillScheme
    Inherits Element
public ref class ColorFillScheme : public Element
type ColorFillScheme =
    class
        inherit Element
    end

The ColorFillScheme type exposes the following members.

Properties
 | Name | Description
Public property | AreaSchemeId | Represents the id of AreaScheme of area plan views that this scheme could be applied to.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | CategoryId | Represents the element category that can be colored by this scheme.
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsByRange | Represents if the parameter values in entries are treated as value range or not.
Public property | IsLinkedFilesIncluded | Represent if the scheme includes entries whose parameter values are based on elements from linked files.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
Public property | ParameterDefinition | Represents the parameter of the elements that this scheme could be used to color.
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | StorageType | Represents the type of parameter values stored in entries.
Public property | Title | Represents the title displayed in ColorFillLegend.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | AddEntry | Adds new entry to the scheme.
Public method | AreEntriesConsistentWithScheme | Checks whether the entries can be set to the scheme or not.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDefineByRange | Checks whether the scheme entries can be explained by range.
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | CanRemoveEntry | Checks whether entry can be removed from the scheme.
Public method | CanUpdateEntry | Checks whether entry exists in the scheme and not the same as input one.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Generates a copy of current scheme.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetEntries | Retrieves copies of all entries.
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFormatOptions | Returns the FormatOptions of the scheme.
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetSupportedParameterIds | Retrieves collection of all parameters supported by the scheme.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsEntryConsistentWithScheme | Checks whether an entry can be added to the scheme or not.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidParameterDefinitionId | Checks whether the input parameter id can be applied to the scheme.
Public method | IsValidSchemeName | Checks whether the name is valid for new generated scheme.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveEntry | Removes an entry whose parameter value is the same as the input from the scheme
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetEntries | Update scheme entries in batch mode.
Public method | SetFormatOptions | Sets the FormatOptions of the scheme.
Public method | SortEntries | Sorts the scheme entries ascending.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UpdateEntry | Updates the scheme entry with the same parameter value as the input entry.
Top
Remarks

A color scheme is based on element category and one of the category parameter, it contains a set of ColorFillSchemeEntry which stores parameter value, color, fill pattern and other entry data. The entry paramater values may be a range or a single value, based on the IsByRange property. Then elements with the specified category could be colored with the color and fill pattern of matching entry whose parameter value or value range matches the element parameter value.

You can retrieve the entries with GetEntries, or modify entries with AddEntry(ColorFillSchemeEntry), RemoveEntry(ColorFillSchemeEntry), UpdateEntry(ColorFillSchemeEntry) and [M:Autodesk.Revit.DB.ColorFillScheme.SetEntries(System.Collections.Generic.IList`1{Autodesk.Revit.DB.ColorFillSchemeEntry})].

Unlike most of the other elements, the color scheme works in an "asynchronous" way in UI:

  1. If document elements change, the color scheme will not be updated immediately.
  2. If color schemes changes, the document elements will not be updated immediately too.

API works slightly different with UI:

  1. GetEntries will return the entries corresponding to the latest document elements status immediately.
  2. The entries modification operation will retrieve the latest entries with GetEntries at first, and then modify those entries by request, but document elements will still not be updated immediately.
  3. To modify multiple entries, it's better to use [M:Autodesk.Revit.DB.ColorFillScheme.SetEntries(System.Collections.Generic.IList`1{Autodesk.Revit.DB.ColorFillSchemeEntry})] but not modify them one by one with other methods for better performance.

Notes:

  • To apply a color scheme whose CategoryId property is OST_Areas to an area plan view, the AreaSchemeId property must be the same as the view if it is not used as a template.
  • To generate a new color scheme, you have to use Duplicate(String) method to duplicate form an existing one.
  • There should not exist two entries values that are the same in a color scheme. if the StorageType property is Double, then the value accuracy should be based on FormatOptions property.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ColorFillScheme Properties

The ColorFillScheme type exposes the following members.

Properties
 | Name | Description
Public property | AreaSchemeId | Represents the id of AreaScheme of area plan views that this scheme could be applied to.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | CategoryId | Represents the element category that can be colored by this scheme.
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsByRange | Represents if the parameter values in entries are treated as value range or not.
Public property | IsLinkedFilesIncluded | Represent if the scheme includes entries whose parameter values are based on elements from linked files.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
Public property | ParameterDefinition | Represents the parameter of the elements that this scheme could be used to color.
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | StorageType | Represents the type of parameter values stored in entries.
Public property | Title | Represents the title displayed in ColorFillLegend.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

ColorFillScheme Class


ColorFillScheme.AreaSchemeId Property

ColorFillSchemeAreaSchemeId Property

Represents the id of AreaScheme of area plan views that this scheme could be applied to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId AreaSchemeId { get; }
Public ReadOnly Property AreaSchemeId As ElementId
    Get
public:
property ElementId^ AreaSchemeId {
    ElementId^ get ();
}
member AreaSchemeId : ElementId with get

Property Value

ElementId
Remarks
Only meaningful if the CategoryId is OST_Areas.
See Also

Reference

ColorFillScheme Class


ColorFillScheme.CategoryId Property

ColorFillSchemeCategoryId Property

Represents the element category that can be colored by this scheme.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId CategoryId { get; }
Public ReadOnly Property CategoryId As ElementId
    Get
public:
property ElementId^ CategoryId {
    ElementId^ get ();
}
member CategoryId : ElementId with get

Property Value

ElementId
See Also

Reference

ColorFillScheme Class


ColorFillScheme.IsByRange Property

ColorFillSchemeIsByRange Property

Represents if the parameter values in entries are treated as value range or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsByRange { get; set; }
Public Property IsByRange As Boolean
    Get
    Set
public:
property bool IsByRange {
    bool get ();
    void set (bool value);
}
member IsByRange : bool with get, set

Property Value

Boolean
Exceptions
Exception | Condition
InvalidOperationException | When setting this property: The scheme entries cannot be explained by range.
Remarks

Notes:

  • Only numeric parameter values could be treated as by range.
  • There will exist at least two entries if the scheme is by range, and the first entry value should be always Int.MinValue or -Double.MaxValue.
  • The entries will always be sorted by ascending in the scheme if it is by range.
See Also

Reference

ColorFillScheme Class


ColorFillScheme.IsLinkedFilesIncluded Property

ColorFillSchemeIsLinkedFilesIncluded Property

Represent if the scheme includes entries whose parameter values are based on elements from linked files.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsLinkedFilesIncluded { get; set; }
Public Property IsLinkedFilesIncluded As Boolean
    Get
    Set
public:
property bool IsLinkedFilesIncluded {
    bool get ();
    void set (bool value);
}
member IsLinkedFilesIncluded : bool with get, set

Property Value

Boolean
See Also

Reference

ColorFillScheme Class


ColorFillScheme.ParameterDefinition Property

ColorFillSchemeParameterDefinition Property

Represents the parameter of the elements that this scheme could be used to color.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId ParameterDefinition { get; set; }
Public Property ParameterDefinition As ElementId
    Get
    Set
public:
property ElementId^ ParameterDefinition {
    ElementId^ get ();
    void set (ElementId^ value);
}
member ParameterDefinition : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentException | When setting this property: The paramId cannot be applied to the scheme.
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
When this property changed, all existing scheme entries will be removed from the scheme, and the value of IsByRange property will be set to false if the parameter storage type is not numeric.
See Also

Reference

ColorFillScheme Class


ColorFillScheme.StorageType Property

ColorFillSchemeStorageType Property

Represents the type of parameter values stored in entries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public StorageType StorageType { get; }
Public ReadOnly Property StorageType As StorageType
    Get
public:
property StorageType StorageType {
    StorageType get ();
}
member StorageType : StorageType with get

Property Value

StorageType
See Also

Reference

ColorFillScheme Class


ColorFillScheme.Title Property

ColorFillSchemeTitle Property

Represents the title displayed in ColorFillLegend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
member Title : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ColorFillScheme Class


ColorFillScheme Methods

The ColorFillScheme type exposes the following members.

Methods
 | Name | Description
Public method | AddEntry | Adds new entry to the scheme.
Public method | AreEntriesConsistentWithScheme | Checks whether the entries can be set to the scheme or not.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDefineByRange | Checks whether the scheme entries can be explained by range.
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | CanRemoveEntry | Checks whether entry can be removed from the scheme.
Public method | CanUpdateEntry | Checks whether entry exists in the scheme and not the same as input one.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Generates a copy of current scheme.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetEntries | Retrieves copies of all entries.
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFormatOptions | Returns the FormatOptions of the scheme.
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetSupportedParameterIds | Retrieves collection of all parameters supported by the scheme.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsEntryConsistentWithScheme | Checks whether an entry can be added to the scheme or not.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidParameterDefinitionId | Checks whether the input parameter id can be applied to the scheme.
Public method | IsValidSchemeName | Checks whether the name is valid for new generated scheme.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveEntry | Removes an entry whose parameter value is the same as the input from the scheme
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetEntries | Update scheme entries in batch mode.
Public method | SetFormatOptions | Sets the FormatOptions of the scheme.
Public method | SortEntries | Sorts the scheme entries ascending.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UpdateEntry | Updates the scheme entry with the same parameter value as the input entry.
Top
See Also

Reference

ColorFillScheme Class


ColorFillScheme.AddEntry Method

ColorFillSchemeAddEntry Method

Adds new entry to the scheme.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddEntry(
    ColorFillSchemeEntry entry
)
Public Sub AddEntry (
    entry As ColorFillSchemeEntry
)
public:
void AddEntry(
    ColorFillSchemeEntry^ entry
)
member AddEntry :
        entry : ColorFillSchemeEntry -> unit

Parameters

entry ColorFillSchemeEntry
Exceptions
Exception | Condition
ArgumentException | There already exists an entry with the same value in the scheme. -or- The entry value is out of range. -or- The scheme and the entry have different parameter storage type. -or- The fill pattern id is not valid for scheme.
ArgumentNullException | A non-optional argument was null
Remarks
To make sure that entry can be added to the scheme, call IsEntryConsistentWithScheme(ColorFillSchemeEntry) first.
See Also

Reference

ColorFillScheme Class


ColorFillScheme.AreEntriesConsistentWithScheme Method

ColorFillSchemeAreEntriesConsistentWithScheme Method

Checks whether the entries can be set to the scheme or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EntryAndSchemeConsistency AreEntriesConsistentWithScheme(
    IList<ColorFillSchemeEntry> entries
)
Public Function AreEntriesConsistentWithScheme (
    entries As IList(Of ColorFillSchemeEntry)
) As EntryAndSchemeConsistency
public:
EntryAndSchemeConsistency AreEntriesConsistentWithScheme(
    IList<ColorFillSchemeEntry^>^ entries
)
member AreEntriesConsistentWithScheme :
        entries : IList<ColorFillSchemeEntry> -> EntryAndSchemeConsistency

Parameters

entries IList ColorFillSchemeEntry
The entries to check.

Return Value

EntryAndSchemeConsistency
The state of the entries and scheme consistency.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ColorFillScheme Class


ColorFillScheme.CanDefineByRange Method

ColorFillSchemeCanDefineByRange Method

Checks whether the scheme entries can be explained by range.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanDefineByRange()
Public Function CanDefineByRange As Boolean
public:
bool CanDefineByRange()
member CanDefineByRange : unit -> bool

Return Value

Boolean
Returns true ifthe scheme entries can be explained by range, false otherwise.
See Also

Reference

ColorFillScheme Class


ColorFillScheme.CanRemoveEntry Method

ColorFillSchemeCanRemoveEntry Method

Checks whether entry can be removed from the scheme.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanRemoveEntry(
    ColorFillSchemeEntry entry
)
Public Function CanRemoveEntry (
    entry As ColorFillSchemeEntry
) As Boolean
public:
bool CanRemoveEntry(
    ColorFillSchemeEntry^ entry
)
member CanRemoveEntry :
        entry : ColorFillSchemeEntry -> bool

Parameters

entry ColorFillSchemeEntry
The entry to remove.

Return Value

Boolean
Returns true if entry can be removed from the scheme, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
An entry cannot be removed if it is in use or does not exist in the scheme.
See Also

Reference

ColorFillScheme Class


ColorFillScheme.CanUpdateEntry Method

ColorFillSchemeCanUpdateEntry Method

Checks whether entry exists in the scheme and not the same as input one.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanUpdateEntry(
    ColorFillSchemeEntry entry
)
Public Function CanUpdateEntry (
    entry As ColorFillSchemeEntry
) As Boolean
public:
bool CanUpdateEntry(
    ColorFillSchemeEntry^ entry
)
member CanUpdateEntry :
        entry : ColorFillSchemeEntry -> bool

Parameters

entry ColorFillSchemeEntry
The entry to be updated.

Return Value

Boolean
Returns true if entry exist in scheme and not the same as input one, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ColorFillScheme Class


ColorFillScheme.Duplicate Method

ColorFillSchemeDuplicate Method

Generates a copy of current scheme.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId Duplicate(
    string name
)
Public Function Duplicate (
    name As String
) As ElementId
public:
ElementId^ Duplicate(
    String^ name
)
member Duplicate :
        name : string -> ElementId

Parameters

name String
The desired name of copied scheme.

Return Value

ElementId
The id of copied scheme.
Exceptions
Exception | Condition
ArgumentException | The name is not valid for new generated scheme.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ColorFillScheme Class


ColorFillScheme.GetEntries Method

ColorFillSchemeGetEntries Method

Retrieves copies of all entries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ColorFillSchemeEntry> GetEntries()
Public Function GetEntries As IList(Of ColorFillSchemeEntry)
public:
IList<ColorFillSchemeEntry^>^ GetEntries()
member GetEntries : unit -> IList<ColorFillSchemeEntry>

Return Value

IList ColorFillSchemeEntry
Remarks
This method recalculates entries based on the current parameter values of the elements colored by the scheme.
See Also

Reference

ColorFillScheme Class


ColorFillScheme.GetFormatOptions Method

ColorFillSchemeGetFormatOptions Method

Returns the FormatOptions of the scheme.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormatOptions GetFormatOptions()
Public Function GetFormatOptions As FormatOptions
public:
FormatOptions^ GetFormatOptions()
member GetFormatOptions : unit -> FormatOptions

Return Value

FormatOptions
Remarks
This method will return the default FormatOptions if the scheme is by value.
See Also

Reference

ColorFillScheme Class


ColorFillScheme.GetSupportedParameterIds Method

ColorFillSchemeGetSupportedParameterIds Method

Retrieves collection of all parameters supported by the scheme.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ElementId> GetSupportedParameterIds()
Public Function GetSupportedParameterIds As IList(Of ElementId)
public:
IList<ElementId^>^ GetSupportedParameterIds()
member GetSupportedParameterIds : unit -> IList<ElementId>

Return Value

IList ElementId
Remarks
Supported parameters depends on CategoryId property.
See Also

Reference

ColorFillScheme Class


ColorFillScheme.IsEntryConsistentWithScheme Method

ColorFillSchemeIsEntryConsistentWithScheme Method

Checks whether an entry can be added to the scheme or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EntryAndSchemeConsistency IsEntryConsistentWithScheme(
    ColorFillSchemeEntry entry
)
Public Function IsEntryConsistentWithScheme (
    entry As ColorFillSchemeEntry
) As EntryAndSchemeConsistency
public:
EntryAndSchemeConsistency IsEntryConsistentWithScheme(
    ColorFillSchemeEntry^ entry
)
member IsEntryConsistentWithScheme :
        entry : ColorFillSchemeEntry -> EntryAndSchemeConsistency

Parameters

entry ColorFillSchemeEntry
The entry to check.

Return Value

EntryAndSchemeConsistency
The state of entry and scheme consistency.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ColorFillScheme Class


ColorFillScheme.IsValidParameterDefinitionId Method

ColorFillSchemeIsValidParameterDefinitionId Method

Checks whether the input parameter id can be applied to the scheme.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidParameterDefinitionId(
    ElementId parameterId
)
Public Function IsValidParameterDefinitionId (
    parameterId As ElementId
) As Boolean
public:
bool IsValidParameterDefinitionId(
    ElementId^ parameterId
)
member IsValidParameterDefinitionId :
        parameterId : ElementId -> bool

Parameters

parameterId ElementId

Return Value

Boolean
Returns true if the input parameter id can be set to this scheme, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ColorFillScheme Class


ColorFillScheme.IsValidSchemeName Method

ColorFillSchemeIsValidSchemeName Method

Checks whether the name is valid for new generated scheme.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidSchemeName(
    string name
)
Public Function IsValidSchemeName (
    name As String
) As Boolean
public:
bool IsValidSchemeName(
    String^ name
)
member IsValidSchemeName :
        name : string -> bool

Parameters

name String

Return Value

Boolean
Returns true if the name is valid for new generated scheme, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
The name should not be empty, or all spaces, or include prohibited characters or duplicated with existing schemes.
See Also

Reference

ColorFillScheme Class


ColorFillScheme.RemoveEntry Method

ColorFillSchemeRemoveEntry Method

Removes an entry whose parameter value is the same as the input from the scheme

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveEntry(
    ColorFillSchemeEntry entry
)
Public Sub RemoveEntry (
    entry As ColorFillSchemeEntry
)
public:
void RemoveEntry(
    ColorFillSchemeEntry^ entry
)
member RemoveEntry :
        entry : ColorFillSchemeEntry -> unit

Parameters

entry ColorFillSchemeEntry
The entry to remove.
Exceptions
Exception | Condition
ArgumentException | The entry cannot be removed from the scheme.
ArgumentNullException | A non-optional argument was null
Remarks
The entry can not be removed if it is in use.
See Also

Reference

ColorFillScheme Class


ColorFillScheme.SetEntries Method

ColorFillSchemeSetEntries Method

Update scheme entries in batch mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetEntries(
    IList<ColorFillSchemeEntry> entries
)
Public Sub SetEntries (
    entries As IList(Of ColorFillSchemeEntry)
)
public:
void SetEntries(
    IList<ColorFillSchemeEntry^>^ entries
)
member SetEntries :
        entries : IList<ColorFillSchemeEntry> -> unit

Parameters

entries IList ColorFillSchemeEntry
Collection of new entries.
Exceptions
Exception | Condition
ArgumentException | There exists entries whose values are duplicated in the input entries. -or- There exists at lease one entry whose value is invalid for the scheme in the input entries. -or- There exists at least one entry in the input entries whose storage type is different with the scheme. -or- There exists at least one entry in the input entries whose fill pattern is invalid for color fill scheme. -or- There exists some inconsistent in the input entries.
ArgumentNullException | A non-optional argument was null
Remarks

For by range scheme:

  • If there is only one entry in the input, Revit will generate another one automatically.
  • If the first existing entry is found in the input, it will be updated, otherwise keep not changed.
  • If the other existing entries are found in the input, they will be updated, otherwise removed.

For by value scheme:

  • For an existing entry that is in use, it will be updated if it can be found in the input, otherwise keep not changed.
  • For an existing entry that is no in use, it will be updated if it can be found in the input, otherwise removed.
  • If an entry in the input cannot be found in the existing entries, it will be added to the scheme.

To make sure that entry can be added to the scheme, call [M:Autodesk.Revit.DB.ColorFillScheme.AreEntriesConsistentWithScheme(System.Collections.Generic.IList`1{Autodesk.Revit.DB.ColorFillSchemeEntry})] first.

See Also

Reference

ColorFillScheme Class


ColorFillScheme.SetFormatOptions Method

ColorFillSchemeSetFormatOptions Method

Sets the FormatOptions of the scheme.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetFormatOptions(
    FormatOptions formatOptions
)
Public Sub SetFormatOptions (
    formatOptions As FormatOptions
)
public:
void SetFormatOptions(
    FormatOptions^ formatOptions
)
member SetFormatOptions :
        formatOptions : FormatOptions -> unit

Parameters

formatOptions FormatOptions
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
This method will set the FormatOptions if the scheme is by range, otherwise do nothing.
See Also

Reference

ColorFillScheme Class


ColorFillScheme.SortEntries Method

ColorFillSchemeSortEntries Method

Sorts the scheme entries ascending.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SortEntries()
Public Sub SortEntries
public:
void SortEntries()
member SortEntries : unit -> unit
Remarks
If the scheme parameter value storage type is ElementId, then the order of entries would be based on the name of the elements.
See Also

Reference

ColorFillScheme Class


ColorFillScheme.UpdateEntry Method

ColorFillSchemeUpdateEntry Method

Updates the scheme entry with the same parameter value as the input entry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void UpdateEntry(
    ColorFillSchemeEntry entry
)
Public Sub UpdateEntry (
    entry As ColorFillSchemeEntry
)
public:
void UpdateEntry(
    ColorFillSchemeEntry^ entry
)
member UpdateEntry :
        entry : ColorFillSchemeEntry -> unit

Parameters

entry ColorFillSchemeEntry
The entry to be updated.
Exceptions
Exception | Condition
ArgumentException | The entry does not exist or the same as input one. -or- The entry does not exist or all the updating fields are the same as existing one.
ArgumentNullException | A non-optional argument was null
Remarks

The following entry fields can be updated:

  • Color
  • FillPattenId
  • Caption
  • IsVisible
/
See Also

Reference

ColorFillScheme Class


ColorFillSchemeEntry Class

Represents an entry of a [!:Autodesk::Revit::DB::ColorFillScheme].
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBColorFillSchemeEntry

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ColorFillSchemeEntry : IDisposable
Public Class ColorFillSchemeEntry
    Implements IDisposable
public ref class ColorFillSchemeEntry : IDisposable
type ColorFillSchemeEntry =
    class
        interface IDisposable
    end

The ColorFillSchemeEntry type exposes the following members.

Constructors
 | Name | Description
Public method | ColorFillSchemeEntry | Creates new ColorFillSchemeEntry.
Top
Properties
 | Name | Description
Public property | Caption | The text displayed in [!:Autodesk::Revit::DB::ColorFillLegend] for this entry.
Public property | Color | The filling color of this entry.
Public property | FillPatternId | The id of fill pattern element of this entry.
Public property | IsInUse | Represents if there exists at least one element colored based on this entry in the document.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | IsVisible | Represents if the element colored based on this entry is visible in views.
Public property | StorageType | The storage type of the value stored in this entry.
Top
Methods
 | Name | Description
Public method | CanSetValue(Double) | Checks whether StorageType of entry is Double and the value is no less than 0.0.
Public method | CanSetValue(ElementId) | Checks whether StorageType of entry is ElementId.
Public method | CanSetValue(Int32) | Checks whether StorageType of entry is Integer.
Public method | Dispose | Releases all resources used by the ColorFillSchemeEntry
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetDoubleValue | Gets the Double value stored within the entry.
Public method | GetElementIdValue | Gets the ElementId value stored within the entry.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIntegerValue | Gets the Integer value stored within the entry.
Public method | GetStringValue | Gets the String value stored within the entry.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetDoubleValue | Sets new Double value of entry.
Public method | SetElementIdValue | Sets new ElementId value of entry.
Public method | SetIntegerValue | Sets new Integer value of entry.
Public method | SetStringValue | Sets new String value of entry.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ColorFillSchemeEntry Constructor

Creates new ColorFillSchemeEntry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ColorFillSchemeEntry(
    StorageType storageType
)
Public Sub New (
    storageType As StorageType
)
public:
ColorFillSchemeEntry(
    StorageType storageType
)
new :
        storageType : StorageType -> ColorFillSchemeEntry

Parameters

storageType StorageType
The type of data that could be stored into this entry.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Remarks
A new created ColorFillSchemeEntry should be assigned proper value before it is applied to a [!:Autodesk::Revit::DB::ColorFillScheme]. If the Color and Caption properties are not set, Revit will generate them automatically after the ColorFillSchemeEntry is applied to the ColorFillScheme.
See Also

Reference

ColorFillSchemeEntry Class


ColorFillSchemeEntry Properties

The ColorFillSchemeEntry type exposes the following members.

Properties
 | Name | Description
Public property | Caption | The text displayed in [!:Autodesk::Revit::DB::ColorFillLegend] for this entry.
Public property | Color | The filling color of this entry.
Public property | FillPatternId | The id of fill pattern element of this entry.
Public property | IsInUse | Represents if there exists at least one element colored based on this entry in the document.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | IsVisible | Represents if the element colored based on this entry is visible in views.
Public property | StorageType | The storage type of the value stored in this entry.
Top
See Also

Reference

ColorFillSchemeEntry Class


ColorFillSchemeEntry.Caption Property

ColorFillSchemeEntryCaption Property

The text displayed in [!:Autodesk::Revit::DB::ColorFillLegend] for this entry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Caption { get; set; }
Public Property Caption As String
    Get
    Set
public:
property String^ Caption {
    String^ get ();
    void set (String^ value);
}
member Caption : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentException | When setting this property: newCaption is an empty string or contains only whitespace.
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
This property is only meaningful for by range scheme.
See Also

Reference

ColorFillSchemeEntry Class


ColorFillSchemeEntry.Color Property

ColorFillSchemeEntryColor Property

The filling color of this entry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color Color { get; set; }
Public Property Color As Color
    Get
    Set
public:
property Color^ Color {
    Color^ get ();
    void set (Color^ value);
}
member Color : Color with get, set

Property Value

Color
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ColorFillSchemeEntry Class


ColorFillSchemeEntry.FillPatternId Property

ColorFillSchemeEntryFillPatternId Property

The id of fill pattern element of this entry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId FillPatternId { get; set; }
Public Property FillPatternId As ElementId
    Get
    Set
public:
property ElementId^ FillPatternId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member FillPatternId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
  • InvalidElementid represents no pattern, that means there would be nothing to be filled for elements colored based on this entry.
  • Only fill pattern elements whose fill pattern target is drafting is valid for color fill scheme.
See Also

Reference

ColorFillSchemeEntry Class


ColorFillSchemeEntry.IsInUse Property

ColorFillSchemeEntryIsInUse Property

Represents if there exists at least one element colored based on this entry in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsInUse { get; }
Public ReadOnly Property IsInUse As Boolean
    Get
public:
property bool IsInUse {
    bool get ();
}
member IsInUse : bool with get

Property Value

Boolean
See Also

Reference

ColorFillSchemeEntry Class


ColorFillSchemeEntry.IsValidObject Property

ColorFillSchemeEntryIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ColorFillSchemeEntry Class


ColorFillSchemeEntry.IsVisible Property

ColorFillSchemeEntryIsVisible Property

Represents if the element colored based on this entry is visible in views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsVisible { get; set; }
Public Property IsVisible As Boolean
    Get
    Set
public:
property bool IsVisible {
    bool get ();
    void set (bool value);
}
member IsVisible : bool with get, set

Property Value

Boolean
See Also

Reference

ColorFillSchemeEntry Class


ColorFillSchemeEntry.StorageType Property

ColorFillSchemeEntryStorageType Property

The storage type of the value stored in this entry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public StorageType StorageType { get; }
Public ReadOnly Property StorageType As StorageType
    Get
public:
property StorageType StorageType {
    StorageType get ();
}
member StorageType : StorageType with get

Property Value

StorageType
See Also

Reference

ColorFillSchemeEntry Class


ColorFillSchemeEntry Methods

The ColorFillSchemeEntry type exposes the following members.

Methods
 | Name | Description
Public method | CanSetValue(Double) | Checks whether StorageType of entry is Double and the value is no less than 0.0.
Public method | CanSetValue(ElementId) | Checks whether StorageType of entry is ElementId.
Public method | CanSetValue(Int32) | Checks whether StorageType of entry is Integer.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetDoubleValue | Gets the Double value stored within the entry.
Public method | GetElementIdValue | Gets the ElementId value stored within the entry.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIntegerValue | Gets the Integer value stored within the entry.
Public method | GetStringValue | Gets the String value stored within the entry.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetDoubleValue | Sets new Double value of entry.
Public method | SetElementIdValue | Sets new ElementId value of entry.
Public method | SetIntegerValue | Sets new Integer value of entry.
Public method | SetStringValue | Sets new String value of entry.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ColorFillSchemeEntry Class


ColorFillSchemeEntry.CanSetValue Method

ColorFillSchemeEntryCanSetValue Method

Overload List
 | Name | Description
Public method | CanSetValue(Double) | Checks whether StorageType of entry is Double and the value is no less than 0.0.
Public method | CanSetValue(ElementId) | Checks whether StorageType of entry is ElementId.
Public method | CanSetValue(Int32) | Checks whether StorageType of entry is Integer.
Top
See Also

Reference

ColorFillSchemeEntry Class


ColorFillSchemeEntry.CanSetValue(Double) Method

ColorFillSchemeEntryCanSetValue(Double) Method

Checks whether StorageType of entry is Double and the value is no less than 0.0.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanSetValue(
    double value
)
Public Function CanSetValue (
    value As Double
) As Boolean
public:
bool CanSetValue(
    double value
)
member CanSetValue :
        value : float -> bool

Parameters

value Double
New Double value.

Return Value

Boolean
True if StorageType of the entry is Double and the value is finite, false otherwise.
See Also

Reference

ColorFillSchemeEntry Class
CanSetValue Overload


ColorFillSchemeEntry.CanSetValue(ElementId) Method

ColorFillSchemeEntryCanSetValue(ElementId) Method

Checks whether StorageType of entry is ElementId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanSetValue(
    ElementId value
)
Public Function CanSetValue (
    value As ElementId
) As Boolean
public:
bool CanSetValue(
    ElementId^ value
)
member CanSetValue :
        value : ElementId -> bool

Parameters

value ElementId
New ElementId value.

Return Value

Boolean
True if StorageType of the entry is ElementId and the entry, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ColorFillSchemeEntry Class
CanSetValue Overload


ColorFillSchemeEntry.CanSetValue(Int32) Method

ColorFillSchemeEntryCanSetValue(Int32) Method

Checks whether StorageType of entry is Integer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanSetValue(
    int value
)
Public Function CanSetValue (
    value As Integer
) As Boolean
public:
bool CanSetValue(
    int value
)
member CanSetValue :
        value : int -> bool

Parameters

value Int32
New Integer value.

Return Value

Boolean
True if StorageType of the entry is Integer, false otherwise.
See Also

Reference

ColorFillSchemeEntry Class
CanSetValue Overload


ColorFillSchemeEntry.Dispose Method

ColorFillSchemeEntryDispose Method

Releases all resources used by the ColorFillSchemeEntry

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ColorFillSchemeEntry Class


ColorFillSchemeEntry.GetDoubleValue Method

ColorFillSchemeEntryGetDoubleValue Method

Gets the Double value stored within the entry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetDoubleValue()
Public Function GetDoubleValue As Double
public:
double GetDoubleValue()
member GetDoubleValue : unit -> float

Return Value

Double
The Double value contained in the entry.
Remarks
This method should only be used if the StorageType property reports the type of the entry as a Double.
See Also

Reference

ColorFillSchemeEntry Class


ColorFillSchemeEntry.GetElementIdValue Method

ColorFillSchemeEntryGetElementIdValue Method

Gets the ElementId value stored within the entry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GetElementIdValue()
Public Function GetElementIdValue As ElementId
public:
ElementId^ GetElementIdValue()
member GetElementIdValue : unit -> ElementId

Return Value

ElementId
The ElementId contained in the entry.
Remarks
This method should only be used if the StorageType property reports the type of the entry as a ElementId.
See Also

Reference

ColorFillSchemeEntry Class


ColorFillSchemeEntry.GetIntegerValue Method

ColorFillSchemeEntryGetIntegerValue Method

Gets the Integer value stored within the entry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetIntegerValue()
Public Function GetIntegerValue As Integer
public:
int GetIntegerValue()
member GetIntegerValue : unit -> int

Return Value

Int32
The Integer value contained in the entry.
Remarks
This method should only be used if the StorageType property reports the type of the entry as a Integer.
See Also

Reference

ColorFillSchemeEntry Class


ColorFillSchemeEntry.GetStringValue Method

ColorFillSchemeEntryGetStringValue Method

Gets the String value stored within the entry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetStringValue()
Public Function GetStringValue As String
public:
String^ GetStringValue()
member GetStringValue : unit -> string

Return Value

String
The String contained in the entry.
Remarks
This method should only be used if the StorageType property reports the type of the entry as a String.
See Also

Reference

ColorFillSchemeEntry Class


ColorFillSchemeEntry.SetDoubleValue Method

ColorFillSchemeEntrySetDoubleValue Method

Sets new Double value of entry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetDoubleValue(
    double value
)
Public Sub SetDoubleValue (
    value As Double
)
public:
void SetDoubleValue(
    double value
)
member SetDoubleValue :
        value : float -> unit

Parameters

value Double
Exceptions
Exception | Condition
InvalidOperationException | The entry has different storage type with Double, or value is not finite.
Remarks
You should only use this method if the StorageType property reports the type of the entry as a Double.
See Also

Reference

ColorFillSchemeEntry Class


ColorFillSchemeEntry.SetElementIdValue Method

ColorFillSchemeEntrySetElementIdValue Method

Sets new ElementId value of entry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetElementIdValue(
    ElementId value
)
Public Sub SetElementIdValue (
    value As ElementId
)
public:
void SetElementIdValue(
    ElementId^ value
)
member SetElementIdValue :
        value : ElementId -> unit

Parameters

value ElementId
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The entry has different storage type with ElementId.
Remarks
You should only use this method if the StorageType property reports the type of the entry as a ElementId.
See Also

Reference

ColorFillSchemeEntry Class


ColorFillSchemeEntry.SetIntegerValue Method

ColorFillSchemeEntrySetIntegerValue Method

Sets new Integer value of entry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetIntegerValue(
    int value
)
Public Sub SetIntegerValue (
    value As Integer
)
public:
void SetIntegerValue(
    int value
)
member SetIntegerValue :
        value : int -> unit

Parameters

value Int32
Exceptions
Exception | Condition
InvalidOperationException | The entry has different storage type with Integer.
Remarks
You should only use this method if the StorageType property reports the type of the entry as a Integer.
See Also

Reference

ColorFillSchemeEntry Class


ColorFillSchemeEntry.SetStringValue Method

ColorFillSchemeEntrySetStringValue Method

Sets new String value of entry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetStringValue(
    string value
)
Public Sub SetStringValue (
    value As String
)
public:
void SetStringValue(
    String^ value
)
member SetStringValue :
        value : string -> unit

Parameters

value String
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The entry has different storage type with String, or the value is empty, or contains forbidden characters.
Remarks
This method should only be used if the StorageType property reports the type of the entry as a String. New value should be not empty and valid for Revit name.
See Also

Reference

ColorFillSchemeEntry Class


ColorOptions Class

A class providing access to color settings which affect the colors applied to specific views.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBColorOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ColorOptions : IDisposable
Public Class ColorOptions
    Implements IDisposable
public ref class ColorOptions : IDisposable
type ColorOptions =
    class
        interface IDisposable
    end

The ColorOptions type exposes the following members.

Properties
 | Name | Description
Public property | AlertColor | The color of the current canvas theme used to highlight elements when a special alert is required.
Public property | BackgroundColor | The background color of the current canvas theme applied to views.
Public property | CalculatingColor | The color of the current canvas theme used to render elements when some aspect of their properties is currently being recalculated.
Public property | EditingColor | The color of the current canvas theme used to render elements when editing.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | PreselectionColor | The color of the current canvas theme used to highlight candidates for selection before they are selected.
Public property | SelectionColor | The color of the current canvas theme used to highlight selected elements.
Public property | SelectionSemitransparent | Indicates whether or not selections will be shown in a semi-transparent manner in current canvas theme.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ColorOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | GetColorOptions | Returns the current Revit instance's ColorOptions.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
ColorOptions are managed and stored along with other global application options and thus impact the application as a whole.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ColorOptions Properties

The ColorOptions type exposes the following members.

Properties
 | Name | Description
Public property | AlertColor | The color of the current canvas theme used to highlight elements when a special alert is required.
Public property | BackgroundColor | The background color of the current canvas theme applied to views.
Public property | CalculatingColor | The color of the current canvas theme used to render elements when some aspect of their properties is currently being recalculated.
Public property | EditingColor | The color of the current canvas theme used to render elements when editing.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | PreselectionColor | The color of the current canvas theme used to highlight candidates for selection before they are selected.
Public property | SelectionColor | The color of the current canvas theme used to highlight selected elements.
Public property | SelectionSemitransparent | Indicates whether or not selections will be shown in a semi-transparent manner in current canvas theme.
Top
See Also

Reference

ColorOptions Class


ColorOptions.AlertColor Property

ColorOptionsAlertColor Property

The color of the current canvas theme used to highlight elements when a special alert is required.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color AlertColor { get; set; }
Public Property AlertColor As Color
    Get
    Set
public:
property Color^ AlertColor {
    Color^ get ();
    void set (Color^ value);
}
member AlertColor : Color with get, set

Property Value

Color
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ColorOptions Class


ColorOptions.BackgroundColor Property

ColorOptionsBackgroundColor Property

The background color of the current canvas theme applied to views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color BackgroundColor { get; set; }
Public Property BackgroundColor As Color
    Get
    Set
public:
property Color^ BackgroundColor {
    Color^ get ();
    void set (Color^ value);
}
member BackgroundColor : Color with get, set

Property Value

Color
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ColorOptions Class


ColorOptions.CalculatingColor Property

ColorOptionsCalculatingColor Property

The color of the current canvas theme used to render elements when some aspect of their properties is currently being recalculated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color CalculatingColor { get; set; }
Public Property CalculatingColor As Color
    Get
    Set
public:
property Color^ CalculatingColor {
    Color^ get ();
    void set (Color^ value);
}
member CalculatingColor : Color with get, set

Property Value

Color
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ColorOptions Class


ColorOptions.EditingColor Property

ColorOptionsEditingColor Property

The color of the current canvas theme used to render elements when editing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color EditingColor { get; set; }
Public Property EditingColor As Color
    Get
    Set
public:
property Color^ EditingColor {
    Color^ get ();
    void set (Color^ value);
}
member EditingColor : Color with get, set

Property Value

Color
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ColorOptions Class


ColorOptions.IsValidObject Property

ColorOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ColorOptions Class


ColorOptions.PreselectionColor Property

ColorOptionsPreselectionColor Property

The color of the current canvas theme used to highlight candidates for selection before they are selected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color PreselectionColor { get; set; }
Public Property PreselectionColor As Color
    Get
    Set
public:
property Color^ PreselectionColor {
    Color^ get ();
    void set (Color^ value);
}
member PreselectionColor : Color with get, set

Property Value

Color
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ColorOptions Class


ColorOptions.SelectionColor Property

ColorOptionsSelectionColor Property

The color of the current canvas theme used to highlight selected elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color SelectionColor { get; set; }
Public Property SelectionColor As Color
    Get
    Set
public:
property Color^ SelectionColor {
    Color^ get ();
    void set (Color^ value);
}
member SelectionColor : Color with get, set

Property Value

Color
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ColorOptions Class


ColorOptions.SelectionSemitransparent Property

ColorOptionsSelectionSemitransparent Property

Indicates whether or not selections will be shown in a semi-transparent manner in current canvas theme.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SelectionSemitransparent { get; set; }
Public Property SelectionSemitransparent As Boolean
    Get
    Set
public:
property bool SelectionSemitransparent {
    bool get ();
    void set (bool value);
}
member SelectionSemitransparent : bool with get, set

Property Value

Boolean
See Also

Reference

ColorOptions Class


ColorOptions Methods

The ColorOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | GetColorOptions | Returns the current Revit instance's ColorOptions.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ColorOptions Class


ColorOptions.Dispose Method

ColorOptionsDispose Method

Releases all resources used by the ColorOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ColorOptions Class


ColorOptions.GetColorOptions Method

ColorOptionsGetColorOptions Method

Returns the current Revit instance's ColorOptions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ColorOptions GetColorOptions()
Public Shared Function GetColorOptions As ColorOptions
public:
static ColorOptions^ GetColorOptions()
static member GetColorOptions : unit -> ColorOptions

Return Value

ColorOptions
The ColorOptions for the current Revit instance.
See Also

Reference

ColorOptions Class


ColorWithTransparency Class

Color with transparency
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBColorWithTransparency

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ColorWithTransparency : IDisposable
Public Class ColorWithTransparency
    Implements IDisposable
public ref class ColorWithTransparency : IDisposable
type ColorWithTransparency =
    class
        interface IDisposable
    end

The ColorWithTransparency type exposes the following members.

Constructors
 | Name | Description
Public method | ColorWithTransparency | color
Public method | ColorWithTransparency(UInt32, UInt32, UInt32, UInt32) | color
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ColorWithTransparency
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBlue | get blue
Public method | GetColor | get color
Public method | GetGreen | get green
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRed | get red
Public method | GetTransparency | get transparency
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetBlue | set blue
Public method | SetColor | set color
Public method | SetGreen | set green
Public method | SetRed | set red
Public method | SetTransparency | set transparency
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ColorWithTransparency Constructor

Overload List
 | Name | Description
Public method | ColorWithTransparency | color
Public method | ColorWithTransparency(UInt32, UInt32, UInt32, UInt32) | color
Top
See Also

Reference

ColorWithTransparency Class


ColorWithTransparency Constructor

color

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ColorWithTransparency()
Public Sub New
public:
ColorWithTransparency()
new : unit -> ColorWithTransparency
See Also

Reference

ColorWithTransparency Class
ColorWithTransparency Overload


ColorWithTransparency(UInt32, UInt32, UInt32, UInt32) Constructor

color

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ColorWithTransparency(
    uint red,
    uint green,
    uint blue,
    uint transparency
)
Public Sub New (
    red As UInteger,
    green As UInteger,
    blue As UInteger,
    transparency As UInteger
)
public:
ColorWithTransparency(
    unsigned int red,
    unsigned int green,
    unsigned int blue,
    unsigned int transparency
)
new :
        red : uint32 *
        green : uint32 *
        blue : uint32 *
        transparency : uint32 -> ColorWithTransparency

Parameters

red UInt32
red
green UInt32
green
blue UInt32
blue
transparency UInt32
transparency
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The value is not valid. The valid range is 0 to 255.
See Also

Reference

ColorWithTransparency Class
ColorWithTransparency Overload


ColorWithTransparency Properties

The ColorWithTransparency type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

ColorWithTransparency Class


ColorWithTransparency.IsValidObject Property

ColorWithTransparencyIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ColorWithTransparency Class


ColorWithTransparency Methods

The ColorWithTransparency type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBlue | get blue
Public method | GetColor | get color
Public method | GetGreen | get green
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRed | get red
Public method | GetTransparency | get transparency
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetBlue | set blue
Public method | SetColor | set color
Public method | SetGreen | set green
Public method | SetRed | set red
Public method | SetTransparency | set transparency
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ColorWithTransparency Class


ColorWithTransparency.Dispose Method

ColorWithTransparencyDispose Method

Releases all resources used by the ColorWithTransparency

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ColorWithTransparency Class


ColorWithTransparency.GetBlue Method

ColorWithTransparencyGetBlue Method

get blue

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public uint GetBlue()
Public Function GetBlue As UInteger
public:
unsigned int GetBlue()
member GetBlue : unit -> uint32

Return Value

UInt32
blue
See Also

Reference

ColorWithTransparency Class


ColorWithTransparency.GetColor Method

ColorWithTransparencyGetColor Method

get color

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color GetColor()
Public Function GetColor As Color
public:
Color^ GetColor()
member GetColor : unit -> Color

Return Value

Color
color
See Also

Reference

ColorWithTransparency Class


ColorWithTransparency.GetGreen Method

ColorWithTransparencyGetGreen Method

get green

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public uint GetGreen()
Public Function GetGreen As UInteger
public:
unsigned int GetGreen()
member GetGreen : unit -> uint32

Return Value

UInt32
green
See Also

Reference

ColorWithTransparency Class


ColorWithTransparency.GetRed Method

ColorWithTransparencyGetRed Method

get red

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public uint GetRed()
Public Function GetRed As UInteger
public:
unsigned int GetRed()
member GetRed : unit -> uint32

Return Value

UInt32
red
See Also

Reference

ColorWithTransparency Class


ColorWithTransparency.GetTransparency Method

ColorWithTransparencyGetTransparency Method

get transparency

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public uint GetTransparency()
Public Function GetTransparency As UInteger
public:
unsigned int GetTransparency()
member GetTransparency : unit -> uint32

Return Value

UInt32
transparency
See Also

Reference

ColorWithTransparency Class


ColorWithTransparency.SetBlue Method

ColorWithTransparencySetBlue Method

set blue

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetBlue(
    uint blue
)
Public Sub SetBlue (
    blue As UInteger
)
public:
void SetBlue(
    unsigned int blue
)
member SetBlue :
        blue : uint32 -> unit

Parameters

blue UInt32
blue
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The value is not valid. The valid range is 0 to 255.
See Also

Reference

ColorWithTransparency Class


ColorWithTransparency.SetColor Method

ColorWithTransparencySetColor Method

set color

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetColor(
    Color color
)
Public Sub SetColor (
    color As Color
)
public:
void SetColor(
    Color^ color
)
member SetColor :
        color : Color -> unit

Parameters

color Color
color
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ColorWithTransparency Class


ColorWithTransparency.SetGreen Method

ColorWithTransparencySetGreen Method

set green

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetGreen(
    uint green
)
Public Sub SetGreen (
    green As UInteger
)
public:
void SetGreen(
    unsigned int green
)
member SetGreen :
        green : uint32 -> unit

Parameters

green UInt32
green
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The value is not valid. The valid range is 0 to 255.
See Also

Reference

ColorWithTransparency Class


ColorWithTransparency.SetRed Method

ColorWithTransparencySetRed Method

set red

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetRed(
    uint red
)
Public Sub SetRed (
    red As UInteger
)
public:
void SetRed(
    unsigned int red
)
member SetRed :
        red : uint32 -> unit

Parameters

red UInt32
red
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The value is not valid. The valid range is 0 to 255.
See Also

Reference

ColorWithTransparency Class


ColorWithTransparency.SetTransparency Method

ColorWithTransparencySetTransparency Method

set transparency

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetTransparency(
    uint transparency
)
Public Sub SetTransparency (
    transparency As UInteger
)
public:
void SetTransparency(
    unsigned int transparency
)
member SetTransparency :
        transparency : uint32 -> unit

Parameters

transparency UInt32
transparency
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The value is not valid. The valid range is 0 to 255.
See Also

Reference

ColorWithTransparency Class


ColumnAttachment Class

An object representing the attachment of the top or bottom of a column to some target: a floor, roof, ceiling, beam, or brace.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBColumnAttachment

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ColumnAttachment : IDisposable
Public Class ColumnAttachment
    Implements IDisposable
public ref class ColumnAttachment : IDisposable
type ColumnAttachment =
    class
        interface IDisposable
    end

The ColumnAttachment type exposes the following members.

Properties
 | Name | Description
Public property | AttachOffset | The offset of the column attachment.
Public property | BaseOrTop | Identifies if this ColumnAttachment is at the base or top of the column.
Public property | CutStyle | Identifies whether the column, or the attached element should be cut (or if neither should be cut).
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Justification | Identifies the type of justification to apply to this ColumnAttachment.
Public property | TargetId | The id of the element that is attached to the column and is described by this ColumnAttachment.
Top
Methods
 | Name | Description
 | AddColumnAttachment | Attaches the column to the target. If an attachment already exists with the same "baseOrTop" value, no attachment is made.
Public method | Dispose | Releases all resources used by the ColumnAttachment
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | GetColumnAttachment(FamilyInstance, ElementId) | Look up a column attachment by specifying the target id.
 | GetColumnAttachment(FamilyInstance, Int32) | Look up a column attachment. There is at most one attachment on the base and one on the top.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | IsValidColumn | Says whether a FamilyInstance supports column attachments.
 | IsValidTarget(Boolean, Element) | Says whether the element can be used as a target for a new attachment.
 | IsValidTarget(FamilyInstance, Element) | Says whether the element can be used as a target for a new attachment.
 | RemoveColumnAttachment(FamilyInstance, ElementId) | Removes any attachment of the column to the specified target.
 | RemoveColumnAttachment(FamilyInstance, Int32) | Removes an attachment at the top or base of a column, if there is one.
Public method | SetJustification | Setter of ColumnAttachmentJustification
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Call IsValidColumn() and IsValidTarget() to verify that specific elements support column attachments. A column has at most one top attachment and one bottom attachment.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ColumnAttachment Properties

The ColumnAttachment type exposes the following members.

Properties
 | Name | Description
Public property | AttachOffset | The offset of the column attachment.
Public property | BaseOrTop | Identifies if this ColumnAttachment is at the base or top of the column.
Public property | CutStyle | Identifies whether the column, or the attached element should be cut (or if neither should be cut).
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Justification | Identifies the type of justification to apply to this ColumnAttachment.
Public property | TargetId | The id of the element that is attached to the column and is described by this ColumnAttachment.
Top
See Also

Reference

ColumnAttachment Class


ColumnAttachment.AttachOffset Property

ColumnAttachmentAttachOffset Property

The offset of the column attachment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double AttachOffset { get; set; }
Public Property AttachOffset As Double
    Get
    Set
public:
property double AttachOffset {
    double get ();
    void set (double value);
}
member AttachOffset : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The given value for attachOffset must be no more than 30000 feet in absolute value.
See Also

Reference

ColumnAttachment Class


ColumnAttachment.BaseOrTop Property

ColumnAttachmentBaseOrTop Property

Identifies if this ColumnAttachment is at the base or top of the column.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int BaseOrTop { get; }
Public ReadOnly Property BaseOrTop As Integer
    Get
public:
property int BaseOrTop {
    int get ();
}
member BaseOrTop : int with get

Property Value

Int32
See Also

Reference

ColumnAttachment Class


ColumnAttachment.CutStyle Property

ColumnAttachmentCutStyle Property

Identifies whether the column, or the attached element should be cut (or if neither should be cut).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ColumnAttachmentCutStyle CutStyle { get; }
Public ReadOnly Property CutStyle As ColumnAttachmentCutStyle
    Get
public:
property ColumnAttachmentCutStyle CutStyle {
    ColumnAttachmentCutStyle get ();
}
member CutStyle : ColumnAttachmentCutStyle with get

Property Value

ColumnAttachmentCutStyle
See Also

Reference

ColumnAttachment Class


ColumnAttachment.IsValidObject Property

ColumnAttachmentIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ColumnAttachment Class


ColumnAttachment.Justification Property

ColumnAttachmentJustification Property

Identifies the type of justification to apply to this ColumnAttachment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ColumnAttachmentJustification Justification { get; }
Public ReadOnly Property Justification As ColumnAttachmentJustification
    Get
public:
property ColumnAttachmentJustification Justification {
    ColumnAttachmentJustification get ();
}
member Justification : ColumnAttachmentJustification with get

Property Value

ColumnAttachmentJustification
See Also

Reference

ColumnAttachment Class


ColumnAttachment.TargetId Property

ColumnAttachmentTargetId Property

The id of the element that is attached to the column and is described by this ColumnAttachment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId TargetId { get; }
Public ReadOnly Property TargetId As ElementId
    Get
public:
property ElementId^ TargetId {
    ElementId^ get ();
}
member TargetId : ElementId with get

Property Value

ElementId
See Also

Reference

ColumnAttachment Class


ColumnAttachment Methods

The ColumnAttachment type exposes the following members.

Methods
 | Name | Description
 | AddColumnAttachment | Attaches the column to the target. If an attachment already exists with the same "baseOrTop" value, no attachment is made.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | GetColumnAttachment(FamilyInstance, ElementId) | Look up a column attachment by specifying the target id.
 | GetColumnAttachment(FamilyInstance, Int32) | Look up a column attachment. There is at most one attachment on the base and one on the top.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | IsValidColumn | Says whether a FamilyInstance supports column attachments.
 | IsValidTarget(Boolean, Element) | Says whether the element can be used as a target for a new attachment.
 | IsValidTarget(FamilyInstance, Element) | Says whether the element can be used as a target for a new attachment.
 | RemoveColumnAttachment(FamilyInstance, ElementId) | Removes any attachment of the column to the specified target.
 | RemoveColumnAttachment(FamilyInstance, Int32) | Removes an attachment at the top or base of a column, if there is one.
Public method | SetJustification | Setter of ColumnAttachmentJustification
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ColumnAttachment Class


ColumnAttachment.AddColumnAttachment Method

ColumnAttachmentAddColumnAttachment Method

Attaches the column to the target. If an attachment already exists with the same "baseOrTop" value, no attachment is made.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void AddColumnAttachment(
    Document doc,
    FamilyInstance column,
    Element target,
    int baseOrTop,
    ColumnAttachmentCutStyle cutColumnStyle,
    ColumnAttachmentJustification justification,
    double attachOffset
)
Public Shared Sub AddColumnAttachment (
    doc As Document,
    column As FamilyInstance,
    target As Element,
    baseOrTop As Integer,
    cutColumnStyle As ColumnAttachmentCutStyle,
    justification As ColumnAttachmentJustification,
    attachOffset As Double
)
public:
static void AddColumnAttachment(
    Document^ doc,
    FamilyInstance^ column,
    Element^ target,
    int baseOrTop,
    ColumnAttachmentCutStyle cutColumnStyle,
    ColumnAttachmentJustification justification,
    double attachOffset
)
static member AddColumnAttachment :
        doc : Document *
        column : FamilyInstance *
        target : Element *
        baseOrTop : int *
        cutColumnStyle : ColumnAttachmentCutStyle *
        justification : ColumnAttachmentJustification *
        attachOffset : float -> unit

Parameters

doc Document
The document containing column and target.
column FamilyInstance
A column.
target Element
A target element.
baseOrTop Int32
0 to attach the column base, 1 to attach the column top.
cutColumnStyle ColumnAttachmentCutStyle
Control the handling of columns that intersect their targets.
justification ColumnAttachmentJustification
Control the column extent in cases where the target is not a uniform height.
attachOffset Double
An additional offset for the bottom. If positive, the column base or top will be higher than the attachment point; if negative, lower.
Exceptions
Exception | Condition
ArgumentException | column is not a column that supports ColumnAttachments. -or- target is not a valid target for ColumnAttachments. -or- column already has an attachment at its base or top as specified by baseOrTop. -or- column already has an attachment to target.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | baseOrTop must be either 0 or 1. -or- The given value for attachOffset must be no more than 30000 feet in absolute value. -or- A value passed for an enumeration argument is not a member of that enumeration
Remarks
This method modifies both column and target elements.
See Also

Reference

ColumnAttachment Class


ColumnAttachment.Dispose Method

ColumnAttachmentDispose Method

Releases all resources used by the ColumnAttachment

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ColumnAttachment Class


ColumnAttachment.GetColumnAttachment Method

ColumnAttachmentGetColumnAttachment Method

Overload List
Name | Description
GetColumnAttachment(FamilyInstance, ElementId) | Look up a column attachment by specifying the target id.
GetColumnAttachment(FamilyInstance, Int32) | Look up a column attachment. There is at most one attachment on the base and one on the top.
Top
See Also

Reference

ColumnAttachment Class


ColumnAttachment.GetColumnAttachment(FamilyInstance, ElementId) Method

ColumnAttachmentGetColumnAttachment(FamilyInstance, ElementId) Method

Look up a column attachment by specifying the target id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ColumnAttachment GetColumnAttachment(
    FamilyInstance column,
    ElementId targetId
)
Public Shared Function GetColumnAttachment (
    column As FamilyInstance,
    targetId As ElementId
) As ColumnAttachment
public:
static ColumnAttachment^ GetColumnAttachment(
    FamilyInstance^ column,
    ElementId^ targetId
)
static member GetColumnAttachment :
        column : FamilyInstance *
        targetId : ElementId -> ColumnAttachment

Parameters

column FamilyInstance
A column.
targetId ElementId
Id of a target element.

Return Value

ColumnAttachment
The column attachment attaching the column to the target, or if there is no such attachment.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
May return either a top or base attachment.
See Also

Reference

ColumnAttachment Class
GetColumnAttachment Overload


ColumnAttachment.GetColumnAttachment(FamilyInstance, Int32) Method

ColumnAttachmentGetColumnAttachment(FamilyInstance, Int32) Method

Look up a column attachment. There is at most one attachment on the base and one on the top.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ColumnAttachment GetColumnAttachment(
    FamilyInstance column,
    int baseOrTop
)
Public Shared Function GetColumnAttachment (
    column As FamilyInstance,
    baseOrTop As Integer
) As ColumnAttachment
public:
static ColumnAttachment^ GetColumnAttachment(
    FamilyInstance^ column,
    int baseOrTop
)
static member GetColumnAttachment :
        column : FamilyInstance *
        baseOrTop : int -> ColumnAttachment

Parameters

column FamilyInstance
A column.
baseOrTop Int32
0 for base, 1 for top.

Return Value

ColumnAttachment
The column attachment for the base or top of the column, or if that end of the column is unattached.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | baseOrTop must be either 0 or 1.
See Also

Reference

ColumnAttachment Class
GetColumnAttachment Overload


ColumnAttachment.IsValidColumn Method

ColumnAttachmentIsValidColumn Method

Says whether a FamilyInstance supports column attachments.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidColumn(
    FamilyInstance familyInstance
)
Public Shared Function IsValidColumn (
    familyInstance As FamilyInstance
) As Boolean
public:
static bool IsValidColumn(
    FamilyInstance^ familyInstance
)
static member IsValidColumn :
        familyInstance : FamilyInstance -> bool

Parameters

familyInstance FamilyInstance
A column.

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
In-place columns do not support attachments.
See Also

Reference

ColumnAttachment Class


ColumnAttachment.IsValidTarget Method

ColumnAttachmentIsValidTarget Method

Overload List
Name | Description
IsValidTarget(Boolean, Element) | Says whether the element can be used as a target for a new attachment.
IsValidTarget(FamilyInstance, Element) | Says whether the element can be used as a target for a new attachment.
Top
See Also

Reference

ColumnAttachment Class


ColumnAttachment.IsValidTarget(Boolean, Element) Method

ColumnAttachmentIsValidTarget(Boolean, Element) Method

Says whether the element can be used as a target for a new attachment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidTarget(
    bool forSlantedColumn,
    Element target
)
Public Shared Function IsValidTarget (
    forSlantedColumn As Boolean,
    target As Element
) As Boolean
public:
static bool IsValidTarget(
    bool forSlantedColumn,
    Element^ target
)
static member IsValidTarget :
        forSlantedColumn : bool *
        target : Element -> bool

Parameters

forSlantedColumn Boolean
If true, check whether the target is valid for a slanted column; if false, check whether the target is valid for a vertical column.
target Element
A proposed target element for a column attachment.

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Valid targets are roofs, floors, ceilings, levels. Beams and braces are valid targets, except for slanted columns.
See Also

Reference

ColumnAttachment Class
IsValidTarget Overload


ColumnAttachment.IsValidTarget(FamilyInstance, Element) Method

ColumnAttachmentIsValidTarget(FamilyInstance, Element) Method

Says whether the element can be used as a target for a new attachment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidTarget(
    FamilyInstance column,
    Element target
)
Public Shared Function IsValidTarget (
    column As FamilyInstance,
    target As Element
) As Boolean
public:
static bool IsValidTarget(
    FamilyInstance^ column,
    Element^ target
)
static member IsValidTarget :
        column : FamilyInstance *
        target : Element -> bool

Parameters

column FamilyInstance
The column to attach. If the target is a beam or brace, the column will be checked to see if it is slanted. Otherwise, this argument is not used and may be omitted.
target Element
A proposed target element for a column attachment.

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Valid targets are roofs, floors, and ceilings. Beams and braces are also valid targets, except for slanted columns.
See Also

Reference

ColumnAttachment Class
IsValidTarget Overload


ColumnAttachment.RemoveColumnAttachment Method

ColumnAttachmentRemoveColumnAttachment Method

Overload List
Name | Description
RemoveColumnAttachment(FamilyInstance, ElementId) | Removes any attachment of the column to the specified target.
RemoveColumnAttachment(FamilyInstance, Int32) | Removes an attachment at the top or base of a column, if there is one.
Top
See Also

Reference

ColumnAttachment Class


ColumnAttachment.RemoveColumnAttachment(FamilyInstance, ElementId) Method

ColumnAttachmentRemoveColumnAttachment(FamilyInstance, ElementId) Method

Removes any attachment of the column to the specified target.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void RemoveColumnAttachment(
    FamilyInstance column,
    ElementId targetId
)
Public Shared Sub RemoveColumnAttachment (
    column As FamilyInstance,
    targetId As ElementId
)
public:
static void RemoveColumnAttachment(
    FamilyInstance^ column,
    ElementId^ targetId
)
static member RemoveColumnAttachment :
        column : FamilyInstance *
        targetId : ElementId -> unit

Parameters

column FamilyInstance
A column.
targetId ElementId
Id of a target element.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
This method modifies both column and target elements.
See Also

Reference

ColumnAttachment Class
RemoveColumnAttachment Overload


ColumnAttachment.RemoveColumnAttachment(FamilyInstance, Int32) Method

ColumnAttachmentRemoveColumnAttachment(FamilyInstance, Int32) Method

Removes an attachment at the top or base of a column, if there is one.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void RemoveColumnAttachment(
    FamilyInstance column,
    int baseOrTop
)
Public Shared Sub RemoveColumnAttachment (
    column As FamilyInstance,
    baseOrTop As Integer
)
public:
static void RemoveColumnAttachment(
    FamilyInstance^ column,
    int baseOrTop
)
static member RemoveColumnAttachment :
        column : FamilyInstance *
        baseOrTop : int -> unit

Parameters

column FamilyInstance
A column.
baseOrTop Int32
0 for base, 1 for top.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | baseOrTop must be either 0 or 1.
Remarks
This method modifies both column and target elements.
See Also

Reference

ColumnAttachment Class
RemoveColumnAttachment Overload


ColumnAttachment.SetJustification Method

ColumnAttachmentSetJustification Method

Setter of ColumnAttachmentJustification

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetJustification(
    ColumnAttachmentJustification justification
)
Public Sub SetJustification (
    justification As ColumnAttachmentJustification
)
public:
void SetJustification(
    ColumnAttachmentJustification justification
)
member SetJustification :
        justification : ColumnAttachmentJustification -> unit

Parameters

justification ColumnAttachmentJustification
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ColumnAttachment Class


ColumnAttachmentCutStyle Enumeration

Control the handling of columns that intersect their targets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ColumnAttachmentCutStyle
Public Enumeration ColumnAttachmentCutStyle
public enum class ColumnAttachmentCutStyle
type ColumnAttachmentCutStyle
Members
Member name | Value | Description
CutColumn | 0 |
CutTarget | 1 |
None | 2 |
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ColumnAttachmentJustification Enumeration

Control the column extent in cases where the target is not a uniform height.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ColumnAttachmentJustification
Public Enumeration ColumnAttachmentJustification
public enum class ColumnAttachmentJustification
type ColumnAttachmentJustification
Members
Member name | Value | Description
Minimum | 0 | Minimize the column extent, so that it comes in contact with the target but does not intersect.
Midpoint | 1 | Extend the column until its midpoint contacts the target.
Maximum | 2 | Extend the column until it is completely covered by the target, intersecting it if necessary.
Tangent | 3 | For slanted columns only. Extend the column until its driving curve contacts the target, then cut the column with a plane tangent to the target at that contact point.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CombinableElement Class

An element that can be added to a geometry combination.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBCombinableElement
Autodesk.Revit.DBGenericForm
Autodesk.Revit.DBGeomCombination

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CombinableElement : Element
Public Class CombinableElement
    Inherits Element
public ref class CombinableElement : public Element
type CombinableElement =
    class
        inherit Element
    end

The CombinableElement type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | Combinations | The geometry combinations that this element belongs to.
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CombinableElement Properties

The CombinableElement type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | Combinations | The geometry combinations that this element belongs to.
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

CombinableElement Class


CombinableElement.Combinations Property

CombinableElementCombinations Property

The geometry combinations that this element belongs to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GeomCombinationSet Combinations { get; }
Public ReadOnly Property Combinations As GeomCombinationSet
    Get
public:
property GeomCombinationSet^ Combinations {
    GeomCombinationSet^ get ();
}
member Combinations : GeomCombinationSet with get

Property Value

GeomCombinationSet
Remarks
If this combinable element does not belong to any geometry combination, this value is an empty collection. A solid combinable element may belong to at most one combination, while a void combinable element may belong to multiple combinations.
See Also

Reference

CombinableElement Class


CombinableElement Methods

The CombinableElement type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CombinableElement Class


CombinableElementArray Class

An array that contains CombinableElement objects.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBCombinableElementArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CombinableElementArray : APIObject,
    IEnumerable
Public Class CombinableElementArray
    Inherits APIObject
    Implements IEnumerable
public ref class CombinableElementArray : public APIObject,
    IEnumerable
type CombinableElementArray =
    class
        inherit APIObject
        interface IEnumerable
    end

The CombinableElementArray type exposes the following members.

Constructors
 | Name | Description
Public method | CombinableElementArray | Initializes a new instance of the CombinableElementArray class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets a CombinableElement at a specified index within the array.
Public property | Size | Returns the number of CombinableElements that are in the array.
Top
Methods
 | Name | Description
Public method | Append | Add the element to the end of the array.
Public method | Clear | Removes every CombinableElement from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified element into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CombinableElementArray Constructor

Initializes a new instance of the CombinableElementArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CombinableElementArray()
Public Sub New
public:
CombinableElementArray()
new : unit -> CombinableElementArray
See Also

Reference

CombinableElementArray Class


CombinableElementArray Properties

The CombinableElementArray type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets a CombinableElement at a specified index within the array.
Public property | Size | Returns the number of CombinableElements that are in the array.
Top
See Also

Reference

CombinableElementArray Class


CombinableElementArray.IsEmpty Property

CombinableElementArrayIsEmpty Property

Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Boolean
Remarks
If the array is empty then True will be returned, otherwise False.
See Also

Reference

CombinableElementArray Class


CombinableElementArray.Item Property

CombinableElementArrayItem Property

Gets or sets a CombinableElement at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual CombinableElement this[
    int index
] { get; set; }
Public Overridable Property Item (
    index As Integer
) As CombinableElement
    Get
    Set
public:
virtual property CombinableElement^ Item[int index] {
    CombinableElement^ get (int index);
    void set (int index, CombinableElement^ value);
}
abstract Item : CombinableElement with get, set
override Item : CombinableElement with get, set

Parameters

index Int32
The index of the CombinableElement to be set or retrieved.

Return Value

CombinableElement
Returns the CombinableElement at the specified index.
See Also

Reference

CombinableElementArray Class


CombinableElementArray.Size Property

CombinableElementArraySize Property

Returns the number of CombinableElements that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
abstract Size : int with get
override Size : int with get

Property Value

Int32
See Also

Reference

CombinableElementArray Class


CombinableElementArray Methods

The CombinableElementArray type exposes the following members.

Methods
 | Name | Description
Public method | Append | Add the element to the end of the array.
Public method | Clear | Removes every CombinableElement from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified element into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CombinableElementArray Class


CombinableElementArray.Append Method

CombinableElementArrayAppend Method

Add the element to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Append(
    CombinableElement item
)
Public Overridable Sub Append (
    item As CombinableElement
)
public:
virtual void Append(
    CombinableElement^ item
)
abstract Append :
        item : CombinableElement -> unit
override Append :
        item : CombinableElement -> unit

Parameters

item CombinableElement
The CombinableElement to be added.
See Also

Reference

CombinableElementArray Class


CombinableElementArray.Clear Method

CombinableElementArrayClear Method

Removes every CombinableElement from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

CombinableElementArray Class


CombinableElementArray.ForwardIterator Method

CombinableElementArrayForwardIterator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual CombinableElementArrayIterator ForwardIterator()
Public Overridable Function ForwardIterator As CombinableElementArrayIterator
public:
virtual CombinableElementArrayIterator^ ForwardIterator()
abstract ForwardIterator : unit -> CombinableElementArrayIterator
override ForwardIterator : unit -> CombinableElementArrayIterator

Return Value

CombinableElementArrayIterator
Returns a forward moving iterator to the array.
See Also

Reference

CombinableElementArray Class


CombinableElementArray.GetEnumerator Method

CombinableElementArrayGetEnumerator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

IEnumerator
Returns a forward moving iterator to the array.

Implements

IEnumerableGetEnumerator
See Also

Reference

CombinableElementArray Class


CombinableElementArray.Insert Method

CombinableElementArrayInsert Method

Insert the specified element into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Insert(
    CombinableElement item,
    int index
)
Public Overridable Sub Insert (
    item As CombinableElement,
    index As Integer
)
public:
virtual void Insert(
    CombinableElement^ item,
    int index
)
abstract Insert :
        item : CombinableElement *
        index : int -> unit
override Insert :
        item : CombinableElement *
        index : int -> unit

Parameters

item CombinableElement
The CombinableElement to be inserted into the array.
index Int32
The CombinableElement will be inserted before this index.

Return Value

Returns whether the CombinableElement was inserted into the array.
See Also

Reference

CombinableElementArray Class


CombinableElementArray.ReverseIterator Method

CombinableElementArrayReverseIterator Method

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual CombinableElementArrayIterator ReverseIterator()
Public Overridable Function ReverseIterator As CombinableElementArrayIterator
public:
virtual CombinableElementArrayIterator^ ReverseIterator()
abstract ReverseIterator : unit -> CombinableElementArrayIterator
override ReverseIterator : unit -> CombinableElementArrayIterator

Return Value

CombinableElementArrayIterator
Returns a backward moving iterator to the array.
See Also

Reference

CombinableElementArray Class


CombinableElementArrayIterator Class

An iterator to an CombinableElement array.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBCombinableElementArrayIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class CombinableElementArrayIterator : APIObject,
    IEnumerator
Public MustInherit Class CombinableElementArrayIterator
    Inherits APIObject
    Implements IEnumerator
public ref class CombinableElementArrayIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type CombinableElementArrayIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The CombinableElementArrayIterator type exposes the following members.

Constructors
 | Name | Description
Public method | CombinableElementArrayIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CombinableElementArrayIterator Constructor

For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CombinableElementArrayIterator()
Public Sub New
public:
CombinableElementArrayIterator()
new : unit -> CombinableElementArrayIterator
Remarks
This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.
See Also

Reference

CombinableElementArrayIterator Class


CombinableElementArrayIterator Properties

The CombinableElementArrayIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

CombinableElementArrayIterator Class


CombinableElementArrayIterator.Current Property

CombinableElementArrayIteratorCurrent Property

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}
abstract Current : Object with get
override Current : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.
See Also

Reference

CombinableElementArrayIterator Class


CombinableElementArrayIterator Methods

The CombinableElementArrayIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CombinableElementArrayIterator Class


CombinableElementArrayIterator.MoveNext Method

CombinableElementArrayIteratorMoveNext Method

Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumeratorMoveNext
Remarks
MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.
See Also

Reference

CombinableElementArrayIterator Class


CombinableElementArrayIterator.Reset Method

CombinableElementArrayIteratorReset Method

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
Remarks
The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.
See Also

Reference

CombinableElementArrayIterator Class


ComponentRepeater Class

An element that contains and manages a set of repeated components.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBComponentRepeater

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ComponentRepeater : Element,
    IEnumerable<ComponentRepeaterSlot>
Public Class ComponentRepeater
    Inherits Element
    Implements IEnumerable(Of ComponentRepeaterSlot)
public ref class ComponentRepeater : public Element,
    IEnumerable<ComponentRepeaterSlot^>
type ComponentRepeater =
    class
        inherit Element
        interface IEnumerable<ComponentRepeaterSlot>
    end

The ComponentRepeater type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | DefaultFamilyType | The default family type for the component repeater.
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | DimensionCount | The dimension count of the component repeater.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
 | CanElementBeRepeated | Determines whether an element can be repeated using the RepeatElements method.
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsTypeValidForRepeater | Determines whether given family type can be used as the default type for the repeater.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
 | RemoveRepeaters | Removes component repeaters from the document, but leaves the individual repeated components in their respective locations and hosted on their original hosts.
 | RepeatElements | Repeats a set of adaptive component hosted on one or more repeating references.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

Component repeaters can be used to replicate (repeat) elements hosted on repeating references. The result of the repeating operation is a collection of slots. Each slot contains one repeated component. The ComponentRepeater class provides the repeating functionality and access to the slots.

Each repeating reference is capable of hosting one point of an adaptive component. An initial pattern can be created by populating one or more repeating references with such points. Component repeaters can then be used to replicate the pattern to fill the rest of the repeating references in the particular repeating reference source.

The repeating references in repeating reference source are arranged in one or two dimensional arrays, allowing for different kinds of repeating:

  • One dimensional source allows for repeating along a path.
  • Two dimensional source allows for repeating across a grid.
  • It is also possible to host a point on a zero dimensional reference (a point). This point will be shared by all slots. A zero dimensional source allows for repeating around a single point. It should not be used alone, but together with at least one other repeating reference source (typically one dimensional.) The point hosted on the zero dimensional source serves as a central point around which other points can be repeated on their respective repeating reference sources.

Multiple adaptive components may be hosted on one repeating reference source, and different points of one adaptive component may be hosted on different repeating reference sources, effectively allowing different points of an adaptive component to be repeated using different patterns.

Following is a typical component repeater creation workflow:

  1. Get the default repeating reference source from a point element, divided path or divided surface. (See HasRepeatingReferenceSource(Document, ElementId) and GetDefaultRepeatingReferenceSource(Document, ElementId).)
  2. Query the bounds of the repeating reference source to find a range of valid coordinates. (See DimensionCount and GetBounds.)
  3. Create one or more instances of adaptive families that will be repeated.
  4. Host the individual points of an adaptive component on one or more repeating references. (See GetReference(RepeaterCoordinates).)
  5. Repeat the set of adaptive components using the RepeatElements() method.

Component repeaters can only be used in Massing families (the conceptual design environment).

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ComponentRepeater Properties

The ComponentRepeater type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | DefaultFamilyType | The default family type for the component repeater.
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | DimensionCount | The dimension count of the component repeater.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

ComponentRepeater Class


ComponentRepeater.DefaultFamilyType Property

ComponentRepeaterDefaultFamilyType Property

The default family type for the component repeater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId DefaultFamilyType { get; set; }
Public Property DefaultFamilyType As ElementId
    Get
    Set
public:
property ElementId^ DefaultFamilyType {
    ElementId^ get ();
    void set (ElementId^ value);
}
member DefaultFamilyType : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentException | When setting this property: Invalid type for the repeater. The type must be an adaptive family with no shape handles. In addition, it must have same category and same number of placement points as the current type of the repeater.
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
The default family type is the type of the instances in default slots. This includes slots that are added when the repeater grows. When setting this property, all slots with instances of the default type will change their components to an instance of the new default type. Empty slots will remain unchanged. Slots with non-default family instances will remain unchanged.
See Also

Reference

ComponentRepeater Class


ComponentRepeater.DimensionCount Property

ComponentRepeaterDimensionCount Property

The dimension count of the component repeater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int DimensionCount { get; }
Public ReadOnly Property DimensionCount As Integer
    Get
public:
property int DimensionCount {
    int get ();
}
member DimensionCount : int with get

Property Value

Int32
See Also

Reference

ComponentRepeater Class


ComponentRepeater Methods

The ComponentRepeater type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
 | CanElementBeRepeated | Determines whether an element can be repeated using the RepeatElements method.
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsTypeValidForRepeater | Determines whether given family type can be used as the default type for the repeater.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
 | RemoveRepeaters | Removes component repeaters from the document, but leaves the individual repeated components in their respective locations and hosted on their original hosts.
 | RepeatElements | Repeats a set of adaptive component hosted on one or more repeating references.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ComponentRepeater Class


ComponentRepeater.CanElementBeRepeated Method

ComponentRepeaterCanElementBeRepeated Method

Determines whether an element can be repeated using the RepeatElements method.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CanElementBeRepeated(
    Document ADoc,
    ElementId elementId
)
Public Shared Function CanElementBeRepeated (
    ADoc As Document,
    elementId As ElementId
) As Boolean
public:
static bool CanElementBeRepeated(
    Document^ ADoc,
    ElementId^ elementId
)
static member CanElementBeRepeated :
        ADoc : Document *
        elementId : ElementId -> bool

Parameters

ADoc Document
The document containing the element.
elementId ElementId
The element to be tested.

Return Value

Boolean
True if the element can be repeated.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
The element must be an adaptive family instance and have no shape handles. At least one placement point must be hosted on a 1D or 2D repeating reference. All other placement points can be hosted on a 0D, 1D or 2D repeating reference, or must be unhosted.
See Also

Reference

ComponentRepeater Class


ComponentRepeater.GetBasicIEnumerator Method

ComponentRepeaterGetBasicIEnumerator Method

Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
internal virtual IEnumerator GetBasicIEnumerator()
Friend Overridable Function GetBasicIEnumerator As IEnumerator
internal:
virtual IEnumerator^ GetBasicIEnumerator()
internal abstract GetBasicIEnumerator : unit -> IEnumerator
internal override GetBasicIEnumerator : unit -> IEnumerator

Return Value

IEnumerator
An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerableGetEnumerator
See Also

Reference

ComponentRepeater Class


ComponentRepeater.GetEnumerator Method

ComponentRepeaterGetEnumerator Method

Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator<ComponentRepeaterSlot> GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator(Of ComponentRepeaterSlot)
public:
virtual IEnumerator<ComponentRepeaterSlot^>^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator<ComponentRepeaterSlot>
override GetEnumerator : unit -> IEnumerator<ComponentRepeaterSlot>

Return Value

IEnumerator ComponentRepeaterSlot
An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerableTGetEnumerator
See Also

Reference

ComponentRepeater Class


ComponentRepeater.IsTypeValidForRepeater Method

ComponentRepeaterIsTypeValidForRepeater Method

Determines whether given family type can be used as the default type for the repeater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsTypeValidForRepeater(
    ElementId typeId
)
Public Function IsTypeValidForRepeater (
    typeId As ElementId
) As Boolean
public:
bool IsTypeValidForRepeater(
    ElementId^ typeId
)
member IsTypeValidForRepeater :
        typeId : ElementId -> bool

Parameters

typeId ElementId
The element id of the type.

Return Value

Boolean
True if the family type can be used as the default type for the repeater.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ComponentRepeater Class


ComponentRepeater.RemoveRepeaters Method

ComponentRepeaterRemoveRepeaters Method

Removes component repeaters from the document, but leaves the individual repeated components in their respective locations and hosted on their original hosts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ISet<ElementId> RemoveRepeaters(
    Document document,
    ISet<ElementId> elementIds
)
Public Shared Function RemoveRepeaters (
    document As Document,
    elementIds As ISet(Of ElementId)
) As ISet(Of ElementId)
public:
static ISet<ElementId^>^ RemoveRepeaters(
    Document^ document,
    ISet<ElementId^>^ elementIds
)
static member RemoveRepeaters :
        document : Document *
        elementIds : ISet<ElementId> -> ISet<ElementId>

Parameters

document Document
The document that contains the component repeaters to remove.
elementIds ISet ElementId
The set of component repeaters that should be removed.

Return Value

ISet ElementId
A collection of components that were previously repeated by the component repeater.
Exceptions
Exception | Condition
ArgumentException | The given element id set is empty. -or- One or more elements in elementIds do not exist in the document. -or- Not all given elements are component repeaters.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
In addition to the component repeaters the component repeater slots are also removed from the document.
See Also

Reference

ComponentRepeater Class


ComponentRepeater.RepeatElements Method

ComponentRepeaterRepeatElements Method

Repeats a set of adaptive component hosted on one or more repeating references.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<ComponentRepeater> RepeatElements(
    Document document,
    ICollection<ElementId> elementIds
)
Public Shared Function RepeatElements (
    document As Document,
    elementIds As ICollection(Of ElementId)
) As IList(Of ComponentRepeater)
public:
static IList<ComponentRepeater^>^ RepeatElements(
    Document^ document,
    ICollection<ElementId^>^ elementIds
)
static member RepeatElements :
        document : Document *
        elementIds : ICollection<ElementId> -> IList<ComponentRepeater>

Parameters

document Document
The document that contains the elements.
elementIds ICollection ElementId
The set of adaptive components used as an input pattern for the repeating operation.

Return Value

IList ComponentRepeater
One or more component repeater objects representing the result pattern of the repeating operation.
Exceptions
Exception | Condition
ArgumentException | The document does not allow creation of a component repeater. -or- The given element id set is empty. -or- One or more elements in elementIds do not exist in the document. -or- Not all given elements can be repeated. All elements must be adaptive family instances, have no shape handles, and have at least one placement point hosted on a 1D or 2D repeating reference. The remaining placement points must be either unhosted or hosted on another repeating reference.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
All elements must be adaptive family instances and have no shape handles. At least one placement point must be hosted on a 1D or 2D repeating reference. All other placement points can be hosted on a 0D, 1D or 2D repeating reference, or must be unhosted. Use CanElementBeRepeated(Document, ElementId) to test whether an element meets these conditions.
See Also

Reference

ComponentRepeater Class


ComponentRepeaterIterator Class

A slot iterator for ComponentRepeater.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBComponentRepeaterIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ComponentRepeaterIterator : IEnumerator<ComponentRepeaterSlot>
Public Class ComponentRepeaterIterator
    Implements IEnumerator(Of ComponentRepeaterSlot)
public ref class ComponentRepeaterIterator : IEnumerator<ComponentRepeaterSlot^>
type ComponentRepeaterIterator =
    class
        interface IEnumerator<ComponentRepeaterSlot>
    end

The ComponentRepeaterIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ComponentRepeaterIterator
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCurrent | Returns the current repeater slot.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next item.
Public method | Reset | Resets the iterator to the initial state.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ComponentRepeaterIterator Properties

The ComponentRepeaterIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

ComponentRepeaterIterator Class


ComponentRepeaterIterator.Current Property

ComponentRepeaterIteratorCurrent Property

Gets the item at the current position of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ComponentRepeaterSlot Current { get; }
Public Overridable ReadOnly Property Current As ComponentRepeaterSlot
    Get
public:
virtual property ComponentRepeaterSlot^ Current {
    ComponentRepeaterSlot^ get ();
}
abstract Current : ComponentRepeaterSlot with get
override Current : ComponentRepeaterSlot with get

Property Value

ComponentRepeaterSlot

Implements

IEnumeratorTCurrent
Exceptions
Exception | Condition
InvalidOperationException | There is no current item in the iterator.
Remarks
There is no current item if the iterator has not started yet or has been done.
See Also

Reference

ComponentRepeaterIterator Class


ComponentRepeaterIterator.CurrentObject Property

ComponentRepeaterIteratorCurrentObject Property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
internal Object CurrentObject { get; }
Friend ReadOnly Property CurrentObject As Object
    Get
internal:
virtual property Object^ CurrentObject {
    Object^ get () sealed;
}
internal abstract CurrentObject : Object with get
internal override CurrentObject : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
See Also

Reference

ComponentRepeaterIterator Class


ComponentRepeaterIterator.IsValidObject Property

ComponentRepeaterIteratorIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ComponentRepeaterIterator Class


ComponentRepeaterIterator Methods

The ComponentRepeaterIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCurrent | Returns the current repeater slot.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next item.
Public method | Reset | Resets the iterator to the initial state.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ComponentRepeaterIterator Class


ComponentRepeaterIterator.Dispose Method

ComponentRepeaterIteratorDispose Method

Releases all resources used by the ComponentRepeaterIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit
See Also

Reference

ComponentRepeaterIterator Class


ComponentRepeaterIterator.GetCurrent Method

ComponentRepeaterIteratorGetCurrent Method

Returns the current repeater slot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ComponentRepeaterSlot GetCurrent()
Public Function GetCurrent As ComponentRepeaterSlot
public:
ComponentRepeaterSlot^ GetCurrent()
member GetCurrent : unit -> ComponentRepeaterSlot

Return Value

ComponentRepeaterSlot
The current slot.
Exceptions
Exception | Condition
InvalidOperationException | There is no current item in the iterator.
See Also

Reference

ComponentRepeaterIterator Class


ComponentRepeaterIterator.IsDone Method

ComponentRepeaterIteratorIsDone Method

Identifies if the iteration has completed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsDone()
Public Overridable Function IsDone As Boolean
public:
virtual bool IsDone()
abstract IsDone : unit -> bool
override IsDone : unit -> bool

Return Value

Boolean
True if the iteration has no more items. False if there are more items to be iterated.
See Also

Reference

ComponentRepeaterIterator Class


ComponentRepeaterIterator.MoveNext Method

ComponentRepeaterIteratorMoveNext Method

Increments the iterator to the next item.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
True if there is a next available item in this iterator. False if the iterator has completed all available items.
See Also

Reference

ComponentRepeaterIterator Class


ComponentRepeaterIterator.Reset Method

ComponentRepeaterIteratorReset Method

Resets the iterator to the initial state.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit
See Also

Reference

ComponentRepeaterIterator Class


ComponentRepeaterSlot Class

Represents a slot that holds one repeated component in a component repeater.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBComponentRepeaterSlot

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ComponentRepeaterSlot : Element
Public Class ComponentRepeaterSlot
    Inherits Element
public ref class ComponentRepeaterSlot : public Element
type ComponentRepeaterSlot =
    class
        inherit Element
    end

The ComponentRepeaterSlot type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyType | The id of the family type of the component in the slot, or invalid id if the slot is empty.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsDefault | A flag indicating whether the slot currently holds an instance of the default family type of the component repeater.
Public property | IsEmpty | A flag indicating whether the slot is currently empty.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsTypeValidForSlot | Determines whether instance of given family type can be used in the component repeater slot.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | MakeDefault | Populates the slot with an instance of the default family type of the component repeater.
Public method | MakeEmpty | Makes the slot empty by removing the instance currently held by the slot.
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

Each slot can be in one of the following states:

  • Empty.
  • Occupied by an instance of the default family of the repeater that contains the slot.
  • Occupied by an instance of another family.
Initially, every occupied slot holds an instance of the default family of the repeater, based on the original element that was repeated.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ComponentRepeaterSlot Properties

The ComponentRepeaterSlot type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyType | The id of the family type of the component in the slot, or invalid id if the slot is empty.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsDefault | A flag indicating whether the slot currently holds an instance of the default family type of the component repeater.
Public property | IsEmpty | A flag indicating whether the slot is currently empty.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

ComponentRepeaterSlot Class


ComponentRepeaterSlot.FamilyType Property

ComponentRepeaterSlotFamilyType Property

The id of the family type of the component in the slot, or invalid id if the slot is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId FamilyType { get; set; }
Public Property FamilyType As ElementId
    Get
    Set
public:
property ElementId^ FamilyType {
    ElementId^ get ();
    void set (ElementId^ value);
}
member FamilyType : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentException | When setting this property: Invalid type for the slot. The type must be an adaptive family with no shape handles. In addition, it must have same category and same number of placement points as the current type of the repeater.
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ComponentRepeaterSlot Class


ComponentRepeaterSlot.IsDefault Property

ComponentRepeaterSlotIsDefault Property

A flag indicating whether the slot currently holds an instance of the default family type of the component repeater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsDefault { get; }
Public ReadOnly Property IsDefault As Boolean
    Get
public:
property bool IsDefault {
    bool get ();
}
member IsDefault : bool with get

Property Value

Boolean
See Also

Reference

ComponentRepeaterSlot Class


ComponentRepeaterSlot.IsEmpty Property

ComponentRepeaterSlotIsEmpty Property

A flag indicating whether the slot is currently empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEmpty { get; }
Public ReadOnly Property IsEmpty As Boolean
    Get
public:
property bool IsEmpty {
    bool get ();
}
member IsEmpty : bool with get

Property Value

Boolean
See Also

Reference

ComponentRepeaterSlot Class


ComponentRepeaterSlot Methods

The ComponentRepeaterSlot type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsTypeValidForSlot | Determines whether instance of given family type can be used in the component repeater slot.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | MakeDefault | Populates the slot with an instance of the default family type of the component repeater.
Public method | MakeEmpty | Makes the slot empty by removing the instance currently held by the slot.
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ComponentRepeaterSlot Class


ComponentRepeaterSlot.IsTypeValidForSlot Method

ComponentRepeaterSlotIsTypeValidForSlot Method

Determines whether instance of given family type can be used in the component repeater slot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsTypeValidForSlot(
    ElementId typeId
)
Public Function IsTypeValidForSlot (
    typeId As ElementId
) As Boolean
public:
bool IsTypeValidForSlot(
    ElementId^ typeId
)
member IsTypeValidForSlot :
        typeId : ElementId -> bool

Parameters

typeId ElementId
The element id of the type.

Return Value

Boolean
True if the family type can be used in the component repeater slot.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ComponentRepeaterSlot Class


ComponentRepeaterSlot.MakeDefault Method

ComponentRepeaterSlotMakeDefault Method

Populates the slot with an instance of the default family type of the component repeater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void MakeDefault()
Public Sub MakeDefault
public:
void MakeDefault()
member MakeDefault : unit -> unit
See Also

Reference

ComponentRepeaterSlot Class


ComponentRepeaterSlot.MakeEmpty Method

ComponentRepeaterSlotMakeEmpty Method

Makes the slot empty by removing the instance currently held by the slot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void MakeEmpty()
Public Sub MakeEmpty
public:
void MakeEmpty()
member MakeEmpty : unit -> unit
See Also

Reference

ComponentRepeaterSlot Class


ComponentRotation Enumeration

ComponentRotation property of DividedSurface. See DividedSurface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ComponentRotation
Public Enumeration ComponentRotation
public enum class ComponentRotation
type ComponentRotation
Members
Member name | Value | Description
Angle0 | 0 |
Angle90 | 90 |
Angle180 | 180 |
Angle270 | 270 |
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CompoundStructure Class

Describes the internal structure of a wall, floor, roof or ceiling.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBCompoundStructure

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CompoundStructure : IDisposable
Public Class CompoundStructure
    Implements IDisposable
public ref class CompoundStructure : IDisposable
type CompoundStructure =
    class
        interface IDisposable
    end

The CompoundStructure type exposes the following members.

Properties
 | Name | Description
Public property | CutoffHeight | Horizontal segments below or at the cutoff height have their distance to the wall bottom fixed, those above have their distance to the wall top fixed.
Public property | EndCap | Indicates the end cap condition defining which shell layers will participate in end wrapping.
Public property | HasStructuralDeck | Checks if the compound structure has a structural deck.
Public property | IsEmpty | Checks whether this CompoundStructure is empty.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | IsVerticallyCompound | Identifies if this CompoundStructure represents a layout that is more complicated than a simple set of parallel layers.
Public property | LayerCount | Returns the number of layers contained in this CompoundStructure.
Public property | MinimumSampleHeight | The minimum sample height determined by the current sample height and the horizontal segments.
Public property | OpeningWrapping | Indicates the opening wrapping condition defining which shell layers of a wall, in plan view, wrap at inserts and openings.
Public property | SampleHeight | The sample height is the presumed height of the wall to which the data in this CompoundStructure is applied.
Public property | StructuralMaterialIndex | Indicates the layer whose material defines the structural properties of the type for the purposes of analysis.
Public property | VariableLayerIndex | Indicates the index of the layer which is designated as variable.
Top
Methods
 | Name | Description
Public method | AddWallSweep | Adds a new wall sweep or reveal to the compound structure.
Public method | AssociateRegionWithLayer | Associates a region with a layer.
Public method | CanLayerBeStructuralMaterial | Identifies if the input layer can be designated as defining the structural material for this structure.
Public method | CanLayerBeVariable | Identifies if the input layer can be designated as a variable thickness layer.
Public method | CanLayerWidthBeNonZero | Identifies if changing the width of an existing layer from zero to a positive value will create a rectangular region.
Public method | CanSplitAndMergeRegionsBeUsed | Checks whether split and merge regions operations can be used for this compound structure.
Public method | ChangeRegionWidth | Adjust the width of an existing simple region.
Public method | ClearWallSweeps | Removes all sweeps or reveals from the compound structure.
 | CreateSimpleCompoundStructure | Creates a non-vertically compound structure comprised of parallel layers.
 | CreateSingleLayerCompoundStructure(MaterialFunctionAssignment, Double, ElementId) | Creates a CompoundStructure containing a single layer.
 | CreateSingleLayerCompoundStructure(Double, MaterialFunctionAssignment, Double, ElementId) | Creates a vertically compound CompoundStructure with one layer.
Public method | DeleteLayer | Deletes the specified layer from this CompoundStructure.
Public method | Dispose | Releases all resources used by the CompoundStructure
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | FindEnclosingRegionAndSegments | Given a pair of grid coordinates, and a direction for splitting, returns the enclosing region and the two segments intersected by a line through the grid point.
Public method | GetAdjacentRegions | Gets the ids of region bound to a specified segment.
Public method | GetCoreBoundaryLayerIndex | Returns the index of the layer just below the core boundary.
Public method | GetDeckEmbeddingType | Retrieves the deck embedding type used for the specified structural deck.
Public method | GetDeckProfileId | Retrieves the profile loop used for the specified structural deck.
Public method | GetExtendableRegionIds | Gets the extendable region ids for the compound structure.
Public method | GetFirstCoreLayerIndex | Gets the index of the first core layer.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLastCoreLayerIndex | Gets the index of the last core layer.
Public method | GetLayerAssociatedToRegion | Gets the layer associated to a particular region.
Public method | GetLayerFunction | Retrieves the function of the specified layer.
Public method | GetLayers | A copy of the layers which define this compound structure.
Public method | GetLayerWidth | Retrieves the width of a specified layer.
Public method | GetMaterialId | Retrieves the material element id of a specified layer.
 | GetMinimumLayerThickness | Get the minimum allowable layer thickness.
Public method | GetNumberOfShellLayers | Retrieves the number of interior or exterior shell layers.
Public method | GetOffsetForLocationLine | Returns the offset from the center of the compound structure to the given location line value.
Public method | GetPreviousNonZeroLayerIndex | Returns the index of the nearest non-zero width layer before this layer.
Public method | GetRegionEnvelope | Gets the envelope that a specified region spans.
Public method | GetRegionIds | Gets the region ids of this compound structure.
Public method | GetRegionsAlongLevel | Returns the ids of the regions encountered as the vertically compound structure is traversed at a constant height above the bottom a wall to which this structure is applied.
Public method | GetRegionsAssociatedToLayer | Gets the set of region ids associated to a particular layer.
Public method | GetSegmentCoordinate | Gets the coordinate of a segment.
Public method | GetSegmentEndPoints | Gets the end points of a segment.
Public method | GetSegmentIds | Gets the segment ids of this compound structure.
Public method | GetSegmentOrientation | Gets the orientation of a segment.
Public method | GetSimpleCompoundStructure | Takes a horizontal slice through a sample wall to which this CompoundStructure is applied and returns a simple compound structure which describes that slice, i.e. a series of parallel layers.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetWallSweepsInfo | Obtains a list of the intrinsic wall sweeps or reveals in this CompoundStructure.
Public method | GetWidth | The width implied by this compound structure.
Public method | GetWidth(Int32) | Computes the width of the envelope (2d bounding box) of the specified region.
Public method | IsCoreLayer | Checks if the specified layer is a core layer.
Public method | IsEqual | Checks whether this CompoundStructure is the same as another CompoundStructure.
Public method | IsLayerValid | Verifies that the data in this layer is internally consistent.
Public method | IsRectangularRegion | Determines whether the specified region is rectangular.
Public method | IsSimpleRegion | Determines whether the region is a simple region in this CompoundStructure.
Public method | IsStructuralDeck | Determines whether a specified layer is a structural deck.
Public method | IsValid | Checks for errors or inconsistencies in the data in this CompoundStructure.
Public method | IsValidRegionId | Determines whether the specified integer is actually the id of a region in this CompoundStructure.
Public method | IsValidSampleHeight | Is the specified height a valid sample height for this compound structure?
Public method | IsValidSegmentId | Determines whether the specified integer is actually the id of a segment in this CompoundStructure.
Public method | IsVerticallyHomogeneous | Indicates whether this CompoundStructure represents a single set of parallel layers.
Public method | MergeRegionsAdjacentToSegment | Merges the two regions which share the specified segment.
Public method | ParticipatesInWrapping | Identifies if a layer is included in wrapping at inserts and ends.
Public method | RemoveWallSweep | Removes a single sweep or reveal from the compound structure.
Public method | SetDeckEmbeddingType | Sets the deck embedding type to use for the specified structural deck.
Public method | SetDeckProfileId | Sets the profile loop to use for the specified structural deck.
Public method | SetExtendableRegionIds | Sets the extendable region ids for the compound structure.
Public method | SetLayer | Sets a single layer for this CompoundStructure.
Public method | SetLayerFunction | Sets the function of the specified layer.
Public method | SetLayers | Completely resets this CompoundStructure and applies a new set of layers.
Public method | SetLayerWidth | Sets the width of a specified layer.
Public method | SetMaterialId | Sets a material element for a specified layer.
Public method | SetNumberOfShellLayers | Sets the number of interior or exterior shell layers.
Public method | SetParticipatesInWrapping | Assigns if a layer is included in wrapping at inserts and ends.
Public method | SplitRegion(UV, RectangularGridSegmentOrientation) | Splits the region which contains the specified grid point by a line with the specified direction.
Public method | SplitRegion(UV, RectangularGridSegmentOrientation, Int32) | Splits the region which contains the specified grid point by a line with the specified direction.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

A compound structure consists a collection of ordered layers, proceeding from exterior to interior for a wall, or from top to bottom for a floor, roof or ceiling. The properties of these layers determine the thickness, material, and function of the overall structure of the associated wall, floor, roof or ceiling. Layers can be accessed via the GetLayers method and completely replaced using SetLayers. Layers can also be accessed and modified individually using the "layer index", which is a value from in the range [0, LayerCount) identifying the layer in the structure.

A structure supports the concept of "core layers" and "shell layers". There are two layer indices which identify where the boundary between core and shell layers occur in the list of layers. The boundaries between shell and core layers are identifiable using GetFirstCoreLayerIndex, GetLastCoreLayerIndex, GetCoreBoundaryLayerIndex(ShellLayerType) or GetNumberOfShellLayers(ShellLayerType). The core layer boundary can be changed with SetNumberOfShellLayers(ShellLayerType, Int32).

Compound structures may be vertically compound. If IsVerticallyCompound is false, the CompoundStructure describes a series of parallel layers, each with specified width, function, material and other properties. If IsVerticallyCompound is true (which should apply only for CompoundStructures assigned to walls) then horizontal sections at different elevations may have different layered structures. In this case, the structure describes a vertical section via a rectangle which is divided into polygonal regions whose sides are all vertical or horizontal segments. A map associates each of these regions with the index of a layer in the CompoundStructure which determines the properties of that region.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CompoundStructure Properties

The CompoundStructure type exposes the following members.

Properties
 | Name | Description
Public property | CutoffHeight | Horizontal segments below or at the cutoff height have their distance to the wall bottom fixed, those above have their distance to the wall top fixed.
Public property | EndCap | Indicates the end cap condition defining which shell layers will participate in end wrapping.
Public property | HasStructuralDeck | Checks if the compound structure has a structural deck.
Public property | IsEmpty | Checks whether this CompoundStructure is empty.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | IsVerticallyCompound | Identifies if this CompoundStructure represents a layout that is more complicated than a simple set of parallel layers.
Public property | LayerCount | Returns the number of layers contained in this CompoundStructure.
Public property | MinimumSampleHeight | The minimum sample height determined by the current sample height and the horizontal segments.
Public property | OpeningWrapping | Indicates the opening wrapping condition defining which shell layers of a wall, in plan view, wrap at inserts and openings.
Public property | SampleHeight | The sample height is the presumed height of the wall to which the data in this CompoundStructure is applied.
Public property | StructuralMaterialIndex | Indicates the layer whose material defines the structural properties of the type for the purposes of analysis.
Public property | VariableLayerIndex | Indicates the index of the layer which is designated as variable.
Top
See Also

Reference

CompoundStructure Class


CompoundStructure.CutoffHeight Property

CompoundStructureCutoffHeight Property

Horizontal segments below or at the cutoff height have their distance to the wall bottom fixed, those above have their distance to the wall top fixed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double CutoffHeight { get; set; }
Public Property CutoffHeight As Double
    Get
    Set
public:
property double CutoffHeight {
    double get ();
    void set (double value);
}
member CutoffHeight : float with get, set

Property Value

Double
The cutoff height of this CompoundStructure.
Exceptions
Exception | Condition
InvalidOperationException | This operation is valid only for vertically compound structures.
Remarks
This allows layers with one horizontal segment above and one below this line to be of variable height.
See Also

Reference

CompoundStructure Class


CompoundStructure.EndCap Property

CompoundStructureEndCap Property

Indicates the end cap condition defining which shell layers will participate in end wrapping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EndCapCondition EndCap { get; set; }
Public Property EndCap As EndCapCondition
    Get
    Set
public:
property EndCapCondition EndCap {
    EndCapCondition get ();
    void set (EndCapCondition value);
}
member EndCap : EndCapCondition with get, set

Property Value

EndCapCondition
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

CompoundStructure Class


CompoundStructure.HasStructuralDeck Property

CompoundStructureHasStructuralDeck Property

Checks if the compound structure has a structural deck.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasStructuralDeck { get; }
Public ReadOnly Property HasStructuralDeck As Boolean
    Get
public:
property bool HasStructuralDeck {
    bool get ();
}
member HasStructuralDeck : bool with get

Property Value

Boolean
See Also

Reference

CompoundStructure Class


CompoundStructure.IsEmpty Property

CompoundStructureIsEmpty Property

Checks whether this CompoundStructure is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEmpty { get; }
Public ReadOnly Property IsEmpty As Boolean
    Get
public:
property bool IsEmpty {
    bool get ();
}
member IsEmpty : bool with get

Property Value

Boolean
See Also

Reference

CompoundStructure Class


CompoundStructure.IsValidObject Property

CompoundStructureIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

CompoundStructure Class


CompoundStructure.IsVerticallyCompound Property

CompoundStructureIsVerticallyCompound Property

Identifies if this CompoundStructure represents a layout that is more complicated than a simple set of parallel layers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsVerticallyCompound { get; }
Public ReadOnly Property IsVerticallyCompound As Boolean
    Get
public:
property bool IsVerticallyCompound {
    bool get ();
}
member IsVerticallyCompound : bool with get

Property Value

Boolean
Remarks
Vertically compound structures should be assigned only to walls.
See Also

Reference

CompoundStructure Class


CompoundStructure.LayerCount Property

CompoundStructureLayerCount Property

Returns the number of layers contained in this CompoundStructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int LayerCount { get; }
Public ReadOnly Property LayerCount As Integer
    Get
public:
property int LayerCount {
    int get ();
}
member LayerCount : int with get

Property Value

Int32
Remarks
Establishes the valid range of indices passed to various access functions: [0 ... this value - 1]
See Also

Reference

CompoundStructure Class


CompoundStructure.MinimumSampleHeight Property

CompoundStructureMinimumSampleHeight Property

The minimum sample height determined by the current sample height and the horizontal segments.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double MinimumSampleHeight { get; }
Public ReadOnly Property MinimumSampleHeight As Double
    Get
public:
property double MinimumSampleHeight {
    double get ();
}
member MinimumSampleHeight : float with get

Property Value

Double
Remarks
All horizontal segments dimensioned to the top must remain strictly above all horizontal segments dimensioned to the bottom.
See Also

Reference

CompoundStructure Class


CompoundStructure.OpeningWrapping Property

CompoundStructureOpeningWrapping Property

Indicates the opening wrapping condition defining which shell layers of a wall, in plan view, wrap at inserts and openings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OpeningWrappingCondition OpeningWrapping { get; set; }
Public Property OpeningWrapping As OpeningWrappingCondition
    Get
    Set
public:
property OpeningWrappingCondition OpeningWrapping {
    OpeningWrappingCondition get ();
    void set (OpeningWrappingCondition value);
}
member OpeningWrapping : OpeningWrappingCondition with get, set

Property Value

OpeningWrappingCondition
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

CompoundStructure Class


CompoundStructure.SampleHeight Property

CompoundStructureSampleHeight Property

The sample height is the presumed height of the wall to which the data in this CompoundStructure is applied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double SampleHeight { get; set; }
Public Property SampleHeight As Double
    Get
    Set
public:
property double SampleHeight {
    double get ();
    void set (double value);
}
member SampleHeight : float with get, set

Property Value

Double
The height of the wall used to define the vertically compound structure.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The value newSampleHeight is smaller than the value of MinimumSampleHeight.
InvalidOperationException | This operation is valid only for vertically compound structures.
Remarks
This value has meaning only for vertically compound structures. In order to apply this CompoundStructure to a wall whose height differs from the sample height, the underlying grid will be rescaled.
See Also

Reference

CompoundStructure Class


CompoundStructure.StructuralMaterialIndex Property

CompoundStructureStructuralMaterialIndex Property

Indicates the layer whose material defines the structural properties of the type for the purposes of analysis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int StructuralMaterialIndex { get; set; }
Public Property StructuralMaterialIndex As Integer
    Get
    Set
public:
property int StructuralMaterialIndex {
    int get ();
    void set (int value);
}
member StructuralMaterialIndex : int with get, set

Property Value

Int32
The index of the layer containing the structural material properties.
Exceptions
Exception | Condition
ArgumentException | When setting this property: The specified layer cannot define the structural material properties of the type.
ArgumentOutOfRangeException | When setting this property: The layer index is invalid.
See Also

Reference

CompoundStructure Class


CompoundStructure.VariableLayerIndex Property

CompoundStructureVariableLayerIndex Property

Indicates the index of the layer which is designated as variable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int VariableLayerIndex { get; set; }
Public Property VariableLayerIndex As Integer
    Get
    Set
public:
property int VariableLayerIndex {
    int get ();
    void set (int value);
}
member VariableLayerIndex : int with get, set

Property Value

Int32
The index of the layer specified as variable. If there is no variable layer, this value is -1.
Exceptions
Exception | Condition
ArgumentException | When setting this property: The specified layer cannot be set to a variable layer.
ArgumentOutOfRangeException | When setting this property: The layer index is out of range. -or- When setting this property: The layer index is invalid.
Remarks
If the host object to which it is applied has an actual width that exceeds the total width of all layers, then all layers except the variable layer will be created with their specified width, and the variable layer will expand to take up the slack. Generally this is applicable for floors and roofs with shape edits applied. There can be only one variable layer. In the wall compound structure UI, when a layer is labeled 'variable' in the thickness column, that means it is assigned either to a non-rectangular region, or it means the layer is assigned to two different layers. Neither of those situations is what this method refers to.
See Also

Reference

CompoundStructure Class


CompoundStructure Methods

The CompoundStructure type exposes the following members.

Methods
 | Name | Description
Public method | AddWallSweep | Adds a new wall sweep or reveal to the compound structure.
Public method | AssociateRegionWithLayer | Associates a region with a layer.
Public method | CanLayerBeStructuralMaterial | Identifies if the input layer can be designated as defining the structural material for this structure.
Public method | CanLayerBeVariable | Identifies if the input layer can be designated as a variable thickness layer.
Public method | CanLayerWidthBeNonZero | Identifies if changing the width of an existing layer from zero to a positive value will create a rectangular region.
Public method | CanSplitAndMergeRegionsBeUsed | Checks whether split and merge regions operations can be used for this compound structure.
Public method | ChangeRegionWidth | Adjust the width of an existing simple region.
Public method | ClearWallSweeps | Removes all sweeps or reveals from the compound structure.
 | CreateSimpleCompoundStructure | Creates a non-vertically compound structure comprised of parallel layers.
 | CreateSingleLayerCompoundStructure(MaterialFunctionAssignment, Double, ElementId) | Creates a CompoundStructure containing a single layer.
 | CreateSingleLayerCompoundStructure(Double, MaterialFunctionAssignment, Double, ElementId) | Creates a vertically compound CompoundStructure with one layer.
Public method | DeleteLayer | Deletes the specified layer from this CompoundStructure.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | FindEnclosingRegionAndSegments | Given a pair of grid coordinates, and a direction for splitting, returns the enclosing region and the two segments intersected by a line through the grid point.
Public method | GetAdjacentRegions | Gets the ids of region bound to a specified segment.
Public method | GetCoreBoundaryLayerIndex | Returns the index of the layer just below the core boundary.
Public method | GetDeckEmbeddingType | Retrieves the deck embedding type used for the specified structural deck.
Public method | GetDeckProfileId | Retrieves the profile loop used for the specified structural deck.
Public method | GetExtendableRegionIds | Gets the extendable region ids for the compound structure.
Public method | GetFirstCoreLayerIndex | Gets the index of the first core layer.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLastCoreLayerIndex | Gets the index of the last core layer.
Public method | GetLayerAssociatedToRegion | Gets the layer associated to a particular region.
Public method | GetLayerFunction | Retrieves the function of the specified layer.
Public method | GetLayers | A copy of the layers which define this compound structure.
Public method | GetLayerWidth | Retrieves the width of a specified layer.
Public method | GetMaterialId | Retrieves the material element id of a specified layer.
 | GetMinimumLayerThickness | Get the minimum allowable layer thickness.
Public method | GetNumberOfShellLayers | Retrieves the number of interior or exterior shell layers.
Public method | GetOffsetForLocationLine | Returns the offset from the center of the compound structure to the given location line value.
Public method | GetPreviousNonZeroLayerIndex | Returns the index of the nearest non-zero width layer before this layer.
Public method | GetRegionEnvelope | Gets the envelope that a specified region spans.
Public method | GetRegionIds | Gets the region ids of this compound structure.
Public method | GetRegionsAlongLevel | Returns the ids of the regions encountered as the vertically compound structure is traversed at a constant height above the bottom a wall to which this structure is applied.
Public method | GetRegionsAssociatedToLayer | Gets the set of region ids associated to a particular layer.
Public method | GetSegmentCoordinate | Gets the coordinate of a segment.
Public method | GetSegmentEndPoints | Gets the end points of a segment.
Public method | GetSegmentIds | Gets the segment ids of this compound structure.
Public method | GetSegmentOrientation | Gets the orientation of a segment.
Public method | GetSimpleCompoundStructure | Takes a horizontal slice through a sample wall to which this CompoundStructure is applied and returns a simple compound structure which describes that slice, i.e. a series of parallel layers.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetWallSweepsInfo | Obtains a list of the intrinsic wall sweeps or reveals in this CompoundStructure.
Public method | GetWidth | The width implied by this compound structure.
Public method | GetWidth(Int32) | Computes the width of the envelope (2d bounding box) of the specified region.
Public method | IsCoreLayer | Checks if the specified layer is a core layer.
Public method | IsEqual | Checks whether this CompoundStructure is the same as another CompoundStructure.
Public method | IsLayerValid | Verifies that the data in this layer is internally consistent.
Public method | IsRectangularRegion | Determines whether the specified region is rectangular.
Public method | IsSimpleRegion | Determines whether the region is a simple region in this CompoundStructure.
Public method | IsStructuralDeck | Determines whether a specified layer is a structural deck.
Public method | IsValid | Checks for errors or inconsistencies in the data in this CompoundStructure.
Public method | IsValidRegionId | Determines whether the specified integer is actually the id of a region in this CompoundStructure.
Public method | IsValidSampleHeight | Is the specified height a valid sample height for this compound structure?
Public method | IsValidSegmentId | Determines whether the specified integer is actually the id of a segment in this CompoundStructure.
Public method | IsVerticallyHomogeneous | Indicates whether this CompoundStructure represents a single set of parallel layers.
Public method | MergeRegionsAdjacentToSegment | Merges the two regions which share the specified segment.
Public method | ParticipatesInWrapping | Identifies if a layer is included in wrapping at inserts and ends.
Public method | RemoveWallSweep | Removes a single sweep or reveal from the compound structure.
Public method | SetDeckEmbeddingType | Sets the deck embedding type to use for the specified structural deck.
Public method | SetDeckProfileId | Sets the profile loop to use for the specified structural deck.
Public method | SetExtendableRegionIds | Sets the extendable region ids for the compound structure.
Public method | SetLayer | Sets a single layer for this CompoundStructure.
Public method | SetLayerFunction | Sets the function of the specified layer.
Public method | SetLayers | Completely resets this CompoundStructure and applies a new set of layers.
Public method | SetLayerWidth | Sets the width of a specified layer.
Public method | SetMaterialId | Sets a material element for a specified layer.
Public method | SetNumberOfShellLayers | Sets the number of interior or exterior shell layers.
Public method | SetParticipatesInWrapping | Assigns if a layer is included in wrapping at inserts and ends.
Public method | SplitRegion(UV, RectangularGridSegmentOrientation) | Splits the region which contains the specified grid point by a line with the specified direction.
Public method | SplitRegion(UV, RectangularGridSegmentOrientation, Int32) | Splits the region which contains the specified grid point by a line with the specified direction.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CompoundStructure Class


CompoundStructure.AddWallSweep Method

CompoundStructureAddWallSweep Method

Adds a new wall sweep or reveal to the compound structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddWallSweep(
    WallSweepInfo wallSweepInfo
)
Public Sub AddWallSweep (
    wallSweepInfo As WallSweepInfo
)
public:
void AddWallSweep(
    WallSweepInfo^ wallSweepInfo
)
member AddWallSweep :
        wallSweepInfo : WallSweepInfo -> unit

Parameters

wallSweepInfo WallSweepInfo
The wall sweep info to create a wall sweep.
Exceptions
Exception | Condition
ArgumentException | The wall sweep info does not represent a fixed wall sweep. Only fixed wall sweeps may be assigned to vertical compound structures. -or- The WallSweepInfo has an invalid id for a fixed wall sweep.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This operation is valid only for vertically compound structures.
Remarks

A wall sweep is an object that is created by sweeping a closed 2d profile along a horizontal line that is positioned on one side (exterior or interior) of the hosting wall. A reveal is a special wall sweep with a void shape that is subtracted from the hosting wall.

The id field of the WallSweepInfo must be populated with a non-negative integer value. If there already is a sweep defined for this id, its parameters will be changed. A new sweep will be created if no existing one has matching id.

See Also

Reference

CompoundStructure Class


CompoundStructure.AssociateRegionWithLayer Method

CompoundStructureAssociateRegionWithLayer Method

Associates a region with a layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AssociateRegionWithLayer(
    int regionId,
    int layerIdx
)
Public Sub AssociateRegionWithLayer (
    regionId As Integer,
    layerIdx As Integer
)
public:
void AssociateRegionWithLayer(
    int regionId,
    int layerIdx
)
member AssociateRegionWithLayer :
        regionId : int *
        layerIdx : int -> unit

Parameters

regionId Int32
The id of a region.
layerIdx Int32
The index of a layer in this CompoundStructure.
Exceptions
Exception | Condition
ArgumentException | It is not a valid region id.
ArgumentOutOfRangeException | The layer index is out of range.
InvalidOperationException | This operation is valid only for vertically compound structures.
See Also

Reference

CompoundStructure Class


CompoundStructure.CanLayerBeStructuralMaterial Method

CompoundStructureCanLayerBeStructuralMaterial Method

Identifies if the input layer can be designated as defining the structural material for this structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanLayerBeStructuralMaterial(
    int layerIndex
)
Public Function CanLayerBeStructuralMaterial (
    layerIndex As Integer
) As Boolean
public:
bool CanLayerBeStructuralMaterial(
    int layerIndex
)
member CanLayerBeStructuralMaterial :
        layerIndex : int -> bool

Parameters

layerIndex Int32
Index of a layer in the CompoundStructure.

Return Value

Boolean
True if the input layer may be used to define the structural material and false otherwise.
Remarks
Only core layers may be designated as defining the structural material.
See Also

Reference

CompoundStructure Class


CompoundStructure.CanLayerBeVariable Method

CompoundStructureCanLayerBeVariable Method

Identifies if the input layer can be designated as a variable thickness layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanLayerBeVariable(
    int variableLayerIndex
)
Public Function CanLayerBeVariable (
    variableLayerIndex As Integer
) As Boolean
public:
bool CanLayerBeVariable(
    int variableLayerIndex
)
member CanLayerBeVariable :
        variableLayerIndex : int -> bool

Parameters

variableLayerIndex Int32
Index of a layer in the CompoundStructure.

Return Value

Boolean
True if the input layer may be a variable thickness layer and false otherwise.
Remarks
A layer whose layer function is StructuralDeck may not be designated as a variable layer.
See Also

Reference

CompoundStructure Class


CompoundStructure.CanLayerWidthBeNonZero Method

CompoundStructureCanLayerWidthBeNonZero Method

Identifies if changing the width of an existing layer from zero to a positive value will create a rectangular region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanLayerWidthBeNonZero(
    int layerIdx
)
Public Function CanLayerWidthBeNonZero (
    layerIdx As Integer
) As Boolean
public:
bool CanLayerWidthBeNonZero(
    int layerIdx
)
member CanLayerWidthBeNonZero :
        layerIdx : int -> bool

Parameters

layerIdx Int32
The index of a CompoundStructureLayer.

Return Value

Boolean
Remarks
This is only allowed if there is a vertical line such that all regions to the left are assigned to layers with index < layerIdx, and all regions to the right are assigned to layers with index > layerIdx.
See Also

Reference

CompoundStructure Class


CompoundStructure.CanSplitAndMergeRegionsBeUsed Method

CompoundStructureCanSplitAndMergeRegionsBeUsed Method

Checks whether split and merge regions operations can be used for this compound structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanSplitAndMergeRegionsBeUsed()
Public Function CanSplitAndMergeRegionsBeUsed As Boolean
public:
bool CanSplitAndMergeRegionsBeUsed()
member CanSplitAndMergeRegionsBeUsed : unit -> bool

Return Value

Boolean
True if split and merge regions operation can be used for this compound structure, false otherwise.
See Also

Reference

CompoundStructure Class


CompoundStructure.ChangeRegionWidth Method

CompoundStructureChangeRegionWidth Method

Adjust the width of an existing simple region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ChangeRegionWidth(
    int regionId,
    double newWidth
)
Public Function ChangeRegionWidth (
    regionId As Integer,
    newWidth As Double
) As Boolean
public:
bool ChangeRegionWidth(
    int regionId,
    double newWidth
)
member ChangeRegionWidth :
        regionId : int *
        newWidth : float -> bool

Parameters

regionId Int32
The id of a region.
newWidth Double
The desired width of the specified region.

Return Value

Boolean
True if newWidth is zero and the region was deleted.
Exceptions
Exception | Condition
ArgumentException | It is not a valid region id. -or- It is not a simple region.
InvalidOperationException | This operation is valid only for vertically compound structures.
Remarks
If width is changed to zero, the effect is to delete the region.
See Also

Reference

CompoundStructure Class


CompoundStructure.ClearWallSweeps Method

CompoundStructureClearWallSweeps Method

Removes all sweeps or reveals from the compound structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ClearWallSweeps(
    WallSweepType wallSweepType
)
Public Sub ClearWallSweeps (
    wallSweepType As WallSweepType
)
public:
void ClearWallSweeps(
    WallSweepType wallSweepType
)
member ClearWallSweeps :
        wallSweepType : WallSweepType -> unit

Parameters

wallSweepType WallSweepType
The type of a wall sweep.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | This operation is valid only for vertically compound structures.
See Also

Reference

CompoundStructure Class


CompoundStructure.CreateSimpleCompoundStructure Method

CompoundStructureCreateSimpleCompoundStructure Method

Creates a non-vertically compound structure comprised of parallel layers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static CompoundStructure CreateSimpleCompoundStructure(
    IList<CompoundStructureLayer> layers
)
Public Shared Function CreateSimpleCompoundStructure (
    layers As IList(Of CompoundStructureLayer)
) As CompoundStructure
public:
static CompoundStructure^ CreateSimpleCompoundStructure(
    IList<CompoundStructureLayer^>^ layers
)
static member CreateSimpleCompoundStructure :
        layers : IList<CompoundStructureLayer> -> CompoundStructure

Parameters

layers IList CompoundStructureLayer
An array which describes the parallel layers of this compound structure.

Return Value

CompoundStructure
A newly created compound structure.
Exceptions
Exception | Condition
ArgumentException | One or more layers is not valid.
ArgumentNullException | A non-optional argument was null
Remarks
All layers are in the core, i.e. there are no shell layers created.
See Also

Reference

CompoundStructure Class


CompoundStructure.CreateSingleLayerCompoundStructure Method

CompoundStructureCreateSingleLayerCompoundStructure Method

Overload List
Name | Description
CreateSingleLayerCompoundStructure(MaterialFunctionAssignment, Double, ElementId) | Creates a CompoundStructure containing a single layer.
CreateSingleLayerCompoundStructure(Double, MaterialFunctionAssignment, Double, ElementId) | Creates a vertically compound CompoundStructure with one layer.
Top
See Also

Reference

CompoundStructure Class


CompoundStructure.CreateSingleLayerCompoundStructure(MaterialFunctionAssignment, Double, ElementId) Method

CompoundStructureCreateSingleLayerCompoundStructure(MaterialFunctionAssignment, Double, ElementId) Method

Creates a CompoundStructure containing a single layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static CompoundStructure CreateSingleLayerCompoundStructure(
    MaterialFunctionAssignment layerFunction,
    double width,
    ElementId materialId
)
Public Shared Function CreateSingleLayerCompoundStructure (
    layerFunction As MaterialFunctionAssignment,
    width As Double,
    materialId As ElementId
) As CompoundStructure
public:
static CompoundStructure^ CreateSingleLayerCompoundStructure(
    MaterialFunctionAssignment layerFunction,
    double width,
    ElementId^ materialId
)
static member CreateSingleLayerCompoundStructure :
        layerFunction : MaterialFunctionAssignment *
        width : float *
        materialId : ElementId -> CompoundStructure

Parameters

layerFunction MaterialFunctionAssignment
The function of the single layer.
width Double
The width of the single layer.
materialId ElementId
The ElementId of the material for the single layer.

Return Value

CompoundStructure
The newly created compound structure.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | The given value for width must be greater than 0 and no more than 30000 feet. -or- A value passed for an enumeration argument is not a member of that enumeration
Remarks
It is not verified that materialId corresponds to a valid Material element.
See Also

Reference

CompoundStructure Class
CreateSingleLayerCompoundStructure Overload


CompoundStructure.CreateSingleLayerCompoundStructure(Double, MaterialFunctionAssignment, Double, ElementId) Method

CompoundStructureCreateSingleLayerCompoundStructure(Double, MaterialFunctionAssignment, Double, ElementId) Method

Creates a vertically compound CompoundStructure with one layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static CompoundStructure CreateSingleLayerCompoundStructure(
    double sampleHeight,
    MaterialFunctionAssignment layerFunction,
    double width,
    ElementId materialId
)
Public Shared Function CreateSingleLayerCompoundStructure (
    sampleHeight As Double,
    layerFunction As MaterialFunctionAssignment,
    width As Double,
    materialId As ElementId
) As CompoundStructure
public:
static CompoundStructure^ CreateSingleLayerCompoundStructure(
    double sampleHeight,
    MaterialFunctionAssignment layerFunction,
    double width,
    ElementId^ materialId
)
static member CreateSingleLayerCompoundStructure :
        sampleHeight : float *
        layerFunction : MaterialFunctionAssignment *
        width : float *
        materialId : ElementId -> CompoundStructure

Parameters

sampleHeight Double
The sample height of this vertically compound structure.
layerFunction MaterialFunctionAssignment
The function of the single layer.
width Double
The width of the single layer.
materialId ElementId
The ElementId of the material for the single layer.

Return Value

CompoundStructure
The newly created compound structure.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | The given value for sampleHeight must be greater than 0 and no more than 30000 feet. -or- The given value for width must be greater than 0 and no more than 30000 feet. -or- A value passed for an enumeration argument is not a member of that enumeration
Remarks
It is not verified that materialId corresponds to a valid MaterialElem.
See Also

Reference

CompoundStructure Class
CreateSingleLayerCompoundStructure Overload


CompoundStructure.DeleteLayer Method

CompoundStructureDeleteLayer Method

Deletes the specified layer from this CompoundStructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool DeleteLayer(
    int layerIdx
)
Public Function DeleteLayer (
    layerIdx As Integer
) As Boolean
public:
bool DeleteLayer(
    int layerIdx
)
member DeleteLayer :
        layerIdx : int -> bool

Parameters

layerIdx Int32
The layer index is zero based. It counts from the exterior of wall and from the top of roofs, floors and ceilings.

Return Value

Boolean
True if the layer was successfully deleted, and false otherwise.
Exceptions
Exception | Condition
ArgumentException | The layer cannot be deleted.
ArgumentOutOfRangeException | The layer index is out of range.
Remarks
For a vertically compound structure, a layer may only be deleted if it is not associated to a region, or else it is associated to exactly one simple region, which will also be deleted. Regions associated to layers with index greater than layerIdx will have their associated layer indices decremented by one.
See Also

Reference

CompoundStructure Class


CompoundStructure.Dispose Method

CompoundStructureDispose Method

Releases all resources used by the CompoundStructure

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

CompoundStructure Class


CompoundStructure.FindEnclosingRegionAndSegments Method

CompoundStructureFindEnclosingRegionAndSegments Method

Given a pair of grid coordinates, and a direction for splitting, returns the enclosing region and the two segments intersected by a line through the grid point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int FindEnclosingRegionAndSegments(
    UV gridUV,
    RectangularGridSegmentOrientation splitDirection,
    out int segmentId1,
    out int segmentId2
)
Public Function FindEnclosingRegionAndSegments (
    gridUV As UV,
    splitDirection As RectangularGridSegmentOrientation,
    <OutAttribute> ByRef segmentId1 As Integer,
    <OutAttribute> ByRef segmentId2 As Integer
) As Integer
public:
int FindEnclosingRegionAndSegments(
    UV^ gridUV,
    RectangularGridSegmentOrientation splitDirection,
    [OutAttribute] int% segmentId1,
    [OutAttribute] int% segmentId2
)
member FindEnclosingRegionAndSegments :
        gridUV : UV *
        splitDirection : RectangularGridSegmentOrientation *
        segmentId1 : int byref *
        segmentId2 : int byref -> int

Parameters

gridUV UV
Coordinates of a point in the rectangular grid of this compound structure.
splitDirection RectangularGridSegmentOrientation
Specifies the direction of the split.
segmentId1 Int32
The id of a segment in the boundary of the containing region which is split by a line through gridUV in the specified direction.
segmentId2 Int32
The id of a segment in the boundary of the containing region which is split by a line through gridUV in the specified direction.

Return Value

Int32
Returns the id of the enclosing region, and -1 if no region encloses the point.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | This operation is valid only for vertically compound structures.
Remarks
Grid coordinates correspond to uv coordinates of faces.
See Also

Reference

CompoundStructure Class


CompoundStructure.GetAdjacentRegions Method

CompoundStructureGetAdjacentRegions Method

Gets the ids of region bound to a specified segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<int> GetAdjacentRegions(
    int segmentId
)
Public Function GetAdjacentRegions (
    segmentId As Integer
) As IList(Of Integer)
public:
IList<int>^ GetAdjacentRegions(
    int segmentId
)
member GetAdjacentRegions :
        segmentId : int -> IList<int>

Parameters

segmentId Int32
The id of a segment in this CompoundStructure.

Return Value

IList Int32
The ids of the regions that are bounded by the specified segment.
Exceptions
Exception | Condition
ArgumentException | The segment id is invalid.
InvalidOperationException | This operation is valid only for vertically compound structures.
Remarks
The boundaries of the regions of a vertically compound structure consist of vertical horizontal segments with unique ids. The segments which define the outer boundary of the structure are adjacent to one region, other segments will be adjacent to two regions.
See Also

Reference

CompoundStructure Class


CompoundStructure.GetCoreBoundaryLayerIndex Method

CompoundStructureGetCoreBoundaryLayerIndex Method

Returns the index of the layer just below the core boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetCoreBoundaryLayerIndex(
    ShellLayerType shellLayerType
)
Public Function GetCoreBoundaryLayerIndex (
    shellLayerType As ShellLayerType
) As Integer
public:
int GetCoreBoundaryLayerIndex(
    ShellLayerType shellLayerType
)
member GetCoreBoundaryLayerIndex :
        shellLayerType : ShellLayerType -> int

Parameters

shellLayerType ShellLayerType
If ShellLayerType.Exterior return the index on the exterior side (or top side for a roof, floor, or ceiling type). If ShellLayerType.Interior return the index on the interior side (or bottom side for a roof, floor, or ceiling type).

Return Value

Int32
The index of the layer.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Remarks
-1 returned if there is no such a layer. You can change the shell/core layer boundary using SetNumberOfShellLayers(ShellLayerType, Int32).
See Also

Reference

CompoundStructure Class


CompoundStructure.GetDeckEmbeddingType Method

CompoundStructureGetDeckEmbeddingType Method

Retrieves the deck embedding type used for the specified structural deck.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public StructDeckEmbeddingType GetDeckEmbeddingType(
    int layerIdx
)
Public Function GetDeckEmbeddingType (
    layerIdx As Integer
) As StructDeckEmbeddingType
public:
StructDeckEmbeddingType GetDeckEmbeddingType(
    int layerIdx
)
member GetDeckEmbeddingType :
        layerIdx : int -> StructDeckEmbeddingType

Parameters

layerIdx Int32
Index of a layer in the CompoundStructure.

Return Value

StructDeckEmbeddingType
The embedding type of the structural deck associated to the specified layer. Invalid if it is not a structural deck.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The layer index is out of range.
See Also

Reference

CompoundStructure Class


CompoundStructure.GetDeckProfileId Method

CompoundStructureGetDeckProfileId Method

Retrieves the profile loop used for the specified structural deck.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GetDeckProfileId(
    int layerIdx
)
Public Function GetDeckProfileId (
    layerIdx As Integer
) As ElementId
public:
ElementId^ GetDeckProfileId(
    int layerIdx
)
member GetDeckProfileId :
        layerIdx : int -> ElementId

Parameters

layerIdx Int32
Index of a layer in the CompoundStructure.

Return Value

ElementId
The element id of a FamilySymbol which contains a profile loop used by a structural deck associated to the specified layer, or invalidElementId if isStructuralDeck(layerIdx) is false.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The layer index is out of range.
See Also

Reference

CompoundStructure Class


CompoundStructure.GetExtendableRegionIds Method

CompoundStructureGetExtendableRegionIds Method

Gets the extendable region ids for the compound structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<int> GetExtendableRegionIds(
    bool top
)
Public Function GetExtendableRegionIds (
    top As Boolean
) As IList(Of Integer)
public:
IList<int>^ GetExtendableRegionIds(
    bool top
)
member GetExtendableRegionIds :
        top : bool -> IList<int>

Parameters

top Boolean
If true, retrieve ids of regions which are extendable at the top, otherwise retrieve the ids of regions which are extendable at the bottom.

Return Value

IList Int32
An array of region ids which are marked extendable.
Exceptions
Exception | Condition
InvalidOperationException | This operation is valid only for vertically compound structures.
Remarks
Regions along the top or bottom of the wall may be set to be extendable.
See Also

Reference

CompoundStructure Class


CompoundStructure.GetFirstCoreLayerIndex Method

CompoundStructureGetFirstCoreLayerIndex Method

Gets the index of the first core layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetFirstCoreLayerIndex()
Public Function GetFirstCoreLayerIndex As Integer
public:
int GetFirstCoreLayerIndex()
member GetFirstCoreLayerIndex : unit -> int

Return Value

Int32
The index of the first core layer.
Remarks
This is the index on the exterior side. You can change the shell/core layer boundary using SetNumberOfShellLayers(ShellLayerType, Int32).
See Also

Reference

CompoundStructure Class


CompoundStructure.GetLastCoreLayerIndex Method

CompoundStructureGetLastCoreLayerIndex Method

Gets the index of the last core layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetLastCoreLayerIndex()
Public Function GetLastCoreLayerIndex As Integer
public:
int GetLastCoreLayerIndex()
member GetLastCoreLayerIndex : unit -> int

Return Value

Int32
The index of the last core layer.
Remarks
This is the index on the interior side. You can change the shell/core layer boundary using SetNumberOfShellLayers(ShellLayerType, Int32).
See Also

Reference

CompoundStructure Class


CompoundStructure.GetLayerAssociatedToRegion Method

CompoundStructureGetLayerAssociatedToRegion Method

Gets the layer associated to a particular region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetLayerAssociatedToRegion(
    int regionId
)
Public Function GetLayerAssociatedToRegion (
    regionId As Integer
) As Integer
public:
int GetLayerAssociatedToRegion(
    int regionId
)
member GetLayerAssociatedToRegion :
        regionId : int -> int

Parameters

regionId Int32
The id of a region.

Return Value

Int32
The index of a layer in this CompoundStructure.
Exceptions
Exception | Condition
ArgumentsInconsistentException | For a non-vertically compound structure, implicitly each layer is associated to its corresponding simple region.
See Also

Reference

CompoundStructure Class


CompoundStructure.GetLayerFunction Method

CompoundStructureGetLayerFunction Method

Retrieves the function of the specified layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MaterialFunctionAssignment GetLayerFunction(
    int layerIdx
)
Public Function GetLayerFunction (
    layerIdx As Integer
) As MaterialFunctionAssignment
public:
MaterialFunctionAssignment GetLayerFunction(
    int layerIdx
)
member GetLayerFunction :
        layerIdx : int -> MaterialFunctionAssignment

Parameters

layerIdx Int32
Index of a layer in the CompoundStructure.

Return Value

MaterialFunctionAssignment
The function of the layer.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The layer index is out of range.
Remarks
The function determines how this layer interacts with the layers of other elements to which it is joined.
See Also

Reference

CompoundStructure Class


CompoundStructure.GetLayers Method

CompoundStructureGetLayers Method

A copy of the layers which define this compound structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<CompoundStructureLayer> GetLayers()
Public Function GetLayers As IList(Of CompoundStructureLayer)
public:
IList<CompoundStructureLayer^>^ GetLayers()
member GetLayers : unit -> IList<CompoundStructureLayer>

Return Value

IList CompoundStructureLayer
The layers, returned in order (Exterior to Interior for walls, top to bottom for roofs, floors or ceilings). The index of each layer in this array can be used in other CompoundStructure methods accepting a layer index.
See Also

Reference

CompoundStructure Class


CompoundStructure.GetLayerWidth Method

CompoundStructureGetLayerWidth Method

Retrieves the width of a specified layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetLayerWidth(
    int layerIdx
)
Public Function GetLayerWidth (
    layerIdx As Integer
) As Double
public:
double GetLayerWidth(
    int layerIdx
)
member GetLayerWidth :
        layerIdx : int -> float

Parameters

layerIdx Int32
Index of a layer in the CompoundStructure.

Return Value

Double
The width of the specified layer.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The layer index is out of range.
See Also

Reference

CompoundStructure Class


CompoundStructure.GetMaterialId Method

CompoundStructureGetMaterialId Method

Retrieves the material element id of a specified layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GetMaterialId(
    int layerIdx
)
Public Function GetMaterialId (
    layerIdx As Integer
) As ElementId
public:
ElementId^ GetMaterialId(
    int layerIdx
)
member GetMaterialId :
        layerIdx : int -> ElementId

Parameters

layerIdx Int32
Index of a layer in the CompoundStructure.

Return Value

ElementId
The material element id.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The layer index is out of range.
See Also

Reference

CompoundStructure Class


CompoundStructure.GetMinimumLayerThickness Method

CompoundStructureGetMinimumLayerThickness Method

Get the minimum allowable layer thickness.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static double GetMinimumLayerThickness()
Public Shared Function GetMinimumLayerThickness As Double
public:
static double GetMinimumLayerThickness()
static member GetMinimumLayerThickness : unit -> float

Return Value

Double
The minimum allowable width of a layer in feet.
See Also

Reference

CompoundStructure Class


CompoundStructure.GetNumberOfShellLayers Method

CompoundStructureGetNumberOfShellLayers Method

Retrieves the number of interior or exterior shell layers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetNumberOfShellLayers(
    ShellLayerType shellLayerType
)
Public Function GetNumberOfShellLayers (
    shellLayerType As ShellLayerType
) As Integer
public:
int GetNumberOfShellLayers(
    ShellLayerType shellLayerType
)
member GetNumberOfShellLayers :
        shellLayerType : ShellLayerType -> int

Parameters

shellLayerType ShellLayerType
If ShellLayerType.Exterior return the number of exterior shell layers (or top shell layers for a roof, floor, or ceiling type). If ShellLayerType.Interior return the number of interior shell layers (or bottom shell layers for a roof, floor, or ceiling type).

Return Value

Int32
The number of shell layers in the interior or exterior shell, as specified by shellLayerType.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Remarks
There will always be at least one core layer, i.e. one layer which is not a shell layer. You can change the shell/core layer boundary using SetNumberOfShellLayers(ShellLayerType, Int32).
See Also

Reference

CompoundStructure Class


CompoundStructure.GetOffsetForLocationLine Method

CompoundStructureGetOffsetForLocationLine Method

Returns the offset from the center of the compound structure to the given location line value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetOffsetForLocationLine(
    WallLocationLine wallLocationLine
)
Public Function GetOffsetForLocationLine (
    wallLocationLine As WallLocationLine
) As Double
public:
double GetOffsetForLocationLine(
    WallLocationLine wallLocationLine
)
member GetOffsetForLocationLine :
        wallLocationLine : WallLocationLine -> float

Parameters

wallLocationLine WallLocationLine
The alignment type of the wall's location line.

Return Value

Double
The offset.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | This operation is valid only vertically homogeneous compound structures.
See Also

Reference

CompoundStructure Class


CompoundStructure.GetPreviousNonZeroLayerIndex Method

CompoundStructureGetPreviousNonZeroLayerIndex Method

Returns the index of the nearest non-zero width layer before this layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetPreviousNonZeroLayerIndex(
    int thisIdx
)
Public Function GetPreviousNonZeroLayerIndex (
    thisIdx As Integer
) As Integer
public:
int GetPreviousNonZeroLayerIndex(
    int thisIdx
)
member GetPreviousNonZeroLayerIndex :
        thisIdx : int -> int

Parameters

thisIdx Int32
The layer from which to look for a non-zero width layer.

Return Value

Int32
The index of the layer found.
Remarks
If this layer is non-zero width, it will be returned. If there are non-zero width layers found, returns -1.
See Also

Reference

CompoundStructure Class


CompoundStructure.GetRegionEnvelope Method

CompoundStructureGetRegionEnvelope Method

Gets the envelope that a specified region spans.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BoundingBoxUV GetRegionEnvelope(
    int regionId
)
Public Function GetRegionEnvelope (
    regionId As Integer
) As BoundingBoxUV
public:
BoundingBoxUV^ GetRegionEnvelope(
    int regionId
)
member GetRegionEnvelope :
        regionId : int -> BoundingBoxUV

Parameters

regionId Int32
The id of the region.

Return Value

BoundingBoxUV
The envelope of the region.
Exceptions
Exception | Condition
ArgumentException | It is not a valid region id.
InvalidOperationException | This operation is valid only for vertically compound structures.
Remarks
This envelope indicates the external boundary of the region. The coordinate system it defines is used in the results of GetSegmentCoordinate().
See Also

Reference

CompoundStructure Class


CompoundStructure.GetRegionIds Method

CompoundStructureGetRegionIds Method

Gets the region ids of this compound structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<int> GetRegionIds()
Public Function GetRegionIds As IList(Of Integer)
public:
IList<int>^ GetRegionIds()
member GetRegionIds : unit -> IList<int>

Return Value

IList Int32
The ids of the regions defining this CompoundStructure.
Exceptions
Exception | Condition
InvalidOperationException | This operation is valid only for vertically compound structures.
Remarks
A vertically compound structure consists of regions with polygonal boundaries.
See Also

Reference

CompoundStructure Class


CompoundStructure.GetRegionsAlongLevel Method

CompoundStructureGetRegionsAlongLevel Method

Returns the ids of the regions encountered as the vertically compound structure is traversed at a constant height above the bottom a wall to which this structure is applied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<int> GetRegionsAlongLevel(
    double height
)
Public Function GetRegionsAlongLevel (
    height As Double
) As IList(Of Integer)
public:
IList<int>^ GetRegionsAlongLevel(
    double height
)
member GetRegionsAlongLevel :
        height : float -> IList<int>

Parameters

height Double
Distance from the bottom of the wall.

Return Value

IList Int32
The ids of the regions intersected by the specified line.
Exceptions
Exception | Condition
ArgumentException | The height is outside valid range. It should be in the range of [0, SampleHeight].
See Also

Reference

CompoundStructure Class


CompoundStructure.GetRegionsAssociatedToLayer Method

CompoundStructureGetRegionsAssociatedToLayer Method

Gets the set of region ids associated to a particular layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<int> GetRegionsAssociatedToLayer(
    int layerIdx
)
Public Function GetRegionsAssociatedToLayer (
    layerIdx As Integer
) As IList(Of Integer)
public:
IList<int>^ GetRegionsAssociatedToLayer(
    int layerIdx
)
member GetRegionsAssociatedToLayer :
        layerIdx : int -> IList<int>

Parameters

layerIdx Int32
The index of a layer in this CompoundStructure.

Return Value

IList Int32
An array of region ids which are associated to the specified layer.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The layer index is out of range.
Remarks
Regions are associated to layers. In a vertically compound structure, more than one region may be associated to a single layer.
See Also

Reference

CompoundStructure Class


CompoundStructure.GetSegmentCoordinate Method

CompoundStructureGetSegmentCoordinate Method

Gets the coordinate of a segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetSegmentCoordinate(
    int segmentId
)
Public Function GetSegmentCoordinate (
    segmentId As Integer
) As Double
public:
double GetSegmentCoordinate(
    int segmentId
)
member GetSegmentCoordinate :
        segmentId : int -> float

Parameters

segmentId Int32
The id of a segment in this CompoundStructure.

Return Value

Double
The local coordinates of the specified segment.
Exceptions
Exception | Condition
ArgumentException | The segment id is invalid.
InvalidOperationException | This operation is valid only for vertically compound structures.
Remarks
The boundaries of the regions of a vertically compound structure consist of vertical horizontal segments. If the segment orientation is horizontal, then its coordinate will lie in the range [0.0, SampleHeight]. If the segment orientation is vertical, then its coordinate will lie in the range of u values obtained from GetRegionEnvelope(Int32).
See Also

Reference

CompoundStructure Class


CompoundStructure.GetSegmentEndPoints Method

CompoundStructureGetSegmentEndPoints Method

Gets the end points of a segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void GetSegmentEndPoints(
    int segmentId,
    int regionId,
    out UV end1,
    out UV end2
)
Public Sub GetSegmentEndPoints (
    segmentId As Integer,
    regionId As Integer,
    <OutAttribute> ByRef end1 As UV,
    <OutAttribute> ByRef end2 As UV
)
public:
void GetSegmentEndPoints(
    int segmentId,
    int regionId,
    [OutAttribute] UV^% end1,
    [OutAttribute] UV^% end2
)
member GetSegmentEndPoints :
        segmentId : int *
        regionId : int *
        end1 : UV byref *
        end2 : UV byref -> unit

Parameters

segmentId Int32
The segment id.
regionId Int32
The region id.
end1 UV
One end point.
end2 UV
The other end point.
Exceptions
Exception | Condition
ArgumentException | The segment id is invalid.
InvalidOperationException | This operation is valid only for vertically compound structures.
See Also

Reference

CompoundStructure Class


CompoundStructure.GetSegmentIds Method

CompoundStructureGetSegmentIds Method

Gets the segment ids of this compound structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<int> GetSegmentIds()
Public Function GetSegmentIds As IList(Of Integer)
public:
IList<int>^ GetSegmentIds()
member GetSegmentIds : unit -> IList<int>

Return Value

IList Int32
The ids of the segments which form the boundary of the regions of this CompoundStructure.
Exceptions
Exception | Condition
InvalidOperationException | This operation is valid only for vertically compound structures.
Remarks
The boundaries of the regions of a vertically compound structure consist of vertical horizontal segments with unique ids.
See Also

Reference

CompoundStructure Class


CompoundStructure.GetSegmentOrientation Method

CompoundStructureGetSegmentOrientation Method

Gets the orientation of a segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RectangularGridSegmentOrientation GetSegmentOrientation(
    int segmentId
)
Public Function GetSegmentOrientation (
    segmentId As Integer
) As RectangularGridSegmentOrientation
public:
RectangularGridSegmentOrientation GetSegmentOrientation(
    int segmentId
)
member GetSegmentOrientation :
        segmentId : int -> RectangularGridSegmentOrientation

Parameters

segmentId Int32
The id of a segment in this CompoundStructure.

Return Value

RectangularGridSegmentOrientation
The orientation of the specified segment.
Exceptions
Exception | Condition
ArgumentException | The segment id is invalid.
InvalidOperationException | This operation is valid only for vertically compound structures.
Remarks
The boundaries of the regions of a vertically compound structure consist of vertical horizontal segments.
See Also

Reference

CompoundStructure Class


CompoundStructure.GetSimpleCompoundStructure Method

CompoundStructureGetSimpleCompoundStructure Method

Takes a horizontal slice through a sample wall to which this CompoundStructure is applied and returns a simple compound structure which describes that slice, i.e. a series of parallel layers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CompoundStructure GetSimpleCompoundStructure(
    double wallHeight,
    double distAboveBase
)
Public Function GetSimpleCompoundStructure (
    wallHeight As Double,
    distAboveBase As Double
) As CompoundStructure
public:
CompoundStructure^ GetSimpleCompoundStructure(
    double wallHeight,
    double distAboveBase
)
member GetSimpleCompoundStructure :
        wallHeight : float *
        distAboveBase : float -> CompoundStructure

Parameters

wallHeight Double
The height of the wall.
distAboveBase Double
The distance from the base of the wall at which to take the section. If distAboveBase < 0, then internally distAboveBase = 0 is used. If distAboveBase > wallHeight, then internally distAboveBase = wallHeight is used.

Return Value

CompoundStructure
A simple CompoundStructure representing a series of parallel layers.
Remarks
If IsVerticallyCompound is false, the output is a copy of this CompoundStructure.
See Also

Reference

CompoundStructure Class


CompoundStructure.GetWallSweepsInfo Method

CompoundStructureGetWallSweepsInfo Method

Obtains a list of the intrinsic wall sweeps or reveals in this CompoundStructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<WallSweepInfo> GetWallSweepsInfo(
    WallSweepType wallSweepType
)
Public Function GetWallSweepsInfo (
    wallSweepType As WallSweepType
) As IList(Of WallSweepInfo)
public:
IList<WallSweepInfo^>^ GetWallSweepsInfo(
    WallSweepType wallSweepType
)
member GetWallSweepsInfo :
        wallSweepType : WallSweepType -> IList<WallSweepInfo>

Parameters

wallSweepType WallSweepType
Whether to obtain wall sweeps or reveals.

Return Value

IList WallSweepInfo
An array which describes the intrinsic wall sweeps or reveals.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

CompoundStructure Class


CompoundStructure.GetWidth Method

CompoundStructureGetWidth Method

Overload List
 | Name | Description
Public method | GetWidth | The width implied by this compound structure.
Public method | GetWidth(Int32) | Computes the width of the envelope (2d bounding box) of the specified region.
Top
See Also

Reference

CompoundStructure Class


CompoundStructure.GetWidth Method

CompoundStructureGetWidth Method

The width implied by this compound structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetWidth()
Public Function GetWidth As Double
public:
double GetWidth()
member GetWidth : unit -> float

Return Value

Double
The width of a host object with this compound structure.
Remarks
If the structure is not vertically compound, then this is simply the sum of all layers' widths. If the structure is vertically compound, this is the width of the rectangular grid stored in the vertically compound structure. The presence of a layer with variable width has no effect on the value returned by this method. The value returned assumes that all layers have their specified width.
See Also

Reference

CompoundStructure Class
GetWidth Overload


CompoundStructure.GetWidth(Int32) Method

CompoundStructureGetWidth(Int32) Method

Computes the width of the envelope (2d bounding box) of the specified region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetWidth(
    int regionId
)
Public Function GetWidth (
    regionId As Integer
) As Double
public:
double GetWidth(
    int regionId
)
member GetWidth :
        regionId : int -> float

Parameters

regionId Int32
The id of a region in this vertically compound structure.

Return Value

Double
The width of the envelope (2d bounding box) of the region.
Exceptions
Exception | Condition
ArgumentException | It is not a valid region id.
InvalidOperationException | This operation is valid only for vertically compound structures.
See Also

Reference

CompoundStructure Class
GetWidth Overload


CompoundStructure.IsCoreLayer Method

CompoundStructureIsCoreLayer Method

Checks if the specified layer is a core layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCoreLayer(
    int layerIdx
)
Public Function IsCoreLayer (
    layerIdx As Integer
) As Boolean
public:
bool IsCoreLayer(
    int layerIdx
)
member IsCoreLayer :
        layerIdx : int -> bool

Parameters

layerIdx Int32
The index of a layer in this CompoundStructure.

Return Value

Boolean
Returns true if the layer is within the core layer boundary, false if it is in the interior or exterior shell layers.
Remarks
You can change the shell/core layer boundary using SetNumberOfShellLayers(ShellLayerType, Int32).
See Also

Reference

CompoundStructure Class


CompoundStructure.IsEqual Method

CompoundStructureIsEqual Method

Checks whether this CompoundStructure is the same as another CompoundStructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEqual(
    CompoundStructure otherStructure
)
Public Function IsEqual (
    otherStructure As CompoundStructure
) As Boolean
public:
bool IsEqual(
    CompoundStructure^ otherStructure
)
member IsEqual :
        otherStructure : CompoundStructure -> bool

Parameters

otherStructure CompoundStructure
A CompoundStructure.

Return Value

Boolean
True if the two CompoundStructures are the same, and false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

CompoundStructure Class


CompoundStructure.IsLayerValid Method

CompoundStructureIsLayerValid Method

Verifies that the data in this layer is internally consistent.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsLayerValid(
    int layerIdx,
    CompoundStructureLayer layer
)
Public Function IsLayerValid (
    layerIdx As Integer,
    layer As CompoundStructureLayer
) As Boolean
public:
bool IsLayerValid(
    int layerIdx,
    CompoundStructureLayer^ layer
)
member IsLayerValid :
        layerIdx : int *
        layer : CompoundStructureLayer -> bool

Parameters

layerIdx Int32
The index of the layer in the compound structure to be set.
layer CompoundStructureLayer
The layer to be set.

Return Value

Boolean
True if the layer is internally consistent, false if the layer is not internally consistent.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
If the layer function is not Membrane or StructuralDeck, the width must be greater than zero. If the layer function is not StructuralDeck, then the deck embedding type must be Invalid, and the deck profile id must be InvalidElementId.
See Also

Reference

CompoundStructure Class


CompoundStructure.IsRectangularRegion Method

CompoundStructureIsRectangularRegion Method

Determines whether the specified region is rectangular.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsRectangularRegion(
    int regionId
)
Public Function IsRectangularRegion (
    regionId As Integer
) As Boolean
public:
bool IsRectangularRegion(
    int regionId
)
member IsRectangularRegion :
        regionId : int -> bool

Parameters

regionId Int32
The id of a region.

Return Value

Boolean
True if the specified region is a rectangle, false otherwise.
Exceptions
Exception | Condition
ArgumentException | It is not a valid region id.
InvalidOperationException | This operation is valid only for vertically compound structures.
See Also

Reference

CompoundStructure Class


CompoundStructure.IsSimpleRegion Method

CompoundStructureIsSimpleRegion Method

Determines whether the region is a simple region in this CompoundStructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSimpleRegion(
    int regionId
)
Public Function IsSimpleRegion (
    regionId As Integer
) As Boolean
public:
bool IsSimpleRegion(
    int regionId
)
member IsSimpleRegion :
        regionId : int -> bool

Parameters

regionId Int32
The id of a region in this vertically compound structure.

Return Value

Boolean
True if the region is simple, false otherwise.
Exceptions
Exception | Condition
ArgumentException | It is not a valid region id.
InvalidOperationException | This operation is valid only for vertically compound structures.
Remarks
A region is simple if it rectangular and spans the height of the wall.
See Also

Reference

CompoundStructure Class


CompoundStructure.IsStructuralDeck Method

CompoundStructureIsStructuralDeck Method

Determines whether a specified layer is a structural deck.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsStructuralDeck(
    int layerIdx
)
Public Function IsStructuralDeck (
    layerIdx As Integer
) As Boolean
public:
bool IsStructuralDeck(
    int layerIdx
)
member IsStructuralDeck :
        layerIdx : int -> bool

Parameters

layerIdx Int32
Index of a layer in the CompoundStructure.

Return Value

Boolean
True if specified layer is a structural deck, and false otherwise.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The layer index is out of range.
See Also

Reference

CompoundStructure Class


CompoundStructure.IsValid Method

CompoundStructureIsValid Method

Checks for errors or inconsistencies in the data in this CompoundStructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValid(
    Document doc,
    out IDictionary<int, CompoundStructureError> errMap,
    out IDictionary<int, int> twoLayerErrorsMap
)
Public Function IsValid (
    doc As Document,
    <OutAttribute> ByRef errMap As IDictionary(Of Integer, CompoundStructureError),
    <OutAttribute> ByRef twoLayerErrorsMap As IDictionary(Of Integer, Integer)
) As Boolean
public:
bool IsValid(
    Document^ doc,
    [OutAttribute] IDictionary<int, CompoundStructureError>^% errMap,
    [OutAttribute] IDictionary<int, int>^% twoLayerErrorsMap
)
member IsValid :
        doc : Document *
        errMap : IDictionary<int, CompoundStructureError> byref *
        twoLayerErrorsMap : IDictionary<int, int> byref -> bool

Parameters

doc Document
Access to the document in which the CompoundStructure will be used.
errMap IDictionary Int32, CompoundStructureError
This map will associate each problematic layer index to a value in CompoundStructureError. General structure errors are reported as associated to layer index -1.
twoLayerErrorsMap IDictionary Int32, Int32
The map is associated to a check run only for vertically Compound Structures. Essentially the Compound Structure is sliced at representative heights. It looks at the region from exterior to interior, and requires that the assigned layer indices do not decrease. If they do, an entry is generated for this map. The first entry is the last valid layer index encountered. The second entry is a region id whose assigned layer index is too small: it should be at least as large as the first entry.

Return Value

Boolean
True if the compound structure is valid for the document, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
This check is run before the CompoundStructure may be assigned to a particular ElementType.
See Also

Reference

CompoundStructure Class


CompoundStructure.IsValidRegionId Method

CompoundStructureIsValidRegionId Method

Determines whether the specified integer is actually the id of a region in this CompoundStructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidRegionId(
    int regionId
)
Public Function IsValidRegionId (
    regionId As Integer
) As Boolean
public:
bool IsValidRegionId(
    int regionId
)
member IsValidRegionId :
        regionId : int -> bool

Parameters

regionId Int32
The id of a region in this vertically compound structure.

Return Value

Boolean
True if the region is valid, false otherwise.
Exceptions
Exception | Condition
InvalidOperationException | This operation is valid only for vertically compound structures.
See Also

Reference

CompoundStructure Class


CompoundStructure.IsValidSampleHeight Method

CompoundStructureIsValidSampleHeight Method

Is the specified height a valid sample height for this compound structure?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidSampleHeight(
    double height
)
Public Function IsValidSampleHeight (
    height As Double
) As Boolean
public:
bool IsValidSampleHeight(
    double height
)
member IsValidSampleHeight :
        height : float -> bool

Parameters

height Double

Return Value

Boolean
Remarks
The sample height cannot be less than the value of MinimumSampleHeight.
See Also

Reference

CompoundStructure Class


CompoundStructure.IsValidSegmentId Method

CompoundStructureIsValidSegmentId Method

Determines whether the specified integer is actually the id of a segment in this CompoundStructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidSegmentId(
    int segmentId
)
Public Function IsValidSegmentId (
    segmentId As Integer
) As Boolean
public:
bool IsValidSegmentId(
    int segmentId
)
member IsValidSegmentId :
        segmentId : int -> bool

Parameters

segmentId Int32
The id of a segment in this CompoundStructure.

Return Value

Boolean
True if the specified segment is valid, false otherwise.
Exceptions
Exception | Condition
InvalidOperationException | This operation is valid only for vertically compound structures.
See Also

Reference

CompoundStructure Class


CompoundStructure.IsVerticallyHomogeneous Method

CompoundStructureIsVerticallyHomogeneous Method

Indicates whether this CompoundStructure represents a single set of parallel layers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsVerticallyHomogeneous()
Public Function IsVerticallyHomogeneous As Boolean
public:
bool IsVerticallyHomogeneous()
member IsVerticallyHomogeneous : unit -> bool

Return Value

Boolean
True if this CompoundStructure represents a series of parallel layers that stretch from bottom to top, false otherwise.
Remarks
Differs from IsVerticallyCompound as a vertically compound structure might happen not to have any horizontal breaks. For that situation, both IsVerticallyCompound and this method will return true.
See Also

Reference

CompoundStructure Class


CompoundStructure.MergeRegionsAdjacentToSegment Method

CompoundStructureMergeRegionsAdjacentToSegment Method

Merges the two regions which share the specified segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int MergeRegionsAdjacentToSegment(
    int segmentId,
    int layerIdxForMergedRegion
)
Public Function MergeRegionsAdjacentToSegment (
    segmentId As Integer,
    layerIdxForMergedRegion As Integer
) As Integer
public:
int MergeRegionsAdjacentToSegment(
    int segmentId,
    int layerIdxForMergedRegion
)
member MergeRegionsAdjacentToSegment :
        segmentId : int *
        layerIdxForMergedRegion : int -> int

Parameters

segmentId Int32
The id of a segment in the underlying grid.
layerIdxForMergedRegion Int32
The index of the layer to which the resulting region will be associated.

Return Value

Int32
The id of the resulting region. If -1 is returned, then the operation would have produced an invalid region and was not performed.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The layer index is out of range.
InvalidOperationException | Split and merge regions operations can be used only for vertically compound structures without variable thickness layers. -or- The segment is not shared by adjacent regions.
See Also

Reference

CompoundStructure Class


CompoundStructure.ParticipatesInWrapping Method

CompoundStructureParticipatesInWrapping Method

Identifies if a layer is included in wrapping at inserts and ends.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ParticipatesInWrapping(
    int layerIdx
)
Public Function ParticipatesInWrapping (
    layerIdx As Integer
) As Boolean
public:
bool ParticipatesInWrapping(
    int layerIdx
)
member ParticipatesInWrapping :
        layerIdx : int -> bool

Parameters

layerIdx Int32
The index of the layer.

Return Value

Boolean
If true, then the layer participates in wrapping at inserts and openings. If false, the layer will not participate in wrapping.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The layer index is out of range.
Remarks
This method applies only to interior and exterior shell layers.
See Also

Reference

CompoundStructure Class


CompoundStructure.RemoveWallSweep Method

CompoundStructureRemoveWallSweep Method

Removes a single sweep or reveal from the compound structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveWallSweep(
    WallSweepType wallSweepType,
    int id
)
Public Sub RemoveWallSweep (
    wallSweepType As WallSweepType,
    id As Integer
)
public:
void RemoveWallSweep(
    WallSweepType wallSweepType,
    int id
)
member RemoveWallSweep :
        wallSweepType : WallSweepType *
        id : int -> unit

Parameters

wallSweepType WallSweepType
The type of a wall sweep.
id Int32
The id of the sweep or reveal to remove.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | This operation is valid only for vertically compound structures.
Remarks
No validation of input arguments is performed. If no reveal or sweep has the specified id, no action is performed.
See Also

Reference

CompoundStructure Class


CompoundStructure.SetDeckEmbeddingType Method

CompoundStructureSetDeckEmbeddingType Method

Sets the deck embedding type to use for the specified structural deck.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetDeckEmbeddingType(
    int layerIdx,
    StructDeckEmbeddingType embedType
)
Public Sub SetDeckEmbeddingType (
    layerIdx As Integer,
    embedType As StructDeckEmbeddingType
)
public:
void SetDeckEmbeddingType(
    int layerIdx,
    StructDeckEmbeddingType embedType
)
member SetDeckEmbeddingType :
        layerIdx : int *
        embedType : StructDeckEmbeddingType -> unit

Parameters

layerIdx Int32
Index of a layer in the CompoundStructure.
embedType StructDeckEmbeddingType
The embedding type to be used by the specified layer if it is a structural deck.
Exceptions
Exception | Condition
ArgumentException | The layer is not a structural deck.
ArgumentOutOfRangeException | The layer index is out of range. -or- A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

CompoundStructure Class


CompoundStructure.SetDeckProfileId Method

CompoundStructureSetDeckProfileId Method

Sets the profile loop to use for the specified structural deck.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetDeckProfileId(
    int layerIdx,
    ElementId profileId
)
Public Sub SetDeckProfileId (
    layerIdx As Integer,
    profileId As ElementId
)
public:
void SetDeckProfileId(
    int layerIdx,
    ElementId^ profileId
)
member SetDeckProfileId :
        layerIdx : int *
        profileId : ElementId -> unit

Parameters

layerIdx Int32
Index of a layer in the CompoundStructure.
profileId ElementId
The element id of a FamilySymbol which contains a profile loop to be used by the specified layer if it is a structural deck.
Exceptions
Exception | Condition
ArgumentException | The layer is not a structural deck.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | The layer index is out of range.
See Also

Reference

CompoundStructure Class


CompoundStructure.SetExtendableRegionIds Method

CompoundStructureSetExtendableRegionIds Method

Sets the extendable region ids for the compound structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetExtendableRegionIds(
    bool top,
    IList<int> regionIds
)
Public Sub SetExtendableRegionIds (
    top As Boolean,
    regionIds As IList(Of Integer)
)
public:
void SetExtendableRegionIds(
    bool top,
    IList<int>^ regionIds
)
member SetExtendableRegionIds :
        top : bool *
        regionIds : IList<int> -> unit

Parameters

top Boolean
If true, set ids of regions which are extendable at the top, otherwise set the ids of regions which are extendable at the bottom.
regionIds IList Int32
The ids of regions which will be extendable.
Exceptions
Exception | Condition
ArgumentException | The region ids are not valid.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This operation is valid only for vertically compound structures.
Remarks
Regions along the top or bottom of the wall may be set to be extendable.
See Also

Reference

CompoundStructure Class


CompoundStructure.SetLayer Method

CompoundStructureSetLayer Method

Sets a single layer for this CompoundStructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetLayer(
    int layerIdx,
    CompoundStructureLayer layer
)
Public Sub SetLayer (
    layerIdx As Integer,
    layer As CompoundStructureLayer
)
public:
void SetLayer(
    int layerIdx,
    CompoundStructureLayer^ layer
)
member SetLayer :
        layerIdx : int *
        layer : CompoundStructureLayer -> unit

Parameters

layerIdx Int32
The index of a layer. This should range from 0 to the number of layers - 1.
layer CompoundStructureLayer
The layer to be set.
Exceptions
Exception | Condition
ArgumentException | The layer is not valid for this operation.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | The layer index is out of range.
InvalidOperationException | This operation is valid only for non-vertically compound structures.
Remarks
This function does not support addition of new layers, use SetLayers() to change the number of layers.
See Also

Reference

CompoundStructure Class


CompoundStructure.SetLayerFunction Method

CompoundStructureSetLayerFunction Method

Sets the function of the specified layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetLayerFunction(
    int layerIdx,
    MaterialFunctionAssignment function
)
Public Sub SetLayerFunction (
    layerIdx As Integer,
    function As MaterialFunctionAssignment
)
public:
void SetLayerFunction(
    int layerIdx,
    MaterialFunctionAssignment function
)
member SetLayerFunction :
        layerIdx : int *
        function : MaterialFunctionAssignment -> unit

Parameters

layerIdx Int32
Index of a layer in the CompoundStructure.
function MaterialFunctionAssignment
The function of the layer.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The layer index is out of range. -or- A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

CompoundStructure Class


CompoundStructure.SetLayers Method

CompoundStructureSetLayers Method

Completely resets this CompoundStructure and applies a new set of layers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetLayers(
    IList<CompoundStructureLayer> layers
)
Public Sub SetLayers (
    layers As IList(Of CompoundStructureLayer)
)
public:
void SetLayers(
    IList<CompoundStructureLayer^>^ layers
)
member SetLayers :
        layers : IList<CompoundStructureLayer> -> unit

Parameters

layers IList CompoundStructureLayer
The layers to be set.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
This function will replace all existing layers with the contents of the input. This provides a full reset for the CompoundStructure. Therefore:
  • All layers will be marked as Core layers, and any settings related to Shell layers (such as GetFirstCoreLayerIndex, GetLastCoreLayerIndex or GetCoreBoundaryLayerIndex(ShellLayerType)) will be modified accordingly.
  • Because all layers will be set as Core layers, the value of LayerCapFlag will be ignored (and set to true) automatically.
  • The VariableLayerIndex will be unset.
  • The StructuralMaterialIndex will be unset.
  • The compound structure will be set to be vertically homogeneous.
See Also

Reference

CompoundStructure Class


CompoundStructure.SetLayerWidth Method

CompoundStructureSetLayerWidth Method

Sets the width of a specified layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetLayerWidth(
    int layerIdx,
    double width
)
Public Sub SetLayerWidth (
    layerIdx As Integer,
    width As Double
)
public:
void SetLayerWidth(
    int layerIdx,
    double width
)
member SetLayerWidth :
        layerIdx : int *
        width : float -> unit

Parameters

layerIdx Int32
Index of a layer in the CompoundStructure.
width Double
The new width of the specified layer.
Exceptions
Exception | Condition
ArgumentException | The width of the layer is not valid.
ArgumentOutOfRangeException | The layer index is out of range.
InvalidOperationException | If the region of the layer is not a simple region.
Remarks
If the structure is vertically compound, and the layer is associated to a single simple region, the width of that region is adjusted. If layerIdx is 0 or LayerCount-1, and there is no associated region in the VerticalRegionsStructure, one will be created and associated to the layer. If the specified layer index is associated to a simple region, and the width is set to 0.0, that region will be deleted.
See Also

Reference

CompoundStructure Class


CompoundStructure.SetMaterialId Method

CompoundStructureSetMaterialId Method

Sets a material element for a specified layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetMaterialId(
    int layerIdx,
    ElementId materialId
)
Public Sub SetMaterialId (
    layerIdx As Integer,
    materialId As ElementId
)
public:
void SetMaterialId(
    int layerIdx,
    ElementId^ materialId
)
member SetMaterialId :
        layerIdx : int *
        materialId : ElementId -> unit

Parameters

layerIdx Int32
Index of a layer in the CompoundStructure.
materialId ElementId
The ElementId of a Material element.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | The layer index is out of range.
Remarks
It is not verified that materialId corresponds to a valid Material element.
See Also

Reference

CompoundStructure Class


CompoundStructure.SetNumberOfShellLayers Method

CompoundStructureSetNumberOfShellLayers Method

Sets the number of interior or exterior shell layers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetNumberOfShellLayers(
    ShellLayerType shellLayerType,
    int numLayers
)
Public Sub SetNumberOfShellLayers (
    shellLayerType As ShellLayerType,
    numLayers As Integer
)
public:
void SetNumberOfShellLayers(
    ShellLayerType shellLayerType,
    int numLayers
)
member SetNumberOfShellLayers :
        shellLayerType : ShellLayerType *
        numLayers : int -> unit

Parameters

shellLayerType ShellLayerType
If ShellLayerType.Exterior set the number of exterior shell layers (or top shell layers for a roof, floor, or ceiling type). If ShellLayerType.Interior set the number of interior shell layers (or bottom shell layers for a roof, floor, or ceiling type).
numLayers Int32
The number of layers to be in the specified shell.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Number of shell layers is negative. -or- A value passed for an enumeration argument is not a member of that enumeration
ArgumentsInconsistentException | Too many shell layers: there must be at least one core layer.
Remarks
There must be at least one core layer, i.e. one layer which is not a shell layer.
See Also

Reference

CompoundStructure Class


CompoundStructure.SetParticipatesInWrapping Method

CompoundStructureSetParticipatesInWrapping Method

Assigns if a layer is included in wrapping at inserts and ends.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetParticipatesInWrapping(
    int layerIdx,
    bool participatesInWrapping
)
Public Sub SetParticipatesInWrapping (
    layerIdx As Integer,
    participatesInWrapping As Boolean
)
public:
void SetParticipatesInWrapping(
    int layerIdx,
    bool participatesInWrapping
)
member SetParticipatesInWrapping :
        layerIdx : int *
        participatesInWrapping : bool -> unit

Parameters

layerIdx Int32
The index of the layer.
participatesInWrapping Boolean
True if the specified layer will participate in wrapping at inserts and ends, false otherwise.
Exceptions
Exception | Condition
ArgumentException | The wrapping of the layer is not valid.
ArgumentOutOfRangeException | The layer index is out of range.
Remarks
This method applies only to interior and exterior shell layers.
See Also

Reference

CompoundStructure Class


CompoundStructure.SplitRegion Method

CompoundStructureSplitRegion Method

Overload List
 | Name | Description
Public method | SplitRegion(UV, RectangularGridSegmentOrientation) | Splits the region which contains the specified grid point by a line with the specified direction.
Public method | SplitRegion(UV, RectangularGridSegmentOrientation, Int32) | Splits the region which contains the specified grid point by a line with the specified direction.
Top
See Also

Reference

CompoundStructure Class


CompoundStructure.SplitRegion(UV, RectangularGridSegmentOrientation) Method

CompoundStructureSplitRegion(UV, RectangularGridSegmentOrientation) Method

Splits the region which contains the specified grid point by a line with the specified direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int SplitRegion(
    UV gridUV,
    RectangularGridSegmentOrientation splitDirection
)
Public Function SplitRegion (
    gridUV As UV,
    splitDirection As RectangularGridSegmentOrientation
) As Integer
public:
int SplitRegion(
    UV^ gridUV,
    RectangularGridSegmentOrientation splitDirection
)
member SplitRegion :
        gridUV : UV *
        splitDirection : RectangularGridSegmentOrientation -> int

Parameters

gridUV UV
Coordinates of a point in the rectangular grid of this compound structure.
splitDirection RectangularGridSegmentOrientation
Specifies the direction of the split.

Return Value

Int32
The id of the region created by this operation.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | Split and merge regions operations can be used only for vertically compound structures without variable thickness layers.
Remarks
This method is meant to be used in conjunction with FindEnclosingRegionAndSegments(UV, RectangularGridSegmentOrientation, Int32, Int32). Grid coordinates correspond to uv coordinates of faces.
See Also

Reference

CompoundStructure Class
SplitRegion Overload


CompoundStructure.SplitRegion(UV, RectangularGridSegmentOrientation, Int32) Method

CompoundStructureSplitRegion(UV, RectangularGridSegmentOrientation, Int32) Method

Splits the region which contains the specified grid point by a line with the specified direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int SplitRegion(
    UV gridUV,
    RectangularGridSegmentOrientation splitDirection,
    out int newSegmentId
)
Public Function SplitRegion (
    gridUV As UV,
    splitDirection As RectangularGridSegmentOrientation,
    <OutAttribute> ByRef newSegmentId As Integer
) As Integer
public:
int SplitRegion(
    UV^ gridUV,
    RectangularGridSegmentOrientation splitDirection,
    [OutAttribute] int% newSegmentId
)
member SplitRegion :
        gridUV : UV *
        splitDirection : RectangularGridSegmentOrientation *
        newSegmentId : int byref -> int

Parameters

gridUV UV
Coordinates of a point in the rectangular grid of this compound structure.
splitDirection RectangularGridSegmentOrientation
Specifies the direction of the split.
newSegmentId Int32
The id of segment that bounds both the original region and the new region.

Return Value

Int32
The id of the region created by this operation.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | Split and merge regions operations can be used only for vertically compound structures without variable thickness layers.
Remarks
This method is meant to be used in conjunction with FindEnclosingRegionAndSegments(UV, RectangularGridSegmentOrientation, Int32, Int32). Grid coordinates correspond to uv coordinates of faces.
See Also

Reference

CompoundStructure Class
SplitRegion Overload


CompoundStructureError Enumeration

When CompoundStructure::isValid() returns false, it uses these values to indicate precise nature of defect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum CompoundStructureError
Public Enumeration CompoundStructureError
public enum class CompoundStructureError
type CompoundStructureError
Members
Member name | Value | Description
BadShellOrder | 0 | Layer Function Priorities ascend from the Core Boundary to the Finish Face.
CoreTooThin | 1 | Core contain a membrane layer or thickness of core is zero.
MembraneTooThick | 3 | Thickness of membrane layer is more than zero.
NonmembraneTooThin | 4 | Thickness of non-membrane layer is too thin.
BadShellsStructure | 5 | The number of shell layers is larger than the total number of layers.
ThinOuterLayer | 6 | Thickness of face layer is too thin.
VerticalUnusedLayer | 7 | A layer is not membrane layer and the Thickness of layer is zero.
VerticalWrongOrderLayer | 8 | Layers assigned to the same Row are not on the same side of the Core Boundary.
VerticalWrongOrderCoreExterior | 9 | Exterior core boundary have more than one face at any height.
VerticalWrongOrderCoreInterior | 10 | Interior core boundary have more than one face at any height.
VerticalWrongOrderMembrane | 11 | Membrane Layer have more than one face at any height.
DeckCantBoundAbove | 12 | There is no layer above Structural deck or it is too thin.
DeckCantBoundBelow | 13 | There is no layer below Structural deck or it is too thin.
VarThickLayerCantBeZero | 14 | Variable thickness layer have zero thickness.
InvalidMaterialId | 15 | Element id used as material id does not correspond to an actual MaterialElem.
ExtensibleRegionsNotContiguousAlongTop | 16 | Extension Layers at the top of the wall must be adjacent.
ExtensibleRegionsNotContiguousAlongBottom | 17 | Extension Layers at the bottom of the wall must be adjacent.
InvalidProfileId | 18 | Element id used as profile id does not correspond to a valid deck profile.
Remarks
'LayerTooThin' enum value was removed in 2016
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CompoundStructureLayer Class

Describes a single layer in a CompoundStructure.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBCompoundStructureLayer

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CompoundStructureLayer : IDisposable
Public Class CompoundStructureLayer
    Implements IDisposable
public ref class CompoundStructureLayer : IDisposable
type CompoundStructureLayer =
    class
        interface IDisposable
    end

The CompoundStructureLayer type exposes the following members.

Constructors
 | Name | Description
Public method | CompoundStructureLayer | Creates a compound structure layer using default settings.
Public method | CompoundStructureLayer(CompoundStructureLayer) | Creates a copy of a compound structure layer.
Public method | CompoundStructureLayer(Double, MaterialFunctionAssignment, ElementId) | Creates a default compound structure layer based on the given width, function and material element id.
Top
Properties
 | Name | Description
Public property | DeckEmbeddingType | Embedding type for structural deck - only for a layer whose function is StructuralDeck.
Public property | DeckProfileId | The ElementId of the structural deck profile - only for a layer whose function is StructuralDeck.
Public property | Function | The function of the layer.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LayerCapFlag | Identifies if the layer participates in wrapping at end caps and/or inserts.
Public property | LayerId | The id of the layer - note that this may be different from the index in the array of layers in a CompoundStructure.
 | MaterialId | Id of the material assigned to this layer.
Public property | Width | Width of the layer.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the CompoundStructureLayer
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CompoundStructureLayer Constructor

Overload List
 | Name | Description
Public method | CompoundStructureLayer | Creates a compound structure layer using default settings.
Public method | CompoundStructureLayer(CompoundStructureLayer) | Creates a copy of a compound structure layer.
Public method | CompoundStructureLayer(Double, MaterialFunctionAssignment, ElementId) | Creates a default compound structure layer based on the given width, function and material element id.
Top
See Also

Reference

CompoundStructureLayer Class


CompoundStructureLayer Constructor

Creates a compound structure layer using default settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CompoundStructureLayer()
Public Sub New
public:
CompoundStructureLayer()
new : unit -> CompoundStructureLayer
Remarks
Note that the combination of the default values does not create a completely valid CompoundStructureLayer. You should change the necessary values before adding to a CompoundStructure.
See Also

Reference

CompoundStructureLayer Class
CompoundStructureLayer Overload


CompoundStructureLayer(CompoundStructureLayer) Constructor

Creates a copy of a compound structure layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CompoundStructureLayer(
    CompoundStructureLayer cs
)
Public Sub New (
    cs As CompoundStructureLayer
)
public:
CompoundStructureLayer(
    CompoundStructureLayer^ cs
)
new :
        cs : CompoundStructureLayer -> CompoundStructureLayer

Parameters

cs CompoundStructureLayer
The compound structure to copy.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

CompoundStructureLayer Class
CompoundStructureLayer Overload


CompoundStructureLayer(Double, MaterialFunctionAssignment, ElementId) Constructor

Creates a default compound structure layer based on the given width, function and material element id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CompoundStructureLayer(
    double width,
    MaterialFunctionAssignment function,
    ElementId materialId
)
Public Sub New (
    width As Double,
    function As MaterialFunctionAssignment,
    materialId As ElementId
)
public:
CompoundStructureLayer(
    double width,
    MaterialFunctionAssignment function,
    ElementId^ materialId
)
new :
        width : float *
        function : MaterialFunctionAssignment *
        materialId : ElementId -> CompoundStructureLayer

Parameters

width Double
The width of the layer.
function MaterialFunctionAssignment
The function of the layer.
materialId ElementId
The material element id of the layer.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

CompoundStructureLayer Class
CompoundStructureLayer Overload


CompoundStructureLayer Properties

The CompoundStructureLayer type exposes the following members.

Properties
 | Name | Description
Public property | DeckEmbeddingType | Embedding type for structural deck - only for a layer whose function is StructuralDeck.
Public property | DeckProfileId | The ElementId of the structural deck profile - only for a layer whose function is StructuralDeck.
Public property | Function | The function of the layer.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LayerCapFlag | Identifies if the layer participates in wrapping at end caps and/or inserts.
Public property | LayerId | The id of the layer - note that this may be different from the index in the array of layers in a CompoundStructure.
 | MaterialId | Id of the material assigned to this layer.
Public property | Width | Width of the layer.
Top
See Also

Reference

CompoundStructureLayer Class


CompoundStructureLayer.DeckEmbeddingType Property

CompoundStructureLayerDeckEmbeddingType Property

Embedding type for structural deck - only for a layer whose function is StructuralDeck.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public StructDeckEmbeddingType DeckEmbeddingType { get; set; }
Public Property DeckEmbeddingType As StructDeckEmbeddingType
    Get
    Set
public:
property StructDeckEmbeddingType DeckEmbeddingType {
    StructDeckEmbeddingType get ();
    void set (StructDeckEmbeddingType value);
}
member DeckEmbeddingType : StructDeckEmbeddingType with get, set

Property Value

StructDeckEmbeddingType
The default is StructDeckEmbeddingType.Invalid.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

CompoundStructureLayer Class


CompoundStructureLayer.DeckProfileId Property

CompoundStructureLayerDeckProfileId Property

The ElementId of the structural deck profile - only for a layer whose function is StructuralDeck.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId DeckProfileId { get; set; }
Public Property DeckProfileId As ElementId
    Get
    Set
public:
property ElementId^ DeckProfileId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member DeckProfileId : ElementId with get, set

Property Value

ElementId
The default is InvalidElementId.
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

CompoundStructureLayer Class


CompoundStructureLayer.Function Property

CompoundStructureLayerFunction Property

The function of the layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MaterialFunctionAssignment Function { get; set; }
Public Property Function As MaterialFunctionAssignment
    Get
    Set
public:
property MaterialFunctionAssignment Function {
    MaterialFunctionAssignment get ();
    void set (MaterialFunctionAssignment value);
}
member Function : MaterialFunctionAssignment with get, set

Property Value

MaterialFunctionAssignment
The default is MaterialFunctionAssignment.None.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

CompoundStructureLayer Class


CompoundStructureLayer.IsValidObject Property

CompoundStructureLayerIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

CompoundStructureLayer Class


CompoundStructureLayer.LayerCapFlag Property

CompoundStructureLayerLayerCapFlag Property

Identifies if the layer participates in wrapping at end caps and/or inserts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool LayerCapFlag { get; set; }
Public Property LayerCapFlag As Boolean
    Get
    Set
public:
property bool LayerCapFlag {
    bool get ();
    void set (bool value);
}
member LayerCapFlag : bool with get, set

Property Value

Boolean
True if the layer participates in wrapping, false otherwise. It is meaningful only for Shell layers (for Core layers, the value is always true). The default value is true.
See Also

Reference

CompoundStructureLayer Class


CompoundStructureLayer.LayerId Property

CompoundStructureLayerLayerId Property

The id of the layer - note that this may be different from the index in the array of layers in a CompoundStructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int LayerId { get; }
Public ReadOnly Property LayerId As Integer
    Get
public:
property int LayerId {
    int get ();
}
member LayerId : int with get

Property Value

Int32
See Also

Reference

CompoundStructureLayer Class


CompoundStructureLayer.MaterialId Property

CompoundStructureLayerMaterialId Property

Id of the material assigned to this layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId MaterialId { get; set; }
Public Property MaterialId As ElementId
    Get
    Set
public:
property ElementId^ MaterialId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member MaterialId : ElementId with get, set

Property Value

ElementId
The default is InvalidElementId.
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
Example
C#
VB
C++
F#
Copy
public void GetWallLayerMaterial(Autodesk.Revit.DB.Document document, Wall wall)
{
    // get WallType of wall
    WallType aWallType = wall.WallType;
    // Only Basic Wall has compoundStructure
    if (WallKind.Basic == aWallType.Kind)
    {
        // Get CompoundStructure
        CompoundStructure comStruct = aWallType.GetCompoundStructure();
        Categories allCategories = document.Settings.Categories;

        // Get the category OST_Walls default Material;
        // use if that layer's default Material is <By Category>
        Category wallCategory = allCategories.get_Item(BuiltInCategory.OST_Walls);
        Autodesk.Revit.DB.Material wallMaterial = wallCategory.Material;

        foreach (CompoundStructureLayer structLayer in comStruct.GetLayers())
        {
            Autodesk.Revit.DB.Material layerMaterial = document.GetElement(structLayer.MaterialId) as Material;

            // If CompoundStructureLayer's Material is specified, use default
            // Material of its Category
            if (null == layerMaterial)
            {
                switch (structLayer.Function)
                {
                    case MaterialFunctionAssignment.Finish1:
                        layerMaterial =
                            allCategories.get_Item(BuiltInCategory.OST_WallsFinish1).Material;
                        break;
                    case MaterialFunctionAssignment.Finish2:
                        layerMaterial =
                            allCategories.get_Item(BuiltInCategory.OST_WallsFinish2).Material;
                        break;
                    case MaterialFunctionAssignment.Membrane:
                        layerMaterial =
                            allCategories.get_Item(BuiltInCategory.OST_WallsMembrane).Material;
                        break;
                    case MaterialFunctionAssignment.Structure:
                        layerMaterial =
                            allCategories.get_Item(BuiltInCategory.OST_WallsStructure).Material;
                        break;
                    case MaterialFunctionAssignment.Substrate:
                        layerMaterial =
                            allCategories.get_Item(BuiltInCategory.OST_WallsSubstrate).Material;
                        break;
                    case MaterialFunctionAssignment.Insulation:
                        layerMaterial =
                            allCategories.get_Item(BuiltInCategory.OST_WallsInsulation).Material;
                        break;
                    default:
                        // It is impossible to reach here
                        break;
                }
                if (null == layerMaterial)
                {
                    // CompoundStructureLayer's default Material is its SubCategory
                    layerMaterial = wallMaterial;
                }
            }
            TaskDialog.Show("Revit","Layer Material: " + layerMaterial);
        }
    }
}
Public Sub GetWallLayerMaterial(document As Autodesk.Revit.DB.Document, wall As Wall)
    ' get WallType of wall
    Dim aWallType As WallType = wall.WallType
    ' Only Basic Wall has compoundStructure
    If WallKind.Basic = aWallType.Kind Then
        ' Get CompoundStructure
        Dim comStruct As CompoundStructure = aWallType.GetCompoundStructure()
        Dim allCategories As Categories = document.Settings.Categories

        ' Get the category OST_Walls default Material;
        ' use if that layer's default Material is <By Category>
        Dim wallCategory As Category = allCategories.Item(BuiltInCategory.OST_Walls)
        Dim wallMaterial As Autodesk.Revit.DB.Material = wallCategory.Material

        For Each structLayer As CompoundStructureLayer In comStruct.GetLayers()
            Dim layerMaterial As Autodesk.Revit.DB.Material = TryCast(document.GetElement(structLayer.MaterialId), Material)

            ' If CompoundStructureLayer's Material is specified, use default
            ' Material of its Category
            If layerMaterial Is Nothing Then
                Select Case structLayer.[Function]
                    Case MaterialFunctionAssignment.Finish1
                        layerMaterial = allCategories.Item(BuiltInCategory.OST_WallsFinish1).Material
                        Exit Select
                    Case MaterialFunctionAssignment.Finish2
                        layerMaterial = allCategories.Item(BuiltInCategory.OST_WallsFinish2).Material
                        Exit Select
                    Case MaterialFunctionAssignment.Membrane
                        layerMaterial = allCategories.Item(BuiltInCategory.OST_WallsMembrane).Material
                        Exit Select
                    Case MaterialFunctionAssignment.[Structure]
                        layerMaterial = allCategories.Item(BuiltInCategory.OST_WallsStructure).Material
                        Exit Select
                    Case MaterialFunctionAssignment.Substrate
                        layerMaterial = allCategories.Item(BuiltInCategory.OST_WallsSubstrate).Material
                        Exit Select
                    Case MaterialFunctionAssignment.Insulation
                        layerMaterial = allCategories.Item(BuiltInCategory.OST_WallsInsulation).Material
                        Exit Select
                    Case Else
                        ' It is impossible to reach here
                        Exit Select
                End Select
                If layerMaterial Is Nothing Then
                    ' CompoundStructureLayer's default Material is its SubCategory
                    layerMaterial = wallMaterial
                End If
            End If
            TaskDialog.Show("Revit", "Layer Material: " & layerMaterial.ToString())
        Next
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

CompoundStructureLayer Class


CompoundStructureLayer.Width Property

CompoundStructureLayerWidth Property

Width of the layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Width { get; set; }
Public Property Width As Double
    Get
    Set
public:
property double Width {
    double get ();
    void set (double value);
}
member Width : float with get, set

Property Value

Double
Remarks
Can be 0.0 if this is a membrane layer. 0.0 is the default.
See Also

Reference

CompoundStructureLayer Class


CompoundStructureLayer Methods

The CompoundStructureLayer type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CompoundStructureLayer Class


CompoundStructureLayer.Dispose Method

CompoundStructureLayerDispose Method

Releases all resources used by the CompoundStructureLayer

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

CompoundStructureLayer Class


ConfigurationReloadInfo Class

This object contains information returned by a reload of the fabrication configuration.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBConfigurationReloadInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ConfigurationReloadInfo : IDisposable
Public Class ConfigurationReloadInfo
    Implements IDisposable
public ref class ConfigurationReloadInfo : IDisposable
type ConfigurationReloadInfo =
    class
        interface IDisposable
    end

The ConfigurationReloadInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ConfigurationReloadInfo | Constructor.
Top
Properties
 | Name | Description
Public property | Disconnects | The number of disconnections caused by the reload.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OutOfDatePartCount | The number of fabrication part instances that had newer versions and were out of date.
Public property | ProfileNotAvailable | The current profile is not available in the disk configuration.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ConfigurationReloadInfo
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetConnectivityValidation | Returns information about the post-reload connectivity validation.
Public method | GetCustomDataChangedElements | Gets a list of ElementIds of fabrication parts that had custom data updated during the reload.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetOutOfDatePartStatus | Access reload information for out of date part.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ConfigurationReloadInfo Constructor

Constructor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConfigurationReloadInfo()
Public Sub New
public:
ConfigurationReloadInfo()
new : unit -> ConfigurationReloadInfo
See Also

Reference

ConfigurationReloadInfo Class


ConfigurationReloadInfo Properties

The ConfigurationReloadInfo type exposes the following members.

Properties
 | Name | Description
Public property | Disconnects | The number of disconnections caused by the reload.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OutOfDatePartCount | The number of fabrication part instances that had newer versions and were out of date.
Public property | ProfileNotAvailable | The current profile is not available in the disk configuration.
Top
See Also

Reference

ConfigurationReloadInfo Class


ConfigurationReloadInfo.Disconnects Property

ConfigurationReloadInfoDisconnects Property

The number of disconnections caused by the reload.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Disconnects { get; }
Public ReadOnly Property Disconnects As Integer
    Get
public:
property int Disconnects {
    int get ();
}
member Disconnects : int with get

Property Value

Int32
See Also

Reference

ConfigurationReloadInfo Class


ConfigurationReloadInfo.IsValidObject Property

ConfigurationReloadInfoIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ConfigurationReloadInfo Class


ConfigurationReloadInfo.OutOfDatePartCount Property

ConfigurationReloadInfoOutOfDatePartCount Property

The number of fabrication part instances that had newer versions and were out of date.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int OutOfDatePartCount { get; }
Public ReadOnly Property OutOfDatePartCount As Integer
    Get
public:
property int OutOfDatePartCount {
    int get ();
}
member OutOfDatePartCount : int with get

Property Value

Int32
See Also

Reference

ConfigurationReloadInfo Class


ConfigurationReloadInfo.ProfileNotAvailable Property

ConfigurationReloadInfoProfileNotAvailable Property

The current profile is not available in the disk configuration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ProfileNotAvailable { get; }
Public ReadOnly Property ProfileNotAvailable As Boolean
    Get
public:
property bool ProfileNotAvailable {
    bool get ();
}
member ProfileNotAvailable : bool with get

Property Value

Boolean
See Also

Reference

ConfigurationReloadInfo Class


ConfigurationReloadInfo Methods

The ConfigurationReloadInfo type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetConnectivityValidation | Returns information about the post-reload connectivity validation.
Public method | GetCustomDataChangedElements | Gets a list of ElementIds of fabrication parts that had custom data updated during the reload.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetOutOfDatePartStatus | Access reload information for out of date part.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ConfigurationReloadInfo Class


ConfigurationReloadInfo.Dispose Method

ConfigurationReloadInfoDispose Method

Releases all resources used by the ConfigurationReloadInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ConfigurationReloadInfo Class


ConfigurationReloadInfo.GetConnectivityValidation Method

ConfigurationReloadInfoGetConnectivityValidation Method

Returns information about the post-reload connectivity validation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConnectionValidationInfo GetConnectivityValidation()
Public Function GetConnectivityValidation As ConnectionValidationInfo
public:
ConnectionValidationInfo^ GetConnectivityValidation()
member GetConnectivityValidation : unit -> ConnectionValidationInfo

Return Value

ConnectionValidationInfo
Information about the post-reload connectivity validation.
See Also

Reference

ConfigurationReloadInfo Class


ConfigurationReloadInfo.GetCustomDataChangedElements Method

ConfigurationReloadInfoGetCustomDataChangedElements Method

Gets a list of ElementIds of fabrication parts that had custom data updated during the reload.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ISet<ElementId> GetCustomDataChangedElements()
Public Function GetCustomDataChangedElements As ISet(Of ElementId)
public:
ISet<ElementId^>^ GetCustomDataChangedElements()
member GetCustomDataChangedElements : unit -> ISet<ElementId>

Return Value

ISet ElementId
A list identifying changed elements.
See Also

Reference

ConfigurationReloadInfo Class


ConfigurationReloadInfo.GetOutOfDatePartStatus Method

ConfigurationReloadInfoGetOutOfDatePartStatus Method

Access reload information for out of date part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReloadSwapOutInfo GetOutOfDatePartStatus(
    int index
)
Public Function GetOutOfDatePartStatus (
    index As Integer
) As ReloadSwapOutInfo
public:
ReloadSwapOutInfo^ GetOutOfDatePartStatus(
    int index
)
member GetOutOfDatePartStatus :
        index : int -> ReloadSwapOutInfo

Parameters

index Int32
The index of the information about the part being reloaded. Must be between 0 and OutOfDatePartCount.

Return Value

ReloadSwapOutInfo
Information about the part being reloaded.
Exceptions
Exception | Condition
ArgumentException | The index is out of range.
See Also

Reference

ConfigurationReloadInfo Class


ConicalFace Class

A conical face of a 3d solid or open shell.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGeometryObject
Autodesk.Revit.DBFace
Autodesk.Revit.DBConicalFace

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ConicalFace : Face
Public Class ConicalFace
    Inherits Face
public ref class ConicalFace : public Face
type ConicalFace =
    class
        inherit Face
    end

The ConicalFace type exposes the following members.

Properties
 | Name | Description
Public property | Area | The area of this face. (Inherited from Face)
Public property | Axis | Axis of the surface.
Public property | EdgeLoops | A collection of edge loops. Each edge loop represents one of the closed boundaries of the face. (Inherited from Face)
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject)
Public property | HalfAngle | Half angle of the surface.
Public property | HasRegions | Identifies if the face contains regions (which can be created, for example, by the Split Face command). (Inherited from Face)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject)
Public property | IsCyclic | Indicates whether the underlying surface is periodic in the specified parametric direction. (Inherited from Face)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject)
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate). (Inherited from Face)
Public property | MaterialElementId | The element ID of the material from which this face is composed. (Inherited from Face)
Public property | OrientationMatchesSurfaceOrientation | Returns true if this face's orientation matches the orientation of the face's surface, false if they have opposite orientations. (Inherited from Face)
Public property | Origin | Origin of the surface.
Public property | Period | The period of the underlying surface in the specified parametric direction. (Inherited from Face)
Public property | Radius | Radii of the surface.
Public property | Reference | Returns a stable reference to the face. (Inherited from Face)
Public property | Visibility | The visibility. (Inherited from GeometryObject)
Top
Methods
 | Name | Description
Public method | ComputeDerivatives | Returns the first partial derivatives of the underlying surface at the specified point. (Inherited from Face)
Public method | ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face)
Public method | ComputeSecondDerivatives | Returns the second partial derivatives of the face at the specified point. (Inherited from Face)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject)
Public method | Evaluate | Evaluates and returns the XYZ coordinates of a point at the indicated UV parameterization of the face. (Inherited from Face)
Public method | GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face)
Public method | GetEdgesAsCurveLoops | Returns a list of closed curve loops that correspond to the edge loops of the face. Curves in each curve loop correspond to individual edges. (Inherited from Face)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject)
Public method | GetRegions | Gets the face regions (created, for example, by the Split Face command) of the face. (Inherited from Face)
Public method | GetSurface | Returns a copy of this face's surface. (Inherited from Face)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face)
Public method | Intersect(Face) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face)
Public method | Intersect(Curve, IntersectionResultArray) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face)
Public method | Intersect(Face, Curve) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face)
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face)
Public method | IsInside(UV, IntersectionResult) | Indicates whether the specified point is within this face and outputs additional information about the point location. (Inherited from Face)
Public method | Project | Projects the specified point on the face. (Inherited from Face)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
 | Triangulate | Returns a triangular mesh approximation to the face. (Inherited from Face)
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face. (Inherited from Face)
Top
Remarks
For details on the parameterization, refer to the documentation for ConicalSurface.
Example
C#
VB
C++
F#
Copy
private void GetConicalFaceInfo(Face face)
{
    ConicalFace conicalFace = face as ConicalFace;
    if (null != conicalFace)
    {
       XYZ axis = conicalFace.Axis;
       XYZ origin = conicalFace.Origin;
        double halfAngle = conicalFace.HalfAngle;
        XYZ radius = conicalFace.get_Radius(0);
    }
}
Private Sub GetConicalFaceInfo(face As Face)
    Dim conicalFace As ConicalFace = TryCast(face, ConicalFace)
    If conicalFace IsNot Nothing Then
        Dim axis As XYZ = conicalFace.Axis
        Dim origin As XYZ = conicalFace.Origin
        Dim halfAngle As Double = conicalFace.HalfAngle
        Dim radius As XYZ = conicalFace.Radius(0)
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ConicalFace Properties

The ConicalFace type exposes the following members.

Properties
 | Name | Description
Public property | Area | The area of this face. (Inherited from Face)
Public property | Axis | Axis of the surface.
Public property | EdgeLoops | A collection of edge loops. Each edge loop represents one of the closed boundaries of the face. (Inherited from Face)
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject)
Public property | HalfAngle | Half angle of the surface.
Public property | HasRegions | Identifies if the face contains regions (which can be created, for example, by the Split Face command). (Inherited from Face)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject)
Public property | IsCyclic | Indicates whether the underlying surface is periodic in the specified parametric direction. (Inherited from Face)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject)
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate). (Inherited from Face)
Public property | MaterialElementId | The element ID of the material from which this face is composed. (Inherited from Face)
Public property | OrientationMatchesSurfaceOrientation | Returns true if this face's orientation matches the orientation of the face's surface, false if they have opposite orientations. (Inherited from Face)
Public property | Origin | Origin of the surface.
Public property | Period | The period of the underlying surface in the specified parametric direction. (Inherited from Face)
Public property | Radius | Radii of the surface.
Public property | Reference | Returns a stable reference to the face. (Inherited from Face)
Public property | Visibility | The visibility. (Inherited from GeometryObject)
Top
See Also

Reference

ConicalFace Class


ConicalFace.Axis Property

ConicalFaceAxis Property

Axis of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Axis { get; }
Public ReadOnly Property Axis As XYZ
    Get
public:
property XYZ^ Axis {
    XYZ^ get ();
}
member Axis : XYZ with get

Property Value

XYZ
See Also

Reference

ConicalFace Class


ConicalFace.HalfAngle Property

ConicalFaceHalfAngle Property

Half angle of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double HalfAngle { get; }
Public ReadOnly Property HalfAngle As Double
    Get
public:
property double HalfAngle {
    double get ();
}
member HalfAngle : float with get

Property Value

Double
See Also

Reference

ConicalFace Class


ConicalFace.Origin Property

ConicalFaceOrigin Property

Origin of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Origin { get; }
Public ReadOnly Property Origin As XYZ
    Get
public:
property XYZ^ Origin {
    XYZ^ get ();
}
member Origin : XYZ with get

Property Value

XYZ
See Also

Reference

ConicalFace Class


ConicalFace.Radius Property

ConicalFaceRadius Property

Radii of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ this[
    int index
] { get; }
Public ReadOnly Property Radius (
    index As Integer
) As XYZ
    Get
public:
property XYZ^ Radius[int index] {
    XYZ^ get (int index);
}
member Radius : XYZ with get

Parameters

index Int32

Property Value

XYZ
See Also

Reference

ConicalFace Class


ConicalFace Methods

The ConicalFace type exposes the following members.

Methods
 | Name | Description
Public method | ComputeDerivatives | Returns the first partial derivatives of the underlying surface at the specified point. (Inherited from Face)
Public method | ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face)
Public method | ComputeSecondDerivatives | Returns the second partial derivatives of the face at the specified point. (Inherited from Face)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject)
Public method | Evaluate | Evaluates and returns the XYZ coordinates of a point at the indicated UV parameterization of the face. (Inherited from Face)
Public method | GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face)
Public method | GetEdgesAsCurveLoops | Returns a list of closed curve loops that correspond to the edge loops of the face. Curves in each curve loop correspond to individual edges. (Inherited from Face)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject)
Public method | GetRegions | Gets the face regions (created, for example, by the Split Face command) of the face. (Inherited from Face)
Public method | GetSurface | Returns a copy of this face's surface. (Inherited from Face)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face)
Public method | Intersect(Face) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face)
Public method | Intersect(Curve, IntersectionResultArray) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face)
Public method | Intersect(Face, Curve) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face)
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face)
Public method | IsInside(UV, IntersectionResult) | Indicates whether the specified point is within this face and outputs additional information about the point location. (Inherited from Face)
Public method | Project | Projects the specified point on the face. (Inherited from Face)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
 | Triangulate | Returns a triangular mesh approximation to the face. (Inherited from Face)
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face. (Inherited from Face)
Top
See Also

Reference

ConicalFace Class


ConicalSurface Class

A Conical Surface.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSurface
Autodesk.Revit.DBConicalSurface

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ConicalSurface : Surface
Public Class ConicalSurface
    Inherits Surface
public ref class ConicalSurface : public Surface
type ConicalSurface =
    class
        inherit Surface
    end

The ConicalSurface type exposes the following members.

Properties
 | Name | Description
Public property | Axis | Axis of the cone. This is the Z axis of the local coordinate system associated with this cone.
Public property | HalfAngle | Cone angle.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Surface)
Public property | OrientationMatchesParametricOrientation | Indicates whether this Surface's orientation is the same as or opposite to its parametric orientation. (Inherited from Surface)
Public property | Origin | Apex of the cone. This is the origin of the local coordinate system associated with this cone.
Public property | XDir | X axis of the local coordinate system associated with this cone.
Public property | YDir | X axis of the local coordinate system associated with this cone.
Top
Methods
 | Name | Description
 | Create | Creates a conical surface defined by a local reference frame and a half angle.
Public method | Dispose | (Inherited from Surface)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBoundingBoxUV | Gets the UV bounding box of the surface. (Inherited from Surface)
Public method | GetFrameOfReference | Returns frame of reference associated with this ConicalSurface.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | IsValidConeAngle | Checks whether the input value lies is not 0, greater than -PI/2 and lesser than PI/2.
Public method | Project | Project a 3D point orthogonally onto a surface (to find the nearest point). Throws InvalidOperationException if the projection fails. (Inherited from Surface)
Public method | ProjectWithGuessPoint | Project a 3D point orthogonally onto a surface (to find the nearest point). This method is meant to be used when a good approximate solution for the projection is available. Throws InvalidOperationException if the projection fails. (Inherited from Surface)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The parametric equation of the cone is S(u, v) = center + v*[sin(halfAngle)(cos(u)*xVec + sin(u)*yVec) + cos(halfAngle)*zVec]. Only the branch of the cone with v >= 0 should be used.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ConicalSurface Properties

The ConicalSurface type exposes the following members.

Properties
 | Name | Description
Public property | Axis | Axis of the cone. This is the Z axis of the local coordinate system associated with this cone.
Public property | HalfAngle | Cone angle.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Surface)
Public property | OrientationMatchesParametricOrientation | Indicates whether this Surface's orientation is the same as or opposite to its parametric orientation. (Inherited from Surface)
Public property | Origin | Apex of the cone. This is the origin of the local coordinate system associated with this cone.
Public property | XDir | X axis of the local coordinate system associated with this cone.
Public property | YDir | X axis of the local coordinate system associated with this cone.
Top
See Also

Reference

ConicalSurface Class


ConicalSurface.Axis Property

ConicalSurfaceAxis Property

Axis of the cone. This is the Z axis of the local coordinate system associated with this cone.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Axis { get; }
Public ReadOnly Property Axis As XYZ
    Get
public:
property XYZ^ Axis {
    XYZ^ get ();
}
member Axis : XYZ with get

Property Value

XYZ
See Also

Reference

ConicalSurface Class


ConicalSurface.HalfAngle Property

ConicalSurfaceHalfAngle Property

Cone angle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double HalfAngle { get; }
Public ReadOnly Property HalfAngle As Double
    Get
public:
property double HalfAngle {
    double get ();
}
member HalfAngle : float with get

Property Value

Double
See Also

Reference

ConicalSurface Class


ConicalSurface.Origin Property

ConicalSurfaceOrigin Property

Apex of the cone. This is the origin of the local coordinate system associated with this cone.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Origin { get; }
Public ReadOnly Property Origin As XYZ
    Get
public:
property XYZ^ Origin {
    XYZ^ get ();
}
member Origin : XYZ with get

Property Value

XYZ
See Also

Reference

ConicalSurface Class


ConicalSurface.XDir Property

ConicalSurfaceXDir Property

X axis of the local coordinate system associated with this cone.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ XDir { get; }
Public ReadOnly Property XDir As XYZ
    Get
public:
property XYZ^ XDir {
    XYZ^ get ();
}
member XDir : XYZ with get

Property Value

XYZ
See Also

Reference

ConicalSurface Class


ConicalSurface.YDir Property

ConicalSurfaceYDir Property

X axis of the local coordinate system associated with this cone.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ YDir { get; }
Public ReadOnly Property YDir As XYZ
    Get
public:
property XYZ^ YDir {
    XYZ^ get ();
}
member YDir : XYZ with get

Property Value

XYZ
See Also

Reference

ConicalSurface Class


ConicalSurface Methods

The ConicalSurface type exposes the following members.

Methods
 | Name | Description
 | Create | Creates a conical surface defined by a local reference frame and a half angle.
Public method | Dispose | (Inherited from Surface)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBoundingBoxUV | Gets the UV bounding box of the surface. (Inherited from Surface)
Public method | GetFrameOfReference | Returns frame of reference associated with this ConicalSurface.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | IsValidConeAngle | Checks whether the input value lies is not 0, greater than -PI/2 and lesser than PI/2.
Public method | Project | Project a 3D point orthogonally onto a surface (to find the nearest point). Throws InvalidOperationException if the projection fails. (Inherited from Surface)
Public method | ProjectWithGuessPoint | Project a 3D point orthogonally onto a surface (to find the nearest point). This method is meant to be used when a good approximate solution for the projection is available. Throws InvalidOperationException if the projection fails. (Inherited from Surface)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ConicalSurface Class


ConicalSurface.Create Method

ConicalSurfaceCreate Method

Creates a conical surface defined by a local reference frame and a half angle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ConicalSurface Create(
    Frame frameOfReference,
    double halfAngle
)
Public Shared Function Create (
    frameOfReference As Frame,
    halfAngle As Double
) As ConicalSurface
public:
static ConicalSurface^ Create(
    Frame^ frameOfReference,
    double halfAngle
)
static member Create :
        frameOfReference : Frame *
        halfAngle : float -> ConicalSurface

Parameters

frameOfReference Frame
frameOfReference is an orthonormal frame that defines a local coordinate system for the cone.
  • Frame.Origin is a point on the cylinder's axis.
  • Frame.BasisZ points along the axis, while Frame.BasisX and Frame.BasisY are orthogonal to the axis.
  • The frame may be either left-handed or right-handed (see Frame.IsRightHanded). Note that the "handedness" of the frame does not, by itself, determine the surface's orientation.
halfAngle Double
Cone angle. Must be not 0, lesser than PI/2 and greater than -PI/2.

Return Value

ConicalSurface
The created ConicalSurface.
Exceptions
Exception | Condition
ArgumentException | This Frame object may not be used as a local frame of reference. -or- The supplied value must be not 0, lesser than PI/2 and greater than -PI/2.
ArgumentNullException | A non-optional argument was null
Remarks
The parametric equation of the cone is S(u, v) = Frame.Origin + v*[sin(halfAngle)(cos(u)*Frame.BasisX + sin(u)*Frame.BasisY) + cos(halfAngle)*Frame.BasisZ] This implies the following facts:
  • Frame.BasisX points from the axis point to the point on the cylinder with coordinates (0, 0).
  • Frame.BasisY points in the direction of the partial derivative dS/du at (0, 0).
  • Frame.BasisZ points in the direction of the partial derivative dS/dv at (0, 0).
Only the branch of the cone with v >= 0 should be used.
See Also

Reference

ConicalSurface Class


ConicalSurface.GetFrameOfReference Method

ConicalSurfaceGetFrameOfReference Method

Returns frame of reference associated with this ConicalSurface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Frame GetFrameOfReference()
Public Function GetFrameOfReference As Frame
public:
Frame^ GetFrameOfReference()
member GetFrameOfReference : unit -> Frame

Return Value

Frame
Frame of reference associated with this ConicalSurface.
Remarks
This is an equivalent of new Frame(Origin, XDir, YDir, Axis).
See Also

Reference

ConicalSurface Class


ConicalSurface.IsValidConeAngle Method

ConicalSurfaceIsValidConeAngle Method

Checks whether the input value lies is not 0, greater than -PI/2 and lesser than PI/2.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidConeAngle(
    double halfAngle
)
Public Shared Function IsValidConeAngle (
    halfAngle As Double
) As Boolean
public:
static bool IsValidConeAngle(
    double halfAngle
)
static member IsValidConeAngle :
        halfAngle : float -> bool

Parameters

halfAngle Double
Cone half-angle parameter.

Return Value

Boolean
True if input is not 0, lesser than PI/2 and greater than -PI/2, false otherwise.
See Also

Reference

ConicalSurface Class


ConnectionResolution Enumeration

An enumerated type listing all the possible resolutions for connectivity validation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConnectionResolution
Public Enumeration ConnectionResolution
public enum class ConnectionResolution
type ConnectionResolution
Members
Member name | Value | Description
Disconnected | 0 | Value for parts were disconnected.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ConnectionValidationInfo Class

This object contains information about fabrication connection validations.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBConnectionValidationInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ConnectionValidationInfo : IDisposable
Public Class ConnectionValidationInfo
    Implements IDisposable
public ref class ConnectionValidationInfo : IDisposable
type ConnectionValidationInfo =
    class
        interface IDisposable
    end

The ConnectionValidationInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionValidationInfo | Constructor.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ConnectionValidationInfo
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetWarning | Access specific warning number of warnings generated by reload.
Public method | IsValidWarningIndex | Validate warning index.
Public method | ManyWarnings | Returns number of warnings generated by reload.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ConnectionValidationInfo Constructor

Constructor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConnectionValidationInfo()
Public Sub New
public:
ConnectionValidationInfo()
new : unit -> ConnectionValidationInfo
See Also

Reference

ConnectionValidationInfo Class


ConnectionValidationInfo Properties

The ConnectionValidationInfo type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

ConnectionValidationInfo Class


ConnectionValidationInfo.IsValidObject Property

ConnectionValidationInfoIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ConnectionValidationInfo Class


ConnectionValidationInfo Methods

The ConnectionValidationInfo type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetWarning | Access specific warning number of warnings generated by reload.
Public method | IsValidWarningIndex | Validate warning index.
Public method | ManyWarnings | Returns number of warnings generated by reload.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ConnectionValidationInfo Class


ConnectionValidationInfo.Dispose Method

ConnectionValidationInfoDispose Method

Releases all resources used by the ConnectionValidationInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ConnectionValidationInfo Class


ConnectionValidationInfo.GetWarning Method

ConnectionValidationInfoGetWarning Method

Access specific warning number of warnings generated by reload.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConnectionValidationWarning GetWarning(
    int index
)
Public Function GetWarning (
    index As Integer
) As ConnectionValidationWarning
public:
ConnectionValidationWarning^ GetWarning(
    int index
)
member GetWarning :
        index : int -> ConnectionValidationWarning

Parameters

index Int32

Return Value

ConnectionValidationWarning
Exceptions
Exception | Condition
ArgumentException | Invalid index.
See Also

Reference

ConnectionValidationInfo Class


ConnectionValidationInfo.IsValidWarningIndex Method

ConnectionValidationInfoIsValidWarningIndex Method

Validate warning index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidWarningIndex(
    int index
)
Public Function IsValidWarningIndex (
    index As Integer
) As Boolean
public:
bool IsValidWarningIndex(
    int index
)
member IsValidWarningIndex :
        index : int -> bool

Parameters

index Int32

Return Value

Boolean
See Also

Reference

ConnectionValidationInfo Class


ConnectionValidationInfo.ManyWarnings Method

ConnectionValidationInfoManyWarnings Method

Returns number of warnings generated by reload.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ManyWarnings()
Public Function ManyWarnings As Integer
public:
int ManyWarnings()
member ManyWarnings : unit -> int

Return Value

Int32
See Also

Reference

ConnectionValidationInfo Class


ConnectionValidationWarning Class

Contains information about a specific connection validation problem.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBConnectionValidationWarning

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ConnectionValidationWarning : IDisposable
Public Class ConnectionValidationWarning
    Implements IDisposable
public ref class ConnectionValidationWarning : IDisposable
type ConnectionValidationWarning =
    class
        interface IDisposable
    end

The ConnectionValidationWarning type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionValidationWarning | Constructor.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Reason | Enumeration for reason of warning.
Public property | Resolution | Enumeration for resolution that was applied.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ConnectionValidationWarning
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetParts | Get ElementIds of affected parts.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ConnectionValidationWarning Constructor

Constructor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConnectionValidationWarning(
    ConnectionResolution resolution,
    ConnectionWarning reason,
    ElementId part1,
    ElementId part2
)
Public Sub New (
    resolution As ConnectionResolution,
    reason As ConnectionWarning,
    part1 As ElementId,
    part2 As ElementId
)
public:
ConnectionValidationWarning(
    ConnectionResolution resolution,
    ConnectionWarning reason,
    ElementId^ part1,
    ElementId^ part2
)
new :
        resolution : ConnectionResolution *
        reason : ConnectionWarning *
        part1 : ElementId *
        part2 : ElementId -> ConnectionValidationWarning

Parameters

resolution ConnectionResolution
Resolution type.
reason ConnectionWarning
Warning reason.
part1 ElementId
First element Id.
part2 ElementId
Second element Id.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ConnectionValidationWarning Class


ConnectionValidationWarning Properties

The ConnectionValidationWarning type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Reason | Enumeration for reason of warning.
Public property | Resolution | Enumeration for resolution that was applied.
Top
See Also

Reference

ConnectionValidationWarning Class


ConnectionValidationWarning.IsValidObject Property

ConnectionValidationWarningIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ConnectionValidationWarning Class


ConnectionValidationWarning.Reason Property

ConnectionValidationWarningReason Property

Enumeration for reason of warning.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConnectionWarning Reason { get; }
Public ReadOnly Property Reason As ConnectionWarning
    Get
public:
property ConnectionWarning Reason {
    ConnectionWarning get ();
}
member Reason : ConnectionWarning with get

Property Value

ConnectionWarning
See Also

Reference

ConnectionValidationWarning Class


ConnectionValidationWarning.Resolution Property

ConnectionValidationWarningResolution Property

Enumeration for resolution that was applied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConnectionResolution Resolution { get; }
Public ReadOnly Property Resolution As ConnectionResolution
    Get
public:
property ConnectionResolution Resolution {
    ConnectionResolution get ();
}
member Resolution : ConnectionResolution with get

Property Value

ConnectionResolution
See Also

Reference

ConnectionValidationWarning Class


ConnectionValidationWarning Methods

The ConnectionValidationWarning type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetParts | Get ElementIds of affected parts.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ConnectionValidationWarning Class


ConnectionValidationWarning.Dispose Method

ConnectionValidationWarningDispose Method

Releases all resources used by the ConnectionValidationWarning

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ConnectionValidationWarning Class


ConnectionValidationWarning.GetParts Method

ConnectionValidationWarningGetParts Method

Get ElementIds of affected parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ISet<ElementId> GetParts()
Public Function GetParts As ISet(Of ElementId)
public:
ISet<ElementId^>^ GetParts()
member GetParts : unit -> ISet<ElementId>

Return Value

ISet ElementId
See Also

Reference

ConnectionValidationWarning Class


ConnectionWarning Enumeration

An enumerated type listing all the reasons for connectivity failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConnectionWarning
Public Enumeration ConnectionWarning
public enum class ConnectionWarning
type ConnectionWarning
Members
Member name | Value | Description
Unknown | 0 | Value for unknown or unspecified reason.
Alignment | 1 | Value for parts were moved when rebuilt so that connectors were no longer aligned.
Size | 2 | Value for sizes didn't match.
Shape | 3 | Value for shapes didn't match.
Connectivity | 4 | Value for fabrication Connectivity Mismatch.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Connector Class

A connector in an Autodesk Revit MEP project document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBConnector

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Connector : IConnector, IDisposable
Public Class Connector
    Implements IConnector, IDisposable
public ref class Connector : IConnector,
    IDisposable
type Connector =
    class
        interface IConnector
        interface IDisposable
    end

The Connector type exposes the following members.

Properties
 | Name | Description
Public property | AllowsSlopeAdjustments | Indicates if the connector allows the slope adjustment.
Public property | AllRefs | All references of the connector.
Public property | Angle | The angle of the Connector.
Public property | AssignedDuctFlowConfiguration | The assigned duct flow configuration of the connector.
Public property | AssignedDuctLossMethod | The duct loss method of the connector.
Public property | AssignedFixtureUnits | The assigned fixture units of the connector.
Public property | AssignedFlow | The assigned flow of the connector.
Public property | AssignedFlowDirection | The assigned flow direction of the connector.
Public property | AssignedFlowFactor | The assigned flow factor of this connector.
Public property | AssignedKCoefficient | The assigned kCoefficient of the connector.
Public property | AssignedLossCoefficient | The assigned loss coefficient of the connector.
Public property | AssignedPipeFlowConfiguration | The pipe flow configuration type of the connector.
Public property | AssignedPipeLossMethod | The pipe loss method of the connector.
Public property | AssignedPressureDrop | The assigned pressure drop of the connector.
Public property | Coefficient | The coefficient of the connector.
Public property | ConnectorManager | The connector manager of the connector.
Public property | ConnectorType | The connector type of the connector.
Public property | CoordinateSystem | The coordinate system of the connector.
Public property | Demand | The demand of the connector.
Public property | Description | The description.
Public property | Direction | The direction of the connector.
Public property | Domain | The domain of the connector.
Public property | DuctSystemType | The duct system type of the connector.
Public property | ElectricalSystemType | The electrical system type of the connector.
Public property | EngagementLength | Connector engagement length. When applicable, it represents the inset distance to the end of the fabrication part from the connection point. Otherwise it returns zero.
Public property | Flow | The flow of the connector.
Public property | GasketLength | Connector gasket length. When applicable, it represents the distance from the end of the fabrication part to the center of the gasket. Otherwise it returns zero.
Public property | Height | The height of the connector.
Public property | Id | A unique identifier to identify this connector.
Public property | IsConnected | Identifies if the connector is physically connected to a connector on another element.
Public property | IsMovable | whether the connector can be moved.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MEPSystem | The system of the connector belong to.
Public property | Origin | The location of the connector.
Public property | Owner | The host of the connector.
Public property | PipeSystemType | The pipe system type of the connector.
Public property | PressureDrop | The pressure drop of the connector.
Public property | Radius | The radius of the connector.
Public property | Shape | The shape of the connector.
Public property | Utility | Indicates if the connector is a utility connector.
Public property | VelocityPressure | The velocity pressure of the connector.
Public property | Width | The width of the connector.
Top
Methods
 | Name | Description
Public method | ConnectTo | Make connection between two connectors.
Public method | DisconnectFrom | Remove connection between two connectors.
Public method | Dispose | Releases all resources used by the Connector
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetFabricationConnectorInfo | Gets fabrication connectivity information.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMEPConnectorInfo | Gets MEP connector information.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsConnectedTo | Identifies if the connector is connected to the specified connector.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This connector is an item that is a part of another element (duct, pipe, fitting, or equipment etc.). This connector does not represent the connector element that can be created inside a family; for that element, refer to ConnectorElement.
Example
C#
VB
C++
F#
Copy
public void GetElementAtConnector(Autodesk.Revit.DB.Connector connector)
{
    MEPSystem mepSystem = connector.MEPSystem;
    if (null != mepSystem)
    {
        string message = "Connector is owned by: " + connector.Owner.Name;

        if (connector.IsConnected == true)
        {
            ConnectorSet connectorSet = connector.AllRefs;
            ConnectorSetIterator csi = connectorSet.ForwardIterator();
            while (csi.MoveNext())
            {
                Connector connected = csi.Current as Connector;
                if (null != connected)
                {
                    // look for physical connections
                    if (connected.ConnectorType == ConnectorType.End ||
                        connected.ConnectorType == ConnectorType.Curve ||
                        connected.ConnectorType == ConnectorType.Physical)
                    {
                        message += "\nConnector is connected to: " + connected.Owner.Name;
                        message += "\nConnection type is: " + connected.ConnectorType;
                    }
                }
            }
        }
        else
        {
            message += "\nConnector is not connected to anything.";
        }

        Autodesk.Revit.UI.TaskDialog.Show("Revit", message);
    }
}
Public Sub GetElementAtConnector(connector As Autodesk.Revit.DB.Connector)
    Dim mepSystem As MEPSystem = connector.MEPSystem
    If mepSystem IsNot Nothing Then
        Dim message As String = "Connector is owned by: " + connector.Owner.Name

        If connector.IsConnected = True Then
            Dim connectorSet As ConnectorSet = connector.AllRefs
            Dim csi As ConnectorSetIterator = connectorSet.ForwardIterator()
            While csi.MoveNext()
                Dim connected As Connector = TryCast(csi.Current, Connector)
                If connected IsNot Nothing Then
                    ' look for physical connections
                    If connected.ConnectorType = ConnectorType.[End] OrElse connected.ConnectorType = ConnectorType.Curve OrElse connected.ConnectorType = ConnectorType.Physical Then
                        message += vbLf & "Connector is connected to: " + connected.Owner.Name
                        message += vbLf & "Connection type is: " + connected.ConnectorType
                    End If
                End If
            End While
        Else
            message += vbLf & "Connector is not connected to anything."
        End If

        UI.TaskDialog.Show("Revit", message)
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Connector Properties

The Connector type exposes the following members.

Properties
 | Name | Description
Public property | AllowsSlopeAdjustments | Indicates if the connector allows the slope adjustment.
Public property | AllRefs | All references of the connector.
Public property | Angle | The angle of the Connector.
Public property | AssignedDuctFlowConfiguration | The assigned duct flow configuration of the connector.
Public property | AssignedDuctLossMethod | The duct loss method of the connector.
Public property | AssignedFixtureUnits | The assigned fixture units of the connector.
Public property | AssignedFlow | The assigned flow of the connector.
Public property | AssignedFlowDirection | The assigned flow direction of the connector.
Public property | AssignedFlowFactor | The assigned flow factor of this connector.
Public property | AssignedKCoefficient | The assigned kCoefficient of the connector.
Public property | AssignedLossCoefficient | The assigned loss coefficient of the connector.
Public property | AssignedPipeFlowConfiguration | The pipe flow configuration type of the connector.
Public property | AssignedPipeLossMethod | The pipe loss method of the connector.
Public property | AssignedPressureDrop | The assigned pressure drop of the connector.
Public property | Coefficient | The coefficient of the connector.
Public property | ConnectorManager | The connector manager of the connector.
Public property | ConnectorType | The connector type of the connector.
Public property | CoordinateSystem | The coordinate system of the connector.
Public property | Demand | The demand of the connector.
Public property | Description | The description.
Public property | Direction | The direction of the connector.
Public property | Domain | The domain of the connector.
Public property | DuctSystemType | The duct system type of the connector.
Public property | ElectricalSystemType | The electrical system type of the connector.
Public property | EngagementLength | Connector engagement length. When applicable, it represents the inset distance to the end of the fabrication part from the connection point. Otherwise it returns zero.
Public property | Flow | The flow of the connector.
Public property | GasketLength | Connector gasket length. When applicable, it represents the distance from the end of the fabrication part to the center of the gasket. Otherwise it returns zero.
Public property | Height | The height of the connector.
Public property | Id | A unique identifier to identify this connector.
Public property | IsConnected | Identifies if the connector is physically connected to a connector on another element.
Public property | IsMovable | whether the connector can be moved.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MEPSystem | The system of the connector belong to.
Public property | Origin | The location of the connector.
Public property | Owner | The host of the connector.
Public property | PipeSystemType | The pipe system type of the connector.
Public property | PressureDrop | The pressure drop of the connector.
Public property | Radius | The radius of the connector.
Public property | Shape | The shape of the connector.
Public property | Utility | Indicates if the connector is a utility connector.
Public property | VelocityPressure | The velocity pressure of the connector.
Public property | Width | The width of the connector.
Top
See Also

Reference

Connector Class


Connector.AllowsSlopeAdjustments Property

ConnectorAllowsSlopeAdjustments Property

Indicates if the connector allows the slope adjustment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AllowsSlopeAdjustments { get; }
Public ReadOnly Property AllowsSlopeAdjustments As Boolean
    Get
public:
property bool AllowsSlopeAdjustments {
    bool get ();
}
member AllowsSlopeAdjustments : bool with get

Property Value

Boolean
See Also

Reference

Connector Class


Connector.AllRefs Property

ConnectorAllRefs Property

All references of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConnectorSet AllRefs { get; }
Public ReadOnly Property AllRefs As ConnectorSet
    Get
public:
property ConnectorSet^ AllRefs {
    ConnectorSet^ get ();
}
member AllRefs : ConnectorSet with get

Property Value

ConnectorSet
Remarks
A set of connectors that the connectors is connected to, including both physical connection and logical connection.
See Also

Reference

Connector Class


Connector.Angle Property

ConnectorAngle Property

The angle of the Connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Angle { get; set; }
Public Property Angle As Double
    Get
    Set
public:
property double Angle {
    double get ();
    void set (double value);
}
member Angle : float with get, set

Property Value

Double
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the connector's domain is not DomainHvac, DomainPiping, or DomainCableTrayConduit. Thrown when set value for the connector not in family instance.
ArgumentException | Thrown when setting an invalid value.
InvalidOperationException | Thrown on failure to set angle.
Remarks
Angle may be assigned for connectors of some family instances. In order to set this property, it must be mapped to a writable instance parameter in the family definition. For a connector obtained from a non-family instance (for example not a fitting, but instead a pipe, duct, or cable tray), the value will always be zero. Non-zero angles are only valid for family instance fitting connectors.
See Also

Reference

Connector Class


Connector.AssignedDuctFlowConfiguration Property

ConnectorAssignedDuctFlowConfiguration Property

The assigned duct flow configuration of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DuctFlowConfigurationType AssignedDuctFlowConfiguration { get; }
Public ReadOnly Property AssignedDuctFlowConfiguration As DuctFlowConfigurationType
    Get
public:
property DuctFlowConfigurationType AssignedDuctFlowConfiguration {
    DuctFlowConfigurationType get ();
}
member AssignedDuctFlowConfiguration : DuctFlowConfigurationType with get

Property Value

DuctFlowConfigurationType
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the connector's domain is not DomainHvac. Thrown when the connector is not in a family instance.
InvalidOperationException | Thrown on failure to get duct flow configuration.
Remarks
Assigned duct flow configuration may be assigned for connectors of some family instances.
See Also

Reference

Connector Class


Connector.AssignedDuctLossMethod Property

ConnectorAssignedDuctLossMethod Property

The duct loss method of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DuctLossMethodType AssignedDuctLossMethod { get; }
Public ReadOnly Property AssignedDuctLossMethod As DuctLossMethodType
    Get
public:
property DuctLossMethodType AssignedDuctLossMethod {
    DuctLossMethodType get ();
}
member AssignedDuctLossMethod : DuctLossMethodType with get

Property Value

DuctLossMethodType
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the connector's domain is not DomainHvac. Thrown when the connector is not in family instance.
InvalidOperationException | Thrown on failure to get duct loss method.
Remarks
Assigned duct loss method may be assigned for connectors of some family instances.
See Also

Reference

Connector Class


Connector.AssignedFixtureUnits Property

ConnectorAssignedFixtureUnits Property

The assigned fixture units of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double AssignedFixtureUnits { get; set; }
Public Property AssignedFixtureUnits As Double
    Get
    Set
public:
property double AssignedFixtureUnits {
    double get ();
    void set (double value);
}
member AssignedFixtureUnits : float with get, set

Property Value

Double
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the connector's domain is not DomainPiping. Thrown when the connector is not in a family instance.
ArgumentException | Thrown when set an invalid value.
InvalidOperationException | Thrown on failure to get or set assigned fixture units.
Remarks
Assigned fixture units may be assigned for connectors of some family instances.
See Also

Reference

Connector Class


Connector.AssignedFlow Property

ConnectorAssignedFlow Property

The assigned flow of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double AssignedFlow { get; set; }
Public Property AssignedFlow As Double
    Get
    Set
public:
property double AssignedFlow {
    double get ();
    void set (double value);
}
member AssignedFlow : float with get, set

Property Value

Double
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the connector's domain is not DomainPiping or DomainHvac. Thrown when the connector is not in a family instance.
ArgumentException | Thrown when set an invalid value.
InvalidOperationException | Thrown on failure to get or set assigned flow.
Remarks
Assigned flow may be assigned for connectors of some family instances. In order to set this property, it must be mapped to a writable instance parameter in the family definition.
See Also

Reference

Connector Class


Connector.AssignedFlowDirection Property

ConnectorAssignedFlowDirection Property

The assigned flow direction of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FlowDirectionType AssignedFlowDirection { get; }
Public ReadOnly Property AssignedFlowDirection As FlowDirectionType
    Get
public:
property FlowDirectionType AssignedFlowDirection {
    FlowDirectionType get ();
}
member AssignedFlowDirection : FlowDirectionType with get

Property Value

FlowDirectionType
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the connector is not in a family instance. Thrown when the connector's domain is not DomainHvac or DomainPiping.
InvalidOperationException | Thrown on failure to get assigned flow direction.
Remarks
Flow direction may be assigned for connectors of some family instances.
See Also

Reference

Connector Class


Connector.AssignedFlowFactor Property

ConnectorAssignedFlowFactor Property

The assigned flow factor of this connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double AssignedFlowFactor { get; set; }
Public Property AssignedFlowFactor As Double
    Get
    Set
public:
property double AssignedFlowFactor {
    double get ();
    void set (double value);
}
member AssignedFlowFactor : float with get, set

Property Value

Double
Exceptions
Exception | Condition
InvalidOperationException | Thrown when get assigned flow factor from a connector not in family instance. Thrown when the connector's domain is not DomainHvac or DomainPiping.
ArgumentException | Throw when set an invalid value.
InvalidOperationException | Thrown on failure to get or set assigned flow factor.
Remarks
Assigned flow factor may be assigned for connectors of some family instances. In order to set this property, it must be mapped to a writable instance parameter in the family definition.
See Also

Reference

Connector Class


Connector.AssignedKCoefficient Property

ConnectorAssignedKCoefficient Property

The assigned kCoefficient of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double AssignedKCoefficient { get; set; }
Public Property AssignedKCoefficient As Double
    Get
    Set
public:
property double AssignedKCoefficient {
    double get ();
    void set (double value);
}
member AssignedKCoefficient : float with get, set

Property Value

Double
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the connector's domain is not DomainPiping. Thrown when the connector is not in a family instance.
ArgumentException | Thrown when set an invalid value.
InvalidOperationException | Thrown on failure to get or set kCoefficient.
Remarks
Assigned kCoefficient may be assigned for connectors of some family instances, for more information. In order to set this property, it must be mapped to a writable instance parameter in the family definition.
See Also

Reference

Connector Class


Connector.AssignedLossCoefficient Property

ConnectorAssignedLossCoefficient Property

The assigned loss coefficient of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double AssignedLossCoefficient { get; set; }
Public Property AssignedLossCoefficient As Double
    Get
    Set
public:
property double AssignedLossCoefficient {
    double get ();
    void set (double value);
}
member AssignedLossCoefficient : float with get, set

Property Value

Double
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the connector's domain is not DomainHvac. Thrown when the connector is not in a family instance.
ArgumentException | Thrown when set an invalid value.
InvalidOperationException | Thrown on failure to get or set assigned loss coefficient.
Remarks
Assigned loss coefficient may be assigned for connectors of some family instances, for more information. In order to set this property, it must be mapped to a writable instance parameter in the family definition.
See Also

Reference

Connector Class


Connector.AssignedPipeFlowConfiguration Property

ConnectorAssignedPipeFlowConfiguration Property

The pipe flow configuration type of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PipeFlowConfigurationType AssignedPipeFlowConfiguration { get; }
Public ReadOnly Property AssignedPipeFlowConfiguration As PipeFlowConfigurationType
    Get
public:
property PipeFlowConfigurationType AssignedPipeFlowConfiguration {
    PipeFlowConfigurationType get ();
}
member AssignedPipeFlowConfiguration : PipeFlowConfigurationType with get

Property Value

PipeFlowConfigurationType
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the connector's domain is not DomainPiping. Thrown when the connector is not in a family instance.
InvalidOperationException | Thrown on failure to get pipe flow configuration.
Remarks
Assigned pipe flow configuration may be assigned for connectors of some family instances.
See Also

Reference

Connector Class


Connector.AssignedPipeLossMethod Property

ConnectorAssignedPipeLossMethod Property

The pipe loss method of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PipeLossMethodType AssignedPipeLossMethod { get; }
Public ReadOnly Property AssignedPipeLossMethod As PipeLossMethodType
    Get
public:
property PipeLossMethodType AssignedPipeLossMethod {
    PipeLossMethodType get ();
}
member AssignedPipeLossMethod : PipeLossMethodType with get

Property Value

PipeLossMethodType
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the connector's domain is not DomainPiping. Thrown when the connector is not in a family instance.
InvalidOperationException | Thrown on failure to get pipe loss method.
Remarks
Assigned duct pipe loss method may be assigned for connectors of some family instances.
See Also

Reference

Connector Class


Connector.AssignedPressureDrop Property

ConnectorAssignedPressureDrop Property

The assigned pressure drop of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double AssignedPressureDrop { get; set; }
Public Property AssignedPressureDrop As Double
    Get
    Set
public:
property double AssignedPressureDrop {
    double get ();
    void set (double value);
}
member AssignedPressureDrop : float with get, set

Property Value

Double
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the connector is not in a family instance. Thrown when the connector's domain is not DomainHvac or DomainPiping.
ArgumentException | Thrown when set an invalid value.
InvalidOperationException | Thrown on failure to get or set assigned pressure drop.
Remarks
Assigned pressure drop may be assigned for connectors of some family instances. In order to set this property, it must be mapped to a writable instance parameter in the family definition.
See Also

Reference

Connector Class


Connector.Coefficient Property

ConnectorCoefficient Property

The coefficient of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Coefficient { get; }
Public ReadOnly Property Coefficient As Double
    Get
public:
property double Coefficient {
    double get ();
}
member Coefficient : float with get

Property Value

Double
Exceptions
Exception | Condition
InvalidOperationException | This connector does not support flow calculation and associated properties.
Remarks
Instantaneous coefficient of this connector, calculated according to system.
See Also

Reference

Connector Class


Connector.ConnectorManager Property

ConnectorConnectorManager Property

The connector manager of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConnectorManager ConnectorManager { get; }
Public ReadOnly Property ConnectorManager As ConnectorManager
    Get
public:
property ConnectorManager^ ConnectorManager {
    ConnectorManager^ get ();
}
member ConnectorManager : ConnectorManager with get

Property Value

ConnectorManager
Exceptions
Exception | Condition
InvalidOperationException | Thrown on failure to get connector manager.
See Also

Reference

Connector Class


Connector.ConnectorType Property

ConnectorConnectorType Property

The connector type of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConnectorType ConnectorType { get; }
Public ReadOnly Property ConnectorType As ConnectorType
    Get
public:
property ConnectorType ConnectorType {
    ConnectorType get ();
}
member ConnectorType : ConnectorType with get

Property Value

ConnectorType
See Also

Reference

Connector Class


Connector.CoordinateSystem Property

ConnectorCoordinateSystem Property

The coordinate system of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Transform CoordinateSystem { get; }
Public Overridable ReadOnly Property CoordinateSystem As Transform
    Get
public:
virtual property Transform^ CoordinateSystem {
    Transform^ get ();
}
abstract CoordinateSystem : Transform with get
override CoordinateSystem : Transform with get

Property Value

Transform

Implements

IConnectorCoordinateSystem
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the connector is of logical type.
InvalidOperationException | Thrown on failure to get coordinate system.
Remarks
The coordinate system's origin is the location of the connector and the Z-axis is normal to the connector.
See Also

Reference

Connector Class


Connector.Demand Property

ConnectorDemand Property

The demand of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Demand { get; }
Public ReadOnly Property Demand As Double
    Get
public:
property double Demand {
    double get ();
}
member Demand : float with get

Property Value

Double
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the connector's domain is not DomainPiping.
InvalidOperationException | Thrown on failure to get demand.
Remarks
Instantaneous demand at this connector, calculated according to system.
See Also

Reference

Connector Class


Connector.Description Property

ConnectorDescription Property

The description.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get
public:
property String^ Description {
    String^ get ();
}
member Description : string with get

Property Value

String
See Also

Reference

Connector Class


Connector.Direction Property

ConnectorDirection Property

The direction of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FlowDirectionType Direction { get; }
Public ReadOnly Property Direction As FlowDirectionType
    Get
public:
property FlowDirectionType Direction {
    FlowDirectionType get ();
}
member Direction : FlowDirectionType with get

Property Value

FlowDirectionType
Exceptions
Exception | Condition
InvalidOperationException | This connector does not support flow calculation and associated properties.
Remarks
Instantaneous direction of this connector, calculated according to system.
See Also

Reference

Connector Class


Connector.Domain Property

ConnectorDomain Property

The domain of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Domain Domain { get; }
Public Overridable ReadOnly Property Domain As Domain
    Get
public:
virtual property Domain Domain {
    Domain get ();
}
abstract Domain : Domain with get
override Domain : Domain with get

Property Value

Domain

Implements

IConnectorDomain
See Also

Reference

Connector Class


Connector.DuctSystemType Property

ConnectorDuctSystemType Property

The duct system type of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DuctSystemType DuctSystemType { get; }
Public ReadOnly Property DuctSystemType As DuctSystemType
    Get
public:
property DuctSystemType DuctSystemType {
    DuctSystemType get ();
}
member DuctSystemType : DuctSystemType with get

Property Value

DuctSystemType
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the connector's domain is not DomainHvac.
InvalidOperationException | Thrown on failure to get duct system type.
Remarks
This is the instantaneous system type at this connector, calculated according to system. For unconnected connectors, the system type is undefined.
See Also

Reference

Connector Class


Connector.ElectricalSystemType Property

ConnectorElectricalSystemType Property

The electrical system type of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElectricalSystemType ElectricalSystemType { get; }
Public ReadOnly Property ElectricalSystemType As ElectricalSystemType
    Get
public:
property ElectricalSystemType ElectricalSystemType {
    ElectricalSystemType get ();
}
member ElectricalSystemType : ElectricalSystemType with get

Property Value

ElectricalSystemType
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the connector's domain is not of DomainElectrical.
InvalidOperationException | Thrown on failure to get electrical system type.
Remarks
Instantaneous system type at this connector, calculated according to system. For unconnected connectors, system type is undefined.
See Also

Reference

Connector Class


Connector.EngagementLength Property

ConnectorEngagementLength Property

Connector engagement length. When applicable, it represents the inset distance to the end of the fabrication part from the connection point. Otherwise it returns zero.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double EngagementLength { get; }
Public ReadOnly Property EngagementLength As Double
    Get
public:
property double EngagementLength {
    double get ();
}
member EngagementLength : float with get

Property Value

Double
See Also

Reference

Connector Class


Connector.Flow Property

ConnectorFlow Property

The flow of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Flow { get; }
Public ReadOnly Property Flow As Double
    Get
public:
property double Flow {
    double get ();
}
member Flow : float with get

Property Value

Double
Exceptions
Exception | Condition
InvalidOperationException | This connector does not support flow calculation and associated properties.
Remarks
Instantaneous flow at this connector, calculated according to system.
See Also

Reference

Connector Class


Connector.GasketLength Property

ConnectorGasketLength Property

Connector gasket length. When applicable, it represents the distance from the end of the fabrication part to the center of the gasket. Otherwise it returns zero.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GasketLength { get; }
Public ReadOnly Property GasketLength As Double
    Get
public:
property double GasketLength {
    double get ();
}
member GasketLength : float with get

Property Value

Double
See Also

Reference

Connector Class


Connector.Height Property

ConnectorHeight Property

The height of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual double Height { get; set; }
Public Overridable Property Height As Double
    Get
    Set
public:
virtual property double Height {
    double get ();
    void set (double value);
}
abstract Height : float with get, set
override Height : float with get, set

Property Value

Double

Implements

IConnectorHeight
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the connector's shape is not rectangular.
ArgumentException | Thrown when the argument is invalid.
InvalidOperationException | Thrown on failure to set height.
Remarks
In order to set this property, it must be mapped to a writable instance parameter in the family definition.
See Also

Reference

Connector Class


Connector.Id Property

ConnectorId Property

A unique identifier to identify this connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Id { get; }
Public ReadOnly Property Id As Integer
    Get
public:
property int Id {
    int get ();
}
member Id : int with get

Property Value

Int32
See Also

Reference

Connector Class


Connector.IsConnected Property

ConnectorIsConnected Property

Identifies if the connector is physically connected to a connector on another element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsConnected { get; }
Public ReadOnly Property IsConnected As Boolean
    Get
public:
property bool IsConnected {
    bool get ();
}
member IsConnected : bool with get

Property Value

Boolean
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the connector's type is LogicalConn.
See Also

Reference

Connector Class


Connector.IsMovable Property

ConnectorIsMovable Property

whether the connector can be moved.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsMovable { get; }
Public ReadOnly Property IsMovable As Boolean
    Get
public:
property bool IsMovable {
    bool get ();
}
member IsMovable : bool with get

Property Value

Boolean
Remarks
Only connectors of type EndConn can be moved.
See Also

Reference

Connector Class


Connector.IsValidObject Property

ConnectorIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

Connector Class


Connector.MEPSystem Property

ConnectorMEPSystem Property

The system of the connector belong to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MEPSystem MEPSystem { get; }
Public ReadOnly Property MEPSystem As MEPSystem
    Get
public:
property MEPSystem^ MEPSystem {
    MEPSystem^ get ();
}
member MEPSystem : MEPSystem with get

Property Value

MEPSystem
Exceptions
Exception | Condition
InvalidOperationException | Thrown on failure to get system.
See Also

Reference

Connector Class


Connector.Origin Property

ConnectorOrigin Property

The location of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual XYZ Origin { get; set; }
Public Overridable Property Origin As XYZ
    Get
    Set
public:
virtual property XYZ^ Origin {
    XYZ^ get ();
    void set (XYZ^ value);
}
abstract Origin : XYZ with get, set
override Origin : XYZ with get, set

Property Value

XYZ

Implements

IConnectorOrigin
Exceptions
Exception | Condition
InvalidOperationException | Thrown when connector's type is NonEndConn. Thrown when the connector is a part of a family instance.
ArgumentException | Thrown when the assigned origin is invalid.
InvalidOperationException | Thrown on failure to set origin.
Remarks
Changing the location of the connector may lead to changes of location and geometry for the connector's host element and the hosts for other elements the element is connected to.
See Also

Reference

Connector Class


Connector.Owner Property

ConnectorOwner Property

The host of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Element Owner { get; }
Public ReadOnly Property Owner As Element
    Get
public:
property Element^ Owner {
    Element^ get ();
}
member Owner : Element with get

Property Value

Element
Remarks
The element that contains this connector. It may also contain other connectors.
See Also

Reference

Connector Class


Connector.PipeSystemType Property

ConnectorPipeSystemType Property

The pipe system type of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PipeSystemType PipeSystemType { get; }
Public ReadOnly Property PipeSystemType As PipeSystemType
    Get
public:
property PipeSystemType PipeSystemType {
    PipeSystemType get ();
}
member PipeSystemType : PipeSystemType with get

Property Value

PipeSystemType
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the connector's domain is not DomainPiping.
InvalidOperationException | Thrown on failure to get pipe system type.
Remarks
Instantaneous system type at this connector, calculated according to system. For unconnected connectors, system type is undefined.
See Also

Reference

Connector Class


Connector.PressureDrop Property

ConnectorPressureDrop Property

The pressure drop of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double PressureDrop { get; }
Public ReadOnly Property PressureDrop As Double
    Get
public:
property double PressureDrop {
    double get ();
}
member PressureDrop : float with get

Property Value

Double
Exceptions
Exception | Condition
InvalidOperationException | This connector does not support flow calculation and associated properties.
Remarks
Instantaneous pressure drop of this connector, calculated according to system.
See Also

Reference

Connector Class


Connector.Radius Property

ConnectorRadius Property

The radius of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual double Radius { get; set; }
Public Overridable Property Radius As Double
    Get
    Set
public:
virtual property double Radius {
    double get ();
    void set (double value);
}
abstract Radius : float with get, set
override Radius : float with get, set

Property Value

Double

Implements

IConnectorRadius
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the connector's shape is not round.
ArgumentException | Thrown when the argument is invalid.
InvalidOperationException | Thrown on failure to set radius.
Remarks
In order to set this property, it must be mapped to a writable instance parameter in the family definition.
See Also

Reference

Connector Class


Connector.Shape Property

ConnectorShape Property

The shape of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ConnectorProfileType Shape { get; }
Public Overridable ReadOnly Property Shape As ConnectorProfileType
    Get
public:
virtual property ConnectorProfileType Shape {
    ConnectorProfileType get ();
}
abstract Shape : ConnectorProfileType with get
override Shape : ConnectorProfileType with get

Property Value

ConnectorProfileType

Implements

IConnectorShape
See Also

Reference

Connector Class


Connector.Utility Property

ConnectorUtility Property

Indicates if the connector is a utility connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Utility { get; }
Public ReadOnly Property Utility As Boolean
    Get
public:
property bool Utility {
    bool get ();
}
member Utility : bool with get

Property Value

Boolean
See Also

Reference

Connector Class


Connector.VelocityPressure Property

ConnectorVelocityPressure Property

The velocity pressure of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double VelocityPressure { get; }
Public ReadOnly Property VelocityPressure As Double
    Get
public:
property double VelocityPressure {
    double get ();
}
member VelocityPressure : float with get

Property Value

Double
Exceptions
Exception | Condition
InvalidOperationException | This connector does not support flow calculation and associated properties.
Remarks
Instantaneous velocity pressure of this connector,calculated according to system.
See Also

Reference

Connector Class


Connector.Width Property

ConnectorWidth Property

The width of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual double Width { get; set; }
Public Overridable Property Width As Double
    Get
    Set
public:
virtual property double Width {
    double get ();
    void set (double value);
}
abstract Width : float with get, set
override Width : float with get, set

Property Value

Double

Implements

IConnectorWidth
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the connector's shape is not rectangular.
ArgumentException | Thrown when the argument is invalid.
InvalidOperationException | Thrown on failure to set width.
Remarks
In order to set this property, it must be mapped to a writable instance parameter in the family definition.
See Also

Reference

Connector Class


Connector Methods

The Connector type exposes the following members.

Methods
 | Name | Description
Public method | ConnectTo | Make connection between two connectors.
Public method | DisconnectFrom | Remove connection between two connectors.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetFabricationConnectorInfo | Gets fabrication connectivity information.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMEPConnectorInfo | Gets MEP connector information.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsConnectedTo | Identifies if the connector is connected to the specified connector.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Connector Class


Connector.ConnectTo Method

ConnectorConnectTo Method

Make connection between two connectors.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ConnectTo(
    Connector connector
)
Public Sub ConnectTo (
    connector As Connector
)
public:
void ConnectTo(
    Connector^ connector
)
member ConnectTo :
        connector : Connector -> unit

Parameters

connector Connector
Indicate the connector will be connected to.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when argument is .
ArgumentException | Argument is invalid.
InvalidOperationException | Thrown when two connectors with different domain types. Thrown when these two connectors fail to connect each other. Thrown when connection already exists.
Remarks
Connection success may create a new Fitting between two connectors, if necessary.
See Also

Reference

Connector Class


Connector.DisconnectFrom Method

ConnectorDisconnectFrom Method

Remove connection between two connectors.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void DisconnectFrom(
    Connector connector
)
Public Sub DisconnectFrom (
    connector As Connector
)
public:
void DisconnectFrom(
    Connector^ connector
)
member DisconnectFrom :
        connector : Connector -> unit

Parameters

connector Connector
Indicate the connector, connection will be removed from.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when argument is .
ArgumentException | Argument is invalid.
InvalidOperationException | Thrown when no connection between these two connector. Thrown on failure to remove the connection between these two connectors.
See Also

Reference

Connector Class


Connector.Dispose Method

ConnectorDispose Method

Releases all resources used by the Connector

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

Connector Class


Connector.GetFabricationConnectorInfo Method

ConnectorGetFabricationConnectorInfo Method

Gets fabrication connectivity information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FabricationConnectorInfo GetFabricationConnectorInfo()
Public Function GetFabricationConnectorInfo As FabricationConnectorInfo
public:
FabricationConnectorInfo^ GetFabricationConnectorInfo()
member GetFabricationConnectorInfo : unit -> FabricationConnectorInfo

Return Value

FabricationConnectorInfo
Returns if there is no fabrication connector information associated.
See Also

Reference

Connector Class


Connector.GetMEPConnectorInfo Method

ConnectorGetMEPConnectorInfo Method

Gets MEP connector information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MEPConnectorInfo GetMEPConnectorInfo()
Public Function GetMEPConnectorInfo As MEPConnectorInfo
public:
MEPConnectorInfo^ GetMEPConnectorInfo()
member GetMEPConnectorInfo : unit -> MEPConnectorInfo

Return Value

MEPConnectorInfo
Returns if there is no MEP connector information associated.
See Also

Reference

Connector Class


Connector.IsConnectedTo Method

ConnectorIsConnectedTo Method

Identifies if the connector is connected to the specified connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsConnectedTo(
    Connector connector
)
Public Function IsConnectedTo (
    connector As Connector
) As Boolean
public:
bool IsConnectedTo(
    Connector^ connector
)
member IsConnectedTo :
        connector : Connector -> bool

Parameters

connector Connector

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the argument is .
See Also

Reference

Connector Class


ConnectorDomainType Enumeration

Type of connector domain.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConnectorDomainType
Public Enumeration ConnectorDomainType
public enum class ConnectorDomainType
type ConnectorDomainType
Members
Member name | Value | Description
Undefined | 0 | Domain is undefined
Hvac | 1 | HVAC (duct) connector
Electrical | 2 | Electrical connector
Piping | 3 | Piping connector
CableTrayConduit | 4 | Connector of cable trays or conduits
StructuralAnalytical | 5 | Connector of Structural Analytical Model
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ConnectorElement Class

A base class that provides support for all connector elements occurring in families.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBConnectorElement

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ConnectorElement : Element,
    IConnector
Public Class ConnectorElement
    Inherits Element
    Implements IConnector
public ref class ConnectorElement : public Element,
    IConnector
type ConnectorElement =
    class
        inherit Element
        interface IConnector
    end

The ConnectorElement type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | CoordinateSystem | The coordinate system of the connector.
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Direction | Gets the direction of the connector element.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | Domain | The domain of the connector.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | Height | The height of the connector.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsPrimary | Identifies if this is the primary connector in the family.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | Origin | The location of the connector in family document.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Radius | The radius of the connector.
Public property | Shape | The shape of the connector.
Public property | SystemClassification | The system classification of the connector.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | Width | The width of the connector.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | AssignAsPrimary | Assign a connector as a primary connector.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeHostReference(Reference) | Changes the connector host reference to a new planar face.
Public method | ChangeHostReference(Reference, Edge) | Changes the connector host reference to a new planar face and a new edge loop.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | CreateCableTrayConnector(Document, Reference) | Create a new cable tray ConnectorElement.
 | CreateCableTrayConnector(Document, Reference, Edge) | Create a new cable tray ConnectorElement.
 | CreateConduitConnector(Document, Reference) | Create a new conduit ConnectorElement.
 | CreateConduitConnector(Document, Reference, Edge) | Create a new conduit ConnectorElement.
 | CreateDuctConnector(Document, DuctSystemType, ConnectorProfileType, Reference) | Create a new duct ConnectorElement.
 | CreateDuctConnector(Document, DuctSystemType, ConnectorProfileType, Reference, Edge) | Create a new duct ConnectorElement.
 | CreateElectricalConnector(Document, ElectricalSystemType, Reference) | Create a new electrical ConnectorElement.
 | CreateElectricalConnector(Document, ElectricalSystemType, Reference, Edge) | Create a new electrical ConnectorElement.
 | CreatePipeConnector(Document, PipeSystemType, Reference) | Create a new pipe ConnectorElement.
 | CreatePipeConnector(Document, PipeSystemType, Reference, Edge) | Create a new pipe ConnectorElement with a face and an edge.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FlipDirection | Reverses the direction of the connector element.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLinkedConnectorElement | Get the linked connector element.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSystemClassificationValid | Checks that the MEPSystemType is valid for the domain of connector.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetLinkedConnectorElement | Set the linked connector element.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ConnectorElement Properties

The ConnectorElement type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | CoordinateSystem | The coordinate system of the connector.
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Direction | Gets the direction of the connector element.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | Domain | The domain of the connector.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | Height | The height of the connector.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsPrimary | Identifies if this is the primary connector in the family.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | Origin | The location of the connector in family document.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Radius | The radius of the connector.
Public property | Shape | The shape of the connector.
Public property | SystemClassification | The system classification of the connector.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | Width | The width of the connector.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

ConnectorElement Class


ConnectorElement.CoordinateSystem Property

ConnectorElementCoordinateSystem Property

The coordinate system of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Transform CoordinateSystem { get; }
Public Overridable ReadOnly Property CoordinateSystem As Transform
    Get
public:
virtual property Transform^ CoordinateSystem {
    Transform^ get ();
}
abstract CoordinateSystem : Transform with get
override CoordinateSystem : Transform with get

Property Value

Transform

Implements

IConnectorCoordinateSystem
Remarks
The Z axis of the coordinate system is the normal to the plane of the connector.
See Also

Reference

ConnectorElement Class


ConnectorElement.Direction Property

ConnectorElementDirection Property

Gets the direction of the connector element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Direction { get; }
Public ReadOnly Property Direction As XYZ
    Get
public:
property XYZ^ Direction {
    XYZ^ get ();
}
member Direction : XYZ with get

Property Value

XYZ
See Also

Reference

ConnectorElement Class


ConnectorElement.Domain Property

ConnectorElementDomain Property

The domain of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Domain Domain { get; }
Public Overridable ReadOnly Property Domain As Domain
    Get
public:
virtual property Domain Domain {
    Domain get ();
}
abstract Domain : Domain with get
override Domain : Domain with get

Property Value

Domain

Implements

IConnectorDomain
Remarks
This property is used to retrieve the domain of the connector.
See Also

Reference

ConnectorElement Class


ConnectorElement.Height Property

ConnectorElementHeight Property

The height of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual double Height { get; }
Public Overridable ReadOnly Property Height As Double
    Get
public:
virtual property double Height {
    double get ();
}
abstract Height : float with get
override Height : float with get

Property Value

Double

Implements

IConnectorHeight
Remarks
-1 if the connector is round.
See Also

Reference

ConnectorElement Class


ConnectorElement.IsPrimary Property

ConnectorElementIsPrimary Property

Identifies if this is the primary connector in the family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsPrimary { get; }
Public ReadOnly Property IsPrimary As Boolean
    Get
public:
property bool IsPrimary {
    bool get ();
}
member IsPrimary : bool with get

Property Value

Boolean
See Also

Reference

ConnectorElement Class


ConnectorElement.Origin Property

ConnectorElementOrigin Property

The location of the connector in family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual XYZ Origin { get; }
Public Overridable ReadOnly Property Origin As XYZ
    Get
public:
virtual property XYZ^ Origin {
    XYZ^ get ();
}
abstract Origin : XYZ with get
override Origin : XYZ with get

Property Value

XYZ

Implements

IConnectorOrigin
See Also

Reference

ConnectorElement Class


ConnectorElement.Radius Property

ConnectorElementRadius Property

The radius of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual double Radius { get; }
Public Overridable ReadOnly Property Radius As Double
    Get
public:
virtual property double Radius {
    double get ();
}
abstract Radius : float with get
override Radius : float with get

Property Value

Double

Implements

IConnectorRadius
Remarks
-1 if the connector is not round.
See Also

Reference

ConnectorElement Class


ConnectorElement.Shape Property

ConnectorElementShape Property

The shape of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ConnectorProfileType Shape { get; }
Public Overridable ReadOnly Property Shape As ConnectorProfileType
    Get
public:
virtual property ConnectorProfileType Shape {
    ConnectorProfileType get ();
}
abstract Shape : ConnectorProfileType with get
override Shape : ConnectorProfileType with get

Property Value

ConnectorProfileType

Implements

IConnectorShape
Remarks
ConnectorProfileType::Invalid if the connector is electrical or undefined.
See Also

Reference

ConnectorElement Class


ConnectorElement.SystemClassification Property

ConnectorElementSystemClassification Property

The system classification of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MEPSystemClassification SystemClassification { get; set; }
Public Property SystemClassification As MEPSystemClassification
    Get
    Set
public:
property MEPSystemClassification SystemClassification {
    MEPSystemClassification get ();
    void set (MEPSystemClassification value);
}
member SystemClassification : MEPSystemClassification with get, set

Property Value

MEPSystemClassification
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
ArgumentsInconsistentException | When setting this property: The MEPSystemType is not valid for the domain of this connector.
See Also

Reference

ConnectorElement Class


ConnectorElement.Width Property

ConnectorElementWidth Property

The width of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual double Width { get; }
Public Overridable ReadOnly Property Width As Double
    Get
public:
virtual property double Width {
    double get ();
}
abstract Width : float with get
override Width : float with get

Property Value

Double

Implements

IConnectorWidth
Remarks
-1 if the connector is round.
See Also

Reference

ConnectorElement Class


ConnectorElement Methods

The ConnectorElement type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | AssignAsPrimary | Assign a connector as a primary connector.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeHostReference(Reference) | Changes the connector host reference to a new planar face.
Public method | ChangeHostReference(Reference, Edge) | Changes the connector host reference to a new planar face and a new edge loop.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | CreateCableTrayConnector(Document, Reference) | Create a new cable tray ConnectorElement.
 | CreateCableTrayConnector(Document, Reference, Edge) | Create a new cable tray ConnectorElement.
 | CreateConduitConnector(Document, Reference) | Create a new conduit ConnectorElement.
 | CreateConduitConnector(Document, Reference, Edge) | Create a new conduit ConnectorElement.
 | CreateDuctConnector(Document, DuctSystemType, ConnectorProfileType, Reference) | Create a new duct ConnectorElement.
 | CreateDuctConnector(Document, DuctSystemType, ConnectorProfileType, Reference, Edge) | Create a new duct ConnectorElement.
 | CreateElectricalConnector(Document, ElectricalSystemType, Reference) | Create a new electrical ConnectorElement.
 | CreateElectricalConnector(Document, ElectricalSystemType, Reference, Edge) | Create a new electrical ConnectorElement.
 | CreatePipeConnector(Document, PipeSystemType, Reference) | Create a new pipe ConnectorElement.
 | CreatePipeConnector(Document, PipeSystemType, Reference, Edge) | Create a new pipe ConnectorElement with a face and an edge.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FlipDirection | Reverses the direction of the connector element.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLinkedConnectorElement | Get the linked connector element.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSystemClassificationValid | Checks that the MEPSystemType is valid for the domain of connector.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetLinkedConnectorElement | Set the linked connector element.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ConnectorElement Class


ConnectorElement.AssignAsPrimary Method

ConnectorElementAssignAsPrimary Method

Assign a connector as a primary connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AssignAsPrimary()
Public Sub AssignAsPrimary
public:
void AssignAsPrimary()
member AssignAsPrimary : unit -> unit
Exceptions
Exception | Condition
InvalidOperationException | Thrown when fail to assign this connector as primary.
Remarks
This method is used to promote this connector as primary, and the rest of connectors in this system will be assigned as secondary.
See Also

Reference

ConnectorElement Class


ConnectorElement.ChangeHostReference Method

ConnectorElementChangeHostReference Method

Overload List
 | Name | Description
Public method | ChangeHostReference(Reference) | Changes the connector host reference to a new planar face.
Public method | ChangeHostReference(Reference, Edge) | Changes the connector host reference to a new planar face and a new edge loop.
Top
See Also

Reference

ConnectorElement Class


ConnectorElement.ChangeHostReference(Reference) Method

ConnectorElementChangeHostReference(Reference) Method

Changes the connector host reference to a new planar face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ChangeHostReference(
    Reference planarFace
)
Public Sub ChangeHostReference (
    planarFace As Reference
)
public:
void ChangeHostReference(
    Reference^ planarFace
)
member ChangeHostReference :
        planarFace : Reference -> unit

Parameters

planarFace Reference
The planar face to place the connector on.
Exceptions
Exception | Condition
ArgumentException | The face is not a planar face.
ArgumentNullException | A non-optional argument was null
Remarks
The connector referenced by a planar face alone is placed at the plane origin, and may be moved later along the planar face.
See Also

Reference

ConnectorElement Class
ChangeHostReference Overload


ConnectorElement.ChangeHostReference(Reference, Edge) Method

ConnectorElementChangeHostReference(Reference, Edge) Method

Changes the connector host reference to a new planar face and a new edge loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ChangeHostReference(
    Reference planarFace,
    Edge edge
)
Public Sub ChangeHostReference (
    planarFace As Reference,
    edge As Edge
)
public:
void ChangeHostReference(
    Reference^ planarFace,
    Edge^ edge
)
member ChangeHostReference :
        planarFace : Reference *
        edge : Edge -> unit

Parameters

planarFace Reference
The planar face to place the connector on.
edge Edge
One of the edges in the edge loop that defines the new connector location on the planar face.
Exceptions
Exception | Condition
ArgumentException | The face is not a planar face. -or- The edge is not on the planar face.
ArgumentNullException | A non-optional argument was null
Remarks
The connector referenced by an edge loop has the fixed origin as defined by the edge loop.
See Also

Reference

ConnectorElement Class
ChangeHostReference Overload


ConnectorElement.CreateCableTrayConnector Method

ConnectorElementCreateCableTrayConnector Method

Overload List
Name | Description
CreateCableTrayConnector(Document, Reference) | Create a new cable tray ConnectorElement.
CreateCableTrayConnector(Document, Reference, Edge) | Create a new cable tray ConnectorElement.
Top
See Also

Reference

ConnectorElement Class


ConnectorElement.CreateCableTrayConnector(Document, Reference) Method

ConnectorElementCreateCableTrayConnector(Document, Reference) Method

Create a new cable tray ConnectorElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ConnectorElement CreateCableTrayConnector(
    Document document,
    Reference planarFace
)
Public Shared Function CreateCableTrayConnector (
    document As Document,
    planarFace As Reference
) As ConnectorElement
public:
static ConnectorElement^ CreateCableTrayConnector(
    Document^ document,
    Reference^ planarFace
)
static member CreateCableTrayConnector :
        document : Document *
        planarFace : Reference -> ConnectorElement

Parameters

document Document
The document to add the connector to.
planarFace Reference
The planar face to place the connector on.

Return Value

ConnectorElement
The cable tray ConnectorElement.
Exceptions
Exception | Condition
ArgumentException | The reference is not a planar face. -or- document is not a family document.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Connector creation is not allowed in this family.
Remarks
Regenerates the document.
See Also

Reference

ConnectorElement Class
CreateCableTrayConnector Overload


ConnectorElement.CreateCableTrayConnector(Document, Reference, Edge) Method

ConnectorElementCreateCableTrayConnector(Document, Reference, Edge) Method

Create a new cable tray ConnectorElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ConnectorElement CreateCableTrayConnector(
    Document document,
    Reference planarFace,
    Edge edge
)
Public Shared Function CreateCableTrayConnector (
    document As Document,
    planarFace As Reference,
    edge As Edge
) As ConnectorElement
public:
static ConnectorElement^ CreateCableTrayConnector(
    Document^ document,
    Reference^ planarFace,
    Edge^ edge
)
static member CreateCableTrayConnector :
        document : Document *
        planarFace : Reference *
        edge : Edge -> ConnectorElement

Parameters

document Document
The document to add the connector to.
planarFace Reference
The planar face to place the connector on.
edge Edge
One of the edges in the edge loop that defines the connector location on the planar face.

Return Value

ConnectorElement
The cable tray ConnectorElement.
Exceptions
Exception | Condition
ArgumentException | The reference is not a planar face. -or- document is not a family document. -or- Thrown when the edge does not belong to the face.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Connector creation is not allowed in this family.
Remarks
Regenerates the document.
See Also

Reference

ConnectorElement Class
CreateCableTrayConnector Overload


ConnectorElement.CreateConduitConnector Method

ConnectorElementCreateConduitConnector Method

Overload List
Name | Description
CreateConduitConnector(Document, Reference) | Create a new conduit ConnectorElement.
CreateConduitConnector(Document, Reference, Edge) | Create a new conduit ConnectorElement.
Top
See Also

Reference

ConnectorElement Class


ConnectorElement.CreateConduitConnector(Document, Reference) Method

ConnectorElementCreateConduitConnector(Document, Reference) Method

Create a new conduit ConnectorElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ConnectorElement CreateConduitConnector(
    Document document,
    Reference planarFace
)
Public Shared Function CreateConduitConnector (
    document As Document,
    planarFace As Reference
) As ConnectorElement
public:
static ConnectorElement^ CreateConduitConnector(
    Document^ document,
    Reference^ planarFace
)
static member CreateConduitConnector :
        document : Document *
        planarFace : Reference -> ConnectorElement

Parameters

document Document
The document to add the connector to.
planarFace Reference
The planar face to place the connector on.

Return Value

ConnectorElement
The conduit ConnectorElement.
Exceptions
Exception | Condition
ArgumentException | The reference is not a planar face. -or- document is not a family document.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Connector creation is not allowed in this family.
Remarks
Regenerates the document.
See Also

Reference

ConnectorElement Class
CreateConduitConnector Overload


ConnectorElement.CreateConduitConnector(Document, Reference, Edge) Method

ConnectorElementCreateConduitConnector(Document, Reference, Edge) Method

Create a new conduit ConnectorElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ConnectorElement CreateConduitConnector(
    Document document,
    Reference planarFace,
    Edge edge
)
Public Shared Function CreateConduitConnector (
    document As Document,
    planarFace As Reference,
    edge As Edge
) As ConnectorElement
public:
static ConnectorElement^ CreateConduitConnector(
    Document^ document,
    Reference^ planarFace,
    Edge^ edge
)
static member CreateConduitConnector :
        document : Document *
        planarFace : Reference *
        edge : Edge -> ConnectorElement

Parameters

document Document
The document to add the connector to.
planarFace Reference
The planar face to place the connector on.
edge Edge
One of the edges in the edge loop that defines the connector location on the planar face.

Return Value

ConnectorElement
The conduit ConnectorElement.
Exceptions
Exception | Condition
ArgumentException | The reference is not a planar face. -or- document is not a family document. -or- Thrown when the edge does not belong to the face.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Connector creation is not allowed in this family.
Remarks
Regenerates the document.
See Also

Reference

ConnectorElement Class
CreateConduitConnector Overload


ConnectorElement.CreateDuctConnector Method

ConnectorElementCreateDuctConnector Method

Overload List
Name | Description
CreateDuctConnector(Document, DuctSystemType, ConnectorProfileType, Reference) | Create a new duct ConnectorElement.
CreateDuctConnector(Document, DuctSystemType, ConnectorProfileType, Reference, Edge) | Create a new duct ConnectorElement.
Top
See Also

Reference

ConnectorElement Class


ConnectorElement.CreateDuctConnector(Document, DuctSystemType, ConnectorProfileType, Reference) Method

ConnectorElementCreateDuctConnector(Document, DuctSystemType, ConnectorProfileType, Reference) Method

Create a new duct ConnectorElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ConnectorElement CreateDuctConnector(
    Document document,
    DuctSystemType ductSystemType,
    ConnectorProfileType profileShape,
    Reference planarFace
)
Public Shared Function CreateDuctConnector (
    document As Document,
    ductSystemType As DuctSystemType,
    profileShape As ConnectorProfileType,
    planarFace As Reference
) As ConnectorElement
public:
static ConnectorElement^ CreateDuctConnector(
    Document^ document,
    DuctSystemType ductSystemType,
    ConnectorProfileType profileShape,
    Reference^ planarFace
)
static member CreateDuctConnector :
        document : Document *
        ductSystemType : DuctSystemType *
        profileShape : ConnectorProfileType *
        planarFace : Reference -> ConnectorElement

Parameters

document Document
The document to add the connector to.
ductSystemType DuctSystemType
The DuctSystemType of the connector.
profileShape ConnectorProfileType
The profile shape of the duct.
planarFace Reference
The planar face to place the connector on.

Return Value

ConnectorElement
The duct ConnectorElement.
Exceptions
Exception | Condition
ArgumentException | The reference is not a planar face. -or- document is not a family document.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | Connector creation is not allowed in this family.
Remarks
Regenerates the document.
See Also

Reference

ConnectorElement Class
CreateDuctConnector Overload


ConnectorElement.CreateDuctConnector(Document, DuctSystemType, ConnectorProfileType, Reference, Edge) Method

ConnectorElementCreateDuctConnector(Document, DuctSystemType, ConnectorProfileType, Reference, Edge) Method

Create a new duct ConnectorElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ConnectorElement CreateDuctConnector(
    Document document,
    DuctSystemType ductSystemType,
    ConnectorProfileType profileShape,
    Reference planarFace,
    Edge edge
)
Public Shared Function CreateDuctConnector (
    document As Document,
    ductSystemType As DuctSystemType,
    profileShape As ConnectorProfileType,
    planarFace As Reference,
    edge As Edge
) As ConnectorElement
public:
static ConnectorElement^ CreateDuctConnector(
    Document^ document,
    DuctSystemType ductSystemType,
    ConnectorProfileType profileShape,
    Reference^ planarFace,
    Edge^ edge
)
static member CreateDuctConnector :
        document : Document *
        ductSystemType : DuctSystemType *
        profileShape : ConnectorProfileType *
        planarFace : Reference *
        edge : Edge -> ConnectorElement

Parameters

document Document
The document to add the connector to.
ductSystemType DuctSystemType
The DuctSystemType of the connector.
profileShape ConnectorProfileType
The profile shape of the duct.
planarFace Reference
The planar face to place the connector on.
edge Edge
One of the edges in the edge loop that defines the connector location on the planar face.

Return Value

ConnectorElement
The duct ConnectorElement.
Exceptions
Exception | Condition
ArgumentException | The reference is not a planar face. -or- document is not a family document. -or- Thrown when the edge does not belong to the face.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | Connector creation is not allowed in this family.
Remarks
Regenerates the document.
See Also

Reference

ConnectorElement Class
CreateDuctConnector Overload


ConnectorElement.CreateElectricalConnector Method

ConnectorElementCreateElectricalConnector Method

Overload List
Name | Description
CreateElectricalConnector(Document, ElectricalSystemType, Reference) | Create a new electrical ConnectorElement.
CreateElectricalConnector(Document, ElectricalSystemType, Reference, Edge) | Create a new electrical ConnectorElement.
Top
See Also

Reference

ConnectorElement Class


ConnectorElement.CreateElectricalConnector(Document, ElectricalSystemType, Reference) Method

ConnectorElementCreateElectricalConnector(Document, ElectricalSystemType, Reference) Method

Create a new electrical ConnectorElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ConnectorElement CreateElectricalConnector(
    Document document,
    ElectricalSystemType electricalSystemType,
    Reference planarFace
)
Public Shared Function CreateElectricalConnector (
    document As Document,
    electricalSystemType As ElectricalSystemType,
    planarFace As Reference
) As ConnectorElement
public:
static ConnectorElement^ CreateElectricalConnector(
    Document^ document,
    ElectricalSystemType electricalSystemType,
    Reference^ planarFace
)
static member CreateElectricalConnector :
        document : Document *
        electricalSystemType : ElectricalSystemType *
        planarFace : Reference -> ConnectorElement

Parameters

document Document
The document to add the connector to.
electricalSystemType ElectricalSystemType
The ElectricalSystemTYpe of the connector.
planarFace Reference
The planar face to place the connector on.

Return Value

ConnectorElement
The electrical ConnectorElement.
Exceptions
Exception | Condition
ArgumentException | The reference is not a planar face. -or- document is not a family document.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | Connector creation is not allowed in this family.
Remarks
Regenerates the document.
See Also

Reference

ConnectorElement Class
CreateElectricalConnector Overload


ConnectorElement.CreateElectricalConnector(Document, ElectricalSystemType, Reference, Edge) Method

ConnectorElementCreateElectricalConnector(Document, ElectricalSystemType, Reference, Edge) Method

Create a new electrical ConnectorElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ConnectorElement CreateElectricalConnector(
    Document document,
    ElectricalSystemType electricalSystemType,
    Reference planarFace,
    Edge edge
)
Public Shared Function CreateElectricalConnector (
    document As Document,
    electricalSystemType As ElectricalSystemType,
    planarFace As Reference,
    edge As Edge
) As ConnectorElement
public:
static ConnectorElement^ CreateElectricalConnector(
    Document^ document,
    ElectricalSystemType electricalSystemType,
    Reference^ planarFace,
    Edge^ edge
)
static member CreateElectricalConnector :
        document : Document *
        electricalSystemType : ElectricalSystemType *
        planarFace : Reference *
        edge : Edge -> ConnectorElement

Parameters

document Document
The document to add the connector to.
electricalSystemType ElectricalSystemType
The ElectricalSystemTYpe of the connector.
planarFace Reference
The planar face to place the connector on.
edge Edge
One of the edges in the edge loop that defines the connector location on the planar face.

Return Value

ConnectorElement
The electrical ConnectorElement.
Exceptions
Exception | Condition
ArgumentException | The reference is not a planar face. -or- document is not a family document. -or- Thrown when the edge does not belong to the face.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | Connector creation is not allowed in this family.
Remarks
Regenerates the document.
See Also

Reference

ConnectorElement Class
CreateElectricalConnector Overload


ConnectorElement.CreatePipeConnector Method

ConnectorElementCreatePipeConnector Method

Overload List
Name | Description
CreatePipeConnector(Document, PipeSystemType, Reference) | Create a new pipe ConnectorElement.
CreatePipeConnector(Document, PipeSystemType, Reference, Edge) | Create a new pipe ConnectorElement with a face and an edge.
Top
See Also

Reference

ConnectorElement Class


ConnectorElement.CreatePipeConnector(Document, PipeSystemType, Reference) Method

ConnectorElementCreatePipeConnector(Document, PipeSystemType, Reference) Method

Create a new pipe ConnectorElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ConnectorElement CreatePipeConnector(
    Document document,
    PipeSystemType pipeSystemType,
    Reference planarFace
)
Public Shared Function CreatePipeConnector (
    document As Document,
    pipeSystemType As PipeSystemType,
    planarFace As Reference
) As ConnectorElement
public:
static ConnectorElement^ CreatePipeConnector(
    Document^ document,
    PipeSystemType pipeSystemType,
    Reference^ planarFace
)
static member CreatePipeConnector :
        document : Document *
        pipeSystemType : PipeSystemType *
        planarFace : Reference -> ConnectorElement

Parameters

document Document
The document to add the connector to.
pipeSystemType PipeSystemType
The PipeSystemType of the connector.
planarFace Reference
The planar face to place the connector on.

Return Value

ConnectorElement
The pipe ConnectorElement.
Exceptions
Exception | Condition
ArgumentException | The reference is not a planar face. -or- document is not a family document.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | Connector creation is not allowed in this family.
Remarks
Regenerates the document.
Example
C#
VB
C++
F#
Copy
public void CreatePipeConnectors(UIDocument uiDocument, Extrusion extrusion)
{
    // get the faces of the extrusion
    Options geoOptions = uiDocument.Document.Application.Create.NewGeometryOptions();
    geoOptions.View = uiDocument.Document.ActiveView;
    geoOptions.ComputeReferences = true;

    List<PlanarFace> planarFaces = new List<PlanarFace>();
    Autodesk.Revit.DB.GeometryElement geoElement = extrusion.get_Geometry(geoOptions);
    foreach (GeometryObject geoObject in geoElement)
    {
        Solid geoSolid = geoObject as Solid;
        if (null != geoSolid)
        {
            foreach (Face geoFace in geoSolid.Faces)
            {
                if (geoFace is PlanarFace)
                {
                    planarFaces.Add(geoFace as PlanarFace);
                }
            }
        }
    }

    if (planarFaces.Count > 1)
    {
        // Create the Supply Hydronic pipe connector
        //PipeConnector connSupply =
        //    uiDocument.Document.FamilyCreate.NewPipeConnector(planarFaces[0].Reference,
        //                                           PipeSystemType.SupplyHydronic);
        ConnectorElement connSupply =
            ConnectorElement.CreatePipeConnector(uiDocument.Document, PipeSystemType.SupplyHydronic, planarFaces[0].Reference);
        Parameter param = connSupply.get_Parameter(BuiltInParameter.CONNECTOR_RADIUS);
        param.Set(1.0); // 1' radius
        param = connSupply.get_Parameter(BuiltInParameter.RBS_PIPE_FLOW_DIRECTION_PARAM);
        param.Set(2);

        // Create the Return Hydronic pipe connector
        //PipeConnector connReturn =
        //    uiDocument.Document.FamilyCreate.NewPipeConnector(planarFaces[1].Reference,
        //                                           PipeSystemType.ReturnHydronic);
        ConnectorElement connReturn =
            ConnectorElement.CreatePipeConnector(uiDocument.Document, PipeSystemType.ReturnHydronic, planarFaces[1].Reference);
        param = connReturn.get_Parameter(BuiltInParameter.CONNECTOR_RADIUS);
        param.Set(0.5); // 6" radius
        param = connReturn.get_Parameter(BuiltInParameter.RBS_PIPE_FLOW_DIRECTION_PARAM);
        param.Set(1);
    }
}
Public Sub CreatePipeConnectors(uiDocument As UIDocument, extrusion As Extrusion)
    ' get the faces of the extrusion
    Dim geoOptions As Options = uiDocument.Document.Application.Create.NewGeometryOptions()
    geoOptions.View = uiDocument.Document.ActiveView
    geoOptions.ComputeReferences = True

    Dim planarFaces As New List(Of PlanarFace)()
    Dim geoElement As Autodesk.Revit.DB.GeometryElement = extrusion.Geometry(geoOptions)
    For Each geoObject As GeometryObject In geoElement
        Dim geoSolid As Solid = TryCast(geoObject, Solid)
        If geoSolid IsNot Nothing Then
            For Each geoFace As Face In geoSolid.Faces
                If TypeOf geoFace Is PlanarFace Then
                    planarFaces.Add(TryCast(geoFace, PlanarFace))
                End If
            Next
        End If
    Next

    If planarFaces.Count > 1 Then
        ' Create the Supply Hydronic pipe connector
        'PipeConnector connSupply =
        '    uiDocument.Document.FamilyCreate.NewPipeConnector(planarFaces[0].Reference,
        '                                           PipeSystemType.SupplyHydronic);
        Dim connSupply As ConnectorElement = ConnectorElement.CreatePipeConnector(uiDocument.Document, PipeSystemType.SupplyHydronic, planarFaces(0).Reference)
        Dim param As Parameter = connSupply.Parameter(BuiltInParameter.CONNECTOR_RADIUS)
        param.[Set](1.0)
        ' 1' radius
        param = connSupply.Parameter(BuiltInParameter.RBS_PIPE_FLOW_DIRECTION_PARAM)
        param.[Set](2)

        ' Create the Return Hydronic pipe connector
        'PipeConnector connReturn =
        '    uiDocument.Document.FamilyCreate.NewPipeConnector(planarFaces[1].Reference,
        '                                           PipeSystemType.ReturnHydronic);
        Dim connReturn As ConnectorElement = ConnectorElement.CreatePipeConnector(uiDocument.Document, PipeSystemType.ReturnHydronic, planarFaces(1).Reference)
        param = connReturn.Parameter(BuiltInParameter.CONNECTOR_RADIUS)
        param.[Set](0.5)
        ' 6" radius
        param = connReturn.Parameter(BuiltInParameter.RBS_PIPE_FLOW_DIRECTION_PARAM)
        param.[Set](1)
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

ConnectorElement Class
CreatePipeConnector Overload


ConnectorElement.CreatePipeConnector(Document, PipeSystemType, Reference, Edge) Method

ConnectorElementCreatePipeConnector(Document, PipeSystemType, Reference, Edge) Method

Create a new pipe ConnectorElement with a face and an edge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ConnectorElement CreatePipeConnector(
    Document document,
    PipeSystemType pipeSystemType,
    Reference planarFace,
    Edge edge
)
Public Shared Function CreatePipeConnector (
    document As Document,
    pipeSystemType As PipeSystemType,
    planarFace As Reference,
    edge As Edge
) As ConnectorElement
public:
static ConnectorElement^ CreatePipeConnector(
    Document^ document,
    PipeSystemType pipeSystemType,
    Reference^ planarFace,
    Edge^ edge
)
static member CreatePipeConnector :
        document : Document *
        pipeSystemType : PipeSystemType *
        planarFace : Reference *
        edge : Edge -> ConnectorElement

Parameters

document Document
The document to add the connector to.
pipeSystemType PipeSystemType
The PipeSystemType of the connector.
planarFace Reference
The planar face to place the connector on.
edge Edge
One of the edges in the edge loop that defines the connector location on the planar face.

Return Value

ConnectorElement
The pipe ConnectorElement.
Exceptions
Exception | Condition
ArgumentException | The reference is not a planar face. -or- document is not a family document. -or- Thrown when the edge does not belong to the face.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | Connector creation is not allowed in this family.
Remarks
Regenerates the document.
See Also

Reference

ConnectorElement Class
CreatePipeConnector Overload


ConnectorElement.FlipDirection Method

ConnectorElementFlipDirection Method

Reverses the direction of the connector element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void FlipDirection()
Public Sub FlipDirection
public:
void FlipDirection()
member FlipDirection : unit -> unit
See Also

Reference

ConnectorElement Class


ConnectorElement.GetLinkedConnectorElement Method

ConnectorElementGetLinkedConnectorElement Method

Get the linked connector element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConnectorElement GetLinkedConnectorElement()
Public Function GetLinkedConnectorElement As ConnectorElement
public:
ConnectorElement^ GetLinkedConnectorElement()
member GetLinkedConnectorElement : unit -> ConnectorElement

Return Value

ConnectorElement
The linked connector element. If , the connector has no link.
See Also

Reference

ConnectorElement Class


ConnectorElement.IsSystemClassificationValid Method

ConnectorElementIsSystemClassificationValid Method

Checks that the MEPSystemType is valid for the domain of connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSystemClassificationValid(
    MEPSystemClassification systemClassification
)
Public Function IsSystemClassificationValid (
    systemClassification As MEPSystemClassification
) As Boolean
public:
bool IsSystemClassificationValid(
    MEPSystemClassification systemClassification
)
member IsSystemClassificationValid :
        systemClassification : MEPSystemClassification -> bool

Parameters

systemClassification MEPSystemClassification
The MEPSystemType to be validated.

Return Value

Boolean
True if the MEPSystemType is valid for the domain of the connector, false otherwise.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ConnectorElement Class


ConnectorElement.SetLinkedConnectorElement Method

ConnectorElementSetLinkedConnectorElement Method

Set the linked connector element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetLinkedConnectorElement(
    ConnectorElement otherConnector
)
Public Sub SetLinkedConnectorElement (
    otherConnector As ConnectorElement
)
public:
void SetLinkedConnectorElement(
    ConnectorElement^ otherConnector
)
member SetLinkedConnectorElement :
        otherConnector : ConnectorElement -> unit

Parameters

otherConnector ConnectorElement
The connector to link to.
Exceptions
Exception | Condition
ArgumentException | The connector being linked to is a different domain than that of the calling connector. -or- The connector being linked to is the same as the calling connector.
InvalidOperationException | This connector type does not support linked connectors.
Remarks
Set the linked connector to to remove the link.
See Also

Reference

ConnectorElement Class


ConnectorGenderType Enumeration

Connector gender type enum

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConnectorGenderType
Public Enumeration ConnectorGenderType
public enum class ConnectorGenderType
type ConnectorGenderType
Members
Member name | Value | Description
Undefined | 0 | Undefined connector gender type
Male | 1 | Male connector gender type
Female | 2 | Female connector gender type
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ConnectorJointType Enumeration

Connector joint type enum

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConnectorJointType
Public Enumeration ConnectorJointType
public enum class ConnectorJointType
type ConnectorJointType
Members
Member name | Value | Description
Undefined | 0 | Undefined connector joint type
Flanged | 1 | Flanged connector joint type
Welded | 2 | Welded connector joint type
Threaded | 3 | Threaded connector joint type
Grooved | 4 | Grooved connector joint type
Glued | 5 | Glued connector joint type
Soldered | 6 | Soldered connector joint type
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ConnectorManager Class

Provides access to the Connector Manager
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBConnectorManager

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ConnectorManager : IDisposable
Public Class ConnectorManager
    Implements IDisposable
public ref class ConnectorManager : IDisposable
type ConnectorManager =
    class
        interface IDisposable
    end

The ConnectorManager type exposes the following members.

Properties
 | Name | Description
Public property | Connectors | Return all the Connectors of the Connector Manager.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Owner | This property is used to retrieve the owner of the Connector Manager.
Public property | UnusedConnectors | Return all the unused Connectors of the Connector Manager.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ConnectorManager
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Lookup | Lookup the connector using the unique index value that identify this connector.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ConnectorManager Properties

The ConnectorManager type exposes the following members.

Properties
 | Name | Description
Public property | Connectors | Return all the Connectors of the Connector Manager.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Owner | This property is used to retrieve the owner of the Connector Manager.
Public property | UnusedConnectors | Return all the unused Connectors of the Connector Manager.
Top
See Also

Reference

ConnectorManager Class


ConnectorManager.Connectors Property

ConnectorManagerConnectors Property

Return all the Connectors of the Connector Manager.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConnectorSet Connectors { get; }
Public ReadOnly Property Connectors As ConnectorSet
    Get
public:
property ConnectorSet^ Connectors {
    ConnectorSet^ get ();
}
member Connectors : ConnectorSet with get

Property Value

ConnectorSet
Remarks
This property is used to retrieve the Connectors from the Connector Manager.
See Also

Reference

ConnectorManager Class


ConnectorManager.IsValidObject Property

ConnectorManagerIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ConnectorManager Class


ConnectorManager.Owner Property

ConnectorManagerOwner Property

This property is used to retrieve the owner of the Connector Manager.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Element Owner { get; }
Public ReadOnly Property Owner As Element
    Get
public:
property Element^ Owner {
    Element^ get ();
}
member Owner : Element with get

Property Value

Element
See Also

Reference

ConnectorManager Class


ConnectorManager.UnusedConnectors Property

ConnectorManagerUnusedConnectors Property

Return all the unused Connectors of the Connector Manager.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConnectorSet UnusedConnectors { get; }
Public ReadOnly Property UnusedConnectors As ConnectorSet
    Get
public:
property ConnectorSet^ UnusedConnectors {
    ConnectorSet^ get ();
}
member UnusedConnectors : ConnectorSet with get

Property Value

ConnectorSet
Remarks
This property is used to retrieve the unused Connectors from the Connector Manager.
See Also

Reference

ConnectorManager Class


ConnectorManager Methods

The ConnectorManager type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Lookup | Lookup the connector using the unique index value that identify this connector.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ConnectorManager Class


ConnectorManager.Dispose Method

ConnectorManagerDispose Method

Releases all resources used by the ConnectorManager

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ConnectorManager Class


ConnectorManager.Lookup Method

ConnectorManagerLookup Method

Lookup the connector using the unique index value that identify this connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Connector Lookup(
    int index
)
Public Function Lookup (
    index As Integer
) As Connector
public:
Connector^ Lookup(
    int index
)
member Lookup :
        index : int -> Connector

Parameters

index Int32
The unique index value.

Return Value

Connector
Returns the connector or null if a connector for the provided unique index value doesn't exist.
See Also

Reference

ConnectorManager Class


ConnectorProfileType Enumeration

An enumerated type listing all connector profile types

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConnectorProfileType
Public Enumeration ConnectorProfileType
public enum class ConnectorProfileType
type ConnectorProfileType
Members
Member name | Value | Description
Round | 0 | Round connector profile
Rectangular | 1 | Rectangular connector profile
Oval | 2 | Oval connector profile
Invalid | -1 | Invalid connector profile
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ConnectorSet Class

A set that can contain any type of object.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBConnectorSet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ConnectorSet : APIObject,
    IEnumerable
Public Class ConnectorSet
    Inherits APIObject
    Implements IEnumerable
public ref class ConnectorSet : public APIObject,
    IEnumerable
type ConnectorSet =
    class
        inherit APIObject
        interface IEnumerable
    end

The ConnectorSet type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectorSet | Initializes a new instance of the ConnectorSet class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Size | Returns the number of objects that are in the set.
Top
Methods
 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ConnectorSet Constructor

Initializes a new instance of the ConnectorSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConnectorSet()
Public Sub New
public:
ConnectorSet()
new : unit -> ConnectorSet
See Also

Reference

ConnectorSet Class


ConnectorSet Properties

The ConnectorSet type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Size | Returns the number of objects that are in the set.
Top
See Also

Reference

ConnectorSet Class


ConnectorSet.IsEmpty Property

ConnectorSetIsEmpty Property

Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Boolean
Remarks
If the set is empty then True will be returned, otherwise False.
See Also

Reference

ConnectorSet Class


ConnectorSet.Size Property

ConnectorSetSize Property

Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
abstract Size : int with get
override Size : int with get

Property Value

Int32
See Also

Reference

ConnectorSet Class


ConnectorSet Methods

The ConnectorSet type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ConnectorSet Class


ConnectorSet.Clear Method

ConnectorSetClear Method

Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

ConnectorSet Class


ConnectorSet.Contains Method

ConnectorSetContains Method

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Contains(
    Connector item
)
Public Overridable Function Contains (
    item As Connector
) As Boolean
public:
virtual bool Contains(
    Connector^ item
)
abstract Contains :
        item : Connector -> bool
override Contains :
        item : Connector -> bool

Parameters

item Connector

Return Value

Boolean
See Also

Reference

ConnectorSet Class


ConnectorSet.Erase Method

ConnectorSetErase Method

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Erase(
    Connector item
)
Public Overridable Function Erase (
    item As Connector
) As Integer
public:
virtual int Erase(
    Connector^ item
)
abstract Erase :
        item : Connector -> int
override Erase :
        item : Connector -> int

Parameters

item Connector

Return Value

Int32
See Also

Reference

ConnectorSet Class


ConnectorSet.ForwardIterator Method

ConnectorSetForwardIterator Method

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ConnectorSetIterator ForwardIterator()
Public Overridable Function ForwardIterator As ConnectorSetIterator
public:
virtual ConnectorSetIterator^ ForwardIterator()
abstract ForwardIterator : unit -> ConnectorSetIterator
override ForwardIterator : unit -> ConnectorSetIterator

Return Value

ConnectorSetIterator
Returns a forward moving iterator to the set.
See Also

Reference

ConnectorSet Class


ConnectorSet.GetEnumerator Method

ConnectorSetGetEnumerator Method

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

IEnumerator
Returns a forward moving iterator to the set.

Implements

IEnumerableGetEnumerator
See Also

Reference

ConnectorSet Class


ConnectorSet.Insert Method

ConnectorSetInsert Method

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Insert(
    Connector item
)
Public Overridable Function Insert (
    item As Connector
) As Boolean
public:
virtual bool Insert(
    Connector^ item
)
abstract Insert :
        item : Connector -> bool
override Insert :
        item : Connector -> bool

Parameters

item Connector

Return Value

Boolean
See Also

Reference

ConnectorSet Class


ConnectorSet.ReverseIterator Method

ConnectorSetReverseIterator Method

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ConnectorSetIterator ReverseIterator()
Public Overridable Function ReverseIterator As ConnectorSetIterator
public:
virtual ConnectorSetIterator^ ReverseIterator()
abstract ReverseIterator : unit -> ConnectorSetIterator
override ReverseIterator : unit -> ConnectorSetIterator

Return Value

ConnectorSetIterator
Returns a backward moving iterator to the set.
See Also

Reference

ConnectorSet Class


ConnectorSetIterator Class

An iterator to a set.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBConnectorSetIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class ConnectorSetIterator : APIObject,
    IEnumerator
Public MustInherit Class ConnectorSetIterator
    Inherits APIObject
    Implements IEnumerator
public ref class ConnectorSetIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type ConnectorSetIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The ConnectorSetIterator type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectorSetIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ConnectorSetIterator Constructor

For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConnectorSetIterator()
Public Sub New
public:
ConnectorSetIterator()
new : unit -> ConnectorSetIterator
Remarks
This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.
See Also

Reference

ConnectorSetIterator Class


ConnectorSetIterator Properties

The ConnectorSetIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

ConnectorSetIterator Class


ConnectorSetIterator.Current Property

ConnectorSetIteratorCurrent Property

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}
abstract Current : Object with get
override Current : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.
See Also

Reference

ConnectorSetIterator Class


ConnectorSetIterator Methods

The ConnectorSetIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ConnectorSetIterator Class


ConnectorSetIterator.MoveNext Method

ConnectorSetIteratorMoveNext Method

Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumeratorMoveNext
Remarks
MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.
See Also

Reference

ConnectorSetIterator Class


ConnectorSetIterator.Reset Method

ConnectorSetIteratorReset Method

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
Remarks
The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.
See Also

Reference

ConnectorSetIterator Class


ConnectorType Enumeration

An enumerated type listing all connector types for a connection

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConnectorType
Public Enumeration ConnectorType
public enum class ConnectorType
type ConnectorType
Members
Member name | Value | Description
Invalid | 0 | Invalid connection type
End | 1 | End connection type
Curve | 2 | Curve connection type
Logical | 4 | Logical connection type
Reference | 8 | Reference connection type
Surface | 16 | Surface connection type
EndSurface | 17 | End or Surface connection type
Physical | 19 | Physical connection type
NonEnd | 30 | Not end connection type
MasterSurface | 32 | This value is deprecated and will be removed in a future version of Revit. Please use MainSurface instead.
MainSurface | 32 | Main surface connection type
Family | 49 | Family connection type
NodeReference | 64 | Reference to the layout node type
BlankEnd | 128 | Blank End type
AnyEnd | 129 | Any end connection type
Super | 256 | Connection between a sub-system and a super-system, such as a connection between supply and return sub-systems and a main hydronic piping system or an air system.
AllModes | 16,777,215 | All connection modes
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Construction Class

Construction definition for Project Information.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBConstruction

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Construction
Public Class Construction
public ref class Construction
type Construction = class end

The Construction type exposes the following members.

Properties
 | Name | Description
Public property | Id | Get the id of the Construction.
Public property | Name | Get the name of the Construction.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This is used to define the information in Constructions.xml.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Construction Properties

The Construction type exposes the following members.

Properties
 | Name | Description
Public property | Id | Get the id of the Construction.
Public property | Name | Get the name of the Construction.
Top
See Also

Reference

Construction Class


Construction.Id Property

ConstructionId Property

Get the id of the Construction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Id { get; }
Public ReadOnly Property Id As String
    Get
public:
property String^ Id {
    String^ get ();
}
member Id : string with get

Property Value

String
Remarks
This property is used to get the id of the Construction.
See Also

Reference

Construction Class


Construction.Name Property

ConstructionName Property

Get the name of the Construction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

String
Remarks
This property is used to get the name of the Construction.
See Also

Reference

Construction Class


Construction Methods

The Construction type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Construction Class


ContentNode Class

This class represents a generic content node in a model-exporting process.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRenderNode
Autodesk.Revit.DBContentNode
Autodesk.Revit.DBLightNode
Autodesk.Revit.DBRPCNode

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ContentNode : RenderNode
Public Class ContentNode
    Inherits RenderNode
public ref class ContentNode : public RenderNode
type ContentNode =
    class
        inherit RenderNode
    end

The ContentNode type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode)
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from RenderNode)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAsset | Returns an an instance of an Asset object, which contains definitions of the content node.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetTransform | A transformation matrix associated with the node.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Members of this class implement properties and methods common to all content classes, such as RPC and Light nodes. Attributes of a content note can be accessed via an Asset object.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ContentNode Properties

The ContentNode type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode)
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode)
Top
See Also

Reference

ContentNode Class


ContentNode Methods

The ContentNode type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from RenderNode)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAsset | Returns an an instance of an Asset object, which contains definitions of the content node.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetTransform | A transformation matrix associated with the node.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ContentNode Class


ContentNode.GetAsset Method

ContentNodeGetAsset Method

Returns an an instance of an Asset object, which contains definitions of the content node.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Asset GetAsset()
Public Function GetAsset As Asset
public:
Asset^ GetAsset()
member GetAsset : unit -> Asset

Return Value

Asset
Remarks
Properties and attributes of the node can be accessed using the standard interface of the Asset class.
See Also

Reference

ContentNode Class


ContentNode.GetTransform Method

ContentNodeGetTransform Method

A transformation matrix associated with the node.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Transform GetTransform()
Public Function GetTransform As Transform
public:
Transform^ GetTransform()
member GetTransform : unit -> Transform

Return Value

Transform
See Also

Reference

ContentNode Class


ContourSetting Class

Contour setting object that handles the contour information used to draw contours on elements.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBContourSetting

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ContourSetting : IDisposable
Public Class ContourSetting
    Implements IDisposable
public ref class ContourSetting : IDisposable
type ContourSetting =
    class
        interface IDisposable
    end

The ContourSetting type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | AddContourRange | Add a set of contours as a contour setting item to the current contour setting.
Public method | AddSingleContour | Add a single contour as a contour setting item to the current contour setting.
Public method | DisableItem | Disable a contour setting item of the current contour setting so that the item will not be used to draw contours.
Public method | Dispose | Releases all resources used by the ContourSetting
Public method | EnableItem | Enable a contour setting item of the current contour setting so that the item will be used to draw contours.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetContourSettingItems | Get all contour setting items.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetItemIndex | Get the index of a contour setting item of the current contour setting
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsItemEnabled | Check if a ContourSettingItem is enabled
Public method | RemoveItem | Remove a contour setting item from the current contour setting.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ContourSetting Properties

The ContourSetting type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

ContourSetting Class


ContourSetting.IsValidObject Property

ContourSettingIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ContourSetting Class


ContourSetting Methods

The ContourSetting type exposes the following members.

Methods
 | Name | Description
Public method | AddContourRange | Add a set of contours as a contour setting item to the current contour setting.
Public method | AddSingleContour | Add a single contour as a contour setting item to the current contour setting.
Public method | DisableItem | Disable a contour setting item of the current contour setting so that the item will not be used to draw contours.
Public method | Dispose |
Public method | EnableItem | Enable a contour setting item of the current contour setting so that the item will be used to draw contours.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetContourSettingItems | Get all contour setting items.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetItemIndex | Get the index of a contour setting item of the current contour setting
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsItemEnabled | Check if a ContourSettingItem is enabled
Public method | RemoveItem | Remove a contour setting item from the current contour setting.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ContourSetting Class


ContourSetting.AddContourRange Method

ContourSettingAddContourRange Method

Add a set of contours as a contour setting item to the current contour setting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ContourSettingItem AddContourRange(
    double start,
    double stop,
    double step,
    ElementId subcategoryId
)
Public Function AddContourRange (
    start As Double,
    stop As Double,
    step As Double,
    subcategoryId As ElementId
) As ContourSettingItem
public:
ContourSettingItem^ AddContourRange(
    double start,
    double stop,
    double step,
    ElementId^ subcategoryId
)
member AddContourRange :
        start : float *
        stop : float *
        step : float *
        subcategoryId : ElementId -> ContourSettingItem

Parameters

start Double
The contour range start elevation.
stop Double
The contour range stop elevation. Should be greater than start elevation.
step Double
The increment elevation of the contour range. Should be greater than zero.
subcategoryId ElementId
The contour line style subcategory id.

Return Value

ContourSettingItem
The newly added contour setting item.
Exceptions
Exception | Condition
ArgumentException | The given value for start is not finite -or- The given value for stop is not finite -or- The given value for step is not finite -or- The input subcategory id is not valid.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The input contour spacing information is not valid.
See Also

Reference

ContourSetting Class


ContourSetting.AddSingleContour Method

ContourSettingAddSingleContour Method

Add a single contour as a contour setting item to the current contour setting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ContourSettingItem AddSingleContour(
    double elevation,
    ElementId subcategoryId
)
Public Function AddSingleContour (
    elevation As Double,
    subcategoryId As ElementId
) As ContourSettingItem
public:
ContourSettingItem^ AddSingleContour(
    double elevation,
    ElementId^ subcategoryId
)
member AddSingleContour :
        elevation : float *
        subcategoryId : ElementId -> ContourSettingItem

Parameters

elevation Double
The contour elevation.
subcategoryId ElementId
The contour line style subcategory id.

Return Value

ContourSettingItem
The newly added contour setting item.
Exceptions
Exception | Condition
ArgumentException | The given value for elevation is not finite
ArgumentNullException | A non-optional argument was null
See Also

Reference

ContourSetting Class


ContourSetting.DisableItem Method

ContourSettingDisableItem Method

Disable a contour setting item of the current contour setting so that the item will not be used to draw contours.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void DisableItem(
    ContourSettingItem item
)
Public Sub DisableItem (
    item As ContourSettingItem
)
public:
void DisableItem(
    ContourSettingItem^ item
)
member DisableItem :
        item : ContourSettingItem -> unit

Parameters

item ContourSettingItem
The contour setting item to be disabled.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Contour setting will not be changed if the item could not be found.
See Also

Reference

ContourSetting Class


ContourSetting.Dispose Method

ContourSettingDispose Method

Releases all resources used by the ContourSetting

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ContourSetting Class


ContourSetting.EnableItem Method

ContourSettingEnableItem Method

Enable a contour setting item of the current contour setting so that the item will be used to draw contours.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void EnableItem(
    ContourSettingItem item
)
Public Sub EnableItem (
    item As ContourSettingItem
)
public:
void EnableItem(
    ContourSettingItem^ item
)
member EnableItem :
        item : ContourSettingItem -> unit

Parameters

item ContourSettingItem
The contour setting item to be enabled.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Contour setting will not be changed if the item could not be found.
See Also

Reference

ContourSetting Class


ContourSetting.GetContourSettingItems Method

ContourSettingGetContourSettingItems Method

Get all contour setting items.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ContourSettingItem> GetContourSettingItems()
Public Function GetContourSettingItems As IList(Of ContourSettingItem)
public:
IList<ContourSettingItem^>^ GetContourSettingItems()
member GetContourSettingItems : unit -> IList<ContourSettingItem>

Return Value

IList ContourSettingItem
An array of contour setting items.
See Also

Reference

ContourSetting Class


ContourSetting.GetItemIndex Method

ContourSettingGetItemIndex Method

Get the index of a contour setting item of the current contour setting

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetItemIndex(
    ContourSettingItem item
)
Public Function GetItemIndex (
    item As ContourSettingItem
) As Integer
public:
int GetItemIndex(
    ContourSettingItem^ item
)
member GetItemIndex :
        item : ContourSettingItem -> int

Parameters

item ContourSettingItem
The contour setting item.

Return Value

Int32
The index of the input contour setting item. -1 if the item is not found.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ContourSetting Class


ContourSetting.IsItemEnabled Method

ContourSettingIsItemEnabled Method

Check if a ContourSettingItem is enabled

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsItemEnabled(
    ContourSettingItem item
)
Public Function IsItemEnabled (
    item As ContourSettingItem
) As Boolean
public:
bool IsItemEnabled(
    ContourSettingItem^ item
)
member IsItemEnabled :
        item : ContourSettingItem -> bool

Parameters

item ContourSettingItem
The contour setting item.

Return Value

Boolean
True if the item is enabled, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ContourSetting Class


ContourSetting.RemoveItem Method

ContourSettingRemoveItem Method

Remove a contour setting item from the current contour setting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveItem(
    ContourSettingItem item
)
Public Sub RemoveItem (
    item As ContourSettingItem
)
public:
void RemoveItem(
    ContourSettingItem^ item
)
member RemoveItem :
        item : ContourSettingItem -> unit

Parameters

item ContourSettingItem
The contour setting item to be removed.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Contour setting will not be changed if the item could not be found.
See Also

Reference

ContourSetting Class


ContourSettingItem Class

Contour setting item that stores the information of a single contour or a set of contours.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBContourSettingItem

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ContourSettingItem : IDisposable
Public Class ContourSettingItem
    Implements IDisposable
public ref class ContourSettingItem : IDisposable
type ContourSettingItem =
    class
        interface IDisposable
    end

The ContourSettingItem type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Start | The contour range start elevation.
Public property | Step | The increment elevation of the contour range.
Public property | Stop | The contour range stop elevation.
Public property | SubCategoryId | The contour line style subcategory id.
Public property | Type | The contour setting item type.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ContourSettingItem
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ContourSettingItem Properties

The ContourSettingItem type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Start | The contour range start elevation.
Public property | Step | The increment elevation of the contour range.
Public property | Stop | The contour range stop elevation.
Public property | SubCategoryId | The contour line style subcategory id.
Public property | Type | The contour setting item type.
Top
See Also

Reference

ContourSettingItem Class


ContourSettingItem.IsValidObject Property

ContourSettingItemIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ContourSettingItem Class


ContourSettingItem.Start Property

ContourSettingItemStart Property

The contour range start elevation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Start { get; }
Public ReadOnly Property Start As Double
    Get
public:
property double Start {
    double get ();
}
member Start : float with get

Property Value

Double
See Also

Reference

ContourSettingItem Class


ContourSettingItem.Step Property

ContourSettingItemStep Property

The increment elevation of the contour range.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Step { get; }
Public ReadOnly Property Step As Double
    Get
public:
property double Step {
    double get ();
}
member Step : float with get

Property Value

Double
See Also

Reference

ContourSettingItem Class


ContourSettingItem.Stop Property

ContourSettingItemStop Property

The contour range stop elevation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Stop { get; }
Public ReadOnly Property Stop As Double
    Get
public:
property double Stop {
    double get ();
}
member Stop : float with get

Property Value

Double
See Also

Reference

ContourSettingItem Class


ContourSettingItem.SubCategoryId Property

ContourSettingItemSubCategoryId Property

The contour line style subcategory id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId SubCategoryId { get; }
Public ReadOnly Property SubCategoryId As ElementId
    Get
public:
property ElementId^ SubCategoryId {
    ElementId^ get ();
}
member SubCategoryId : ElementId with get

Property Value

ElementId
See Also

Reference

ContourSettingItem Class


ContourSettingItem.Type Property

ContourSettingItemType Property

The contour setting item type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ContourSettingItemType Type { get; }
Public ReadOnly Property Type As ContourSettingItemType
    Get
public:
property ContourSettingItemType Type {
    ContourSettingItemType get ();
}
member Type : ContourSettingItemType with get

Property Value

ContourSettingItemType
See Also

Reference

ContourSettingItem Class


ContourSettingItem Methods

The ContourSettingItem type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ContourSettingItem Class


ContourSettingItem.Dispose Method

ContourSettingItemDispose Method

Releases all resources used by the ContourSettingItem

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ContourSettingItem Class


ContourSettingItemType Enumeration

The type of a ContourSettingItem

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ContourSettingItemType
Public Enumeration ContourSettingItemType
public enum class ContourSettingItemType
type ContourSettingItemType
Members
Member name | Value | Description
Single | 0 | The item only contains a single contour line.
UnboundedRange | 1 | The item contains contour lines in an unbounded range.
BoundedRange | 2 | The item contains contour lines in a bounded range.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Control Class

A control in Autodesk Revit family document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBControl

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Control : Element
Public Class Control
    Inherits Element
public ref class Control : public Element
type Control =
    class
        inherit Element
    end

The Control type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | Origin | The control origin.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Shape | The control shape.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | View | The view.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The object represents a variety of different shapes of controls in family document. The different shapes of controls can handle the family instance in different ways.
  • A vertical/horizontal arrow control rotates the instance by 180 degrees.
  • A double vertical arrow control mirrors the instance geometry vertically.
  • A double horizontal arrow control mirrors the instance geometry horizontally.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Control Properties

The Control type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | Origin | The control origin.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Shape | The control shape.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | View | The view.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

Control Class


Control.Origin Property

ControlOrigin Property

The control origin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Origin { get; }
Public ReadOnly Property Origin As XYZ
    Get
public:
property XYZ^ Origin {
    XYZ^ get ();
}
member Origin : XYZ with get

Property Value

XYZ
See Also

Reference

Control Class


Control.Shape Property

ControlShape Property

The control shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ControlShape Shape { get; }
Public ReadOnly Property Shape As ControlShape
    Get
public:
property ControlShape Shape {
    ControlShape get ();
}
member Shape : ControlShape with get

Property Value

ControlShape
See Also

Reference

Control Class


Control.View Property

ControlView Property

The view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public View View { get; }
Public ReadOnly Property View As View
    Get
public:
property View^ View {
    View^ get ();
}
member View : View with get

Property Value

View
See Also

Reference

Control Class


Control Methods

The Control type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Control Class


ControlShape Enumeration

An enumerated type listing four shapes of control that Autodesk Revit supports.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ControlShape
Public Enumeration ControlShape
public enum class ControlShape
type ControlShape
Members
Member name | Value | Description
VerticalArrow | 0 | Vertical arrow.
HorizontalArrow | 1 | Horizontal arrow.
DoubleVerticalArrow | 2 | Double vertical arrow.
DoubleHorizontalArrow | 3 | Double horizontal arrow.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CoordinatePlaneVisibility Enumeration

Visibility settings for ReferencePoint element's coordinate reference planes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum CoordinatePlaneVisibility
Public Enumeration CoordinatePlaneVisibility
public enum class CoordinatePlaneVisibility
type CoordinatePlaneVisibility
Members
Member name | Value | Description
Never | 0 | Never visible.
WhenSelected | 1 | Visible when selected.
Always | 2 | Always Visible.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CopyPasteOptions Class

Settings to control the behavior of a copy-paste operation.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBCopyPasteOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CopyPasteOptions : IDisposable
Public Class CopyPasteOptions
    Implements IDisposable
public ref class CopyPasteOptions : IDisposable
type CopyPasteOptions =
    class
        interface IDisposable
    end

The CopyPasteOptions type exposes the following members.

Constructors
 | Name | Description
Public method | CopyPasteOptions | Creates a new instance of a CopyPasteOptions object.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the CopyPasteOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetDuplicateTypeNamesHandler | Returns current duplicate type names handler or if none is set.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetDuplicateTypeNamesHandler | Sets a custom duplicate type names handler. If this value is not set, the default handler is used. By default, Revit displays a modal dialog with options to either copy new types only, or cancel the operation.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CopyPasteOptions Constructor

Creates a new instance of a CopyPasteOptions object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CopyPasteOptions()
Public Sub New
public:
CopyPasteOptions()
new : unit -> CopyPasteOptions
See Also

Reference

CopyPasteOptions Class


CopyPasteOptions Properties

The CopyPasteOptions type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

CopyPasteOptions Class


CopyPasteOptions.IsValidObject Property

CopyPasteOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

CopyPasteOptions Class


CopyPasteOptions Methods

The CopyPasteOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetDuplicateTypeNamesHandler | Returns current duplicate type names handler or if none is set.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetDuplicateTypeNamesHandler | Sets a custom duplicate type names handler. If this value is not set, the default handler is used. By default, Revit displays a modal dialog with options to either copy new types only, or cancel the operation.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CopyPasteOptions Class


CopyPasteOptions.Dispose Method

CopyPasteOptionsDispose Method

Releases all resources used by the CopyPasteOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

CopyPasteOptions Class


CopyPasteOptions.GetDuplicateTypeNamesHandler Method

CopyPasteOptionsGetDuplicateTypeNamesHandler Method

Returns current duplicate type names handler or if none is set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IDuplicateTypeNamesHandler GetDuplicateTypeNamesHandler()
Public Function GetDuplicateTypeNamesHandler As IDuplicateTypeNamesHandler
public:
IDuplicateTypeNamesHandler^ GetDuplicateTypeNamesHandler()
member GetDuplicateTypeNamesHandler : unit -> IDuplicateTypeNamesHandler

Return Value

IDuplicateTypeNamesHandler
See Also

Reference

CopyPasteOptions Class


CopyPasteOptions.SetDuplicateTypeNamesHandler Method

CopyPasteOptionsSetDuplicateTypeNamesHandler Method

Sets a custom duplicate type names handler. If this value is not set, the default handler is used. By default, Revit displays a modal dialog with options to either copy new types only, or cancel the operation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetDuplicateTypeNamesHandler(
    IDuplicateTypeNamesHandler handler
)
Public Sub SetDuplicateTypeNamesHandler (
    handler As IDuplicateTypeNamesHandler
)
public:
void SetDuplicateTypeNamesHandler(
    IDuplicateTypeNamesHandler^ handler
)
member SetDuplicateTypeNamesHandler :
        handler : IDuplicateTypeNamesHandler -> unit

Parameters

handler IDuplicateTypeNamesHandler
The duplicate type names handler.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

CopyPasteOptions Class


CurtainCell Class

Represents a CurtainCell within Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBCurtainCell

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CurtainCell : APIObject
Public Class CurtainCell
    Inherits APIObject
public ref class CurtainCell : public APIObject
type CurtainCell =
    class
        inherit APIObject
    end

The CurtainCell type exposes the following members.

Properties
 | Name | Description
Public property | CurveLoops | The cell boundaries on the reference face. The boundaries can have more than one CurveLoop. Each item in the returned array represents a CurveLoop containing 3 or more than 3 edges.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | PlanarizedCurveLoops | The planarized curve loops for cell boundaries. The boundaries can have more than one CurveLoop. Each item in the returned array represents a CurveLoop containing 3 or more than 3 edges.
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CurtainCell Properties

The CurtainCell type exposes the following members.

Properties
 | Name | Description
Public property | CurveLoops | The cell boundaries on the reference face. The boundaries can have more than one CurveLoop. Each item in the returned array represents a CurveLoop containing 3 or more than 3 edges.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | PlanarizedCurveLoops | The planarized curve loops for cell boundaries. The boundaries can have more than one CurveLoop. Each item in the returned array represents a CurveLoop containing 3 or more than 3 edges.
Top
See Also

Reference

CurtainCell Class


CurtainCell.CurveLoops Property

CurtainCellCurveLoops Property

The cell boundaries on the reference face. The boundaries can have more than one CurveLoop. Each item in the returned array represents a CurveLoop containing 3 or more than 3 edges.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurveArrArray CurveLoops { get; }
Public ReadOnly Property CurveLoops As CurveArrArray
    Get
public:
property CurveArrArray^ CurveLoops {
    CurveArrArray^ get ();
}
member CurveLoops : CurveArrArray with get

Property Value

CurveArrArray
See Also

Reference

CurtainCell Class


CurtainCell.PlanarizedCurveLoops Property

CurtainCellPlanarizedCurveLoops Property

The planarized curve loops for cell boundaries. The boundaries can have more than one CurveLoop. Each item in the returned array represents a CurveLoop containing 3 or more than 3 edges.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurveArrArray PlanarizedCurveLoops { get; }
Public ReadOnly Property PlanarizedCurveLoops As CurveArrArray
    Get
public:
property CurveArrArray^ PlanarizedCurveLoops {
    CurveArrArray^ get ();
}
member PlanarizedCurveLoops : CurveArrArray with get

Property Value

CurveArrArray
See Also

Reference

CurtainCell Class


CurtainCell Methods

The CurtainCell type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CurtainCell Class


CurtainGrid Class

Represents a curtain grid element within Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBCurtainGrid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CurtainGrid : APIObject
Public Class CurtainGrid
    Inherits APIObject
public ref class CurtainGrid : public APIObject
type CurtainGrid =
    class
        inherit APIObject
    end

The CurtainGrid type exposes the following members.

Properties
 | Name | Description
Public property | Grid1Angle | The angle for the U grid line pattern of the curtain grid.
Public property | Grid1Justification | The justification for the U grid line pattern of the curtain grid.
Public property | Grid1Offset | The offset for the U grid line pattern of the curtain grid.
Public property | Grid2Angle | The angle for V grid line pattern of the curtain grid.
Public property | Grid2Justification | The justification for the V grid line pattern of the curtain grid.
Public property | Grid2Offset | The offset for V grid line pattern of the curtain grid.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | NumPanels | The number of panels.
Public property | NumULines | Get the number of grid lines in the U direction.
Public property | NumVLines | Get the number of grid lines in the V direction.
Top
Methods
 | Name | Description
Public method | AddGridLine | Add a grid line to the curtain grid.
Public method | ChangePanelType | Change the type of a curtain panel.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCell | Get the specified cell located by the intersection of the grid lines.
Public method | GetCurtainCells | Gets the CurtainCells owned by this curtain grid.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMullionIds | Gets all ElementIds of the mullions of the curtain grid.
Public method | GetPanel | Get the specified panel located by the intersection of the grid lines.
Public method | GetPanelIds | Gets all ElementIds of the panels of the curtain grid.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetUGridLineIds | Gets all ElementIds of grid lines in the U direction.
Public method | GetUnlockedMullionIds | Gets all ElementIds of the unlocked mullions of the curtain grid.
Public method | GetUnlockedPanelIds | Gets all ElementIds of the unlocked panels of the curtain grid.
Public method | GetVGridLineIds | Gets all ElementIds of grid lines in the V direction.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This element is obtained from a curtain wall, curtain system, or curtain roof. A curtain wall has only one curtain grid, while a curtain system or curtain roof may have several curtain grids.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CurtainGrid Properties

The CurtainGrid type exposes the following members.

Properties
 | Name | Description
Public property | Grid1Angle | The angle for the U grid line pattern of the curtain grid.
Public property | Grid1Justification | The justification for the U grid line pattern of the curtain grid.
Public property | Grid1Offset | The offset for the U grid line pattern of the curtain grid.
Public property | Grid2Angle | The angle for V grid line pattern of the curtain grid.
Public property | Grid2Justification | The justification for the V grid line pattern of the curtain grid.
Public property | Grid2Offset | The offset for V grid line pattern of the curtain grid.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | NumPanels | The number of panels.
Public property | NumULines | Get the number of grid lines in the U direction.
Public property | NumVLines | Get the number of grid lines in the V direction.
Top
See Also

Reference

CurtainGrid Class


CurtainGrid.Grid1Angle Property

CurtainGridGrid1Angle Property

The angle for the U grid line pattern of the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Grid1Angle { get; set; }
Public Property Grid1Angle As Double
    Get
    Set
public:
property double Grid1Angle {
    double get ();
    void set (double value);
}
member Grid1Angle : float with get, set

Property Value

Double
See Also

Reference

CurtainGrid Class


CurtainGrid.Grid1Justification Property

CurtainGridGrid1Justification Property

The justification for the U grid line pattern of the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurtainGridAlignType Grid1Justification { get; set; }
Public Property Grid1Justification As CurtainGridAlignType
    Get
    Set
public:
property CurtainGridAlignType Grid1Justification {
    CurtainGridAlignType get ();
    void set (CurtainGridAlignType value);
}
member Grid1Justification : CurtainGridAlignType with get, set

Property Value

CurtainGridAlignType
See Also

Reference

CurtainGrid Class


CurtainGrid.Grid1Offset Property

CurtainGridGrid1Offset Property

The offset for the U grid line pattern of the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Grid1Offset { get; set; }
Public Property Grid1Offset As Double
    Get
    Set
public:
property double Grid1Offset {
    double get ();
    void set (double value);
}
member Grid1Offset : float with get, set

Property Value

Double
See Also

Reference

CurtainGrid Class


CurtainGrid.Grid2Angle Property

CurtainGridGrid2Angle Property

The angle for V grid line pattern of the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Grid2Angle { get; set; }
Public Property Grid2Angle As Double
    Get
    Set
public:
property double Grid2Angle {
    double get ();
    void set (double value);
}
member Grid2Angle : float with get, set

Property Value

Double
See Also

Reference

CurtainGrid Class


CurtainGrid.Grid2Justification Property

CurtainGridGrid2Justification Property

The justification for the V grid line pattern of the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurtainGridAlignType Grid2Justification { get; set; }
Public Property Grid2Justification As CurtainGridAlignType
    Get
    Set
public:
property CurtainGridAlignType Grid2Justification {
    CurtainGridAlignType get ();
    void set (CurtainGridAlignType value);
}
member Grid2Justification : CurtainGridAlignType with get, set

Property Value

CurtainGridAlignType
See Also

Reference

CurtainGrid Class


CurtainGrid.Grid2Offset Property

CurtainGridGrid2Offset Property

The offset for V grid line pattern of the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Grid2Offset { get; set; }
Public Property Grid2Offset As Double
    Get
    Set
public:
property double Grid2Offset {
    double get ();
    void set (double value);
}
member Grid2Offset : float with get, set

Property Value

Double
See Also

Reference

CurtainGrid Class


CurtainGrid.NumPanels Property

CurtainGridNumPanels Property

The number of panels.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int NumPanels { get; }
Public ReadOnly Property NumPanels As Integer
    Get
public:
property int NumPanels {
    int get ();
}
member NumPanels : int with get

Property Value

Int32
See Also

Reference

CurtainGrid Class


CurtainGrid.NumULines Property

CurtainGridNumULines Property

Get the number of grid lines in the U direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int NumULines { get; }
Public ReadOnly Property NumULines As Integer
    Get
public:
property int NumULines {
    int get ();
}
member NumULines : int with get

Property Value

Int32
See Also

Reference

CurtainGrid Class


CurtainGrid.NumVLines Property

CurtainGridNumVLines Property

Get the number of grid lines in the V direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int NumVLines { get; }
Public ReadOnly Property NumVLines As Integer
    Get
public:
property int NumVLines {
    int get ();
}
member NumVLines : int with get

Property Value

Int32
See Also

Reference

CurtainGrid Class


CurtainGrid Methods

The CurtainGrid type exposes the following members.

Methods
 | Name | Description
Public method | AddGridLine | Add a grid line to the curtain grid.
Public method | ChangePanelType | Change the type of a curtain panel.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCell | Get the specified cell located by the intersection of the grid lines.
Public method | GetCurtainCells | Gets the CurtainCells owned by this curtain grid.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMullionIds | Gets all ElementIds of the mullions of the curtain grid.
Public method | GetPanel | Get the specified panel located by the intersection of the grid lines.
Public method | GetPanelIds | Gets all ElementIds of the panels of the curtain grid.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetUGridLineIds | Gets all ElementIds of grid lines in the U direction.
Public method | GetUnlockedMullionIds | Gets all ElementIds of the unlocked mullions of the curtain grid.
Public method | GetUnlockedPanelIds | Gets all ElementIds of the unlocked panels of the curtain grid.
Public method | GetVGridLineIds | Gets all ElementIds of grid lines in the V direction.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CurtainGrid Class


CurtainGrid.AddGridLine Method

CurtainGridAddGridLine Method

Add a grid line to the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurtainGridLine AddGridLine(
    bool isUGridLine,
    XYZ position,
    bool oneSegmentOnly
)
Public Function AddGridLine (
    isUGridLine As Boolean,
    position As XYZ,
    oneSegmentOnly As Boolean
) As CurtainGridLine
public:
CurtainGridLine^ AddGridLine(
    bool isUGridLine,
    XYZ^ position,
    bool oneSegmentOnly
)
member AddGridLine :
        isUGridLine : bool *
        position : XYZ *
        oneSegmentOnly : bool -> CurtainGridLine

Parameters

isUGridLine Boolean
If true, a U-direction grid line will be added. Otherwise, a V-direction grid line will be added.
position XYZ
The position of the grid line.
oneSegmentOnly Boolean
If it is true, only one segment is added. Otherwise, all segments will be added for the grid line.

Return Value

CurtainGridLine
The created grid line is returned if the operation is successful. Otherwise, is returned.
Exceptions
Exception | Condition
InvalidOperationException | Thrown if the position for the grid line is out of range.
See Also

Reference

CurtainGrid Class


CurtainGrid.ChangePanelType Method

CurtainGridChangePanelType Method

Change the type of a curtain panel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Element ChangePanelType(
    Element panel,
    ElementType newSymbol
)
Public Function ChangePanelType (
    panel As Element,
    newSymbol As ElementType
) As Element
public:
Element^ ChangePanelType(
    Element^ panel,
    ElementType^ newSymbol
)
member ChangePanelType :
        panel : Element *
        newSymbol : ElementType -> Element

Parameters

panel Element
The panel to be changed, it can be a type of Panel or Wall.
newSymbol ElementType
The new symbol, it may be of PanelType or WallType when the panel is hosted in a curtain wall. The new symbol can only be of type PanelType if the Panel is hosted in a curtain system.

Return Value

Element
If operation succeeds, the modified panel element is returned.
Exceptions
Exception | Condition
ArgumentException | Thrown if the input symbol can't be used for the panel.
InvalidOperationException | Thrown when the type change failed.
See Also

Reference

CurtainGrid Class


CurtainGrid.GetCell Method

CurtainGridGetCell Method

Get the specified cell located by the intersection of the grid lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurtainCell GetCell(
    ElementId uGridLineId,
    ElementId vGridLineId
)
Public Function GetCell (
    uGridLineId As ElementId,
    vGridLineId As ElementId
) As CurtainCell
public:
CurtainCell^ GetCell(
    ElementId^ uGridLineId,
    ElementId^ vGridLineId
)
member GetCell :
        uGridLineId : ElementId *
        vGridLineId : ElementId -> CurtainCell

Parameters

uGridLineId ElementId
The id of a grid line in the U-direction used to locate the cell.
vGridLineId ElementId
The id of a grid line in the V-direction used to locate the cell.

Return Value

CurtainCell
The cell.
Exceptions
Exception | Condition
ArgumentException | Thrown if the grid line ids are not part of this curtain grid.
See Also

Reference

CurtainGrid Class


CurtainGrid.GetCurtainCells Method

CurtainGridGetCurtainCells Method

Gets the CurtainCells owned by this curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<CurtainCell> GetCurtainCells()
Public Function GetCurtainCells As ICollection(Of CurtainCell)
public:
ICollection<CurtainCell^>^ GetCurtainCells()
member GetCurtainCells : unit -> ICollection<CurtainCell>

Return Value

ICollection CurtainCell
The CurtainCells owned by this curtain grid.
See Also

Reference

CurtainGrid Class


CurtainGrid.GetMullionIds Method

CurtainGridGetMullionIds Method

Gets all ElementIds of the mullions of the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetMullionIds()
Public Function GetMullionIds As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetMullionIds()
member GetMullionIds : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
The mullion ElementIds
Remarks
ElementIds are of Mullion Elements.
See Also

Reference

CurtainGrid Class


CurtainGrid.GetPanel Method

CurtainGridGetPanel Method

Get the specified panel located by the intersection of the grid lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Panel GetPanel(
    ElementId uGridLineId,
    ElementId vGridLineId
)
Public Function GetPanel (
    uGridLineId As ElementId,
    vGridLineId As ElementId
) As Panel
public:
Panel^ GetPanel(
    ElementId^ uGridLineId,
    ElementId^ vGridLineId
)
member GetPanel :
        uGridLineId : ElementId *
        vGridLineId : ElementId -> Panel

Parameters

uGridLineId ElementId
The id of a grid line in the U-direction used to locate the panel.
vGridLineId ElementId
The id of a grid line in the V-direction used to locate the panel.

Return Value

Panel
The panel, or if the panel cannot be found at this intersection.
See Also

Reference

CurtainGrid Class


CurtainGrid.GetPanelIds Method

CurtainGridGetPanelIds Method

Gets all ElementIds of the panels of the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetPanelIds()
Public Function GetPanelIds As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetPanelIds()
member GetPanelIds : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
The panel ElementIds
Remarks
For curtain walls, the ElementIds in this set are of either Panel or Wall Elements. For curtain systems, ElementIds are of Panel Elements.
See Also

Reference

CurtainGrid Class


CurtainGrid.GetUGridLineIds Method

CurtainGridGetUGridLineIds Method

Gets all ElementIds of grid lines in the U direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetUGridLineIds()
Public Function GetUGridLineIds As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetUGridLineIds()
member GetUGridLineIds : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
The U grid line ElementIds
See Also

Reference

CurtainGrid Class


CurtainGrid.GetUnlockedMullionIds Method

CurtainGridGetUnlockedMullionIds Method

Gets all ElementIds of the unlocked mullions of the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetUnlockedMullionIds()
Public Function GetUnlockedMullionIds As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetUnlockedMullionIds()
member GetUnlockedMullionIds : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
The unlocked mullion ElementIds
Remarks
ElementIds are of Mullion Elements.
See Also

Reference

CurtainGrid Class


CurtainGrid.GetUnlockedPanelIds Method

CurtainGridGetUnlockedPanelIds Method

Gets all ElementIds of the unlocked panels of the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetUnlockedPanelIds()
Public Function GetUnlockedPanelIds As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetUnlockedPanelIds()
member GetUnlockedPanelIds : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
The unlocked panel ElementIds
Remarks
For curtain walls, the ElementIds in this set are of either Panel or Wall Elements. For curtain systems, ElementIds are of Panel Elements.
See Also

Reference

CurtainGrid Class


CurtainGrid.GetVGridLineIds Method

CurtainGridGetVGridLineIds Method

Gets all ElementIds of grid lines in the V direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetVGridLineIds()
Public Function GetVGridLineIds As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetVGridLineIds()
member GetVGridLineIds : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
The V grid line ElementIds
See Also

Reference

CurtainGrid Class


CurtainGridAlignType Enumeration

An enumerated to list CurtainGrid patterns.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum CurtainGridAlignType
Public Enumeration CurtainGridAlignType
public enum class CurtainGridAlignType
type CurtainGridAlignType
Members
Member name | Value | Description
NoJustify | 0 | NoJustify.
Beginning | 1 | Beginning pattern of CurtainGrid.
Center | 2 | Center pattern of CurtainGrid.
End | 3 | End pattern of CurtainGrid.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CurtainGridLine Class

Represents a CurtainGridLine within Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBHostObject
Autodesk.Revit.DBCurtainGridLine

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CurtainGridLine : HostObject
Public Class CurtainGridLine
    Inherits HostObject
public ref class CurtainGridLine : public HostObject
type CurtainGridLine =
    class
        inherit HostObject
    end

The CurtainGridLine type exposes the following members.

Properties
 | Name | Description
Public property | AllSegmentCurves | Retrieve the curves of all segments.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | ExistingSegmentCurves | Retrieve all the existing segment curves of the grid line.
Public property | FullCurve | Retrieve the geometry curve of the curtain grid line.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsUGridLine | Retrieve the direction of a grid line.If it is true,we say it is a UGridLine,otherwise it is VGridLine
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Lock | Retrieves or changes the lock state of the curtain grid line.
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SkippedSegmentCurves | Retrieve all the removed segment curves of the grid line.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | AddAllSegments | All the segments on this grid line will be added.
Public method | AddMullions | Add mullions on the specified segments of a grid. If any segment already has a mullion, no change is made to that segment.
Public method | AddSegment | Add a segment based on the specified segment curve of the gridline.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveSegment | Remove the segment specified by the input curve.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CurtainGridLine Properties

The CurtainGridLine type exposes the following members.

Properties
 | Name | Description
Public property | AllSegmentCurves | Retrieve the curves of all segments.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | ExistingSegmentCurves | Retrieve all the existing segment curves of the grid line.
Public property | FullCurve | Retrieve the geometry curve of the curtain grid line.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsUGridLine | Retrieve the direction of a grid line.If it is true,we say it is a UGridLine,otherwise it is VGridLine
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Lock | Retrieves or changes the lock state of the curtain grid line.
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SkippedSegmentCurves | Retrieve all the removed segment curves of the grid line.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

CurtainGridLine Class


CurtainGridLine.AllSegmentCurves Property

CurtainGridLineAllSegmentCurves Property

Retrieve the curves of all segments.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurveArray AllSegmentCurves { get; }
Public ReadOnly Property AllSegmentCurves As CurveArray
    Get
public:
property CurveArray^ AllSegmentCurves {
    CurveArray^ get ();
}
member AllSegmentCurves : CurveArray with get

Property Value

CurveArray
Remarks
User can get these curves and then call the method AddSegment() or RemoveSegment() to add/remove specified segments. If the specified segment is already added/removed, nothing will happen.
See Also

Reference

CurtainGridLine Class


CurtainGridLine.ExistingSegmentCurves Property

CurtainGridLineExistingSegmentCurves Property

Retrieve all the existing segment curves of the grid line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurveArray ExistingSegmentCurves { get; }
Public ReadOnly Property ExistingSegmentCurves As CurveArray
    Get
public:
property CurveArray^ ExistingSegmentCurves {
    CurveArray^ get ();
}
member ExistingSegmentCurves : CurveArray with get

Property Value

CurveArray
Remarks
User can get these curves and call RemoveSegment() to remove the segments to the gridline or call AddMullions() to add mullions to these segments.
See Also

Reference

CurtainGridLine Class


CurtainGridLine.FullCurve Property

CurtainGridLineFullCurve Property

Retrieve the geometry curve of the curtain grid line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Curve FullCurve { get; }
Public ReadOnly Property FullCurve As Curve
    Get
public:
property Curve^ FullCurve {
    Curve^ get ();
}
member FullCurve : Curve with get

Property Value

Curve
See Also

Reference

CurtainGridLine Class


CurtainGridLine.IsUGridLine Property

CurtainGridLineIsUGridLine Property

Retrieve the direction of a grid line.If it is true,we say it is a UGridLine,otherwise it is VGridLine

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsUGridLine { get; }
Public ReadOnly Property IsUGridLine As Boolean
    Get
public:
property bool IsUGridLine {
    bool get ();
}
member IsUGridLine : bool with get

Property Value

Boolean
See Also

Reference

CurtainGridLine Class


CurtainGridLine.Lock Property

CurtainGridLineLock Property

Retrieves or changes the lock state of the curtain grid line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Lock { get; set; }
Public Property Lock As Boolean
    Get
    Set
public:
property bool Lock {
    bool get ();
    void set (bool value);
}
member Lock : bool with get, set

Property Value

Boolean
See Also

Reference

CurtainGridLine Class


CurtainGridLine.SkippedSegmentCurves Property

CurtainGridLineSkippedSegmentCurves Property

Retrieve all the removed segment curves of the grid line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurveArray SkippedSegmentCurves { get; }
Public ReadOnly Property SkippedSegmentCurves As CurveArray
    Get
public:
property CurveArray^ SkippedSegmentCurves {
    CurveArray^ get ();
}
member SkippedSegmentCurves : CurveArray with get

Property Value

CurveArray
Remarks
User can get these curves and then call the method AddSegment() to add the segments to the grid line.
See Also

Reference

CurtainGridLine Class


CurtainGridLine Methods

The CurtainGridLine type exposes the following members.

Methods
 | Name | Description
Public method | AddAllSegments | All the segments on this grid line will be added.
Public method | AddMullions | Add mullions on the specified segments of a grid. If any segment already has a mullion, no change is made to that segment.
Public method | AddSegment | Add a segment based on the specified segment curve of the gridline.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveSegment | Remove the segment specified by the input curve.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CurtainGridLine Class


CurtainGridLine.AddAllSegments Method

CurtainGridLineAddAllSegments Method

All the segments on this grid line will be added.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddAllSegments()
Public Sub AddAllSegments
public:
void AddAllSegments()
member AddAllSegments : unit -> unit
See Also

Reference

CurtainGridLine Class


CurtainGridLine.AddMullions Method

CurtainGridLineAddMullions Method

Add mullions on the specified segments of a grid. If any segment already has a mullion, no change is made to that segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementSet AddMullions(
    Curve segment,
    MullionType mullionType,
    bool oneSegmentOnly
)
Public Function AddMullions (
    segment As Curve,
    mullionType As MullionType,
    oneSegmentOnly As Boolean
) As ElementSet
public:
ElementSet^ AddMullions(
    Curve^ segment,
    MullionType^ mullionType,
    bool oneSegmentOnly
)
member AddMullions :
        segment : Curve *
        mullionType : MullionType *
        oneSegmentOnly : bool -> ElementSet

Parameters

segment Curve
Curve of the segment.
mullionType MullionType
The type of the mullion to add.
oneSegmentOnly Boolean
If true, add one mullion to the specified segment, otherwise add mullions to all the segments of the matching grid line.

Return Value

ElementSet
If operation succeeds, the created mullions will be returned.
Exceptions
Exception | Condition
InvalidOperationException | Invalid curtain grid line or invalid mullion type argument.
See Also

Reference

CurtainGridLine Class


CurtainGridLine.AddSegment Method

CurtainGridLineAddSegment Method

Add a segment based on the specified segment curve of the gridline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddSegment(
    Curve curve
)
Public Sub AddSegment (
    curve As Curve
)
public:
void AddSegment(
    Curve^ curve
)
member AddSegment :
        curve : Curve -> unit

Parameters

curve Curve
The curve used to locate the segment to be removed. This function will invoke regeneration.
Exceptions
Exception | Condition
InvalidOperationException | Segment may not have been found in location indicated by curve.
See Also

Reference

CurtainGridLine Class


CurtainGridLine.RemoveSegment Method

CurtainGridLineRemoveSegment Method

Remove the segment specified by the input curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveSegment(
    Curve curve
)
Public Sub RemoveSegment (
    curve As Curve
)
public:
void RemoveSegment(
    Curve^ curve
)
member RemoveSegment :
        curve : Curve -> unit

Parameters

curve Curve
The curve used to locate the segment to be removed.
Exceptions
Exception | Condition
InvalidOperationException | Segment may not have been found in location indicated by curve.
Remarks
When a segment is removed, the neighboring two panels will be merged into one panel. This function will invoke regeneration.
See Also

Reference

CurtainGridLine Class


CurtainGridSet Class

A set that can contain any type of object.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBCurtainGridSet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CurtainGridSet : APIObject,
    IEnumerable
Public Class CurtainGridSet
    Inherits APIObject
    Implements IEnumerable
public ref class CurtainGridSet : public APIObject,
    IEnumerable
type CurtainGridSet =
    class
        inherit APIObject
        interface IEnumerable
    end

The CurtainGridSet type exposes the following members.

Constructors
 | Name | Description
Public method | CurtainGridSet | Initializes a new instance of the CurtainGridSet class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Size | Returns the number of objects that are in the set.
Top
Methods
 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CurtainGridSet Constructor

Initializes a new instance of the CurtainGridSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurtainGridSet()
Public Sub New
public:
CurtainGridSet()
new : unit -> CurtainGridSet
See Also

Reference

CurtainGridSet Class


CurtainGridSet Properties

The CurtainGridSet type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Size | Returns the number of objects that are in the set.
Top
See Also

Reference

CurtainGridSet Class


CurtainGridSet.IsEmpty Property

CurtainGridSetIsEmpty Property

Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Boolean
Remarks
If the set is empty then True will be returned, otherwise False.
See Also

Reference

CurtainGridSet Class


CurtainGridSet.Size Property

CurtainGridSetSize Property

Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
abstract Size : int with get
override Size : int with get

Property Value

Int32
See Also

Reference

CurtainGridSet Class


CurtainGridSet Methods

The CurtainGridSet type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CurtainGridSet Class


CurtainGridSet.Clear Method

CurtainGridSetClear Method

Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

CurtainGridSet Class


CurtainGridSet.Contains Method

CurtainGridSetContains Method

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Contains(
    CurtainGrid item
)
Public Overridable Function Contains (
    item As CurtainGrid
) As Boolean
public:
virtual bool Contains(
    CurtainGrid^ item
)
abstract Contains :
        item : CurtainGrid -> bool
override Contains :
        item : CurtainGrid -> bool

Parameters

item CurtainGrid

Return Value

Boolean
See Also

Reference

CurtainGridSet Class


CurtainGridSet.Erase Method

CurtainGridSetErase Method

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Erase(
    CurtainGrid item
)
Public Overridable Function Erase (
    item As CurtainGrid
) As Integer
public:
virtual int Erase(
    CurtainGrid^ item
)
abstract Erase :
        item : CurtainGrid -> int
override Erase :
        item : CurtainGrid -> int

Parameters

item CurtainGrid

Return Value

Int32
See Also

Reference

CurtainGridSet Class


CurtainGridSet.ForwardIterator Method

CurtainGridSetForwardIterator Method

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual CurtainGridSetIterator ForwardIterator()
Public Overridable Function ForwardIterator As CurtainGridSetIterator
public:
virtual CurtainGridSetIterator^ ForwardIterator()
abstract ForwardIterator : unit -> CurtainGridSetIterator
override ForwardIterator : unit -> CurtainGridSetIterator

Return Value

CurtainGridSetIterator
Returns a forward moving iterator to the set.
See Also

Reference

CurtainGridSet Class


CurtainGridSet.GetEnumerator Method

CurtainGridSetGetEnumerator Method

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

IEnumerator
Returns a forward moving iterator to the set.

Implements

IEnumerableGetEnumerator
See Also

Reference

CurtainGridSet Class


CurtainGridSet.Insert Method

CurtainGridSetInsert Method

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Insert(
    CurtainGrid item
)
Public Overridable Function Insert (
    item As CurtainGrid
) As Boolean
public:
virtual bool Insert(
    CurtainGrid^ item
)
abstract Insert :
        item : CurtainGrid -> bool
override Insert :
        item : CurtainGrid -> bool

Parameters

item CurtainGrid

Return Value

Boolean
See Also

Reference

CurtainGridSet Class


CurtainGridSet.ReverseIterator Method

CurtainGridSetReverseIterator Method

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual CurtainGridSetIterator ReverseIterator()
Public Overridable Function ReverseIterator As CurtainGridSetIterator
public:
virtual CurtainGridSetIterator^ ReverseIterator()
abstract ReverseIterator : unit -> CurtainGridSetIterator
override ReverseIterator : unit -> CurtainGridSetIterator

Return Value

CurtainGridSetIterator
Returns a backward moving iterator to the set.
See Also

Reference

CurtainGridSet Class


CurtainGridSetIterator Class

An iterator to a set.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBCurtainGridSetIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class CurtainGridSetIterator : APIObject,
    IEnumerator
Public MustInherit Class CurtainGridSetIterator
    Inherits APIObject
    Implements IEnumerator
public ref class CurtainGridSetIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type CurtainGridSetIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The CurtainGridSetIterator type exposes the following members.

Constructors
 | Name | Description
Public method | CurtainGridSetIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CurtainGridSetIterator Constructor

For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurtainGridSetIterator()
Public Sub New
public:
CurtainGridSetIterator()
new : unit -> CurtainGridSetIterator
Remarks
This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.
See Also

Reference

CurtainGridSetIterator Class


CurtainGridSetIterator Properties

The CurtainGridSetIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

CurtainGridSetIterator Class


CurtainGridSetIterator.Current Property

CurtainGridSetIteratorCurrent Property

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}
abstract Current : Object with get
override Current : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.
See Also

Reference

CurtainGridSetIterator Class


CurtainGridSetIterator Methods

The CurtainGridSetIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CurtainGridSetIterator Class


CurtainGridSetIterator.MoveNext Method

CurtainGridSetIteratorMoveNext Method

Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumeratorMoveNext
Remarks
MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.
See Also

Reference

CurtainGridSetIterator Class


CurtainGridSetIterator.Reset Method

CurtainGridSetIteratorReset Method

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
Remarks
The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.
See Also

Reference

CurtainGridSetIterator Class


CurtainSystem Class

Provides access to the CurtainSystem object in Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBHostObject
Autodesk.Revit.DBCurtainSystemBase
Autodesk.Revit.DBCurtainSystem

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CurtainSystem : CurtainSystemBase
Public Class CurtainSystem
    Inherits CurtainSystemBase
public ref class CurtainSystem : public CurtainSystemBase
type CurtainSystem =
    class
        inherit CurtainSystemBase
    end

The CurtainSystem type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CurtainGrids | Get all the CurtainGrid object of this CurtainSystem. Each CurtainGrid corresponds to one face.
Public property | CurtainSystemType | get or set the type of the CurtainSystem.
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | AddCurtainGrid | Add CurtainGrid on the specified face for the CurtainSystem.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveCurtainGrid | Remove CurtainGrid from the specified face for the CurtainSystem.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The user can create CurtainSystem object and change the internal properties.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CurtainSystem Properties

The CurtainSystem type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CurtainGrids | Get all the CurtainGrid object of this CurtainSystem. Each CurtainGrid corresponds to one face.
Public property | CurtainSystemType | get or set the type of the CurtainSystem.
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

CurtainSystem Class


CurtainSystem.CurtainGrids Property

CurtainSystemCurtainGrids Property

Get all the CurtainGrid object of this CurtainSystem. Each CurtainGrid corresponds to one face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurtainGridSet CurtainGrids { get; }
Public ReadOnly Property CurtainGrids As CurtainGridSet
    Get
public:
property CurtainGridSet^ CurtainGrids {
    CurtainGridSet^ get ();
}
member CurtainGrids : CurtainGridSet with get

Return Value

CurtainGridSet
A CurtainGrid set will be returned if the operation succeeds. will be returned if the CurtainSystem doesn't include any CurtainGrid.
See Also

Reference

CurtainSystem Class


CurtainSystem.CurtainSystemType Property

CurtainSystemCurtainSystemType Property

get or set the type of the CurtainSystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurtainSystemType CurtainSystemType { get; set; }
Public Property CurtainSystemType As CurtainSystemType
    Get
    Set
public:
property CurtainSystemType^ CurtainSystemType {
    CurtainSystemType^ get ();
    void set (CurtainSystemType^ value);
}
member CurtainSystemType : CurtainSystemType with get, set

Property Value

CurtainSystemType
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the specified parameter curtainSystemType is .
InvalidOperationException | Thrown when the type of the CurtainSystem cannot be changed to the specified one.
See Also

Reference

CurtainSystem Class


CurtainSystem Methods

The CurtainSystem type exposes the following members.

Methods
 | Name | Description
Public method | AddCurtainGrid | Add CurtainGrid on the specified face for the CurtainSystem.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveCurtainGrid | Remove CurtainGrid from the specified face for the CurtainSystem.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CurtainSystem Class


CurtainSystem.AddCurtainGrid Method

CurtainSystemAddCurtainGrid Method

Add CurtainGrid on the specified face for the CurtainSystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddCurtainGrid(
    Reference face
)
Public Sub AddCurtainGrid (
    face As Reference
)
public:
void AddCurtainGrid(
    Reference^ face
)
member AddCurtainGrid :
        face : Reference -> unit

Parameters

face Reference
The face new CurtainGrid will be created on.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument face is .
InvalidOperationException | Thrown when creating CurtainGrid on the specified face fails or regenerate fails.
See Also

Reference

CurtainSystem Class


CurtainSystem.RemoveCurtainGrid Method

CurtainSystemRemoveCurtainGrid Method

Remove CurtainGrid from the specified face for the CurtainSystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveCurtainGrid(
    Reference face
)
Public Sub RemoveCurtainGrid (
    face As Reference
)
public:
void RemoveCurtainGrid(
    Reference^ face
)
member RemoveCurtainGrid :
        face : Reference -> unit

Parameters

face Reference
The face CurtainGrid will be removed from.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input parameter face is .
InvalidOperationException | Thrown when the CurtainGrid cannot be removed from the specified face or regenerate fails.
See Also

Reference

CurtainSystem Class


CurtainSystemBase Class

Provides access to the CurtainSystemBase object in Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBHostObject
Autodesk.Revit.DBCurtainSystemBase
Autodesk.Revit.DBCurtainSystem

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CurtainSystemBase : HostObject
Public Class CurtainSystemBase
    Inherits HostObject
public ref class CurtainSystemBase : public HostObject
type CurtainSystemBase =
    class
        inherit HostObject
    end

The CurtainSystemBase type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This is the base class of CurtainSystem.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CurtainSystemBase Properties

The CurtainSystemBase type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

CurtainSystemBase Class


CurtainSystemBase Methods

The CurtainSystemBase type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CurtainSystemBase Class


CurtainSystemType Class

An object that represents CurtainSystem type.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBHostObjAttributes
Autodesk.Revit.DBCurtainSystemType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CurtainSystemType : HostObjAttributes
Public Class CurtainSystemType
    Inherits HostObjAttributes
public ref class CurtainSystemType : public HostObjAttributes
type CurtainSystemType =
    class
        inherit HostObjAttributes
    end

The CurtainSystemType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CurtainSystemType Properties

The CurtainSystemType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

CurtainSystemType Class


CurtainSystemType Methods

The CurtainSystemType type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CurtainSystemType Class


Curve Class

A parametric curve.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGeometryObject
Autodesk.Revit.DBCurve
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Curve : GeometryObject
Public Class Curve
    Inherits GeometryObject
public ref class Curve : public GeometryObject
type Curve =
    class
        inherit GeometryObject
    end

The Curve type exposes the following members.

Properties
 | Name | Description
Public property | ApproximateLength | The approximate length of the curve.
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval.
Public property | IsClosed | Describes whether the curve is closed.
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic.
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject)
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Length | The exact length of the curve.
Public property | Period | The period of this curve.
Public property | Reference | Returns a stable reference to the curve.
Public property | Visibility | The visibility. (Inherited from GeometryObject)
Top
Methods
 | Name | Description
Public method | Clone | Returns a copy of this curve.
Public method | ComputeClosestPoints | Find the closest points between two curves. Closest points mean closest pairs of points, each pair consisting of a point on this, say P1, and a point on other curve, say P2. P1 and P2 are closest locally. Each pairs of closest points will be represented by the corresponding parameter values with respect to the two curves and the 3d points. A closest pair is also known as a pair of critical points of the distance function between points of the two curves. If the input parameter returnAllCriticalPoints is set to false, then the function will return only pairs with minimum distance.
Public method | ComputeDerivatives | Returns the vectors describing the curve at the specified parameter.
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter.
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter.
Public method | CreateOffset | Creates a new curve that is an offset of the existing curve.
Public method | CreateReversed | Creates a new curve with the opposite orientation of the existing curve.
Public method | CreateTransformed | Crates a new instance of a curve as a transformation of this curve.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Distance | Returns the shortest distance from the specified point to this curve.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject)
Public method | Evaluate | Evaluates and returns the point that matches a parameter along the curve.
Public method | GetEndParameter | Returns the raw parameter value at the start or end of this curve.
Public method | GetEndPoint | Returns the 3D point at the start or end of this curve.
Public method | GetEndPointReference | Returns a stable reference to the start point or the end point of the curve.
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve.
Public method | Intersect(Curve, IntersectionResultArray) | Calculates the intersection of this curve with the specified curve and returns the intersection results.
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds.
Public method | IsInside(Double, Int32) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index.
Public method | MakeBound | Changes the bounds of this curve to the specified values.
Public method | MakeUnbound | Makes this curve unbound.
Public method | Project | Projects the specified point on this curve.
Public method | SetGraphicsStyleId | Sets the graphics style id for this curve.
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The concrete curves are defined by parametric equations. If the curve is bound, it is only defined for an interval in parameterization. Otherwise, it is defined for all values of the parameter.
See Also

Reference

Autodesk.Revit.DB Namespace
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGeometryObject
Autodesk.Revit.DBCurve
Autodesk.Revit.DBArc
Autodesk.Revit.DBCylindricalHelix
Autodesk.Revit.DBEllipse
Autodesk.Revit.DBHermiteSpline
Autodesk.Revit.DBLine
Autodesk.Revit.DBNurbSpline


Curve Properties

The Curve type exposes the following members.

Properties
 | Name | Description
Public property | ApproximateLength | The approximate length of the curve.
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval.
Public property | IsClosed | Describes whether the curve is closed.
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic.
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject)
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Length | The exact length of the curve.
Public property | Period | The period of this curve.
Public property | Reference | Returns a stable reference to the curve.
Public property | Visibility | The visibility. (Inherited from GeometryObject)
Top
See Also

Reference

Curve Class


Curve.ApproximateLength Property

CurveApproximateLength Property

The approximate length of the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double ApproximateLength { get; }
Public ReadOnly Property ApproximateLength As Double
    Get
public:
property double ApproximateLength {
    double get ();
}
member ApproximateLength : float with get

Property Value

Double
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the curve is unbound and not periodic.
Remarks
Quickly estimates the length of the curve, may deviate by a factor of 2 in some cases. The computation is exact for lines and arcs.
See Also

Reference

Curve Class


Curve.IsBound Property

CurveIsBound Property

Describes whether the parameter of the curve is restricted to a particular interval.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsBound { get; }
Public ReadOnly Property IsBound As Boolean
    Get
public:
property bool IsBound {
    bool get ();
}
member IsBound : bool with get

Property Value

Boolean
See Also

Reference

Curve Class


Curve.IsClosed Property

CurveIsClosed Property

Describes whether the curve is closed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsClosed { get; }
Public ReadOnly Property IsClosed As Boolean
    Get
public:
property bool IsClosed {
    bool get ();
}
member IsClosed : bool with get

Property Value

Boolean
Remarks
A curve is "closed" if it is bounded and its start and end points coincide (to within Revit's 3D tolerance), or if it is unbounded and periodic.
See Also

Reference

Curve Class


Curve.IsCyclic Property

CurveIsCyclic Property

The boolean value that indicates whether this curve is cyclic.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCyclic { get; }
Public ReadOnly Property IsCyclic As Boolean
    Get
public:
property bool IsCyclic {
    bool get ();
}
member IsCyclic : bool with get

Return Value

Boolean
True if this curve is cyclic; otherwise, false.
See Also

Reference

Curve Class


Curve.Length Property

CurveLength Property

The exact length of the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Length { get; }
Public ReadOnly Property Length As Double
    Get
public:
property double Length {
    double get ();
}
member Length : float with get

Property Value

Double
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the curve is unbound and not periodic.
Remarks
Computes the length of the curve using analytical or numeric integration. There is no performance hit for lines and arcs.
See Also

Reference

Curve Class


Curve.Period Property

CurvePeriod Property

The period of this curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Period { get; }
Public ReadOnly Property Period As Double
    Get
public:
property double Period {
    double get ();
}
member Period : float with get

Property Value

Double
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the curve is not cyclic.
See Also

Reference

Curve Class


Curve.Reference Property

CurveReference Property

Returns a stable reference to the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Reference Reference { get; }
Public ReadOnly Property Reference As Reference
    Get
public:
property Reference^ Reference {
    Reference^ get ();
}
member Reference : Reference with get

Property Value

Reference
This value is set for curve geometry obtained from Revit elements. if the curve was created via parameters, copying, transform, or other operations.
Remarks
This value is also if the corresponding geometry object does not permit referencing.
See Also

Reference

Curve Class


Curve Methods

The Curve type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Returns a copy of this curve.
Public method | ComputeClosestPoints | Find the closest points between two curves. Closest points mean closest pairs of points, each pair consisting of a point on this, say P1, and a point on other curve, say P2. P1 and P2 are closest locally. Each pairs of closest points will be represented by the corresponding parameter values with respect to the two curves and the 3d points. A closest pair is also known as a pair of critical points of the distance function between points of the two curves. If the input parameter returnAllCriticalPoints is set to false, then the function will return only pairs with minimum distance.
Public method | ComputeDerivatives | Returns the vectors describing the curve at the specified parameter.
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter.
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter.
Public method | CreateOffset | Creates a new curve that is an offset of the existing curve.
Public method | CreateReversed | Creates a new curve with the opposite orientation of the existing curve.
Public method | CreateTransformed | Crates a new instance of a curve as a transformation of this curve.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Distance | Returns the shortest distance from the specified point to this curve.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject)
Public method | Evaluate | Evaluates and returns the point that matches a parameter along the curve.
Public method | GetEndParameter | Returns the raw parameter value at the start or end of this curve.
Public method | GetEndPoint | Returns the 3D point at the start or end of this curve.
Public method | GetEndPointReference | Returns a stable reference to the start point or the end point of the curve.
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve.
Public method | Intersect(Curve, IntersectionResultArray) | Calculates the intersection of this curve with the specified curve and returns the intersection results.
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds.
Public method | IsInside(Double, Int32) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index.
Public method | MakeBound | Changes the bounds of this curve to the specified values.
Public method | MakeUnbound | Makes this curve unbound.
Public method | Project | Projects the specified point on this curve.
Public method | SetGraphicsStyleId | Sets the graphics style id for this curve.
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Curve Class


Curve.Clone Method

CurveClone Method

Returns a copy of this curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Curve Clone()
Public Function Clone As Curve
public:
Curve^ Clone()
member Clone : unit -> Curve

Return Value

Curve
A copy of this curve.
See Also

Reference

Curve Class


Curve.ComputeClosestPoints Method

CurveComputeClosestPoints Method

Find the closest points between two curves. Closest points mean closest pairs of points, each pair consisting of a point on this, say P1, and a point on other curve, say P2. P1 and P2 are closest locally. Each pairs of closest points will be represented by the corresponding parameter values with respect to the two curves and the 3d points. A closest pair is also known as a pair of critical points of the distance function between points of the two curves. If the input parameter returnAllCriticalPoints is set to false, then the function will return only pairs with minimum distance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ComputeClosestPoints(
    Curve otherCurve,
    bool withinThisCurveBounds,
    bool withinOtherCurveBounds,
    bool returnAllCriticalPnts,
    out IList<ClosestPointsPairBetweenTwoCurves> resultList
)
Public Sub ComputeClosestPoints (
    otherCurve As Curve,
    withinThisCurveBounds As Boolean,
    withinOtherCurveBounds As Boolean,
    returnAllCriticalPnts As Boolean,
    <OutAttribute> ByRef resultList As IList(Of ClosestPointsPairBetweenTwoCurves)
)
public:
void ComputeClosestPoints(
    Curve^ otherCurve,
    bool withinThisCurveBounds,
    bool withinOtherCurveBounds,
    bool returnAllCriticalPnts,
    [OutAttribute] IList<ClosestPointsPairBetweenTwoCurves^>^% resultList
)
member ComputeClosestPoints :
        otherCurve : Curve *
        withinThisCurveBounds : bool *
        withinOtherCurveBounds : bool *
        returnAllCriticalPnts : bool *
        resultList : IList<ClosestPointsPairBetweenTwoCurves> byref -> unit

Parameters

otherCurve Curve
The specified curve used to compute closest points to this curve.
withinThisCurveBounds Boolean
If this parameter is true only the solutions that are between this curve bounds will be returned. This curve must be bound if this parameter is true.
withinOtherCurveBounds Boolean
If this parameter is true only the solutions that are between other curve bounds will be returned. The other curve must be bound if this parameter is true.
returnAllCriticalPnts Boolean
The input parameter returnAllCriticalPnts is used to tell if all the critical points of the distance function are to be returned.
resultList IList ClosestPointsPairBetweenTwoCurves
Output parameter that will contain the results collection.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when otherCurve argument is null. Thrown when resultArray is null.
ArgumentsInconsistentException | Thrown when withinThisCurveBounds is true and this curve is unbounded. Thrown when withinOtherCurveBounds is true and other curve is unbounded.
InvalidOperationException | Thrown when the method failed. For example the problem has infinitely many solutions such as two parallel lines or two concentric circles, or in other singular cases that the method currently cannot handle, such as evaluating the closest points between a spline and a line, and the spline contains a flat segment (all points on the segment have zero curvature), and the closest points lie within that flat segment.
Remarks
The output list of closest points contains one entry for each pair of closest points. The following is the meaning of every ClosestPointsPairBetweenTwoCurves's members:
  • XYZPointOnFirstCurve is the closest point on the first curve;
  • XYZPointOnSecondCurve is the closest point on the second curve;
  • ParameterOnFirstCurve is the raw (not normalized) parameter on the first curve
  • ParameterOnSecondCurve is the raw (not normalized) parameter on the second curve
  • Distance is the distance from the closest point on the first curve to the closest point on the second curve.
See Also

Reference

Curve Class


Curve.ComputeDerivatives Method

CurveComputeDerivatives Method

Returns the vectors describing the curve at the specified parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Transform ComputeDerivatives(
    double parameter,
    bool normalized
)
Public Function ComputeDerivatives (
    parameter As Double,
    normalized As Boolean
) As Transform
public:
Transform^ ComputeDerivatives(
    double parameter,
    bool normalized
)
member ComputeDerivatives :
        parameter : float *
        normalized : bool -> Transform

Parameters

parameter Double
The parameter to be evaluated.
normalized Boolean
If false, param is interpreted as natural parameterization of the curve. If true, param is expected to be in [0,1] interval mapped to the bounds of the curve. Setting to true is valid only if the curve is bound.

Return Value

Transform
The transformation containing the point on the curve, the tangent vector, derivative of tangent vector, and bi-normal vector.
Exceptions
Exception | Condition
ArgumentException | The given value for parameter is not finite
ArgumentOutOfRangeException | The curve cannot be evaluated as normalized because it is unbound. -or- The parameter is not a valid value for normalized evaluation.
Remarks
The following is the meaning of the transformation members:
  • Origin is the point on the curve (equivalent to Evaluate(Double, Boolean)).
  • BasisX is the tangent vector (the first derivative).
  • BasisY is the second derivative. Note that for curves where this cannot be uniquely determined (e.g. lines), this will be a Zero vector.
  • BasisZ is the bi-normal vector (tangent x normal). Note that for curves where normal cannot be uniquely determined (e.g. lines), this will be a Zero vector.
None of the vectors are normalized.
See Also

Reference

Curve Class


Curve.ComputeNormalizedParameter Method

CurveComputeNormalizedParameter Method

Computes the normalized curve parameter from the raw parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double ComputeNormalizedParameter(
    double rawParameter
)
Public Function ComputeNormalizedParameter (
    rawParameter As Double
) As Double
public:
double ComputeNormalizedParameter(
    double rawParameter
)
member ComputeNormalizedParameter :
        rawParameter : float -> float

Parameters

rawParameter Double
The raw parameter.

Return Value

Double
The real number equal to the normalized curve parameter.
Exceptions
Exception | Condition
ArgumentException | Thrown when rawParameter is infinite.
InvalidOperationException | Thrown when the curve is unbound.
See Also

Reference

Curve Class


Curve.ComputeRawParameter Method

CurveComputeRawParameter Method

Computes the raw parameter from the normalized parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double ComputeRawParameter(
    double normalizedParameter
)
Public Function ComputeRawParameter (
    normalizedParameter As Double
) As Double
public:
double ComputeRawParameter(
    double normalizedParameter
)
member ComputeRawParameter :
        normalizedParameter : float -> float

Parameters

normalizedParameter Double
The normalized parameter.

Return Value

Double
The real number equal to the raw curve parameter.
Exceptions
Exception | Condition
ArgumentException | Thrown when normalizedParameter is infinite.
InvalidOperationException | Thrown when the curve is unbound.
See Also

Reference

Curve Class


Curve.CreateOffset Method

CurveCreateOffset Method

Creates a new curve that is an offset of the existing curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Curve CreateOffset(
    double offsetDist,
    XYZ referenceVector
)
Public Function CreateOffset (
    offsetDist As Double,
    referenceVector As XYZ
) As Curve
public:
Curve^ CreateOffset(
    double offsetDist,
    XYZ^ referenceVector
)
member CreateOffset :
        offsetDist : float *
        referenceVector : XYZ -> Curve

Parameters

offsetDist Double
The signed distance that controls the offset.
referenceVector XYZ
A reference vector to define the offset direction.

Return Value

Curve
The new curve.
Exceptions
Exception | Condition
InvalidOperationException | Cannot create the offset of the curve.
Remarks
The offset curve is obtained by moving the points of the given curve by a certain distance (not necessarily the input distance) to the right relative to the reference vector. If the distance is negative, then the offset will be actually on the left side. The precise role played by the reference vector depends on the curve type in an inconsistent way, as specified in detail below. We plan to update this function to have a more consistent and understandable behavior.

For Line, HermiteSpline, NurbSpline and Cylindrical Helix, the right direction is along the cross product of the tangent at that point and the reference vector. In other words, the "right" side of the curve at a given point on the curve is defined with the reference vector being thought of as the upward direction and curve tangent being thought of as the forward direction, as if you are walking along the curve with your body aligned to the reference vector.

For Arc and Ellipse, the right direction is defined relative to the axis of the arc or ellipse in conjunction with the reference vector. If the dot product of the reference vector with the axis is positive, then the right direction is along the cross product of the curve tangent the axis. If the dot product is negetive, then it is in the other way. If the dot product is zero, then it is an input error.

More details of the behavior depending on the type of curve:
  • Line: For a Line, a vecPerp is computed as the cross product of the line direction and the reference vector. The offset is obtained by moving the line by the given distance along the direction of the vecPerp. Note: vecPerp can be zero vector if the reference vector is parallel to the line direction. In that case, the offset is simply a copy of the given line. No error is reported.
  • Arc: For an Arc, the offset is done in the plane of the arc. The resulting offset is another arc in the same plane as the given arc and with the same center. The radius is increased or decreased by the offset distance depending on the offset is to the right or left. The reference vector is used to determine if the offset is to be done to the right or left of the arc, based on the dot product of the reference vector with the axis (normal vector) of the arc. If the dot product is positive then the offset is to the right relative to the axis of the arc; if not, it is to the left. If the dot product is zero, that is, reference vector is perpendicular to the axis, the function will return NULL and report an error.
  • Ellipse: An Ellipse is also a planar curve like the Arc. The offset is done in the plane of the ellipse. Note that the offset of an ellipse is not an ellipse in general. It will be approximated by a Hermite spline curve. The offset curve is obtained by offsetting the points of the ellipse, by the given offset distance, to the right or left relative to the axis (normal vector) of the ellipse. The reference vector is used to determine if the offset is to be done to the right or left of the ellipse, based on the dot product of the reference vector with the axis of the ellipse. If the dot product is positive then the offset is to the right relative to the axis of the ellipse; if not, it is to the left. If the dot product is zero, that is, reference vector is perpendicular to the axis, the function will return NULL and report an error.
  • HermiteSpline, NurbSpline and Cylindrical Helix: A Hermite or Nurbs spline curve can be planar or non-planar; a cylindrical helix is non-planar. For these three types of curves, the offset is computed in a general way as follows: Let P be a point on the given curve and let T be the unit tangent vector at P, assuming that the derivative of the curve at P is not zero. The offset vector at P is the cross product of T and the reference vector. Then the offset point Q corresponding to P is computed as: Q = P + (offset distance) * (offset vector at P). The offset depends on the magnitude as well as the direction of the reference vector. If the magnitude of the reference vector is not one, then the actual distance moved will not be the given offset distance. NOTE: If the curve is a planar Hermite or Nurbs spline curve, the offset curve may not lie on the same plane – unlike the case of arc and ellipse.
See Also

Reference

Curve Class


Curve.CreateReversed Method

CurveCreateReversed Method

Creates a new curve with the opposite orientation of the existing curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Curve CreateReversed()
Public Function CreateReversed As Curve
public:
Curve^ CreateReversed()
member CreateReversed : unit -> Curve

Return Value

Curve
The new curve.
See Also

Reference

Curve Class


Curve.CreateTransformed Method

CurveCreateTransformed Method

Crates a new instance of a curve as a transformation of this curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Curve CreateTransformed(
    Transform transform
)
Public Function CreateTransformed (
    transform As Transform
) As Curve
public:
Curve^ CreateTransformed(
    Transform^ transform
)
member CreateTransformed :
        transform : Transform -> Curve

Parameters

transform Transform
The transform to apply.

Return Value

Curve
The new curve.
Exceptions
Exception | Condition
ArgumentException | transform is not conformal.
ArgumentNullException | A non-optional argument was NULL
See Also

Reference

Curve Class


Curve.Distance Method

CurveDistance Method

Returns the shortest distance from the specified point to this curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Distance(
    XYZ point
)
Public Function Distance (
    point As XYZ
) As Double
public:
double Distance(
    XYZ^ point
)
member Distance :
        point : XYZ -> float

Parameters

point XYZ
The specified point.

Return Value

Double
The real number equal to the shortest distance.
Exceptions
Exception | Condition
InvalidOperationException | Thrown when failed to find the closest point on the curve.
Remarks
Returns the distance from the closest point on the curve to the specified point.
See Also

Reference

Curve Class


Curve.Evaluate Method

CurveEvaluate Method

Evaluates and returns the point that matches a parameter along the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Evaluate(
    double parameter,
    bool normalized
)
Public Function Evaluate (
    parameter As Double,
    normalized As Boolean
) As XYZ
public:
XYZ^ Evaluate(
    double parameter,
    bool normalized
)
member Evaluate :
        parameter : float *
        normalized : bool -> XYZ

Parameters

parameter Double
The parameter to be evaluated.
normalized Boolean
If false, param is interpreted as natural parameterization of the curve. If true, param is expected to be in [0,1] interval mapped to the bounds of the curve. Setting to true is valid only if the curve is bound.

Return Value

XYZ
The point evaluated along the curve.
Exceptions
Exception | Condition
ArgumentException | The given value for parameter is not finite
ArgumentOutOfRangeException | The curve cannot be evaluated as normalized because it is unbound. -or- The parameter is not a valid value for normalized evaluation.
See Also

Reference

Curve Class


Curve.GetEndParameter Method

CurveGetEndParameter Method

Returns the raw parameter value at the start or end of this curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetEndParameter(
    int index
)
Public Function GetEndParameter (
    index As Integer
) As Double
public:
double GetEndParameter(
    int index
)
member GetEndParameter :
        index : int -> float

Parameters

index Int32
0 for the start or 1 for end of the curve.

Return Value

Double
The parameter.
Exceptions
Exception | Condition
ArgumentException | curve is unbound and does not have start and end points. -or- index must be 0 for the start of the curve or 1 for the end.
ArgumentNullException | A non-optional argument was NULL
Remarks
The start and end value of the parameter can be any value (as it is determined by the system based on the inputs). For curves with regular curvature like lines and arcs, the raw parameter can be used to measure along the curve in Revit's default units (feet). Raw parameters are also the only way to evaluate points along unbound curves.
See Also

Reference

Curve Class


Curve.GetEndPoint Method

CurveGetEndPoint Method

Returns the 3D point at the start or end of this curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ GetEndPoint(
    int index
)
Public Function GetEndPoint (
    index As Integer
) As XYZ
public:
XYZ^ GetEndPoint(
    int index
)
member GetEndPoint :
        index : int -> XYZ

Parameters

index Int32
0 for the start or 1 for end of the curve.

Return Value

XYZ
The curve endpoint.
Exceptions
Exception | Condition
ArgumentException | curve is unbound and does not have start and end points. -or- index must be 0 for the start of the curve or 1 for the end.
ArgumentNullException | A non-optional argument was NULL
See Also

Reference

Curve Class


Curve.GetEndPointReference Method

CurveGetEndPointReference Method

Returns a stable reference to the start point or the end point of the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Reference GetEndPointReference(
    int index
)
Public Function GetEndPointReference (
    index As Integer
) As Reference
public:
Reference^ GetEndPointReference(
    int index
)
member GetEndPointReference :
        index : int -> Reference

Parameters

index Int32
Use 0 for the start point; 1 for the end point.

Return Value

Reference
Reference to the point or if reference cannot be obtained.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown when the specified index is not 0 or 1.
InvalidOperationException | Thrown when the object is internally marked as read-only or this curve is unbound.
See Also

Reference

Curve Class


Curve.Intersect Method

CurveIntersect Method

Calculates the intersection of this curve with the specified curve.
Overload List
 | Name | Description
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve.
Public method | Intersect(Curve, IntersectionResultArray) | Calculates the intersection of this curve with the specified curve and returns the intersection results.
Top
See Also

Reference

Curve Class


Curve.Intersect(Curve) Method

CurveIntersect(Curve) Method

Calculates the intersection of this curve with the specified curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SetComparisonResult Intersect(
    Curve curve
)
Public Function Intersect (
    curve As Curve
) As SetComparisonResult
public:
SetComparisonResult Intersect(
    Curve^ curve
)
member Intersect :
        curve : Curve -> SetComparisonResult

Parameters

curve Curve
The specified curve to intersect with this curve.

Return Value

SetComparisonResult
  • SetComparisonResult.Overlap - One or more intersections were encountered.
  • SetComparisonResult.Subset - The inputs are parallel lines with only one common intersection point, or the curve used to invoke the intersection check is a line entirely within the unbound line passed as argument curve.
  • SetComparisonResult.Superset - The input curve is entirely within the unbound line used to invoke the intersection check.
  • SetComparisonResult.Disjoint - There is no intersection found between the two curves.
  • SetComparisonResult.Equal - The two curves are identical.
Exceptions
Exception | Condition
ArgumentNullException | The specified curve is .
InvalidOperationException | Failed to calculate the intersection.
See Also

Reference

Curve Class
Intersect Overload


Curve.Intersect(Curve, IntersectionResultArray) Method

CurveIntersect(Curve, IntersectionResultArray) Method

Calculates the intersection of this curve with the specified curve and returns the intersection results.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SetComparisonResult Intersect(
    Curve curve,
    out IntersectionResultArray resultArray
)
Public Function Intersect (
    curve As Curve,
    <OutAttribute> ByRef resultArray As IntersectionResultArray
) As SetComparisonResult
public:
SetComparisonResult Intersect(
    Curve^ curve,
    [OutAttribute] IntersectionResultArray^% resultArray
)
member Intersect :
        curve : Curve *
        resultArray : IntersectionResultArray byref -> SetComparisonResult

Parameters

curve Curve
The specified curve to intersect with this curve.
resultArray IntersectionResultArray
Provides more information about the intersection.

Return Value

SetComparisonResult
  • SetComparisonResult.Overlap - One or more intersections were encountered. The output argument has the details.
  • SetComparisonResult.Subset - The inputs are parallel lines with only one common intersection point, or the curve used to invoke the intersection check is a line entirely within the unbound line passed as argument curve. If the former, the output argument has the details of the intersection point.
  • SetComparisonResult.Superset - The input curve is entirely within the unbound line used to invoke the intersection check.
  • SetComparisonResult.Disjoint - There is no intersection found between the two curves.
  • SetComparisonResult.Equal - The two curves are identical.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the specified curve is .
InvalidOperationException | Thrown when failed to calculate the intersection.
Remarks
The array of the intersection results contains one entry for each point where curves intersect. The following is the meaning of IntersectionResult members:
  • XYZPoint is the evaluated intersection point
  • UVPoint.U is the unnormalized parameter on this curve (use ComputeNormalizedParameter to compute the normalized value).
  • UVPoint.V is the unnormalized parameter on the specified curve (use ComputeNormalizedParameter to compute the normalized value).
See Also

Reference

Curve Class
Intersect Overload


Curve.IsInside Method

CurveIsInside Method

Indicates whether the specified parameter value is within this curve's bounds.
Overload List
 | Name | Description
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds.
Public method | IsInside(Double, Int32) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index.
Top
See Also

Reference

Curve Class


Curve.IsInside(Double) Method

CurveIsInside(Double) Method

Indicates whether the specified parameter value is within this curve's bounds.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsInside(
    double parameter
)
Public Function IsInside (
    parameter As Double
) As Boolean
public:
bool IsInside(
    double parameter
)
member IsInside :
        parameter : float -> bool

Parameters

parameter Double
The raw curve parameter to be evaluated.

Return Value

Boolean
True if the parameter is within the bounds, otherwise false.
Exceptions
Exception | Condition
ArgumentException | Thrown when the specified parameter is infinite.
Remarks
Always returns true if this curve is unbound.
See Also

Reference

Curve Class
IsInside Overload


Curve.IsInside(Double, Int32) Method

CurveIsInside(Double, Int32) Method

Indicates whether the specified parameter value is within this curve's bounds and outputs the end index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsInside(
    double parameter,
    out int end
)
Public Function IsInside (
    parameter As Double,
    <OutAttribute> ByRef end As Integer
) As Boolean
public:
bool IsInside(
    double parameter,
    [OutAttribute] int% end
)
member IsInside :
        parameter : float *
        end : int byref -> bool

Parameters

parameter Double
The raw curve parameter to be evaluated.
end Int32
The end index is equal to 0 for the start point, 1 for the end point, or -1 if the parameter is not at the end.

Return Value

Boolean
True if the parameter is within the curve's bounds, otherwise false.
Remarks
Always returns true if this curve is unbound.
See Also

Reference

Curve Class
IsInside Overload


Curve.MakeBound Method

CurveMakeBound Method

Changes the bounds of this curve to the specified values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void MakeBound(
    double startParameter,
    double endParameter
)
Public Sub MakeBound (
    startParameter As Double,
    endParameter As Double
)
public:
void MakeBound(
    double startParameter,
    double endParameter
)
member MakeBound :
        startParameter : float *
        endParameter : float -> unit

Parameters

startParameter Double
The new parameter of the start point.
endParameter Double
The new parameter of the end point.
Exceptions
Exception | Condition
ArgumentException | Thrown when the specified values are infinite.
InvalidOperationException | Thrown when endParameter is smaller than startParameter.
Remarks
If the curve is marked as read-only (because it was extracted directly from a Revit element or collection/aggregation object), calling this method causes the object to be changed to carry a disconnected copy of the original curve. The modification will not affect the original curve or the object that supplied it.
See Also

Reference

Curve Class


Curve.MakeUnbound Method

CurveMakeUnbound Method

Makes this curve unbound.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void MakeUnbound()
Public Sub MakeUnbound
public:
void MakeUnbound()
member MakeUnbound : unit -> unit
Remarks
If the curve is marked as read-only (because it was extracted directly from a Revit element or collection/aggregation object), calling this method causes the object to be changed to carry a disconnected copy of the original curve. The modification will not affect the original curve or the object that supplied it.
See Also

Reference

Curve Class


Curve.Project Method

CurveProject Method

Projects the specified point on this curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IntersectionResult Project(
    XYZ point
)
Public Function Project (
    point As XYZ
) As IntersectionResult
public:
IntersectionResult^ Project(
    XYZ^ point
)
member Project :
        point : XYZ -> IntersectionResult

Parameters

point XYZ
The point to be projected.

Return Value

IntersectionResult
Geometric information if projection is successful.
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the curve is an arc and either its radius is zero or the input point is the center of the arc. Thrown when the curve is an elliptical arc and the input point is one of the foci of the elliptical arc.
Remarks
The following is the meaning of every IntersectionResult's members:
  • XYZPoint is the nearest point on the curve;
  • Parameter is the unnormalized parameter on the curve (use ComputeNormalizedParameter to compute the normalized value)
  • Distance is the distance from the point to the curve (equivalent to Distance).
See Also

Reference

Curve Class


Curve.SetGraphicsStyleId Method

CurveSetGraphicsStyleId Method

Sets the graphics style id for this curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetGraphicsStyleId(
    ElementId id
)
Public Sub SetGraphicsStyleId (
    id As ElementId
)
public:
void SetGraphicsStyleId(
    ElementId^ id
)
member SetGraphicsStyleId :
        id : ElementId -> unit

Parameters

id ElementId
The id of the GraphicsStyle element from which to apply the curve properties.
Remarks

If the curve is marked as read-only (because it was extracted directly from a Revit element or collection/aggregation object), calling this method causes the object to be changed to carry a disconnected copy of the original curve. The modification will not affect the original curve or the object that supplied it.

Many methods in the Revit API will not use the graphics style associated to this curve. For example, curves used as portions of the sketch of an element will not read this property. Newly created curve elements will not use this value either, as they inherit their graphical properties from their associated category.

See Also

Reference

Curve Class


Curve.Tessellate Method

CurveTessellate Method

Valid only if the curve is bound. Returns a polyline approximation to the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<XYZ> Tessellate()
Public Function Tessellate As IList(Of XYZ)
public:
IList<XYZ^>^ Tessellate()
member Tessellate : unit -> IList<XYZ>

Return Value

IList XYZ
Remarks
Tolerance of approximation is defined internally by Revit to be adequate for display purposes.
See Also

Reference

Curve Class


CurveArrArray Class

An array that can contain any type of object.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBCurveArrArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CurveArrArray : APIObject,
    IEnumerable
Public Class CurveArrArray
    Inherits APIObject
    Implements IEnumerable
public ref class CurveArrArray : public APIObject,
    IEnumerable
type CurveArrArray =
    class
        inherit APIObject
        interface IEnumerable
    end

The CurveArrArray type exposes the following members.

Constructors
 | Name | Description
Public method | CurveArrArray | Initializes a new instance of the CurveArrArray class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.
Top
Methods
 | Name | Description
Public method | Append |
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CurveArrArray Constructor

Initializes a new instance of the CurveArrArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurveArrArray()
Public Sub New
public:
CurveArrArray()
new : unit -> CurveArrArray
See Also

Reference

CurveArrArray Class


CurveArrArray Properties

The CurveArrArray type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.
Top
See Also

Reference

CurveArrArray Class


CurveArrArray.IsEmpty Property

CurveArrArrayIsEmpty Property

Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Boolean
Remarks
If the array is empty then True will be returned, otherwise False.
See Also

Reference

CurveArrArray Class


CurveArrArray.Item Property

CurveArrArrayItem Property

Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual CurveArray this[
    int index
] { get; set; }
Public Overridable Property Item (
    index As Integer
) As CurveArray
    Get
    Set
public:
virtual property CurveArray^ Item[int index] {
    CurveArray^ get (int index);
    void set (int index, CurveArray^ value);
}
abstract Item : CurveArray with get, set
override Item : CurveArray with get, set

Parameters

index Int32
The index of the item to be set or retrieved.

Return Value

CurveArray
Returns the object at the specified index.
See Also

Reference

CurveArrArray Class


CurveArrArray.Size Property

CurveArrArraySize Property

Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
abstract Size : int with get
override Size : int with get

Property Value

Int32
See Also

Reference

CurveArrArray Class


CurveArrArray Methods

The CurveArrArray type exposes the following members.

Methods
 | Name | Description
Public method | Append |
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CurveArrArray Class


CurveArrArray.Append Method

CurveArrArrayAppend Method

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Append(
    CurveArray item
)
Public Overridable Sub Append (
    item As CurveArray
)
public:
virtual void Append(
    CurveArray^ item
)
abstract Append :
        item : CurveArray -> unit
override Append :
        item : CurveArray -> unit

Parameters

item CurveArray
See Also

Reference

CurveArrArray Class


CurveArrArray.Clear Method

CurveArrArrayClear Method

Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

CurveArrArray Class


CurveArrArray.ForwardIterator Method

CurveArrArrayForwardIterator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual CurveArrArrayIterator ForwardIterator()
Public Overridable Function ForwardIterator As CurveArrArrayIterator
public:
virtual CurveArrArrayIterator^ ForwardIterator()
abstract ForwardIterator : unit -> CurveArrArrayIterator
override ForwardIterator : unit -> CurveArrArrayIterator

Return Value

CurveArrArrayIterator
Returns a forward moving iterator to the array.
See Also

Reference

CurveArrArray Class


CurveArrArray.GetEnumerator Method

CurveArrArrayGetEnumerator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

IEnumerator
Returns a forward moving iterator to the array.

Implements

IEnumerableGetEnumerator
See Also

Reference

CurveArrArray Class


CurveArrArray.Insert Method

CurveArrArrayInsert Method

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Insert(
    CurveArray item,
    int index
)
Public Overridable Sub Insert (
    item As CurveArray,
    index As Integer
)
public:
virtual void Insert(
    CurveArray^ item,
    int index
)
abstract Insert :
        item : CurveArray *
        index : int -> unit
override Insert :
        item : CurveArray *
        index : int -> unit

Parameters

item CurveArray
index Int32
See Also

Reference

CurveArrArray Class


CurveArrArray.ReverseIterator Method

CurveArrArrayReverseIterator Method

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual CurveArrArrayIterator ReverseIterator()
Public Overridable Function ReverseIterator As CurveArrArrayIterator
public:
virtual CurveArrArrayIterator^ ReverseIterator()
abstract ReverseIterator : unit -> CurveArrArrayIterator
override ReverseIterator : unit -> CurveArrArrayIterator

Return Value

CurveArrArrayIterator
Returns a backward moving iterator to the array.
See Also

Reference

CurveArrArray Class


CurveArrArrayIterator Class

An iterator to a array.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBCurveArrArrayIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class CurveArrArrayIterator : APIObject,
    IEnumerator
Public MustInherit Class CurveArrArrayIterator
    Inherits APIObject
    Implements IEnumerator
public ref class CurveArrArrayIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type CurveArrArrayIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The CurveArrArrayIterator type exposes the following members.

Constructors
 | Name | Description
Public method | CurveArrArrayIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CurveArrArrayIterator Constructor

For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurveArrArrayIterator()
Public Sub New
public:
CurveArrArrayIterator()
new : unit -> CurveArrArrayIterator
Remarks
This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.
See Also

Reference

CurveArrArrayIterator Class


CurveArrArrayIterator Properties

The CurveArrArrayIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

CurveArrArrayIterator Class


CurveArrArrayIterator.Current Property

CurveArrArrayIteratorCurrent Property

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}
abstract Current : Object with get
override Current : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.
See Also

Reference

CurveArrArrayIterator Class


CurveArrArrayIterator Methods

The CurveArrArrayIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CurveArrArrayIterator Class


CurveArrArrayIterator.MoveNext Method

CurveArrArrayIteratorMoveNext Method

Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumeratorMoveNext
Remarks
MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.
See Also

Reference

CurveArrArrayIterator Class


CurveArrArrayIterator.Reset Method

CurveArrArrayIteratorReset Method

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
Remarks
The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.
See Also

Reference

CurveArrArrayIterator Class


CurveArray Class

An array that can contain curves.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBCurveArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CurveArray : APIObject, IEnumerable
Public Class CurveArray
    Inherits APIObject
    Implements IEnumerable
public ref class CurveArray : public APIObject,
    IEnumerable
type CurveArray =
    class
        inherit APIObject
        interface IEnumerable
    end

The CurveArray type exposes the following members.

Constructors
 | Name | Description
Public method | CurveArray | Initializes a new instance of the CurveArray class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets a curve at a specified index within the array.
Public property | Size | Returns the number of curves that are in the array.
Top
Methods
 | Name | Description
Public method | Append | Add the curve to the end of the array.
Public method | Clear | Removes every curve from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified curve into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CurveArray Constructor

Initializes a new instance of the CurveArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurveArray()
Public Sub New
public:
CurveArray()
new : unit -> CurveArray
See Also

Reference

CurveArray Class


CurveArray Properties

The CurveArray type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets a curve at a specified index within the array.
Public property | Size | Returns the number of curves that are in the array.
Top
See Also

Reference

CurveArray Class


CurveArray.IsEmpty Property

CurveArrayIsEmpty Property

Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Boolean
Remarks
If the array is empty then True will be returned, otherwise False.
See Also

Reference

CurveArray Class


CurveArray.Item Property

CurveArrayItem Property

Gets or sets a curve at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Curve this[
    int index
] { get; set; }
Public Overridable Property Item (
    index As Integer
) As Curve
    Get
    Set
public:
virtual property Curve^ Item[int index] {
    Curve^ get (int index);
    void set (int index, Curve^ value);
}
abstract Item : Curve with get, set
override Item : Curve with get, set

Parameters

index Int32
The index of the curve to be set or retrieved.

Return Value

Curve
Returns the curve at the specified index.
See Also

Reference

CurveArray Class


CurveArray.Size Property

CurveArraySize Property

Returns the number of curves that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
abstract Size : int with get
override Size : int with get

Property Value

Int32
See Also

Reference

CurveArray Class


CurveArray Methods

The CurveArray type exposes the following members.

Methods
 | Name | Description
Public method | Append | Add the curve to the end of the array.
Public method | Clear | Removes every curve from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified curve into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CurveArray Class


CurveArray.Append Method

CurveArrayAppend Method

Add the curve to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Append(
    Curve item
)
Public Overridable Sub Append (
    item As Curve
)
public:
virtual void Append(
    Curve^ item
)
abstract Append :
        item : Curve -> unit
override Append :
        item : Curve -> unit

Parameters

item Curve
The curve to be added.
See Also

Reference

CurveArray Class


CurveArray.Clear Method

CurveArrayClear Method

Removes every curve from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

CurveArray Class


CurveArray.ForwardIterator Method

CurveArrayForwardIterator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual CurveArrayIterator ForwardIterator()
Public Overridable Function ForwardIterator As CurveArrayIterator
public:
virtual CurveArrayIterator^ ForwardIterator()
abstract ForwardIterator : unit -> CurveArrayIterator
override ForwardIterator : unit -> CurveArrayIterator

Return Value

CurveArrayIterator
Returns a forward moving iterator to the array.
See Also

Reference

CurveArray Class


CurveArray.GetEnumerator Method

CurveArrayGetEnumerator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

IEnumerator
Returns a forward moving iterator to the array.

Implements

IEnumerableGetEnumerator
See Also

Reference

CurveArray Class


CurveArray.Insert Method

CurveArrayInsert Method

Insert the specified curve into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Insert(
    Curve item,
    int index
)
Public Overridable Sub Insert (
    item As Curve,
    index As Integer
)
public:
virtual void Insert(
    Curve^ item,
    int index
)
abstract Insert :
        item : Curve *
        index : int -> unit
override Insert :
        item : Curve *
        index : int -> unit

Parameters

item Curve
The curve to be inserted into the array.
index Int32
The curve will be inserted before this index.

Return Value

Returns whether the curve was inserted into the array.
See Also

Reference

CurveArray Class


CurveArray.ReverseIterator Method

CurveArrayReverseIterator Method

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual CurveArrayIterator ReverseIterator()
Public Overridable Function ReverseIterator As CurveArrayIterator
public:
virtual CurveArrayIterator^ ReverseIterator()
abstract ReverseIterator : unit -> CurveArrayIterator
override ReverseIterator : unit -> CurveArrayIterator

Return Value

CurveArrayIterator
Returns a backward moving iterator to the array.
See Also

Reference

CurveArray Class


CurveArrayIterator Class

An iterator to a curve array.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBCurveArrayIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class CurveArrayIterator : APIObject,
    IEnumerator
Public MustInherit Class CurveArrayIterator
    Inherits APIObject
    Implements IEnumerator
public ref class CurveArrayIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type CurveArrayIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The CurveArrayIterator type exposes the following members.

Constructors
 | Name | Description
Public method | CurveArrayIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CurveArrayIterator Constructor

For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurveArrayIterator()
Public Sub New
public:
CurveArrayIterator()
new : unit -> CurveArrayIterator
Remarks
This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.
See Also

Reference

CurveArrayIterator Class


CurveArrayIterator Properties

The CurveArrayIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

CurveArrayIterator Class


CurveArrayIterator.Current Property

CurveArrayIteratorCurrent Property

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}
abstract Current : Object with get
override Current : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.
See Also

Reference

CurveArrayIterator Class


CurveArrayIterator Methods

The CurveArrayIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CurveArrayIterator Class


CurveArrayIterator.MoveNext Method

CurveArrayIteratorMoveNext Method

Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumeratorMoveNext
Remarks
MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.
See Also

Reference

CurveArrayIterator Class


CurveArrayIterator.Reset Method

CurveArrayIteratorReset Method

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
Remarks
The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.
See Also

Reference

CurveArrayIterator Class


CurveByPoints Class

A curve interpolating two or more points.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBCurveElement
Autodesk.Revit.DBCurveByPoints

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CurveByPoints : CurveElement
Public Class CurveByPoints
    Inherits CurveElement
public ref class CurveByPoints : public CurveElement
type CurveByPoints =
    class
        inherit CurveElement
    end

The CurveByPoints type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CurveElementType | Type of the curve element. (Inherited from CurveElement)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsReferenceLine |
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ReferenceType | Indicates the type of reference.
Public property | SketchPlane | Override the SketchPlane property of CurveElement. (Overrides CurveElementSketchPlane)
Public property | Subcategory | The subcategory, or graphics style, of the CurveByPoints.
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element. (Inherited from CurveElement)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | Visible | Whether the point is visible when the family is loaded into a project.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPoints | Get the sequence of points interpolated by this curve.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetVisibility | Gets the visibility.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement)
Public method | SetPoints | Change the sequence of points interpolated by this curve.
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement)
Public method | SetVisibility | Sets the visibility.
 | SortPoints | Order a set of ReferencePoints in the same way Revit does when creating a curve from points.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The points to be interpolated are represented as ReferencePoints, which must already exist in the document. In terms of appearance and graphics control, CurveByPoints behaves similarly to ModelCurve. The main difference being that a ModelCurve refers to a SketchPlane, while a CurveByPoints does not. For more methods capable of accessing data from CurveByPoints elements, see the static class CurveByPointsUtils.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CurveByPoints Properties

The CurveByPoints type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CurveElementType | Type of the curve element. (Inherited from CurveElement)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsReferenceLine |
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ReferenceType | Indicates the type of reference.
Public property | SketchPlane | Override the SketchPlane property of CurveElement. (Overrides CurveElementSketchPlane)
Public property | Subcategory | The subcategory, or graphics style, of the CurveByPoints.
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element. (Inherited from CurveElement)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | Visible | Whether the point is visible when the family is loaded into a project.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

CurveByPoints Class


CurveByPoints.IsReferenceLine Property

CurveByPointsIsReferenceLine Property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsReferenceLine { get; set; }
Public Property IsReferenceLine As Boolean
    Get
    Set
public:
property bool IsReferenceLine {
    bool get ();
    void set (bool value);
}
member IsReferenceLine : bool with get, set

Property Value

Boolean
See Also

Reference

CurveByPoints Class


CurveByPoints.ReferenceType Property

CurveByPointsReferenceType Property

Indicates the type of reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReferenceType ReferenceType { get; set; }
Public Property ReferenceType As ReferenceType
    Get
    Set
public:
property ReferenceType ReferenceType {
    ReferenceType get ();
    void set (ReferenceType value);
}
member ReferenceType : ReferenceType with get, set

Property Value

ReferenceType
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown when argument is out of range.
InvalidOperationException | Thrown when regeneration failed.
See Also

Reference

CurveByPoints Class


CurveByPoints.SketchPlane Property

CurveByPointsSketchPlane Property

Override the SketchPlane property of CurveElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override SketchPlane SketchPlane { get; set; }
Public Overrides Property SketchPlane As SketchPlane
    Get
    Set
public:
virtual property SketchPlane^ SketchPlane {
    SketchPlane^ get () override;
    void set (SketchPlane^ value) override;
}
abstract SketchPlane : SketchPlane with get, set
override SketchPlane : SketchPlane with get, set

Property Value

SketchPlane
Remarks
CurveByPoints has no associated SketchPlane. Getting this property returns . Setting it causes an InvalidOperationException.
See Also

Reference

CurveByPoints Class


CurveByPoints.Subcategory Property

CurveByPointsSubcategory Property

The subcategory, or graphics style, of the CurveByPoints.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GraphicsStyle Subcategory { get; set; }
Public Property Subcategory As GraphicsStyle
    Get
    Set
public:
property GraphicsStyle^ Subcategory {
    GraphicsStyle^ get ();
    void set (GraphicsStyle^ value);
}
member Subcategory : GraphicsStyle with get, set

Property Value

GraphicsStyle
Remarks
If the family category is non-cuttable, the subcategory can be set to be the family category or one of its subcategories. If the family category is cuttable, the subcategory can be set as the graphics styles of the family category, its subcategories, or the invisible lines graphics style.
See Also

Reference

CurveByPoints Class


CurveByPoints.Visible Property

CurveByPointsVisible Property

Whether the point is visible when the family is loaded into a project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Visible { get; set; }
Public Property Visible As Boolean
    Get
    Set
public:
property bool Visible {
    bool get ();
    void set (bool value);
}
member Visible : bool with get, set

Property Value

Boolean
See Also

Reference

CurveByPoints Class


CurveByPoints Methods

The CurveByPoints type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPoints | Get the sequence of points interpolated by this curve.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetVisibility | Gets the visibility.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement)
Public method | SetPoints | Change the sequence of points interpolated by this curve.
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement)
Public method | SetVisibility | Sets the visibility.
 | SortPoints | Order a set of ReferencePoints in the same way Revit does when creating a curve from points.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CurveByPoints Class


CurveByPoints.GetPoints Method

CurveByPointsGetPoints Method

Get the sequence of points interpolated by this curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReferencePointArray GetPoints()
Public Function GetPoints As ReferencePointArray
public:
ReferencePointArray^ GetPoints()
member GetPoints : unit -> ReferencePointArray

Return Value

ReferencePointArray
See Also

Reference

CurveByPoints Class


CurveByPoints.GetVisibility Method

CurveByPointsGetVisibility Method

Gets the visibility.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyElementVisibility GetVisibility()
Public Function GetVisibility As FamilyElementVisibility
public:
FamilyElementVisibility^ GetVisibility()
member GetVisibility : unit -> FamilyElementVisibility

Return Value

FamilyElementVisibility
A copy of visibility settings for the curve.
See Also

Reference

CurveByPoints Class


CurveByPoints.SetPoints Method

CurveByPointsSetPoints Method

Change the sequence of points interpolated by this curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetPoints(
    ReferencePointArray points
)
Public Sub SetPoints (
    points As ReferencePointArray
)
public:
void SetPoints(
    ReferencePointArray^ points
)
member SetPoints :
        points : ReferencePointArray -> unit

Parameters

points ReferencePointArray
An array of 2 or more ReferencePoints.
Exceptions
Exception | Condition
ArgumentException | Thrown when the array contains fewer than 2 points, when the array contains duplicates, or when adjacent points are located too close together.
See Also

Reference

CurveByPoints Class


CurveByPoints.SetVisibility Method

CurveByPointsSetVisibility Method

Sets the visibility.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetVisibility(
    FamilyElementVisibility visibility
)
Public Sub SetVisibility (
    visibility As FamilyElementVisibility
)
public:
void SetVisibility(
    FamilyElementVisibility^ visibility
)
member SetVisibility :
        visibility : FamilyElementVisibility -> unit

Parameters

visibility FamilyElementVisibility
Exceptions
Exception | Condition
ArgumentNullException | Thrown when visibility is .
InvalidOperationException | Thrown when regeneration failed.
Remarks
The visibility of the CurveByPoints can be changed for different types of views and detail levels in the project.
See Also

Reference

CurveByPoints Class


CurveByPoints.SortPoints Method

CurveByPointsSortPoints Method

Order a set of ReferencePoints in the same way Revit does when creating a curve from points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool SortPoints(
    ReferencePointArray arr
)
Public Shared Function SortPoints (
    arr As ReferencePointArray
) As Boolean
public:
static bool SortPoints(
    ReferencePointArray^ arr
)
static member SortPoints :
        arr : ReferencePointArray -> bool

Parameters

arr ReferencePointArray
An array of ReferencePoints. The array is reordered if sortPoints returns true, and is unchanged if sortPoints returns false.

Return Value

Boolean
False if the least-squares method is unable to find a solution; true otherwise.
Remarks
Finds a best-fit line to the points by the least squares method, and orders the points by their projection onto the line.
See Also

Reference

CurveByPoints Class


CurveByPointsArray Class

An array that can contain CurveByPoints elements.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBCurveByPointsArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CurveByPointsArray : APIObject,
    IEnumerable
Public Class CurveByPointsArray
    Inherits APIObject
    Implements IEnumerable
public ref class CurveByPointsArray : public APIObject,
    IEnumerable
type CurveByPointsArray =
    class
        inherit APIObject
        interface IEnumerable
    end

The CurveByPointsArray type exposes the following members.

Constructors
 | Name | Description
Public method | CurveByPointsArray | Initializes a new instance of the CurveByPointsArray class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets a curve at a specified index within the array.
Public property | Size | Returns the number of curves that are in the array.
Top
Methods
 | Name | Description
Public method | Append |
Public method | Clear | Removes every curve from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CurveByPointsArray Constructor

Initializes a new instance of the CurveByPointsArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurveByPointsArray()
Public Sub New
public:
CurveByPointsArray()
new : unit -> CurveByPointsArray
See Also

Reference

CurveByPointsArray Class


CurveByPointsArray Properties

The CurveByPointsArray type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets a curve at a specified index within the array.
Public property | Size | Returns the number of curves that are in the array.
Top
See Also

Reference

CurveByPointsArray Class


CurveByPointsArray.IsEmpty Property

CurveByPointsArrayIsEmpty Property

Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Boolean
Remarks
If the array is empty then True will be returned, otherwise False.
See Also

Reference

CurveByPointsArray Class


CurveByPointsArray.Item Property

CurveByPointsArrayItem Property

Gets or sets a curve at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual CurveByPoints this[
    int index
] { get; set; }
Public Overridable Property Item (
    index As Integer
) As CurveByPoints
    Get
    Set
public:
virtual property CurveByPoints^ Item[int index] {
    CurveByPoints^ get (int index);
    void set (int index, CurveByPoints^ value);
}
abstract Item : CurveByPoints with get, set
override Item : CurveByPoints with get, set

Parameters

index Int32
The index of the curve to be set or retrieved.

Return Value

CurveByPoints
Returns the curve at the specified index.
See Also

Reference

CurveByPointsArray Class


CurveByPointsArray.Size Property

CurveByPointsArraySize Property

Returns the number of curves that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
abstract Size : int with get
override Size : int with get

Property Value

Int32
See Also

Reference

CurveByPointsArray Class


CurveByPointsArray Methods

The CurveByPointsArray type exposes the following members.

Methods
 | Name | Description
Public method | Append |
Public method | Clear | Removes every curve from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CurveByPointsArray Class


CurveByPointsArray.Append Method

CurveByPointsArrayAppend Method

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Append(
    CurveByPoints item
)
Public Overridable Sub Append (
    item As CurveByPoints
)
public:
virtual void Append(
    CurveByPoints^ item
)
abstract Append :
        item : CurveByPoints -> unit
override Append :
        item : CurveByPoints -> unit

Parameters

item CurveByPoints
See Also

Reference

CurveByPointsArray Class


CurveByPointsArray.Clear Method

CurveByPointsArrayClear Method

Removes every curve from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

CurveByPointsArray Class


CurveByPointsArray.ForwardIterator Method

CurveByPointsArrayForwardIterator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual CurveByPointsArrayIterator ForwardIterator()
Public Overridable Function ForwardIterator As CurveByPointsArrayIterator
public:
virtual CurveByPointsArrayIterator^ ForwardIterator()
abstract ForwardIterator : unit -> CurveByPointsArrayIterator
override ForwardIterator : unit -> CurveByPointsArrayIterator

Return Value

CurveByPointsArrayIterator
Returns a forward moving iterator to the array.
See Also

Reference

CurveByPointsArray Class


CurveByPointsArray.GetEnumerator Method

CurveByPointsArrayGetEnumerator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

IEnumerator
Returns a forward moving iterator to the array.

Implements

IEnumerableGetEnumerator
See Also

Reference

CurveByPointsArray Class


CurveByPointsArray.Insert Method

CurveByPointsArrayInsert Method

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Insert(
    CurveByPoints item,
    int index
)
Public Overridable Sub Insert (
    item As CurveByPoints,
    index As Integer
)
public:
virtual void Insert(
    CurveByPoints^ item,
    int index
)
abstract Insert :
        item : CurveByPoints *
        index : int -> unit
override Insert :
        item : CurveByPoints *
        index : int -> unit

Parameters

item CurveByPoints
index Int32
See Also

Reference

CurveByPointsArray Class


CurveByPointsArray.ReverseIterator Method

CurveByPointsArrayReverseIterator Method

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual CurveByPointsArrayIterator ReverseIterator()
Public Overridable Function ReverseIterator As CurveByPointsArrayIterator
public:
virtual CurveByPointsArrayIterator^ ReverseIterator()
abstract ReverseIterator : unit -> CurveByPointsArrayIterator
override ReverseIterator : unit -> CurveByPointsArrayIterator

Return Value

CurveByPointsArrayIterator
Returns a backward moving iterator to the array.
See Also

Reference

CurveByPointsArray Class


CurveByPointsArrayIterator Class

An iterator to a CurveByPoints array.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBCurveByPointsArrayIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class CurveByPointsArrayIterator : APIObject,
    IEnumerator
Public MustInherit Class CurveByPointsArrayIterator
    Inherits APIObject
    Implements IEnumerator
public ref class CurveByPointsArrayIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type CurveByPointsArrayIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The CurveByPointsArrayIterator type exposes the following members.

Constructors
 | Name | Description
Public method | CurveByPointsArrayIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CurveByPointsArrayIterator Constructor

For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurveByPointsArrayIterator()
Public Sub New
public:
CurveByPointsArrayIterator()
new : unit -> CurveByPointsArrayIterator
Remarks
This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.
See Also

Reference

CurveByPointsArrayIterator Class


CurveByPointsArrayIterator Properties

The CurveByPointsArrayIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

CurveByPointsArrayIterator Class


CurveByPointsArrayIterator.Current Property

CurveByPointsArrayIteratorCurrent Property

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}
abstract Current : Object with get
override Current : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.
See Also

Reference

CurveByPointsArrayIterator Class


CurveByPointsArrayIterator Methods

The CurveByPointsArrayIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CurveByPointsArrayIterator Class


CurveByPointsArrayIterator.MoveNext Method

CurveByPointsArrayIteratorMoveNext Method

Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumeratorMoveNext
Remarks
MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.
See Also

Reference

CurveByPointsArrayIterator Class


CurveByPointsArrayIterator.Reset Method

CurveByPointsArrayIteratorReset Method

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
Remarks
The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.
See Also

Reference

CurveByPointsArrayIterator Class


CurveByPointsUtils Class

A static class that contains methods for processing curves driven by points.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBCurveByPointsUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CurveByPointsUtils : IDisposable
Public Class CurveByPointsUtils
    Implements IDisposable
public ref class CurveByPointsUtils : IDisposable
type CurveByPointsUtils =
    class
        interface IDisposable
    end

The CurveByPointsUtils type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
 | AddCurvesToFaceRegion | Adds The CurveElements to one or more FaceRegions.
 | CreateArcThroughPoints | Creates an arc through the given reference points.
 | CreateRectangle | Creates rectangle on face or sketchplane for two given diagonal points.
Public method | Dispose | Releases all resources used by the CurveByPointsUtils
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | GetFaceRegions | Gets the FaceRegions in the existing face.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
 | GetHostFace | Gets the host face to which the CurveElement is added.
 | GetProjectionType | Gets the projection type of the CurveElement.
 | GetSketchOnSurface | Gets the relationship between the CurveElement and face.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | SetProjectionType | Sets the projection type of the CurveElement.
 | SetSketchOnSurface | Sets the relationship between the CurveElement and face.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
 | ValidateCurveElementIdArrayForFaceRegions | Validates that the input CurveElements can define FaceRegions. The CurveElements must be CurveByPoints. Each curve must be entirely hosted by a single Face or hosts related to a common Face (for example, Edges of a common Face, other CurveElements hosted by a common Face). To be added to the FaceRegion definition, a CurveElement must have the SketchOnSurface attribute set.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CurveByPointsUtils Properties

The CurveByPointsUtils type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

CurveByPointsUtils Class


CurveByPointsUtils.IsValidObject Property

CurveByPointsUtilsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

CurveByPointsUtils Class


CurveByPointsUtils Methods

The CurveByPointsUtils type exposes the following members.

Methods
 | Name | Description
 | AddCurvesToFaceRegion | Adds The CurveElements to one or more FaceRegions.
 | CreateArcThroughPoints | Creates an arc through the given reference points.
 | CreateRectangle | Creates rectangle on face or sketchplane for two given diagonal points.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | GetFaceRegions | Gets the FaceRegions in the existing face.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
 | GetHostFace | Gets the host face to which the CurveElement is added.
 | GetProjectionType | Gets the projection type of the CurveElement.
 | GetSketchOnSurface | Gets the relationship between the CurveElement and face.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | SetProjectionType | Sets the projection type of the CurveElement.
 | SetSketchOnSurface | Sets the relationship between the CurveElement and face.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
 | ValidateCurveElementIdArrayForFaceRegions | Validates that the input CurveElements can define FaceRegions. The CurveElements must be CurveByPoints. Each curve must be entirely hosted by a single Face or hosts related to a common Face (for example, Edges of a common Face, other CurveElements hosted by a common Face). To be added to the FaceRegion definition, a CurveElement must have the SketchOnSurface attribute set.
Top
See Also

Reference

CurveByPointsUtils Class


CurveByPointsUtils.AddCurvesToFaceRegion Method

CurveByPointsUtilsAddCurvesToFaceRegion Method

Adds The CurveElements to one or more FaceRegions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void AddCurvesToFaceRegion(
    Document document,
    IList<ElementId> curveElemIds
)
Public Shared Sub AddCurvesToFaceRegion (
    document As Document,
    curveElemIds As IList(Of ElementId)
)
public:
static void AddCurvesToFaceRegion(
    Document^ document,
    IList<ElementId^>^ curveElemIds
)
static member AddCurvesToFaceRegion :
        document : Document *
        curveElemIds : IList<ElementId> -> unit

Parameters

document Document
The Document.
curveElemIds IList ElementId
The ElementIds of CurveElements which are to define the FaceRegion.
Exceptions
Exception | Condition
ArgumentException | All the input CurveElements must be CurveByPoints, with the sketchOnSurface attribute set to True, and for each CurveElement, the defining ReferencePoints must be hosted on References related to a common Face or Edge.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Failed to add curves to FaceRegion.
Remarks
The CurveElements that are input may produce an arbitrary number of regions.
See Also

Reference

CurveByPointsUtils Class


CurveByPointsUtils.CreateArcThroughPoints Method

CurveByPointsUtilsCreateArcThroughPoints Method

Creates an arc through the given reference points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static CurveElement CreateArcThroughPoints(
    Document document,
    ReferencePoint startPoint,
    ReferencePoint endPoint,
    ReferencePoint interiorPoint
)
Public Shared Function CreateArcThroughPoints (
    document As Document,
    startPoint As ReferencePoint,
    endPoint As ReferencePoint,
    interiorPoint As ReferencePoint
) As CurveElement
public:
static CurveElement^ CreateArcThroughPoints(
    Document^ document,
    ReferencePoint^ startPoint,
    ReferencePoint^ endPoint,
    ReferencePoint^ interiorPoint
)
static member CreateArcThroughPoints :
        document : Document *
        startPoint : ReferencePoint *
        endPoint : ReferencePoint *
        interiorPoint : ReferencePoint -> CurveElement

Parameters

document Document
The Document.
startPoint ReferencePoint
The start point of the arc.
endPoint ReferencePoint
The end end of the arc.
interiorPoint ReferencePoint
The interior point on the arc.

Return Value

CurveElement
The CurveElement to be created.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Can't create an arc from the given points
Remarks
The interiorPoint determines the orientation of the arc while startPoint and endPoint determine the angle parameters at the ends.
See Also

Reference

CurveByPointsUtils Class


CurveByPointsUtils.CreateRectangle Method

CurveByPointsUtilsCreateRectangle Method

Creates rectangle on face or sketchplane for two given diagonal points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void CreateRectangle(
    Document document,
    ReferencePoint startPoint,
    ReferencePoint endPoint,
    CurveProjectionType projectionType,
    bool boundaryReferenceLines,
    bool boundaryCurvesFollowSurface,
    out IList<ElementId> createdCurvesIds,
    out IList<ElementId> createdCornersIds
)
Public Shared Sub CreateRectangle (
    document As Document,
    startPoint As ReferencePoint,
    endPoint As ReferencePoint,
    projectionType As CurveProjectionType,
    boundaryReferenceLines As Boolean,
    boundaryCurvesFollowSurface As Boolean,
    <OutAttribute> ByRef createdCurvesIds As IList(Of ElementId),
    <OutAttribute> ByRef createdCornersIds As IList(Of ElementId)
)
public:
static void CreateRectangle(
    Document^ document,
    ReferencePoint^ startPoint,
    ReferencePoint^ endPoint,
    CurveProjectionType projectionType,
    bool boundaryReferenceLines,
    bool boundaryCurvesFollowSurface,
    [OutAttribute] IList<ElementId^>^% createdCurvesIds,
    [OutAttribute] IList<ElementId^>^% createdCornersIds
)
static member CreateRectangle :
        document : Document *
        startPoint : ReferencePoint *
        endPoint : ReferencePoint *
        projectionType : CurveProjectionType *
        boundaryReferenceLines : bool *
        boundaryCurvesFollowSurface : bool *
        createdCurvesIds : IList<ElementId> byref *
        createdCornersIds : IList<ElementId> byref -> unit

Parameters

document Document
The Document.
startPoint ReferencePoint
First diagonal point of rectangle.
endPoint ReferencePoint
Second diagonal point of rectangle.
projectionType CurveProjectionType
Projection type of rectangle's boundary curves. If the rectangle input points are Face hosted, and CurveProjectionType::ParallelToLevel is requested, and the Face normal at the location of the start point is at a less than 45 degree angle with the level planes, then the projectionType will be set to FromTopDown, even if ParallelToLevel was requested.
boundaryReferenceLines Boolean
True if rectangle's boundary curves should be reference lines, false otherwise.
boundaryCurvesFollowSurface Boolean
True if rectangle's boundary curves should follow surface, false otherwise.
createdCurvesIds IList ElementId
Created rectangle's boundary curves ids.
createdCornersIds IList ElementId
Ids of two newly created corner points.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | Unexpected projection type. -or- A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | Unable to create rectangle.
Remarks
This array contains the ElementIds of the two additional corner points that are created to complete the rectangle.
See Also

Reference

CurveByPointsUtils Class


CurveByPointsUtils.Dispose Method

CurveByPointsUtilsDispose Method

Releases all resources used by the CurveByPointsUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

CurveByPointsUtils Class


CurveByPointsUtils.GetFaceRegions Method

CurveByPointsUtilsGetFaceRegions Method

Gets the FaceRegions in the existing face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<Reference> GetFaceRegions(
    Document cda,
    Reference referenceOfFace
)
Public Shared Function GetFaceRegions (
    cda As Document,
    referenceOfFace As Reference
) As IList(Of Reference)
public:
static IList<Reference^>^ GetFaceRegions(
    Document^ cda,
    Reference^ referenceOfFace
)
static member GetFaceRegions :
        cda : Document *
        referenceOfFace : Reference -> IList<Reference>

Parameters

cda Document
The Document.
referenceOfFace Reference
The Reference of the existing face.

Return Value

IList Reference
The FaceRegions in the existing face, or an empty collection if no FaceRegions are found.
Exceptions
Exception | Condition
ArgumentException | The Reference is not a Face Reference.
ArgumentNullException | A non-optional argument was null
See Also

Reference

CurveByPointsUtils Class


CurveByPointsUtils.GetHostFace Method

CurveByPointsUtilsGetHostFace Method

Gets the host face to which the CurveElement is added.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Reference GetHostFace(
    CurveElement curveElem
)
Public Shared Function GetHostFace (
    curveElem As CurveElement
) As Reference
public:
static Reference^ GetHostFace(
    CurveElement^ curveElem
)
static member GetHostFace :
        curveElem : CurveElement -> Reference

Parameters

curveElem CurveElement
The CurveElement.

Return Value

Reference
The host face to which the CurveElement is added, or an empty Reference if the host is not a face.
Exceptions
Exception | Condition
ArgumentException | The input CurveElement is not a CurveByPoints.
ArgumentNullException | A non-optional argument was null
See Also

Reference

CurveByPointsUtils Class


CurveByPointsUtils.GetProjectionType Method

CurveByPointsUtilsGetProjectionType Method

Gets the projection type of the CurveElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static CurveProjectionType GetProjectionType(
    CurveElement curveElem
)
Public Shared Function GetProjectionType (
    curveElem As CurveElement
) As CurveProjectionType
public:
static CurveProjectionType GetProjectionType(
    CurveElement^ curveElem
)
static member GetProjectionType :
        curveElem : CurveElement -> CurveProjectionType

Parameters

curveElem CurveElement
The CurveElement.

Return Value

CurveProjectionType
The projection type.
Exceptions
Exception | Condition
ArgumentException | The input CurveElement is not a CurveByPoints.
ArgumentNullException | A non-optional argument was null
See Also

Reference

CurveByPointsUtils Class


CurveByPointsUtils.GetSketchOnSurface Method

CurveByPointsUtilsGetSketchOnSurface Method

Gets the relationship between the CurveElement and face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool GetSketchOnSurface(
    CurveElement curveElem
)
Public Shared Function GetSketchOnSurface (
    curveElem As CurveElement
) As Boolean
public:
static bool GetSketchOnSurface(
    CurveElement^ curveElem
)
static member GetSketchOnSurface :
        curveElem : CurveElement -> bool

Parameters

curveElem CurveElement
The CurveElement.

Return Value

Boolean
Whether or not the CurveElement should lie on the face and be able to be added to the face.
Exceptions
Exception | Condition
ArgumentException | The input CurveElement is not a CurveByPoints.
ArgumentNullException | A non-optional argument was null
See Also

Reference

CurveByPointsUtils Class


CurveByPointsUtils.SetProjectionType Method

CurveByPointsUtilsSetProjectionType Method

Sets the projection type of the CurveElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void SetProjectionType(
    CurveElement curveElem,
    CurveProjectionType value
)
Public Shared Sub SetProjectionType (
    curveElem As CurveElement,
    value As CurveProjectionType
)
public:
static void SetProjectionType(
    CurveElement^ curveElem,
    CurveProjectionType value
)
static member SetProjectionType :
        curveElem : CurveElement *
        value : CurveProjectionType -> unit

Parameters

curveElem CurveElement
The CurveElement.
value CurveProjectionType
The input projection type.
Exceptions
Exception | Condition
ArgumentException | The input CurveElement is not a CurveByPoints.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

CurveByPointsUtils Class


CurveByPointsUtils.SetSketchOnSurface Method

CurveByPointsUtilsSetSketchOnSurface Method

Sets the relationship between the CurveElement and face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void SetSketchOnSurface(
    CurveElement curveElem,
    bool sketchOnSurface
)
Public Shared Sub SetSketchOnSurface (
    curveElem As CurveElement,
    sketchOnSurface As Boolean
)
public:
static void SetSketchOnSurface(
    CurveElement^ curveElem,
    bool sketchOnSurface
)
static member SetSketchOnSurface :
        curveElem : CurveElement *
        sketchOnSurface : bool -> unit

Parameters

curveElem CurveElement
The CurveElement.
sketchOnSurface Boolean
Whether or not the CurveElement should lie on the face and be able to be added to the face.
Exceptions
Exception | Condition
ArgumentException | The input CurveElement is not a CurveByPoints.
ArgumentNullException | A non-optional argument was null
See Also

Reference

CurveByPointsUtils Class


CurveByPointsUtils.ValidateCurveElementIdArrayForFaceRegions Method

CurveByPointsUtilsValidateCurveElementIdArrayForFaceRegions Method

Validates that the input CurveElements can define FaceRegions. The CurveElements must be CurveByPoints. Each curve must be entirely hosted by a single Face or hosts related to a common Face (for example, Edges of a common Face, other CurveElements hosted by a common Face). To be added to the FaceRegion definition, a CurveElement must have the SketchOnSurface attribute set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool ValidateCurveElementIdArrayForFaceRegions(
    Document document,
    IList<ElementId> curveElemIds
)
Public Shared Function ValidateCurveElementIdArrayForFaceRegions (
    document As Document,
    curveElemIds As IList(Of ElementId)
) As Boolean
public:
static bool ValidateCurveElementIdArrayForFaceRegions(
    Document^ document,
    IList<ElementId^>^ curveElemIds
)
static member ValidateCurveElementIdArrayForFaceRegions :
        document : Document *
        curveElemIds : IList<ElementId> -> bool

Parameters

document Document
The Document.
curveElemIds IList ElementId
The CurveElements.

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

CurveByPointsUtils Class


CurvedEdgeConditionParam Enumeration

The allowed values for the HOST_SSE_CURVED_EDGE_CONDITION_PARAM parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum CurvedEdgeConditionParam
Public Enumeration CurvedEdgeConditionParam
public enum class CurvedEdgeConditionParam
type CurvedEdgeConditionParam
Members
Member name | Value | Description
NotApplicable | 0 | Not Applicable
ConformToCurve | 1 | Conform to curve
ProjectToSideFace | 2 | Project to side
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CurveElement Class

Class representing curve elements.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBCurveElement
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CurveElement : Element
Public Class CurveElement
    Inherits Element
public ref class CurveElement : public Element
type CurveElement =
    class
        inherit Element
    end

The CurveElement type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property.
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CurveElementType | Type of the curve element.
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GeometryCurve | Geometry curve of the curve element.
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LineStyle | The line style of this curve element.
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SketchPlane | The sketch plane the curve element lies in.
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | CreateAreaBasedLoadBoundaryLine | Creates an area based load boundary line.
 | CreateAreaBasedLoadBoundaryLines | Creates area based load boundary lines.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point.
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point.
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point.
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry.
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement.
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
As a base class of several specialized curved elements (such as ModelCurve, ModelLine, CurveByPoints, etc.) CurveElement exposes methods and properties of general use applicable to most kinds of curves.
See Also

Reference

Autodesk.Revit.DB Namespace
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBCurveElement
Autodesk.Revit.DBCurveByPoints
Autodesk.Revit.DBDetailCurve
Autodesk.Revit.DBModelCurve
Autodesk.Revit.DB.StructureAreaReinforcementCurve
Autodesk.Revit.DBSymbolicCurve


CurveElement Properties

The CurveElement type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property.
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CurveElementType | Type of the curve element.
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GeometryCurve | Geometry curve of the curve element.
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LineStyle | The line style of this curve element.
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SketchPlane | The sketch plane the curve element lies in.
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

CurveElement Class


CurveElement.CenterPointReference Property

CurveElementCenterPointReference Property

Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Reference CenterPointReference { get; }
Public ReadOnly Property CenterPointReference As Reference
    Get
public:
property Reference^ CenterPointReference {
    Reference^ get ();
}
member CenterPointReference : Reference with get

Property Value

Reference
Remarks
Use this reference property when using the API to dimension between centerpoints of curves.
See Also

Reference

CurveElement Class


CurveElement.CurveElementType Property

CurveElementCurveElementType Property

Type of the curve element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurveElementType CurveElementType { get; }
Public ReadOnly Property CurveElementType As CurveElementType
    Get
public:
property CurveElementType CurveElementType {
    CurveElementType get ();
}
member CurveElementType : CurveElementType with get

Property Value

CurveElementType
See Also

Reference

CurveElement Class


CurveElement.GeometryCurve Property

CurveElementGeometryCurve Property

Geometry curve of the curve element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Curve GeometryCurve { get; set; }
Public Property GeometryCurve As Curve
    Get
    Set
public:
property Curve^ GeometryCurve {
    Curve^ get ();
    void set (Curve^ value);
}
member GeometryCurve : Curve with get, set

Property Value

Curve
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the argument is .
ArgumentNullException | Thrown if the argument is .
ArgumentException | Thrown if the input curve is of a type different from the current. -- or -- Thrown if the input curve is bound and the current is not or vice versa. -- or -- Thrown if the input curve is helical. -- or -- Thrown if the input curve lies outside of the SketchPlane of the current curve and the CurveElement is not CurveByPoints.
Remarks
When setting this property, any curves that this curve is currently joined to will affect the result - the final geometry of this curve and of the joined curves may change. To avoid the effect of existing joins, use SetGeometryCurve(Curve, Boolean) with true passed ot overrideJoins. After the curve geometry is set, other nearby curves may join to the new curve geometry.
See Also

Reference

CurveElement Class


CurveElement.LineStyle Property

CurveElementLineStyle Property

The line style of this curve element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Element LineStyle { get; set; }
Public Property LineStyle As Element
    Get
    Set
public:
property Element^ LineStyle {
    Element^ get ();
    void set (Element^ value);
}
member LineStyle : Element with get, set

Property Value

Element
Exceptions
Exception | Condition
ArgumentNullException | Thrown when argument is .
InvalidOperationException | Thrown when regeneration failed. -- or -- Thrown when fail to get line style.
Remarks
The return of this property will be a [!:Autodesk::Revit::DB::GraphicsStyle] element. These graphics styles should be associated to subcategories of the BuiltInCategory OST_Lines.
See Also

Reference

CurveElement Class


CurveElement.SketchPlane Property

CurveElementSketchPlane Property

The sketch plane the curve element lies in.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual SketchPlane SketchPlane { get; set; }
Public Overridable Property SketchPlane As SketchPlane
    Get
    Set
public:
virtual property SketchPlane^ SketchPlane {
    SketchPlane^ get ();
    void set (SketchPlane^ value);
}
abstract SketchPlane : SketchPlane with get, set
override SketchPlane : SketchPlane with get, set

Property Value

SketchPlane
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the argument is .
InvalidOperationException | Thrown if the CurveElement is CurveByPoints or belongs to a Path3d element. -- or -- Thrown if the sketch plane is set on a DetailCurve. --or-- Thrown if the sketch plane is not parallel to the existing plane. -- or -- Thrown if the sketch plane is not suitable. -- or -- Thrown if the CurveElement belongs to a sketch-based element. -- or -- Thrown if modifying the sketch plane is not allowed. -- or -- Thrown if the CurveElement cannot be moved out of its sketch plane.
Remarks
The new sketch plane must be parallel to the existing sketch plane. Setting this property is not permitted for detail curves because they must be placed only on view-specific planes.
See Also

Reference

CurveElement Class


CurveElement.SupportsTangentLocks Property

CurveElementSupportsTangentLocks Property

Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SupportsTangentLocks { get; }
Public ReadOnly Property SupportsTangentLocks As Boolean
    Get
public:
property bool SupportsTangentLocks {
    bool get ();
}
member SupportsTangentLocks : bool with get

Property Value

Boolean
See Also

Reference

CurveElement Class


CurveElement Methods

The CurveElement type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | CreateAreaBasedLoadBoundaryLine | Creates an area based load boundary line.
 | CreateAreaBasedLoadBoundaryLines | Creates area based load boundary lines.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point.
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point.
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point.
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry.
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement.
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CurveElement Class


CurveElement.CreateAreaBasedLoadBoundaryLine Method

CurveElementCreateAreaBasedLoadBoundaryLine Method

Creates an area based load boundary line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static CurveElement CreateAreaBasedLoadBoundaryLine(
    Document document,
    Curve curve,
    ElementId levelId
)
Public Shared Function CreateAreaBasedLoadBoundaryLine (
    document As Document,
    curve As Curve,
    levelId As ElementId
) As CurveElement
public:
static CurveElement^ CreateAreaBasedLoadBoundaryLine(
    Document^ document,
    Curve^ curve,
    ElementId^ levelId
)
static member CreateAreaBasedLoadBoundaryLine :
        document : Document *
        curve : Curve *
        levelId : ElementId -> CurveElement

Parameters

document Document
The document in which to create the area based load boundary line.
curve Curve
The curve.
levelId ElementId
The id of level.

Return Value

CurveElement
The newly created area based load boundary line.
Exceptions
Exception | Condition
ArgumentException | document is not a project document. -or- The input curve is not bound. -or- The curve is degenerate (its length is too close to zero). -or- The ElementId levelId is not a Level. -or- The curve doesn't lie in the plane of the level.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
See Also

Reference

CurveElement Class


CurveElement.CreateAreaBasedLoadBoundaryLines Method

CurveElementCreateAreaBasedLoadBoundaryLines Method

Creates area based load boundary lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<CurveElement> CreateAreaBasedLoadBoundaryLines(
    Document document,
    IList<Curve> curves,
    ElementId levelId
)
Public Shared Function CreateAreaBasedLoadBoundaryLines (
    document As Document,
    curves As IList(Of Curve),
    levelId As ElementId
) As IList(Of CurveElement)
public:
static IList<CurveElement^>^ CreateAreaBasedLoadBoundaryLines(
    Document^ document,
    IList<Curve^>^ curves,
    ElementId^ levelId
)
static member CreateAreaBasedLoadBoundaryLines :
        document : Document *
        curves : IList<Curve> *
        levelId : ElementId -> IList<CurveElement>

Parameters

document Document
The document in which to create the area based load boundary lines.
curves IList Curve
The curves.
levelId ElementId
The id of level.

Return Value

IList CurveElement
The newly created area based load boundary lines.
Exceptions
Exception | Condition
ArgumentException | document is not a project document. -or- The input curves contains a null pointer or a curve that is not bounded. -or- The input curves contains at least one curve which is degenerate (its length is too close to zero). -or- The ElementId levelId is not a Level. -or- The input curves contains a curve doesn't lie in the plane of the level.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
See Also

Reference

CurveElement Class


CurveElement.GetAdjoinedCurveElements Method

CurveElementGetAdjoinedCurveElements Method

Returns elements that are joining with this curve element at the given end point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ISet<ElementId> GetAdjoinedCurveElements(
    int end
)
Public Function GetAdjoinedCurveElements (
    end As Integer
) As ISet(Of ElementId)
public:
ISet<ElementId^>^ GetAdjoinedCurveElements(
    int end
)
member GetAdjoinedCurveElements :
        end : int -> ISet<ElementId>

Parameters

end Int32
Id of one the curve's end. Value '0' indicates start and '1' indicates the end of the curve, respectively.

Return Value

ISet ElementId
Collection of Ids of Curve Elements.
Exceptions
Exception | Condition
ArgumentException | The given Id does not represent any of the two end-points of a curve element. A valid value of either '0' or '1' is expected.
See Also

Reference

CurveElement Class


CurveElement.GetAreaBasedLoadBoundaryLineData Method

CurveElementGetAreaBasedLoadBoundaryLineData Method

Gets the area based load boundary line data from this curve, if applicable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AreaBasedLoadBoundaryLineData GetAreaBasedLoadBoundaryLineData()
Public Function GetAreaBasedLoadBoundaryLineData As AreaBasedLoadBoundaryLineData
public:
AreaBasedLoadBoundaryLineData^ GetAreaBasedLoadBoundaryLineData()
member GetAreaBasedLoadBoundaryLineData : unit -> AreaBasedLoadBoundaryLineData

Return Value

AreaBasedLoadBoundaryLineData
The area based load boundary line data, if this is an area based load boundary, or otherwise.
Remarks
Will return if curve element isn't an area based load boundary line.
See Also

Reference

CurveElement Class


CurveElement.GetLineStyleIds Method

CurveElementGetLineStyleIds Method

Ids of all line style Elements that are applicable to this curve element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetLineStyleIds()
Public Function GetLineStyleIds As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetLineStyleIds()
member GetLineStyleIds : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
A collection of Ids of line style elements.
Remarks
The elements are of the [!:Autodesk::Revit::DB::GraphicsStyle] class.
See Also

Reference

CurveElement Class


CurveElement.GetTangentLock Method

CurveElementGetTangentLock Method

Returns the state of a tangent join between this and another curve element at the given end-point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool GetTangentLock(
    int end,
    ElementId other
)
Public Function GetTangentLock (
    end As Integer,
    other As ElementId
) As Boolean
public:
bool GetTangentLock(
    int end,
    ElementId^ other
)
member GetTangentLock :
        end : int *
        other : ElementId -> bool

Parameters

end Int32
Index of one of the curve's end. Values '0' and '1' indicate the start or end point, respectively.
other ElementId
ElementId of another Curve Element from the same document.

Return Value

Boolean
Returns True if this curve element has a tangent joint with the other input element and the join is curently locked; returns False otherwise.
Exceptions
Exception | Condition
ArgumentException | The given Id does not represent any of the two end-points of a curve element. A valid value of either '0' or '1' is expected. -or- The given ElementId (%elementId) is not of a valid Curve Element. A valid Curve Element must be in the same document and must be diferent than this curve elements self. -or- This element has no tangent join with the input element at the given end-point.
ArgumentNullException | A non-optional argument was null
Remarks
The return value indicates whether there is such tangent join and if it is currently locked. A negative value indicates that there either is no tangent join with the other element at the given end-point, or the join between those two curve element is not currently locked.
See Also

Reference

CurveElement Class


CurveElement.HasTangentJoin Method

CurveElementHasTangentJoin Method

Tests whether this curve element and the input curve element have common tangent join at the given end-point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasTangentJoin(
    int end,
    ElementId other
)
Public Function HasTangentJoin (
    end As Integer,
    other As ElementId
) As Boolean
public:
bool HasTangentJoin(
    int end,
    ElementId^ other
)
member HasTangentJoin :
        end : int *
        other : ElementId -> bool

Parameters

end Int32
Index of one of the curve's end. Values '0' and '1' indicate the start or end point, respectively.
other ElementId
ElementId of another Curve Element from the same document.

Return Value

Boolean
Returns True if the two curve elements have a tangent join at the given end-point.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

CurveElement Class


CurveElement.HasTangentLocks Method

CurveElementHasTangentLocks Method

Tests whether this curve element has any locked tangent joins at the given end-point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasTangentLocks(
    int end
)
Public Function HasTangentLocks (
    end As Integer
) As Boolean
public:
bool HasTangentLocks(
    int end
)
member HasTangentLocks :
        end : int -> bool

Parameters

end Int32
Index of one of the curve's end. Values '0' and '1' indicate the start or end point, respectively.

Return Value

Boolean
Returns True if the curve element is tangentially locked to at least one other curve element at the given end-point; returns False otherwise.
Remarks
Note that tangent locks between two elements at their joined ends are always kept in sync with each other. It means that if one curve element is locked to another curve, the other curve will be automatically locked to the first curve at the shared join.
See Also

Reference

CurveElement Class


CurveElement.IsAdjoinedCurveElement Method

CurveElementIsAdjoinedCurveElement Method

This method tests whether this and the given curve elements are joined at the given end.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsAdjoinedCurveElement(
    int end,
    ElementId other
)
Public Function IsAdjoinedCurveElement (
    end As Integer,
    other As ElementId
) As Boolean
public:
bool IsAdjoinedCurveElement(
    int end,
    ElementId^ other
)
member IsAdjoinedCurveElement :
        end : int *
        other : ElementId -> bool

Parameters

end Int32
Index of one of the curve's end. Values '0' and '1' indicate the start or end point, respectively.
other ElementId
ElementId of another Curve Element from the same document.

Return Value

Boolean
Returns True if the input curve element joins This curve element at the given end-point; returns False otherwise.
Exceptions
Exception | Condition
ArgumentException | The given Id does not represent any of the two end-points of a curve element. A valid value of either '0' or '1' is expected. -or- The given ElementId (%elementId) is not of a valid Curve Element. A valid Curve Element must be in the same document and must be diferent than this curve elements self.
ArgumentNullException | A non-optional argument was null
Remarks
The input end is relative to this curve element. The other curve element can be joined at any of its end-points.
See Also

Reference

CurveElement Class


CurveElement.SetGeometryCurve Method

CurveElementSetGeometryCurve Method

Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetGeometryCurve(
    Curve curve,
    bool overrideJoins
)
Public Sub SetGeometryCurve (
    curve As Curve,
    overrideJoins As Boolean
)
public:
void SetGeometryCurve(
    Curve^ curve,
    bool overrideJoins
)
member SetGeometryCurve :
        curve : Curve *
        overrideJoins : bool -> unit

Parameters

curve Curve
The new curve.
overrideJoins Boolean
An option to specify whether or not existing joins will affect setting the geometry of the CurveElement. Setting this parameter to false is essentially the same as directly setting the GeometryCurve property.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the argument is .
ArgumentException | Thrown if the input curve is of a type different from the current. -- or -- Thrown if the input curve is bound and the current is not or vice versa. -- or -- Thrown if the input curve is helical. -- or -- Thrown if the input curve lies outside of the SketchPlane of the current curve and the CurveElement is not CurveByPoints.
See Also

Reference

CurveElement Class


CurveElement.SetSketchPlaneAndCurve Method

CurveElementSetSketchPlaneAndCurve Method

Sets the sketch plane and the curve for this CurveElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetSketchPlaneAndCurve(
    SketchPlane sketchPlane,
    Curve curve
)
Public Sub SetSketchPlaneAndCurve (
    sketchPlane As SketchPlane,
    curve As Curve
)
public:
void SetSketchPlaneAndCurve(
    SketchPlane^ sketchPlane,
    Curve^ curve
)
member SetSketchPlaneAndCurve :
        sketchPlane : SketchPlane *
        curve : Curve -> unit

Parameters

sketchPlane SketchPlane
The new sketch plane.
curve Curve
The new curve.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if the argument is .
InvalidOperationException | Thrown if the CurveElement is CurveByPoints or belongs to a Path3d element. -- or -- Thrown if the sketch plane is set on a DetailCurve. -- or -- Thrown if the sketch plane is not suitable. -- or -- Thrown if the CurveElement belongs to a sketch-based element. -- or -- Thrown if modifying the sketch plane is not allowed. -- or -- Thrown if the CurveElement cannot be moved out of its sketch plane. -- or -- Thrown if the input curve is of a type different from the current. -- or -- Thrown if the input curve is bound and the current is not or vice versa. -- or -- Thrown if the input curve is helical. -- or -- Thrown if the input curve lies outside of the SketchPlane of the current curve.
Remarks
Unlike the setters of SketchPlane and GeometryCurve, this method will reset relationships between the two properties and with other elements. To set a geometry curve which belongs to a sketch-based elements, use GeometryCurve
See Also

Reference

CurveElement Class


CurveElement.SetTangentLock Method

CurveElementSetTangentLock Method

Sets a new status for an existing tangent join with another curve element at the given end-point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetTangentLock(
    int end,
    ElementId other,
    bool state
)
Public Sub SetTangentLock (
    end As Integer,
    other As ElementId,
    state As Boolean
)
public:
void SetTangentLock(
    int end,
    ElementId^ other,
    bool state
)
member SetTangentLock :
        end : int *
        other : ElementId *
        state : bool -> unit

Parameters

end Int32
Index of one of the curve's ends. Values '0' and '1' indicate the start or end point, respectively.
other ElementId
ElementId of another Curve Element from the same document.
state Boolean
Requested new state of the lock; True to lock it, False to unlock it.
Exceptions
Exception | Condition
ArgumentException | The given Id does not represent any of the two end-points of a curve element. A valid value of either '0' or '1' is expected. -or- The given ElementId (%elementId) is not of a valid Curve Element. A valid Curve Element must be in the same document and must be diferent than this curve elements self. -or- This element has no tangent join with the input element at the given end-point. -or- The element other does not exist in the document containing this CurveElement
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This curve element does not support tangent joins with other elements.
ModificationForbiddenException | This CurveElement is an internal element, such as a component of a loaded family or a group type. -or- The document containing this CurveElement is in Group Edit Mode, Sketch Edit Mode, or Paste Mode, and the element is not a member of the group, sketch, or clipboard. -or- This CurveElement is a member of a group or sketch, and the document is not currently editing the group or sketch. -or- other is an internal element, such as a component of a loaded family or a group type. -or- The document containing other is in Group Edit Mode, Sketch Edit Mode, or Paste Mode, and the element is not a member of the group, sketch, or clipboard. -or- other is a member of a group or sketch, and the document is not currently editing the group or sketch.
Remarks

The input status indicates whether the tangent join is to be locked or unlocked. Note that the status can be set only if this and the other curve element are currently joined and tangent at the given point.

Locking a tangent join between elements of a family will make the family parametric. A parametric family needs to utilize a geometry solver in order to determine final shapes of its instances. Using the solver in families which contain large sketches may cause regenerations of such families to become significantly slower. To determine whether a particular family falls into such a category, programmers can query IsParametric property and [!:Autodesk::Revit::DB::Family::DoesContainLargeSketches()] method of the Family class.

See Also

Reference

CurveElement Class


CurveElementFilter Class

A filter used to pass curve elements which are of a specific type.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementSlowFilter
Autodesk.Revit.DBCurveElementFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CurveElementFilter : ElementSlowFilter
Public Class CurveElementFilter
    Inherits ElementSlowFilter
public ref class CurveElementFilter : public ElementSlowFilter
type CurveElementFilter =
    class
        inherit ElementSlowFilter
    end

The CurveElementFilter type exposes the following members.

Constructors
 | Name | Description
Public method | CurveElementFilter(CurveElementType) | Constructs a new instance of a filter to match specific types of curve elements.
Public method | CurveElementFilter(CurveElementType, Boolean) | Constructs a new instance of a filter to match specific types of curve elements, with the option to match all curves which are not of the given curve type.
Top
Properties
 | Name | Description
Public property | CurveElementType | The curve element type.
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Example
C#
VB
C++
F#
Copy
// Create a CurveElement filter to find CurveByPoints elements.
// It is necessary to use the CurveElementFilter, and not an ElementClassFilter or  the shortcut
// method OfClass() because subclasses of CurveElement are not supported by those methods.
CurveElementFilter filter = new CurveElementFilter(CurveElementType.CurveByPoints);

// Apply the filter to the elements in the active document
FilteredElementCollector collector = new FilteredElementCollector(document);
ICollection<Element> founds = collector.WherePasses(filter).ToElements();

// Find all curve elements: use inverted filter with invalid CurveElementType to match elements
CurveElementFilter notCurveByPntFilter = new CurveElementFilter(CurveElementType.Invalid, true); // inverted filter
collector = new FilteredElementCollector(document);
ICollection<Element> notCurveByPntFounds = collector.WherePasses(notCurveByPntFilter).ToElements();
' Create a CurveElement filter to find CurveByPoints elements.
' It is necessary to use the CurveElementFilter, and not an ElementClassFilter or  the shortcut
' method OfClass() because subclasses of CurveElement are not supported by those methods.
Dim filter As New CurveElementFilter(CurveElementType.CurveByPoints)

' Apply the filter to the elements in the active document
Dim collector As New FilteredElementCollector(document)
Dim founds As ICollection(Of Element) = collector.WherePasses(filter).ToElements()

' Find all curve elements: use inverted filter with invalid CurveElementType to match elements
Dim notCurveByPntFilter As New CurveElementFilter(CurveElementType.Invalid, True)
' inverted filter
collector = New FilteredElementCollector(document)
Dim notCurveByPntFounds As ICollection(Of Element) = collector.WherePasses(notCurveByPntFilter).ToElements()

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CurveElementFilter Constructor

Overload List
 | Name | Description
Public method | CurveElementFilter(CurveElementType) | Constructs a new instance of a filter to match specific types of curve elements.
Public method | CurveElementFilter(CurveElementType, Boolean) | Constructs a new instance of a filter to match specific types of curve elements, with the option to match all curves which are not of the given curve type.
Top
See Also

Reference

CurveElementFilter Class


CurveElementFilter(CurveElementType) Constructor

Constructs a new instance of a filter to match specific types of curve elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurveElementFilter(
    CurveElementType curveElementType
)
Public Sub New (
    curveElementType As CurveElementType
)
public:
CurveElementFilter(
    CurveElementType curveElementType
)
new :
        curveElementType : CurveElementType -> CurveElementFilter

Parameters

curveElementType CurveElementType
The curve element type to match.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

CurveElementFilter Class
CurveElementFilter Overload


CurveElementFilter(CurveElementType, Boolean) Constructor

Constructs a new instance of a filter to match specific types of curve elements, with the option to match all curves which are not of the given curve type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurveElementFilter(
    CurveElementType curveElementType,
    bool inverted
)
Public Sub New (
    curveElementType As CurveElementType,
    inverted As Boolean
)
public:
CurveElementFilter(
    CurveElementType curveElementType,
    bool inverted
)
new :
        curveElementType : CurveElementType *
        inverted : bool -> CurveElementFilter

Parameters

curveElementType CurveElementType
The curve element type to match.
inverted Boolean
True if the filter should match all curves which are not of the given curve type.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

CurveElementFilter Class
CurveElementFilter Overload


CurveElementFilter Properties

The CurveElementFilter type exposes the following members.

Properties
 | Name | Description
Public property | CurveElementType | The curve element type.
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
See Also

Reference

CurveElementFilter Class


CurveElementFilter.CurveElementType Property

CurveElementFilterCurveElementType Property

The curve element type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurveElementType CurveElementType { get; }
Public ReadOnly Property CurveElementType As CurveElementType
    Get
public:
property CurveElementType CurveElementType {
    CurveElementType get ();
}
member CurveElementType : CurveElementType with get

Property Value

CurveElementType
See Also

Reference

CurveElementFilter Class


CurveElementFilter Methods

The CurveElementFilter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CurveElementFilter Class


CurveElementType Enumeration

An enumerated type listing the curve element types that can be used when filtering elements (via CurveElementFilter).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum CurveElementType
Public Enumeration CurveElementType
public enum class CurveElementType
type CurveElementType
Members
Member name | Value | Description
Invalid | 0 | An invalid curve element type.
ModelCurve | 1 | A model curve.
DetailCurve | 2 | A detail curve.
SymbolicCurve | 3 | A symbolic curve.
ReferenceLine | 4 | A reference line.
SpaceSeparation | 5 | A space separation curve.
RoomSeparation | 6 | An room separation curve.
AreaSeparation | 7 | An area separation curve.
CurveByPoints | 8 | A curve created by connecting a set of points.
RepeatingDetail | 9 | The profile of a repeating detail set.
Insulation | 10 | A detail curve representing insulation.
Cloud | 11 | A portion of a revision cloud.
AreaBasedLoadBoundary | 12 | An Area Based Load Boundary curve.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CurveExtents Class

Represents the start and end parameters for a curve segment.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBCurveExtents

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CurveExtents : IDisposable
Public Class CurveExtents
    Implements IDisposable
public ref class CurveExtents : IDisposable
type CurveExtents =
    class
        interface IDisposable
    end

The CurveExtents type exposes the following members.

Properties
 | Name | Description
Public property | EndParameter | The end parameter of the curve extents.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | StartParameter | The start parameter of the curve extents.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the CurveExtents
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CurveExtents Properties

The CurveExtents type exposes the following members.

Properties
 | Name | Description
Public property | EndParameter | The end parameter of the curve extents.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | StartParameter | The start parameter of the curve extents.
Top
See Also

Reference

CurveExtents Class


CurveExtents.EndParameter Property

CurveExtentsEndParameter Property

The end parameter of the curve extents.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double EndParameter { get; }
Public ReadOnly Property EndParameter As Double
    Get
public:
property double EndParameter {
    double get ();
}
member EndParameter : float with get

Property Value

Double
See Also

Reference

CurveExtents Class


CurveExtents.IsValidObject Property

CurveExtentsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

CurveExtents Class


CurveExtents.StartParameter Property

CurveExtentsStartParameter Property

The start parameter of the curve extents.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double StartParameter { get; }
Public ReadOnly Property StartParameter As Double
    Get
public:
property double StartParameter {
    double get ();
}
member StartParameter : float with get

Property Value

Double
See Also

Reference

CurveExtents Class


CurveExtents Methods

The CurveExtents type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CurveExtents Class


CurveExtents.Dispose Method

CurveExtentsDispose Method

Releases all resources used by the CurveExtents

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

CurveExtents Class


CurveLoop Class

A class that represents a chain of curves.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBCurveLoop

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CurveLoop : IEnumerable<Curve>,
    IDisposable
Public Class CurveLoop
    Implements IEnumerable(Of Curve), IDisposable
public ref class CurveLoop : IEnumerable<Curve^>,
    IDisposable
type CurveLoop =
    class
        interface IEnumerable<Curve>
        interface IDisposable
    end

The CurveLoop type exposes the following members.

Constructors
 | Name | Description
Public method | CurveLoop | Constructs a new empty curve loop.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Append | Append the curve to this loop.
 | Create | Creates a new curve loop.
 | CreateViaCopy | Creates a new curve loop as a copy of the input.
 | CreateViaOffset(CurveLoop, IListDouble, XYZ) | Creates a new curve loop that is an offset of the existing curve loop.
 | CreateViaOffset(CurveLoop, Double, XYZ) | Creates a new curve loop that is an offset of the existing curve loop.
 | CreateViaThicken(Curve, Double, XYZ) | Creates a new closed curve loop by thickening the input curve with respect to a given plane.
 | CreateViaThicken(CurveLoop, Double, XYZ) | Creates a new closed curve loop by thickening the input open curve loop with respect to a given plane.
 | CreateViaTransform | Creates a new curve loop as a transformed copy of the input curve loop.
Public method | Dispose | Releases all resources used by the CurveLoop
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Flip | Reverses the orientation of the curve loop.
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetCurveLoopIterator | Returns a curve that iterates through the curve loop.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetExactLength | Returns the sum of exact lengths of all curves in the loop.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetPlane | Gets the plane of the curve loop, if it is planar.
Public method | GetRectangularHeight | Returns the width of a curve loop if it is rectangular with respect to the projection plane.
Public method | GetRectangularWidth | Returns the width of a curve loop if it is rectangular with respect to the projection plane.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HasPlane | Identifies if the CurveLoop is planar.
Public method | IsCounterclockwise | Determines if this CurveLoop is oriented counter-clockwise (CCW) or clockwise (CW) with respect to the specified 3D direction.
Public method | IsOpen | Returns whether the curve loop is open or closed, as determined by an internal flag.
Public method | IsRectangular | Identifies if the curve loop is rectangular with respect to a given projection plane.
Public method | NumberOfCurves | Returns the number of curves in the curve loop.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | Transform | Transforms this curve loop and all of its component curves by the supplied transformation.
Top
Remarks
There are specific requirements for how valid CurveLoops must be formed:
  • The curves should typically be contiguous.
  • The CurveLoop may be either closed (where the start and end points coincide) or open.
  • There should be no self-intersections.

A CurveLoop is said to be "continuous" if either:

  • the loop contains at most one curve
  • the end of each curve coincides with the start of the next one (if there is a next curve).

Many geometry utilities require CurveLoops to be continuous, but discontinuous CurveLoops are sometimes used. For example, the curves in a continuous CurveLoop may be offset, resulting in a discontinuous loop if the offset curves overlap or do not meet, and the offset curves might then be extended or trimmed to form a continuous CurveLoop.

A CurveLoop is said to be "closed" if it is non-empty, continuous, and if either:

  • the loop contains just one curve, which is unbounded and periodic
  • the loop's end point coincides with its start point
For example, a CurveLoop comprising four lines forming a rectangle, listed in order around the rectangle, with each curve oriented in direction in which the curves are listed is closed. As another example, a CurveLoop consisting of just one unbounded circle is closed.

A CurveLoop is said to be "open" if it is not closed. For example, a CurveLoop consisting of a single line is open, as is the "offset CurveLoop" mentioned above. Note that an open CurveLoop may be continuous or discontinuous, and a continuous CurveLoop may be open or closed. The definitions imply that a discontinuous CurveLoop is necessarily open and an empty CurveLoop is open.

It should also be noted that these definitions take the order of the curves and the curves' directions into account. For example, a CurveLoop comprising the four edges of a rectangle in the order {bottom, top, left, right} is discontinuous. Similarly, a CurveLoop comprising the four edges of a rectangle in the order {bottom, right, top, left}, with three of the lines oriented in the counter-clockwise direction of the rectangle and the fourth oriented in the clockwise direction, is discontinuous.

Finally, note that some routines in Revit may set the CurveLoop to be marked "open" or "closed" in spite of the actual geometry of the curves. In these special cases, the CurveLoop class does not require that the CurveLoop is correctly marked.

In the API, the members of the CurveLoop may be directly iterated, as the class implements IEnumerable<Curve>. The iteration provides copies of the curves directly contained in the loop; modification of the curves will not affect the curves that are contained in the loop.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CurveLoop Constructor

Constructs a new empty curve loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurveLoop()
Public Sub New
public:
CurveLoop()
new : unit -> CurveLoop
See Also

Reference

CurveLoop Class


CurveLoop Properties

The CurveLoop type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

CurveLoop Class


CurveLoop.IsValidObject Property

CurveLoopIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

CurveLoop Class


CurveLoop Methods

The CurveLoop type exposes the following members.

Methods
 | Name | Description
Public method | Append | Append the curve to this loop.
 | Create | Creates a new curve loop.
 | CreateViaCopy | Creates a new curve loop as a copy of the input.
 | CreateViaOffset(CurveLoop, IListDouble, XYZ) | Creates a new curve loop that is an offset of the existing curve loop.
 | CreateViaOffset(CurveLoop, Double, XYZ) | Creates a new curve loop that is an offset of the existing curve loop.
 | CreateViaThicken(Curve, Double, XYZ) | Creates a new closed curve loop by thickening the input curve with respect to a given plane.
 | CreateViaThicken(CurveLoop, Double, XYZ) | Creates a new closed curve loop by thickening the input open curve loop with respect to a given plane.
 | CreateViaTransform | Creates a new curve loop as a transformed copy of the input curve loop.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Flip | Reverses the orientation of the curve loop.
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetCurveLoopIterator | Returns a curve that iterates through the curve loop.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetExactLength | Returns the sum of exact lengths of all curves in the loop.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetPlane | Gets the plane of the curve loop, if it is planar.
Public method | GetRectangularHeight | Returns the width of a curve loop if it is rectangular with respect to the projection plane.
Public method | GetRectangularWidth | Returns the width of a curve loop if it is rectangular with respect to the projection plane.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HasPlane | Identifies if the CurveLoop is planar.
Public method | IsCounterclockwise | Determines if this CurveLoop is oriented counter-clockwise (CCW) or clockwise (CW) with respect to the specified 3D direction.
Public method | IsOpen | Returns whether the curve loop is open or closed, as determined by an internal flag.
Public method | IsRectangular | Identifies if the curve loop is rectangular with respect to a given projection plane.
Public method | NumberOfCurves | Returns the number of curves in the curve loop.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | Transform | Transforms this curve loop and all of its component curves by the supplied transformation.
Top
See Also

Reference

CurveLoop Class


CurveLoop.Append Method

CurveLoopAppend Method

Append the curve to this loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Append(
    Curve curve
)
Public Sub Append (
    curve As Curve
)
public:
void Append(
    Curve^ curve
)
member Append :
        curve : Curve -> unit

Parameters

curve Curve
The curve.
Exceptions
Exception | Condition
ArgumentException | The input curve points to a helical curve and is not supported for this operation. -or- Throws if the input curve makes the loop not contiguous.
ArgumentNullException | A non-optional argument was null
See Also

Reference

CurveLoop Class


CurveLoop.Create Method

CurveLoopCreate Method

Creates a new curve loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static CurveLoop Create(
    IList<Curve> curves
)
Public Shared Function Create (
    curves As IList(Of Curve)
) As CurveLoop
public:
static CurveLoop^ Create(
    IList<Curve^>^ curves
)
static member Create :
        curves : IList<Curve> -> CurveLoop

Parameters

curves IList Curve
The curves.

Return Value

CurveLoop
The curve loop.
Exceptions
Exception | Condition
ArgumentException | The input curves contains at least one helical curve and is not supported for this operation. -or- Throws if the input curves are not contiguous.
ArgumentNullException | A non-optional argument was null
See Also

Reference

CurveLoop Class


CurveLoop.CreateViaCopy Method

CurveLoopCreateViaCopy Method

Creates a new curve loop as a copy of the input.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static CurveLoop CreateViaCopy(
    CurveLoop original
)
Public Shared Function CreateViaCopy (
    original As CurveLoop
) As CurveLoop
public:
static CurveLoop^ CreateViaCopy(
    CurveLoop^ original
)
static member CreateViaCopy :
        original : CurveLoop -> CurveLoop

Parameters

original CurveLoop
The original curve loop.

Return Value

CurveLoop
The copied curve loop.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

CurveLoop Class


CurveLoop.CreateViaOffset Method

CurveLoopCreateViaOffset Method

Overload List
Name | Description
CreateViaOffset(CurveLoop, IListDouble, XYZ) | Creates a new curve loop that is an offset of the existing curve loop.
CreateViaOffset(CurveLoop, Double, XYZ) | Creates a new curve loop that is an offset of the existing curve loop.
Top
See Also

Reference

CurveLoop Class


CurveLoop.CreateViaOffset(CurveLoop, IList<Double>, XYZ) Method

CurveLoopCreateViaOffset(CurveLoop, IListDouble, XYZ) Method

Creates a new curve loop that is an offset of the existing curve loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static CurveLoop CreateViaOffset(
    CurveLoop original,
    IList<double> offsetDists,
    XYZ normal
)
Public Shared Function CreateViaOffset (
    original As CurveLoop,
    offsetDists As IList(Of Double),
    normal As XYZ
) As CurveLoop
public:
static CurveLoop^ CreateViaOffset(
    CurveLoop^ original,
    IList<double>^ offsetDists,
    XYZ^ normal
)
static member CreateViaOffset :
        original : CurveLoop *
        offsetDists : IList<float> *
        normal : XYZ -> CurveLoop

Parameters

original CurveLoop
The original curve loop.
offsetDists IList Double
The signed offset distances for each curve. The size of this array must match the size of the curve loop. Curve at position i will be offset with offsetDists[i].
normal XYZ
The normal of the offset plane.

Return Value

CurveLoop
The offset curve loop.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Thrown if the curve loop could not be offset.
Remarks
For each curve i in the curve loop, the offset curve is theoretically defined by translating every point of the original curve by the vector offsetDist[i] * (curveTan x normal) where curveTan is the curve's unit tangent vector at the given point. The curves are then trimmed to create a continuous curve loop. For a planar curve loop, this amounts to pushing each point "to the right" of the curve loop by the signed offset distance offsetDist, within the plane of the curve loop. The "right" side of the curve loop at a given point on the curve loop is defined with reference to normal being thought of as the upward direction and curveTan being thought of as the forward direction, as if you are walking along the curve loop. It follows that if offsetDist[i] is positive, points will be offset to the right of the curve loop, whereas if offsetDist[i] is negative, points will be offset to the left of the curve loop.

If the curve loop contains curves such as elliptical segments or splines, it is possible the offset creation will fail if Revit will not be able to trim contiguous curves to meet one another. If the offset is successful, offsets of those curve types will be created as HermiteSplines.

See Also

Reference

CurveLoop Class
CreateViaOffset Overload


CurveLoop.CreateViaOffset(CurveLoop, Double, XYZ) Method

CurveLoopCreateViaOffset(CurveLoop, Double, XYZ) Method

Creates a new curve loop that is an offset of the existing curve loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static CurveLoop CreateViaOffset(
    CurveLoop original,
    double offsetDist,
    XYZ normal
)
Public Shared Function CreateViaOffset (
    original As CurveLoop,
    offsetDist As Double,
    normal As XYZ
) As CurveLoop
public:
static CurveLoop^ CreateViaOffset(
    CurveLoop^ original,
    double offsetDist,
    XYZ^ normal
)
static member CreateViaOffset :
        original : CurveLoop *
        offsetDist : float *
        normal : XYZ -> CurveLoop

Parameters

original CurveLoop
The original curve loop.
offsetDist Double
The signed offset distance.
normal XYZ
The normal of the offset plane.

Return Value

CurveLoop
The offset curve loop.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Thrown if the curve loop could not be offset.
Remarks
For each curve in the curve loop, the offset curve is theoretically defined by translating every point of the original curve by the vector offsetDist * (curveTan x normal) where curveTan is the curve's unit tangent vector at the given point. The curves are then trimmed to create a continuous curve loop. For a planar curve loop, this amounts to pushing each point "to the right" of the curve loop by the signed offset distance offsetDist, within the plane of the curve loop. The "right" side of the curve loop at a given point on the curve loop is defined with reference to normal being thought of as the upward direction and curveTan being thought of as the forward direction, as if you are walking along the curve loop. It follows that if offsetDist is positive, points will be offset to the right of the curve loop, whereas if offsetDist is negative, points will be offset to the left of the curve loop.

If the curve loop contains curves such as elliptical segments or splines, it is possible the offset creation will fail if Revit will not be able to trim contiguous curves to meet one another. If the offset is successful, offsets of those curve types will be created as HermiteSplines.

See Also

Reference

CurveLoop Class
CreateViaOffset Overload


CurveLoop.CreateViaThicken Method

CurveLoopCreateViaThicken Method

Overload List
Name | Description
CreateViaThicken(Curve, Double, XYZ) | Creates a new closed curve loop by thickening the input curve with respect to a given plane.
CreateViaThicken(CurveLoop, Double, XYZ) | Creates a new closed curve loop by thickening the input open curve loop with respect to a given plane.
Top
See Also

Reference

CurveLoop Class


CurveLoop.CreateViaThicken(Curve, Double, XYZ) Method

CurveLoopCreateViaThicken(Curve, Double, XYZ) Method

Creates a new closed curve loop by thickening the input curve with respect to a given plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static CurveLoop CreateViaThicken(
    Curve pCurve,
    double thickness,
    XYZ normal
)
Public Shared Function CreateViaThicken (
    pCurve As Curve,
    thickness As Double,
    normal As XYZ
) As CurveLoop
public:
static CurveLoop^ CreateViaThicken(
    Curve^ pCurve,
    double thickness,
    XYZ^ normal
)
static member CreateViaThicken :
        pCurve : Curve *
        thickness : float *
        normal : XYZ -> CurveLoop

Parameters

pCurve Curve
The input curve.
thickness Double
The distance between the offset curves created on either side of the input curve.
normal XYZ
The normal vector to the plane used for thickening.

Return Value

CurveLoop
The new curve loop.
Exceptions
Exception | Condition
ArgumentException | The input thickness is too short for a curve. -or- The input pCurve points to a helical curve and is not supported for this operation.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Throws if the input curve could not be thickened.
Remarks
The new loop will be created via offsets of the input curve (in the plane of the normal vector) with the endpoints connected with lines.The original curve will be at the center of the new loop.

Note that for input elliptical fragments and NurbSpline curves, any offsets will be created as HermiteSplines.

See Also

Reference

CurveLoop Class
CreateViaThicken Overload


CurveLoop.CreateViaThicken(CurveLoop, Double, XYZ) Method

CurveLoopCreateViaThicken(CurveLoop, Double, XYZ) Method

Creates a new closed curve loop by thickening the input open curve loop with respect to a given plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static CurveLoop CreateViaThicken(
    CurveLoop curveLoop,
    double thickness,
    XYZ normal
)
Public Shared Function CreateViaThicken (
    curveLoop As CurveLoop,
    thickness As Double,
    normal As XYZ
) As CurveLoop
public:
static CurveLoop^ CreateViaThicken(
    CurveLoop^ curveLoop,
    double thickness,
    XYZ^ normal
)
static member CreateViaThicken :
        curveLoop : CurveLoop *
        thickness : float *
        normal : XYZ -> CurveLoop

Parameters

curveLoop CurveLoop
The input curve loop.
thickness Double
The distance between the offset curves created on either side of the input curve.
normal XYZ
The normal vector to the plane used for thickening.

Return Value

CurveLoop
The new curve loop.
Exceptions
Exception | Condition
ArgumentException | The input thickness is too short for a curve. -or- the curve loop is not marked as open.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Throws if the input curve could not be thickened.
Remarks
The new loop will be created via offsets of the input curve loop (in the plane of the normal vector) with the endpoints connected with lines.The original curve loop will be at the center of the new loop.

If the curve loop contains curves such as elliptical segments or splines, it is possible the offset creation will fail if Revit will not be able to trim contiguous curves to meet one another. If the offset is successful, offsets of those curve types will be created as HermiteSplines.

See Also

Reference

CurveLoop Class
CreateViaThicken Overload


CurveLoop.CreateViaTransform Method

CurveLoopCreateViaTransform Method

Creates a new curve loop as a transformed copy of the input curve loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static CurveLoop CreateViaTransform(
    CurveLoop curveLoop,
    Transform transform
)
Public Shared Function CreateViaTransform (
    curveLoop As CurveLoop,
    transform As Transform
) As CurveLoop
public:
static CurveLoop^ CreateViaTransform(
    CurveLoop^ curveLoop,
    Transform^ transform
)
static member CreateViaTransform :
        curveLoop : CurveLoop *
        transform : Transform -> CurveLoop

Parameters

curveLoop CurveLoop
The input curve loop.
transform Transform
The transformation.

Return Value

CurveLoop
The new curve loop.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | transform is not conformal. -or- transform has a scale that is negative or zero.
Remarks
The newly created CurveLoop is guaranteed to be valid with all consituent curves contiguous (assuming that the curves were contiguous in the input curve loop).
See Also

Reference

CurveLoop Class


CurveLoop.Dispose Method

CurveLoopDispose Method

Releases all resources used by the CurveLoop

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

CurveLoop Class


CurveLoop.Flip Method

CurveLoopFlip Method

Reverses the orientation of the curve loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Flip()
Public Sub Flip
public:
void Flip()
member Flip : unit -> unit
See Also

Reference

CurveLoop Class


CurveLoop.GetBasicIEnumerator Method

CurveLoopGetBasicIEnumerator Method

Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
internal virtual IEnumerator GetBasicIEnumerator()
Friend Overridable Function GetBasicIEnumerator As IEnumerator
internal:
virtual IEnumerator^ GetBasicIEnumerator()
internal abstract GetBasicIEnumerator : unit -> IEnumerator
internal override GetBasicIEnumerator : unit -> IEnumerator

Return Value

IEnumerator
An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerableGetEnumerator
See Also

Reference

CurveLoop Class


CurveLoop.GetCurveLoopIterator Method

CurveLoopGetCurveLoopIterator Method

Returns a curve that iterates through the curve loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurveLoopIterator GetCurveLoopIterator()
Public Function GetCurveLoopIterator As CurveLoopIterator
public:
CurveLoopIterator^ GetCurveLoopIterator()
member GetCurveLoopIterator : unit -> CurveLoopIterator

Return Value

CurveLoopIterator
A curve loop iterator object that can be used to iterate through key-value pairs in the collection.
See Also

Reference

CurveLoop Class


CurveLoop.GetEnumerator Method

CurveLoopGetEnumerator Method

Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator<Curve> GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator(Of Curve)
public:
virtual IEnumerator<Curve^>^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator<Curve>
override GetEnumerator : unit -> IEnumerator<Curve>

Return Value

IEnumerator Curve
An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerableTGetEnumerator
See Also

Reference

CurveLoop Class


CurveLoop.GetExactLength Method

CurveLoopGetExactLength Method

Returns the sum of exact lengths of all curves in the loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetExactLength()
Public Function GetExactLength As Double
public:
double GetExactLength()
member GetExactLength : unit -> float

Return Value

Double
The total length of the curves in the loop.
See Also

Reference

CurveLoop Class


CurveLoop.GetPlane Method

CurveLoopGetPlane Method

Gets the plane of the curve loop, if it is planar.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Plane GetPlane()
Public Function GetPlane As Plane
public:
Plane^ GetPlane()
member GetPlane : unit -> Plane

Return Value

Plane
The plane of the curve loop.
Exceptions
Exception | Condition
InvalidOperationException | The curve loop does not lie in a single plane.
See Also

Reference

CurveLoop Class


CurveLoop.GetRectangularHeight Method

CurveLoopGetRectangularHeight Method

Returns the width of a curve loop if it is rectangular with respect to the projection plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetRectangularHeight(
    Plane plane
)
Public Function GetRectangularHeight (
    plane As Plane
) As Double
public:
double GetRectangularHeight(
    Plane^ plane
)
member GetRectangularHeight :
        plane : Plane -> float

Parameters

plane Plane
The plane to which the curves will be projected.

Return Value

Double
The height.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The curve loop is not rectangular when projected to the input plane.
Remarks
The height is determined by the V extents of the UV curve created by from the curve loop plane.
See Also

Reference

CurveLoop Class


CurveLoop.GetRectangularWidth Method

CurveLoopGetRectangularWidth Method

Returns the width of a curve loop if it is rectangular with respect to the projection plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetRectangularWidth(
    Plane plane
)
Public Function GetRectangularWidth (
    plane As Plane
) As Double
public:
double GetRectangularWidth(
    Plane^ plane
)
member GetRectangularWidth :
        plane : Plane -> float

Parameters

plane Plane
The plane to which the curves will be projected.

Return Value

Double
The width.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The curve loop is not rectangular when projected to the input plane.
Remarks
The width is determined by the U extents of the UV curve created by from the curve loop plane.
See Also

Reference

CurveLoop Class


CurveLoop.HasPlane Method

CurveLoopHasPlane Method

Identifies if the CurveLoop is planar.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasPlane()
Public Function HasPlane As Boolean
public:
bool HasPlane()
member HasPlane : unit -> bool

Return Value

Boolean
True if the curve loop is planar, false otherwise.
See Also

Reference

CurveLoop Class


CurveLoop.IsCounterclockwise Method

CurveLoopIsCounterclockwise Method

Determines if this CurveLoop is oriented counter-clockwise (CCW) or clockwise (CW) with respect to the specified 3D direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCounterclockwise(
    XYZ normal
)
Public Function IsCounterclockwise (
    normal As XYZ
) As Boolean
public:
bool IsCounterclockwise(
    XYZ^ normal
)
member IsCounterclockwise :
        normal : XYZ -> bool

Parameters

normal XYZ
The normal vector to the plane used for this determination.

Return Value

Boolean
True if the curve loop is oriented counter-clockwise with respect to the specified 3D direction, false if the loop is oriented clockwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The curve loop is open or consists of a single unbound curve; counterclockwise determination has no meaning.
Remarks
CCW means that the projection of the CurveLoop onto a plane having "normal" as its oriented normal is CCW. This method should only be called if the loop is closed and has a non-singular projection onto the plane (i.e., the projection should have no self-intersections and should not be degenerate or even nearly degenerate). The return value in other cases is indeterminate.
See Also

Reference

CurveLoop Class


CurveLoop.IsOpen Method

CurveLoopIsOpen Method

Returns whether the curve loop is open or closed, as determined by an internal flag.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsOpen()
Public Function IsOpen As Boolean
public:
bool IsOpen()
member IsOpen : unit -> bool

Return Value

Boolean
True if the CurveLoop is marked open, false if marked closed.
Remarks
Some routines in Revit may set the CurveLoop to be marked "open" or "closed" in spite of the actual geometry of the curves. In these special cases, the CurveLoop class does not require that the CurveLoop is correctly marked.
See Also

Reference

CurveLoop Class


CurveLoop.IsRectangular Method

CurveLoopIsRectangular Method

Identifies if the curve loop is rectangular with respect to a given projection plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsRectangular(
    Plane plane
)
Public Function IsRectangular (
    plane As Plane
) As Boolean
public:
bool IsRectangular(
    Plane^ plane
)
member IsRectangular :
        plane : Plane -> bool

Parameters

plane Plane
The plane to which the curves will be projected to determine if they represent a rectangle.

Return Value

Boolean
True if the curve loop is rectangular, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

CurveLoop Class


CurveLoop.NumberOfCurves Method

CurveLoopNumberOfCurves Method

Returns the number of curves in the curve loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int NumberOfCurves()
Public Function NumberOfCurves As Integer
public:
int NumberOfCurves()
member NumberOfCurves : unit -> int

Return Value

Int32
The number of curves in the curve loop.
See Also

Reference

CurveLoop Class


CurveLoop.Transform Method

CurveLoopTransform Method

Transforms this curve loop and all of its component curves by the supplied transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Transform(
    Transform transform
)
Public Sub Transform (
    transform As Transform
)
public:
void Transform(
    Transform^ transform
)
member Transform :
        transform : Transform -> unit

Parameters

transform Transform
The transformation.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | transform is not conformal. -or- transform has a scale that is negative or zero.
Remarks
The modified CurveLoop is guaranteed to be valid with all consituent curves contiguous (assuming that the curves were contiguous in the input curve loop).
See Also

Reference

CurveLoop Class


CurveLoopIterator Class

An iterator to a curve loop.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBCurveLoopIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CurveLoopIterator : IEnumerator<Curve>
Public Class CurveLoopIterator
    Implements IEnumerator(Of Curve)
public ref class CurveLoopIterator : IEnumerator<Curve^>
type CurveLoopIterator =
    class
        interface IEnumerator<Curve>
    end

The CurveLoopIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the CurveLoopIterator
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Increments the iterator to the next item.
Public method | Reset | Resets the iterator to the initial state.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CurveLoopIterator Properties

The CurveLoopIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

CurveLoopIterator Class


CurveLoopIterator.Current Property

CurveLoopIteratorCurrent Property

Gets the item at the current position of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Curve Current { get; }
Public Overridable ReadOnly Property Current As Curve
    Get
public:
virtual property Curve^ Current {
    Curve^ get ();
}
abstract Current : Curve with get
override Current : Curve with get

Property Value

Curve

Implements

IEnumeratorTCurrent
Exceptions
Exception | Condition
InvalidOperationException | There is no current item in the iterator.
Remarks
There is no current item if the iterator has not started yet or has been done.
See Also

Reference

CurveLoopIterator Class


CurveLoopIterator.CurrentObject Property

CurveLoopIteratorCurrentObject Property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
internal Object CurrentObject { get; }
Friend ReadOnly Property CurrentObject As Object
    Get
internal:
virtual property Object^ CurrentObject {
    Object^ get () sealed;
}
internal abstract CurrentObject : Object with get
internal override CurrentObject : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
See Also

Reference

CurveLoopIterator Class


CurveLoopIterator.IsValidObject Property

CurveLoopIteratorIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

CurveLoopIterator Class


CurveLoopIterator Methods

The CurveLoopIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Increments the iterator to the next item.
Public method | Reset | Resets the iterator to the initial state.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CurveLoopIterator Class


CurveLoopIterator.Dispose Method

CurveLoopIteratorDispose Method

Releases all resources used by the CurveLoopIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit
See Also

Reference

CurveLoopIterator Class


CurveLoopIterator.MoveNext Method

CurveLoopIteratorMoveNext Method

Increments the iterator to the next item.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
True if there is a next available item in this iterator. False if the iterator has completed all available items.
Remarks
After an enumerator is created or after the Reset method is called, an enumerator is positioned before the first element of the collection, and the first call to the MoveNext method moves the enumerator over the first element of the collection.
See Also

Reference

CurveLoopIterator Class


CurveLoopIterator.Reset Method

CurveLoopIteratorReset Method

Resets the iterator to the initial state.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit
See Also

Reference

CurveLoopIterator Class


CurveLoopsProfile Class

Represents a curve loop based profile for sweep or swept blend elements.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBSweepProfile
Autodesk.Revit.DBCurveLoopsProfile

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CurveLoopsProfile : SweepProfile
Public Class CurveLoopsProfile
    Inherits SweepProfile
public ref class CurveLoopsProfile : public SweepProfile
type CurveLoopsProfile =
    class
        inherit SweepProfile
    end

The CurveLoopsProfile type exposes the following members.

Properties
 | Name | Description
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Profile | Returns the curve loops of the profile.
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Use objects of this type in methods as NewSweep() and NewSweptBlend() in FamilyItemFactory to create the profile.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CurveLoopsProfile Properties

The CurveLoopsProfile type exposes the following members.

Properties
 | Name | Description
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Profile | Returns the curve loops of the profile.
Top
See Also

Reference

CurveLoopsProfile Class


CurveLoopsProfile.Profile Property

CurveLoopsProfileProfile Property

Returns the curve loops of the profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurveArrArray Profile { get; set; }
Public Property Profile As CurveArrArray
    Get
    Set
public:
property CurveArrArray^ Profile {
    CurveArrArray^ get ();
    void set (CurveArrArray^ value);
}
member Profile : CurveArrArray with get, set

Property Value

CurveArrArray
Remarks
This property is used to retrieve the curve loops of profile.
See Also

Reference

CurveLoopsProfile Class


CurveLoopsProfile Methods

The CurveLoopsProfile type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CurveLoopsProfile Class


CurveNode Class

An output node that represents a model curve.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRenderNode
Autodesk.Revit.DBModelCurveNode
Autodesk.Revit.DBCurveNode

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CurveNode : ModelCurveNode
Public Class CurveNode
    Inherits ModelCurveNode
public ref class CurveNode : public ModelCurveNode
type CurveNode =
    class
        inherit ModelCurveNode
    end

The CurveNode type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode)
Public property | LineProperties | Access to the line (pen) properties of the curve being drawn (Inherited from ModelCurveNode)
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from RenderNode)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCurve | Returns the geometric curve object corresponding to the node.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
See also: OnCurve(CurveNode).
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CurveNode Properties

The CurveNode type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode)
Public property | LineProperties | Access to the line (pen) properties of the curve being drawn (Inherited from ModelCurveNode)
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode)
Top
See Also

Reference

CurveNode Class


CurveNode Methods

The CurveNode type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from RenderNode)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCurve | Returns the geometric curve object corresponding to the node.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CurveNode Class


CurveNode.GetCurve Method

CurveNodeGetCurve Method

Returns the geometric curve object corresponding to the node.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Curve GetCurve()
Public Function GetCurve As Curve
public:
Curve^ GetCurve()
member GetCurve : unit -> Curve

Return Value

Curve
The curve.
See Also

Reference

CurveNode Class


CurveProjectionType Enumeration

This attribute indicates how the curve will be projected to the surface if the curve is sketched on the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum CurveProjectionType
Public Enumeration CurveProjectionType
public enum class CurveProjectionType
type CurveProjectionType
Members
Member name | Value | Description
FromTopDown | 0 | Projects curve in a direction parallel to the height of the project or family (projects in an upwardly or downwardly direction). For example, would be used to project curves to a surface that represented a roof or site, where the goal was for the curves to look from above as they were sketched, even though they are being mapped to the surface.
ParallelToLevel | 1 | The curves are projected to their target surface in a projection direction that is parallel to level. The exact vector of projection also considers the endpoints of the curve being projected or endpoints in a loop of curves it belongs to (if any). But the vector is always parallel to the level. This is used to create curves on the building that retain a particular sketched shape based on elevation perspective, regardless of target surface contours. Sketching windows is an example where this is useful.
FollowSurfaceUV | 2 | The curve is generated on to lie on the surface based on its endpoints/control points on the surface, its curve type, and depending on the surface type, either projecting to the surface based on projecting tessellation points of the curve to the target surface, or by interpreting the equation produced by the curve type and user defined control points in the surface uv. In some ways, this is the most robust way to generate the curve on the surface, but for some surface shapes, it can make it difficult to obtain the desired appearance from a particular perspective in the model.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CurveUV Class

A class that encapsulates the notion of a curve in the 2D parameter space of a surface in 3D space.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBCurveUV

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CurveUV : IDisposable
Public Class CurveUV
    Implements IDisposable
public ref class CurveUV : IDisposable
type CurveUV =
    class
        interface IDisposable
    end

The CurveUV type exposes the following members.

Properties
 | Name | Description
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | As3DCurveInXYPlane | Returns a 3D curve lying in the XY plane in XYZ coordinates, representing the 2D curve with its UV coordinates identified with XY coordinates.
Public method | ComputeDerivatives | Computes the first derivative, the second derivative and the unit tangent vector at the specified parameter along the curve.
 | Create | Create a CurveUV from a bounded 3D Curve lying in the XY plane.
Public method | Dispose | Releases all resources used by the CurveUV
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Evaluate | Evaluates and returns the point at the specified parameter along the curve.
Public method | GetEndParameter | Gets the raw parameter value at the start or end of this curve.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | Transform | Transform this CurveUV by the given 2D affine transform if possible.
Top
Remarks
Revit does not have a class to represent 2D curves explicitly.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CurveUV Properties

The CurveUV type exposes the following members.

Properties
 | Name | Description
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

CurveUV Class


CurveUV.IsBound Property

CurveUVIsBound Property

Describes whether the parameter of the curve is restricted to a particular interval.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsBound { get; }
Public ReadOnly Property IsBound As Boolean
    Get
public:
property bool IsBound {
    bool get ();
}
member IsBound : bool with get

Property Value

Boolean
See Also

Reference

CurveUV Class


CurveUV.IsValidObject Property

CurveUVIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

CurveUV Class


CurveUV Methods

The CurveUV type exposes the following members.

Methods
 | Name | Description
Public method | As3DCurveInXYPlane | Returns a 3D curve lying in the XY plane in XYZ coordinates, representing the 2D curve with its UV coordinates identified with XY coordinates.
Public method | ComputeDerivatives | Computes the first derivative, the second derivative and the unit tangent vector at the specified parameter along the curve.
 | Create | Create a CurveUV from a bounded 3D Curve lying in the XY plane.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Evaluate | Evaluates and returns the point at the specified parameter along the curve.
Public method | GetEndParameter | Gets the raw parameter value at the start or end of this curve.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | Transform | Transform this CurveUV by the given 2D affine transform if possible.
Top
See Also

Reference

CurveUV Class


CurveUV.As3DCurveInXYPlane Method

CurveUVAs3DCurveInXYPlane Method

Returns a 3D curve lying in the XY plane in XYZ coordinates, representing the 2D curve with its UV coordinates identified with XY coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Curve As3DCurveInXYPlane()
Public Function As3DCurveInXYPlane As Curve
public:
Curve^ As3DCurveInXYPlane()
member As3DCurveInXYPlane : unit -> Curve

Return Value

Curve
3D curve lying in the XY plane in XYZ coordinates, representing the 2D curve with its UV coordinates identified with XY coordinates.
Remarks
Ideally, this function should only be used in cases when the 2D curve needs to be used in a context that does not support 2D curves, but can represent them as 3D curves with Z = 0 everywhere (for example, converting the 2D curve to another CAD system that does not support 2D curves).
See Also

Reference

CurveUV Class


CurveUV.ComputeDerivatives Method

CurveUVComputeDerivatives Method

Computes the first derivative, the second derivative and the unit tangent vector at the specified parameter along the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<UV> ComputeDerivatives(
    double parameter,
    bool normalized
)
Public Function ComputeDerivatives (
    parameter As Double,
    normalized As Boolean
) As IList(Of UV)
public:
IList<UV^>^ ComputeDerivatives(
    double parameter,
    bool normalized
)
member ComputeDerivatives :
        parameter : float *
        normalized : bool -> IList<UV>

Parameters

parameter Double
The specified parameter along the curve.
normalized Boolean
If false, parameter is interpreted as natural parameterization of the curve. If true, param is expected to be in [0,1] interval mapped to the bounds of the curve. Setting to true is valid only if the curve is bound.

Return Value

IList UV
The array containing three members: the first derivative (at index [0]), the second derivative (at index [1]) and the unit tangent vector (at index [2]).
Exceptions
Exception | Condition
ArgumentException | The given value for parameter is not finite
ArgumentOutOfRangeException | The curve cannot be evaluated as normalized because it is unbound. -or- The parameter is not a valid value for normalized evaluation.
See Also

Reference

CurveUV Class


CurveUV.Create Method

CurveUVCreate Method

Create a CurveUV from a bounded 3D Curve lying in the XY plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static CurveUV Create(
    Curve curve3D
)
Public Shared Function Create (
    curve3D As Curve
) As CurveUV
public:
static CurveUV^ Create(
    Curve^ curve3D
)
static member Create :
        curve3D : Curve -> CurveUV

Parameters

curve3D Curve
The input bounded 3D Curve lying in the XY plane (i.e., z = 0 everywhere along the curve).

Return Value

CurveUV
The newly created CurveUV.
Exceptions
Exception | Condition
ArgumentException | The input Curve is not a bounded 3D Curve lying in the XY plane (i.e., z = 0 everywhere along the curve).
ArgumentNullException | A non-optional argument was null
Remarks
The XY plane is identified with the uv parameter space of the surface to which this SurfParamSpaceCurve refers.
See Also

Reference

CurveUV Class


CurveUV.Dispose Method

CurveUVDispose Method

Releases all resources used by the CurveUV

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

CurveUV Class


CurveUV.Evaluate Method

CurveUVEvaluate Method

Evaluates and returns the point at the specified parameter along the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public UV Evaluate(
    double parameter,
    bool normalized
)
Public Function Evaluate (
    parameter As Double,
    normalized As Boolean
) As UV
public:
UV^ Evaluate(
    double parameter,
    bool normalized
)
member Evaluate :
        parameter : float *
        normalized : bool -> UV

Parameters

parameter Double
The specified parameter along the curve.
normalized Boolean
If false, parameter is interpreted as natural parameterization of the curve. If true, param is expected to be in [0,1] interval mapped to the bounds of the curve. Setting to true is valid only if the curve is bound.

Return Value

UV
The point evaluated along the curve.
Exceptions
Exception | Condition
ArgumentException | The given value for parameter is not finite
ArgumentOutOfRangeException | The curve cannot be evaluated as normalized because it is unbound. -or- The parameter is not a valid value for normalized evaluation.
See Also

Reference

CurveUV Class


CurveUV.GetEndParameter Method

CurveUVGetEndParameter Method

Gets the raw parameter value at the start or end of this curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetEndParameter(
    int index
)
Public Function GetEndParameter (
    index As Integer
) As Double
public:
double GetEndParameter(
    int index
)
member GetEndParameter :
        index : int -> float

Parameters

index Int32
Use 0 for the start parameter, 1 for the end parameter of the curve.

Return Value

Double
The raw parameter value at the start or end of this curve.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The given value for index is not 0 or 1.
InvalidOperationException | This curve is unbound and does not have start and end points.
See Also

Reference

CurveUV Class


CurveUV.Transform Method

CurveUVTransform Method

Transform this CurveUV by the given 2D affine transform if possible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurveUV Transform(
    Transform2D trfUV
)
Public Function Transform (
    trfUV As Transform2D
) As CurveUV
public:
CurveUV^ Transform(
    Transform2D^ trfUV
)
member Transform :
        trfUV : Transform2D -> CurveUV

Parameters

trfUV Transform2D
The given 2D affine transform.

Return Value

CurveUV
If successful a transformed CurveUV, otherwise .
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

CurveUV Class


CustomExporter Class

A class that allows exporting 3D or 2D views via an export context.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBCustomExporter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CustomExporter : IDisposable
Public Class CustomExporter
    Implements IDisposable
public ref class CustomExporter : IDisposable
type CustomExporter =
    class
        interface IDisposable
    end

The CustomExporter type exposes the following members.

Constructors
 | Name | Description
Public method | CustomExporter | Constructs a new instance of a CustomExporter for a given document using the input instance of IExportContext as the output device.
Top
Properties
 | Name | Description
Public property | Export2DForceDisplayStyle | This value tells the exporter of 2D views to force the given display mode for the view.
Public property | Export2DGeometricObjectsIncludingPatternLines | This flag sets the exporter of 2D views to either include or exclude output of face pattern lines as part of geometric objects when the model is being processed by the export context.
Public property | Export2DIncludingAnnotationObjects | This flag sets the exporter of 2D views to either include or exclude output of annotation objects when the model is being processed by the export context.
Public property | IncludeGeometricObjects | This flag sets the exporter to either include or exclude output of geometric objects such as faces and curves when the model is being processed by the export context.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ShouldStopOnError | This flag instructs the exporting process to either stop or continue in case an error occurs during any of the exporting methods.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the CustomExporter
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Export(IListElementId) | Exports a collection of 3D or 2D views
Public method | Export(View) | Exports one 3D or 2D view
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | IsRenderingSupported | Checks if view rendering is currently supported in the running instance of Revit.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

The Export method of this class triggers standard rendering or exporting process in Revit, but instead of displaying the result on screen or printer, the output is channeled through the given custom context that handles processing of the geometric as well as non-geometric information.

Revit will process the exporting algorithm depending on the type of given context. If an instance of IPhotoRenderContext is used, then Revit will output the model as if executing the Render command, thus only such entities that would be visible in a rendered view will be sent to the context.

Alternatively, if an instance of IModelExportContext is used, Revit will output the model as if exporting it to a CAD format, a process which results outputting also objects that would not appear in a rendered image, such as model curves and text annotations.

For 2D views, an instance of IExportContext2D has to be used. Revit will output the contents of the 2D view as it is displayed on the screen. Export can be modified by setting properties pertaining to 2D views: Export2DGeometricObjectsIncludingPatternLines, Export2DIncludingAnnotationObjects. Export2DForceDisplayStyle. See notes for 2D export in IExportContext2D.

Example
C#
VB
C++
F#
Copy
/// <summary>
/// This method initiates a custom export process for a given 3D view.
/// </summary>
internal void ExportA3DView(Document document, View a3DView)
{
   // Instantiate an export context - the class that receives the output data during
   // export process. The context class must implement the IExportContext interface.
   MyExportContext context = new MyExportContext(document);

   // Create an instance of a custom exporter by giving it a document and the context.
   CustomExporter exporter = new CustomExporter(document, context);

   // Optionally set attributes that should apply to the export process. For example:

   // a) Exclude OnFaceBegin and OnFaceEnd method from being invoked in the export
   //    context if data about faces and edges are not relevant to the export.
   //    Excluding face nodes would dramatically speed up the export process.
   //    Note: Excluding faces just excludes the calls, not the actual processing of
   //    face tessellation. Meshes of the faces will still be received by the context.
   exporter.IncludeGeometricObjects = false;

   // b) Set TRUE or FALSE to abort the export process should an error occur
   exporter.ShouldStopOnError = true;

   // Initiate the export process by calling one of Exporter's 'export' method,
   // in this case the one that takes a single 3D view as an argument.
   exporter.Export(a3DView);
}
' <summary>
' This method initiates a custom export process for a given 3D view.
' </summary>
Friend Sub ExportA3DView(document As Document, a3DView As View)
    ' Instantiate an export context - the class that receives the output data during
    ' export process. The context class must implement the IExportContext interface.
    Dim context As New MyExportContext(document)

    ' Create an instance of a custom exporter by giving it a document and the context.
    Dim exporter As New CustomExporter(document, context)

    ' Optionally set attributes that should apply to the export process. For example:

    ' a) Exclude OnFaceBegin and OnFaceEnd method from being invoked in the export
    '    context if data about faces and edges are not relevant to the export.
    '    Excluding face nodes would dramatically speed up the export process.
    '    Note: Excluding faces just excludes the calls, not the actual processing of
    '    face tessellation. Meshes of the faces will still be received by the context.
    exporter.IncludeGeometricObjects = False

    ' b) Set TRUE or FALSE to abort the export process should an error occur
    exporter.ShouldStopOnError = True

    ' Initiate the export process by calling one of Exporter's 'export' method,
    ' in this case the one that takes a single 3D view as an argument.
    exporter.Export(a3DView)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CustomExporter Constructor

Constructs a new instance of a CustomExporter for a given document using the input instance of IExportContext as the output device.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CustomExporter(
    Document document,
    IExportContext context
)
Public Sub New (
    document As Document,
    context As IExportContext
)
public:
CustomExporter(
    Document^ document,
    IExportContext^ context
)
new :
        document : Document *
        context : IExportContext -> CustomExporter

Parameters

document Document
The document containing the model to be exported
context IExportContext
An instance of a context class that will be consuming the output
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
The input context should be an instance of a class that implements either IModelExportContext or IPhotoRenderContext interfaces.
See Also

Reference

CustomExporter Class


CustomExporter Properties

The CustomExporter type exposes the following members.

Properties
 | Name | Description
Public property | Export2DForceDisplayStyle | This value tells the exporter of 2D views to force the given display mode for the view.
Public property | Export2DGeometricObjectsIncludingPatternLines | This flag sets the exporter of 2D views to either include or exclude output of face pattern lines as part of geometric objects when the model is being processed by the export context.
Public property | Export2DIncludingAnnotationObjects | This flag sets the exporter of 2D views to either include or exclude output of annotation objects when the model is being processed by the export context.
Public property | IncludeGeometricObjects | This flag sets the exporter to either include or exclude output of geometric objects such as faces and curves when the model is being processed by the export context.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ShouldStopOnError | This flag instructs the exporting process to either stop or continue in case an error occurs during any of the exporting methods.
Top
See Also

Reference

CustomExporter Class


CustomExporter.Export2DForceDisplayStyle Property

CustomExporterExport2DForceDisplayStyle Property

This value tells the exporter of 2D views to force the given display mode for the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DisplayStyle Export2DForceDisplayStyle { get; set; }
Public Property Export2DForceDisplayStyle As DisplayStyle
    Get
    Set
public:
property DisplayStyle Export2DForceDisplayStyle {
    DisplayStyle get ();
    void set (DisplayStyle value);
}
member Export2DForceDisplayStyle : DisplayStyle with get, set

Property Value

DisplayStyle
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
Only DisplayStyle::Wireframe and DisplayStyle::HLR values are supported. Default forced value is DisplayStyle::HLR unless the view has DisplayStyle:Wireframe.

See notes for 2D export for views in non-Wireframe display style in [!:Autodesk::Revit::DB::IExportContextBase] and IExportContext2D.

See Also

Reference

CustomExporter Class


CustomExporter.Export2DGeometricObjectsIncludingPatternLines Property

CustomExporterExport2DGeometricObjectsIncludingPatternLines Property

This flag sets the exporter of 2D views to either include or exclude output of face pattern lines as part of geometric objects when the model is being processed by the export context.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Export2DGeometricObjectsIncludingPatternLines { get; set; }
Public Property Export2DGeometricObjectsIncludingPatternLines As Boolean
    Get
    Set
public:
property bool Export2DGeometricObjectsIncludingPatternLines {
    bool get ();
    void set (bool value);
}
member Export2DGeometricObjectsIncludingPatternLines : bool with get, set

Property Value

Boolean
Remarks
This flag is ignored if view has Wireframe display style. This flag is ignored unless property "IncludeGeometricObjects" is set to true.
See Also

Reference

CustomExporter Class


CustomExporter.Export2DIncludingAnnotationObjects Property

CustomExporterExport2DIncludingAnnotationObjects Property

This flag sets the exporter of 2D views to either include or exclude output of annotation objects when the model is being processed by the export context.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Export2DIncludingAnnotationObjects { get; set; }
Public Property Export2DIncludingAnnotationObjects As Boolean
    Get
    Set
public:
property bool Export2DIncludingAnnotationObjects {
    bool get ();
    void set (bool value);
}
member Export2DIncludingAnnotationObjects : bool with get, set

Property Value

Boolean
Remarks
A convenient way of determining whether an element category is annotation is using [!:Autodesk::Revit::DB::Category::CategoryType].
See Also

Reference

CustomExporter Class


CustomExporter.IncludeGeometricObjects Property

CustomExporterIncludeGeometricObjects Property

This flag sets the exporter to either include or exclude output of geometric objects such as faces and curves when the model is being processed by the export context.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IncludeGeometricObjects { get; set; }
Public Property IncludeGeometricObjects As Boolean
    Get
    Set
public:
property bool IncludeGeometricObjects {
    bool get ();
    void set (bool value);
}
member IncludeGeometricObjects : bool with get, set

Property Value

Boolean
Remarks

If geometric objects are to be excluded, the context will not receive any of the calls to related to Faces or Curves. However, the objects will be still processed by Revit resulting in exporting their tessellated geometry in form of polymeshes or lines, respectivelly.

Regardless of the value of this property, the export context must always implement the methods related to receiving of geometric objects (e.g. OnFaceStart, OnFaceEnd, OnCurve, etc.), even though the methods may never be invoked.

Setting this property to False allows clients to significantly speed up the export process. If the export context does not need to examine geometric objects, it is recommended setting this property to False, which will make the export process faster even when compared with export during which notifications about geometric objects are sent, but ignored by the context.

See Also

Reference

CustomExporter Class


CustomExporter.IsValidObject Property

CustomExporterIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

CustomExporter Class


CustomExporter.ShouldStopOnError Property

CustomExporterShouldStopOnError Property

This flag instructs the exporting process to either stop or continue in case an error occurs during any of the exporting methods.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldStopOnError { get; set; }
Public Property ShouldStopOnError As Boolean
    Get
    Set
public:
property bool ShouldStopOnError {
    bool get ();
    void set (bool value);
}
member ShouldStopOnError : bool with get, set

Property Value

Boolean
See Also

Reference

CustomExporter Class


CustomExporter Methods

The CustomExporter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Export(IListElementId) | Exports a collection of 3D or 2D views
Public method | Export(View) | Exports one 3D or 2D view
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | IsRenderingSupported | Checks if view rendering is currently supported in the running instance of Revit.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CustomExporter Class


CustomExporter.Dispose Method

CustomExporterDispose Method

Releases all resources used by the CustomExporter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

CustomExporter Class


CustomExporter.Export Method

CustomExporterExport Method

Overload List
 | Name | Description
Public method | Export(IListElementId) | Exports a collection of 3D or 2D views
Public method | Export(View) | Exports one 3D or 2D view
Top
See Also

Reference

CustomExporter Class


CustomExporter.Export(IList<ElementId>) Method

CustomExporterExport(IListElementId) Method

Exports a collection of 3D or 2D views

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Export(
    IList<ElementId> viewIds
)
Public Sub Export (
    viewIds As IList(Of ElementId)
)
public:
void Export(
    IList<ElementId^>^ viewIds
)
member Export :
        viewIds : IList<ElementId> -> unit

Parameters

viewIds IList ElementId
An array of views to export
Exceptions
Exception | Condition
ArgumentException | One or more elements in viewIds is not a valid exportable view. For example, templates are not considered valid views to export.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The instance of IExportContext is not valid. -or- Rendering is currently not supported in the running instance of Revit. One reason for that to happen is that rendering and material libraries are not currently available.
Remarks

Note that the actual export process may differ depending on the type of export context used. For example, when the IModelExportContext is used, Revit is likely to perform several rounds of traversing each view, which may result in invoking the OnViewBegin/OnViewEnd method multiple times for every one view. It is because Revit draws objects in several layers (model layer, annotation layer, etc.) and will traverse each layer individually. In the most common scenario the user will receive two invocations of OnViewBegin/OnViewEnd: In the first round, all model entities will be received, while in the second round all text annotation elements will be received, if any present in the given view.

Note that all views in the collection must be either 3D or 2D views and they must match the exporter context.

Note that currently the only 2D view types exported are IncludeGeometricObjects FloorPlan, CeilingPlan,Elevation, Section, Detail, EngineeringPlan, AreaPlan.

See Also

Reference

CustomExporter Class
Export Overload


CustomExporter.Export(View) Method

CustomExporterExport(View) Method

Exports one 3D or 2D view

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Export(
    View view
)
Public Sub Export (
    view As View
)
public:
void Export(
    View^ view
)
member Export :
        view : View -> unit

Parameters

view View
An instance of the view to export
Exceptions
Exception | Condition
ArgumentException | The view is not exportable, such as a template view or wrong type view, for example.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The instance of IExportContext is not valid. -or- Rendering is currently not supported in the running instance of Revit. One reason for that to happen is that rendering and material libraries are not currently available.
Remarks

Note that the actual export process may differ depending on the type of export context used. For example, when the IModelExportContext is used, Revit is likely to perform several rounds of traversing each view, which may result in invoking the OnViewBegin/OnViewEnd method multiple times for every one view. It is because Revit draws objects in several layers (model layer, annotation layer, etc.) and will traverse each layer individually. In the most common scenario the user will receive two invocations of OnViewBegin/OnViewEnd: In the first round, all model entities will be received, while in the second round all text annotation elements will be received, if any present in the given view.

See Also

Reference

CustomExporter Class
Export Overload


CustomExporter.IsRenderingSupported Method

CustomExporterIsRenderingSupported Method

Checks if view rendering is currently supported in the running instance of Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsRenderingSupported()
Public Shared Function IsRenderingSupported As Boolean
public:
static bool IsRenderingSupported()
static member IsRenderingSupported : unit -> bool

Return Value

Boolean
Returns True if rendering is currently supported, False otherwise.
Remarks
A typical reason for rendering not being enabled is when rendering and material libraries are not currently available in the installed copy of Revit.
See Also

Reference

CustomExporter Class


CustomFieldData Class

A class that offer access to the information about a custom field.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBCustomFieldData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CustomFieldData : IDisposable
Public Class CustomFieldData
    Implements IDisposable
public ref class CustomFieldData : IDisposable
type CustomFieldData =
    class
        interface IDisposable
    end

The CustomFieldData type exposes the following members.

Properties
 | Name | Description
Public property | DefaultRowHeightOnSheet | Identifies the default row height for this field.
Public property | FieldName | The name of this custom field.
Public property | FieldTooltip | The tooltip that will be shown in the schedule properties dialog for this custom field.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the CustomFieldData
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCustomFieldId | Gets an unique identifier of the custom field.
Public method | GetCustomFieldProperties | Gets an instance of ICustomFieldProperties which represents the properties of this field.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetCustomFieldProperties | Sets an instance of ICustomFieldProperties which represents the properties of this field.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | ValidateCustomFieldProperties | Validates the custom field properties.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CustomFieldData Properties

The CustomFieldData type exposes the following members.

Properties
 | Name | Description
Public property | DefaultRowHeightOnSheet | Identifies the default row height for this field.
Public property | FieldName | The name of this custom field.
Public property | FieldTooltip | The tooltip that will be shown in the schedule properties dialog for this custom field.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

CustomFieldData Class


CustomFieldData.DefaultRowHeightOnSheet Property

CustomFieldDataDefaultRowHeightOnSheet Property

Identifies the default row height for this field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double DefaultRowHeightOnSheet { get; }
Public ReadOnly Property DefaultRowHeightOnSheet As Double
    Get
public:
property double DefaultRowHeightOnSheet {
    double get ();
}
member DefaultRowHeightOnSheet : float with get

Property Value

Double
See Also

Reference

CustomFieldData Class


CustomFieldData.FieldName Property

CustomFieldDataFieldName Property

The name of this custom field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FieldName { get; }
Public ReadOnly Property FieldName As String
    Get
public:
property String^ FieldName {
    String^ get ();
}
member FieldName : string with get

Property Value

String
See Also

Reference

CustomFieldData Class


CustomFieldData.FieldTooltip Property

CustomFieldDataFieldTooltip Property

The tooltip that will be shown in the schedule properties dialog for this custom field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FieldTooltip { get; }
Public ReadOnly Property FieldTooltip As String
    Get
public:
property String^ FieldTooltip {
    String^ get ();
}
member FieldTooltip : string with get

Property Value

String
See Also

Reference

CustomFieldData Class


CustomFieldData.IsValidObject Property

CustomFieldDataIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

CustomFieldData Class


CustomFieldData Methods

The CustomFieldData type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCustomFieldId | Gets an unique identifier of the custom field.
Public method | GetCustomFieldProperties | Gets an instance of ICustomFieldProperties which represents the properties of this field.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetCustomFieldProperties | Sets an instance of ICustomFieldProperties which represents the properties of this field.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | ValidateCustomFieldProperties | Validates the custom field properties.
Top
See Also

Reference

CustomFieldData Class


CustomFieldData.Dispose Method

CustomFieldDataDispose Method

Releases all resources used by the CustomFieldData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

CustomFieldData Class


CustomFieldData.GetCustomFieldId Method

CustomFieldDataGetCustomFieldId Method

Gets an unique identifier of the custom field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid GetCustomFieldId()
Public Function GetCustomFieldId As Guid
public:
Guid GetCustomFieldId()
member GetCustomFieldId : unit -> Guid

Return Value

Guid
Returns an unique identifier of type of custom field.
See Also

Reference

CustomFieldData Class


CustomFieldData.GetCustomFieldProperties Method

CustomFieldDataGetCustomFieldProperties Method

Gets an instance of ICustomFieldProperties which represents the properties of this field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICustomFieldProperties GetCustomFieldProperties()
Public Function GetCustomFieldProperties As ICustomFieldProperties
public:
ICustomFieldProperties^ GetCustomFieldProperties()
member GetCustomFieldProperties : unit -> ICustomFieldProperties

Return Value

ICustomFieldProperties
Returns an instance of ICustomFieldProperties.
Exceptions
Exception | Condition
InvalidOperationException | Can't obtain the properties from a CustomFieldData of a SchedulableField (which is not added to a schedule).
See Also

Reference

CustomFieldData Class


CustomFieldData.SetCustomFieldProperties Method

CustomFieldDataSetCustomFieldProperties Method

Sets an instance of ICustomFieldProperties which represents the properties of this field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetCustomFieldProperties(
    ICustomFieldProperties customFieldProperties
)
Public Sub SetCustomFieldProperties (
    customFieldProperties As ICustomFieldProperties
)
public:
void SetCustomFieldProperties(
    ICustomFieldProperties^ customFieldProperties
)
member SetCustomFieldProperties :
        customFieldProperties : ICustomFieldProperties -> unit

Parameters

customFieldProperties ICustomFieldProperties
An instance of ICustomFieldProperties which represents the properties of this field.
Exceptions
Exception | Condition
ArgumentException | The input properties are not valid.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Can't set the properties to a CustomFieldData of a SchedulableField (which is not added to a schedule).
See Also

Reference

CustomFieldData Class


CustomFieldData.ValidateCustomFieldProperties Method

CustomFieldDataValidateCustomFieldProperties Method

Validates the custom field properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ValidateCustomFieldProperties(
    ICustomFieldProperties customFieldProperties
)
Public Function ValidateCustomFieldProperties (
    customFieldProperties As ICustomFieldProperties
) As String
public:
String^ ValidateCustomFieldProperties(
    ICustomFieldProperties^ customFieldProperties
)
member ValidateCustomFieldProperties :
        customFieldProperties : ICustomFieldProperties -> string

Parameters

customFieldProperties ICustomFieldProperties
An instance of ICustomFieldProperties which represents the properties of this field.

Return Value

String
If the properties are valid, an empty string will be returned. If the properties are not valid, a non-empty string which describes the error will be returned.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Can't validate the properties of a CustomFieldData of a SchedulableField (which is not added to a schedule).
See Also

Reference

CustomFieldData Class


CustomSubCategoryId Enumeration

An enumerated type listing pseudo sub-categories that can appear in a mapping template. These types do not represent an independent category in Revit, but can be mapped to specific IFC entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum CustomSubCategoryId
Public Enumeration CustomSubCategoryId
public enum class CustomSubCategoryId
type CustomSubCategoryId
Members
Member name | Value | Description
InteriorWall | 1 | The custom id representing interior walls.
ExteriorWall | 2 | The custom id representing exterior walls.
FoundationWall | 3 | The custom id representing foundation walls.
RetainingWall | 4 | The custom id representing retaining walls.
Coreshaft | 5 | The custom id representing cores/shafts.
Soffit | 6 | The custom id representing soffits.
None | -1 | The default value for most Revit categories and subcategories.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CutFailureReason Enumeration

The reason why a solid-solid cut cannot be created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum CutFailureReason
Public Enumeration CutFailureReason
public enum class CutFailureReason
type CutFailureReason
Members
Member name | Value | Description
CutAllowed | 0 | Yes, the cutting element can add a cut to the target element.
CutAlreadyExists | 1 | The cutting element has already cut the target element.
OppositeCutExists | 2 | The target element has already cut the cutting element.
CutNotAppropriateForElements | 3 | The cut is not appropriate for the two elements.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CylindricalFace Class

A cylindrical face of a 3d solid or open shell.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGeometryObject
Autodesk.Revit.DBFace
Autodesk.Revit.DBCylindricalFace

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CylindricalFace : Face
Public Class CylindricalFace
    Inherits Face
public ref class CylindricalFace : public Face
type CylindricalFace =
    class
        inherit Face
    end

The CylindricalFace type exposes the following members.

Properties
 | Name | Description
Public property | Area | The area of this face. (Inherited from Face)
Public property | Axis | Axis of the surface.
Public property | EdgeLoops | A collection of edge loops. Each edge loop represents one of the closed boundaries of the face. (Inherited from Face)
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject)
Public property | HasRegions | Identifies if the face contains regions (which can be created, for example, by the Split Face command). (Inherited from Face)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject)
Public property | IsCyclic | Indicates whether the underlying surface is periodic in the specified parametric direction. (Inherited from Face)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject)
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate). (Inherited from Face)
Public property | MaterialElementId | The element ID of the material from which this face is composed. (Inherited from Face)
Public property | OrientationMatchesSurfaceOrientation | Returns true if this face's orientation matches the orientation of the face's surface, false if they have opposite orientations. (Inherited from Face)
Public property | Origin | Origin of the surface.
Public property | Period | The period of the underlying surface in the specified parametric direction. (Inherited from Face)
Public property | Radius | Radii of the surface.
Public property | Reference | Returns a stable reference to the face. (Inherited from Face)
Public property | Visibility | The visibility. (Inherited from GeometryObject)
Top
Methods
 | Name | Description
Public method | ComputeDerivatives | Returns the first partial derivatives of the underlying surface at the specified point. (Inherited from Face)
Public method | ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face)
Public method | ComputeSecondDerivatives | Returns the second partial derivatives of the face at the specified point. (Inherited from Face)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject)
Public method | Evaluate | Evaluates and returns the XYZ coordinates of a point at the indicated UV parameterization of the face. (Inherited from Face)
Public method | GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face)
Public method | GetEdgesAsCurveLoops | Returns a list of closed curve loops that correspond to the edge loops of the face. Curves in each curve loop correspond to individual edges. (Inherited from Face)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject)
Public method | GetRegions | Gets the face regions (created, for example, by the Split Face command) of the face. (Inherited from Face)
Public method | GetSurface | Returns a copy of this face's surface. (Inherited from Face)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face)
Public method | Intersect(Face) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face)
Public method | Intersect(Curve, IntersectionResultArray) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face)
Public method | Intersect(Face, Curve) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face)
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face)
Public method | IsInside(UV, IntersectionResult) | Indicates whether the specified point is within this face and outputs additional information about the point location. (Inherited from Face)
Public method | Project | Projects the specified point on the face. (Inherited from Face)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
 | Triangulate | Returns a triangular mesh approximation to the face. (Inherited from Face)
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face. (Inherited from Face)
Top
Remarks
For details on the parameterization, refer to the documentation for CylindricalSurface.
Example
C#
VB
C++
F#
Copy
private void GetCylindricalFaceInfo(Face face)
{
    CylindricalFace cylindricalFace = face as CylindricalFace;
    if (null != cylindricalFace)
    {
       XYZ axis = cylindricalFace.Axis;
       XYZ origin = cylindricalFace.Origin;
       XYZ radius = cylindricalFace.get_Radius(0);
    }
}
Private Sub GetCylindricalFaceInfo(face As Face)
    Dim cylindricalFace As CylindricalFace = TryCast(face, CylindricalFace)
    If cylindricalFace IsNot Nothing Then
        Dim axis As XYZ = cylindricalFace.Axis
        Dim origin As XYZ = cylindricalFace.Origin
        Dim radius As XYZ = cylindricalFace.Radius(0)
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CylindricalFace Properties

The CylindricalFace type exposes the following members.

Properties
 | Name | Description
Public property | Area | The area of this face. (Inherited from Face)
Public property | Axis | Axis of the surface.
Public property | EdgeLoops | A collection of edge loops. Each edge loop represents one of the closed boundaries of the face. (Inherited from Face)
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject)
Public property | HasRegions | Identifies if the face contains regions (which can be created, for example, by the Split Face command). (Inherited from Face)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject)
Public property | IsCyclic | Indicates whether the underlying surface is periodic in the specified parametric direction. (Inherited from Face)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject)
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate). (Inherited from Face)
Public property | MaterialElementId | The element ID of the material from which this face is composed. (Inherited from Face)
Public property | OrientationMatchesSurfaceOrientation | Returns true if this face's orientation matches the orientation of the face's surface, false if they have opposite orientations. (Inherited from Face)
Public property | Origin | Origin of the surface.
Public property | Period | The period of the underlying surface in the specified parametric direction. (Inherited from Face)
Public property | Radius | Radii of the surface.
Public property | Reference | Returns a stable reference to the face. (Inherited from Face)
Public property | Visibility | The visibility. (Inherited from GeometryObject)
Top
See Also

Reference

CylindricalFace Class


CylindricalFace.Axis Property

CylindricalFaceAxis Property

Axis of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Axis { get; }
Public ReadOnly Property Axis As XYZ
    Get
public:
property XYZ^ Axis {
    XYZ^ get ();
}
member Axis : XYZ with get

Property Value

XYZ
See Also

Reference

CylindricalFace Class


CylindricalFace.Origin Property

CylindricalFaceOrigin Property

Origin of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Origin { get; }
Public ReadOnly Property Origin As XYZ
    Get
public:
property XYZ^ Origin {
    XYZ^ get ();
}
member Origin : XYZ with get

Property Value

XYZ
See Also

Reference

CylindricalFace Class


CylindricalFace.Radius Property

CylindricalFaceRadius Property

Radii of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ this[
    int index
] { get; }
Public ReadOnly Property Radius (
    index As Integer
) As XYZ
    Get
public:
property XYZ^ Radius[int index] {
    XYZ^ get (int index);
}
member Radius : XYZ with get

Parameters

index Int32

Property Value

XYZ
See Also

Reference

CylindricalFace Class


CylindricalFace Methods

The CylindricalFace type exposes the following members.

Methods
 | Name | Description
Public method | ComputeDerivatives | Returns the first partial derivatives of the underlying surface at the specified point. (Inherited from Face)
Public method | ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face)
Public method | ComputeSecondDerivatives | Returns the second partial derivatives of the face at the specified point. (Inherited from Face)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject)
Public method | Evaluate | Evaluates and returns the XYZ coordinates of a point at the indicated UV parameterization of the face. (Inherited from Face)
Public method | GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face)
Public method | GetEdgesAsCurveLoops | Returns a list of closed curve loops that correspond to the edge loops of the face. Curves in each curve loop correspond to individual edges. (Inherited from Face)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject)
Public method | GetRegions | Gets the face regions (created, for example, by the Split Face command) of the face. (Inherited from Face)
Public method | GetSurface | Returns a copy of this face's surface. (Inherited from Face)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face)
Public method | Intersect(Face) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face)
Public method | Intersect(Curve, IntersectionResultArray) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face)
Public method | Intersect(Face, Curve) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face)
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face)
Public method | IsInside(UV, IntersectionResult) | Indicates whether the specified point is within this face and outputs additional information about the point location. (Inherited from Face)
Public method | Project | Projects the specified point on the face. (Inherited from Face)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
 | Triangulate | Returns a triangular mesh approximation to the face. (Inherited from Face)
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face. (Inherited from Face)
Top
See Also

Reference

CylindricalFace Class


CylindricalHelix Class

A cylindrical helix.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGeometryObject
Autodesk.Revit.DBCurve
Autodesk.Revit.DBCylindricalHelix

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CylindricalHelix : Curve
Public Class CylindricalHelix
    Inherits Curve
public ref class CylindricalHelix : public Curve
type CylindricalHelix =
    class
        inherit Curve
    end

The CylindricalHelix type exposes the following members.

Properties
 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve)
Public property | BasePoint | The base point of the axis of the cylindrical helix.
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject)
Public property | Height | Height of the cylindrical helix.
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve)
Public property | IsClosed | Describes whether the curve is closed. (Inherited from Curve)
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject)
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | IsRightHanded | True if the helix is right handed, false if the helix is left handed.
Public property | Length | The exact length of the curve. (Inherited from Curve)
Public property | Period | The period of this curve. (Inherited from Curve)
Public property | Pitch | The pitch of the cylindrical helix.
Public property | Radius | The radius of the cylindrical helix.
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve)
Public property | Visibility | The visibility. (Inherited from GeometryObject)
Public property | XVector | The X direction vector.
Public property | YVector | The Y direction vector.
Public property | ZVector | The Z direction vector, which is same as the axis direction vector.
Top
Methods
 | Name | Description
Public method | Clone | Returns a copy of this curve. (Inherited from Curve)
Public method | ComputeClosestPoints | Find the closest points between two curves. Closest points mean closest pairs of points, each pair consisting of a point on this, say P1, and a point on other curve, say P2. P1 and P2 are closest locally. Each pairs of closest points will be represented by the corresponding parameter values with respect to the two curves and the 3d points. A closest pair is also known as a pair of critical points of the distance function between points of the two curves. If the input parameter returnAllCriticalPoints is set to false, then the function will return only pairs with minimum distance. (Inherited from Curve)
Public method | ComputeDerivatives | Returns the vectors describing the curve at the specified parameter. (Inherited from Curve)
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve)
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve)
 | Create | Create a cylindrical helix.
Public method | CreateOffset | Creates a new curve that is an offset of the existing curve. (Inherited from Curve)
Public method | CreateReversed | Creates a new curve with the opposite orientation of the existing curve. (Inherited from Curve)
Public method | CreateTransformed | Crates a new instance of a curve as a transformation of this curve. (Inherited from Curve)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject)
Public method | Evaluate | Evaluates and returns the point that matches a parameter along the curve. (Inherited from Curve)
Public method | GetEndParameter | Returns the raw parameter value at the start or end of this curve. (Inherited from Curve)
Public method | GetEndPoint | Returns the 3D point at the start or end of this curve. (Inherited from Curve)
Public method | GetEndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve)
Public method | Intersect(Curve, IntersectionResultArray) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve)
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve)
Public method | IsInside(Double, Int32) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve)
Public method | MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve)
Public method | MakeUnbound | Makes this curve unbound. (Inherited from Curve)
Public method | Project | Projects the specified point on this curve. (Inherited from Curve)
Public method | SetGraphicsStyleId | Sets the graphics style id for this curve. (Inherited from Curve)
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The helix winds around a cylinder making constant angle with the axis of the cylinder. In this release, CylindricalHelix curves are used only in specific applications in stairs and railings, and should not be used or encountered when accessing curves of other Revit elements and geometry.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CylindricalHelix Properties

The CylindricalHelix type exposes the following members.

Properties
 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve)
Public property | BasePoint | The base point of the axis of the cylindrical helix.
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject)
Public property | Height | Height of the cylindrical helix.
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve)
Public property | IsClosed | Describes whether the curve is closed. (Inherited from Curve)
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject)
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | IsRightHanded | True if the helix is right handed, false if the helix is left handed.
Public property | Length | The exact length of the curve. (Inherited from Curve)
Public property | Period | The period of this curve. (Inherited from Curve)
Public property | Pitch | The pitch of the cylindrical helix.
Public property | Radius | The radius of the cylindrical helix.
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve)
Public property | Visibility | The visibility. (Inherited from GeometryObject)
Public property | XVector | The X direction vector.
Public property | YVector | The Y direction vector.
Public property | ZVector | The Z direction vector, which is same as the axis direction vector.
Top
See Also

Reference

CylindricalHelix Class


CylindricalHelix.BasePoint Property

CylindricalHelixBasePoint Property

The base point of the axis of the cylindrical helix.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ BasePoint { get; }
Public ReadOnly Property BasePoint As XYZ
    Get
public:
property XYZ^ BasePoint {
    XYZ^ get ();
}
member BasePoint : XYZ with get

Property Value

XYZ
See Also

Reference

CylindricalHelix Class


CylindricalHelix.Height Property

CylindricalHelixHeight Property

Height of the cylindrical helix.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Height { get; }
Public ReadOnly Property Height As Double
    Get
public:
property double Height {
    double get ();
}
member Height : float with get

Property Value

Double
Exceptions
Exception | Condition
InapplicableDataException | Height is not defined for unbounded helix.
Remarks
It is the length of the span of the helix along the axis direction. The height is defined only if the helix is bounded. That is, its start and end angles (parameters) are specified.
See Also

Reference

CylindricalHelix Class


CylindricalHelix.IsRightHanded Property

CylindricalHelixIsRightHanded Property

True if the helix is right handed, false if the helix is left handed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsRightHanded { get; }
Public ReadOnly Property IsRightHanded As Boolean
    Get
public:
property bool IsRightHanded {
    bool get ();
}
member IsRightHanded : bool with get

Property Value

Boolean
See Also

Reference

CylindricalHelix Class


CylindricalHelix.Pitch Property

CylindricalHelixPitch Property

The pitch of the cylindrical helix.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Pitch { get; }
Public ReadOnly Property Pitch As Double
    Get
public:
property double Pitch {
    double get ();
}
member Pitch : float with get

Property Value

Double
Remarks
It is the distance moved along the axis direction when a point makes one rotation about the axis. Pitch can be positive or negative.
See Also

Reference

CylindricalHelix Class


CylindricalHelix.Radius Property

CylindricalHelixRadius Property

The radius of the cylindrical helix.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Radius { get; }
Public ReadOnly Property Radius As Double
    Get
public:
property double Radius {
    double get ();
}
member Radius : float with get

Property Value

Double
See Also

Reference

CylindricalHelix Class


CylindricalHelix.XVector Property

CylindricalHelixXVector Property

The X direction vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ XVector { get; }
Public ReadOnly Property XVector As XYZ
    Get
public:
property XYZ^ XVector {
    XYZ^ get ();
}
member XVector : XYZ with get

Property Value

XYZ
See Also

Reference

CylindricalHelix Class


CylindricalHelix.YVector Property

CylindricalHelixYVector Property

The Y direction vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ YVector { get; }
Public ReadOnly Property YVector As XYZ
    Get
public:
property XYZ^ YVector {
    XYZ^ get ();
}
member YVector : XYZ with get

Property Value

XYZ
See Also

Reference

CylindricalHelix Class


CylindricalHelix.ZVector Property

CylindricalHelixZVector Property

The Z direction vector, which is same as the axis direction vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ ZVector { get; }
Public ReadOnly Property ZVector As XYZ
    Get
public:
property XYZ^ ZVector {
    XYZ^ get ();
}
member ZVector : XYZ with get

Property Value

XYZ
See Also

Reference

CylindricalHelix Class


CylindricalHelix Methods

The CylindricalHelix type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Returns a copy of this curve. (Inherited from Curve)
Public method | ComputeClosestPoints | Find the closest points between two curves. Closest points mean closest pairs of points, each pair consisting of a point on this, say P1, and a point on other curve, say P2. P1 and P2 are closest locally. Each pairs of closest points will be represented by the corresponding parameter values with respect to the two curves and the 3d points. A closest pair is also known as a pair of critical points of the distance function between points of the two curves. If the input parameter returnAllCriticalPoints is set to false, then the function will return only pairs with minimum distance. (Inherited from Curve)
Public method | ComputeDerivatives | Returns the vectors describing the curve at the specified parameter. (Inherited from Curve)
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve)
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve)
 | Create | Create a cylindrical helix.
Public method | CreateOffset | Creates a new curve that is an offset of the existing curve. (Inherited from Curve)
Public method | CreateReversed | Creates a new curve with the opposite orientation of the existing curve. (Inherited from Curve)
Public method | CreateTransformed | Crates a new instance of a curve as a transformation of this curve. (Inherited from Curve)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject)
Public method | Evaluate | Evaluates and returns the point that matches a parameter along the curve. (Inherited from Curve)
Public method | GetEndParameter | Returns the raw parameter value at the start or end of this curve. (Inherited from Curve)
Public method | GetEndPoint | Returns the 3D point at the start or end of this curve. (Inherited from Curve)
Public method | GetEndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve)
Public method | Intersect(Curve, IntersectionResultArray) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve)
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve)
Public method | IsInside(Double, Int32) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve)
Public method | MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve)
Public method | MakeUnbound | Makes this curve unbound. (Inherited from Curve)
Public method | Project | Projects the specified point on this curve. (Inherited from Curve)
Public method | SetGraphicsStyleId | Sets the graphics style id for this curve. (Inherited from Curve)
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CylindricalHelix Class


CylindricalHelix.Create Method

CylindricalHelixCreate Method

Create a cylindrical helix.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static CylindricalHelix Create(
    XYZ basePoint,
    double radius,
    XYZ xVector,
    XYZ zVector,
    double pitch,
    double startAngle,
    double endAngle
)
Public Shared Function Create (
    basePoint As XYZ,
    radius As Double,
    xVector As XYZ,
    zVector As XYZ,
    pitch As Double,
    startAngle As Double,
    endAngle As Double
) As CylindricalHelix
public:
static CylindricalHelix^ Create(
    XYZ^ basePoint,
    double radius,
    XYZ^ xVector,
    XYZ^ zVector,
    double pitch,
    double startAngle,
    double endAngle
)
static member Create :
        basePoint : XYZ *
        radius : float *
        xVector : XYZ *
        zVector : XYZ *
        pitch : float *
        startAngle : float *
        endAngle : float -> CylindricalHelix

Parameters

basePoint XYZ
Base point of the axis. It can be any point in 3d.
radius Double
Radius. It should be a positive number.
xVector XYZ
X vector. Should be Non-zero vector.
zVector XYZ
Z vector = axis direction. Should be non-zero and orthogonal to X Vector.
pitch Double
Pitch. It should be non-zero number, can be positive or negative. Positive means right handed and negative means left handed.
startAngle Double
Start angle. It specifies the start point of the Helix.
endAngle Double
End angle. It specifies the end point of the Helix. End angle should not be equal to start angle.

Return Value

CylindricalHelix
Exceptions
Exception | Condition
ArgumentException | The radius is negative -or- the pitch is zero -or- the xVector or zVector is zero length -or- zVector is not orthogonal to xVector -or- endAngle is equal to startAngle.
See Also

Reference

CylindricalHelix Class


CylindricalSurface Class

A cylindrical surface.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSurface
Autodesk.Revit.DBCylindricalSurface

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CylindricalSurface : Surface
Public Class CylindricalSurface
    Inherits Surface
public ref class CylindricalSurface : public Surface
type CylindricalSurface =
    class
        inherit Surface
    end

The CylindricalSurface type exposes the following members.

Properties
 | Name | Description
Public property | Axis | Axis of the cylinder. This is the Z axis of the local coordinate system associated with this cylinder.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Surface)
Public property | OrientationMatchesParametricOrientation | Indicates whether this Surface's orientation is the same as or opposite to its parametric orientation. (Inherited from Surface)
Public property | Origin | Center of the circle that defines the base of the cylinder. This is the origin of the local coordinate system associated with this cylinder.
Public property | Radius | Radius of the circle that defines the base of this cylinder.
Public property | XDir | X axis of the local coordinate system associated with this cylinder.
Public property | YDir | Y axis of the local coordinate system associated with this cylinder.
Top
Methods
 | Name | Description
 | Create | Construct a cylindrical surface defined by a local coordinate system and a radius.
Public method | Dispose | (Inherited from Surface)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBoundingBoxUV | Gets the UV bounding box of the surface. (Inherited from Surface)
Public method | GetFrameOfReference | Returns frame of reference associated with this CylindricalSurface.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Project | Project a 3D point orthogonally onto a surface (to find the nearest point). Throws InvalidOperationException if the projection fails. (Inherited from Surface)
Public method | ProjectWithGuessPoint | Project a 3D point orthogonally onto a surface (to find the nearest point). This method is meant to be used when a good approximate solution for the projection is available. Throws InvalidOperationException if the projection fails. (Inherited from Surface)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The parametric equation of the cylinder is S(u, v) = center + radius*cos(u)*xVec + radius*sin(u)*yVec + v*zVec.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


CylindricalSurface Properties

The CylindricalSurface type exposes the following members.

Properties
 | Name | Description
Public property | Axis | Axis of the cylinder. This is the Z axis of the local coordinate system associated with this cylinder.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Surface)
Public property | OrientationMatchesParametricOrientation | Indicates whether this Surface's orientation is the same as or opposite to its parametric orientation. (Inherited from Surface)
Public property | Origin | Center of the circle that defines the base of the cylinder. This is the origin of the local coordinate system associated with this cylinder.
Public property | Radius | Radius of the circle that defines the base of this cylinder.
Public property | XDir | X axis of the local coordinate system associated with this cylinder.
Public property | YDir | Y axis of the local coordinate system associated with this cylinder.
Top
See Also

Reference

CylindricalSurface Class


CylindricalSurface.Axis Property

CylindricalSurfaceAxis Property

Axis of the cylinder. This is the Z axis of the local coordinate system associated with this cylinder.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Axis { get; }
Public ReadOnly Property Axis As XYZ
    Get
public:
property XYZ^ Axis {
    XYZ^ get ();
}
member Axis : XYZ with get

Property Value

XYZ
See Also

Reference

CylindricalSurface Class


CylindricalSurface.Origin Property

CylindricalSurfaceOrigin Property

Center of the circle that defines the base of the cylinder. This is the origin of the local coordinate system associated with this cylinder.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Origin { get; }
Public ReadOnly Property Origin As XYZ
    Get
public:
property XYZ^ Origin {
    XYZ^ get ();
}
member Origin : XYZ with get

Property Value

XYZ
See Also

Reference

CylindricalSurface Class


CylindricalSurface.Radius Property

CylindricalSurfaceRadius Property

Radius of the circle that defines the base of this cylinder.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Radius { get; }
Public ReadOnly Property Radius As Double
    Get
public:
property double Radius {
    double get ();
}
member Radius : float with get

Property Value

Double
See Also

Reference

CylindricalSurface Class


CylindricalSurface.XDir Property

CylindricalSurfaceXDir Property

X axis of the local coordinate system associated with this cylinder.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ XDir { get; }
Public ReadOnly Property XDir As XYZ
    Get
public:
property XYZ^ XDir {
    XYZ^ get ();
}
member XDir : XYZ with get

Property Value

XYZ
See Also

Reference

CylindricalSurface Class


CylindricalSurface.YDir Property

CylindricalSurfaceYDir Property

Y axis of the local coordinate system associated with this cylinder.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ YDir { get; }
Public ReadOnly Property YDir As XYZ
    Get
public:
property XYZ^ YDir {
    XYZ^ get ();
}
member YDir : XYZ with get

Property Value

XYZ
See Also

Reference

CylindricalSurface Class


CylindricalSurface Methods

The CylindricalSurface type exposes the following members.

Methods
 | Name | Description
 | Create | Construct a cylindrical surface defined by a local coordinate system and a radius.
Public method | Dispose | (Inherited from Surface)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBoundingBoxUV | Gets the UV bounding box of the surface. (Inherited from Surface)
Public method | GetFrameOfReference | Returns frame of reference associated with this CylindricalSurface.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Project | Project a 3D point orthogonally onto a surface (to find the nearest point). Throws InvalidOperationException if the projection fails. (Inherited from Surface)
Public method | ProjectWithGuessPoint | Project a 3D point orthogonally onto a surface (to find the nearest point). This method is meant to be used when a good approximate solution for the projection is available. Throws InvalidOperationException if the projection fails. (Inherited from Surface)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CylindricalSurface Class


CylindricalSurface.Create Method

CylindricalSurfaceCreate Method

Construct a cylindrical surface defined by a local coordinate system and a radius.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static CylindricalSurface Create(
    Frame frameOfReference,
    double radius
)
Public Shared Function Create (
    frameOfReference As Frame,
    radius As Double
) As CylindricalSurface
public:
static CylindricalSurface^ Create(
    Frame^ frameOfReference,
    double radius
)
static member Create :
        frameOfReference : Frame *
        radius : float -> CylindricalSurface

Parameters

frameOfReference Frame
frameOfReference is an orthonormal frame that defines a local coordinate system for the cylinder.
  • Frame.Origin is a point on the cylinder's axis.
  • Frame.BasisZ points along the axis, while Frame.BasisX and Frame.BasisY are orthogonal to the axis.
  • The frame may be either left-handed or right-handed (see Frame.IsRightHanded). Note that the "handedness" of the frame does not, by itself, determine the surface's orientation.
radius Double
Radius of the circle that defines the base of the cylindrical surface.

Return Value

CylindricalSurface
The created CylindricalSurface.
Exceptions
Exception | Condition
ArgumentException | This Frame object may not be used as a local frame of reference.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | The given value for radius must be greater than 0 and no more than 30000 feet.
Remarks
The parametric equation of the cylinder is S(u, v) = Frame.Origin + radius*cos(u)*Frame.BasisX + radius*sin(u)*Frame.BasisY + v*Frame.BasisZ. This implies the following facts:
  • Frame.BasisX points from the axis point to the point on the cylinder with coordinates (0, 0).
  • Frame.BasisY points in the direction of the partial derivative dS/du at (0, 0).
  • Frame.BasisZ points in the direction of the partial derivative dS/dv at (0, 0).
See Also

Reference

CylindricalSurface Class


CylindricalSurface.GetFrameOfReference Method

CylindricalSurfaceGetFrameOfReference Method

Returns frame of reference associated with this CylindricalSurface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Frame GetFrameOfReference()
Public Function GetFrameOfReference As Frame
public:
Frame^ GetFrameOfReference()
member GetFrameOfReference : unit -> Frame

Return Value

Frame
Frame of reference associated with this CylindricalSurface.
Remarks
This is an equivalent of new Frame(Origin, XDir, YDir, Axis).
See Also

Reference

CylindricalSurface Class


DataConversionMonitorScope Class

This class is used to regsiter an application-supplied object that implements IDataConversionMonitor. Creating the object registers an implementation of IDataConversionMonitor supplied as constructor argument. When the scope object is destroyed, that object is unregistered.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBDataConversionMonitorScope

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DataConversionMonitorScope : IDisposable
Public Class DataConversionMonitorScope
    Implements IDisposable
public ref class DataConversionMonitorScope : IDisposable
type DataConversionMonitorScope =
    class
        interface IDisposable
    end

The DataConversionMonitorScope type exposes the following members.

Constructors
 | Name | Description
Public method | DataConversionMonitorScope | The only constructor. Expects a valid pointer to IDataConversionMonitor.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the DataConversionMonitorScope
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DataConversionMonitorScope Constructor

The only constructor. Expects a valid pointer to IDataConversionMonitor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DataConversionMonitorScope(
    IDataConversionMonitor IDCM
)
Public Sub New (
    IDCM As IDataConversionMonitor
)
public:
DataConversionMonitorScope(
    IDataConversionMonitor^ IDCM
)
new :
        IDCM : IDataConversionMonitor -> DataConversionMonitorScope

Parameters

IDCM IDataConversionMonitor
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DataConversionMonitorScope Class


DataConversionMonitorScope Properties

The DataConversionMonitorScope type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

DataConversionMonitorScope Class


DataConversionMonitorScope.IsValidObject Property

DataConversionMonitorScopeIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

DataConversionMonitorScope Class


DataConversionMonitorScope Methods

The DataConversionMonitorScope type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DataConversionMonitorScope Class


DataConversionMonitorScope.Dispose Method

DataConversionMonitorScopeDispose Method

Releases all resources used by the DataConversionMonitorScope

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

DataConversionMonitorScope Class


DataExchangeMessageId Enumeration

Predefined message ids for DataExchangeLog.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DataExchangeMessageId
Public Enumeration DataExchangeMessageId
public enum class DataExchangeMessageId
type DataExchangeMessageId
Members
Member name | Value | Description
None | 0 | No message.
UnitOfProgressCompleted | 1 | That message will be sent at reasonable intervals to provide the using application an opportunity to update its progress indicator.
ObjectCreated | 2 | An informational message. An object - a face, edge, solid, etc. - has been created successfully.
UnexpectedResult | 3 | Unexpected result produced by a data conversion operation. Conversion may continue, but the results should be carefully reviewed.
InvalidSourceObject | 4 | An error message. A source object was found to be invalid.
InvalidDataSet | 5 | No data could be imported. Would typically be reported as a error. May be reported as a fatal error.
GenericError | 6 | A catch-all error code. Used for errors that are not enumerated explicitly.
ObjectNotSupported | 7 | A warning message. A source object was not converted.
ObjectNotConverted | 8 | An error message. The conversion code was unable to process a valid supported source object.
InvalidRenderingStyle | 9 | An error message. The conversion code was unable to process a render style. The created model will differ in visual appearance.
EmptyObject | 10 | A warning level message. The conversion encountered an object with no data to convert. The object will be ignored. This may indicate a problem with incoming data.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DataExchangeMessageSeverity Enumeration

Error levels for DataExchangeLog

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DataExchangeMessageSeverity
Public Enumeration DataExchangeMessageSeverity
public enum class DataExchangeMessageSeverity
type DataExchangeMessageSeverity
Members
Member name | Value | Description
Info | 0 | Informational message, such as successful creation fo a face, edge or a solid.
Warning | 1 | A potential problem. The converted data should be carefully examined and/or compared to the source data
Error | 2 | A problem. The converted data should be carefully examined and/or compared to the source data. The application may want to cancel the conversion process.
FatalError | 3 | A serious problem that makes further data conversion pointless. The conversion process will be cancelled.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DataExchangeMessageVerbosity Enumeration

Predefined verbosity levels for DataExchangeLog

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DataExchangeMessageVerbosity
Public Enumeration DataExchangeMessageVerbosity
public enum class DataExchangeMessageVerbosity
type DataExchangeMessageVerbosity
Members
Member name | Value | Description
Minimal | 0 | Minimal verbosity. Only fatal errors are reported.
Default | 1 | Default verbosity. Warnings, errors, fatal errors are reported.
Verbose | 2 | All events are reported.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DatumEnds Enumeration

An enumerated type representing ends of a datum plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DatumEnds
Public Enumeration DatumEnds
public enum class DatumEnds
type DatumEnds
Members
Member name | Value | Description
End0 | 0 | The start point of the datum plane in the view.
End1 | 1 | The end point of the datum plane in the view.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DatumExtentType Enumeration

Represents the type of datum extent that is displayed in a particular view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DatumExtentType
Public Enumeration DatumExtentType
public enum class DatumExtentType
type DatumExtentType
Members
Member name | Value | Description
Model | 0 | The extent represents the actual 3D extent of the datum plane.
ViewSpecific | 1 | The extent displayed is specific to the view and does not represent the actual 3D extent of the datum plane.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DatumPlane Class

A base class representing a datum surface (level, grid or reference plane) in Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBDatumPlane
Autodesk.Revit.DBGrid
Autodesk.Revit.DBLevel
Autodesk.Revit.DBReferencePlane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DatumPlane : Element
Public Class DatumPlane
    Inherits Element
public ref class DatumPlane : public Element
type DatumPlane =
    class
        inherit Element
    end

The DatumPlane type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | AddLeader | Adds a default Leader for the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders).
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanBeVisibleInView | Checks if the datum plane can be visible in the view.
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetCurvesInView | Gets a collection of curves representing the DatumPlane element in the given view.
Public method | GetDatumExtentTypeInView | Identifies whether the curve representing the datum plane is displayed according to its actual 3d extents, or else according to a view specific setting.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLeader | Gets a copy of the leader applied to the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders).
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPropagationViews | Gets a list of candidate views which are parallel to the current view and to which the extents of the datum may be propagated.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasBubbleInView | Identifies if the DatumPlane has bubble or not.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HideBubbleInView | Hides the bubble in a view. This method does not apply to Reference planes.
Public method | IsBubbleVisibleInView | Identifies if the bubble is visible or not in a view.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsCurveValidInView | Checks if the curve is valid to be as the extents for the datum plane in a view. The curve must be bound and coincident with the original one of the datum plane.
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsLeaderValid | Identifies if the leader valid or not for this DatumPlane. This method does not apply to Reference planes (which do not support leaders).
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | Maximize3DExtents | Computes the 3d extents of all model geometry and levels, and extends the 3d extents of this datum surface to include the model extents.
Public method | PropagateToViews | Propagates the extents applied to this datum in the view to the specified parallel views.
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetCurveInView | Sets the extents to match the curve.
Public method | SetDatumExtentType | Sets whether the curve representing the datum plane is displayed according to its 3d extents, or else according to a view specific setting.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetLeader | Sets the leader to the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders).
Public method | ShowBubbleInView | Shows the bubble in a view. This method does not apply to Reference planes.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
A DatumPlane represents a 3d surface with finite extents. It can be either a rectangle with arbitrary orientation, or a cylinder whose axis is parallel to the project z-axis. If a datum is visible in a plan or section view, it will be displayed as one or more curves. These curves are determined by the intersection of the datum surface with the cut plane of the view. By default, the extents of these curves reflect the 3d extents of the datum surface. If the surface is a plane, then the extents represent the projection of the surface onto the cut plane. This matters, for example, when viewing a datum plane, really a 3d rectangle, along one of its diagonals. The extents of the curve do not vary with the location of the view, because we use the projection of the rectangle and not the actual intersection. If the surface is a cylinder, then the extents reflect the actual intersection of the surface with the cut plane. In addition, the curves that represent a DatumPlane can be modified on a view specific basis. In this case, the ends of the curve no longer reflect the 3d extents of the datum.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DatumPlane Properties

The DatumPlane type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

DatumPlane Class


DatumPlane Methods

The DatumPlane type exposes the following members.

Methods
 | Name | Description
Public method | AddLeader | Adds a default Leader for the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders).
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanBeVisibleInView | Checks if the datum plane can be visible in the view.
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetCurvesInView | Gets a collection of curves representing the DatumPlane element in the given view.
Public method | GetDatumExtentTypeInView | Identifies whether the curve representing the datum plane is displayed according to its actual 3d extents, or else according to a view specific setting.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLeader | Gets a copy of the leader applied to the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders).
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPropagationViews | Gets a list of candidate views which are parallel to the current view and to which the extents of the datum may be propagated.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasBubbleInView | Identifies if the DatumPlane has bubble or not.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HideBubbleInView | Hides the bubble in a view. This method does not apply to Reference planes.
Public method | IsBubbleVisibleInView | Identifies if the bubble is visible or not in a view.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsCurveValidInView | Checks if the curve is valid to be as the extents for the datum plane in a view. The curve must be bound and coincident with the original one of the datum plane.
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsLeaderValid | Identifies if the leader valid or not for this DatumPlane. This method does not apply to Reference planes (which do not support leaders).
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | Maximize3DExtents | Computes the 3d extents of all model geometry and levels, and extends the 3d extents of this datum surface to include the model extents.
Public method | PropagateToViews | Propagates the extents applied to this datum in the view to the specified parallel views.
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetCurveInView | Sets the extents to match the curve.
Public method | SetDatumExtentType | Sets whether the curve representing the datum plane is displayed according to its 3d extents, or else according to a view specific setting.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetLeader | Sets the leader to the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders).
Public method | ShowBubbleInView | Shows the bubble in a view. This method does not apply to Reference planes.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DatumPlane Class


DatumPlane.AddLeader Method

DatumPlaneAddLeader Method

Adds a default Leader for the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Leader AddLeader(
    DatumEnds datumEnd,
    View view
)
Public Function AddLeader (
    datumEnd As DatumEnds,
    view As View
) As Leader
public:
Leader^ AddLeader(
    DatumEnds datumEnd,
    View^ view
)
member AddLeader :
        datumEnd : DatumEnds *
        view : View -> Leader

Parameters

datumEnd DatumEnds
The end of the datum plane.
view View
The view on which the DatumPlane shows.

Return Value

Leader
The Leader of the datum plane. Null will return if the view is null.
Exceptions
Exception | Condition
ArgumentException | The datum plane cannot be visible in the view. -or- The bubble is not visible at the datumEnd of the datum plane.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | This datum plane has no leaders. -or- The DatumPlane already has a leader applied.
Remarks
The leader can be added only to ends where the bubble is set to be shown and does not have a leader applied.
See Also

Reference

DatumPlane Class


DatumPlane.CanBeVisibleInView Method

DatumPlaneCanBeVisibleInView Method

Checks if the datum plane can be visible in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanBeVisibleInView(
    View view
)
Public Function CanBeVisibleInView (
    view As View
) As Boolean
public:
bool CanBeVisibleInView(
    View^ view
)
member CanBeVisibleInView :
        view : View -> bool

Parameters

view View
The view.

Return Value

Boolean
True if visible, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
This method determines if the orientation of the DatumPlane and View allows that the DatumPlane can be seen in the indicated view. It does not actually determine if the DatumPlane is visible, as many factors can affect the visibility of an element in a given view (for example, hiding the element).
See Also

Reference

DatumPlane Class


DatumPlane.GetCurvesInView Method

DatumPlaneGetCurvesInView Method

Gets a collection of curves representing the DatumPlane element in the given view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<Curve> GetCurvesInView(
    DatumExtentType extentMode,
    View view
)
Public Function GetCurvesInView (
    extentMode As DatumExtentType,
    view As View
) As IList(Of Curve)
public:
IList<Curve^>^ GetCurvesInView(
    DatumExtentType extentMode,
    View^ view
)
member GetCurvesInView :
        extentMode : DatumExtentType *
        view : View -> IList<Curve>

Parameters

extentMode DatumExtentType
The extent type.
view View
The view.

Return Value

IList Curve
The curves.
Exceptions
Exception | Condition
ArgumentException | The datum plane cannot be visible in the view.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Remarks
Curves returned for Model extents can be different than curves returned for View-specific extents (2d extents) in the given view. In some cases, such as an arc grid in a section view, there will be two identical curves but offset from one another.
See Also

Reference

DatumPlane Class


DatumPlane.GetDatumExtentTypeInView Method

DatumPlaneGetDatumExtentTypeInView Method

Identifies whether the curve representing the datum plane is displayed according to its actual 3d extents, or else according to a view specific setting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DatumExtentType GetDatumExtentTypeInView(
    DatumEnds datumEnd,
    View view
)
Public Function GetDatumExtentTypeInView (
    datumEnd As DatumEnds,
    view As View
) As DatumExtentType
public:
DatumExtentType GetDatumExtentTypeInView(
    DatumEnds datumEnd,
    View^ view
)
member GetDatumExtentTypeInView :
        datumEnd : DatumEnds *
        view : View -> DatumExtentType

Parameters

datumEnd DatumEnds
Specifies one end of the curve representing the datum plane in the view.
view View
The view in which to evaluate the datum extent settings.

Return Value

DatumExtentType
The extent type.
Exceptions
Exception | Condition
ArgumentException | The datum plane cannot be visible in the view.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Remarks
In a particular view, the datum plane is represented by a curve and the two ends of the curve may have different DatumExtentTypes in that view.
See Also

Reference

DatumPlane Class


DatumPlane.GetLeader Method

DatumPlaneGetLeader Method

Gets a copy of the leader applied to the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Leader GetLeader(
    DatumEnds datumEnd,
    View view
)
Public Function GetLeader (
    datumEnd As DatumEnds,
    view As View
) As Leader
public:
Leader^ GetLeader(
    DatumEnds datumEnd,
    View^ view
)
member GetLeader :
        datumEnd : DatumEnds *
        view : View -> Leader

Parameters

datumEnd DatumEnds
The end of the datum plane.
view View
The view on which the DatumPlane shows.

Return Value

Leader
The Leader of the datum plane. Null will return if no leader applied.
Exceptions
Exception | Condition
ArgumentException | The datum plane cannot be visible in the view.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | This datum plane has no leaders.
See Also

Reference

DatumPlane Class


DatumPlane.GetPropagationViews Method

DatumPlaneGetPropagationViews Method

Gets a list of candidate views which are parallel to the current view and to which the extents of the datum may be propagated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ISet<ElementId> GetPropagationViews(
    View view
)
Public Function GetPropagationViews (
    view As View
) As ISet(Of ElementId)
public:
ISet<ElementId^>^ GetPropagationViews(
    View^ view
)
member GetPropagationViews :
        view : View -> ISet<ElementId>

Parameters

view View
The view on which the DatumPlane shows.

Return Value

ISet ElementId
A set of ElementIds of the parallel views for extent propagation.
Exceptions
Exception | Condition
ArgumentException | The datum plane cannot be visible in the view.
ArgumentNullException | A non-optional argument was null
See Also

Reference

DatumPlane Class


DatumPlane.HasBubbleInView Method

DatumPlaneHasBubbleInView Method

Identifies if the DatumPlane has bubble or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasBubbleInView(
    DatumEnds datumEnd,
    View view
)
Public Function HasBubbleInView (
    datumEnd As DatumEnds,
    view As View
) As Boolean
public:
bool HasBubbleInView(
    DatumEnds datumEnd,
    View^ view
)
member HasBubbleInView :
        datumEnd : DatumEnds *
        view : View -> bool

Parameters

datumEnd DatumEnds
The end of the datum plane.
view View
The view on which the DatumPlane shows.

Return Value

Boolean
True if the DatumPlane has bubble, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | This datum plane doesn't support bubble operations.
See Also

Reference

DatumPlane Class


DatumPlane.HideBubbleInView Method

DatumPlaneHideBubbleInView Method

Hides the bubble in a view. This method does not apply to Reference planes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void HideBubbleInView(
    DatumEnds datumEnd,
    View view
)
Public Sub HideBubbleInView (
    datumEnd As DatumEnds,
    view As View
)
public:
void HideBubbleInView(
    DatumEnds datumEnd,
    View^ view
)
member HideBubbleInView :
        datumEnd : DatumEnds *
        view : View -> unit

Parameters

datumEnd DatumEnds
The end of the datum plane.
view View
The view on which the DatumPlane shows.
Exceptions
Exception | Condition
ArgumentException | The datum plane cannot be visible in the view.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | This datum plane doesn't support bubble operations.
See Also

Reference

DatumPlane Class


DatumPlane.IsBubbleVisibleInView Method

DatumPlaneIsBubbleVisibleInView Method

Identifies if the bubble is visible or not in a view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsBubbleVisibleInView(
    DatumEnds datumEnd,
    View view
)
Public Function IsBubbleVisibleInView (
    datumEnd As DatumEnds,
    view As View
) As Boolean
public:
bool IsBubbleVisibleInView(
    DatumEnds datumEnd,
    View^ view
)
member IsBubbleVisibleInView :
        datumEnd : DatumEnds *
        view : View -> bool

Parameters

datumEnd DatumEnds
The end of the datum plane.
view View
The view on which the DatumPlane shows.

Return Value

Boolean
True if the bubble is visible, false otherwise.
Exceptions
Exception | Condition
ArgumentException | The datum plane cannot be visible in the view.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | This datum plane doesn't support bubble operations.
See Also

Reference

DatumPlane Class


DatumPlane.IsCurveValidInView Method

DatumPlaneIsCurveValidInView Method

Checks if the curve is valid to be as the extents for the datum plane in a view. The curve must be bound and coincident with the original one of the datum plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCurveValidInView(
    DatumExtentType extentMode,
    View view,
    Curve curve
)
Public Function IsCurveValidInView (
    extentMode As DatumExtentType,
    view As View,
    curve As Curve
) As Boolean
public:
bool IsCurveValidInView(
    DatumExtentType extentMode,
    View^ view,
    Curve^ curve
)
member IsCurveValidInView :
        extentMode : DatumExtentType *
        view : View *
        curve : Curve -> bool

Parameters

extentMode DatumExtentType
The extent type.
view View
The view.
curve Curve
The curve.

Return Value

Boolean
True if it is valid, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

DatumPlane Class


DatumPlane.IsLeaderValid Method

DatumPlaneIsLeaderValid Method

Identifies if the leader valid or not for this DatumPlane. This method does not apply to Reference planes (which do not support leaders).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsLeaderValid(
    DatumEnds datumEnd,
    View view,
    Leader leader
)
Public Function IsLeaderValid (
    datumEnd As DatumEnds,
    view As View,
    leader As Leader
) As Boolean
public:
bool IsLeaderValid(
    DatumEnds datumEnd,
    View^ view,
    Leader^ leader
)
member IsLeaderValid :
        datumEnd : DatumEnds *
        view : View *
        leader : Leader -> bool

Parameters

datumEnd DatumEnds
The end of the datum plane.
view View
The view on which the DatumPlane shows.
leader Leader
The Leader for setting the datum plane.

Return Value

Boolean
True if the leader is valid for set leader, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | This datum plane has no leaders. -or- The DatumPlane should not have a leader.
Remarks
If the view or leader is null, it will throw ArgumentNullException; A valid leader meets the following conditions:
  • The leader's End, Elbow and Anchor should lie in the View's plane
  • The End of the leader should be on the datum plane's curve(s)
  • The Elbow of the leader should be between the End and Anchor
See Also

Reference

DatumPlane Class


DatumPlane.Maximize3DExtents Method

DatumPlaneMaximize3DExtents Method

Computes the 3d extents of all model geometry and levels, and extends the 3d extents of this datum surface to include the model extents.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Maximize3DExtents()
Public Sub Maximize3DExtents
public:
void Maximize3DExtents()
member Maximize3DExtents : unit -> unit
Remarks
Currently does not apply to curved grids.
See Also

Reference

DatumPlane Class


DatumPlane.PropagateToViews Method

DatumPlanePropagateToViews Method

Propagates the extents applied to this datum in the view to the specified parallel views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void PropagateToViews(
    View view,
    ISet<ElementId> parallelViews
)
Public Sub PropagateToViews (
    view As View,
    parallelViews As ISet(Of ElementId)
)
public:
void PropagateToViews(
    View^ view,
    ISet<ElementId^>^ parallelViews
)
member PropagateToViews :
        view : View *
        parallelViews : ISet<ElementId> -> unit

Parameters

view View
The view on which the DatumPlane shows.
parallelViews ISet ElementId
The ids of the specified parallel views.
Exceptions
Exception | Condition
ArgumentException | The datum plane cannot be visible in the view. -or- One ElementId in parallelViews is not valid for extent propagation.
ArgumentNullException | A non-optional argument was null
See Also

Reference

DatumPlane Class


DatumPlane.SetCurveInView Method

DatumPlaneSetCurveInView Method

Sets the extents to match the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetCurveInView(
    DatumExtentType extentMode,
    View view,
    Curve curve
)
Public Sub SetCurveInView (
    extentMode As DatumExtentType,
    view As View,
    curve As Curve
)
public:
void SetCurveInView(
    DatumExtentType extentMode,
    View^ view,
    Curve^ curve
)
member SetCurveInView :
        extentMode : DatumExtentType *
        view : View *
        curve : Curve -> unit

Parameters

extentMode DatumExtentType
The extent type.
view View
The view.
curve Curve
The curve.
Exceptions
Exception | Condition
ArgumentException | The datum plane cannot be visible in the view. -or- The curve is unbound or not coincident with the original one of the datum plane.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

DatumPlane Class


DatumPlane.SetDatumExtentType Method

DatumPlaneSetDatumExtentType Method

Sets whether the curve representing the datum plane is displayed according to its 3d extents, or else according to a view specific setting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetDatumExtentType(
    DatumEnds datumEnd,
    View view,
    DatumExtentType extentMode
)
Public Sub SetDatumExtentType (
    datumEnd As DatumEnds,
    view As View,
    extentMode As DatumExtentType
)
public:
void SetDatumExtentType(
    DatumEnds datumEnd,
    View^ view,
    DatumExtentType extentMode
)
member SetDatumExtentType :
        datumEnd : DatumEnds *
        view : View *
        extentMode : DatumExtentType -> unit

Parameters

datumEnd DatumEnds
Specifies one end of the curve representing the datum plane in the view.
view View
The view in which to set the datum extent settings.
extentMode DatumExtentType
The DatumExtentType.
Exceptions
Exception | Condition
ArgumentException | The datum plane cannot be visible in the view.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Remarks
In a particular view, the datum plane is represented by a curve and the two ends of the curve may have different DatumExtentTypes in that view. If the value is changed from DatumExtentType::Model to DatumExtentType::ViewSpecific, then the view specific extents will be identical to the model extent until modified.
See Also

Reference

DatumPlane Class


DatumPlane.SetLeader Method

DatumPlaneSetLeader Method

Sets the leader to the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetLeader(
    DatumEnds datumEnd,
    View view,
    Leader pLeader
)
Public Sub SetLeader (
    datumEnd As DatumEnds,
    view As View,
    pLeader As Leader
)
public:
void SetLeader(
    DatumEnds datumEnd,
    View^ view,
    Leader^ pLeader
)
member SetLeader :
        datumEnd : DatumEnds *
        view : View *
        pLeader : Leader -> unit

Parameters

datumEnd DatumEnds
The end of the datum plane.
view View
The view on which the DatumPlane shows.
pLeader Leader
The Leader for setting the datum plane.
Exceptions
Exception | Condition
ArgumentException | One of the conditions is not valid: the input leader and view is not null; The leader End, Elbow, Anchor should be in the view; the End of leader should be in the datum plane curves; Elbow is between End and Anchor. -or- The datum plane cannot be visible in the view. -or- The bubble is not visible at the datumEnd of the datum plane.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Remarks
The leader can be applied only to ends where the bubble is set to be shown.
See Also

Reference

DatumPlane Class


DatumPlane.ShowBubbleInView Method

DatumPlaneShowBubbleInView Method

Shows the bubble in a view. This method does not apply to Reference planes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ShowBubbleInView(
    DatumEnds datumEnd,
    View view
)
Public Sub ShowBubbleInView (
    datumEnd As DatumEnds,
    view As View
)
public:
void ShowBubbleInView(
    DatumEnds datumEnd,
    View^ view
)
member ShowBubbleInView :
        datumEnd : DatumEnds *
        view : View -> unit

Parameters

datumEnd DatumEnds
The end of the datum plane.
view View
The view on which the DatumPlane shows.
Exceptions
Exception | Condition
ArgumentException | The datum plane cannot be visible in the view.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | This datum plane doesn't support bubble operations. -or- This DatumPlane doesn't have bubbles shown the view.
See Also

Reference

DatumPlane Class


DecimalSymbol Enumeration

The symbol used to separate the integer and fractional parts of a number.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DecimalSymbol
Public Enumeration DecimalSymbol
public enum class DecimalSymbol
type DecimalSymbol
Members
Member name | Value | Description
Dot | 0 | A dot (".").
Comma | 1 | A comma (",").
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DefaultDivideSettings Class

Provides access to project-wide divide settings.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBDefaultDivideSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DefaultDivideSettings : Element
Public Class DefaultDivideSettings
    Inherits Element
public ref class DefaultDivideSettings : public Element
type DefaultDivideSettings =
    class
        inherit Element
    end

The DefaultDivideSettings type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | PathDistance | A default Divided Path distance for a fixed, minimum, or maximum distance layout.
Public property | PathLayout | A default Divided Path layout.
Public property | PathMeasurementType | A default Divided Path measurement type for distance layouts.
Public property | PathNumber | A default Divided Path number for a fixed number layout.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
 | GetDefaultDivideSettings | Obtains the DefaultDivideSettings object for the specified document.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetSurfaceDistance | Gets the default Divided Surface distance for a fixed, minimum, or maximum distance layout for U or V gridlines.
Public method | GetSurfaceLayout | Gets the default Divided Surface layout for U or V gridlines.
Public method | GetSurfaceNumber | Gets the default Divided Surface number for a fixed number layout for U or V gridlines.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetSurfaceDistance | Sets the default Divided Surface distance for a fixed, minimum, or maximum distance layout for U or V gridlines.
Public method | SetSurfaceLayout | Sets the default Divided Surface layout for U or V gridlines.
Public method | SetSurfaceNumber | Sets the default Divided Surface number for a fixed number layout for U or V gridlines.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DefaultDivideSettings Properties

The DefaultDivideSettings type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | PathDistance | A default Divided Path distance for a fixed, minimum, or maximum distance layout.
Public property | PathLayout | A default Divided Path layout.
Public property | PathMeasurementType | A default Divided Path measurement type for distance layouts.
Public property | PathNumber | A default Divided Path number for a fixed number layout.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

DefaultDivideSettings Class


DefaultDivideSettings.PathDistance Property

DefaultDivideSettingsPathDistance Property

A default Divided Path distance for a fixed, minimum, or maximum distance layout.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double PathDistance { get; set; }
Public Property PathDistance As Double
    Get
    Set
public:
property double PathDistance {
    double get ();
    void set (double value);
}
member PathDistance : float with get, set

Property Value

Double
See Also

Reference

DefaultDivideSettings Class


DefaultDivideSettings.PathLayout Property

DefaultDivideSettingsPathLayout Property

A default Divided Path layout.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SpacingRuleLayout PathLayout { get; set; }
Public Property PathLayout As SpacingRuleLayout
    Get
    Set
public:
property SpacingRuleLayout PathLayout {
    SpacingRuleLayout get ();
    void set (SpacingRuleLayout value);
}
member PathLayout : SpacingRuleLayout with get, set

Property Value

SpacingRuleLayout
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

DefaultDivideSettings Class


DefaultDivideSettings.PathMeasurementType Property

DefaultDivideSettingsPathMeasurementType Property

A default Divided Path measurement type for distance layouts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DividedPathMeasurementType PathMeasurementType { get; set; }
Public Property PathMeasurementType As DividedPathMeasurementType
    Get
    Set
public:
property DividedPathMeasurementType PathMeasurementType {
    DividedPathMeasurementType get ();
    void set (DividedPathMeasurementType value);
}
member PathMeasurementType : DividedPathMeasurementType with get, set

Property Value

DividedPathMeasurementType
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

DefaultDivideSettings Class


DefaultDivideSettings.PathNumber Property

DefaultDivideSettingsPathNumber Property

A default Divided Path number for a fixed number layout.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int PathNumber { get; set; }
Public Property PathNumber As Integer
    Get
    Set
public:
property int PathNumber {
    int get ();
    void set (int value);
}
member PathNumber : int with get, set

Property Value

Int32
See Also

Reference

DefaultDivideSettings Class


DefaultDivideSettings Methods

The DefaultDivideSettings type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
 | GetDefaultDivideSettings | Obtains the DefaultDivideSettings object for the specified document.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetSurfaceDistance | Gets the default Divided Surface distance for a fixed, minimum, or maximum distance layout for U or V gridlines.
Public method | GetSurfaceLayout | Gets the default Divided Surface layout for U or V gridlines.
Public method | GetSurfaceNumber | Gets the default Divided Surface number for a fixed number layout for U or V gridlines.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetSurfaceDistance | Sets the default Divided Surface distance for a fixed, minimum, or maximum distance layout for U or V gridlines.
Public method | SetSurfaceLayout | Sets the default Divided Surface layout for U or V gridlines.
Public method | SetSurfaceNumber | Sets the default Divided Surface number for a fixed number layout for U or V gridlines.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DefaultDivideSettings Class


DefaultDivideSettings.GetDefaultDivideSettings Method

DefaultDivideSettingsGetDefaultDivideSettings Method

Obtains the DefaultDivideSettings object for the specified document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static DefaultDivideSettings GetDefaultDivideSettings(
    Document cda
)
Public Shared Function GetDefaultDivideSettings (
    cda As Document
) As DefaultDivideSettings
public:
static DefaultDivideSettings^ GetDefaultDivideSettings(
    Document^ cda
)
static member GetDefaultDivideSettings :
        cda : Document -> DefaultDivideSettings

Parameters

cda Document
A document.

Return Value

DefaultDivideSettings
The DefaultDivideSettings object.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DefaultDivideSettings Class


DefaultDivideSettings.GetSurfaceDistance Method

DefaultDivideSettingsGetSurfaceDistance Method

Gets the default Divided Surface distance for a fixed, minimum, or maximum distance layout for U or V gridlines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetSurfaceDistance(
    UVGridlineType gridlines
)
Public Function GetSurfaceDistance (
    gridlines As UVGridlineType
) As Double
public:
double GetSurfaceDistance(
    UVGridlineType gridlines
)
member GetSurfaceDistance :
        gridlines : UVGridlineType -> float

Parameters

gridlines UVGridlineType
U-gridlines or V-gridlines.

Return Value

Double
The default distance for the layout.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

DefaultDivideSettings Class


DefaultDivideSettings.GetSurfaceLayout Method

DefaultDivideSettingsGetSurfaceLayout Method

Gets the default Divided Surface layout for U or V gridlines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SpacingRuleLayout GetSurfaceLayout(
    UVGridlineType gridlines
)
Public Function GetSurfaceLayout (
    gridlines As UVGridlineType
) As SpacingRuleLayout
public:
SpacingRuleLayout GetSurfaceLayout(
    UVGridlineType gridlines
)
member GetSurfaceLayout :
        gridlines : UVGridlineType -> SpacingRuleLayout

Parameters

gridlines UVGridlineType
U-gridlines or V-gridlines.

Return Value

SpacingRuleLayout
The layout spacing rule.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

DefaultDivideSettings Class


DefaultDivideSettings.GetSurfaceNumber Method

DefaultDivideSettingsGetSurfaceNumber Method

Gets the default Divided Surface number for a fixed number layout for U or V gridlines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetSurfaceNumber(
    UVGridlineType gridlines
)
Public Function GetSurfaceNumber (
    gridlines As UVGridlineType
) As Integer
public:
int GetSurfaceNumber(
    UVGridlineType gridlines
)
member GetSurfaceNumber :
        gridlines : UVGridlineType -> int

Parameters

gridlines UVGridlineType
U-gridlines or V-gridlines.

Return Value

Int32
The default number for a fixed number layout.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

DefaultDivideSettings Class


DefaultDivideSettings.SetSurfaceDistance Method

DefaultDivideSettingsSetSurfaceDistance Method

Sets the default Divided Surface distance for a fixed, minimum, or maximum distance layout for U or V gridlines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetSurfaceDistance(
    UVGridlineType gridlines,
    double distance
)
Public Sub SetSurfaceDistance (
    gridlines As UVGridlineType,
    distance As Double
)
public:
void SetSurfaceDistance(
    UVGridlineType gridlines,
    double distance
)
member SetSurfaceDistance :
        gridlines : UVGridlineType *
        distance : float -> unit

Parameters

gridlines UVGridlineType
U-gridlines or V-gridlines.
distance Double
A default distance for a layout.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The given value for distance must be positive. -or- A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

DefaultDivideSettings Class


DefaultDivideSettings.SetSurfaceLayout Method

DefaultDivideSettingsSetSurfaceLayout Method

Sets the default Divided Surface layout for U or V gridlines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetSurfaceLayout(
    UVGridlineType gridlines,
    SpacingRuleLayout layout
)
Public Sub SetSurfaceLayout (
    gridlines As UVGridlineType,
    layout As SpacingRuleLayout
)
public:
void SetSurfaceLayout(
    UVGridlineType gridlines,
    SpacingRuleLayout layout
)
member SetSurfaceLayout :
        gridlines : UVGridlineType *
        layout : SpacingRuleLayout -> unit

Parameters

gridlines UVGridlineType
U-gridlines or V-gridlines.
layout SpacingRuleLayout
A layout spacing rule.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

DefaultDivideSettings Class


DefaultDivideSettings.SetSurfaceNumber Method

DefaultDivideSettingsSetSurfaceNumber Method

Sets the default Divided Surface number for a fixed number layout for U or V gridlines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetSurfaceNumber(
    UVGridlineType gridlines,
    int number
)
Public Sub SetSurfaceNumber (
    gridlines As UVGridlineType,
    number As Integer
)
public:
void SetSurfaceNumber(
    UVGridlineType gridlines,
    int number
)
member SetSurfaceNumber :
        gridlines : UVGridlineType *
        number : int -> unit

Parameters

gridlines UVGridlineType
U-gridlines or V-gridlines.
number Int32
A default number for a fixed number layout.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The given value for number is not positive. -or- A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

DefaultDivideSettings Class


DefaultOpenFromCloudCallback Class

A default callback that may be used to control Revit's behavior when opening a model.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBDefaultOpenFromCloudCallback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DefaultOpenFromCloudCallback : IOpenFromCloudCallback,
    IDisposable
Public Class DefaultOpenFromCloudCallback
    Implements IOpenFromCloudCallback, IDisposable
public ref class DefaultOpenFromCloudCallback : IOpenFromCloudCallback,
    IDisposable
type DefaultOpenFromCloudCallback =
    class
        interface IOpenFromCloudCallback
        interface IDisposable
    end

The DefaultOpenFromCloudCallback type exposes the following members.

Constructors
 | Name | Description
Public method | DefaultOpenFromCloudCallback | Create a default open callback. Open latest by default for all scenarios.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the DefaultOpenFromCloudCallback
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | OnOpenConflict | A method called when the conflict is happen during the model opening.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DefaultOpenFromCloudCallback Constructor

Create a default open callback. Open latest by default for all scenarios.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DefaultOpenFromCloudCallback()
Public Sub New
public:
DefaultOpenFromCloudCallback()
new : unit -> DefaultOpenFromCloudCallback
See Also

Reference

DefaultOpenFromCloudCallback Class


DefaultOpenFromCloudCallback Properties

The DefaultOpenFromCloudCallback type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

DefaultOpenFromCloudCallback Class


DefaultOpenFromCloudCallback.IsValidObject Property

DefaultOpenFromCloudCallbackIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

DefaultOpenFromCloudCallback Class


DefaultOpenFromCloudCallback Methods

The DefaultOpenFromCloudCallback type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | OnOpenConflict | A method called when the conflict is happen during the model opening.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DefaultOpenFromCloudCallback Class


DefaultOpenFromCloudCallback.Dispose Method

DefaultOpenFromCloudCallbackDispose Method

Releases all resources used by the DefaultOpenFromCloudCallback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

DefaultOpenFromCloudCallback Class


DefaultOpenFromCloudCallback.OnOpenConflict Method

DefaultOpenFromCloudCallbackOnOpenConflict Method

A method called when the conflict is happen during the model opening.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual OpenConflictResult OnOpenConflict(
    OpenConflictScenario scenario
)
Public Overridable Function OnOpenConflict (
    scenario As OpenConflictScenario
) As OpenConflictResult
public:
virtual OpenConflictResult OnOpenConflict(
    OpenConflictScenario scenario
)
abstract OnOpenConflict :
        scenario : OpenConflictScenario -> OpenConflictResult
override OnOpenConflict :
        scenario : OpenConflictScenario -> OpenConflictResult

Parameters

scenario OpenConflictScenario
The scenario of the conflict.

Return Value

OpenConflictResult
Returns the result to indicate whether to keep the unsynchronized change, or open the latest version or cancel the open action.

Implements

IOpenFromCloudCallbackOnOpenConflict(OpenConflictScenario)
See Also

Reference

DefaultOpenFromCloudCallback Class


Definition Class

The Definition object is a base object for all type of parameter definitions within the Autodesk Revit API.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBDefinition
Autodesk.Revit.DBExternalDefinition
Autodesk.Revit.DBInternalDefinition

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class Definition
Public MustInherit Class Definition
public ref class Definition abstract
[<AbstractClassAttribute>]
type Definition = class end

The Definition type exposes the following members.

Properties
 | Name | Description
Public property | Name | The user visible name for the parameter.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | GetDataType | Gets a ForgeTypeId identifying the data type describing values of the parameter.
Public method | GetGroupTypeId | Returns the identifier of the parameter definition's parameter group.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This object supports properties and methods that report the name and type of a particular parameter. There are two kinds of definition object derived from this: InternalDefinition which represents all kinds of definitions existing entirely within the Autodesk Revit database. ExternalDefinitions represent definitions stored on disk in a shared parameters file. Most of the time code should be written to utilize this Definition base class as then the code will be applicable to both internal and external parameter definitions.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Definition Properties

The Definition type exposes the following members.

Properties
 | Name | Description
Public property | Name | The user visible name for the parameter.
Top
See Also

Reference

Definition Class


Definition.Name Property

DefinitionName Property

The user visible name for the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract string Name { get; }
Public MustOverride ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () abstract;
}
abstract Name : string with get

Property Value

String
See Also

Reference

Definition Class


Definition Methods

The Definition type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | GetDataType | Gets a ForgeTypeId identifying the data type describing values of the parameter.
Public method | GetGroupTypeId | Returns the identifier of the parameter definition's parameter group.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Definition Class


Definition.GetDataType Method

DefinitionGetDataType Method

Gets a ForgeTypeId identifying the data type describing values of the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ForgeTypeId GetDataType()
Public Function GetDataType As ForgeTypeId
public:
ForgeTypeId^ GetDataType()
member GetDataType : unit -> ForgeTypeId

Return Value

ForgeTypeId
A ForgeTypeId identifying the data type of the parameter or an empty ForgeTypeId.
Remarks
The returned ForgeTypeId may be empty or may identify either a spec or a category. When it is a category, it indicates a Family Type parameter of that category. See Parameter.IsSpec(ForgeTypeId), UnitUtils.IsMeasurableSpec(ForgeTypeId), Category.IsBuiltInCategory(ForgeTypeId), and Parameter.IsValidDataType(ForgeTypeId). Some built-in parameters, such as those for color or level, have special data types which are not available for use with user-defined parameters and which have no representation in the Revit user interface or API. For these built-in parameters, this method returns an empty ForgeTypeId instance.
Example
C#
VB
C++
F#
Copy
//Find parameter using the Parameter's definition data type.
public Parameter FindParameter(Element element)
{
    Parameter foundParameter = null;
    // This will find the first parameter that measures length
    foreach (Parameter parameter in element.Parameters)
    {
        if (parameter.Definition.GetDataType() == SpecTypeId.Length)
        {
            foundParameter = parameter;
            break;
        }
    }
    return foundParameter;
}
'Find parameter using the Parameter's definition data type.
Public Function FindParameter(element As Element) As Parameter
    Dim foundParameter As Parameter = Nothing
    ' This will find the first parameter that measures length
    For Each parameter As Parameter In element.Parameters
        If parameter.Definition.GetDataType() = SpecTypeId.Length Then
            foundParameter = parameter
            Exit For
        End If
    Next
    Return foundParameter
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Definition Class


Definition.GetGroupTypeId Method

DefinitionGetGroupTypeId Method

Returns the identifier of the parameter definition's parameter group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract ForgeTypeId GetGroupTypeId()
Public MustOverride Function GetGroupTypeId As ForgeTypeId
public:
virtual ForgeTypeId^ GetGroupTypeId() abstract
abstract GetGroupTypeId : unit -> ForgeTypeId

Return Value

ForgeTypeId
See Also

Reference

Definition Class


DefinitionBindingMap Class

A map that contains mappings of parameter definitions to parameter bindings.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBDefinitionBindingMap
Autodesk.Revit.DBBindingMap

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DefinitionBindingMap : APIObject,
    IEnumerable
Public Class DefinitionBindingMap
    Inherits APIObject
    Implements IEnumerable
public ref class DefinitionBindingMap : public APIObject,
    IEnumerable
type DefinitionBindingMap =
    class
        inherit APIObject
        interface IEnumerable
    end

The DefinitionBindingMap type exposes the following members.

Constructors
 | Name | Description
Public method | DefinitionBindingMap | Initializes a new instance of the DefinitionBindingMap class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the map is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item |
Public property | Size | Returns the number of bindings that are in the map.
Top
Methods
 | Name | Description
Public method | Clear | Removes every binding from the map, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the map.
Public method | GetEnumerator | Retrieve a forward moving iterator to the map.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the map.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DefinitionBindingMap Constructor

Initializes a new instance of the DefinitionBindingMap class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DefinitionBindingMap()
Public Sub New
public:
DefinitionBindingMap()
new : unit -> DefinitionBindingMap
See Also

Reference

DefinitionBindingMap Class


DefinitionBindingMap Properties

The DefinitionBindingMap type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the map is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item |
Public property | Size | Returns the number of bindings that are in the map.
Top
See Also

Reference

DefinitionBindingMap Class


DefinitionBindingMap.IsEmpty Property

DefinitionBindingMapIsEmpty Property

Test to see if the map is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Boolean
Remarks
If the map is empty then True will be returned, otherwise False.
See Also

Reference

DefinitionBindingMap Class


DefinitionBindingMap.Item Property

DefinitionBindingMapItem Property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Binding this[
    Definition key
] { get; set; }
Public Overridable Property Item (
    key As Definition
) As Binding
    Get
    Set
public:
virtual property Binding^ Item[Definition^ key] {
    Binding^ get (Definition^ key);
    void set (Definition^ key, Binding^ value);
}
abstract Item : Binding with get, set
override Item : Binding with get, set

Parameters

key Definition

Property Value

Binding
See Also

Reference

DefinitionBindingMap Class


DefinitionBindingMap.Size Property

DefinitionBindingMapSize Property

Returns the number of bindings that are in the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
abstract Size : int with get
override Size : int with get

Property Value

Int32
See Also

Reference

DefinitionBindingMap Class


DefinitionBindingMap Methods

The DefinitionBindingMap type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Removes every binding from the map, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the map.
Public method | GetEnumerator | Retrieve a forward moving iterator to the map.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the map.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DefinitionBindingMap Class


DefinitionBindingMap.Clear Method

DefinitionBindingMapClear Method

Removes every binding from the map, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

DefinitionBindingMap Class


DefinitionBindingMap.Contains Method

DefinitionBindingMapContains Method

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Contains(
    Definition key
)
Public Overridable Function Contains (
    key As Definition
) As Boolean
public:
virtual bool Contains(
    Definition^ key
)
abstract Contains :
        key : Definition -> bool
override Contains :
        key : Definition -> bool

Parameters

key Definition

Return Value

Boolean
See Also

Reference

DefinitionBindingMap Class


DefinitionBindingMap.Erase Method

DefinitionBindingMapErase Method

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Erase(
    Definition key
)
Public Overridable Function Erase (
    key As Definition
) As Integer
public:
virtual int Erase(
    Definition^ key
)
abstract Erase :
        key : Definition -> int
override Erase :
        key : Definition -> int

Parameters

key Definition

Return Value

Int32
See Also

Reference

DefinitionBindingMap Class


DefinitionBindingMap.ForwardIterator Method

DefinitionBindingMapForwardIterator Method

Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual DefinitionBindingMapIterator ForwardIterator()
Public Overridable Function ForwardIterator As DefinitionBindingMapIterator
public:
virtual DefinitionBindingMapIterator^ ForwardIterator()
abstract ForwardIterator : unit -> DefinitionBindingMapIterator
override ForwardIterator : unit -> DefinitionBindingMapIterator

Return Value

DefinitionBindingMapIterator
Returns a forward moving iterator to the map.
See Also

Reference

DefinitionBindingMap Class


DefinitionBindingMap.GetEnumerator Method

DefinitionBindingMapGetEnumerator Method

Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

IEnumerator
Returns a forward moving iterator to the map.

Implements

IEnumerableGetEnumerator
See Also

Reference

DefinitionBindingMap Class


DefinitionBindingMap.Insert Method

DefinitionBindingMapInsert Method

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Insert(
    Definition key,
    Binding item
)
Public Overridable Function Insert (
    key As Definition,
    item As Binding
) As Boolean
public:
virtual bool Insert(
    Definition^ key,
    Binding^ item
)
abstract Insert :
        key : Definition *
        item : Binding -> bool
override Insert :
        key : Definition *
        item : Binding -> bool

Parameters

key Definition
item Binding

Return Value

Boolean
See Also

Reference

DefinitionBindingMap Class


DefinitionBindingMap.ReverseIterator Method

DefinitionBindingMapReverseIterator Method

Retrieve a backward moving iterator to the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual DefinitionBindingMapIterator ReverseIterator()
Public Overridable Function ReverseIterator As DefinitionBindingMapIterator
public:
virtual DefinitionBindingMapIterator^ ReverseIterator()
abstract ReverseIterator : unit -> DefinitionBindingMapIterator
override ReverseIterator : unit -> DefinitionBindingMapIterator

Return Value

DefinitionBindingMapIterator
Returns a backward moving iterator to the map.
See Also

Reference

DefinitionBindingMap Class


DefinitionBindingMapIterator Class

An iterator to a parameter definition to parameter bindings map.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBDefinitionBindingMapIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class DefinitionBindingMapIterator : APIObject,
    IEnumerator
Public MustInherit Class DefinitionBindingMapIterator
    Inherits APIObject
    Implements IEnumerator
public ref class DefinitionBindingMapIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type DefinitionBindingMapIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The DefinitionBindingMapIterator type exposes the following members.

Constructors
 | Name | Description
Public method | DefinitionBindingMapIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the binding that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Key | Retrieves the definition that is the current focus of the iterator.
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the map.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DefinitionBindingMapIterator Constructor

For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DefinitionBindingMapIterator()
Public Sub New
public:
DefinitionBindingMapIterator()
new : unit -> DefinitionBindingMapIterator
Remarks
This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.
See Also

Reference

DefinitionBindingMapIterator Class


DefinitionBindingMapIterator Properties

The DefinitionBindingMapIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Retrieves the binding that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Key | Retrieves the definition that is the current focus of the iterator.
Top
See Also

Reference

DefinitionBindingMapIterator Class


DefinitionBindingMapIterator.Current Property

DefinitionBindingMapIteratorCurrent Property

Retrieves the binding that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}
abstract Current : Object with get
override Current : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.
See Also

Reference

DefinitionBindingMapIterator Class


DefinitionBindingMapIterator.Key Property

DefinitionBindingMapIteratorKey Property

Retrieves the definition that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Definition Key { get; }
Public Overridable ReadOnly Property Key As Definition
    Get
public:
virtual property Definition^ Key {
    Definition^ get ();
}
abstract Key : Definition with get
override Key : Definition with get

Property Value

Definition
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid key as per expected behavior of IEnumerator.
See Also

Reference

DefinitionBindingMapIterator Class


DefinitionBindingMapIterator Methods

The DefinitionBindingMapIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the map.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DefinitionBindingMapIterator Class


DefinitionBindingMapIterator.MoveNext Method

DefinitionBindingMapIteratorMoveNext Method

Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the map.

Implements

IEnumeratorMoveNext
Remarks
MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.
See Also

Reference

DefinitionBindingMapIterator Class


DefinitionBindingMapIterator.Reset Method

DefinitionBindingMapIteratorReset Method

Bring the iterator back to the start of the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
Remarks
The Reset method will return the iterator back to the start of the map in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.
See Also

Reference

DefinitionBindingMapIterator Class


DefinitionFile Class

The DefinitionFile object represents a shared parameters file on disk.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBDefinitionFile

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DefinitionFile : APIObject
Public Class DefinitionFile
    Inherits APIObject
public ref class DefinitionFile : public APIObject
type DefinitionFile =
    class
        inherit APIObject
    end

The DefinitionFile type exposes the following members.

Properties
 | Name | Description
Public property | Filename | This property returns the physical filename of the shared parameters file on disk.
Public property | Groups | Return a map of shared parameter definition groups contained within the file.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Shared Parameters are parameter definitions that are stored in a text file external to the Autodesk Revit project. These definitions can be used in multiple projects and are identifiable by a unique identifier generated when they are created. API access to shared parameters consist of a number of objects, the first of which is an object that represents the shared parameters file on disk. That object then contains a number of Group objects. Shared parameters are grouped for easier management. These groups then contain the shared parameter definitions. The groups support the ability to create new shared parameter definitions. The DefinitionFile object can be retrieved by the Application.OpenSharedParameterFile method.
Example
C#
VB
C++
F#
Copy
private void ShowDefinitionFileInfo(DefinitionFile myDefinitionFile)
{
    StringBuilder fileInformation = new StringBuilder(500);

    // get the file name
    fileInformation.AppendLine("File Name: " + myDefinitionFile.Filename);

    // iterate the Definition groups of this file
    foreach (DefinitionGroup myGroup in myDefinitionFile.Groups)
    {
        // get the group name
        fileInformation.AppendLine("Group Name: " + myGroup.Name);

        // iterate the difinitions
        foreach (Definition definition in myGroup.Definitions)
        {
            // get definition name
            fileInformation.AppendLine("Definition Name: " + definition.Name);
        }
    }
    TaskDialog.Show("Revit",fileInformation.ToString());
}
Private Sub ShowDefinitionFileInfo(myDefinitionFile As DefinitionFile)
   Dim fileInformation As New StringBuilder(500)

   ' get the file name
   fileInformation.AppendLine("File Name: " & Convert.ToString(myDefinitionFile.Filename))

   ' iterate the Definition groups of this file
   For Each myGroup As DefinitionGroup In myDefinitionFile.Groups
      ' get the group name
      fileInformation.AppendLine("Group Name: " + myGroup.Name)

      ' iterate the difinitions
      For Each definition As Definition In myGroup.Definitions
         ' get definition name
         fileInformation.AppendLine("Definition Name: " + definition.Name)
      Next
   Next
   TaskDialog.Show("Revit", fileInformation.ToString())
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DefinitionFile Properties

The DefinitionFile type exposes the following members.

Properties
 | Name | Description
Public property | Filename | This property returns the physical filename of the shared parameters file on disk.
Public property | Groups | Return a map of shared parameter definition groups contained within the file.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

DefinitionFile Class


DefinitionFile.Filename Property

DefinitionFileFilename Property

This property returns the physical filename of the shared parameters file on disk.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Filename { get; }
Public ReadOnly Property Filename As String
    Get
public:
property String^ Filename {
    String^ get ();
}
member Filename : string with get

Property Value

String
See Also

Reference

DefinitionFile Class


DefinitionFile.Groups Property

DefinitionFileGroups Property

Return a map of shared parameter definition groups contained within the file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DefinitionGroups Groups { get; }
Public ReadOnly Property Groups As DefinitionGroups
    Get
public:
property DefinitionGroups^ Groups {
    DefinitionGroups^ get ();
}
member Groups : DefinitionGroups with get

Property Value

DefinitionGroups
Remarks
A particular group can be found by Name, using the Item property on the DefinitionGroups object. A new group can be created by using the Create method on the DefinitionGroups Object. The Create method takes the name of the new group, as a string, as its input parameter, returning a reference to a new definition group object as its result.
See Also

Reference

DefinitionFile Class


DefinitionFile Methods

The DefinitionFile type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DefinitionFile Class


DefinitionGroup Class

The DefinitionGroup is a container that is used to hold shared parameter definitions on disk.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBDefinitionGroup

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DefinitionGroup : APIObject
Public Class DefinitionGroup
    Inherits APIObject
public ref class DefinitionGroup : public APIObject
type DefinitionGroup =
    class
        inherit APIObject
    end

The DefinitionGroup type exposes the following members.

Properties
 | Name | Description
Public property | Definitions | The Definitions property returns an object that contains all the shared parameter definitions within the group.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Name | Returns the name of the parameter group.
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Groups are used for logical arrangement of the shared parameters into meaningful sets. Through the DefinitionGroup object new shared parameter definitions can be made.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DefinitionGroup Properties

The DefinitionGroup type exposes the following members.

Properties
 | Name | Description
Public property | Definitions | The Definitions property returns an object that contains all the shared parameter definitions within the group.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Name | Returns the name of the parameter group.
Top
See Also

Reference

DefinitionGroup Class


DefinitionGroup.Definitions Property

DefinitionGroupDefinitions Property

The Definitions property returns an object that contains all the shared parameter definitions within the group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Definitions Definitions { get; }
Public ReadOnly Property Definitions As Definitions
    Get
public:
property Definitions^ Definitions {
    Definitions^ get ();
}
member Definitions : Definitions with get

Property Value

Definitions
Remarks
A known definition can be retrieved, by name, using the Item property on the Definitions object. A new definition can be created by using the Create method. The Create method takes two parameters, a string for name and a type. If the creation of the definition was successful then an object representing the definition is returned by the Create method.
See Also

Reference

DefinitionGroup Class


DefinitionGroup.Name Property

DefinitionGroupName Property

Returns the name of the parameter group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

String
See Also

Reference

DefinitionGroup Class


DefinitionGroup Methods

The DefinitionGroup type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DefinitionGroup Class


DefinitionGroups Class

A specialized set of definition groups that allows creation of new groups.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBDefinitionGroups

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DefinitionGroups : IEnumerable<DefinitionGroup>,
    IDisposable
Public Class DefinitionGroups
    Implements IEnumerable(Of DefinitionGroup), IDisposable
public ref class DefinitionGroups : IEnumerable<DefinitionGroup^>,
    IDisposable
type DefinitionGroups =
    class
        interface IEnumerable<DefinitionGroup>
        interface IDisposable
    end

The DefinitionGroups type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Identifies if the definition groups collection is empty.
Public property | Item | Retrieve a definition group by name.
Public property | Size | The number of definition groups in the collection.
Top
Methods
 | Name | Description
Public method | Contains | Tests for the existence of a definition group within the collection.
Public method | Create | Create a new parameter definition group using the name provided.
Public method | Dispose | Releases all resources used by the DefinitionGroups
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Retrieves an enumerator to the collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DefinitionGroups Properties

The DefinitionGroups type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Identifies if the definition groups collection is empty.
Public property | Item | Retrieve a definition group by name.
Public property | Size | The number of definition groups in the collection.
Top
See Also

Reference

DefinitionGroups Class


DefinitionGroups.IsEmpty Property

DefinitionGroupsIsEmpty Property

Identifies if the definition groups collection is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEmpty { get; }
Public ReadOnly Property IsEmpty As Boolean
    Get
public:
property bool IsEmpty {
    bool get ();
}
member IsEmpty : bool with get

Property Value

Boolean
See Also

Reference

DefinitionGroups Class


DefinitionGroups.Item Property

DefinitionGroupsItem Property

Retrieve a definition group by name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DefinitionGroup this[
    string groupName
] { get; }
Public ReadOnly Property Item (
    groupName As String
) As DefinitionGroup
    Get
public:
property DefinitionGroup^ Item[String^ groupName] {
    DefinitionGroup^ get (String^ groupName);
}
member Item : DefinitionGroup with get

Parameters

groupName String
The name of the group for which to search.

Property Value

DefinitionGroup
Remarks
If the group is not found then will be returned.
See Also

Reference

DefinitionGroups Class


DefinitionGroups.Size Property

DefinitionGroupsSize Property

The number of definition groups in the collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Size { get; }
Public ReadOnly Property Size As Integer
    Get
public:
property int Size {
    int get ();
}
member Size : int with get

Property Value

Int32
See Also

Reference

DefinitionGroups Class


DefinitionGroups Methods

The DefinitionGroups type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Tests for the existence of a definition group within the collection.
Public method | Create | Create a new parameter definition group using the name provided.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Retrieves an enumerator to the collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DefinitionGroups Class


DefinitionGroups.Contains Method

DefinitionGroupsContains Method

Tests for the existence of a definition group within the collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Contains(
    DefinitionGroup definitionGroup
)
Public Function Contains (
    definitionGroup As DefinitionGroup
) As Boolean
public:
bool Contains(
    DefinitionGroup^ definitionGroup
)
member Contains :
        definitionGroup : DefinitionGroup -> bool

Parameters

definitionGroup DefinitionGroup
The definition group to look for.

Return Value

Boolean
True if the definition group was found, false otherwise.
See Also

Reference

DefinitionGroups Class


DefinitionGroups.Create Method

DefinitionGroupsCreate Method

Create a new parameter definition group using the name provided.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DefinitionGroup Create(
    string name
)
Public Function Create (
    name As String
) As DefinitionGroup
public:
DefinitionGroup^ Create(
    String^ name
)
member Create :
        name : string -> DefinitionGroup

Parameters

name String
The name of the group to be created.

Return Value

DefinitionGroup
If successful a reference to the new parameter group is returned, otherwise .
Remarks
If a group with the same name already exists then an exception will be thrown.
See Also

Reference

DefinitionGroups Class


DefinitionGroups.Dispose Method

DefinitionGroupsDispose Method

Releases all resources used by the DefinitionGroups

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

DefinitionGroups Class


DefinitionGroups.GetBasicIEnumerator Method

DefinitionGroupsGetBasicIEnumerator Method

Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
internal virtual IEnumerator GetBasicIEnumerator()
Friend Overridable Function GetBasicIEnumerator As IEnumerator
internal:
virtual IEnumerator^ GetBasicIEnumerator()
internal abstract GetBasicIEnumerator : unit -> IEnumerator
internal override GetBasicIEnumerator : unit -> IEnumerator

Return Value

IEnumerator
An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerableGetEnumerator
See Also

Reference

DefinitionGroups Class


DefinitionGroups.GetEnumerator Method

DefinitionGroupsGetEnumerator Method

Retrieves an enumerator to the collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator<DefinitionGroup> GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator(Of DefinitionGroup)
public:
virtual IEnumerator<DefinitionGroup^>^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator<DefinitionGroup>
override GetEnumerator : unit -> IEnumerator<DefinitionGroup>

Return Value

IEnumerator DefinitionGroup
The enumerator.

Implements

IEnumerableTGetEnumerator
See Also

Reference

DefinitionGroups Class


Definitions Class

A base class that supports the addition of new parameter definitions.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBDefinitions
Autodesk.Revit.DBExternalDefinitions
Autodesk.Revit.DBInternalDefinitions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Definitions : IEnumerable<Definition>,
    IDisposable
Public Class Definitions
    Implements IEnumerable(Of Definition), IDisposable
public ref class Definitions : IEnumerable<Definition^>,
    IDisposable
type Definitions =
    class
        interface IEnumerable<Definition>
        interface IDisposable
    end

The Definitions type exposes the following members.

Constructors
 | Name | Description
Public method | Definitions | Constructs an empty set of parameter definitions.
Top
Properties
 | Name | Description
Public property | IsEmpty | Identifies if the definitions collection is empty.
Public property | Item | Retrieves a definition by a given name.
Public property | Size | The number of definitions in the collection.
Top
Methods
 | Name | Description
Public method | Contains | Tests for the existence of a definition within the set.
Public method | Create | Creates a new parameter definition using specified options.
Public method | Dispose | Releases all resources used by the Definitions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Retrieves an enumerator to the collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
There are two derivations of this class, one of which handles external parameters and another which handles internal parameters.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Definitions Constructor

Constructs an empty set of parameter definitions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Definitions()
Public Sub New
public:
Definitions()
new : unit -> Definitions
See Also

Reference

Definitions Class


Definitions Properties

The Definitions type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Identifies if the definitions collection is empty.
Public property | Item | Retrieves a definition by a given name.
Public property | Size | The number of definitions in the collection.
Top
See Also

Reference

Definitions Class


Definitions.IsEmpty Property

DefinitionsIsEmpty Property

Identifies if the definitions collection is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEmpty { get; }
Public ReadOnly Property IsEmpty As Boolean
    Get
public:
property bool IsEmpty {
    bool get ();
}
member IsEmpty : bool with get

Property Value

Boolean
See Also

Reference

Definitions Class


Definitions.Item Property

DefinitionsItem Property

Retrieves a definition by a given name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Definition this[
    string name
] { get; }
Public ReadOnly Property Item (
    name As String
) As Definition
    Get
public:
property Definition^ Item[String^ name] {
    Definition^ get (String^ name);
}
member Item : Definition with get

Parameters

name String
The name of the parameter definition for which to search.

Property Value

Definition
Remarks
If the definition is not found then will be returned.
See Also

Reference

Definitions Class


Definitions.Size Property

DefinitionsSize Property

The number of definitions in the collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Size { get; }
Public ReadOnly Property Size As Integer
    Get
public:
property int Size {
    int get ();
}
member Size : int with get

Property Value

Int32
See Also

Reference

Definitions Class


Definitions Methods

The Definitions type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Tests for the existence of a definition within the set.
Public method | Create | Creates a new parameter definition using specified options.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Retrieves an enumerator to the collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Definitions Class


Definitions.Contains Method

DefinitionsContains Method

Tests for the existence of a definition within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Contains(
    Definition definition
)
Public Function Contains (
    definition As Definition
) As Boolean
public:
bool Contains(
    Definition^ definition
)
member Contains :
        definition : Definition -> bool

Parameters

definition Definition
The definition to look for.

Return Value

Boolean
True if the definition was found, false otherwise.
See Also

Reference

Definitions Class


Definitions.Create Method

DefinitionsCreate Method

Creates a new parameter definition using specified options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Definition Create(
    ExternalDefinitionCreationOptions option
)
Public Function Create (
    option As ExternalDefinitionCreationOptions
) As Definition
public:
Definition^ Create(
    ExternalDefinitionCreationOptions^ option
)
member Create :
        option : ExternalDefinitionCreationOptions -> Definition

Parameters

option ExternalDefinitionCreationOptions
The options used to create the new parameter definition.

Return Value

Definition
If successful a reference to the new parameter definition is returned, otherwise .
Remarks
This method only supports creation of new external definitions (shared parameters).
See Also

Reference

Definitions Class


Definitions.Dispose Method

DefinitionsDispose Method

Releases all resources used by the Definitions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

Definitions Class


Definitions.GetBasicIEnumerator Method

DefinitionsGetBasicIEnumerator Method

Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
internal virtual IEnumerator GetBasicIEnumerator()
Friend Overridable Function GetBasicIEnumerator As IEnumerator
internal:
virtual IEnumerator^ GetBasicIEnumerator()
internal abstract GetBasicIEnumerator : unit -> IEnumerator
internal override GetBasicIEnumerator : unit -> IEnumerator

Return Value

IEnumerator
An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerableGetEnumerator
See Also

Reference

Definitions Class


Definitions.GetEnumerator Method

DefinitionsGetEnumerator Method

Retrieves an enumerator to the collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator<Definition> GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator(Of Definition)
public:
virtual IEnumerator<Definition^>^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator<Definition>
override GetEnumerator : unit -> IEnumerator<Definition>

Return Value

IEnumerator Definition
The enumerator.

Implements

IEnumerableTGetEnumerator
See Also

Reference

Definitions Class


DeleteElements Class

Deletes element(s) related to the failure.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFailureResolution
Autodesk.Revit.DBDeleteElements

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DeleteElements : FailureResolution
Public Class DeleteElements
    Inherits FailureResolution
public ref class DeleteElements : public FailureResolution
type DeleteElements =
    class
        inherit FailureResolution
    end

The DeleteElements type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FailureResolution)
Top
Methods
 | Name | Description
 | Create(Document, ElementId) | Creates an instance of the DeleteElements resolution.
 | Create(Document, IListElementId) | Creates an instance of the DeleteElements resolution.
 | Create(Document, ISetElementId) | Creates an instance of the DeleteElements resolution.
Public method | Dispose | (Inherited from FailureResolution)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DeleteElements Properties

The DeleteElements type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FailureResolution)
Top
See Also

Reference

DeleteElements Class


DeleteElements Methods

The DeleteElements type exposes the following members.

Methods
 | Name | Description
 | Create(Document, ElementId) | Creates an instance of the DeleteElements resolution.
 | Create(Document, IListElementId) | Creates an instance of the DeleteElements resolution.
 | Create(Document, ISetElementId) | Creates an instance of the DeleteElements resolution.
Public method | Dispose | (Inherited from FailureResolution)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DeleteElements Class


DeleteElements.Create Method

DeleteElementsCreate Method

Overload List
Name | Description
Create(Document, ElementId) | Creates an instance of the DeleteElements resolution.
Create(Document, IListElementId) | Creates an instance of the DeleteElements resolution.
Create(Document, ISetElementId) | Creates an instance of the DeleteElements resolution.
Top
See Also

Reference

DeleteElements Class


DeleteElements.Create(Document, ElementId) Method

DeleteElementsCreate(Document, ElementId) Method

Creates an instance of the DeleteElements resolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureResolution Create(
    Document document,
    ElementId id
)
Public Shared Function Create (
    document As Document,
    id As ElementId
) As FailureResolution
public:
static FailureResolution^ Create(
    Document^ document,
    ElementId^ id
)
static member Create :
        document : Document *
        id : ElementId -> FailureResolution

Parameters

document Document
The document which owns the element to delete.
id ElementId
The id of the element that will be deleted when this resolution is chosen.

Return Value

FailureResolution
The instance of the DeletedElements resolution.
Exceptions
Exception | Condition
ArgumentException | The input id is not valid for deletion.
ArgumentNullException | A non-optional argument was null
See Also

Reference

DeleteElements Class
Create Overload


DeleteElements.Create(Document, IList<ElementId>) Method

DeleteElementsCreate(Document, IListElementId) Method

Creates an instance of the DeleteElements resolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureResolution Create(
    Document document,
    IList<ElementId> ids
)
Public Shared Function Create (
    document As Document,
    ids As IList(Of ElementId)
) As FailureResolution
public:
static FailureResolution^ Create(
    Document^ document,
    IList<ElementId^>^ ids
)
static member Create :
        document : Document *
        ids : IList<ElementId> -> FailureResolution

Parameters

document Document
The document which owns the elements to delete.
ids IList ElementId
The ids of the elements that will be deleted when this resolution is chosen.

Return Value

FailureResolution
The instance of the DeleteElements resolution.
Exceptions
Exception | Condition
ArgumentException | The input ids is empty or contains an invalid element id.
ArgumentNullException | A non-optional argument was null
See Also

Reference

DeleteElements Class
Create Overload


DeleteElements.Create(Document, ISet<ElementId>) Method

DeleteElementsCreate(Document, ISetElementId) Method

Creates an instance of the DeleteElements resolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureResolution Create(
    Document document,
    ISet<ElementId> ids
)
Public Shared Function Create (
    document As Document,
    ids As ISet(Of ElementId)
) As FailureResolution
public:
static FailureResolution^ Create(
    Document^ document,
    ISet<ElementId^>^ ids
)
static member Create :
        document : Document *
        ids : ISet<ElementId> -> FailureResolution

Parameters

document Document
The document which owns the elements to delete.
ids ISet ElementId
The ids of the elements that will be deleted when this resolution is chosen.

Return Value

FailureResolution
The instance of the DeleteElements resolution.
Exceptions
Exception | Condition
ArgumentException | The input ids is empty or contains an invalid element id.
ArgumentNullException | A non-optional argument was null
See Also

Reference

DeleteElements Class
Create Overload


DeleteWorksetOption Enumeration

This class defines an enumerative type used to specify the option to delete a workset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DeleteWorksetOption
Public Enumeration DeleteWorksetOption
public enum class DeleteWorksetOption
type DeleteWorksetOption
Members
Member name | Value | Description
MoveElementsToWorkset | 0 | Delete a workset, while moving the elements from the deleted workset to another workset.
DeleteAllElements | 1 | Delete a workset together with all the elements in this workset.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DeleteWorksetSettings Class

This class represents the settings used to delete a workset.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBDeleteWorksetSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DeleteWorksetSettings : IDisposable
Public Class DeleteWorksetSettings
    Implements IDisposable
public ref class DeleteWorksetSettings : IDisposable
type DeleteWorksetSettings =
    class
        interface IDisposable
    end

The DeleteWorksetSettings type exposes the following members.

Constructors
 | Name | Description
Public method | DeleteWorksetSettings | Constructs a DeleteWorksetSettings object with DeleteWorksetOption::DeleteAllElements option.
Public method | DeleteWorksetSettings(DeleteWorksetOption, WorksetId) | Constructs a DeleteWorksetSettings object.
Top
Properties
 | Name | Description
Public property | DeleteWorksetOption | The current delete workset option.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | WorksetId | The target worksetId for those elements under the deleted workset, which is used for DeleteWorksetOption::MoveElementsToWorkset.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the DeleteWorksetSettings
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DeleteWorksetSettings Constructor

Overload List
 | Name | Description
Public method | DeleteWorksetSettings | Constructs a DeleteWorksetSettings object with DeleteWorksetOption::DeleteAllElements option.
Public method | DeleteWorksetSettings(DeleteWorksetOption, WorksetId) | Constructs a DeleteWorksetSettings object.
Top
See Also

Reference

DeleteWorksetSettings Class


DeleteWorksetSettings Constructor

Constructs a DeleteWorksetSettings object with DeleteWorksetOption::DeleteAllElements option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DeleteWorksetSettings()
Public Sub New
public:
DeleteWorksetSettings()
new : unit -> DeleteWorksetSettings
See Also

Reference

DeleteWorksetSettings Class
DeleteWorksetSettings Overload


DeleteWorksetSettings(DeleteWorksetOption, WorksetId) Constructor

Constructs a DeleteWorksetSettings object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DeleteWorksetSettings(
    DeleteWorksetOption deleteWorksetOption,
    WorksetId elementsMoveInto
)
Public Sub New (
    deleteWorksetOption As DeleteWorksetOption,
    elementsMoveInto As WorksetId
)
public:
DeleteWorksetSettings(
    DeleteWorksetOption deleteWorksetOption,
    WorksetId^ elementsMoveInto
)
new :
        deleteWorksetOption : DeleteWorksetOption *
        elementsMoveInto : WorksetId -> DeleteWorksetSettings

Parameters

deleteWorksetOption DeleteWorksetOption
elementsMoveInto WorksetId
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Remarks
elementsMoveInto only takes effect when DeleteWorksetOption::Enum is MoveElementsToWorkset.
See Also

Reference

DeleteWorksetSettings Class
DeleteWorksetSettings Overload


DeleteWorksetSettings Properties

The DeleteWorksetSettings type exposes the following members.

Properties
 | Name | Description
Public property | DeleteWorksetOption | The current delete workset option.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | WorksetId | The target worksetId for those elements under the deleted workset, which is used for DeleteWorksetOption::MoveElementsToWorkset.
Top
See Also

Reference

DeleteWorksetSettings Class


DeleteWorksetSettings.DeleteWorksetOption Property

DeleteWorksetSettingsDeleteWorksetOption Property

The current delete workset option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DeleteWorksetOption DeleteWorksetOption { get; set; }
Public Property DeleteWorksetOption As DeleteWorksetOption
    Get
    Set
public:
property DeleteWorksetOption DeleteWorksetOption {
    DeleteWorksetOption get ();
    void set (DeleteWorksetOption value);
}
member DeleteWorksetOption : DeleteWorksetOption with get, set

Property Value

DeleteWorksetOption
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

DeleteWorksetSettings Class


DeleteWorksetSettings.IsValidObject Property

DeleteWorksetSettingsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

DeleteWorksetSettings Class


DeleteWorksetSettings.WorksetId Property

DeleteWorksetSettingsWorksetId Property

The target worksetId for those elements under the deleted workset, which is used for DeleteWorksetOption::MoveElementsToWorkset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WorksetId WorksetId { get; set; }
Public Property WorksetId As WorksetId
    Get
    Set
public:
property WorksetId^ WorksetId {
    WorksetId^ get ();
    void set (WorksetId^ value);
}
member WorksetId : WorksetId with get, set

Property Value

WorksetId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

DeleteWorksetSettings Class


DeleteWorksetSettings Methods

The DeleteWorksetSettings type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DeleteWorksetSettings Class


DeleteWorksetSettings.Dispose Method

DeleteWorksetSettingsDispose Method

Releases all resources used by the DeleteWorksetSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

DeleteWorksetSettings Class


DesignOption Class

An element that represents a design alternative.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBDesignOption

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DesignOption : Element
Public Class DesignOption
    Inherits Element
public ref class DesignOption : public Element
type DesignOption =
    class
        inherit Element
    end

The DesignOption type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsPrimary | Determines whether this is a primary design option.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
 | GetActiveDesignOptionId | Gets the active design option id for the current design option set.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Design options enable the user to add alternative designs within the same project. Each element can either be in a design option or not at all, in which case it is considered to be part of the main model and have no design alternatives.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DesignOption Properties

The DesignOption type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsPrimary | Determines whether this is a primary design option.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

DesignOption Class


DesignOption.IsPrimary Property

DesignOptionIsPrimary Property

Determines whether this is a primary design option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsPrimary { get; }
Public ReadOnly Property IsPrimary As Boolean
    Get
public:
property bool IsPrimary {
    bool get ();
}
member IsPrimary : bool with get

Property Value

Boolean
See Also

Reference

DesignOption Class


DesignOption Methods

The DesignOption type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
 | GetActiveDesignOptionId | Gets the active design option id for the current design option set.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DesignOption Class


DesignOption.GetActiveDesignOptionId Method

DesignOptionGetActiveDesignOptionId Method

Gets the active design option id for the current design option set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ElementId GetActiveDesignOptionId(
    Document document
)
Public Shared Function GetActiveDesignOptionId (
    document As Document
) As ElementId
public:
static ElementId^ GetActiveDesignOptionId(
    Document^ document
)
static member GetActiveDesignOptionId :
        document : Document -> ElementId

Parameters

document Document
The document.

Return Value

ElementId
The active design option id. It can be invalid id if there is no active design option in the model.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DesignOption Class


DetachFromCentralOption Enumeration

Options for workset detachment behavior.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DetachFromCentralOption
Public Enumeration DetachFromCentralOption
public enum class DetachFromCentralOption
type DetachFromCentralOption
Members
Member name | Value | Description
DoNotDetach | 0 | Do not detach the file being opened from its central file.
DetachAndPreserveWorksets | 1 | Detach the file being opened from its central file.
DetachAndDiscardWorksets | 2 | Detach the model being opened from its central model and discard worksets/worksharing.
ClearTransmittedSaveAsNewCentral | 3 | After opening the transmitted, workshared model, immediately resave it with its current name and clear the transmitted flag.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DetailArc Class

Represents a DetailArc within Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBCurveElement
Autodesk.Revit.DBDetailCurve
Autodesk.Revit.DBDetailArc

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DetailArc : DetailCurve
Public Class DetailArc
    Inherits DetailCurve
public ref class DetailArc : public DetailCurve
type DetailArc =
    class
        inherit DetailCurve
    end

The DetailArc type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CurveElementType | Type of the curve element. (Inherited from CurveElement)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement)
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element. (Inherited from CurveElement)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement)
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from DetailCurve::geometryCurve property.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DetailArc Properties

The DetailArc type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CurveElementType | Type of the curve element. (Inherited from CurveElement)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement)
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element. (Inherited from CurveElement)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

DetailArc Class


DetailArc Methods

The DetailArc type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement)
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DetailArc Class


DetailCurve Class

A curve that is used to create a detail drawing. A detail curve is visible only in the view in which it is drawn.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBCurveElement
Autodesk.Revit.DBDetailCurve
Autodesk.Revit.DBDetailArc
Autodesk.Revit.DBDetailEllipse
Autodesk.Revit.DBDetailLine
Autodesk.Revit.DBDetailNurbSpline

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DetailCurve : CurveElement
Public Class DetailCurve
    Inherits CurveElement
public ref class DetailCurve : public CurveElement
type DetailCurve =
    class
        inherit CurveElement
    end

The DetailCurve type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CurveElementType | Type of the curve element. (Inherited from CurveElement)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement)
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element. (Inherited from CurveElement)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement)
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DetailCurve Properties

The DetailCurve type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CurveElementType | Type of the curve element. (Inherited from CurveElement)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement)
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element. (Inherited from CurveElement)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

DetailCurve Class


DetailCurve Methods

The DetailCurve type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement)
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DetailCurve Class


DetailCurveArray Class

An array that can contain any type of object.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBDetailCurveArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DetailCurveArray : APIObject,
    IEnumerable
Public Class DetailCurveArray
    Inherits APIObject
    Implements IEnumerable
public ref class DetailCurveArray : public APIObject,
    IEnumerable
type DetailCurveArray =
    class
        inherit APIObject
        interface IEnumerable
    end

The DetailCurveArray type exposes the following members.

Constructors
 | Name | Description
Public method | DetailCurveArray | Initializes a new instance of the DetailCurveArray class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.
Top
Methods
 | Name | Description
Public method | Append |
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DetailCurveArray Constructor

Initializes a new instance of the DetailCurveArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DetailCurveArray()
Public Sub New
public:
DetailCurveArray()
new : unit -> DetailCurveArray
See Also

Reference

DetailCurveArray Class


DetailCurveArray Properties

The DetailCurveArray type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.
Top
See Also

Reference

DetailCurveArray Class


DetailCurveArray.IsEmpty Property

DetailCurveArrayIsEmpty Property

Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Boolean
Remarks
If the array is empty then True will be returned, otherwise False.
See Also

Reference

DetailCurveArray Class


DetailCurveArray.Item Property

DetailCurveArrayItem Property

Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual DetailCurve this[
    int index
] { get; set; }
Public Overridable Property Item (
    index As Integer
) As DetailCurve
    Get
    Set
public:
virtual property DetailCurve^ Item[int index] {
    DetailCurve^ get (int index);
    void set (int index, DetailCurve^ value);
}
abstract Item : DetailCurve with get, set
override Item : DetailCurve with get, set

Parameters

index Int32
The index of the item to be set or retrieved.

Return Value

DetailCurve
Returns the object at the specified index.
See Also

Reference

DetailCurveArray Class


DetailCurveArray.Size Property

DetailCurveArraySize Property

Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
abstract Size : int with get
override Size : int with get

Property Value

Int32
See Also

Reference

DetailCurveArray Class


DetailCurveArray Methods

The DetailCurveArray type exposes the following members.

Methods
 | Name | Description
Public method | Append |
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DetailCurveArray Class


DetailCurveArray.Append Method

DetailCurveArrayAppend Method

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Append(
    DetailCurve item
)
Public Overridable Sub Append (
    item As DetailCurve
)
public:
virtual void Append(
    DetailCurve^ item
)
abstract Append :
        item : DetailCurve -> unit
override Append :
        item : DetailCurve -> unit

Parameters

item DetailCurve
See Also

Reference

DetailCurveArray Class


DetailCurveArray.Clear Method

DetailCurveArrayClear Method

Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

DetailCurveArray Class


DetailCurveArray.ForwardIterator Method

DetailCurveArrayForwardIterator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual DetailCurveArrayIterator ForwardIterator()
Public Overridable Function ForwardIterator As DetailCurveArrayIterator
public:
virtual DetailCurveArrayIterator^ ForwardIterator()
abstract ForwardIterator : unit -> DetailCurveArrayIterator
override ForwardIterator : unit -> DetailCurveArrayIterator

Return Value

DetailCurveArrayIterator
Returns a forward moving iterator to the array.
See Also

Reference

DetailCurveArray Class


DetailCurveArray.GetEnumerator Method

DetailCurveArrayGetEnumerator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

IEnumerator
Returns a forward moving iterator to the array.

Implements

IEnumerableGetEnumerator
See Also

Reference

DetailCurveArray Class


DetailCurveArray.Insert Method

DetailCurveArrayInsert Method

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Insert(
    DetailCurve item,
    int index
)
Public Overridable Sub Insert (
    item As DetailCurve,
    index As Integer
)
public:
virtual void Insert(
    DetailCurve^ item,
    int index
)
abstract Insert :
        item : DetailCurve *
        index : int -> unit
override Insert :
        item : DetailCurve *
        index : int -> unit

Parameters

item DetailCurve
index Int32
See Also

Reference

DetailCurveArray Class


DetailCurveArray.ReverseIterator Method

DetailCurveArrayReverseIterator Method

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual DetailCurveArrayIterator ReverseIterator()
Public Overridable Function ReverseIterator As DetailCurveArrayIterator
public:
virtual DetailCurveArrayIterator^ ReverseIterator()
abstract ReverseIterator : unit -> DetailCurveArrayIterator
override ReverseIterator : unit -> DetailCurveArrayIterator

Return Value

DetailCurveArrayIterator
Returns a backward moving iterator to the array.
See Also

Reference

DetailCurveArray Class


DetailCurveArrayIterator Class

An iterator to a array.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBDetailCurveArrayIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class DetailCurveArrayIterator : APIObject,
    IEnumerator
Public MustInherit Class DetailCurveArrayIterator
    Inherits APIObject
    Implements IEnumerator
public ref class DetailCurveArrayIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type DetailCurveArrayIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The DetailCurveArrayIterator type exposes the following members.

Constructors
 | Name | Description
Public method | DetailCurveArrayIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DetailCurveArrayIterator Constructor

For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DetailCurveArrayIterator()
Public Sub New
public:
DetailCurveArrayIterator()
new : unit -> DetailCurveArrayIterator
Remarks
This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.
See Also

Reference

DetailCurveArrayIterator Class


DetailCurveArrayIterator Properties

The DetailCurveArrayIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

DetailCurveArrayIterator Class


DetailCurveArrayIterator.Current Property

DetailCurveArrayIteratorCurrent Property

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}
abstract Current : Object with get
override Current : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.
See Also

Reference

DetailCurveArrayIterator Class


DetailCurveArrayIterator Methods

The DetailCurveArrayIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DetailCurveArrayIterator Class


DetailCurveArrayIterator.MoveNext Method

DetailCurveArrayIteratorMoveNext Method

Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumeratorMoveNext
Remarks
MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.
See Also

Reference

DetailCurveArrayIterator Class


DetailCurveArrayIterator.Reset Method

DetailCurveArrayIteratorReset Method

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
Remarks
The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.
See Also

Reference

DetailCurveArrayIterator Class


DetailElementOrderUtils Class

A utility class that arranges the draw order of the detail elements.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBDetailElementOrderUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class DetailElementOrderUtils
Public NotInheritable Class DetailElementOrderUtils
public ref class DetailElementOrderUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DetailElementOrderUtils = class end

The DetailElementOrderUtils type exposes the following members.

Methods
Name | Description
AreDetailElements | Indicates if the elements are all detail elements that participate in detail draw ordering in the view.
BringForward(Document, View, ElementId) | Moves the given detail instance one step closer to the front of all other detail instances in the view.
BringForward(Document, View, ICollectionElementId) | Moves the given detail instances one step closer to the front of all other detail instances in the view, while keeping the order of the given ones.
BringToFront(Document, View, ElementId) | Places the given detail instance in the front of all other detail instances in the view.
BringToFront(Document, View, ICollectionElementId) | Places the given detail instances in the front of all other detail instances in the view, while keeping the order of the given ones.
GetDrawOrderForDetails | Returns the given detail elements according to the currently specified draw order for the detail elements in a given view.
IsDetailElement | Indicates if the element is a detail element that participates in detail draw ordering in the view.
SendBackward(Document, View, ElementId) | Moves the given detail instance one step closer to the back of all other detail instances in the view.
SendBackward(Document, View, ICollectionElementId) | Moves the given detail instances one step closer to the back with relation to all other detail instances in the view, while keeping the order of the given ones.
SendToBack(Document, View, ElementId) | Places the given detail instance behind all detail instances in the view.
SendToBack(Document, View, ICollectionElementId) | Places the given detail instances behind all other detail instances in the view, while keeping the order of the given ones.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DetailElementOrderUtils Methods

The DetailElementOrderUtils type exposes the following members.

Methods
Name | Description
AreDetailElements | Indicates if the elements are all detail elements that participate in detail draw ordering in the view.
BringForward(Document, View, ElementId) | Moves the given detail instance one step closer to the front of all other detail instances in the view.
BringForward(Document, View, ICollectionElementId) | Moves the given detail instances one step closer to the front of all other detail instances in the view, while keeping the order of the given ones.
BringToFront(Document, View, ElementId) | Places the given detail instance in the front of all other detail instances in the view.
BringToFront(Document, View, ICollectionElementId) | Places the given detail instances in the front of all other detail instances in the view, while keeping the order of the given ones.
GetDrawOrderForDetails | Returns the given detail elements according to the currently specified draw order for the detail elements in a given view.
IsDetailElement | Indicates if the element is a detail element that participates in detail draw ordering in the view.
SendBackward(Document, View, ElementId) | Moves the given detail instance one step closer to the back of all other detail instances in the view.
SendBackward(Document, View, ICollectionElementId) | Moves the given detail instances one step closer to the back with relation to all other detail instances in the view, while keeping the order of the given ones.
SendToBack(Document, View, ElementId) | Places the given detail instance behind all detail instances in the view.
SendToBack(Document, View, ICollectionElementId) | Places the given detail instances behind all other detail instances in the view, while keeping the order of the given ones.
Top
See Also

Reference

DetailElementOrderUtils Class


DetailElementOrderUtils.AreDetailElements Method

DetailElementOrderUtilsAreDetailElements Method

Indicates if the elements are all detail elements that participate in detail draw ordering in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool AreDetailElements(
    Document document,
    View view,
    ICollection<ElementId> detailElementIds
)
Public Shared Function AreDetailElements (
    document As Document,
    view As View,
    detailElementIds As ICollection(Of ElementId)
) As Boolean
public:
static bool AreDetailElements(
    Document^ document,
    View^ view,
    ICollection<ElementId^>^ detailElementIds
)
static member AreDetailElements :
        document : Document *
        view : View *
        detailElementIds : ICollection<ElementId> -> bool

Parameters

document Document
The document.
view View
The view in which the details appear.
detailElementIds ICollection ElementId
The details to check.

Return Value

Boolean
True if the detail elements are orderable in the view, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DetailElementOrderUtils Class


DetailElementOrderUtils.BringForward Method

DetailElementOrderUtilsBringForward Method

Overload List
Name | Description
BringForward(Document, View, ElementId) | Moves the given detail instance one step closer to the front of all other detail instances in the view.
BringForward(Document, View, ICollectionElementId) | Moves the given detail instances one step closer to the front of all other detail instances in the view, while keeping the order of the given ones.
Top
See Also

Reference

DetailElementOrderUtils Class


DetailElementOrderUtils.BringForward(Document, View, ElementId) Method

DetailElementOrderUtilsBringForward(Document, View, ElementId) Method

Moves the given detail instance one step closer to the front of all other detail instances in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void BringForward(
    Document document,
    View view,
    ElementId detailElementId
)
Public Shared Sub BringForward (
    document As Document,
    view As View,
    detailElementId As ElementId
)
public:
static void BringForward(
    Document^ document,
    View^ view,
    ElementId^ detailElementId
)
static member BringForward :
        document : Document *
        view : View *
        detailElementId : ElementId -> unit

Parameters

document Document
The document.
view View
The view in which the detail appears.
detailElementId ElementId
The detail to bring forward.
Exceptions
Exception | Condition
ArgumentException | The document does not support detail draw order. Only projects and 3d families support draw order. 2d families and in-place families do not support draw order. -or- The element detailElementId is not a detail or it does not participate in detail draw ordering. Details must be visible in the view. -or- In 3d families, detail draw order can only be adjusted in views that are parallel to the document's X, Y or Z axes.
ArgumentNullException | A non-optional argument was null
See Also

Reference

DetailElementOrderUtils Class
BringForward Overload


DetailElementOrderUtils.BringForward(Document, View, ICollection<ElementId>) Method

DetailElementOrderUtilsBringForward(Document, View, ICollectionElementId) Method

Moves the given detail instances one step closer to the front of all other detail instances in the view, while keeping the order of the given ones.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void BringForward(
    Document document,
    View view,
    ICollection<ElementId> detailElementIds
)
Public Shared Sub BringForward (
    document As Document,
    view As View,
    detailElementIds As ICollection(Of ElementId)
)
public:
static void BringForward(
    Document^ document,
    View^ view,
    ICollection<ElementId^>^ detailElementIds
)
static member BringForward :
        document : Document *
        view : View *
        detailElementIds : ICollection<ElementId> -> unit

Parameters

document Document
The document.
view View
The view in which the details appear.
detailElementIds ICollection ElementId
The details to bring forward.
Exceptions
Exception | Condition
ArgumentException | The document does not support detail draw order. Only projects and 3d families support draw order. 2d families and in-place families do not support draw order. -or- detailElementIds is empty or it contains elements that do not participate in detail draw ordering. Details must be visible in the view. -or- In 3d families, detail draw order can only be adjusted in views that are parallel to the document's X, Y or Z axes.
ArgumentNullException | A non-optional argument was null
See Also

Reference

DetailElementOrderUtils Class
BringForward Overload


DetailElementOrderUtils.BringToFront Method

DetailElementOrderUtilsBringToFront Method

Overload List
Name | Description
BringToFront(Document, View, ElementId) | Places the given detail instance in the front of all other detail instances in the view.
BringToFront(Document, View, ICollectionElementId) | Places the given detail instances in the front of all other detail instances in the view, while keeping the order of the given ones.
Top
See Also

Reference

DetailElementOrderUtils Class


DetailElementOrderUtils.BringToFront(Document, View, ElementId) Method

DetailElementOrderUtilsBringToFront(Document, View, ElementId) Method

Places the given detail instance in the front of all other detail instances in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void BringToFront(
    Document document,
    View view,
    ElementId detailElementId
)
Public Shared Sub BringToFront (
    document As Document,
    view As View,
    detailElementId As ElementId
)
public:
static void BringToFront(
    Document^ document,
    View^ view,
    ElementId^ detailElementId
)
static member BringToFront :
        document : Document *
        view : View *
        detailElementId : ElementId -> unit

Parameters

document Document
The document.
view View
The view in which the detail appears.
detailElementId ElementId
The detail element.
Exceptions
Exception | Condition
ArgumentException | The document does not support detail draw order. Only projects and 3d families support draw order. 2d families and in-place families do not support draw order. -or- The element detailElementId is not a detail or it does not participate in detail draw ordering. Details must be visible in the view. -or- In 3d families, detail draw order can only be adjusted in views that are parallel to the document's X, Y or Z axes.
ArgumentNullException | A non-optional argument was null
See Also

Reference

DetailElementOrderUtils Class
BringToFront Overload


DetailElementOrderUtils.BringToFront(Document, View, ICollection<ElementId>) Method

DetailElementOrderUtilsBringToFront(Document, View, ICollectionElementId) Method

Places the given detail instances in the front of all other detail instances in the view, while keeping the order of the given ones.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void BringToFront(
    Document document,
    View view,
    ICollection<ElementId> detailElementIds
)
Public Shared Sub BringToFront (
    document As Document,
    view As View,
    detailElementIds As ICollection(Of ElementId)
)
public:
static void BringToFront(
    Document^ document,
    View^ view,
    ICollection<ElementId^>^ detailElementIds
)
static member BringToFront :
        document : Document *
        view : View *
        detailElementIds : ICollection<ElementId> -> unit

Parameters

document Document
The document.
view View
The view in which the details appear.
detailElementIds ICollection ElementId
The details to bring to front.
Exceptions
Exception | Condition
ArgumentException | The document does not support detail draw order. Only projects and 3d families support draw order. 2d families and in-place families do not support draw order. -or- detailElementIds is empty or it contains elements that do not participate in detail draw ordering. Details must be visible in the view. -or- In 3d families, detail draw order can only be adjusted in views that are parallel to the document's X, Y or Z axes.
ArgumentNullException | A non-optional argument was null
See Also

Reference

DetailElementOrderUtils Class
BringToFront Overload


DetailElementOrderUtils.GetDrawOrderForDetails Method

DetailElementOrderUtilsGetDrawOrderForDetails Method

Returns the given detail elements according to the currently specified draw order for the detail elements in a given view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<ElementId> GetDrawOrderForDetails(
    View view,
    ISet<ElementId> detailIdsToSort
)
Public Shared Function GetDrawOrderForDetails (
    view As View,
    detailIdsToSort As ISet(Of ElementId)
) As IList(Of ElementId)
public:
static IList<ElementId^>^ GetDrawOrderForDetails(
    View^ view,
    ISet<ElementId^>^ detailIdsToSort
)
static member GetDrawOrderForDetails :
        view : View *
        detailIdsToSort : ISet<ElementId> -> IList<ElementId>

Parameters

view View
The view in which the details appear.
detailIdsToSort ISet ElementId
The detail to be sorted by draw order.

Return Value

IList ElementId
The detail ids sorted from back to front, with earlier elements drawing first and appearing under later elements.
Exceptions
Exception | Condition
ArgumentException | The document does not support detail draw order. Only projects and 3d families support draw order. 2d families and in-place families do not support draw order. -or- detailIdsToSort is empty or it contains elements are not visible in the view. -or- detailIdsToSort is empty or it contains elements that do not participate in detail draw ordering. Details must be visible in the view.
ArgumentNullException | A non-optional argument was null
Remarks
The sort order is from back to front, with earlier elements drawing first and appearing under later elements.
See Also

Reference

DetailElementOrderUtils Class


DetailElementOrderUtils.IsDetailElement Method

DetailElementOrderUtilsIsDetailElement Method

Indicates if the element is a detail element that participates in detail draw ordering in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsDetailElement(
    Document document,
    View view,
    ElementId detailElementId
)
Public Shared Function IsDetailElement (
    document As Document,
    view As View,
    detailElementId As ElementId
) As Boolean
public:
static bool IsDetailElement(
    Document^ document,
    View^ view,
    ElementId^ detailElementId
)
static member IsDetailElement :
        document : Document *
        view : View *
        detailElementId : ElementId -> bool

Parameters

document Document
The document.
view View
The view in which the detail appears.
detailElementId ElementId
The detail element.

Return Value

Boolean
True if the detail element is orderable in the view, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DetailElementOrderUtils Class


DetailElementOrderUtils.SendBackward Method

DetailElementOrderUtilsSendBackward Method

Overload List
Name | Description
SendBackward(Document, View, ElementId) | Moves the given detail instance one step closer to the back of all other detail instances in the view.
SendBackward(Document, View, ICollectionElementId) | Moves the given detail instances one step closer to the back with relation to all other detail instances in the view, while keeping the order of the given ones.
Top
See Also

Reference

DetailElementOrderUtils Class


DetailElementOrderUtils.SendBackward(Document, View, ElementId) Method

DetailElementOrderUtilsSendBackward(Document, View, ElementId) Method

Moves the given detail instance one step closer to the back of all other detail instances in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void SendBackward(
    Document document,
    View view,
    ElementId detailElementId
)
Public Shared Sub SendBackward (
    document As Document,
    view As View,
    detailElementId As ElementId
)
public:
static void SendBackward(
    Document^ document,
    View^ view,
    ElementId^ detailElementId
)
static member SendBackward :
        document : Document *
        view : View *
        detailElementId : ElementId -> unit

Parameters

document Document
The document.
view View
The view in which the detail appears.
detailElementId ElementId
The detail to move backward.
Exceptions
Exception | Condition
ArgumentException | The document does not support detail draw order. Only projects and 3d families support draw order. 2d families and in-place families do not support draw order. -or- The element detailElementId is not a detail or it does not participate in detail draw ordering. Details must be visible in the view. -or- In 3d families, detail draw order can only be adjusted in views that are parallel to the document's X, Y or Z axes.
ArgumentNullException | A non-optional argument was null
See Also

Reference

DetailElementOrderUtils Class
SendBackward Overload


DetailElementOrderUtils.SendBackward(Document, View, ICollection<ElementId>) Method

DetailElementOrderUtilsSendBackward(Document, View, ICollectionElementId) Method

Moves the given detail instances one step closer to the back with relation to all other detail instances in the view, while keeping the order of the given ones.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void SendBackward(
    Document document,
    View view,
    ICollection<ElementId> detailElementIds
)
Public Shared Sub SendBackward (
    document As Document,
    view As View,
    detailElementIds As ICollection(Of ElementId)
)
public:
static void SendBackward(
    Document^ document,
    View^ view,
    ICollection<ElementId^>^ detailElementIds
)
static member SendBackward :
        document : Document *
        view : View *
        detailElementIds : ICollection<ElementId> -> unit

Parameters

document Document
The document.
view View
The view in which the details appear.
detailElementIds ICollection ElementId
The details to move backward.
Exceptions
Exception | Condition
ArgumentException | The document does not support detail draw order. Only projects and 3d families support draw order. 2d families and in-place families do not support draw order. -or- detailElementIds is empty or it contains elements that do not participate in detail draw ordering. Details must be visible in the view. -or- In 3d families, detail draw order can only be adjusted in views that are parallel to the document's X, Y or Z axes.
ArgumentNullException | A non-optional argument was null
See Also

Reference

DetailElementOrderUtils Class
SendBackward Overload


DetailElementOrderUtils.SendToBack Method

DetailElementOrderUtilsSendToBack Method

Overload List
Name | Description
SendToBack(Document, View, ElementId) | Places the given detail instance behind all detail instances in the view.
SendToBack(Document, View, ICollectionElementId) | Places the given detail instances behind all other detail instances in the view, while keeping the order of the given ones.
Top
See Also

Reference

DetailElementOrderUtils Class


DetailElementOrderUtils.SendToBack(Document, View, ElementId) Method

DetailElementOrderUtilsSendToBack(Document, View, ElementId) Method

Places the given detail instance behind all detail instances in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void SendToBack(
    Document document,
    View view,
    ElementId detailElementId
)
Public Shared Sub SendToBack (
    document As Document,
    view As View,
    detailElementId As ElementId
)
public:
static void SendToBack(
    Document^ document,
    View^ view,
    ElementId^ detailElementId
)
static member SendToBack :
        document : Document *
        view : View *
        detailElementId : ElementId -> unit

Parameters

document Document
The document.
view View
The view in which the detail appears.
detailElementId ElementId
The detail to send to back.
Exceptions
Exception | Condition
ArgumentException | The document does not support detail draw order. Only projects and 3d families support draw order. 2d families and in-place families do not support draw order. -or- The element detailElementId is not a detail or it does not participate in detail draw ordering. Details must be visible in the view. -or- In 3d families, detail draw order can only be adjusted in views that are parallel to the document's X, Y or Z axes.
ArgumentNullException | A non-optional argument was null
See Also

Reference

DetailElementOrderUtils Class
SendToBack Overload


DetailElementOrderUtils.SendToBack(Document, View, ICollection<ElementId>) Method

DetailElementOrderUtilsSendToBack(Document, View, ICollectionElementId) Method

Places the given detail instances behind all other detail instances in the view, while keeping the order of the given ones.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void SendToBack(
    Document document,
    View view,
    ICollection<ElementId> detailElementIds
)
Public Shared Sub SendToBack (
    document As Document,
    view As View,
    detailElementIds As ICollection(Of ElementId)
)
public:
static void SendToBack(
    Document^ document,
    View^ view,
    ICollection<ElementId^>^ detailElementIds
)
static member SendToBack :
        document : Document *
        view : View *
        detailElementIds : ICollection<ElementId> -> unit

Parameters

document Document
The document.
view View
The view in which the details appear.
detailElementIds ICollection ElementId
The details to send to back.
Exceptions
Exception | Condition
ArgumentException | The document does not support detail draw order. Only projects and 3d families support draw order. 2d families and in-place families do not support draw order. -or- detailElementIds is empty or it contains elements that do not participate in detail draw ordering. Details must be visible in the view. -or- In 3d families, detail draw order can only be adjusted in views that are parallel to the document's X, Y or Z axes.
ArgumentNullException | A non-optional argument was null
See Also

Reference

DetailElementOrderUtils Class
SendToBack Overload


DetailEllipse Class

Represents a DetailEllipse within Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBCurveElement
Autodesk.Revit.DBDetailCurve
Autodesk.Revit.DBDetailEllipse

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DetailEllipse : DetailCurve
Public Class DetailEllipse
    Inherits DetailCurve
public ref class DetailEllipse : public DetailCurve
type DetailEllipse =
    class
        inherit DetailCurve
    end

The DetailEllipse type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CurveElementType | Type of the curve element. (Inherited from CurveElement)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement)
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element. (Inherited from CurveElement)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement)
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from DetailCurve::geometryCurve property.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DetailEllipse Properties

The DetailEllipse type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CurveElementType | Type of the curve element. (Inherited from CurveElement)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement)
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element. (Inherited from CurveElement)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

DetailEllipse Class


DetailEllipse Methods

The DetailEllipse type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement)
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DetailEllipse Class


DetailLine Class

Represents a DetailLine within Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBCurveElement
Autodesk.Revit.DBDetailCurve
Autodesk.Revit.DBDetailLine

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DetailLine : DetailCurve
Public Class DetailLine
    Inherits DetailCurve
public ref class DetailLine : public DetailCurve
type DetailLine =
    class
        inherit DetailCurve
    end

The DetailLine type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CurveElementType | Type of the curve element. (Inherited from CurveElement)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement)
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element. (Inherited from CurveElement)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement)
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from DetailCurve::geometryCurve property.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DetailLine Properties

The DetailLine type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CurveElementType | Type of the curve element. (Inherited from CurveElement)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement)
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element. (Inherited from CurveElement)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

DetailLine Class


DetailLine Methods

The DetailLine type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement)
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DetailLine Class


DetailNurbSpline Class

Represents a DetailNurbSpline within Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBCurveElement
Autodesk.Revit.DBDetailCurve
Autodesk.Revit.DBDetailNurbSpline

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DetailNurbSpline : DetailCurve
Public Class DetailNurbSpline
    Inherits DetailCurve
public ref class DetailNurbSpline : public DetailCurve
type DetailNurbSpline =
    class
        inherit DetailCurve
    end

The DetailNurbSpline type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CurveElementType | Type of the curve element. (Inherited from CurveElement)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement)
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element. (Inherited from CurveElement)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement)
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from DetailCurve::geometryCurve property.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DetailNurbSpline Properties

The DetailNurbSpline type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CurveElementType | Type of the curve element. (Inherited from CurveElement)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement)
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element. (Inherited from CurveElement)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

DetailNurbSpline Class


DetailNurbSpline Methods

The DetailNurbSpline type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement)
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DetailNurbSpline Class


DGNExportOptions Class

The export options used by exporting DGN format file.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBaseExportOptions
Autodesk.Revit.DBDGNExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DGNExportOptions : BaseExportOptions
Public Class DGNExportOptions
    Inherits BaseExportOptions
public ref class DGNExportOptions : public BaseExportOptions
type DGNExportOptions =
    class
        inherit BaseExportOptions
    end

The DGNExportOptions type exposes the following members.

Constructors
 | Name | Description
Public method | DGNExportOptions | Constructs a new instance of DGNExportOptions with default values of all properties.
Public method | DGNExportOptions(DGNExportOptions) | Constructs a new instance of DGNExportOptions as a copy of the export options.
Top
Properties
 | Name | Description
Public property | Colors | Export color mode. Default value is ExportColorMode.IndexColors. (Inherited from BaseExportOptions)
Public property | FileVersion | The DGN file version. Default value of fileVersion is DGNFileFormat.Default.
Public property | HatchPatternsFileName | Custom hatch patterns (pat) file name. (Inherited from BaseExportOptions)
Public property | HideReferencePlane | Whether or not to hide reference planes. Default value is false. (Inherited from BaseExportOptions)
Public property | HideScopeBox | Whether or not to hide the scope box. Default value is false. (Inherited from BaseExportOptions)
Public property | HideUnreferenceViewTags | Whether or not to hide unreference view tags. Default value is false. (Inherited from BaseExportOptions)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BaseExportOptions)
Public property | LayerMapping | Name of a layer settings standard or filename (with custom layer settings). Valid standards are: DGNV7 (only for DGN), AIA, CP83, BS1192, and ISO13567. default value is "" (empty) which means if no value is set, if no value is set, Revit will use a default value according to the localization. (Inherited from BaseExportOptions)
Public property | MergedViews | Whether to merge all views in one file (via XRefs). Default value of mergedViews is false.
Public property | PreserveCoincidentLines | Whether or not to preserve coincident lines. Default value is false. (Inherited from BaseExportOptions)
Public property | PropOverrides | How to export overridden object styles. Default value is PropOverrideMode.ByEntity. (Inherited from BaseExportOptions)
Public property | SeedName | The name of the DGN seed. Default value of seedName is empty.
Public property | WorkingUnits | If true, Main Units will be used. If false, Sub Units will be used. Default value of WorkingUnits is true.
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from BaseExportOptions)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetExportFontTable | Gets font table. (Inherited from BaseExportOptions)
Public method | GetExportLayerTable | Gets the layer table. (Inherited from BaseExportOptions)
Public method | GetExportLinetypeTable | Gets a copy of the line type table. (Inherited from BaseExportOptions)
Public method | GetExportLineweightTable | Gets a copy of the line weight table.
Public method | GetExportPatternTable | Gets a copy of the pattern table. (Inherited from BaseExportOptions)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
 | GetPredefinedOptions | Returns an instance DGNExportOptions containing settings from a predefined export setup.
 | GetPredefinedSetupNames | Returns a list of names of predefined setups of DGN export options.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetExportFontTable | Sets font table to option. (Inherited from BaseExportOptions)
Public method | SetExportLayerTable | Sets layer table back to option (Inherited from BaseExportOptions)
Public method | SetExportLinetypeTable | Sets the line type table to use during export. (Inherited from BaseExportOptions)
Public method | SetExportLineweightTable | Sets the line weight table to use during export.
Public method | SetExportPatternTable | Sets the pattern table to use during export. (Inherited from BaseExportOptions)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DGNExportOptions Constructor

Overload List
 | Name | Description
Public method | DGNExportOptions | Constructs a new instance of DGNExportOptions with default values of all properties.
Public method | DGNExportOptions(DGNExportOptions) | Constructs a new instance of DGNExportOptions as a copy of the export options.
Top
See Also

Reference

DGNExportOptions Class


DGNExportOptions Constructor

Constructs a new instance of DGNExportOptions with default values of all properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DGNExportOptions()
Public Sub New
public:
DGNExportOptions()
new : unit -> DGNExportOptions
See Also

Reference

DGNExportOptions Class
DGNExportOptions Overload


DGNExportOptions(DGNExportOptions) Constructor

Constructs a new instance of DGNExportOptions as a copy of the export options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DGNExportOptions(
    DGNExportOptions option
)
Public Sub New (
    option As DGNExportOptions
)
public:
DGNExportOptions(
    DGNExportOptions^ option
)
new :
        option : DGNExportOptions -> DGNExportOptions

Parameters

option DGNExportOptions
The options to be copied.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DGNExportOptions Class
DGNExportOptions Overload


DGNExportOptions Properties

The DGNExportOptions type exposes the following members.

Properties
 | Name | Description
Public property | Colors | Export color mode. Default value is ExportColorMode.IndexColors. (Inherited from BaseExportOptions)
Public property | FileVersion | The DGN file version. Default value of fileVersion is DGNFileFormat.Default.
Public property | HatchPatternsFileName | Custom hatch patterns (pat) file name. (Inherited from BaseExportOptions)
Public property | HideReferencePlane | Whether or not to hide reference planes. Default value is false. (Inherited from BaseExportOptions)
Public property | HideScopeBox | Whether or not to hide the scope box. Default value is false. (Inherited from BaseExportOptions)
Public property | HideUnreferenceViewTags | Whether or not to hide unreference view tags. Default value is false. (Inherited from BaseExportOptions)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BaseExportOptions)
Public property | LayerMapping | Name of a layer settings standard or filename (with custom layer settings). Valid standards are: DGNV7 (only for DGN), AIA, CP83, BS1192, and ISO13567. default value is "" (empty) which means if no value is set, if no value is set, Revit will use a default value according to the localization. (Inherited from BaseExportOptions)
Public property | MergedViews | Whether to merge all views in one file (via XRefs). Default value of mergedViews is false.
Public property | PreserveCoincidentLines | Whether or not to preserve coincident lines. Default value is false. (Inherited from BaseExportOptions)
Public property | PropOverrides | How to export overridden object styles. Default value is PropOverrideMode.ByEntity. (Inherited from BaseExportOptions)
Public property | SeedName | The name of the DGN seed. Default value of seedName is empty.
Public property | WorkingUnits | If true, Main Units will be used. If false, Sub Units will be used. Default value of WorkingUnits is true.
Top
See Also

Reference

DGNExportOptions Class


DGNExportOptions.FileVersion Property

DGNExportOptionsFileVersion Property

The DGN file version. Default value of fileVersion is DGNFileFormat.Default.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DGNFileFormat FileVersion { get; set; }
Public Property FileVersion As DGNFileFormat
    Get
    Set
public:
property DGNFileFormat FileVersion {
    DGNFileFormat get ();
    void set (DGNFileFormat value);
}
member FileVersion : DGNFileFormat with get, set

Property Value

DGNFileFormat
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

DGNExportOptions Class


DGNExportOptions.MergedViews Property

DGNExportOptionsMergedViews Property

Whether to merge all views in one file (via XRefs). Default value of mergedViews is false.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool MergedViews { get; set; }
Public Property MergedViews As Boolean
    Get
    Set
public:
property bool MergedViews {
    bool get ();
    void set (bool value);
}
member MergedViews : bool with get, set

Property Value

Boolean
See Also

Reference

DGNExportOptions Class


DGNExportOptions.SeedName Property

DGNExportOptionsSeedName Property

The name of the DGN seed. Default value of seedName is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SeedName { get; set; }
Public Property SeedName As String
    Get
    Set
public:
property String^ SeedName {
    String^ get ();
    void set (String^ value);
}
member SeedName : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

DGNExportOptions Class


DGNExportOptions.WorkingUnits Property

DGNExportOptionsWorkingUnits Property

If true, Main Units will be used. If false, Sub Units will be used. Default value of WorkingUnits is true.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool WorkingUnits { get; set; }
Public Property WorkingUnits As Boolean
    Get
    Set
public:
property bool WorkingUnits {
    bool get ();
    void set (bool value);
}
member WorkingUnits : bool with get, set

Property Value

Boolean
See Also

Reference

DGNExportOptions Class


DGNExportOptions Methods

The DGNExportOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from BaseExportOptions)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetExportFontTable | Gets font table. (Inherited from BaseExportOptions)
Public method | GetExportLayerTable | Gets the layer table. (Inherited from BaseExportOptions)
Public method | GetExportLinetypeTable | Gets a copy of the line type table. (Inherited from BaseExportOptions)
Public method | GetExportLineweightTable | Gets a copy of the line weight table.
Public method | GetExportPatternTable | Gets a copy of the pattern table. (Inherited from BaseExportOptions)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
 | GetPredefinedOptions | Returns an instance DGNExportOptions containing settings from a predefined export setup.
 | GetPredefinedSetupNames | Returns a list of names of predefined setups of DGN export options.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetExportFontTable | Sets font table to option. (Inherited from BaseExportOptions)
Public method | SetExportLayerTable | Sets layer table back to option (Inherited from BaseExportOptions)
Public method | SetExportLinetypeTable | Sets the line type table to use during export. (Inherited from BaseExportOptions)
Public method | SetExportLineweightTable | Sets the line weight table to use during export.
Public method | SetExportPatternTable | Sets the pattern table to use during export. (Inherited from BaseExportOptions)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DGNExportOptions Class


DGNExportOptions.GetExportLineweightTable Method

DGNExportOptionsGetExportLineweightTable Method

Gets a copy of the line weight table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportLineweightTable GetExportLineweightTable()
Public Function GetExportLineweightTable As ExportLineweightTable
public:
ExportLineweightTable^ GetExportLineweightTable()
member GetExportLineweightTable : unit -> ExportLineweightTable

Return Value

ExportLineweightTable
The line weight table.
See Also

Reference

DGNExportOptions Class


DGNExportOptions.GetPredefinedOptions Method

DGNExportOptionsGetPredefinedOptions Method

Returns an instance DGNExportOptions containing settings from a predefined export setup.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static DGNExportOptions GetPredefinedOptions(
    Document document,
    string setup
)
Public Shared Function GetPredefinedOptions (
    document As Document,
    setup As String
) As DGNExportOptions
public:
static DGNExportOptions^ GetPredefinedOptions(
    Document^ document,
    String^ setup
)
static member GetPredefinedOptions :
        document : Document *
        setup : string -> DGNExportOptions

Parameters

document Document
A Revit project document to retrieve the setup from.
setup String
The name of a predefined export setup from the specified document.

Return Value

DGNExportOptions
An instance of predefined DGNExportOptions, or if the name was not found.
Exceptions
Exception | Condition
ArgumentException | document is not a project document.
ArgumentNullException | A non-optional argument was null
See Also

Reference

DGNExportOptions Class


DGNExportOptions.GetPredefinedSetupNames Method

DGNExportOptionsGetPredefinedSetupNames Method

Returns a list of names of predefined setups of DGN export options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<string> GetPredefinedSetupNames(
    Document document
)
Public Shared Function GetPredefinedSetupNames (
    document As Document
) As IList(Of String)
public:
static IList<String^>^ GetPredefinedSetupNames(
    Document^ document
)
static member GetPredefinedSetupNames :
        document : Document -> IList<string>

Parameters

document Document
A Revit document to retrieve names from.

Return Value

IList String
An array of strings representing names of predefined setups.
Exceptions
Exception | Condition
ArgumentException | document is not a project document.
ArgumentNullException | A non-optional argument was null
Remarks
To get predefined options in the desired format use the static method getPredefinedOptions defined in DGNExportOptions.
See Also

Reference

DGNExportOptions Class


DGNExportOptions.SetExportLineweightTable Method

DGNExportOptionsSetExportLineweightTable Method

Sets the line weight table to use during export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetExportLineweightTable(
    ExportLineweightTable lineweightTable
)
Public Sub SetExportLineweightTable (
    lineweightTable As ExportLineweightTable
)
public:
void SetExportLineweightTable(
    ExportLineweightTable^ lineweightTable
)
member SetExportLineweightTable :
        lineweightTable : ExportLineweightTable -> unit

Parameters

lineweightTable ExportLineweightTable
The line weight table to be set.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DGNExportOptions Class


DGNFileFormat Enumeration

An enumerated type listing available Microstation versions into which a file may be exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DGNFileFormat
Public Enumeration DGNFileFormat
public enum class DGNFileFormat
type DGNFileFormat
Members
Member name | Value | Description
DGNVersion7 | 19 | Micorstation V7 file format.
Default | 20 | The Autodesk Revit application's default file format.
DGNVersion8 | 20 | Micorstation V8 file format.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DGNImportOptions Class

The import options used to import DGN format files.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBaseImportOptions
Autodesk.Revit.DBDGNImportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DGNImportOptions : BaseImportOptions
Public Class DGNImportOptions
    Inherits BaseImportOptions
public ref class DGNImportOptions : public BaseImportOptions
type DGNImportOptions =
    class
        inherit BaseImportOptions
    end

The DGNImportOptions type exposes the following members.

Constructors
 | Name | Description
Public method | DGNImportOptions | Constructs a new instance of DGNImportOptions with default values of all properties.
Public method | DGNImportOptions(DGNImportOptions) | Constructs a new instance of DGNImportOptions as a copy of the import options.
Top
Properties
 | Name | Description
Public property | AutoCorrectAlmostVHLines | Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines. (Inherited from BaseImportOptions)
Public property | ColorMode | Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors. (Inherited from BaseImportOptions)
Public property | CustomScale | Scaling the import. If this is defined and a valid value (> 0.0), it takes priority over units. (Inherited from BaseImportOptions)
Public property | DGNModelViewName | The model view name to be imported. Need user give a model view name to specify which model view need to be imported into Revit
Public property | IgnoreUnsupportedElementWarning | If true, ignore warning messages about unsupported elements in the DGN file. If false, the import process is aborted if imported dgn files have unsupported elements.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BaseImportOptions)
Public property | OrientToView | Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false) (Inherited from BaseImportOptions)
Public property | Placement | Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates. (Inherited from BaseImportOptions)
Public property | ReferencePoint | The 3D point in the document where the imported instance will be inserted. If not explicitly set, the instance will be inserted at the document origin. (Inherited from BaseImportOptions)
Public property | ThisViewOnly | Imports drawings into the view that was passed into the import method. This option is not available in 3D views. (Inherited from BaseImportOptions)
Public property | Unit | The unit of measure for imported geometry. (Inherited from BaseImportOptions)
Public property | VisibleLayersOnly | Only import the visible layers. (Inherited from BaseImportOptions)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from BaseImportOptions)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetDefaultLengthUnit | Get the default length unit used for importing unitless files. (Inherited from BaseImportOptions)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLayerSelection | Get all set layers name which user want to import into Revit. (Inherited from BaseImportOptions)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetDefaultLengthUnit | Set the default length unit used for importing unitless files. (Inherited from BaseImportOptions)
Public method | SetLayerSelection | Set the layers name which user want to import into Revit. (Inherited from BaseImportOptions)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DGNImportOptions Constructor

Overload List
 | Name | Description
Public method | DGNImportOptions | Constructs a new instance of DGNImportOptions with default values of all properties.
Public method | DGNImportOptions(DGNImportOptions) | Constructs a new instance of DGNImportOptions as a copy of the import options.
Top
See Also

Reference

DGNImportOptions Class


DGNImportOptions Constructor

Constructs a new instance of DGNImportOptions with default values of all properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DGNImportOptions()
Public Sub New
public:
DGNImportOptions()
new : unit -> DGNImportOptions
See Also

Reference

DGNImportOptions Class
DGNImportOptions Overload


DGNImportOptions(DGNImportOptions) Constructor

Constructs a new instance of DGNImportOptions as a copy of the import options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DGNImportOptions(
    DGNImportOptions option
)
Public Sub New (
    option As DGNImportOptions
)
public:
DGNImportOptions(
    DGNImportOptions^ option
)
new :
        option : DGNImportOptions -> DGNImportOptions

Parameters

option DGNImportOptions
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DGNImportOptions Class
DGNImportOptions Overload


DGNImportOptions Properties

The DGNImportOptions type exposes the following members.

Properties
 | Name | Description
Public property | AutoCorrectAlmostVHLines | Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines. (Inherited from BaseImportOptions)
Public property | ColorMode | Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors. (Inherited from BaseImportOptions)
Public property | CustomScale | Scaling the import. If this is defined and a valid value (> 0.0), it takes priority over units. (Inherited from BaseImportOptions)
Public property | DGNModelViewName | The model view name to be imported. Need user give a model view name to specify which model view need to be imported into Revit
Public property | IgnoreUnsupportedElementWarning | If true, ignore warning messages about unsupported elements in the DGN file. If false, the import process is aborted if imported dgn files have unsupported elements.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BaseImportOptions)
Public property | OrientToView | Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false) (Inherited from BaseImportOptions)
Public property | Placement | Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates. (Inherited from BaseImportOptions)
Public property | ReferencePoint | The 3D point in the document where the imported instance will be inserted. If not explicitly set, the instance will be inserted at the document origin. (Inherited from BaseImportOptions)
Public property | ThisViewOnly | Imports drawings into the view that was passed into the import method. This option is not available in 3D views. (Inherited from BaseImportOptions)
Public property | Unit | The unit of measure for imported geometry. (Inherited from BaseImportOptions)
Public property | VisibleLayersOnly | Only import the visible layers. (Inherited from BaseImportOptions)
Top
See Also

Reference

DGNImportOptions Class


DGNImportOptions.DGNModelViewName Property

DGNImportOptionsDGNModelViewName Property

The model view name to be imported. Need user give a model view name to specify which model view need to be imported into Revit

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string DGNModelViewName { get; set; }
Public Property DGNModelViewName As String
    Get
    Set
public:
property String^ DGNModelViewName {
    String^ get ();
    void set (String^ value);
}
member DGNModelViewName : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

DGNImportOptions Class


DGNImportOptions.IgnoreUnsupportedElementWarning Property

DGNImportOptionsIgnoreUnsupportedElementWarning Property

If true, ignore warning messages about unsupported elements in the DGN file. If false, the import process is aborted if imported dgn files have unsupported elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IgnoreUnsupportedElementWarning { get; set; }
Public Property IgnoreUnsupportedElementWarning As Boolean
    Get
    Set
public:
property bool IgnoreUnsupportedElementWarning {
    bool get ();
    void set (bool value);
}
member IgnoreUnsupportedElementWarning : bool with get, set

Property Value

Boolean
See Also

Reference

DGNImportOptions Class


DGNImportOptions Methods

The DGNImportOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from BaseImportOptions)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetDefaultLengthUnit | Get the default length unit used for importing unitless files. (Inherited from BaseImportOptions)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLayerSelection | Get all set layers name which user want to import into Revit. (Inherited from BaseImportOptions)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetDefaultLengthUnit | Set the default length unit used for importing unitless files. (Inherited from BaseImportOptions)
Public method | SetLayerSelection | Set the layers name which user want to import into Revit. (Inherited from BaseImportOptions)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DGNImportOptions Class


DigitGroupingAmount Enumeration

The number of digits in each group when numbers are formatted with digit grouping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DigitGroupingAmount
Public Enumeration DigitGroupingAmount
public enum class DigitGroupingAmount
type DigitGroupingAmount
Members
Member name | Value | Description
Two | 0 | Digits are in groups of two, with the exception of the first group to the left of the decimal symbol which contains three digits.
Three | 1 | Digits are in groups of three.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DigitGroupingSymbol Enumeration

The symbol used to separate groups of digits when numbers are formatted with digit grouping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DigitGroupingSymbol
Public Enumeration DigitGroupingSymbol
public enum class DigitGroupingSymbol
type DigitGroupingSymbol
Members
Member name | Value | Description
Dot | 0 | A dot (".").
Comma | 1 | A comma (",").
Space | 2 | A space (" ").
Apostrophe | 3 | An apostrophe ("'").
Tick | 3 | An apostrophe ("'"). This value is deprecated in Revit 2015. Use DigitGroupingSymbol.Apostrophe instead.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Dimension Class

An object that represents a dimension within the Revit project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBDimension
Autodesk.Revit.DBAngularDimension
Autodesk.Revit.DBLinearDimension
Autodesk.Revit.DBRadialDimension
Autodesk.Revit.DBSpotDimension

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Dimension : Element
Public Class Dimension
    Inherits Element
public ref class Dimension : public Element
type Dimension =
    class
        inherit Element
    end

The Dimension type exposes the following members.

Properties
 | Name | Description
Public property | Above | The text shown above the segment's value.
Public property | AreReferencesAvailable | Indicates if this dimension's references can be resolved.
Public property | AreSegmentsEqual | Indicates if all segments are forced to be equal.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | Below | The text shown below the segment's value.
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | Curve | A curve that represents the dimension line.
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | DimensionShape | The shape of this dimension.
Public property | DimensionType | The dimension style of this dimension.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyLabel | The family parameter label of the dimension.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HasLeader | True if dimension has leader, false otherwise.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsLocked | Indicates if this dimension is locked.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValid | Indicates if this dimension is valid.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LeaderEndPosition | The position of the dimension's leader end point.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Retrieves or changes the name associated with the Dimension.
Public property | NumberOfSegments | The number of segments for the dimension.
Public property | Origin | The dimension origin.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Prefix | The text shown before the segment's value.
Public property | References | Returns an array of geometric references to which the dimension is attached.
Public property | Segments | The segments in the dimension.
Public property | Suffix | The text shown after the segment's value.
 | TextPosition | The position of the dimension text's drag point.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | Value | The value of the dimension.
Public property | ValueOverride | The text that replaces the segment's value.
Public property | ValueString | The dimension value as a user visible string.
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | View | Supplies the view that contains the dimension if the dimension is view specific.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasOneSegment | Determines whether a dimension has one segment.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsTextPositionAdjustable | Indicates if this dimension is supported to set/get TextPosition/LeaderEndPosition.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | ResetTextPosition | Resets the text position of the dimension to the initial position determined by its type and parameters.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Example
C#
VB
C++
F#
Copy
public void GetInfo_Dimension(Dimension dimension)
{
    string message = "Dimension : ";
    // Get Dimension name
    message += "\nDimension name is : " + dimension.Name;

    // Get Dimension Curve
    Autodesk.Revit.DB.Curve curve = dimension.Curve;
    if (curve != null && curve.IsBound)
    {
        // Get curve start point
        message += "\nCurve start point:(" + curve.GetEndPoint(0).X + ", "
             + curve.GetEndPoint(0).Y + ", " + curve.GetEndPoint(0).Z + ")";
        // Get curve end point
        message += "; Curve end point:(" + curve.GetEndPoint(1).X + ", "
             + curve.GetEndPoint(1).Y + ", " + curve.GetEndPoint(1).Z + ")";
    }

    // Get Dimension type name
    message += "\nDimension type name is : " + dimension.DimensionType.Name;

    // Get Dimension view name
    message += "\nDimension view name is : " + dimension.View.Name;

    // Get Dimension reference count
    message += "\nDimension references count is " + dimension.References.Size;

    if (BuiltInCategory.OST_Dimensions == dimension.Category.BuiltInCategory)
    {
        message += "\nDimension is a permanent dimension.";
    }
    else if (BuiltInCategory.OST_Constraints == dimension.Category.BuiltInCategory)
    {
        message += "\nDimension is a constraint element.";
    }

    Autodesk.Revit.UI.TaskDialog.Show("Revit",message);
}
Public Sub GetInfo_Dimension(dimension As Dimension)
   Dim message As String = "Dimension : "
   ' Get Dimension name
   message += vbLf & "Dimension name is : " + dimension.Name

   ' Get Dimension Curve
   Dim curve As Autodesk.Revit.DB.Curve = dimension.Curve
   If curve IsNot Nothing AndAlso curve.IsBound Then
      ' Get curve start point
      message += vbLf & "Curve start point:(" + curve.GetEndPoint(0).X + ", " + curve.GetEndPoint(0).Y + ", " + curve.GetEndPoint(0).Z + ")"
      ' Get curve end point
      message += "; Curve end point:(" + curve.GetEndPoint(1).X + ", " + curve.GetEndPoint(1).Y + ", " + curve.GetEndPoint(1).Z + ")"
   End If

   ' Get Dimension type name
   message += vbLf & "Dimension type name is : " + dimension.DimensionType.Name

   ' Get Dimension view name
   message += vbLf & "Dimension view name is : " + dimension.View.Name

   ' Get Dimension reference count
   message += vbLf & "Dimension references count is " + dimension.References.Size

   If BuiltInCategory.OST_Dimensions = dimension.Category.BuiltInCategory Then
      message += vbLf & "Dimension is a permanent dimension."
   ElseIf BuiltInCategory.OST_Constraints = dimension.Category.BuiltInCategory Then
      message += vbLf & "Dimension is a constraint element."
   End If

   UI.TaskDialog.Show("Revit", message)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Dimension Properties

The Dimension type exposes the following members.

Properties
 | Name | Description
Public property | Above | The text shown above the segment's value.
Public property | AreReferencesAvailable | Indicates if this dimension's references can be resolved.
Public property | AreSegmentsEqual | Indicates if all segments are forced to be equal.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | Below | The text shown below the segment's value.
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | Curve | A curve that represents the dimension line.
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | DimensionShape | The shape of this dimension.
Public property | DimensionType | The dimension style of this dimension.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyLabel | The family parameter label of the dimension.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HasLeader | True if dimension has leader, false otherwise.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsLocked | Indicates if this dimension is locked.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValid | Indicates if this dimension is valid.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LeaderEndPosition | The position of the dimension's leader end point.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Retrieves or changes the name associated with the Dimension.
Public property | NumberOfSegments | The number of segments for the dimension.
Public property | Origin | The dimension origin.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Prefix | The text shown before the segment's value.
Public property | References | Returns an array of geometric references to which the dimension is attached.
Public property | Segments | The segments in the dimension.
Public property | Suffix | The text shown after the segment's value.
 | TextPosition | The position of the dimension text's drag point.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | Value | The value of the dimension.
Public property | ValueOverride | The text that replaces the segment's value.
Public property | ValueString | The dimension value as a user visible string.
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | View | Supplies the view that contains the dimension if the dimension is view specific.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

Dimension Class


Dimension.Above Property

DimensionAbove Property

The text shown above the segment's value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Above { get; set; }
Public Property Above As String
    Get
    Set
public:
property String^ Above {
    String^ get ();
    void set (String^ value);
}
member Above : string with get, set

Property Value

String
Remarks
This property is for use with single-segmment dimensions only. For multi-segment dimensions use the corresponding properties of the DimensionSegment class.
See Also

Reference

Dimension Class


Dimension.AreReferencesAvailable Property

DimensionAreReferencesAvailable Property

Indicates if this dimension's references can be resolved.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AreReferencesAvailable { get; }
Public ReadOnly Property AreReferencesAvailable As Boolean
    Get
public:
property bool AreReferencesAvailable {
    bool get ();
}
member AreReferencesAvailable : bool with get

Property Value

Boolean
Remarks
This property always returns true for model dimensions. It can return false for view-specific dimensions that can lose their references in certain situations. For example, the host element references may not be available when the view containing the dimension is closed. In general, if the host element view-specific geometry is not available, dimensions that reference that geometry will not be able to resolve their references.
See Also

Reference

Dimension Class


Dimension.AreSegmentsEqual Property

DimensionAreSegmentsEqual Property

Indicates if all segments are forced to be equal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AreSegmentsEqual { get; set; }
Public Property AreSegmentsEqual As Boolean
    Get
    Set
public:
property bool AreSegmentsEqual {
    bool get ();
    void set (bool value);
}
member AreSegmentsEqual : bool with get, set

Property Value

Boolean
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the dimension is non-linear or has only one segment.
Remarks
This property is usable only for linear dimensions with more than one segment.
See Also

Reference

Dimension Class


Dimension.Below Property

DimensionBelow Property

The text shown below the segment's value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Below { get; set; }
Public Property Below As String
    Get
    Set
public:
property String^ Below {
    String^ get ();
    void set (String^ value);
}
member Below : string with get, set

Property Value

String
Remarks
This property is for use with single-segment dimensions only. For multi-segment dimensions use the corresponding properties of the DimensionSegment class.
See Also

Reference

Dimension Class


Dimension.Curve Property

DimensionCurve Property

A curve that represents the dimension line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Curve Curve { get; }
Public ReadOnly Property Curve As Curve
    Get
public:
property Curve^ Curve {
    Curve^ get ();
}
member Curve : Curve with get

Property Value

Curve
See Also

Reference

Dimension Class


Dimension.DimensionShape Property

DimensionDimensionShape Property

The shape of this dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DimensionShape DimensionShape { get; }
Public ReadOnly Property DimensionShape As DimensionShape
    Get
public:
property DimensionShape DimensionShape {
    DimensionShape get ();
}
member DimensionShape : DimensionShape with get

Property Value

DimensionShape
See Also

Reference

Dimension Class


Dimension.DimensionType Property

DimensionDimensionType Property

The dimension style of this dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DimensionType DimensionType { get; set; }
Public Property DimensionType As DimensionType
    Get
    Set
public:
property DimensionType^ DimensionType {
    DimensionType^ get ();
    void set (DimensionType^ value);
}
member DimensionType : DimensionType with get, set

Property Value

DimensionType
See Also

Reference

Dimension Class


Dimension.FamilyLabel Property

DimensionFamilyLabel Property

The family parameter label of the dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyParameter FamilyLabel { get; set; }
Public Property FamilyLabel As FamilyParameter
    Get
    Set
public:
property FamilyParameter^ FamilyLabel {
    FamilyParameter^ get ();
    void set (FamilyParameter^ value);
}
member FamilyLabel : FamilyParameter with get, set

Property Value

FamilyParameter
Exceptions
Exception | Condition
ArgumentException | Thrown when the family parameter's ParameterType is not suitable for this dimension.
InvalidOperationException | Thrown when dimension can not be labeled.
InvalidOperationException | Thrown when failed to get the BuiltInParameter DIM_LABEL.
Remarks
A dimension only can be labeled to a family parameter in a family document. When the dimension is labeled by a reporting parameter, the dimension value drives the parameter value. When the parameter is labeled by a non-reporting, the value of the parameter drives the dimension. If the dimension is multi-segmented, each segment of the dimension is driven by the same parameter value. Multi-segmented dimensions cannot be labeled by reporting parameters. To unbind the family parameter, set this property to .
See Also

Reference

Dimension Class


Dimension.HasLeader Property

DimensionHasLeader Property

True if dimension has leader, false otherwise.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasLeader { get; set; }
Public Property HasLeader As Boolean
    Get
    Set
public:
property bool HasLeader {
    bool get ();
    void set (bool value);
}
member HasLeader : bool with get, set

Property Value

Boolean
See Also

Reference

Dimension Class


Dimension.IsLocked Property

DimensionIsLocked Property

Indicates if this dimension is locked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsLocked { get; set; }
Public Property IsLocked As Boolean
    Get
    Set
public:
property bool IsLocked {
    bool get ();
    void set (bool value);
}
member IsLocked : bool with get, set

Property Value

Boolean
Remarks
This property always returns false if the dimension is a radial or spot dimension. This property cannot be set if the dimension has been labeled, or if the dimension shape is arc-length, radial, diameter or spot, or if the dimension is linear with more than one segment.
See Also

Reference

Dimension Class


Dimension.IsValid Property

DimensionIsValid Property

Indicates if this dimension is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValid { get; }
Public ReadOnly Property IsValid As Boolean
    Get
public:
property bool IsValid {
    bool get ();
}
member IsValid : bool with get

Property Value

Boolean
Remarks
This property always returns true for model dimensions. It can return false for view-specific dimensions that are hidden because they are in an invalid state. An example of an invalid state is having misaligned references for an aligned dimension.
See Also

Reference

Dimension Class


Dimension.LeaderEndPosition Property

DimensionLeaderEndPosition Property

The position of the dimension's leader end point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ LeaderEndPosition { get; set; }
Public Property LeaderEndPosition As XYZ
    Get
    Set
public:
property XYZ^ LeaderEndPosition {
    XYZ^ get ();
    void set (XYZ^ value);
}
member LeaderEndPosition : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
InvalidOperationException Dimension must have leader. -or- Thrown when:
  • SpotDimension style type is SpotSlope.
  • Using equality formula.
  • Dimension style is ordinate.
-or- Thrown when:
  • SpotDimension has more than one segments.
-or-
Remarks

This property is not applicable to all dimensions. For example, it is not available for spot slope dimensions, multi-segments dimensions, dimensions using equality formula, and when dimension style is ordinate.

If the position is not applicable, this property throws InvalidOperationException.

Notes for SpotDimension:

  • This property throws InvalidOperationException if dimension has no leader.
  • Setting of this property works differently for leader with and without shoulder.
  • If leader has shoulder, setting is limited by points on line between leader end and shoulder points (projected point is used).
  • Setting of this property also affects TextPosition.

See Also

Reference

Dimension Class


Dimension.Name Property

DimensionName Property

Retrieves or changes the name associated with the Dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

String
Remarks
The property inherited from element is hidden, a System.InvalidOperationException is thrown.
See Also

Reference

Dimension Class


Dimension.NumberOfSegments Property

DimensionNumberOfSegments Property

The number of segments for the dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int NumberOfSegments { get; }
Public ReadOnly Property NumberOfSegments As Integer
    Get
public:
property int NumberOfSegments {
    int get ();
}
member NumberOfSegments : int with get

Property Value

Int32
See Also

Reference

Dimension Class


Dimension.Origin Property

DimensionOrigin Property

The dimension origin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Origin { get; }
Public ReadOnly Property Origin As XYZ
    Get
public:
property XYZ^ Origin {
    XYZ^ get ();
}
member Origin : XYZ with get

Property Value

XYZ
Exceptions
Exception Condition
InvalidOperationException Thrown when:
  • SpotDimension has more than one segments.
Remarks
The origin is the middle point of the dimension line that makes up the dimension. This property is for use with single-segment dimensions only. For multi-segment dimensions use the corresponding property of the DimensionSegment class.
See Also

Reference

Dimension Class


Dimension.Prefix Property

DimensionPrefix Property

The text shown before the segment's value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Prefix { get; set; }
Public Property Prefix As String
    Get
    Set
public:
property String^ Prefix {
    String^ get ();
    void set (String^ value);
}
member Prefix : string with get, set

Property Value

String
Remarks
This property is for use with single-segmment dimensions only. For multi-segment dimensions use the corresponding properties of the DimensionSegment class.
See Also

Reference

Dimension Class


Dimension.References Property

DimensionReferences Property

Returns an array of geometric references to which the dimension is attached.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReferenceArray References { get; }
Public ReadOnly Property References As ReferenceArray
    Get
public:
property ReferenceArray^ References {
    ReferenceArray^ get ();
}
member References : ReferenceArray with get

Property Value

ReferenceArray
See Also

Reference

Dimension Class


Dimension.Segments Property

DimensionSegments Property

The segments in the dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DimensionSegmentArray Segments { get; }
Public ReadOnly Property Segments As DimensionSegmentArray
    Get
public:
property DimensionSegmentArray^ Segments {
    DimensionSegmentArray^ get ();
}
member Segments : DimensionSegmentArray with get

Property Value

DimensionSegmentArray
Remarks
Returns a read only array of segments in the dimension. The references of the dimension can be mapped to segments in order. The first segment here wrapped by first and second references; the nth segment is wrapped by nth and n+1st references.
See Also

Reference

Dimension Class


Dimension.Suffix Property

DimensionSuffix Property

The text shown after the segment's value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Suffix { get; set; }
Public Property Suffix As String
    Get
    Set
public:
property String^ Suffix {
    String^ get ();
    void set (String^ value);
}
member Suffix : string with get, set

Property Value

String
Remarks
This property is for use with single-segmment dimensions only. For multi-segment dimensions use the corresponding properties of the DimensionSegment class.
See Also

Reference

Dimension Class


Dimension.TextPosition Property

DimensionTextPosition Property

The position of the dimension text's drag point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ TextPosition { get; set; }
Public Property TextPosition As XYZ
    Get
    Set
public:
property XYZ^ TextPosition {
    XYZ^ get ();
    void set (XYZ^ value);
}
member TextPosition : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
InvalidOperationException Thrown when:
  • SpotDimension style type is SpotSlope.
  • Using equality formula.
  • Dimension style is ordinate.
-or- Thrown when:
  • SpotDimension has more than one segments.
-or-
Remarks

This property is not applicable to all dimensions. For example, it is not available for spot slope dimensions, multi-segments dimensions, dimensions using equality formula, and when dimension style is ordinate.

If the position is not applicable, this property throws InvalidOperationException.

Example
C#
Copy
    // Get the current text XYZ position
XYZ currentTextPosition = dimToModify.TextPosition;
// Calculate a new XYZ position by transforming the current text position
XYZ newTextPosition = Transform.CreateTranslation(new XYZ(0.0, 1.0, 0.0)).OfPoint(currentTextPosition);
// Set the new text position
dimToModify.TextPosition = newTextPosition;
See Also

Reference

Dimension Class


Dimension.Value Property

DimensionValue Property

The value of the dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double? Value { get; }
Public ReadOnly Property Value As Double?
    Get
public:
property Nullable<double> Value {
    Nullable<double> get ();
}
member Value : Nullable<float> with get

Property Value

Nullable Double
Remarks
This nullable property will not have a value for spot dimensions or for linear dimensions with more than one segment.
See Also

Reference

Dimension Class


Dimension.ValueOverride Property

DimensionValueOverride Property

The text that replaces the segment's value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ValueOverride { get; set; }
Public Property ValueOverride As String
    Get
    Set
public:
property String^ ValueOverride {
    String^ get ();
    void set (String^ value);
}
member ValueOverride : string with get, set

Property Value

String
Remarks
This property is for use with single-segment dimensions only. For multi-segment dimensions use the corresponding properties of the DimensionSegment class.
See Also

Reference

Dimension Class


Dimension.ValueString Property

DimensionValueString Property

The dimension value as a user visible string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ValueString { get; }
Public ReadOnly Property ValueString As String
    Get
public:
property String^ ValueString {
    String^ get ();
}
member ValueString : string with get

Property Value

String
Remarks
This property always return if this is a spot dimension, or it is a linear dimension with more than one segments.
See Also

Reference

Dimension Class


Dimension.View Property

DimensionView Property

Supplies the view that contains the dimension if the dimension is view specific.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public View View { get; }
Public ReadOnly Property View As View
    Get
public:
property View^ View {
    View^ get ();
}
member View : View with get

Property Value

View
See Also

Reference

Dimension Class


Dimension Methods

The Dimension type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasOneSegment | Determines whether a dimension has one segment.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsTextPositionAdjustable | Indicates if this dimension is supported to set/get TextPosition/LeaderEndPosition.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | ResetTextPosition | Resets the text position of the dimension to the initial position determined by its type and parameters.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Dimension Class


Dimension.HasOneSegment Method

DimensionHasOneSegment Method

Determines whether a dimension has one segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasOneSegment()
Public Function HasOneSegment As Boolean
public:
bool HasOneSegment()
member HasOneSegment : unit -> bool

Return Value

Boolean
See Also

Reference

Dimension Class


Dimension.IsTextPositionAdjustable Method

DimensionIsTextPositionAdjustable Method

Indicates if this dimension is supported to set/get TextPosition/LeaderEndPosition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsTextPositionAdjustable()
Public Function IsTextPositionAdjustable As Boolean
public:
bool IsTextPositionAdjustable()
member IsTextPositionAdjustable : unit -> bool

Return Value

Boolean
See Also

Reference

Dimension Class


Dimension.ResetTextPosition Method

DimensionResetTextPosition Method

Resets the text position of the dimension to the initial position determined by its type and parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetTextPosition()
Public Sub ResetTextPosition
public:
void ResetTextPosition()
member ResetTextPosition : unit -> unit
Exceptions
Exception Condition
InvalidOperationException Thrown when:
  • SpotDimension has more than one segments.
Remarks
The initial point is the text position determined by the type and parameters of the dimension. This property is for use with single-segment dimensions only. For multi-segment dimensions use the corresponding method of the DimensionSegment class.
See Also

Reference

Dimension Class


DimensionEqualityLabelFormatting Class

Instances of this class represent individual parameters used to make up a dimension equality formula for continuous linear or angular dimensions.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBDimensionEqualityLabelFormatting

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DimensionEqualityLabelFormatting : IDisposable
Public Class DimensionEqualityLabelFormatting
    Implements IDisposable
public ref class DimensionEqualityLabelFormatting : IDisposable
type DimensionEqualityLabelFormatting =
    class
        interface IDisposable
    end

The DimensionEqualityLabelFormatting type exposes the following members.

Constructors
 | Name | Description
Public method | DimensionEqualityLabelFormatting | Constructs a new instance of a DimensionEqualityLabelFormatting object with specified settings.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LabelType | The parameter value to be shown.
Public property | LeadingSpaces | The number of spaces to include before the parameter value.
Public property | Prefix | The prefix to include before the parameter value.
Public property | Suffix | The suffix to include after the parameter value.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the DimensionEqualityLabelFormatting
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetFormatOptions | Gets the format options used to show the parameter value.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsValidFormatOptions | Checks whether a FormatOptions object is valid for the LabelType.
Public method | SetFormatOptions | Sets the format options used to show the parameter value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DimensionEqualityLabelFormatting Constructor

Constructs a new instance of a DimensionEqualityLabelFormatting object with specified settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DimensionEqualityLabelFormatting(
    int leadingSpaces,
    string prefix,
    LabelType labelType,
    string suffix,
    FormatOptions formatOptions
)
Public Sub New (
    leadingSpaces As Integer,
    prefix As String,
    labelType As LabelType,
    suffix As String,
    formatOptions As FormatOptions
)
public:
DimensionEqualityLabelFormatting(
    int leadingSpaces,
    String^ prefix,
    LabelType labelType,
    String^ suffix,
    FormatOptions^ formatOptions
)
new :
        leadingSpaces : int *
        prefix : string *
        labelType : LabelType *
        suffix : string *
        formatOptions : FormatOptions -> DimensionEqualityLabelFormatting

Parameters

leadingSpaces Int32
The number of spaces to include before the parameter value.
prefix String
The prefix to include before the parameter value.
labelType LabelType
The parameter value to be shown.
suffix String
The suffix to include after the parameter value.
formatOptions FormatOptions
The format options to use for the parameter value.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

DimensionEqualityLabelFormatting Class


DimensionEqualityLabelFormatting Properties

The DimensionEqualityLabelFormatting type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LabelType | The parameter value to be shown.
Public property | LeadingSpaces | The number of spaces to include before the parameter value.
Public property | Prefix | The prefix to include before the parameter value.
Public property | Suffix | The suffix to include after the parameter value.
Top
See Also

Reference

DimensionEqualityLabelFormatting Class


DimensionEqualityLabelFormatting.IsValidObject Property

DimensionEqualityLabelFormattingIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

DimensionEqualityLabelFormatting Class


DimensionEqualityLabelFormatting.LabelType Property

DimensionEqualityLabelFormattingLabelType Property

The parameter value to be shown.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LabelType LabelType { get; }
Public ReadOnly Property LabelType As LabelType
    Get
public:
property LabelType LabelType {
    LabelType get ();
}
member LabelType : LabelType with get

Property Value

LabelType
See Also

Reference

DimensionEqualityLabelFormatting Class


DimensionEqualityLabelFormatting.LeadingSpaces Property

DimensionEqualityLabelFormattingLeadingSpaces Property

The number of spaces to include before the parameter value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int LeadingSpaces { get; set; }
Public Property LeadingSpaces As Integer
    Get
    Set
public:
property int LeadingSpaces {
    int get ();
    void set (int value);
}
member LeadingSpaces : int with get, set

Property Value

Int32
See Also

Reference

DimensionEqualityLabelFormatting Class


DimensionEqualityLabelFormatting.Prefix Property

DimensionEqualityLabelFormattingPrefix Property

The prefix to include before the parameter value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Prefix { get; set; }
Public Property Prefix As String
    Get
    Set
public:
property String^ Prefix {
    String^ get ();
    void set (String^ value);
}
member Prefix : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

DimensionEqualityLabelFormatting Class


DimensionEqualityLabelFormatting.Suffix Property

DimensionEqualityLabelFormattingSuffix Property

The suffix to include after the parameter value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Suffix { get; set; }
Public Property Suffix As String
    Get
    Set
public:
property String^ Suffix {
    String^ get ();
    void set (String^ value);
}
member Suffix : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

DimensionEqualityLabelFormatting Class


DimensionEqualityLabelFormatting Methods

The DimensionEqualityLabelFormatting type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetFormatOptions | Gets the format options used to show the parameter value.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsValidFormatOptions | Checks whether a FormatOptions object is valid for the LabelType.
Public method | SetFormatOptions | Sets the format options used to show the parameter value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DimensionEqualityLabelFormatting Class


DimensionEqualityLabelFormatting.Dispose Method

DimensionEqualityLabelFormattingDispose Method

Releases all resources used by the DimensionEqualityLabelFormatting

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

DimensionEqualityLabelFormatting Class


DimensionEqualityLabelFormatting.GetFormatOptions Method

DimensionEqualityLabelFormattingGetFormatOptions Method

Gets the format options used to show the parameter value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormatOptions GetFormatOptions()
Public Function GetFormatOptions As FormatOptions
public:
FormatOptions^ GetFormatOptions()
member GetFormatOptions : unit -> FormatOptions

Return Value

FormatOptions
A copy of the format options.
See Also

Reference

DimensionEqualityLabelFormatting Class


DimensionEqualityLabelFormatting.IsValidFormatOptions Method

DimensionEqualityLabelFormattingIsValidFormatOptions Method

Checks whether a FormatOptions object is valid for the LabelType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidFormatOptions()
Public Function IsValidFormatOptions As Boolean
public:
bool IsValidFormatOptions()
member IsValidFormatOptions : unit -> bool

Return Value

Boolean
True if the FormatOptions object is valid, false otherwise.
Remarks
Only objects whose LabelType is LengthOfSegment or TotalLength can have FormatOptions assigned.
See Also

Reference

DimensionEqualityLabelFormatting Class


DimensionEqualityLabelFormatting.SetFormatOptions Method

DimensionEqualityLabelFormattingSetFormatOptions Method

Sets the format options used to show the parameter value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetFormatOptions(
    FormatOptions formatOptions
)
Public Sub SetFormatOptions (
    formatOptions As FormatOptions
)
public:
void SetFormatOptions(
    FormatOptions^ formatOptions
)
member SetFormatOptions :
        formatOptions : FormatOptions -> unit

Parameters

formatOptions FormatOptions
The format options to be set.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This DimensionEqualityLabelFormatting uses a LabelType which does not support assignment of FormatOptions.
See Also

Reference

DimensionEqualityLabelFormatting Class


DimensionSegment Class

A segment of a dimension within the Autodesk Revit project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBDimensionSegment

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DimensionSegment : APIObject
Public Class DimensionSegment
    Inherits APIObject
public ref class DimensionSegment : public APIObject
type DimensionSegment =
    class
        inherit APIObject
    end

The DimensionSegment type exposes the following members.

Properties
 | Name | Description
Public property | Above | The text shown above the segment's value.
Public property | Below | The text shown below the segment's value.
Public property | IsLocked | Indicates if this segment is locked.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | LeaderEndPosition | The position of the dimension leader end point.
Public property | Origin | The segment origin.
Public property | Prefix | The text shown before the segment's value.
Public property | Suffix | The text shown after the segment's value.
 | TextPosition | The position of the dimension text's drag point.
Public property | Value | The length of the segment.
Public property | ValueOverride | The text that replaces the segment's value.
Public property | ValueString | The displayed value shown for the dimension segment.
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsTextPositionAdjustable | Indicates if this dimension is supported to set/get TextPosition/LeaderPosition.
Public method | ResetTextPosition | Resets the text position of the segment to the initial position determined by its type and parameters.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DimensionSegment Properties

The DimensionSegment type exposes the following members.

Properties
 | Name | Description
Public property | Above | The text shown above the segment's value.
Public property | Below | The text shown below the segment's value.
Public property | IsLocked | Indicates if this segment is locked.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | LeaderEndPosition | The position of the dimension leader end point.
Public property | Origin | The segment origin.
Public property | Prefix | The text shown before the segment's value.
Public property | Suffix | The text shown after the segment's value.
 | TextPosition | The position of the dimension text's drag point.
Public property | Value | The length of the segment.
Public property | ValueOverride | The text that replaces the segment's value.
Public property | ValueString | The displayed value shown for the dimension segment.
Top
See Also

Reference

DimensionSegment Class


DimensionSegment.Above Property

DimensionSegmentAbove Property

The text shown above the segment's value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Above { get; set; }
Public Property Above As String
    Get
    Set
public:
property String^ Above {
    String^ get ();
    void set (String^ value);
}
member Above : string with get, set

Property Value

String
See Also

Reference

DimensionSegment Class


DimensionSegment.Below Property

DimensionSegmentBelow Property

The text shown below the segment's value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Below { get; set; }
Public Property Below As String
    Get
    Set
public:
property String^ Below {
    String^ get ();
    void set (String^ value);
}
member Below : string with get, set

Property Value

String
See Also

Reference

DimensionSegment Class


DimensionSegment.IsLocked Property

DimensionSegmentIsLocked Property

Indicates if this segment is locked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsLocked { get; set; }
Public Property IsLocked As Boolean
    Get
    Set
public:
property bool IsLocked {
    bool get ();
    void set (bool value);
}
member IsLocked : bool with get, set

Property Value

Boolean
Remarks
This property always returns false if the dimension is a radial or spot dimension. This property cannot be set if the segment has been labeled, or the dimension shape is a radial or spot dimension.
See Also

Reference

DimensionSegment Class


DimensionSegment.LeaderEndPosition Property

DimensionSegmentLeaderEndPosition Property

The position of the dimension leader end point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ LeaderEndPosition { get; set; }
Public Property LeaderEndPosition As XYZ
    Get
    Set
public:
property XYZ^ LeaderEndPosition {
    XYZ^ get ();
    void set (XYZ^ value);
}
member LeaderEndPosition : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
ApplicationException | Thrown when the dimension text is unavailable.
InvalidOperationException Thrown when:
  • The dimension text is a SpotElevation
  • When using equality formula.
  • When dimension style is ordinate.
Remarks

This property is not applicable to all dimensions. For example, it is not available for spot dimensions, dimensions using equality formula, and when dimension style is ordinate.

If the position is not applicable, this property returns NULL and will not allow setting a value.

See Also

Reference

DimensionSegment Class


DimensionSegment.Origin Property

DimensionSegmentOrigin Property

The segment origin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Origin { get; }
Public ReadOnly Property Origin As XYZ
    Get
public:
property XYZ^ Origin {
    XYZ^ get ();
}
member Origin : XYZ with get

Property Value

XYZ
Remarks
The origin will be the midpoint of the line that makes up the segment.
See Also

Reference

DimensionSegment Class


DimensionSegment.Prefix Property

DimensionSegmentPrefix Property

The text shown before the segment's value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Prefix { get; set; }
Public Property Prefix As String
    Get
    Set
public:
property String^ Prefix {
    String^ get ();
    void set (String^ value);
}
member Prefix : string with get, set

Property Value

String
See Also

Reference

DimensionSegment Class


DimensionSegment.Suffix Property

DimensionSegmentSuffix Property

The text shown after the segment's value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Suffix { get; set; }
Public Property Suffix As String
    Get
    Set
public:
property String^ Suffix {
    String^ get ();
    void set (String^ value);
}
member Suffix : string with get, set

Property Value

String
See Also

Reference

DimensionSegment Class


DimensionSegment.TextPosition Property

DimensionSegmentTextPosition Property

The position of the dimension text's drag point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ TextPosition { get; set; }
Public Property TextPosition As XYZ
    Get
    Set
public:
property XYZ^ TextPosition {
    XYZ^ get ();
    void set (XYZ^ value);
}
member TextPosition : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
ApplicationException | Thrown when the dimension text is unavailable.
InvalidOperationException Thrown when:
  • The dimension text is a SpotElevation
  • When using equality formula.
  • When dimension style is ordinate.
.
Remarks

This property is not applicable to all dimensions. For example, it is not available for spot dimensions, dimensions using equality formula, and when dimension style is ordinate.

If the position is not applicable, this property returns NULL and will not allow setting a value.

Example
C#
Copy
      // Get the current text XYZ position
XYZ currentTextPosition = currentSegment.TextPosition;
// Calculate a new XYZ position by transforming the current text position
XYZ newTextPosition = Transform.CreateTranslation(new XYZ(0, 1, 0)).OfPoint(currentTextPosition);
// Set the new text position for the segment's text
currentSegment.TextPosition = newTextPosition;
See Also

Reference

DimensionSegment Class


DimensionSegment.Value Property

DimensionSegmentValue Property

The length of the segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double? Value { get; }
Public ReadOnly Property Value As Double?
    Get
public:
property Nullable<double> Value {
    Nullable<double> get ();
}
member Value : Nullable<float> with get

Property Value

Nullable Double
See Also

Reference

DimensionSegment Class


DimensionSegment.ValueOverride Property

DimensionSegmentValueOverride Property

The text that replaces the segment's value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ValueOverride { get; set; }
Public Property ValueOverride As String
    Get
    Set
public:
property String^ ValueOverride {
    String^ get ();
    void set (String^ value);
}
member ValueOverride : string with get, set

Property Value

String
See Also

Reference

DimensionSegment Class


DimensionSegment.ValueString Property

DimensionSegmentValueString Property

The displayed value shown for the dimension segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ValueString { get; }
Public ReadOnly Property ValueString As String
    Get
public:
property String^ ValueString {
    String^ get ();
}
member ValueString : string with get

Property Value

String
See Also

Reference

DimensionSegment Class


DimensionSegment Methods

The DimensionSegment type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsTextPositionAdjustable | Indicates if this dimension is supported to set/get TextPosition/LeaderPosition.
Public method | ResetTextPosition | Resets the text position of the segment to the initial position determined by its type and parameters.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DimensionSegment Class


DimensionSegment.IsTextPositionAdjustable Method

DimensionSegmentIsTextPositionAdjustable Method

Indicates if this dimension is supported to set/get TextPosition/LeaderPosition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsTextPositionAdjustable()
Public Function IsTextPositionAdjustable As Boolean
public:
bool IsTextPositionAdjustable()
member IsTextPositionAdjustable : unit -> bool

Return Value

Boolean
True if this dimension is supported to set/get TextPosition/LeaderPosition, false otherwise.
See Also

Reference

DimensionSegment Class


DimensionSegment.ResetTextPosition Method

DimensionSegmentResetTextPosition Method

Resets the text position of the segment to the initial position determined by its type and parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetTextPosition()
Public Sub ResetTextPosition
public:
void ResetTextPosition()
member ResetTextPosition : unit -> unit
Remarks
The initial point is the text location when dimension is created.
See Also

Reference

DimensionSegment Class


DimensionSegmentArray Class

An array that can contain any number of DimensionSegment objects.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBDimensionSegmentArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DimensionSegmentArray : APIObject,
    IEnumerable
Public Class DimensionSegmentArray
    Inherits APIObject
    Implements IEnumerable
public ref class DimensionSegmentArray : public APIObject,
    IEnumerable
type DimensionSegmentArray =
    class
        inherit APIObject
        interface IEnumerable
    end

The DimensionSegmentArray type exposes the following members.

Constructors
 | Name | Description
Public method | DimensionSegmentArray | Initializes a new instance of the DimensionSegmentArray class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.
Top
Methods
 | Name | Description
Public method | Append | Add the item to the end of the array.
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified item into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DimensionSegmentArray Constructor

Initializes a new instance of the DimensionSegmentArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DimensionSegmentArray()
Public Sub New
public:
DimensionSegmentArray()
new : unit -> DimensionSegmentArray
See Also

Reference

DimensionSegmentArray Class


DimensionSegmentArray Properties

The DimensionSegmentArray type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.
Top
See Also

Reference

DimensionSegmentArray Class


DimensionSegmentArray.IsEmpty Property

DimensionSegmentArrayIsEmpty Property

Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Boolean
Remarks
If the array is empty then True will be returned, otherwise False.
See Also

Reference

DimensionSegmentArray Class


DimensionSegmentArray.Item Property

DimensionSegmentArrayItem Property

Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual DimensionSegment this[
    int index
] { get; set; }
Public Overridable Property Item (
    index As Integer
) As DimensionSegment
    Get
    Set
public:
virtual property DimensionSegment^ Item[int index] {
    DimensionSegment^ get (int index);
    void set (int index, DimensionSegment^ value);
}
abstract Item : DimensionSegment with get, set
override Item : DimensionSegment with get, set

Parameters

index Int32
The index of the item to be set or retrieved.

Return Value

DimensionSegment
Returns the object at the specified index.
See Also

Reference

DimensionSegmentArray Class


DimensionSegmentArray.Size Property

DimensionSegmentArraySize Property

Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
abstract Size : int with get
override Size : int with get

Property Value

Int32
See Also

Reference

DimensionSegmentArray Class


DimensionSegmentArray Methods

The DimensionSegmentArray type exposes the following members.

Methods
 | Name | Description
Public method | Append | Add the item to the end of the array.
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified item into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DimensionSegmentArray Class


DimensionSegmentArray.Append Method

DimensionSegmentArrayAppend Method

Add the item to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Append(
    DimensionSegment item
)
Public Overridable Sub Append (
    item As DimensionSegment
)
public:
virtual void Append(
    DimensionSegment^ item
)
abstract Append :
        item : DimensionSegment -> unit
override Append :
        item : DimensionSegment -> unit

Parameters

item DimensionSegment
The item to be added.
See Also

Reference

DimensionSegmentArray Class


DimensionSegmentArray.Clear Method

DimensionSegmentArrayClear Method

Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

DimensionSegmentArray Class


DimensionSegmentArray.ForwardIterator Method

DimensionSegmentArrayForwardIterator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual DimensionSegmentArrayIterator ForwardIterator()
Public Overridable Function ForwardIterator As DimensionSegmentArrayIterator
public:
virtual DimensionSegmentArrayIterator^ ForwardIterator()
abstract ForwardIterator : unit -> DimensionSegmentArrayIterator
override ForwardIterator : unit -> DimensionSegmentArrayIterator

Return Value

DimensionSegmentArrayIterator
Returns a forward moving iterator to the array.
See Also

Reference

DimensionSegmentArray Class


DimensionSegmentArray.GetEnumerator Method

DimensionSegmentArrayGetEnumerator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

IEnumerator
Returns a forward moving iterator to the array.

Implements

IEnumerableGetEnumerator
See Also

Reference

DimensionSegmentArray Class


DimensionSegmentArray.Insert Method

DimensionSegmentArrayInsert Method

Insert the specified item into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Insert(
    DimensionSegment item,
    int index
)
Public Overridable Sub Insert (
    item As DimensionSegment,
    index As Integer
)
public:
virtual void Insert(
    DimensionSegment^ item,
    int index
)
abstract Insert :
        item : DimensionSegment *
        index : int -> unit
override Insert :
        item : DimensionSegment *
        index : int -> unit

Parameters

item DimensionSegment
The item to be inserted into the array.
index Int32
The item will be inserted before this index.

Return Value

Returns whether the item was inserted into the array.
See Also

Reference

DimensionSegmentArray Class


DimensionSegmentArray.ReverseIterator Method

DimensionSegmentArrayReverseIterator Method

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual DimensionSegmentArrayIterator ReverseIterator()
Public Overridable Function ReverseIterator As DimensionSegmentArrayIterator
public:
virtual DimensionSegmentArrayIterator^ ReverseIterator()
abstract ReverseIterator : unit -> DimensionSegmentArrayIterator
override ReverseIterator : unit -> DimensionSegmentArrayIterator

Return Value

DimensionSegmentArrayIterator
Returns a backward moving iterator to the array.
See Also

Reference

DimensionSegmentArray Class


DimensionSegmentArrayIterator Class

An iterator to an array of DimensionSegment objects..
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBDimensionSegmentArrayIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class DimensionSegmentArrayIterator : APIObject,
    IEnumerator
Public MustInherit Class DimensionSegmentArrayIterator
    Inherits APIObject
    Implements IEnumerator
public ref class DimensionSegmentArrayIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type DimensionSegmentArrayIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The DimensionSegmentArrayIterator type exposes the following members.

Constructors
 | Name | Description
Public method | DimensionSegmentArrayIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DimensionSegmentArrayIterator Constructor

For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DimensionSegmentArrayIterator()
Public Sub New
public:
DimensionSegmentArrayIterator()
new : unit -> DimensionSegmentArrayIterator
Remarks
This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.
See Also

Reference

DimensionSegmentArrayIterator Class


DimensionSegmentArrayIterator Properties

The DimensionSegmentArrayIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

DimensionSegmentArrayIterator Class


DimensionSegmentArrayIterator.Current Property

DimensionSegmentArrayIteratorCurrent Property

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}
abstract Current : Object with get
override Current : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.
See Also

Reference

DimensionSegmentArrayIterator Class


DimensionSegmentArrayIterator Methods

The DimensionSegmentArrayIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DimensionSegmentArrayIterator Class


DimensionSegmentArrayIterator.MoveNext Method

DimensionSegmentArrayIteratorMoveNext Method

Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumeratorMoveNext
Remarks
MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.
See Also

Reference

DimensionSegmentArrayIterator Class


DimensionSegmentArrayIterator.Reset Method

DimensionSegmentArrayIteratorReset Method

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
Remarks
The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.
See Also

Reference

DimensionSegmentArrayIterator Class


DimensionShape Enumeration

An enumerated type to list dimension type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DimensionShape
Public Enumeration DimensionShape
public enum class DimensionShape
type DimensionShape
Members
Member name | Value | Description
Linear | 0 | Linear dimension.
Angular | 1 | Angular dimension.
Radial | 2 | Radial dimension.
ArcLength | 3 | ArcLength dimension.
Spot | 4 | Spot dimension.
Diameter | 5 | Diameter dimension.
Unknown | 6 | Unknown type dimension.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DimensionStyleType Enumeration

An enumerated type containing possible style types of dimensions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DimensionStyleType
Public Enumeration DimensionStyleType
public enum class DimensionStyleType
type DimensionStyleType
Members
Member name | Value | Description
Linear | 0 | Linear dimension.
Angular | 1 | Angular dimension.
Radial | 2 | Radial dimension.
ArcLength | 3 | ArcLength dimension.
SpotElevation | 4 | SpotElevation
SpotCoordinate | 5 | SpotCoordinate
LinearFixed | 7 | LinearFixed dimension, which is linear dimension whose direction is parallel to X or Y.
SpotSlope | 8 | SpotSlope
Diameter | 9 | Diameter dimension.
AlignmentStationLabel | 10 | Alignment Station Label
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DimensionType Class

An object that represents a dimension style.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBDimensionType
Autodesk.Revit.DBSpotDimensionType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DimensionType : ElementType
Public Class DimensionType
    Inherits ElementType
public ref class DimensionType : public ElementType
type DimensionType =
    class
        inherit ElementType
    end

The DimensionType type exposes the following members.

Properties
 | Name | Description
Public property | AlternateUnits | The alternate units display mode for this DimensionType.
Public property | AlternateUnitsPrefix | The prefix text for the alternate units value.
Public property | AlternateUnitsSuffix | The suffix text for the alternate units value.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Prefix | The prefix text for the dimension value.
Public property | StyleType | The dimension style type of this DimensionType.
Public property | Suffix | The suffix text for the dimension value.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveEqualityFormula | Checks whether this DimensionType can have an equality formula.
Public method | CanHaveOrdinateDimensionSetting | Checks whether this DimensionType can have an ordinate dimension settings.
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAlternateUnitsFormatOptions | Gets the FormatOptions to optionally override the default settings in the Units class for the alternate units value.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetEqualityFormula | Gets an ordered list of the entries in the equality formula definition.
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetOrdinateDimensionSetting | Gets the ordinate dimension settings for this DimensionType.
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSpecTypeId | Gets the spec of this dimension style.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetUnitsFormatOptions | Gets the FormatOptions to optionally override the default settings in the Units class for the units value.
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetAlternateUnitsFormatOptions | Sets the FormatOptions to optionally override the default settings in the Units class for the alternate units value.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetEqualityFormula | Sets an ordered list of the entries to use in the equality formula definition.
Public method | SetOrdinateDimensionSetting | Sets the ordinate dimension settings for this DimensionType.
Public method | SetUnitsFormatOptions | Sets the FormatOptions to optionally override the default settings in the Units class for the units value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DimensionType Properties

The DimensionType type exposes the following members.

Properties
 | Name | Description
Public property | AlternateUnits | The alternate units display mode for this DimensionType.
Public property | AlternateUnitsPrefix | The prefix text for the alternate units value.
Public property | AlternateUnitsSuffix | The suffix text for the alternate units value.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Prefix | The prefix text for the dimension value.
Public property | StyleType | The dimension style type of this DimensionType.
Public property | Suffix | The suffix text for the dimension value.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

DimensionType Class


DimensionType.AlternateUnits Property

DimensionTypeAlternateUnits Property

The alternate units display mode for this DimensionType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AlternateUnits AlternateUnits { get; set; }
Public Property AlternateUnits As AlternateUnits
    Get
    Set
public:
property AlternateUnits AlternateUnits {
    AlternateUnits get ();
    void set (AlternateUnits value);
}
member AlternateUnits : AlternateUnits with get, set

Property Value

AlternateUnits
Alternate units let dimensions display values in multiple units. For example, for a dimension which shows its values in imperial units, alternate units can be used to repeat those values in metric units.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

DimensionType Class


DimensionType.AlternateUnitsPrefix Property

DimensionTypeAlternateUnitsPrefix Property

The prefix text for the alternate units value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string AlternateUnitsPrefix { get; set; }
Public Property AlternateUnitsPrefix As String
    Get
    Set
public:
property String^ AlternateUnitsPrefix {
    String^ get ();
    void set (String^ value);
}
member AlternateUnitsPrefix : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

DimensionType Class


DimensionType.AlternateUnitsSuffix Property

DimensionTypeAlternateUnitsSuffix Property

The suffix text for the alternate units value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string AlternateUnitsSuffix { get; set; }
Public Property AlternateUnitsSuffix As String
    Get
    Set
public:
property String^ AlternateUnitsSuffix {
    String^ get ();
    void set (String^ value);
}
member AlternateUnitsSuffix : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

DimensionType Class


DimensionType.Prefix Property

DimensionTypePrefix Property

The prefix text for the dimension value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Prefix { get; set; }
Public Property Prefix As String
    Get
    Set
public:
property String^ Prefix {
    String^ get ();
    void set (String^ value);
}
member Prefix : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
The text goes immediately before the value and is not overridden by the possible instance prefix.
See Also

Reference

DimensionType Class


DimensionType.StyleType Property

DimensionTypeStyleType Property

The dimension style type of this DimensionType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DimensionStyleType StyleType { get; }
Public ReadOnly Property StyleType As DimensionStyleType
    Get
public:
property DimensionStyleType StyleType {
    DimensionStyleType get ();
}
member StyleType : DimensionStyleType with get

Property Value

DimensionStyleType
See Also

Reference

DimensionType Class


DimensionType.Suffix Property

DimensionTypeSuffix Property

The suffix text for the dimension value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Suffix { get; set; }
Public Property Suffix As String
    Get
    Set
public:
property String^ Suffix {
    String^ get ();
    void set (String^ value);
}
member Suffix : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
The text goes immediately after the value and is not overridden by the possible instance suffix.
See Also

Reference

DimensionType Class


DimensionType Methods

The DimensionType type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveEqualityFormula | Checks whether this DimensionType can have an equality formula.
Public method | CanHaveOrdinateDimensionSetting | Checks whether this DimensionType can have an ordinate dimension settings.
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAlternateUnitsFormatOptions | Gets the FormatOptions to optionally override the default settings in the Units class for the alternate units value.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetEqualityFormula | Gets an ordered list of the entries in the equality formula definition.
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetOrdinateDimensionSetting | Gets the ordinate dimension settings for this DimensionType.
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSpecTypeId | Gets the spec of this dimension style.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetUnitsFormatOptions | Gets the FormatOptions to optionally override the default settings in the Units class for the units value.
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetAlternateUnitsFormatOptions | Sets the FormatOptions to optionally override the default settings in the Units class for the alternate units value.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetEqualityFormula | Sets an ordered list of the entries to use in the equality formula definition.
Public method | SetOrdinateDimensionSetting | Sets the ordinate dimension settings for this DimensionType.
Public method | SetUnitsFormatOptions | Sets the FormatOptions to optionally override the default settings in the Units class for the units value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DimensionType Class


DimensionType.CanHaveEqualityFormula Method

DimensionTypeCanHaveEqualityFormula Method

Checks whether this DimensionType can have an equality formula.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanHaveEqualityFormula()
Public Function CanHaveEqualityFormula As Boolean
public:
bool CanHaveEqualityFormula()
member CanHaveEqualityFormula : unit -> bool

Return Value

Boolean
True when the DimensionType is continuous linear or angular, false otherwise
Remarks
Equality formulas can be used for continuous linear or angular dimension types.
See Also

Reference

DimensionType Class


DimensionType.CanHaveOrdinateDimensionSetting Method

DimensionTypeCanHaveOrdinateDimensionSetting Method

Checks whether this DimensionType can have an ordinate dimension settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanHaveOrdinateDimensionSetting()
Public Function CanHaveOrdinateDimensionSetting As Boolean
public:
bool CanHaveOrdinateDimensionSetting()
member CanHaveOrdinateDimensionSetting : unit -> bool

Return Value

Boolean
True when the DimensionType is linear and the Dimension String Type parameter is ordinate, false otherwise.
Remarks
It returns true when the DimensionType is linear and when Dimension String Type parameter is set to Ordinate.
See Also

Reference

DimensionType Class


DimensionType.GetAlternateUnitsFormatOptions Method

DimensionTypeGetAlternateUnitsFormatOptions Method

Gets the FormatOptions to optionally override the default settings in the Units class for the alternate units value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormatOptions GetAlternateUnitsFormatOptions()
Public Function GetAlternateUnitsFormatOptions As FormatOptions
public:
FormatOptions^ GetAlternateUnitsFormatOptions()
member GetAlternateUnitsFormatOptions : unit -> FormatOptions

Return Value

FormatOptions
A copy of the FormatOptions.
See Also

Reference

DimensionType Class


DimensionType.GetEqualityFormula Method

DimensionTypeGetEqualityFormula Method

Gets an ordered list of the entries in the equality formula definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<DimensionEqualityLabelFormatting> GetEqualityFormula()
Public Function GetEqualityFormula As IList(Of DimensionEqualityLabelFormatting)
public:
IList<DimensionEqualityLabelFormatting^>^ GetEqualityFormula()
member GetEqualityFormula : unit -> IList<DimensionEqualityLabelFormatting>

Return Value

IList DimensionEqualityLabelFormatting
An ordered list of the entries in the equality formula definition.
Exceptions
Exception | Condition
InvalidOperationException | The given DimensionType cannot be assigned an equality formula as it is not continuous linear or angular.
See Also

Reference

DimensionType Class


DimensionType.GetOrdinateDimensionSetting Method

DimensionTypeGetOrdinateDimensionSetting Method

Gets the ordinate dimension settings for this DimensionType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OrdinateDimensionSetting GetOrdinateDimensionSetting()
Public Function GetOrdinateDimensionSetting As OrdinateDimensionSetting
public:
OrdinateDimensionSetting^ GetOrdinateDimensionSetting()
member GetOrdinateDimensionSetting : unit -> OrdinateDimensionSetting

Return Value

OrdinateDimensionSetting
The ordinate dimension settings.
See Also

Reference

DimensionType Class


DimensionType.GetSpecTypeId Method

DimensionTypeGetSpecTypeId Method

Gets the spec of this dimension style.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ForgeTypeId GetSpecTypeId()
Public Function GetSpecTypeId As ForgeTypeId
public:
ForgeTypeId^ GetSpecTypeId()
member GetSpecTypeId : unit -> ForgeTypeId

Return Value

ForgeTypeId
Identifier of the spec.
Remarks
The spec will represent either length, angle or slope.
See Also

Reference

DimensionType Class


DimensionType.GetUnitsFormatOptions Method

DimensionTypeGetUnitsFormatOptions Method

Gets the FormatOptions to optionally override the default settings in the Units class for the units value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormatOptions GetUnitsFormatOptions()
Public Function GetUnitsFormatOptions As FormatOptions
public:
FormatOptions^ GetUnitsFormatOptions()
member GetUnitsFormatOptions : unit -> FormatOptions

Return Value

FormatOptions
A copy of the FormatOptions.
See Also

Reference

DimensionType Class


DimensionType.SetAlternateUnitsFormatOptions Method

DimensionTypeSetAlternateUnitsFormatOptions Method

Sets the FormatOptions to optionally override the default settings in the Units class for the alternate units value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetAlternateUnitsFormatOptions(
    FormatOptions formatOptions
)
Public Sub SetAlternateUnitsFormatOptions (
    formatOptions As FormatOptions
)
public:
void SetAlternateUnitsFormatOptions(
    FormatOptions^ formatOptions
)
member SetAlternateUnitsFormatOptions :
        formatOptions : FormatOptions -> unit

Parameters

formatOptions FormatOptions
The FormatOptions.
Exceptions
Exception | Condition
ArgumentException | The display unit in formatOptions is not a valid display unit for the unit type of this DimensionType, or the rounding method in formatOptions is not set to Nearest. See UnitUtils.IsValidDisplayUnit(UnitType, DisplayUnitType), UnitUtils.GetValidDisplayUnits(UnitType) and FormatOptions.RoundingMethod.
ArgumentNullException | A non-optional argument was null
Remarks
See the UnitType property to determine the unit type of this dimension style.
See Also

Reference

DimensionType Class


DimensionType.SetEqualityFormula Method

DimensionTypeSetEqualityFormula Method

Sets an ordered list of the entries to use in the equality formula definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetEqualityFormula(
    IList<DimensionEqualityLabelFormatting> formattingArr
)
Public Sub SetEqualityFormula (
    formattingArr As IList(Of DimensionEqualityLabelFormatting)
)
public:
void SetEqualityFormula(
    IList<DimensionEqualityLabelFormatting^>^ formattingArr
)
member SetEqualityFormula :
        formattingArr : IList<DimensionEqualityLabelFormatting> -> unit

Parameters

formattingArr IList DimensionEqualityLabelFormatting
An ordered list of the entries to use in the equality formula definition.
Exceptions
Exception | Condition
ArgumentException | The input equality formula entries are not valid for use in the given DimensionType.
ArgumentNullException | A non-optional argument was null
See Also

Reference

DimensionType Class


DimensionType.SetOrdinateDimensionSetting Method

DimensionTypeSetOrdinateDimensionSetting Method

Sets the ordinate dimension settings for this DimensionType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetOrdinateDimensionSetting(
    OrdinateDimensionSetting ordinateDimSetting
)
Public Sub SetOrdinateDimensionSetting (
    ordinateDimSetting As OrdinateDimensionSetting
)
public:
void SetOrdinateDimensionSetting(
    OrdinateDimensionSetting^ ordinateDimSetting
)
member SetOrdinateDimensionSetting :
        ordinateDimSetting : OrdinateDimensionSetting -> unit

Parameters

ordinateDimSetting OrdinateDimensionSetting
The new ordinate dimension settings.
Exceptions
Exception | Condition
ArgumentException | The origin tick mark id in the Ordinate Dimension Setting is invalid for the dimension style.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This DimensionType cannot be assigned ordinate dimension settings, as it is not a linear DimensionType or its Dimension String Type parameter is not set to Ordinate.
See Also

Reference

DimensionType Class


DimensionType.SetUnitsFormatOptions Method

DimensionTypeSetUnitsFormatOptions Method

Sets the FormatOptions to optionally override the default settings in the Units class for the units value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetUnitsFormatOptions(
    FormatOptions formatOptions
)
Public Sub SetUnitsFormatOptions (
    formatOptions As FormatOptions
)
public:
void SetUnitsFormatOptions(
    FormatOptions^ formatOptions
)
member SetUnitsFormatOptions :
        formatOptions : FormatOptions -> unit

Parameters

formatOptions FormatOptions
The FormatOptions.
Exceptions
Exception | Condition
ArgumentException | The display unit in formatOptions is not a valid display unit for the unit type of this DimensionType, or the rounding method in formatOptions is not set to Nearest. See UnitUtils.IsValidDisplayUnit(UnitType, DisplayUnitType), UnitUtils.GetValidDisplayUnits(UnitType) and FormatOptions.RoundingMethod.
ArgumentNullException | A non-optional argument was null
Remarks
See the UnitType property to determine the unit type of this dimension style.
See Also

Reference

DimensionType Class


DirectShape Class

This class is used to store externally created geometric shapes. Primary intended use is for importing shapes from other data formats such as IFC or STEP. A DirectShape object may be assigned a category. That will affect how that object is displayed in Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBDirectShape

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DirectShape : Element
Public Class DirectShape
    Inherits Element
public ref class DirectShape : public Element
type DirectShape =
    class
        inherit Element
    end

The DirectShape type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationDataId | A text string that identifies the data to the creating application.
Public property | ApplicationId | A text string that identifies the creating application.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | TypeId | Element id of a DirectShapeType object that holds properties to be shared by this element. Optional.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
Name | Description
Public method | AddExternallyTaggedGeometry | Adds the externally tagged geometry object to the DirectShape.
Public method | AddReferenceCurve(Curve) | Adds a reference curve to the DirectShape.
Public method | AddReferenceCurve(Curve, DirectShapeReferenceOptions) | Adds a reference curve to the DirectShape.
Public method | AddReferencePlane(Plane) | Adds a reference plane to the DirectShape. The reference plane can either be bounded or unbounded.
Public method | AddReferencePlane(Plane, BoundingBoxUV) | Adds a reference plane to the DirectShape. The reference plane can either be bounded or unbounded.
Public method | AddReferencePlane(Plane, DirectShapeReferenceOptions) | Adds a reference plane to the DirectShape. The reference plane can either be bounded or unbounded.
Public method | AddReferencePlane(Plane, BoundingBoxUV, DirectShapeReferenceOptions) | Adds a reference plane to the DirectShape. The reference plane can either be bounded or unbounded.
Public method | AddReferencePoint(XYZ) | Adds a reference point to the DirectShape.
Public method | AddReferencePoint(XYZ, DirectShapeReferenceOptions) | Adds a reference point to the DirectShape.
Public method | AppendShape(IListGeometryObject) | Appends the collection of GeometryObjects into the model shape representation stored in this DirectShape.
Public method | AppendShape(ShapeBuilder) | Appends shape built by the supplied ShapeBuilderObject to shape representation stored in this DirectShape. The data stored in the supplied ShapeBuilder object will be cleared.
Public method | AppendShape(IListGeometryObject, DirectShapeTargetViewType) | Appends the collection of GeometryObjects into the model or view specific shape representation stored in this DirectShape. Passing DirectShapeTargetViewType.Default as view type will cause the model shape to be updated.
Public method | AreOptionsValid | Validates that the given DirectShapeOptions are allowed for this particular DirectShape.
Public method | AreOptionsValidForTransientDirectShape | Validates that the given DirectShapeOptions are allowed if this DirectShape is transient.
Public method ArePhasesModifiable Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element.
(Inherited from Element)
Public method | AreValidDirectShapeReferenceOptions | Validates that the input DirectShapeReferenceOptions are suitable for creating a direct shape reference object. If the options specify an ExternalGeometryId, it must not correspond to any existing reference object belonging to the DirectShape.
Public method CanBeHidden Indicates if the element can be hidden in the view.
(Inherited from Element)
Public method CanBeLocked Identifies if the element can be locked.
(Inherited from Element)
Public method | CanCreateParts | Indicates if it is possible to create parts from this DirectShape element.
Public method CanDeleteSubelement Checks if given subelement can be removed from the element.
(Inherited from Element)
Public method CanHaveTypeAssigned Identifies if the element can have a type assigned.
(Inherited from Element)
Public method ChangeTypeId(ElementId) Changes the type of the element.
(Inherited from Element)
CreateElement | Creates a DirectShape object and adds it to document.
CreateElementInstance | Creates a DirectShape object and adds it to document.
CreateGeometryInstance | Creates a copy of a definition shape that was created earlier.
Public method DeleteEntity Deletes the existing entity created by %schema% in the element
(Inherited from Element)
Public method DeleteSubelement Removes a subelement from the element.
(Inherited from Element)
Public method DeleteSubelements Removes the subelements from the element.
(Inherited from Element)
Public method Dispose
(Inherited from Element)
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object)
Public method EvaluateAllParameterValues Evaluates all the parameters' values of the element.
(Inherited from Element)
Public method EvaluateParameterValues Evaluate the parameters' values of the element on the given parameter ID set.
(Inherited from Element)
Public method GetDependentElements Get all elements that, from a logical point of view, are the children of this Element.
(Inherited from Element)
Public method GetEntity Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise.
(Inherited from Element)
Public method GetEntitySchemaGuids Returns the Schema guids of any Entities stored in this element.
(Inherited from Element)
Public method GetExternalFileReference Gets information pertaining to the external file referenced by the element.
(Inherited from Element)
Public method | GetExternallyTaggedGeometry | Gets the externally tagged geometry by its external ID that is stored in this DirectShape.
Public method | GetExternallyTaggedReference | Retrieve a Reference to reference geometry of the DirectShape that is associated with a particular ExternalGeometryId.
Public method GetExternalResourceReference Gets the ExternalResourceReference associated with a specified external resource type.
(Inherited from Element)
Public method GetExternalResourceReferenceExpanded Gets the collection of ExternalResourceReference associated with a specified external resource type.
(Inherited from Element)
Public method GetExternalResourceReferences Gets the map of the external resource references referenced by the element.
(Inherited from Element)
Public method GetExternalResourceReferencesExpanded Gets the expanded map of the external resource references referenced by the element.
(Inherited from Element)
GetGeneratingElementIds Returns the ids of the element(s) that generated the input geometry object.
(Inherited from Element)
Public method GetGeometryObjectFromReference Retrieve one geometric primitive contained in the element given a reference.
(Inherited from Element)
Public method GetHashCode Serves as the default hash function.
(Inherited from Object)
Public method GetMaterialArea Gets the area of the material with the given id.
(Inherited from Element)
Public method GetMaterialIds Gets the element ids of all materials present in the element.
(Inherited from Element)
Public method GetMaterialVolume Gets the volume of the material with the given id.
(Inherited from Element)
Public method GetMonitoredLinkElementIds Provides the link instance IDs when the element is monitoring.
(Inherited from Element)
Public method GetMonitoredLocalElementIds Provides the local element IDs when the element is monitoring.
(Inherited from Element)
Public method | GetOptions | Gets a copy of the current options for this DirectShape.
Public method GetOrderedParameters Gets the parameters associated to the element in order.
(Inherited from Element)
Public method GetParameter Retrieves a parameter from the element given identifier.
(Inherited from Element)
Public method GetParameterFormatOptions Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists.
(Inherited from Element)
Public method GetParameters Retrieves the parameters from the element via the given name.
(Inherited from Element)
Public method GetPhaseStatus Gets the status of a given element in the input phase
(Inherited from Element)
Public method GetSubelements Returns the collection of element subelements.
(Inherited from Element)
Public method GetType Gets the Type of the current instance.
(Inherited from Object)
GetTypeId Returns the identifier of this element's type.
(Inherited from Element)
Public method GetValidTypes Obtains a set of types that are valid for this element.
(Inherited from Element)
Public method | HasExternalGeometry | Checks whether the externally tagged geometry is already present in this DirectShape.
Public method | HasExternallyTaggedReference | Checks if the externally tagged reference is already present in this DirectShape.
Public method HasPhases Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.
(Inherited from Element)
Public method IsCreatedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element)
Public method IsDemolishedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element)
Public method IsExternalFileReference Determines whether this Element represents an external file.
(Inherited from Element)
Public method IsHidden Identifies if the element has been permanently hidden in the view.
(Inherited from Element)
Public method IsMonitoringLinkElement Indicate whether an element is monitoring any elements in any linked models.
(Inherited from Element)
Public method IsMonitoringLocalElement Indicate whether an element is monitoring other local elements.
(Inherited from Element)
Public method IsPhaseCreatedValid Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element.
(Inherited from Element)
Public method IsPhaseDemolishedValid Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element.
(Inherited from Element)
IsSupportedDocument | Tests whether a DirectShape or a DirectShapeType may be created in this document.
IsValidCategoryId | Test the category id to make sure the category is allowed for a DirectShape or DirectShapeType.
Public method | IsValidGeometry | Validates geometry to be stored in a DirectShape. Suitable geometry validation is performed. Additionally, the geometry must make sense as a shape representation for the category assigned to this DirectShape object.
IsValidReferenceCurve | Validates that the input curve is suitable for creating a direct shape reference curve. Bounded and unbounded lines are accepted. Other bounded and unbounded curve types with natural bounds are accepted if they are not closed. Unbounded periodic curves are not allowed.
IsValidReferencePlaneBoundingBoxUV | Validates that the input BoundingBoxUV is suitable for bounding a reference plane surface. The input BoundingBoxUV must be set and not degenerate.
Public method | IsValidShape(ExternallyTaggedGeometryObject) | Validates shape to be stored in a DirectShape.
Public method | IsValidShape(IListGeometryObject) | Validates shape to be stored in a DirectShape. Supercedes and extends IsValidGeometry().
Public method | IsValidShape(IListGeometryObject, DirectShapeTargetViewType) | Validates view-specific shape to be stored in a DirectShape. Expects a non-default view type.
Public method IsValidType(ElementId) Checks if given type is valid for this element.
(Inherited from Element)
Public method IsValidTypeId Tests the type id to make sure it satisfies the following conditions
  • It is a valid element id.
  • It corresponds to a valid DirectShapeType.
  • The DirectShapeType has the same category assigned.
Additionally, this functions tests that the current type id in this DirectShape is invalid. The type id is initialized to invalidElementId by the create functions. Once it is set, it may no longer be changed.
Public method | IsValidUsage | Validates that the ExternallyTaggedGeometryObject's usage is set to an allowed value for a DirectShape.
Public method LookupParameter Attempts to find a parameter on the element which has the given name.
(Inherited from Element)
Public method RefersToExternalResourceReference Determines whether this Element uses external resources associated with a specified external resource type.
(Inherited from Element)
Public method RefersToExternalResourceReferences Determines whether this Element uses external resources.
(Inherited from Element)
Public method | RemoveAllReferenceObjects | Removes all reference objects (if any) from the DirectShape.
Public method | RemoveExternallyTaggedGeometry | Removes the externally tagged geometry object by its external ID from this DirectShape.
Public method | RemoveReferenceObject(ExternalGeometryId) | Removes any reference object associated with the provided ExternalGeometryId from the DirectShape. Nothing is done if no reference object has the given external ID or if the external ID is an empty string.
Public method | RemoveReferenceObject(String) | Removes any reference objects with the given name from the DirectShape. Nothing is done if no reference objects have the given name or if the name is the empty string.
Public method | ResetExternallyTaggedGeometry | Removes all of the externally tagged geometry in this DirectShape.
Public method SetEntity Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten.
(Inherited from Element)
Public method | SetName | Sets the name for the DirectShape element.
Public method | SetOptions | Sets the options to use for this DirectShape.
Public method | SetShape(IListGeometryObject) | Builds the shape of this object from the supplied collection of GeometryObjects. The objects are copied. If the new shape is identical to the old one, the old shape will be kept.
Public method | SetShape(ShapeBuilder) | Sets the shape of this object to the one accumulated in the supplied Builder object. If the new shape is identical to the old one, the old shape will be kept.
Public method | SetShape(IListGeometryObject, DirectShapeTargetViewType) | Builds the shape of this object from the supplied collection of GeometryObjects. The objects are copied. If the new shape is identical to the old one, the old shape will be kept.
Public method | SetTypeId | Sets the DirectShapeType for the DirectShape element.
Public method ToString Returns a string that represents the current object.
(Inherited from Object)
Public method | UpdateExternallyTaggedGeometry | Updates the externally tagged geometry object in the DirectShape.
Top
Remarks
DirectShape is not a replacement for "real" Wall, Roof, Window, etc. It would typically be used where there is not enough information to create, e.g., a Wall, or full functionality of a Wall object is not needed. Some category-specific functionality may be available. If you need to modify a shape held by a DirectShape object, use Revit Geometry API, and then store the modified shape back to the DirectShape object.
Example
C#
VB
C++
F#
Copy
// Create a DirectShape Sphere
public void CreateSphereDirectShape(Document doc)
{
    List<Curve> profile = new List<Curve>();

    // first create sphere with 2' radius
    XYZ center = XYZ.Zero;
    double radius = 2.0;
    XYZ profile00 = center;
    XYZ profilePlus = center + new XYZ(0, radius, 0);
    XYZ profileMinus = center - new XYZ(0, radius, 0);

    profile.Add(Line.CreateBound(profilePlus, profileMinus));
    profile.Add(Arc.Create(profileMinus, profilePlus, center + new XYZ(radius, 0, 0)));

    CurveLoop curveLoop = CurveLoop.Create(profile);
    SolidOptions options = new SolidOptions(ElementId.InvalidElementId, ElementId.InvalidElementId);

    Frame frame = new Frame(center, XYZ.BasisX, -XYZ.BasisZ, XYZ.BasisY);
    if (Frame.CanDefineRevitGeometry(frame) == true)
    {
        Solid sphere = GeometryCreationUtilities.CreateRevolvedGeometry(frame, new CurveLoop[] { curveLoop }, 0, 2 * Math.PI, options);
        using (Transaction t = new Transaction(doc, "Create sphere direct shape"))
        {
            t.Start();
            // create direct shape and assign the sphere shape
            DirectShape ds = DirectShape.CreateElement(doc, new ElementId(BuiltInCategory.OST_GenericModel));

            ds.ApplicationId = "Application id";
            ds.ApplicationDataId = "Geometry object id";
            ds.SetShape(new GeometryObject[] { sphere });
            t.Commit();
        }
    }
}
' Create a DirectShape Sphere
Public Sub CreateSphereDirectShape(doc As Document)
    Dim profile As New List(Of Curve)()

    ' first create sphere with 2' radius
    Dim center As XYZ = XYZ.Zero
    Dim radius As Double = 2.0
    Dim profile00 As XYZ = center
    Dim profilePlus As XYZ = center + New XYZ(0, radius, 0)
    Dim profileMinus As XYZ = center - New XYZ(0, radius, 0)

    profile.Add(Line.CreateBound(profilePlus, profileMinus))
    profile.Add(Arc.Create(profileMinus, profilePlus, center + New XYZ(radius, 0, 0)))

    Dim curveLoop__1 As CurveLoop = CurveLoop.Create(profile)
    Dim options As New SolidOptions(ElementId.InvalidElementId, ElementId.InvalidElementId)

    Dim frame__2 As New Frame(center, XYZ.BasisX, -XYZ.BasisZ, XYZ.BasisY)
    If Frame.CanDefineRevitGeometry(frame__2) = True Then
        Dim sphere As Solid = GeometryCreationUtilities.CreateRevolvedGeometry(frame__2, New CurveLoop() {curveLoop__1}, 0, 2 * Math.PI, options)
        Using t As New Transaction(doc, "Create sphere direct shape")
            t.Start()
            ' create direct shape and assign the sphere shape
            Dim ds As DirectShape = DirectShape.CreateElement(doc, New ElementId(BuiltInCategory.OST_GenericModel))

            ds.ApplicationId = "Application id"
            ds.ApplicationDataId = "Geometry object id"
            ds.SetShape(New GeometryObject() {sphere})
            t.Commit()
        End Using
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DirectShape Properties

The DirectShape type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationDataId | A text string that identifies the data to the creating application.
Public property | ApplicationId | A text string that identifies the creating application.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | TypeId | Element id of a DirectShapeType object that holds properties to be shared by this element. Optional.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

DirectShape Class


DirectShape.ApplicationDataId Property

DirectShapeApplicationDataId Property

A text string that identifies the data to the creating application.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ApplicationDataId { get; set; }
Public Property ApplicationDataId As String
    Get
    Set
public:
property String^ ApplicationDataId {
    String^ get ();
    void set (String^ value);
}
member ApplicationDataId : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
The intended use is to enable the creating application to identify the native data that was the source of this DirectShape. However, the creating application may use any text string as appropriate for its purposes, or leave this property unset.
See Also

Reference

DirectShape Class


DirectShape.ApplicationId Property

DirectShapeApplicationId Property

A text string that identifies the creating application.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ApplicationId { get; set; }
Public Property ApplicationId As String
    Get
    Set
public:
property String^ ApplicationId {
    String^ get ();
    void set (String^ value);
}
member ApplicationId : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
The creating application may use any text string as appropriate for its purposes, or leave this property unset. One option is to use Application.ActiveAddInId for a unique application id, or concatenate it with an application name for a more informative, but still unique id.
See Also

Reference

DirectShape Class


DirectShape.TypeId Property

DirectShapeTypeId Property

Element id of a DirectShapeType object that holds properties to be shared by this element. Optional.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId TypeId { get; }
Public ReadOnly Property TypeId As ElementId
    Get
public:
property ElementId^ TypeId {
    ElementId^ get ();
}
member TypeId : ElementId with get

Property Value

ElementId
See Also

Reference

DirectShape Class


DirectShape Methods

The DirectShape type exposes the following members.

Methods
Name | Description
Public method | AddExternallyTaggedGeometry | Adds the externally tagged geometry object to the DirectShape.
Public method | AddReferenceCurve(Curve) | Adds a reference curve to the DirectShape.
Public method | AddReferenceCurve(Curve, DirectShapeReferenceOptions) | Adds a reference curve to the DirectShape.
Public method | AddReferencePlane(Plane) | Adds a reference plane to the DirectShape. The reference plane can either be bounded or unbounded.
Public method | AddReferencePlane(Plane, BoundingBoxUV) | Adds a reference plane to the DirectShape. The reference plane can either be bounded or unbounded.
Public method | AddReferencePlane(Plane, DirectShapeReferenceOptions) | Adds a reference plane to the DirectShape. The reference plane can either be bounded or unbounded.
Public method | AddReferencePlane(Plane, BoundingBoxUV, DirectShapeReferenceOptions) | Adds a reference plane to the DirectShape. The reference plane can either be bounded or unbounded.
Public method | AddReferencePoint(XYZ) | Adds a reference point to the DirectShape.
Public method | AddReferencePoint(XYZ, DirectShapeReferenceOptions) | Adds a reference point to the DirectShape.
Public method | AppendShape(IListGeometryObject) | Appends the collection of GeometryObjects into the model shape representation stored in this DirectShape.
Public method | AppendShape(ShapeBuilder) | Appends shape built by the supplied ShapeBuilderObject to shape representation stored in this DirectShape. The data stored in the supplied ShapeBuilder object will be cleared.
Public method | AppendShape(IListGeometryObject, DirectShapeTargetViewType) | Appends the collection of GeometryObjects into the model or view specific shape representation stored in this DirectShape. Passing DirectShapeTargetViewType.Default as view type will cause the model shape to be updated.
Public method | AreOptionsValid | Validates that the given DirectShapeOptions are allowed for this particular DirectShape.
Public method | AreOptionsValidForTransientDirectShape | Validates that the given DirectShapeOptions are allowed if this DirectShape is transient.
Public method ArePhasesModifiable Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element.
(Inherited from Element)
Public method | AreValidDirectShapeReferenceOptions | Validates that the input DirectShapeReferenceOptions are suitable for creating a direct shape reference object. If the options specify an ExternalGeometryId, it must not correspond to any existing reference object belonging to the DirectShape.
Public method CanBeHidden Indicates if the element can be hidden in the view.
(Inherited from Element)
Public method CanBeLocked Identifies if the element can be locked.
(Inherited from Element)
Public method | CanCreateParts | Indicates if it is possible to create parts from this DirectShape element.
Public method CanDeleteSubelement Checks if given subelement can be removed from the element.
(Inherited from Element)
Public method CanHaveTypeAssigned Identifies if the element can have a type assigned.
(Inherited from Element)
Public method ChangeTypeId(ElementId) Changes the type of the element.
(Inherited from Element)
CreateElement | Creates a DirectShape object and adds it to document.
CreateElementInstance | Creates a DirectShape object and adds it to document.
CreateGeometryInstance | Creates a copy of a definition shape that was created earlier.
Public method DeleteEntity Deletes the existing entity created by %schema% in the element
(Inherited from Element)
Public method DeleteSubelement Removes a subelement from the element.
(Inherited from Element)
Public method DeleteSubelements Removes the subelements from the element.
(Inherited from Element)
Public method Dispose
(Inherited from Element)
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object)
Public method EvaluateAllParameterValues Evaluates all the parameters' values of the element.
(Inherited from Element)
Public method EvaluateParameterValues Evaluate the parameters' values of the element on the given parameter ID set.
(Inherited from Element)
Public method GetDependentElements Get all elements that, from a logical point of view, are the children of this Element.
(Inherited from Element)
Public method GetEntity Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise.
(Inherited from Element)
Public method GetEntitySchemaGuids Returns the Schema guids of any Entities stored in this element.
(Inherited from Element)
Public method GetExternalFileReference Gets information pertaining to the external file referenced by the element.
(Inherited from Element)
Public method | GetExternallyTaggedGeometry | Gets the externally tagged geometry by its external ID that is stored in this DirectShape.
Public method | GetExternallyTaggedReference | Retrieve a Reference to reference geometry of the DirectShape that is associated with a particular ExternalGeometryId.
Public method GetExternalResourceReference Gets the ExternalResourceReference associated with a specified external resource type.
(Inherited from Element)
Public method GetExternalResourceReferenceExpanded Gets the collection of ExternalResourceReference associated with a specified external resource type.
(Inherited from Element)
Public method GetExternalResourceReferences Gets the map of the external resource references referenced by the element.
(Inherited from Element)
Public method GetExternalResourceReferencesExpanded Gets the expanded map of the external resource references referenced by the element.
(Inherited from Element)
GetGeneratingElementIds Returns the ids of the element(s) that generated the input geometry object.
(Inherited from Element)
Public method GetGeometryObjectFromReference Retrieve one geometric primitive contained in the element given a reference.
(Inherited from Element)
Public method GetHashCode Serves as the default hash function.
(Inherited from Object)
Public method GetMaterialArea Gets the area of the material with the given id.
(Inherited from Element)
Public method GetMaterialIds Gets the element ids of all materials present in the element.
(Inherited from Element)
Public method GetMaterialVolume Gets the volume of the material with the given id.
(Inherited from Element)
Public method GetMonitoredLinkElementIds Provides the link instance IDs when the element is monitoring.
(Inherited from Element)
Public method GetMonitoredLocalElementIds Provides the local element IDs when the element is monitoring.
(Inherited from Element)
Public method | GetOptions | Gets a copy of the current options for this DirectShape.
Public method GetOrderedParameters Gets the parameters associated to the element in order.
(Inherited from Element)
Public method GetParameter Retrieves a parameter from the element given identifier.
(Inherited from Element)
Public method GetParameterFormatOptions Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists.
(Inherited from Element)
Public method GetParameters Retrieves the parameters from the element via the given name.
(Inherited from Element)
Public method GetPhaseStatus Gets the status of a given element in the input phase
(Inherited from Element)
Public method GetSubelements Returns the collection of element subelements.
(Inherited from Element)
Public method GetType Gets the Type of the current instance.
(Inherited from Object)
GetTypeId Returns the identifier of this element's type.
(Inherited from Element)
Public method GetValidTypes Obtains a set of types that are valid for this element.
(Inherited from Element)
Public method | HasExternalGeometry | Checks whether the externally tagged geometry is already present in this DirectShape.
Public method | HasExternallyTaggedReference | Checks if the externally tagged reference is already present in this DirectShape.
Public method HasPhases Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.
(Inherited from Element)
Public method IsCreatedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element)
Public method IsDemolishedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element)
Public method IsExternalFileReference Determines whether this Element represents an external file.
(Inherited from Element)
Public method IsHidden Identifies if the element has been permanently hidden in the view.
(Inherited from Element)
Public method IsMonitoringLinkElement Indicate whether an element is monitoring any elements in any linked models.
(Inherited from Element)
Public method IsMonitoringLocalElement Indicate whether an element is monitoring other local elements.
(Inherited from Element)
Public method IsPhaseCreatedValid Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element.
(Inherited from Element)
Public method IsPhaseDemolishedValid Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element.
(Inherited from Element)
IsSupportedDocument | Tests whether a DirectShape or a DirectShapeType may be created in this document.
IsValidCategoryId | Test the category id to make sure the category is allowed for a DirectShape or DirectShapeType.
Public method | IsValidGeometry | Validates geometry to be stored in a DirectShape. Suitable geometry validation is performed. Additionally, the geometry must make sense as a shape representation for the category assigned to this DirectShape object.
IsValidReferenceCurve | Validates that the input curve is suitable for creating a direct shape reference curve. Bounded and unbounded lines are accepted. Other bounded and unbounded curve types with natural bounds are accepted if they are not closed. Unbounded periodic curves are not allowed.
IsValidReferencePlaneBoundingBoxUV | Validates that the input BoundingBoxUV is suitable for bounding a reference plane surface. The input BoundingBoxUV must be set and not degenerate.
Public method | IsValidShape(ExternallyTaggedGeometryObject) | Validates shape to be stored in a DirectShape.
Public method | IsValidShape(IListGeometryObject) | Validates shape to be stored in a DirectShape. Supercedes and extends IsValidGeometry().
Public method | IsValidShape(IListGeometryObject, DirectShapeTargetViewType) | Validates view-specific shape to be stored in a DirectShape. Expects a non-default view type.
Public method IsValidType(ElementId) Checks if given type is valid for this element.
(Inherited from Element)
Public method IsValidTypeId Tests the type id to make sure it satisfies the following conditions
  • It is a valid element id.
  • It corresponds to a valid DirectShapeType.
  • The DirectShapeType has the same category assigned.
Additionally, this functions tests that the current type id in this DirectShape is invalid. The type id is initialized to invalidElementId by the create functions. Once it is set, it may no longer be changed.
Public method | IsValidUsage | Validates that the ExternallyTaggedGeometryObject's usage is set to an allowed value for a DirectShape.
Public method LookupParameter Attempts to find a parameter on the element which has the given name.
(Inherited from Element)
Public method RefersToExternalResourceReference Determines whether this Element uses external resources associated with a specified external resource type.
(Inherited from Element)
Public method RefersToExternalResourceReferences Determines whether this Element uses external resources.
(Inherited from Element)
Public method | RemoveAllReferenceObjects | Removes all reference objects (if any) from the DirectShape.
Public method | RemoveExternallyTaggedGeometry | Removes the externally tagged geometry object by its external ID from this DirectShape.
Public method | RemoveReferenceObject(ExternalGeometryId) | Removes any reference object associated with the provided ExternalGeometryId from the DirectShape. Nothing is done if no reference object has the given external ID or if the external ID is an empty string.
Public method | RemoveReferenceObject(String) | Removes any reference objects with the given name from the DirectShape. Nothing is done if no reference objects have the given name or if the name is the empty string.
Public method | ResetExternallyTaggedGeometry | Removes all of the externally tagged geometry in this DirectShape.
Public method SetEntity Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten.
(Inherited from Element)
Public method | SetName | Sets the name for the DirectShape element.
Public method | SetOptions | Sets the options to use for this DirectShape.
Public method | SetShape(IListGeometryObject) | Builds the shape of this object from the supplied collection of GeometryObjects. The objects are copied. If the new shape is identical to the old one, the old shape will be kept.
Public method | SetShape(ShapeBuilder) | Sets the shape of this object to the one accumulated in the supplied Builder object. If the new shape is identical to the old one, the old shape will be kept.
Public method | SetShape(IListGeometryObject, DirectShapeTargetViewType) | Builds the shape of this object from the supplied collection of GeometryObjects. The objects are copied. If the new shape is identical to the old one, the old shape will be kept.
Public method | SetTypeId | Sets the DirectShapeType for the DirectShape element.
Public method ToString Returns a string that represents the current object.
(Inherited from Object)
Public method | UpdateExternallyTaggedGeometry | Updates the externally tagged geometry object in the DirectShape.
Top
See Also

Reference

DirectShape Class


DirectShape.AddExternallyTaggedGeometry Method

DirectShapeAddExternallyTaggedGeometry Method

Adds the externally tagged geometry object to the DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddExternallyTaggedGeometry(
    ExternallyTaggedGeometryObject externallyTaggedGeometry
)
Public Sub AddExternallyTaggedGeometry (
    externallyTaggedGeometry As ExternallyTaggedGeometryObject
)
public:
void AddExternallyTaggedGeometry(
    ExternallyTaggedGeometryObject^ externallyTaggedGeometry
)
member AddExternallyTaggedGeometry :
        externallyTaggedGeometry : ExternallyTaggedGeometryObject -> unit

Parameters

externallyTaggedGeometry ExternallyTaggedGeometryObject
The externally tagged geometry that should be added to the DirectShape.
Exceptions
Exception | Condition
ArgumentException | The input shape does not satisfy DirectShape validation criteria. -or- The input geometry does not have a permitted usage. -or- The externallyTaggedGeometry has already been added to this DirectShape.
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShape Class


DirectShape.AddReferenceCurve Method

DirectShapeAddReferenceCurve Method

Overload List
 | Name | Description
Public method | AddReferenceCurve(Curve) | Adds a reference curve to the DirectShape.
Public method | AddReferenceCurve(Curve, DirectShapeReferenceOptions) | Adds a reference curve to the DirectShape.
Top
See Also

Reference

DirectShape Class


DirectShape.AddReferenceCurve(Curve) Method

DirectShapeAddReferenceCurve(Curve) Method

Adds a reference curve to the DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddReferenceCurve(
    Curve refCurve
)
Public Sub AddReferenceCurve (
    refCurve As Curve
)
public:
void AddReferenceCurve(
    Curve^ refCurve
)
member AddReferenceCurve :
        refCurve : Curve -> unit

Parameters

refCurve Curve
The geometry of the new reference curve.
Exceptions
Exception | Condition
ArgumentException | refCurve cannot be used for creating a reference curve.
ArgumentNullException | A non-optional argument was null
Remarks

There are two cases to consider:

  1. The input curve's bounds are set. The resulting reference curve that is added to the DirectShape will be displayed with those bounds. Note that the specified bounds must not be degenerate. Permitted curve types are those for which [!:Autodesk::Revit::DB::DirectShape::isValidReferenceCurve] returns true.
  2. The input curve is unbounded. Reasonable bounds are automatically calculated and applied to the input curve. The automatic bounds are based on the host DirectShape's geometry.

Note that only lines and splines may be unbounded. You must specify valid bounds for all other curve types.

See Also

Reference

DirectShape Class
AddReferenceCurve Overload


DirectShape.AddReferenceCurve(Curve, DirectShapeReferenceOptions) Method

DirectShapeAddReferenceCurve(Curve, DirectShapeReferenceOptions) Method

Adds a reference curve to the DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddReferenceCurve(
    Curve refCurve,
    DirectShapeReferenceOptions options
)
Public Sub AddReferenceCurve (
    refCurve As Curve,
    options As DirectShapeReferenceOptions
)
public:
void AddReferenceCurve(
    Curve^ refCurve,
    DirectShapeReferenceOptions^ options
)
member AddReferenceCurve :
        refCurve : Curve *
        options : DirectShapeReferenceOptions -> unit

Parameters

refCurve Curve
The geometry of the new reference curve.
options DirectShapeReferenceOptions
The options that are used to configure the new reference curve.
Exceptions
Exception | Condition
ArgumentException | refCurve cannot be used for creating a reference curve. -or- options cannot be used to add a reference object to this DirectShape.
ArgumentNullException | A non-optional argument was null
Remarks

There are two cases to consider:

  1. The input curve's bounds are set. The resulting reference curve that is added to the DirectShape will be displayed with those bounds. Note that the specified bounds must not be degenerate. Permitted curve types are those for which [!:Autodesk::Revit::DB::DirectShape::isValidReferenceCurve] returns true.
  2. The input curve is unbounded. Reasonable bounds are automatically calculated and applied to the input curve. The automatic bounds are based on the host DirectShape's geometry.

Note that only lines and splines may be unbounded. You must specify valid bounds for all other curve types.

See Also

Reference

DirectShape Class
AddReferenceCurve Overload


DirectShape.AddReferencePlane Method

DirectShapeAddReferencePlane Method

Overload List
 | Name | Description
Public method | AddReferencePlane(Plane) | Adds a reference plane to the DirectShape. The reference plane can either be bounded or unbounded.
Public method | AddReferencePlane(Plane, BoundingBoxUV) | Adds a reference plane to the DirectShape. The reference plane can either be bounded or unbounded.
Public method | AddReferencePlane(Plane, DirectShapeReferenceOptions) | Adds a reference plane to the DirectShape. The reference plane can either be bounded or unbounded.
Public method | AddReferencePlane(Plane, BoundingBoxUV, DirectShapeReferenceOptions) | Adds a reference plane to the DirectShape. The reference plane can either be bounded or unbounded.
Top
See Also

Reference

DirectShape Class


DirectShape.AddReferencePlane(Plane) Method

DirectShapeAddReferencePlane(Plane) Method

Adds a reference plane to the DirectShape. The reference plane can either be bounded or unbounded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddReferencePlane(
    Plane refPlane
)
Public Sub AddReferencePlane (
    refPlane As Plane
)
public:
void AddReferencePlane(
    Plane^ refPlane
)
member AddReferencePlane :
        refPlane : Plane -> unit

Parameters

refPlane Plane
The geometry of the new reference plane.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShape Class
AddReferencePlane Overload


DirectShape.AddReferencePlane(Plane, BoundingBoxUV) Method

DirectShapeAddReferencePlane(Plane, BoundingBoxUV) Method

Adds a reference plane to the DirectShape. The reference plane can either be bounded or unbounded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddReferencePlane(
    Plane refPlane,
    BoundingBoxUV boundingBoxUV
)
Public Sub AddReferencePlane (
    refPlane As Plane,
    boundingBoxUV As BoundingBoxUV
)
public:
void AddReferencePlane(
    Plane^ refPlane,
    BoundingBoxUV^ boundingBoxUV
)
member AddReferencePlane :
        refPlane : Plane *
        boundingBoxUV : BoundingBoxUV -> unit

Parameters

refPlane Plane
The geometry of the new reference plane.
boundingBoxUV BoundingBoxUV
If boundingBoxUV is set, the resulting reference plane that is added to the DirectShape will be displayed with those bounds. Note that the specified bounds must not be degenerate. If boundingBoxUV is not set, reasonable bounds are automatically calculated and applied to the input plane. The automatic bounds are based on the host direct shape's geometry.
Exceptions
Exception | Condition
ArgumentException | boundingBoxUV cannot be used as a BoundingBoxUV for the reference plane surface.
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShape Class
AddReferencePlane Overload


DirectShape.AddReferencePlane(Plane, DirectShapeReferenceOptions) Method

DirectShapeAddReferencePlane(Plane, DirectShapeReferenceOptions) Method

Adds a reference plane to the DirectShape. The reference plane can either be bounded or unbounded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddReferencePlane(
    Plane refPlane,
    DirectShapeReferenceOptions options
)
Public Sub AddReferencePlane (
    refPlane As Plane,
    options As DirectShapeReferenceOptions
)
public:
void AddReferencePlane(
    Plane^ refPlane,
    DirectShapeReferenceOptions^ options
)
member AddReferencePlane :
        refPlane : Plane *
        options : DirectShapeReferenceOptions -> unit

Parameters

refPlane Plane
The geometry of the new reference plane.
options DirectShapeReferenceOptions
The options that are used to configure the new reference plane.
Exceptions
Exception | Condition
ArgumentException | options cannot be used to add a reference object to this DirectShape.
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShape Class
AddReferencePlane Overload


DirectShape.AddReferencePlane(Plane, BoundingBoxUV, DirectShapeReferenceOptions) Method

DirectShapeAddReferencePlane(Plane, BoundingBoxUV, DirectShapeReferenceOptions) Method

Adds a reference plane to the DirectShape. The reference plane can either be bounded or unbounded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddReferencePlane(
    Plane refPlane,
    BoundingBoxUV boundingBoxUV,
    DirectShapeReferenceOptions options
)
Public Sub AddReferencePlane (
    refPlane As Plane,
    boundingBoxUV As BoundingBoxUV,
    options As DirectShapeReferenceOptions
)
public:
void AddReferencePlane(
    Plane^ refPlane,
    BoundingBoxUV^ boundingBoxUV,
    DirectShapeReferenceOptions^ options
)
member AddReferencePlane :
        refPlane : Plane *
        boundingBoxUV : BoundingBoxUV *
        options : DirectShapeReferenceOptions -> unit

Parameters

refPlane Plane
The geometry of the new reference plane.
boundingBoxUV BoundingBoxUV
If boundingBoxUV is set, the resulting reference plane that is added to the DirectShape will be displayed with those bounds. Note that the specified bounds must not be degenerate. If boundingBoxUV is not set, reasonable bounds are automatically calculated and applied to the input plane. The automatic bounds are based on the host direct shape's geometry.
options DirectShapeReferenceOptions
The options that are used to configure the new reference plane.
Exceptions
Exception | Condition
ArgumentException | boundingBoxUV cannot be used as a BoundingBoxUV for the reference plane surface. -or- options cannot be used to add a reference object to this DirectShape.
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShape Class
AddReferencePlane Overload


DirectShape.AddReferencePoint Method

DirectShapeAddReferencePoint Method

Overload List
 | Name | Description
Public method | AddReferencePoint(XYZ) | Adds a reference point to the DirectShape.
Public method | AddReferencePoint(XYZ, DirectShapeReferenceOptions) | Adds a reference point to the DirectShape.
Top
See Also

Reference

DirectShape Class


DirectShape.AddReferencePoint(XYZ) Method

DirectShapeAddReferencePoint(XYZ) Method

Adds a reference point to the DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddReferencePoint(
    XYZ refPoint
)
Public Sub AddReferencePoint (
    refPoint As XYZ
)
public:
void AddReferencePoint(
    XYZ^ refPoint
)
member AddReferencePoint :
        refPoint : XYZ -> unit

Parameters

refPoint XYZ
The coordinates of the new reference point.
Exceptions
Exception | Condition
ArgumentException | The input point lies outside of Revit design limits.
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShape Class
AddReferencePoint Overload


DirectShape.AddReferencePoint(XYZ, DirectShapeReferenceOptions) Method

DirectShapeAddReferencePoint(XYZ, DirectShapeReferenceOptions) Method

Adds a reference point to the DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddReferencePoint(
    XYZ refPoint,
    DirectShapeReferenceOptions options
)
Public Sub AddReferencePoint (
    refPoint As XYZ,
    options As DirectShapeReferenceOptions
)
public:
void AddReferencePoint(
    XYZ^ refPoint,
    DirectShapeReferenceOptions^ options
)
member AddReferencePoint :
        refPoint : XYZ *
        options : DirectShapeReferenceOptions -> unit

Parameters

refPoint XYZ
The coordinates of the new reference point.
options DirectShapeReferenceOptions
The options that are used to configure the new reference point.
Exceptions
Exception | Condition
ArgumentException | The input point lies outside of Revit design limits. -or- options cannot be used to add a reference object to this DirectShape.
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShape Class
AddReferencePoint Overload


DirectShape.AppendShape Method

DirectShapeAppendShape Method

Overload List
 | Name | Description
Public method | AppendShape(IListGeometryObject) | Appends the collection of GeometryObjects into the model shape representation stored in this DirectShape.
Public method | AppendShape(ShapeBuilder) | Appends shape built by the supplied ShapeBuilderObject to shape representation stored in this DirectShape. The data stored in the supplied ShapeBuilder object will be cleared.
Public method | AppendShape(IListGeometryObject, DirectShapeTargetViewType) | Appends the collection of GeometryObjects into the model or view specific shape representation stored in this DirectShape. Passing DirectShapeTargetViewType.Default as view type will cause the model shape to be updated.
Top
See Also

Reference

DirectShape Class


DirectShape.AppendShape(IList<GeometryObject>) Method

DirectShapeAppendShape(IListGeometryObject) Method

Appends the collection of GeometryObjects into the model shape representation stored in this DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AppendShape(
    IList<GeometryObject> pGeomArr
)
Public Sub AppendShape (
    pGeomArr As IList(Of GeometryObject)
)
public:
void AppendShape(
    IList<GeometryObject^>^ pGeomArr
)
member AppendShape :
        pGeomArr : IList<GeometryObject> -> unit

Parameters

pGeomArr IList GeometryObject
Shape expressed as a collection of GeometryObjects. The supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point and Curve.
Exceptions
Exception | Condition
ArgumentException | At least one member of pGeomArr does not satisfy DirectShape validation criteria.
ArgumentNullException | A non-optional argument was null
Remarks
The existing shape will not be cleared by this function, and intersecting or overlapped geometry will not be joined with the appended geometry. It is up to the caller to ensure that the combination of geometry will have the correct appearance in Revit.
See Also

Reference

DirectShape Class
AppendShape Overload


DirectShape.AppendShape(ShapeBuilder) Method

DirectShapeAppendShape(ShapeBuilder) Method

Appends shape built by the supplied ShapeBuilderObject to shape representation stored in this DirectShape. The data stored in the supplied ShapeBuilder object will be cleared.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AppendShape(
    ShapeBuilder ShapeBuilder
)
Public Sub AppendShape (
    ShapeBuilder As ShapeBuilder
)
public:
void AppendShape(
    ShapeBuilder^ ShapeBuilder
)
member AppendShape :
        ShapeBuilder : ShapeBuilder -> unit

Parameters

ShapeBuilder ShapeBuilder
The ShapeBuilder object that was used to build the shape to be appended.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
The existing shape will not be cleared by this function, and intersecting or overlapped geometry will not be joined with the appended geometry. It is up to the caller to ensure that the combination of geometry will have the correct appearance in Revit. This function will bypass extra geometry validation because the built geometry has already been validated by the ShapeBuilder. It is therefore slightly more efficient than the AppendShape() routine that accepts GeometryObjects directly as input.
See Also

Reference

DirectShape Class
AppendShape Overload


DirectShape.AppendShape(IList<GeometryObject>, DirectShapeTargetViewType) Method

DirectShapeAppendShape(IListGeometryObject, DirectShapeTargetViewType) Method

Appends the collection of GeometryObjects into the model or view specific shape representation stored in this DirectShape. Passing DirectShapeTargetViewType.Default as view type will cause the model shape to be updated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AppendShape(
    IList<GeometryObject> pGeomArr,
    DirectShapeTargetViewType viewType
)
Public Sub AppendShape (
    pGeomArr As IList(Of GeometryObject),
    viewType As DirectShapeTargetViewType
)
public:
void AppendShape(
    IList<GeometryObject^>^ pGeomArr,
    DirectShapeTargetViewType viewType
)
member AppendShape :
        pGeomArr : IList<GeometryObject> *
        viewType : DirectShapeTargetViewType -> unit

Parameters

pGeomArr IList GeometryObject
Shape expressed as a collection of GeometryObjects. For viewType = DirectShapeTargetViewType::Default, the supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point and Curve. For viewType = DirectShapeTargetViewType::Plan, the supported types of GeometryObjects are: Point and Curve.
viewType DirectShapeTargetViewType
Passing DirectShapeTargetViewType.Default as view type will cause the default shape to be appended.
Exceptions
Exception | Condition
ArgumentException | At least one member of pGeomArr does not satisfy DirectShape validation criteria.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Remarks
The existing shape will not be cleared by this function, and intersecting or overlapped geometry will not be joined with the appended geometry. It is up to the caller to ensure that the combination of geometry will have the correct appearance in Revit.
See Also

Reference

DirectShape Class
AppendShape Overload


DirectShape.AreOptionsValid Method

DirectShapeAreOptionsValid Method

Validates that the given DirectShapeOptions are allowed for this particular DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AreOptionsValid(
    DirectShapeOptions options
)
Public Function AreOptionsValid (
    options As DirectShapeOptions
) As Boolean
public:
bool AreOptionsValid(
    DirectShapeOptions^ options
)
member AreOptionsValid :
        options : DirectShapeOptions -> bool

Parameters

options DirectShapeOptions
The options object.

Return Value

Boolean
True if the DirectShapeOptions are valid; false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShape Class


DirectShape.AreOptionsValidForTransientDirectShape Method

DirectShapeAreOptionsValidForTransientDirectShape Method

Validates that the given DirectShapeOptions are allowed if this DirectShape is transient.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AreOptionsValidForTransientDirectShape(
    DirectShapeOptions options
)
Public Function AreOptionsValidForTransientDirectShape (
    options As DirectShapeOptions
) As Boolean
public:
bool AreOptionsValidForTransientDirectShape(
    DirectShapeOptions^ options
)
member AreOptionsValidForTransientDirectShape :
        options : DirectShapeOptions -> bool

Parameters

options DirectShapeOptions
The options object.

Return Value

Boolean
True if the DirectShapeOptions are valid; false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShape Class


DirectShape.AreValidDirectShapeReferenceOptions Method

DirectShapeAreValidDirectShapeReferenceOptions Method

Validates that the input DirectShapeReferenceOptions are suitable for creating a direct shape reference object. If the options specify an ExternalGeometryId, it must not correspond to any existing reference object belonging to the DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AreValidDirectShapeReferenceOptions(
    DirectShapeReferenceOptions options
)
Public Function AreValidDirectShapeReferenceOptions (
    options As DirectShapeReferenceOptions
) As Boolean
public:
bool AreValidDirectShapeReferenceOptions(
    DirectShapeReferenceOptions^ options
)
member AreValidDirectShapeReferenceOptions :
        options : DirectShapeReferenceOptions -> bool

Parameters

options DirectShapeReferenceOptions
The options to test.

Return Value

Boolean
True if the options can be used to add a reference object to this DirectShape.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShape Class


DirectShape.CanCreateParts Method

DirectShapeCanCreateParts Method

Indicates if it is possible to create parts from this DirectShape element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanCreateParts()
Public Function CanCreateParts As Boolean
public:
bool CanCreateParts()
member CanCreateParts : unit -> bool

Return Value

Boolean
True if it is possible to create parts from this DirectShape.
Remarks
While it is generally possible to create parts from DirectShape elements, some characteristics make parts creation impossible. This property is re-evaluated every time the element's geometry is modified (via a call to SetShape or AppendShape). Invalid configurations include: DirectShape elements containing a polymesh, or an open geometry, as well as DirectShape elements not containing any solids and DirectShape elements configured as NotReferenceable (via a call to SetOptions). Finally, if a DirectShape element has DirectShapeType instances in its geometry, and one of those DirectShapeTypes has a configuration that is incompatible with parts creation, the DirectShape element will also be incompatible with parts creation.
See Also

Reference

DirectShape Class


DirectShape.CreateElement Method

DirectShapeCreateElement Method

Creates a DirectShape object and adds it to document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static DirectShape CreateElement(
    Document document,
    ElementId categoryId
)
Public Shared Function CreateElement (
    document As Document,
    categoryId As ElementId
) As DirectShape
public:
static DirectShape^ CreateElement(
    Document^ document,
    ElementId^ categoryId
)
static member CreateElement :
        document : Document *
        categoryId : ElementId -> DirectShape

Parameters

document Document
Document to which the created element will be added.
categoryId ElementId
Id of the category assigned to this DirectShape. Must be a valid category id.

Return Value

DirectShape
The created DirectShape object.
Exceptions
Exception | Condition
ArgumentException | Document document may not contain DirectShape or DirectShapeType objects. -or- Element id categoryId may not be used as a DirectShape category.
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShape Class


DirectShape.CreateElementInstance Method

DirectShapeCreateElementInstance Method

Creates a DirectShape object and adds it to document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static DirectShape CreateElementInstance(
    Document document,
    ElementId typeId,
    ElementId categoryId,
    string definitionId,
    Transform trf
)
Public Shared Function CreateElementInstance (
    document As Document,
    typeId As ElementId,
    categoryId As ElementId,
    definitionId As String,
    trf As Transform
) As DirectShape
public:
static DirectShape^ CreateElementInstance(
    Document^ document,
    ElementId^ typeId,
    ElementId^ categoryId,
    String^ definitionId,
    Transform^ trf
)
static member CreateElementInstance :
        document : Document *
        typeId : ElementId *
        categoryId : ElementId *
        definitionId : string *
        trf : Transform -> DirectShape

Parameters

document Document
Document to which the created element will be added.
typeId ElementId
Element id of a DirectShapeType element.
categoryId ElementId
Id of the category assigned to this DirectShape. Must be a valid category id.
definitionId String
Id of the shape definition that was created earlier and stored via DirectShapeLibrary.
trf Transform
Transform to be applied to the definition.

Return Value

DirectShape
The created DirectShape object.
Exceptions
Exception | Condition
ArgumentException | Document document may not contain DirectShape or DirectShapeType objects. -or- Element id categoryId may not be used as a DirectShape category.
ArgumentNullException | A non-optional argument was null
Remarks
This function is included for convenience. It essentially combines CreateGeometryInstance and CreateElement. The shape stored in the element is either a reference or a copy of a definition shape that was created earlier. How the definitions are stored will determine whether an instance or a copy of the shape will be created. The intended use is to support a definition/instance pattern common in CAD formats - DWG blocks, STEP MAPPED_ITEM, IFC IfcMappedItem. Use DirectShapeLibrary class to store definitions prior to using them here.
See Also

Reference

DirectShape Class


DirectShape.CreateGeometryInstance Method

DirectShapeCreateGeometryInstance Method

Creates a copy of a definition shape that was created earlier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<GeometryObject> CreateGeometryInstance(
    Document document,
    string definition_id,
    Transform trf
)
Public Shared Function CreateGeometryInstance (
    document As Document,
    definition_id As String,
    trf As Transform
) As IList(Of GeometryObject)
public:
static IList<GeometryObject^>^ CreateGeometryInstance(
    Document^ document,
    String^ definition_id,
    Transform^ trf
)
static member CreateGeometryInstance :
        document : Document *
        definition_id : string *
        trf : Transform -> IList<GeometryObject>

Parameters

document Document
Document to which the created element will be added
definition_id String
ID of the shape definition that was created earlier and stored via DirectShapeLibrary
trf Transform
Transform to be applied to the definition

Return Value

IList GeometryObject
A collection of GeometryObjects representing a placed instance of the pre-defined shape The caller function takes ownership
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Use DirectShapeLibrary class to store definitions prior to using them here. How the definitions are stored will determine whether an instance or a copy of the shape will be created. Use the output of this function as input to CreateElement to make the created shape persistent. This is intended to support a definition/instance pattern common in CAD formats - DWG blocks, STEP MAPPED_ITEM, IFC IfcMappedItem.
See Also

Reference

DirectShape Class


DirectShape.GetExternallyTaggedGeometry Method

DirectShapeGetExternallyTaggedGeometry Method

Gets the externally tagged geometry by its external ID that is stored in this DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExternallyTaggedGeometryObject GetExternallyTaggedGeometry(
    ExternalGeometryId externalId
)
Public Function GetExternallyTaggedGeometry (
    externalId As ExternalGeometryId
) As ExternallyTaggedGeometryObject
public:
ExternallyTaggedGeometryObject^ GetExternallyTaggedGeometry(
    ExternalGeometryId^ externalId
)
member GetExternallyTaggedGeometry :
        externalId : ExternalGeometryId -> ExternallyTaggedGeometryObject

Parameters

externalId ExternalGeometryId
The external ID of the externally tagged geometry that should be obtained.

Return Value

ExternallyTaggedGeometryObject
The externally tagged geometry. Or if there is no such externally tagged geometry in the DirectShape.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShape Class


DirectShape.GetExternallyTaggedReference Method

DirectShapeGetExternallyTaggedReference Method

Retrieve a Reference to reference geometry of the DirectShape that is associated with a particular ExternalGeometryId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Reference GetExternallyTaggedReference(
    ExternalGeometryId externalId
)
Public Function GetExternallyTaggedReference (
    externalId As ExternalGeometryId
) As Reference
public:
Reference^ GetExternallyTaggedReference(
    ExternalGeometryId^ externalId
)
member GetExternallyTaggedReference :
        externalId : ExternalGeometryId -> Reference

Parameters

externalId ExternalGeometryId
The ExternalGeometryId of the requested reference object.

Return Value

Reference
A Reference to the externally tagged reference GeometryObject having the provided external ID or if there is no reference geometry having the external ID.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShape Class


DirectShape.GetOptions Method

DirectShapeGetOptions Method

Gets a copy of the current options for this DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DirectShapeOptions GetOptions()
Public Function GetOptions As DirectShapeOptions
public:
DirectShapeOptions^ GetOptions()
member GetOptions : unit -> DirectShapeOptions

Return Value

DirectShapeOptions
Options currently set for this DirectShape.
See Also

Reference

DirectShape Class


DirectShape.HasExternalGeometry Method

DirectShapeHasExternalGeometry Method

Checks whether the externally tagged geometry is already present in this DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasExternalGeometry(
    ExternalGeometryId externalId
)
Public Function HasExternalGeometry (
    externalId As ExternalGeometryId
) As Boolean
public:
bool HasExternalGeometry(
    ExternalGeometryId^ externalId
)
member HasExternalGeometry :
        externalId : ExternalGeometryId -> bool

Parameters

externalId ExternalGeometryId
The external ID of the externally tagged geometry to check.

Return Value

Boolean
True if such an externally tagged geometry is already present in this DirectShape, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShape Class


DirectShape.HasExternallyTaggedReference Method

DirectShapeHasExternallyTaggedReference Method

Checks if the externally tagged reference is already present in this DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasExternallyTaggedReference(
    ExternalGeometryId externalId
)
Public Function HasExternallyTaggedReference (
    externalId As ExternalGeometryId
) As Boolean
public:
bool HasExternallyTaggedReference(
    ExternalGeometryId^ externalId
)
member HasExternallyTaggedReference :
        externalId : ExternalGeometryId -> bool

Parameters

externalId ExternalGeometryId
The external ID of the tagged reference to check for.

Return Value

Boolean
True if the DirectShape holds a reference with the specified ExternalGeometryId.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShape Class


DirectShape.IsSupportedDocument Method

DirectShapeIsSupportedDocument Method

Tests whether a DirectShape or a DirectShapeType may be created in this document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsSupportedDocument(
    Document document
)
Public Shared Function IsSupportedDocument (
    document As Document
) As Boolean
public:
static bool IsSupportedDocument(
    Document^ document
)
static member IsSupportedDocument :
        document : Document -> bool

Parameters

document Document
Document to be tested.

Return Value

Boolean
True if a DirectShape or a DirectShapeType object can be created in this document, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Some types of Document, such as 2D families, can't support DirectShape functionality.
See Also

Reference

DirectShape Class


DirectShape.IsValidCategoryId Method

DirectShapeIsValidCategoryId Method

Test the category id to make sure the category is allowed for a DirectShape or DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidCategoryId(
    ElementId categoryId,
    Document doc
)
Public Shared Function IsValidCategoryId (
    categoryId As ElementId,
    doc As Document
) As Boolean
public:
static bool IsValidCategoryId(
    ElementId^ categoryId,
    Document^ doc
)
static member IsValidCategoryId :
        categoryId : ElementId *
        doc : Document -> bool

Parameters

categoryId ElementId
Category id to be tested.
doc Document
Document to look up the category by id.

Return Value

Boolean
True if the category is allowed for a DirectShape or DirectShapeType, false if not.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShape Class


DirectShape.IsValidGeometry Method

DirectShapeIsValidGeometry Method

Validates geometry to be stored in a DirectShape. Suitable geometry validation is performed. Additionally, the geometry must make sense as a shape representation for the category assigned to this DirectShape object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidGeometry(
    Solid Geom
)
Public Function IsValidGeometry (
    Geom As Solid
) As Boolean
public:
bool IsValidGeometry(
    Solid^ Geom
)
member IsValidGeometry :
        Geom : Solid -> bool

Parameters

Geom Solid
GeometryObject to be validated.

Return Value

Boolean
True if the supplied GeometryObject passes the validation criteria.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShape Class


DirectShape.IsValidReferenceCurve Method

DirectShapeIsValidReferenceCurve Method

Validates that the input curve is suitable for creating a direct shape reference curve. Bounded and unbounded lines are accepted. Other bounded and unbounded curve types with natural bounds are accepted if they are not closed. Unbounded periodic curves are not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidReferenceCurve(
    Curve curve
)
Public Shared Function IsValidReferenceCurve (
    curve As Curve
) As Boolean
public:
static bool IsValidReferenceCurve(
    Curve^ curve
)
static member IsValidReferenceCurve :
        curve : Curve -> bool

Parameters

curve Curve
The curve to test.

Return Value

Boolean
True if the input curve point can be used to create a direct shape reference curve, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShape Class


DirectShape.IsValidReferencePlaneBoundingBoxUV Method

DirectShapeIsValidReferencePlaneBoundingBoxUV Method

Validates that the input BoundingBoxUV is suitable for bounding a reference plane surface. The input BoundingBoxUV must be set and not degenerate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidReferencePlaneBoundingBoxUV(
    BoundingBoxUV boundingBoxUV
)
Public Shared Function IsValidReferencePlaneBoundingBoxUV (
    boundingBoxUV As BoundingBoxUV
) As Boolean
public:
static bool IsValidReferencePlaneBoundingBoxUV(
    BoundingBoxUV^ boundingBoxUV
)
static member IsValidReferencePlaneBoundingBoxUV :
        boundingBoxUV : BoundingBoxUV -> bool

Parameters

boundingBoxUV BoundingBoxUV
The reference plane BoundingBoxUV to test.

Return Value

Boolean
True if the input BoundingBoxUV is valid for reference plane surfaces, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShape Class


DirectShape.IsValidShape Method

DirectShapeIsValidShape Method

Overload List
 | Name | Description
Public method | IsValidShape(ExternallyTaggedGeometryObject) | Validates shape to be stored in a DirectShape.
Public method | IsValidShape(IListGeometryObject) | Validates shape to be stored in a DirectShape. Supercedes and extends IsValidGeometry().
Public method | IsValidShape(IListGeometryObject, DirectShapeTargetViewType) | Validates view-specific shape to be stored in a DirectShape. Expects a non-default view type.
Top
See Also

Reference

DirectShape Class


DirectShape.IsValidShape(ExternallyTaggedGeometryObject) Method

DirectShapeIsValidShape(ExternallyTaggedGeometryObject) Method

Validates shape to be stored in a DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidShape(
    ExternallyTaggedGeometryObject externallyTaggedGeometry
)
Public Function IsValidShape (
    externallyTaggedGeometry As ExternallyTaggedGeometryObject
) As Boolean
public:
bool IsValidShape(
    ExternallyTaggedGeometryObject^ externallyTaggedGeometry
)
member IsValidShape :
        externallyTaggedGeometry : ExternallyTaggedGeometryObject -> bool

Parameters

externallyTaggedGeometry ExternallyTaggedGeometryObject
The supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point and Curve.

Return Value

Boolean
True if the supplied shape passes the validation criteria.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
This function uses the same criteria as IsValidShape(GeometryObject).
See Also

Reference

DirectShape Class
IsValidShape Overload


DirectShape.IsValidShape(IList<GeometryObject>) Method

DirectShapeIsValidShape(IListGeometryObject) Method

Validates shape to be stored in a DirectShape. Supercedes and extends IsValidGeometry().

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidShape(
    IList<GeometryObject> shape
)
Public Function IsValidShape (
    shape As IList(Of GeometryObject)
) As Boolean
public:
bool IsValidShape(
    IList<GeometryObject^>^ shape
)
member IsValidShape :
        shape : IList<GeometryObject> -> bool

Parameters

shape IList GeometryObject
Shape to be validated represented as a collection of GeometryObjects. The supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point and Curve.

Return Value

Boolean
True if the supplied shape passes the validation criteria.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
This function calls IsValidShape(GeometryObject) to validate each object in the list.
See Also

Reference

DirectShape Class
IsValidShape Overload


DirectShape.IsValidShape(IList<GeometryObject>, DirectShapeTargetViewType) Method

DirectShapeIsValidShape(IListGeometryObject, DirectShapeTargetViewType) Method

Validates view-specific shape to be stored in a DirectShape. Expects a non-default view type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidShape(
    IList<GeometryObject> shape,
    DirectShapeTargetViewType viewType
)
Public Function IsValidShape (
    shape As IList(Of GeometryObject),
    viewType As DirectShapeTargetViewType
) As Boolean
public:
bool IsValidShape(
    IList<GeometryObject^>^ shape,
    DirectShapeTargetViewType viewType
)
member IsValidShape :
        shape : IList<GeometryObject> *
        viewType : DirectShapeTargetViewType -> bool

Parameters

shape IList GeometryObject
Shape of this object expressed as a collection of GeometryObjects. For viewType = DirectShapeTargetViewType::Default, the supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point and Curve. For viewType = DirectShapeTargetViewType::Plan, the supported types of GeometryObjects are: Point and Curve.
viewType DirectShapeTargetViewType
The view type this shape is intended for.

Return Value

Boolean
True if the supplied shape passes the validation criteria.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

DirectShape Class
IsValidShape Overload


DirectShape.IsValidTypeId Method

DirectShapeIsValidTypeId Method

Tests the type id to make sure it satisfies the following conditions
  • It is a valid element id.
  • It corresponds to a valid DirectShapeType.
  • The DirectShapeType has the same category assigned.
Additionally, this functions tests that the current type id in this DirectShape is invalid. The type id is initialized to invalidElementId by the create functions. Once it is set, it may no longer be changed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidTypeId(
    ElementId typeId
)
Public Function IsValidTypeId (
    typeId As ElementId
) As Boolean
public:
bool IsValidTypeId(
    ElementId^ typeId
)
member IsValidTypeId :
        typeId : ElementId -> bool

Parameters

typeId ElementId
Type id to be tested.

Return Value

Boolean
False unless typeId satisfies the conditions listed above and the type id of this object was not set previously.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShape Class


DirectShape.IsValidUsage Method

DirectShapeIsValidUsage Method

Validates that the ExternallyTaggedGeometryObject's usage is set to an allowed value for a DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidUsage(
    ExternallyTaggedGeometryObject externallyTaggedGeometry
)
Public Function IsValidUsage (
    externallyTaggedGeometry As ExternallyTaggedGeometryObject
) As Boolean
public:
bool IsValidUsage(
    ExternallyTaggedGeometryObject^ externallyTaggedGeometry
)
member IsValidUsage :
        externallyTaggedGeometry : ExternallyTaggedGeometryObject -> bool

Parameters

externallyTaggedGeometry ExternallyTaggedGeometryObject
The geometry to check.

Return Value

Boolean
True if the usage is permitted.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShape Class


DirectShape.RemoveAllReferenceObjects Method

DirectShapeRemoveAllReferenceObjects Method

Removes all reference objects (if any) from the DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveAllReferenceObjects()
Public Sub RemoveAllReferenceObjects
public:
void RemoveAllReferenceObjects()
member RemoveAllReferenceObjects : unit -> unit
See Also

Reference

DirectShape Class


DirectShape.RemoveExternallyTaggedGeometry Method

DirectShapeRemoveExternallyTaggedGeometry Method

Removes the externally tagged geometry object by its external ID from this DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveExternallyTaggedGeometry(
    ExternalGeometryId externalId
)
Public Sub RemoveExternallyTaggedGeometry (
    externalId As ExternalGeometryId
)
public:
void RemoveExternallyTaggedGeometry(
    ExternalGeometryId^ externalId
)
member RemoveExternallyTaggedGeometry :
        externalId : ExternalGeometryId -> unit

Parameters

externalId ExternalGeometryId
The external ID of the externally tagged geometry that should be removed.
Exceptions
Exception | Condition
ArgumentException | The externally tagged geometry with the input externalId is not present in this DirectShape.
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShape Class


DirectShape.RemoveReferenceObject Method

DirectShapeRemoveReferenceObject Method

Overload List
 | Name | Description
Public method | RemoveReferenceObject(ExternalGeometryId) | Removes any reference object associated with the provided ExternalGeometryId from the DirectShape. Nothing is done if no reference object has the given external ID or if the external ID is an empty string.
Public method | RemoveReferenceObject(String) | Removes any reference objects with the given name from the DirectShape. Nothing is done if no reference objects have the given name or if the name is the empty string.
Top
See Also

Reference

DirectShape Class


DirectShape.RemoveReferenceObject(ExternalGeometryId) Method

DirectShapeRemoveReferenceObject(ExternalGeometryId) Method

Removes any reference object associated with the provided ExternalGeometryId from the DirectShape. Nothing is done if no reference object has the given external ID or if the external ID is an empty string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveReferenceObject(
    ExternalGeometryId externalId
)
Public Sub RemoveReferenceObject (
    externalId As ExternalGeometryId
)
public:
void RemoveReferenceObject(
    ExternalGeometryId^ externalId
)
member RemoveReferenceObject :
        externalId : ExternalGeometryId -> unit

Parameters

externalId ExternalGeometryId
The ExternalGeometryId of the reference object to be removed.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShape Class
RemoveReferenceObject Overload


DirectShape.RemoveReferenceObject(String) Method

DirectShapeRemoveReferenceObject(String) Method

Removes any reference objects with the given name from the DirectShape. Nothing is done if no reference objects have the given name or if the name is the empty string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveReferenceObject(
    string refName
)
Public Sub RemoveReferenceObject (
    refName As String
)
public:
void RemoveReferenceObject(
    String^ refName
)
member RemoveReferenceObject :
        refName : string -> unit

Parameters

refName String
The name of the reference object(s) to be removed.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShape Class
RemoveReferenceObject Overload


DirectShape.ResetExternallyTaggedGeometry Method

DirectShapeResetExternallyTaggedGeometry Method

Removes all of the externally tagged geometry in this DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetExternallyTaggedGeometry()
Public Sub ResetExternallyTaggedGeometry
public:
void ResetExternallyTaggedGeometry()
member ResetExternallyTaggedGeometry : unit -> unit
See Also

Reference

DirectShape Class


DirectShape.SetName Method

DirectShapeSetName Method

Sets the name for the DirectShape element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetName(
    string name
)
Public Sub SetName (
    name As String
)
public:
void SetName(
    String^ name
)
member SetName :
        name : string -> unit

Parameters

name String
The name.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShape Class


DirectShape.SetOptions Method

DirectShapeSetOptions Method

Sets the options to use for this DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetOptions(
    DirectShapeOptions options
)
Public Sub SetOptions (
    options As DirectShapeOptions
)
public:
void SetOptions(
    DirectShapeOptions^ options
)
member SetOptions :
        options : DirectShapeOptions -> unit

Parameters

options DirectShapeOptions
Options to use for this DirectShape.
Exceptions
Exception | Condition
ArgumentException | The DirectShapeOptions provided are not valid for this DirectShape. -or- The DirectShapeOptions provided are not valid for this transient DirectShape.
ArgumentNullException | A non-optional argument was null
Remarks
The new options take effect immediately. If this DirectShape relies on a DirectShapeType for references, the options stored in DirectShapeType take precedence. Note that changing options affects how the object interacts with Revit. E.g., switching references off will disable existing constraints applied to that object.
See Also

Reference

DirectShape Class


DirectShape.SetShape Method

DirectShapeSetShape Method

Overload List
 | Name | Description
Public method | SetShape(IListGeometryObject) | Builds the shape of this object from the supplied collection of GeometryObjects. The objects are copied. If the new shape is identical to the old one, the old shape will be kept.
Public method | SetShape(ShapeBuilder) | Sets the shape of this object to the one accumulated in the supplied Builder object. If the new shape is identical to the old one, the old shape will be kept.
Public method | SetShape(IListGeometryObject, DirectShapeTargetViewType) | Builds the shape of this object from the supplied collection of GeometryObjects. The objects are copied. If the new shape is identical to the old one, the old shape will be kept.
Top
See Also

Reference

DirectShape Class


DirectShape.SetShape(IList<GeometryObject>) Method

DirectShapeSetShape(IListGeometryObject) Method

Builds the shape of this object from the supplied collection of GeometryObjects. The objects are copied. If the new shape is identical to the old one, the old shape will be kept.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetShape(
    IList<GeometryObject> pGeomArr
)
Public Sub SetShape (
    pGeomArr As IList(Of GeometryObject)
)
public:
void SetShape(
    IList<GeometryObject^>^ pGeomArr
)
member SetShape :
        pGeomArr : IList<GeometryObject> -> unit

Parameters

pGeomArr IList GeometryObject
Shape of this object expressed as a collection of GeometryObjects. The supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point and Curve.
Exceptions
Exception | Condition
ArgumentException | At least one member of pGeomArr does not satisfy DirectShape validation criteria.
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShape Class
SetShape Overload


DirectShape.SetShape(ShapeBuilder) Method

DirectShapeSetShape(ShapeBuilder) Method

Sets the shape of this object to the one accumulated in the supplied Builder object. If the new shape is identical to the old one, the old shape will be kept.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetShape(
    ShapeBuilder pBuilder
)
Public Sub SetShape (
    pBuilder As ShapeBuilder
)
public:
void SetShape(
    ShapeBuilder^ pBuilder
)
member SetShape :
        pBuilder : ShapeBuilder -> unit

Parameters

pBuilder ShapeBuilder
A ShapeBuilder object that was used to successfully build geometry to store in this DirectShape. The built shape will be transferred to the DirectShape, and the ShapeBuilder object will be reset.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
This function will bypass extra geometry validation because the built geometry has already been validated by the ShapeBuilder. It is therefore slightly more efficient than the SetShape() routine that accepts GeometryObjects directly as input. Supplying a ViewShapeBuilder object as argument will cause the view-specific shape of this DirectShape to be updated. Supplying other ShapeBuilder types will update the model shape.
See Also

Reference

DirectShape Class
SetShape Overload


DirectShape.SetShape(IList<GeometryObject>, DirectShapeTargetViewType) Method

DirectShapeSetShape(IListGeometryObject, DirectShapeTargetViewType) Method

Builds the shape of this object from the supplied collection of GeometryObjects. The objects are copied. If the new shape is identical to the old one, the old shape will be kept.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetShape(
    IList<GeometryObject> pGeomArr,
    DirectShapeTargetViewType viewType
)
Public Sub SetShape (
    pGeomArr As IList(Of GeometryObject),
    viewType As DirectShapeTargetViewType
)
public:
void SetShape(
    IList<GeometryObject^>^ pGeomArr,
    DirectShapeTargetViewType viewType
)
member SetShape :
        pGeomArr : IList<GeometryObject> *
        viewType : DirectShapeTargetViewType -> unit

Parameters

pGeomArr IList GeometryObject
Shape of this object expressed as a collection of GeometryObjects. For viewType = DirectShapeTargetViewType::Default, the supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point and Curve. For viewType = DirectShapeTargetViewType::Plan, the supported types of GeometryObjects are: Point and Curve.
viewType DirectShapeTargetViewType
Optional: set a view-specific shape representation that will be used in views of that type only. Passing DirectShapeTargetViewType::Default as view type will cause the default shape to be set.
Exceptions
Exception | Condition
ArgumentException | At least one member of pGeomArr does not satisfy DirectShape validation criteria.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

DirectShape Class
SetShape Overload


DirectShape.SetTypeId Method

DirectShapeSetTypeId Method

Sets the DirectShapeType for the DirectShape element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetTypeId(
    ElementId typeId
)
Public Sub SetTypeId (
    typeId As ElementId
)
public:
void SetTypeId(
    ElementId^ typeId
)
member SetTypeId :
        typeId : ElementId -> unit

Parameters

typeId ElementId
The ID of the type corresponding to this DirectShape element. May only be set once.
Exceptions
Exception | Condition
ArgumentException | typeId is not a valid Element identifier.
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShape Class


DirectShape.UpdateExternallyTaggedGeometry Method

DirectShapeUpdateExternallyTaggedGeometry Method

Updates the externally tagged geometry object in the DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void UpdateExternallyTaggedGeometry(
    ExternallyTaggedGeometryObject externallyTaggedGeometry
)
Public Sub UpdateExternallyTaggedGeometry (
    externallyTaggedGeometry As ExternallyTaggedGeometryObject
)
public:
void UpdateExternallyTaggedGeometry(
    ExternallyTaggedGeometryObject^ externallyTaggedGeometry
)
member UpdateExternallyTaggedGeometry :
        externallyTaggedGeometry : ExternallyTaggedGeometryObject -> unit

Parameters

externallyTaggedGeometry ExternallyTaggedGeometryObject
The externally tagged geometry that should be updated in the DirectShape.
Exceptions
Exception | Condition
ArgumentException | The input shape does not satisfy DirectShape validation criteria. -or- A previous version of the externally tagged geometry is not present in this DirectShape.
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShape Class


DirectShapeLibrary Class

DirectShapeLibrary is used to store pre-created geometry for further referencing via the definition/instance mechanism. It is not persistent: the scope of a library object is usually a single data creation session. DirectShape::createGeometryInstance and DirectShape::CreateElementInstance will use the current DirectShapeLibrary to look up the definitions. store a collection of GNodes as definition end class DirectShapeDefinition
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBDirectShapeLibrary

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DirectShapeLibrary : IDisposable
Public Class DirectShapeLibrary
    Implements IDisposable
public ref class DirectShapeLibrary : IDisposable
type DirectShapeLibrary =
    class
        interface IDisposable
    end

The DirectShapeLibrary type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | AddDefinition(String, GeometryObject) | Add a definition to be reused by instances. A definition is a single geometry object.
Public method | AddDefinition(String, IListGeometryObject) | Add a definition to be reused by instances. A definition is a collection of geometry objects.
Public method | AddDefinitionType | Add a definition to be reused by instances. Adding a definition type will change how the instances are created. When asked to create a definition, the library object will look for a corresponding type object. If one is found, it will create an instance of geometry stored in the type object. If it is not found, the library will look for a list of geometry objects stored as definition, and will copy and transform these to create an instance.
Public method | Contains | A quick check whether a definition already exists in the library. Checks for stored geometry objects only.
Public method | ContainsType | A quick check whether a definition type already exists in the library. Checks for type objects only.
Public method | Dispose | Releases all resources used by the DirectShapeLibrary
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | FindDefinition | Find a definition by id
Public method | FindDefinitionType | Find a DirectShapeType element by definition id. The element will be used for creating instances of that definition.
 | GetDirectShapeLibrary | Get the currently active Library object
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Reset | Removes all definitions from library. This is useful when importing several self-contained data sets within one session. Once a data set is imported, keeping the definitions specific to that data set will slow down the searches.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
There are two ways to add a definition to the library. The first is to add the definition as an array of geometry objects. A DirectShape created as an instance of that definition will hold a copy of predefined geometry, transformed as requested. If the definition was added as a DirectShapeType, a DirectShape object created as an instance of that definition will reference the type. Its geometry would be an instance of type geometry.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DirectShapeLibrary Properties

The DirectShapeLibrary type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

DirectShapeLibrary Class


DirectShapeLibrary.IsValidObject Property

DirectShapeLibraryIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

DirectShapeLibrary Class


DirectShapeLibrary Methods

The DirectShapeLibrary type exposes the following members.

Methods
 | Name | Description
Public method | AddDefinition(String, GeometryObject) | Add a definition to be reused by instances. A definition is a single geometry object.
Public method | AddDefinition(String, IListGeometryObject) | Add a definition to be reused by instances. A definition is a collection of geometry objects.
Public method | AddDefinitionType | Add a definition to be reused by instances. Adding a definition type will change how the instances are created. When asked to create a definition, the library object will look for a corresponding type object. If one is found, it will create an instance of geometry stored in the type object. If it is not found, the library will look for a list of geometry objects stored as definition, and will copy and transform these to create an instance.
Public method | Contains | A quick check whether a definition already exists in the library. Checks for stored geometry objects only.
Public method | ContainsType | A quick check whether a definition type already exists in the library. Checks for type objects only.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | FindDefinition | Find a definition by id
Public method | FindDefinitionType | Find a DirectShapeType element by definition id. The element will be used for creating instances of that definition.
 | GetDirectShapeLibrary | Get the currently active Library object
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Reset | Removes all definitions from library. This is useful when importing several self-contained data sets within one session. Once a data set is imported, keeping the definitions specific to that data set will slow down the searches.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DirectShapeLibrary Class


DirectShapeLibrary.AddDefinition Method

DirectShapeLibraryAddDefinition Method

Overload List
 | Name | Description
Public method | AddDefinition(String, GeometryObject) | Add a definition to be reused by instances. A definition is a single geometry object.
Public method | AddDefinition(String, IListGeometryObject) | Add a definition to be reused by instances. A definition is a collection of geometry objects.
Top
See Also

Reference

DirectShapeLibrary Class


DirectShapeLibrary.AddDefinition(String, GeometryObject) Method

DirectShapeLibraryAddDefinition(String, GeometryObject) Method

Add a definition to be reused by instances. A definition is a single geometry object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddDefinition(
    string id,
    GeometryObject GNode
)
Public Sub AddDefinition (
    id As String,
    GNode As GeometryObject
)
public:
void AddDefinition(
    String^ id,
    GeometryObject^ GNode
)
member AddDefinition :
        id : string *
        GNode : GeometryObject -> unit

Parameters

id String
ID of the definition to be added. Must be unique.
GNode GeometryObject
Definition as a single Geometry object
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShapeLibrary Class
AddDefinition Overload


DirectShapeLibrary.AddDefinition(String, IList<GeometryObject>) Method

DirectShapeLibraryAddDefinition(String, IListGeometryObject) Method

Add a definition to be reused by instances. A definition is a collection of geometry objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddDefinition(
    string id,
    IList<GeometryObject> GNodes
)
Public Sub AddDefinition (
    id As String,
    GNodes As IList(Of GeometryObject)
)
public:
void AddDefinition(
    String^ id,
    IList<GeometryObject^>^ GNodes
)
member AddDefinition :
        id : string *
        GNodes : IList<GeometryObject> -> unit

Parameters

id String
ID of the definition to be added. Must be unique.
GNodes IList GeometryObject
Definition as a list of Geometry objects
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShapeLibrary Class
AddDefinition Overload


DirectShapeLibrary.AddDefinitionType Method

DirectShapeLibraryAddDefinitionType Method

Add a definition to be reused by instances. Adding a definition type will change how the instances are created. When asked to create a definition, the library object will look for a corresponding type object. If one is found, it will create an instance of geometry stored in the type object. If it is not found, the library will look for a list of geometry objects stored as definition, and will copy and transform these to create an instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddDefinitionType(
    string id,
    ElementId typeId
)
Public Sub AddDefinitionType (
    id As String,
    typeId As ElementId
)
public:
void AddDefinitionType(
    String^ id,
    ElementId^ typeId
)
member AddDefinitionType :
        id : string *
        typeId : ElementId -> unit

Parameters

id String
ID of the definition to be added. Must be unique.
typeId ElementId
Element id of the DirectShapeType element that will be used as a definition.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShapeLibrary Class


DirectShapeLibrary.Contains Method

DirectShapeLibraryContains Method

A quick check whether a definition already exists in the library. Checks for stored geometry objects only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Contains(
    string id
)
Public Function Contains (
    id As String
) As Boolean
public:
bool Contains(
    String^ id
)
member Contains :
        id : string -> bool

Parameters

id String
Definition id

Return Value

Boolean
True if a geometry definition exists, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShapeLibrary Class


DirectShapeLibrary.ContainsType Method

DirectShapeLibraryContainsType Method

A quick check whether a definition type already exists in the library. Checks for type objects only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ContainsType(
    string name
)
Public Function ContainsType (
    name As String
) As Boolean
public:
bool ContainsType(
    String^ name
)
member ContainsType :
        name : string -> bool

Parameters

name String
Definition id

Return Value

Boolean
True if a geometry definition exists, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShapeLibrary Class


DirectShapeLibrary.Dispose Method

DirectShapeLibraryDispose Method

Releases all resources used by the DirectShapeLibrary

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

DirectShapeLibrary Class


DirectShapeLibrary.FindDefinition Method

DirectShapeLibraryFindDefinition Method

Find a definition by id

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<GeometryObject> FindDefinition(
    string id
)
Public Function FindDefinition (
    id As String
) As IList(Of GeometryObject)
public:
IList<GeometryObject^>^ FindDefinition(
    String^ id
)
member FindDefinition :
        id : string -> IList<GeometryObject>

Parameters

id String
Definition id. Expecected to be unique

Return Value

IList GeometryObject
List of geometry objects that together define a shape
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShapeLibrary Class


DirectShapeLibrary.FindDefinitionType Method

DirectShapeLibraryFindDefinitionType Method

Find a DirectShapeType element by definition id. The element will be used for creating instances of that definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId FindDefinitionType(
    string id
)
Public Function FindDefinitionType (
    id As String
) As ElementId
public:
ElementId^ FindDefinitionType(
    String^ id
)
member FindDefinitionType :
        id : string -> ElementId

Parameters

id String
Definition id. Expected to be unique.

Return Value

ElementId
Element id of a DirectShapeTypeElement
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShapeLibrary Class


DirectShapeLibrary.GetDirectShapeLibrary Method

DirectShapeLibraryGetDirectShapeLibrary Method

Get the currently active Library object

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static DirectShapeLibrary GetDirectShapeLibrary(
    Document ADoc
)
Public Shared Function GetDirectShapeLibrary (
    ADoc As Document
) As DirectShapeLibrary
public:
static DirectShapeLibrary^ GetDirectShapeLibrary(
    Document^ ADoc
)
static member GetDirectShapeLibrary :
        ADoc : Document -> DirectShapeLibrary

Parameters

ADoc Document

Return Value

DirectShapeLibrary
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShapeLibrary Class


DirectShapeLibrary.Reset Method

DirectShapeLibraryReset Method

Removes all definitions from library. This is useful when importing several self-contained data sets within one session. Once a data set is imported, keeping the definitions specific to that data set will slow down the searches.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Reset()
Public Sub Reset
public:
void Reset()
member Reset : unit -> unit
See Also

Reference

DirectShapeLibrary Class


DirectShapeOptions Class

This class is used to control behavior of a DirectShape object.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBDirectShapeOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DirectShapeOptions : IDisposable
Public Class DirectShapeOptions
    Implements IDisposable
public ref class DirectShapeOptions : IDisposable
type DirectShapeOptions =
    class
        interface IDisposable
    end

The DirectShapeOptions type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ReferencingOption | Whether or not the geometry stored in a DirectShape object may be referenced.
Public property | RoomBoundingOption | Identifies whether the DirectShape supports an option for the "Room Bounding" parameter to permit participation in room boundary calculations.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the DirectShapeOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Use Enable/Disable functions to change the default behavior. Use DirectShape.SetOptions to modify that object's behavior.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DirectShapeOptions Properties

The DirectShapeOptions type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ReferencingOption | Whether or not the geometry stored in a DirectShape object may be referenced.
Public property | RoomBoundingOption | Identifies whether the DirectShape supports an option for the "Room Bounding" parameter to permit participation in room boundary calculations.
Top
See Also

Reference

DirectShapeOptions Class


DirectShapeOptions.IsValidObject Property

DirectShapeOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

DirectShapeOptions Class


DirectShapeOptions.ReferencingOption Property

DirectShapeOptionsReferencingOption Property

Whether or not the geometry stored in a DirectShape object may be referenced.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DirectShapeReferencingOption ReferencingOption { get; set; }
Public Property ReferencingOption As DirectShapeReferencingOption
    Get
    Set
public:
property DirectShapeReferencingOption ReferencingOption {
    DirectShapeReferencingOption get ();
    void set (DirectShapeReferencingOption value);
}
member ReferencingOption : DirectShapeReferencingOption with get, set

Property Value

DirectShapeReferencingOption
The default value is Referenceable.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
If the geometry is not referenceable, it may not be used for dimensioning, snapping, alignment, or face-hosting. The element may still be selected by the user for operations which do not reference individual geometry objects.
See Also

Reference

DirectShapeOptions Class


DirectShapeOptions.RoomBoundingOption Property

DirectShapeOptionsRoomBoundingOption Property

Identifies whether the DirectShape supports an option for the "Room Bounding" parameter to permit participation in room boundary calculations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DirectShapeRoomBoundingOption RoomBoundingOption { get; }
Public ReadOnly Property RoomBoundingOption As DirectShapeRoomBoundingOption
    Get
public:
property DirectShapeRoomBoundingOption RoomBoundingOption {
    DirectShapeRoomBoundingOption get ();
}
member RoomBoundingOption : DirectShapeRoomBoundingOption with get

Property Value

DirectShapeRoomBoundingOption
See Also

Reference

DirectShapeOptions Class


DirectShapeOptions Methods

The DirectShapeOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DirectShapeOptions Class


DirectShapeOptions.Dispose Method

DirectShapeOptionsDispose Method

Releases all resources used by the DirectShapeOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

DirectShapeOptions Class


DirectShapeReferenceOptions Class

This class is used to control the behavior of DirectShape and DirectShapeType reference objects.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBDirectShapeReferenceOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DirectShapeReferenceOptions : IDisposable
Public Class DirectShapeReferenceOptions
    Implements IDisposable
public ref class DirectShapeReferenceOptions : IDisposable
type DirectShapeReferenceOptions =
    class
        interface IDisposable
    end

The DirectShapeReferenceOptions type exposes the following members.

Constructors
 | Name | Description
Public method | DirectShapeReferenceOptions | Constructs a new DirectShapeRefOptions instance with default settings.
Public method | DirectShapeReferenceOptions(DirectShapeReferenceOptions) | Constructs a new copy of the input DirectShapeRefOptions object.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The name associated with the reference object. The name does not need to be unique. The name must not be empty and must contain valid characters.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the DirectShapeReferenceOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetExternalGeometryId | Retrieves the ExternalGeometryId associated with the reference object.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | IsValidExternalGeometryId | Validates that the input ExternalGeometryId can be assigned to a direct shape reference.
 | IsValidReferenceName | Validates that the input name can be assigned to a direct shape reference.
Public method | SetExternalGeometryId | Sets the ExternalGeometryId associated with the reference object. The ID must be non-empty.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DirectShapeReferenceOptions Constructor

Overload List
 | Name | Description
Public method | DirectShapeReferenceOptions | Constructs a new DirectShapeRefOptions instance with default settings.
Public method | DirectShapeReferenceOptions(DirectShapeReferenceOptions) | Constructs a new copy of the input DirectShapeRefOptions object.
Top
See Also

Reference

DirectShapeReferenceOptions Class


DirectShapeReferenceOptions Constructor

Constructs a new DirectShapeRefOptions instance with default settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DirectShapeReferenceOptions()
Public Sub New
public:
DirectShapeReferenceOptions()
new : unit -> DirectShapeReferenceOptions
See Also

Reference

DirectShapeReferenceOptions Class
DirectShapeReferenceOptions Overload


DirectShapeReferenceOptions(DirectShapeReferenceOptions) Constructor

Constructs a new copy of the input DirectShapeRefOptions object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DirectShapeReferenceOptions(
    DirectShapeReferenceOptions other
)
Public Sub New (
    other As DirectShapeReferenceOptions
)
public:
DirectShapeReferenceOptions(
    DirectShapeReferenceOptions^ other
)
new :
        other : DirectShapeReferenceOptions -> DirectShapeReferenceOptions

Parameters

other DirectShapeReferenceOptions
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShapeReferenceOptions Class
DirectShapeReferenceOptions Overload


DirectShapeReferenceOptions Properties

The DirectShapeReferenceOptions type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The name associated with the reference object. The name does not need to be unique. The name must not be empty and must contain valid characters.
Top
See Also

Reference

DirectShapeReferenceOptions Class


DirectShapeReferenceOptions.IsValidObject Property

DirectShapeReferenceOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

DirectShapeReferenceOptions Class


DirectShapeReferenceOptions.Name Property

DirectShapeReferenceOptionsName Property

The name associated with the reference object. The name does not need to be unique. The name must not be empty and must contain valid characters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentException | When setting this property: value cannot be used as a name for the direct shape reference.
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

DirectShapeReferenceOptions Class


DirectShapeReferenceOptions Methods

The DirectShapeReferenceOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetExternalGeometryId | Retrieves the ExternalGeometryId associated with the reference object.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | IsValidExternalGeometryId | Validates that the input ExternalGeometryId can be assigned to a direct shape reference.
 | IsValidReferenceName | Validates that the input name can be assigned to a direct shape reference.
Public method | SetExternalGeometryId | Sets the ExternalGeometryId associated with the reference object. The ID must be non-empty.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DirectShapeReferenceOptions Class


DirectShapeReferenceOptions.Dispose Method

DirectShapeReferenceOptionsDispose Method

Releases all resources used by the DirectShapeReferenceOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

DirectShapeReferenceOptions Class


DirectShapeReferenceOptions.GetExternalGeometryId Method

DirectShapeReferenceOptionsGetExternalGeometryId Method

Retrieves the ExternalGeometryId associated with the reference object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExternalGeometryId GetExternalGeometryId()
Public Function GetExternalGeometryId As ExternalGeometryId
public:
ExternalGeometryId^ GetExternalGeometryId()
member GetExternalGeometryId : unit -> ExternalGeometryId

Return Value

ExternalGeometryId
Remarks
If an ExternalGeometryId has not been set, this method returns .
See Also

Reference

DirectShapeReferenceOptions Class


DirectShapeReferenceOptions.IsValidExternalGeometryId Method

DirectShapeReferenceOptionsIsValidExternalGeometryId Method

Validates that the input ExternalGeometryId can be assigned to a direct shape reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidExternalGeometryId(
    ExternalGeometryId externalId
)
Public Shared Function IsValidExternalGeometryId (
    externalId As ExternalGeometryId
) As Boolean
public:
static bool IsValidExternalGeometryId(
    ExternalGeometryId^ externalId
)
static member IsValidExternalGeometryId :
        externalId : ExternalGeometryId -> bool

Parameters

externalId ExternalGeometryId
The ExternalGeometryId to assign to the reference.

Return Value

Boolean
True if the provided ExternalGeometryId is valid, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShapeReferenceOptions Class


DirectShapeReferenceOptions.IsValidReferenceName Method

DirectShapeReferenceOptionsIsValidReferenceName Method

Validates that the input name can be assigned to a direct shape reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidReferenceName(
    string name
)
Public Shared Function IsValidReferenceName (
    name As String
) As Boolean
public:
static bool IsValidReferenceName(
    String^ name
)
static member IsValidReferenceName :
        name : string -> bool

Parameters

name String
The name to assign to the reference.

Return Value

Boolean
True if the input name is valid, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShapeReferenceOptions Class


DirectShapeReferenceOptions.SetExternalGeometryId Method

DirectShapeReferenceOptionsSetExternalGeometryId Method

Sets the ExternalGeometryId associated with the reference object. The ID must be non-empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DirectShapeReferenceOptions SetExternalGeometryId(
    ExternalGeometryId externalId
)
Public Function SetExternalGeometryId (
    externalId As ExternalGeometryId
) As DirectShapeReferenceOptions
public:
DirectShapeReferenceOptions^ SetExternalGeometryId(
    ExternalGeometryId^ externalId
)
member SetExternalGeometryId :
        externalId : ExternalGeometryId -> DirectShapeReferenceOptions

Parameters

externalId ExternalGeometryId

Return Value

DirectShapeReferenceOptions
Exceptions
Exception | Condition
ArgumentException | externalId cannot be used as an ExternalGeometryId for a direct shape reference.
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShapeReferenceOptions Class


DirectShapeReferencingOption Enumeration

An enumerated type containing possible referencing options for DirectShapes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DirectShapeReferencingOption
Public Enumeration DirectShapeReferencingOption
public enum class DirectShapeReferencingOption
type DirectShapeReferencingOption
Members
Member name | Value | Description
NotReferenceable | 0 | The associated DirectShape shall not be referenceable.
Referenceable | 1 | The associated DirectShape may be dimensioned and/or otherwise referenced.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DirectShapeRoomBoundingOption Enumeration

An enumerated type containing possible room bounding settings for DirectShapes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DirectShapeRoomBoundingOption
Public Enumeration DirectShapeRoomBoundingOption
public enum class DirectShapeRoomBoundingOption
type DirectShapeRoomBoundingOption
Members
Member name | Value | Description
NotApplicable | 0 | The associated DirectShape doesn't have a room bounding parameter, and isn't allowed to. Trying to change to this value will result in an exception. Trying to change from this value is restricted to DirectShapes that can be room bounding.
SetByParameter | 1 | The associated DirectShape has a room bounding parameter which is which is writeable and defaults to on. If can be toggled by a user or the API (by accessing the parameter WALL_ATTR_ROOM_BOUNDING).
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DirectShapeTargetViewType Enumeration

View types for which DirectShape objects are allowed to have alternative shape representations

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DirectShapeTargetViewType
Public Enumeration DirectShapeTargetViewType
public enum class DirectShapeTargetViewType
type DirectShapeTargetViewType
Members
Member name | Value | Description
Undefined | 0 | Invalid value
Default | 1 | Shape to be used in all views for which a view-specific shape was not provided
Plan | 2 | The alternate representation will be used only in Revit Plan views
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DirectShapeType Class

The type element associated with a DirectShape element. This element includes data reused by DirectShape elements of the same type.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBDirectShapeType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DirectShapeType : ElementType
Public Class DirectShapeType
    Inherits ElementType
public ref class DirectShapeType : public ElementType
type DirectShapeType =
    class
        inherit ElementType
    end

The DirectShapeType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | UserAssignability | An option controlling the ability of DirectShapes to assign this DirectShapeType as its type.
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | AddExternallyTaggedGeometry | Adds the externally tagged geometry object to the DirectShapeType.
Public method | AddReferenceCurve(Curve) | Adds a reference curve to the DirectShapeType.
Public method | AddReferenceCurve(Curve, DirectShapeReferenceOptions) | Adds a reference curve to the DirectShapeType.
Public method | AddReferencePlane(Plane) | Adds a reference plane to the DirectShapeType. The reference plane can either be bounded or unbounded.
Public method | AddReferencePlane(Plane, BoundingBoxUV) | Adds a reference plane to the DirectShapeType. The reference plane can either be bounded or unbounded.
Public method | AddReferencePlane(Plane, DirectShapeReferenceOptions) | Adds a reference plane to the DirectShapeType. The reference plane can either be bounded or unbounded.
Public method | AddReferencePlane(Plane, BoundingBoxUV, DirectShapeReferenceOptions) | Adds a reference plane to the DirectShapeType. The reference plane can either be bounded or unbounded.
Public method | AddReferencePoint(XYZ) | Adds a reference point to the DirectShapeType.
Public method | AddReferencePoint(XYZ, DirectShapeReferenceOptions) | Adds a reference point to the DirectShapeType.
Public method | AppendShape(IListGeometryObject) | Appends the collection of GeometryObjects into the model shape representation stored in this DirectShape.
Public method | AppendShape(ShapeBuilder) | Append shape built by the supplied ShapeBuilderObject to shape representation stored in this DirectShapeType. The data stored in the supplied ShapeBuilder object will be cleared.
Public method | AppendShape(IListGeometryObject, DirectShapeTargetViewType) | Appends the collection of GeometryObjects into the model or view specific shape representation stored in this DirectShapeType. Passing DirectShapeTargetViewType.Default as view type will cause the model shape to be updated.
Public method | AreOptionsValid | Validates that the given DirectShapeTypeOptions are allowed for this particular DirectShapeType.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | AreValidDirectShapeReferenceOptions | Validates that the input DirectShapeReferenceOptions are suitable for creating a direct shape reference object. If the options specify an ExternalGeometryId, it must not correspond to any existing reference object belonging to the DirectShapeType.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanChangeFamilyName | Checks whether the DirectShapeType supports a custom family name.
Public method | CanCreateParts | Indicates if it is possible to create parts from this DirectShapeType element.
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create(Document, String, ElementId) | Creates a DirectShapeType element.
 | Create(Document, String, ElementId, DirectShapeTypeOptions) | Creates a DirectShapeType element.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternallyTaggedGeometry | Gets the externally tagged geometry by its external ID that is stored in this DirectShapeType.
Public method | GetExternallyTaggedReference | Retrieve a Reference to reference geometry of the DirectShapeType that is associated with a particular ExternalGeometryId.
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOptions | Gets a copy of the current options for this DirectShapeType.
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasExternalGeometry | Checks whether the externally tagged geometry is already present in this DirectShapeType.
Public method | HasExternallyTaggedReference | Checks if the externally tagged reference is already present in this DirectShapeType.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
 | IsValidReferenceCurve | Validates that the input curve is suitable for creating a direct shape type reference curve. Bounded and unbounded lines are accepted. Other bounded and unbounded curve types with natural bounds are accepted if they are not closed. Unbounded periodic curves are not allowed.
 | IsValidReferencePlaneBoundingBoxUV | Validates that the input BoundingBoxUV is suitable for bounding a reference plane surface. The input BoundingBoxUV must be set and not degenerate.
Public method | IsValidShape(ExternallyTaggedGeometryObject) | Validates shape to be stored in a DirectShapeType.
Public method | IsValidShape(IListGeometryObject) | Validates shape to be stored in a DirectShapeType.
Public method | IsValidShape(IListGeometryObject, DirectShapeTargetViewType) | Validates view-specific shape to be stored in a DirectShapeType. Expects a non-default view type.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | IsValidUsage | Validates that the ExternallyTaggedGeometryObject's usage is set to an allowed value for a DirectShapeType.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveAllReferenceObjects | Removes all reference objects (if any) from the DirectShapeType.
Public method | RemoveExternallyTaggedGeometry | Removes the externally tagged geometry object by its external ID from this DirectShapeType.
Public method | RemoveReferenceObject(ExternalGeometryId) | Removes any reference object associated with the provided ExternalGeometryId from the DirectShapeType. Nothing is done if no reference object has the given external ID or if the external ID is an empty string.
Public method | RemoveReferenceObject(String) | Removes any reference objects with the given name from the DirectShapeType. Nothing is done if no reference objects have the given name or if the name is the empty string.
Public method | ResetExternallyTaggedGeometry | Removes all of the externally tagged geometry in this DirectShapeType.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetFamilyName | Sets the family name for the DirectShapeType.
Public method | SetOptions | Sets the options to use for this DirectShapeType.
Public method | SetShape(IListGeometryObject) | Builds the type shape from the supplied collection of GeometryObjects. The objects are copied. If the new shape is identical to the old one, the old shape will be kept.
Public method | SetShape(ShapeBuilder) | Sets the shape of this object to the one accumulated in the supplied Builder object. If the new shape is identical to the old one, the old shape will be kept.
Public method | SetShape(IListGeometryObject, DirectShapeTargetViewType) | Builds the type shape from the supplied collection of GeometryObjects. The objects are copied. If the new shape is identical to the old one, the old shape will be kept.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UpdateExternallyTaggedGeometry | Updates the externally tagged geometry object in the DirectShapeType.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DirectShapeType Properties

The DirectShapeType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | UserAssignability | An option controlling the ability of DirectShapes to assign this DirectShapeType as its type.
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

DirectShapeType Class


DirectShapeType.UserAssignability Property

DirectShapeTypeUserAssignability Property

An option controlling the ability of DirectShapes to assign this DirectShapeType as its type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DirectShapeTypeUserAssignability UserAssignability { get; set; }
Public Property UserAssignability As DirectShapeTypeUserAssignability
    Get
    Set
public:
property DirectShapeTypeUserAssignability UserAssignability {
    DirectShapeTypeUserAssignability get ();
    void set (DirectShapeTypeUserAssignability value);
}
member UserAssignability : DirectShapeTypeUserAssignability with get, set

Property Value

DirectShapeTypeUserAssignability
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

DirectShapeType Class


DirectShapeType Methods

The DirectShapeType type exposes the following members.

Methods
 | Name | Description
Public method | AddExternallyTaggedGeometry | Adds the externally tagged geometry object to the DirectShapeType.
Public method | AddReferenceCurve(Curve) | Adds a reference curve to the DirectShapeType.
Public method | AddReferenceCurve(Curve, DirectShapeReferenceOptions) | Adds a reference curve to the DirectShapeType.
Public method | AddReferencePlane(Plane) | Adds a reference plane to the DirectShapeType. The reference plane can either be bounded or unbounded.
Public method | AddReferencePlane(Plane, BoundingBoxUV) | Adds a reference plane to the DirectShapeType. The reference plane can either be bounded or unbounded.
Public method | AddReferencePlane(Plane, DirectShapeReferenceOptions) | Adds a reference plane to the DirectShapeType. The reference plane can either be bounded or unbounded.
Public method | AddReferencePlane(Plane, BoundingBoxUV, DirectShapeReferenceOptions) | Adds a reference plane to the DirectShapeType. The reference plane can either be bounded or unbounded.
Public method | AddReferencePoint(XYZ) | Adds a reference point to the DirectShapeType.
Public method | AddReferencePoint(XYZ, DirectShapeReferenceOptions) | Adds a reference point to the DirectShapeType.
Public method | AppendShape(IListGeometryObject) | Appends the collection of GeometryObjects into the model shape representation stored in this DirectShape.
Public method | AppendShape(ShapeBuilder) | Append shape built by the supplied ShapeBuilderObject to shape representation stored in this DirectShapeType. The data stored in the supplied ShapeBuilder object will be cleared.
Public method | AppendShape(IListGeometryObject, DirectShapeTargetViewType) | Appends the collection of GeometryObjects into the model or view specific shape representation stored in this DirectShapeType. Passing DirectShapeTargetViewType.Default as view type will cause the model shape to be updated.
Public method | AreOptionsValid | Validates that the given DirectShapeTypeOptions are allowed for this particular DirectShapeType.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | AreValidDirectShapeReferenceOptions | Validates that the input DirectShapeReferenceOptions are suitable for creating a direct shape reference object. If the options specify an ExternalGeometryId, it must not correspond to any existing reference object belonging to the DirectShapeType.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanChangeFamilyName | Checks whether the DirectShapeType supports a custom family name.
Public method | CanCreateParts | Indicates if it is possible to create parts from this DirectShapeType element.
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create(Document, String, ElementId) | Creates a DirectShapeType element.
 | Create(Document, String, ElementId, DirectShapeTypeOptions) | Creates a DirectShapeType element.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternallyTaggedGeometry | Gets the externally tagged geometry by its external ID that is stored in this DirectShapeType.
Public method | GetExternallyTaggedReference | Retrieve a Reference to reference geometry of the DirectShapeType that is associated with a particular ExternalGeometryId.
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOptions | Gets a copy of the current options for this DirectShapeType.
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasExternalGeometry | Checks whether the externally tagged geometry is already present in this DirectShapeType.
Public method | HasExternallyTaggedReference | Checks if the externally tagged reference is already present in this DirectShapeType.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
 | IsValidReferenceCurve | Validates that the input curve is suitable for creating a direct shape type reference curve. Bounded and unbounded lines are accepted. Other bounded and unbounded curve types with natural bounds are accepted if they are not closed. Unbounded periodic curves are not allowed.
 | IsValidReferencePlaneBoundingBoxUV | Validates that the input BoundingBoxUV is suitable for bounding a reference plane surface. The input BoundingBoxUV must be set and not degenerate.
Public method | IsValidShape(ExternallyTaggedGeometryObject) | Validates shape to be stored in a DirectShapeType.
Public method | IsValidShape(IListGeometryObject) | Validates shape to be stored in a DirectShapeType.
Public method | IsValidShape(IListGeometryObject, DirectShapeTargetViewType) | Validates view-specific shape to be stored in a DirectShapeType. Expects a non-default view type.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | IsValidUsage | Validates that the ExternallyTaggedGeometryObject's usage is set to an allowed value for a DirectShapeType.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveAllReferenceObjects | Removes all reference objects (if any) from the DirectShapeType.
Public method | RemoveExternallyTaggedGeometry | Removes the externally tagged geometry object by its external ID from this DirectShapeType.
Public method | RemoveReferenceObject(ExternalGeometryId) | Removes any reference object associated with the provided ExternalGeometryId from the DirectShapeType. Nothing is done if no reference object has the given external ID or if the external ID is an empty string.
Public method | RemoveReferenceObject(String) | Removes any reference objects with the given name from the DirectShapeType. Nothing is done if no reference objects have the given name or if the name is the empty string.
Public method | ResetExternallyTaggedGeometry | Removes all of the externally tagged geometry in this DirectShapeType.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetFamilyName | Sets the family name for the DirectShapeType.
Public method | SetOptions | Sets the options to use for this DirectShapeType.
Public method | SetShape(IListGeometryObject) | Builds the type shape from the supplied collection of GeometryObjects. The objects are copied. If the new shape is identical to the old one, the old shape will be kept.
Public method | SetShape(ShapeBuilder) | Sets the shape of this object to the one accumulated in the supplied Builder object. If the new shape is identical to the old one, the old shape will be kept.
Public method | SetShape(IListGeometryObject, DirectShapeTargetViewType) | Builds the type shape from the supplied collection of GeometryObjects. The objects are copied. If the new shape is identical to the old one, the old shape will be kept.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UpdateExternallyTaggedGeometry | Updates the externally tagged geometry object in the DirectShapeType.
Top
See Also

Reference

DirectShapeType Class


DirectShapeType.AddExternallyTaggedGeometry Method

DirectShapeTypeAddExternallyTaggedGeometry Method

Adds the externally tagged geometry object to the DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddExternallyTaggedGeometry(
    ExternallyTaggedGeometryObject externallyTaggedGeometry
)
Public Sub AddExternallyTaggedGeometry (
    externallyTaggedGeometry As ExternallyTaggedGeometryObject
)
public:
void AddExternallyTaggedGeometry(
    ExternallyTaggedGeometryObject^ externallyTaggedGeometry
)
member AddExternallyTaggedGeometry :
        externallyTaggedGeometry : ExternallyTaggedGeometryObject -> unit

Parameters

externallyTaggedGeometry ExternallyTaggedGeometryObject
The externally tagged geometry that should be added to the DirectShapeType.
Exceptions
Exception | Condition
ArgumentException | The input shape does not satisfy DirectShapeType validation criteria. -or- The input geometry does not have a permitted usage. -or- The externallyTaggedGeometry has already been added to this DirectShapeType.
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShapeType Class


DirectShapeType.AddReferenceCurve Method

DirectShapeTypeAddReferenceCurve Method

Overload List
 | Name | Description
Public method | AddReferenceCurve(Curve) | Adds a reference curve to the DirectShapeType.
Public method | AddReferenceCurve(Curve, DirectShapeReferenceOptions) | Adds a reference curve to the DirectShapeType.
Top
See Also

Reference

DirectShapeType Class


DirectShapeType.AddReferenceCurve(Curve) Method

DirectShapeTypeAddReferenceCurve(Curve) Method

Adds a reference curve to the DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddReferenceCurve(
    Curve refCurve
)
Public Sub AddReferenceCurve (
    refCurve As Curve
)
public:
void AddReferenceCurve(
    Curve^ refCurve
)
member AddReferenceCurve :
        refCurve : Curve -> unit

Parameters

refCurve Curve
The geometry of the new reference curve.
Exceptions
Exception | Condition
ArgumentException | refCurve cannot be used for creating a reference curve.
ArgumentNullException | A non-optional argument was null
Remarks

There are two cases to consider:

  1. The input curve's bounds are set. The resulting reference curve that is added to the DirectShapeType will be displayed with those bounds. Note that the specified bounds must not be degenerate. Permitted curve types are those for which [!:Autodesk::Revit::DB::DirectShapeType::isValidReferenceCurve] returns true.
  2. The input curve is unbounded. Reasonable bounds are automatically calculated and applied to the input curve. The automatic bounds are based on the host DirectShapeType's geometry.

Note that only lines and splines may be unbounded. You must specify valid bounds for all other curve types.

See Also

Reference

DirectShapeType Class
AddReferenceCurve Overload


DirectShapeType.AddReferenceCurve(Curve, DirectShapeReferenceOptions) Method

DirectShapeTypeAddReferenceCurve(Curve, DirectShapeReferenceOptions) Method

Adds a reference curve to the DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddReferenceCurve(
    Curve refCurve,
    DirectShapeReferenceOptions options
)
Public Sub AddReferenceCurve (
    refCurve As Curve,
    options As DirectShapeReferenceOptions
)
public:
void AddReferenceCurve(
    Curve^ refCurve,
    DirectShapeReferenceOptions^ options
)
member AddReferenceCurve :
        refCurve : Curve *
        options : DirectShapeReferenceOptions -> unit

Parameters

refCurve Curve
The geometry of the new reference curve.
options DirectShapeReferenceOptions
The options that are used to configure the new reference curve.
Exceptions
Exception | Condition
ArgumentException | refCurve cannot be used for creating a reference curve. -or- options cannot be used to add a reference object to this DirectShapeType.
ArgumentNullException | A non-optional argument was null
Remarks

There are two cases to consider:

  1. The input curve's bounds are set. The resulting reference curve that is added to the DirectShapeType will be displayed with those bounds. Note that the specified bounds must not be degenerate. Permitted curve types are those for which [!:Autodesk::Revit::DB::DirectShapeType::isValidReferenceCurve] returns true.
  2. The input curve is unbounded. Reasonable bounds are automatically calculated and applied to the input curve. The automatic bounds are based on the host DirectShapeType's geometry.

Note that only lines and splines may be unbounded. You must specify valid bounds for all other curve types.

See Also

Reference

DirectShapeType Class
AddReferenceCurve Overload


DirectShapeType.AddReferencePlane Method

DirectShapeTypeAddReferencePlane Method

Overload List
 | Name | Description
Public method | AddReferencePlane(Plane) | Adds a reference plane to the DirectShapeType. The reference plane can either be bounded or unbounded.
Public method | AddReferencePlane(Plane, BoundingBoxUV) | Adds a reference plane to the DirectShapeType. The reference plane can either be bounded or unbounded.
Public method | AddReferencePlane(Plane, DirectShapeReferenceOptions) | Adds a reference plane to the DirectShapeType. The reference plane can either be bounded or unbounded.
Public method | AddReferencePlane(Plane, BoundingBoxUV, DirectShapeReferenceOptions) | Adds a reference plane to the DirectShapeType. The reference plane can either be bounded or unbounded.
Top
See Also

Reference

DirectShapeType Class


DirectShapeType.AddReferencePlane(Plane) Method

DirectShapeTypeAddReferencePlane(Plane) Method

Adds a reference plane to the DirectShapeType. The reference plane can either be bounded or unbounded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddReferencePlane(
    Plane refPlane
)
Public Sub AddReferencePlane (
    refPlane As Plane
)
public:
void AddReferencePlane(
    Plane^ refPlane
)
member AddReferencePlane :
        refPlane : Plane -> unit

Parameters

refPlane Plane
The geometry of the new reference plane.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShapeType Class
AddReferencePlane Overload


DirectShapeType.AddReferencePlane(Plane, BoundingBoxUV) Method

DirectShapeTypeAddReferencePlane(Plane, BoundingBoxUV) Method

Adds a reference plane to the DirectShapeType. The reference plane can either be bounded or unbounded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddReferencePlane(
    Plane refPlane,
    BoundingBoxUV boundingBoxUV
)
Public Sub AddReferencePlane (
    refPlane As Plane,
    boundingBoxUV As BoundingBoxUV
)
public:
void AddReferencePlane(
    Plane^ refPlane,
    BoundingBoxUV^ boundingBoxUV
)
member AddReferencePlane :
        refPlane : Plane *
        boundingBoxUV : BoundingBoxUV -> unit

Parameters

refPlane Plane
The geometry of the new reference plane.
boundingBoxUV BoundingBoxUV
If boundingBoxUV is set, the resulting reference plane that is added to the DirectShapeType will be displayed with those bounds. Note that the specified bounds must not be degenerate. If boundingBoxUV is not set, reasonable bounds are automatically calculated and applied to the input plane. The automatic bounds are based on the host direct shape's geometry.
Exceptions
Exception | Condition
ArgumentException | boundingBoxUV cannot be used as a BoundingBoxUV for the reference plane surface.
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShapeType Class
AddReferencePlane Overload


DirectShapeType.AddReferencePlane(Plane, DirectShapeReferenceOptions) Method

DirectShapeTypeAddReferencePlane(Plane, DirectShapeReferenceOptions) Method

Adds a reference plane to the DirectShapeType. The reference plane can either be bounded or unbounded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddReferencePlane(
    Plane refPlane,
    DirectShapeReferenceOptions options
)
Public Sub AddReferencePlane (
    refPlane As Plane,
    options As DirectShapeReferenceOptions
)
public:
void AddReferencePlane(
    Plane^ refPlane,
    DirectShapeReferenceOptions^ options
)
member AddReferencePlane :
        refPlane : Plane *
        options : DirectShapeReferenceOptions -> unit

Parameters

refPlane Plane
The geometry of the new reference plane.
options DirectShapeReferenceOptions
The options that are used to configure the new reference plane.
Exceptions
Exception | Condition
ArgumentException | options cannot be used to add a reference object to this DirectShapeType.
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShapeType Class
AddReferencePlane Overload


DirectShapeType.AddReferencePlane(Plane, BoundingBoxUV, DirectShapeReferenceOptions) Method

DirectShapeTypeAddReferencePlane(Plane, BoundingBoxUV, DirectShapeReferenceOptions) Method

Adds a reference plane to the DirectShapeType. The reference plane can either be bounded or unbounded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddReferencePlane(
    Plane refPlane,
    BoundingBoxUV boundingBoxUV,
    DirectShapeReferenceOptions options
)
Public Sub AddReferencePlane (
    refPlane As Plane,
    boundingBoxUV As BoundingBoxUV,
    options As DirectShapeReferenceOptions
)
public:
void AddReferencePlane(
    Plane^ refPlane,
    BoundingBoxUV^ boundingBoxUV,
    DirectShapeReferenceOptions^ options
)
member AddReferencePlane :
        refPlane : Plane *
        boundingBoxUV : BoundingBoxUV *
        options : DirectShapeReferenceOptions -> unit

Parameters

refPlane Plane
The geometry of the new reference plane.
boundingBoxUV BoundingBoxUV
If boundingBoxUV is set, the resulting reference plane that is added to the DirectShapeType will be displayed with those bounds. Note that the specified bounds must not be degenerate. If boundingBoxUV is not set, reasonable bounds are automatically calculated and applied to the input plane. The automatic bounds are based on the host direct shape's geometry.
options DirectShapeReferenceOptions
The options that are used to configure the new reference plane.
Exceptions
Exception | Condition
ArgumentException | boundingBoxUV cannot be used as a BoundingBoxUV for the reference plane surface. -or- options cannot be used to add a reference object to this DirectShapeType.
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShapeType Class
AddReferencePlane Overload


DirectShapeType.AddReferencePoint Method

DirectShapeTypeAddReferencePoint Method

Overload List
 | Name | Description
Public method | AddReferencePoint(XYZ) | Adds a reference point to the DirectShapeType.
Public method | AddReferencePoint(XYZ, DirectShapeReferenceOptions) | Adds a reference point to the DirectShapeType.
Top
See Also

Reference

DirectShapeType Class


DirectShapeType.AddReferencePoint(XYZ) Method

DirectShapeTypeAddReferencePoint(XYZ) Method

Adds a reference point to the DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddReferencePoint(
    XYZ refPoint
)
Public Sub AddReferencePoint (
    refPoint As XYZ
)
public:
void AddReferencePoint(
    XYZ^ refPoint
)
member AddReferencePoint :
        refPoint : XYZ -> unit

Parameters

refPoint XYZ
The coordinates of the new reference point.
Exceptions
Exception | Condition
ArgumentException | The input point lies outside of Revit design limits.
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShapeType Class
AddReferencePoint Overload


DirectShapeType.AddReferencePoint(XYZ, DirectShapeReferenceOptions) Method

DirectShapeTypeAddReferencePoint(XYZ, DirectShapeReferenceOptions) Method

Adds a reference point to the DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddReferencePoint(
    XYZ refPoint,
    DirectShapeReferenceOptions options
)
Public Sub AddReferencePoint (
    refPoint As XYZ,
    options As DirectShapeReferenceOptions
)
public:
void AddReferencePoint(
    XYZ^ refPoint,
    DirectShapeReferenceOptions^ options
)
member AddReferencePoint :
        refPoint : XYZ *
        options : DirectShapeReferenceOptions -> unit

Parameters

refPoint XYZ
The coordinates of the new reference point.
options DirectShapeReferenceOptions
The options that are used to configure the new reference point.
Exceptions
Exception | Condition
ArgumentException | The input point lies outside of Revit design limits. -or- options cannot be used to add a reference object to this DirectShapeType.
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShapeType Class
AddReferencePoint Overload


DirectShapeType.AppendShape Method

DirectShapeTypeAppendShape Method

Overload List
 | Name | Description
Public method | AppendShape(IListGeometryObject) | Appends the collection of GeometryObjects into the model shape representation stored in this DirectShape.
Public method | AppendShape(ShapeBuilder) | Append shape built by the supplied ShapeBuilderObject to shape representation stored in this DirectShapeType. The data stored in the supplied ShapeBuilder object will be cleared.
Public method | AppendShape(IListGeometryObject, DirectShapeTargetViewType) | Appends the collection of GeometryObjects into the model or view specific shape representation stored in this DirectShapeType. Passing DirectShapeTargetViewType.Default as view type will cause the model shape to be updated.
Top
See Also

Reference

DirectShapeType Class


DirectShapeType.AppendShape(IList<GeometryObject>) Method

DirectShapeTypeAppendShape(IListGeometryObject) Method

Appends the collection of GeometryObjects into the model shape representation stored in this DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AppendShape(
    IList<GeometryObject> pGeomArr
)
Public Sub AppendShape (
    pGeomArr As IList(Of GeometryObject)
)
public:
void AppendShape(
    IList<GeometryObject^>^ pGeomArr
)
member AppendShape :
        pGeomArr : IList<GeometryObject> -> unit

Parameters

pGeomArr IList GeometryObject
Shape expressed as a collection of GeometryObjects. The supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point, Curve and PolyLine.
Exceptions
Exception | Condition
ArgumentException | At least one member of pGeomArr does not satisfy DirectShapeType validation criteria.
ArgumentNullException | A non-optional argument was null
Remarks
The existing shape will not be cleared by this function, and intersecting or overlapped geometry will not be joined with the appended geometry. It is up to the caller to ensure that the combination of geometry will have the correct appearance in Revit.
See Also

Reference

DirectShapeType Class
AppendShape Overload


DirectShapeType.AppendShape(ShapeBuilder) Method

DirectShapeTypeAppendShape(ShapeBuilder) Method

Append shape built by the supplied ShapeBuilderObject to shape representation stored in this DirectShapeType. The data stored in the supplied ShapeBuilder object will be cleared.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AppendShape(
    ShapeBuilder ShapeBuilder
)
Public Sub AppendShape (
    ShapeBuilder As ShapeBuilder
)
public:
void AppendShape(
    ShapeBuilder^ ShapeBuilder
)
member AppendShape :
        ShapeBuilder : ShapeBuilder -> unit

Parameters

ShapeBuilder ShapeBuilder
The ShapeBuilder object that was used to build the shape to be appended.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
The existing shape will not be cleared by this function, and intersecting or overlapped geometry will not be joined with the appended geometry. It is up to the caller to ensure that the combination of geometry will have teh correct appearance in Revit. This function will bypass extra geometry validation because the built geometry has already been validated by the ShapeBuilder. It is therefore slightly more efficient than the AppendShape() routine that accepts GeometryObjects directly as input.
See Also

Reference

DirectShapeType Class
AppendShape Overload


DirectShapeType.AppendShape(IList<GeometryObject>, DirectShapeTargetViewType) Method

DirectShapeTypeAppendShape(IListGeometryObject, DirectShapeTargetViewType) Method

Appends the collection of GeometryObjects into the model or view specific shape representation stored in this DirectShapeType. Passing DirectShapeTargetViewType.Default as view type will cause the model shape to be updated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AppendShape(
    IList<GeometryObject> pGeomArr,
    DirectShapeTargetViewType viewType
)
Public Sub AppendShape (
    pGeomArr As IList(Of GeometryObject),
    viewType As DirectShapeTargetViewType
)
public:
void AppendShape(
    IList<GeometryObject^>^ pGeomArr,
    DirectShapeTargetViewType viewType
)
member AppendShape :
        pGeomArr : IList<GeometryObject> *
        viewType : DirectShapeTargetViewType -> unit

Parameters

pGeomArr IList GeometryObject
Shape expressed as a collection of GeometryObjects. For viewType = DirectShapeTargetViewType::Default, the supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point, Curve and PolyLine. For viewType = DirectShapeTargetViewType::Plan, the supported types of GeometryObjects are: Point and Curve.
viewType DirectShapeTargetViewType
Passing DirectShapeTargetViewType.Default as view type will cause the default shape to be appended.
Exceptions
Exception | Condition
ArgumentException | At least one member of pGeomArr does not satisfy DirectShapeType validation criteria.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Remarks
The existing shape will not be cleared by this function, and intersecting or overlapped geometry will not be joined with the appended geometry. It is up to the caller to ensure that the combination of geometry will have the correct appearance in Revit.
See Also

Reference

DirectShapeType Class
AppendShape Overload


DirectShapeType.AreOptionsValid Method

DirectShapeTypeAreOptionsValid Method

Validates that the given DirectShapeTypeOptions are allowed for this particular DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AreOptionsValid(
    DirectShapeTypeOptions options
)
Public Function AreOptionsValid (
    options As DirectShapeTypeOptions
) As Boolean
public:
bool AreOptionsValid(
    DirectShapeTypeOptions^ options
)
member AreOptionsValid :
        options : DirectShapeTypeOptions -> bool

Parameters

options DirectShapeTypeOptions
The options object.

Return Value

Boolean
True if the DirectShapeTypeOptions are valid; false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShapeType Class


DirectShapeType.AreValidDirectShapeReferenceOptions Method

DirectShapeTypeAreValidDirectShapeReferenceOptions Method

Validates that the input DirectShapeReferenceOptions are suitable for creating a direct shape reference object. If the options specify an ExternalGeometryId, it must not correspond to any existing reference object belonging to the DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AreValidDirectShapeReferenceOptions(
    DirectShapeReferenceOptions options
)
Public Function AreValidDirectShapeReferenceOptions (
    options As DirectShapeReferenceOptions
) As Boolean
public:
bool AreValidDirectShapeReferenceOptions(
    DirectShapeReferenceOptions^ options
)
member AreValidDirectShapeReferenceOptions :
        options : DirectShapeReferenceOptions -> bool

Parameters

options DirectShapeReferenceOptions
The options to test.

Return Value

Boolean
True if the options can be used to add a reference object to this DirectShapeType.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShapeType Class


DirectShapeType.CanChangeFamilyName Method

DirectShapeTypeCanChangeFamilyName Method

Checks whether the DirectShapeType supports a custom family name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanChangeFamilyName()
Public Function CanChangeFamilyName As Boolean
public:
bool CanChangeFamilyName()
member CanChangeFamilyName : unit -> bool

Return Value

Boolean
True if a custom family name is supported, false otherwise.
See Also

Reference

DirectShapeType Class


DirectShapeType.CanCreateParts Method

DirectShapeTypeCanCreateParts Method

Indicates if it is possible to create parts from this DirectShapeType element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanCreateParts()
Public Function CanCreateParts As Boolean
public:
bool CanCreateParts()
member CanCreateParts : unit -> bool

Return Value

Boolean
True if it is possible to create parts from this DirectShapeType.
Remarks
While it is generally possible to create parts from DirectShape elements, some characteristics make parts creation impossible. This property is re-evaluated every time the DirectShapeType's geometry is modified (via a call to SetShape or AppendShape). Invalid configurations include: DirectShapeTypes containing a polymesh, or an open geometry, as well as DirectShapeTypes not containing any solids and DirectShapeTypes configured as NotReferenceable (via a call to SetOptions). Finally, if a DirectShapeType has other DirectShapeType instances in its geometry, and one of those other DirectShapeTypes has a configuration that is incompatible with parts creation, the host DirectShapeType will also be incompatible with parts creation.
See Also

Reference

DirectShapeType Class


DirectShapeType.Create Method

DirectShapeTypeCreate Method

Overload List
Name | Description
Create(Document, String, ElementId) | Creates a DirectShapeType element.
Create(Document, String, ElementId, DirectShapeTypeOptions) | Creates a DirectShapeType element.
Top
See Also

Reference

DirectShapeType Class


DirectShapeType.Create(Document, String, ElementId) Method

DirectShapeTypeCreate(Document, String, ElementId) Method

Creates a DirectShapeType element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static DirectShapeType Create(
    Document document,
    string name,
    ElementId categoryId
)
Public Shared Function Create (
    document As Document,
    name As String,
    categoryId As ElementId
) As DirectShapeType
public:
static DirectShapeType^ Create(
    Document^ document,
    String^ name,
    ElementId^ categoryId
)
static member Create :
        document : Document *
        name : string *
        categoryId : ElementId -> DirectShapeType

Parameters

document Document
Document to which the created element will be added. Must be a project document.
name String
Name of the DirectShapeType.
categoryId ElementId
Id of the category assigned to this DirectShapeType. Must be a valid category id.

Return Value

DirectShapeType
The new DirectShapeType.
Exceptions
Exception | Condition
ArgumentException | document is not a project document. -or- Document document may not contain DirectShape or DirectShapeType objects. -or- Element id categoryId may not be used as a DirectShape category.
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShapeType Class
Create Overload


DirectShapeType.Create(Document, String, ElementId, DirectShapeTypeOptions) Method

DirectShapeTypeCreate(Document, String, ElementId, DirectShapeTypeOptions) Method

Creates a DirectShapeType element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static DirectShapeType Create(
    Document document,
    string name,
    ElementId categoryId,
    DirectShapeTypeOptions options
)
Public Shared Function Create (
    document As Document,
    name As String,
    categoryId As ElementId,
    options As DirectShapeTypeOptions
) As DirectShapeType
public:
static DirectShapeType^ Create(
    Document^ document,
    String^ name,
    ElementId^ categoryId,
    DirectShapeTypeOptions^ options
)
static member Create :
        document : Document *
        name : string *
        categoryId : ElementId *
        options : DirectShapeTypeOptions -> DirectShapeType

Parameters

document Document
Document to which the created element will be added.
name String
Name of the DirectShapeType.
categoryId ElementId
Id of the category assigned to this DirectShapeType. Must be a valid category id.
options DirectShapeTypeOptions
Options that can be used to control the behavior of DirectShapeType being created.

Return Value

DirectShapeType
The new DirectShapeType.
Exceptions
Exception | Condition
ArgumentException | Document document may not contain DirectShape or DirectShapeType objects. -or- Element id categoryId may not be used as a DirectShape category.
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShapeType Class
Create Overload


DirectShapeType.GetExternallyTaggedGeometry Method

DirectShapeTypeGetExternallyTaggedGeometry Method

Gets the externally tagged geometry by its external ID that is stored in this DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExternallyTaggedGeometryObject GetExternallyTaggedGeometry(
    ExternalGeometryId externalId
)
Public Function GetExternallyTaggedGeometry (
    externalId As ExternalGeometryId
) As ExternallyTaggedGeometryObject
public:
ExternallyTaggedGeometryObject^ GetExternallyTaggedGeometry(
    ExternalGeometryId^ externalId
)
member GetExternallyTaggedGeometry :
        externalId : ExternalGeometryId -> ExternallyTaggedGeometryObject

Parameters

externalId ExternalGeometryId
The external ID of the externally tagged geometry that should be obtained.

Return Value

ExternallyTaggedGeometryObject
The externally tagged geometry. Or if there is no such externally tagged geometry in the DirectShapeType.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShapeType Class


DirectShapeType.GetExternallyTaggedReference Method

DirectShapeTypeGetExternallyTaggedReference Method

Retrieve a Reference to reference geometry of the DirectShapeType that is associated with a particular ExternalGeometryId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Reference GetExternallyTaggedReference(
    ExternalGeometryId externalId
)
Public Function GetExternallyTaggedReference (
    externalId As ExternalGeometryId
) As Reference
public:
Reference^ GetExternallyTaggedReference(
    ExternalGeometryId^ externalId
)
member GetExternallyTaggedReference :
        externalId : ExternalGeometryId -> Reference

Parameters

externalId ExternalGeometryId
The ExternalGeometryId of the requested reference object.

Return Value

Reference
A Reference to the externally tagged reference GeometryObject having the provided external ID or if there is no reference geometry having the external ID.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShapeType Class


DirectShapeType.GetOptions Method

DirectShapeTypeGetOptions Method

Gets a copy of the current options for this DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DirectShapeTypeOptions GetOptions()
Public Function GetOptions As DirectShapeTypeOptions
public:
DirectShapeTypeOptions^ GetOptions()
member GetOptions : unit -> DirectShapeTypeOptions

Return Value

DirectShapeTypeOptions
Options currently set for this DirectShapeType.
See Also

Reference

DirectShapeType Class


DirectShapeType.HasExternalGeometry Method

DirectShapeTypeHasExternalGeometry Method

Checks whether the externally tagged geometry is already present in this DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasExternalGeometry(
    ExternalGeometryId externalId
)
Public Function HasExternalGeometry (
    externalId As ExternalGeometryId
) As Boolean
public:
bool HasExternalGeometry(
    ExternalGeometryId^ externalId
)
member HasExternalGeometry :
        externalId : ExternalGeometryId -> bool

Parameters

externalId ExternalGeometryId
The external ID of the externally tagged geometry to check.

Return Value

Boolean
True if such an externally tagged geometry is already present in this DirectShapeType, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShapeType Class


DirectShapeType.HasExternallyTaggedReference Method

DirectShapeTypeHasExternallyTaggedReference Method

Checks if the externally tagged reference is already present in this DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasExternallyTaggedReference(
    ExternalGeometryId externalId
)
Public Function HasExternallyTaggedReference (
    externalId As ExternalGeometryId
) As Boolean
public:
bool HasExternallyTaggedReference(
    ExternalGeometryId^ externalId
)
member HasExternallyTaggedReference :
        externalId : ExternalGeometryId -> bool

Parameters

externalId ExternalGeometryId
The external ID of the tagged reference to check for.

Return Value

Boolean
True if the DirectShapeType holds a reference with the specified ExternalGeometryId.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShapeType Class


DirectShapeType.IsValidReferenceCurve Method

DirectShapeTypeIsValidReferenceCurve Method

Validates that the input curve is suitable for creating a direct shape type reference curve. Bounded and unbounded lines are accepted. Other bounded and unbounded curve types with natural bounds are accepted if they are not closed. Unbounded periodic curves are not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidReferenceCurve(
    Curve curve
)
Public Shared Function IsValidReferenceCurve (
    curve As Curve
) As Boolean
public:
static bool IsValidReferenceCurve(
    Curve^ curve
)
static member IsValidReferenceCurve :
        curve : Curve -> bool

Parameters

curve Curve
The curve to test.

Return Value

Boolean
True if the input curve point can be used to create a direct shape reference curve, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShapeType Class


DirectShapeType.IsValidReferencePlaneBoundingBoxUV Method

DirectShapeTypeIsValidReferencePlaneBoundingBoxUV Method

Validates that the input BoundingBoxUV is suitable for bounding a reference plane surface. The input BoundingBoxUV must be set and not degenerate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidReferencePlaneBoundingBoxUV(
    BoundingBoxUV boundingBoxUV
)
Public Shared Function IsValidReferencePlaneBoundingBoxUV (
    boundingBoxUV As BoundingBoxUV
) As Boolean
public:
static bool IsValidReferencePlaneBoundingBoxUV(
    BoundingBoxUV^ boundingBoxUV
)
static member IsValidReferencePlaneBoundingBoxUV :
        boundingBoxUV : BoundingBoxUV -> bool

Parameters

boundingBoxUV BoundingBoxUV
The reference plane BoundingBoxUV to test.

Return Value

Boolean
True if the input BoundingBoxUV is valid for reference plane surfaces, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShapeType Class


DirectShapeType.IsValidShape Method

DirectShapeTypeIsValidShape Method

Overload List
 | Name | Description
Public method | IsValidShape(ExternallyTaggedGeometryObject) | Validates shape to be stored in a DirectShapeType.
Public method | IsValidShape(IListGeometryObject) | Validates shape to be stored in a DirectShapeType.
Public method | IsValidShape(IListGeometryObject, DirectShapeTargetViewType) | Validates view-specific shape to be stored in a DirectShapeType. Expects a non-default view type.
Top
See Also

Reference

DirectShapeType Class


DirectShapeType.IsValidShape(ExternallyTaggedGeometryObject) Method

DirectShapeTypeIsValidShape(ExternallyTaggedGeometryObject) Method

Validates shape to be stored in a DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidShape(
    ExternallyTaggedGeometryObject externallyTaggedGeometry
)
Public Function IsValidShape (
    externallyTaggedGeometry As ExternallyTaggedGeometryObject
) As Boolean
public:
bool IsValidShape(
    ExternallyTaggedGeometryObject^ externallyTaggedGeometry
)
member IsValidShape :
        externallyTaggedGeometry : ExternallyTaggedGeometryObject -> bool

Parameters

externallyTaggedGeometry ExternallyTaggedGeometryObject
The supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point and Curve.

Return Value

Boolean
True if the supplied shape passes the validation criteria.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
This function uses the same criteria as IsValidShape(GeometryObject).
See Also

Reference

DirectShapeType Class
IsValidShape Overload


DirectShapeType.IsValidShape(IList<GeometryObject>) Method

DirectShapeTypeIsValidShape(IListGeometryObject) Method

Validates shape to be stored in a DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidShape(
    IList<GeometryObject> shape
)
Public Function IsValidShape (
    shape As IList(Of GeometryObject)
) As Boolean
public:
bool IsValidShape(
    IList<GeometryObject^>^ shape
)
member IsValidShape :
        shape : IList<GeometryObject> -> bool

Parameters

shape IList GeometryObject
Shape to be validated represented as a collection of GeometryObjects. The supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point, Curve and PolyLine.

Return Value

Boolean
True if the supplied shape passes the validation criteria.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
This function calls IsValidShape(GeometryObject) to validate each object in the list.
See Also

Reference

DirectShapeType Class
IsValidShape Overload


DirectShapeType.IsValidShape(IList<GeometryObject>, DirectShapeTargetViewType) Method

DirectShapeTypeIsValidShape(IListGeometryObject, DirectShapeTargetViewType) Method

Validates view-specific shape to be stored in a DirectShapeType. Expects a non-default view type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidShape(
    IList<GeometryObject> shape,
    DirectShapeTargetViewType viewType
)
Public Function IsValidShape (
    shape As IList(Of GeometryObject),
    viewType As DirectShapeTargetViewType
) As Boolean
public:
bool IsValidShape(
    IList<GeometryObject^>^ shape,
    DirectShapeTargetViewType viewType
)
member IsValidShape :
        shape : IList<GeometryObject> *
        viewType : DirectShapeTargetViewType -> bool

Parameters

shape IList GeometryObject
Shape of this object expressed as a collection of GeometryObjects. For viewType = DirectShapeTargetViewType::Default, the supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point, Curve and PolyLine. For viewType = DirectShapeTargetViewType::Plan, the supported types of GeometryObjects are: Point and Curve.
viewType DirectShapeTargetViewType
The view type this shape is intended for.

Return Value

Boolean
True if the supplied shape passes the validation criteria.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

DirectShapeType Class
IsValidShape Overload


DirectShapeType.IsValidUsage Method

DirectShapeTypeIsValidUsage Method

Validates that the ExternallyTaggedGeometryObject's usage is set to an allowed value for a DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidUsage(
    ExternallyTaggedGeometryObject externallyTaggedGeometry
)
Public Function IsValidUsage (
    externallyTaggedGeometry As ExternallyTaggedGeometryObject
) As Boolean
public:
bool IsValidUsage(
    ExternallyTaggedGeometryObject^ externallyTaggedGeometry
)
member IsValidUsage :
        externallyTaggedGeometry : ExternallyTaggedGeometryObject -> bool

Parameters

externallyTaggedGeometry ExternallyTaggedGeometryObject
The geometry to check.

Return Value

Boolean
True if the usage is permitted.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShapeType Class


DirectShapeType.RemoveAllReferenceObjects Method

DirectShapeTypeRemoveAllReferenceObjects Method

Removes all reference objects (if any) from the DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveAllReferenceObjects()
Public Sub RemoveAllReferenceObjects
public:
void RemoveAllReferenceObjects()
member RemoveAllReferenceObjects : unit -> unit
See Also

Reference

DirectShapeType Class


DirectShapeType.RemoveExternallyTaggedGeometry Method

DirectShapeTypeRemoveExternallyTaggedGeometry Method

Removes the externally tagged geometry object by its external ID from this DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveExternallyTaggedGeometry(
    ExternalGeometryId externalId
)
Public Sub RemoveExternallyTaggedGeometry (
    externalId As ExternalGeometryId
)
public:
void RemoveExternallyTaggedGeometry(
    ExternalGeometryId^ externalId
)
member RemoveExternallyTaggedGeometry :
        externalId : ExternalGeometryId -> unit

Parameters

externalId ExternalGeometryId
The external ID of the externally tagged geometry that should be removed.
Exceptions
Exception | Condition
ArgumentException | The externally tagged geometry with the input externalId is not present in this DirectShapeType.
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShapeType Class


DirectShapeType.RemoveReferenceObject Method

DirectShapeTypeRemoveReferenceObject Method

Overload List
 | Name | Description
Public method | RemoveReferenceObject(ExternalGeometryId) | Removes any reference object associated with the provided ExternalGeometryId from the DirectShapeType. Nothing is done if no reference object has the given external ID or if the external ID is an empty string.
Public method | RemoveReferenceObject(String) | Removes any reference objects with the given name from the DirectShapeType. Nothing is done if no reference objects have the given name or if the name is the empty string.
Top
See Also

Reference

DirectShapeType Class


DirectShapeType.RemoveReferenceObject(ExternalGeometryId) Method

DirectShapeTypeRemoveReferenceObject(ExternalGeometryId) Method

Removes any reference object associated with the provided ExternalGeometryId from the DirectShapeType. Nothing is done if no reference object has the given external ID or if the external ID is an empty string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveReferenceObject(
    ExternalGeometryId externalId
)
Public Sub RemoveReferenceObject (
    externalId As ExternalGeometryId
)
public:
void RemoveReferenceObject(
    ExternalGeometryId^ externalId
)
member RemoveReferenceObject :
        externalId : ExternalGeometryId -> unit

Parameters

externalId ExternalGeometryId
The ExternalGeometryId of the reference object to be removed.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShapeType Class
RemoveReferenceObject Overload


DirectShapeType.RemoveReferenceObject(String) Method

DirectShapeTypeRemoveReferenceObject(String) Method

Removes any reference objects with the given name from the DirectShapeType. Nothing is done if no reference objects have the given name or if the name is the empty string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveReferenceObject(
    string refName
)
Public Sub RemoveReferenceObject (
    refName As String
)
public:
void RemoveReferenceObject(
    String^ refName
)
member RemoveReferenceObject :
        refName : string -> unit

Parameters

refName String
The name of the reference object(s) to be removed.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShapeType Class
RemoveReferenceObject Overload


DirectShapeType.ResetExternallyTaggedGeometry Method

DirectShapeTypeResetExternallyTaggedGeometry Method

Removes all of the externally tagged geometry in this DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetExternallyTaggedGeometry()
Public Sub ResetExternallyTaggedGeometry
public:
void ResetExternallyTaggedGeometry()
member ResetExternallyTaggedGeometry : unit -> unit
See Also

Reference

DirectShapeType Class


DirectShapeType.SetFamilyName Method

DirectShapeTypeSetFamilyName Method

Sets the family name for the DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetFamilyName(
    string name
)
Public Sub SetFamilyName (
    name As String
)
public:
void SetFamilyName(
    String^ name
)
member SetFamilyName :
        name : string -> unit

Parameters

name String
Family name for the DirectShapeType.
Exceptions
Exception | Condition
ArgumentException | The element type name was empty, contained invalid characters, or was invalid for the specific element type.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The given DirectShapeType has a category which does not support a custom family name.
Remarks
By default the family name is either Direct Shape or a category-specific name. When a category-specific name is used the family name cannot be set.
See Also

Reference

DirectShapeType Class


DirectShapeType.SetOptions Method

DirectShapeTypeSetOptions Method

Sets the options to use for this DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetOptions(
    DirectShapeTypeOptions options
)
Public Sub SetOptions (
    options As DirectShapeTypeOptions
)
public:
void SetOptions(
    DirectShapeTypeOptions^ options
)
member SetOptions :
        options : DirectShapeTypeOptions -> unit

Parameters

options DirectShapeTypeOptions
Options to use for this DirectShapeType.
Exceptions
Exception | Condition
ArgumentException | The DirectShapeTypeOptions provided are not valid for this DirectShapeType.
ArgumentNullException | A non-optional argument was null
Remarks
The new options take effect immediately.
See Also

Reference

DirectShapeType Class


DirectShapeType.SetShape Method

DirectShapeTypeSetShape Method

Overload List
 | Name | Description
Public method | SetShape(IListGeometryObject) | Builds the type shape from the supplied collection of GeometryObjects. The objects are copied. If the new shape is identical to the old one, the old shape will be kept.
Public method | SetShape(ShapeBuilder) | Sets the shape of this object to the one accumulated in the supplied Builder object. If the new shape is identical to the old one, the old shape will be kept.
Public method | SetShape(IListGeometryObject, DirectShapeTargetViewType) | Builds the type shape from the supplied collection of GeometryObjects. The objects are copied. If the new shape is identical to the old one, the old shape will be kept.
Top
See Also

Reference

DirectShapeType Class


DirectShapeType.SetShape(IList<GeometryObject>) Method

DirectShapeTypeSetShape(IListGeometryObject) Method

Builds the type shape from the supplied collection of GeometryObjects. The objects are copied. If the new shape is identical to the old one, the old shape will be kept.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetShape(
    IList<GeometryObject> pGeomArr
)
Public Sub SetShape (
    pGeomArr As IList(Of GeometryObject)
)
public:
void SetShape(
    IList<GeometryObject^>^ pGeomArr
)
member SetShape :
        pGeomArr : IList<GeometryObject> -> unit

Parameters

pGeomArr IList GeometryObject
Shape of this object expressed as a collection of GeometryObjects. These will be copied. Shape and Category should be consistent: geometry supplied as shape should be valid for the Category the type object is associated with. The supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point, Curve and PolyLine.
Exceptions
Exception | Condition
ArgumentException | At least one member of pGeomArr does not satisfy DirectShapeType validation criteria.
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShapeType Class
SetShape Overload


DirectShapeType.SetShape(ShapeBuilder) Method

DirectShapeTypeSetShape(ShapeBuilder) Method

Sets the shape of this object to the one accumulated in the supplied Builder object. If the new shape is identical to the old one, the old shape will be kept.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetShape(
    ShapeBuilder pBuilder
)
Public Sub SetShape (
    pBuilder As ShapeBuilder
)
public:
void SetShape(
    ShapeBuilder^ pBuilder
)
member SetShape :
        pBuilder : ShapeBuilder -> unit

Parameters

pBuilder ShapeBuilder
A ShapeBuilder object that was used to successfully build geometry to store in this DirectShapeType. The built shape will be transferred to the DirectShapeType, and the ShapeBuilder object will be reset.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
This function will bypass extra geometry validation because the built geometry has already been validated by the ShapeBuilder. It is therefore slightly more efficient than the SetShape() routine that accepts GeometryObjects directly as input. Supplying a ViewShapeBuilder object as argument will cause the view-specific shape of this DirectShapeType to be updated. Supplying other ShapeBuilder types will update the model shape.
See Also

Reference

DirectShapeType Class
SetShape Overload


DirectShapeType.SetShape(IList<GeometryObject>, DirectShapeTargetViewType) Method

DirectShapeTypeSetShape(IListGeometryObject, DirectShapeTargetViewType) Method

Builds the type shape from the supplied collection of GeometryObjects. The objects are copied. If the new shape is identical to the old one, the old shape will be kept.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetShape(
    IList<GeometryObject> pGeomArr,
    DirectShapeTargetViewType viewType
)
Public Sub SetShape (
    pGeomArr As IList(Of GeometryObject),
    viewType As DirectShapeTargetViewType
)
public:
void SetShape(
    IList<GeometryObject^>^ pGeomArr,
    DirectShapeTargetViewType viewType
)
member SetShape :
        pGeomArr : IList<GeometryObject> *
        viewType : DirectShapeTargetViewType -> unit

Parameters

pGeomArr IList GeometryObject
Shape of this object expressed as a collection of GeometryObjects. These will be copied. Shape and Category should be consistent: geometry supplied as shape should be valid for the Category the type object is associated with. For viewType = DirectShapeTargetViewType::Default, the supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point and Curve. For viewType = DirectShapeTargetViewType::Plan, the supported types of GeometryObjects are: Point and Curve
viewType DirectShapeTargetViewType
Specifies which target view type to associate the geometry with. The target view type will decide which views can show this geometry.
Exceptions
Exception | Condition
ArgumentException | At least one member of pGeomArr does not satisfy DirectShapeType validation criteria.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

DirectShapeType Class
SetShape Overload


DirectShapeType.UpdateExternallyTaggedGeometry Method

DirectShapeTypeUpdateExternallyTaggedGeometry Method

Updates the externally tagged geometry object in the DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void UpdateExternallyTaggedGeometry(
    ExternallyTaggedGeometryObject externallyTaggedGeometry
)
Public Sub UpdateExternallyTaggedGeometry (
    externallyTaggedGeometry As ExternallyTaggedGeometryObject
)
public:
void UpdateExternallyTaggedGeometry(
    ExternallyTaggedGeometryObject^ externallyTaggedGeometry
)
member UpdateExternallyTaggedGeometry :
        externallyTaggedGeometry : ExternallyTaggedGeometryObject -> unit

Parameters

externallyTaggedGeometry ExternallyTaggedGeometryObject
The externally tagged geometry that should be updated in the DirectShapeType.
Exceptions
Exception | Condition
ArgumentException | The input shape does not satisfy DirectShapeType validation criteria. -or- A previous version of the externally tagged geometry is not present in this DirectShapeType.
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShapeType Class


DirectShapeTypeOptions Class

This class is used to control behavior of a DirectShapeType object.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBDirectShapeTypeOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DirectShapeTypeOptions : IDisposable
Public Class DirectShapeTypeOptions
    Implements IDisposable
public ref class DirectShapeTypeOptions : IDisposable
type DirectShapeTypeOptions =
    class
        interface IDisposable
    end

The DirectShapeTypeOptions type exposes the following members.

Constructors
 | Name | Description
Public method | DirectShapeTypeOptions | Constructs a new DirectShapeTypeOptions instance with default settings.
Top
Properties
 | Name | Description
Public property | AllowDuplicateNames | Determines whether or not duplicate DirectShapeType names are allowed.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the DirectShapeTypeOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqualTo | Compare this object with the one supplied as argument. Return true if the options specified by both objects are the same.
Public method | IsValid | Determines whether a DirectShapeTypeOptions is internally consistent (valid).
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Use Enable/Disable functions to change the default behavior. Use DirectShapeType.SetOptions to modify that object's behavior.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DirectShapeTypeOptions Constructor

Constructs a new DirectShapeTypeOptions instance with default settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DirectShapeTypeOptions()
Public Sub New
public:
DirectShapeTypeOptions()
new : unit -> DirectShapeTypeOptions
See Also

Reference

DirectShapeTypeOptions Class


DirectShapeTypeOptions Properties

The DirectShapeTypeOptions type exposes the following members.

Properties
 | Name | Description
Public property | AllowDuplicateNames | Determines whether or not duplicate DirectShapeType names are allowed.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

DirectShapeTypeOptions Class


DirectShapeTypeOptions.AllowDuplicateNames Property

DirectShapeTypeOptionsAllowDuplicateNames Property

Determines whether or not duplicate DirectShapeType names are allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AllowDuplicateNames { get; set; }
Public Property AllowDuplicateNames As Boolean
    Get
    Set
public:
property bool AllowDuplicateNames {
    bool get ();
    void set (bool value);
}
member AllowDuplicateNames : bool with get, set

Property Value

Boolean
See Also

Reference

DirectShapeTypeOptions Class


DirectShapeTypeOptions.IsValidObject Property

DirectShapeTypeOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

DirectShapeTypeOptions Class


DirectShapeTypeOptions Methods

The DirectShapeTypeOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqualTo | Compare this object with the one supplied as argument. Return true if the options specified by both objects are the same.
Public method | IsValid | Determines whether a DirectShapeTypeOptions is internally consistent (valid).
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DirectShapeTypeOptions Class


DirectShapeTypeOptions.Dispose Method

DirectShapeTypeOptionsDispose Method

Releases all resources used by the DirectShapeTypeOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

DirectShapeTypeOptions Class


DirectShapeTypeOptions.IsEqualTo Method

DirectShapeTypeOptionsIsEqualTo Method

Compare this object with the one supplied as argument. Return true if the options specified by both objects are the same.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEqualTo(
    DirectShapeTypeOptions other
)
Public Function IsEqualTo (
    other As DirectShapeTypeOptions
) As Boolean
public:
bool IsEqualTo(
    DirectShapeTypeOptions^ other
)
member IsEqualTo :
        other : DirectShapeTypeOptions -> bool

Parameters

other DirectShapeTypeOptions
the DirectShapeTypeOptions object to be compared.

Return Value

Boolean
True if both objects specify the same options.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DirectShapeTypeOptions Class


DirectShapeTypeOptions.IsValid Method

DirectShapeTypeOptionsIsValid Method

Determines whether a DirectShapeTypeOptions is internally consistent (valid).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValid()
Public Function IsValid As Boolean
public:
bool IsValid()
member IsValid : unit -> bool

Return Value

Boolean
Remarks
This is currently a placeholder and always returns true. Will be made public_api and a validator when it does something useful.
See Also

Reference

DirectShapeTypeOptions Class


DirectShapeTypeUserAssignability Enumeration

Options for a DirectShapeType which affect whether or not it can be assigned as the type of a DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DirectShapeTypeUserAssignability
Public Enumeration DirectShapeTypeUserAssignability
public enum class DirectShapeTypeUserAssignability
type DirectShapeTypeUserAssignability
Members
Member name | Value | Description
Assignable | 0 | The DirectShapeType can be used to replace the type of an existing DirectShape.
Nonassignable | 1 | The DirectShapeType cannot be used to replace the type of an existing DirectShape.
Remarks
Only DirectShapeTypes which permit assignability will be shown in the type selector dialog. A DirectShape which uses a DirectShapeType which is not assignable can be copied.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DisableAnalyticalModelCB Class

Disable the analytical model for a structural wall.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFailureResolution
Autodesk.Revit.DBDisableAnalyticalModelCB

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DisableAnalyticalModelCB : FailureResolution
Public Class DisableAnalyticalModelCB
    Inherits FailureResolution
public ref class DisableAnalyticalModelCB : public FailureResolution
type DisableAnalyticalModelCB =
    class
        inherit FailureResolution
    end

The DisableAnalyticalModelCB type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FailureResolution)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from FailureResolution)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DisableAnalyticalModelCB Properties

The DisableAnalyticalModelCB type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FailureResolution)
Top
See Also

Reference

DisableAnalyticalModelCB Class


DisableAnalyticalModelCB Methods

The DisableAnalyticalModelCB type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from FailureResolution)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DisableAnalyticalModelCB Class


DisciplineTypeId Class

This class contains constants identifying disciplines.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBDisciplineTypeId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class DisciplineTypeId
Public NotInheritable Class DisciplineTypeId
public ref class DisciplineTypeId abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DisciplineTypeId = class end

The DisciplineTypeId type exposes the following members.

Properties
Name | Description
Architecture | Architecture.
Common | Common.
Electrical | Electrical.
Energy | Energy.
Hvac | HVAC.
Infrastructure | Infrastructure.
Piping | Piping.
Structural | Structural.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DisciplineTypeId Properties

The DisciplineTypeId type exposes the following members.

Properties
Name | Description
Architecture | Architecture.
Common | Common.
Electrical | Electrical.
Energy | Energy.
Hvac | HVAC.
Infrastructure | Infrastructure.
Piping | Piping.
Structural | Structural.
Top
See Also

Reference

DisciplineTypeId Class


DisciplineTypeId.Architecture Property

DisciplineTypeIdArchitecture Property

Architecture.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Architecture { get; }
Public Shared ReadOnly Property Architecture As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Architecture {
    ForgeTypeId^ get ();
}
static member Architecture : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

DisciplineTypeId Class


DisciplineTypeId.Common Property

DisciplineTypeIdCommon Property

Common.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Common { get; }
Public Shared ReadOnly Property Common As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Common {
    ForgeTypeId^ get ();
}
static member Common : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

DisciplineTypeId Class


DisciplineTypeId.Electrical Property

DisciplineTypeIdElectrical Property

Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Electrical { get; }
Public Shared ReadOnly Property Electrical As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Electrical {
    ForgeTypeId^ get ();
}
static member Electrical : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

DisciplineTypeId Class


DisciplineTypeId.Energy Property

DisciplineTypeIdEnergy Property

Energy.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Energy { get; }
Public Shared ReadOnly Property Energy As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Energy {
    ForgeTypeId^ get ();
}
static member Energy : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

DisciplineTypeId Class


DisciplineTypeId.Hvac Property

DisciplineTypeIdHvac Property

HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Hvac { get; }
Public Shared ReadOnly Property Hvac As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Hvac {
    ForgeTypeId^ get ();
}
static member Hvac : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

DisciplineTypeId Class


DisciplineTypeId.Infrastructure Property

DisciplineTypeIdInfrastructure Property

Infrastructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Infrastructure { get; }
Public Shared ReadOnly Property Infrastructure As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Infrastructure {
    ForgeTypeId^ get ();
}
static member Infrastructure : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

DisciplineTypeId Class


DisciplineTypeId.Piping Property

DisciplineTypeIdPiping Property

Piping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Piping { get; }
Public Shared ReadOnly Property Piping As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Piping {
    ForgeTypeId^ get ();
}
static member Piping : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

DisciplineTypeId Class


DisciplineTypeId.Structural Property

DisciplineTypeIdStructural Property

Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Structural { get; }
Public Shared ReadOnly Property Structural As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Structural {
    ForgeTypeId^ get ();
}
static member Structural : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

DisciplineTypeId Class


DisplacementElement Class

A view-specific element that causes other elements to appear to be displaced from their actual locations.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBDisplacementElement

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DisplacementElement : Element
Public Class DisplacementElement
    Inherits Element
public ref class DisplacementElement : public Element
type DisplacementElement =
    class
        inherit Element
    end

The DisplacementElement type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParentId | The element id of the parent DisplacementElement. This DisplacementElement's relative transform will be concatenated with the absolute transform of its parent.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
 | CanCategoryBeDisplaced | Indicates whether elements of the specified category are eligible as displaced elements.
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanElementsBeAddedToDisplacementSet | Indicates if these elements can be displaced by this DisplacementElement.
 | CanElementsBeDisplaced(View, ICollectionElementId) | Indicates if elements can be assigned to a new DisplacementElement.
 | CanElementsBeDisplaced(View, ICollectionElementId, ElementId) | Indicates if elements can be assigned to a new DisplacementElement.
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new DisplacementElement as a child of the specified parent DisplacementElement.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAbsoluteDisplacement | The absolute displacement applied to the displaced elements.
 | GetAdditionalElementsToDisplace | Identify a set of elements that potentially should be displaced along with a given element.
Public method | GetChildren | Returns a set of DisplacementElements which have this DisplacementElement as a parent.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetDisplacedElementIds | The ids of the elements affected by this DisplacementElement.
 | GetDisplacedElementIds(View) | Returns the element ids of all displaced elements in the specified view.
Public method | GetDisplacedElementIdsFromAllChildren | The element ids of elements displaced by this DisplacementElement and any DisplacementElement which declare this one as parent.
 | GetDisplacementElementId | The element id of the DisplacementElement that includes the specified element.
 | GetDisplacementElementIds | The element ids of all DisplacementElements owned by the specified view.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetRelativeDisplacement | The relative displacement applied to the displaced elements by this DisplacementElement.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
 | IsAllowedAsDisplacedElement | Indicates if the specified element is allowed to be displaced.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
 | IsElementDisplacedInView | Indicates if the specified element displaced in the specified View.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
 | IsNotEmpty | Validates that the input set of element ids is valid for a DisplacementElement.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
 | IsValidAsParentInView | Indicates whether the specified DisplacementElement can be used as a parent when creating a DisplacementElement in the specified view.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveDisplacedElement | Remove a displaced element from this DisplacementElement.
Public method | ResetDisplacedElements | Sets the translation of the DisplacementElement to (0, 0, 0). The DisplacementElement continues to exist, but its elements are displayed in their actual location.
Public method | SetDisplacedElementIds | Sets the ids of the elements affected by this DisplacementElement.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetRelativeDisplacement | Sets the relative displacement applied to the displaced elements by this DisplacementElement.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

The DisplacementElement does not actually change the location of any model elements; it merely causes them to be displayed in a different location.

An element may only be displaced by a single DisplacementElement in any view. Assigning an element to more than one DisplacementElement is an error condition.

A DisplacementElement can declare another DisplacementElement as its parent. In that case, its transform will be concatenated with that of the parent, and the displacement of its associated elements will be relative to the parent DisplacementElement.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DisplacementElement Properties

The DisplacementElement type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParentId | The element id of the parent DisplacementElement. This DisplacementElement's relative transform will be concatenated with the absolute transform of its parent.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

DisplacementElement Class


DisplacementElement.ParentId Property

DisplacementElementParentId Property

The element id of the parent DisplacementElement. This DisplacementElement's relative transform will be concatenated with the absolute transform of its parent.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId ParentId { get; }
Public ReadOnly Property ParentId As ElementId
    Get
public:
property ElementId^ ParentId {
    ElementId^ get ();
}
member ParentId : ElementId with get

Property Value

ElementId
See Also

Reference

DisplacementElement Class


DisplacementElement Methods

The DisplacementElement type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
 | CanCategoryBeDisplaced | Indicates whether elements of the specified category are eligible as displaced elements.
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanElementsBeAddedToDisplacementSet | Indicates if these elements can be displaced by this DisplacementElement.
 | CanElementsBeDisplaced(View, ICollectionElementId) | Indicates if elements can be assigned to a new DisplacementElement.
 | CanElementsBeDisplaced(View, ICollectionElementId, ElementId) | Indicates if elements can be assigned to a new DisplacementElement.
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new DisplacementElement as a child of the specified parent DisplacementElement.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAbsoluteDisplacement | The absolute displacement applied to the displaced elements.
 | GetAdditionalElementsToDisplace | Identify a set of elements that potentially should be displaced along with a given element.
Public method | GetChildren | Returns a set of DisplacementElements which have this DisplacementElement as a parent.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetDisplacedElementIds | The ids of the elements affected by this DisplacementElement.
 | GetDisplacedElementIds(View) | Returns the element ids of all displaced elements in the specified view.
Public method | GetDisplacedElementIdsFromAllChildren | The element ids of elements displaced by this DisplacementElement and any DisplacementElement which declare this one as parent.
 | GetDisplacementElementId | The element id of the DisplacementElement that includes the specified element.
 | GetDisplacementElementIds | The element ids of all DisplacementElements owned by the specified view.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetRelativeDisplacement | The relative displacement applied to the displaced elements by this DisplacementElement.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
 | IsAllowedAsDisplacedElement | Indicates if the specified element is allowed to be displaced.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
 | IsElementDisplacedInView | Indicates if the specified element displaced in the specified View.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
 | IsNotEmpty | Validates that the input set of element ids is valid for a DisplacementElement.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
 | IsValidAsParentInView | Indicates whether the specified DisplacementElement can be used as a parent when creating a DisplacementElement in the specified view.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveDisplacedElement | Remove a displaced element from this DisplacementElement.
Public method | ResetDisplacedElements | Sets the translation of the DisplacementElement to (0, 0, 0). The DisplacementElement continues to exist, but its elements are displayed in their actual location.
Public method | SetDisplacedElementIds | Sets the ids of the elements affected by this DisplacementElement.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetRelativeDisplacement | Sets the relative displacement applied to the displaced elements by this DisplacementElement.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DisplacementElement Class


DisplacementElement.CanCategoryBeDisplaced Method

DisplacementElementCanCategoryBeDisplaced Method

Indicates whether elements of the specified category are eligible as displaced elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CanCategoryBeDisplaced(
    ElementId categoryId
)
Public Shared Function CanCategoryBeDisplaced (
    categoryId As ElementId
) As Boolean
public:
static bool CanCategoryBeDisplaced(
    ElementId^ categoryId
)
static member CanCategoryBeDisplaced :
        categoryId : ElementId -> bool

Parameters

categoryId ElementId
Category id of element to be replaced.

Return Value

Boolean
Returns true if elements of this category can be displaced, and false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Elements may be disallowed as displaced elements for reasons other than their category.
See Also

Reference

DisplacementElement Class


DisplacementElement.CanElementsBeAddedToDisplacementSet Method

DisplacementElementCanElementsBeAddedToDisplacementSet Method

Indicates if these elements can be displaced by this DisplacementElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanElementsBeAddedToDisplacementSet(
    ICollection<ElementId> toDisplace
)
Public Function CanElementsBeAddedToDisplacementSet (
    toDisplace As ICollection(Of ElementId)
) As Boolean
public:
bool CanElementsBeAddedToDisplacementSet(
    ICollection<ElementId^>^ toDisplace
)
member CanElementsBeAddedToDisplacementSet :
        toDisplace : ICollection<ElementId> -> bool

Parameters

toDisplace ICollection ElementId
The elements to displace.

Return Value

Boolean
True if the elements can be displaced by this DisplacementElement.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DisplacementElement Class


DisplacementElement.CanElementsBeDisplaced Method

DisplacementElementCanElementsBeDisplaced Method

Overload List
Name | Description
CanElementsBeDisplaced(View, ICollectionElementId) | Indicates if elements can be assigned to a new DisplacementElement.
CanElementsBeDisplaced(View, ICollectionElementId, ElementId) | Indicates if elements can be assigned to a new DisplacementElement.
Top
See Also

Reference

DisplacementElement Class


DisplacementElement.CanElementsBeDisplaced(View, ICollection<ElementId>) Method

DisplacementElementCanElementsBeDisplaced(View, ICollectionElementId) Method

Indicates if elements can be assigned to a new DisplacementElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CanElementsBeDisplaced(
    View view,
    ICollection<ElementId> elementIds
)
Public Shared Function CanElementsBeDisplaced (
    view As View,
    elementIds As ICollection(Of ElementId)
) As Boolean
public:
static bool CanElementsBeDisplaced(
    View^ view,
    ICollection<ElementId^>^ elementIds
)
static member CanElementsBeDisplaced :
        view : View *
        elementIds : ICollection<ElementId> -> bool

Parameters

view View
The view.
elementIds ICollection ElementId
The element ids.

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
A necessary condition is that isAllowedAsDisplacedElement returns true for each individual element id. In addition, if isElementDisplaced must return the same value for all the specified element ids.
See Also

Reference

DisplacementElement Class
CanElementsBeDisplaced Overload


DisplacementElement.CanElementsBeDisplaced(View, ICollection<ElementId>, ElementId) Method

DisplacementElementCanElementsBeDisplaced(View, ICollectionElementId, ElementId) Method

Indicates if elements can be assigned to a new DisplacementElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CanElementsBeDisplaced(
    View view,
    ICollection<ElementId> elementIds,
    out ElementId commonDisplacedElementId
)
Public Shared Function CanElementsBeDisplaced (
    view As View,
    elementIds As ICollection(Of ElementId),
    <OutAttribute> ByRef commonDisplacedElementId As ElementId
) As Boolean
public:
static bool CanElementsBeDisplaced(
    View^ view,
    ICollection<ElementId^>^ elementIds,
    [OutAttribute] ElementId^% commonDisplacedElementId
)
static member CanElementsBeDisplaced :
        view : View *
        elementIds : ICollection<ElementId> *
        commonDisplacedElementId : ElementId byref -> bool

Parameters

view View
The view.
elementIds ICollection ElementId
The element ids.
commonDisplacedElementId ElementId
If this method returns true, then this is the element id of a DisplacementElement which lists all of elemIds among its displaced elements.

Return Value

Boolean
Returns true if the specified element ids can be assigned to a new DisplacementElement.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
A necessary condition is that isAllowedAsDisplacedElement returns true for each individual element id. In addition, if isElementDisplaced must return the same value for all the specified element ids.
See Also

Reference

DisplacementElement Class
CanElementsBeDisplaced Overload


DisplacementElement.Create Method

DisplacementElementCreate Method

Creates a new DisplacementElement as a child of the specified parent DisplacementElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static DisplacementElement Create(
    Document document,
    ICollection<ElementId> elementsToDisplace,
    XYZ displacement,
    View ownerDBView,
    DisplacementElement parentDisplacementElement
)
Public Shared Function Create (
    document As Document,
    elementsToDisplace As ICollection(Of ElementId),
    displacement As XYZ,
    ownerDBView As View,
    parentDisplacementElement As DisplacementElement
) As DisplacementElement
public:
static DisplacementElement^ Create(
    Document^ document,
    ICollection<ElementId^>^ elementsToDisplace,
    XYZ^ displacement,
    View^ ownerDBView,
    DisplacementElement^ parentDisplacementElement
)
static member Create :
        document : Document *
        elementsToDisplace : ICollection<ElementId> *
        displacement : XYZ *
        ownerDBView : View *
        parentDisplacementElement : DisplacementElement -> DisplacementElement

Parameters

document Document
The Document
elementsToDisplace ICollection ElementId
The elements to be displaced.
displacement XYZ
The translation to be applied to the graphics of the displaced elements.
ownerDBView View
The 3D view which will own the DisplacementElement.
parentDisplacementElement DisplacementElement
An existing DisplacementElement that will be the parent of the one being created. It must be owned by ownerDBView. The relative transform of new DisplacementElement will be concatenated with the absolute transform of the parent DisplacementElement. If the elements specified by displacedElemIds are already displaced by another DisplacementElement, then this must be that element.

Return Value

DisplacementElement
The id of the new DisplacementElement.
Exceptions
Exception | Condition
ArgumentException | #elementIds# contains no element ids. -or- ownerDBView is not a 3D view. -or- For each individual element in the set elementsToDisplace, isAllowedAsDisplacedElement must return true, and the elements must either not already be displaced in the specified view, or else they must all be displaced by the same displacement element in the view. -or- The DisplacementElement parentDisplacementElement in not owned by the view ownerDBView.
ArgumentNullException | A non-optional argument was null
Example
C#
VB
C++
F#
Copy
public static void CreateDisplacementAndPath(Document doc, View view)
{
    // Find roof
    FilteredElementCollector fec = new FilteredElementCollector(doc);
    fec.OfClass(typeof(RoofBase));
    RoofBase roof = fec.FirstElement() as RoofBase;

    // Get a geometric reference for the path
    Reference edgeRef = GetHorizontalEdgeReference(roof);

    using (Transaction t = new Transaction(doc, "CreateDisplacementAndPath"))
    {
        t.Start();
        // Create a new top level DisplacementElement
        DisplacementElement dispElem = DisplacementElement.Create(doc, new ElementId[] { roof.Id }, new XYZ(10, 0, 20), view, null);

        // Create the path associated to the element
        DisplacementPath.Create(doc, dispElem, edgeRef, 0.5);
        t.Commit();
    }
}

private static Reference GetHorizontalEdgeReference(Element elem)
{
    //Find target edge from lower face of roof
    Options options = new Options();
    options.ComputeReferences = true;

    GeometryElement geomElem = elem.get_Geometry(options);

    foreach (var geomObj in geomElem)
    {
        if (geomObj is Solid)
        {
            Solid solid = geomObj as Solid;
            var faces = solid.Faces;

            foreach (Face face in faces)
            {
                BoundingBoxUV box = face.GetBoundingBox();
                UV midpoint = (box.Min + box.Max) / 2.0;
                if (face.ComputeNormal(midpoint).Normalize().Z < -0.1) // Downward facing, this is good enough
                {
                    var edgeLoops = face.EdgeLoops;
                    foreach (EdgeArray edgeArray in edgeLoops)
                    {
                        foreach (Edge edge in edgeArray)
                        {
                            // horizontal?
                            if (Math.Abs(edge.AsCurve().ComputeDerivatives(0.0, true).BasisX.DotProduct(XYZ.BasisZ)) - 1 <= 0.00001)
                            {
                                return edge.Reference;
                            }
                        }
                    }
                }
            }
        }
    }

    return null;
}
Public Shared Sub CreateDisplacementAndPath(doc As Document, view As View)
    ' Find roof
    Dim fec As New FilteredElementCollector(doc)
    fec.OfClass(GetType(RoofBase))
    Dim roof As RoofBase = TryCast(fec.FirstElement(), RoofBase)

    ' Get a geometric reference for the path
    Dim edgeRef As Reference = GetHorizontalEdgeReference(roof)

    Using t As New Transaction(doc, "CreateDisplacementAndPath")
        t.Start()
        ' Create a new top level DisplacementElement
        Dim dispElem As DisplacementElement = DisplacementElement.Create(doc, New ElementId() {roof.Id}, New XYZ(10, 0, 20), view, Nothing)

        ' Create the path associated to the element
        DisplacementPath.Create(doc, dispElem, edgeRef, 0.5)
        t.Commit()
    End Using
End Sub

Private Shared Function GetHorizontalEdgeReference(elem As Element) As Reference
    'Find target edge from lower face of roof
    Dim options As New Options()
    options.ComputeReferences = True

    Dim geomElem As GeometryElement = elem.Geometry(options)

    For Each geomObj As GeometryObject In geomElem
        If TypeOf geomObj Is Solid Then
            Dim solid As Solid = TryCast(geomObj, Solid)
            Dim faces = solid.Faces

            For Each face As Face In faces
                Dim box As BoundingBoxUV = face.GetBoundingBox()
                Dim midpoint As UV = (box.Min + box.Max) / 2.0
                If face.ComputeNormal(midpoint).Normalize().Z < -0.1 Then
                    ' Downward facing, this is good enough
                    Dim edgeLoops = face.EdgeLoops
                    For Each edgeArray As EdgeArray In edgeLoops
                        For Each edge As Edge In edgeArray
                            ' horizontal?
                            If Math.Abs(edge.AsCurve().ComputeDerivatives(0.0, True).BasisX.DotProduct(XYZ.BasisZ)) - 1 <= 0.00001 Then
                                Return edge.Reference
                            End If
                        Next
                    Next
                End If
            Next
        End If
    Next

    Return Nothing
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

DisplacementElement Class


DisplacementElement.GetAbsoluteDisplacement Method

DisplacementElementGetAbsoluteDisplacement Method

The absolute displacement applied to the displaced elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ GetAbsoluteDisplacement()
Public Function GetAbsoluteDisplacement As XYZ
public:
XYZ^ GetAbsoluteDisplacement()
member GetAbsoluteDisplacement : unit -> XYZ

Return Value

XYZ
The absolute displacement.
Remarks
The value is the relative translation of this DisplacementElement plus the relative displacements of all of its ancestor DisplacementElements.
See Also

Reference

DisplacementElement Class


DisplacementElement.GetAdditionalElementsToDisplace Method

DisplacementElementGetAdditionalElementsToDisplace Method

Identify a set of elements that potentially should be displaced along with a given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ICollection<ElementId> GetAdditionalElementsToDisplace(
    Document document,
    View view,
    ElementId idToDisplace
)
Public Shared Function GetAdditionalElementsToDisplace (
    document As Document,
    view As View,
    idToDisplace As ElementId
) As ICollection(Of ElementId)
public:
static ICollection<ElementId^>^ GetAdditionalElementsToDisplace(
    Document^ document,
    View^ view,
    ElementId^ idToDisplace
)
static member GetAdditionalElementsToDisplace :
        document : Document *
        view : View *
        idToDisplace : ElementId -> ICollection<ElementId>

Parameters

document Document
the document
view View
the view
idToDisplace ElementId
element id of element to displace

Return Value

ICollection ElementId
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
For example, when a wall is displaced, any inserts or hosted elements should also be displaced.
See Also

Reference

DisplacementElement Class


DisplacementElement.GetChildren Method

DisplacementElementGetChildren Method

Returns a set of DisplacementElements which have this DisplacementElement as a parent.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<DisplacementElement> GetChildren()
Public Function GetChildren As IList(Of DisplacementElement)
public:
IList<DisplacementElement^>^ GetChildren()
member GetChildren : unit -> IList<DisplacementElement>

Return Value

IList DisplacementElement
The returned array is sorted by element id.
See Also

Reference

DisplacementElement Class


DisplacementElement.GetDisplacedElementIds Method

DisplacementElementGetDisplacedElementIds Method

Overload List
 | Name | Description
Public method | GetDisplacedElementIds | The ids of the elements affected by this DisplacementElement.
 | GetDisplacedElementIds(View) | Returns the element ids of all displaced elements in the specified view.
Top
See Also

Reference

DisplacementElement Class


DisplacementElement.GetDisplacedElementIds Method

DisplacementElementGetDisplacedElementIds Method

The ids of the elements affected by this DisplacementElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetDisplacedElementIds()
Public Function GetDisplacedElementIds As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetDisplacedElementIds()
member GetDisplacedElementIds : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
The element ids.
See Also

Reference

DisplacementElement Class
GetDisplacedElementIds Overload


DisplacementElement.GetDisplacedElementIds(View) Method

DisplacementElementGetDisplacedElementIds(View) Method

Returns the element ids of all displaced elements in the specified view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ICollection<ElementId> GetDisplacedElementIds(
    View view
)
Public Shared Function GetDisplacedElementIds (
    view As View
) As ICollection(Of ElementId)
public:
static ICollection<ElementId^>^ GetDisplacedElementIds(
    View^ view
)
static member GetDisplacedElementIds :
        view : View -> ICollection<ElementId>

Parameters

view View
The view.

Return Value

ICollection ElementId
The element ids.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DisplacementElement Class
GetDisplacedElementIds Overload


DisplacementElement.GetDisplacedElementIdsFromAllChildren Method

DisplacementElementGetDisplacedElementIdsFromAllChildren Method

The element ids of elements displaced by this DisplacementElement and any DisplacementElement which declare this one as parent.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetDisplacedElementIdsFromAllChildren()
Public Function GetDisplacedElementIdsFromAllChildren As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetDisplacedElementIdsFromAllChildren()
member GetDisplacedElementIdsFromAllChildren : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
The element ids.
See Also

Reference

DisplacementElement Class


DisplacementElement.GetDisplacementElementId Method

DisplacementElementGetDisplacementElementId Method

The element id of the DisplacementElement that includes the specified element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ElementId GetDisplacementElementId(
    View view,
    ElementId id
)
Public Shared Function GetDisplacementElementId (
    view As View,
    id As ElementId
) As ElementId
public:
static ElementId^ GetDisplacementElementId(
    View^ view,
    ElementId^ id
)
static member GetDisplacementElementId :
        view : View *
        id : ElementId -> ElementId

Parameters

view View
The view.
id ElementId
The element id.

Return Value

ElementId
The element id of DisplacementElement that includes the specified element id.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DisplacementElement Class


DisplacementElement.GetDisplacementElementIds Method

DisplacementElementGetDisplacementElementIds Method

The element ids of all DisplacementElements owned by the specified view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ICollection<ElementId> GetDisplacementElementIds(
    View view
)
Public Shared Function GetDisplacementElementIds (
    view As View
) As ICollection(Of ElementId)
public:
static ICollection<ElementId^>^ GetDisplacementElementIds(
    View^ view
)
static member GetDisplacementElementIds :
        view : View -> ICollection<ElementId>

Parameters

view View
The view.

Return Value

ICollection ElementId
The element ids.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DisplacementElement Class


DisplacementElement.GetRelativeDisplacement Method

DisplacementElementGetRelativeDisplacement Method

The relative displacement applied to the displaced elements by this DisplacementElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ GetRelativeDisplacement()
Public Function GetRelativeDisplacement As XYZ
public:
XYZ^ GetRelativeDisplacement()
member GetRelativeDisplacement : unit -> XYZ

Return Value

XYZ
The relative displacement.
See Also

Reference

DisplacementElement Class


DisplacementElement.IsAllowedAsDisplacedElement Method

DisplacementElementIsAllowedAsDisplacedElement Method

Indicates if the specified element is allowed to be displaced.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsAllowedAsDisplacedElement(
    Element element
)
Public Shared Function IsAllowedAsDisplacedElement (
    element As Element
) As Boolean
public:
static bool IsAllowedAsDisplacedElement(
    Element^ element
)
static member IsAllowedAsDisplacedElement :
        element : Element -> bool

Parameters

element Element
Any element.

Return Value

Boolean
Returns true if the element is eligible to be assigned to a DisplacementElement.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Exclusions include view specific elements as well as certain categories of elements.
See Also

Reference

DisplacementElement Class


DisplacementElement.IsElementDisplacedInView Method

DisplacementElementIsElementDisplacedInView Method

Indicates if the specified element displaced in the specified View.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsElementDisplacedInView(
    View view,
    ElementId id
)
Public Shared Function IsElementDisplacedInView (
    view As View,
    id As ElementId
) As Boolean
public:
static bool IsElementDisplacedInView(
    View^ view,
    ElementId^ id
)
static member IsElementDisplacedInView :
        view : View *
        id : ElementId -> bool

Parameters

view View
The view.
id ElementId
The element id.

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DisplacementElement Class


DisplacementElement.IsNotEmpty Method

DisplacementElementIsNotEmpty Method

Validates that the input set of element ids is valid for a DisplacementElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsNotEmpty(
    ICollection<ElementId> elementIds
)
Public Shared Function IsNotEmpty (
    elementIds As ICollection(Of ElementId)
) As Boolean
public:
static bool IsNotEmpty(
    ICollection<ElementId^>^ elementIds
)
static member IsNotEmpty :
        elementIds : ICollection<ElementId> -> bool

Parameters

elementIds ICollection ElementId
A set of element ids.

Return Value

Boolean
True if the set of element ids is not empty.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DisplacementElement Class


DisplacementElement.IsValidAsParentInView Method

DisplacementElementIsValidAsParentInView Method

Indicates whether the specified DisplacementElement can be used as a parent when creating a DisplacementElement in the specified view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidAsParentInView(
    View view,
    DisplacementElement parent
)
Public Shared Function IsValidAsParentInView (
    view As View,
    parent As DisplacementElement
) As Boolean
public:
static bool IsValidAsParentInView(
    View^ view,
    DisplacementElement^ parent
)
static member IsValidAsParentInView :
        view : View *
        parent : DisplacementElement -> bool

Parameters

view View
A view.
parent DisplacementElement
A DisplacementElement.

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DisplacementElement Class


DisplacementElement.RemoveDisplacedElement Method

DisplacementElementRemoveDisplacedElement Method

Remove a displaced element from this DisplacementElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveDisplacedElement(
    Element ElemToRemove
)
Public Sub RemoveDisplacedElement (
    ElemToRemove As Element
)
public:
void RemoveDisplacedElement(
    Element^ ElemToRemove
)
member RemoveDisplacedElement :
        ElemToRemove : Element -> unit

Parameters

ElemToRemove Element
The element to remove.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DisplacementElement Class


DisplacementElement.ResetDisplacedElements Method

DisplacementElementResetDisplacedElements Method

Sets the translation of the DisplacementElement to (0, 0, 0). The DisplacementElement continues to exist, but its elements are displayed in their actual location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetDisplacedElements()
Public Sub ResetDisplacedElements
public:
void ResetDisplacedElements()
member ResetDisplacedElements : unit -> unit
See Also

Reference

DisplacementElement Class


DisplacementElement.SetDisplacedElementIds Method

DisplacementElementSetDisplacedElementIds Method

Sets the ids of the elements affected by this DisplacementElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetDisplacedElementIds(
    ICollection<ElementId> displacedElemIds
)
Public Sub SetDisplacedElementIds (
    displacedElemIds As ICollection(Of ElementId)
)
public:
void SetDisplacedElementIds(
    ICollection<ElementId^>^ displacedElemIds
)
member SetDisplacedElementIds :
        displacedElemIds : ICollection<ElementId> -> unit

Parameters

displacedElemIds ICollection ElementId
Set of ids of elements to be displaced by this DisplacementElement.
Exceptions
Exception | Condition
ArgumentException | For each individual element in the set displacedElemIds, isAllowedAsDisplacedElement must return true, and the elements must not already be displaced in the specified view.
ArgumentNullException | A non-optional argument was null
See Also

Reference

DisplacementElement Class


DisplacementElement.SetRelativeDisplacement Method

DisplacementElementSetRelativeDisplacement Method

Sets the relative displacement applied to the displaced elements by this DisplacementElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetRelativeDisplacement(
    XYZ displacement
)
Public Sub SetRelativeDisplacement (
    displacement As XYZ
)
public:
void SetRelativeDisplacement(
    XYZ^ displacement
)
member SetRelativeDisplacement :
        displacement : XYZ -> unit

Parameters

displacement XYZ
The relative displacement.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DisplacementElement Class


DisplacementPath Class

A view-specific annotation related to a DisplacementElement.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBDisplacementPath

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DisplacementPath : Element
Public Class DisplacementPath
    Inherits Element
public ref class DisplacementPath : public Element
type DisplacementPath =
    class
        inherit Element
    end

The DisplacementPath type exposes the following members.

Properties
 | Name | Description
Public property | AncestorIdx | Specifies the end point of the path.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | PathStyle | Specifies the style of the path.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new DisplacementPath referencing a DisplacementElement and edge or curve and adds it to the document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
 | IsValidParam | Is the specified value a valid edge or curve parameter.
 | IsValidReference | Does the specified pick represent an edge or a curve belonging to one of the displaced elements.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetAnchorPoint | Sets the reference that determines the origin of this DisplacementPath.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The DisplacementPath is anchored to the DisplacementElement by a reference to a point on an edge of a source element of the DisplacementElement. It is represented by a single line, or a series of jogged lines, originating at the specified point on the displaced element.

The associated DisplacementElement may have a parent DisplacementElement and this parent may have its own parent DisplacementElement, producing a series of ancestors. The terminal point may be the point's original (un-displaced) location, or the corresponding point on any of the intermediate displaced locations corresponding to these ancestor DisplacementElements.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DisplacementPath Properties

The DisplacementPath type exposes the following members.

Properties
 | Name | Description
Public property | AncestorIdx | Specifies the end point of the path.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | PathStyle | Specifies the style of the path.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

DisplacementPath Class


DisplacementPath.AncestorIdx Property

DisplacementPathAncestorIdx Property

Specifies the end point of the path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int AncestorIdx { get; set; }
Public Property AncestorIdx As Integer
    Get
    Set
public:
property int AncestorIdx {
    int get ();
    void set (int value);
}
member AncestorIdx : int with get, set

Property Value

Int32
See Also

Reference

DisplacementPath Class


DisplacementPath.PathStyle Property

DisplacementPathPathStyle Property

Specifies the style of the path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DisplacementPathStyle PathStyle { get; set; }
Public Property PathStyle As DisplacementPathStyle
    Get
    Set
public:
property DisplacementPathStyle PathStyle {
    DisplacementPathStyle get ();
    void set (DisplacementPathStyle value);
}
member PathStyle : DisplacementPathStyle with get, set

Property Value

DisplacementPathStyle
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

DisplacementPath Class


DisplacementPath Methods

The DisplacementPath type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new DisplacementPath referencing a DisplacementElement and edge or curve and adds it to the document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
 | IsValidParam | Is the specified value a valid edge or curve parameter.
 | IsValidReference | Does the specified pick represent an edge or a curve belonging to one of the displaced elements.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetAnchorPoint | Sets the reference that determines the origin of this DisplacementPath.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DisplacementPath Class


DisplacementPath.Create Method

DisplacementPathCreate Method

Creates a new DisplacementPath referencing a DisplacementElement and edge or curve and adds it to the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ElementId Create(
    Document aDoc,
    DisplacementElement displacementElement,
    Reference reference,
    double param
)
Public Shared Function Create (
    aDoc As Document,
    displacementElement As DisplacementElement,
    reference As Reference,
    param As Double
) As ElementId
public:
static ElementId^ Create(
    Document^ aDoc,
    DisplacementElement^ displacementElement,
    Reference^ reference,
    double param
)
static member Create :
        aDoc : Document *
        displacementElement : DisplacementElement *
        reference : Reference *
        param : float -> ElementId

Parameters

aDoc Document
The document.
displacementElement DisplacementElement
Element id of a DisplacementElement
reference Reference
A reference that refers to an edge or curve of one of the elements displaced by the displacementElement.
param Double
A value in the range [0,1]. It will be interpreted as a parameter for the specified edge.

Return Value

ElementId
The element id of the newly created DisplacementPath.
Exceptions
Exception | Condition
ArgumentException | The value param should lie in the range [0,1]. -or- reference does not represent an edge or curve belonging to an element displaced by displacementElement.
ArgumentNullException | A non-optional argument was null
See Also

Reference

DisplacementPath Class


DisplacementPath.IsValidParam Method

DisplacementPathIsValidParam Method

Is the specified value a valid edge or curve parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidParam(
    double param
)
Public Shared Function IsValidParam (
    param As Double
) As Boolean
public:
static bool IsValidParam(
    double param
)
static member IsValidParam :
        param : float -> bool

Parameters

param Double
proposed edge parameter.

Return Value

Boolean
See Also

Reference

DisplacementPath Class


DisplacementPath.IsValidReference Method

DisplacementPathIsValidReference Method

Does the specified pick represent an edge or a curve belonging to one of the displaced elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidReference(
    DisplacementElement displacementElement,
    Reference reference
)
Public Shared Function IsValidReference (
    displacementElement As DisplacementElement,
    reference As Reference
) As Boolean
public:
static bool IsValidReference(
    DisplacementElement^ displacementElement,
    Reference^ reference
)
static member IsValidReference :
        displacementElement : DisplacementElement *
        reference : Reference -> bool

Parameters

displacementElement DisplacementElement
A DisplacementElement.
reference Reference
A pick.

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DisplacementPath Class


DisplacementPath.SetAnchorPoint Method

DisplacementPathSetAnchorPoint Method

Sets the reference that determines the origin of this DisplacementPath.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetAnchorPoint(
    DisplacementElement displacementElement,
    Reference reference,
    double param
)
Public Sub SetAnchorPoint (
    displacementElement As DisplacementElement,
    reference As Reference,
    param As Double
)
public:
void SetAnchorPoint(
    DisplacementElement^ displacementElement,
    Reference^ reference,
    double param
)
member SetAnchorPoint :
        displacementElement : DisplacementElement *
        reference : Reference *
        param : float -> unit

Parameters

displacementElement DisplacementElement
The element id of a DisplacementElement.
reference Reference
A reference of an edge or a curve in the GRep of the element corresponding to elemId.
param Double
An parameter used to specify a point on the edge.
Exceptions
Exception | Condition
ArgumentException | The value param should lie in the range [0,1]. -or- reference does not represent an edge or curve belonging to an element displaced by displacementElement.
ArgumentNullException | A non-optional argument was null
See Also

Reference

DisplacementPath Class


DisplacementPathStyle Enumeration

Used to control the graphical representation of a DisplacementPath element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DisplacementPathStyle
Public Enumeration DisplacementPathStyle
public enum class DisplacementPathStyle
type DisplacementPathStyle
Members
Member name | Value | Description
Straight | 0 | A single straight line is used to represent each stage of the displacement.
Jogged | 1 | A jogged path consisting of three straight lines is used to represent each stage of the displacement.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DisplayStyle Enumeration

Display type of the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DisplayStyle
Public Enumeration DisplayStyle
public enum class DisplayStyle
type DisplayStyle
Members
Member name | Value | Description
Undefined | 0 | View does not use Render Type
Wireframe | 1 | Wireframe
HLR | 2 | Hidden Line Removal
Shading | 3 | Shading
ShadingWithEdges | 4 | Shading With Edges
Rendering | 5 | Rendering
Realistic | 6 | Realistic
FlatColors | 7 | Flat Colors
RealisticWithEdges | 8 | Realistic With Edges
Textures | 9 | Textures
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DisplayUnit Enumeration

Describes the type of Revit display unit, metric or imperial.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DisplayUnit
Public Enumeration DisplayUnit
public enum class DisplayUnit
type DisplayUnit
Members
Member name | Value | Description
METRIC | 0 |
IMPERIAL | 1 |
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DistanceMeasuredFrom Enumeration

Indicates if the distance is measured from the top or bottom of the wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DistanceMeasuredFrom
Public Enumeration DistanceMeasuredFrom
public enum class DistanceMeasuredFrom
type DistanceMeasuredFrom
Members
Member name | Value | Description
Base | 0 | From bottom.
Top | 1 | From top.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DistributionOfNormals Enumeration

An enumeration containing the choices of how normal vectors are assigned and distributed along the surface of a polymesh. Planar faces would typically have only normal vector associated, but curved faces can have a different normal either for each facet (triangle) or each point of the tessellated polymesh.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DistributionOfNormals
Public Enumeration DistributionOfNormals
public enum class DistributionOfNormals
type DistributionOfNormals
Members
Member name | Value | Description
AtEachPoint | 0 | One normal vector is assigned to each vertex of the polymesh.
OnePerFace | 1 | There is only one common normal vector assigned to the face/polymesh.
OnEachFacet | 2 | There is one normal vector per each facet of the polymesh.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DividedPath Class

An element that consists of a set of points distributed along a path which consists of a connected set of curves and edges.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBDividedPath

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DividedPath : Element
Public Class DividedPath
    Inherits Element
public ref class DividedPath : public Element
type DividedPath =
    class
        inherit Element
    end

The DividedPath type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | BeginningIndent | The beginningIndent is an offset distance from the beginning of the first curve that determines the beginning of the range over which the layout is applied. The measurement type determines how the distance is measured.
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | DisplayNodeNumbers | Controls whether the node numbers are shown when the divided path is selected
Public property | DisplayNodes | Controls whether the points of the divided path are visible
Public property | DisplayReferenceCurves | Controls whether the curves in the path are visible
Public property | Distance | The distance between points that are distributed along the path according to the selected layout. When the layout is set to 'FixedDistance' this value can be set to desired distance. The measurement type determines how the distance is measured.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | EndIndent | The endIndent is an offset distance from the end of the last curve that determines the end of the range over which the layout is applied. The measurement type determines how the distance is measured.
Public property | FixedNumberOfPoints | The number of points used when the layout is set to 'FixedNumber'.
Public property | Flipped | If the divided path is flipped the nodes are numbered in the reverse order. It also switches the ends from which beginningIndent and endIndent are measured from.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsClosedLoop | Whether or not the path forms a closed loop.
Public property | IsCyclical | True if the first and last point coincide False otherwise.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | MaximumDistance | The maximum distance is used when the layout is set to 'MaximumSpacing'. When that layout rule is used the distance between points will not exceed this value. The measurement type determines how the distance is measured.
Public property | MeasurementType | The measurement type determines how distances are calculated. Either along a straight line between two points ('ChordLength') or along the segment of the path that connects them. ('SegmentLength').
Public property | MinimumDistance | The minimum distance is used when the layout is set to 'MinimumSpacing'. When that layout rule is used the distance between points will not fall below this value. The measurement type determines how the distance is measured.
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | NumberOfPoints | The total number of points of the divided surface. This combines the layout points and the intersection points.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SpacingRuleJustification | When the layout is set to 'FixedDistance' the points may not cover the entire range of the path. The justification determines whether the points are centered on the range, or shifted towards the start or end of the range.
Public property | SpacingRuleLayout | The layout determines how points are distributed along the path.
Public property | TotalPathLength | The sum of the curve lengths.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
 | AreCurveReferencesConnected | This checks if the references represent a connected set of curves as required by the divided path.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create(Document, IListReference) | Creates a new instance of a divided path with a default layout.
 | Create(Document, IListReference, ICollectionElementId) | Creates a new instance of a divided path whose points are determined by the intersecting elements.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | Flip | Toggle the flipped value
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIntersectingElements | Get the elements whose intersection with path produces points.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
 | IsCurveReferenceValid | This returns true if the reference represents a curve or edge that can be used to create a divided path.
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
 | IsIntersectorValidForCreation | This returns true if the intersector is an element that can be used to intersect with a newly created divided path.
Public method | IsIntersectorValidForDividedPath | This returns true if the intersector is an element that can be used to intersect with the divided path.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidBeginningIndent | Checks that the indent value does not cause the beginningIndent and endIndent to overlop
Public method | IsValidEndIndent | Checks that the indent value does not cause the beginningIndent and endIndent to overlop
 | IsValidFixedNumberOfPoints | Identifies if the indicated number of points is valid for assignment to a DividedPath with a layout type 'FixedNumber'.
Public method | IsValidMeasurementType | Checks that the measurement type enumeration value is valid
Public method | IsValidSpacingRuleJustification | Checks that the justification enumeration value is valid
Public method | IsValidSpacingRuleLayout | Checks that the spacing rule layout enumeration value is valid
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
 | SeparateReferencesIntoConnectedReferences | This function separates the input curve references into groups of connected curve references. Each group of connected curve references can be used to create a divided path.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetIntersectingElements | Set the elements whose intersection with path produces points.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The points can be the result of a uniform distribution along the path. The type of the distribution is determined by a selected 'layout'. The distance between the layout points depends on the path, the layout, and layout specific settings. In addition, points can also be the result of intersecting the path with other elements.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DividedPath Properties

The DividedPath type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | BeginningIndent | The beginningIndent is an offset distance from the beginning of the first curve that determines the beginning of the range over which the layout is applied. The measurement type determines how the distance is measured.
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | DisplayNodeNumbers | Controls whether the node numbers are shown when the divided path is selected
Public property | DisplayNodes | Controls whether the points of the divided path are visible
Public property | DisplayReferenceCurves | Controls whether the curves in the path are visible
Public property | Distance | The distance between points that are distributed along the path according to the selected layout. When the layout is set to 'FixedDistance' this value can be set to desired distance. The measurement type determines how the distance is measured.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | EndIndent | The endIndent is an offset distance from the end of the last curve that determines the end of the range over which the layout is applied. The measurement type determines how the distance is measured.
Public property | FixedNumberOfPoints | The number of points used when the layout is set to 'FixedNumber'.
Public property | Flipped | If the divided path is flipped the nodes are numbered in the reverse order. It also switches the ends from which beginningIndent and endIndent are measured from.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsClosedLoop | Whether or not the path forms a closed loop.
Public property | IsCyclical | True if the first and last point coincide False otherwise.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | MaximumDistance | The maximum distance is used when the layout is set to 'MaximumSpacing'. When that layout rule is used the distance between points will not exceed this value. The measurement type determines how the distance is measured.
Public property | MeasurementType | The measurement type determines how distances are calculated. Either along a straight line between two points ('ChordLength') or along the segment of the path that connects them. ('SegmentLength').
Public property | MinimumDistance | The minimum distance is used when the layout is set to 'MinimumSpacing'. When that layout rule is used the distance between points will not fall below this value. The measurement type determines how the distance is measured.
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | NumberOfPoints | The total number of points of the divided surface. This combines the layout points and the intersection points.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SpacingRuleJustification | When the layout is set to 'FixedDistance' the points may not cover the entire range of the path. The justification determines whether the points are centered on the range, or shifted towards the start or end of the range.
Public property | SpacingRuleLayout | The layout determines how points are distributed along the path.
Public property | TotalPathLength | The sum of the curve lengths.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

DividedPath Class


DividedPath.BeginningIndent Property

DividedPathBeginningIndent Property

The beginningIndent is an offset distance from the beginning of the first curve that determines the beginning of the range over which the layout is applied. The measurement type determines how the distance is measured.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double BeginningIndent { get; set; }
Public Property BeginningIndent As Double
    Get
    Set
public:
property double BeginningIndent {
    double get ();
    void set (double value);
}
member BeginningIndent : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The given value for beginningIndent must be between 0 and 30000 feet. -or- When setting this property: beginningIndent overlaps with endIndent
Remarks
BeginningIndent and endIndent are not allowed to overlap
See Also

Reference

DividedPath Class


DividedPath.DisplayNodeNumbers Property

DividedPathDisplayNodeNumbers Property

Controls whether the node numbers are shown when the divided path is selected

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool DisplayNodeNumbers { get; set; }
Public Property DisplayNodeNumbers As Boolean
    Get
    Set
public:
property bool DisplayNodeNumbers {
    bool get ();
    void set (bool value);
}
member DisplayNodeNumbers : bool with get, set

Property Value

Boolean
Remarks
If true the divided path will show the number of each node when the divided path is selected. If false the node numbers are hidden.
See Also

Reference

DividedPath Class


DividedPath.DisplayNodes Property

DividedPathDisplayNodes Property

Controls whether the points of the divided path are visible

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool DisplayNodes { get; set; }
Public Property DisplayNodes As Boolean
    Get
    Set
public:
property bool DisplayNodes {
    bool get ();
    void set (bool value);
}
member DisplayNodes : bool with get, set

Property Value

Boolean
Remarks
If true the nodes of the divided path are visible. If false the nodes are hidden.
See Also

Reference

DividedPath Class


DividedPath.DisplayReferenceCurves Property

DividedPathDisplayReferenceCurves Property

Controls whether the curves in the path are visible

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool DisplayReferenceCurves { get; set; }
Public Property DisplayReferenceCurves As Boolean
    Get
    Set
public:
property bool DisplayReferenceCurves {
    bool get ();
    void set (bool value);
}
member DisplayReferenceCurves : bool with get, set

Property Value

Boolean
Remarks
If true the references that represent the curves will not be hidden. If false the references that represent the curves may be hidden Only references that are curve elements can be hidden If multiple divided paths reference a curve element then the curve element is not hidden unless all divided paths request that it be hidden.
See Also

Reference

DividedPath Class


DividedPath.Distance Property

DividedPathDistance Property

The distance between points that are distributed along the path according to the selected layout. When the layout is set to 'FixedDistance' this value can be set to desired distance. The measurement type determines how the distance is measured.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Distance { get; set; }
Public Property Distance As Double
    Get
    Set
public:
property double Distance {
    double get ();
    void set (double value);
}
member Distance : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The distance is too small.
InvalidOperationException | When setting this property: The distance can only be set when the layout of this DividedPath is set to 'FixedDistance' or 'None'.
Remarks
This does not take into account points obtained by intersections with other elements. When the layout is set to 'None' the distance is the value that would be used by the 'FixedDistance' layout.
See Also

Reference

DividedPath Class


DividedPath.EndIndent Property

DividedPathEndIndent Property

The endIndent is an offset distance from the end of the last curve that determines the end of the range over which the layout is applied. The measurement type determines how the distance is measured.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double EndIndent { get; set; }
Public Property EndIndent As Double
    Get
    Set
public:
property double EndIndent {
    double get ();
    void set (double value);
}
member EndIndent : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The given value for endIndent must be between 0 and 30000 feet. -or- When setting this property: endIndent overlaps with beginningIndent
Remarks
BeginningIndent and endIndent are not allowed to overlap
See Also

Reference

DividedPath Class


DividedPath.FixedNumberOfPoints Property

DividedPathFixedNumberOfPoints Property

The number of points used when the layout is set to 'FixedNumber'.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int FixedNumberOfPoints { get; set; }
Public Property FixedNumberOfPoints As Integer
    Get
    Set
public:
property int FixedNumberOfPoints {
    int get ();
    void set (int value);
}
member FixedNumberOfPoints : int with get, set

Property Value

Int32
Exceptions
Exception | Condition
ArgumentException | When setting this property: fixedNumberOfPoints must be at least 2 and at most 200.
Remarks
To get the actual number of point use GetNumberOfPoints().
See Also

Reference

DividedPath Class


DividedPath.Flipped Property

DividedPathFlipped Property

If the divided path is flipped the nodes are numbered in the reverse order. It also switches the ends from which beginningIndent and endIndent are measured from.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Flipped { get; }
Public ReadOnly Property Flipped As Boolean
    Get
public:
property bool Flipped {
    bool get ();
}
member Flipped : bool with get

Property Value

Boolean
See Also

Reference

DividedPath Class


DividedPath.IsClosedLoop Property

DividedPathIsClosedLoop Property

Whether or not the path forms a closed loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsClosedLoop { get; }
Public ReadOnly Property IsClosedLoop As Boolean
    Get
public:
property bool IsClosedLoop {
    bool get ();
}
member IsClosedLoop : bool with get

Property Value

Boolean
Remarks
True if the path form a closed loop. False otherwise.
See Also

Reference

DividedPath Class


DividedPath.IsCyclical Property

DividedPathIsCyclical Property

True if the first and last point coincide False otherwise.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCyclical { get; }
Public ReadOnly Property IsCyclical As Boolean
    Get
public:
property bool IsCyclical {
    bool get ();
}
member IsCyclical : bool with get

Property Value

Boolean
See Also

Reference

DividedPath Class


DividedPath.MaximumDistance Property

DividedPathMaximumDistance Property

The maximum distance is used when the layout is set to 'MaximumSpacing'. When that layout rule is used the distance between points will not exceed this value. The measurement type determines how the distance is measured.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double MaximumDistance { get; set; }
Public Property MaximumDistance As Double
    Get
    Set
public:
property double MaximumDistance {
    double get ();
    void set (double value);
}
member MaximumDistance : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The maximumDistance is too small.
See Also

Reference

DividedPath Class


DividedPath.MeasurementType Property

DividedPathMeasurementType Property

The measurement type determines how distances are calculated. Either along a straight line between two points ('ChordLength') or along the segment of the path that connects them. ('SegmentLength').

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DividedPathMeasurementType MeasurementType { get; set; }
Public Property MeasurementType As DividedPathMeasurementType
    Get
    Set
public:
property DividedPathMeasurementType MeasurementType {
    DividedPathMeasurementType get ();
    void set (DividedPathMeasurementType value);
}
member MeasurementType : DividedPathMeasurementType with get, set

Property Value

DividedPathMeasurementType
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: Invalid measurementType -or- When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

DividedPath Class


DividedPath.MinimumDistance Property

DividedPathMinimumDistance Property

The minimum distance is used when the layout is set to 'MinimumSpacing'. When that layout rule is used the distance between points will not fall below this value. The measurement type determines how the distance is measured.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double MinimumDistance { get; set; }
Public Property MinimumDistance As Double
    Get
    Set
public:
property double MinimumDistance {
    double get ();
    void set (double value);
}
member MinimumDistance : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The minimumDistance is too small.
See Also

Reference

DividedPath Class


DividedPath.NumberOfPoints Property

DividedPathNumberOfPoints Property

The total number of points of the divided surface. This combines the layout points and the intersection points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int NumberOfPoints { get; }
Public ReadOnly Property NumberOfPoints As Integer
    Get
public:
property int NumberOfPoints {
    int get ();
}
member NumberOfPoints : int with get

Property Value

Int32
See Also

Reference

DividedPath Class


DividedPath.SpacingRuleJustification Property

DividedPathSpacingRuleJustification Property

When the layout is set to 'FixedDistance' the points may not cover the entire range of the path. The justification determines whether the points are centered on the range, or shifted towards the start or end of the range.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SpacingRuleJustification SpacingRuleJustification { get; set; }
Public Property SpacingRuleJustification As SpacingRuleJustification
    Get
    Set
public:
property SpacingRuleJustification SpacingRuleJustification {
    SpacingRuleJustification get ();
    void set (SpacingRuleJustification value);
}
member SpacingRuleJustification : SpacingRuleJustification with get, set

Property Value

SpacingRuleJustification
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: Invalid justification -or- When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

DividedPath Class


DividedPath.SpacingRuleLayout Property

DividedPathSpacingRuleLayout Property

The layout determines how points are distributed along the path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SpacingRuleLayout SpacingRuleLayout { get; set; }
Public Property SpacingRuleLayout As SpacingRuleLayout
    Get
    Set
public:
property SpacingRuleLayout SpacingRuleLayout {
    SpacingRuleLayout get ();
    void set (SpacingRuleLayout value);
}
member SpacingRuleLayout : SpacingRuleLayout with get, set

Property Value

SpacingRuleLayout
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: Invalid layout -or- When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

DividedPath Class


DividedPath.TotalPathLength Property

DividedPathTotalPathLength Property

The sum of the curve lengths.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double TotalPathLength { get; }
Public ReadOnly Property TotalPathLength As Double
    Get
public:
property double TotalPathLength {
    double get ();
}
member TotalPathLength : float with get

Property Value

Double
See Also

Reference

DividedPath Class


DividedPath Methods

The DividedPath type exposes the following members.

Methods
 | Name | Description
 | AreCurveReferencesConnected | This checks if the references represent a connected set of curves as required by the divided path.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create(Document, IListReference) | Creates a new instance of a divided path with a default layout.
 | Create(Document, IListReference, ICollectionElementId) | Creates a new instance of a divided path whose points are determined by the intersecting elements.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | Flip | Toggle the flipped value
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIntersectingElements | Get the elements whose intersection with path produces points.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
 | IsCurveReferenceValid | This returns true if the reference represents a curve or edge that can be used to create a divided path.
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
 | IsIntersectorValidForCreation | This returns true if the intersector is an element that can be used to intersect with a newly created divided path.
Public method | IsIntersectorValidForDividedPath | This returns true if the intersector is an element that can be used to intersect with the divided path.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidBeginningIndent | Checks that the indent value does not cause the beginningIndent and endIndent to overlop
Public method | IsValidEndIndent | Checks that the indent value does not cause the beginningIndent and endIndent to overlop
 | IsValidFixedNumberOfPoints | Identifies if the indicated number of points is valid for assignment to a DividedPath with a layout type 'FixedNumber'.
Public method | IsValidMeasurementType | Checks that the measurement type enumeration value is valid
Public method | IsValidSpacingRuleJustification | Checks that the justification enumeration value is valid
Public method | IsValidSpacingRuleLayout | Checks that the spacing rule layout enumeration value is valid
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
 | SeparateReferencesIntoConnectedReferences | This function separates the input curve references into groups of connected curve references. Each group of connected curve references can be used to create a divided path.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetIntersectingElements | Set the elements whose intersection with path produces points.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DividedPath Class


DividedPath.AreCurveReferencesConnected Method

DividedPathAreCurveReferencesConnected Method

This checks if the references represent a connected set of curves as required by the divided path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool AreCurveReferencesConnected(
    Document document,
    IList<Reference> curveReferences
)
Public Shared Function AreCurveReferencesConnected (
    document As Document,
    curveReferences As IList(Of Reference)
) As Boolean
public:
static bool AreCurveReferencesConnected(
    Document^ document,
    IList<Reference^>^ curveReferences
)
static member AreCurveReferencesConnected :
        document : Document *
        curveReferences : IList<Reference> -> bool

Parameters

document Document
The document.
curveReferences IList Reference
The references.

Return Value

Boolean
True if the arguments passed the checks, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DividedPath Class


DividedPath.Create Method

DividedPathCreate Method

Overload List
Name | Description
Create(Document, IListReference) | Creates a new instance of a divided path with a default layout.
Create(Document, IListReference, ICollectionElementId) | Creates a new instance of a divided path whose points are determined by the intersecting elements.
Top
See Also

Reference

DividedPath Class


DividedPath.Create(Document, IList<Reference>) Method

DividedPathCreate(Document, IListReference) Method

Creates a new instance of a divided path with a default layout.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static DividedPath Create(
    Document document,
    IList<Reference> curveReferences
)
Public Shared Function Create (
    document As Document,
    curveReferences As IList(Of Reference)
) As DividedPath
public:
static DividedPath^ Create(
    Document^ document,
    IList<Reference^>^ curveReferences
)
static member Create :
        document : Document *
        curveReferences : IList<Reference> -> DividedPath

Parameters

document Document
The document.
curveReferences IList Reference
References that represent a connected set of curves or edges.

Return Value

DividedPath
The newly created divided path.
Exceptions
Exception | Condition
ArgumentException | The document does not allow creation of a divided path. -or- Not all curve references in curveReferences represent a curve or an edge -or- The references in curveReferences are not connected.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
See Also

Reference

DividedPath Class
Create Overload


DividedPath.Create(Document, IList<Reference>, ICollection<ElementId>) Method

DividedPathCreate(Document, IListReference, ICollectionElementId) Method

Creates a new instance of a divided path whose points are determined by the intersecting elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static DividedPath Create(
    Document document,
    IList<Reference> curveReferences,
    ICollection<ElementId> intersectors
)
Public Shared Function Create (
    document As Document,
    curveReferences As IList(Of Reference),
    intersectors As ICollection(Of ElementId)
) As DividedPath
public:
static DividedPath^ Create(
    Document^ document,
    IList<Reference^>^ curveReferences,
    ICollection<ElementId^>^ intersectors
)
static member Create :
        document : Document *
        curveReferences : IList<Reference> *
        intersectors : ICollection<ElementId> -> DividedPath

Parameters

document Document
The document.
curveReferences IList Reference
References that represent a connected set of curves or edges.
intersectors ICollection ElementId
Elements whose intersection with the curve references result in additional divisions.

Return Value

DividedPath
The newly created divided path.
Exceptions
Exception | Condition
ArgumentException | The document does not allow creation of a divided path. -or- Not all curve references in curveReferences represent a curve or an edge -or- The references in curveReferences are not connected. -or- Not all intersecting elements in intersectors are valid.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
Intersectors can be curve elements, datum planes, or other divided paths.
See Also

Reference

DividedPath Class
Create Overload


DividedPath.Flip Method

DividedPathFlip Method

Toggle the flipped value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Flip()
Public Sub Flip
public:
void Flip()
member Flip : unit -> unit
See Also

Reference

DividedPath Class


DividedPath.GetIntersectingElements Method

DividedPathGetIntersectingElements Method

Get the elements whose intersection with path produces points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetIntersectingElements()
Public Function GetIntersectingElements As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetIntersectingElements()
member GetIntersectingElements : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
See Also

Reference

DividedPath Class


DividedPath.IsCurveReferenceValid Method

DividedPathIsCurveReferenceValid Method

This returns true if the reference represents a curve or edge that can be used to create a divided path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsCurveReferenceValid(
    Document document,
    Reference curveReference
)
Public Shared Function IsCurveReferenceValid (
    document As Document,
    curveReference As Reference
) As Boolean
public:
static bool IsCurveReferenceValid(
    Document^ document,
    Reference^ curveReference
)
static member IsCurveReferenceValid :
        document : Document *
        curveReference : Reference -> bool

Parameters

document Document
The document.
curveReference Reference
The reference.

Return Value

Boolean
True if the reference can be used to create a divided path, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DividedPath Class


DividedPath.IsIntersectorValidForCreation Method

DividedPathIsIntersectorValidForCreation Method

This returns true if the intersector is an element that can be used to intersect with a newly created divided path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsIntersectorValidForCreation(
    Document document,
    ElementId intersector
)
Public Shared Function IsIntersectorValidForCreation (
    document As Document,
    intersector As ElementId
) As Boolean
public:
static bool IsIntersectorValidForCreation(
    Document^ document,
    ElementId^ intersector
)
static member IsIntersectorValidForCreation :
        document : Document *
        intersector : ElementId -> bool

Parameters

document Document
The document.
intersector ElementId
The intersector.

Return Value

Boolean
True if the reference can be used to create a divided path, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Intersectors can be curve elements, datum planes, or divided paths. This function is should not be used to validate the input to SetIntersectors() because it does not check for self intersection of any other circular dependencies between intersectors. Use isIntersectorValidForDividedPath() instead.
See Also

Reference

DividedPath Class


DividedPath.IsIntersectorValidForDividedPath Method

DividedPathIsIntersectorValidForDividedPath Method

This returns true if the intersector is an element that can be used to intersect with the divided path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsIntersectorValidForDividedPath(
    ElementId intersector
)
Public Function IsIntersectorValidForDividedPath (
    intersector As ElementId
) As Boolean
public:
bool IsIntersectorValidForDividedPath(
    ElementId^ intersector
)
member IsIntersectorValidForDividedPath :
        intersector : ElementId -> bool

Parameters

intersector ElementId
The intersector.

Return Value

Boolean
True if the reference can be used to create a divided path, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Intersectors can be curve elements, datum planes, or other divided paths. Note that divided paths that have this divided path as an intersector (either directly, or recursively) are not valid. Also, if the nesting of divided path intersectors that have intersectors is more than 5 levels deep the divided path intersector is considered invalid as well.
See Also

Reference

DividedPath Class


DividedPath.IsValidBeginningIndent Method

DividedPathIsValidBeginningIndent Method

Checks that the indent value does not cause the beginningIndent and endIndent to overlop

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidBeginningIndent(
    double beginningIndent
)
Public Function IsValidBeginningIndent (
    beginningIndent As Double
) As Boolean
public:
bool IsValidBeginningIndent(
    double beginningIndent
)
member IsValidBeginningIndent :
        beginningIndent : float -> bool

Parameters

beginningIndent Double

Return Value

Boolean
See Also

Reference

DividedPath Class


DividedPath.IsValidEndIndent Method

DividedPathIsValidEndIndent Method

Checks that the indent value does not cause the beginningIndent and endIndent to overlop

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidEndIndent(
    double endIndent
)
Public Function IsValidEndIndent (
    endIndent As Double
) As Boolean
public:
bool IsValidEndIndent(
    double endIndent
)
member IsValidEndIndent :
        endIndent : float -> bool

Parameters

endIndent Double

Return Value

Boolean
See Also

Reference

DividedPath Class


DividedPath.IsValidFixedNumberOfPoints Method

DividedPathIsValidFixedNumberOfPoints Method

Identifies if the indicated number of points is valid for assignment to a DividedPath with a layout type 'FixedNumber'.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidFixedNumberOfPoints(
    int fixedNumberOfPoints
)
Public Shared Function IsValidFixedNumberOfPoints (
    fixedNumberOfPoints As Integer
) As Boolean
public:
static bool IsValidFixedNumberOfPoints(
    int fixedNumberOfPoints
)
static member IsValidFixedNumberOfPoints :
        fixedNumberOfPoints : int -> bool

Parameters

fixedNumberOfPoints Int32

Return Value

Boolean
See Also

Reference

DividedPath Class


DividedPath.IsValidMeasurementType Method

DividedPathIsValidMeasurementType Method

Checks that the measurement type enumeration value is valid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidMeasurementType(
    DividedPathMeasurementType measurementType
)
Public Function IsValidMeasurementType (
    measurementType As DividedPathMeasurementType
) As Boolean
public:
bool IsValidMeasurementType(
    DividedPathMeasurementType measurementType
)
member IsValidMeasurementType :
        measurementType : DividedPathMeasurementType -> bool

Parameters

measurementType DividedPathMeasurementType

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

DividedPath Class


DividedPath.IsValidSpacingRuleJustification Method

DividedPathIsValidSpacingRuleJustification Method

Checks that the justification enumeration value is valid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidSpacingRuleJustification(
    SpacingRuleJustification justification
)
Public Function IsValidSpacingRuleJustification (
    justification As SpacingRuleJustification
) As Boolean
public:
bool IsValidSpacingRuleJustification(
    SpacingRuleJustification justification
)
member IsValidSpacingRuleJustification :
        justification : SpacingRuleJustification -> bool

Parameters

justification SpacingRuleJustification

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

DividedPath Class


DividedPath.IsValidSpacingRuleLayout Method

DividedPathIsValidSpacingRuleLayout Method

Checks that the spacing rule layout enumeration value is valid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidSpacingRuleLayout(
    SpacingRuleLayout layout
)
Public Function IsValidSpacingRuleLayout (
    layout As SpacingRuleLayout
) As Boolean
public:
bool IsValidSpacingRuleLayout(
    SpacingRuleLayout layout
)
member IsValidSpacingRuleLayout :
        layout : SpacingRuleLayout -> bool

Parameters

layout SpacingRuleLayout

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

DividedPath Class


DividedPath.SeparateReferencesIntoConnectedReferences Method

DividedPathSeparateReferencesIntoConnectedReferences Method

This function separates the input curve references into groups of connected curve references. Each group of connected curve references can be used to create a divided path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<IList<Reference>> SeparateReferencesIntoConnectedReferences(
    Document document,
    IList<Reference> curveReferences
)
Public Shared Function SeparateReferencesIntoConnectedReferences (
    document As Document,
    curveReferences As IList(Of Reference)
) As IList(Of IList(Of Reference))
public:
static IList<IList<Reference^>^>^ SeparateReferencesIntoConnectedReferences(
    Document^ document,
    IList<Reference^>^ curveReferences
)
static member SeparateReferencesIntoConnectedReferences :
        document : Document *
        curveReferences : IList<Reference> -> IList<IList<Reference>>

Parameters

document Document
The document.
curveReferences IList Reference
The references.

Return Value

IList IList Reference
The grouped references
Exceptions
Exception | Condition
ArgumentException | Not all curve references in curveReferences represent a curve or an edge
ArgumentNullException | A non-optional argument was null
InvalidOperationException | this operation failed.
See Also

Reference

DividedPath Class


DividedPath.SetIntersectingElements Method

DividedPathSetIntersectingElements Method

Set the elements whose intersection with path produces points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetIntersectingElements(
    ICollection<ElementId> intersectors
)
Public Sub SetIntersectingElements (
    intersectors As ICollection(Of ElementId)
)
public:
void SetIntersectingElements(
    ICollection<ElementId^>^ intersectors
)
member SetIntersectingElements :
        intersectors : ICollection<ElementId> -> unit

Parameters

intersectors ICollection ElementId
Exceptions
Exception | Condition
ArgumentException | Not all intersecting elements in intersectors are valid.
ArgumentNullException | A non-optional argument was null
See Also

Reference

DividedPath Class


DividedPathMeasurementType Enumeration

DividedPath measurement type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DividedPathMeasurementType
Public Enumeration DividedPathMeasurementType
public enum class DividedPathMeasurementType
type DividedPathMeasurementType
Members
Member name | Value | Description
ChordLength | 0 | Distances between two points are measured along a straight line between the points.
SegmentLength | 1 | Distances between two points are measured along the path segment between the points.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DividedSurface Class

An element that represents a mesh on the surface of another element, a family instance, an import instance or a geometry combination, and a tile pattern built on that mesh.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBDividedSurface

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DividedSurface : Element
Public Class DividedSurface
    Inherits Element
public ref class DividedSurface : public Element
type DividedSurface =
    class
        inherit Element
    end

The DividedSurface type exposes the following members.

Properties
 | Name | Description
Public property | AllGridRotation | Angle of rotation applied to the U- and V- directions together.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | BorderTile | Determines the handling of tiles that overlap the surface's boundary.
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | ComponentRotation | The rotation of the pattern by a multiple of 90 degrees.
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | Host | The element whose surface has been divided.
Public property | HostReference | A reference to the divided face on the host.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsComponentFlipped | Whether the pattern is flipped.
Public property | IsComponentMirrored | Whether the pattern is mirror-imaged.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | NumberOfUGridlines | Get the number of U-gridlines used on the surface.
Public property | NumberOfVGridlines | Get the number of V-gridlines used on the surface.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | UPatternIndent | The offset applied to the pattern by an integral number of grid nodes in the U-direction.
Public property | USpacingRule | Access to the rule for laying out the first series of equidistant parallel lines on the surface.
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | VPatternIndent | The offset applied to the pattern by an integral number of grid nodes in the V-direction.
Public property | VSpacingRule | Access to the rule for laying out the second series of equidistant parallel lines on the surface.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | AddIntersectionElement | Adds an intersection element to the divided surface.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
 | CanBeDivided | This returns true if the reference represents a face that can be used to create a divided surface.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeIntersectionElement | Checks if the element can be an intersection reference.
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new instance of a divided surface with a default layout.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAllIntersectionElements | Gets all intersection elements which produce division lines.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
 | GetDividedSurfaceForReference | Get a divided surface for a given reference. Returns null if the reference does not host a divided surface.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetGridNodeLocation | Specify whether a particular grid node is interior to the surface, on the boundary, or outside the boundary.
Public method | GetGridNodeReference | Get a reference to the geometric point associated with a grid node.
Public method | GetGridNodeUV | Get the position of a grid node in UV coordinates in the surface.
Public method | GetGridSegmentReference | Get a reference to a line segment connecting two adjacent grid nodes.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
 | GetReferencesWithDividedSurfaces | For a given host element get references to all the faces that host a divided surface
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTileFamilyInstance | Get a reference to a tile element associated with a given seed node.
Public method | GetTileReference | Get a reference to one of the tile surfaces associated with a given seed node.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSeedNode | Reports whether a grid node is a "seed node," a node that is associated with one or more tiles.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveAllIntersectionElements | Removes all the intersection elements from a divided surface.
Public method | RemoveIntersectionElement | Removes an intersection element from a divided surface.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The type of this element may be set to: a TilePattern element, a FamilySymbol element from a Curtain Panel family.
Example
C#
VB
C++
F#
Copy
public void TileSurface(Document document, Form form)
{
    // cover surface with OctagonRotate tile pattern
    TilePatterns tilePatterns = document.Settings.TilePatterns;
    foreach (Reference r in DividedSurface.GetReferencesWithDividedSurfaces(form))
    {
        DividedSurface ds = DividedSurface.GetDividedSurfaceForReference(document, r);
        ds.ChangeTypeId(tilePatterns.GetTilePattern(TilePatternsBuiltIn.OctagonRotate).Id);
    }
}
Public Sub TileSurface(document As Document, form As Form)
    ' cover surface with OctagonRotate tile pattern
    Dim tilePatterns As TilePatterns = document.Settings.TilePatterns
    For Each r As Reference In DividedSurface.GetReferencesWithDividedSurfaces(form)
        Dim ds As DividedSurface = DividedSurface.GetDividedSurfaceForReference(document, r)
        ds.ChangeTypeId(tilePatterns.GetTilePattern(TilePatternsBuiltIn.OctagonRotate).Id)
    Next
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DividedSurface Properties

The DividedSurface type exposes the following members.

Properties
 | Name | Description
Public property | AllGridRotation | Angle of rotation applied to the U- and V- directions together.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | BorderTile | Determines the handling of tiles that overlap the surface's boundary.
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | ComponentRotation | The rotation of the pattern by a multiple of 90 degrees.
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | Host | The element whose surface has been divided.
Public property | HostReference | A reference to the divided face on the host.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsComponentFlipped | Whether the pattern is flipped.
Public property | IsComponentMirrored | Whether the pattern is mirror-imaged.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | NumberOfUGridlines | Get the number of U-gridlines used on the surface.
Public property | NumberOfVGridlines | Get the number of V-gridlines used on the surface.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | UPatternIndent | The offset applied to the pattern by an integral number of grid nodes in the U-direction.
Public property | USpacingRule | Access to the rule for laying out the first series of equidistant parallel lines on the surface.
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | VPatternIndent | The offset applied to the pattern by an integral number of grid nodes in the V-direction.
Public property | VSpacingRule | Access to the rule for laying out the second series of equidistant parallel lines on the surface.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

DividedSurface Class


DividedSurface.AllGridRotation Property

DividedSurfaceAllGridRotation Property

Angle of rotation applied to the U- and V- directions together.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double AllGridRotation { get; set; }
Public Property AllGridRotation As Double
    Get
    Set
public:
property double AllGridRotation {
    double get ();
    void set (double value);
}
member AllGridRotation : float with get, set

Property Value

Double
See Also

Reference

DividedSurface Class


DividedSurface.BorderTile Property

DividedSurfaceBorderTile Property

Determines the handling of tiles that overlap the surface's boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BorderTile BorderTile { get; set; }
Public Property BorderTile As BorderTile
    Get
    Set
public:
property BorderTile BorderTile {
    BorderTile get ();
    void set (BorderTile value);
}
member BorderTile : BorderTile with get, set

Property Value

BorderTile
See Also

Reference

DividedSurface Class


DividedSurface.ComponentRotation Property

DividedSurfaceComponentRotation Property

The rotation of the pattern by a multiple of 90 degrees.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ComponentRotation ComponentRotation { get; set; }
Public Property ComponentRotation As ComponentRotation
    Get
    Set
public:
property ComponentRotation ComponentRotation {
    ComponentRotation get ();
    void set (ComponentRotation value);
}
member ComponentRotation : ComponentRotation with get, set

Property Value

ComponentRotation
Remarks
This property has no effect unless a pattern is selected (the ObjectType property is not ).
See Also

Reference

DividedSurface Class


DividedSurface.Host Property

DividedSurfaceHost Property

The element whose surface has been divided.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Element Host { get; }
Public ReadOnly Property Host As Element
    Get
public:
property Element^ Host {
    Element^ get ();
}
member Host : Element with get

Property Value

Element
See Also

Reference

DividedSurface Class


DividedSurface.HostReference Property

DividedSurfaceHostReference Property

A reference to the divided face on the host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Reference HostReference { get; }
Public ReadOnly Property HostReference As Reference
    Get
public:
property Reference^ HostReference {
    Reference^ get ();
}
member HostReference : Reference with get

Property Value

Reference
Remarks
This is the same as the hostReference argument to the NewDividedSurface method of FamilyItemFactory.
See Also

Reference

DividedSurface Class


DividedSurface.IsComponentFlipped Property

DividedSurfaceIsComponentFlipped Property

Whether the pattern is flipped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsComponentFlipped { get; set; }
Public Property IsComponentFlipped As Boolean
    Get
    Set
public:
property bool IsComponentFlipped {
    bool get ();
    void set (bool value);
}
member IsComponentFlipped : bool with get, set

Property Value

Boolean
Remarks
This property has no effect unless a pattern is selected (the ObjectType property is not ). Changing this flag effectively reflects the component through its XY-plane, which is equivalent to reflecting it through the original surface.
See Also

Reference

DividedSurface Class


DividedSurface.IsComponentMirrored Property

DividedSurfaceIsComponentMirrored Property

Whether the pattern is mirror-imaged.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsComponentMirrored { get; set; }
Public Property IsComponentMirrored As Boolean
    Get
    Set
public:
property bool IsComponentMirrored {
    bool get ();
    void set (bool value);
}
member IsComponentMirrored : bool with get, set

Property Value

Boolean
Remarks
This property has no effect unless a pattern is selected (the ObjectType property is not ). Changing this flag effectively reflects the component through its YZ-plane.
See Also

Reference

DividedSurface Class


DividedSurface.NumberOfUGridlines Property

DividedSurfaceNumberOfUGridlines Property

Get the number of U-gridlines used on the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int NumberOfUGridlines { get; }
Public ReadOnly Property NumberOfUGridlines As Integer
    Get
public:
property int NumberOfUGridlines {
    int get ();
}
member NumberOfUGridlines : int with get

Property Value

Int32
See Also

Reference

DividedSurface Class


DividedSurface.NumberOfVGridlines Property

DividedSurfaceNumberOfVGridlines Property

Get the number of V-gridlines used on the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int NumberOfVGridlines { get; }
Public ReadOnly Property NumberOfVGridlines As Integer
    Get
public:
property int NumberOfVGridlines {
    int get ();
}
member NumberOfVGridlines : int with get

Property Value

Int32
See Also

Reference

DividedSurface Class


DividedSurface.UPatternIndent Property

DividedSurfaceUPatternIndent Property

The offset applied to the pattern by an integral number of grid nodes in the U-direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int UPatternIndent { get; set; }
Public Property UPatternIndent As Integer
    Get
    Set
public:
property int UPatternIndent {
    int get ();
    void set (int value);
}
member UPatternIndent : int with get, set

Property Value

Int32
See Also

Reference

DividedSurface Class


DividedSurface.USpacingRule Property

DividedSurfaceUSpacingRule Property

Access to the rule for laying out the first series of equidistant parallel lines on the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SpacingRule USpacingRule { get; }
Public ReadOnly Property USpacingRule As SpacingRule
    Get
public:
property SpacingRule^ USpacingRule {
    SpacingRule^ get ();
}
member USpacingRule : SpacingRule with get

Property Value

SpacingRule
See Also

Reference

DividedSurface Class


DividedSurface.VPatternIndent Property

DividedSurfaceVPatternIndent Property

The offset applied to the pattern by an integral number of grid nodes in the V-direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int VPatternIndent { get; set; }
Public Property VPatternIndent As Integer
    Get
    Set
public:
property int VPatternIndent {
    int get ();
    void set (int value);
}
member VPatternIndent : int with get, set

Property Value

Int32
See Also

Reference

DividedSurface Class


DividedSurface.VSpacingRule Property

DividedSurfaceVSpacingRule Property

Access to the rule for laying out the second series of equidistant parallel lines on the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SpacingRule VSpacingRule { get; }
Public ReadOnly Property VSpacingRule As SpacingRule
    Get
public:
property SpacingRule^ VSpacingRule {
    SpacingRule^ get ();
}
member VSpacingRule : SpacingRule with get

Property Value

SpacingRule
See Also

Reference

DividedSurface Class


DividedSurface Methods

The DividedSurface type exposes the following members.

Methods
 | Name | Description
Public method | AddIntersectionElement | Adds an intersection element to the divided surface.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
 | CanBeDivided | This returns true if the reference represents a face that can be used to create a divided surface.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeIntersectionElement | Checks if the element can be an intersection reference.
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new instance of a divided surface with a default layout.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAllIntersectionElements | Gets all intersection elements which produce division lines.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
 | GetDividedSurfaceForReference | Get a divided surface for a given reference. Returns null if the reference does not host a divided surface.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetGridNodeLocation | Specify whether a particular grid node is interior to the surface, on the boundary, or outside the boundary.
Public method | GetGridNodeReference | Get a reference to the geometric point associated with a grid node.
Public method | GetGridNodeUV | Get the position of a grid node in UV coordinates in the surface.
Public method | GetGridSegmentReference | Get a reference to a line segment connecting two adjacent grid nodes.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
 | GetReferencesWithDividedSurfaces | For a given host element get references to all the faces that host a divided surface
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTileFamilyInstance | Get a reference to a tile element associated with a given seed node.
Public method | GetTileReference | Get a reference to one of the tile surfaces associated with a given seed node.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSeedNode | Reports whether a grid node is a "seed node," a node that is associated with one or more tiles.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveAllIntersectionElements | Removes all the intersection elements from a divided surface.
Public method | RemoveIntersectionElement | Removes an intersection element from a divided surface.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DividedSurface Class


DividedSurface.AddIntersectionElement Method

DividedSurfaceAddIntersectionElement Method

Adds an intersection element to the divided surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddIntersectionElement(
    ElementId newIntersectionElemId
)
Public Sub AddIntersectionElement (
    newIntersectionElemId As ElementId
)
public:
void AddIntersectionElement(
    ElementId^ newIntersectionElemId
)
member AddIntersectionElement :
        newIntersectionElemId : ElementId -> unit

Parameters

newIntersectionElemId ElementId
The intersection element to be added.
Exceptions
Exception | Condition
ArgumentException | The element newIntersectionElemId is not a level, grid, reference plane, or a curve element whose category is lines and reference lines.
ArgumentNullException | A non-optional argument was null
See Also

Reference

DividedSurface Class


DividedSurface.CanBeDivided Method

DividedSurfaceCanBeDivided Method

This returns true if the reference represents a face that can be used to create a divided surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CanBeDivided(
    Document document,
    Reference reference
)
Public Shared Function CanBeDivided (
    document As Document,
    reference As Reference
) As Boolean
public:
static bool CanBeDivided(
    Document^ document,
    Reference^ reference
)
static member CanBeDivided :
        document : Document *
        reference : Reference -> bool

Parameters

document Document
The document.
reference Reference
The reference.

Return Value

Boolean
True if the reference can be used to create a divided surface, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DividedSurface Class


DividedSurface.CanBeIntersectionElement Method

DividedSurfaceCanBeIntersectionElement Method

Checks if the element can be an intersection reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanBeIntersectionElement(
    ElementId id
)
Public Function CanBeIntersectionElement (
    id As ElementId
) As Boolean
public:
bool CanBeIntersectionElement(
    ElementId^ id
)
member CanBeIntersectionElement :
        id : ElementId -> bool

Parameters

id ElementId
The element to be checked.

Return Value

Boolean
True if the element can be an intersection reference., false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
The element must be a level, grid, reference plane, or a curve element whose category is lines and reference lines.
See Also

Reference

DividedSurface Class


DividedSurface.Create Method

DividedSurfaceCreate Method

Creates a new instance of a divided surface with a default layout.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static DividedSurface Create(
    Document document,
    Reference faceReference
)
Public Shared Function Create (
    document As Document,
    faceReference As Reference
) As DividedSurface
public:
static DividedSurface^ Create(
    Document^ document,
    Reference^ faceReference
)
static member Create :
        document : Document *
        faceReference : Reference -> DividedSurface

Parameters

document Document
The document.
faceReference Reference
Reference that represents a face.

Return Value

DividedSurface
The newly created divided surface.
Exceptions
Exception | Condition
ArgumentException | The document does not allow creation of a divided surface. -or- Reference is unstable import element -or- Reference does not represent a face -or- Reference already hosts a divided surface
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Example
C#
VB
C++
F#
Copy
public void DivideSurface(Document document, Form form)
{
    Autodesk.Revit.ApplicationServices.Application application = document.Application;
    Options opt = application.Create.NewGeometryOptions();
    opt.ComputeReferences = true;

    Autodesk.Revit.DB.GeometryElement geomElem = form.get_Geometry(opt);
    foreach (GeometryObject geomObj in geomElem)
    {
        Solid solid = geomObj as Solid;
        foreach (Face face in solid.Faces)
        {
            if (face.Reference != null)
            {
                DividedSurface ds = DividedSurface.Create(document,face.Reference);
                // create a divided surface with fixed number of U and V grid lines
                SpacingRule srU = ds.USpacingRule;
                srU.SetLayoutFixedNumber(16, SpacingRuleJustification.Center, 0, 0);

                SpacingRule srV = ds.VSpacingRule;
                srV.SetLayoutFixedNumber(24, SpacingRuleJustification.Center, 0, 0);

                break;  // just divide one face of form
            }
        }
    }
}
Public Sub DivideSurface(document As Document, form As Form)
    Dim application As Autodesk.Revit.ApplicationServices.Application = document.Application
    Dim opt As Options = application.Create.NewGeometryOptions()
    opt.ComputeReferences = True

    Dim geomElem As Autodesk.Revit.DB.GeometryElement = form.Geometry(opt)
    For Each geomObj As GeometryObject In geomElem
        Dim solid As Solid = TryCast(geomObj, Solid)
        For Each face As Face In solid.Faces
            If face.Reference IsNot Nothing Then
                Dim ds As DividedSurface = DividedSurface.Create(document, face.Reference)
                ' create a divided surface with fixed number of U and V grid lines
                Dim srU As SpacingRule = ds.USpacingRule
                srU.SetLayoutFixedNumber(16, SpacingRuleJustification.Center, 0, 0)

                Dim srV As SpacingRule = ds.VSpacingRule
                srV.SetLayoutFixedNumber(24, SpacingRuleJustification.Center, 0, 0)

                ' just divide one face of form
                Exit For
            End If
        Next
    Next
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

DividedSurface Class


DividedSurface.GetAllIntersectionElements Method

DividedSurfaceGetAllIntersectionElements Method

Gets all intersection elements which produce division lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetAllIntersectionElements()
Public Function GetAllIntersectionElements As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetAllIntersectionElements()
member GetAllIntersectionElements : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
The intersection elements.
See Also

Reference

DividedSurface Class


DividedSurface.GetDividedSurfaceForReference Method

DividedSurfaceGetDividedSurfaceForReference Method

Get a divided surface for a given reference. Returns null if the reference does not host a divided surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static DividedSurface GetDividedSurfaceForReference(
    Document document,
    Reference faceReference
)
Public Shared Function GetDividedSurfaceForReference (
    document As Document,
    faceReference As Reference
) As DividedSurface
public:
static DividedSurface^ GetDividedSurfaceForReference(
    Document^ document,
    Reference^ faceReference
)
static member GetDividedSurfaceForReference :
        document : Document *
        faceReference : Reference -> DividedSurface

Parameters

document Document
The document.
faceReference Reference
Reference that represents a face.

Return Value

DividedSurface
The newly created divided surface.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DividedSurface Class


DividedSurface.GetGridNodeLocation Method

DividedSurfaceGetGridNodeLocation Method

Specify whether a particular grid node is interior to the surface, on the boundary, or outside the boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GridNodeLocation GetGridNodeLocation(
    GridNode gridNode
)
Public Function GetGridNodeLocation (
    gridNode As GridNode
) As GridNodeLocation
public:
GridNodeLocation GetGridNodeLocation(
    GridNode gridNode
)
member GetGridNodeLocation :
        gridNode : GridNode -> GridNodeLocation

Parameters

gridNode GridNode

Return Value

GridNodeLocation
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown when the grid node indexes are outside the range [ 0, NumberOfUGridlines - 1 ], [ 0, NumberOfVGridlines - 1 ].
See Also

Reference

DividedSurface Class


DividedSurface.GetGridNodeReference Method

DividedSurfaceGetGridNodeReference Method

Get a reference to the geometric point associated with a grid node.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Reference GetGridNodeReference(
    GridNode gridNode
)
Public Function GetGridNodeReference (
    gridNode As GridNode
) As Reference
public:
Reference^ GetGridNodeReference(
    GridNode gridNode
)
member GetGridNodeReference :
        gridNode : GridNode -> Reference

Parameters

gridNode GridNode

Return Value

Reference
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown when the grid node indexes are outside the range [ 0, NumberOfUGridlines - 1 ], [ 0, NumberOfVGridlines - 1 ].
See Also

Reference

DividedSurface Class


DividedSurface.GetGridNodeUV Method

DividedSurfaceGetGridNodeUV Method

Get the position of a grid node in UV coordinates in the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public UV GetGridNodeUV(
    GridNode gridNode
)
Public Function GetGridNodeUV (
    gridNode As GridNode
) As UV
public:
UV^ GetGridNodeUV(
    GridNode gridNode
)
member GetGridNodeUV :
        gridNode : GridNode -> UV

Parameters

gridNode GridNode

Return Value

UV
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown when the grid node indexes are outside the range [ 0, NumberOfUGridlines - 1 ], [ 0, NumberOfVGridlines - 1 ].
See Also

Reference

DividedSurface Class


DividedSurface.GetGridSegmentReference Method

DividedSurfaceGetGridSegmentReference Method

Get a reference to a line segment connecting two adjacent grid nodes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Reference GetGridSegmentReference(
    GridNode gridNode,
    GridSegmentDirection gridSegmentDirection
)
Public Function GetGridSegmentReference (
    gridNode As GridNode,
    gridSegmentDirection As GridSegmentDirection
) As Reference
public:
Reference^ GetGridSegmentReference(
    GridNode gridNode,
    GridSegmentDirection gridSegmentDirection
)
member GetGridSegmentReference :
        gridNode : GridNode *
        gridSegmentDirection : GridSegmentDirection -> Reference

Parameters

gridNode GridNode
gridSegmentDirection GridSegmentDirection

Return Value

Reference
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown when the grid node indexes are outside the range [ 0, NumberOfUGridlines - 1 ], [ 0, NumberOfVGridlines - 1 ], or when the adjacent grid node specified by gridSegmentDirection is out of range.
See Also

Reference

DividedSurface Class


DividedSurface.GetReferencesWithDividedSurfaces Method

DividedSurfaceGetReferencesWithDividedSurfaces Method

For a given host element get references to all the faces that host a divided surface

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<Reference> GetReferencesWithDividedSurfaces(
    Element host
)
Public Shared Function GetReferencesWithDividedSurfaces (
    host As Element
) As IList(Of Reference)
public:
static IList<Reference^>^ GetReferencesWithDividedSurfaces(
    Element^ host
)
static member GetReferencesWithDividedSurfaces :
        host : Element -> IList<Reference>

Parameters

host Element
The element that hosts the divided surfaces

Return Value

IList Reference
References that host a divided surface
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DividedSurface Class


DividedSurface.GetTileFamilyInstance Method

DividedSurfaceGetTileFamilyInstance Method

Get a reference to a tile element associated with a given seed node.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyInstance GetTileFamilyInstance(
    GridNode gridNode,
    int tileIndex
)
Public Function GetTileFamilyInstance (
    gridNode As GridNode,
    tileIndex As Integer
) As FamilyInstance
public:
FamilyInstance^ GetTileFamilyInstance(
    GridNode gridNode,
    int tileIndex
)
member GetTileFamilyInstance :
        gridNode : GridNode *
        tileIndex : int -> FamilyInstance

Parameters

gridNode GridNode
tileIndex Int32

Return Value

FamilyInstance
A FamilyInstance object. Returns if the ObjectType property is not a FamilySymbol. Returns if the grid node is not a "seed node", or if the tile is omitted due to boundary conditions.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if the grid node is outside of the range specified by NumberOfUGridlines and NumberOfVGridlines, or if tileIndex is outside the range [0, TilesPerSeedNode-1].
See Also

Reference

DividedSurface Class


DividedSurface.GetTileReference Method

DividedSurfaceGetTileReference Method

Get a reference to one of the tile surfaces associated with a given seed node.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Reference GetTileReference(
    GridNode gridNode,
    int tileIndex
)
Public Function GetTileReference (
    gridNode As GridNode,
    tileIndex As Integer
) As Reference
public:
Reference^ GetTileReference(
    GridNode gridNode,
    int tileIndex
)
member GetTileReference :
        gridNode : GridNode *
        tileIndex : int -> Reference

Parameters

gridNode GridNode
tileIndex Int32
An integer between 0 and T-1, where T is TilesPerSeedNode.

Return Value

Reference
A reference to a Face (surface). Returns if the grid node is not a "seed node", or if the tile is omitted due to boundary conditions.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown if the grid node is outside of the range specified by NumberOfUGridlines and NumberOfVGridlines, or if tileIndex is outside the range [0, TilesPerSeedNode-1].
See Also

Reference

DividedSurface Class


DividedSurface.IsSeedNode Method

DividedSurfaceIsSeedNode Method

Reports whether a grid node is a "seed node," a node that is associated with one or more tiles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSeedNode(
    GridNode gridNode
)
Public Function IsSeedNode (
    gridNode As GridNode
) As Boolean
public:
bool IsSeedNode(
    GridNode gridNode
)
member IsSeedNode :
        gridNode : GridNode -> bool

Parameters

gridNode GridNode

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown when the grid node indexes are outside the range [ 0, NumberOfUGridlines - 1 ], [ 0, NumberOfVGridlines - 1 ].
See Also

Reference

DividedSurface Class


DividedSurface.RemoveAllIntersectionElements Method

DividedSurfaceRemoveAllIntersectionElements Method

Removes all the intersection elements from a divided surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveAllIntersectionElements()
Public Sub RemoveAllIntersectionElements
public:
void RemoveAllIntersectionElements()
member RemoveAllIntersectionElements : unit -> unit
See Also

Reference

DividedSurface Class


DividedSurface.RemoveIntersectionElement Method

DividedSurfaceRemoveIntersectionElement Method

Removes an intersection element from a divided surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveIntersectionElement(
    ElementId referenceElemIdToRemove
)
Public Sub RemoveIntersectionElement (
    referenceElemIdToRemove As ElementId
)
public:
void RemoveIntersectionElement(
    ElementId^ referenceElemIdToRemove
)
member RemoveIntersectionElement :
        referenceElemIdToRemove : ElementId -> unit

Parameters

referenceElemIdToRemove ElementId
The intersection element to be removed.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DividedSurface Class


Document Class

An object that represents an open Autodesk Revit project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBDocument

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Document : IDisposable
Public Class Document
    Implements IDisposable
public ref class Document : IDisposable
type Document =
    class
        interface IDisposable
    end

The Document type exposes the following members.

Properties
 | Name | Description
Public property | ActiveProjectLocation | Retrieve the active project location.
 | ActiveView | The document's active view.
Public property | Application | Returns the Application in which the Document resides.
Public property | Create | An object that can be used to create new instances of Autodesk Revit API elements within a project.
Public property | CreationGUID | A unique identifier generated when the Document was first created.
Public property | DisplayUnitSystem | Provides access to display unit type with in the document.
Public property | FamilyCreate | An object that can be used to create new instances of Autodesk Revit API elements within a family document.
Public property | FamilyManager | The family manager object provides access to family types and parameters.
Public property | IsDetached | Identifies if a workshared document is detached. Also, see IsWorkshared
Public property | IsFamilyDocument | Identifies if the current document is a family document.
Public property | IsLinked | Identifies if a document is a linked RVT.
Public property | IsModelInCloud | Identifies if document is stored on Autodesk cloud services.
Public property | IsModifiable | Identifies if the document is modifiable.
Public property | IsModified | The state of changes made to the document.
Public property | IsReadOnly | Identifies if the document is read-only or can possibly be modified.
Public property | IsReadOnlyFile | Signals whether the document was opened from a read-only file.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | IsWorkshared | Identifies if worksharing (i.e. editing permissions and multiple worksets) have been enabled in the document. Also, see IsDetached
Public property | MassDisplayTemporaryOverride | This setting controls temporary display in views of objects with mass category or subcategories.
Public property | MullionTypes | This property is used to retrieve all the mullion types in current system.
 | OwnerFamily | Get the Family of this Family Document.
Public property | PanelTypes | Retrieves a set of PanelType objects that contains all the panel types that are currently loaded into the project.
Public property | ParameterBindings | Retrieves an object from which mappings between parameter definitions and categories can be found.
 | PathName | The fully qualified path of the document's disk file.
 | Phases | Retrieves all of the phases in the document.
Public property | PlanTopologies | Get the PlanTopologies of the current project in the last phase.
Public property | PlanTopologiesPhase | Gets the PlanTopologies of the current project in a given phase.
Public property | PlanTopologyLevel | Get the PlanTopology of a given level in the last phase.
Public property | PlanTopologyLevel, Phase | Get the PlanTopology of a given level in a given phase.
Public property | PrintManager | Retrieve the PrintManager of current project.
Public property | ProjectInformation | Return the Project Information of the current project.
Public property | ProjectLocations | Retrieve all the project locations associated with this project
Public property | ReactionsAreUpToDate | Reports if the analytical model has regenerated in a document with reaction loads.
Public property | Settings | Provides access to general application settings, such as Categories.
Public property | SiteLocation | Returns the site location information.
Public property | Title | The document's title.
Public property | TypeOfStorage | Get the storage type of the specified BuiltInParameter.
Public property | WorksharingCentralGUID | The central GUID of the server-based model.
Top
Methods
 | Name | Description
Public method | AcquireCoordinates | Acquires coordinates from the specified link instance.
Public method | AutoJoinElements | Forces the elements in the Revit document to automatically join to their neighbors where appropriate.
Public method | CanEnableCloudWorksharing | Checks if cloud worksharing can be enabled for the cloud model.
Public method | CanEnableWorksharing | Checks if worksharing can be enabled in the document.
Public method | Close | Closes the document, save the changes if there are.
Public method | Close(Boolean) | Closes the document with the option to save.
Public method | CombineElements | Combine a set of combinable elements into a geometry combination.
Public method | ConvertDetailToModelCurves | Converts a group of DetailCurves to equivalent ModelCurves.
Public method | ConvertModelToDetailCurves | Converts a group of ModelCurves to equivalent DetailCurves.
Public method | ConvertModelToSymbolicCurves | Converts a group of ModelCurves to equivalent SymbolicCurves.
Public method | ConvertSymbolicToModelCurves | Converts a group of SymbolicCurves to equivalent ModelCurves.
 | Delete(ElementId) | Deletes an element from the document given the id of that element.
 | Delete(ICollectionElementId) | Deletes a set of elements from the document.
Public method | Dispose | Releases all resources used by the Document
 | EditFamily | Gets the document of a loaded family to edit.
Public method | EnableCloudWorksharing | Enables cloud worksharing for a cloud model
Public method | EnableWorksharing | Enables worksharing in the document.
Public method | Equals | Determines whether the specified Object equals to this Object. (Overrides ObjectEquals(Object))
Public method | EraseSchemaAndAllEntities | Erases Schema and all its Entities from the document.
Public method | Export(String, IListElementId, PDFExportOptions) | Exports a selection of views in PDF format.
Public method | Export(String, String, GBXMLExportOptions) | Export the model in gbXML (green-building) format.
Public method | Export(String, String, IFCExportOptions) | Exports the document to the Industry Standard Classes (IFC) format.
Public method | Export(String, String, NavisworksExportOptions) | Exports a Revit project to the Navisworks .nwc format.
Public method | Export(String, String, OBJExportOptions) | Exports a view specified in the export options to the OBJ format.
Public method | Export(String, String, STEPExportOptions) | Exports the current view or a selection of views in STEP format.
Public method | Export(String, String, STLExportOptions) | Exports a view specified in the export options to the STL format.
 | Export(String, String, ViewSet, DWFExportOptions) | Exports the current view or a selection of views in DWF format.
Public method | Export(String, String, ViewSet, DWFXExportOptions) | Exports the current view or a selection of views in DWFX format.
Public method | Export(String, String, ViewSet, FBXExportOptions) | Exports the document in 3D-Studio Max (FBX) format.
 | Export(String, String, ICollectionElementId, DGNExportOptions) | Exports a selection of views in DGN format.
 | Export(String, String, ICollectionElementId, DWGExportOptions) | Exports a selection of views in DWG format.
Public method | Export(String, String, ICollectionElementId, DXFExportOptions) | Exports a selection of views in DXF format.
Public method | Export(String, String, ICollectionElementId, SATExportOptions) | Exports the current view or a selection of views in SAT format.
Public method | ExportImage | Exports a view or set of views into an image file.
 | GetAllUnusedElements | Returns the list of element ids that are not used. The list of unused element ids may include elements that can't be deleted.
 | GetChangedElements | Extracts a collection containing the ids of elements that have been created, modified or deleted between the input baseVersion and the document's current version.
Public method | GetCloudFolderId | Gets ForgeDM folder id where the model locates.
Public method | GetCloudModelPath | Gets the cloud model path of the cloud model.
Public method | GetCloudModelUrn | A ForgeDM Urn identifying the model.
 | GetDefaultElementTypeId | Gets the default element type id with the given DefaultElementType id.
 | GetDefaultFamilyTypeId | Gets the default family type id with the given family category id.
Public method | GetDocumentPreviewSettings | Returns the preview settings for the given document.
 | GetDocumentVersion | Gets the DocumentVersion that corresponds to a document.
Public method | GetElement(ElementId) | Gets the Element referenced by the input ElementId.
Public method | GetElement(Reference) | Gets the Element referenced by the input reference.
Public method | GetElement(String) | Gets the Element referenced by a unique id string.
Public method | GetHashCode | Gets the hash code of this document instance. (Overrides ObjectGetHashCode)
Public method | GetHubId | Gets ForgeDM hub id where the model locates. It is cached in session.
Public method | GetPaintedMaterial | Get the material painted on the element's face. Returns invalidElementId if the face is not painted.
Public method | GetPrintSettingIds | Retrieves all Print Settings of current project.
Public method | GetProjectId | Gets ForgeDM project id where the model locates.
Public method | GetRoomAtPoint(XYZ) | Gets a room containing the point.
Public method | GetRoomAtPoint(XYZ, Phase) | Gets a room containing the point.
Public method | GetSpaceAtPoint(XYZ) | Gets a space containing the point.
Public method | GetSpaceAtPoint(XYZ, Phase) | Gets a space containing the point.
Public method | GetSubelement(Reference) | Gets the subelement referenced by the input reference.
Public method | GetSubelement(String) | Gets the subelement referenced by a unique id string.
Public method | GetSubelement(ElementId, Int32) | Gets the subelement referenced by a parent id and subelement id.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeOfStorage | Get the storage type of the identified built-in parameter.
Public method | GetUnits | Gets the Units object.
 | GetUnusedElements | Returns the list of element ids that are not used and can be deleted from the document.
Public method | GetWarnings | Returns list of failure messages generated from persistent (reviewable) warnings accumulated in the document.
Public method | GetWorksetId | Get Id of the Workset which owns the element.
Public method | GetWorksetTable | Get the WorksetTable of this document.
Public method | GetWorksharingCentralModelPath | Gets the central model path of the worksharing model.
 | HasAllChangesFromCentral | Returns whether the model in the current session is up to date with central.
Public method | Import(String, GBXMLImportOptions) | Imports a Green-Building XML file into the document.
Public method | Import(String, AXMImportOptions, View) | Imports an AXM file into the document.
Public method | Import(String, ImportOptions3DM, View) | Imports a 3DM file into the document.
Public method | Import(String, OBJImportOptions, View) | Imports an OBJ file into the document.
Public method | Import(String, SATImportOptions, View) | Imports an SAT file into the document.
Public method | Import(String, SKPImportOptions, View) | Imports a SKP file into the document.
Public method | Import(String, STEPImportOptions, View) | Imports a STEP file into the document.
Public method | Import(String, STLImportOptions, View) | Imports an STL file into the document.
Public method | Import(String, DGNImportOptions, View, ElementId) | Imports a DGN file to the document.
Public method | Import(String, DWGImportOptions, View, ElementId) | Imports a DWG or DXF file to the document.
Public method | IsBackgroundCalculationInProgress | Indicates whether there are any background calculations in progress for this document.
Public method | IsDefaultElementTypeIdValid | Checks whether the element type id is valid for the give DefaultElmentType id.
Public method | IsDefaultFamilyTypeIdValid | Checks whether the family type id is valid for the give family category.
Public method | IsPainted | Checks if the element's face is painted with a material.
 | IsValidVersionGUID | Checks whether the GUID is valid for the given document. Empty GUID is allowed.
Public method | Link(String, DWFImportOptions) | Links Markups in a DWF file into the project document.
Public method | Link(String, ImportOptions3DM, View) | Links a 3DM file into the project document.
Public method | Link(String, OBJImportOptions, View) | Links an OBJ file into the project document.
Public method | Link(String, SATImportOptions, View) | Links an SAT file into the project document.
Public method | Link(String, SKPImportOptions, View) | Links a SKP file into the project document.
Public method | Link(String, STEPImportOptions, View) | Links an STEP file into the project document.
Public method | Link(String, STLImportOptions, View) | Links an STL file into the project document.
Public method | Link(String, DGNImportOptions, View, ElementId) | Links a DGN file into the project document.
Public method | Link(String, DWGImportOptions, View, ElementId) | Links a DWG or DXF file into the project document.
Public method | LoadFamily(Document) | Loads the contents of this family document into another document.
Public method | LoadFamily(String) | Loads an entire family and all its types/symbols into the document.
Public method | LoadFamily(Document, IFamilyLoadOptions) | Loads the contents of this family document into another document.
 | LoadFamily(String, Family) | Loads an entire family and all its types/symbols into the document and provides a reference to the loaded family.
Public method | LoadFamily(String, IFamilyLoadOptions, Family) | Loads an entire family and all its types/symbols into the document and provides a reference to the loaded family.
Public method | LoadFamilySymbol(String, String) | Loads only a specified family type/symbol from a family file into the document.
Public method | LoadFamilySymbol(String, String, FamilySymbol) | Loads only the specified family type/symbol from a family file into the document and provides a reference to the loaded family symbol.
Public method | LoadFamilySymbol(String, String, IFamilyLoadOptions, FamilySymbol) | Loads only the specified family type/symbol from a family file into the document and provides a reference to the loaded family symbol.
Public method | MakeTransientElements | This method encapsulates the process of creating transient elements in the document.
 | Paint(ElementId, Face, ElementId) | Paint the element's face with specified material.
 | Paint(ElementId, Face, FamilyParameter) | Paint the element's face with specified material.
 | PostFailure | Posts a failure to be displayed to the user at the end of transaction.
Public method | Print(ViewSet) | Prints a set of views with default view template and default print settings.
Public method | Print(ViewSet, View) | Prints a set of views with a specified view template and default print settings.
Public method | Print(ViewSet, Boolean) | Prints a set of views with default view template and default print settings.
Public method | Print(ViewSet, View, Boolean) | Prints a set of views with a specified view template and default print settings.
Public method | PublishCoordinates | Publish coordinates to the specified ProjectLocation of the link instance.
 | Regenerate | Updates the elements in the Revit document to reflect all changes.
 | ReloadLatest | Fetches changes from central (due to one or more synchronizations with central) and merges them into the current session.
Public method | RemovePaint | Remove the material painted on the element's face. If the face is currently not painted,it will do nothing.
Public method | ResetSharedCoordinates | Reset shared coordinates for the host model/file.
Public method | Save | Saves the document.
Public method | Save(SaveOptions) | Saves the document.
Public method | SaveAs(String) | Saves the document to a given file path.
Public method | SaveAs(ModelPath, SaveAsOptions) | Saves the document to a given path.
 | SaveAs(String, SaveAsOptions) | Saves the document to a given file path.
Public method | SaveAsCloudModel | Saves current non-workshared or workshared model as a cloud model or workshared cloud model in BIM 360 Docs or Autodesk Docs.
Public method | SaveCloudModel | Saves cloud model.
Public method | SaveToProjectAsImage | Creates an image view from the currently active view.
Public method | SeparateElements | Separate a set of combinable elements out of combinations they currently belong to.
Public method | SetDefaultElementTypeId | Sets the default element type id of the given DefaultElementType id.
 | SetDefaultFamilyTypeId | Sets the default family type id for the given family category.
Public method | SetUnits | Sets the units.
 | SynchronizeWithCentral | Performs reload latest until the model in the current session is up to date and then saves changes back to central. A save to central is performed even if no changes were made.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UnpostFailure | Deletes the posted failure message associated with a given FailureMessageKey.
Top
Events
 | Name | Description
Public event | DocumentClosing | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
Public event | DocumentPrinted | Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.
Public event | DocumentPrinting | Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.
Public event | DocumentSaved | Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.
Public event | DocumentSavedAs | Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.
Public event | DocumentSaving | Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document.
Public event | DocumentSavingAs | Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.
Public event | ViewPrinted | Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.
Public event | ViewPrinting | Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.
Top
Remarks
The Document object represents an Autodesk Revit project. Revit can have multiple projects open and multiple views to those projects. The active or top most view will be the active project and hence the active document which is available from the Application object.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Document Properties

The Document type exposes the following members.

Properties
 | Name | Description
Public property | ActiveProjectLocation | Retrieve the active project location.
 | ActiveView | The document's active view.
Public property | Application | Returns the Application in which the Document resides.
Public property | Create | An object that can be used to create new instances of Autodesk Revit API elements within a project.
Public property | CreationGUID | A unique identifier generated when the Document was first created.
Public property | DisplayUnitSystem | Provides access to display unit type with in the document.
Public property | FamilyCreate | An object that can be used to create new instances of Autodesk Revit API elements within a family document.
Public property | FamilyManager | The family manager object provides access to family types and parameters.
Public property | IsDetached | Identifies if a workshared document is detached. Also, see IsWorkshared
Public property | IsFamilyDocument | Identifies if the current document is a family document.
Public property | IsLinked | Identifies if a document is a linked RVT.
Public property | IsModelInCloud | Identifies if document is stored on Autodesk cloud services.
Public property | IsModifiable | Identifies if the document is modifiable.
Public property | IsModified | The state of changes made to the document.
Public property | IsReadOnly | Identifies if the document is read-only or can possibly be modified.
Public property | IsReadOnlyFile | Signals whether the document was opened from a read-only file.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | IsWorkshared | Identifies if worksharing (i.e. editing permissions and multiple worksets) have been enabled in the document. Also, see IsDetached
Public property | MassDisplayTemporaryOverride | This setting controls temporary display in views of objects with mass category or subcategories.
Public property | MullionTypes | This property is used to retrieve all the mullion types in current system.
 | OwnerFamily | Get the Family of this Family Document.
Public property | PanelTypes | Retrieves a set of PanelType objects that contains all the panel types that are currently loaded into the project.
Public property | ParameterBindings | Retrieves an object from which mappings between parameter definitions and categories can be found.
 | PathName | The fully qualified path of the document's disk file.
 | Phases | Retrieves all of the phases in the document.
Public property | PlanTopologies | Get the PlanTopologies of the current project in the last phase.
Public property | PlanTopologiesPhase | Gets the PlanTopologies of the current project in a given phase.
Public property | PlanTopologyLevel | Get the PlanTopology of a given level in the last phase.
Public property | PlanTopologyLevel, Phase | Get the PlanTopology of a given level in a given phase.
Public property | PrintManager | Retrieve the PrintManager of current project.
Public property | ProjectInformation | Return the Project Information of the current project.
Public property | ProjectLocations | Retrieve all the project locations associated with this project
Public property | ReactionsAreUpToDate | Reports if the analytical model has regenerated in a document with reaction loads.
Public property | Settings | Provides access to general application settings, such as Categories.
Public property | SiteLocation | Returns the site location information.
Public property | Title | The document's title.
Public property | TypeOfStorage | Get the storage type of the specified BuiltInParameter.
Public property | WorksharingCentralGUID | The central GUID of the server-based model.
Top
See Also

Reference

Document Class


Document.ActiveProjectLocation Property

DocumentActiveProjectLocation Property

Retrieve the active project location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ProjectLocation ActiveProjectLocation { get; set; }
Public Property ActiveProjectLocation As ProjectLocation
    Get
    Set
public:
property ProjectLocation^ ActiveProjectLocation {
    ProjectLocation^ get ();
    void set (ProjectLocation^ value);
}
member ActiveProjectLocation : ProjectLocation with get, set

Property Value

ProjectLocation
Remarks
Getting this property returns the currently active project location that the user is currently working with. Setting this property can be used to change the active project location.
See Also

Reference

Document Class


Document.ActiveView Property

DocumentActiveView Property

The document's active view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public View ActiveView { get; }
Public ReadOnly Property ActiveView As View
    Get
public:
property View^ ActiveView {
    View^ get ();
}
member ActiveView : View with get

Property Value

View
The active view is the view that last had focus in the UI. if no view is considered active.
Example
C#
VB
C++
F#
Copy
// Get the active view of the current document.
Autodesk.Revit.DB.View view = document.ActiveView;

// Get the class type of the active view, and format the prompt string
String prompt = "Revit is currently in ";
if (view is Autodesk.Revit.DB.View3D)
{
    prompt += "3D view.";
}
else if (view is Autodesk.Revit.DB.ViewSection)
{
    prompt += "section view.";
}
else if (view is Autodesk.Revit.DB.ViewSheet)
{
    prompt += "sheet view.";
}
else if (view is Autodesk.Revit.DB.ViewDrafting)
{
    prompt += "drafting view.";
}
else
{
    prompt += "normal view, the view name is " + view.Name;
}

// Give the user some information
TaskDialog.Show("Revit",prompt);
' Get the active view of the current document.
Dim view As Autodesk.Revit.DB.View = document.ActiveView

' Get the class type of the active view, and format the prompt string
Dim prompt As [String] = "Revit is currently in "
If TypeOf view Is Autodesk.Revit.DB.View3D Then
   prompt += "3D view."
ElseIf TypeOf view Is Autodesk.Revit.DB.ViewSection Then
   prompt += "section view."
ElseIf TypeOf view Is Autodesk.Revit.DB.ViewSheet Then
   prompt += "sheet view."
ElseIf TypeOf view Is Autodesk.Revit.DB.ViewDrafting Then
   prompt += "drafting view."
Else
   prompt += "normal view, the view name is " + view.Name
End If

' Give the user some information
TaskDialog.Show("Revit", prompt)

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Document Class


Document.Application Property

DocumentApplication Property

Returns the Application in which the Document resides.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Application Application { get; }
Public ReadOnly Property Application As Application
    Get
public:
property Application^ Application {
    Application^ get ();
}
member Application : Application with get

Property Value

Application
See Also

Reference

Document Class


Document.Create Property

DocumentCreate Property

An object that can be used to create new instances of Autodesk Revit API elements within a project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Document Create { get; }
Public ReadOnly Property Create As Document
    Get
public:
property Document^ Create {
    Document^ get ();
}
member Create : Document with get

Property Value

Document
This object is used to create new instances of project elements within the Autodesk Revit API, such as FamilyInstances or groups.
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the current document is family document.
See Also

Reference

Document Class


Document.CreationGUID Property

DocumentCreationGUID Property

A unique identifier generated when the Document was first created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid CreationGUID { get; }
Public ReadOnly Property CreationGUID As Guid
    Get
public:
property Guid CreationGUID {
    Guid get ();
}
member CreationGUID : Guid with get

Property Value

Guid
See Also

Reference

Document Class


Document.DisplayUnitSystem Property

DocumentDisplayUnitSystem Property

Provides access to display unit type with in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DisplayUnit DisplayUnitSystem { get; }
Public ReadOnly Property DisplayUnitSystem As DisplayUnit
    Get
public:
property DisplayUnit DisplayUnitSystem {
    DisplayUnit get ();
}
member DisplayUnitSystem : DisplayUnit with get

Property Value

DisplayUnit
Remarks
Return the display unit type, metric or imperial.
See Also

Reference

Document Class


Document.FamilyCreate Property

DocumentFamilyCreate Property

An object that can be used to create new instances of Autodesk Revit API elements within a family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyItemFactory FamilyCreate { get; }
Public ReadOnly Property FamilyCreate As FamilyItemFactory
    Get
public:
property FamilyItemFactory^ FamilyCreate {
    FamilyItemFactory^ get ();
}
member FamilyCreate : FamilyItemFactory with get

Property Value

FamilyItemFactory
This object is used to create new instances of family elements within the Autodesk Revit API, such as Extrusion or Reference lines.
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the current document is project document.
See Also

Reference

Document Class


Document.FamilyManager Property

DocumentFamilyManager Property

The family manager object provides access to family types and parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyManager FamilyManager { get; }
Public ReadOnly Property FamilyManager As FamilyManager
    Get
public:
property FamilyManager^ FamilyManager {
    FamilyManager^ get ();
}
member FamilyManager : FamilyManager with get

Property Value

FamilyManager
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the current document is project document.
Remarks
This property is available when the document is a family document.
See Also

Reference

Document Class


Document.IsDetached Property

DocumentIsDetached Property

Identifies if a workshared document is detached. Also, see IsWorkshared

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsDetached { get; }
Public ReadOnly Property IsDetached As Boolean
    Get
public:
property bool IsDetached {
    bool get ();
}
member IsDetached : bool with get

Property Value

Boolean
Remarks
Note that Title and PathName will be empty strings if a document is detached.
See Also

Reference

Document Class


Document.IsFamilyDocument Property

DocumentIsFamilyDocument Property

Identifies if the current document is a family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsFamilyDocument { get; }
Public ReadOnly Property IsFamilyDocument As Boolean
    Get
public:
property bool IsFamilyDocument {
    bool get ();
}
member IsFamilyDocument : bool with get

Property Value

Boolean
See Also

Reference

Document Class


Document.IsLinked Property

DocumentIsLinked Property

Identifies if a document is a linked RVT.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsLinked { get; }
Public ReadOnly Property IsLinked As Boolean
    Get
public:
property bool IsLinked {
    bool get ();
}
member IsLinked : bool with get

Property Value

Boolean
See Also

Reference

Document Class


Document.IsModelInCloud Property

DocumentIsModelInCloud Property

Identifies if document is stored on Autodesk cloud services.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsModelInCloud { get; }
Public ReadOnly Property IsModelInCloud As Boolean
    Get
public:
property bool IsModelInCloud {
    bool get ();
}
member IsModelInCloud : bool with get

Property Value

Boolean
See Also

Reference

Document Class


Document.IsModifiable Property

DocumentIsModifiable Property

Identifies if the document is modifiable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsModifiable { get; }
Public ReadOnly Property IsModifiable As Boolean
    Get
public:
property bool IsModifiable {
    bool get ();
}
member IsModifiable : bool with get

Property Value

Boolean
Remarks
This is not a permanent state such as, for example IsReadOnlyFile. Value of this property changes dynamically multiple times within the life-time of an open document. Regardless of the mode a document is opened with, the model can only be modified inside an open transaction. Furthermore, even with a transaction open, the model is not always modifiable. Though this is rather a rare situation, it can happen, most likely during model regeneration, failure processing, or some events. An attempt to modify a non-modifiable document will result in throwing a ModificationOutsideTransactionException. See also IsReadOnly
See Also

Reference

Document Class


Document.IsModified Property

DocumentIsModified Property

The state of changes made to the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsModified { get; }
Public ReadOnly Property IsModified As Boolean
    Get
public:
property bool IsModified {
    bool get ();
}
member IsModified : bool with get

Property Value

Boolean
See Also

Reference

Document Class


Document.IsReadOnly Property

DocumentIsReadOnly Property

Identifies if the document is read-only or can possibly be modified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}
member IsReadOnly : bool with get

Property Value

Boolean
Remarks
Like the IsModifiable, IsReadOnly is also a dynamic property. It's value can change depending on the state a document is currently in. There are various factors that may affect this property. The most probable reason for this property to return 'true' is when Revit is currently processing failures (recoverable or not). Another possibility is when an external command is executed in read-only mode. If a document is in a read-only state, then not only the model cannot be modified at the moment, but even a new transaction may not be started. Attempting to do so will raise an InvalidOperationException.
See Also

Reference

Document Class


Document.IsReadOnlyFile Property

DocumentIsReadOnlyFile Property

Signals whether the document was opened from a read-only file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsReadOnlyFile { get; }
Public ReadOnly Property IsReadOnlyFile As Boolean
    Get
public:
property bool IsReadOnlyFile {
    bool get ();
}
member IsReadOnlyFile : bool with get

Property Value

Boolean
Remarks
A document could be opened this way when, for example, at the time of opening the file was being used by another Revit user, or if the disk file has the read-only attribute set.

Although it will still be possible to modify the opened document, any changes made there will not be possible to save into the original file. If the changes are to be preserved, the document must be saved under a different name using the SaveAs() method.

See Also

Reference

Document Class


Document.IsValidObject Property

DocumentIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

Document Class


Document.IsWorkshared Property

DocumentIsWorkshared Property

Identifies if worksharing (i.e. editing permissions and multiple worksets) have been enabled in the document. Also, see IsDetached

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsWorkshared { get; }
Public ReadOnly Property IsWorkshared As Boolean
    Get
public:
property bool IsWorkshared {
    bool get ();
}
member IsWorkshared : bool with get

Property Value

Boolean
See Also

Reference

Document Class


Document.MassDisplayTemporaryOverride Property

DocumentMassDisplayTemporaryOverride Property

This setting controls temporary display in views of objects with mass category or subcategories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MassDisplayTemporaryOverrideType MassDisplayTemporaryOverride { get; set; }
Public Property MassDisplayTemporaryOverride As MassDisplayTemporaryOverrideType
    Get
    Set
public:
property MassDisplayTemporaryOverrideType MassDisplayTemporaryOverride {
    MassDisplayTemporaryOverrideType get ();
    void set (MassDisplayTemporaryOverrideType value);
}
member MassDisplayTemporaryOverride : MassDisplayTemporaryOverrideType with get, set

Property Value

MassDisplayTemporaryOverrideType
The MassDisplayTemporaryOverrideType that is active.
Exceptions
Exception | Condition
ArgumentException | When setting this property: The MassDisplayTemporaryOverrideType::Enum value is not in the proper range.
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
This setting is temporary and is not stored in the document. The mass display overrides allow mass category and certain mass subcategories to be displayed in all views, regardless of the visibility settings of that view. The settings that show certain mass subcategories will also force the other mass subcategories to be hidden.
See Also

Reference

Document Class


Document.MullionTypes Property

DocumentMullionTypes Property

This property is used to retrieve all the mullion types in current system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MullionTypeSet MullionTypes { get; }
Public ReadOnly Property MullionTypes As MullionTypeSet
    Get
public:
property MullionTypeSet^ MullionTypes {
    MullionTypeSet^ get ();
}
member MullionTypes : MullionTypeSet with get

Property Value

MullionTypeSet
Remarks
This property returns a set of MullionType objects. These objects can be used change the type of a mullion from one type to another.
See Also

Reference

Document Class


Document.OwnerFamily Property

DocumentOwnerFamily Property

Get the Family of this Family Document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Family OwnerFamily { get; }
Public ReadOnly Property OwnerFamily As Family
    Get
public:
property Family^ OwnerFamily {
    Family^ get ();
}
member OwnerFamily : Family with get

Property Value

Family
Remarks
Only available if the current document is family document.
Example
C#
VB
C++
F#
Copy
string categoryName = familyDoc.OwnerFamily.FamilyCategory.Name;
Dim categoryName As String = familyDoc.OwnerFamily.FamilyCategory.Name

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Document Class


Document.PanelTypes Property

DocumentPanelTypes Property

Retrieves a set of PanelType objects that contains all the panel types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PanelTypeSet PanelTypes { get; }
Public ReadOnly Property PanelTypes As PanelTypeSet
    Get
public:
property PanelTypeSet^ PanelTypes {
    PanelTypeSet^ get ();
}
member PanelTypes : PanelTypeSet with get

Property Value

PanelTypeSet
Remarks
This property returns a set of panelType objects. These objects can be used change the type of a panel from one type to another.
See Also

Reference

Document Class


Document.ParameterBindings Property

DocumentParameterBindings Property

Retrieves an object from which mappings between parameter definitions and categories can be found.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BindingMap ParameterBindings { get; }
Public ReadOnly Property ParameterBindings As BindingMap
    Get
public:
property BindingMap^ ParameterBindings {
    BindingMap^ get ();
}
member ParameterBindings : BindingMap with get

Property Value

BindingMap
Exceptions
Exception | Condition
InvalidOperationException | When the document is a family document.
Remarks
Returns a mapping between parameter definitions and parameter bindings. New bindings can be added to the Revit Document by using this object.
See Also

Reference

Document Class


Document.PathName Property

DocumentPathName Property

The fully qualified path of the document's disk file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string PathName { get; }
Public ReadOnly Property PathName As String
    Get
public:
property String^ PathName {
    String^ get ();
}
member PathName : string with get

Property Value

String
Remarks
This string is empty if the project has not been saved or does not have a disk file associated with it yet. Note that the pathname will be empty if a document is detached. See IsDetached.
Example
C#
VB
C++
F#
Copy
string docPathName = document.PathName;
Dim docPathName As String = document.PathName

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Document Class


Document.Phases Property

DocumentPhases Property

Retrieves all of the phases in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PhaseArray Phases { get; }
Public ReadOnly Property Phases As PhaseArray
    Get
public:
property PhaseArray^ Phases {
    PhaseArray^ get ();
}
member Phases : PhaseArray with get

Property Value

PhaseArray
Remarks

The phases are returned in order from earliest phase to latest phase.

When Revit is running with UI activated, the default created phase for newly created elements is inherited from the phase of the currently active view.

When Revit is running without its UI, such as when Revit runs on Autodesk Forge Design Automation API for Revit, the default phase for newly created elements is the latest phase in the document.

Example
C#
VB
C++
F#
Copy
void Getinfo_Phase(Document doc)
{
    // Get the phase array which contains all the phases.
    PhaseArray phases = doc.Phases;
    // Format the prompt string which identifies all supported phases in the current document.
    String prompt = null;
    if (0 != phases.Size)
    {
        prompt = "All the phases in current document list as follow:";
        foreach (Phase ii in phases)
        {
            prompt += "\n\t" + ii.Name;
        }
    }
    else
    {
        prompt = "There are no phases in current document.";
    }
    // Give the user the information.
    TaskDialog.Show("Revit",prompt);
}
Private Sub Getinfo_Phase(doc As Document)
    ' Get the phase array which contains all the phases.
    Dim phases As PhaseArray = doc.Phases
    ' Format the prompt string which identifies all supported phases in the current document.
    Dim prompt As [String] = Nothing
    If 0 <> phases.Size Then
        prompt = "All the phases in current document list as follow:"
        For Each ii As Phase In phases
            prompt += vbLf & vbTab + ii.Name
        Next
    Else
        prompt = "There are no phases in current document."
    End If
    ' Give the user the information.
    TaskDialog.Show("Revit", prompt)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Document Class


Document.PlanTopologies Property

DocumentPlanTopologies Property

Gets the PlanTopologies of the current project.
Overload List
 | Name | Description
Public property | PlanTopologies | Get the PlanTopologies of the current project in the last phase.
Public property | PlanTopologiesPhase | Gets the PlanTopologies of the current project in a given phase.
Top
See Also

Reference

Document Class


Document.PlanTopologies Property

DocumentPlanTopologies Property

Get the PlanTopologies of the current project in the last phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PlanTopologySet PlanTopologies { get; }
Public ReadOnly Property PlanTopologies As PlanTopologySet
    Get
public:
property PlanTopologySet^ PlanTopologies {
    PlanTopologySet^ get ();
}
member PlanTopologies : PlanTopologySet with get

Property Value

PlanTopologySet
Remarks
Accessing plan topologies requires that document is modifiable as it will actually trigger calculating plan topologies if they have not been calculated yet. The time necessary for the calculations may be significant and should be considered.
See Also

Reference

Document Class
PlanTopologies Overload


Document.PlanTopologies(Phase) Property

DocumentPlanTopologies(Phase) Property

Gets the PlanTopologies of the current project in a given phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PlanTopologySet this[
    Phase phase
] { get; }
Public ReadOnly Property PlanTopologies (
    phase As Phase
) As PlanTopologySet
    Get
public:
property PlanTopologySet^ PlanTopologies[Phase^ phase] {
    PlanTopologySet^ get (Phase^ phase);
}
member PlanTopologies : PlanTopologySet with get

Parameters

phase Phase
The phase of the Plan Topology.

Property Value

PlanTopologySet
Remarks
Accessing plan topologies requires that document is modifiable as it will actually trigger calculating plan topologies if they have not been calculated yet. The time necessary for the calculations may be significant and should be considered.
See Also

Reference

Document Class
PlanTopologies Overload


Document.PlanTopology Property

DocumentPlanTopology Property

Gets the PlanTopology of a given level.
Overload List
 | Name | Description
Public property | PlanTopologyLevel | Get the PlanTopology of a given level in the last phase.
Public property | PlanTopologyLevel, Phase | Get the PlanTopology of a given level in a given phase.
Top
See Also

Reference

Document Class


Document.PlanTopology(Level) Property

DocumentPlanTopology(Level) Property

Get the PlanTopology of a given level in the last phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PlanTopology this[
    Level level
] { get; }
Public ReadOnly Property PlanTopology (
    level As Level
) As PlanTopology
    Get
public:
property PlanTopology^ PlanTopology[Level^ level] {
    PlanTopology^ get (Level^ level);
}
member PlanTopology : PlanTopology with get

Parameters

level Level
The level of the Plan Topology.

Property Value

PlanTopology
Remarks
Accessing plan topology requires that document is modifiable as it will actually trigger calculating plan topology if they have not been calculated yet. The time necessary for the calculations may be significant and should be considered.
See Also

Reference

Document Class
PlanTopology Overload


Document.PlanTopology(Level, Phase) Property

DocumentPlanTopology(Level, Phase) Property

Get the PlanTopology of a given level in a given phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PlanTopology this[
    Level level,
    Phase phase
] { get; }
Public ReadOnly Property PlanTopology (
    level As Level,
    phase As Phase
) As PlanTopology
    Get
public:
property PlanTopology^ PlanTopology[Level^ level, Phase^ phase] {
    PlanTopology^ get (Level^ level, Phase^ phase);
}
member PlanTopology : PlanTopology with get

Parameters

level Level
The level of the Plan Topology.
phase Phase
The phase of the Plan Topology.

Property Value

PlanTopology
Remarks
Accessing plan topology requires that document is modifiable as it will actually trigger calculating plan topology if they have not been calculated yet. The time necessary for the calculations may be significant and should be considered.
See Also

Reference

Document Class
PlanTopology Overload


Document.PrintManager Property

DocumentPrintManager Property

Retrieve the PrintManager of current project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PrintManager PrintManager { get; }
Public ReadOnly Property PrintManager As PrintManager
    Get
public:
property PrintManager^ PrintManager {
    PrintManager^ get ();
}
member PrintManager : PrintManager with get

Property Value

PrintManager
See Also

Reference

Document Class


Document.ProjectInformation Property

DocumentProjectInformation Property

Return the Project Information of the current project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ProjectInfo ProjectInformation { get; }
Public ReadOnly Property ProjectInformation As ProjectInfo
    Get
public:
property ProjectInfo^ ProjectInformation {
    ProjectInfo^ get ();
}
member ProjectInformation : ProjectInfo with get

Return Value

ProjectInfo
Autodesk::Revit::DB::ProjectInfo
See Also

Reference

Document Class


Document.ProjectLocations Property

DocumentProjectLocations Property

Retrieve all the project locations associated with this project

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ProjectLocationSet ProjectLocations { get; }
Public ReadOnly Property ProjectLocations As ProjectLocationSet
    Get
public:
property ProjectLocationSet^ ProjectLocations {
    ProjectLocationSet^ get ();
}
member ProjectLocations : ProjectLocationSet with get

Property Value

ProjectLocationSet
Remarks
This property returns all the locations of the project. A project can have one site location but many project locations within that site. Each project location object is an offset and rotation from the site location.
See Also

Reference

Document Class


Document.ReactionsAreUpToDate Property

DocumentReactionsAreUpToDate Property

Reports if the analytical model has regenerated in a document with reaction loads.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ReactionsAreUpToDate { get; }
Public ReadOnly Property ReactionsAreUpToDate As Boolean
    Get
public:
property bool ReactionsAreUpToDate {
    bool get ();
}
member ReactionsAreUpToDate : bool with get

Property Value

Boolean
Remarks
Revit sets this property to False after regeneration of the analytical model if the document contains loads that have isReaction=True. This results in a user-visible warning that exists until there are no longer loads with isReaction=True.
See Also

Reference

Document Class


Document.Settings Property

DocumentSettings Property

Provides access to general application settings, such as Categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Settings Settings { get; }
Public ReadOnly Property Settings As Settings
    Get
public:
property Settings^ Settings {
    Settings^ get ();
}
member Settings : Settings with get

Property Value

Settings
Remarks
Returns an object that provides access to various settings within Autodesk Revit. The Settings property returns an object that provides access to the categories within the Autodesk Revit project.
See Also

Reference

Document Class


Document.SiteLocation Property

DocumentSiteLocation Property

Returns the site location information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SiteLocation SiteLocation { get; }
Public ReadOnly Property SiteLocation As SiteLocation
    Get
public:
property SiteLocation^ SiteLocation {
    SiteLocation^ get ();
}
member SiteLocation : SiteLocation with get

Property Value

SiteLocation
Remarks
The SiteLocation property returns an object that contains the site location for the entire project.
See Also

Reference

Document Class


Document.Title Property

DocumentTitle Property

The document's title.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Title { get; }
Public ReadOnly Property Title As String
    Get
public:
property String^ Title {
    String^ get ();
}
member Title : string with get

Property Value

String
Remarks
Title is derived from the document's filename, not including the filename extension. Note that returned title will be defaulted if no document saved. Note that returned string may be empty if a document is detached. See IsDetached.
See Also

Reference

Document Class


Document.TypeOfStorage Property

DocumentTypeOfStorage Property

Get the storage type of the specified BuiltInParameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public StorageType this[
    BuiltInParameter A_0
] { get; }
Public ReadOnly Property TypeOfStorage (
    A_0 As BuiltInParameter
) As StorageType
    Get
public:
property StorageType TypeOfStorage[BuiltInParameter A_0] {
    StorageType get (BuiltInParameter A_0);
}
member TypeOfStorage : StorageType with get

Parameters

A_0 BuiltInParameter

Property Value

StorageType
See Also

Reference

Document Class


Document.WorksharingCentralGUID Property

DocumentWorksharingCentralGUID Property

The central GUID of the server-based model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid WorksharingCentralGUID { get; }
Public ReadOnly Property WorksharingCentralGUID As Guid
    Get
public:
property Guid WorksharingCentralGUID {
    Guid get ();
}
member WorksharingCentralGUID : Guid with get

Property Value

Guid
Exceptions
Exception | Condition
InapplicableDataException | Thrown when the central model of this document is not a server-based model that created in Revit 2013 or later release.
Remarks
The central model of this document that is file-based model or saved in a release prior to Revit 2013 did not have this GUID. Only the central model saved in Revit 2013 or later and stored on Revit Server will be able to provide this value.
See Also

Reference

Document Class


Document Methods

The Document type exposes the following members.

Methods
 | Name | Description
Public method | AcquireCoordinates | Acquires coordinates from the specified link instance.
Public method | AutoJoinElements | Forces the elements in the Revit document to automatically join to their neighbors where appropriate.
Public method | CanEnableCloudWorksharing | Checks if cloud worksharing can be enabled for the cloud model.
Public method | CanEnableWorksharing | Checks if worksharing can be enabled in the document.
Public method | Close | Closes the document, save the changes if there are.
Public method | Close(Boolean) | Closes the document with the option to save.
Public method | CombineElements | Combine a set of combinable elements into a geometry combination.
Public method | ConvertDetailToModelCurves | Converts a group of DetailCurves to equivalent ModelCurves.
Public method | ConvertModelToDetailCurves | Converts a group of ModelCurves to equivalent DetailCurves.
Public method | ConvertModelToSymbolicCurves | Converts a group of ModelCurves to equivalent SymbolicCurves.
Public method | ConvertSymbolicToModelCurves | Converts a group of SymbolicCurves to equivalent ModelCurves.
 | Delete(ElementId) | Deletes an element from the document given the id of that element.
 | Delete(ICollectionElementId) | Deletes a set of elements from the document.
Public method | Dispose |
 | EditFamily | Gets the document of a loaded family to edit.
Public method | EnableCloudWorksharing | Enables cloud worksharing for a cloud model
Public method | EnableWorksharing | Enables worksharing in the document.
Public method | Equals | Determines whether the specified Object equals to this Object. (Overrides ObjectEquals(Object))
Public method | EraseSchemaAndAllEntities | Erases Schema and all its Entities from the document.
Public method | Export(String, IListElementId, PDFExportOptions) | Exports a selection of views in PDF format.
Public method | Export(String, String, GBXMLExportOptions) | Export the model in gbXML (green-building) format.
Public method | Export(String, String, IFCExportOptions) | Exports the document to the Industry Standard Classes (IFC) format.
Public method | Export(String, String, NavisworksExportOptions) | Exports a Revit project to the Navisworks .nwc format.
Public method | Export(String, String, OBJExportOptions) | Exports a view specified in the export options to the OBJ format.
Public method | Export(String, String, STEPExportOptions) | Exports the current view or a selection of views in STEP format.
Public method | Export(String, String, STLExportOptions) | Exports a view specified in the export options to the STL format.
 | Export(String, String, ViewSet, DWFExportOptions) | Exports the current view or a selection of views in DWF format.
Public method | Export(String, String, ViewSet, DWFXExportOptions) | Exports the current view or a selection of views in DWFX format.
Public method | Export(String, String, ViewSet, FBXExportOptions) | Exports the document in 3D-Studio Max (FBX) format.
 | Export(String, String, ICollectionElementId, DGNExportOptions) | Exports a selection of views in DGN format.
 | Export(String, String, ICollectionElementId, DWGExportOptions) | Exports a selection of views in DWG format.
Public method | Export(String, String, ICollectionElementId, DXFExportOptions) | Exports a selection of views in DXF format.
Public method | Export(String, String, ICollectionElementId, SATExportOptions) | Exports the current view or a selection of views in SAT format.
Public method | ExportImage | Exports a view or set of views into an image file.
 | GetAllUnusedElements | Returns the list of element ids that are not used. The list of unused element ids may include elements that can't be deleted.
 | GetChangedElements | Extracts a collection containing the ids of elements that have been created, modified or deleted between the input baseVersion and the document's current version.
Public method | GetCloudFolderId | Gets ForgeDM folder id where the model locates.
Public method | GetCloudModelPath | Gets the cloud model path of the cloud model.
Public method | GetCloudModelUrn | A ForgeDM Urn identifying the model.
 | GetDefaultElementTypeId | Gets the default element type id with the given DefaultElementType id.
 | GetDefaultFamilyTypeId | Gets the default family type id with the given family category id.
Public method | GetDocumentPreviewSettings | Returns the preview settings for the given document.
 | GetDocumentVersion | Gets the DocumentVersion that corresponds to a document.
Public method | GetElement(ElementId) | Gets the Element referenced by the input ElementId.
Public method | GetElement(Reference) | Gets the Element referenced by the input reference.
Public method | GetElement(String) | Gets the Element referenced by a unique id string.
Public method | GetHashCode | Gets the hash code of this document instance. (Overrides ObjectGetHashCode)
Public method | GetHubId | Gets ForgeDM hub id where the model locates. It is cached in session.
Public method | GetPaintedMaterial | Get the material painted on the element's face. Returns invalidElementId if the face is not painted.
Public method | GetPrintSettingIds | Retrieves all Print Settings of current project.
Public method | GetProjectId | Gets ForgeDM project id where the model locates.
Public method | GetRoomAtPoint(XYZ) | Gets a room containing the point.
Public method | GetRoomAtPoint(XYZ, Phase) | Gets a room containing the point.
Public method | GetSpaceAtPoint(XYZ) | Gets a space containing the point.
Public method | GetSpaceAtPoint(XYZ, Phase) | Gets a space containing the point.
Public method | GetSubelement(Reference) | Gets the subelement referenced by the input reference.
Public method | GetSubelement(String) | Gets the subelement referenced by a unique id string.
Public method | GetSubelement(ElementId, Int32) | Gets the subelement referenced by a parent id and subelement id.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeOfStorage | Get the storage type of the identified built-in parameter.
Public method | GetUnits | Gets the Units object.
 | GetUnusedElements | Returns the list of element ids that are not used and can be deleted from the document.
Public method | GetWarnings | Returns list of failure messages generated from persistent (reviewable) warnings accumulated in the document.
Public method | GetWorksetId | Get Id of the Workset which owns the element.
Public method | GetWorksetTable | Get the WorksetTable of this document.
Public method | GetWorksharingCentralModelPath | Gets the central model path of the worksharing model.
 | HasAllChangesFromCentral | Returns whether the model in the current session is up to date with central.
Public method | Import(String, GBXMLImportOptions) | Imports a Green-Building XML file into the document.
Public method | Import(String, AXMImportOptions, View) | Imports an AXM file into the document.
Public method | Import(String, ImportOptions3DM, View) | Imports a 3DM file into the document.
Public method | Import(String, OBJImportOptions, View) | Imports an OBJ file into the document.
Public method | Import(String, SATImportOptions, View) | Imports an SAT file into the document.
Public method | Import(String, SKPImportOptions, View) | Imports a SKP file into the document.
Public method | Import(String, STEPImportOptions, View) | Imports a STEP file into the document.
Public method | Import(String, STLImportOptions, View) | Imports an STL file into the document.
Public method | Import(String, DGNImportOptions, View, ElementId) | Imports a DGN file to the document.
Public method | Import(String, DWGImportOptions, View, ElementId) | Imports a DWG or DXF file to the document.
Public method | IsBackgroundCalculationInProgress | Indicates whether there are any background calculations in progress for this document.
Public method | IsDefaultElementTypeIdValid | Checks whether the element type id is valid for the give DefaultElmentType id.
Public method | IsDefaultFamilyTypeIdValid | Checks whether the family type id is valid for the give family category.
Public method | IsPainted | Checks if the element's face is painted with a material.
 | IsValidVersionGUID | Checks whether the GUID is valid for the given document. Empty GUID is allowed.
Public method | Link(String, DWFImportOptions) | Links Markups in a DWF file into the project document.
Public method | Link(String, ImportOptions3DM, View) | Links a 3DM file into the project document.
Public method | Link(String, OBJImportOptions, View) | Links an OBJ file into the project document.
Public method | Link(String, SATImportOptions, View) | Links an SAT file into the project document.
Public method | Link(String, SKPImportOptions, View) | Links a SKP file into the project document.
Public method | Link(String, STEPImportOptions, View) | Links an STEP file into the project document.
Public method | Link(String, STLImportOptions, View) | Links an STL file into the project document.
Public method | Link(String, DGNImportOptions, View, ElementId) | Links a DGN file into the project document.
Public method | Link(String, DWGImportOptions, View, ElementId) | Links a DWG or DXF file into the project document.
Public method | LoadFamily(Document) | Loads the contents of this family document into another document.
Public method | LoadFamily(String) | Loads an entire family and all its types/symbols into the document.
Public method | LoadFamily(Document, IFamilyLoadOptions) | Loads the contents of this family document into another document.
 | LoadFamily(String, Family) | Loads an entire family and all its types/symbols into the document and provides a reference to the loaded family.
Public method | LoadFamily(String, IFamilyLoadOptions, Family) | Loads an entire family and all its types/symbols into the document and provides a reference to the loaded family.
Public method | LoadFamilySymbol(String, String) | Loads only a specified family type/symbol from a family file into the document.
Public method | LoadFamilySymbol(String, String, FamilySymbol) | Loads only the specified family type/symbol from a family file into the document and provides a reference to the loaded family symbol.
Public method | LoadFamilySymbol(String, String, IFamilyLoadOptions, FamilySymbol) | Loads only the specified family type/symbol from a family file into the document and provides a reference to the loaded family symbol.
Public method | MakeTransientElements | This method encapsulates the process of creating transient elements in the document.
 | Paint(ElementId, Face, ElementId) | Paint the element's face with specified material.
 | Paint(ElementId, Face, FamilyParameter) | Paint the element's face with specified material.
 | PostFailure | Posts a failure to be displayed to the user at the end of transaction.
Public method | Print(ViewSet) | Prints a set of views with default view template and default print settings.
Public method | Print(ViewSet, View) | Prints a set of views with a specified view template and default print settings.
Public method | Print(ViewSet, Boolean) | Prints a set of views with default view template and default print settings.
Public method | Print(ViewSet, View, Boolean) | Prints a set of views with a specified view template and default print settings.
Public method | PublishCoordinates | Publish coordinates to the specified ProjectLocation of the link instance.
 | Regenerate | Updates the elements in the Revit document to reflect all changes.
 | ReloadLatest | Fetches changes from central (due to one or more synchronizations with central) and merges them into the current session.
Public method | RemovePaint | Remove the material painted on the element's face. If the face is currently not painted,it will do nothing.
Public method | ResetSharedCoordinates | Reset shared coordinates for the host model/file.
Public method | Save | Saves the document.
Public method | Save(SaveOptions) | Saves the document.
Public method | SaveAs(String) | Saves the document to a given file path.
Public method | SaveAs(ModelPath, SaveAsOptions) | Saves the document to a given path.
 | SaveAs(String, SaveAsOptions) | Saves the document to a given file path.
Public method | SaveAsCloudModel | Saves current non-workshared or workshared model as a cloud model or workshared cloud model in BIM 360 Docs or Autodesk Docs.
Public method | SaveCloudModel | Saves cloud model.
Public method | SaveToProjectAsImage | Creates an image view from the currently active view.
Public method | SeparateElements | Separate a set of combinable elements out of combinations they currently belong to.
Public method | SetDefaultElementTypeId | Sets the default element type id of the given DefaultElementType id.
 | SetDefaultFamilyTypeId | Sets the default family type id for the given family category.
Public method | SetUnits | Sets the units.
 | SynchronizeWithCentral | Performs reload latest until the model in the current session is up to date and then saves changes back to central. A save to central is performed even if no changes were made.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UnpostFailure | Deletes the posted failure message associated with a given FailureMessageKey.
Top
See Also

Reference

Document Class


Document.AcquireCoordinates Method

DocumentAcquireCoordinates Method

Acquires coordinates from the specified link instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AcquireCoordinates(
    ElementId linkInstanceId
)
Public Sub AcquireCoordinates (
    linkInstanceId As ElementId
)
public:
void AcquireCoordinates(
    ElementId^ linkInstanceId
)
member AcquireCoordinates :
        linkInstanceId : ElementId -> unit

Parameters

linkInstanceId ElementId
The ElementId of the link instance (such as RevitLinkInstance or ImportInstance) from which the coordinates would be acquired.
Exceptions
Exception | Condition
ArgumentException | The element linkInstanceId does not exist in the document
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This Document is not a project document. -or- This Document is in an edit mode. -or- The coordinate system of the selected model are the same as the host model. -or- Cannot acquire coordinates from a model placed multiple times. -or- Failed to acquire coordinates from the link instance.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks

When you acquire coordinates from the linked model, the shared coordinates of the linked model become the shared coordinates of the host model, based on the position of the linked model instance in the host model. There is no change to the host model's internal coordinates.

The host model also acquires True North from the linked model. The origin of the linked model's shared coordinates becomes the origin of the host model's shared coordinates.

When a Revit model acquires coordinates from a linked DWG file, the World Coordinate System (WCS) of the selected linked DWG file becomes the shared coordinate system of the host Revit model, based on the position of the linked DWG instance. The Y axis of the DWG becomes True North, and the origin of the DWG becomes the origin of the shared coordinate system of the Revit model.

On acquiring coordinates from a geo-referenced model, the geolocation information will be pulled from the linked model to the host model.

Unlike UI operation Acquire Coordinates, calling the API would always overwrite the geolocation information in the host model even if it is different from the one in the linked model, or the linked model has empty geolocation information (in which case the geolocation information in the host model would be removed).

See Also

Reference

Document Class


Document.AutoJoinElements Method

DocumentAutoJoinElements Method

Forces the elements in the Revit document to automatically join to their neighbors where appropriate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AutoJoinElements()
Public Sub AutoJoinElements
public:
void AutoJoinElements()
member AutoJoinElements : unit -> unit
Exceptions
Exception | Condition
AutoJoinFailedException | Thrown when the operation fails.
Remarks
Use this method to force elements in the document to automatically join to their neighbors. Note that when a transaction is committed there is an automatic call to automatically join elements.
See Also

Reference

Document Class


Document.CanEnableCloudWorksharing Method

DocumentCanEnableCloudWorksharing Method

Checks if cloud worksharing can be enabled for the cloud model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanEnableCloudWorksharing()
Public Function CanEnableCloudWorksharing As Boolean
public:
bool CanEnableCloudWorksharing()
member CanEnableCloudWorksharing : unit -> bool

Return Value

Boolean
True if cloud worksharing can be enabled in the document, which also means the current document is a single user cloud model, False otherwise.
See Also

Reference

Document Class


Document.CanEnableWorksharing Method

DocumentCanEnableWorksharing Method

Checks if worksharing can be enabled in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanEnableWorksharing()
Public Function CanEnableWorksharing As Boolean
public:
bool CanEnableWorksharing()
member CanEnableWorksharing : unit -> bool

Return Value

Boolean
True if worksharing can be enabled in the document, False otherwise.
See Also

Reference

Document Class


Document.Close Method

DocumentClose Method

Closes the document.
Overload List
 | Name | Description
Public method | Close | Closes the document, save the changes if there are.
Public method | Close(Boolean) | Closes the document with the option to save.
Top
See Also

Reference

Document Class


Document.Close Method

DocumentClose Method

Closes the document, save the changes if there are.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Close()
Public Function Close As Boolean
public:
bool Close()
member Close : unit -> bool

Return Value

Boolean
False if either closing procedure fails or if saving of a modified document failed. Also returns False if closing is cancelled by an external application during 'DocumentClosing' event. When function succeeds, True is returned.
Exceptions
Exception | Condition
InvalidOperationException | Thrown when attempting to close the currently active document. Thrown if there are any transactions, sub-transactions or transaction groups which were opened by the API code, and not closed. All of these items must be handled before attempting to close the document. Thrown if the PathName is not set yet. Thrown if the saving target file is read only.
InvalidOperationException | Thrown if this a linked file.
Remarks
The currently active document may not be closed by this function. It can only be closed via Revit's UI.

The changes will saved automatically, the document will not be closed if failed to save changes. If the document was created in this current session and has not been saved to a file yet, it needs to call Revit::UI::UIDocument::SaveAndClose() method instead.

See Also

Reference

Document Class
Close Overload


Document.Close(Boolean) Method

DocumentClose(Boolean) Method

Closes the document with the option to save.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Close(
    bool saveModified
)
Public Function Close (
    saveModified As Boolean
) As Boolean
public:
bool Close(
    bool saveModified
)
member Close :
        saveModified : bool -> bool

Parameters

saveModified Boolean
Indicates if the current document should be saved before close operation.

Return Value

Boolean
False if closing procedure fails or if saving of a modified document was requested (saveModified = True) but failed. Also returns False if closing is cancelled by an external application during 'DocumentClosing' event. When function succeeds, True is returned.
Exceptions
Exception | Condition
InvalidOperationException | Thrown when attempting to close the currently active document. Thrown if there are any transactions, sub-transactions or transaction groups which were opened by the API code, and not closed. All of these items must be handled before attempting to close the document. Thrown if saveModified is 'true' and the PathName is not set yet. Thrown if saveModified is 'true' and the saving target file is read only.
InvalidOperationException | Thrown if this a linked file.
Remarks
The currently active document may not be closed by this function. It can only be closed via Revit's UI.
See Also

Reference

Document Class
Close Overload


Document.CombineElements Method

DocumentCombineElements Method

Combine a set of combinable elements into a geometry combination.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GeomCombination CombineElements(
    CombinableElementArray members
)
Public Function CombineElements (
    members As CombinableElementArray
) As GeomCombination
public:
GeomCombination^ CombineElements(
    CombinableElementArray^ members
)
member CombineElements :
        members : CombinableElementArray -> GeomCombination

Parameters

members CombinableElementArray
A list of combinable elements to be combined.

Return Value

GeomCombination
If successful, the newly created geometry combination is returned, otherwise an exception with error information will be thrown.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument is .
ArgumentException | Thrown when members contains less than two elements. Thrown when members contains elements.
InvalidOperationException | Thrown when creation of the combination failed.
Remarks
If one or more existing geometry combinations are included as input, the return value may be one of those pre-existing combinations. The rest of the pre-existing geometry combinations will be consumed into the new combination; those handles are no longer valid.
See Also

Reference

Document Class


Document.ConvertDetailToModelCurves Method

DocumentConvertDetailToModelCurves Method

Converts a group of DetailCurves to equivalent ModelCurves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ModelCurveArray ConvertDetailToModelCurves(
    View view,
    DetailCurveArray detailCurves
)
Public Function ConvertDetailToModelCurves (
    view As View,
    detailCurves As DetailCurveArray
) As ModelCurveArray
public:
ModelCurveArray^ ConvertDetailToModelCurves(
    View^ view,
    DetailCurveArray^ detailCurves
)
member ConvertDetailToModelCurves :
        view : View *
        detailCurves : DetailCurveArray -> ModelCurveArray

Parameters

view View
The view where the new lines will be created. The lines are projected on the view workplane. The view workplane must be parallel to the view plane.
detailCurves DetailCurveArray
The detail curve array to be converted.

Return Value

ModelCurveArray
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument is .
ArgumentException | Thrown when the given detail lines are not visible in the given view. Thrown when the detail lines are not in the same view or not parallel to the given view.
InvalidOperationException | Thrown when one or more curves could not be successfully converted.
Remarks
This operation will create new ModelCurves with the same geometry of the original detail curves' geometry. The detail curves will be deleted from the document.
See Also

Reference

Document Class


Document.ConvertModelToDetailCurves Method

DocumentConvertModelToDetailCurves Method

Converts a group of ModelCurves to equivalent DetailCurves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DetailCurveArray ConvertModelToDetailCurves(
    View view,
    ModelCurveArray modelCurves
)
Public Function ConvertModelToDetailCurves (
    view As View,
    modelCurves As ModelCurveArray
) As DetailCurveArray
public:
DetailCurveArray^ ConvertModelToDetailCurves(
    View^ view,
    ModelCurveArray^ modelCurves
)
member ConvertModelToDetailCurves :
        view : View *
        modelCurves : ModelCurveArray -> DetailCurveArray

Parameters

view View
The view where the new lines will be created. The lines are projected on the view plane. If the lines are not parallel to the view plane, lines are foreshortened and arcs are converted to ellipses. Splines are modified.
modelCurves ModelCurveArray
The model curve array to be converted.

Return Value

DetailCurveArray
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument is .
ArgumentException | Thrown when view is invalid to create DetailCurves on it.
InvalidOperationException | Thrown when current document is a family. Thrown when one or more curves could not be successfully converted, perhaps because some of the input curves could not be projected onto the active workplane of the view.
Remarks
This operation will create new DetailCurves with the same geometry of the original model curves' geometry. The model curves will be deleted from the document. If the model curves do not lie in a plane parallel to the view, their geometry will be projected to the view.
See Also

Reference

Document Class


Document.ConvertModelToSymbolicCurves Method

DocumentConvertModelToSymbolicCurves Method

Converts a group of ModelCurves to equivalent SymbolicCurves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SymbolicCurveArray ConvertModelToSymbolicCurves(
    View view,
    ModelCurveArray modelCurves
)
Public Function ConvertModelToSymbolicCurves (
    view As View,
    modelCurves As ModelCurveArray
) As SymbolicCurveArray
public:
SymbolicCurveArray^ ConvertModelToSymbolicCurves(
    View^ view,
    ModelCurveArray^ modelCurves
)
member ConvertModelToSymbolicCurves :
        view : View *
        modelCurves : ModelCurveArray -> SymbolicCurveArray

Parameters

view View
The view where the new lines will be created. The lines are projected on the view workplane. The view workplane must be parallel to the view plane. If the lines are not parallel to the view plane, lines are foreshortened and arcs are converted to ellipses. Splines are modified.
modelCurves ModelCurveArray
The model curve array to be converted.

Return Value

SymbolicCurveArray
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument is .
ArgumentException | Thrown when view is invalid to create SymbolicCurves on it.
InvalidOperationException | Thrown when current document is a family. Thrown when one or more curves could not be successfully converted, perhaps because some of the input curves could not be projected onto the active workplane of the view.
Remarks
This operation will create new SymbolicCurves with the modelCurves' geometry curves and delete the ModelCurve in the array. If modelCurves are not parallel to the workplane, they will be projected to the workplane and create new SymbolicCurves with the projected curves.
See Also

Reference

Document Class


Document.ConvertSymbolicToModelCurves Method

DocumentConvertSymbolicToModelCurves Method

Converts a group of SymbolicCurves to equivalent ModelCurves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ModelCurveArray ConvertSymbolicToModelCurves(
    View view,
    SymbolicCurveArray symbolicCurve
)
Public Function ConvertSymbolicToModelCurves (
    view As View,
    symbolicCurve As SymbolicCurveArray
) As ModelCurveArray
public:
ModelCurveArray^ ConvertSymbolicToModelCurves(
    View^ view,
    SymbolicCurveArray^ symbolicCurve
)
member ConvertSymbolicToModelCurves :
        view : View *
        symbolicCurve : SymbolicCurveArray -> ModelCurveArray

Parameters

view View
The view where the new lines will be created. The lines are projected on the view workplane. The view workplane must be parallel to the view plane.
symbolicCurve SymbolicCurveArray
The symbolic curve array to be converted.

Return Value

ModelCurveArray
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument is .
InvalidOperationException | Thrown when one or more curves could not be successfully converted.
Remarks
This operation will create new ModelCurves with the symbolicCurves' geometry curves and delete the SymbolicCurve in the array.
See Also

Reference

Document Class


Document.Delete Method

DocumentDelete Method

Overload List
Name | Description
Delete(ElementId) | Deletes an element from the document given the id of that element.
Delete(ICollectionElementId) | Deletes a set of elements from the document.
Top
See Also

Reference

Document Class


Document.Delete(ElementId) Method

DocumentDelete(ElementId) Method

Deletes an element from the document given the id of that element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> Delete(
    ElementId elementId
)
Public Function Delete (
    elementId As ElementId
) As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ Delete(
    ElementId^ elementId
)
member Delete :
        elementId : ElementId -> ICollection<ElementId>

Parameters

elementId ElementId
Id of the element to delete.

Return Value

ICollection ElementId
The deleted element id set.
Exceptions
Exception | Condition
ArgumentException | The element elementId does not exist in the document -or- ElementId cannot be deleted.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
This method will delete the element and any elements that are totally dependent upon that element. Any references to the deleted elements will become invalid and hence cause an exception to be thrown if they are accessed. The elements will be deleted with no prompts for user confirmation. Pinned elements will be deleted with no warnings.

Note: in a family document, the predefined elements (those elements inherited from its family template file) can't be deleted by this method.

Example
C#
VB
C++
F#
Copy
private void DeleteElement(Autodesk.Revit.DB.Document document, Element element)
{
    // Delete a selected element.
   ICollection<Autodesk.Revit.DB.ElementId> deletedIdSet = document.Delete(element.Id);

    if (0 == deletedIdSet.Count)
    {
        throw new Exception("Deleting the selected element in Revit failed.");
    }

    String prompt = "The selected element has been removed and ";
    prompt += deletedIdSet.Count - 1;
    prompt += " more dependent elements have also been removed.";

    // Give the user some information
    TaskDialog.Show("Revit",prompt);

}
Private Sub DeleteElement(document As Autodesk.Revit.DB.Document, element As Element)
    ' Delete a selected element.
    Dim deletedIdSet As ICollection(Of Autodesk.Revit.DB.ElementId) = document.Delete(element.Id)

    If 0 = deletedIdSet.Count Then
        Throw New Exception("Deleting the selected element in Revit failed.")
    End If

    Dim prompt As [String] = "The selected element has been removed and "
    prompt += deletedIdSet.Count - 1
    prompt += " more dependent elements have also been removed."

    ' Give the user some information
    TaskDialog.Show("Revit", prompt)

End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

C#
VB
C++
F#
Copy
private void DeleteElement(Autodesk.Revit.DB.Document document, Element element)
{
    // Delete an element via its id
    Autodesk.Revit.DB.ElementId elementId = element.Id;
    ICollection<Autodesk.Revit.DB.ElementId> deletedIdSet = document.Delete(elementId);

    if (0 == deletedIdSet.Count)
    {
        throw new Exception("Deleting the selected element in Revit failed.");
    }

    String prompt = "The selected element has been removed and ";
    prompt += deletedIdSet.Count - 1;
    prompt += " more dependent elements have also been removed.";

    // Give the user some information
    TaskDialog.Show("Revit", prompt);
}
Private Sub DeleteElement(document As Autodesk.Revit.DB.Document, element As Element)
    ' Delete an element via its id
    Dim elementId As Autodesk.Revit.DB.ElementId = element.Id
    Dim deletedIdSet As ICollection(Of Autodesk.Revit.DB.ElementId) = document.Delete(elementId)

    If 0 = deletedIdSet.Count Then
        Throw New Exception("Deleting the selected element in Revit failed.")
    End If

    Dim prompt As [String] = "The selected element has been removed and "
    prompt += deletedIdSet.Count - 1
    prompt += " more dependent elements have also been removed."

    ' Give the user some information
    TaskDialog.Show("Revit", prompt)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Document Class
Delete Overload


Document.Delete(ICollection<ElementId>) Method

DocumentDelete(ICollectionElementId) Method

Deletes a set of elements from the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> Delete(
    ICollection<ElementId> elementIds
)
Public Function Delete (
    elementIds As ICollection(Of ElementId)
) As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ Delete(
    ICollection<ElementId^>^ elementIds
)
member Delete :
        elementIds : ICollection<ElementId> -> ICollection<ElementId>

Parameters

elementIds ICollection ElementId
The ids of the elements to delete.

Return Value

ICollection ElementId
The deleted element id set.
Exceptions
Exception | Condition
ArgumentException | One or more elements in elementIds do not exist in the document. -or- One or more of the elementIds cannot be deleted.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
This method will delete the elements and any elements that are totally dependent upon that element. Any references to the deleted elements will become invalid and hence cause an exception to be thrown if they are accessed. The elements will be deleted with no prompts for user confirmation. Pinned elements will be deleted with no warnings.

Note: in a family document, the predefined elements (those elements inherited from its family template file) can't be deleted by this method.

Example
C#
VB
C++
F#
Copy
// Delete all the selected elements via the set of element ids.
ICollection<Autodesk.Revit.DB.ElementId> idSelection = null ;
 UIDocument uidoc = new UIDocument(document);
 ICollection<ElementId> selectedIds = uidoc.Selection.GetElementIds();
 foreach (ElementId id in selectedIds)
 {
     idSelection.Add(id);
 }
 ICollection<Autodesk.Revit.DB.ElementId> deletedIdSet = document.Delete(idSelection);

 if (0 == deletedIdSet.Count)
 {
     throw new Exception("Deleting the selected elements in Revit failed.");
 }

 TaskDialog.Show("Revit","The selected element has been removed.");
' Delete all the selected elements via the set of element ids.
Dim idSelection As ICollection(Of Autodesk.Revit.DB.ElementId) = Nothing
Dim uidoc As New UIDocument(document)
Dim selectedIds As ICollection(Of ElementId) = uidoc.Selection.GetElementIds()
For Each id As ElementId In selectedIds
    idSelection.Add(id)
Next
Dim deletedIdSet As ICollection(Of Autodesk.Revit.DB.ElementId) = document.Delete(idSelection)

If 0 = deletedIdSet.Count Then
    Throw New Exception("Deleting the selected elements in Revit failed.")
End If

TaskDialog.Show("Revit", "The selected element has been removed.")

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

C#
VB
C++
F#
Copy
// Delete all the selected elements via the set of elements
UIDocument uidoc = new UIDocument(document);
ICollection<ElementId> elements = uidoc.Selection.GetElementIds();
ICollection<Autodesk.Revit.DB.ElementId> deletedIdSet = document.Delete(elements);

if (0 == deletedIdSet.Count)
{
    throw new Exception("Deleting the selected elements in Revit failed.");
}

TaskDialog.Show("Revit","The selected element has been removed.");
' Delete all the selected elements via the set of elements
Dim uidoc As New UIDocument(document)
Dim elements As ICollection(Of ElementId) = uidoc.Selection.GetElementIds()
Dim deletedIdSet As ICollection(Of Autodesk.Revit.DB.ElementId) = document.Delete(elements)

If 0 = deletedIdSet.Count Then
    Throw New Exception("Deleting the selected elements in Revit failed.")
End If

TaskDialog.Show("Revit", "The selected element has been removed.")

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Document Class
Delete Overload


Document.Dispose Method

DocumentDispose Method

Releases all resources used by the Document

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

Document Class


Document.EditFamily Method

DocumentEditFamily Method

Gets the document of a loaded family to edit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Document EditFamily(
    Family loadedFamily
)
Public Function EditFamily (
    loadedFamily As Family
) As Document
public:
Document^ EditFamily(
    Family^ loadedFamily
)
member EditFamily :
        loadedFamily : Family -> Document

Parameters

loadedFamily Family
The loaded family in current document.

Return Value

Document
Reference of the document of the family.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument-"loadedFamily"-is .
ArgumentException | Thrown when the input argument-"loadedFamily"-is an in-place family or a non-editable family. (This can be checked with the IsInPlace and IsEditable properties of the Family class.
InvalidOperationException | Thrown when the family is already being edited.
ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.
InvalidOperationException | Thrown if this method is called while the document is modifiable (i.e. it has an unfinished transaction.)
InvalidOperationException | Thrown if this method is currently in a read-only state.
Remarks
This creates an independent copy of the family for editing. To apply the changes back to the family stored in the document, use the LoadFamily overload accepting IFamilyLoadOptions.

This method may not be called if the document is currently modifiable (has an open transaction) or is in a read-only state. The method may not be called during dynamic updates. To test the document's current status, check the values of IsModifiable and IsReadOnly properties.

Example
C#
VB
C++
F#
Copy
public void GetLoadedSymbols(Autodesk.Revit.DB.Document document, FamilyInstance familyInstance)
{
    if (null != familyInstance.Symbol)
    {
        // Get family associated with this
        Family family = familyInstance.Symbol.Family;

        // Get Family document for family
        Document familyDoc = document.EditFamily(family);
        if (null != familyDoc && familyDoc.IsFamilyDocument == true)
        {
            String loadedFamilies = "FamilySymbols in " + family.Name + ":\n";
            FilteredElementCollector collector = new FilteredElementCollector(document);
            ICollection<Element> collection =
                collector.OfClass(typeof(FamilySymbol)).ToElements();
            foreach (Element e in collection)
            {
                FamilySymbol fs = e as FamilySymbol;
                loadedFamilies += "\t" + fs.Name + "\n";
            }

            TaskDialog.Show("Revit",loadedFamilies);
        }
    }
}
Public Sub GetLoadedSymbols(document As Autodesk.Revit.DB.Document, familyInstance As FamilyInstance)
    If familyInstance.Symbol IsNot Nothing Then
        ' Get family associated with this
        Dim family As Family = familyInstance.Symbol.Family

        ' Get Family document for family
        Dim familyDoc As Document = document.EditFamily(family)
        If familyDoc IsNot Nothing AndAlso familyDoc.IsFamilyDocument = True Then
            Dim loadedFamilies As [String] = "FamilySymbols in " + family.Name & ":" & vbLf
            Dim collector As New FilteredElementCollector(document)
            Dim collection As ICollection(Of Element) = collector.OfClass(GetType(FamilySymbol)).ToElements()
            For Each e As Element In collection
                Dim fs As FamilySymbol = TryCast(e, FamilySymbol)
                loadedFamilies += vbTab + fs.Name & vbLf
            Next

            TaskDialog.Show("Revit", loadedFamilies)
        End If
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Document Class


Document.EnableCloudWorksharing Method

DocumentEnableCloudWorksharing Method

Enables cloud worksharing for a cloud model

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void EnableCloudWorksharing()
Public Sub EnableCloudWorksharing
public:
void EnableCloudWorksharing()
member EnableCloudWorksharing : unit -> unit
Exceptions
Exception | Condition
CentralModelAccessDeniedException | Access to the cloud model was denied due to lack of access privileges. -or- Access to the central model was denied. A possible reason is because the model was under maintenance.
CentralModelContentionException | The central model is locked by another client.
CentralModelException | The model in cloud is missing. -or- The model in cloud is incompatible. -or- The model in cloud is corrupt or not an RVT file. -or- The model in cloud was rolled back. -or- An internal error happened on the model in cloud , please contact the administrator.
FileNotFoundException | Cannot access the local cache.
InvalidOperationException | This Document is not a primary document, it is a linked document. -or- This Document is read-only: It cannot be modified. -or- This Document has an open editing transaction and is accepting changes. -or- This Document is not a project document. -or- This Document is in an edit mode. -or- Saving is not allowed in the current application mode. -or- This Document does not have a central location: Worksharing needs to be enabled and central model saved. -or- The file is read-only, can not be saved. -or- The cloud model does not allow cloud worksharing to be enabled. -or- Operation is not permitted when there is any open sub-transaction, transaction, or transaction group.
RevitServerCommunicationException | Could be for any of the reasons related to network.
RevitServerInternalException | Could be for any of the reasons that conversion fails with RevitServerInternalException.
RevitServerUnauthenticatedUserException | User is not signed in with Autodesk id.
RevitServerUnauthorizedException | You do not have workshared cloud model entitlement to access this resource in cloud -or- User is not authorized to access the specified cloud project.
Remarks
This operation will convert an existing cloud model to a workshared cloud model. This method cannot be used if current model is not a cloud model. This method cannot be used if the current user doesn't have the workshared cloud model entitlement.
See Also

Reference

Document Class


Document.EnableWorksharing Method

DocumentEnableWorksharing Method

Enables worksharing in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void EnableWorksharing(
    string worksetNameGridLevel,
    string worksetName
)
Public Sub EnableWorksharing (
    worksetNameGridLevel As String,
    worksetName As String
)
public:
void EnableWorksharing(
    String^ worksetNameGridLevel,
    String^ worksetName
)
member EnableWorksharing :
        worksetNameGridLevel : string *
        worksetName : string -> unit

Parameters

worksetNameGridLevel String
Name of workset for grids and levels.
worksetName String
Name of workset for all other elements.
Exceptions
Exception | Condition
ArgumentException | worksetNameGridLevel is an empty string. -or- worksetName is an empty string. -or- worksetNameGridLevel cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- worksetName cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~".
ArgumentNullException | A non-optional argument was null
ForbiddenForDynamicUpdateException | This method may not be called during dynamic update.
InvalidOperationException | The document does not allow worksharing to be enabled. -or- This Document is in an edit mode. -or- This Document is a workshared document. -or- There is a transaction phase left open (such as a transaction, sub-transaction of transaction group) at the time of invoking this method.
OperationCanceledException | Enabling worksharing was cancelled.
Remarks
The document's Undo history will be cleared by this command. As a result, this command and others executed before it cannot be undone.

All transaction phases (e.g. transactions transaction groups and sub-transaction) that were explicitly started must be finished prior to calling this method.

See Also

Reference

Document Class


Document.Equals Method

DocumentEquals Method

Determines whether the specified Object equals to this Object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj Object

Return Value

Boolean
Remarks
Two document instances are considered equal if they represent the same document currently opened in the Revit session.
See Also

Reference

Document Class


Document.EraseSchemaAndAllEntities Method

DocumentEraseSchemaAndAllEntities Method

Erases Schema and all its Entities from the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void EraseSchemaAndAllEntities(
    Schema schema
)
Public Sub EraseSchemaAndAllEntities (
    schema As Schema
)
public:
void EraseSchemaAndAllEntities(
    Schema^ schema
)
member EraseSchemaAndAllEntities :
        schema : Schema -> unit

Parameters

schema Schema
The Schema to erase.
Exceptions
Exception | Condition
ArgumentException | No write access to this Schema.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
The Schema remains in memory. Any schema the schema is a sub-schema for will not be impacted. All data referenced by the schema as the result of being a sub-schema will remain in the document.
See Also

Reference

Document Class


Document.Export Method

DocumentExport Method

Overload List
 | Name | Description
Public method | Export(String, IListElementId, PDFExportOptions) | Exports a selection of views in PDF format.
Public method | Export(String, String, GBXMLExportOptions) | Export the model in gbXML (green-building) format.
Public method | Export(String, String, IFCExportOptions) | Exports the document to the Industry Standard Classes (IFC) format.
Public method | Export(String, String, NavisworksExportOptions) | Exports a Revit project to the Navisworks .nwc format.
Public method | Export(String, String, OBJExportOptions) | Exports a view specified in the export options to the OBJ format.
Public method | Export(String, String, STEPExportOptions) | Exports the current view or a selection of views in STEP format.
Public method | Export(String, String, STLExportOptions) | Exports a view specified in the export options to the STL format.
 | Export(String, String, ViewSet, DWFExportOptions) | Exports the current view or a selection of views in DWF format.
Public method | Export(String, String, ViewSet, DWFXExportOptions) | Exports the current view or a selection of views in DWFX format.
Public method | Export(String, String, ViewSet, FBXExportOptions) | Exports the document in 3D-Studio Max (FBX) format.
 | Export(String, String, ICollectionElementId, DGNExportOptions) | Exports a selection of views in DGN format.
 | Export(String, String, ICollectionElementId, DWGExportOptions) | Exports a selection of views in DWG format.
Public method | Export(String, String, ICollectionElementId, DXFExportOptions) | Exports a selection of views in DXF format.
Public method | Export(String, String, ICollectionElementId, SATExportOptions) | Exports the current view or a selection of views in SAT format.
Top
See Also

Reference

Document Class


Document.Export(String, IList<ElementId>, PDFExportOptions) Method

DocumentExport(String, IListElementId, PDFExportOptions) Method

Exports a selection of views in PDF format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Export(
    string folder,
    IList<ElementId> viewIds,
    PDFExportOptions options
)
Public Function Export (
    folder As String,
    viewIds As IList(Of ElementId),
    options As PDFExportOptions
) As Boolean
public:
bool Export(
    String^ folder,
    IList<ElementId^>^ viewIds,
    PDFExportOptions^ options
)
member Export :
        folder : string *
        viewIds : IList<ElementId> *
        options : PDFExportOptions -> bool

Parameters

folder String
Output folder, into which file(s) will be exported. The folder must exist.
viewIds IList ElementId
Selection of ordered views to be exported. The list must contain at least one valid view.
options PDFExportOptions
Various options applicable to the PDF format.

Return Value

Boolean
True if all specified views are exported successfully, False if exporting of any view fails, even if some views might have been exported successfully.
Exceptions
Exception | Condition
ArgumentException | non empty list of views must be provided. -or- NullOrEmpty -or- There are duplicate views in viewIds -or- some of the views are not printable (exportable). -or- Thrown when one or more input arguments are invalid.
ArgumentNullException | A non-optional argument was null
FileAccessException | Thrown when the target PDF file is inaccessible, e.g. already opened.
InvalidOperationException | A PDF Export is already occurring on this document. -or- There are too many PDF Exports in progress (3). -or- A PDF Export cannot occur in the background in a Family document. -or- Export is temporarily disabled. -or- Exporting is not allowed in the current application mode.
InvalidPathArgumentException | The folder does not exist.
See Also

Reference

Document Class
Export Overload


Document.Export(String, String, GBXMLExportOptions) Method

DocumentExport(String, String, GBXMLExportOptions) Method

Export the model in gbXML (green-building) format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Export(
    string folder,
    string name,
    GBXMLExportOptions options
)
Public Function Export (
    folder As String,
    name As String,
    options As GBXMLExportOptions
) As Boolean
public:
bool Export(
    String^ folder,
    String^ name,
    GBXMLExportOptions^ options
)
member Export :
        folder : string *
        name : string *
        options : GBXMLExportOptions -> bool

Parameters

folder String
Indicates the path of a folder where to export the gbXML file.
name String
Indicates the name of the gbXML file to export. If it doesn't end with ".xml", extension ".xml" will be added automatically. The name cannot contain any of the following characters: \/:*?"<>|. Empty name is not acceptable.
options GBXMLExportOptions
Options which control the contents of the export.

Return Value

Boolean
True if successful, otherwise False.
Exceptions
Exception | Condition
ArgumentException | The path is not valid for exporting gbXML files. -or- The name is empty or not valid for exporting gbXML files. -or- Analysis type is invalid. For AnalysisMode.ConceptualMasses, use Document.Export(String, String, MassGBXMLExportOptions). -or- There is no main EnergyAnalysisDetailModel in the document, or the current main EnergyAnalysisDetailModel is not compatible with the option set in the GBXMLExportOptions.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Exporting is not allowed in the current application mode. -or- Export is temporarily disabled.
Remarks
This export operation will operate on the main EnergyAnalysisDetailModel in the document, if it exists (see EnergyAnalysisDetailModel.GetMainEnergyAnalysisDetailModel()). If it does not exist, or if the requested ExportEnergyModelType does not match the type of the main EnergyAnalysisDetailModel, this function will fail. If you need to export a model with different settings or type than the current main energy model in the document, you should delete the current main energy model, update the EnergyAnalysisSettings, and regenerate the energy model.
See Also

Reference

Document Class
Export Overload


Document.Export(String, String, IFCExportOptions) Method

DocumentExport(String, String, IFCExportOptions) Method

Exports the document to the Industry Standard Classes (IFC) format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Export(
    string folder,
    string name,
    IFCExportOptions options
)
Public Function Export (
    folder As String,
    name As String,
    options As IFCExportOptions
) As Boolean
public:
bool Export(
    String^ folder,
    String^ name,
    IFCExportOptions^ options
)
member Export :
        folder : string *
        name : string *
        options : IFCExportOptions -> bool

Parameters

folder String
Output folder into which the file will be exported. The folder must exist.
name String
Either the name of a single file or a prefix for a set of files. If empty, automatic naming will be used.
options IFCExportOptions
Various options applicable to the IFC format. If , all options will be set to their respective default values.

Return Value

Boolean
True if successful, otherwise False.
Exceptions
Exception | Condition
ArgumentException | NullOrEmpty -or- Contains invalid characters.
ArgumentNullException | A non-optional argument was null
FileArgumentNotFoundException | The IFCExportOptions FamilyMappingFile does not exist.
ForbiddenForDynamicUpdateException | This method may not be called during dynamic update.
InvalidOperationException | Export is temporarily disabled. -or- Exporting is not allowed in the current application mode. -or- This Document is not a project document.
InvalidPathArgumentException | The folder does not exist.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
OptionalFunctionalityNotAvailableException | The IFC module is not available in the installed Revit.
Remarks
Exporting to IFC requires that document is modifiable, therefore there must be a transaction already open when this method is called.

This method may not be invoked during dynamic update, for the internal routine might need to modify the existing transaction.

See Also

Reference

Document Class
Export Overload


Document.Export(String, String, NavisworksExportOptions) Method

DocumentExport(String, String, NavisworksExportOptions) Method

Exports a Revit project to the Navisworks .nwc format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Export(
    string folder,
    string name,
    NavisworksExportOptions options
)
Public Sub Export (
    folder As String,
    name As String,
    options As NavisworksExportOptions
)
public:
void Export(
    String^ folder,
    String^ name,
    NavisworksExportOptions^ options
)
member Export :
        folder : string *
        name : string *
        options : NavisworksExportOptions -> unit

Parameters

folder String
The name of the folder for the exported file.
name String
The name of the exported file. If it doesn't end in '.nwc', this extension will be added automatically.
options NavisworksExportOptions
Options which control the contents of the export.
Exceptions
Exception | Condition
ArgumentException | NullOrEmpty -or- Contains invalid characters. -or- The input options were not valid. Check the exception message for specific details.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Export is temporarily disabled. -or- Exporting is not allowed in the current application mode.
InvalidPathArgumentException | The folder does not exist.
OperationCanceledException | The export operation is cancelled in event handler.
OptionalFunctionalityNotAvailableException | A Navisworks Exporter is not available in the installed Revit.
Remarks
This is an optional functionality that does not have to be installed. The method "OptionalFunctionalityUtils.isNavisworksExporterAvailable()" can be called to check if the exporter is present.
See Also

Reference

Document Class
Export Overload


Document.Export(String, String, OBJExportOptions) Method

DocumentExport(String, String, OBJExportOptions) Method

Exports a view specified in the export options to the OBJ format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Export(
    string folder,
    string name,
    OBJExportOptions options
)
Public Function Export (
    folder As String,
    name As String,
    options As OBJExportOptions
) As Boolean
public:
bool Export(
    String^ folder,
    String^ name,
    OBJExportOptions^ options
)
member Export :
        folder : string *
        name : string *
        options : OBJExportOptions -> bool

Parameters

folder String
Output folder into which the file will be exported. The folder must exist.
name String
Indicates the name of the OBJ file to export. If it doesn't end with ".obj", this extension will be added automatically. The name cannot contain any of the following characters: \/:*?"<>|. Empty name is not acceptable.
options OBJExportOptions
Various options applicable to the OBJ format.

Return Value

Boolean
True if successful, otherwise False.
Exceptions
Exception | Condition
ArgumentException | NullOrEmpty -or- Contains invalid characters. -or- The provided options do not specify a printable 3D view.
ArgumentNullException | A non-optional argument was null
ForbiddenForDynamicUpdateException | This method may not be called during dynamic update.
InvalidOperationException | Export is temporarily disabled. -or- Exporting is not allowed in the current application mode.
InvalidPathArgumentException | The folder does not exist.
OptionalFunctionalityNotAvailableException | The ShapeExporter functionality is not available in the installed Revit, or the Material Library is missing.
See Also

Reference

Document Class
Export Overload


Document.Export(String, String, STEPExportOptions) Method

DocumentExport(String, String, STEPExportOptions) Method

Exports the current view or a selection of views in STEP format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Export(
    string folder,
    string name,
    STEPExportOptions options
)
Public Function Export (
    folder As String,
    name As String,
    options As STEPExportOptions
) As Boolean
public:
bool Export(
    String^ folder,
    String^ name,
    STEPExportOptions^ options
)
member Export :
        folder : string *
        name : string *
        options : STEPExportOptions -> bool

Parameters

folder String
Output folder, into which file(s) will be exported. The folder must exist.
name String
Either the name of a single file or a prefix for a set of files. If empty, automatic naming will be used.
options STEPExportOptions
Various options applicable to the STEP format.

Return Value

Boolean
True if successful, otherwise False.
Exceptions
Exception | Condition
ArgumentException | NullOrEmpty -or- Contains invalid characters. -or- The provided options do not specify a printable 3D view.
ArgumentNullException | A non-optional argument was null
ForbiddenForDynamicUpdateException | This method may not be called during dynamic update.
InvalidOperationException | Export is temporarily disabled. -or- Exporting is not allowed in the current application mode.
InvalidPathArgumentException | The folder does not exist.
OptionalFunctionalityNotAvailableException | The ShapeExporter functionality is not available in the installed Revit, or the Material Library is missing.
Remarks
All the views must be 3D views for the Export to succeed.
See Also

Reference

Document Class
Export Overload


Document.Export(String, String, STLExportOptions) Method

DocumentExport(String, String, STLExportOptions) Method

Exports a view specified in the export options to the STL format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Export(
    string folder,
    string name,
    STLExportOptions options
)
Public Function Export (
    folder As String,
    name As String,
    options As STLExportOptions
) As Boolean
public:
bool Export(
    String^ folder,
    String^ name,
    STLExportOptions^ options
)
member Export :
        folder : string *
        name : string *
        options : STLExportOptions -> bool

Parameters

folder String
Output folder into which the file will be exported. The folder must exist.
name String
Indicates the name of the STL file to export. If it doesn't end with ".stl", this extension will be added automatically. The name cannot contain any of the following characters: \/:*?"<>|. Empty name is not acceptable.
options STLExportOptions
Various options applicable to the STL format.

Return Value

Boolean
True if successful, otherwise False.
Exceptions
Exception | Condition
ArgumentException | NullOrEmpty -or- Contains invalid characters. -or- The provided options do not specify a printable 3D view.
ArgumentNullException | A non-optional argument was null
ForbiddenForDynamicUpdateException | This method may not be called during dynamic update.
InvalidOperationException | Export is temporarily disabled. -or- Exporting is not allowed in the current application mode.
InvalidPathArgumentException | The folder does not exist.
OptionalFunctionalityNotAvailableException | The ShapeExporter functionality is not available in the installed Revit, or the Material Library is missing.
See Also

Reference

Document Class
Export Overload


Document.Export(String, String, ViewSet, DWFExportOptions) Method

DocumentExport(String, String, ViewSet, DWFExportOptions) Method

Exports the current view or a selection of views in DWF format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Export(
    string folder,
    string name,
    ViewSet views,
    DWFExportOptions options
)
Public Function Export (
    folder As String,
    name As String,
    views As ViewSet,
    options As DWFExportOptions
) As Boolean
public:
bool Export(
    String^ folder,
    String^ name,
    ViewSet^ views,
    DWFExportOptions^ options
)
member Export :
        folder : string *
        name : string *
        views : ViewSet *
        options : DWFExportOptions -> bool

Parameters

folder String
Output folder, into which file(s) will be exported. The folder must exist.
name String
Either the name of a single file or a prefix for a set of files. If or empty, automatic naming will be used.
views ViewSet
Selection of views to be exported.
options DWFExportOptions
Various options applicable to the DWF format. If , all options will be set to their respective default values.

Return Value

Boolean
Function returns true only if all specified views are exported successfully. Returns False if exporting of any view fails, even if some views might have been exported successfully.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input views is
ArgumentException | Thrown when the input views is an empty ViewSet.
InvalidOperationException | Thrown when the current document is not modifiable.
Remarks
All the views must be printable in order for the Export to succeed. It can be assured by checking the CanBePrinted property of each view.
Example
C#
VB
C++
F#
Copy
public bool ExportViewToDWF(Document document, View view, string pathname)
{
    DWFExportOptions dwfOptions = new DWFExportOptions();
    // export with crop box and area and room geometry
    dwfOptions.CropBoxVisible = true;
    dwfOptions.ExportingAreas = true;
    dwfOptions.ExportTexture = false;

    ViewSet views = new ViewSet();
    views.Insert(view);
    return (document.Export(Path.GetDirectoryName(pathname),
        Path.GetFileNameWithoutExtension(pathname), views, dwfOptions));
}
Public Function ExportViewToDWF(document As Document, view As View, pathname As String) As Boolean
   Dim dwfOptions As New DWFExportOptions()
   ' export with crop box and area and room geometry
   dwfOptions.CropBoxVisible = True
   dwfOptions.ExportingAreas = True
   dwfOptions.ExportTexture = False

   Dim views As New ViewSet()
   views.Insert(view)
   Return (document.Export(Path.GetDirectoryName(pathname), Path.GetFileNameWithoutExtension(pathname), views, dwfOptions))
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Document Class
Export Overload


Document.Export(String, String, ViewSet, DWFXExportOptions) Method

DocumentExport(String, String, ViewSet, DWFXExportOptions) Method

Exports the current view or a selection of views in DWFX format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Export(
    string folder,
    string name,
    ViewSet views,
    DWFXExportOptions options
)
Public Function Export (
    folder As String,
    name As String,
    views As ViewSet,
    options As DWFXExportOptions
) As Boolean
public:
bool Export(
    String^ folder,
    String^ name,
    ViewSet^ views,
    DWFXExportOptions^ options
)
member Export :
        folder : string *
        name : string *
        views : ViewSet *
        options : DWFXExportOptions -> bool

Parameters

folder String
Output folder, into which file(s) will be exported. The folder must exist.
name String
Either the name of a single file or a prefix for a set of files. If or empty, automatic naming will be used.
views ViewSet
Selection of views to be exported.
options DWFXExportOptions
Various options applicable to the DWFX format. If , all options will be set to their respective default values.

Return Value

Boolean
Function returns true only if all specified views are exported successfully. The function returns False if exporting of any view fails, even if some views might have been exported successfully.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input views is
ArgumentException | Thrown when the input views is an empty ViewSet.
InvalidOperationException | Thrown when the current document is not modifiable.
Remarks
All the views must be printable in order for the Export to succeed. It can be assured by checking the CanBePrinted property of each view.
See Also

Reference

Document Class
Export Overload


Document.Export(String, String, ViewSet, FBXExportOptions) Method

DocumentExport(String, String, ViewSet, FBXExportOptions) Method

Exports the document in 3D-Studio Max (FBX) format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Export(
    string folder,
    string name,
    ViewSet views,
    FBXExportOptions options
)
Public Function Export (
    folder As String,
    name As String,
    views As ViewSet,
    options As FBXExportOptions
) As Boolean
public:
bool Export(
    String^ folder,
    String^ name,
    ViewSet^ views,
    FBXExportOptions^ options
)
member Export :
        folder : string *
        name : string *
        views : ViewSet *
        options : FBXExportOptions -> bool

Parameters

folder String
Output folder, into which file(s) will be exported. The folder must exist.
name String
Either the name of a single file or a prefix for a set of files. If or empty, automatic naming will be used.
views ViewSet
Selection of views to be exported.Only 3D views are allowed.
options FBXExportOptions
Options applicable to the FBX format.

Return Value

Boolean
Function returns true only if all specified views are exported successfully. The function returns False if exporting of any view fails, even if some views might have been exported successfully.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input views is
ArgumentException | Thrown when the input views is an empty ViewSet. Thrown if any view in the views is not a 3D view.
Remarks
Though the 'options' argument is not currently used, an object still must be provided (may be ).
See Also

Reference

Document Class
Export Overload


Document.Export(String, String, ICollection<ElementId>, DGNExportOptions) Method

DocumentExport(String, String, ICollectionElementId, DGNExportOptions) Method

Exports a selection of views in DGN format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Export(
    string folder,
    string name,
    ICollection<ElementId> views,
    DGNExportOptions options
)
Public Function Export (
    folder As String,
    name As String,
    views As ICollection(Of ElementId),
    options As DGNExportOptions
) As Boolean
public:
bool Export(
    String^ folder,
    String^ name,
    ICollection<ElementId^>^ views,
    DGNExportOptions^ options
)
member Export :
        folder : string *
        name : string *
        views : ICollection<ElementId> *
        options : DGNExportOptions -> bool

Parameters

folder String
Output folder, into which file(s) will be exported. The folder must exist.
name String
Either the name of a single file or a prefix for a set of files. If empty, automatic naming will be used. If , throw ArgumentException.
views ICollection ElementId
Selection of views to be exported. The set must contain at least one valid view.
options DGNExportOptions
Various options applicable to the DGN format. If , all options will be set to their respective default values.

Return Value

Boolean
True if successful, otherwise False.
Exceptions
Exception | Condition
ArgumentException | NullOrEmpty -or- Contains invalid characters. -or- non empty list of views must be provided. -or- some of the views are not printable (exportable). -or- Thrown when the options in DGNExportOptions is invalid.
ArgumentNullException | A non-optional argument was null
DirectoryNotFoundException | Thrown when the directory does not exist.
InvalidOperationException | Export is temporarily disabled. -or- Exporting is not allowed in the current application mode.
InvalidPathArgumentException | The folder does not exist.
OptionalFunctionalityNotAvailableException | The DWG module is not available in the installed Revit. -or- The Graphics module is not available in the installed Revit.
Remarks
All the views must be printable for the Export to succeed. It can be assured by checking the CanBePrinted property of each view.
Example
C#
VB
C++
F#
Copy
public bool ExportDGN(Document document, View view)
{
    bool exported = false;
    // Get predefined setups and use the first one
    IList<string> setupNames = BaseExportOptions.GetPredefinedSetupNames(document);
    if (setupNames.Count > 0)
    {
        // Get predefined options for first predefined setup
        DGNExportOptions dgnOptions = DGNExportOptions.GetPredefinedOptions(document, setupNames[0]);

        // export the active view if it is printable
        if (view.CanBePrinted == true)
        {
            ICollection<ElementId> views = new List<ElementId>();
            views.Add(view.Id);
            exported = document.Export(Path.GetDirectoryName(document.PathName),
                Path.GetFileNameWithoutExtension(document.PathName), views, dgnOptions);
        }
    }

    return exported;
}
Public Function ExportDGN(document As Document, view As View) As Boolean
   Dim exported As Boolean = False
   ' Get predefined setups and use the first one
   Dim setupNames As IList(Of String) = BaseExportOptions.GetPredefinedSetupNames(document)
   If setupNames.Count > 0 Then
      ' Get predefined options for first predefined setup
      Dim dgnOptions As DGNExportOptions = DGNExportOptions.GetPredefinedOptions(document, setupNames(0))

      ' export the active view if it is printable
      If view.CanBePrinted = True Then
         Dim views As ICollection(Of ElementId) = New List(Of ElementId)()
         views.Add(view.Id)
         exported = document.Export(Path.GetDirectoryName(document.PathName), Path.GetFileNameWithoutExtension(document.PathName), views, dgnOptions)
      End If
   End If

   Return exported
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Document Class
Export Overload


Document.Export(String, String, ICollection<ElementId>, DWGExportOptions) Method

DocumentExport(String, String, ICollectionElementId, DWGExportOptions) Method

Exports a selection of views in DWG format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Export(
    string folder,
    string name,
    ICollection<ElementId> views,
    DWGExportOptions options
)
Public Function Export (
    folder As String,
    name As String,
    views As ICollection(Of ElementId),
    options As DWGExportOptions
) As Boolean
public:
bool Export(
    String^ folder,
    String^ name,
    ICollection<ElementId^>^ views,
    DWGExportOptions^ options
)
member Export :
        folder : string *
        name : string *
        views : ICollection<ElementId> *
        options : DWGExportOptions -> bool

Parameters

folder String
Output folder, into which file(s) will be exported. The folder must exist.
name String
Either the name of a single file or a prefix for a set of files. If empty, automatic naming will be used. If , throw ArgumentException.
views ICollection ElementId
Selection of views to be exported. The set must contain at least one valid view.
options DWGExportOptions
Various options applicable to the DWG format. If , all options will be set to their respective default values.

Return Value

Boolean
True if successful, otherwise False.
Exceptions
Exception | Condition
ArgumentException | NullOrEmpty -or- Contains invalid characters. -or- non empty list of views must be provided. -or- some of the views are not printable (exportable). -or- The modifiers set in layer info must be valid. -or- Thrown when the options in DWGExportOptions is invalid.
ArgumentNullException | A non-optional argument was null
DirectoryNotFoundException | Thrown when the directory does not exist.
InvalidOperationException | Export is temporarily disabled. -or- Exporting is not allowed in the current application mode.
InvalidPathArgumentException | The folder does not exist.
OptionalFunctionalityNotAvailableException | The DWG module is not available in the installed Revit. -or- The Graphics module is not available in the installed Revit.
Remarks
All the views must be printable for the Export to succeed. It can be assured by checking the CanBePrinted property of each view.
Example
C#
VB
C++
F#
Copy
public bool ExportDWG(Document document, View view, string setupName)
{
    bool exported = false;
    // Get the predefined setups and use the one with the given name.
    IList<string> setupNames = BaseExportOptions.GetPredefinedSetupNames(document);
    foreach (string name in setupNames)
    {
        if (name.CompareTo(setupName) == 0)
        {
            // Export using the predefined options
            DWGExportOptions dwgOptions = DWGExportOptions.GetPredefinedOptions(document, name);

            // Export the active view
            ICollection<ElementId> views = new List<ElementId>();
            views.Add(view.Id);
            // The document has to be saved already, therefore it has a valid PathName.
            exported = document.Export(Path.GetDirectoryName(document.PathName),
                Path.GetFileNameWithoutExtension(document.PathName), views, dwgOptions);
            break;
        }
    }

    return exported;
}
Public Function ExportDWG(document As Document, view As View, setupName As String) As Boolean
   Dim exported As Boolean = False
   ' Get the predefined setups and use the one with the given name.
   Dim setupNames As IList(Of String) = BaseExportOptions.GetPredefinedSetupNames(document)
   For Each name As String In setupNames
      If name.CompareTo(setupName) = 0 Then
         ' Export using the predefined options
         Dim dwgOptions As DWGExportOptions = DWGExportOptions.GetPredefinedOptions(document, name)

         ' Export the active view
         Dim views As ICollection(Of ElementId) = New List(Of ElementId)()
         views.Add(view.Id)
         ' The document has to be saved already, therefore it has a valid PathName.
         exported = document.Export(Path.GetDirectoryName(document.PathName), Path.GetFileNameWithoutExtension(document.PathName), views, dwgOptions)
         Exit For
      End If
   Next

   Return exported
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Document Class
Export Overload


Document.Export(String, String, ICollection<ElementId>, DXFExportOptions) Method

DocumentExport(String, String, ICollectionElementId, DXFExportOptions) Method

Exports a selection of views in DXF format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Export(
    string folder,
    string name,
    ICollection<ElementId> views,
    DXFExportOptions options
)
Public Function Export (
    folder As String,
    name As String,
    views As ICollection(Of ElementId),
    options As DXFExportOptions
) As Boolean
public:
bool Export(
    String^ folder,
    String^ name,
    ICollection<ElementId^>^ views,
    DXFExportOptions^ options
)
member Export :
        folder : string *
        name : string *
        views : ICollection<ElementId> *
        options : DXFExportOptions -> bool

Parameters

folder String
Output folder, into which file(s) will be exported. The folder must exist.
name String
Either the name of a single file or a prefix for a set of files. If empty, automatic naming will be used.
views ICollection ElementId
Selection of views to be exported. The set must contain at least one valid view.
options DXFExportOptions
Various options applicable to the DXF format. If , all options will be set to their respective default values.

Return Value

Boolean
True if successful, otherwise False.
Exceptions
Exception | Condition
ArgumentException | NullOrEmpty -or- Contains invalid characters. -or- non empty list of views must be provided. -or- some of the views are not printable (exportable). -or- Thrown when the options in DWGExportOptions is invalid.
ArgumentNullException | A non-optional argument was null
DirectoryNotFoundException | Thrown when the directory does not exist.
InvalidOperationException | Export is temporarily disabled. -or- Exporting is not allowed in the current application mode.
InvalidPathArgumentException | The folder does not exist.
OptionalFunctionalityNotAvailableException | The DXF module is not available in the installed Revit. -or- The Graphics module is not available in the installed Revit.
Remarks
All the views must be printable for the Export to succeed. It can be assured by checking the CanBePrinted property of each view.
See Also

Reference

Document Class
Export Overload


Document.Export(String, String, ICollection<ElementId>, SATExportOptions) Method

DocumentExport(String, String, ICollectionElementId, SATExportOptions) Method

Exports the current view or a selection of views in SAT format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Export(
    string folder,
    string name,
    ICollection<ElementId> views,
    SATExportOptions options
)
Public Function Export (
    folder As String,
    name As String,
    views As ICollection(Of ElementId),
    options As SATExportOptions
) As Boolean
public:
bool Export(
    String^ folder,
    String^ name,
    ICollection<ElementId^>^ views,
    SATExportOptions^ options
)
member Export :
        folder : string *
        name : string *
        views : ICollection<ElementId> *
        options : SATExportOptions -> bool

Parameters

folder String
Output folder, into which file(s) will be exported. The folder must exist.
name String
Either the name of a single file or a prefix for a set of files. If empty, automatic naming will be used.
views ICollection ElementId
Selection of views to be exported. The set must contain at least one valid view.
options SATExportOptions
Various options applicable to the SAT format.For now, this option is empty. If , all options will be set to their respective default values.

Return Value

Boolean
True if successful, otherwise False.
Exceptions
Exception | Condition
ArgumentException | NullOrEmpty -or- Contains invalid characters. -or- non empty list of views must be provided. -or- At least one provided viewId does not correspond to a printable 3D view.
ArgumentNullException | A non-optional argument was null
DirectoryNotFoundException | Thrown when the directory does not exist.
ForbiddenForDynamicUpdateException | This method may not be called during dynamic update.
InvalidOperationException | Export is temporarily disabled. -or- Exporting is not allowed in the current application mode.
InvalidPathArgumentException | The folder does not exist.
OptionalFunctionalityNotAvailableException | The ShapeExporter functionality is not available in the installed Revit, or the Material Library is missing.
Remarks
All the views must be 3D views for the Export to succeed.
See Also

Reference

Document Class
Export Overload


Document.ExportImage Method

DocumentExportImage Method

Exports a view or set of views into an image file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ExportImage(
    ImageExportOptions options
)
Public Sub ExportImage (
    options As ImageExportOptions
)
public:
void ExportImage(
    ImageExportOptions^ options
)
member ExportImage :
        options : ImageExportOptions -> unit

Parameters

options ImageExportOptions
The options which govern the image export.
Exceptions
Exception | Condition
ArgumentException | The current view cannot be exported as an image
ArgumentNullException | A non-optional argument was null
FileAccessException | The path indicated could not be accessed.
FileNotFoundException | The path indicated could not be found.
InvalidOperationException | Exporting is not allowed in the current application mode. -or- Failed to export image due to an error with the inputs. -or- Failed to export image due to an issue where the DirectX Device was lost.
OptionalFunctionalityNotAvailableException | The Graphics module is not available in the installed Revit.
See Also

Reference

Document Class


Document.GetAllUnusedElements Method

DocumentGetAllUnusedElements Method

Returns the list of element ids that are not used. The list of unused element ids may include elements that can't be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ISet<ElementId> GetAllUnusedElements(
    ISet<ElementId> categories
)
Public Function GetAllUnusedElements (
    categories As ISet(Of ElementId)
) As ISet(Of ElementId)
public:
ISet<ElementId^>^ GetAllUnusedElements(
    ISet<ElementId^>^ categories
)
member GetAllUnusedElements :
        categories : ISet<ElementId> -> ISet<ElementId>

Parameters

categories ISet ElementId
Collection of categories to check for unused elements.

Return Value

ISet ElementId
Unused element ids.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
This method returns unused element ids that are available in the Purge Unused window in the Revit, including elements that can't be deleted. To get unused elements that do not have a category assigned add INVALID to the collection of categories. If the input categories collection is empty, the method returns all unused elements in the document.
Example
C#
VB
C++
F#
Copy
public void GetAllUnusedElements(Autodesk.Revit.DB.Document document)
{
   // Get all unused elements in the document
   var allUnusedElementIds = document.GetAllUnusedElements(new HashSet<ElementId>());

   // Get unused elements without a category
   var unusedElementIdsWithNoCategory = document.GetAllUnusedElements(new HashSet<ElementId>() { new ElementId(BuiltInCategory.INVALID) });

   // Get unused wall and floors types
   HashSet<ElementId> categoriesToPurge = new HashSet<ElementId>
   {
      new ElementId(BuiltInCategory.OST_Walls),
      new ElementId(BuiltInCategory.OST_Floors)
   };

   var unusedElementIds = document.GetAllUnusedElements(categoriesToPurge);
}
     Public Sub GetAllUnusedElements(ByVal document As Document)
         ' Get all unused elements in the document
         Dim allUnusedElementIds = document.GetAllUnusedElements(New HashSet(Of ElementId)())

         ' Get unused elements without a category
         Dim unusedElementIdsWithNoCategory = document.GetAllUnusedElements(New HashSet(Of ElementId)() From {
                New ElementId(BuiltInCategory.INVALID)
            })

         ' Get unused wall and floors types
         Dim categoriesToPurge As HashSet(Of ElementId) = New HashSet(Of ElementId) From {
   New ElementId(BuiltInCategory.OST_Walls),
   New ElementId(BuiltInCategory.OST_Floors)
}

         Dim unusedElementIds = document.GetAllUnusedElements(categoriesToPurge)
     End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Document Class


Document.GetChangedElements Method

DocumentGetChangedElements Method

Extracts a collection containing the ids of elements that have been created, modified or deleted between the input baseVersion and the document's current version.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocumentDifference GetChangedElements(
    Guid baseVersionGUID
)
Public Function GetChangedElements (
    baseVersionGUID As Guid
) As DocumentDifference
public:
DocumentDifference^ GetChangedElements(
    Guid baseVersionGUID
)
member GetChangedElements :
        baseVersionGUID : Guid -> DocumentDifference

Parameters

baseVersionGUID Guid
GUID of base version(excluded) to compare. This GUID should be retrieved from property [!:Autodesk::Revit::DB::DocumentVersion::VersoinGUID]. Empty GUID is allowed to retrieve changes of each version in the document.

Return Value

DocumentDifference
An object containing collections of the created, modified and deleted ids between the input version and current version.
Exceptions
Exception | Condition
ArgumentException | This GUID is invalid in the given document.
Example
C#
VB
C++
F#
Copy
private void ShowChangedElements(Autodesk.Revit.DB.Document document, Guid baseVerseionGuid)
{
    //Parameter baseVersionGuid is retrieved from property VersionGUID of Autodesk.Revit.DB.DocumentVersion.
    //System.Guid.Empty is allowed to get all changes in document.
    DocumentDifference docDiff = document.GetChangedElements(baseVerseionGuid);
    if (docDiff.AreDeletedElementIdsAvailable)
    {
        TaskDialog.Show("Revit", "Deleted element history is available in current document.");
    }
    else
    {
        TaskDialog.Show("Revit", "Deleted element history is not available in current document.");
    }

    // New added elements.
    var createdElementIds = docDiff.GetCreatedElementIds();

    // Modified elements.
    var modifiedElementIds = docDiff.GetModifiedElementIds();

    // Deleted elements.
    // For nonworkshared model, always returns an empty collection.
    var deletedElementIds = docDiff.GetDeletedElementIds();

    var changesetMessage = $"Found {createdElementIds.Count} new created elements, {modifiedElementIds.Count} modified elements and {deletedElementIds.Count} deleted elements.";
    TaskDialog.Show("Revit", changesetMessage);
}
Private Sub ShowChangedElements(ByVal document As Document, ByVal baseVerseionGuid As Guid)
    'Parameter baseVersionGuid is retrieved from property VersionGUID of Autodesk.Revit.DB.DocumentVersion.
    'System.Guid.Empty is allowed to get all changes in document.
    Dim docDiff = document.GetChangedElements(baseVerseionGuid)

    If docDiff.AreDeletedElementIdsAvailable Then
        TaskDialog.Show("Revit", "Deleted element history is available in current document.")
    Else
        TaskDialog.Show("Revit", "Deleted element history is not available in current document.")
    End If

    ' New added elements.
    Dim createdElementIds = docDiff.GetCreatedElementIds()

    ' Modified elements.
    Dim modifiedElementIds = docDiff.GetModifiedElementIds()

    ' Deleted elements.
    ' For nonworkshared model, always returns an empty collection.
    Dim deletedElementIds = docDiff.GetDeletedElementIds()
    Dim changesetMessage = $"Found {createdElementIds.Count} new created elements, {modifiedElementIds.Count} modified elements and {deletedElementIds.Count} deleted elements."
    TaskDialog.Show("Revit", changesetMessage)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Document Class


Document.GetCloudFolderId Method

DocumentGetCloudFolderId Method

Gets ForgeDM folder id where the model locates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetCloudFolderId(
    bool forceRefresh
)
Public Function GetCloudFolderId (
    forceRefresh As Boolean
) As String
public:
String^ GetCloudFolderId(
    bool forceRefresh
)
member GetCloudFolderId :
        forceRefresh : bool -> string

Parameters

forceRefresh Boolean
Cached value will be refreshed by sending a service call when forceRefresh is true.

Return Value

String
Exceptions
Exception | Condition
RevitServerUnauthorizedException | Thrown when cannot get data from ForgeDM for Revit cloud model.
Remarks
It is empty for non-cloud model; It is cached in Revit model opened session after getting it if forceRefresh is false; ForgeDM folder id can be changed during Revit model opened session, set forceRefresh as 'true' to get new value.
See Also

Reference

Document Class


Document.GetCloudModelPath Method

DocumentGetCloudModelPath Method

Gets the cloud model path of the cloud model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ModelPath GetCloudModelPath()
Public Function GetCloudModelPath As ModelPath
public:
ModelPath^ GetCloudModelPath()
member GetCloudModelPath : unit -> ModelPath

Return Value

ModelPath
The cloud model path
Exceptions
Exception | Condition
InvalidOperationException | This Document is a not cloud model, cannot execute this operation.
See Also

Reference

Document Class


Document.GetCloudModelUrn Method

DocumentGetCloudModelUrn Method

A ForgeDM Urn identifying the model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetCloudModelUrn()
Public Function GetCloudModelUrn As String
public:
String^ GetCloudModelUrn()
member GetCloudModelUrn : unit -> string

Return Value

String
Exceptions
Exception | Condition
RevitServerUnauthorizedException | Thrown when cannot get data from ForgeDM.
Remarks
It is empty for non-cloud model; It is cached in Revit model opened session after getting it;
See Also

Reference

Document Class


Document.GetDefaultElementTypeId Method

DocumentGetDefaultElementTypeId Method

Gets the default element type id with the given DefaultElementType id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GetDefaultElementTypeId(
    ElementTypeGroup defaultTypeId
)
Public Function GetDefaultElementTypeId (
    defaultTypeId As ElementTypeGroup
) As ElementId
public:
ElementId^ GetDefaultElementTypeId(
    ElementTypeGroup defaultTypeId
)
member GetDefaultElementTypeId :
        defaultTypeId : ElementTypeGroup -> ElementId

Parameters

defaultTypeId ElementTypeGroup
The default element type id.

Return Value

ElementId
The element type id.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Example
C#
VB
C++
F#
Copy
private bool IsWallUsingDefaultType(Document document, Wall wall)
{
    ElementId defaultElementTypeId = document.GetDefaultElementTypeId(ElementTypeGroup.WallType);
    return (wall.WallType.Id == defaultElementTypeId);
}
Private Function IsWallUsingDefaultType(document As Document, wall As Wall) As Boolean
   Dim defaultElementTypeId As ElementId = document.GetDefaultElementTypeId(ElementTypeGroup.WallType)
   Return (wall.WallType.Id = defaultElementTypeId)
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Document Class


Document.GetDefaultFamilyTypeId Method

DocumentGetDefaultFamilyTypeId Method

Gets the default family type id with the given family category id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GetDefaultFamilyTypeId(
    ElementId familyCategoryId
)
Public Function GetDefaultFamilyTypeId (
    familyCategoryId As ElementId
) As ElementId
public:
ElementId^ GetDefaultFamilyTypeId(
    ElementId^ familyCategoryId
)
member GetDefaultFamilyTypeId :
        familyCategoryId : ElementId -> ElementId

Parameters

familyCategoryId ElementId
The family category id.

Return Value

ElementId
The default family type id.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Example
C#
VB
C++
F#
Copy
private void AssignDefaultTypeToColumn(Document document, FamilyInstance column)
{
    ElementId defaultTypeId = document.GetDefaultFamilyTypeId(new ElementId(BuiltInCategory.OST_StructuralColumns));

    if (defaultTypeId != ElementId.InvalidElementId)
    {
        FamilySymbol defaultType = document.GetElement(defaultTypeId) as FamilySymbol;
        if (defaultType != null)
        {
            column.Symbol = defaultType;
        }
    }
}
Private Sub AssignDefaultTypeToColumn(document As Document, column As FamilyInstance)
   Dim defaultTypeId As ElementId = document.GetDefaultFamilyTypeId(New ElementId(BuiltInCategory.OST_StructuralColumns))

   If defaultTypeId <> ElementId.InvalidElementId Then
      Dim defaultType As FamilySymbol = TryCast(document.GetElement(defaultTypeId), FamilySymbol)
      If defaultType IsNot Nothing Then
         column.Symbol = defaultType
      End If
   End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Document Class


Document.GetDocumentPreviewSettings Method

DocumentGetDocumentPreviewSettings Method

Returns the preview settings for the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocumentPreviewSettings GetDocumentPreviewSettings()
Public Function GetDocumentPreviewSettings As DocumentPreviewSettings
public:
DocumentPreviewSettings^ GetDocumentPreviewSettings()
member GetDocumentPreviewSettings : unit -> DocumentPreviewSettings

Return Value

DocumentPreviewSettings
The preview settings.
See Also

Reference

Document Class


Document.GetDocumentVersion Method

DocumentGetDocumentVersion Method

Gets the DocumentVersion that corresponds to a document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static DocumentVersion GetDocumentVersion(
    Document doc
)
Public Shared Function GetDocumentVersion (
    doc As Document
) As DocumentVersion
public:
static DocumentVersion^ GetDocumentVersion(
    Document^ doc
)
static member GetDocumentVersion :
        doc : Document -> DocumentVersion

Parameters

doc Document
The document whose DocumentVersion will be returned.

Return Value

DocumentVersion
The DocumentVersion corresponding to the given document.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
This function can be combined with IsModified to see whether a document in memory is different from a version on disk. The documents are different if the document is modified or if the two DocumentVersions differ.
See Also

Reference

Document Class


Document.GetElement Method

DocumentGetElement Method

Overload List
 | Name | Description
Public method | GetElement(ElementId) | Gets the Element referenced by the input ElementId.
Public method | GetElement(Reference) | Gets the Element referenced by the input reference.
Public method | GetElement(String) | Gets the Element referenced by a unique id string.
Top
See Also

Reference

Document Class


Document.GetElement(ElementId) Method

DocumentGetElement(ElementId) Method

Gets the Element referenced by the input ElementId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Element GetElement(
    ElementId id
)
Public Function GetElement (
    id As ElementId
) As Element
public:
Element^ GetElement(
    ElementId^ id
)
member GetElement :
        id : ElementId -> Element

Parameters

id ElementId
The ElementId, whose referenced Element will be retrieved from the model.

Return Value

Element
The element referenced by the input argument.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
will be returned if the input ElementId doesn't reference to a valid Element.
See Also

Reference

Document Class
GetElement Overload


Document.GetElement(Reference) Method

DocumentGetElement(Reference) Method

Gets the Element referenced by the input reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Element GetElement(
    Reference reference
)
Public Function GetElement (
    reference As Reference
) As Element
public:
Element^ GetElement(
    Reference^ reference
)
member GetElement :
        reference : Reference -> Element

Parameters

reference Reference
The reference, whose referenced Element will be retrieved from the model.

Return Value

Element
The element referenced by the input argument.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
will be returned if the input reference doesn't reference to a valid Element.
See Also

Reference

Document Class
GetElement Overload


Document.GetElement(String) Method

DocumentGetElement(String) Method

Gets the Element referenced by a unique id string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Element GetElement(
    string uniqueId
)
Public Function GetElement (
    uniqueId As String
) As Element
public:
Element^ GetElement(
    String^ uniqueId
)
member GetElement :
        uniqueId : string -> Element

Parameters

uniqueId String
The element unique id, whose referenced Element will be retrieved from the model.
  • UniqueId

    • Return Value

    Element
    The element referenced by the input argument.
    Exceptions
    Exception | Condition
ArgumentNullException | A non-optional argument was null
    Remarks
    will be returned if the input id string doesn't reference to a valid Element.
    See Also

    Reference

    Document Class
    GetElement Overload


Document.GetHashCode Method

DocumentGetHashCode Method

Gets the hash code of this document instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Int32
Remarks
The hash code is the same for document instances that represent the same document currently opened in the Revit session. The hash code is generated when a Revit file is opened or created in session. If the same Revit file is opened later (in the same session or a different session) the hash code will not be the same.
See Also

Reference

Document Class


Document.GetHubId Method

DocumentGetHubId Method

Gets ForgeDM hub id where the model locates. It is cached in session.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetHubId()
Public Function GetHubId As String
public:
String^ GetHubId()
member GetHubId : unit -> string

Return Value

String
Exceptions
Exception | Condition
RevitServerUnauthorizedException | Thrown when cannot get data from ForgeDM for Revit cloud model.
Remarks
It is empty for non-cloud model; It is cached in Revit model opened session after getting it;
See Also

Reference

Document Class


Document.GetPaintedMaterial Method

DocumentGetPaintedMaterial Method

Get the material painted on the element's face. Returns invalidElementId if the face is not painted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GetPaintedMaterial(
    ElementId elementId,
    Face face
)
Public Function GetPaintedMaterial (
    elementId As ElementId,
    face As Face
) As ElementId
public:
ElementId^ GetPaintedMaterial(
    ElementId^ elementId,
    Face^ face
)
member GetPaintedMaterial :
        elementId : ElementId *
        face : Face -> ElementId

Parameters

elementId ElementId
The element that the face belongs to.
face Face
The painted element's face.

Return Value

ElementId
The material's Id painted on the element's face.
Exceptions
Exception | Condition
ArgumentException | The element elementId does not exist in the document -or- The face doesn't belong to the element
ArgumentNullException | A non-optional argument was null
See Also

Reference

Document Class


Document.GetPrintSettingIds Method

DocumentGetPrintSettingIds Method

Retrieves all Print Settings of current project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetPrintSettingIds()
Public Function GetPrintSettingIds As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetPrintSettingIds()
member GetPrintSettingIds : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
The ElementIds of all print setting elements
See Also

Reference

Document Class


Document.GetProjectId Method

DocumentGetProjectId Method

Gets ForgeDM project id where the model locates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetProjectId()
Public Function GetProjectId As String
public:
String^ GetProjectId()
member GetProjectId : unit -> string

Return Value

String
Exceptions
Exception | Condition
RevitServerUnauthorizedException | Thrown when cannot get data from ForgeDM for Revit cloud model.
Remarks
It is empty for non-cloud model; It is cached in Revit model opened session after getting it;
See Also

Reference

Document Class


Document.GetRoomAtPoint Method

DocumentGetRoomAtPoint Method

Gets a room containing the point.
Overload List
 | Name | Description
Public method | GetRoomAtPoint(XYZ) | Gets a room containing the point.
Public method | GetRoomAtPoint(XYZ, Phase) | Gets a room containing the point.
Top
See Also

Reference

Document Class


Document.GetRoomAtPoint(XYZ) Method

DocumentGetRoomAtPoint(XYZ) Method

Gets a room containing the point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Room GetRoomAtPoint(
    XYZ point
)
Public Function GetRoomAtPoint (
    point As XYZ
) As Room
public:
Room^ GetRoomAtPoint(
    XYZ^ point
)
member GetRoomAtPoint :
        point : XYZ -> Room

Parameters

point XYZ
Point to be checked.

Return Value

Room
The room containing the point.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the point is .
ArgumentException | Thrown when the coordinates of the point are not number or are Double::MaxValue or Double::MinValue.
Remarks
Surveys only the rooms from the final phase of the project. The first one found will be returned. If there is no room containing the point, it returns .
See Also

Reference

Document Class
GetRoomAtPoint Overload


Document.GetRoomAtPoint(XYZ, Phase) Method

DocumentGetRoomAtPoint(XYZ, Phase) Method

Gets a room containing the point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Room GetRoomAtPoint(
    XYZ point,
    Phase phase
)
Public Function GetRoomAtPoint (
    point As XYZ,
    phase As Phase
) As Room
public:
Room^ GetRoomAtPoint(
    XYZ^ point,
    Phase^ phase
)
member GetRoomAtPoint :
        point : XYZ *
        phase : Phase -> Room

Parameters

point XYZ
Point to be checked.
phase Phase
Phase in which the room exists.

Return Value

Room
The room containing the point.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the point is .
ArgumentException | Thrown when the coordinates of the point are not number or are Double::MaxValue or Double::MinValue.
Remarks
If phase is , it will get the room of the last phase.The first one found will be returned. If there is no room containing the point, it returns .
See Also

Reference

Document Class
GetRoomAtPoint Overload


Document.GetSpaceAtPoint Method

DocumentGetSpaceAtPoint Method

Gets a space containing the point.
Overload List
 | Name | Description
Public method | GetSpaceAtPoint(XYZ) | Gets a space containing the point.
Public method | GetSpaceAtPoint(XYZ, Phase) | Gets a space containing the point.
Top
See Also

Reference

Document Class


Document.GetSpaceAtPoint(XYZ) Method

DocumentGetSpaceAtPoint(XYZ) Method

Gets a space containing the point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Space GetSpaceAtPoint(
    XYZ point
)
Public Function GetSpaceAtPoint (
    point As XYZ
) As Space
public:
Space^ GetSpaceAtPoint(
    XYZ^ point
)
member GetSpaceAtPoint :
        point : XYZ -> Space

Parameters

point XYZ
Point to be checked.

Return Value

Space
The space containing the point.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the point is .
ArgumentException | Thrown when the coordinates of the point are not number or are Double::MaxValue or Double::MinValue.
Remarks
Surveys only the spaces from the final phase of the project. The first one found will be returned. If there is no space containing the point, it returns .
See Also

Reference

Document Class
GetSpaceAtPoint Overload


Document.GetSpaceAtPoint(XYZ, Phase) Method

DocumentGetSpaceAtPoint(XYZ, Phase) Method

Gets a space containing the point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Space GetSpaceAtPoint(
    XYZ point,
    Phase phase
)
Public Function GetSpaceAtPoint (
    point As XYZ,
    phase As Phase
) As Space
public:
Space^ GetSpaceAtPoint(
    XYZ^ point,
    Phase^ phase
)
member GetSpaceAtPoint :
        point : XYZ *
        phase : Phase -> Space

Parameters

point XYZ
Point to be checked.
phase Phase
Phase in which the space exists.

Return Value

Space
The space containing the point.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the point is .
ArgumentException | Thrown when the coordinates of the point are not number or are Double::MaxValue or Double::MinValue.
Remarks
If phase is , it will get the space of the last phase.The first one found will be returned. If there is no space containing the point, it returns .
See Also

Reference

Document Class
GetSpaceAtPoint Overload


Document.GetSubelement Method

DocumentGetSubelement Method

Overload List
 | Name | Description
Public method | GetSubelement(Reference) | Gets the subelement referenced by the input reference.
Public method | GetSubelement(String) | Gets the subelement referenced by a unique id string.
Public method | GetSubelement(ElementId, Int32) | Gets the subelement referenced by a parent id and subelement id.
Top
See Also

Reference

Document Class


Document.GetSubelement(Reference) Method

DocumentGetSubelement(Reference) Method

Gets the subelement referenced by the input reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Subelement GetSubelement(
    Reference reference
)
Public Function GetSubelement (
    reference As Reference
) As Subelement
public:
Subelement^ GetSubelement(
    Reference^ reference
)
member GetSubelement :
        reference : Reference -> Subelement

Parameters

reference Reference
The reference that identifies element or subelement.

Return Value

Subelement
The subelement referenced by the input argument.
Exceptions
Exception | Condition
ArgumentException | reference does not identify a valid element or subelement.
ArgumentNullException | A non-optional argument was null
See Also

Reference

Document Class
GetSubelement Overload


Document.GetSubelement(String) Method

DocumentGetSubelement(String) Method

Gets the subelement referenced by a unique id string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Subelement GetSubelement(
    string uniqueId
)
Public Function GetSubelement (
    uniqueId As String
) As Subelement
public:
Subelement^ GetSubelement(
    String^ uniqueId
)
member GetSubelement :
        uniqueId : string -> Subelement

Parameters

uniqueId String
The unique id that identifies element or subelement.
  • UniqueId

    • Return Value

    Subelement
    The subelement referenced by the input argument.
    Exceptions
    Exception | Condition
ArgumentNullException | A non-optional argument was null
    Remarks
    will be returned if the input id string doesn't reference to a valid element or subelement.
    See Also

    Reference

    Document Class
    GetSubelement Overload


Document.GetSubelement(ElementId, Int32) Method

DocumentGetSubelement(ElementId, Int32) Method

Gets the subelement referenced by a parent id and subelement id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Subelement GetSubelement(
    ElementId id,
    int subId
)
Public Function GetSubelement (
    id As ElementId,
    subId As Integer
) As Subelement
public:
Subelement^ GetSubelement(
    ElementId^ id,
    int subId
)
member GetSubelement :
        id : ElementId *
        subId : int -> Subelement

Parameters

id ElementId
Id of the element.
subId Int32
Id of the sub element.

Return Value

Subelement
The subelement referenced by the input argument.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
will be returned if the input id string doesn't reference to a valid element or subelement.
See Also

Reference

Document Class
GetSubelement Overload


Document.GetTypeOfStorage Method

DocumentGetTypeOfStorage Method

Get the storage type of the identified built-in parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public StorageType GetTypeOfStorage(
    ForgeTypeId parameterTypeId
)
Public Function GetTypeOfStorage (
    parameterTypeId As ForgeTypeId
) As StorageType
public:
StorageType GetTypeOfStorage(
    ForgeTypeId^ parameterTypeId
)
member GetTypeOfStorage :
        parameterTypeId : ForgeTypeId -> StorageType

Parameters

parameterTypeId ForgeTypeId
Identifier of the built-in parameter.

Return Value

StorageType
Storage type of the built-in parameter.
Exceptions
Exception | Condition
ArgumentException | parameterTypeId does not identify a built-in parameter. See Parameter.IsBuiltInParameter(ForgeTypeId) and Parameter.GetParameterTypeId(BuiltInParameter).
ArgumentNullException | A non-optional argument was NULL
See Also

Reference

Document Class


Document.GetUnits Method

DocumentGetUnits Method

Gets the Units object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Units GetUnits()
Public Function GetUnits As Units
public:
Units^ GetUnits()
member GetUnits : unit -> Units

Return Value

Units
The Units object.
See Also

Reference

Document Class


Document.GetUnusedElements Method

DocumentGetUnusedElements Method

Returns the list of element ids that are not used and can be deleted from the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ISet<ElementId> GetUnusedElements(
    ISet<ElementId> categories
)
Public Function GetUnusedElements (
    categories As ISet(Of ElementId)
) As ISet(Of ElementId)
public:
ISet<ElementId^>^ GetUnusedElements(
    ISet<ElementId^>^ categories
)
member GetUnusedElements :
        categories : ISet<ElementId> -> ISet<ElementId>

Parameters

categories ISet ElementId
Collection of categories to check for unused elements.

Return Value

ISet ElementId
Unused elements that can be deleted from the document.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
This method returns unused element ids that are available in the Purge Unused window in the Revit. To get unused elements that do not have a category assigned add INVALID to the collection of categories. If the input categories collection is empty, the method returns all unused elements in the document.
Example
C#
VB
C++
F#
Copy
public void DeleteAllUnused(Autodesk.Revit.DB.Document document)
{
   using (Transaction transaction = new Transaction(document, "Delete unused elements"))
   {
      transaction.Start();

      ISet<ElementId> unusedElementIds = document.GetUnusedElements(new HashSet<ElementId>());
      while (unusedElementIds.Any())
      {
         document.Delete(unusedElementIds);
         unusedElementIds = document.GetUnusedElements(new HashSet<ElementId>());
      }

      transaction.Commit();
   }
}

public void GetUnusedElements(Autodesk.Revit.DB.Document document)
{
   // Get all unused elements in the document
   var allUnusedElementIds = document.GetUnusedElements(new HashSet<ElementId>());

   // Get unused elements without a category
   var unusedElementIdsWithNoCategory = document.GetUnusedElements(new HashSet<ElementId>() { new ElementId(BuiltInCategory.INVALID) });

   // Get unused wall and floors types
   HashSet<ElementId> categoriesToPurge = new HashSet<ElementId>
   {
      new ElementId(BuiltInCategory.OST_Walls),
      new ElementId(BuiltInCategory.OST_Floors)
   };

   var unusedElementIds = document.GetUnusedElements(categoriesToPurge);
}
     Public Sub DeleteAllUnused(ByVal document As Document)
         Using transaction As Transaction = New Transaction(document, "Delete unused elements")
             transaction.Start()

             Dim unusedElementIds As ISet(Of ElementId) = document.GetUnusedElements(New HashSet(Of ElementId)())
             While unusedElementIds.Any()
                 document.Delete(unusedElementIds)
                 unusedElementIds = document.GetUnusedElements(New HashSet(Of ElementId)())
             End While

             transaction.Commit()
         End Using
     End Sub

     Public Sub GetUnusedElements(ByVal document As Document)
         ' Get all unused elements in the document
         Dim allUnusedElementIds = document.GetUnusedElements(New HashSet(Of ElementId)())

         ' Get unused elements without a category
         Dim unusedElementIdsWithNoCategory = document.GetUnusedElements(New HashSet(Of ElementId)() From {
                New ElementId(BuiltInCategory.INVALID)
            })

         ' Get unused wall and floors types
         Dim categoriesToPurge As HashSet(Of ElementId) = New HashSet(Of ElementId) From {
   New ElementId(BuiltInCategory.OST_Walls),
   New ElementId(BuiltInCategory.OST_Floors)
}

         Dim unusedElementIds = document.GetUnusedElements(categoriesToPurge)
     End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Document Class


Document.GetWarnings Method

DocumentGetWarnings Method

Returns list of failure messages generated from persistent (reviewable) warnings accumulated in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<FailureMessage> GetWarnings()
Public Function GetWarnings As IList(Of FailureMessage)
public:
IList<FailureMessage^>^ GetWarnings()
member GetWarnings : unit -> IList<FailureMessage>

Return Value

IList FailureMessage
List of failure messages representing warnings accumulated in the document.
Remarks
Function returns list of failure messages identical to the list displayed in a warning dialog when command Manage tab->Inquiry pane->Review Warnings is issued through the UI. Operations performed on the returned list by the caller do not impact information about warnings stored in the document.
See Also

Reference

Document Class


Document.GetWorksetId Method

DocumentGetWorksetId Method

Get Id of the Workset which owns the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WorksetId GetWorksetId(
    ElementId id
)
Public Function GetWorksetId (
    id As ElementId
) As WorksetId
public:
WorksetId^ GetWorksetId(
    ElementId^ id
)
member GetWorksetId :
        id : ElementId -> WorksetId

Parameters

id ElementId
Id of the element.

Return Value

WorksetId
Id of the Workset which owns the element.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Each element belongs to one and only one workset.
See Also

Reference

Document Class


Document.GetWorksetTable Method

DocumentGetWorksetTable Method

Get the WorksetTable of this document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WorksetTable GetWorksetTable()
Public Function GetWorksetTable As WorksetTable
public:
WorksetTable^ GetWorksetTable()
member GetWorksetTable : unit -> WorksetTable

Return Value

WorksetTable
The WorksetTable of this document.
Remarks
There is one WorksetTable for each document. There will be at least one workset in the table, even if sharing has not yet been enabled for this document.
See Also

Reference

Document Class


Document.GetWorksharingCentralModelPath Method

DocumentGetWorksharingCentralModelPath Method

Gets the central model path of the worksharing model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ModelPath GetWorksharingCentralModelPath()
Public Function GetWorksharingCentralModelPath As ModelPath
public:
ModelPath^ GetWorksharingCentralModelPath()
member GetWorksharingCentralModelPath : unit -> ModelPath

Return Value

ModelPath
The central model path, or null if the document is not workshared.
Exceptions
Exception | Condition
InvalidOperationException | This Document is not a workshared document.
See Also

Reference

Document Class


Document.HasAllChangesFromCentral Method

DocumentHasAllChangesFromCentral Method

Returns whether the model in the current session is up to date with central.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasAllChangesFromCentral()
Public Function HasAllChangesFromCentral As Boolean
public:
bool HasAllChangesFromCentral()
member HasAllChangesFromCentral : unit -> bool

Return Value

Boolean
True means up to date; false means out of date.

If central is locked but Revit can determine that the model in the current session is out of date without opening central, this method will return false instead of throwing CentralModelContentionException.

Exceptions
Exception | Condition
CentralFileCommunicationException | The file-based central model could not be reached, because e.g. the network is down or the file server is down.
CentralModelAccessDeniedException | Access to the central model was denied due to lack of access privileges. -or- Access to the central model was denied. A possible reason is because the model was under maintenance.
CentralModelContentionException | The central model is locked by another client.
CentralModelException | Username does not match the one used to create the local file. -or- The central model has been replaced by a local model. -or- Local incompatible because it was closed without saving after synchronizing with central. -or- The central model is missing. -or- The central model is incompatible. -or- The central model is corrupt or not an RVT file. -or- The central model was rolled back. -or- The central model's elements have been relinquished -or- The central model is overritten by other user. -or- An internal error happened on the central model, please contact the server administrator.
FileNotFoundException | Cannot access the local file.
InvalidOperationException | This Document is not a workshared document. -or- This Document is a local file that is not owned by the current user, who therefore is not allowed to modify it.
RevitServerCommunicationException | The server-based central model could not be accessed because of a network communication error.
RevitServerInternalException | An internal error happened on the server, please contact the server administrator.
RevitServerUnauthenticatedUserException | User is not signed in with Autodesk id.
RevitServerUnauthorizedException | User is not authorized to access the specified A360 project.
Example
C#
VB
C++
F#
Copy
void ReloadDocument(Document doc)
{
    ReloadLatestOptions reloadOpts = new ReloadLatestOptions();
    try
    {
        doc.ReloadLatest(reloadOpts);
        // Check to make sure no new changes were synced with Central during reload
        if (doc.HasAllChangesFromCentral() == false)
        {
            // If there are changes from central, reload again
            doc.ReloadLatest(reloadOpts);
        }
    }
    catch (Exception e)
    {
        TaskDialog.Show("Reload Failed", e.Message);
    }
}
Private Sub ReloadDocument(doc As Document)
    Dim reloadOpts As New ReloadLatestOptions()
    Try
        doc.ReloadLatest(reloadOpts)
        ' Check to make sure no new changes were synced with Central during reload
        If doc.HasAllChangesFromCentral() = False Then
            ' If there are changes from central, reload again
            doc.ReloadLatest(reloadOpts)
        End If
    Catch e As Exception
        TaskDialog.Show("Reload Failed", e.Message)
    End Try
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Document Class


Document.Import Method

DocumentImport Method

Overload List
 | Name | Description
Public method | Import(String, GBXMLImportOptions) | Imports a Green-Building XML file into the document.
Public method | Import(String, AXMImportOptions, View) | Imports an AXM file into the document.
Public method | Import(String, ImportOptions3DM, View) | Imports a 3DM file into the document.
Public method | Import(String, OBJImportOptions, View) | Imports an OBJ file into the document.
Public method | Import(String, SATImportOptions, View) | Imports an SAT file into the document.
Public method | Import(String, SKPImportOptions, View) | Imports a SKP file into the document.
Public method | Import(String, STEPImportOptions, View) | Imports a STEP file into the document.
Public method | Import(String, STLImportOptions, View) | Imports an STL file into the document.
Public method | Import(String, DGNImportOptions, View, ElementId) | Imports a DGN file to the document.
Public method | Import(String, DWGImportOptions, View, ElementId) | Imports a DWG or DXF file to the document.
Top
See Also

Reference

Document Class


Document.Import(String, GBXMLImportOptions) Method

DocumentImport(String, GBXMLImportOptions) Method

Imports a Green-Building XML file into the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Import(
    string file,
    GBXMLImportOptions options
)
Public Function Import (
    file As String,
    options As GBXMLImportOptions
) As Boolean
public:
bool Import(
    String^ file,
    GBXMLImportOptions^ options
)
member Import :
        file : string *
        options : GBXMLImportOptions -> bool

Parameters

file String
Full path of the file to import. File must exist.
options GBXMLImportOptions
Various options applicable to GBXml import. If , all options will be set to their respective default values.

Return Value

Boolean
True if successful, otherwise False.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when file argument is or empty.
FileNotFoundException | Thrown when the file specified does not exist.
ArgumentException | Thrown when no file is specified or if the file is not a valid gbXML file or does not contain any result elements.
Remarks
This method is available only in MEP. Though the 'options' argument is not currently used, an object still must be provided (may be ). The method will return False if not succeed. e.g when the input xml file does not contain any result elements.
See Also

Reference

Document Class
Import Overload


Document.Import(String, AXMImportOptions, View) Method

DocumentImport(String, AXMImportOptions, View) Method

Imports an AXM file into the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId Import(
    string file,
    AXMImportOptions options,
    View pDBView
)
Public Function Import (
    file As String,
    options As AXMImportOptions,
    pDBView As View
) As ElementId
public:
ElementId^ Import(
    String^ file,
    AXMImportOptions^ options,
    View^ pDBView
)
member Import :
        file : string *
        options : AXMImportOptions *
        pDBView : View -> ElementId

Parameters

file String
Full path of the file to import. File must exist and must be a valid AXM file.
options AXMImportOptions
Various import options applicable to the AXM format. If , all options will be set to their respective default values. Import FormIt support Preserve color mode, center-to-center and origin-to-origin placement, other options are not supported. Import FormIt does not support orient to view and this view only option.
pDBView View
View used to aid placement of the imported file. If the options specify center-to-center placement, this argument is required and the imported file will be placed in the center of the specified view. Otherwise, this view is used to obtain a base level to associate with the imported file. If not specified, an existing view will be chosen instead and may open a view or associate the imported file to an arbitrary level.

Return Value

ElementId
Returns the element Id of the imported instance.
Exceptions
Exception | Condition
ArgumentException | Not a valid file for AXM import (.axm files are valid). -or- The provided view is not valid for the options provided. -or- Visible layer only option is not false or layers are specified in SetLayerSelection. -or- Import levels is only supported in project document or conceptual mass document for AXM import. -or- Not all AXM import option settings are valid. For more details, please refer to AXMImportOptions. -or- The scale is not valid as a CustomScale for use during import. -or- NullOrEmpty -or- The view is not printable.
ArgumentNullException | A non-optional argument was null
FileArgumentNotFoundException | The given file does not exist.
InvalidOperationException | Import is temporarily disabled.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
OptionalFunctionalityNotAvailableException | The AXM Import/Link module is not available in the installed Revit.
See Also

Reference

Document Class
Import Overload


Document.Import(String, ImportOptions3DM, View) Method

DocumentImport(String, ImportOptions3DM, View) Method

Imports a 3DM file into the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId Import(
    string file,
    ImportOptions3DM options,
    View pDBView
)
Public Function Import (
    file As String,
    options As ImportOptions3DM,
    pDBView As View
) As ElementId
public:
ElementId^ Import(
    String^ file,
    ImportOptions3DM^ options,
    View^ pDBView
)
member Import :
        file : string *
        options : ImportOptions3DM *
        pDBView : View -> ElementId

Parameters

file String
Full path of the file to import. File must exist and must be a valid 3DM file.
options ImportOptions3DM
Various import options applicable to the 3DM format. If , all options will be set to their respective default values.
pDBView View
View used to aid placement of the imported file. If the options specify ThisViewOnly, this argument is required and the imported file will only be visible in the specified view. If the options specify center-to-center placement, this argument is required and the imported file will be placed in the center of the specified view. Otherwise, this view is used to obtain a base level to associate with the imported file. If not specified, an existing view will be chosen instead and may open a view or associate the imported file to an arbitrary level.

Return Value

ElementId
Returns the element Id of the imported instance.
Exceptions
Exception | Condition
ArgumentException | Not a valid file for 3DM import (.3dm files are valid). -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view. -or- The provided view is not valid for the options provided. -or- One or more strings describing layer selection is invalid or empty. -or- The scale is not valid as a CustomScale for use during import. -or- NullOrEmpty -or- The view is not printable.
ArgumentNullException | A non-optional argument was null
FileArgumentNotFoundException | The given file does not exist.
InvalidOperationException | Import is temporarily disabled.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
OptionalFunctionalityNotAvailableException | The 3DM Import/Link module is not available in the installed Revit.
See Also

Reference

Document Class
Import Overload


Document.Import(String, OBJImportOptions, View) Method

DocumentImport(String, OBJImportOptions, View) Method

Imports an OBJ file into the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId Import(
    string file,
    OBJImportOptions options,
    View pDBView
)
Public Function Import (
    file As String,
    options As OBJImportOptions,
    pDBView As View
) As ElementId
public:
ElementId^ Import(
    String^ file,
    OBJImportOptions^ options,
    View^ pDBView
)
member Import :
        file : string *
        options : OBJImportOptions *
        pDBView : View -> ElementId

Parameters

file String
Full path of the file to import. File must exist and must be a valid OBJ file.
options OBJImportOptions
Various import options applicable to the OBJ format. If , all options will be set to their respective default values.
pDBView View
View used to aid placement of the imported file. If the options specify ThisViewOnly, this argument is required and the imported file will only be visible in the specified view. If the options specify center-to-center placement, this argument is required and the imported file will be placed in the center of the specified view. Otherwise, this view is used to obtain a base level to associate with the imported file. If not specified, an existing view will be chosen instead and may open a view or associate the imported file to an arbitrary level.

Return Value

ElementId
Returns the element Id of the imported instance.
Exceptions
Exception | Condition
ArgumentException | Not a valid file for OBJ import (.obj files are valid). -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view. -or- The provided view is not valid for the options provided. -or- One or more strings describing layer selection is invalid or empty. -or- The scale is not valid as a CustomScale for use during import. -or- NullOrEmpty -or- The view is not printable.
ArgumentNullException | A non-optional argument was null
FileArgumentNotFoundException | The given file does not exist.
InvalidOperationException | Import is temporarily disabled.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
OptionalFunctionalityNotAvailableException | The OBJ Import/Link module is not available in the installed Revit.
See Also

Reference

Document Class
Import Overload


Document.Import(String, SATImportOptions, View) Method

DocumentImport(String, SATImportOptions, View) Method

Imports an SAT file into the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId Import(
    string file,
    SATImportOptions options,
    View pDBView
)
Public Function Import (
    file As String,
    options As SATImportOptions,
    pDBView As View
) As ElementId
public:
ElementId^ Import(
    String^ file,
    SATImportOptions^ options,
    View^ pDBView
)
member Import :
        file : string *
        options : SATImportOptions *
        pDBView : View -> ElementId

Parameters

file String
Full path of the file to import. File must exist and must be a valid SAT file.
options SATImportOptions
Various import options applicable to the SAT format. If , all options will be set to their respective default values.
pDBView View
View used to aid placement of the imported file. If the options specify ThisViewOnly, this argument is required and the imported file will only be visible in the specified view. If the options specify center-to-center placement, this argument is required and the imported file will be placed in the center of the specified view. Otherwise, this view is used to obtain a base level to associate with the imported file. If not specified, an existing view will be chosen instead and may open a view or associate the imported file to an arbitrary level.

Return Value

ElementId
Returns the element Id of the imported instance.
Exceptions
Exception | Condition
ArgumentException | Not a valid file for SAT import (.sat files are valid). -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view. -or- The provided view is not valid for the options provided. -or- One or more strings describing layer selection is invalid or empty. -or- The scale is not valid as a CustomScale for use during import. -or- NullOrEmpty -or- The view is not printable.
ArgumentNullException | A non-optional argument was null
FileArgumentNotFoundException | The given file does not exist.
InvalidOperationException | Import is temporarily disabled.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
OptionalFunctionalityNotAvailableException | The SAT Import/Link module is not available in the installed Revit.
See Also

Reference

Document Class
Import Overload


Document.Import(String, SKPImportOptions, View) Method

DocumentImport(String, SKPImportOptions, View) Method

Imports a SKP file into the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId Import(
    string file,
    SKPImportOptions options,
    View pDBView
)
Public Function Import (
    file As String,
    options As SKPImportOptions,
    pDBView As View
) As ElementId
public:
ElementId^ Import(
    String^ file,
    SKPImportOptions^ options,
    View^ pDBView
)
member Import :
        file : string *
        options : SKPImportOptions *
        pDBView : View -> ElementId

Parameters

file String
Full path of the file to import. File must exist and must be a valid SKP file.
options SKPImportOptions
Various import options applicable to the SKP format. If , all options will be set to their respective default values.
pDBView View
View used to aid placement of the imported file. If the options specify ThisViewOnly, this argument is required and the imported file will only be visible in the specified view. If the options specify center-to-center placement, this argument is required and the imported file will be placed in the center of the specified view. Otherwise, this view is used to obtain a base level to associate with the imported file. If not specified, an existing view will be chosen instead and may open a view or associate the imported file to an arbitrary level.

Return Value

ElementId
Returns the element Id of the imported instance.
Exceptions
Exception | Condition
ArgumentException | Not a valid file for SKP import (.skp files are valid). -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view. -or- The provided view is not valid for the options provided. -or- One or more strings describing layer selection is invalid or empty. -or- The scale is not valid as a CustomScale for use during import. -or- NullOrEmpty -or- The view is not printable.
ArgumentNullException | A non-optional argument was null
FileArgumentNotFoundException | The given file does not exist.
InvalidOperationException | Import is temporarily disabled.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
OptionalFunctionalityNotAvailableException | The SKP Import/Link module is not available in the installed Revit.
See Also

Reference

Document Class
Import Overload


Document.Import(String, STEPImportOptions, View) Method

DocumentImport(String, STEPImportOptions, View) Method

Imports a STEP file into the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId Import(
    string file,
    STEPImportOptions options,
    View pDBView
)
Public Function Import (
    file As String,
    options As STEPImportOptions,
    pDBView As View
) As ElementId
public:
ElementId^ Import(
    String^ file,
    STEPImportOptions^ options,
    View^ pDBView
)
member Import :
        file : string *
        options : STEPImportOptions *
        pDBView : View -> ElementId

Parameters

file String
Full path of the file to import. File must exist and must be a valid STEP file.
options STEPImportOptions
Various import options applicable to the STEP format. If , all options will be set to their respective default values.
pDBView View
View used to aid placement of the imported file. If the options specify ThisViewOnly, this argument is required and the imported file will only be visible in the specified view. If the options specify center-to-center placement, this argument is required and the imported file will be placed in the center of the specified view. Otherwise, this view is used to obtain a base level to associate with the imported file. If not specified, an existing view will be chosen instead and may open a view or associate the imported file to an arbitrary level.

Return Value

ElementId
Returns the element Id of the imported instance.
Exceptions
Exception | Condition
ArgumentException | Not a valid file for STEP import (.step, .stp., .stpz files are valid). -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view. -or- The provided view is not valid for the options provided. -or- One or more strings describing layer selection is invalid or empty. -or- The scale is not valid as a CustomScale for use during import. -or- NullOrEmpty -or- The view is not printable.
ArgumentNullException | A non-optional argument was null
FileArgumentNotFoundException | The given file does not exist.
InvalidOperationException | Import is temporarily disabled.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
OptionalFunctionalityNotAvailableException | The STEP Import/Link module is not available in the installed Revit.
See Also

Reference

Document Class
Import Overload


Document.Import(String, STLImportOptions, View) Method

DocumentImport(String, STLImportOptions, View) Method

Imports an STL file into the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId Import(
    string file,
    STLImportOptions options,
    View pDBView
)
Public Function Import (
    file As String,
    options As STLImportOptions,
    pDBView As View
) As ElementId
public:
ElementId^ Import(
    String^ file,
    STLImportOptions^ options,
    View^ pDBView
)
member Import :
        file : string *
        options : STLImportOptions *
        pDBView : View -> ElementId

Parameters

file String
Full path of the file to import. File must exist and must be a valid STL file.
options STLImportOptions
Various import options applicable to the STL format. If , all options will be set to their respective default values.
pDBView View
View used to aid placement of the imported file. If the options specify ThisViewOnly, this argument is required and the imported file will only be visible in the specified view. If the options specify center-to-center placement, this argument is required and the imported file will be placed in the center of the specified view. Otherwise, this view is used to obtain a base level to associate with the imported file. If not specified, an existing view will be chosen instead and may open a view or associate the imported file to an arbitrary level.

Return Value

ElementId
Returns the element Id of the imported instance.
Exceptions
Exception | Condition
ArgumentException | Not a valid file for STL import (.stl files are valid). -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view. -or- The provided view is not valid for the options provided. -or- One or more strings describing layer selection is invalid or empty. -or- The scale is not valid as a CustomScale for use during import. -or- NullOrEmpty -or- The view is not printable.
ArgumentNullException | A non-optional argument was null
FileArgumentNotFoundException | The given file does not exist.
InvalidOperationException | Import is temporarily disabled.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
OptionalFunctionalityNotAvailableException | The STL Import/Link module is not available in the installed Revit.
See Also

Reference

Document Class
Import Overload


Document.Import(String, DGNImportOptions, View, ElementId) Method

DocumentImport(String, DGNImportOptions, View, ElementId) Method

Imports a DGN file to the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Import(
    string file,
    DGNImportOptions options,
    View pDBView,
    out ElementId elementId
)
Public Function Import (
    file As String,
    options As DGNImportOptions,
    pDBView As View,
    <OutAttribute> ByRef elementId As ElementId
) As Boolean
public:
bool Import(
    String^ file,
    DGNImportOptions^ options,
    View^ pDBView,
    [OutAttribute] ElementId^% elementId
)
member Import :
        file : string *
        options : DGNImportOptions *
        pDBView : View *
        elementId : ElementId byref -> bool

Parameters

file String
Full path of the file to import. File must exist and must be a valid DGN file.
options DGNImportOptions
Various options applicable to the DGN format. If , all options will be set to their respective default values.
pDBView View
View used to aid placement of the imported file. If the options specify ThisViewOnly, this argument is required and the imported file will only be visible in the specified view. If the options specify center-to-center placement, this argument is required and the imported file will be placed in the center of the specified view. Otherwise, this view is used to obtain a base level to associate with the imported file. If not specified, an existing view will be chosen instead and may open a view or associate the imported file to an arbitrary level.
elementId ElementId
The id of imported instance after a successful import.

Return Value

Boolean
True if successful, otherwise False.
Exceptions
Exception | Condition
ArgumentException | Not a valid file for DGN import (.dgn files are valid). -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view. -or- The provided view is not valid for the options provided. -or- One or more strings describing layer selection is invalid or empty. -or- The scale is not valid as a CustomScale for use during import. -or- NullOrEmpty -or- The view is not printable. -or- Empty DGN model view name characters. -or- Visible layer only option must be set to false for DGN import.
ArgumentNullException | A non-optional argument was null
FileArgumentNotFoundException | The given file does not exist.
InvalidOperationException | Import is temporarily disabled.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
OptionalFunctionalityNotAvailableException | The DGN Import/Link module is not available in the installed Revit.
See Also

Reference

Document Class
Import Overload


Document.Import(String, DWGImportOptions, View, ElementId) Method

DocumentImport(String, DWGImportOptions, View, ElementId) Method

Imports a DWG or DXF file to the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Import(
    string file,
    DWGImportOptions options,
    View pDBView,
    out ElementId elementId
)
Public Function Import (
    file As String,
    options As DWGImportOptions,
    pDBView As View,
    <OutAttribute> ByRef elementId As ElementId
) As Boolean
public:
bool Import(
    String^ file,
    DWGImportOptions^ options,
    View^ pDBView,
    [OutAttribute] ElementId^% elementId
)
member Import :
        file : string *
        options : DWGImportOptions *
        pDBView : View *
        elementId : ElementId byref -> bool

Parameters

file String
Full path of the file to import. File must exist and must be a valid DWG or DXF file.
options DWGImportOptions
Various options applicable to the DWG or DXF format. If , all options will be set to their respective default values.
pDBView View
View used to aid placement of the imported file. If the options specify ThisViewOnly, this argument is required and the imported file will only be visible in the specified view. If the options specify center-to-center placement, this argument is required and the imported file will be placed in the center of the specified view. Otherwise, this view is used to obtain a base level to associate with the imported file. If not specified, an existing view will be chosen instead and may open a view or associate the imported file to an arbitrary level.
elementId ElementId
The id of imported instance after a successful import.

Return Value

Boolean
True if successful, otherwise False.
Exceptions
Exception | Condition
ArgumentException | Not a valid file for DWG import (.dwg and .dxf files are valid). -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view. -or- The provided view is not valid for the options provided. -or- One or more strings describing layer selection is invalid or empty. -or- The line weights are not valid; either it contains an invalid number of line weights, or a line weight outside the valid range. -or- The scale is not valid as a CustomScale for use during import. -or- NullOrEmpty -or- The view is not printable.
ArgumentNullException | A non-optional argument was null
FileArgumentNotFoundException | The given file does not exist.
InvalidOperationException | Import is temporarily disabled.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
OptionalFunctionalityNotAvailableException | The DWG Import/Link module is not available in the installed Revit.
See Also

Reference

Document Class
Import Overload


Document.IsBackgroundCalculationInProgress Method

DocumentIsBackgroundCalculationInProgress Method

Indicates whether there are any background calculations in progress for this document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsBackgroundCalculationInProgress()
Public Function IsBackgroundCalculationInProgress As Boolean
public:
bool IsBackgroundCalculationInProgress()
member IsBackgroundCalculationInProgress : unit -> bool

Return Value

Boolean
Returns true if the document has any data calculation in progress and false otherwise.
Remarks
When a document has background calculations in progress, users cannot perform the following operations:
  • Save/Close the document.
  • Export/Print the document.
  • Synchronize to central, in worksharing environment.
  • Create a steel element.
  • Copy/Mirror/Rotate a steel element.
  • Edit the sketch of plate element.
  • Edit a custom connection.
See Also

Reference

Document Class


Document.IsDefaultElementTypeIdValid Method

DocumentIsDefaultElementTypeIdValid Method

Checks whether the element type id is valid for the give DefaultElmentType id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsDefaultElementTypeIdValid(
    ElementTypeGroup defaultTypeId,
    ElementId typeId
)
Public Function IsDefaultElementTypeIdValid (
    defaultTypeId As ElementTypeGroup,
    typeId As ElementId
) As Boolean
public:
bool IsDefaultElementTypeIdValid(
    ElementTypeGroup defaultTypeId,
    ElementId^ typeId
)
member IsDefaultElementTypeIdValid :
        defaultTypeId : ElementTypeGroup *
        typeId : ElementId -> bool

Parameters

defaultTypeId ElementTypeGroup
The default element type id.
typeId ElementId
The element type id.

Return Value

Boolean
True if the element type id is valid for the give DefaultElmentType id, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

Document Class


Document.IsDefaultFamilyTypeIdValid Method

DocumentIsDefaultFamilyTypeIdValid Method

Checks whether the family type id is valid for the give family category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsDefaultFamilyTypeIdValid(
    ElementId familyCategoryId,
    ElementId familyTypeId
)
Public Function IsDefaultFamilyTypeIdValid (
    familyCategoryId As ElementId,
    familyTypeId As ElementId
) As Boolean
public:
bool IsDefaultFamilyTypeIdValid(
    ElementId^ familyCategoryId,
    ElementId^ familyTypeId
)
member IsDefaultFamilyTypeIdValid :
        familyCategoryId : ElementId *
        familyTypeId : ElementId -> bool

Parameters

familyCategoryId ElementId
The family category id.
familyTypeId ElementId
The default family type id.

Return Value

Boolean
True if the family type id is valid for the give family category, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

Document Class


Document.IsPainted Method

DocumentIsPainted Method

Checks if the element's face is painted with a material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsPainted(
    ElementId elementId,
    Face face
)
Public Function IsPainted (
    elementId As ElementId,
    face As Face
) As Boolean
public:
bool IsPainted(
    ElementId^ elementId,
    Face^ face
)
member IsPainted :
        elementId : ElementId *
        face : Face -> bool

Parameters

elementId ElementId
The element that the face belongs to.
face Face
The painted element's face.

Return Value

Boolean
True if the element's face is painted.
Exceptions
Exception | Condition
ArgumentException | The element elementId does not exist in the document -or- The face doesn't belong to the element
ArgumentNullException | A non-optional argument was null
See Also

Reference

Document Class


Document.IsValidVersionGUID Method

DocumentIsValidVersionGUID Method

Checks whether the GUID is valid for the given document. Empty GUID is allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidVersionGUID(
    Document document,
    Guid versionGUID
)
Public Shared Function IsValidVersionGUID (
    document As Document,
    versionGUID As Guid
) As Boolean
public:
static bool IsValidVersionGUID(
    Document^ document,
    Guid versionGUID
)
static member IsValidVersionGUID :
        document : Document *
        versionGUID : Guid -> bool

Parameters

document Document
Target document.
versionGUID Guid
The GUID to check.

Return Value

Boolean
True if the GUID is valid.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

Document Class


Document.Link Method

DocumentLink Method

Overload List
 | Name | Description
Public method | Link(String, DWFImportOptions) | Links Markups in a DWF file into the project document.
Public method | Link(String, ImportOptions3DM, View) | Links a 3DM file into the project document.
Public method | Link(String, OBJImportOptions, View) | Links an OBJ file into the project document.
Public method | Link(String, SATImportOptions, View) | Links an SAT file into the project document.
Public method | Link(String, SKPImportOptions, View) | Links a SKP file into the project document.
Public method | Link(String, STEPImportOptions, View) | Links an STEP file into the project document.
Public method | Link(String, STLImportOptions, View) | Links an STL file into the project document.
Public method | Link(String, DGNImportOptions, View, ElementId) | Links a DGN file into the project document.
Public method | Link(String, DWGImportOptions, View, ElementId) | Links a DWG or DXF file into the project document.
Top
See Also

Reference

Document Class


Document.Link(String, DWFImportOptions) Method

DocumentLink(String, DWFImportOptions) Method

Links Markups in a DWF file into the project document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ElementId> Link(
    string file,
    DWFImportOptions options
)
Public Function Link (
    file As String,
    options As DWFImportOptions
) As IList(Of ElementId)
public:
IList<ElementId^>^ Link(
    String^ file,
    DWFImportOptions^ options
)
member Link :
        file : string *
        options : DWFImportOptions -> IList<ElementId>

Parameters

file String
Full path of the file to link. File must exist and must be a valid DWF file.
options DWFImportOptions
Various link options applicable to the DWF format.

Return Value

IList ElementId
A collection of link instance element ids created by the markup link.
Exceptions
Exception | Condition
ArgumentException | Not a valid file for DWF import (.dwf or.dwfx files are valid). -or- Some of the views are not importable.
ArgumentNullException | A non-optional argument was null
FileArgumentNotFoundException | The given file does not exist.
InvalidOperationException | Import is temporarily disabled. -or- This Document is not a project document.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
Link isn't supported for family documents. Please use import instead.
See Also

Reference

Document Class
Link Overload


Document.Link(String, ImportOptions3DM, View) Method

DocumentLink(String, ImportOptions3DM, View) Method

Links a 3DM file into the project document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId Link(
    string file,
    ImportOptions3DM options,
    View pDBView
)
Public Function Link (
    file As String,
    options As ImportOptions3DM,
    pDBView As View
) As ElementId
public:
ElementId^ Link(
    String^ file,
    ImportOptions3DM^ options,
    View^ pDBView
)
member Link :
        file : string *
        options : ImportOptions3DM *
        pDBView : View -> ElementId

Parameters

file String
Full path of the file to link. File must exist and must be a valid 3DM file.
options ImportOptions3DM
Various import options applicable to the 3DM format. If , all options will be set to their respective default values.
pDBView View
View used to aid placement of the linked file. If the options specify ThisViewOnly, this argument is required and the linked file will only be visible in the specified view. If the options specify center-to-center placement, this argument is required and the linked file will be placed in the center of the specified view. Otherwise, this view is used to obtain a base level to associate with the linked file. If not specified, an existing view will be chosen instead and may open a view or associate the linked file to an arbitrary level.

Return Value

ElementId
Returns the element Id of the linked instance.
Exceptions
Exception | Condition
ArgumentException | Not a valid file for 3DM import (.3dm files are valid). -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view. -or- The provided view is not valid for the options provided. -or- One or more strings describing layer selection is invalid or empty. -or- The scale is not valid as a CustomScale for use during import. -or- NullOrEmpty -or- The view is not printable.
ArgumentNullException | A non-optional argument was null
FileArgumentNotFoundException | The given file does not exist.
InvalidOperationException | Import is temporarily disabled. -or- This Document is not a project document.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
OptionalFunctionalityNotAvailableException | The 3DM Import/Link module is not available in the installed Revit.
Remarks
Link isn't supported for family documents. Please use import instead.
See Also

Reference

Document Class
Link Overload


Document.Link(String, OBJImportOptions, View) Method

DocumentLink(String, OBJImportOptions, View) Method

Links an OBJ file into the project document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId Link(
    string file,
    OBJImportOptions options,
    View pDBView
)
Public Function Link (
    file As String,
    options As OBJImportOptions,
    pDBView As View
) As ElementId
public:
ElementId^ Link(
    String^ file,
    OBJImportOptions^ options,
    View^ pDBView
)
member Link :
        file : string *
        options : OBJImportOptions *
        pDBView : View -> ElementId

Parameters

file String
Full path of the file to link. File must exist and must be a valid OBJ file.
options OBJImportOptions
Various import options applicable to the OBJ format. If , all options will be set to their respective default values.
pDBView View
View used to aid placement of the linked file. If the options specify ThisViewOnly, this argument is required and the linked file will only be visible in the specified view. If the options specify center-to-center placement, this argument is required and the linked file will be placed in the center of the specified view. Otherwise, this view is used to obtain a base level to associate with the linked file. If not specified, an existing view will be chosen instead and may open a view or associate the linked file to an arbitrary level.

Return Value

ElementId
Returns the element Id of the linked instance.
Exceptions
Exception | Condition
ArgumentException | Not a valid file for OBJ import (.obj files are valid). -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view. -or- The provided view is not valid for the options provided. -or- One or more strings describing layer selection is invalid or empty. -or- The scale is not valid as a CustomScale for use during import. -or- NullOrEmpty -or- The view is not printable.
ArgumentNullException | A non-optional argument was null
FileArgumentNotFoundException | The given file does not exist.
InvalidOperationException | Import is temporarily disabled. -or- This Document is not a project document.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
OptionalFunctionalityNotAvailableException | The OBJ Import/Link module is not available in the installed Revit.
Remarks
Link isn't supported for family documents. Please use import instead.
See Also

Reference

Document Class
Link Overload


Document.Link(String, SATImportOptions, View) Method

DocumentLink(String, SATImportOptions, View) Method

Links an SAT file into the project document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId Link(
    string file,
    SATImportOptions options,
    View pDBView
)
Public Function Link (
    file As String,
    options As SATImportOptions,
    pDBView As View
) As ElementId
public:
ElementId^ Link(
    String^ file,
    SATImportOptions^ options,
    View^ pDBView
)
member Link :
        file : string *
        options : SATImportOptions *
        pDBView : View -> ElementId

Parameters

file String
Full path of the file to link. File must exist and must be a valid SAT file.
options SATImportOptions
Various import options applicable to the SAT format. If , all options will be set to their respective default values.
pDBView View
View used to aid placement of the linked file. If the options specify ThisViewOnly, this argument is required and the linked file will only be visible in the specified view. If the options specify center-to-center placement, this argument is required and the linked file will be placed in the center of the specified view. Otherwise, this view is used to obtain a base level to associate with the linked file. If not specified, an existing view will be chosen instead and may open a view or associate the linked file to an arbitrary level.

Return Value

ElementId
Returns the element Id of the linked instance.
Exceptions
Exception | Condition
ArgumentException | Not a valid file for SAT import (.sat files are valid). -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view. -or- The provided view is not valid for the options provided. -or- One or more strings describing layer selection is invalid or empty. -or- The scale is not valid as a CustomScale for use during import. -or- NullOrEmpty -or- The view is not printable.
ArgumentNullException | A non-optional argument was null
FileArgumentNotFoundException | The given file does not exist.
InvalidOperationException | Import is temporarily disabled. -or- This Document is not a project document.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
OptionalFunctionalityNotAvailableException | The SAT Import/Link module is not available in the installed Revit.
Remarks
Link isn't supported for family documents. Please use import instead.
See Also

Reference

Document Class
Link Overload


Document.Link(String, SKPImportOptions, View) Method

DocumentLink(String, SKPImportOptions, View) Method

Links a SKP file into the project document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId Link(
    string file,
    SKPImportOptions options,
    View pDBView
)
Public Function Link (
    file As String,
    options As SKPImportOptions,
    pDBView As View
) As ElementId
public:
ElementId^ Link(
    String^ file,
    SKPImportOptions^ options,
    View^ pDBView
)
member Link :
        file : string *
        options : SKPImportOptions *
        pDBView : View -> ElementId

Parameters

file String
Full path of the file to link. File must exist and must be a valid SKP file.
options SKPImportOptions
Various import options applicable to the SKP format. If , all options will be set to their respective default values.
pDBView View
View used to aid placement of the linked file. If the options specify ThisViewOnly, this argument is required and the linked file will only be visible in the specified view. If the options specify center-to-center placement, this argument is required and the linked file will be placed in the center of the specified view. Otherwise, this view is used to obtain a base level to associate with the linked file. If not specified, an existing view will be chosen instead and may open a view or associate the linked file to an arbitrary level.

Return Value

ElementId
Returns the element Id of the linked instance.
Exceptions
Exception | Condition
ArgumentException | Not a valid file for SKP import (.skp files are valid). -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view. -or- The provided view is not valid for the options provided. -or- One or more strings describing layer selection is invalid or empty. -or- The scale is not valid as a CustomScale for use during import. -or- NullOrEmpty -or- The view is not printable.
ArgumentNullException | A non-optional argument was null
FileArgumentNotFoundException | The given file does not exist.
InvalidOperationException | Import is temporarily disabled. -or- This Document is not a project document.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
OptionalFunctionalityNotAvailableException | The SKP Import/Link module is not available in the installed Revit.
Remarks
Link isn't supported for family documents. Please use import instead.
See Also

Reference

Document Class
Link Overload


Document.Link(String, STEPImportOptions, View) Method

DocumentLink(String, STEPImportOptions, View) Method

Links an STEP file into the project document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId Link(
    string file,
    STEPImportOptions options,
    View pDBView
)
Public Function Link (
    file As String,
    options As STEPImportOptions,
    pDBView As View
) As ElementId
public:
ElementId^ Link(
    String^ file,
    STEPImportOptions^ options,
    View^ pDBView
)
member Link :
        file : string *
        options : STEPImportOptions *
        pDBView : View -> ElementId

Parameters

file String
Full path of the file to link. File must exist and must be a valid STEP file.
options STEPImportOptions
Various import options applicable to the STEP format. If , all options will be set to their respective default values.
pDBView View
View used to aid placement of the linked file. If the options specify ThisViewOnly, this argument is required and the linked file will only be visible in the specified view. If the options specify center-to-center placement, this argument is required and the linked file will be placed in the center of the specified view. Otherwise, this view is used to obtain a base level to associate with the linked file. If not specified, an existing view will be chosen instead and may open a view or associate the linked file to an arbitrary level.

Return Value

ElementId
Returns the element Id of the linked instance.
Exceptions
Exception | Condition
ArgumentException | Not a valid file for STEP import (.step, .stp., .stpz files are valid). -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view. -or- The provided view is not valid for the options provided. -or- One or more strings describing layer selection is invalid or empty. -or- The scale is not valid as a CustomScale for use during import. -or- NullOrEmpty -or- The view is not printable.
ArgumentNullException | A non-optional argument was null
FileArgumentNotFoundException | The given file does not exist.
InvalidOperationException | Import is temporarily disabled. -or- This Document is not a project document.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
OptionalFunctionalityNotAvailableException | The STEP Import/Link module is not available in the installed Revit.
Remarks
Link isn't supported for family documents. Please use import instead.
See Also

Reference

Document Class
Link Overload


Document.Link(String, STLImportOptions, View) Method

DocumentLink(String, STLImportOptions, View) Method

Links an STL file into the project document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId Link(
    string file,
    STLImportOptions options,
    View pDBView
)
Public Function Link (
    file As String,
    options As STLImportOptions,
    pDBView As View
) As ElementId
public:
ElementId^ Link(
    String^ file,
    STLImportOptions^ options,
    View^ pDBView
)
member Link :
        file : string *
        options : STLImportOptions *
        pDBView : View -> ElementId

Parameters

file String
Full path of the file to link. File must exist and must be a valid STL file.
options STLImportOptions
Various import options applicable to the STL format. If , all options will be set to their respective default values.
pDBView View
View used to aid placement of the linked file. If the options specify ThisViewOnly, this argument is required and the linked file will only be visible in the specified view. If the options specify center-to-center placement, this argument is required and the linked file will be placed in the center of the specified view. Otherwise, this view is used to obtain a base level to associate with the linked file. If not specified, an existing view will be chosen instead and may open a view or associate the linked file to an arbitrary level.

Return Value

ElementId
Returns the element Id of the linked instance.
Exceptions
Exception | Condition
ArgumentException | Not a valid file for STL import (.stl files are valid). -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view. -or- The provided view is not valid for the options provided. -or- One or more strings describing layer selection is invalid or empty. -or- The scale is not valid as a CustomScale for use during import. -or- NullOrEmpty -or- The view is not printable.
ArgumentNullException | A non-optional argument was null
FileArgumentNotFoundException | The given file does not exist.
InvalidOperationException | Import is temporarily disabled. -or- This Document is not a project document.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
OptionalFunctionalityNotAvailableException | The STL Import/Link module is not available in the installed Revit.
Remarks
Link isn't supported for family documents. Please use import instead.
See Also

Reference

Document Class
Link Overload


Document.Link(String, DGNImportOptions, View, ElementId) Method

DocumentLink(String, DGNImportOptions, View, ElementId) Method

Links a DGN file into the project document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Link(
    string file,
    DGNImportOptions options,
    View pDBView,
    out ElementId elementId
)
Public Function Link (
    file As String,
    options As DGNImportOptions,
    pDBView As View,
    <OutAttribute> ByRef elementId As ElementId
) As Boolean
public:
bool Link(
    String^ file,
    DGNImportOptions^ options,
    View^ pDBView,
    [OutAttribute] ElementId^% elementId
)
member Link :
        file : string *
        options : DGNImportOptions *
        pDBView : View *
        elementId : ElementId byref -> bool

Parameters

file String
Full path of the file to link. File must exist and must be a valid DGN file.
options DGNImportOptions
Various import options applicable to the DGN format. If , all options will be set to their respective default values.
pDBView View
View used to aid placement of the linked file. If the options specify ThisViewOnly, this argument is required and the linked file will only be visible in the specified view. If the options specify center-to-center placement, this argument is required and the linked file will be placed in the center of the specified view. Otherwise, this view is used to obtain a base level to associate with the linked file. If not specified, an existing view will be chosen instead and may open a view or associate the linked file to an arbitrary level.
elementId ElementId
The id of linked instance after a successful link.

Return Value

Boolean
True if successful, otherwise False.
Exceptions
Exception | Condition
ArgumentException | Not a valid file for DGN import (.dgn files are valid). -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view. -or- The provided view is not valid for the options provided. -or- One or more strings describing layer selection is invalid or empty. -or- The scale is not valid as a CustomScale for use during import. -or- NullOrEmpty -or- The view is not printable. -or- Empty DGN model view name characters. -or- Visible layer only option must be set to false for DGN import.
ArgumentNullException | A non-optional argument was null
FileArgumentNotFoundException | The given file does not exist.
InvalidOperationException | Import is temporarily disabled. -or- This Document is not a project document.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
OptionalFunctionalityNotAvailableException | The DGN Import/Link module is not available in the installed Revit.
Remarks
Link isn't supported for family documents. Please use import instead.
See Also

Reference

Document Class
Link Overload


Document.Link(String, DWGImportOptions, View, ElementId) Method

DocumentLink(String, DWGImportOptions, View, ElementId) Method

Links a DWG or DXF file into the project document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Link(
    string file,
    DWGImportOptions options,
    View pDBView,
    out ElementId elementId
)
Public Function Link (
    file As String,
    options As DWGImportOptions,
    pDBView As View,
    <OutAttribute> ByRef elementId As ElementId
) As Boolean
public:
bool Link(
    String^ file,
    DWGImportOptions^ options,
    View^ pDBView,
    [OutAttribute] ElementId^% elementId
)
member Link :
        file : string *
        options : DWGImportOptions *
        pDBView : View *
        elementId : ElementId byref -> bool

Parameters

file String
Full path of the file to link. File must exist and must be a valid DWG or DXF file.
options DWGImportOptions
Various import options applicable to the DWG or DXF format. If , all options will be set to their respective default values.
pDBView View
View used to aid placement of the linked file. If the options specify ThisViewOnly, this argument is required and the linked file will only be visible in the specified view. If the options specify center-to-center placement, this argument is required and the linked file will be placed in the center of the specified view. Otherwise, this view is used to obtain a base level to associate with the linked file. If not specified, an existing view will be chosen instead and may open a view or associate the linked file to an arbitrary level.
elementId ElementId
The id of linked instance after a successful link.

Return Value

Boolean
True if successful, otherwise False.
Exceptions
Exception | Condition
ArgumentException | Not a valid file for DWG import (.dwg and .dxf files are valid). -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view. -or- The provided view is not valid for the options provided. -or- One or more strings describing layer selection is invalid or empty. -or- The line weights are not valid; either it contains an invalid number of line weights, or a line weight outside the valid range. -or- The scale is not valid as a CustomScale for use during import. -or- NullOrEmpty -or- The view is not printable.
ArgumentNullException | A non-optional argument was null
FileArgumentNotFoundException | The given file does not exist.
InvalidOperationException | Import is temporarily disabled. -or- This Document is not a project document.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
OptionalFunctionalityNotAvailableException | The DWG Import/Link module is not available in the installed Revit.
Remarks
Link isn't supported for family documents. Please use import instead.
See Also

Reference

Document Class
Link Overload


Document.LoadFamily Method

DocumentLoadFamily Method

Loads a family and all its types/symbols into the document.
Overload List
 | Name | Description
Public method | LoadFamily(Document) | Loads the contents of this family document into another document.
Public method | LoadFamily(String) | Loads an entire family and all its types/symbols into the document.
Public method | LoadFamily(Document, IFamilyLoadOptions) | Loads the contents of this family document into another document.
 | LoadFamily(String, Family) | Loads an entire family and all its types/symbols into the document and provides a reference to the loaded family.
Public method | LoadFamily(String, IFamilyLoadOptions, Family) | Loads an entire family and all its types/symbols into the document and provides a reference to the loaded family.
Top
See Also

Reference

Document Class


Document.LoadFamily(Document) Method

DocumentLoadFamily(Document) Method

Loads the contents of this family document into another document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Family LoadFamily(
    Document targetDocument
)
Public Function LoadFamily (
    targetDocument As Document
) As Family
public:
Family^ LoadFamily(
    Document^ targetDocument
)
member LoadFamily :
        targetDocument : Document -> Family

Parameters

targetDocument Document
The target document where the family will be loaded.

Return Value

Family
Reference of the family in the target document.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument-"targetDocument"-is .
InvalidOperationException | Thrown when the current document is not a family document, or when the target document is modifiable (e.g. there is an uncommitted transaction) or doesn't support load of this kind of families (e.g. loading a model family to detail family is disallowed), or when this family was found in the target document already and the conflict caused an automatic abort of the load operation, or when a shared family in this family was found in the target document already and the conflict caused an automatic abort of the load operation, or this document is currently in a read-only state.
ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.
Remarks
If you are reloading an edited family back into the source document from which it was extracted, this method will always fail. This is because this method automatically suppresses the prompts Revit typically uses to deal with conflicts between families, and assumes that any such conflict should prevent the loading. If you want to be able to reload the same family into the source document, you should use the LoadFamily() overload accepting IFamilyLoadOptions.
See Also

Reference

Document Class
LoadFamily Overload


Document.LoadFamily(String) Method

DocumentLoadFamily(String) Method

Loads an entire family and all its types/symbols into the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool LoadFamily(
    string filename
)
Public Function LoadFamily (
    filename As String
) As Boolean
public:
bool LoadFamily(
    String^ filename
)
member LoadFamily :
        filename : string -> bool

Parameters

filename String
The fully qualified filename of the Family file, usually ending in .rfa.

Return Value

Boolean
True if the entire family was loaded successfully into the project, otherwise False.
Exceptions
Exception | Condition
ArgumentException | Thrown when filename is or empty.
Remarks

Loading an entire family may take a considerable amount of time and memory. It is recommended that you use one of the LoadFamilySymbol() methods and only load those symbols that you need.

See Also

Reference

Document Class
LoadFamily Overload


Document.LoadFamily(Document, IFamilyLoadOptions) Method

DocumentLoadFamily(Document, IFamilyLoadOptions) Method

Loads the contents of this family document into another document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Family LoadFamily(
    Document targetDocument,
    IFamilyLoadOptions familyLoadOptions
)
Public Function LoadFamily (
    targetDocument As Document,
    familyLoadOptions As IFamilyLoadOptions
) As Family
public:
Family^ LoadFamily(
    Document^ targetDocument,
    IFamilyLoadOptions^ familyLoadOptions
)
member LoadFamily :
        targetDocument : Document *
        familyLoadOptions : IFamilyLoadOptions -> Family

Parameters

targetDocument Document
The target document which the family will be loaded into.
familyLoadOptions IFamilyLoadOptions
The interface implementation to use when responding to conflicts during the load operation.

Return Value

Family
Reference of the family in the target document.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument-"targetDocument" or "familyLoadOptions"-is .
InvalidOperationException | Thrown when the current document is not a family document, or when the target document is modifiable (e.g. there is an uncommitted transaction) or doesn't support load of this kind of families (e.g. loading a model family to detail family is disallowed), or the load was cancelled due to a conflict and a False return from one of the interface methods, or this document is currently in a read-only state.
ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.
Remarks
If you are reloading an edited family back into the source document from which it was extracted, use this overload. This is because this overload allows you to respond to possible conflicts due to families already being present in the target document. The Revit API offers one automatic overload: RevitUIFamilyLoadOptions, which will show the same prompts to the user as seen during an interactive load.
See Also

Reference

Document Class
LoadFamily Overload


Document.LoadFamily(String, Family) Method

DocumentLoadFamily(String, Family) Method

Loads an entire family and all its types/symbols into the document and provides a reference to the loaded family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool LoadFamily(
    string filename,
    out Family family
)
Public Function LoadFamily (
    filename As String,
    <OutAttribute> ByRef family As Family
) As Boolean
public:
bool LoadFamily(
    String^ filename,
    [OutAttribute] Family^% family
)
member LoadFamily :
        filename : string *
        family : Family byref -> bool

Parameters

filename String
The fully qualified filename of the Family file, usually ending in .rfa.
family Family
A reference to the family that was loaded if successful, otherwise .

Return Value

Boolean
True if the entire family was loaded successfully into the project, otherwise False.
Exceptions
Exception | Condition
ArgumentException | Thrown when filename is or empty.
Remarks

Loading an entire family may take a considerable amount of time and memory. It is recommended that you use one of the LoadFamilySymbol() methods and only load those symbols that you need.

Example
C#
VB
C++
F#
Copy
// Get the Revit library path as defined via the Options dialog - File Locations tab - Places button
string libraryPath = "";
application.Application.GetLibraryPaths().TryGetValue("Imperial Library", out libraryPath);

if (String.IsNullOrEmpty(libraryPath))
{
    libraryPath = "c:\\";   // If not have, use a default path.
}

// Allow the user to select a family file.
OpenFileDialog openFileDialog1 = new OpenFileDialog();
openFileDialog1.InitialDirectory = libraryPath;
openFileDialog1.Filter = "Family Files (*.rfa)|*.rfa";

// Load the family file using LoadFamily method and then give information.
if (DialogResult.OK == openFileDialog1.ShowDialog())
{
    Autodesk.Revit.DB.Family family = null;
    if (document.LoadFamily(openFileDialog1.FileName, out family))
    {
        String name = family.Name;
        Autodesk.Revit.UI.TaskDialog.Show("Revit","Family file has been loaded. Its name is " + name);
    }
    else
    {
        Autodesk.Revit.UI.TaskDialog.Show("Revit","Can't load the family file.");
    }
}
' Get the Revit library path as defined via the Options dialog - File Locations tab - Places button
Dim libraryPath As String = ""
application.Application.GetLibraryPaths().TryGetValue("Imperial Library", libraryPath)

If [String].IsNullOrEmpty(libraryPath) Then
    ' If not have, use a default path.
    libraryPath = "c:\"
End If

' Allow the user to select a family file.
Dim openFileDialog1 As New OpenFileDialog()
openFileDialog1.InitialDirectory = libraryPath
openFileDialog1.Filter = "Family Files (*.rfa)|*.rfa"

' Load the family file using LoadFamily method and then give information.
If DialogResult.OK = openFileDialog1.ShowDialog() Then
    Dim family As Autodesk.Revit.DB.Family = Nothing
    If document.LoadFamily(openFileDialog1.FileName, family) Then
        Dim name As [String] = family.Name
        UI.TaskDialog.Show("Revit", "Family file has been loaded. Its name is " & name)
    Else
        UI.TaskDialog.Show("Revit", "Can't load the family file.")
    End If
End If

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Document Class
LoadFamily Overload


Document.LoadFamily(String, IFamilyLoadOptions, Family) Method

DocumentLoadFamily(String, IFamilyLoadOptions, Family) Method

Loads an entire family and all its types/symbols into the document and provides a reference to the loaded family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool LoadFamily(
    string filename,
    IFamilyLoadOptions familyLoadOptions,
    out Family family
)
Public Function LoadFamily (
    filename As String,
    familyLoadOptions As IFamilyLoadOptions,
    <OutAttribute> ByRef family As Family
) As Boolean
public:
bool LoadFamily(
    String^ filename,
    IFamilyLoadOptions^ familyLoadOptions,
    [OutAttribute] Family^% family
)
member LoadFamily :
        filename : string *
        familyLoadOptions : IFamilyLoadOptions *
        family : Family byref -> bool

Parameters

filename String
The fully qualified filename of the Family file, usually ending in .rfa.
familyLoadOptions IFamilyLoadOptions
The interface implementation to use when loading a family into the document.
family Family
A reference to the family that was loaded if successful, otherwise Nothing.

Return Value

Boolean
True if the entire family was loaded successfully into the project, otherwise False.
Exceptions
Exception | Condition
ArgumentException | Thrown when filename is or empty.
ArgumentNullException | Thrown when the input argument "familyLoadOptions" is .
Remarks

Loading an entire family may take a considerable amount of time and memory. It is recommended that you use one of the LoadFamilySymbol() methods and only load those symbols that you need.

See Also

Reference

Document Class
LoadFamily Overload


Document.LoadFamilySymbol Method

DocumentLoadFamilySymbol Method

Loads only a specified family type/symbol from a family file into the document.
Overload List
 | Name | Description
Public method | LoadFamilySymbol(String, String) | Loads only a specified family type/symbol from a family file into the document.
Public method | LoadFamilySymbol(String, String, FamilySymbol) | Loads only the specified family type/symbol from a family file into the document and provides a reference to the loaded family symbol.
Public method | LoadFamilySymbol(String, String, IFamilyLoadOptions, FamilySymbol) | Loads only the specified family type/symbol from a family file into the document and provides a reference to the loaded family symbol.
Top
See Also

Reference

Document Class


Document.LoadFamilySymbol(String, String) Method

DocumentLoadFamilySymbol(String, String) Method

Loads only a specified family type/symbol from a family file into the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool LoadFamilySymbol(
    string filename,
    string name
)
Public Function LoadFamilySymbol (
    filename As String,
    name As String
) As Boolean
public:
bool LoadFamilySymbol(
    String^ filename,
    String^ name
)
member LoadFamilySymbol :
        filename : string *
        name : string -> bool

Parameters

filename String
The fully qualified filename of the Family file, usually ending in .rfa.
name String
The name of the type/symbol to be loaded, such as "W11x14".

Return Value

Boolean
True if the family type/symbol was loaded successfully into the project, otherwise False.
Exceptions
Exception | Condition
ArgumentException | Thrown when filename or name is or empty.
Remarks
This function supports loading of types/symbols stored in the family, or those available in the family Type Catalog file.
See Also

Reference

Document Class
LoadFamilySymbol Overload


Document.LoadFamilySymbol(String, String, FamilySymbol) Method

DocumentLoadFamilySymbol(String, String, FamilySymbol) Method

Loads only the specified family type/symbol from a family file into the document and provides a reference to the loaded family symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool LoadFamilySymbol(
    string filename,
    string name,
    out FamilySymbol symbol
)
Public Function LoadFamilySymbol (
    filename As String,
    name As String,
    <OutAttribute> ByRef symbol As FamilySymbol
) As Boolean
public:
bool LoadFamilySymbol(
    String^ filename,
    String^ name,
    [OutAttribute] FamilySymbol^% symbol
)
member LoadFamilySymbol :
        filename : string *
        name : string *
        symbol : FamilySymbol byref -> bool

Parameters

filename String
The fully qualified filename of the Family file, usually ending in .rfa.
name String
The name of the type/symbol to be loaded, such as "W11x14".
symbol FamilySymbol
A reference to the family symbol that was loaded if successful, otherwise .

Return Value

Boolean
True if the family type/symbol was loaded successfully into the project, otherwise False.
Exceptions
Exception | Condition
ArgumentException | Thrown when filename or name is or empty.
Remarks
This function supports loading of types/symbols stored in the family, or those available in the family Type Catalog file.
See Also

Reference

Document Class
LoadFamilySymbol Overload


Document.LoadFamilySymbol(String, String, IFamilyLoadOptions, FamilySymbol) Method

DocumentLoadFamilySymbol(String, String, IFamilyLoadOptions, FamilySymbol) Method

Loads only the specified family type/symbol from a family file into the document and provides a reference to the loaded family symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool LoadFamilySymbol(
    string filename,
    string name,
    IFamilyLoadOptions familyLoadOptions,
    out FamilySymbol symbol
)
Public Function LoadFamilySymbol (
    filename As String,
    name As String,
    familyLoadOptions As IFamilyLoadOptions,
    <OutAttribute> ByRef symbol As FamilySymbol
) As Boolean
public:
bool LoadFamilySymbol(
    String^ filename,
    String^ name,
    IFamilyLoadOptions^ familyLoadOptions,
    [OutAttribute] FamilySymbol^% symbol
)
member LoadFamilySymbol :
        filename : string *
        name : string *
        familyLoadOptions : IFamilyLoadOptions *
        symbol : FamilySymbol byref -> bool

Parameters

filename String
The fully qualified filename of the Family file, usually ending in .rfa.
name String
The name of the type/symbol to be loaded, such as "W11x14".
familyLoadOptions IFamilyLoadOptions
The interface implementation to use when loading a family into the document.
symbol FamilySymbol
A reference to the family symbol that was loaded if successful, otherwise Nothing.

Return Value

Boolean
True if the family type/symbol was loaded successfully into the project, otherwise False.
Exceptions
Exception | Condition
ArgumentException | Thrown when filename or name is or empty.
Remarks
This function supports loading of types/symbols stored in the family, or those available in the family Type Catalog file.
See Also

Reference

Document Class
LoadFamilySymbol Overload


Document.MakeTransientElements Method

DocumentMakeTransientElements Method

This method encapsulates the process of creating transient elements in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void MakeTransientElements(
    ITransientElementMaker maker
)
Public Sub MakeTransientElements (
    maker As ITransientElementMaker
)
public:
void MakeTransientElements(
    ITransientElementMaker^ maker
)
member MakeTransientElements :
        maker : ITransientElementMaker -> unit

Parameters

maker ITransientElementMaker
An instance of a class that implements the ITransientElementMaker interface. The maker will be called to create element(s) which would become transient.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This Document has an open editing transaction and is accepting changes. -or- This Document is read-only: It cannot be modified.
Remarks
The method establishes a context within which transient elements will be created and then invokes the given maker object to create the elements. For more information refer to the IsTransient method.
See Also

Reference

Document Class


Document.Paint Method

DocumentPaint Method

Overload List
Name | Description
Paint(ElementId, Face, ElementId) | Paint the element's face with specified material.
Paint(ElementId, Face, FamilyParameter) | Paint the element's face with specified material.
Top
See Also

Reference

Document Class


Document.Paint(ElementId, Face, ElementId) Method

DocumentPaint(ElementId, Face, ElementId) Method

Paint the element's face with specified material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Paint(
    ElementId elementId,
    Face face,
    ElementId materialId
)
Public Sub Paint (
    elementId As ElementId,
    face As Face,
    materialId As ElementId
)
public:
void Paint(
    ElementId^ elementId,
    Face^ face,
    ElementId^ materialId
)
member Paint :
        elementId : ElementId *
        face : Face *
        materialId : ElementId -> unit

Parameters

elementId ElementId
The element that the face belongs to.
face Face
The painted element's face.
materialId ElementId
The material to be painted on the face
Exceptions
Exception | Condition
ArgumentException | The element elementId does not exist in the document -or- The element materialId does not exist in the document -or- The face doesn't belong to the element -or- The materialId doesn't specify a material element. -or- The element's face cannot be painted.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Example
C#
VB
C++
F#
Copy
// Paint any unpainted faces of a given wall
public void PaintWallFaces(Wall wall, ElementId matId)
{
    Document doc = wall.Document;
    GeometryElement geometryElement = wall.get_Geometry(new Options());
    foreach (GeometryObject geometryObject in geometryElement)
    {
        if (geometryObject is Solid)
        {
            Solid solid = geometryObject as Solid;
            foreach (Face face in solid.Faces)
            {
                if (doc.IsPainted(wall.Id, face) == false)
                {
                    doc.Paint(wall.Id, face, matId);
                }
            }
        }
    }
}
' Paint any unpainted faces of a given wall
Public Sub PaintWallFaces(wall As Wall, matId As ElementId)
   Dim doc As Document = wall.Document
   Dim geometryElement As GeometryElement = wall.Geometry(New Options())
   For Each geometryObject As GeometryObject In geometryElement
      If TypeOf geometryObject Is Solid Then
         Dim solid As Solid = TryCast(geometryObject, Solid)
         For Each face As Face In solid.Faces
            If doc.IsPainted(wall.Id, face) = False Then
               doc.Paint(wall.Id, face, matId)
            End If
         Next
      End If
   Next
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

C#
VB
C++
F#
Copy
public void ApplyPaintByMaterial(Document document, Wall wall, Material material)
{
   // Before acquiring the geometry, make sure the detail level is set to 'Fine'
   Options geoOptions = new Options();
   geoOptions.DetailLevel = ViewDetailLevel.Fine;

   // Obtain geometry for the given Wall element
   GeometryElement geoElem = wall.get_Geometry(geoOptions);

   // Find a face on the wall
   Face wallFace = null;
   IEnumerator<GeometryObject> geoObjectItor = geoElem.GetEnumerator();
   while (geoObjectItor.MoveNext())
   {
      // need to find a solid first
      Solid theSolid = geoObjectItor.Current as Solid;
      if (null != theSolid)
      {
         // Examine faces of the solid to find one with at least
         // one region. Then take the geometric face of that region.
         foreach (Face face in theSolid.Faces)
         {
            if (face.HasRegions)
            {
               wallFace = face.GetRegions()[0];
               break;
            }
         }
      }
   }

   if (null == wallFace)
   {
      TaskDialog.Show("Failure", "Could not find a face to paint on the given wall.");
      return;
   }

   // Paint material to the wall face (modification must be inside a transaction)

   using (Transaction transaction = new Transaction(document, "Painting a wall"))
   {
      transaction.Start();
      document.Paint(wall.Id, wallFace, material.Id);
      transaction.Commit();
   }

   // For illustration purposes only, check if the painted material indeed got applied

   bool isPainted = document.IsPainted(wall.Id, wallFace);
   if (isPainted)
   {
      ElementId paintedMatId = document.GetPaintedMaterial(wall.Id, wallFace);
      if (paintedMatId == material.Id)
      {
         TaskDialog.Show("Painting material", "Wall painted successfully.");
      }
   }
}
Public Sub ApplyPaintByMaterial(document As Document, wall As Wall, material As Material)
    ' Before acquiring the geometry, make sure the detail level is set to 'Fine'
    Dim geoOptions As New Options()
    geoOptions.DetailLevel = ViewDetailLevel.Fine

    ' Obtain geometry for the given Wall element
    Dim geoElem As GeometryElement = wall.Geometry(geoOptions)

    ' Find a face on the wall
    Dim wallFace As Face = Nothing
    Dim geoObjectItor As IEnumerator(Of GeometryObject) = geoElem.GetEnumerator()
    While geoObjectItor.MoveNext()
        ' need to find a solid first
        Dim theSolid As Solid = TryCast(geoObjectItor.Current, Solid)
        If theSolid IsNot Nothing Then
            ' Examine faces of the solid to find one with at least
            ' one region. Then take the geometric face of that region.
            For Each face As Face In theSolid.Faces
                If face.HasRegions Then
                    wallFace = face.GetRegions()(0)
                    Exit For
                End If
            Next
        End If
    End While

    If wallFace Is Nothing Then
        TaskDialog.Show("Failure", "Could not find a face to paint on the given wall.")
        Return
    End If

    ' Paint material to the wall face (modification must be inside a transaction)

    Using transaction As New Transaction(document, "Painting a wall")
        transaction.Start()
        document.Paint(wall.Id, wallFace, material.Id)
        transaction.Commit()
    End Using

    ' For illustration purposes only, check if the painted material indeed got applied

    Dim isPainted As Boolean = document.IsPainted(wall.Id, wallFace)
    If isPainted Then
        Dim paintedMatId As ElementId = document.GetPaintedMaterial(wall.Id, wallFace)
        If paintedMatId = material.Id Then
            TaskDialog.Show("Painting material", "Wall painted successfully.")
        End If
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Document Class
Paint Overload


Document.Paint(ElementId, Face, FamilyParameter) Method

DocumentPaint(ElementId, Face, FamilyParameter) Method

Paint the element's face with specified material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Paint(
    ElementId elementId,
    Face face,
    FamilyParameter familyParameter
)
Public Sub Paint (
    elementId As ElementId,
    face As Face,
    familyParameter As FamilyParameter
)
public:
void Paint(
    ElementId^ elementId,
    Face^ face,
    FamilyParameter^ familyParameter
)
member Paint :
        elementId : ElementId *
        face : Face *
        familyParameter : FamilyParameter -> unit

Parameters

elementId ElementId
The element that the face belongs to.
face Face
The painted element's face.
familyParameter FamilyParameter
The family parameter associated with a material.
Exceptions
Exception | Condition
ArgumentException | The element elementId does not exist in the document. -or- The element materialId does not exist in the document. -or- The face doesn't belongs to the element. -or- The family parameter doesn't specify a material element. -or- The element's face cannot be painted.
ArgumentNullException | A non-optional argument was NULL
InvalidOperationException | This document is not modifiable. -or- This operation is valid only in family.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Example
C#
VB
C++
F#
Copy
public void ApplyPaintByMaterialParameter(Document document, Extrusion extrusion, Material material)
{
   Face geoFace = null;

   using (Transaction transaction = new Transaction(document, "Painting"))
   {
      transaction.Start();

      // create a new type and material parameter in the document.
      FamilyManager famMgr = document.FamilyManager;
      if (famMgr.Types.Size == 0)
      {
         FamilyType createdType = famMgr.NewType("New_type");
         famMgr.CurrentType = createdType;
      }

      FamilyParameter materialParam =
         famMgr.AddParameter("Material_Para", GroupTypeId.Materials, SpecTypeId.Reference.Material, true);

      famMgr.Set(materialParam, material.Id);

      // Before acquiring the geometry, make sure the detail level is set to 'Fine'
      Options geoOptions = new Options();
      geoOptions.DetailLevel = ViewDetailLevel.Fine;

      // Find the first geometry face of the given extrusion object
      GeometryElement geoElem = extrusion.get_Geometry(geoOptions);
      IEnumerator<GeometryObject> geoObjectItor = geoElem.GetEnumerator();
      while (geoObjectItor.MoveNext())
      {
         // need to find a solid first
         Solid theSolid = geoObjectItor.Current as Solid;
         if (null != theSolid)
         {
            foreach (Face face in theSolid.Faces)
            {
               geoFace = face;
               break;
            }
         }
      }

      if (null == geoFace)
      {
         TaskDialog.Show("Failure", "Could not find a face to paint.");
         transaction.RollBack();
         return;
      }

      // Paint a material family parameter to the extrusion face.
      document.Paint(extrusion.Id, geoFace, materialParam);
      transaction.Commit();
   }

   // For illustration purposes only, check if the painted material indeed got applied

   bool isPainted = document.IsPainted(extrusion.Id, geoFace);
   if (isPainted)
   {
      ElementId paintedMatId = document.GetPaintedMaterial(extrusion.Id, geoFace);
      if (paintedMatId == material.Id)
      {
         TaskDialog.Show("Painting material", "Face painted successfully.");
      }
   }
}
Public Sub ApplyPaintByMaterialParameter(document As Document, extrusion As Extrusion, material As Material)
    Dim geoFace As Face = Nothing

    Using transaction As New Transaction(document, "Painting")
        transaction.Start()

        ' create a new type and material parameter in the document.
        Dim famMgr As FamilyManager = document.FamilyManager
        If famMgr.Types.Size = 0 Then
            Dim createdType As FamilyType = famMgr.NewType("New_type")
            famMgr.CurrentType = createdType
        End If

    Dim materialParam As FamilyParameter = famMgr.AddParameter("Material_Para", GroupTypeId.Materials, SpecTypeId.Reference.Material, True)

    famMgr.[Set](materialParam, material.Id)

        ' Before acquiring the geometry, make sure the detail level is set to 'Fine'
        Dim geoOptions As New Options()
        geoOptions.DetailLevel = ViewDetailLevel.Fine

        ' Find the first geometry face of the given extrusion object
        Dim geoElem As GeometryElement = extrusion.Geometry(geoOptions)
        Dim geoObjectItor As IEnumerator(Of GeometryObject) = geoElem.GetEnumerator()
        While geoObjectItor.MoveNext()
            ' need to find a solid first
            Dim theSolid As Solid = TryCast(geoObjectItor.Current, Solid)
            If theSolid IsNot Nothing Then
                For Each face As Face In theSolid.Faces
                    geoFace = face
                    Exit For
                Next
            End If
        End While

        If geoFace Is Nothing Then
            TaskDialog.Show("Failure", "Could not find a face to paint.")
            transaction.RollBack()
            Return
        End If

        ' Paint a material family parameter to the extrusion face.
        document.Paint(extrusion.Id, geoFace, materialParam)
        transaction.Commit()
    End Using

    ' For illustration purposes only, check if the painted material indeed got applied

    Dim isPainted As Boolean = document.IsPainted(extrusion.Id, geoFace)
    If isPainted Then
        Dim paintedMatId As ElementId = document.GetPaintedMaterial(extrusion.Id, geoFace)
        If paintedMatId = material.Id Then
            TaskDialog.Show("Painting material", "Face painted successfully.")
        End If
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Document Class
Paint Overload


Document.PostFailure Method

DocumentPostFailure Method

Posts a failure to be displayed to the user at the end of transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FailureMessageKey PostFailure(
    FailureMessage failure
)
Public Function PostFailure (
    failure As FailureMessage
) As FailureMessageKey
public:
FailureMessageKey^ PostFailure(
    FailureMessage^ failure
)
member PostFailure :
        failure : FailureMessage -> FailureMessageKey

Parameters

failure FailureMessage
The failure to be posted.

Return Value

FailureMessageKey
A unique key that identifies posted failure message in a document. If exactly the same error is posted more than once, and not removed between the postings, returned key will be the same every time.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Document must be in state of accepting posted failures and the failures must be appropriate for that current state.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
If code inside transaction detects a problem that needs to be communicated to the user, it should report these conditions via this method. Failures will be validated and possibly resolved at the end of transaction. Warnings posted via this method will not be stored in the document after they are resolved. A unique key returned by postFailure can be stored for the lifetime of transaction and used to remove failure message if it is no longer relevant.
Example
C#
VB
C++
F#
Copy
// Execute function for an Updater triggered when new FamilyInstances are added
public void Execute(UpdaterData data)
{
   Document doc = data.GetDocument();
   Autodesk.Revit.ApplicationServices.Application app = doc.Application;
   foreach (ElementId id in data.GetModifiedElementIds())
   {
      AnalyticalMember fi = doc.GetElement(id) as AnalyticalMember;
      if (fi.StructuralRole == AnalyticalStructuralRole.StructuralRoleBeam)
      {
         if (fi.IsSingleCurve() == true)
         {
            Curve beamCurve = fi.GetCurve();
            // enforce beam length minimum of 12 inches
            if (beamCurve.Length < 12.0)
            {
               FailureMessage failMessage =
                     new FailureMessage(BuiltInFailures.CurveFailures.TooShort);
               failMessage.SetFailingElement(id);
               doc.PostFailure(failMessage);
            }
         }
      }
   }
}
' Execute function for an Updater triggered when new FamilyInstances are added
Public Sub Execute(data As UpdaterData) Implements IUpdater.Execute
   Dim doc As Document = data.GetDocument()
   Dim app As Autodesk.Revit.ApplicationServices.Application = doc.Application
   For Each id As ElementId In data.GetModifiedElementIds()
      Dim fi As FamilyInstance = TryCast(doc.GetElement(id), FamilyInstance)
      If fi.StructuralType = StructuralType.Beam Then
         Dim analyticalModel As Autodesk.Revit.DB.Structure.AnalyticalElement = Nothing
         Dim relManager As Autodesk.Revit.DB.Structure.AnalyticalToPhysicalAssociationManager = Autodesk.Revit.DB.Structure.AnalyticalToPhysicalAssociationManager.GetAnalyticalToPhysicalAssociationManager(doc)

         If (relManager Is Nothing) Then
            Exit Sub
         End If

         Dim counterpartId As ElementId = relManager.GetAssociatedElementId(fi.Id)
         If (counterpartId Is Nothing) Then
            Exit Sub
         End If

         analyticalModel = doc.GetElement(counterpartId)
         If analyticalModel.IsSingleCurve() = True Then
            Dim beamCurve As Curve = analyticalModel.GetCurve()
            ' enforce beam length minimum of 12 inches
            If beamCurve.Length < 12.0 Then
               Dim failMessage As New FailureMessage(BuiltInFailures.CurveFailures.TooShort)
               failMessage.SetFailingElement(id)
               doc.PostFailure(failMessage)
            End If
         End If
      End If
   Next
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Document Class


Document.Print Method

DocumentPrint Method

Prints a set of views.
Overload List
 | Name | Description
Public method | Print(ViewSet) | Prints a set of views with default view template and default print settings.
Public method | Print(ViewSet, View) | Prints a set of views with a specified view template and default print settings.
Public method | Print(ViewSet, Boolean) | Prints a set of views with default view template and default print settings.
Public method | Print(ViewSet, View, Boolean) | Prints a set of views with a specified view template and default print settings.
Top
See Also

Reference

Document Class


Document.Print(ViewSet) Method

DocumentPrint(ViewSet) Method

Prints a set of views with default view template and default print settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Print(
    ViewSet views
)
Public Sub Print (
    views As ViewSet
)
public:
void Print(
    ViewSet^ views
)
member Print :
        views : ViewSet -> unit

Parameters

views ViewSet
The set of views which need to be printed.
Exceptions
Exception | Condition
InvalidOperationException | Thrown when printing is not allowed in the current application mode. Or when at least one view from the view set is not a printable view.
ArgumentNullException | Thrown when the view set to be printed is .
ArgumentException | Thrown when the view set contains a element.
InvalidOperationException | Thrown when at least one view from the view set could not be printed.
OperationCanceledException | Thrown when print is cancelled by event handler.
Remarks
If one view in the set can not be printed successfully then an exception will be thrown.
See Also

Reference

Document Class
Print Overload


Document.Print(ViewSet, View) Method

DocumentPrint(ViewSet, View) Method

Prints a set of views with a specified view template and default print settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Print(
    ViewSet views,
    View viewTemplate
)
Public Sub Print (
    views As ViewSet,
    viewTemplate As View
)
public:
void Print(
    ViewSet^ views,
    View^ viewTemplate
)
member Print :
        views : ViewSet *
        viewTemplate : View -> unit

Parameters

views ViewSet
The set of views which need to be printed.
viewTemplate View
The view template which apply to the set of views.
Exceptions
Exception | Condition
InvalidOperationException | Thrown when printing is not allowed in the current application mode. Or when at least one view from the view set is not a printable view.
ArgumentNullException | Thrown when the view set to be printed is .
ArgumentException | Thrown when the view set contains a element.
ApplicationException | Thrown when at least one view from the view set could not be printed.
OperationCanceledException | Thrown when print is cancelled by event handler.
Remarks
If one view in the set can not be printed successfully then an exception will be thrown.
See Also

Reference

Document Class
Print Overload


Document.Print(ViewSet, Boolean) Method

DocumentPrint(ViewSet, Boolean) Method

Prints a set of views with default view template and default print settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Print(
    ViewSet views,
    bool useCurrentPrintSettings
)
Public Sub Print (
    views As ViewSet,
    useCurrentPrintSettings As Boolean
)
public:
void Print(
    ViewSet^ views,
    bool useCurrentPrintSettings
)
member Print :
        views : ViewSet *
        useCurrentPrintSettings : bool -> unit

Parameters

views ViewSet
The set of views which need to be printed.
useCurrentPrintSettings Boolean
If true, print the view with the current print setting, otherwise with the print setting of the document of the view.
Exceptions
Exception | Condition
InvalidOperationException | Thrown when printing is not allowed in the current application mode. Or when at least one view from the view set is not a printable view.
ArgumentNullException | Thrown when the view set to be printed is .
ArgumentException | Thrown when the view set contains a element.
ApplicationException | Thrown when at least one view from the view set could not be printed.
OperationCanceledException | Thrown when print is cancelled by event handler.
Remarks
If one view in the set can not be printed successfully then an exception will be thrown.
See Also

Reference

Document Class
Print Overload


Document.Print(ViewSet, View, Boolean) Method

DocumentPrint(ViewSet, View, Boolean) Method

Prints a set of views with a specified view template and default print settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Print(
    ViewSet views,
    View viewTemplate,
    bool useCurrentPrintSettings
)
Public Sub Print (
    views As ViewSet,
    viewTemplate As View,
    useCurrentPrintSettings As Boolean
)
public:
void Print(
    ViewSet^ views,
    View^ viewTemplate,
    bool useCurrentPrintSettings
)
member Print :
        views : ViewSet *
        viewTemplate : View *
        useCurrentPrintSettings : bool -> unit

Parameters

views ViewSet
The set of views which need to be printed.
viewTemplate View
The view template which apply to the set of views.
useCurrentPrintSettings Boolean
If true, print the view with the current print setting, otherwise with the print setting of the document of the view.
Exceptions
Exception | Condition
InvalidOperationException | Thrown when printing is not allowed in the current application mode. Or when at least one view from the view set is not a printable view.
ArgumentNullException | Thrown when the view set to be printed is .
ArgumentException | Thrown when the view set contains a element.
ApplicationException | Thrown when at least one view from the view set could not be printed.
OperationCanceledException | Thrown when print is cancelled by event handler.
Remarks
If one view in the set can not be printed successfully then an exception will be thrown.
See Also

Reference

Document Class
Print Overload


Document.PublishCoordinates Method

DocumentPublishCoordinates Method

Publish coordinates to the specified ProjectLocation of the link instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void PublishCoordinates(
    LinkElementId locationId
)
Public Sub PublishCoordinates (
    locationId As LinkElementId
)
public:
void PublishCoordinates(
    LinkElementId^ locationId
)
member PublishCoordinates :
        locationId : LinkElementId -> unit

Parameters

locationId LinkElementId
The ElementId of the ProjectLocation in the linked document, to which the transform would be published to.
Exceptions
Exception | Condition
ArgumentException | locationId does not contain a valid linkInstanceId. -or- Only RevitLinkInstance is supported through API for publish coordinates.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This Document is not a project document. -or- This Document is in an edit mode. -or- Attempting to publish shared coordinates to a cloud based link which is treated as read-only. -or- Failed to publish coordinates to the specified ProjectLocation of the link instance.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks

The host project's True North and shared origin are recorded in the linked project, based on the current position of the linked instance. This location is now named in both the host project and the linked project. More than one position of the link can be recorded.

When you publish shared coordinates from a host Revit project to a linked DWG, this changes the linked DWG. The origin of the host Revit project's shared coordinate system becomes the origin of a new User Coordinate System (UCS) in the DWG file. The Y axis of the new UCS corresponds to the host project's True North. You can name the UCS when you publish coordinates. It is not recommended that you change this name after publishing coordinates.

Note: Currently, only RevitLinkInstance is supported. DWG link instance, which is ImportInstance is not supported now. Passing in an locationId that points to an ImportInstance would result an ArgumentException.

See Also

Reference

Document Class


Document.Regenerate Method

DocumentRegenerate Method

Updates the elements in the Revit document to reflect all changes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Regenerate()
Public Sub Regenerate
public:
void Regenerate()
member Regenerate : unit -> unit
Exceptions
Exception | Condition
RegenerationFailedException Thrown when the operation fails.
  • If regeneration fails, there is posted error of severity DocumentCorruption that will be delivered to the end user at the end of transaction explaining what specifically has happened.
  • If regeneration has failed, document is corrupted and even reading from it is illegal.
  • Code that called regeneration and got this exception should not catch and ignore it - instead, it should do nothing but internal cleanup and return control to the owner of currently active transaction/subtransaction, which must be aborted.
InvalidOperationException | Modification of the document is forbidden. Typically, this is because there is no open transaction; consult documentation for Document.IsModified for other possible causes.
Remarks
Use this method to force update to the document after a group of changes. Note that when a transaction is committed there is an automatic call to regenerate the document.
Example
C#
VB
C++
F#
Copy
FamilyInstance instance = doc.Create.NewFamilyInstance(new XYZ(15, 20, 0), familySymbol, StructuralType.NonStructural);
FamilyInstance instance2 = doc.Create.NewFamilyInstance(new XYZ(25, 30, 0), familySymbol, StructuralType.NonStructural);
// faster to create multiple instances without calling Regenerate after each one

LocationPoint point = instance.Location as LocationPoint;
// this data is incorrect because the new geometry has not yet been regenerated

doc.Regenerate();
point = instance.Location as LocationPoint;
// now it is correct
Dim instance As FamilyInstance = doc.Create.NewFamilyInstance(New XYZ(15, 20, 0), familySymbol, StructuralType.NonStructural)
Dim instance2 As FamilyInstance = doc.Create.NewFamilyInstance(New XYZ(25, 30, 0), familySymbol, StructuralType.NonStructural)
' faster to create multiple instances without calling Regenerate after each one

Dim point As LocationPoint = TryCast(instance.Location, LocationPoint)
' this data is incorrect because the new geometry has not yet been regenerated

doc.Regenerate()
point = TryCast(instance.Location, LocationPoint)
' now it is correct

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Document Class


Document.ReloadLatest Method

DocumentReloadLatest Method

Fetches changes from central (due to one or more synchronizations with central) and merges them into the current session.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ReloadLatest(
    ReloadLatestOptions reloadOptions
)
Public Sub ReloadLatest (
    reloadOptions As ReloadLatestOptions
)
public:
void ReloadLatest(
    ReloadLatestOptions^ reloadOptions
)
member ReloadLatest :
        reloadOptions : ReloadLatestOptions -> unit

Parameters

reloadOptions ReloadLatestOptions
Various options to control behavior of reloadLatest.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
CentralFileCommunicationException | The file-based central model could not be reached, because e.g. the network is down or the file server is down.
CentralModelAccessDeniedException | Access to the central model was denied due to lack of access privileges. -or- Access to the central model was denied. A possible reason is because the model was under maintenance.
CentralModelContentionException | The central model is locked by another client.
CentralModelException | Username does not match the one used to create the local file. -or- Revit could not save all of the worksets that have been changed. Try again. -or- The central model has been replaced by a local model. -or- Local incompatible because it was closed without saving after synchronizing with central. -or- The central model is missing. -or- The central model is incompatible. -or- The central model is corrupt or not an RVT file. -or- The central model was rolled back. -or- The central model's elements have been relinquished -or- The central model is overritten by other user. -or- An internal error happened on the central model, please contact the server administrator.
FileNotFoundException | Cannot access the local file.
InvalidOperationException | This Document is not a primary document, it is a linked document. -or- This Document is not a local model: it is not workshared or is central. -or- This Document is read-only: It cannot be modified. -or- This Document has an open editing transaction and is accepting changes. -or- This Document is not a project document. -or- This Document is in an edit mode. -or- This Document is a local file that is not owned by the current user, who therefore is not allowed to modify it. -or- Operation is not permitted when there is any open sub-transaction, transaction, or transaction group.
OperationCanceledException | Reload Latest was canceled by the user or by an API event callback.
RevitServerCommunicationException | The server-based central model could not be accessed because of a network communication error.
RevitServerInternalException | An internal error happened on the server, please contact the server administrator.
RevitServerUnauthenticatedUserException | User is not signed in with Autodesk id.
RevitServerUnauthorizedException | User is not authorized to access the specified A360 project.
Remarks
After this call finishes, use hasAllChangesFromCentral to confirm that there were no Synchronizations with Central performed during execution of ReloadLatest.
Example
C#
VB
C++
F#
Copy
public static void ReloadLatestWithMessage(Document doc)
{
    // Tell user what we're doing
    TaskDialog td = new TaskDialog("Alert");
    td.MainInstruction = "Application 'Automatic element creator' needs to reload changes from central in order to proceed.";
    td.MainContent = "This will update your local with all changes currently in the central model.  This operation " +
                     "may take some time depending on the number of changes available on the central.";
    td.CommonButtons = TaskDialogCommonButtons.Ok | TaskDialogCommonButtons.Cancel;

    TaskDialogResult result = td.Show();

    if (result == TaskDialogResult.Ok)
    {
        // There are no currently customizable user options for ReloadLatest.
        doc.ReloadLatest(new ReloadLatestOptions());
        TaskDialog.Show("Proceeding...", "Reload operation completed, proceeding with updates.");
    }
    else
    {
        TaskDialog.Show("Canceled.", "Reload operation canceled, so changes will not be made.  Return to this command later when ready to reload.");
    }
}
Public Shared Sub ReloadLatestWithMessage(doc As Document)
    ' Tell user what we're doing
    Dim td As New TaskDialog("Alert")
    td.MainInstruction = "Application 'Automatic element creator' needs to reload changes from central in order to proceed."
    td.MainContent = "This will update your local with all changes currently in the central model.  This operation " + "may take some time depending on the number of changes available on the central."
    td.CommonButtons = TaskDialogCommonButtons.Ok Or TaskDialogCommonButtons.Cancel

    Dim result As TaskDialogResult = td.Show()

    If result = TaskDialogResult.Ok Then
        ' There are no currently customizable user options for ReloadLatest.
        doc.ReloadLatest(New ReloadLatestOptions())
        TaskDialog.Show("Proceeding...", "Reload operation completed, proceeding with updates.")
    Else
        TaskDialog.Show("Canceled.", "Reload operation canceled, so changes will not be made.  Return to this command later when ready to reload.")
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Document Class


Document.RemovePaint Method

DocumentRemovePaint Method

Remove the material painted on the element's face. If the face is currently not painted,it will do nothing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemovePaint(
    ElementId elementId,
    Face face
)
Public Sub RemovePaint (
    elementId As ElementId,
    face As Face
)
public:
void RemovePaint(
    ElementId^ elementId,
    Face^ face
)
member RemovePaint :
        elementId : ElementId *
        face : Face -> unit

Parameters

elementId ElementId
The element that the painted face belongs to.
face Face
The painted element's face.
Exceptions
Exception | Condition
ArgumentException | The element elementId does not exist in the document -or- The face doesn't belong to the element
ArgumentNullException | A non-optional argument was null
See Also

Reference

Document Class


Document.ResetSharedCoordinates Method

DocumentResetSharedCoordinates Method

Reset shared coordinates for the host model/file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetSharedCoordinates()
Public Sub ResetSharedCoordinates
public:
void ResetSharedCoordinates()
member ResetSharedCoordinates : unit -> unit
Exceptions
Exception | Condition
InvalidOperationException | This Document is not a primary document, it is a linked document. -or- This Document is not a project document. -or- This Document is in an edit mode.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
When you reset shared coordinates, the shared coordinates of the host model will be erased. The shared relationship with all the linked models will be eliminated. Survey point will be reset back to startup location, where it coincides with the Internal Origin. The rotation angle between Project North and True North will be reset back to 0.
See Also

Reference

Document Class


Document.Save Method

DocumentSave Method

Overload List
 | Name | Description
Public method | Save | Saves the document.
Public method | Save(SaveOptions) | Saves the document.
Top
See Also

Reference

Document Class


Document.Save Method

DocumentSave Method

Saves the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Save()
Public Sub Save
public:
void Save()
member Save : unit -> unit
Exceptions
Exception | Condition
CentralModelException | Central model is missing. -or- Central model is incompatible. -or- The central model was saved in a different version of Revit. -or- Revit encountered errors while saving to the new central model. Resave again as a new central model. -or- Incompatible servers for external services. -or- Username does not match the one used to create the local file. -or- Revit could not save all of the worksets that have been changed. Try again.
ForbiddenForDynamicUpdateException | Save may not be called during dynamic update.
InsufficientResourcesException | This computer does not have enough memory, disk space, or other necessary resource to save the model.
InvalidOperationException | This Document is not a primary document, it is a linked document. -or- Save is temporarily disabled. -or- Saving is not allowed in the current application mode. -or- File path must be already set to be able to save the document.It needs to be first saved using the SaveAs method instead. -or- The file is read-only, can not be saved. -or- Operation is not permitted when there is any open sub-transaction, transaction, or transaction group. -or- Saving failed.
OperationCanceledException | Saving was canceled by the user or by an API event callback.
OutdatedDirectlyOpenedCentralException | Other users have modified the central model while you had it opened. Resave your document as a local file and then synchronize with central again.
Remarks

If the document was created in this current session and has not been saved to a file yet, it needs to be first saved using the SaveAs method instead.

This method may not be called unless all transactions, sub-transactions, and transaction groups that were opened by the API code were closed. That also implies that this method cannot be called during dynamic updates. Event handlers are not allowed to save document that are currently in modifiable state.

See Also

Reference

Document Class
Save Overload


Document.Save(SaveOptions) Method

DocumentSave(SaveOptions) Method

Saves the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Save(
    SaveOptions options
)
Public Sub Save (
    options As SaveOptions
)
public:
void Save(
    SaveOptions^ options
)
member Save :
        options : SaveOptions -> unit

Parameters

options SaveOptions
Options to control the Save operation.
Exceptions
Exception | Condition
ArgumentException | options.PreviewViewId is not valid for generation of a preview.
ArgumentNullException | A non-optional argument was null
CentralModelException | Central model is missing. -or- Central model is incompatible. -or- The central model was saved in a different version of Revit. -or- Revit encountered errors while saving to the new central model. Resave again as a new central model. -or- Incompatible servers for external services. -or- Username does not match the one used to create the local file. -or- Revit could not save all of the worksets that have been changed. Try again.
ForbiddenForDynamicUpdateException | Save may not be called during dynamic update.
InsufficientResourcesException | This computer does not have enough memory, disk space, or other necessary resource to save the model.
InvalidOperationException | This Document is not a primary document, it is a linked document. -or- Save is temporarily disabled. -or- Saving is not allowed in the current application mode. -or- File path must be already set to be able to save the document.It needs to be first saved using the SaveAs method instead. -or- The file is read-only, can not be saved. -or- Operation is not permitted when there is any open sub-transaction, transaction, or transaction group. -or- Saving failed.
OperationCanceledException | Saving was canceled by the user or by an API event callback.
OutdatedDirectlyOpenedCentralException | Other users have modified the central model while you had it opened. Resave your document as a local file and then synchronize with central again.
Remarks

If the document was created in this current session and has not been saved to a file yet, it needs to be first saved using the SaveAs method instead.

This method may not be called unless all transactions, sub-transactions, and transaction groups that were opened by the API code were closed. That also implies that this method cannot be called during dynamic updates. Event handlers are not allowed to save document that are currently in modifiable state.

See Also

Reference

Document Class
Save Overload


Document.SaveAs Method

DocumentSaveAs Method

Overload List
 | Name | Description
Public method | SaveAs(String) | Saves the document to a given file path.
Public method | SaveAs(ModelPath, SaveAsOptions) | Saves the document to a given path.
 | SaveAs(String, SaveAsOptions) | Saves the document to a given file path.
Top
See Also

Reference

Document Class


Document.SaveAs(String) Method

DocumentSaveAs(String) Method

Saves the document to a given file path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SaveAs(
    string filepath
)
Public Sub SaveAs (
    filepath As String
)
public:
void SaveAs(
    String^ filepath
)
member SaveAs :
        filepath : string -> unit

Parameters

filepath String
File name and path to be saved as. Either a relative or absolute path can be provided.
Exceptions
Exception | Condition
ArgumentException | filepath is an empty string. -or- The filepath is not a valid file path.
ArgumentNullException | A non-optional argument was null
CentralModelException | Central model is missing. -or- Central model is incompatible. -or- The central model was saved in a different version of Revit. -or- Revit encountered errors while saving to the new central model. Resave again as a new central model. -or- Incompatible servers for external services. -or- Username does not match the one used to create the local file. -or- Revit could not save all of the worksets that have been changed. Try again.
FileAccessException | The file at the given path location could not be accessed or saved.
FileNotFoundException | The given file, path or network location could not be found during save.
ForbiddenForDynamicUpdateException | SaveAs may not be called during dynamic update.
InsufficientResourcesException | This computer does not have enough memory, disk space, or other necessary resource to save the model.
InvalidOperationException | This Document is not a primary document, it is a linked document. -or- SaveAs is temporarily disabled. -or- There is an existing file at filepath. -or- Saving is not allowed in the current application mode. -or- The document just had worksharing enabled or was opened detached, so SaveAsOptions must be passed in SaveAs with WorksharingSaveAsOptions.SaveAsCentral set to true. -or- Operation is not permitted when there is any open sub-transaction, transaction, or transaction group. -or- Saving failed.
OperationCanceledException | Saving was canceled by the user or by an API event callback.
OutdatedDirectlyOpenedCentralException | Other users have modified the central model while you had it opened. Resave your document as a local file and then synchronize with central again.
Remarks
The document's title in Revit's title bar will be updated automatically to reflect the file's new name.
See Also

Reference

Document Class
SaveAs Overload


Document.SaveAs(ModelPath, SaveAsOptions) Method

DocumentSaveAs(ModelPath, SaveAsOptions) Method

Saves the document to a given path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SaveAs(
    ModelPath path,
    SaveAsOptions options
)
Public Sub SaveAs (
    path As ModelPath,
    options As SaveAsOptions
)
public:
void SaveAs(
    ModelPath^ path,
    SaveAsOptions^ options
)
member SaveAs :
        path : ModelPath *
        options : SaveAsOptions -> unit

Parameters

path ModelPath
Name and path to be saved as. For a file path, either a relative or absolute path can be provided.
options SaveAsOptions
Options to govern the SaveAs operation.
Exceptions
Exception | Condition
ArgumentException | The path is empty. -or- The specified filepath is invalid. -or- options.PreviewViewId is not valid for generation of a preview. -or- The document is not workshared, so no WorksharingSaveAsOptions are allowed to be set for SaveAs. -or- The document just had worksharing enabled or was opened detached, so WorksharingSaveAsOptions.SaveAsCentral must be set to true for SaveAs. -or- Revit cannot clear the transmitted flag. This is not a transmitted document.
ArgumentNullException | A non-optional argument was null
CentralModelAccessDeniedException | Access to the central model was denied. A possible reason is because the model was under maintenance.
CentralModelContentionException | The central model is being accessed by another client.
CentralModelException | The central model is overwritten by other user. -or- The central model is missing. -or- The central model is incompatible. -or- Your data or permissions saving is aborted by another user. -or- The central model was saved in a different version of Revit. -or- Revit encountered errors while saving to the new central model. Resave again as a new central model. -or- Incompatible servers for external services. -or- Overwrite old-version model is not supported for server-based. -or- An internal error happened on the central model, please contact the server administrator. -or- Username does not match the one used to create the local file. -or- Revit could not save all of the worksets that have been changed. Try again.
FileAccessException | The file at the given path location could not be accessed or saved.
FileNotFoundException | The given file, path or network location could not be found during save.
ForbiddenForDynamicUpdateException | SaveAs may not be called during dynamic update.
InsufficientResourcesException | This computer does not have enough memory, disk space, or other necessary resource to save the model.
InvalidOperationException | This Document is not a primary document, it is a linked document. -or- SaveAs is temporarily disabled. -or- options.overwriteExistingFile is 'false' but there is an existing file at path. -or- options.overwriteExistingFile is 'true' but the target file at path is read only. -or- There is already a central at path; Revit Server does not allow overwrite. -or- Revit Server only supports RVT model. -or- Saving is not allowed in the current application mode. -or- Operation is not permitted when there is any open sub-transaction, transaction, or transaction group. -or- Saving failed. -or- The file path is invalid.
OperationCanceledException | Saving was canceled by the user or by an API event callback.
OutdatedDirectlyOpenedCentralException | Other users have modified the central model while you had it opened. Resave your document as a local file and then synchronize with central again.
RevitServerCommunicationException | The server-based central model could not be accessed because of a network communication error.
RevitServerInternalException | The disk space is running low on server, please contact the server administrator. -or- An internal error happened on the server, please contact the server administrator.
Remarks

This method may not be called unless all transactions, sub-transactions, and transaction groups that were opened by the API code were closed. That also implies that this method cannot be called during dynamic updates. Event handlers are not allowed to save document that are currently in modifiable state.

If options.rename is true, then the document's title in Revit's title bar will be updated automatically to reflect the file's new name.

See Also

Reference

Document Class
SaveAs Overload


Document.SaveAs(String, SaveAsOptions) Method

DocumentSaveAs(String, SaveAsOptions) Method

Saves the document to a given file path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SaveAs(
    string filepath,
    SaveAsOptions options
)
Public Sub SaveAs (
    filepath As String,
    options As SaveAsOptions
)
public:
void SaveAs(
    String^ filepath,
    SaveAsOptions^ options
)
member SaveAs :
        filepath : string *
        options : SaveAsOptions -> unit

Parameters

filepath String
File name and path to be saved as. Either a relative or absolute path can be provided.
options SaveAsOptions
Options to govern the SaveAs operation.
Exceptions
Exception | Condition
ArgumentException | filepath is an empty string. -or- The specified filepath is invalid. -or- options.PreviewViewId is not valid for generation of a preview. -or- The document is not workshared, so no WorksharingSaveAsOptions are allowed to be set for SaveAs. -or- The document just had worksharing enabled or was opened detached, so WorksharingSaveAsOptions.SaveAsCentral must be set to true for SaveAs. -or- Revit cannot clear the transmitted flag. This is not a transmitted document.
ArgumentNullException | A non-optional argument was null
CentralModelException | Central model is missing. -or- Central model is incompatible. -or- The central model was saved in a different version of Revit. -or- Revit encountered errors while saving to the new central model. Resave again as a new central model. -or- Incompatible servers for external services. -or- Username does not match the one used to create the local file. -or- Revit could not save all of the worksets that have been changed. Try again.
FileAccessException | The file at the given path location could not be accessed or saved.
FileNotFoundException | The given file, path or network location could not be found during save.
ForbiddenForDynamicUpdateException | SaveAs may not be called during dynamic update.
InsufficientResourcesException | This computer does not have enough memory, disk space, or other necessary resource to save the model.
InvalidOperationException | This Document is not a primary document, it is a linked document. -or- SaveAs is temporarily disabled. -or- options.overwriteExistingFile is 'false' but there is an existing file at filepath. -or- options.overwriteExistingFile is 'true' but the target file at filepath is read only. -or- Saving is not allowed in the current application mode. -or- Operation is not permitted when there is any open sub-transaction, transaction, or transaction group. -or- Revit cannot clear the transmitted flag. This is not a transmitted document. -or- Saving failed.
OperationCanceledException | Saving was canceled by the user or by an API event callback.
OutdatedDirectlyOpenedCentralException | Other users have modified the central model while you had it opened. Resave your document as a local file and then synchronize with central again.
Remarks

This method may not be called unless all transactions, sub-transactions, and transaction groups that were opened by the API code were closed. That also implies that this method cannot be called during dynamic updates. Event handlers are not allowed to save document that are currently in modifiable state.

If options.rename is true, then the document's title in Revit's title bar will be updated automatically to reflect the file's new name.

Example
C#
VB
C++
F#
Copy
// Get the document's preview settings
DocumentPreviewSettings settings = document.GetDocumentPreviewSettings();

// Find a candidate plan view
FilteredElementCollector collector = new FilteredElementCollector(document);
collector.OfClass(typeof(ViewPlan));

Func<ViewPlan, bool> isValidForPreview = v => settings.IsViewIdValidForPreview(v.Id);

ViewPlan viewForPreview = collector.OfType<ViewPlan>().First<ViewPlan>(isValidForPreview);

// Save the document
SaveAsOptions options = new SaveAsOptions();
options.PreviewViewId = viewForPreview.Id;

document.SaveAs(@"c:\renamed_family.rfa", options);
' Get the document's preview settings
Dim settings As DocumentPreviewSettings = document.GetDocumentPreviewSettings()

' Find a candidate plan view
Dim collector As New FilteredElementCollector(document)
collector.OfClass(GetType(ViewPlan))

Dim isValidForPreview As Func(Of ViewPlan, Boolean) = Function(v) settings.IsViewIdValidForPreview(v.Id)

Dim viewForPreview As ViewPlan = collector.OfType(Of ViewPlan)().First(isValidForPreview)

' Save the document
Dim options As New SaveAsOptions()
options.PreviewViewId = viewForPreview.Id

document.SaveAs("c:\renamed_family.rfa", options)

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Document Class
SaveAs Overload


Document.SaveAsCloudModel Method

DocumentSaveAsCloudModel Method

Saves current non-workshared or workshared model as a cloud model or workshared cloud model in BIM 360 Docs or Autodesk Docs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SaveAsCloudModel(
    Guid accountId,
    Guid projectId,
    string folderId,
    string modelName
)
Public Sub SaveAsCloudModel (
    accountId As Guid,
    projectId As Guid,
    folderId As String,
    modelName As String
)
public:
void SaveAsCloudModel(
    Guid accountId,
    Guid projectId,
    String^ folderId,
    String^ modelName
)
member SaveAsCloudModel :
        accountId : Guid *
        projectId : Guid *
        folderId : string *
        modelName : string -> unit

Parameters

accountId Guid
The BIM 360 Docs or Autodesk Docs account Id. You can use one of the following methods to get this Id:
  • If you get the hub Id with Forge Data Management API, remove the prefix "b." of the Id string and convert the rest to a Guid.
  • If you get the account Id with Forge BIM 360 Docs or Autodesk Docs API, just convert the Id string to a Guid.
projectId Guid
The BIM 360 Docs or Autodesk Docs project Id. You can use one of the following methods to get this Id:
  • If you get the project Id with Forge Data Management API, remove the prefix "b." of the Id string and convert the rest to a Guid.
  • If you get the project Id with Forge BIM 360 Docs or Autodesk Docs API, just convert the Id string to a Guid.
folderId String
Folder identity in BIM 360 Docs or Autodesk Docs to save the model. You can use one of the following methods to get this Id:
  • The folder Id string from Forge Data Management API.
  • The folder Id string from Forge BIM 360 Docs or Autodesk Docs API.
modelName String
Model name in BIM 360 Docs or Autodesk Docs to save the model.
Exceptions
Exception | Condition
ArgumentException | folderId is an empty string. -or- modelName is an empty string. -or- The input file name "modelName" does not represent a valid file name. -or- Thrown when the input BIM 360 Docs or Autodesk Docs account Id or project Id is invalid or unmatched.
ArgumentNullException | A non-optional argument was null
ForbiddenForDynamicUpdateException | SaveAs may not be called during dynamic update.
InvalidOperationException | Saving is not allowed in the current application mode. -or- This Document is not a project document. -or- This Document is in an edit mode. -or- This Document is not a primary document, it is a linked document. -or- SaveAs is temporarily disabled. -or- This Document is a cloud model, cannot be saved as a cloud model. -or- There is a transaction phase left open (such as a transaction, sub-transaction of transaction group) at the time of invoking this method.
RevitServerCommunicationException | Could be for any of the reasons related to network.
RevitServerInternalException | Could be for any of the reasons that saveAs fails with RevitServerInternalException.
RevitServerModelAlreadyExistsException | Failed due to there is a model with the same name already exists at the specified location.
RevitServerModelNameBreaksConventionException | Failed due to the model name is breaking project naming convention.
RevitServerUnauthenticatedUserException | User is not signed in with Autodesk id.
RevitServerUnauthorizedException | You don't have the entitlement to perform the operation to this this Document. -or- User is not authorized to access the specified cloud project.
Remarks

Assumes that user is currently signed in BIM 360 Docs or Autodesk Docs and has access to Autodesk cloud services. This operation will create a model on cloud and then create a local cache of the cloud model. This method cannot be used when current document is already in cloud.

You can use one of the following methods to save a local model as a workshared cloud model in BIM 360 Docs or Autodesk Docs.

  • If the local model is a workshared model, then it will be a workshared cloud model after you use this method successfully.
  • If the local model is a non-workshared model, you can enable the workset with EnableWorksharing(String, String) and then save as a workshared cloud model.
  • If the local model is a non-workshared model, and you have already saved it as a non-workshared cloud model in BIM 360 Docs or Autodesk Docs, you can still enable the workset with EnableCloudWorksharing to convert it to a workshared cloud model.

You cannot save a local workshared model as a non-workshared cloud model in BIM 360 Docs or Autodesk Docs.

See Also

Reference

Document Class


Document.SaveCloudModel Method

DocumentSaveCloudModel Method

Saves cloud model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SaveCloudModel()
Public Sub SaveCloudModel
public:
void SaveCloudModel()
member SaveCloudModel : unit -> unit
Exceptions
Exception | Condition
CentralModelAccessDeniedException | Could be for any of the reasons that related to access to the cloud model.
CentralModelContentionException | The central model is locked by another client.
CentralModelException | Could be for any of the reasons that fails with CentralModelException, for example, a central model with that name is already associated to the specified cloud project.
FileNotFoundException | Cannot access the local file.
InvalidOperationException | This Document is not a primary document, it is a linked document. -or- This Document is read-only: It cannot be modified. -or- This Document has an open editing transaction and is accepting changes. -or- This Document is not a project document. -or- This Document is in an edit mode. -or- Saving is not allowed in the current application mode. -or- This Document does not have a central location: Worksharing needs to be enabled and central model saved. -or- The file is read-only, can not be saved. -or- This Document is a not cloud model, cannot execute this operation. -or- This Document is a workshared document. -or- Operation is not permitted when there is any open sub-transaction, transaction, or transaction group.
OperationCanceledException | Synchronize With Central was canceled by the user or by an API event callback.
RevitServerCommunicationException | Could be for any of the reasons related to network.
RevitServerInternalException | Could be for any of the reasons that save fails with RevitServerInternalException.
RevitServerUnauthenticatedUserException | User is not signed in with Autodesk id.
RevitServerUnauthorizedException | User is not authorized to access the specified cloud project.
See Also

Reference

Document Class


Document.SaveToProjectAsImage Method

DocumentSaveToProjectAsImage Method

Creates an image view from the currently active view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId SaveToProjectAsImage(
    ImageExportOptions options
)
Public Function SaveToProjectAsImage (
    options As ImageExportOptions
) As ElementId
public:
ElementId^ SaveToProjectAsImage(
    ImageExportOptions^ options
)
member SaveToProjectAsImage :
        options : ImageExportOptions -> ElementId

Parameters

options ImageExportOptions
The options which govern the image creation.

Return Value

ElementId
Id of the newly created view if the operation succeeded, invalid element id otherwise.
Exceptions
Exception | Condition
ArgumentException | options object is invalid: the ExportRange is invalid, must be CurrentView or VisibleRegionOfCurrentView, or the ViewName is invalid, must be non-empty, unique and should not contain prohibited characters. -or- The current view cannot be exported as an image
ArgumentNullException | A non-optional argument was null
See Also

Reference

Document Class


Document.SeparateElements Method

DocumentSeparateElements Method

Separate a set of combinable elements out of combinations they currently belong to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SeparateElements(
    CombinableElementArray members
)
Public Sub SeparateElements (
    members As CombinableElementArray
)
public:
void SeparateElements(
    CombinableElementArray^ members
)
member SeparateElements :
        members : CombinableElementArray -> unit

Parameters

members CombinableElementArray
A list of combinable elements to be separated.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument is .
ArgumentException | Thrown when members is empty. Thrown when members contains elements.
InvalidOperationException | Thrown when separation failed.
Remarks
If geometry combination elements are passed as input, they will be completely separated and deleted. If generic forms that happen to belong to combination elements are passed, these forms will be removed from their geometry combination. The handles of geometry combinations completely removed by this operation are no longer valid.
See Also

Reference

Document Class


Document.SetDefaultElementTypeId Method

DocumentSetDefaultElementTypeId Method

Sets the default element type id of the given DefaultElementType id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetDefaultElementTypeId(
    ElementTypeGroup defaultTypeId,
    ElementId typeId
)
Public Sub SetDefaultElementTypeId (
    defaultTypeId As ElementTypeGroup,
    typeId As ElementId
)
public:
void SetDefaultElementTypeId(
    ElementTypeGroup defaultTypeId,
    ElementId^ typeId
)
member SetDefaultElementTypeId :
        defaultTypeId : ElementTypeGroup *
        typeId : ElementId -> unit

Parameters

defaultTypeId ElementTypeGroup
The default element type id.
typeId ElementId
The element type id.
Exceptions
Exception | Condition
ArgumentException | The element type id typeId is invalid for the give DefaultElementType id defaultTypeId.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

Document Class


Document.SetDefaultFamilyTypeId Method

DocumentSetDefaultFamilyTypeId Method

Sets the default family type id for the given family category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetDefaultFamilyTypeId(
    ElementId familyCategoryId,
    ElementId familyTypeId
)
Public Sub SetDefaultFamilyTypeId (
    familyCategoryId As ElementId,
    familyTypeId As ElementId
)
public:
void SetDefaultFamilyTypeId(
    ElementId^ familyCategoryId,
    ElementId^ familyTypeId
)
member SetDefaultFamilyTypeId :
        familyCategoryId : ElementId *
        familyTypeId : ElementId -> unit

Parameters

familyCategoryId ElementId
The family category id.
familyTypeId ElementId
The default family type id.
Exceptions
Exception | Condition
ArgumentException | The family type id familyTypeId is invalid for the give family category familyCategoryId.
ArgumentNullException | A non-optional argument was null
Example
C#
VB
C++
F#
Copy
private void SetDefaultTypeFromDoor(Document document, FamilyInstance door)
{
    ElementId doorCategoryId = new ElementId(BuiltInCategory.OST_Doors);

    // It is necessary to test the type suitability to be a default family type, for not every type can be set as default.
    // Trying to set a non-qualifying default type will cause an exception
    if (door.Symbol.IsValidDefaultFamilyType(doorCategoryId))
    {
        document.SetDefaultFamilyTypeId(doorCategoryId, door.Symbol.Id);
    }
}
Private Sub SetDefaultTypeFromDoor(document As Document, door As FamilyInstance)
   Dim doorCategoryId As New ElementId(BuiltInCategory.OST_Doors)

   ' It is necessary to test the type suitability to be a default family type, for not every type can be set as default.
   ' Trying to set a non-qualifying default type will cause an exception
   If door.Symbol.IsValidDefaultFamilyType(doorCategoryId) Then
      document.SetDefaultFamilyTypeId(doorCategoryId, door.Symbol.Id)
   End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Document Class


Document.SetUnits Method

DocumentSetUnits Method

Sets the units.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetUnits(
    Units units
)
Public Sub SetUnits (
    units As Units
)
public:
void SetUnits(
    Units^ units
)
member SetUnits :
        units : Units -> unit

Parameters

units Units
The units.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

Document Class


Document.SynchronizeWithCentral Method

DocumentSynchronizeWithCentral Method

Performs reload latest until the model in the current session is up to date and then saves changes back to central. A save to central is performed even if no changes were made.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SynchronizeWithCentral(
    TransactWithCentralOptions transactOptions,
    SynchronizeWithCentralOptions syncOptions
)
Public Sub SynchronizeWithCentral (
    transactOptions As TransactWithCentralOptions,
    syncOptions As SynchronizeWithCentralOptions
)
public:
void SynchronizeWithCentral(
    TransactWithCentralOptions^ transactOptions,
    SynchronizeWithCentralOptions^ syncOptions
)
member SynchronizeWithCentral :
        transactOptions : TransactWithCentralOptions *
        syncOptions : SynchronizeWithCentralOptions -> unit

Parameters

transactOptions TransactWithCentralOptions
Options to customize behavior accessing the central model.
syncOptions SynchronizeWithCentralOptions
Options to customize behavior of SynchronizeWithCentral.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
CentralFileCommunicationException | The file-based central model could not be reached, because e.g. the network is down or the file server is down.
CentralModelAccessDeniedException | Access to the central model was denied due to lack of access privileges. -or- Access to the central model was denied. A possible reason is because the model was under maintenance.
CentralModelContentionException | The central model is locked by another client.
CentralModelException | Username does not match the one used to create the local file. -or- Revit could not save all of the worksets that have been changed. Try again. -or- Some of the elements you changed in this model are now editable by someone else, or you checked out worksets that were at risk or relinquished in the central model but not this file. You cannot synchronize with the central model until the other user relinquishes these elements without making changes. -or- The central model has been replaced by a local model. -or- Local incompatible because it was closed without saving after synchronizing with central. -or- The central model is missing. -or- The central model is incompatible. -or- The central model is corrupt or not an RVT file. -or- The central model was rolled back. -or- The central model's elements have been relinquished -or- Your data or permissions saving is aborted by another user. -or- The central model is overritten by other user. -or- An internal error happened on the central model, please contact the server administrator.
FileNotFoundException | Cannot access the local file.
InvalidOperationException | This Document is not a primary document, it is a linked document. -or- This Document is read-only: It cannot be modified. -or- This Document has an open editing transaction and is accepting changes. -or- This Document is not a project document. -or- This Document is in an edit mode. -or- Saving is not allowed in the current application mode. -or- This Document does not have a central location: Worksharing needs to be enabled and central model saved. -or- This Document is a local file that is not owned by the current user, who therefore is not allowed to modify it. -or- The local file is read-only. It can not be saved before or after synchronizing with central. -or- This Document is not a workshared document. -or- Saving local before first reload latest and after saving changes to central in Synchronize with Central is mandatory for server-based local models. -or- Operation is not permitted when there is any open sub-transaction, transaction, or transaction group.
OperationCanceledException | Synchronize With Central was canceled by the user or by an API event callback.
RevitServerCommunicationException | The server-based central model could not be reached because of a network communication error.
RevitServerInternalException | The disk space is running low on server, please contact the server administrator. -or- An internal error happened on the server, please contact the server administrator.
RevitServerUnauthenticatedUserException | User is not signed in with Autodesk id.
RevitServerUnauthorizedException | User is not authorized to access the specified A360 project.
Example
C#
VB
C++
F#
Copy
public void SyncWithoutRelinquishing(Document doc)
{
    // Set options for accessing central model
    TransactWithCentralOptions transOpts = new TransactWithCentralOptions();
    SynchLockCallback transCallBack = new SynchLockCallback();
    // Override default behavior of waiting to try again if the central model is locked
    transOpts.SetLockCallback(transCallBack);

    // Set options for synchronizing with central
    SynchronizeWithCentralOptions syncOpts = new SynchronizeWithCentralOptions();
    // Sync without relinquishing any checked out elements or worksets
    RelinquishOptions relinquishOpts = new RelinquishOptions(false);
    syncOpts.SetRelinquishOptions(relinquishOpts);
    // Do not automatically save local model after sync
    syncOpts.SaveLocalAfter = false;
    syncOpts.Comment = "Changes to Workset1";

    try
    {
        doc.SynchronizeWithCentral(transOpts, syncOpts);
    }
    catch (Exception e)
    {
        TaskDialog.Show("Synchronize Failed", e.Message);
    }
}

// This class implements the ICentralLockedCallback to override Revit's default
// behavior for how to handle when the central model is locked by another user
class SynchLockCallback : ICentralLockedCallback
{
    // If unable to lock central, give up rather than waiting
    public bool ShouldWaitForLockAvailability()
    {
        return false;
    }

}
Public Sub SyncWithoutRelinquishing(doc As Document)
    ' Set options for accessing central model
    Dim transOpts As New TransactWithCentralOptions()
    Dim transCallBack As New SynchLockCallback()
    ' Override default behavior of waiting to try again if the central model is locked
    transOpts.SetLockCallback(transCallBack)

    ' Set options for synchronizing with central
    Dim syncOpts As New SynchronizeWithCentralOptions()
    ' Sync without relinquishing any checked out elements or worksets
    Dim relinquishOpts As New RelinquishOptions(False)
    syncOpts.SetRelinquishOptions(relinquishOpts)
    ' Do not automatically save local model after sync
    syncOpts.SaveLocalAfter = False
    syncOpts.Comment = "Changes to Workset1"

    Try
        doc.SynchronizeWithCentral(transOpts, syncOpts)
    Catch e As Exception
        TaskDialog.Show("Synchronize Failed", e.Message)
    End Try
End Sub

' This class implements the ICentralLockedCallback to override Revit's default
' behavior for how to handle when the central model is locked by another user
Private Class SynchLockCallback
    Implements ICentralLockedCallback
    ' If unable to lock central, give up rather than waiting
    Public Function ShouldWaitForLockAvailability() As Boolean Implements ICentralLockedCallback.ShouldWaitForLockAvailability
        Return False
    End Function

End Class

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Document Class


Document.UnpostFailure Method

DocumentUnpostFailure Method

Deletes the posted failure message associated with a given FailureMessageKey.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void UnpostFailure(
    FailureMessageKey messageKey
)
Public Sub UnpostFailure (
    messageKey As FailureMessageKey
)
public:
void UnpostFailure(
    FailureMessageKey^ messageKey
)
member UnpostFailure :
        messageKey : FailureMessageKey -> unit

Parameters

messageKey FailureMessageKey
The key of the FailureMessage to be deleted.
Exceptions
Exception | Condition
ArgumentException | messageKey is invalid
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
If code that previously has posted a failure is executed again or otherwise detects that failure conditions do not exist anymore and the failure is not longer relevant, it should delete a failure message in order to let transaction to be committed. In order to delete the failure, it should invoke this method with a message key that was returned when the failure was posted.
See Also

Reference

Document Class


Document Events

The Document type exposes the following members.

Events
 | Name | Description
Public event | DocumentClosing | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
Public event | DocumentPrinted | Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.
Public event | DocumentPrinting | Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.
Public event | DocumentSaved | Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.
Public event | DocumentSavedAs | Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.
Public event | DocumentSaving | Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document.
Public event | DocumentSavingAs | Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.
Public event | ViewPrinted | Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.
Public event | ViewPrinting | Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.
Top
See Also

Reference

Document Class


Document.DocumentClosing Event

DocumentDocumentClosing Event

Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DocumentClosingEventArgs> DocumentClosing
Public Event DocumentClosing As EventHandler(Of DocumentClosingEventArgs)
public:
 event EventHandler<DocumentClosingEventArgs^>^ DocumentClosing {
    void add (EventHandler<DocumentClosingEventArgs^>^ value);
    void remove (EventHandler<DocumentClosingEventArgs^>^ value);
}
member DocumentClosing : IEvent<EventHandler<DocumentClosingEventArgs>,
    DocumentClosingEventArgs>

Value

EventHandler DocumentClosingEventArgs
Remarks

This event is raised when Revit is just about to close a document.

This event is cancellable, except when it is raised as part of application closing. Check the 'Cancellable' property of event's argument to see whether it is cancellable or not. When it is cancellable, call the 'Cancel()' method of event's argument to True to cancel it. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document may not be modified during this event.

The following API functions are not available for the current document during this event:

  • Close and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another Autodesk::Revit::ApplicationServices::Application::DocumentClosed event will be raised immediately after document is closed.

See Also

Reference

Document Class


Document.DocumentPrinted Event

DocumentDocumentPrinted Event

Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DocumentPrintedEventArgs> DocumentPrinted
Public Event DocumentPrinted As EventHandler(Of DocumentPrintedEventArgs)
public:
 event EventHandler<DocumentPrintedEventArgs^>^ DocumentPrinted {
    void add (EventHandler<DocumentPrintedEventArgs^>^ value);
    void remove (EventHandler<DocumentPrintedEventArgs^>^ value);
}
member DocumentPrinted : IEvent<EventHandler<DocumentPrintedEventArgs>,
    DocumentPrintedEventArgs>

Value

EventHandler DocumentPrintedEventArgs
Remarks

This event is raised immediately after Revit has finished printing a view or ViewSet of the document. It is raised even when document printing failed or was cancelled (during DocumentPriting event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event's argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of printing has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Reference

Document Class


Document.DocumentPrinting Event

DocumentDocumentPrinting Event

Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DocumentPrintingEventArgs> DocumentPrinting
Public Event DocumentPrinting As EventHandler(Of DocumentPrintingEventArgs)
public:
 event EventHandler<DocumentPrintingEventArgs^>^ DocumentPrinting {
    void add (EventHandler<DocumentPrintingEventArgs^>^ value);
    void remove (EventHandler<DocumentPrintingEventArgs^>^ value);
}
member DocumentPrinting : IEvent<EventHandler<DocumentPrintingEventArgs>,
    DocumentPrintingEventArgs>

Value

EventHandler DocumentPrintingEventArgs
Remarks

This event is raised when Revit is just about to print a view or ViewSet of the document.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is cancellable. To cancel it, call the 'Cancel()' method of event's argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for current document during this event:

  • All overloads of Autodesk.Revit.DB.Document.Export()
  • Autodesk::Revit::DB::Document::Print
  • Print and similar overloads.
  • SubmitPrint and similar overloads.
  • Close and similar overloads.
  • Save .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

After this event, for each view being printed,ViewPrinting and ViewPrinted events will be raised. Another event DocumentPrinted will be raised immediately after document printing is finished.

See Also

Reference

Document Class


Document.DocumentSaved Event

DocumentDocumentSaved Event

Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DocumentSavedEventArgs> DocumentSaved
Public Event DocumentSaved As EventHandler(Of DocumentSavedEventArgs)
public:
 event EventHandler<DocumentSavedEventArgs^>^ DocumentSaved {
    void add (EventHandler<DocumentSavedEventArgs^>^ value);
    void remove (EventHandler<DocumentSavedEventArgs^>^ value);
}
member DocumentSaved : IEvent<EventHandler<DocumentSavedEventArgs>,
    DocumentSavedEventArgs>

Value

EventHandler DocumentSavedEventArgs
Remarks

This event is raised immediately after Revit has finished saving a document. Note that the first save of a newly created document will raise DocumentSavedAs rather than the DocumentSaved event. It is raised even when document saving failed or was cancelled (during DocumentSaving event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' property in event's argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of saving document has already been finished.

The following API functions are not available for the current document during this event:

  • Close and similar overloads.
  • Save .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Reference

Document Class


Document.DocumentSavedAs Event

DocumentDocumentSavedAs Event

Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DocumentSavedAsEventArgs> DocumentSavedAs
Public Event DocumentSavedAs As EventHandler(Of DocumentSavedAsEventArgs)
public:
 event EventHandler<DocumentSavedAsEventArgs^>^ DocumentSavedAs {
    void add (EventHandler<DocumentSavedAsEventArgs^>^ value);
    void remove (EventHandler<DocumentSavedAsEventArgs^>^ value);
}
member DocumentSavedAs : IEvent<EventHandler<DocumentSavedAsEventArgs>,
    DocumentSavedAsEventArgs>

Value

EventHandler DocumentSavedAsEventArgs
Remarks

This event is raised immediately after Revit has finished saving document with a new file name. Note that the first save of a newly created document will raise DocumentSavedAs rather than DocumentSaved event. It is raised even when document saving failed or was cancelled (during DocumentSavingAs event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' property in event's argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of saving document has already been finished.

The following API functions are not available for the current document during this event:

  • Close and similar overloads.
  • Save .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Reference

Document Class


Document.DocumentSaving Event

DocumentDocumentSaving Event

Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DocumentSavingEventArgs> DocumentSaving
Public Event DocumentSaving As EventHandler(Of DocumentSavingEventArgs)
public:
 event EventHandler<DocumentSavingEventArgs^>^ DocumentSaving {
    void add (EventHandler<DocumentSavingEventArgs^>^ value);
    void remove (EventHandler<DocumentSavingEventArgs^>^ value);
}
member DocumentSaving : IEvent<EventHandler<DocumentSavingEventArgs>,
    DocumentSavingEventArgs>

Value

EventHandler DocumentSavingEventArgs
Remarks

This event is raised when Revit is just about to save the document. Note that the first save of a newly created document will raise DocumentSavingAs rather than the DocumentSaving event.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

This event is cancellable, except when it is raised during close of the application. Check the 'Cancellable' property of event's argument to see whether it is cancellable or not. When it is cancellable, call the 'Cancel()' method of event's argument to cancel it. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • Close and similar overloads.
  • Save .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event DocumentSaved will be raised immediately after the document has been saved.

See Also

Reference

Document Class


Document.DocumentSavingAs Event

DocumentDocumentSavingAs Event

Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<DocumentSavingAsEventArgs> DocumentSavingAs
Public Event DocumentSavingAs As EventHandler(Of DocumentSavingAsEventArgs)
public:
 event EventHandler<DocumentSavingAsEventArgs^>^ DocumentSavingAs {
    void add (EventHandler<DocumentSavingAsEventArgs^>^ value);
    void remove (EventHandler<DocumentSavingAsEventArgs^>^ value);
}
member DocumentSavingAs : IEvent<EventHandler<DocumentSavingAsEventArgs>,
    DocumentSavingAsEventArgs>

Value

EventHandler DocumentSavingAsEventArgs
Remarks

This event is raised when Revit is just about to save the document with a new file name. Note that the first save of a newly created document will raise DocumentSavingAs rather than DocumentSaving event.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

This event is cancellable, except when it is raised during close of the application. Check the 'Cancellable' property of event's argument to see whether it is cancellable or not. When it is cancellable, call the 'Cancel()' method of event's argument to cancel it. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • Close and similar overloads.
  • Save .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event DocumentSavedAs will be raised immediately after the document has been saved with a new file name.

See Also

Reference

Document Class


Document.ViewPrinted Event

DocumentViewPrinted Event

Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<ViewPrintedEventArgs> ViewPrinted
Public Event ViewPrinted As EventHandler(Of ViewPrintedEventArgs)
public:
 event EventHandler<ViewPrintedEventArgs^>^ ViewPrinted {
    void add (EventHandler<ViewPrintedEventArgs^>^ value);
    void remove (EventHandler<ViewPrintedEventArgs^>^ value);
}
member ViewPrinted : IEvent<EventHandler<ViewPrintedEventArgs>,
    ViewPrintedEventArgs>

Value

EventHandler ViewPrintedEventArgs
Remarks

This event is raised immediately after Revit has finished printing a view of the document. If multiple views are combined to a single file, this event will be raised only once. It is raised even when view printing failed.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event's argument to see whether the action was successful or not.

This event is not cancellable, for the process of view printing has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Reference

Document Class


Document.ViewPrinting Event

DocumentViewPrinting Event

Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<ViewPrintingEventArgs> ViewPrinting
Public Event ViewPrinting As EventHandler(Of ViewPrintingEventArgs)
public:
 event EventHandler<ViewPrintingEventArgs^>^ ViewPrinting {
    void add (EventHandler<ViewPrintingEventArgs^>^ value);
    void remove (EventHandler<ViewPrintingEventArgs^>^ value);
}
member ViewPrinting : IEvent<EventHandler<ViewPrintingEventArgs>,
    ViewPrintingEventArgs>

Value

EventHandler ViewPrintingEventArgs
Remarks

This event is raised when Revit is just about to print a view of the document. If multiple views are combined to a single file, this event will be raised only once.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is not cancellable. The 'Cancellable' property of event's argument is always False.

The following API functions are not available for the current document during this event:

  • All overloads of Autodesk.Revit.DB.Document.Export()
  • Autodesk.Revit.DB.Document.Print()
  • Print and similar overloads.
  • SubmitPrint and similar overloads.
  • Close and similar overloads.
  • Save .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event ViewPrinted will be raised immediately after view printing is finished.

See Also

Reference

Document Class


DocumentDifference Class

DocumentDifference represents the difference (including added elements, modified elements and deleted elements) of a Revit model between different DocumentVersion of the model.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBDocumentDifference

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DocumentDifference : IDisposable
Public Class DocumentDifference
    Implements IDisposable
public ref class DocumentDifference : IDisposable
type DocumentDifference =
    class
        interface IDisposable
    end

The DocumentDifference type exposes the following members.

Properties
 | Name | Description
Public property | AreDeletedElementIdsAvailable | Whether or the deleted elements were retrieved.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the DocumentDifference
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCreatedElementIds | Created element id collection.
Public method | GetDeletedElementIds | Deleted element id collection. For non-worksharing models, this will always be an empty collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetModifiedElementIds | Modified element id collection.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
For workshared models, DocumentDifference may contain all the added elements, modified elements and deleted elements. For non-workshared models, deleted elements are not tracked, so this object may only contain added elements and modified elements.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DocumentDifference Properties

The DocumentDifference type exposes the following members.

Properties
 | Name | Description
Public property | AreDeletedElementIdsAvailable | Whether or the deleted elements were retrieved.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

DocumentDifference Class


DocumentDifference.AreDeletedElementIdsAvailable Property

DocumentDifferenceAreDeletedElementIdsAvailable Property

Whether or the deleted elements were retrieved.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AreDeletedElementIdsAvailable { get; }
Public ReadOnly Property AreDeletedElementIdsAvailable As Boolean
    Get
public:
property bool AreDeletedElementIdsAvailable {
    bool get ();
}
member AreDeletedElementIdsAvailable : bool with get

Property Value

Boolean
See Also

Reference

DocumentDifference Class


DocumentDifference.IsValidObject Property

DocumentDifferenceIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

DocumentDifference Class


DocumentDifference Methods

The DocumentDifference type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCreatedElementIds | Created element id collection.
Public method | GetDeletedElementIds | Deleted element id collection. For non-worksharing models, this will always be an empty collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetModifiedElementIds | Modified element id collection.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DocumentDifference Class


DocumentDifference.Dispose Method

DocumentDifferenceDispose Method

Releases all resources used by the DocumentDifference

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

DocumentDifference Class


DocumentDifference.GetCreatedElementIds Method

DocumentDifferenceGetCreatedElementIds Method

Created element id collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ISet<ElementId> GetCreatedElementIds()
Public Function GetCreatedElementIds As ISet(Of ElementId)
public:
ISet<ElementId^>^ GetCreatedElementIds()
member GetCreatedElementIds : unit -> ISet<ElementId>

Return Value

ISet ElementId
See Also

Reference

DocumentDifference Class


DocumentDifference.GetDeletedElementIds Method

DocumentDifferenceGetDeletedElementIds Method

Deleted element id collection. For non-worksharing models, this will always be an empty collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ISet<ElementId> GetDeletedElementIds()
Public Function GetDeletedElementIds As ISet(Of ElementId)
public:
ISet<ElementId^>^ GetDeletedElementIds()
member GetDeletedElementIds : unit -> ISet<ElementId>

Return Value

ISet ElementId
See Also

Reference

DocumentDifference Class


DocumentDifference.GetModifiedElementIds Method

DocumentDifferenceGetModifiedElementIds Method

Modified element id collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ISet<ElementId> GetModifiedElementIds()
Public Function GetModifiedElementIds As ISet(Of ElementId)
public:
ISet<ElementId^>^ GetModifiedElementIds()
member GetModifiedElementIds : unit -> ISet<ElementId>

Return Value

ISet ElementId
See Also

Reference

DocumentDifference Class


DocumentPreviewSettings Class

Contains the settings related to the saving of preview images for a given document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBDocumentPreviewSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DocumentPreviewSettings : IDisposable
Public Class DocumentPreviewSettings
    Implements IDisposable
public ref class DocumentPreviewSettings : IDisposable
type DocumentPreviewSettings =
    class
        interface IDisposable
    end

The DocumentPreviewSettings type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | IsViewUpdateForced | Identifies if Revit will update the preview view if necessary.
Public property | PreviewViewId | The view id that will be used to generate the preview.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the DocumentPreviewSettings
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForceViewUpdate | Sets Revit to update the preview view if necessary.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsViewIdValidForPreview | Identifies if the view id is valid as a preview view id.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Example
C#
VB
C++
F#
Copy
// Get the document's preview settings
DocumentPreviewSettings settings = document.GetDocumentPreviewSettings();

// Find a candidate 3D view
FilteredElementCollector collector = new FilteredElementCollector(document);
collector.OfClass(typeof(View3D));

Func<View3D, bool> isValidForPreview = v => settings.IsViewIdValidForPreview(v.Id);

View3D viewForPreview = collector.OfType<View3D>().First<View3D>(isValidForPreview);

// Set the preview settings
using (Transaction setTransaction = new Transaction(document, "Set preview view id"))
{
   setTransaction.Start();
   settings.PreviewViewId = viewForPreview.Id;
   setTransaction.Commit();
}

// Save the document
document.Save();
' Get the document's preview settings
Dim settings As DocumentPreviewSettings = document.GetDocumentPreviewSettings()

' Find a candidate 3D view
Dim collector As New FilteredElementCollector(document)
collector.OfClass(GetType(View3D))

Dim isValidForPreview As Func(Of View3D, Boolean) = Function(v) settings.IsViewIdValidForPreview(v.Id)

Dim viewForPreview As View3D = collector.OfType(Of View3D)().First(isValidForPreview)

' Set the preview settings
Using setTransaction As New Transaction(document, "Set preview view id")
    setTransaction.Start()
    settings.PreviewViewId = viewForPreview.Id
    setTransaction.Commit()
End Using

' Save the document
document.Save()

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DocumentPreviewSettings Properties

The DocumentPreviewSettings type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | IsViewUpdateForced | Identifies if Revit will update the preview view if necessary.
Public property | PreviewViewId | The view id that will be used to generate the preview.
Top
See Also

Reference

DocumentPreviewSettings Class


DocumentPreviewSettings.IsValidObject Property

DocumentPreviewSettingsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

DocumentPreviewSettings Class


DocumentPreviewSettings.IsViewUpdateForced Property

DocumentPreviewSettingsIsViewUpdateForced Property

Identifies if Revit will update the preview view if necessary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsViewUpdateForced { get; }
Public ReadOnly Property IsViewUpdateForced As Boolean
    Get
public:
property bool IsViewUpdateForced {
    bool get ();
}
member IsViewUpdateForced : bool with get

Property Value

Boolean
Remarks
This setting applies only to a single Save operation and is reset to false after it is accessed.
See Also

Reference

DocumentPreviewSettings Class


DocumentPreviewSettings.PreviewViewId Property

DocumentPreviewSettingsPreviewViewId Property

The view id that will be used to generate the preview.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId PreviewViewId { get; set; }
Public Property PreviewViewId As ElementId
    Get
    Set
public:
property ElementId^ PreviewViewId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member PreviewViewId : ElementId with get, set

Property Value

ElementId
InvalidElementId signals that there is no permanent preview view for the document. Where possible the document's active view will be used to generate the preview upon save; where there is no active view the document will not include a preview.
Exceptions
Exception | Condition
ArgumentException | When setting this property: The view id is not valid to use as a preview view.
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
This view will always be saved as the preview view for the document unless it is overridden by the value used in SaveOptions or SaveAsOptions.
See Also

Reference

DocumentPreviewSettings Class


DocumentPreviewSettings Methods

The DocumentPreviewSettings type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForceViewUpdate | Sets Revit to update the preview view if necessary.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsViewIdValidForPreview | Identifies if the view id is valid as a preview view id.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DocumentPreviewSettings Class


DocumentPreviewSettings.Dispose Method

DocumentPreviewSettingsDispose Method

Releases all resources used by the DocumentPreviewSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

DocumentPreviewSettings Class


DocumentPreviewSettings.ForceViewUpdate Method

DocumentPreviewSettingsForceViewUpdate Method

Sets Revit to update the preview view if necessary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ForceViewUpdate(
    bool forceViewUpdate
)
Public Sub ForceViewUpdate (
    forceViewUpdate As Boolean
)
public:
void ForceViewUpdate(
    bool forceViewUpdate
)
member ForceViewUpdate :
        forceViewUpdate : bool -> unit

Parameters

forceViewUpdate Boolean
True to force update of the preview view. False to skip update if necessary (the default).
Remarks

An update is necessary if the view has never been displayed, or if the model has been changed and the view has not been updated or accessed. If the preview view has not been updated, the preview may not be properly saved.

This setting applies only to a single Save operation and is reset to false after it is accessed.

See Also

Reference

DocumentPreviewSettings Class


DocumentPreviewSettings.IsViewIdValidForPreview Method

DocumentPreviewSettingsIsViewIdValidForPreview Method

Identifies if the view id is valid as a preview view id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsViewIdValidForPreview(
    ElementId viewId
)
Public Function IsViewIdValidForPreview (
    viewId As ElementId
) As Boolean
public:
bool IsViewIdValidForPreview(
    ElementId^ viewId
)
member IsViewIdValidForPreview :
        viewId : ElementId -> bool

Parameters

viewId ElementId
The view id.

Return Value

Boolean
True if the view id is valid for preview, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Only graphical views (3d or 2d) are valid for use as a preview view. Other views (such as view templates) will not pass this method. InvalidElementId is accepted by this method as this id means that no special view is set for the preview.
See Also

Reference

DocumentPreviewSettings Class


DocumentSet Class

A set that can contain any documents.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBDocumentSet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DocumentSet : APIObject,
    IEnumerable
Public Class DocumentSet
    Inherits APIObject
    Implements IEnumerable
public ref class DocumentSet : public APIObject,
    IEnumerable
type DocumentSet =
    class
        inherit APIObject
        interface IEnumerable
    end

The DocumentSet type exposes the following members.

Constructors
 | Name | Description
Public method | DocumentSet | Initializes a new instance of the DocumentSet class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Size | Returns the number of objects that are in the set.
Top
Methods
 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of an item within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase | Removes a specified object from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified item into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DocumentSet Constructor

Initializes a new instance of the DocumentSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocumentSet()
Public Sub New
public:
DocumentSet()
new : unit -> DocumentSet
See Also

Reference

DocumentSet Class


DocumentSet Properties

The DocumentSet type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Size | Returns the number of objects that are in the set.
Top
See Also

Reference

DocumentSet Class


DocumentSet.IsEmpty Property

DocumentSetIsEmpty Property

Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Boolean
Remarks
If the set is empty then True will be returned, otherwise False.
See Also

Reference

DocumentSet Class


DocumentSet.Size Property

DocumentSetSize Property

Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
abstract Size : int with get
override Size : int with get

Property Value

Int32
See Also

Reference

DocumentSet Class


DocumentSet Methods

The DocumentSet type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of an item within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase | Removes a specified object from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified item into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DocumentSet Class


DocumentSet.Clear Method

DocumentSetClear Method

Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

DocumentSet Class


DocumentSet.Contains Method

DocumentSetContains Method

Tests for the existence of an item within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Contains(
    Document item
)
Public Overridable Function Contains (
    item As Document
) As Boolean
public:
virtual bool Contains(
    Document^ item
)
abstract Contains :
        item : Document -> bool
override Contains :
        item : Document -> bool

Parameters

item Document
The item to be searched for.

Return Value

Boolean
The Contains method returns True if the item is within the set, otherwise False.
See Also

Reference

DocumentSet Class


DocumentSet.Erase Method

DocumentSetErase Method

Removes a specified object from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Erase(
    Document item
)
Public Overridable Function Erase (
    item As Document
) As Integer
public:
virtual int Erase(
    Document^ item
)
abstract Erase :
        item : Document -> int
override Erase :
        item : Document -> int

Parameters

item Document
The item to be erased.

Return Value

Int32
The number of items that were erased from the set.
See Also

Reference

DocumentSet Class


DocumentSet.ForwardIterator Method

DocumentSetForwardIterator Method

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual DocumentSetIterator ForwardIterator()
Public Overridable Function ForwardIterator As DocumentSetIterator
public:
virtual DocumentSetIterator^ ForwardIterator()
abstract ForwardIterator : unit -> DocumentSetIterator
override ForwardIterator : unit -> DocumentSetIterator

Return Value

DocumentSetIterator
Returns a forward moving iterator to the set.
See Also

Reference

DocumentSet Class


DocumentSet.GetEnumerator Method

DocumentSetGetEnumerator Method

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

IEnumerator
Returns a forward moving iterator to the set.

Implements

IEnumerableGetEnumerator
See Also

Reference

DocumentSet Class


DocumentSet.Insert Method

DocumentSetInsert Method

Insert the specified item into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Insert(
    Document item
)
Public Overridable Function Insert (
    item As Document
) As Boolean
public:
virtual bool Insert(
    Document^ item
)
abstract Insert :
        item : Document -> bool
override Insert :
        item : Document -> bool

Parameters

item Document
The item to be inserted into the set.

Return Value

Boolean
Returns whether the item was inserted into the set.
See Also

Reference

DocumentSet Class


DocumentSet.ReverseIterator Method

DocumentSetReverseIterator Method

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual DocumentSetIterator ReverseIterator()
Public Overridable Function ReverseIterator As DocumentSetIterator
public:
virtual DocumentSetIterator^ ReverseIterator()
abstract ReverseIterator : unit -> DocumentSetIterator
override ReverseIterator : unit -> DocumentSetIterator

Return Value

DocumentSetIterator
Returns a backward moving iterator to the set.
See Also

Reference

DocumentSet Class


DocumentSetIterator Class

An iterator to a set of documents.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBDocumentSetIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class DocumentSetIterator : APIObject,
    IEnumerator
Public MustInherit Class DocumentSetIterator
    Inherits APIObject
    Implements IEnumerator
public ref class DocumentSetIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type DocumentSetIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The DocumentSetIterator type exposes the following members.

Constructors
 | Name | Description
Public method | DocumentSetIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DocumentSetIterator Constructor

For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DocumentSetIterator()
Public Sub New
public:
DocumentSetIterator()
new : unit -> DocumentSetIterator
Remarks
This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.
See Also

Reference

DocumentSetIterator Class


DocumentSetIterator Properties

The DocumentSetIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

DocumentSetIterator Class


DocumentSetIterator.Current Property

DocumentSetIteratorCurrent Property

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}
abstract Current : Object with get
override Current : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.
See Also

Reference

DocumentSetIterator Class


DocumentSetIterator Methods

The DocumentSetIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DocumentSetIterator Class


DocumentSetIterator.MoveNext Method

DocumentSetIteratorMoveNext Method

Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumeratorMoveNext
Remarks
MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.
See Also

Reference

DocumentSetIterator Class


DocumentSetIterator.Reset Method

DocumentSetIteratorReset Method

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
Remarks
The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.
See Also

Reference

DocumentSetIterator Class


DocumentType Enumeration

Types of Revit documents.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DocumentType
Public Enumeration DocumentType
public enum class DocumentType
type DocumentType
Members
Member name | Value | Description
Project | 0 | Project document.
Family | 1 | Family document.
Template | 2 | Template document.
IFC | 3 | IFC document.
BuildingComponent | 4 | Building Component document.
Other | 100 | Document of another type.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DocumentValidation Class

Utility functions with document validation
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBDocumentValidation

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class DocumentValidation
Public NotInheritable Class DocumentValidation
public ref class DocumentValidation abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DocumentValidation = class end

The DocumentValidation type exposes the following members.

Methods
Name | Description
CanDeleteElement | Indicates if an element can be deleted.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DocumentValidation Methods

The DocumentValidation type exposes the following members.

Methods
Name | Description
CanDeleteElement | Indicates if an element can be deleted.
Top
See Also

Reference

DocumentValidation Class


DocumentValidation.CanDeleteElement Method

DocumentValidationCanDeleteElement Method

Indicates if an element can be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CanDeleteElement(
    Document document,
    ElementId elementId
)
Public Shared Function CanDeleteElement (
    document As Document,
    elementId As ElementId
) As Boolean
public:
static bool CanDeleteElement(
    Document^ document,
    ElementId^ elementId
)
static member CanDeleteElement :
        document : Document *
        elementId : ElementId -> bool

Parameters

document Document
The document.
elementId ElementId
The id of the element to check.

Return Value

Boolean
True if the element can be deleted, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DocumentValidation Class


DocumentVersion Class

This class uniquely identifies an edition of a given document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBDocumentVersion

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DocumentVersion : IDisposable
Public Class DocumentVersion
    Implements IDisposable
public ref class DocumentVersion : IDisposable
type DocumentVersion =
    class
        interface IDisposable
    end

The DocumentVersion type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NumberOfSaves | The number of times the document has been saved. The save number and GUID are both necessary to uniquely identify a document version.
Public property | VersionGUID | The GUID portion of the DocumentVersion. The GUID is updated when changes are made to the document, but may not update with every change to the document. The GUID and save number are both necessary to uniquely identify a document version.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the DocumentVersion
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqual | Checks whether two DocumentVersions are identical. They are identical if both the GUID and number of saves are equal. If two DocumentVersions are identical, they come from the same document, with the same set of changes.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

DocumentVersion consists of two parts - a GUID and an integer. The GUID is updated as new elements are created in the document, but it is not necessarily changed whenever any individual change is made to the document. The integer is updated when the document is saved.

The GUID will change as changes are made to a model, so it should not be treated as a static value.

This class does not contain any time information - you cannot compare two DocumentVersions and know which document is newer. It can be used to tell whether a document has changed since it was last inspected. See GetDocumentVersion

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DocumentVersion Properties

The DocumentVersion type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NumberOfSaves | The number of times the document has been saved. The save number and GUID are both necessary to uniquely identify a document version.
Public property | VersionGUID | The GUID portion of the DocumentVersion. The GUID is updated when changes are made to the document, but may not update with every change to the document. The GUID and save number are both necessary to uniquely identify a document version.
Top
See Also

Reference

DocumentVersion Class


DocumentVersion.IsValidObject Property

DocumentVersionIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

DocumentVersion Class


DocumentVersion.NumberOfSaves Property

DocumentVersionNumberOfSaves Property

The number of times the document has been saved. The save number and GUID are both necessary to uniquely identify a document version.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int NumberOfSaves { get; }
Public ReadOnly Property NumberOfSaves As Integer
    Get
public:
property int NumberOfSaves {
    int get ();
}
member NumberOfSaves : int with get

Property Value

Int32
See Also

Reference

DocumentVersion Class


DocumentVersion.VersionGUID Property

DocumentVersionVersionGUID Property

The GUID portion of the DocumentVersion. The GUID is updated when changes are made to the document, but may not update with every change to the document. The GUID and save number are both necessary to uniquely identify a document version.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid VersionGUID { get; }
Public ReadOnly Property VersionGUID As Guid
    Get
public:
property Guid VersionGUID {
    Guid get ();
}
member VersionGUID : Guid with get

Property Value

Guid
See Also

Reference

DocumentVersion Class


DocumentVersion Methods

The DocumentVersion type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqual | Checks whether two DocumentVersions are identical. They are identical if both the GUID and number of saves are equal. If two DocumentVersions are identical, they come from the same document, with the same set of changes.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DocumentVersion Class


DocumentVersion.Dispose Method

DocumentVersionDispose Method

Releases all resources used by the DocumentVersion

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

DocumentVersion Class


DocumentVersion.IsEqual Method

DocumentVersionIsEqual Method

Checks whether two DocumentVersions are identical. They are identical if both the GUID and number of saves are equal. If two DocumentVersions are identical, they come from the same document, with the same set of changes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEqual(
    DocumentVersion other
)
Public Function IsEqual (
    other As DocumentVersion
) As Boolean
public:
bool IsEqual(
    DocumentVersion^ other
)
member IsEqual :
        other : DocumentVersion -> bool

Parameters

other DocumentVersion
The DocumentVersion to compare to this DocumentVersion.

Return Value

Boolean
True if the two DocumentVersions are equal. False otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DocumentVersion Class


Domain Enumeration

Type of connector domain.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum Domain
Public Enumeration Domain
public enum class Domain
type Domain
Members
Member name | Value | Description
DomainUndefined | 0 | Domain is undefined
DomainHvac | 1 | HVAC (duct) connector
DomainElectrical | 2 | Electrical connector
DomainPiping | 3 | Connector of cable trays or conduits
DomainCableTrayConduit | 4 | Connector of Structural Analytical Model
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DoorEvacuationExitType Enumeration

An enumerated type listing the possible door evacuation types

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DoorEvacuationExitType
Public Enumeration DoorEvacuationExitType
public enum class DoorEvacuationExitType
type DoorEvacuationExitType
Members
Member name | Value | Description
ExteriorExit | 0 | Exterior exit door.
InteriorExit | 1 | Interior exit door.
InteriorPassage | 2 | Interior passage door.
None | 3 | Not used for exit access.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DoubleArray Class

An array that contains doubles.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBDoubleArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DoubleArray : APIObject,
    IEnumerable
Public Class DoubleArray
    Inherits APIObject
    Implements IEnumerable
public ref class DoubleArray : public APIObject,
    IEnumerable
type DoubleArray =
    class
        inherit APIObject
        interface IEnumerable
    end

The DoubleArray type exposes the following members.

Constructors
 | Name | Description
Public method | DoubleArray | Initializes a new instance of the DoubleArray class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets a double at a specified index within the array.
Public property | Size | Returns the number of doubles that are in the array.
Top
Methods
 | Name | Description
Public method | Append |
Public method | Clear | Removes every double from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DoubleArray Constructor

Initializes a new instance of the DoubleArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DoubleArray()
Public Sub New
public:
DoubleArray()
new : unit -> DoubleArray
See Also

Reference

DoubleArray Class


DoubleArray Properties

The DoubleArray type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets a double at a specified index within the array.
Public property | Size | Returns the number of doubles that are in the array.
Top
See Also

Reference

DoubleArray Class


DoubleArray.IsEmpty Property

DoubleArrayIsEmpty Property

Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Boolean
Remarks
If the array is empty then True will be returned, otherwise False.
See Also

Reference

DoubleArray Class


DoubleArray.Item Property

DoubleArrayItem Property

Gets or sets a double at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual double this[
    int index
] { get; set; }
Public Overridable Property Item (
    index As Integer
) As Double
    Get
    Set
public:
virtual property double Item[int index] {
    double get (int index);
    void set (int index, double value);
}
abstract Item : float with get, set
override Item : float with get, set

Parameters

index Int32
The index of the double to be set or retrieved.

Return Value

Double
Returns the double at the specified index.
See Also

Reference

DoubleArray Class


DoubleArray.Size Property

DoubleArraySize Property

Returns the number of doubles that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
abstract Size : int with get
override Size : int with get

Property Value

Int32
See Also

Reference

DoubleArray Class


DoubleArray Methods

The DoubleArray type exposes the following members.

Methods
 | Name | Description
Public method | Append |
Public method | Clear | Removes every double from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DoubleArray Class


DoubleArray.Append Method

DoubleArrayAppend Method

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Append(
    ref double item
)
Public Overridable Sub Append (
    ByRef item As Double
)
public:
virtual void Append(
    double% item
)
abstract Append :
        item : float byref -> unit
override Append :
        item : float byref -> unit

Parameters

item Double
See Also

Reference

DoubleArray Class


DoubleArray.Clear Method

DoubleArrayClear Method

Removes every double from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

DoubleArray Class


DoubleArray.ForwardIterator Method

DoubleArrayForwardIterator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual DoubleArrayIterator ForwardIterator()
Public Overridable Function ForwardIterator As DoubleArrayIterator
public:
virtual DoubleArrayIterator^ ForwardIterator()
abstract ForwardIterator : unit -> DoubleArrayIterator
override ForwardIterator : unit -> DoubleArrayIterator

Return Value

DoubleArrayIterator
Returns a forward moving iterator to the array.
See Also

Reference

DoubleArray Class


DoubleArray.GetEnumerator Method

DoubleArrayGetEnumerator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

IEnumerator
Returns a forward moving iterator to the array.

Implements

IEnumerableGetEnumerator
See Also

Reference

DoubleArray Class


DoubleArray.Insert Method

DoubleArrayInsert Method

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Insert(
    ref double item,
    int index
)
Public Overridable Sub Insert (
    ByRef item As Double,
    index As Integer
)
public:
virtual void Insert(
    double% item,
    int index
)
abstract Insert :
        item : float byref *
        index : int -> unit
override Insert :
        item : float byref *
        index : int -> unit

Parameters

item Double
index Int32
See Also

Reference

DoubleArray Class


DoubleArray.ReverseIterator Method

DoubleArrayReverseIterator Method

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual DoubleArrayIterator ReverseIterator()
Public Overridable Function ReverseIterator As DoubleArrayIterator
public:
virtual DoubleArrayIterator^ ReverseIterator()
abstract ReverseIterator : unit -> DoubleArrayIterator
override ReverseIterator : unit -> DoubleArrayIterator

Return Value

DoubleArrayIterator
Returns a backward moving iterator to the array.
See Also

Reference

DoubleArray Class


DoubleArrayIterator Class

An iterator to an array of doubles.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBDoubleArrayIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class DoubleArrayIterator : APIObject,
    IEnumerator
Public MustInherit Class DoubleArrayIterator
    Inherits APIObject
    Implements IEnumerator
public ref class DoubleArrayIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type DoubleArrayIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The DoubleArrayIterator type exposes the following members.

Constructors
 | Name | Description
Public method | DoubleArrayIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DoubleArrayIterator Constructor

For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DoubleArrayIterator()
Public Sub New
public:
DoubleArrayIterator()
new : unit -> DoubleArrayIterator
Remarks
This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.
See Also

Reference

DoubleArrayIterator Class


DoubleArrayIterator Properties

The DoubleArrayIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

DoubleArrayIterator Class


DoubleArrayIterator.Current Property

DoubleArrayIteratorCurrent Property

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}
abstract Current : Object with get
override Current : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.
See Also

Reference

DoubleArrayIterator Class


DoubleArrayIterator Methods

The DoubleArrayIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DoubleArrayIterator Class


DoubleArrayIterator.MoveNext Method

DoubleArrayIteratorMoveNext Method

Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumeratorMoveNext
Remarks
MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.
See Also

Reference

DoubleArrayIterator Class


DoubleArrayIterator.Reset Method

DoubleArrayIteratorReset Method

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
Remarks
The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.
See Also

Reference

DoubleArrayIterator Class


DoubleParameterValue Class

A class that holds a Double value of a parameter element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBParameterValue
Autodesk.Revit.DBDoubleParameterValue

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DoubleParameterValue : ParameterValue
Public Class DoubleParameterValue
    Inherits ParameterValue
public ref class DoubleParameterValue : public ParameterValue
type DoubleParameterValue =
    class
        inherit ParameterValue
    end

The DoubleParameterValue type exposes the following members.

Constructors
 | Name | Description
Public method | DoubleParameterValue | Default constructor
Public method | DoubleParameterValue(Double) | Value constructor
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ParameterValue)
Public property | Value | The stored value
Top
Methods
 | Name | Description
Public method | Copy | Makes an identical copy of the given parameter value. (Inherited from ParameterValue)
Public method | Dispose | (Inherited from ParameterValue)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqual | Tests equality with another instance of the same class. (Inherited from ParameterValue)
Public method | IsSameType | Tests another instance is of the same value type. (Inherited from ParameterValue)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DoubleParameterValue Constructor

Overload List
 | Name | Description
Public method | DoubleParameterValue | Default constructor
Public method | DoubleParameterValue(Double) | Value constructor
Top
See Also

Reference

DoubleParameterValue Class


DoubleParameterValue Constructor

Default constructor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DoubleParameterValue()
Public Sub New
public:
DoubleParameterValue()
new : unit -> DoubleParameterValue
See Also

Reference

DoubleParameterValue Class
DoubleParameterValue Overload


DoubleParameterValue(Double) Constructor

Value constructor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DoubleParameterValue(
    double value
)
Public Sub New (
    value As Double
)
public:
DoubleParameterValue(
    double value
)
new :
        value : float -> DoubleParameterValue

Parameters

value Double
See Also

Reference

DoubleParameterValue Class
DoubleParameterValue Overload


DoubleParameterValue Properties

The DoubleParameterValue type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ParameterValue)
Public property | Value | The stored value
Top
See Also

Reference

DoubleParameterValue Class


DoubleParameterValue.Value Property

DoubleParameterValueValue Property

The stored value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Value { get; set; }
Public Property Value As Double
    Get
    Set
public:
property double Value {
    double get ();
    void set (double value);
}
member Value : float with get, set

Property Value

Double
See Also

Reference

DoubleParameterValue Class


DoubleParameterValue Methods

The DoubleParameterValue type exposes the following members.

Methods
 | Name | Description
Public method | Copy | Makes an identical copy of the given parameter value. (Inherited from ParameterValue)
Public method | Dispose | (Inherited from ParameterValue)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqual | Tests equality with another instance of the same class. (Inherited from ParameterValue)
Public method | IsSameType | Tests another instance is of the same value type. (Inherited from ParameterValue)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DoubleParameterValue Class


DrawLayer Enumeration

An enumerated type containing possible DrawLayer options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DrawLayer
Public Enumeration DrawLayer
public enum class DrawLayer
type DrawLayer
Members
Member name | Value | Description
Foreground | 0 | Draw in the foreground layer
Background | 1 | Draw in the background layer
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DuplicateTypeAction Enumeration

This enumerated type defines the action to be taken when there are types with the same name being pasted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DuplicateTypeAction
Public Enumeration DuplicateTypeAction
public enum class DuplicateTypeAction
type DuplicateTypeAction
Members
Member name | Value | Description
UseDestinationTypes | 1 | Proceed with the paste operation and use the types with the same name in the destination document.
Abort | 2 | Cancel the paste operation.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DuplicateTypeNamesHandlerArgs Class

A structure that provides information about an attempt to copy types with names that already exist in the destination document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBDuplicateTypeNamesHandlerArgs

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DuplicateTypeNamesHandlerArgs : IDisposable
Public Class DuplicateTypeNamesHandlerArgs
    Implements IDisposable
public ref class DuplicateTypeNamesHandlerArgs : IDisposable
type DuplicateTypeNamesHandlerArgs =
    class
        interface IDisposable
    end

The DuplicateTypeNamesHandlerArgs type exposes the following members.

Properties
 | Name | Description
Public property | Document | The document that contains the types with duplicate names.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the DuplicateTypeNamesHandlerArgs
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeIds | Returns ids of the types with duplicate names.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DuplicateTypeNamesHandlerArgs Properties

The DuplicateTypeNamesHandlerArgs type exposes the following members.

Properties
 | Name | Description
Public property | Document | The document that contains the types with duplicate names.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

DuplicateTypeNamesHandlerArgs Class


DuplicateTypeNamesHandlerArgs.Document Property

DuplicateTypeNamesHandlerArgsDocument Property

The document that contains the types with duplicate names.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Document Document { get; }
Public ReadOnly Property Document As Document
    Get
public:
property Document^ Document {
    Document^ get ();
}
member Document : Document with get

Property Value

Document
See Also

Reference

DuplicateTypeNamesHandlerArgs Class


DuplicateTypeNamesHandlerArgs.IsValidObject Property

DuplicateTypeNamesHandlerArgsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

DuplicateTypeNamesHandlerArgs Class


DuplicateTypeNamesHandlerArgs Methods

The DuplicateTypeNamesHandlerArgs type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeIds | Returns ids of the types with duplicate names.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DuplicateTypeNamesHandlerArgs Class


DuplicateTypeNamesHandlerArgs.Dispose Method

DuplicateTypeNamesHandlerArgsDispose Method

Releases all resources used by the DuplicateTypeNamesHandlerArgs

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

DuplicateTypeNamesHandlerArgs Class


DuplicateTypeNamesHandlerArgs.GetTypeIds Method

DuplicateTypeNamesHandlerArgsGetTypeIds Method

Returns ids of the types with duplicate names.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetTypeIds()
Public Function GetTypeIds As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetTypeIds()
member GetTypeIds : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
See Also

Reference

DuplicateTypeNamesHandlerArgs Class


DWFExportOptions Class

DWF Export options.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBCADExportOptions
Autodesk.Revit.DBDWFExportOptions
Autodesk.Revit.DBDWFXExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DWFExportOptions : CADExportOptions
Public Class DWFExportOptions
    Inherits CADExportOptions
public ref class DWFExportOptions : public CADExportOptions
type DWFExportOptions =
    class
        inherit CADExportOptions
    end

The DWFExportOptions type exposes the following members.

Constructors
 | Name | Description
Public method | DWFExportOptions | Default constructor. Sets all options to their default values.
Top
Properties
 | Name | Description
Public property | CropBoxVisible | Whether to export crop box.
Public property | ExportingAreas | Whether to also export areas and rooms' geometry.
Public property | ExportObjectData | Whether to include properties associated with elements.
Public property | ExportOnlyViewId | Only export the specified view.
Public property | ExportTexture | Whether to export texture.
Public property | ImageFormat | Controls the compression level of images embedded.
Public property | ImageQuality | Image quality level when compressed raster format(JPEG) is used.
Public property | MergedViews | Whether to merge all views in one file.
Public property | PaperFormat | Standard paper format.
Public property | PortraitLayout | Paper orientation - Portrait/Landscape.
Public property | StopOnError | Whether export process should stop when a view fails to export.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DWFExportOptions Constructor

Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DWFExportOptions()
Public Sub New
public:
DWFExportOptions()
new : unit -> DWFExportOptions
See Also

Reference

DWFExportOptions Class


DWFExportOptions Properties

The DWFExportOptions type exposes the following members.

Properties
 | Name | Description
Public property | CropBoxVisible | Whether to export crop box.
Public property | ExportingAreas | Whether to also export areas and rooms' geometry.
Public property | ExportObjectData | Whether to include properties associated with elements.
Public property | ExportOnlyViewId | Only export the specified view.
Public property | ExportTexture | Whether to export texture.
Public property | ImageFormat | Controls the compression level of images embedded.
Public property | ImageQuality | Image quality level when compressed raster format(JPEG) is used.
Public property | MergedViews | Whether to merge all views in one file.
Public property | PaperFormat | Standard paper format.
Public property | PortraitLayout | Paper orientation - Portrait/Landscape.
Public property | StopOnError | Whether export process should stop when a view fails to export.
Top
See Also

Reference

DWFExportOptions Class


DWFExportOptions.CropBoxVisible Property

DWFExportOptionsCropBoxVisible Property

Whether to export crop box.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CropBoxVisible { get; set; }
Public Property CropBoxVisible As Boolean
    Get
    Set
public:
property bool CropBoxVisible {
    bool get ();
    void set (bool value);
}
member CropBoxVisible : bool with get, set

Property Value

Boolean
Remarks
The default value is false.
See Also

Reference

DWFExportOptions Class


DWFExportOptions.ExportingAreas Property

DWFExportOptionsExportingAreas Property

Whether to also export areas and rooms' geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ExportingAreas { get; set; }
Public Property ExportingAreas As Boolean
    Get
    Set
public:
property bool ExportingAreas {
    bool get ();
    void set (bool value);
}
member ExportingAreas : bool with get, set

Property Value

Boolean
See Also

Reference

DWFExportOptions Class


DWFExportOptions.ExportObjectData Property

DWFExportOptionsExportObjectData Property

Whether to include properties associated with elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ExportObjectData { get; set; }
Public Property ExportObjectData As Boolean
    Get
    Set
public:
property bool ExportObjectData {
    bool get ();
    void set (bool value);
}
member ExportObjectData : bool with get, set

Property Value

Boolean
Remarks
ExportObjectData must be enabled (true) in order to also enable exporting rooms and areas (ExportingAreas). If ExportObjectData is disabled, the ExportingAreas property will be ignored.
See Also

Reference

DWFExportOptions Class


DWFExportOptions.ExportOnlyViewId Property

DWFExportOptionsExportOnlyViewId Property

Only export the specified view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId ExportOnlyViewId { get; set; }
Public Property ExportOnlyViewId As ElementId
    Get
    Set
public:
property ElementId^ ExportOnlyViewId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member ExportOnlyViewId : ElementId with get, set

Property Value

ElementId
Remarks
Export only the specified view, but the data of the other views is still used, e. g. the hyperlink information.
See Also

Reference

DWFExportOptions Class


DWFExportOptions.ExportTexture Property

DWFExportOptionsExportTexture Property

Whether to export texture.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ExportTexture { get; set; }
Public Property ExportTexture As Boolean
    Get
    Set
public:
property bool ExportTexture {
    bool get ();
    void set (bool value);
}
member ExportTexture : bool with get, set

Property Value

Boolean
Remarks
The default value is true. This property only take effect to 3D DWF.
See Also

Reference

DWFExportOptions Class


DWFExportOptions.ImageFormat Property

DWFExportOptionsImageFormat Property

Controls the compression level of images embedded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DWFImageFormat ImageFormat { get; set; }
Public Property ImageFormat As DWFImageFormat
    Get
    Set
public:
property DWFImageFormat ImageFormat {
    DWFImageFormat get ();
    void set (DWFImageFormat value);
}
member ImageFormat : DWFImageFormat with get, set

Property Value

DWFImageFormat
Remarks
ImageQuality is ignored when ImageFormat is set to "PNG"-the standard format.
See Also

Reference

DWFExportOptions Class


DWFExportOptions.ImageQuality Property

DWFExportOptionsImageQuality Property

Image quality level when compressed raster format(JPEG) is used.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DWFImageQuality ImageQuality { get; set; }
Public Property ImageQuality As DWFImageQuality
    Get
    Set
public:
property DWFImageQuality ImageQuality {
    DWFImageQuality get ();
    void set (DWFImageQuality value);
}
member ImageQuality : DWFImageQuality with get, set

Property Value

DWFImageQuality
Remarks
The default value is Default.
See Also

Reference

DWFExportOptions Class


DWFExportOptions.MergedViews Property

DWFExportOptionsMergedViews Property

Whether to merge all views in one file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool MergedViews { get; set; }
Public Property MergedViews As Boolean
    Get
    Set
public:
property bool MergedViews {
    bool get ();
    void set (bool value);
}
member MergedViews : bool with get, set

Property Value

Boolean
See Also

Reference

DWFExportOptions Class


DWFExportOptions.PaperFormat Property

DWFExportOptionsPaperFormat Property

Standard paper format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportPaperFormat PaperFormat { get; set; }
Public Property PaperFormat As ExportPaperFormat
    Get
    Set
public:
property ExportPaperFormat PaperFormat {
    ExportPaperFormat get ();
    void set (ExportPaperFormat value);
}
member PaperFormat : ExportPaperFormat with get, set

Property Value

ExportPaperFormat
See Also

Reference

DWFExportOptions Class


DWFExportOptions.PortraitLayout Property

DWFExportOptionsPortraitLayout Property

Paper orientation - Portrait/Landscape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool PortraitLayout { get; set; }
Public Property PortraitLayout As Boolean
    Get
    Set
public:
property bool PortraitLayout {
    bool get ();
    void set (bool value);
}
member PortraitLayout : bool with get, set

Property Value

Boolean
See Also

Reference

DWFExportOptions Class


DWFExportOptions.StopOnError Property

DWFExportOptionsStopOnError Property

Whether export process should stop when a view fails to export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool StopOnError { get; set; }
Public Property StopOnError As Boolean
    Get
    Set
public:
property bool StopOnError {
    bool get ();
    void set (bool value);
}
member StopOnError : bool with get, set

Property Value

Boolean
Remarks
If set to false, the export would continue until all views are processed. This option has an effect only when a set of more than one view is specified.
See Also

Reference

DWFExportOptions Class


DWFExportOptions Methods

The DWFExportOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DWFExportOptions Class


DWFImageFormat Enumeration

An enumerated type listing possible image format for DWF Export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DWFImageFormat
Public Enumeration DWFImageFormat
public enum class DWFImageFormat
type DWFImageFormat
Members
Member name | Value | Description
Lossless | 0 |
Lossy | 1 |
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DWFImageQuality Enumeration

An enumerated type listing possible image quality for DWF Export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DWFImageQuality
Public Enumeration DWFImageQuality
public enum class DWFImageQuality
type DWFImageQuality
Members
Member name | Value | Description
Default | 10 |
Low | 11 |
Medium | 12 |
High | 13 |
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DWFImportOptions Class

The import options used by importing DWF or DWFx format file.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBDWFImportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DWFImportOptions : IDisposable
Public Class DWFImportOptions
    Implements IDisposable
public ref class DWFImportOptions : IDisposable
type DWFImportOptions =
    class
        interface IDisposable
    end

The DWFImportOptions type exposes the following members.

Constructors
 | Name | Description
Public method | DWFImportOptions(DWFImportOptions) | Constructs a new instance of DWFImportOptions as a copy of the import options.
Public method | DWFImportOptions(IListElementId) | Constructs a new instance of DWFImportOptions with an array of imported sheet views.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the DWFImportOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetSheetViews | Get sheet views where DWF markups are imported.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetSheetViews | Set sheet views where DWF markups are imported.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DWFImportOptions Constructor

Overload List
 | Name | Description
Public method | DWFImportOptions(DWFImportOptions) | Constructs a new instance of DWFImportOptions as a copy of the import options.
Public method | DWFImportOptions(IListElementId) | Constructs a new instance of DWFImportOptions with an array of imported sheet views.
Top
See Also

Reference

DWFImportOptions Class


DWFImportOptions(DWFImportOptions) Constructor

Constructs a new instance of DWFImportOptions as a copy of the import options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DWFImportOptions(
    DWFImportOptions option
)
Public Sub New (
    option As DWFImportOptions
)
public:
DWFImportOptions(
    DWFImportOptions^ option
)
new :
        option : DWFImportOptions -> DWFImportOptions

Parameters

option DWFImportOptions
The options to be copied.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DWFImportOptions Class
DWFImportOptions Overload


DWFImportOptions(IList<ElementId>) Constructor

DWFImportOptions(IListElementId) Constructor

Constructs a new instance of DWFImportOptions with an array of imported sheet views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DWFImportOptions(
    IList<ElementId> views
)
Public Sub New (
    views As IList(Of ElementId)
)
public:
DWFImportOptions(
    IList<ElementId^>^ views
)
new :
        views : IList<ElementId> -> DWFImportOptions

Parameters

views IList ElementId
These sheet views where DWF markups are imported.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DWFImportOptions Class
DWFImportOptions Overload


DWFImportOptions Properties

The DWFImportOptions type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

DWFImportOptions Class


DWFImportOptions.IsValidObject Property

DWFImportOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

DWFImportOptions Class


DWFImportOptions Methods

The DWFImportOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetSheetViews | Get sheet views where DWF markups are imported.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetSheetViews | Set sheet views where DWF markups are imported.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DWFImportOptions Class


DWFImportOptions.Dispose Method

DWFImportOptionsDispose Method

Releases all resources used by the DWFImportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

DWFImportOptions Class


DWFImportOptions.GetSheetViews Method

DWFImportOptionsGetSheetViews Method

Get sheet views where DWF markups are imported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ElementId> GetSheetViews()
Public Function GetSheetViews As IList(Of ElementId)
public:
IList<ElementId^>^ GetSheetViews()
member GetSheetViews : unit -> IList<ElementId>

Return Value

IList ElementId
An array of sheet views
See Also

Reference

DWFImportOptions Class


DWFImportOptions.SetSheetViews Method

DWFImportOptionsSetSheetViews Method

Set sheet views where DWF markups are imported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetSheetViews(
    IList<ElementId> sheetViews
)
Public Sub SetSheetViews (
    sheetViews As IList(Of ElementId)
)
public:
void SetSheetViews(
    IList<ElementId^>^ sheetViews
)
member SetSheetViews :
        sheetViews : IList<ElementId> -> unit

Parameters

sheetViews IList ElementId
An array of imported sheet views.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DWFImportOptions Class


DWFXExportOptions Class

DWFX Export options.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBCADExportOptions
Autodesk.Revit.DBDWFExportOptions
Autodesk.Revit.DBDWFXExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DWFXExportOptions : DWFExportOptions
Public Class DWFXExportOptions
    Inherits DWFExportOptions
public ref class DWFXExportOptions : public DWFExportOptions
type DWFXExportOptions =
    class
        inherit DWFExportOptions
    end

The DWFXExportOptions type exposes the following members.

Constructors
 | Name | Description
Public method | DWFXExportOptions | Default constructor. Sets all options to their default values.
Top
Properties
 | Name | Description
Public property | CropBoxVisible | Whether to export crop box. (Inherited from DWFExportOptions)
Public property | ExportingAreas | Whether to also export areas and rooms' geometry. (Inherited from DWFExportOptions)
Public property | ExportObjectData | Whether to include properties associated with elements. (Inherited from DWFExportOptions)
Public property | ExportOnlyViewId | Only export the specified view. (Inherited from DWFExportOptions)
Public property | ExportTexture | Whether to export texture. (Inherited from DWFExportOptions)
Public property | ImageFormat | Controls the compression level of images embedded. (Inherited from DWFExportOptions)
Public property | ImageQuality | Image quality level when compressed raster format(JPEG) is used. (Inherited from DWFExportOptions)
Public property | MergedViews | Whether to merge all views in one file. (Inherited from DWFExportOptions)
Public property | PaperFormat | Standard paper format. (Inherited from DWFExportOptions)
Public property | PortraitLayout | Paper orientation - Portrait/Landscape. (Inherited from DWFExportOptions)
Public property | StopOnError | Whether export process should stop when a view fails to export. (Inherited from DWFExportOptions)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DWFXExportOptions Constructor

Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DWFXExportOptions()
Public Sub New
public:
DWFXExportOptions()
new : unit -> DWFXExportOptions
See Also

Reference

DWFXExportOptions Class


DWFXExportOptions Properties

The DWFXExportOptions type exposes the following members.

Properties
 | Name | Description
Public property | CropBoxVisible | Whether to export crop box. (Inherited from DWFExportOptions)
Public property | ExportingAreas | Whether to also export areas and rooms' geometry. (Inherited from DWFExportOptions)
Public property | ExportObjectData | Whether to include properties associated with elements. (Inherited from DWFExportOptions)
Public property | ExportOnlyViewId | Only export the specified view. (Inherited from DWFExportOptions)
Public property | ExportTexture | Whether to export texture. (Inherited from DWFExportOptions)
Public property | ImageFormat | Controls the compression level of images embedded. (Inherited from DWFExportOptions)
Public property | ImageQuality | Image quality level when compressed raster format(JPEG) is used. (Inherited from DWFExportOptions)
Public property | MergedViews | Whether to merge all views in one file. (Inherited from DWFExportOptions)
Public property | PaperFormat | Standard paper format. (Inherited from DWFExportOptions)
Public property | PortraitLayout | Paper orientation - Portrait/Landscape. (Inherited from DWFExportOptions)
Public property | StopOnError | Whether export process should stop when a view fails to export. (Inherited from DWFExportOptions)
Top
See Also

Reference

DWFXExportOptions Class


DWFXExportOptions Methods

The DWFXExportOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DWFXExportOptions Class


DWGExportOptions Class

The export options used by exporting DWG format file.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBaseExportOptions
Autodesk.Revit.DBACADExportOptions
Autodesk.Revit.DBDWGExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DWGExportOptions : ACADExportOptions
Public Class DWGExportOptions
    Inherits ACADExportOptions
public ref class DWGExportOptions : public ACADExportOptions
type DWGExportOptions =
    class
        inherit ACADExportOptions
    end

The DWGExportOptions type exposes the following members.

Constructors
 | Name | Description
Public method | DWGExportOptions | Constructs a new instance of DWGExportOptions with default values of all properties.
Public method | DWGExportOptions(DWGExportOptions) | Constructs a new instance of DWGExportOptions as a copy of the export options.
Top
Properties
 | Name | Description
Public property | ACAPreference | The preferred way to generate geometry of ACA objects. Default value is ACAObjectPreference.Object. (Inherited from ACADExportOptions)
Public property | Colors | Export color mode. Default value is ExportColorMode.IndexColors. (Inherited from BaseExportOptions)
Public property | ExportingAreas | True to export area and room geometry, false otherwise. Default value is false. (Inherited from ACADExportOptions)
Public property | ExportOfSolids | The mode used to export solids in 3D views. Default value is SolidGeometry.Polymesh. (Inherited from ACADExportOptions)
Public property | FileVersion | ACADVersion::Default Default value is ACADVersion.Default. (Inherited from ACADExportOptions)
Public property | HatchBackgroundColor | The color that will be set as hatch backgound color on the exported hatch. This color will be used only if useHatchBackgroundColor is true. default value is white (Inherited from ACADExportOptions)
Public property | HatchPatternsFileName | Custom hatch patterns (pat) file name. (Inherited from BaseExportOptions)
Public property | HideReferencePlane | Whether or not to hide reference planes. Default value is false. (Inherited from BaseExportOptions)
Public property | HideScopeBox | Whether or not to hide the scope box. Default value is false. (Inherited from BaseExportOptions)
Public property | HideUnreferenceViewTags | Whether or not to hide unreference view tags. Default value is false. (Inherited from BaseExportOptions)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BaseExportOptions)
Public property | LayerMapping | Name of a layer settings standard or filename (with custom layer settings). Valid standards are: DGNV7 (only for DGN), AIA, CP83, BS1192, and ISO13567. default value is "" (empty) which means if no value is set, if no value is set, Revit will use a default value according to the localization. (Inherited from BaseExportOptions)
Public property | LineScaling | The scaling mode for the line type. Default value is LineScaling.ViewScale. (Inherited from ACADExportOptions)
Public property | LinetypesFileName | The custom linetype file name (*.lin). Default value is empty. (Inherited from ACADExportOptions)
Public property | MarkNonplotLayers | If true and the nonplot layer suffix is not empty, all layers whose names contain that suffix will be marked as non-plot. (Inherited from ACADExportOptions)
Public property | MergedViews | Whether to merge all views in one file (via XRefs). Default value is false for mergedViews.
Public property | NonplotSuffix | If the MarkNonplotLayers attribute is set to true, all layers with names containing this suffix will be marked as non-plot. No action will be performed if the suffix is empty. (Inherited from ACADExportOptions)
Public property | PreserveCoincidentLines | Whether or not to preserve coincident lines. Default value is false. (Inherited from BaseExportOptions)
Public property | PropOverrides | How to export overridden object styles. Default value is PropOverrideMode.ByEntity. (Inherited from BaseExportOptions)
Public property | SharedCoords | True to use the shared coordinate system's origin, false to use the project origin. Default value is false. (Inherited from ACADExportOptions)
Public property | TargetUnit | The target unit type. Default value is ExportUnit.Default. (Inherited from ACADExportOptions)
Public property | TextTreatment | The text treatment. Deault value is TextTreatment.Exact. (Inherited from ACADExportOptions)
Public property | UseHatchBackgroundColor | Indicates if hatch background color will be used or not. default value is false. (Inherited from ACADExportOptions)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from BaseExportOptions)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetExportFontTable | Gets font table. (Inherited from BaseExportOptions)
Public method | GetExportLayerTable | Gets the layer table. (Inherited from BaseExportOptions)
Public method | GetExportLinetypeTable | Gets a copy of the line type table. (Inherited from BaseExportOptions)
Public method | GetExportPatternTable | Gets a copy of the pattern table. (Inherited from BaseExportOptions)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
 | GetPredefinedOptions | Returns an instance DWGExportOptions containing settings from a predefined export setup.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetExportFontTable | Sets font table to option. (Inherited from BaseExportOptions)
Public method | SetExportLayerTable | Sets layer table back to option (Inherited from BaseExportOptions)
Public method | SetExportLinetypeTable | Sets the line type table to use during export. (Inherited from BaseExportOptions)
Public method | SetExportPatternTable | Sets the pattern table to use during export. (Inherited from BaseExportOptions)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DWGExportOptions Constructor

Overload List
 | Name | Description
Public method | DWGExportOptions | Constructs a new instance of DWGExportOptions with default values of all properties.
Public method | DWGExportOptions(DWGExportOptions) | Constructs a new instance of DWGExportOptions as a copy of the export options.
Top
See Also

Reference

DWGExportOptions Class


DWGExportOptions Constructor

Constructs a new instance of DWGExportOptions with default values of all properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DWGExportOptions()
Public Sub New
public:
DWGExportOptions()
new : unit -> DWGExportOptions
See Also

Reference

DWGExportOptions Class
DWGExportOptions Overload


DWGExportOptions(DWGExportOptions) Constructor

Constructs a new instance of DWGExportOptions as a copy of the export options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DWGExportOptions(
    DWGExportOptions option
)
Public Sub New (
    option As DWGExportOptions
)
public:
DWGExportOptions(
    DWGExportOptions^ option
)
new :
        option : DWGExportOptions -> DWGExportOptions

Parameters

option DWGExportOptions
The options to be copied.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DWGExportOptions Class
DWGExportOptions Overload


DWGExportOptions Properties

The DWGExportOptions type exposes the following members.

Properties
 | Name | Description
Public property | ACAPreference | The preferred way to generate geometry of ACA objects. Default value is ACAObjectPreference.Object. (Inherited from ACADExportOptions)
Public property | Colors | Export color mode. Default value is ExportColorMode.IndexColors. (Inherited from BaseExportOptions)
Public property | ExportingAreas | True to export area and room geometry, false otherwise. Default value is false. (Inherited from ACADExportOptions)
Public property | ExportOfSolids | The mode used to export solids in 3D views. Default value is SolidGeometry.Polymesh. (Inherited from ACADExportOptions)
Public property | FileVersion | ACADVersion::Default Default value is ACADVersion.Default. (Inherited from ACADExportOptions)
Public property | HatchBackgroundColor | The color that will be set as hatch backgound color on the exported hatch. This color will be used only if useHatchBackgroundColor is true. default value is white (Inherited from ACADExportOptions)
Public property | HatchPatternsFileName | Custom hatch patterns (pat) file name. (Inherited from BaseExportOptions)
Public property | HideReferencePlane | Whether or not to hide reference planes. Default value is false. (Inherited from BaseExportOptions)
Public property | HideScopeBox | Whether or not to hide the scope box. Default value is false. (Inherited from BaseExportOptions)
Public property | HideUnreferenceViewTags | Whether or not to hide unreference view tags. Default value is false. (Inherited from BaseExportOptions)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BaseExportOptions)
Public property | LayerMapping | Name of a layer settings standard or filename (with custom layer settings). Valid standards are: DGNV7 (only for DGN), AIA, CP83, BS1192, and ISO13567. default value is "" (empty) which means if no value is set, if no value is set, Revit will use a default value according to the localization. (Inherited from BaseExportOptions)
Public property | LineScaling | The scaling mode for the line type. Default value is LineScaling.ViewScale. (Inherited from ACADExportOptions)
Public property | LinetypesFileName | The custom linetype file name (*.lin). Default value is empty. (Inherited from ACADExportOptions)
Public property | MarkNonplotLayers | If true and the nonplot layer suffix is not empty, all layers whose names contain that suffix will be marked as non-plot. (Inherited from ACADExportOptions)
Public property | MergedViews | Whether to merge all views in one file (via XRefs). Default value is false for mergedViews.
Public property | NonplotSuffix | If the MarkNonplotLayers attribute is set to true, all layers with names containing this suffix will be marked as non-plot. No action will be performed if the suffix is empty. (Inherited from ACADExportOptions)
Public property | PreserveCoincidentLines | Whether or not to preserve coincident lines. Default value is false. (Inherited from BaseExportOptions)
Public property | PropOverrides | How to export overridden object styles. Default value is PropOverrideMode.ByEntity. (Inherited from BaseExportOptions)
Public property | SharedCoords | True to use the shared coordinate system's origin, false to use the project origin. Default value is false. (Inherited from ACADExportOptions)
Public property | TargetUnit | The target unit type. Default value is ExportUnit.Default. (Inherited from ACADExportOptions)
Public property | TextTreatment | The text treatment. Deault value is TextTreatment.Exact. (Inherited from ACADExportOptions)
Public property | UseHatchBackgroundColor | Indicates if hatch background color will be used or not. default value is false. (Inherited from ACADExportOptions)
Top
See Also

Reference

DWGExportOptions Class


DWGExportOptions.MergedViews Property

DWGExportOptionsMergedViews Property

Whether to merge all views in one file (via XRefs). Default value is false for mergedViews.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool MergedViews { get; set; }
Public Property MergedViews As Boolean
    Get
    Set
public:
property bool MergedViews {
    bool get ();
    void set (bool value);
}
member MergedViews : bool with get, set

Property Value

Boolean
See Also

Reference

DWGExportOptions Class


DWGExportOptions Methods

The DWGExportOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from BaseExportOptions)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetExportFontTable | Gets font table. (Inherited from BaseExportOptions)
Public method | GetExportLayerTable | Gets the layer table. (Inherited from BaseExportOptions)
Public method | GetExportLinetypeTable | Gets a copy of the line type table. (Inherited from BaseExportOptions)
Public method | GetExportPatternTable | Gets a copy of the pattern table. (Inherited from BaseExportOptions)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
 | GetPredefinedOptions | Returns an instance DWGExportOptions containing settings from a predefined export setup.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetExportFontTable | Sets font table to option. (Inherited from BaseExportOptions)
Public method | SetExportLayerTable | Sets layer table back to option (Inherited from BaseExportOptions)
Public method | SetExportLinetypeTable | Sets the line type table to use during export. (Inherited from BaseExportOptions)
Public method | SetExportPatternTable | Sets the pattern table to use during export. (Inherited from BaseExportOptions)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DWGExportOptions Class


DWGExportOptions.GetPredefinedOptions Method

DWGExportOptionsGetPredefinedOptions Method

Returns an instance DWGExportOptions containing settings from a predefined export setup.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static DWGExportOptions GetPredefinedOptions(
    Document document,
    string setup
)
Public Shared Function GetPredefinedOptions (
    document As Document,
    setup As String
) As DWGExportOptions
public:
static DWGExportOptions^ GetPredefinedOptions(
    Document^ document,
    String^ setup
)
static member GetPredefinedOptions :
        document : Document *
        setup : string -> DWGExportOptions

Parameters

document Document
A Revit project document to retrieve the setup from.
setup String
The name of a predefined export setup from the specified document.

Return Value

DWGExportOptions
An instance of predefined DWGExportOptions, or if the name was not found.
Exceptions
Exception | Condition
ArgumentException | document is not a project document.
ArgumentNullException | A non-optional argument was null
See Also

Reference

DWGExportOptions Class


DWGImportOptions Class

The import options used by importing DWG or DXF format file.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBaseImportOptions
Autodesk.Revit.DBDWGImportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DWGImportOptions : BaseImportOptions
Public Class DWGImportOptions
    Inherits BaseImportOptions
public ref class DWGImportOptions : public BaseImportOptions
type DWGImportOptions =
    class
        inherit BaseImportOptions
    end

The DWGImportOptions type exposes the following members.

Constructors
 | Name | Description
Public method | DWGImportOptions | Constructs a new instance of DWGImportOptions with default values of all properties.
Public method | DWGImportOptions(DWGImportOptions) | Constructs a new instance of DWGImportOptions as a copy of the import options.
Top
Properties
 | Name | Description
Public property | AutoCorrectAlmostVHLines | Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines. (Inherited from BaseImportOptions)
Public property | ColorMode | Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors. (Inherited from BaseImportOptions)
Public property | CustomScale | Scaling the import. If this is defined and a valid value (> 0.0), it takes priority over units. (Inherited from BaseImportOptions)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BaseImportOptions)
Public property | OrientToView | Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false) (Inherited from BaseImportOptions)
Public property | Placement | Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates. (Inherited from BaseImportOptions)
Public property | ReferencePoint | The 3D point in the document where the imported instance will be inserted. If not explicitly set, the instance will be inserted at the document origin. (Inherited from BaseImportOptions)
Public property | ThisViewOnly | Imports drawings into the view that was passed into the import method. This option is not available in 3D views. (Inherited from BaseImportOptions)
Public property | Unit | The unit of measure for imported geometry. (Inherited from BaseImportOptions)
Public property | VisibleLayersOnly | Only import the visible layers. (Inherited from BaseImportOptions)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from BaseImportOptions)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetDefaultLengthUnit | Get the default length unit used for importing unitless files. (Inherited from BaseImportOptions)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLayerSelection | Get all set layers name which user want to import into Revit. (Inherited from BaseImportOptions)
Public method | GetLineWeights | Gets array of line weights.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetDefaultLengthUnit | Set the default length unit used for importing unitless files. (Inherited from BaseImportOptions)
Public method | SetLayerSelection | Set the layers name which user want to import into Revit. (Inherited from BaseImportOptions)
Public method | SetLineWeights | Set array of line weights.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DWGImportOptions Constructor

Overload List
 | Name | Description
Public method | DWGImportOptions | Constructs a new instance of DWGImportOptions with default values of all properties.
Public method | DWGImportOptions(DWGImportOptions) | Constructs a new instance of DWGImportOptions as a copy of the import options.
Top
See Also

Reference

DWGImportOptions Class


DWGImportOptions Constructor

Constructs a new instance of DWGImportOptions with default values of all properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DWGImportOptions()
Public Sub New
public:
DWGImportOptions()
new : unit -> DWGImportOptions
See Also

Reference

DWGImportOptions Class
DWGImportOptions Overload


DWGImportOptions(DWGImportOptions) Constructor

Constructs a new instance of DWGImportOptions as a copy of the import options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DWGImportOptions(
    DWGImportOptions option
)
Public Sub New (
    option As DWGImportOptions
)
public:
DWGImportOptions(
    DWGImportOptions^ option
)
new :
        option : DWGImportOptions -> DWGImportOptions

Parameters

option DWGImportOptions
The options to be copied.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DWGImportOptions Class
DWGImportOptions Overload


DWGImportOptions Properties

The DWGImportOptions type exposes the following members.

Properties
 | Name | Description
Public property | AutoCorrectAlmostVHLines | Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines. (Inherited from BaseImportOptions)
Public property | ColorMode | Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors. (Inherited from BaseImportOptions)
Public property | CustomScale | Scaling the import. If this is defined and a valid value (> 0.0), it takes priority over units. (Inherited from BaseImportOptions)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BaseImportOptions)
Public property | OrientToView | Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false) (Inherited from BaseImportOptions)
Public property | Placement | Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates. (Inherited from BaseImportOptions)
Public property | ReferencePoint | The 3D point in the document where the imported instance will be inserted. If not explicitly set, the instance will be inserted at the document origin. (Inherited from BaseImportOptions)
Public property | ThisViewOnly | Imports drawings into the view that was passed into the import method. This option is not available in 3D views. (Inherited from BaseImportOptions)
Public property | Unit | The unit of measure for imported geometry. (Inherited from BaseImportOptions)
Public property | VisibleLayersOnly | Only import the visible layers. (Inherited from BaseImportOptions)
Top
See Also

Reference

DWGImportOptions Class


DWGImportOptions Methods

The DWGImportOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from BaseImportOptions)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetDefaultLengthUnit | Get the default length unit used for importing unitless files. (Inherited from BaseImportOptions)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLayerSelection | Get all set layers name which user want to import into Revit. (Inherited from BaseImportOptions)
Public method | GetLineWeights | Gets array of line weights.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetDefaultLengthUnit | Set the default length unit used for importing unitless files. (Inherited from BaseImportOptions)
Public method | SetLayerSelection | Set the layers name which user want to import into Revit. (Inherited from BaseImportOptions)
Public method | SetLineWeights | Set array of line weights.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DWGImportOptions Class


DWGImportOptions.GetLineWeights Method

DWGImportOptionsGetLineWeights Method

Gets array of line weights.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<int> GetLineWeights()
Public Function GetLineWeights As IList(Of Integer)
public:
IList<int>^ GetLineWeights()
member GetLineWeights : unit -> IList<int>

Return Value

IList Int32
See Also

Reference

DWGImportOptions Class


DWGImportOptions.SetLineWeights Method

DWGImportOptionsSetLineWeights Method

Set array of line weights.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetLineWeights(
    IList<int> lineWeight
)
Public Sub SetLineWeights (
    lineWeight As IList(Of Integer)
)
public:
void SetLineWeights(
    IList<int>^ lineWeight
)
member SetLineWeights :
        lineWeight : IList<int> -> unit

Parameters

lineWeight IList Int32
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DWGImportOptions Class


DXFExportOptions Class

The export options used by exporting DXF format file.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBaseExportOptions
Autodesk.Revit.DBACADExportOptions
Autodesk.Revit.DBDXFExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DXFExportOptions : ACADExportOptions
Public Class DXFExportOptions
    Inherits ACADExportOptions
public ref class DXFExportOptions : public ACADExportOptions
type DXFExportOptions =
    class
        inherit ACADExportOptions
    end

The DXFExportOptions type exposes the following members.

Constructors
 | Name | Description
Public method | DXFExportOptions | Constructs a new instance of DXFImportOptions with default values of all properties.
Public method | DXFExportOptions(DXFExportOptions) | Constructs a new instance of DXFImportOptions as a copy of the export options.
Top
Properties
 | Name | Description
Public property | ACAPreference | The preferred way to generate geometry of ACA objects. Default value is ACAObjectPreference.Object. (Inherited from ACADExportOptions)
Public property | Colors | Export color mode. Default value is ExportColorMode.IndexColors. (Inherited from BaseExportOptions)
Public property | ExportingAreas | True to export area and room geometry, false otherwise. Default value is false. (Inherited from ACADExportOptions)
Public property | ExportOfSolids | The mode used to export solids in 3D views. Default value is SolidGeometry.Polymesh. (Inherited from ACADExportOptions)
Public property | FileVersion | ACADVersion::Default Default value is ACADVersion.Default. (Inherited from ACADExportOptions)
Public property | HatchBackgroundColor | The color that will be set as hatch backgound color on the exported hatch. This color will be used only if useHatchBackgroundColor is true. default value is white (Inherited from ACADExportOptions)
Public property | HatchPatternsFileName | Custom hatch patterns (pat) file name. (Inherited from BaseExportOptions)
Public property | HideReferencePlane | Whether or not to hide reference planes. Default value is false. (Inherited from BaseExportOptions)
Public property | HideScopeBox | Whether or not to hide the scope box. Default value is false. (Inherited from BaseExportOptions)
Public property | HideUnreferenceViewTags | Whether or not to hide unreference view tags. Default value is false. (Inherited from BaseExportOptions)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BaseExportOptions)
Public property | LayerMapping | Name of a layer settings standard or filename (with custom layer settings). Valid standards are: DGNV7 (only for DGN), AIA, CP83, BS1192, and ISO13567. default value is "" (empty) which means if no value is set, if no value is set, Revit will use a default value according to the localization. (Inherited from BaseExportOptions)
Public property | LineScaling | The scaling mode for the line type. Default value is LineScaling.ViewScale. (Inherited from ACADExportOptions)
Public property | LinetypesFileName | The custom linetype file name (*.lin). Default value is empty. (Inherited from ACADExportOptions)
Public property | MarkNonplotLayers | If true and the nonplot layer suffix is not empty, all layers whose names contain that suffix will be marked as non-plot. (Inherited from ACADExportOptions)
Public property | NonplotSuffix | If the MarkNonplotLayers attribute is set to true, all layers with names containing this suffix will be marked as non-plot. No action will be performed if the suffix is empty. (Inherited from ACADExportOptions)
Public property | PreserveCoincidentLines | Whether or not to preserve coincident lines. Default value is false. (Inherited from BaseExportOptions)
Public property | PropOverrides | How to export overridden object styles. Default value is PropOverrideMode.ByEntity. (Inherited from BaseExportOptions)
Public property | SharedCoords | True to use the shared coordinate system's origin, false to use the project origin. Default value is false. (Inherited from ACADExportOptions)
Public property | TargetUnit | The target unit type. Default value is ExportUnit.Default. (Inherited from ACADExportOptions)
Public property | TextTreatment | The text treatment. Deault value is TextTreatment.Exact. (Inherited from ACADExportOptions)
Public property | UseHatchBackgroundColor | Indicates if hatch background color will be used or not. default value is false. (Inherited from ACADExportOptions)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from BaseExportOptions)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetExportFontTable | Gets font table. (Inherited from BaseExportOptions)
Public method | GetExportLayerTable | Gets the layer table. (Inherited from BaseExportOptions)
Public method | GetExportLinetypeTable | Gets a copy of the line type table. (Inherited from BaseExportOptions)
Public method | GetExportPatternTable | Gets a copy of the pattern table. (Inherited from BaseExportOptions)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
 | GetPredefinedOptions | Returns an instance DXFExportOptions containing settings from a predefined export setup.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetExportFontTable | Sets font table to option. (Inherited from BaseExportOptions)
Public method | SetExportLayerTable | Sets layer table back to option (Inherited from BaseExportOptions)
Public method | SetExportLinetypeTable | Sets the line type table to use during export. (Inherited from BaseExportOptions)
Public method | SetExportPatternTable | Sets the pattern table to use during export. (Inherited from BaseExportOptions)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


DXFExportOptions Constructor

Overload List
 | Name | Description
Public method | DXFExportOptions | Constructs a new instance of DXFImportOptions with default values of all properties.
Public method | DXFExportOptions(DXFExportOptions) | Constructs a new instance of DXFImportOptions as a copy of the export options.
Top
See Also

Reference

DXFExportOptions Class


DXFExportOptions Constructor

Constructs a new instance of DXFImportOptions with default values of all properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DXFExportOptions()
Public Sub New
public:
DXFExportOptions()
new : unit -> DXFExportOptions
See Also

Reference

DXFExportOptions Class
DXFExportOptions Overload


DXFExportOptions(DXFExportOptions) Constructor

Constructs a new instance of DXFImportOptions as a copy of the export options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DXFExportOptions(
    DXFExportOptions option
)
Public Sub New (
    option As DXFExportOptions
)
public:
DXFExportOptions(
    DXFExportOptions^ option
)
new :
        option : DXFExportOptions -> DXFExportOptions

Parameters

option DXFExportOptions
The options to be copied.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

DXFExportOptions Class
DXFExportOptions Overload


DXFExportOptions Properties

The DXFExportOptions type exposes the following members.

Properties
 | Name | Description
Public property | ACAPreference | The preferred way to generate geometry of ACA objects. Default value is ACAObjectPreference.Object. (Inherited from ACADExportOptions)
Public property | Colors | Export color mode. Default value is ExportColorMode.IndexColors. (Inherited from BaseExportOptions)
Public property | ExportingAreas | True to export area and room geometry, false otherwise. Default value is false. (Inherited from ACADExportOptions)
Public property | ExportOfSolids | The mode used to export solids in 3D views. Default value is SolidGeometry.Polymesh. (Inherited from ACADExportOptions)
Public property | FileVersion | ACADVersion::Default Default value is ACADVersion.Default. (Inherited from ACADExportOptions)
Public property | HatchBackgroundColor | The color that will be set as hatch backgound color on the exported hatch. This color will be used only if useHatchBackgroundColor is true. default value is white (Inherited from ACADExportOptions)
Public property | HatchPatternsFileName | Custom hatch patterns (pat) file name. (Inherited from BaseExportOptions)
Public property | HideReferencePlane | Whether or not to hide reference planes. Default value is false. (Inherited from BaseExportOptions)
Public property | HideScopeBox | Whether or not to hide the scope box. Default value is false. (Inherited from BaseExportOptions)
Public property | HideUnreferenceViewTags | Whether or not to hide unreference view tags. Default value is false. (Inherited from BaseExportOptions)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BaseExportOptions)
Public property | LayerMapping | Name of a layer settings standard or filename (with custom layer settings). Valid standards are: DGNV7 (only for DGN), AIA, CP83, BS1192, and ISO13567. default value is "" (empty) which means if no value is set, if no value is set, Revit will use a default value according to the localization. (Inherited from BaseExportOptions)
Public property | LineScaling | The scaling mode for the line type. Default value is LineScaling.ViewScale. (Inherited from ACADExportOptions)
Public property | LinetypesFileName | The custom linetype file name (*.lin). Default value is empty. (Inherited from ACADExportOptions)
Public property | MarkNonplotLayers | If true and the nonplot layer suffix is not empty, all layers whose names contain that suffix will be marked as non-plot. (Inherited from ACADExportOptions)
Public property | NonplotSuffix | If the MarkNonplotLayers attribute is set to true, all layers with names containing this suffix will be marked as non-plot. No action will be performed if the suffix is empty. (Inherited from ACADExportOptions)
Public property | PreserveCoincidentLines | Whether or not to preserve coincident lines. Default value is false. (Inherited from BaseExportOptions)
Public property | PropOverrides | How to export overridden object styles. Default value is PropOverrideMode.ByEntity. (Inherited from BaseExportOptions)
Public property | SharedCoords | True to use the shared coordinate system's origin, false to use the project origin. Default value is false. (Inherited from ACADExportOptions)
Public property | TargetUnit | The target unit type. Default value is ExportUnit.Default. (Inherited from ACADExportOptions)
Public property | TextTreatment | The text treatment. Deault value is TextTreatment.Exact. (Inherited from ACADExportOptions)
Public property | UseHatchBackgroundColor | Indicates if hatch background color will be used or not. default value is false. (Inherited from ACADExportOptions)
Top
See Also

Reference

DXFExportOptions Class


DXFExportOptions Methods

The DXFExportOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from BaseExportOptions)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetExportFontTable | Gets font table. (Inherited from BaseExportOptions)
Public method | GetExportLayerTable | Gets the layer table. (Inherited from BaseExportOptions)
Public method | GetExportLinetypeTable | Gets a copy of the line type table. (Inherited from BaseExportOptions)
Public method | GetExportPatternTable | Gets a copy of the pattern table. (Inherited from BaseExportOptions)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
 | GetPredefinedOptions | Returns an instance DXFExportOptions containing settings from a predefined export setup.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetExportFontTable | Sets font table to option. (Inherited from BaseExportOptions)
Public method | SetExportLayerTable | Sets layer table back to option (Inherited from BaseExportOptions)
Public method | SetExportLinetypeTable | Sets the line type table to use during export. (Inherited from BaseExportOptions)
Public method | SetExportPatternTable | Sets the pattern table to use during export. (Inherited from BaseExportOptions)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

DXFExportOptions Class


DXFExportOptions.GetPredefinedOptions Method

DXFExportOptionsGetPredefinedOptions Method

Returns an instance DXFExportOptions containing settings from a predefined export setup.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static DXFExportOptions GetPredefinedOptions(
    Document document,
    string setup
)
Public Shared Function GetPredefinedOptions (
    document As Document,
    setup As String
) As DXFExportOptions
public:
static DXFExportOptions^ GetPredefinedOptions(
    Document^ document,
    String^ setup
)
static member GetPredefinedOptions :
        document : Document *
        setup : string -> DXFExportOptions

Parameters

document Document
A Revit project document to retrieve the setup from.
setup String
The name of a predefined export setup from the specified document.

Return Value

DXFExportOptions
An instance of predefined DXFExportOptions, or if the name was not found.
Exceptions
Exception | Condition
ArgumentException | document is not a project document.
ArgumentNullException | A non-optional argument was null
See Also

Reference

DXFExportOptions Class


EaveCutterType Enumeration

An enumerated type to store type of EaveCutter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum EaveCutterType
Public Enumeration EaveCutterType
public enum class EaveCutterType
type EaveCutterType
Members
Member name | Value | Description
PlumbCut | 33,615 | Plumb Cut type of Eave.
TwoCutSquare | 33,618 | Two Cut Square type of Eave.
TwoCutPlumb | 33,619 | Two Cut Plumb type of Eave.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Edge Class

An edge of a 3d solid.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGeometryObject
Autodesk.Revit.DBEdge

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Edge : GeometryObject
Public Class Edge
    Inherits GeometryObject
public ref class Edge : public GeometryObject
type Edge =
    class
        inherit GeometryObject
    end

The Edge type exposes the following members.

Properties
 | Name | Description
Public property | ApproximateLength | Returns the approximate length of the edge.
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject)
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Reference | Returns a stable reference to the edge.
Public property | Visibility | The visibility. (Inherited from GeometryObject)
Top
Methods
 | Name | Description
Public method | AsCurve | Returns a curve that corresponds to the edge's parametric orientation.
Public method | AsCurveFollowingFace | Returns a curve that corresponds to this edge as oriented in its topological direction on the specified face.
Public method | ComputeDerivatives | Returns the vectors describing the edge at the specified parameter.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject)
Public method | Evaluate | Evaluates a parameter on the edge.
Public method | EvaluateOnFace | Evaluates a parameter on the edge to produce UV coordinates on the face.
Public method | GetCurveUV(Int32) | Calculate a 2D curve that represents the edge in the uv-parameter plane of one of the edge's faces. The output curve's direction will follow the parametric direction of the edge, not the topological direction of the edge on the given face.
Public method | GetCurveUV(Int32, Transform2D) | Calculate and transform a 2D curve that represents the edge in the uv-parameter plane of one of the edge's faces. The output curve's direction will follow the parametric direction of the edge, not the topological direction of the edge on the given face.
Public method | GetEndPointReference | Returns a stable reference to the start or the end point of the edge.
Public method | GetFace | Returns one of the two faces that meet at the edge.
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsFlippedOnFace(Face) | Determines if this edge's topological direction on the Face is opposite to its parametric direction.
Public method | IsFlippedOnFace(Int32) | Determines if this edge's topological direction on the Face is opposite to its parametric direction.
Public method | Tessellate | Returns a polyline approximation to the edge.
Public method | TessellateOnFace | Returns a polyline approximation to the edge in UV parameters of the face.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Edges are defined by intersections of surfaces that form faces of the solid. They have arbitrary parameterization that is normalized to [0,1].
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Edge Properties

The Edge type exposes the following members.

Properties
 | Name | Description
Public property | ApproximateLength | Returns the approximate length of the edge.
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject)
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Reference | Returns a stable reference to the edge.
Public property | Visibility | The visibility. (Inherited from GeometryObject)
Top
See Also

Reference

Edge Class


Edge.ApproximateLength Property

EdgeApproximateLength Property

Returns the approximate length of the edge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double ApproximateLength { get; }
Public ReadOnly Property ApproximateLength As Double
    Get
public:
property double ApproximateLength {
    double get ();
}
member ApproximateLength : float with get

Property Value

Double
Remarks
Estimates the length of the edge by adding together tessellated segments, Will underestimate when the surface is curved.
See Also

Reference

Edge Class


Edge.Reference Property

EdgeReference Property

Returns a stable reference to the edge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Reference Reference { get; }
Public ReadOnly Property Reference As Reference
    Get
public:
property Reference^ Reference {
    Reference^ get ();
}
member Reference : Reference with get

Property Value

Reference
Remarks
This value is if the corresponding geometry object does not permit referencing.
See Also

Reference

Edge Class


Edge Methods

The Edge type exposes the following members.

Methods
 | Name | Description
Public method | AsCurve | Returns a curve that corresponds to the edge's parametric orientation.
Public method | AsCurveFollowingFace | Returns a curve that corresponds to this edge as oriented in its topological direction on the specified face.
Public method | ComputeDerivatives | Returns the vectors describing the edge at the specified parameter.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject)
Public method | Evaluate | Evaluates a parameter on the edge.
Public method | EvaluateOnFace | Evaluates a parameter on the edge to produce UV coordinates on the face.
Public method | GetCurveUV(Int32) | Calculate a 2D curve that represents the edge in the uv-parameter plane of one of the edge's faces. The output curve's direction will follow the parametric direction of the edge, not the topological direction of the edge on the given face.
Public method | GetCurveUV(Int32, Transform2D) | Calculate and transform a 2D curve that represents the edge in the uv-parameter plane of one of the edge's faces. The output curve's direction will follow the parametric direction of the edge, not the topological direction of the edge on the given face.
Public method | GetEndPointReference | Returns a stable reference to the start or the end point of the edge.
Public method | GetFace | Returns one of the two faces that meet at the edge.
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsFlippedOnFace(Face) | Determines if this edge's topological direction on the Face is opposite to its parametric direction.
Public method | IsFlippedOnFace(Int32) | Determines if this edge's topological direction on the Face is opposite to its parametric direction.
Public method | Tessellate | Returns a polyline approximation to the edge.
Public method | TessellateOnFace | Returns a polyline approximation to the edge in UV parameters of the face.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Edge Class


Edge.AsCurve Method

EdgeAsCurve Method

Returns a curve that corresponds to the edge's parametric orientation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Curve AsCurve()
Public Function AsCurve As Curve
public:
Curve^ AsCurve()
member AsCurve : unit -> Curve

Return Value

Curve
It can be an Arc, Line, or HermiteSpline.
See Also

Reference

Edge Class


Edge.AsCurveFollowingFace Method

EdgeAsCurveFollowingFace Method

Returns a curve that corresponds to this edge as oriented in its topological direction on the specified face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Curve AsCurveFollowingFace(
    Face faceForDir
)
Public Function AsCurveFollowingFace (
    faceForDir As Face
) As Curve
public:
Curve^ AsCurveFollowingFace(
    Face^ faceForDir
)
member AsCurveFollowingFace :
        faceForDir : Face -> Curve

Parameters

faceForDir Face
Specifies the face, on which the curve will follow the topological direction of the edge.

Return Value

Curve
It can be an Arc, Line, or HermiteSpline.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the specified faceForDir is .
ArgumentException | Thrown when the specified faceForDir is not one of the faces for this edge.
Remarks
Evaluating the edge using EvaluateOnFace gives the same result as evaluating the curve returned by AsCurveFollowingFace with a normalized curve parameter. When a Hermite spline is returned, the two evaluated points will be approximately equal.
See Also

Reference

Edge Class


Edge.ComputeDerivatives Method

EdgeComputeDerivatives Method

Returns the vectors describing the edge at the specified parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Transform ComputeDerivatives(
    double parameter
)
Public Function ComputeDerivatives (
    parameter As Double
) As Transform
public:
Transform^ ComputeDerivatives(
    double parameter
)
member ComputeDerivatives :
        parameter : float -> Transform

Parameters

parameter Double
The parameter to be evaluated.

Return Value

Transform
The transformation containing a tangent vector, derivative of tangent vector, and bi-normal vector.
Remarks
The following is the meaning of the transformation members:
  • Origin is the point on the edge (equivalent to Evaluate);
  • BasisX is the tangent vector (the first derivative);
  • BasisY is the second derivative;
  • BasisZ is the bi-normal vector (tangent x normal).
Normal and bi-normal are zero if the edge is straight at the point. None of the vectors are normalized.
See Also

Reference

Edge Class


Edge.Evaluate Method

EdgeEvaluate Method

Evaluates a parameter on the edge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Evaluate(
    double param
)
Public Function Evaluate (
    param As Double
) As XYZ
public:
XYZ^ Evaluate(
    double param
)
member Evaluate :
        param : float -> XYZ

Parameters

param Double
The parameter to be evaluated, in [0,1].

Return Value

XYZ
See Also

Reference

Edge Class


Edge.EvaluateOnFace Method

EdgeEvaluateOnFace Method

Evaluates a parameter on the edge to produce UV coordinates on the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public UV EvaluateOnFace(
    double param,
    Face face
)
Public Function EvaluateOnFace (
    param As Double,
    face As Face
) As UV
public:
UV^ EvaluateOnFace(
    double param,
    Face^ face
)
member EvaluateOnFace :
        param : float *
        face : Face -> UV

Parameters

param Double
The parameter to be evaluated, in [0,1].
face Face
The face on which to perform the evaluation. Must belong to the edge.

Return Value

UV
See Also

Reference

Edge Class


Edge.GetCurveUV Method

EdgeGetCurveUV Method

Overload List
 | Name | Description
Public method | GetCurveUV(Int32) | Calculate a 2D curve that represents the edge in the uv-parameter plane of one of the edge's faces. The output curve's direction will follow the parametric direction of the edge, not the topological direction of the edge on the given face.
Public method | GetCurveUV(Int32, Transform2D) | Calculate and transform a 2D curve that represents the edge in the uv-parameter plane of one of the edge's faces. The output curve's direction will follow the parametric direction of the edge, not the topological direction of the edge on the given face.
Top
See Also

Reference

Edge Class


Edge.GetCurveUV(Int32) Method

EdgeGetCurveUV(Int32) Method

Calculate a 2D curve that represents the edge in the uv-parameter plane of one of the edge's faces. The output curve's direction will follow the parametric direction of the edge, not the topological direction of the edge on the given face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurveUV GetCurveUV(
    int index
)
Public Function GetCurveUV (
    index As Integer
) As CurveUV
public:
CurveUV^ GetCurveUV(
    int index
)
member GetCurveUV :
        index : int -> CurveUV

Parameters

index Int32
The index of the face (0 or 1).

Return Value

CurveUV
If successful, returns the calculated CurveUV, otherwise.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown when the specified index is not 0 or 1.
See Also

Reference

Edge Class
GetCurveUV Overload


Edge.GetCurveUV(Int32, Transform2D) Method

EdgeGetCurveUV(Int32, Transform2D) Method

Calculate and transform a 2D curve that represents the edge in the uv-parameter plane of one of the edge's faces. The output curve's direction will follow the parametric direction of the edge, not the topological direction of the edge on the given face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurveUV GetCurveUV(
    int index,
    Transform2D transform
)
Public Function GetCurveUV (
    index As Integer,
    transform As Transform2D
) As CurveUV
public:
CurveUV^ GetCurveUV(
    int index,
    Transform2D^ transform
)
member GetCurveUV :
        index : int *
        transform : Transform2D -> CurveUV

Parameters

index Int32
The index of the face (0 or 1).
transform Transform2D
Transformation to apply to the curve.

Return Value

CurveUV
If successful, returns the calculated and transformed CurveUV, otherwise.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown when the specified index is not 0 or 1.
Remarks
Use of this function is preferred over using GetCurveUV(int index) and then transforming the curve, as the latter approach may yield a less accurate result.
See Also

Reference

Edge Class
GetCurveUV Overload


Edge.GetEndPointReference Method

EdgeGetEndPointReference Method

Returns a stable reference to the start or the end point of the edge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Reference GetEndPointReference(
    int index
)
Public Function GetEndPointReference (
    index As Integer
) As Reference
public:
Reference^ GetEndPointReference(
    int index
)
member GetEndPointReference :
        index : int -> Reference

Parameters

index Int32
Use 0 for the start point; 1 for the end point.

Return Value

Reference
Reference to the point or if reference cannot be obtained.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown when the specified index is not 0 or 1.
InvalidOperationException | Thrown when the object is internally marked as read-only in the setter.
See Also

Reference

Edge Class


Edge.GetFace Method

EdgeGetFace Method

Returns one of the two faces that meet at the edge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Face GetFace(
    int index
)
Public Function GetFace (
    index As Integer
) As Face
public:
Face^ GetFace(
    int index
)
member GetFace :
        index : int -> Face

Parameters

index Int32
The index of the face (0 or 1).

Return Value

Face
See Also

Reference

Edge Class


Edge.IsFlippedOnFace Method

EdgeIsFlippedOnFace Method

Overload List
 | Name | Description
Public method | IsFlippedOnFace(Face) | Determines if this edge's topological direction on the Face is opposite to its parametric direction.
Public method | IsFlippedOnFace(Int32) | Determines if this edge's topological direction on the Face is opposite to its parametric direction.
Top
See Also

Reference

Edge Class


Edge.IsFlippedOnFace(Face) Method

EdgeIsFlippedOnFace(Face) Method

Determines if this edge's topological direction on the Face is opposite to its parametric direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsFlippedOnFace(
    Face face
)
Public Function IsFlippedOnFace (
    face As Face
) As Boolean
public:
bool IsFlippedOnFace(
    Face^ face
)
member IsFlippedOnFace :
        face : Face -> bool

Parameters

face Face
The face with respect to which the direction is considered. Must belong to the edge.

Return Value

Boolean
true if this edge's topological direction on the Face is opposite to its parametric direction, false if the topological direction agrees with the parametric direction.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the specified face is .
ArgumentException | Thrown when the specified face is not one of the faces for this edge.
Remarks
Outer edge loops on a Face are oriented counter-clockwise with respect to the Face's orientation, and inner loops are oriented clockwise. The topological direction of an edge on a face means the direction in which the edge's loop is being traversed.
See Also

Reference

Edge Class
IsFlippedOnFace Overload


Edge.IsFlippedOnFace(Int32) Method

EdgeIsFlippedOnFace(Int32) Method

Determines if this edge's topological direction on the Face is opposite to its parametric direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsFlippedOnFace(
    int index
)
Public Function IsFlippedOnFace (
    index As Integer
) As Boolean
public:
bool IsFlippedOnFace(
    int index
)
member IsFlippedOnFace :
        index : int -> bool

Parameters

index Int32
The index of the face (0 or 1).

Return Value

Boolean
true if this edge's topological direction on the Face is opposite to its parametric direction, false if the topological direction agrees with the parametric direction.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown when the specified index is not 0 or 1.
Remarks
Outer edge loops on a Face are oriented counter-clockwise with respect to the Face's orientation, and inner loops are oriented clockwise. The topological direction of an edge on a face means the direction in which the edge's loop is being traversed.
See Also

Reference

Edge Class
IsFlippedOnFace Overload


Edge.Tessellate Method

EdgeTessellate Method

Returns a polyline approximation to the edge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<XYZ> Tessellate()
Public Function Tessellate As IList(Of XYZ)
public:
IList<XYZ^>^ Tessellate()
member Tessellate : unit -> IList<XYZ>

Return Value

IList XYZ
Remarks
Tolerance of approximation is defined internally by Revit to be adequate for display purposes.
See Also

Reference

Edge Class


Edge.TessellateOnFace Method

EdgeTessellateOnFace Method

Returns a polyline approximation to the edge in UV parameters of the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<UV> TessellateOnFace(
    Face face
)
Public Function TessellateOnFace (
    face As Face
) As IList(Of UV)
public:
IList<UV^>^ TessellateOnFace(
    Face^ face
)
member TessellateOnFace :
        face : Face -> IList<UV>

Parameters

face Face
The face on which to perform the tessellation. Must belong to the edge.

Return Value

IList UV
Remarks
Tolerance of approximation is defined internally by Revit to be adequate for display purposes.
See Also

Reference

Edge Class


EdgeArray Class

An array that contains edges.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBEdgeArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class EdgeArray : APIObject, IEnumerable
Public Class EdgeArray
    Inherits APIObject
    Implements IEnumerable
public ref class EdgeArray : public APIObject,
    IEnumerable
type EdgeArray =
    class
        inherit APIObject
        interface IEnumerable
    end

The EdgeArray type exposes the following members.

Constructors
 | Name | Description
Public method | EdgeArray | Initializes a new instance of the EdgeArray class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets an edge at a specified index within the array.
Public property | Size | Returns the number of edges that are in the array.
Top
Methods
 | Name | Description
Public method | Append | Add the edge to the end of the array.
Public method | Clear | Removes every edge from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified edge into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


EdgeArray Constructor

Initializes a new instance of the EdgeArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EdgeArray()
Public Sub New
public:
EdgeArray()
new : unit -> EdgeArray
See Also

Reference

EdgeArray Class


EdgeArray Properties

The EdgeArray type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets an edge at a specified index within the array.
Public property | Size | Returns the number of edges that are in the array.
Top
See Also

Reference

EdgeArray Class


EdgeArray.IsEmpty Property

EdgeArrayIsEmpty Property

Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Boolean
Remarks
If the array is empty then True will be returned, otherwise False.
See Also

Reference

EdgeArray Class


EdgeArray.Item Property

EdgeArrayItem Property

Gets or sets an edge at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Edge this[
    int index
] { get; set; }
Public Overridable Property Item (
    index As Integer
) As Edge
    Get
    Set
public:
virtual property Edge^ Item[int index] {
    Edge^ get (int index);
    void set (int index, Edge^ value);
}
abstract Item : Edge with get, set
override Item : Edge with get, set

Parameters

index Int32
The index of the edge to be set or retrieved.

Return Value

Edge
Returns the edge at the specified index.
See Also

Reference

EdgeArray Class


EdgeArray.Size Property

EdgeArraySize Property

Returns the number of edges that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
abstract Size : int with get
override Size : int with get

Property Value

Int32
See Also

Reference

EdgeArray Class


EdgeArray Methods

The EdgeArray type exposes the following members.

Methods
 | Name | Description
Public method | Append | Add the edge to the end of the array.
Public method | Clear | Removes every edge from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified edge into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

EdgeArray Class


EdgeArray.Append Method

EdgeArrayAppend Method

Add the edge to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Append(
    Edge item
)
Public Overridable Sub Append (
    item As Edge
)
public:
virtual void Append(
    Edge^ item
)
abstract Append :
        item : Edge -> unit
override Append :
        item : Edge -> unit

Parameters

item Edge
The edge to be added.
See Also

Reference

EdgeArray Class


EdgeArray.Clear Method

EdgeArrayClear Method

Removes every edge from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

EdgeArray Class


EdgeArray.ForwardIterator Method

EdgeArrayForwardIterator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual EdgeArrayIterator ForwardIterator()
Public Overridable Function ForwardIterator As EdgeArrayIterator
public:
virtual EdgeArrayIterator^ ForwardIterator()
abstract ForwardIterator : unit -> EdgeArrayIterator
override ForwardIterator : unit -> EdgeArrayIterator

Return Value

EdgeArrayIterator
Returns a forward moving iterator to the array.
See Also

Reference

EdgeArray Class


EdgeArray.GetEnumerator Method

EdgeArrayGetEnumerator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

IEnumerator
Returns a forward moving iterator to the array.

Implements

IEnumerableGetEnumerator
See Also

Reference

EdgeArray Class


EdgeArray.Insert Method

EdgeArrayInsert Method

Insert the specified edge into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Insert(
    Edge item,
    int index
)
Public Overridable Sub Insert (
    item As Edge,
    index As Integer
)
public:
virtual void Insert(
    Edge^ item,
    int index
)
abstract Insert :
        item : Edge *
        index : int -> unit
override Insert :
        item : Edge *
        index : int -> unit

Parameters

item Edge
The edge to be inserted into the array.
index Int32
The edge will be inserted before this index.

Return Value

Returns whether the edge was inserted into the array.
See Also

Reference

EdgeArray Class


EdgeArray.ReverseIterator Method

EdgeArrayReverseIterator Method

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual EdgeArrayIterator ReverseIterator()
Public Overridable Function ReverseIterator As EdgeArrayIterator
public:
virtual EdgeArrayIterator^ ReverseIterator()
abstract ReverseIterator : unit -> EdgeArrayIterator
override ReverseIterator : unit -> EdgeArrayIterator

Return Value

EdgeArrayIterator
Returns a backward moving iterator to the array.
See Also

Reference

EdgeArray Class


EdgeArrayArray Class

An array of edge arrays.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBEdgeArrayArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class EdgeArrayArray : APIObject,
    IEnumerable
Public Class EdgeArrayArray
    Inherits APIObject
    Implements IEnumerable
public ref class EdgeArrayArray : public APIObject,
    IEnumerable
type EdgeArrayArray =
    class
        inherit APIObject
        interface IEnumerable
    end

The EdgeArrayArray type exposes the following members.

Constructors
 | Name | Description
Public method | EdgeArrayArray | Initializes a new instance of the EdgeArrayArray class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets an edge array at a specified index within the array.
Public property | Size | Returns the number of edge arrays that are in the array.
Top
Methods
 | Name | Description
Public method | Append | Add the edge array to the end of the array.
Public method | Clear | Removes every edge array from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified edge array into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Example
C#
VB
C++
F#
Copy
public void GetEdgeArrayArray(Autodesk.Revit.ApplicationServices.Application app, Autodesk.Revit.DB.Element element)
{
    // Get geometry element of the selected element
    Options geoOptions = app.Create.NewGeometryOptions();
    Autodesk.Revit.DB.GeometryElement geoElement = element.get_Geometry(geoOptions);
    // Get geometry object
    foreach (GeometryObject o in geoElement)
    {
        Solid solid = o as Solid;
        if (null != solid)
        {
            foreach (Face face in solid.Faces)
            {
                if (face != null)
                {
                    EdgeArrayArray edgeArrays = face.EdgeLoops;
                    foreach (EdgeArray edges in edgeArrays)
                    {
                        foreach (Edge edge in edges)
                        {
                            // Get one test point
                            XYZ testPoint = edge.Evaluate(0.5);
                            string edgeInfo = string.Format("Point on edge: ({0},{1},{2})", testPoint.X, testPoint.Y, testPoint.Z);
                            TaskDialog.Show("Revit",edgeInfo);
                        }
                    }
                }
            }
        }
    }
}
Public Sub GetEdgeArrayArray(app As Autodesk.Revit.ApplicationServices.Application, element As Autodesk.Revit.DB.Element)
    ' Get geometry element of the selected element
    Dim geoOptions As Options = app.Create.NewGeometryOptions()
    Dim geoElement As Autodesk.Revit.DB.GeometryElement = element.Geometry(geoOptions)
    ' Get geometry object
    For Each o As GeometryObject In geoElement
        Dim solid As Solid = TryCast(o, Solid)
        If solid IsNot Nothing Then
            For Each face As Face In solid.Faces
                If face IsNot Nothing Then
                    Dim edgeArrays As EdgeArrayArray = face.EdgeLoops
                    For Each edges As EdgeArray In edgeArrays
                        For Each edge As Edge In edges
                            ' Get one test point
                            Dim testPoint As XYZ = edge.Evaluate(0.5)
                            Dim edgeInfo As String = String.Format("Point on edge: ({0},{1},{2})", testPoint.X, testPoint.Y, testPoint.Z)
                            TaskDialog.Show("Revit", edgeInfo)
                        Next
                    Next
                End If
            Next
        End If
    Next
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


EdgeArrayArray Constructor

Initializes a new instance of the EdgeArrayArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EdgeArrayArray()
Public Sub New
public:
EdgeArrayArray()
new : unit -> EdgeArrayArray
See Also

Reference

EdgeArrayArray Class


EdgeArrayArray Properties

The EdgeArrayArray type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets an edge array at a specified index within the array.
Public property | Size | Returns the number of edge arrays that are in the array.
Top
See Also

Reference

EdgeArrayArray Class


EdgeArrayArray.IsEmpty Property

EdgeArrayArrayIsEmpty Property

Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Boolean
Remarks
If the array is empty then True will be returned, otherwise False.
See Also

Reference

EdgeArrayArray Class


EdgeArrayArray.Item Property

EdgeArrayArrayItem Property

Gets or sets an edge array at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual EdgeArray this[
    int index
] { get; set; }
Public Overridable Property Item (
    index As Integer
) As EdgeArray
    Get
    Set
public:
virtual property EdgeArray^ Item[int index] {
    EdgeArray^ get (int index);
    void set (int index, EdgeArray^ value);
}
abstract Item : EdgeArray with get, set
override Item : EdgeArray with get, set

Parameters

index Int32
The index of the edge array to be set or retrieved.

Return Value

EdgeArray
Returns the edge array at the specified index.
See Also

Reference

EdgeArrayArray Class


EdgeArrayArray.Size Property

EdgeArrayArraySize Property

Returns the number of edge arrays that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
abstract Size : int with get
override Size : int with get

Property Value

Int32
See Also

Reference

EdgeArrayArray Class


EdgeArrayArray Methods

The EdgeArrayArray type exposes the following members.

Methods
 | Name | Description
Public method | Append | Add the edge array to the end of the array.
Public method | Clear | Removes every edge array from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified edge array into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

EdgeArrayArray Class


EdgeArrayArray.Append Method

EdgeArrayArrayAppend Method

Add the edge array to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Append(
    EdgeArray item
)
Public Overridable Sub Append (
    item As EdgeArray
)
public:
virtual void Append(
    EdgeArray^ item
)
abstract Append :
        item : EdgeArray -> unit
override Append :
        item : EdgeArray -> unit

Parameters

item EdgeArray
The edge array to be added.
See Also

Reference

EdgeArrayArray Class


EdgeArrayArray.Clear Method

EdgeArrayArrayClear Method

Removes every edge array from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

EdgeArrayArray Class


EdgeArrayArray.ForwardIterator Method

EdgeArrayArrayForwardIterator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual EdgeArrayArrayIterator ForwardIterator()
Public Overridable Function ForwardIterator As EdgeArrayArrayIterator
public:
virtual EdgeArrayArrayIterator^ ForwardIterator()
abstract ForwardIterator : unit -> EdgeArrayArrayIterator
override ForwardIterator : unit -> EdgeArrayArrayIterator

Return Value

EdgeArrayArrayIterator
Returns a forward moving iterator to the array.
See Also

Reference

EdgeArrayArray Class


EdgeArrayArray.GetEnumerator Method

EdgeArrayArrayGetEnumerator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

IEnumerator
Returns a forward moving iterator to the array.

Implements

IEnumerableGetEnumerator
See Also

Reference

EdgeArrayArray Class


EdgeArrayArray.Insert Method

EdgeArrayArrayInsert Method

Insert the specified edge array into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Insert(
    EdgeArray item,
    int index
)
Public Overridable Sub Insert (
    item As EdgeArray,
    index As Integer
)
public:
virtual void Insert(
    EdgeArray^ item,
    int index
)
abstract Insert :
        item : EdgeArray *
        index : int -> unit
override Insert :
        item : EdgeArray *
        index : int -> unit

Parameters

item EdgeArray
The edge array to be inserted into the array.
index Int32
The edge array will be inserted before this index.

Return Value

Returns whether the edge array was inserted into the array.
See Also

Reference

EdgeArrayArray Class


EdgeArrayArray.ReverseIterator Method

EdgeArrayArrayReverseIterator Method

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual EdgeArrayArrayIterator ReverseIterator()
Public Overridable Function ReverseIterator As EdgeArrayArrayIterator
public:
virtual EdgeArrayArrayIterator^ ReverseIterator()
abstract ReverseIterator : unit -> EdgeArrayArrayIterator
override ReverseIterator : unit -> EdgeArrayArrayIterator

Return Value

EdgeArrayArrayIterator
Returns a backward moving iterator to the array.
See Also

Reference

EdgeArrayArray Class


EdgeArrayArrayIterator Class

An iterator to an array or edge arrays.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBEdgeArrayArrayIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class EdgeArrayArrayIterator : APIObject,
    IEnumerator
Public MustInherit Class EdgeArrayArrayIterator
    Inherits APIObject
    Implements IEnumerator
public ref class EdgeArrayArrayIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type EdgeArrayArrayIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The EdgeArrayArrayIterator type exposes the following members.

Constructors
 | Name | Description
Public method | EdgeArrayArrayIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


EdgeArrayArrayIterator Constructor

For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EdgeArrayArrayIterator()
Public Sub New
public:
EdgeArrayArrayIterator()
new : unit -> EdgeArrayArrayIterator
Remarks
This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.
See Also

Reference

EdgeArrayArrayIterator Class


EdgeArrayArrayIterator Properties

The EdgeArrayArrayIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

EdgeArrayArrayIterator Class


EdgeArrayArrayIterator.Current Property

EdgeArrayArrayIteratorCurrent Property

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}
abstract Current : Object with get
override Current : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.
See Also

Reference

EdgeArrayArrayIterator Class


EdgeArrayArrayIterator Methods

The EdgeArrayArrayIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

EdgeArrayArrayIterator Class


EdgeArrayArrayIterator.MoveNext Method

EdgeArrayArrayIteratorMoveNext Method

Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumeratorMoveNext
Remarks
MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.
See Also

Reference

EdgeArrayArrayIterator Class


EdgeArrayArrayIterator.Reset Method

EdgeArrayArrayIteratorReset Method

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
Remarks
The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.
See Also

Reference

EdgeArrayArrayIterator Class


EdgeArrayIterator Class

An iterator to an edge array.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBEdgeArrayIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class EdgeArrayIterator : APIObject,
    IEnumerator
Public MustInherit Class EdgeArrayIterator
    Inherits APIObject
    Implements IEnumerator
public ref class EdgeArrayIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type EdgeArrayIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The EdgeArrayIterator type exposes the following members.

Constructors
 | Name | Description
Public method | EdgeArrayIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


EdgeArrayIterator Constructor

For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EdgeArrayIterator()
Public Sub New
public:
EdgeArrayIterator()
new : unit -> EdgeArrayIterator
Remarks
This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.
See Also

Reference

EdgeArrayIterator Class


EdgeArrayIterator Properties

The EdgeArrayIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

EdgeArrayIterator Class


EdgeArrayIterator.Current Property

EdgeArrayIteratorCurrent Property

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}
abstract Current : Object with get
override Current : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.
See Also

Reference

EdgeArrayIterator Class


EdgeArrayIterator Methods

The EdgeArrayIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

EdgeArrayIterator Class


EdgeArrayIterator.MoveNext Method

EdgeArrayIteratorMoveNext Method

Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumeratorMoveNext
Remarks
MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.
See Also

Reference

EdgeArrayIterator Class


EdgeArrayIterator.Reset Method

EdgeArrayIteratorReset Method

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
Remarks
The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.
See Also

Reference

EdgeArrayIterator Class


EdgeEndPoint Class

Represents the start or the end point of an Edge.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBEdgeEndPoint

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class EdgeEndPoint : IDisposable
Public Class EdgeEndPoint
    Implements IDisposable
public ref class EdgeEndPoint : IDisposable
type EdgeEndPoint =
    class
        interface IDisposable
    end

The EdgeEndPoint type exposes the following members.

Constructors
 | Name | Description
Public method | EdgeEndPoint | Constructs an instance of EdgeEndPoint.
Top
Properties
 | Name | Description
Public property | Edge | The Edge.
Public property | Index | The index of the start or the end point of an Edge: 0 is the start point, 1 is the end point.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the EdgeEndPoint
Public method | Equals(EdgeEndPoint) | Determines whether this EdgeEndPoint is equal to another.
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Evaluate | Evaluate the end point of the edge in 3d coordinates.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


EdgeEndPoint Constructor

Constructs an instance of EdgeEndPoint.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EdgeEndPoint(
    Edge edge,
    int index
)
Public Sub New (
    edge As Edge,
    index As Integer
)
public:
EdgeEndPoint(
    Edge^ edge,
    int index
)
new :
        edge : Edge *
        index : int -> EdgeEndPoint

Parameters

edge Edge
The Edge.
index Int32
Use 0 for the start point, 1 for the end point of an Edge.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | The given value for index is not 0 or 1.
See Also

Reference

EdgeEndPoint Class


EdgeEndPoint Properties

The EdgeEndPoint type exposes the following members.

Properties
 | Name | Description
Public property | Edge | The Edge.
Public property | Index | The index of the start or the end point of an Edge: 0 is the start point, 1 is the end point.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

EdgeEndPoint Class


EdgeEndPoint.Edge Property

EdgeEndPointEdge Property

The Edge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Edge Edge { get; }
Public ReadOnly Property Edge As Edge
    Get
public:
property Edge^ Edge {
    Edge^ get ();
}
member Edge : Edge with get

Property Value

Edge
See Also

Reference

EdgeEndPoint Class


EdgeEndPoint.Index Property

EdgeEndPointIndex Property

The index of the start or the end point of an Edge: 0 is the start point, 1 is the end point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get
public:
property int Index {
    int get ();
}
member Index : int with get

Property Value

Int32
See Also

Reference

EdgeEndPoint Class


EdgeEndPoint.IsValidObject Property

EdgeEndPointIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

EdgeEndPoint Class


EdgeEndPoint Methods

The EdgeEndPoint type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals(EdgeEndPoint) | Determines whether this EdgeEndPoint is equal to another.
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Evaluate | Evaluate the end point of the edge in 3d coordinates.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

EdgeEndPoint Class


EdgeEndPoint.Dispose Method

EdgeEndPointDispose Method

Releases all resources used by the EdgeEndPoint

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

EdgeEndPoint Class


EdgeEndPoint.Equals Method

EdgeEndPointEquals Method

Overload List
 | Name | Description
Public method | Equals(EdgeEndPoint) | Determines whether this EdgeEndPoint is equal to another.
Public method | Equals(Object) | Determines whether the specified object is equal to the current object.
Top
See Also

Reference

EdgeEndPoint Class


EdgeEndPoint.Equals(EdgeEndPoint) Method

EdgeEndPointEquals(EdgeEndPoint) Method

Determines whether this EdgeEndPoint is equal to another.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    EdgeEndPoint other
)
Public Function Equals (
    other As EdgeEndPoint
) As Boolean
public:
bool Equals(
    EdgeEndPoint^ other
)
member Equals :
        other : EdgeEndPoint -> bool

Parameters

other EdgeEndPoint
The EdgeEndPoint with which to compare this EdgeEndPoint.

Return Value

Boolean
True if the given EdgeEndPoint is equal to this one, otherwise false.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

EdgeEndPoint Class
Equals Overload


EdgeEndPoint.Evaluate Method

EdgeEndPointEvaluate Method

Evaluate the end point of the edge in 3d coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Evaluate()
Public Function Evaluate As XYZ
public:
XYZ^ Evaluate()
member Evaluate : unit -> XYZ

Return Value

XYZ
The end point of the edge in 3d coordinates.
Exceptions
Exception | Condition
InvalidOperationException | Failed to evaluate the end point of the edge.
See Also

Reference

EdgeEndPoint Class


EditScope Class

The base class for a scope object that provides special access and limitations related to editing certain elements.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBEditScope
Autodesk.Revit.DB.ArchitectureTopographyEditScope
Autodesk.Revit.DBSketchEditScope
Autodesk.Revit.DBStairsEditScope

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class EditScope : IDisposable
Public Class EditScope
    Implements IDisposable
public ref class EditScope : IDisposable
type EditScope =
    class
        interface IDisposable
    end

The EditScope type exposes the following members.

Properties
 | Name | Description
Public property | IsActive | Tells if the EditScope is active. In other words, the EditScope has started but not committed/canceled yet.
Public property | IsPermitted | Tells if the edit scope is permitted to start.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Cancel | Cancels the edit scope.
Public method | Commit | Finishes the edit scope.
Public method | Dispose | Releases all resources used by the EditScope
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Derivations of this class provide specific functionality to manage edit modes for specific purposes.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


EditScope Properties

The EditScope type exposes the following members.

Properties
 | Name | Description
Public property | IsActive | Tells if the EditScope is active. In other words, the EditScope has started but not committed/canceled yet.
Public property | IsPermitted | Tells if the edit scope is permitted to start.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

EditScope Class


EditScope.IsActive Property

EditScopeIsActive Property

Tells if the EditScope is active. In other words, the EditScope has started but not committed/canceled yet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsActive { get; }
Public ReadOnly Property IsActive As Boolean
    Get
public:
property bool IsActive {
    bool get ();
}
member IsActive : bool with get

Property Value

Boolean
Remarks
Starting the edit scope is not permitted when it is active. Canceling/committing is not allowed when the edit scope is not active.
See Also

Reference

EditScope Class


EditScope.IsPermitted Property

EditScopeIsPermitted Property

Tells if the edit scope is permitted to start.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsPermitted { get; }
Public ReadOnly Property IsPermitted As Boolean
    Get
public:
property bool IsPermitted {
    bool get ();
}
member IsPermitted : bool with get

Property Value

Boolean
Remarks
The edit scope is not permitted to start for one of the following possible reasons: The document is in read-only state, or the document is currently modifiable, or there already is another edit mode active in the document.
See Also

Reference

EditScope Class


EditScope.IsValidObject Property

EditScopeIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

EditScope Class


EditScope Methods

The EditScope type exposes the following members.

Methods
 | Name | Description
Public method | Cancel | Cancels the edit scope.
Public method | Commit | Finishes the edit scope.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

EditScope Class


EditScope.Cancel Method

EditScopeCancel Method

Cancels the edit scope.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Cancel()
Public Sub Cancel
public:
void Cancel()
member Cancel : unit -> unit
Exceptions
Exception | Condition
InvalidOperationException | EditScope is not active. EditScope can only be committed or cancelled when it is active. -or- EditScope cannot be closed, for there is a transaction or transaction group still open in the document.
Remarks
All the changes made after starting the EditScope will be rolled back.
See Also

Reference

EditScope Class


EditScope.Commit Method

EditScopeCommit Method

Finishes the edit scope.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Commit(
    IFailuresPreprocessor failurePreprocessor
)
Public Sub Commit (
    failurePreprocessor As IFailuresPreprocessor
)
public:
void Commit(
    IFailuresPreprocessor^ failurePreprocessor
)
member Commit :
        failurePreprocessor : IFailuresPreprocessor -> unit

Parameters

failurePreprocessor IFailuresPreprocessor
Callback to be invoked in the beginning of failure processing.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | EditScope is not active. EditScope can only be committed or cancelled when it is active. -or- EditScope cannot be closed, for there is a transaction or transaction group still open in the document.
Remarks
All the changes made after starting the EditScope will be committed. Changes will be merged into one transaction.
See Also

Reference

EditScope Class


EditScope.Dispose Method

EditScopeDispose Method

Releases all resources used by the EditScope

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

EditScope Class


Element Class

Base class for most persistent data within a Revit document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Element : IDisposable
Public Class Element
    Implements IDisposable
public ref class Element : IDisposable
type Element =
    class
        interface IDisposable
    end

The Element type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs.
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides.
 | CreatedPhaseId | Id of a Phase at which the Element was created.
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished.
 | DesignOption | Returns the design option to which the element belongs.
Public property | Document | Returns the Document in which the Element resides.
 | Geometry | Retrieves the geometric representation of the element.
Public property | GroupId | The id of the group to which an element belongs.
 | Id | A unique identifier for an Element in an Autodesk Revit project.
Public property | IsModifiable | Identifies if the element is modifiable.
Public property | IsTransient | Indicates whether an element is transient or permanent.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LevelId | The id of the level associated with the element.
 | Location | This property is used to find the physical location of an element within a project.
Public property | Name | A human readable name for the Element.
Public property | OwnerViewId | The id of the view that owns the element.
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id.
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition.
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter.
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element.
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element.
Public property | Pinned | Identifies if the element has been pinned to prevent changes.
 | UniqueId | A stable unique identifier for an element within the document.
Public property | VersionGuid | Get the element version Guid.
Public property | ViewSpecific | Identifies if the element is owned by a view.
Public property | WorksetId | Get Id of the Workset which owns the element.
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element.
Public method | CanBeHidden | Indicates if the element can be hidden in the view.
Public method | CanBeLocked | Identifies if the element can be locked.
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element.
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned.
 | CanHaveTypeAssigned(Document, ICollectionElementId) | Checks if all elements in the set can have a type assigned.
Public method | ChangeTypeId(ElementId) | Changes the type of the element.
 | ChangeTypeId(Document, ICollectionElementId, ElementId) | Changes the type of all elements in the given set.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element
Public method | DeleteSubelement | Removes a subelement from the element.
Public method | DeleteSubelements | Removes the subelements from the element.
Public method | Dispose | Releases all resources used by the Element
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element.
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set.
 | GetChangeTypeAny | Returns ChangeType associated with any change in an element.
 | GetChangeTypeElementAddition | Returns ChangeType associated with element addition
 | GetChangeTypeElementDeletion | Returns ChangeType associated with element deletion.
 | GetChangeTypeGeometry | Returns ChangeType associated with a change in the geometry of an element
 | GetChangeTypeParameter(ElementId) | Returns ChangeType associated with a change in a parameter's value
 | GetChangeTypeParameter(Parameter) | Returns ChangeType associated with a change in a parameter's value
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise.
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element.
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element.
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type.
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type.
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element.
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element.
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object.
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id.
Public method | GetMaterialIds | Gets the element ids of all materials present in the element.
Public method | GetMaterialVolume | Gets the volume of the material with the given id.
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring.
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring.
Public method | GetOrderedParameters | Gets the parameters associated to the element in order.
Public method | GetParameter | Retrieves a parameter from the element given identifier.
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists.
Public method | GetParameters | Retrieves the parameters from the element via the given name.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase
Public method | GetSubelements | Returns the collection of element subelements.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type.
Public method | GetValidTypes | Obtains a set of types that are valid for this element.
 | GetValidTypes(Document, ICollectionElementId) | Obtains a set of types that are valid for all given elements.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order.
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order.
Public method | IsExternalFileReference | Determines whether this Element represents an external file.
Public method | IsHidden | Identifies if the element has been permanently hidden in the view.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models.
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element.
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element.
 | IsValidType(Document, ICollectionElementId, ElementId) | Checks if given type is valid for the set of elements.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name.
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type.
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The data in a Revit document consists primarily of a collection of elements. An element usually corresponds to a single component of a building or drawing, such as a wall, door, or dimension, but it can also be something more abstract, like a wall type or a view. Every element in a document has a unique ID, represented by the ElementId class.
See Also

Reference

Autodesk.Revit.DB Namespace
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DB.AnalysisAnalysisDisplayLegend
Autodesk.Revit.DB.AnalysisAnalysisDisplayStyle
Autodesk.Revit.DB.AnalysisBuildingOperatingDaySchedule
Autodesk.Revit.DB.AnalysisBuildingOperatingYearSchedule
Autodesk.Revit.DB.AnalysisConceptualSurfaceType
Autodesk.Revit.DB.AnalysisEnergyAnalysisConstruction
Autodesk.Revit.DB.AnalysisEnergyAnalysisDetailModel
Autodesk.Revit.DB.AnalysisEnergyAnalysisMaterial
Autodesk.Revit.DB.AnalysisEnergyAnalysisOpening
Autodesk.Revit.DB.AnalysisEnergyAnalysisSpace
Autodesk.Revit.DB.AnalysisEnergyAnalysisSurface
Autodesk.Revit.DB.AnalysisEnergyAnalysisWindowType
Autodesk.Revit.DB.AnalysisEnergyAnalysisZone
Autodesk.Revit.DB.AnalysisEnergyDataSettings
Autodesk.Revit.DB.AnalysisGenericZone
Autodesk.Revit.DB.AnalysisHVACLoadType
Autodesk.Revit.DB.AnalysisMassLevelData
Autodesk.Revit.DB.AnalysisMassSurfaceData
Autodesk.Revit.DB.AnalysisPathOfTravel
Autodesk.Revit.DB.AnalysisRouteAnalysisSettings
Autodesk.Revit.DB.AnalysisSpatialFieldManager
Autodesk.Revit.DBAppearanceAssetElement
Autodesk.Revit.DB.ArchitectureContinuousRail
Autodesk.Revit.DB.ArchitectureMultistoryStairs
Autodesk.Revit.DB.ArchitectureRailing
Autodesk.Revit.DB.ArchitectureStairs
Autodesk.Revit.DB.ArchitectureStairsLanding
Autodesk.Revit.DB.ArchitectureStairsPath
Autodesk.Revit.DB.ArchitectureStairsRun
Autodesk.Revit.DB.ArchitectureTopographySurface
Autodesk.Revit.DBAreaScheme
Autodesk.Revit.DBAreaVolumeSettings
Autodesk.Revit.DBAssemblyInstance
Autodesk.Revit.DBBaseArray
Autodesk.Revit.DBBasePoint
Autodesk.Revit.DBBeamSystem
Autodesk.Revit.DBColorFillLegend
Autodesk.Revit.DBColorFillScheme
Autodesk.Revit.DBCombinableElement
Autodesk.Revit.DBComponentRepeater
Autodesk.Revit.DBComponentRepeaterSlot
Autodesk.Revit.DBConnectorElement
Autodesk.Revit.DBControl
Autodesk.Revit.DBCurveElement
Autodesk.Revit.DBDatumPlane
Autodesk.Revit.DBDefaultDivideSettings
Autodesk.Revit.DBDesignOption
Autodesk.Revit.DBDimension
Autodesk.Revit.DBDirectShape
Autodesk.Revit.DBDisplacementElement
Autodesk.Revit.DBDisplacementPath
Autodesk.Revit.DBDividedPath
Autodesk.Revit.DBDividedSurface
Autodesk.Revit.DB.ElectricalAreaBasedLoadType
Autodesk.Revit.DB.ElectricalCableTrayConduitRunBase
Autodesk.Revit.DB.ElectricalCableTraySettings
Autodesk.Revit.DB.ElectricalCableTraySizes
Autodesk.Revit.DB.ElectricalCircuitNamingScheme
Autodesk.Revit.DB.ElectricalCircuitNamingSchemeSettings
Autodesk.Revit.DB.ElectricalConduitSettings
Autodesk.Revit.DB.ElectricalConduitSizeSettings
Autodesk.Revit.DB.ElectricalElectricalAnalyticalLoadSet
Autodesk.Revit.DB.ElectricalElectricalAnalyticalNode
Autodesk.Revit.DB.ElectricalElectricalDemandFactorDefinition
Autodesk.Revit.DB.ElectricalElectricalLoadClassification
Autodesk.Revit.DB.ElectricalElectricalSetting
Autodesk.Revit.DB.ElectricalPanelScheduleSheetInstance
Autodesk.Revit.DB.ElectricalPanelScheduleTemplate
Autodesk.Revit.DBElementType
Autodesk.Revit.DBElevationMarker
Autodesk.Revit.DBExportDGNSettings
Autodesk.Revit.DBExportDWGSettings
Autodesk.Revit.DBExportPDFSettings
Autodesk.Revit.DB.ExtensibleStorageDataStorage
Autodesk.Revit.DBFabricationConfiguration
Autodesk.Revit.DBFabricationPart
Autodesk.Revit.DBFabricationServiceSettings
Autodesk.Revit.DBFaceSplitter
Autodesk.Revit.DBFamily
Autodesk.Revit.DBFilledRegion
Autodesk.Revit.DBFillPatternElement
Autodesk.Revit.DBFilterElement
Autodesk.Revit.DBGraphicsStyle
Autodesk.Revit.DBGroup
Autodesk.Revit.DBHostObject
Autodesk.Revit.DBIFCCategoryTemplate
Autodesk.Revit.DBImageInstance
Autodesk.Revit.DBIndependentTag
Autodesk.Revit.DBInstance
Autodesk.Revit.DBInternalOrigin
Autodesk.Revit.DBKeyBasedTreeEntryTable
Autodesk.Revit.DBLinePatternElement
Autodesk.Revit.DBMaterial
Autodesk.Revit.DB.MechanicalDuctSettings
Autodesk.Revit.DB.MechanicalDuctSizeSettings
Autodesk.Revit.DB.MechanicalMechanicalEquipmentSet
Autodesk.Revit.DB.MechanicalMEPAnalyticalSystem
Autodesk.Revit.DB.MechanicalMEPHiddenLineSettings
Autodesk.Revit.DB.MechanicalZone
Autodesk.Revit.DB.MechanicalZoneEquipment
Autodesk.Revit.DBMEPSystem
Autodesk.Revit.DBModelText
Autodesk.Revit.DBMultipleValuesIndicationSettings
Autodesk.Revit.DBMultiReferenceAnnotation
Autodesk.Revit.DBMultiSegmentGrid
Autodesk.Revit.DBNestedFamilyTypeReference
Autodesk.Revit.DBNumberingSchema
Autodesk.Revit.DBNumberSystem
Autodesk.Revit.DBOpening
Autodesk.Revit.DBParameterElement
Autodesk.Revit.DBPart
Autodesk.Revit.DBPartMaker
Autodesk.Revit.DBPhase
Autodesk.Revit.DBPhaseFilter
Autodesk.Revit.DB.PlumbingPipeSettings
Autodesk.Revit.DBPrintSetting
Autodesk.Revit.DBProjectInfo
Autodesk.Revit.DBPropertyLine
Autodesk.Revit.DBPropertySetElement
Autodesk.Revit.DBReferencePoint
Autodesk.Revit.DBRevision
Autodesk.Revit.DBRevisionCloud
Autodesk.Revit.DBRevisionNumberingSequence
Autodesk.Revit.DBRevisionSettings
Autodesk.Revit.DBScheduleSheetInstance
Autodesk.Revit.DBSegment
Autodesk.Revit.DBSheetCollection
Autodesk.Revit.DBSketchBase
Autodesk.Revit.DBSketchPlane
Autodesk.Revit.DBSpatialElement
Autodesk.Revit.DBSpatialElementCalculationLocation
Autodesk.Revit.DBSpatialElementTag
Autodesk.Revit.DBSSEPointVisibilitySettings
Autodesk.Revit.DBStartingViewSettings
Autodesk.Revit.DB.StructureAnalyticalElement
Autodesk.Revit.DB.StructureAnalyticalLink
Autodesk.Revit.DB.StructureAnalyticalToPhysicalAssociationManager
Autodesk.Revit.DB.StructureAreaReinforcement
Autodesk.Revit.DB.StructureBoundaryConditions
Autodesk.Revit.DB.StructureFabricArea
Autodesk.Revit.DB.StructureFabricSheet
Autodesk.Revit.DB.StructureHub
Autodesk.Revit.DB.StructureLoadBase
Autodesk.Revit.DB.StructureLoadCase
Autodesk.Revit.DB.StructureLoadCombination
Autodesk.Revit.DB.StructureLoadNature
Autodesk.Revit.DB.StructureLoadUsage
Autodesk.Revit.DB.StructurePathReinforcement
Autodesk.Revit.DB.StructureRebar
Autodesk.Revit.DB.StructureRebarContainer
Autodesk.Revit.DB.StructureRebarCoupler
Autodesk.Revit.DB.StructureRebarInSystem
Autodesk.Revit.DB.StructureReinforcementSettings
Autodesk.Revit.DB.StructureStructuralConnectionHandler
Autodesk.Revit.DB.StructureStructuralConnectionSettings
Autodesk.Revit.DB.StructureStructuralSettings
Autodesk.Revit.DB.StructureTruss
Autodesk.Revit.DBSunAndShadowSettings
Autodesk.Revit.DBTextElement
Autodesk.Revit.DBView
Autodesk.Revit.DBViewNavigationToolSettings
Autodesk.Revit.DBViewport
Autodesk.Revit.DBViewSheetSet
Autodesk.Revit.DBWorksetDefaultVisibilitySettings
Autodesk.Revit.DBWorksharingDisplaySettings


Element Properties

The Element type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs.
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides.
 | CreatedPhaseId | Id of a Phase at which the Element was created.
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished.
 | DesignOption | Returns the design option to which the element belongs.
Public property | Document | Returns the Document in which the Element resides.
 | Geometry | Retrieves the geometric representation of the element.
Public property | GroupId | The id of the group to which an element belongs.
 | Id | A unique identifier for an Element in an Autodesk Revit project.
Public property | IsModifiable | Identifies if the element is modifiable.
Public property | IsTransient | Indicates whether an element is transient or permanent.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LevelId | The id of the level associated with the element.
 | Location | This property is used to find the physical location of an element within a project.
Public property | Name | A human readable name for the Element.
Public property | OwnerViewId | The id of the view that owns the element.
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id.
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition.
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter.
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element.
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element.
Public property | Pinned | Identifies if the element has been pinned to prevent changes.
 | UniqueId | A stable unique identifier for an element within the document.
Public property | VersionGuid | Get the element version Guid.
Public property | ViewSpecific | Identifies if the element is owned by a view.
Public property | WorksetId | Get Id of the Workset which owns the element.
Top
See Also

Reference

Element Class


Element.AssemblyInstanceId Property

ElementAssemblyInstanceId Property

The id of the assembly instance to which the element belongs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId AssemblyInstanceId { get; }
Public ReadOnly Property AssemblyInstanceId As ElementId
    Get
public:
property ElementId^ AssemblyInstanceId {
    ElementId^ get ();
}
member AssemblyInstanceId : ElementId with get

Property Value

ElementId
See Also

Reference

Element Class


Element.BoundingBox Property

ElementBoundingBox Property

Retrieves a box that circumscribes all geometry of the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BoundingBoxXYZ this[
    View A_0
] { get; }
Public ReadOnly Property BoundingBox (
    A_0 As View
) As BoundingBoxXYZ
    Get
public:
property BoundingBoxXYZ^ BoundingBox[View^ A_0] {
    BoundingBoxXYZ^ get (View^ A_0);
}
member BoundingBox : BoundingBoxXYZ with get

Parameters

A_0 View

Property Value

BoundingBoxXYZ
Remarks
Pass in a view to query view-specific (e.g., cut) geometry or for model geometry. If the view box is not known or cannot be calculated, this will return the model box; if the model box is not known, this will return . The box will always be aligned to the default axes of the model coordinate system (thus no rotation should be applied to the return value). Also note that this bounding box volume may enclose geometry that is not obvious. For example, the "flip controls" that could be part of a family will be included in the computation of the bounding box even though they are not always visible in the family instance of the family.
Example
C#
VB
C++
F#
Copy
private void GetElementBoundingBox(Autodesk.Revit.DB.Document document, Autodesk.Revit.DB.Element element)
{
    // Get the BoundingBox instance for current view.
    BoundingBoxXYZ box = element.get_BoundingBox(document.ActiveView);
    if (null == box)
    {
        throw new Exception("Selected element doesn't contain a bounding box.");
    }

    string info = "Bounding box is enabled: " + box.Enabled.ToString();

    // Give the user some information.
    TaskDialog.Show("Revit",info);
}
Private Sub GetElementBoundingBox(document As Autodesk.Revit.DB.Document, element As Autodesk.Revit.DB.Element)
    ' Get the BoundingBox instance for current view.
    Dim box As BoundingBoxXYZ = element.BoundingBox(document.ActiveView)
    If box Is Nothing Then
        Throw New Exception("Selected element doesn't contain a bounding box.")
    End If

    Dim info As String = "Bounding box is enabled: " & box.Enabled.ToString()

    ' Give the user some information.
    TaskDialog.Show("Revit", info)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Element Class


Element.Category Property

ElementCategory Property

Retrieves a Category object that represents the category or sub category in which the element resides.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Category Category { get; }
Public ReadOnly Property Category As Category
    Get
public:
property Category^ Category {
    Category^ get ();
}
member Category : Category with get

Property Value

Category
Remarks
All category objects can be retrieved from the application by using the Categories property of the Application.Settings object.
See Also

Reference

Element Class


Element.CreatedPhaseId Property

ElementCreatedPhaseId Property

Id of a Phase at which the Element was created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId CreatedPhaseId { get; set; }
Public Property CreatedPhaseId As ElementId
    Get
    Set
public:
property ElementId^ CreatedPhaseId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member CreatedPhaseId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentException | When setting this property: The element does not allow setting the property CreatedPhaseId to the value of createdPhaseId. -or- When setting this property: Invalid order of phases: An object cannot be demolished before it was created.
ArgumentNullException | When setting this property: A non-optional argument was null
InvalidOperationException | When setting this property: The element does not have properties CreatedPhaseId and DemolishedPhaseId. -or- When setting this property: The element does not allow setting the properties CreatedPhaseId and DemolishedPhaseId.
Remarks

After setting the property CreatedPhaseId, regeneration can fail if CreatedPhaseId and DemolishedPhaseId are out of order with respect to their index in the property Document.Phases.

When Revit is running with UI activated, the default created phase for newly created elements is inherited from the phase of the currently active view.

When Revit is running without its UI, such as when Revit runs on Autodesk Forge Design Automation API for Revit, the default CreatedPhaseId for newly created elements is the latest phase in Autodesk::Revit::DB::Document::Phases.

Example
C#
VB
C++
F#
Copy
void ShowPhaseCreatedName(Element element)
{
    // Get the Phase Create property, and assert it should not be null
    Autodesk.Revit.DB.Phase phaseCreated = element.Document.GetElement(element.CreatedPhaseId) as Phase;
    if (null == phaseCreated)
    {
        throw new Exception("Elements always have a phase for when they are created.");
    }
    else
    {
        // Show the Phase Create name to the user.
        String prompt = "The phase created is: " + phaseCreated.Name;
        TaskDialog.Show("Revit",prompt);
    }
}
Private Sub ShowPhaseCreatedName(element As Element)
    ' Get the Phase Create property, and assert it should not be null
    Dim phaseCreated As Autodesk.Revit.DB.Phase = TryCast(element.Document.GetElement(element.CreatedPhaseId), Phase)
    If phaseCreated Is Nothing Then
        Throw New Exception("Elements always have a phase for when they are created.")
    Else
        ' Show the Phase Create name to the user.
        Dim prompt As [String] = "The phase created is: " + phaseCreated.Name
        TaskDialog.Show("Revit", prompt)
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Element Class


Element.DemolishedPhaseId Property

ElementDemolishedPhaseId Property

Id of a Phase at which the Element was demolished.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId DemolishedPhaseId { get; set; }
Public Property DemolishedPhaseId As ElementId
    Get
    Set
public:
property ElementId^ DemolishedPhaseId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member DemolishedPhaseId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentException | When setting this property: The element does not allow setting the property DemolishedPhaseId to the value of demolishedPhaseId. -or- When setting this property: Invalid order of phases: An object cannot be demolished before it was created.
ArgumentNullException | When setting this property: A non-optional argument was null
InvalidOperationException | When setting this property: The element does not have properties CreatedPhaseId and DemolishedPhaseId. -or- When setting this property: The element does not allow setting the properties CreatedPhaseId and DemolishedPhaseId.
Remarks
After setting the property, DemolishedPhaseId regeneration can fail if CreatedPhaseId and DemolishedPhaseId are out of order with respect to their index in the property Document.Phases. Can be set to invalid element id.
Example
C#
VB
C++
F#
Copy
void ShowPhaseDemolishedName(Element element)
{
    // Get the Phase Demolished property, and check whether it be null
    Autodesk.Revit.DB.Phase phaseDemolished = element.Document.GetElement(element.DemolishedPhaseId) as Phase;
    if (null == phaseDemolished)
    {
        TaskDialog.Show("Revit","This Element doesn't have Phase Demolished parameter.");
    }
    else
    {
        // Show the Phase Demolished name to the user.
        String prompt = "The phase demolished is: " + phaseDemolished.Name;
        TaskDialog.Show("Revit",prompt);
    }
}
Private Sub ShowPhaseDemolishedName(element As Element)
    ' Get the Phase Demolished property, and check whether it be null
    Dim phaseDemolished As Autodesk.Revit.DB.Phase = TryCast(element.Document.GetElement(element.DemolishedPhaseId), Phase)
    If phaseDemolished Is Nothing Then
        TaskDialog.Show("Revit", "This Element doesn't have Phase Demolished parameter.")
    Else
        ' Show the Phase Demolished name to the user.
        Dim prompt As [String] = "The phase demolished is: " + phaseDemolished.Name
        TaskDialog.Show("Revit", prompt)
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Element Class


Element.DesignOption Property

ElementDesignOption Property

Returns the design option to which the element belongs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DesignOption DesignOption { get; }
Public ReadOnly Property DesignOption As DesignOption
    Get
public:
property DesignOption^ DesignOption {
    DesignOption^ get ();
}
member DesignOption : DesignOption with get

Property Value

DesignOption
Remarks
If the element is not in a design option, i.e. in the main model, then this property will return .
Example
C#
VB
C++
F#
Copy
void Getinfo_DesignOption(Document document)
{
    // Get the selected Elements in the Active Document
    UIDocument uidoc = new UIDocument(document);
    ICollection<ElementId> selectedIds = uidoc.Selection.GetElementIds();

    foreach (ElementId id in selectedIds)
    {
        Element element = document.GetElement(id);
        //Use the DesignOption property of Element
        if (element.DesignOption != null)
        {
            TaskDialog.Show("Revit",element.DesignOption.Name.ToString());
        }
    }
}
Private Sub Getinfo_DesignOption(document As Document)
    ' Get the selected Elements in the Active Document
    Dim uidoc As New UIDocument(document)
    Dim selectedIds As ICollection(Of ElementId) = uidoc.Selection.GetElementIds()

    For Each id As ElementId In selectedIds
        Dim element As Element = document.GetElement(id)
        'Use the DesignOption property of Element
        If element.DesignOption IsNot Nothing Then
            TaskDialog.Show("Revit", element.DesignOption.Name.ToString())
        End If
    Next
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Element Class


Element.Document Property

ElementDocument Property

Returns the Document in which the Element resides.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Document Document { get; }
Public ReadOnly Property Document As Document
    Get
public:
property Document^ Document {
    Document^ get ();
}
member Document : Document with get

Property Value

Document
Remarks
All elements are contained within a document. An element can be retrieved from this document by using the id that is returned by the element's id property.
See Also

Reference

Element Class


Element.Geometry Property

ElementGeometry Property

Retrieves the geometric representation of the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GeometryElement this[
    Options options
] { get; }
Public ReadOnly Property Geometry (
    options As Options
) As GeometryElement
    Get
public:
property GeometryElement^ Geometry[Options^ options] {
    GeometryElement^ get (Options^ options);
}
member Geometry : GeometryElement with get

Parameters

options Options
User preferences for parsing of geometry.

Property Value

GeometryElement
An object that provides access to the geometry of the element.
Remarks

This call will retrieve 3d representation of the element. will be returned for symbols, annotations or details. This involves extensive parsing or Revit's data structures, so try to minimize calls if performance is critical.

Geometry objects provided from this method are obtained directly from the element. When the element is changed for any reason, the geometry will be recalculated by Revit and geometry objects obtained before the change are likely to no longer be valid. If you need to preserve geometry information obtained an element even after changes to that element, you should copy the geometry objects or save the properties independently.

Although the geometry obtained from this method comes directly from the element, any attempt to modify any of the geometry objects will operate only on a disconnected copy of the original geometry object from the element. The modification will not affect the geometry of the original element from which it was obtained - to change the geometry of the element you must use methods that directly affect the geometry calculated or stored by Revit for this element.

If you require that the geometry items obtained contain valid Reference objects, be sure to set the ComputeReferences property of the Options.

Example
C#
VB
C++
F#
Copy
public void GetCurvesFromABeam(Autodesk.Revit.DB.FamilyInstance beam,
                               Autodesk.Revit.DB.Options options)
{
    Autodesk.Revit.DB.GeometryElement geomElem = beam.get_Geometry(options);

    Autodesk.Revit.DB.CurveArray curves = new CurveArray();
    System.Collections.Generic.List<Autodesk.Revit.DB.Solid> solids = new System.Collections.Generic.List<Autodesk.Revit.DB.Solid>();

    //Find all solids and insert them into solid array
    AddCurvesAndSolids(geomElem, ref curves, ref solids);
}

private void AddCurvesAndSolids(Autodesk.Revit.DB.GeometryElement geomElem,
                                ref Autodesk.Revit.DB.CurveArray curves,
                                ref System.Collections.Generic.List<Autodesk.Revit.DB.Solid> solids)
{
    foreach (Autodesk.Revit.DB.GeometryObject geomObj in geomElem)
    {
        Autodesk.Revit.DB.Curve curve = geomObj as Autodesk.Revit.DB.Curve;
        if (null != curve)
        {
            curves.Append(curve);
            continue;
        }
        Autodesk.Revit.DB.Solid solid = geomObj as Autodesk.Revit.DB.Solid;
        if (null != solid)
        {
            solids.Add(solid);
            continue;
        }
        //If this GeometryObject is Instance, call AddCurvesAndSolids
        Autodesk.Revit.DB.GeometryInstance geomInst = geomObj as Autodesk.Revit.DB.GeometryInstance;
        if (null != geomInst)
        {
            Autodesk.Revit.DB.GeometryElement transformedGeomElem
              = geomInst.GetInstanceGeometry(geomInst.Transform);
            AddCurvesAndSolids(transformedGeomElem, ref curves, ref solids);
        }
    }
}
  Public Sub GetCurvesFromABeam(beam As Autodesk.Revit.DB.FamilyInstance, options As Autodesk.Revit.DB.Options)
      Dim geomElem As Autodesk.Revit.DB.GeometryElement = beam.Geometry(options)

      Dim curves As Autodesk.Revit.DB.CurveArray = New CurveArray()
   Dim solids As New System.Collections.Generic.List(Of Autodesk.Revit.DB.Solid)

      'Find all solids and insert them into solid array
      AddCurvesAndSolids(geomElem, curves, solids)
  End Sub

Private Sub AddCurvesAndSolids(geomElem As Autodesk.Revit.DB.GeometryElement, ByRef curves As Autodesk.Revit.DB.CurveArray, ByRef solids As System.Collections.Generic.List(Of Autodesk.Revit.DB.Solid))
   For Each geomObj As Autodesk.Revit.DB.GeometryObject In geomElem
      Dim curve As Autodesk.Revit.DB.Curve = TryCast(geomObj, Autodesk.Revit.DB.Curve)
      If curve IsNot Nothing Then
         curves.Append(curve)
         Continue For
      End If
      Dim solid As Autodesk.Revit.DB.Solid = TryCast(geomObj, Autodesk.Revit.DB.Solid)
      If solid IsNot Nothing Then
         solids.Add(solid)
         Continue For
      End If
      'If this GeometryObject is Instance, call AddCurvesAndSolids
      Dim geomInst As Autodesk.Revit.DB.GeometryInstance = TryCast(geomObj, Autodesk.Revit.DB.GeometryInstance)
      If geomInst IsNot Nothing Then
         Dim transformedGeomElem As Autodesk.Revit.DB.GeometryElement = geomInst.GetInstanceGeometry(geomInst.Transform)
         AddCurvesAndSolids(transformedGeomElem, curves, solids)
      End If
   Next
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Element Class


Element.GroupId Property

ElementGroupId Property

The id of the group to which an element belongs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GroupId { get; }
Public ReadOnly Property GroupId As ElementId
    Get
public:
property ElementId^ GroupId {
    ElementId^ get ();
}
member GroupId : ElementId with get

Property Value

ElementId
See Also

Reference

Element Class


Element.Id Property

ElementId Property

A unique identifier for an Element in an Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId Id { get; }
Public ReadOnly Property Id As ElementId
    Get
public:
property ElementId^ Id {
    ElementId^ get ();
}
member Id : ElementId with get

Property Value

ElementId
Remarks
Returns an object containing the project-wide unique identifier for this Element. The identifier with this id is only unique for the project, it is not unique across separate Autodesk Revit projects.
Example
C#
VB
C++
F#
Copy
private void CheckElementId(Autodesk.Revit.DB.Document document, Autodesk.Revit.DB.Element element)
{
    // Get the id of the element
    Autodesk.Revit.DB.ElementId selectedId = element.Id;
    long idValue = selectedId.Value;

    // create a new id and set the value
    Autodesk.Revit.DB.ElementId id = new Autodesk.Revit.DB.ElementId(idValue);

    // Get the element
    Autodesk.Revit.DB.Element first = document.GetElement(id);

    // And get the element using the original Id (they should be the same)
    Autodesk.Revit.DB.Element second = document.GetElement(selectedId);

    String prompt = "Get an element twice. They should be the same element.";
    // Use the Equal method to check two elements. It is not a good way.
    bool isSame = first.Equals(second);
    prompt += "\nUsing Equal method on elements, the result is: " + isSame;
    isSame = first.Id.Equals(second.Id);
    prompt += "\nUsing Equal method on element's Id properties, the result is: " + isSame;

    TaskDialog.Show("Revit",prompt);
}
Private Sub CheckElementId(document As Autodesk.Revit.DB.Document, element As Autodesk.Revit.DB.Element)
    ' Get the id of the element
    Dim selectedId As Autodesk.Revit.DB.ElementId = element.Id
    Dim idValue As Long = selectedId.Value

    ' create a new id and set the value
    Dim id As New Autodesk.Revit.DB.ElementId(idValue)

    ' Get the element
    Dim first As Autodesk.Revit.DB.Element = document.GetElement(id)

    ' And get the element using the original Id (they should be the same)
    Dim second As Autodesk.Revit.DB.Element = document.GetElement(selectedId)

    Dim prompt As [String] = "Get an element twice. They should be the same element."
    ' Use the Equal method to check two elements. It is not a good way.
    Dim isSame As Boolean = first.Equals(second)
    prompt += vbLf & "Using Equal method on elements, the result is: " & isSame
    isSame = first.Id.Equals(second.Id)
    prompt += vbLf & "Using Equal method on element's Id properties, the result is: " & isSame

    TaskDialog.Show("Revit", prompt)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Element Class


Element.IsModifiable Property

ElementIsModifiable Property

Identifies if the element is modifiable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsModifiable { get; }
Public ReadOnly Property IsModifiable As Boolean
    Get
public:
property bool IsModifiable {
    bool get ();
}
member IsModifiable : bool with get

Property Value

Boolean
Remarks
This is not a permanent state. The value depends on the document state. For example, active edit modes can make IsModifiable false for many elements.
See Also

Reference

Element Class


Element.IsTransient Property

ElementIsTransient Property

Indicates whether an element is transient or permanent.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsTransient { get; }
Public ReadOnly Property IsTransient As Boolean
    Get
public:
property bool IsTransient {
    bool get ();
}
member IsTransient : bool with get

Property Value

Boolean
Remarks

Transient elements are usually created for short term use. This type of element can be created via Document.MakeTransientElements().

Transient and Permanent elements are not allowed to reference each other. A transient element can only refer to other transient elements in the same document.

Transient elements also cannot be selected or scheduled, and will not be saved when the document is saved, and will be discarded when the document is closed.

Modifying a transient element does not require a transaction, because such elements are not part of the model. As an effect of this, however, creation and modification of transients cannot be undone.

Because transient elements are technically not part of the model, they will not be found when using standard element filters, or in any collection of elements Revit returns, such as elements reported in dynamic updaters, etc.

See Also

Reference

Element Class


Element.IsValidObject Property

ElementIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

Element Class


Element.LevelId Property

ElementLevelId Property

The id of the level associated with the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId LevelId { get; }
Public ReadOnly Property LevelId As ElementId
    Get
public:
property ElementId^ LevelId {
    ElementId^ get ();
}
member LevelId : ElementId with get

Property Value

ElementId
See Also

Reference

Element Class


Element.Location Property

ElementLocation Property

This property is used to find the physical location of an element within a project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Location Location { get; }
Public Overridable ReadOnly Property Location As Location
    Get
public:
virtual property Location^ Location {
    Location^ get ();
}
abstract Location : Location with get
override Location : Location with get

Property Value

Location
Remarks
The Location property returns an object that can be used to find the location of an object within the project. An object may have a point location, such as a table or may have a line location. A wall is an example of an element that has a line location.
Example
C#
VB
C++
F#
Copy
void GetLocationInformation(Autodesk.Revit.DB.Element element)
{
    // Get the Location property and judge whether it exists
    Autodesk.Revit.DB.Location position = element.Location;

    String prompt = null;
    if (null == position)
    {
        prompt = "No location can be found in element.";
    }
    else
    {
        // If the location is a point location, give the user information
        Autodesk.Revit.DB.LocationPoint positionPoint = position as Autodesk.Revit.DB.LocationPoint;
        if (null != positionPoint)
        {
            prompt = "Element has a point location.";
        }
        else
        {

            // If the location is a curve location, give the user information
            Autodesk.Revit.DB.LocationCurve positionCurve = position as Autodesk.Revit.DB.LocationCurve;
            if (null != positionCurve)
            {
                prompt = "Element has a curve location.";
            }
        }
    }

    if (null != prompt)
    {
        TaskDialog.Show("Revit",prompt);
    }
}
Private Sub GetLocationInformation(element As Autodesk.Revit.DB.Element)
    ' Get the Location property and judge whether it exists
    Dim position As Autodesk.Revit.DB.Location = element.Location

    Dim prompt As [String] = Nothing
    If position Is Nothing Then
        prompt = "No location can be found in element."
    Else
        ' If the location is a point location, give the user information
        Dim positionPoint As Autodesk.Revit.DB.LocationPoint = TryCast(position, Autodesk.Revit.DB.LocationPoint)
        If positionPoint IsNot Nothing Then
            prompt = "Element has a point location."
        Else

            ' If the location is a curve location, give the user information
            Dim positionCurve As Autodesk.Revit.DB.LocationCurve = TryCast(position, Autodesk.Revit.DB.LocationCurve)
            If positionCurve IsNot Nothing Then
                prompt = "Element has a curve location."
            End If
        End If
    End If

    If prompt IsNot Nothing Then
        TaskDialog.Show("Revit", prompt)
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Element Class


Element.Name Property

ElementName Property

A human readable name for the Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

String
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the name of the element cannot be changed.
ArgumentException | Thrown when the element requires a unique name and a non-unique name is set.
Remarks
The Name property is a human readable name for the element, such as Wall.
See Also

Reference

Element Class


Element.OwnerViewId Property

ElementOwnerViewId Property

The id of the view that owns the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId OwnerViewId { get; }
Public ReadOnly Property OwnerViewId As ElementId
    Get
public:
property ElementId^ OwnerViewId {
    ElementId^ get ();
}
member OwnerViewId : ElementId with get

Property Value

ElementId
See Also

Reference

Element Class


Element.Parameter Property

ElementParameter Property

Retrieves a parameter from the element given an identifier.
Overload List
 | Name | Description
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id.
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition.
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter.
Top
See Also

Reference

Element Class


Element.Parameter(BuiltInParameter) Property

ElementParameter(BuiltInParameter) Property

Retrieves a parameter from the element given a parameter id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Parameter this[
    BuiltInParameter parameterId
] { get; }
Public ReadOnly Property Parameter (
    parameterId As BuiltInParameter
) As Parameter
    Get
public:
property Parameter^ Parameter[BuiltInParameter parameterId] {
    Parameter^ get (BuiltInParameter parameterId);
}
member Parameter : Parameter with get

Parameters

parameterId BuiltInParameter
The built in parameter id of the parameter to be retrieved.

Property Value

Parameter
Remarks
Parameters are a generic form of data storage within elements. The parameters are visible through the Autodesk Revit user interface in the Element Properties dialog. This method uses a built in parameter id to access the parameter. Autodesk Revit has a large number of built in parameters that are available via an enumerated type.
Example
C#
VB
C++
F#
Copy
public Parameter FindWithBuiltinParameterID(Wall wall)
{
    //Use the WALL_BASE_OFFSET paramametId
    // to get the base offset parameter of the wall.
    BuiltInParameter paraIndex = BuiltInParameter.WALL_BASE_OFFSET;
    Parameter parameter = wall.get_Parameter(paraIndex);

    return parameter;
}
Public Function FindWithBuiltinParameterID(wall As Wall) As Parameter
    'Use the WALL_BASE_OFFSET paramametId
    ' to get the base offset parameter of the wall.
    Dim paraIndex As BuiltInParameter = BuiltInParameter.WALL_BASE_OFFSET
    Dim parameter As Parameter = wall.Parameter(paraIndex)

    Return parameter
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Element Class
Parameter Overload


Element.Parameter(Definition) Property

ElementParameter(Definition) Property

Retrieves a parameter from the element based on its definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Parameter this[
    Definition definition
] { get; }
Public ReadOnly Property Parameter (
    definition As Definition
) As Parameter
    Get
public:
property Parameter^ Parameter[Definition^ definition] {
    Parameter^ get (Definition^ definition);
}
member Parameter : Parameter with get

Parameters

definition Definition
The internal or external definition of the parameter.

Property Value

Parameter
Remarks
Parameters are a generic form of data storage within elements. The parameters are visible through the Autodesk Revit user interface in the Element Properties dialog. An element can only have one instance of a parameter with a specific definition. By using this method you can retrieve that parameter based on definition.
See Also

Reference

Element Class
Parameter Overload


Element.Parameter(Guid) Property

ElementParameter(Guid) Property

Retrieves a parameter from the element given a GUID for a shared parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Parameter this[
    Guid guid
] { get; }
Public ReadOnly Property Parameter (
    guid As Guid
) As Parameter
    Get
public:
property Parameter^ Parameter[Guid guid] {
    Parameter^ get (Guid guid);
}
member Parameter : Parameter with get

Parameters

guid Guid
The unique id associated with the shared parameter.

Property Value

Parameter
Remarks
Parameters are a generic form of data storage within elements. The parameters are visible through the Autodesk Revit user interface in the Element Properties dialog. This method is used to retrieve a parameter for a known shared parameter. When a shared parameter is created it is assigned a Guid which will not change. This guid can be used to retrieve the piece of data from the element at a later time.
See Also

Reference

Element Class
Parameter Overload


Element.Parameters Property

ElementParameters Property

Retrieves a set containing all of the parameters that are contained within the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ParameterSet Parameters { get; }
Public ReadOnly Property Parameters As ParameterSet
    Get
public:
property ParameterSet^ Parameters {
    ParameterSet^ get ();
}
member Parameters : ParameterSet with get

Property Value

ParameterSet
Remarks
The Parameters property contains a set of all the parameters that the element supports. These parameters are displayed in the Element properties dialog in the Autodesk Revit interface. These parameters can be retrieved and set via the parameter objects stored in this set.
Example
C#
VB
C++
F#
Copy
void GetElementParameterInformation(Document document, Element element)
{
    // Format the prompt information string
    String prompt = "Show parameters in selected Element: \n\r";

    StringBuilder st = new StringBuilder();
    // iterate element's parameters
    foreach (Parameter para in element.Parameters)
    {
        st.AppendLine(GetParameterInformation(para, document));
    }

    // Give the user some information
    TaskDialog.Show("Revit", prompt + st.ToString());
}

String GetParameterInformation(Parameter para, Document document)
{
    string defName = para.Definition.Name + "\t : ";
    string defValue = string.Empty;
    // Use different method to get parameter data according to the storage type
    switch (para.StorageType)
    {
        case StorageType.Double:
            //covert the number into Metric
            defValue = para.AsValueString();
            break;
        case StorageType.ElementId:
            //find out the name of the element
            Autodesk.Revit.DB.ElementId id = para.AsElementId();
            if (id != ElementId.InvalidElementId)
            {
                defValue = document.GetElement(id).Name;
            }
            else
            {
                defValue = id.ToString();
            }
            break;
        case StorageType.Integer:
            if (SpecTypeId.Boolean.YesNo == para.Definition.GetDataType())
            {
                if (para.AsInteger() == 0)
                {
                    defValue = "False";
                }
                else
                {
                    defValue = "True";
                }
            }
            else
            {
                defValue = para.AsInteger().ToString();
            }
            break;
        case StorageType.String:
            defValue = para.AsString();
            break;
        default:
            defValue = "Unexposed parameter.";
            break;
    }

    return defName + defValue;
}
Private Sub GetElementParameterInformation(document As Document, element As Element)
    ' Format the prompt information string
    Dim prompt As [String] = "Show parameters in selected Element: " & vbLf & vbCr

    Dim st As New StringBuilder()
    ' iterate element's parameters
    For Each para As Parameter In element.Parameters
        st.AppendLine(GetParameterInformation(para, document))
    Next

    ' Give the user some information
    TaskDialog.Show("Revit", prompt + st.ToString())
End Sub

Private Function GetParameterInformation(para As Parameter, document As Document) As [String]
    Dim defName As String = para.Definition.Name + vbTab & " : "
    Dim defValue As String = String.Empty
    ' Use different method to get parameter data according to the storage type
    Select Case para.StorageType
        Case StorageType.[Double]
            'covert the number into Metric
            defValue = para.AsValueString()
            Exit Select
        Case StorageType.ElementId
            'find out the name of the element
            Dim id As Autodesk.Revit.DB.ElementId = para.AsElementId()
            If id > Autodesk.Revit.DB.ElementId.InvalidElementId Then
                defValue = document.GetElement(id).Name
            Else
                defValue = id.ToString()
            End If
            Exit Select
        Case StorageType.[Integer]
            If SpecTypeId.Boolean.YesNo = para.Definition.GetDataType() Then
                If para.AsInteger() = 0 Then
                    defValue = "False"
                Else
                    defValue = "True"
                End If
            Else
                defValue = para.AsInteger().ToString()
            End If
            Exit Select
        Case StorageType.[String]
            defValue = para.AsString()
            Exit Select
        Case Else
            defValue = "Unexposed parameter."
            Exit Select
    End Select

    Return defName & defValue
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Element Class


Element.ParametersMap Property

ElementParametersMap Property

Retrieves a map containing all of the parameters that are contained within the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ParameterMap ParametersMap { get; }
Public ReadOnly Property ParametersMap As ParameterMap
    Get
public:
property ParameterMap^ ParametersMap {
    ParameterMap^ get ();
}
member ParametersMap : ParameterMap with get

Property Value

ParameterMap
Remarks
The Parameters can be rapidly accessed by parameter name as a key. These parameters are displayed in the Element properties dialog in the Autodesk Revit interface. These parameters can be retrieved and set via the parameter objects stored in this map.
See Also

Reference

Element Class


Element.Pinned Property

ElementPinned Property

Identifies if the element has been pinned to prevent changes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Pinned { get; set; }
Public Property Pinned As Boolean
    Get
    Set
public:
property bool Pinned {
    bool get ();
    void set (bool value);
}
member Pinned : bool with get, set

Property Value

Boolean
Exceptions
Exception | Condition
InvalidOperationException | When setting this property: Element cannot be pinned or unpinned.
Remarks
An element which is pinned may not be moved, and warnings will be issued when an attempt is made to delete it.
See Also

Reference

Element Class


Element.UniqueId Property

ElementUniqueId Property

A stable unique identifier for an element within the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string UniqueId { get; }
Public ReadOnly Property UniqueId As String
    Get
public:
property String^ UniqueId {
    String^ get ();
}
member UniqueId : string with get

Property Value

String
Remarks
The UniqueId can be used to store an identifier in an external database and to retrieve the same element in the future if it still exists. This id can be passed to the Document's Element property to retrieve the element. The UniqueId is stable across upgrades and workset operations such as Save To Central, while the ElementId property may change.
Example
C#
VB
C++
F#
Copy
private void CheckElementUniqueId(Autodesk.Revit.DB.Document document, Autodesk.Revit.DB.Element element)
{
    String uniqueId = element.UniqueId;

    // Get the element using the UniqueId
    Autodesk.Revit.DB.Element elem = document.GetElement(uniqueId);

    String prompt = "UniqueId of element is: " + uniqueId;
    prompt += "\nUniqueID of elem is: " + elem.UniqueId;
}
Private Sub CheckElementUniqueId(document As Autodesk.Revit.DB.Document, element As Autodesk.Revit.DB.Element)
    Dim uniqueId As [String] = element.UniqueId

    ' Get the element using the UniqueId
    Dim elem As Autodesk.Revit.DB.Element = document.GetElement(uniqueId)

    Dim prompt As [String] = "UniqueId of element is: " & uniqueId
    prompt += vbLf & "UniqueID of elem is: " + elem.UniqueId
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Element Class


Element.VersionGuid Property

ElementVersionGuid Property

Get the element version Guid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid VersionGuid { get; }
Public ReadOnly Property VersionGuid As Guid
    Get
public:
property Guid VersionGuid {
    Guid get ();
}
member VersionGuid : Guid with get

Property Value

Guid
Exceptions
Exception | Condition
InvalidOperationException | When the Element is transient or when the Document has no version Guid for this Element.
Remarks
If element version Guid is the same for a certain element in two instances of the saved file then we guarantee that the two elements are identical. One element version covers a period of time that is larger than a single transaction: it is a period between two saves, synchronize to central and reload latest. Thus, in an opened document in-between saves or synchronize actions, this version cannot be used to determine if any particular element has changed. To watch for element changes happening in-session, use event [!:Autodesk::Revit::ApplicationServices::Application::DocumentChanged].
See Also

Reference

Element Class


Element.ViewSpecific Property

ElementViewSpecific Property

Identifies if the element is owned by a view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ViewSpecific { get; }
Public ReadOnly Property ViewSpecific As Boolean
    Get
public:
property bool ViewSpecific {
    bool get ();
}
member ViewSpecific : bool with get

Property Value

Boolean
See Also

Reference

Element Class


Element.WorksetId Property

ElementWorksetId Property

Get Id of the Workset which owns the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WorksetId WorksetId { get; }
Public ReadOnly Property WorksetId As WorksetId
    Get
public:
property WorksetId^ WorksetId {
    WorksetId^ get ();
}
member WorksetId : WorksetId with get

Property Value

WorksetId
Remarks
Each element belongs to one and only one workset.
See Also

Reference

Element Class


Element Methods

The Element type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element.
Public method | CanBeHidden | Indicates if the element can be hidden in the view.
Public method | CanBeLocked | Identifies if the element can be locked.
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element.
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned.
 | CanHaveTypeAssigned(Document, ICollectionElementId) | Checks if all elements in the set can have a type assigned.
Public method | ChangeTypeId(ElementId) | Changes the type of the element.
 | ChangeTypeId(Document, ICollectionElementId, ElementId) | Changes the type of all elements in the given set.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element
Public method | DeleteSubelement | Removes a subelement from the element.
Public method | DeleteSubelements | Removes the subelements from the element.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element.
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set.
 | GetChangeTypeAny | Returns ChangeType associated with any change in an element.
 | GetChangeTypeElementAddition | Returns ChangeType associated with element addition
 | GetChangeTypeElementDeletion | Returns ChangeType associated with element deletion.
 | GetChangeTypeGeometry | Returns ChangeType associated with a change in the geometry of an element
 | GetChangeTypeParameter(ElementId) | Returns ChangeType associated with a change in a parameter's value
 | GetChangeTypeParameter(Parameter) | Returns ChangeType associated with a change in a parameter's value
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise.
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element.
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element.
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type.
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type.
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element.
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element.
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object.
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id.
Public method | GetMaterialIds | Gets the element ids of all materials present in the element.
Public method | GetMaterialVolume | Gets the volume of the material with the given id.
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring.
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring.
Public method | GetOrderedParameters | Gets the parameters associated to the element in order.
Public method | GetParameter | Retrieves a parameter from the element given identifier.
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists.
Public method | GetParameters | Retrieves the parameters from the element via the given name.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase
Public method | GetSubelements | Returns the collection of element subelements.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type.
Public method | GetValidTypes | Obtains a set of types that are valid for this element.
 | GetValidTypes(Document, ICollectionElementId) | Obtains a set of types that are valid for all given elements.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order.
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order.
Public method | IsExternalFileReference | Determines whether this Element represents an external file.
Public method | IsHidden | Identifies if the element has been permanently hidden in the view.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models.
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element.
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element.
 | IsValidType(Document, ICollectionElementId, ElementId) | Checks if given type is valid for the set of elements.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name.
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type.
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Element Class


Element.ArePhasesModifiable Method

ElementArePhasesModifiable Method

Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ArePhasesModifiable()
Public Function ArePhasesModifiable As Boolean
public:
bool ArePhasesModifiable()
member ArePhasesModifiable : unit -> bool

Return Value

Boolean
True if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element, false otherwise.
Remarks
Acts as a validator for setting the properties CreatedPhaseId and DemolishedPhaseId.
See Also

Reference

Element Class


Element.CanBeHidden Method

ElementCanBeHidden Method

Indicates if the element can be hidden in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanBeHidden(
    View pView
)
Public Function CanBeHidden (
    pView As View
) As Boolean
public:
bool CanBeHidden(
    View^ pView
)
member CanBeHidden :
        pView : View -> bool

Parameters

pView View

Return Value

Boolean
If the element is not permitted to be hidden, false is returned.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when argument is .
Remarks
See discussion for some types of elements which may not be hidden. Note: elements in families can only be hidden temporarily.
See Also

Reference

Element Class


Element.CanBeLocked Method

ElementCanBeLocked Method

Identifies if the element can be locked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanBeLocked()
Public Function CanBeLocked As Boolean
public:
bool CanBeLocked()
member CanBeLocked : unit -> bool

Return Value

Boolean
True if the element can be locked, false otherwise.
See Also

Reference

Element Class


Element.CanDeleteSubelement Method

ElementCanDeleteSubelement Method

Checks if given subelement can be removed from the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanDeleteSubelement(
    Subelement subelem
)
Public Function CanDeleteSubelement (
    subelem As Subelement
) As Boolean
public:
bool CanDeleteSubelement(
    Subelement^ subelem
)
member CanDeleteSubelement :
        subelem : Subelement -> bool

Parameters

subelem Subelement
Subelement to check.

Return Value

Boolean
True if subelement can be removed, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

Element Class


Element.CanHaveTypeAssigned Method

ElementCanHaveTypeAssigned Method

Overload List
 | Name | Description
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned.
 | CanHaveTypeAssigned(Document, ICollectionElementId) | Checks if all elements in the set can have a type assigned.
Top
See Also

Reference

Element Class


Element.CanHaveTypeAssigned Method

ElementCanHaveTypeAssigned Method

Identifies if the element can have a type assigned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanHaveTypeAssigned()
Public Function CanHaveTypeAssigned As Boolean
public:
bool CanHaveTypeAssigned()
member CanHaveTypeAssigned : unit -> bool

Return Value

Boolean
True if element can have a type assigned, false otherwise.
Remarks
Some elements cannot have type assigned, in which case invalid element id is considered to be their type id.
See Also

Reference

Element Class
CanHaveTypeAssigned Overload


Element.CanHaveTypeAssigned(Document, ICollection<ElementId>) Method

ElementCanHaveTypeAssigned(Document, ICollectionElementId) Method

Checks if all elements in the set can have a type assigned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CanHaveTypeAssigned(
    Document document,
    ICollection<ElementId> elementIds
)
Public Shared Function CanHaveTypeAssigned (
    document As Document,
    elementIds As ICollection(Of ElementId)
) As Boolean
public:
static bool CanHaveTypeAssigned(
    Document^ document,
    ICollection<ElementId^>^ elementIds
)
static member CanHaveTypeAssigned :
        document : Document *
        elementIds : ICollection<ElementId> -> bool

Parameters

document Document
The document.
elementIds ICollection ElementId
A collection of element IDs.

Return Value

Boolean
True if all elements in the set can have a type assigned, false otherwise.
Exceptions
Exception | Condition
ArgumentException | Thrown when at least one of the elements does not exist in the document.
ArgumentNullException | A non-optional argument was null
See Also

Reference

Element Class
CanHaveTypeAssigned Overload


Element.ChangeTypeId Method

ElementChangeTypeId Method

Overload List
 | Name | Description
Public method | ChangeTypeId(ElementId) | Changes the type of the element.
 | ChangeTypeId(Document, ICollectionElementId, ElementId) | Changes the type of all elements in the given set.
Top
See Also

Reference

Element Class


Element.ChangeTypeId(ElementId) Method

ElementChangeTypeId(ElementId) Method

Changes the type of the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId ChangeTypeId(
    ElementId typeId
)
Public Function ChangeTypeId (
    typeId As ElementId
) As ElementId
public:
ElementId^ ChangeTypeId(
    ElementId^ typeId
)
member ChangeTypeId :
        typeId : ElementId -> ElementId

Parameters

typeId ElementId
Identifier of the type to assign to this element.

Return Value

ElementId
The new element id if new element is created, or InvalidElementId if the element's type changed without creating a new element.
Exceptions
Exception | Condition
ArgumentException | The type typeId is not valid for this element.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This Element cannot have type assigned.
ModificationForbiddenException | This Element is an internal element, such as a component of a loaded family or a group type. -or- The document containing this Element is in Group Edit Mode, Sketch Edit Mode, or Paste Mode, and the element is not a member of the group, sketch, or clipboard. -or- This Element is a member of a group or sketch, and the document is not currently editing the group or sketch.
Remarks
In rare cases, applying a change in type will result in a new element being created. The only active examples of this are when applying a normal wall type to a curtain panel, or converting such a wall back to a curtain panel. In this situation the new element id is returned. Also, this element becomes invalid. See also: IsModifiable.
See Also

Reference

Element Class
ChangeTypeId Overload


Element.ChangeTypeId(Document, ICollection<ElementId>, ElementId) Method

ElementChangeTypeId(Document, ICollectionElementId, ElementId) Method

Changes the type of all elements in the given set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IDictionary<ElementId, ElementId> ChangeTypeId(
    Document document,
    ICollection<ElementId> elementIds,
    ElementId typeId
)
Public Shared Function ChangeTypeId (
    document As Document,
    elementIds As ICollection(Of ElementId),
    typeId As ElementId
) As IDictionary(Of ElementId, ElementId)
public:
static IDictionary<ElementId^, ElementId^>^ ChangeTypeId(
    Document^ document,
    ICollection<ElementId^>^ elementIds,
    ElementId^ typeId
)
static member ChangeTypeId :
        document : Document *
        elementIds : ICollection<ElementId> *
        typeId : ElementId -> IDictionary<ElementId, ElementId>

Parameters

document Document
The document.
elementIds ICollection ElementId
A collection of element IDs.
typeId ElementId
Identifier of the type to assign to this element.

Return Value

IDictionary ElementId, ElementId
The map of original element IDs to the new element IDs if some elements were replaced by new elements (the map is empty if no elements were replaced)
Exceptions
Exception | Condition
ArgumentException | At least one of the elements in elementIds does not exist in the document -or- Not all elements elementIds can have a type assigned. -or- The type typeId is not valid for at least one of the elements in elementIds.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | One or more elements in elementIds is a member of a loaded family. -or- One or more elements in elementIds is a member of a group type that is not being edited.
Remarks
In some cases, applying a change in type will result in a new element being created. The only active examples of this are when applying a normal wall type to a curtain panel, or converting such a wall back to a curtain panel. Then return map would have (original element id, new element id) pair(s). Note: this function needs an open transaction. Note: this function calls regeneration.
See Also

Reference

Element Class
ChangeTypeId Overload


Element.DeleteEntity Method

ElementDeleteEntity Method

Deletes the existing entity created by %schema% in the element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool DeleteEntity(
    Schema schema
)
Public Function DeleteEntity (
    schema As Schema
) As Boolean
public:
bool DeleteEntity(
    Schema^ schema
)
member DeleteEntity :
        schema : Schema -> bool

Parameters

schema Schema
Schema used for creation of the entity

Return Value

Boolean
True if entity was deleted, false if entity didn't exist
Exceptions
Exception | Condition
ArgumentException | Writing of Entities of this Schema is not allowed to the current add-in.
ArgumentNullException | A non-optional argument was null
See Also

Reference

Element Class


Element.DeleteSubelement Method

ElementDeleteSubelement Method

Removes a subelement from the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool DeleteSubelement(
    Subelement subelem
)
Public Function DeleteSubelement (
    subelem As Subelement
) As Boolean
public:
bool DeleteSubelement(
    Subelement^ subelem
)
member DeleteSubelement :
        subelem : Subelement -> bool

Parameters

subelem Subelement
The subelement to delete.

Return Value

Boolean
True if entire element was deleted, false otherwise.
Exceptions
Exception | Condition
ArgumentException | The subelement subelem does not exist in the element. -or- Subelement subelem cannot be deleted.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | This Element is an internal element, such as a component of a loaded family or a group type. -or- The document containing this Element is in Group Edit Mode, Sketch Edit Mode, or Paste Mode, and the element is not a member of the group, sketch, or clipboard. -or- This Element is a member of a group or sketch, and the document is not currently editing the group or sketch.
Remarks
Depending on implementation for given element as the result, the element can be deleted - especially if after subelement deletion there are no subelements left. See also: IsModifiable.
See Also

Reference

Element Class


Element.DeleteSubelements Method

ElementDeleteSubelements Method

Removes the subelements from the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool DeleteSubelements(
    IList<Subelement> subelems
)
Public Function DeleteSubelements (
    subelems As IList(Of Subelement)
) As Boolean
public:
bool DeleteSubelements(
    IList<Subelement^>^ subelems
)
member DeleteSubelements :
        subelems : IList<Subelement> -> bool

Parameters

subelems IList Subelement
Subelements to delete.

Return Value

Boolean
True if entire element was deleted, false otherwise.
Exceptions
Exception | Condition
ArgumentException | One or more subelements in subelems do not exist in the element. -or- One or more of the subelements subelems cannot be deleted.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | This Element is an internal element, such as a component of a loaded family or a group type. -or- The document containing this Element is in Group Edit Mode, Sketch Edit Mode, or Paste Mode, and the element is not a member of the group, sketch, or clipboard. -or- This Element is a member of a group or sketch, and the document is not currently editing the group or sketch.
Remarks
Depending on implementation for given element as the result, the element can be deleted - especially if after Subelement deletion there are no Subelement left. See also: IsModifiable.
See Also

Reference

Element Class


Element.Dispose Method

ElementDispose Method

Releases all resources used by the Element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

Element Class


Element.EvaluateAllParameterValues Method

ElementEvaluateAllParameterValues Method

Evaluates all the parameters' values of the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<EvaluatedParameter> EvaluateAllParameterValues()
Public Function EvaluateAllParameterValues As IList(Of EvaluatedParameter)
public:
IList<EvaluatedParameter^>^ EvaluateAllParameterValues()
member EvaluateAllParameterValues : unit -> IList<EvaluatedParameter>

Return Value

IList EvaluatedParameter
List of EvaluatedParameter of the element.
See Also

Reference

Element Class


Element.EvaluateParameterValues Method

ElementEvaluateParameterValues Method

Evaluate the parameters' values of the element on the given parameter ID set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<EvaluatedParameter> EvaluateParameterValues(
    ISet<ElementId> parameterIds
)
Public Function EvaluateParameterValues (
    parameterIds As ISet(Of ElementId)
) As IList(Of EvaluatedParameter)
public:
IList<EvaluatedParameter^>^ EvaluateParameterValues(
    ISet<ElementId^>^ parameterIds
)
member EvaluateParameterValues :
        parameterIds : ISet<ElementId> -> IList<EvaluatedParameter>

Parameters

parameterIds ISet ElementId
Parameter IDs with which the ParameterValue to be retrieved.

Return Value

IList EvaluatedParameter
List of EvaluatedParameter of the element, which does not include those that cannot be retrieved but are passed in through parameterIds.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

Element Class


Element.GetChangeTypeAny Method

ElementGetChangeTypeAny Method

Returns ChangeType associated with any change in an element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ChangeType GetChangeTypeAny()
Public Shared Function GetChangeTypeAny As ChangeType
public:
static ChangeType^ GetChangeTypeAny()
static member GetChangeTypeAny : unit -> ChangeType

Return Value

ChangeType
ChangeType that can be used to define a trigger for an Updater, triggering on any change in an element.
Remarks

Use this change type to trigger an Updater when elements change in any way. For maximum efficiency, we recommend the use of ChangeTypeParameter and ChangeTypeGeometry, if applicable, instead.

Caution: Changes to an element by an Updater using this trigger will result in re-triggering of the Updater. For example, Updater1 triggers on ChangeTypeAny on Element X. A Revit user modifies parameter A of X. Updater1 is triggered and modifies X's parameter B. The change in parameter B, triggers another call to Updater1.Execute(). If Updater1 continues to modify X, it can run into an infinite loop. Infinite loops are detected by Revit and result in the Updater being disabled.

Note: This change type will not trigger on newly created or deleted elements or on changes caused by Undo and Redo.

See Also

Reference

Element Class


Element.GetChangeTypeElementAddition Method

ElementGetChangeTypeElementAddition Method

Returns ChangeType associated with element addition

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ChangeType GetChangeTypeElementAddition()
Public Shared Function GetChangeTypeElementAddition As ChangeType
public:
static ChangeType^ GetChangeTypeElementAddition()
static member GetChangeTypeElementAddition : unit -> ChangeType

Return Value

ChangeType
ChangeType that can be used to define a trigger for an Updater, triggering on element addition.
Remarks
Use this change type to trigger an Updater on the addition of elements to a document. Note: This change type will not trigger on changes caused by Undo and Redo.
See Also

Reference

Element Class


Element.GetChangeTypeElementDeletion Method

ElementGetChangeTypeElementDeletion Method

Returns ChangeType associated with element deletion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ChangeType GetChangeTypeElementDeletion()
Public Shared Function GetChangeTypeElementDeletion As ChangeType
public:
static ChangeType^ GetChangeTypeElementDeletion()
static member GetChangeTypeElementDeletion : unit -> ChangeType

Return Value

ChangeType
ChangeType that can be used to define a trigger for an Updater, triggering on element deletion.
Remarks
ChangeType that can be used to define a trigger for an Updater, Use this change type to trigger an Updater on the deletion of elements from a document. Note: This change type will not trigger on changes caused by Undo and Redo.
See Also

Reference

Element Class


Element.GetChangeTypeGeometry Method

ElementGetChangeTypeGeometry Method

Returns ChangeType associated with a change in the geometry of an element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ChangeType GetChangeTypeGeometry()
Public Shared Function GetChangeTypeGeometry As ChangeType
public:
static ChangeType^ GetChangeTypeGeometry()
static member GetChangeTypeGeometry : unit -> ChangeType

Return Value

ChangeType
ChangeType that can be used to define a trigger for an Updater, triggering on a geometry change in an element
Remarks
Use this change type to trigger an Updater when the geometry of an element changes. For example, changes like cutting a hole in a wall or adjusting its height are considered to be geometric changes. Note: This change type will not trigger on newly created or deleted elements or on changes caused by Undo and Redo.
See Also

Reference

Element Class


Element.GetChangeTypeParameter Method

ElementGetChangeTypeParameter Method

Overload List
Name | Description
GetChangeTypeParameter(ElementId) | Returns ChangeType associated with a change in a parameter's value
GetChangeTypeParameter(Parameter) | Returns ChangeType associated with a change in a parameter's value
Top
See Also

Reference

Element Class


Element.GetChangeTypeParameter(ElementId) Method

ElementGetChangeTypeParameter(ElementId) Method

Returns ChangeType associated with a change in a parameter's value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ChangeType GetChangeTypeParameter(
    ElementId parameterId
)
Public Shared Function GetChangeTypeParameter (
    parameterId As ElementId
) As ChangeType
public:
static ChangeType^ GetChangeTypeParameter(
    ElementId^ parameterId
)
static member GetChangeTypeParameter :
        parameterId : ElementId -> ChangeType

Parameters

parameterId ElementId
ElementId of parameter for the ChangeType to trigger on.

Return Value

ChangeType
ChangeType that can be used to define a trigger for an Updater, triggering on parameter value change.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
remarks: Use this change type to trigger an Updater when the value of an element's parameter changes. Note: This change type will not trigger on newly created or deleted elements or on changes caused by Undo and Redo.
See Also

Reference

Element Class
GetChangeTypeParameter Overload


Element.GetChangeTypeParameter(Parameter) Method

ElementGetChangeTypeParameter(Parameter) Method

Returns ChangeType associated with a change in a parameter's value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ChangeType GetChangeTypeParameter(
    Parameter param
)
Public Shared Function GetChangeTypeParameter (
    param As Parameter
) As ChangeType
public:
static ChangeType^ GetChangeTypeParameter(
    Parameter^ param
)
static member GetChangeTypeParameter :
        param : Parameter -> ChangeType

Parameters

param Parameter
Parameter for the ChangeType to trigger on

Return Value

ChangeType
ChangeType that can be used to define a trigger for an Updater, triggering on parameter value change
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was
Remarks
Use this change type to trigger an Updater when the value of an element's parameter changes. Note: This change type will not trigger on newly created or deleted elements.
See Also

Reference

Element Class
GetChangeTypeParameter Overload


Element.GetDependentElements Method

ElementGetDependentElements Method

Get all elements that, from a logical point of view, are the children of this Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ElementId> GetDependentElements(
    ElementFilter filter
)
Public Function GetDependentElements (
    filter As ElementFilter
) As IList(Of ElementId)
public:
IList<ElementId^>^ GetDependentElements(
    ElementFilter^ filter
)
member GetDependentElements :
        filter : ElementFilter -> IList<ElementId>

Parameters

filter ElementFilter
What type of elements we are interested of. Can be NULL to return all dependent elements.

Return Value

IList ElementId
Logical children of this element
Remarks

The elements that this method will return:

  1. Will be deleted if the input Element is deleted.
  2. Potentially could report the input Element as a host (there could be other type of parent/child relationship here: for example view/view-specific elements, etc.)

See Also

Reference

Element Class


Element.GetEntity Method

ElementGetEntity Method

Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Entity GetEntity(
    Schema schema
)
Public Function GetEntity (
    schema As Schema
) As Entity
public:
Entity^ GetEntity(
    Schema^ schema
)
member GetEntity :
        schema : Schema -> Entity

Parameters

schema Schema
The Schema describing the Entity.

Return Value

Entity
The returned Entity.
Exceptions
Exception | Condition
ArgumentException | Reading of Entities of this Schema is not allowed to the current add-in.
ArgumentNullException | A non-optional argument was null
Remarks
The Entity that is returned is a copy of the stored data (with copy-on-write optimization). Modifying it is allowed (even with restricted write), but to save your changes you must call SetEntity.
See Also

Reference

Element Class


Element.GetEntitySchemaGuids Method

ElementGetEntitySchemaGuids Method

Returns the Schema guids of any Entities stored in this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<Guid> GetEntitySchemaGuids()
Public Function GetEntitySchemaGuids As IList(Of Guid)
public:
IList<Guid>^ GetEntitySchemaGuids()
member GetEntitySchemaGuids : unit -> IList<Guid>

Return Value

IList Guid
The schema Entity guids.
See Also

Reference

Element Class


Element.GetExternalFileReference Method

ElementGetExternalFileReference Method

Gets information pertaining to the external file referenced by the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExternalFileReference GetExternalFileReference()
Public Function GetExternalFileReference As ExternalFileReference
public:
ExternalFileReference^ GetExternalFileReference()
member GetExternalFileReference : unit -> ExternalFileReference

Return Value

ExternalFileReference
An object containing path and type information for the external file referenced by the element.
Exceptions
Exception | Condition
InvalidOperationException | This Element does not represent an external file.
See Also

Reference

Element Class


Element.GetExternalResourceReference Method

ElementGetExternalResourceReference Method

Gets the ExternalResourceReference associated with a specified external resource type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExternalResourceReference GetExternalResourceReference(
    ExternalResourceType resourceType
)
Public Function GetExternalResourceReference (
    resourceType As ExternalResourceType
) As ExternalResourceReference
public:
ExternalResourceReference^ GetExternalResourceReference(
    ExternalResourceType^ resourceType
)
member GetExternalResourceReference :
        resourceType : ExternalResourceType -> ExternalResourceReference

Parameters

resourceType ExternalResourceType
The desired external resource type.

Return Value

ExternalResourceReference
The copy of the ExternalResourceReference associated with a specified external resource type.
Exceptions
Exception | Condition
ArgumentException | This Element does not use a resource reference for the specified resource type.
ArgumentNullException | A non-optional argument was null
Remarks
For an element which has multiple external resource references under a specified type like AppearanceAssetElement, it will return the first one. See also: [!:Autodesk::Revit::DB::Element::getExternalResourceReferenceExpanded].
See Also

Reference

Element Class


Element.GetExternalResourceReferenceExpanded Method

ElementGetExternalResourceReferenceExpanded Method

Gets the collection of ExternalResourceReference associated with a specified external resource type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ExternalResourceReference> GetExternalResourceReferenceExpanded(
    ExternalResourceType resourceType
)
Public Function GetExternalResourceReferenceExpanded (
    resourceType As ExternalResourceType
) As IList(Of ExternalResourceReference)
public:
IList<ExternalResourceReference^>^ GetExternalResourceReferenceExpanded(
    ExternalResourceType^ resourceType
)
member GetExternalResourceReferenceExpanded :
        resourceType : ExternalResourceType -> IList<ExternalResourceReference>

Parameters

resourceType ExternalResourceType
The desired external resource type.

Return Value

IList ExternalResourceReference
The collection of the ExternalResourceReference associated with a specified external resource type.
Exceptions
Exception | Condition
ArgumentException | This Element does not use a resource reference for the specified resource type.
ArgumentNullException | A non-optional argument was null
Remarks
Use this API for an element which has multiple external resource references under a specified type, e.g., AppearanceAssetElement. See also: [!:Autodesk::Revit::DB::Element::getExternalResourceReference].
See Also

Reference

Element Class


Element.GetExternalResourceReferences Method

ElementGetExternalResourceReferences Method

Gets the map of the external resource references referenced by the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IDictionary<ExternalResourceType, ExternalResourceReference> GetExternalResourceReferences()
Public Function GetExternalResourceReferences As IDictionary(Of ExternalResourceType, ExternalResourceReference)
public:
IDictionary<ExternalResourceType^, ExternalResourceReference^>^ GetExternalResourceReferences()
member GetExternalResourceReferences : unit -> IDictionary<ExternalResourceType, ExternalResourceReference>

Return Value

IDictionary ExternalResourceType, ExternalResourceReference
The map of the external resource references referenced by the element.
Exceptions
Exception | Condition
InvalidOperationException | This Element does not use any external resource.
Remarks
For an element which has multiple external resource references under a specified type like AppearanceAssetElement, the first one will be the value in the map. See also: [!:Autodesk::Revit::DB::Element::getExternalResourceReferencesExpanded].
See Also

Reference

Element Class


Element.GetExternalResourceReferencesExpanded Method

ElementGetExternalResourceReferencesExpanded Method

Gets the expanded map of the external resource references referenced by the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IDictionary<ExternalResourceType, IList<ExternalResourceReference>> GetExternalResourceReferencesExpanded()
Public Function GetExternalResourceReferencesExpanded As IDictionary(Of ExternalResourceType, IList(Of ExternalResourceReference))
public:
IDictionary<ExternalResourceType^, IList<ExternalResourceReference^>^>^ GetExternalResourceReferencesExpanded()
member GetExternalResourceReferencesExpanded : unit -> IDictionary<ExternalResourceType, IList<ExternalResourceReference>>

Return Value

IDictionary ExternalResourceType, IList ExternalResourceReference
The expanded map of the external resource references referenced by the element.
Exceptions
Exception | Condition
InvalidOperationException | This Element does not use any external resource.
Remarks
The value includes all external resource references under the type. Use this API for an element which has multiple external resource references under a specified type, e.g., AppearanceAssetElement. See also: [!:Autodesk::Revit::DB::Element::getExternalResourceReferences].
See Also

Reference

Element Class


Element.GetGeneratingElementIds Method

ElementGetGeneratingElementIds Method

Returns the ids of the element(s) that generated the input geometry object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetGeneratingElementIds(
    GeometryObject geometryObject
)
Public Function GetGeneratingElementIds (
    geometryObject As GeometryObject
) As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetGeneratingElementIds(
    GeometryObject^ geometryObject
)
member GetGeneratingElementIds :
        geometryObject : GeometryObject -> ICollection<ElementId>

Parameters

geometryObject GeometryObject
The geometry object whose generating element is requested.

Return Value

ICollection ElementId
The id(s) of the element(s) that generated (or may have generated) the given geometry object. Empty if no generating elements are found. If the set contains just one id, it is the id of the element that generated the geometry object.
Exceptions
Exception | Condition
ArgumentException | The input geometryObject is invalid and so cannot be used to obtain the generating element ids.
ArgumentNullException | A non-optional argument was null
Remarks
This function supports many different types of relationships among elements. Most of these relationships will return a single element, for example:
  • Window and door cutting walls
  • Openings cutting hosts
  • Face splitting faces
  • Wall sweep or reveal traversing wall
A few relationships have the potential for returning multiple elements, including:
  • Walls joining to other wall(s)
  • Elements extending to roof(s)
If more than one id is returned, one of them (unspecified) is the id of the element that generated the geometry object and the others are ids of related elements. For example, if a wall A is joined to two walls B and C in a way that creates two end faces, and if this function is called for one of the two end faces, it will return the ids of walls B and C.
Example
C#
VB
C++
F#
Copy
// Find elements joined or attached to the end faces of a given wall (such as walls and roofs).
// Mid-joined walls (such as in a T configuration) are not found because they do not affect end face geometry.

ICollection<ElementId> joinedElements = new Collection<ElementId>(); // collection to store the walls joined to the selected wall

// find all faces of the selected wall
GeometryElement geometryElement = wall.get_Geometry(new Options());
foreach (GeometryObject geometryObject in geometryElement)
{
    if (geometryObject is Solid)
    {
        Solid solid = geometryObject as Solid;
        foreach (Face face in solid.Faces)
        {
            // for each face, find the other elements that generated the geometry of that face
            ICollection<ElementId> generatingElementIds = wall.GetGeneratingElementIds(face);

            generatingElementIds.Remove(wall.Id); // remove the originally selected wall, leaving only other elements joined to it
            foreach (ElementId id in generatingElementIds)
            {
                if (!(joinedElements.Contains(id)))
                    joinedElements.Add(id); // add each wall joined to this face to the overall collection
            }
        }
    }
}

uidocument.Selection.SetElementIds(joinedElements); // select all of the joined elements
' Find elements joined or attached to the end faces of a given wall (such as walls and roofs).
' Mid-joined walls (such as in a T configuration) are not found because they do not affect end face geometry.

Dim joinedElements As ICollection(Of ElementId) = New Collection(Of ElementId)()
' collection to store the walls joined to the selected wall
' find all faces of the selected wall
Dim geometryElement As GeometryElement = wall.Geometry(New Options())
For Each geometryObject As GeometryObject In geometryElement
    If TypeOf geometryObject Is Solid Then
        Dim solid As Solid = TryCast(geometryObject, Solid)
        For Each face As Face In solid.Faces
            ' for each face, find the other elements that generated the geometry of that face
            Dim generatingElementIds As ICollection(Of ElementId) = wall.GetGeneratingElementIds(face)

            generatingElementIds.Remove(wall.Id)
            ' remove the originally selected wall, leaving only other elements joined to it
            For Each id As ElementId In generatingElementIds
                If Not (joinedElements.Contains(id)) Then
                    joinedElements.Add(id)
                    ' add each wall joined to this face to the overall collection
                End If
            Next
        Next
    End If
Next

uidocument.Selection.SetElementIds(joinedElements)
' select all of the joined elements

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Element Class


Element.GetGeometryObjectFromReference Method

ElementGetGeometryObjectFromReference Method

Retrieve one geometric primitive contained in the element given a reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GeometryObject GetGeometryObjectFromReference(
    Reference reference
)
Public Function GetGeometryObjectFromReference (
    reference As Reference
) As GeometryObject
public:
GeometryObject^ GetGeometryObjectFromReference(
    Reference^ reference
)
member GetGeometryObjectFromReference :
        reference : Reference -> GeometryObject

Parameters

reference Reference
The geometric object referenced by this instance will be retrieved from the model.

Return Value

GeometryObject
The geometric object referenced by the input reference.
Exceptions
Exception | Condition
ArgumentException | The id of this element is not same as that referenced by reference
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The element id held by the input reference is not same as the id of this element. The geometric information could not be taken for this element.
Remarks
It will return the last geometric object in the path. will be returned if related geometric object could not be found in the model.
See Also

Reference

Element Class


Element.GetMaterialArea Method

ElementGetMaterialArea Method

Gets the area of the material with the given id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetMaterialArea(
    ElementId materialId,
    bool usePaintMaterial
)
Public Function GetMaterialArea (
    materialId As ElementId,
    usePaintMaterial As Boolean
) As Double
public:
double GetMaterialArea(
    ElementId^ materialId,
    bool usePaintMaterial
)
member GetMaterialArea :
        materialId : ElementId *
        usePaintMaterial : bool -> float

Parameters

materialId ElementId
The material id returned from GetMaterialIds(Boolean).
usePaintMaterial Boolean
If true, this material id was returned as a paint material from GetMaterialIds(Boolean) and the area returned should be calculated from paint applied to the element. If false, this material id was returned as a non-paint element material from GetMaterialIds(Boolean) and the area is calculated from the element geometry and layers.

Return Value

Double
The area of the material for this element. Returns 0.0 if the material id is not a part of this element.
Exceptions
Exception | Condition
ArgumentException | materialId is not a valid Element identifier.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This Element element does not support paint material assignment.
See Also

Reference

Element Class


Element.GetMaterialIds Method

ElementGetMaterialIds Method

Gets the element ids of all materials present in the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetMaterialIds(
    bool returnPaintMaterials
)
Public Function GetMaterialIds (
    returnPaintMaterials As Boolean
) As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetMaterialIds(
    bool returnPaintMaterials
)
member GetMaterialIds :
        returnPaintMaterials : bool -> ICollection<ElementId>

Parameters

returnPaintMaterials Boolean
If true, this returns material ids assigned to element faces by the Paint tools. If false, this returns ids associated to the material through its geometry or compound structure layers.

Return Value

ICollection ElementId
The set of material ids.
Remarks
The returned collection of materials will be empty in any of the following situations:
  • The returnPaintMaterials flag is false, and the Category.HasMaterialQuantities property of the element's Category is false.
  • The returnPaintMaterials flag is true, and the the element does not have any painted faces.
Any material ids returned by this method can be used in GetMaterialArea() to get the calculated area associated to the material. Non-paint materials ids returned by this method can be used in GetMaterialVolume() to get the volume associated to the material.
See Also

Reference

Element Class


Element.GetMaterialVolume Method

ElementGetMaterialVolume Method

Gets the volume of the material with the given id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetMaterialVolume(
    ElementId materialId
)
Public Function GetMaterialVolume (
    materialId As ElementId
) As Double
public:
double GetMaterialVolume(
    ElementId^ materialId
)
member GetMaterialVolume :
        materialId : ElementId -> float

Parameters

materialId ElementId
The material id returned from GetMaterialIds(Boolean).

Return Value

Double
The volume of the material for this element. Returns 0.0 if the material is not a part of this element.
Exceptions
Exception | Condition
ArgumentException | materialId is not a valid Element identifier.
ArgumentNullException | A non-optional argument was null
See Also

Reference

Element Class


Element.GetMonitoredLinkElementIds Method

ElementGetMonitoredLinkElementIds Method

Provides the link instance IDs when the element is monitoring.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ElementId> GetMonitoredLinkElementIds()
Public Function GetMonitoredLinkElementIds As IList(Of ElementId)
public:
IList<ElementId^>^ GetMonitoredLinkElementIds()
member GetMonitoredLinkElementIds : unit -> IList<ElementId>

Return Value

IList ElementId
The IDs of linked instances.
See Also

Reference

Element Class


Element.GetMonitoredLocalElementIds Method

ElementGetMonitoredLocalElementIds Method

Provides the local element IDs when the element is monitoring.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ElementId> GetMonitoredLocalElementIds()
Public Function GetMonitoredLocalElementIds As IList(Of ElementId)
public:
IList<ElementId^>^ GetMonitoredLocalElementIds()
member GetMonitoredLocalElementIds : unit -> IList<ElementId>

Return Value

IList ElementId
The IDs of local element IDs being monitored by this element.
See Also

Reference

Element Class


Element.GetOrderedParameters Method

ElementGetOrderedParameters Method

Gets the parameters associated to the element in order.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<Parameter> GetOrderedParameters()
Public Function GetOrderedParameters As IList(Of Parameter)
public:
IList<Parameter^>^ GetOrderedParameters()
member GetOrderedParameters : unit -> IList<Parameter>

Return Value

IList Parameter
A collection containing all parameters.
Remarks

The collection consists of only visible parameters associated to the element; it returns a different list than Element.Parameters.

The parameters are returned in the order in which they appear in the Revit UI within a given group; however, parameters of different groups may be mixed within this output.

Currently the Revit UI order is determined first by group and next by the order of the individual parameters.

See Also

Reference

Element Class


Element.GetParameter Method

ElementGetParameter Method

Retrieves a parameter from the element given identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Parameter GetParameter(
    ForgeTypeId parameterTypeId
)
Public Function GetParameter (
    parameterTypeId As ForgeTypeId
) As Parameter
public:
Parameter^ GetParameter(
    ForgeTypeId^ parameterTypeId
)
member GetParameter :
        parameterTypeId : ForgeTypeId -> Parameter

Parameters

parameterTypeId ForgeTypeId
Identifier of the built-in parameter.

Return Value

Parameter
Exceptions
Exception | Condition
ArgumentException | parameterTypeId does not identify a built-in parameter. See Parameter.IsBuiltInParameter(ForgeTypeId) and Parameter.GetParameterTypeId(BuiltInParameter).
ArgumentNullException | A non-optional argument was NULL
Remarks
Parameters are a generic form of data storage within elements. The parameters are visible through the Autodesk Revit user interface in the Element Properties dialog. This method uses a built in parameter identifier to access the parameter. Autodesk Revit has a large number of built in parameters that are available via static properties.
See Also

Reference

Element Class


Element.GetParameterFormatOptions Method

ElementGetParameterFormatOptions Method

Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormatOptions GetParameterFormatOptions(
    ElementId parameterId
)
Public Function GetParameterFormatOptions (
    parameterId As ElementId
) As FormatOptions
public:
FormatOptions^ GetParameterFormatOptions(
    ElementId^ parameterId
)
member GetParameterFormatOptions :
        parameterId : ElementId -> FormatOptions

Parameters

parameterId ElementId
Id of parameter for which FormatOptions will be returned.

Return Value

FormatOptions
Format options of element parameter. If the UseDefault property is true, then no formatting overrides have been defined in the element for the specified parameter, and the FormatOptions for the parameter should be obtained from the Unit object, which can be obtained from the Document.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

Element Class


Element.GetParameters Method

ElementGetParameters Method

Retrieves the parameters from the element via the given name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<Parameter> GetParameters(
    string name
)
Public Function GetParameters (
    name As String
) As IList(Of Parameter)
public:
IList<Parameter^>^ GetParameters(
    String^ name
)
member GetParameters :
        name : string -> IList<Parameter>

Parameters

name String
The name of the parameter to be retrieved.

Return Value

IList Parameter
A collection containing the parameters having the same given parameter name.
Remarks

Multiple matches of parameters with the same name can occur because shared parameters or project parameters can be bound to an element category even if there is a built-in parameter with the same name already.

If this method is used to find built-in parameters the code will not be portable to other languages of Revit (because built-in parameter names are translated, and this method matches the translation).

For the reasons above this method should be used sparingly and when portability across multiple languages is not a requirement.

Safer approaches include:

  • get_Parameter(Guid) to get a shared parameter by stored guid.
  • get_Parameter(BuiltInParameter) to find a built-in parameter in a language-independent way.
See Also

Reference

Element Class


Element.GetPhaseStatus Method

ElementGetPhaseStatus Method

Gets the status of a given element in the input phase

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementOnPhaseStatus GetPhaseStatus(
    ElementId phaseId
)
Public Function GetPhaseStatus (
    phaseId As ElementId
) As ElementOnPhaseStatus
public:
ElementOnPhaseStatus GetPhaseStatus(
    ElementId^ phaseId
)
member GetPhaseStatus :
        phaseId : ElementId -> ElementOnPhaseStatus

Parameters

phaseId ElementId
Id of the phase.

Return Value

ElementOnPhaseStatus
The status of the element in the phase.
Exceptions
Exception | Condition
ArgumentException | The id does not represent a valid phase.
ArgumentNullException | A non-optional argument was null
See Also

Reference

Element Class


Element.GetSubelements Method

ElementGetSubelements Method

Returns the collection of element subelements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<Subelement> GetSubelements()
Public Function GetSubelements As IList(Of Subelement)
public:
IList<Subelement^>^ GetSubelements()
member GetSubelements : unit -> IList<Subelement>

Return Value

IList Subelement
The collection of element subelements.
Remarks
This collection will not include the Element itself.
See Also

Reference

Element Class


Element.GetTypeId Method

ElementGetTypeId Method

Returns the identifier of this element's type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GetTypeId()
Public Function GetTypeId As ElementId
public:
ElementId^ GetTypeId()
member GetTypeId : unit -> ElementId

Return Value

ElementId
The id of the element's type, or invalid element id if the element cannot have type assigned.
Remarks
Some elements cannot have type assigned, in which case this method returns invalid element id.
Example
C#
VB
C++
F#
Copy
void GetStairType(Autodesk.Revit.DB.Document document)
{
   FilteredElementCollector collector = new FilteredElementCollector(document);
   ICollection<Element> stairs = collector.OfClass(typeof(FamilyInstance)).OfCategory(BuiltInCategory.OST_Stairs).ToElements();
   foreach (Element stair in stairs)
    {
        if (null == stair.GetTypeId())
        {
            TaskDialog.Show("Revit","No symbol found in stair element: " + stair.Name);
        }
        else
        {
            Element elemType = document.GetElement(stair.GetTypeId());
            string info = "Stair type is: " + elemType.Name;
            TaskDialog.Show("Revit",info);
        }
    }
}
Private Sub GetStairType(document As Autodesk.Revit.DB.Document)
    Dim collector As New FilteredElementCollector(document)
    Dim stairs As ICollection(Of Element) = collector.OfClass(GetType(FamilyInstance)).OfCategory(BuiltInCategory.OST_Stairs).ToElements()
    For Each stair As Element In stairs
        If stair.GetTypeId() Is Nothing Then
            TaskDialog.Show("Revit", "No symbol found in stair element: " + stair.Name)
        Else
            Dim elemType As Element = document.GetElement(stair.GetTypeId())
            Dim info As String = "Stair type is: " + elemType.Name
            TaskDialog.Show("Revit", info)
        End If
    Next
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Element Class


Element.GetValidTypes Method

ElementGetValidTypes Method

Overload List
 | Name | Description
Public method | GetValidTypes | Obtains a set of types that are valid for this element.
 | GetValidTypes(Document, ICollectionElementId) | Obtains a set of types that are valid for all given elements.
Top
See Also

Reference

Element Class


Element.GetValidTypes Method

ElementGetValidTypes Method

Obtains a set of types that are valid for this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetValidTypes()
Public Function GetValidTypes As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetValidTypes()
member GetValidTypes : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
A set of element IDs of types that are valid for this element or an empty set if element cannot have type assigned.
See Also

Reference

Element Class
GetValidTypes Overload


Element.GetValidTypes(Document, ICollection<ElementId>) Method

ElementGetValidTypes(Document, ICollectionElementId) Method

Obtains a set of types that are valid for all given elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ICollection<ElementId> GetValidTypes(
    Document document,
    ICollection<ElementId> elementIds
)
Public Shared Function GetValidTypes (
    document As Document,
    elementIds As ICollection(Of ElementId)
) As ICollection(Of ElementId)
public:
static ICollection<ElementId^>^ GetValidTypes(
    Document^ document,
    ICollection<ElementId^>^ elementIds
)
static member GetValidTypes :
        document : Document *
        elementIds : ICollection<ElementId> -> ICollection<ElementId>

Parameters

document Document
The document.
elementIds ICollection ElementId
A collection of element IDs.

Return Value

ICollection ElementId
A set of element IDs of types that are valid for these elements or an empty set if any element cannot have a type assigned.
Exceptions
Exception | Condition
ArgumentException | Thrown when at least one of the elements does not exist in the document.
ArgumentNullException | A non-optional argument was null
See Also

Reference

Element Class
GetValidTypes Overload


Element.HasPhases Method

ElementHasPhases Method

Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasPhases()
Public Function HasPhases As Boolean
public:
bool HasPhases()
member HasPhases : unit -> bool

Return Value

Boolean
True if this Element has the properties CreatedPhaseId and DemolishedPhaseId, false otherwise.
Remarks
Acts as a validator for setting the properties CreatedPhaseId and DemolishedPhaseId.
See Also

Reference

Element Class


Element.IsCreatedPhaseOrderValid Method

ElementIsCreatedPhaseOrderValid Method

Returns true if createdPhaseId and demolishedPhaseId are in order.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCreatedPhaseOrderValid(
    ElementId createdPhaseId
)
Public Function IsCreatedPhaseOrderValid (
    createdPhaseId As ElementId
) As Boolean
public:
bool IsCreatedPhaseOrderValid(
    ElementId^ createdPhaseId
)
member IsCreatedPhaseOrderValid :
        createdPhaseId : ElementId -> bool

Parameters

createdPhaseId ElementId
The createdPhaseId.

Return Value

Boolean
True if createdPhaseId index is less than or equal to demolishedPhaseId, otherwise returns false.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

Element Class


Element.IsDemolishedPhaseOrderValid Method

ElementIsDemolishedPhaseOrderValid Method

Returns true if createdPhaseId and demolishedPhaseId are in order.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsDemolishedPhaseOrderValid(
    ElementId demolishedPhaseId
)
Public Function IsDemolishedPhaseOrderValid (
    demolishedPhaseId As ElementId
) As Boolean
public:
bool IsDemolishedPhaseOrderValid(
    ElementId^ demolishedPhaseId
)
member IsDemolishedPhaseOrderValid :
        demolishedPhaseId : ElementId -> bool

Parameters

demolishedPhaseId ElementId
The demolishedPhaseId.

Return Value

Boolean
True if createdPhaseId index is less than or equal to demolishedPhaseId, otherwise returns false.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

Element Class


Element.IsExternalFileReference Method

ElementIsExternalFileReference Method

Determines whether this Element represents an external file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsExternalFileReference()
Public Function IsExternalFileReference As Boolean
public:
bool IsExternalFileReference()
member IsExternalFileReference : unit -> bool

Return Value

Boolean
True if this element contains information about some external file, false if it does not.
Remarks
Linked files are references to external files, but imported files are not, as their data is brought wholly into Revit.
See Also

Reference

Element Class


Element.IsHidden Method

ElementIsHidden Method

Identifies if the element has been permanently hidden in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsHidden(
    View pView
)
Public Function IsHidden (
    pView As View
) As Boolean
public:
bool IsHidden(
    View^ pView
)
member IsHidden :
        pView : View -> bool

Parameters

pView View

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentNullException | Thrown when argument is .
Remarks
This does not determine if the element is hidden as a result of temporary hide/isolate, view sectioning, view crop box, or other operations that can cause elements not to be visible. To hide or unhide an element, use the Hide() and Unhide() method of View.
See Also

Reference

Element Class


Element.IsMonitoringLinkElement Method

ElementIsMonitoringLinkElement Method

Indicate whether an element is monitoring any elements in any linked models.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsMonitoringLinkElement()
Public Function IsMonitoringLinkElement As Boolean
public:
bool IsMonitoringLinkElement()
member IsMonitoringLinkElement : unit -> bool

Return Value

Boolean
True if this element is monitoring elements in a linked models. Otherwise, false will be returned.
See Also

Reference

Element Class


Element.IsMonitoringLocalElement Method

ElementIsMonitoringLocalElement Method

Indicate whether an element is monitoring other local elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsMonitoringLocalElement()
Public Function IsMonitoringLocalElement As Boolean
public:
bool IsMonitoringLocalElement()
member IsMonitoringLocalElement : unit -> bool

Return Value

Boolean
True if this element is monitoring other elements in same project. Otherwise, false will be returned.
See Also

Reference

Element Class


Element.IsPhaseCreatedValid Method

ElementIsPhaseCreatedValid Method

Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsPhaseCreatedValid(
    ElementId createdPhaseId
)
Public Function IsPhaseCreatedValid (
    createdPhaseId As ElementId
) As Boolean
public:
bool IsPhaseCreatedValid(
    ElementId^ createdPhaseId
)
member IsPhaseCreatedValid :
        createdPhaseId : ElementId -> bool

Parameters

createdPhaseId ElementId
The id of a Phase.

Return Value

Boolean
True if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Acts as a validator for setting the property CreatedPhaseId.
See Also

Reference

Element Class


Element.IsPhaseDemolishedValid Method

ElementIsPhaseDemolishedValid Method

Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsPhaseDemolishedValid(
    ElementId demolishedPhaseId
)
Public Function IsPhaseDemolishedValid (
    demolishedPhaseId As ElementId
) As Boolean
public:
bool IsPhaseDemolishedValid(
    ElementId^ demolishedPhaseId
)
member IsPhaseDemolishedValid :
        demolishedPhaseId : ElementId -> bool

Parameters

demolishedPhaseId ElementId
The id of a Phase or invalidElementId.

Return Value

Boolean
True if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Acts as a validator for setting the property DemolishedPhaseId.
See Also

Reference

Element Class


Element.IsValidType Method

ElementIsValidType Method

Overload List
 | Name | Description
Public method | IsValidType(ElementId) | Checks if given type is valid for this element.
 | IsValidType(Document, ICollectionElementId, ElementId) | Checks if given type is valid for the set of elements.
Top
See Also

Reference

Element Class


Element.IsValidType(ElementId) Method

ElementIsValidType(ElementId) Method

Checks if given type is valid for this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidType(
    ElementId typeId
)
Public Function IsValidType (
    typeId As ElementId
) As Boolean
public:
bool IsValidType(
    ElementId^ typeId
)
member IsValidType :
        typeId : ElementId -> bool

Parameters

typeId ElementId
ElementId of the type to check.

Return Value

Boolean
True if element can have a type assigned and this type is valid for this element, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
A type is valid for an element if it can be assigned to the element.
See Also

Reference

Element Class
IsValidType Overload


Element.IsValidType(Document, ICollection<ElementId>, ElementId) Method

ElementIsValidType(Document, ICollectionElementId, ElementId) Method

Checks if given type is valid for the set of elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidType(
    Document document,
    ICollection<ElementId> elementIds,
    ElementId typeId
)
Public Shared Function IsValidType (
    document As Document,
    elementIds As ICollection(Of ElementId),
    typeId As ElementId
) As Boolean
public:
static bool IsValidType(
    Document^ document,
    ICollection<ElementId^>^ elementIds,
    ElementId^ typeId
)
static member IsValidType :
        document : Document *
        elementIds : ICollection<ElementId> *
        typeId : ElementId -> bool

Parameters

document Document
The document.
elementIds ICollection ElementId
A collection of element IDs.
typeId ElementId
ElementId of the type to check.

Return Value

Boolean
True if all elements can have a type assigned and this type is valid for all elements, false otherwise.
Exceptions
Exception | Condition
ArgumentException | Thrown when at least one of the elements does not exist in the document.
ArgumentNullException | A non-optional argument was null
Remarks
A type is valid for the set of elements if it is valid for each and every element in the set.
See Also

Reference

Element Class
IsValidType Overload


Element.LookupParameter Method

ElementLookupParameter Method

Attempts to find a parameter on the element which has the given name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Parameter LookupParameter(
    string name
)
Public Function LookupParameter (
    name As String
) As Parameter
public:
Parameter^ LookupParameter(
    String^ name
)
member LookupParameter :
        name : string -> Parameter

Parameters

name String
The name of the parameter to be retrieved.

Return Value

Parameter
The matching parameter. This return may be if there is no matching parameter. If there are multiple matching parameters the first one found is returned.
Remarks
This method will attempt to find a parameter on this Element whose name matches the input. The possible results include:
  • A single matching parameter is found: it will be returned.
  • No matching parameter is found: is returned.
  • Multiple matching parameters exist. In this situation the first one encountered will be returned. This match is determined at random and may change in the future.

Multiple matches of parameters with the same name can occur because shared parameters or project parameters can be bound to an element category even if there is a built-in parameter with the same name already.

If this method is used to find built-in parameters the code will not be portable to other languages of Revit (because built-in parameter names are translated, and this method matches the translation).

For the reasons above this method should be used sparingly and only when you have a reasonable expectation that only one parameter exists with the given name, and when portability across multiple languages is not a requirement.

Safer approaches include:

  • GetParameters(String) to get all the matches with the given name.
  • get_Parameter(Guid) to get a shared parameter by stored guid.
  • get_Parameter(BuiltInParameter) to find a built-in parameter in a language-independent way.
See Also

Reference

Element Class


Element.RefersToExternalResourceReference Method

ElementRefersToExternalResourceReference Method

Determines whether this Element uses external resources associated with a specified external resource type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool RefersToExternalResourceReference(
    ExternalResourceType resourceType
)
Public Function RefersToExternalResourceReference (
    resourceType As ExternalResourceType
) As Boolean
public:
bool RefersToExternalResourceReference(
    ExternalResourceType^ resourceType
)
member RefersToExternalResourceReference :
        resourceType : ExternalResourceType -> bool

Parameters

resourceType ExternalResourceType
The desired external resource type.

Return Value

Boolean
Returns true if this Element uses external resources associated with the specified external resource type; otherwise, false.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

Element Class


Element.RefersToExternalResourceReferences Method

ElementRefersToExternalResourceReferences Method

Determines whether this Element uses external resources.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool RefersToExternalResourceReferences()
Public Function RefersToExternalResourceReferences As Boolean
public:
bool RefersToExternalResourceReferences()
member RefersToExternalResourceReferences : unit -> bool

Return Value

Boolean
True if this element uses external resources, false if it does not.
Remarks
Some elements may contain references to data from external resources. These elements contain one or more ExternalResourceReferences.
See Also

Reference

Element Class


Element.SetEntity Method

ElementSetEntity Method

Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetEntity(
    Entity entity
)
Public Sub SetEntity (
    entity As Entity
)
public:
void SetEntity(
    Entity^ entity
)
member SetEntity :
        entity : Entity -> unit

Parameters

entity Entity
The Entity to be stored.
Exceptions
Exception | Condition
ArgumentException | Writing of Entities of this Schema is not allowed to the current add-in.
ArgumentNullException | A non-optional argument was null
See Also

Reference

Element Class


ElementArray Class

An array that contains element objects.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBElementArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ElementArray : APIObject,
    IEnumerable
Public Class ElementArray
    Inherits APIObject
    Implements IEnumerable
public ref class ElementArray : public APIObject,
    IEnumerable
type ElementArray =
    class
        inherit APIObject
        interface IEnumerable
    end

The ElementArray type exposes the following members.

Constructors
 | Name | Description
Public method | ElementArray | Initializes a new instance of the ElementArray class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets an element at a specified index within the array.
Public property | Size | Returns the number of elements that are in the array.
Top
Methods
 | Name | Description
Public method | Append | Add the element to the end of the array.
Public method | Clear | Removes every element from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified element into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ElementArray Constructor

Initializes a new instance of the ElementArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementArray()
Public Sub New
public:
ElementArray()
new : unit -> ElementArray
See Also

Reference

ElementArray Class


ElementArray Properties

The ElementArray type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets an element at a specified index within the array.
Public property | Size | Returns the number of elements that are in the array.
Top
See Also

Reference

ElementArray Class


ElementArray.IsEmpty Property

ElementArrayIsEmpty Property

Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Boolean
Remarks
If the array is empty then True will be returned, otherwise False.
See Also

Reference

ElementArray Class


ElementArray.Item Property

ElementArrayItem Property

Gets or sets an element at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Element this[
    int index
] { get; set; }
Public Overridable Property Item (
    index As Integer
) As Element
    Get
    Set
public:
virtual property Element^ Item[int index] {
    Element^ get (int index);
    void set (int index, Element^ value);
}
abstract Item : Element with get, set
override Item : Element with get, set

Parameters

index Int32
The index of the element to be set or retrieved.

Return Value

Element
Returns the element at the specified index.
See Also

Reference

ElementArray Class


ElementArray.Size Property

ElementArraySize Property

Returns the number of elements that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
abstract Size : int with get
override Size : int with get

Property Value

Int32
See Also

Reference

ElementArray Class


ElementArray Methods

The ElementArray type exposes the following members.

Methods
 | Name | Description
Public method | Append | Add the element to the end of the array.
Public method | Clear | Removes every element from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified element into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ElementArray Class


ElementArray.Append Method

ElementArrayAppend Method

Add the element to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Append(
    Element item
)
Public Overridable Sub Append (
    item As Element
)
public:
virtual void Append(
    Element^ item
)
abstract Append :
        item : Element -> unit
override Append :
        item : Element -> unit

Parameters

item Element
The element to be added.
See Also

Reference

ElementArray Class


ElementArray.Clear Method

ElementArrayClear Method

Removes every element from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

ElementArray Class


ElementArray.ForwardIterator Method

ElementArrayForwardIterator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ElementArrayIterator ForwardIterator()
Public Overridable Function ForwardIterator As ElementArrayIterator
public:
virtual ElementArrayIterator^ ForwardIterator()
abstract ForwardIterator : unit -> ElementArrayIterator
override ForwardIterator : unit -> ElementArrayIterator

Return Value

ElementArrayIterator
Returns a forward moving iterator to the array.
See Also

Reference

ElementArray Class


ElementArray.GetEnumerator Method

ElementArrayGetEnumerator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

IEnumerator
Returns a forward moving iterator to the array.

Implements

IEnumerableGetEnumerator
See Also

Reference

ElementArray Class


ElementArray.Insert Method

ElementArrayInsert Method

Insert the specified element into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Insert(
    Element item,
    int index
)
Public Overridable Sub Insert (
    item As Element,
    index As Integer
)
public:
virtual void Insert(
    Element^ item,
    int index
)
abstract Insert :
        item : Element *
        index : int -> unit
override Insert :
        item : Element *
        index : int -> unit

Parameters

item Element
The element to be inserted into the array.
index Int32
The element will be inserted before this index.

Return Value

Returns whether the element was inserted into the array.
See Also

Reference

ElementArray Class


ElementArray.ReverseIterator Method

ElementArrayReverseIterator Method

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ElementArrayIterator ReverseIterator()
Public Overridable Function ReverseIterator As ElementArrayIterator
public:
virtual ElementArrayIterator^ ReverseIterator()
abstract ReverseIterator : unit -> ElementArrayIterator
override ReverseIterator : unit -> ElementArrayIterator

Return Value

ElementArrayIterator
Returns a backward moving iterator to the array.
See Also

Reference

ElementArray Class


ElementArrayIterator Class

An iterator to an element array.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBElementArrayIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class ElementArrayIterator : APIObject,
    IEnumerator
Public MustInherit Class ElementArrayIterator
    Inherits APIObject
    Implements IEnumerator
public ref class ElementArrayIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type ElementArrayIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The ElementArrayIterator type exposes the following members.

Constructors
 | Name | Description
Public method | ElementArrayIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ElementArrayIterator Constructor

For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementArrayIterator()
Public Sub New
public:
ElementArrayIterator()
new : unit -> ElementArrayIterator
Remarks
This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.
See Also

Reference

ElementArrayIterator Class


ElementArrayIterator Properties

The ElementArrayIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

ElementArrayIterator Class


ElementArrayIterator.Current Property

ElementArrayIteratorCurrent Property

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}
abstract Current : Object with get
override Current : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.
See Also

Reference

ElementArrayIterator Class


ElementArrayIterator Methods

The ElementArrayIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ElementArrayIterator Class


ElementArrayIterator.MoveNext Method

ElementArrayIteratorMoveNext Method

Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumeratorMoveNext
Remarks
MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.
See Also

Reference

ElementArrayIterator Class


ElementArrayIterator.Reset Method

ElementArrayIteratorReset Method

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
Remarks
The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.
See Also

Reference

ElementArrayIterator Class


ElementBinding Class

A base class for all types of binding that attach to an element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBBinding
Autodesk.Revit.DBElementBinding
Autodesk.Revit.DBInstanceBinding
Autodesk.Revit.DBTypeBinding

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class ElementBinding : Binding
Public MustInherit Class ElementBinding
    Inherits Binding
public ref class ElementBinding abstract : public Binding
[<AbstractClassAttribute>]
type ElementBinding =
    class
        inherit Binding
    end

The ElementBinding type exposes the following members.

Properties
 | Name | Description
Public property | Categories | Retrieve or set the categories to which a parameter definition will be bound.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This base class provides methods that are common to all types of binding that work with elements.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ElementBinding Properties

The ElementBinding type exposes the following members.

Properties
 | Name | Description
Public property | Categories | Retrieve or set the categories to which a parameter definition will be bound.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

ElementBinding Class


ElementBinding.Categories Property

ElementBindingCategories Property

Retrieve or set the categories to which a parameter definition will be bound.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CategorySet Categories { get; set; }
Public Property Categories As CategorySet
    Get
    Set
public:
property CategorySet^ Categories {
    CategorySet^ get ();
    void set (CategorySet^ value);
}
member Categories : CategorySet with get, set

Property Value

CategorySet
Remarks
The Categories property is used to set the categories to which the definition will be bound when it is added to the document bindings. This property can also be read from existing bindings to interrogate to which categories a parameter has been bound.
See Also

Reference

ElementBinding Class


ElementBinding Methods

The ElementBinding type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ElementBinding Class


ElementCategoryFilter Class

A filter used to match elements by their category.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementQuickFilter
Autodesk.Revit.DBElementCategoryFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ElementCategoryFilter : ElementQuickFilter
Public Class ElementCategoryFilter
    Inherits ElementQuickFilter
public ref class ElementCategoryFilter : public ElementQuickFilter
type ElementCategoryFilter =
    class
        inherit ElementQuickFilter
    end

The ElementCategoryFilter type exposes the following members.

Constructors
 | Name | Description
Public method | ElementCategoryFilter(BuiltInCategory) | Constructs a new instance of a filter to match elements by category.
Public method | ElementCategoryFilter(ElementId) | Constructs a new instance of a filter to match elements by category.
Public method | ElementCategoryFilter(BuiltInCategory, Boolean) | Constructs a new instance of a filter to match elements by category, with the option to match all elements which are not of the given category.
Public method | ElementCategoryFilter(ElementId, Boolean) | Constructs a new instance of a filter to match elements by category, with the option to match all elements which are of the given category.
Top
Properties
 | Name | Description
Public property | CategoryId | The category id.
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.
Example
C#
VB
C++
F#
Copy
// Find all Wall instances in the document by using category filter
ElementCategoryFilter filter = new ElementCategoryFilter(BuiltInCategory.OST_Walls);

// Apply the filter to the elements in the active document,
// Use shortcut WhereElementIsNotElementType() to find wall instances only
FilteredElementCollector collector = new FilteredElementCollector(document);
IList<Element> walls = collector.WherePasses(filter).WhereElementIsNotElementType().ToElements();
String prompt = "The walls in the current document are:\n";
foreach (Element e in walls)
{
    prompt += e.Name + "\n";
}
TaskDialog.Show("Revit", prompt);
' Find all Wall instances in the document by using category filter
Dim filter As New ElementCategoryFilter(BuiltInCategory.OST_Walls)

' Apply the filter to the elements in the active document,
' Use shortcut WhereElementIsNotElementType() to find wall instances only
Dim collector As New FilteredElementCollector(document)
Dim walls As IList(Of Element) = collector.WherePasses(filter).WhereElementIsNotElementType().ToElements()
Dim prompt As [String] = "The walls in the current document are:" & vbLf
For Each e As Element In walls
   prompt += e.Name + vbLf
Next
TaskDialog.Show("Revit", prompt)

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ElementCategoryFilter Constructor

Overload List
 | Name | Description
Public method | ElementCategoryFilter(BuiltInCategory) | Constructs a new instance of a filter to match elements by category.
Public method | ElementCategoryFilter(ElementId) | Constructs a new instance of a filter to match elements by category.
Public method | ElementCategoryFilter(BuiltInCategory, Boolean) | Constructs a new instance of a filter to match elements by category, with the option to match all elements which are not of the given category.
Public method | ElementCategoryFilter(ElementId, Boolean) | Constructs a new instance of a filter to match elements by category, with the option to match all elements which are of the given category.
Top
See Also

Reference

ElementCategoryFilter Class


ElementCategoryFilter(BuiltInCategory) Constructor

Constructs a new instance of a filter to match elements by category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementCategoryFilter(
    BuiltInCategory category
)
Public Sub New (
    category As BuiltInCategory
)
public:
ElementCategoryFilter(
    BuiltInCategory category
)
new :
        category : BuiltInCategory -> ElementCategoryFilter

Parameters

category BuiltInCategory
The category to match.
See Also

Reference

ElementCategoryFilter Class
ElementCategoryFilter Overload


ElementCategoryFilter(ElementId) Constructor

Constructs a new instance of a filter to match elements by category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementCategoryFilter(
    ElementId categoryId
)
Public Sub New (
    categoryId As ElementId
)
public:
ElementCategoryFilter(
    ElementId^ categoryId
)
new :
        categoryId : ElementId -> ElementCategoryFilter

Parameters

categoryId ElementId
The category id to match.
Exceptions
Exception | Condition
ArgumentException | The category was not valid for filtering.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ElementCategoryFilter Class
ElementCategoryFilter Overload


ElementCategoryFilter(BuiltInCategory, Boolean) Constructor

Constructs a new instance of a filter to match elements by category, with the option to match all elements which are not of the given category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementCategoryFilter(
    BuiltInCategory category,
    bool inverted
)
Public Sub New (
    category As BuiltInCategory,
    inverted As Boolean
)
public:
ElementCategoryFilter(
    BuiltInCategory category,
    bool inverted
)
new :
        category : BuiltInCategory *
        inverted : bool -> ElementCategoryFilter

Parameters

category BuiltInCategory
The category to match.
inverted Boolean
True if the filter should match all elements which are not of the given category.
See Also

Reference

ElementCategoryFilter Class
ElementCategoryFilter Overload


ElementCategoryFilter(ElementId, Boolean) Constructor

Constructs a new instance of a filter to match elements by category, with the option to match all elements which are of the given category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementCategoryFilter(
    ElementId categoryId,
    bool inverted
)
Public Sub New (
    categoryId As ElementId,
    inverted As Boolean
)
public:
ElementCategoryFilter(
    ElementId^ categoryId,
    bool inverted
)
new :
        categoryId : ElementId *
        inverted : bool -> ElementCategoryFilter

Parameters

categoryId ElementId
The category id to match.
inverted Boolean
True if the filter should match all elements which are not of the given category.
Exceptions
Exception | Condition
ArgumentException | The category was not valid for filtering.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ElementCategoryFilter Class
ElementCategoryFilter Overload


ElementCategoryFilter Properties

The ElementCategoryFilter type exposes the following members.

Properties
 | Name | Description
Public property | CategoryId | The category id.
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
See Also

Reference

ElementCategoryFilter Class


ElementCategoryFilter.CategoryId Property

ElementCategoryFilterCategoryId Property

The category id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId CategoryId { get; }
Public ReadOnly Property CategoryId As ElementId
    Get
public:
property ElementId^ CategoryId {
    ElementId^ get ();
}
member CategoryId : ElementId with get

Property Value

ElementId
See Also

Reference

ElementCategoryFilter Class


ElementCategoryFilter Methods

The ElementCategoryFilter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ElementCategoryFilter Class


ElementClassFilter Class

A filter used to match elements by their class.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementQuickFilter
Autodesk.Revit.DBElementClassFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ElementClassFilter : ElementQuickFilter
Public Class ElementClassFilter
    Inherits ElementQuickFilter
public ref class ElementClassFilter : public ElementQuickFilter
type ElementClassFilter =
    class
        inherit ElementQuickFilter
    end

The ElementClassFilter type exposes the following members.

Constructors
 | Name | Description
Public method | ElementClassFilter(Type) | Constructs a new instance of a filter to match elements by class.
Public method | ElementClassFilter(Type, Boolean) | Constructs a new instance of a filter to match elements by class, with the option to match all elements which are not of the given class.
Top
Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetElementClass | The class for the filter.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

This filter will match elements whose class is an exact match to the input class, or elements whose class is derived from the input class.

There is a small subset of Element subclasses in the API which are not supported by this filter. These types exist in the API, but not in Revit's native object model, which means that this filter doesn't support them. In order to use a class filter to find elements of these types, it is necessary to use a higher level class and then process the results further to find elements matching only the subtype. The following types are affected by this restriction:

  • Subclasses of Autodesk.Revit.DB.Material
  • Subclasses of Autodesk.Revit.DB.CurveElement
  • Subclasses of Autodesk.Revit.DB.ConnectorElement
  • Subclasses of Autodesk.Revit.DB.HostedSweep
  • Autodesk.Revit.DB.Architecture.Room
  • Autodesk.Revit.DB.Mechanical.Space
  • Autodesk.Revit.DB.Area
  • Autodesk.Revit.DB.Architecture.RoomTag
  • Autodesk.Revit.DB.Mechanical.SpaceTag
  • Autodesk.Revit.DB.AreaTag
  • Autodesk.Revit.DB.CombinableElement
  • Autodesk.Revit.DB.Mullion
  • Autodesk.Revit.DB.Panel
  • Autodesk.Revit.DB.AnnotationSymbol
  • Autodesk.Revit.DB.Structure.AreaReinforcementType
  • Autodesk.Revit.DB.Structure.PathReinforcementType
  • Autodesk.Revit.DB.AnnotationSymbolType
  • Autodesk.Revit.DB.Architecture.RoomTagType
  • Autodesk.Revit.DB.Mechanical.SpaceTagType
  • Autodesk.Revit.DB.AreaTagType
  • Autodesk.Revit.DB.Structure.TrussType

Example
C#
VB
C++
F#
Copy
// Use ElementClassFilter to find family instances whose name is 60" x 30" Student
ElementClassFilter filter = new ElementClassFilter(typeof(FamilyInstance));

// Apply the filter to the elements in the active document
FilteredElementCollector collector = new FilteredElementCollector(document);
collector.WherePasses(filter);

// Use Linq query to find family instances whose name is 60" x 30" Student
var query = from element in collector
            where element.Name == "60\" x 30\" Student"
            select element;

// Cast found elements to family instances,
// this cast to FamilyInstance is safe because ElementClassFilter for FamilyInstance was used
List<FamilyInstance> familyInstances = query.Cast<FamilyInstance>().ToList<FamilyInstance>();
' Use ElementClassFilter to find family instances whose name is 60" x 30" Student
Dim filter As New ElementClassFilter(GetType(FamilyInstance))

' Apply the filter to the elements in the active document
Dim collector As New FilteredElementCollector(document)
collector.WherePasses(filter)

' Use Linq query to find family instances whose name is 60" x 30" Student
Dim query As System.Collections.Generic.IEnumerable(Of Autodesk.Revit.DB.Element)
query = From element In collector _
 Where element.Name = "60"" x 30"" Student" _
 Select element

' Cast found elements to family instances,
' this cast to FamilyInstance is safe because ElementClassFilter for FamilyInstance was used
Dim familyInstances As List(Of FamilyInstance) = query.Cast(Of FamilyInstance)().ToList()

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ElementClassFilter Constructor

Overload List
 | Name | Description
Public method | ElementClassFilter(Type) | Constructs a new instance of a filter to match elements by class.
Public method | ElementClassFilter(Type, Boolean) | Constructs a new instance of a filter to match elements by class, with the option to match all elements which are not of the given class.
Top
See Also

Reference

ElementClassFilter Class


ElementClassFilter(Type) Constructor

Constructs a new instance of a filter to match elements by class.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementClassFilter(
    Type type
)
Public Sub New (
    type As Type
)
public:
ElementClassFilter(
    Type^ type
)
new :
        type : Type -> ElementClassFilter

Parameters

type Type
The type to match.
Exceptions
Exception | Condition
ArgumentException | The input type is not a subclass of Element. -or- The input type is of an element class that exists in the API, but not in Revit's native object model.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ElementClassFilter Class
ElementClassFilter Overload


ElementClassFilter(Type, Boolean) Constructor

Constructs a new instance of a filter to match elements by class, with the option to match all elements which are not of the given class.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementClassFilter(
    Type type,
    bool inverted
)
Public Sub New (
    type As Type,
    inverted As Boolean
)
public:
ElementClassFilter(
    Type^ type,
    bool inverted
)
new :
        type : Type *
        inverted : bool -> ElementClassFilter

Parameters

type Type
The type to match.
inverted Boolean
True if the filter should match all elements which are not of the given class.
Exceptions
Exception | Condition
ArgumentException | The input type is not a subclass of Element. -or- The input type is of an element class that exists in the API, but not in Revit's native object model.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ElementClassFilter Class
ElementClassFilter Overload


ElementClassFilter Properties

The ElementClassFilter type exposes the following members.

Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
See Also

Reference

ElementClassFilter Class


ElementClassFilter Methods

The ElementClassFilter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetElementClass | The class for the filter.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ElementClassFilter Class


ElementClassFilter.GetElementClass Method

ElementClassFilterGetElementClass Method

The class for the filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Type GetElementClass()
Public Function GetElementClass As Type
public:
Type^ GetElementClass()
member GetElementClass : unit -> Type

Return Value

Type
The class.
See Also

Reference

ElementClassFilter Class


ElementDesignOptionFilter Class

A filter used to find elements contained within a particular design option.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementQuickFilter
Autodesk.Revit.DBElementDesignOptionFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ElementDesignOptionFilter : ElementQuickFilter
Public Class ElementDesignOptionFilter
    Inherits ElementQuickFilter
public ref class ElementDesignOptionFilter : public ElementQuickFilter
type ElementDesignOptionFilter =
    class
        inherit ElementQuickFilter
    end

The ElementDesignOptionFilter type exposes the following members.

Constructors
 | Name | Description
Public method | ElementDesignOptionFilter(ElementId) | Constructs a new instance of a filter to match elements contained within a particular design option.
Public method | ElementDesignOptionFilter(ElementId, Boolean) | Constructs a new instance of a filter to match elements contained within a particular design option, with the option to invert the filter and find elements not contained within a particular design option.
Top
Properties
 | Name | Description
Public property | DesignOptionId | The design option id.
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.
Example
C#
VB
C++
F#
Copy
// Create an ElementDesignOption filter to find all walls in the active design option.
// Note that if no design option is being edited, GetActiveDesignOptionId() method will return ElementId.InvalidElementId,
// ElementDesignOptionFilter with invalid id will filter elements not associated to a design option
ElementId activeOptId = Autodesk.Revit.DB.DesignOption.GetActiveDesignOptionId(document);

// Create an ElementDesignOption filter
ElementDesignOptionFilter filter = new ElementDesignOptionFilter(activeOptId);

// Apply the filter to the elements in the active document,
// use shortcut method OfClass() to find Walls only
FilteredElementCollector collector = new FilteredElementCollector(document);
ICollection<Element> wallsOfDesignOpt = collector.WherePasses(filter).OfClass(typeof(Wall)).ToElements();

// Find all walls that are not contained within active design option: use inverted filter to match elements
ElementDesignOptionFilter notActiveOptFilter = new ElementDesignOptionFilter(activeOptId, true); // inverted filter
collector = new FilteredElementCollector(document);
ICollection<Element> notActiveOptWalls =
    collector.WherePasses(notActiveOptFilter).OfClass(typeof(Wall)).ToElements();
' Create an ElementDesignOption filter to find all walls in the active design option.
' Note that if no design option is being edited, GetActiveDesignOptionId() method will return ElementId.InvalidElementId,
' ElementDesignOptionFilter with invalid id will filter elements not associated to a design option
Dim activeOptId As ElementId = Autodesk.Revit.DB.DesignOption.GetActiveDesignOptionId(document)

' Create an ElementDesignOption filter
Dim filter As New ElementDesignOptionFilter(activeOptId)

' Apply the filter to the elements in the active document,
' use shortcut method OfClass() to find Walls only
Dim collector As New FilteredElementCollector(document)
Dim wallsOfDesignOpt As ICollection(Of Element) = collector.WherePasses(filter).OfClass(GetType(Wall)).ToElements()

' Find all walls that are not contained within active design option: use inverted filter to match elements
Dim notActiveOptFilter As New ElementDesignOptionFilter(activeOptId, True)
' inverted filter
collector = New FilteredElementCollector(document)
Dim notActiveOptWalls As ICollection(Of Element) = collector.WherePasses(notActiveOptFilter).OfClass(GetType(Wall)).ToElements()

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ElementDesignOptionFilter Constructor

Overload List
 | Name | Description
Public method | ElementDesignOptionFilter(ElementId) | Constructs a new instance of a filter to match elements contained within a particular design option.
Public method | ElementDesignOptionFilter(ElementId, Boolean) | Constructs a new instance of a filter to match elements contained within a particular design option, with the option to invert the filter and find elements not contained within a particular design option.
Top
See Also

Reference

ElementDesignOptionFilter Class


ElementDesignOptionFilter(ElementId) Constructor

Constructs a new instance of a filter to match elements contained within a particular design option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementDesignOptionFilter(
    ElementId designOptionId
)
Public Sub New (
    designOptionId As ElementId
)
public:
ElementDesignOptionFilter(
    ElementId^ designOptionId
)
new :
        designOptionId : ElementId -> ElementDesignOptionFilter

Parameters

designOptionId ElementId
The design option id to match.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ElementDesignOptionFilter Class
ElementDesignOptionFilter Overload


ElementDesignOptionFilter(ElementId, Boolean) Constructor

Constructs a new instance of a filter to match elements contained within a particular design option, with the option to invert the filter and find elements not contained within a particular design option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementDesignOptionFilter(
    ElementId designOptionId,
    bool inverted
)
Public Sub New (
    designOptionId As ElementId,
    inverted As Boolean
)
public:
ElementDesignOptionFilter(
    ElementId^ designOptionId,
    bool inverted
)
new :
        designOptionId : ElementId *
        inverted : bool -> ElementDesignOptionFilter

Parameters

designOptionId ElementId
The design option id to match.
inverted Boolean
True if the filter should match all elements which are not contained within a particular design option.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ElementDesignOptionFilter Class
ElementDesignOptionFilter Overload


ElementDesignOptionFilter Properties

The ElementDesignOptionFilter type exposes the following members.

Properties
 | Name | Description
Public property | DesignOptionId | The design option id.
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
See Also

Reference

ElementDesignOptionFilter Class


ElementDesignOptionFilter.DesignOptionId Property

ElementDesignOptionFilterDesignOptionId Property

The design option id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId DesignOptionId { get; }
Public ReadOnly Property DesignOptionId As ElementId
    Get
public:
property ElementId^ DesignOptionId {
    ElementId^ get ();
}
member DesignOptionId : ElementId with get

Property Value

ElementId
See Also

Reference

ElementDesignOptionFilter Class


ElementDesignOptionFilter Methods

The ElementDesignOptionFilter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ElementDesignOptionFilter Class


ElementFilter Class

A base class for a type of filter that accepts or rejects elements based upon criteria.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementLogicalFilter
Autodesk.Revit.DBElementQuickFilter
Autodesk.Revit.DBElementSlowFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ElementFilter : IDisposable
Public Class ElementFilter
    Implements IDisposable
public ref class ElementFilter : IDisposable
type ElementFilter =
    class
        interface IDisposable
    end

The ElementFilter type exposes the following members.

Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ElementFilter
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element.
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ElementFilter Properties

The ElementFilter type exposes the following members.

Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

ElementFilter Class


ElementFilter.Inverted Property

ElementFilterInverted Property

True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Inverted { get; }
Public ReadOnly Property Inverted As Boolean
    Get
public:
property bool Inverted {
    bool get ();
}
member Inverted : bool with get

Property Value

Boolean
See Also

Reference

ElementFilter Class


ElementFilter.IsValidObject Property

ElementFilterIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ElementFilter Class


ElementFilter Methods

The ElementFilter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element.
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ElementFilter Class


ElementFilter.Dispose Method

ElementFilterDispose Method

Releases all resources used by the ElementFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ElementFilter Class


ElementFilter.PassesFilter Method

ElementFilterPassesFilter Method

Overload List
 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element.
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element.
Top
See Also

Reference

ElementFilter Class


ElementFilter.PassesFilter(Element) Method

ElementFilterPassesFilter(Element) Method

Applies the filter to a given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool PassesFilter(
    Element element
)
Public Function PassesFilter (
    element As Element
) As Boolean
public:
bool PassesFilter(
    Element^ element
)
member PassesFilter :
        element : Element -> bool

Parameters

element Element
The element.

Return Value

Boolean
True if the element is accepted by the filter. False if the element is rejected.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ElementFilter Class
PassesFilter Overload


ElementFilter.PassesFilter(Document, ElementId) Method

ElementFilterPassesFilter(Document, ElementId) Method

Applies the filter to a given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool PassesFilter(
    Document document,
    ElementId id
)
Public Function PassesFilter (
    document As Document,
    id As ElementId
) As Boolean
public:
bool PassesFilter(
    Document^ document,
    ElementId^ id
)
member PassesFilter :
        document : Document *
        id : ElementId -> bool

Parameters

document Document
The document.
id ElementId
The element id.

Return Value

Boolean
True if the element is accepted by the filter. False if the element is rejected.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ElementFilter Class
PassesFilter Overload


ElementId Class

The ElementId object is used as a unique identification for an element within a single project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ElementId
Public Class ElementId
public ref class ElementId
type ElementId = class end

The ElementId type exposes the following members.

Constructors
 | Name | Description
Public method | ElementId(BuiltInCategory) | Create an ElementId handle with the given BuiltInCategory id.
Public method | ElementId(BuiltInParameter) | Create an ElementId handle with the given BuiltInParameter id.
Public method | ElementId(Int32) | Obsolete. Create an ElementId handle with the given 32-bit integer id.
Public method | ElementId(Int64) | Create an ElementId handle with the given 64-bit integer id.
Top
Properties
 | Name | Description
Public property | IntegerValue | Obsolete. Provides the value of the element id as a 32-bit integer.
 | InvalidElementId | Get the invalid ElementId whose value is -1.
Public property | Value | Provides the value of the element id as a 64-bit integer.
Top
Methods
 | Name | Description
Public method | Compare | Compares two element ids.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object))
Public method | GetHashCode | Gets the value of the id as hash code (Overrides ObjectGetHashCode)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | Parse | Parse the string representation of the id into a corresponding ElementId.
Public method | ToString | Gets a String representation of the value of the id. (Overrides ObjectToString)
 | TryParse | Parse the string representation of the id into a corresponding ElementId.
Top
Operators
Name | Description
Equality(ElementId, ElementId) | Determines whether these two ElementIds are the same.
GreaterThan(ElementId, ElementId) | Determines whether one element id is greater than another element id.
GreaterThanOrEqual(ElementId, ElementId) | Determines whether one element id is not less than another element id.
Inequality(ElementId, ElementId) | Determines whether these two ElementIds are different.
LessThan(ElementId, ElementId) | Determines whether this element id is less than another element id.
LessThanOrEqual(ElementId, ElementId) | Determines whether one element id is not greater than another element id.
Top
Remarks
The Value within the ElementId is only unique with a single project. It is not unique across several projects. The Id can be used to retrieve a specific element from the database when needed. However ids are subject to change during an Autodesk Revit session and as such should not be retained and used across repeated calls to external commands. If a manner is needed to uniquely identify an element beyond this limitation then a shared parameter should be added to the element containing a unique identifier managed by the external application.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ElementId Constructor

Overload List
 | Name | Description
Public method | ElementId(BuiltInCategory) | Create an ElementId handle with the given BuiltInCategory id.
Public method | ElementId(BuiltInParameter) | Create an ElementId handle with the given BuiltInParameter id.
Public method | ElementId(Int32) | Obsolete. Create an ElementId handle with the given 32-bit integer id.
Public method | ElementId(Int64) | Create an ElementId handle with the given 64-bit integer id.
Top
See Also

Reference

ElementId Class


ElementId(BuiltInCategory) Constructor

Create an ElementId handle with the given BuiltInCategory id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId(
    BuiltInCategory categoryId
)
Public Sub New (
    categoryId As BuiltInCategory
)
public:
ElementId(
    BuiltInCategory categoryId
)
new :
        categoryId : BuiltInCategory -> ElementId

Parameters

categoryId BuiltInCategory
The id.
See Also

Reference

ElementId Class
ElementId Overload


ElementId(BuiltInParameter) Constructor

Create an ElementId handle with the given BuiltInParameter id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId(
    BuiltInParameter parameterId
)
Public Sub New (
    parameterId As BuiltInParameter
)
public:
ElementId(
    BuiltInParameter parameterId
)
new :
        parameterId : BuiltInParameter -> ElementId

Parameters

parameterId BuiltInParameter
The id.
See Also

Reference

ElementId Class
ElementId Overload


ElementId(Int32) Constructor

Note: This API is now obsolete.

Create an ElementId handle with the given 32-bit integer id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This constructor is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use the ElementId(Int64 id) constructor instead.")]
public ElementId(
    int id
)
<ObsoleteAttribute("This constructor is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use the ElementId(Int64 id) constructor instead.")>
Public Sub New (
    id As Integer
)
public:
[ObsoleteAttribute(L"This constructor is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use the ElementId(Int64 id) constructor instead.")]
ElementId(
    int id
)
[<ObsoleteAttribute("This constructor is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use the ElementId(Int64 id) constructor instead.")>]
new :
        id : int -> ElementId

Parameters

id Int32
The id.
See Also

Reference

ElementId Class
ElementId Overload


ElementId(Int64) Constructor

Create an ElementId handle with the given 64-bit integer id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId(
    long id
)
Public Sub New (
    id As Long
)
public:
ElementId(
    long long id
)
new :
        id : int64 -> ElementId

Parameters

id Int64
The id.
See Also

Reference

ElementId Class
ElementId Overload


ElementId Properties

The ElementId type exposes the following members.

Properties
 | Name | Description
Public property | IntegerValue | Obsolete. Provides the value of the element id as a 32-bit integer.
 | InvalidElementId | Get the invalid ElementId whose value is -1.
Public property | Value | Provides the value of the element id as a 64-bit integer.
Top
See Also

Reference

ElementId Class


ElementId.IntegerValue Property

ElementIdIntegerValue Property

Note: This API is now obsolete.

Provides the value of the element id as a 32-bit integer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This property is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use the Value property instead.")]
public int IntegerValue { get; }
<ObsoleteAttribute("This property is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use the Value property instead.")>
Public ReadOnly Property IntegerValue As Integer
    Get
public:
[ObsoleteAttribute(L"This property is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use the Value property instead.")]
property int IntegerValue {
    int get ();
}
[<ObsoleteAttribute("This property is deprecated in Revit 2024 and may be removed in a future version of Revit. Please use the Value property instead.")>]
member IntegerValue : int with get

Property Value

Int32
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the value of the element id is too large to be represented as a 32-bit integer.
See Also

Reference

ElementId Class


ElementId.InvalidElementId Property

ElementIdInvalidElementId Property

Get the invalid ElementId whose value is -1.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ElementId InvalidElementId { get; }
Public Shared ReadOnly Property InvalidElementId As ElementId
    Get
public:
static property ElementId^ InvalidElementId {
    ElementId^ get ();
}
static member InvalidElementId : ElementId with get

Property Value

ElementId
See Also

Reference

ElementId Class


ElementId.Value Property

ElementIdValue Property

Provides the value of the element id as a 64-bit integer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long Value { get; }
Public ReadOnly Property Value As Long
    Get
public:
property long long Value {
    long long get ();
}
member Value : int64 with get

Property Value

Int64
See Also

Reference

ElementId Class


ElementId Methods

The ElementId type exposes the following members.

Methods
 | Name | Description
Public method | Compare | Compares two element ids.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object))
Public method | GetHashCode | Gets the value of the id as hash code (Overrides ObjectGetHashCode)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | Parse | Parse the string representation of the id into a corresponding ElementId.
Public method | ToString | Gets a String representation of the value of the id. (Overrides ObjectToString)
 | TryParse | Parse the string representation of the id into a corresponding ElementId.
Top
See Also

Reference

ElementId Class


ElementId.Compare Method

ElementIdCompare Method

Compares two element ids.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Compare(
    ElementId id
)
Public Function Compare (
    id As ElementId
) As Integer
public:
int Compare(
    ElementId^ id
)
member Compare :
        id : ElementId -> int

Parameters

id ElementId
The ElementId to be compared with this ElementId.

Return Value

Int32
-1 if this element id is less than id, 0 if equal, 1 if greater.
See Also

Reference

ElementId Class


ElementId.Equals Method

ElementIdEquals Method

Determines whether the specified Object is equal to the current Object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj Object
Another object.

Return Value

Boolean
See Also

Reference

ElementId Class


ElementId.GetHashCode Method

ElementIdGetHashCode Method

Gets the value of the id as hash code

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Int32
See Also

Reference

ElementId Class


ElementId.Parse Method

ElementIdParse Method

Parse the string representation of the id into a corresponding ElementId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ElementId Parse(
    string idStr
)
Public Shared Function Parse (
    idStr As String
) As ElementId
public:
static ElementId^ Parse(
    String^ idStr
)
static member Parse :
        idStr : string -> ElementId

Parameters

idStr String
The string representation of the id to return.

Return Value

ElementId
ElementId string represented.
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the string cannot be parsed into an ElementId.
Remarks
If the string represents [!:Autodesk::Revit::DB::Element::InvalidElementId] it will be returned.
See Also

Reference

ElementId Class


ElementId.ToString Method

ElementIdToString Method

Gets a String representation of the value of the id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

String
See Also

Reference

ElementId Class


ElementId.TryParse Method

ElementIdTryParse Method

Parse the string representation of the id into a corresponding ElementId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool TryParse(
    string idStr,
    out ElementId id
)
Public Shared Function TryParse (
    idStr As String,
    <OutAttribute> ByRef id As ElementId
) As Boolean
public:
static bool TryParse(
    String^ idStr,
    [OutAttribute] ElementId^% id
)
static member TryParse :
        idStr : string *
        id : ElementId byref -> bool

Parameters

idStr String
The string representation of the id to return.
id ElementId
Out parameter set to the ElementId represented by the string.

Return Value

Boolean
true if the string was successfully parsed into an ElementId, false otherwise.
Remarks
If the string represents [!:Autodesk::Revit::DB::Element::InvalidElementId] the id will contain it upon return. If the parse fails, the id will be undefined.
See Also

Reference

ElementId Class


ElementId Operators

The ElementId type exposes the following members.

Operators
Name | Description
Equality(ElementId, ElementId) | Determines whether these two ElementIds are the same.
GreaterThan(ElementId, ElementId) | Determines whether one element id is greater than another element id.
GreaterThanOrEqual(ElementId, ElementId) | Determines whether one element id is not less than another element id.
Inequality(ElementId, ElementId) | Determines whether these two ElementIds are different.
LessThan(ElementId, ElementId) | Determines whether this element id is less than another element id.
LessThanOrEqual(ElementId, ElementId) | Determines whether one element id is not greater than another element id.
Top
See Also

Reference

ElementId Class


ElementId.Equality Operator

ElementIdEquality Operator

Determines whether these two ElementIds are the same.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool operator ==(
    ElementId first,
    ElementId second
)
Public Shared Operator = (
    first As ElementId,
    second As ElementId
) As Boolean
public:
static bool operator ==(
    ElementId^ first,
    ElementId^ second
)
static let inline (=)
        first : ElementId *
        second : ElementId  : bool

Parameters

first ElementId
The first ElementId.
second ElementId
The second ElementId.

Return Value

Boolean
True if the ElementIds are the same; otherwise, false.
See Also

Reference

ElementId Class


ElementId.GreaterThan Operator

ElementIdGreaterThan Operator

Determines whether one element id is greater than another element id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool operator >(
    ElementId elementId1,
    ElementId elementId2
)
Public Shared Operator > (
    elementId1 As ElementId,
    elementId2 As ElementId
) As Boolean
public:
static bool operator >(
    ElementId^ elementId1,
    ElementId^ elementId2
)
static let inline (>)
        elementId1 : ElementId *
        elementId2 : ElementId  : bool

Parameters

elementId1 ElementId
The first ElementId.
elementId2 ElementId
The second ElementId.

Return Value

Boolean
True if the first element id is greater than the second element id, otherwise, false.
See Also

Reference

ElementId Class


ElementId.GreaterThanOrEqual Operator

ElementIdGreaterThanOrEqual Operator

Determines whether one element id is not less than another element id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool operator >=(
    ElementId elementId1,
    ElementId elementId2
)
Public Shared Operator >= (
    elementId1 As ElementId,
    elementId2 As ElementId
) As Boolean
public:
static bool operator >=(
    ElementId^ elementId1,
    ElementId^ elementId2
)
static let inline (>=)
        elementId1 : ElementId *
        elementId2 : ElementId  : bool

Parameters

elementId1 ElementId
The first ElementId.
elementId2 ElementId
The second ElementId.

Return Value

Boolean
True if the first element id is not less than the second element id, otherwise, false.
See Also

Reference

ElementId Class


ElementId.Inequality Operator

ElementIdInequality Operator

Determines whether these two ElementIds are different.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool operator !=(
    ElementId first,
    ElementId second
)
Public Shared Operator <> (
    first As ElementId,
    second As ElementId
) As Boolean
public:
static bool operator !=(
    ElementId^ first,
    ElementId^ second
)
static let inline (<>)
        first : ElementId *
        second : ElementId  : bool

Parameters

first ElementId
The first ElementId.
second ElementId
The second ElementId.

Return Value

Boolean
True if the ElementIds are different; otherwise, false.
See Also

Reference

ElementId Class


ElementId.LessThan Operator

ElementIdLessThan Operator

Determines whether this element id is less than another element id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool operator <(
    ElementId elementId1,
    ElementId elementId2
)
Public Shared Operator < (
    elementId1 As ElementId,
    elementId2 As ElementId
) As Boolean
public:
static bool operator <(
    ElementId^ elementId1,
    ElementId^ elementId2
)
static let inline (<)
        elementId1 : ElementId *
        elementId2 : ElementId  : bool

Parameters

elementId1 ElementId
The first ElementId.
elementId2 ElementId
The second ElementId.

Return Value

Boolean
True if the first element id is less than the second element id, otherwise, false.
See Also

Reference

ElementId Class


ElementId.LessThanOrEqual Operator

ElementIdLessThanOrEqual Operator

Determines whether one element id is not greater than another element id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool operator <=(
    ElementId elementId1,
    ElementId elementId2
)
Public Shared Operator <= (
    elementId1 As ElementId,
    elementId2 As ElementId
) As Boolean
public:
static bool operator <=(
    ElementId^ elementId1,
    ElementId^ elementId2
)
static let inline (<=)
        elementId1 : ElementId *
        elementId2 : ElementId  : bool

Parameters

elementId1 ElementId
The first ElementId.
elementId2 ElementId
The second ElementId.

Return Value

Boolean
True if the first element id is not greater than the second element id, otherwise, false.
See Also

Reference

ElementId Class


ElementIdParameterValue Class

A class that holds a ElementId value of a parameter element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBParameterValue
Autodesk.Revit.DBElementIdParameterValue

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ElementIdParameterValue : ParameterValue
Public Class ElementIdParameterValue
    Inherits ParameterValue
public ref class ElementIdParameterValue : public ParameterValue
type ElementIdParameterValue =
    class
        inherit ParameterValue
    end

The ElementIdParameterValue type exposes the following members.

Constructors
 | Name | Description
Public method | ElementIdParameterValue | Default constructor
Public method | ElementIdParameterValue(ElementId) | Value constructor
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ParameterValue)
Public property | Value | The stored value
Top
Methods
 | Name | Description
Public method | Copy | Makes an identical copy of the given parameter value. (Inherited from ParameterValue)
Public method | Dispose | (Inherited from ParameterValue)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqual | Tests equality with another instance of the same class. (Inherited from ParameterValue)
Public method | IsSameType | Tests another instance is of the same value type. (Inherited from ParameterValue)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ElementIdParameterValue Constructor

Overload List
 | Name | Description
Public method | ElementIdParameterValue | Default constructor
Public method | ElementIdParameterValue(ElementId) | Value constructor
Top
See Also

Reference

ElementIdParameterValue Class


ElementIdParameterValue Constructor

Default constructor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementIdParameterValue()
Public Sub New
public:
ElementIdParameterValue()
new : unit -> ElementIdParameterValue
See Also

Reference

ElementIdParameterValue Class
ElementIdParameterValue Overload


ElementIdParameterValue(ElementId) Constructor

Value constructor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementIdParameterValue(
    ElementId value
)
Public Sub New (
    value As ElementId
)
public:
ElementIdParameterValue(
    ElementId^ value
)
new :
        value : ElementId -> ElementIdParameterValue

Parameters

value ElementId
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ElementIdParameterValue Class
ElementIdParameterValue Overload


ElementIdParameterValue Properties

The ElementIdParameterValue type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ParameterValue)
Public property | Value | The stored value
Top
See Also

Reference

ElementIdParameterValue Class


ElementIdParameterValue.Value Property

ElementIdParameterValueValue Property

The stored value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId Value { get; set; }
Public Property Value As ElementId
    Get
    Set
public:
property ElementId^ Value {
    ElementId^ get ();
    void set (ElementId^ value);
}
member Value : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ElementIdParameterValue Class


ElementIdParameterValue Methods

The ElementIdParameterValue type exposes the following members.

Methods
 | Name | Description
Public method | Copy | Makes an identical copy of the given parameter value. (Inherited from ParameterValue)
Public method | Dispose | (Inherited from ParameterValue)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqual | Tests equality with another instance of the same class. (Inherited from ParameterValue)
Public method | IsSameType | Tests another instance is of the same value type. (Inherited from ParameterValue)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ElementIdParameterValue Class


ElementIdSetFilter Class

A filter wrapping a set of elements.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementQuickFilter
Autodesk.Revit.DBElementIdSetFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ElementIdSetFilter : ElementQuickFilter
Public Class ElementIdSetFilter
    Inherits ElementQuickFilter
public ref class ElementIdSetFilter : public ElementQuickFilter
type ElementIdSetFilter =
    class
        inherit ElementQuickFilter
    end

The ElementIdSetFilter type exposes the following members.

Constructors
 | Name | Description
Public method | ElementIdSetFilter | Constructs a new instance of a filter wrapping a set of elements.
Top
Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIdsToInclude | Returns the ids of this filter.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ElementIdSetFilter Constructor

Constructs a new instance of a filter wrapping a set of elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementIdSetFilter(
    ICollection<ElementId> idsToInclude
)
Public Sub New (
    idsToInclude As ICollection(Of ElementId)
)
public:
ElementIdSetFilter(
    ICollection<ElementId^>^ idsToInclude
)
new :
        idsToInclude : ICollection<ElementId> -> ElementIdSetFilter

Parameters

idsToInclude ICollection ElementId
The ids.
Exceptions
Exception | Condition
ArgumentException | The input collection of ids was empty, or its contents were not valid for iteration.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ElementIdSetFilter Class


ElementIdSetFilter Properties

The ElementIdSetFilter type exposes the following members.

Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
See Also

Reference

ElementIdSetFilter Class


ElementIdSetFilter Methods

The ElementIdSetFilter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIdsToInclude | Returns the ids of this filter.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ElementIdSetFilter Class


ElementIdSetFilter.GetIdsToInclude Method

ElementIdSetFilterGetIdsToInclude Method

Returns the ids of this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetIdsToInclude()
Public Function GetIdsToInclude As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetIdsToInclude()
member GetIdsToInclude : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
The collection of ids.
See Also

Reference

ElementIdSetFilter Class


ElementIntersectsElementFilter Class

A filter to find elements that intersect the solid geometry of a given element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementSlowFilter
Autodesk.Revit.DBElementIntersectsFilter
Autodesk.Revit.DBElementIntersectsElementFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ElementIntersectsElementFilter : ElementIntersectsFilter
Public Class ElementIntersectsElementFilter
    Inherits ElementIntersectsFilter
public ref class ElementIntersectsElementFilter : public ElementIntersectsFilter
type ElementIntersectsElementFilter =
    class
        inherit ElementIntersectsFilter
    end

The ElementIntersectsElementFilter type exposes the following members.

Constructors
 | Name | Description
Public method | ElementIntersectsElementFilter(Element) | Constructs a filter to match elements which intersect the given element.
Public method | ElementIntersectsElementFilter(Element, Boolean) | Constructs a filter to match elements which intersect the given element, with the option to match all elements not intersecting the given element.
Top
Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetElement | Gets the target element.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

The target object is another element. The intersection is determined with the same logic used by Revit to determine if an interference exists during generation of an Interference Report. (This means that some combinations of elements will never be detected as intersecting by this filter, such as concrete members which are automatically joined at their intersections). Also, elements which have no solid geometry, such as Rebar, will never be detected as intersecting by this filter.

This filter is a slow filter. Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple this filter with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ElementIntersectsElementFilter Constructor

Overload List
 | Name | Description
Public method | ElementIntersectsElementFilter(Element) | Constructs a filter to match elements which intersect the given element.
Public method | ElementIntersectsElementFilter(Element, Boolean) | Constructs a filter to match elements which intersect the given element, with the option to match all elements not intersecting the given element.
Top
See Also

Reference

ElementIntersectsElementFilter Class


ElementIntersectsElementFilter(Element) Constructor

Constructs a filter to match elements which intersect the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementIntersectsElementFilter(
    Element element
)
Public Sub New (
    element As Element
)
public:
ElementIntersectsElementFilter(
    Element^ element
)
new :
        element : Element -> ElementIntersectsElementFilter

Parameters

element Element
The element to check for intersection.
Exceptions
Exception | Condition
ArgumentException | The category of the element is not supported for element intersection filters. -or- The element is not supported for element intersection filters.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ElementIntersectsElementFilter Class
ElementIntersectsElementFilter Overload


ElementIntersectsElementFilter(Element, Boolean) Constructor

Constructs a filter to match elements which intersect the given element, with the option to match all elements not intersecting the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementIntersectsElementFilter(
    Element element,
    bool inverted
)
Public Sub New (
    element As Element,
    inverted As Boolean
)
public:
ElementIntersectsElementFilter(
    Element^ element,
    bool inverted
)
new :
        element : Element *
        inverted : bool -> ElementIntersectsElementFilter

Parameters

element Element
The element to check for intersection.
inverted Boolean
True if the filter should match all elements which do not intersect the given element.
Exceptions
Exception | Condition
ArgumentException | The category of the element is not supported for element intersection filters. -or- The element is not supported for element intersection filters.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ElementIntersectsElementFilter Class
ElementIntersectsElementFilter Overload


ElementIntersectsElementFilter Properties

The ElementIntersectsElementFilter type exposes the following members.

Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
See Also

Reference

ElementIntersectsElementFilter Class


ElementIntersectsElementFilter Methods

The ElementIntersectsElementFilter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetElement | Gets the target element.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ElementIntersectsElementFilter Class


ElementIntersectsElementFilter.GetElement Method

ElementIntersectsElementFilterGetElement Method

Gets the target element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Element GetElement()
Public Function GetElement As Element
public:
Element^ GetElement()
member GetElement : unit -> Element

Return Value

Element
The element.
See Also

Reference

ElementIntersectsElementFilter Class


ElementIntersectsFilter Class

A base class for filters used to match elements which intersect with geometry.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementSlowFilter
Autodesk.Revit.DBElementIntersectsFilter
Autodesk.Revit.DBElementIntersectsElementFilter
Autodesk.Revit.DBElementIntersectsSolidFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ElementIntersectsFilter : ElementSlowFilter
Public Class ElementIntersectsFilter
    Inherits ElementSlowFilter
public ref class ElementIntersectsFilter : public ElementSlowFilter
type ElementIntersectsFilter =
    class
        inherit ElementSlowFilter
    end

The ElementIntersectsFilter type exposes the following members.

Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | IsCategorySupported | Identifies if the input element is of a category supported by element intersection filters.
 | IsElementSupported | Identifies if the input element is supported by element intersection filters.
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ElementIntersectsFilter Properties

The ElementIntersectsFilter type exposes the following members.

Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
See Also

Reference

ElementIntersectsFilter Class


ElementIntersectsFilter Methods

The ElementIntersectsFilter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | IsCategorySupported | Identifies if the input element is of a category supported by element intersection filters.
 | IsElementSupported | Identifies if the input element is supported by element intersection filters.
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ElementIntersectsFilter Class


ElementIntersectsFilter.IsCategorySupported Method

ElementIntersectsFilterIsCategorySupported Method

Identifies if the input element is of a category supported by element intersection filters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsCategorySupported(
    Element element
)
Public Shared Function IsCategorySupported (
    element As Element
) As Boolean
public:
static bool IsCategorySupported(
    Element^ element
)
static member IsCategorySupported :
        element : Element -> bool

Parameters

element Element
The element.

Return Value

Boolean
True if the element category is supported, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ElementIntersectsFilter Class


ElementIntersectsFilter.IsElementSupported Method

ElementIntersectsFilterIsElementSupported Method

Identifies if the input element is supported by element intersection filters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsElementSupported(
    Element element
)
Public Shared Function IsElementSupported (
    element As Element
) As Boolean
public:
static bool IsElementSupported(
    Element^ element
)
static member IsElementSupported :
        element : Element -> bool

Parameters

element Element
The element.

Return Value

Boolean
True if the element is supported, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ElementIntersectsFilter Class


ElementIntersectsSolidFilter Class

A filter to find elements that intersect the given solid geometry.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementSlowFilter
Autodesk.Revit.DBElementIntersectsFilter
Autodesk.Revit.DBElementIntersectsSolidFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ElementIntersectsSolidFilter : ElementIntersectsFilter
Public Class ElementIntersectsSolidFilter
    Inherits ElementIntersectsFilter
public ref class ElementIntersectsSolidFilter : public ElementIntersectsFilter
type ElementIntersectsSolidFilter =
    class
        inherit ElementIntersectsFilter
    end

The ElementIntersectsSolidFilter type exposes the following members.

Constructors
 | Name | Description
Public method | ElementIntersectsSolidFilter(Solid) | Constructs a filter to match elements which intersect the given element.
Public method | ElementIntersectsSolidFilter(Solid, Boolean) | Constructs a filter to match elements which intersect the given element, with the option to match all elements not intersecting the given element.
Top
Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetSolid | Gets the target solid geometry.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

The input solid used for this filter can be obtained from an existing element, created from scratch using the routines in GeometryCreationUtilities or builder classes, or the generated from the result of a secondary operation such as a Boolean operation. Similar to the ElementIntersectsElementFilter, this filter will not detect as intersecting elements which lack solid geometry, such as Rebar.

This filter is a slow filter. Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple this filter with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded.

Example
C#
VB
C++
F#
Copy
// Find intersections between family instances and a selected element
Reference reference = uidoc.Selection.PickObject(ObjectType.Element, "Select element that will be checked for intersection with all family instances");
Element element = doc.GetElement(reference);
GeometryElement geomElement = element.get_Geometry(new Options());
Solid solid = null;
foreach (GeometryObject geomObj in geomElement)
{
    solid = geomObj as Solid;
    if (solid != null) break;
}

FilteredElementCollector collector = new FilteredElementCollector(doc);
collector.OfClass(typeof(FamilyInstance));
collector.WherePasses(new ElementIntersectsSolidFilter(solid)); // Apply intersection filter to find matches

TaskDialog.Show("Revit", collector.Count() + " family instances intersect with the selected element (" + element.Category.Name + " id:" + element.Id.ToString() + ")");
' Find intersections between family instances and a selected element
Dim reference As Reference = uidoc.Selection.PickObject(ObjectType.Element, "Select element that will be checked for intersection with all family instances")
Dim element As Element = doc.GetElement(reference)
Dim geomElement As GeometryElement = element.Geometry(New Options())
Dim solid As Solid = Nothing
For Each geomObj As GeometryObject In geomElement
    solid = TryCast(geomObj, Solid)
    If solid IsNot Nothing Then
        Exit For
    End If
Next

Dim collector As New FilteredElementCollector(doc)
collector.OfClass(GetType(FamilyInstance))
collector.WherePasses(New ElementIntersectsSolidFilter(solid))
' Apply intersection filter to find matches
TaskDialog.Show("Revit", collector.Count() + " family instances intersect with the selected element (" + element.Category.Name + " id:" + element.Id.ToString() + ")")

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

C#
VB
C++
F#
Copy
// Find intersections between family instances and a selected element
Reference reference = uidoc.Selection.PickObject(ObjectType.Element, "Select element that will be checked for intersection with all family instances");
Element element = doc.GetElement(reference);
GeometryElement geomElement = element.get_Geometry(new Options());
Solid solid = null;
foreach (GeometryObject geomObj in geomElement)
{
    solid = geomObj as Solid;
    if (solid != null) break;
}

FilteredElementCollector collector = new FilteredElementCollector(doc);
collector.OfClass(typeof(FamilyInstance));
collector.WherePasses(new ElementIntersectsSolidFilter(solid)); // Apply intersection filter to find matches

TaskDialog.Show("Revit", collector.Count() + " family instances intersect with the selected element (" + element.Category.Name + " id:" + element.Id.ToString() + ")");
' Find intersections between family instances and a selected element
Dim reference As Reference = uidoc.Selection.PickObject(ObjectType.Element, "Select element that will be checked for intersection with all family instances")
Dim element As Element = doc.GetElement(reference)
Dim geomElement As GeometryElement = element.Geometry(New Options())
Dim solid As Solid = Nothing
For Each geomObj As GeometryObject In geomElement
    solid = TryCast(geomObj, Solid)
    If solid IsNot Nothing Then
        Exit For
    End If
Next

Dim collector As New FilteredElementCollector(doc)
collector.OfClass(GetType(FamilyInstance))
collector.WherePasses(New ElementIntersectsSolidFilter(solid))
' Apply intersection filter to find matches
TaskDialog.Show("Revit", collector.Count() + " family instances intersect with the selected element (" + element.Category.Name + " id:" + element.Id.ToString() + ")")

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ElementIntersectsSolidFilter Constructor

Overload List
 | Name | Description
Public method | ElementIntersectsSolidFilter(Solid) | Constructs a filter to match elements which intersect the given element.
Public method | ElementIntersectsSolidFilter(Solid, Boolean) | Constructs a filter to match elements which intersect the given element, with the option to match all elements not intersecting the given element.
Top
See Also

Reference

ElementIntersectsSolidFilter Class


ElementIntersectsSolidFilter(Solid) Constructor

Constructs a filter to match elements which intersect the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementIntersectsSolidFilter(
    Solid solid
)
Public Sub New (
    solid As Solid
)
public:
ElementIntersectsSolidFilter(
    Solid^ solid
)
new :
        solid : Solid -> ElementIntersectsSolidFilter

Parameters

solid Solid
The solid geometry to check for intersection.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ElementIntersectsSolidFilter Class
ElementIntersectsSolidFilter Overload


ElementIntersectsSolidFilter(Solid, Boolean) Constructor

Constructs a filter to match elements which intersect the given element, with the option to match all elements not intersecting the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementIntersectsSolidFilter(
    Solid solid,
    bool inverted
)
Public Sub New (
    solid As Solid,
    inverted As Boolean
)
public:
ElementIntersectsSolidFilter(
    Solid^ solid,
    bool inverted
)
new :
        solid : Solid *
        inverted : bool -> ElementIntersectsSolidFilter

Parameters

solid Solid
The solid geometry to check for intersection.
inverted Boolean
True if the filter should match all elements which do not intersect the given element.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ElementIntersectsSolidFilter Class
ElementIntersectsSolidFilter Overload


ElementIntersectsSolidFilter Properties

The ElementIntersectsSolidFilter type exposes the following members.

Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
See Also

Reference

ElementIntersectsSolidFilter Class


ElementIntersectsSolidFilter Methods

The ElementIntersectsSolidFilter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetSolid | Gets the target solid geometry.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ElementIntersectsSolidFilter Class


ElementIntersectsSolidFilter.GetSolid Method

ElementIntersectsSolidFilterGetSolid Method

Gets the target solid geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Solid GetSolid()
Public Function GetSolid As Solid
public:
Solid^ GetSolid()
member GetSolid : unit -> Solid

Return Value

Solid
The solid geometry.
See Also

Reference

ElementIntersectsSolidFilter Class


ElementIsCurveDrivenFilter Class

A filter used to match elements which are curve driven.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementQuickFilter
Autodesk.Revit.DBElementIsCurveDrivenFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ElementIsCurveDrivenFilter : ElementQuickFilter
Public Class ElementIsCurveDrivenFilter
    Inherits ElementQuickFilter
public ref class ElementIsCurveDrivenFilter : public ElementQuickFilter
type ElementIsCurveDrivenFilter =
    class
        inherit ElementQuickFilter
    end

The ElementIsCurveDrivenFilter type exposes the following members.

Constructors
 | Name | Description
Public method | ElementIsCurveDrivenFilter | Constructs a new instance of a filter to match only curve driven elements.
Public method | ElementIsCurveDrivenFilter(Boolean) | Constructs a new instance of a filter to match only curve driven elements, with the option to match all elements which are not curve driven elements.
Top
Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The term "curve driven" indicates that the element's Location property is a LocationCurve. Example elements found by this filter include walls, beams, and curve elements. This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.
Example
C#
VB
C++
F#
Copy
// Create an ElementIsCurveDriven filter to find slanted columns(which is curve-driven) in the document,
// The term "curve driven" indicates that the element's Location property is a LocationCurve
ElementIsCurveDrivenFilter filter = new ElementIsCurveDrivenFilter();

// Apply the filter to the elements in the active document,
// Use the ElementIsCurveDrivenFilter on columns to find only slanted columns (vertical columns
// are placed at a single point).
FilteredElementCollector collector = new FilteredElementCollector(document);
ICollection<Element> slantColumns = collector
    .WherePasses(filter).OfCategory(BuiltInCategory.OST_StructuralColumns).ToElements();

// Find elements of not curve driven: use inverted filter to match elements
ElementIsCurveDrivenFilter notCurveDrivenFilter = new ElementIsCurveDrivenFilter(true); // inverted filter
collector = new FilteredElementCollector(document);
ICollection<Element> notCurveDrivenFounds = collector.WherePasses(notCurveDrivenFilter).ToElements();
' Create an ElementIsCurveDriven filter to find slanted columns(which is curve-driven) in the document,
' The term "curve driven" indicates that the element's Location property is a LocationCurve
Dim filter As New ElementIsCurveDrivenFilter()

' Apply the filter to the elements in the active document,
' Use the ElementIsCurveDrivenFilter on columns to find only slanted columns (vertical columns
' are placed at a single point).
Dim collector As New FilteredElementCollector(document)
Dim slantColumns As ICollection(Of Element) = collector.WherePasses(filter).OfCategory(BuiltInCategory.OST_StructuralColumns).ToElements()

' Find elements of not curve driven: use inverted filter to match elements
Dim notCurveDrivenFilter As New ElementIsCurveDrivenFilter(True)
' inverted filter
collector = New FilteredElementCollector(document)
Dim notCurveDrivenFounds As ICollection(Of Element) = collector.WherePasses(notCurveDrivenFilter).ToElements()

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ElementIsCurveDrivenFilter Constructor

Overload List
 | Name | Description
Public method | ElementIsCurveDrivenFilter | Constructs a new instance of a filter to match only curve driven elements.
Public method | ElementIsCurveDrivenFilter(Boolean) | Constructs a new instance of a filter to match only curve driven elements, with the option to match all elements which are not curve driven elements.
Top
See Also

Reference

ElementIsCurveDrivenFilter Class


ElementIsCurveDrivenFilter Constructor

Constructs a new instance of a filter to match only curve driven elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementIsCurveDrivenFilter()
Public Sub New
public:
ElementIsCurveDrivenFilter()
new : unit -> ElementIsCurveDrivenFilter
Remarks
The term "curve driven" indicates that the element's Location property is a LocationCurve. Example elements found by this filter include walls, beams, and curve elements.
See Also

Reference

ElementIsCurveDrivenFilter Class
ElementIsCurveDrivenFilter Overload


ElementIsCurveDrivenFilter(Boolean) Constructor

Constructs a new instance of a filter to match only curve driven elements, with the option to match all elements which are not curve driven elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementIsCurveDrivenFilter(
    bool inverted
)
Public Sub New (
    inverted As Boolean
)
public:
ElementIsCurveDrivenFilter(
    bool inverted
)
new :
        inverted : bool -> ElementIsCurveDrivenFilter

Parameters

inverted Boolean
True if the filter should match all elements which are not curve driven elements.
Remarks
The term "curve driven" indicates that the element's Location property is a LocationCurve. Example elements found by this filter include walls, beams, and curve elements.
See Also

Reference

ElementIsCurveDrivenFilter Class
ElementIsCurveDrivenFilter Overload


ElementIsCurveDrivenFilter Properties

The ElementIsCurveDrivenFilter type exposes the following members.

Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
See Also

Reference

ElementIsCurveDrivenFilter Class


ElementIsCurveDrivenFilter Methods

The ElementIsCurveDrivenFilter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ElementIsCurveDrivenFilter Class


ElementIsElementTypeFilter Class

A filter used to match elements which are ElementTypes.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementQuickFilter
Autodesk.Revit.DBElementIsElementTypeFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ElementIsElementTypeFilter : ElementQuickFilter
Public Class ElementIsElementTypeFilter
    Inherits ElementQuickFilter
public ref class ElementIsElementTypeFilter : public ElementQuickFilter
type ElementIsElementTypeFilter =
    class
        inherit ElementQuickFilter
    end

The ElementIsElementTypeFilter type exposes the following members.

Constructors
 | Name | Description
Public method | ElementIsElementTypeFilter | Constructs a new instance of a filter to match only ElementTypes.
Public method | ElementIsElementTypeFilter(Boolean) | Constructs a new instance of a filter to match only ElementTypes, with the option to match all elements which are not ElementTypes.
Top
Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ElementIsElementTypeFilter Constructor

Overload List
 | Name | Description
Public method | ElementIsElementTypeFilter | Constructs a new instance of a filter to match only ElementTypes.
Public method | ElementIsElementTypeFilter(Boolean) | Constructs a new instance of a filter to match only ElementTypes, with the option to match all elements which are not ElementTypes.
Top
See Also

Reference

ElementIsElementTypeFilter Class


ElementIsElementTypeFilter Constructor

Constructs a new instance of a filter to match only ElementTypes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementIsElementTypeFilter()
Public Sub New
public:
ElementIsElementTypeFilter()
new : unit -> ElementIsElementTypeFilter
See Also

Reference

ElementIsElementTypeFilter Class
ElementIsElementTypeFilter Overload


ElementIsElementTypeFilter(Boolean) Constructor

Constructs a new instance of a filter to match only ElementTypes, with the option to match all elements which are not ElementTypes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementIsElementTypeFilter(
    bool inverted
)
Public Sub New (
    inverted As Boolean
)
public:
ElementIsElementTypeFilter(
    bool inverted
)
new :
        inverted : bool -> ElementIsElementTypeFilter

Parameters

inverted Boolean
True if the filter should match all elements which are not ElementTypes.
See Also

Reference

ElementIsElementTypeFilter Class
ElementIsElementTypeFilter Overload


ElementIsElementTypeFilter Properties

The ElementIsElementTypeFilter type exposes the following members.

Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
See Also

Reference

ElementIsElementTypeFilter Class


ElementIsElementTypeFilter Methods

The ElementIsElementTypeFilter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ElementIsElementTypeFilter Class


ElementLevelFilter Class

A filter used to match elements by their associated level.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementSlowFilter
Autodesk.Revit.DBElementLevelFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ElementLevelFilter : ElementSlowFilter
Public Class ElementLevelFilter
    Inherits ElementSlowFilter
public ref class ElementLevelFilter : public ElementSlowFilter
type ElementLevelFilter =
    class
        inherit ElementSlowFilter
    end

The ElementLevelFilter type exposes the following members.

Constructors
 | Name | Description
Public method | ElementLevelFilter(ElementId) | Constructs a new instance of an ElementLevelFilter.
Public method | ElementLevelFilter(ElementId, Boolean) | Constructs a new instance of an ElementLevelFilter, with the option to match all elements not associated to the given level id.
Top
Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Public property | LevelId | The id of the level that will be matched to elements' associated level.
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This filter is a slow filter. Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple this filter with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded.
Example
C#
VB
C++
F#
Copy
// Use ElementLevel filter to find elements by their associated level in the document

// Find the level whose Name is "Level 1"
FilteredElementCollector collector = new FilteredElementCollector(document);
ICollection<Element> levels = collector.OfClass(typeof(Level)).ToElements();
var query = from element in collector where element.Name == "Level 1" select element;// Linq query

// Get the level id which will be used to match elements
List<Element> level1 = query.ToList<Element>();
ElementId levelId = level1[0].Id;

// Find all walls on level one
ElementLevelFilter level1Filter = new ElementLevelFilter(levelId);
collector = new FilteredElementCollector(document);
ICollection<Element> allWallsOnLevel1 = collector.OfClass(typeof(Wall)).WherePasses(level1Filter).ToElements();

// Find all rooms not on level one: use an inverted ElementLevelFilter to match all elements not on the target level
ElementLevelFilter notOnLevel1Filter = new ElementLevelFilter(levelId, true); // Inverted filter
collector = new FilteredElementCollector(document);
IList<Element> allRoomsNotOnLevel1 = collector.WherePasses(new RoomFilter()).WherePasses(notOnLevel1Filter).ToElements();
' Use ElementLevel filter to find elements by their associated level in the document

' Find the level whose Name is "Level 1"
Dim collector As New FilteredElementCollector(document)
Dim levels As ICollection(Of Element) = collector.OfClass(GetType(Level)).ToElements()
Dim query As System.Collections.Generic.IEnumerable(Of Autodesk.Revit.DB.Element)
query = From element In collector _
 Where element.Name = "Level 1" _
 Select element

' Linq query
' Get the level id which will be used to match elements
Dim level1 As List(Of Element) = query.ToList()
Dim levelId As ElementId = level1(0).Id

' Find all walls on level one
Dim level1Filter As New ElementLevelFilter(levelId)
collector = New FilteredElementCollector(document)
Dim allWallsOnLevel1 As ICollection(Of Element) = collector.OfClass(GetType(Wall)).WherePasses(level1Filter).ToElements()

' Find all rooms not on level one: use an inverted ElementLevelFilter to match all elements not on the target level
Dim notOnLevel1Filter As New ElementLevelFilter(levelId, True)
' Inverted filter
collector = New FilteredElementCollector(document)
Dim allRoomsNotOnLevel1 As IList(Of Element) = collector.WherePasses(New RoomFilter()).WherePasses(notOnLevel1Filter).ToElements()

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ElementLevelFilter Constructor

Overload List
 | Name | Description
Public method | ElementLevelFilter(ElementId) | Constructs a new instance of an ElementLevelFilter.
Public method | ElementLevelFilter(ElementId, Boolean) | Constructs a new instance of an ElementLevelFilter, with the option to match all elements not associated to the given level id.
Top
See Also

Reference

ElementLevelFilter Class


ElementLevelFilter(ElementId) Constructor

Constructs a new instance of an ElementLevelFilter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementLevelFilter(
    ElementId levelId
)
Public Sub New (
    levelId As ElementId
)
public:
ElementLevelFilter(
    ElementId^ levelId
)
new :
        levelId : ElementId -> ElementLevelFilter

Parameters

levelId ElementId
The id of the level that will be matched to elements' associated level.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ElementLevelFilter Class
ElementLevelFilter Overload


ElementLevelFilter(ElementId, Boolean) Constructor

Constructs a new instance of an ElementLevelFilter, with the option to match all elements not associated to the given level id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementLevelFilter(
    ElementId levelId,
    bool inverted
)
Public Sub New (
    levelId As ElementId,
    inverted As Boolean
)
public:
ElementLevelFilter(
    ElementId^ levelId,
    bool inverted
)
new :
        levelId : ElementId *
        inverted : bool -> ElementLevelFilter

Parameters

levelId ElementId
The id of the level that will be matched to elements' associated level.
inverted Boolean
True if the filter should match all elements not associated to the given level.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ElementLevelFilter Class
ElementLevelFilter Overload


ElementLevelFilter Properties

The ElementLevelFilter type exposes the following members.

Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Public property | LevelId | The id of the level that will be matched to elements' associated level.
Top
See Also

Reference

ElementLevelFilter Class


ElementLevelFilter.LevelId Property

ElementLevelFilterLevelId Property

The id of the level that will be matched to elements' associated level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId LevelId { get; }
Public ReadOnly Property LevelId As ElementId
    Get
public:
property ElementId^ LevelId {
    ElementId^ get ();
}
member LevelId : ElementId with get

Property Value

ElementId
See Also

Reference

ElementLevelFilter Class


ElementLevelFilter Methods

The ElementLevelFilter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ElementLevelFilter Class


ElementLogicalFilter Class

A filter used to logically combine two or more filters.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementLogicalFilter
Autodesk.Revit.DBLogicalAndFilter
Autodesk.Revit.DBLogicalOrFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ElementLogicalFilter : ElementFilter
Public Class ElementLogicalFilter
    Inherits ElementFilter
public ref class ElementLogicalFilter : public ElementFilter
type ElementLogicalFilter =
    class
        inherit ElementFilter
    end

The ElementLogicalFilter type exposes the following members.

Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetFilters | Returns an array of copies of the filters that are logically combined by this ElementLogicalFilter.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | SetFilters | Replaces current filters in the logical filter with any number of input filters.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The component filters may be reordered by Revit to cause the quickest acting filters to be evaluated first.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ElementLogicalFilter Properties

The ElementLogicalFilter type exposes the following members.

Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
See Also

Reference

ElementLogicalFilter Class


ElementLogicalFilter Methods

The ElementLogicalFilter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetFilters | Returns an array of copies of the filters that are logically combined by this ElementLogicalFilter.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | SetFilters | Replaces current filters in the logical filter with any number of input filters.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ElementLogicalFilter Class


ElementLogicalFilter.GetFilters Method

ElementLogicalFilterGetFilters Method

Returns an array of copies of the filters that are logically combined by this ElementLogicalFilter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ElementFilter> GetFilters()
Public Function GetFilters As IList(Of ElementFilter)
public:
IList<ElementFilter^>^ GetFilters()
member GetFilters : unit -> IList<ElementFilter>

Return Value

IList ElementFilter
Copies of the filters that are logically combined by this ElementLogicalFilter.
See Also

Reference

ElementLogicalFilter Class


ElementLogicalFilter.SetFilters Method

ElementLogicalFilterSetFilters Method

Replaces current filters in the logical filter with any number of input filters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetFilters(
    IList<ElementFilter> filters
)
Public Sub SetFilters (
    filters As IList(Of ElementFilter)
)
public:
void SetFilters(
    IList<ElementFilter^>^ filters
)
member SetFilters :
        filters : IList<ElementFilter> -> unit

Parameters

filters IList ElementFilter
A collection of input filters.
Exceptions
Exception | Condition
ArgumentException | The filter collection is empty, or contains invalid inputs.
ArgumentNullException | A non-optional argument was null
Remarks
The input filters will be copied.
See Also

Reference

ElementLogicalFilter Class


ElementMulticategoryFilter Class

A filter used to find elements whose category matches any of a given set of categories.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementQuickFilter
Autodesk.Revit.DBElementMulticategoryFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ElementMulticategoryFilter : ElementQuickFilter
Public Class ElementMulticategoryFilter
    Inherits ElementQuickFilter
public ref class ElementMulticategoryFilter : public ElementQuickFilter
type ElementMulticategoryFilter =
    class
        inherit ElementQuickFilter
    end

The ElementMulticategoryFilter type exposes the following members.

Constructors
 | Name | Description
Public method | ElementMulticategoryFilter(ICollectionBuiltInCategory) | Constructs a new instance of a filter to match elements by built-in category.
Public method | ElementMulticategoryFilter(ICollectionElementId) | Constructs a new instance of a filter to find elements whose category matches any of a given set of categories.
Public method | ElementMulticategoryFilter(ICollectionBuiltInCategory, Boolean) | Constructs a new instance of a filter to match elements by built-in category, with the option to match all elements which are not of the given category.
Public method | ElementMulticategoryFilter(ICollectionElementId, Boolean) | Constructs a new instance of a filter to find elements whose category matches any of a given set of categories, with the option to instead match elements which are not of the given categories.
Top
Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCategoryIds | Gets the category ids assigned to this filter.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ElementMulticategoryFilter Constructor

Overload List
 | Name | Description
Public method | ElementMulticategoryFilter(ICollectionBuiltInCategory) | Constructs a new instance of a filter to match elements by built-in category.
Public method | ElementMulticategoryFilter(ICollectionElementId) | Constructs a new instance of a filter to find elements whose category matches any of a given set of categories.
Public method | ElementMulticategoryFilter(ICollectionBuiltInCategory, Boolean) | Constructs a new instance of a filter to match elements by built-in category, with the option to match all elements which are not of the given category.
Public method | ElementMulticategoryFilter(ICollectionElementId, Boolean) | Constructs a new instance of a filter to find elements whose category matches any of a given set of categories, with the option to instead match elements which are not of the given categories.
Top
See Also

Reference

ElementMulticategoryFilter Class


ElementMulticategoryFilter(ICollection<BuiltInCategory>) Constructor

ElementMulticategoryFilter(ICollectionBuiltInCategory) Constructor

Constructs a new instance of a filter to match elements by built-in category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementMulticategoryFilter(
    ICollection<BuiltInCategory> categories
)
Public Sub New (
    categories As ICollection(Of BuiltInCategory)
)
public:
ElementMulticategoryFilter(
    ICollection<BuiltInCategory>^ categories
)
new :
        categories : ICollection<BuiltInCategory> -> ElementMulticategoryFilter

Parameters

categories ICollection BuiltInCategory
The built-in categories to match.
See Also

Reference

ElementMulticategoryFilter Class
ElementMulticategoryFilter Overload


ElementMulticategoryFilter(ICollection<ElementId>) Constructor

ElementMulticategoryFilter(ICollectionElementId) Constructor

Constructs a new instance of a filter to find elements whose category matches any of a given set of categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementMulticategoryFilter(
    ICollection<ElementId> categoryIds
)
Public Sub New (
    categoryIds As ICollection(Of ElementId)
)
public:
ElementMulticategoryFilter(
    ICollection<ElementId^>^ categoryIds
)
new :
        categoryIds : ICollection<ElementId> -> ElementMulticategoryFilter

Parameters

categoryIds ICollection ElementId
The category ids to match.
Exceptions
Exception | Condition
ArgumentException | One or more categories was not valid for filtering.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ElementMulticategoryFilter Class
ElementMulticategoryFilter Overload


ElementMulticategoryFilter(ICollection<BuiltInCategory>, Boolean) Constructor

ElementMulticategoryFilter(ICollectionBuiltInCategory, Boolean) Constructor

Constructs a new instance of a filter to match elements by built-in category, with the option to match all elements which are not of the given category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementMulticategoryFilter(
    ICollection<BuiltInCategory> categories,
    bool inverted
)
Public Sub New (
    categories As ICollection(Of BuiltInCategory),
    inverted As Boolean
)
public:
ElementMulticategoryFilter(
    ICollection<BuiltInCategory>^ categories,
    bool inverted
)
new :
        categories : ICollection<BuiltInCategory> *
        inverted : bool -> ElementMulticategoryFilter

Parameters

categories ICollection BuiltInCategory
The built-in categories to match.
inverted Boolean
True if the filter should match all elements which are not of the given built-in categories.
See Also

Reference

ElementMulticategoryFilter Class
ElementMulticategoryFilter Overload


ElementMulticategoryFilter(ICollection<ElementId>, Boolean) Constructor

ElementMulticategoryFilter(ICollectionElementId, Boolean) Constructor

Constructs a new instance of a filter to find elements whose category matches any of a given set of categories, with the option to instead match elements which are not of the given categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementMulticategoryFilter(
    ICollection<ElementId> categoryIds,
    bool inverted
)
Public Sub New (
    categoryIds As ICollection(Of ElementId),
    inverted As Boolean
)
public:
ElementMulticategoryFilter(
    ICollection<ElementId^>^ categoryIds,
    bool inverted
)
new :
        categoryIds : ICollection<ElementId> *
        inverted : bool -> ElementMulticategoryFilter

Parameters

categoryIds ICollection ElementId
The category ids to match.
inverted Boolean
True if the filter should match all elements which are not of the given categories.
Exceptions
Exception | Condition
ArgumentException | One or more categories was not valid for filtering.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ElementMulticategoryFilter Class
ElementMulticategoryFilter Overload


ElementMulticategoryFilter Properties

The ElementMulticategoryFilter type exposes the following members.

Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
See Also

Reference

ElementMulticategoryFilter Class


ElementMulticategoryFilter Methods

The ElementMulticategoryFilter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCategoryIds | Gets the category ids assigned to this filter.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ElementMulticategoryFilter Class


ElementMulticategoryFilter.GetCategoryIds Method

ElementMulticategoryFilterGetCategoryIds Method

Gets the category ids assigned to this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetCategoryIds()
Public Function GetCategoryIds As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetCategoryIds()
member GetCategoryIds : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
The category ids.
See Also

Reference

ElementMulticategoryFilter Class


ElementMulticlassFilter Class

A filter used to match elements by their class, where more than one class of element may be passed.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementQuickFilter
Autodesk.Revit.DBElementMulticlassFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ElementMulticlassFilter : ElementQuickFilter
Public Class ElementMulticlassFilter
    Inherits ElementQuickFilter
public ref class ElementMulticlassFilter : public ElementQuickFilter
type ElementMulticlassFilter =
    class
        inherit ElementQuickFilter
    end

The ElementMulticlassFilter type exposes the following members.

Constructors
 | Name | Description
Public method | ElementMulticlassFilter(IListType) | Constructs a new instance of a filter to find elements whose Element subclasses matches any of a given set of input classes.
Public method | ElementMulticlassFilter(IListType, Boolean) | Constructs a new instance of a filter to find elements whose Element subclasses matches any of a given set of input classes, with an option to instead match elements whose Element subclass does not match the list of input classes.
Top
Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

Only elements whose class is an exact match to one of the input classes, or elements whose type is derived from the input class will pass the collector.

There is a small subset of Element subclasses in the API that are not supported by this filter. These classes exist in the API, but not in Revit's native object model, which means that this filter doesn't support them. In order to use a class filter to find elements of these types, it is necessary to use a higher level class and then process the results further to find elements matching only the subclass. For a list of subclasses affected by this restriction, consult the documentation for [!:Autodesk::Revit::DB::ElementClassFilter].

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ElementMulticlassFilter Constructor

Overload List
 | Name | Description
Public method | ElementMulticlassFilter(IListType) | Constructs a new instance of a filter to find elements whose Element subclasses matches any of a given set of input classes.
Public method | ElementMulticlassFilter(IListType, Boolean) | Constructs a new instance of a filter to find elements whose Element subclasses matches any of a given set of input classes, with an option to instead match elements whose Element subclass does not match the list of input classes.
Top
See Also

Reference

ElementMulticlassFilter Class


ElementMulticlassFilter(IList<Type>) Constructor

ElementMulticlassFilter(IListType) Constructor

Constructs a new instance of a filter to find elements whose Element subclasses matches any of a given set of input classes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementMulticlassFilter(
    IList<Type> typeList
)
Public Sub New (
    typeList As IList(Of Type)
)
public:
ElementMulticlassFilter(
    IList<Type^>^ typeList
)
new :
        typeList : IList<Type> -> ElementMulticlassFilter

Parameters

typeList IList Type
The list of Element subclass types to match.
Exceptions
Exception | Condition
ArgumentException | One or more input types are not valid subclasses of Element for this filter. -or- One or more of the types do not exist in Revit's native object model.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ElementMulticlassFilter Class
ElementMulticlassFilter Overload


ElementMulticlassFilter(IList<Type>, Boolean) Constructor

ElementMulticlassFilter(IListType, Boolean) Constructor

Constructs a new instance of a filter to find elements whose Element subclasses matches any of a given set of input classes, with an option to instead match elements whose Element subclass does not match the list of input classes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementMulticlassFilter(
    IList<Type> typeList,
    bool inverted
)
Public Sub New (
    typeList As IList(Of Type),
    inverted As Boolean
)
public:
ElementMulticlassFilter(
    IList<Type^>^ typeList,
    bool inverted
)
new :
        typeList : IList<Type> *
        inverted : bool -> ElementMulticlassFilter

Parameters

typeList IList Type
The list of Element subclass types to match.
inverted Boolean
True if the filter should match all elements which are not of the given Element subclass.
Exceptions
Exception | Condition
ArgumentException | One or more input types are not valid subclasses of Element for this filter. -or- One or more of the types do not exist in Revit's native object model.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ElementMulticlassFilter Class
ElementMulticlassFilter Overload


ElementMulticlassFilter Properties

The ElementMulticlassFilter type exposes the following members.

Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
See Also

Reference

ElementMulticlassFilter Class


ElementMulticlassFilter Methods

The ElementMulticlassFilter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ElementMulticlassFilter Class


ElementNode Class

A render node that represents an element, including the host document containing the element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRenderNode
Autodesk.Revit.DBElementNode

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ElementNode : RenderNode
Public Class ElementNode
    Inherits RenderNode
public ref class ElementNode : public RenderNode
type ElementNode =
    class
        inherit RenderNode
    end

The ElementNode type exposes the following members.

Properties
 | Name | Description
Public property | Document | Gets the document associated with the element.
Public property | ElementId | The Id of the element.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode)
Public property | LinkInstanceId | The Id of the link instance for the element.
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from RenderNode)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
See also: OnElementBegin2D(ElementNode). See also: OnElementEnd2D(ElementNode).
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ElementNode Properties

The ElementNode type exposes the following members.

Properties
 | Name | Description
Public property | Document | Gets the document associated with the element.
Public property | ElementId | The Id of the element.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode)
Public property | LinkInstanceId | The Id of the link instance for the element.
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode)
Top
See Also

Reference

ElementNode Class


ElementNode.Document Property

ElementNodeDocument Property

Gets the document associated with the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Document Document { get; }
Public ReadOnly Property Document As Document
    Get
public:
property Document^ Document {
    Document^ get ();
}
member Document : Document with get

Property Value

Document
Remarks
The document is in read-only state. Transactions are not allowed in it.
See Also

Reference

ElementNode Class


ElementNode.ElementId Property

ElementNodeElementId Property

The Id of the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId ElementId { get; }
Public ReadOnly Property ElementId As ElementId
    Get
public:
property ElementId^ ElementId {
    ElementId^ get ();
}
member ElementId : ElementId with get

Property Value

ElementId
See Also

Reference

ElementNode Class


ElementNode.LinkInstanceId Property

ElementNodeLinkInstanceId Property

The Id of the link instance for the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId LinkInstanceId { get; }
Public ReadOnly Property LinkInstanceId As ElementId
    Get
public:
property ElementId^ LinkInstanceId {
    ElementId^ get ();
}
member LinkInstanceId : ElementId with get

Property Value

ElementId
See Also

Reference

ElementNode Class


ElementNode Methods

The ElementNode type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from RenderNode)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ElementNode Class


ElementOnPhaseStatus Enumeration

The statuses that an element can have with respect to a given phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ElementOnPhaseStatus
Public Enumeration ElementOnPhaseStatus
public enum class ElementOnPhaseStatus
type ElementOnPhaseStatus
Members
Member name | Value | Description
None | 0 | Phase status is undefined (e.g., for annotations)
Past | 1 | Created and demolished before the given phase
Existing | 2 | Created in a previous phase, existing through the end of the given phase
Demolished | 3 | Created before the given phase, to be demolished on the given phase
New | 4 | Created on this phase (and not demolished)
Temporary | 5 | Created and demolished during this phase
Future | 6 | Created after this phase
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ElementOwnerViewFilter Class

A filter used to match elements which are owned by a particular view.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementQuickFilter
Autodesk.Revit.DBElementOwnerViewFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ElementOwnerViewFilter : ElementQuickFilter
Public Class ElementOwnerViewFilter
    Inherits ElementQuickFilter
public ref class ElementOwnerViewFilter : public ElementQuickFilter
type ElementOwnerViewFilter =
    class
        inherit ElementQuickFilter
    end

The ElementOwnerViewFilter type exposes the following members.

Constructors
 | Name | Description
Public method | ElementOwnerViewFilter(ElementId) | Constructs a new instance of a filter to match elements which are owned by a particular view.
Public method | ElementOwnerViewFilter(ElementId, Boolean) | Constructs a new instance of a filter to match elements which are owned by a particular view, with the option to invert the filter and find elements not owned by the given view.
Top
Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Public property | ViewId | The view id.
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.
Example
C#
VB
C++
F#
Copy
// Use ElementOwnerView filter to find TextNotes in the active view

// Create an ElementOwnerView filter with id of active view
ElementOwnerViewFilter elementOwnerViewFilter = new ElementOwnerViewFilter(document.ActiveView.Id);

// Apply the filter to the elements in the active document,
// Use shortcut method OfClass() to find TextNotes only
FilteredElementCollector collector = new FilteredElementCollector(document);
ICollection<Element> textNotesOfActiveView =
    collector.WherePasses(elementOwnerViewFilter).OfClass(typeof(TextNote)).ToElements();

// Find TextNotes which are not owned by active view: use an inverted filter to match TextNotes
ElementOwnerViewFilter notOwnedFilter = new ElementOwnerViewFilter(document.ActiveView.Id, true); // inverted filter
collector = new FilteredElementCollector(document);
ICollection<Element> notOwnedByViewFounds =
    collector.WherePasses(notOwnedFilter).OfClass(typeof(TextNote)).ToElements();
' Use ElementOwnerView filter to find TextNotes in the active view

' Create an ElementOwnerView filter with id of active view
Dim elementOwnerViewFilter As New ElementOwnerViewFilter(document.ActiveView.Id)

' Apply the filter to the elements in the active document,
' Use shortcut method OfClass() to find TextNotes only
Dim collector As New FilteredElementCollector(document)
Dim textNotesOfActiveView As ICollection(Of Element) = collector.WherePasses(elementOwnerViewFilter).OfClass(GetType(TextNote)).ToElements()

' Find TextNotes which are not owned by active view: use an inverted filter to match TextNotes
Dim notOwnedFilter As New ElementOwnerViewFilter(document.ActiveView.Id, True)
' inverted filter
collector = New FilteredElementCollector(document)
Dim notOwnedByViewFounds As ICollection(Of Element) = collector.WherePasses(notOwnedFilter).OfClass(GetType(TextNote)).ToElements()

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ElementOwnerViewFilter Constructor

Overload List
 | Name | Description
Public method | ElementOwnerViewFilter(ElementId) | Constructs a new instance of a filter to match elements which are owned by a particular view.
Public method | ElementOwnerViewFilter(ElementId, Boolean) | Constructs a new instance of a filter to match elements which are owned by a particular view, with the option to invert the filter and find elements not owned by the given view.
Top
See Also

Reference

ElementOwnerViewFilter Class


ElementOwnerViewFilter(ElementId) Constructor

Constructs a new instance of a filter to match elements which are owned by a particular view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementOwnerViewFilter(
    ElementId viewId
)
Public Sub New (
    viewId As ElementId
)
public:
ElementOwnerViewFilter(
    ElementId^ viewId
)
new :
        viewId : ElementId -> ElementOwnerViewFilter

Parameters

viewId ElementId
The view id to match. Pass invalid element id to create a filter that will pass non-view-specific elements.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ElementOwnerViewFilter Class
ElementOwnerViewFilter Overload


ElementOwnerViewFilter(ElementId, Boolean) Constructor

Constructs a new instance of a filter to match elements which are owned by a particular view, with the option to invert the filter and find elements not owned by the given view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementOwnerViewFilter(
    ElementId viewId,
    bool inverted
)
Public Sub New (
    viewId As ElementId,
    inverted As Boolean
)
public:
ElementOwnerViewFilter(
    ElementId^ viewId,
    bool inverted
)
new :
        viewId : ElementId *
        inverted : bool -> ElementOwnerViewFilter

Parameters

viewId ElementId
The view id to match. Pass invalid element id to create a filter that will pass non-view-specific elements.
inverted Boolean
True if the filter should match all elements which are not owned by the given view.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ElementOwnerViewFilter Class
ElementOwnerViewFilter Overload


ElementOwnerViewFilter Properties

The ElementOwnerViewFilter type exposes the following members.

Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Public property | ViewId | The view id.
Top
See Also

Reference

ElementOwnerViewFilter Class


ElementOwnerViewFilter.ViewId Property

ElementOwnerViewFilterViewId Property

The view id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId ViewId { get; }
Public ReadOnly Property ViewId As ElementId
    Get
public:
property ElementId^ ViewId {
    ElementId^ get ();
}
member ViewId : ElementId with get

Property Value

ElementId
See Also

Reference

ElementOwnerViewFilter Class


ElementOwnerViewFilter Methods

The ElementOwnerViewFilter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ElementOwnerViewFilter Class


ElementParameterFilter Class

A filter used to match elements by one or more parameter filter rules.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementSlowFilter
Autodesk.Revit.DBElementParameterFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ElementParameterFilter : ElementSlowFilter
Public Class ElementParameterFilter
    Inherits ElementSlowFilter
public ref class ElementParameterFilter : public ElementSlowFilter
type ElementParameterFilter =
    class
        inherit ElementSlowFilter
    end

The ElementParameterFilter type exposes the following members.

Constructors
 | Name | Description
Public method | ElementParameterFilter(FilterRule) | Constructs a new instance of an ElementParameterFilter from a single rule.
Public method | ElementParameterFilter(IListFilterRule) | Constructs a new instance of an ElementParameterFilter from a set of rules.
Public method | ElementParameterFilter(FilterRule, Boolean) | Constructs a new instance of an ElementParameterFilter, with the option to match all elements not passing a given filter rule.
Public method | ElementParameterFilter(IListFilterRule, Boolean) | Constructs a new instance of an ElementParameterFilter, with the option to match all elements not passing the given filter rules.
Top
Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRules | Returns the set of rules contained in this filter.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This filter is a slow filter. Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple this filter with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded.
Example
C#
VB
C++
F#
Copy
// Creates an ElementParameter filter to find rooms whose area is
// greater than specified value
// Create filter by provider and evaluator
// provider
ParameterValueProvider pvp = new ParameterValueProvider(new ElementId(BuiltInParameter.ROOM_AREA));
// evaluator
FilterNumericRuleEvaluator fnrv = new FilterNumericGreater();
// rule value
double ruleValue = 100.0f; // filter room whose area is greater than 100 SF
// rule
FilterRule fRule = new FilterDoubleRule(pvp, fnrv, ruleValue, 1E-6);

// Create an ElementParameter filter
ElementParameterFilter filter = new ElementParameterFilter(fRule);

// Apply the filter to the elements in the active document
FilteredElementCollector collector = new FilteredElementCollector(document);
IList<Element> rooms = collector.WherePasses(filter).ToElements();

// Find rooms whose area is less than or equal to 100:
// Use inverted filter to match elements
ElementParameterFilter lessOrEqualFilter = new ElementParameterFilter(fRule, true);
collector = new FilteredElementCollector(document);
IList<Element> lessOrEqualFounds = collector.WherePasses(lessOrEqualFilter).ToElements();
' Creates an ElementParameter filter to find rooms whose area is
' greater than specified value
' Create filter by provider and evaluator
' provider
Dim pvp As New ParameterValueProvider(New ElementId(BuiltInParameter.ROOM_AREA))
' evaluator
Dim fnrv As FilterNumericRuleEvaluator = New FilterNumericGreater()
' rule value
Dim ruleValue As Double = 100.0F
' filter room whose area is greater than 100 SF
' rule
Dim fRule As FilterRule = New FilterDoubleRule(pvp, fnrv, ruleValue, 0.000001)

' Create an ElementParameter filter
Dim filter As New ElementParameterFilter(fRule)

' Apply the filter to the elements in the active document
Dim collector As New FilteredElementCollector(document)
Dim rooms As IList(Of Element) = collector.WherePasses(filter).ToElements()

' Find rooms whose area is less than or equal to 100:
' Use inverted filter to match elements
Dim lessOrEqualFilter As New ElementParameterFilter(fRule, True)
collector = New FilteredElementCollector(document)
Dim lessOrEqualFounds As IList(Of Element) = collector.WherePasses(lessOrEqualFilter).ToElements()

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ElementParameterFilter Constructor

Overload List
 | Name | Description
Public method | ElementParameterFilter(FilterRule) | Constructs a new instance of an ElementParameterFilter from a single rule.
Public method | ElementParameterFilter(IListFilterRule) | Constructs a new instance of an ElementParameterFilter from a set of rules.
Public method | ElementParameterFilter(FilterRule, Boolean) | Constructs a new instance of an ElementParameterFilter, with the option to match all elements not passing a given filter rule.
Public method | ElementParameterFilter(IListFilterRule, Boolean) | Constructs a new instance of an ElementParameterFilter, with the option to match all elements not passing the given filter rules.
Top
See Also

Reference

ElementParameterFilter Class


ElementParameterFilter(FilterRule) Constructor

Constructs a new instance of an ElementParameterFilter from a single rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementParameterFilter(
    FilterRule filterRule
)
Public Sub New (
    filterRule As FilterRule
)
public:
ElementParameterFilter(
    FilterRule^ filterRule
)
new :
        filterRule : FilterRule -> ElementParameterFilter

Parameters

filterRule FilterRule
The rule applied to test if the element passes this filter.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ElementParameterFilter Class
ElementParameterFilter Overload


ElementParameterFilter(IList<FilterRule>) Constructor

ElementParameterFilter(IListFilterRule) Constructor

Constructs a new instance of an ElementParameterFilter from a set of rules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementParameterFilter(
    IList<FilterRule> filterRules
)
Public Sub New (
    filterRules As IList(Of FilterRule)
)
public:
ElementParameterFilter(
    IList<FilterRule^>^ filterRules
)
new :
        filterRules : IList<FilterRule> -> ElementParameterFilter

Parameters

filterRules IList FilterRule
The rules applied to test if the element passes this filter.
Exceptions
Exception | Condition
ArgumentException | The filterRules array is empty or invalid.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ElementParameterFilter Class
ElementParameterFilter Overload


ElementParameterFilter(FilterRule, Boolean) Constructor

Constructs a new instance of an ElementParameterFilter, with the option to match all elements not passing a given filter rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementParameterFilter(
    FilterRule filterRule,
    bool inverted
)
Public Sub New (
    filterRule As FilterRule,
    inverted As Boolean
)
public:
ElementParameterFilter(
    FilterRule^ filterRule,
    bool inverted
)
new :
        filterRule : FilterRule *
        inverted : bool -> ElementParameterFilter

Parameters

filterRule FilterRule
The rule applied to test if the element passes this filter.
inverted Boolean
True if the filter should match all elements which do not pass the filter rule.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ElementParameterFilter Class
ElementParameterFilter Overload


ElementParameterFilter(IList<FilterRule>, Boolean) Constructor

ElementParameterFilter(IListFilterRule, Boolean) Constructor

Constructs a new instance of an ElementParameterFilter, with the option to match all elements not passing the given filter rules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementParameterFilter(
    IList<FilterRule> filterRules,
    bool inverted
)
Public Sub New (
    filterRules As IList(Of FilterRule),
    inverted As Boolean
)
public:
ElementParameterFilter(
    IList<FilterRule^>^ filterRules,
    bool inverted
)
new :
        filterRules : IList<FilterRule> *
        inverted : bool -> ElementParameterFilter

Parameters

filterRules IList FilterRule
The rules applied to test if the element passes this filter.
inverted Boolean
True if the filter should match all elements which do not pass the filter rules.
Exceptions
Exception | Condition
ArgumentException | The filterRules array is empty or invalid.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ElementParameterFilter Class
ElementParameterFilter Overload


ElementParameterFilter Properties

The ElementParameterFilter type exposes the following members.

Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
See Also

Reference

ElementParameterFilter Class


ElementParameterFilter Methods

The ElementParameterFilter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRules | Returns the set of rules contained in this filter.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ElementParameterFilter Class


ElementParameterFilter.GetRules Method

ElementParameterFilterGetRules Method

Returns the set of rules contained in this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<FilterRule> GetRules()
Public Function GetRules As IList(Of FilterRule)
public:
IList<FilterRule^>^ GetRules()
member GetRules : unit -> IList<FilterRule>

Return Value

IList FilterRule
A copy of the set of rules.
See Also

Reference

ElementParameterFilter Class


ElementPhaseStatusFilter Class

A filter used to match elements that have a given phase status on a given phase.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementSlowFilter
Autodesk.Revit.DBElementPhaseStatusFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ElementPhaseStatusFilter : ElementSlowFilter
Public Class ElementPhaseStatusFilter
    Inherits ElementSlowFilter
public ref class ElementPhaseStatusFilter : public ElementSlowFilter
type ElementPhaseStatusFilter =
    class
        inherit ElementSlowFilter
    end

The ElementPhaseStatusFilter type exposes the following members.

Constructors
 | Name | Description
Public method | ElementPhaseStatusFilter(ElementId, ElementOnPhaseStatus) | Constructs a new instance of a file to match elements that have a given phase status on the input phase.
Public method | ElementPhaseStatusFilter(ElementId, ICollectionElementOnPhaseStatus) | Constructs a new instance of a file to match elements that have a given phase statuses on the input phase.
Public method | ElementPhaseStatusFilter(ElementId, ElementOnPhaseStatus, Boolean) | Constructs a new instance of a file to match elements that have a given phase status on the input phase, with the option to match all elements that have a phase status other than the input status.
Public method | ElementPhaseStatusFilter(ElementId, ICollectionElementOnPhaseStatus, Boolean) | Constructs a new instance of a file to match elements that have a given phase statuses on the input phase, with the option to match all elements that have a phase status other than the input statuses.
Top
Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Public property | PhaseId | The phase id.
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetPhaseStatuses | Returns the phase statuses assigned to this filter.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This filter is a slow filter. Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple this filter with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ElementPhaseStatusFilter Constructor

Overload List
 | Name | Description
Public method | ElementPhaseStatusFilter(ElementId, ElementOnPhaseStatus) | Constructs a new instance of a file to match elements that have a given phase status on the input phase.
Public method | ElementPhaseStatusFilter(ElementId, ICollectionElementOnPhaseStatus) | Constructs a new instance of a file to match elements that have a given phase statuses on the input phase.
Public method | ElementPhaseStatusFilter(ElementId, ElementOnPhaseStatus, Boolean) | Constructs a new instance of a file to match elements that have a given phase status on the input phase, with the option to match all elements that have a phase status other than the input status.
Public method | ElementPhaseStatusFilter(ElementId, ICollectionElementOnPhaseStatus, Boolean) | Constructs a new instance of a file to match elements that have a given phase statuses on the input phase, with the option to match all elements that have a phase status other than the input statuses.
Top
See Also

Reference

ElementPhaseStatusFilter Class


ElementPhaseStatusFilter(ElementId, ElementOnPhaseStatus) Constructor

Constructs a new instance of a file to match elements that have a given phase status on the input phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementPhaseStatusFilter(
    ElementId phaseId,
    ElementOnPhaseStatus phaseStatus
)
Public Sub New (
    phaseId As ElementId,
    phaseStatus As ElementOnPhaseStatus
)
public:
ElementPhaseStatusFilter(
    ElementId^ phaseId,
    ElementOnPhaseStatus phaseStatus
)
new :
        phaseId : ElementId *
        phaseStatus : ElementOnPhaseStatus -> ElementPhaseStatusFilter

Parameters

phaseId ElementId
Id of the phase.
phaseStatus ElementOnPhaseStatus
Target status.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ElementPhaseStatusFilter Class
ElementPhaseStatusFilter Overload


ElementPhaseStatusFilter(ElementId, ICollection<ElementOnPhaseStatus>) Constructor

ElementPhaseStatusFilter(ElementId, ICollectionElementOnPhaseStatus) Constructor

Constructs a new instance of a file to match elements that have a given phase statuses on the input phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementPhaseStatusFilter(
    ElementId phaseId,
    ICollection<ElementOnPhaseStatus> phaseStatuses
)
Public Sub New (
    phaseId As ElementId,
    phaseStatuses As ICollection(Of ElementOnPhaseStatus)
)
public:
ElementPhaseStatusFilter(
    ElementId^ phaseId,
    ICollection<ElementOnPhaseStatus>^ phaseStatuses
)
new :
        phaseId : ElementId *
        phaseStatuses : ICollection<ElementOnPhaseStatus> -> ElementPhaseStatusFilter

Parameters

phaseId ElementId
Id of the phase.
phaseStatuses ICollection ElementOnPhaseStatus
Target statuses.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ElementPhaseStatusFilter Class
ElementPhaseStatusFilter Overload


ElementPhaseStatusFilter(ElementId, ElementOnPhaseStatus, Boolean) Constructor

Constructs a new instance of a file to match elements that have a given phase status on the input phase, with the option to match all elements that have a phase status other than the input status.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementPhaseStatusFilter(
    ElementId phaseId,
    ElementOnPhaseStatus phaseStatus,
    bool inverted
)
Public Sub New (
    phaseId As ElementId,
    phaseStatus As ElementOnPhaseStatus,
    inverted As Boolean
)
public:
ElementPhaseStatusFilter(
    ElementId^ phaseId,
    ElementOnPhaseStatus phaseStatus,
    bool inverted
)
new :
        phaseId : ElementId *
        phaseStatus : ElementOnPhaseStatus *
        inverted : bool -> ElementPhaseStatusFilter

Parameters

phaseId ElementId
Id of the phase.
phaseStatus ElementOnPhaseStatus
Target status.
inverted Boolean
True to match all phase statuses other than the input status.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ElementPhaseStatusFilter Class
ElementPhaseStatusFilter Overload


ElementPhaseStatusFilter(ElementId, ICollection<ElementOnPhaseStatus>, Boolean) Constructor

ElementPhaseStatusFilter(ElementId, ICollectionElementOnPhaseStatus, Boolean) Constructor

Constructs a new instance of a file to match elements that have a given phase statuses on the input phase, with the option to match all elements that have a phase status other than the input statuses.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementPhaseStatusFilter(
    ElementId phaseId,
    ICollection<ElementOnPhaseStatus> phaseStatuses,
    bool inverted
)
Public Sub New (
    phaseId As ElementId,
    phaseStatuses As ICollection(Of ElementOnPhaseStatus),
    inverted As Boolean
)
public:
ElementPhaseStatusFilter(
    ElementId^ phaseId,
    ICollection<ElementOnPhaseStatus>^ phaseStatuses,
    bool inverted
)
new :
        phaseId : ElementId *
        phaseStatuses : ICollection<ElementOnPhaseStatus> *
        inverted : bool -> ElementPhaseStatusFilter

Parameters

phaseId ElementId
Id of the phase.
phaseStatuses ICollection ElementOnPhaseStatus
Target statuses.
inverted Boolean
True to match all phase statuses other than the input statuses.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ElementPhaseStatusFilter Class
ElementPhaseStatusFilter Overload


ElementPhaseStatusFilter Properties

The ElementPhaseStatusFilter type exposes the following members.

Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Public property | PhaseId | The phase id.
Top
See Also

Reference

ElementPhaseStatusFilter Class


ElementPhaseStatusFilter.PhaseId Property

ElementPhaseStatusFilterPhaseId Property

The phase id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId PhaseId { get; }
Public ReadOnly Property PhaseId As ElementId
    Get
public:
property ElementId^ PhaseId {
    ElementId^ get ();
}
member PhaseId : ElementId with get

Property Value

ElementId
See Also

Reference

ElementPhaseStatusFilter Class


ElementPhaseStatusFilter Methods

The ElementPhaseStatusFilter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetPhaseStatuses | Returns the phase statuses assigned to this filter.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ElementPhaseStatusFilter Class


ElementPhaseStatusFilter.GetPhaseStatuses Method

ElementPhaseStatusFilterGetPhaseStatuses Method

Returns the phase statuses assigned to this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementOnPhaseStatus> GetPhaseStatuses()
Public Function GetPhaseStatuses As ICollection(Of ElementOnPhaseStatus)
public:
ICollection<ElementOnPhaseStatus>^ GetPhaseStatuses()
member GetPhaseStatuses : unit -> ICollection<ElementOnPhaseStatus>

Return Value

ICollection ElementOnPhaseStatus
The phase statuses.
See Also

Reference

ElementPhaseStatusFilter Class


ElementQuickFilter Class

A base class for a type of filter that operates on element records.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementQuickFilter
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ElementQuickFilter : ElementFilter
Public Class ElementQuickFilter
    Inherits ElementFilter
public ref class ElementQuickFilter : public ElementFilter
type ElementQuickFilter =
    class
        inherit ElementFilter
    end

The ElementQuickFilter type exposes the following members.

Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.
See Also

Reference

Autodesk.Revit.DB Namespace
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementQuickFilter
Autodesk.Revit.DBBoundingBoxContainsPointFilter
Autodesk.Revit.DBBoundingBoxIntersectsFilter
Autodesk.Revit.DBBoundingBoxIsInsideFilter
Autodesk.Revit.DBElementCategoryFilter
Autodesk.Revit.DBElementClassFilter
Autodesk.Revit.DBElementDesignOptionFilter
Autodesk.Revit.DBElementIdSetFilter
Autodesk.Revit.DBElementIsCurveDrivenFilter
Autodesk.Revit.DBElementIsElementTypeFilter
Autodesk.Revit.DBElementMulticategoryFilter
Autodesk.Revit.DBElementMulticlassFilter
Autodesk.Revit.DBElementOwnerViewFilter
Autodesk.Revit.DBElementStructuralTypeFilter
Autodesk.Revit.DBElementWorksetFilter
Autodesk.Revit.DBExclusionFilter
Autodesk.Revit.DB.ExtensibleStorageExtensibleStorageFilter
Autodesk.Revit.DBFamilySymbolFilter
Autodesk.Revit.DBVisibleInViewFilter


ElementQuickFilter Properties

The ElementQuickFilter type exposes the following members.

Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
See Also

Reference

ElementQuickFilter Class


ElementQuickFilter Methods

The ElementQuickFilter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ElementQuickFilter Class


ElementRecord Class

A record in the Revit database representing an element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementRecord

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ElementRecord : IDisposable
Public Class ElementRecord
    Implements IDisposable
public ref class ElementRecord : IDisposable
type ElementRecord =
    class
        interface IDisposable
    end

The ElementRecord type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | WorksetId | Get Id of the workset which owns the element.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ElementRecord
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBoundingBox | Gets the bounding box of the element record.
Public method | GetCategoryId | Gets the category id of the element record.
Public method | GetDesignOptionId | Gets the design option id of the element record.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetId | Gets the id of the element record.
Public method | GetOwnerViewId | Gets the element id of the owner view record.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HasBoundingBox | Determines whether this element record has a bounding box.
Public method | IsAnElementType | Identifies if the element record represents an ElementType.
Public method | IsCurveDriven | Identifies if the element is curve driven.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The record is used to extract basic information about an element before the element is fully expanded in memory.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ElementRecord Properties

The ElementRecord type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | WorksetId | Get Id of the workset which owns the element.
Top
See Also

Reference

ElementRecord Class


ElementRecord.IsValidObject Property

ElementRecordIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ElementRecord Class


ElementRecord.WorksetId Property

ElementRecordWorksetId Property

Get Id of the workset which owns the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WorksetId WorksetId { get; }
Public ReadOnly Property WorksetId As WorksetId
    Get
public:
property WorksetId^ WorksetId {
    WorksetId^ get ();
}
member WorksetId : WorksetId with get

Property Value

WorksetId
Remarks
Each element belongs to one and only one workset.
See Also

Reference

ElementRecord Class


ElementRecord Methods

The ElementRecord type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBoundingBox | Gets the bounding box of the element record.
Public method | GetCategoryId | Gets the category id of the element record.
Public method | GetDesignOptionId | Gets the design option id of the element record.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetId | Gets the id of the element record.
Public method | GetOwnerViewId | Gets the element id of the owner view record.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HasBoundingBox | Determines whether this element record has a bounding box.
Public method | IsAnElementType | Identifies if the element record represents an ElementType.
Public method | IsCurveDriven | Identifies if the element is curve driven.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ElementRecord Class


ElementRecord.Dispose Method

ElementRecordDispose Method

Releases all resources used by the ElementRecord

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ElementRecord Class


ElementRecord.GetBoundingBox Method

ElementRecordGetBoundingBox Method

Gets the bounding box of the element record.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Outline GetBoundingBox()
Public Function GetBoundingBox As Outline
public:
Outline^ GetBoundingBox()
member GetBoundingBox : unit -> Outline

Return Value

Outline
The bounding box outline. if there is no bounding box for this element.
See Also

Reference

ElementRecord Class


ElementRecord.GetCategoryId Method

ElementRecordGetCategoryId Method

Gets the category id of the element record.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GetCategoryId()
Public Function GetCategoryId As ElementId
public:
ElementId^ GetCategoryId()
member GetCategoryId : unit -> ElementId

Return Value

ElementId
The category id.
See Also

Reference

ElementRecord Class


ElementRecord.GetDesignOptionId Method

ElementRecordGetDesignOptionId Method

Gets the design option id of the element record.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GetDesignOptionId()
Public Function GetDesignOptionId As ElementId
public:
ElementId^ GetDesignOptionId()
member GetDesignOptionId : unit -> ElementId

Return Value

ElementId
The design option id.
See Also

Reference

ElementRecord Class


ElementRecord.GetId Method

ElementRecordGetId Method

Gets the id of the element record.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GetId()
Public Function GetId As ElementId
public:
ElementId^ GetId()
member GetId : unit -> ElementId

Return Value

ElementId
The element id.
See Also

Reference

ElementRecord Class


ElementRecord.GetOwnerViewId Method

ElementRecordGetOwnerViewId Method

Gets the element id of the owner view record.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GetOwnerViewId()
Public Function GetOwnerViewId As ElementId
public:
ElementId^ GetOwnerViewId()
member GetOwnerViewId : unit -> ElementId

Return Value

ElementId
The view record element id.
See Also

Reference

ElementRecord Class


ElementRecord.HasBoundingBox Method

ElementRecordHasBoundingBox Method

Determines whether this element record has a bounding box.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasBoundingBox()
Public Function HasBoundingBox As Boolean
public:
bool HasBoundingBox()
member HasBoundingBox : unit -> bool

Return Value

Boolean
True if the element record has a bounding box or false otherwise.
See Also

Reference

ElementRecord Class


ElementRecord.IsAnElementType Method

ElementRecordIsAnElementType Method

Identifies if the element record represents an ElementType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsAnElementType()
Public Function IsAnElementType As Boolean
public:
bool IsAnElementType()
member IsAnElementType : unit -> bool

Return Value

Boolean
True if the element record represents an ElementType.
See Also

Reference

ElementRecord Class


ElementRecord.IsCurveDriven Method

ElementRecordIsCurveDriven Method

Identifies if the element is curve driven.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCurveDriven()
Public Function IsCurveDriven As Boolean
public:
bool IsCurveDriven()
member IsCurveDriven : unit -> bool

Return Value

Boolean
True if the element is curve driven.
See Also

Reference

ElementRecord Class


ElementReferenceType Enumeration

Element reference types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ElementReferenceType
Public Enumeration ElementReferenceType
public enum class ElementReferenceType
type ElementReferenceType
Members
Member name | Value | Description
REFERENCE_TYPE_NONE | 0 | The reference is to an element.
REFERENCE_TYPE_LINEAR | 1 | The reference is to a curve or edge.
REFERENCE_TYPE_SURFACE | 2 | The reference is to a face or face region.
REFERENCE_TYPE_FOREIGN | 3 | The reference is to geometry or elements in linked Revit file.
REFERENCE_TYPE_INSTANCE | 4 | The reference is an instance of a symbol.
REFERENCE_TYPE_CUT_EDGE | 5 | The reference is to a face that was cut (where the original pick was made on the cut edge).
REFERENCE_TYPE_MESH | 6 | The reference is to a mesh.
REFERENCE_TYPE_SUBELEMENT | 7 | The reference is to a subelement.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ElementSet Class

A set that contains element objects.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBElementSet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ElementSet : APIObject, IEnumerable
Public Class ElementSet
    Inherits APIObject
    Implements IEnumerable
public ref class ElementSet : public APIObject,
    IEnumerable
type ElementSet =
    class
        inherit APIObject
        interface IEnumerable
    end

The ElementSet type exposes the following members.

Constructors
 | Name | Description
Public method | ElementSet | Initializes a new instance of the ElementSet class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Size | Returns the number of elements that are in the set.
Top
Methods
 | Name | Description
Public method | Clear | Removes every item element the set, rendering it empty.
Public method | Contains | Tests for the existence of an element within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase | Removes a specified element from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified element into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Example
C#
VB
C++
F#
Copy
ICollection<ElementId> selectedIds = uidoc.Selection.GetElementIds();

string info = "Selected elements:\n";
foreach (ElementId id in selectedIds)
{
    Element elem = document.GetElement(id);
    info += elem.Name + "\n";
}

TaskDialog.Show("Revit",info);
Dim selectedIds As ICollection(Of ElementId) = uidoc.Selection.GetElementIds()

Dim info As String = "Selected elements:" & vbLf
For Each id As ElementId In selectedIds
    Dim elem As Element = document.GetElement(id)
    info += elem.Name + vbLf
Next

TaskDialog.Show("Revit", info)

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ElementSet Constructor

Initializes a new instance of the ElementSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementSet()
Public Sub New
public:
ElementSet()
new : unit -> ElementSet
See Also

Reference

ElementSet Class


ElementSet Properties

The ElementSet type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Size | Returns the number of elements that are in the set.
Top
See Also

Reference

ElementSet Class


ElementSet.IsEmpty Property

ElementSetIsEmpty Property

Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Boolean
Remarks
If the set is empty then True will be returned, otherwise False.
See Also

Reference

ElementSet Class


ElementSet.Size Property

ElementSetSize Property

Returns the number of elements that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
abstract Size : int with get
override Size : int with get

Property Value

Int32
See Also

Reference

ElementSet Class


ElementSet Methods

The ElementSet type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Removes every item element the set, rendering it empty.
Public method | Contains | Tests for the existence of an element within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase | Removes a specified element from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified element into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ElementSet Class


ElementSet.Clear Method

ElementSetClear Method

Removes every item element the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

ElementSet Class


ElementSet.Contains Method

ElementSetContains Method

Tests for the existence of an element within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Contains(
    Element item
)
Public Overridable Function Contains (
    item As Element
) As Boolean
public:
virtual bool Contains(
    Element^ item
)
abstract Contains :
        item : Element -> bool
override Contains :
        item : Element -> bool

Parameters

item Element
The element to be searched for.

Return Value

Boolean
The Contains method returns True if the element is within the set, otherwise False.
See Also

Reference

ElementSet Class


ElementSet.Erase Method

ElementSetErase Method

Removes a specified element from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Erase(
    Element item
)
Public Overridable Function Erase (
    item As Element
) As Integer
public:
virtual int Erase(
    Element^ item
)
abstract Erase :
        item : Element -> int
override Erase :
        item : Element -> int

Parameters

item Element
The element to be erased.

Return Value

Int32
The number of elements that were erased from the set.
See Also

Reference

ElementSet Class


ElementSet.ForwardIterator Method

ElementSetForwardIterator Method

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ElementSetIterator ForwardIterator()
Public Overridable Function ForwardIterator As ElementSetIterator
public:
virtual ElementSetIterator^ ForwardIterator()
abstract ForwardIterator : unit -> ElementSetIterator
override ForwardIterator : unit -> ElementSetIterator

Return Value

ElementSetIterator
Returns a forward moving iterator to the set.
See Also

Reference

ElementSet Class


ElementSet.GetEnumerator Method

ElementSetGetEnumerator Method

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

IEnumerator
Returns a forward moving iterator to the set.

Implements

IEnumerableGetEnumerator
See Also

Reference

ElementSet Class


ElementSet.Insert Method

ElementSetInsert Method

Insert the specified element into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Insert(
    Element item
)
Public Overridable Function Insert (
    item As Element
) As Boolean
public:
virtual bool Insert(
    Element^ item
)
abstract Insert :
        item : Element -> bool
override Insert :
        item : Element -> bool

Parameters

item Element
The element to be inserted into the set.

Return Value

Boolean
Returns whether the element was inserted into the set.
See Also

Reference

ElementSet Class


ElementSet.ReverseIterator Method

ElementSetReverseIterator Method

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ElementSetIterator ReverseIterator()
Public Overridable Function ReverseIterator As ElementSetIterator
public:
virtual ElementSetIterator^ ReverseIterator()
abstract ReverseIterator : unit -> ElementSetIterator
override ReverseIterator : unit -> ElementSetIterator

Return Value

ElementSetIterator
Returns a backward moving iterator to the set.
See Also

Reference

ElementSet Class


ElementSetIterator Class

An iterator to an element set.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBElementSetIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class ElementSetIterator : APIObject,
    IEnumerator
Public MustInherit Class ElementSetIterator
    Inherits APIObject
    Implements IEnumerator
public ref class ElementSetIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type ElementSetIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The ElementSetIterator type exposes the following members.

Constructors
 | Name | Description
Public method | ElementSetIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ElementSetIterator Constructor

For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementSetIterator()
Public Sub New
public:
ElementSetIterator()
new : unit -> ElementSetIterator
Remarks
This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.
See Also

Reference

ElementSetIterator Class


ElementSetIterator Properties

The ElementSetIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

ElementSetIterator Class


ElementSetIterator.Current Property

ElementSetIteratorCurrent Property

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}
abstract Current : Object with get
override Current : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.
See Also

Reference

ElementSetIterator Class


ElementSetIterator Methods

The ElementSetIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ElementSetIterator Class


ElementSetIterator.MoveNext Method

ElementSetIteratorMoveNext Method

Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumeratorMoveNext
Remarks
MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.
See Also

Reference

ElementSetIterator Class


ElementSetIterator.Reset Method

ElementSetIteratorReset Method

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
Remarks
The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.
See Also

Reference

ElementSetIterator Class


ElementSlowFilter Class

A base class for a type of filter that operates on expanded elements.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementSlowFilter
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ElementSlowFilter : ElementFilter
Public Class ElementSlowFilter
    Inherits ElementFilter
public ref class ElementSlowFilter : public ElementFilter
type ElementSlowFilter =
    class
        inherit ElementFilter
    end

The ElementSlowFilter type exposes the following members.

Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple slow filters with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded in order to evaluate against the criteria set by this filter.
See Also

Reference

Autodesk.Revit.DB Namespace
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementSlowFilter
Autodesk.Revit.DB.ArchitectureRoomFilter
Autodesk.Revit.DB.ArchitectureRoomTagFilter
Autodesk.Revit.DBAreaFilter
Autodesk.Revit.DBAreaTagFilter
Autodesk.Revit.DBCurveElementFilter
Autodesk.Revit.DBElementIntersectsFilter
Autodesk.Revit.DBElementLevelFilter
Autodesk.Revit.DBElementParameterFilter
Autodesk.Revit.DBElementPhaseStatusFilter
Autodesk.Revit.DBFamilyInstanceFilter
Autodesk.Revit.DB.MechanicalSpaceFilter
Autodesk.Revit.DB.MechanicalSpaceTagFilter
Autodesk.Revit.DBPrimaryDesignOptionMemberFilter
Autodesk.Revit.DB.StructureFamilyStructuralMaterialTypeFilter
Autodesk.Revit.DB.StructureStructuralInstanceUsageFilter
Autodesk.Revit.DB.StructureStructuralMaterialTypeFilter
Autodesk.Revit.DB.StructureStructuralWallUsageFilter
Autodesk.Revit.UI.SelectionSelectableInViewFilter


ElementSlowFilter Properties

The ElementSlowFilter type exposes the following members.

Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
See Also

Reference

ElementSlowFilter Class


ElementSlowFilter Methods

The ElementSlowFilter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ElementSlowFilter Class


ElementStructuralTypeFilter Class

A filter used to find elements matching a structural type.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementQuickFilter
Autodesk.Revit.DBElementStructuralTypeFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ElementStructuralTypeFilter : ElementQuickFilter
Public Class ElementStructuralTypeFilter
    Inherits ElementQuickFilter
public ref class ElementStructuralTypeFilter : public ElementQuickFilter
type ElementStructuralTypeFilter =
    class
        inherit ElementQuickFilter
    end

The ElementStructuralTypeFilter type exposes the following members.

Constructors
 | Name | Description
Public method | ElementStructuralTypeFilter(StructuralType) | Constructs a new instance of a filter to match elements by structural type.
Public method | ElementStructuralTypeFilter(StructuralType, Boolean) | Constructs a new instance of a filter to match elements by structural type, with the option to match all elements which are of the given structural type.
Top
Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Public property | StructuralType | The structural type.
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ElementStructuralTypeFilter Constructor

Overload List
 | Name | Description
Public method | ElementStructuralTypeFilter(StructuralType) | Constructs a new instance of a filter to match elements by structural type.
Public method | ElementStructuralTypeFilter(StructuralType, Boolean) | Constructs a new instance of a filter to match elements by structural type, with the option to match all elements which are of the given structural type.
Top
See Also

Reference

ElementStructuralTypeFilter Class


ElementStructuralTypeFilter(StructuralType) Constructor

Constructs a new instance of a filter to match elements by structural type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementStructuralTypeFilter(
    StructuralType structuralType
)
Public Sub New (
    structuralType As StructuralType
)
public:
ElementStructuralTypeFilter(
    StructuralType structuralType
)
new :
        structuralType : StructuralType -> ElementStructuralTypeFilter

Parameters

structuralType StructuralType
The structural type to match.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ElementStructuralTypeFilter Class
ElementStructuralTypeFilter Overload


ElementStructuralTypeFilter(StructuralType, Boolean) Constructor

Constructs a new instance of a filter to match elements by structural type, with the option to match all elements which are of the given structural type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementStructuralTypeFilter(
    StructuralType structuralType,
    bool inverted
)
Public Sub New (
    structuralType As StructuralType,
    inverted As Boolean
)
public:
ElementStructuralTypeFilter(
    StructuralType structuralType,
    bool inverted
)
new :
        structuralType : StructuralType *
        inverted : bool -> ElementStructuralTypeFilter

Parameters

structuralType StructuralType
The structural type to match.
inverted Boolean
True if the filter should match all elements which are not of the given structural type.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ElementStructuralTypeFilter Class
ElementStructuralTypeFilter Overload


ElementStructuralTypeFilter Properties

The ElementStructuralTypeFilter type exposes the following members.

Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Public property | StructuralType | The structural type.
Top
See Also

Reference

ElementStructuralTypeFilter Class


ElementStructuralTypeFilter.StructuralType Property

ElementStructuralTypeFilterStructuralType Property

The structural type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public StructuralType StructuralType { get; }
Public ReadOnly Property StructuralType As StructuralType
    Get
public:
property StructuralType StructuralType {
    StructuralType get ();
}
member StructuralType : StructuralType with get

Property Value

StructuralType
See Also

Reference

ElementStructuralTypeFilter Class


ElementStructuralTypeFilter Methods

The ElementStructuralTypeFilter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ElementStructuralTypeFilter Class


ElementTransformUtils Class

A collection of utilities allowing transformation of elements (e.g. move, rotate, mirror and copy).
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementTransformUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ElementTransformUtils
Public NotInheritable Class ElementTransformUtils
public ref class ElementTransformUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ElementTransformUtils = class end

The ElementTransformUtils type exposes the following members.

Methods
Name | Description
CanMirrorElement | Determines whether element can be mirrored.
CanMirrorElements | Determines whether elements can be mirrored.
CopyElement | Copies an element and places the copy at a location indicated by a given transformation.
CopyElements(Document, ICollectionElementId, XYZ) | Copies a set of elements and places the copies at a location indicated by a given translation.
CopyElements(Document, ICollectionElementId, Document, Transform, CopyPasteOptions) | Copies a set of elements from source document to destination document.
CopyElements(View, ICollectionElementId, View, Transform, CopyPasteOptions) | Copies a set of elements from source view to destination view.
GetTransformFromViewToView | Returns a transformation that is applied to elements when copying from one view to another view.
MirrorElement | Creates a mirrored copy of an element about a given plane.
MirrorElements | Mirrors a set of elements about a given plane.
MoveElement | Moves one element by a given transformation.
MoveElements | Moves a set of elements by a given transformation.
RotateElement | Rotates an element about the given axis and angle.
RotateElements | Rotates a set of elements about the given axis and angle.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ElementTransformUtils Methods

The ElementTransformUtils type exposes the following members.

Methods
Name | Description
CanMirrorElement | Determines whether element can be mirrored.
CanMirrorElements | Determines whether elements can be mirrored.
CopyElement | Copies an element and places the copy at a location indicated by a given transformation.
CopyElements(Document, ICollectionElementId, XYZ) | Copies a set of elements and places the copies at a location indicated by a given translation.
CopyElements(Document, ICollectionElementId, Document, Transform, CopyPasteOptions) | Copies a set of elements from source document to destination document.
CopyElements(View, ICollectionElementId, View, Transform, CopyPasteOptions) | Copies a set of elements from source view to destination view.
GetTransformFromViewToView | Returns a transformation that is applied to elements when copying from one view to another view.
MirrorElement | Creates a mirrored copy of an element about a given plane.
MirrorElements | Mirrors a set of elements about a given plane.
MoveElement | Moves one element by a given transformation.
MoveElements | Moves a set of elements by a given transformation.
RotateElement | Rotates an element about the given axis and angle.
RotateElements | Rotates a set of elements about the given axis and angle.
Top
See Also

Reference

ElementTransformUtils Class


ElementTransformUtils.CanMirrorElement Method

ElementTransformUtilsCanMirrorElement Method

Determines whether element can be mirrored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CanMirrorElement(
    Document ADoc,
    ElementId elemId
)
Public Shared Function CanMirrorElement (
    ADoc As Document,
    elemId As ElementId
) As Boolean
public:
static bool CanMirrorElement(
    Document^ ADoc,
    ElementId^ elemId
)
static member CanMirrorElement :
        ADoc : Document *
        elemId : ElementId -> bool

Parameters

ADoc Document
The document where the element reside.
elemId ElementId
The element identified by id.

Return Value

Boolean
True if the element can be mirrored.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ElementTransformUtils Class


ElementTransformUtils.CanMirrorElements Method

ElementTransformUtilsCanMirrorElements Method

Determines whether elements can be mirrored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CanMirrorElements(
    Document ADoc,
    ICollection<ElementId> elemIds
)
Public Shared Function CanMirrorElements (
    ADoc As Document,
    elemIds As ICollection(Of ElementId)
) As Boolean
public:
static bool CanMirrorElements(
    Document^ ADoc,
    ICollection<ElementId^>^ elemIds
)
static member CanMirrorElements :
        ADoc : Document *
        elemIds : ICollection<ElementId> -> bool

Parameters

ADoc Document
The document where the elements reside.
elemIds ICollection ElementId
The elements identified by id.

Return Value

Boolean
True if the elements can be mirrored.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ElementTransformUtils Class


ElementTransformUtils.CopyElement Method

ElementTransformUtilsCopyElement Method

Copies an element and places the copy at a location indicated by a given transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ICollection<ElementId> CopyElement(
    Document document,
    ElementId elementToCopy,
    XYZ translation
)
Public Shared Function CopyElement (
    document As Document,
    elementToCopy As ElementId,
    translation As XYZ
) As ICollection(Of ElementId)
public:
static ICollection<ElementId^>^ CopyElement(
    Document^ document,
    ElementId^ elementToCopy,
    XYZ^ translation
)
static member CopyElement :
        document : Document *
        elementToCopy : ElementId *
        translation : XYZ -> ICollection<ElementId>

Parameters

document Document
The document that owns the element.
elementToCopy ElementId
The id of the element to copy.
translation XYZ
The translation vector for the new element.

Return Value

ICollection ElementId
The ids of the newly created copied elements. More than one element may be created due to dependencies.
Exceptions
Exception | Condition
ArgumentException | The element elementToCopy does not exist in the document -or- The input element is a Sketch member and there is no Sketch in the edit mode to place this element in.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | It is not allowed to copy Sketch member to non-parallel sketch. -or- If we are not able to copy the element.
See Also

Reference

ElementTransformUtils Class


ElementTransformUtils.CopyElements Method

ElementTransformUtilsCopyElements Method

Overload List
Name | Description
CopyElements(Document, ICollectionElementId, XYZ) | Copies a set of elements and places the copies at a location indicated by a given translation.
CopyElements(Document, ICollectionElementId, Document, Transform, CopyPasteOptions) | Copies a set of elements from source document to destination document.
CopyElements(View, ICollectionElementId, View, Transform, CopyPasteOptions) | Copies a set of elements from source view to destination view.
Top
See Also

Reference

ElementTransformUtils Class


ElementTransformUtils.CopyElements(Document, ICollection<ElementId>, XYZ) Method

ElementTransformUtilsCopyElements(Document, ICollectionElementId, XYZ) Method

Copies a set of elements and places the copies at a location indicated by a given translation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ICollection<ElementId> CopyElements(
    Document document,
    ICollection<ElementId> elementsToCopy,
    XYZ translation
)
Public Shared Function CopyElements (
    document As Document,
    elementsToCopy As ICollection(Of ElementId),
    translation As XYZ
) As ICollection(Of ElementId)
public:
static ICollection<ElementId^>^ CopyElements(
    Document^ document,
    ICollection<ElementId^>^ elementsToCopy,
    XYZ^ translation
)
static member CopyElements :
        document : Document *
        elementsToCopy : ICollection<ElementId> *
        translation : XYZ -> ICollection<ElementId>

Parameters

document Document
The document that owns the elements.
elementsToCopy ICollection ElementId
The set of elements to copy.
translation XYZ
The translation vector for the new elements.

Return Value

ICollection ElementId
The ids of the newly created copied elements.
Exceptions
Exception | Condition
ArgumentException | The given element id set is empty. -or- One or more elements in elementsToCopy do not exist in the document. -or- Some of the elements cannot be copied, because they belong to different views. -or- The input set of elements contains Sketch members along with other elements or there is no active Sketch edit mode.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | It is not allowed to copy Sketch members between non-parallel sketches. -or- If we are not able to copy all the elements.
Remarks
This method is not suitable for elements that are hosted in other elements as it does not perform rehosting. If you need to rehost your elements in addition to copying them, use one of the other CopyElements() overloads.
See Also

Reference

ElementTransformUtils Class
CopyElements Overload


ElementTransformUtils.CopyElements(Document, ICollection<ElementId>, Document, Transform, CopyPasteOptions) Method

ElementTransformUtilsCopyElements(Document, ICollectionElementId, Document, Transform, CopyPasteOptions) Method

Copies a set of elements from source document to destination document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ICollection<ElementId> CopyElements(
    Document sourceDocument,
    ICollection<ElementId> elementsToCopy,
    Document destinationDocument,
    Transform transform,
    CopyPasteOptions options
)
Public Shared Function CopyElements (
    sourceDocument As Document,
    elementsToCopy As ICollection(Of ElementId),
    destinationDocument As Document,
    transform As Transform,
    options As CopyPasteOptions
) As ICollection(Of ElementId)
public:
static ICollection<ElementId^>^ CopyElements(
    Document^ sourceDocument,
    ICollection<ElementId^>^ elementsToCopy,
    Document^ destinationDocument,
    Transform^ transform,
    CopyPasteOptions^ options
)
static member CopyElements :
        sourceDocument : Document *
        elementsToCopy : ICollection<ElementId> *
        destinationDocument : Document *
        transform : Transform *
        options : CopyPasteOptions -> ICollection<ElementId>

Parameters

sourceDocument Document
The document that contains the elements to copy.
elementsToCopy ICollection ElementId
The set of elements to copy.
destinationDocument Document
The destination document to paste the elements into.
transform Transform
The transform for the new elements. Can be if no transform is required.
options CopyPasteOptions
Optional settings. Can be if default settings should be used.

Return Value

ICollection ElementId
The ids of the newly created copied elements.
Exceptions
Exception | Condition
ArgumentException | The given element id set is empty. -or- One or more elements in elementsToCopy do not exist in the document. -or- Some of the elements cannot be copied, because they are view-specific. -or- The input set of elements contains Sketch members along with other elements or there is no active Sketch edit mode.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | It is not allowed to copy Sketch members between non-parallel sketches. -or- The elements cannot be copied.
OperationCanceledException | User cancelled the operation.
Remarks

Copies are placed at their respective original locations or locations specified by the optional transformation.

This method can be used for copying non-view specific elements only. For copying view-specific elements, use the view-specific form of the CopyElements method.

The destination document can be the same as the source document.

This method performs rehosting of elements where applicable.

Example
C#
VB
C++
F#
Copy
// Copy wall element.
public void CopyWall(Autodesk.Revit.DB.Document sourceDocument, Autodesk.Revit.DB.Document destinationDocument, Autodesk.Revit.DB.Wall wall)
{
   Transform transform = Transform.CreateTranslation(new XYZ(150, 150, 0));
   CopyPasteOptions options = new CopyPasteOptions();

   ElementTransformUtils.CopyElements(sourceDocument, new List<ElementId> { wall.Id }, destinationDocument, transform, options);
}

// The method copies existing Sketch curves inside of the Floor sketch.
public void CopySketchMembersInsideOfSketch(Autodesk.Revit.DB.Document document, Autodesk.Revit.DB.Floor floor)
{
   var floorSketch = document.GetElement(floor.SketchId) as Sketch;

   // Start Sketch edit mode to copy Sketch members inside of the Sketch
   SketchEditScope sketchScope = new SketchEditScope(document, "Edit floor sketch");
   sketchScope.Start(floor.SketchId);

   // Start transaction to be able to modify the document
   using (Transaction tr = new Transaction(document, "Copy sketch members"))
   {
      tr.Start();

      var transform = Transform.CreateTranslation(new XYZ(150, 150, 0));
      var copiedIds = ElementTransformUtils.CopyElements(
         document, floorSketch.GetAllElements(), document, transform, new CopyPasteOptions());

      tr.Commit();
   }

   sketchScope.Commit(new CustomFailuresPreprocessor());
}

// The method copies Sketch members from the Floor to the Ceiling Sketch.
public void CopySketchMembersBetweenSketch(Autodesk.Revit.DB.Floor floor, Autodesk.Revit.DB.Ceiling ceiling)
{
   var ceilingSketch = ceiling.Document.GetElement(ceiling.SketchId) as Sketch;
   var floorSketch = floor.Document.GetElement(floor.SketchId) as Sketch;

   // Sketch members can be copied only between parallel Sketches.
   if (!MathComparisonUtils.IsAlmostEqual(
      Math.Abs(floorSketch.SketchPlane.GetPlane().Normal.DotProduct(ceilingSketch.SketchPlane.GetPlane().Normal)), 1.0))
   {
      return;
   }

   // Start Sketch edit mode, for the ceiling sketch, to copy and paste floor Sketch members to the ceiling
   SketchEditScope sketchScope = new SketchEditScope(ceiling.Document, "Edit ceiling sketch");
   sketchScope.Start(ceiling.SketchId);

   // Start transaction to be able to modify the document
   using (Transaction tr = new Transaction(ceiling.Document, "Copy sketch members"))
   {
      tr.Start();

      var transform = Transform.CreateTranslation(new XYZ(150, 150, 0));
      var copiedIds = ElementTransformUtils.CopyElements(
         floor.Document, floorSketch.GetAllElements(), ceiling.Document, transform, new CopyPasteOptions());

      tr.Commit();
   }

   sketchScope.Commit(new CustomFailuresPreprocessor());
}

// The method copies ModelCurves from the document to the Sketch.
public void CopyModelCurvesFromDocumentToSketch(Autodesk.Revit.DB.Sketch sketch, List<ElementId> modelCurveIds)
{
   // Start Sketch edit mode to insert ModelCurves into the Floor Sketch.
   SketchEditScope sketchScope = new SketchEditScope(sketch.Document, "Edit floor sketch");
   sketchScope.Start(sketch.Id);

   // Start transaction to be able to modify the document
   using (Transaction tr = new Transaction(sketch.Document, "Copy sketch members"))
   {
      tr.Start();

      var transform = Transform.CreateTranslation(new XYZ(150, 150, 0));
      var copiedIds = ElementTransformUtils.CopyElements(
         sketch.Document, modelCurveIds, sketch.Document, transform, new CopyPasteOptions());

      tr.Commit();
   }

   // Sketch curves should not have open loops or intersections to be successfully committed.
   sketchScope.Commit(new CustomFailuresPreprocessor());
}
'Copy wall element.
Public Sub CopyWall(ByVal sourceDocument As Autodesk.Revit.DB.Document, ByVal destinationDocument As Autodesk.Revit.DB.Document, ByVal wall As Autodesk.Revit.DB.Wall)
    Dim transform As Transform = Transform.CreateTranslation(New XYZ(150, 150, 0))
    Dim options As CopyPasteOptions = New CopyPasteOptions()
    ElementTransformUtils.CopyElements(sourceDocument, New List(Of ElementId) From {
        wall.Id
    }, destinationDocument, transform, options)
End Sub

'The method copies existing Sketch curves inside of the Floor sketch.
Public Sub CopySketchMembersInsideOfSketch(ByVal document As Autodesk.Revit.DB.Document, ByVal floor As Autodesk.Revit.DB.Floor)
    Dim floorSketch = TryCast(document.GetElement(floor.SketchId), Sketch)

    'Start Sketch edit mode to copy Sketch members inside of the Sketch
    Dim sketchScope As SketchEditScope = New SketchEditScope(document, "Edit floor sketch")
    sketchScope.Start(floor.SketchId)

    'Start Sketch edit mode to copy Sketch members inside of the Sketch
    Using tr As Transaction = New Transaction(document, "Copy sketch members")
        tr.Start()
        Dim transform As Transform = Transform.CreateTranslation(New XYZ(150, 150, 0))
        Dim copiedIds = ElementTransformUtils.CopyElements(document, floorSketch.GetAllElements(), document, transform, New CopyPasteOptions())
        tr.Commit()
    End Using

    sketchScope.Commit(New CustomFailuresPreprocessor())
End Sub

'The method copies Sketch members from the Floor to the Ceiling Sketch.
Public Sub CopySketchMembersBetweenSketch(ByVal floor As Autodesk.Revit.DB.Floor, ByVal ceiling As Autodesk.Revit.DB.Ceiling)
    Dim ceilingSketch = TryCast(ceiling.Document.GetElement(ceiling.SketchId), Sketch)
    Dim floorSketch = TryCast(floor.Document.GetElement(floor.SketchId), Sketch)

    'Sketch members can be copied only between parallel Sketches.
    If Not MathComparisonUtils.IsAlmostEqual(Math.Abs(floorSketch.SketchPlane.GetPlane().Normal.DotProduct(ceilingSketch.SketchPlane.GetPlane().Normal)), 1.0) Then
        Return
    End If

    'Start Sketch edit mode, for the ceiling sketch, to copy and paste floor Sketch members to the ceiling
    Dim sketchScope As SketchEditScope = New SketchEditScope(ceiling.Document, "Edit ceiling sketch")
    sketchScope.Start(ceiling.SketchId)

    'Start transaction to be able to modify the document
    Using tr As Transaction = New Transaction(ceiling.Document, "Copy sketch members")
        tr.Start()
        Dim transform As Transform = Transform.CreateTranslation(New XYZ(150, 150, 0))
        Dim copiedIds = ElementTransformUtils.CopyElements(floor.Document, floorSketch.GetAllElements(), ceiling.Document, transform, New CopyPasteOptions())
        tr.Commit()
    End Using

    sketchScope.Commit(New CustomFailuresPreprocessor())
End Sub

'The method copies ModelCurves from the document to the Sketch.
Public Sub CopyModelCurvesFromDocumentToSketch(ByVal sketch As Autodesk.Revit.DB.Sketch, ByVal modelCurveIds As List(Of ElementId))
    'Start Sketch edit mode to insert ModelCurves into the Floor Sketch.
    Dim sketchScope As SketchEditScope = New SketchEditScope(sketch.Document, "Edit floor sketch")
    sketchScope.Start(sketch.Id)

    'Start transaction to be able to modify the document
    Using tr As Transaction = New Transaction(sketch.Document, "Copy sketch members")
        tr.Start()
        Dim transform As Transform = Transform.CreateTranslation(New XYZ(150, 150, 0))
        Dim copiedIds = ElementTransformUtils.CopyElements(sketch.Document, modelCurveIds, sketch.Document, transform, New CopyPasteOptions())
        tr.Commit()
    End Using

    'Sketch curves should not have open loops or intersections to be successfully committed.
    sketchScope.Commit(New CustomFailuresPreprocessor())
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

ElementTransformUtils Class
CopyElements Overload


ElementTransformUtils.CopyElements(View, ICollection<ElementId>, View, Transform, CopyPasteOptions) Method

ElementTransformUtilsCopyElements(View, ICollectionElementId, View, Transform, CopyPasteOptions) Method

Copies a set of elements from source view to destination view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ICollection<ElementId> CopyElements(
    View sourceView,
    ICollection<ElementId> elementsToCopy,
    View destinationView,
    Transform additionalTransform,
    CopyPasteOptions options
)
Public Shared Function CopyElements (
    sourceView As View,
    elementsToCopy As ICollection(Of ElementId),
    destinationView As View,
    additionalTransform As Transform,
    options As CopyPasteOptions
) As ICollection(Of ElementId)
public:
static ICollection<ElementId^>^ CopyElements(
    View^ sourceView,
    ICollection<ElementId^>^ elementsToCopy,
    View^ destinationView,
    Transform^ additionalTransform,
    CopyPasteOptions^ options
)
static member CopyElements :
        sourceView : View *
        elementsToCopy : ICollection<ElementId> *
        destinationView : View *
        additionalTransform : Transform *
        options : CopyPasteOptions -> ICollection<ElementId>

Parameters

sourceView View
The view in the source document that contains the elements to copy.
elementsToCopy ICollection ElementId
The set of elements to copy.
destinationView View
The view in the destination document that the elements will be pasted into.
additionalTransform Transform
The transform for the new elements, in addition to the transformation between the source and destination views. Can be if no transform is required. The transformation must be within the plane of the destination view.
options CopyPasteOptions
Optional settings. Can be if default settings should be used.

Return Value

ICollection ElementId
The ids of the newly created copied elements.
Exceptions
Exception | Condition
ArgumentException | The given element id set is empty. -or- The specified view cannot be used as a source or destination for copying elements between two views. -or- Some of the elements cannot be copied, because they belong to a different document. -or- Some of the elements cannot be copied, because they belong to a different view. -or- The elements cannot be copied into the destination view. Drafting views cannot contain model elements. -or- The transformation is not within the plane of the destination view. -or- The input set of elements contains Sketch members along with other elements and the Sketch Id of those members isn't in the set.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | It is not allowed to copy Sketch members between non-parallel sketches. -or- The elements cannot be copied.
OperationCanceledException | User cancelled the operation.
Remarks

This method can be used for both view-specific and model elements.

Both source and destination views must be 2D graphics views capable of drawing details and view-specific elements (floor and ceiling plans, elevations, sections, drafting views.) Drafting views cannot be used as a destination for model elements.

The pasted elements are repositioned to ensure proper placement in the destination view (e.g. elevation is changed when copying from a level to a different level.) Additional transformation within the destination view can be performed by providing additionalTransform argument. This additional transformation must be within the plane of the destination view.

The destination view can be in the same document as the source view.

The destination view can be the same as the source view.

All view-specific elements in the set must be specific to the source view. Elements specific to views other than the source view or to multiple views cannot be copied.

This method performs rehosting of elements where applicable.

Example
C#
VB
C++
F#
Copy
// The method copies view-specific DetailCurve.
public void CopyDetailCurve(Autodesk.Revit.DB.DetailCurve curve, Autodesk.Revit.DB.View destinationView)
{
   var ownerView = curve.Document.GetElement(curve.OwnerViewId) as Autodesk.Revit.DB.View;
   Transform transform = Transform.CreateTranslation(new XYZ(150, 150, 0));
   CopyPasteOptions options = new CopyPasteOptions();

   ElementTransformUtils.CopyElements(ownerView, new List<ElementId> { curve.Id }, destinationView, transform, options);
}

// The method copies sketch curves from the Floor Sketch to the Document to create independent ModelCurves
// that would replicate curves in the sketch.
public void CopySketchMembersToDocument(Autodesk.Revit.DB.Document document, Autodesk.Revit.DB.Floor floor, Autodesk.Revit.DB.View destinationView)
{
   var floorSketch = document.GetElement(floor.SketchId) as Sketch;
   // Select only curve elements from Sketch.
   var sketchCurves = floorSketch.GetAllElements().Where(id => document.GetElement(id) is ModelCurve).ToList();
   var transform = Transform.CreateTranslation(new XYZ(150, 150, 0));

   var copiedIds = ElementTransformUtils.CopyElements(
      destinationView, sketchCurves, destinationView, transform, new CopyPasteOptions());
}
    'The method copies view-specific DetailCurve.
    Public Sub CopyDetailCurve(ByVal curve As Autodesk.Revit.DB.DetailCurve, ByVal destinationView As Autodesk.Revit.DB.View)
        Dim ownerView = TryCast(curve.Document.GetElement(curve.OwnerViewId), Autodesk.Revit.DB.View)
        Dim transform As Transform = Transform.CreateTranslation(New XYZ(150, 150, 0))
        Dim options As CopyPasteOptions = New CopyPasteOptions()
        ElementTransformUtils.CopyElements(ownerView, New List(Of ElementId) From {
            curve.Id
        }, destinationView, transform, options)
    End Sub

    'The method copies sketch curves from the Floor Sketch to the Document to create independent ModelCurves
    'that would replicate curves in the sketch.
    Public Sub CopySketchMembersToDocument(ByVal document As Autodesk.Revit.DB.Document, ByVal floor As Autodesk.Revit.DB.Floor, ByVal destinationView As Autodesk.Revit.DB.View)
        Dim floorSketch = TryCast(document.GetElement(floor.SketchId), Sketch)

        'Select only curve elements from Sketch.
        Dim sketchCurves = floorSketch.GetAllElements().Where(Function(id) TypeOf document.GetElement(id) Is ModelCurve).ToList()
        Dim transform As Transform = Transform.CreateTranslation(New XYZ(150, 150, 0))
        Dim copiedIds = ElementTransformUtils.CopyElements(destinationView, sketchCurves, destinationView, transform, New CopyPasteOptions())
    End Sub
End Class

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

ElementTransformUtils Class
CopyElements Overload


ElementTransformUtils.GetTransformFromViewToView Method

ElementTransformUtilsGetTransformFromViewToView Method

Returns a transformation that is applied to elements when copying from one view to another view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Transform GetTransformFromViewToView(
    View sourceView,
    View destinationView
)
Public Shared Function GetTransformFromViewToView (
    sourceView As View,
    destinationView As View
) As Transform
public:
static Transform^ GetTransformFromViewToView(
    View^ sourceView,
    View^ destinationView
)
static member GetTransformFromViewToView :
        sourceView : View *
        destinationView : View -> Transform

Parameters

sourceView View
The source view
destinationView View
The destination view

Return Value

Transform
The transformation from source view to destination view.
Exceptions
Exception | Condition
ArgumentException | The specified view cannot be used as a source or destination for copying elements between two views.
ArgumentNullException | A non-optional argument was null
Remarks
Both source and destination views must be 2D graphics views capable of drawing details and view-specific elements (floor and ceiling plans, elevations, sections, drafting views.) The result is a transformation needed to copy an element from drawing plane of the source view to the drawing plane of the destination view. The destination view can be in the same document as the source view. The destination view can be the same as the source view.
See Also

Reference

ElementTransformUtils Class


ElementTransformUtils.MirrorElement Method

ElementTransformUtilsMirrorElement Method

Creates a mirrored copy of an element about a given plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void MirrorElement(
    Document document,
    ElementId elementToMirror,
    Plane plane
)
Public Shared Sub MirrorElement (
    document As Document,
    elementToMirror As ElementId,
    plane As Plane
)
public:
static void MirrorElement(
    Document^ document,
    ElementId^ elementToMirror,
    Plane^ plane
)
static member MirrorElement :
        document : Document *
        elementToMirror : ElementId *
        plane : Plane -> unit

Parameters

document Document
The document that owns the element.
elementToMirror ElementId
The element to mirror.
plane Plane
The mirror plane.
Exceptions
Exception | Condition
ArgumentException | elementToMirror cannot be mirrored. -or- The element elementToMirror does not exist in the document -or- The input element is a Sketch member and there is no Sketch in the edit mode to place this element in.
ArgumentNullException | A non-optional argument was null
Example
C#
VB
C++
F#
Copy
public void MirrorWall(Autodesk.Revit.DB.Document document, Wall wall)
{
    Reference reference = HostObjectUtils.GetSideFaces(wall, ShellLayerType.Exterior).First();
    Face face = wall.GetGeometryObjectFromReference(reference) as Face; // get one of the wall's major side faces

    UV bboxMin = face.GetBoundingBox().Min;
    Plane plane = Plane.CreateByNormalAndOrigin(face.ComputeNormal(bboxMin), face.Evaluate(bboxMin).Add(new XYZ(10, 10, 0)));
    // create a plane based on this side face with an offset of 10 in the X & Y directions

    ElementTransformUtils.MirrorElement(document, wall.Id, plane);
}
Public Sub MirrorWall(document As Autodesk.Revit.DB.Document, wall As Wall)
    Dim reference As Reference = HostObjectUtils.GetSideFaces(wall, ShellLayerType.Exterior).First()
    Dim face As Face = TryCast(wall.GetGeometryObjectFromReference(reference), Face)
    ' get one of the wall's major side faces
    Dim bboxMin As UV = face.GetBoundingBox().Min
 Dim plane As Plane = Autodesk.Revit.DB.Plane.CreateByNormalAndOrigin(face.ComputeNormal(bboxMin), face.Evaluate(bboxMin).Add(New XYZ(10, 10, 0)))
    ' create a plane based on this side face with an offset of 10 in the X & Y directions

    ElementTransformUtils.MirrorElement(document, wall.Id, plane)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

ElementTransformUtils Class


ElementTransformUtils.MirrorElements Method

ElementTransformUtilsMirrorElements Method

Mirrors a set of elements about a given plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<ElementId> MirrorElements(
    Document document,
    ICollection<ElementId> elementsToMirror,
    Plane plane,
    bool mirrorCopies
)
Public Shared Function MirrorElements (
    document As Document,
    elementsToMirror As ICollection(Of ElementId),
    plane As Plane,
    mirrorCopies As Boolean
) As IList(Of ElementId)
public:
static IList<ElementId^>^ MirrorElements(
    Document^ document,
    ICollection<ElementId^>^ elementsToMirror,
    Plane^ plane,
    bool mirrorCopies
)
static member MirrorElements :
        document : Document *
        elementsToMirror : ICollection<ElementId> *
        plane : Plane *
        mirrorCopies : bool -> IList<ElementId>

Parameters

document Document
The document that owns the elements.
elementsToMirror ICollection ElementId
The set of elements to mirror.
plane Plane
The mirror plane.
mirrorCopies Boolean
True if mirroring should be performed on copies of the elements, leaving the original elements intact. False if no copies should be created and the elements should be mirrored directly.

Return Value

IList ElementId
A collection of ids of newly created elements - mirrored copies. It is empty if the mirrorCopies arguments is false.
Exceptions
Exception | Condition
ArgumentException | elementsToMirror cannot be mirrored. -or- The given element id set is empty. -or- One or more elements in elementsToMirror do not exist in the document. -or- Some of the elements cannot be copied, because they belong to different views. -or- The input set of elements contains Sketch members along with other elements or there is no active Sketch edit mode.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Thrown when the elements cannot be moved (e.g. due to some of the elements being pinned).
Remarks
Optionally, copies of the elements can be created prior to the operation and mirroring is then performed on the copies instead of the original elements.
See Also

Reference

ElementTransformUtils Class


ElementTransformUtils.MoveElement Method

ElementTransformUtilsMoveElement Method

Moves one element by a given transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void MoveElement(
    Document document,
    ElementId elementToMove,
    XYZ translation
)
Public Shared Sub MoveElement (
    document As Document,
    elementToMove As ElementId,
    translation As XYZ
)
public:
static void MoveElement(
    Document^ document,
    ElementId^ elementToMove,
    XYZ^ translation
)
static member MoveElement :
        document : Document *
        elementToMove : ElementId *
        translation : XYZ -> unit

Parameters

document Document
The document that owns the elements.
elementToMove ElementId
The id of the element to move.
translation XYZ
The translation vector for the elements.
Exceptions
Exception | Condition
ArgumentException | The element elementToMove does not exist in the document
ArgumentNullException | A non-optional argument was null
InvalidOperationException | If we are not able to move the element (for example, if it is pinned). -or- Move operation failed.
Example
C#
VB
C++
F#
Copy
public void MoveColumn(Autodesk.Revit.DB.Document document, FamilyInstance column)
{
    // get the column current location
    LocationPoint columnLocation = column.Location as LocationPoint;

    XYZ oldPlace = columnLocation.Point;

    // Move the column to new location.
    XYZ newPlace = new XYZ(10, 20, 30);
    ElementTransformUtils.MoveElement(document, column.Id, newPlace);

    // now get the column's new location
    columnLocation = column.Location as LocationPoint;
    XYZ newActual = columnLocation.Point;

    string info = "Original Z location: " + oldPlace.Z +
                  "\nNew Z location: " + newActual.Z;

    TaskDialog.Show("Revit",info);
}
Public Sub MoveColumn(document As Autodesk.Revit.DB.Document, column As FamilyInstance)
    ' get the column current location
    Dim columnLocation As LocationPoint = TryCast(column.Location, LocationPoint)

    Dim oldPlace As XYZ = columnLocation.Point

    ' Move the column to new location.
    Dim newPlace As New XYZ(10, 20, 30)
    ElementTransformUtils.MoveElement(document, column.Id, newPlace)

    ' now get the column's new location
    columnLocation = TryCast(column.Location, LocationPoint)
    Dim newActual As XYZ = columnLocation.Point

    Dim info As String = ("Original Z location: " + oldPlace.Z & vbLf & "New Z location: ") + newActual.Z

    TaskDialog.Show("Revit", info)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

ElementTransformUtils Class


ElementTransformUtils.MoveElements Method

ElementTransformUtilsMoveElements Method

Moves a set of elements by a given transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void MoveElements(
    Document document,
    ICollection<ElementId> elementsToMove,
    XYZ translation
)
Public Shared Sub MoveElements (
    document As Document,
    elementsToMove As ICollection(Of ElementId),
    translation As XYZ
)
public:
static void MoveElements(
    Document^ document,
    ICollection<ElementId^>^ elementsToMove,
    XYZ^ translation
)
static member MoveElements :
        document : Document *
        elementsToMove : ICollection<ElementId> *
        translation : XYZ -> unit

Parameters

document Document
The document that owns the elements.
elementsToMove ICollection ElementId
The set of elements to move.
translation XYZ
The translation vector for the elements.
Exceptions
Exception | Condition
ArgumentException | The given element id set is empty. -or- One or more elements in elementsToMove do not exist in the document.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | If we are not able to move all the elements (for example, if one or more elements is pinned). -or- Move operation failed.
See Also

Reference

ElementTransformUtils Class


ElementTransformUtils.RotateElement Method

ElementTransformUtilsRotateElement Method

Rotates an element about the given axis and angle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void RotateElement(
    Document document,
    ElementId elementToRotate,
    Line axis,
    double angle
)
Public Shared Sub RotateElement (
    document As Document,
    elementToRotate As ElementId,
    axis As Line,
    angle As Double
)
public:
static void RotateElement(
    Document^ document,
    ElementId^ elementToRotate,
    Line^ axis,
    double angle
)
static member RotateElement :
        document : Document *
        elementToRotate : ElementId *
        axis : Line *
        angle : float -> unit

Parameters

document Document
The document that owns the elements.
elementToRotate ElementId
The element to rotate.
axis Line
The axis of rotation.
angle Double
The angle of rotation in radians.
Exceptions
Exception | Condition
ArgumentException | The element elementToRotate does not exist in the document
ArgumentNullException | A non-optional argument was null
Example
C#
VB
C++
F#
Copy
public void RotateColumn(Autodesk.Revit.DB.Document document, Autodesk.Revit.DB.Element element)
{
    XYZ point1 = new XYZ(10, 20, 0);
    XYZ point2 = new XYZ(10, 20, 30);
    Line axis = Line.CreateBound(point1, point2);
    ElementTransformUtils.RotateElement(document, element.Id, axis, Math.PI / 3.0);
}
Public Sub RotateColumn(document As Autodesk.Revit.DB.Document, element As Autodesk.Revit.DB.Element)
    Dim point1 As New XYZ(10, 20, 0)
    Dim point2 As New XYZ(10, 20, 30)
    Dim axis As Line = Line.CreateBound(point1, point2)
    ElementTransformUtils.RotateElement(document, element.Id, axis, Math.PI / 3.0)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

ElementTransformUtils Class


ElementTransformUtils.RotateElements Method

ElementTransformUtilsRotateElements Method

Rotates a set of elements about the given axis and angle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void RotateElements(
    Document document,
    ICollection<ElementId> elementsToRotate,
    Line axis,
    double angle
)
Public Shared Sub RotateElements (
    document As Document,
    elementsToRotate As ICollection(Of ElementId),
    axis As Line,
    angle As Double
)
public:
static void RotateElements(
    Document^ document,
    ICollection<ElementId^>^ elementsToRotate,
    Line^ axis,
    double angle
)
static member RotateElements :
        document : Document *
        elementsToRotate : ICollection<ElementId> *
        axis : Line *
        angle : float -> unit

Parameters

document Document
The document that owns the elements.
elementsToRotate ICollection ElementId
The set of elements to rotate.
axis Line
The axis of rotation.
angle Double
The angle of rotation in radians.
Exceptions
Exception | Condition
ArgumentException | The given element id set is empty. -or- One or more elements in elementsToRotate do not exist in the document.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ElementTransformUtils Class


ElementType Class

Base class for all Types within Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ElementType : Element
Public Class ElementType
    Inherits Element
public ref class ElementType : public Element
type ElementType =
    class
        inherit Element
    end

The ElementType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy
Public property | CanBeDeleted | Determine if this ElementType can be deleted
Public property | CanBeRenamed | Determine if this ElementType can be renamed
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Overrides ElementName)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element.
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type.
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Element types are usually non user visible elements that define instances. For example a wall type is a type that is not visible until an instance of the wall is created.
See Also

Reference

Autodesk.Revit.DB Namespace
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DB.AnalysisConceptualConstructionType
Autodesk.Revit.DB.ArchitectureContinuousRailType
Autodesk.Revit.DB.ArchitectureCutMarkType
Autodesk.Revit.DB.ArchitectureRailingType
Autodesk.Revit.DB.ArchitectureStairsLandingType
Autodesk.Revit.DB.ArchitectureStairsPathType
Autodesk.Revit.DB.ArchitectureStairsRunType
Autodesk.Revit.DB.ArchitectureStairsType
Autodesk.Revit.DB.ArchitectureTopographyLinkType
Autodesk.Revit.DBAssemblyType
Autodesk.Revit.DBBeamSystemType
Autodesk.Revit.DBBrowserOrganization
Autodesk.Revit.DBCADLinkType
Autodesk.Revit.DBDimensionType
Autodesk.Revit.DBDirectShapeType
Autodesk.Revit.DB.ElectricalDistributionSysType
Autodesk.Revit.DB.ElectricalInsulationType
Autodesk.Revit.DB.ElectricalTemperatureRatingType
Autodesk.Revit.DB.ElectricalVoltageType
Autodesk.Revit.DB.ElectricalWireMaterialType
Autodesk.Revit.DB.ElectricalWireType
Autodesk.Revit.DBFabricationPartType
Autodesk.Revit.DBGroupType
Autodesk.Revit.DBHostObjAttributes
Autodesk.Revit.DBImageType
Autodesk.Revit.DBInsertableObject
Autodesk.Revit.DBLineAndTextAttrSymbol
Autodesk.Revit.DB.MechanicalDuctInsulationType
Autodesk.Revit.DB.MechanicalDuctLiningType
Autodesk.Revit.DB.MechanicalMechanicalEquipmentSetType
Autodesk.Revit.DB.MechanicalMEPBuildingConstruction
Autodesk.Revit.DBMEPAnalyticalConnectionType
Autodesk.Revit.DBMEPSystemType
Autodesk.Revit.DBModelTextType
Autodesk.Revit.DBMultiReferenceAnnotationType
Autodesk.Revit.DB.PlumbingFluidType
Autodesk.Revit.DB.PlumbingPipeInsulationType
Autodesk.Revit.DB.PlumbingPipeScheduleType
Autodesk.Revit.DBPointCloudType
Autodesk.Revit.DBRevitLinkType
Autodesk.Revit.DBSiteLocation
Autodesk.Revit.DB.StructureAnalyticalLinkType
Autodesk.Revit.DB.StructureAreaReinforcementType
Autodesk.Revit.DB.StructureEndTreatmentType
Autodesk.Revit.DB.StructureFabricAreaType
Autodesk.Revit.DB.StructureFabricSheetType
Autodesk.Revit.DB.StructureFabricWireType
Autodesk.Revit.DB.StructureLoadTypeBase
Autodesk.Revit.DB.StructurePathReinforcementType
Autodesk.Revit.DB.StructureRebarBarType
Autodesk.Revit.DB.StructureRebarBendingDetailType
Autodesk.Revit.DB.StructureRebarContainerType
Autodesk.Revit.DB.StructureRebarCoverType
Autodesk.Revit.DB.StructureRebarHookType
Autodesk.Revit.DB.StructureRebarShape
Autodesk.Revit.DB.StructureStructuralConnectionApprovalType
Autodesk.Revit.DB.StructureStructuralConnectionHandlerType
Autodesk.Revit.DB.StructureStructuralConnectionType
Autodesk.Revit.DBTilePattern
Autodesk.Revit.DBViewFamilyType


ElementType Properties

The ElementType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy
Public property | CanBeDeleted | Determine if this ElementType can be deleted
Public property | CanBeRenamed | Determine if this ElementType can be renamed
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Overrides ElementName)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

ElementType Class


ElementType.CanBeCopied Property

ElementTypeCanBeCopied Property

Determine if this ElementType can create a copy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanBeCopied { get; }
Public ReadOnly Property CanBeCopied As Boolean
    Get
public:
property bool CanBeCopied {
    bool get ();
}
member CanBeCopied : bool with get

Property Value

Boolean
See Also

Reference

ElementType Class


ElementType.CanBeDeleted Property

ElementTypeCanBeDeleted Property

Determine if this ElementType can be deleted

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanBeDeleted { get; }
Public ReadOnly Property CanBeDeleted As Boolean
    Get
public:
property bool CanBeDeleted {
    bool get ();
}
member CanBeDeleted : bool with get

Property Value

Boolean
See Also

Reference

ElementType Class


ElementType.CanBeRenamed Property

ElementTypeCanBeRenamed Property

Determine if this ElementType can be renamed

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanBeRenamed { get; }
Public ReadOnly Property CanBeRenamed As Boolean
    Get
public:
property bool CanBeRenamed {
    bool get ();
}
member CanBeRenamed : bool with get

Property Value

Boolean
See Also

Reference

ElementType Class


ElementType.FamilyName Property

ElementTypeFamilyName Property

Gets the family name of this element type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FamilyName { get; }
Public ReadOnly Property FamilyName As String
    Get
public:
property String^ FamilyName {
    String^ get ();
}
member FamilyName : string with get

Property Value

String
Remarks
This value is a localized string describing the family in which this ElementType belongs. For family symbols, this will be the name of the associated Family. For system family types, this will be the name used to group related types, such as "Oval Duct" or "Curtain Wall".
See Also

Reference

ElementType Class


ElementType.Name Property

ElementTypeName Property

Set the name for the ElementType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string Name { set; }
Public Overrides WriteOnly Property Name As String
    Set
public:
virtual property String^ Name {
    void set (String^ value) override;
}
abstract Name : string with set
override Name : string with set

Property Value

String
Remarks
This method will assign the element type a new name.
See Also

Reference

ElementType Class


ElementType Methods

The ElementType type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element.
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type.
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ElementType Class


ElementType.Duplicate Method

ElementTypeDuplicate Method

Duplicates an existing element type and assigns it a new name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementType Duplicate(
    string name
)
Public Function Duplicate (
    name As String
) As ElementType
public:
ElementType^ Duplicate(
    String^ name
)
member Duplicate :
        name : string -> ElementType

Parameters

name String
The new name of the element type.

Return Value

ElementType
The duplicated element type.
Exceptions
Exception | Condition
ArgumentException | name is an empty string. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- The element type name was empty, contained invalid characters, or was invalid for the specific element type. -or- The name is already in use for this element type.
ArgumentNullException | A non-optional argument was null
InternalException | Duplicate element type could not be obtained.
InvalidOperationException | The ElementType cannot be copied.
See Also

Reference

ElementType Class


ElementType.GetPreviewImage Method

ElementTypeGetPreviewImage Method

Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Bitmap GetPreviewImage(
    Size size
)
Public Overridable Function GetPreviewImage (
    size As Size
) As Bitmap
public:
virtual Bitmap^ GetPreviewImage(
    Size size
)
abstract GetPreviewImage :
        size : Size -> Bitmap
override GetPreviewImage :
        size : Size -> Bitmap

Parameters

size Size
The width and height of the preview image in pixels.

Return Value

Bitmap
System::Drawing::Bitmap represents the preview image. if there is no preview image.
Exceptions
Exception | Condition
ArgumentException | The width or height of the size is equal or less than zero.
See Also

Reference

ElementType Class


ElementType.GetSimilarTypes Method

ElementTypeGetSimilarTypes Method

Obtains a set of types that are similar to this type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetSimilarTypes()
Public Function GetSimilarTypes As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetSimilarTypes()
member GetSimilarTypes : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
A set of element IDs of types that are similar to this type.
Remarks
Two types are similar if elements that have one type could be assigned the other type.
See Also

Reference

ElementType Class


ElementType.IsSimilarType Method

ElementTypeIsSimilarType Method

Checks if given type is similar to this type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSimilarType(
    ElementId typeId
)
Public Function IsSimilarType (
    typeId As ElementId
) As Boolean
public:
bool IsSimilarType(
    ElementId^ typeId
)
member IsSimilarType :
        typeId : ElementId -> bool

Parameters

typeId ElementId
ElementId of the type to check.

Return Value

Boolean
True if given type is similar to this type, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Two types are similar if elements that have one type could be assigned the other type.
See Also

Reference

ElementType Class


ElementType.IsValidDefaultFamilyType Method

ElementTypeIsValidDefaultFamilyType Method

Identifies if this type is a valid default family type for the given family category id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidDefaultFamilyType(
    ElementId familyCategoryId
)
Public Function IsValidDefaultFamilyType (
    familyCategoryId As ElementId
) As Boolean
public:
bool IsValidDefaultFamilyType(
    ElementId^ familyCategoryId
)
member IsValidDefaultFamilyType :
        familyCategoryId : ElementId -> bool

Parameters

familyCategoryId ElementId
The family category id.

Return Value

Boolean
True if this type is a valid default family type for the given family category id.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ElementType Class


ElementTypeGroup Enumeration

The element type group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ElementTypeGroup
Public Enumeration ElementTypeGroup
public enum class ElementTypeGroup
type ElementTypeGroup
Members
Member name | Value | Description
RailingsTypeForStairs | 0 | The railings type for stairs.
RailingsTypeForRamps | 1 | The railings type for ramps.
WallType | 2 | The wall type.
RoofType | 3 | The roof type.
FloorType | 4 | The floor type.
FootingSlabType | 5 | The footing slab type.
CeilingType | 6 | The ceiling type.
StairsBySketchType | 7 | The stairs by sketch type.
GridType | 8 | The Grid Type.
LevelType | 9 | The Level Type
LinearDimensionType | 10 | The linear dimension type.
SpotElevationType | 11 | The spot elevation type.
TextNoteType | 12 | The text note type.
TagNoteType | 13 | The tag note type.
ModelTextType | 14 | The model text type.
CorniceType | 16 | The cornice type.
RevealType | 17 | The reveal type.
ViewportType | 19 | The viewport type.
ReferenceViewerType | 21 | The reference viewer type.
CalloutType | 22 | The callout view type.
RampType | 28 | The ramp type.
StairsRailingType | 30 | The stairs railing type.
ModelGroupType | 32 | The model group type.
DetailGroupType | 33 | The detail group type.
AttachedDetailGroupType | 34 | The attached detail group type.
FilledRegionType | 35 | The filled region type.
RadialDimensionType | 36 | The radial dimension type.
AngularDimensionType | 37 | The angular dimension type.
ArcLengthDimensionType | 38 | The arc length dimension type.
BuildingPadType | 43 | The building pad type.
DecalType | 45 | The decal type.
ContourLabelingType | 46 | The contour labeling type.
RoofSoffitType | 47 | The roof soffit type.
FasciaType | 48 | The fascial type.
GutterType | 49 | The gutter type.
EdgeSlabType | 50 | The slab edge type.
RepeatingDetailType | 53 | The repeating detail type.
BeamSystemType | 54 | The beam system type.
CurtainSystemType | 58 | The curtain system type.
ViewType3D | 62 | The 3D view type.
ViewTypeWalkthrough | 63 | The walkthrough view type.
ViewTypeRendering | 64 | The rendering view type.
ViewTypeSchedule | 65 | The schedule view type.
ViewTypeLegend | 66 | The legend view type.
ViewTypeCostReport | 67 | The cost report view type.
ViewTypeSheet | 68 | The sheet view type.
ViewTypeDrafting | 69 | The drafting view type.
ViewTypeStructuralPlan | 70 | The structural plan view type.
ViewTypeFloorPlan | 71 | The floor plan view type.
ViewTypeCeilingPlan | 72 | The ceiling plan view type.
ViewTypeSection | 73 | The section view type.
ViewTypeDetailView | 74 | The detail view type.
ViewTypeElevation | 75 | The elevation view type.
ViewTypeStructuralElevation | 76 | The structrual elevation view type.
ViewTypeLoadsReport | 78 | The loads report view type.
ViewTypePressureLossReport | 79 | The pressure loss report view type.
ViewTypePanelSchedule | 80 | The panel schedule view type.
AreaLoadType | 82 | The area load type.
LineLoadType | 83 | The line load type.
PointLoadType | 84 | The point load type.
RebarBarType | 85 | The rebar bar type.
AreaReinforcementType | 87 | Area reinforcement type.
PathReinforcementType | 88 | Path reinforcement type.
FabricAreaType | 90 | The fabric area type.
FabricSheetType | 91 | The fabric sheet type.
DuctType | 97 | The duct type.
FlexDuctType | 98 | The flex duct type.
PipeType | 100 | The pipe type.
FlexPipeType | 101 | The flex pipe type.
WireType | 102 | The wire type.
SpotCoordinateType | 106 | The spot coordinate type.
ViewTypeGraphScheduleColumn | 107 | The graph schedule column view type.
SpotSlopeType | 108 | The spot slope type.
WallFoundationType | 109 | The wall foundation type.
PipeInsulationType | 119 | The pipe insulation type.
DuctInsulationType | 120 | The duct insulation type.
DuctLiningType | 121 | The duct lining type.
CableTrayType | 122 | The cable tray type.
ConduitType | 123 | The conduilt type.
DiameterDimensionType | 126 | The diameter dimension type.
StairsType | 127 | The stairs type.
AnalyticalLinkType | 136 | The analytical link type.
MultiReferenceAnnotationType | 140 | The multi-reference annotation type.
ColorFillType | 143 | The color fill legend type.
RebarContainerType | 144 | The Rebar Container Type.
StructuralConnectionHandlerType | 145 | The Structural Connection Handler Type.
EndTreatmentType | 146 | The End Treatment Type.
ViewTypeSystemsAnalysisReport | 150 | The system analysis report view type.
AlignmentStationLabelType | 151 | The alignment station label type.
BendingDetail | 154 | The bending detail type.
SchematicBendingDetail | 155 | The schematic bending detail type.
RebarSpliceType | 156 | The rebar splice type.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ElementWorksetFilter Class

A filter used to match elements which reside in a given workset.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementQuickFilter
Autodesk.Revit.DBElementWorksetFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ElementWorksetFilter : ElementQuickFilter
Public Class ElementWorksetFilter
    Inherits ElementQuickFilter
public ref class ElementWorksetFilter : public ElementQuickFilter
type ElementWorksetFilter =
    class
        inherit ElementQuickFilter
    end

The ElementWorksetFilter type exposes the following members.

Constructors
 | Name | Description
Public method | ElementWorksetFilter(WorksetId) | Constructs a new instance of a filter to match elements in a given workset.
Public method | ElementWorksetFilter(WorksetId, Boolean) | Constructs a new instance of a filter to match elements in a given workset.
Top
Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Public property | WorksetId | The workset id.
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This filter is a quick filter.
Example
C#
VB
C++
F#
Copy
public void WorksetElements(Document doc, Workset workset)
{
    // filter all elements that belong to the given workset
    FilteredElementCollector elementCollector = new FilteredElementCollector(doc);
    ElementWorksetFilter elementWorksetFilter = new ElementWorksetFilter(workset.Id);
    ICollection<Element> worksetElemsfounds = elementCollector.WherePasses(elementWorksetFilter).ToElements();

    // how many elements were found?
    int elementsCount = worksetElemsfounds.Count;
    String message = "Element count : " + elementsCount;

    // Get name and/or Id of the elements that pass the given filter and show a few of them
    int count = 5;  // show info for 5 elements only
    foreach (Element ele in worksetElemsfounds)
    {
        if (null != ele)
        {
           message += "\nElementId : " + ele.Id;
           message += ", Element Name : " + ele.Name;

          if (0 == --count)
              break;
        }
    }

    Autodesk.Revit.UI.TaskDialog.Show("ElementsOfWorkset", message);
}
Public Sub WorksetElements(doc As Document, workset As Workset)
    ' filter all elements that belong to the given workset
    Dim elementCollector As New FilteredElementCollector(doc)
    Dim elementWorksetFilter As New ElementWorksetFilter(workset.Id)
    Dim worksetElemsfounds As ICollection(Of Element) = elementCollector.WherePasses(elementWorksetFilter).ToElements()

    ' how many elements were found?
    Dim elementsCount As Integer = worksetElemsfounds.Count
    Dim message As [String] = "Element count : " + elementsCount

    ' Get name and/or Id of the elements that pass the given filter and show a few of them
    Dim count As Integer = 5
    ' show info for 5 elements only
    For Each ele As Element In worksetElemsfounds
        If ele IsNot Nothing Then
            message += vbLf & "ElementId : " + ele.Id.ToString
            message += ", Element Name : " + ele.Name

            If 0 = System.Threading.Interlocked.Decrement(count) Then
                Exit For
            End If
        End If
    Next

    Autodesk.Revit.UI.TaskDialog.Show("ElementsOfWorkset", message)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ElementWorksetFilter Constructor

Overload List
 | Name | Description
Public method | ElementWorksetFilter(WorksetId) | Constructs a new instance of a filter to match elements in a given workset.
Public method | ElementWorksetFilter(WorksetId, Boolean) | Constructs a new instance of a filter to match elements in a given workset.
Top
See Also

Reference

ElementWorksetFilter Class


ElementWorksetFilter(WorksetId) Constructor

Constructs a new instance of a filter to match elements in a given workset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementWorksetFilter(
    WorksetId worksetId
)
Public Sub New (
    worksetId As WorksetId
)
public:
ElementWorksetFilter(
    WorksetId^ worksetId
)
new :
        worksetId : WorksetId -> ElementWorksetFilter

Parameters

worksetId WorksetId
The workset id to match.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ElementWorksetFilter Class
ElementWorksetFilter Overload


ElementWorksetFilter(WorksetId, Boolean) Constructor

Constructs a new instance of a filter to match elements in a given workset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementWorksetFilter(
    WorksetId worksetId,
    bool inverted
)
Public Sub New (
    worksetId As WorksetId,
    inverted As Boolean
)
public:
ElementWorksetFilter(
    WorksetId^ worksetId,
    bool inverted
)
new :
        worksetId : WorksetId *
        inverted : bool -> ElementWorksetFilter

Parameters

worksetId WorksetId
The workset id to match.
inverted Boolean
True if the filter should match all elements which are not in the given workset.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ElementWorksetFilter Class
ElementWorksetFilter Overload


ElementWorksetFilter Properties

The ElementWorksetFilter type exposes the following members.

Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Public property | WorksetId | The workset id.
Top
See Also

Reference

ElementWorksetFilter Class


ElementWorksetFilter.WorksetId Property

ElementWorksetFilterWorksetId Property

The workset id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WorksetId WorksetId { get; }
Public ReadOnly Property WorksetId As WorksetId
    Get
public:
property WorksetId^ WorksetId {
    WorksetId^ get ();
}
member WorksetId : WorksetId with get

Property Value

WorksetId
See Also

Reference

ElementWorksetFilter Class


ElementWorksetFilter Methods

The ElementWorksetFilter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ElementWorksetFilter Class


ElevationMarker Class

ElevationMarkers either host elevation ViewSection views or view references.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElevationMarker

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ElevationMarker : Element
Public Class ElevationMarker
    Inherits Element
public ref class ElevationMarker : public Element
type ElevationMarker =
    class
        inherit Element
    end

The ElevationMarker type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CurrentViewCount | The current number of views hosted by this ElevationMarker.
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsReference | Indicates if this is a reference ElevationMarker. Only reference elevations can be hosted by reference ElevationMarkers.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | MaximumViewCount | The maximum number of views that can be hosted by this ElevationMarker.
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | CreateElevation | Creates a new elevation ViewSection on the ElevationMarker at the desired index.
 | CreateElevationMarker | Creates a new ElevationMarker.
Public method | CreateReferenceElevation | Creates a reference elevation on the ElevationMarker at the desired index.
 | CreateReferenceElevationMarker | Creates a new ElevationMarker.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetViewId | Returns the ViewSection id for the index of the ElevationMarker.
Public method | HasElevations | Returns true if the ElevationMarker has at least one elevation view, false otherwise.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsAvailableIndex | Returns true if a new elevation ViewSection can be placed at %index%, returns false otherwise.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
ElevationMarkers store the ViewFamilyType which will be used by all elevations hosted on the ElevationMarker. The orientation of an ElevationMarker is determined by the orientation of the views it hosts. You can check the orientation of any view by getting View.ViewDirection. To reorient the ElevationMarker and all of the views it hosts, call ElementTransformUtils.RotateElement with the ElevationMarker as an argument.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ElevationMarker Properties

The ElevationMarker type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CurrentViewCount | The current number of views hosted by this ElevationMarker.
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsReference | Indicates if this is a reference ElevationMarker. Only reference elevations can be hosted by reference ElevationMarkers.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | MaximumViewCount | The maximum number of views that can be hosted by this ElevationMarker.
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

ElevationMarker Class


ElevationMarker.CurrentViewCount Property

ElevationMarkerCurrentViewCount Property

The current number of views hosted by this ElevationMarker.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int CurrentViewCount { get; }
Public ReadOnly Property CurrentViewCount As Integer
    Get
public:
property int CurrentViewCount {
    int get ();
}
member CurrentViewCount : int with get

Property Value

Int32
See Also

Reference

ElevationMarker Class


ElevationMarker.IsReference Property

ElevationMarkerIsReference Property

Indicates if this is a reference ElevationMarker. Only reference elevations can be hosted by reference ElevationMarkers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsReference { get; }
Public ReadOnly Property IsReference As Boolean
    Get
public:
property bool IsReference {
    bool get ();
}
member IsReference : bool with get

Property Value

Boolean
See Also

Reference

ElevationMarker Class


ElevationMarker.MaximumViewCount Property

ElevationMarkerMaximumViewCount Property

The maximum number of views that can be hosted by this ElevationMarker.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int MaximumViewCount { get; }
Public ReadOnly Property MaximumViewCount As Integer
    Get
public:
property int MaximumViewCount {
    int get ();
}
member MaximumViewCount : int with get

Property Value

Int32
See Also

Reference

ElevationMarker Class


ElevationMarker Methods

The ElevationMarker type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | CreateElevation | Creates a new elevation ViewSection on the ElevationMarker at the desired index.
 | CreateElevationMarker | Creates a new ElevationMarker.
Public method | CreateReferenceElevation | Creates a reference elevation on the ElevationMarker at the desired index.
 | CreateReferenceElevationMarker | Creates a new ElevationMarker.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetViewId | Returns the ViewSection id for the index of the ElevationMarker.
Public method | HasElevations | Returns true if the ElevationMarker has at least one elevation view, false otherwise.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsAvailableIndex | Returns true if a new elevation ViewSection can be placed at %index%, returns false otherwise.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ElevationMarker Class


ElevationMarker.CreateElevation Method

ElevationMarkerCreateElevation Method

Creates a new elevation ViewSection on the ElevationMarker at the desired index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ViewSection CreateElevation(
    Document document,
    ElementId viewPlanId,
    int index
)
Public Function CreateElevation (
    document As Document,
    viewPlanId As ElementId,
    index As Integer
) As ViewSection
public:
ViewSection^ CreateElevation(
    Document^ document,
    ElementId^ viewPlanId,
    int index
)
member CreateElevation :
        document : Document *
        viewPlanId : ElementId *
        index : int -> ViewSection

Parameters

document Document
The document to which the new elevation ViewSection will be added.
viewPlanId ElementId
The id of a ViewPlan in which the ElevationMarker is visible. The new elevation ViewSection will derive its extents and inherit settings from the ViewPlan.
index Int32
The index on the ElevationMarker where the new elevation ViewSection will be placed. The index on the ElevationMarker must be valid and unused. View direction is determined by the index.

Return Value

ViewSection
The new elevation ViewSection.
Exceptions
Exception | Condition
ArgumentException | The ElementId viewPlanId does not correspond to a ViewPlan. -or- index is occupied or out of range. -or- Elevation view creation is not allowed in this family.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Only reference elevations can be hosted on this ElevationMarker.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
The ViewFamilyType for the new elevation ViewSection is inherited from the ElevationMarker. The new elevation ViewSection will receive a unique view name.
See Also

Reference

ElevationMarker Class


ElevationMarker.CreateElevationMarker Method

ElevationMarkerCreateElevationMarker Method

Creates a new ElevationMarker.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ElevationMarker CreateElevationMarker(
    Document document,
    ElementId viewFamilyTypeId,
    XYZ origin,
    int initialViewScale
)
Public Shared Function CreateElevationMarker (
    document As Document,
    viewFamilyTypeId As ElementId,
    origin As XYZ,
    initialViewScale As Integer
) As ElevationMarker
public:
static ElevationMarker^ CreateElevationMarker(
    Document^ document,
    ElementId^ viewFamilyTypeId,
    XYZ^ origin,
    int initialViewScale
)
static member CreateElevationMarker :
        document : Document *
        viewFamilyTypeId : ElementId *
        origin : XYZ *
        initialViewScale : int -> ElevationMarker

Parameters

document Document
The document to which the new ElevationMarker will be added.
viewFamilyTypeId ElementId
This ViewFamilyType will be used by all elevations hosted on the new ElevationMarker.
origin XYZ
The desired origin for the ElevationMarker.
initialViewScale Int32
This view scale will be automatically applied to new elevations created on the ElevationMarker. The scale is the ratio of true model size to paper size.

Return Value

ElevationMarker
The new ElevationMarker.
Exceptions
Exception | Condition
ArgumentException | This view family type is not appropriate for ElevationMarkers. -or- The denominator X of the view scale 1/X must be in the range 1 to 24,000. -or- Elevation view creation is not allowed in this family.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ElevationMarker Class


ElevationMarker.CreateReferenceElevation Method

ElevationMarkerCreateReferenceElevation Method

Creates a reference elevation on the ElevationMarker at the desired index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void CreateReferenceElevation(
    Document document,
    int index,
    ElementId viewIdToReference
)
Public Sub CreateReferenceElevation (
    document As Document,
    index As Integer,
    viewIdToReference As ElementId
)
public:
void CreateReferenceElevation(
    Document^ document,
    int index,
    ElementId^ viewIdToReference
)
member CreateReferenceElevation :
        document : Document *
        index : int *
        viewIdToReference : ElementId -> unit

Parameters

document Document
The document to which the new reference elevation will be added.
index Int32
The index on the ElevationMarker where the reference elevation will be placed.
viewIdToReference ElementId
The view which will be referenced.
Exceptions
Exception | Condition
ArgumentException | The ElementId viewIdToReference does not correspond to a View. -or- This view cannot be referenced by elevations. -or- index is occupied or out of range. -or- Elevation view creation is not allowed in this family.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Only reference elevations can be hosted on this ElevationMarker.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
See Also

Reference

ElevationMarker Class


ElevationMarker.CreateReferenceElevationMarker Method

ElevationMarkerCreateReferenceElevationMarker Method

Creates a new ElevationMarker.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ElevationMarker CreateReferenceElevationMarker(
    Document document,
    ElementId viewFamilyTypeId,
    XYZ origin,
    ElementId viewPlanId
)
Public Shared Function CreateReferenceElevationMarker (
    document As Document,
    viewFamilyTypeId As ElementId,
    origin As XYZ,
    viewPlanId As ElementId
) As ElevationMarker
public:
static ElevationMarker^ CreateReferenceElevationMarker(
    Document^ document,
    ElementId^ viewFamilyTypeId,
    XYZ^ origin,
    ElementId^ viewPlanId
)
static member CreateReferenceElevationMarker :
        document : Document *
        viewFamilyTypeId : ElementId *
        origin : XYZ *
        viewPlanId : ElementId -> ElevationMarker

Parameters

document Document
The document to which the new ElevationMarker will be added.
viewFamilyTypeId ElementId
This ViewFamilyType will be used by all elevations hosted on the new ElevationMarker.
origin XYZ
The desired origin for the ElevationMarker.
viewPlanId ElementId
The ViewPlan in which the reference ElevationMarker will appear. Reference ElevationMarkers only appear in one view.

Return Value

ElevationMarker
The new ElevationMarker.
Exceptions
Exception | Condition
ArgumentException | The ElementId viewPlanId does not correspond to a ViewPlan. -or- This view family type is not appropriate for ElevationMarkers. -or- Elevation view creation is not allowed in this family.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ElevationMarker Class


ElevationMarker.GetViewId Method

ElevationMarkerGetViewId Method

Returns the ViewSection id for the index of the ElevationMarker.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GetViewId(
    int index
)
Public Function GetViewId (
    index As Integer
) As ElementId
public:
ElementId^ GetViewId(
    int index
)
member GetViewId :
        index : int -> ElementId

Parameters

index Int32
The index of the ElevationMarker for which a ViewSection id will be returned.

Return Value

ElementId
ViewSection id of the view at the ElevationMarker index, invalid element id otherwise.
Exceptions
Exception | Condition
ArgumentException | The index index is out of range for this ElevationMarker.
See Also

Reference

ElevationMarker Class


ElevationMarker.HasElevations Method

ElevationMarkerHasElevations Method

Returns true if the ElevationMarker has at least one elevation view, false otherwise.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasElevations()
Public Function HasElevations As Boolean
public:
bool HasElevations()
member HasElevations : unit -> bool

Return Value

Boolean
True if the ElevationMarker has at least one elevation view, false otherwise.
See Also

Reference

ElevationMarker Class


ElevationMarker.IsAvailableIndex Method

ElevationMarkerIsAvailableIndex Method

Returns true if a new elevation ViewSection can be placed at %index%, returns false otherwise.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsAvailableIndex(
    int index
)
Public Function IsAvailableIndex (
    index As Integer
) As Boolean
public:
bool IsAvailableIndex(
    int index
)
member IsAvailableIndex :
        index : int -> bool

Parameters

index Int32
The index of the ElevationMarker which will be checked.

Return Value

Boolean
True if an elevation can be created at %index%, false otherwise.
Remarks
False will be returned if the %index% is already occupied or if %index% is out of range for the ElevationMarker.
See Also

Reference

ElevationMarker Class


Ellipse Class

A whole or partial ellipse.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGeometryObject
Autodesk.Revit.DBCurve
Autodesk.Revit.DBEllipse

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Ellipse : Curve
Public Class Ellipse
    Inherits Curve
public ref class Ellipse : public Curve
type Ellipse =
    class
        inherit Curve
    end

The Ellipse type exposes the following members.

Properties
 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve)
Public property | Center | Returns the center of the ellipse.
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve)
Public property | IsClosed | Describes whether the curve is closed. (Inherited from Curve)
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject)
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Length | The exact length of the curve. (Inherited from Curve)
Public property | Normal | Returns the normal to the plane in which the ellipse is defined.
Public property | Period | The period of this curve. (Inherited from Curve)
Public property | RadiusX | Returns the X vector radius of the ellipse.
Public property | RadiusY | Returns the Y vector radius of the ellipse.
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve)
Public property | Visibility | The visibility. (Inherited from GeometryObject)
Public property | XDirection | The X direction.
Public property | YDirection | The Y direction.
Top
Methods
 | Name | Description
Public method | Clone | Returns a copy of this curve. (Inherited from Curve)
Public method | ComputeClosestPoints | Find the closest points between two curves. Closest points mean closest pairs of points, each pair consisting of a point on this, say P1, and a point on other curve, say P2. P1 and P2 are closest locally. Each pairs of closest points will be represented by the corresponding parameter values with respect to the two curves and the 3d points. A closest pair is also known as a pair of critical points of the distance function between points of the two curves. If the input parameter returnAllCriticalPoints is set to false, then the function will return only pairs with minimum distance. (Inherited from Curve)
Public method | ComputeDerivatives | Returns the vectors describing the curve at the specified parameter. (Inherited from Curve)
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve)
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve)
 | CreateCurve | Creates a new geometric ellipse or elliptical arc object.
Public method | CreateOffset | Creates a new curve that is an offset of the existing curve. (Inherited from Curve)
Public method | CreateReversed | Creates a new curve with the opposite orientation of the existing curve. (Inherited from Curve)
Public method | CreateTransformed | Crates a new instance of a curve as a transformation of this curve. (Inherited from Curve)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject)
Public method | Evaluate | Evaluates and returns the point that matches a parameter along the curve. (Inherited from Curve)
Public method | GetEndParameter | Returns the raw parameter value at the start or end of this curve. (Inherited from Curve)
Public method | GetEndPoint | Returns the 3D point at the start or end of this curve. (Inherited from Curve)
Public method | GetEndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve)
Public method | Intersect(Curve, IntersectionResultArray) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve)
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve)
Public method | IsInside(Double, Int32) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve)
Public method | MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve)
Public method | MakeUnbound | Makes this curve unbound. (Inherited from Curve)
Public method | Project | Projects the specified point on this curve. (Inherited from Curve)
Public method | SetGraphicsStyleId | Sets the graphics style id for this curve. (Inherited from Curve)
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Ellipse Properties

The Ellipse type exposes the following members.

Properties
 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve)
Public property | Center | Returns the center of the ellipse.
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve)
Public property | IsClosed | Describes whether the curve is closed. (Inherited from Curve)
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject)
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Length | The exact length of the curve. (Inherited from Curve)
Public property | Normal | Returns the normal to the plane in which the ellipse is defined.
Public property | Period | The period of this curve. (Inherited from Curve)
Public property | RadiusX | Returns the X vector radius of the ellipse.
Public property | RadiusY | Returns the Y vector radius of the ellipse.
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve)
Public property | Visibility | The visibility. (Inherited from GeometryObject)
Public property | XDirection | The X direction.
Public property | YDirection | The Y direction.
Top
See Also

Reference

Ellipse Class


Ellipse.Center Property

EllipseCenter Property

Returns the center of the ellipse.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Center { get; }
Public ReadOnly Property Center As XYZ
    Get
public:
property XYZ^ Center {
    XYZ^ get ();
}
member Center : XYZ with get

Property Value

XYZ
See Also

Reference

Ellipse Class


Ellipse.Normal Property

EllipseNormal Property

Returns the normal to the plane in which the ellipse is defined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Normal { get; }
Public ReadOnly Property Normal As XYZ
    Get
public:
property XYZ^ Normal {
    XYZ^ get ();
}
member Normal : XYZ with get

Property Value

XYZ
See Also

Reference

Ellipse Class


Ellipse.RadiusX Property

EllipseRadiusX Property

Returns the X vector radius of the ellipse.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double RadiusX { get; }
Public ReadOnly Property RadiusX As Double
    Get
public:
property double RadiusX {
    double get ();
}
member RadiusX : float with get

Property Value

Double
See Also

Reference

Ellipse Class


Ellipse.RadiusY Property

EllipseRadiusY Property

Returns the Y vector radius of the ellipse.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double RadiusY { get; }
Public ReadOnly Property RadiusY As Double
    Get
public:
property double RadiusY {
    double get ();
}
member RadiusY : float with get

Property Value

Double
See Also

Reference

Ellipse Class


Ellipse.XDirection Property

EllipseXDirection Property

The X direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ XDirection { get; }
Public ReadOnly Property XDirection As XYZ
    Get
public:
property XYZ^ XDirection {
    XYZ^ get ();
}
member XDirection : XYZ with get

Property Value

XYZ
See Also

Reference

Ellipse Class


Ellipse.YDirection Property

EllipseYDirection Property

The Y direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ YDirection { get; }
Public ReadOnly Property YDirection As XYZ
    Get
public:
property XYZ^ YDirection {
    XYZ^ get ();
}
member YDirection : XYZ with get

Property Value

XYZ
See Also

Reference

Ellipse Class


Ellipse Methods

The Ellipse type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Returns a copy of this curve. (Inherited from Curve)
Public method | ComputeClosestPoints | Find the closest points between two curves. Closest points mean closest pairs of points, each pair consisting of a point on this, say P1, and a point on other curve, say P2. P1 and P2 are closest locally. Each pairs of closest points will be represented by the corresponding parameter values with respect to the two curves and the 3d points. A closest pair is also known as a pair of critical points of the distance function between points of the two curves. If the input parameter returnAllCriticalPoints is set to false, then the function will return only pairs with minimum distance. (Inherited from Curve)
Public method | ComputeDerivatives | Returns the vectors describing the curve at the specified parameter. (Inherited from Curve)
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve)
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve)
 | CreateCurve | Creates a new geometric ellipse or elliptical arc object.
Public method | CreateOffset | Creates a new curve that is an offset of the existing curve. (Inherited from Curve)
Public method | CreateReversed | Creates a new curve with the opposite orientation of the existing curve. (Inherited from Curve)
Public method | CreateTransformed | Crates a new instance of a curve as a transformation of this curve. (Inherited from Curve)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject)
Public method | Evaluate | Evaluates and returns the point that matches a parameter along the curve. (Inherited from Curve)
Public method | GetEndParameter | Returns the raw parameter value at the start or end of this curve. (Inherited from Curve)
Public method | GetEndPoint | Returns the 3D point at the start or end of this curve. (Inherited from Curve)
Public method | GetEndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve)
Public method | Intersect(Curve, IntersectionResultArray) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve)
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve)
Public method | IsInside(Double, Int32) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve)
Public method | MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve)
Public method | MakeUnbound | Makes this curve unbound. (Inherited from Curve)
Public method | Project | Projects the specified point on this curve. (Inherited from Curve)
Public method | SetGraphicsStyleId | Sets the graphics style id for this curve. (Inherited from Curve)
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Ellipse Class


Ellipse.CreateCurve Method

EllipseCreateCurve Method

Creates a new geometric ellipse or elliptical arc object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Curve CreateCurve(
    XYZ center,
    double xRadius,
    double yRadius,
    XYZ xAxis,
    XYZ yAxis,
    double startParameter,
    double endParameter
)
Public Shared Function CreateCurve (
    center As XYZ,
    xRadius As Double,
    yRadius As Double,
    xAxis As XYZ,
    yAxis As XYZ,
    startParameter As Double,
    endParameter As Double
) As Curve
public:
static Curve^ CreateCurve(
    XYZ^ center,
    double xRadius,
    double yRadius,
    XYZ^ xAxis,
    XYZ^ yAxis,
    double startParameter,
    double endParameter
)
static member CreateCurve :
        center : XYZ *
        xRadius : float *
        yRadius : float *
        xAxis : XYZ *
        yAxis : XYZ *
        startParameter : float *
        endParameter : float -> Curve

Parameters

center XYZ
The center.
xRadius Double
The x vector radius of the ellipse.
yRadius Double
The y vector radius of the ellipse.
xAxis XYZ
The x axis to define the ellipse plane. Must be normalized.
yAxis XYZ
The y axis to define the ellipse plane. Must be normalized.
startParameter Double
The raw parameter value at the start of the ellipse.
endParameter Double
The raw parameter value at the end of the ellipse.

Return Value

Curve
The new ellipse or elliptical arc.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was NULL
ArgumentOutOfRangeException | The given value for xRadius must be greater than 0 and no more than 30000 feet. -or- The given value for yRadius must be greater than 0 and no more than 30000 feet. -or- xAxis is not length 1.0. -or- yAxis is not length 1.0.
ArgumentsInconsistentException | The vectors xAxis and yAxis are not perpendicular. -or- Start parameter must be less than end parameter. -or- Curve length is too small for Revit's tolerance (as identified by Application.ShortCurveTolerance).
Remarks
If the angle range is equal to or greater than 2 * PI, the curve will be automatically converted to an unbounded ellipse. If xRadius and yRadius are almost equal, the curve will be returned as an arc.
See Also

Reference

Ellipse Class


EndCapCondition Enumeration

Used by CompoundStructure to describe which shell layers participate in end wrapping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum EndCapCondition
Public Enumeration EndCapCondition
public enum class EndCapCondition
type EndCapCondition
Members
Member name | Value | Description
None | 0 | None of the shell layers participate in end wrapping.
Exterior | 1 | Only the exterior shell layers participate in end wrapping.
Interior | 2 | Only the interior shell layers participate in end wrapping.
NoEndCap | 3 | No end wrapping ability. Floors and roofs must use this enum value.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


EntryAndSchemeConsistency Enumeration

Enumeration used to specify why an entry is inconsistent with a scheme or another entry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum EntryAndSchemeConsistency
Public Enumeration EntryAndSchemeConsistency
public enum class EntryAndSchemeConsistency
type EntryAndSchemeConsistency
Members
Member name | Value | Description
Consistent | 0 | The scheme entry can be applied to the scheme.
InconsistentStorageType | 1 | The type of value stored in the entry is different from the type of the scheme parameter.
ValueOutOfRange | 2 | The value stored in the entry is out of the scheme parameter range.
ValueDuplicated | 3 | There already exists another entry with the same value.
InvalidFillPatternId | 4 | The fill pattern id is not valid.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


EvaluatedParameter Class

Hold the evaluated ParameterValue and Definition of a parameter.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBEvaluatedParameter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class EvaluatedParameter : IDisposable
Public Class EvaluatedParameter
    Implements IDisposable
public ref class EvaluatedParameter : IDisposable
type EvaluatedParameter =
    class
        interface IDisposable
    end

The EvaluatedParameter type exposes the following members.

Properties
 | Name | Description
Public property | Definition | Definition of the parameter.
Public property | HasValue | This property is true when the parameter value was successfully obtained, false otherwise.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | StorageType | The storage type describes the type that is used internally within the parameter to store its value.
Public property | Value | Evaluated value of the parameter.
Top
Methods
 | Name | Description
Public method | AsValueString(Document) | Get the parameter value as a string with units.
Public method | AsValueString(Document, FormatOptions) | Get the parameter value as a string with units.
Public method | Dispose | Releases all resources used by the EvaluatedParameter
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


EvaluatedParameter Properties

The EvaluatedParameter type exposes the following members.

Properties
 | Name | Description
Public property | Definition | Definition of the parameter.
Public property | HasValue | This property is true when the parameter value was successfully obtained, false otherwise.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | StorageType | The storage type describes the type that is used internally within the parameter to store its value.
Public property | Value | Evaluated value of the parameter.
Top
See Also

Reference

EvaluatedParameter Class


EvaluatedParameter.Definition Property

EvaluatedParameterDefinition Property

Definition of the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public InternalDefinition Definition { get; }
Public ReadOnly Property Definition As InternalDefinition
    Get
public:
property InternalDefinition^ Definition {
    InternalDefinition^ get ();
}
member Definition : InternalDefinition with get

Property Value

InternalDefinition
See Also

Reference

EvaluatedParameter Class


EvaluatedParameter.HasValue Property

EvaluatedParameterHasValue Property

This property is true when the parameter value was successfully obtained, false otherwise.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasValue { get; }
Public ReadOnly Property HasValue As Boolean
    Get
public:
property bool HasValue {
    bool get ();
}
member HasValue : bool with get

Property Value

Boolean
See Also

Reference

EvaluatedParameter Class


EvaluatedParameter.IsValidObject Property

EvaluatedParameterIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

EvaluatedParameter Class


EvaluatedParameter.StorageType Property

EvaluatedParameterStorageType Property

The storage type describes the type that is used internally within the parameter to store its value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public StorageType StorageType { get; }
Public ReadOnly Property StorageType As StorageType
    Get
public:
property StorageType StorageType {
    StorageType get ();
}
member StorageType : StorageType with get

Property Value

StorageType
Remarks
The property will return one of the following possibilities: String, Integer, Double or ElementId. Based on the value of this property the correct access and set methods should be used to retrieve and set the parameter's data value.
See Also

Reference

EvaluatedParameter Class


EvaluatedParameter.Value Property

EvaluatedParameterValue Property

Evaluated value of the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ParameterValue Value { get; }
Public ReadOnly Property Value As ParameterValue
    Get
public:
property ParameterValue^ Value {
    ParameterValue^ get ();
}
member Value : ParameterValue with get

Property Value

ParameterValue
See Also

Reference

EvaluatedParameter Class


EvaluatedParameter Methods

The EvaluatedParameter type exposes the following members.

Methods
 | Name | Description
Public method | AsValueString(Document) | Get the parameter value as a string with units.
Public method | AsValueString(Document, FormatOptions) | Get the parameter value as a string with units.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

EvaluatedParameter Class


EvaluatedParameter.AsValueString Method

EvaluatedParameterAsValueString Method

Overload List
 | Name | Description
Public method | AsValueString(Document) | Get the parameter value as a string with units.
Public method | AsValueString(Document, FormatOptions) | Get the parameter value as a string with units.
Top
See Also

Reference

EvaluatedParameter Class


EvaluatedParameter.AsValueString(Document) Method

EvaluatedParameterAsValueString(Document) Method

Get the parameter value as a string with units.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string AsValueString(
    Document doc
)
Public Function AsValueString (
    doc As Document
) As String
public:
String^ AsValueString(
    Document^ doc
)
member AsValueString :
        doc : Document -> string

Parameters

doc Document
The document to be used to obtain information about the parameter.

Return Value

String
The string that represents the parameter value.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

EvaluatedParameter Class
AsValueString Overload


EvaluatedParameter.AsValueString(Document, FormatOptions) Method

EvaluatedParameterAsValueString(Document, FormatOptions) Method

Get the parameter value as a string with units.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string AsValueString(
    Document doc,
    FormatOptions options
)
Public Function AsValueString (
    doc As Document,
    options As FormatOptions
) As String
public:
String^ AsValueString(
    Document^ doc,
    FormatOptions^ options
)
member AsValueString :
        doc : Document *
        options : FormatOptions -> string

Parameters

doc Document
The document to be used to obtain information about the parameter.
options FormatOptions
Options for formatting the string.

Return Value

String
The string that represents the parameter value.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

EvaluatedParameter Class
AsValueString Overload


EvaluatedParameter.Dispose Method

EvaluatedParameterDispose Method

Releases all resources used by the EvaluatedParameter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

EvaluatedParameter Class


ExclusionFilter Class

A filter used to exclude a set of elements automatically.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementQuickFilter
Autodesk.Revit.DBExclusionFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExclusionFilter : ElementQuickFilter
Public Class ExclusionFilter
    Inherits ElementQuickFilter
public ref class ExclusionFilter : public ElementQuickFilter
type ExclusionFilter =
    class
        inherit ElementQuickFilter
    end

The ExclusionFilter type exposes the following members.

Constructors
 | Name | Description
Public method | ExclusionFilter | Constructs a new instance of a filter to exclude elements automatically.
Top
Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIdsToExclude | Returns the ids to be excluded by this filter.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.
Example
C#
VB
C++
F#
Copy
// Use Exclusion filter to find exclude a set of elements in the document automatically

// Find all walls that are not currently selected,
// Get all element ids which are current selected by users, exclude these ids when filtering
ICollection<ElementId> selectedIds = uiDocument.Selection.GetElementIds();

// Use the selection to instantiate an exclusion filter
ExclusionFilter filter = new ExclusionFilter(selectedIds);
// For the sake of simplicity we do not test here whether the selection is empty or not,
// but in production code a proper validation would have to be done to avoid an argument
// exception from the filter's consructor.

// Apply the filter to the elements in the active document,
// Use shortcut method OfClass() to find Walls only
FilteredElementCollector collector = new FilteredElementCollector(uiDocument.Document);
IList<Element> walls = collector.WherePasses(filter).OfClass(typeof(Wall)).ToElements();
' Use Exclusion filter to find exclude a set of elements in the document automatically

' Find all walls that are not currently selected,
' Get all element ids which are current selected by users, exclude these ids when filtering
Dim selectedIds As ICollection(Of ElementId) = uiDocument.Selection.GetElementIds()

' Use the selection to instantiate an exclusion filter
Dim filter As New ExclusionFilter(selectedIds)
' For the sake of simplicity we do not test here whether the selection is empty or not,
' but in production code a proper validation would have to be done to avoid an argument
' exception from the filter's consructor.

' Apply the filter to the elements in the active document,
' Use shortcut method OfClass() to find Walls only
Dim collector As New FilteredElementCollector(uiDocument.Document)
Dim walls As IList(Of Element) = collector.WherePasses(filter).OfClass(GetType(Wall)).ToElements()

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExclusionFilter Constructor

Constructs a new instance of a filter to exclude elements automatically.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExclusionFilter(
    ICollection<ElementId> idsToExclude
)
Public Sub New (
    idsToExclude As ICollection(Of ElementId)
)
public:
ExclusionFilter(
    ICollection<ElementId^>^ idsToExclude
)
new :
        idsToExclude : ICollection<ElementId> -> ExclusionFilter

Parameters

idsToExclude ICollection ElementId
The ids to exclude from the results.
Exceptions
Exception | Condition
ArgumentException | The input collection of ids was empty, or its contents were not valid for iteration.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExclusionFilter Class


ExclusionFilter Properties

The ExclusionFilter type exposes the following members.

Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
See Also

Reference

ExclusionFilter Class


ExclusionFilter Methods

The ExclusionFilter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIdsToExclude | Returns the ids to be excluded by this filter.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExclusionFilter Class


ExclusionFilter.GetIdsToExclude Method

ExclusionFilterGetIdsToExclude Method

Returns the ids to be excluded by this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetIdsToExclude()
Public Function GetIdsToExclude As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetIdsToExclude()
member GetIdsToExclude : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
The collection of ids to exclude.
See Also

Reference

ExclusionFilter Class


ExportColorMode Enumeration

An enumerated type listing export color mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ExportColorMode
Public Enumeration ExportColorMode
public enum class ExportColorMode
type ExportColorMode
Members
Member name | Value | Description
IndexColors | 0 | All colors from the Revit project will be set to the closest of the 255 AutoCAD Color Index colors.
TrueColor | 1 | All colors from the Revit project will be exported as 24-bit RGB values as specified in object styles.
TrueColorPerView | 2 | All colors from the Revit project will be exported as 24-bit RGB values as specified in view.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExportColumnHeaders Enumeration

Options for exporting column headers in schedule view export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ExportColumnHeaders
Public Enumeration ExportColumnHeaders
public enum class ExportColumnHeaders
type ExportColumnHeaders
Members
Member name | Value | Description
None | 0 | Do not export column headers.
OneRow | 1 | Export the column headers only.
MultipleRows | 2 | Both column headers and grouped header cells are exported.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExportDGNSettings Class

This element contains DGN export settings which are saved in a Revit document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBExportDGNSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExportDGNSettings : Element
Public Class ExportDGNSettings
    Inherits Element
public ref class ExportDGNSettings : public Element
type ExportDGNSettings =
    class
        inherit Element
    end

The ExportDGNSettings type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create(Document, String) | Create a DGN export settings with default values.
 | Create(Document, String, DGNExportOptions) | Create DGN export settings with specified values in DGNExportOptions.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
 | FindByName | Returns the pre-defined non-in-session exporting settings for DGN in the given document with the specified name.
 | GetActivePredefinedSettings | Returns the active pre-defined non-in-session exporting settings for DGN in the given document.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetDGNExportOptions | Gets the options stored in the these settings.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
 | ListNames | Returns a list of names of dgn export settings.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetDGNExportOptions | Sets the options stored in these settings.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExportDGNSettings Properties

The ExportDGNSettings type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

ExportDGNSettings Class


ExportDGNSettings Methods

The ExportDGNSettings type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create(Document, String) | Create a DGN export settings with default values.
 | Create(Document, String, DGNExportOptions) | Create DGN export settings with specified values in DGNExportOptions.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
 | FindByName | Returns the pre-defined non-in-session exporting settings for DGN in the given document with the specified name.
 | GetActivePredefinedSettings | Returns the active pre-defined non-in-session exporting settings for DGN in the given document.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetDGNExportOptions | Gets the options stored in the these settings.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
 | ListNames | Returns a list of names of dgn export settings.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetDGNExportOptions | Sets the options stored in these settings.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportDGNSettings Class


ExportDGNSettings.Create Method

ExportDGNSettingsCreate Method

Overload List
Name | Description
Create(Document, String) | Create a DGN export settings with default values.
Create(Document, String, DGNExportOptions) | Create DGN export settings with specified values in DGNExportOptions.
Top
See Also

Reference

ExportDGNSettings Class


ExportDGNSettings.Create(Document, String) Method

ExportDGNSettingsCreate(Document, String) Method

Create a DGN export settings with default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ExportDGNSettings Create(
    Document document,
    string name
)
Public Shared Function Create (
    document As Document,
    name As String
) As ExportDGNSettings
public:
static ExportDGNSettings^ Create(
    Document^ document,
    String^ name
)
static member Create :
        document : Document *
        name : string -> ExportDGNSettings

Parameters

document Document
Document where created settings is saved.
name String
The name specified to this settings.

Return Value

ExportDGNSettings
The new DGN export settings instance.
Exceptions
Exception | Condition
ArgumentException | ExistOrEmpty
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportDGNSettings Class
Create Overload


ExportDGNSettings.Create(Document, String, DGNExportOptions) Method

ExportDGNSettingsCreate(Document, String, DGNExportOptions) Method

Create DGN export settings with specified values in DGNExportOptions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ExportDGNSettings Create(
    Document document,
    string name,
    DGNExportOptions options
)
Public Shared Function Create (
    document As Document,
    name As String,
    options As DGNExportOptions
) As ExportDGNSettings
public:
static ExportDGNSettings^ Create(
    Document^ document,
    String^ name,
    DGNExportOptions^ options
)
static member Create :
        document : Document *
        name : string *
        options : DGNExportOptions -> ExportDGNSettings

Parameters

document Document
Document where created settings is saved.
name String
The name specified to this settings.
options DGNExportOptions
The options which will be stored in these settings.

Return Value

ExportDGNSettings
The new DGN export settings instance.
Exceptions
Exception | Condition
ArgumentException | ExistOrEmpty
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportDGNSettings Class
Create Overload


ExportDGNSettings.FindByName Method

ExportDGNSettingsFindByName Method

Returns the pre-defined non-in-session exporting settings for DGN in the given document with the specified name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ExportDGNSettings FindByName(
    Document aDoc,
    string name
)
Public Shared Function FindByName (
    aDoc As Document,
    name As String
) As ExportDGNSettings
public:
static ExportDGNSettings^ FindByName(
    Document^ aDoc,
    String^ name
)
static member FindByName :
        aDoc : Document *
        name : string -> ExportDGNSettings

Parameters

aDoc Document
A Revit document to retrieve the specified pre-defined exporting settings for DGN.
name String
The name of the settings to retrieve.

Return Value

ExportDGNSettings
The pre-defined DGN exporting settings, or null if nothing found that has the corresponding name.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportDGNSettings Class


ExportDGNSettings.GetActivePredefinedSettings Method

ExportDGNSettingsGetActivePredefinedSettings Method

Returns the active pre-defined non-in-session exporting settings for DGN in the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ExportDGNSettings GetActivePredefinedSettings(
    Document aDoc
)
Public Shared Function GetActivePredefinedSettings (
    aDoc As Document
) As ExportDGNSettings
public:
static ExportDGNSettings^ GetActivePredefinedSettings(
    Document^ aDoc
)
static member GetActivePredefinedSettings :
        aDoc : Document -> ExportDGNSettings

Parameters

aDoc Document
A Revit document to retrieve the active pre-defined exporting settings for DGN.

Return Value

ExportDGNSettings
The active pre-defined exporting settings for DGN, or null if nothing pre-defined exists or the in-session settings is selected.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportDGNSettings Class


ExportDGNSettings.GetDGNExportOptions Method

ExportDGNSettingsGetDGNExportOptions Method

Gets the options stored in the these settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DGNExportOptions GetDGNExportOptions()
Public Function GetDGNExportOptions As DGNExportOptions
public:
DGNExportOptions^ GetDGNExportOptions()
member GetDGNExportOptions : unit -> DGNExportOptions

Return Value

DGNExportOptions
The options.
See Also

Reference

ExportDGNSettings Class


ExportDGNSettings.ListNames Method

ExportDGNSettingsListNames Method

Returns a list of names of dgn export settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<string> ListNames(
    Document aDoc
)
Public Shared Function ListNames (
    aDoc As Document
) As IList(Of String)
public:
static IList<String^>^ ListNames(
    Document^ aDoc
)
static member ListNames :
        aDoc : Document -> IList<string>

Parameters

aDoc Document
A Revit document to retrieve names from

Return Value

IList String
An array of strings representing names of predefined setups.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportDGNSettings Class


ExportDGNSettings.SetDGNExportOptions Method

ExportDGNSettingsSetDGNExportOptions Method

Sets the options stored in these settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetDGNExportOptions(
    DGNExportOptions options
)
Public Sub SetDGNExportOptions (
    options As DGNExportOptions
)
public:
void SetDGNExportOptions(
    DGNExportOptions^ options
)
member SetDGNExportOptions :
        options : DGNExportOptions -> unit

Parameters

options DGNExportOptions
The options.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportDGNSettings Class


ExportDWGSettings Class

This element contains DWG/DXF export settings which are saved in a Revit document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBExportDWGSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExportDWGSettings : Element
Public Class ExportDWGSettings
    Inherits Element
public ref class ExportDWGSettings : public Element
type ExportDWGSettings =
    class
        inherit Element
    end

The ExportDWGSettings type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create(Document, String) | Create a DWG export settings with default values.
 | Create(Document, String, DWGExportOptions) | Create a DWG export settings with default values.
 | Create(Document, String, DXFExportOptions) | Create a DWG export settings with default values.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
 | FindByName | Returns the pre-defined non-in-session exporting settings for DWG in the given document with the specified name.
 | GetActivePredefinedSettings | Returns the active pre-defined non-in-session exporting settings for DWG in the given document.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetDWGExportOptions | Gets the options stored in the these settings.
Public method | GetDXFExportOptions | Gets the options stored in the these settings.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
 | ListNames | Returns a list of names of dwg/dxf export settings.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetDWGExportOptions | Sets the options stored in these settings.
Public method | SetDXFExportOptions | Sets the options stored in these settings.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExportDWGSettings Properties

The ExportDWGSettings type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

ExportDWGSettings Class


ExportDWGSettings Methods

The ExportDWGSettings type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create(Document, String) | Create a DWG export settings with default values.
 | Create(Document, String, DWGExportOptions) | Create a DWG export settings with default values.
 | Create(Document, String, DXFExportOptions) | Create a DWG export settings with default values.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
 | FindByName | Returns the pre-defined non-in-session exporting settings for DWG in the given document with the specified name.
 | GetActivePredefinedSettings | Returns the active pre-defined non-in-session exporting settings for DWG in the given document.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetDWGExportOptions | Gets the options stored in the these settings.
Public method | GetDXFExportOptions | Gets the options stored in the these settings.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
 | ListNames | Returns a list of names of dwg/dxf export settings.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetDWGExportOptions | Sets the options stored in these settings.
Public method | SetDXFExportOptions | Sets the options stored in these settings.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportDWGSettings Class


ExportDWGSettings.Create Method

ExportDWGSettingsCreate Method

Overload List
Name | Description
Create(Document, String) | Create a DWG export settings with default values.
Create(Document, String, DWGExportOptions) | Create a DWG export settings with default values.
Create(Document, String, DXFExportOptions) | Create a DWG export settings with default values.
Top
See Also

Reference

ExportDWGSettings Class


ExportDWGSettings.Create(Document, String) Method

ExportDWGSettingsCreate(Document, String) Method

Create a DWG export settings with default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ExportDWGSettings Create(
    Document document,
    string name
)
Public Shared Function Create (
    document As Document,
    name As String
) As ExportDWGSettings
public:
static ExportDWGSettings^ Create(
    Document^ document,
    String^ name
)
static member Create :
        document : Document *
        name : string -> ExportDWGSettings

Parameters

document Document
Document where created settings is saved.
name String
The name specified to this settings.

Return Value

ExportDWGSettings
The new DWG export settings instance.
Exceptions
Exception | Condition
ArgumentException | ExistOrEmpty
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportDWGSettings Class
Create Overload


ExportDWGSettings.Create(Document, String, DWGExportOptions) Method

ExportDWGSettingsCreate(Document, String, DWGExportOptions) Method

Create a DWG export settings with default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ExportDWGSettings Create(
    Document document,
    string name,
    DWGExportOptions options
)
Public Shared Function Create (
    document As Document,
    name As String,
    options As DWGExportOptions
) As ExportDWGSettings
public:
static ExportDWGSettings^ Create(
    Document^ document,
    String^ name,
    DWGExportOptions^ options
)
static member Create :
        document : Document *
        name : string *
        options : DWGExportOptions -> ExportDWGSettings

Parameters

document Document
Document where created settings is saved.
name String
The name specified to this settings.
options DWGExportOptions
Initialize settings by using values in DWGExportOptions.

Return Value

ExportDWGSettings
The new DWG export settings instance.
Exceptions
Exception | Condition
ArgumentException | ExistOrEmpty
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportDWGSettings Class
Create Overload


ExportDWGSettings.Create(Document, String, DXFExportOptions) Method

ExportDWGSettingsCreate(Document, String, DXFExportOptions) Method

Create a DWG export settings with default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ExportDWGSettings Create(
    Document document,
    string name,
    DXFExportOptions options
)
Public Shared Function Create (
    document As Document,
    name As String,
    options As DXFExportOptions
) As ExportDWGSettings
public:
static ExportDWGSettings^ Create(
    Document^ document,
    String^ name,
    DXFExportOptions^ options
)
static member Create :
        document : Document *
        name : string *
        options : DXFExportOptions -> ExportDWGSettings

Parameters

document Document
Document where created settings is saved.
name String
The name specified to this settings.
options DXFExportOptions
Initialize settings by using values in DXFExportOptions.

Return Value

ExportDWGSettings
The new DWG export settings instance.
Exceptions
Exception | Condition
ArgumentException | ExistOrEmpty
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportDWGSettings Class
Create Overload


ExportDWGSettings.FindByName Method

ExportDWGSettingsFindByName Method

Returns the pre-defined non-in-session exporting settings for DWG in the given document with the specified name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ExportDWGSettings FindByName(
    Document aDoc,
    string name
)
Public Shared Function FindByName (
    aDoc As Document,
    name As String
) As ExportDWGSettings
public:
static ExportDWGSettings^ FindByName(
    Document^ aDoc,
    String^ name
)
static member FindByName :
        aDoc : Document *
        name : string -> ExportDWGSettings

Parameters

aDoc Document
A Revit document to retrieve the specified pre-defined exporting settings for DWG.
name String
The name of the settings to retrieve.

Return Value

ExportDWGSettings
The pre-defined DWG exporting settings, or null if nothing found that has the corresponding name.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportDWGSettings Class


ExportDWGSettings.GetActivePredefinedSettings Method

ExportDWGSettingsGetActivePredefinedSettings Method

Returns the active pre-defined non-in-session exporting settings for DWG in the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ExportDWGSettings GetActivePredefinedSettings(
    Document aDoc
)
Public Shared Function GetActivePredefinedSettings (
    aDoc As Document
) As ExportDWGSettings
public:
static ExportDWGSettings^ GetActivePredefinedSettings(
    Document^ aDoc
)
static member GetActivePredefinedSettings :
        aDoc : Document -> ExportDWGSettings

Parameters

aDoc Document
A Revit document to retrieve the active pre-defined exporting settings for DWG.

Return Value

ExportDWGSettings
The active pre-defined exporting settings for DWG, or null if nothing pre-defined exists or the in-session settings is selected.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportDWGSettings Class


ExportDWGSettings.GetDWGExportOptions Method

ExportDWGSettingsGetDWGExportOptions Method

Gets the options stored in the these settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DWGExportOptions GetDWGExportOptions()
Public Function GetDWGExportOptions As DWGExportOptions
public:
DWGExportOptions^ GetDWGExportOptions()
member GetDWGExportOptions : unit -> DWGExportOptions

Return Value

DWGExportOptions
The options.
See Also

Reference

ExportDWGSettings Class


ExportDWGSettings.GetDXFExportOptions Method

ExportDWGSettingsGetDXFExportOptions Method

Gets the options stored in the these settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DXFExportOptions GetDXFExportOptions()
Public Function GetDXFExportOptions As DXFExportOptions
public:
DXFExportOptions^ GetDXFExportOptions()
member GetDXFExportOptions : unit -> DXFExportOptions

Return Value

DXFExportOptions
The options
See Also

Reference

ExportDWGSettings Class


ExportDWGSettings.ListNames Method

ExportDWGSettingsListNames Method

Returns a list of names of dwg/dxf export settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<string> ListNames(
    Document aDoc
)
Public Shared Function ListNames (
    aDoc As Document
) As IList(Of String)
public:
static IList<String^>^ ListNames(
    Document^ aDoc
)
static member ListNames :
        aDoc : Document -> IList<string>

Parameters

aDoc Document
A Revit document to retrieve names from.

Return Value

IList String
An array of strings representing names of predefined setups.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportDWGSettings Class


ExportDWGSettings.SetDWGExportOptions Method

ExportDWGSettingsSetDWGExportOptions Method

Sets the options stored in these settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetDWGExportOptions(
    DWGExportOptions options
)
Public Sub SetDWGExportOptions (
    options As DWGExportOptions
)
public:
void SetDWGExportOptions(
    DWGExportOptions^ options
)
member SetDWGExportOptions :
        options : DWGExportOptions -> unit

Parameters

options DWGExportOptions
The options.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportDWGSettings Class


ExportDWGSettings.SetDXFExportOptions Method

ExportDWGSettingsSetDXFExportOptions Method

Sets the options stored in these settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetDXFExportOptions(
    DXFExportOptions options
)
Public Sub SetDXFExportOptions (
    options As DXFExportOptions
)
public:
void SetDXFExportOptions(
    DXFExportOptions^ options
)
member SetDXFExportOptions :
        options : DXFExportOptions -> unit

Parameters

options DXFExportOptions
The options.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportDWGSettings Class


ExportEnergyModelType Enumeration

This enum is used to define if energy model used for gbXML export should be based on rooms/spaces, building elements or analysis mode in EnergyDataSettings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ExportEnergyModelType
Public Enumeration ExportEnergyModelType
public enum class ExportEnergyModelType
type ExportEnergyModelType
Members
Member name | Value | Description
SpatialElement | 0 | Energy model based on rooms or spaces.
BuildingElement | 1 | The building element based energy analytical model.
AnalysisMode | 2 | Energy model based on analysis mode in EnergyDataSettings.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExportFontInfo Class

A value used to represent the info stored in an ExportFontTable.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExportFontInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExportFontInfo : IDisposable
Public Class ExportFontInfo
    Implements IDisposable
public ref class ExportFontInfo : IDisposable
type ExportFontInfo =
    class
        interface IDisposable
    end

The ExportFontInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ExportFontInfo | Constructs a new default ExportFontInfo.
Public method | ExportFontInfo(ExportFontInfo) | Constructs a new copy of the input ExportFontInfo object.
Public method | ExportFontInfo(String) | Constructs a new ExportFontInfo using the destination font name as input.
Top
Properties
 | Name | Description
Public property | DestinationFontName | The destination font name (the name of the font in the exported format).
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ExportFontInfo
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExportFontInfo Constructor

Overload List
 | Name | Description
Public method | ExportFontInfo | Constructs a new default ExportFontInfo.
Public method | ExportFontInfo(ExportFontInfo) | Constructs a new copy of the input ExportFontInfo object.
Public method | ExportFontInfo(String) | Constructs a new ExportFontInfo using the destination font name as input.
Top
See Also

Reference

ExportFontInfo Class


ExportFontInfo Constructor

Constructs a new default ExportFontInfo.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportFontInfo()
Public Sub New
public:
ExportFontInfo()
new : unit -> ExportFontInfo
See Also

Reference

ExportFontInfo Class
ExportFontInfo Overload


ExportFontInfo(ExportFontInfo) Constructor

Constructs a new copy of the input ExportFontInfo object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportFontInfo(
    ExportFontInfo other
)
Public Sub New (
    other As ExportFontInfo
)
public:
ExportFontInfo(
    ExportFontInfo^ other
)
new :
        other : ExportFontInfo -> ExportFontInfo

Parameters

other ExportFontInfo
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportFontInfo Class
ExportFontInfo Overload


ExportFontInfo(String) Constructor

Constructs a new ExportFontInfo using the destination font name as input.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportFontInfo(
    string destinationFontName
)
Public Sub New (
    destinationFontName As String
)
public:
ExportFontInfo(
    String^ destinationFontName
)
new :
        destinationFontName : string -> ExportFontInfo

Parameters

destinationFontName String
The destination font name (the name of the font in the exported format).
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportFontInfo Class
ExportFontInfo Overload


ExportFontInfo Properties

The ExportFontInfo type exposes the following members.

Properties
 | Name | Description
Public property | DestinationFontName | The destination font name (the name of the font in the exported format).
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

ExportFontInfo Class


ExportFontInfo.DestinationFontName Property

ExportFontInfoDestinationFontName Property

The destination font name (the name of the font in the exported format).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string DestinationFontName { get; set; }
Public Property DestinationFontName As String
    Get
    Set
public:
property String^ DestinationFontName {
    String^ get ();
    void set (String^ value);
}
member DestinationFontName : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ExportFontInfo Class


ExportFontInfo.IsValidObject Property

ExportFontInfoIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ExportFontInfo Class


ExportFontInfo Methods

The ExportFontInfo type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportFontInfo Class


ExportFontInfo.Dispose Method

ExportFontInfoDispose Method

Releases all resources used by the ExportFontInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ExportFontInfo Class


ExportFontKey Class

A key used to represent an item stored in an ExportFontTable.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExportFontKey

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExportFontKey : IDisposable
Public Class ExportFontKey
    Implements IDisposable
public ref class ExportFontKey : IDisposable
type ExportFontKey =
    class
        interface IDisposable
    end

The ExportFontKey type exposes the following members.

Constructors
 | Name | Description
Public method | ExportFontKey | Constructs a new default ExportFontKey.
Public method | ExportFontKey(ExportFontKey) | Constructs a new copy of the input ExportFontKey object.
Public method | ExportFontKey(String) | Constructs a new ExportFontKey using an input font name.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OriginalFontName | The original font name.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ExportFontKey
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExportFontKey Constructor

Overload List
 | Name | Description
Public method | ExportFontKey | Constructs a new default ExportFontKey.
Public method | ExportFontKey(ExportFontKey) | Constructs a new copy of the input ExportFontKey object.
Public method | ExportFontKey(String) | Constructs a new ExportFontKey using an input font name.
Top
See Also

Reference

ExportFontKey Class


ExportFontKey Constructor

Constructs a new default ExportFontKey.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportFontKey()
Public Sub New
public:
ExportFontKey()
new : unit -> ExportFontKey
See Also

Reference

ExportFontKey Class
ExportFontKey Overload


ExportFontKey(ExportFontKey) Constructor

Constructs a new copy of the input ExportFontKey object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportFontKey(
    ExportFontKey other
)
Public Sub New (
    other As ExportFontKey
)
public:
ExportFontKey(
    ExportFontKey^ other
)
new :
        other : ExportFontKey -> ExportFontKey

Parameters

other ExportFontKey
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportFontKey Class
ExportFontKey Overload


ExportFontKey(String) Constructor

Constructs a new ExportFontKey using an input font name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportFontKey(
    string originalFontName
)
Public Sub New (
    originalFontName As String
)
public:
ExportFontKey(
    String^ originalFontName
)
new :
        originalFontName : string -> ExportFontKey

Parameters

originalFontName String
The original font name.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportFontKey Class
ExportFontKey Overload


ExportFontKey Properties

The ExportFontKey type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OriginalFontName | The original font name.
Top
See Also

Reference

ExportFontKey Class


ExportFontKey.IsValidObject Property

ExportFontKeyIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ExportFontKey Class


ExportFontKey.OriginalFontName Property

ExportFontKeyOriginalFontName Property

The original font name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string OriginalFontName { get; set; }
Public Property OriginalFontName As String
    Get
    Set
public:
property String^ OriginalFontName {
    String^ get ();
    void set (String^ value);
}
member OriginalFontName : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ExportFontKey Class


ExportFontKey Methods

The ExportFontKey type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportFontKey Class


ExportFontKey.Dispose Method

ExportFontKeyDispose Method

Releases all resources used by the ExportFontKey

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ExportFontKey Class


ExportFontTable Class

A table supporting a mapping of Revit font names to font names that will be set in the target export format.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExportFontTable

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExportFontTable : IEnumerable<KeyValuePair<ExportFontKey, ExportFontInfo>>,
    IDisposable
Public Class ExportFontTable
    Implements IEnumerable(Of KeyValuePair(Of ExportFontKey, ExportFontInfo)),
    IDisposable
public ref class ExportFontTable : IEnumerable<KeyValuePair<ExportFontKey^, ExportFontInfo^>>,
    IDisposable
type ExportFontTable =
    class
        interface IEnumerable<KeyValuePair<ExportFontKey, ExportFontInfo>>
        interface IDisposable
    end

The ExportFontTable type exposes the following members.

Constructors
 | Name | Description
Public method | ExportFontTable | Constructs a new ExportFontTable with default values.
Top
Properties
 | Name | Description
Public property | Count | Count of the items contained in the collection.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Item | A copy of the ExportFontInfo for the font's ExportFontKey.
Top
Methods
 | Name | Description
Public method | Add | Inserts a (key,info) pair into Export font table.
Public method | Clear | Removes all contents stored in the table.
Public method | ContainsKey | Checks whether a font key exists in the table.
Public method | Dispose | Releases all resources used by the ExportFontTable
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetExportFontInfo | Gets a copy of the font info associated to the input font key.
Public method | GetFontTableIterator | Returns a FontTableIterator that iterates through the collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetKeys | Returns a collection of the keys stored in this table.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetValues | Returns a collection of the values stored in this table.
Public method | Remove | Removes the pair (key, info) by font key.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

This table is structured as a mapping from ExportFontKey to ExportFontInfo members. The ExportFontKey contains the identification information for the font table: the Revit font name. The ExportFontInfo contains the font name to use in the export format.

The table can be accessed via direct iteration as a collection of KeyValuePairs, or by traversal of the stored keys obtained from GetKeys(), or via specific lookup of a key constructed externally. In all cases, the ExportFontInfo returned will be a copy of the ExportFontInfo from the table. In order to make changes to the ExportFontInfo and use those settings during export, set the modified ExportFontInfo back into the table using the same key.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExportFontTable Constructor

Constructs a new ExportFontTable with default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportFontTable()
Public Sub New
public:
ExportFontTable()
new : unit -> ExportFontTable
See Also

Reference

ExportFontTable Class


ExportFontTable Properties

The ExportFontTable type exposes the following members.

Properties
 | Name | Description
Public property | Count | Count of the items contained in the collection.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Item | A copy of the ExportFontInfo for the font's ExportFontKey.
Top
See Also

Reference

ExportFontTable Class


ExportFontTable.Count Property

ExportFontTableCount Property

Count of the items contained in the collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
member Count : int with get

Property Value

Int32
See Also

Reference

ExportFontTable Class


ExportFontTable.IsValidObject Property

ExportFontTableIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ExportFontTable Class


ExportFontTable.Item Property

ExportFontTableItem Property

A copy of the ExportFontInfo for the font's ExportFontKey.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportFontInfo this[
    ExportFontKey fontKey
] { get; set; }
Public Default Property Item (
    fontKey As ExportFontKey
) As ExportFontInfo
    Get
    Set
public:
virtual property ExportFontInfo^ default[ExportFontKey^ fontKey] {
    ExportFontInfo^ get (ExportFontKey^ fontKey) sealed;
    void set (ExportFontKey^ fontKey, ExportFontInfo^ value) sealed;
}
abstract Item : ExportFontInfo with get, set
override Item : ExportFontInfo with get, set

Parameters

fontKey ExportFontKey

Return Value

ExportFontInfo
A copy of the ExportFontInfo.
Exceptions
Exception | Condition
ArgumentException | When getting this property: An entry with the given key is not present in the table.
Remarks
When getting this property, it returns a copy of the ExportFontInfo from the table. In order to make changes to the ExportFontInfo and use those settings during export, set the modified ExportFontInfo back into the table using the same key.
See Also

Reference

ExportFontTable Class


ExportFontTable Methods

The ExportFontTable type exposes the following members.

Methods
 | Name | Description
Public method | Add | Inserts a (key,info) pair into Export font table.
Public method | Clear | Removes all contents stored in the table.
Public method | ContainsKey | Checks whether a font key exists in the table.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetExportFontInfo | Gets a copy of the font info associated to the input font key.
Public method | GetFontTableIterator | Returns a FontTableIterator that iterates through the collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetKeys | Returns a collection of the keys stored in this table.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetValues | Returns a collection of the values stored in this table.
Public method | Remove | Removes the pair (key, info) by font key.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportFontTable Class


ExportFontTable.Add Method

ExportFontTableAdd Method

Inserts a (key,info) pair into Export font table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Add(
    ExportFontKey exportFontKey,
    ExportFontInfo exportFontInfo
)
Public Sub Add (
    exportFontKey As ExportFontKey,
    exportFontInfo As ExportFontInfo
)
public:
void Add(
    ExportFontKey^ exportFontKey,
    ExportFontInfo^ exportFontInfo
)
member Add :
        exportFontKey : ExportFontKey *
        exportFontInfo : ExportFontInfo -> unit

Parameters

exportFontKey ExportFontKey
The export font key to be added.
exportFontInfo ExportFontInfo
The export font info to be added.
Exceptions
Exception | Condition
ArgumentException | The key already exists in the table.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportFontTable Class


ExportFontTable.Clear Method

ExportFontTableClear Method

Removes all contents stored in the table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

ExportFontTable Class


ExportFontTable.ContainsKey Method

ExportFontTableContainsKey Method

Checks whether a font key exists in the table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ContainsKey(
    ExportFontKey exportfontKey
)
Public Function ContainsKey (
    exportfontKey As ExportFontKey
) As Boolean
public:
bool ContainsKey(
    ExportFontKey^ exportfontKey
)
member ContainsKey :
        exportfontKey : ExportFontKey -> bool

Parameters

exportfontKey ExportFontKey
The export font Key.

Return Value

Boolean
True if the font key exists in the table.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportFontTable Class


ExportFontTable.Dispose Method

ExportFontTableDispose Method

Releases all resources used by the ExportFontTable

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ExportFontTable Class


ExportFontTable.GetBasicIEnumerator Method

ExportFontTableGetBasicIEnumerator Method

Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
internal virtual IEnumerator GetBasicIEnumerator()
Friend Overridable Function GetBasicIEnumerator As IEnumerator
internal:
virtual IEnumerator^ GetBasicIEnumerator()
internal abstract GetBasicIEnumerator : unit -> IEnumerator
internal override GetBasicIEnumerator : unit -> IEnumerator

Return Value

IEnumerator
An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerableGetEnumerator
See Also

Reference

ExportFontTable Class


ExportFontTable.GetEnumerator Method

ExportFontTableGetEnumerator Method

Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator<KeyValuePair<ExportFontKey, ExportFontInfo>> GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator(Of KeyValuePair(Of ExportFontKey, ExportFontInfo))
public:
virtual IEnumerator<KeyValuePair<ExportFontKey^, ExportFontInfo^>>^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator<KeyValuePair<ExportFontKey, ExportFontInfo>>
override GetEnumerator : unit -> IEnumerator<KeyValuePair<ExportFontKey, ExportFontInfo>>

Return Value

IEnumerator KeyValuePair ExportFontKey, ExportFontInfo
An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerableTGetEnumerator
See Also

Reference

ExportFontTable Class


ExportFontTable.GetExportFontInfo Method

ExportFontTableGetExportFontInfo Method

Gets a copy of the font info associated to the input font key.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportFontInfo GetExportFontInfo(
    ExportFontKey exportFontKey
)
Public Function GetExportFontInfo (
    exportFontKey As ExportFontKey
) As ExportFontInfo
public:
ExportFontInfo^ GetExportFontInfo(
    ExportFontKey^ exportFontKey
)
member GetExportFontInfo :
        exportFontKey : ExportFontKey -> ExportFontInfo

Parameters

exportFontKey ExportFontKey
The export font Key.

Return Value

ExportFontInfo
Returns the fontInfo for this key.
Exceptions
Exception | Condition
ArgumentException | An entry with the given key is not present in the table.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportFontTable Class


ExportFontTable.GetFontTableIterator Method

ExportFontTableGetFontTableIterator Method

Returns a FontTableIterator that iterates through the collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportFontTableIterator GetFontTableIterator()
Public Function GetFontTableIterator As ExportFontTableIterator
public:
ExportFontTableIterator^ GetFontTableIterator()
member GetFontTableIterator : unit -> ExportFontTableIterator

Return Value

ExportFontTableIterator
A FontTableIterator object that can be used to iterate through key-value pairs in the collection.
See Also

Reference

ExportFontTable Class


ExportFontTable.GetKeys Method

ExportFontTableGetKeys Method

Returns a collection of the keys stored in this table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ExportFontKey> GetKeys()
Public Function GetKeys As IList(Of ExportFontKey)
public:
IList<ExportFontKey^>^ GetKeys()
member GetKeys : unit -> IList<ExportFontKey>

Return Value

IList ExportFontKey
The collection of keys.
See Also

Reference

ExportFontTable Class


ExportFontTable.GetValues Method

ExportFontTableGetValues Method

Returns a collection of the values stored in this table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ExportFontInfo> GetValues()
Public Function GetValues As IList(Of ExportFontInfo)
public:
IList<ExportFontInfo^>^ GetValues()
member GetValues : unit -> IList<ExportFontInfo>

Return Value

IList ExportFontInfo
The collection of values.
See Also

Reference

ExportFontTable Class


ExportFontTable.Remove Method

ExportFontTableRemove Method

Removes the pair (key, info) by font key.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Remove(
    ExportFontKey exportFontKey
)
Public Sub Remove (
    exportFontKey As ExportFontKey
)
public:
void Remove(
    ExportFontKey^ exportFontKey
)
member Remove :
        exportFontKey : ExportFontKey -> unit

Parameters

exportFontKey ExportFontKey
The export font key.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportFontTable Class


ExportFontTableIterator Class

An iterator to a set of font table.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExportFontTableIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExportFontTableIterator : IEnumerator<KeyValuePair<ExportFontKey, ExportFontInfo>>
Public Class ExportFontTableIterator
    Implements IEnumerator(Of KeyValuePair(Of ExportFontKey, ExportFontInfo))
public ref class ExportFontTableIterator : IEnumerator<KeyValuePair<ExportFontKey^, ExportFontInfo^>>
type ExportFontTableIterator =
    class
        interface IEnumerator<KeyValuePair<ExportFontKey, ExportFontInfo>>
    end

The ExportFontTableIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ExportFontTableIterator
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next item.
Public method | Reset | Resets the iterator to the initial state.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExportFontTableIterator Properties

The ExportFontTableIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

ExportFontTableIterator Class


ExportFontTableIterator.Current Property

ExportFontTableIteratorCurrent Property

Gets the item at the current position of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual KeyValuePair<ExportFontKey, ExportFontInfo> Current { get; }
Public Overridable ReadOnly Property Current As KeyValuePair(Of ExportFontKey, ExportFontInfo)
    Get
public:
virtual property KeyValuePair<ExportFontKey^, ExportFontInfo^> Current {
    KeyValuePair<ExportFontKey^, ExportFontInfo^> get ();
}
abstract Current : KeyValuePair<ExportFontKey, ExportFontInfo> with get
override Current : KeyValuePair<ExportFontKey, ExportFontInfo> with get

Property Value

KeyValuePair ExportFontKey, ExportFontInfo

Implements

IEnumeratorTCurrent
Exceptions
Exception | Condition
InvalidOperationException | There is no current item in the iterator.
Remarks
There is no current item if the iterator has not started yet or has been done.
See Also

Reference

ExportFontTableIterator Class


ExportFontTableIterator.CurrentObject Property

ExportFontTableIteratorCurrentObject Property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
internal Object CurrentObject { get; }
Friend ReadOnly Property CurrentObject As Object
    Get
internal:
virtual property Object^ CurrentObject {
    Object^ get () sealed;
}
internal abstract CurrentObject : Object with get
internal override CurrentObject : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
See Also

Reference

ExportFontTableIterator Class


ExportFontTableIterator.IsValidObject Property

ExportFontTableIteratorIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ExportFontTableIterator Class


ExportFontTableIterator Methods

The ExportFontTableIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next item.
Public method | Reset | Resets the iterator to the initial state.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportFontTableIterator Class


ExportFontTableIterator.Dispose Method

ExportFontTableIteratorDispose Method

Releases all resources used by the ExportFontTableIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit
See Also

Reference

ExportFontTableIterator Class


ExportFontTableIterator.IsDone Method

ExportFontTableIteratorIsDone Method

Identifies if the iteration has completed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsDone()
Public Overridable Function IsDone As Boolean
public:
virtual bool IsDone()
abstract IsDone : unit -> bool
override IsDone : unit -> bool

Return Value

Boolean
True if the iteration has no more items. False if there are more items to be iterated.
See Also

Reference

ExportFontTableIterator Class


ExportFontTableIterator.MoveNext Method

ExportFontTableIteratorMoveNext Method

Increments the iterator to the next item.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
True if there is a next available item in this iterator. False if the iterator has completed all available items.
See Also

Reference

ExportFontTableIterator Class


ExportFontTableIterator.Reset Method

ExportFontTableIteratorReset Method

Resets the iterator to the initial state.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit
See Also

Reference

ExportFontTableIterator Class


ExportIFCCategoryInfo Class

Represents the mapped IFC information stored in the template.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExportIFCCategoryInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExportIFCCategoryInfo : IDisposable
Public Class ExportIFCCategoryInfo
    Implements IDisposable
public ref class ExportIFCCategoryInfo : IDisposable
type ExportIFCCategoryInfo =
    class
        interface IDisposable
    end

The ExportIFCCategoryInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ExportIFCCategoryInfo | Constructs a new ExportIFCCategoryInfo with default values.
Public method | ExportIFCCategoryInfo(Boolean, String, String, String, String) | Constructs a new ExportIFCCategoryInfo with input values.
Top
Properties
 | Name | Description
Public property | IFCEntityName | The name of the IFC entity mapped to a particular Revit category.
Public property | IFCExportFlag | The boolean value that indicates whether the category is exported to ifc.
Public property | IFCPredefinedType | The name of the predefined type mapped to a particular Revit category.
Public property | IFCPresentationLayerName | The name of the presentation layer mapped to a particular Revit category.
Public property | IFCUserDefinedType | The name of the user-defined type mapped to a particular Revit category.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ExportIFCCategoryInfo
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsDefault | Determines if a ExportIFCCategoryInfo contains default information.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExportIFCCategoryInfo Constructor

Overload List
 | Name | Description
Public method | ExportIFCCategoryInfo | Constructs a new ExportIFCCategoryInfo with default values.
Public method | ExportIFCCategoryInfo(Boolean, String, String, String, String) | Constructs a new ExportIFCCategoryInfo with input values.
Top
See Also

Reference

ExportIFCCategoryInfo Class


ExportIFCCategoryInfo Constructor

Constructs a new ExportIFCCategoryInfo with default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportIFCCategoryInfo()
Public Sub New
public:
ExportIFCCategoryInfo()
new : unit -> ExportIFCCategoryInfo
See Also

Reference

ExportIFCCategoryInfo Class
ExportIFCCategoryInfo Overload


ExportIFCCategoryInfo(Boolean, String, String, String, String) Constructor

Constructs a new ExportIFCCategoryInfo with input values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportIFCCategoryInfo(
    bool ifcExportFlag,
    string ifcEntityName,
    string ifcPredefinedType,
    string ifcUserDefinedType,
    string ifcPresentationLayerName
)
Public Sub New (
    ifcExportFlag As Boolean,
    ifcEntityName As String,
    ifcPredefinedType As String,
    ifcUserDefinedType As String,
    ifcPresentationLayerName As String
)
public:
ExportIFCCategoryInfo(
    bool ifcExportFlag,
    String^ ifcEntityName,
    String^ ifcPredefinedType,
    String^ ifcUserDefinedType,
    String^ ifcPresentationLayerName
)
new :
        ifcExportFlag : bool *
        ifcEntityName : string *
        ifcPredefinedType : string *
        ifcUserDefinedType : string *
        ifcPresentationLayerName : string -> ExportIFCCategoryInfo

Parameters

ifcExportFlag Boolean
The flag that indicates whether the category is exported.
ifcEntityName String
The IFC entity name.
ifcPredefinedType String
The IFC predefined type.
ifcUserDefinedType String
The IFC user defined type.
ifcPresentationLayerName String
The IFC presentation layer name.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportIFCCategoryInfo Class
ExportIFCCategoryInfo Overload


ExportIFCCategoryInfo Properties

The ExportIFCCategoryInfo type exposes the following members.

Properties
 | Name | Description
Public property | IFCEntityName | The name of the IFC entity mapped to a particular Revit category.
Public property | IFCExportFlag | The boolean value that indicates whether the category is exported to ifc.
Public property | IFCPredefinedType | The name of the predefined type mapped to a particular Revit category.
Public property | IFCPresentationLayerName | The name of the presentation layer mapped to a particular Revit category.
Public property | IFCUserDefinedType | The name of the user-defined type mapped to a particular Revit category.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

ExportIFCCategoryInfo Class


ExportIFCCategoryInfo.IFCEntityName Property

ExportIFCCategoryInfoIFCEntityName Property

The name of the IFC entity mapped to a particular Revit category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string IFCEntityName { get; set; }
Public Property IFCEntityName As String
    Get
    Set
public:
property String^ IFCEntityName {
    String^ get ();
    void set (String^ value);
}
member IFCEntityName : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ExportIFCCategoryInfo Class


ExportIFCCategoryInfo.IFCExportFlag Property

ExportIFCCategoryInfoIFCExportFlag Property

The boolean value that indicates whether the category is exported to ifc.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IFCExportFlag { get; set; }
Public Property IFCExportFlag As Boolean
    Get
    Set
public:
property bool IFCExportFlag {
    bool get ();
    void set (bool value);
}
member IFCExportFlag : bool with get, set

Property Value

Boolean
See Also

Reference

ExportIFCCategoryInfo Class


ExportIFCCategoryInfo.IFCPredefinedType Property

ExportIFCCategoryInfoIFCPredefinedType Property

The name of the predefined type mapped to a particular Revit category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string IFCPredefinedType { get; set; }
Public Property IFCPredefinedType As String
    Get
    Set
public:
property String^ IFCPredefinedType {
    String^ get ();
    void set (String^ value);
}
member IFCPredefinedType : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ExportIFCCategoryInfo Class


ExportIFCCategoryInfo.IFCPresentationLayerName Property

ExportIFCCategoryInfoIFCPresentationLayerName Property

The name of the presentation layer mapped to a particular Revit category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string IFCPresentationLayerName { get; set; }
Public Property IFCPresentationLayerName As String
    Get
    Set
public:
property String^ IFCPresentationLayerName {
    String^ get ();
    void set (String^ value);
}
member IFCPresentationLayerName : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ExportIFCCategoryInfo Class


ExportIFCCategoryInfo.IFCUserDefinedType Property

ExportIFCCategoryInfoIFCUserDefinedType Property

The name of the user-defined type mapped to a particular Revit category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string IFCUserDefinedType { get; set; }
Public Property IFCUserDefinedType As String
    Get
    Set
public:
property String^ IFCUserDefinedType {
    String^ get ();
    void set (String^ value);
}
member IFCUserDefinedType : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ExportIFCCategoryInfo Class


ExportIFCCategoryInfo.IsValidObject Property

ExportIFCCategoryInfoIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ExportIFCCategoryInfo Class


ExportIFCCategoryInfo Methods

The ExportIFCCategoryInfo type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsDefault | Determines if a ExportIFCCategoryInfo contains default information.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportIFCCategoryInfo Class


ExportIFCCategoryInfo.Dispose Method

ExportIFCCategoryInfoDispose Method

Releases all resources used by the ExportIFCCategoryInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ExportIFCCategoryInfo Class


ExportIFCCategoryInfo.IsDefault Method

ExportIFCCategoryInfoIsDefault Method

Determines if a ExportIFCCategoryInfo contains default information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsDefault()
Public Function IsDefault As Boolean
public:
bool IsDefault()
member IsDefault : unit -> bool

Return Value

Boolean
True if the ExportIFCCategoryInfo contains only default information.
Remarks
We consider an ExportIFCCategoryInfo is set to default if it is set to export and has no entity name.
See Also

Reference

ExportIFCCategoryInfo Class


ExportIFCCategoryKey Class

Represents a Revit category item stored in a template.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExportIFCCategoryKey

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExportIFCCategoryKey : IDisposable
Public Class ExportIFCCategoryKey
    Implements IDisposable
public ref class ExportIFCCategoryKey : IDisposable
type ExportIFCCategoryKey =
    class
        interface IDisposable
    end

The ExportIFCCategoryKey type exposes the following members.

Constructors
 | Name | Description
Public method | ExportIFCCategoryKey | Constructs a new ExportIFCCategoryKey with default values.
Public method | ExportIFCCategoryKey(String, String, CustomSubCategoryId) | Constructs a new ExportIFCCategoryKey with category, subcategory names and special id.
Top
Properties
 | Name | Description
Public property | CategoryName | The Revit category name.
Public property | CustomSubCategoryId | The Revit custom subcategory id.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SubCategoryName | The Revit subcategrory name.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ExportIFCCategoryKey
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExportIFCCategoryKey Constructor

Overload List
 | Name | Description
Public method | ExportIFCCategoryKey | Constructs a new ExportIFCCategoryKey with default values.
Public method | ExportIFCCategoryKey(String, String, CustomSubCategoryId) | Constructs a new ExportIFCCategoryKey with category, subcategory names and special id.
Top
See Also

Reference

ExportIFCCategoryKey Class


ExportIFCCategoryKey Constructor

Constructs a new ExportIFCCategoryKey with default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportIFCCategoryKey()
Public Sub New
public:
ExportIFCCategoryKey()
new : unit -> ExportIFCCategoryKey
See Also

Reference

ExportIFCCategoryKey Class
ExportIFCCategoryKey Overload


ExportIFCCategoryKey(String, String, CustomSubCategoryId) Constructor

Constructs a new ExportIFCCategoryKey with category, subcategory names and special id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportIFCCategoryKey(
    string categoryName,
    string subCategoryName,
    CustomSubCategoryId customSubCategoryId
)
Public Sub New (
    categoryName As String,
    subCategoryName As String,
    customSubCategoryId As CustomSubCategoryId
)
public:
ExportIFCCategoryKey(
    String^ categoryName,
    String^ subCategoryName,
    CustomSubCategoryId customSubCategoryId
)
new :
        categoryName : string *
        subCategoryName : string *
        customSubCategoryId : CustomSubCategoryId -> ExportIFCCategoryKey

Parameters

categoryName String
The Revit category name.
subCategoryName String
The Revit subcategory name.
customSubCategoryId CustomSubCategoryId
The Revit custom subcategory id.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ExportIFCCategoryKey Class
ExportIFCCategoryKey Overload


ExportIFCCategoryKey Properties

The ExportIFCCategoryKey type exposes the following members.

Properties
 | Name | Description
Public property | CategoryName | The Revit category name.
Public property | CustomSubCategoryId | The Revit custom subcategory id.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SubCategoryName | The Revit subcategrory name.
Top
See Also

Reference

ExportIFCCategoryKey Class


ExportIFCCategoryKey.CategoryName Property

ExportIFCCategoryKeyCategoryName Property

The Revit category name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string CategoryName { get; set; }
Public Property CategoryName As String
    Get
    Set
public:
property String^ CategoryName {
    String^ get ();
    void set (String^ value);
}
member CategoryName : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ExportIFCCategoryKey Class


ExportIFCCategoryKey.CustomSubCategoryId Property

ExportIFCCategoryKeyCustomSubCategoryId Property

The Revit custom subcategory id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CustomSubCategoryId CustomSubCategoryId { get; set; }
Public Property CustomSubCategoryId As CustomSubCategoryId
    Get
    Set
public:
property CustomSubCategoryId CustomSubCategoryId {
    CustomSubCategoryId get ();
    void set (CustomSubCategoryId value);
}
member CustomSubCategoryId : CustomSubCategoryId with get, set

Property Value

CustomSubCategoryId
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ExportIFCCategoryKey Class


ExportIFCCategoryKey.IsValidObject Property

ExportIFCCategoryKeyIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ExportIFCCategoryKey Class


ExportIFCCategoryKey.SubCategoryName Property

ExportIFCCategoryKeySubCategoryName Property

The Revit subcategrory name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SubCategoryName { get; set; }
Public Property SubCategoryName As String
    Get
    Set
public:
property String^ SubCategoryName {
    String^ get ();
    void set (String^ value);
}
member SubCategoryName : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ExportIFCCategoryKey Class


ExportIFCCategoryKey Methods

The ExportIFCCategoryKey type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportIFCCategoryKey Class


ExportIFCCategoryKey.Dispose Method

ExportIFCCategoryKeyDispose Method

Releases all resources used by the ExportIFCCategoryKey

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ExportIFCCategoryKey Class


ExportLayerInfo Class

A value used to represent the info stored in the ExportLayerTable.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExportLayerInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExportLayerInfo : IDisposable
Public Class ExportLayerInfo
    Implements IDisposable
public ref class ExportLayerInfo : IDisposable
type ExportLayerInfo =
    class
        interface IDisposable
    end

The ExportLayerInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ExportLayerInfo | Constructs a new ExportLayerInfo with default values.
Top
Properties
 | Name | Description
Public property | CategoryType | The category type which this layer belongs to.
Public property | ColorName | The color name stored in value. For IFC export, the naming is to match the "colornumber" setting -- really, this stores a string that generates the colorNumber (for formats that don't use the color but need a second entry.)
Public property | ColorNumber | The color number stored in value.
Public property | CutColorNumber | The cut color number stored in value.
Public property | CutLayerName | The cut layer name stored in value.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LayerName | The layer name stored in value.
Top
Methods
 | Name | Description
Public method | AddCutLayerModifier | Adds a cut layer modifier to the layer info.
Public method | AddLayerModifier | Adds a project layer modifier to the layer info.
Public method | ClearCutLayerModifiers | Clears all the cut layer modifiers stored in the layer info.
Public method | ClearLayerModifiers | Clears all the project layer modifiers stored in the layer info.
Public method | Dispose | Releases all resources used by the ExportLayerInfo
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCutLayerModifiers | Gets all the cut layer modifiers from the layer info.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLayerModifiers | Gets all the project layer modifiers from the layer info.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | RemoveCutLayerModifier | Removes a cut layer modifier from the layer info.
Public method | RemoveLayerModifier | Removes a project layer modifier from the layer info.
Public method | SetCutLayerModifiers | Sets a cut layer modifier array to the layer info.
Public method | SetLayerModifiers | Sets a project layer modifier array to the layer info.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Example
C#
VB
C++
F#
Copy
public bool ExportDWGModifyLayerTable(Document document, View view)
{
    bool exported = false;
    IList<string> setupNames = BaseExportOptions.GetPredefinedSetupNames(document);
    if (setupNames.Count > 0)
    {
        // Get the export options for the first predefined setup
        DWGExportOptions dwgOptions = DWGExportOptions.GetPredefinedOptions(document, setupNames[0]);

        // Get the export layer table
        ExportLayerTable layerTable = dwgOptions.GetExportLayerTable();

        // Find the first mapping for the Ceilings category
        string category = "Ceilings";
        ExportLayerKey targetKey = layerTable.GetKeys().First<ExportLayerKey>(layerKey => layerKey.CategoryName == category);
        ExportLayerInfo targetInfo = layerTable[targetKey];

        // change the color name and cut color number for this mapping
        targetInfo.ColorName = "31";
        targetInfo.CutColorNumber = 31;

        // Set the change back to the map
        layerTable[targetKey] = targetInfo;

        // Set the modified table back to the options
        dwgOptions.SetExportLayerTable(layerTable);

        ICollection<ElementId> views = new List<ElementId>();
        views.Add(view.Id);

        exported = document.Export(Path.GetDirectoryName(document.PathName),
            Path.GetFileNameWithoutExtension(document.PathName), views, dwgOptions);
    }

    return exported;
}
Public Function ExportDWGModifyLayerTable(document As Document, view As View) As Boolean
   Dim exported As Boolean = False
   Dim setupNames As IList(Of String) = BaseExportOptions.GetPredefinedSetupNames(document)
   If setupNames.Count > 0 Then
      ' Get the export options for the first predefined setup
      Dim dwgOptions As DWGExportOptions = DWGExportOptions.GetPredefinedOptions(document, setupNames(0))

      ' Get the export layer table
      Dim layerTable As ExportLayerTable = dwgOptions.GetExportLayerTable()

      ' Find the first mapping for the Ceilings category
      Dim category As String = "Ceilings"
      Dim targetKey As ExportLayerKey = layerTable.GetKeys().First(Function(layerKey) layerKey.CategoryName = category)
      Dim targetInfo As ExportLayerInfo = layerTable(targetKey)

      ' change the color name and cut color number for this mapping
      targetInfo.ColorName = "31"
      targetInfo.CutColorNumber = 31

      ' Set the change back to the map
      layerTable(targetKey) = targetInfo

      ' Set the modified table back to the options
      dwgOptions.SetExportLayerTable(layerTable)

      Dim views As ICollection(Of ElementId) = New List(Of ElementId)()
      views.Add(view.Id)

      exported = document.Export(Path.GetDirectoryName(document.PathName), Path.GetFileNameWithoutExtension(document.PathName), views, dwgOptions)
   End If

   Return exported
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExportLayerInfo Constructor

Constructs a new ExportLayerInfo with default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportLayerInfo()
Public Sub New
public:
ExportLayerInfo()
new : unit -> ExportLayerInfo
See Also

Reference

ExportLayerInfo Class


ExportLayerInfo Properties

The ExportLayerInfo type exposes the following members.

Properties
 | Name | Description
Public property | CategoryType | The category type which this layer belongs to.
Public property | ColorName | The color name stored in value. For IFC export, the naming is to match the "colornumber" setting -- really, this stores a string that generates the colorNumber (for formats that don't use the color but need a second entry.)
Public property | ColorNumber | The color number stored in value.
Public property | CutColorNumber | The cut color number stored in value.
Public property | CutLayerName | The cut layer name stored in value.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LayerName | The layer name stored in value.
Top
See Also

Reference

ExportLayerInfo Class


ExportLayerInfo.CategoryType Property

ExportLayerInfoCategoryType Property

The category type which this layer belongs to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LayerCategoryType CategoryType { get; set; }
Public Property CategoryType As LayerCategoryType
    Get
    Set
public:
property LayerCategoryType CategoryType {
    LayerCategoryType get ();
    void set (LayerCategoryType value);
}
member CategoryType : LayerCategoryType with get, set

Property Value

LayerCategoryType
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ExportLayerInfo Class


ExportLayerInfo.ColorName Property

ExportLayerInfoColorName Property

The color name stored in value. For IFC export, the naming is to match the "colornumber" setting -- really, this stores a string that generates the colorNumber (for formats that don't use the color but need a second entry.)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ColorName { get; set; }
Public Property ColorName As String
    Get
    Set
public:
property String^ ColorName {
    String^ get ();
    void set (String^ value);
}
member ColorName : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ExportLayerInfo Class


ExportLayerInfo.ColorNumber Property

ExportLayerInfoColorNumber Property

The color number stored in value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ColorNumber { get; set; }
Public Property ColorNumber As Integer
    Get
    Set
public:
property int ColorNumber {
    int get ();
    void set (int value);
}
member ColorNumber : int with get, set

Property Value

Int32
See Also

Reference

ExportLayerInfo Class


ExportLayerInfo.CutColorNumber Property

ExportLayerInfoCutColorNumber Property

The cut color number stored in value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int CutColorNumber { get; set; }
Public Property CutColorNumber As Integer
    Get
    Set
public:
property int CutColorNumber {
    int get ();
    void set (int value);
}
member CutColorNumber : int with get, set

Property Value

Int32
See Also

Reference

ExportLayerInfo Class


ExportLayerInfo.CutLayerName Property

ExportLayerInfoCutLayerName Property

The cut layer name stored in value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string CutLayerName { get; set; }
Public Property CutLayerName As String
    Get
    Set
public:
property String^ CutLayerName {
    String^ get ();
    void set (String^ value);
}
member CutLayerName : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ExportLayerInfo Class


ExportLayerInfo.IsValidObject Property

ExportLayerInfoIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ExportLayerInfo Class


ExportLayerInfo.LayerName Property

ExportLayerInfoLayerName Property

The layer name stored in value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string LayerName { get; set; }
Public Property LayerName As String
    Get
    Set
public:
property String^ LayerName {
    String^ get ();
    void set (String^ value);
}
member LayerName : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ExportLayerInfo Class


ExportLayerInfo Methods

The ExportLayerInfo type exposes the following members.

Methods
 | Name | Description
Public method | AddCutLayerModifier | Adds a cut layer modifier to the layer info.
Public method | AddLayerModifier | Adds a project layer modifier to the layer info.
Public method | ClearCutLayerModifiers | Clears all the cut layer modifiers stored in the layer info.
Public method | ClearLayerModifiers | Clears all the project layer modifiers stored in the layer info.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCutLayerModifiers | Gets all the cut layer modifiers from the layer info.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLayerModifiers | Gets all the project layer modifiers from the layer info.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | RemoveCutLayerModifier | Removes a cut layer modifier from the layer info.
Public method | RemoveLayerModifier | Removes a project layer modifier from the layer info.
Public method | SetCutLayerModifiers | Sets a cut layer modifier array to the layer info.
Public method | SetLayerModifiers | Sets a project layer modifier array to the layer info.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportLayerInfo Class


ExportLayerInfo.AddCutLayerModifier Method

ExportLayerInfoAddCutLayerModifier Method

Adds a cut layer modifier to the layer info.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddCutLayerModifier(
    LayerModifier layerModifier
)
Public Sub AddCutLayerModifier (
    layerModifier As LayerModifier
)
public:
void AddCutLayerModifier(
    LayerModifier^ layerModifier
)
member AddCutLayerModifier :
        layerModifier : LayerModifier -> unit

Parameters

layerModifier LayerModifier
The cut layer modifier.
Exceptions
Exception | Condition
ArgumentException | The separator string contains one or more prohibited characters. -or- The modifier type already exists in the cut layer info.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportLayerInfo Class


ExportLayerInfo.AddLayerModifier Method

ExportLayerInfoAddLayerModifier Method

Adds a project layer modifier to the layer info.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddLayerModifier(
    LayerModifier layerModifier
)
Public Sub AddLayerModifier (
    layerModifier As LayerModifier
)
public:
void AddLayerModifier(
    LayerModifier^ layerModifier
)
member AddLayerModifier :
        layerModifier : LayerModifier -> unit

Parameters

layerModifier LayerModifier
The project layer modifier.
Exceptions
Exception | Condition
ArgumentException | The separator string contains one or more prohibited characters. -or- The modifier type already exists in the layer info.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportLayerInfo Class


ExportLayerInfo.ClearCutLayerModifiers Method

ExportLayerInfoClearCutLayerModifiers Method

Clears all the cut layer modifiers stored in the layer info.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ClearCutLayerModifiers()
Public Sub ClearCutLayerModifiers
public:
void ClearCutLayerModifiers()
member ClearCutLayerModifiers : unit -> unit
See Also

Reference

ExportLayerInfo Class


ExportLayerInfo.ClearLayerModifiers Method

ExportLayerInfoClearLayerModifiers Method

Clears all the project layer modifiers stored in the layer info.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ClearLayerModifiers()
Public Sub ClearLayerModifiers
public:
void ClearLayerModifiers()
member ClearLayerModifiers : unit -> unit
See Also

Reference

ExportLayerInfo Class


ExportLayerInfo.Dispose Method

ExportLayerInfoDispose Method

Releases all resources used by the ExportLayerInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ExportLayerInfo Class


ExportLayerInfo.GetCutLayerModifiers Method

ExportLayerInfoGetCutLayerModifiers Method

Gets all the cut layer modifiers from the layer info.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<LayerModifier> GetCutLayerModifiers()
Public Function GetCutLayerModifiers As IList(Of LayerModifier)
public:
IList<LayerModifier^>^ GetCutLayerModifiers()
member GetCutLayerModifiers : unit -> IList<LayerModifier>

Return Value

IList LayerModifier
The cut layer modifier array.
See Also

Reference

ExportLayerInfo Class


ExportLayerInfo.GetLayerModifiers Method

ExportLayerInfoGetLayerModifiers Method

Gets all the project layer modifiers from the layer info.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<LayerModifier> GetLayerModifiers()
Public Function GetLayerModifiers As IList(Of LayerModifier)
public:
IList<LayerModifier^>^ GetLayerModifiers()
member GetLayerModifiers : unit -> IList<LayerModifier>

Return Value

IList LayerModifier
The project layer modifier array.
See Also

Reference

ExportLayerInfo Class


ExportLayerInfo.RemoveCutLayerModifier Method

ExportLayerInfoRemoveCutLayerModifier Method

Removes a cut layer modifier from the layer info.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveCutLayerModifier(
    LayerModifier layerModifier
)
Public Sub RemoveCutLayerModifier (
    layerModifier As LayerModifier
)
public:
void RemoveCutLayerModifier(
    LayerModifier^ layerModifier
)
member RemoveCutLayerModifier :
        layerModifier : LayerModifier -> unit

Parameters

layerModifier LayerModifier
The cut layer modifier.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportLayerInfo Class


ExportLayerInfo.RemoveLayerModifier Method

ExportLayerInfoRemoveLayerModifier Method

Removes a project layer modifier from the layer info.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveLayerModifier(
    LayerModifier layerModifier
)
Public Sub RemoveLayerModifier (
    layerModifier As LayerModifier
)
public:
void RemoveLayerModifier(
    LayerModifier^ layerModifier
)
member RemoveLayerModifier :
        layerModifier : LayerModifier -> unit

Parameters

layerModifier LayerModifier
The project layer modifier.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportLayerInfo Class


ExportLayerInfo.SetCutLayerModifiers Method

ExportLayerInfoSetCutLayerModifiers Method

Sets a cut layer modifier array to the layer info.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetCutLayerModifiers(
    IList<LayerModifier> cutLayermodifiers
)
Public Sub SetCutLayerModifiers (
    cutLayermodifiers As IList(Of LayerModifier)
)
public:
void SetCutLayerModifiers(
    IList<LayerModifier^>^ cutLayermodifiers
)
member SetCutLayerModifiers :
        cutLayermodifiers : IList<LayerModifier> -> unit

Parameters

cutLayermodifiers IList LayerModifier
The cut layer modifier array.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportLayerInfo Class


ExportLayerInfo.SetLayerModifiers Method

ExportLayerInfoSetLayerModifiers Method

Sets a project layer modifier array to the layer info.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetLayerModifiers(
    IList<LayerModifier> layermodifiers
)
Public Sub SetLayerModifiers (
    layermodifiers As IList(Of LayerModifier)
)
public:
void SetLayerModifiers(
    IList<LayerModifier^>^ layermodifiers
)
member SetLayerModifiers :
        layermodifiers : IList<LayerModifier> -> unit

Parameters

layermodifiers IList LayerModifier
The project layer modifier array.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportLayerInfo Class


ExportLayerKey Class

A key used to represent an item stored in an ExportLayerTable.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExportLayerKey

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExportLayerKey : IDisposable
Public Class ExportLayerKey
    Implements IDisposable
public ref class ExportLayerKey : IDisposable
type ExportLayerKey =
    class
        interface IDisposable
    end

The ExportLayerKey type exposes the following members.

Constructors
 | Name | Description
Public method | ExportLayerKey | Constructs a new ExportLayerKey with default values.
Public method | ExportLayerKey(String, String, SpecialType) | Constructs a new ExportLayerKey with categoryName, subCategoryName and a special type.
Top
Properties
 | Name | Description
Public property | CategoryName | The category name.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SpecialType | The special type for layer key.
Public property | SubCategoryName | The subcategrory Name.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ExportLayerKey
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExportLayerKey Constructor

Overload List
 | Name | Description
Public method | ExportLayerKey | Constructs a new ExportLayerKey with default values.
Public method | ExportLayerKey(String, String, SpecialType) | Constructs a new ExportLayerKey with categoryName, subCategoryName and a special type.
Top
See Also

Reference

ExportLayerKey Class


ExportLayerKey Constructor

Constructs a new ExportLayerKey with default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportLayerKey()
Public Sub New
public:
ExportLayerKey()
new : unit -> ExportLayerKey
See Also

Reference

ExportLayerKey Class
ExportLayerKey Overload


ExportLayerKey(String, String, SpecialType) Constructor

Constructs a new ExportLayerKey with categoryName, subCategoryName and a special type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportLayerKey(
    string categoryName,
    string subCategoryName,
    SpecialType num
)
Public Sub New (
    categoryName As String,
    subCategoryName As String,
    num As SpecialType
)
public:
ExportLayerKey(
    String^ categoryName,
    String^ subCategoryName,
    SpecialType num
)
new :
        categoryName : string *
        subCategoryName : string *
        num : SpecialType -> ExportLayerKey

Parameters

categoryName String
The category name for the layer key.
subCategoryName String
The subCategoryName for the layer key.
num SpecialType
The special type for layer key.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ExportLayerKey Class
ExportLayerKey Overload


ExportLayerKey Properties

The ExportLayerKey type exposes the following members.

Properties
 | Name | Description
Public property | CategoryName | The category name.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SpecialType | The special type for layer key.
Public property | SubCategoryName | The subcategrory Name.
Top
See Also

Reference

ExportLayerKey Class


ExportLayerKey.CategoryName Property

ExportLayerKeyCategoryName Property

The category name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string CategoryName { get; set; }
Public Property CategoryName As String
    Get
    Set
public:
property String^ CategoryName {
    String^ get ();
    void set (String^ value);
}
member CategoryName : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ExportLayerKey Class


ExportLayerKey.IsValidObject Property

ExportLayerKeyIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ExportLayerKey Class


ExportLayerKey.SpecialType Property

ExportLayerKeySpecialType Property

The special type for layer key.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SpecialType SpecialType { get; set; }
Public Property SpecialType As SpecialType
    Get
    Set
public:
property SpecialType SpecialType {
    SpecialType get ();
    void set (SpecialType value);
}
member SpecialType : SpecialType with get, set

Property Value

SpecialType
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ExportLayerKey Class


ExportLayerKey.SubCategoryName Property

ExportLayerKeySubCategoryName Property

The subcategrory Name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SubCategoryName { get; set; }
Public Property SubCategoryName As String
    Get
    Set
public:
property String^ SubCategoryName {
    String^ get ();
    void set (String^ value);
}
member SubCategoryName : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ExportLayerKey Class


ExportLayerKey Methods

The ExportLayerKey type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportLayerKey Class


ExportLayerKey.Dispose Method

ExportLayerKeyDispose Method

Releases all resources used by the ExportLayerKey

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ExportLayerKey Class


ExportLayerTable Class

A table supporting a mapping of category and subcategory to layer name and other layer properties that will be set in the target export format.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExportLayerTable

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExportLayerTable : IEnumerable<KeyValuePair<ExportLayerKey, ExportLayerInfo>>,
    IDisposable
Public Class ExportLayerTable
    Implements IEnumerable(Of KeyValuePair(Of ExportLayerKey, ExportLayerInfo)),
    IDisposable
public ref class ExportLayerTable : IEnumerable<KeyValuePair<ExportLayerKey^, ExportLayerInfo^>>,
    IDisposable
type ExportLayerTable =
    class
        interface IEnumerable<KeyValuePair<ExportLayerKey, ExportLayerInfo>>
        interface IDisposable
    end

The ExportLayerTable type exposes the following members.

Constructors
 | Name | Description
Public method | ExportLayerTable | Constructs a new ExportLayerTable with default values.
Top
Properties
 | Name | Description
Public property | Count | Count of the items contained in the collection.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Item | A copy of the ExportLayerInfo item that corresponds to the layer's ExportLayerKey.
Top
Methods
 | Name | Description
Public method | Add | Inserts a (key,info) pair into Export layer table.
Public method | Clear | Removes all contents stored in the table.
Public method | ContainsKey | Checks whether a layer key exists in the table.
Public method | Dispose | Releases all resources used by the ExportLayerTable
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | GetAvaliableLayerModifierTypes | Gets all the avaliable layer modifier types for the layer key.
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetExportLayerInfo | Gets a copy of the layer info associated to the input pattern key.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetKeys | Gets all the keys stored in the map.
Public method | GetLayerTableIterator | Returns a LayerTableIterator that iterates through the collection.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetValues | Returns all the values stored in the map.
Public method | Remove | Removes the pair (key, info) by pattern key.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

This table is structured as a mapping from ExportLayerKey to ExportLayerInfo members. The ExportLayerKey contains the identification information for the layer table: the Revit category and subcategory names. In addition, the key contains a SpecialType member used only to represent non-Revit categories that can be assigned specific layer information on export. The ExportLayerInfo contains the exported layer name, color name, and layer modifiers for standard and cut representations.

The table can be accessed via direct iteration as a collection of KeyValuePairs, or by traversal of the stored keys obtained from GetKeys(), or via specific lookup of a key constructed externally. In all cases, the ExportLayerInfo returned will be a copy of the ExportLayerInfo from the table. In order to make changes to the ExportLayerInfo and use those settings during export, set the modified ExportLayerInfo back into the table using the same key.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExportLayerTable Constructor

Constructs a new ExportLayerTable with default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportLayerTable()
Public Sub New
public:
ExportLayerTable()
new : unit -> ExportLayerTable
See Also

Reference

ExportLayerTable Class


ExportLayerTable Properties

The ExportLayerTable type exposes the following members.

Properties
 | Name | Description
Public property | Count | Count of the items contained in the collection.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Item | A copy of the ExportLayerInfo item that corresponds to the layer's ExportLayerKey.
Top
See Also

Reference

ExportLayerTable Class


ExportLayerTable.Count Property

ExportLayerTableCount Property

Count of the items contained in the collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
member Count : int with get

Property Value

Int32
See Also

Reference

ExportLayerTable Class


ExportLayerTable.IsValidObject Property

ExportLayerTableIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ExportLayerTable Class


ExportLayerTable.Item Property

ExportLayerTableItem Property

A copy of the ExportLayerInfo item that corresponds to the layer's ExportLayerKey.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportLayerInfo this[
    ExportLayerKey layerKey
] { get; set; }
Public Default Property Item (
    layerKey As ExportLayerKey
) As ExportLayerInfo
    Get
    Set
public:
virtual property ExportLayerInfo^ default[ExportLayerKey^ layerKey] {
    ExportLayerInfo^ get (ExportLayerKey^ layerKey) sealed;
    void set (ExportLayerKey^ layerKey, ExportLayerInfo^ value) sealed;
}
abstract Item : ExportLayerInfo with get, set
override Item : ExportLayerInfo with get, set

Parameters

layerKey ExportLayerKey

Return Value

ExportLayerInfo
A copy of the ExportLayerInfo for the layer Key.
Exceptions
Exception | Condition
ArgumentException | When getting this property: An entry with the given key is not present in the table.
Remarks
When getting this property, it returns a copy of the ExportLayerInfo from the table. In order to make changes to the ExportLayerInfo and use those settings during export, set the modified ExportLayerInfo back into the table using the same key.
See Also

Reference

ExportLayerTable Class


ExportLayerTable Methods

The ExportLayerTable type exposes the following members.

Methods
 | Name | Description
Public method | Add | Inserts a (key,info) pair into Export layer table.
Public method | Clear | Removes all contents stored in the table.
Public method | ContainsKey | Checks whether a layer key exists in the table.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | GetAvaliableLayerModifierTypes | Gets all the avaliable layer modifier types for the layer key.
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetExportLayerInfo | Gets a copy of the layer info associated to the input pattern key.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetKeys | Gets all the keys stored in the map.
Public method | GetLayerTableIterator | Returns a LayerTableIterator that iterates through the collection.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetValues | Returns all the values stored in the map.
Public method | Remove | Removes the pair (key, info) by pattern key.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportLayerTable Class


ExportLayerTable.Add Method

ExportLayerTableAdd Method

Inserts a (key,info) pair into Export layer table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Add(
    ExportLayerKey exportLayerKey,
    ExportLayerInfo exportLayerInfo
)
Public Sub Add (
    exportLayerKey As ExportLayerKey,
    exportLayerInfo As ExportLayerInfo
)
public:
void Add(
    ExportLayerKey^ exportLayerKey,
    ExportLayerInfo^ exportLayerInfo
)
member Add :
        exportLayerKey : ExportLayerKey *
        exportLayerInfo : ExportLayerInfo -> unit

Parameters

exportLayerKey ExportLayerKey
The export layer key to be added.
exportLayerInfo ExportLayerInfo
The export layer info to be added.
Exceptions
Exception | Condition
ArgumentException | The key already exists in the table. -or- The layer info does not contain the Category as a modifier type.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportLayerTable Class


ExportLayerTable.Clear Method

ExportLayerTableClear Method

Removes all contents stored in the table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

ExportLayerTable Class


ExportLayerTable.ContainsKey Method

ExportLayerTableContainsKey Method

Checks whether a layer key exists in the table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ContainsKey(
    ExportLayerKey exportlayerKey
)
Public Function ContainsKey (
    exportlayerKey As ExportLayerKey
) As Boolean
public:
bool ContainsKey(
    ExportLayerKey^ exportlayerKey
)
member ContainsKey :
        exportlayerKey : ExportLayerKey -> bool

Parameters

exportlayerKey ExportLayerKey
The export layer Key.

Return Value

Boolean
True if the layer key exists in the table.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportLayerTable Class


ExportLayerTable.Dispose Method

ExportLayerTableDispose Method

Releases all resources used by the ExportLayerTable

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ExportLayerTable Class


ExportLayerTable.GetAvaliableLayerModifierTypes Method

ExportLayerTableGetAvaliableLayerModifierTypes Method

Gets all the avaliable layer modifier types for the layer key.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<ModifierType> GetAvaliableLayerModifierTypes(
    Document document,
    ExportLayerKey exportLayerKey
)
Public Shared Function GetAvaliableLayerModifierTypes (
    document As Document,
    exportLayerKey As ExportLayerKey
) As IList(Of ModifierType)
public:
static IList<ModifierType>^ GetAvaliableLayerModifierTypes(
    Document^ document,
    ExportLayerKey^ exportLayerKey
)
static member GetAvaliableLayerModifierTypes :
        document : Document *
        exportLayerKey : ExportLayerKey -> IList<ModifierType>

Parameters

document Document
A Revit document to retrieve avaliable layer modifier types from.
exportLayerKey ExportLayerKey
The export layer key to specify wich category and subCategory will be used to get the layer modifier types.

Return Value

IList ModifierType
The layer modifier types.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was NULL
See Also

Reference

ExportLayerTable Class


ExportLayerTable.GetBasicIEnumerator Method

ExportLayerTableGetBasicIEnumerator Method

Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
internal virtual IEnumerator GetBasicIEnumerator()
Friend Overridable Function GetBasicIEnumerator As IEnumerator
internal:
virtual IEnumerator^ GetBasicIEnumerator()
internal abstract GetBasicIEnumerator : unit -> IEnumerator
internal override GetBasicIEnumerator : unit -> IEnumerator

Return Value

IEnumerator
An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerableGetEnumerator
See Also

Reference

ExportLayerTable Class


ExportLayerTable.GetEnumerator Method

ExportLayerTableGetEnumerator Method

Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator<KeyValuePair<ExportLayerKey, ExportLayerInfo>> GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator(Of KeyValuePair(Of ExportLayerKey, ExportLayerInfo))
public:
virtual IEnumerator<KeyValuePair<ExportLayerKey^, ExportLayerInfo^>>^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator<KeyValuePair<ExportLayerKey, ExportLayerInfo>>
override GetEnumerator : unit -> IEnumerator<KeyValuePair<ExportLayerKey, ExportLayerInfo>>

Return Value

IEnumerator KeyValuePair ExportLayerKey, ExportLayerInfo
An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerableTGetEnumerator
See Also

Reference

ExportLayerTable Class


ExportLayerTable.GetExportLayerInfo Method

ExportLayerTableGetExportLayerInfo Method

Gets a copy of the layer info associated to the input pattern key.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportLayerInfo GetExportLayerInfo(
    ExportLayerKey exportLayerKey
)
Public Function GetExportLayerInfo (
    exportLayerKey As ExportLayerKey
) As ExportLayerInfo
public:
ExportLayerInfo^ GetExportLayerInfo(
    ExportLayerKey^ exportLayerKey
)
member GetExportLayerInfo :
        exportLayerKey : ExportLayerKey -> ExportLayerInfo

Parameters

exportLayerKey ExportLayerKey
The export layer Key.

Return Value

ExportLayerInfo
Return the layerInfo for this key.
Exceptions
Exception | Condition
ArgumentException | An entry with the given key is not present in the table.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportLayerTable Class


ExportLayerTable.GetKeys Method

ExportLayerTableGetKeys Method

Gets all the keys stored in the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ExportLayerKey> GetKeys()
Public Function GetKeys As IList(Of ExportLayerKey)
public:
IList<ExportLayerKey^>^ GetKeys()
member GetKeys : unit -> IList<ExportLayerKey>

Return Value

IList ExportLayerKey
Return the key array.
See Also

Reference

ExportLayerTable Class


ExportLayerTable.GetLayerTableIterator Method

ExportLayerTableGetLayerTableIterator Method

Returns a LayerTableIterator that iterates through the collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportLayerTableIterator GetLayerTableIterator()
Public Function GetLayerTableIterator As ExportLayerTableIterator
public:
ExportLayerTableIterator^ GetLayerTableIterator()
member GetLayerTableIterator : unit -> ExportLayerTableIterator

Return Value

ExportLayerTableIterator
A LayerTableIterator object that can be used to iterate through key-value pairs in the collection.
See Also

Reference

ExportLayerTable Class


ExportLayerTable.GetValues Method

ExportLayerTableGetValues Method

Returns all the values stored in the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ExportLayerInfo> GetValues()
Public Function GetValues As IList(Of ExportLayerInfo)
public:
IList<ExportLayerInfo^>^ GetValues()
member GetValues : unit -> IList<ExportLayerInfo>

Return Value

IList ExportLayerInfo
Return the info array.
See Also

Reference

ExportLayerTable Class


ExportLayerTable.Remove Method

ExportLayerTableRemove Method

Removes the pair (key, info) by pattern key.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Remove(
    ExportLayerKey exportLayerKey
)
Public Sub Remove (
    exportLayerKey As ExportLayerKey
)
public:
void Remove(
    ExportLayerKey^ exportLayerKey
)
member Remove :
        exportLayerKey : ExportLayerKey -> unit

Parameters

exportLayerKey ExportLayerKey
The export pattern key.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportLayerTable Class


ExportLayerTableIterator Class

An iterator to a set of Layer table.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExportLayerTableIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExportLayerTableIterator : IEnumerator<KeyValuePair<ExportLayerKey, ExportLayerInfo>>
Public Class ExportLayerTableIterator
    Implements IEnumerator(Of KeyValuePair(Of ExportLayerKey, ExportLayerInfo))
public ref class ExportLayerTableIterator : IEnumerator<KeyValuePair<ExportLayerKey^, ExportLayerInfo^>>
type ExportLayerTableIterator =
    class
        interface IEnumerator<KeyValuePair<ExportLayerKey, ExportLayerInfo>>
    end

The ExportLayerTableIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ExportLayerTableIterator
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next item.
Public method | Reset | Resets the iterator to the initial state.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExportLayerTableIterator Properties

The ExportLayerTableIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

ExportLayerTableIterator Class


ExportLayerTableIterator.Current Property

ExportLayerTableIteratorCurrent Property

Gets the item at the current position of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual KeyValuePair<ExportLayerKey, ExportLayerInfo> Current { get; }
Public Overridable ReadOnly Property Current As KeyValuePair(Of ExportLayerKey, ExportLayerInfo)
    Get
public:
virtual property KeyValuePair<ExportLayerKey^, ExportLayerInfo^> Current {
    KeyValuePair<ExportLayerKey^, ExportLayerInfo^> get ();
}
abstract Current : KeyValuePair<ExportLayerKey, ExportLayerInfo> with get
override Current : KeyValuePair<ExportLayerKey, ExportLayerInfo> with get

Property Value

KeyValuePair ExportLayerKey, ExportLayerInfo

Implements

IEnumeratorTCurrent
Exceptions
Exception | Condition
InvalidOperationException | There is no current item in the iterator.
Remarks
There is no current item if the iterator has not started yet or has been done.
See Also

Reference

ExportLayerTableIterator Class


ExportLayerTableIterator.CurrentObject Property

ExportLayerTableIteratorCurrentObject Property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
internal Object CurrentObject { get; }
Friend ReadOnly Property CurrentObject As Object
    Get
internal:
virtual property Object^ CurrentObject {
    Object^ get () sealed;
}
internal abstract CurrentObject : Object with get
internal override CurrentObject : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
See Also

Reference

ExportLayerTableIterator Class


ExportLayerTableIterator.IsValidObject Property

ExportLayerTableIteratorIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ExportLayerTableIterator Class


ExportLayerTableIterator Methods

The ExportLayerTableIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next item.
Public method | Reset | Resets the iterator to the initial state.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportLayerTableIterator Class


ExportLayerTableIterator.Dispose Method

ExportLayerTableIteratorDispose Method

Releases all resources used by the ExportLayerTableIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit
See Also

Reference

ExportLayerTableIterator Class


ExportLayerTableIterator.IsDone Method

ExportLayerTableIteratorIsDone Method

Identifies if the iteration has completed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsDone()
Public Overridable Function IsDone As Boolean
public:
virtual bool IsDone()
abstract IsDone : unit -> bool
override IsDone : unit -> bool

Return Value

Boolean
True if the iteration has no more items. False if there are more items to be iterated.
See Also

Reference

ExportLayerTableIterator Class


ExportLayerTableIterator.MoveNext Method

ExportLayerTableIteratorMoveNext Method

Increments the iterator to the next item.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
True if there is a next available item in this iterator. False if the iterator has completed all available items.
See Also

Reference

ExportLayerTableIterator Class


ExportLayerTableIterator.Reset Method

ExportLayerTableIteratorReset Method

Resets the iterator to the initial state.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit
See Also

Reference

ExportLayerTableIterator Class


ExportLinetypeInfo Class

A value used to represent the info stored in the ExportLinetypeTable.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExportLinetypeInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExportLinetypeInfo : IDisposable
Public Class ExportLinetypeInfo
    Implements IDisposable
public ref class ExportLinetypeInfo : IDisposable
type ExportLinetypeInfo =
    class
        interface IDisposable
    end

The ExportLinetypeInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ExportLinetypeInfo | Constructs a new default ExportLinetypeInfo.
Public method | ExportLinetypeInfo(ExportLinetypeInfo) | Constructs a new copy of the input ExportLinetypeInfo object.
Public method | ExportLinetypeInfo(String) | Constructs a new ExportLinetypeInfo using the destination linetype name as input.
Top
Properties
 | Name | Description
Public property | DestinationLinetypeName | The destination linetype name (the name of the linetype in the exported format).
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ExportLinetypeInfo
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExportLinetypeInfo Constructor

Overload List
 | Name | Description
Public method | ExportLinetypeInfo | Constructs a new default ExportLinetypeInfo.
Public method | ExportLinetypeInfo(ExportLinetypeInfo) | Constructs a new copy of the input ExportLinetypeInfo object.
Public method | ExportLinetypeInfo(String) | Constructs a new ExportLinetypeInfo using the destination linetype name as input.
Top
See Also

Reference

ExportLinetypeInfo Class


ExportLinetypeInfo Constructor

Constructs a new default ExportLinetypeInfo.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportLinetypeInfo()
Public Sub New
public:
ExportLinetypeInfo()
new : unit -> ExportLinetypeInfo
See Also

Reference

ExportLinetypeInfo Class
ExportLinetypeInfo Overload


ExportLinetypeInfo(ExportLinetypeInfo) Constructor

Constructs a new copy of the input ExportLinetypeInfo object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportLinetypeInfo(
    ExportLinetypeInfo other
)
Public Sub New (
    other As ExportLinetypeInfo
)
public:
ExportLinetypeInfo(
    ExportLinetypeInfo^ other
)
new :
        other : ExportLinetypeInfo -> ExportLinetypeInfo

Parameters

other ExportLinetypeInfo
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportLinetypeInfo Class
ExportLinetypeInfo Overload


ExportLinetypeInfo(String) Constructor

Constructs a new ExportLinetypeInfo using the destination linetype name as input.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportLinetypeInfo(
    string destinationLinetypeName
)
Public Sub New (
    destinationLinetypeName As String
)
public:
ExportLinetypeInfo(
    String^ destinationLinetypeName
)
new :
        destinationLinetypeName : string -> ExportLinetypeInfo

Parameters

destinationLinetypeName String
The destination line type name (the name of the linetype in the exported format).
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportLinetypeInfo Class
ExportLinetypeInfo Overload


ExportLinetypeInfo Properties

The ExportLinetypeInfo type exposes the following members.

Properties
 | Name | Description
Public property | DestinationLinetypeName | The destination linetype name (the name of the linetype in the exported format).
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

ExportLinetypeInfo Class


ExportLinetypeInfo.DestinationLinetypeName Property

ExportLinetypeInfoDestinationLinetypeName Property

The destination linetype name (the name of the linetype in the exported format).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string DestinationLinetypeName { get; set; }
Public Property DestinationLinetypeName As String
    Get
    Set
public:
property String^ DestinationLinetypeName {
    String^ get ();
    void set (String^ value);
}
member DestinationLinetypeName : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ExportLinetypeInfo Class


ExportLinetypeInfo.IsValidObject Property

ExportLinetypeInfoIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ExportLinetypeInfo Class


ExportLinetypeInfo Methods

The ExportLinetypeInfo type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportLinetypeInfo Class


ExportLinetypeInfo.Dispose Method

ExportLinetypeInfoDispose Method

Releases all resources used by the ExportLinetypeInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ExportLinetypeInfo Class


ExportLinetypeKey Class

A key used to represent an item stored in an ExportLinetypeTable.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExportLinetypeKey

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExportLinetypeKey : IDisposable
Public Class ExportLinetypeKey
    Implements IDisposable
public ref class ExportLinetypeKey : IDisposable
type ExportLinetypeKey =
    class
        interface IDisposable
    end

The ExportLinetypeKey type exposes the following members.

Constructors
 | Name | Description
Public method | ExportLinetypeKey | Constructs a new default ExportLinetypeKey.
Public method | ExportLinetypeKey(ExportLinetypeKey) | Constructs a new copy of the input ExportLinetypeKey object.
Public method | ExportLinetypeKey(String) | Constructs a new default ExportLinetypeKey using the original line type name as input.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OriginalLinetypeName | The original linetype name.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ExportLinetypeKey
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExportLinetypeKey Constructor

Overload List
 | Name | Description
Public method | ExportLinetypeKey | Constructs a new default ExportLinetypeKey.
Public method | ExportLinetypeKey(ExportLinetypeKey) | Constructs a new copy of the input ExportLinetypeKey object.
Public method | ExportLinetypeKey(String) | Constructs a new default ExportLinetypeKey using the original line type name as input.
Top
See Also

Reference

ExportLinetypeKey Class


ExportLinetypeKey Constructor

Constructs a new default ExportLinetypeKey.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportLinetypeKey()
Public Sub New
public:
ExportLinetypeKey()
new : unit -> ExportLinetypeKey
See Also

Reference

ExportLinetypeKey Class
ExportLinetypeKey Overload


ExportLinetypeKey(ExportLinetypeKey) Constructor

Constructs a new copy of the input ExportLinetypeKey object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportLinetypeKey(
    ExportLinetypeKey other
)
Public Sub New (
    other As ExportLinetypeKey
)
public:
ExportLinetypeKey(
    ExportLinetypeKey^ other
)
new :
        other : ExportLinetypeKey -> ExportLinetypeKey

Parameters

other ExportLinetypeKey
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportLinetypeKey Class
ExportLinetypeKey Overload


ExportLinetypeKey(String) Constructor

Constructs a new default ExportLinetypeKey using the original line type name as input.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportLinetypeKey(
    string originalLinetypeName
)
Public Sub New (
    originalLinetypeName As String
)
public:
ExportLinetypeKey(
    String^ originalLinetypeName
)
new :
        originalLinetypeName : string -> ExportLinetypeKey

Parameters

originalLinetypeName String
The original line type name.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportLinetypeKey Class
ExportLinetypeKey Overload


ExportLinetypeKey Properties

The ExportLinetypeKey type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OriginalLinetypeName | The original linetype name.
Top
See Also

Reference

ExportLinetypeKey Class


ExportLinetypeKey.IsValidObject Property

ExportLinetypeKeyIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ExportLinetypeKey Class


ExportLinetypeKey.OriginalLinetypeName Property

ExportLinetypeKeyOriginalLinetypeName Property

The original linetype name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string OriginalLinetypeName { get; set; }
Public Property OriginalLinetypeName As String
    Get
    Set
public:
property String^ OriginalLinetypeName {
    String^ get ();
    void set (String^ value);
}
member OriginalLinetypeName : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ExportLinetypeKey Class


ExportLinetypeKey Methods

The ExportLinetypeKey type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportLinetypeKey Class


ExportLinetypeKey.Dispose Method

ExportLinetypeKeyDispose Method

Releases all resources used by the ExportLinetypeKey

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ExportLinetypeKey Class


ExportLinetypeTable Class

A table supporting a mapping of linetypes in Revit to linetype names that will be set in the target export format.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExportLinetypeTable

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExportLinetypeTable : IEnumerable<KeyValuePair<ExportLinetypeKey, ExportLinetypeInfo>>,
    IDisposable
Public Class ExportLinetypeTable
    Implements IEnumerable(Of KeyValuePair(Of ExportLinetypeKey, ExportLinetypeInfo)),
    IDisposable
public ref class ExportLinetypeTable : IEnumerable<KeyValuePair<ExportLinetypeKey^, ExportLinetypeInfo^>>,
    IDisposable
type ExportLinetypeTable =
    class
        interface IEnumerable<KeyValuePair<ExportLinetypeKey, ExportLinetypeInfo>>
        interface IDisposable
    end

The ExportLinetypeTable type exposes the following members.

Constructors
 | Name | Description
Public method | ExportLinetypeTable | Constructs a new ExportLinetypeTable with default values.
Top
Properties
 | Name | Description
Public property | Count | Count of the items contained in the collection.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Item | A copy of the ExportLinetypeInfo for the linetype's ExportLinetypeKey.
Top
Methods
 | Name | Description
Public method | Add | Inserts a (key, info) pair into Export line type table.
Public method | Clear | Removes all contents stored in Export line type table.
Public method | ContainsKey | Checks whether a pattern key exists in the table.
Public method | Dispose | Releases all resources used by the ExportLinetypeTable
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetExportLinetypeInfo | Gets a copy of the ExportLinetypeInfo corresponding to the given ExportLinetypeKey.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetKeys | Gets all the keys stored in the map.
Public method | GetLinetypeTableIterator | Returns a ExportLinetypeTableIterator that iterates through the collection.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetValues | Returns all the values stored in the map.
Public method | Remove | Removes the pair (key, info) corresponding to the given ExportLinetypeKey.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

This table is structured as a mapping from ExportLinetypeKey to ExportLinetypeInfo members. The ExportLinetypeKey contains the identification information for the pattern table: the Revit linetype name. The ExportLinetypeInfo contains the linetype name to use in the export format.

The table can be accessed via direct iteration as a collection of KeyValuePairs, or by traversal of the stored keys obtained from GetKeys(), or via specific lookup of a key constructed externally. In all cases, the ExportLinetypeInfo returned will be a copy of the ExportLinetypeInfo from the table. In order to make changes to the ExportLinetypeInfo and use those settings during export, set the modified ExportLinetypeInfo back into the table using the same key.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExportLinetypeTable Constructor

Constructs a new ExportLinetypeTable with default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportLinetypeTable()
Public Sub New
public:
ExportLinetypeTable()
new : unit -> ExportLinetypeTable
See Also

Reference

ExportLinetypeTable Class


ExportLinetypeTable Properties

The ExportLinetypeTable type exposes the following members.

Properties
 | Name | Description
Public property | Count | Count of the items contained in the collection.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Item | A copy of the ExportLinetypeInfo for the linetype's ExportLinetypeKey.
Top
See Also

Reference

ExportLinetypeTable Class


ExportLinetypeTable.Count Property

ExportLinetypeTableCount Property

Count of the items contained in the collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
member Count : int with get

Property Value

Int32
See Also

Reference

ExportLinetypeTable Class


ExportLinetypeTable.IsValidObject Property

ExportLinetypeTableIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ExportLinetypeTable Class


ExportLinetypeTable.Item Property

ExportLinetypeTableItem Property

A copy of the ExportLinetypeInfo for the linetype's ExportLinetypeKey.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportLinetypeInfo this[
    ExportLinetypeKey linetypeKey
] { get; set; }
Public Default Property Item (
    linetypeKey As ExportLinetypeKey
) As ExportLinetypeInfo
    Get
    Set
public:
virtual property ExportLinetypeInfo^ default[ExportLinetypeKey^ linetypeKey] {
    ExportLinetypeInfo^ get (ExportLinetypeKey^ linetypeKey) sealed;
    void set (ExportLinetypeKey^ linetypeKey, ExportLinetypeInfo^ value) sealed;
}
abstract Item : ExportLinetypeInfo with get, set
override Item : ExportLinetypeInfo with get, set

Parameters

linetypeKey ExportLinetypeKey

Return Value

ExportLinetypeInfo
A copy of the ExportLinetypeInfo.
Exceptions
Exception | Condition
ArgumentException | When getting this property: An entry with the given key is not present in the table.
Remarks
When getting this property, it returns a copy of the ExportLinetypeInfo from the table. In order to make changes to the ExportLinetypeInfo and use those settings during export, set the modified ExportLinetypeInfo back into the table using the same key.
See Also

Reference

ExportLinetypeTable Class


ExportLinetypeTable Methods

The ExportLinetypeTable type exposes the following members.

Methods
 | Name | Description
Public method | Add | Inserts a (key, info) pair into Export line type table.
Public method | Clear | Removes all contents stored in Export line type table.
Public method | ContainsKey | Checks whether a pattern key exists in the table.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetExportLinetypeInfo | Gets a copy of the ExportLinetypeInfo corresponding to the given ExportLinetypeKey.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetKeys | Gets all the keys stored in the map.
Public method | GetLinetypeTableIterator | Returns a ExportLinetypeTableIterator that iterates through the collection.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetValues | Returns all the values stored in the map.
Public method | Remove | Removes the pair (key, info) corresponding to the given ExportLinetypeKey.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportLinetypeTable Class


ExportLinetypeTable.Add Method

ExportLinetypeTableAdd Method

Inserts a (key, info) pair into Export line type table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Add(
    ExportLinetypeKey exportLinetypeKey,
    ExportLinetypeInfo exportLinetypeInfo
)
Public Sub Add (
    exportLinetypeKey As ExportLinetypeKey,
    exportLinetypeInfo As ExportLinetypeInfo
)
public:
void Add(
    ExportLinetypeKey^ exportLinetypeKey,
    ExportLinetypeInfo^ exportLinetypeInfo
)
member Add :
        exportLinetypeKey : ExportLinetypeKey *
        exportLinetypeInfo : ExportLinetypeInfo -> unit

Parameters

exportLinetypeKey ExportLinetypeKey
The export line type Key to be added.
exportLinetypeInfo ExportLinetypeInfo
The export line type info to be added.
Exceptions
Exception | Condition
ArgumentException | The key already exists in the table.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportLinetypeTable Class


ExportLinetypeTable.Clear Method

ExportLinetypeTableClear Method

Removes all contents stored in Export line type table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

ExportLinetypeTable Class


ExportLinetypeTable.ContainsKey Method

ExportLinetypeTableContainsKey Method

Checks whether a pattern key exists in the table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ContainsKey(
    ExportLinetypeKey exportLinetypeKey
)
Public Function ContainsKey (
    exportLinetypeKey As ExportLinetypeKey
) As Boolean
public:
bool ContainsKey(
    ExportLinetypeKey^ exportLinetypeKey
)
member ContainsKey :
        exportLinetypeKey : ExportLinetypeKey -> bool

Parameters

exportLinetypeKey ExportLinetypeKey
The export line type key.

Return Value

Boolean
True if the line type exists in the table.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportLinetypeTable Class


ExportLinetypeTable.Dispose Method

ExportLinetypeTableDispose Method

Releases all resources used by the ExportLinetypeTable

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ExportLinetypeTable Class


ExportLinetypeTable.GetBasicIEnumerator Method

ExportLinetypeTableGetBasicIEnumerator Method

Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
internal virtual IEnumerator GetBasicIEnumerator()
Friend Overridable Function GetBasicIEnumerator As IEnumerator
internal:
virtual IEnumerator^ GetBasicIEnumerator()
internal abstract GetBasicIEnumerator : unit -> IEnumerator
internal override GetBasicIEnumerator : unit -> IEnumerator

Return Value

IEnumerator
An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerableGetEnumerator
See Also

Reference

ExportLinetypeTable Class


ExportLinetypeTable.GetEnumerator Method

ExportLinetypeTableGetEnumerator Method

Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator<KeyValuePair<ExportLinetypeKey, ExportLinetypeInfo>> GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator(Of KeyValuePair(Of ExportLinetypeKey, ExportLinetypeInfo))
public:
virtual IEnumerator<KeyValuePair<ExportLinetypeKey^, ExportLinetypeInfo^>>^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator<KeyValuePair<ExportLinetypeKey, ExportLinetypeInfo>>
override GetEnumerator : unit -> IEnumerator<KeyValuePair<ExportLinetypeKey, ExportLinetypeInfo>>

Return Value

IEnumerator KeyValuePair ExportLinetypeKey, ExportLinetypeInfo
An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerableTGetEnumerator
See Also

Reference

ExportLinetypeTable Class


ExportLinetypeTable.GetExportLinetypeInfo Method

ExportLinetypeTableGetExportLinetypeInfo Method

Gets a copy of the ExportLinetypeInfo corresponding to the given ExportLinetypeKey.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportLinetypeInfo GetExportLinetypeInfo(
    ExportLinetypeKey exportLinetypeKey
)
Public Function GetExportLinetypeInfo (
    exportLinetypeKey As ExportLinetypeKey
) As ExportLinetypeInfo
public:
ExportLinetypeInfo^ GetExportLinetypeInfo(
    ExportLinetypeKey^ exportLinetypeKey
)
member GetExportLinetypeInfo :
        exportLinetypeKey : ExportLinetypeKey -> ExportLinetypeInfo

Parameters

exportLinetypeKey ExportLinetypeKey
The export line type Key.

Return Value

ExportLinetypeInfo
Returns the line type info for this key.
Exceptions
Exception | Condition
ArgumentException | An entry with the given key is not present in the table.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportLinetypeTable Class


ExportLinetypeTable.GetKeys Method

ExportLinetypeTableGetKeys Method

Gets all the keys stored in the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ExportLinetypeKey> GetKeys()
Public Function GetKeys As IList(Of ExportLinetypeKey)
public:
IList<ExportLinetypeKey^>^ GetKeys()
member GetKeys : unit -> IList<ExportLinetypeKey>

Return Value

IList ExportLinetypeKey
The keys.
See Also

Reference

ExportLinetypeTable Class


ExportLinetypeTable.GetLinetypeTableIterator Method

ExportLinetypeTableGetLinetypeTableIterator Method

Returns a ExportLinetypeTableIterator that iterates through the collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportLinetypeTableIterator GetLinetypeTableIterator()
Public Function GetLinetypeTableIterator As ExportLinetypeTableIterator
public:
ExportLinetypeTableIterator^ GetLinetypeTableIterator()
member GetLinetypeTableIterator : unit -> ExportLinetypeTableIterator

Return Value

ExportLinetypeTableIterator
A ExportLinetypeTableIterator object that can be used to iterate through key-value pairs in the collection.
See Also

Reference

ExportLinetypeTable Class


ExportLinetypeTable.GetValues Method

ExportLinetypeTableGetValues Method

Returns all the values stored in the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ExportLinetypeInfo> GetValues()
Public Function GetValues As IList(Of ExportLinetypeInfo)
public:
IList<ExportLinetypeInfo^>^ GetValues()
member GetValues : unit -> IList<ExportLinetypeInfo>

Return Value

IList ExportLinetypeInfo
The info.
See Also

Reference

ExportLinetypeTable Class


ExportLinetypeTable.Remove Method

ExportLinetypeTableRemove Method

Removes the pair (key, info) corresponding to the given ExportLinetypeKey.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Remove(
    ExportLinetypeKey exportLinetypeKey
)
Public Sub Remove (
    exportLinetypeKey As ExportLinetypeKey
)
public:
void Remove(
    ExportLinetypeKey^ exportLinetypeKey
)
member Remove :
        exportLinetypeKey : ExportLinetypeKey -> unit

Parameters

exportLinetypeKey ExportLinetypeKey
The export line type key
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportLinetypeTable Class


ExportLinetypeTableIterator Class

An iterator to a set of line type table.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExportLinetypeTableIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExportLinetypeTableIterator : IEnumerator<KeyValuePair<ExportLinetypeKey, ExportLinetypeInfo>>
Public Class ExportLinetypeTableIterator
    Implements IEnumerator(Of KeyValuePair(Of ExportLinetypeKey, ExportLinetypeInfo))
public ref class ExportLinetypeTableIterator : IEnumerator<KeyValuePair<ExportLinetypeKey^, ExportLinetypeInfo^>>
type ExportLinetypeTableIterator =
    class
        interface IEnumerator<KeyValuePair<ExportLinetypeKey, ExportLinetypeInfo>>
    end

The ExportLinetypeTableIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ExportLinetypeTableIterator
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next item.
Public method | Reset | Resets the iterator to the initial state.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExportLinetypeTableIterator Properties

The ExportLinetypeTableIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

ExportLinetypeTableIterator Class


ExportLinetypeTableIterator.Current Property

ExportLinetypeTableIteratorCurrent Property

Gets the item at the current position of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual KeyValuePair<ExportLinetypeKey, ExportLinetypeInfo> Current { get; }
Public Overridable ReadOnly Property Current As KeyValuePair(Of ExportLinetypeKey, ExportLinetypeInfo)
    Get
public:
virtual property KeyValuePair<ExportLinetypeKey^, ExportLinetypeInfo^> Current {
    KeyValuePair<ExportLinetypeKey^, ExportLinetypeInfo^> get ();
}
abstract Current : KeyValuePair<ExportLinetypeKey, ExportLinetypeInfo> with get
override Current : KeyValuePair<ExportLinetypeKey, ExportLinetypeInfo> with get

Property Value

KeyValuePair ExportLinetypeKey, ExportLinetypeInfo

Implements

IEnumeratorTCurrent
Exceptions
Exception | Condition
InvalidOperationException | There is no current item in the iterator.
Remarks
There is no current item if the iterator has not started yet or has been done.
See Also

Reference

ExportLinetypeTableIterator Class


ExportLinetypeTableIterator.CurrentObject Property

ExportLinetypeTableIteratorCurrentObject Property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
internal Object CurrentObject { get; }
Friend ReadOnly Property CurrentObject As Object
    Get
internal:
virtual property Object^ CurrentObject {
    Object^ get () sealed;
}
internal abstract CurrentObject : Object with get
internal override CurrentObject : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
See Also

Reference

ExportLinetypeTableIterator Class


ExportLinetypeTableIterator.IsValidObject Property

ExportLinetypeTableIteratorIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ExportLinetypeTableIterator Class


ExportLinetypeTableIterator Methods

The ExportLinetypeTableIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next item.
Public method | Reset | Resets the iterator to the initial state.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportLinetypeTableIterator Class


ExportLinetypeTableIterator.Dispose Method

ExportLinetypeTableIteratorDispose Method

Releases all resources used by the ExportLinetypeTableIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit
See Also

Reference

ExportLinetypeTableIterator Class


ExportLinetypeTableIterator.IsDone Method

ExportLinetypeTableIteratorIsDone Method

Identifies if the iteration has completed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsDone()
Public Overridable Function IsDone As Boolean
public:
virtual bool IsDone()
abstract IsDone : unit -> bool
override IsDone : unit -> bool

Return Value

Boolean
True if the iteration has no more items. False if there are more items to be iterated.
See Also

Reference

ExportLinetypeTableIterator Class


ExportLinetypeTableIterator.MoveNext Method

ExportLinetypeTableIteratorMoveNext Method

Increments the iterator to the next item.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
True if the iteration has no more items. False if there are more items to be iterated.
See Also

Reference

ExportLinetypeTableIterator Class


ExportLinetypeTableIterator.Reset Method

ExportLinetypeTableIteratorReset Method

Resets the iterator to the initial state.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit
See Also

Reference

ExportLinetypeTableIterator Class


ExportLineweightInfo Class

A value used to represent the info stored in the ExportLineweightTable.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExportLineweightInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExportLineweightInfo : IDisposable
Public Class ExportLineweightInfo
    Implements IDisposable
public ref class ExportLineweightInfo : IDisposable
type ExportLineweightInfo =
    class
        interface IDisposable
    end

The ExportLineweightInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ExportLineweightInfo | Constructs a new default ExportLineweightInfo.
Public method | ExportLineweightInfo(ExportLineweightInfo) | Constructs a new copy of the input ExportLineweightInfo object.
Public method | ExportLineweightInfo(String) | Constructs a new ExportLineweightInfo using the destination line weight name as input.
Top
Properties
 | Name | Description
Public property | DestinationLineweightName | The destination lineweight name (the name of the line weight in the exported format)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ExportLineweightInfo
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExportLineweightInfo Constructor

Overload List
 | Name | Description
Public method | ExportLineweightInfo | Constructs a new default ExportLineweightInfo.
Public method | ExportLineweightInfo(ExportLineweightInfo) | Constructs a new copy of the input ExportLineweightInfo object.
Public method | ExportLineweightInfo(String) | Constructs a new ExportLineweightInfo using the destination line weight name as input.
Top
See Also

Reference

ExportLineweightInfo Class


ExportLineweightInfo Constructor

Constructs a new default ExportLineweightInfo.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportLineweightInfo()
Public Sub New
public:
ExportLineweightInfo()
new : unit -> ExportLineweightInfo
See Also

Reference

ExportLineweightInfo Class
ExportLineweightInfo Overload


ExportLineweightInfo(ExportLineweightInfo) Constructor

Constructs a new copy of the input ExportLineweightInfo object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportLineweightInfo(
    ExportLineweightInfo other
)
Public Sub New (
    other As ExportLineweightInfo
)
public:
ExportLineweightInfo(
    ExportLineweightInfo^ other
)
new :
        other : ExportLineweightInfo -> ExportLineweightInfo

Parameters

other ExportLineweightInfo
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportLineweightInfo Class
ExportLineweightInfo Overload


ExportLineweightInfo(String) Constructor

Constructs a new ExportLineweightInfo using the destination line weight name as input.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportLineweightInfo(
    string destinationLineweightName
)
Public Sub New (
    destinationLineweightName As String
)
public:
ExportLineweightInfo(
    String^ destinationLineweightName
)
new :
        destinationLineweightName : string -> ExportLineweightInfo

Parameters

destinationLineweightName String
The destination line weight name (the name of the line weight in the exported format).
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportLineweightInfo Class
ExportLineweightInfo Overload


ExportLineweightInfo Properties

The ExportLineweightInfo type exposes the following members.

Properties
 | Name | Description
Public property | DestinationLineweightName | The destination lineweight name (the name of the line weight in the exported format)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

ExportLineweightInfo Class


ExportLineweightInfo.DestinationLineweightName Property

ExportLineweightInfoDestinationLineweightName Property

The destination lineweight name (the name of the line weight in the exported format)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string DestinationLineweightName { get; set; }
Public Property DestinationLineweightName As String
    Get
    Set
public:
property String^ DestinationLineweightName {
    String^ get ();
    void set (String^ value);
}
member DestinationLineweightName : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ExportLineweightInfo Class


ExportLineweightInfo.IsValidObject Property

ExportLineweightInfoIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ExportLineweightInfo Class


ExportLineweightInfo Methods

The ExportLineweightInfo type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportLineweightInfo Class


ExportLineweightInfo.Dispose Method

ExportLineweightInfoDispose Method

Releases all resources used by the ExportLineweightInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ExportLineweightInfo Class


ExportLineweightKey Class

A key used to represent an item stored in an ExportLineweightTable.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExportLineweightKey

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExportLineweightKey : IDisposable
Public Class ExportLineweightKey
    Implements IDisposable
public ref class ExportLineweightKey : IDisposable
type ExportLineweightKey =
    class
        interface IDisposable
    end

The ExportLineweightKey type exposes the following members.

Constructors
 | Name | Description
Public method | ExportLineweightKey | Constructs a new default ExportLineweightKey.
Public method | ExportLineweightKey(ExportLineweightKey) | Constructs a new copy of the input ExportLineweightKey object.
Public method | ExportLineweightKey(Int32) | Constructs a new default ExportLineweightKey using the original line weight as input.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OriginalLineweight | The original line weight.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ExportLineweightKey
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExportLineweightKey Constructor

Overload List
 | Name | Description
Public method | ExportLineweightKey | Constructs a new default ExportLineweightKey.
Public method | ExportLineweightKey(ExportLineweightKey) | Constructs a new copy of the input ExportLineweightKey object.
Public method | ExportLineweightKey(Int32) | Constructs a new default ExportLineweightKey using the original line weight as input.
Top
See Also

Reference

ExportLineweightKey Class


ExportLineweightKey Constructor

Constructs a new default ExportLineweightKey.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportLineweightKey()
Public Sub New
public:
ExportLineweightKey()
new : unit -> ExportLineweightKey
See Also

Reference

ExportLineweightKey Class
ExportLineweightKey Overload


ExportLineweightKey(ExportLineweightKey) Constructor

Constructs a new copy of the input ExportLineweightKey object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportLineweightKey(
    ExportLineweightKey other
)
Public Sub New (
    other As ExportLineweightKey
)
public:
ExportLineweightKey(
    ExportLineweightKey^ other
)
new :
        other : ExportLineweightKey -> ExportLineweightKey

Parameters

other ExportLineweightKey
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportLineweightKey Class
ExportLineweightKey Overload


ExportLineweightKey(Int32) Constructor

Constructs a new default ExportLineweightKey using the original line weight as input.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportLineweightKey(
    int originalLineweight
)
Public Sub New (
    originalLineweight As Integer
)
public:
ExportLineweightKey(
    int originalLineweight
)
new :
        originalLineweight : int -> ExportLineweightKey

Parameters

originalLineweight Int32
The original line weight.
See Also

Reference

ExportLineweightKey Class
ExportLineweightKey Overload


ExportLineweightKey Properties

The ExportLineweightKey type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OriginalLineweight | The original line weight.
Top
See Also

Reference

ExportLineweightKey Class


ExportLineweightKey.IsValidObject Property

ExportLineweightKeyIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ExportLineweightKey Class


ExportLineweightKey.OriginalLineweight Property

ExportLineweightKeyOriginalLineweight Property

The original line weight.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int OriginalLineweight { get; set; }
Public Property OriginalLineweight As Integer
    Get
    Set
public:
property int OriginalLineweight {
    int get ();
    void set (int value);
}
member OriginalLineweight : int with get, set

Property Value

Int32
See Also

Reference

ExportLineweightKey Class


ExportLineweightKey Methods

The ExportLineweightKey type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportLineweightKey Class


ExportLineweightKey.Dispose Method

ExportLineweightKeyDispose Method

Releases all resources used by the ExportLineweightKey

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ExportLineweightKey Class


ExportLineweightTable Class

A table supporting a mapping of line weights in Revit to line weight names that will be set in the target export format.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExportLineweightTable

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExportLineweightTable : IEnumerable<KeyValuePair<ExportLineweightKey, ExportLineweightInfo>>,
    IDisposable
Public Class ExportLineweightTable
    Implements IEnumerable(Of KeyValuePair(Of ExportLineweightKey, ExportLineweightInfo)),
    IDisposable
public ref class ExportLineweightTable : IEnumerable<KeyValuePair<ExportLineweightKey^, ExportLineweightInfo^>>,
    IDisposable
type ExportLineweightTable =
    class
        interface IEnumerable<KeyValuePair<ExportLineweightKey, ExportLineweightInfo>>
        interface IDisposable
    end

The ExportLineweightTable type exposes the following members.

Constructors
 | Name | Description
Public method | ExportLineweightTable | Constructs a new ExportLineweightTable with default settings.
Top
Properties
 | Name | Description
Public property | Count | Count of the items contained in the collection.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Item | A copy of the ExportLineweightInfo for the line weight's ExportLineweightKey.
Top
Methods
 | Name | Description
Public method | Add | Inserts a (key, info) pair into Export line weight table.
Public method | Clear | Removes all contents stored in Export line weight table.
Public method | ContainsKey | Checks whether a line weight key exists in the table.
Public method | Dispose | Releases all resources used by the ExportLineweightTable
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetExportLineweightInfo | Gets a copy of the ExportLineweightInfo corresponding to the given ExportLineweightKey.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetKeys | Gets all the keys stored in the map.
Public method | GetLineweightTableIterator | Returns a ExportLineweightTableIterator that iterates through the collection.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetValues | Returns all the values stored in the map.
Public method | Remove | Removes the pair (key, info) corresponding to the given ExportLineweightKey.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

This table is structured as a mapping from ExportLineweightKey to ExportLineweightInfo members. The ExportLineweightKey contains the identification information for the pattern table: the Revit line weight. The ExportLineweightInfo contains the line weight to use in the export format.

The table can be accessed via direct iteration as a collection of KeyValuePairs, or by traversal of the stored keys obtained from GetKeys(), or via specific lookup of a key constructed externally. In all cases, the ExportLineweightInfo returned will be a copy of the ExportLineweightInfo from the table. In order to make changes to the ExportLineweightInfo and use those settings during export, set the modified ExportLineweightInfo back into the table using the same key.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExportLineweightTable Constructor

Constructs a new ExportLineweightTable with default settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportLineweightTable()
Public Sub New
public:
ExportLineweightTable()
new : unit -> ExportLineweightTable
See Also

Reference

ExportLineweightTable Class


ExportLineweightTable Properties

The ExportLineweightTable type exposes the following members.

Properties
 | Name | Description
Public property | Count | Count of the items contained in the collection.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Item | A copy of the ExportLineweightInfo for the line weight's ExportLineweightKey.
Top
See Also

Reference

ExportLineweightTable Class


ExportLineweightTable.Count Property

ExportLineweightTableCount Property

Count of the items contained in the collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
member Count : int with get

Property Value

Int32
See Also

Reference

ExportLineweightTable Class


ExportLineweightTable.IsValidObject Property

ExportLineweightTableIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ExportLineweightTable Class


ExportLineweightTable.Item Property

ExportLineweightTableItem Property

A copy of the ExportLineweightInfo for the line weight's ExportLineweightKey.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportLineweightInfo this[
    ExportLineweightKey lineweightKey
] { get; set; }
Public Default Property Item (
    lineweightKey As ExportLineweightKey
) As ExportLineweightInfo
    Get
    Set
public:
virtual property ExportLineweightInfo^ default[ExportLineweightKey^ lineweightKey] {
    ExportLineweightInfo^ get (ExportLineweightKey^ lineweightKey) sealed;
    void set (ExportLineweightKey^ lineweightKey, ExportLineweightInfo^ value) sealed;
}
abstract Item : ExportLineweightInfo with get, set
override Item : ExportLineweightInfo with get, set

Parameters

lineweightKey ExportLineweightKey

Return Value

ExportLineweightInfo
A copy of the ExportLineweightInfo.
Exceptions
Exception | Condition
ArgumentException | When getting this property: An entry with the given key is not present in the table.
Remarks
When getting this property, it returns a copy of the ExportLineweightInfo from the table. In order to make changes to the ExportLineweightInfo and use those settings during export, set the modified ExportLineweightInfo back into the table using the same key.
See Also

Reference

ExportLineweightTable Class


ExportLineweightTable Methods

The ExportLineweightTable type exposes the following members.

Methods
 | Name | Description
Public method | Add | Inserts a (key, info) pair into Export line weight table.
Public method | Clear | Removes all contents stored in Export line weight table.
Public method | ContainsKey | Checks whether a line weight key exists in the table.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetExportLineweightInfo | Gets a copy of the ExportLineweightInfo corresponding to the given ExportLineweightKey.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetKeys | Gets all the keys stored in the map.
Public method | GetLineweightTableIterator | Returns a ExportLineweightTableIterator that iterates through the collection.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetValues | Returns all the values stored in the map.
Public method | Remove | Removes the pair (key, info) corresponding to the given ExportLineweightKey.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportLineweightTable Class


ExportLineweightTable.Add Method

ExportLineweightTableAdd Method

Inserts a (key, info) pair into Export line weight table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Add(
    ExportLineweightKey exportLineweightKey,
    ExportLineweightInfo exportLineweightInfo
)
Public Sub Add (
    exportLineweightKey As ExportLineweightKey,
    exportLineweightInfo As ExportLineweightInfo
)
public:
void Add(
    ExportLineweightKey^ exportLineweightKey,
    ExportLineweightInfo^ exportLineweightInfo
)
member Add :
        exportLineweightKey : ExportLineweightKey *
        exportLineweightInfo : ExportLineweightInfo -> unit

Parameters

exportLineweightKey ExportLineweightKey
The export line weight Key to be added.
exportLineweightInfo ExportLineweightInfo
The export line weight info to be added.
Exceptions
Exception | Condition
ArgumentException | The key already exists in the table.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportLineweightTable Class


ExportLineweightTable.Clear Method

ExportLineweightTableClear Method

Removes all contents stored in Export line weight table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

ExportLineweightTable Class


ExportLineweightTable.ContainsKey Method

ExportLineweightTableContainsKey Method

Checks whether a line weight key exists in the table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ContainsKey(
    ExportLineweightKey exportLineweightKey
)
Public Function ContainsKey (
    exportLineweightKey As ExportLineweightKey
) As Boolean
public:
bool ContainsKey(
    ExportLineweightKey^ exportLineweightKey
)
member ContainsKey :
        exportLineweightKey : ExportLineweightKey -> bool

Parameters

exportLineweightKey ExportLineweightKey
The export line weight key.

Return Value

Boolean
True if the line weight exists in the table.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportLineweightTable Class


ExportLineweightTable.Dispose Method

ExportLineweightTableDispose Method

Releases all resources used by the ExportLineweightTable

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ExportLineweightTable Class


ExportLineweightTable.GetBasicIEnumerator Method

ExportLineweightTableGetBasicIEnumerator Method

Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
internal virtual IEnumerator GetBasicIEnumerator()
Friend Overridable Function GetBasicIEnumerator As IEnumerator
internal:
virtual IEnumerator^ GetBasicIEnumerator()
internal abstract GetBasicIEnumerator : unit -> IEnumerator
internal override GetBasicIEnumerator : unit -> IEnumerator

Return Value

IEnumerator
An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerableGetEnumerator
See Also

Reference

ExportLineweightTable Class


ExportLineweightTable.GetEnumerator Method

ExportLineweightTableGetEnumerator Method

Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator<KeyValuePair<ExportLineweightKey, ExportLineweightInfo>> GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator(Of KeyValuePair(Of ExportLineweightKey, ExportLineweightInfo))
public:
virtual IEnumerator<KeyValuePair<ExportLineweightKey^, ExportLineweightInfo^>>^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator<KeyValuePair<ExportLineweightKey, ExportLineweightInfo>>
override GetEnumerator : unit -> IEnumerator<KeyValuePair<ExportLineweightKey, ExportLineweightInfo>>

Return Value

IEnumerator KeyValuePair ExportLineweightKey, ExportLineweightInfo
An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerableTGetEnumerator
See Also

Reference

ExportLineweightTable Class


ExportLineweightTable.GetExportLineweightInfo Method

ExportLineweightTableGetExportLineweightInfo Method

Gets a copy of the ExportLineweightInfo corresponding to the given ExportLineweightKey.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportLineweightInfo GetExportLineweightInfo(
    ExportLineweightKey exportLineweightKey
)
Public Function GetExportLineweightInfo (
    exportLineweightKey As ExportLineweightKey
) As ExportLineweightInfo
public:
ExportLineweightInfo^ GetExportLineweightInfo(
    ExportLineweightKey^ exportLineweightKey
)
member GetExportLineweightInfo :
        exportLineweightKey : ExportLineweightKey -> ExportLineweightInfo

Parameters

exportLineweightKey ExportLineweightKey
The export line weight Key.

Return Value

ExportLineweightInfo
Returns the line weight info for this key.
Exceptions
Exception | Condition
ArgumentException | An entry with the given key is not present in the table.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportLineweightTable Class


ExportLineweightTable.GetKeys Method

ExportLineweightTableGetKeys Method

Gets all the keys stored in the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ExportLineweightKey> GetKeys()
Public Function GetKeys As IList(Of ExportLineweightKey)
public:
IList<ExportLineweightKey^>^ GetKeys()
member GetKeys : unit -> IList<ExportLineweightKey>

Return Value

IList ExportLineweightKey
The keys.
See Also

Reference

ExportLineweightTable Class


ExportLineweightTable.GetLineweightTableIterator Method

ExportLineweightTableGetLineweightTableIterator Method

Returns a ExportLineweightTableIterator that iterates through the collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportLineweightTableIterator GetLineweightTableIterator()
Public Function GetLineweightTableIterator As ExportLineweightTableIterator
public:
ExportLineweightTableIterator^ GetLineweightTableIterator()
member GetLineweightTableIterator : unit -> ExportLineweightTableIterator

Return Value

ExportLineweightTableIterator
A ExportLineweightTableIterator object that can be used to iterate through key-value pairs in the collection.
See Also

Reference

ExportLineweightTable Class


ExportLineweightTable.GetValues Method

ExportLineweightTableGetValues Method

Returns all the values stored in the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ExportLineweightInfo> GetValues()
Public Function GetValues As IList(Of ExportLineweightInfo)
public:
IList<ExportLineweightInfo^>^ GetValues()
member GetValues : unit -> IList<ExportLineweightInfo>

Return Value

IList ExportLineweightInfo
The info.
See Also

Reference

ExportLineweightTable Class


ExportLineweightTable.Remove Method

ExportLineweightTableRemove Method

Removes the pair (key, info) corresponding to the given ExportLineweightKey.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Remove(
    ExportLineweightKey exportLineweightKey
)
Public Sub Remove (
    exportLineweightKey As ExportLineweightKey
)
public:
void Remove(
    ExportLineweightKey^ exportLineweightKey
)
member Remove :
        exportLineweightKey : ExportLineweightKey -> unit

Parameters

exportLineweightKey ExportLineweightKey
The export line weight key
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportLineweightTable Class


ExportLineweightTableIterator Class

An iterator to a set of line weight table.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExportLineweightTableIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExportLineweightTableIterator : IEnumerator<KeyValuePair<ExportLineweightKey, ExportLineweightInfo>>
Public Class ExportLineweightTableIterator
    Implements IEnumerator(Of KeyValuePair(Of ExportLineweightKey, ExportLineweightInfo))
public ref class ExportLineweightTableIterator : IEnumerator<KeyValuePair<ExportLineweightKey^, ExportLineweightInfo^>>
type ExportLineweightTableIterator =
    class
        interface IEnumerator<KeyValuePair<ExportLineweightKey, ExportLineweightInfo>>
    end

The ExportLineweightTableIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ExportLineweightTableIterator
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next item.
Public method | Reset | Resets the iterator to the initial state.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExportLineweightTableIterator Properties

The ExportLineweightTableIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

ExportLineweightTableIterator Class


ExportLineweightTableIterator.Current Property

ExportLineweightTableIteratorCurrent Property

Gets the item at the current position of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual KeyValuePair<ExportLineweightKey, ExportLineweightInfo> Current { get; }
Public Overridable ReadOnly Property Current As KeyValuePair(Of ExportLineweightKey, ExportLineweightInfo)
    Get
public:
virtual property KeyValuePair<ExportLineweightKey^, ExportLineweightInfo^> Current {
    KeyValuePair<ExportLineweightKey^, ExportLineweightInfo^> get ();
}
abstract Current : KeyValuePair<ExportLineweightKey, ExportLineweightInfo> with get
override Current : KeyValuePair<ExportLineweightKey, ExportLineweightInfo> with get

Property Value

KeyValuePair ExportLineweightKey, ExportLineweightInfo

Implements

IEnumeratorTCurrent
Exceptions
Exception | Condition
InvalidOperationException | There is no current item in the iterator.
Remarks
There is no current item if the iterator has not started yet or has been done.
See Also

Reference

ExportLineweightTableIterator Class


ExportLineweightTableIterator.CurrentObject Property

ExportLineweightTableIteratorCurrentObject Property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
internal Object CurrentObject { get; }
Friend ReadOnly Property CurrentObject As Object
    Get
internal:
virtual property Object^ CurrentObject {
    Object^ get () sealed;
}
internal abstract CurrentObject : Object with get
internal override CurrentObject : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
See Also

Reference

ExportLineweightTableIterator Class


ExportLineweightTableIterator.IsValidObject Property

ExportLineweightTableIteratorIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ExportLineweightTableIterator Class


ExportLineweightTableIterator Methods

The ExportLineweightTableIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next item.
Public method | Reset | Resets the iterator to the initial state.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportLineweightTableIterator Class


ExportLineweightTableIterator.Dispose Method

ExportLineweightTableIteratorDispose Method

Releases all resources used by the ExportLineweightTableIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit
See Also

Reference

ExportLineweightTableIterator Class


ExportLineweightTableIterator.IsDone Method

ExportLineweightTableIteratorIsDone Method

Identifies if the iteration has completed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsDone()
Public Overridable Function IsDone As Boolean
public:
virtual bool IsDone()
abstract IsDone : unit -> bool
override IsDone : unit -> bool

Return Value

Boolean
True if the iteration has no more items. False if there are more items to be iterated.
See Also

Reference

ExportLineweightTableIterator Class


ExportLineweightTableIterator.MoveNext Method

ExportLineweightTableIteratorMoveNext Method

Increments the iterator to the next item.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
True if the iteration has no more items. False if there are more items to be iterated.
See Also

Reference

ExportLineweightTableIterator Class


ExportLineweightTableIterator.Reset Method

ExportLineweightTableIteratorReset Method

Resets the iterator to the initial state.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit
See Also

Reference

ExportLineweightTableIterator Class


ExportPaperFormat Enumeration

Paper formats supported by export

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ExportPaperFormat
Public Enumeration ExportPaperFormat
public enum class ExportPaperFormat
type ExportPaperFormat
Members
Member name | Value | Description
Default | 0 | Default paper format.
ANSI_A | 1 | ANSI A, 8.5 x 11 in
ANSI_B | 2 | ANSI B, 11 x 17 in
ANSI_C | 3 | ANSI C, 17 x 22 in
ANSI_D | 4 | ANSI D, 22 x 34 in
ANSI_E | 5 | ANSI E, 34 x 44 in
ISO_A4 | 6 | ISO A4, 210 x 297 mm
ISO_A3 | 7 | ISO A3, 297 x 420 mm
ISO_A2 | 8 | ISO A2, 420 x 594 mm
ISO_A1 | 9 | ISO A1, 594 x 841 mm
ISO_A0 | 10 | ISO A0, 841 x 1189 mm
ISO_B4 | 11 | ISO B4, 250 x 353 mm
ISO_B3 | 12 | ISO B3, 353 x 500 mm
ISO_B2 | 13 | ISO B2, 500 x 707 mm
ISO_B1 | 14 | ISO B1, 707 x 1000 mm
ARCH_A | 15 | ARCH A, 9 x 12 in
ARCH_B | 16 | ARCH B, 12 x 18 in
ARCH_C | 17 | ARCH C, 18 x 24 in
ARCH_D | 18 | ARCH D, 24 x 36 in
ARCH_E | 19 | ARCH E, 36 x 48 in
ARCH_E1 | 20 | ARCH E1, 30 x 42 in
ARCH_E2 | 21 | ARCH E2, 26 x 38 in
ARCH_E3 | 22 | ARCH E3, 27 x 39 in
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExportPatternInfo Class

A value used to represent the info stored in the ExportPatternTable.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExportPatternInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExportPatternInfo : IDisposable
Public Class ExportPatternInfo
    Implements IDisposable
public ref class ExportPatternInfo : IDisposable
type ExportPatternInfo =
    class
        interface IDisposable
    end

The ExportPatternInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ExportPatternInfo | Constructs a new default ExportPatternInfo.
Public method | ExportPatternInfo(ExportPatternInfo) | Constructs a new copy of the input ExportPatternInfo object.
Public method | ExportPatternInfo(String) | Constructs a new ExportPatternInfo using the destination pattern name as input.
Top
Properties
 | Name | Description
Public property | DestinationPatternName | The destination pattern name (the name of the pattern in the exported format).
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ExportPatternInfo
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExportPatternInfo Constructor

Overload List
 | Name | Description
Public method | ExportPatternInfo | Constructs a new default ExportPatternInfo.
Public method | ExportPatternInfo(ExportPatternInfo) | Constructs a new copy of the input ExportPatternInfo object.
Public method | ExportPatternInfo(String) | Constructs a new ExportPatternInfo using the destination pattern name as input.
Top
See Also

Reference

ExportPatternInfo Class


ExportPatternInfo Constructor

Constructs a new default ExportPatternInfo.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportPatternInfo()
Public Sub New
public:
ExportPatternInfo()
new : unit -> ExportPatternInfo
See Also

Reference

ExportPatternInfo Class
ExportPatternInfo Overload


ExportPatternInfo(ExportPatternInfo) Constructor

Constructs a new copy of the input ExportPatternInfo object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportPatternInfo(
    ExportPatternInfo other
)
Public Sub New (
    other As ExportPatternInfo
)
public:
ExportPatternInfo(
    ExportPatternInfo^ other
)
new :
        other : ExportPatternInfo -> ExportPatternInfo

Parameters

other ExportPatternInfo
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportPatternInfo Class
ExportPatternInfo Overload


ExportPatternInfo(String) Constructor

Constructs a new ExportPatternInfo using the destination pattern name as input.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportPatternInfo(
    string destinationPatternName
)
Public Sub New (
    destinationPatternName As String
)
public:
ExportPatternInfo(
    String^ destinationPatternName
)
new :
        destinationPatternName : string -> ExportPatternInfo

Parameters

destinationPatternName String
The destination pattern name (the name of the pattern in the exported format).
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportPatternInfo Class
ExportPatternInfo Overload


ExportPatternInfo Properties

The ExportPatternInfo type exposes the following members.

Properties
 | Name | Description
Public property | DestinationPatternName | The destination pattern name (the name of the pattern in the exported format).
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

ExportPatternInfo Class


ExportPatternInfo.DestinationPatternName Property

ExportPatternInfoDestinationPatternName Property

The destination pattern name (the name of the pattern in the exported format).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string DestinationPatternName { get; set; }
Public Property DestinationPatternName As String
    Get
    Set
public:
property String^ DestinationPatternName {
    String^ get ();
    void set (String^ value);
}
member DestinationPatternName : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ExportPatternInfo Class


ExportPatternInfo.IsValidObject Property

ExportPatternInfoIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ExportPatternInfo Class


ExportPatternInfo Methods

The ExportPatternInfo type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportPatternInfo Class


ExportPatternInfo.Dispose Method

ExportPatternInfoDispose Method

Releases all resources used by the ExportPatternInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ExportPatternInfo Class


ExportPatternKey Class

A key used to represent an item stored in an ExportPatternTable.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExportPatternKey

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExportPatternKey : IDisposable
Public Class ExportPatternKey
    Implements IDisposable
public ref class ExportPatternKey : IDisposable
type ExportPatternKey =
    class
        interface IDisposable
    end

The ExportPatternKey type exposes the following members.

Constructors
 | Name | Description
Public method | ExportPatternKey | Constructs a new default ExportPatternKey.
Public method | ExportPatternKey(ExportPatternKey) | Constructs a new copy of the input ExportPatternKey object.
Public method | ExportPatternKey(FillPatternTarget, String) | Constructs a new ExportPatternKey using the original fill pattern type and name as input.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OriginalFillPatternName | The original FillPattern name.
Public property | OriginalFillPatternType | The original FillPattern type.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ExportPatternKey
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExportPatternKey Constructor

Overload List
 | Name | Description
Public method | ExportPatternKey | Constructs a new default ExportPatternKey.
Public method | ExportPatternKey(ExportPatternKey) | Constructs a new copy of the input ExportPatternKey object.
Public method | ExportPatternKey(FillPatternTarget, String) | Constructs a new ExportPatternKey using the original fill pattern type and name as input.
Top
See Also

Reference

ExportPatternKey Class


ExportPatternKey Constructor

Constructs a new default ExportPatternKey.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportPatternKey()
Public Sub New
public:
ExportPatternKey()
new : unit -> ExportPatternKey
See Also

Reference

ExportPatternKey Class
ExportPatternKey Overload


ExportPatternKey(ExportPatternKey) Constructor

Constructs a new copy of the input ExportPatternKey object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportPatternKey(
    ExportPatternKey other
)
Public Sub New (
    other As ExportPatternKey
)
public:
ExportPatternKey(
    ExportPatternKey^ other
)
new :
        other : ExportPatternKey -> ExportPatternKey

Parameters

other ExportPatternKey
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportPatternKey Class
ExportPatternKey Overload


ExportPatternKey(FillPatternTarget, String) Constructor

Constructs a new ExportPatternKey using the original fill pattern type and name as input.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportPatternKey(
    FillPatternTarget originalFillPatternType,
    string originalFillPatternName
)
Public Sub New (
    originalFillPatternType As FillPatternTarget,
    originalFillPatternName As String
)
public:
ExportPatternKey(
    FillPatternTarget originalFillPatternType,
    String^ originalFillPatternName
)
new :
        originalFillPatternType : FillPatternTarget *
        originalFillPatternName : string -> ExportPatternKey

Parameters

originalFillPatternType FillPatternTarget
The original FillPattern type.
originalFillPatternName String
The original FillPattern name.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ExportPatternKey Class
ExportPatternKey Overload


ExportPatternKey Properties

The ExportPatternKey type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OriginalFillPatternName | The original FillPattern name.
Public property | OriginalFillPatternType | The original FillPattern type.
Top
See Also

Reference

ExportPatternKey Class


ExportPatternKey.IsValidObject Property

ExportPatternKeyIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ExportPatternKey Class


ExportPatternKey.OriginalFillPatternName Property

ExportPatternKeyOriginalFillPatternName Property

The original FillPattern name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string OriginalFillPatternName { get; set; }
Public Property OriginalFillPatternName As String
    Get
    Set
public:
property String^ OriginalFillPatternName {
    String^ get ();
    void set (String^ value);
}
member OriginalFillPatternName : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ExportPatternKey Class


ExportPatternKey.OriginalFillPatternType Property

ExportPatternKeyOriginalFillPatternType Property

The original FillPattern type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FillPatternTarget OriginalFillPatternType { get; set; }
Public Property OriginalFillPatternType As FillPatternTarget
    Get
    Set
public:
property FillPatternTarget OriginalFillPatternType {
    FillPatternTarget get ();
    void set (FillPatternTarget value);
}
member OriginalFillPatternType : FillPatternTarget with get, set

Property Value

FillPatternTarget
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ExportPatternKey Class


ExportPatternKey Methods

The ExportPatternKey type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportPatternKey Class


ExportPatternKey.Dispose Method

ExportPatternKeyDispose Method

Releases all resources used by the ExportPatternKey

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ExportPatternKey Class


ExportPatternTable Class

A table supporting a mapping of FillPatterns in Revit to pattern names that will be set in the target export format.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExportPatternTable

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExportPatternTable : IEnumerable<KeyValuePair<ExportPatternKey, ExportPatternInfo>>,
    IDisposable
Public Class ExportPatternTable
    Implements IEnumerable(Of KeyValuePair(Of ExportPatternKey, ExportPatternInfo)),
    IDisposable
public ref class ExportPatternTable : IEnumerable<KeyValuePair<ExportPatternKey^, ExportPatternInfo^>>,
    IDisposable
type ExportPatternTable =
    class
        interface IEnumerable<KeyValuePair<ExportPatternKey, ExportPatternInfo>>
        interface IDisposable
    end

The ExportPatternTable type exposes the following members.

Constructors
 | Name | Description
Public method | ExportPatternTable | Constructs a new ExportPatternTable with default values.
Top
Properties
 | Name | Description
Public property | Count | Count of the items contained in the collection.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Item | A copy of the ExportPatternInfo for the pattern's ExportPatternKey.
Top
Methods
 | Name | Description
Public method | Add | Inserts a (key,info) pair into Export pattern table.
Public method | Clear | Removes all contents stored in the table.
Public method | ContainsKey | Checks whether a pattern key exists in the table.
Public method | Dispose | Releases all resources used by the ExportPatternTable
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetExportPatternInfo | Gets a copy of the pattern info associated to the input pattern key.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetKeys | Gets all the keys stored in the map.
Public method | GetPatternTableIterator | Returns a PatternTableIterator that iterates through the collection.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetValues | Returns all the values stored in the map.
Public method | Remove | Removes the pair (key, info) by pattern key.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

This table is structured as a mapping from ExportPatternKey to ExportPatternInfo members. The ExportPatternKey contains the identification information for the pattern table: the Revit fill pattern type and name. The ExportPatternInfo contains the pattern name to use in the export format.

The table can be accessed via direct iteration as a collection of KeyValuePairs, or by traversal of the stored keys obtained from GetKeys(), or via specific lookup of a key constructed externally. In all cases, the ExportPatternInfo returned will be a copy of the ExportPatternInfo from the table. In order to make changes to the ExportPatternInfo and use those settings during export, set the modified ExportPatternInfo back into the table using the same key.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExportPatternTable Constructor

Constructs a new ExportPatternTable with default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportPatternTable()
Public Sub New
public:
ExportPatternTable()
new : unit -> ExportPatternTable
See Also

Reference

ExportPatternTable Class


ExportPatternTable Properties

The ExportPatternTable type exposes the following members.

Properties
 | Name | Description
Public property | Count | Count of the items contained in the collection.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Item | A copy of the ExportPatternInfo for the pattern's ExportPatternKey.
Top
See Also

Reference

ExportPatternTable Class


ExportPatternTable.Count Property

ExportPatternTableCount Property

Count of the items contained in the collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
member Count : int with get

Property Value

Int32
See Also

Reference

ExportPatternTable Class


ExportPatternTable.IsValidObject Property

ExportPatternTableIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ExportPatternTable Class


ExportPatternTable.Item Property

ExportPatternTableItem Property

A copy of the ExportPatternInfo for the pattern's ExportPatternKey.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportPatternInfo this[
    ExportPatternKey patternKey
] { get; set; }
Public Default Property Item (
    patternKey As ExportPatternKey
) As ExportPatternInfo
    Get
    Set
public:
virtual property ExportPatternInfo^ default[ExportPatternKey^ patternKey] {
    ExportPatternInfo^ get (ExportPatternKey^ patternKey) sealed;
    void set (ExportPatternKey^ patternKey, ExportPatternInfo^ value) sealed;
}
abstract Item : ExportPatternInfo with get, set
override Item : ExportPatternInfo with get, set

Parameters

patternKey ExportPatternKey

Return Value

ExportPatternInfo
A copy of the ExportPatternInfo.
Exceptions
Exception | Condition
ArgumentException | When getting this property: An entry with the given key is not present in the table.
Remarks
When getting this property, it returns a copy of the ExportPatternInfo from the table. In order to make changes to the ExportPatternInfo and use those settings during export, set the modified ExportPatternInfo back into the table using the same key.
See Also

Reference

ExportPatternTable Class


ExportPatternTable Methods

The ExportPatternTable type exposes the following members.

Methods
 | Name | Description
Public method | Add | Inserts a (key,info) pair into Export pattern table.
Public method | Clear | Removes all contents stored in the table.
Public method | ContainsKey | Checks whether a pattern key exists in the table.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetExportPatternInfo | Gets a copy of the pattern info associated to the input pattern key.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetKeys | Gets all the keys stored in the map.
Public method | GetPatternTableIterator | Returns a PatternTableIterator that iterates through the collection.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetValues | Returns all the values stored in the map.
Public method | Remove | Removes the pair (key, info) by pattern key.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportPatternTable Class


ExportPatternTable.Add Method

ExportPatternTableAdd Method

Inserts a (key,info) pair into Export pattern table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Add(
    ExportPatternKey exportPatternKey,
    ExportPatternInfo exportPatternInfo
)
Public Sub Add (
    exportPatternKey As ExportPatternKey,
    exportPatternInfo As ExportPatternInfo
)
public:
void Add(
    ExportPatternKey^ exportPatternKey,
    ExportPatternInfo^ exportPatternInfo
)
member Add :
        exportPatternKey : ExportPatternKey *
        exportPatternInfo : ExportPatternInfo -> unit

Parameters

exportPatternKey ExportPatternKey
The export pattern key to be added.
exportPatternInfo ExportPatternInfo
The export pattern info to be added.
Exceptions
Exception | Condition
ArgumentException | The key already exists in the table.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportPatternTable Class


ExportPatternTable.Clear Method

ExportPatternTableClear Method

Removes all contents stored in the table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

ExportPatternTable Class


ExportPatternTable.ContainsKey Method

ExportPatternTableContainsKey Method

Checks whether a pattern key exists in the table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ContainsKey(
    ExportPatternKey exportpatternKey
)
Public Function ContainsKey (
    exportpatternKey As ExportPatternKey
) As Boolean
public:
bool ContainsKey(
    ExportPatternKey^ exportpatternKey
)
member ContainsKey :
        exportpatternKey : ExportPatternKey -> bool

Parameters

exportpatternKey ExportPatternKey
The export pattern Key.

Return Value

Boolean
True if the pattern key exists in the table.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportPatternTable Class


ExportPatternTable.Dispose Method

ExportPatternTableDispose Method

Releases all resources used by the ExportPatternTable

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ExportPatternTable Class


ExportPatternTable.GetBasicIEnumerator Method

ExportPatternTableGetBasicIEnumerator Method

Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
internal virtual IEnumerator GetBasicIEnumerator()
Friend Overridable Function GetBasicIEnumerator As IEnumerator
internal:
virtual IEnumerator^ GetBasicIEnumerator()
internal abstract GetBasicIEnumerator : unit -> IEnumerator
internal override GetBasicIEnumerator : unit -> IEnumerator

Return Value

IEnumerator
An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerableGetEnumerator
See Also

Reference

ExportPatternTable Class


ExportPatternTable.GetEnumerator Method

ExportPatternTableGetEnumerator Method

Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator<KeyValuePair<ExportPatternKey, ExportPatternInfo>> GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator(Of KeyValuePair(Of ExportPatternKey, ExportPatternInfo))
public:
virtual IEnumerator<KeyValuePair<ExportPatternKey^, ExportPatternInfo^>>^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator<KeyValuePair<ExportPatternKey, ExportPatternInfo>>
override GetEnumerator : unit -> IEnumerator<KeyValuePair<ExportPatternKey, ExportPatternInfo>>

Return Value

IEnumerator KeyValuePair ExportPatternKey, ExportPatternInfo
An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerableTGetEnumerator
See Also

Reference

ExportPatternTable Class


ExportPatternTable.GetExportPatternInfo Method

ExportPatternTableGetExportPatternInfo Method

Gets a copy of the pattern info associated to the input pattern key.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportPatternInfo GetExportPatternInfo(
    ExportPatternKey exportPatternKey
)
Public Function GetExportPatternInfo (
    exportPatternKey As ExportPatternKey
) As ExportPatternInfo
public:
ExportPatternInfo^ GetExportPatternInfo(
    ExportPatternKey^ exportPatternKey
)
member GetExportPatternInfo :
        exportPatternKey : ExportPatternKey -> ExportPatternInfo

Parameters

exportPatternKey ExportPatternKey
The export pattern Key.

Return Value

ExportPatternInfo
Return the patternInfo for this key.
Exceptions
Exception | Condition
ArgumentException | An entry with the given key is not present in the table.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportPatternTable Class


ExportPatternTable.GetKeys Method

ExportPatternTableGetKeys Method

Gets all the keys stored in the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ExportPatternKey> GetKeys()
Public Function GetKeys As IList(Of ExportPatternKey)
public:
IList<ExportPatternKey^>^ GetKeys()
member GetKeys : unit -> IList<ExportPatternKey>

Return Value

IList ExportPatternKey
Return the key array.
See Also

Reference

ExportPatternTable Class


ExportPatternTable.GetPatternTableIterator Method

ExportPatternTableGetPatternTableIterator Method

Returns a PatternTableIterator that iterates through the collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportPatternTableIterator GetPatternTableIterator()
Public Function GetPatternTableIterator As ExportPatternTableIterator
public:
ExportPatternTableIterator^ GetPatternTableIterator()
member GetPatternTableIterator : unit -> ExportPatternTableIterator

Return Value

ExportPatternTableIterator
A PatternTableIterator object that can be used to iterate through key-value pairs in the collection.
See Also

Reference

ExportPatternTable Class


ExportPatternTable.GetValues Method

ExportPatternTableGetValues Method

Returns all the values stored in the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ExportPatternInfo> GetValues()
Public Function GetValues As IList(Of ExportPatternInfo)
public:
IList<ExportPatternInfo^>^ GetValues()
member GetValues : unit -> IList<ExportPatternInfo>

Return Value

IList ExportPatternInfo
Return the info array.
See Also

Reference

ExportPatternTable Class


ExportPatternTable.Remove Method

ExportPatternTableRemove Method

Removes the pair (key, info) by pattern key.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Remove(
    ExportPatternKey exportPatternKey
)
Public Sub Remove (
    exportPatternKey As ExportPatternKey
)
public:
void Remove(
    ExportPatternKey^ exportPatternKey
)
member Remove :
        exportPatternKey : ExportPatternKey -> unit

Parameters

exportPatternKey ExportPatternKey
The export pattern key.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportPatternTable Class


ExportPatternTableIterator Class

An iterator to a set of Pattern table.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExportPatternTableIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExportPatternTableIterator : IEnumerator<KeyValuePair<ExportPatternKey, ExportPatternInfo>>
Public Class ExportPatternTableIterator
    Implements IEnumerator(Of KeyValuePair(Of ExportPatternKey, ExportPatternInfo))
public ref class ExportPatternTableIterator : IEnumerator<KeyValuePair<ExportPatternKey^, ExportPatternInfo^>>
type ExportPatternTableIterator =
    class
        interface IEnumerator<KeyValuePair<ExportPatternKey, ExportPatternInfo>>
    end

The ExportPatternTableIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ExportPatternTableIterator
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next item.
Public method | Reset | Resets the iterator to the initial state.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExportPatternTableIterator Properties

The ExportPatternTableIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

ExportPatternTableIterator Class


ExportPatternTableIterator.Current Property

ExportPatternTableIteratorCurrent Property

Gets the item at the current position of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual KeyValuePair<ExportPatternKey, ExportPatternInfo> Current { get; }
Public Overridable ReadOnly Property Current As KeyValuePair(Of ExportPatternKey, ExportPatternInfo)
    Get
public:
virtual property KeyValuePair<ExportPatternKey^, ExportPatternInfo^> Current {
    KeyValuePair<ExportPatternKey^, ExportPatternInfo^> get ();
}
abstract Current : KeyValuePair<ExportPatternKey, ExportPatternInfo> with get
override Current : KeyValuePair<ExportPatternKey, ExportPatternInfo> with get

Property Value

KeyValuePair ExportPatternKey, ExportPatternInfo

Implements

IEnumeratorTCurrent
Exceptions
Exception | Condition
InvalidOperationException | There is no current item in the iterator.
Remarks
There is no current item if the iterator has not started yet or has been done.
See Also

Reference

ExportPatternTableIterator Class


ExportPatternTableIterator.CurrentObject Property

ExportPatternTableIteratorCurrentObject Property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
internal Object CurrentObject { get; }
Friend ReadOnly Property CurrentObject As Object
    Get
internal:
virtual property Object^ CurrentObject {
    Object^ get () sealed;
}
internal abstract CurrentObject : Object with get
internal override CurrentObject : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
See Also

Reference

ExportPatternTableIterator Class


ExportPatternTableIterator.IsValidObject Property

ExportPatternTableIteratorIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ExportPatternTableIterator Class


ExportPatternTableIterator Methods

The ExportPatternTableIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next item.
Public method | Reset | Resets the iterator to the initial state.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportPatternTableIterator Class


ExportPatternTableIterator.Dispose Method

ExportPatternTableIteratorDispose Method

Releases all resources used by the ExportPatternTableIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit
See Also

Reference

ExportPatternTableIterator Class


ExportPatternTableIterator.IsDone Method

ExportPatternTableIteratorIsDone Method

Identifies if the iteration has completed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsDone()
Public Overridable Function IsDone As Boolean
public:
virtual bool IsDone()
abstract IsDone : unit -> bool
override IsDone : unit -> bool

Return Value

Boolean
True if the iteration has no more items. False if there are more items to be iterated.
See Also

Reference

ExportPatternTableIterator Class


ExportPatternTableIterator.MoveNext Method

ExportPatternTableIteratorMoveNext Method

Increments the iterator to the next item.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
True if there is a next available item in this iterator. False if the iterator has completed all available items.
See Also

Reference

ExportPatternTableIterator Class


ExportPatternTableIterator.Reset Method

ExportPatternTableIteratorReset Method

Resets the iterator to the initial state.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit
See Also

Reference

ExportPatternTableIterator Class


ExportPDFSettings Class

Settings for PDF export
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBExportPDFSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExportPDFSettings : Element
Public Class ExportPDFSettings
    Inherits Element
public ref class ExportPDFSettings : public Element
type ExportPDFSettings =
    class
        inherit Element
    end

The ExportPDFSettings type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Returns an new created ExportPDFSettings element in the document with specified settings.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
 | FindByName | Returns settings element by name.
 | GetActivePredefinedSettings | Gets the active settings element in the document.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOptions | Gets a copy of options from settings for exporting. Modification on this options would not change the element.
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
 | IsValidName | Returns result that the proposed name is valid and not exist in the specified document.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
 | ListNames | Returns all the names of the settings instances in the document.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetOptions | Sets options for exporting.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExportPDFSettings Properties

The ExportPDFSettings type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

ExportPDFSettings Class


ExportPDFSettings Methods

The ExportPDFSettings type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Returns an new created ExportPDFSettings element in the document with specified settings.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
 | FindByName | Returns settings element by name.
 | GetActivePredefinedSettings | Gets the active settings element in the document.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOptions | Gets a copy of options from settings for exporting. Modification on this options would not change the element.
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
 | IsValidName | Returns result that the proposed name is valid and not exist in the specified document.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
 | ListNames | Returns all the names of the settings instances in the document.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetOptions | Sets options for exporting.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExportPDFSettings Class


ExportPDFSettings.Create Method

ExportPDFSettingsCreate Method

Returns an new created ExportPDFSettings element in the document with specified settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ExportPDFSettings Create(
    Document document,
    string name,
    PDFExportOptions options
)
Public Shared Function Create (
    document As Document,
    name As String,
    options As PDFExportOptions
) As ExportPDFSettings
public:
static ExportPDFSettings^ Create(
    Document^ document,
    String^ name,
    PDFExportOptions^ options
)
static member Create :
        document : Document *
        name : string *
        options : PDFExportOptions -> ExportPDFSettings

Parameters

document Document
Document where the settings will be created.
name String
Name to the settings.
options PDFExportOptions
The options to be set.

Return Value

ExportPDFSettings
New instance of ExportPDFSettings just created in the document.
Exceptions
Exception | Condition
ArgumentException | name is an empty string or contains only whitespace. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- Setting name.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
See Also

Reference

ExportPDFSettings Class


ExportPDFSettings.FindByName Method

ExportPDFSettingsFindByName Method

Returns settings element by name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ExportPDFSettings FindByName(
    Document document,
    string name
)
Public Shared Function FindByName (
    document As Document,
    name As String
) As ExportPDFSettings
public:
static ExportPDFSettings^ FindByName(
    Document^ document,
    String^ name
)
static member FindByName :
        document : Document *
        name : string -> ExportPDFSettings

Parameters

document Document
The document to find the settings with the specified name.
name String
Name of the settings to find.

Return Value

ExportPDFSettings
The settings element, or if not found.
Exceptions
Exception | Condition
ArgumentException | name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~".
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportPDFSettings Class


ExportPDFSettings.GetActivePredefinedSettings Method

ExportPDFSettingsGetActivePredefinedSettings Method

Gets the active settings element in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ExportPDFSettings GetActivePredefinedSettings(
    Document document
)
Public Shared Function GetActivePredefinedSettings (
    document As Document
) As ExportPDFSettings
public:
static ExportPDFSettings^ GetActivePredefinedSettings(
    Document^ document
)
static member GetActivePredefinedSettings :
        document : Document -> ExportPDFSettings

Parameters

document Document
The document to find the active settings.

Return Value

ExportPDFSettings
The active settings, or if none.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportPDFSettings Class


ExportPDFSettings.GetOptions Method

ExportPDFSettingsGetOptions Method

Gets a copy of options from settings for exporting. Modification on this options would not change the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PDFExportOptions GetOptions()
Public Function GetOptions As PDFExportOptions
public:
PDFExportOptions^ GetOptions()
member GetOptions : unit -> PDFExportOptions

Return Value

PDFExportOptions
The options.
Remarks
Since the [!:PDFExportOptions.FileName] is not serialized, when [!:Combine] is (which means all the views would be exported into one PDF file, whose file name is specified by [!:PDFExportOptions.FileName]), the returned PDFExportOptions would have [!:PDFExportOptions.FileName] as an empty string. The user has to set the [!:PDFExportOptions.FileName] before calling the [!:Document.Export(string, IList{ElementId}, PDFExportOption)] API exporting a "combined" PDF file.
See Also

Reference

ExportPDFSettings Class


ExportPDFSettings.IsValidName Method

ExportPDFSettingsIsValidName Method

Returns result that the proposed name is valid and not exist in the specified document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidName(
    Document document,
    string name
)
Public Shared Function IsValidName (
    document As Document,
    name As String
) As Boolean
public:
static bool IsValidName(
    Document^ document,
    String^ name
)
static member IsValidName :
        document : Document *
        name : string -> bool

Parameters

document Document
Document to check
name String
Name to check.

Return Value

Boolean
Whether or not the name is valid.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Name can't contains following characters, such as { } [ ] | ; < > ? ` ~ \ : \r \n \f \t \v. Name can't be blank. If true, the name is valid and not exist in specified document. If false, the name is not a valid name which means it does not exist in specified document.
See Also

Reference

ExportPDFSettings Class


ExportPDFSettings.ListNames Method

ExportPDFSettingsListNames Method

Returns all the names of the settings instances in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<string> ListNames(
    Document document
)
Public Shared Function ListNames (
    document As Document
) As IList(Of String)
public:
static IList<String^>^ ListNames(
    Document^ document
)
static member ListNames :
        document : Document -> IList<string>

Parameters

document Document
Document where the settings to be found.

Return Value

IList String
List of names.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportPDFSettings Class


ExportPDFSettings.SetOptions Method

ExportPDFSettingsSetOptions Method

Sets options for exporting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetOptions(
    PDFExportOptions options
)
Public Sub SetOptions (
    options As PDFExportOptions
)
public:
void SetOptions(
    PDFExportOptions^ options
)
member SetOptions :
        options : PDFExportOptions -> unit

Parameters

options PDFExportOptions
Other options.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExportPDFSettings Class


ExportRange Enumeration

This enum is used to define what view, part of the view, or list of views will be exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ExportRange
Public Enumeration ExportRange
public enum class ExportRange
type ExportRange
Members
Member name | Value | Description
CurrentView | 0 | Export the current view only (zoom to fit of the current view).
VisibleRegionOfCurrentView | 1 | Export the visible region of the current view.
SetOfViews | 2 | Export a set of views (set in ViewsAndSheets).
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExportResolution Enumeration

An enumerated type listing possible options to control the tessellation quality.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ExportResolution
Public Enumeration ExportResolution
public enum class ExportResolution
type ExportResolution
Members
Member name | Value | Description
Custom | 0 | Tessellated export with custom resolution (all tessellation parameters have default values).
Fine | 1 | Tessellated export with fine resolution.
Medium | 2 | Tessellated export with medium resolution.
Coarse | 3 | Tessellated export with coarse resolution.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExportSheetType Enumeration

An enumerated type listing possible Sheet type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ExportSheetType
Public Enumeration ExportSheetType
public enum class ExportSheetType
type ExportSheetType
Members
Member name | Value | Description
Current | 0 |
Visible | 1 |
Select | 2 |
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExportTextQualifier Enumeration

Options for the text qualifier character in schedule view export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ExportTextQualifier
Public Enumeration ExportTextQualifier
public enum class ExportTextQualifier
type ExportTextQualifier
Members
Member name | Value | Description
None | 0 | No text qualifier.
Quote | 1 | The quote character - ' - is used to qualify text.
DoubleQuote | 2 | The quote character - " - is used to qualify text.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExportUnit Enumeration

An enumerated type listing possible target units for CAD Export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ExportUnit
Public Enumeration ExportUnit
public enum class ExportUnit
type ExportUnit
Members
Member name | Value | Description
Default | 0 | Default export unit. Depends on Revit's current units.
Inch | 1 | Inches in fractional notation.
Foot | 2 | Feet and Inches in fractional notation.
Millimeter | 3 | Millimeters as decimal values.
Centimeter | 4 | Centimeters as decimal values.
Meter | 5 | Meters as decimal values.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExportUtils Class

This class provides utilities related to document export.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExportUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ExportUtils
Public NotInheritable Class ExportUtils
public ref class ExportUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ExportUtils = class end

The ExportUtils type exposes the following members.

Methods
Name | Description
GetExportId(Subelement) | Retrieves the GUID representing the subelement in DWF and IFC export.
GetExportId(Document, ElementId) | Retrieves the GUID representing this element in DWF and IFC export.
GetGBXMLDocumentId | Retrieves the GUID representing this document in exported gbXML files.
GetNurbsSurfaceDataForSurface | Returns the necessary information to define a NURBS surface for a given [!:Autodesk::Revit::DB::HermiteSuface] or [!:Autodesk::Revit::DB::RuledSuface].
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExportUtils Methods

The ExportUtils type exposes the following members.

Methods
Name | Description
GetExportId(Subelement) | Retrieves the GUID representing the subelement in DWF and IFC export.
GetExportId(Document, ElementId) | Retrieves the GUID representing this element in DWF and IFC export.
GetGBXMLDocumentId | Retrieves the GUID representing this document in exported gbXML files.
GetNurbsSurfaceDataForSurface | Returns the necessary information to define a NURBS surface for a given [!:Autodesk::Revit::DB::HermiteSuface] or [!:Autodesk::Revit::DB::RuledSuface].
Top
See Also

Reference

ExportUtils Class


ExportUtils.GetExportId Method

ExportUtilsGetExportId Method

Overload List
Name | Description
GetExportId(Subelement) | Retrieves the GUID representing the subelement in DWF and IFC export.
GetExportId(Document, ElementId) | Retrieves the GUID representing this element in DWF and IFC export.
Top
See Also

Reference

ExportUtils Class


ExportUtils.GetExportId(Subelement) Method

ExportUtilsGetExportId(Subelement) Method

Retrieves the GUID representing the subelement in DWF and IFC export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Guid GetExportId(
    Subelement subelement
)
Public Shared Function GetExportId (
    subelement As Subelement
) As Guid
public:
static Guid GetExportId(
    Subelement^ subelement
)
static member GetExportId :
        subelement : Subelement -> Guid

Parameters

subelement Subelement
The subelement.

Return Value

Guid
The value of the GUID representing the subelement in the export context.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
This id is used in the contents of DWF export and IFC export and it should be used only when cross-referencing to the contents of these export formats. When storing Ids that will need to be mapped back to subelements in future sessions, UniqueId must be used.
See Also

Reference

ExportUtils Class
GetExportId Overload


ExportUtils.GetExportId(Document, ElementId) Method

ExportUtilsGetExportId(Document, ElementId) Method

Retrieves the GUID representing this element in DWF and IFC export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Guid GetExportId(
    Document document,
    ElementId elementId
)
Public Shared Function GetExportId (
    document As Document,
    elementId As ElementId
) As Guid
public:
static Guid GetExportId(
    Document^ document,
    ElementId^ elementId
)
static member GetExportId :
        document : Document *
        elementId : ElementId -> Guid

Parameters

document Document
The document.
elementId ElementId
The id of the element.

Return Value

Guid
The value of the GUID representing the element in the export context.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
This id is used in the contents of DWF export and IFC export and it should be used only when cross-referencing to the contents of these export formats. When storing Ids that will need to be mapped back to elements in future sessions, UniqueId must be used.
See Also

Reference

ExportUtils Class
GetExportId Overload


ExportUtils.GetGBXMLDocumentId Method

ExportUtilsGetGBXMLDocumentId Method

Retrieves the GUID representing this document in exported gbXML files.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Guid GetGBXMLDocumentId(
    Document document
)
Public Shared Function GetGBXMLDocumentId (
    document As Document
) As Guid
public:
static Guid GetGBXMLDocumentId(
    Document^ document
)
static member GetGBXMLDocumentId :
        document : Document -> Guid

Parameters

document Document
The document.

Return Value

Guid
The value of the GUID representing this document in gbXML export.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
This id can be used to cross-reference different gbXML exports from the same document.
See Also

Reference

ExportUtils Class


ExportUtils.GetNurbsSurfaceDataForSurface Method

ExportUtilsGetNurbsSurfaceDataForSurface Method

Returns the necessary information to define a NURBS surface for a given [!:Autodesk::Revit::DB::HermiteSuface] or [!:Autodesk::Revit::DB::RuledSuface].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static NurbsSurfaceData GetNurbsSurfaceDataForSurface(
    Surface surface
)
Public Shared Function GetNurbsSurfaceDataForSurface (
    surface As Surface
) As NurbsSurfaceData
public:
static NurbsSurfaceData^ GetNurbsSurfaceDataForSurface(
    Surface^ surface
)
static member GetNurbsSurfaceDataForSurface :
        surface : Surface -> NurbsSurfaceData

Parameters

surface Surface
The HermiteSurface or RuledSurface to be converted.

Return Value

NurbsSurfaceData
A class containing the necessary data to define a NURBS surface.
Exceptions
Exception | Condition
ArgumentException | This surface type is not supported for this function.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Couldn't get NURBS data from surface.
Remarks
This function is intended for export purposes.
See Also

Reference

ExportUtils Class


ExternalDBApplicationResult Enumeration

Informs Autodesk Revit of the status of your external db application after execution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ExternalDBApplicationResult
Public Enumeration ExternalDBApplicationResult
public enum class ExternalDBApplicationResult
type ExternalDBApplicationResult
Members
Member name | Value | Description
Succeeded | 0 | The external db application completed successfully. Autodesk Revit will keep this object during the entire Revit session.
Failed | -1 | The external db application was unable to complete its task.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExternalDefinition Class

The ExternalDefinition object adds properties specific to Autodesk Revit shared parameter definitions.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBDefinition
Autodesk.Revit.DBExternalDefinition

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExternalDefinition : Definition,
    IDisposable
Public Class ExternalDefinition
    Inherits Definition
    Implements IDisposable
public ref class ExternalDefinition : public Definition,
    IDisposable
type ExternalDefinition =
    class
        inherit Definition
        interface IDisposable
    end

The ExternalDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Description | The description of the parameter. The description will be used as tooltip in the Revit UI including in the properties palette.
Public property | GUID | Returns the GUID associated with the shared parameter definition.
Public property | HideWhenNoValue | Indicates whether this parameter should be hidden from the properties palette when it has no value.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The user visible name for the parameter. (Overrides DefinitionName)
Public property | OwnerGroup | Returns or change the group ID of the external parameter definition.
Public property | UserModifiable | Indicates whether the parameter can be modified by the user interface.
Public property | Visible | Indicates if the parameter is visible in the Autodesk Revit user interface.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ExternalDefinition
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | GetDataType | Gets a ForgeTypeId identifying the data type describing values of the parameter. (Inherited from Definition)
Public method | GetGroupTypeId | Returns the identifier of the parameter definition's parameter group. (Overrides DefinitionGetGroupTypeId)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

The ExternalDefinition object can be created by a definition Group object from a shared parameters file. External parameter definition must belong to a Group which is nothing more than a collection of shared parameter definitions. The following process should be followed to add a parameter to an element: Open the shared parameters file, via the Application.OpenSharedParameterFile() method. Access an existing or create a new group, via the DefinitionFile.Groups property. Access an existing or create a new external parameter definition, via the DefinitionGroup.Definitions property. Create a new Binding object with the categories to which the parameter will be bound using an InstanceBinding or a TypeBinding object. Finally add the binding and definition to the document using the Document.ParameterBindings object.

Shared parameters added to elements are typically visible to interactive users. To add data to elements that is never visible to interactive users, use Extensible Storage to construct and populate the needed structured data.

Example
C#
VB
C++
F#
Copy
private void ReadEditExternalParam(DefinitionFile file)
{
    // get ExternalDefinition from shared parameter file
    DefinitionGroups myGroups = file.Groups;
    DefinitionGroup myGroup = myGroups.get_Item("MyGroup");
    if (myGroup != null)
    {
         ExternalDefinition myExtDef = myGroup.Definitions.get_Item("MyParam") as ExternalDefinition;
         if (myExtDef != null)
         {
             DefinitionGroup newGroup = myGroups.get_Item("AnotherGroup");
             if (newGroup != null)
             {
                 // change the OwnerGroup of the ExternalDefinition
                 myExtDef.OwnerGroup = newGroup;
             }
         }
    }
}
Private Sub ReadEditExternalParam(file As DefinitionFile)
   ' get ExternalDefinition from shared parameter file
   Dim myGroups As DefinitionGroups = file.Groups
   Dim myGroup As DefinitionGroup = myGroups.Item("MyGroup")
   If myGroup IsNot Nothing Then
      Dim myExtDef As ExternalDefinition = TryCast(myGroup.Definitions.Item("MyParam"), ExternalDefinition)
      If myExtDef IsNot Nothing Then
         Dim newGroup As DefinitionGroup = myGroups.Item("AnotherGroup")
         If newGroup IsNot Nothing Then
            ' change the OwnerGroup of the ExternalDefinition
            myExtDef.OwnerGroup = newGroup
         End If
      End If
   End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExternalDefinition Properties

The ExternalDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Description | The description of the parameter. The description will be used as tooltip in the Revit UI including in the properties palette.
Public property | GUID | Returns the GUID associated with the shared parameter definition.
Public property | HideWhenNoValue | Indicates whether this parameter should be hidden from the properties palette when it has no value.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The user visible name for the parameter. (Overrides DefinitionName)
Public property | OwnerGroup | Returns or change the group ID of the external parameter definition.
Public property | UserModifiable | Indicates whether the parameter can be modified by the user interface.
Public property | Visible | Indicates if the parameter is visible in the Autodesk Revit user interface.
Top
See Also

Reference

ExternalDefinition Class


ExternalDefinition.Description Property

ExternalDefinitionDescription Property

The description of the parameter. The description will be used as tooltip in the Revit UI including in the properties palette.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Description { get; }
Public Overridable ReadOnly Property Description As String
    Get
public:
virtual property String^ Description {
    String^ get ();
}
abstract Description : string with get
override Description : string with get

Property Value

String
See Also

Reference

ExternalDefinition Class


ExternalDefinition.GUID Property

ExternalDefinitionGUID Property

Returns the GUID associated with the shared parameter definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Guid GUID { get; }
Public Overridable ReadOnly Property GUID As Guid
    Get
public:
virtual property Guid GUID {
    Guid get ();
}
abstract GUID : Guid with get
override GUID : Guid with get

Property Value

Guid
Remarks
Each shared parameter when created is issued a unique identifier. This identifier can then be used at a later time to retrieve the parameter from the Element ensuring that the correct parameter is always retrieved.
See Also

Reference

ExternalDefinition Class


ExternalDefinition.HideWhenNoValue Property

ExternalDefinitionHideWhenNoValue Property

Indicates whether this parameter should be hidden from the properties palette when it has no value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HideWhenNoValue { get; set; }
Public Property HideWhenNoValue As Boolean
    Get
    Set
public:
property bool HideWhenNoValue {
    bool get ();
    void set (bool value);
}
member HideWhenNoValue : bool with get, set

Property Value

Boolean
If true, the parameter will be hidden from the properties palette when it has no value. If false, the parameter will always be shown in the properties palette, no matter if it has a value or not.
Remarks
Even when hidden, the parameter can still be accessed directly via the API.
See Also

Reference

ExternalDefinition Class


ExternalDefinition.IsValidObject Property

ExternalDefinitionIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ExternalDefinition Class


ExternalDefinition.Name Property

ExternalDefinitionName Property

The user visible name for the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string Name { get; }
Public Overrides ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () override;
}
abstract Name : string with get
override Name : string with get

Property Value

String
See Also

Reference

ExternalDefinition Class


ExternalDefinition.OwnerGroup Property

ExternalDefinitionOwnerGroup Property

Returns or change the group ID of the external parameter definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual DefinitionGroup OwnerGroup { get; set; }
Public Overridable Property OwnerGroup As DefinitionGroup
    Get
    Set
public:
virtual property DefinitionGroup^ OwnerGroup {
    DefinitionGroup^ get ();
    void set (DefinitionGroup^ value);
}
abstract OwnerGroup : DefinitionGroup with get, set
override OwnerGroup : DefinitionGroup with get, set

Property Value

DefinitionGroup
Remarks
If failed When set the group, an InvalidOperationException will be thrown.
See Also

Reference

ExternalDefinition Class


ExternalDefinition.UserModifiable Property

ExternalDefinitionUserModifiable Property

Indicates whether the parameter can be modified by the user interface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UserModifiable { get; }
Public ReadOnly Property UserModifiable As Boolean
    Get
public:
property bool UserModifiable {
    bool get ();
}
member UserModifiable : bool with get

Property Value

Boolean
Remarks
If true, the user can edit the value of this parameter. If false, the user cannot edit this value (it will appear grayed out). However, any API application can modify the value of this parameter.
See Also

Reference

ExternalDefinition Class


ExternalDefinition.Visible Property

ExternalDefinitionVisible Property

Indicates if the parameter is visible in the Autodesk Revit user interface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Visible { get; }
Public Overridable ReadOnly Property Visible As Boolean
    Get
public:
virtual property bool Visible {
    bool get ();
}
abstract Visible : bool with get
override Visible : bool with get

Property Value

Boolean
Remarks
The visible property controls whether a shared parameter is hidden from the user. This is useful if you wish to add data to an element that is only meaningful to your application and not to the user. This value can only be set when the shared parameter definition is created.
See Also

Reference

ExternalDefinition Class


ExternalDefinition Methods

The ExternalDefinition type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | GetDataType | Gets a ForgeTypeId identifying the data type describing values of the parameter. (Inherited from Definition)
Public method | GetGroupTypeId | Returns the identifier of the parameter definition's parameter group. (Overrides DefinitionGetGroupTypeId)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExternalDefinition Class


ExternalDefinition.Dispose Method

ExternalDefinitionDispose Method

Releases all resources used by the ExternalDefinition

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ExternalDefinition Class


ExternalDefinition.GetGroupTypeId Method

ExternalDefinitionGetGroupTypeId Method

Returns the identifier of the parameter definition's parameter group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ForgeTypeId GetGroupTypeId()
Public Overrides Function GetGroupTypeId As ForgeTypeId
public:
virtual ForgeTypeId^ GetGroupTypeId() override
abstract GetGroupTypeId : unit -> ForgeTypeId
override GetGroupTypeId : unit -> ForgeTypeId

Return Value

ForgeTypeId
See Also

Reference

ExternalDefinition Class


ExternalDefinitionCreationOptions Class

An option class used for creating a new shared parameter definition, including options such as name, type, visibility, Guid description and modifiable flag.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExternalDefinitionCreationOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExternalDefinitionCreationOptions : IDisposable
Public Class ExternalDefinitionCreationOptions
    Implements IDisposable
public ref class ExternalDefinitionCreationOptions : IDisposable
type ExternalDefinitionCreationOptions =
    class
        interface IDisposable
    end

The ExternalDefinitionCreationOptions type exposes the following members.

Constructors
 | Name | Description
Public method | ExternalDefinitionCreationOptions | Constructs the options using a specified name and type.
Top
Properties
 | Name | Description
Public property | Description | The description of the parameter definition to be created. The description will be used as tooltip in the Revit UI including in the properties palette. The default is an empty string.
Public property | GUID | The GUID to use for this parameter definition. If not explicitly set, a random GUID is used.
Public property | HideWhenNoValue | This property indicates whether this parameter should be hidden from the properties palette when it doesn't have a value.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The name of the parameter definition to be created.
Public property | UserModifiable | This property indicates whether this parameter can be modified by UI user or not.
Public property | Visible | True if the parameter is visible to the user, false if it is hidden and accessible only via the API. The default is true.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ExternalDefinitionCreationOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetDataType | Gets the identifier describing the parameter's data type. The identifier may belong to either a spec or a category. If it is a category, the parameter is a Family Type parameter of that category.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetDataType | Sets the parameter's data type.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExternalDefinitionCreationOptions Constructor

Constructs the options using a specified name and type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExternalDefinitionCreationOptions(
    string name,
    ForgeTypeId dataType
)
Public Sub New (
    name As String,
    dataType As ForgeTypeId
)
public:
ExternalDefinitionCreationOptions(
    String^ name,
    ForgeTypeId^ dataType
)
new :
        name : string *
        dataType : ForgeTypeId -> ExternalDefinitionCreationOptions

Parameters

name String
The name of the parameter definition to be created.
dataType ForgeTypeId
The identifier of either a spec or a category. A category identifier indicates a Family Type parameter of that category.
Exceptions
Exception | Condition
ArgumentException | The given identifier is neither a spec nor a category.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExternalDefinitionCreationOptions Class


ExternalDefinitionCreationOptions Properties

The ExternalDefinitionCreationOptions type exposes the following members.

Properties
 | Name | Description
Public property | Description | The description of the parameter definition to be created. The description will be used as tooltip in the Revit UI including in the properties palette. The default is an empty string.
Public property | GUID | The GUID to use for this parameter definition. If not explicitly set, a random GUID is used.
Public property | HideWhenNoValue | This property indicates whether this parameter should be hidden from the properties palette when it doesn't have a value.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The name of the parameter definition to be created.
Public property | UserModifiable | This property indicates whether this parameter can be modified by UI user or not.
Public property | Visible | True if the parameter is visible to the user, false if it is hidden and accessible only via the API. The default is true.
Top
See Also

Reference

ExternalDefinitionCreationOptions Class


ExternalDefinitionCreationOptions.Description Property

ExternalDefinitionCreationOptionsDescription Property

The description of the parameter definition to be created. The description will be used as tooltip in the Revit UI including in the properties palette. The default is an empty string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ExternalDefinitionCreationOptions Class


ExternalDefinitionCreationOptions.GUID Property

ExternalDefinitionCreationOptionsGUID Property

The GUID to use for this parameter definition. If not explicitly set, a random GUID is used.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid GUID { get; set; }
Public Property GUID As Guid
    Get
    Set
public:
property Guid GUID {
    Guid get ();
    void set (Guid value);
}
member GUID : Guid with get, set

Property Value

Guid
See Also

Reference

ExternalDefinitionCreationOptions Class


ExternalDefinitionCreationOptions.HideWhenNoValue Property

ExternalDefinitionCreationOptionsHideWhenNoValue Property

This property indicates whether this parameter should be hidden from the properties palette when it doesn't have a value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HideWhenNoValue { get; set; }
Public Property HideWhenNoValue As Boolean
    Get
    Set
public:
property bool HideWhenNoValue {
    bool get ();
    void set (bool value);
}
member HideWhenNoValue : bool with get, set

Property Value

Boolean
True if the parameter should be hidden when it has no value, False if the parameter should remain visible in the properties palette even when it doesn't have a value. The default is false
See Also

Reference

ExternalDefinitionCreationOptions Class


ExternalDefinitionCreationOptions.IsValidObject Property

ExternalDefinitionCreationOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ExternalDefinitionCreationOptions Class


ExternalDefinitionCreationOptions.Name Property

ExternalDefinitionCreationOptionsName Property

The name of the parameter definition to be created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ExternalDefinitionCreationOptions Class


ExternalDefinitionCreationOptions.UserModifiable Property

ExternalDefinitionCreationOptionsUserModifiable Property

This property indicates whether this parameter can be modified by UI user or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UserModifiable { get; set; }
Public Property UserModifiable As Boolean
    Get
    Set
public:
property bool UserModifiable {
    bool get ();
    void set (bool value);
}
member UserModifiable : bool with get, set

Property Value

Boolean
True if the parameter will be modifiable by the user in the user interface, false if the parameter will display as read-only. The default is true.
See Also

Reference

ExternalDefinitionCreationOptions Class


ExternalDefinitionCreationOptions.Visible Property

ExternalDefinitionCreationOptionsVisible Property

True if the parameter is visible to the user, false if it is hidden and accessible only via the API. The default is true.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Visible { get; set; }
Public Property Visible As Boolean
    Get
    Set
public:
property bool Visible {
    bool get ();
    void set (bool value);
}
member Visible : bool with get, set

Property Value

Boolean
See Also

Reference

ExternalDefinitionCreationOptions Class


ExternalDefinitionCreationOptions Methods

The ExternalDefinitionCreationOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetDataType | Gets the identifier describing the parameter's data type. The identifier may belong to either a spec or a category. If it is a category, the parameter is a Family Type parameter of that category.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetDataType | Sets the parameter's data type.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExternalDefinitionCreationOptions Class


ExternalDefinitionCreationOptions.Dispose Method

ExternalDefinitionCreationOptionsDispose Method

Releases all resources used by the ExternalDefinitionCreationOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ExternalDefinitionCreationOptions Class


ExternalDefinitionCreationOptions.GetDataType Method

ExternalDefinitionCreationOptionsGetDataType Method

Gets the identifier describing the parameter's data type. The identifier may belong to either a spec or a category. If it is a category, the parameter is a Family Type parameter of that category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ForgeTypeId GetDataType()
Public Function GetDataType As ForgeTypeId
public:
ForgeTypeId^ GetDataType()
member GetDataType : unit -> ForgeTypeId

Return Value

ForgeTypeId
See Also

Reference

ExternalDefinitionCreationOptions Class


ExternalDefinitionCreationOptions.SetDataType Method

ExternalDefinitionCreationOptionsSetDataType Method

Sets the parameter's data type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetDataType(
    ForgeTypeId dataType
)
Public Sub SetDataType (
    dataType As ForgeTypeId
)
public:
void SetDataType(
    ForgeTypeId^ dataType
)
member SetDataType :
        dataType : ForgeTypeId -> unit

Parameters

dataType ForgeTypeId
The identifier of either a spec or a category. A category identifier indicates a Family Type parameter of that category.
Exceptions
Exception | Condition
ArgumentException | The given identifier is neither a spec nor a category.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExternalDefinitionCreationOptions Class


ExternalDefinitions Class

Supports the creation of new shared parameters definitions.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBDefinitions
Autodesk.Revit.DBExternalDefinitions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExternalDefinitions : Definitions
Public Class ExternalDefinitions
    Inherits Definitions
public ref class ExternalDefinitions : public Definitions
type ExternalDefinitions =
    class
        inherit Definitions
    end

The ExternalDefinitions type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Identifies if the definitions collection is empty. (Inherited from Definitions)
Public property | Item | Retrieves a definition by a given name. (Inherited from Definitions)
Public property | Size | The number of definitions in the collection. (Inherited from Definitions)
Top
Methods
 | Name | Description
Public method | Contains | Tests for the existence of a definition within the set. (Inherited from Definitions)
Public method | Create | Creates a new parameter definition using specified options. (Inherited from Definitions)
Public method | Dispose | (Inherited from Definitions)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Definitions)
Public method | GetEnumerator | Retrieves an enumerator to the collection. (Inherited from Definitions)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExternalDefinitions Properties

The ExternalDefinitions type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Identifies if the definitions collection is empty. (Inherited from Definitions)
Public property | Item | Retrieves a definition by a given name. (Inherited from Definitions)
Public property | Size | The number of definitions in the collection. (Inherited from Definitions)
Top
See Also

Reference

ExternalDefinitions Class


ExternalDefinitions Methods

The ExternalDefinitions type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Tests for the existence of a definition within the set. (Inherited from Definitions)
Public method | Create | Creates a new parameter definition using specified options. (Inherited from Definitions)
Public method | Dispose | (Inherited from Definitions)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Definitions)
Public method | GetEnumerator | Retrieves an enumerator to the collection. (Inherited from Definitions)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExternalDefinitions Class


ExternalFileReference Class

A class that contains the details of a reference to a file outside of a given document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExternalFileReference

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExternalFileReference : IDisposable
Public Class ExternalFileReference
    Implements IDisposable
public ref class ExternalFileReference : IDisposable
type ExternalFileReference =
    class
        interface IDisposable
    end

The ExternalFileReference type exposes the following members.

Properties
 | Name | Description
Public property | ExternalFileReferenceType | The type of external file which this object references.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | PathType | The path type of the link (relative, absolute, or server).
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ExternalFileReference
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAbsolutePath | Returns an absolute path to the referenced file, regardless of whether the PathType.Enum is relative or absolute.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLinkedFileStatus | Returns a LinkedFileStatus.Enum corresponding to the load status of the referenced file.
Public method | GetPath | Gets the path of the link, relative or absolute according to the link's settings
Public method | GetReferencingId | Gets the ElementId corresponding to the element which this ExternalFileReference is associated with.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | IsValidExternalFileReference | Checks an ExternalFileReference to see if it is properly created.
Public method | IsValidPathTypeForExternalFileReference | Checks whether a PathType enum value will be valid to use with this ExternalFileReference.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExternalFileReference Properties

The ExternalFileReference type exposes the following members.

Properties
 | Name | Description
Public property | ExternalFileReferenceType | The type of external file which this object references.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | PathType | The path type of the link (relative, absolute, or server).
Top
See Also

Reference

ExternalFileReference Class


ExternalFileReference.ExternalFileReferenceType Property

ExternalFileReferenceExternalFileReferenceType Property

The type of external file which this object references.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExternalFileReferenceType ExternalFileReferenceType { get; }
Public ReadOnly Property ExternalFileReferenceType As ExternalFileReferenceType
    Get
public:
property ExternalFileReferenceType ExternalFileReferenceType {
    ExternalFileReferenceType get ();
}
member ExternalFileReferenceType : ExternalFileReferenceType with get

Property Value

ExternalFileReferenceType
See Also

Reference

ExternalFileReference Class


ExternalFileReference.IsValidObject Property

ExternalFileReferenceIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ExternalFileReference Class


ExternalFileReference.PathType Property

ExternalFileReferencePathType Property

The path type of the link (relative, absolute, or server).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PathType PathType { get; }
Public ReadOnly Property PathType As PathType
    Get
public:
property PathType PathType {
    PathType get ();
}
member PathType : PathType with get

Property Value

PathType
See Also

Reference

ExternalFileReference Class


ExternalFileReference Methods

The ExternalFileReference type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAbsolutePath | Returns an absolute path to the referenced file, regardless of whether the PathType.Enum is relative or absolute.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLinkedFileStatus | Returns a LinkedFileStatus.Enum corresponding to the load status of the referenced file.
Public method | GetPath | Gets the path of the link, relative or absolute according to the link's settings
Public method | GetReferencingId | Gets the ElementId corresponding to the element which this ExternalFileReference is associated with.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | IsValidExternalFileReference | Checks an ExternalFileReference to see if it is properly created.
Public method | IsValidPathTypeForExternalFileReference | Checks whether a PathType enum value will be valid to use with this ExternalFileReference.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExternalFileReference Class


ExternalFileReference.Dispose Method

ExternalFileReferenceDispose Method

Releases all resources used by the ExternalFileReference

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ExternalFileReference Class


ExternalFileReference.GetAbsolutePath Method

ExternalFileReferenceGetAbsolutePath Method

Returns an absolute path to the referenced file, regardless of whether the PathType.Enum is relative or absolute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ModelPath GetAbsolutePath()
Public Function GetAbsolutePath As ModelPath
public:
ModelPath^ GetAbsolutePath()
member GetAbsolutePath : unit -> ModelPath

Return Value

ModelPath
A full path to the linked model.
Remarks
ExternalFileReferences which are taken from a closed document will report their absolute path as of the last time the document was saved.
See Also

Reference

ExternalFileReference Class


ExternalFileReference.GetLinkedFileStatus Method

ExternalFileReferenceGetLinkedFileStatus Method

Returns a LinkedFileStatus.Enum corresponding to the load status of the referenced file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LinkedFileStatus GetLinkedFileStatus()
Public Function GetLinkedFileStatus As LinkedFileStatus
public:
LinkedFileStatus GetLinkedFileStatus()
member GetLinkedFileStatus : unit -> LinkedFileStatus

Return Value

LinkedFileStatus
Remarks
Options are Invalid, Loaded, Unloaded, NotFound, or Imported.
See Also

Reference

ExternalFileReference Class


ExternalFileReference.GetPath Method

ExternalFileReferenceGetPath Method

Gets the path of the link, relative or absolute according to the link's settings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ModelPath GetPath()
Public Function GetPath As ModelPath
public:
ModelPath^ GetPath()
member GetPath : unit -> ModelPath

Return Value

ModelPath
The path of the link. This path will be relative for relatively-pathed links.
See Also

Reference

ExternalFileReference Class


ExternalFileReference.GetReferencingId Method

ExternalFileReferenceGetReferencingId Method

Gets the ElementId corresponding to the element which this ExternalFileReference is associated with.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GetReferencingId()
Public Function GetReferencingId As ElementId
public:
ElementId^ GetReferencingId()
member GetReferencingId : unit -> ElementId

Return Value

ElementId
See Also

Reference

ExternalFileReference Class


ExternalFileReference.IsValidExternalFileReference Method

ExternalFileReferenceIsValidExternalFileReference Method

Checks an ExternalFileReference to see if it is properly created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidExternalFileReference(
    ExternalFileReference data
)
Public Shared Function IsValidExternalFileReference (
    data As ExternalFileReference
) As Boolean
public:
static bool IsValidExternalFileReference(
    ExternalFileReference^ data
)
static member IsValidExternalFileReference :
        data : ExternalFileReference -> bool

Parameters

data ExternalFileReference
The ExternalFileReference to be checked

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
The following restrictions exist:
  • PathType.Server is only valid for ExternalFileReferences of type ExternalFileReferenceType.RevitLink
  • PathType.Content is only valid for ExternalFileReferences of type ExternalFileReferenceType.KeynoteTable, ExternalFileReferenceType.AssemblyCodeTable or ExternalFileReferenceType.Decal
  • Keynote tables, assembly code tables and Decals (ExternalFileReferenceType.KeynoteTable, ExternalFileReferenceType.AssemblyCodeTable and ExternalFileReferenceType.Decal) may only be LinkedFileStatus.Loaded or LinkedFileStatus.NotFound.
See Also

Reference

ExternalFileReference Class


ExternalFileReference.IsValidPathTypeForExternalFileReference Method

ExternalFileReferenceIsValidPathTypeForExternalFileReference Method

Checks whether a PathType enum value will be valid to use with this ExternalFileReference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidPathTypeForExternalFileReference(
    PathType pathType
)
Public Function IsValidPathTypeForExternalFileReference (
    pathType As PathType
) As Boolean
public:
bool IsValidPathTypeForExternalFileReference(
    PathType pathType
)
member IsValidPathTypeForExternalFileReference :
        pathType : PathType -> bool

Parameters

pathType PathType

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Remarks
  • PathType.Server is only valid for ExternalFileReferences of type ExternalFileReferenceType.RevitLink
  • PathType.Content is only valid for ExternalFileReferences of type ExternalFileReferenceType.KeynoteTable, ExternalFileReferenceType.AssemblyCodeTable and ExternalFileReferenceType.Decal
See Also

Reference

ExternalFileReference Class


ExternalFileReferenceType Enumeration

Enum class indicating kinds of external file references

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ExternalFileReferenceType
Public Enumeration ExternalFileReferenceType
public enum class ExternalFileReferenceType
type ExternalFileReferenceType
Members
Member name | Value | Description
None | 0 | Uninitialized value
RevitLink | 1 | Revit linked files
CADLink | 2 | Linked CAD files
DWFMarkup | 3 | DWF markup files
KeynoteTable | 4 | The keynote table (The file which contains keynote information.)
Decal | 5 | Decals (images which appear only during rendering)
Material | 6 | Materials are not included as ExternalFileReferences in the 2012 release
AssemblyCodeTable | 7 | The assembly code table (The file which contains assembly code information.)
SystemsAnalysisReport | 12 | Systems analysis report file path
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExternalFileUtils Class

A utility class containing functions related to external file references.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExternalFileUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ExternalFileUtils
Public NotInheritable Class ExternalFileUtils
public ref class ExternalFileUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ExternalFileUtils = class end

The ExternalFileUtils type exposes the following members.

Methods
Name | Description
GetAllExternalFileReferences | Gets the ids of all elements which are external file references.
GetExternalFileReference | Gets the external file referencing data for the given element.
GetFileBasedTempFolder | Gets a temp folder based on the given file name
IsExternalFileReference | Determines whether the given element represents an external file.
Top
Remarks
Elements which are external file references refer to files outside of the base .rvt file. Examples include Revit links, CAD links, the element which stores the location of the keynote file, and rendering decals.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExternalFileUtils Methods

The ExternalFileUtils type exposes the following members.

Methods
Name | Description
GetAllExternalFileReferences | Gets the ids of all elements which are external file references.
GetExternalFileReference | Gets the external file referencing data for the given element.
GetFileBasedTempFolder | Gets a temp folder based on the given file name
IsExternalFileReference | Determines whether the given element represents an external file.
Top
See Also

Reference

ExternalFileUtils Class


ExternalFileUtils.GetAllExternalFileReferences Method

ExternalFileUtilsGetAllExternalFileReferences Method

Gets the ids of all elements which are external file references.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ICollection<ElementId> GetAllExternalFileReferences(
    Document aDoc
)
Public Shared Function GetAllExternalFileReferences (
    aDoc As Document
) As ICollection(Of ElementId)
public:
static ICollection<ElementId^>^ GetAllExternalFileReferences(
    Document^ aDoc
)
static member GetAllExternalFileReferences :
        aDoc : Document -> ICollection<ElementId>

Parameters

aDoc Document
A Revit Document.

Return Value

ICollection ElementId
The ids of all elements which are external file references.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
This function will not return the ids of nested Revit links; it only returns top-level references.
See Also

Reference

ExternalFileUtils Class


ExternalFileUtils.GetExternalFileReference Method

ExternalFileUtilsGetExternalFileReference Method

Gets the external file referencing data for the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ExternalFileReference GetExternalFileReference(
    Document aDoc,
    ElementId elemId
)
Public Shared Function GetExternalFileReference (
    aDoc As Document,
    elemId As ElementId
) As ExternalFileReference
public:
static ExternalFileReference^ GetExternalFileReference(
    Document^ aDoc,
    ElementId^ elemId
)
static member GetExternalFileReference :
        aDoc : Document *
        elemId : ElementId -> ExternalFileReference

Parameters

aDoc Document
A Revit Document.
elemId ElementId
The element whose external file reference we want.

Return Value

ExternalFileReference
An object containing path and type information for the given element's external file.
Exceptions
Exception | Condition
ArgumentException | The element elemId does not exist in the document -or- elemId does not represent an external file reference.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExternalFileUtils Class


ExternalFileUtils.GetFileBasedTempFolder Method

ExternalFileUtilsGetFileBasedTempFolder Method

Gets a temp folder based on the given file name

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetFileBasedTempFolder(
    string filename
)
Public Shared Function GetFileBasedTempFolder (
    filename As String
) As String
public:
static String^ GetFileBasedTempFolder(
    String^ filename
)
static member GetFileBasedTempFolder :
        filename : string -> string

Parameters

filename String

Return Value

String
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExternalFileUtils Class


ExternalFileUtils.IsExternalFileReference Method

ExternalFileUtilsIsExternalFileReference Method

Determines whether the given element represents an external file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsExternalFileReference(
    Document aDoc,
    ElementId elemId
)
Public Shared Function IsExternalFileReference (
    aDoc As Document,
    elemId As ElementId
) As Boolean
public:
static bool IsExternalFileReference(
    Document^ aDoc,
    ElementId^ elemId
)
static member IsExternalFileReference :
        aDoc : Document *
        elemId : ElementId -> bool

Parameters

aDoc Document
A Revit Document.
elemId ElementId
The element to be checked for an external file reference.

Return Value

Boolean
True if the given element represents an external file; false otherwise.
Exceptions
Exception | Condition
ArgumentException | The element elemId does not exist in the document
ArgumentNullException | A non-optional argument was null
Remarks

CAD imports are not external file references, as their data is brought fully into Revit. No connection is maintained to the original file.

A link may be an external resource without being an external file.

See Also

Reference

ExternalFileUtils Class


ExternalGeometryId Class

This class represents an identifier for geometry from external sources.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExternalGeometryId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExternalGeometryId : IDisposable
Public Class ExternalGeometryId
    Implements IDisposable
public ref class ExternalGeometryId : IDisposable
type ExternalGeometryId =
    class
        interface IDisposable
    end

The ExternalGeometryId type exposes the following members.

Constructors
 | Name | Description
Public method | ExternalGeometryId | Constructs an ExternalGeometryId object holding the given external geometry identifier.
Top
Properties
 | Name | Description
Public property | Id | External geometry identifier.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ExternalGeometryId
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object))
Public method | GetHashCode | Gets the hash code. (Overrides ObjectGetHashCode)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | IsValidExternalGeometryId | Checks whether a given string represents a valid ExternalGeometryId or not.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Operators
Name | Description
Equality(ExternalGeometryId, ExternalGeometryId) | Determines whether two ExternalGeometryIds are the same.
Inequality(ExternalGeometryId, ExternalGeometryId) | Determines whether two ExternalGeometryIds are different.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExternalGeometryId Constructor

Constructs an ExternalGeometryId object holding the given external geometry identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExternalGeometryId(
    string externalGeometryId
)
Public Sub New (
    externalGeometryId As String
)
public:
ExternalGeometryId(
    String^ externalGeometryId
)
new :
        externalGeometryId : string -> ExternalGeometryId

Parameters

externalGeometryId String
A string that represents an identifier for an external geometry.
Exceptions
Exception | Condition
ArgumentException | externalGeometryId is not a valid ExternalGeometryId.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExternalGeometryId Class


ExternalGeometryId Properties

The ExternalGeometryId type exposes the following members.

Properties
 | Name | Description
Public property | Id | External geometry identifier.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

ExternalGeometryId Class


ExternalGeometryId.Id Property

ExternalGeometryIdId Property

External geometry identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Id { get; }
Public ReadOnly Property Id As String
    Get
public:
property String^ Id {
    String^ get ();
}
member Id : string with get

Property Value

String
See Also

Reference

ExternalGeometryId Class


ExternalGeometryId.IsValidObject Property

ExternalGeometryIdIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ExternalGeometryId Class


ExternalGeometryId Methods

The ExternalGeometryId type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object))
Public method | GetHashCode | Gets the hash code. (Overrides ObjectGetHashCode)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | IsValidExternalGeometryId | Checks whether a given string represents a valid ExternalGeometryId or not.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExternalGeometryId Class


ExternalGeometryId.Dispose Method

ExternalGeometryIdDispose Method

Releases all resources used by the ExternalGeometryId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ExternalGeometryId Class


ExternalGeometryId.Equals Method

ExternalGeometryIdEquals Method

Determines whether the specified Object is equal to the current Object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj Object
Another object.

Return Value

Boolean
See Also

Reference

ExternalGeometryId Class


ExternalGeometryId.GetHashCode Method

ExternalGeometryIdGetHashCode Method

Gets the hash code.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Int32
See Also

Reference

ExternalGeometryId Class


ExternalGeometryId.IsValidExternalGeometryId Method

ExternalGeometryIdIsValidExternalGeometryId Method

Checks whether a given string represents a valid ExternalGeometryId or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidExternalGeometryId(
    string externalGeometryId
)
Public Shared Function IsValidExternalGeometryId (
    externalGeometryId As String
) As Boolean
public:
static bool IsValidExternalGeometryId(
    String^ externalGeometryId
)
static member IsValidExternalGeometryId :
        externalGeometryId : string -> bool

Parameters

externalGeometryId String
A string that represents an identifier for an external geometry.

Return Value

Boolean
True if the string represents a valid ExternalGeometryId, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Any non-empty string is a valid ExternalGeometryId.
See Also

Reference

ExternalGeometryId Class


ExternalGeometryId Operators

The ExternalGeometryId type exposes the following members.

Operators
Name | Description
Equality(ExternalGeometryId, ExternalGeometryId) | Determines whether two ExternalGeometryIds are the same.
Inequality(ExternalGeometryId, ExternalGeometryId) | Determines whether two ExternalGeometryIds are different.
Top
See Also

Reference

ExternalGeometryId Class


ExternalGeometryId.Equality Operator

ExternalGeometryIdEquality Operator

Determines whether two ExternalGeometryIds are the same.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool operator ==(
    ExternalGeometryId first,
    ExternalGeometryId second
)
Public Shared Operator = (
    first As ExternalGeometryId,
    second As ExternalGeometryId
) As Boolean
public:
static bool operator ==(
    ExternalGeometryId^ first,
    ExternalGeometryId^ second
)
static let inline (=)
        first : ExternalGeometryId *
        second : ExternalGeometryId  : bool

Parameters

first ExternalGeometryId
The first ExternalGeometryId.
second ExternalGeometryId
The second ExternalGeometryId.

Return Value

Boolean
True if the ExternalGeometryIds are the same; otherwise, false.
See Also

Reference

ExternalGeometryId Class


ExternalGeometryId.Inequality Operator

ExternalGeometryIdInequality Operator

Determines whether two ExternalGeometryIds are different.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool operator !=(
    ExternalGeometryId first,
    ExternalGeometryId second
)
Public Shared Operator <> (
    first As ExternalGeometryId,
    second As ExternalGeometryId
) As Boolean
public:
static bool operator !=(
    ExternalGeometryId^ first,
    ExternalGeometryId^ second
)
static let inline (<>)
        first : ExternalGeometryId *
        second : ExternalGeometryId  : bool

Parameters

first ExternalGeometryId
The first ExternalGeometryId.
second ExternalGeometryId
The second ExternalGeometryId.

Return Value

Boolean
True if the ExternalGeometryIds are different; otherwise, false.
See Also

Reference

ExternalGeometryId Class


ExternallyTaggedBRep Class

An ExternallyTaggedSolid can hold any shape created by BRepBuilder.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExternallyTaggedGeometryObject
Autodesk.Revit.DBExternallyTaggedBRep

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExternallyTaggedBRep : ExternallyTaggedGeometryObject
Public Class ExternallyTaggedBRep
    Inherits ExternallyTaggedGeometryObject
public ref class ExternallyTaggedBRep : public ExternallyTaggedGeometryObject
type ExternallyTaggedBRep =
    class
        inherit ExternallyTaggedGeometryObject
    end

The ExternallyTaggedBRep type exposes the following members.

Properties
 | Name | Description
Public property | ExternalId | The external Id of the geometry object. (Inherited from ExternallyTaggedGeometryObject)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ExternallyTaggedGeometryObject)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from ExternallyTaggedGeometryObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetTaggedGeometry | Returns the externally tagged geometry object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExternallyTaggedBRep Properties

The ExternallyTaggedBRep type exposes the following members.

Properties
 | Name | Description
Public property | ExternalId | The external Id of the geometry object. (Inherited from ExternallyTaggedGeometryObject)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ExternallyTaggedGeometryObject)
Top
See Also

Reference

ExternallyTaggedBRep Class


ExternallyTaggedBRep Methods

The ExternallyTaggedBRep type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from ExternallyTaggedGeometryObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetTaggedGeometry | Returns the externally tagged geometry object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExternallyTaggedBRep Class


ExternallyTaggedBRep.GetTaggedGeometry Method

ExternallyTaggedBRepGetTaggedGeometry Method

Returns the externally tagged geometry object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GeometryObject GetTaggedGeometry(
    ExternalGeometryId externalId
)
Public Function GetTaggedGeometry (
    externalId As ExternalGeometryId
) As GeometryObject
public:
GeometryObject^ GetTaggedGeometry(
    ExternalGeometryId^ externalId
)
member GetTaggedGeometry :
        externalId : ExternalGeometryId -> GeometryObject

Parameters

externalId ExternalGeometryId
An external tag that may match a geometry object (i.e face/edge) in this Solid.

Return Value

GeometryObject
Returns the geometry object that matches the external tag. If no such object is found, this method will return null.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExternallyTaggedBRep Class


ExternallyTaggedGeometryObject Class

Base class for ExternallyTaggedGeometryObject and ExternallyTaggedSolid.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExternallyTaggedGeometryObject
Autodesk.Revit.DBExternallyTaggedBRep
Autodesk.Revit.DBExternallyTaggedNonBRep

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExternallyTaggedGeometryObject : IDisposable
Public Class ExternallyTaggedGeometryObject
    Implements IDisposable
public ref class ExternallyTaggedGeometryObject : IDisposable
type ExternallyTaggedGeometryObject =
    class
        interface IDisposable
    end

The ExternallyTaggedGeometryObject type exposes the following members.

Properties
 | Name | Description
Public property | ExternalId | The external Id of the geometry object.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ExternallyTaggedGeometryObject
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExternallyTaggedGeometryObject Properties

The ExternallyTaggedGeometryObject type exposes the following members.

Properties
 | Name | Description
Public property | ExternalId | The external Id of the geometry object.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

ExternallyTaggedGeometryObject Class


ExternallyTaggedGeometryObject.ExternalId Property

ExternallyTaggedGeometryObjectExternalId Property

The external Id of the geometry object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExternalGeometryId ExternalId { get; }
Public ReadOnly Property ExternalId As ExternalGeometryId
    Get
public:
property ExternalGeometryId^ ExternalId {
    ExternalGeometryId^ get ();
}
member ExternalId : ExternalGeometryId with get

Property Value

ExternalGeometryId
See Also

Reference

ExternallyTaggedGeometryObject Class


ExternallyTaggedGeometryObject.IsValidObject Property

ExternallyTaggedGeometryObjectIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ExternallyTaggedGeometryObject Class


ExternallyTaggedGeometryObject Methods

The ExternallyTaggedGeometryObject type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExternallyTaggedGeometryObject Class


ExternallyTaggedGeometryObject.Dispose Method

ExternallyTaggedGeometryObjectDispose Method

Releases all resources used by the ExternallyTaggedGeometryObject

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ExternallyTaggedGeometryObject Class


ExternallyTaggedGeometryValidation Class

Provides validation for geometry to be stored in an ExternallyTaggedGeometry.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExternallyTaggedGeometryValidation

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ExternallyTaggedGeometryValidation
Public NotInheritable Class ExternallyTaggedGeometryValidation
public ref class ExternallyTaggedGeometryValidation abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ExternallyTaggedGeometryValidation = class end

The ExternallyTaggedGeometryValidation type exposes the following members.

Methods
Name | Description
IsNonSolid | Makes sure that the input geometry object is not a Solid.
IsSolid | Makes sure that the input geometry object is a Solid.
LacksSubnodes | Makes sure that the input geometry object does not have sub-nodes.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExternallyTaggedGeometryValidation Methods

The ExternallyTaggedGeometryValidation type exposes the following members.

Methods
Name | Description
IsNonSolid | Makes sure that the input geometry object is not a Solid.
IsSolid | Makes sure that the input geometry object is a Solid.
LacksSubnodes | Makes sure that the input geometry object does not have sub-nodes.
Top
See Also

Reference

ExternallyTaggedGeometryValidation Class


ExternallyTaggedGeometryValidation.IsNonSolid Method

ExternallyTaggedGeometryValidationIsNonSolid Method

Makes sure that the input geometry object is not a Solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsNonSolid(
    GeometryObject geometry
)
Public Shared Function IsNonSolid (
    geometry As GeometryObject
) As Boolean
public:
static bool IsNonSolid(
    GeometryObject^ geometry
)
static member IsNonSolid :
        geometry : GeometryObject -> bool

Parameters

geometry GeometryObject
Geometry object to be validated.

Return Value

Boolean
True if the supplied geometry object is not a Solid.
Remarks
This validation is different than negating IsSolid().
See Also

Reference

ExternallyTaggedGeometryValidation Class


ExternallyTaggedGeometryValidation.IsSolid Method

ExternallyTaggedGeometryValidationIsSolid Method

Makes sure that the input geometry object is a Solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsSolid(
    GeometryObject geometry
)
Public Shared Function IsSolid (
    geometry As GeometryObject
) As Boolean
public:
static bool IsSolid(
    GeometryObject^ geometry
)
static member IsSolid :
        geometry : GeometryObject -> bool

Parameters

geometry GeometryObject
Geometry object to be validated.

Return Value

Boolean
True if the supplied geometry object is a Solid.
Remarks
This validation is different than negating IsNonSolid().
See Also

Reference

ExternallyTaggedGeometryValidation Class


ExternallyTaggedGeometryValidation.LacksSubnodes Method

ExternallyTaggedGeometryValidationLacksSubnodes Method

Makes sure that the input geometry object does not have sub-nodes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool LacksSubnodes(
    GeometryObject geometry
)
Public Shared Function LacksSubnodes (
    geometry As GeometryObject
) As Boolean
public:
static bool LacksSubnodes(
    GeometryObject^ geometry
)
static member LacksSubnodes :
        geometry : GeometryObject -> bool

Parameters

geometry GeometryObject
Geometry object to be validated.

Return Value

Boolean
True if the supplied geometry object does not have sub-nodes.
See Also

Reference

ExternallyTaggedGeometryValidation Class


ExternallyTaggedNonBRep Class

This class is used to create an externally tagged geometry object.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExternallyTaggedGeometryObject
Autodesk.Revit.DBExternallyTaggedNonBRep

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExternallyTaggedNonBRep : ExternallyTaggedGeometryObject
Public Class ExternallyTaggedNonBRep
    Inherits ExternallyTaggedGeometryObject
public ref class ExternallyTaggedNonBRep : public ExternallyTaggedGeometryObject
type ExternallyTaggedNonBRep =
    class
        inherit ExternallyTaggedGeometryObject
    end

The ExternallyTaggedNonBRep type exposes the following members.

Constructors
 | Name | Description
Public method | ExternallyTaggedNonBRep | Constructs an ExternallyTaggedGeometryObject associating a given ExternalGeometryId with a particular GeometryObject.
Top
Properties
 | Name | Description
Public property | ExternalId | The external Id of the geometry object. (Inherited from ExternallyTaggedGeometryObject)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ExternallyTaggedGeometryObject)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from ExternallyTaggedGeometryObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetUsage | Controls the usage of this ExternallyTaggedNonBRep.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExternallyTaggedNonBRep Constructor

Constructs an ExternallyTaggedGeometryObject associating a given ExternalGeometryId with a particular GeometryObject.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExternallyTaggedNonBRep(
    ExternalGeometryId externalId,
    GeometryObject geometry
)
Public Sub New (
    externalId As ExternalGeometryId,
    geometry As GeometryObject
)
public:
ExternallyTaggedNonBRep(
    ExternalGeometryId^ externalId,
    GeometryObject^ geometry
)
new :
        externalId : ExternalGeometryId *
        geometry : GeometryObject -> ExternallyTaggedNonBRep

Parameters

externalId ExternalGeometryId
The Id of the input geometry object.
geometry GeometryObject
The externally tagged geometry object.
Exceptions
Exception | Condition
ArgumentException | geometry must not be a Solid. -or- geometry must not have sub-nodes.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExternallyTaggedNonBRep Class


ExternallyTaggedNonBRep Properties

The ExternallyTaggedNonBRep type exposes the following members.

Properties
 | Name | Description
Public property | ExternalId | The external Id of the geometry object. (Inherited from ExternallyTaggedGeometryObject)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ExternallyTaggedGeometryObject)
Top
See Also

Reference

ExternallyTaggedNonBRep Class


ExternallyTaggedNonBRep Methods

The ExternallyTaggedNonBRep type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from ExternallyTaggedGeometryObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetUsage | Controls the usage of this ExternallyTaggedNonBRep.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExternallyTaggedNonBRep Class


ExternallyTaggedNonBRep.SetUsage Method

ExternallyTaggedNonBRepSetUsage Method

Controls the usage of this ExternallyTaggedNonBRep.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetUsage(
    ExternallyTaggedNonBRepUsage usage
)
Public Sub SetUsage (
    usage As ExternallyTaggedNonBRepUsage
)
public:
void SetUsage(
    ExternallyTaggedNonBRepUsage usage
)
member SetUsage :
        usage : ExternallyTaggedNonBRepUsage -> unit

Parameters

usage ExternallyTaggedNonBRepUsage
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ExternallyTaggedNonBRep Class


ExternallyTaggedNonBReps Class

Holds a collection of ExternallyTaggedNonBRep instances.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExternallyTaggedNonBReps

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExternallyTaggedNonBReps : IDisposable
Public Class ExternallyTaggedNonBReps
    Implements IDisposable
public ref class ExternallyTaggedNonBReps : IDisposable
type ExternallyTaggedNonBReps =
    class
        interface IDisposable
    end

The ExternallyTaggedNonBReps type exposes the following members.

Constructors
 | Name | Description
Public method | ExternallyTaggedNonBReps | Make a new empty collection of ExternallyTaggedNonBRep instances.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Add | Adds a copy of the input ExternallyTaggedNonBRep to this collection.
Public method | CanAddExternallyTaggedNonBRep | Checks if the input geometry could be added to this collection or not.
Public method | Dispose | Releases all resources used by the ExternallyTaggedNonBReps
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExternallyTaggedNonBReps Constructor

Make a new empty collection of ExternallyTaggedNonBRep instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExternallyTaggedNonBReps()
Public Sub New
public:
ExternallyTaggedNonBReps()
new : unit -> ExternallyTaggedNonBReps
See Also

Reference

ExternallyTaggedNonBReps Class


ExternallyTaggedNonBReps Properties

The ExternallyTaggedNonBReps type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

ExternallyTaggedNonBReps Class


ExternallyTaggedNonBReps.IsValidObject Property

ExternallyTaggedNonBRepsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ExternallyTaggedNonBReps Class


ExternallyTaggedNonBReps Methods

The ExternallyTaggedNonBReps type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a copy of the input ExternallyTaggedNonBRep to this collection.
Public method | CanAddExternallyTaggedNonBRep | Checks if the input geometry could be added to this collection or not.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExternallyTaggedNonBReps Class


ExternallyTaggedNonBReps.Add Method

ExternallyTaggedNonBRepsAdd Method

Adds a copy of the input ExternallyTaggedNonBRep to this collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Add(
    ExternallyTaggedNonBRep geometry
)
Public Sub Add (
    geometry As ExternallyTaggedNonBRep
)
public:
void Add(
    ExternallyTaggedNonBRep^ geometry
)
member Add :
        geometry : ExternallyTaggedNonBRep -> unit

Parameters

geometry ExternallyTaggedNonBRep
The ExternallyTaggedNonBRep to be added.
Exceptions
Exception | Condition
ArgumentException | The ExternalGeometryId of geometry already exists in this collection.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExternallyTaggedNonBReps Class


ExternallyTaggedNonBReps.CanAddExternallyTaggedNonBRep Method

ExternallyTaggedNonBRepsCanAddExternallyTaggedNonBRep Method

Checks if the input geometry could be added to this collection or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanAddExternallyTaggedNonBRep(
    ExternallyTaggedNonBRep geometry
)
Public Function CanAddExternallyTaggedNonBRep (
    geometry As ExternallyTaggedNonBRep
) As Boolean
public:
bool CanAddExternallyTaggedNonBRep(
    ExternallyTaggedNonBRep^ geometry
)
member CanAddExternallyTaggedNonBRep :
        geometry : ExternallyTaggedNonBRep -> bool

Parameters

geometry ExternallyTaggedNonBRep

Return Value

Boolean
True if we can add the input geometry to this collection, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Duplicate ExternalGeometryIds are prohibited.
See Also

Reference

ExternallyTaggedNonBReps Class


ExternallyTaggedNonBReps.Dispose Method

ExternallyTaggedNonBRepsDispose Method

Releases all resources used by the ExternallyTaggedNonBReps

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ExternallyTaggedNonBReps Class


ExternallyTaggedNonBRepUsage Enumeration

The ways in which an ExternallyTaggedNonBRep can be used in Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ExternallyTaggedNonBRepUsage
Public Enumeration ExternallyTaggedNonBRepUsage
public enum class ExternallyTaggedNonBRepUsage
type ExternallyTaggedNonBRepUsage
Members
Member name | Value | Description
Displayable | 0 | Can be used for display purposes.
Selectable | 1 | Can be selected as well as displayed.
Snappable | 2 | Can be snapped to as well as selected.
Referenceable | 3 | Can be dimensioned to as well as snapped to.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExternalResourceBrowserData Class

Represents a collection of external resources and external resource folders to be presented as the content of a folder in the file browser in Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExternalResourceBrowserData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExternalResourceBrowserData : IDisposable
Public Class ExternalResourceBrowserData
    Implements IDisposable
public ref class ExternalResourceBrowserData : IDisposable
type ExternalResourceBrowserData =
    class
        interface IDisposable
    end

The ExternalResourceBrowserData type exposes the following members.

Constructors
 | Name | Description
Public method | ExternalResourceBrowserData | Constructs a new ExternalResourceBrowserData using the given document(optional), server id, folder path and match options.
Top
Properties
 | Name | Description
Public property | FolderPath | The current folder path to which the new resources and subfolder belong.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ServerId | The Id of IExternalResourceServer which handles the external resource load.
Top
Methods
 | Name | Description
Public method | AddResource(String) | Adds an external resource to the folder path by supplying the resource name.
Public method | AddResource(String, IDictionaryString, String) | Adds an external resource to the folder path by supplying the resource name and reference information.
Public method | AddResource(String, String) | Adds an external resource to the folder path by supplying the resource name and version.
Public method | AddResource(String, String, IDictionaryString, String) | Adds an external resource to the folder path by supplying the resource name, version and reference information.
Public method | AddSubFolder(String) | Adds a subfolder to the folder path with the given name.
Public method | AddSubFolder(String, String) | Adds a subfolder to the folder path with the given name and icon type.
Public method | CallingDocumentHasModelPath | Indicates whether the document requesting the external resource browser data has a defined ModelPath.
Public method | Dispose | Releases all resources used by the ExternalResourceBrowserData
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCallingDocumentModelPath | Returns a copy of the ModelPath of the document that is requesting the external resource browser data.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMatchOptions | Gets the match options used to filter external resources.
Public method | GetResources | Gets the external resources under the folder path of the browser data.
Public method | GetSubFoldersData | Gets the subfolders data under the folder path of the browser data.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsValidFolderName | Checks whether the folder name is valid.
Public method | IsValidResourceName | Checks whether the resource name is valid.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

This data represents the contents to be shown to the user while they are browsing a specific folder in Revit.

The folder path can be obtained from the FolderPath property.

The external resource server is expected to populate all of the available resources and subfolders that should appear in the Revit file browser while the browser is open to this particular folder.

If the user navigates to another folder, a different ExternalResourceBrowserData object will be provided to allow the server to populate resources at that location.

When adding resource and subfolder, the resource and subfolder should not be added recursively.

When adding resource and subfolder, the name should be unique short name(without folder).

The name of resource and subfolder should not contain any invalid character of \/:*?"<>|.

The length of resource combined path(server name + folder path + resource name) should not exceed 259; The length of subfolder also has same restriction.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExternalResourceBrowserData Constructor

Constructs a new ExternalResourceBrowserData using the given document(optional), server id, folder path and match options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExternalResourceBrowserData(
    Document document,
    Guid serverId,
    string folderPath,
    ExternalResourceMatchOptions matchOptions
)
Public Sub New (
    document As Document,
    serverId As Guid,
    folderPath As String,
    matchOptions As ExternalResourceMatchOptions
)
public:
ExternalResourceBrowserData(
    Document^ document,
    Guid serverId,
    String^ folderPath,
    ExternalResourceMatchOptions^ matchOptions
)
new :
        document : Document *
        serverId : Guid *
        folderPath : string *
        matchOptions : ExternalResourceMatchOptions -> ExternalResourceBrowserData

Parameters

document Document
The document for which the external resource browser data is requested. The document can be , if so, the getCallingDocumentModelPath() will not return ModelPath.
serverId Guid
The id of IExternalResourceServer which handles the external resource browsing and loading.
folderPath String
The folder path to which the external resources and subfolders belong.

The folder separator should always be "/" and "/" always represents the root folder for the server.

The interpretation of what a folder represents is up to the server. For example, the folder "/English/Keynote" might be a physical folder on a disk, or a table or key in a database.

matchOptions ExternalResourceMatchOptions
The options to match the external resources and folders.

Generally, the returned resources should match the options, otherwise the resource may be regarded as invalid which may not be available in browser dialogs.

Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExternalResourceBrowserData Class


ExternalResourceBrowserData Properties

The ExternalResourceBrowserData type exposes the following members.

Properties
 | Name | Description
Public property | FolderPath | The current folder path to which the new resources and subfolder belong.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ServerId | The Id of IExternalResourceServer which handles the external resource load.
Top
See Also

Reference

ExternalResourceBrowserData Class


ExternalResourceBrowserData.FolderPath Property

ExternalResourceBrowserDataFolderPath Property

The current folder path to which the new resources and subfolder belong.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FolderPath { get; }
Public ReadOnly Property FolderPath As String
    Get
public:
property String^ FolderPath {
    String^ get ();
}
member FolderPath : string with get

Property Value

String
See Also

Reference

ExternalResourceBrowserData Class


ExternalResourceBrowserData.IsValidObject Property

ExternalResourceBrowserDataIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ExternalResourceBrowserData Class


ExternalResourceBrowserData.ServerId Property

ExternalResourceBrowserDataServerId Property

The Id of IExternalResourceServer which handles the external resource load.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid ServerId { get; }
Public ReadOnly Property ServerId As Guid
    Get
public:
property Guid ServerId {
    Guid get ();
}
member ServerId : Guid with get

Property Value

Guid
See Also

Reference

ExternalResourceBrowserData Class


ExternalResourceBrowserData Methods

The ExternalResourceBrowserData type exposes the following members.

Methods
 | Name | Description
Public method | AddResource(String) | Adds an external resource to the folder path by supplying the resource name.
Public method | AddResource(String, IDictionaryString, String) | Adds an external resource to the folder path by supplying the resource name and reference information.
Public method | AddResource(String, String) | Adds an external resource to the folder path by supplying the resource name and version.
Public method | AddResource(String, String, IDictionaryString, String) | Adds an external resource to the folder path by supplying the resource name, version and reference information.
Public method | AddSubFolder(String) | Adds a subfolder to the folder path with the given name.
Public method | AddSubFolder(String, String) | Adds a subfolder to the folder path with the given name and icon type.
Public method | CallingDocumentHasModelPath | Indicates whether the document requesting the external resource browser data has a defined ModelPath.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCallingDocumentModelPath | Returns a copy of the ModelPath of the document that is requesting the external resource browser data.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMatchOptions | Gets the match options used to filter external resources.
Public method | GetResources | Gets the external resources under the folder path of the browser data.
Public method | GetSubFoldersData | Gets the subfolders data under the folder path of the browser data.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsValidFolderName | Checks whether the folder name is valid.
Public method | IsValidResourceName | Checks whether the resource name is valid.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExternalResourceBrowserData Class


ExternalResourceBrowserData.AddResource Method

ExternalResourceBrowserDataAddResource Method

Overload List
 | Name | Description
Public method | AddResource(String) | Adds an external resource to the folder path by supplying the resource name.
Public method | AddResource(String, IDictionaryString, String) | Adds an external resource to the folder path by supplying the resource name and reference information.
Public method | AddResource(String, String) | Adds an external resource to the folder path by supplying the resource name and version.
Public method | AddResource(String, String, IDictionaryString, String) | Adds an external resource to the folder path by supplying the resource name, version and reference information.
Top
See Also

Reference

ExternalResourceBrowserData Class


ExternalResourceBrowserData.AddResource(String) Method

ExternalResourceBrowserDataAddResource(String) Method

Adds an external resource to the folder path by supplying the resource name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddResource(
    string resourceName
)
Public Sub AddResource (
    resourceName As String
)
public:
void AddResource(
    String^ resourceName
)
member AddResource :
        resourceName : string -> unit

Parameters

resourceName String
The unique short name of external resource.
Exceptions
Exception | Condition
ArgumentException | The resourceName is not a valid resource name used to display in Revit external resource browse UI. The name should be a unique non-empty short name and it should not contain any invalid character of \\/:*?"<>|. The length of combined path(server name + folder path + resourceName) should not exceeds 259.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExternalResourceBrowserData Class
AddResource Overload


ExternalResourceBrowserData.AddResource(String, IDictionary<String, String>) Method

ExternalResourceBrowserDataAddResource(String, IDictionaryString, String) Method

Adds an external resource to the folder path by supplying the resource name and reference information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddResource(
    string resourceName,
    IDictionary<string, string> referenceInformation
)
Public Sub AddResource (
    resourceName As String,
    referenceInformation As IDictionary(Of String, String)
)
public:
void AddResource(
    String^ resourceName,
    IDictionary<String^, String^>^ referenceInformation
)
member AddResource :
        resourceName : string *
        referenceInformation : IDictionary<string, string> -> unit

Parameters

resourceName String
The unique short name of external resource.
referenceInformation IDictionary String, String
The (String, String) map containing reference or lookup information that will be stored in Revit.
Exceptions
Exception | Condition
ArgumentException | The resourceName is not a valid resource name used to display in Revit external resource browse UI. The name should be a unique non-empty short name and it should not contain any invalid character of \\/:*?"<>|. The length of combined path(server name + folder path + resourceName) should not exceeds 259.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExternalResourceBrowserData Class
AddResource Overload


ExternalResourceBrowserData.AddResource(String, String) Method

ExternalResourceBrowserDataAddResource(String, String) Method

Adds an external resource to the folder path by supplying the resource name and version.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddResource(
    string resourceName,
    string version
)
Public Sub AddResource (
    resourceName As String,
    version As String
)
public:
void AddResource(
    String^ resourceName,
    String^ version
)
member AddResource :
        resourceName : string *
        version : string -> unit

Parameters

resourceName String
The unique short name of external resource.
version String
The version of external resource.
Exceptions
Exception | Condition
ArgumentException | The resourceName is not a valid resource name used to display in Revit external resource browse UI. The name should be a unique non-empty short name and it should not contain any invalid character of \\/:*?"<>|. The length of combined path(server name + folder path + resourceName) should not exceeds 259.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExternalResourceBrowserData Class
AddResource Overload


ExternalResourceBrowserData.AddResource(String, String, IDictionary<String, String>) Method

ExternalResourceBrowserDataAddResource(String, String, IDictionaryString, String) Method

Adds an external resource to the folder path by supplying the resource name, version and reference information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddResource(
    string resourceName,
    string version,
    IDictionary<string, string> referenceInformation
)
Public Sub AddResource (
    resourceName As String,
    version As String,
    referenceInformation As IDictionary(Of String, String)
)
public:
void AddResource(
    String^ resourceName,
    String^ version,
    IDictionary<String^, String^>^ referenceInformation
)
member AddResource :
        resourceName : string *
        version : string *
        referenceInformation : IDictionary<string, string> -> unit

Parameters

resourceName String
The unique short name of external resource.
version String
The version of external resource.
referenceInformation IDictionary String, String
The (String, String) map containing reference or lookup information that will be stored in Revit.
Exceptions
Exception | Condition
ArgumentException | The resourceName is not a valid resource name used to display in Revit external resource browse UI. The name should be a unique non-empty short name and it should not contain any invalid character of \\/:*?"<>|. The length of combined path(server name + folder path + resourceName) should not exceeds 259.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExternalResourceBrowserData Class
AddResource Overload


ExternalResourceBrowserData.AddSubFolder Method

ExternalResourceBrowserDataAddSubFolder Method

Overload List
 | Name | Description
Public method | AddSubFolder(String) | Adds a subfolder to the folder path with the given name.
Public method | AddSubFolder(String, String) | Adds a subfolder to the folder path with the given name and icon type.
Top
See Also

Reference

ExternalResourceBrowserData Class


ExternalResourceBrowserData.AddSubFolder(String) Method

ExternalResourceBrowserDataAddSubFolder(String) Method

Adds a subfolder to the folder path with the given name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddSubFolder(
    string folderName
)
Public Sub AddSubFolder (
    folderName As String
)
public:
void AddSubFolder(
    String^ folderName
)
member AddSubFolder :
        folderName : string -> unit

Parameters

folderName String
The name of the folder.
Exceptions
Exception | Condition
ArgumentException | The folderName is not a valid folder name used to display in Revit external resource browse UI. The name should be a unique non-empty short name and it should not contain any invalid character of \\/:*?"<>|. The length of combined path(server name + folder path) should not exceeds 259.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExternalResourceBrowserData Class
AddSubFolder Overload


ExternalResourceBrowserData.AddSubFolder(String, String) Method

ExternalResourceBrowserDataAddSubFolder(String, String) Method

Adds a subfolder to the folder path with the given name and icon type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddSubFolder(
    string folderName,
    string iconPath
)
Public Sub AddSubFolder (
    folderName As String,
    iconPath As String
)
public:
void AddSubFolder(
    String^ folderName,
    String^ iconPath
)
member AddSubFolder :
        folderName : string *
        iconPath : string -> unit

Parameters

folderName String
The name of the folder.
iconPath String
Icon path.
Exceptions
Exception | Condition
ArgumentException | The folderName is not a valid folder name used to display in Revit external resource browse UI. The name should be a unique non-empty short name and it should not contain any invalid character of \\/:*?"<>|. The length of combined path(server name + folder path) should not exceeds 259.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExternalResourceBrowserData Class
AddSubFolder Overload


ExternalResourceBrowserData.CallingDocumentHasModelPath Method

ExternalResourceBrowserDataCallingDocumentHasModelPath Method

Indicates whether the document requesting the external resource browser data has a defined ModelPath.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CallingDocumentHasModelPath()
Public Function CallingDocumentHasModelPath As Boolean
public:
bool CallingDocumentHasModelPath()
member CallingDocumentHasModelPath : unit -> bool

Return Value

Boolean
True if the document has a defined ModelPath.
Remarks
A project that is detached, or has not been saved to disk yet, will not have a ModelPath.
See Also

Reference

ExternalResourceBrowserData Class


ExternalResourceBrowserData.Dispose Method

ExternalResourceBrowserDataDispose Method

Releases all resources used by the ExternalResourceBrowserData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ExternalResourceBrowserData Class


ExternalResourceBrowserData.GetCallingDocumentModelPath Method

ExternalResourceBrowserDataGetCallingDocumentModelPath Method

Returns a copy of the ModelPath of the document that is requesting the external resource browser data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ModelPath GetCallingDocumentModelPath()
Public Function GetCallingDocumentModelPath As ModelPath
public:
ModelPath^ GetCallingDocumentModelPath()
member GetCallingDocumentModelPath : unit -> ModelPath

Return Value

ModelPath
A copy of the ModelPath of the document that is requesting the external resource browser data.
Exceptions
Exception | Condition
InvalidOperationException | The document requesting the external resource browser data does not have a ModelPath, either because it is detached, or because it has not been saved to disk yet, or no document specified.
See Also

Reference

ExternalResourceBrowserData Class


ExternalResourceBrowserData.GetMatchOptions Method

ExternalResourceBrowserDataGetMatchOptions Method

Gets the match options used to filter external resources.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExternalResourceMatchOptions GetMatchOptions()
Public Function GetMatchOptions As ExternalResourceMatchOptions
public:
ExternalResourceMatchOptions^ GetMatchOptions()
member GetMatchOptions : unit -> ExternalResourceMatchOptions

Return Value

ExternalResourceMatchOptions
The external resource match options.
See Also

Reference

ExternalResourceBrowserData Class


ExternalResourceBrowserData.GetResources Method

ExternalResourceBrowserDataGetResources Method

Gets the external resources under the folder path of the browser data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ExternalResourceReference> GetResources()
Public Function GetResources As IList(Of ExternalResourceReference)
public:
IList<ExternalResourceReference^>^ GetResources()
member GetResources : unit -> IList<ExternalResourceReference>

Return Value

IList ExternalResourceReference
The external resources under current folder of the browser data.
See Also

Reference

ExternalResourceBrowserData Class


ExternalResourceBrowserData.GetSubFoldersData Method

ExternalResourceBrowserDataGetSubFoldersData Method

Gets the subfolders data under the folder path of the browser data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ExternalResourceSubFolder> GetSubFoldersData()
Public Function GetSubFoldersData As IList(Of ExternalResourceSubFolder)
public:
IList<ExternalResourceSubFolder^>^ GetSubFoldersData()
member GetSubFoldersData : unit -> IList<ExternalResourceSubFolder>

Return Value

IList ExternalResourceSubFolder
The subfolders data under folder path of the browser data.
See Also

Reference

ExternalResourceBrowserData Class


ExternalResourceBrowserData.IsValidFolderName Method

ExternalResourceBrowserDataIsValidFolderName Method

Checks whether the folder name is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidFolderName(
    string folderName
)
Public Function IsValidFolderName (
    folderName As String
) As Boolean
public:
bool IsValidFolderName(
    String^ folderName
)
member IsValidFolderName :
        folderName : string -> bool

Parameters

folderName String
The folder name to check.

Return Value

Boolean
True if the name is a valid folder name, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExternalResourceBrowserData Class


ExternalResourceBrowserData.IsValidResourceName Method

ExternalResourceBrowserDataIsValidResourceName Method

Checks whether the resource name is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidResourceName(
    string resourceName
)
Public Function IsValidResourceName (
    resourceName As String
) As Boolean
public:
bool IsValidResourceName(
    String^ resourceName
)
member IsValidResourceName :
        resourceName : string -> bool

Parameters

resourceName String
The resource name to check.

Return Value

Boolean
True if the name is a valid resource name, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExternalResourceBrowserData Class


ExternalResourceLoadContent Class

This class contains the actual content data and other results of an external resource load operation that are returned by an IExternalResourceServer to Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExternalResourceLoadContent
Autodesk.Revit.DBKeyBasedTreeEntriesLoadContent
Autodesk.Revit.DBLinkLoadContent

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExternalResourceLoadContent : IDisposable
Public Class ExternalResourceLoadContent
    Implements IDisposable
public ref class ExternalResourceLoadContent : IDisposable
type ExternalResourceLoadContent =
    class
        interface IDisposable
    end

The ExternalResourceLoadContent type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LoadStatus | A value to indicate the status of an external resource load operation. IExternalResourceServers should set this in the LoadResource() method.
Public property | Version | The version of the external data that the server is providing in this object.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ExternalResourceLoadContent
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

When Revit calls the LoadResource method for an IExternalResourceServer, Revit will provide an object that is a sub-class of ExternalResourceLoadContent. The IExternalResourceServer will use this object to return the content Revit should use for the external resource. The server can also add information about any errors that occurred during the load operation. This error information will be stored by Revit and later passed to the associated IExternalResourceUIServer (if any) that designates the IExternalResourceServer as its "DBServer" (see the IExternalResourceUIServer.GetDBServerId() method). The IExternalResourceUIServer can then generate any UI that is required for handling the errors that occurred.

Note that since different kinds of external resources are expected to return different kinds of data to Revit, a number of ExternalResourceLoadContent sub-classes have been created to handle the data for specific ExternalResourceTypes. This base class contains only a string to indicate the version of the resource data that is being supplied by the server and a status variable to indicate the outcome of a load operation. Revit will always provide the server with an instance of the appropriate sub-class of ExternalResourceLoadContent, with internal data that are relevant to the particular ExternalResourceType that is being loaded.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExternalResourceLoadContent Properties

The ExternalResourceLoadContent type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LoadStatus | A value to indicate the status of an external resource load operation. IExternalResourceServers should set this in the LoadResource() method.
Public property | Version | The version of the external data that the server is providing in this object.
Top
See Also

Reference

ExternalResourceLoadContent Class


ExternalResourceLoadContent.IsValidObject Property

ExternalResourceLoadContentIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ExternalResourceLoadContent Class


ExternalResourceLoadContent.LoadStatus Property

ExternalResourceLoadContentLoadStatus Property

A value to indicate the status of an external resource load operation. IExternalResourceServers should set this in the LoadResource() method.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExternalResourceLoadStatus LoadStatus { get; set; }
Public Property LoadStatus As ExternalResourceLoadStatus
    Get
    Set
public:
property ExternalResourceLoadStatus LoadStatus {
    ExternalResourceLoadStatus get ();
    void set (ExternalResourceLoadStatus value);
}
member LoadStatus : ExternalResourceLoadStatus with get, set

Property Value

ExternalResourceLoadStatus
Exceptions
Exception | Condition
ArgumentException | When setting this property: The ExternalResourceLoadContent does not contain all the necessary data. To see the requirements for this particular resource type, please see the documentation for the specific subclass of ExternalResourceLoadContent.
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ExternalResourceLoadContent Class


ExternalResourceLoadContent.Version Property

ExternalResourceLoadContentVersion Property

The version of the external data that the server is providing in this object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Version { get; set; }
Public Property Version As String
    Get
    Set
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}
member Version : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks

When its LoadResource() method is invoked, an IExternalResourceServer can indicate the version of the data that it is providing to Revit by setting this property. Doing so will improve performance, because Revit will use the version information to avoid unnecessary reloads.

See GetResourceVersionStatus(ExternalResourceReference).

See Also

Reference

ExternalResourceLoadContent Class


ExternalResourceLoadContent Methods

The ExternalResourceLoadContent type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExternalResourceLoadContent Class


ExternalResourceLoadContent.Dispose Method

ExternalResourceLoadContentDispose Method

Releases all resources used by the ExternalResourceLoadContent

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ExternalResourceLoadContent Class


ExternalResourceLoadContext Class

This class contains data describing the context related to an external resource load operation.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExternalResourceLoadContext

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExternalResourceLoadContext : IDisposable
Public Class ExternalResourceLoadContext
    Implements IDisposable
public ref class ExternalResourceLoadContext : IDisposable
type ExternalResourceLoadContext =
    class
        interface IDisposable
    end

The ExternalResourceLoadContext type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LoadOperationType | An enum value indicating whether the resource load was triggered by an automatic event (such as file open) or an explicit user action.
Top
Methods
 | Name | Description
Public method | CallingDocumentHasModelPath | Indicates whether the document requesting the external resource has a defined ModelPath.
Public method | Dispose | Releases all resources used by the ExternalResourceLoadContext
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCallingDocumentModelPath | Returns a copy of the ModelPath of the document that is requesting the external resource.
Public method | GetCurrentlyLoadedReference | Returns a copy of the ExternalResourceReference currently in use by the containing element.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

Note that automatic loads can occur in the context of other operations such as opening a file. During automatic loads, it is therefore recommended that the server only display UI that is critical for the user to see (such as error message).

The loading operation type is Explicit when the user is specifically trying to reload the resource. During explicit loads, it may be desirable to provide more feedback to the user, such as specific feedback that the load operation succeeded.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExternalResourceLoadContext Properties

The ExternalResourceLoadContext type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LoadOperationType | An enum value indicating whether the resource load was triggered by an automatic event (such as file open) or an explicit user action.
Top
See Also

Reference

ExternalResourceLoadContext Class


ExternalResourceLoadContext.IsValidObject Property

ExternalResourceLoadContextIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ExternalResourceLoadContext Class


ExternalResourceLoadContext.LoadOperationType Property

ExternalResourceLoadContextLoadOperationType Property

An enum value indicating whether the resource load was triggered by an automatic event (such as file open) or an explicit user action.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LoadOperationType LoadOperationType { get; }
Public ReadOnly Property LoadOperationType As LoadOperationType
    Get
public:
property LoadOperationType LoadOperationType {
    LoadOperationType get ();
}
member LoadOperationType : LoadOperationType with get

Property Value

LoadOperationType
See Also

Reference

ExternalResourceLoadContext Class


ExternalResourceLoadContext Methods

The ExternalResourceLoadContext type exposes the following members.

Methods
 | Name | Description
Public method | CallingDocumentHasModelPath | Indicates whether the document requesting the external resource has a defined ModelPath.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCallingDocumentModelPath | Returns a copy of the ModelPath of the document that is requesting the external resource.
Public method | GetCurrentlyLoadedReference | Returns a copy of the ExternalResourceReference currently in use by the containing element.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExternalResourceLoadContext Class


ExternalResourceLoadContext.CallingDocumentHasModelPath Method

ExternalResourceLoadContextCallingDocumentHasModelPath Method

Indicates whether the document requesting the external resource has a defined ModelPath.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CallingDocumentHasModelPath()
Public Function CallingDocumentHasModelPath As Boolean
public:
bool CallingDocumentHasModelPath()
member CallingDocumentHasModelPath : unit -> bool

Return Value

Boolean
True if the document has a defined ModelPath.
Remarks
A project that is detached, or has not been saved to disk yet, will not have a ModelPath.
See Also

Reference

ExternalResourceLoadContext Class


ExternalResourceLoadContext.Dispose Method

ExternalResourceLoadContextDispose Method

Releases all resources used by the ExternalResourceLoadContext

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ExternalResourceLoadContext Class


ExternalResourceLoadContext.GetCallingDocumentModelPath Method

ExternalResourceLoadContextGetCallingDocumentModelPath Method

Returns a copy of the ModelPath of the document that is requesting the external resource.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ModelPath GetCallingDocumentModelPath()
Public Function GetCallingDocumentModelPath As ModelPath
public:
ModelPath^ GetCallingDocumentModelPath()
member GetCallingDocumentModelPath : unit -> ModelPath

Return Value

ModelPath
A copy of the ModelPath of the document that is requesting the external resource.
Exceptions
Exception | Condition
InvalidOperationException | The document requesting the external resource does not have a ModelPath, either because it is detached, or because it has not been saved to disk yet.
See Also

Reference

ExternalResourceLoadContext Class


ExternalResourceLoadContext.GetCurrentlyLoadedReference Method

ExternalResourceLoadContextGetCurrentlyLoadedReference Method

Returns a copy of the ExternalResourceReference currently in use by the containing element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExternalResourceReference GetCurrentlyLoadedReference()
Public Function GetCurrentlyLoadedReference As ExternalResourceReference
public:
ExternalResourceReference^ GetCurrentlyLoadedReference()
member GetCurrentlyLoadedReference : unit -> ExternalResourceReference

Return Value

ExternalResourceReference
A copy of the ExternalResourceReference currently in use by the containing element.
Remarks

A server may use to wish this information to, for example, tell whether the Revit user was previously using their server or not.

This reference may be if there is no current value. For example, a newly-created link being loaded for the first time would have no currently-loaded reference.

See Also

Reference

ExternalResourceLoadContext Class


ExternalResourceLoadData Class

This class contains the input and output data resulting from invoking an IExternalResourceServer's LoadResource method.

After the call to LoadResource, the resulting ExternalResourceLoadData will be passed into IExternalResourceServer.HandleLoadResourceResults() so that appropriate UI can be displayed.

Server providers can inspect the ExternalResourceLoadData to get an ExternalResourceLoadContent object of the subclass appropriate to the external resource. The class also contains a copy of the ExternalResourceReference, and information about the context of the load operation.

Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExternalResourceLoadData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExternalResourceLoadData : IDisposable
Public Class ExternalResourceLoadData
    Implements IDisposable
public ref class ExternalResourceLoadData : IDisposable
type ExternalResourceLoadData =
    class
        interface IDisposable
    end

The ExternalResourceLoadData type exposes the following members.

Properties
 | Name | Description
Public property | ErrorsReported | Indicates whether the IExternalResourceUIServer has reported errors for this ExternalResourceLoadData. This value can be set by the IExternalResourceUIServer in HandleLoadResourceResults().
Public property | ExternalResourceType | The ExternalResourceType for which Revit is requesting data from the server.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LoadStatus | The success or failure status of the load attempt.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ExternalResourceLoadData
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetExternalResourceReference | Returns the ExternalResourceReference that identifies which resource should be loaded.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLoadContent | Returns the ExternalResourceLoadContent resulting from this load operation.
Public method | GetLoadContext | Returns an object containing information about the context of the load operation.
Public method | GetLoadRequestId | Returns the load operation GUID.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExternalResourceLoadData Properties

The ExternalResourceLoadData type exposes the following members.

Properties
 | Name | Description
Public property | ErrorsReported | Indicates whether the IExternalResourceUIServer has reported errors for this ExternalResourceLoadData. This value can be set by the IExternalResourceUIServer in HandleLoadResourceResults().
Public property | ExternalResourceType | The ExternalResourceType for which Revit is requesting data from the server.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LoadStatus | The success or failure status of the load attempt.
Top
See Also

Reference

ExternalResourceLoadData Class


ExternalResourceLoadData.ErrorsReported Property

ExternalResourceLoadDataErrorsReported Property

Indicates whether the IExternalResourceUIServer has reported errors for this ExternalResourceLoadData. This value can be set by the IExternalResourceUIServer in HandleLoadResourceResults().

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ErrorsReported { get; set; }
Public Property ErrorsReported As Boolean
    Get
    Set
public:
property bool ErrorsReported {
    bool get ();
    void set (bool value);
}
member ErrorsReported : bool with get, set

Property Value

Boolean
Remarks

For Revit links specifically, Revit will check this value to see if it should report errors about a given link in the Unresolved References dialog. An IExternalResourceUIServer can set this value to true to avoid redundant messages.

Note that it is possible for Revit to encounter errors internally even if the server successfully provides a reference. In general, this value should only be set to true if the server has reported an error condition.

See Also

Reference

ExternalResourceLoadData Class


ExternalResourceLoadData.ExternalResourceType Property

ExternalResourceLoadDataExternalResourceType Property

The ExternalResourceType for which Revit is requesting data from the server.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExternalResourceType ExternalResourceType { get; }
Public ReadOnly Property ExternalResourceType As ExternalResourceType
    Get
public:
property ExternalResourceType^ ExternalResourceType {
    ExternalResourceType^ get ();
}
member ExternalResourceType : ExternalResourceType with get

Property Value

ExternalResourceType
See Also

Reference

ExternalResourceLoadData Class


ExternalResourceLoadData.IsValidObject Property

ExternalResourceLoadDataIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ExternalResourceLoadData Class


ExternalResourceLoadData.LoadStatus Property

ExternalResourceLoadDataLoadStatus Property

The success or failure status of the load attempt.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExternalResourceLoadStatus LoadStatus { get; }
Public ReadOnly Property LoadStatus As ExternalResourceLoadStatus
    Get
public:
property ExternalResourceLoadStatus LoadStatus {
    ExternalResourceLoadStatus get ();
}
member LoadStatus : ExternalResourceLoadStatus with get

Property Value

ExternalResourceLoadStatus
See Also

Reference

ExternalResourceLoadData Class


ExternalResourceLoadData Methods

The ExternalResourceLoadData type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetExternalResourceReference | Returns the ExternalResourceReference that identifies which resource should be loaded.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLoadContent | Returns the ExternalResourceLoadContent resulting from this load operation.
Public method | GetLoadContext | Returns an object containing information about the context of the load operation.
Public method | GetLoadRequestId | Returns the load operation GUID.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExternalResourceLoadData Class


ExternalResourceLoadData.Dispose Method

ExternalResourceLoadDataDispose Method

Releases all resources used by the ExternalResourceLoadData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ExternalResourceLoadData Class


ExternalResourceLoadData.GetExternalResourceReference Method

ExternalResourceLoadDataGetExternalResourceReference Method

Returns the ExternalResourceReference that identifies which resource should be loaded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExternalResourceReference GetExternalResourceReference()
Public Function GetExternalResourceReference As ExternalResourceReference
public:
ExternalResourceReference^ GetExternalResourceReference()
member GetExternalResourceReference : unit -> ExternalResourceReference

Return Value

ExternalResourceReference
Remarks
Information in this object tells the server from which specific resource Revit expects to receive the external data.
See Also

Reference

ExternalResourceLoadData Class


ExternalResourceLoadData.GetLoadContent Method

ExternalResourceLoadDataGetLoadContent Method

Returns the ExternalResourceLoadContent resulting from this load operation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExternalResourceLoadContent GetLoadContent()
Public Function GetLoadContent As ExternalResourceLoadContent
public:
ExternalResourceLoadContent^ GetLoadContent()
member GetLoadContent : unit -> ExternalResourceLoadContent

Return Value

ExternalResourceLoadContent
A reference to an ExternalResourceLoadContent object.
Remarks
This object contains the content produced by the call to the IExternalResourceServer's LoadResource method.
See Also

Reference

ExternalResourceLoadData Class


ExternalResourceLoadData.GetLoadContext Method

ExternalResourceLoadDataGetLoadContext Method

Returns an object containing information about the context of the load operation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExternalResourceLoadContext GetLoadContext()
Public Function GetLoadContext As ExternalResourceLoadContext
public:
ExternalResourceLoadContext^ GetLoadContext()
member GetLoadContext : unit -> ExternalResourceLoadContext

Return Value

ExternalResourceLoadContext
An object containing information about the context of the load operation.
See Also

Reference

ExternalResourceLoadData Class


ExternalResourceLoadData.GetLoadRequestId Method

ExternalResourceLoadDataGetLoadRequestId Method

Returns the load operation GUID.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid GetLoadRequestId()
Public Function GetLoadRequestId As Guid
public:
Guid GetLoadRequestId()
member GetLoadRequestId : unit -> Guid

Return Value

Guid
The load operation GUID.
Remarks
This Id uniquely identifies the load request. IExternalResourceServers can use it as a key to store and retrieve information (such as errors) that is relevant to a specific load operation.
See Also

Reference

ExternalResourceLoadData Class


ExternalResourceLoadStatus Enumeration

A flag to indicate the status of an ExternalResource load request.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ExternalResourceLoadStatus
Public Enumeration ExternalResourceLoadStatus
public enum class ExternalResourceLoadStatus
type ExternalResourceLoadStatus
Members
Member name | Value | Description
Success | 0 | The load operation was successful.
Failure | 1 | The load operation failed.
Uninitialized | 2 | The load operation is in an incomplete state. Revit will treat this result as a failure.
ResourceAlreadyCurrent | 3 | The current version of the resource is already loaded into Revit so no changes were made to the model.
CannotFindServer | 4 | The server identified by the ExternalResourceReference could not be found, and may not be registered.
ServerThrewException | 5 | The server identified by the ExternalResourceReference threw an exception while attempting to load a resource.
Remarks
This flag is returned by the LoadResource method of the IExternalResourceServer class to inform callers whether the load operation succeeded, or encountered an error.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExternalResourceMatchOptions Class

Represents match options used to filter external resources when listing them from external resource server.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExternalResourceMatchOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExternalResourceMatchOptions : IDisposable
Public Class ExternalResourceMatchOptions
    Implements IDisposable
public ref class ExternalResourceMatchOptions : IDisposable
type ExternalResourceMatchOptions =
    class
        interface IDisposable
    end

The ExternalResourceMatchOptions type exposes the following members.

Constructors
 | Name | Description
Public method | ExternalResourceMatchOptions | Constructs new instance with specified resource type.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ResourceType | The desired resource type which external resources should match.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ExternalResourceMatchOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExternalResourceMatchOptions Constructor

Constructs new instance with specified resource type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExternalResourceMatchOptions(
    ExternalResourceType resourceType
)
Public Sub New (
    resourceType As ExternalResourceType
)
public:
ExternalResourceMatchOptions(
    ExternalResourceType^ resourceType
)
new :
        resourceType : ExternalResourceType -> ExternalResourceMatchOptions

Parameters

resourceType ExternalResourceType
The desired resource type.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExternalResourceMatchOptions Class


ExternalResourceMatchOptions Properties

The ExternalResourceMatchOptions type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ResourceType | The desired resource type which external resources should match.
Top
See Also

Reference

ExternalResourceMatchOptions Class


ExternalResourceMatchOptions.IsValidObject Property

ExternalResourceMatchOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ExternalResourceMatchOptions Class


ExternalResourceMatchOptions.ResourceType Property

ExternalResourceMatchOptionsResourceType Property

The desired resource type which external resources should match.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExternalResourceType ResourceType { get; }
Public ReadOnly Property ResourceType As ExternalResourceType
    Get
public:
property ExternalResourceType^ ResourceType {
    ExternalResourceType^ get ();
}
member ResourceType : ExternalResourceType with get

Property Value

ExternalResourceType
See Also

Reference

ExternalResourceMatchOptions Class


ExternalResourceMatchOptions Methods

The ExternalResourceMatchOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExternalResourceMatchOptions Class


ExternalResourceMatchOptions.Dispose Method

ExternalResourceMatchOptionsDispose Method

Releases all resources used by the ExternalResourceMatchOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ExternalResourceMatchOptions Class


ExternalResourceReference Class

This class identifies an external resource provided by an IExternalResourceServer.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExternalResourceReference

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExternalResourceReference : IDisposable
Public Class ExternalResourceReference
    Implements IDisposable
public ref class ExternalResourceReference : IDisposable
type ExternalResourceReference =
    class
        interface IDisposable
    end

The ExternalResourceReference type exposes the following members.

Constructors
 | Name | Description
Public method | ExternalResourceReference(ExternalResourceReference) | Creates a new ExternalResourceReference from the given ExternalResourceReference.
Public method | ExternalResourceReference(Guid, IDictionaryString, String, String, String) | Creates a new ExternalResourceReference from the given data.
Top
Properties
Name | Description
Public property InSessionPath

The path stores the full display path which includes the server name plus the path provided by ExternalResourceServer.

The path that Revit will present for user recognizing and browsing to this resource during one session of Revit.

This property allows ExternalResourceServers to handle cases where the path to a resource may vary between Revit sessions. For example, if this ExternalResourceReference refers to a resource in a folder, this property can be used to store the current path of the resource. If the resource is moved to another folder later, the ExternalResourceServer could calculate the correct path for the resource from resource identification information when it is loaded and store it in this property, so that it will work correctly even if the rvt file is opened in a different location.

Do not rely on this path to look up an ExternalResourceReference, as the path is neither unique nor stable. It isn't unique because multiple servers might use the same server name and display name format. It isn't stable because some servers allow renaming, and because a server might change its name at some point.

Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ServerId | The id of the server that Revit is expecting to provide the external resource.
Public property | Version | The version of the external data that was most recently loaded in Revit.
Top
Methods
 | Name | Description
 | CreateLocalResource | Creates an ExternalResourceReference representing a local file managed by Revit's built-in server.
Public method | Dispose | Releases all resources used by the ExternalResourceReference
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetReferenceInformation | Returns a copy of an object containing previously-stored reference or lookup information about the specific resource provided by the server.
Public method | GetResourceShortDisplayName | Gets the short display name of the external resource.
Public method | GetResourceVersionStatus | Checks whether this ExternalResourceReference corresponds to the current version of the resource.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HasValidDisplayPath | Checks whether this external Resource has a valid display path.
Public method | IsValidReference | Checks whether the reference is in a valid format.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

The class contains:

  • The id of the IExternalResourceServer from which the resource was obtained.
  • A (String, String) map containing information that is meaningful to the server for accessing the desired data. This could be something as simple as "4" to indicate that Revit wants option 4 from a range of several choices, or something more detailed, such as a filename or directory path.
  • A String indicating the version of the resource that was most recently loaded in Revit.
  • A (String, String) map containing "in session" information that is meaningful to the server, but which does not need to be saved permanently in the document on disk.

When calling an IExternalResourceServer, Revit will provide an ExternalResourceReference to identify the specific resource that Revit is using from that server. The server can then use the relevant information in the (String, String) maps to retrieve the data from the correct source.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExternalResourceReference Constructor

Overload List
 | Name | Description
Public method | ExternalResourceReference(ExternalResourceReference) | Creates a new ExternalResourceReference from the given ExternalResourceReference.
Public method | ExternalResourceReference(Guid, IDictionaryString, String, String, String) | Creates a new ExternalResourceReference from the given data.
Top
See Also

Reference

ExternalResourceReference Class


ExternalResourceReference(ExternalResourceReference) Constructor

Creates a new ExternalResourceReference from the given ExternalResourceReference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExternalResourceReference(
    ExternalResourceReference other
)
Public Sub New (
    other As ExternalResourceReference
)
public:
ExternalResourceReference(
    ExternalResourceReference^ other
)
new :
        other : ExternalResourceReference -> ExternalResourceReference

Parameters

other ExternalResourceReference
The ExternalResourceReference to copy.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExternalResourceReference Class
ExternalResourceReference Overload


ExternalResourceReference(Guid, IDictionary<String, String>, String, String) Constructor

ExternalResourceReference(Guid, IDictionaryString, String, String, String) Constructor

Creates a new ExternalResourceReference from the given data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExternalResourceReference(
    Guid serverId,
    IDictionary<string, string> referenceInformation,
    string version,
    string inSessionPath
)
Public Sub New (
    serverId As Guid,
    referenceInformation As IDictionary(Of String, String),
    version As String,
    inSessionPath As String
)
public:
ExternalResourceReference(
    Guid serverId,
    IDictionary<String^, String^>^ referenceInformation,
    String^ version,
    String^ inSessionPath
)
new :
        serverId : Guid *
        referenceInformation : IDictionary<string, string> *
        version : string *
        inSessionPath : string -> ExternalResourceReference

Parameters

serverId Guid
The id of the server associated with this ExternalResourceReference. The server must implement IExternalResourceServer.
referenceInformation IDictionary String, String
The (String, String) map containing reference or lookup information that will be stored in Revit.
version String
The version of the external data.
inSessionPath String
The path that identifies a resource in server. ExternalResourceServer must provide this path which should not contain the server name. Revit internally will construct and store the full display path which includes the server name plus this path at the time a resource is loaded into the model for use if the server is missing.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The file is not allowed to access.
See Also

Reference

ExternalResourceReference Class
ExternalResourceReference Overload


ExternalResourceReference Properties

The ExternalResourceReference type exposes the following members.

Properties
Name | Description
Public property InSessionPath

The path stores the full display path which includes the server name plus the path provided by ExternalResourceServer.

The path that Revit will present for user recognizing and browsing to this resource during one session of Revit.

This property allows ExternalResourceServers to handle cases where the path to a resource may vary between Revit sessions. For example, if this ExternalResourceReference refers to a resource in a folder, this property can be used to store the current path of the resource. If the resource is moved to another folder later, the ExternalResourceServer could calculate the correct path for the resource from resource identification information when it is loaded and store it in this property, so that it will work correctly even if the rvt file is opened in a different location.

Do not rely on this path to look up an ExternalResourceReference, as the path is neither unique nor stable. It isn't unique because multiple servers might use the same server name and display name format. It isn't stable because some servers allow renaming, and because a server might change its name at some point.

Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ServerId | The id of the server that Revit is expecting to provide the external resource.
Public property | Version | The version of the external data that was most recently loaded in Revit.
Top
See Also

Reference

ExternalResourceReference Class


ExternalResourceReference.InSessionPath Property

ExternalResourceReferenceInSessionPath Property

The path stores the full display path which includes the server name plus the path provided by ExternalResourceServer.

The path that Revit will present for user recognizing and browsing to this resource during one session of Revit.

This property allows ExternalResourceServers to handle cases where the path to a resource may vary between Revit sessions. For example, if this ExternalResourceReference refers to a resource in a folder, this property can be used to store the current path of the resource. If the resource is moved to another folder later, the ExternalResourceServer could calculate the correct path for the resource from resource identification information when it is loaded and store it in this property, so that it will work correctly even if the rvt file is opened in a different location.

Do not rely on this path to look up an ExternalResourceReference, as the path is neither unique nor stable. It isn't unique because multiple servers might use the same server name and display name format. It isn't stable because some servers allow renaming, and because a server might change its name at some point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string InSessionPath { get; }
Public ReadOnly Property InSessionPath As String
    Get
public:
property String^ InSessionPath {
    String^ get ();
}
member InSessionPath : string with get

Property Value

String
See Also

Reference

ExternalResourceReference Class


ExternalResourceReference.IsValidObject Property

ExternalResourceReferenceIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ExternalResourceReference Class


ExternalResourceReference.ServerId Property

ExternalResourceReferenceServerId Property

The id of the server that Revit is expecting to provide the external resource.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid ServerId { get; }
Public ReadOnly Property ServerId As Guid
    Get
public:
property Guid ServerId {
    Guid get ();
}
member ServerId : Guid with get

Property Value

Guid
See Also

Reference

ExternalResourceReference Class


ExternalResourceReference.Version Property

ExternalResourceReferenceVersion Property

The version of the external data that was most recently loaded in Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Version { get; }
Public ReadOnly Property Version As String
    Get
public:
property String^ Version {
    String^ get ();
}
member Version : string with get

Property Value

String
See Also

Reference

ExternalResourceReference Class


ExternalResourceReference Methods

The ExternalResourceReference type exposes the following members.

Methods
 | Name | Description
 | CreateLocalResource | Creates an ExternalResourceReference representing a local file managed by Revit's built-in server.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetReferenceInformation | Returns a copy of an object containing previously-stored reference or lookup information about the specific resource provided by the server.
Public method | GetResourceShortDisplayName | Gets the short display name of the external resource.
Public method | GetResourceVersionStatus | Checks whether this ExternalResourceReference corresponds to the current version of the resource.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HasValidDisplayPath | Checks whether this external Resource has a valid display path.
Public method | IsValidReference | Checks whether the reference is in a valid format.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExternalResourceReference Class


ExternalResourceReference.CreateLocalResource Method

ExternalResourceReferenceCreateLocalResource Method

Creates an ExternalResourceReference representing a local file managed by Revit's built-in server.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ExternalResourceReference CreateLocalResource(
    Document doc,
    ExternalResourceType resourceType,
    ModelPath path,
    PathType pathType
)
Public Shared Function CreateLocalResource (
    doc As Document,
    resourceType As ExternalResourceType,
    path As ModelPath,
    pathType As PathType
) As ExternalResourceReference
public:
static ExternalResourceReference^ CreateLocalResource(
    Document^ doc,
    ExternalResourceType^ resourceType,
    ModelPath^ path,
    PathType pathType
)
static member CreateLocalResource :
        doc : Document *
        resourceType : ExternalResourceType *
        path : ModelPath *
        pathType : PathType -> ExternalResourceReference

Parameters

doc Document
The document containing the reference. If the PathType is relative, the path will be made relative to the location of this Document. (If this Document belongs to a workshared model, the reference will be relative to the central model.)
resourceType ExternalResourceType
The type of the external resource.
path ModelPath
A path to the external file. This path must be absolute. If the PathType is relative, then Revit will relativize the path according to the location of the given Document.
pathType PathType
An enum indicating the type of path which the ExternalResourceReference should use. The PathType must be PathType.Server if the reference is to a Revit model on Revit Server. The PathType must be PathType.Absolute if the reference is local but the host model or host's central model are on Revit Server.

Return Value

ExternalResourceReference
The newly-created ExternalResourceReference.
Exceptions
Exception | Condition
ArgumentException | The PathType.Enum value is not valid for this resource type or Document location. PathType.Content is not valid for Revit links. The PathType must be PathType.Server if the resource is on Revit Server and is only valid for Revit links. The PathType must be PathType.Absolute if the host document or the host document's central model are on Revit Server. -or- The given path path is a cloud path which is not supported in this method.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | The model is not allowed to access.
See Also

Reference

ExternalResourceReference Class


ExternalResourceReference.Dispose Method

ExternalResourceReferenceDispose Method

Releases all resources used by the ExternalResourceReference

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ExternalResourceReference Class


ExternalResourceReference.GetReferenceInformation Method

ExternalResourceReferenceGetReferenceInformation Method

Returns a copy of an object containing previously-stored reference or lookup information about the specific resource provided by the server.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IDictionary<string, string> GetReferenceInformation()
Public Function GetReferenceInformation As IDictionary(Of String, String)
public:
IDictionary<String^, String^>^ GetReferenceInformation()
member GetReferenceInformation : unit -> IDictionary<string, string>

Return Value

IDictionary String, String
A copy of a (String, String) map containing previously-stored reference or lookup information.
See Also

Reference

ExternalResourceReference Class


ExternalResourceReference.GetResourceShortDisplayName Method

ExternalResourceReferenceGetResourceShortDisplayName Method

Gets the short display name of the external resource.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetResourceShortDisplayName()
Public Function GetResourceShortDisplayName As String
public:
String^ GetResourceShortDisplayName()
member GetResourceShortDisplayName : unit -> string

Return Value

String
The short display name of the external resource.
Exceptions
Exception | Condition
InvalidOperationException | The ExternalResourceReference (this ExternalResourceReference) is has no valid display path.
Remarks
For an external resource, such as a Rvt Link loaded from an external server, which has a full display path such as "My Server://Nested/Nested_1.rvt", this function returns "Nested_1.rvt". For an external resource, such as a Rvt Link loaded from the "built-in" server, which has a full display path such as "c:\LocalLinks\Link_1.rvt", this function returns "Link_1.rvt".
See Also

Reference

ExternalResourceReference Class


ExternalResourceReference.GetResourceVersionStatus Method

ExternalResourceReferenceGetResourceVersionStatus Method

Checks whether this ExternalResourceReference corresponds to the current version of the resource.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ResourceVersionStatus GetResourceVersionStatus()
Public Function GetResourceVersionStatus As ResourceVersionStatus
public:
ResourceVersionStatus GetResourceVersionStatus()
member GetResourceVersionStatus : unit -> ResourceVersionStatus

Return Value

ResourceVersionStatus
An enum indicating whether this reference represents the most recent version of the resource.
Exceptions
Exception | Condition
InvalidOperationException | The server referenced by the ExternalResourceReference does not exist or does not implement IExternalResourceServer.
Remarks
This method should only be called if the ExternalResourceServer that provides the resource is present.
See Also

Reference

ExternalResourceReference Class


ExternalResourceReference.HasValidDisplayPath Method

ExternalResourceReferenceHasValidDisplayPath Method

Checks whether this external Resource has a valid display path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasValidDisplayPath()
Public Function HasValidDisplayPath As Boolean
public:
bool HasValidDisplayPath()
member HasValidDisplayPath : unit -> bool

Return Value

Boolean
True if the this external Resource has a valid display path. False otherwise.
Remarks
For an external resource, such as a Revit link loaded from an external server, the valid display path should be like "My Server://Nested/Nested_1.rvt". For an external resource, such as a Revit link loaded from the "built-in" server, the valid display path should be like "c:\LocalLinks\Link_1.rvt".
See Also

Reference

ExternalResourceReference Class


ExternalResourceReference.IsValidReference Method

ExternalResourceReferenceIsValidReference Method

Checks whether the reference is in a valid format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidReference(
    ExternalResourceType resourceType
)
Public Function IsValidReference (
    resourceType As ExternalResourceType
) As Boolean
public:
bool IsValidReference(
    ExternalResourceType^ resourceType
)
member IsValidReference :
        resourceType : ExternalResourceType -> bool

Parameters

resourceType ExternalResourceType
The type of resource which the ExternalResourceReference should correspond to.

Return Value

Boolean
True if this is a valid ExternalResourceReference. False otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
This function checks:
  • The server id corresponds to a valid server which implements IExternalResourceServer.
  • The server supports the given ExternalResourceType.
  • The reference information is well-formed.
This function does not check whether the resource exists on the server.
See Also

Reference

ExternalResourceReference Class


ExternalResourceServerExtensions Class

An object that contains overrides for external resource-specific methods.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExternalResourceServerExtensions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExternalResourceServerExtensions : IDisposable
Public Class ExternalResourceServerExtensions
    Implements IDisposable
public ref class ExternalResourceServerExtensions : IDisposable
type ExternalResourceServerExtensions =
    class
        interface IDisposable
    end

The ExternalResourceServerExtensions type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ExternalResourceServerExtensions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCADLinkOperations | Gets the specific methods supported by external resource CAD Links.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRevitLinkOperations | Gets the specific methods supported by the external resource of Revit Links.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

This class permits assignment of some specific operations related to a type of external resource, such as what to do when "Open (and Unload)" happens, or when "Shared Coordinates update" happens for Revit or CAD links.

There is no feedback to the UI server for ExternalResourceServerExtensions. Revit will use standard, common message dialogs to handle any error conditions.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExternalResourceServerExtensions Properties

The ExternalResourceServerExtensions type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

ExternalResourceServerExtensions Class


ExternalResourceServerExtensions.IsValidObject Property

ExternalResourceServerExtensionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ExternalResourceServerExtensions Class


ExternalResourceServerExtensions Methods

The ExternalResourceServerExtensions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCADLinkOperations | Gets the specific methods supported by external resource CAD Links.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRevitLinkOperations | Gets the specific methods supported by the external resource of Revit Links.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExternalResourceServerExtensions Class


ExternalResourceServerExtensions.Dispose Method

ExternalResourceServerExtensionsDispose Method

Releases all resources used by the ExternalResourceServerExtensions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ExternalResourceServerExtensions Class


ExternalResourceServerExtensions.GetCADLinkOperations Method

ExternalResourceServerExtensionsGetCADLinkOperations Method

Gets the specific methods supported by external resource CAD Links.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CADLinkOperations GetCADLinkOperations()
Public Function GetCADLinkOperations As CADLinkOperations
public:
CADLinkOperations^ GetCADLinkOperations()
member GetCADLinkOperations : unit -> CADLinkOperations

Return Value

CADLinkOperations
The specific methods supported by external resource CAD Links.
See Also

Reference

ExternalResourceServerExtensions Class


ExternalResourceServerExtensions.GetRevitLinkOperations Method

ExternalResourceServerExtensionsGetRevitLinkOperations Method

Gets the specific methods supported by the external resource of Revit Links.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RevitLinkOperations GetRevitLinkOperations()
Public Function GetRevitLinkOperations As RevitLinkOperations
public:
RevitLinkOperations^ GetRevitLinkOperations()
member GetRevitLinkOperations : unit -> RevitLinkOperations

Return Value

RevitLinkOperations
The specific methods supported by the external resource of Revit Links.
See Also

Reference

ExternalResourceServerExtensions Class


ExternalResourceServerUtils Class

Contains utilities related to external resource server.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExternalResourceServerUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ExternalResourceServerUtils
Public NotInheritable Class ExternalResourceServerUtils
public ref class ExternalResourceServerUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ExternalResourceServerUtils = class end

The ExternalResourceServerUtils type exposes the following members.

Methods
Name | Description
IsValidShortName | Checks whether the name is a valid short name for the external resource server.
ServerSupportsAssemblyCodeData | Checks that the server referenced by the given ExternalResourceReference supports AssemblyCodeData.
ServerSupportsCADLinks | Checks that the server referenced by the given ExternalResourceReference supports CAD links.
ServerSupportsIFCLinks | Checks that the server referenced by the given ExternalResourceReference supports IFC links.
ServerSupportsKeynotes | Checks that the server referenced by the given ExternalResourceReference supports KeynoteTable data.
ServerSupportsRevitLinks | Checks that the server referenced by the given ExternalResourceReference supports Revit links.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExternalResourceServerUtils Methods

The ExternalResourceServerUtils type exposes the following members.

Methods
Name | Description
IsValidShortName | Checks whether the name is a valid short name for the external resource server.
ServerSupportsAssemblyCodeData | Checks that the server referenced by the given ExternalResourceReference supports AssemblyCodeData.
ServerSupportsCADLinks | Checks that the server referenced by the given ExternalResourceReference supports CAD links.
ServerSupportsIFCLinks | Checks that the server referenced by the given ExternalResourceReference supports IFC links.
ServerSupportsKeynotes | Checks that the server referenced by the given ExternalResourceReference supports KeynoteTable data.
ServerSupportsRevitLinks | Checks that the server referenced by the given ExternalResourceReference supports Revit links.
Top
See Also

Reference

ExternalResourceServerUtils Class


ExternalResourceServerUtils.IsValidShortName Method

ExternalResourceServerUtilsIsValidShortName Method

Checks whether the name is a valid short name for the external resource server.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidShortName(
    Guid serverId,
    string serverName
)
Public Shared Function IsValidShortName (
    serverId As Guid,
    serverName As String
) As Boolean
public:
static bool IsValidShortName(
    Guid serverId,
    String^ serverName
)
static member IsValidShortName :
        serverId : Guid *
        serverName : string -> bool

Parameters

serverId Guid
The id of the external resource server.
serverName String
The short name of the external resource server.

Return Value

Boolean
True if the name is a valid short name, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
A valid short name should match the restrictions documented in GetShortName.
See Also

Reference

ExternalResourceServerUtils Class


ExternalResourceServerUtils.ServerSupportsAssemblyCodeData Method

ExternalResourceServerUtilsServerSupportsAssemblyCodeData Method

Checks that the server referenced by the given ExternalResourceReference supports AssemblyCodeData.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool ServerSupportsAssemblyCodeData(
    ExternalResourceReference extRef
)
Public Shared Function ServerSupportsAssemblyCodeData (
    extRef As ExternalResourceReference
) As Boolean
public:
static bool ServerSupportsAssemblyCodeData(
    ExternalResourceReference^ extRef
)
static member ServerSupportsAssemblyCodeData :
        extRef : ExternalResourceReference -> bool

Parameters

extRef ExternalResourceReference
The ExternalResourceReference to check.

Return Value

Boolean
True if the ExternalResourceReference refers to a server that supports AssemblyCodeData. False otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExternalResourceServerUtils Class


ExternalResourceServerUtils.ServerSupportsCADLinks Method

ExternalResourceServerUtilsServerSupportsCADLinks Method

Checks that the server referenced by the given ExternalResourceReference supports CAD links.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool ServerSupportsCADLinks(
    ExternalResourceReference extRef
)
Public Shared Function ServerSupportsCADLinks (
    extRef As ExternalResourceReference
) As Boolean
public:
static bool ServerSupportsCADLinks(
    ExternalResourceReference^ extRef
)
static member ServerSupportsCADLinks :
        extRef : ExternalResourceReference -> bool

Parameters

extRef ExternalResourceReference
The ExternalResourceReference to check.

Return Value

Boolean
True if the ExternalResourceReference refers to a server that supports CAD links. False otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExternalResourceServerUtils Class


ExternalResourceServerUtils.ServerSupportsIFCLinks Method

ExternalResourceServerUtilsServerSupportsIFCLinks Method

Checks that the server referenced by the given ExternalResourceReference supports IFC links.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool ServerSupportsIFCLinks(
    ExternalResourceReference extRef
)
Public Shared Function ServerSupportsIFCLinks (
    extRef As ExternalResourceReference
) As Boolean
public:
static bool ServerSupportsIFCLinks(
    ExternalResourceReference^ extRef
)
static member ServerSupportsIFCLinks :
        extRef : ExternalResourceReference -> bool

Parameters

extRef ExternalResourceReference
The ExternalResourceReference to check.

Return Value

Boolean
True if the ExternalResourceReference refers to a server that supports IFC links. False otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExternalResourceServerUtils Class


ExternalResourceServerUtils.ServerSupportsKeynotes Method

ExternalResourceServerUtilsServerSupportsKeynotes Method

Checks that the server referenced by the given ExternalResourceReference supports KeynoteTable data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool ServerSupportsKeynotes(
    ExternalResourceReference extRef
)
Public Shared Function ServerSupportsKeynotes (
    extRef As ExternalResourceReference
) As Boolean
public:
static bool ServerSupportsKeynotes(
    ExternalResourceReference^ extRef
)
static member ServerSupportsKeynotes :
        extRef : ExternalResourceReference -> bool

Parameters

extRef ExternalResourceReference
The ExternalResourceReference to check.

Return Value

Boolean
True if the ExternalResourceReference refers to a server that supports keynotes. False otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExternalResourceServerUtils Class


ExternalResourceServerUtils.ServerSupportsRevitLinks Method

ExternalResourceServerUtilsServerSupportsRevitLinks Method

Checks that the server referenced by the given ExternalResourceReference supports Revit links.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool ServerSupportsRevitLinks(
    ExternalResourceReference extRef
)
Public Shared Function ServerSupportsRevitLinks (
    extRef As ExternalResourceReference
) As Boolean
public:
static bool ServerSupportsRevitLinks(
    ExternalResourceReference^ extRef
)
static member ServerSupportsRevitLinks :
        extRef : ExternalResourceReference -> bool

Parameters

extRef ExternalResourceReference
The ExternalResourceReference to check.

Return Value

Boolean
True if the ExternalResourceReference refers to a server that supports Revit links. False otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExternalResourceServerUtils Class


ExternalResourceServiceUtils Class

Contains utilities related to external resource service.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExternalResourceServiceUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ExternalResourceServiceUtils
Public NotInheritable Class ExternalResourceServiceUtils
public ref class ExternalResourceServiceUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ExternalResourceServiceUtils = class end

The ExternalResourceServiceUtils type exposes the following members.

Methods
Name | Description
GetServersByType | Gets registered external resource servers which support the external resource type.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExternalResourceServiceUtils Methods

The ExternalResourceServiceUtils type exposes the following members.

Methods
Name | Description
GetServersByType | Gets registered external resource servers which support the external resource type.
Top
See Also

Reference

ExternalResourceServiceUtils Class


ExternalResourceServiceUtils.GetServersByType Method

ExternalResourceServiceUtilsGetServersByType Method

Gets registered external resource servers which support the external resource type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<IExternalResourceServer> GetServersByType(
    ExternalResourceType type
)
Public Shared Function GetServersByType (
    type As ExternalResourceType
) As IList(Of IExternalResourceServer)
public:
static IList<IExternalResourceServer^>^ GetServersByType(
    ExternalResourceType^ type
)
static member GetServersByType :
        type : ExternalResourceType -> IList<IExternalResourceServer>

Parameters

type ExternalResourceType
The external resource type for the servers to match

Return Value

IList IExternalResourceServer
A list of matched external resource servers
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExternalResourceServiceUtils Class


ExternalResourceSubFolder Class

Data that describes a remote folder to be shown in the file browser dialog
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExternalResourceSubFolder

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExternalResourceSubFolder : IDisposable
Public Class ExternalResourceSubFolder
    Implements IDisposable
public ref class ExternalResourceSubFolder : IDisposable
type ExternalResourceSubFolder =
    class
        interface IDisposable
    end

The ExternalResourceSubFolder type exposes the following members.

Constructors
 | Name | Description
Public method | ExternalResourceSubFolder | Constructs a new ExternalResourceSubFolder with default values for folder name and icon path.
Public method | ExternalResourceSubFolder(String, String) | Constructs a new ExternalResourceSubFolder with custom values for folder name and icon path.
Top
Properties
 | Name | Description
Public property | FolderName | Folder displayed name.
Public property | IconPath | The path of the resource icon.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ExternalResourceSubFolder
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExternalResourceSubFolder Constructor

Overload List
 | Name | Description
Public method | ExternalResourceSubFolder | Constructs a new ExternalResourceSubFolder with default values for folder name and icon path.
Public method | ExternalResourceSubFolder(String, String) | Constructs a new ExternalResourceSubFolder with custom values for folder name and icon path.
Top
See Also

Reference

ExternalResourceSubFolder Class


ExternalResourceSubFolder Constructor

Constructs a new ExternalResourceSubFolder with default values for folder name and icon path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExternalResourceSubFolder()
Public Sub New
public:
ExternalResourceSubFolder()
new : unit -> ExternalResourceSubFolder
See Also

Reference

ExternalResourceSubFolder Class
ExternalResourceSubFolder Overload


ExternalResourceSubFolder(String, String) Constructor

Constructs a new ExternalResourceSubFolder with custom values for folder name and icon path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExternalResourceSubFolder(
    string folderName,
    string iconPath
)
Public Sub New (
    folderName As String,
    iconPath As String
)
public:
ExternalResourceSubFolder(
    String^ folderName,
    String^ iconPath
)
new :
        folderName : string *
        iconPath : string -> ExternalResourceSubFolder

Parameters

folderName String
Folder displayed name.
iconPath String
The path of the resource icon.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExternalResourceSubFolder Class
ExternalResourceSubFolder Overload


ExternalResourceSubFolder Properties

The ExternalResourceSubFolder type exposes the following members.

Properties
 | Name | Description
Public property | FolderName | Folder displayed name.
Public property | IconPath | The path of the resource icon.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

ExternalResourceSubFolder Class


ExternalResourceSubFolder.FolderName Property

ExternalResourceSubFolderFolderName Property

Folder displayed name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FolderName { get; set; }
Public Property FolderName As String
    Get
    Set
public:
property String^ FolderName {
    String^ get ();
    void set (String^ value);
}
member FolderName : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ExternalResourceSubFolder Class


ExternalResourceSubFolder.IconPath Property

ExternalResourceSubFolderIconPath Property

The path of the resource icon.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string IconPath { get; set; }
Public Property IconPath As String
    Get
    Set
public:
property String^ IconPath {
    String^ get ();
    void set (String^ value);
}
member IconPath : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ExternalResourceSubFolder Class


ExternalResourceSubFolder.IsValidObject Property

ExternalResourceSubFolderIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ExternalResourceSubFolder Class


ExternalResourceSubFolder Methods

The ExternalResourceSubFolder type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExternalResourceSubFolder Class


ExternalResourceSubFolder.Dispose Method

ExternalResourceSubFolderDispose Method

Releases all resources used by the ExternalResourceSubFolder

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ExternalResourceSubFolder Class


ExternalResourceType Class

A type class used to distinguish between different kinds of external resource.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBGuidEnum
Autodesk.Revit.DBExternalResourceType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExternalResourceType : GuidEnum
Public Class ExternalResourceType
    Inherits GuidEnum
public ref class ExternalResourceType : public GuidEnum
type ExternalResourceType =
    class
        inherit GuidEnum
    end

The ExternalResourceType type exposes the following members.

Constructors
 | Name | Description
Public method | ExternalResourceType | Creates a new ExternalResourceType instance.
Top
Properties
 | Name | Description
Public property | Guid | The Guid of GUID-based enum object. (Inherited from GuidEnum)
Top
Methods
 | Name | Description
Public method | Equals | Compares two Guid-based enum object based on their concrete class and GUID value. (Inherited from GuidEnum)
Public method | GetHashCode | Generates a hash code for this Guid-based enum object. (Inherited from GuidEnum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Operators
Name | Description
Equality(ExternalResourceType, ExternalResourceType) | Compares two ExternalResourceType instances.
Inequality(ExternalResourceType, ExternalResourceType) | Compares two ExternalResourceType instances.
Top
Remarks
Revit elements can consume multiple types of external resource data, provided by one or more external servers. Conversely, external servers can support one, or more than one, type of external resource.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExternalResourceType Constructor

Creates a new ExternalResourceType instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExternalResourceType(
    Guid guid
)
Public Sub New (
    guid As Guid
)
public:
ExternalResourceType(
    Guid guid
)
new :
        guid : Guid -> ExternalResourceType

Parameters

guid Guid
The identifier for the ExternalResourceType.
See Also

Reference

ExternalResourceType Class


ExternalResourceType Properties

The ExternalResourceType type exposes the following members.

Properties
 | Name | Description
Public property | Guid | The Guid of GUID-based enum object. (Inherited from GuidEnum)
Top
See Also

Reference

ExternalResourceType Class


ExternalResourceType Methods

The ExternalResourceType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares two Guid-based enum object based on their concrete class and GUID value. (Inherited from GuidEnum)
Public method | GetHashCode | Generates a hash code for this Guid-based enum object. (Inherited from GuidEnum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExternalResourceType Class


ExternalResourceType Operators

The ExternalResourceType type exposes the following members.

Operators
Name | Description
Equality(ExternalResourceType, ExternalResourceType) | Compares two ExternalResourceType instances.
Inequality(ExternalResourceType, ExternalResourceType) | Compares two ExternalResourceType instances.
Top
See Also

Reference

ExternalResourceType Class


ExternalResourceType.Equality Operator

ExternalResourceTypeEquality Operator

Compares two ExternalResourceType instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool operator ==(
    ExternalResourceType first,
    ExternalResourceType second
)
Public Shared Operator = (
    first As ExternalResourceType,
    second As ExternalResourceType
) As Boolean
public:
static bool operator ==(
    ExternalResourceType^ first,
    ExternalResourceType^ second
)
static let inline (=)
        first : ExternalResourceType *
        second : ExternalResourceType  : bool

Parameters

first ExternalResourceType
The first ExternalResourceType.
second ExternalResourceType
The second ExternalResourceType.

Return Value

Boolean
True if the inputs are identical, false if they are different.
See Also

Reference

ExternalResourceType Class


ExternalResourceType.Inequality Operator

ExternalResourceTypeInequality Operator

Compares two ExternalResourceType instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool operator !=(
    ExternalResourceType first,
    ExternalResourceType second
)
Public Shared Operator <> (
    first As ExternalResourceType,
    second As ExternalResourceType
) As Boolean
public:
static bool operator !=(
    ExternalResourceType^ first,
    ExternalResourceType^ second
)
static let inline (<>)
        first : ExternalResourceType *
        second : ExternalResourceType  : bool

Parameters

first ExternalResourceType
The first ExternalResourceType.
second ExternalResourceType
The second ExternalResourceType.

Return Value

Boolean
True if the inputs are different, false if they are identical.
See Also

Reference

ExternalResourceType Class


ExternalResourceTypes Class

Provides a container of all Revit built-in ExternalResourceType instances.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExternalResourceTypes

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ExternalResourceTypes
Public NotInheritable Class ExternalResourceTypes
public ref class ExternalResourceTypes abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ExternalResourceTypes = class end
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExternalResourceTypes.BuiltInExternalResourceTypes Class

ExternalResourceTypesBuiltInExternalResourceTypes Class

A collection of ids of the ExternalResourceTypes provided by Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExternalResourceTypesBuiltInExternalResourceTypes

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class BuiltInExternalResourceTypes
Public NotInheritable Class BuiltInExternalResourceTypes
public ref class BuiltInExternalResourceTypes abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type BuiltInExternalResourceTypes = class end

The ExternalResourceTypesBuiltInExternalResourceTypes type exposes the following members.

Properties
Name | Description
AssemblyCodeTable | An external resource type representing assembly code data.
CADLink | An external resource type representing CAD Links data.
DecalBumpMap | An external resource type representing Decal linked data for bump map. This type is reserved for future expansion but not yet implemented.
DecalCutOut | An external resource type representing Decal linked data for cut out opacity. This type is reserved for future expansion but not yet implemented.
DecalImage | An external resource type representing decal images.
DecalMap | An external resource type representing Decal linked data for diffuse. This type is reserved for future expansion but not yet implemented.
DWFMarkup | An external resource type representing DWF markups data. This type is reserved for future expansion but not yet implemented.
FabricationConfiguration | An external resource type representing an MEP fabrication configuration.
IFCLink | An external resource type representing IFC links.
Image | An external resource type representing images.
KeynoteTable | An external resource type representing keynote data.
MaterialTexture | An external resource type representing material texture images.
PointCloud | An external resource type representing Point Clouds. This type is reserved for future expansion but not yet implemented.
RevitLink | An external resource type representing Revit Links data.
SystemsAnalysisReport | An external resource type representing systems analysis report path.
TopographyLink | An external resource type representing Topography Links.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


BuiltInExternalResourceTypes Properties

The ExternalResourceTypesBuiltInExternalResourceTypes type exposes the following members.

Properties
Name | Description
AssemblyCodeTable | An external resource type representing assembly code data.
CADLink | An external resource type representing CAD Links data.
DecalBumpMap | An external resource type representing Decal linked data for bump map. This type is reserved for future expansion but not yet implemented.
DecalCutOut | An external resource type representing Decal linked data for cut out opacity. This type is reserved for future expansion but not yet implemented.
DecalImage | An external resource type representing decal images.
DecalMap | An external resource type representing Decal linked data for diffuse. This type is reserved for future expansion but not yet implemented.
DWFMarkup | An external resource type representing DWF markups data. This type is reserved for future expansion but not yet implemented.
FabricationConfiguration | An external resource type representing an MEP fabrication configuration.
IFCLink | An external resource type representing IFC links.
Image | An external resource type representing images.
KeynoteTable | An external resource type representing keynote data.
MaterialTexture | An external resource type representing material texture images.
PointCloud | An external resource type representing Point Clouds. This type is reserved for future expansion but not yet implemented.
RevitLink | An external resource type representing Revit Links data.
SystemsAnalysisReport | An external resource type representing systems analysis report path.
TopographyLink | An external resource type representing Topography Links.
Top
See Also

Reference

ExternalResourceTypesBuiltInExternalResourceTypes Class


ExternalResourceTypes.BuiltInExternalResourceTypes.AssemblyCodeTable Property

ExternalResourceTypesBuiltInExternalResourceTypesAssemblyCodeTable Property

An external resource type representing assembly code data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ExternalResourceType AssemblyCodeTable { get; }
Public Shared ReadOnly Property AssemblyCodeTable As ExternalResourceType
    Get
public:
static property ExternalResourceType^ AssemblyCodeTable {
    ExternalResourceType^ get ();
}
static member AssemblyCodeTable : ExternalResourceType with get

Property Value

ExternalResourceType
See Also

Reference

ExternalResourceTypesBuiltInExternalResourceTypes Class


ExternalResourceTypes.BuiltInExternalResourceTypes.CADLink Property

ExternalResourceTypesBuiltInExternalResourceTypesCADLink Property

An external resource type representing CAD Links data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ExternalResourceType CADLink { get; }
Public Shared ReadOnly Property CADLink As ExternalResourceType
    Get
public:
static property ExternalResourceType^ CADLink {
    ExternalResourceType^ get ();
}
static member CADLink : ExternalResourceType with get

Property Value

ExternalResourceType
See Also

Reference

ExternalResourceTypesBuiltInExternalResourceTypes Class


ExternalResourceTypes.BuiltInExternalResourceTypes.DecalBumpMap Property

ExternalResourceTypesBuiltInExternalResourceTypesDecalBumpMap Property

An external resource type representing Decal linked data for bump map. This type is reserved for future expansion but not yet implemented.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ExternalResourceType DecalBumpMap { get; }
Public Shared ReadOnly Property DecalBumpMap As ExternalResourceType
    Get
public:
static property ExternalResourceType^ DecalBumpMap {
    ExternalResourceType^ get ();
}
static member DecalBumpMap : ExternalResourceType with get

Property Value

ExternalResourceType
See Also

Reference

ExternalResourceTypesBuiltInExternalResourceTypes Class


ExternalResourceTypes.BuiltInExternalResourceTypes.DecalCutOut Property

ExternalResourceTypesBuiltInExternalResourceTypesDecalCutOut Property

An external resource type representing Decal linked data for cut out opacity. This type is reserved for future expansion but not yet implemented.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ExternalResourceType DecalCutOut { get; }
Public Shared ReadOnly Property DecalCutOut As ExternalResourceType
    Get
public:
static property ExternalResourceType^ DecalCutOut {
    ExternalResourceType^ get ();
}
static member DecalCutOut : ExternalResourceType with get

Property Value

ExternalResourceType
See Also

Reference

ExternalResourceTypesBuiltInExternalResourceTypes Class


ExternalResourceTypes.BuiltInExternalResourceTypes.DecalImage Property

ExternalResourceTypesBuiltInExternalResourceTypesDecalImage Property

An external resource type representing decal images.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ExternalResourceType DecalImage { get; }
Public Shared ReadOnly Property DecalImage As ExternalResourceType
    Get
public:
static property ExternalResourceType^ DecalImage {
    ExternalResourceType^ get ();
}
static member DecalImage : ExternalResourceType with get

Property Value

ExternalResourceType
See Also

Reference

ExternalResourceTypesBuiltInExternalResourceTypes Class


ExternalResourceTypes.BuiltInExternalResourceTypes.DecalMap Property

ExternalResourceTypesBuiltInExternalResourceTypesDecalMap Property

An external resource type representing Decal linked data for diffuse. This type is reserved for future expansion but not yet implemented.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ExternalResourceType DecalMap { get; }
Public Shared ReadOnly Property DecalMap As ExternalResourceType
    Get
public:
static property ExternalResourceType^ DecalMap {
    ExternalResourceType^ get ();
}
static member DecalMap : ExternalResourceType with get

Property Value

ExternalResourceType
See Also

Reference

ExternalResourceTypesBuiltInExternalResourceTypes Class


ExternalResourceTypes.BuiltInExternalResourceTypes.DWFMarkup Property

ExternalResourceTypesBuiltInExternalResourceTypesDWFMarkup Property

An external resource type representing DWF markups data. This type is reserved for future expansion but not yet implemented.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ExternalResourceType DWFMarkup { get; }
Public Shared ReadOnly Property DWFMarkup As ExternalResourceType
    Get
public:
static property ExternalResourceType^ DWFMarkup {
    ExternalResourceType^ get ();
}
static member DWFMarkup : ExternalResourceType with get

Property Value

ExternalResourceType
See Also

Reference

ExternalResourceTypesBuiltInExternalResourceTypes Class


ExternalResourceTypes.BuiltInExternalResourceTypes.FabricationConfiguration Property

ExternalResourceTypesBuiltInExternalResourceTypesFabricationConfiguration Property

An external resource type representing an MEP fabrication configuration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ExternalResourceType FabricationConfiguration { get; }
Public Shared ReadOnly Property FabricationConfiguration As ExternalResourceType
    Get
public:
static property ExternalResourceType^ FabricationConfiguration {
    ExternalResourceType^ get ();
}
static member FabricationConfiguration : ExternalResourceType with get

Property Value

ExternalResourceType
See Also

Reference

ExternalResourceTypesBuiltInExternalResourceTypes Class


ExternalResourceTypes.BuiltInExternalResourceTypes.IFCLink Property

ExternalResourceTypesBuiltInExternalResourceTypesIFCLink Property

An external resource type representing IFC links.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ExternalResourceType IFCLink { get; }
Public Shared ReadOnly Property IFCLink As ExternalResourceType
    Get
public:
static property ExternalResourceType^ IFCLink {
    ExternalResourceType^ get ();
}
static member IFCLink : ExternalResourceType with get

Property Value

ExternalResourceType
See Also

Reference

ExternalResourceTypesBuiltInExternalResourceTypes Class


ExternalResourceTypes.BuiltInExternalResourceTypes.Image Property

ExternalResourceTypesBuiltInExternalResourceTypesImage Property

An external resource type representing images.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ExternalResourceType Image { get; }
Public Shared ReadOnly Property Image As ExternalResourceType
    Get
public:
static property ExternalResourceType^ Image {
    ExternalResourceType^ get ();
}
static member Image : ExternalResourceType with get

Property Value

ExternalResourceType
See Also

Reference

ExternalResourceTypesBuiltInExternalResourceTypes Class


ExternalResourceTypes.BuiltInExternalResourceTypes.KeynoteTable Property

ExternalResourceTypesBuiltInExternalResourceTypesKeynoteTable Property

An external resource type representing keynote data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ExternalResourceType KeynoteTable { get; }
Public Shared ReadOnly Property KeynoteTable As ExternalResourceType
    Get
public:
static property ExternalResourceType^ KeynoteTable {
    ExternalResourceType^ get ();
}
static member KeynoteTable : ExternalResourceType with get

Property Value

ExternalResourceType
See Also

Reference

ExternalResourceTypesBuiltInExternalResourceTypes Class


ExternalResourceTypes.BuiltInExternalResourceTypes.MaterialTexture Property

ExternalResourceTypesBuiltInExternalResourceTypesMaterialTexture Property

An external resource type representing material texture images.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ExternalResourceType MaterialTexture { get; }
Public Shared ReadOnly Property MaterialTexture As ExternalResourceType
    Get
public:
static property ExternalResourceType^ MaterialTexture {
    ExternalResourceType^ get ();
}
static member MaterialTexture : ExternalResourceType with get

Property Value

ExternalResourceType
See Also

Reference

ExternalResourceTypesBuiltInExternalResourceTypes Class


ExternalResourceTypes.BuiltInExternalResourceTypes.PointCloud Property

ExternalResourceTypesBuiltInExternalResourceTypesPointCloud Property

An external resource type representing Point Clouds. This type is reserved for future expansion but not yet implemented.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ExternalResourceType PointCloud { get; }
Public Shared ReadOnly Property PointCloud As ExternalResourceType
    Get
public:
static property ExternalResourceType^ PointCloud {
    ExternalResourceType^ get ();
}
static member PointCloud : ExternalResourceType with get

Property Value

ExternalResourceType
See Also

Reference

ExternalResourceTypesBuiltInExternalResourceTypes Class


ExternalResourceTypes.BuiltInExternalResourceTypes.RevitLink Property

ExternalResourceTypesBuiltInExternalResourceTypesRevitLink Property

An external resource type representing Revit Links data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ExternalResourceType RevitLink { get; }
Public Shared ReadOnly Property RevitLink As ExternalResourceType
    Get
public:
static property ExternalResourceType^ RevitLink {
    ExternalResourceType^ get ();
}
static member RevitLink : ExternalResourceType with get

Property Value

ExternalResourceType
See Also

Reference

ExternalResourceTypesBuiltInExternalResourceTypes Class


ExternalResourceTypes.BuiltInExternalResourceTypes.SystemsAnalysisReport Property

ExternalResourceTypesBuiltInExternalResourceTypesSystemsAnalysisReport Property

An external resource type representing systems analysis report path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ExternalResourceType SystemsAnalysisReport { get; }
Public Shared ReadOnly Property SystemsAnalysisReport As ExternalResourceType
    Get
public:
static property ExternalResourceType^ SystemsAnalysisReport {
    ExternalResourceType^ get ();
}
static member SystemsAnalysisReport : ExternalResourceType with get

Property Value

ExternalResourceType
See Also

Reference

ExternalResourceTypesBuiltInExternalResourceTypes Class


ExternalResourceTypes.BuiltInExternalResourceTypes.TopographyLink Property

ExternalResourceTypesBuiltInExternalResourceTypesTopographyLink Property

An external resource type representing Topography Links.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ExternalResourceType TopographyLink { get; }
Public Shared ReadOnly Property TopographyLink As ExternalResourceType
    Get
public:
static property ExternalResourceType^ TopographyLink {
    ExternalResourceType^ get ();
}
static member TopographyLink : ExternalResourceType with get

Property Value

ExternalResourceType
See Also

Reference

ExternalResourceTypesBuiltInExternalResourceTypes Class


ExternalResourceUIBrowseResultType Enumeration

Describes the type of external resource browsing result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ExternalResourceUIBrowseResultType
Public Enumeration ExternalResourceUIBrowseResultType
public enum class ExternalResourceUIBrowseResultType
type ExternalResourceUIBrowseResultType
Members
Member name | Value | Description
Success | 0 | There is no predefined error happened during this browse operation. The DB server can store any errors itself in this case.
FolderNotFound | 1 | The specified external resource folder cannot be found by external resource server.
ResourceNotFound | 2 | The specified external resource cannot be found by external resource server.
Remarks
This enum is used to describe the type of external resources browsing operation result ( the browsing operation include list folders and resources of an external server or a folder, or open an external resource in browsing dialog.) The meaning of each enum value:
  • There is no predefined error happened during this browse operation. The DB server can store any errors itself in this case.
  • FolderNotFound means the external resource folder want to browse could not be founded in external server.
  • ResourceNotFound means the external resource want to open could not be founded in external server.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExternalResourceUtils Class

A utility class containing functions related to external resource references.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExternalResourceUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ExternalResourceUtils
Public NotInheritable Class ExternalResourceUtils
public ref class ExternalResourceUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ExternalResourceUtils = class end

The ExternalResourceUtils type exposes the following members.

Methods
Name | Description
GetAllExternalResourceReferences(Document) | Gets the ids of all elements which refer to external resources.
GetAllExternalResourceReferences(Document, ExternalResourceType) | Gets the ids of all elements which refer to a specific type of external resource.
Top
Remarks
Elements which are external resource references refer to data outside of the base .rvt file. Examples include Revit links and the keynote table data.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExternalResourceUtils Methods

The ExternalResourceUtils type exposes the following members.

Methods
Name | Description
GetAllExternalResourceReferences(Document) | Gets the ids of all elements which refer to external resources.
GetAllExternalResourceReferences(Document, ExternalResourceType) | Gets the ids of all elements which refer to a specific type of external resource.
Top
See Also

Reference

ExternalResourceUtils Class


ExternalResourceUtils.GetAllExternalResourceReferences Method

ExternalResourceUtilsGetAllExternalResourceReferences Method

Overload List
Name | Description
GetAllExternalResourceReferences(Document) | Gets the ids of all elements which refer to external resources.
GetAllExternalResourceReferences(Document, ExternalResourceType) | Gets the ids of all elements which refer to a specific type of external resource.
Top
See Also

Reference

ExternalResourceUtils Class


ExternalResourceUtils.GetAllExternalResourceReferences(Document) Method

ExternalResourceUtilsGetAllExternalResourceReferences(Document) Method

Gets the ids of all elements which refer to external resources.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ISet<ElementId> GetAllExternalResourceReferences(
    Document document
)
Public Shared Function GetAllExternalResourceReferences (
    document As Document
) As ISet(Of ElementId)
public:
static ISet<ElementId^>^ GetAllExternalResourceReferences(
    Document^ document
)
static member GetAllExternalResourceReferences :
        document : Document -> ISet<ElementId>

Parameters

document Document
The Revit Document containing the external resource references.

Return Value

ISet ElementId
The ids of all elements which refer to external resources.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
This function will not return the ids of nested Revit links; it only returns top-level references.
See Also

Reference

ExternalResourceUtils Class
GetAllExternalResourceReferences Overload


ExternalResourceUtils.GetAllExternalResourceReferences(Document, ExternalResourceType) Method

ExternalResourceUtilsGetAllExternalResourceReferences(Document, ExternalResourceType) Method

Gets the ids of all elements which refer to a specific type of external resource.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ISet<ElementId> GetAllExternalResourceReferences(
    Document document,
    ExternalResourceType resourceType
)
Public Shared Function GetAllExternalResourceReferences (
    document As Document,
    resourceType As ExternalResourceType
) As ISet(Of ElementId)
public:
static ISet<ElementId^>^ GetAllExternalResourceReferences(
    Document^ document,
    ExternalResourceType^ resourceType
)
static member GetAllExternalResourceReferences :
        document : Document *
        resourceType : ExternalResourceType -> ISet<ElementId>

Parameters

document Document
The Revit Document containing the external resource references.
resourceType ExternalResourceType
The type of external resource.

Return Value

ISet ElementId
The ids of all elements which refer to external resources of the specified type.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ExternalResourceUtils Class
GetAllExternalResourceReferences Overload


Extrusion Class

A extrusion solid or void form.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBCombinableElement
Autodesk.Revit.DBGenericForm
Autodesk.Revit.DBExtrusion

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Extrusion : GenericForm
Public Class Extrusion
    Inherits GenericForm
public ref class Extrusion : public GenericForm
type Extrusion =
    class
        inherit GenericForm
    end

The Extrusion type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | EndOffset | The offset of the end of the extrusion relative to the sketch plane.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Get and Set the Name property (Inherited from GenericForm)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Sketch | Returns the Sketch of the Extrusion.
Public property | StartOffset | The offset of the start of the extrusion relative to the sketch plane.
Public property | Subcategory | The subcategory. (Inherited from GenericForm)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Extrusion Properties

The Extrusion type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | EndOffset | The offset of the end of the extrusion relative to the sketch plane.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Get and Set the Name property (Inherited from GenericForm)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Sketch | Returns the Sketch of the Extrusion.
Public property | StartOffset | The offset of the start of the extrusion relative to the sketch plane.
Public property | Subcategory | The subcategory. (Inherited from GenericForm)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

Extrusion Class


Extrusion.EndOffset Property

ExtrusionEndOffset Property

The offset of the end of the extrusion relative to the sketch plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double EndOffset { get; set; }
Public Property EndOffset As Double
    Get
    Set
public:
property double EndOffset {
    double get ();
    void set (double value);
}
member EndOffset : float with get, set

Property Value

Double
Remarks
The direction of the offset is based on the normal of the extrusion's sketch plane: a positive value is in the direction of the normal, a negative value is in the other direction.
See Also

Reference

Extrusion Class


Extrusion.Sketch Property

ExtrusionSketch Property

Returns the Sketch of the Extrusion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Sketch Sketch { get; }
Public ReadOnly Property Sketch As Sketch
    Get
public:
property Sketch^ Sketch {
    Sketch^ get ();
}
member Sketch : Sketch with get

Property Value

Sketch
Remarks
This property is used to retrieve the Sketches of the Extrusion.
See Also

Reference

Extrusion Class


Extrusion.StartOffset Property

ExtrusionStartOffset Property

The offset of the start of the extrusion relative to the sketch plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double StartOffset { get; set; }
Public Property StartOffset As Double
    Get
    Set
public:
property double StartOffset {
    double get ();
    void set (double value);
}
member StartOffset : float with get, set

Property Value

Double
Remarks
The direction of the offset is based on the normal of the extrusion's sketch plane: a positive value is in the direction of the normal, a negative value is in the other direction.
See Also

Reference

Extrusion Class


Extrusion Methods

The Extrusion type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Extrusion Class


ExtrusionAnalyzer Class

This geometry utility allows you to attempt to "fit" a given piece of geometry into the shape of an extrusion.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExtrusionAnalyzer

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExtrusionAnalyzer : IDisposable
Public Class ExtrusionAnalyzer
    Implements IDisposable
public ref class ExtrusionAnalyzer : IDisposable
type ExtrusionAnalyzer =
    class
        interface IDisposable
    end

The ExtrusionAnalyzer type exposes the following members.

Properties
 | Name | Description
Public property | EndParameter | The end parameter (distance along the extrusion direction from the input plane) calculated by the extrusion analysis.
Public property | ExtrusionDirection | The direction of extrusion specified for the extrusion analysis.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | StartParameter | The start parameter (distance along the extrusion direction from the input plane) calculated by the extrusion analysis.
Top
Methods
 | Name | Description
Public method | CalculateFaceAlignment | Calculates the alignment status of each face of the solid.
 | Create | Creates an ExtrusionAnalyzer and computes and stores the solid's shadow.
Public method | Dispose | Releases all resources used by the ExtrusionAnalyzer
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetExtrusionBase | Obtains the face that represents the base contour of the extrusion analysis.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

An instance of this class is a single-time use class which should be supplied a solid geometry, a plane, and a direction. The utility will calculate a base boundary parallel to the input plane which is the outer boundary of the shadow cast by the solid onto the input plane and along the extrusion direction.

After the extrusion has been calculated, the class permits a second step analysis to identify all faces from the original geometry which do not align with the faces of the calculated extrusion.

This utility works best for geometry which are at least somewhat "extrusion-like", for example, the geometry of a wall which may or may not be affected by end joins, floor joins, roof joins, openings cut by windows and doors, or other modifications.

The ExtrusionAnalyzer expects only one single extrusion-like solid geometry. The ExtrusionAnalyzer does not support a Geometry containing multiple solids.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExtrusionAnalyzer Properties

The ExtrusionAnalyzer type exposes the following members.

Properties
 | Name | Description
Public property | EndParameter | The end parameter (distance along the extrusion direction from the input plane) calculated by the extrusion analysis.
Public property | ExtrusionDirection | The direction of extrusion specified for the extrusion analysis.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | StartParameter | The start parameter (distance along the extrusion direction from the input plane) calculated by the extrusion analysis.
Top
See Also

Reference

ExtrusionAnalyzer Class


ExtrusionAnalyzer.EndParameter Property

ExtrusionAnalyzerEndParameter Property

The end parameter (distance along the extrusion direction from the input plane) calculated by the extrusion analysis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double EndParameter { get; }
Public ReadOnly Property EndParameter As Double
    Get
public:
property double EndParameter {
    double get ();
}
member EndParameter : float with get

Property Value

Double
See Also

Reference

ExtrusionAnalyzer Class


ExtrusionAnalyzer.ExtrusionDirection Property

ExtrusionAnalyzerExtrusionDirection Property

The direction of extrusion specified for the extrusion analysis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ ExtrusionDirection { get; }
Public ReadOnly Property ExtrusionDirection As XYZ
    Get
public:
property XYZ^ ExtrusionDirection {
    XYZ^ get ();
}
member ExtrusionDirection : XYZ with get

Property Value

XYZ
See Also

Reference

ExtrusionAnalyzer Class


ExtrusionAnalyzer.IsValidObject Property

ExtrusionAnalyzerIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ExtrusionAnalyzer Class


ExtrusionAnalyzer.StartParameter Property

ExtrusionAnalyzerStartParameter Property

The start parameter (distance along the extrusion direction from the input plane) calculated by the extrusion analysis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double StartParameter { get; }
Public ReadOnly Property StartParameter As Double
    Get
public:
property double StartParameter {
    double get ();
}
member StartParameter : float with get

Property Value

Double
See Also

Reference

ExtrusionAnalyzer Class


ExtrusionAnalyzer Methods

The ExtrusionAnalyzer type exposes the following members.

Methods
 | Name | Description
Public method | CalculateFaceAlignment | Calculates the alignment status of each face of the solid.
 | Create | Creates an ExtrusionAnalyzer and computes and stores the solid's shadow.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetExtrusionBase | Obtains the face that represents the base contour of the extrusion analysis.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExtrusionAnalyzer Class


ExtrusionAnalyzer.CalculateFaceAlignment Method

ExtrusionAnalyzerCalculateFaceAlignment Method

Calculates the alignment status of each face of the solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IDictionary<Face, ExtrusionAnalyzerFaceAlignment> CalculateFaceAlignment()
Public Function CalculateFaceAlignment As IDictionary(Of Face, ExtrusionAnalyzerFaceAlignment)
public:
IDictionary<Face^, ExtrusionAnalyzerFaceAlignment>^ CalculateFaceAlignment()
member CalculateFaceAlignment : unit -> IDictionary<Face, ExtrusionAnalyzerFaceAlignment>

Return Value

IDictionary Face, ExtrusionAnalyzerFaceAlignment
Maps each face of the solid to its alignment status.
Remarks
You can obtain the element which produced the non-aligned face by passing the face to Element.GetGeneratingElementIds().
See Also

Reference

ExtrusionAnalyzer Class


ExtrusionAnalyzer.Create Method

ExtrusionAnalyzerCreate Method

Creates an ExtrusionAnalyzer and computes and stores the solid's shadow.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ExtrusionAnalyzer Create(
    Solid solidGeometry,
    Plane plane,
    XYZ direction
)
Public Shared Function Create (
    solidGeometry As Solid,
    plane As Plane,
    direction As XYZ
) As ExtrusionAnalyzer
public:
static ExtrusionAnalyzer^ Create(
    Solid^ solidGeometry,
    Plane^ plane,
    XYZ^ direction
)
static member Create :
        solidGeometry : Solid *
        plane : Plane *
        direction : XYZ -> ExtrusionAnalyzer

Parameters

solidGeometry Solid
The geometry to analyze.
plane Plane
The plane to use for the base plane for the extrusion.
direction XYZ
The direction to use for the calculation for the extrusion. The direction must be transverse to the base plane.

Return Value

ExtrusionAnalyzer
The newly created ExtrusionAnalyzer object.
Exceptions
Exception | Condition
ArgumentException | The input direction must be transverse to the input plane.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | A failure occurred in creating the ExtrusionAnalyzer or computing the solid's shadow.
See Also

Reference

ExtrusionAnalyzer Class


ExtrusionAnalyzer.Dispose Method

ExtrusionAnalyzerDispose Method

Releases all resources used by the ExtrusionAnalyzer

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ExtrusionAnalyzer Class


ExtrusionAnalyzer.GetExtrusionBase Method

ExtrusionAnalyzerGetExtrusionBase Method

Obtains the face that represents the base contour of the extrusion analysis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Face GetExtrusionBase()
Public Function GetExtrusionBase As Face
public:
Face^ GetExtrusionBase()
member GetExtrusionBase : unit -> Face

Return Value

Face
The face that represents the base contour.
See Also

Reference

ExtrusionAnalyzer Class


ExtrusionAnalyzerFaceAlignment Enumeration

Indicates whether a face of the solid analyzed by ExtrusionAnalyzer is fully aligned, partially aligned, or unaligned with faces of the extrusion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ExtrusionAnalyzerFaceAlignment
Public Enumeration ExtrusionAnalyzerFaceAlignment
public enum class ExtrusionAnalyzerFaceAlignment
type ExtrusionAnalyzerFaceAlignment
Members
Member name | Value | Description
FullyAligned | 0 | The face is fully aligned with faces of the extrusion.
PartiallyAligned | 1 | The face is only partially aligned with faces of the extrusion.
Unaligned | 2 | The face is not aligned with any faces of the extrusion.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExtrusionRoof Class

Represents some kinds of Extrusion Roofs.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBHostObject
Autodesk.Revit.DBRoofBase
Autodesk.Revit.DBExtrusionRoof

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ExtrusionRoof : RoofBase
Public Class ExtrusionRoof
    Inherits RoofBase
public ref class ExtrusionRoof : public RoofBase
type ExtrusionRoof =
    class
        inherit RoofBase
    end

The ExtrusionRoof type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CurtainGrids | Retrieve all the CurtainGrid objects of a curtain Roof.
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | EaveCuts | Retrieve or set the EaveCutterType. (Inherited from RoofBase)
Public property | FasciaDepth | Retrieve or set the FasciaDepth. (Inherited from RoofBase)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | RoofType | Retrieve or set the Type. (Inherited from RoofBase)
Public property | SlabShapeEditor | Obsolete. Get the SlabShapeEditor used for slab shape editing. (Inherited from RoofBase)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetProfile | Retrieve the Profile of ExtrusionRoof.
Public method | GetSlabShapeEditor | Gets a SlabShapeEditor that can used to add or modify points of this RoofBase. (Inherited from RoofBase)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The ExtrusionRoof object represents some kinds of extruded roofs in Revit.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ExtrusionRoof Properties

The ExtrusionRoof type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CurtainGrids | Retrieve all the CurtainGrid objects of a curtain Roof.
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | EaveCuts | Retrieve or set the EaveCutterType. (Inherited from RoofBase)
Public property | FasciaDepth | Retrieve or set the FasciaDepth. (Inherited from RoofBase)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | RoofType | Retrieve or set the Type. (Inherited from RoofBase)
Public property | SlabShapeEditor | Obsolete. Get the SlabShapeEditor used for slab shape editing. (Inherited from RoofBase)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

ExtrusionRoof Class


ExtrusionRoof.CurtainGrids Property

ExtrusionRoofCurtainGrids Property

Retrieve all the CurtainGrid objects of a curtain Roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurtainGridSet CurtainGrids { get; }
Public ReadOnly Property CurtainGrids As CurtainGridSet
    Get
public:
property CurtainGridSet^ CurtainGrids {
    CurtainGridSet^ get ();
}
member CurtainGrids : CurtainGridSet with get

Property Value

CurtainGridSet
Remarks
Only when the object is a CurtainRoof, this property makes sense.
See Also

Reference

ExtrusionRoof Class


ExtrusionRoof Methods

The ExtrusionRoof type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetProfile | Retrieve the Profile of ExtrusionRoof.
Public method | GetSlabShapeEditor | Gets a SlabShapeEditor that can used to add or modify points of this RoofBase. (Inherited from RoofBase)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ExtrusionRoof Class


ExtrusionRoof.GetProfile Method

ExtrusionRoofGetProfile Method

Retrieve the Profile of ExtrusionRoof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ModelCurveArray GetProfile()
Public Function GetProfile As ModelCurveArray
public:
ModelCurveArray^ GetProfile()
member GetProfile : unit -> ModelCurveArray

Return Value

ModelCurveArray
See Also

Reference

ExtrusionRoof Class


FabricationAncillaryUsage Class

Structure that holds information about the usage of a fabrication ancillary
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFabricationAncillaryUsage

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FabricationAncillaryUsage : IDisposable
Public Class FabricationAncillaryUsage
    Implements IDisposable
public ref class FabricationAncillaryUsage : IDisposable
type FabricationAncillaryUsage =
    class
        interface IDisposable
    end

The FabricationAncillaryUsage type exposes the following members.

Properties
 | Name | Description
Public property | AncillaryDepth | Depth of required ancillary if it isn't round.
Public property | AncillaryId | Fabrication ancillary database identifier.
Public property | AncillaryWidthOrDiameter | Width or diameter of required ancillary.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Length | Length of required ancillaries.
Public property | ProductCode | A unique string code that idnenifies the ancillary in the fabriction database in order to purchase it.
Public property | Quantity | Quantity of required ancillaries.
Public property | Type | Fabrication ancillary type.
Public property | UsageType | Fabrication ancillary usage type.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the FabricationAncillaryUsage
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FabricationAncillaryUsage Properties

The FabricationAncillaryUsage type exposes the following members.

Properties
 | Name | Description
Public property | AncillaryDepth | Depth of required ancillary if it isn't round.
Public property | AncillaryId | Fabrication ancillary database identifier.
Public property | AncillaryWidthOrDiameter | Width or diameter of required ancillary.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Length | Length of required ancillaries.
Public property | ProductCode | A unique string code that idnenifies the ancillary in the fabriction database in order to purchase it.
Public property | Quantity | Quantity of required ancillaries.
Public property | Type | Fabrication ancillary type.
Public property | UsageType | Fabrication ancillary usage type.
Top
See Also

Reference

FabricationAncillaryUsage Class


FabricationAncillaryUsage.AncillaryDepth Property

FabricationAncillaryUsageAncillaryDepth Property

Depth of required ancillary if it isn't round.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double AncillaryDepth { get; }
Public ReadOnly Property AncillaryDepth As Double
    Get
public:
property double AncillaryDepth {
    double get ();
}
member AncillaryDepth : float with get

Property Value

Double
See Also

Reference

FabricationAncillaryUsage Class


FabricationAncillaryUsage.AncillaryId Property

FabricationAncillaryUsageAncillaryId Property

Fabrication ancillary database identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int AncillaryId { get; }
Public ReadOnly Property AncillaryId As Integer
    Get
public:
property int AncillaryId {
    int get ();
}
member AncillaryId : int with get

Property Value

Int32
See Also

Reference

FabricationAncillaryUsage Class


FabricationAncillaryUsage.AncillaryWidthOrDiameter Property

FabricationAncillaryUsageAncillaryWidthOrDiameter Property

Width or diameter of required ancillary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double AncillaryWidthOrDiameter { get; }
Public ReadOnly Property AncillaryWidthOrDiameter As Double
    Get
public:
property double AncillaryWidthOrDiameter {
    double get ();
}
member AncillaryWidthOrDiameter : float with get

Property Value

Double
See Also

Reference

FabricationAncillaryUsage Class


FabricationAncillaryUsage.IsValidObject Property

FabricationAncillaryUsageIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

FabricationAncillaryUsage Class


FabricationAncillaryUsage.Length Property

FabricationAncillaryUsageLength Property

Length of required ancillaries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Length { get; }
Public ReadOnly Property Length As Double
    Get
public:
property double Length {
    double get ();
}
member Length : float with get

Property Value

Double
See Also

Reference

FabricationAncillaryUsage Class


FabricationAncillaryUsage.ProductCode Property

FabricationAncillaryUsageProductCode Property

A unique string code that idnenifies the ancillary in the fabriction database in order to purchase it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ProductCode { get; }
Public ReadOnly Property ProductCode As String
    Get
public:
property String^ ProductCode {
    String^ get ();
}
member ProductCode : string with get

Property Value

String
See Also

Reference

FabricationAncillaryUsage Class


FabricationAncillaryUsage.Quantity Property

FabricationAncillaryUsageQuantity Property

Quantity of required ancillaries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Quantity { get; }
Public ReadOnly Property Quantity As Double
    Get
public:
property double Quantity {
    double get ();
}
member Quantity : float with get

Property Value

Double
See Also

Reference

FabricationAncillaryUsage Class


FabricationAncillaryUsage.Type Property

FabricationAncillaryUsageType Property

Fabrication ancillary type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FabricationAncillaryType Type { get; }
Public ReadOnly Property Type As FabricationAncillaryType
    Get
public:
property FabricationAncillaryType Type {
    FabricationAncillaryType get ();
}
member Type : FabricationAncillaryType with get

Property Value

FabricationAncillaryType
See Also

Reference

FabricationAncillaryUsage Class


FabricationAncillaryUsage.UsageType Property

FabricationAncillaryUsageUsageType Property

Fabrication ancillary usage type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FabricationAncillaryUsageType UsageType { get; }
Public ReadOnly Property UsageType As FabricationAncillaryUsageType
    Get
public:
property FabricationAncillaryUsageType UsageType {
    FabricationAncillaryUsageType get ();
}
member UsageType : FabricationAncillaryUsageType with get

Property Value

FabricationAncillaryUsageType
See Also

Reference

FabricationAncillaryUsage Class


FabricationAncillaryUsage Methods

The FabricationAncillaryUsage type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FabricationAncillaryUsage Class


FabricationAncillaryUsage.Dispose Method

FabricationAncillaryUsageDispose Method

Releases all resources used by the FabricationAncillaryUsage

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FabricationAncillaryUsage Class


FabricationConfiguration Class

This element contains the information about the fabrication configuration settings used by the project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBFabricationConfiguration

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FabricationConfiguration : Element
Public Class FabricationConfiguration
    Inherits Element
public ref class FabricationConfiguration : public Element
type FabricationConfiguration =
    class
        inherit Element
    end

The FabricationConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | AncillaryExists | Checks to see if the specified ancillary exists.
Public method | AreItemFilesLoaded | Checks if the fabrication item files have been loaded.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanBeSwapped | Checks if the fabrication configuration can be swapped.
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | CanUnloadItemFiles | Checks if the fabrication item files are already in use and should not be unloaded.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | CheckConnectionsForAllFabricationParts | Checks the connections for all fabrication parts in the current project. It will create reviewable warnings for all bad connections found. The checks are looking for bad alignments or gaps, incompatible connection types, mismatches of size, mismatches of shapes.
Public method | CustomDataExists | Checks to see if the specified custom data exists.
Public method | DamperExists | Checks to see if the specified damper exists.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAllDampers | Gets all damper identifiers in the fabrication configuration.
Public method | GetAllFabricationConnectorDefinitions | Gets fabrication connector identifiers from the fabrication configuration, filtered by shape and domain.
Public method | GetAllInsulationSpecifications | Gets all insulation specification identifiers in the fabrication configuration.
Public method | GetAllLoadedItemFiles | Get list of all loaded fabrication item files.
Public method | GetAllLoadedServices | Returns all the loaded fabrication services.
Public method | GetAllMaterials | Gets all material identifiers in the fabrication configuration.
Public method | GetAllPartCustomData | Gets all possible fabrication part custom data identifiers.
Public method | GetAllPartStatuses | Gets all possible fabrication part status identifiers.
Public method | GetAllServices | Returns all fabrication services in the fabrication configuration.
Public method | GetAllSpecifications | Gets all specification identifiers in the fabrication configuration.
Public method | GetAllUsedItemFiles | Returns all the used fabrication item files. A fabrication item file is used if any fabrication parts in the model were created from it.
Public method | GetAllUsedServices | Returns all the used fabrication services. A service is used if any fabrication part in the service is created by user.
Public method | GetAncillaries | Gets fabrication ancillaries of the specified type.
Public method | GetAncillaryGroup | Gets the fabrication ancillary group of the specified fabrication ancillary identifier.
Public method | GetAncillaryGroupName | Gets the fabrication ancillary group and name for the specified fabrication ancillary identifier.
Public method | GetAncillaryName | Gets the fabrication ancillary name for the specified fabrication ancillary identifier.
Public method | GetDamperName | Gets the damper name from its identifier.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetFabricationConfiguration | Gets the fabrication configuration element in the document.
Public method | GetFabricationConfigurationInfo | Gets the information about the fabrication configuration of the project.
Public method | GetFabricationConnectorDomain | Gets the fabrication connector domain from its identifier.
Public method | GetFabricationConnectorGroup | Gets the fabrication connector group from its identifier.
Public method | GetFabricationConnectorName | Gets the fabrication connector name from its identifier.
Public method | GetFabricationConnectorShape | Gets the fabrication connector shape from its identifier.
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetInsulationSpecificationAbbreviation | Gets insulation specification abbreviation.
Public method | GetInsulationSpecificationGroup | Gets the insulation specification group from its identifier.
Public method | GetInsulationSpecificationName | Gets the insulation specification name from its identifier.
Public method | GetItemFolders | Gets a list of fabrication item folders in the fabrication item folder structure.
Public method | GetMaterialAbbreviation | Gets the abreviation of the material or the insulation or the double wall material.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialByGUID | Gets the material identifier by its GUID.
Public method | GetMaterialGaugeByGUID | Gets the material gauge identifier by its GUID and material identifier.
Public method | GetMaterialGaugeGUID | Gets the material gauge GUID by its material/gauge identifiers.
Public method | GetMaterialGroup | Gets material group from its identifier.
Public method | GetMaterialGUID | Gets the material GUID by its identifier.
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialName | Gets material name from its identifier.
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPartCustomDataName | Gets the custom data name from its identifier.
Public method | GetPartCustomDataType | Gets the custom data type from its identifier. See FabricationCustomDataType enumerator.
Public method | GetPartStatusDescription | Gets the status description from its identifier.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetProfile | Return the profile of the loaded fabrication configuration. Return empty string for global profile.
Public method | GetService | Get the service based on the service identifier from the fabrication configuration in the current document.
Public method | GetServiceByGUID | Gets the service identifier by its GUID.
Public method | GetServiceGUID | Gets the service GUID by its identifier.
Public method | GetServiceTypeName | Gets the service type name.
Public method | GetSpecificationAbbreviation | Gets specification abbreviation.
Public method | GetSpecificationByGUID | Gets the specification identifier by its GUID.
Public method | GetSpecificationGroup | Gets the specification group from its identifier.
Public method | GetSpecificationGUID | Gets the specification GUID by its identifier.
Public method | GetSpecificationName | Gets the specification name from its identifier.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetUpdatedStraightsFromValidateConnections | Get the set of element identifiers of fabrication part straights that were previously updated. If there were no straights were updated it will return an empty set of element identifiers.
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasValidConfiguration | Checks whether a valid fabrication configuration has been set for the project.
Public method | IsAncillaryKit | Gets whether the specified fabrication ancillary identifier is an ancillary kit or not.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LoadItemFiles | Loads the specified fabrication item files into the project.
Public method | LoadServices | Loads the specified fabrication services into the project.
Public method | LocateFabricationConnector | Gets the fabrication connector identifiers by group and name, filtered by shape and domain.
Public method | LocateInsulationSpecification | Gets the insulation specification by group and name.
Public method | LocateMaterial | Gets material by group and name.
Public method | LocateSpecification | Gets the specification identifier by group and name.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | PostReviewableWarningsForBadConnections | Reviewable warnings are created for all entries contained in the connection validation information.
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | ReloadConfiguration | Reloads the fabrication configuration from its source fabrication configuration.
Public method | SetConfiguration(FabricationConfigurationInfo) | Set the fabrication configuration with global profile.
Public method | SetConfiguration(FabricationConfigurationInfo, String) | Set the fabrication configuration with specific profile.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetServicesToLoad | Sets the services which are to be loaded or not next time reloadConfiguration is called. If a service is not included but is currently loaded then it will be unloaded then.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UnloadItemFiles | Unload the specified fabrication item files from the project.
Public method | UnloadServices | Unload the specified fabrication services from the project.
Public method | ValidateConnectionsForAllFabricationParts | Validates all fabrication part connections in the current project. Invalid connections found will be added to the connection validation information class. The validation checks for bad alignments or gaps, incompatible connection types, mismatches of size, mismatches of shapes.
Top
Remarks
The element provides information about the location of the fabrication database, its properties, and settings related to fabrication items.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FabricationConfiguration Properties

The FabricationConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration Methods

The FabricationConfiguration type exposes the following members.

Methods
 | Name | Description
Public method | AncillaryExists | Checks to see if the specified ancillary exists.
Public method | AreItemFilesLoaded | Checks if the fabrication item files have been loaded.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanBeSwapped | Checks if the fabrication configuration can be swapped.
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | CanUnloadItemFiles | Checks if the fabrication item files are already in use and should not be unloaded.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | CheckConnectionsForAllFabricationParts | Checks the connections for all fabrication parts in the current project. It will create reviewable warnings for all bad connections found. The checks are looking for bad alignments or gaps, incompatible connection types, mismatches of size, mismatches of shapes.
Public method | CustomDataExists | Checks to see if the specified custom data exists.
Public method | DamperExists | Checks to see if the specified damper exists.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAllDampers | Gets all damper identifiers in the fabrication configuration.
Public method | GetAllFabricationConnectorDefinitions | Gets fabrication connector identifiers from the fabrication configuration, filtered by shape and domain.
Public method | GetAllInsulationSpecifications | Gets all insulation specification identifiers in the fabrication configuration.
Public method | GetAllLoadedItemFiles | Get list of all loaded fabrication item files.
Public method | GetAllLoadedServices | Returns all the loaded fabrication services.
Public method | GetAllMaterials | Gets all material identifiers in the fabrication configuration.
Public method | GetAllPartCustomData | Gets all possible fabrication part custom data identifiers.
Public method | GetAllPartStatuses | Gets all possible fabrication part status identifiers.
Public method | GetAllServices | Returns all fabrication services in the fabrication configuration.
Public method | GetAllSpecifications | Gets all specification identifiers in the fabrication configuration.
Public method | GetAllUsedItemFiles | Returns all the used fabrication item files. A fabrication item file is used if any fabrication parts in the model were created from it.
Public method | GetAllUsedServices | Returns all the used fabrication services. A service is used if any fabrication part in the service is created by user.
Public method | GetAncillaries | Gets fabrication ancillaries of the specified type.
Public method | GetAncillaryGroup | Gets the fabrication ancillary group of the specified fabrication ancillary identifier.
Public method | GetAncillaryGroupName | Gets the fabrication ancillary group and name for the specified fabrication ancillary identifier.
Public method | GetAncillaryName | Gets the fabrication ancillary name for the specified fabrication ancillary identifier.
Public method | GetDamperName | Gets the damper name from its identifier.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetFabricationConfiguration | Gets the fabrication configuration element in the document.
Public method | GetFabricationConfigurationInfo | Gets the information about the fabrication configuration of the project.
Public method | GetFabricationConnectorDomain | Gets the fabrication connector domain from its identifier.
Public method | GetFabricationConnectorGroup | Gets the fabrication connector group from its identifier.
Public method | GetFabricationConnectorName | Gets the fabrication connector name from its identifier.
Public method | GetFabricationConnectorShape | Gets the fabrication connector shape from its identifier.
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetInsulationSpecificationAbbreviation | Gets insulation specification abbreviation.
Public method | GetInsulationSpecificationGroup | Gets the insulation specification group from its identifier.
Public method | GetInsulationSpecificationName | Gets the insulation specification name from its identifier.
Public method | GetItemFolders | Gets a list of fabrication item folders in the fabrication item folder structure.
Public method | GetMaterialAbbreviation | Gets the abreviation of the material or the insulation or the double wall material.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialByGUID | Gets the material identifier by its GUID.
Public method | GetMaterialGaugeByGUID | Gets the material gauge identifier by its GUID and material identifier.
Public method | GetMaterialGaugeGUID | Gets the material gauge GUID by its material/gauge identifiers.
Public method | GetMaterialGroup | Gets material group from its identifier.
Public method | GetMaterialGUID | Gets the material GUID by its identifier.
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialName | Gets material name from its identifier.
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPartCustomDataName | Gets the custom data name from its identifier.
Public method | GetPartCustomDataType | Gets the custom data type from its identifier. See FabricationCustomDataType enumerator.
Public method | GetPartStatusDescription | Gets the status description from its identifier.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetProfile | Return the profile of the loaded fabrication configuration. Return empty string for global profile.
Public method | GetService | Get the service based on the service identifier from the fabrication configuration in the current document.
Public method | GetServiceByGUID | Gets the service identifier by its GUID.
Public method | GetServiceGUID | Gets the service GUID by its identifier.
Public method | GetServiceTypeName | Gets the service type name.
Public method | GetSpecificationAbbreviation | Gets specification abbreviation.
Public method | GetSpecificationByGUID | Gets the specification identifier by its GUID.
Public method | GetSpecificationGroup | Gets the specification group from its identifier.
Public method | GetSpecificationGUID | Gets the specification GUID by its identifier.
Public method | GetSpecificationName | Gets the specification name from its identifier.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetUpdatedStraightsFromValidateConnections | Get the set of element identifiers of fabrication part straights that were previously updated. If there were no straights were updated it will return an empty set of element identifiers.
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasValidConfiguration | Checks whether a valid fabrication configuration has been set for the project.
Public method | IsAncillaryKit | Gets whether the specified fabrication ancillary identifier is an ancillary kit or not.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LoadItemFiles | Loads the specified fabrication item files into the project.
Public method | LoadServices | Loads the specified fabrication services into the project.
Public method | LocateFabricationConnector | Gets the fabrication connector identifiers by group and name, filtered by shape and domain.
Public method | LocateInsulationSpecification | Gets the insulation specification by group and name.
Public method | LocateMaterial | Gets material by group and name.
Public method | LocateSpecification | Gets the specification identifier by group and name.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | PostReviewableWarningsForBadConnections | Reviewable warnings are created for all entries contained in the connection validation information.
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | ReloadConfiguration | Reloads the fabrication configuration from its source fabrication configuration.
Public method | SetConfiguration(FabricationConfigurationInfo) | Set the fabrication configuration with global profile.
Public method | SetConfiguration(FabricationConfigurationInfo, String) | Set the fabrication configuration with specific profile.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetServicesToLoad | Sets the services which are to be loaded or not next time reloadConfiguration is called. If a service is not included but is currently loaded then it will be unloaded then.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UnloadItemFiles | Unload the specified fabrication item files from the project.
Public method | UnloadServices | Unload the specified fabrication services from the project.
Public method | ValidateConnectionsForAllFabricationParts | Validates all fabrication part connections in the current project. Invalid connections found will be added to the connection validation information class. The validation checks for bad alignments or gaps, incompatible connection types, mismatches of size, mismatches of shapes.
Top
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.AncillaryExists Method

FabricationConfigurationAncillaryExists Method

Checks to see if the specified ancillary exists.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AncillaryExists(
    int ancillaryId
)
Public Function AncillaryExists (
    ancillaryId As Integer
) As Boolean
public:
bool AncillaryExists(
    int ancillaryId
)
member AncillaryExists :
        ancillaryId : int -> bool

Parameters

ancillaryId Int32
The ancillary identifier.

Return Value

Boolean
Returns true if the ancillary exists.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.AreItemFilesLoaded Method

FabricationConfigurationAreItemFilesLoaded Method

Checks if the fabrication item files have been loaded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AreItemFilesLoaded(
    IList<FabricationItemFile> itemFiles
)
Public Function AreItemFilesLoaded (
    itemFiles As IList(Of FabricationItemFile)
) As Boolean
public:
bool AreItemFilesLoaded(
    IList<FabricationItemFile^>^ itemFiles
)
member AreItemFilesLoaded :
        itemFiles : IList<FabricationItemFile> -> bool

Parameters

itemFiles IList FabricationItemFile
The fabrication item files.

Return Value

Boolean
Returns true if the fabrication item files have been loaded, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.CanBeSwapped Method

FabricationConfigurationCanBeSwapped Method

Checks if the fabrication configuration can be swapped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanBeSwapped()
Public Function CanBeSwapped As Boolean
public:
bool CanBeSwapped()
member CanBeSwapped : unit -> bool

Return Value

Boolean
True if the fabrication configuration can be swapped, false otherwise.
Remarks
Swapping configuration is not permitted if the existing configuration has already been used to create fabrication part elements in the document.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.CanUnloadItemFiles Method

FabricationConfigurationCanUnloadItemFiles Method

Checks if the fabrication item files are already in use and should not be unloaded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanUnloadItemFiles(
    IList<FabricationItemFile> itemFiles
)
Public Function CanUnloadItemFiles (
    itemFiles As IList(Of FabricationItemFile)
) As Boolean
public:
bool CanUnloadItemFiles(
    IList<FabricationItemFile^>^ itemFiles
)
member CanUnloadItemFiles :
        itemFiles : IList<FabricationItemFile> -> bool

Parameters

itemFiles IList FabricationItemFile
The fabrication item files to unload.

Return Value

Boolean
Returns true if the fabrication item files can be unloaded, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.CheckConnectionsForAllFabricationParts Method

FabricationConfigurationCheckConnectionsForAllFabricationParts Method

Checks the connections for all fabrication parts in the current project. It will create reviewable warnings for all bad connections found. The checks are looking for bad alignments or gaps, incompatible connection types, mismatches of size, mismatches of shapes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int CheckConnectionsForAllFabricationParts()
Public Function CheckConnectionsForAllFabricationParts As Integer
public:
int CheckConnectionsForAllFabricationParts()
member CheckConnectionsForAllFabricationParts : unit -> int

Return Value

Int32
The number of bad connections found.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.CustomDataExists Method

FabricationConfigurationCustomDataExists Method

Checks to see if the specified custom data exists.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CustomDataExists(
    int customDataId
)
Public Function CustomDataExists (
    customDataId As Integer
) As Boolean
public:
bool CustomDataExists(
    int customDataId
)
member CustomDataExists :
        customDataId : int -> bool

Parameters

customDataId Int32
The custom data identifier.

Return Value

Boolean
Returns true if the custom data exists.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.DamperExists Method

FabricationConfigurationDamperExists Method

Checks to see if the specified damper exists.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool DamperExists(
    int damperId
)
Public Function DamperExists (
    damperId As Integer
) As Boolean
public:
bool DamperExists(
    int damperId
)
member DamperExists :
        damperId : int -> bool

Parameters

damperId Int32
The damper identifier to check.

Return Value

Boolean
Returns true if the damper exists.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetAllDampers Method

FabricationConfigurationGetAllDampers Method

Gets all damper identifiers in the fabrication configuration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<int> GetAllDampers()
Public Function GetAllDampers As IList(Of Integer)
public:
IList<int>^ GetAllDampers()
member GetAllDampers : unit -> IList<int>

Return Value

IList Int32
An array of specification identifiers.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetAllFabricationConnectorDefinitions Method

FabricationConfigurationGetAllFabricationConnectorDefinitions Method

Gets fabrication connector identifiers from the fabrication configuration, filtered by shape and domain.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<int> GetAllFabricationConnectorDefinitions(
    ConnectorDomainType domain,
    ConnectorProfileType shape
)
Public Function GetAllFabricationConnectorDefinitions (
    domain As ConnectorDomainType,
    shape As ConnectorProfileType
) As IList(Of Integer)
public:
IList<int>^ GetAllFabricationConnectorDefinitions(
    ConnectorDomainType domain,
    ConnectorProfileType shape
)
member GetAllFabricationConnectorDefinitions :
        domain : ConnectorDomainType *
        shape : ConnectorProfileType -> IList<int>

Parameters

domain ConnectorDomainType
ConnectorDomainType to filter by. Pass ConnectorDomainType.Undefined to get all connector domains.
shape ConnectorProfileType
ConnectorProfileType to filter by. Pass ConnectorProfileType.Invalid to get all shapes.

Return Value

IList Int32
All the fabrication connector identifiers, filtered by shape and domain. The return will be empty if no connectors are found.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetAllInsulationSpecifications Method

FabricationConfigurationGetAllInsulationSpecifications Method

Gets all insulation specification identifiers in the fabrication configuration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<int> GetAllInsulationSpecifications(
    FabricationPart pFabPart
)
Public Function GetAllInsulationSpecifications (
    pFabPart As FabricationPart
) As IList(Of Integer)
public:
IList<int>^ GetAllInsulationSpecifications(
    FabricationPart^ pFabPart
)
member GetAllInsulationSpecifications :
        pFabPart : FabricationPart -> IList<int>

Parameters

pFabPart FabricationPart
The fabrication part.

Return Value

IList Int32
An array of insulation specification identifiers.
Remarks
If a part is passed, only returns insulation specification which are valid for the part, otherwise returns all insulation specifications.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetAllLoadedItemFiles Method

FabricationConfigurationGetAllLoadedItemFiles Method

Get list of all loaded fabrication item files.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<FabricationItemFile> GetAllLoadedItemFiles()
Public Function GetAllLoadedItemFiles As IList(Of FabricationItemFile)
public:
IList<FabricationItemFile^>^ GetAllLoadedItemFiles()
member GetAllLoadedItemFiles : unit -> IList<FabricationItemFile>

Return Value

IList FabricationItemFile
Returns an array of the loaded fabrication item files.
Exceptions
Exception | Condition
InvalidOperationException | The fabrication configuration is not set yet.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetAllLoadedServices Method

FabricationConfigurationGetAllLoadedServices Method

Returns all the loaded fabrication services.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<FabricationService> GetAllLoadedServices()
Public Function GetAllLoadedServices As IList(Of FabricationService)
public:
IList<FabricationService^>^ GetAllLoadedServices()
member GetAllLoadedServices : unit -> IList<FabricationService>

Return Value

IList FabricationService
All the loaded fabrication services.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetAllMaterials Method

FabricationConfigurationGetAllMaterials Method

Gets all material identifiers in the fabrication configuration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<int> GetAllMaterials(
    FabricationPart part
)
Public Function GetAllMaterials (
    part As FabricationPart
) As IList(Of Integer)
public:
IList<int>^ GetAllMaterials(
    FabricationPart^ part
)
member GetAllMaterials :
        part : FabricationPart -> IList<int>

Parameters

part FabricationPart
The fabrication part.

Return Value

IList Int32
An array of material identifiers.
Remarks
If a part is passed, only returns materials which are valid for the part, otherwise returns all materials.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetAllPartCustomData Method

FabricationConfigurationGetAllPartCustomData Method

Gets all possible fabrication part custom data identifiers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<int> GetAllPartCustomData()
Public Function GetAllPartCustomData As IList(Of Integer)
public:
IList<int>^ GetAllPartCustomData()
member GetAllPartCustomData : unit -> IList<int>

Return Value

IList Int32
An array of custom data identifiers.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetAllPartStatuses Method

FabricationConfigurationGetAllPartStatuses Method

Gets all possible fabrication part status identifiers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<int> GetAllPartStatuses()
Public Function GetAllPartStatuses As IList(Of Integer)
public:
IList<int>^ GetAllPartStatuses()
member GetAllPartStatuses : unit -> IList<int>

Return Value

IList Int32
An array of status identifiers.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetAllServices Method

FabricationConfigurationGetAllServices Method

Returns all fabrication services in the fabrication configuration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<FabricationService> GetAllServices()
Public Function GetAllServices As IList(Of FabricationService)
public:
IList<FabricationService^>^ GetAllServices()
member GetAllServices : unit -> IList<FabricationService>

Return Value

IList FabricationService
All fabrication services. The return will be empty if no services are found.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetAllSpecifications Method

FabricationConfigurationGetAllSpecifications Method

Gets all specification identifiers in the fabrication configuration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<int> GetAllSpecifications(
    FabricationPart part
)
Public Function GetAllSpecifications (
    part As FabricationPart
) As IList(Of Integer)
public:
IList<int>^ GetAllSpecifications(
    FabricationPart^ part
)
member GetAllSpecifications :
        part : FabricationPart -> IList<int>

Parameters

part FabricationPart
The fabrication part.

Return Value

IList Int32
An array of specification identifiers.
Remarks
If a part is passed, only returns specifications which are valid for the part, otherwise returns all specifications.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetAllUsedItemFiles Method

FabricationConfigurationGetAllUsedItemFiles Method

Returns all the used fabrication item files. A fabrication item file is used if any fabrication parts in the model were created from it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<FabricationItemFile> GetAllUsedItemFiles()
Public Function GetAllUsedItemFiles As IList(Of FabricationItemFile)
public:
IList<FabricationItemFile^>^ GetAllUsedItemFiles()
member GetAllUsedItemFiles : unit -> IList<FabricationItemFile>

Return Value

IList FabricationItemFile
All the used fabrication item files.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetAllUsedServices Method

FabricationConfigurationGetAllUsedServices Method

Returns all the used fabrication services. A service is used if any fabrication part in the service is created by user.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<FabricationService> GetAllUsedServices()
Public Function GetAllUsedServices As IList(Of FabricationService)
public:
IList<FabricationService^>^ GetAllUsedServices()
member GetAllUsedServices : unit -> IList<FabricationService>

Return Value

IList FabricationService
All the used fabrication services.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetAncillaries Method

FabricationConfigurationGetAncillaries Method

Gets fabrication ancillaries of the specified type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<int> GetAncillaries(
    FabricationAncillaryType type,
    bool includeKits,
    bool filterKits
)
Public Function GetAncillaries (
    type As FabricationAncillaryType,
    includeKits As Boolean,
    filterKits As Boolean
) As IList(Of Integer)
public:
IList<int>^ GetAncillaries(
    FabricationAncillaryType type,
    bool includeKits,
    bool filterKits
)
member GetAncillaries :
        type : FabricationAncillaryType *
        includeKits : bool *
        filterKits : bool -> IList<int>

Parameters

type FabricationAncillaryType
The type of ancillaries to get.
includeKits Boolean
Whether or not to include ancillary kits as well.
filterKits Boolean
Whether kits should be filtered to only those that contain the specified ancillary type.

Return Value

IList Int32
An array of ancillary identifiers.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetAncillaryGroup Method

FabricationConfigurationGetAncillaryGroup Method

Gets the fabrication ancillary group of the specified fabrication ancillary identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetAncillaryGroup(
    int ancillaryId
)
Public Function GetAncillaryGroup (
    ancillaryId As Integer
) As String
public:
String^ GetAncillaryGroup(
    int ancillaryId
)
member GetAncillaryGroup :
        ancillaryId : int -> string

Parameters

ancillaryId Int32
The fabrication ancillary database identifier of the ancillary.

Return Value

String
The group name of the ancillary.
Exceptions
Exception | Condition
ArgumentException | The ancillary does not exist.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetAncillaryGroupName Method

FabricationConfigurationGetAncillaryGroupName Method

Gets the fabrication ancillary group and name for the specified fabrication ancillary identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetAncillaryGroupName(
    int ancillaryId
)
Public Function GetAncillaryGroupName (
    ancillaryId As Integer
) As String
public:
String^ GetAncillaryGroupName(
    int ancillaryId
)
member GetAncillaryGroupName :
        ancillaryId : int -> string

Parameters

ancillaryId Int32
The fabrication ancillary database identifier of the ancillary.

Return Value

String
The group and name of the ancillary.
Exceptions
Exception | Condition
ArgumentException | The ancillary does not exist.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetAncillaryName Method

FabricationConfigurationGetAncillaryName Method

Gets the fabrication ancillary name for the specified fabrication ancillary identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetAncillaryName(
    int ancillaryId
)
Public Function GetAncillaryName (
    ancillaryId As Integer
) As String
public:
String^ GetAncillaryName(
    int ancillaryId
)
member GetAncillaryName :
        ancillaryId : int -> string

Parameters

ancillaryId Int32
The fabrication ancillary database identifier of the ancillary.

Return Value

String
The name of the ancillary.
Exceptions
Exception | Condition
ArgumentException | The ancillary does not exist.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetDamperName Method

FabricationConfigurationGetDamperName Method

Gets the damper name from its identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetDamperName(
    int damperId
)
Public Function GetDamperName (
    damperId As Integer
) As String
public:
String^ GetDamperName(
    int damperId
)
member GetDamperName :
        damperId : int -> string

Parameters

damperId Int32
The damper identifier.

Return Value

String
The damper name.
Exceptions
Exception | Condition
ArgumentException | The damper does not exist.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetFabricationConfiguration Method

FabricationConfigurationGetFabricationConfiguration Method

Gets the fabrication configuration element in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FabricationConfiguration GetFabricationConfiguration(
    Document document
)
Public Shared Function GetFabricationConfiguration (
    document As Document
) As FabricationConfiguration
public:
static FabricationConfiguration^ GetFabricationConfiguration(
    Document^ document
)
static member GetFabricationConfiguration :
        document : Document -> FabricationConfiguration

Parameters

document Document
The document.

Return Value

FabricationConfiguration
The fabrication configuration element in the document.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetFabricationConfigurationInfo Method

FabricationConfigurationGetFabricationConfigurationInfo Method

Gets the information about the fabrication configuration of the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FabricationConfigurationInfo GetFabricationConfigurationInfo()
Public Function GetFabricationConfigurationInfo As FabricationConfigurationInfo
public:
FabricationConfigurationInfo^ GetFabricationConfigurationInfo()
member GetFabricationConfigurationInfo : unit -> FabricationConfigurationInfo

Return Value

FabricationConfigurationInfo
The information about the fabrication configuration of the project.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetFabricationConnectorDomain Method

FabricationConfigurationGetFabricationConnectorDomain Method

Gets the fabrication connector domain from its identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConnectorDomainType GetFabricationConnectorDomain(
    int fabricationConnectorId
)
Public Function GetFabricationConnectorDomain (
    fabricationConnectorId As Integer
) As ConnectorDomainType
public:
ConnectorDomainType GetFabricationConnectorDomain(
    int fabricationConnectorId
)
member GetFabricationConnectorDomain :
        fabricationConnectorId : int -> ConnectorDomainType

Parameters

fabricationConnectorId Int32
The fabrication connector identifier.

Return Value

ConnectorDomainType
The fabrication connector's domain.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetFabricationConnectorGroup Method

FabricationConfigurationGetFabricationConnectorGroup Method

Gets the fabrication connector group from its identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetFabricationConnectorGroup(
    int fabricationConnectorId
)
Public Function GetFabricationConnectorGroup (
    fabricationConnectorId As Integer
) As String
public:
String^ GetFabricationConnectorGroup(
    int fabricationConnectorId
)
member GetFabricationConnectorGroup :
        fabricationConnectorId : int -> string

Parameters

fabricationConnectorId Int32
The fabrication connector identifier.

Return Value

String
The fabrication connector's group.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetFabricationConnectorName Method

FabricationConfigurationGetFabricationConnectorName Method

Gets the fabrication connector name from its identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetFabricationConnectorName(
    int fabricationConnectorId
)
Public Function GetFabricationConnectorName (
    fabricationConnectorId As Integer
) As String
public:
String^ GetFabricationConnectorName(
    int fabricationConnectorId
)
member GetFabricationConnectorName :
        fabricationConnectorId : int -> string

Parameters

fabricationConnectorId Int32
The fabrication connector identifier.

Return Value

String
The fabrication connector's name.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetFabricationConnectorShape Method

FabricationConfigurationGetFabricationConnectorShape Method

Gets the fabrication connector shape from its identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConnectorProfileType GetFabricationConnectorShape(
    int fabricationConnectorId
)
Public Function GetFabricationConnectorShape (
    fabricationConnectorId As Integer
) As ConnectorProfileType
public:
ConnectorProfileType GetFabricationConnectorShape(
    int fabricationConnectorId
)
member GetFabricationConnectorShape :
        fabricationConnectorId : int -> ConnectorProfileType

Parameters

fabricationConnectorId Int32
The fabrication connector identifier.

Return Value

ConnectorProfileType
The fabrication connector's shape.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetInsulationSpecificationAbbreviation Method

FabricationConfigurationGetInsulationSpecificationAbbreviation Method

Gets insulation specification abbreviation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetInsulationSpecificationAbbreviation(
    int insulationSpecificationId
)
Public Function GetInsulationSpecificationAbbreviation (
    insulationSpecificationId As Integer
) As String
public:
String^ GetInsulationSpecificationAbbreviation(
    int insulationSpecificationId
)
member GetInsulationSpecificationAbbreviation :
        insulationSpecificationId : int -> string

Parameters

insulationSpecificationId Int32
The insulation specification identifier.

Return Value

String
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetInsulationSpecificationGroup Method

FabricationConfigurationGetInsulationSpecificationGroup Method

Gets the insulation specification group from its identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetInsulationSpecificationGroup(
    int specId
)
Public Function GetInsulationSpecificationGroup (
    specId As Integer
) As String
public:
String^ GetInsulationSpecificationGroup(
    int specId
)
member GetInsulationSpecificationGroup :
        specId : int -> string

Parameters

specId Int32
The insulation specification identifier.

Return Value

String
The insulation specification group.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetInsulationSpecificationName Method

FabricationConfigurationGetInsulationSpecificationName Method

Gets the insulation specification name from its identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetInsulationSpecificationName(
    int specId
)
Public Function GetInsulationSpecificationName (
    specId As Integer
) As String
public:
String^ GetInsulationSpecificationName(
    int specId
)
member GetInsulationSpecificationName :
        specId : int -> string

Parameters

specId Int32
The insulation specification identifier.

Return Value

String
The insulation specification name.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetItemFolders Method

FabricationConfigurationGetItemFolders Method

Gets a list of fabrication item folders in the fabrication item folder structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<FabricationItemFolder> GetItemFolders()
Public Function GetItemFolders As IList(Of FabricationItemFolder)
public:
IList<FabricationItemFolder^>^ GetItemFolders()
member GetItemFolders : unit -> IList<FabricationItemFolder>

Return Value

IList FabricationItemFolder
Returns a list of fabrication item folders in the fabrication item folder structure.
Exceptions
Exception | Condition
InvalidOperationException | The current fabrication configuration is not connected and updated to source configuration. Reload and try again.
Remarks
To get the item folders, you may need to call ReloadConfiguration first.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetMaterialAbbreviation Method

FabricationConfigurationGetMaterialAbbreviation Method

Gets the abreviation of the material or the insulation or the double wall material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetMaterialAbbreviation(
    int materialId
)
Public Function GetMaterialAbbreviation (
    materialId As Integer
) As String
public:
String^ GetMaterialAbbreviation(
    int materialId
)
member GetMaterialAbbreviation :
        materialId : int -> string

Parameters

materialId Int32
The material identifier.

Return Value

String
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetMaterialByGUID Method

FabricationConfigurationGetMaterialByGUID Method

Gets the material identifier by its GUID.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetMaterialByGUID(
    Guid materialGUID
)
Public Function GetMaterialByGUID (
    materialGUID As Guid
) As Integer
public:
int GetMaterialByGUID(
    Guid materialGUID
)
member GetMaterialByGUID :
        materialGUID : Guid -> int

Parameters

materialGUID Guid
The material GUID.

Return Value

Int32
The material identifier. Returns 0 if not found.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetMaterialGaugeByGUID Method

FabricationConfigurationGetMaterialGaugeByGUID Method

Gets the material gauge identifier by its GUID and material identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetMaterialGaugeByGUID(
    Guid gaugeGUID,
    int materialId
)
Public Function GetMaterialGaugeByGUID (
    gaugeGUID As Guid,
    materialId As Integer
) As Integer
public:
int GetMaterialGaugeByGUID(
    Guid gaugeGUID,
    int materialId
)
member GetMaterialGaugeByGUID :
        gaugeGUID : Guid *
        materialId : int -> int

Parameters

gaugeGUID Guid
The material gauge GUID.
materialId Int32
The material identifier. The same material gauge GUID could have different material gauge identifiers for different materials.

Return Value

Int32
The gauge identifier. Returns 0 if not found.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetMaterialGaugeGUID Method

FabricationConfigurationGetMaterialGaugeGUID Method

Gets the material gauge GUID by its material/gauge identifiers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid GetMaterialGaugeGUID(
    int materialId,
    int gaugeId
)
Public Function GetMaterialGaugeGUID (
    materialId As Integer,
    gaugeId As Integer
) As Guid
public:
Guid GetMaterialGaugeGUID(
    int materialId,
    int gaugeId
)
member GetMaterialGaugeGUID :
        materialId : int *
        gaugeId : int -> Guid

Parameters

materialId Int32
The material identifier. The same material gauge GUID could have different material gauge identifiers for different materials.
gaugeId Int32
The material gauge identifier.

Return Value

Guid
The material gauge GUID. Returns empty GUID if not found.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetMaterialGroup Method

FabricationConfigurationGetMaterialGroup Method

Gets material group from its identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetMaterialGroup(
    int materialId
)
Public Function GetMaterialGroup (
    materialId As Integer
) As String
public:
String^ GetMaterialGroup(
    int materialId
)
member GetMaterialGroup :
        materialId : int -> string

Parameters

materialId Int32
The material identifier.

Return Value

String
The material group.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetMaterialGUID Method

FabricationConfigurationGetMaterialGUID Method

Gets the material GUID by its identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid GetMaterialGUID(
    int materialId
)
Public Function GetMaterialGUID (
    materialId As Integer
) As Guid
public:
Guid GetMaterialGUID(
    int materialId
)
member GetMaterialGUID :
        materialId : int -> Guid

Parameters

materialId Int32
The material identifier.

Return Value

Guid
The material GUID. Returns empty GUID if not found.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetMaterialName Method

FabricationConfigurationGetMaterialName Method

Gets material name from its identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetMaterialName(
    int materialId
)
Public Function GetMaterialName (
    materialId As Integer
) As String
public:
String^ GetMaterialName(
    int materialId
)
member GetMaterialName :
        materialId : int -> string

Parameters

materialId Int32
The material identifier.

Return Value

String
The material name without the group.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetPartCustomDataName Method

FabricationConfigurationGetPartCustomDataName Method

Gets the custom data name from its identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetPartCustomDataName(
    int customDataId
)
Public Function GetPartCustomDataName (
    customDataId As Integer
) As String
public:
String^ GetPartCustomDataName(
    int customDataId
)
member GetPartCustomDataName :
        customDataId : int -> string

Parameters

customDataId Int32
The custom data identifier.

Return Value

String
The custom data name.
Exceptions
Exception | Condition
ArgumentException | The custom data does not exist.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetPartCustomDataType Method

FabricationConfigurationGetPartCustomDataType Method

Gets the custom data type from its identifier. See FabricationCustomDataType enumerator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FabricationCustomDataType GetPartCustomDataType(
    int customDataId
)
Public Function GetPartCustomDataType (
    customDataId As Integer
) As FabricationCustomDataType
public:
FabricationCustomDataType GetPartCustomDataType(
    int customDataId
)
member GetPartCustomDataType :
        customDataId : int -> FabricationCustomDataType

Parameters

customDataId Int32
The custom data identifier.

Return Value

FabricationCustomDataType
The custom data type.
Exceptions
Exception | Condition
ArgumentException | The custom data does not exist.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetPartStatusDescription Method

FabricationConfigurationGetPartStatusDescription Method

Gets the status description from its identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetPartStatusDescription(
    int statusId
)
Public Function GetPartStatusDescription (
    statusId As Integer
) As String
public:
String^ GetPartStatusDescription(
    int statusId
)
member GetPartStatusDescription :
        statusId : int -> string

Parameters

statusId Int32
The status identifier.

Return Value

String
The status description.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetProfile Method

FabricationConfigurationGetProfile Method

Return the profile of the loaded fabrication configuration. Return empty string for global profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetProfile()
Public Function GetProfile As String
public:
String^ GetProfile()
member GetProfile : unit -> string

Return Value

String
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetService Method

FabricationConfigurationGetService Method

Get the service based on the service identifier from the fabrication configuration in the current document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FabricationService GetService(
    int serviceId
)
Public Function GetService (
    serviceId As Integer
) As FabricationService
public:
FabricationService^ GetService(
    int serviceId
)
member GetService :
        serviceId : int -> FabricationService

Parameters

serviceId Int32
The service identifier.

Return Value

FabricationService
The service based on the service identifier.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetServiceByGUID Method

FabricationConfigurationGetServiceByGUID Method

Gets the service identifier by its GUID.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetServiceByGUID(
    Guid serviceGUID
)
Public Function GetServiceByGUID (
    serviceGUID As Guid
) As Integer
public:
int GetServiceByGUID(
    Guid serviceGUID
)
member GetServiceByGUID :
        serviceGUID : Guid -> int

Parameters

serviceGUID Guid
The service GUID.

Return Value

Int32
The service identifier. Returns 0 if not found.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetServiceGUID Method

FabricationConfigurationGetServiceGUID Method

Gets the service GUID by its identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid GetServiceGUID(
    int serviceId
)
Public Function GetServiceGUID (
    serviceId As Integer
) As Guid
public:
Guid GetServiceGUID(
    int serviceId
)
member GetServiceGUID :
        serviceId : int -> Guid

Parameters

serviceId Int32
The service identifier.

Return Value

Guid
The service GUID. Returns empty GUID if not found.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetServiceTypeName Method

FabricationConfigurationGetServiceTypeName Method

Gets the service type name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetServiceTypeName(
    int serviceTypeId
)
Public Function GetServiceTypeName (
    serviceTypeId As Integer
) As String
public:
String^ GetServiceTypeName(
    int serviceTypeId
)
member GetServiceTypeName :
        serviceTypeId : int -> string

Parameters

serviceTypeId Int32
The service type identifier.

Return Value

String
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetSpecificationAbbreviation Method

FabricationConfigurationGetSpecificationAbbreviation Method

Gets specification abbreviation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetSpecificationAbbreviation(
    int specificationId
)
Public Function GetSpecificationAbbreviation (
    specificationId As Integer
) As String
public:
String^ GetSpecificationAbbreviation(
    int specificationId
)
member GetSpecificationAbbreviation :
        specificationId : int -> string

Parameters

specificationId Int32
The specification identifier.

Return Value

String
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetSpecificationByGUID Method

FabricationConfigurationGetSpecificationByGUID Method

Gets the specification identifier by its GUID.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetSpecificationByGUID(
    Guid specificationGUID
)
Public Function GetSpecificationByGUID (
    specificationGUID As Guid
) As Integer
public:
int GetSpecificationByGUID(
    Guid specificationGUID
)
member GetSpecificationByGUID :
        specificationGUID : Guid -> int

Parameters

specificationGUID Guid
The specification GUID.

Return Value

Int32
The specification identifier. Returns 0 if not found.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetSpecificationGroup Method

FabricationConfigurationGetSpecificationGroup Method

Gets the specification group from its identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetSpecificationGroup(
    int specId
)
Public Function GetSpecificationGroup (
    specId As Integer
) As String
public:
String^ GetSpecificationGroup(
    int specId
)
member GetSpecificationGroup :
        specId : int -> string

Parameters

specId Int32
The specification identifier.

Return Value

String
The specification group.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetSpecificationGUID Method

FabricationConfigurationGetSpecificationGUID Method

Gets the specification GUID by its identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid GetSpecificationGUID(
    int specificationId
)
Public Function GetSpecificationGUID (
    specificationId As Integer
) As Guid
public:
Guid GetSpecificationGUID(
    int specificationId
)
member GetSpecificationGUID :
        specificationId : int -> Guid

Parameters

specificationId Int32
The specification identifier.

Return Value

Guid
The specification GUID. Returns empty GUID if not found.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetSpecificationName Method

FabricationConfigurationGetSpecificationName Method

Gets the specification name from its identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetSpecificationName(
    int specId
)
Public Function GetSpecificationName (
    specId As Integer
) As String
public:
String^ GetSpecificationName(
    int specId
)
member GetSpecificationName :
        specId : int -> string

Parameters

specId Int32
The specification identifier.

Return Value

String
The specification name;
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.GetUpdatedStraightsFromValidateConnections Method

FabricationConfigurationGetUpdatedStraightsFromValidateConnections Method

Get the set of element identifiers of fabrication part straights that were previously updated. If there were no straights were updated it will return an empty set of element identifiers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ISet<ElementId> GetUpdatedStraightsFromValidateConnections()
Public Function GetUpdatedStraightsFromValidateConnections As ISet(Of ElementId)
public:
ISet<ElementId^>^ GetUpdatedStraightsFromValidateConnections()
member GetUpdatedStraightsFromValidateConnections : unit -> ISet<ElementId>

Return Value

ISet ElementId
Returns the set of element identifiers of fabrication part straights that were updated.
Remarks
The set of element identifiers were created by calling ValidateConnectionsForAllFabricationParts with the option updateGapForStraights set to true.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.HasValidConfiguration Method

FabricationConfigurationHasValidConfiguration Method

Checks whether a valid fabrication configuration has been set for the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasValidConfiguration()
Public Function HasValidConfiguration As Boolean
public:
bool HasValidConfiguration()
member HasValidConfiguration : unit -> bool

Return Value

Boolean
True if a valid fabrication configuration has been set for the project.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.IsAncillaryKit Method

FabricationConfigurationIsAncillaryKit Method

Gets whether the specified fabrication ancillary identifier is an ancillary kit or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsAncillaryKit(
    int ancillaryId
)
Public Function IsAncillaryKit (
    ancillaryId As Integer
) As Boolean
public:
bool IsAncillaryKit(
    int ancillaryId
)
member IsAncillaryKit :
        ancillaryId : int -> bool

Parameters

ancillaryId Int32
The fabrication ancillary database identifier of the ancillary.

Return Value

Boolean
Returns true if the ancillary is a kit.
Exceptions
Exception | Condition
ArgumentException | The ancillary does not exist.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.LoadItemFiles Method

FabricationConfigurationLoadItemFiles Method

Loads the specified fabrication item files into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<FabricationItemFile> LoadItemFiles(
    IList<FabricationItemFile> itemFiles
)
Public Function LoadItemFiles (
    itemFiles As IList(Of FabricationItemFile)
) As IList(Of FabricationItemFile)
public:
IList<FabricationItemFile^>^ LoadItemFiles(
    IList<FabricationItemFile^>^ itemFiles
)
member LoadItemFiles :
        itemFiles : IList<FabricationItemFile> -> IList<FabricationItemFile>

Parameters

itemFiles IList FabricationItemFile
The relative paths of the fabrication item files to load.

Return Value

IList FabricationItemFile
The relative paths of the fabrication item files which failed to load.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The current fabrication configuration is not connected and updated to source configuration. Reload and try again. -or- this operation failed.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.LoadServices Method

FabricationConfigurationLoadServices Method

Loads the specified fabrication services into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<int> LoadServices(
    IList<int> serviceIds
)
Public Function LoadServices (
    serviceIds As IList(Of Integer)
) As IList(Of Integer)
public:
IList<int>^ LoadServices(
    IList<int>^ serviceIds
)
member LoadServices :
        serviceIds : IList<int> -> IList<int>

Parameters

serviceIds IList Int32
The identifiers of the fabrication services to load.

Return Value

IList Int32
The identifiers of the fabrication services which failed to load.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The current fabrication configuration is not connected and updated to source configuration. Reload and try again. -or- this operation failed.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.LocateFabricationConnector Method

FabricationConfigurationLocateFabricationConnector Method

Gets the fabrication connector identifiers by group and name, filtered by shape and domain.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int LocateFabricationConnector(
    string group,
    string name,
    ConnectorDomainType domain,
    ConnectorProfileType shape
)
Public Function LocateFabricationConnector (
    group As String,
    name As String,
    domain As ConnectorDomainType,
    shape As ConnectorProfileType
) As Integer
public:
int LocateFabricationConnector(
    String^ group,
    String^ name,
    ConnectorDomainType domain,
    ConnectorProfileType shape
)
member LocateFabricationConnector :
        group : string *
        name : string *
        domain : ConnectorDomainType *
        shape : ConnectorProfileType -> int

Parameters

group String
The fabrication connector group.
name String
The fabrication connector name.
domain ConnectorDomainType
ConnectorDomainType to filter by. Pass ConnectorDomainType::Undefined to get all connector domains.
shape ConnectorProfileType
ConnectorProfileType to filter by. Pass ConnectorProfileType::Invalid to get all shapes.

Return Value

Int32
Return the fabrication connector identifier. Returns -1 if not found.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.LocateInsulationSpecification Method

FabricationConfigurationLocateInsulationSpecification Method

Gets the insulation specification by group and name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int LocateInsulationSpecification(
    string group,
    string name
)
Public Function LocateInsulationSpecification (
    group As String,
    name As String
) As Integer
public:
int LocateInsulationSpecification(
    String^ group,
    String^ name
)
member LocateInsulationSpecification :
        group : string *
        name : string -> int

Parameters

group String
The insulation specification group.
name String
The insulation specification name.

Return Value

Int32
The insulation specification identifier. Returns -1 if not found.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.LocateMaterial Method

FabricationConfigurationLocateMaterial Method

Gets material by group and name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int LocateMaterial(
    string group,
    string name
)
Public Function LocateMaterial (
    group As String,
    name As String
) As Integer
public:
int LocateMaterial(
    String^ group,
    String^ name
)
member LocateMaterial :
        group : string *
        name : string -> int

Parameters

group String
The material group.
name String
The group name.

Return Value

Int32
The material identifier. Returns -1 if not found.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.LocateSpecification Method

FabricationConfigurationLocateSpecification Method

Gets the specification identifier by group and name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int LocateSpecification(
    string group,
    string name
)
Public Function LocateSpecification (
    group As String,
    name As String
) As Integer
public:
int LocateSpecification(
    String^ group,
    String^ name
)
member LocateSpecification :
        group : string *
        name : string -> int

Parameters

group String
The specification group.
name String
The specification name.

Return Value

Int32
The specification identifier. Returns -1 if not found.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.PostReviewableWarningsForBadConnections Method

FabricationConfigurationPostReviewableWarningsForBadConnections Method

Reviewable warnings are created for all entries contained in the connection validation information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void PostReviewableWarningsForBadConnections(
    ConnectionValidationInfo info
)
Public Sub PostReviewableWarningsForBadConnections (
    info As ConnectionValidationInfo
)
public:
void PostReviewableWarningsForBadConnections(
    ConnectionValidationInfo^ info
)
member PostReviewableWarningsForBadConnections :
        info : ConnectionValidationInfo -> unit

Parameters

info ConnectionValidationInfo
The connection information created from the connection validation check.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | this operation failed.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.ReloadConfiguration Method

FabricationConfigurationReloadConfiguration Method

Reloads the fabrication configuration from its source fabrication configuration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConfigurationReloadInfo ReloadConfiguration()
Public Function ReloadConfiguration As ConfigurationReloadInfo
public:
ConfigurationReloadInfo^ ReloadConfiguration()
member ReloadConfiguration : unit -> ConfigurationReloadInfo

Return Value

ConfigurationReloadInfo
The information about the reload of the fabrication configuration.
Exceptions
Exception | Condition
InvalidOperationException | The fabrication configuration is not set yet. -or- The source fabrication configuration could not be found. -or- this operation failed.
Remarks
The configuration must be reloaded from its source fabrication configuration before loading new fabrication services or additional parts.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.SetConfiguration Method

FabricationConfigurationSetConfiguration Method

Overload List
 | Name | Description
Public method | SetConfiguration(FabricationConfigurationInfo) | Set the fabrication configuration with global profile.
Public method | SetConfiguration(FabricationConfigurationInfo, String) | Set the fabrication configuration with specific profile.
Top
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.SetConfiguration(FabricationConfigurationInfo) Method

FabricationConfigurationSetConfiguration(FabricationConfigurationInfo) Method

Set the fabrication configuration with global profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetConfiguration(
    FabricationConfigurationInfo fabricationConfigurationInfo
)
Public Sub SetConfiguration (
    fabricationConfigurationInfo As FabricationConfigurationInfo
)
public:
void SetConfiguration(
    FabricationConfigurationInfo^ fabricationConfigurationInfo
)
member SetConfiguration :
        fabricationConfigurationInfo : FabricationConfigurationInfo -> unit

Parameters

fabricationConfigurationInfo FabricationConfigurationInfo
The desired fabrication configuration.
Exceptions
Exception | Condition
InvalidOperationException | The fabrication configuration cannot be swapped because the exiting fabrication configuration has already been used in the document. -or- Cannot set the configuration.
See Also

Reference

FabricationConfiguration Class
SetConfiguration Overload


FabricationConfiguration.SetConfiguration(FabricationConfigurationInfo, String) Method

FabricationConfigurationSetConfiguration(FabricationConfigurationInfo, String) Method

Set the fabrication configuration with specific profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetConfiguration(
    FabricationConfigurationInfo fabricationConfigurationInfo,
    string profile
)
Public Sub SetConfiguration (
    fabricationConfigurationInfo As FabricationConfigurationInfo,
    profile As String
)
public:
void SetConfiguration(
    FabricationConfigurationInfo^ fabricationConfigurationInfo,
    String^ profile
)
member SetConfiguration :
        fabricationConfigurationInfo : FabricationConfigurationInfo *
        profile : string -> unit

Parameters

fabricationConfigurationInfo FabricationConfigurationInfo
The desired fabrication configuration.
profile String
The desired profile of the fabrication configuration. Use empty string for the global profile.
Exceptions
Exception | Condition
ArgumentException | The profile "profile" is invalid.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The fabrication configuration cannot be swapped because the exiting fabrication configuration has already been used in the document. -or- Cannot set the configuration.
See Also

Reference

FabricationConfiguration Class
SetConfiguration Overload


FabricationConfiguration.SetServicesToLoad Method

FabricationConfigurationSetServicesToLoad Method

Sets the services which are to be loaded or not next time reloadConfiguration is called. If a service is not included but is currently loaded then it will be unloaded then.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SetServicesToLoad(
    IList<int> serviceIds
)
Public Function SetServicesToLoad (
    serviceIds As IList(Of Integer)
) As Boolean
public:
bool SetServicesToLoad(
    IList<int>^ serviceIds
)
member SetServicesToLoad :
        serviceIds : IList<int> -> bool

Parameters

serviceIds IList Int32

Return Value

Boolean
Returns true if successful. May fail if any service currently loaded is not included and is in use so cannot be unloaded.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.UnloadItemFiles Method

FabricationConfigurationUnloadItemFiles Method

Unload the specified fabrication item files from the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void UnloadItemFiles(
    IList<FabricationItemFile> itemFiles
)
Public Sub UnloadItemFiles (
    itemFiles As IList(Of FabricationItemFile)
)
public:
void UnloadItemFiles(
    IList<FabricationItemFile^>^ itemFiles
)
member UnloadItemFiles :
        itemFiles : IList<FabricationItemFile> -> unit

Parameters

itemFiles IList FabricationItemFile
The fabrication item files to unload.
Exceptions
Exception | Condition
ArgumentException | Fabrication item files can not be unloaded if they are currently in use. -or- Some fabrication item files have not been loaded.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The current fabrication configuration is not connected and updated to source configuration. Reload and try again.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.UnloadServices Method

FabricationConfigurationUnloadServices Method

Unload the specified fabrication services from the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void UnloadServices(
    IList<int> serviceIds
)
Public Sub UnloadServices (
    serviceIds As IList(Of Integer)
)
public:
void UnloadServices(
    IList<int>^ serviceIds
)
member UnloadServices :
        serviceIds : IList<int> -> unit

Parameters

serviceIds IList Int32
The identifiers of the fabrication services to unload.
Exceptions
Exception | Condition
ArgumentException | Fabrication services can not be unloaded if they are in use currently. -or- Some services are not loaded yet.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The current fabrication configuration is not connected and updated to source configuration. Reload and try again.
See Also

Reference

FabricationConfiguration Class


FabricationConfiguration.ValidateConnectionsForAllFabricationParts Method

FabricationConfigurationValidateConnectionsForAllFabricationParts Method

Validates all fabrication part connections in the current project. Invalid connections found will be added to the connection validation information class. The validation checks for bad alignments or gaps, incompatible connection types, mismatches of size, mismatches of shapes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConnectionValidationInfo ValidateConnectionsForAllFabricationParts(
    bool updateGapForStraights
)
Public Function ValidateConnectionsForAllFabricationParts (
    updateGapForStraights As Boolean
) As ConnectionValidationInfo
public:
ConnectionValidationInfo^ ValidateConnectionsForAllFabricationParts(
    bool updateGapForStraights
)
member ValidateConnectionsForAllFabricationParts :
        updateGapForStraights : bool -> ConnectionValidationInfo

Parameters

updateGapForStraights Boolean
Attempt to update straights to remove the gap between the connctors.

Return Value

ConnectionValidationInfo
The information about the validation check.
Exceptions
Exception | Condition
InvalidOperationException | this operation failed.
Remarks
If set to update straights any updated straights will be added to a set of element identifiers. Call GetUpdatedStraightsFromValidateConnections to get the set of element identifiers for the updated straights.
See Also

Reference

FabricationConfiguration Class


FabricationConfigurationInfo Class

Represents an MEP object that holds the properties of an MEP fabrication configuration.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFabricationConfigurationInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FabricationConfigurationInfo : IDisposable
Public Class FabricationConfigurationInfo
    Implements IDisposable
public ref class FabricationConfigurationInfo : IDisposable
type FabricationConfigurationInfo =
    class
        interface IDisposable
    end

The FabricationConfigurationInfo type exposes the following members.

Properties
 | Name | Description
Public property | CloudId | The identifier of the cloud configuration.
Public property | Description | The description of the fabrication configuration.
Public property | GUID | The unique identification of the fabrication configuration.
Public property | IsCloudConfiguration | Whether the cloud configuration is a remote cloud one.
Public property | IsLocked | Checks whether the fabrication configuration is locked. If true, the configuration is locked and cannot be removed.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The name of the fabrication configuration.
Public property | Path | The path where the fabrication configuration is located. To populate this property, you may need to call FindSourceFabricationConfiguration first.
Public property | UnitSystem | The unit system of the fabrication configuration. Units can be UnitSystem.Metric or UnitSystem.Imperial.
Public property | Version | The version of the fabrication configuration.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the FabricationConfigurationInfo
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | FindSourceFabricationConfiguration | Finds the source fabrication configuration on disk which matches the input fabrication configuration.
 | GetAllFabricationConfigurations | Gets all added fabrication configurations.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetProfiles | Return the profiles in the fabrication configuration.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsValid | Checks if the fabrication configuration is valid.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
To populate the Path property, you may need to call FindSourceFabricationConfiguration first.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FabricationConfigurationInfo Properties

The FabricationConfigurationInfo type exposes the following members.

Properties
 | Name | Description
Public property | CloudId | The identifier of the cloud configuration.
Public property | Description | The description of the fabrication configuration.
Public property | GUID | The unique identification of the fabrication configuration.
Public property | IsCloudConfiguration | Whether the cloud configuration is a remote cloud one.
Public property | IsLocked | Checks whether the fabrication configuration is locked. If true, the configuration is locked and cannot be removed.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The name of the fabrication configuration.
Public property | Path | The path where the fabrication configuration is located. To populate this property, you may need to call FindSourceFabricationConfiguration first.
Public property | UnitSystem | The unit system of the fabrication configuration. Units can be UnitSystem.Metric or UnitSystem.Imperial.
Public property | Version | The version of the fabrication configuration.
Top
See Also

Reference

FabricationConfigurationInfo Class


FabricationConfigurationInfo.CloudId Property

FabricationConfigurationInfoCloudId Property

The identifier of the cloud configuration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string CloudId { get; }
Public ReadOnly Property CloudId As String
    Get
public:
property String^ CloudId {
    String^ get ();
}
member CloudId : string with get

Property Value

String
See Also

Reference

FabricationConfigurationInfo Class


FabricationConfigurationInfo.Description Property

FabricationConfigurationInfoDescription Property

The description of the fabrication configuration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get
public:
property String^ Description {
    String^ get ();
}
member Description : string with get

Property Value

String
See Also

Reference

FabricationConfigurationInfo Class


FabricationConfigurationInfo.GUID Property

FabricationConfigurationInfoGUID Property

The unique identification of the fabrication configuration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid GUID { get; }
Public ReadOnly Property GUID As Guid
    Get
public:
property Guid GUID {
    Guid get ();
}
member GUID : Guid with get

Property Value

Guid
See Also

Reference

FabricationConfigurationInfo Class


FabricationConfigurationInfo.IsCloudConfiguration Property

FabricationConfigurationInfoIsCloudConfiguration Property

Whether the cloud configuration is a remote cloud one.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCloudConfiguration { get; }
Public ReadOnly Property IsCloudConfiguration As Boolean
    Get
public:
property bool IsCloudConfiguration {
    bool get ();
}
member IsCloudConfiguration : bool with get

Property Value

Boolean
See Also

Reference

FabricationConfigurationInfo Class


FabricationConfigurationInfo.IsLocked Property

FabricationConfigurationInfoIsLocked Property

Checks whether the fabrication configuration is locked. If true, the configuration is locked and cannot be removed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsLocked { get; }
Public ReadOnly Property IsLocked As Boolean
    Get
public:
property bool IsLocked {
    bool get ();
}
member IsLocked : bool with get

Property Value

Boolean
See Also

Reference

FabricationConfigurationInfo Class


FabricationConfigurationInfo.IsValidObject Property

FabricationConfigurationInfoIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

FabricationConfigurationInfo Class


FabricationConfigurationInfo.Name Property

FabricationConfigurationInfoName Property

The name of the fabrication configuration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

String
See Also

Reference

FabricationConfigurationInfo Class


FabricationConfigurationInfo.Path Property

FabricationConfigurationInfoPath Property

The path where the fabrication configuration is located. To populate this property, you may need to call FindSourceFabricationConfiguration first.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Path { get; }
Public ReadOnly Property Path As String
    Get
public:
property String^ Path {
    String^ get ();
}
member Path : string with get

Property Value

String
See Also

Reference

FabricationConfigurationInfo Class


FabricationConfigurationInfo.UnitSystem Property

FabricationConfigurationInfoUnitSystem Property

The unit system of the fabrication configuration. Units can be UnitSystem.Metric or UnitSystem.Imperial.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public UnitSystem UnitSystem { get; }
Public ReadOnly Property UnitSystem As UnitSystem
    Get
public:
property UnitSystem UnitSystem {
    UnitSystem get ();
}
member UnitSystem : UnitSystem with get

Property Value

UnitSystem
See Also

Reference

FabricationConfigurationInfo Class


FabricationConfigurationInfo.Version Property

FabricationConfigurationInfoVersion Property

The version of the fabrication configuration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Version { get; }
Public ReadOnly Property Version As Double
    Get
public:
property double Version {
    double get ();
}
member Version : float with get

Property Value

Double
See Also

Reference

FabricationConfigurationInfo Class


FabricationConfigurationInfo Methods

The FabricationConfigurationInfo type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | FindSourceFabricationConfiguration | Finds the source fabrication configuration on disk which matches the input fabrication configuration.
 | GetAllFabricationConfigurations | Gets all added fabrication configurations.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetProfiles | Return the profiles in the fabrication configuration.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsValid | Checks if the fabrication configuration is valid.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FabricationConfigurationInfo Class


FabricationConfigurationInfo.Dispose Method

FabricationConfigurationInfoDispose Method

Releases all resources used by the FabricationConfigurationInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FabricationConfigurationInfo Class


FabricationConfigurationInfo.FindSourceFabricationConfiguration Method

FabricationConfigurationInfoFindSourceFabricationConfiguration Method

Finds the source fabrication configuration on disk which matches the input fabrication configuration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FabricationConfigurationInfo FindSourceFabricationConfiguration(
    FabricationConfigurationInfo fabricationConfiguration
)
Public Shared Function FindSourceFabricationConfiguration (
    fabricationConfiguration As FabricationConfigurationInfo
) As FabricationConfigurationInfo
public:
static FabricationConfigurationInfo^ FindSourceFabricationConfiguration(
    FabricationConfigurationInfo^ fabricationConfiguration
)
static member FindSourceFabricationConfiguration :
        fabricationConfiguration : FabricationConfigurationInfo -> FabricationConfigurationInfo

Parameters

fabricationConfiguration FabricationConfigurationInfo
The fabrication configuration to match.

Return Value

FabricationConfigurationInfo
The matching source fabrication configuration.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Fabrication configuration is matched by configuration GUID and version. The GUIDs are required to be the same. For version, we first try to match the version exactly. If Revit cannot find an exact match, then it looks for the closest version later than the input configuration, then the closest earlier version.
See Also

Reference

FabricationConfigurationInfo Class


FabricationConfigurationInfo.GetAllFabricationConfigurations Method

FabricationConfigurationInfoGetAllFabricationConfigurations Method

Gets all added fabrication configurations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<FabricationConfigurationInfo> GetAllFabricationConfigurations()
Public Shared Function GetAllFabricationConfigurations As IList(Of FabricationConfigurationInfo)
public:
static IList<FabricationConfigurationInfo^>^ GetAllFabricationConfigurations()
static member GetAllFabricationConfigurations : unit -> IList<FabricationConfigurationInfo>

Return Value

IList FabricationConfigurationInfo
All added fabrication configurations.
See Also

Reference

FabricationConfigurationInfo Class


FabricationConfigurationInfo.GetProfiles Method

FabricationConfigurationInfoGetProfiles Method

Return the profiles in the fabrication configuration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<string> GetProfiles()
Public Function GetProfiles As IList(Of String)
public:
IList<String^>^ GetProfiles()
member GetProfiles : unit -> IList<string>

Return Value

IList String
Remarks
The global profile name is empty, and is not returned here.
See Also

Reference

FabricationConfigurationInfo Class


FabricationConfigurationInfo.IsValid Method

FabricationConfigurationInfoIsValid Method

Checks if the fabrication configuration is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValid()
Public Function IsValid As Boolean
public:
bool IsValid()
member IsValid : unit -> bool

Return Value

Boolean
True if the fabrication configuration is valid.
See Also

Reference

FabricationConfigurationInfo Class


FabricationConnectorInfo Class

Fabrication connector information.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFabricationConnectorInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FabricationConnectorInfo : IDisposable
Public Class FabricationConnectorInfo
    Implements IDisposable
public ref class FabricationConnectorInfo : IDisposable
type FabricationConnectorInfo =
    class
        interface IDisposable
    end

The FabricationConnectorInfo type exposes the following members.

Properties
 | Name | Description
Public property | BodyConnectorId | Fabrication body connector Id.
Public property | DoubleWallConnectorId | Fabrication double wall connector Id.
Public property | FabricationIndex | The index of the connector shown within the fabrication software.
Public property | IsBodyConnectorLocked | Fabrication body connector lock.
Public property | IsDoubleWallConnectorLocked | Fabrication double wall connector lock.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the FabricationConnectorInfo
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HasDoubleWallConnector | Checks if there are any double wall connectors fabricated.
Public method | IsValid | Checks if the connector has fabrication parameters associated with it that can be set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FabricationConnectorInfo Properties

The FabricationConnectorInfo type exposes the following members.

Properties
 | Name | Description
Public property | BodyConnectorId | Fabrication body connector Id.
Public property | DoubleWallConnectorId | Fabrication double wall connector Id.
Public property | FabricationIndex | The index of the connector shown within the fabrication software.
Public property | IsBodyConnectorLocked | Fabrication body connector lock.
Public property | IsDoubleWallConnectorLocked | Fabrication double wall connector lock.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

FabricationConnectorInfo Class


FabricationConnectorInfo.BodyConnectorId Property

FabricationConnectorInfoBodyConnectorId Property

Fabrication body connector Id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int BodyConnectorId { get; set; }
Public Property BodyConnectorId As Integer
    Get
    Set
public:
property int BodyConnectorId {
    int get ();
    void set (int value);
}
member BodyConnectorId : int with get, set

Property Value

Int32
Exceptions
Exception | Condition
ArgumentException | When setting this property: bodyConnectorId is invalid based on the shape and domain.
InvalidOperationException | When setting this property: the connector cannot be modified on an owned fabrication part. -or- When setting this property: the connector is already connected. -or- When setting this property: the fabrication part is connected to more than one item.
Remarks
A reference to the fabrication configuration connectors. Setting the connector value will also set the connector lock. A value of 0 indicates the connector is set to none.
See Also

Reference

FabricationConnectorInfo Class


FabricationConnectorInfo.DoubleWallConnectorId Property

FabricationConnectorInfoDoubleWallConnectorId Property

Fabrication double wall connector Id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int DoubleWallConnectorId { get; set; }
Public Property DoubleWallConnectorId As Integer
    Get
    Set
public:
property int DoubleWallConnectorId {
    int get ();
    void set (int value);
}
member DoubleWallConnectorId : int with get, set

Property Value

Int32
Exceptions
Exception | Condition
ArgumentException | When setting this property: doubleWallConnectorId is invalid based on the shape and domain.
InvalidOperationException | No double wall connector available. -or- When setting this property: the connector cannot be modified on an owned fabrication part. -or- When setting this property: the connector is already connected. -or- When setting this property: the fabrication part is connected to more than one item.
Remarks
A reference to the fabrication configuration connectors. Setting the connector value will also set the connector lock. A value of 0 indicates no connector.
See Also

Reference

FabricationConnectorInfo Class


FabricationConnectorInfo.FabricationIndex Property

FabricationConnectorInfoFabricationIndex Property

The index of the connector shown within the fabrication software.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int FabricationIndex { get; }
Public ReadOnly Property FabricationIndex As Integer
    Get
public:
property int FabricationIndex {
    int get ();
}
member FabricationIndex : int with get

Property Value

Int32
See Also

Reference

FabricationConnectorInfo Class


FabricationConnectorInfo.IsBodyConnectorLocked Property

FabricationConnectorInfoIsBodyConnectorLocked Property

Fabrication body connector lock.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsBodyConnectorLocked { get; set; }
Public Property IsBodyConnectorLocked As Boolean
    Get
    Set
public:
property bool IsBodyConnectorLocked {
    bool get ();
    void set (bool value);
}
member IsBodyConnectorLocked : bool with get, set

Property Value

Boolean
Exceptions
Exception | Condition
InvalidOperationException | When setting this property: the connector cannot be modified on an owned fabrication part. -or- When setting this property: the connector is already connected. -or- When setting this property: the fabrication part is connected to more than one item.
Remarks
If set this prevents the connector value being overridden by the fabrication specification.
See Also

Reference

FabricationConnectorInfo Class


FabricationConnectorInfo.IsDoubleWallConnectorLocked Property

FabricationConnectorInfoIsDoubleWallConnectorLocked Property

Fabrication double wall connector lock.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsDoubleWallConnectorLocked { get; set; }
Public Property IsDoubleWallConnectorLocked As Boolean
    Get
    Set
public:
property bool IsDoubleWallConnectorLocked {
    bool get ();
    void set (bool value);
}
member IsDoubleWallConnectorLocked : bool with get, set

Property Value

Boolean
Exceptions
Exception | Condition
InvalidOperationException | No double wall connector available. -or- When setting this property: the connector cannot be modified on an owned fabrication part. -or- When setting this property: the connector is already connected. -or- When setting this property: the fabrication part is connected to more than one item.
Remarks
If set this prevents the connector value being overridden by the fabrication specification.
See Also

Reference

FabricationConnectorInfo Class


FabricationConnectorInfo.IsValidObject Property

FabricationConnectorInfoIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

FabricationConnectorInfo Class


FabricationConnectorInfo Methods

The FabricationConnectorInfo type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HasDoubleWallConnector | Checks if there are any double wall connectors fabricated.
Public method | IsValid | Checks if the connector has fabrication parameters associated with it that can be set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FabricationConnectorInfo Class


FabricationConnectorInfo.Dispose Method

FabricationConnectorInfoDispose Method

Releases all resources used by the FabricationConnectorInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FabricationConnectorInfo Class


FabricationConnectorInfo.HasDoubleWallConnector Method

FabricationConnectorInfoHasDoubleWallConnector Method

Checks if there are any double wall connectors fabricated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasDoubleWallConnector()
Public Function HasDoubleWallConnector As Boolean
public:
bool HasDoubleWallConnector()
member HasDoubleWallConnector : unit -> bool

Return Value

Boolean
True if there are any double wall connectors fabricated.
See Also

Reference

FabricationConnectorInfo Class


FabricationConnectorInfo.IsValid Method

FabricationConnectorInfoIsValid Method

Checks if the connector has fabrication parameters associated with it that can be set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValid()
Public Function IsValid As Boolean
public:
bool IsValid()
member IsValid : unit -> bool

Return Value

Boolean
True if the connector has fabrication parameters associated with it that can be set.
See Also

Reference

FabricationConnectorInfo Class


FabricationDimensionDefinition Class

Represents the definition of a single fabrication pattern dimension. Together all dimensions represent the parametric definition of the fabrication part.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFabricationDimensionDefinition

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FabricationDimensionDefinition : IDisposable
Public Class FabricationDimensionDefinition
    Implements IDisposable
public ref class FabricationDimensionDefinition : IDisposable
type FabricationDimensionDefinition =
    class
        interface IDisposable
    end

The FabricationDimensionDefinition type exposes the following members.

Properties
 | Name | Description
Public property | IsModifiable | If the fabrication dimension is modifiable by user.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | Fabrication dimension name.
Public property | Type | Fabrication dimension type.
Public property | UnitType | Fabrication dimension unit type.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the FabricationDimensionDefinition
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FabricationDimensionDefinition Properties

The FabricationDimensionDefinition type exposes the following members.

Properties
 | Name | Description
Public property | IsModifiable | If the fabrication dimension is modifiable by user.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | Fabrication dimension name.
Public property | Type | Fabrication dimension type.
Public property | UnitType | Fabrication dimension unit type.
Top
See Also

Reference

FabricationDimensionDefinition Class


FabricationDimensionDefinition.IsModifiable Property

FabricationDimensionDefinitionIsModifiable Property

If the fabrication dimension is modifiable by user.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsModifiable { get; }
Public ReadOnly Property IsModifiable As Boolean
    Get
public:
property bool IsModifiable {
    bool get ();
}
member IsModifiable : bool with get

Property Value

Boolean
See Also

Reference

FabricationDimensionDefinition Class


FabricationDimensionDefinition.IsValidObject Property

FabricationDimensionDefinitionIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

FabricationDimensionDefinition Class


FabricationDimensionDefinition.Name Property

FabricationDimensionDefinitionName Property

Fabrication dimension name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

String
See Also

Reference

FabricationDimensionDefinition Class


FabricationDimensionDefinition.Type Property

FabricationDimensionDefinitionType Property

Fabrication dimension type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FabricationDimensionType Type { get; }
Public ReadOnly Property Type As FabricationDimensionType
    Get
public:
property FabricationDimensionType Type {
    FabricationDimensionType get ();
}
member Type : FabricationDimensionType with get

Property Value

FabricationDimensionType
See Also

Reference

FabricationDimensionDefinition Class


FabricationDimensionDefinition.UnitType Property

FabricationDimensionDefinitionUnitType Property

Fabrication dimension unit type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FabricationDimensionUnitType UnitType { get; }
Public ReadOnly Property UnitType As FabricationDimensionUnitType
    Get
public:
property FabricationDimensionUnitType UnitType {
    FabricationDimensionUnitType get ();
}
member UnitType : FabricationDimensionUnitType with get

Property Value

FabricationDimensionUnitType
See Also

Reference

FabricationDimensionDefinition Class


FabricationDimensionDefinition Methods

The FabricationDimensionDefinition type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FabricationDimensionDefinition Class


FabricationDimensionDefinition.Dispose Method

FabricationDimensionDefinitionDispose Method

Releases all resources used by the FabricationDimensionDefinition

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FabricationDimensionDefinition Class


FabricationDimensionType Enumeration

Fabrication dimension type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum FabricationDimensionType
Public Enumeration FabricationDimensionType
public enum class FabricationDimensionType
type FabricationDimensionType
Members
Member name | Value | Description
Internal | 0 | Internal.
Width | 1 | Width.
Depth | 2 | Depth.
Diameter | 3 | Diameter.
Angle | 4 | Angle.
Length | 5 | Length.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FabricationDimensionUnitType Enumeration

Fabrication dimension unit type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum FabricationDimensionUnitType
Public Enumeration FabricationDimensionUnitType
public enum class FabricationDimensionUnitType
type FabricationDimensionUnitType
Members
Member name | Value | Description
NoUnits | 0 | NoUnits.
Linear | 1 | Linear.
Angular | 2 | Angular.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FabricationHostedInfo Class

The fabrication hosted element information.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFabricationHostedInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FabricationHostedInfo : IDisposable
Public Class FabricationHostedInfo
    Implements IDisposable
public ref class FabricationHostedInfo : IDisposable
type FabricationHostedInfo =
    class
        interface IDisposable
    end

The FabricationHostedInfo type exposes the following members.

Properties
 | Name | Description
Public property | HostId | Returns the identifier of the host.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | DisconnectFromHost | Disconnects the part from the host.
Public method | Dispose | Releases all resources used by the FabricationHostedInfo
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBearerCenterline | Gets the centerline of the bearer. The method is applicable only for bearer hanger.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PlaceOnHost(ElementId, Connector, Double) | Places the part on the specified host.
Public method | PlaceOnHost(ElementId, Connector, Double, Double) | Places the part on the specified host.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
A fabrication part may have a host, the FabricationHostedInfo stores the host information for the fabrication part.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FabricationHostedInfo Properties

The FabricationHostedInfo type exposes the following members.

Properties
 | Name | Description
Public property | HostId | Returns the identifier of the host.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

FabricationHostedInfo Class


FabricationHostedInfo.HostId Property

FabricationHostedInfoHostId Property

Returns the identifier of the host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId HostId { get; }
Public ReadOnly Property HostId As ElementId
    Get
public:
property ElementId^ HostId {
    ElementId^ get ();
}
member HostId : ElementId with get

Property Value

ElementId
See Also

Reference

FabricationHostedInfo Class


FabricationHostedInfo.IsValidObject Property

FabricationHostedInfoIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

FabricationHostedInfo Class


FabricationHostedInfo Methods

The FabricationHostedInfo type exposes the following members.

Methods
 | Name | Description
Public method | DisconnectFromHost | Disconnects the part from the host.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBearerCenterline | Gets the centerline of the bearer. The method is applicable only for bearer hanger.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PlaceOnHost(ElementId, Connector, Double) | Places the part on the specified host.
Public method | PlaceOnHost(ElementId, Connector, Double, Double) | Places the part on the specified host.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FabricationHostedInfo Class


FabricationHostedInfo.DisconnectFromHost Method

FabricationHostedInfoDisconnectFromHost Method

Disconnects the part from the host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void DisconnectFromHost()
Public Sub DisconnectFromHost
public:
void DisconnectFromHost()
member DisconnectFromHost : unit -> unit
See Also

Reference

FabricationHostedInfo Class


FabricationHostedInfo.Dispose Method

FabricationHostedInfoDispose Method

Releases all resources used by the FabricationHostedInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FabricationHostedInfo Class


FabricationHostedInfo.GetBearerCenterline Method

FabricationHostedInfoGetBearerCenterline Method

Gets the centerline of the bearer. The method is applicable only for bearer hanger.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Line GetBearerCenterline()
Public Function GetBearerCenterline As Line
public:
Line^ GetBearerCenterline()
member GetBearerCenterline : unit -> Line

Return Value

Line
The centerline of the bearer.
Exceptions
Exception | Condition
InvalidOperationException | The hanger is not a bearer hanger.
See Also

Reference

FabricationHostedInfo Class


FabricationHostedInfo.PlaceOnHost Method

FabricationHostedInfoPlaceOnHost Method

Overload List
 | Name | Description
Public method | PlaceOnHost(ElementId, Connector, Double) | Places the part on the specified host.
Public method | PlaceOnHost(ElementId, Connector, Double, Double) | Places the part on the specified host.
Top
See Also

Reference

FabricationHostedInfo Class


FabricationHostedInfo.PlaceOnHost(ElementId, Connector, Double) Method

FabricationHostedInfoPlaceOnHost(ElementId, Connector, Double) Method

Places the part on the specified host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void PlaceOnHost(
    ElementId hostId,
    Connector hostConnector,
    double distance
)
Public Sub PlaceOnHost (
    hostId As ElementId,
    hostConnector As Connector,
    distance As Double
)
public:
void PlaceOnHost(
    ElementId^ hostId,
    Connector^ hostConnector,
    double distance
)
member PlaceOnHost :
        hostId : ElementId *
        hostConnector : Connector *
        distance : float -> unit

Parameters

hostId ElementId
Identifier of the host fabrication part.
hostConnector Connector
The connector of the host.
distance Double
The distance from the connector to place the hosted part. Units are in feet (ft).
Exceptions
Exception | Condition
ArgumentException | Invalid fabrication part host. The host should be a straight fabrication part. -or- Invalid connector of fabrication part host. -or- The distance is out of range.
ArgumentNullException | A non-optional argument was null
Remarks
The document must be regenerated before the fabrication part can be used. Check ValidationStatus after regeneration to see if the part is valid for fabrication.
See Also

Reference

FabricationHostedInfo Class
PlaceOnHost Overload


FabricationHostedInfo.PlaceOnHost(ElementId, Connector, Double, Double) Method

FabricationHostedInfoPlaceOnHost(ElementId, Connector, Double, Double) Method

Places the part on the specified host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void PlaceOnHost(
    ElementId hostId,
    Connector hostConnector,
    double distance,
    double axisRotation
)
Public Sub PlaceOnHost (
    hostId As ElementId,
    hostConnector As Connector,
    distance As Double,
    axisRotation As Double
)
public:
void PlaceOnHost(
    ElementId^ hostId,
    Connector^ hostConnector,
    double distance,
    double axisRotation
)
member PlaceOnHost :
        hostId : ElementId *
        hostConnector : Connector *
        distance : float *
        axisRotation : float -> unit

Parameters

hostId ElementId
Identifier of the host fabrication part.
hostConnector Connector
The connector of the host.
distance Double
The distance from the connector to place the hosted part. Units are in feet (ft).
axisRotation Double
The axis rotation in radians.
Exceptions
Exception | Condition
ArgumentException | Invalid fabrication part host. The host should be a straight fabrication part. -or- Invalid connector of fabrication part host. -or- The distance is out of range. -or- For rectangular and oval parts the axis rotation must be a multiple of PI/2.
ArgumentNullException | A non-optional argument was null
Remarks
The document must be regenerated before the fabrication part can be used. Check ValidationStatus after regeneration to see if the part is valid for fabrication.
See Also

Reference

FabricationHostedInfo Class
PlaceOnHost Overload


FabricationItemFile Class

This class holds information about the item file, including whether it is already loaded from disk into Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFabricationItemFile

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FabricationItemFile : IDisposable
Public Class FabricationItemFile
    Implements IDisposable
public ref class FabricationItemFile : IDisposable
type FabricationItemFile =
    class
        interface IDisposable
    end

The FabricationItemFile type exposes the following members.

Properties
 | Name | Description
Public property | Identifier | The string identifier for the item file. This string is unique and can be used to compare whether fabrication item files are the same file.
Public property | IsUsed | Checks to see if the item file is already in use in the project.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the FabricationItemFile
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetImage | Gets the image for the fabrication item file.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsLoaded | Checks to see if the item file has been loaded into the configuration.
Public method | IsValid | Checks to see if the item file is valid.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This object is created as a result of loading from disk.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FabricationItemFile Properties

The FabricationItemFile type exposes the following members.

Properties
 | Name | Description
Public property | Identifier | The string identifier for the item file. This string is unique and can be used to compare whether fabrication item files are the same file.
Public property | IsUsed | Checks to see if the item file is already in use in the project.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

FabricationItemFile Class


FabricationItemFile.Identifier Property

FabricationItemFileIdentifier Property

The string identifier for the item file. This string is unique and can be used to compare whether fabrication item files are the same file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Identifier { get; }
Public ReadOnly Property Identifier As String
    Get
public:
property String^ Identifier {
    String^ get ();
}
member Identifier : string with get

Property Value

String
See Also

Reference

FabricationItemFile Class


FabricationItemFile.IsUsed Property

FabricationItemFileIsUsed Property

Checks to see if the item file is already in use in the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsUsed { get; }
Public ReadOnly Property IsUsed As Boolean
    Get
public:
property bool IsUsed {
    bool get ();
}
member IsUsed : bool with get

Property Value

Boolean
See Also

Reference

FabricationItemFile Class


FabricationItemFile.IsValidObject Property

FabricationItemFileIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

FabricationItemFile Class


FabricationItemFile Methods

The FabricationItemFile type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetImage | Gets the image for the fabrication item file.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsLoaded | Checks to see if the item file has been loaded into the configuration.
Public method | IsValid | Checks to see if the item file is valid.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FabricationItemFile Class


FabricationItemFile.Dispose Method

FabricationItemFileDispose Method

Releases all resources used by the FabricationItemFile

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FabricationItemFile Class


FabricationItemFile.GetImage Method

FabricationItemFileGetImage Method

Gets the image for the fabrication item file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Bitmap GetImage()
Public Overridable Function GetImage As Bitmap
public:
virtual Bitmap^ GetImage()
abstract GetImage : unit -> Bitmap
override GetImage : unit -> Bitmap

Return Value

Bitmap
System.Drawing.Bitmap represents the fabrication item file image. if there is no preview image.
See Also

Reference

FabricationItemFile Class


FabricationItemFile.IsLoaded Method

FabricationItemFileIsLoaded Method

Checks to see if the item file has been loaded into the configuration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsLoaded()
Public Function IsLoaded As Boolean
public:
bool IsLoaded()
member IsLoaded : unit -> bool

Return Value

Boolean
Returns true if the item file has been loaded into the configuration, false otherwise.
See Also

Reference

FabricationItemFile Class


FabricationItemFile.IsValid Method

FabricationItemFileIsValid Method

Checks to see if the item file is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValid()
Public Function IsValid As Boolean
public:
bool IsValid()
member IsValid : unit -> bool

Return Value

Boolean
Returns true if the item file is valid, false otherwise.
See Also

Reference

FabricationItemFile Class


FabricationItemFolder Class

A fabrication item folder that can contain sub folders and access to the FabricationItemFiles contained within.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFabricationItemFolder

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FabricationItemFolder : IDisposable
Public Class FabricationItemFolder
    Implements IDisposable
public ref class FabricationItemFolder : IDisposable
type FabricationItemFolder =
    class
        interface IDisposable
    end

The FabricationItemFolder type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The item folder's name.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the FabricationItemFolder
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetItemFiles | Gets the item files in this item folder.
Public method | GetSubFolders | Gets the item folder's sub folders.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FabricationItemFolder Properties

The FabricationItemFolder type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The item folder's name.
Top
See Also

Reference

FabricationItemFolder Class


FabricationItemFolder.IsValidObject Property

FabricationItemFolderIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

FabricationItemFolder Class


FabricationItemFolder.Name Property

FabricationItemFolderName Property

The item folder's name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

String
See Also

Reference

FabricationItemFolder Class


FabricationItemFolder Methods

The FabricationItemFolder type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetItemFiles | Gets the item files in this item folder.
Public method | GetSubFolders | Gets the item folder's sub folders.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FabricationItemFolder Class


FabricationItemFolder.Dispose Method

FabricationItemFolderDispose Method

Releases all resources used by the FabricationItemFolder

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FabricationItemFolder Class


FabricationItemFolder.GetItemFiles Method

FabricationItemFolderGetItemFiles Method

Gets the item files in this item folder.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<FabricationItemFile> GetItemFiles()
Public Function GetItemFiles As IList(Of FabricationItemFile)
public:
IList<FabricationItemFile^>^ GetItemFiles()
member GetItemFiles : unit -> IList<FabricationItemFile>

Return Value

IList FabricationItemFile
See Also

Reference

FabricationItemFolder Class


FabricationItemFolder.GetSubFolders Method

FabricationItemFolderGetSubFolders Method

Gets the item folder's sub folders.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<FabricationItemFolder> GetSubFolders()
Public Function GetSubFolders As IList(Of FabricationItemFolder)
public:
IList<FabricationItemFolder^>^ GetSubFolders()
member GetSubFolders : unit -> IList<FabricationItemFolder>

Return Value

IList FabricationItemFolder
See Also

Reference

FabricationItemFolder Class


FabricationMaterialType Enumeration

An enumerated type listing all fabrication material types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum FabricationMaterialType
Public Enumeration FabricationMaterialType
public enum class FabricationMaterialType
type FabricationMaterialType
Members
Member name | Value | Description
Unknown | 0 | Unknown material type
Ductwork | 1 | Flatbed material type (thickness/wire gauge)
Pipework | 2 | Pipework material type (index/specification name)
Containment | 3 | Containment material type (index/specification name)
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FabricationPart Class

Represents a fabrication component in the Autodesk Revit MEP product.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBFabricationPart

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FabricationPart : Element
Public Class FabricationPart
    Inherits Element
public ref class FabricationPart : public Element
type FabricationPart =
    class
        inherit Element
    end

The FabricationPart type exposes the following members.

Properties
 | Name | Description
Public property | Alias | The alias of the fabrication part.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | BottomOfPartElevation | The associated elevation to the bottom of fabrication part off of the current level.
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | CenterlineLength | The centerline length of the fabrication part.
Public property | ConnectorManager | The connector manager of the fabrication part.
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CutType | The cut type of the fabrication part.
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | DomainType | The domain type for the fabrication part.
Public property | DoubleWallMaterial | The double wall material identifier of the fabrication part.
Public property | DoubleWallMaterialArea | The double wall material area of the fabrication part. If the fabrication part is not double walled, returns zero.
Public property | DoubleWallMaterialThickness | The double wall material thickness of the fabrication part. If the fabrication part is not double walled, returns zero.
Public property | FreeSize | The inner size of the fabrication part.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GeometryChecksum | Gets the geometry checksum of the fabrication part symbol, and it does nothing with the fabrication part instance position.
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HangerRodKit | Specifies whether an ancillary kit is being used to override support rods, bolts and clips, if any. A value of 0 indicates no override is being used.
Public property | HasDoubleWall | True if the fabrication part is double walled.
Public property | HasInsulation | True if the fabrication part is insulated.
Public property | HasLining | True if the fabrication part is lined.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | InsulationArea | The insulation area of the fabrication part. If the fabrication part is not insulated, returns zero.
Public property | InsulationSpecification | The fabrication part insulation specification identifier.
Public property | InsulationThickness | The insulation thickness of the fabrication part. If the fabrication part is not insulated, returns zero.
Public property | InsulationType | The insulation type of the fabrication part.
Public property | IsBoughtOut | True if the fabrication part is bought out.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | ItemCustomId | The item custom identifier for the fabrication part.
Public property | ItemNumber | The item number that is used for identification, re-ordering from shop.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LevelOffset | The associated level offset that indicates the distance from the center of the fabrication part to the current level.
Public property | LiningArea | The lining area of the fabrication part. If the fabrication part is not lined, returns zero.
Public property | LiningThickness | The lining thickness of the fabrication part. If the fabrication part is not lined, returns zero.
Public property | LiningType | The lining type of the fabrication part.
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Material | The fabrication material identifier.
Public property | MaterialGauge | The fabrication material gauge identifier.
Public property | MaterialThickness | The material thickness of the fabrication part.
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | Notes | The notes of the fabrication part.
Public property | Origin | The origin of the fabrication part element.
Public property | OverallSize | The overall size of the fabrication part.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | PartGuid | The fabrication part's globally unique identifier.
Public property | PartStatus | The status identifier for the fabrication part.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ProductCode | The current database id of the part within the fabrication database.
Public property | ProductDataRange | The product data range of the fabrication part.
Public property | ProductFinishDescription | The product finish description of the fabrication part.
Public property | ProductInstallType | The product install type of the fabrication part.
Public property | ProductListEntry | The product entry index of the fabrication part. A value of -1 indicates the fabrication part is not a product list.
Public property | ProductLongDescription | The product long description of the fabrication part.
Public property | ProductMaterialDescription | The product material description of the fabrication part.
Public property | ProductName | The product name of the fabrication part.
Public property | ProductOriginalEquipmentManufacture | The product original equipment manufacture (OEM) of the fabrication part.
Public property | ProductShortDescription | The product short description of the fabrication part.
Public property | ProductSizeDescription | The product size description of the fabrication part.
Public property | ProductSpecificationDescription | The product specification description of the fabrication part.
Public property | ServiceAbbreviation | The associated service abbreviation for the fabrication service.
Public property | ServiceId | The fabrication part service identifier. The service can only be changed to compatible services.
Public property | ServiceName | The name of the service associated with the fabrication part.
Public property | ServiceType | The service type identifier of the fabrication part.
Public property | SheetMetalArea | The sheet metal area of the fabrication part.
Public property | Size | The size of the fabrication part.
Public property | Slope | The slope for the straight fabrication part.
Public property | Specification | The fabrication part specification identifier.
Public property | SpoolName | The spool name of the fabrication part.
Public property | TopOfPartElevation | The associated elevation to the top of fabrication part off of the current level.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | ValidationStatus | The validation status of the fabrication part.
Public property | Vendor | The vendor of the fabrication part.
Public property | VendorCode | The vendor code of the fabrication part.
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | Weight | The weight of the fabrication part.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | AddPartCustomData | Add custom data type to the fabrication part. The new data gets the default value defined by the fabrication configuration.
Public method | AdjustEndLength | Adjusts the length for the specified connector.
 | AlignPartByConnector | Align the part by its connector to a point and rotation in free space.
 | AlignPartByConnectors | Moves fabrication part by one of its connectors and aligns it to another connector.
 | AlignPartByConnectorToConnector | Align a part by its connector to another connector. This will replace the FabricationPart::AlignPartByConnectors method.
 | AlignPartByInsertionPoint | Align the part by its insertion point to a point and rotation in free space.
 | AlignPartByInsertionPointAndCutInToStraight | Align the part by its insertion point to a point and rotation on a straight. This will automatically size and connect the part being cut into, if possible.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanAdjustEndLength | Checks if the end of fabrication part can be adjusted.
Public method | CanASlopeBeApplied | This will test if a slope can be applied to the part and maintain connections with any connected parts.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanFlipPart | Validates if the fabrication part is one of the supported fabrication part types that can be flipped.
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | CanSplitStraight | Validates if the straight can be split into two at the passed in point.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | ConnectAndCouple | Makes a connection between the specified connectors and adds coupling if necessary.
 | Create(Document, FabricationItemFile, ElementId) | Creates a fabrication part element from a fabrication item file.
 | Create(Document, FabricationServiceButton, Int32, ElementId) | Creates a fabrication part element based on button.
 | Create(Document, FabricationServiceButton, Double, Double, ElementId) | Creates a fabrication part element based on button and size.
 | CreateHanger(Document, FabricationServiceButton, Int32, ElementId) | Creates a free placed hanger.
 | CreateHanger(Document, FabricationServiceButton, ElementId, Connector, Double, Boolean) | Creates a hanger on the fabrication part.
 | CreateHanger(Document, FabricationServiceButton, Int32, ElementId, Connector, Double, Boolean) | Creates a hanger on the fabrication part.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | Flip | Flips the fabrication part that is directionally oriented (tees, crosses, valves, dampers, etc.) to the opposite direction.
Public method | GetCalculatedDimensionValue | Gets the calculated dimension value.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetDimensionCalculatedOptions | Gets the calculated options of the fabrication dimension.
Public method | GetDimensions | Gets all fabrication dimensions.
Public method | GetDimensionValue | Gets the value of the fabrication dimension, returns value in Revit internal units.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetHostedInfo | Gets the fabrication hosted element information.
Public method | GetInsulationLiningGeometry | Gets insulation and lining geometry for this fabrication part.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPartAncillaryUsage | Gets a list of all ancillary usage information for the part.
Public method | GetPartCustomDataInteger | Get custom data integer value for the specified custom data.
Public method | GetPartCustomDataReal | Get custom data real value for the specified custom data.
Public method | GetPartCustomDataText | Get custom data text for the specified custom data.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetProductListEntryCount | Gets the number of product entries for this part.
Public method | GetProductListEntryName | Gets the specified product list entry name.
Public method | GetRodInfo | Gets the fabrication rod information.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTransform | Gets the transformation matrix of the fabrication part element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetVersionHistory | Gets a history of version change information about the current part.
Public method | HasCustomData | Check if fabrication part contains custom data already.
Public method | HasNoConnections | Checks to see if all the fabrication part's connectors are open.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsAHanger | Checks whether it is a hanger.
Public method | IsAStraight | Checks whether it is a straight part.
Public method | IsATap | Checks if it is any sort of tap.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDimensionCalculated | Checks if the fabrication dimension is calculated.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsProductList | Gets whether or not the fabrication part is a product list.
Public method | IsProductListEntryCompatibleSize | Checks to see if this part can be changed to the specified product entry without altering any connected dimensions.
Public method | IsSameAs | Compare this fabrication part with the part passed and checks the pattern dimensions and options. A list of fields that can be ignored in the comparison check can be specified.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
 | OptimizeLengths | Optimizes the length fabrication straight parts.
 | PlaceAsTap | Places the part by its connector to a specific position on the straight part at the specified distance from the host part connector.
 | PlaceFittingAsCutIn | Places the fitting on the straight part by cut in, use the fitting's focal point as the insertion position.
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemovePartCustomData | Remove custom data from the fabrication part.
 | Reposition | Repositions the fabrication straight part to another end of the run.
 | RotateConnectedPartByConnector | Rotates a connected fabrication part around the axis of the specified connector.
 | RotateConnectedTap | Rotates a connected fabrication tap by the specified angles about the primary and secondary axis.
 | SaveAsFabricationJob | Save fabrication parts to an MEP job that can be opened in the fabrication software.
Public method | SetCalculatedDimensionValue | Sets the calculated dimension value.
Public method | SetDimensionValue | Sets the fabrication dimension value. The value is in Revit internal units.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetPartCustomDataInteger | Set the custom data integer value for the specified custom data.
Public method | SetPartCustomDataReal | Set the custom data real value for the specified custom data.
Public method | SetPartCustomDataText | Set the custom data real value for the specified custom data.
Public method | SetPositionByEnd | Positions the connector of the fabrication part element by the passed point.
Public method | SplitStraight(XYZ) | Splits the straight into two at the passed in point.
Public method | SplitStraight(Document, ElementId, XYZ) | Splits the straight into two at the passed in point.
 | StretchAndFit | Stretch the fabrication part from the specified connector and fit to the target routing end.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FabricationPart Properties

The FabricationPart type exposes the following members.

Properties
 | Name | Description
Public property | Alias | The alias of the fabrication part.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | BottomOfPartElevation | The associated elevation to the bottom of fabrication part off of the current level.
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | CenterlineLength | The centerline length of the fabrication part.
Public property | ConnectorManager | The connector manager of the fabrication part.
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CutType | The cut type of the fabrication part.
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | DomainType | The domain type for the fabrication part.
Public property | DoubleWallMaterial | The double wall material identifier of the fabrication part.
Public property | DoubleWallMaterialArea | The double wall material area of the fabrication part. If the fabrication part is not double walled, returns zero.
Public property | DoubleWallMaterialThickness | The double wall material thickness of the fabrication part. If the fabrication part is not double walled, returns zero.
Public property | FreeSize | The inner size of the fabrication part.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GeometryChecksum | Gets the geometry checksum of the fabrication part symbol, and it does nothing with the fabrication part instance position.
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HangerRodKit | Specifies whether an ancillary kit is being used to override support rods, bolts and clips, if any. A value of 0 indicates no override is being used.
Public property | HasDoubleWall | True if the fabrication part is double walled.
Public property | HasInsulation | True if the fabrication part is insulated.
Public property | HasLining | True if the fabrication part is lined.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | InsulationArea | The insulation area of the fabrication part. If the fabrication part is not insulated, returns zero.
Public property | InsulationSpecification | The fabrication part insulation specification identifier.
Public property | InsulationThickness | The insulation thickness of the fabrication part. If the fabrication part is not insulated, returns zero.
Public property | InsulationType | The insulation type of the fabrication part.
Public property | IsBoughtOut | True if the fabrication part is bought out.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | ItemCustomId | The item custom identifier for the fabrication part.
Public property | ItemNumber | The item number that is used for identification, re-ordering from shop.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LevelOffset | The associated level offset that indicates the distance from the center of the fabrication part to the current level.
Public property | LiningArea | The lining area of the fabrication part. If the fabrication part is not lined, returns zero.
Public property | LiningThickness | The lining thickness of the fabrication part. If the fabrication part is not lined, returns zero.
Public property | LiningType | The lining type of the fabrication part.
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Material | The fabrication material identifier.
Public property | MaterialGauge | The fabrication material gauge identifier.
Public property | MaterialThickness | The material thickness of the fabrication part.
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | Notes | The notes of the fabrication part.
Public property | Origin | The origin of the fabrication part element.
Public property | OverallSize | The overall size of the fabrication part.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | PartGuid | The fabrication part's globally unique identifier.
Public property | PartStatus | The status identifier for the fabrication part.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ProductCode | The current database id of the part within the fabrication database.
Public property | ProductDataRange | The product data range of the fabrication part.
Public property | ProductFinishDescription | The product finish description of the fabrication part.
Public property | ProductInstallType | The product install type of the fabrication part.
Public property | ProductListEntry | The product entry index of the fabrication part. A value of -1 indicates the fabrication part is not a product list.
Public property | ProductLongDescription | The product long description of the fabrication part.
Public property | ProductMaterialDescription | The product material description of the fabrication part.
Public property | ProductName | The product name of the fabrication part.
Public property | ProductOriginalEquipmentManufacture | The product original equipment manufacture (OEM) of the fabrication part.
Public property | ProductShortDescription | The product short description of the fabrication part.
Public property | ProductSizeDescription | The product size description of the fabrication part.
Public property | ProductSpecificationDescription | The product specification description of the fabrication part.
Public property | ServiceAbbreviation | The associated service abbreviation for the fabrication service.
Public property | ServiceId | The fabrication part service identifier. The service can only be changed to compatible services.
Public property | ServiceName | The name of the service associated with the fabrication part.
Public property | ServiceType | The service type identifier of the fabrication part.
Public property | SheetMetalArea | The sheet metal area of the fabrication part.
Public property | Size | The size of the fabrication part.
Public property | Slope | The slope for the straight fabrication part.
Public property | Specification | The fabrication part specification identifier.
Public property | SpoolName | The spool name of the fabrication part.
Public property | TopOfPartElevation | The associated elevation to the top of fabrication part off of the current level.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | ValidationStatus | The validation status of the fabrication part.
Public property | Vendor | The vendor of the fabrication part.
Public property | VendorCode | The vendor code of the fabrication part.
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | Weight | The weight of the fabrication part.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

FabricationPart Class


FabricationPart.Alias Property

FabricationPartAlias Property

The alias of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Alias { get; }
Public ReadOnly Property Alias As String
    Get
public:
property String^ Alias {
    String^ get ();
}
member Alias : string with get

Property Value

String
See Also

Reference

FabricationPart Class


FabricationPart.BottomOfPartElevation Property

FabricationPartBottomOfPartElevation Property

The associated elevation to the bottom of fabrication part off of the current level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double BottomOfPartElevation { get; }
Public ReadOnly Property BottomOfPartElevation As Double
    Get
public:
property double BottomOfPartElevation {
    double get ();
}
member BottomOfPartElevation : float with get

Property Value

Double
See Also

Reference

FabricationPart Class


FabricationPart.CenterlineLength Property

FabricationPartCenterlineLength Property

The centerline length of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double CenterlineLength { get; }
Public ReadOnly Property CenterlineLength As Double
    Get
public:
property double CenterlineLength {
    double get ();
}
member CenterlineLength : float with get

Property Value

Double
See Also

Reference

FabricationPart Class


FabricationPart.ConnectorManager Property

FabricationPartConnectorManager Property

The connector manager of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConnectorManager ConnectorManager { get; }
Public ReadOnly Property ConnectorManager As ConnectorManager
    Get
public:
property ConnectorManager^ ConnectorManager {
    ConnectorManager^ get ();
}
member ConnectorManager : ConnectorManager with get

Property Value

ConnectorManager
See Also

Reference

FabricationPart Class


FabricationPart.CutType Property

FabricationPartCutType Property

The cut type of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int CutType { get; }
Public ReadOnly Property CutType As Integer
    Get
public:
property int CutType {
    int get ();
}
member CutType : int with get

Property Value

Int32
See Also

Reference

FabricationPart Class


FabricationPart.DomainType Property

FabricationPartDomainType Property

The domain type for the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConnectorDomainType DomainType { get; }
Public ReadOnly Property DomainType As ConnectorDomainType
    Get
public:
property ConnectorDomainType DomainType {
    ConnectorDomainType get ();
}
member DomainType : ConnectorDomainType with get

Property Value

ConnectorDomainType
See Also

Reference

FabricationPart Class


FabricationPart.DoubleWallMaterial Property

FabricationPartDoubleWallMaterial Property

The double wall material identifier of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int DoubleWallMaterial { get; }
Public ReadOnly Property DoubleWallMaterial As Integer
    Get
public:
property int DoubleWallMaterial {
    int get ();
}
member DoubleWallMaterial : int with get

Property Value

Int32
See Also

Reference

FabricationPart Class


FabricationPart.DoubleWallMaterialArea Property

FabricationPartDoubleWallMaterialArea Property

The double wall material area of the fabrication part. If the fabrication part is not double walled, returns zero.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double DoubleWallMaterialArea { get; }
Public ReadOnly Property DoubleWallMaterialArea As Double
    Get
public:
property double DoubleWallMaterialArea {
    double get ();
}
member DoubleWallMaterialArea : float with get

Property Value

Double
See Also

Reference

FabricationPart Class


FabricationPart.DoubleWallMaterialThickness Property

FabricationPartDoubleWallMaterialThickness Property

The double wall material thickness of the fabrication part. If the fabrication part is not double walled, returns zero.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double DoubleWallMaterialThickness { get; }
Public ReadOnly Property DoubleWallMaterialThickness As Double
    Get
public:
property double DoubleWallMaterialThickness {
    double get ();
}
member DoubleWallMaterialThickness : float with get

Property Value

Double
See Also

Reference

FabricationPart Class


FabricationPart.FreeSize Property

FabricationPartFreeSize Property

The inner size of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FreeSize { get; }
Public ReadOnly Property FreeSize As String
    Get
public:
property String^ FreeSize {
    String^ get ();
}
member FreeSize : string with get

Property Value

String
See Also

Reference

FabricationPart Class


FabricationPart.GeometryChecksum Property

FabricationPartGeometryChecksum Property

Gets the geometry checksum of the fabrication part symbol, and it does nothing with the fabrication part instance position.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AssetPropertyUInt64 GeometryChecksum { get; }
Public ReadOnly Property GeometryChecksum As AssetPropertyUInt64
    Get
public:
property AssetPropertyUInt64^ GeometryChecksum {
    AssetPropertyUInt64^ get ();
}
member GeometryChecksum : AssetPropertyUInt64 with get

Property Value

AssetPropertyUInt64
See Also

Reference

FabricationPart Class


FabricationPart.HangerRodKit Property

FabricationPartHangerRodKit Property

Specifies whether an ancillary kit is being used to override support rods, bolts and clips, if any. A value of 0 indicates no override is being used.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int HangerRodKit { get; set; }
Public Property HangerRodKit As Integer
    Get
    Set
public:
property int HangerRodKit {
    int get ();
    void set (int value);
}
member HangerRodKit : int with get, set

Property Value

Int32
Remarks
For hangers only. Setting an invalid hanger rod kit will result in the property being unchanged.
See Also

Reference

FabricationPart Class


FabricationPart.HasDoubleWall Property

FabricationPartHasDoubleWall Property

True if the fabrication part is double walled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasDoubleWall { get; }
Public ReadOnly Property HasDoubleWall As Boolean
    Get
public:
property bool HasDoubleWall {
    bool get ();
}
member HasDoubleWall : bool with get

Property Value

Boolean
See Also

Reference

FabricationPart Class


FabricationPart.HasInsulation Property

FabricationPartHasInsulation Property

True if the fabrication part is insulated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasInsulation { get; }
Public ReadOnly Property HasInsulation As Boolean
    Get
public:
property bool HasInsulation {
    bool get ();
}
member HasInsulation : bool with get

Property Value

Boolean
See Also

Reference

FabricationPart Class


FabricationPart.HasLining Property

FabricationPartHasLining Property

True if the fabrication part is lined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasLining { get; }
Public ReadOnly Property HasLining As Boolean
    Get
public:
property bool HasLining {
    bool get ();
}
member HasLining : bool with get

Property Value

Boolean
See Also

Reference

FabricationPart Class


FabricationPart.InsulationArea Property

FabricationPartInsulationArea Property

The insulation area of the fabrication part. If the fabrication part is not insulated, returns zero.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double InsulationArea { get; }
Public ReadOnly Property InsulationArea As Double
    Get
public:
property double InsulationArea {
    double get ();
}
member InsulationArea : float with get

Property Value

Double
See Also

Reference

FabricationPart Class


FabricationPart.InsulationSpecification Property

FabricationPartInsulationSpecification Property

The fabrication part insulation specification identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int InsulationSpecification { get; set; }
Public Property InsulationSpecification As Integer
    Get
    Set
public:
property int InsulationSpecification {
    int get ();
    void set (int value);
}
member InsulationSpecification : int with get, set

Property Value

Int32
Exceptions
Exception | Condition
ArgumentException | When setting this property: the insulation specification is invalid for the fabrication part.
InvalidOperationException | -or- When setting this property: the fabrication part has taps connected. -or- When setting this property: the specification fails to be set by identifier: specId.
Remarks
A value of 0 indicates the insulation specification is set to off.
See Also

Reference

FabricationPart Class


FabricationPart.InsulationThickness Property

FabricationPartInsulationThickness Property

The insulation thickness of the fabrication part. If the fabrication part is not insulated, returns zero.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double InsulationThickness { get; }
Public ReadOnly Property InsulationThickness As Double
    Get
public:
property double InsulationThickness {
    double get ();
}
member InsulationThickness : float with get

Property Value

Double
See Also

Reference

FabricationPart Class


FabricationPart.InsulationType Property

FabricationPartInsulationType Property

The insulation type of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string InsulationType { get; }
Public ReadOnly Property InsulationType As String
    Get
public:
property String^ InsulationType {
    String^ get ();
}
member InsulationType : string with get

Property Value

String
See Also

Reference

FabricationPart Class


FabricationPart.IsBoughtOut Property

FabricationPartIsBoughtOut Property

True if the fabrication part is bought out.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsBoughtOut { get; }
Public ReadOnly Property IsBoughtOut As Boolean
    Get
public:
property bool IsBoughtOut {
    bool get ();
}
member IsBoughtOut : bool with get

Property Value

Boolean
See Also

Reference

FabricationPart Class


FabricationPart.ItemCustomId Property

FabricationPartItemCustomId Property

The item custom identifier for the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ItemCustomId { get; }
Public ReadOnly Property ItemCustomId As Integer
    Get
public:
property int ItemCustomId {
    int get ();
}
member ItemCustomId : int with get

Property Value

Int32
See Also

Reference

FabricationPart Class


FabricationPart.ItemNumber Property

FabricationPartItemNumber Property

The item number that is used for identification, re-ordering from shop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ItemNumber { get; set; }
Public Property ItemNumber As String
    Get
    Set
public:
property String^ ItemNumber {
    String^ get ();
    void set (String^ value);
}
member ItemNumber : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
InvalidOperationException | When setting this property:
See Also

Reference

FabricationPart Class


FabricationPart.LevelOffset Property

FabricationPartLevelOffset Property

The associated level offset that indicates the distance from the center of the fabrication part to the current level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double LevelOffset { get; }
Public ReadOnly Property LevelOffset As Double
    Get
public:
property double LevelOffset {
    double get ();
}
member LevelOffset : float with get

Property Value

Double
See Also

Reference

FabricationPart Class


FabricationPart.LiningArea Property

FabricationPartLiningArea Property

The lining area of the fabrication part. If the fabrication part is not lined, returns zero.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double LiningArea { get; }
Public ReadOnly Property LiningArea As Double
    Get
public:
property double LiningArea {
    double get ();
}
member LiningArea : float with get

Property Value

Double
See Also

Reference

FabricationPart Class


FabricationPart.LiningThickness Property

FabricationPartLiningThickness Property

The lining thickness of the fabrication part. If the fabrication part is not lined, returns zero.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double LiningThickness { get; }
Public ReadOnly Property LiningThickness As Double
    Get
public:
property double LiningThickness {
    double get ();
}
member LiningThickness : float with get

Property Value

Double
See Also

Reference

FabricationPart Class


FabricationPart.LiningType Property

FabricationPartLiningType Property

The lining type of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string LiningType { get; }
Public ReadOnly Property LiningType As String
    Get
public:
property String^ LiningType {
    String^ get ();
}
member LiningType : string with get

Property Value

String
See Also

Reference

FabricationPart Class


FabricationPart.Material Property

FabricationPartMaterial Property

The fabrication material identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Material { get; set; }
Public Property Material As Integer
    Get
    Set
public:
property int Material {
    int get ();
    void set (int value);
}
member Material : int with get, set

Property Value

Int32
Exceptions
Exception | Condition
ArgumentException | When setting this property: the material is not valid for the fabrication part's specification.
InvalidOperationException | When setting this property: the material is not able to be modified. -or- When setting this property: the fabrication part is connected to more than one item. -or- When setting this property: the material fails to be set by identifier: materialId.
See Also

Reference

FabricationPart Class


FabricationPart.MaterialGauge Property

FabricationPartMaterialGauge Property

The fabrication material gauge identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int MaterialGauge { get; }
Public ReadOnly Property MaterialGauge As Integer
    Get
public:
property int MaterialGauge {
    int get ();
}
member MaterialGauge : int with get

Property Value

Int32
See Also

Reference

FabricationPart Class


FabricationPart.MaterialThickness Property

FabricationPartMaterialThickness Property

The material thickness of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double MaterialThickness { get; }
Public ReadOnly Property MaterialThickness As Double
    Get
public:
property double MaterialThickness {
    double get ();
}
member MaterialThickness : float with get

Property Value

Double
See Also

Reference

FabricationPart Class


FabricationPart.Notes Property

FabricationPartNotes Property

The notes of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Notes { get; set; }
Public Property Notes As String
    Get
    Set
public:
property String^ Notes {
    String^ get ();
    void set (String^ value);
}
member Notes : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
InvalidOperationException | When setting this property:
See Also

Reference

FabricationPart Class


FabricationPart.Origin Property

FabricationPartOrigin Property

The origin of the fabrication part element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Origin { get; }
Public ReadOnly Property Origin As XYZ
    Get
public:
property XYZ^ Origin {
    XYZ^ get ();
}
member Origin : XYZ with get

Property Value

XYZ
See Also

Reference

FabricationPart Class


FabricationPart.OverallSize Property

FabricationPartOverallSize Property

The overall size of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string OverallSize { get; }
Public ReadOnly Property OverallSize As String
    Get
public:
property String^ OverallSize {
    String^ get ();
}
member OverallSize : string with get

Property Value

String
See Also

Reference

FabricationPart Class


FabricationPart.PartGuid Property

FabricationPartPartGuid Property

The fabrication part's globally unique identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid PartGuid { get; }
Public ReadOnly Property PartGuid As Guid
    Get
public:
property Guid PartGuid {
    Guid get ();
}
member PartGuid : Guid with get

Property Value

Guid
See Also

Reference

FabricationPart Class


FabricationPart.PartStatus Property

FabricationPartPartStatus Property

The status identifier for the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int PartStatus { get; set; }
Public Property PartStatus As Integer
    Get
    Set
public:
property int PartStatus {
    int get ();
    void set (int value);
}
member PartStatus : int with get, set

Property Value

Int32
See Also

Reference

FabricationPart Class


FabricationPart.ProductCode Property

FabricationPartProductCode Property

The current database id of the part within the fabrication database.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ProductCode { get; }
Public ReadOnly Property ProductCode As String
    Get
public:
property String^ ProductCode {
    String^ get ();
}
member ProductCode : string with get

Property Value

String
See Also

Reference

FabricationPart Class


FabricationPart.ProductDataRange Property

FabricationPartProductDataRange Property

The product data range of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ProductDataRange { get; }
Public ReadOnly Property ProductDataRange As String
    Get
public:
property String^ ProductDataRange {
    String^ get ();
}
member ProductDataRange : string with get

Property Value

String
See Also

Reference

FabricationPart Class


FabricationPart.ProductFinishDescription Property

FabricationPartProductFinishDescription Property

The product finish description of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ProductFinishDescription { get; }
Public ReadOnly Property ProductFinishDescription As String
    Get
public:
property String^ ProductFinishDescription {
    String^ get ();
}
member ProductFinishDescription : string with get

Property Value

String
See Also

Reference

FabricationPart Class


FabricationPart.ProductInstallType Property

FabricationPartProductInstallType Property

The product install type of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ProductInstallType { get; }
Public ReadOnly Property ProductInstallType As String
    Get
public:
property String^ ProductInstallType {
    String^ get ();
}
member ProductInstallType : string with get

Property Value

String
See Also

Reference

FabricationPart Class


FabricationPart.ProductListEntry Property

FabricationPartProductListEntry Property

The product entry index of the fabrication part. A value of -1 indicates the fabrication part is not a product list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ProductListEntry { get; set; }
Public Property ProductListEntry As Integer
    Get
    Set
public:
property int ProductListEntry {
    int get ();
    void set (int value);
}
member ProductListEntry : int with get, set

Property Value

Int32
Exceptions
Exception | Condition
ArgumentException | When setting this property: modifying the product entry will cause the dimensions of connected ends to change.
ArgumentOutOfRangeException | When setting this property: The product entry index is not larger than 0 and less than GetProductCount.
InvalidOperationException | When setting this property: -or- When setting this property: the product entry fails to be set by index: productEntryIndex.
Remarks
The product list is a catalog of available sizes for the part and the index refers to the entry on this list.
See Also

Reference

FabricationPart Class


FabricationPart.ProductLongDescription Property

FabricationPartProductLongDescription Property

The product long description of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ProductLongDescription { get; }
Public ReadOnly Property ProductLongDescription As String
    Get
public:
property String^ ProductLongDescription {
    String^ get ();
}
member ProductLongDescription : string with get

Property Value

String
See Also

Reference

FabricationPart Class


FabricationPart.ProductMaterialDescription Property

FabricationPartProductMaterialDescription Property

The product material description of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ProductMaterialDescription { get; }
Public ReadOnly Property ProductMaterialDescription As String
    Get
public:
property String^ ProductMaterialDescription {
    String^ get ();
}
member ProductMaterialDescription : string with get

Property Value

String
See Also

Reference

FabricationPart Class


FabricationPart.ProductName Property

FabricationPartProductName Property

The product name of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ProductName { get; }
Public ReadOnly Property ProductName As String
    Get
public:
property String^ ProductName {
    String^ get ();
}
member ProductName : string with get

Property Value

String
See Also

Reference

FabricationPart Class


FabricationPart.ProductOriginalEquipmentManufacture Property

FabricationPartProductOriginalEquipmentManufacture Property

The product original equipment manufacture (OEM) of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ProductOriginalEquipmentManufacture { get; }
Public ReadOnly Property ProductOriginalEquipmentManufacture As String
    Get
public:
property String^ ProductOriginalEquipmentManufacture {
    String^ get ();
}
member ProductOriginalEquipmentManufacture : string with get

Property Value

String
See Also

Reference

FabricationPart Class


FabricationPart.ProductShortDescription Property

FabricationPartProductShortDescription Property

The product short description of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ProductShortDescription { get; }
Public ReadOnly Property ProductShortDescription As String
    Get
public:
property String^ ProductShortDescription {
    String^ get ();
}
member ProductShortDescription : string with get

Property Value

String
See Also

Reference

FabricationPart Class


FabricationPart.ProductSizeDescription Property

FabricationPartProductSizeDescription Property

The product size description of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ProductSizeDescription { get; }
Public ReadOnly Property ProductSizeDescription As String
    Get
public:
property String^ ProductSizeDescription {
    String^ get ();
}
member ProductSizeDescription : string with get

Property Value

String
See Also

Reference

FabricationPart Class


FabricationPart.ProductSpecificationDescription Property

FabricationPartProductSpecificationDescription Property

The product specification description of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ProductSpecificationDescription { get; }
Public ReadOnly Property ProductSpecificationDescription As String
    Get
public:
property String^ ProductSpecificationDescription {
    String^ get ();
}
member ProductSpecificationDescription : string with get

Property Value

String
See Also

Reference

FabricationPart Class


FabricationPart.ServiceAbbreviation Property

FabricationPartServiceAbbreviation Property

The associated service abbreviation for the fabrication service.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ServiceAbbreviation { get; }
Public ReadOnly Property ServiceAbbreviation As String
    Get
public:
property String^ ServiceAbbreviation {
    String^ get ();
}
member ServiceAbbreviation : string with get

Property Value

String
See Also

Reference

FabricationPart Class


FabricationPart.ServiceId Property

FabricationPartServiceId Property

The fabrication part service identifier. The service can only be changed to compatible services.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ServiceId { get; set; }
Public Property ServiceId As Integer
    Get
    Set
public:
property int ServiceId {
    int get ();
    void set (int value);
}
member ServiceId : int with get, set

Property Value

Int32
Exceptions
Exception | Condition
ArgumentException | When setting this property:
See Also

Reference

FabricationPart Class


FabricationPart.ServiceName Property

FabricationPartServiceName Property

The name of the service associated with the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ServiceName { get; }
Public ReadOnly Property ServiceName As String
    Get
public:
property String^ ServiceName {
    String^ get ();
}
member ServiceName : string with get

Property Value

String
See Also

Reference

FabricationPart Class


FabricationPart.ServiceType Property

FabricationPartServiceType Property

The service type identifier of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ServiceType { get; }
Public ReadOnly Property ServiceType As Integer
    Get
public:
property int ServiceType {
    int get ();
}
member ServiceType : int with get

Property Value

Int32
See Also

Reference

FabricationPart Class


FabricationPart.SheetMetalArea Property

FabricationPartSheetMetalArea Property

The sheet metal area of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double SheetMetalArea { get; }
Public ReadOnly Property SheetMetalArea As Double
    Get
public:
property double SheetMetalArea {
    double get ();
}
member SheetMetalArea : float with get

Property Value

Double
See Also

Reference

FabricationPart Class


FabricationPart.Size Property

FabricationPartSize Property

The size of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Size { get; }
Public ReadOnly Property Size As String
    Get
public:
property String^ Size {
    String^ get ();
}
member Size : string with get

Property Value

String
See Also

Reference

FabricationPart Class


FabricationPart.Slope Property

FabricationPartSlope Property

The slope for the straight fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Slope { get; }
Public ReadOnly Property Slope As Double
    Get
public:
property double Slope {
    double get ();
}
member Slope : float with get

Property Value

Double
See Also

Reference

FabricationPart Class


FabricationPart.Specification Property

FabricationPartSpecification Property

The fabrication part specification identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Specification { get; set; }
Public Property Specification As Integer
    Get
    Set
public:
property int Specification {
    int get ();
    void set (int value);
}
member Specification : int with get, set

Property Value

Int32
Exceptions
Exception | Condition
ArgumentException | When setting this property: the specification is invalid for the fabrication part.
InvalidOperationException | When setting this property: the specification is not able to be modified. -or- When setting this property: the fabrication part is connected to more than one item. -or- When setting this property: the specification fails to be set by identifier: specId.
Remarks
A value of 0 indicates the specification is set to undefined.
See Also

Reference

FabricationPart Class


FabricationPart.SpoolName Property

FabricationPartSpoolName Property

The spool name of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SpoolName { get; set; }
Public Property SpoolName As String
    Get
    Set
public:
property String^ SpoolName {
    String^ get ();
    void set (String^ value);
}
member SpoolName : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
InvalidOperationException | When setting this property:
See Also

Reference

FabricationPart Class


FabricationPart.TopOfPartElevation Property

FabricationPartTopOfPartElevation Property

The associated elevation to the top of fabrication part off of the current level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double TopOfPartElevation { get; }
Public ReadOnly Property TopOfPartElevation As Double
    Get
public:
property double TopOfPartElevation {
    double get ();
}
member TopOfPartElevation : float with get

Property Value

Double
See Also

Reference

FabricationPart Class


FabricationPart.ValidationStatus Property

FabricationPartValidationStatus Property

The validation status of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ValidationStatus ValidationStatus { get; }
Public ReadOnly Property ValidationStatus As ValidationStatus
    Get
public:
property ValidationStatus ValidationStatus {
    ValidationStatus get ();
}
member ValidationStatus : ValidationStatus with get

Property Value

ValidationStatus
See Also

Reference

FabricationPart Class


FabricationPart.Vendor Property

FabricationPartVendor Property

The vendor of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Vendor { get; }
Public ReadOnly Property Vendor As String
    Get
public:
property String^ Vendor {
    String^ get ();
}
member Vendor : string with get

Property Value

String
See Also

Reference

FabricationPart Class


FabricationPart.VendorCode Property

FabricationPartVendorCode Property

The vendor code of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string VendorCode { get; }
Public ReadOnly Property VendorCode As String
    Get
public:
property String^ VendorCode {
    String^ get ();
}
member VendorCode : string with get

Property Value

String
See Also

Reference

FabricationPart Class


FabricationPart.Weight Property

FabricationPartWeight Property

The weight of the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Weight { get; }
Public ReadOnly Property Weight As Double
    Get
public:
property double Weight {
    double get ();
}
member Weight : float with get

Property Value

Double
See Also

Reference

FabricationPart Class


FabricationPart Methods

The FabricationPart type exposes the following members.

Methods
 | Name | Description
Public method | AddPartCustomData | Add custom data type to the fabrication part. The new data gets the default value defined by the fabrication configuration.
Public method | AdjustEndLength | Adjusts the length for the specified connector.
 | AlignPartByConnector | Align the part by its connector to a point and rotation in free space.
 | AlignPartByConnectors | Moves fabrication part by one of its connectors and aligns it to another connector.
 | AlignPartByConnectorToConnector | Align a part by its connector to another connector. This will replace the FabricationPart::AlignPartByConnectors method.
 | AlignPartByInsertionPoint | Align the part by its insertion point to a point and rotation in free space.
 | AlignPartByInsertionPointAndCutInToStraight | Align the part by its insertion point to a point and rotation on a straight. This will automatically size and connect the part being cut into, if possible.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanAdjustEndLength | Checks if the end of fabrication part can be adjusted.
Public method | CanASlopeBeApplied | This will test if a slope can be applied to the part and maintain connections with any connected parts.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanFlipPart | Validates if the fabrication part is one of the supported fabrication part types that can be flipped.
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | CanSplitStraight | Validates if the straight can be split into two at the passed in point.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | ConnectAndCouple | Makes a connection between the specified connectors and adds coupling if necessary.
 | Create(Document, FabricationItemFile, ElementId) | Creates a fabrication part element from a fabrication item file.
 | Create(Document, FabricationServiceButton, Int32, ElementId) | Creates a fabrication part element based on button.
 | Create(Document, FabricationServiceButton, Double, Double, ElementId) | Creates a fabrication part element based on button and size.
 | CreateHanger(Document, FabricationServiceButton, Int32, ElementId) | Creates a free placed hanger.
 | CreateHanger(Document, FabricationServiceButton, ElementId, Connector, Double, Boolean) | Creates a hanger on the fabrication part.
 | CreateHanger(Document, FabricationServiceButton, Int32, ElementId, Connector, Double, Boolean) | Creates a hanger on the fabrication part.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | Flip | Flips the fabrication part that is directionally oriented (tees, crosses, valves, dampers, etc.) to the opposite direction.
Public method | GetCalculatedDimensionValue | Gets the calculated dimension value.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetDimensionCalculatedOptions | Gets the calculated options of the fabrication dimension.
Public method | GetDimensions | Gets all fabrication dimensions.
Public method | GetDimensionValue | Gets the value of the fabrication dimension, returns value in Revit internal units.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetHostedInfo | Gets the fabrication hosted element information.
Public method | GetInsulationLiningGeometry | Gets insulation and lining geometry for this fabrication part.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPartAncillaryUsage | Gets a list of all ancillary usage information for the part.
Public method | GetPartCustomDataInteger | Get custom data integer value for the specified custom data.
Public method | GetPartCustomDataReal | Get custom data real value for the specified custom data.
Public method | GetPartCustomDataText | Get custom data text for the specified custom data.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetProductListEntryCount | Gets the number of product entries for this part.
Public method | GetProductListEntryName | Gets the specified product list entry name.
Public method | GetRodInfo | Gets the fabrication rod information.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTransform | Gets the transformation matrix of the fabrication part element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetVersionHistory | Gets a history of version change information about the current part.
Public method | HasCustomData | Check if fabrication part contains custom data already.
Public method | HasNoConnections | Checks to see if all the fabrication part's connectors are open.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsAHanger | Checks whether it is a hanger.
Public method | IsAStraight | Checks whether it is a straight part.
Public method | IsATap | Checks if it is any sort of tap.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDimensionCalculated | Checks if the fabrication dimension is calculated.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsProductList | Gets whether or not the fabrication part is a product list.
Public method | IsProductListEntryCompatibleSize | Checks to see if this part can be changed to the specified product entry without altering any connected dimensions.
Public method | IsSameAs | Compare this fabrication part with the part passed and checks the pattern dimensions and options. A list of fields that can be ignored in the comparison check can be specified.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
 | OptimizeLengths | Optimizes the length fabrication straight parts.
 | PlaceAsTap | Places the part by its connector to a specific position on the straight part at the specified distance from the host part connector.
 | PlaceFittingAsCutIn | Places the fitting on the straight part by cut in, use the fitting's focal point as the insertion position.
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemovePartCustomData | Remove custom data from the fabrication part.
 | Reposition | Repositions the fabrication straight part to another end of the run.
 | RotateConnectedPartByConnector | Rotates a connected fabrication part around the axis of the specified connector.
 | RotateConnectedTap | Rotates a connected fabrication tap by the specified angles about the primary and secondary axis.
 | SaveAsFabricationJob | Save fabrication parts to an MEP job that can be opened in the fabrication software.
Public method | SetCalculatedDimensionValue | Sets the calculated dimension value.
Public method | SetDimensionValue | Sets the fabrication dimension value. The value is in Revit internal units.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetPartCustomDataInteger | Set the custom data integer value for the specified custom data.
Public method | SetPartCustomDataReal | Set the custom data real value for the specified custom data.
Public method | SetPartCustomDataText | Set the custom data real value for the specified custom data.
Public method | SetPositionByEnd | Positions the connector of the fabrication part element by the passed point.
Public method | SplitStraight(XYZ) | Splits the straight into two at the passed in point.
Public method | SplitStraight(Document, ElementId, XYZ) | Splits the straight into two at the passed in point.
 | StretchAndFit | Stretch the fabrication part from the specified connector and fit to the target routing end.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FabricationPart Class


FabricationPart.AddPartCustomData Method

FabricationPartAddPartCustomData Method

Add custom data type to the fabrication part. The new data gets the default value defined by the fabrication configuration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AddPartCustomData(
    int customId
)
Public Function AddPartCustomData (
    customId As Integer
) As Boolean
public:
bool AddPartCustomData(
    int customId
)
member AddPartCustomData :
        customId : int -> bool

Parameters

customId Int32
The identifier of the custom data field to add.

Return Value

Boolean
Returns true if the type was not already present.
Exceptions
Exception | Condition
ArgumentException | The custom data identifier does not exist.
Remarks
The custom id must be positive.
See Also

Reference

FabricationPart Class


FabricationPart.AdjustEndLength Method

FabricationPartAdjustEndLength Method

Adjusts the length for the specified connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double AdjustEndLength(
    Connector connector,
    double lengthToAdjust,
    bool totalLengthOnly
)
Public Function AdjustEndLength (
    connector As Connector,
    lengthToAdjust As Double,
    totalLengthOnly As Boolean
) As Double
public:
double AdjustEndLength(
    Connector^ connector,
    double lengthToAdjust,
    bool totalLengthOnly
)
member AdjustEndLength :
        connector : Connector *
        lengthToAdjust : float *
        totalLengthOnly : bool -> float

Parameters

connector Connector
# The connector of the fabrication part to adjust length.
lengthToAdjust Double
The length to adjust.
totalLengthOnly Boolean
True if adjust the total length only when adjust length.

Return Value

Double
The adjusted length.
Exceptions
Exception | Condition
ArgumentException | The end of the fabrication part of the connector can not be adjusted. -or- Connector is connected.
ArgumentNullException | A non-optional argument was null
See Also

Reference

FabricationPart Class


FabricationPart.AlignPartByConnector Method

FabricationPartAlignPartByConnector Method

Align the part by its connector to a point and rotation in free space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool AlignPartByConnector(
    Document document,
    Connector connector,
    XYZ position,
    double rotation,
    double rotationPerpendicular,
    double slope,
    FabricationPartJustification justification,
    Transform trf
)
Public Shared Function AlignPartByConnector (
    document As Document,
    connector As Connector,
    position As XYZ,
    rotation As Double,
    rotationPerpendicular As Double,
    slope As Double,
    justification As FabricationPartJustification,
    trf As Transform
) As Boolean
public:
static bool AlignPartByConnector(
    Document^ document,
    Connector^ connector,
    XYZ^ position,
    double rotation,
    double rotationPerpendicular,
    double slope,
    FabricationPartJustification justification,
    Transform^ trf
)
static member AlignPartByConnector :
        document : Document *
        connector : Connector *
        position : XYZ *
        rotation : float *
        rotationPerpendicular : float *
        slope : float *
        justification : FabricationPartJustification *
        trf : Transform -> bool

Parameters

document Document
The document.
connector Connector
The connector to align in free space.
position XYZ
The position to move the connector to.
rotation Double
The rotation in radians.
rotationPerpendicular Double
The perpendicular rotation for free placement around the Y axis direction of connection - angle in radians.
slope Double
The slope value to flex to match if possible in fractional units (eg.1/50). Positive values are up, negative are down. Slopes can only be applied to fittings, whilst straights will inherit the slope from the piece it is connecting to.
justification FabricationPartJustification
The justification to align eccentric parts.
trf Transform
Optional alignment transformation matrix, eg. a Trf that describes plan or side elevation.

Return Value

Boolean
True if the alignment succeeds, false otherwise.
Exceptions
Exception | Condition
ArgumentException | The connector does not belong to a fabrication part. -or- The fabrication part is connected.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

FabricationPart Class


FabricationPart.AlignPartByConnectors Method

FabricationPartAlignPartByConnectors Method

Moves fabrication part by one of its connectors and aligns it to another connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool AlignPartByConnectors(
    Document document,
    Connector connector,
    Connector toConnector,
    double axisRotation
)
Public Shared Function AlignPartByConnectors (
    document As Document,
    connector As Connector,
    toConnector As Connector,
    axisRotation As Double
) As Boolean
public:
static bool AlignPartByConnectors(
    Document^ document,
    Connector^ connector,
    Connector^ toConnector,
    double axisRotation
)
static member AlignPartByConnectors :
        document : Document *
        connector : Connector *
        toConnector : Connector *
        axisRotation : float -> bool

Parameters

document Document
The document.
connector Connector
The connector of the fabrication part to move and align by.
toConnector Connector
The connector of the fabrication part or family to align to.
axisRotation Double
Rotation around the direction of connection - angle between width vectors in radians.

Return Value

Boolean
True if alignment succeeds, false otherwise.
Exceptions
Exception | Condition
ArgumentException | For rectangular and oval parts the axis rotation must be a multiple of PI/2. -or- The connector does not belong to a fabrication part. -or- The fabrication part is connected.
ArgumentNullException | A non-optional argument was null
See Also

Reference

FabricationPart Class


FabricationPart.AlignPartByConnectorToConnector Method

FabricationPartAlignPartByConnectorToConnector Method

Align a part by its connector to another connector. This will replace the FabricationPart::AlignPartByConnectors method.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool AlignPartByConnectorToConnector(
    Document document,
    Connector connector,
    Connector fixedConnector,
    double rotation,
    double slope,
    FabricationPartJustification justification
)
Public Shared Function AlignPartByConnectorToConnector (
    document As Document,
    connector As Connector,
    fixedConnector As Connector,
    rotation As Double,
    slope As Double,
    justification As FabricationPartJustification
) As Boolean
public:
static bool AlignPartByConnectorToConnector(
    Document^ document,
    Connector^ connector,
    Connector^ fixedConnector,
    double rotation,
    double slope,
    FabricationPartJustification justification
)
static member AlignPartByConnectorToConnector :
        document : Document *
        connector : Connector *
        fixedConnector : Connector *
        rotation : float *
        slope : float *
        justification : FabricationPartJustification -> bool

Parameters

document Document
The document.
connector Connector
The connector of the fabrication part to move by in free space.
fixedConnector Connector
The connector for the fabrication part or family connector to align to.
rotation Double
The rotation in radians.
slope Double
The slope value to flex to match if possible in fractional units (eg.1/50). Positive values are up, negative are down. Slopes can only be applied to fittings, whilst straights will inherit the slope from the piece it is connecting to.
justification FabricationPartJustification
The justification to align eccentric parts.

Return Value

Boolean
True if the alignment succeeds, false otherwise and the part will not move from the original position.
Exceptions
Exception | Condition
ArgumentException | For rectangular and oval parts the axis rotation must be a multiple of PI/2. -or- The connector does not belong to a fabrication part. -or- The fabrication part is connected.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

FabricationPart Class


FabricationPart.AlignPartByInsertionPoint Method

FabricationPartAlignPartByInsertionPoint Method

Align the part by its insertion point to a point and rotation in free space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool AlignPartByInsertionPoint(
    Document document,
    ElementId partId,
    XYZ position,
    double rotation,
    double rotationPerpendicular,
    double slope,
    FabricationPartJustification justification,
    Transform trf
)
Public Shared Function AlignPartByInsertionPoint (
    document As Document,
    partId As ElementId,
    position As XYZ,
    rotation As Double,
    rotationPerpendicular As Double,
    slope As Double,
    justification As FabricationPartJustification,
    trf As Transform
) As Boolean
public:
static bool AlignPartByInsertionPoint(
    Document^ document,
    ElementId^ partId,
    XYZ^ position,
    double rotation,
    double rotationPerpendicular,
    double slope,
    FabricationPartJustification justification,
    Transform^ trf
)
static member AlignPartByInsertionPoint :
        document : Document *
        partId : ElementId *
        position : XYZ *
        rotation : float *
        rotationPerpendicular : float *
        slope : float *
        justification : FabricationPartJustification *
        trf : Transform -> bool

Parameters

document Document
The document.
partId ElementId
The element identifier of the part to align.
position XYZ
The position to move the part's insertion point to.
rotation Double
The rotation in radians.
rotationPerpendicular Double
The perpendicular rotation for free placement around the Y axis direction of connection - angle in radians.
slope Double
The slope value to flex to match if possible in fractional units (eg.1/50). Positive values are up, negative are down. Slopes can only be applied to fittings, whilst straights will inherit the slope from the piece it is connecting to.
justification FabricationPartJustification
The justification to align eccentric parts.
trf Transform
Optional alignment transformation matrix, eg. a Trf that describes plan or side elevation.

Return Value

Boolean
True if the alignment succeeds, false otherwise.
Exceptions
Exception | Condition
ArgumentException | The element is not a fabrication part. -or- Not all of the fabrication part's connectors are open.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

FabricationPart Class


FabricationPart.AlignPartByInsertionPointAndCutInToStraight Method

FabricationPartAlignPartByInsertionPointAndCutInToStraight Method

Align the part by its insertion point to a point and rotation on a straight. This will automatically size and connect the part being cut into, if possible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool AlignPartByInsertionPointAndCutInToStraight(
    Document document,
    ElementId straightId,
    ElementId partId,
    XYZ position,
    double rotation,
    double slope,
    bool flip
)
Public Shared Function AlignPartByInsertionPointAndCutInToStraight (
    document As Document,
    straightId As ElementId,
    partId As ElementId,
    position As XYZ,
    rotation As Double,
    slope As Double,
    flip As Boolean
) As Boolean
public:
static bool AlignPartByInsertionPointAndCutInToStraight(
    Document^ document,
    ElementId^ straightId,
    ElementId^ partId,
    XYZ^ position,
    double rotation,
    double slope,
    bool flip
)
static member AlignPartByInsertionPointAndCutInToStraight :
        document : Document *
        straightId : ElementId *
        partId : ElementId *
        position : XYZ *
        rotation : float *
        slope : float *
        flip : bool -> bool

Parameters

document Document
The document.
straightId ElementId
The element identifier of the straight to be cut in to.
partId ElementId
The element identifier of the part to align and cut in with.
position XYZ
The position to move the parts insertion point to.
rotation Double
The rotation in radians.
slope Double
The slope value to flex to match if possible in fractional units (eg.1/50). Positive values are up, negative are down. Slopes can only be applied to fittings, whilst straights will inherit the slope from the piece it is connecting to.
flip Boolean
Flip the part to allow for flow direction.

Return Value

Boolean
True if the alignment succeeds, false otherwise.
Exceptions
Exception | Condition
ArgumentException | The element is not a fabrication part. -or- Not all of the fabrication part's connectors are open. -or- The part is not a straight. -or- The fabrication parts do not have matching domain types. -or- The position is not on the straight.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Failed to align the part to the straight to cut in to.
See Also

Reference

FabricationPart Class


FabricationPart.CanAdjustEndLength Method

FabricationPartCanAdjustEndLength Method

Checks if the end of fabrication part can be adjusted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanAdjustEndLength(
    Connector connector
)
Public Function CanAdjustEndLength (
    connector As Connector
) As Boolean
public:
bool CanAdjustEndLength(
    Connector^ connector
)
member CanAdjustEndLength :
        connector : Connector -> bool

Parameters

connector Connector
The connector of the fabrication part to adjust length.

Return Value

Boolean
True if the end of fabrication part can be adjusted.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FabricationPart Class


FabricationPart.CanASlopeBeApplied Method

FabricationPartCanASlopeBeApplied Method

This will test if a slope can be applied to the part and maintain connections with any connected parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanASlopeBeApplied()
Public Function CanASlopeBeApplied As Boolean
public:
bool CanASlopeBeApplied()
member CanASlopeBeApplied : unit -> bool

Return Value

Boolean
Returns true if the part can be successfully sloped otherwise false.
See Also

Reference

FabricationPart Class


FabricationPart.CanFlipPart Method

FabricationPartCanFlipPart Method

Validates if the fabrication part is one of the supported fabrication part types that can be flipped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanFlipPart()
Public Function CanFlipPart As Boolean
public:
bool CanFlipPart()
member CanFlipPart : unit -> bool

Return Value

Boolean
Returns true if valid otherwise false if the fabrication part cannot be flipped.
See Also

Reference

FabricationPart Class


FabricationPart.CanSplitStraight Method

FabricationPartCanSplitStraight Method

Validates if the straight can be split into two at the passed in point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanSplitStraight(
    XYZ position
)
Public Function CanSplitStraight (
    position As XYZ
) As Boolean
public:
bool CanSplitStraight(
    XYZ^ position
)
member CanSplitStraight :
        position : XYZ -> bool

Parameters

position XYZ
The position to split in the straight.

Return Value

Boolean
Returns true if valid otherwise false if the straight cannot be split.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FabricationPart Class


FabricationPart.ConnectAndCouple Method

FabricationPartConnectAndCouple Method

Makes a connection between the specified connectors and adds coupling if necessary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool ConnectAndCouple(
    Document document,
    Connector connector,
    Connector toConnector
)
Public Shared Function ConnectAndCouple (
    document As Document,
    connector As Connector,
    toConnector As Connector
) As Boolean
public:
static bool ConnectAndCouple(
    Document^ document,
    Connector^ connector,
    Connector^ toConnector
)
static member ConnectAndCouple :
        document : Document *
        connector : Connector *
        toConnector : Connector -> bool

Parameters

document Document
The document.
connector Connector
The connector of the fabrication part.
toConnector Connector
The connector of the fabrication part or family to connect to.

Return Value

Boolean
True if connection succeeded, false otherwise.
Exceptions
Exception | Condition
ArgumentException | The connector does not belong to a fabrication part. -or- The fabrication part connectors are not aligned, call AlignPartByConnectors to align them.
ArgumentNullException | A non-optional argument was null
Remarks
This function does not place and align the fabrication part. Call AlignPartByConnectors before connecting.
See Also

Reference

FabricationPart Class


FabricationPart.Create Method

FabricationPartCreate Method

Overload List
Name | Description
Create(Document, FabricationItemFile, ElementId) | Creates a fabrication part element from a fabrication item file.
Create(Document, FabricationServiceButton, Int32, ElementId) | Creates a fabrication part element based on button.
Create(Document, FabricationServiceButton, Double, Double, ElementId) | Creates a fabrication part element based on button and size.
Top
See Also

Reference

FabricationPart Class


FabricationPart.Create(Document, FabricationItemFile, ElementId) Method

FabricationPartCreate(Document, FabricationItemFile, ElementId) Method

Creates a fabrication part element from a fabrication item file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FabricationPart Create(
    Document document,
    FabricationItemFile itemFile,
    ElementId levelId
)
Public Shared Function Create (
    document As Document,
    itemFile As FabricationItemFile,
    levelId As ElementId
) As FabricationPart
public:
static FabricationPart^ Create(
    Document^ document,
    FabricationItemFile^ itemFile,
    ElementId^ levelId
)
static member Create :
        document : Document *
        itemFile : FabricationItemFile *
        levelId : ElementId -> FabricationPart

Parameters

document Document
The document.
itemFile FabricationItemFile
The fabrication item file.
levelId ElementId
The element identifier associated with the Level the FabricationPart will be created on.

Return Value

FabricationPart
The new fabrication part.
Exceptions
Exception | Condition
ArgumentException | The item file is not valid for use in Revit. -or- The item file has not been loaded into the configuration. -or- The ElementId levelId is not a Level.
ArgumentNullException | A non-optional argument was null
See Also

Reference

FabricationPart Class
Create Overload


FabricationPart.Create(Document, FabricationServiceButton, Int32, ElementId) Method

FabricationPartCreate(Document, FabricationServiceButton, Int32, ElementId) Method

Creates a fabrication part element based on button.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FabricationPart Create(
    Document document,
    FabricationServiceButton button,
    int condition,
    ElementId levelId
)
Public Shared Function Create (
    document As Document,
    button As FabricationServiceButton,
    condition As Integer,
    levelId As ElementId
) As FabricationPart
public:
static FabricationPart^ Create(
    Document^ document,
    FabricationServiceButton^ button,
    int condition,
    ElementId^ levelId
)
static member Create :
        document : Document *
        button : FabricationServiceButton *
        condition : int *
        levelId : ElementId -> FabricationPart

Parameters

document Document
The document.
button FabricationServiceButton
The fabrication service button to use.
condition Int32
The condition index.
levelId ElementId
The element identifier associated with the Level the FabricationPart will be created on.

Return Value

FabricationPart
The new fabrication part.
Exceptions
Exception | Condition
ArgumentException | Fabrication service button contains invalid fittings. -or- Please use FabricationPart.CreateHanger to create fabrication hanger. -or- The ElementId levelId is not a Level.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | The index condition is not larger or equal to 0 and less than ConditionCount.
InvalidOperationException | The fabrication part type does not exist. Reload the service using FabricationConfiguration.LoadServices.
See Also

Reference

FabricationPart Class
Create Overload


FabricationPart.Create(Document, FabricationServiceButton, Double, Double, ElementId) Method

FabricationPartCreate(Document, FabricationServiceButton, Double, Double, ElementId) Method

Creates a fabrication part element based on button and size.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FabricationPart Create(
    Document document,
    FabricationServiceButton button,
    double width,
    double depth,
    ElementId levelId
)
Public Shared Function Create (
    document As Document,
    button As FabricationServiceButton,
    width As Double,
    depth As Double,
    levelId As ElementId
) As FabricationPart
public:
static FabricationPart^ Create(
    Document^ document,
    FabricationServiceButton^ button,
    double width,
    double depth,
    ElementId^ levelId
)
static member Create :
        document : Document *
        button : FabricationServiceButton *
        width : float *
        depth : float *
        levelId : ElementId -> FabricationPart

Parameters

document Document
The document.
button FabricationServiceButton
The fabrication service button to use. Matches button condition based on the specified size.
width Double
The width of the part. Units are in feet (ft).
depth Double
The depth of the part. Units are in feet (ft). It should be equal to width for round part.
levelId ElementId
The element identifier associated with the Level the FabricationPart will be created on.

Return Value

FabricationPart
The new fabrication part.
Exceptions
Exception | Condition
ArgumentException | Fabrication service button contains invalid fittings. -or- Please use FabricationPart.CreateHanger to create fabrication hanger. -or- The ElementId levelId is not a Level.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The fabrication part type does not exist. Reload the service using FabricationConfiguration.LoadServices. -or- failing to match a button condition based on specific size.
See Also

Reference

FabricationPart Class
Create Overload


FabricationPart.CreateHanger Method

FabricationPartCreateHanger Method

Overload List
Name | Description
CreateHanger(Document, FabricationServiceButton, Int32, ElementId) | Creates a free placed hanger.
CreateHanger(Document, FabricationServiceButton, ElementId, Connector, Double, Boolean) | Creates a hanger on the fabrication part.
CreateHanger(Document, FabricationServiceButton, Int32, ElementId, Connector, Double, Boolean) | Creates a hanger on the fabrication part.
Top
See Also

Reference

FabricationPart Class


FabricationPart.CreateHanger(Document, FabricationServiceButton, Int32, ElementId) Method

FabricationPartCreateHanger(Document, FabricationServiceButton, Int32, ElementId) Method

Creates a free placed hanger.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FabricationPart CreateHanger(
    Document document,
    FabricationServiceButton button,
    int condition,
    ElementId levelId
)
Public Shared Function CreateHanger (
    document As Document,
    button As FabricationServiceButton,
    condition As Integer,
    levelId As ElementId
) As FabricationPart
public:
static FabricationPart^ CreateHanger(
    Document^ document,
    FabricationServiceButton^ button,
    int condition,
    ElementId^ levelId
)
static member CreateHanger :
        document : Document *
        button : FabricationServiceButton *
        condition : int *
        levelId : ElementId -> FabricationPart

Parameters

document Document
The document.
button FabricationServiceButton
The fabrication service button to use.
condition Int32
The condition index. If the button has multiple conditions.
levelId ElementId
The level identifier associated with the level.

Return Value

FabricationPart
The newly-created fabrication hanger.
Exceptions
Exception | Condition
ArgumentException | Invalid fabrication service button.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | The index condition is not larger or equal to 0 and less than ConditionCount.
See Also

Reference

FabricationPart Class
CreateHanger Overload


FabricationPart.CreateHanger(Document, FabricationServiceButton, ElementId, Connector, Double, Boolean) Method

FabricationPartCreateHanger(Document, FabricationServiceButton, ElementId, Connector, Double, Boolean) Method

Creates a hanger on the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FabricationPart CreateHanger(
    Document document,
    FabricationServiceButton button,
    ElementId hostId,
    Connector hostConnector,
    double distance,
    bool attachToStructure
)
Public Shared Function CreateHanger (
    document As Document,
    button As FabricationServiceButton,
    hostId As ElementId,
    hostConnector As Connector,
    distance As Double,
    attachToStructure As Boolean
) As FabricationPart
public:
static FabricationPart^ CreateHanger(
    Document^ document,
    FabricationServiceButton^ button,
    ElementId^ hostId,
    Connector^ hostConnector,
    double distance,
    bool attachToStructure
)
static member CreateHanger :
        document : Document *
        button : FabricationServiceButton *
        hostId : ElementId *
        hostConnector : Connector *
        distance : float *
        attachToStructure : bool -> FabricationPart

Parameters

document Document
The document.
button FabricationServiceButton
The fabrication service button to use. It finds the matching condition automatically if the button has multiple condition.
hostId ElementId
The host part id. The host should be one horizontal straight part.
hostConnector Connector
The connector of the host.
distance Double
The distance from the input connector of the host part. Units are in feet (ft).
attachToStructure Boolean
Attach to the nearest structural element. The structural element might be one of Floor/Roof/Stair/Structure Framing.

Return Value

FabricationPart
The newly-created fabrication hanger.
Exceptions
Exception | Condition
ArgumentException | Hangers may only be placed on straight horizontal fabrication segments and some kind of fittings. -or- Invalid fabrication service button. -or- The distance is out of range.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | cannot place hanger on the host.
See Also

Reference

FabricationPart Class
CreateHanger Overload


FabricationPart.CreateHanger(Document, FabricationServiceButton, Int32, ElementId, Connector, Double, Boolean) Method

FabricationPartCreateHanger(Document, FabricationServiceButton, Int32, ElementId, Connector, Double, Boolean) Method

Creates a hanger on the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FabricationPart CreateHanger(
    Document document,
    FabricationServiceButton button,
    int condition,
    ElementId hostId,
    Connector hostConnector,
    double distance,
    bool attachToStructure
)
Public Shared Function CreateHanger (
    document As Document,
    button As FabricationServiceButton,
    condition As Integer,
    hostId As ElementId,
    hostConnector As Connector,
    distance As Double,
    attachToStructure As Boolean
) As FabricationPart
public:
static FabricationPart^ CreateHanger(
    Document^ document,
    FabricationServiceButton^ button,
    int condition,
    ElementId^ hostId,
    Connector^ hostConnector,
    double distance,
    bool attachToStructure
)
static member CreateHanger :
        document : Document *
        button : FabricationServiceButton *
        condition : int *
        hostId : ElementId *
        hostConnector : Connector *
        distance : float *
        attachToStructure : bool -> FabricationPart

Parameters

document Document
The document.
button FabricationServiceButton
The fabrication service button to use.
condition Int32
The condition index. If the button has multiple conditions.
hostId ElementId
The host part id. The host should be one horizontal straight part.
hostConnector Connector
The connector of the host.
distance Double
The distance from the input connector of the host part. Units are in feet (ft).
attachToStructure Boolean
Attach to the nearest structural element. The structural element might be one of Floor/Roof/Stair/Structural Framing.

Return Value

FabricationPart
The newly-created fabrication hanger.
Exceptions
Exception | Condition
ArgumentException | Hangers may only be placed on straight horizontal fabrication segments and some kind of fittings. -or- Invalid fabrication service button.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | The index condition is not larger or equal to 0 and less than ConditionCount.
InvalidOperationException | the distance is out of range. -or- cannot find suitable fabrication part for the host. -or- cannot place hanger on the host.
See Also

Reference

FabricationPart Class
CreateHanger Overload


FabricationPart.Flip Method

FabricationPartFlip Method

Flips the fabrication part that is directionally oriented (tees, crosses, valves, dampers, etc.) to the opposite direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Flip()
Public Function Flip As Boolean
public:
bool Flip()
member Flip : unit -> bool

Return Value

Boolean
Returns true if successful otherwise false if the fabrication part cannot be flipped.
Exceptions
Exception | Condition
InvalidOperationException | It is not a valid part that can be flipped.
Remarks
Existing connections will be maintained, disconnect warnings will be posted if the connection cannot be maintained.
See Also

Reference

FabricationPart Class


FabricationPart.GetCalculatedDimensionValue Method

FabricationPartGetCalculatedDimensionValue Method

Gets the calculated dimension value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetCalculatedDimensionValue(
    FabricationDimensionDefinition dim
)
Public Function GetCalculatedDimensionValue (
    dim As FabricationDimensionDefinition
) As String
public:
String^ GetCalculatedDimensionValue(
    FabricationDimensionDefinition^ dim
)
member GetCalculatedDimensionValue :
        dim : FabricationDimensionDefinition -> string

Parameters

dim FabricationDimensionDefinition
The fabrication dimension.

Return Value

String
The calculated dimension value.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FabricationPart Class


FabricationPart.GetDimensionCalculatedOptions Method

FabricationPartGetDimensionCalculatedOptions Method

Gets the calculated options of the fabrication dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<string> GetDimensionCalculatedOptions(
    FabricationDimensionDefinition dim
)
Public Function GetDimensionCalculatedOptions (
    dim As FabricationDimensionDefinition
) As IList(Of String)
public:
IList<String^>^ GetDimensionCalculatedOptions(
    FabricationDimensionDefinition^ dim
)
member GetDimensionCalculatedOptions :
        dim : FabricationDimensionDefinition -> IList<string>

Parameters

dim FabricationDimensionDefinition
The fabrication dimension.

Return Value

IList String
The calculated options of the fabrication dimension.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FabricationPart Class


FabricationPart.GetDimensions Method

FabricationPartGetDimensions Method

Gets all fabrication dimensions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<FabricationDimensionDefinition> GetDimensions()
Public Function GetDimensions As IList(Of FabricationDimensionDefinition)
public:
IList<FabricationDimensionDefinition^>^ GetDimensions()
member GetDimensions : unit -> IList<FabricationDimensionDefinition>

Return Value

IList FabricationDimensionDefinition
Returns an array of fabrication dimensions.
See Also

Reference

FabricationPart Class


FabricationPart.GetDimensionValue Method

FabricationPartGetDimensionValue Method

Gets the value of the fabrication dimension, returns value in Revit internal units.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetDimensionValue(
    FabricationDimensionDefinition dim
)
Public Function GetDimensionValue (
    dim As FabricationDimensionDefinition
) As Double
public:
double GetDimensionValue(
    FabricationDimensionDefinition^ dim
)
member GetDimensionValue :
        dim : FabricationDimensionDefinition -> float

Parameters

dim FabricationDimensionDefinition
The fabrication dimension.

Return Value

Double
The dimension value.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FabricationPart Class


FabricationPart.GetHostedInfo Method

FabricationPartGetHostedInfo Method

Gets the fabrication hosted element information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FabricationHostedInfo GetHostedInfo()
Public Function GetHostedInfo As FabricationHostedInfo
public:
FabricationHostedInfo^ GetHostedInfo()
member GetHostedInfo : unit -> FabricationHostedInfo

Return Value

FabricationHostedInfo
The fabrication hosted element information. Returns null if the fabrication part does not have a host.
See Also

Reference

FabricationPart Class


FabricationPart.GetInsulationLiningGeometry Method

FabricationPartGetInsulationLiningGeometry Method

Gets insulation and lining geometry for this fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GeometryElement GetInsulationLiningGeometry()
Public Function GetInsulationLiningGeometry As GeometryElement
public:
GeometryElement^ GetInsulationLiningGeometry()
member GetInsulationLiningGeometry : unit -> GeometryElement

Return Value

GeometryElement
Returns any insulation and liner geometry.
See Also

Reference

FabricationPart Class


FabricationPart.GetPartAncillaryUsage Method

FabricationPartGetPartAncillaryUsage Method

Gets a list of all ancillary usage information for the part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<FabricationAncillaryUsage> GetPartAncillaryUsage()
Public Function GetPartAncillaryUsage As IList(Of FabricationAncillaryUsage)
public:
IList<FabricationAncillaryUsage^>^ GetPartAncillaryUsage()
member GetPartAncillaryUsage : unit -> IList<FabricationAncillaryUsage>

Return Value

IList FabricationAncillaryUsage
Returns array of usage information, one per unique type of ancillary used.
See Also

Reference

FabricationPart Class


FabricationPart.GetPartCustomDataInteger Method

FabricationPartGetPartCustomDataInteger Method

Get custom data integer value for the specified custom data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetPartCustomDataInteger(
    int customId
)
Public Function GetPartCustomDataInteger (
    customId As Integer
) As Integer
public:
int GetPartCustomDataInteger(
    int customId
)
member GetPartCustomDataInteger :
        customId : int -> int

Parameters

customId Int32
The identifier of the custom data field to get.

Return Value

Int32
Returns the integer of the custom data. If the data is not a number it will return 0.
Exceptions
Exception | Condition
ArgumentException | The custom data does not exist on the part.
See Also

Reference

FabricationPart Class


FabricationPart.GetPartCustomDataReal Method

FabricationPartGetPartCustomDataReal Method

Get custom data real value for the specified custom data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetPartCustomDataReal(
    int customId
)
Public Function GetPartCustomDataReal (
    customId As Integer
) As Double
public:
double GetPartCustomDataReal(
    int customId
)
member GetPartCustomDataReal :
        customId : int -> float

Parameters

customId Int32
The identifier of the custom data field to get.

Return Value

Double
Returns the real number of the custom data. If the data is not a number it will return 0.0.
Exceptions
Exception | Condition
ArgumentException | The custom data does not exist on the part.
See Also

Reference

FabricationPart Class


FabricationPart.GetPartCustomDataText Method

FabricationPartGetPartCustomDataText Method

Get custom data text for the specified custom data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetPartCustomDataText(
    int customId
)
Public Function GetPartCustomDataText (
    customId As Integer
) As String
public:
String^ GetPartCustomDataText(
    int customId
)
member GetPartCustomDataText :
        customId : int -> string

Parameters

customId Int32
The identifier of the custom data field to get.

Return Value

String
Returns the text of the custom data. If the data is a number it will be formatted according to the fabrication configuration's rules.
Exceptions
Exception | Condition
ArgumentException | The custom data does not exist on the part.
See Also

Reference

FabricationPart Class


FabricationPart.GetProductListEntryCount Method

FabricationPartGetProductListEntryCount Method

Gets the number of product entries for this part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetProductListEntryCount()
Public Function GetProductListEntryCount As Integer
public:
int GetProductListEntryCount()
member GetProductListEntryCount : unit -> int

Return Value

Int32
Returns the number of product entries.
See Also

Reference

FabricationPart Class


FabricationPart.GetProductListEntryName Method

FabricationPartGetProductListEntryName Method

Gets the specified product list entry name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetProductListEntryName(
    int index
)
Public Function GetProductListEntryName (
    index As Integer
) As String
public:
String^ GetProductListEntryName(
    int index
)
member GetProductListEntryName :
        index : int -> string

Parameters

index Int32
The product entry index.

Return Value

String
Returns the specified product entry name.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The product entry index is not larger than 0 and less than GetProductCount.
See Also

Reference

FabricationPart Class


FabricationPart.GetRodInfo Method

FabricationPartGetRodInfo Method

Gets the fabrication rod information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FabricationRodInfo GetRodInfo()
Public Function GetRodInfo As FabricationRodInfo
public:
FabricationRodInfo^ GetRodInfo()
member GetRodInfo : unit -> FabricationRodInfo

Return Value

FabricationRodInfo
The fabrication rod information. Returns null if the fabrication part does not have any rod.
See Also

Reference

FabricationPart Class


FabricationPart.GetTransform Method

FabricationPartGetTransform Method

Gets the transformation matrix of the fabrication part element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Transform GetTransform()
Public Function GetTransform As Transform
public:
Transform^ GetTransform()
member GetTransform : unit -> Transform

Return Value

Transform
The transformation matrix of the fabrication part element.
See Also

Reference

FabricationPart Class


FabricationPart.GetVersionHistory Method

FabricationPartGetVersionHistory Method

Gets a history of version change information about the current part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<FabricationVersionInfo> GetVersionHistory()
Public Function GetVersionHistory As IList(Of FabricationVersionInfo)
public:
IList<FabricationVersionInfo^>^ GetVersionHistory()
member GetVersionHistory : unit -> IList<FabricationVersionInfo>

Return Value

IList FabricationVersionInfo
A list of version information about the current part. The list starts with the most recent changes.
See Also

Reference

FabricationPart Class


FabricationPart.HasCustomData Method

FabricationPartHasCustomData Method

Check if fabrication part contains custom data already.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasCustomData(
    int customId
)
Public Function HasCustomData (
    customId As Integer
) As Boolean
public:
bool HasCustomData(
    int customId
)
member HasCustomData :
        customId : int -> bool

Parameters

customId Int32
The identifier of the custom data field to look for.

Return Value

Boolean
Returns true if the fabrication part contains the custom data.
See Also

Reference

FabricationPart Class


FabricationPart.HasNoConnections Method

FabricationPartHasNoConnections Method

Checks to see if all the fabrication part's connectors are open.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasNoConnections()
Public Function HasNoConnections As Boolean
public:
bool HasNoConnections()
member HasNoConnections : unit -> bool

Return Value

Boolean
Returns true if the part has zero connections.
See Also

Reference

FabricationPart Class


FabricationPart.IsAHanger Method

FabricationPartIsAHanger Method

Checks whether it is a hanger.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsAHanger()
Public Function IsAHanger As Boolean
public:
bool IsAHanger()
member IsAHanger : unit -> bool

Return Value

Boolean
True if the part is a hanger. False otherwise.
See Also

Reference

FabricationPart Class


FabricationPart.IsAStraight Method

FabricationPartIsAStraight Method

Checks whether it is a straight part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsAStraight()
Public Function IsAStraight As Boolean
public:
bool IsAStraight()
member IsAStraight : unit -> bool

Return Value

Boolean
True if the part is a straight part. False otherwise.
See Also

Reference

FabricationPart Class


FabricationPart.IsATap Method

FabricationPartIsATap Method

Checks if it is any sort of tap.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsATap()
Public Function IsATap As Boolean
public:
bool IsATap()
member IsATap : unit -> bool

Return Value

Boolean
True if it is any sort of tap.
See Also

Reference

FabricationPart Class


FabricationPart.IsDimensionCalculated Method

FabricationPartIsDimensionCalculated Method

Checks if the fabrication dimension is calculated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsDimensionCalculated(
    FabricationDimensionDefinition dim
)
Public Function IsDimensionCalculated (
    dim As FabricationDimensionDefinition
) As Boolean
public:
bool IsDimensionCalculated(
    FabricationDimensionDefinition^ dim
)
member IsDimensionCalculated :
        dim : FabricationDimensionDefinition -> bool

Parameters

dim FabricationDimensionDefinition
The fabrication dimension.

Return Value

Boolean
True if the fabrication dimension is calculated.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FabricationPart Class


FabricationPart.IsProductList Method

FabricationPartIsProductList Method

Gets whether or not the fabrication part is a product list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsProductList()
Public Function IsProductList As Boolean
public:
bool IsProductList()
member IsProductList : unit -> bool

Return Value

Boolean
Returns true if the fabrication part is a product list.
Exceptions
Exception | Condition
InvalidOperationException | the fabrication part is not a product list.
See Also

Reference

FabricationPart Class


FabricationPart.IsProductListEntryCompatibleSize Method

FabricationPartIsProductListEntryCompatibleSize Method

Checks to see if this part can be changed to the specified product entry without altering any connected dimensions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsProductListEntryCompatibleSize(
    int productEntry
)
Public Function IsProductListEntryCompatibleSize (
    productEntry As Integer
) As Boolean
public:
bool IsProductListEntryCompatibleSize(
    int productEntry
)
member IsProductListEntryCompatibleSize :
        productEntry : int -> bool

Parameters

productEntry Int32
The product entry index.

Return Value

Boolean
Returns true if the part can be changed to the specified product entry without altering any connected dimensions.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The product entry index is not larger than 0 and less than GetProductCount.
See Also

Reference

FabricationPart Class


FabricationPart.IsSameAs Method

FabricationPartIsSameAs Method

Compare this fabrication part with the part passed and checks the pattern dimensions and options. A list of fields that can be ignored in the comparison check can be specified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSameAs(
    FabricationPart part,
    IList<FabricationPartCompareType> ignoreFields
)
Public Function IsSameAs (
    part As FabricationPart,
    ignoreFields As IList(Of FabricationPartCompareType)
) As Boolean
public:
bool IsSameAs(
    FabricationPart^ part,
    IList<FabricationPartCompareType>^ ignoreFields
)
member IsSameAs :
        part : FabricationPart *
        ignoreFields : IList<FabricationPartCompareType> -> bool

Parameters

part FabricationPart
The part to compare this part with.
ignoreFields IList FabricationPartCompareType
Array of types of data to ignore from the comparison check.

Return Value

Boolean
Returns true if the fabrication parts are the same.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FabricationPart Class


FabricationPart.OptimizeLengths Method

FabricationPartOptimizeLengths Method

Optimizes the length fabrication straight parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ISet<ElementId> OptimizeLengths(
    Document document,
    ISet<ElementId> partIds
)
Public Shared Function OptimizeLengths (
    document As Document,
    partIds As ISet(Of ElementId)
) As ISet(Of ElementId)
public:
static ISet<ElementId^>^ OptimizeLengths(
    Document^ document,
    ISet<ElementId^>^ partIds
)
static member OptimizeLengths :
        document : Document *
        partIds : ISet<ElementId> -> ISet<ElementId>

Parameters

document Document
The document.
partIds ISet ElementId
The identifiers of the fabrication parts in a selected fabrication part run.

Return Value

ISet ElementId
New and modified fabrication part ids in the optimize
Exceptions
Exception | Condition
ArgumentException | There are no straight parts to optimize, or all parts are locked or locked by group membership.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | this operation failed.
See Also

Reference

FabricationPart Class


FabricationPart.PlaceAsTap Method

FabricationPartPlaceAsTap Method

Places the part by its connector to a specific position on the straight part at the specified distance from the host part connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void PlaceAsTap(
    Document document,
    Connector tapPartConnector,
    Connector hostPartConnector,
    double distance,
    double axisRotation,
    double secondaryAxisRotation
)
Public Shared Sub PlaceAsTap (
    document As Document,
    tapPartConnector As Connector,
    hostPartConnector As Connector,
    distance As Double,
    axisRotation As Double,
    secondaryAxisRotation As Double
)
public:
static void PlaceAsTap(
    Document^ document,
    Connector^ tapPartConnector,
    Connector^ hostPartConnector,
    double distance,
    double axisRotation,
    double secondaryAxisRotation
)
static member PlaceAsTap :
        document : Document *
        tapPartConnector : Connector *
        hostPartConnector : Connector *
        distance : float *
        axisRotation : float *
        secondaryAxisRotation : float -> unit

Parameters

document Document
The document.
tapPartConnector Connector
The connector of the part to place.
hostPartConnector Connector
The connector of host part.
distance Double
The distance to host part connector where to place the part.
axisRotation Double
The axis rotation in radians.
secondaryAxisRotation Double
The secondary axis rotation in radians.
Exceptions
Exception | Condition
ArgumentException | It is not a valid part to place as tap. -or- Tap should be placed on straight part. -or- The distance is out of range. -or- For rectangular and oval parts the axis rotation must be a multiple of PI/2. -or- Invalid tap for host's profile type. -or- The fabrication part is connected.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | tap is not connected by its primary connector.
[!:Autodesk::Revit::Exceptions::InvalidOpertationException] | tap does not fit on the host.
Remarks
Tap cannot be placed if it is already connected.
See Also

Reference

FabricationPart Class


FabricationPart.PlaceFittingAsCutIn Method

FabricationPartPlaceFittingAsCutIn Method

Places the fitting on the straight part by cut in, use the fitting's focal point as the insertion position.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool PlaceFittingAsCutIn(
    Document document,
    ElementId straightId,
    ElementId fittingId,
    XYZ position,
    Connector fittingConnector,
    double axisRotation
)
Public Shared Function PlaceFittingAsCutIn (
    document As Document,
    straightId As ElementId,
    fittingId As ElementId,
    position As XYZ,
    fittingConnector As Connector,
    axisRotation As Double
) As Boolean
public:
static bool PlaceFittingAsCutIn(
    Document^ document,
    ElementId^ straightId,
    ElementId^ fittingId,
    XYZ^ position,
    Connector^ fittingConnector,
    double axisRotation
)
static member PlaceFittingAsCutIn :
        document : Document *
        straightId : ElementId *
        fittingId : ElementId *
        position : XYZ *
        fittingConnector : Connector *
        axisRotation : float -> bool

Parameters

document Document
The document.
straightId ElementId
Identifier of the straight to be cut in.
fittingId ElementId
Identifier of the fitting to cut in.
position XYZ
The position to cut in the straight.
fittingConnector Connector
The connector of the fitting to align with the primary connector of the straight part.
axisRotation Double
Rotation around the direction of connection - angle between width vectors in radians.

Return Value

Boolean
True if cuts in successful.
Exceptions
Exception | Condition
ArgumentException | For rectangular and oval parts the axis rotation must be a multiple of PI/2. -or- The fitting connector is not a connector of the fitting. -or- The fitting connector is not valid, it is not within a pair connector for cutting in.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Failed to align fitting to the straight to cut in. -or- There is no enough room in the run for cut in.
See Also

Reference

FabricationPart Class


FabricationPart.RemovePartCustomData Method

FabricationPartRemovePartCustomData Method

Remove custom data from the fabrication part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool RemovePartCustomData(
    int customId
)
Public Function RemovePartCustomData (
    customId As Integer
) As Boolean
public:
bool RemovePartCustomData(
    int customId
)
member RemovePartCustomData :
        customId : int -> bool

Parameters

customId Int32
The identifier of the custom data field to remove.

Return Value

Boolean
Returns true if the type was found and removed. The type will not be removed if it is not an optional type.
Exceptions
Exception | Condition
ArgumentException | The custom data does not exist on the part.
See Also

Reference

FabricationPart Class


FabricationPart.Reposition Method

FabricationPartReposition Method

Repositions the fabrication straight part to another end of the run.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void Reposition(
    Document document,
    ElementId partId
)
Public Shared Sub Reposition (
    document As Document,
    partId As ElementId
)
public:
static void Reposition(
    Document^ document,
    ElementId^ partId
)
static member Reposition :
        document : Document *
        partId : ElementId -> unit

Parameters

document Document
The document.
partId ElementId
Identifier of the fabrication part to reposition.
Exceptions
Exception | Condition
ArgumentException | It is not a straight segment on the end in the run. -or- There are locked parts in the run.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | this operation failed.
See Also

Reference

FabricationPart Class


FabricationPart.RotateConnectedPartByConnector Method

FabricationPartRotateConnectedPartByConnector Method

Rotates a connected fabrication part around the axis of the specified connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void RotateConnectedPartByConnector(
    Document document,
    Connector connector,
    double axisRotationBy
)
Public Shared Sub RotateConnectedPartByConnector (
    document As Document,
    connector As Connector,
    axisRotationBy As Double
)
public:
static void RotateConnectedPartByConnector(
    Document^ document,
    Connector^ connector,
    double axisRotationBy
)
static member RotateConnectedPartByConnector :
        document : Document *
        connector : Connector *
        axisRotationBy : float -> unit

Parameters

document Document
The document.
connector Connector
The connected connector of the fabrication part to be rotated.
axisRotationBy Double
The angle in radians to rotate by.
Exceptions
Exception | Condition
ArgumentException | For rectangular and oval parts the axis rotation must be a multiple of PI/2. -or- The connector does not belong to a fabrication part. -or- Connector is not connected. -or- Connector belongs to a fabrication part tap. -or- Fabrication part cannot be rotated because it is either unable to be re-sized or it is too constrained.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | rotate failed because the fabrication part geometry could not be modified accordingly.
Remarks
Attempts to resize rectangular and oval ends if the angle is a multiple of PI/2. Taps cannot be rotated. For rectangular and oval profiles only 90, 180 and 270 degree rotations are valid.
See Also

Reference

FabricationPart Class


FabricationPart.RotateConnectedTap Method

FabricationPartRotateConnectedTap Method

Rotates a connected fabrication tap by the specified angles about the primary and secondary axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void RotateConnectedTap(
    Document document,
    FabricationPart tap,
    double primaryAxisRotateBy,
    double secondaryAxisRotateBy
)
Public Shared Sub RotateConnectedTap (
    document As Document,
    tap As FabricationPart,
    primaryAxisRotateBy As Double,
    secondaryAxisRotateBy As Double
)
public:
static void RotateConnectedTap(
    Document^ document,
    FabricationPart^ tap,
    double primaryAxisRotateBy,
    double secondaryAxisRotateBy
)
static member RotateConnectedTap :
        document : Document *
        tap : FabricationPart *
        primaryAxisRotateBy : float *
        secondaryAxisRotateBy : float -> unit

Parameters

document Document
The document.
tap FabricationPart
The connected fabrication part tap to rotate.
primaryAxisRotateBy Double
The primary axis rotation angle in radians to rotate by.
secondaryAxisRotateBy Double
The secondary axis rotation angle in radians to rotate by.
Exceptions
Exception | Condition
ArgumentException | Is not connected as a fabrication part tap. -or- tap cannot be rotated about the primary axis by the specified angle: primaryAxisRotateBy -or- tap cannot be rotated about the secondary axis by the specified angle: secondaryAxisRotateBy
ArgumentNullException | A non-optional argument was null
See Also

Reference

FabricationPart Class


FabricationPart.SaveAsFabricationJob Method

FabricationPartSaveAsFabricationJob Method

Save fabrication parts to an MEP job that can be opened in the fabrication software.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ISet<ElementId> SaveAsFabricationJob(
    Document document,
    ISet<ElementId> ids,
    string filename,
    FabricationSaveJobOptions saveOptions
)
Public Shared Function SaveAsFabricationJob (
    document As Document,
    ids As ISet(Of ElementId),
    filename As String,
    saveOptions As FabricationSaveJobOptions
) As ISet(Of ElementId)
public:
static ISet<ElementId^>^ SaveAsFabricationJob(
    Document^ document,
    ISet<ElementId^>^ ids,
    String^ filename,
    FabricationSaveJobOptions^ saveOptions
)
static member SaveAsFabricationJob :
        document : Document *
        ids : ISet<ElementId> *
        filename : string *
        saveOptions : FabricationSaveJobOptions -> ISet<ElementId>

Parameters

document Document
The document.
ids ISet ElementId
List of element Ids of fabrication parts or assemblies and group elements that contain fabrication parts to save. Non-fabrication part elements will be ignored.
filename String
The full path and filename of the fabrication job to save.
saveOptions FabricationSaveJobOptions
Options for the save operation.

Return Value

ISet ElementId
Returns a list of fabrication part element Ids that were saved to the fabrication job.
Exceptions
Exception | Condition
ArgumentException | Fabrication configuration is missing.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | the path to the filename must already exist and be writeable
InvalidPathArgumentException | The destination file name includes one or more invalid characters.
Remarks
Only fabrication MAJ files are supported.
See Also

Reference

FabricationPart Class


FabricationPart.SetCalculatedDimensionValue Method

FabricationPartSetCalculatedDimensionValue Method

Sets the calculated dimension value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetCalculatedDimensionValue(
    FabricationDimensionDefinition dim,
    string value
)
Public Sub SetCalculatedDimensionValue (
    dim As FabricationDimensionDefinition,
    value As String
)
public:
void SetCalculatedDimensionValue(
    FabricationDimensionDefinition^ dim,
    String^ value
)
member SetCalculatedDimensionValue :
        dim : FabricationDimensionDefinition *
        value : string -> unit

Parameters

dim FabricationDimensionDefinition
The fabrication dimension.
value String
The calculated dimension value.
Exceptions
Exception | Condition
ArgumentException | value is not a valid calculated fabrication dimension value. -or- fabrication dimension is unable to be modified because it is locked or from a product list. -or- the fabrication dimension is unable to be modified because it will affect the geometry of a connected end.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | the fabrication dimension is unable to be modified because the fabrication part is connected to more than one object. -or- the fabrication dimension cannot be set to the option: value.
Remarks
Multiple dimensions may need to be set in order to reach the desired outcome. The document must be regenerated before the fabrication part can be used. Check ValidationStatus after regeneration to see if the part is valid for fabrication.
See Also

Reference

FabricationPart Class


FabricationPart.SetDimensionValue Method

FabricationPartSetDimensionValue Method

Sets the fabrication dimension value. The value is in Revit internal units.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetDimensionValue(
    FabricationDimensionDefinition dim,
    double newValue
)
Public Sub SetDimensionValue (
    dim As FabricationDimensionDefinition,
    newValue As Double
)
public:
void SetDimensionValue(
    FabricationDimensionDefinition^ dim,
    double newValue
)
member SetDimensionValue :
        dim : FabricationDimensionDefinition *
        newValue : float -> unit

Parameters

dim FabricationDimensionDefinition
The fabrication dimension.
newValue Double
The dimension value.
Exceptions
Exception | Condition
ArgumentException | fabrication dimension is unable to be modified because it is locked or from a product list. -or- the fabrication dimension is unable to be modified because it will affect the geometry of a connected end.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | the fabrication dimension is unable to be modified because the fabrication part is connected to more than one object. -or- the fabrication dimension cannot be set to the value: newValue.
Remarks
Multiple dimensions may need to be set in order to reach the desired outcome. The document must be regenerated before the fabrication part can be used. Check ValidationStatus after regeneration to see if the part is valid for fabrication.
See Also

Reference

FabricationPart Class


FabricationPart.SetPartCustomDataInteger Method

FabricationPartSetPartCustomDataInteger Method

Set the custom data integer value for the specified custom data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetPartCustomDataInteger(
    int customId,
    int value
)
Public Sub SetPartCustomDataInteger (
    customId As Integer,
    value As Integer
)
public:
void SetPartCustomDataInteger(
    int customId,
    int value
)
member SetPartCustomDataInteger :
        customId : int *
        value : int -> unit

Parameters

customId Int32
The identifier of the custom data field to set.
value Int32
The integer value of the custom data. If the data is not an integer type the value will be parsed according to the fabrication confifuration rules.
Exceptions
Exception | Condition
ArgumentException | The custom data does not exist on the part.
See Also

Reference

FabricationPart Class


FabricationPart.SetPartCustomDataReal Method

FabricationPartSetPartCustomDataReal Method

Set the custom data real value for the specified custom data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetPartCustomDataReal(
    int customId,
    double value
)
Public Sub SetPartCustomDataReal (
    customId As Integer,
    value As Double
)
public:
void SetPartCustomDataReal(
    int customId,
    double value
)
member SetPartCustomDataReal :
        customId : int *
        value : float -> unit

Parameters

customId Int32
The identifier of the custom data field to set.
value Double
The real value of the custom data. If the data is not a real type the value will be parsed according to the fabrication confifuration rules.
Exceptions
Exception | Condition
ArgumentException | The custom data does not exist on the part.
See Also

Reference

FabricationPart Class


FabricationPart.SetPartCustomDataText Method

FabricationPartSetPartCustomDataText Method

Set the custom data real value for the specified custom data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetPartCustomDataText(
    int customId,
    string value
)
Public Sub SetPartCustomDataText (
    customId As Integer,
    value As String
)
public:
void SetPartCustomDataText(
    int customId,
    String^ value
)
member SetPartCustomDataText :
        customId : int *
        value : string -> unit

Parameters

customId Int32
The identifier of the custom data field to set.
value String
The text value of the custom data. If the data is not a text type the value will be parsed according to the fabrication confifuration rules.
Exceptions
Exception | Condition
ArgumentException | The custom data does not exist on the part.
ArgumentNullException | A non-optional argument was null
See Also

Reference

FabricationPart Class


FabricationPart.SetPositionByEnd Method

FabricationPartSetPositionByEnd Method

Positions the connector of the fabrication part element by the passed point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetPositionByEnd(
    Connector connector,
    XYZ position
)
Public Sub SetPositionByEnd (
    connector As Connector,
    position As XYZ
)
public:
void SetPositionByEnd(
    Connector^ connector,
    XYZ^ position
)
member SetPositionByEnd :
        connector : Connector *
        position : XYZ -> unit

Parameters

connector Connector
The connector of the fabrication part element.
position XYZ
The position to move to.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | this operation failed.
See Also

Reference

FabricationPart Class


FabricationPart.SplitStraight Method

FabricationPartSplitStraight Method

Overload List
 | Name | Description
Public method | SplitStraight(XYZ) | Splits the straight into two at the passed in point.
Public method | SplitStraight(Document, ElementId, XYZ) | Splits the straight into two at the passed in point.
Top
See Also

Reference

FabricationPart Class


FabricationPart.SplitStraight(XYZ) Method

FabricationPartSplitStraight(XYZ) Method

Splits the straight into two at the passed in point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId SplitStraight(
    XYZ position
)
Public Function SplitStraight (
    position As XYZ
) As ElementId
public:
ElementId^ SplitStraight(
    XYZ^ position
)
member SplitStraight :
        position : XYZ -> ElementId

Parameters

position XYZ
The position to split in the straight.

Return Value

ElementId
Returns the element identifier of the new straight.
Exceptions
Exception | Condition
ArgumentException | The position is not on the straight.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The part is not a straight.
See Also

Reference

FabricationPart Class
SplitStraight Overload


FabricationPart.SplitStraight(Document, ElementId, XYZ) Method

FabricationPartSplitStraight(Document, ElementId, XYZ) Method

Splits the straight into two at the passed in point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId SplitStraight(
    Document document,
    ElementId partId,
    XYZ position
)
Public Function SplitStraight (
    document As Document,
    partId As ElementId,
    position As XYZ
) As ElementId
public:
ElementId^ SplitStraight(
    Document^ document,
    ElementId^ partId,
    XYZ^ position
)
member SplitStraight :
        document : Document *
        partId : ElementId *
        position : XYZ -> ElementId

Parameters

document Document
The document.
partId ElementId
Identifier of the straight to split.
position XYZ
The position to split in the straight.

Return Value

ElementId
Returns the element identifier of the new straight.
Exceptions
Exception | Condition
ArgumentException | The part is not a straight. -or- The position is not on the straight.
ArgumentNullException | A non-optional argument was null
See Also

Reference

FabricationPart Class
SplitStraight Overload


FabricationPart.StretchAndFit Method

FabricationPartStretchAndFit Method

Stretch the fabrication part from the specified connector and fit to the target routing end.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FabricationPartFitResult StretchAndFit(
    Document document,
    Connector stretchConnector,
    FabricationPartRouteEnd target,
    out ISet<ElementId> newPartIds
)
Public Shared Function StretchAndFit (
    document As Document,
    stretchConnector As Connector,
    target As FabricationPartRouteEnd,
    <OutAttribute> ByRef newPartIds As ISet(Of ElementId)
) As FabricationPartFitResult
public:
static FabricationPartFitResult StretchAndFit(
    Document^ document,
    Connector^ stretchConnector,
    FabricationPartRouteEnd^ target,
    [OutAttribute] ISet<ElementId^>^% newPartIds
)
static member StretchAndFit :
        document : Document *
        stretchConnector : Connector *
        target : FabricationPartRouteEnd *
        newPartIds : ISet<ElementId> byref -> FabricationPartFitResult

Parameters

document Document
The document in which to perform the stretch and fit.
stretchConnector Connector
The connector of the fabrication part to be stretched.
target FabricationPartRouteEnd
The target routing end to align and fit to.
newPartIds ISet ElementId
New fabrication part element identifiers.

Return Value

FabricationPartFitResult
Returns FabricationPartFitResult::Success if successful.
Exceptions
Exception | Condition
ArgumentException | Connector does not belong to a fabrication part with a valid fabrication service. -or- Connector is connected. -or- Connector belongs to a fabrication part straight, tap, or hanger. -or- Routing end is valid to route to. -or- stretch target end type must be a supported type.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | fabrication part is not connected at one end only. -or- cannot stretch fabrication part to a different service.
Remarks
Cannot stretch and fit fabrication part straight, tap or hanger.
See Also

Reference

FabricationPart Class


FabricationPartType Class

Represents a fabrication component type in the Autodesk Revit MEP product.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBFabricationPartType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FabricationPartType : ElementType
Public Class FabricationPartType
    Inherits ElementType
public ref class FabricationPartType : public ElementType
type FabricationPartType =
    class
        inherit ElementType
    end

The FabricationPartType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a fabrication part type element based on a specific fabrication servic button and condition.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
 | Lookup | Looks up an existing fabrication part type based on a specfic fabrication service button and condition.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
For the product-based MAP parts, every size is a new part type in Revit. For others, one part type can have many sizes.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FabricationPartType Properties

The FabricationPartType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

FabricationPartType Class


FabricationPartType Methods

The FabricationPartType type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a fabrication part type element based on a specific fabrication servic button and condition.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
 | Lookup | Looks up an existing fabrication part type based on a specfic fabrication service button and condition.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FabricationPartType Class


FabricationPartType.Create Method

FabricationPartTypeCreate Method

Creates a fabrication part type element based on a specific fabrication servic button and condition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FabricationPartType Create(
    Document document,
    FabricationServiceButton button,
    int condition
)
Public Shared Function Create (
    document As Document,
    button As FabricationServiceButton,
    condition As Integer
) As FabricationPartType
public:
static FabricationPartType^ Create(
    Document^ document,
    FabricationServiceButton^ button,
    int condition
)
static member Create :
        document : Document *
        button : FabricationServiceButton *
        condition : int -> FabricationPartType

Parameters

document Document
The document.
button FabricationServiceButton
The fabrication service button.
condition Int32
The condition index.

Return Value

FabricationPartType
The created fabrication part type element.
Exceptions
Exception | Condition
ArgumentException | Fabrication service button contains invalid fittings.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | The index condition is not larger or equal to 0 and less than ConditionCount.
InvalidOperationException | The fabrication part type already exists.
See Also

Reference

FabricationPartType Class


FabricationPartType.Lookup Method

FabricationPartTypeLookup Method

Looks up an existing fabrication part type based on a specfic fabrication service button and condition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ElementId Lookup(
    Document document,
    FabricationServiceButton button,
    int condition
)
Public Shared Function Lookup (
    document As Document,
    button As FabricationServiceButton,
    condition As Integer
) As ElementId
public:
static ElementId^ Lookup(
    Document^ document,
    FabricationServiceButton^ button,
    int condition
)
static member Lookup :
        document : Document *
        button : FabricationServiceButton *
        condition : int -> ElementId

Parameters

document Document
The document.
button FabricationServiceButton
The fabrication service button.
condition Int32
The condition index.

Return Value

ElementId
Identifier of the fabrication part type element or invalidElementId if no fabrication part type exist for the specific fabrication service button and condition
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | The index condition is not larger or equal to 0 and less than ConditionCount.
See Also

Reference

FabricationPartType Class


FabricationRodInfo Class

The rod information of the fabrication part.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFabricationRodInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FabricationRodInfo : IDisposable
Public Class FabricationRodInfo
    Implements IDisposable
public ref class FabricationRodInfo : IDisposable
type FabricationRodInfo =
    class
        interface IDisposable
    end

The FabricationRodInfo type exposes the following members.

Properties
 | Name | Description
Public property | CanRodsBeHosted | Controls whether the hanger's rod's will be automatically hosted by other elements.
Public property | IsAttachedToStructure | Checks if the hanger is attached to structure.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | RodCount | Gets the number of rods.
Top
Methods
 | Name | Description
Public method | AttachToHanger | Attaches the hanger rod to another bearer hanger.
Public method | AttachToStructure | Attaches to the nearest structural element.
Public method | Dispose | Releases all resources used by the FabricationRodInfo
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBearerExtension | Gets the bearer extension. The method is applicable only for bearer hanger.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRodAttachedElementId | Gets the identifier of the attached component for the specified rod.
Public method | GetRodEndPosition | Gets the position of the rod end.
Public method | GetRodLength | Get the current rod length. If the rod is the length will include structural extension.
Public method | GetRodStructureExtension | Gets the length of the rod's top extension into structure.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsRodLockedWithHost | Checks if the rod is locked with the host. The method is applicable only for bearer hanger.
Public method | SetBearerExtension | Sets the bearer extension. The method is applicable only for bearer hanger.
Public method | SetRodEndPosition | Sets the position of the rod end. The method is applicable only for bearer hanger.
Public method | SetRodLength | Set the rod length of the hanger for the specified rod index, excluding top extension. The hanger must not be set to be auto-hosted.
Public method | SetRodLockedWithHost | Locks the rod with the host. The method is applicable only for bearer hanger.
Public method | SetRodStructureExtension | Set the length of the rod's top extension into structure. The rod must be attached to structure.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
A fabrication part may have one or more rods. The FabricationRodInfo stores the rod information of the fabrication part.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FabricationRodInfo Properties

The FabricationRodInfo type exposes the following members.

Properties
 | Name | Description
Public property | CanRodsBeHosted | Controls whether the hanger's rod's will be automatically hosted by other elements.
Public property | IsAttachedToStructure | Checks if the hanger is attached to structure.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | RodCount | Gets the number of rods.
Top
See Also

Reference

FabricationRodInfo Class


FabricationRodInfo.CanRodsBeHosted Property

FabricationRodInfoCanRodsBeHosted Property

Controls whether the hanger's rod's will be automatically hosted by other elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanRodsBeHosted { get; set; }
Public Property CanRodsBeHosted As Boolean
    Get
    Set
public:
property bool CanRodsBeHosted {
    bool get ();
    void set (bool value);
}
member CanRodsBeHosted : bool with get, set

Property Value

Boolean
See Also

Reference

FabricationRodInfo Class


FabricationRodInfo.IsAttachedToStructure Property

FabricationRodInfoIsAttachedToStructure Property

Checks if the hanger is attached to structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsAttachedToStructure { get; }
Public ReadOnly Property IsAttachedToStructure As Boolean
    Get
public:
property bool IsAttachedToStructure {
    bool get ();
}
member IsAttachedToStructure : bool with get

Property Value

Boolean
See Also

Reference

FabricationRodInfo Class


FabricationRodInfo.IsValidObject Property

FabricationRodInfoIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

FabricationRodInfo Class


FabricationRodInfo.RodCount Property

FabricationRodInfoRodCount Property

Gets the number of rods.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int RodCount { get; }
Public ReadOnly Property RodCount As Integer
    Get
public:
property int RodCount {
    int get ();
}
member RodCount : int with get

Property Value

Int32
See Also

Reference

FabricationRodInfo Class


FabricationRodInfo Methods

The FabricationRodInfo type exposes the following members.

Methods
 | Name | Description
Public method | AttachToHanger | Attaches the hanger rod to another bearer hanger.
Public method | AttachToStructure | Attaches to the nearest structural element.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBearerExtension | Gets the bearer extension. The method is applicable only for bearer hanger.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRodAttachedElementId | Gets the identifier of the attached component for the specified rod.
Public method | GetRodEndPosition | Gets the position of the rod end.
Public method | GetRodLength | Get the current rod length. If the rod is the length will include structural extension.
Public method | GetRodStructureExtension | Gets the length of the rod's top extension into structure.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsRodLockedWithHost | Checks if the rod is locked with the host. The method is applicable only for bearer hanger.
Public method | SetBearerExtension | Sets the bearer extension. The method is applicable only for bearer hanger.
Public method | SetRodEndPosition | Sets the position of the rod end. The method is applicable only for bearer hanger.
Public method | SetRodLength | Set the rod length of the hanger for the specified rod index, excluding top extension. The hanger must not be set to be auto-hosted.
Public method | SetRodLockedWithHost | Locks the rod with the host. The method is applicable only for bearer hanger.
Public method | SetRodStructureExtension | Set the length of the rod's top extension into structure. The rod must be attached to structure.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FabricationRodInfo Class


FabricationRodInfo.AttachToHanger Method

FabricationRodInfoAttachToHanger Method

Attaches the hanger rod to another bearer hanger.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AttachToHanger(
    ElementId hangerId,
    int rodIndex,
    XYZ position
)
Public Sub AttachToHanger (
    hangerId As ElementId,
    rodIndex As Integer,
    position As XYZ
)
public:
void AttachToHanger(
    ElementId^ hangerId,
    int rodIndex,
    XYZ^ position
)
member AttachToHanger :
        hangerId : ElementId *
        rodIndex : int *
        position : XYZ -> unit

Parameters

hangerId ElementId
Identifier of the bearer hanger to which the rod attaches.
rodIndex Int32
The index of the rod.
position XYZ
The position of the rod end. It should be on bearer centerline.
Exceptions
Exception | Condition
ArgumentException | The hanger is not a bearer hanger. -or- The point is not on hanger bearer centerline.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | the index rodIndex is should be in range of rod count.
See Also

Reference

FabricationRodInfo Class


FabricationRodInfo.AttachToStructure Method

FabricationRodInfoAttachToStructure Method

Attaches to the nearest structural element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AttachToStructure()
Public Sub AttachToStructure
public:
void AttachToStructure()
member AttachToStructure : unit -> unit
See Also

Reference

FabricationRodInfo Class


FabricationRodInfo.Dispose Method

FabricationRodInfoDispose Method

Releases all resources used by the FabricationRodInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FabricationRodInfo Class


FabricationRodInfo.GetBearerExtension Method

FabricationRodInfoGetBearerExtension Method

Gets the bearer extension. The method is applicable only for bearer hanger.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetBearerExtension(
    int rodIndex
)
Public Function GetBearerExtension (
    rodIndex As Integer
) As Double
public:
double GetBearerExtension(
    int rodIndex
)
member GetBearerExtension :
        rodIndex : int -> float

Parameters

rodIndex Int32
The index of the rod.

Return Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | the index rodIndex is should be in range of rod count.
InvalidOperationException | The hanger is not a bearer hanger.
See Also

Reference

FabricationRodInfo Class


FabricationRodInfo.GetRodAttachedElementId Method

FabricationRodInfoGetRodAttachedElementId Method

Gets the identifier of the attached component for the specified rod.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LinkElementId GetRodAttachedElementId(
    int rodIndex
)
Public Function GetRodAttachedElementId (
    rodIndex As Integer
) As LinkElementId
public:
LinkElementId^ GetRodAttachedElementId(
    int rodIndex
)
member GetRodAttachedElementId :
        rodIndex : int -> LinkElementId

Parameters

rodIndex Int32
The index of the specified rod.

Return Value

LinkElementId
Exceptions
Exception | Condition
ArgumentOutOfRangeException | the index rodIndex is should be in range of rod count.
InvalidOperationException | The rods do not attached to any structue.
See Also

Reference

FabricationRodInfo Class


FabricationRodInfo.GetRodEndPosition Method

FabricationRodInfoGetRodEndPosition Method

Gets the position of the rod end.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ GetRodEndPosition(
    int rodIndex
)
Public Function GetRodEndPosition (
    rodIndex As Integer
) As XYZ
public:
XYZ^ GetRodEndPosition(
    int rodIndex
)
member GetRodEndPosition :
        rodIndex : int -> XYZ

Parameters

rodIndex Int32
The index of the rod.

Return Value

XYZ
The position of the rod end.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | the index rodIndex is should be in range of rod count.
See Also

Reference

FabricationRodInfo Class


FabricationRodInfo.GetRodLength Method

FabricationRodInfoGetRodLength Method

Get the current rod length. If the rod is the length will include structural extension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetRodLength(
    int rodIndex
)
Public Function GetRodLength (
    rodIndex As Integer
) As Double
public:
double GetRodLength(
    int rodIndex
)
member GetRodLength :
        rodIndex : int -> float

Parameters

rodIndex Int32
The rod index.

Return Value

Double
Returns rod length of hanger for specified end.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | the index rodIndex is should be in range of rod count.
See Also

Reference

FabricationRodInfo Class


FabricationRodInfo.GetRodStructureExtension Method

FabricationRodInfoGetRodStructureExtension Method

Gets the length of the rod's top extension into structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetRodStructureExtension(
    int rodIndex
)
Public Function GetRodStructureExtension (
    rodIndex As Integer
) As Double
public:
double GetRodStructureExtension(
    int rodIndex
)
member GetRodStructureExtension :
        rodIndex : int -> float

Parameters

rodIndex Int32
The rod index.

Return Value

Double
Returns the extension length that will be applied if the rod is attached to structure.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | the index rodIndex is should be in range of rod count.
See Also

Reference

FabricationRodInfo Class


FabricationRodInfo.IsRodLockedWithHost Method

FabricationRodInfoIsRodLockedWithHost Method

Checks if the rod is locked with the host. The method is applicable only for bearer hanger.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsRodLockedWithHost(
    int rodIndex
)
Public Function IsRodLockedWithHost (
    rodIndex As Integer
) As Boolean
public:
bool IsRodLockedWithHost(
    int rodIndex
)
member IsRodLockedWithHost :
        rodIndex : int -> bool

Parameters

rodIndex Int32
The index of the rod.

Return Value

Boolean
True if the rod is locked with its host.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | the index rodIndex is should be in range of rod count.
InvalidOperationException | The hanger is not a bearer hanger.
See Also

Reference

FabricationRodInfo Class


FabricationRodInfo.SetBearerExtension Method

FabricationRodInfoSetBearerExtension Method

Sets the bearer extension. The method is applicable only for bearer hanger.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetBearerExtension(
    int rodIndex,
    double length
)
Public Sub SetBearerExtension (
    rodIndex As Integer,
    length As Double
)
public:
void SetBearerExtension(
    int rodIndex,
    double length
)
member SetBearerExtension :
        rodIndex : int *
        length : float -> unit

Parameters

rodIndex Int32
The index of the rod.
length Double
The new length of bearer extension.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | the index rodIndex is should be in range of rod count.
InvalidOperationException | The hanger is not a bearer hanger.
See Also

Reference

FabricationRodInfo Class


FabricationRodInfo.SetRodEndPosition Method

FabricationRodInfoSetRodEndPosition Method

Sets the position of the rod end. The method is applicable only for bearer hanger.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetRodEndPosition(
    int rodIndex,
    XYZ position
)
Public Sub SetRodEndPosition (
    rodIndex As Integer,
    position As XYZ
)
public:
void SetRodEndPosition(
    int rodIndex,
    XYZ^ position
)
member SetRodEndPosition :
        rodIndex : int *
        position : XYZ -> unit

Parameters

rodIndex Int32
The index of the rod.
position XYZ
The position of the rod end.
Exceptions
Exception | Condition
ArgumentException | Invalid rod position.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | the index rodIndex is should be in range of rod count.
InvalidOperationException | The hanger is not a bearer hanger.
See Also

Reference

FabricationRodInfo Class


FabricationRodInfo.SetRodLength Method

FabricationRodInfoSetRodLength Method

Set the rod length of the hanger for the specified rod index, excluding top extension. The hanger must not be set to be auto-hosted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SetRodLength(
    int rodIndex,
    double newLength
)
Public Function SetRodLength (
    rodIndex As Integer,
    newLength As Double
) As Boolean
public:
bool SetRodLength(
    int rodIndex,
    double newLength
)
member SetRodLength :
        rodIndex : int *
        newLength : float -> bool

Parameters

rodIndex Int32
The rod index.
newLength Double

Return Value

Boolean
Returns true if it was successful otherwise false.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | the index rodIndex is should be in range of rod count.
InvalidOperationException | The rod length cannot be set because the hanger is set to automatically host to other elements.
See Also

Reference

FabricationRodInfo Class


FabricationRodInfo.SetRodLockedWithHost Method

FabricationRodInfoSetRodLockedWithHost Method

Locks the rod with the host. The method is applicable only for bearer hanger.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetRodLockedWithHost(
    int rodIndex,
    bool locked
)
Public Sub SetRodLockedWithHost (
    rodIndex As Integer,
    locked As Boolean
)
public:
void SetRodLockedWithHost(
    int rodIndex,
    bool locked
)
member SetRodLockedWithHost :
        rodIndex : int *
        locked : bool -> unit

Parameters

rodIndex Int32
The index of the rod.
locked Boolean
Locks the rod with the host.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | the index rodIndex is should be in range of rod count.
InvalidOperationException | The hanger is not a bearer hanger.
See Also

Reference

FabricationRodInfo Class


FabricationRodInfo.SetRodStructureExtension Method

FabricationRodInfoSetRodStructureExtension Method

Set the length of the rod's top extension into structure. The rod must be attached to structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SetRodStructureExtension(
    int rodIndex,
    double extension
)
Public Function SetRodStructureExtension (
    rodIndex As Integer,
    extension As Double
) As Boolean
public:
bool SetRodStructureExtension(
    int rodIndex,
    double extension
)
member SetRodStructureExtension :
        rodIndex : int *
        extension : float -> bool

Parameters

rodIndex Int32
The rod index.
extension Double
Distance the rod will extend into the structure.

Return Value

Boolean
Returns true if it was successful otherwise false.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | the index rodIndex is should be in range of rod count.
InvalidOperationException | The rods do not attached to any structue.
See Also

Reference

FabricationRodInfo Class


FabricationService Class

This object contains information about a fabrication service.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFabricationService

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FabricationService : IDisposable
Public Class FabricationService
    Implements IDisposable
public ref class FabricationService : IDisposable
type FabricationService =
    class
        interface IDisposable
    end

The FabricationService type exposes the following members.

Properties
 | Name | Description
Public property | Abbreviation | The short name of service.
Public property | FabricationSystemName | The fabrication system name of the service.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The name of the service.
Public property | PaletteCount | The number of palettes in the service.
Public property | ServiceId | The service identifier of the service.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the FabricationService
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetButton | Gets the service button for a given palette index and button index from the service.
Public method | GetButtonCount | Gets the number of buttons for a given palette in the service.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetPaletteName | Gets the name of a palette based on palette index.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsCompatibleWith | Check whether the service is broadly interchangable with another one without affecting part geometry. The services must have the same fabrication system template and specification.
Public method | IsPaletteExcluded | Get whether a service palette is excluded from being used by the Route and Fill, Design to Fabrication, or Multi Point Routing commands. The default configuration values may be overridden by SetServicePaletteExclusions.
Public method | IsValidButtonIndex | Validates the button index.
Public method | IsValidPaletteIndex | Validates the palette index.
Public method | OverrideServiceButtonExclusion | Overrides the default service button exclusions, used by Route and Fill, Design to Fabrication, or Multi Point Routing for the current user and session only.
Public method | ResetServiceExclusionOverrides | Resets the overridden service palette and button exclusions back to default, as defined by the configuration.
Public method | SetServicePaletteExclusions | Sets the service palette exclusions, used by Route and Fill or Design to Fabrication commands, for the current user and session only. This will alter them from the default configuration exclusions to only exclude those palettes passed.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
A fabrication service defines what fabrication service buttons that can be used. Fabrication services are part of the fabrication configuration.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FabricationService Properties

The FabricationService type exposes the following members.

Properties
 | Name | Description
Public property | Abbreviation | The short name of service.
Public property | FabricationSystemName | The fabrication system name of the service.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The name of the service.
Public property | PaletteCount | The number of palettes in the service.
Public property | ServiceId | The service identifier of the service.
Top
See Also

Reference

FabricationService Class


FabricationService.Abbreviation Property

FabricationServiceAbbreviation Property

The short name of service.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Abbreviation { get; }
Public ReadOnly Property Abbreviation As String
    Get
public:
property String^ Abbreviation {
    String^ get ();
}
member Abbreviation : string with get

Property Value

String
See Also

Reference

FabricationService Class


FabricationService.FabricationSystemName Property

FabricationServiceFabricationSystemName Property

The fabrication system name of the service.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FabricationSystemName { get; }
Public ReadOnly Property FabricationSystemName As String
    Get
public:
property String^ FabricationSystemName {
    String^ get ();
}
member FabricationSystemName : string with get

Property Value

String
Remarks
A fabrication system in this context is a set of buttons that can be shared across fabrication services. It has nothing to do with other MEP systems in Revit.
See Also

Reference

FabricationService Class


FabricationService.IsValidObject Property

FabricationServiceIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

FabricationService Class


FabricationService.Name Property

FabricationServiceName Property

The name of the service.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

String
See Also

Reference

FabricationService Class


FabricationService.PaletteCount Property

FabricationServicePaletteCount Property

The number of palettes in the service.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int PaletteCount { get; }
Public ReadOnly Property PaletteCount As Integer
    Get
public:
property int PaletteCount {
    int get ();
}
member PaletteCount : int with get

Property Value

Int32
See Also

Reference

FabricationService Class


FabricationService.ServiceId Property

FabricationServiceServiceId Property

The service identifier of the service.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ServiceId { get; }
Public ReadOnly Property ServiceId As Integer
    Get
public:
property int ServiceId {
    int get ();
}
member ServiceId : int with get

Property Value

Int32
See Also

Reference

FabricationService Class


FabricationService Methods

The FabricationService type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetButton | Gets the service button for a given palette index and button index from the service.
Public method | GetButtonCount | Gets the number of buttons for a given palette in the service.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetPaletteName | Gets the name of a palette based on palette index.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsCompatibleWith | Check whether the service is broadly interchangable with another one without affecting part geometry. The services must have the same fabrication system template and specification.
Public method | IsPaletteExcluded | Get whether a service palette is excluded from being used by the Route and Fill, Design to Fabrication, or Multi Point Routing commands. The default configuration values may be overridden by SetServicePaletteExclusions.
Public method | IsValidButtonIndex | Validates the button index.
Public method | IsValidPaletteIndex | Validates the palette index.
Public method | OverrideServiceButtonExclusion | Overrides the default service button exclusions, used by Route and Fill, Design to Fabrication, or Multi Point Routing for the current user and session only.
Public method | ResetServiceExclusionOverrides | Resets the overridden service palette and button exclusions back to default, as defined by the configuration.
Public method | SetServicePaletteExclusions | Sets the service palette exclusions, used by Route and Fill or Design to Fabrication commands, for the current user and session only. This will alter them from the default configuration exclusions to only exclude those palettes passed.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FabricationService Class


FabricationService.Dispose Method

FabricationServiceDispose Method

Releases all resources used by the FabricationService

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FabricationService Class


FabricationService.GetButton Method

FabricationServiceGetButton Method

Gets the service button for a given palette index and button index from the service.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FabricationServiceButton GetButton(
    int paletteIndex,
    int buttonIndex
)
Public Function GetButton (
    paletteIndex As Integer,
    buttonIndex As Integer
) As FabricationServiceButton
public:
FabricationServiceButton^ GetButton(
    int paletteIndex,
    int buttonIndex
)
member GetButton :
        paletteIndex : int *
        buttonIndex : int -> FabricationServiceButton

Parameters

paletteIndex Int32
The palette index.
buttonIndex Int32
The button index.

Return Value

FabricationServiceButton
The service button.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The index paletteIndex is not larger or equal to 0 and less than PaletteCount.
See Also

Reference

FabricationService Class


FabricationService.GetButtonCount Method

FabricationServiceGetButtonCount Method

Gets the number of buttons for a given palette in the service.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetButtonCount(
    int palette
)
Public Function GetButtonCount (
    palette As Integer
) As Integer
public:
int GetButtonCount(
    int palette
)
member GetButtonCount :
        palette : int -> int

Parameters

palette Int32
The index of the palette

Return Value

Int32
The number of buttons.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The index palette is not larger or equal to 0 and less than PaletteCount.
See Also

Reference

FabricationService Class


FabricationService.GetPaletteName Method

FabricationServiceGetPaletteName Method

Gets the name of a palette based on palette index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetPaletteName(
    int palette
)
Public Function GetPaletteName (
    palette As Integer
) As String
public:
String^ GetPaletteName(
    int palette
)
member GetPaletteName :
        palette : int -> string

Parameters

palette Int32
The index of the palette.

Return Value

String
The name of the palette.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The index palette is not larger or equal to 0 and less than PaletteCount.
See Also

Reference

FabricationService Class


FabricationService.IsCompatibleWith Method

FabricationServiceIsCompatibleWith Method

Check whether the service is broadly interchangable with another one without affecting part geometry. The services must have the same fabrication system template and specification.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCompatibleWith(
    FabricationService otherService
)
Public Function IsCompatibleWith (
    otherService As FabricationService
) As Boolean
public:
bool IsCompatibleWith(
    FabricationService^ otherService
)
member IsCompatibleWith :
        otherService : FabricationService -> bool

Parameters

otherService FabricationService

Return Value

Boolean
Returns true if the services are compatible.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FabricationService Class


FabricationService.IsPaletteExcluded Method

FabricationServiceIsPaletteExcluded Method

Get whether a service palette is excluded from being used by the Route and Fill, Design to Fabrication, or Multi Point Routing commands. The default configuration values may be overridden by SetServicePaletteExclusions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsPaletteExcluded(
    int paletteIndex
)
Public Function IsPaletteExcluded (
    paletteIndex As Integer
) As Boolean
public:
bool IsPaletteExcluded(
    int paletteIndex
)
member IsPaletteExcluded :
        paletteIndex : int -> bool

Parameters

paletteIndex Int32
The index of the palete.

Return Value

Boolean
Returns true if the palette indexed by paletteIndex is currently to be excluded.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The index paletteIndex is not larger or equal to 0 and less than PaletteCount.
See Also

Reference

FabricationService Class


FabricationService.IsValidButtonIndex Method

FabricationServiceIsValidButtonIndex Method

Validates the button index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidButtonIndex(
    int paletteIndex,
    int buttonIndex
)
Public Function IsValidButtonIndex (
    paletteIndex As Integer,
    buttonIndex As Integer
) As Boolean
public:
bool IsValidButtonIndex(
    int paletteIndex,
    int buttonIndex
)
member IsValidButtonIndex :
        paletteIndex : int *
        buttonIndex : int -> bool

Parameters

paletteIndex Int32
The palette index.
buttonIndex Int32
The button index to check.

Return Value

Boolean
True if larger or equal to 0 and less than PaletteCount.
See Also

Reference

FabricationService Class


FabricationService.IsValidPaletteIndex Method

FabricationServiceIsValidPaletteIndex Method

Validates the palette index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidPaletteIndex(
    int paletteIndex
)
Public Function IsValidPaletteIndex (
    paletteIndex As Integer
) As Boolean
public:
bool IsValidPaletteIndex(
    int paletteIndex
)
member IsValidPaletteIndex :
        paletteIndex : int -> bool

Parameters

paletteIndex Int32
The palette index to check.

Return Value

Boolean
True if larger or equal to 0 and less than PaletteCount.
See Also

Reference

FabricationService Class


FabricationService.OverrideServiceButtonExclusion Method

FabricationServiceOverrideServiceButtonExclusion Method

Overrides the default service button exclusions, used by Route and Fill, Design to Fabrication, or Multi Point Routing for the current user and session only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void OverrideServiceButtonExclusion(
    int paletteIndex,
    int buttonIndex,
    bool exclude
)
Public Sub OverrideServiceButtonExclusion (
    paletteIndex As Integer,
    buttonIndex As Integer,
    exclude As Boolean
)
public:
void OverrideServiceButtonExclusion(
    int paletteIndex,
    int buttonIndex,
    bool exclude
)
member OverrideServiceButtonExclusion :
        paletteIndex : int *
        buttonIndex : int *
        exclude : bool -> unit

Parameters

paletteIndex Int32
The index of the service palette to exclude the service button from.
buttonIndex Int32
The index of the service button to exclude.
exclude Boolean
Pass true to exclude from being used by Route and Fill or Design to Fabrication.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The index paletteIndex is not larger or equal to 0 and less than PaletteCount.
See Also

Reference

FabricationService Class


FabricationService.ResetServiceExclusionOverrides Method

FabricationServiceResetServiceExclusionOverrides Method

Resets the overridden service palette and button exclusions back to default, as defined by the configuration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetServiceExclusionOverrides()
Public Sub ResetServiceExclusionOverrides
public:
void ResetServiceExclusionOverrides()
member ResetServiceExclusionOverrides : unit -> unit
See Also

Reference

FabricationService Class


FabricationService.SetServicePaletteExclusions Method

FabricationServiceSetServicePaletteExclusions Method

Sets the service palette exclusions, used by Route and Fill or Design to Fabrication commands, for the current user and session only. This will alter them from the default configuration exclusions to only exclude those palettes passed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SetServicePaletteExclusions(
    IList<int> excludedPalettes
)
Public Function SetServicePaletteExclusions (
    excludedPalettes As IList(Of Integer)
) As Boolean
public:
bool SetServicePaletteExclusions(
    IList<int>^ excludedPalettes
)
member SetServicePaletteExclusions :
        excludedPalettes : IList<int> -> bool

Parameters

excludedPalettes IList Int32
A list of service palette indexes to be excluded.

Return Value

Boolean
Returns true if succeeded to set the exclusions to the specified palette(s).
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | Palette indices contains an index that is not larger or equal to 0 and less than PaletteCount.
See Also

Reference

FabricationService Class


FabricationServiceButton Class

The object contains information about a fabricaton button.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFabricationServiceButton

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FabricationServiceButton : IDisposable
Public Class FabricationServiceButton
    Implements IDisposable
public ref class FabricationServiceButton : IDisposable
type FabricationServiceButton =
    class
        interface IDisposable
    end

The FabricationServiceButton type exposes the following members.

Properties
 | Name | Description
Public property | ButtonIndex | The button index for this button.
Public property | Code | The code of the button.
Public property | ConditionCount | The number of conditions.
Public property | IsAHanger | Checks if the fabrication service button is hanger.
Public property | IsStraight | Checks if all of the fabrication service button conditions are straights.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The name of the button.
Public property | PaletteIndex | The palette index for this button.
Public property | ServiceId | The fabrication service identifier for the fabrication service this button belongs to.
Top
Methods
 | Name | Description
Public method | ContainsFabricationPartType | Checks to see if the fabrication part type exists on one of the button conditions.
Public method | Dispose | Releases all resources used by the FabricationServiceButton
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetConditionDescription | Gets the description for the condition size range.
Public method | GetConditionImage | Gets the image for the specified fabrication service button condition.
Public method | GetConditionLowerValue | Gets the condition lower value (valid if greater or equal) for a given condition index.
Public method | GetConditionName | Gets the name of the specified condition on the fabrication service button.
Public method | GetConditionUpperValue | Gets the condition upper value (valid if less) for a given condition index.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetImage | Gets the image for fabrication service button.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsExcluded | Gets if the button's fabrication part content associated with the button is to be excluded from Route and Fill, Design to Fabrication, or Multi-Point Routing commands.
Public method | IsUnrestrictedCondition | Checks if the condition is unrestricted.
Public method | IsValid | Checks if the button contains only valid fittings.
 | IsValidConditionIndex | Validates if the given condition index is valid or not.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
A fabrication service button defines what items to use for different conditions. Fabrication service buttons are part of a fabrication service.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FabricationServiceButton Properties

The FabricationServiceButton type exposes the following members.

Properties
 | Name | Description
Public property | ButtonIndex | The button index for this button.
Public property | Code | The code of the button.
Public property | ConditionCount | The number of conditions.
Public property | IsAHanger | Checks if the fabrication service button is hanger.
Public property | IsStraight | Checks if all of the fabrication service button conditions are straights.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The name of the button.
Public property | PaletteIndex | The palette index for this button.
Public property | ServiceId | The fabrication service identifier for the fabrication service this button belongs to.
Top
See Also

Reference

FabricationServiceButton Class


FabricationServiceButton.ButtonIndex Property

FabricationServiceButtonButtonIndex Property

The button index for this button.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ButtonIndex { get; }
Public ReadOnly Property ButtonIndex As Integer
    Get
public:
property int ButtonIndex {
    int get ();
}
member ButtonIndex : int with get

Property Value

Int32
See Also

Reference

FabricationServiceButton Class


FabricationServiceButton.Code Property

FabricationServiceButtonCode Property

The code of the button.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Code { get; }
Public ReadOnly Property Code As String
    Get
public:
property String^ Code {
    String^ get ();
}
member Code : string with get

Property Value

String
See Also

Reference

FabricationServiceButton Class


FabricationServiceButton.ConditionCount Property

FabricationServiceButtonConditionCount Property

The number of conditions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ConditionCount { get; }
Public ReadOnly Property ConditionCount As Integer
    Get
public:
property int ConditionCount {
    int get ();
}
member ConditionCount : int with get

Property Value

Int32
See Also

Reference

FabricationServiceButton Class


FabricationServiceButton.IsAHanger Property

FabricationServiceButtonIsAHanger Property

Checks if the fabrication service button is hanger.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsAHanger { get; }
Public ReadOnly Property IsAHanger As Boolean
    Get
public:
property bool IsAHanger {
    bool get ();
}
member IsAHanger : bool with get

Property Value

Boolean
See Also

Reference

FabricationServiceButton Class


FabricationServiceButton.IsStraight Property

FabricationServiceButtonIsStraight Property

Checks if all of the fabrication service button conditions are straights.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsStraight { get; }
Public ReadOnly Property IsStraight As Boolean
    Get
public:
property bool IsStraight {
    bool get ();
}
member IsStraight : bool with get

Property Value

Boolean
See Also

Reference

FabricationServiceButton Class


FabricationServiceButton.IsValidObject Property

FabricationServiceButtonIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

FabricationServiceButton Class


FabricationServiceButton.Name Property

FabricationServiceButtonName Property

The name of the button.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

String
See Also

Reference

FabricationServiceButton Class


FabricationServiceButton.PaletteIndex Property

FabricationServiceButtonPaletteIndex Property

The palette index for this button.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int PaletteIndex { get; }
Public ReadOnly Property PaletteIndex As Integer
    Get
public:
property int PaletteIndex {
    int get ();
}
member PaletteIndex : int with get

Property Value

Int32
See Also

Reference

FabricationServiceButton Class


FabricationServiceButton.ServiceId Property

FabricationServiceButtonServiceId Property

The fabrication service identifier for the fabrication service this button belongs to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ServiceId { get; }
Public ReadOnly Property ServiceId As Integer
    Get
public:
property int ServiceId {
    int get ();
}
member ServiceId : int with get

Property Value

Int32
See Also

Reference

FabricationServiceButton Class


FabricationServiceButton Methods

The FabricationServiceButton type exposes the following members.

Methods
 | Name | Description
Public method | ContainsFabricationPartType | Checks to see if the fabrication part type exists on one of the button conditions.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetConditionDescription | Gets the description for the condition size range.
Public method | GetConditionImage | Gets the image for the specified fabrication service button condition.
Public method | GetConditionLowerValue | Gets the condition lower value (valid if greater or equal) for a given condition index.
Public method | GetConditionName | Gets the name of the specified condition on the fabrication service button.
Public method | GetConditionUpperValue | Gets the condition upper value (valid if less) for a given condition index.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetImage | Gets the image for fabrication service button.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsExcluded | Gets if the button's fabrication part content associated with the button is to be excluded from Route and Fill, Design to Fabrication, or Multi-Point Routing commands.
Public method | IsUnrestrictedCondition | Checks if the condition is unrestricted.
Public method | IsValid | Checks if the button contains only valid fittings.
 | IsValidConditionIndex | Validates if the given condition index is valid or not.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FabricationServiceButton Class


FabricationServiceButton.ContainsFabricationPartType Method

FabricationServiceButtonContainsFabricationPartType Method

Checks to see if the fabrication part type exists on one of the button conditions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ContainsFabricationPartType(
    FabricationPartType partType
)
Public Function ContainsFabricationPartType (
    partType As FabricationPartType
) As Boolean
public:
bool ContainsFabricationPartType(
    FabricationPartType^ partType
)
member ContainsFabricationPartType :
        partType : FabricationPartType -> bool

Parameters

partType FabricationPartType
The fabrication part type to check.

Return Value

Boolean
Returns true if the fabrication part type exists on the fabrication service button.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FabricationServiceButton Class


FabricationServiceButton.Dispose Method

FabricationServiceButtonDispose Method

Releases all resources used by the FabricationServiceButton

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FabricationServiceButton Class


FabricationServiceButton.GetConditionDescription Method

FabricationServiceButtonGetConditionDescription Method

Gets the description for the condition size range.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetConditionDescription(
    int condition
)
Public Function GetConditionDescription (
    condition As Integer
) As String
public:
String^ GetConditionDescription(
    int condition
)
member GetConditionDescription :
        condition : int -> string

Parameters

condition Int32
The index of the condition in the service button.

Return Value

String
A user-defined string that describes the condition range, as defined in the fabrication configuration. For example, this may describe the size of the range or describe the type of fitting.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The index condition is not larger or equal to 0 and less than ConditionCount.
See Also

Reference

FabricationServiceButton Class


FabricationServiceButton.GetConditionImage Method

FabricationServiceButtonGetConditionImage Method

Gets the image for the specified fabrication service button condition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Bitmap GetConditionImage(
    int condition
)
Public Overridable Function GetConditionImage (
    condition As Integer
) As Bitmap
public:
virtual Bitmap^ GetConditionImage(
    int condition
)
abstract GetConditionImage :
        condition : int -> Bitmap
override GetConditionImage :
        condition : int -> Bitmap

Parameters

condition Int32
The condition index.

Return Value

Bitmap
System.Drawing.Bitmap represents the fabrication service button image. if there is no preview image.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | the index condition is not larger or equal to 0 and less than ConditionCount
See Also

Reference

FabricationServiceButton Class


FabricationServiceButton.GetConditionLowerValue Method

FabricationServiceButtonGetConditionLowerValue Method

Gets the condition lower value (valid if greater or equal) for a given condition index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetConditionLowerValue(
    int condition
)
Public Function GetConditionLowerValue (
    condition As Integer
) As Double
public:
double GetConditionLowerValue(
    int condition
)
member GetConditionLowerValue :
        condition : int -> float

Parameters

condition Int32
The condition index.

Return Value

Double
The condition lower value.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The index condition is not larger or equal to 0 and less than ConditionCount.
Remarks
A value of -1 indicates an unrestricted value.
See Also

Reference

FabricationServiceButton Class


FabricationServiceButton.GetConditionName Method

FabricationServiceButtonGetConditionName Method

Gets the name of the specified condition on the fabrication service button.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetConditionName(
    int condition
)
Public Function GetConditionName (
    condition As Integer
) As String
public:
String^ GetConditionName(
    int condition
)
member GetConditionName :
        condition : int -> string

Parameters

condition Int32
The condition index.

Return Value

String
The name of the specified condition on the fabrication service button.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The index condition is not larger or equal to 0 and less than ConditionCount.
See Also

Reference

FabricationServiceButton Class


FabricationServiceButton.GetConditionUpperValue Method

FabricationServiceButtonGetConditionUpperValue Method

Gets the condition upper value (valid if less) for a given condition index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetConditionUpperValue(
    int condition
)
Public Function GetConditionUpperValue (
    condition As Integer
) As Double
public:
double GetConditionUpperValue(
    int condition
)
member GetConditionUpperValue :
        condition : int -> float

Parameters

condition Int32
The condition index.

Return Value

Double
The condition upper value.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The index condition is not larger or equal to 0 and less than ConditionCount.
Remarks
A value of -1 indicates an unrestricted value.
See Also

Reference

FabricationServiceButton Class


FabricationServiceButton.GetImage Method

FabricationServiceButtonGetImage Method

Gets the image for fabrication service button.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Bitmap GetImage()
Public Overridable Function GetImage As Bitmap
public:
virtual Bitmap^ GetImage()
abstract GetImage : unit -> Bitmap
override GetImage : unit -> Bitmap

Return Value

Bitmap
System.Drawing.Bitmap represents the fabrication service button image. if there is no preview image.
See Also

Reference

FabricationServiceButton Class


FabricationServiceButton.IsExcluded Method

FabricationServiceButtonIsExcluded Method

Gets if the button's fabrication part content associated with the button is to be excluded from Route and Fill, Design to Fabrication, or Multi-Point Routing commands.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsExcluded()
Public Function IsExcluded As Boolean
public:
bool IsExcluded()
member IsExcluded : unit -> bool

Return Value

Boolean
Returns true if the button's parts are excluded.
See Also

Reference

FabricationServiceButton Class


FabricationServiceButton.IsUnrestrictedCondition Method

FabricationServiceButtonIsUnrestrictedCondition Method

Checks if the condition is unrestricted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsUnrestrictedCondition(
    int condition
)
Public Function IsUnrestrictedCondition (
    condition As Integer
) As Boolean
public:
bool IsUnrestrictedCondition(
    int condition
)
member IsUnrestrictedCondition :
        condition : int -> bool

Parameters

condition Int32
The condition index.

Return Value

Boolean
True if the condition is unrestricted.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The index condition is not larger or equal to 0 and less than ConditionCount.
See Also

Reference

FabricationServiceButton Class


FabricationServiceButton.IsValid Method

FabricationServiceButtonIsValid Method

Checks if the button contains only valid fittings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValid()
Public Function IsValid As Boolean
public:
bool IsValid()
member IsValid : unit -> bool

Return Value

Boolean
True if the button contains only valid fittings.
See Also

Reference

FabricationServiceButton Class


FabricationServiceButton.IsValidConditionIndex Method

FabricationServiceButtonIsValidConditionIndex Method

Validates if the given condition index is valid or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidConditionIndex(
    FabricationServiceButton button,
    int condition
)
Public Shared Function IsValidConditionIndex (
    button As FabricationServiceButton,
    condition As Integer
) As Boolean
public:
static bool IsValidConditionIndex(
    FabricationServiceButton^ button,
    int condition
)
static member IsValidConditionIndex :
        button : FabricationServiceButton *
        condition : int -> bool

Parameters

button FabricationServiceButton
The button to check.
condition Int32
The condition index.

Return Value

Boolean
True if larger or equal to 0 and less than ConditionCount.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FabricationServiceButton Class


FabricationServiceSettings Class

Represents the settings related to the fabrication services.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBFabricationServiceSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FabricationServiceSettings : Element
Public Class FabricationServiceSettings
    Inherits Element
public ref class FabricationServiceSettings : public Element
type FabricationServiceSettings =
    class
        inherit Element
    end

The FabricationServiceSettings type exposes the following members.

Properties
 | Name | Description
 | AirFluidType | A special fluid type for fabrication HVAC services.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetFabricationServiceSettings | Gets the settings element in the document.
Public method | GetFluidTemperature | Gets the fluid temperature of the specified service.
Public method | GetFluidType | Gets the fluid type of the specified service.
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasValidFluidSetting | Is the service associated with a fluid type and temperature?
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveFluidSetting | Clears the fluid setting of the specified service if found.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetFluidTypeAndTemperature | Sets the fluid type and temperature of the specified service.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FabricationServiceSettings Properties

The FabricationServiceSettings type exposes the following members.

Properties
 | Name | Description
 | AirFluidType | A special fluid type for fabrication HVAC services.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

FabricationServiceSettings Class


FabricationServiceSettings.AirFluidType Property

FabricationServiceSettingsAirFluidType Property

A special fluid type for fabrication HVAC services.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ElementId AirFluidType { get; }
Public Shared ReadOnly Property AirFluidType As ElementId
    Get
public:
static property ElementId^ AirFluidType {
    ElementId^ get ();
}
static member AirFluidType : ElementId with get

Property Value

ElementId
See Also

Reference

FabricationServiceSettings Class


FabricationServiceSettings Methods

The FabricationServiceSettings type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetFabricationServiceSettings | Gets the settings element in the document.
Public method | GetFluidTemperature | Gets the fluid temperature of the specified service.
Public method | GetFluidType | Gets the fluid type of the specified service.
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasValidFluidSetting | Is the service associated with a fluid type and temperature?
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveFluidSetting | Clears the fluid setting of the specified service if found.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetFluidTypeAndTemperature | Sets the fluid type and temperature of the specified service.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FabricationServiceSettings Class


FabricationServiceSettings.GetFabricationServiceSettings Method

FabricationServiceSettingsGetFabricationServiceSettings Method

Gets the settings element in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FabricationServiceSettings GetFabricationServiceSettings(
    Document doc
)
Public Shared Function GetFabricationServiceSettings (
    doc As Document
) As FabricationServiceSettings
public:
static FabricationServiceSettings^ GetFabricationServiceSettings(
    Document^ doc
)
static member GetFabricationServiceSettings :
        doc : Document -> FabricationServiceSettings

Parameters

doc Document
The document where the settings element is found.

Return Value

FabricationServiceSettings
The element which stores the fabrication service settings for the document.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FabricationServiceSettings Class


FabricationServiceSettings.GetFluidTemperature Method

FabricationServiceSettingsGetFluidTemperature Method

Gets the fluid temperature of the specified service.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetFluidTemperature(
    FabricationService service
)
Public Function GetFluidTemperature (
    service As FabricationService
) As Double
public:
double GetFluidTemperature(
    FabricationService^ service
)
member GetFluidTemperature :
        service : FabricationService -> float

Parameters

service FabricationService
The service to lookup.

Return Value

Double
The temperature in Kelvin.
Exceptions
Exception | Condition
ArgumentException | service is not mapped to a fluid type and temperature.
ArgumentNullException | A non-optional argument was null
See Also

Reference

FabricationServiceSettings Class


FabricationServiceSettings.GetFluidType Method

FabricationServiceSettingsGetFluidType Method

Gets the fluid type of the specified service.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GetFluidType(
    FabricationService service
)
Public Function GetFluidType (
    service As FabricationService
) As ElementId
public:
ElementId^ GetFluidType(
    FabricationService^ service
)
member GetFluidType :
        service : FabricationService -> ElementId

Parameters

service FabricationService
The service to lookup.

Return Value

ElementId
The fluid type id.
Exceptions
Exception | Condition
ArgumentException | service is not mapped to a fluid type and temperature.
ArgumentNullException | A non-optional argument was null
See Also

Reference

FabricationServiceSettings Class


FabricationServiceSettings.HasValidFluidSetting Method

FabricationServiceSettingsHasValidFluidSetting Method

Is the service associated with a fluid type and temperature?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasValidFluidSetting(
    FabricationService service
)
Public Function HasValidFluidSetting (
    service As FabricationService
) As Boolean
public:
bool HasValidFluidSetting(
    FabricationService^ service
)
member HasValidFluidSetting :
        service : FabricationService -> bool

Parameters

service FabricationService
The service to lookup.

Return Value

Boolean
True if the service is associated with a fluid type and temperature, otherwise false.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FabricationServiceSettings Class


FabricationServiceSettings.RemoveFluidSetting Method

FabricationServiceSettingsRemoveFluidSetting Method

Clears the fluid setting of the specified service if found.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveFluidSetting(
    FabricationService service
)
Public Sub RemoveFluidSetting (
    service As FabricationService
)
public:
void RemoveFluidSetting(
    FabricationService^ service
)
member RemoveFluidSetting :
        service : FabricationService -> unit

Parameters

service FabricationService
The service to clear.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FabricationServiceSettings Class


FabricationServiceSettings.SetFluidTypeAndTemperature Method

FabricationServiceSettingsSetFluidTypeAndTemperature Method

Sets the fluid type and temperature of the specified service.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetFluidTypeAndTemperature(
    FabricationService service,
    ElementId fluidId,
    double temperature
)
Public Sub SetFluidTypeAndTemperature (
    service As FabricationService,
    fluidId As ElementId,
    temperature As Double
)
public:
void SetFluidTypeAndTemperature(
    FabricationService^ service,
    ElementId^ fluidId,
    double temperature
)
member SetFluidTypeAndTemperature :
        service : FabricationService *
        fluidId : ElementId *
        temperature : float -> unit

Parameters

service FabricationService
The fabrication service to be set.
fluidId ElementId
The fluid type id.
temperature Double
The temperature in Kelvin.
Exceptions
Exception | Condition
ArgumentException | fluidId is not a fluid type. -or- The temperature is not defined for the fluidId fluid type.
ArgumentNullException | A non-optional argument was null
See Also

Reference

FabricationServiceSettings Class


FabricationVersionInfo Class

The object contains versioning information about fabrication data.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFabricationVersionInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FabricationVersionInfo : IDisposable
Public Class FabricationVersionInfo
    Implements IDisposable
public ref class FabricationVersionInfo : IDisposable
type FabricationVersionInfo =
    class
        interface IDisposable
    end

The FabricationVersionInfo type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Reason | The user-specified reason for the change.
Public property | Version | The version number of the change.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the FabricationVersionInfo
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FabricationVersionInfo Properties

The FabricationVersionInfo type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Reason | The user-specified reason for the change.
Public property | Version | The version number of the change.
Top
See Also

Reference

FabricationVersionInfo Class


FabricationVersionInfo.IsValidObject Property

FabricationVersionInfoIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

FabricationVersionInfo Class


FabricationVersionInfo.Reason Property

FabricationVersionInfoReason Property

The user-specified reason for the change.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Reason { get; }
Public ReadOnly Property Reason As String
    Get
public:
property String^ Reason {
    String^ get ();
}
member Reason : string with get

Property Value

String
See Also

Reference

FabricationVersionInfo Class


FabricationVersionInfo.Version Property

FabricationVersionInfoVersion Property

The version number of the change.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Version { get; }
Public ReadOnly Property Version As Integer
    Get
public:
property int Version {
    int get ();
}
member Version : int with get

Property Value

Int32
See Also

Reference

FabricationVersionInfo Class


FabricationVersionInfo Methods

The FabricationVersionInfo type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FabricationVersionInfo Class


FabricationVersionInfo.Dispose Method

FabricationVersionInfoDispose Method

Releases all resources used by the FabricationVersionInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FabricationVersionInfo Class


Face Class

A bounded face of a 3d solid or open shell.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGeometryObject
Autodesk.Revit.DBFace
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Face : GeometryObject
Public Class Face
    Inherits GeometryObject
public ref class Face : public GeometryObject
type Face =
    class
        inherit GeometryObject
    end

The Face type exposes the following members.

Properties
 | Name | Description
Public property | Area | The area of this face.
Public property | EdgeLoops | A collection of edge loops. Each edge loop represents one of the closed boundaries of the face.
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject)
Public property | HasRegions | Identifies if the face contains regions (which can be created, for example, by the Split Face command).
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject)
Public property | IsCyclic | Indicates whether the underlying surface is periodic in the specified parametric direction.
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject)
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate).
Public property | MaterialElementId | The element ID of the material from which this face is composed.
Public property | OrientationMatchesSurfaceOrientation | Returns true if this face's orientation matches the orientation of the face's surface, false if they have opposite orientations.
Public property | Period | The period of the underlying surface in the specified parametric direction.
Public property | Reference | Returns a stable reference to the face.
Public property | Visibility | The visibility. (Inherited from GeometryObject)
Top
Methods
 | Name | Description
Public method | ComputeDerivatives | Returns the first partial derivatives of the underlying surface at the specified point.
Public method | ComputeNormal | Returns the normal vector for the face at the given point.
Public method | ComputeSecondDerivatives | Returns the second partial derivatives of the face at the specified point.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject)
Public method | Evaluate | Evaluates and returns the XYZ coordinates of a point at the indicated UV parameterization of the face.
Public method | GetBoundingBox | Returns the UV bounding box of the face.
Public method | GetEdgesAsCurveLoops | Returns a list of closed curve loops that correspond to the edge loops of the face. Curves in each curve loop correspond to individual edges.
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject)
Public method | GetRegions | Gets the face regions (created, for example, by the Split Face command) of the face.
Public method | GetSurface | Returns a copy of this face's surface.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face.
Public method | Intersect(Face) | Calculates the intersection of the specified face with this face and returns the intersection results.
Public method | Intersect(Curve, IntersectionResultArray) | Calculates the intersection of the specified curve with this face and returns the intersection results.
Public method | Intersect(Face, Curve) | Calculates the intersection of the specified face with this face and returns the intersection results.
Public method | IsInside(UV) | Indicates whether the specified point is within this face.
Public method | IsInside(UV, IntersectionResult) | Indicates whether the specified point is within this face and outputs additional information about the point location.
Public method | Project | Projects the specified point on the face.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
 | Triangulate | Returns a triangular mesh approximation to the face.
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face.
Top
Remarks
Faces are defined by surfaces (Surface) bounded by edge loops. The surfaces provide natural UV parameterization to the faces.
See Also

Reference

Autodesk.Revit.DB Namespace
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGeometryObject
Autodesk.Revit.DBFace
Autodesk.Revit.DBConicalFace
Autodesk.Revit.DBCylindricalFace
Autodesk.Revit.DBHermiteFace
Autodesk.Revit.DBPlanarFace
Autodesk.Revit.DBRevolvedFace
Autodesk.Revit.DBRuledFace


Face Properties

The Face type exposes the following members.

Properties
 | Name | Description
Public property | Area | The area of this face.
Public property | EdgeLoops | A collection of edge loops. Each edge loop represents one of the closed boundaries of the face.
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject)
Public property | HasRegions | Identifies if the face contains regions (which can be created, for example, by the Split Face command).
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject)
Public property | IsCyclic | Indicates whether the underlying surface is periodic in the specified parametric direction.
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject)
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate).
Public property | MaterialElementId | The element ID of the material from which this face is composed.
Public property | OrientationMatchesSurfaceOrientation | Returns true if this face's orientation matches the orientation of the face's surface, false if they have opposite orientations.
Public property | Period | The period of the underlying surface in the specified parametric direction.
Public property | Reference | Returns a stable reference to the face.
Public property | Visibility | The visibility. (Inherited from GeometryObject)
Top
See Also

Reference

Face Class


Face.Area Property

FaceArea Property

The area of this face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Area { get; }
Public ReadOnly Property Area As Double
    Get
public:
property double Area {
    double get ();
}
member Area : float with get

Property Value

Double
Remarks
Returns zero if fails to compute the area. In some cases, this area may be estimated.
See Also

Reference

Face Class


Face.EdgeLoops Property

FaceEdgeLoops Property

A collection of edge loops. Each edge loop represents one of the closed boundaries of the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EdgeArrayArray EdgeLoops { get; }
Public ReadOnly Property EdgeLoops As EdgeArrayArray
    Get
public:
property EdgeArrayArray^ EdgeLoops {
    EdgeArrayArray^ get ();
}
member EdgeLoops : EdgeArrayArray with get

Property Value

EdgeArrayArray
See Also

Reference

Face Class


Face.HasRegions Property

FaceHasRegions Property

Identifies if the face contains regions (which can be created, for example, by the Split Face command).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasRegions { get; }
Public ReadOnly Property HasRegions As Boolean
    Get
public:
property bool HasRegions {
    bool get ();
}
member HasRegions : bool with get

Property Value

Boolean
Remarks
If this is true, use GetRegions to get access to the specific Faces which make up the regions.
See Also

Reference

Face Class


Face.IsCyclic Property

FaceIsCyclic Property

Indicates whether the underlying surface is periodic in the specified parametric direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool this[
    int paramIdx
] { get; }
Public ReadOnly Property IsCyclic (
    paramIdx As Integer
) As Boolean
    Get
public:
property bool IsCyclic[int paramIdx] {
    bool get (int paramIdx);
}
member IsCyclic : bool with get

Parameters

paramIdx Int32
Use 0 for U coordinates and 1 for V coordinates.

Return Value

Boolean
True if the underlying surface is cyclic in the specified coordinate space; otherwise, false.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown when an incorrect coordinate dimension is supplied.
See Also

Reference

Face Class


Face.IsTwoSided Property

FaceIsTwoSided Property

Determines if a face is two-sided (degenerate).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsTwoSided { get; }
Public Overridable ReadOnly Property IsTwoSided As Boolean
    Get
public:
virtual property bool IsTwoSided {
    bool get ();
}
abstract IsTwoSided : bool with get
override IsTwoSided : bool with get

Property Value

Boolean
See Also

Reference

Face Class


Face.MaterialElementId Property

FaceMaterialElementId Property

The element ID of the material from which this face is composed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId MaterialElementId { get; }
Public ReadOnly Property MaterialElementId As ElementId
    Get
public:
property ElementId^ MaterialElementId {
    ElementId^ get ();
}
member MaterialElementId : ElementId with get

Property Value

ElementId
See Also

Reference

Face Class


Face.OrientationMatchesSurfaceOrientation Property

FaceOrientationMatchesSurfaceOrientation Property

Returns true if this face's orientation matches the orientation of the face's surface, false if they have opposite orientations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool OrientationMatchesSurfaceOrientation { get; }
Public ReadOnly Property OrientationMatchesSurfaceOrientation As Boolean
    Get
public:
property bool OrientationMatchesSurfaceOrientation {
    bool get ();
}
member OrientationMatchesSurfaceOrientation : bool with get

Property Value

Boolean
Remarks
(Revit uses only orientable faces and surfaces). At any point on a face or surface, the face's or surface's orientation is specified by the normal vector at that point. The face's normal vector can be the same or opposite to that of its surface. If OrientationMatchesSurfaceOrientation() is true, then the face’s normal vector is the same as that of its surface at each point on the face, otherwise the normal vectors are opposite. See also Surface::OrientationMatchesParametricOrientation.
See Also

Reference

Face Class


Face.Period Property

FacePeriod Property

The period of the underlying surface in the specified parametric direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double this[
    int paramIdx
] { get; }
Public ReadOnly Property Period (
    paramIdx As Integer
) As Double
    Get
public:
property double Period[int paramIdx] {
    double get (int paramIdx);
}
member Period : float with get

Parameters

paramIdx Int32
Use 0 for U coordinates and 1 for V coordinates.

Return Value

Double
The real number equal to the period of the underlying surface.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown when an incorrect coordinate dimension is supplied.
InvalidOperationException | Thrown when this face is not cyclic in the specified direction.
See Also

Reference

Face Class


Face.Reference Property

FaceReference Property

Returns a stable reference to the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Reference Reference { get; }
Public ReadOnly Property Reference As Reference
    Get
public:
property Reference^ Reference {
    Reference^ get ();
}
member Reference : Reference with get

Property Value

Reference
This value may be if the object does not store a corresponding reference. This might be due to any of the following reasons:
  • The face was obtained from an API member which does not permit options to generate corresponding References (most API members, besides Element.Geometry, do not have an option to generate a Reference).
  • The corresponding geometry object does not permit referencing.
See Also

Reference

Face Class


Face Methods

The Face type exposes the following members.

Methods
 | Name | Description
Public method | ComputeDerivatives | Returns the first partial derivatives of the underlying surface at the specified point.
Public method | ComputeNormal | Returns the normal vector for the face at the given point.
Public method | ComputeSecondDerivatives | Returns the second partial derivatives of the face at the specified point.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject)
Public method | Evaluate | Evaluates and returns the XYZ coordinates of a point at the indicated UV parameterization of the face.
Public method | GetBoundingBox | Returns the UV bounding box of the face.
Public method | GetEdgesAsCurveLoops | Returns a list of closed curve loops that correspond to the edge loops of the face. Curves in each curve loop correspond to individual edges.
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject)
Public method | GetRegions | Gets the face regions (created, for example, by the Split Face command) of the face.
Public method | GetSurface | Returns a copy of this face's surface.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face.
Public method | Intersect(Face) | Calculates the intersection of the specified face with this face and returns the intersection results.
Public method | Intersect(Curve, IntersectionResultArray) | Calculates the intersection of the specified curve with this face and returns the intersection results.
Public method | Intersect(Face, Curve) | Calculates the intersection of the specified face with this face and returns the intersection results.
Public method | IsInside(UV) | Indicates whether the specified point is within this face.
Public method | IsInside(UV, IntersectionResult) | Indicates whether the specified point is within this face and outputs additional information about the point location.
Public method | Project | Projects the specified point on the face.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
 | Triangulate | Returns a triangular mesh approximation to the face.
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face.
Top
See Also

Reference

Face Class


Face.ComputeDerivatives Method

FaceComputeDerivatives Method

Returns the first partial derivatives of the underlying surface at the specified point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Transform ComputeDerivatives(
    UV point
)
Public Function ComputeDerivatives (
    point As UV
) As Transform
public:
Transform^ ComputeDerivatives(
    UV^ point
)
member ComputeDerivatives :
        point : UV -> Transform

Parameters

point UV
The parameters to be evaluated, in natural parameterization of the face.

Return Value

Transform
A transformation containing tangent vectors and a normal vector.
Remarks
The following is the meaning of the transformation members:
  • Origin is the point on the face (equivalent to Evaluate(UV));
  • BasisX is the tangent vector along the U coordinate (partial derivative with respect to U).
  • BasisY is the tangent vector along the V coordinate (partial derivative with respect to V).
  • BasisZ is the underlying surface's normal vector. This is not necessarily aligned with the normal vector pointing out of a solid that contains the face, to get that value use ComputeNormal(UV).
None of the vectors are normalized.
See Also

Reference

Face Class


Face.ComputeNormal Method

FaceComputeNormal Method

Returns the normal vector for the face at the given point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ ComputeNormal(
    UV point
)
Public Function ComputeNormal (
    point As UV
) As XYZ
public:
XYZ^ ComputeNormal(
    UV^ point
)
member ComputeNormal :
        point : UV -> XYZ

Parameters

point UV
The parameters to be evaluated, in natural parameterization of the face.

Return Value

XYZ
The normal vector. This vector will be normalized.
Remarks
Differs from the normal returned from ComputeDerivatives(UV) in that this vector is the "face normal" vector. It will always be oriented to point out of a solid that contains the face.
See Also

Reference

Face Class


Face.ComputeSecondDerivatives Method

FaceComputeSecondDerivatives Method

Returns the second partial derivatives of the face at the specified point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FaceSecondDerivatives ComputeSecondDerivatives(
    UV point
)
Public Function ComputeSecondDerivatives (
    point As UV
) As FaceSecondDerivatives
public:
FaceSecondDerivatives^ ComputeSecondDerivatives(
    UV^ point
)
member ComputeSecondDerivatives :
        point : UV -> FaceSecondDerivatives

Parameters

point UV
The parameters to be evaluated, in natural parameterization of the face.

Return Value

FaceSecondDerivatives
The second partial derivatives of the face at the specified point.
Remarks
It does not take the bounding edge loops into account.
See Also

Reference

Face Class


Face.Evaluate Method

FaceEvaluate Method

Evaluates and returns the XYZ coordinates of a point at the indicated UV parameterization of the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Evaluate(
    UV params
)
Public Function Evaluate (
    params As UV
) As XYZ
public:
XYZ^ Evaluate(
    UV^ params
)
member Evaluate :
        params : UV -> XYZ

Parameters

params UV
The parameters to be evaluated, in natural parameterization of the face.

Return Value

XYZ
The XYZ coordinates.
Remarks
The evaluation is performed on the underlying Surface, and can return results outside of the boundaries of the face.
See Also

Reference

Face Class


Face.GetBoundingBox Method

FaceGetBoundingBox Method

Returns the UV bounding box of the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BoundingBoxUV GetBoundingBox()
Public Function GetBoundingBox As BoundingBoxUV
public:
BoundingBoxUV^ GetBoundingBox()
member GetBoundingBox : unit -> BoundingBoxUV

Return Value

BoundingBoxUV
A BoundingBoxUV with the extents of the parameterization of the face.
See Also

Reference

Face Class


Face.GetEdgesAsCurveLoops Method

FaceGetEdgesAsCurveLoops Method

Returns a list of closed curve loops that correspond to the edge loops of the face. Curves in each curve loop correspond to individual edges.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<CurveLoop> GetEdgesAsCurveLoops()
Public Function GetEdgesAsCurveLoops As IList(Of CurveLoop)
public:
IList<CurveLoop^>^ GetEdgesAsCurveLoops()
member GetEdgesAsCurveLoops : unit -> IList<CurveLoop>

Return Value

IList CurveLoop
A list of closed curve loops, that correspond edges of face.
Remarks
Orientations of the curves and curve loops match the orientations of the face's edges and edge loops. The order of the CurveLoops should be considered as arbitrary.
See Also

Reference

Face Class


Face.GetRegions Method

FaceGetRegions Method

Gets the face regions (created, for example, by the Split Face command) of the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<Face> GetRegions()
Public Function GetRegions As IList(Of Face)
public:
IList<Face^>^ GetRegions()
member GetRegions : unit -> IList<Face>

Return Value

IList Face
A list of faces, one for the main face of the object hosting the Split Face (such as wall or floor) and one face for each Split Face regions.
Remarks
Use the FaceSplitter class to filter and find elements which may generate face regions.
See Also

Reference

Face Class


Face.GetSurface Method

FaceGetSurface Method

Returns a copy of this face's surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Surface GetSurface()
Public Function GetSurface As Surface
public:
Surface^ GetSurface()
member GetSurface : unit -> Surface

Return Value

Surface
A copy of this face's surface.
See Also

Reference

Face Class


Face.Intersect Method

FaceIntersect Method

Calculates the intersection of the specified curve with this face.
Overload List
 | Name | Description
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face.
Public method | Intersect(Face) | Calculates the intersection of the specified face with this face and returns the intersection results.
Public method | Intersect(Curve, IntersectionResultArray) | Calculates the intersection of the specified curve with this face and returns the intersection results.
Public method | Intersect(Face, Curve) | Calculates the intersection of the specified face with this face and returns the intersection results.
Top
See Also

Reference

Face Class


Face.Intersect(Curve) Method

FaceIntersect(Curve) Method

Calculates the intersection of the specified curve with this face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SetComparisonResult Intersect(
    Curve curve
)
Public Function Intersect (
    curve As Curve
) As SetComparisonResult
public:
SetComparisonResult Intersect(
    Curve^ curve
)
member Intersect :
        curve : Curve -> SetComparisonResult

Parameters

curve Curve
The specified curve to intersect with this face.

Return Value

SetComparisonResult
  • SetComparisonResult.Overlap - One or more intersections were encountered.
  • SetComparisonResult.Subset - The curve is coincident with the surface.
  • SetComparisonResult.Disjoint - There is no intersection found.
Exceptions
Exception | Condition
ArgumentNullException | The curve is .
InvalidOperationException | The intersection calculation fails.
See Also

Reference

Face Class
Intersect Overload


Face.Intersect(Face) Method

FaceIntersect(Face) Method

Calculates the intersection of the specified face with this face and returns the intersection results.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FaceIntersectionFaceResult Intersect(
    Face face
)
Public Function Intersect (
    face As Face
) As FaceIntersectionFaceResult
public:
FaceIntersectionFaceResult Intersect(
    Face^ face
)
member Intersect :
        face : Face -> FaceIntersectionFaceResult

Parameters

face Face
The specified face to intersect with this face.

Return Value

FaceIntersectionFaceResult
  • FaceIntersectionFaceResult.Intersecting - One or more intersections were encountered.
  • SetComparisonResult.NonIntersecting - There is no intersection found.
Exceptions
Exception | Condition
ArgumentNullException | The face is .
InvalidOperationException | The intersection calculation fails.
Remarks
This is not a general-purpose function: it only works properly for simple configurations. For other configurations, it may return an incorrect result. Some configurations for which the function might return a correct result are:
  • A planar face that fully intersects another face in a single curve, when the other face is planar or cylindrical.
  • A cylindrical face that fully intersects another face in a single curve, when the other face is planar.
See Also

Reference

Face Class
Intersect Overload


Face.Intersect(Curve, IntersectionResultArray) Method

FaceIntersect(Curve, IntersectionResultArray) Method

Calculates the intersection of the specified curve with this face and returns the intersection results.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SetComparisonResult Intersect(
    Curve curve,
    out IntersectionResultArray results
)
Public Function Intersect (
    curve As Curve,
    <OutAttribute> ByRef results As IntersectionResultArray
) As SetComparisonResult
public:
SetComparisonResult Intersect(
    Curve^ curve,
    [OutAttribute] IntersectionResultArray^% results
)
member Intersect :
        curve : Curve *
        results : IntersectionResultArray byref -> SetComparisonResult

Parameters

curve Curve
The specified curve to intersect with this face.
results IntersectionResultArray
Provides more information about the intersection.

Return Value

SetComparisonResult
  • SetComparisonResult.Overlap - One or more intersections were encountered. The output argument has the results.
  • SetComparisonResult.Subset - The curve is coincident with the surface.
  • SetComparisonResult.Disjoint - There is no intersection found.
Exceptions
Exception | Condition
ArgumentNullException | The curve is .
InvalidOperationException | The intersection calculation fails.
Remarks
The array of the intersection results contains one entry for each point where this face and the curve intersect. The following is the meaning of IntersectionResult's members:
  • XYZPoint is the evaluated intersection point.
  • UVPoint is the intersection parameters on the face.
  • Parameter is the raw intersection parameter on the curve.
  • EdgeObject is the edge if the intersection happens to be near an edge of the face.
  • EdgeParameter is the parameter of the nearest point on the edge.
See Also

Reference

Face Class
Intersect Overload


Face.Intersect(Face, Curve) Method

FaceIntersect(Face, Curve) Method

Calculates the intersection of the specified face with this face and returns the intersection results.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FaceIntersectionFaceResult Intersect(
    Face face,
    out Curve result
)
Public Function Intersect (
    face As Face,
    <OutAttribute> ByRef result As Curve
) As FaceIntersectionFaceResult
public:
FaceIntersectionFaceResult Intersect(
    Face^ face,
    [OutAttribute] Curve^% result
)
member Intersect :
        face : Face *
        result : Curve byref -> FaceIntersectionFaceResult

Parameters

face Face
The specified face to intersect with this face.
result Curve
A single Curve representing the intersection.

Return Value

FaceIntersectionFaceResult
  • FaceIntersectionFaceResult.Intersecting - One or more intersections were encountered.
  • SetComparisonResult.NonIntersecting - There is no intersection found.
Exceptions
Exception | Condition
ArgumentNullException | The face is .
InvalidOperationException | The intersection calculation fails.
Remarks
This is not a general-purpose function: it only works properly for simple configurations. For other configurations, it may return an incorrect result. Some configurations for which the function might return a correct result are:
  • A planar face that fully intersects another face in a single curve, when the other face is planar or cylindrical.
  • A cylindrical face that fully intersects another face in a single curve, when the other face is planar.
See Also

Reference

Face Class
Intersect Overload


Face.IsInside Method

FaceIsInside Method

Indicates whether the specified point is within this face.
Overload List
 | Name | Description
Public method | IsInside(UV) | Indicates whether the specified point is within this face.
Public method | IsInside(UV, IntersectionResult) | Indicates whether the specified point is within this face and outputs additional information about the point location.
Top
See Also

Reference

Face Class


Face.IsInside(UV) Method

FaceIsInside(UV) Method

Indicates whether the specified point is within this face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsInside(
    UV point
)
Public Function IsInside (
    point As UV
) As Boolean
public:
bool IsInside(
    UV^ point
)
member IsInside :
        point : UV -> bool

Parameters

point UV
The parameters to be evaluated, in natural parameterization of the face.

Return Value

Boolean
True if point is within this face or on its boundary, otherwise false.
See Also

Reference

Face Class
IsInside Overload


Face.IsInside(UV, IntersectionResult) Method

FaceIsInside(UV, IntersectionResult) Method

Indicates whether the specified point is within this face and outputs additional information about the point location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsInside(
    UV point,
    out IntersectionResult result
)
Public Function IsInside (
    point As UV,
    <OutAttribute> ByRef result As IntersectionResult
) As Boolean
public:
bool IsInside(
    UV^ point,
    [OutAttribute] IntersectionResult^% result
)
member IsInside :
        point : UV *
        result : IntersectionResult byref -> bool

Parameters

point UV
The parameters to be evaluated, in natural parameterization of the face.
result IntersectionResult
Provides more information only when the point is on the edge; otherwise, .

Return Value

Boolean
True if within this face or on its boundary, otherwise False.
Remarks
The following is the meaning of the IntersectionResult members when the point is on the edge:
  • EdgeObject is the edge that the point lies on
  • EdgeParameter is the parameter of the point on the edge nearest to the UV point
  • UV is the specified point
See Also

Reference

Face Class
IsInside Overload


Face.Project Method

FaceProject Method

Projects the specified point on the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IntersectionResult Project(
    XYZ point
)
Public Function Project (
    point As XYZ
) As IntersectionResult
public:
IntersectionResult^ Project(
    XYZ^ point
)
member Project :
        point : XYZ -> IntersectionResult

Parameters

point XYZ
The point to be projected.

Return Value

IntersectionResult
Geometric information if projection is successful; if projection fails or the nearest point is outside of this face, returns .
Remarks
The following is the meaning of IntersectionResult's members:
  • XYZPoint is the nearest point to the projected point on the face.
  • UVPoint is the UV coordinates of the nearest point on the face.
  • Distance is the distance from the point to the face.
  • EdgeObject is the edge if projected point is near an edge.
  • EdgeParameter is the parameter of the nearest point on the edge.
See Also

Reference

Face Class


Face.Triangulate Method

FaceTriangulate Method

Overload List
 | Name | Description
 | Triangulate | Returns a triangular mesh approximation to the face.
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face.
Top
See Also

Reference

Face Class


Face.Triangulate Method

FaceTriangulate Method

Returns a triangular mesh approximation to the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Mesh Triangulate()
Public Function Triangulate As Mesh
public:
Mesh^ Triangulate()
member Triangulate : unit -> Mesh

Return Value

Mesh
Remarks
Tolerance of approximation is defined internally by Revit to be adequate for display purposes.
Example
C#
VB
C++
F#
Copy
private void TriangulateFace(Face face)
{
    // Get mesh
    Mesh mesh = face.Triangulate();
    for (int i = 0; i < mesh.NumTriangles; i++)
    {
        MeshTriangle triangle = mesh.get_Triangle(i);
        XYZ vertex1 = triangle.get_Vertex(0);
        XYZ vertex2 = triangle.get_Vertex(1);
        XYZ vertex3 = triangle.get_Vertex(2);
    }
}
Private Sub TriangulateFace(face As Face)
    ' Get mesh
    Dim mesh As Mesh = face.Triangulate()
    For i As Integer = 0 To mesh.NumTriangles - 1
        Dim triangle As MeshTriangle = mesh.Triangle(i)
        Dim vertex1 As XYZ = triangle.Vertex(0)
        Dim vertex2 As XYZ = triangle.Vertex(1)
        Dim vertex3 As XYZ = triangle.Vertex(2)
    Next
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Face Class
Triangulate Overload


Face.Triangulate(Double) Method

FaceTriangulate(Double) Method

Returns a triangular mesh approximation to the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Mesh Triangulate(
    double levelOfDetail
)
Public Function Triangulate (
    levelOfDetail As Double
) As Mesh
public:
Mesh^ Triangulate(
    double levelOfDetail
)
member Triangulate :
        levelOfDetail : float -> Mesh

Parameters

levelOfDetail Double
The level of detail. Its range is from 0 to 1. 0 is the lowest level of detail and 1 is the highest.

Return Value

Mesh
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown when level of detail is less than 0 or greater than 1.
See Also

Reference

Face Class
Triangulate Overload


FaceArray Class

An array that contains faces.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBFaceArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FaceArray : APIObject, IEnumerable
Public Class FaceArray
    Inherits APIObject
    Implements IEnumerable
public ref class FaceArray : public APIObject,
    IEnumerable
type FaceArray =
    class
        inherit APIObject
        interface IEnumerable
    end

The FaceArray type exposes the following members.

Constructors
 | Name | Description
Public method | FaceArray | Initializes a new instance of the FaceArray class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets a face at a specified index within the array.
Public property | Size | Returns the number of faces that are in the array.
Top
Methods
 | Name | Description
Public method | Append | Add the face to the end of the array.
Public method | Clear | Removes every face from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified face into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FaceArray Constructor

Initializes a new instance of the FaceArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FaceArray()
Public Sub New
public:
FaceArray()
new : unit -> FaceArray
See Also

Reference

FaceArray Class


FaceArray Properties

The FaceArray type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets a face at a specified index within the array.
Public property | Size | Returns the number of faces that are in the array.
Top
See Also

Reference

FaceArray Class


FaceArray.IsEmpty Property

FaceArrayIsEmpty Property

Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Boolean
Remarks
If the array is empty then True will be returned, otherwise False.
See Also

Reference

FaceArray Class


FaceArray.Item Property

FaceArrayItem Property

Gets or sets a face at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Face this[
    int index
] { get; set; }
Public Overridable Property Item (
    index As Integer
) As Face
    Get
    Set
public:
virtual property Face^ Item[int index] {
    Face^ get (int index);
    void set (int index, Face^ value);
}
abstract Item : Face with get, set
override Item : Face with get, set

Parameters

index Int32
The index of the face to be set or retrieved.

Return Value

Face
Returns the face at the specified index.
See Also

Reference

FaceArray Class


FaceArray.Size Property

FaceArraySize Property

Returns the number of faces that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
abstract Size : int with get
override Size : int with get

Property Value

Int32
See Also

Reference

FaceArray Class


FaceArray Methods

The FaceArray type exposes the following members.

Methods
 | Name | Description
Public method | Append | Add the face to the end of the array.
Public method | Clear | Removes every face from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified face into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FaceArray Class


FaceArray.Append Method

FaceArrayAppend Method

Add the face to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Append(
    Face item
)
Public Overridable Sub Append (
    item As Face
)
public:
virtual void Append(
    Face^ item
)
abstract Append :
        item : Face -> unit
override Append :
        item : Face -> unit

Parameters

item Face
The face to be added.
See Also

Reference

FaceArray Class


FaceArray.Clear Method

FaceArrayClear Method

Removes every face from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

FaceArray Class


FaceArray.ForwardIterator Method

FaceArrayForwardIterator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual FaceArrayIterator ForwardIterator()
Public Overridable Function ForwardIterator As FaceArrayIterator
public:
virtual FaceArrayIterator^ ForwardIterator()
abstract ForwardIterator : unit -> FaceArrayIterator
override ForwardIterator : unit -> FaceArrayIterator

Return Value

FaceArrayIterator
Returns a forward moving iterator to the array.
See Also

Reference

FaceArray Class


FaceArray.GetEnumerator Method

FaceArrayGetEnumerator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

IEnumerator
Returns a forward moving iterator to the array.

Implements

IEnumerableGetEnumerator
See Also

Reference

FaceArray Class


FaceArray.Insert Method

FaceArrayInsert Method

Insert the specified face into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Insert(
    Face item,
    int index
)
Public Overridable Sub Insert (
    item As Face,
    index As Integer
)
public:
virtual void Insert(
    Face^ item,
    int index
)
abstract Insert :
        item : Face *
        index : int -> unit
override Insert :
        item : Face *
        index : int -> unit

Parameters

item Face
The face to be inserted into the array.
index Int32
The face will be inserted before this index.

Return Value

Returns whether the face was inserted into the array.
See Also

Reference

FaceArray Class


FaceArray.ReverseIterator Method

FaceArrayReverseIterator Method

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual FaceArrayIterator ReverseIterator()
Public Overridable Function ReverseIterator As FaceArrayIterator
public:
virtual FaceArrayIterator^ ReverseIterator()
abstract ReverseIterator : unit -> FaceArrayIterator
override ReverseIterator : unit -> FaceArrayIterator

Return Value

FaceArrayIterator
Returns a backward moving iterator to the array.
See Also

Reference

FaceArray Class


FaceArrayIterator Class

An iterator to a face array.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBFaceArrayIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class FaceArrayIterator : APIObject,
    IEnumerator
Public MustInherit Class FaceArrayIterator
    Inherits APIObject
    Implements IEnumerator
public ref class FaceArrayIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type FaceArrayIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The FaceArrayIterator type exposes the following members.

Constructors
 | Name | Description
Public method | FaceArrayIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FaceArrayIterator Constructor

For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FaceArrayIterator()
Public Sub New
public:
FaceArrayIterator()
new : unit -> FaceArrayIterator
Remarks
This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.
See Also

Reference

FaceArrayIterator Class


FaceArrayIterator Properties

The FaceArrayIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

FaceArrayIterator Class


FaceArrayIterator.Current Property

FaceArrayIteratorCurrent Property

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}
abstract Current : Object with get
override Current : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.
See Also

Reference

FaceArrayIterator Class


FaceArrayIterator Methods

The FaceArrayIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FaceArrayIterator Class


FaceArrayIterator.MoveNext Method

FaceArrayIteratorMoveNext Method

Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumeratorMoveNext
Remarks
MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.
See Also

Reference

FaceArrayIterator Class


FaceArrayIterator.Reset Method

FaceArrayIteratorReset Method

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
Remarks
The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.
See Also

Reference

FaceArrayIterator Class


FaceDetailNode Class

A base class of output nodes that represent face edges and face silhouettes.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRenderNode
Autodesk.Revit.DBFaceDetailNode
Autodesk.Revit.DBFaceEdgeNode
Autodesk.Revit.DBFaceSilhouetteNode

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FaceDetailNode : RenderNode
Public Class FaceDetailNode
    Inherits RenderNode
public ref class FaceDetailNode : public RenderNode
type FaceDetailNode =
    class
        inherit RenderNode
    end

The FaceDetailNode type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode)
Public property | LineProperties | Access to the line (pen) properties of the curve being drawn.
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from RenderNode)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetInstanceTransform | Returns instance transform of the object being drawn.
Public method | GetLinkTransform | Returns link transform of the object being drawn.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FaceDetailNode Properties

The FaceDetailNode type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode)
Public property | LineProperties | Access to the line (pen) properties of the curve being drawn.
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode)
Top
See Also

Reference

FaceDetailNode Class


FaceDetailNode.LineProperties Property

FaceDetailNodeLineProperties Property

Access to the line (pen) properties of the curve being drawn.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LineProperties LineProperties { get; }
Public ReadOnly Property LineProperties As LineProperties
    Get
public:
property LineProperties^ LineProperties {
    LineProperties^ get ();
}
member LineProperties : LineProperties with get

Property Value

LineProperties
See Also

Reference

FaceDetailNode Class


FaceDetailNode Methods

The FaceDetailNode type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from RenderNode)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetInstanceTransform | Returns instance transform of the object being drawn.
Public method | GetLinkTransform | Returns link transform of the object being drawn.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FaceDetailNode Class


FaceDetailNode.GetInstanceTransform Method

FaceDetailNodeGetInstanceTransform Method

Returns instance transform of the object being drawn.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Transform GetInstanceTransform()
Public Function GetInstanceTransform As Transform
public:
Transform^ GetInstanceTransform()
member GetInstanceTransform : unit -> Transform

Return Value

Transform
See Also

Reference

FaceDetailNode Class


FaceDetailNode.GetLinkTransform Method

FaceDetailNodeGetLinkTransform Method

Returns link transform of the object being drawn.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Transform GetLinkTransform()
Public Function GetLinkTransform As Transform
public:
Transform^ GetLinkTransform()
member GetLinkTransform : unit -> Transform

Return Value

Transform
See Also

Reference

FaceDetailNode Class


FaceEdgeNode Class

An output node that represents a Face edge.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRenderNode
Autodesk.Revit.DBFaceDetailNode
Autodesk.Revit.DBFaceEdgeNode

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FaceEdgeNode : FaceDetailNode
Public Class FaceEdgeNode
    Inherits FaceDetailNode
public ref class FaceEdgeNode : public FaceDetailNode
type FaceEdgeNode =
    class
        inherit FaceDetailNode
    end

The FaceEdgeNode type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode)
Public property | LineProperties | Access to the line (pen) properties of the curve being drawn. (Inherited from FaceDetailNode)
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from RenderNode)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetFaceEdge | Returns the Face edge object corresponding to the node.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetInstanceTransform | Returns instance transform of the object being drawn. (Inherited from FaceDetailNode)
Public method | GetLinkTransform | Returns link transform of the object being drawn. (Inherited from FaceDetailNode)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
See also: OnFaceEdge2D(FaceEdgeNode).
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FaceEdgeNode Properties

The FaceEdgeNode type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode)
Public property | LineProperties | Access to the line (pen) properties of the curve being drawn. (Inherited from FaceDetailNode)
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode)
Top
See Also

Reference

FaceEdgeNode Class


FaceEdgeNode Methods

The FaceEdgeNode type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from RenderNode)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetFaceEdge | Returns the Face edge object corresponding to the node.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetInstanceTransform | Returns instance transform of the object being drawn. (Inherited from FaceDetailNode)
Public method | GetLinkTransform | Returns link transform of the object being drawn. (Inherited from FaceDetailNode)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FaceEdgeNode Class


FaceEdgeNode.GetFaceEdge Method

FaceEdgeNodeGetFaceEdge Method

Returns the Face edge object corresponding to the node.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Edge GetFaceEdge()
Public Function GetFaceEdge As Edge
public:
Edge^ GetFaceEdge()
member GetFaceEdge : unit -> Edge

Return Value

Edge
The face edge.
See Also

Reference

FaceEdgeNode Class


FaceIntersectionFaceResult Enumeration

An enumerated type listing the possible results of a face-face intersection calculation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum FaceIntersectionFaceResult
Public Enumeration FaceIntersectionFaceResult
public enum class FaceIntersectionFaceResult
type FaceIntersectionFaceResult
Members
Member name | Value | Description
Intersecting | 0 | The two faces have an intersection.
NonIntersecting | 1 | The two faces have no intersection.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FaceNode Class

An output node that represents a Face.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRenderNode
Autodesk.Revit.DBFaceNode

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FaceNode : RenderNode
Public Class FaceNode
    Inherits RenderNode
public ref class FaceNode : public RenderNode
type FaceNode =
    class
        inherit RenderNode
    end

The FaceNode type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode)
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from RenderNode)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetFace | Returns the Face object corresponding to the node.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
See also: OnFaceBegin(FaceNode).
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FaceNode Properties

The FaceNode type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode)
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode)
Top
See Also

Reference

FaceNode Class


FaceNode Methods

The FaceNode type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from RenderNode)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetFace | Returns the Face object corresponding to the node.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FaceNode Class


FaceNode.GetFace Method

FaceNodeGetFace Method

Returns the Face object corresponding to the node.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Face GetFace()
Public Function GetFace As Face
public:
Face^ GetFace()
member GetFace : unit -> Face

Return Value

Face
The face.
See Also

Reference

FaceNode Class


FaceSecondDerivatives Class

Contains second partial derivatives of a face at a specified point.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFaceSecondDerivatives

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FaceSecondDerivatives : IDisposable
Public Class FaceSecondDerivatives
    Implements IDisposable
public ref class FaceSecondDerivatives : IDisposable
type FaceSecondDerivatives =
    class
        interface IDisposable
    end

The FaceSecondDerivatives type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MixedDerivative | The mixed derivative.
Public property | UUDerivative | The second derivative with respect to U.
Public property | VVDerivative | The second derivative with respect to V.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the FaceSecondDerivatives
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FaceSecondDerivatives Properties

The FaceSecondDerivatives type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MixedDerivative | The mixed derivative.
Public property | UUDerivative | The second derivative with respect to U.
Public property | VVDerivative | The second derivative with respect to V.
Top
See Also

Reference

FaceSecondDerivatives Class


FaceSecondDerivatives.IsValidObject Property

FaceSecondDerivativesIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

FaceSecondDerivatives Class


FaceSecondDerivatives.MixedDerivative Property

FaceSecondDerivativesMixedDerivative Property

The mixed derivative.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ MixedDerivative { get; }
Public ReadOnly Property MixedDerivative As XYZ
    Get
public:
property XYZ^ MixedDerivative {
    XYZ^ get ();
}
member MixedDerivative : XYZ with get

Property Value

XYZ
See Also

Reference

FaceSecondDerivatives Class


FaceSecondDerivatives.UUDerivative Property

FaceSecondDerivativesUUDerivative Property

The second derivative with respect to U.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ UUDerivative { get; }
Public ReadOnly Property UUDerivative As XYZ
    Get
public:
property XYZ^ UUDerivative {
    XYZ^ get ();
}
member UUDerivative : XYZ with get

Property Value

XYZ
See Also

Reference

FaceSecondDerivatives Class


FaceSecondDerivatives.VVDerivative Property

FaceSecondDerivativesVVDerivative Property

The second derivative with respect to V.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ VVDerivative { get; }
Public ReadOnly Property VVDerivative As XYZ
    Get
public:
property XYZ^ VVDerivative {
    XYZ^ get ();
}
member VVDerivative : XYZ with get

Property Value

XYZ
See Also

Reference

FaceSecondDerivatives Class


FaceSecondDerivatives Methods

The FaceSecondDerivatives type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FaceSecondDerivatives Class


FaceSecondDerivatives.Dispose Method

FaceSecondDerivativesDispose Method

Releases all resources used by the FaceSecondDerivatives

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FaceSecondDerivatives Class


FaceSilhouetteNode Class

An output node that represents a Face edge.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRenderNode
Autodesk.Revit.DBFaceDetailNode
Autodesk.Revit.DBFaceSilhouetteNode

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FaceSilhouetteNode : FaceDetailNode
Public Class FaceSilhouetteNode
    Inherits FaceDetailNode
public ref class FaceSilhouetteNode : public FaceDetailNode
type FaceSilhouetteNode =
    class
        inherit FaceDetailNode
    end

The FaceSilhouetteNode type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode)
Public property | LineProperties | Access to the line (pen) properties of the curve being drawn. (Inherited from FaceDetailNode)
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from RenderNode)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetFace | Returns the Face object corresponding to the node.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetInstanceTransform | Returns instance transform of the object being drawn. (Inherited from FaceDetailNode)
Public method | GetLinkTransform | Returns link transform of the object being drawn. (Inherited from FaceDetailNode)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
See also: OnFaceSilhouette2D(FaceSilhouetteNode).
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FaceSilhouetteNode Properties

The FaceSilhouetteNode type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode)
Public property | LineProperties | Access to the line (pen) properties of the curve being drawn. (Inherited from FaceDetailNode)
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode)
Top
See Also

Reference

FaceSilhouetteNode Class


FaceSilhouetteNode Methods

The FaceSilhouetteNode type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from RenderNode)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetFace | Returns the Face object corresponding to the node.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetInstanceTransform | Returns instance transform of the object being drawn. (Inherited from FaceDetailNode)
Public method | GetLinkTransform | Returns link transform of the object being drawn. (Inherited from FaceDetailNode)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FaceSilhouetteNode Class


FaceSilhouetteNode.GetFace Method

FaceSilhouetteNodeGetFace Method

Returns the Face object corresponding to the node.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Face GetFace()
Public Function GetFace As Face
public:
Face^ GetFace()
member GetFace : unit -> Face

Return Value

Face
The face.
See Also

Reference

FaceSilhouetteNode Class


FaceSplitter Class

Represents an element that splits a face.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBFaceSplitter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FaceSplitter : Element
Public Class FaceSplitter
    Inherits Element
public ref class FaceSplitter : public Element
type FaceSplitter =
    class
        inherit Element
    end

The FaceSplitter type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SplitElementId | The id of the element whose face is split by this element.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetBoundaries | Gets the boundaries.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FaceSplitter Properties

The FaceSplitter type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SplitElementId | The id of the element whose face is split by this element.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

FaceSplitter Class


FaceSplitter.SplitElementId Property

FaceSplitterSplitElementId Property

The id of the element whose face is split by this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId SplitElementId { get; }
Public ReadOnly Property SplitElementId As ElementId
    Get
public:
property ElementId^ SplitElementId {
    ElementId^ get ();
}
member SplitElementId : ElementId with get

Property Value

ElementId
See Also

Reference

FaceSplitter Class


FaceSplitter Methods

The FaceSplitter type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetBoundaries | Gets the boundaries.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FaceSplitter Class


FaceSplitter.GetBoundaries Method

FaceSplitterGetBoundaries Method

Gets the boundaries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<CurveLoop> GetBoundaries()
Public Function GetBoundaries As IList(Of CurveLoop)
public:
IList<CurveLoop^>^ GetBoundaries()
member GetBoundaries : unit -> IList<CurveLoop>

Return Value

IList CurveLoop
The face splitter boundaries.
See Also

Reference

FaceSplitter Class


FacetingUtils Class

This class is used to convertTrianglesToQuads a triangulated structure into a structure in which some of the triangles have been consolidated into quadrilaterals.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFacetingUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class FacetingUtils
Public NotInheritable Class FacetingUtils
public ref class FacetingUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type FacetingUtils = class end

The FacetingUtils type exposes the following members.

Methods
Name | Description
ConvertTrianglesToQuads | Replaces pairs of adjacent, coplanar triangles by quadrilaterals.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FacetingUtils Methods

The FacetingUtils type exposes the following members.

Methods
Name | Description
ConvertTrianglesToQuads | Replaces pairs of adjacent, coplanar triangles by quadrilaterals.
Top
See Also

Reference

FacetingUtils Class


FacetingUtils.ConvertTrianglesToQuads Method

FacetingUtilsConvertTrianglesToQuads Method

Replaces pairs of adjacent, coplanar triangles by quadrilaterals.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<TriOrQuadFacet> ConvertTrianglesToQuads(
    TriangulationInterface triangulation
)
Public Shared Function ConvertTrianglesToQuads (
    triangulation As TriangulationInterface
) As IList(Of TriOrQuadFacet)
public:
static IList<TriOrQuadFacet^>^ ConvertTrianglesToQuads(
    TriangulationInterface^ triangulation
)
static member ConvertTrianglesToQuads :
        triangulation : TriangulationInterface -> IList<TriOrQuadFacet>

Parameters

triangulation TriangulationInterface
A triangulated face, shell, or solid.

Return Value

IList TriOrQuadFacet
A collection of triangles and quadrilaterals representing the original triangulated object.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This operation failed.
See Also

Reference

FacetingUtils Class


FaceToposolid Class

An object that represents a face-based Toposolid within the Autodesk Revit project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBHostObject
Autodesk.Revit.DBFaceToposolid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FaceToposolid : HostObject
Public Class FaceToposolid
    Inherits HostObject
public ref class FaceToposolid : public HostObject
type FaceToposolid =
    class
        inherit HostObject
    end

The FaceToposolid type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new instance of a face toposolid attached to a non-vertical massing face.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetReferencedFaces | Gets the referenced faces of the face toposolid
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetFaceReferences | Sets the referenced faces of the face toposolid
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UpdateToFace | Resets the face toposolid to its defining faces.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FaceToposolid Properties

The FaceToposolid type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

FaceToposolid Class


FaceToposolid Methods

The FaceToposolid type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new instance of a face toposolid attached to a non-vertical massing face.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetReferencedFaces | Gets the referenced faces of the face toposolid
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetFaceReferences | Sets the referenced faces of the face toposolid
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UpdateToFace | Resets the face toposolid to its defining faces.
Top
See Also

Reference

FaceToposolid Class


FaceToposolid.Create Method

FaceToposolidCreate Method

Creates a new instance of a face toposolid attached to a non-vertical massing face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FaceToposolid Create(
    Document document,
    ElementId toposolidTypeId,
    ElementId levelId,
    IList<Reference> faceReferences
)
Public Shared Function Create (
    document As Document,
    toposolidTypeId As ElementId,
    levelId As ElementId,
    faceReferences As IList(Of Reference)
) As FaceToposolid
public:
static FaceToposolid^ Create(
    Document^ document,
    ElementId^ toposolidTypeId,
    ElementId^ levelId,
    IList<Reference^>^ faceReferences
)
static member Create :
        document : Document *
        toposolidTypeId : ElementId *
        levelId : ElementId *
        faceReferences : IList<Reference> -> FaceToposolid

Parameters

document Document
The document.
toposolidTypeId ElementId
The toposolid type.
levelId ElementId
The level id.
faceReferences IList Reference
The references from the massing face.

Return Value

FaceToposolid
The newly created face toposolid.
Exceptions
Exception | Condition
ArgumentException | document is not a project document. -or- Toposolid type is not valid for this face toposolid. -or- The ElementId levelId is not a Level. -or- The faces are not valid for face toposolid creation.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
See Also

Reference

FaceToposolid Class


FaceToposolid.GetReferencedFaces Method

FaceToposolidGetReferencedFaces Method

Gets the referenced faces of the face toposolid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<Reference> GetReferencedFaces()
Public Function GetReferencedFaces As IList(Of Reference)
public:
IList<Reference^>^ GetReferencedFaces()
member GetReferencedFaces : unit -> IList<Reference>

Return Value

IList Reference
The referenced faces
See Also

Reference

FaceToposolid Class


FaceToposolid.SetFaceReferences Method

FaceToposolidSetFaceReferences Method

Sets the referenced faces of the face toposolid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetFaceReferences(
    IList<Reference> faceReferences
)
Public Sub SetFaceReferences (
    faceReferences As IList(Of Reference)
)
public:
void SetFaceReferences(
    IList<Reference^>^ faceReferences
)
member SetFaceReferences :
        faceReferences : IList<Reference> -> unit

Parameters

faceReferences IList Reference
The references from the massing face.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FaceToposolid Class


FaceToposolid.UpdateToFace Method

FaceToposolidUpdateToFace Method

Resets the face toposolid to its defining faces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void UpdateToFace()
Public Sub UpdateToFace
public:
void UpdateToFace()
member UpdateToFace : unit -> unit
See Also

Reference

FaceToposolid Class


FaceWall Class

A wall attached to a non-vertical massing face.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBHostObject
Autodesk.Revit.DBFaceWall

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FaceWall : HostObject
Public Class FaceWall
    Inherits HostObject
public ref class FaceWall : public HostObject
type FaceWall =
    class
        inherit HostObject
    end

The FaceWall type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new instance of a wall attached to a non-vertical massing face.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
 | IsValidFaceReferenceForFaceWall | Identifies if a reference may be used as the parent of a face wall.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
 | IsWallTypeValidForFaceWall | Identifies if a wall type may be applied to a face wall.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FaceWall Properties

The FaceWall type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

FaceWall Class


FaceWall Methods

The FaceWall type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new instance of a wall attached to a non-vertical massing face.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
 | IsValidFaceReferenceForFaceWall | Identifies if a reference may be used as the parent of a face wall.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
 | IsWallTypeValidForFaceWall | Identifies if a wall type may be applied to a face wall.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FaceWall Class


FaceWall.Create Method

FaceWallCreate Method

Creates a new instance of a wall attached to a non-vertical massing face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FaceWall Create(
    Document document,
    ElementId wallType,
    WallLocationLine locationLine,
    Reference faceReference
)
Public Shared Function Create (
    document As Document,
    wallType As ElementId,
    locationLine As WallLocationLine,
    faceReference As Reference
) As FaceWall
public:
static FaceWall^ Create(
    Document^ document,
    ElementId^ wallType,
    WallLocationLine locationLine,
    Reference^ faceReference
)
static member Create :
        document : Document *
        wallType : ElementId *
        locationLine : WallLocationLine *
        faceReference : Reference -> FaceWall

Parameters

document Document
The document.
wallType ElementId
The wall type. This must be a wall type accepted by IsWallTypeValidForFaceWall()
locationLine WallLocationLine
The alignment of the wall location line.
faceReference Reference
The reference from the massing face. This must pass IsValidFaceReferenceForFaceWall()

Return Value

FaceWall
The newly created face wall.
Exceptions
Exception | Condition
ArgumentException | The element wallType does not exist in the document -or- document is not a project document. -or- This wall type cannot be applied to a face wall. -or- This reference cannot be applied to a face wall.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
ForbiddenForDynamicUpdateException | During a dynamic update, the newly created face wall is going to be joined to surrounding structures.
InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The element is a member of a loaded family. -or- The element is a member of a group type that is not being edited.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
This method will regenerate the document.
See Also

Reference

FaceWall Class


FaceWall.IsValidFaceReferenceForFaceWall Method

FaceWallIsValidFaceReferenceForFaceWall Method

Identifies if a reference may be used as the parent of a face wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidFaceReferenceForFaceWall(
    Document document,
    Reference faceReference
)
Public Shared Function IsValidFaceReferenceForFaceWall (
    document As Document,
    faceReference As Reference
) As Boolean
public:
static bool IsValidFaceReferenceForFaceWall(
    Document^ document,
    Reference^ faceReference
)
static member IsValidFaceReferenceForFaceWall :
        document : Document *
        faceReference : Reference -> bool

Parameters

document Document
The document.
faceReference Reference
The reference.

Return Value

Boolean
True if the reference is valid as a parent to a face wall, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
The reference must represent a face of a massing instance, and must be planar, and its normal must not be vertical or horizontal.
See Also

Reference

FaceWall Class


FaceWall.IsWallTypeValidForFaceWall Method

FaceWallIsWallTypeValidForFaceWall Method

Identifies if a wall type may be applied to a face wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsWallTypeValidForFaceWall(
    Document document,
    ElementId wallType
)
Public Shared Function IsWallTypeValidForFaceWall (
    document As Document,
    wallType As ElementId
) As Boolean
public:
static bool IsWallTypeValidForFaceWall(
    Document^ document,
    ElementId^ wallType
)
static member IsWallTypeValidForFaceWall :
        document : Document *
        wallType : ElementId -> bool

Parameters

document Document
The document.
wallType ElementId
The wall type.

Return Value

Boolean
True if the wall type is valid for face wall, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FaceWall Class


FailureDefinition Class

Defines persistent information about a failure.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFailureDefinition

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FailureDefinition : IDisposable
Public Class FailureDefinition
    Implements IDisposable
public ref class FailureDefinition : IDisposable
type FailureDefinition =
    class
        interface IDisposable
    end

The FailureDefinition type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Severity | The severity of the failure.
Top
Methods
 | Name | Description
Public method | AddResolutionType | Adds a type of possible resolution for the failure.
 | CreateFailureDefinition | Creates an instance of a FailureDefinition.
Public method | Dispose | Releases all resources used by the FailureDefinition
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetApplicableResolutionTypes | Retrieves a list of resolution types applicable to the failure.
Public method | GetDefaultResolutionType | Retrieves the default resolution type for the failure.
Public method | GetDescriptionText | Retrieves the description text of the failure.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetResolutionCaption | Retrieves the caption for a specific resolution type.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HasResolutions | Checks if the FailureDefinition has at least one resolution.
Public method | IsResolutionApplicable | Checks if the given resolution type is applicable to the failure.
Public method | SetDefaultResolutionType | Sets the default resolution type for the failure.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Each failure that can be potentially posted in Revit must be based on a FailureDefinition object that contains some persistent information about failure such as identity, severity, basic description text, types of resolution and default resolution. Each FailureMessage, which contains variable part of the information for a specific failure when it occurs, is created with a reference to a registered FailureDefinition. In order to be able to post a failure, one must define and register it via FailureDefinition object during Revit Application startup.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FailureDefinition Properties

The FailureDefinition type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Severity | The severity of the failure.
Top
See Also

Reference

FailureDefinition Class


FailureDefinition.IsValidObject Property

FailureDefinitionIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

FailureDefinition Class


FailureDefinition.Severity Property

FailureDefinitionSeverity Property

The severity of the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FailureSeverity Severity { get; }
Public ReadOnly Property Severity As FailureSeverity
    Get
public:
property FailureSeverity Severity {
    FailureSeverity get ();
}
member Severity : FailureSeverity with get

Property Value

FailureSeverity
See Also

Reference

FailureDefinition Class


FailureDefinition Methods

The FailureDefinition type exposes the following members.

Methods
 | Name | Description
Public method | AddResolutionType | Adds a type of possible resolution for the failure.
 | CreateFailureDefinition | Creates an instance of a FailureDefinition.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetApplicableResolutionTypes | Retrieves a list of resolution types applicable to the failure.
Public method | GetDefaultResolutionType | Retrieves the default resolution type for the failure.
Public method | GetDescriptionText | Retrieves the description text of the failure.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetResolutionCaption | Retrieves the caption for a specific resolution type.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HasResolutions | Checks if the FailureDefinition has at least one resolution.
Public method | IsResolutionApplicable | Checks if the given resolution type is applicable to the failure.
Public method | SetDefaultResolutionType | Sets the default resolution type for the failure.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FailureDefinition Class


FailureDefinition.AddResolutionType Method

FailureDefinitionAddResolutionType Method

Adds a type of possible resolution for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FailureDefinition AddResolutionType(
    FailureResolutionType type,
    string caption,
    Type classOfResolution
)
Public Function AddResolutionType (
    type As FailureResolutionType,
    caption As String,
    classOfResolution As Type
) As FailureDefinition
public:
FailureDefinition^ AddResolutionType(
    FailureResolutionType type,
    String^ caption,
    Type^ classOfResolution
)
member AddResolutionType :
        type : FailureResolutionType *
        caption : string *
        classOfResolution : Type -> FailureDefinition

Parameters

type FailureResolutionType
Type of the resolution to add. The type of resolution can be used only once for the FailureDefinition.
caption String
A simple description of the resolution.
classOfResolution Type
The runtime class of the resolution. Used to ensure that the actual FailureResoution object added to the instance of FailureMessage belongs to an applicable class.

Return Value

FailureDefinition
The FailureDefinition.
Exceptions
Exception | Condition
ArgumentException | The type has already been added as a resolution to the FailureDefinition. -or- The input classOfResolution is not a subclass of FailureResolution.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Remarks
In order to inform Revit what failure resolutions can be possibly used with a given failure, a FailureDefinition must contain a full list of resolution types applicable to the failure, including user-visible caption and runtime class of the resolution. The number of resolutions is not limited. The first added resolution becomes the default resolution.
See Also

Reference

FailureDefinition Class


FailureDefinition.CreateFailureDefinition Method

FailureDefinitionCreateFailureDefinition Method

Creates an instance of a FailureDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FailureDefinition CreateFailureDefinition(
    FailureDefinitionId id,
    FailureSeverity severity,
    string messageString
)
Public Shared Function CreateFailureDefinition (
    id As FailureDefinitionId,
    severity As FailureSeverity,
    messageString As String
) As FailureDefinition
public:
static FailureDefinition^ CreateFailureDefinition(
    FailureDefinitionId^ id,
    FailureSeverity severity,
    String^ messageString
)
static member CreateFailureDefinition :
        id : FailureDefinitionId *
        severity : FailureSeverity *
        messageString : string -> FailureDefinition

Parameters

id FailureDefinitionId
Unique identifier of the failure.
severity FailureSeverity
The severity of the failure. Cannot be FailureSeverity::None.
messageString String
A user-visible string describing the failure.

Return Value

FailureDefinition
The created FailureDefinition instance.
Exceptions
Exception | Condition
ArgumentException | The id of failure definition is not valid. -or- The id of failure definition is already used to register another FailureDefinition. -or- The severity of failures cannot be FailureSeverity::None. -or- Message string is empty or contains invalid characters.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Remarks
The newly created FailureDefinition will be added to the FailureDefinitionRegistry. Because FailureDefinition could only be registered when Revit starting up, this function cannot be used after Revit has already started. Throws InvalidOperationException if invoked after Revit start-up is completed.
Example
C#
VB
C++
F#
Copy
// define a new failure id for a warning about walls
FailureDefinitionId warnId =
    new FailureDefinitionId(new Guid("FB4F5AF3-42BB-4371-B559-FB1648D5B4D1"));

// register the new warning using FailureDefinition
FailureDefinition failDef = FailureDefinition.CreateFailureDefinition(warnId,
    FailureSeverity.Warning,
    "Wall is too big (>100'). Performance problems may result.");
' define a new failure id for a warning about walls
Dim warnId As New FailureDefinitionId(New Guid("FB4F5AF3-42BB-4371-B559-FB1648D5B4D1"))

' register the new warning using FailureDefinition
Dim failDef As FailureDefinition = FailureDefinition.CreateFailureDefinition(warnId, FailureSeverity.Warning, "Wall is too big (>100'). Performance problems may result.")

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

FailureDefinition Class


FailureDefinition.Dispose Method

FailureDefinitionDispose Method

Releases all resources used by the FailureDefinition

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FailureDefinition Class


FailureDefinition.GetApplicableResolutionTypes Method

FailureDefinitionGetApplicableResolutionTypes Method

Retrieves a list of resolution types applicable to the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<FailureResolutionType> GetApplicableResolutionTypes()
Public Function GetApplicableResolutionTypes As IList(Of FailureResolutionType)
public:
IList<FailureResolutionType>^ GetApplicableResolutionTypes()
member GetApplicableResolutionTypes : unit -> IList<FailureResolutionType>

Return Value

IList FailureResolutionType
The list of resolution types applicable to the failure.
See Also

Reference

FailureDefinition Class


FailureDefinition.GetDefaultResolutionType Method

FailureDefinitionGetDefaultResolutionType Method

Retrieves the default resolution type for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FailureResolutionType GetDefaultResolutionType()
Public Function GetDefaultResolutionType As FailureResolutionType
public:
FailureResolutionType GetDefaultResolutionType()
member GetDefaultResolutionType : unit -> FailureResolutionType

Return Value

FailureResolutionType
The Default resolution type for the failure.
Exceptions
Exception | Condition
InvalidOperationException | FailureDefinition does not have any resolutions.
See Also

Reference

FailureDefinition Class


FailureDefinition.GetDescriptionText Method

FailureDefinitionGetDescriptionText Method

Retrieves the description text of the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetDescriptionText()
Public Function GetDescriptionText As String
public:
String^ GetDescriptionText()
member GetDescriptionText : unit -> string

Return Value

String
The description text.
Remarks
Retrieved description text for built-in Revit failures is localized. The result may vary from the description text retrieved from the corresponding FailureMessage. A failure definition contains a description string, that may have format specifiers like %s, and "sample" strings, that will be used to resolve them. A FailureMessage will contain "specific" strings. So, in the failure definition description "Cannot keep %s joined" will be converted into "Cannot keep Element joined" while the description in actual FailureMessage will read "Cannot keep Walls joined" or "Cannot keep Beams joined"
See Also

Reference

FailureDefinition Class


FailureDefinition.GetResolutionCaption Method

FailureDefinitionGetResolutionCaption Method

Retrieves the caption for a specific resolution type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetResolutionCaption(
    FailureResolutionType type
)
Public Function GetResolutionCaption (
    type As FailureResolutionType
) As String
public:
String^ GetResolutionCaption(
    FailureResolutionType type
)
member GetResolutionCaption :
        type : FailureResolutionType -> string

Parameters

type FailureResolutionType
The resolution type.

Return Value

String
The caption of the resolution.
Exceptions
Exception | Condition
ArgumentException | Resolution of the type is not applicable to the failure.
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | FailureDefinition does not have any resolutions.
See Also

Reference

FailureDefinition Class


FailureDefinition.HasResolutions Method

FailureDefinitionHasResolutions Method

Checks if the FailureDefinition has at least one resolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasResolutions()
Public Function HasResolutions As Boolean
public:
bool HasResolutions()
member HasResolutions : unit -> bool

Return Value

Boolean
True if at least one resolution is defined in the FailureDefinition.
See Also

Reference

FailureDefinition Class


FailureDefinition.IsResolutionApplicable Method

FailureDefinitionIsResolutionApplicable Method

Checks if the given resolution type is applicable to the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsResolutionApplicable(
    FailureResolutionType type
)
Public Function IsResolutionApplicable (
    type As FailureResolutionType
) As Boolean
public:
bool IsResolutionApplicable(
    FailureResolutionType type
)
member IsResolutionApplicable :
        type : FailureResolutionType -> bool

Parameters

type FailureResolutionType
The resolution type to check.

Return Value

Boolean
True if the given resolution type is applicable to the failure, false otherwise.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

FailureDefinition Class


FailureDefinition.SetDefaultResolutionType Method

FailureDefinitionSetDefaultResolutionType Method

Sets the default resolution type for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FailureDefinition SetDefaultResolutionType(
    FailureResolutionType type
)
Public Function SetDefaultResolutionType (
    type As FailureResolutionType
) As FailureDefinition
public:
FailureDefinition^ SetDefaultResolutionType(
    FailureResolutionType type
)
member SetDefaultResolutionType :
        type : FailureResolutionType -> FailureDefinition

Parameters

type FailureResolutionType
The type of resolution to be used as default.

Return Value

FailureDefinition
The FailureDefinition.
Exceptions
Exception | Condition
ArgumentException | Resolution of the type is not applicable to the failure.
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | FailureDefinition does not have any resolutions.
Remarks
If failure has multiple resolutions, one of them is designated as designated as the default resolution. The default resolution is used by Revit failure processing mechanism to resolve failures automatically when applicable.
See Also

Reference

FailureDefinition Class


FailureDefinitionAccessor Class

A class that provides access to the details of a FailureDefinition after the definition has been defined.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFailureDefinitionAccessor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FailureDefinitionAccessor : IDisposable
Public Class FailureDefinitionAccessor
    Implements IDisposable
public ref class FailureDefinitionAccessor : IDisposable
type FailureDefinitionAccessor =
    class
        interface IDisposable
    end

The FailureDefinitionAccessor type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the FailureDefinitionAccessor
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetApplicableResolutionTypes | Retrieves a list of resolution types applicable to the failure.
Public method | GetDefaultResolutionType | Retrieves the default resolution type for the failure.
Public method | GetDescriptionText | Retrieves the description text of the failure.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetId | Retrieves the unique identifier of the FailureDefinition.
Public method | GetResolutionCaption | Retrieves the caption for a specific resolution type.
Public method | GetSeverity | Retrieves severity of the failure.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HasResolutions | Checks if the FailureDefinition has at least one resolution.
Public method | IsResolutionApplicable | Checks if the given resolution type is applicable to the failure.
Public method | SetDefaultResolutionType | Sets the default resolution type for the failure.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FailureDefinitionAccessor Properties

The FailureDefinitionAccessor type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

FailureDefinitionAccessor Class


FailureDefinitionAccessor.IsValidObject Property

FailureDefinitionAccessorIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

FailureDefinitionAccessor Class


FailureDefinitionAccessor Methods

The FailureDefinitionAccessor type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetApplicableResolutionTypes | Retrieves a list of resolution types applicable to the failure.
Public method | GetDefaultResolutionType | Retrieves the default resolution type for the failure.
Public method | GetDescriptionText | Retrieves the description text of the failure.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetId | Retrieves the unique identifier of the FailureDefinition.
Public method | GetResolutionCaption | Retrieves the caption for a specific resolution type.
Public method | GetSeverity | Retrieves severity of the failure.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HasResolutions | Checks if the FailureDefinition has at least one resolution.
Public method | IsResolutionApplicable | Checks if the given resolution type is applicable to the failure.
Public method | SetDefaultResolutionType | Sets the default resolution type for the failure.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FailureDefinitionAccessor Class


FailureDefinitionAccessor.Dispose Method

FailureDefinitionAccessorDispose Method

Releases all resources used by the FailureDefinitionAccessor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FailureDefinitionAccessor Class


FailureDefinitionAccessor.GetApplicableResolutionTypes Method

FailureDefinitionAccessorGetApplicableResolutionTypes Method

Retrieves a list of resolution types applicable to the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<FailureResolutionType> GetApplicableResolutionTypes()
Public Function GetApplicableResolutionTypes As IList(Of FailureResolutionType)
public:
IList<FailureResolutionType>^ GetApplicableResolutionTypes()
member GetApplicableResolutionTypes : unit -> IList<FailureResolutionType>

Return Value

IList FailureResolutionType
The list of resolution types applicable to the failure.
Exceptions
Exception | Condition
InvalidOperationException | The FailureDefinitionAccessor has not been properly initialized.
See Also

Reference

FailureDefinitionAccessor Class


FailureDefinitionAccessor.GetDefaultResolutionType Method

FailureDefinitionAccessorGetDefaultResolutionType Method

Retrieves the default resolution type for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FailureResolutionType GetDefaultResolutionType()
Public Function GetDefaultResolutionType As FailureResolutionType
public:
FailureResolutionType GetDefaultResolutionType()
member GetDefaultResolutionType : unit -> FailureResolutionType

Return Value

FailureResolutionType
The default resolution type for the failure.
Exceptions
Exception | Condition
InvalidOperationException | The FailureDefinitionAccessor has not been properly initialized. -or- FailureDefinition does not have any resolutions.
See Also

Reference

FailureDefinitionAccessor Class


FailureDefinitionAccessor.GetDescriptionText Method

FailureDefinitionAccessorGetDescriptionText Method

Retrieves the description text of the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetDescriptionText()
Public Function GetDescriptionText As String
public:
String^ GetDescriptionText()
member GetDescriptionText : unit -> string

Return Value

String
The description text.
Exceptions
Exception | Condition
InvalidOperationException | The FailureDefinitionAccessor has not been properly initialized.
Remarks
Retrieved description text for built-in Revit failures is localized. The result may vary from the description text retrieved from the corresponding FailureMessage. A failure definition contains a description string, that may have format specifiers like %s, and "sample" strings, that will be used to resolve them. A FailureMessage will contain "specific" strings. So, in the failure definition description "Cannot keep %s joined" will be converted into "Cannot keep Element joined" while the description in actual FailureMessage will read "Cannot keep Walls joined" or "Cannot keep Beams joined"
See Also

Reference

FailureDefinitionAccessor Class


FailureDefinitionAccessor.GetId Method

FailureDefinitionAccessorGetId Method

Retrieves the unique identifier of the FailureDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FailureDefinitionId GetId()
Public Function GetId As FailureDefinitionId
public:
FailureDefinitionId^ GetId()
member GetId : unit -> FailureDefinitionId

Return Value

FailureDefinitionId
The unique identifier of the FailureDefinition.
Exceptions
Exception | Condition
InvalidOperationException | The FailureDefinitionAccessor has not been properly initialized.
See Also

Reference

FailureDefinitionAccessor Class


FailureDefinitionAccessor.GetResolutionCaption Method

FailureDefinitionAccessorGetResolutionCaption Method

Retrieves the caption for a specific resolution type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetResolutionCaption(
    FailureResolutionType type
)
Public Function GetResolutionCaption (
    type As FailureResolutionType
) As String
public:
String^ GetResolutionCaption(
    FailureResolutionType type
)
member GetResolutionCaption :
        type : FailureResolutionType -> string

Parameters

type FailureResolutionType
The resolution type.

Return Value

String
The caption of the resolution.
Exceptions
Exception | Condition
ArgumentException | Resolution of the type is not applicable to the failure.
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | The FailureDefinitionAccessor has not been properly initialized. -or- FailureDefinition does not have any resolutions.
See Also

Reference

FailureDefinitionAccessor Class


FailureDefinitionAccessor.GetSeverity Method

FailureDefinitionAccessorGetSeverity Method

Retrieves severity of the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FailureSeverity GetSeverity()
Public Function GetSeverity As FailureSeverity
public:
FailureSeverity GetSeverity()
member GetSeverity : unit -> FailureSeverity

Return Value

FailureSeverity
The severity of the failure.
Exceptions
Exception | Condition
InvalidOperationException | The FailureDefinitionAccessor has not been properly initialized.
See Also

Reference

FailureDefinitionAccessor Class


FailureDefinitionAccessor.HasResolutions Method

FailureDefinitionAccessorHasResolutions Method

Checks if the FailureDefinition has at least one resolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasResolutions()
Public Function HasResolutions As Boolean
public:
bool HasResolutions()
member HasResolutions : unit -> bool

Return Value

Boolean
True if at least one resolution is defined in the FailureDefinition.
Exceptions
Exception | Condition
InvalidOperationException | The FailureDefinitionAccessor has not been properly initialized.
See Also

Reference

FailureDefinitionAccessor Class


FailureDefinitionAccessor.IsResolutionApplicable Method

FailureDefinitionAccessorIsResolutionApplicable Method

Checks if the given resolution type is applicable to the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsResolutionApplicable(
    FailureResolutionType type
)
Public Function IsResolutionApplicable (
    type As FailureResolutionType
) As Boolean
public:
bool IsResolutionApplicable(
    FailureResolutionType type
)
member IsResolutionApplicable :
        type : FailureResolutionType -> bool

Parameters

type FailureResolutionType
The resolution type to check.

Return Value

Boolean
True if the given resolution type is applicable to the failure, false otherwise.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | The FailureDefinitionAccessor has not been properly initialized.
See Also

Reference

FailureDefinitionAccessor Class


FailureDefinitionAccessor.SetDefaultResolutionType Method

FailureDefinitionAccessorSetDefaultResolutionType Method

Sets the default resolution type for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetDefaultResolutionType(
    FailureResolutionType type
)
Public Sub SetDefaultResolutionType (
    type As FailureResolutionType
)
public:
void SetDefaultResolutionType(
    FailureResolutionType type
)
member SetDefaultResolutionType :
        type : FailureResolutionType -> unit

Parameters

type FailureResolutionType
The type of resolution to be used as default.
Exceptions
Exception | Condition
ArgumentException | Resolution of the type is not applicable to the failure.
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | The FailureDefinitionAccessor has not been properly initialized. -or- FailureDefinition does not have any resolutions.
Remarks
If failure has multiple resolutions, one of them is designated as designated as the default resolution. The default resolution is used by Revit failure processing mechanism to resolve failures automatically when applicable.
See Also

Reference

FailureDefinitionAccessor Class


FailureDefinitionId Class

The unique identifier of a FailureDefinition.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBGuidEnum
Autodesk.Revit.DBFailureDefinitionId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FailureDefinitionId : GuidEnum
Public Class FailureDefinitionId
    Inherits GuidEnum
public ref class FailureDefinitionId : public GuidEnum
type FailureDefinitionId =
    class
        inherit GuidEnum
    end

The FailureDefinitionId type exposes the following members.

Constructors
 | Name | Description
Public method | FailureDefinitionId | Creates a new FailureDefinitionId instance.
Top
Properties
 | Name | Description
Public property | Guid | The Guid of GUID-based enum object. (Inherited from GuidEnum)
Top
Methods
 | Name | Description
Public method | Equals | Compares two Guid-based enum object based on their concrete class and GUID value. (Inherited from GuidEnum)
Public method | GetHashCode | Generates a hash code for this Guid-based enum object. (Inherited from GuidEnum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Operators
Name | Description
Equality(FailureDefinitionId, FailureDefinitionId) | Compares two FailureDefinitionId instances.
Inequality(FailureDefinitionId, FailureDefinitionId) | Compares two FailureDefinitionId instances.
Top
Remarks
Each possible failure in Revit must be defined and registered during Revit application startup by creating a FailureDefinition object. Unique FailureDefinitionId must be used as a key to register FailureDefinition. Those unique FailureDefinitionId should be created using GUID generation tool. Later FailureDefinitionId can be used to lookup FailureDefinition in FailureDefinitionRegistry, and create and post FailureMessages.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FailureDefinitionId Constructor

Creates a new FailureDefinitionId instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FailureDefinitionId(
    Guid guid
)
Public Sub New (
    guid As Guid
)
public:
FailureDefinitionId(
    Guid guid
)
new :
        guid : Guid -> FailureDefinitionId

Parameters

guid Guid
The identifier for the FailureDefinitionId.
See Also

Reference

FailureDefinitionId Class


FailureDefinitionId Properties

The FailureDefinitionId type exposes the following members.

Properties
 | Name | Description
Public property | Guid | The Guid of GUID-based enum object. (Inherited from GuidEnum)
Top
See Also

Reference

FailureDefinitionId Class


FailureDefinitionId Methods

The FailureDefinitionId type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares two Guid-based enum object based on their concrete class and GUID value. (Inherited from GuidEnum)
Public method | GetHashCode | Generates a hash code for this Guid-based enum object. (Inherited from GuidEnum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FailureDefinitionId Class


FailureDefinitionId Operators

The FailureDefinitionId type exposes the following members.

Operators
Name | Description
Equality(FailureDefinitionId, FailureDefinitionId) | Compares two FailureDefinitionId instances.
Inequality(FailureDefinitionId, FailureDefinitionId) | Compares two FailureDefinitionId instances.
Top
See Also

Reference

FailureDefinitionId Class


FailureDefinitionId.Equality Operator

FailureDefinitionIdEquality Operator

Compares two FailureDefinitionId instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool operator ==(
    FailureDefinitionId first,
    FailureDefinitionId second
)
Public Shared Operator = (
    first As FailureDefinitionId,
    second As FailureDefinitionId
) As Boolean
public:
static bool operator ==(
    FailureDefinitionId^ first,
    FailureDefinitionId^ second
)
static let inline (=)
        first : FailureDefinitionId *
        second : FailureDefinitionId  : bool

Parameters

first FailureDefinitionId
The first FailureDefinitionId.
second FailureDefinitionId
The second FailureDefinitionId.

Return Value

Boolean
True if the inputs are identical, false if they are different.
See Also

Reference

FailureDefinitionId Class


FailureDefinitionId.Inequality Operator

FailureDefinitionIdInequality Operator

Compares two FailureDefinitionId instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool operator !=(
    FailureDefinitionId first,
    FailureDefinitionId second
)
Public Shared Operator <> (
    first As FailureDefinitionId,
    second As FailureDefinitionId
) As Boolean
public:
static bool operator !=(
    FailureDefinitionId^ first,
    FailureDefinitionId^ second
)
static let inline (<>)
        first : FailureDefinitionId *
        second : FailureDefinitionId  : bool

Parameters

first FailureDefinitionId
The first FailureDefinitionId.
second FailureDefinitionId
The second FailureDefinitionId.

Return Value

Boolean
True if the inputs are different, false if they are identical.
See Also

Reference

FailureDefinitionId Class


FailureDefinitionRegistry Class

The global registry for all FailureDefinitions in the Revit session.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFailureDefinitionRegistry

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FailureDefinitionRegistry : IDisposable
Public Class FailureDefinitionRegistry
    Implements IDisposable
public ref class FailureDefinitionRegistry : IDisposable
type FailureDefinitionRegistry =
    class
        interface IDisposable
    end

The FailureDefinitionRegistry type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the FailureDefinitionRegistry
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | FindFailureDefinition | Finds a specific FailureDefinition by a given FailureDefinitionId.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ListAllFailureDefinitions | Retrieves all the registered FailureDefinitions.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
When a FailureDefinition is created, it will be registered in this registry automatically. Registration is allowed only during Revit Application startup - after that FailureDefinitionRegistry is locked and creation of new FailureDefinitions is not allowed. There is only one instance of FailureDefinitionRegistry in session. GetFailureDefinitionRegistry
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FailureDefinitionRegistry Properties

The FailureDefinitionRegistry type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

FailureDefinitionRegistry Class


FailureDefinitionRegistry.IsValidObject Property

FailureDefinitionRegistryIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

FailureDefinitionRegistry Class


FailureDefinitionRegistry Methods

The FailureDefinitionRegistry type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | FindFailureDefinition | Finds a specific FailureDefinition by a given FailureDefinitionId.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ListAllFailureDefinitions | Retrieves all the registered FailureDefinitions.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FailureDefinitionRegistry Class


FailureDefinitionRegistry.Dispose Method

FailureDefinitionRegistryDispose Method

Releases all resources used by the FailureDefinitionRegistry

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FailureDefinitionRegistry Class


FailureDefinitionRegistry.FindFailureDefinition Method

FailureDefinitionRegistryFindFailureDefinition Method

Finds a specific FailureDefinition by a given FailureDefinitionId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FailureDefinitionAccessor FindFailureDefinition(
    FailureDefinitionId id
)
Public Function FindFailureDefinition (
    id As FailureDefinitionId
) As FailureDefinitionAccessor
public:
FailureDefinitionAccessor^ FindFailureDefinition(
    FailureDefinitionId^ id
)
member FindFailureDefinition :
        id : FailureDefinitionId -> FailureDefinitionAccessor

Parameters

id FailureDefinitionId
The id of the FailureDefinition.

Return Value

FailureDefinitionAccessor
The accessor of the found FailureDefinition, or null, if the FailureDefinition was not found.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FailureDefinitionRegistry Class


FailureDefinitionRegistry.ListAllFailureDefinitions Method

FailureDefinitionRegistryListAllFailureDefinitions Method

Retrieves all the registered FailureDefinitions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<FailureDefinitionAccessor> ListAllFailureDefinitions()
Public Function ListAllFailureDefinitions As IList(Of FailureDefinitionAccessor)
public:
IList<FailureDefinitionAccessor^>^ ListAllFailureDefinitions()
member ListAllFailureDefinitions : unit -> IList<FailureDefinitionAccessor>

Return Value

IList FailureDefinitionAccessor
All the registered FailureDefinitions.
See Also

Reference

FailureDefinitionRegistry Class


FailureHandlingOptions Class

Options to control how failures (if any occurred during the transaction) should be handled at the time the transaction is being ended.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFailureHandlingOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FailureHandlingOptions : IDisposable
Public Class FailureHandlingOptions
    Implements IDisposable
public ref class FailureHandlingOptions : IDisposable
type FailureHandlingOptions =
    class
        interface IDisposable
    end

The FailureHandlingOptions type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the FailureHandlingOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetClearAfterRollback | Obtains the flag indicating if all posted failures should be removed silently when transaction is being rolled back.
Public method | GetDelayedMiniWarnings | Obtains the flag indicating if showing of mini-warning dialog should be delayed until the end of next transaction.
Public method | GetFailuresPreprocessor | Gets the callback to be invoked in the beginning of failure processing.
Public method | GetForcedModalHandling | Obtains the flag indicating if the error handling dialog shown at the end of the failing transaction should be modal.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetTransactionFinalizer | Gets the callback to be executed after transaction is completed.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetClearAfterRollback | Sets a flag indicating that Revit should clear all posted failures silently when the failing transaction is being rolled back intentionally. If not set, the failures may still be displayed to the user during rollback.
Public method | SetDelayedMiniWarnings | Sets a flag indicating if Revit should delay the display of the mini-warning dialog (if one is to be shown as a result of warnings in the current transaction) until the end of the next transaction.
Public method | SetFailuresPreprocessor | Sets the callback to be invoked in the beginning of failure processing.
Public method | SetForcedModalHandling | Sets a flag indicating whether Revit will show a modal (blocking) error dialog if the transaction failed to finish.
Public method | SetTransactionFinalizer | Sets the callback to be executed after the transaction is completed.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FailureHandlingOptions Properties

The FailureHandlingOptions type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

FailureHandlingOptions Class


FailureHandlingOptions.IsValidObject Property

FailureHandlingOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

FailureHandlingOptions Class


FailureHandlingOptions Methods

The FailureHandlingOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetClearAfterRollback | Obtains the flag indicating if all posted failures should be removed silently when transaction is being rolled back.
Public method | GetDelayedMiniWarnings | Obtains the flag indicating if showing of mini-warning dialog should be delayed until the end of next transaction.
Public method | GetFailuresPreprocessor | Gets the callback to be invoked in the beginning of failure processing.
Public method | GetForcedModalHandling | Obtains the flag indicating if the error handling dialog shown at the end of the failing transaction should be modal.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetTransactionFinalizer | Gets the callback to be executed after transaction is completed.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetClearAfterRollback | Sets a flag indicating that Revit should clear all posted failures silently when the failing transaction is being rolled back intentionally. If not set, the failures may still be displayed to the user during rollback.
Public method | SetDelayedMiniWarnings | Sets a flag indicating if Revit should delay the display of the mini-warning dialog (if one is to be shown as a result of warnings in the current transaction) until the end of the next transaction.
Public method | SetFailuresPreprocessor | Sets the callback to be invoked in the beginning of failure processing.
Public method | SetForcedModalHandling | Sets a flag indicating whether Revit will show a modal (blocking) error dialog if the transaction failed to finish.
Public method | SetTransactionFinalizer | Sets the callback to be executed after the transaction is completed.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FailureHandlingOptions Class


FailureHandlingOptions.Dispose Method

FailureHandlingOptionsDispose Method

Releases all resources used by the FailureHandlingOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FailureHandlingOptions Class


FailureHandlingOptions.GetClearAfterRollback Method

FailureHandlingOptionsGetClearAfterRollback Method

Obtains the flag indicating if all posted failures should be removed silently when transaction is being rolled back.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool GetClearAfterRollback()
Public Function GetClearAfterRollback As Boolean
public:
bool GetClearAfterRollback()
member GetClearAfterRollback : unit -> bool

Return Value

Boolean
True to clear posted failures silently if the transaction is being rolled back, false to keep these failures in place (they may be displayed to the user).
See Also

Reference

FailureHandlingOptions Class


FailureHandlingOptions.GetDelayedMiniWarnings Method

FailureHandlingOptionsGetDelayedMiniWarnings Method

Obtains the flag indicating if showing of mini-warning dialog should be delayed until the end of next transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool GetDelayedMiniWarnings()
Public Function GetDelayedMiniWarnings As Boolean
public:
bool GetDelayedMiniWarnings()
member GetDelayedMiniWarnings : unit -> bool

Return Value

Boolean
True to delay the display of the mini-warning dialog until the end of the next transation, false to display them as this transaction is completed.
See Also

Reference

FailureHandlingOptions Class


FailureHandlingOptions.GetFailuresPreprocessor Method

FailureHandlingOptionsGetFailuresPreprocessor Method

Gets the callback to be invoked in the beginning of failure processing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IFailuresPreprocessor GetFailuresPreprocessor()
Public Function GetFailuresPreprocessor As IFailuresPreprocessor
public:
IFailuresPreprocessor^ GetFailuresPreprocessor()
member GetFailuresPreprocessor : unit -> IFailuresPreprocessor

Return Value

IFailuresPreprocessor
The callback to be invoked in the beginning of failure processing.
See Also

Reference

FailureHandlingOptions Class


FailureHandlingOptions.GetForcedModalHandling Method

FailureHandlingOptionsGetForcedModalHandling Method

Obtains the flag indicating if the error handling dialog shown at the end of the failing transaction should be modal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool GetForcedModalHandling()
Public Function GetForcedModalHandling As Boolean
public:
bool GetForcedModalHandling()
member GetForcedModalHandling : unit -> bool

Return Value

Boolean
True if the options force Revit to use a modal error dialog, false if it allows use of a non-blocking dialog for warnings resulting from this transaction.
See Also

Reference

FailureHandlingOptions Class


FailureHandlingOptions.GetTransactionFinalizer Method

FailureHandlingOptionsGetTransactionFinalizer Method

Gets the callback to be executed after transaction is completed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ITransactionFinalizer GetTransactionFinalizer()
Public Function GetTransactionFinalizer As ITransactionFinalizer
public:
ITransactionFinalizer^ GetTransactionFinalizer()
member GetTransactionFinalizer : unit -> ITransactionFinalizer

Return Value

ITransactionFinalizer
The callback to be executed after transaction is completed.
See Also

Reference

FailureHandlingOptions Class


FailureHandlingOptions.SetClearAfterRollback Method

FailureHandlingOptionsSetClearAfterRollback Method

Sets a flag indicating that Revit should clear all posted failures silently when the failing transaction is being rolled back intentionally. If not set, the failures may still be displayed to the user during rollback.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FailureHandlingOptions SetClearAfterRollback(
    bool bFlag
)
Public Function SetClearAfterRollback (
    bFlag As Boolean
) As FailureHandlingOptions
public:
FailureHandlingOptions^ SetClearAfterRollback(
    bool bFlag
)
member SetClearAfterRollback :
        bFlag : bool -> FailureHandlingOptions

Parameters

bFlag Boolean
True to clear posted failures silently if the transaction is being rolled back, false to keep these failures in place (they may be displayed to the user).

Return Value

FailureHandlingOptions
This FailureHandlingOptions object.
See Also

Reference

FailureHandlingOptions Class


FailureHandlingOptions.SetDelayedMiniWarnings Method

FailureHandlingOptionsSetDelayedMiniWarnings Method

Sets a flag indicating if Revit should delay the display of the mini-warning dialog (if one is to be shown as a result of warnings in the current transaction) until the end of the next transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FailureHandlingOptions SetDelayedMiniWarnings(
    bool bFlag
)
Public Function SetDelayedMiniWarnings (
    bFlag As Boolean
) As FailureHandlingOptions
public:
FailureHandlingOptions^ SetDelayedMiniWarnings(
    bool bFlag
)
member SetDelayedMiniWarnings :
        bFlag : bool -> FailureHandlingOptions

Parameters

bFlag Boolean
True to delay the display of the mini-warning dialog until the end of the next transation, false to display them as this transaction is completed.

Return Value

FailureHandlingOptions
This FailureHandlingOptions object.
Remarks
This controls warnings suitable for the mini-warnings dialog only. If the modal flag is set to true with SetForcedModalHandling(Boolean) then this flag will be ignored.
See Also

Reference

FailureHandlingOptions Class


FailureHandlingOptions.SetFailuresPreprocessor Method

FailureHandlingOptionsSetFailuresPreprocessor Method

Sets the callback to be invoked in the beginning of failure processing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FailureHandlingOptions SetFailuresPreprocessor(
    IFailuresPreprocessor preprocessor
)
Public Function SetFailuresPreprocessor (
    preprocessor As IFailuresPreprocessor
) As FailureHandlingOptions
public:
FailureHandlingOptions^ SetFailuresPreprocessor(
    IFailuresPreprocessor^ preprocessor
)
member SetFailuresPreprocessor :
        preprocessor : IFailuresPreprocessor -> FailureHandlingOptions

Parameters

preprocessor IFailuresPreprocessor
The callback to be invoked in the beginning of failure processing.

Return Value

FailureHandlingOptions
This FailureHandlingOptions object.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FailureHandlingOptions Class


FailureHandlingOptions.SetForcedModalHandling Method

FailureHandlingOptionsSetForcedModalHandling Method

Sets a flag indicating whether Revit will show a modal (blocking) error dialog if the transaction failed to finish.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FailureHandlingOptions SetForcedModalHandling(
    bool bFlag
)
Public Function SetForcedModalHandling (
    bFlag As Boolean
) As FailureHandlingOptions
public:
FailureHandlingOptions^ SetForcedModalHandling(
    bool bFlag
)
member SetForcedModalHandling :
        bFlag : bool -> FailureHandlingOptions

Parameters

bFlag Boolean
True to force Revit to use a modal error dialog, false to allow a non-blocking dialog for warnings resulting from this transaction.

Return Value

FailureHandlingOptions
This FailureHandlingOptions object.
See Also

Reference

FailureHandlingOptions Class


FailureHandlingOptions.SetTransactionFinalizer Method

FailureHandlingOptionsSetTransactionFinalizer Method

Sets the callback to be executed after the transaction is completed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FailureHandlingOptions SetTransactionFinalizer(
    ITransactionFinalizer finalizer
)
Public Function SetTransactionFinalizer (
    finalizer As ITransactionFinalizer
) As FailureHandlingOptions
public:
FailureHandlingOptions^ SetTransactionFinalizer(
    ITransactionFinalizer^ finalizer
)
member SetTransactionFinalizer :
        finalizer : ITransactionFinalizer -> FailureHandlingOptions

Parameters

finalizer ITransactionFinalizer
The callback to be executed after the transaction is completed.

Return Value

FailureHandlingOptions
This FailureHandlingOptions object.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FailureHandlingOptions Class


FailureMessage Class

Represents a message describing a failure of an operation in Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFailureMessage

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FailureMessage : IDisposable
Public Class FailureMessage
    Implements IDisposable
public ref class FailureMessage : IDisposable
type FailureMessage =
    class
        interface IDisposable
    end

The FailureMessage type exposes the following members.

Constructors
 | Name | Description
Public method | FailureMessage | Creates a new FailureMessage related to a given FailureDefinition.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | AddResolution | Adds a resolution for the failure.
Public method | Dispose | Releases all resources used by the FailureMessage
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAdditionalElements | Retrieves list of the additional reference elements for the failure.
Public method | GetDefaultResolutionCaption | Retrieves the caption of the default resolution of the failure.
Public method | GetDescriptionText | Retrieves the description text of the failure.
Public method | GetFailingElements | Retrieves list of the elements that have caused the failure.
Public method | GetFailureDefinitionId | Retrieves the id of the failure definition for the failure.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetSeverity | Retrieves the severity of the failure.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HasResolutionOfType | Checks if failure has a resolution of a given type.
Public method | HasResolutions | Checks if the failure has any resolutions.
Public method | SetAdditionalElement | Sets the additional reference element for the failure.
Public method | SetAdditionalElements | Sets the additional reference elements for the failure.
Public method | SetFailingElement | Sets the element that has caused the failure.
Public method | SetFailingElements | Sets elements that have caused the failure.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Failure messages are typically shown to the user in the Revit error dialog. This class contains the following information about the failures:
  1. The basic description of the failure (retrieved from the FailureDefinition)
  2. The available resolutions for the failure.
  3. The elements related to the failure.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FailureMessage Constructor

Creates a new FailureMessage related to a given FailureDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FailureMessage(
    FailureDefinitionId id
)
Public Sub New (
    id As FailureDefinitionId
)
public:
FailureMessage(
    FailureDefinitionId^ id
)
new :
        id : FailureDefinitionId -> FailureMessage

Parameters

id FailureDefinitionId
Id of FailureDefinition.
Exceptions
Exception | Condition
ArgumentException | id is invalid or does not have corresponding failure definition.
ArgumentNullException | A non-optional argument was null
See Also

Reference

FailureMessage Class


FailureMessage Properties

The FailureMessage type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

FailureMessage Class


FailureMessage.IsValidObject Property

FailureMessageIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

FailureMessage Class


FailureMessage Methods

The FailureMessage type exposes the following members.

Methods
 | Name | Description
Public method | AddResolution | Adds a resolution for the failure.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAdditionalElements | Retrieves list of the additional reference elements for the failure.
Public method | GetDefaultResolutionCaption | Retrieves the caption of the default resolution of the failure.
Public method | GetDescriptionText | Retrieves the description text of the failure.
Public method | GetFailingElements | Retrieves list of the elements that have caused the failure.
Public method | GetFailureDefinitionId | Retrieves the id of the failure definition for the failure.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetSeverity | Retrieves the severity of the failure.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HasResolutionOfType | Checks if failure has a resolution of a given type.
Public method | HasResolutions | Checks if the failure has any resolutions.
Public method | SetAdditionalElement | Sets the additional reference element for the failure.
Public method | SetAdditionalElements | Sets the additional reference elements for the failure.
Public method | SetFailingElement | Sets the element that has caused the failure.
Public method | SetFailingElements | Sets elements that have caused the failure.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FailureMessage Class


FailureMessage.AddResolution Method

FailureMessageAddResolution Method

Adds a resolution for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FailureMessage AddResolution(
    FailureResolutionType type,
    FailureResolution resolution
)
Public Function AddResolution (
    type As FailureResolutionType,
    resolution As FailureResolution
) As FailureMessage
public:
FailureMessage^ AddResolution(
    FailureResolutionType type,
    FailureResolution^ resolution
)
member AddResolution :
        type : FailureResolutionType *
        resolution : FailureResolution -> FailureMessage

Parameters

type FailureResolutionType
The type of the resolution.
resolution FailureResolution
The resolution.

Return Value

FailureMessage
The FailureMessage.
Exceptions
Exception | Condition
ArgumentException | type is not a valid resolution type for this FailureMessage. -or- resolution of type is not valid for this FailureMessage. -or- This FailureMessage already contains a resolution of type type.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | This FailureMessage is already posted to a document
Remarks
Each pair of FailureResolutionType and FailureResolution must have been defined in FailureDefinition, and could only be added once.
See Also

Reference

FailureMessage Class


FailureMessage.Dispose Method

FailureMessageDispose Method

Releases all resources used by the FailureMessage

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FailureMessage Class


FailureMessage.GetAdditionalElements Method

FailureMessageGetAdditionalElements Method

Retrieves list of the additional reference elements for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetAdditionalElements()
Public Function GetAdditionalElements As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetAdditionalElements()
member GetAdditionalElements : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
The additional elements.
See Also

Reference

FailureMessage Class


FailureMessage.GetDefaultResolutionCaption Method

FailureMessageGetDefaultResolutionCaption Method

Retrieves the caption of the default resolution of the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetDefaultResolutionCaption()
Public Function GetDefaultResolutionCaption As String
public:
String^ GetDefaultResolutionCaption()
member GetDefaultResolutionCaption : unit -> string

Return Value

String
The caption of the default resolution of the failure.
Exceptions
Exception | Condition
InvalidOperationException | This FailureMessage does not have any resolutions.
See Also

Reference

FailureMessage Class


FailureMessage.GetDescriptionText Method

FailureMessageGetDescriptionText Method

Retrieves the description text of the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetDescriptionText()
Public Function GetDescriptionText As String
public:
String^ GetDescriptionText()
member GetDescriptionText : unit -> string

Return Value

String
The description text.
See Also

Reference

FailureMessage Class


FailureMessage.GetFailingElements Method

FailureMessageGetFailingElements Method

Retrieves list of the elements that have caused the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetFailingElements()
Public Function GetFailingElements As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetFailingElements()
member GetFailingElements : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
The elements that have caused the failure.
See Also

Reference

FailureMessage Class


FailureMessage.GetFailureDefinitionId Method

FailureMessageGetFailureDefinitionId Method

Retrieves the id of the failure definition for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FailureDefinitionId GetFailureDefinitionId()
Public Function GetFailureDefinitionId As FailureDefinitionId
public:
FailureDefinitionId^ GetFailureDefinitionId()
member GetFailureDefinitionId : unit -> FailureDefinitionId

Return Value

FailureDefinitionId
The id of the FailureDefinition for the failure.
See Also

Reference

FailureMessage Class


FailureMessage.GetSeverity Method

FailureMessageGetSeverity Method

Retrieves the severity of the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FailureSeverity GetSeverity()
Public Function GetSeverity As FailureSeverity
public:
FailureSeverity GetSeverity()
member GetSeverity : unit -> FailureSeverity

Return Value

FailureSeverity
The severity of the failure.
See Also

Reference

FailureMessage Class


FailureMessage.HasResolutionOfType Method

FailureMessageHasResolutionOfType Method

Checks if failure has a resolution of a given type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasResolutionOfType(
    FailureResolutionType type
)
Public Function HasResolutionOfType (
    type As FailureResolutionType
) As Boolean
public:
bool HasResolutionOfType(
    FailureResolutionType type
)
member HasResolutionOfType :
        type : FailureResolutionType -> bool

Parameters

type FailureResolutionType
The type of resolution.

Return Value

Boolean
True if the failure has a type of resolutions, else false.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

FailureMessage Class


FailureMessage.HasResolutions Method

FailureMessageHasResolutions Method

Checks if the failure has any resolutions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasResolutions()
Public Function HasResolutions As Boolean
public:
bool HasResolutions()
member HasResolutions : unit -> bool

Return Value

Boolean
True if the failure has any resolutions, false otherwise.
See Also

Reference

FailureMessage Class


FailureMessage.SetAdditionalElement Method

FailureMessageSetAdditionalElement Method

Sets the additional reference element for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FailureMessage SetAdditionalElement(
    ElementId additionalElement
)
Public Function SetAdditionalElement (
    additionalElement As ElementId
) As FailureMessage
public:
FailureMessage^ SetAdditionalElement(
    ElementId^ additionalElement
)
member SetAdditionalElement :
        additionalElement : ElementId -> FailureMessage

Parameters

additionalElement ElementId
The additional element.

Return Value

FailureMessage
The FailureMessage.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This FailureMessage is already posted to a document
Remarks
Additional elements are used to highlight additional information to the user. They are not considered as causing the failure, but are related to it. User cannot delete them in extended error dialog.
See Also

Reference

FailureMessage Class


FailureMessage.SetAdditionalElements Method

FailureMessageSetAdditionalElements Method

Sets the additional reference elements for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FailureMessage SetAdditionalElements(
    ICollection<ElementId> additionalElements
)
Public Function SetAdditionalElements (
    additionalElements As ICollection(Of ElementId)
) As FailureMessage
public:
FailureMessage^ SetAdditionalElements(
    ICollection<ElementId^>^ additionalElements
)
member SetAdditionalElements :
        additionalElements : ICollection<ElementId> -> FailureMessage

Parameters

additionalElements ICollection ElementId
The additional elements.

Return Value

FailureMessage
The FailureMessage.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This FailureMessage is already posted to a document
Remarks
Additional elements are used to highlight additional information to the user. They are not considered as causing the failure, but are related to it. User cannot delete them in extended error dialog.
See Also

Reference

FailureMessage Class


FailureMessage.SetFailingElement Method

FailureMessageSetFailingElement Method

Sets the element that has caused the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FailureMessage SetFailingElement(
    ElementId id
)
Public Function SetFailingElement (
    id As ElementId
) As FailureMessage
public:
FailureMessage^ SetFailingElement(
    ElementId^ id
)
member SetFailingElement :
        id : ElementId -> FailureMessage

Parameters

id ElementId
The element that has caused the failure.

Return Value

FailureMessage
The FailureMessage.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This FailureMessage is already posted to a document
Remarks
In Revit error dialog this element will be highlighted to the user and can be deleted by user via extended error dialog.
See Also

Reference

FailureMessage Class


FailureMessage.SetFailingElements Method

FailureMessageSetFailingElements Method

Sets elements that have caused the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FailureMessage SetFailingElements(
    ICollection<ElementId> idsToShow
)
Public Function SetFailingElements (
    idsToShow As ICollection(Of ElementId)
) As FailureMessage
public:
FailureMessage^ SetFailingElements(
    ICollection<ElementId^>^ idsToShow
)
member SetFailingElements :
        idsToShow : ICollection<ElementId> -> FailureMessage

Parameters

idsToShow ICollection ElementId
The elements that have caused the failure.

Return Value

FailureMessage
The FailureMessage.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This FailureMessage is already posted to a document
Remarks
In the Revit error dialog these elements will be highlighted to the user and can be deleted by user via extended error dialog.
See Also

Reference

FailureMessage Class


FailureMessageAccessor Class

Restricted accessor for FailureMessage.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFailureMessageAccessor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FailureMessageAccessor : IDisposable
Public Class FailureMessageAccessor
    Implements IDisposable
public ref class FailureMessageAccessor : IDisposable
type FailureMessageAccessor =
    class
        interface IDisposable
    end

The FailureMessageAccessor type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | CloneFailureMessage | Creates a copy of the FailureMessage.
Public method | Dispose | Releases all resources used by the FailureMessageAccessor
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAdditionalElementIds | Retrieves Ids of Elements that have not caused the failure but are related to it Checks if the failure has resolution of a given resolution type.
Public method | GetCurrentResolutionType | Retrieves the type of resolution to be used to resolve the failure.
Public method | GetDefaultResolutionCaption | Retrieves the caption of default resolution of the failure.
Public method | GetDescriptionText | Retrieves the description of the failure.
Public method | GetFailingElementIds | Retrieves Ids of Elements that have caused the failure.
Public method | GetFailureDefinitionId | Retrieves the Id of the FailureDefinition of the failure.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetNumberOfResolutions | Retrieves number of resolutions that can be used to resolve failure.
Public method | GetSeverity | Retrieves the severity of the failure.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HasResolutionOfType | Checks if failure has a resolution of a given type.
Public method | HasResolutions | Checks if the failure has any resolutions.
Public method | SetCurrentResolutionType | Sets the type of a resolution to be used to resolve the failure.
Public method | ShouldMergeWithMessage | Checks if the FailureMessage should be merged with the other FailureMessage for better user experience.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Provides access to a FailureMessage stored in a Document. Reading of the information from the FailureMessage is allowed, changing of information is generally not allowed, except setting of the current resolution type.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FailureMessageAccessor Properties

The FailureMessageAccessor type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

FailureMessageAccessor Class


FailureMessageAccessor.IsValidObject Property

FailureMessageAccessorIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

FailureMessageAccessor Class


FailureMessageAccessor Methods

The FailureMessageAccessor type exposes the following members.

Methods
 | Name | Description
Public method | CloneFailureMessage | Creates a copy of the FailureMessage.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAdditionalElementIds | Retrieves Ids of Elements that have not caused the failure but are related to it Checks if the failure has resolution of a given resolution type.
Public method | GetCurrentResolutionType | Retrieves the type of resolution to be used to resolve the failure.
Public method | GetDefaultResolutionCaption | Retrieves the caption of default resolution of the failure.
Public method | GetDescriptionText | Retrieves the description of the failure.
Public method | GetFailingElementIds | Retrieves Ids of Elements that have caused the failure.
Public method | GetFailureDefinitionId | Retrieves the Id of the FailureDefinition of the failure.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetNumberOfResolutions | Retrieves number of resolutions that can be used to resolve failure.
Public method | GetSeverity | Retrieves the severity of the failure.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HasResolutionOfType | Checks if failure has a resolution of a given type.
Public method | HasResolutions | Checks if the failure has any resolutions.
Public method | SetCurrentResolutionType | Sets the type of a resolution to be used to resolve the failure.
Public method | ShouldMergeWithMessage | Checks if the FailureMessage should be merged with the other FailureMessage for better user experience.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FailureMessageAccessor Class


FailureMessageAccessor.CloneFailureMessage Method

FailureMessageAccessorCloneFailureMessage Method

Creates a copy of the FailureMessage.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FailureMessage CloneFailureMessage()
Public Function CloneFailureMessage As FailureMessage
public:
FailureMessage^ CloneFailureMessage()
member CloneFailureMessage : unit -> FailureMessage

Return Value

FailureMessage
Copy of the FailureMesassge.
Exceptions
Exception | Condition
InvalidOperationException | This FailureMessageAccessor has not been properly initialized.
See Also

Reference

FailureMessageAccessor Class


FailureMessageAccessor.Dispose Method

FailureMessageAccessorDispose Method

Releases all resources used by the FailureMessageAccessor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FailureMessageAccessor Class


FailureMessageAccessor.GetAdditionalElementIds Method

FailureMessageAccessorGetAdditionalElementIds Method

Retrieves Ids of Elements that have not caused the failure but are related to it Checks if the failure has resolution of a given resolution type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetAdditionalElementIds()
Public Function GetAdditionalElementIds As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetAdditionalElementIds()
member GetAdditionalElementIds : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
Ids of Elements related to the failure
Exceptions
Exception | Condition
InvalidOperationException | This FailureMessageAccessor has not been properly initialized.
See Also

Reference

FailureMessageAccessor Class


FailureMessageAccessor.GetCurrentResolutionType Method

FailureMessageAccessorGetCurrentResolutionType Method

Retrieves the type of resolution to be used to resolve the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FailureResolutionType GetCurrentResolutionType()
Public Function GetCurrentResolutionType As FailureResolutionType
public:
FailureResolutionType GetCurrentResolutionType()
member GetCurrentResolutionType : unit -> FailureResolutionType

Return Value

FailureResolutionType
The type of failure resolution to be used to resolve the failure.
Exceptions
Exception | Condition
InvalidOperationException | This FailureMessageAccessor has not been properly initialized. -or- This FailureMessageAccessor does not have any resolutions.
Remarks
If the current resolution type was never set for the failure, FailureResolutionType::Default is returned.
See Also

Reference

FailureMessageAccessor Class


FailureMessageAccessor.GetDefaultResolutionCaption Method

FailureMessageAccessorGetDefaultResolutionCaption Method

Retrieves the caption of default resolution of the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetDefaultResolutionCaption()
Public Function GetDefaultResolutionCaption As String
public:
String^ GetDefaultResolutionCaption()
member GetDefaultResolutionCaption : unit -> string

Return Value

String
The caption of default resolution of the failure.
Exceptions
Exception | Condition
InvalidOperationException | This FailureMessageAccessor has not been properly initialized.
See Also

Reference

FailureMessageAccessor Class


FailureMessageAccessor.GetDescriptionText Method

FailureMessageAccessorGetDescriptionText Method

Retrieves the description of the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetDescriptionText()
Public Function GetDescriptionText As String
public:
String^ GetDescriptionText()
member GetDescriptionText : unit -> string

Return Value

String
The description text.
Exceptions
Exception | Condition
InvalidOperationException | This FailureMessageAccessor has not been properly initialized.
See Also

Reference

FailureMessageAccessor Class


FailureMessageAccessor.GetFailingElementIds Method

FailureMessageAccessorGetFailingElementIds Method

Retrieves Ids of Elements that have caused the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetFailingElementIds()
Public Function GetFailingElementIds As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetFailingElementIds()
member GetFailingElementIds : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
Ids of Elements that have caused the failure.
Exceptions
Exception | Condition
InvalidOperationException | This FailureMessageAccessor has not been properly initialized.
See Also

Reference

FailureMessageAccessor Class


FailureMessageAccessor.GetFailureDefinitionId Method

FailureMessageAccessorGetFailureDefinitionId Method

Retrieves the Id of the FailureDefinition of the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FailureDefinitionId GetFailureDefinitionId()
Public Function GetFailureDefinitionId As FailureDefinitionId
public:
FailureDefinitionId^ GetFailureDefinitionId()
member GetFailureDefinitionId : unit -> FailureDefinitionId

Return Value

FailureDefinitionId
The Id of the FailureDefinition of the failure.
Exceptions
Exception | Condition
InvalidOperationException | This FailureMessageAccessor has not been properly initialized.
See Also

Reference

FailureMessageAccessor Class


FailureMessageAccessor.GetNumberOfResolutions Method

FailureMessageAccessorGetNumberOfResolutions Method

Retrieves number of resolutions that can be used to resolve failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetNumberOfResolutions()
Public Function GetNumberOfResolutions As Integer
public:
int GetNumberOfResolutions()
member GetNumberOfResolutions : unit -> int

Return Value

Int32
Number of resolutions that can be used to resolve failure
Exceptions
Exception | Condition
InvalidOperationException | This FailureMessageAccessor has not been properly initialized.
Remarks
If number of resolutions is zero, the failure cannot be resolved. If severity of the failure is Warning, it can be deleted. Otherwise, the only option is to cancel current operation and roll back the transaction
See Also

Reference

FailureMessageAccessor Class


FailureMessageAccessor.GetSeverity Method

FailureMessageAccessorGetSeverity Method

Retrieves the severity of the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FailureSeverity GetSeverity()
Public Function GetSeverity As FailureSeverity
public:
FailureSeverity GetSeverity()
member GetSeverity : unit -> FailureSeverity

Return Value

FailureSeverity
The severity of the failure.
Exceptions
Exception | Condition
InvalidOperationException | This FailureMessageAccessor has not been properly initialized.
See Also

Reference

FailureMessageAccessor Class


FailureMessageAccessor.HasResolutionOfType Method

FailureMessageAccessorHasResolutionOfType Method

Checks if failure has a resolution of a given type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasResolutionOfType(
    FailureResolutionType type
)
Public Function HasResolutionOfType (
    type As FailureResolutionType
) As Boolean
public:
bool HasResolutionOfType(
    FailureResolutionType type
)
member HasResolutionOfType :
        type : FailureResolutionType -> bool

Parameters

type FailureResolutionType
The type of resolution.

Return Value

Boolean
True if failure has a resolution of a given type, false otherwise.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | This FailureMessageAccessor has not been properly initialized.
See Also

Reference

FailureMessageAccessor Class


FailureMessageAccessor.HasResolutions Method

FailureMessageAccessorHasResolutions Method

Checks if the failure has any resolutions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasResolutions()
Public Function HasResolutions As Boolean
public:
bool HasResolutions()
member HasResolutions : unit -> bool

Return Value

Boolean
True if the failure has any resolutions, false otherwise.
Exceptions
Exception | Condition
InvalidOperationException | This FailureMessageAccessor has not been properly initialized.
See Also

Reference

FailureMessageAccessor Class


FailureMessageAccessor.SetCurrentResolutionType Method

FailureMessageAccessorSetCurrentResolutionType Method

Sets the type of a resolution to be used to resolve the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetCurrentResolutionType(
    FailureResolutionType resolutionType
)
Public Sub SetCurrentResolutionType (
    resolutionType As FailureResolutionType
)
public:
void SetCurrentResolutionType(
    FailureResolutionType resolutionType
)
member SetCurrentResolutionType :
        resolutionType : FailureResolutionType -> unit

Parameters

resolutionType FailureResolutionType
The type of failure resolution to be used to resolve the failure.
Exceptions
Exception | Condition
ArgumentException | This FailureMessageAccessor has no resolution of resolutionType.
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | This FailureMessageAccessor has not been properly initialized. -or- This FailureMessageAccessor does not have any resolutions.
Remarks
When FailuresAccessor is used to resolve failures, it will execute resolutions based on current resolution type. If no current resolution type is set, the default resolution type will be used. Setting is performed on the FailureMessageAccessor object itself, so if there are several accessors issued for the same FailureMessage, setting of the resolution type performed on one of them does not impact the others.
See Also

Reference

FailureMessageAccessor Class


FailureMessageAccessor.ShouldMergeWithMessage Method

FailureMessageAccessorShouldMergeWithMessage Method

Checks if the FailureMessage should be merged with the other FailureMessage for better user experience.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldMergeWithMessage(
    FailureMessageAccessor messageToMergeWith
)
Public Function ShouldMergeWithMessage (
    messageToMergeWith As FailureMessageAccessor
) As Boolean
public:
bool ShouldMergeWithMessage(
    FailureMessageAccessor^ messageToMergeWith
)
member ShouldMergeWithMessage :
        messageToMergeWith : FailureMessageAccessor -> bool

Parameters

messageToMergeWith FailureMessageAccessor

Return Value

Boolean
True if messages should be merged
Exceptions
Exception | Condition
ArgumentException | messageToMergeWith has not been properly initialized.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This FailureMessageAccessor has not been properly initialized.
Remarks
Messages should be merged if all user-visible information except failing elements is the same, failure resolution types are the same and merging lists of failing elements keeps message text applicable to all of them equally. Method is used by the Revit UI to display multiple messages as one.
See Also

Reference

FailureMessageAccessor Class


FailureMessageKey Class

A unique key assigned to each posted failure message
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFailureMessageKey

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FailureMessageKey : IDisposable
Public Class FailureMessageKey
    Implements IDisposable
public ref class FailureMessageKey : IDisposable
type FailureMessageKey =
    class
        interface IDisposable
    end

The FailureMessageKey type exposes the following members.

Constructors
 | Name | Description
Public method | FailureMessageKey | Constructs a new FailureMessageKey with default settings.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the FailureMessageKey
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object))
Public method | GetHashCode | Gets the integer value of the id as hash code (Overrides ObjectGetHashCode)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqual | Checks it this key is equal to the other.
Public method | IsValid | Checks if the failure message key is valid
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Operators
Name | Description
Equality(FailureMessageKey, FailureMessageKey) | Determines whether two FailureMessageKeys are the same.
Inequality(FailureMessageKey, FailureMessageKey) | Determines whether two FailureMessageKeys are different.
Top
Remarks
When a failure message is posted, it gets a unique key assigned and returned to the caller. The key is guaranteed to be unique in the Revit session. The key can be used to unpost (delete) previously posted failure message if it is no longer valid.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FailureMessageKey Constructor

Constructs a new FailureMessageKey with default settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FailureMessageKey()
Public Sub New
public:
FailureMessageKey()
new : unit -> FailureMessageKey
See Also

Reference

FailureMessageKey Class


FailureMessageKey Properties

The FailureMessageKey type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

FailureMessageKey Class


FailureMessageKey.IsValidObject Property

FailureMessageKeyIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

FailureMessageKey Class


FailureMessageKey Methods

The FailureMessageKey type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object))
Public method | GetHashCode | Gets the integer value of the id as hash code (Overrides ObjectGetHashCode)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqual | Checks it this key is equal to the other.
Public method | IsValid | Checks if the failure message key is valid
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FailureMessageKey Class


FailureMessageKey.Dispose Method

FailureMessageKeyDispose Method

Releases all resources used by the FailureMessageKey

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FailureMessageKey Class


FailureMessageKey.Equals Method

FailureMessageKeyEquals Method

Determines whether the specified Object is equal to the current Object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj Object
Another object.

Return Value

Boolean
See Also

Reference

FailureMessageKey Class


FailureMessageKey.GetHashCode Method

FailureMessageKeyGetHashCode Method

Gets the integer value of the id as hash code

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Int32
See Also

Reference

FailureMessageKey Class


FailureMessageKey.IsEqual Method

FailureMessageKeyIsEqual Method

Checks it this key is equal to the other.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEqual(
    FailureMessageKey other
)
Public Function IsEqual (
    other As FailureMessageKey
) As Boolean
public:
bool IsEqual(
    FailureMessageKey^ other
)
member IsEqual :
        other : FailureMessageKey -> bool

Parameters

other FailureMessageKey
The key to compare with.

Return Value

Boolean
True if keys are equal, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FailureMessageKey Class


FailureMessageKey.IsValid Method

FailureMessageKeyIsValid Method

Checks if the failure message key is valid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValid()
Public Function IsValid As Boolean
public:
bool IsValid()
member IsValid : unit -> bool

Return Value

Boolean
True if the failure message key is valid
See Also

Reference

FailureMessageKey Class


FailureMessageKey Operators

The FailureMessageKey type exposes the following members.

Operators
Name | Description
Equality(FailureMessageKey, FailureMessageKey) | Determines whether two FailureMessageKeys are the same.
Inequality(FailureMessageKey, FailureMessageKey) | Determines whether two FailureMessageKeys are different.
Top
See Also

Reference

FailureMessageKey Class


FailureMessageKey.Equality Operator

FailureMessageKeyEquality Operator

Determines whether two FailureMessageKeys are the same.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool operator ==(
    FailureMessageKey first,
    FailureMessageKey second
)
Public Shared Operator = (
    first As FailureMessageKey,
    second As FailureMessageKey
) As Boolean
public:
static bool operator ==(
    FailureMessageKey^ first,
    FailureMessageKey^ second
)
static let inline (=)
        first : FailureMessageKey *
        second : FailureMessageKey  : bool

Parameters

first FailureMessageKey
The first FailureMessageKey.
second FailureMessageKey
The second FailureMessageKey.

Return Value

Boolean
True if the FailureMessageKeys are the same; otherwise, false.
See Also

Reference

FailureMessageKey Class


FailureMessageKey.Inequality Operator

FailureMessageKeyInequality Operator

Determines whether two FailureMessageKeys are different.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool operator !=(
    FailureMessageKey first,
    FailureMessageKey second
)
Public Shared Operator <> (
    first As FailureMessageKey,
    second As FailureMessageKey
) As Boolean
public:
static bool operator !=(
    FailureMessageKey^ first,
    FailureMessageKey^ second
)
static let inline (<>)
        first : FailureMessageKey *
        second : FailureMessageKey  : bool

Parameters

first FailureMessageKey
The first FailureMessageKey.
second FailureMessageKey
The second FailureMessageKey.

Return Value

Boolean
True if the FailureMessageKeys are different; otherwise, false.
See Also

Reference

FailureMessageKey Class


FailureProcessingResult Enumeration

An enumerated type representing the result achieved by any of the available types of failure handlers: FailuresPreprocessor, the handler of FailuresProcessing event or a FailuresProcessor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum FailureProcessingResult
Public Enumeration FailureProcessingResult
public enum class FailureProcessingResult
type FailureProcessingResult
Members
Member name | Value | Description
Continue | 0 | This value should be used if no action was taken and/or caller should continue with default failure processing for the open transaction. In the absence of any other available handlers, this means that the Revit user interface will display any errors to the user for resolution. (Warnings will not be displayed if they have been deleted already by the failure handler). If a FailuresProcessor returns Continue with unresolved failures, Revit will instead act as if ProceedWithRollBack was returned.
ProceedWithCommit | 1 | This value should be used if some or all failures were resolved by the handler. It instructs the Revit failure processing/transaction mechanism to try to repeat the transaction committing process. Despite the request to commit to the transaction, there is no guarantee that the commit will succeed. If errors remain unresolved the handler will likely be called again. Handler code should be careful not to try to repeatedly commit if it is unable to deal with all the errors. ProceedWithCommit cannot be used if the transaction is already being rolled back, and will be treated as ProceedWithRollBack in this case.
ProceedWithRollBack | 2 | This value should be returned if the transaction was originally requested to be committed and the failure handler requires it to be rolled back instead. In order to rollback silently, before ProceedWithRollBack is returned the failure handler should set the FailureHandlingOptions to clear errors after rollback. This will cause all failures to be deleted. If this is not set, default failure processing will continue, and failures may be delivered to the user even though the transaction will be rolled back.
WaitForUserInput | 3 | This value should only be returned by a FailuresProcessor - and only if it is waiting for something to happen externally. Typically this would be some sort of user input needed to complete failures processing. If this value is set from any other processor, it will be treated as ProceedWithRollback.
Remarks
The ability to return certain values may be restricted for certain methods or for certain contexts.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FailureResolution Class

Defines a resolution for a failure.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFailureResolution
Autodesk.Revit.DBDeleteElements
Autodesk.Revit.DBDisableAnalyticalModelCB

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FailureResolution : IDisposable
Public Class FailureResolution
    Implements IDisposable
public ref class FailureResolution : IDisposable
type FailureResolution =
    class
        interface IDisposable
    end

The FailureResolution type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the FailureResolution
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
A failure could have several permitted resolutions. List of applicable resolution types for the specific failure is defined by the FailureDefinition, actual FailureResolutions are instantiated with the FailureMessage before it is posted. Multiple resolutions per failure are allowed, although Revit UI only uses default resolution.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FailureResolution Properties

The FailureResolution type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

FailureResolution Class


FailureResolution.IsValidObject Property

FailureResolutionIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

FailureResolution Class


FailureResolution Methods

The FailureResolution type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FailureResolution Class


FailureResolution.Dispose Method

FailureResolutionDispose Method

Releases all resources used by the FailureResolution

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FailureResolution Class


FailureResolutionType Enumeration

Enumeration to classify FailureResolutions by nature of operation they perform on failing Elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum FailureResolutionType
Public Enumeration FailureResolutionType
public enum class FailureResolutionType
type FailureResolutionType
Members
Member name | Value | Description
Invalid | 0 | Special (reserved) type. This should be non-initialized value of any variable of FailureResolutionType, end user should not see this value, API programmer could use this in initialization and comparison.
Default | 1 | Special (reserved) type. It cannot be used as a type when defining a resolution, but can be used as a key to query default resolution from FailureMessage or FailureDefinition.
CreateElements | 2 | Defines a resolution of a failure where Revit will add new Element(s) in place of missing one(s).
DeleteElements | 3 | Defines a resolution of a failure by deleting Element(s) that caused the failure.
SkipElements | 4 | Defines a resolution of a failure by skipping Element(s) for which operation has failed and proceeding with the rest of Elements.
MoveElements | 5 | Defines a resolution of a failure by moving Element(s) to an appropriate location.
FixElements | 6 | Defines a resolution of a failure by changing failing Element(s) - specific change may vary depending in type of failure and type of Element(s).
DetachElements | 7 | Defines a resolution of a failure by removing invalid relationships between elements such as joined walls and roofs, grouped elements, and associated curves.
QuitEditMode | 8 | Defines a resolution of a failure by quitting an Edit Mode instead of committing changes. Changes made in edit mode will be rolled back.
UnlockConstraints | 9 | Defines a resolution of a failure by unconstraining Element(s).
SetValue | 10 | Defines a resolution of a failure by setting an appropriate value in place of invalid value.
SaveDocument | 11 | Save the current document to avoid losing more if something serious occurs.
ShowElements | 12 | The standard "Show" may fail in some context, special resolution could be added in this condition to show failing element(s).
Others | 100,000 | Resolution type does not match any of the above.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FailuresAccessor Class

An interface class that provides access to failure information posted in a document and methods to resolve these failures.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFailuresAccessor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FailuresAccessor : IDisposable
Public Class FailuresAccessor
    Implements IDisposable
public ref class FailuresAccessor : IDisposable
type FailuresAccessor =
    class
        interface IDisposable
    end

The FailuresAccessor type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | CanCommitPendingTransaction | Checks if pending failure processing can be finished by committing a pending transaction.
Public method | CanRollBackPendingTransaction | Checks if pending failure processing can be finished by rolling back a pending transaction.
Public method | CommitPendingTransaction | Finishes pending failures processing by committing the pending transaction.
Public method | DeleteAllWarnings | Deletes all FailureMessages of severity "Warning" currently posted in a document.
Public method | DeleteElements | Resolves failures by deletion of elements related to the failures.
Public method | DeleteWarning | Deletes one specific failure message of severity "Warning".
Public method | Dispose | Releases all resources used by the FailuresAccessor
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAttemptedResolutionTypes | Returns list of the failure resolution types attempted for the failure in the current transaction.
Public method | GetDocument | Provides access to a document for which failures are being processed or preprocessed.
Public method | GetFailureHandlingOptions | Provides access to the failure handling options for the transaction currently being finished.
Public method | GetFailureMessages | Provides access to the individual failure messages currently posted in the document.
Public method | GetFailureMessages(FailureSeverity) | Provides access to the individual failure messages if a given severity currently posted in the document.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetSeverity | Provides access to the current failure severity.
Public method | GetTransactionName | Retrieves the name of the transaction for which failures are being processed.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsActive | Method allows to check if this instance of the accessor is currently active.
Public method | IsElementsDeletionPermitted | Checks if resolution of the failures by deleting failure elements is permitted.
Public method | IsElementsDeletionPermitted(IListElementId) | Checks if resolution of the failures by deleting given collection of elements is permitted.
Public method | IsElementsDeletionPermitted(IListElementId, String) | Checks if resolution of the failures by deleting given collection of elements is permitted.
Public method | IsFailureResolutionPermitted | Checks if resolution of failures is permitted.
Public method | IsFailureResolutionPermitted(FailureMessageAccessor) | Checks if default resolution of the failure is permitted.
Public method | IsFailureResolutionPermitted(FailureMessageAccessor, FailureResolutionType) | Checks if resolution of the failure using given resolution type is permitted.
Public method | IsPending | Checks if the failure processing is pending.
Public method | IsTransactionBeingCommitted | Checks if the transaction for which failures are processed is being committed or rolled back.
Public method | JournalFailures | Allows to record information about failures in the journal.
Public method | PostFailure | Posts an additional failure message to be processed for the current transaction.
Public method | ReplaceFailures | Deletes all failure messages currently posted in a document and replaces them with one "generic" failure.
Public method | ResolveFailure | Resolves one failure using the failure resolution type last set for it.
Public method | ResolveFailures | Resolves one or more failures using last set failure resolution type for each of the failures. If failure resolution type was not set for some of failures, default failure resolution type will be used.
Public method | RollBackPendingTransaction | Finishes pending failures processing by rolling back the pending transaction.
Public method | SetFailureHandlingOptions | Sets failure handling options for the transaction currently being finished.
Public method | SetTransactionName | Changes the name of the transaction for which failures are being processed.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
An instance of this class can be obtained only as an argument passed to interfaces used in the process of failure resolution and is the only available interface to fetch information about failures in a document. While reading from a document during failure processing is allowed, the only way to modify document during failure resolution is via methods provided by this class. After returning from failure processing, the instance of the class is deactivated and cannot be used any longer.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FailuresAccessor Properties

The FailuresAccessor type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

FailuresAccessor Class


FailuresAccessor.IsValidObject Property

FailuresAccessorIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

FailuresAccessor Class


FailuresAccessor Methods

The FailuresAccessor type exposes the following members.

Methods
 | Name | Description
Public method | CanCommitPendingTransaction | Checks if pending failure processing can be finished by committing a pending transaction.
Public method | CanRollBackPendingTransaction | Checks if pending failure processing can be finished by rolling back a pending transaction.
Public method | CommitPendingTransaction | Finishes pending failures processing by committing the pending transaction.
Public method | DeleteAllWarnings | Deletes all FailureMessages of severity "Warning" currently posted in a document.
Public method | DeleteElements | Resolves failures by deletion of elements related to the failures.
Public method | DeleteWarning | Deletes one specific failure message of severity "Warning".
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAttemptedResolutionTypes | Returns list of the failure resolution types attempted for the failure in the current transaction.
Public method | GetDocument | Provides access to a document for which failures are being processed or preprocessed.
Public method | GetFailureHandlingOptions | Provides access to the failure handling options for the transaction currently being finished.
Public method | GetFailureMessages | Provides access to the individual failure messages currently posted in the document.
Public method | GetFailureMessages(FailureSeverity) | Provides access to the individual failure messages if a given severity currently posted in the document.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetSeverity | Provides access to the current failure severity.
Public method | GetTransactionName | Retrieves the name of the transaction for which failures are being processed.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsActive | Method allows to check if this instance of the accessor is currently active.
Public method | IsElementsDeletionPermitted | Checks if resolution of the failures by deleting failure elements is permitted.
Public method | IsElementsDeletionPermitted(IListElementId) | Checks if resolution of the failures by deleting given collection of elements is permitted.
Public method | IsElementsDeletionPermitted(IListElementId, String) | Checks if resolution of the failures by deleting given collection of elements is permitted.
Public method | IsFailureResolutionPermitted | Checks if resolution of failures is permitted.
Public method | IsFailureResolutionPermitted(FailureMessageAccessor) | Checks if default resolution of the failure is permitted.
Public method | IsFailureResolutionPermitted(FailureMessageAccessor, FailureResolutionType) | Checks if resolution of the failure using given resolution type is permitted.
Public method | IsPending | Checks if the failure processing is pending.
Public method | IsTransactionBeingCommitted | Checks if the transaction for which failures are processed is being committed or rolled back.
Public method | JournalFailures | Allows to record information about failures in the journal.
Public method | PostFailure | Posts an additional failure message to be processed for the current transaction.
Public method | ReplaceFailures | Deletes all failure messages currently posted in a document and replaces them with one "generic" failure.
Public method | ResolveFailure | Resolves one failure using the failure resolution type last set for it.
Public method | ResolveFailures | Resolves one or more failures using last set failure resolution type for each of the failures. If failure resolution type was not set for some of failures, default failure resolution type will be used.
Public method | RollBackPendingTransaction | Finishes pending failures processing by rolling back the pending transaction.
Public method | SetFailureHandlingOptions | Sets failure handling options for the transaction currently being finished.
Public method | SetTransactionName | Changes the name of the transaction for which failures are being processed.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FailuresAccessor Class


FailuresAccessor.CanCommitPendingTransaction Method

FailuresAccessorCanCommitPendingTransaction Method

Checks if pending failure processing can be finished by committing a pending transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanCommitPendingTransaction()
Public Function CanCommitPendingTransaction As Boolean
public:
bool CanCommitPendingTransaction()
member CanCommitPendingTransaction : unit -> bool

Return Value

Boolean
True if there is a pending transaction and this transaction is allowed to be committed.
Exceptions
Exception | Condition
InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).
Remarks
Check makes sense only if the failure processing is pending.
See Also

Reference

FailuresAccessor Class


FailuresAccessor.CanRollBackPendingTransaction Method

FailuresAccessorCanRollBackPendingTransaction Method

Checks if pending failure processing can be finished by rolling back a pending transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanRollBackPendingTransaction()
Public Function CanRollBackPendingTransaction As Boolean
public:
bool CanRollBackPendingTransaction()
member CanRollBackPendingTransaction : unit -> bool

Return Value

Boolean
True if there is a pending transaction and this transaction is allowed to be rolled back
Exceptions
Exception | Condition
InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).
Remarks
Check makes sense only if the failure processing is pending.
See Also

Reference

FailuresAccessor Class


FailuresAccessor.CommitPendingTransaction Method

FailuresAccessorCommitPendingTransaction Method

Finishes pending failures processing by committing the pending transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TransactionStatus CommitPendingTransaction()
Public Function CommitPendingTransaction As TransactionStatus
public:
TransactionStatus CommitPendingTransaction()
member CommitPendingTransaction : unit -> TransactionStatus

Return Value

TransactionStatus
Result of attempt to commit the pending transaction.
Exceptions
Exception | Condition
InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing). -or- The processing of the failures is not in the pending state. -or- There is no pending transaction or transaction is not allowed to be committed.
See Also

Reference

FailuresAccessor Class


FailuresAccessor.DeleteAllWarnings Method

FailuresAccessorDeleteAllWarnings Method

Deletes all FailureMessages of severity "Warning" currently posted in a document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void DeleteAllWarnings()
Public Sub DeleteAllWarnings
public:
void DeleteAllWarnings()
member DeleteAllWarnings : unit -> unit
Exceptions
Exception | Condition
InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).
Remarks
Warnings are deleted immediately and will not be accessible by any further failures processing. Any accessors for these failure messages become invalid.
See Also

Reference

FailuresAccessor Class


FailuresAccessor.DeleteElements Method

FailuresAccessorDeleteElements Method

Resolves failures by deletion of elements related to the failures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void DeleteElements(
    IList<ElementId> idsToDelete
)
Public Sub DeleteElements (
    idsToDelete As IList(Of ElementId)
)
public:
void DeleteElements(
    IList<ElementId^>^ idsToDelete
)
member DeleteElements :
        idsToDelete : IList<ElementId> -> unit

Parameters

idsToDelete IList ElementId
Ids of elements to be deleted.
Exceptions
Exception | Condition
ArgumentException | Resolution of the failures by deleting idsToDelete is not permitted
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).
See Also

Reference

FailuresAccessor Class


FailuresAccessor.DeleteWarning Method

FailuresAccessorDeleteWarning Method

Deletes one specific failure message of severity "Warning".

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void DeleteWarning(
    FailureMessageAccessor failure
)
Public Sub DeleteWarning (
    failure As FailureMessageAccessor
)
public:
void DeleteWarning(
    FailureMessageAccessor^ failure
)
member DeleteWarning :
        failure : FailureMessageAccessor -> unit

Parameters

failure FailureMessageAccessor
The accessor to the warning to be deleted.
Exceptions
Exception | Condition
ArgumentException | failure has not been properly initialized. -or- Severity of failure is not FailureSeverity::Warning.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).
See Also

Reference

FailuresAccessor Class


FailuresAccessor.Dispose Method

FailuresAccessorDispose Method

Releases all resources used by the FailuresAccessor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FailuresAccessor Class


FailuresAccessor.GetAttemptedResolutionTypes Method

FailuresAccessorGetAttemptedResolutionTypes Method

Returns list of the failure resolution types attempted for the failure in the current transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<FailureResolutionType> GetAttemptedResolutionTypes(
    FailureMessageAccessor failure
)
Public Function GetAttemptedResolutionTypes (
    failure As FailureMessageAccessor
) As IList(Of FailureResolutionType)
public:
IList<FailureResolutionType>^ GetAttemptedResolutionTypes(
    FailureMessageAccessor^ failure
)
member GetAttemptedResolutionTypes :
        failure : FailureMessageAccessor -> IList<FailureResolutionType>

Parameters

failure FailureMessageAccessor
The failure.

Return Value

IList FailureResolutionType
The list of the types of failure resolutions attempted for the failure.
Exceptions
Exception | Condition
ArgumentException | failure has not been properly initialized.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).
Remarks
In some cases attempt to resolve a failure has no impact or failure gets reposted during next round of the end of transaction checks after being resolved. Knowing if any failure resolutions were attempted for the failure allows failures processor to prevent infinite loop.
See Also

Reference

FailuresAccessor Class


FailuresAccessor.GetDocument Method

FailuresAccessorGetDocument Method

Provides access to a document for which failures are being processed or preprocessed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Document GetDocument()
Public Function GetDocument As Document
public:
Document^ GetDocument()
member GetDocument : unit -> Document

Return Value

Document
The document for which failures preprocessing or processing is being performed.
Exceptions
Exception | Condition
InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).
See Also

Reference

FailuresAccessor Class


FailuresAccessor.GetFailureHandlingOptions Method

FailuresAccessorGetFailureHandlingOptions Method

Provides access to the failure handling options for the transaction currently being finished.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FailureHandlingOptions GetFailureHandlingOptions()
Public Function GetFailureHandlingOptions As FailureHandlingOptions
public:
FailureHandlingOptions^ GetFailureHandlingOptions()
member GetFailureHandlingOptions : unit -> FailureHandlingOptions

Return Value

FailureHandlingOptions
The failure handling options for transaction currently being finished.
Exceptions
Exception | Condition
InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).
See Also

Reference

FailuresAccessor Class


FailuresAccessor.GetFailureMessages Method

FailuresAccessorGetFailureMessages Method

Overload List
 | Name | Description
Public method | GetFailureMessages | Provides access to the individual failure messages currently posted in the document.
Public method | GetFailureMessages(FailureSeverity) | Provides access to the individual failure messages if a given severity currently posted in the document.
Top
See Also

Reference

FailuresAccessor Class


FailuresAccessor.GetFailureMessages Method

FailuresAccessorGetFailureMessages Method

Provides access to the individual failure messages currently posted in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<FailureMessageAccessor> GetFailureMessages()
Public Function GetFailureMessages As IList(Of FailureMessageAccessor)
public:
IList<FailureMessageAccessor^>^ GetFailureMessages()
member GetFailureMessages : unit -> IList<FailureMessageAccessor>

Return Value

IList FailureMessageAccessor
The accessors to the individual failure messages posted in the document.
Exceptions
Exception | Condition
InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).
Remarks
Returned set of messages will be ordered from more severe to less severe.
See Also

Reference

FailuresAccessor Class
GetFailureMessages Overload


FailuresAccessor.GetFailureMessages(FailureSeverity) Method

FailuresAccessorGetFailureMessages(FailureSeverity) Method

Provides access to the individual failure messages if a given severity currently posted in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<FailureMessageAccessor> GetFailureMessages(
    FailureSeverity severity
)
Public Function GetFailureMessages (
    severity As FailureSeverity
) As IList(Of FailureMessageAccessor)
public:
IList<FailureMessageAccessor^>^ GetFailureMessages(
    FailureSeverity severity
)
member GetFailureMessages :
        severity : FailureSeverity -> IList<FailureMessageAccessor>

Parameters

severity FailureSeverity
The failure severity for which failure messages are requested. If the requested severity is None, an empty collection is returned.

Return Value

IList FailureMessageAccessor
Accessors to the individual failure messages of a given severity posted in the document.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).
See Also

Reference

FailuresAccessor Class
GetFailureMessages Overload


FailuresAccessor.GetSeverity Method

FailuresAccessorGetSeverity Method

Provides access to the current failure severity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FailureSeverity GetSeverity()
Public Function GetSeverity As FailureSeverity
public:
FailureSeverity GetSeverity()
member GetSeverity : unit -> FailureSeverity

Return Value

FailureSeverity
The highest severity of a failure message currently posted in the document.
Exceptions
Exception | Condition
InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).
See Also

Reference

FailuresAccessor Class


FailuresAccessor.GetTransactionName Method

FailuresAccessorGetTransactionName Method

Retrieves the name of the transaction for which failures are being processed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetTransactionName()
Public Function GetTransactionName As String
public:
String^ GetTransactionName()
member GetTransactionName : unit -> string

Return Value

String
The name of the transaction for which failures are being processed.
Exceptions
Exception | Condition
InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).
See Also

Reference

FailuresAccessor Class


FailuresAccessor.IsActive Method

FailuresAccessorIsActive Method

Method allows to check if this instance of the accessor is currently active.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsActive()
Public Function IsActive As Boolean
public:
bool IsActive()
member IsActive : unit -> bool

Return Value

Boolean
True if this instance is currently active and can be used.
Remarks
Generally, this instance is active when it is passed to any of interfaces used in the process of failure resolution, and becomes inactive after returning control to Revit. The only special case is if failures processor returns WaitForUserInput, in which case document stays in the FailureMode and instance of failures accessor stays active till FailureMode is ended.
See Also

Reference

FailuresAccessor Class


FailuresAccessor.IsElementsDeletionPermitted Method

FailuresAccessorIsElementsDeletionPermitted Method

Overload List
 | Name | Description
Public method | IsElementsDeletionPermitted | Checks if resolution of the failures by deleting failure elements is permitted.
Public method | IsElementsDeletionPermitted(IListElementId) | Checks if resolution of the failures by deleting given collection of elements is permitted.
Public method | IsElementsDeletionPermitted(IListElementId, String) | Checks if resolution of the failures by deleting given collection of elements is permitted.
Top
See Also

Reference

FailuresAccessor Class


FailuresAccessor.IsElementsDeletionPermitted Method

FailuresAccessorIsElementsDeletionPermitted Method

Checks if resolution of the failures by deleting failure elements is permitted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsElementsDeletionPermitted()
Public Function IsElementsDeletionPermitted As Boolean
public:
bool IsElementsDeletionPermitted()
member IsElementsDeletionPermitted : unit -> bool

Return Value

Boolean
True if resolution of the failures by deleting failure elements is permitted.
Exceptions
Exception | Condition
InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).
See Also

Reference

FailuresAccessor Class
IsElementsDeletionPermitted Overload


FailuresAccessor.IsElementsDeletionPermitted(IList<ElementId>) Method

FailuresAccessorIsElementsDeletionPermitted(IListElementId) Method

Checks if resolution of the failures by deleting given collection of elements is permitted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsElementsDeletionPermitted(
    IList<ElementId> idsToDelete
)
Public Function IsElementsDeletionPermitted (
    idsToDelete As IList(Of ElementId)
) As Boolean
public:
bool IsElementsDeletionPermitted(
    IList<ElementId^>^ idsToDelete
)
member IsElementsDeletionPermitted :
        idsToDelete : IList<ElementId> -> bool

Parameters

idsToDelete IList ElementId
The Ids of elements to be deleted.

Return Value

Boolean
True if resolution of the failures by deleting given elements is permitted.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).
Remarks
Method does not confirm if deletion of the elements will or may resolve the failure - it simply verifies that given elements exist and can be deleted in the current state of the document.
See Also

Reference

FailuresAccessor Class
IsElementsDeletionPermitted Overload


FailuresAccessor.IsElementsDeletionPermitted(IList<ElementId>, String) Method

FailuresAccessorIsElementsDeletionPermitted(IListElementId, String) Method

Checks if resolution of the failures by deleting given collection of elements is permitted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsElementsDeletionPermitted(
    IList<ElementId> idsToDelete,
    out string reason
)
Public Function IsElementsDeletionPermitted (
    idsToDelete As IList(Of ElementId),
    <OutAttribute> ByRef reason As String
) As Boolean
public:
bool IsElementsDeletionPermitted(
    IList<ElementId^>^ idsToDelete,
    [OutAttribute] String^% reason
)
member IsElementsDeletionPermitted :
        idsToDelete : IList<ElementId> *
        reason : string byref -> bool

Parameters

idsToDelete IList ElementId
The Ids of elements to be deleted.
reason String
A localized string explaining reason why the elements cannot be deleted.

Return Value

Boolean
True if resolution of the failures by deleting given elements is permitted
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).
Remarks
Method does not confirm if deletion of the elements will or may resolve the failure - it simply verifies that given elements can be deleted in the current state of the document.
See Also

Reference

FailuresAccessor Class
IsElementsDeletionPermitted Overload


FailuresAccessor.IsFailureResolutionPermitted Method

FailuresAccessorIsFailureResolutionPermitted Method

Overload List
 | Name | Description
Public method | IsFailureResolutionPermitted | Checks if resolution of failures is permitted.
Public method | IsFailureResolutionPermitted(FailureMessageAccessor) | Checks if default resolution of the failure is permitted.
Public method | IsFailureResolutionPermitted(FailureMessageAccessor, FailureResolutionType) | Checks if resolution of the failure using given resolution type is permitted.
Top
See Also

Reference

FailuresAccessor Class


FailuresAccessor.IsFailureResolutionPermitted Method

FailuresAccessorIsFailureResolutionPermitted Method

Checks if resolution of failures is permitted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsFailureResolutionPermitted()
Public Function IsFailureResolutionPermitted As Boolean
public:
bool IsFailureResolutionPermitted()
member IsFailureResolutionPermitted : unit -> bool

Return Value

Boolean
True if resolutions of failures is permitted.
See Also

Reference

FailuresAccessor Class
IsFailureResolutionPermitted Overload


FailuresAccessor.IsFailureResolutionPermitted(FailureMessageAccessor) Method

FailuresAccessorIsFailureResolutionPermitted(FailureMessageAccessor) Method

Checks if default resolution of the failure is permitted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsFailureResolutionPermitted(
    FailureMessageAccessor failure
)
Public Function IsFailureResolutionPermitted (
    failure As FailureMessageAccessor
) As Boolean
public:
bool IsFailureResolutionPermitted(
    FailureMessageAccessor^ failure
)
member IsFailureResolutionPermitted :
        failure : FailureMessageAccessor -> bool

Parameters

failure FailureMessageAccessor
The accessor to the failure to be resolved.

Return Value

Boolean
True if default resolution of the failure is permitted
Exceptions
Exception | Condition
ArgumentException | failure has not been properly initialized.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).
See Also

Reference

FailuresAccessor Class
IsFailureResolutionPermitted Overload


FailuresAccessor.IsFailureResolutionPermitted(FailureMessageAccessor, FailureResolutionType) Method

FailuresAccessorIsFailureResolutionPermitted(FailureMessageAccessor, FailureResolutionType) Method

Checks if resolution of the failure using given resolution type is permitted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsFailureResolutionPermitted(
    FailureMessageAccessor failure,
    FailureResolutionType resolutionType
)
Public Function IsFailureResolutionPermitted (
    failure As FailureMessageAccessor,
    resolutionType As FailureResolutionType
) As Boolean
public:
bool IsFailureResolutionPermitted(
    FailureMessageAccessor^ failure,
    FailureResolutionType resolutionType
)
member IsFailureResolutionPermitted :
        failure : FailureMessageAccessor *
        resolutionType : FailureResolutionType -> bool

Parameters

failure FailureMessageAccessor
Accessor to the failure to be resolved.
resolutionType FailureResolutionType
Type of the failure resolution to be used.

Return Value

Boolean
True if resolution of the failure using given resolution type is permitted.
Exceptions
Exception | Condition
ArgumentException | failure has not been properly initialized.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).
See Also

Reference

FailuresAccessor Class
IsFailureResolutionPermitted Overload


FailuresAccessor.IsPending Method

FailuresAccessorIsPending Method

Checks if the failure processing is pending.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsPending()
Public Function IsPending As Boolean
public:
bool IsPending()
member IsPending : unit -> bool

Return Value

Boolean
True if the failures processing is in the pending state.
Exceptions
Exception | Condition
InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).
Remarks
The failure processing is pending after failures processor has returned WaitForUserInput and until pending state is finished by either committing or rolling back of the pending transaction.
See Also

Reference

FailuresAccessor Class


FailuresAccessor.IsTransactionBeingCommitted Method

FailuresAccessorIsTransactionBeingCommitted Method

Checks if the transaction for which failures are processed is being committed or rolled back.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsTransactionBeingCommitted()
Public Function IsTransactionBeingCommitted As Boolean
public:
bool IsTransactionBeingCommitted()
member IsTransactionBeingCommitted : unit -> bool

Return Value

Boolean
True if current transaction is being committed, false if the transaction is being rolled back.
Exceptions
Exception | Condition
InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).
Remarks
A transaction is considered as "being committed" if a caller has requested the transaction to be committed and no previous failure processing operation requested the transaction to be rolled back.
See Also

Reference

FailuresAccessor Class


FailuresAccessor.JournalFailures Method

FailuresAccessorJournalFailures Method

Allows to record information about failures in the journal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void JournalFailures(
    IList<FailureMessageAccessor> failures
)
Public Sub JournalFailures (
    failures As IList(Of FailureMessageAccessor)
)
public:
void JournalFailures(
    IList<FailureMessageAccessor^>^ failures
)
member JournalFailures :
        failures : IList<FailureMessageAccessor> -> unit

Parameters

failures IList FailureMessageAccessor
Accessors to the failures to journal.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).
Remarks
Records information about failure messages and elements involved in the failures. If this method not invoked, journal does not contain any information about failures resolved by (pre)processing.
See Also

Reference

FailuresAccessor Class


FailuresAccessor.PostFailure Method

FailuresAccessorPostFailure Method

Posts an additional failure message to be processed for the current transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void PostFailure(
    FailureMessage failure
)
Public Sub PostFailure (
    failure As FailureMessage
)
public:
void PostFailure(
    FailureMessage^ failure
)
member PostFailure :
        failure : FailureMessage -> unit

Parameters

failure FailureMessage
Failure message to post.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).
Remarks
Should be used during failures processing instead of a similar method in a document class. Using method of the document class with the same name during failures processing is prohibited.
See Also

Reference

FailuresAccessor Class


FailuresAccessor.ReplaceFailures Method

FailuresAccessorReplaceFailures Method

Deletes all failure messages currently posted in a document and replaces them with one "generic" failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ReplaceFailures(
    FailureMessage failure
)
Public Sub ReplaceFailures (
    failure As FailureMessage
)
public:
void ReplaceFailures(
    FailureMessage^ failure
)
member ReplaceFailures :
        failure : FailureMessage -> unit

Parameters

failure FailureMessage
FailureMessage that should replace all currently posted messages. It must have severity DocumentCorruption.
Exceptions
Exception | Condition
ArgumentException | Severity of failure must be FailureSeverity::DocumentCorruption.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).
Remarks
If analysis done by Failures Processing code concludes that in a given context delivering of the posted failures to the user makes no sense, this method can be used to discard all posted failures and substitute one "generic" one, that will be delivered to the user and then transaction forced to be aborted. After the call, (pre)processing of failures should return ProceedWithRollback.
See Also

Reference

FailuresAccessor Class


FailuresAccessor.ResolveFailure Method

FailuresAccessorResolveFailure Method

Resolves one failure using the failure resolution type last set for it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ResolveFailure(
    FailureMessageAccessor failure
)
Public Sub ResolveFailure (
    failure As FailureMessageAccessor
)
public:
void ResolveFailure(
    FailureMessageAccessor^ failure
)
member ResolveFailure :
        failure : FailureMessageAccessor -> unit

Parameters

failure FailureMessageAccessor
The accessor to the failure to be resolved.
Exceptions
Exception | Condition
ArgumentException | failure has not been properly initialized. -or- failure does not have any resolutions. -or- Default resolution of failure is not permitted or not applicable. -or- The failure was already attempted to resolve twice with that resolution type.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing). -or- Resolution of failures is not permitted in the current state of the document.
Remarks
If failure resolution type was not set, the default failure resolution type will be used. After execution of the failure resolution the failure will not be removed from the document automatically. To prevent the failure from being delivered to the user, failures (pre)processor should return ProceedWithCommit. It will cause failures to be regenerated and failure resolution process to be restarted. If attempt to resolve failure was not successful, and the same failure is present on repetitive calls of the failures (pre)processor, the preprocessor code should take care to attempt a different resolution the next time the failure appears, to avoid an infinite loop.
See Also

Reference

FailuresAccessor Class


FailuresAccessor.ResolveFailures Method

FailuresAccessorResolveFailures Method

Resolves one or more failures using last set failure resolution type for each of the failures. If failure resolution type was not set for some of failures, default failure resolution type will be used.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ResolveFailures(
    IList<FailureMessageAccessor> failures
)
Public Sub ResolveFailures (
    failures As IList(Of FailureMessageAccessor)
)
public:
void ResolveFailures(
    IList<FailureMessageAccessor^>^ failures
)
member ResolveFailures :
        failures : IList<FailureMessageAccessor> -> unit

Parameters

failures IList FailureMessageAccessor
The accessors to the failures to be resolved.
Exceptions
Exception | Condition
ArgumentException | Default resolution of one of the failures is not permitted or not applicable. -or- One of the failures was already attempted to resolve twice with that resolution type.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing). -or- Resolution of failures is not permitted in the current state of the document.
Remarks
After execution of the failure resolutions the failures will not be removed from the document automatically. To prevent failure from being delivered to the user, failures (pre)processor should return ProceedWithCommit. It will cause failures to be regenerated and failure resolution process to be restarted. If attempt to resolve failure was not successful, and the same failure is present on repetitive calls of the failures (pre)processor, the preprocessor code should take care to attempt a different resolution the next time the failure appears, to avoid an infinite loop.
See Also

Reference

FailuresAccessor Class


FailuresAccessor.RollBackPendingTransaction Method

FailuresAccessorRollBackPendingTransaction Method

Finishes pending failures processing by rolling back the pending transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TransactionStatus RollBackPendingTransaction()
Public Function RollBackPendingTransaction As TransactionStatus
public:
TransactionStatus RollBackPendingTransaction()
member RollBackPendingTransaction : unit -> TransactionStatus

Return Value

TransactionStatus
Result of attempt to roll back the pending transaction.
Exceptions
Exception | Condition
InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing). -or- The processing of the failures is not in the pending state.
See Also

Reference

FailuresAccessor Class


FailuresAccessor.SetFailureHandlingOptions Method

FailuresAccessorSetFailureHandlingOptions Method

Sets failure handling options for the transaction currently being finished.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetFailureHandlingOptions(
    FailureHandlingOptions options
)
Public Sub SetFailureHandlingOptions (
    options As FailureHandlingOptions
)
public:
void SetFailureHandlingOptions(
    FailureHandlingOptions^ options
)
member SetFailureHandlingOptions :
        options : FailureHandlingOptions -> unit

Parameters

options FailureHandlingOptions
The failure handling options to be set for the transaction currently being finished.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).
Remarks
If used with returning ProceedWithRollback from (pre)processing, allows to dismiss errors and roll back transaction without any further failures processing and silently for the user.
See Also

Reference

FailuresAccessor Class


FailuresAccessor.SetTransactionName Method

FailuresAccessorSetTransactionName Method

Changes the name of the transaction for which failures are being processed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetTransactionName(
    string transactionName
)
Public Sub SetTransactionName (
    transactionName As String
)
public:
void SetTransactionName(
    String^ transactionName
)
member SetTransactionName :
        transactionName : string -> unit

Parameters

transactionName String
The name of the transaction to set.
Exceptions
Exception | Condition
ArgumentException | transactionName is an empty string.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).
Remarks
If the transaction will be committed by or after failures processing it can change its name to reflect results of processing of the failures. For example, if the original transaction name was "review warnings" and some of the warnings were resolved by deleting of the relevant elements, failures processor may change the name of the transaction to "delete elements".
See Also

Reference

FailuresAccessor Class


FailureSeverity Enumeration

Enum represents severity of a failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum FailureSeverity
Public Enumeration FailureSeverity
public enum class FailureSeverity
type FailureSeverity
Members
Member name | Value | Description
None | 0 | Represents a failure-free state of a document. This value cannot be used as an argument to construct FailureMesasage.
Warning | 1 | Failure that can be ignored by end-user. Failures of this severity do not prevent transactions from being committed.
Error | 2 | Failure that cannot be ignored. If FailureMeassage of this severity is posted, the current transaction cannot be committed unless failure is resolved via appropriate FailureResolution.
DocumentCorruption | 3 | Failure that forces Transaction to be rolled back as soon as possible due to known corruption to a document. When failure of this severity is posted, reading of information from a document is not allowed. The current transaction has to be rolled back first in order to work with the document.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Family Class

An element that represents a custom family (not a system family) in Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBFamily

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Family : Element
Public Class Family
    Inherits Element
public ref class Family : public Element
type Family =
    class
        inherit Element
    end

The Family type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CurtainPanelHorizontalSpacing | For Curtain Panel families, the horizontal spacing of the driving mesh.
Public property | CurtainPanelTilePattern | For Curtain Panel families, the choice of tile pattern.
Public property | CurtainPanelVerticalSpacing | For Curtain Panel families, the vertical spacing of the driving mesh.
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | FamilyCategory | Retrieves or sets a Category object that represents the category or sub category in which the elements ( this family could generate ) reside.
Public property | FamilyCategoryId | The id of the category or sub category in which the elements that this family could generate reside.
Public property | FamilyPlacementType | Identifies the type of placement required by a given family.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsConceptualMassFamily | Whether the Family is a Conceptual Mass family.
Public property | IsCurtainPanelFamily | Whether the Family is a Curtain Panel family. Curtain Panel family symbols are used as the ObjectTypes of DividedSurface elements.
Public property | IsEditable | True if the family supports editing, false otherwise.
Public property | IsInPlace | True if the family is an in-place family, false if the family is a loadable family.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsOwnerFamily | True if the family is the owner family for its own editable document, false otherwise.
Public property | IsParametric | Identifies whether the family contains parametric relations between some of its elements.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsUserCreated | Determine whether the family has been defined by the user.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ShowSpatialElementCalculationPoint | For families that can have a calculation point for spatial elements, hide or show the calculation point. SpatialElementCalculationPoint elements.
Public property | StructuralCodeName | The family's structural code name.
Public property | StructuralFamilyNameKey | The family's structural section shape name key.
Public property | StructuralMaterialType | The family's structural material type.
Public property | StructuralSectionShape | The family's structural section shape.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveStructuralSection | Identifies if this Family can have a structural section.
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
 | CanLoadFamilies | Checks whether the document is in a state that allows the loading of families.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | ExtractPartAtom | Writes a PartAtom XML from the contents of a family object.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFamilySymbolIds | Gets the ids of the FamilySymbols owned by this Family.
 | GetFamilyTypeParameterValues | Returns all applicable values for a FamilyType parameter of this family.
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasLargeSketches | Checks whether the family contains sketches with a large number of elements.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsAppropriateCategoryId | Identifies if the input category id can be assigned as the new category for this family.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Custom families within the Revit API represented by three objects - Family, FamilySymbol and FamilyInstance. Each object plays a significant part in the structure of families. The Family element represents the entire family that consists of a collection of types, such as an 'I Beam'. You can think of that object as representing the entire family file. The Family object contains a number of FamilySymbol elements. The FamilySymbol object represents a specific set of family settings within that Family and represents what is known in the Revit user interface as a Type, such as 'W14x32'. The FamilyInstance object represents an actual instance of that type placed the Autodesk Revit project. For example the FamilyInstance would be a single instance of a W14x32 column within the project.
Example
C#
VB
C++
F#
Copy
public void GetInfoForSymbols(Family family)
{
    StringBuilder message = new StringBuilder("Selected element's family name is : " + family.Name);
    ISet<ElementId> familySymbolIds = family.GetFamilySymbolIds();

    if (familySymbolIds.Count == 0)
    {
        message.AppendLine("Contains no family symbols.");
    }
    else
    {
        message.AppendLine("The family symbols contained in this family are : ");

        // Get family symbols which is contained in this family
        foreach (ElementId id in familySymbolIds)
        {
            FamilySymbol familySymbol = family.Document.GetElement(id) as FamilySymbol;
            // Get family symbol name
            message.AppendLine("\nName: " + familySymbol.Name);
            foreach (ElementId materialId in familySymbol.GetMaterialIds(false))
            {
                Material material = familySymbol.Document.GetElement(materialId) as Material;
                message.AppendLine("\nMaterial : " + material.Name);
            }
        }
    }

    TaskDialog.Show("Revit",message.ToString());
}
Public Sub GetInfoForSymbols(family As Family)
    Dim message As New StringBuilder("Selected element's family name is : " & Convert.ToString(family.Name))
    Dim familySymbolIds As ISet(Of ElementId) = family.GetFamilySymbolIds()

    If familySymbolIds.Count = 0 Then
        message.AppendLine("Contains no family symbols.")
    Else
        message.AppendLine("The family symbols contained in this family are : ")

        ' Get family symbols which is contained in this family
        For Each id As ElementId In familySymbolIds
            Dim familySymbol As FamilySymbol = TryCast(family.Document.GetElement(id), FamilySymbol)
            ' Get family symbol name
            message.AppendLine(vbLf & "Name: " + familySymbol.Name)
            For Each materialId As ElementId In familySymbol.GetMaterialIds(False)
                Dim material As Material = TryCast(familySymbol.Document.GetElement(materialId), Material)
                message.AppendLine(vbLf & "Material : " + material.Name)
            Next
        Next
    End If

    TaskDialog.Show("Revit", message.ToString())
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Family Properties

The Family type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CurtainPanelHorizontalSpacing | For Curtain Panel families, the horizontal spacing of the driving mesh.
Public property | CurtainPanelTilePattern | For Curtain Panel families, the choice of tile pattern.
Public property | CurtainPanelVerticalSpacing | For Curtain Panel families, the vertical spacing of the driving mesh.
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | FamilyCategory | Retrieves or sets a Category object that represents the category or sub category in which the elements ( this family could generate ) reside.
Public property | FamilyCategoryId | The id of the category or sub category in which the elements that this family could generate reside.
Public property | FamilyPlacementType | Identifies the type of placement required by a given family.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsConceptualMassFamily | Whether the Family is a Conceptual Mass family.
Public property | IsCurtainPanelFamily | Whether the Family is a Curtain Panel family. Curtain Panel family symbols are used as the ObjectTypes of DividedSurface elements.
Public property | IsEditable | True if the family supports editing, false otherwise.
Public property | IsInPlace | True if the family is an in-place family, false if the family is a loadable family.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsOwnerFamily | True if the family is the owner family for its own editable document, false otherwise.
Public property | IsParametric | Identifies whether the family contains parametric relations between some of its elements.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsUserCreated | Determine whether the family has been defined by the user.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ShowSpatialElementCalculationPoint | For families that can have a calculation point for spatial elements, hide or show the calculation point. SpatialElementCalculationPoint elements.
Public property | StructuralCodeName | The family's structural code name.
Public property | StructuralFamilyNameKey | The family's structural section shape name key.
Public property | StructuralMaterialType | The family's structural material type.
Public property | StructuralSectionShape | The family's structural section shape.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

Family Class


Family.CurtainPanelHorizontalSpacing Property

FamilyCurtainPanelHorizontalSpacing Property

For Curtain Panel families, the horizontal spacing of the driving mesh.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double CurtainPanelHorizontalSpacing { get; set; }
Public Property CurtainPanelHorizontalSpacing As Double
    Get
    Set
public:
property double CurtainPanelHorizontalSpacing {
    double get ();
    void set (double value);
}
member CurtainPanelHorizontalSpacing : float with get, set

Property Value

Double
Exceptions
Exception | Condition
InvalidOperationException | Thrown if this family is not the owner family of a curtain panel family document.
See Also

Reference

Family Class


Family.CurtainPanelTilePattern Property

FamilyCurtainPanelTilePattern Property

For Curtain Panel families, the choice of tile pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TilePatternsBuiltIn CurtainPanelTilePattern { get; }
Public ReadOnly Property CurtainPanelTilePattern As TilePatternsBuiltIn
    Get
public:
property TilePatternsBuiltIn CurtainPanelTilePattern {
    TilePatternsBuiltIn get ();
}
member CurtainPanelTilePattern : TilePatternsBuiltIn with get

Property Value

TilePatternsBuiltIn
Exceptions
Exception | Condition
InvalidOperationException | Thrown if this family is not a Curtain Panel family.
See Also

Reference

Family Class


Family.CurtainPanelVerticalSpacing Property

FamilyCurtainPanelVerticalSpacing Property

For Curtain Panel families, the vertical spacing of the driving mesh.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double CurtainPanelVerticalSpacing { get; set; }
Public Property CurtainPanelVerticalSpacing As Double
    Get
    Set
public:
property double CurtainPanelVerticalSpacing {
    double get ();
    void set (double value);
}
member CurtainPanelVerticalSpacing : float with get, set

Property Value

Double
Exceptions
Exception | Condition
InvalidOperationException | Thrown if this family is not the owner family of a curtain panel family document.
See Also

Reference

Family Class


Family.FamilyCategory Property

FamilyFamilyCategory Property

Retrieves or sets a Category object that represents the category or sub category in which the elements ( this family could generate ) reside.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Category FamilyCategory { get; set; }
Public Property FamilyCategory As Category
    Get
    Set
public:
property Category^ FamilyCategory {
    Category^ get ();
    void set (Category^ value);
}
member FamilyCategory : Category with get, set

Property Value

Category
Exceptions
Exception | Condition
ArgumentException | Thrown when the input category cannot be assigned to this family.
ArgumentNullException | Thrown when the input category is .
Remarks
All category objects can be retrieved from the application by using the Categories property of the Application.Settings object.
Example
C#
VB
C++
F#
Copy
public void GetBeamAndColumnSymbols(Document document)
{
   List<FamilySymbol> columnTypes = new List<FamilySymbol>();
   List<FamilySymbol> framingTypes = new List<FamilySymbol>();
    FilteredElementCollector collector = new FilteredElementCollector(document);
    ICollection<Element> elements = collector.OfClass(typeof(Family)).ToElements();

    foreach(Element element in elements)
    {
        Family family = element as Family;
        Category category = family.FamilyCategory;
        if (null != category)
        {
            ISet<ElementId> familySymbolIds = family.GetFamilySymbolIds();
            if (BuiltInCategory.OST_StructuralColumns == category.BuiltInCategory)
            {
                foreach (ElementId id in familySymbolIds)
                {
                    FamilySymbol symbol = family.Document.GetElement(id) as FamilySymbol;
                    columnTypes.Add(symbol);
                }
            }
            else if (BuiltInCategory.OST_StructuralFraming == category.BuiltInCategory)
            {
                foreach (ElementId id in familySymbolIds)
                {
                    FamilySymbol symbol = family.Document.GetElement(id) as FamilySymbol;
                    framingTypes.Add(symbol);
                }
            }
        }
    }

    string message = "Column Types: ";
    foreach (FamilySymbol familySymbol in columnTypes)
    {
       message += "\n" + familySymbol.Name;
    }

    TaskDialog.Show("Revit",message);
}
Public Sub GetBeamAndColumnSymbols(document As Document)
   Dim columnTypes As New System.Collections.Generic.List(Of FamilySymbol)
   Dim framingTypes As New System.Collections.Generic.List(Of FamilySymbol)
   Dim collector As New FilteredElementCollector(document)
   Dim elements As ICollection(Of Element) = collector.OfClass(GetType(Family)).ToElements()

   For Each element As Element In elements
      Dim family As Family = TryCast(element, Family)
      Dim category As Category = family.FamilyCategory
      If category IsNot Nothing Then
         Dim familySymbolIds As ISet(Of ElementId) = family.GetFamilySymbolIds()
         If BuiltInCategory.OST_StructuralColumns = category.BuiltInCategory Then
            For Each id As ElementId In familySymbolIds
               Dim symbol As FamilySymbol = TryCast(family.Document.GetElement(id), FamilySymbol)
               columnTypes.Add(symbol)
            Next
         ElseIf BuiltInCategory.OST_StructuralFraming = category.BuiltInCategory Then
            For Each id As ElementId In familySymbolIds
               Dim symbol As FamilySymbol = TryCast(family.Document.GetElement(id), FamilySymbol)
               framingTypes.Add(symbol)
            Next
         End If
      End If
   Next

   Dim message As String = "Column Types: "
   For Each familySybmol As FamilySymbol In columnTypes
      message += vbLf + familySybmol.Name
   Next

   TaskDialog.Show("Revit", message)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Family Class


Family.FamilyCategoryId Property

FamilyFamilyCategoryId Property

The id of the category or sub category in which the elements that this family could generate reside.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId FamilyCategoryId { get; set; }
Public Property FamilyCategoryId As ElementId
    Get
    Set
public:
property ElementId^ FamilyCategoryId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member FamilyCategoryId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentException | When setting this property: The input category id cannot be assigned as the new category for this family.
ArgumentNullException | When setting this property: A non-optional argument was null
InvalidOperationException | When setting this property: The family is not an owner family for its own editable document.
See Also

Reference

Family Class


Family.FamilyPlacementType Property

FamilyFamilyPlacementType Property

Identifies the type of placement required by a given family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyPlacementType FamilyPlacementType { get; }
Public ReadOnly Property FamilyPlacementType As FamilyPlacementType
    Get
public:
property FamilyPlacementType FamilyPlacementType {
    FamilyPlacementType get ();
}
member FamilyPlacementType : FamilyPlacementType with get

Property Value

FamilyPlacementType
See Also

Reference

Family Class


Family.IsConceptualMassFamily Property

FamilyIsConceptualMassFamily Property

Whether the Family is a Conceptual Mass family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsConceptualMassFamily { get; }
Public ReadOnly Property IsConceptualMassFamily As Boolean
    Get
public:
property bool IsConceptualMassFamily {
    bool get ();
}
member IsConceptualMassFamily : bool with get

Property Value

Boolean
See Also

Reference

Family Class


Family.IsCurtainPanelFamily Property

FamilyIsCurtainPanelFamily Property

Whether the Family is a Curtain Panel family. Curtain Panel family symbols are used as the ObjectTypes of DividedSurface elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCurtainPanelFamily { get; }
Public ReadOnly Property IsCurtainPanelFamily As Boolean
    Get
public:
property bool IsCurtainPanelFamily {
    bool get ();
}
member IsCurtainPanelFamily : bool with get

Property Value

Boolean
See Also

Reference

Family Class


Family.IsEditable Property

FamilyIsEditable Property

True if the family supports editing, false otherwise.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEditable { get; }
Public ReadOnly Property IsEditable As Boolean
    Get
public:
property bool IsEditable {
    bool get ();
}
member IsEditable : bool with get

Property Value

Boolean
Remarks
The family will not be editable if it is in-place, not saveable, or represents the primary family inside a family document.
See Also

Reference

Family Class


Family.IsInPlace Property

FamilyIsInPlace Property

True if the family is an in-place family, false if the family is a loadable family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsInPlace { get; }
Public ReadOnly Property IsInPlace As Boolean
    Get
public:
property bool IsInPlace {
    bool get ();
}
member IsInPlace : bool with get

Property Value

Boolean
See Also

Reference

Family Class


Family.IsOwnerFamily Property

FamilyIsOwnerFamily Property

True if the family is the owner family for its own editable document, false otherwise.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsOwnerFamily { get; }
Public ReadOnly Property IsOwnerFamily As Boolean
    Get
public:
property bool IsOwnerFamily {
    bool get ();
}
member IsOwnerFamily : bool with get

Property Value

Boolean
See Also

Reference

Family Class


Family.IsParametric Property

FamilyIsParametric Property

Identifies whether the family contains parametric relations between some of its elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsParametric { get; }
Public ReadOnly Property IsParametric As Boolean
    Get
public:
property bool IsParametric {
    bool get ();
}
member IsParametric : bool with get

Property Value

Boolean
Remarks

A family is parametric if it contains parameter-driven relations between its elements, such as labeled dimensions or locked tangential joins.

Parametric families containing large sketches may cause performance problems. Caution is therefore advised before adding any constraints to a yet non-parametric family that already contains large sketches. See [!:DoesContainLargeSketches()].

See Also

Reference

Family Class


Family.IsUserCreated Property

FamilyIsUserCreated Property

Determine whether the family has been defined by the user.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsUserCreated { get; }
Public ReadOnly Property IsUserCreated As Boolean
    Get
public:
property bool IsUserCreated {
    bool get ();
}
member IsUserCreated : bool with get

Property Value

Boolean
Remarks
Some families are created internally and cannot be saved or reloaded. This function will return False for such internal families.
See Also

Reference

Family Class


Family.ShowSpatialElementCalculationPoint Property

FamilyShowSpatialElementCalculationPoint Property

For families that can have a calculation point for spatial elements, hide or show the calculation point. SpatialElementCalculationPoint elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShowSpatialElementCalculationPoint { get; set; }
Public Property ShowSpatialElementCalculationPoint As Boolean
    Get
    Set
public:
property bool ShowSpatialElementCalculationPoint {
    bool get ();
    void set (bool value);
}
member ShowSpatialElementCalculationPoint : bool with get, set

Property Value

Boolean
See Also

Reference

Family Class


Family.StructuralCodeName Property

FamilyStructuralCodeName Property

The family's structural code name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string StructuralCodeName { get; set; }
Public Property StructuralCodeName As String
    Get
    Set
public:
property String^ StructuralCodeName {
    String^ get ();
    void set (String^ value);
}
member StructuralCodeName : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

Family Class


Family.StructuralFamilyNameKey Property

FamilyStructuralFamilyNameKey Property

The family's structural section shape name key.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string StructuralFamilyNameKey { get; set; }
Public Property StructuralFamilyNameKey As String
    Get
    Set
public:
property String^ StructuralFamilyNameKey {
    String^ get ();
    void set (String^ value);
}
member StructuralFamilyNameKey : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

Family Class


Family.StructuralMaterialType Property

FamilyStructuralMaterialType Property

The family's structural material type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public StructuralMaterialType StructuralMaterialType { get; }
Public ReadOnly Property StructuralMaterialType As StructuralMaterialType
    Get
public:
property StructuralMaterialType StructuralMaterialType {
    StructuralMaterialType get ();
}
member StructuralMaterialType : StructuralMaterialType with get

Property Value

StructuralMaterialType
See Also

Reference

Family Class


Family.StructuralSectionShape Property

FamilyStructuralSectionShape Property

The family's structural section shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public StructuralSectionShape StructuralSectionShape { get; set; }
Public Property StructuralSectionShape As StructuralSectionShape
    Get
    Set
public:
property StructuralSectionShape StructuralSectionShape {
    StructuralSectionShape get ();
    void set (StructuralSectionShape value);
}
member StructuralSectionShape : StructuralSectionShape with get, set

Property Value

StructuralSectionShape
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | When setting this property: This Family cannot have a structural section.
See Also

Reference

Family Class


Family Methods

The Family type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveStructuralSection | Identifies if this Family can have a structural section.
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
 | CanLoadFamilies | Checks whether the document is in a state that allows the loading of families.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | ExtractPartAtom | Writes a PartAtom XML from the contents of a family object.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFamilySymbolIds | Gets the ids of the FamilySymbols owned by this Family.
 | GetFamilyTypeParameterValues | Returns all applicable values for a FamilyType parameter of this family.
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasLargeSketches | Checks whether the family contains sketches with a large number of elements.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsAppropriateCategoryId | Identifies if the input category id can be assigned as the new category for this family.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Family Class


Family.CanHaveStructuralSection Method

FamilyCanHaveStructuralSection Method

Identifies if this Family can have a structural section.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanHaveStructuralSection()
Public Function CanHaveStructuralSection As Boolean
public:
bool CanHaveStructuralSection()
member CanHaveStructuralSection : unit -> bool

Return Value

Boolean
True if the Family can have structural section, false otherwise.
See Also

Reference

Family Class


Family.CanLoadFamilies Method

FamilyCanLoadFamilies Method

Checks whether the document is in a state that allows the loading of families.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CanLoadFamilies(
    Document document
)
Public Shared Function CanLoadFamilies (
    document As Document
) As Boolean
public:
static bool CanLoadFamilies(
    Document^ document
)
static member CanLoadFamilies :
        document : Document -> bool

Parameters

document Document
The document to check.

Return Value

Boolean
True if loading of families is allowed, otherwise False.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

Family Class


Family.ExtractPartAtom Method

FamilyExtractPartAtom Method

Writes a PartAtom XML from the contents of a family object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ExtractPartAtom(
    string xmlFilePath
)
Public Sub ExtractPartAtom (
    xmlFilePath As String
)
public:
void ExtractPartAtom(
    String^ xmlFilePath
)
member ExtractPartAtom :
        xmlFilePath : string -> unit

Parameters

xmlFilePath String
The xml file to be saved.
Exceptions
Exception | Condition
ArgumentException | If 'xmlFilePath' is or an empty string.
Remarks
This method is designed for a family loaded into a document in session. So it will skip the type catalog file. To extract the PartAtom XML from a family file on disk, use Application.ExtractPartAtomFromFamilyFile()
See Also

Reference

Family Class


Family.GetFamilySymbolIds Method

FamilyGetFamilySymbolIds Method

Gets the ids of the FamilySymbols owned by this Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ISet<ElementId> GetFamilySymbolIds()
Public Function GetFamilySymbolIds As ISet(Of ElementId)
public:
ISet<ElementId^>^ GetFamilySymbolIds()
member GetFamilySymbolIds : unit -> ISet<ElementId>

Return Value

ISet ElementId
The ids of the FamilySymbols.
See Also

Reference

Family Class


Family.GetFamilyTypeParameterValues Method

FamilyGetFamilyTypeParameterValues Method

Returns all applicable values for a FamilyType parameter of this family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ISet<ElementId> GetFamilyTypeParameterValues(
    ElementId parameterId
)
Public Function GetFamilyTypeParameterValues (
    parameterId As ElementId
) As ISet(Of ElementId)
public:
ISet<ElementId^>^ GetFamilyTypeParameterValues(
    ElementId^ parameterId
)
member GetFamilyTypeParameterValues :
        parameterId : ElementId -> ISet<ElementId>

Parameters

parameterId ElementId
A valid Id of a FamilyType parameter defined for this family.

Return Value

ISet ElementId
Ids of all applicable ElementType and NestedFamilyTypeReference elements.
Exceptions
Exception | Condition
ArgumentException | The given parameterId does not represent a valid FamilyType parameter of this family.
ArgumentNullException | A non-optional argument was null
Remarks

The values are Element Ids of all family types that match the category specified by the definition of the given parameter. The elements are either of class ElementType or NestedFamilyTypeReference. The second variant is for the types that are nested in families and thus are not accessible otherwise.

If there are no applicable types of such category the returned collection will be empty.

Example
C#
VB
C++
F#
Copy
public void GetNestedFamilyTypes(FamilyInstance instance)
{
    // find one FamilyType parameter and all values applicable to it

    Parameter aTypeParam = null;
    ISet<ElementId> values = null;

    Family family = instance.Symbol.Family;

    foreach (Parameter param in instance.Symbol.Parameters)
    {

        if (Category.IsBuiltInCategory(param.Definition.GetDataType()))
        {

            aTypeParam = param;

            values = family.GetFamilyTypeParameterValues(param.Id);

            break;
        }
    }

    if (aTypeParam == null)
    {
        TaskDialog.Show("Warning", "The selected family has no FamilyType parameter defined.");
    }
    else if (values == null)
    {
        TaskDialog.Show("Error", "A FamilyType parameter does not have any applicable values!?");
    }
    else
    {
        ElementId newValue = values.Last<ElementId>();

        if (newValue != aTypeParam.AsElementId())
        {

            using (Transaction trans = new Transaction(instance.Document, "Setting parameter value"))
            {

                trans.Start();
                aTypeParam.Set(newValue);
                trans.Commit();
            }
        }
    }
}
Public Sub GetNestedFamilyTypes(instance As FamilyInstance)
    ' find one FamilyType parameter and all values applicable to it

    Dim aTypeParam As Parameter = Nothing
    Dim values As ISet(Of ElementId) = Nothing

    Dim family As Family = instance.Symbol.Family

    For Each param As Parameter In instance.Symbol.Parameters

        If Category.IsBuiltInCategory(param.Definition.GetDataType()) Then

            aTypeParam = param

            values = family.GetFamilyTypeParameterValues(param.Id)

            Exit For
        End If
    Next

    If aTypeParam Is Nothing Then
        TaskDialog.Show("Warning", "The selected family has no FamilyType parameter defined.")
    ElseIf values Is Nothing Then
        TaskDialog.Show("Error", "A FamilyType parameter does not have any applicable values!?")
    Else
        Dim newValue As ElementId = values.Last()

        If newValue <> aTypeParam.AsElementId() Then

            Using trans As New Transaction(instance.Document, "Setting parameter value")

                trans.Start()
                aTypeParam.[Set](newValue)
                trans.Commit()
            End Using
        End If
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Family Class


Family.HasLargeSketches Method

FamilyHasLargeSketches Method

Checks whether the family contains sketches with a large number of elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasLargeSketches()
Public Function HasLargeSketches As Boolean
public:
bool HasLargeSketches()
member HasLargeSketches : unit -> bool

Return Value

Boolean
Remarks
Families containing large sketches (typically with 300+ elements) may cause performance problems in parametric families (see IsParametric). Thus, before adding any constraints to a family (which will make the family parametric,) this method can be queried and the decision about whether the family should indeed be turned parametric may be deferred to the end-user.
See Also

Reference

Family Class


Family.IsAppropriateCategoryId Method

FamilyIsAppropriateCategoryId Method

Identifies if the input category id can be assigned as the new category for this family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsAppropriateCategoryId(
    ElementId categoryId
)
Public Function IsAppropriateCategoryId (
    categoryId As ElementId
) As Boolean
public:
bool IsAppropriateCategoryId(
    ElementId^ categoryId
)
member IsAppropriateCategoryId :
        categoryId : ElementId -> bool

Parameters

categoryId ElementId
The category id.

Return Value

Boolean
True if the input category id can be assigned as the new category for this family, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

Family Class


FamilyElementVisibility Class

Provides access to the visibility parameters of family elements in family document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBFamilyElementVisibility

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FamilyElementVisibility : APIObject
Public Class FamilyElementVisibility
    Inherits APIObject
public ref class FamilyElementVisibility : public APIObject
type FamilyElementVisibility =
    class
        inherit APIObject
    end

The FamilyElementVisibility type exposes the following members.

Constructors
 | Name | Description
Public method | FamilyElementVisibility | Initializes a new instance of the FamilyElementVisibility class
Top
Properties
 | Name | Description
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | IsShownInCoarse | Indicates if the instance is display with Coarse detail level in the view of project document.
Public property | IsShownInFine | Indicates if the instance is display with Fine detail level in the view of project document.
Public property | IsShownInFrontBack | Indicates if the instance is display in Front/Back view of project document.
Public property | IsShownInLeftRight | Indicates if the instance is display in Left/Right view of project document.
Public property | IsShownInMedium | Indicates if the instance is display with Medium detail level in the view of project document.
Public property | IsShownInPlanRCPCut | Indicates if the instance is displayed when cut in Plan/RCP (if the category permits).
Public property | IsShownInTopBottom | Indicates if the instance is display in Plan/RCP view of project document.
Public property | IsShownOnlyWhenCut | Indicates if the instance is displayed only if it has been cut.
Public property | VisibilityType | Indicates if the instance is Model or View specific.
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Example
C#
VB
C++
F#
Copy
public void CreateAndSetVisibility(Autodesk.Revit.DB.Document familyDocument, SketchPlane sketchPlane)
{
    // create a new ModelCurve in the family document
    XYZ p0 = new XYZ(1, 1, 0);
    XYZ p1 = new XYZ(5, 1, 0);
    Line line1 = Line.CreateBound(p0, p1);

    ModelCurve modelCurve1 = familyDocument.FamilyCreate.NewModelCurve(line1, sketchPlane);

    // create a new ModelText along ModelCurve line
    ModelText text = familyDocument.FamilyCreate.NewModelText("Hello World", null, sketchPlane, p0, HorizontalAlign.Center, 0.1);

    // set visibility for text
    FamilyElementVisibility textVisibility = new FamilyElementVisibility(FamilyElementVisibilityType.Model);
    textVisibility.IsShownInTopBottom = false;
    text.SetVisibility(textVisibility);

    // set visibility for line
    FamilyElementVisibility curveVisibility = new FamilyElementVisibility(FamilyElementVisibilityType.Model);
    curveVisibility.IsShownInCoarse = false;
    modelCurve1.SetVisibility(curveVisibility);

}
Public Sub CreateAndSetVisibility(familyDocument As Autodesk.Revit.DB.Document, sketchPlane As SketchPlane)
    ' create a new ModelCurve in the family document
    Dim p0 As New XYZ(1, 1, 0)
    Dim p1 As New XYZ(5, 1, 0)
    Dim line1 As Line = Line.CreateBound(p0, p1)

    Dim modelCurve1 As ModelCurve = familyDocument.FamilyCreate.NewModelCurve(line1, sketchPlane)

    ' create a new ModelText along ModelCurve line
    Dim text As ModelText = familyDocument.FamilyCreate.NewModelText("Hello World", Nothing, sketchPlane, p0, HorizontalAlign.Center, 0.1)

    ' set visibility for text
    Dim textVisibility As New FamilyElementVisibility(FamilyElementVisibilityType.Model)
    textVisibility.IsShownInTopBottom = False
    text.SetVisibility(textVisibility)

    ' set visibility for line
    Dim curveVisibility As New FamilyElementVisibility(FamilyElementVisibilityType.Model)
    curveVisibility.IsShownInCoarse = False
    modelCurve1.SetVisibility(curveVisibility)

End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FamilyElementVisibility Constructor

Initializes a new instance of the FamilyElementVisibility class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyElementVisibility(
    FamilyElementVisibilityType visibilityType
)
Public Sub New (
    visibilityType As FamilyElementVisibilityType
)
public:
FamilyElementVisibility(
    FamilyElementVisibilityType visibilityType
)
new :
        visibilityType : FamilyElementVisibilityType -> FamilyElementVisibility

Parameters

visibilityType FamilyElementVisibilityType
See Also

Reference

FamilyElementVisibility Class


FamilyElementVisibility Properties

The FamilyElementVisibility type exposes the following members.

Properties
 | Name | Description
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | IsShownInCoarse | Indicates if the instance is display with Coarse detail level in the view of project document.
Public property | IsShownInFine | Indicates if the instance is display with Fine detail level in the view of project document.
Public property | IsShownInFrontBack | Indicates if the instance is display in Front/Back view of project document.
Public property | IsShownInLeftRight | Indicates if the instance is display in Left/Right view of project document.
Public property | IsShownInMedium | Indicates if the instance is display with Medium detail level in the view of project document.
Public property | IsShownInPlanRCPCut | Indicates if the instance is displayed when cut in Plan/RCP (if the category permits).
Public property | IsShownInTopBottom | Indicates if the instance is display in Plan/RCP view of project document.
Public property | IsShownOnlyWhenCut | Indicates if the instance is displayed only if it has been cut.
Public property | VisibilityType | Indicates if the instance is Model or View specific.
Top
See Also

Reference

FamilyElementVisibility Class


FamilyElementVisibility.IsShownInCoarse Property

FamilyElementVisibilityIsShownInCoarse Property

Indicates if the instance is display with Coarse detail level in the view of project document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsShownInCoarse { get; set; }
Public Property IsShownInCoarse As Boolean
    Get
    Set
public:
property bool IsShownInCoarse {
    bool get ();
    void set (bool value);
}
member IsShownInCoarse : bool with get, set

Property Value

Boolean
Remarks
This property cannot be set to false if the other two detail levels are also false.
See Also

Reference

FamilyElementVisibility Class


FamilyElementVisibility.IsShownInFine Property

FamilyElementVisibilityIsShownInFine Property

Indicates if the instance is display with Fine detail level in the view of project document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsShownInFine { get; set; }
Public Property IsShownInFine As Boolean
    Get
    Set
public:
property bool IsShownInFine {
    bool get ();
    void set (bool value);
}
member IsShownInFine : bool with get, set

Property Value

Boolean
Remarks
This property cannot be set to false if the other two detail levels are also false.
See Also

Reference

FamilyElementVisibility Class


FamilyElementVisibility.IsShownInFrontBack Property

FamilyElementVisibilityIsShownInFrontBack Property

Indicates if the instance is display in Front/Back view of project document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsShownInFrontBack { get; set; }
Public Property IsShownInFrontBack As Boolean
    Get
    Set
public:
property bool IsShownInFrontBack {
    bool get ();
    void set (bool value);
}
member IsShownInFrontBack : bool with get, set

Property Value

Boolean
Remarks
This property matters for objects whose visibility type is Model.
See Also

Reference

FamilyElementVisibility Class


FamilyElementVisibility.IsShownInLeftRight Property

FamilyElementVisibilityIsShownInLeftRight Property

Indicates if the instance is display in Left/Right view of project document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsShownInLeftRight { get; set; }
Public Property IsShownInLeftRight As Boolean
    Get
    Set
public:
property bool IsShownInLeftRight {
    bool get ();
    void set (bool value);
}
member IsShownInLeftRight : bool with get, set

Property Value

Boolean
Remarks
This property matters for objects whose visibility type is Model.
See Also

Reference

FamilyElementVisibility Class


FamilyElementVisibility.IsShownInMedium Property

FamilyElementVisibilityIsShownInMedium Property

Indicates if the instance is display with Medium detail level in the view of project document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsShownInMedium { get; set; }
Public Property IsShownInMedium As Boolean
    Get
    Set
public:
property bool IsShownInMedium {
    bool get ();
    void set (bool value);
}
member IsShownInMedium : bool with get, set

Property Value

Boolean
Remarks
This property cannot be set to false if the other two detail levels are also false.
See Also

Reference

FamilyElementVisibility Class


FamilyElementVisibility.IsShownInPlanRCPCut Property

FamilyElementVisibilityIsShownInPlanRCPCut Property

Indicates if the instance is displayed when cut in Plan/RCP (if the category permits).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsShownInPlanRCPCut { get; set; }
Public Property IsShownInPlanRCPCut As Boolean
    Get
    Set
public:
property bool IsShownInPlanRCPCut {
    bool get ();
    void set (bool value);
}
member IsShownInPlanRCPCut : bool with get, set

Property Value

Boolean
Remarks
controls whether the Model Family Element is shown when a FamilyInstance of that Family is cut in a Plan/RCP view, i.e. the cut plane passes through the bounding box of the instance. It only has a meaning for categories that are "cut in the symbol". For non-cuttable categories it is always false and for ones that are "cuttable in the instance" it is the same as the IsShownInTopBottom.
See Also

Reference

FamilyElementVisibility Class


FamilyElementVisibility.IsShownInTopBottom Property

FamilyElementVisibilityIsShownInTopBottom Property

Indicates if the instance is display in Plan/RCP view of project document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsShownInTopBottom { get; set; }
Public Property IsShownInTopBottom As Boolean
    Get
    Set
public:
property bool IsShownInTopBottom {
    bool get ();
    void set (bool value);
}
member IsShownInTopBottom : bool with get, set

Property Value

Boolean
Remarks
This property matters for objects whose visibility type is Model.
See Also

Reference

FamilyElementVisibility Class


FamilyElementVisibility.IsShownOnlyWhenCut Property

FamilyElementVisibilityIsShownOnlyWhenCut Property

Indicates if the instance is displayed only if it has been cut.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsShownOnlyWhenCut { get; set; }
Public Property IsShownOnlyWhenCut As Boolean
    Get
    Set
public:
property bool IsShownOnlyWhenCut {
    bool get ();
    void set (bool value);
}
member IsShownOnlyWhenCut : bool with get, set

Property Value

Boolean
Remarks
This property matters for objects which visibility type is ViewSpecific.
See Also

Reference

FamilyElementVisibility Class


FamilyElementVisibility.VisibilityType Property

FamilyElementVisibilityVisibilityType Property

Indicates if the instance is Model or View specific.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyElementVisibilityType VisibilityType { get; }
Public ReadOnly Property VisibilityType As FamilyElementVisibilityType
    Get
public:
property FamilyElementVisibilityType VisibilityType {
    FamilyElementVisibilityType get ();
}
member VisibilityType : FamilyElementVisibilityType with get

Property Value

FamilyElementVisibilityType
See Also

Reference

FamilyElementVisibility Class


FamilyElementVisibility Methods

The FamilyElementVisibility type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FamilyElementVisibility Class


FamilyElementVisibilityType Enumeration

Indicates the Visibility type of generic forms.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum FamilyElementVisibilityType
Public Enumeration FamilyElementVisibilityType
public enum class FamilyElementVisibilityType
type FamilyElementVisibilityType
Members
Member name | Value | Description
Model | 0 | The element will be displayed in 3D views and model other model views.
ViewSpecific | 1 | The element will be displayed only in the view where it is created. This applies to items like detail components, annotations, and view-specific imports.
Remarks
Use this enum to indicate the visibility type of new forms.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FamilyHostingBehavior Enumeration

Types of hosts into/onto which a family can be hosted. For informative purposes only. Does not affect anything in Revit!

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum FamilyHostingBehavior
Public Enumeration FamilyHostingBehavior
public enum class FamilyHostingBehavior
type FamilyHostingBehavior
Members
Member name | Value | Description
None | 0 |
Wall | 1 |
Floor | 2 |
Ceiling | 3 |
Roof | 4 |
Face | 5 |
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FamilyInstance Class

This object represents a single instance of a family type, such as a single I beam.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBInstance
Autodesk.Revit.DBFamilyInstance
Autodesk.Revit.DBAnnotationSymbol
Autodesk.Revit.DBMullion
Autodesk.Revit.DBPanel

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FamilyInstance : Instance
Public Class FamilyInstance
    Inherits Instance
public ref class FamilyInstance : public Instance
type FamilyInstance =
    class
        inherit Instance
    end

The FamilyInstance type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanFlipFacing | Property to test whether the orientation of family instance facing can be flipped.
Public property | CanFlipHand | Property to test whether the orientation of family instance hand can be flipped.
Public property | CanFlipWorkPlane | Identifies if the instance can flip its work plane.
Public property | CanRotate | Property to test whether the family instance can be rotated by 180 degrees.
Public property | CanSplit | Identifies whether a particular family instance can be split at a point on it's defining curve (by Split(Double)).
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | ExtensionUtility | Property to check whether the instance can be extended and return the interface for extension operation.
Public property | FacingFlipped | Property to test whether the orientation of family instance facing is flipped.
Public property | FacingOrientation | Property to get the orientation of family instance facing.
Public property | FromRoom | The "From Room" set for the door or window in the last phase of the project.
Public property | FromRoomPhase |
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HandFlipped | Property to test whether the orientation of family instance hand is flipped.
Public property | HandOrientation | Property to get the orientation of family instance hand.
Public property | HasSpatialElementCalculationPoint | Identifies if this instance has a single SpatialElementCalculationPoint used as the search point for Revit to identify if the instance is inside a room or space.
Public property | HasSpatialElementFromToCalculationPoints | Identifies if this instance has a pair of SpatialElementCalculationPoints used as the search points for Revit to identify if the instance lies between up to two rooms or spaces.
Public property | Host | If the instance is contained within another element, this property returns the containing element. An instance that is face hosted will return the element containing the face.
Public property | HostFace | Property to get the reference to the host face of family instance.
Public property | HostParameter | If the instance is hosted by a wall, this property returns the parameter value of the insertion point of the instance along the wall's location curve, as long as the family of the instance isn't work plane based.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | Invisible | Property to test whether the family instance is invisible.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsSlantedColumn | Indicates if the family instance is a slanted column.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | IsWorkPlaneFlipped | Identifies if the instance's work plane is flipped.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | Location | This property is used to find the physical location of an instance within project. (Overrides ElementLocation)
Public property | MEPModel | Retrieves the MEP model for the family instance.
Public property | Mirrored | Property to test whether the family instance is mirrored. (only one axis is flipped)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Room | The room in which the instance is located (during the last phase of the project).
Public property | RoomPhase |
Public property | Space | The space in which the instance is located (during the last phase of the project).
Public property | SpacePhase |
Public property | StructuralMaterialId | Identifies the material that defines the instance's structural analysis properties.
Public property | StructuralMaterialType | This property returns the physical material from which the instance is made.
 | StructuralType | Provides the primary structural type of the instance, such as beam or column etc.
Public property | StructuralUsage | Provides the primary structural usage of the instance, such as brace, girder etc.
Public property | SuperComponent | Property to get the super component of current family instance.
 | Symbol | Returns or changes the FamilySymbol object that represents the type of the instance.
Public property | ToRoom | The "To Room" set for the door or window in the last phase of the project.
Public property | ToRoomPhase |
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | AddCoping | Adds a coping (cut) to a steel beam.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | flipFacing | The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true.
Public method | FlipFromToRoom | Flips the settings of "From Room" and "To Room" for the door or window instance.
Public method | flipHand | The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true.
Public method | GetCopingIds | Lists the elements currently used as coping cutters for this element.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFamilyPointPlacementReferences | Returns the Point Placement References for the Family Instance.
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetOriginalGeometry | Returns the original geometry of the instance, before the instance is modified by joins, cuts, coping, extensions, or other post-processing.
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetReferenceByName | Gets the family instance reference corresponding to the named reference plane in the instance's family.
Public method | GetReferenceName | Gets the name of the reference plane in the family corresponding to the given family instance reference.
Public method | GetReferences | Gets family instance references corresponding to the reference planes or reference lines of the given reference type in the instance's family.
Public method | GetReferenceType | Gets the type of the reference plane or reference line in the instance's family corresponding to the given family instance reference.
Public method | GetSpatialElementCalculationPoint | Gets the location of the calculation point for this instance.
Public method | GetSpatialElementFromToCalculationPoints | Gets the locations for the calculation points for this instance.
 | GetSubComponentIds | Gets the sub component ElementIds of the current family instance.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetSweptProfile | Gets the object that describes the profile that is swept along the driving curve for this instance.
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances. (Inherited from Instance)
Public method | GetTransform | Gets the transform of the instance. (Inherited from Instance)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasModifiedGeometry | Identifies if the geometry of this FamilyInstance has been modified from the automatically generated default.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasSweptProfile | Indicates if this instance can be represented as a swept profile.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveCoping | Removes a coping (cut) from a steel beam.
Public method | rotate | The family instance will be flipped by 180 degrees. If it can not be rotated, return false, otherwise return true.
Public method | SetCopingIds | Specifies the set of coping cutters on this element.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | Split | Splits the family instance element at a point on its defining curve.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Examples of FamilyInstance objects within Autodesk Revit are Beams, Columns, Braces and Desks. The FamilyInstance object provides more detailed properties that enable the type of the family instance to be changed, thus changing their appearance within the project.
Example
C#
VB
C++
F#
Copy
public void GetInfo_FamilyInstance(FamilyInstance familyInstance)
{
    string message = "FamilyInstance : ";
    // Get FamilyInstance host name
    if (familyInstance.Host != null)
    {
        message += "\nFamilyInstance host name is : " + familyInstance.Host.Name;
    }

    foreach (ElementId materialId in familyInstance.GetMaterialIds(false))
    {
        Material material = familyInstance.Document.GetElement(materialId) as Material;
        message += "\nFamilyInstance e material : " + material.Name;
    }
    // Get FamilyInstance room name
    if (familyInstance.Room != null)
    {
        message += "\nFamilyInstance room name is : " + familyInstance.Room.Name;
    }

    // Get FamilyInstance structural type
    message += "\nFamilyInstance structural type is : " + familyInstance.StructuralType;

    // Get FamilyInstance structural usage
    message += "\nFamilyInstance structural usage is : " + familyInstance.StructuralUsage;

    TaskDialog.Show("Revit",message);
}
Public Sub GetInfo_FamilyInstance(familyInstance As FamilyInstance)
 Dim message As String = "FamilyInstance : "

 ' Get FamilyInstance host name
 If familyInstance.Host IsNot Nothing Then
        message += vbLf & "FamilyInstance host name is : " & Convert.ToString(familyInstance.Host.Name)
    End If

    For Each materialId As ElementId In familyInstance.GetMaterialIds(False)
        Dim material As Material = TryCast(familyInstance.Document.GetElement(materialId), Material)
        message += vbLf & "FamilyInstance e material : " + material.Name
    Next
    ' Get FamilyInstance room name
    If familyInstance.Room IsNot Nothing Then
        message += vbLf & "FamilyInstance room name is : " & Convert.ToString(familyInstance.Room.Name)
    End If

    ' Get FamilyInstance structural type
    message += vbLf & "FamilyInstance structural type is : " & Convert.ToString(familyInstance.StructuralType)

    ' Get FamilyInstance structural usage
    message += vbLf & "FamilyInstance structural usage is : " & Convert.ToString(familyInstance.StructuralUsage)

    TaskDialog.Show("Revit", message)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FamilyInstance Properties

The FamilyInstance type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanFlipFacing | Property to test whether the orientation of family instance facing can be flipped.
Public property | CanFlipHand | Property to test whether the orientation of family instance hand can be flipped.
Public property | CanFlipWorkPlane | Identifies if the instance can flip its work plane.
Public property | CanRotate | Property to test whether the family instance can be rotated by 180 degrees.
Public property | CanSplit | Identifies whether a particular family instance can be split at a point on it's defining curve (by Split(Double)).
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | ExtensionUtility | Property to check whether the instance can be extended and return the interface for extension operation.
Public property | FacingFlipped | Property to test whether the orientation of family instance facing is flipped.
Public property | FacingOrientation | Property to get the orientation of family instance facing.
Public property | FromRoom | The "From Room" set for the door or window in the last phase of the project.
Public property | FromRoomPhase |
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HandFlipped | Property to test whether the orientation of family instance hand is flipped.
Public property | HandOrientation | Property to get the orientation of family instance hand.
Public property | HasSpatialElementCalculationPoint | Identifies if this instance has a single SpatialElementCalculationPoint used as the search point for Revit to identify if the instance is inside a room or space.
Public property | HasSpatialElementFromToCalculationPoints | Identifies if this instance has a pair of SpatialElementCalculationPoints used as the search points for Revit to identify if the instance lies between up to two rooms or spaces.
Public property | Host | If the instance is contained within another element, this property returns the containing element. An instance that is face hosted will return the element containing the face.
Public property | HostFace | Property to get the reference to the host face of family instance.
Public property | HostParameter | If the instance is hosted by a wall, this property returns the parameter value of the insertion point of the instance along the wall's location curve, as long as the family of the instance isn't work plane based.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | Invisible | Property to test whether the family instance is invisible.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsSlantedColumn | Indicates if the family instance is a slanted column.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | IsWorkPlaneFlipped | Identifies if the instance's work plane is flipped.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | Location | This property is used to find the physical location of an instance within project. (Overrides ElementLocation)
Public property | MEPModel | Retrieves the MEP model for the family instance.
Public property | Mirrored | Property to test whether the family instance is mirrored. (only one axis is flipped)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Room | The room in which the instance is located (during the last phase of the project).
Public property | RoomPhase |
Public property | Space | The space in which the instance is located (during the last phase of the project).
Public property | SpacePhase |
Public property | StructuralMaterialId | Identifies the material that defines the instance's structural analysis properties.
Public property | StructuralMaterialType | This property returns the physical material from which the instance is made.
 | StructuralType | Provides the primary structural type of the instance, such as beam or column etc.
Public property | StructuralUsage | Provides the primary structural usage of the instance, such as brace, girder etc.
Public property | SuperComponent | Property to get the super component of current family instance.
 | Symbol | Returns or changes the FamilySymbol object that represents the type of the instance.
Public property | ToRoom | The "To Room" set for the door or window in the last phase of the project.
Public property | ToRoomPhase |
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

FamilyInstance Class


FamilyInstance.CanFlipFacing Property

FamilyInstanceCanFlipFacing Property

Property to test whether the orientation of family instance facing can be flipped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanFlipFacing { get; }
Public ReadOnly Property CanFlipFacing As Boolean
    Get
public:
property bool CanFlipFacing {
    bool get ();
}
member CanFlipFacing : bool with get

Property Value

Boolean
See Also

Reference

FamilyInstance Class


FamilyInstance.CanFlipHand Property

FamilyInstanceCanFlipHand Property

Property to test whether the orientation of family instance hand can be flipped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanFlipHand { get; }
Public ReadOnly Property CanFlipHand As Boolean
    Get
public:
property bool CanFlipHand {
    bool get ();
}
member CanFlipHand : bool with get

Property Value

Boolean
See Also

Reference

FamilyInstance Class


FamilyInstance.CanFlipWorkPlane Property

FamilyInstanceCanFlipWorkPlane Property

Identifies if the instance can flip its work plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanFlipWorkPlane { get; }
Public ReadOnly Property CanFlipWorkPlane As Boolean
    Get
public:
property bool CanFlipWorkPlane {
    bool get ();
}
member CanFlipWorkPlane : bool with get

Property Value

Boolean
See Also

Reference

FamilyInstance Class


FamilyInstance.CanRotate Property

FamilyInstanceCanRotate Property

Property to test whether the family instance can be rotated by 180 degrees.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanRotate { get; }
Public ReadOnly Property CanRotate As Boolean
    Get
public:
property bool CanRotate {
    bool get ();
}
member CanRotate : bool with get

Property Value

Boolean
See Also

Reference

FamilyInstance Class


FamilyInstance.CanSplit Property

FamilyInstanceCanSplit Property

Identifies whether a particular family instance can be split at a point on it's defining curve (by Split(Double)).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanSplit { get; }
Public ReadOnly Property CanSplit As Boolean
    Get
public:
property bool CanSplit {
    bool get ();
}
member CanSplit : bool with get

Property Value

Boolean
True if the family instance can be split, otherwise false.
See Also

Reference

FamilyInstance Class


FamilyInstance.ExtensionUtility Property

FamilyInstanceExtensionUtility Property

Property to check whether the instance can be extended and return the interface for extension operation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IExtension ExtensionUtility { get; }
Public ReadOnly Property ExtensionUtility As IExtension
    Get
public:
property IExtension^ ExtensionUtility {
    IExtension^ get ();
}
member ExtensionUtility : IExtension with get

Property Value

IExtension
Remarks
If the family instance can not support extension operation, it returns
See Also

Reference

FamilyInstance Class


FamilyInstance.FacingFlipped Property

FamilyInstanceFacingFlipped Property

Property to test whether the orientation of family instance facing is flipped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool FacingFlipped { get; }
Public ReadOnly Property FacingFlipped As Boolean
    Get
public:
property bool FacingFlipped {
    bool get ();
}
member FacingFlipped : bool with get

Property Value

Boolean
See Also

Reference

FamilyInstance Class


FamilyInstance.FacingOrientation Property

FamilyInstanceFacingOrientation Property

Property to get the orientation of family instance facing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ FacingOrientation { get; }
Public ReadOnly Property FacingOrientation As XYZ
    Get
public:
property XYZ^ FacingOrientation {
    XYZ^ get ();
}
member FacingOrientation : XYZ with get

Property Value

XYZ
See Also

Reference

FamilyInstance Class


FamilyInstance.FromRoom Property

FamilyInstanceFromRoom Property

The "From Room" set for the door or window.
Overload List
 | Name | Description
Public property | FromRoom | The "From Room" set for the door or window in the last phase of the project.
Public property | FromRoomPhase |
Top
See Also

Reference

FamilyInstance Class


FamilyInstance.FromRoom Property

FamilyInstanceFromRoom Property

The "From Room" set for the door or window in the last phase of the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Room FromRoom { get; }
Public ReadOnly Property FromRoom As Room
    Get
public:
property Room^ FromRoom {
    Room^ get ();
}
member FromRoom : Room with get

Property Value

Room
The "From Room" set for the door or window in the last phase of the project. if the FamilyInstance is neither a door nor a window, or if the door or window leads to a space where there is no room (an exterior space or interior space with no room defined). Also if there is no target room assigned to the last phase, or phase does not apply to this FamilyInstance.
Remarks
Revit automatically calculates the "From Room" for a given door or window. This is the default shown when creating a door or window schedule and adding the "From Room" properties. The user can opt to swap the "From Room" and "To Room" values via the schedule if they choose. The method FlipFromToRoom also can be used to swap the values.
See Also

Reference

FamilyInstance Class
FromRoom Overload


FamilyInstance.FromRoom(Phase) Property

FamilyInstanceFromRoom(Phase) Property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Room this[
    Phase phase
] { get; }
Public ReadOnly Property FromRoom (
    phase As Phase
) As Room
    Get
public:
property Room^ FromRoom[Phase^ phase] {
    Room^ get (Phase^ phase);
}
member FromRoom : Room with get

Parameters

phase Phase

Property Value

Room
See Also

Reference

FamilyInstance Class
FromRoom Overload


FamilyInstance.HandFlipped Property

FamilyInstanceHandFlipped Property

Property to test whether the orientation of family instance hand is flipped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HandFlipped { get; }
Public ReadOnly Property HandFlipped As Boolean
    Get
public:
property bool HandFlipped {
    bool get ();
}
member HandFlipped : bool with get

Property Value

Boolean
See Also

Reference

FamilyInstance Class


FamilyInstance.HandOrientation Property

FamilyInstanceHandOrientation Property

Property to get the orientation of family instance hand.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ HandOrientation { get; }
Public ReadOnly Property HandOrientation As XYZ
    Get
public:
property XYZ^ HandOrientation {
    XYZ^ get ();
}
member HandOrientation : XYZ with get

Property Value

XYZ
See Also

Reference

FamilyInstance Class


FamilyInstance.HasSpatialElementCalculationPoint Property

FamilyInstanceHasSpatialElementCalculationPoint Property

Identifies if this instance has a single SpatialElementCalculationPoint used as the search point for Revit to identify if the instance is inside a room or space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasSpatialElementCalculationPoint { get; }
Public ReadOnly Property HasSpatialElementCalculationPoint As Boolean
    Get
public:
property bool HasSpatialElementCalculationPoint {
    bool get ();
}
member HasSpatialElementCalculationPoint : bool with get

Return Value

Boolean
True if this instance has a single SpatialElementCalculationPoint used as the search point, false otherwise.
See Also

Reference

FamilyInstance Class


FamilyInstance.HasSpatialElementFromToCalculationPoints Property

FamilyInstanceHasSpatialElementFromToCalculationPoints Property

Identifies if this instance has a pair of SpatialElementCalculationPoints used as the search points for Revit to identify if the instance lies between up to two rooms or spaces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasSpatialElementFromToCalculationPoints { get; }
Public ReadOnly Property HasSpatialElementFromToCalculationPoints As Boolean
    Get
public:
property bool HasSpatialElementFromToCalculationPoints {
    bool get ();
}
member HasSpatialElementFromToCalculationPoints : bool with get

Return Value

Boolean
True if this instance has a pair of SpatialElementCalculationPoints used as the search points, false otherwise.
Remarks

The points determine which room or space is considered the "from" and which is considered the "to" for a family instance which connects two rooms or spaces, such as a door or window.

See Also

Reference

FamilyInstance Class


FamilyInstance.Host Property

FamilyInstanceHost Property

If the instance is contained within another element, this property returns the containing element. An instance that is face hosted will return the element containing the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Element Host { get; }
Public ReadOnly Property Host As Element
    Get
public:
property Element^ Host {
    Element^ get ();
}
member Host : Element with get

Property Value

Element
Remarks
An example of an instance that is contained is a window. In this case the host property would return the wall in which the window is contained. Another example is an instance that is hosted to a planar or curved face in a Mass element will return the Mass element.
See Also

Reference

FamilyInstance Class


FamilyInstance.HostFace Property

FamilyInstanceHostFace Property

Property to get the reference to the host face of family instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Reference HostFace { get; }
Public ReadOnly Property HostFace As Reference
    Get
public:
property Reference^ HostFace {
    Reference^ get ();
}
member HostFace : Reference with get

Property Value

Reference
If the instance is placed on a work plane, this property will return the reference to the geometry face underlying the work plane. If the work plane is not referencing other geometry, this property will return . If the instance is not hosted on a face or work plane, this property will return .
See Also

Reference

FamilyInstance Class


FamilyInstance.HostParameter Property

FamilyInstanceHostParameter Property

If the instance is hosted by a wall, this property returns the parameter value of the insertion point of the instance along the wall's location curve, as long as the family of the instance isn't work plane based.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double HostParameter { get; }
Public ReadOnly Property HostParameter As Double
    Get
public:
property double HostParameter {
    double get ();
}
member HostParameter : float with get

Property Value

Double
Exceptions
Exception | Condition
InvalidOperationException | Only hosted instances whose family is not work plane based can support this functionality.
InvalidOperationException | Only hosted instances of type Wall or in-place elements of category OST_Walls can support this functionality.
Remarks
This works for instances with a host element that is of type Wall or is in the OST_Walls category only, including in-place ones.
See Also

Reference

FamilyInstance Class


FamilyInstance.Invisible Property

FamilyInstanceInvisible Property

Property to test whether the family instance is invisible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Invisible { get; }
Public ReadOnly Property Invisible As Boolean
    Get
public:
property bool Invisible {
    bool get ();
}
member Invisible : bool with get

Property Value

Boolean
See Also

Reference

FamilyInstance Class


FamilyInstance.IsSlantedColumn Property

FamilyInstanceIsSlantedColumn Property

Indicates if the family instance is a slanted column.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSlantedColumn { get; }
Public ReadOnly Property IsSlantedColumn As Boolean
    Get
public:
property bool IsSlantedColumn {
    bool get ();
}
member IsSlantedColumn : bool with get

Property Value

Boolean
Remarks
If the family instance is a slanted column, it returns true, otherwise returns false.
See Also

Reference

FamilyInstance Class


FamilyInstance.IsWorkPlaneFlipped Property

FamilyInstanceIsWorkPlaneFlipped Property

Identifies if the instance's work plane is flipped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsWorkPlaneFlipped { get; set; }
Public Property IsWorkPlaneFlipped As Boolean
    Get
    Set
public:
property bool IsWorkPlaneFlipped {
    bool get ();
    void set (bool value);
}
member IsWorkPlaneFlipped : bool with get, set

Property Value

Boolean
Exceptions
Exception | Condition
InapplicableDataException | Work plane cannot be flipped for this instance.
See Also

Reference

FamilyInstance Class


FamilyInstance.Location Property

FamilyInstanceLocation Property

This property is used to find the physical location of an instance within project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Location Location { get; }
Public Overrides ReadOnly Property Location As Location
    Get
public:
virtual property Location^ Location {
    Location^ get () override;
}
abstract Location : Location with get
override Location : Location with get

Property Value

Location
Remarks
The Location property returns an object that can be used to find the location of an instance within the project. An instance may have a point location, such as a footing or may have a line location. A beam is an example of an instance that has a line location.
See Also

Reference

FamilyInstance Class


FamilyInstance.MEPModel Property

FamilyInstanceMEPModel Property

Retrieves the MEP model for the family instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MEPModel MEPModel { get; }
Public ReadOnly Property MEPModel As MEPModel
    Get
public:
property MEPModel^ MEPModel {
    MEPModel^ get ();
}
member MEPModel : MEPModel with get

Property Value

MEPModel
Remarks
If the family instance has a MEP model it is returned by this method, otherwise is returned. Different types of MEP model will be returned based on the type of the instance, for example - if the instance is a lighting device then a lighting device model will be returned. This property will only function with the Autodesk Revit MEP product.
See Also

Reference

FamilyInstance Class


FamilyInstance.Mirrored Property

FamilyInstanceMirrored Property

Property to test whether the family instance is mirrored. (only one axis is flipped)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Mirrored { get; }
Public ReadOnly Property Mirrored As Boolean
    Get
public:
property bool Mirrored {
    bool get ();
}
member Mirrored : bool with get

Property Value

Boolean
See Also

Reference

FamilyInstance Class


FamilyInstance.Room Property

FamilyInstanceRoom Property

The room in which the instance is located.
Overload List
 | Name | Description
Public property | Room | The room in which the instance is located (during the last phase of the project).
Public property | RoomPhase |
Top
See Also

Reference

FamilyInstance Class


FamilyInstance.Room Property

FamilyInstanceRoom Property

The room in which the instance is located (during the last phase of the project).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Room Room { get; }
Public ReadOnly Property Room As Room
    Get
public:
property Room^ Room {
    Room^ get ();
}
member Room : Room with get

Property Value

Room
Remarks
This property will be the first room encountered that contains the instance. If more than one room includes this point in its volume only the first one is returned. If no room is found that contains the instance, or if phase does not apply to this FaimlyInstance, this property is . This property should not be used for door or window instances, which are placed on the boundary or between rooms. Use the FromRoom and ToRoom properties instead.
See Also

Reference

FamilyInstance Class
Room Overload


FamilyInstance.Room(Phase) Property

FamilyInstanceRoom(Phase) Property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Room this[
    Phase phase
] { get; }
Public ReadOnly Property Room (
    phase As Phase
) As Room
    Get
public:
property Room^ Room[Phase^ phase] {
    Room^ get (Phase^ phase);
}
member Room : Room with get

Parameters

phase Phase

Property Value

Room
See Also

Reference

FamilyInstance Class
Room Overload


FamilyInstance.Space Property

FamilyInstanceSpace Property

The space in which the instance is located.
Overload List
 | Name | Description
Public property | Space | The space in which the instance is located (during the last phase of the project).
Public property | SpacePhase |
Top
See Also

Reference

FamilyInstance Class


FamilyInstance.Space Property

FamilyInstanceSpace Property

The space in which the instance is located (during the last phase of the project).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Space Space { get; }
Public ReadOnly Property Space As Space
    Get
public:
property Space^ Space {
    Space^ get ();
}
member Space : Space with get

Property Value

Space
Remarks
This property will be the first space encountered that contains the instance. If more than one space includes this point in its volume only the first one is returned. If no space is found that contains the instance, or if phase does not apply to this FaimlyInstance, this property is .
See Also

Reference

FamilyInstance Class
Space Overload


FamilyInstance.Space(Phase) Property

FamilyInstanceSpace(Phase) Property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Space this[
    Phase phase
] { get; }
Public ReadOnly Property Space (
    phase As Phase
) As Space
    Get
public:
property Space^ Space[Phase^ phase] {
    Space^ get (Phase^ phase);
}
member Space : Space with get

Parameters

phase Phase

Property Value

Space
See Also

Reference

FamilyInstance Class
Space Overload


FamilyInstance.StructuralMaterialId Property

FamilyInstanceStructuralMaterialId Property

Identifies the material that defines the instance's structural analysis properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId StructuralMaterialId { get; set; }
Public Property StructuralMaterialId As ElementId
    Get
    Set
public:
property ElementId^ StructuralMaterialId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member StructuralMaterialId : ElementId with get, set

Property Value

ElementId
See Also

Reference

FamilyInstance Class


FamilyInstance.StructuralMaterialType Property

FamilyInstanceStructuralMaterialType Property

This property returns the physical material from which the instance is made.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public StructuralMaterialType StructuralMaterialType { get; }
Public ReadOnly Property StructuralMaterialType As StructuralMaterialType
    Get
public:
property StructuralMaterialType StructuralMaterialType {
    StructuralMaterialType get ();
}
member StructuralMaterialType : StructuralMaterialType with get

Property Value

StructuralMaterialType
Remarks
Values of this property can be Steel, Concrete, Wood or some other material. Different from Revit materials that geometry really consists of, this property is a family parameter defining family behavior and can not be set per instance. Its value is the same with the type of the instance's family. For example, the instances of different kind of column families(Steel, Concrete or Wood) have different material values and can't be changed int the UI or RevitAPI.
See Also

Reference

FamilyInstance Class


FamilyInstance.StructuralType Property

FamilyInstanceStructuralType Property

Provides the primary structural type of the instance, such as beam or column etc.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public StructuralType StructuralType { get; }
Public ReadOnly Property StructuralType As StructuralType
    Get
public:
property StructuralType StructuralType {
    StructuralType get ();
}
member StructuralType : StructuralType with get

Property Value

StructuralType
Example
C#
VB
C++
F#
Copy
public void GetStructuralType(FamilyInstance familyInstance)
{
    string message = "";
    switch (familyInstance.StructuralType)
    {
        case StructuralType.Beam:
            message = "FamilyInstance is a beam.";
            break;
        case StructuralType.Brace:
            message = "FamilyInstance is a brace.";
            break;
        case StructuralType.Column:
            message = "FamilyInstance is a column.";
            break;
        case StructuralType.Footing:
            message = "FamilyInstance is a footing.";
            break;
        default:
            message = "FamilyInstance is non-structural or unknown framing.";
            break;
    }

    TaskDialog.Show("Revit",message);
}
Public Sub GetStructuralType(familyInstance As FamilyInstance)
    Dim message As String = ""
    Select Case familyInstance.StructuralType
        Case StructuralType.Beam
            message = "FamilyInstance is a beam."
            Exit Select
        Case StructuralType.Brace
            message = "FamilyInstance is a brace."
            Exit Select
        Case StructuralType.Column
            message = "FamilyInstance is a column."
            Exit Select
        Case StructuralType.Footing
            message = "FamilyInstance is a footing."
            Exit Select
        Case Else
            message = "FamilyInstance is non-structural or unknown framing."
            Exit Select
    End Select

    TaskDialog.Show("Revit", message)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

FamilyInstance Class


FamilyInstance.StructuralUsage Property

FamilyInstanceStructuralUsage Property

Provides the primary structural usage of the instance, such as brace, girder etc.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public StructuralInstanceUsage StructuralUsage { get; set; }
Public Property StructuralUsage As StructuralInstanceUsage
    Get
    Set
public:
property StructuralInstanceUsage StructuralUsage {
    StructuralInstanceUsage get ();
    void set (StructuralInstanceUsage value);
}
member StructuralUsage : StructuralInstanceUsage with get, set

Property Value

StructuralInstanceUsage
See Also

Reference

FamilyInstance Class


FamilyInstance.SuperComponent Property

FamilyInstanceSuperComponent Property

Property to get the super component of current family instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Element SuperComponent { get; }
Public ReadOnly Property SuperComponent As Element
    Get
public:
property Element^ SuperComponent {
    Element^ get ();
}
member SuperComponent : Element with get

Property Value

Element
Remarks
When the FamilyInstance has no super component, it returns
See Also

Reference

FamilyInstance Class


FamilyInstance.Symbol Property

FamilyInstanceSymbol Property

Returns or changes the FamilySymbol object that represents the type of the instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilySymbol Symbol { get; set; }
Public Property Symbol As FamilySymbol
    Get
    Set
public:
property FamilySymbol^ Symbol {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}
member Symbol : FamilySymbol with get, set

Property Value

FamilySymbol
Remarks
Setting this property will result in the type of the instance being changed. Related types can be found by examining the Family to which the symbol belongs.
Example
C#
VB
C++
F#
Copy
public void GetInfo_FamilyInstance_Symbol(FamilyInstance familyInstance)
{
    string message = "FamilyInstance symbol: ";
    if (familyInstance.Symbol != null)
    {
        // Get FamilyInstance structural symbol
        message += "\nFamilyInstance structural symbol name is : " + familyInstance.Symbol.Name;

        // Rename the Symbol used by this FamilyInstance
        familyInstance.Symbol.Name = "TestFamilyInstanceSymbolName";

        // Get FamilyInstance structural symbol
        message += "\nFamilyInstance structural symbol name after set is : " + familyInstance.Symbol.Name;
    }
    TaskDialog.Show("Revit",message);
}
Public Sub GetInfo_FamilyInstance_Symbol(familyInstance As FamilyInstance)
    Dim message As String = "FamilyInstance symbol: "
    If familyInstance.Symbol IsNot Nothing Then
        ' Get FamilyInstance structural symbol
        message += vbLf & "FamilyInstance structural symbol name is : " & Convert.ToString(familyInstance.Symbol.Name)

        ' Rename the Symbol used by this FamilyInstance
        familyInstance.Symbol.Name = "TestFamilyInstanceSymbolName"

        ' Get FamilyInstance structural symbol
        message += vbLf & "FamilyInstance structural symbol name after set is : " & Convert.ToString(familyInstance.Symbol.Name)
    End If
    TaskDialog.Show("Revit", message)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

FamilyInstance Class


FamilyInstance.ToRoom Property

FamilyInstanceToRoom Property

The "To Room" set for the door or window.
Overload List
 | Name | Description
Public property | ToRoom | The "To Room" set for the door or window in the last phase of the project.
Public property | ToRoomPhase |
Top
See Also

Reference

FamilyInstance Class


FamilyInstance.ToRoom Property

FamilyInstanceToRoom Property

The "To Room" set for the door or window in the last phase of the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Room ToRoom { get; }
Public ReadOnly Property ToRoom As Room
    Get
public:
property Room^ ToRoom {
    Room^ get ();
}
member ToRoom : Room with get

Property Value

Room
The "To Room" set for the door or window in the last phase of the project. if the FamilyInstance is neither a door nor a window, or if the door or window leads to a space where there is no room (an exterior space or interior space with no room defined). Also if there is no target room assigned to the last phase, or phase does not apply to this FamilyInstance.
Remarks
Revit automatically calculates the "To Room" for a given door or window. This is the default shown when creating a door or window schedule and adding the "To Room" properties. The user can opt to swap the "From Room" and "To Room" values via the schedule if they choose. The method FlipFromToRoom also can be used to swap the values.
See Also

Reference

FamilyInstance Class
ToRoom Overload


FamilyInstance.ToRoom(Phase) Property

FamilyInstanceToRoom(Phase) Property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Room this[
    Phase phase
] { get; }
Public ReadOnly Property ToRoom (
    phase As Phase
) As Room
    Get
public:
property Room^ ToRoom[Phase^ phase] {
    Room^ get (Phase^ phase);
}
member ToRoom : Room with get

Parameters

phase Phase

Property Value

Room
See Also

Reference

FamilyInstance Class
ToRoom Overload


FamilyInstance Methods

The FamilyInstance type exposes the following members.

Methods
 | Name | Description
Public method | AddCoping | Adds a coping (cut) to a steel beam.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | flipFacing | The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true.
Public method | FlipFromToRoom | Flips the settings of "From Room" and "To Room" for the door or window instance.
Public method | flipHand | The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true.
Public method | GetCopingIds | Lists the elements currently used as coping cutters for this element.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFamilyPointPlacementReferences | Returns the Point Placement References for the Family Instance.
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetOriginalGeometry | Returns the original geometry of the instance, before the instance is modified by joins, cuts, coping, extensions, or other post-processing.
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetReferenceByName | Gets the family instance reference corresponding to the named reference plane in the instance's family.
Public method | GetReferenceName | Gets the name of the reference plane in the family corresponding to the given family instance reference.
Public method | GetReferences | Gets family instance references corresponding to the reference planes or reference lines of the given reference type in the instance's family.
Public method | GetReferenceType | Gets the type of the reference plane or reference line in the instance's family corresponding to the given family instance reference.
Public method | GetSpatialElementCalculationPoint | Gets the location of the calculation point for this instance.
Public method | GetSpatialElementFromToCalculationPoints | Gets the locations for the calculation points for this instance.
 | GetSubComponentIds | Gets the sub component ElementIds of the current family instance.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetSweptProfile | Gets the object that describes the profile that is swept along the driving curve for this instance.
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances. (Inherited from Instance)
Public method | GetTransform | Gets the transform of the instance. (Inherited from Instance)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasModifiedGeometry | Identifies if the geometry of this FamilyInstance has been modified from the automatically generated default.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasSweptProfile | Indicates if this instance can be represented as a swept profile.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveCoping | Removes a coping (cut) from a steel beam.
Public method | rotate | The family instance will be flipped by 180 degrees. If it can not be rotated, return false, otherwise return true.
Public method | SetCopingIds | Specifies the set of coping cutters on this element.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | Split | Splits the family instance element at a point on its defining curve.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FamilyInstance Class


FamilyInstance.AddCoping Method

FamilyInstanceAddCoping Method

Adds a coping (cut) to a steel beam.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AddCoping(
    FamilyInstance cutter
)
Public Function AddCoping (
    cutter As FamilyInstance
) As Boolean
public:
bool AddCoping(
    FamilyInstance^ cutter
)
member AddCoping :
        cutter : FamilyInstance -> bool

Parameters

cutter FamilyInstance
A steel beam or column. May not be or itself.

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentNullException | Thrown when 'cutter' is .
ArgumentException | Thrown when 'cutter' refers to this instance.
InvalidOperationException | Thrown when regeneration fails.
Remarks
This beam will be cut to fit another element, the cutter. The cut will include an offset determined by the parameter STRUCTURAL_COPING_DISTANCE. The parameter affects all copings on this element. This function corresponds to Tools -> Coping in Revit Structure.
See Also

Reference

FamilyInstance Class


FamilyInstance.flipFacing Method

FamilyInstanceflipFacing Method

The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool flipFacing()
Public Function flipFacing As Boolean
public:
bool flipFacing()
member flipFacing : unit -> bool

Return Value

Boolean
See Also

Reference

FamilyInstance Class


FamilyInstance.FlipFromToRoom Method

FamilyInstanceFlipFromToRoom Method

Flips the settings of "From Room" and "To Room" for the door or window instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void FlipFromToRoom()
Public Sub FlipFromToRoom
public:
void FlipFromToRoom()
member FlipFromToRoom : unit -> unit
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the FamilyInstance is neither a door nor a window.
See Also

Reference

FamilyInstance Class


FamilyInstance.flipHand Method

FamilyInstanceflipHand Method

The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool flipHand()
Public Function flipHand As Boolean
public:
bool flipHand()
member flipHand : unit -> bool

Return Value

Boolean
See Also

Reference

FamilyInstance Class


FamilyInstance.GetCopingIds Method

FamilyInstanceGetCopingIds Method

Lists the elements currently used as coping cutters for this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetCopingIds()
Public Function GetCopingIds As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetCopingIds()
member GetCopingIds : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
The coping ElementIds
See Also

Reference

FamilyInstance Class


FamilyInstance.GetFamilyPointPlacementReferences Method

FamilyInstanceGetFamilyPointPlacementReferences Method

Returns the Point Placement References for the Family Instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<FamilyPointPlacementReference> GetFamilyPointPlacementReferences()
Public Function GetFamilyPointPlacementReferences As IList(Of FamilyPointPlacementReference)
public:
IList<FamilyPointPlacementReference^>^ GetFamilyPointPlacementReferences()
member GetFamilyPointPlacementReferences : unit -> IList<FamilyPointPlacementReference>

Return Value

IList FamilyPointPlacementReference
Remarks
If a family instance has point placement references then they are returned by this method, otherwise an empty collection is returned. Examples of FamilyInstance objects that contain placement references are Panels and Flexible Components.
See Also

Reference

FamilyInstance Class


FamilyInstance.GetOriginalGeometry Method

FamilyInstanceGetOriginalGeometry Method

Returns the original geometry of the instance, before the instance is modified by joins, cuts, coping, extensions, or other post-processing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GeometryElement GetOriginalGeometry(
    Options options
)
Public Function GetOriginalGeometry (
    options As Options
) As GeometryElement
public:
GeometryElement^ GetOriginalGeometry(
    Options^ options
)
member GetOriginalGeometry :
        options : Options -> GeometryElement

Parameters

options Options
The options used to obtain the geometry. Note that ComputeReferences may not be set to true.

Return Value

GeometryElement
Exceptions
Exception | Condition
ArgumentException | Thrown when the options are not valid for this operation (ComputeReferences == true)
Remarks

This method returns the original geometry of the instance. The instance's geometry will reflect the values of all instance level parameters (e.g. reference levels for columns) and of the placement conditions (so a beam placed along a 20' long line will be 20' long). It excludes all modifications made to the geometry due to operations like joining, cutting, openings, coping, or extensions.

The geometry will not include the GeometryInstance typically returned when you access the geometry of a FamilyInstance via Element.Geometry. But GeometryInstances may be encountered if there are nested family instances within the family.

The geometry is returned in the coordinates of the FamilySymbol, not the coordinates of the instance. If needed, you can transform the returned GeometryElement using the GetTransformed() method, passing the results from GetTransform(), or some other user-defined transformation.

The geometry returned is from Revit's internal computations and does not represent actual Revit geometry. Thus, you cannot use it as a reference for other geometry.

See Also

Reference

FamilyInstance Class


FamilyInstance.GetReferenceByName Method

FamilyInstanceGetReferenceByName Method

Gets the family instance reference corresponding to the named reference plane in the instance's family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Reference GetReferenceByName(
    string name
)
Public Function GetReferenceByName (
    name As String
) As Reference
public:
Reference^ GetReferenceByName(
    String^ name
)
member GetReferenceByName :
        name : string -> Reference

Parameters

name String
The name of the reference plane in the family.

Return Value

Reference
Returns the family instance reference corresponding to the named reference plane in the instance's family. Returns null if there is no reference plane with this name in the family, or if the plane exists but its "Is Reference" property is "Not a Reference", or if the input string is empty.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
If there is a reference plane in the instance's family that has the given name, and the plane's "Is Reference" property is not "Not a Reference", there will be a corresponding reference in the family's instance. This function returns that reference.
See Also

Reference

FamilyInstance Class


FamilyInstance.GetReferenceName Method

FamilyInstanceGetReferenceName Method

Gets the name of the reference plane in the family corresponding to the given family instance reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetReferenceName(
    Reference reference
)
Public Function GetReferenceName (
    reference As Reference
) As String
public:
String^ GetReferenceName(
    Reference^ reference
)
member GetReferenceName :
        reference : Reference -> string

Parameters

reference Reference
The family instance reference.

Return Value

String
Returns the name of the reference plane in the family corresponding to the given family instance reference. If the reference doesn't correspond to a named reference plane, returns an empty string.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
If the given family reference corresponds to a named reference plane in the instance's family, the name of that reference plane will be returned. Otherwise, an empty string will be returned.
See Also

Reference

FamilyInstance Class


FamilyInstance.GetReferences Method

FamilyInstanceGetReferences Method

Gets family instance references corresponding to the reference planes or reference lines of the given reference type in the instance's family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<Reference> GetReferences(
    FamilyInstanceReferenceType referenceType
)
Public Function GetReferences (
    referenceType As FamilyInstanceReferenceType
) As IList(Of Reference)
public:
IList<Reference^>^ GetReferences(
    FamilyInstanceReferenceType referenceType
)
member GetReferences :
        referenceType : FamilyInstanceReferenceType -> IList<Reference>

Parameters

referenceType FamilyInstanceReferenceType
The family reference type.

Return Value

IList Reference
Returns all the family instance references corresponding to reference planes and reference lines of the given reference type. Returns null if there are no family instance references of the given reference type, or if the input reference type is FamilyInstanceReferenceType.NotAReference.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Remarks
Reference planes from the instance's family that have their "Is Reference" property set to "Not a Reference" do not create references in the family instance.
See Also

Reference

FamilyInstance Class


FamilyInstance.GetReferenceType Method

FamilyInstanceGetReferenceType Method

Gets the type of the reference plane or reference line in the instance's family corresponding to the given family instance reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyInstanceReferenceType GetReferenceType(
    Reference reference
)
Public Function GetReferenceType (
    reference As Reference
) As FamilyInstanceReferenceType
public:
FamilyInstanceReferenceType GetReferenceType(
    Reference^ reference
)
member GetReferenceType :
        reference : Reference -> FamilyInstanceReferenceType

Parameters

reference Reference
The family instance reference.

Return Value

FamilyInstanceReferenceType
Returns the type of the reference plane or reference line in the instance's family corresponding to the given family instance reference. Returns FamilyInstanceReferenceType.NotAReference if the instance reference doesn't correspond to a reference plane or line in the family.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FamilyInstance Class


FamilyInstance.GetSpatialElementCalculationPoint Method

FamilyInstanceGetSpatialElementCalculationPoint Method

Gets the location of the calculation point for this instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ GetSpatialElementCalculationPoint()
Public Function GetSpatialElementCalculationPoint As XYZ
public:
XYZ^ GetSpatialElementCalculationPoint()
member GetSpatialElementCalculationPoint : unit -> XYZ

Return Value

XYZ
A 3d point.
Exceptions
Exception | Condition
InvalidOperationException | Thrown if this instance does not have a single calculation point.
Remarks

See HasSpatialElementCalculationPoint for reference.

See Also

Reference

FamilyInstance Class


FamilyInstance.GetSpatialElementFromToCalculationPoints Method

FamilyInstanceGetSpatialElementFromToCalculationPoints Method

Gets the locations for the calculation points for this instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<XYZ> GetSpatialElementFromToCalculationPoints()
Public Function GetSpatialElementFromToCalculationPoints As IList(Of XYZ)
public:
IList<XYZ^>^ GetSpatialElementFromToCalculationPoints()
member GetSpatialElementFromToCalculationPoints : unit -> IList<XYZ>

Return Value

IList XYZ
A list of 3d points.
Exceptions
Exception | Condition
InvalidOperationException | Thrown if this instance does not have from/to calculation points..
Remarks

For a family instance which connects two rooms or spaces, such as a door or window, the points determine which room or space is considered the "from" and which is considered the "to".

See Also

Reference

FamilyInstance Class


FamilyInstance.GetSubComponentIds Method

FamilyInstanceGetSubComponentIds Method

Gets the sub component ElementIds of the current family instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetSubComponentIds()
Public Function GetSubComponentIds As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetSubComponentIds()
member GetSubComponentIds : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
The subcomponent ElementIDs
Example
C#
VB
C++
F#
Copy
public void GetSubAndSuperComponents(FamilyInstance familyInstance)
{
    ICollection<ElementId> subElemSet = familyInstance.GetSubComponentIds();
    if (subElemSet != null)
    {
        string subElems = "";
        foreach (Autodesk.Revit.DB.ElementId ee in subElemSet)
        {
            FamilyInstance f = familyInstance.Document.GetElement(ee) as FamilyInstance;
            subElems = subElems + f.Name + "\n";
        }
        TaskDialog.Show("Revit","Subcomponent count = " + subElemSet.Count + "\n" + subElems);
    }
    FamilyInstance super = familyInstance.SuperComponent as FamilyInstance;
    if (super != null)
    {
        TaskDialog.Show("Revit","SUPER component: " + super.Name);
    }
}
Public Sub GetSubAndSuperComponents(familyInstance As FamilyInstance)
    Dim subElemSet As ICollection(Of ElementId) = familyInstance.GetSubComponentIds()
    If subElemSet IsNot Nothing Then
        Dim subElems As String = ""
        For Each ee As Autodesk.Revit.DB.ElementId In subElemSet
            Dim f As FamilyInstance = TryCast(familyInstance.Document.GetElement(ee), FamilyInstance)
            subElems = subElems + f.Name & vbLf
        Next
        TaskDialog.Show("Revit", "Subcomponent count = " & subElemSet.Count & vbLf & subElems)
    End If
    Dim super As FamilyInstance = TryCast(familyInstance.SuperComponent, FamilyInstance)
    If super IsNot Nothing Then
        TaskDialog.Show("Revit", "SUPER component: " + super.Name)
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

FamilyInstance Class


FamilyInstance.GetSweptProfile Method

FamilyInstanceGetSweptProfile Method

Gets the object that describes the profile that is swept along the driving curve for this instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SweptProfile GetSweptProfile()
Public Function GetSweptProfile As SweptProfile
public:
SweptProfile^ GetSweptProfile()
member GetSweptProfile : unit -> SweptProfile

Return Value

SweptProfile
A swept profile.
Exceptions
Exception | Condition
InapplicableDataException | Thrown if this instance does not have a swept profile.
See Also

Reference

FamilyInstance Class


FamilyInstance.HasModifiedGeometry Method

FamilyInstanceHasModifiedGeometry Method

Identifies if the geometry of this FamilyInstance has been modified from the automatically generated default.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasModifiedGeometry()
Public Function HasModifiedGeometry As Boolean
public:
bool HasModifiedGeometry()
member HasModifiedGeometry : unit -> bool

Return Value

Boolean
Remarks
This method returns true if the geometry has been modified from post-processing activity in Revit such as joining, cutting, coping, extension, adaptive component modification, or other similar activity.
See Also

Reference

FamilyInstance Class


FamilyInstance.HasSweptProfile Method

FamilyInstanceHasSweptProfile Method

Indicates if this instance can be represented as a swept profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasSweptProfile()
Public Function HasSweptProfile As Boolean
public:
bool HasSweptProfile()
member HasSweptProfile : unit -> bool

Return Value

Boolean
True if the instance can be represented as a swept profile, false otherwise.
See Also

Reference

FamilyInstance Class


FamilyInstance.RemoveCoping Method

FamilyInstanceRemoveCoping Method

Removes a coping (cut) from a steel beam.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool RemoveCoping(
    FamilyInstance cutter
)
Public Function RemoveCoping (
    cutter As FamilyInstance
) As Boolean
public:
bool RemoveCoping(
    FamilyInstance^ cutter
)
member RemoveCoping :
        cutter : FamilyInstance -> bool

Parameters

cutter FamilyInstance
A steel beam or column for which this beam currently has a coping cut. May not be or itself.

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentNullException | Thrown when 'cutter' is .
ArgumentException | Thrown when 'cutter' refers to this instance.
InvalidOperationException | Thrown when regeneration fails.
Remarks
This function corresponds to Tools -> Remove coping in Revit Structure.
See Also

Reference

FamilyInstance Class


FamilyInstance.rotate Method

FamilyInstancerotate Method

The family instance will be flipped by 180 degrees. If it can not be rotated, return false, otherwise return true.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool rotate()
Public Function rotate As Boolean
public:
bool rotate()
member rotate : unit -> bool

Return Value

Boolean
See Also

Reference

FamilyInstance Class


FamilyInstance.SetCopingIds Method

FamilyInstanceSetCopingIds Method

Specifies the set of coping cutters on this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SetCopingIds(
    ICollection<ElementId> cutters
)
Public Function SetCopingIds (
    cutters As ICollection(Of ElementId)
) As Boolean
public:
bool SetCopingIds(
    ICollection<ElementId^>^ cutters
)
member SetCopingIds :
        cutters : ICollection<ElementId> -> bool

Parameters

cutters ICollection ElementId
A set of coping cutters (steel beams and steel columns).

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentException | Thrown when 'cutters' contains this instance.
InvalidOperationException | Thrown when regeneration fails or if a cutter element is not a FamilyInstance.
Remarks
The set may be or empty, but may not contain the element being coped.
See Also

Reference

FamilyInstance Class


FamilyInstance.Split Method

FamilyInstanceSplit Method

Splits the family instance element at a point on its defining curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId Split(
    double param
)
Public Function Split (
    param As Double
) As ElementId
public:
ElementId^ Split(
    double param
)
member Split :
        param : float -> ElementId

Parameters

param Double
The normalized parameter value along the element (should be greater than 0 and less than 1).

Return Value

ElementId
The newly created family instance id.
Exceptions
Exception | Condition
ArgumentException | Thrown when parameter is out of range.
InvalidOperationException | Thrown when the family instance element cannot be split.
Remarks

Splitting is permitted for architectural and structural columns, beams and braces. Beams and braces that are not a line or an arc is not permitted. See CanSplit to determine if the family instance is allowed to be split by this method.

Splitting modifies this family instance and adds a second family instance to the model.

See Also

Reference

FamilyInstance Class


FamilyInstanceFilter Class

A filter used to find elements that are family instances of the given family symbol.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementSlowFilter
Autodesk.Revit.DBFamilyInstanceFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FamilyInstanceFilter : ElementSlowFilter
Public Class FamilyInstanceFilter
    Inherits ElementSlowFilter
public ref class FamilyInstanceFilter : public ElementSlowFilter
type FamilyInstanceFilter =
    class
        inherit ElementSlowFilter
    end

The FamilyInstanceFilter type exposes the following members.

Constructors
 | Name | Description
Public method | FamilyInstanceFilter | Constructs a new instance of a filter to match family instances of the given family symbol.
Top
Properties
 | Name | Description
Public property | FamilySymbolId | The family symbol id.
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This filter is a slow filter, but it uses a quick filter to eliminate non-candidate elements before the elements are obtained and expanded. Therefore this filter does not have to be paired with another quick filter to minimize the number of Elements that are expanded.
Example
C#
VB
C++
F#
Copy
// Creates a FamilyInstance filter for elements that are family instances of the given family symbol in the document

// Find all family symbols whose name is "W10X49"
FilteredElementCollector collector = new FilteredElementCollector(document);
collector = collector.OfClass(typeof(FamilySymbol));

// Get Element Id for family symbol which will be used to find family instances
var query = from element in collector where element.Name == "W10X49" select element;
List<Element> famSyms = query.ToList<Element>();
ElementId symbolId = famSyms[0].Id;

// Create a FamilyInstance filter with the FamilySymbol Id
FamilyInstanceFilter filter = new FamilyInstanceFilter(document, symbolId);

// Apply the filter to the elements in the active document
collector = new FilteredElementCollector(document);
ICollection<Element> familyInstances = collector.WherePasses(filter).ToElements();
' Creates a FamilyInstance filter for elements that are family instances of the given family symbol in the document

' Find all family symbols whose name is "W10X49"
Dim collector As New FilteredElementCollector(document)
collector = collector.OfClass(GetType(FamilySymbol))

' Get Element Id for family symbol which will be used to find family instances
Dim query As System.Collections.Generic.IEnumerable(Of Autodesk.Revit.DB.Element)
query = From element In collector _
 Where element.Name = "Level 1" _
 Select element

Dim famSyms As List(Of Element) = query.ToList()
Dim symbolId As ElementId = famSyms(0).Id

' Create a FamilyInstance filter with the FamilySymbol Id
Dim filter As New FamilyInstanceFilter(document, symbolId)

' Apply the filter to the elements in the active document
collector = New FilteredElementCollector(document)
Dim familyInstances As ICollection(Of Element) = collector.WherePasses(filter).ToElements()

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FamilyInstanceFilter Constructor

Constructs a new instance of a filter to match family instances of the given family symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyInstanceFilter(
    Document document,
    ElementId familySymbolId
)
Public Sub New (
    document As Document,
    familySymbolId As ElementId
)
public:
FamilyInstanceFilter(
    Document^ document,
    ElementId^ familySymbolId
)
new :
        document : Document *
        familySymbolId : ElementId -> FamilyInstanceFilter

Parameters

document Document
The document. This requirement is unique to this filter and is needed to ensure the input family symbol id is valid for the provided document. This ensures the most stability and greatest performance for this filter.
familySymbolId ElementId
The family symbol id.
Exceptions
Exception | Condition
ArgumentException | The familySymbolId does not represent a valid FamilySymbol record in the document.
ArgumentNullException | A non-optional argument was null
See Also

Reference

FamilyInstanceFilter Class


FamilyInstanceFilter Properties

The FamilyInstanceFilter type exposes the following members.

Properties
 | Name | Description
Public property | FamilySymbolId | The family symbol id.
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
See Also

Reference

FamilyInstanceFilter Class


FamilyInstanceFilter.FamilySymbolId Property

FamilyInstanceFilterFamilySymbolId Property

The family symbol id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId FamilySymbolId { get; }
Public ReadOnly Property FamilySymbolId As ElementId
    Get
public:
property ElementId^ FamilySymbolId {
    ElementId^ get ();
}
member FamilySymbolId : ElementId with get

Property Value

ElementId
See Also

Reference

FamilyInstanceFilter Class


FamilyInstanceFilter Methods

The FamilyInstanceFilter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FamilyInstanceFilter Class


FamilyInstanceReferenceType Enumeration

Corresponds to the possible values of parameter "Is Reference" of reference planes and parameter "Reference" of reference lines in families. This enum is used to identify references of family instances corresponding to reference planes and reference lines in the family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum FamilyInstanceReferenceType
Public Enumeration FamilyInstanceReferenceType
public enum class FamilyInstanceReferenceType
type FamilyInstanceReferenceType
Members
Member name | Value | Description
Left | 0 | Reference plane whose "Is Reference" parameter is set to "Left". There may be no more than one such reference plane in the family. This reference is stable: if there is a dimension to this reference of an instance, and the instance's type or family is replaced, the dimension will survive.
CenterLeftRight | 1 | Reference plane whose "Is Reference" parameter is set to "Center (Left/Right)". There may be no more than one such reference plane in the family. This reference is stable: if there is a dimension to this reference of an instance, and the instance's type or family is replaced, the dimension will survive.
Right | 2 | Reference plane whose "Is Reference" parameter is set to "Right". There may be no more than one such reference plane in the family. This reference is stable: if there is a dimension to this reference of an instance, and the instance's type or family is replaced, the dimension will survive.
Front | 3 | Reference plane whose "Is Reference" parameter is set to "Front". There may be no more than one such reference plane in the family. This reference is stable: if there is a dimension to this reference of an instance, and the instance's type or family is replaced, the dimension will survive.
CenterFrontBack | 4 | Reference plane whose "Is Reference" parameter is set to "Center (Front/Back)". There may be no more than one such reference plane in the family. This reference is stable: if there is a dimension to this reference of an instance, and the instance's type or family is replaced, the dimension will survive.
Back | 5 | Reference plane whose "Is Reference" parameter is set to "Back". There may be no more than one such reference plane in the family. This reference is stable: if there is a dimension to this reference of an instance, and the instance's type or family is replaced, the dimension will survive.
Bottom | 6 | Reference plane whose "Is Reference" parameter is set to "Bottom". There may be no more than one such reference plane in the family. This reference is stable: if there is a dimension to this reference of an instance, and the instance's type or family is replaced, the dimension will survive.
CenterElevation | 7 | Reference plane whose "Is Reference" parameter is set to "Center (Elevation)". There may be no more than one such reference plane in the family. This reference is stable: if there is a dimension to this reference of an instance, and the instance's type or family is replaced, the dimension will survive.
Top | 8 | Reference plane whose "Is Reference" parameter is set to "Top". There may be no more than one such reference plane in the family. This reference is stable: if there is a dimension to this reference of an instance, and the instance's type or family is replaced, the dimension will survive.
StrongReference | 9 | Reference plane whose "Is Reference" parameter is set to "Strong Reference", or reference line whose "Reference" parameter is set to "Strong Reference". There may be multiple such reference planes and lines in the family. These references are not stable: if there is a dimension to such reference, and the instance's family is replaced, the dimension is not guaranteed to survive.
WeakReference | 10 | Reference plane whose "Is Reference" parameter is set to "Weak Reference", or reference line whose "Reference" parameter is set to "Weak Reference". There may be multiple such reference planes and lines in the family. These references are not stable: if there is a dimension to such reference, and the instance's family is replaced, the dimension is not guaranteed to survive.
NotAReference | 11 | This value is returned from FamilyInstance::getReferenceType if the reference does not correspond to any reference plane or reference line in the family.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FamilyManager Class

The family manager object to manage the family types and parameters in family document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBFamilyManager

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FamilyManager : APIObject
Public Class FamilyManager
    Inherits APIObject
public ref class FamilyManager : public APIObject
type FamilyManager =
    class
        inherit APIObject
    end

The FamilyManager type exposes the following members.

Properties
 | Name | Description
Public property | CurrentType | The current family type.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | ParameterBuiltInParameter | Obtains the parameter of this type with a given parameter id.
Public property | ParameterDefinition | Obtains the parameter of this type with a given definition.
Public property | ParameterGuid | Obtains the parameter of this type with a given GUID for a shared parameter.
Public property | ParameterString | Obtains the parameter of this type with a given name.
Public property | Parameters | All family parameters in this family.
 | Types | All family types in the family.
Top
Methods
 | Name | Description
Public method | AddParameter(ExternalDefinition, ForgeTypeId, Boolean) | Add a new shared parameter to the family.
Public method | AddParameter(String, ForgeTypeId, Category, Boolean) | Add a new family type parameter to control the type of a nested family within another family.
Public method | AddParameter(String, ForgeTypeId, ForgeTypeId, Boolean) | Add a new family parameter with a given name.
Public method | AssociateElementParameterToFamilyParameter | Associates or disassociates the element parameter to an existing family parameter.
Public method | CanElementParameterBeAssociated | Indicates if this element parameter can be associated with a family parameter.
Public method | DeleteCurrentType | Remove the current family type.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAssociatedFamilyParameter | Gets the associated family parameter of an element parameter.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetParameter | Obtains the family parameter with the given built-in parameter identifier.
Public method | GetParameters | Gets the parameters associated to family types in order.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsParameterLockable | For Conceptual Mass and Curtain Panel families, indicate whether the specified parameter can be locked.
Public method | IsParameterLocked | For Conceptual Mass and Curtain Panel families, indicate whether the specified dimension-driving parameter is locked.
Public method | IsUserAssignableParameterGroup | Checks if the given parameter group can be assigned to new parameters.
Public method | MakeInstance | Set the family parameter as an instance parameter.
Public method | MakeNonReporting | Set the reporting family parameter as a regular/driving parameter.
Public method | MakeReporting | Set the family parameter as a reporting parameter.
Public method | MakeType | Set the family parameter as a type parameter.
 | NewType | Add a new family type with a given name and makes it be the current type.
Public method | RemoveParameter | Remove an existing family parameter from the family.
Public method | RenameCurrentType | Rename the current family type.
Public method | RenameParameter | Rename a family parameter.
Public method | ReorderParameters | Reorders the family parameters by the specified parameters order.
Public method | ReplaceParameter(FamilyParameter, ExternalDefinition, ForgeTypeId, Boolean) | Replace a family parameter with a shared parameter.
Public method | ReplaceParameter(FamilyParameter, String, ForgeTypeId, Boolean) | Replace a shared family parameter with a new non-shared family parameter.
Public method | Set(FamilyParameter, ElementId) | Set the ElementId value of a family parameter of the current family type.
Public method | Set(FamilyParameter, Double) | Set the double value of a family parameter of the current family type.
Public method | Set(FamilyParameter, Int32) | Set the integer value of a family parameter of the current family type.
Public method | Set(FamilyParameter, String) | Set the string value of a family parameter of the current family type.
Public method | SetDescription | Set the description for an existing family parameter. The description will be used as tooltip in the Revit UI including in the properties palette.
Public method | SetFormula | Set the formula of a family parameter.
Public method | SetParameterLocked | For Conceptual Mass and Curtain Panel families, lock or unlock a dimension-driving parameter.
Public method | SetValueString | Set the string value of a family parameter of the current family type.
 | SortParameters | Sorts the family parameters according to the desired sort order.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FamilyManager Properties

The FamilyManager type exposes the following members.

Properties
 | Name | Description
Public property | CurrentType | The current family type.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | ParameterBuiltInParameter | Obtains the parameter of this type with a given parameter id.
Public property | ParameterDefinition | Obtains the parameter of this type with a given definition.
Public property | ParameterGuid | Obtains the parameter of this type with a given GUID for a shared parameter.
Public property | ParameterString | Obtains the parameter of this type with a given name.
Public property | Parameters | All family parameters in this family.
 | Types | All family types in the family.
Top
See Also

Reference

FamilyManager Class


FamilyManager.CurrentType Property

FamilyManagerCurrentType Property

The current family type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyType CurrentType { get; set; }
Public Property CurrentType As FamilyType
    Get
    Set
public:
property FamilyType^ CurrentType {
    FamilyType^ get ();
    void set (FamilyType^ value);
}
member CurrentType : FamilyType with get, set

Property Value

FamilyType
Remarks
Only the current family type is editable using the methods in FamilyManager. If you want to modify the properties of any family type, it must be set to be the current type first. This value will be if there is no type in the family. In order to modify parameter values, you will need to create one using NewType(String).
See Also

Reference

FamilyManager Class


FamilyManager.Parameter Property

FamilyManagerParameter Property

Obtains a parameter based on an identifier.
Overload List
 | Name | Description
Public property | ParameterBuiltInParameter | Obtains the parameter of this type with a given parameter id.
Public property | ParameterDefinition | Obtains the parameter of this type with a given definition.
Public property | ParameterGuid | Obtains the parameter of this type with a given GUID for a shared parameter.
Public property | ParameterString | Obtains the parameter of this type with a given name.
Top
See Also

Reference

FamilyManager Class


FamilyManager.Parameter(BuiltInParameter) Property

FamilyManagerParameter(BuiltInParameter) Property

Obtains the parameter of this type with a given parameter id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyParameter this[
    BuiltInParameter parameterId
] { get; }
Public ReadOnly Property Parameter (
    parameterId As BuiltInParameter
) As FamilyParameter
    Get
public:
property FamilyParameter^ Parameter[BuiltInParameter parameterId] {
    FamilyParameter^ get (BuiltInParameter parameterId);
}
member Parameter : FamilyParameter with get

Parameters

parameterId BuiltInParameter

Property Value

FamilyParameter
Remarks
Returns if the parameter is not found.
See Also

Reference

FamilyManager Class
Parameter Overload


FamilyManager.Parameter(Definition) Property

FamilyManagerParameter(Definition) Property

Obtains the parameter of this type with a given definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyParameter this[
    Definition definition
] { get; }
Public ReadOnly Property Parameter (
    definition As Definition
) As FamilyParameter
    Get
public:
property FamilyParameter^ Parameter[Definition^ definition] {
    FamilyParameter^ get (Definition^ definition);
}
member Parameter : FamilyParameter with get

Parameters

definition Definition

Property Value

FamilyParameter
Remarks
Returns if the parameter is not found.
See Also

Reference

FamilyManager Class
Parameter Overload


FamilyManager.Parameter(Guid) Property

FamilyManagerParameter(Guid) Property

Obtains the parameter of this type with a given GUID for a shared parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyParameter this[
    Guid guid
] { get; }
Public ReadOnly Property Parameter (
    guid As Guid
) As FamilyParameter
    Get
public:
property FamilyParameter^ Parameter[Guid guid] {
    FamilyParameter^ get (Guid guid);
}
member Parameter : FamilyParameter with get

Parameters

guid Guid

Property Value

FamilyParameter
Remarks
Returns if the parameter is not found. This method is used to retrieve a family parameter for a known shared parameter. When a shared parameter is created it is assigned a Guid which will not change. This guid can be used to retrieve the piece of data from the element at a later time.
See Also

Reference

FamilyManager Class
Parameter Overload


FamilyManager.Parameter(String) Property

FamilyManagerParameter(String) Property

Obtains the parameter of this type with a given name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyParameter this[
    string parameterName
] { get; }
Public ReadOnly Property Parameter (
    parameterName As String
) As FamilyParameter
    Get
public:
property FamilyParameter^ Parameter[String^ parameterName] {
    FamilyParameter^ get (String^ parameterName);
}
member Parameter : FamilyParameter with get

Parameters

parameterName String

Property Value

FamilyParameter
Remarks
Returns if the parameter is not found.
See Also

Reference

FamilyManager Class
Parameter Overload


FamilyManager.Parameters Property

FamilyManagerParameters Property

All family parameters in this family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyParameterSet Parameters { get; }
Public ReadOnly Property Parameters As FamilyParameterSet
    Get
public:
property FamilyParameterSet^ Parameters {
    FamilyParameterSet^ get ();
}
member Parameters : FamilyParameterSet with get

Property Value

FamilyParameterSet
Remarks
These parameters will include the 'family parameter', 'shared parameter' and 'builtIn parameter' binding to the family types. Some parameters might be created as placeholders without a currently assigned value.
See Also

Reference

FamilyManager Class


FamilyManager.Types Property

FamilyManagerTypes Property

All family types in the family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyTypeSet Types { get; }
Public ReadOnly Property Types As FamilyTypeSet
    Get
public:
property FamilyTypeSet^ Types {
    FamilyTypeSet^ get ();
}
member Types : FamilyTypeSet with get

Property Value

FamilyTypeSet
Example
C#
VB
C++
F#
Copy
public void GetFamilyTypesInFamily(Document familyDoc)
{
    if (familyDoc.IsFamilyDocument)
    {
        FamilyManager familyManager = familyDoc.FamilyManager;

        // get types in family
        string types = "Family Types: ";
        FamilyTypeSet familyTypes = familyManager.Types;
        FamilyTypeSetIterator familyTypesItor = familyTypes.ForwardIterator();
        familyTypesItor.Reset();
        while (familyTypesItor.MoveNext())
        {
            FamilyType familyType = familyTypesItor.Current as FamilyType;
            types += "\n" + familyType.Name;
        }
        TaskDialog.Show("Revit",types);
    }
}
Public Sub GetFamilyTypesInFamily(familyDoc As Document)
    If familyDoc.IsFamilyDocument Then
        Dim familyManager As FamilyManager = familyDoc.FamilyManager

        ' get types in family
        Dim types As String = "Family Types: "
        Dim familyTypes As FamilyTypeSet = familyManager.Types
        Dim familyTypesItor As FamilyTypeSetIterator = familyTypes.ForwardIterator()
        familyTypesItor.Reset()
        While familyTypesItor.MoveNext()
            Dim familyType As FamilyType = TryCast(familyTypesItor.Current, FamilyType)
            types += vbLf + familyType.Name
        End While
        TaskDialog.Show("Revit", types)
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

FamilyManager Class


FamilyManager Methods

The FamilyManager type exposes the following members.

Methods
 | Name | Description
Public method | AddParameter(ExternalDefinition, ForgeTypeId, Boolean) | Add a new shared parameter to the family.
Public method | AddParameter(String, ForgeTypeId, Category, Boolean) | Add a new family type parameter to control the type of a nested family within another family.
Public method | AddParameter(String, ForgeTypeId, ForgeTypeId, Boolean) | Add a new family parameter with a given name.
Public method | AssociateElementParameterToFamilyParameter | Associates or disassociates the element parameter to an existing family parameter.
Public method | CanElementParameterBeAssociated | Indicates if this element parameter can be associated with a family parameter.
Public method | DeleteCurrentType | Remove the current family type.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAssociatedFamilyParameter | Gets the associated family parameter of an element parameter.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetParameter | Obtains the family parameter with the given built-in parameter identifier.
Public method | GetParameters | Gets the parameters associated to family types in order.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsParameterLockable | For Conceptual Mass and Curtain Panel families, indicate whether the specified parameter can be locked.
Public method | IsParameterLocked | For Conceptual Mass and Curtain Panel families, indicate whether the specified dimension-driving parameter is locked.
Public method | IsUserAssignableParameterGroup | Checks if the given parameter group can be assigned to new parameters.
Public method | MakeInstance | Set the family parameter as an instance parameter.
Public method | MakeNonReporting | Set the reporting family parameter as a regular/driving parameter.
Public method | MakeReporting | Set the family parameter as a reporting parameter.
Public method | MakeType | Set the family parameter as a type parameter.
 | NewType | Add a new family type with a given name and makes it be the current type.
Public method | RemoveParameter | Remove an existing family parameter from the family.
Public method | RenameCurrentType | Rename the current family type.
Public method | RenameParameter | Rename a family parameter.
Public method | ReorderParameters | Reorders the family parameters by the specified parameters order.
Public method | ReplaceParameter(FamilyParameter, ExternalDefinition, ForgeTypeId, Boolean) | Replace a family parameter with a shared parameter.
Public method | ReplaceParameter(FamilyParameter, String, ForgeTypeId, Boolean) | Replace a shared family parameter with a new non-shared family parameter.
Public method | Set(FamilyParameter, ElementId) | Set the ElementId value of a family parameter of the current family type.
Public method | Set(FamilyParameter, Double) | Set the double value of a family parameter of the current family type.
Public method | Set(FamilyParameter, Int32) | Set the integer value of a family parameter of the current family type.
Public method | Set(FamilyParameter, String) | Set the string value of a family parameter of the current family type.
Public method | SetDescription | Set the description for an existing family parameter. The description will be used as tooltip in the Revit UI including in the properties palette.
Public method | SetFormula | Set the formula of a family parameter.
Public method | SetParameterLocked | For Conceptual Mass and Curtain Panel families, lock or unlock a dimension-driving parameter.
Public method | SetValueString | Set the string value of a family parameter of the current family type.
 | SortParameters | Sorts the family parameters according to the desired sort order.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FamilyManager Class


FamilyManager.AddParameter Method

FamilyManagerAddParameter Method

Add a new parameter to the family.
Overload List
 | Name | Description
Public method | AddParameter(ExternalDefinition, ForgeTypeId, Boolean) | Add a new shared parameter to the family.
Public method | AddParameter(String, ForgeTypeId, Category, Boolean) | Add a new family type parameter to control the type of a nested family within another family.
Public method | AddParameter(String, ForgeTypeId, ForgeTypeId, Boolean) | Add a new family parameter with a given name.
Top
See Also

Reference

FamilyManager Class


FamilyManager.AddParameter(ExternalDefinition, ForgeTypeId, Boolean) Method

FamilyManagerAddParameter(ExternalDefinition, ForgeTypeId, Boolean) Method

Add a new shared parameter to the family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyParameter AddParameter(
    ExternalDefinition familyDefinition,
    ForgeTypeId groupTypeId,
    bool isInstance
)
Public Function AddParameter (
    familyDefinition As ExternalDefinition,
    groupTypeId As ForgeTypeId,
    isInstance As Boolean
) As FamilyParameter
public:
FamilyParameter^ AddParameter(
    ExternalDefinition^ familyDefinition,
    ForgeTypeId^ groupTypeId,
    bool isInstance
)
member AddParameter :
        familyDefinition : ExternalDefinition *
        groupTypeId : ForgeTypeId *
        isInstance : bool -> FamilyParameter

Parameters

familyDefinition ExternalDefinition
The definition of the loaded shared parameter.
groupTypeId ForgeTypeId
The identifier of the parameter group to which the family parameter belongs.
isInstance Boolean
Indicates if the new parameter is instance or type.

Return Value

FamilyParameter
If creation was successful the new shared parameter is returned, otherwise an exception with failure information will be thrown.
Exceptions
Exception | Condition
ArgumentException | Thrown when the input parameter group cannot be assigned to the new parameter.
InvalidOperationException | Thrown when the shared family parameter creation is not supported. Or trying to add an instance parameter of image type.
Remarks
This method can work even without any family type, but it cannot be assigned the value via FamilyManager.Set methods when there is no current type.
See Also

Reference

FamilyManager Class
AddParameter Overload


FamilyManager.AddParameter(String, ForgeTypeId, Category, Boolean) Method

FamilyManagerAddParameter(String, ForgeTypeId, Category, Boolean) Method

Add a new family type parameter to control the type of a nested family within another family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyParameter AddParameter(
    string parameterName,
    ForgeTypeId groupTypeId,
    Category familyCategory,
    bool isInstance
)
Public Function AddParameter (
    parameterName As String,
    groupTypeId As ForgeTypeId,
    familyCategory As Category,
    isInstance As Boolean
) As FamilyParameter
public:
FamilyParameter^ AddParameter(
    String^ parameterName,
    ForgeTypeId^ groupTypeId,
    Category^ familyCategory,
    bool isInstance
)
member AddParameter :
        parameterName : string *
        groupTypeId : ForgeTypeId *
        familyCategory : Category *
        isInstance : bool -> FamilyParameter

Parameters

parameterName String
The name of the new family parameter.
groupTypeId ForgeTypeId
The identifier of the group to which the family parameter belongs.
familyCategory Category
The category to which the new family parameter binds.
isInstance Boolean
Indicates if the new family parameter is instance or type.

Return Value

FamilyParameter
If creation was successful the new parameter is returned, otherwise an exception with failure information will be thrown.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument-"parameterName"-is .
ArgumentException | Thrown when the input argument-"parameterName"-is already in use, or the input parameter group cannot be assigned to the new parameter, or the input argument-"familyCategory"-is illegal to bind with parameter.
InvalidOperationException | Thrown when the required family of familyCategory is not existing in current document, , or when the creation failed. Or trying to add an instance parameter of image type.
Remarks
This method can work even without any family type, but it cannot be assigned the value via FamilyManager.Set methods when there is no current type.
See Also

Reference

FamilyManager Class
AddParameter Overload


FamilyManager.AddParameter(String, ForgeTypeId, ForgeTypeId, Boolean) Method

FamilyManagerAddParameter(String, ForgeTypeId, ForgeTypeId, Boolean) Method

Add a new family parameter with a given name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyParameter AddParameter(
    string parameterName,
    ForgeTypeId groupTypeId,
    ForgeTypeId specTypeId,
    bool isInstance
)
Public Function AddParameter (
    parameterName As String,
    groupTypeId As ForgeTypeId,
    specTypeId As ForgeTypeId,
    isInstance As Boolean
) As FamilyParameter
public:
FamilyParameter^ AddParameter(
    String^ parameterName,
    ForgeTypeId^ groupTypeId,
    ForgeTypeId^ specTypeId,
    bool isInstance
)
member AddParameter :
        parameterName : string *
        groupTypeId : ForgeTypeId *
        specTypeId : ForgeTypeId *
        isInstance : bool -> FamilyParameter

Parameters

parameterName String
The name of the new family parameter.
groupTypeId ForgeTypeId
The identifier of the new family parameter's parameter group.
specTypeId ForgeTypeId
The type of new family parameter.
isInstance Boolean
Indicates if the new family parameter is instance or type.

Return Value

FamilyParameter
If creation was successful the new parameter is returned, otherwise an exception with failure information will be thrown.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument-"parameterName"-is .
ArgumentException | Thrown when the input argument-"parameterName"-is already in use, or when the input argument -"specTypeId" is an invalid type, or the input parameter group cannot be assigned to the new parameter.
InvalidOperationException | Thrown when the family parameter creation failed. Or trying to add an instance parameter of image type.
Remarks
This method can work even without any family type, but it cannot be assigned the value via FamilyManager.Set methods when there is no current type. To add a parameter of family type use the AddParameter overload that accepts a category instead.
See Also

Reference

FamilyManager Class
AddParameter Overload


FamilyManager.AssociateElementParameterToFamilyParameter Method

FamilyManagerAssociateElementParameterToFamilyParameter Method

Associates or disassociates the element parameter to an existing family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AssociateElementParameterToFamilyParameter(
    Parameter elementParameter,
    FamilyParameter familyParameter
)
Public Sub AssociateElementParameterToFamilyParameter (
    elementParameter As Parameter,
    familyParameter As FamilyParameter
)
public:
void AssociateElementParameterToFamilyParameter(
    Parameter^ elementParameter,
    FamilyParameter^ familyParameter
)
member AssociateElementParameterToFamilyParameter :
        elementParameter : Parameter *
        familyParameter : FamilyParameter -> unit

Parameters

elementParameter Parameter
The parameter of an element in family.
familyParameter FamilyParameter
The existing family parameter. If the input to this argument is , it will disassociate the element parameter from any family parameters.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument-"elementParameter"-is .
ArgumentException | Thrown when the input argument-"elementParameter" or "familyParameter"-is an invalid parameter, or the input argument-"elementParameter"-cannot be associated.
InvalidOperationException | Thrown when the family parameter binding failed.
Remarks
The parameter types of these two input parameter should be same, if not an exception with failure information will be thrown.
See Also

Reference

FamilyManager Class


FamilyManager.CanElementParameterBeAssociated Method

FamilyManagerCanElementParameterBeAssociated Method

Indicates if this element parameter can be associated with a family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanElementParameterBeAssociated(
    Parameter elementParameter
)
Public Function CanElementParameterBeAssociated (
    elementParameter As Parameter
) As Boolean
public:
bool CanElementParameterBeAssociated(
    Parameter^ elementParameter
)
member CanElementParameterBeAssociated :
        elementParameter : Parameter -> bool

Parameters

elementParameter Parameter

Return Value

Boolean
See Also

Reference

FamilyManager Class


FamilyManager.DeleteCurrentType Method

FamilyManagerDeleteCurrentType Method

Remove the current family type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void DeleteCurrentType()
Public Sub DeleteCurrentType
public:
void DeleteCurrentType()
member DeleteCurrentType : unit -> unit
Exceptions
Exception | Condition
InvalidOperationException | Thrown when there is only one family type in current document.
Remarks
If successfully removed, the first available type will become the current type, otherwise an exception with failure information will be thrown.
See Also

Reference

FamilyManager Class


FamilyManager.GetAssociatedFamilyParameter Method

FamilyManagerGetAssociatedFamilyParameter Method

Gets the associated family parameter of an element parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyParameter GetAssociatedFamilyParameter(
    Parameter elementParameter
)
Public Function GetAssociatedFamilyParameter (
    elementParameter As Parameter
) As FamilyParameter
public:
FamilyParameter^ GetAssociatedFamilyParameter(
    Parameter^ elementParameter
)
member GetAssociatedFamilyParameter :
        elementParameter : Parameter -> FamilyParameter

Parameters

elementParameter Parameter
The parameter of an element in family.

Return Value

FamilyParameter
The associated family parameter if there is an association between them, returns if not.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument-"elementParameter"-is .
See Also

Reference

FamilyManager Class


FamilyManager.GetParameter Method

FamilyManagerGetParameter Method

Obtains the family parameter with the given built-in parameter identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyParameter GetParameter(
    ForgeTypeId parameterTypeId
)
Public Function GetParameter (
    parameterTypeId As ForgeTypeId
) As FamilyParameter
public:
FamilyParameter^ GetParameter(
    ForgeTypeId^ parameterTypeId
)
member GetParameter :
        parameterTypeId : ForgeTypeId -> FamilyParameter

Parameters

parameterTypeId ForgeTypeId
Identifier of the built-in parameter.

Return Value

FamilyParameter
Exceptions
Exception | Condition
ArgumentException | parameterTypeId does not identify a built-in parameter. See Parameter.IsBuiltInParameter(ForgeTypeId) and Parameter.GetParameterTypeId(BuiltInParameter).
ArgumentNullException | A non-optional argument was NULL
Remarks
Returns if the parameter is not found.
See Also

Reference

FamilyManager Class


FamilyManager.GetParameters Method

FamilyManagerGetParameters Method

Gets the parameters associated to family types in order.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<FamilyParameter> GetParameters()
Public Function GetParameters As IList(Of FamilyParameter)
public:
IList<FamilyParameter^>^ GetParameters()
member GetParameters : unit -> IList<FamilyParameter>

Return Value

IList FamilyParameter
A collection containing all family parameters.
Remarks

The parameters are family built-in parameters, category built-in parameters and shared parameters associated to the family types.

The collection consists of both visible and invisible parameters associated to the family types.

The parameters are returned in the order in which they appear in the Revit UI within a given group; however, parameters of different groups may be mixed within this output.

Currently the Revit UI order is determined first by group and next by the order of the individual parameters.

See Also

Reference

FamilyManager Class


FamilyManager.IsParameterLockable Method

FamilyManagerIsParameterLockable Method

For Conceptual Mass and Curtain Panel families, indicate whether the specified parameter can be locked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsParameterLockable(
    FamilyParameter familyParameter
)
Public Function IsParameterLockable (
    familyParameter As FamilyParameter
) As Boolean
public:
bool IsParameterLockable(
    FamilyParameter^ familyParameter
)
member IsParameterLockable :
        familyParameter : FamilyParameter -> bool

Parameters

familyParameter FamilyParameter

Return Value

Boolean
True if the family is a Conceptual Mass or Curtain Panel Family and the parameter drives one or more dimensions; false otherwise.
See Also

Reference

FamilyManager Class


FamilyManager.IsParameterLocked Method

FamilyManagerIsParameterLocked Method

For Conceptual Mass and Curtain Panel families, indicate whether the specified dimension-driving parameter is locked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsParameterLocked(
    FamilyParameter familyParameter
)
Public Function IsParameterLocked (
    familyParameter As FamilyParameter
) As Boolean
public:
bool IsParameterLocked(
    FamilyParameter^ familyParameter
)
member IsParameterLocked :
        familyParameter : FamilyParameter -> bool

Parameters

familyParameter FamilyParameter

Return Value

Boolean
True if the parameter is lockable and is locked; false otherwise.
Exceptions
Exception | Condition
InvalidOperationException | Thrown if this family is not a Conceptual Mass or Curtain Panel family.
See Also

Reference

FamilyManager Class


FamilyManager.IsUserAssignableParameterGroup Method

FamilyManagerIsUserAssignableParameterGroup Method

Checks if the given parameter group can be assigned to new parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsUserAssignableParameterGroup(
    ForgeTypeId groupTypeId
)
Public Function IsUserAssignableParameterGroup (
    groupTypeId As ForgeTypeId
) As Boolean
public:
bool IsUserAssignableParameterGroup(
    ForgeTypeId^ groupTypeId
)
member IsUserAssignableParameterGroup :
        groupTypeId : ForgeTypeId -> bool

Parameters

groupTypeId ForgeTypeId

Return Value

Boolean
True if the parameter group can be assigned to new parameters, false otherwise.
See Also

Reference

FamilyManager Class


FamilyManager.MakeInstance Method

FamilyManagerMakeInstance Method

Set the family parameter as an instance parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void MakeInstance(
    FamilyParameter familyParameter
)
Public Sub MakeInstance (
    familyParameter As FamilyParameter
)
public:
void MakeInstance(
    FamilyParameter^ familyParameter
)
member MakeInstance :
        familyParameter : FamilyParameter -> unit

Parameters

familyParameter FamilyParameter
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument-"familyParameter"-is .
ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid parameter or a builtIn parameter.
InvalidOperationException | Thrown when there is Type family parameter driven by this parameter. Or trying to make a parameter of image type to instance.
See Also

Reference

FamilyManager Class


FamilyManager.MakeNonReporting Method

FamilyManagerMakeNonReporting Method

Set the reporting family parameter as a regular/driving parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void MakeNonReporting(
    FamilyParameter familyParameter
)
Public Sub MakeNonReporting (
    familyParameter As FamilyParameter
)
public:
void MakeNonReporting(
    FamilyParameter^ familyParameter
)
member MakeNonReporting :
        familyParameter : FamilyParameter -> unit

Parameters

familyParameter FamilyParameter
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument-"familyParameter"-is .
InvalidOperationException | Thrown when attempting to make a parameter which is labeled to an arc length dimension non-reporting.
See Also

Reference

FamilyManager Class


FamilyManager.MakeReporting Method

FamilyManagerMakeReporting Method

Set the family parameter as a reporting parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void MakeReporting(
    FamilyParameter familyParameter
)
Public Sub MakeReporting (
    familyParameter As FamilyParameter
)
public:
void MakeReporting(
    FamilyParameter^ familyParameter
)
member MakeReporting :
        familyParameter : FamilyParameter -> unit

Parameters

familyParameter FamilyParameter
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument-"familyParameter"-is .
InvalidOperationException | Thrown when the parameter can not be changed to a reporting parameter.
See Also

Reference

FamilyManager Class


FamilyManager.MakeType Method

FamilyManagerMakeType Method

Set the family parameter as a type parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void MakeType(
    FamilyParameter familyParameter
)
Public Sub MakeType (
    familyParameter As FamilyParameter
)
public:
void MakeType(
    FamilyParameter^ familyParameter
)
member MakeType :
        familyParameter : FamilyParameter -> unit

Parameters

familyParameter FamilyParameter
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument-"familyParameter"-is .
ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid parameter or a builtIn parameter.
See Also

Reference

FamilyManager Class


FamilyManager.NewType Method

FamilyManagerNewType Method

Add a new family type with a given name and makes it be the current type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyType NewType(
    string typeName
)
Public Function NewType (
    typeName As String
) As FamilyType
public:
FamilyType^ NewType(
    String^ typeName
)
member NewType :
        typeName : string -> FamilyType

Parameters

typeName String
The name of new family type.

Return Value

FamilyType
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument-"typeName"-is .
ArgumentException | Thrown when the input argument-"typeName"-is already in use.
InvalidOperationException | Thrown when the family type creation failed.
Example
C#
VB
C++
F#
Copy
public void EditFamilyTypes(Document document, FamilyInstance familyInstance)
{
    // example works best when familyInstance is a rectangular concrete element

    if ((null == document) || (null == familyInstance.Symbol))
    {
        return;   // invalid arguments
    }

    // Get family associated with this
    Family family = familyInstance.Symbol.Family;
    if (null == family)
    {
        return;    // could not get the family
    }

    // Get Family document for family
    Document familyDoc = document.EditFamily(family);
    if (null == familyDoc)
    {
        return;    // could not open a family for edit
    }

    FamilyManager familyManager = familyDoc.FamilyManager;
    if (null == familyManager)
    {
        return;  // cuould not get a family manager
    }

    // Start transaction for the family document
    using (Transaction newFamilyTypeTransaction = new Transaction(familyDoc, "Add Type to Family"))
    {
        int changesMade = 0;
        newFamilyTypeTransaction.Start();

        // add a new type and edit its parameters
        FamilyType newFamilyType = familyManager.NewType("2X2");

        if (newFamilyType != null)
        {
            // look for 'b' and 'h' parameters and set them to 2 feet
            FamilyParameter familyParam = familyManager.get_Parameter("b");
            if (null != familyParam)
            {
                familyManager.Set(familyParam, 2.0);
                changesMade += 1;
            }

            familyParam = familyManager.get_Parameter("h");
            if (null != familyParam)
            {
                familyManager.Set(familyParam, 2.0);
                changesMade += 1;
            }
        }

        if (2 == changesMade)   // set both paramaters?
        {
            newFamilyTypeTransaction.Commit();
        }
        else   // could not make the change -> should roll back
        {
            newFamilyTypeTransaction.RollBack();
        }

        // if could not make the change or could not commit it, we return
        if (newFamilyTypeTransaction.GetStatus() != TransactionStatus.Committed)
        {
            return;
        }
    }

    // now update the Revit project with Family which has a new type
    LoadOpts loadOptions = new LoadOpts();

    // This overload is necessary for reloading an edited family
    // back into the source document from which it was extracted
    family = familyDoc.LoadFamily(document, loadOptions);
    if (null != family)
    {
        // find the new type and assign it to FamilyInstance
        ISet<ElementId> familySymbolIds = family.GetFamilySymbolIds();
        foreach (ElementId id in familySymbolIds)
        {
            FamilySymbol familySymbol = family.Document.GetElement(id) as FamilySymbol;
            if ((null != familySymbol) && familySymbol.Name == "2X2")
            {
                using (Transaction changeSymbol = new Transaction(document, "Change Symbol Assignment"))
                {
                    changeSymbol.Start();
                    familyInstance.Symbol = familySymbol;
                    changeSymbol.Commit();
                }
                break;
            }
        }
    }
}

class LoadOpts : IFamilyLoadOptions
{
    public bool OnFamilyFound(bool familyInUse, out bool overwriteParameterValues)
    {
        overwriteParameterValues = true;
        return true;
    }

    public bool OnSharedFamilyFound(Family sharedFamily, bool familyInUse, out FamilySource source, out bool overwriteParameterValues)
    {
        source = FamilySource.Family;
        overwriteParameterValues = true;
        return true;
    }
}
Public Sub EditFamilyTypes(document As Document, familyInstance As FamilyInstance)
    ' example works best when familyInstance is a rectangular concrete element

    If (document Is Nothing) OrElse (familyInstance.Symbol Is Nothing) Then
        ' invalid arguments
        Return
    End If

    ' Get family associated with this
    Dim family As Family = familyInstance.Symbol.Family
    If family Is Nothing Then
        ' could not get the family
        Return
    End If

    ' Get Family document for family
    Dim familyDoc As Document = document.EditFamily(family)
    If familyDoc Is Nothing Then
        ' could not open a family for edit
        Return
    End If

    Dim familyManager As FamilyManager = familyDoc.FamilyManager
    If familyManager Is Nothing Then
        ' cuould not get a family manager
        Return
    End If

    ' Start transaction for the family document
    Using newFamilyTypeTransaction As New Transaction(familyDoc, "Add Type to Family")
        Dim changesMade As Integer = 0
        newFamilyTypeTransaction.Start()

        ' add a new type and edit its parameters
        Dim newFamilyType As FamilyType = familyManager.NewType("2X2")

        If newFamilyType IsNot Nothing Then
            ' look for 'b' and 'h' parameters and set them to 2 feet
            Dim familyParam As FamilyParameter = familyManager.Parameter("b")
            If familyParam IsNot Nothing Then
                familyManager.[Set](familyParam, 2.0)
                changesMade += 1
            End If

            familyParam = familyManager.Parameter("h")
            If familyParam IsNot Nothing Then
                familyManager.[Set](familyParam, 2.0)
                changesMade += 1
            End If
        End If

        If 2 = changesMade Then
            ' set both paramaters?
            newFamilyTypeTransaction.Commit()
        Else
            ' could not make the change -> should roll back
            newFamilyTypeTransaction.RollBack()
        End If

        ' if could not make the change or could not commit it, we return
        If newFamilyTypeTransaction.GetStatus() <> TransactionStatus.Committed Then
            Return
        End If
    End Using

    ' now update the Revit project with Family which has a new type
    Dim loadOptions As New LoadOpts()

    ' This overload is necessary for reloading an edited family
    ' back into the source document from which it was extracted
    family = familyDoc.LoadFamily(document, loadOptions)
    If family IsNot Nothing Then
        ' find the new type and assign it to FamilyInstance
        Dim familySymbolIds As ISet(Of ElementId) = family.GetFamilySymbolIds()
        For Each id As ElementId In familySymbolIds
            Dim familySymbol As FamilySymbol = TryCast(family.Document.GetElement(id), FamilySymbol)
            If (familySymbol IsNot Nothing) AndAlso familySymbol.Name = "2X2" Then
                Using changeSymbol As New Transaction(document, "Change Symbol Assignment")
                    changeSymbol.Start()
                    familyInstance.Symbol = familySymbol
                    changeSymbol.Commit()
                End Using
                Exit For
            End If
        Next
    End If
End Sub

Private Class LoadOpts
    Implements IFamilyLoadOptions
    Public Function OnFamilyFound(familyInUse As Boolean, ByRef overwriteParameterValues As Boolean) As Boolean Implements IFamilyLoadOptions.OnFamilyFound
        overwriteParameterValues = True
        Return True
    End Function

    Public Function OnSharedFamilyFound(sharedFamily As Family, familyInUse As Boolean, ByRef source As FamilySource, ByRef overwriteParameterValues As Boolean) As Boolean Implements IFamilyLoadOptions.OnSharedFamilyFound
        source = FamilySource.Family
        overwriteParameterValues = True
        Return True
    End Function
End Class

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

FamilyManager Class


FamilyManager.RemoveParameter Method

FamilyManagerRemoveParameter Method

Remove an existing family parameter from the family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveParameter(
    FamilyParameter familyParameter
)
Public Sub RemoveParameter (
    familyParameter As FamilyParameter
)
public:
void RemoveParameter(
    FamilyParameter^ familyParameter
)
member RemoveParameter :
        familyParameter : FamilyParameter -> unit

Parameters

familyParameter FamilyParameter
The family parameter.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument-"familyParameter"-is .
ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid parameter or a builtIn parameter.
InvalidOperationException | Thrown when the family parameter deletion failed.
Remarks
Only family and shared parameters may be removed, built-in parameters may not be removed. If the parameter is used in any formulas, those formulas will be automatically removed along with the parameter.
See Also

Reference

FamilyManager Class


FamilyManager.RenameCurrentType Method

FamilyManagerRenameCurrentType Method

Rename the current family type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RenameCurrentType(
    string typeName
)
Public Sub RenameCurrentType (
    typeName As String
)
public:
void RenameCurrentType(
    String^ typeName
)
member RenameCurrentType :
        typeName : string -> unit

Parameters

typeName String
The new name of the current family type.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument-"typeName"-is .
ArgumentException | Thrown when the input argument-"typeName"-is already in use.
InvalidOperationException | Thrown when the family type rename failed.
See Also

Reference

FamilyManager Class


FamilyManager.RenameParameter Method

FamilyManagerRenameParameter Method

Rename a family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RenameParameter(
    FamilyParameter familyParameter,
    string name
)
Public Sub RenameParameter (
    familyParameter As FamilyParameter,
    name As String
)
public:
void RenameParameter(
    FamilyParameter^ familyParameter,
    String^ name
)
member RenameParameter :
        familyParameter : FamilyParameter *
        name : string -> unit

Parameters

familyParameter FamilyParameter
The family parameter.
name String
The new name.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument-"familyParameter" or "name"-is .
ArgumentException | Thrown when the input argument-"familyParameter"-is invalid, or the input name string contains illegal characters, or duplicated with existing parameter name.
InvalidOperationException | Thrown when trying to rename a built-in parameter or shared parameter.
Remarks
This operation is valid only for Family Parameters, and is invalid for Shared Parameters and Built-in Parameters.
See Also

Reference

FamilyManager Class


FamilyManager.ReorderParameters Method

FamilyManagerReorderParameters Method

Reorders the family parameters by the specified parameters order.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ReorderParameters(
    IList<FamilyParameter> parameters
)
Public Sub ReorderParameters (
    parameters As IList(Of FamilyParameter)
)
public:
void ReorderParameters(
    IList<FamilyParameter^>^ parameters
)
member ReorderParameters :
        parameters : IList<FamilyParameter> -> unit

Parameters

parameters IList FamilyParameter
The new parameters order for the family. The contents of this collection should consist of exactly the same parameters returned by the GetParameters() method. This will include invisible parameters; they can be reordered but this will have no effect when viewing the parameters in the Revit UI.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when argument is or empty.
ArgumentException | Thrown when the input parameters collection does not contain the same parameters as those returned by GetParameters().
InvalidOperationException | Thrown when this family is a Rebar Shape family which doesn't support parameters reorder.
Remarks

Reordering the parameters only affects visible parameters within the same parameter group.

Parameters that belong to different groups will remain separated, and the groups' order will not be affected.

See Also

Reference

FamilyManager Class


FamilyManager.ReplaceParameter Method

FamilyManagerReplaceParameter Method

Overload List
 | Name | Description
Public method | ReplaceParameter(FamilyParameter, ExternalDefinition, ForgeTypeId, Boolean) | Replace a family parameter with a shared parameter.
Public method | ReplaceParameter(FamilyParameter, String, ForgeTypeId, Boolean) | Replace a shared family parameter with a new non-shared family parameter.
Top
See Also

Reference

FamilyManager Class


FamilyManager.ReplaceParameter(FamilyParameter, ExternalDefinition, ForgeTypeId, Boolean) Method

FamilyManagerReplaceParameter(FamilyParameter, ExternalDefinition, ForgeTypeId, Boolean) Method

Replace a family parameter with a shared parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyParameter ReplaceParameter(
    FamilyParameter currentParameter,
    ExternalDefinition familyDefinition,
    ForgeTypeId groupTypeId,
    bool isInstance
)
Public Function ReplaceParameter (
    currentParameter As FamilyParameter,
    familyDefinition As ExternalDefinition,
    groupTypeId As ForgeTypeId,
    isInstance As Boolean
) As FamilyParameter
public:
FamilyParameter^ ReplaceParameter(
    FamilyParameter^ currentParameter,
    ExternalDefinition^ familyDefinition,
    ForgeTypeId^ groupTypeId,
    bool isInstance
)
member ReplaceParameter :
        currentParameter : FamilyParameter *
        familyDefinition : ExternalDefinition *
        groupTypeId : ForgeTypeId *
        isInstance : bool -> FamilyParameter

Parameters

currentParameter FamilyParameter
The current family parameter.
familyDefinition ExternalDefinition
The definition of the loaded shared parameter.
groupTypeId ForgeTypeId
The identifier of the group to which the new shared parameter belongs.
isInstance Boolean
Indicates if the new parameter is instance or type.

Return Value

FamilyParameter
If replacement was successful the new shared parameter is returned, otherwise an exception with failure information will be thrown.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument-"familyParameter" or "name"-is .
ArgumentException | Thrown when the input argument-"familyParameter"-is invalid, or the input parameter group cannot be assigned to the new parameter, or the input name string contains illegal characters, or duplicated with existing parameter name.
InvalidOperationException | Thrown when trying to replace a built-in parameter.
InvalidOperationException | Thrown when replacement failed, because the replacement would cause a formula error. Or trying to replace with an instance parameter of image type.
Remarks
This operation is invalid for Built-in Parameters. The formulas and labels which in reference to this parameter will be updated to the new parameter.
See Also

Reference

FamilyManager Class
ReplaceParameter Overload


FamilyManager.ReplaceParameter(FamilyParameter, String, ForgeTypeId, Boolean) Method

FamilyManagerReplaceParameter(FamilyParameter, String, ForgeTypeId, Boolean) Method

Replace a shared family parameter with a new non-shared family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyParameter ReplaceParameter(
    FamilyParameter currentParameter,
    string parameterName,
    ForgeTypeId groupTypeId,
    bool isInstance
)
Public Function ReplaceParameter (
    currentParameter As FamilyParameter,
    parameterName As String,
    groupTypeId As ForgeTypeId,
    isInstance As Boolean
) As FamilyParameter
public:
FamilyParameter^ ReplaceParameter(
    FamilyParameter^ currentParameter,
    String^ parameterName,
    ForgeTypeId^ groupTypeId,
    bool isInstance
)
member ReplaceParameter :
        currentParameter : FamilyParameter *
        parameterName : string *
        groupTypeId : ForgeTypeId *
        isInstance : bool -> FamilyParameter

Parameters

currentParameter FamilyParameter
The current family parameter.
parameterName String
The name of the new family parameter.
groupTypeId ForgeTypeId
The identifier of the group to which the new family parameter belongs.
isInstance Boolean
Indicates if the new parameter is instance or type.

Return Value

FamilyParameter
If replacement was successful the new family parameter is returned, otherwise an exception with failure information will be thrown.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument-"currentParameter" or "parameterName"-is .
ArgumentException | Thrown when the input argument-"currentParameter"-is invalid, or the input parameter group cannot be assigned to the new parameter, or the input name string contains illegal characters, or duplicated with existing parameter name.
InvalidOperationException | Thrown when trying to replace a built-in parameter or family parameter.
InvalidOperationException | Thrown when replacement failed, because the replacement would cause a formula error. Or trying to replace with an instance parameter of image type.
See Also

Reference

FamilyManager Class
ReplaceParameter Overload


FamilyManager.Set Method

FamilyManagerSet Method

Set the value of a family parameter of the current family type.
Overload List
 | Name | Description
Public method | Set(FamilyParameter, ElementId) | Set the ElementId value of a family parameter of the current family type.
Public method | Set(FamilyParameter, Double) | Set the double value of a family parameter of the current family type.
Public method | Set(FamilyParameter, Int32) | Set the integer value of a family parameter of the current family type.
Public method | Set(FamilyParameter, String) | Set the string value of a family parameter of the current family type.
Top
See Also

Reference

FamilyManager Class


FamilyManager.Set(FamilyParameter, ElementId) Method

FamilyManagerSet(FamilyParameter, ElementId) Method

Set the ElementId value of a family parameter of the current family type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Set(
    FamilyParameter familyParameter,
    ElementId value
)
Public Sub Set (
    familyParameter As FamilyParameter,
    value As ElementId
)
public:
void Set(
    FamilyParameter^ familyParameter,
    ElementId^ value
)
member Set :
        familyParameter : FamilyParameter *
        value : ElementId -> unit

Parameters

familyParameter FamilyParameter
A family parameter of the current type.
value ElementId
The new value for family parameter.
Exceptions
Exception | Condition
ArgumentException | Thrown when the storage type of family parameter is not ElementId --or-- The input ElementId does not represent either a valid element in the document or InvalidElementId.
ArgumentOutOfRangeException | Thrown when the input ElementId is not valid as a value for this FamilyParameter.
InvalidOperationException | Thrown when the family parameter is determined by formula, or the current family type is invalid.
See Also

Reference

FamilyManager Class
Set Overload


FamilyManager.Set(FamilyParameter, Double) Method

FamilyManagerSet(FamilyParameter, Double) Method

Set the double value of a family parameter of the current family type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Set(
    FamilyParameter familyParameter,
    double value
)
Public Sub Set (
    familyParameter As FamilyParameter,
    value As Double
)
public:
void Set(
    FamilyParameter^ familyParameter,
    double value
)
member Set :
        familyParameter : FamilyParameter *
        value : float -> unit

Parameters

familyParameter FamilyParameter
A family parameter of the current type.
value Double
The new value for family parameter.
Exceptions
Exception | Condition
ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid family parameter.
ArgumentOutOfRangeException | Thrown when the input argument-"familyParameter"-is out of range.
InvalidOperationException | Thrown when the family parameter is determined by formula, or the current family type is invalid.
See Also

Reference

FamilyManager Class
Set Overload


FamilyManager.Set(FamilyParameter, Int32) Method

FamilyManagerSet(FamilyParameter, Int32) Method

Set the integer value of a family parameter of the current family type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Set(
    FamilyParameter familyParameter,
    int value
)
Public Sub Set (
    familyParameter As FamilyParameter,
    value As Integer
)
public:
void Set(
    FamilyParameter^ familyParameter,
    int value
)
member Set :
        familyParameter : FamilyParameter *
        value : int -> unit

Parameters

familyParameter FamilyParameter
A family parameter of the current type.
value Int32
The new value for family parameter.
Exceptions
Exception | Condition
ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid family parameter.
ArgumentOutOfRangeException | Thrown when the input argument-"familyParameter"-is out of range.
InvalidOperationException | Thrown when the family parameter is determined by formula, or the current family type is invalid.
See Also

Reference

FamilyManager Class
Set Overload


FamilyManager.Set(FamilyParameter, String) Method

FamilyManagerSet(FamilyParameter, String) Method

Set the string value of a family parameter of the current family type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Set(
    FamilyParameter familyParameter,
    string value
)
Public Sub Set (
    familyParameter As FamilyParameter,
    value As String
)
public:
void Set(
    FamilyParameter^ familyParameter,
    String^ value
)
member Set :
        familyParameter : FamilyParameter *
        value : string -> unit

Parameters

familyParameter FamilyParameter
A family parameter of the current type.
value String
The new value for family parameter.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument-"familyParameter"-is .
ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid family parameter.
ArgumentOutOfRangeException | Thrown when the input argument-"familyParameter"-is out of range.
InvalidOperationException | Thrown when the family parameter is determined by formula, or the current family type is invalid.
See Also

Reference

FamilyManager Class
Set Overload


FamilyManager.SetDescription Method

FamilyManagerSetDescription Method

Set the description for an existing family parameter. The description will be used as tooltip in the Revit UI including in the properties palette.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetDescription(
    FamilyParameter familyParameter,
    string description
)
Public Sub SetDescription (
    familyParameter As FamilyParameter,
    description As String
)
public:
void SetDescription(
    FamilyParameter^ familyParameter,
    String^ description
)
member SetDescription :
        familyParameter : FamilyParameter *
        description : string -> unit

Parameters

familyParameter FamilyParameter
The family parameter.
description String
The description of the family parameter.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument-"familyParameter"-is .
ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid parameter or a builtIn parameter.
See Also

Reference

FamilyManager Class


FamilyManager.SetFormula Method

FamilyManagerSetFormula Method

Set the formula of a family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetFormula(
    FamilyParameter familyParameter,
    string formula
)
Public Sub SetFormula (
    familyParameter As FamilyParameter,
    formula As String
)
public:
void SetFormula(
    FamilyParameter^ familyParameter,
    String^ formula
)
member SetFormula :
        familyParameter : FamilyParameter *
        formula : string -> unit

Parameters

familyParameter FamilyParameter
The family parameter.
formula String
The formula string, input to clean the formula of the parameter.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument-"familyParameter"-is .
InvalidOperationException | Thrown when there is no valid family type, or the parameter cannot be assigned a formula, or the operation make a circular chain of references among the formulas.
See Also

Reference

FamilyManager Class


FamilyManager.SetParameterLocked Method

FamilyManagerSetParameterLocked Method

For Conceptual Mass and Curtain Panel families, lock or unlock a dimension-driving parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetParameterLocked(
    FamilyParameter familyParameter,
    bool locked
)
Public Sub SetParameterLocked (
    familyParameter As FamilyParameter,
    locked As Boolean
)
public:
void SetParameterLocked(
    FamilyParameter^ familyParameter,
    bool locked
)
member SetParameterLocked :
        familyParameter : FamilyParameter *
        locked : bool -> unit

Parameters

familyParameter FamilyParameter
locked Boolean
Exceptions
Exception | Condition
InvalidOperationException | Thrown if this family is not a Conceptual Mass or Curtain Panel family.
ArgumentException | Thrown if the parameter is not lockable.
See Also

Reference

FamilyManager Class


FamilyManager.SetValueString Method

FamilyManagerSetValueString Method

Set the string value of a family parameter of the current family type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetValueString(
    FamilyParameter familyParameter,
    string value
)
Public Sub SetValueString (
    familyParameter As FamilyParameter,
    value As String
)
public:
void SetValueString(
    FamilyParameter^ familyParameter,
    String^ value
)
member SetValueString :
        familyParameter : FamilyParameter *
        value : string -> unit

Parameters

familyParameter FamilyParameter
The family parameter of current type.
value String
The new value string for family parameter.
Exceptions
Exception | Condition
ArgumentException | Thrown when the input argument-"familyParameter" or "value"-is .
ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid family parameter. or the input argument-"value"-is an illegal string.
ArgumentOutOfRangeException | Thrown when the input argument-"familyParameter"-is out of range.
InvalidOperationException | Thrown when the family parameter is determined by formula, or it is not a value type, or the current family type is invalid.
See Also

Reference

FamilyManager Class


FamilyManager.SortParameters Method

FamilyManagerSortParameters Method

Sorts the family parameters according to the desired sort order.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SortParameters(
    ParametersOrder order
)
Public Sub SortParameters (
    order As ParametersOrder
)
public:
void SortParameters(
    ParametersOrder order
)
member SortParameters :
        order : ParametersOrder -> unit

Parameters

order ParametersOrder
The desired sort order.
Exceptions
Exception | Condition
InvalidOperationException | Thrown when this family is a Rebar Shape family which doesn't support parameters reorder.
Remarks

The sort only affects visible parameters within the same parameter group.

Parameters that belong to different groups will remain separated, and the groups' order will not be affected.

The sort is a one-time operation and when new parameters are added they will not be automatically sorted.

Example
C#
VB
C++
F#
Copy
private void DisplayParametersInAscendingOrder(Document familyDoc)
{
    FamilyManager familyManager = familyDoc.FamilyManager;
    familyManager.SortParameters(ParametersOrder.Ascending);
}
Private Sub DisplayParametersInAscendingOrder(familyDoc As Document)
    Dim familyManager As FamilyManager = familyDoc.FamilyManager
    familyManager.SortParameters(ParametersOrder.Ascending)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

FamilyManager Class


FamilyNestingBehavior Enumeration

This attribute describes the family nesting behavior.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum FamilyNestingBehavior
Public Enumeration FamilyNestingBehavior
public enum class FamilyNestingBehavior
type FamilyNestingBehavior
Members
Member name | Value | Description
Embedded | 0 |
Shared | 1 |
Subelement | 2 |
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FamilyParameter Class

The family parameter object.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBFamilyParameter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FamilyParameter : APIObject
Public Class FamilyParameter
    Inherits APIObject
public ref class FamilyParameter : public APIObject
type FamilyParameter =
    class
        inherit APIObject
    end

The FamilyParameter type exposes the following members.

Properties
 | Name | Description
Public property | AssociatedParameters | The parameters from elements in the family which are associated to this parameter.
Public property | CanAssignFormula | Indicates if this parameter can be assigned a formula.
Public property | Definition | The definition.
Public property | Formula | The formula.
 | GUID | The globally unique identifier
Public property | Id | The id of the family parameter.
Public property | IsDeterminedByFormula | Indicates if the parameter is determined by formula.
Public property | IsInstance | Indicates if the parameter is instance or type.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Overrides APIObjectIsReadOnly)
Public property | IsReporting | Indicates if the parameter is a reporting parameter.
Public property | IsShared | Identifies if the parameter is a shared parameter.
Public property | StorageType | The storage type describes the type that is used internally within the parameter to store its value.
Public property | UserModifiable | Indicates whether the interactive user can modify the value of this parameter.
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetUnitTypeId | Gets the identifier of the unit quantifying the parameter value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FamilyParameter Properties

The FamilyParameter type exposes the following members.

Properties
 | Name | Description
Public property | AssociatedParameters | The parameters from elements in the family which are associated to this parameter.
Public property | CanAssignFormula | Indicates if this parameter can be assigned a formula.
Public property | Definition | The definition.
Public property | Formula | The formula.
 | GUID | The globally unique identifier
Public property | Id | The id of the family parameter.
Public property | IsDeterminedByFormula | Indicates if the parameter is determined by formula.
Public property | IsInstance | Indicates if the parameter is instance or type.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Overrides APIObjectIsReadOnly)
Public property | IsReporting | Indicates if the parameter is a reporting parameter.
Public property | IsShared | Identifies if the parameter is a shared parameter.
Public property | StorageType | The storage type describes the type that is used internally within the parameter to store its value.
Public property | UserModifiable | Indicates whether the interactive user can modify the value of this parameter.
Top
See Also

Reference

FamilyParameter Class


FamilyParameter.AssociatedParameters Property

FamilyParameterAssociatedParameters Property

The parameters from elements in the family which are associated to this parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ParameterSet AssociatedParameters { get; }
Public ReadOnly Property AssociatedParameters As ParameterSet
    Get
public:
property ParameterSet^ AssociatedParameters {
    ParameterSet^ get ();
}
member AssociatedParameters : ParameterSet with get

Property Value

ParameterSet
See Also

Reference

FamilyParameter Class


FamilyParameter.CanAssignFormula Property

FamilyParameterCanAssignFormula Property

Indicates if this parameter can be assigned a formula.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanAssignFormula { get; }
Public ReadOnly Property CanAssignFormula As Boolean
    Get
public:
property bool CanAssignFormula {
    bool get ();
}
member CanAssignFormula : bool with get

Property Value

Boolean
See Also

Reference

FamilyParameter Class


FamilyParameter.Definition Property

FamilyParameterDefinition Property

The definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Definition Definition { get; }
Public ReadOnly Property Definition As Definition
    Get
public:
property Definition^ Definition {
    Definition^ get ();
}
member Definition : Definition with get

Property Value

Definition
See Also

Reference

FamilyParameter Class


FamilyParameter.Formula Property

FamilyParameterFormula Property

The formula.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Formula { get; }
Public ReadOnly Property Formula As String
    Get
public:
property String^ Formula {
    String^ get ();
}
member Formula : string with get

Property Value

String
Remarks
Returns if there is no formula governing this parameter.
See Also

Reference

FamilyParameter Class


FamilyParameter.GUID Property

FamilyParameterGUID Property

The globally unique identifier

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid GUID { get; }
Public ReadOnly Property GUID As Guid
    Get
public:
property Guid GUID {
    Guid get ();
}
member GUID : Guid with get

Property Value

Guid
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the parameter is not a shared parameter.
Example
C#
VB
C++
F#
Copy
foreach (FamilyParameter familyParam in familyDoc.FamilyManager.Parameters)
{
    string familyParamName = familyParam.Definition.Name;
    try
    {
        Guid guid = familyParam.GUID;
        TaskDialog.Show("Revit",familyParamName + " is shared. Guid is " + guid);
    }
    catch (System.Exception)
    {
        TaskDialog.Show("Revit",familyParamName + " is NOT shared");
    }
}
For Each familyParam As FamilyParameter In familyDoc.FamilyManager.Parameters
    Dim familyParamName As String = familyParam.Definition.Name
    Try
        Dim guid As Guid = familyParam.GUID
        TaskDialog.Show("Revit", familyParamName & " is shared. Guid is " & Convert.ToString(guid))
    Catch generatedExceptionName As System.Exception
        TaskDialog.Show("Revit", familyParamName & " is NOT shared")
    End Try

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

FamilyParameter Class


FamilyParameter.Id Property

FamilyParameterId Property

The id of the family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId Id { get; }
Public ReadOnly Property Id As ElementId
    Get
public:
property ElementId^ Id {
    ElementId^ get ();
}
member Id : ElementId with get

Property Value

ElementId
See Also

Reference

FamilyParameter Class


FamilyParameter.IsDeterminedByFormula Property

FamilyParameterIsDeterminedByFormula Property

Indicates if the parameter is determined by formula.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsDeterminedByFormula { get; }
Public ReadOnly Property IsDeterminedByFormula As Boolean
    Get
public:
property bool IsDeterminedByFormula {
    bool get ();
}
member IsDeterminedByFormula : bool with get

Property Value

Boolean
Remarks
The parameter is read only if it is determined by formula.
See Also

Reference

FamilyParameter Class


FamilyParameter.IsInstance Property

FamilyParameterIsInstance Property

Indicates if the parameter is instance or type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsInstance { get; }
Public ReadOnly Property IsInstance As Boolean
    Get
public:
property bool IsInstance {
    bool get ();
}
member IsInstance : bool with get

Property Value

Boolean
See Also

Reference

FamilyParameter Class


FamilyParameter.IsReadOnly Property

FamilyParameterIsReadOnly Property

Identifies if the object is read-only or modifiable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool IsReadOnly { get; }
Public Overrides ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get () override;
}
abstract IsReadOnly : bool with get
override IsReadOnly : bool with get

Property Value

Boolean
If true, the object may not be modified. If false, the object's contents may be modified.
See Also

Reference

FamilyParameter Class


FamilyParameter.IsReporting Property

FamilyParameterIsReporting Property

Indicates if the parameter is a reporting parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsReporting { get; }
Public ReadOnly Property IsReporting As Boolean
    Get
public:
property bool IsReporting {
    bool get ();
}
member IsReporting : bool with get

Property Value

Boolean
Remarks
If true, the parameter is a reporting parameter associated to a dimension value, and cannot be modified. If false, the parameter is a driving parameter and if associated to a dimension, can modify the dimension it labels.
See Also

Reference

FamilyParameter Class


FamilyParameter.IsShared Property

FamilyParameterIsShared Property

Identifies if the parameter is a shared parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsShared { get; }
Public ReadOnly Property IsShared As Boolean
    Get
public:
property bool IsShared {
    bool get ();
}
member IsShared : bool with get

Property Value

Boolean
See Also

Reference

FamilyParameter Class


FamilyParameter.StorageType Property

FamilyParameterStorageType Property

The storage type describes the type that is used internally within the parameter to store its value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public StorageType StorageType { get; }
Public ReadOnly Property StorageType As StorageType
    Get
public:
property StorageType StorageType {
    StorageType get ();
}
member StorageType : StorageType with get

Property Value

StorageType
Remarks
The property will return one of the following possibilities: String, Integer, Double or ElementId. Based on the value of this property the correct access and set methods should be used to retrieve and set the parameter's data value.
See Also

Reference

FamilyParameter Class


FamilyParameter.UserModifiable Property

FamilyParameterUserModifiable Property

Indicates whether the interactive user can modify the value of this parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UserModifiable { get; }
Public ReadOnly Property UserModifiable As Boolean
    Get
public:
property bool UserModifiable {
    bool get ();
}
member UserModifiable : bool with get

Property Value

Boolean
Remarks
Note that for shared parameters IsReadOnly can return false for shared parameters whose UserModifiable property is also false, because the value of those parameters can be modified by the API. If a parameter is governed by a formula, IsReadOnly would return true, even if the flag for UserModifiable was set to true when the shared parameter was created.
See Also

Reference

FamilyParameter Class


FamilyParameter Methods

The FamilyParameter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetUnitTypeId | Gets the identifier of the unit quantifying the parameter value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FamilyParameter Class


FamilyParameter.GetUnitTypeId Method

FamilyParameterGetUnitTypeId Method

Gets the identifier of the unit quantifying the parameter value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ForgeTypeId GetUnitTypeId()
Public Function GetUnitTypeId As ForgeTypeId
public:
ForgeTypeId^ GetUnitTypeId()
member GetUnitTypeId : unit -> ForgeTypeId

Return Value

ForgeTypeId
Exceptions
Exception | Condition
InvalidOperationException | Thrown if this parameter is not of value type.
See Also

Reference

FamilyParameter Class


FamilyParameterSet Class

A set that contains FamilyParameter objects.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBFamilyParameterSet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FamilyParameterSet : APIObject,
    IEnumerable
Public Class FamilyParameterSet
    Inherits APIObject
    Implements IEnumerable
public ref class FamilyParameterSet : public APIObject,
    IEnumerable
type FamilyParameterSet =
    class
        inherit APIObject
        interface IEnumerable
    end

The FamilyParameterSet type exposes the following members.

Constructors
 | Name | Description
Public method | FamilyParameterSet | Initializes a new instance of the FamilyParameterSet class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Size | Returns the number of objects that are in the set.
Top
Methods
 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FamilyParameterSet Constructor

Initializes a new instance of the FamilyParameterSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyParameterSet()
Public Sub New
public:
FamilyParameterSet()
new : unit -> FamilyParameterSet
See Also

Reference

FamilyParameterSet Class


FamilyParameterSet Properties

The FamilyParameterSet type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Size | Returns the number of objects that are in the set.
Top
See Also

Reference

FamilyParameterSet Class


FamilyParameterSet.IsEmpty Property

FamilyParameterSetIsEmpty Property

Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Boolean
Remarks
If the set is empty then True will be returned, otherwise False.
See Also

Reference

FamilyParameterSet Class


FamilyParameterSet.Size Property

FamilyParameterSetSize Property

Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
abstract Size : int with get
override Size : int with get

Property Value

Int32
See Also

Reference

FamilyParameterSet Class


FamilyParameterSet Methods

The FamilyParameterSet type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FamilyParameterSet Class


FamilyParameterSet.Clear Method

FamilyParameterSetClear Method

Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

FamilyParameterSet Class


FamilyParameterSet.Contains Method

FamilyParameterSetContains Method

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Contains(
    FamilyParameter item
)
Public Overridable Function Contains (
    item As FamilyParameter
) As Boolean
public:
virtual bool Contains(
    FamilyParameter^ item
)
abstract Contains :
        item : FamilyParameter -> bool
override Contains :
        item : FamilyParameter -> bool

Parameters

item FamilyParameter

Return Value

Boolean
See Also

Reference

FamilyParameterSet Class


FamilyParameterSet.Erase Method

FamilyParameterSetErase Method

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Erase(
    FamilyParameter item
)
Public Overridable Function Erase (
    item As FamilyParameter
) As Integer
public:
virtual int Erase(
    FamilyParameter^ item
)
abstract Erase :
        item : FamilyParameter -> int
override Erase :
        item : FamilyParameter -> int

Parameters

item FamilyParameter

Return Value

Int32
See Also

Reference

FamilyParameterSet Class


FamilyParameterSet.ForwardIterator Method

FamilyParameterSetForwardIterator Method

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual FamilyParameterSetIterator ForwardIterator()
Public Overridable Function ForwardIterator As FamilyParameterSetIterator
public:
virtual FamilyParameterSetIterator^ ForwardIterator()
abstract ForwardIterator : unit -> FamilyParameterSetIterator
override ForwardIterator : unit -> FamilyParameterSetIterator

Return Value

FamilyParameterSetIterator
Returns a forward moving iterator to the set.
See Also

Reference

FamilyParameterSet Class


FamilyParameterSet.GetEnumerator Method

FamilyParameterSetGetEnumerator Method

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

IEnumerator
Returns a forward moving iterator to the set.

Implements

IEnumerableGetEnumerator
See Also

Reference

FamilyParameterSet Class


FamilyParameterSet.Insert Method

FamilyParameterSetInsert Method

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Insert(
    FamilyParameter item
)
Public Overridable Function Insert (
    item As FamilyParameter
) As Boolean
public:
virtual bool Insert(
    FamilyParameter^ item
)
abstract Insert :
        item : FamilyParameter -> bool
override Insert :
        item : FamilyParameter -> bool

Parameters

item FamilyParameter

Return Value

Boolean
See Also

Reference

FamilyParameterSet Class


FamilyParameterSet.ReverseIterator Method

FamilyParameterSetReverseIterator Method

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual FamilyParameterSetIterator ReverseIterator()
Public Overridable Function ReverseIterator As FamilyParameterSetIterator
public:
virtual FamilyParameterSetIterator^ ReverseIterator()
abstract ReverseIterator : unit -> FamilyParameterSetIterator
override ReverseIterator : unit -> FamilyParameterSetIterator

Return Value

FamilyParameterSetIterator
Returns a backward moving iterator to the set.
See Also

Reference

FamilyParameterSet Class


FamilyParameterSetIterator Class

An iterator to a FamilyParameter set.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBFamilyParameterSetIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class FamilyParameterSetIterator : APIObject,
    IEnumerator
Public MustInherit Class FamilyParameterSetIterator
    Inherits APIObject
    Implements IEnumerator
public ref class FamilyParameterSetIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type FamilyParameterSetIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The FamilyParameterSetIterator type exposes the following members.

Constructors
 | Name | Description
Public method | FamilyParameterSetIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FamilyParameterSetIterator Constructor

For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyParameterSetIterator()
Public Sub New
public:
FamilyParameterSetIterator()
new : unit -> FamilyParameterSetIterator
Remarks
This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.
See Also

Reference

FamilyParameterSetIterator Class


FamilyParameterSetIterator Properties

The FamilyParameterSetIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

FamilyParameterSetIterator Class


FamilyParameterSetIterator.Current Property

FamilyParameterSetIteratorCurrent Property

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}
abstract Current : Object with get
override Current : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.
See Also

Reference

FamilyParameterSetIterator Class


FamilyParameterSetIterator Methods

The FamilyParameterSetIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FamilyParameterSetIterator Class


FamilyParameterSetIterator.MoveNext Method

FamilyParameterSetIteratorMoveNext Method

Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumeratorMoveNext
Remarks
MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.
See Also

Reference

FamilyParameterSetIterator Class


FamilyParameterSetIterator.Reset Method

FamilyParameterSetIteratorReset Method

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
Remarks
The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.
See Also

Reference

FamilyParameterSetIterator Class


FamilyPlacementType Enumeration

The type of placement required for a given family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum FamilyPlacementType
Public Enumeration FamilyPlacementType
public enum class FamilyPlacementType
type FamilyPlacementType
Members
Member name | Value | Description
OneLevelBased | 0 | The family is placed referencing a single level.
OneLevelBasedHosted | 1 | The family is placed referencing a single level and host.
TwoLevelsBased | 2 | The family is placed referencing two levels (e.g. a column).
ViewBased | 3 | The family is view-specific (e.g. a detail annotation)
WorkPlaneBased | 4 | The family is placed on a work plane or face.
CurveBased | 5 | The family is based on a line and placed on a work plane.
CurveBasedDetail | 6 | The family is based on a line and place on a specific view (e.g. a detail component).
CurveDrivenStructural | 7 | The family is a structural curve driven member (beam, brace, or slanted column)
Adaptive | 8 | The family is an adaptive family.
Invalid | 9 | This signals an invalid value for the enum.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FamilyPointLocation Class

Data corresponding to the point locations in certain types of Family Symbols.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBFamilyPointLocation

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FamilyPointLocation : APIObject
Public Class FamilyPointLocation
    Inherits APIObject
public ref class FamilyPointLocation : public APIObject
type FamilyPointLocation =
    class
        inherit APIObject
    end

The FamilyPointLocation type exposes the following members.

Properties
 | Name | Description
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The name of the corresponding reference point in the Family document.
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLocation | Gets the location of the point.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Examples of FamilySymbol objects that contain placement references are Panels and Flexible Components.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FamilyPointLocation Properties

The FamilyPointLocation type exposes the following members.

Properties
 | Name | Description
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The name of the corresponding reference point in the Family document.
Top
See Also

Reference

FamilyPointLocation Class


FamilyPointLocation.IsValidObject Property

FamilyPointLocationIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

FamilyPointLocation Class


FamilyPointLocation.Name Property

FamilyPointLocationName Property

The name of the corresponding reference point in the Family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

String
See Also

Reference

FamilyPointLocation Class


FamilyPointLocation Methods

The FamilyPointLocation type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLocation | Gets the location of the point.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FamilyPointLocation Class


FamilyPointLocation.GetLocation Method

FamilyPointLocationGetLocation Method

Gets the location of the point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Transform GetLocation()
Public Function GetLocation As Transform
public:
Transform^ GetLocation()
member GetLocation : unit -> Transform

Return Value

Transform
The location of the point.
See Also

Reference

FamilyPointLocation Class


FamilyPointPlacementReference Class

This object represents data corresponding to the placement references in a certain types of Family Instances (see examples listed below).
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBFamilyPointPlacementReference

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FamilyPointPlacementReference : APIObject
Public Class FamilyPointPlacementReference
    Inherits APIObject
public ref class FamilyPointPlacementReference : public APIObject
type FamilyPointPlacementReference =
    class
        inherit APIObject
    end

The FamilyPointPlacementReference type exposes the following members.

Properties
 | Name | Description
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Location | The location of the point.
Public property | Name | The name of the corresponding reference point in the Family document.
Public property | PointReference | The reference on which the point depends on.
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Examples of FamilyInstance objects that contain placement references are Panels and Flexible Components.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FamilyPointPlacementReference Properties

The FamilyPointPlacementReference type exposes the following members.

Properties
 | Name | Description
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Location | The location of the point.
Public property | Name | The name of the corresponding reference point in the Family document.
Public property | PointReference | The reference on which the point depends on.
Top
See Also

Reference

FamilyPointPlacementReference Class


FamilyPointPlacementReference.Location Property

FamilyPointPlacementReferenceLocation Property

The location of the point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Transform Location { get; }
Public ReadOnly Property Location As Transform
    Get
public:
property Transform^ Location {
    Transform^ get ();
}
member Location : Transform with get

Property Value

Transform
See Also

Reference

FamilyPointPlacementReference Class


FamilyPointPlacementReference.Name Property

FamilyPointPlacementReferenceName Property

The name of the corresponding reference point in the Family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

String
See Also

Reference

FamilyPointPlacementReference Class


FamilyPointPlacementReference.PointReference Property

FamilyPointPlacementReferencePointReference Property

The reference on which the point depends on.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Reference PointReference { get; }
Public ReadOnly Property PointReference As Reference
    Get
public:
property Reference^ PointReference {
    Reference^ get ();
}
member PointReference : Reference with get

Property Value

Reference
See Also

Reference

FamilyPointPlacementReference Class


FamilyPointPlacementReference Methods

The FamilyPointPlacementReference type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FamilyPointPlacementReference Class


FamilySizeTable Class

Contains size information for a family.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFamilySizeTable

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FamilySizeTable : IDisposable
Public Class FamilySizeTable
    Implements IDisposable
public ref class FamilySizeTable : IDisposable
type FamilySizeTable =
    class
        interface IDisposable
    end

The FamilySizeTable type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NumberOfColumns | Number of columns in the table.
Public property | NumberOfRows | Number of rows in the table.
Top
Methods
 | Name | Description
Public method | AsValueString | Gets the table cell value as a string.
Public method | Dispose | Releases all resources used by the FamilySizeTable
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetColumnHeader | Gets a column of the table at at given index.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsValidColumnIndex | Checks if the column index is valid.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FamilySizeTable Properties

The FamilySizeTable type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NumberOfColumns | Number of columns in the table.
Public property | NumberOfRows | Number of rows in the table.
Top
See Also

Reference

FamilySizeTable Class


FamilySizeTable.IsValidObject Property

FamilySizeTableIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

FamilySizeTable Class


FamilySizeTable.NumberOfColumns Property

FamilySizeTableNumberOfColumns Property

Number of columns in the table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int NumberOfColumns { get; }
Public ReadOnly Property NumberOfColumns As Integer
    Get
public:
property int NumberOfColumns {
    int get ();
}
member NumberOfColumns : int with get

Property Value

Int32
See Also

Reference

FamilySizeTable Class


FamilySizeTable.NumberOfRows Property

FamilySizeTableNumberOfRows Property

Number of rows in the table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int NumberOfRows { get; }
Public ReadOnly Property NumberOfRows As Integer
    Get
public:
property int NumberOfRows {
    int get ();
}
member NumberOfRows : int with get

Property Value

Int32
See Also

Reference

FamilySizeTable Class


FamilySizeTable Methods

The FamilySizeTable type exposes the following members.

Methods
 | Name | Description
Public method | AsValueString | Gets the table cell value as a string.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetColumnHeader | Gets a column of the table at at given index.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsValidColumnIndex | Checks if the column index is valid.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FamilySizeTable Class


FamilySizeTable.AsValueString Method

FamilySizeTableAsValueString Method

Gets the table cell value as a string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string AsValueString(
    int row,
    int column
)
Public Function AsValueString (
    row As Integer,
    column As Integer
) As String
public:
String^ AsValueString(
    int row,
    int column
)
member AsValueString :
        row : int *
        column : int -> string

Parameters

row Int32
The table row.
column Int32
The table column.

Return Value

String
The table cell value as a string.
See Also

Reference

FamilySizeTable Class


FamilySizeTable.Dispose Method

FamilySizeTableDispose Method

Releases all resources used by the FamilySizeTable

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FamilySizeTable Class


FamilySizeTable.GetColumnHeader Method

FamilySizeTableGetColumnHeader Method

Gets a column of the table at at given index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilySizeTableColumn GetColumnHeader(
    int index
)
Public Function GetColumnHeader (
    index As Integer
) As FamilySizeTableColumn
public:
FamilySizeTableColumn^ GetColumnHeader(
    int index
)
member GetColumnHeader :
        index : int -> FamilySizeTableColumn

Parameters

index Int32
Index of the column.

Return Value

FamilySizeTableColumn
The column at the given index.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The column index is out of range.
See Also

Reference

FamilySizeTable Class


FamilySizeTable.IsValidColumnIndex Method

FamilySizeTableIsValidColumnIndex Method

Checks if the column index is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidColumnIndex(
    int index
)
Public Function IsValidColumnIndex (
    index As Integer
) As Boolean
public:
bool IsValidColumnIndex(
    int index
)
member IsValidColumnIndex :
        index : int -> bool

Parameters

index Int32
The index of the column.

Return Value

Boolean
True if the column index is valid, false otherwise.
See Also

Reference

FamilySizeTable Class


FamilySizeTableColumn Class

Contains column information for a FamilySizeTable.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFamilySizeTableColumn

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FamilySizeTableColumn : IDisposable
Public Class FamilySizeTableColumn
    Implements IDisposable
public ref class FamilySizeTableColumn : IDisposable
type FamilySizeTableColumn =
    class
        interface IDisposable
    end

The FamilySizeTableColumn type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The column name.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the FamilySizeTableColumn
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetSpecTypeId | Gets the identifier of the spec describing values in the column.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetUnitTypeId | Gets the identifier of the unit quantifying values in the column.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FamilySizeTableColumn Properties

The FamilySizeTableColumn type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The column name.
Top
See Also

Reference

FamilySizeTableColumn Class


FamilySizeTableColumn.IsValidObject Property

FamilySizeTableColumnIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

FamilySizeTableColumn Class


FamilySizeTableColumn.Name Property

FamilySizeTableColumnName Property

The column name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

String
See Also

Reference

FamilySizeTableColumn Class


FamilySizeTableColumn Methods

The FamilySizeTableColumn type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetSpecTypeId | Gets the identifier of the spec describing values in the column.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetUnitTypeId | Gets the identifier of the unit quantifying values in the column.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FamilySizeTableColumn Class


FamilySizeTableColumn.Dispose Method

FamilySizeTableColumnDispose Method

Releases all resources used by the FamilySizeTableColumn

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FamilySizeTableColumn Class


FamilySizeTableColumn.GetSpecTypeId Method

FamilySizeTableColumnGetSpecTypeId Method

Gets the identifier of the spec describing values in the column.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ForgeTypeId GetSpecTypeId()
Public Function GetSpecTypeId As ForgeTypeId
public:
ForgeTypeId^ GetSpecTypeId()
member GetSpecTypeId : unit -> ForgeTypeId

Return Value

ForgeTypeId
Identifier of the spec.
See Also

Reference

FamilySizeTableColumn Class


FamilySizeTableColumn.GetUnitTypeId Method

FamilySizeTableColumnGetUnitTypeId Method

Gets the identifier of the unit quantifying values in the column.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ForgeTypeId GetUnitTypeId()
Public Function GetUnitTypeId As ForgeTypeId
public:
ForgeTypeId^ GetUnitTypeId()
member GetUnitTypeId : unit -> ForgeTypeId

Return Value

ForgeTypeId
Identifier of the unit.
See Also

Reference

FamilySizeTableColumn Class


FamilySizeTableErrorInfo Class

Error information generated from the CSV file import of a FamilySizeTable.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFamilySizeTableErrorInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FamilySizeTableErrorInfo : IDisposable
Public Class FamilySizeTableErrorInfo
    Implements IDisposable
public ref class FamilySizeTableErrorInfo : IDisposable
type FamilySizeTableErrorInfo =
    class
        interface IDisposable
    end

The FamilySizeTableErrorInfo type exposes the following members.

Constructors
 | Name | Description
Public method | FamilySizeTableErrorInfo | Constructs a new FamilySizeTableErrorInfo with default settings.
Top
Properties
 | Name | Description
Public property | FamilySizeTableErrorType | The error type.
Public property | FilePath | The path of the imported CSV file.
Public property | InvalidColumnIndex | The index of the invalid column.
Public property | InvalidHeaderText | The invalid header text.
Public property | InvalidRowIndex | The index of the invalid row.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the FamilySizeTableErrorInfo
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FamilySizeTableErrorInfo Constructor

Constructs a new FamilySizeTableErrorInfo with default settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilySizeTableErrorInfo()
Public Sub New
public:
FamilySizeTableErrorInfo()
new : unit -> FamilySizeTableErrorInfo
See Also

Reference

FamilySizeTableErrorInfo Class


FamilySizeTableErrorInfo Properties

The FamilySizeTableErrorInfo type exposes the following members.

Properties
 | Name | Description
Public property | FamilySizeTableErrorType | The error type.
Public property | FilePath | The path of the imported CSV file.
Public property | InvalidColumnIndex | The index of the invalid column.
Public property | InvalidHeaderText | The invalid header text.
Public property | InvalidRowIndex | The index of the invalid row.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

FamilySizeTableErrorInfo Class


FamilySizeTableErrorInfo.FamilySizeTableErrorType Property

FamilySizeTableErrorInfoFamilySizeTableErrorType Property

The error type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilySizeTableErrorType FamilySizeTableErrorType { get; }
Public ReadOnly Property FamilySizeTableErrorType As FamilySizeTableErrorType
    Get
public:
property FamilySizeTableErrorType FamilySizeTableErrorType {
    FamilySizeTableErrorType get ();
}
member FamilySizeTableErrorType : FamilySizeTableErrorType with get

Property Value

FamilySizeTableErrorType
See Also

Reference

FamilySizeTableErrorInfo Class


FamilySizeTableErrorInfo.FilePath Property

FamilySizeTableErrorInfoFilePath Property

The path of the imported CSV file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FilePath { get; }
Public ReadOnly Property FilePath As String
    Get
public:
property String^ FilePath {
    String^ get ();
}
member FilePath : string with get

Property Value

String
See Also

Reference

FamilySizeTableErrorInfo Class


FamilySizeTableErrorInfo.InvalidColumnIndex Property

FamilySizeTableErrorInfoInvalidColumnIndex Property

The index of the invalid column.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int InvalidColumnIndex { get; }
Public ReadOnly Property InvalidColumnIndex As Integer
    Get
public:
property int InvalidColumnIndex {
    int get ();
}
member InvalidColumnIndex : int with get

Property Value

Int32
See Also

Reference

FamilySizeTableErrorInfo Class


FamilySizeTableErrorInfo.InvalidHeaderText Property

FamilySizeTableErrorInfoInvalidHeaderText Property

The invalid header text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string InvalidHeaderText { get; }
Public ReadOnly Property InvalidHeaderText As String
    Get
public:
property String^ InvalidHeaderText {
    String^ get ();
}
member InvalidHeaderText : string with get

Property Value

String
See Also

Reference

FamilySizeTableErrorInfo Class


FamilySizeTableErrorInfo.InvalidRowIndex Property

FamilySizeTableErrorInfoInvalidRowIndex Property

The index of the invalid row.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int InvalidRowIndex { get; }
Public ReadOnly Property InvalidRowIndex As Integer
    Get
public:
property int InvalidRowIndex {
    int get ();
}
member InvalidRowIndex : int with get

Property Value

Int32
See Also

Reference

FamilySizeTableErrorInfo Class


FamilySizeTableErrorInfo.IsValidObject Property

FamilySizeTableErrorInfoIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

FamilySizeTableErrorInfo Class


FamilySizeTableErrorInfo Methods

The FamilySizeTableErrorInfo type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FamilySizeTableErrorInfo Class


FamilySizeTableErrorInfo.Dispose Method

FamilySizeTableErrorInfoDispose Method

Releases all resources used by the FamilySizeTableErrorInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FamilySizeTableErrorInfo Class


FamilySizeTableErrorType Enumeration

The set of errors that can be returned when importing a FamilySizeTable from a CSV file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum FamilySizeTableErrorType
Public Enumeration FamilySizeTableErrorType
public enum class FamilySizeTableErrorType
type FamilySizeTableErrorType
Members
Member name | Value | Description
FileNotFound | 0 | The FamilySize Table CSV file was not found.
CannotOpenFile | 1 | Failed to open the FamilySizeTable CSV file.
CannotReadFile | 2 | Failed to read the FamilySizeTable CSV file.
InvalidHeaderSeparator | 3 | The CSV file header separator is not invalid. Valid header separators are comma(,), semicolon(;), colon(:), and pipe (|).
CannotParseColumnHeader | 4 | Failed to parse the column header of the FamilySizeTable CSV file.
IncorrectNumberOfColumns | 5 | The number of columns in the header row of the FamilySizeTable CSV file is different than the number of columns of data.
Undefined | -1 | Undefined error.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FamilySizeTableManager Class

Manages importing, exporting, and querying size data through the FamilySizeTable class.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFamilySizeTableManager

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FamilySizeTableManager : IDisposable
Public Class FamilySizeTableManager
    Implements IDisposable
public ref class FamilySizeTableManager : IDisposable
type FamilySizeTableManager =
    class
        interface IDisposable
    end

The FamilySizeTableManager type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NumberOfSizeTables | The number of FamilySizeTables in a family.
Top
Methods
 | Name | Description
 | CreateFamilySizeTableManager | Adds FamilySizeTableManager to a Family. A FamilySizeTableManager and FamilySizeTables are only needed when importing, exporting, or removing size data previously stored in CSV files.
Public method | Dispose | Releases all resources used by the FamilySizeTableManager
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ExportSizeTable | Exports the size table to aCSV file.
Public method | GetAllSizeTableNames | Get the FamilySizeTable names in a family.
 | GetFamilySizeTableManager | Gets a FamilySizeTableManager from a Family
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetSizeTable | Get a FamilySizeTable by name.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HasSizeTable | Checks if a FamilySizeTable of a given name exists.
Public method | ImportSizeTable | Imports a FamilySizeTable from a CSV file.
Public method | RemoveSizeTable | Removes the FamilySizeTable of a given name.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FamilySizeTableManager Properties

The FamilySizeTableManager type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NumberOfSizeTables | The number of FamilySizeTables in a family.
Top
See Also

Reference

FamilySizeTableManager Class


FamilySizeTableManager.IsValidObject Property

FamilySizeTableManagerIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

FamilySizeTableManager Class


FamilySizeTableManager.NumberOfSizeTables Property

FamilySizeTableManagerNumberOfSizeTables Property

The number of FamilySizeTables in a family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int NumberOfSizeTables { get; }
Public ReadOnly Property NumberOfSizeTables As Integer
    Get
public:
property int NumberOfSizeTables {
    int get ();
}
member NumberOfSizeTables : int with get

Property Value

Int32
See Also

Reference

FamilySizeTableManager Class


FamilySizeTableManager Methods

The FamilySizeTableManager type exposes the following members.

Methods
 | Name | Description
 | CreateFamilySizeTableManager | Adds FamilySizeTableManager to a Family. A FamilySizeTableManager and FamilySizeTables are only needed when importing, exporting, or removing size data previously stored in CSV files.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ExportSizeTable | Exports the size table to aCSV file.
Public method | GetAllSizeTableNames | Get the FamilySizeTable names in a family.
 | GetFamilySizeTableManager | Gets a FamilySizeTableManager from a Family
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetSizeTable | Get a FamilySizeTable by name.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HasSizeTable | Checks if a FamilySizeTable of a given name exists.
Public method | ImportSizeTable | Imports a FamilySizeTable from a CSV file.
Public method | RemoveSizeTable | Removes the FamilySizeTable of a given name.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FamilySizeTableManager Class


FamilySizeTableManager.CreateFamilySizeTableManager Method

FamilySizeTableManagerCreateFamilySizeTableManager Method

Adds FamilySizeTableManager to a Family. A FamilySizeTableManager and FamilySizeTables are only needed when importing, exporting, or removing size data previously stored in CSV files.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CreateFamilySizeTableManager(
    Document document,
    ElementId familyId
)
Public Shared Function CreateFamilySizeTableManager (
    document As Document,
    familyId As ElementId
) As Boolean
public:
static bool CreateFamilySizeTableManager(
    Document^ document,
    ElementId^ familyId
)
static member CreateFamilySizeTableManager :
        document : Document *
        familyId : ElementId -> bool

Parameters

document Document
Family owned document or project document.
familyId ElementId
ElementId of the Family.

Return Value

Boolean
True if successful, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FamilySizeTableManager Class


FamilySizeTableManager.Dispose Method

FamilySizeTableManagerDispose Method

Releases all resources used by the FamilySizeTableManager

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FamilySizeTableManager Class


FamilySizeTableManager.ExportSizeTable Method

FamilySizeTableManagerExportSizeTable Method

Exports the size table to aCSV file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ExportSizeTable(
    string tableName,
    string filePath
)
Public Function ExportSizeTable (
    tableName As String,
    filePath As String
) As Boolean
public:
bool ExportSizeTable(
    String^ tableName,
    String^ filePath
)
member ExportSizeTable :
        tableName : string *
        filePath : string -> bool

Parameters

tableName String
The bool name to export.
filePath String
The CSV file to export to.

Return Value

Boolean
True if successful, false otherwise..
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FamilySizeTableManager Class


FamilySizeTableManager.GetAllSizeTableNames Method

FamilySizeTableManagerGetAllSizeTableNames Method

Get the FamilySizeTable names in a family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<string> GetAllSizeTableNames()
Public Function GetAllSizeTableNames As IList(Of String)
public:
IList<String^>^ GetAllSizeTableNames()
member GetAllSizeTableNames : unit -> IList<string>

Return Value

IList String
Array of size table names.
See Also

Reference

FamilySizeTableManager Class


FamilySizeTableManager.GetFamilySizeTableManager Method

FamilySizeTableManagerGetFamilySizeTableManager Method

Gets a FamilySizeTableManager from a Family

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FamilySizeTableManager GetFamilySizeTableManager(
    Document document,
    ElementId familyId
)
Public Shared Function GetFamilySizeTableManager (
    document As Document,
    familyId As ElementId
) As FamilySizeTableManager
public:
static FamilySizeTableManager^ GetFamilySizeTableManager(
    Document^ document,
    ElementId^ familyId
)
static member GetFamilySizeTableManager :
        document : Document *
        familyId : ElementId -> FamilySizeTableManager

Parameters

document Document
Family owned document or a project document
familyId ElementId
ElementId of the Family.

Return Value

FamilySizeTableManager
The FamilySizeTableManager of the Family.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FamilySizeTableManager Class


FamilySizeTableManager.GetSizeTable Method

FamilySizeTableManagerGetSizeTable Method

Get a FamilySizeTable by name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilySizeTable GetSizeTable(
    string tableName
)
Public Function GetSizeTable (
    tableName As String
) As FamilySizeTable
public:
FamilySizeTable^ GetSizeTable(
    String^ tableName
)
member GetSizeTable :
        tableName : string -> FamilySizeTable

Parameters

tableName String
The FamilySizeTable name.

Return Value

FamilySizeTable
The FamilySizeTable of a given name.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FamilySizeTableManager Class


FamilySizeTableManager.HasSizeTable Method

FamilySizeTableManagerHasSizeTable Method

Checks if a FamilySizeTable of a given name exists.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasSizeTable(
    string tableName
)
Public Function HasSizeTable (
    tableName As String
) As Boolean
public:
bool HasSizeTable(
    String^ tableName
)
member HasSizeTable :
        tableName : string -> bool

Parameters

tableName String
The name of the FamilySizeTable.

Return Value

Boolean
True if the FamilySizeTable exists, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FamilySizeTableManager Class


FamilySizeTableManager.ImportSizeTable Method

FamilySizeTableManagerImportSizeTable Method

Imports a FamilySizeTable from a CSV file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ImportSizeTable(
    Document document,
    string filePath,
    FamilySizeTableErrorInfo errorInfo
)
Public Function ImportSizeTable (
    document As Document,
    filePath As String,
    errorInfo As FamilySizeTableErrorInfo
) As Boolean
public:
bool ImportSizeTable(
    Document^ document,
    String^ filePath,
    FamilySizeTableErrorInfo^ errorInfo
)
member ImportSizeTable :
        document : Document *
        filePath : string *
        errorInfo : FamilySizeTableErrorInfo -> bool

Parameters

document Document
Family owned document or project document.
filePath String
The CSV file path.
errorInfo FamilySizeTableErrorInfo
An error object to be written to if errors occur.

Return Value

Boolean
True if successful, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FamilySizeTableManager Class


FamilySizeTableManager.RemoveSizeTable Method

FamilySizeTableManagerRemoveSizeTable Method

Removes the FamilySizeTable of a given name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool RemoveSizeTable(
    string tableName
)
Public Function RemoveSizeTable (
    tableName As String
) As Boolean
public:
bool RemoveSizeTable(
    String^ tableName
)
member RemoveSizeTable :
        tableName : string -> bool

Parameters

tableName String
The FamilySizeTable name.

Return Value

Boolean
True if successful, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FamilySizeTableManager Class


FamilySource Enumeration

Describes which version of the family to be loaded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum FamilySource
Public Enumeration FamilySource
public enum class FamilySource
type FamilySource
Members
Member name | Value | Description
Project | 0 | Loading the family from target project document.
Family | 1 | Loading the family from current family document.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FamilySymbol Class

An element that represents a single type with a Family.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBInsertableObject
Autodesk.Revit.DBFamilySymbol
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FamilySymbol : InsertableObject
Public Class FamilySymbol
    Inherits InsertableObject
public ref class FamilySymbol : public InsertableObject
type FamilySymbol =
    class
        inherit InsertableObject
    end

The FamilySymbol type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | Family | The Family object to which the symbol belongs.
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsActive | Identifies whether the symbol is active.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | StructuralMaterialType | This property returns the physical material from which the type is made.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | Activate | Activates the symbol to ensure that its geometry is accessible.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveStructuralSection | Identifies if this FamilySymbol can have a structural section.
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFamilyPointLocations | Returns the Point Locations for the Family Symbol.
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetStructuralSection | Gets the structural section from element.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetThermalProperties | Gets the thermal properties for the given FamilySymbol.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasThermalProperties | Identifies if this FamilySymbol can include thermal properties.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetStructuralSection | Sets the structural section in element.
Public method | SetThermalProperties | Sets the thermal properties for the given FamilySymbol.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Custom families within the Revit API represented by three objects - Family, FamilySymbol and FamilyInstance. Each object plays a significant part in the structure of families. The Family element represents the entire family that consists of a collection of types, such as an 'I Beam'. You can think of that object as representing the entire family file. The Family object contains a number of FamilySymbol elements. The FamilySymbol object represents a specific set of family settings within that Family and represents what is known in the Revit user interface as a Type, such as 'W14x32'. The FamilyInstance object represents an actual instance of that type placed the Autodesk Revit project. For example the FamilyInstance would be a single instance of a W14x32 column within the project.
Example
C#
VB
C++
F#
Copy
public void GetInfo_FamilySymbol(FamilySymbol familySymbol)
{
    string message;
    // Get FamilySymbol family name
    message = "Family name is : " + familySymbol.Family.Name;

    // Get FamilySymbol material
    message += "\nFamilySymbol materials are :";
    foreach (ElementId matid in familySymbol.GetMaterialIds(true))
    {
       Material material = familySymbol.Document.GetElement(matid) as Material;
       if (null != material)
       {
          message += "\n" + material.Name;
       }
    }

    TaskDialog.Show("Revit",message);
}
Public Sub GetInfo_FamilySymbol(familySymbol As FamilySymbol)
   Dim message As String
   ' Get FamilySymbol family name
   message = "Family name is : " & Convert.ToString(familySymbol.Family.Name)

   ' Get FamilySymbol material
   message += vbLf & "FamilySymbol materials are :"
   For Each matid As ElementId In familySymbol.GetMaterialIds(True)
      Dim material As Material = TryCast(familySymbol.Document.GetElement(matid), Material)
      If material IsNot Nothing Then
         message += vbLf + material.Name
      End If
   Next

   TaskDialog.Show("Revit", message)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBInsertableObject
Autodesk.Revit.DBFamilySymbol
Autodesk.Revit.DBAnnotationSymbolType
Autodesk.Revit.DB.ArchitectureRoomTagType
Autodesk.Revit.DBAreaTagType
Autodesk.Revit.DB.MechanicalSpaceTagType
Autodesk.Revit.DBMullionType
Autodesk.Revit.DBPanelType
Autodesk.Revit.DB.StructureTrussType


FamilySymbol Properties

The FamilySymbol type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | Family | The Family object to which the symbol belongs.
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsActive | Identifies whether the symbol is active.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | StructuralMaterialType | This property returns the physical material from which the type is made.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

FamilySymbol Class


FamilySymbol.Family Property

FamilySymbolFamily Property

The Family object to which the symbol belongs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Family Family { get; }
Public ReadOnly Property Family As Family
    Get
public:
property Family^ Family {
    Family^ get ();
}
member Family : Family with get

Property Value

Family
See Also

Reference

FamilySymbol Class


FamilySymbol.IsActive Property

FamilySymbolIsActive Property

Identifies whether the symbol is active.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsActive { get; }
Public ReadOnly Property IsActive As Boolean
    Get
public:
property bool IsActive {
    bool get ();
}
member IsActive : bool with get

Property Value

Boolean
Remarks
Symbols that are not used in the document may be deactivated to conserve memory and regeneration time. When the symbol is inactive, its geometry is empty and cannot be accessed. In order to access the geometry of a symbol that is not active in the document, the symbol should first be activated by calling Activate.
See Also

Reference

FamilySymbol Class


FamilySymbol.StructuralMaterialType Property

FamilySymbolStructuralMaterialType Property

This property returns the physical material from which the type is made.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public StructuralMaterialType StructuralMaterialType { get; }
Public ReadOnly Property StructuralMaterialType As StructuralMaterialType
    Get
public:
property StructuralMaterialType StructuralMaterialType {
    StructuralMaterialType get ();
}
member StructuralMaterialType : StructuralMaterialType with get

Property Value

StructuralMaterialType
Remarks
Values of this property can be Steel, Concrete, Wood or some other material.
See Also

Reference

FamilySymbol Class


FamilySymbol Methods

The FamilySymbol type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Activates the symbol to ensure that its geometry is accessible.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveStructuralSection | Identifies if this FamilySymbol can have a structural section.
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFamilyPointLocations | Returns the Point Locations for the Family Symbol.
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetStructuralSection | Gets the structural section from element.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetThermalProperties | Gets the thermal properties for the given FamilySymbol.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasThermalProperties | Identifies if this FamilySymbol can include thermal properties.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetStructuralSection | Sets the structural section in element.
Public method | SetThermalProperties | Sets the thermal properties for the given FamilySymbol.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FamilySymbol Class


FamilySymbol.Activate Method

FamilySymbolActivate Method

Activates the symbol to ensure that its geometry is accessible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Activate()
Public Sub Activate
public:
void Activate()
member Activate : unit -> unit
Remarks
Symbols that are not used in the document may be deactivated to conserve memory and regeneration time. When the symbol is inactive, its geometry is empty and should not be accessed. In order to access geometry of a symbol that is not active in the document, first check its IsActive property. Note that until the document is regenerated, the newly activated symbol's geometry will still be empty.
See Also

Reference

FamilySymbol Class


FamilySymbol.CanHaveStructuralSection Method

FamilySymbolCanHaveStructuralSection Method

Identifies if this FamilySymbol can have a structural section.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanHaveStructuralSection()
Public Function CanHaveStructuralSection As Boolean
public:
bool CanHaveStructuralSection()
member CanHaveStructuralSection : unit -> bool

Return Value

Boolean
True if the FamilySymbol can have structural section, false otherwise.
See Also

Reference

FamilySymbol Class


FamilySymbol.GetFamilyPointLocations Method

FamilySymbolGetFamilyPointLocations Method

Returns the Point Locations for the Family Symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<FamilyPointLocation> GetFamilyPointLocations()
Public Function GetFamilyPointLocations As IList(Of FamilyPointLocation)
public:
IList<FamilyPointLocation^>^ GetFamilyPointLocations()
member GetFamilyPointLocations : unit -> IList<FamilyPointLocation>

Return Value

IList FamilyPointLocation
Remarks
If a family symbol has point references then their locations are returned by this method, otherwise an empty collection is returned. Examples of FamilySymbol objects that contain point location are Panels and Flexible Components.
See Also

Reference

FamilySymbol Class


FamilySymbol.GetStructuralSection Method

FamilySymbolGetStructuralSection Method

Gets the structural section from element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public StructuralSection GetStructuralSection()
Public Function GetStructuralSection As StructuralSection
public:
StructuralSection^ GetStructuralSection()
member GetStructuralSection : unit -> StructuralSection

Return Value

StructuralSection
The structural section. if the family symbol does not contain a structural section.
Remarks
Only beams, braces and structural columns can have a structural section. To check if the element can have structural section use the [!:Family.HasStructuralSection()] method.
See Also

Reference

FamilySymbol Class


FamilySymbol.GetThermalProperties Method

FamilySymbolGetThermalProperties Method

Gets the thermal properties for the given FamilySymbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyThermalProperties GetThermalProperties()
Public Function GetThermalProperties As FamilyThermalProperties
public:
FamilyThermalProperties^ GetThermalProperties()
member GetThermalProperties : unit -> FamilyThermalProperties

Return Value

FamilyThermalProperties
The thermal properties. if the family symbol does not contain thermal properties.
Remarks
Doors, windows, and curtain wall panels will have thermal properties.
See Also

Reference

FamilySymbol Class


FamilySymbol.HasThermalProperties Method

FamilySymbolHasThermalProperties Method

Identifies if this FamilySymbol can include thermal properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasThermalProperties()
Public Function HasThermalProperties As Boolean
public:
bool HasThermalProperties()
member HasThermalProperties : unit -> bool

Return Value

Boolean
True if the FamilySymbol can include thermal properties, false otherwise.
See Also

Reference

FamilySymbol Class


FamilySymbol.SetStructuralSection Method

FamilySymbolSetStructuralSection Method

Sets the structural section in element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetStructuralSection(
    StructuralSection structuralSection
)
Public Sub SetStructuralSection (
    structuralSection As StructuralSection
)
public:
void SetStructuralSection(
    StructuralSection^ structuralSection
)
member SetStructuralSection :
        structuralSection : StructuralSection -> unit

Parameters

structuralSection StructuralSection
Structural section with values that will be set.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This FamilySymbol cannot have a structural section.
Remarks
Only beams, braces and structural columns can have a structural section. To check if the element can have structural section use the [!:Family.HasStructuralSection()] method.
See Also

Reference

FamilySymbol Class


FamilySymbol.SetThermalProperties Method

FamilySymbolSetThermalProperties Method

Sets the thermal properties for the given FamilySymbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetThermalProperties(
    FamilyThermalProperties thermalProperties
)
Public Sub SetThermalProperties (
    thermalProperties As FamilyThermalProperties
)
public:
void SetThermalProperties(
    FamilyThermalProperties^ thermalProperties
)
member SetThermalProperties :
        thermalProperties : FamilyThermalProperties -> unit

Parameters

thermalProperties FamilyThermalProperties
The new thermal properties. If , this unsets custom thermal properties for this FamilySymbol.
Exceptions
Exception | Condition
ArgumentException | The thermal properties are not valid for assignment.
InvalidOperationException | This FamilySymbol does not contain thermal properties.
See Also

Reference

FamilySymbol Class


FamilySymbolFilter Class

A filter used to find all family symbols of the given family.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementQuickFilter
Autodesk.Revit.DBFamilySymbolFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FamilySymbolFilter : ElementQuickFilter
Public Class FamilySymbolFilter
    Inherits ElementQuickFilter
public ref class FamilySymbolFilter : public ElementQuickFilter
type FamilySymbolFilter =
    class
        inherit ElementQuickFilter
    end

The FamilySymbolFilter type exposes the following members.

Constructors
 | Name | Description
Public method | FamilySymbolFilter | Constructs a new instance of a filter to find all family symbols of the given family.
Top
Properties
 | Name | Description
Public property | FamilyId | The family id.
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

Note that it may be faster to get a list of symbol ids from GetFamilySymbolIds rather than to iterate all of the contents of a document with this filter applied.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FamilySymbolFilter Constructor

Constructs a new instance of a filter to find all family symbols of the given family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilySymbolFilter(
    ElementId familyId
)
Public Sub New (
    familyId As ElementId
)
public:
FamilySymbolFilter(
    ElementId^ familyId
)
new :
        familyId : ElementId -> FamilySymbolFilter

Parameters

familyId ElementId
The family id.
Exceptions
Exception | Condition
ArgumentException | The familyId is invalid.
ArgumentNullException | A non-optional argument was null
See Also

Reference

FamilySymbolFilter Class


FamilySymbolFilter Properties

The FamilySymbolFilter type exposes the following members.

Properties
 | Name | Description
Public property | FamilyId | The family id.
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
See Also

Reference

FamilySymbolFilter Class


FamilySymbolFilter.FamilyId Property

FamilySymbolFilterFamilyId Property

The family id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId FamilyId { get; }
Public ReadOnly Property FamilyId As ElementId
    Get
public:
property ElementId^ FamilyId {
    ElementId^ get ();
}
member FamilyId : ElementId with get

Property Value

ElementId
See Also

Reference

FamilySymbolFilter Class


FamilySymbolFilter Methods

The FamilySymbolFilter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FamilySymbolFilter Class


FamilySymbolProfile Class

Represents a family symbol based profile for sweep or swept blend elements.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBSweepProfile
Autodesk.Revit.DBFamilySymbolProfile

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FamilySymbolProfile : SweepProfile
Public Class FamilySymbolProfile
    Inherits SweepProfile
public ref class FamilySymbolProfile : public SweepProfile
type FamilySymbolProfile =
    class
        inherit SweepProfile
    end

The FamilySymbolProfile type exposes the following members.

Properties
 | Name | Description
Public property | Angle | The angle of the rotation of the profile in radians.
Public property | IsFlipped | Indicates if the symbol profile is flipped or not.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Profile | Returns the family symbol of the profile.
Public property | XOffset | The offset of the profile to the origin of the sketch plane in the X direction.
Public property | YOffset | The offset of the profile to the origin of the sketch plane in the Y direction.
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Use objects of this type in methods as NewSweep() and NewSweptBlend() in FamilyItemFactory to create the profile.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FamilySymbolProfile Properties

The FamilySymbolProfile type exposes the following members.

Properties
 | Name | Description
Public property | Angle | The angle of the rotation of the profile in radians.
Public property | IsFlipped | Indicates if the symbol profile is flipped or not.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Profile | Returns the family symbol of the profile.
Public property | XOffset | The offset of the profile to the origin of the sketch plane in the X direction.
Public property | YOffset | The offset of the profile to the origin of the sketch plane in the Y direction.
Top
See Also

Reference

FamilySymbolProfile Class


FamilySymbolProfile.Angle Property

FamilySymbolProfileAngle Property

The angle of the rotation of the profile in radians.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Angle { get; set; }
Public Property Angle As Double
    Get
    Set
public:
property double Angle {
    double get ();
    void set (double value);
}
member Angle : float with get, set

Property Value

Double
See Also

Reference

FamilySymbolProfile Class


FamilySymbolProfile.IsFlipped Property

FamilySymbolProfileIsFlipped Property

Indicates if the symbol profile is flipped or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsFlipped { get; set; }
Public Property IsFlipped As Boolean
    Get
    Set
public:
property bool IsFlipped {
    bool get ();
    void set (bool value);
}
member IsFlipped : bool with get, set

Property Value

Boolean
See Also

Reference

FamilySymbolProfile Class


FamilySymbolProfile.Profile Property

FamilySymbolProfileProfile Property

Returns the family symbol of the profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilySymbol Profile { get; set; }
Public Property Profile As FamilySymbol
    Get
    Set
public:
property FamilySymbol^ Profile {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}
member Profile : FamilySymbol with get, set

Property Value

FamilySymbol
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the argument is .
ArgumentException | Thrown when the category of argument is not BuiltInCategory.OST_ProfileFamilies.
Remarks
The symbol must of the category BuiltInCategory.OST_ProfileFamilies.
See Also

Reference

FamilySymbolProfile Class


FamilySymbolProfile.XOffset Property

FamilySymbolProfileXOffset Property

The offset of the profile to the origin of the sketch plane in the X direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double XOffset { get; set; }
Public Property XOffset As Double
    Get
    Set
public:
property double XOffset {
    double get ();
    void set (double value);
}
member XOffset : float with get, set

Property Value

Double
See Also

Reference

FamilySymbolProfile Class


FamilySymbolProfile.YOffset Property

FamilySymbolProfileYOffset Property

The offset of the profile to the origin of the sketch plane in the Y direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double YOffset { get; set; }
Public Property YOffset As Double
    Get
    Set
public:
property double YOffset {
    double get ();
    void set (double value);
}
member YOffset : float with get, set

Property Value

Double
See Also

Reference

FamilySymbolProfile Class


FamilySymbolProfile Methods

The FamilySymbolProfile type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FamilySymbolProfile Class


FamilyThermalProperties Class

A class that contains thermal properties for specific types of families (doors, windows, and curtain wall panels).
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFamilyThermalProperties

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FamilyThermalProperties : IDisposable
Public Class FamilyThermalProperties
    Implements IDisposable
public ref class FamilyThermalProperties : IDisposable
type FamilyThermalProperties =
    class
        interface IDisposable
    end

The FamilyThermalProperties type exposes the following members.

Constructors
 | Name | Description
Public method | FamilyThermalProperties | Constructs a new FamilyThermalProperties with default settings.
Top
Properties
 | Name | Description
Public property | AnalyticConstructionName | The construction gbXML name. This value corresponds to the 'Name' property of a constructionType node in Constructions.xml.
Public property | AnalyticConstructionTypeId | The construction gbXML type. This value corresponds to the 'id' property of a constructionType node in Constructions.xml.
Public property | HeatTransferCoefficient | The heat transfer coefficient value (U-Value). The units are watts per meter-squared kelvin (W/(m^2*K)).
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SolarHeatGainCoefficient | The solar heat gain coefficient.
Public property | ThermalResistance | The calculated thermal resistance value (R-Value). The units are meter-squared kelvin per watt ((m^2*K)/Watt).
Public property | VisualLightTransmittance | The visual light transmittance.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the FamilyThermalProperties
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | Find | Finds the thermal properties by the 'id' property of a constructionType node in Constructions.xml.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsValid | Confirms that the thermal properties are correctly set for assignment to a FamilySymbol.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FamilyThermalProperties Constructor

Constructs a new FamilyThermalProperties with default settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyThermalProperties()
Public Sub New
public:
FamilyThermalProperties()
new : unit -> FamilyThermalProperties
See Also

Reference

FamilyThermalProperties Class


FamilyThermalProperties Properties

The FamilyThermalProperties type exposes the following members.

Properties
 | Name | Description
Public property | AnalyticConstructionName | The construction gbXML name. This value corresponds to the 'Name' property of a constructionType node in Constructions.xml.
Public property | AnalyticConstructionTypeId | The construction gbXML type. This value corresponds to the 'id' property of a constructionType node in Constructions.xml.
Public property | HeatTransferCoefficient | The heat transfer coefficient value (U-Value). The units are watts per meter-squared kelvin (W/(m^2*K)).
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SolarHeatGainCoefficient | The solar heat gain coefficient.
Public property | ThermalResistance | The calculated thermal resistance value (R-Value). The units are meter-squared kelvin per watt ((m^2*K)/Watt).
Public property | VisualLightTransmittance | The visual light transmittance.
Top
See Also

Reference

FamilyThermalProperties Class


FamilyThermalProperties.AnalyticConstructionName Property

FamilyThermalPropertiesAnalyticConstructionName Property

The construction gbXML name. This value corresponds to the 'Name' property of a constructionType node in Constructions.xml.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string AnalyticConstructionName { get; }
Public ReadOnly Property AnalyticConstructionName As String
    Get
public:
property String^ AnalyticConstructionName {
    String^ get ();
}
member AnalyticConstructionName : string with get

Property Value

String
See Also

Reference

FamilyThermalProperties Class


FamilyThermalProperties.AnalyticConstructionTypeId Property

FamilyThermalPropertiesAnalyticConstructionTypeId Property

The construction gbXML type. This value corresponds to the 'id' property of a constructionType node in Constructions.xml.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string AnalyticConstructionTypeId { get; }
Public ReadOnly Property AnalyticConstructionTypeId As String
    Get
public:
property String^ AnalyticConstructionTypeId {
    String^ get ();
}
member AnalyticConstructionTypeId : string with get

Property Value

String
See Also

Reference

FamilyThermalProperties Class


FamilyThermalProperties.HeatTransferCoefficient Property

FamilyThermalPropertiesHeatTransferCoefficient Property

The heat transfer coefficient value (U-Value). The units are watts per meter-squared kelvin (W/(m^2*K)).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double HeatTransferCoefficient { get; }
Public ReadOnly Property HeatTransferCoefficient As Double
    Get
public:
property double HeatTransferCoefficient {
    double get ();
}
member HeatTransferCoefficient : float with get

Property Value

Double
See Also

Reference

FamilyThermalProperties Class


FamilyThermalProperties.IsValidObject Property

FamilyThermalPropertiesIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

FamilyThermalProperties Class


FamilyThermalProperties.SolarHeatGainCoefficient Property

FamilyThermalPropertiesSolarHeatGainCoefficient Property

The solar heat gain coefficient.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double SolarHeatGainCoefficient { get; }
Public ReadOnly Property SolarHeatGainCoefficient As Double
    Get
public:
property double SolarHeatGainCoefficient {
    double get ();
}
member SolarHeatGainCoefficient : float with get

Property Value

Double
See Also

Reference

FamilyThermalProperties Class


FamilyThermalProperties.ThermalResistance Property

FamilyThermalPropertiesThermalResistance Property

The calculated thermal resistance value (R-Value). The units are meter-squared kelvin per watt ((m^2*K)/Watt).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double ThermalResistance { get; }
Public ReadOnly Property ThermalResistance As Double
    Get
public:
property double ThermalResistance {
    double get ();
}
member ThermalResistance : float with get

Property Value

Double
See Also

Reference

FamilyThermalProperties Class


FamilyThermalProperties.VisualLightTransmittance Property

FamilyThermalPropertiesVisualLightTransmittance Property

The visual light transmittance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double VisualLightTransmittance { get; }
Public ReadOnly Property VisualLightTransmittance As Double
    Get
public:
property double VisualLightTransmittance {
    double get ();
}
member VisualLightTransmittance : float with get

Property Value

Double
See Also

Reference

FamilyThermalProperties Class


FamilyThermalProperties Methods

The FamilyThermalProperties type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | Find | Finds the thermal properties by the 'id' property of a constructionType node in Constructions.xml.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsValid | Confirms that the thermal properties are correctly set for assignment to a FamilySymbol.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FamilyThermalProperties Class


FamilyThermalProperties.Dispose Method

FamilyThermalPropertiesDispose Method

Releases all resources used by the FamilyThermalProperties

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FamilyThermalProperties Class


FamilyThermalProperties.Find Method

FamilyThermalPropertiesFind Method

Finds the thermal properties by the 'id' property of a constructionType node in Constructions.xml.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FamilyThermalProperties Find(
    Document pADoc,
    string constructionId
)
Public Shared Function Find (
    pADoc As Document,
    constructionId As String
) As FamilyThermalProperties
public:
static FamilyThermalProperties^ Find(
    Document^ pADoc,
    String^ constructionId
)
static member Find :
        pADoc : Document *
        constructionId : string -> FamilyThermalProperties

Parameters

pADoc Document
The document.
constructionId String
The 'id' property of a constructionType node in Constructions.xml

Return Value

FamilyThermalProperties
The thermal properties found, or if no match was found.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FamilyThermalProperties Class


FamilyThermalProperties.IsValid Method

FamilyThermalPropertiesIsValid Method

Confirms that the thermal properties are correctly set for assignment to a FamilySymbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValid()
Public Function IsValid As Boolean
public:
bool IsValid()
member IsValid : unit -> bool

Return Value

Boolean
True if the thermal properties are valid, false otherwise.
See Also

Reference

FamilyThermalProperties Class


FamilyType Class

The family type object provides read access to the values of family parameters for this type.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBFamilyType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FamilyType : APIObject
Public Class FamilyType
    Inherits APIObject
public ref class FamilyType : public APIObject
type FamilyType =
    class
        inherit APIObject
    end

The FamilyType type exposes the following members.

Properties
 | Name | Description
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Name | The name of the family type.
Top
Methods
 | Name | Description
Public method | AsDouble | Provides access to the double precision number of the given family parameter.
Public method | AsElementId | Provides access to the Autodesk::Revit::DB::ElementId^ stored in the given family parameter.
Public method | AsInteger | Provides access to the integer number of the given family parameter.
Public method | AsString | Provides access to the string contents of the given family parameter.
Public method | AsValueString | Provides access to value as a string with unit in the given family parameter.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HasValue | Indicates if this family parameter has an assigned value or not.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FamilyType Properties

The FamilyType type exposes the following members.

Properties
 | Name | Description
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Name | The name of the family type.
Top
See Also

Reference

FamilyType Class


FamilyType.Name Property

FamilyTypeName Property

The name of the family type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

String
See Also

Reference

FamilyType Class


FamilyType Methods

The FamilyType type exposes the following members.

Methods
 | Name | Description
Public method | AsDouble | Provides access to the double precision number of the given family parameter.
Public method | AsElementId | Provides access to the Autodesk::Revit::DB::ElementId^ stored in the given family parameter.
Public method | AsInteger | Provides access to the integer number of the given family parameter.
Public method | AsString | Provides access to the string contents of the given family parameter.
Public method | AsValueString | Provides access to value as a string with unit in the given family parameter.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HasValue | Indicates if this family parameter has an assigned value or not.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FamilyType Class


FamilyType.AsDouble Method

FamilyTypeAsDouble Method

Provides access to the double precision number of the given family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double? AsDouble(
    FamilyParameter familyParameter
)
Public Function AsDouble (
    familyParameter As FamilyParameter
) As Double?
public:
Nullable<double> AsDouble(
    FamilyParameter^ familyParameter
)
member AsDouble :
        familyParameter : FamilyParameter -> Nullable<float>

Parameters

familyParameter FamilyParameter

Return Value

Nullable Double
The double value contained in the parameter. Returns if the storage type of the input argument is not double type or this parameter has no value.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument-"familyParameter"-is .
ArgumentException | Thrown if the input argument-"familyParameter"-is invalid,
See Also

Reference

FamilyType Class


FamilyType.AsElementId Method

FamilyTypeAsElementId Method

Provides access to the Autodesk::Revit::DB::ElementId^ stored in the given family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId AsElementId(
    FamilyParameter familyParameter
)
Public Function AsElementId (
    familyParameter As FamilyParameter
) As ElementId
public:
ElementId^ AsElementId(
    FamilyParameter^ familyParameter
)
member AsElementId :
        familyParameter : FamilyParameter -> ElementId

Parameters

familyParameter FamilyParameter

Return Value

ElementId
The Autodesk::Revit::DB::ElementId^ contained in the parameter.Returns an invalid element id if the storage type of the input argument is Autodesk::Revit::DB::ElementId^ type or this parameter has no value.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument-"familyParameter"-is .
ArgumentException | Thrown if the input argument-"familyParameter"-is invalid,
See Also

Reference

FamilyType Class


FamilyType.AsInteger Method

FamilyTypeAsInteger Method

Provides access to the integer number of the given family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int? AsInteger(
    FamilyParameter familyParameter
)
Public Function AsInteger (
    familyParameter As FamilyParameter
) As Integer?
public:
Nullable<int> AsInteger(
    FamilyParameter^ familyParameter
)
member AsInteger :
        familyParameter : FamilyParameter -> Nullable<int>

Parameters

familyParameter FamilyParameter

Return Value

Nullable Int32
The integer value contained in the parameter. Returns if the storage type of the input argument is not integer type or this parameter has no value.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument-"familyParameter"-is .
ArgumentException | Thrown if the input argument-"familyParameter"-is invalid,
See Also

Reference

FamilyType Class


FamilyType.AsString Method

FamilyTypeAsString Method

Provides access to the string contents of the given family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string AsString(
    FamilyParameter familyParameter
)
Public Function AsString (
    familyParameter As FamilyParameter
) As String
public:
String^ AsString(
    FamilyParameter^ familyParameter
)
member AsString :
        familyParameter : FamilyParameter -> string

Parameters

familyParameter FamilyParameter

Return Value

String
The string contained in the parameter. Returns if the storage type of the input argument is not string type or this parameter has no value.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument-"familyParameter"-is .
ArgumentException | Thrown if the input argument-"familyParameter"-is invalid,
See Also

Reference

FamilyType Class


FamilyType.AsValueString Method

FamilyTypeAsValueString Method

Provides access to value as a string with unit in the given family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string AsValueString(
    FamilyParameter familyParameter
)
Public Function AsValueString (
    familyParameter As FamilyParameter
) As String
public:
String^ AsValueString(
    FamilyParameter^ familyParameter
)
member AsValueString :
        familyParameter : FamilyParameter -> string

Parameters

familyParameter FamilyParameter

Return Value

String
The string that represents the parameter value with unit.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument-"familyParameter"-is .
ArgumentException | Thrown if the input argument-"familyParameter"-is invalid.
Remarks
The method only applies to parameters of value types. If the parameter has no value or does not contain a numeric value, the method returns .
See Also

Reference

FamilyType Class


FamilyType.HasValue Method

FamilyTypeHasValue Method

Indicates if this family parameter has an assigned value or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasValue(
    FamilyParameter familyParameter
)
Public Function HasValue (
    familyParameter As FamilyParameter
) As Boolean
public:
bool HasValue(
    FamilyParameter^ familyParameter
)
member HasValue :
        familyParameter : FamilyParameter -> bool

Parameters

familyParameter FamilyParameter

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument-"familyParameter"-is .
ArgumentException | Thrown if the input argument-"familyParameter"-is invalid.
See Also

Reference

FamilyType Class


FamilyTypeSet Class

A set that contains FamilyType objects.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBFamilyTypeSet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FamilyTypeSet : APIObject,
    IEnumerable
Public Class FamilyTypeSet
    Inherits APIObject
    Implements IEnumerable
public ref class FamilyTypeSet : public APIObject,
    IEnumerable
type FamilyTypeSet =
    class
        inherit APIObject
        interface IEnumerable
    end

The FamilyTypeSet type exposes the following members.

Constructors
 | Name | Description
Public method | FamilyTypeSet | Initializes a new instance of the FamilyTypeSet class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Size | Returns the number of objects that are in the set.
Top
Methods
 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FamilyTypeSet Constructor

Initializes a new instance of the FamilyTypeSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyTypeSet()
Public Sub New
public:
FamilyTypeSet()
new : unit -> FamilyTypeSet
See Also

Reference

FamilyTypeSet Class


FamilyTypeSet Properties

The FamilyTypeSet type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Size | Returns the number of objects that are in the set.
Top
See Also

Reference

FamilyTypeSet Class


FamilyTypeSet.IsEmpty Property

FamilyTypeSetIsEmpty Property

Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Boolean
Remarks
If the set is empty then True will be returned, otherwise False.
See Also

Reference

FamilyTypeSet Class


FamilyTypeSet.Size Property

FamilyTypeSetSize Property

Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
abstract Size : int with get
override Size : int with get

Property Value

Int32
See Also

Reference

FamilyTypeSet Class


FamilyTypeSet Methods

The FamilyTypeSet type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FamilyTypeSet Class


FamilyTypeSet.Clear Method

FamilyTypeSetClear Method

Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

FamilyTypeSet Class


FamilyTypeSet.Contains Method

FamilyTypeSetContains Method

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Contains(
    FamilyType item
)
Public Overridable Function Contains (
    item As FamilyType
) As Boolean
public:
virtual bool Contains(
    FamilyType^ item
)
abstract Contains :
        item : FamilyType -> bool
override Contains :
        item : FamilyType -> bool

Parameters

item FamilyType

Return Value

Boolean
See Also

Reference

FamilyTypeSet Class


FamilyTypeSet.Erase Method

FamilyTypeSetErase Method

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Erase(
    FamilyType item
)
Public Overridable Function Erase (
    item As FamilyType
) As Integer
public:
virtual int Erase(
    FamilyType^ item
)
abstract Erase :
        item : FamilyType -> int
override Erase :
        item : FamilyType -> int

Parameters

item FamilyType

Return Value

Int32
See Also

Reference

FamilyTypeSet Class


FamilyTypeSet.ForwardIterator Method

FamilyTypeSetForwardIterator Method

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual FamilyTypeSetIterator ForwardIterator()
Public Overridable Function ForwardIterator As FamilyTypeSetIterator
public:
virtual FamilyTypeSetIterator^ ForwardIterator()
abstract ForwardIterator : unit -> FamilyTypeSetIterator
override ForwardIterator : unit -> FamilyTypeSetIterator

Return Value

FamilyTypeSetIterator
Returns a forward moving iterator to the set.
See Also

Reference

FamilyTypeSet Class


FamilyTypeSet.GetEnumerator Method

FamilyTypeSetGetEnumerator Method

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

IEnumerator
Returns a forward moving iterator to the set.

Implements

IEnumerableGetEnumerator
See Also

Reference

FamilyTypeSet Class


FamilyTypeSet.Insert Method

FamilyTypeSetInsert Method

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Insert(
    FamilyType item
)
Public Overridable Function Insert (
    item As FamilyType
) As Boolean
public:
virtual bool Insert(
    FamilyType^ item
)
abstract Insert :
        item : FamilyType -> bool
override Insert :
        item : FamilyType -> bool

Parameters

item FamilyType

Return Value

Boolean
See Also

Reference

FamilyTypeSet Class


FamilyTypeSet.ReverseIterator Method

FamilyTypeSetReverseIterator Method

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual FamilyTypeSetIterator ReverseIterator()
Public Overridable Function ReverseIterator As FamilyTypeSetIterator
public:
virtual FamilyTypeSetIterator^ ReverseIterator()
abstract ReverseIterator : unit -> FamilyTypeSetIterator
override ReverseIterator : unit -> FamilyTypeSetIterator

Return Value

FamilyTypeSetIterator
Returns a backward moving iterator to the set.
See Also

Reference

FamilyTypeSet Class


FamilyTypeSetIterator Class

An iterator to a FamilyType set.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBFamilyTypeSetIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class FamilyTypeSetIterator : APIObject,
    IEnumerator
Public MustInherit Class FamilyTypeSetIterator
    Inherits APIObject
    Implements IEnumerator
public ref class FamilyTypeSetIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type FamilyTypeSetIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The FamilyTypeSetIterator type exposes the following members.

Constructors
 | Name | Description
Public method | FamilyTypeSetIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FamilyTypeSetIterator Constructor

For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyTypeSetIterator()
Public Sub New
public:
FamilyTypeSetIterator()
new : unit -> FamilyTypeSetIterator
Remarks
This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.
See Also

Reference

FamilyTypeSetIterator Class


FamilyTypeSetIterator Properties

The FamilyTypeSetIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

FamilyTypeSetIterator Class


FamilyTypeSetIterator.Current Property

FamilyTypeSetIteratorCurrent Property

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}
abstract Current : Object with get
override Current : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.
See Also

Reference

FamilyTypeSetIterator Class


FamilyTypeSetIterator Methods

The FamilyTypeSetIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FamilyTypeSetIterator Class


FamilyTypeSetIterator.MoveNext Method

FamilyTypeSetIteratorMoveNext Method

Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumeratorMoveNext
Remarks
MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.
See Also

Reference

FamilyTypeSetIterator Class


FamilyTypeSetIterator.Reset Method

FamilyTypeSetIteratorReset Method

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
Remarks
The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.
See Also

Reference

FamilyTypeSetIterator Class


FamilyUtils Class

Contains utilities related to family operations.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFamilyUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class FamilyUtils
Public NotInheritable Class FamilyUtils
public ref class FamilyUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type FamilyUtils = class end

The FamilyUtils type exposes the following members.

Methods
Name | Description
ConvertFamilyToFaceHostBased | Converts a family to be face host based.
FamilyCanConvertToFaceHostBased | Indicates whether the family can be converted to face host based.
GetProfileSymbols | Gets the profile Family Symbols of the document.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FamilyUtils Methods

The FamilyUtils type exposes the following members.

Methods
Name | Description
ConvertFamilyToFaceHostBased | Converts a family to be face host based.
FamilyCanConvertToFaceHostBased | Indicates whether the family can be converted to face host based.
GetProfileSymbols | Gets the profile Family Symbols of the document.
Top
See Also

Reference

FamilyUtils Class


FamilyUtils.ConvertFamilyToFaceHostBased Method

FamilyUtilsConvertFamilyToFaceHostBased Method

Converts a family to be face host based.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void ConvertFamilyToFaceHostBased(
    Document document,
    ElementId familyId
)
Public Shared Sub ConvertFamilyToFaceHostBased (
    document As Document,
    familyId As ElementId
)
public:
static void ConvertFamilyToFaceHostBased(
    Document^ document,
    ElementId^ familyId
)
static member ConvertFamilyToFaceHostBased :
        document : Document *
        familyId : ElementId -> unit

Parameters

document Document
The document containing the family to be converted.
familyId ElementId
The family id.
Exceptions
Exception | Condition
ArgumentException | The input familyId cannot be converted to face host based.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Failed to convert the family to face host based. -or- The family is already unhosted.
Remarks
Converts a family hosted by some element other than a face to be hosted by a face. This is done by replacing the existing host (wall, roof, ceiling, floor) with a face. Conversion can succeed only if FamilyUtils.FamilyCanConvertToFaceHostBased() returns true.
See Also

Reference

FamilyUtils Class


FamilyUtils.FamilyCanConvertToFaceHostBased Method

FamilyUtilsFamilyCanConvertToFaceHostBased Method

Indicates whether the family can be converted to face host based.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool FamilyCanConvertToFaceHostBased(
    Document document,
    ElementId familyId
)
Public Shared Function FamilyCanConvertToFaceHostBased (
    document As Document,
    familyId As ElementId
) As Boolean
public:
static bool FamilyCanConvertToFaceHostBased(
    Document^ document,
    ElementId^ familyId
)
static member FamilyCanConvertToFaceHostBased :
        document : Document *
        familyId : ElementId -> bool

Parameters

document Document
The document.
familyId ElementId
The element id of the family.

Return Value

Boolean
True if the family can be converted to face-based. Otherwise false, which will be returned if there any family instances exist in the project, the family is already face-based, or the family does not have a host. Also, false is returned if the family does not belong to one of the following categories:
  • OST_CommunicationDevices
  • OST_DataDevices
  • OST_DuctTerminal
  • OST_ElectricalEquipment
  • OST_ElectricalFixtures
  • OST_FireAlarmDevices
  • OST_LightingDevices
  • OST_LightingFixtures
  • OST_MechanicalControlDevices
  • OST_MechanicalEquipment
  • OST_NurseCallDevices
  • OST_PlumbingEquipment
  • OST_PlumbingFixtures
  • OST_SecurityDevices
  • OST_Sprinklers
  • OST_TelephoneDevices
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FamilyUtils Class


FamilyUtils.GetProfileSymbols Method

FamilyUtilsGetProfileSymbols Method

Gets the profile Family Symbols of the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ICollection<ElementId> GetProfileSymbols(
    Document document,
    ProfileFamilyUsage profileFamilyUsage,
    bool oneCurveLoopOnly
)
Public Shared Function GetProfileSymbols (
    document As Document,
    profileFamilyUsage As ProfileFamilyUsage,
    oneCurveLoopOnly As Boolean
) As ICollection(Of ElementId)
public:
static ICollection<ElementId^>^ GetProfileSymbols(
    Document^ document,
    ProfileFamilyUsage profileFamilyUsage,
    bool oneCurveLoopOnly
)
static member GetProfileSymbols :
        document : Document *
        profileFamilyUsage : ProfileFamilyUsage *
        oneCurveLoopOnly : bool -> ICollection<ElementId>

Parameters

document Document
The document.
profileFamilyUsage ProfileFamilyUsage
The profile family usage.
oneCurveLoopOnly Boolean
Whether or not to return only profiles with one curve loop.

Return Value

ICollection ElementId
The set of profile Family Symbol element ids.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

FamilyUtils Class


FBXExportOptions Class

3D-Studio Max (FBX) Export options.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFBXExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FBXExportOptions
Public Class FBXExportOptions
public ref class FBXExportOptions
type FBXExportOptions = class end

The FBXExportOptions type exposes the following members.

Constructors
 | Name | Description
Public method | FBXExportOptions | Default constructor. Sets all options to their default values.
Top
Properties
 | Name | Description
Public property | LevelsOfDetailValue | The value of the levels of detail.
Public property | StopOnError | Whether export process should stop when a view fails to export.
Public property | UseLevelsOfDetail | True to use levels of detail, false otherwise.
Public property | WithoutBoundaryEdges | True to export without boundary edges, false otherwise.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FBXExportOptions Constructor

Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FBXExportOptions()
Public Sub New
public:
FBXExportOptions()
new : unit -> FBXExportOptions
See Also

Reference

FBXExportOptions Class


FBXExportOptions Properties

The FBXExportOptions type exposes the following members.

Properties
 | Name | Description
Public property | LevelsOfDetailValue | The value of the levels of detail.
Public property | StopOnError | Whether export process should stop when a view fails to export.
Public property | UseLevelsOfDetail | True to use levels of detail, false otherwise.
Public property | WithoutBoundaryEdges | True to export without boundary edges, false otherwise.
Top
See Also

Reference

FBXExportOptions Class


FBXExportOptions.LevelsOfDetailValue Property

FBXExportOptionsLevelsOfDetailValue Property

The value of the levels of detail.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int LevelsOfDetailValue { get; set; }
Public Property LevelsOfDetailValue As Integer
    Get
    Set
public:
property int LevelsOfDetailValue {
    int get ();
    void set (int value);
}
member LevelsOfDetailValue : int with get, set

Property Value

Int32
To use this option, UseLevelsOfDetail should be set to true. And the value should be in the range [0, 15]. It will be calculated based on the settings of current view if it's not assigned a valid value.
See Also

Reference

FBXExportOptions Class


FBXExportOptions.StopOnError Property

FBXExportOptionsStopOnError Property

Whether export process should stop when a view fails to export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool StopOnError { get; set; }
Public Property StopOnError As Boolean
    Get
    Set
public:
property bool StopOnError {
    bool get ();
    void set (bool value);
}
member StopOnError : bool with get, set

Property Value

Boolean
Remarks
If set to false, the export would continue until all views are processed. This option has an effect only when a set of more than one view is specified.
See Also

Reference

FBXExportOptions Class


FBXExportOptions.UseLevelsOfDetail Property

FBXExportOptionsUseLevelsOfDetail Property

True to use levels of detail, false otherwise.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UseLevelsOfDetail { get; set; }
Public Property UseLevelsOfDetail As Boolean
    Get
    Set
public:
property bool UseLevelsOfDetail {
    bool get ();
    void set (bool value);
}
member UseLevelsOfDetail : bool with get, set

Property Value

Boolean
The default value is false.
See Also

Reference

FBXExportOptions Class


FBXExportOptions.WithoutBoundaryEdges Property

FBXExportOptionsWithoutBoundaryEdges Property

True to export without boundary edges, false otherwise.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool WithoutBoundaryEdges { get; set; }
Public Property WithoutBoundaryEdges As Boolean
    Get
    Set
public:
property bool WithoutBoundaryEdges {
    bool get ();
    void set (bool value);
}
member WithoutBoundaryEdges : bool with get, set

Property Value

Boolean
The default value is false.
See Also

Reference

FBXExportOptions Class


FBXExportOptions Methods

The FBXExportOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FBXExportOptions Class


FilePath Class

This class represents a path on a disk or network location, but not a path to a Revit server location.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBModelPath
Autodesk.Revit.DBFilePath

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilePath : ModelPath
Public Class FilePath
    Inherits ModelPath
public ref class FilePath : public ModelPath
type FilePath =
    class
        inherit ModelPath
    end

The FilePath type exposes the following members.

Constructors
 | Name | Description
Public method | FilePath | Constructs a FilePath
Top
Properties
 | Name | Description
Public property | CentralServerPath | The path to the location of the central Revit server or cloud. (Inherited from ModelPath)
Public property | CloudPath | Whether this path represents a path on an Autodesk server such as BIM360. (Inherited from ModelPath)
Public property | Empty | Whether this path is empty (Inherited from ModelPath)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ModelPath)
Public property | Region | The region of the BIM 360 Docs or Autodesk Docs account and project which contains this model. (Inherited from ModelPath)
Public property | ServerPath | Whether this path is a server path (as opposed to a file path or cloud path) (Inherited from ModelPath)
Top
Methods
 | Name | Description
Public method | Compare | Compares this ModelPath with another (Inherited from ModelPath)
Public method | Dispose | (Inherited from ModelPath)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetModelGUID | A GUID identifying the Revit cloud model. (Inherited from ModelPath)
Public method | GetProjectGUID | A GUID identifying the BIM 360 Docs or Autodesk Docs project to which the model is associated. (Inherited from ModelPath)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FilePath Constructor

Constructs a FilePath

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilePath(
    string path
)
Public Sub New (
    path As String
)
public:
FilePath(
    String^ path
)
new :
        path : string -> FilePath

Parameters

path String
The path to the file. This path does not have to be a full path; it can be relative.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FilePath Class


FilePath Properties

The FilePath type exposes the following members.

Properties
 | Name | Description
Public property | CentralServerPath | The path to the location of the central Revit server or cloud. (Inherited from ModelPath)
Public property | CloudPath | Whether this path represents a path on an Autodesk server such as BIM360. (Inherited from ModelPath)
Public property | Empty | Whether this path is empty (Inherited from ModelPath)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ModelPath)
Public property | Region | The region of the BIM 360 Docs or Autodesk Docs account and project which contains this model. (Inherited from ModelPath)
Public property | ServerPath | Whether this path is a server path (as opposed to a file path or cloud path) (Inherited from ModelPath)
Top
See Also

Reference

FilePath Class


FilePath Methods

The FilePath type exposes the following members.

Methods
 | Name | Description
Public method | Compare | Compares this ModelPath with another (Inherited from ModelPath)
Public method | Dispose | (Inherited from ModelPath)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetModelGUID | A GUID identifying the Revit cloud model. (Inherited from ModelPath)
Public method | GetProjectGUID | A GUID identifying the BIM 360 Docs or Autodesk Docs project to which the model is associated. (Inherited from ModelPath)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FilePath Class


FilledRegion Class

A filled region element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBFilledRegion

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilledRegion : Element
Public Class FilledRegion
    Inherits Element
public ref class FilledRegion : public Element
type FilledRegion =
    class
        inherit Element
    end

The FilledRegion type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsMasking | Indicates whether this element is a 'Filled Region or a 'Masking Region'.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create(Document, ElementId, ElementId, IListCurveLoop) | Creates a view-specific filled region from the given boundaries.
 | Create(Document, ElementId, SketchPlane, IListCurveLoop) | Creates a filled region on a sketch plane in a 3d model family.
 | CreateMaskingRegion(Document, ElementId, IListCurveLoop) | Creates a view-specific masking region from the given boundaries.
 | CreateMaskingRegion(Document, SketchPlane, IListCurveLoop) | Creates a masking region on a sketch plane in a 3d model family.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetBoundaries | Gets the boundaries.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
 | GetValidLineStyleIdsForFilledRegion | Gets the line style Ids which are permitted to be assigned to a filled region.
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
 | IsValidFilledRegionTypeId | Indicates whether the given Id is a valid filled region type Id.
 | IsValidLineStyleIdForFilledRegion | Indicates whether the given Id is a valid line style Id.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetLineStyleId | Sets the line style Id for all boundaries.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FilledRegion Properties

The FilledRegion type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsMasking | Indicates whether this element is a 'Filled Region or a 'Masking Region'.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

FilledRegion Class


FilledRegion.IsMasking Property

FilledRegionIsMasking Property

Indicates whether this element is a 'Filled Region or a 'Masking Region'.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsMasking { get; }
Public ReadOnly Property IsMasking As Boolean
    Get
public:
property bool IsMasking {
    bool get ();
}
member IsMasking : bool with get

Property Value

Boolean
See Also

Reference

FilledRegion Class


FilledRegion Methods

The FilledRegion type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create(Document, ElementId, ElementId, IListCurveLoop) | Creates a view-specific filled region from the given boundaries.
 | Create(Document, ElementId, SketchPlane, IListCurveLoop) | Creates a filled region on a sketch plane in a 3d model family.
 | CreateMaskingRegion(Document, ElementId, IListCurveLoop) | Creates a view-specific masking region from the given boundaries.
 | CreateMaskingRegion(Document, SketchPlane, IListCurveLoop) | Creates a masking region on a sketch plane in a 3d model family.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetBoundaries | Gets the boundaries.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
 | GetValidLineStyleIdsForFilledRegion | Gets the line style Ids which are permitted to be assigned to a filled region.
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
 | IsValidFilledRegionTypeId | Indicates whether the given Id is a valid filled region type Id.
 | IsValidLineStyleIdForFilledRegion | Indicates whether the given Id is a valid line style Id.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetLineStyleId | Sets the line style Id for all boundaries.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FilledRegion Class


FilledRegion.Create Method

FilledRegionCreate Method

Overload List
Name | Description
Create(Document, ElementId, ElementId, IListCurveLoop) | Creates a view-specific filled region from the given boundaries.
Create(Document, ElementId, SketchPlane, IListCurveLoop) | Creates a filled region on a sketch plane in a 3d model family.
Top
See Also

Reference

FilledRegion Class


FilledRegion.Create(Document, ElementId, ElementId, IList<CurveLoop>) Method

FilledRegionCreate(Document, ElementId, ElementId, IListCurveLoop) Method

Creates a view-specific filled region from the given boundaries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FilledRegion Create(
    Document document,
    ElementId typeId,
    ElementId viewId,
    IList<CurveLoop> boundaries
)
Public Shared Function Create (
    document As Document,
    typeId As ElementId,
    viewId As ElementId,
    boundaries As IList(Of CurveLoop)
) As FilledRegion
public:
static FilledRegion^ Create(
    Document^ document,
    ElementId^ typeId,
    ElementId^ viewId,
    IList<CurveLoop^>^ boundaries
)
static member Create :
        document : Document *
        typeId : ElementId *
        viewId : ElementId *
        boundaries : IList<CurveLoop> -> FilledRegion

Parameters

document Document
The document in which to create the filled region.
typeId ElementId
The filled region type Id.
viewId ElementId
The view Id.
boundaries IList CurveLoop
The boundaries.

Return Value

FilledRegion
The newly created filled region.
Exceptions
Exception | Condition
ArgumentException | The document is a 3d model family. -or- The Id typeId is invalid. -or- Details can't be drawn in the view. -or- Masking regions and Filled regions can't be created in this document or view. -or- The input curve loops cannot compose a valid boundary, that means: the "curveLoops" collection is empty; or some curve loops intersect with each other; or each curve loop is not closed individually; or each curve loop is not planar; or each curve loop is not in a plane parallel to the view's detail sketch plane; or input curves contain at least one helical curve. -or- Thrown if the viewId or typeId is invalid, or the view does not support the detail items creation, or if the boundaries are empty, open, or self-intersecting.
ArgumentNullException | A non-optional argument was null
Remarks
View-specific filled regions can be created in models and 2d families. The line style of the boundaries will be set to thin lines by default.
See Also

Reference

FilledRegion Class
Create Overload


FilledRegion.Create(Document, ElementId, SketchPlane, IList<CurveLoop>) Method

FilledRegionCreate(Document, ElementId, SketchPlane, IListCurveLoop) Method

Creates a filled region on a sketch plane in a 3d model family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FilledRegion Create(
    Document document,
    ElementId typeId,
    SketchPlane sketchPlane,
    IList<CurveLoop> boundaries
)
Public Shared Function Create (
    document As Document,
    typeId As ElementId,
    sketchPlane As SketchPlane,
    boundaries As IList(Of CurveLoop)
) As FilledRegion
public:
static FilledRegion^ Create(
    Document^ document,
    ElementId^ typeId,
    SketchPlane^ sketchPlane,
    IList<CurveLoop^>^ boundaries
)
static member Create :
        document : Document *
        typeId : ElementId *
        sketchPlane : SketchPlane *
        boundaries : IList<CurveLoop> -> FilledRegion

Parameters

document Document
The family document in which to create the filled region.
typeId ElementId
The filled region type Id.
sketchPlane SketchPlane
The sketch plane for use with the filled region.
boundaries IList CurveLoop
The filled region boundaries, which will be projected onto the sketch plane.

Return Value

FilledRegion
The new filled region.
Exceptions
Exception | Condition
ArgumentException | The document is not a 3d model family. -or- The Id typeId is invalid. -or- Filled regions can't be created in this document or view. -or- The sketch plane is not suitable for model elements. -or- The sketch plane normal is not parallel to the model's X, Y or Z axis. -or- The input curve loops cannot compose a valid boundary, that means: the "curveLoops" collection is empty; or some curve loops intersect with each other; or each curve loop is not closed individually; or each curve loop is not planar; or each curve loop is not in a plane parallel to the sketch plane; or input curves contain at least one helical curve.
ArgumentNullException | A non-optional argument was null
Remarks
If the sketch plane is currently in use, then a copy of the sketch plane will be created and used. The sketch plane normal must be parallel to the model's X, Y or Z axis. The sketch plane can be a planar face reference to model geometry. The line style of the boundaries will be set to thin lines by default.
See Also

Reference

FilledRegion Class
Create Overload


FilledRegion.CreateMaskingRegion Method

FilledRegionCreateMaskingRegion Method

Overload List
Name | Description
CreateMaskingRegion(Document, ElementId, IListCurveLoop) | Creates a view-specific masking region from the given boundaries.
CreateMaskingRegion(Document, SketchPlane, IListCurveLoop) | Creates a masking region on a sketch plane in a 3d model family.
Top
See Also

Reference

FilledRegion Class


FilledRegion.CreateMaskingRegion(Document, ElementId, IList<CurveLoop>) Method

FilledRegionCreateMaskingRegion(Document, ElementId, IListCurveLoop) Method

Creates a view-specific masking region from the given boundaries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FilledRegion CreateMaskingRegion(
    Document document,
    ElementId viewId,
    IList<CurveLoop> boundaries
)
Public Shared Function CreateMaskingRegion (
    document As Document,
    viewId As ElementId,
    boundaries As IList(Of CurveLoop)
) As FilledRegion
public:
static FilledRegion^ CreateMaskingRegion(
    Document^ document,
    ElementId^ viewId,
    IList<CurveLoop^>^ boundaries
)
static member CreateMaskingRegion :
        document : Document *
        viewId : ElementId *
        boundaries : IList<CurveLoop> -> FilledRegion

Parameters

document Document
The document in which to create the masking region.
viewId ElementId
The view Id.
boundaries IList CurveLoop
The boundaries.

Return Value

FilledRegion
The newly created masking region.
Exceptions
Exception | Condition
ArgumentException | The document is a 3d model family. -or- Details can't be drawn in the view. -or- Masking regions and Filled regions can't be created in this document or view. -or- The input curve loops cannot compose a valid boundary, that means: the "curveLoops" collection is empty; or some curve loops intersect with each other; or each curve loop is not closed individually; or each curve loop is not planar; or each curve loop is not in a plane parallel to the view's detail sketch plane; or input curves contain at least one helical curve. -or- Thrown if the viewId is invalid, or the view does not support the detail items creation, or if the boundaries are empty, open, or self-intersecting.
ArgumentNullException | A non-optional argument was null
Remarks
View-specific masking regions can be created in models and 2d families. The line style of the boundaries will be set to thin lines by default.
See Also

Reference

FilledRegion Class
CreateMaskingRegion Overload


FilledRegion.CreateMaskingRegion(Document, SketchPlane, IList<CurveLoop>) Method

FilledRegionCreateMaskingRegion(Document, SketchPlane, IListCurveLoop) Method

Creates a masking region on a sketch plane in a 3d model family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FilledRegion CreateMaskingRegion(
    Document document,
    SketchPlane sketchPlane,
    IList<CurveLoop> boundaries
)
Public Shared Function CreateMaskingRegion (
    document As Document,
    sketchPlane As SketchPlane,
    boundaries As IList(Of CurveLoop)
) As FilledRegion
public:
static FilledRegion^ CreateMaskingRegion(
    Document^ document,
    SketchPlane^ sketchPlane,
    IList<CurveLoop^>^ boundaries
)
static member CreateMaskingRegion :
        document : Document *
        sketchPlane : SketchPlane *
        boundaries : IList<CurveLoop> -> FilledRegion

Parameters

document Document
The family document in which to create the masking region.
sketchPlane SketchPlane
The sketch plane for use with the masking region.
boundaries IList CurveLoop
The masking region boundaries, which will be projected onto the sketch plane.

Return Value

FilledRegion
The new masking region.
Exceptions
Exception | Condition
ArgumentException | The document is not a 3d model family. -or- Filled regions can't be created in this document or view. -or- The sketch plane is not suitable for model elements. -or- The sketch plane normal is not parallel to the model's X, Y or Z axis. -or- The input curve loops cannot compose a valid boundary, that means: the "curveLoops" collection is empty; or some curve loops intersect with each other; or each curve loop is not closed individually; or each curve loop is not planar; or each curve loop is not in a plane parallel to the sketch plane; or input curves contain at least one helical curve.
ArgumentNullException | A non-optional argument was null
Remarks
If the sketch plane is currently in use, then a copy of the sketch plane will be created and used. The sketch plane normal must be parallel to the model's X, Y or Z axis. The sketch plane can be a planar face reference to model geometry. The line style of the boundaries will be set to thin lines by default.
See Also

Reference

FilledRegion Class
CreateMaskingRegion Overload


FilledRegion.GetBoundaries Method

FilledRegionGetBoundaries Method

Gets the boundaries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<CurveLoop> GetBoundaries()
Public Function GetBoundaries As IList(Of CurveLoop)
public:
IList<CurveLoop^>^ GetBoundaries()
member GetBoundaries : unit -> IList<CurveLoop>

Return Value

IList CurveLoop
The filled region boundaries.
See Also

Reference

FilledRegion Class


FilledRegion.GetValidLineStyleIdsForFilledRegion Method

FilledRegionGetValidLineStyleIdsForFilledRegion Method

Gets the line style Ids which are permitted to be assigned to a filled region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<ElementId> GetValidLineStyleIdsForFilledRegion(
    Document document
)
Public Shared Function GetValidLineStyleIdsForFilledRegion (
    document As Document
) As IList(Of ElementId)
public:
static IList<ElementId^>^ GetValidLineStyleIdsForFilledRegion(
    Document^ document
)
static member GetValidLineStyleIdsForFilledRegion :
        document : Document -> IList<ElementId>

Parameters

document Document
The document.

Return Value

IList ElementId
The valid line style Ids.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FilledRegion Class


FilledRegion.IsValidFilledRegionTypeId Method

FilledRegionIsValidFilledRegionTypeId Method

Indicates whether the given Id is a valid filled region type Id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidFilledRegionTypeId(
    Document document,
    ElementId typeId
)
Public Shared Function IsValidFilledRegionTypeId (
    document As Document,
    typeId As ElementId
) As Boolean
public:
static bool IsValidFilledRegionTypeId(
    Document^ document,
    ElementId^ typeId
)
static member IsValidFilledRegionTypeId :
        document : Document *
        typeId : ElementId -> bool

Parameters

document Document
The document.
typeId ElementId
The filled region type Id.

Return Value

Boolean
True if it is a valid filled region type Id, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FilledRegion Class


FilledRegion.IsValidLineStyleIdForFilledRegion Method

FilledRegionIsValidLineStyleIdForFilledRegion Method

Indicates whether the given Id is a valid line style Id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidLineStyleIdForFilledRegion(
    Document document,
    ElementId lineStyleId
)
Public Shared Function IsValidLineStyleIdForFilledRegion (
    document As Document,
    lineStyleId As ElementId
) As Boolean
public:
static bool IsValidLineStyleIdForFilledRegion(
    Document^ document,
    ElementId^ lineStyleId
)
static member IsValidLineStyleIdForFilledRegion :
        document : Document *
        lineStyleId : ElementId -> bool

Parameters

document Document
The document.
lineStyleId ElementId
The line style Id.

Return Value

Boolean
True if it is a valid line style Id, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FilledRegion Class


FilledRegion.SetLineStyleId Method

FilledRegionSetLineStyleId Method

Sets the line style Id for all boundaries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetLineStyleId(
    ElementId lineStyleId
)
Public Sub SetLineStyleId (
    lineStyleId As ElementId
)
public:
void SetLineStyleId(
    ElementId^ lineStyleId
)
member SetLineStyleId :
        lineStyleId : ElementId -> unit

Parameters

lineStyleId ElementId
The line style Id.
Exceptions
Exception | Condition
ArgumentException | lineStyleId is not a valid line style Id for a filled region.
ArgumentNullException | A non-optional argument was null
See Also

Reference

FilledRegion Class


FilledRegionType Class

A filled region attributes element. Note, the forground pattern color is stored in the parent class
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBLineAndTextAttrSymbol
Autodesk.Revit.DBFilledRegionType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilledRegionType : LineAndTextAttrSymbol
Public Class FilledRegionType
    Inherits LineAndTextAttrSymbol
public ref class FilledRegionType : public LineAndTextAttrSymbol
type FilledRegionType =
    class
        inherit LineAndTextAttrSymbol
    end

The FilledRegionType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | BackgroundPatternColor | The background fill pattern color.
Public property | BackgroundPatternId | The background fill pattern Id.
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
Public property | ForegroundPatternColor | The foreground fill pattern color.
Public property | ForegroundPatternId | The foreground fill pattern Id.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsMasking | If true then the FilledRegion will cover the lines and edges of objects behind it. If false then lines and edges will remain visible.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LineWeight | The line weight of the fill pattern.
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidBackgroundPatternId | Check if the id is valid for a background pattern
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidFillPatternId | Check if the id is a FillPatternElement or an invalidElementId
Public method | IsValidForegroundPatternId | Check if the id is valid for a foreground pattern
 | IsValidLineWeight | Indicates whether the given line weight value is valid.
Public method | IsValidMasking | Check that in a family the FillRegionType is always masking.
Public method | IsValidSolidFillPatternId | Checks if the id is valid for a background pattern
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FilledRegionType Properties

The FilledRegionType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | BackgroundPatternColor | The background fill pattern color.
Public property | BackgroundPatternId | The background fill pattern Id.
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
Public property | ForegroundPatternColor | The foreground fill pattern color.
Public property | ForegroundPatternId | The foreground fill pattern Id.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsMasking | If true then the FilledRegion will cover the lines and edges of objects behind it. If false then lines and edges will remain visible.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LineWeight | The line weight of the fill pattern.
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

FilledRegionType Class


FilledRegionType.BackgroundPatternColor Property

FilledRegionTypeBackgroundPatternColor Property

The background fill pattern color.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color BackgroundPatternColor { get; set; }
Public Property BackgroundPatternColor As Color
    Get
    Set
public:
property Color^ BackgroundPatternColor {
    Color^ get ();
    void set (Color^ value);
}
member BackgroundPatternColor : Color with get, set

Property Value

Color
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

FilledRegionType Class


FilledRegionType.BackgroundPatternId Property

FilledRegionTypeBackgroundPatternId Property

The background fill pattern Id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId BackgroundPatternId { get; set; }
Public Property BackgroundPatternId As ElementId
    Get
    Set
public:
property ElementId^ BackgroundPatternId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member BackgroundPatternId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentException | When setting this property: The patternId must either be InvalidElementId or represent a valid FillPatternElement. -or- When setting this property: The patternId must be a 'Drafting' pattern. -or- When setting this property: In a family the patternId can not be a solid fill pattern if the 'IsMasking' property is false.
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
The FillPattern used for a background pattern must have a 'Drafting' target. This applies to both project and family elements. In addition, when the FilledRegionAttributes element is in a family, the pattern cannot be the solid fill pattern unless the 'IsMasking' property is set to true. InvalidElementId is used when there is no background pattern
See Also

Reference

FilledRegionType Class


FilledRegionType.ForegroundPatternColor Property

FilledRegionTypeForegroundPatternColor Property

The foreground fill pattern color.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color ForegroundPatternColor { get; set; }
Public Property ForegroundPatternColor As Color
    Get
    Set
public:
property Color^ ForegroundPatternColor {
    Color^ get ();
    void set (Color^ value);
}
member ForegroundPatternColor : Color with get, set

Property Value

Color
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

FilledRegionType Class


FilledRegionType.ForegroundPatternId Property

FilledRegionTypeForegroundPatternId Property

The foreground fill pattern Id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId ForegroundPatternId { get; set; }
Public Property ForegroundPatternId As ElementId
    Get
    Set
public:
property ElementId^ ForegroundPatternId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member ForegroundPatternId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentException | When setting this property: The patternId must either be InvalidElementId or represent a valid FillPatternElement. -or- When setting this property: In a family the patternId must be a 'Drafting' pattern. -or- When setting this property: In a family the patternId can not be a solid fill pattern if the 'IsMasking' property is false.
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
When the FilledRegionAttributes element is in a family then the FillPattern used for a foreground pattern must have a 'Drafting' target. In addition, when the FilledRegionAttributes element is in a family, the pattern cannot be the solid fill pattern unless the 'IsMasking' property is set to true. InvalidElementId is used when there is no foreground pattern
See Also

Reference

FilledRegionType Class


FilledRegionType.IsMasking Property

FilledRegionTypeIsMasking Property

If true then the FilledRegion will cover the lines and edges of objects behind it. If false then lines and edges will remain visible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsMasking { get; set; }
Public Property IsMasking As Boolean
    Get
    Set
public:
property bool IsMasking {
    bool get ();
    void set (bool value);
}
member IsMasking : bool with get, set

Property Value

Boolean
Exceptions
Exception | Condition
ArgumentException | When setting this property: In a family a FilledRegionType with a solid fill pattern isMasking must always be true.
See Also

Reference

FilledRegionType Class


FilledRegionType.LineWeight Property

FilledRegionTypeLineWeight Property

The line weight of the fill pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int LineWeight { get; set; }
Public Property LineWeight As Integer
    Get
    Set
public:
property int LineWeight {
    int get ();
    void set (int value);
}
member LineWeight : int with get, set

Property Value

Int32
Exceptions
Exception | Condition
ArgumentException | When setting this property: lineWeight is not a valid line weight value (it must be within the range of 1-16).
See Also

Reference

FilledRegionType Class


FilledRegionType Methods

The FilledRegionType type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidBackgroundPatternId | Check if the id is valid for a background pattern
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidFillPatternId | Check if the id is a FillPatternElement or an invalidElementId
Public method | IsValidForegroundPatternId | Check if the id is valid for a foreground pattern
 | IsValidLineWeight | Indicates whether the given line weight value is valid.
Public method | IsValidMasking | Check that in a family the FillRegionType is always masking.
Public method | IsValidSolidFillPatternId | Checks if the id is valid for a background pattern
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FilledRegionType Class


FilledRegionType.IsValidBackgroundPatternId Method

FilledRegionTypeIsValidBackgroundPatternId Method

Check if the id is valid for a background pattern

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidBackgroundPatternId(
    ElementId patternId
)
Public Function IsValidBackgroundPatternId (
    patternId As ElementId
) As Boolean
public:
bool IsValidBackgroundPatternId(
    ElementId^ patternId
)
member IsValidBackgroundPatternId :
        patternId : ElementId -> bool

Parameters

patternId ElementId
Element id of the FillPatternElement

Return Value

Boolean
False if the FillPatternElement is a model pattern. True otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
The FillPatternElement must be a 'Drafting' pattern.
See Also

Reference

FilledRegionType Class


FilledRegionType.IsValidFillPatternId Method

FilledRegionTypeIsValidFillPatternId Method

Check if the id is a FillPatternElement or an invalidElementId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidFillPatternId(
    ElementId patternId
)
Public Function IsValidFillPatternId (
    patternId As ElementId
) As Boolean
public:
bool IsValidFillPatternId(
    ElementId^ patternId
)
member IsValidFillPatternId :
        patternId : ElementId -> bool

Parameters

patternId ElementId
Element id of the FillPatternElement

Return Value

Boolean
True if the id is InvalidElementId, or if the element is a FillPatternElement. False otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FilledRegionType Class


FilledRegionType.IsValidForegroundPatternId Method

FilledRegionTypeIsValidForegroundPatternId Method

Check if the id is valid for a foreground pattern

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidForegroundPatternId(
    ElementId patternId
)
Public Function IsValidForegroundPatternId (
    patternId As ElementId
) As Boolean
public:
bool IsValidForegroundPatternId(
    ElementId^ patternId
)
member IsValidForegroundPatternId :
        patternId : ElementId -> bool

Parameters

patternId ElementId
Element id of the FillPatternElement

Return Value

Boolean
False if in a family, and the id is a FillPatternElement that targets 'Drafting'. True otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
In a family the FillPatternElement must be a 'Drafting' pattern.
See Also

Reference

FilledRegionType Class


FilledRegionType.IsValidLineWeight Method

FilledRegionTypeIsValidLineWeight Method

Indicates whether the given line weight value is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidLineWeight(
    int lineWeight
)
Public Shared Function IsValidLineWeight (
    lineWeight As Integer
) As Boolean
public:
static bool IsValidLineWeight(
    int lineWeight
)
static member IsValidLineWeight :
        lineWeight : int -> bool

Parameters

lineWeight Int32
The line weight.

Return Value

Boolean
True if it is a valid line weight value, false otherwise.
See Also

Reference

FilledRegionType Class


FilledRegionType.IsValidMasking Method

FilledRegionTypeIsValidMasking Method

Check that in a family the FillRegionType is always masking.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidMasking(
    bool isMasking
)
Public Function IsValidMasking (
    isMasking As Boolean
) As Boolean
public:
bool IsValidMasking(
    bool isMasking
)
member IsValidMasking :
        isMasking : bool -> bool

Parameters

isMasking Boolean
The isMasking value to check.

Return Value

Boolean
True if the IsMasking property can be set to the new value.
See Also

Reference

FilledRegionType Class


FilledRegionType.IsValidSolidFillPatternId Method

FilledRegionTypeIsValidSolidFillPatternId Method

Checks if the id is valid for a background pattern

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidSolidFillPatternId(
    ElementId patternId
)
Public Function IsValidSolidFillPatternId (
    patternId As ElementId
) As Boolean
public:
bool IsValidSolidFillPatternId(
    ElementId^ patternId
)
member IsValidSolidFillPatternId :
        patternId : ElementId -> bool

Parameters

patternId ElementId
Element id of the FillPatternElement

Return Value

Boolean
False if in a family and the id is a solid fill pattern and 'isMasking' is masking is false. True otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FilledRegionType Class


FillGrid Class

Represents a grid line in a fill pattern.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFillGrid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FillGrid : IDisposable
Public Class FillGrid
    Implements IDisposable
public ref class FillGrid : IDisposable
type FillGrid =
    class
        interface IDisposable
    end

The FillGrid type exposes the following members.

Constructors
 | Name | Description
Public method | FillGrid | Creates a simple fill grid.
Public method | FillGrid(FillGrid) | Constructs a new FillGrid with default settings.
Public method | FillGrid(Double, Double) | Creates a simple fill grid with given angle and offset.
Top
Properties
 | Name | Description
Public property | Angle | Gets and sets the angle of the fill grid.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Offset | Gets and sets the offset of the fill grid.
Public property | Origin | Gets and sets the origin of the fill grid.
Public property | Shift | Gets and sets the shift of the fill grid.
Top
Methods
 | Name | Description
Public method | CalculateLengthPerArea | Calculates length of the pattern per unit area.
Public method | CalculateLinesPerLength | Calculates the number of solid lines of the pattern per unit length.
Public method | CalculateStrokesPerArea | Calculates the number of the segments of the pattern per unit area.
Public method | Dispose | Releases all resources used by the FillGrid
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetHatchingDirection | Provides the hatching propagation. Hatching is inverted.
Public method | GetPointLineZone(UV) | Gets the index of fill grid line closest to the input 2d point.
Public method | GetPointLineZone(UV, UV) | Gets the index of fill grid line and the point on the grid line nearest to the input point.
Public method | GetSegmentDirection | Provides the segment direction.
Public method | GetSegments | Gets the segments of the fill grid.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqual | Check if two fill grids are equal.
Public method | SetSegments | Sets the segments to the fill grid.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
A grid line is described in the two dimensions of a face as follows: angle, origin, shift, offset, segments
  • Angle specifies the direction, in degrees, of the grid line relative to the x-axis.
  • Parallel lines are drawn as specified by Offset and Shift to fill the entire face. Offset defines the distance between parallel lines. Zero Offset is not allowed. Shift moves the pattern of dashes and spaces along the length of each new parallel line. Shift is ignored if the line is solid.
  • The segments defines a repeating pattern of dashes and spaces for the grid line. If it is omitted, the line is solid. Positive numbers define dashes, negative numbers define spaces, and zero specifies a dot. If you begin a pattern with a space, do not alternate dashes and spaces, or do not end with a space, Revit will introduce tiny dashes or spaces to compensate. Revit expands dots and very short dashes into dashes of a minimum size.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FillGrid Constructor

Overload List
 | Name | Description
Public method | FillGrid | Creates a simple fill grid.
Public method | FillGrid(FillGrid) | Constructs a new FillGrid with default settings.
Public method | FillGrid(Double, Double) | Creates a simple fill grid with given angle and offset.
Top
See Also

Reference

FillGrid Class


FillGrid Constructor

Creates a simple fill grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FillGrid()
Public Sub New
public:
FillGrid()
new : unit -> FillGrid
See Also

Reference

FillGrid Class
FillGrid Overload


FillGrid(FillGrid) Constructor

Constructs a new FillGrid with default settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FillGrid(
    FillGrid other
)
Public Sub New (
    other As FillGrid
)
public:
FillGrid(
    FillGrid^ other
)
new :
        other : FillGrid -> FillGrid

Parameters

other FillGrid
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FillGrid Class
FillGrid Overload


FillGrid(Double, Double) Constructor

Creates a simple fill grid with given angle and offset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FillGrid(
    double angle,
    double offset
)
Public Sub New (
    angle As Double,
    offset As Double
)
public:
FillGrid(
    double angle,
    double offset
)
new :
        angle : float *
        offset : float -> FillGrid

Parameters

angle Double
The angle.
offset Double
The offset represents the spacing between the lines.
See Also

Reference

FillGrid Class
FillGrid Overload


FillGrid Properties

The FillGrid type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets and sets the angle of the fill grid.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Offset | Gets and sets the offset of the fill grid.
Public property | Origin | Gets and sets the origin of the fill grid.
Public property | Shift | Gets and sets the shift of the fill grid.
Top
See Also

Reference

FillGrid Class


FillGrid.Angle Property

FillGridAngle Property

Gets and sets the angle of the fill grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Angle { get; set; }
Public Property Angle As Double
    Get
    Set
public:
property double Angle {
    double get ();
    void set (double value);
}
member Angle : float with get, set

Property Value

Double
See Also

Reference

FillGrid Class


FillGrid.IsValidObject Property

FillGridIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

FillGrid Class


FillGrid.Offset Property

FillGridOffset Property

Gets and sets the offset of the fill grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Offset { get; set; }
Public Property Offset As Double
    Get
    Set
public:
property double Offset {
    double get ();
    void set (double value);
}
member Offset : float with get, set

Property Value

Double
The offset of the fill grid.
Remarks
Offset defines the distance between parallel lines. A zero offset is not allowed.
See Also

Reference

FillGrid Class


FillGrid.Origin Property

FillGridOrigin Property

Gets and sets the origin of the fill grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public UV Origin { get; set; }
Public Property Origin As UV
    Get
    Set
public:
property UV^ Origin {
    UV^ get ();
    void set (UV^ value);
}
member Origin : UV with get, set

Property Value

UV
The origin of the fill grid.
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

FillGrid Class


FillGrid.Shift Property

FillGridShift Property

Gets and sets the shift of the fill grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Shift { get; set; }
Public Property Shift As Double
    Get
    Set
public:
property double Shift {
    double get ();
    void set (double value);
}
member Shift : float with get, set

Property Value

Double
The shift of the fill grid.
Remarks
Shift moves the pattern of dashes and spaces along the length of each new parallel line. Shift is ignored if the line is solid.
See Also

Reference

FillGrid Class


FillGrid Methods

The FillGrid type exposes the following members.

Methods
 | Name | Description
Public method | CalculateLengthPerArea | Calculates length of the pattern per unit area.
Public method | CalculateLinesPerLength | Calculates the number of solid lines of the pattern per unit length.
Public method | CalculateStrokesPerArea | Calculates the number of the segments of the pattern per unit area.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetHatchingDirection | Provides the hatching propagation. Hatching is inverted.
Public method | GetPointLineZone(UV) | Gets the index of fill grid line closest to the input 2d point.
Public method | GetPointLineZone(UV, UV) | Gets the index of fill grid line and the point on the grid line nearest to the input point.
Public method | GetSegmentDirection | Provides the segment direction.
Public method | GetSegments | Gets the segments of the fill grid.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqual | Check if two fill grids are equal.
Public method | SetSegments | Sets the segments to the fill grid.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FillGrid Class


FillGrid.CalculateLengthPerArea Method

FillGridCalculateLengthPerArea Method

Calculates length of the pattern per unit area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double CalculateLengthPerArea()
Public Function CalculateLengthPerArea As Double
public:
double CalculateLengthPerArea()
member CalculateLengthPerArea : unit -> float

Return Value

Double
The length per area.
See Also

Reference

FillGrid Class


FillGrid.CalculateLinesPerLength Method

FillGridCalculateLinesPerLength Method

Calculates the number of solid lines of the pattern per unit length.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double CalculateLinesPerLength()
Public Function CalculateLinesPerLength As Double
public:
double CalculateLinesPerLength()
member CalculateLinesPerLength : unit -> float

Return Value

Double
The solid lines per length.
See Also

Reference

FillGrid Class


FillGrid.CalculateStrokesPerArea Method

FillGridCalculateStrokesPerArea Method

Calculates the number of the segments of the pattern per unit area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double CalculateStrokesPerArea()
Public Function CalculateStrokesPerArea As Double
public:
double CalculateStrokesPerArea()
member CalculateStrokesPerArea : unit -> float

Return Value

Double
The strokes per area.
See Also

Reference

FillGrid Class


FillGrid.Dispose Method

FillGridDispose Method

Releases all resources used by the FillGrid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FillGrid Class


FillGrid.GetHatchingDirection Method

FillGridGetHatchingDirection Method

Provides the hatching propagation. Hatching is inverted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public UV GetHatchingDirection()
Public Function GetHatchingDirection As UV
public:
UV^ GetHatchingDirection()
member GetHatchingDirection : unit -> UV

Return Value

UV
The direction of hatching.
See Also

Reference

FillGrid Class


FillGrid.GetPointLineZone Method

FillGridGetPointLineZone Method

Overload List
 | Name | Description
Public method | GetPointLineZone(UV) | Gets the index of fill grid line closest to the input 2d point.
Public method | GetPointLineZone(UV, UV) | Gets the index of fill grid line and the point on the grid line nearest to the input point.
Top
See Also

Reference

FillGrid Class


FillGrid.GetPointLineZone(UV) Method

FillGridGetPointLineZone(UV) Method

Gets the index of fill grid line closest to the input 2d point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetPointLineZone(
    UV point
)
Public Function GetPointLineZone (
    point As UV
) As Integer
public:
int GetPointLineZone(
    UV^ point
)
member GetPointLineZone :
        point : UV -> int

Parameters

point UV
Input point.

Return Value

Int32
The index of fill grid line.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FillGrid Class
GetPointLineZone Overload


FillGrid.GetPointLineZone(UV, UV) Method

FillGridGetPointLineZone(UV, UV) Method

Gets the index of fill grid line and the point on the grid line nearest to the input point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetPointLineZone(
    UV point,
    out UV nearestPoint
)
Public Function GetPointLineZone (
    point As UV,
    <OutAttribute> ByRef nearestPoint As UV
) As Integer
public:
int GetPointLineZone(
    UV^ point,
    [OutAttribute] UV^% nearestPoint
)
member GetPointLineZone :
        point : UV *
        nearestPoint : UV byref -> int

Parameters

point UV
Input point.
nearestPoint UV
The point on the grid line nearest to the input point.

Return Value

Int32
The index of fill grid line.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FillGrid Class
GetPointLineZone Overload


FillGrid.GetSegmentDirection Method

FillGridGetSegmentDirection Method

Provides the segment direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public UV GetSegmentDirection()
Public Function GetSegmentDirection As UV
public:
UV^ GetSegmentDirection()
member GetSegmentDirection : unit -> UV

Return Value

UV
The direction of segment.
See Also

Reference

FillGrid Class


FillGrid.GetSegments Method

FillGridGetSegments Method

Gets the segments of the fill grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<double> GetSegments()
Public Function GetSegments As IList(Of Double)
public:
IList<double>^ GetSegments()
member GetSegments : unit -> IList<float>

Return Value

IList Double
The segments.
See Also

Reference

FillGrid Class


FillGrid.IsEqual Method

FillGridIsEqual Method

Check if two fill grids are equal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEqual(
    FillGrid other
)
Public Function IsEqual (
    other As FillGrid
) As Boolean
public:
bool IsEqual(
    FillGrid^ other
)
member IsEqual :
        other : FillGrid -> bool

Parameters

other FillGrid
The fill grid to be compared.

Return Value

Boolean
True if the two fill grids are equal, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FillGrid Class


FillGrid.SetSegments Method

FillGridSetSegments Method

Sets the segments to the fill grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetSegments(
    IList<double> segArr
)
Public Sub SetSegments (
    segArr As IList(Of Double)
)
public:
void SetSegments(
    IList<double>^ segArr
)
member SetSegments :
        segArr : IList<float> -> unit

Parameters

segArr IList Double
The segments to be used.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FillGrid Class


FillPattern Class

Represents a fill pattern object.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFillPattern

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FillPattern : IDisposable
Public Class FillPattern
    Implements IDisposable
public ref class FillPattern : IDisposable
type FillPattern =
    class
        interface IDisposable
    end

The FillPattern type exposes the following members.

Constructors
 | Name | Description
Public method | FillPattern | Creates a fill pattern with FillPatternHostOrientation::FPORIENTATION_TO_VIEW and FillPatternTarget::FPTARGET_NONE.
Public method | FillPattern(FillPattern) | Constructs a new copy of the input FillPattern object.
Public method | FillPattern(String, FillPatternTarget, FillPatternHostOrientation) | Creates a fill pattern based on the given name, FillPatternTarget and FillPatternHostOrientation.
Public method | FillPattern(String, FillPatternTarget, FillPatternHostOrientation, Double, Double) | Creates a simple hatch fill pattern based on the given name, angle, spacing, FillPatternTarget and FillPatternHostOrientation.
Public method | FillPattern(String, FillPatternTarget, FillPatternHostOrientation, Double, Double, Double) | Creates a simple crosshatch fill pattern based on the given name, angle, spacing, FillPatternTarget and FillPatternHostOrientation.
Top
Properties
 | Name | Description
Public property | GridCount | Gets the count of the fill grids in this fill pattern.
Public property | HostOrientation | Orientation to host layer.
Public property | IsSolidFill | Check if the fill pattern is a solid fill pattern.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LengthPerArea | Gets length of all lines that placed on unit area.
Public property | LinesPerLength | Gets the number of solid lines that placed in unit length.
Public property | Name | The name of the fill pattern.
Public property | StrokesPerArea | Gets the number of strokes that placed on unit area.
Public property | Target | Target of this fill pattern applied to.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the FillPattern
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ExpandDots | Corrects pattern dots to make them be drawn properly for Revit.
 | ExportToPAT | Export a list of FillPatterns to an AutoCAD PAT file.
Public method | GetFillGrid | Gets the specified fill grid.
Public method | GetFillGrids | Gets all fill grids in this fill pattern
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqual | Check if the contents and the name of the fill pattern is the same as the name and contents of this fill pattern.
Public method | SetFillGrid | Sets the fill grid.
Public method | SetFillGrids | Set the fill grids in this fill pattern.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Fill patterns control the appearance of surfaces that are cut or shown in projection. A simple fill pattern consists of a series of parallel or orthogonal lines. Note - Dots are coded as zero-length dashes in the fill pattern definition. When the Revit graphic engine encounters a zero-length line it simply ignores it and doesn't draw anything. So call ExpandDots() for the patterns you construct to convert dots to small dashes, so that the rendering of the FillPattern is correct.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FillPattern Constructor

Overload List
 | Name | Description
Public method | FillPattern | Creates a fill pattern with FillPatternHostOrientation::FPORIENTATION_TO_VIEW and FillPatternTarget::FPTARGET_NONE.
Public method | FillPattern(FillPattern) | Constructs a new copy of the input FillPattern object.
Public method | FillPattern(String, FillPatternTarget, FillPatternHostOrientation) | Creates a fill pattern based on the given name, FillPatternTarget and FillPatternHostOrientation.
Public method | FillPattern(String, FillPatternTarget, FillPatternHostOrientation, Double, Double) | Creates a simple hatch fill pattern based on the given name, angle, spacing, FillPatternTarget and FillPatternHostOrientation.
Public method | FillPattern(String, FillPatternTarget, FillPatternHostOrientation, Double, Double, Double) | Creates a simple crosshatch fill pattern based on the given name, angle, spacing, FillPatternTarget and FillPatternHostOrientation.
Top
See Also

Reference

FillPattern Class


FillPattern Constructor

Creates a fill pattern with FillPatternHostOrientation::FPORIENTATION_TO_VIEW and FillPatternTarget::FPTARGET_NONE.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FillPattern()
Public Sub New
public:
FillPattern()
new : unit -> FillPattern
See Also

Reference

FillPattern Class
FillPattern Overload


FillPattern(FillPattern) Constructor

Constructs a new copy of the input FillPattern object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FillPattern(
    FillPattern other
)
Public Sub New (
    other As FillPattern
)
public:
FillPattern(
    FillPattern^ other
)
new :
        other : FillPattern -> FillPattern

Parameters

other FillPattern
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FillPattern Class
FillPattern Overload


FillPattern(String, FillPatternTarget, FillPatternHostOrientation) Constructor

Creates a fill pattern based on the given name, FillPatternTarget and FillPatternHostOrientation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FillPattern(
    string name,
    FillPatternTarget target,
    FillPatternHostOrientation orientation
)
Public Sub New (
    name As String,
    target As FillPatternTarget,
    orientation As FillPatternHostOrientation
)
public:
FillPattern(
    String^ name,
    FillPatternTarget target,
    FillPatternHostOrientation orientation
)
new :
        name : string *
        target : FillPatternTarget *
        orientation : FillPatternHostOrientation -> FillPattern

Parameters

name String
The name.
target FillPatternTarget
The fill pattern target.
orientation FillPatternHostOrientation
The fill pattern orientation.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

FillPattern Class
FillPattern Overload


FillPattern(String, FillPatternTarget, FillPatternHostOrientation, Double, Double) Constructor

Creates a simple hatch fill pattern based on the given name, angle, spacing, FillPatternTarget and FillPatternHostOrientation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FillPattern(
    string name,
    FillPatternTarget target,
    FillPatternHostOrientation orientation,
    double angle,
    double spacing1
)
Public Sub New (
    name As String,
    target As FillPatternTarget,
    orientation As FillPatternHostOrientation,
    angle As Double,
    spacing1 As Double
)
public:
FillPattern(
    String^ name,
    FillPatternTarget target,
    FillPatternHostOrientation orientation,
    double angle,
    double spacing1
)
new :
        name : string *
        target : FillPatternTarget *
        orientation : FillPatternHostOrientation *
        angle : float *
        spacing1 : float -> FillPattern

Parameters

name String
The name.
target FillPatternTarget
The fill pattern target.
orientation FillPatternHostOrientation
The fill pattern orientation.
angle Double
The angle.
spacing1 Double
The spacing.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

FillPattern Class
FillPattern Overload


FillPattern(String, FillPatternTarget, FillPatternHostOrientation, Double, Double, Double) Constructor

Creates a simple crosshatch fill pattern based on the given name, angle, spacing, FillPatternTarget and FillPatternHostOrientation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FillPattern(
    string name,
    FillPatternTarget target,
    FillPatternHostOrientation orientation,
    double angle,
    double spacing1,
    double spacing2
)
Public Sub New (
    name As String,
    target As FillPatternTarget,
    orientation As FillPatternHostOrientation,
    angle As Double,
    spacing1 As Double,
    spacing2 As Double
)
public:
FillPattern(
    String^ name,
    FillPatternTarget target,
    FillPatternHostOrientation orientation,
    double angle,
    double spacing1,
    double spacing2
)
new :
        name : string *
        target : FillPatternTarget *
        orientation : FillPatternHostOrientation *
        angle : float *
        spacing1 : float *
        spacing2 : float -> FillPattern

Parameters

name String
The name.
target FillPatternTarget
The fill pattern target.
orientation FillPatternHostOrientation
The fill pattern orientation.
angle Double
The angle.
spacing1 Double
The spacing.
spacing2 Double
The spacing.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

FillPattern Class
FillPattern Overload


FillPattern Properties

The FillPattern type exposes the following members.

Properties
 | Name | Description
Public property | GridCount | Gets the count of the fill grids in this fill pattern.
Public property | HostOrientation | Orientation to host layer.
Public property | IsSolidFill | Check if the fill pattern is a solid fill pattern.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LengthPerArea | Gets length of all lines that placed on unit area.
Public property | LinesPerLength | Gets the number of solid lines that placed in unit length.
Public property | Name | The name of the fill pattern.
Public property | StrokesPerArea | Gets the number of strokes that placed on unit area.
Public property | Target | Target of this fill pattern applied to.
Top
See Also

Reference

FillPattern Class


FillPattern.GridCount Property

FillPatternGridCount Property

Gets the count of the fill grids in this fill pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GridCount { get; }
Public ReadOnly Property GridCount As Integer
    Get
public:
property int GridCount {
    int get ();
}
member GridCount : int with get

Property Value

Int32
See Also

Reference

FillPattern Class


FillPattern.HostOrientation Property

FillPatternHostOrientation Property

Orientation to host layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FillPatternHostOrientation HostOrientation { get; set; }
Public Property HostOrientation As FillPatternHostOrientation
    Get
    Set
public:
property FillPatternHostOrientation HostOrientation {
    FillPatternHostOrientation get ();
    void set (FillPatternHostOrientation value);
}
member HostOrientation : FillPatternHostOrientation with get, set

Property Value

FillPatternHostOrientation
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

FillPattern Class


FillPattern.IsSolidFill Property

FillPatternIsSolidFill Property

Check if the fill pattern is a solid fill pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSolidFill { get; }
Public ReadOnly Property IsSolidFill As Boolean
    Get
public:
property bool IsSolidFill {
    bool get ();
}
member IsSolidFill : bool with get

Property Value

Boolean
See Also

Reference

FillPattern Class


FillPattern.IsValidObject Property

FillPatternIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

FillPattern Class


FillPattern.LengthPerArea Property

FillPatternLengthPerArea Property

Gets length of all lines that placed on unit area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double LengthPerArea { get; }
Public ReadOnly Property LengthPerArea As Double
    Get
public:
property double LengthPerArea {
    double get ();
}
member LengthPerArea : float with get

Property Value

Double
See Also

Reference

FillPattern Class


FillPattern.LinesPerLength Property

FillPatternLinesPerLength Property

Gets the number of solid lines that placed in unit length.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double LinesPerLength { get; }
Public ReadOnly Property LinesPerLength As Double
    Get
public:
property double LinesPerLength {
    double get ();
}
member LinesPerLength : float with get

Property Value

Double
See Also

Reference

FillPattern Class


FillPattern.Name Property

FillPatternName Property

The name of the fill pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
The name of solid fill patterns cannot be changed.
See Also

Reference

FillPattern Class


FillPattern.StrokesPerArea Property

FillPatternStrokesPerArea Property

Gets the number of strokes that placed on unit area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double StrokesPerArea { get; }
Public ReadOnly Property StrokesPerArea As Double
    Get
public:
property double StrokesPerArea {
    double get ();
}
member StrokesPerArea : float with get

Property Value

Double
See Also

Reference

FillPattern Class


FillPattern.Target Property

FillPatternTarget Property

Target of this fill pattern applied to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FillPatternTarget Target { get; set; }
Public Property Target As FillPatternTarget
    Get
    Set
public:
property FillPatternTarget Target {
    FillPatternTarget get ();
    void set (FillPatternTarget value);
}
member Target : FillPatternTarget with get, set

Property Value

FillPatternTarget
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

FillPattern Class


FillPattern Methods

The FillPattern type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ExpandDots | Corrects pattern dots to make them be drawn properly for Revit.
 | ExportToPAT | Export a list of FillPatterns to an AutoCAD PAT file.
Public method | GetFillGrid | Gets the specified fill grid.
Public method | GetFillGrids | Gets all fill grids in this fill pattern
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqual | Check if the contents and the name of the fill pattern is the same as the name and contents of this fill pattern.
Public method | SetFillGrid | Sets the fill grid.
Public method | SetFillGrids | Set the fill grids in this fill pattern.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FillPattern Class


FillPattern.Dispose Method

FillPatternDispose Method

Releases all resources used by the FillPattern

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FillPattern Class


FillPattern.ExpandDots Method

FillPatternExpandDots Method

Corrects pattern dots to make them be drawn properly for Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ExpandDots()
Public Function ExpandDots As Boolean
public:
bool ExpandDots()
member ExpandDots : unit -> bool

Return Value

Boolean
Indicates whether any dots were in fact expanded.
See Also

Reference

FillPattern Class


FillPattern.ExportToPAT Method

FillPatternExportToPAT Method

Export a list of FillPatterns to an AutoCAD PAT file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool ExportToPAT(
    IList<FillPattern> fillPatterns,
    string filename
)
Public Shared Function ExportToPAT (
    fillPatterns As IList(Of FillPattern),
    filename As String
) As Boolean
public:
static bool ExportToPAT(
    IList<FillPattern^>^ fillPatterns,
    String^ filename
)
static member ExportToPAT :
        fillPatterns : IList<FillPattern> *
        filename : string -> bool

Parameters

fillPatterns IList FillPattern
A list of FillPatterns to export.
filename String
The full path of the file to export to.

Return Value

Boolean
True if all patterns were exported successfully, False if export of any pattern failed.
Exceptions
Exception | Condition
ArgumentException | filename is an empty string. -or- fillPatterns is empty. -or- fillPatterns contains the solid fill pattern.
ArgumentNullException | A non-optional argument was null
FileArgumentAlreadyExistsException | filename is pointing to a folder that already exists and cannot be deleted.
InvalidPathArgumentException | The destination file name includes one or more invalid characters.
Remarks

The built-in Solid Fill pattern cannot be expressed in this format.

The PAT file format is ASCII based. FillPatterns with names that contain non-ASCII characters will be exported as 'Pattern_###'. The original name is exported in the description field of the PAT format, encoded as UTF-8.

See Also

Reference

FillPattern Class


FillPattern.GetFillGrid Method

FillPatternGetFillGrid Method

Gets the specified fill grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FillGrid GetFillGrid(
    int gridIdx
)
Public Function GetFillGrid (
    gridIdx As Integer
) As FillGrid
public:
FillGrid^ GetFillGrid(
    int gridIdx
)
member GetFillGrid :
        gridIdx : int -> FillGrid

Parameters

gridIdx Int32
The index of the fill grid.

Return Value

FillGrid
The fill grid.
Exceptions
Exception | Condition
ArgumentException | The index of the FillGrid is not valid.
See Also

Reference

FillPattern Class


FillPattern.GetFillGrids Method

FillPatternGetFillGrids Method

Gets all fill grids in this fill pattern

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<FillGrid> GetFillGrids()
Public Function GetFillGrids As IList(Of FillGrid)
public:
IList<FillGrid^>^ GetFillGrids()
member GetFillGrids : unit -> IList<FillGrid>

Return Value

IList FillGrid
The fill grids.
See Also

Reference

FillPattern Class


FillPattern.IsEqual Method

FillPatternIsEqual Method

Check if the contents and the name of the fill pattern is the same as the name and contents of this fill pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEqual(
    FillPattern other
)
Public Function IsEqual (
    other As FillPattern
) As Boolean
public:
bool IsEqual(
    FillPattern^ other
)
member IsEqual :
        other : FillPattern -> bool

Parameters

other FillPattern
The fill pattern to be compared.

Return Value

Boolean
True for equal, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FillPattern Class


FillPattern.SetFillGrid Method

FillPatternSetFillGrid Method

Sets the fill grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetFillGrid(
    int gridIdx,
    FillGrid fillGrid
)
Public Sub SetFillGrid (
    gridIdx As Integer,
    fillGrid As FillGrid
)
public:
void SetFillGrid(
    int gridIdx,
    FillGrid^ fillGrid
)
member SetFillGrid :
        gridIdx : int *
        fillGrid : FillGrid -> unit

Parameters

gridIdx Int32
The index of the fill grid.
fillGrid FillGrid
The fill grid to be used.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FillPattern Class


FillPattern.SetFillGrids Method

FillPatternSetFillGrids Method

Set the fill grids in this fill pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetFillGrids(
    IList<FillGrid> fillGrids
)
Public Sub SetFillGrids (
    fillGrids As IList(Of FillGrid)
)
public:
void SetFillGrids(
    IList<FillGrid^>^ fillGrids
)
member SetFillGrids :
        fillGrids : IList<FillGrid> -> unit

Parameters

fillGrids IList FillGrid
The fill grids to be used.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FillPattern Class


FillPatternElement Class

An element that represents a fill pattern.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBFillPatternElement

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FillPatternElement : Element
Public Class FillPatternElement
    Inherits Element
public ref class FillPatternElement : public Element
type FillPatternElement =
    class
        inherit Element
    end

The FillPatternElement type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new FillPatternElement.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFillPattern | Gets the FillPattern associated to this element.
 | GetFillPatternElementByName | Retrieves the FillPatternElement by its name.
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetFillPattern | Sets the FillPattern associated to this element.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The FillPatternElement represents a fill pattern in a project. It enables the user to retrieve, modify or create a fill pattern in a project.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FillPatternElement Properties

The FillPatternElement type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

FillPatternElement Class


FillPatternElement Methods

The FillPatternElement type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new FillPatternElement.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFillPattern | Gets the FillPattern associated to this element.
 | GetFillPatternElementByName | Retrieves the FillPatternElement by its name.
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetFillPattern | Sets the FillPattern associated to this element.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FillPatternElement Class


FillPatternElement.Create Method

FillPatternElementCreate Method

Creates a new FillPatternElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FillPatternElement Create(
    Document document,
    FillPattern fillPattern
)
Public Shared Function Create (
    document As Document,
    fillPattern As FillPattern
) As FillPatternElement
public:
static FillPatternElement^ Create(
    Document^ document,
    FillPattern^ fillPattern
)
static member Create :
        document : Document *
        fillPattern : FillPattern -> FillPatternElement

Parameters

document Document
The document in which to create the FillPatternElement.
fillPattern FillPattern
The FillPattern associated to the newly created FillPatternElement.

Return Value

FillPatternElement
The newly created FillPatternElement.
Exceptions
Exception | Condition
ArgumentException | fillPattern does not have a valid Target. -or- fillPattern does not have a valid Name. -or- fillPattern is a solid fill pattern. -or- fillPattern contains FillGrids with a zero Offset. -or- The name of the fillPattern already exists.
ArgumentNullException | A non-optional argument was null
Example
C#
VB
C++
F#
Copy
// Create a complex fill pattern
public void CreateComplexFillPattern(Document doc)
{
    // Create the fill pattern
    FillPattern fillPattern = new FillPattern("API-created", FillPatternTarget.Model,
                                              FillPatternHostOrientation.ToHost);

    // Add grids
    List<FillGrid> grids = new List<FillGrid>();

    //Horizontal lines.
    // The arguments: origin, offset (vertical distance between lines),
    // angle, shift (delta between location of start point per line)
    // The last two arguments are the segments: e.g. 1.0 units on,
    // 0.1 units off (units are Revit units (ft))
    grids.Add(CreateGrid(new UV(0, 0.1), 0.5, 0, 0.55, 1.0, 0.1));
    grids.Add(CreateGrid(new UV(0, 0.5), 0.5, 0, 0.55, 1.0, 0.1));

    // Vertical lines.
    grids.Add(CreateGrid(new UV(0, 0.1), 0.55, Math.PI / 2, 0.5, 0.4, 0.6));
    grids.Add(CreateGrid(new UV(1.0, 0.1), 0.55, Math.PI / 2, 0.5, 0.4, 0.6));

    fillPattern.SetFillGrids(grids);

    // Create the fill pattern element. Now document is modified; transaction is needed
    using (Transaction t = new Transaction(doc, "Create fill pattern"))
    {
       t.Start();
       FillPatternElement patternElement = FillPatternElement.Create(doc, fillPattern);
       t.Commit();
    }
}

// Creates and returns a new fill grid
private FillGrid CreateGrid(UV origin, double offset, double angle,
                            double shift, params double[] segments)
{
    FillGrid fillGrid = new FillGrid();
    fillGrid.Origin = origin;
    fillGrid.Offset = offset;
    fillGrid.Angle = angle;
    fillGrid.Shift = shift;
    List<double> segmentsList = new List<double>();
    foreach (double d in segments)
    {
        segmentsList.Add(d);
    }
    fillGrid.SetSegments(segmentsList);

    return fillGrid;
}
' Create a complex fill pattern
Public Sub CreateComplexFillPattern(doc As Document)
    ' Create the fill pattern
    Dim fillPattern As New FillPattern("API-created", FillPatternTarget.Model, FillPatternHostOrientation.ToHost)

    ' Add grids
    Dim grids As New List(Of FillGrid)()

    'Horizontal lines.
    ' The arguments: origin, offset (vertical distance between lines),
    ' angle, shift (delta between location of start point per line)
    ' The last two arguments are the segments: e.g. 1.0 units on,
    ' 0.1 units off (units are Revit units (ft))
    grids.Add(CreateGrid(New UV(0, 0.1), 0.5, 0, 0.55, 1.0, 0.1))
    grids.Add(CreateGrid(New UV(0, 0.5), 0.5, 0, 0.55, 1.0, 0.1))

    ' Vertical lines.
    grids.Add(CreateGrid(New UV(0, 0.1), 0.55, Math.PI / 2, 0.5, 0.4, 0.6))
    grids.Add(CreateGrid(New UV(1.0, 0.1), 0.55, Math.PI / 2, 0.5, 0.4, 0.6))

    fillPattern.SetFillGrids(grids)

    ' Create the fill pattern element. Now document is modified; transaction is needed
    Using t As New Transaction(doc, "Create fill pattern")
        t.Start()
        Dim patternElement As FillPatternElement = FillPatternElement.Create(doc, fillPattern)
        t.Commit()
    End Using
End Sub

' Creates and returns a new fill grid
Private Function CreateGrid(origin As UV, offset As Double, angle As Double, shift As Double, ParamArray segments As Double()) As FillGrid
    Dim fillGrid As New FillGrid()
    fillGrid.Origin = origin
    fillGrid.Offset = offset
    fillGrid.Angle = angle
    fillGrid.Shift = shift
    Dim segmentsList As New List(Of Double)()
    For Each d As Double In segments
        segmentsList.Add(d)
    Next
    fillGrid.SetSegments(segmentsList)

    Return fillGrid
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

FillPatternElement Class


FillPatternElement.GetFillPattern Method

FillPatternElementGetFillPattern Method

Gets the FillPattern associated to this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FillPattern GetFillPattern()
Public Function GetFillPattern As FillPattern
public:
FillPattern^ GetFillPattern()
member GetFillPattern : unit -> FillPattern

Return Value

FillPattern
A copy of FillPattern object.
See Also

Reference

FillPatternElement Class


FillPatternElement.GetFillPatternElementByName Method

FillPatternElementGetFillPatternElementByName Method

Retrieves the FillPatternElement by its name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FillPatternElement GetFillPatternElementByName(
    Document document,
    FillPatternTarget target,
    string name
)
Public Shared Function GetFillPatternElementByName (
    document As Document,
    target As FillPatternTarget,
    name As String
) As FillPatternElement
public:
static FillPatternElement^ GetFillPatternElementByName(
    Document^ document,
    FillPatternTarget target,
    String^ name
)
static member GetFillPatternElementByName :
        document : Document *
        target : FillPatternTarget *
        name : string -> FillPatternElement

Parameters

document Document
The document in which to retrieve the FillPatternElement.
target FillPatternTarget
The FillPatternTarget of the FillPatternElement.
name String
The name of the FillPatternElement.

Return Value

FillPatternElement
The FillPatternElement.
Exceptions
Exception | Condition
ArgumentException | target must be Model or Drafting.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

FillPatternElement Class


FillPatternElement.SetFillPattern Method

FillPatternElementSetFillPattern Method

Sets the FillPattern associated to this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetFillPattern(
    FillPattern newFillPattern
)
Public Sub SetFillPattern (
    newFillPattern As FillPattern
)
public:
void SetFillPattern(
    FillPattern^ newFillPattern
)
member SetFillPattern :
        newFillPattern : FillPattern -> unit

Parameters

newFillPattern FillPattern
The new FillPattern object.
Exceptions
Exception | Condition
ArgumentException | newFillPattern does not have a valid Target. -or- newFillPattern does not have a valid Name. -or- newFillPattern is a solid fill pattern. -or- newFillPattern contains FillGrids with a zero Offset. -or- The name of the newFillPattern already exists.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The element is the build-in solid fill pattern element and can not be modified.
Remarks
The data stored inside the input FillPattern will be copied into this element. The input FillPattern itself will not be associated with the element.
See Also

Reference

FillPatternElement Class


FillPatternHostOrientation Enumeration

The types of orientations for fill patterns.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum FillPatternHostOrientation
Public Enumeration FillPatternHostOrientation
public enum class FillPatternHostOrientation
type FillPatternHostOrientation
Members
Member name | Value | Description
ToView | 0 | All patterns share the same orientation and origin with respect to view, so they perfectly align at element transitions.
AsText | 1 | Mimics the behavior of text. Patterns align with the host and share the same origin with respect to view.
ToHost | 2 | Patterns align with the host and compute a origin to fit the host.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FillPatternTarget Enumeration

The type of the fill pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum FillPatternTarget
Public Enumeration FillPatternTarget
public enum class FillPatternTarget
type FillPatternTarget
Members
Member name | Value | Description
Drafting | 0 | Represents a material in symbolic form.
Model | 1 | Represents an actual element appearance on a building.
None | 2 |
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FilterableValueProvider Class

Defines the interface for classes that extract values from elements in a Revit project for testing against filter rules.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterableValueProvider
Autodesk.Revit.DBParameterValueProvider

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilterableValueProvider : IDisposable
Public Class FilterableValueProvider
    Implements IDisposable
public ref class FilterableValueProvider : IDisposable
type FilterableValueProvider =
    class
        interface IDisposable
    end

The FilterableValueProvider type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the FilterableValueProvider
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAssociatedGlobalParameterValue | Gets a global parameter value associated with a parameter from the given element.
Public method | GetDoubleValue | Gets a double-precision numeric value from the given element.
Public method | GetElementIdValue | Gets an ElementId value from the given element.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIntegerValue | Gets an integer value from the given element.
Public method | GetStringValue | Gets a string value from the given element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsDoubleValueSupported | Determines whether the provide can provide a double-precision numeric value for the given element.
Public method | IsElementIdValueSupported | Determines whether the provide can provide an ElementId value for the given element.
Public method | IsIntegerValueSupported | Determines whether the provide can provide an integer value for the given element.
Public method | IsStringValueSupported | Determines whether the provide can provide a string value for the given element.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FilterableValueProvider Properties

The FilterableValueProvider type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

FilterableValueProvider Class


FilterableValueProvider.IsValidObject Property

FilterableValueProviderIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

FilterableValueProvider Class


FilterableValueProvider Methods

The FilterableValueProvider type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAssociatedGlobalParameterValue | Gets a global parameter value associated with a parameter from the given element.
Public method | GetDoubleValue | Gets a double-precision numeric value from the given element.
Public method | GetElementIdValue | Gets an ElementId value from the given element.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIntegerValue | Gets an integer value from the given element.
Public method | GetStringValue | Gets a string value from the given element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsDoubleValueSupported | Determines whether the provide can provide a double-precision numeric value for the given element.
Public method | IsElementIdValueSupported | Determines whether the provide can provide an ElementId value for the given element.
Public method | IsIntegerValueSupported | Determines whether the provide can provide an integer value for the given element.
Public method | IsStringValueSupported | Determines whether the provide can provide a string value for the given element.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FilterableValueProvider Class


FilterableValueProvider.Dispose Method

FilterableValueProviderDispose Method

Releases all resources used by the FilterableValueProvider

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FilterableValueProvider Class


FilterableValueProvider.GetAssociatedGlobalParameterValue Method

FilterableValueProviderGetAssociatedGlobalParameterValue Method

Gets a global parameter value associated with a parameter from the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GetAssociatedGlobalParameterValue(
    Element element
)
Public Function GetAssociatedGlobalParameterValue (
    element As Element
) As ElementId
public:
ElementId^ GetAssociatedGlobalParameterValue(
    Element^ element
)
member GetAssociatedGlobalParameterValue :
        element : Element -> ElementId

Parameters

element Element
The element to query.

Return Value

ElementId
The associated global parameter.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FilterableValueProvider Class


FilterableValueProvider.GetDoubleValue Method

FilterableValueProviderGetDoubleValue Method

Gets a double-precision numeric value from the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetDoubleValue(
    Element element
)
Public Function GetDoubleValue (
    element As Element
) As Double
public:
double GetDoubleValue(
    Element^ element
)
member GetDoubleValue :
        element : Element -> float

Parameters

element Element
The element to query.

Return Value

Double
The double-precision numeric value from the element.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FilterableValueProvider Class


FilterableValueProvider.GetElementIdValue Method

FilterableValueProviderGetElementIdValue Method

Gets an ElementId value from the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GetElementIdValue(
    Element element
)
Public Function GetElementIdValue (
    element As Element
) As ElementId
public:
ElementId^ GetElementIdValue(
    Element^ element
)
member GetElementIdValue :
        element : Element -> ElementId

Parameters

element Element
The element to query.

Return Value

ElementId
The ElementId value from the element.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FilterableValueProvider Class


FilterableValueProvider.GetIntegerValue Method

FilterableValueProviderGetIntegerValue Method

Gets an integer value from the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetIntegerValue(
    Element element
)
Public Function GetIntegerValue (
    element As Element
) As Integer
public:
int GetIntegerValue(
    Element^ element
)
member GetIntegerValue :
        element : Element -> int

Parameters

element Element
The element to query.

Return Value

Int32
The integer value from the element.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FilterableValueProvider Class


FilterableValueProvider.GetStringValue Method

FilterableValueProviderGetStringValue Method

Gets a string value from the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetStringValue(
    Element element
)
Public Function GetStringValue (
    element As Element
) As String
public:
String^ GetStringValue(
    Element^ element
)
member GetStringValue :
        element : Element -> string

Parameters

element Element
The element to query.

Return Value

String
The string value from the element.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FilterableValueProvider Class


FilterableValueProvider.IsDoubleValueSupported Method

FilterableValueProviderIsDoubleValueSupported Method

Determines whether the provide can provide a double-precision numeric value for the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsDoubleValueSupported(
    Element element
)
Public Function IsDoubleValueSupported (
    element As Element
) As Boolean
public:
bool IsDoubleValueSupported(
    Element^ element
)
member IsDoubleValueSupported :
        element : Element -> bool

Parameters

element Element
The element to query.

Return Value

Boolean
True if the provider can return a double-precision numeric value for the given element, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FilterableValueProvider Class


FilterableValueProvider.IsElementIdValueSupported Method

FilterableValueProviderIsElementIdValueSupported Method

Determines whether the provide can provide an ElementId value for the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsElementIdValueSupported(
    Element element
)
Public Function IsElementIdValueSupported (
    element As Element
) As Boolean
public:
bool IsElementIdValueSupported(
    Element^ element
)
member IsElementIdValueSupported :
        element : Element -> bool

Parameters

element Element
The element to query.

Return Value

Boolean
True if the provider can return an ElementId value for the given element, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FilterableValueProvider Class


FilterableValueProvider.IsIntegerValueSupported Method

FilterableValueProviderIsIntegerValueSupported Method

Determines whether the provide can provide an integer value for the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsIntegerValueSupported(
    Element element
)
Public Function IsIntegerValueSupported (
    element As Element
) As Boolean
public:
bool IsIntegerValueSupported(
    Element^ element
)
member IsIntegerValueSupported :
        element : Element -> bool

Parameters

element Element
The element to query.

Return Value

Boolean
True if the provider can return an integer value for the given element, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FilterableValueProvider Class


FilterableValueProvider.IsStringValueSupported Method

FilterableValueProviderIsStringValueSupported Method

Determines whether the provide can provide a string value for the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsStringValueSupported(
    Element element
)
Public Function IsStringValueSupported (
    element As Element
) As Boolean
public:
bool IsStringValueSupported(
    Element^ element
)
member IsStringValueSupported :
        element : Element -> bool

Parameters

element Element
The element to query.

Return Value

Boolean
True if the provider can return a string value for the given element, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FilterableValueProvider Class


FilterCategoryRule Class

A filter rule that matches elements of a set of categories.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterRule
Autodesk.Revit.DBFilterCategoryRule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilterCategoryRule : FilterRule
Public Class FilterCategoryRule
    Inherits FilterRule
public ref class FilterCategoryRule : public FilterRule
type FilterCategoryRule =
    class
        inherit FilterRule
    end

The FilterCategoryRule type exposes the following members.

Constructors
 | Name | Description
Public method | FilterCategoryRule | Constructs a new instance of FilterCategoryRule.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule)
Top
Methods
 | Name | Description
 | AllCategoriesFilterable | Checks that all of the given categories are filterable.
Public method | Dispose | (Inherited from FilterRule)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCategories | Gets the rule's categories.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetCategories | Sets the rule's categories.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FilterCategoryRule Constructor

Constructs a new instance of FilterCategoryRule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterCategoryRule(
    ICollection<ElementId> categories
)
Public Sub New (
    categories As ICollection(Of ElementId)
)
public:
FilterCategoryRule(
    ICollection<ElementId^>^ categories
)
new :
        categories : ICollection<ElementId> -> FilterCategoryRule

Parameters

categories ICollection ElementId
The set of categories.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FilterCategoryRule Class


FilterCategoryRule Properties

The FilterCategoryRule type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule)
Top
See Also

Reference

FilterCategoryRule Class


FilterCategoryRule Methods

The FilterCategoryRule type exposes the following members.

Methods
 | Name | Description
 | AllCategoriesFilterable | Checks that all of the given categories are filterable.
Public method | Dispose | (Inherited from FilterRule)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCategories | Gets the rule's categories.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetCategories | Sets the rule's categories.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FilterCategoryRule Class


FilterCategoryRule.AllCategoriesFilterable Method

FilterCategoryRuleAllCategoriesFilterable Method

Checks that all of the given categories are filterable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool AllCategoriesFilterable(
    ICollection<ElementId> categories
)
Public Shared Function AllCategoriesFilterable (
    categories As ICollection(Of ElementId)
) As Boolean
public:
static bool AllCategoriesFilterable(
    ICollection<ElementId^>^ categories
)
static member AllCategoriesFilterable :
        categories : ICollection<ElementId> -> bool

Parameters

categories ICollection ElementId
The set of categories to check.

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FilterCategoryRule Class


FilterCategoryRule.GetCategories Method

FilterCategoryRuleGetCategories Method

Gets the rule's categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetCategories()
Public Function GetCategories As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetCategories()
member GetCategories : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
See Also

Reference

FilterCategoryRule Class


FilterCategoryRule.SetCategories Method

FilterCategoryRuleSetCategories Method

Sets the rule's categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SetCategories(
    ICollection<ElementId> categories
)
Public Function SetCategories (
    categories As ICollection(Of ElementId)
) As Boolean
public:
bool SetCategories(
    ICollection<ElementId^>^ categories
)
member SetCategories :
        categories : ICollection<ElementId> -> bool

Parameters

categories ICollection ElementId
The categories.

Return Value

Boolean
True if the set of categories was changed, false if no change was necessary.
Exceptions
Exception | Condition
ArgumentException | One of the given categories is not filterable
ArgumentNullException | A non-optional argument was null
See Also

Reference

FilterCategoryRule Class


FilterDoubleRule Class

A filter rule that operates on double-precision numeric values in a Revit project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterRule
Autodesk.Revit.DBFilterValueRule
Autodesk.Revit.DBFilterNumericValueRule
Autodesk.Revit.DBFilterDoubleRule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilterDoubleRule : FilterNumericValueRule
Public Class FilterDoubleRule
    Inherits FilterNumericValueRule
public ref class FilterDoubleRule : public FilterNumericValueRule
type FilterDoubleRule =
    class
        inherit FilterNumericValueRule
    end

The FilterDoubleRule type exposes the following members.

Constructors
 | Name | Description
Public method | FilterDoubleRule | Constructs an instance of FilterDoubleRule.
Top
Properties
 | Name | Description
Public property | Epsilon | The tolerance within which two floating-point values may be considered equal.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule)
Public property | RuleValue | The user-supplied value against which values from a Revit document will be tested.
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterRule)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetEvaluator | Gets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetEvaluator | Sets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FilterDoubleRule Constructor

Constructs an instance of FilterDoubleRule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterDoubleRule(
    FilterableValueProvider valueProvider,
    FilterNumericRuleEvaluator evaluator,
    double ruleValue,
    double epsilon
)
Public Sub New (
    valueProvider As FilterableValueProvider,
    evaluator As FilterNumericRuleEvaluator,
    ruleValue As Double,
    epsilon As Double
)
public:
FilterDoubleRule(
    FilterableValueProvider^ valueProvider,
    FilterNumericRuleEvaluator^ evaluator,
    double ruleValue,
    double epsilon
)
new :
        valueProvider : FilterableValueProvider *
        evaluator : FilterNumericRuleEvaluator *
        ruleValue : float *
        epsilon : float -> FilterDoubleRule

Parameters

valueProvider FilterableValueProvider
A pointer to a "value provider" object that will extract values from a Revit document.
evaluator FilterNumericRuleEvaluator
A pointer to the filter rule evaluator object that implements the desired test. The built-in evaluators implement commonly used tests such as less-than, greater-than less-than-or-equal-to, equal, etc.
ruleValue Double
The user-supplied value against which values from a Revit document will be tested.
epsilon Double
The tolerance within which two floating-point values may be considered equal.
Exceptions
Exception | Condition
ArgumentException | The given value for ruleValue is not finite -or- The given value for ruleValue is not a number -or- The given value for epsilon is not finite -or- The given value for epsilon is not a number
ArgumentNullException | A non-optional argument was null
See Also

Reference

FilterDoubleRule Class


FilterDoubleRule Properties

The FilterDoubleRule type exposes the following members.

Properties
 | Name | Description
Public property | Epsilon | The tolerance within which two floating-point values may be considered equal.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule)
Public property | RuleValue | The user-supplied value against which values from a Revit document will be tested.
Top
See Also

Reference

FilterDoubleRule Class


FilterDoubleRule.Epsilon Property

FilterDoubleRuleEpsilon Property

The tolerance within which two floating-point values may be considered equal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Epsilon { get; set; }
Public Property Epsilon As Double
    Get
    Set
public:
property double Epsilon {
    double get ();
    void set (double value);
}
member Epsilon : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentException | When setting this property: The given value for epsilon is not finite -or- When setting this property: The given value for epsilon is not a number
See Also

Reference

FilterDoubleRule Class


FilterDoubleRule.RuleValue Property

FilterDoubleRuleRuleValue Property

The user-supplied value against which values from a Revit document will be tested.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double RuleValue { get; set; }
Public Property RuleValue As Double
    Get
    Set
public:
property double RuleValue {
    double get ();
    void set (double value);
}
member RuleValue : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentException | When setting this property: The given value for ruleValue is not finite -or- When setting this property: The given value for ruleValue is not a number
See Also

Reference

FilterDoubleRule Class


FilterDoubleRule Methods

The FilterDoubleRule type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterRule)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetEvaluator | Gets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetEvaluator | Sets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FilterDoubleRule Class


FilteredElementCollector Class

This class is used to search, filter and iterate through a set of elements.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilteredElementCollector

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilteredElementCollector : IEnumerable<Element>,
    IDisposable
Public Class FilteredElementCollector
    Implements IEnumerable(Of Element), IDisposable
public ref class FilteredElementCollector : IEnumerable<Element^>,
    IDisposable
type FilteredElementCollector =
    class
        interface IEnumerable<Element>
        interface IDisposable
    end

The FilteredElementCollector type exposes the following members.

Constructors
 | Name | Description
Public method | FilteredElementCollector(Document) | Constructs a new FilteredElementCollector that will search and filter the set of elements in a document.
 | FilteredElementCollector(Document, ElementId) | Constructs a new FilteredElementCollector that will search and filter the visible elements in a view.
Public method | FilteredElementCollector(Document, ICollectionElementId) | Constructs a new FilteredElementCollector that will search and filter a specified set of elements.
Public method | FilteredElementCollector(Document, ElementId, ElementId) | Constructs a new FilteredElementCollector that will search and filter the visible elements from a Revit link in a host document view.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | ContainedInDesignOption | Applies an ElementDesignOptionFilter to the collector.
Public method | Dispose | Releases all resources used by the FilteredElementCollector
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Excluding | Applies an ExclusionFilter to the collector.
 | FirstElement | Returns the first element to pass the filter(s).
 | FirstElementId | Returns the id of the first element to pass the filter(s).
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetElementCount | Gets the number of elements in your current filter.
 | GetElementIdIterator | Returns an element id iterator to the elements passing the filters.
 | GetElementIterator | Returns an element iterator to the elements passing the filters.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IntersectWith | Intersects the set of elements passing the filter in this collector with the set of elements passing the filter in another collector.
 | IsViewValidForElementIteration | Identifies if the particular element is valid for iteration of drawn elements.
 | OfCategory | Applies an ElementCategoryFilter to the collector.
Public method | OfCategoryId | Applies an ElementCategoryFilter to the collector.
 | OfClass | Applies an ElementClassFilter to the collector.
Public method | OwnedByView | Applies an ElementOwnerViewFilter to the collector.
Public method | ToElementIds | Returns the complete set of element ids that pass the filter(s).
Public method | ToElements | Returns the complete set of elements that pass the filter(s).
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UnionWith | Unites the set of elements passing the filter in this collector with the set of elements passing the filter in another collector.
Public method | WhereElementIsCurveDriven | Applies an ElementIsCurveDrivenFilter to the collector.
Public method | WhereElementIsElementType | Applies an ElementIsElementTypeFilter to the collector.
Public method | WhereElementIsNotElementType | Applies an inverted ElementIsElementTypeFilter to the collector.
Public method | WhereElementIsViewIndependent | Applies an ElementOwnerViewFilter to the collector.
Public method | WherePasses | Applies an element filter to the collector.
Top
Remarks

Developers can assign a variety of conditions to filter the elements that are returned. This class requires that at least one condition be set before making the attempt to access the elements.

Revit will attempt to organize the filters in order to minimize expansion of elements regardless of the order in which conditions and filters are applied.

There are three groups of methods that you can use on a given collector once you have applied filter(s) to it. One group provides collections of all passing elements, a second finds the first match of the given filter(s), and a third provides an iterator that is evaluated lazily (each element is tested by the filter only when the iterator reaches it). You should only use one of the methods from these group at a time; the collector will reset if you call another method to extract elements. Thus, if you have previously obtained an iterator, it will be stopped and traverse no more elements if you call another method to extract elements.

In .NET, this class supports the IEnumerable interface for Elements. You can use this class with LINQ queries and operations to process lists of elements. Note that because the ElementFilters and the shortcut methods offered by this class process elements in native code before their managed wrappers are generated, better performance will be obtained by using as many native filters as possible on the collector before attempting to process the results using LINQ queries.

One special consideration when using this class in .NET: the debugger will attempt to traverse the members of the collector because of its implementation of IEnumerable. You may see strange results if you also attempt to extract the first element or all elements from the collector while the debugger is also looking at the contents of the collector.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FilteredElementCollector Constructor

Overload List
 | Name | Description
Public method | FilteredElementCollector(Document) | Constructs a new FilteredElementCollector that will search and filter the set of elements in a document.
 | FilteredElementCollector(Document, ElementId) | Constructs a new FilteredElementCollector that will search and filter the visible elements in a view.
Public method | FilteredElementCollector(Document, ICollectionElementId) | Constructs a new FilteredElementCollector that will search and filter a specified set of elements.
Public method | FilteredElementCollector(Document, ElementId, ElementId) | Constructs a new FilteredElementCollector that will search and filter the visible elements from a Revit link in a host document view.
Top
See Also

Reference

FilteredElementCollector Class


FilteredElementCollector(Document) Constructor

Constructs a new FilteredElementCollector that will search and filter the set of elements in a document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilteredElementCollector(
    Document document
)
Public Sub New (
    document As Document
)
public:
FilteredElementCollector(
    Document^ document
)
new :
        document : Document -> FilteredElementCollector

Parameters

document Document
The document.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FilteredElementCollector Class
FilteredElementCollector Overload


FilteredElementCollector(Document, ElementId) Constructor

Constructs a new FilteredElementCollector that will search and filter the visible elements in a view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilteredElementCollector(
    Document document,
    ElementId viewId
)
Public Sub New (
    document As Document,
    viewId As ElementId
)
public:
FilteredElementCollector(
    Document^ document,
    ElementId^ viewId
)
new :
        document : Document *
        viewId : ElementId -> FilteredElementCollector

Parameters

document Document
The document that owns the view.
viewId ElementId
The view id.
Exceptions
Exception | Condition
ArgumentException | viewId is not a view. -or- viewId is not valid for element iteration, because it has no way of representing drawn elements. Many view templates will fail this check.
ArgumentNullException | A non-optional argument was null
Remarks

Elements that will be passed by the collector have graphics that may be visible in the input view. Some elements may still be hidden because they are obscured by other elements.

For elements which are outside of a crop region, they may still be passed by the collector because Revit relies on later processing to eliminate the elements hidden by the crop. This effect may more easily occur for non-rectangular crop regions, but may also happen even for rectangular crops. You can compare the boundary of the region with the element's boundary if more precise results are required.

Accessing these visible elements may require Revit to rebuild the geometry of the view. The first time your code constructs a collector for a given view, or the first time your code constructs a collector for a view whose display settings have just been changed, you may experience a significant performance degradation.

Example
C#
VB
C++
F#
Copy
private void CountElements(UIDocument uiDoc)
{
    StringBuilder message = new StringBuilder();
    FilteredElementCollector viewCollector =
        new FilteredElementCollector(uiDoc.Document, uiDoc.ActiveView.Id);
    viewCollector.OfCategory(BuiltInCategory.OST_Walls);
    message.AppendLine("Wall category elements within active View: "
       + viewCollector.ToElementIds().Count);

    FilteredElementCollector docCollector = new FilteredElementCollector(uiDoc.Document);
    docCollector.OfCategory(BuiltInCategory.OST_Walls);
    message.AppendLine("Wall category elements within document: "
       + docCollector.ToElementIds().Count);

    TaskDialog.Show("Revit", message.ToString());
}
Private Sub CountElements(uiDoc As UIDocument)
   Dim message As New StringBuilder()
   Dim viewCollector As New FilteredElementCollector(uiDoc.Document, uiDoc.ActiveView.Id)
   viewCollector.OfCategory(BuiltInCategory.OST_Walls)
   message.AppendLine("Wall category elements within active View: " + viewCollector.ToElementIds().Count)

   Dim docCollector As New FilteredElementCollector(uiDoc.Document)
   docCollector.OfCategory(BuiltInCategory.OST_Walls)
   message.AppendLine("Wall category elements within document: " + docCollector.ToElementIds().Count)

   TaskDialog.Show("Revit", message.ToString())
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

C#
VB
C++
F#
Copy
public static void GetScheduleContents(ViewSchedule viewSchedule)
{
    // Collect types displayed in the schedule
    FilteredElementCollector typeCollector = new FilteredElementCollector(viewSchedule.Document, viewSchedule.Id);
    typeCollector.WhereElementIsElementType();

    int numberOfTypes = typeCollector.Count();

    // Collect instances displayed in the schedule
    FilteredElementCollector instCollector = new FilteredElementCollector(viewSchedule.Document, viewSchedule.Id);
    instCollector.WhereElementIsNotElementType();

    int numberOfInstances = instCollector.Count();

    TaskDialog.Show("Elements in schedule", String.Format("Types {0} instances {1}", numberOfTypes, numberOfInstances));
}
Public Shared Sub GetScheduleContents(viewSchedule As ViewSchedule)
    ' Collect types displayed in the schedule
    Dim typeCollector As New FilteredElementCollector(viewSchedule.Document, viewSchedule.Id)
    typeCollector.WhereElementIsElementType()

    Dim numberOfTypes As Integer = typeCollector.Count()

    ' Collect instances displayed in the schedule
    Dim instCollector As New FilteredElementCollector(viewSchedule.Document, viewSchedule.Id)
    instCollector.WhereElementIsNotElementType()

    Dim numberOfInstances As Integer = instCollector.Count()

    TaskDialog.Show("Elements in schedule", [String].Format("Types {0} instances {1}", numberOfTypes, numberOfInstances))
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

FilteredElementCollector Class
FilteredElementCollector Overload


FilteredElementCollector(Document, ICollection<ElementId>) Constructor

FilteredElementCollector(Document, ICollectionElementId) Constructor

Constructs a new FilteredElementCollector that will search and filter a specified set of elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilteredElementCollector(
    Document document,
    ICollection<ElementId> elementIds
)
Public Sub New (
    document As Document,
    elementIds As ICollection(Of ElementId)
)
public:
FilteredElementCollector(
    Document^ document,
    ICollection<ElementId^>^ elementIds
)
new :
        document : Document *
        elementIds : ICollection<ElementId> -> FilteredElementCollector

Parameters

document Document
The document that owns the elements matching the element ids.
elementIds ICollection ElementId
The input set of element ids.
Exceptions
Exception | Condition
ArgumentException | The input collection of ids was empty, or its contents were not valid for iteration.
ArgumentNullException | A non-optional argument was null
See Also

Reference

FilteredElementCollector Class
FilteredElementCollector Overload


FilteredElementCollector(Document, ElementId, ElementId) Constructor

Constructs a new FilteredElementCollector that will search and filter the visible elements from a Revit link in a host document view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilteredElementCollector(
    Document hostDocument,
    ElementId viewId,
    ElementId linkId
)
Public Sub New (
    hostDocument As Document,
    viewId As ElementId,
    linkId As ElementId
)
public:
FilteredElementCollector(
    Document^ hostDocument,
    ElementId^ viewId,
    ElementId^ linkId
)
new :
        hostDocument : Document *
        viewId : ElementId *
        linkId : ElementId -> FilteredElementCollector

Parameters

hostDocument Document
The document that owns the view.
viewId ElementId
The view id in the host document.
linkId ElementId
The Revit link instance id in the host document.
Exceptions
Exception | Condition
ArgumentException | viewId is not a view. -or- linkId does not refer to a valid link document. -or- viewId is not valid for element iteration, because it has no way of representing drawn elements. Many view templates will fail this check.
ArgumentNullException | A non-optional argument was null
Remarks

Only visible elements belonging to the link instance will be returned. Other instances of that link may have different element visibility in a given view.

Elements that will be passed by the collector have graphics that may be visible in the input view. Some elements may still be hidden because they are obscured by other elements.

For elements which are outside of a crop region, they may still be passed by the collector because Revit relies on later processing to eliminate the elements hidden by the crop. This effect may more easily occur for non-rectangular crop regions, but may also happen even for rectangular crops. You can compare the boundary of the region with the element's boundary if more precise results are required.

Accessing these visible elements may require Revit to rebuild the geometry of the view. The first time your code constructs a collector for a given view, or the first time your code constructs a collector for a view whose display settings have just been changed, you may experience a significant performance degradation.

See Also

Reference

FilteredElementCollector Class
FilteredElementCollector Overload


FilteredElementCollector Properties

The FilteredElementCollector type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

FilteredElementCollector Class


FilteredElementCollector.IsValidObject Property

FilteredElementCollectorIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

FilteredElementCollector Class


FilteredElementCollector Methods

The FilteredElementCollector type exposes the following members.

Methods
 | Name | Description
Public method | ContainedInDesignOption | Applies an ElementDesignOptionFilter to the collector.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Excluding | Applies an ExclusionFilter to the collector.
 | FirstElement | Returns the first element to pass the filter(s).
 | FirstElementId | Returns the id of the first element to pass the filter(s).
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetElementCount | Gets the number of elements in your current filter.
 | GetElementIdIterator | Returns an element id iterator to the elements passing the filters.
 | GetElementIterator | Returns an element iterator to the elements passing the filters.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IntersectWith | Intersects the set of elements passing the filter in this collector with the set of elements passing the filter in another collector.
 | IsViewValidForElementIteration | Identifies if the particular element is valid for iteration of drawn elements.
 | OfCategory | Applies an ElementCategoryFilter to the collector.
Public method | OfCategoryId | Applies an ElementCategoryFilter to the collector.
 | OfClass | Applies an ElementClassFilter to the collector.
Public method | OwnedByView | Applies an ElementOwnerViewFilter to the collector.
Public method | ToElementIds | Returns the complete set of element ids that pass the filter(s).
Public method | ToElements | Returns the complete set of elements that pass the filter(s).
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UnionWith | Unites the set of elements passing the filter in this collector with the set of elements passing the filter in another collector.
Public method | WhereElementIsCurveDriven | Applies an ElementIsCurveDrivenFilter to the collector.
Public method | WhereElementIsElementType | Applies an ElementIsElementTypeFilter to the collector.
Public method | WhereElementIsNotElementType | Applies an inverted ElementIsElementTypeFilter to the collector.
Public method | WhereElementIsViewIndependent | Applies an ElementOwnerViewFilter to the collector.
Public method | WherePasses | Applies an element filter to the collector.
Top
See Also

Reference

FilteredElementCollector Class


FilteredElementCollector.ContainedInDesignOption Method

FilteredElementCollectorContainedInDesignOption Method

Applies an ElementDesignOptionFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilteredElementCollector ContainedInDesignOption(
    ElementId designOptionId
)
Public Function ContainedInDesignOption (
    designOptionId As ElementId
) As FilteredElementCollector
public:
FilteredElementCollector^ ContainedInDesignOption(
    ElementId^ designOptionId
)
member ContainedInDesignOption :
        designOptionId : ElementId -> FilteredElementCollector

Parameters

designOptionId ElementId
The design option id.

Return Value

FilteredElementCollector
A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Only elements that are contained by this particular design option will pass the collector. If you have an active iterator to this collector it will be stopped by this call.
See Also

Reference

FilteredElementCollector Class


FilteredElementCollector.Dispose Method

FilteredElementCollectorDispose Method

Releases all resources used by the FilteredElementCollector

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FilteredElementCollector Class


FilteredElementCollector.Excluding Method

FilteredElementCollectorExcluding Method

Applies an ExclusionFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilteredElementCollector Excluding(
    ICollection<ElementId> idsToExclude
)
Public Function Excluding (
    idsToExclude As ICollection(Of ElementId)
) As FilteredElementCollector
public:
FilteredElementCollector^ Excluding(
    ICollection<ElementId^>^ idsToExclude
)
member Excluding :
        idsToExclude : ICollection<ElementId> -> FilteredElementCollector

Parameters

idsToExclude ICollection ElementId
The ids to exclude from the results.

Return Value

FilteredElementCollector
A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.
Exceptions
Exception | Condition
ArgumentException | The input collection of ids was empty, or its contents were not valid for iteration.
ArgumentNullException | A non-optional argument was null
Remarks
Elements passed to this filter will be automatically excluded from the results. If you have an active iterator to this collector it will be stopped by this call.
See Also

Reference

FilteredElementCollector Class


FilteredElementCollector.FirstElement Method

FilteredElementCollectorFirstElement Method

Returns the first element to pass the filter(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Element FirstElement()
Public Function FirstElement As Element
public:
Element^ FirstElement()
member FirstElement : unit -> Element

Return Value

Element
The first element.
Exceptions
Exception | Condition
InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.
Remarks
This will reset the collector to the beginning and find the first element that passes the applied filter(s). If you have an active iterator to this same collector it will be stopped by this call.
Example
C#
VB
C++
F#
Copy
public FamilyInstance GetAColumn(Autodesk.Revit.DB.Document document)
{
    // Create a filter to find all columns
    StructuralInstanceUsageFilter columnFilter =
        new StructuralInstanceUsageFilter(StructuralInstanceUsage.Column);

    // Apply the filter to the elements in the active document
    FilteredElementCollector collector = new FilteredElementCollector(document);
    collector.WherePasses(columnFilter);

    // Get the first column from the filtered results
    // Element will be a FamilyInstance
    FamilyInstance column = collector.FirstElement() as FamilyInstance;

    return column;
}
Public Function GetAColumn(document As Autodesk.Revit.DB.Document) As FamilyInstance
   ' Create a filter to find all columns
   Dim columnFilter As New StructuralInstanceUsageFilter(StructuralInstanceUsage.Column)

   ' Apply the filter to the elements in the active document
   Dim collector As New FilteredElementCollector(document)
   collector.WherePasses(columnFilter)

   ' Get the first column from the filtered results
   ' Element will be a FamilyInstance
   Dim column As FamilyInstance = TryCast(collector.FirstElement(), FamilyInstance)

   Return column
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

FilteredElementCollector Class


FilteredElementCollector.FirstElementId Method

FilteredElementCollectorFirstElementId Method

Returns the id of the first element to pass the filter(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId FirstElementId()
Public Function FirstElementId As ElementId
public:
ElementId^ FirstElementId()
member FirstElementId : unit -> ElementId

Return Value

ElementId
The first element id.
Exceptions
Exception | Condition
InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.
Remarks
This will reset the collector to the beginning and find the first element that passes the applied filter(s). If you have an active iterator to this same collector it will be stopped by this call.
Example
C#
VB
C++
F#
Copy
FilteredElementCollector collector = new FilteredElementCollector(document);

// Use shortcut OfClass to get View elements
collector.OfClass(typeof(View3D));

// Get the Id of the first view
ElementId viewId = collector.FirstElementId();

// Test if the view is valid for element filtering
if (FilteredElementCollector.IsViewValidForElementIteration(document, viewId))
{
    FilteredElementCollector viewCollector = new FilteredElementCollector(document, viewId);

    // Get all FamilyInstance items in the view and delete them
    viewCollector.OfClass(typeof(FamilyInstance));
    ICollection<ElementId> familyInstanceIds = viewCollector.ToElementIds();

    document.Delete(familyInstanceIds);
}
Dim collector As New FilteredElementCollector(document)

' Use shortcut OfClass to get View elements
collector.OfClass(GetType(View3D))

' Get the Id of the first view
Dim viewId As ElementId = collector.FirstElementId()

' Test if the view is valid for element filtering
If FilteredElementCollector.IsViewValidForElementIteration(document, viewId) Then
   Dim viewCollector As New FilteredElementCollector(document, viewId)

   ' Get all FamilyInstance items in the view and delete them
   viewCollector.OfClass(GetType(FamilyInstance))
   Dim familyInstanceIds As ICollection(Of ElementId) = viewCollector.ToElementIds()

   document.Delete(familyInstanceIds)
End If

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

FilteredElementCollector Class


FilteredElementCollector.GetBasicIEnumerator Method

FilteredElementCollectorGetBasicIEnumerator Method

Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
internal virtual IEnumerator GetBasicIEnumerator()
Friend Overridable Function GetBasicIEnumerator As IEnumerator
internal:
virtual IEnumerator^ GetBasicIEnumerator()
internal abstract GetBasicIEnumerator : unit -> IEnumerator
internal override GetBasicIEnumerator : unit -> IEnumerator

Return Value

IEnumerator
An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerableGetEnumerator
See Also

Reference

FilteredElementCollector Class


FilteredElementCollector.GetElementCount Method

FilteredElementCollectorGetElementCount Method

Gets the number of elements in your current filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetElementCount()
Public Function GetElementCount As Integer
public:
int GetElementCount()
member GetElementCount : unit -> int

Return Value

Int32
The number of elements
Remarks
Does not require a filter, if called on a new FilteredElementCollector it will return a count of all the elements.
See Also

Reference

FilteredElementCollector Class


FilteredElementCollector.GetElementIdIterator Method

FilteredElementCollectorGetElementIdIterator Method

Returns an element id iterator to the elements passing the filters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilteredElementIdIterator GetElementIdIterator()
Public Function GetElementIdIterator As FilteredElementIdIterator
public:
FilteredElementIdIterator^ GetElementIdIterator()
member GetElementIdIterator : unit -> FilteredElementIdIterator

Return Value

FilteredElementIdIterator
Exceptions
Exception | Condition
InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.
Remarks
Calling this when you have an active iterator to this same collector will result in the first iterator being stopped by this call.
Example
C#
VB
C++
F#
Copy
// Use a RoomFilter to find all room elements in the document.
RoomFilter filter = new RoomFilter();

// Apply the filter to the elements in the active document
FilteredElementCollector collector = new FilteredElementCollector(document);
collector.WherePasses(filter);

// Get results as ElementId iterator
FilteredElementIdIterator roomIdItr = collector.GetElementIdIterator();
roomIdItr.Reset();
while (roomIdItr.MoveNext())
{
    ElementId roomId = roomIdItr.Current;
    // Warn rooms smaller than 50 SF
    Room room = document.GetElement(roomId) as Room;
    if (room.Area < 50.0)
    {
        String prompt = "Room is too small: id = " + roomId.ToString();
        TaskDialog.Show("Revit", prompt);
        break;
    }
}
' Use a RoomFilter to find all room elements in the document.
Dim filter As New RoomFilter()

' Apply the filter to the elements in the active document
Dim collector As New FilteredElementCollector(document)
collector.WherePasses(filter)

' Get results as ElementId iterator
Dim roomIdItr As FilteredElementIdIterator = collector.GetElementIdIterator()
roomIdItr.Reset()
While roomIdItr.MoveNext()
   Dim roomId As ElementId = roomIdItr.Current
   ' Warn rooms smaller than 50 SF
   Dim room As Room = TryCast(document.GetElement(roomId), Room)
   If room.Area < 50.0 Then
      Dim prompt As [String] = "Room is too small: id = " & roomId.ToString()
      TaskDialog.Show("Revit", prompt)
      Exit While
   End If
End While

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

FilteredElementCollector Class


FilteredElementCollector.GetElementIterator Method

FilteredElementCollectorGetElementIterator Method

Returns an element iterator to the elements passing the filters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilteredElementIterator GetElementIterator()
Public Function GetElementIterator As FilteredElementIterator
public:
FilteredElementIterator^ GetElementIterator()
member GetElementIterator : unit -> FilteredElementIterator

Return Value

FilteredElementIterator
Exceptions
Exception | Condition
InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.
Remarks
Calling this when you have an active iterator to this same collector will result in the first iterator being stopped by this call.
Example
C#
VB
C++
F#
Copy
FilteredElementCollector collector = new FilteredElementCollector(document);

// Apply a filter to get all pipes in the document
collector.OfClass(typeof(Autodesk.Revit.DB.Plumbing.Pipe));

// Get results as an element iterator and look for a pipe with
// a specific flow state
FilteredElementIterator elemItr = collector.GetElementIterator();
elemItr.Reset();
while (elemItr.MoveNext())
{
    Pipe pipe = elemItr.Current as Pipe;
    if (pipe.FlowState == PipeFlowState.LaminarState)
    {
        TaskDialog.Show("Revit", "Model has at least one pipe with Laminar flow state.");
        break;
    }
}
Dim collector As New FilteredElementCollector(document)

' Apply a filter to get all pipes in the document
collector.OfClass(GetType(Autodesk.Revit.DB.Plumbing.Pipe))

' Get results as an element iterator and look for a pipe with
' a specific flow state
Dim elemItr As FilteredElementIterator = collector.GetElementIterator()
elemItr.Reset()
While elemItr.MoveNext()
   Dim pipe As Pipe = TryCast(elemItr.Current, Pipe)
   If pipe.FlowState = PipeFlowState.LaminarState Then
      TaskDialog.Show("Revit", "Model has at least one pipe with Laminar flow state.")
      Exit While
   End If
End While

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

FilteredElementCollector Class


FilteredElementCollector.GetEnumerator Method

FilteredElementCollectorGetEnumerator Method

Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator<Element> GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator(Of Element)
public:
virtual IEnumerator<Element^>^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator<Element>
override GetEnumerator : unit -> IEnumerator<Element>

Return Value

IEnumerator Element
An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerableTGetEnumerator
See Also

Reference

FilteredElementCollector Class


FilteredElementCollector.IntersectWith Method

FilteredElementCollectorIntersectWith Method

Intersects the set of elements passing the filter in this collector with the set of elements passing the filter in another collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilteredElementCollector IntersectWith(
    FilteredElementCollector other
)
Public Function IntersectWith (
    other As FilteredElementCollector
) As FilteredElementCollector
public:
FilteredElementCollector^ IntersectWith(
    FilteredElementCollector^ other
)
member IntersectWith :
        other : FilteredElementCollector -> FilteredElementCollector

Parameters

other FilteredElementCollector
The other collector

Return Value

FilteredElementCollector
A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.
Exceptions
Exception | Condition
ArgumentException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.
Remarks
The result will be the same as using a LogicalAndFilter to connect this filter with another. If you have an active iterator to this collector it will be stopped by this call.
See Also

Reference

FilteredElementCollector Class


FilteredElementCollector.IsViewValidForElementIteration Method

FilteredElementCollectorIsViewValidForElementIteration Method

Identifies if the particular element is valid for iteration of drawn elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsViewValidForElementIteration(
    Document document,
    ElementId viewId
)
Public Shared Function IsViewValidForElementIteration (
    document As Document,
    viewId As ElementId
) As Boolean
public:
static bool IsViewValidForElementIteration(
    Document^ document,
    ElementId^ viewId
)
static member IsViewValidForElementIteration :
        document : Document *
        viewId : ElementId -> bool

Parameters

document Document
The document.
viewId ElementId
The view id.

Return Value

Boolean
True if the element is valid for iteration.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Views that have no way of representing drawn elements, such as many view templates, fail this check.
See Also

Reference

FilteredElementCollector Class


FilteredElementCollector.OfCategory Method

FilteredElementCollectorOfCategory Method

Applies an ElementCategoryFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilteredElementCollector OfCategory(
    BuiltInCategory category
)
Public Function OfCategory (
    category As BuiltInCategory
) As FilteredElementCollector
public:
FilteredElementCollector^ OfCategory(
    BuiltInCategory category
)
member OfCategory :
        category : BuiltInCategory -> FilteredElementCollector

Parameters

category BuiltInCategory
The category.

Return Value

FilteredElementCollector
This collector.
Remarks
Only elements of this category id will pass the collector.
Example
C#
VB
C++
F#
Copy
// Use OfCategory method to apply an ElementCategoryFilter and fine elements in the Doors category
FilteredElementCollector collector = new FilteredElementCollector(document);
ICollection<Element> doors = collector.OfCategory(BuiltInCategory.OST_Doors).ToElements();
' Use OfCategory method to apply an ElementCategoryFilter and fine elements in the Doors category
Dim collector As New FilteredElementCollector(document)
Dim doors As ICollection(Of Element) = collector.OfCategory(BuiltInCategory.OST_Doors).ToElements()

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

FilteredElementCollector Class


FilteredElementCollector.OfCategoryId Method

FilteredElementCollectorOfCategoryId Method

Applies an ElementCategoryFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilteredElementCollector OfCategoryId(
    ElementId categoryId
)
Public Function OfCategoryId (
    categoryId As ElementId
) As FilteredElementCollector
public:
FilteredElementCollector^ OfCategoryId(
    ElementId^ categoryId
)
member OfCategoryId :
        categoryId : ElementId -> FilteredElementCollector

Parameters

categoryId ElementId
The category id.

Return Value

FilteredElementCollector
A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Only elements of this category id will pass the collector. If you have an active iterator to this collector it will be stopped by this call.
See Also

Reference

FilteredElementCollector Class


FilteredElementCollector.OfClass Method

FilteredElementCollectorOfClass Method

Applies an ElementClassFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilteredElementCollector OfClass(
    Type type
)
Public Function OfClass (
    type As Type
) As FilteredElementCollector
public:
FilteredElementCollector^ OfClass(
    Type^ type
)
member OfClass :
        type : Type -> FilteredElementCollector

Parameters

type Type
The element type.

Return Value

FilteredElementCollector
A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.
Exceptions
Exception | Condition
ArgumentException | The input type is not a subclass of Element. -or- The input type is of an element type that exists in the API, but not in Revit's native object model.
ArgumentNullException | A non-optional argument was null
Remarks
Only elements whose class is an exact match to the input class, or elements whose type is derived from the input class will pass the collector.

There is a small subset of Element subclasses in the API that are not supported by this filter. These classes exist in the API, but not in Revit's native object model, which means that this filter doesn't support them. In order to use a class filter to find elements of these types, it is necessary to use a higher level class and then process the results further to find elements matching only the subclass. For a list of subclasses affected by this restriction, consult the documentation for ElementClassFilter.

If you have an active iterator to this collector it will be stopped by this call.

Example
C#
VB
C++
F#
Copy
// Use OfClass method to apply an ElementClassFilter and find Levels in the document
FilteredElementCollector collector = new FilteredElementCollector(document);
ICollection<Element> levels = collector.OfClass(typeof(Level)).ToElements();
' Use OfClass method to apply an ElementClassFilter and find Levels in the document
Dim collector As New FilteredElementCollector(document)
Dim levels As ICollection(Of Element) = collector.OfClass(GetType(Level)).ToElements()

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

FilteredElementCollector Class


FilteredElementCollector.OwnedByView Method

FilteredElementCollectorOwnedByView Method

Applies an ElementOwnerViewFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilteredElementCollector OwnedByView(
    ElementId viewId
)
Public Function OwnedByView (
    viewId As ElementId
) As FilteredElementCollector
public:
FilteredElementCollector^ OwnedByView(
    ElementId^ viewId
)
member OwnedByView :
        viewId : ElementId -> FilteredElementCollector

Parameters

viewId ElementId
The view id of the owner view.

Return Value

FilteredElementCollector
A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Only elements that are owned by this particular view will pass the collector. If you have an active iterator to this collector it will be stopped by this call.
See Also

Reference

FilteredElementCollector Class


FilteredElementCollector.ToElementIds Method

FilteredElementCollectorToElementIds Method

Returns the complete set of element ids that pass the filter(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> ToElementIds()
Public Function ToElementIds As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ ToElementIds()
member ToElementIds : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
The complete set of element ids.
Exceptions
Exception | Condition
InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.
Remarks
This will reset the collector to the beginning and extract all elements that pass the applied filter(s). If you have an active iterator to this same collector it will be stopped by this call.
See Also

Reference

FilteredElementCollector Class


FilteredElementCollector.ToElements Method

FilteredElementCollectorToElements Method

Returns the complete set of elements that pass the filter(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<Element> ToElements()
Public Function ToElements As IList(Of Element)
public:
IList<Element^>^ ToElements()
member ToElements : unit -> IList<Element>

Return Value

IList Element
The complete set of element ids.
Exceptions
Exception | Condition
InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.
Remarks
This will reset the collector to the beginning and extract all elements that pass the applied filter(s). If you have an active iterator to this same collector it will be stopped by this call.
See Also

Reference

FilteredElementCollector Class


FilteredElementCollector.UnionWith Method

FilteredElementCollectorUnionWith Method

Unites the set of elements passing the filter in this collector with the set of elements passing the filter in another collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilteredElementCollector UnionWith(
    FilteredElementCollector other
)
Public Function UnionWith (
    other As FilteredElementCollector
) As FilteredElementCollector
public:
FilteredElementCollector^ UnionWith(
    FilteredElementCollector^ other
)
member UnionWith :
        other : FilteredElementCollector -> FilteredElementCollector

Parameters

other FilteredElementCollector
The other collector

Return Value

FilteredElementCollector
A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.
Exceptions
Exception | Condition
ArgumentException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.
Remarks
The result will be the same as using a LogicalOrFilter to connect this filter with another. If you have an active iterator to this collector it will be stopped by this call.
See Also

Reference

FilteredElementCollector Class


FilteredElementCollector.WhereElementIsCurveDriven Method

FilteredElementCollectorWhereElementIsCurveDriven Method

Applies an ElementIsCurveDrivenFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilteredElementCollector WhereElementIsCurveDriven()
Public Function WhereElementIsCurveDriven As FilteredElementCollector
public:
FilteredElementCollector^ WhereElementIsCurveDriven()
member WhereElementIsCurveDriven : unit -> FilteredElementCollector

Return Value

FilteredElementCollector
A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.
Remarks
Only elements that are curve driven will pass the collector. If you have an active iterator to this collector it will be stopped by this call.
See Also

Reference

FilteredElementCollector Class


FilteredElementCollector.WhereElementIsElementType Method

FilteredElementCollectorWhereElementIsElementType Method

Applies an ElementIsElementTypeFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilteredElementCollector WhereElementIsElementType()
Public Function WhereElementIsElementType As FilteredElementCollector
public:
FilteredElementCollector^ WhereElementIsElementType()
member WhereElementIsElementType : unit -> FilteredElementCollector

Return Value

FilteredElementCollector
A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.
Remarks
Only elements that are ElementTypes will pass the collector. If you have an active iterator to this collector it will be stopped by this call.
See Also

Reference

FilteredElementCollector Class


FilteredElementCollector.WhereElementIsNotElementType Method

FilteredElementCollectorWhereElementIsNotElementType Method

Applies an inverted ElementIsElementTypeFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilteredElementCollector WhereElementIsNotElementType()
Public Function WhereElementIsNotElementType As FilteredElementCollector
public:
FilteredElementCollector^ WhereElementIsNotElementType()
member WhereElementIsNotElementType : unit -> FilteredElementCollector

Return Value

FilteredElementCollector
A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.
Remarks
Only elements that are not element types will pass the collector. If you have an active iterator to this collector it will be stopped by this call.
See Also

Reference

FilteredElementCollector Class


FilteredElementCollector.WhereElementIsViewIndependent Method

FilteredElementCollectorWhereElementIsViewIndependent Method

Applies an ElementOwnerViewFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilteredElementCollector WhereElementIsViewIndependent()
Public Function WhereElementIsViewIndependent As FilteredElementCollector
public:
FilteredElementCollector^ WhereElementIsViewIndependent()
member WhereElementIsViewIndependent : unit -> FilteredElementCollector

Return Value

FilteredElementCollector
A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.
Remarks
Only elements that are view independent will pass the collector. If you have an active iterator to this collector it will be stopped by this call.
See Also

Reference

FilteredElementCollector Class


FilteredElementCollector.WherePasses Method

FilteredElementCollectorWherePasses Method

Applies an element filter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilteredElementCollector WherePasses(
    ElementFilter filter
)
Public Function WherePasses (
    filter As ElementFilter
) As FilteredElementCollector
public:
FilteredElementCollector^ WherePasses(
    ElementFilter^ filter
)
member WherePasses :
        filter : ElementFilter -> FilteredElementCollector

Parameters

filter ElementFilter
The element filter.

Return Value

FilteredElementCollector
A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
The filter will be added as an additional condition that all filtered elements must pass. If you have an active iterator to this collector it will be stopped by this call.
See Also

Reference

FilteredElementCollector Class


FilteredElementIdIterator Class

An iterator to a set of element ids filtered by the settings of a FilteredElementCollector.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilteredElementIdIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilteredElementIdIterator : IEnumerator<ElementId>
Public Class FilteredElementIdIterator
    Implements IEnumerator(Of ElementId)
public ref class FilteredElementIdIterator : IEnumerator<ElementId^>
type FilteredElementIdIterator =
    class
        interface IEnumerator<ElementId>
    end

The FilteredElementIdIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the FilteredElementIdIterator
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCurrent | The current element id found by the iterator.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next element id passing the filter.
Public method | Reset | Resets the iterator to the beginning.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FilteredElementIdIterator Properties

The FilteredElementIdIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

FilteredElementIdIterator Class


FilteredElementIdIterator.Current Property

FilteredElementIdIteratorCurrent Property

Gets the item at the current position of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ElementId Current { get; }
Public Overridable ReadOnly Property Current As ElementId
    Get
public:
virtual property ElementId^ Current {
    ElementId^ get ();
}
abstract Current : ElementId with get
override Current : ElementId with get

Property Value

ElementId

Implements

IEnumeratorTCurrent
Exceptions
Exception | Condition
InvalidOperationException | There is no current item in the iterator.
Remarks
There is no current item if the iterator has not started yet or has been done.
See Also

Reference

FilteredElementIdIterator Class


FilteredElementIdIterator.CurrentObject Property

FilteredElementIdIteratorCurrentObject Property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
internal Object CurrentObject { get; }
Friend ReadOnly Property CurrentObject As Object
    Get
internal:
virtual property Object^ CurrentObject {
    Object^ get () sealed;
}
internal abstract CurrentObject : Object with get
internal override CurrentObject : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
See Also

Reference

FilteredElementIdIterator Class


FilteredElementIdIterator.IsValidObject Property

FilteredElementIdIteratorIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

FilteredElementIdIterator Class


FilteredElementIdIterator Methods

The FilteredElementIdIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCurrent | The current element id found by the iterator.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next element id passing the filter.
Public method | Reset | Resets the iterator to the beginning.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FilteredElementIdIterator Class


FilteredElementIdIterator.Dispose Method

FilteredElementIdIteratorDispose Method

Releases all resources used by the FilteredElementIdIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit
See Also

Reference

FilteredElementIdIterator Class


FilteredElementIdIterator.GetCurrent Method

FilteredElementIdIteratorGetCurrent Method

The current element id found by the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GetCurrent()
Public Function GetCurrent As ElementId
public:
ElementId^ GetCurrent()
member GetCurrent : unit -> ElementId

Return Value

ElementId
The element id.
Exceptions
Exception | Condition
InvalidOperationException | There are no more element ids in the iterator. -or- The FilteredElementCollector that yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator. -or- The iterator cannot proceed due to changes made to the Element table in Revit's database (typically, this can be the result of an Element deletion).
See Also

Reference

FilteredElementIdIterator Class


FilteredElementIdIterator.IsDone Method

FilteredElementIdIteratorIsDone Method

Identifies if the iteration has completed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsDone()
Public Overridable Function IsDone As Boolean
public:
virtual bool IsDone()
abstract IsDone : unit -> bool
override IsDone : unit -> bool

Return Value

Boolean
True if the iteration has no more matching elements. False if there are more element ids to be iterated.
Exceptions
Exception | Condition
InvalidOperationException | The FilteredElementCollector that yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.
See Also

Reference

FilteredElementIdIterator Class


FilteredElementIdIterator.MoveNext Method

FilteredElementIdIteratorMoveNext Method

Increments the iterator to the next element id passing the filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
True if there is another available element id passing the filter in this iterator. False if the iterator has completed all available element ids.
Exceptions
Exception | Condition
InvalidOperationException | The FilteredElementCollector that yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator. -or- The iterator cannot proceed due to changes made to the Element table in Revit's database (typically, this can be the result of an Element deletion).
See Also

Reference

FilteredElementIdIterator Class


FilteredElementIdIterator.Reset Method

FilteredElementIdIteratorReset Method

Resets the iterator to the beginning.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit
Exceptions
Exception | Condition
InvalidOperationException | The FilteredElementCollector that yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.
See Also

Reference

FilteredElementIdIterator Class


FilteredElementIterator Class

An iterator to a set of elements filtered by the settings of a FilteredElementCollector.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilteredElementIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilteredElementIterator : IEnumerator<Element>
Public Class FilteredElementIterator
    Implements IEnumerator(Of Element)
public ref class FilteredElementIterator : IEnumerator<Element^>
type FilteredElementIterator =
    class
        interface IEnumerator<Element>
    end

The FilteredElementIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the FilteredElementIterator
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCurrent | The current element found by the iterator.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next element passing the filter.
Public method | Reset | Resets the iterator to the beginning.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FilteredElementIterator Properties

The FilteredElementIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

FilteredElementIterator Class


FilteredElementIterator.Current Property

FilteredElementIteratorCurrent Property

Gets the item at the current position of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Element Current { get; }
Public Overridable ReadOnly Property Current As Element
    Get
public:
virtual property Element^ Current {
    Element^ get ();
}
abstract Current : Element with get
override Current : Element with get

Property Value

Element

Implements

IEnumeratorTCurrent
Exceptions
Exception | Condition
InvalidOperationException | There is no current item in the iterator.
Remarks
There is no current item if the iterator has not started yet or has been done.
See Also

Reference

FilteredElementIterator Class


FilteredElementIterator.CurrentObject Property

FilteredElementIteratorCurrentObject Property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
internal Object CurrentObject { get; }
Friend ReadOnly Property CurrentObject As Object
    Get
internal:
virtual property Object^ CurrentObject {
    Object^ get () sealed;
}
internal abstract CurrentObject : Object with get
internal override CurrentObject : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
See Also

Reference

FilteredElementIterator Class


FilteredElementIterator.IsValidObject Property

FilteredElementIteratorIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

FilteredElementIterator Class


FilteredElementIterator Methods

The FilteredElementIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCurrent | The current element found by the iterator.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next element passing the filter.
Public method | Reset | Resets the iterator to the beginning.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FilteredElementIterator Class


FilteredElementIterator.Dispose Method

FilteredElementIteratorDispose Method

Releases all resources used by the FilteredElementIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit
See Also

Reference

FilteredElementIterator Class


FilteredElementIterator.GetCurrent Method

FilteredElementIteratorGetCurrent Method

The current element found by the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Element GetCurrent()
Public Function GetCurrent As Element
public:
Element^ GetCurrent()
member GetCurrent : unit -> Element

Return Value

Element
The element.
Exceptions
Exception | Condition
InvalidOperationException | There are no more element ids in the iterator. -or- The FilteredElementCollector that yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator. -or- The iterator cannot proceed due to changes made to the Element table in Revit's database (typically, This can be the result of an Element deletion).
See Also

Reference

FilteredElementIterator Class


FilteredElementIterator.IsDone Method

FilteredElementIteratorIsDone Method

Identifies if the iteration has completed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsDone()
Public Overridable Function IsDone As Boolean
public:
virtual bool IsDone()
abstract IsDone : unit -> bool
override IsDone : unit -> bool

Return Value

Boolean
True if the iteration has no more matching elements. False if there are more element ids to be iterated.
Exceptions
Exception | Condition
InvalidOperationException | The FilteredElementCollector that yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.
See Also

Reference

FilteredElementIterator Class


FilteredElementIterator.MoveNext Method

FilteredElementIteratorMoveNext Method

Increments the iterator to the next element passing the filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
True if there is another available element passing the filter in this iterator. False if the iterator has completed all available elements.
Exceptions
Exception | Condition
InvalidOperationException | The FilteredElementCollector that yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator. -or- The iterator cannot proceed due to changes made to the Element table in Revit's database (typically, This can be the result of an Element deletion).
See Also

Reference

FilteredElementIterator Class


FilteredElementIterator.Reset Method

FilteredElementIteratorReset Method

Resets the iterator to the beginning.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit
Exceptions
Exception | Condition
InvalidOperationException | The FilteredElementCollector that yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.
See Also

Reference

FilteredElementIterator Class


FilteredWorksetCollector Class

This class is used to search, filter and iterate through a set of worksets.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilteredWorksetCollector

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilteredWorksetCollector : IEnumerable<Workset>,
    IDisposable
Public Class FilteredWorksetCollector
    Implements IEnumerable(Of Workset), IDisposable
public ref class FilteredWorksetCollector : IEnumerable<Workset^>,
    IDisposable
type FilteredWorksetCollector =
    class
        interface IEnumerable<Workset>
        interface IDisposable
    end

The FilteredWorksetCollector type exposes the following members.

Constructors
 | Name | Description
Public method | FilteredWorksetCollector | Constructs a new FilteredWorksetCollector that will search and filter the set of worksets in a document.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the FilteredWorksetCollector
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | FirstWorkset | Returns the first workset to pass the filter(s).
Public method | FirstWorksetId | Returns the id of the first workset to pass the filter(s).
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetWorksetIdIterator | Returns a FilteredWorksetIdIterator to the worksets passing the current filter.
Public method | GetWorksetIterator | Returns a FilteredWorksetIterator to the worksets passing the current filter.
Public method | OfKind | Applies a WorksetKindFilter to the collector.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | ToWorksetIds | Returns the complete set of workset ids that pass the filter(s).
Public method | ToWorksets | Returns the complete set of worksets that pass the filter(s).
Public method | WherePasses | Applies a workset filter to the collector.
Top
Remarks

Developers can assign a condition to filter the worksets that are returned. If no condition is applied, it attempts to access all the worksets in the document.

The collector will reset if you call another method to extract worksets. Thus, if you have previously obtained an iterator, it will be stopped and traverse no more worksets if you call another method to extract worksets.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FilteredWorksetCollector Constructor

Constructs a new FilteredWorksetCollector that will search and filter the set of worksets in a document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilteredWorksetCollector(
    Document document
)
Public Sub New (
    document As Document
)
public:
FilteredWorksetCollector(
    Document^ document
)
new :
        document : Document -> FilteredWorksetCollector

Parameters

document Document
The document.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FilteredWorksetCollector Class


FilteredWorksetCollector Properties

The FilteredWorksetCollector type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

FilteredWorksetCollector Class


FilteredWorksetCollector.IsValidObject Property

FilteredWorksetCollectorIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

FilteredWorksetCollector Class


FilteredWorksetCollector Methods

The FilteredWorksetCollector type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | FirstWorkset | Returns the first workset to pass the filter(s).
Public method | FirstWorksetId | Returns the id of the first workset to pass the filter(s).
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetWorksetIdIterator | Returns a FilteredWorksetIdIterator to the worksets passing the current filter.
Public method | GetWorksetIterator | Returns a FilteredWorksetIterator to the worksets passing the current filter.
Public method | OfKind | Applies a WorksetKindFilter to the collector.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | ToWorksetIds | Returns the complete set of workset ids that pass the filter(s).
Public method | ToWorksets | Returns the complete set of worksets that pass the filter(s).
Public method | WherePasses | Applies a workset filter to the collector.
Top
See Also

Reference

FilteredWorksetCollector Class


FilteredWorksetCollector.Dispose Method

FilteredWorksetCollectorDispose Method

Releases all resources used by the FilteredWorksetCollector

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FilteredWorksetCollector Class


FilteredWorksetCollector.FirstWorkset Method

FilteredWorksetCollectorFirstWorkset Method

Returns the first workset to pass the filter(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Workset FirstWorkset()
Public Function FirstWorkset As Workset
public:
Workset^ FirstWorkset()
member FirstWorkset : unit -> Workset

Return Value

Workset
The first workset.
Exceptions
Exception | Condition
InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of worksets is not permitted without a filter.
Remarks
This will reset the collector to the beginning and find the first workset that passes the applied filter(s). If you have an active iterator to this same collector it will be stopped by this call.
See Also

Reference

FilteredWorksetCollector Class


FilteredWorksetCollector.FirstWorksetId Method

FilteredWorksetCollectorFirstWorksetId Method

Returns the id of the first workset to pass the filter(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WorksetId FirstWorksetId()
Public Function FirstWorksetId As WorksetId
public:
WorksetId^ FirstWorksetId()
member FirstWorksetId : unit -> WorksetId

Return Value

WorksetId
The first workset id.
Exceptions
Exception | Condition
InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of worksets is not permitted without a filter.
Remarks
This will reset the collector to the beginning and find the first workset that passes the applied filter(s). If you have an active iterator to this same collector it will be stopped by this call.
See Also

Reference

FilteredWorksetCollector Class


FilteredWorksetCollector.GetBasicIEnumerator Method

FilteredWorksetCollectorGetBasicIEnumerator Method

Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
internal virtual IEnumerator GetBasicIEnumerator()
Friend Overridable Function GetBasicIEnumerator As IEnumerator
internal:
virtual IEnumerator^ GetBasicIEnumerator()
internal abstract GetBasicIEnumerator : unit -> IEnumerator
internal override GetBasicIEnumerator : unit -> IEnumerator

Return Value

IEnumerator
An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerableGetEnumerator
See Also

Reference

FilteredWorksetCollector Class


FilteredWorksetCollector.GetEnumerator Method

FilteredWorksetCollectorGetEnumerator Method

Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator<Workset> GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator(Of Workset)
public:
virtual IEnumerator<Workset^>^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator<Workset>
override GetEnumerator : unit -> IEnumerator<Workset>

Return Value

IEnumerator Workset
An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerableTGetEnumerator
See Also

Reference

FilteredWorksetCollector Class


FilteredWorksetCollector.GetWorksetIdIterator Method

FilteredWorksetCollectorGetWorksetIdIterator Method

Returns a FilteredWorksetIdIterator to the worksets passing the current filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilteredWorksetIdIterator GetWorksetIdIterator()
Public Function GetWorksetIdIterator As FilteredWorksetIdIterator
public:
FilteredWorksetIdIterator^ GetWorksetIdIterator()
member GetWorksetIdIterator : unit -> FilteredWorksetIdIterator

Return Value

FilteredWorksetIdIterator
Remarks
Calling this when you have an active iterator to this same collector will result in the first iterator being stopped by this call.
See Also

Reference

FilteredWorksetCollector Class


FilteredWorksetCollector.GetWorksetIterator Method

FilteredWorksetCollectorGetWorksetIterator Method

Returns a FilteredWorksetIterator to the worksets passing the current filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilteredWorksetIterator GetWorksetIterator()
Public Function GetWorksetIterator As FilteredWorksetIterator
public:
FilteredWorksetIterator^ GetWorksetIterator()
member GetWorksetIterator : unit -> FilteredWorksetIterator

Return Value

FilteredWorksetIterator
Remarks
Calling this when you have an active iterator to this same collector will result in the first iterator being stopped by this call.
See Also

Reference

FilteredWorksetCollector Class


FilteredWorksetCollector.OfKind Method

FilteredWorksetCollectorOfKind Method

Applies a WorksetKindFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilteredWorksetCollector OfKind(
    WorksetKind worksetKind
)
Public Function OfKind (
    worksetKind As WorksetKind
) As FilteredWorksetCollector
public:
FilteredWorksetCollector^ OfKind(
    WorksetKind worksetKind
)
member OfKind :
        worksetKind : WorksetKind -> FilteredWorksetCollector

Parameters

worksetKind WorksetKind
The WorksetKind of the workset.

Return Value

FilteredWorksetCollector
A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Remarks
Only worksets whose WorksetKind is an exact match to the input WorksetKind will pass the collector.

If you have an active iterator to this collector it will be stopped by this call.

See Also

Reference

FilteredWorksetCollector Class


FilteredWorksetCollector.ToWorksetIds Method

FilteredWorksetCollectorToWorksetIds Method

Returns the complete set of workset ids that pass the filter(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<WorksetId> ToWorksetIds()
Public Function ToWorksetIds As ICollection(Of WorksetId)
public:
ICollection<WorksetId^>^ ToWorksetIds()
member ToWorksetIds : unit -> ICollection<WorksetId>

Return Value

ICollection WorksetId
The complete set of workset ids.
Exceptions
Exception | Condition
InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of worksets is not permitted without a filter.
Remarks
This will reset the collector to the beginning and extract all worksets that pass the applied filter(s). If you have an active iterator to this same collector it will be stopped by this call.
See Also

Reference

FilteredWorksetCollector Class


FilteredWorksetCollector.ToWorksets Method

FilteredWorksetCollectorToWorksets Method

Returns the complete set of worksets that pass the filter(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<Workset> ToWorksets()
Public Function ToWorksets As IList(Of Workset)
public:
IList<Workset^>^ ToWorksets()
member ToWorksets : unit -> IList<Workset>

Return Value

IList Workset
The complete array of worksets.
Exceptions
Exception | Condition
InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of worksets is not permitted without a filter.
Remarks
This will reset the collector to the beginning and extract all worksets that pass the applied filter(s). If you have an active iterator to this same collector it will be stopped by this call.
See Also

Reference

FilteredWorksetCollector Class


FilteredWorksetCollector.WherePasses Method

FilteredWorksetCollectorWherePasses Method

Applies a workset filter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilteredWorksetCollector WherePasses(
    WorksetFilter filter
)
Public Function WherePasses (
    filter As WorksetFilter
) As FilteredWorksetCollector
public:
FilteredWorksetCollector^ WherePasses(
    WorksetFilter^ filter
)
member WherePasses :
        filter : WorksetFilter -> FilteredWorksetCollector

Parameters

filter WorksetFilter
The workset filter.

Return Value

FilteredWorksetCollector
A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
The filter will be added as an additional condition that all filtered worksets must pass. If you have an active iterator to this collector it will be stopped by this call.
See Also

Reference

FilteredWorksetCollector Class


FilteredWorksetIdIterator Class

An iterator to a set of workset ids filtered by the settings of a FilteredWorksetCollector.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilteredWorksetIdIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilteredWorksetIdIterator : IEnumerator<WorksetId>
Public Class FilteredWorksetIdIterator
    Implements IEnumerator(Of WorksetId)
public ref class FilteredWorksetIdIterator : IEnumerator<WorksetId^>
type FilteredWorksetIdIterator =
    class
        interface IEnumerator<WorksetId>
    end

The FilteredWorksetIdIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the FilteredWorksetIdIterator
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCurrent | The current workset id found by the iterator.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next workset id passing the filter.
Public method | Reset | Resets the iterator to the beginning.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FilteredWorksetIdIterator Properties

The FilteredWorksetIdIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

FilteredWorksetIdIterator Class


FilteredWorksetIdIterator.Current Property

FilteredWorksetIdIteratorCurrent Property

Gets the item at the current position of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual WorksetId Current { get; }
Public Overridable ReadOnly Property Current As WorksetId
    Get
public:
virtual property WorksetId^ Current {
    WorksetId^ get ();
}
abstract Current : WorksetId with get
override Current : WorksetId with get

Property Value

WorksetId

Implements

IEnumeratorTCurrent
Exceptions
Exception | Condition
InvalidOperationException | There is no current item in the iterator.
Remarks
There is no current item if the iterator has not started yet or has been done.
See Also

Reference

FilteredWorksetIdIterator Class


FilteredWorksetIdIterator.CurrentObject Property

FilteredWorksetIdIteratorCurrentObject Property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
internal Object CurrentObject { get; }
Friend ReadOnly Property CurrentObject As Object
    Get
internal:
virtual property Object^ CurrentObject {
    Object^ get () sealed;
}
internal abstract CurrentObject : Object with get
internal override CurrentObject : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
See Also

Reference

FilteredWorksetIdIterator Class


FilteredWorksetIdIterator.IsValidObject Property

FilteredWorksetIdIteratorIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

FilteredWorksetIdIterator Class


FilteredWorksetIdIterator Methods

The FilteredWorksetIdIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCurrent | The current workset id found by the iterator.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next workset id passing the filter.
Public method | Reset | Resets the iterator to the beginning.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FilteredWorksetIdIterator Class


FilteredWorksetIdIterator.Dispose Method

FilteredWorksetIdIteratorDispose Method

Releases all resources used by the FilteredWorksetIdIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit
See Also

Reference

FilteredWorksetIdIterator Class


FilteredWorksetIdIterator.GetCurrent Method

FilteredWorksetIdIteratorGetCurrent Method

The current workset id found by the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WorksetId GetCurrent()
Public Function GetCurrent As WorksetId
public:
WorksetId^ GetCurrent()
member GetCurrent : unit -> WorksetId

Return Value

WorksetId
The workset id.
Exceptions
Exception | Condition
InvalidOperationException | There are no more workset ids in the iterator. -or- The FilteredWorksetCollector that yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.
See Also

Reference

FilteredWorksetIdIterator Class


FilteredWorksetIdIterator.IsDone Method

FilteredWorksetIdIteratorIsDone Method

Identifies if the iteration has completed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsDone()
Public Overridable Function IsDone As Boolean
public:
virtual bool IsDone()
abstract IsDone : unit -> bool
override IsDone : unit -> bool

Return Value

Boolean
True if the iteration has no more matching worksets. False if there are more workset ids to be iterated.
Exceptions
Exception | Condition
InvalidOperationException | The FilteredWorksetCollector that yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.
See Also

Reference

FilteredWorksetIdIterator Class


FilteredWorksetIdIterator.MoveNext Method

FilteredWorksetIdIteratorMoveNext Method

Increments the iterator to the next workset id passing the filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
True if there is another available workset id passing the filter in this iterator. False if the iterator has completed all available workset ids.
Exceptions
Exception | Condition
InvalidOperationException | The FilteredWorksetCollector that yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.
See Also

Reference

FilteredWorksetIdIterator Class


FilteredWorksetIdIterator.Reset Method

FilteredWorksetIdIteratorReset Method

Resets the iterator to the beginning.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit
Exceptions
Exception | Condition
InvalidOperationException | The FilteredWorksetCollector that yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.
See Also

Reference

FilteredWorksetIdIterator Class


FilteredWorksetIterator Class

An iterator to a set of worksets filtered by the settings of a FilteredWorksetCollector.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilteredWorksetIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilteredWorksetIterator : IEnumerator<Workset>
Public Class FilteredWorksetIterator
    Implements IEnumerator(Of Workset)
public ref class FilteredWorksetIterator : IEnumerator<Workset^>
type FilteredWorksetIterator =
    class
        interface IEnumerator<Workset>
    end

The FilteredWorksetIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the FilteredWorksetIterator
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCurrent | The current workset found by the iterator.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next workset passing the filter.
Public method | Reset | Resets the iterator to the beginning.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FilteredWorksetIterator Properties

The FilteredWorksetIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

FilteredWorksetIterator Class


FilteredWorksetIterator.Current Property

FilteredWorksetIteratorCurrent Property

Gets the item at the current position of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Workset Current { get; }
Public Overridable ReadOnly Property Current As Workset
    Get
public:
virtual property Workset^ Current {
    Workset^ get ();
}
abstract Current : Workset with get
override Current : Workset with get

Property Value

Workset

Implements

IEnumeratorTCurrent
Exceptions
Exception | Condition
InvalidOperationException | There is no current item in the iterator.
Remarks
There is no current item if the iterator has not started yet or has been done.
See Also

Reference

FilteredWorksetIterator Class


FilteredWorksetIterator.CurrentObject Property

FilteredWorksetIteratorCurrentObject Property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
internal Object CurrentObject { get; }
Friend ReadOnly Property CurrentObject As Object
    Get
internal:
virtual property Object^ CurrentObject {
    Object^ get () sealed;
}
internal abstract CurrentObject : Object with get
internal override CurrentObject : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
See Also

Reference

FilteredWorksetIterator Class


FilteredWorksetIterator.IsValidObject Property

FilteredWorksetIteratorIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

FilteredWorksetIterator Class


FilteredWorksetIterator Methods

The FilteredWorksetIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCurrent | The current workset found by the iterator.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next workset passing the filter.
Public method | Reset | Resets the iterator to the beginning.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FilteredWorksetIterator Class


FilteredWorksetIterator.Dispose Method

FilteredWorksetIteratorDispose Method

Releases all resources used by the FilteredWorksetIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit
See Also

Reference

FilteredWorksetIterator Class


FilteredWorksetIterator.GetCurrent Method

FilteredWorksetIteratorGetCurrent Method

The current workset found by the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Workset GetCurrent()
Public Function GetCurrent As Workset
public:
Workset^ GetCurrent()
member GetCurrent : unit -> Workset

Return Value

Workset
The workset.
Exceptions
Exception | Condition
InvalidOperationException | There are no more worksets in the iterator. -or- The FilteredWorksetCollector that yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.
See Also

Reference

FilteredWorksetIterator Class


FilteredWorksetIterator.IsDone Method

FilteredWorksetIteratorIsDone Method

Identifies if the iteration has completed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsDone()
Public Overridable Function IsDone As Boolean
public:
virtual bool IsDone()
abstract IsDone : unit -> bool
override IsDone : unit -> bool

Return Value

Boolean
True if the iteration has no more matching worksets. False if there are more worksets to be iterated.
Exceptions
Exception | Condition
InvalidOperationException | The FilteredWorksetCollector that yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.
See Also

Reference

FilteredWorksetIterator Class


FilteredWorksetIterator.MoveNext Method

FilteredWorksetIteratorMoveNext Method

Increments the iterator to the next workset passing the filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
True if there is another available workset passing the filter in this iterator. False if the iterator has completed all available worksets.
Exceptions
Exception | Condition
InvalidOperationException | The FilteredWorksetCollector that yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.
See Also

Reference

FilteredWorksetIterator Class


FilteredWorksetIterator.Reset Method

FilteredWorksetIteratorReset Method

Resets the iterator to the beginning.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit
Exceptions
Exception | Condition
InvalidOperationException | The FilteredWorksetCollector that yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.
See Also

Reference

FilteredWorksetIterator Class


FilterElement Class

The base class for filter elements in the document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBFilterElement
Autodesk.Revit.DBParameterFilterElement
Autodesk.Revit.DBSelectionFilterElement

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilterElement : Element
Public Class FilterElement
    Inherits Element
public ref class FilterElement : public Element
type FilterElement =
    class
        inherit Element
    end

The FilterElement type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsNameUnique(String) | Determines whether a potential filter element name is unique.
 | IsNameUnique(Document, String) | Determines whether the given name could be applied to a new FilterElement, or if it could not be applied because the name is already in use.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FilterElement Properties

The FilterElement type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

FilterElement Class


FilterElement Methods

The FilterElement type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsNameUnique(String) | Determines whether a potential filter element name is unique.
 | IsNameUnique(Document, String) | Determines whether the given name could be applied to a new FilterElement, or if it could not be applied because the name is already in use.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FilterElement Class


FilterElement.IsNameUnique Method

FilterElementIsNameUnique Method

Overload List
 | Name | Description
Public method | IsNameUnique(String) | Determines whether a potential filter element name is unique.
 | IsNameUnique(Document, String) | Determines whether the given name could be applied to a new FilterElement, or if it could not be applied because the name is already in use.
Top
See Also

Reference

FilterElement Class


FilterElement.IsNameUnique(String) Method

FilterElementIsNameUnique(String) Method

Determines whether a potential filter element name is unique.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsNameUnique(
    string name
)
Public Function IsNameUnique (
    name As String
) As Boolean
public:
bool IsNameUnique(
    String^ name
)
member IsNameUnique :
        name : string -> bool

Parameters

name String
The candidate name.

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FilterElement Class
IsNameUnique Overload


FilterElement.IsNameUnique(Document, String) Method

FilterElementIsNameUnique(Document, String) Method

Determines whether the given name could be applied to a new FilterElement, or if it could not be applied because the name is already in use.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsNameUnique(
    Document aDocument,
    string name
)
Public Shared Function IsNameUnique (
    aDocument As Document,
    name As String
) As Boolean
public:
static bool IsNameUnique(
    Document^ aDocument,
    String^ name
)
static member IsNameUnique :
        aDocument : Document *
        name : string -> bool

Parameters

aDocument Document
The document in which the name is being tested for uniqueness.
name String
The name tested for uniqueness.

Return Value

Boolean
Returns true if the name is unique, and false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FilterElement Class
IsNameUnique Overload


FilterElementIdRule Class

A filter rule that operates on ElementId values in a Revit project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterRule
Autodesk.Revit.DBFilterValueRule
Autodesk.Revit.DBFilterNumericValueRule
Autodesk.Revit.DBFilterElementIdRule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilterElementIdRule : FilterNumericValueRule
Public Class FilterElementIdRule
    Inherits FilterNumericValueRule
public ref class FilterElementIdRule : public FilterNumericValueRule
type FilterElementIdRule =
    class
        inherit FilterNumericValueRule
    end

The FilterElementIdRule type exposes the following members.

Constructors
 | Name | Description
Public method | FilterElementIdRule | Constructs an instance of FilterElementIdRule.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule)
Public property | RuleValue | The user-supplied value against which values from a Revit document will be tested.
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterRule)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetEvaluator | Gets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetEvaluator | Sets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
 | UsesLevelFiltering | This function checks if a parameter uses level filtering.
Top
Remarks
When GetRuleParameter returns a parameter that UsesLevelFiltering(Document, ElementId), then the comparisons will first compare the values of the levels' elevations, then compare the levels' names, and finally the levels' element ids to rank and sort the levels.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FilterElementIdRule Constructor

Constructs an instance of FilterElementIdRule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterElementIdRule(
    FilterableValueProvider valueProvider,
    FilterNumericRuleEvaluator evaluator,
    ElementId ruleValue
)
Public Sub New (
    valueProvider As FilterableValueProvider,
    evaluator As FilterNumericRuleEvaluator,
    ruleValue As ElementId
)
public:
FilterElementIdRule(
    FilterableValueProvider^ valueProvider,
    FilterNumericRuleEvaluator^ evaluator,
    ElementId^ ruleValue
)
new :
        valueProvider : FilterableValueProvider *
        evaluator : FilterNumericRuleEvaluator *
        ruleValue : ElementId -> FilterElementIdRule

Parameters

valueProvider FilterableValueProvider
A pointer to a "value provider" object that will extract values from a Revit document.
evaluator FilterNumericRuleEvaluator
A pointer to the filter rule evaluator object that implements the desired test. The built-in evaluators implement commonly used tests such as less-than, greater-than less-than-or-equal-to, equal, etc.
ruleValue ElementId
The user-supplied value against which values from a Revit document will be tested.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FilterElementIdRule Class


FilterElementIdRule Properties

The FilterElementIdRule type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule)
Public property | RuleValue | The user-supplied value against which values from a Revit document will be tested.
Top
See Also

Reference

FilterElementIdRule Class


FilterElementIdRule.RuleValue Property

FilterElementIdRuleRuleValue Property

The user-supplied value against which values from a Revit document will be tested.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId RuleValue { get; set; }
Public Property RuleValue As ElementId
    Get
    Set
public:
property ElementId^ RuleValue {
    ElementId^ get ();
    void set (ElementId^ value);
}
member RuleValue : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

FilterElementIdRule Class


FilterElementIdRule Methods

The FilterElementIdRule type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterRule)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetEvaluator | Gets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetEvaluator | Sets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
 | UsesLevelFiltering | This function checks if a parameter uses level filtering.
Top
See Also

Reference

FilterElementIdRule Class


FilterElementIdRule.UsesLevelFiltering Method

FilterElementIdRuleUsesLevelFiltering Method

This function checks if a parameter uses level filtering.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool UsesLevelFiltering(
    Document doc,
    ElementId parameterId
)
Public Shared Function UsesLevelFiltering (
    doc As Document,
    parameterId As ElementId
) As Boolean
public:
static bool UsesLevelFiltering(
    Document^ doc,
    ElementId^ parameterId
)
static member UsesLevelFiltering :
        doc : Document *
        parameterId : ElementId -> bool

Parameters

doc Document
The document which owns the parameter.
parameterId ElementId
The id of the parameter that will be tested to see if it uses level filtering.

Return Value

Boolean
True if the parameter uses level filtering, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
When level-filtering parameters are compared, the comparisons will first compare the values of the levels' elevations, then compare the levels' names, and finally the levels' element ids to rank and sort the levels.
See Also

Reference

FilterElementIdRule Class


FilterGlobalParameterAssociationRule Class

A filter rule that operates on global parameters ElementId values in a Revit project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterRule
Autodesk.Revit.DBFilterValueRule
Autodesk.Revit.DBFilterNumericValueRule
Autodesk.Revit.DBFilterGlobalParameterAssociationRule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilterGlobalParameterAssociationRule : FilterNumericValueRule
Public Class FilterGlobalParameterAssociationRule
    Inherits FilterNumericValueRule
public ref class FilterGlobalParameterAssociationRule : public FilterNumericValueRule
type FilterGlobalParameterAssociationRule =
    class
        inherit FilterNumericValueRule
    end

The FilterGlobalParameterAssociationRule type exposes the following members.

Constructors
 | Name | Description
Public method | FilterGlobalParameterAssociationRule | Constructs an instance of FilterGlobalParameterAssociationRule.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule)
Public property | RuleValue | The user-supplied global parameter value against which values from a Revit document will be tested.
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterRule)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetEvaluator | Gets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetEvaluator | Sets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FilterGlobalParameterAssociationRule Constructor

Constructs an instance of FilterGlobalParameterAssociationRule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterGlobalParameterAssociationRule(
    FilterableValueProvider valueProvider,
    FilterNumericRuleEvaluator evaluator,
    ElementId ruleValue
)
Public Sub New (
    valueProvider As FilterableValueProvider,
    evaluator As FilterNumericRuleEvaluator,
    ruleValue As ElementId
)
public:
FilterGlobalParameterAssociationRule(
    FilterableValueProvider^ valueProvider,
    FilterNumericRuleEvaluator^ evaluator,
    ElementId^ ruleValue
)
new :
        valueProvider : FilterableValueProvider *
        evaluator : FilterNumericRuleEvaluator *
        ruleValue : ElementId -> FilterGlobalParameterAssociationRule

Parameters

valueProvider FilterableValueProvider
A pointer to a "value provider" object that will extract values from a Revit document.
evaluator FilterNumericRuleEvaluator
A pointer to the filter rule evaluator object that implements the desired test. The built-in evaluators implement commonly used tests such as less-than, greater-than less-than-or-equal-to, equal, etc.
ruleValue ElementId
The user-supplied global parameter value against which values from a Revit document will be tested.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FilterGlobalParameterAssociationRule Class


FilterGlobalParameterAssociationRule Properties

The FilterGlobalParameterAssociationRule type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule)
Public property | RuleValue | The user-supplied global parameter value against which values from a Revit document will be tested.
Top
See Also

Reference

FilterGlobalParameterAssociationRule Class


FilterGlobalParameterAssociationRule.RuleValue Property

FilterGlobalParameterAssociationRuleRuleValue Property

The user-supplied global parameter value against which values from a Revit document will be tested.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId RuleValue { get; set; }
Public Property RuleValue As ElementId
    Get
    Set
public:
property ElementId^ RuleValue {
    ElementId^ get ();
    void set (ElementId^ value);
}
member RuleValue : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

FilterGlobalParameterAssociationRule Class


FilterGlobalParameterAssociationRule Methods

The FilterGlobalParameterAssociationRule type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterRule)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetEvaluator | Gets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetEvaluator | Sets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FilterGlobalParameterAssociationRule Class


FilterIntegerRule Class

A filter rule that operates on integer values in a Revit project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterRule
Autodesk.Revit.DBFilterValueRule
Autodesk.Revit.DBFilterNumericValueRule
Autodesk.Revit.DBFilterIntegerRule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilterIntegerRule : FilterNumericValueRule
Public Class FilterIntegerRule
    Inherits FilterNumericValueRule
public ref class FilterIntegerRule : public FilterNumericValueRule
type FilterIntegerRule =
    class
        inherit FilterNumericValueRule
    end

The FilterIntegerRule type exposes the following members.

Constructors
 | Name | Description
Public method | FilterIntegerRule | Constructs an instance of FilterIntegerRule.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule)
Public property | RuleValue | The user-supplied value against which values from a Revit document will be tested.
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterRule)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetEvaluator | Gets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetEvaluator | Sets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FilterIntegerRule Constructor

Constructs an instance of FilterIntegerRule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterIntegerRule(
    FilterableValueProvider valueProvider,
    FilterNumericRuleEvaluator evaluator,
    int ruleValue
)
Public Sub New (
    valueProvider As FilterableValueProvider,
    evaluator As FilterNumericRuleEvaluator,
    ruleValue As Integer
)
public:
FilterIntegerRule(
    FilterableValueProvider^ valueProvider,
    FilterNumericRuleEvaluator^ evaluator,
    int ruleValue
)
new :
        valueProvider : FilterableValueProvider *
        evaluator : FilterNumericRuleEvaluator *
        ruleValue : int -> FilterIntegerRule

Parameters

valueProvider FilterableValueProvider
A pointer to a "value provider" object that will extract values from a Revit document.
evaluator FilterNumericRuleEvaluator
A pointer to the filter rule evaluator object that implements the desired test. The built-in evaluators implement commonly used tests such as less-than, greater-than less-than-or-equal-to, equal, etc.
ruleValue Int32
The user-supplied value against which values from a Revit document will be tested.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FilterIntegerRule Class


FilterIntegerRule Properties

The FilterIntegerRule type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule)
Public property | RuleValue | The user-supplied value against which values from a Revit document will be tested.
Top
See Also

Reference

FilterIntegerRule Class


FilterIntegerRule.RuleValue Property

FilterIntegerRuleRuleValue Property

The user-supplied value against which values from a Revit document will be tested.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int RuleValue { get; set; }
Public Property RuleValue As Integer
    Get
    Set
public:
property int RuleValue {
    int get ();
    void set (int value);
}
member RuleValue : int with get, set

Property Value

Int32
See Also

Reference

FilterIntegerRule Class


FilterIntegerRule Methods

The FilterIntegerRule type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterRule)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetEvaluator | Gets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetEvaluator | Sets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FilterIntegerRule Class


FilterInverseRule Class

A filter rule that inverts the boolean values returned by the rule it contains.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterRule
Autodesk.Revit.DBFilterInverseRule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilterInverseRule : FilterRule
Public Class FilterInverseRule
    Inherits FilterRule
public ref class FilterInverseRule : public FilterRule
type FilterInverseRule =
    class
        inherit FilterRule
    end

The FilterInverseRule type exposes the following members.

Constructors
 | Name | Description
Public method | FilterInverseRule | Constructs a new instance of FilterInverseRule.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterRule)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetInnerRule | Gets the rule being inverted.
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetInnerRule | Gets the rule being inverted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
FilterInverse rule performs a logical "not" operation on its inner rule's "elementPasses()" method.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FilterInverseRule Constructor

Constructs a new instance of FilterInverseRule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterInverseRule(
    FilterRule innerRule
)
Public Sub New (
    innerRule As FilterRule
)
public:
FilterInverseRule(
    FilterRule^ innerRule
)
new :
        innerRule : FilterRule -> FilterInverseRule

Parameters

innerRule FilterRule
The rule to invert.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FilterInverseRule Class


FilterInverseRule Properties

The FilterInverseRule type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule)
Top
See Also

Reference

FilterInverseRule Class


FilterInverseRule Methods

The FilterInverseRule type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterRule)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetInnerRule | Gets the rule being inverted.
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetInnerRule | Gets the rule being inverted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FilterInverseRule Class


FilterInverseRule.GetInnerRule Method

FilterInverseRuleGetInnerRule Method

Gets the rule being inverted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterRule GetInnerRule()
Public Function GetInnerRule As FilterRule
public:
FilterRule^ GetInnerRule()
member GetInnerRule : unit -> FilterRule

Return Value

FilterRule
See Also

Reference

FilterInverseRule Class


FilterInverseRule.SetInnerRule Method

FilterInverseRuleSetInnerRule Method

Gets the rule being inverted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetInnerRule(
    FilterRule innerRule
)
Public Sub SetInnerRule (
    innerRule As FilterRule
)
public:
void SetInnerRule(
    FilterRule^ innerRule
)
member SetInnerRule :
        innerRule : FilterRule -> unit

Parameters

innerRule FilterRule
The rule to invert.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FilterInverseRule Class


FilterNumericEquals Class

Tests whether numeric values from the document are equal to a certain value
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterNumericRuleEvaluator
Autodesk.Revit.DBFilterNumericEquals

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilterNumericEquals : FilterNumericRuleEvaluator
Public Class FilterNumericEquals
    Inherits FilterNumericRuleEvaluator
public ref class FilterNumericEquals : public FilterNumericRuleEvaluator
type FilterNumericEquals =
    class
        inherit FilterNumericRuleEvaluator
    end

The FilterNumericEquals type exposes the following members.

Constructors
 | Name | Description
Public method | FilterNumericEquals | Constructs an instance of FilterNumericEquals.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterNumericRuleEvaluator)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterNumericRuleEvaluator)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Evaluate(Int32, Int32) | Obsolete. Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator)
Public method | Evaluate(Int64, Int64) | Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator)
Public method | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not. (Inherited from FilterNumericRuleEvaluator)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FilterNumericEquals Constructor

Constructs an instance of FilterNumericEquals.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterNumericEquals()
Public Sub New
public:
FilterNumericEquals()
new : unit -> FilterNumericEquals
See Also

Reference

FilterNumericEquals Class


FilterNumericEquals Properties

The FilterNumericEquals type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterNumericRuleEvaluator)
Top
See Also

Reference

FilterNumericEquals Class


FilterNumericEquals Methods

The FilterNumericEquals type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterNumericRuleEvaluator)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Evaluate(Int32, Int32) | Obsolete. Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator)
Public method | Evaluate(Int64, Int64) | Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator)
Public method | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not. (Inherited from FilterNumericRuleEvaluator)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FilterNumericEquals Class


FilterNumericGreater Class

Tests whether numeric values from the document are greater than a certain value
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterNumericRuleEvaluator
Autodesk.Revit.DBFilterNumericGreater

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilterNumericGreater : FilterNumericRuleEvaluator
Public Class FilterNumericGreater
    Inherits FilterNumericRuleEvaluator
public ref class FilterNumericGreater : public FilterNumericRuleEvaluator
type FilterNumericGreater =
    class
        inherit FilterNumericRuleEvaluator
    end

The FilterNumericGreater type exposes the following members.

Constructors
 | Name | Description
Public method | FilterNumericGreater | Constructs an instance of FilterNumericGreater.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterNumericRuleEvaluator)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterNumericRuleEvaluator)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Evaluate(Int32, Int32) | Obsolete. Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator)
Public method | Evaluate(Int64, Int64) | Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator)
Public method | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not. (Inherited from FilterNumericRuleEvaluator)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FilterNumericGreater Constructor

Constructs an instance of FilterNumericGreater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterNumericGreater()
Public Sub New
public:
FilterNumericGreater()
new : unit -> FilterNumericGreater
See Also

Reference

FilterNumericGreater Class


FilterNumericGreater Properties

The FilterNumericGreater type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterNumericRuleEvaluator)
Top
See Also

Reference

FilterNumericGreater Class


FilterNumericGreater Methods

The FilterNumericGreater type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterNumericRuleEvaluator)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Evaluate(Int32, Int32) | Obsolete. Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator)
Public method | Evaluate(Int64, Int64) | Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator)
Public method | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not. (Inherited from FilterNumericRuleEvaluator)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FilterNumericGreater Class


FilterNumericGreaterOrEqual Class

Tests whether numeric values from the document are greater than or equal to a certain value
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterNumericRuleEvaluator
Autodesk.Revit.DBFilterNumericGreaterOrEqual

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilterNumericGreaterOrEqual : FilterNumericRuleEvaluator
Public Class FilterNumericGreaterOrEqual
    Inherits FilterNumericRuleEvaluator
public ref class FilterNumericGreaterOrEqual : public FilterNumericRuleEvaluator
type FilterNumericGreaterOrEqual =
    class
        inherit FilterNumericRuleEvaluator
    end

The FilterNumericGreaterOrEqual type exposes the following members.

Constructors
 | Name | Description
Public method | FilterNumericGreaterOrEqual | Constructs an instance of FilterNumericGreaterOrEqual.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterNumericRuleEvaluator)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterNumericRuleEvaluator)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Evaluate(Int32, Int32) | Obsolete. Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator)
Public method | Evaluate(Int64, Int64) | Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator)
Public method | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not. (Inherited from FilterNumericRuleEvaluator)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FilterNumericGreaterOrEqual Constructor

Constructs an instance of FilterNumericGreaterOrEqual.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterNumericGreaterOrEqual()
Public Sub New
public:
FilterNumericGreaterOrEqual()
new : unit -> FilterNumericGreaterOrEqual
See Also

Reference

FilterNumericGreaterOrEqual Class


FilterNumericGreaterOrEqual Properties

The FilterNumericGreaterOrEqual type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterNumericRuleEvaluator)
Top
See Also

Reference

FilterNumericGreaterOrEqual Class


FilterNumericGreaterOrEqual Methods

The FilterNumericGreaterOrEqual type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterNumericRuleEvaluator)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Evaluate(Int32, Int32) | Obsolete. Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator)
Public method | Evaluate(Int64, Int64) | Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator)
Public method | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not. (Inherited from FilterNumericRuleEvaluator)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FilterNumericGreaterOrEqual Class


FilterNumericLess Class

Tests whether numeric values from the document are less than a certain value
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterNumericRuleEvaluator
Autodesk.Revit.DBFilterNumericLess

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilterNumericLess : FilterNumericRuleEvaluator
Public Class FilterNumericLess
    Inherits FilterNumericRuleEvaluator
public ref class FilterNumericLess : public FilterNumericRuleEvaluator
type FilterNumericLess =
    class
        inherit FilterNumericRuleEvaluator
    end

The FilterNumericLess type exposes the following members.

Constructors
 | Name | Description
Public method | FilterNumericLess | Constructs an instance of FilterNumericLess.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterNumericRuleEvaluator)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterNumericRuleEvaluator)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Evaluate(Int32, Int32) | Obsolete. Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator)
Public method | Evaluate(Int64, Int64) | Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator)
Public method | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not. (Inherited from FilterNumericRuleEvaluator)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FilterNumericLess Constructor

Constructs an instance of FilterNumericLess.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterNumericLess()
Public Sub New
public:
FilterNumericLess()
new : unit -> FilterNumericLess
See Also

Reference

FilterNumericLess Class


FilterNumericLess Properties

The FilterNumericLess type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterNumericRuleEvaluator)
Top
See Also

Reference

FilterNumericLess Class


FilterNumericLess Methods

The FilterNumericLess type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterNumericRuleEvaluator)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Evaluate(Int32, Int32) | Obsolete. Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator)
Public method | Evaluate(Int64, Int64) | Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator)
Public method | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not. (Inherited from FilterNumericRuleEvaluator)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FilterNumericLess Class


FilterNumericLessOrEqual Class

Tests whether numeric values from the document are less than or equal to a certain value
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterNumericRuleEvaluator
Autodesk.Revit.DBFilterNumericLessOrEqual

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilterNumericLessOrEqual : FilterNumericRuleEvaluator
Public Class FilterNumericLessOrEqual
    Inherits FilterNumericRuleEvaluator
public ref class FilterNumericLessOrEqual : public FilterNumericRuleEvaluator
type FilterNumericLessOrEqual =
    class
        inherit FilterNumericRuleEvaluator
    end

The FilterNumericLessOrEqual type exposes the following members.

Constructors
 | Name | Description
Public method | FilterNumericLessOrEqual | Constructs an instance of FilterNumericLessOrEqual.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterNumericRuleEvaluator)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterNumericRuleEvaluator)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Evaluate(Int32, Int32) | Obsolete. Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator)
Public method | Evaluate(Int64, Int64) | Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator)
Public method | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not. (Inherited from FilterNumericRuleEvaluator)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FilterNumericLessOrEqual Constructor

Constructs an instance of FilterNumericLessOrEqual.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterNumericLessOrEqual()
Public Sub New
public:
FilterNumericLessOrEqual()
new : unit -> FilterNumericLessOrEqual
See Also

Reference

FilterNumericLessOrEqual Class


FilterNumericLessOrEqual Properties

The FilterNumericLessOrEqual type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterNumericRuleEvaluator)
Top
See Also

Reference

FilterNumericLessOrEqual Class


FilterNumericLessOrEqual Methods

The FilterNumericLessOrEqual type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterNumericRuleEvaluator)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Evaluate(Int32, Int32) | Obsolete. Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator)
Public method | Evaluate(Int64, Int64) | Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator)
Public method | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not. (Inherited from FilterNumericRuleEvaluator)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FilterNumericLessOrEqual Class


FilterNumericRuleEvaluator Class

Base for all classes that compare numeric values from Revit to a user-supplied filter value.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterNumericRuleEvaluator
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilterNumericRuleEvaluator : IDisposable
Public Class FilterNumericRuleEvaluator
    Implements IDisposable
public ref class FilterNumericRuleEvaluator : IDisposable
type FilterNumericRuleEvaluator =
    class
        interface IDisposable
    end

The FilterNumericRuleEvaluator type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the FilterNumericRuleEvaluator
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Evaluate(Int32, Int32) | Obsolete. Derived classes should override this method to implement the desired test.
Public method | Evaluate(Int64, Int64) | Derived classes should override this method to implement the desired test.
Public method | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
A class derived from FilterNumericRuleEvaluator must handle both integer and double-precision types. For double-precision comparisons, an epsilon value is given. The evaluator class should use this value in a manner appropriate to the comparison being implemented.
See Also

Reference

Autodesk.Revit.DB Namespace
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterNumericRuleEvaluator
Autodesk.Revit.DBFilterNumericEquals
Autodesk.Revit.DBFilterNumericGreater
Autodesk.Revit.DBFilterNumericGreaterOrEqual
Autodesk.Revit.DBFilterNumericLess
Autodesk.Revit.DBFilterNumericLessOrEqual


FilterNumericRuleEvaluator Properties

The FilterNumericRuleEvaluator type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

FilterNumericRuleEvaluator Class


FilterNumericRuleEvaluator.IsValidObject Property

FilterNumericRuleEvaluatorIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

FilterNumericRuleEvaluator Class


FilterNumericRuleEvaluator Methods

The FilterNumericRuleEvaluator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Evaluate(Int32, Int32) | Obsolete. Derived classes should override this method to implement the desired test.
Public method | Evaluate(Int64, Int64) | Derived classes should override this method to implement the desired test.
Public method | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FilterNumericRuleEvaluator Class


FilterNumericRuleEvaluator.Dispose Method

FilterNumericRuleEvaluatorDispose Method

Releases all resources used by the FilterNumericRuleEvaluator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FilterNumericRuleEvaluator Class


FilterNumericRuleEvaluator.Evaluate Method

FilterNumericRuleEvaluatorEvaluate Method

Overload List
 | Name | Description
Public method | Evaluate(Int32, Int32) | Obsolete. Derived classes should override this method to implement the desired test.
Public method | Evaluate(Int64, Int64) | Derived classes should override this method to implement the desired test.
Public method | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not.
Top
See Also

Reference

FilterNumericRuleEvaluator Class


FilterNumericRuleEvaluator.Evaluate(Int32, Int32) Method

FilterNumericRuleEvaluatorEvaluate(Int32, Int32) Method

Note: This API is now obsolete.

Derived classes should override this method to implement the desired test.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is deprecated in Revit 2024. Override the evalute method taking Int64 instead. It may be removed in a future version.")]
public bool Evaluate(
    int lhs,
    int rhs
)
<ObsoleteAttribute("This method is deprecated in Revit 2024. Override the evalute method taking Int64 instead. It may be removed in a future version.")>
Public Function Evaluate (
    lhs As Integer,
    rhs As Integer
) As Boolean
public:
[ObsoleteAttribute(L"This method is deprecated in Revit 2024. Override the evalute method taking Int64 instead. It may be removed in a future version.")]
bool Evaluate(
    int lhs,
    int rhs
)
[<ObsoleteAttribute("This method is deprecated in Revit 2024. Override the evalute method taking Int64 instead. It may be removed in a future version.")>]
member Evaluate :
        lhs : int *
        rhs : int -> bool

Parameters

lhs Int32
A value from an element in the document.
rhs Int32
The user-supplied value against which values from the document are tested.

Return Value

Boolean
True if lhs, rhs satisfy the condition implemented by this evaluator.
See Also

Reference

FilterNumericRuleEvaluator Class
Evaluate Overload


FilterNumericRuleEvaluator.Evaluate(Int64, Int64) Method

FilterNumericRuleEvaluatorEvaluate(Int64, Int64) Method

Derived classes should override this method to implement the desired test.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Evaluate(
    long lhs,
    long rhs
)
Public Function Evaluate (
    lhs As Long,
    rhs As Long
) As Boolean
public:
bool Evaluate(
    long long lhs,
    long long rhs
)
member Evaluate :
        lhs : int64 *
        rhs : int64 -> bool

Parameters

lhs Int64
A value from an element in the document.
rhs Int64
The user-supplied value against which values from the document are tested.

Return Value

Boolean
True if lhs, rhs satisfy the condition implemented by this evaluator.
See Also

Reference

FilterNumericRuleEvaluator Class
Evaluate Overload


FilterNumericRuleEvaluator.Evaluate(Double, Double, Double) Method

FilterNumericRuleEvaluatorEvaluate(Double, Double, Double) Method

Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Evaluate(
    double lhs,
    double rhs,
    double epsilon
)
Public Function Evaluate (
    lhs As Double,
    rhs As Double,
    epsilon As Double
) As Boolean
public:
bool Evaluate(
    double lhs,
    double rhs,
    double epsilon
)
member Evaluate :
        lhs : float *
        rhs : float *
        epsilon : float -> bool

Parameters

lhs Double
A value from an element in the document.
rhs Double
The user-supplied value against which values from the document are tested.
epsilon Double
Defines the tolerance within which two values may be considered equal.

Return Value

Boolean
True if the given arguments satisfy the condition, otherwise false.
Exceptions
Exception | Condition
ArgumentException | The given value for lhs is not finite -or- The given value for lhs is not a number -or- The given value for rhs is not finite -or- The given value for rhs is not a number -or- The given value for epsilon is not finite -or- The given value for epsilon is not a number
Remarks
The arguments may be thought of as the left and right operands of a binary expression; for example, "a < b", "x >= 100", etc. The left operand comes from an element in the Revit document (e.g., the value of a parameter.) The right operand is supplied by the user when creating the filter that contains the rule that uses this evaluator.
See Also

Reference

FilterNumericRuleEvaluator Class
Evaluate Overload


FilterNumericValueRule Class

Base for all classes that use a FilterNumericRuleEvaluator to perform their comparisons
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterRule
Autodesk.Revit.DBFilterValueRule
Autodesk.Revit.DBFilterNumericValueRule
Autodesk.Revit.DBFilterDoubleRule
Autodesk.Revit.DBFilterElementIdRule
Autodesk.Revit.DBFilterGlobalParameterAssociationRule
Autodesk.Revit.DBFilterIntegerRule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilterNumericValueRule : FilterValueRule
Public Class FilterNumericValueRule
    Inherits FilterValueRule
public ref class FilterNumericValueRule : public FilterValueRule
type FilterNumericValueRule =
    class
        inherit FilterValueRule
    end

The FilterNumericValueRule type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterRule)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetEvaluator | Gets the evaluator that implements the test for this rule.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetEvaluator | Sets the evaluator that implements the test for this rule.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FilterNumericValueRule Properties

The FilterNumericValueRule type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule)
Top
See Also

Reference

FilterNumericValueRule Class


FilterNumericValueRule Methods

The FilterNumericValueRule type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterRule)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetEvaluator | Gets the evaluator that implements the test for this rule.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetEvaluator | Sets the evaluator that implements the test for this rule.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FilterNumericValueRule Class


FilterNumericValueRule.GetEvaluator Method

FilterNumericValueRuleGetEvaluator Method

Gets the evaluator that implements the test for this rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterNumericRuleEvaluator GetEvaluator()
Public Function GetEvaluator As FilterNumericRuleEvaluator
public:
FilterNumericRuleEvaluator^ GetEvaluator()
member GetEvaluator : unit -> FilterNumericRuleEvaluator

Return Value

FilterNumericRuleEvaluator
See Also

Reference

FilterNumericValueRule Class


FilterNumericValueRule.SetEvaluator Method

FilterNumericValueRuleSetEvaluator Method

Sets the evaluator that implements the test for this rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetEvaluator(
    FilterNumericRuleEvaluator evaluator
)
Public Sub SetEvaluator (
    evaluator As FilterNumericRuleEvaluator
)
public:
void SetEvaluator(
    FilterNumericRuleEvaluator^ evaluator
)
member SetEvaluator :
        evaluator : FilterNumericRuleEvaluator -> unit

Parameters

evaluator FilterNumericRuleEvaluator
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FilterNumericValueRule Class


FilterOperatorAndTextString Class

An instance of this class holds a filter operator and a text string that denotes the operator in a particular context. For example, the text string for ScheduleFilterType::LessThan may be "is less than" for a filter rule based on a parameter with numerical values or "is below" for a filter rule based on a parameter representing a Level.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterOperatorAndTextString

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilterOperatorAndTextString : IDisposable
Public Class FilterOperatorAndTextString
    Implements IDisposable
public ref class FilterOperatorAndTextString : IDisposable
type FilterOperatorAndTextString =
    class
        interface IDisposable
    end

The FilterOperatorAndTextString type exposes the following members.

Properties
 | Name | Description
Public property | FilterOperatorStr | A text string denoting the filter operator.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OperatorType | The filter operator.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the FilterOperatorAndTextString
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FilterOperatorAndTextString Properties

The FilterOperatorAndTextString type exposes the following members.

Properties
 | Name | Description
Public property | FilterOperatorStr | A text string denoting the filter operator.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OperatorType | The filter operator.
Top
See Also

Reference

FilterOperatorAndTextString Class


FilterOperatorAndTextString.FilterOperatorStr Property

FilterOperatorAndTextStringFilterOperatorStr Property

A text string denoting the filter operator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FilterOperatorStr { get; }
Public ReadOnly Property FilterOperatorStr As String
    Get
public:
property String^ FilterOperatorStr {
    String^ get ();
}
member FilterOperatorStr : string with get

Property Value

String
See Also

Reference

FilterOperatorAndTextString Class


FilterOperatorAndTextString.IsValidObject Property

FilterOperatorAndTextStringIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

FilterOperatorAndTextString Class


FilterOperatorAndTextString.OperatorType Property

FilterOperatorAndTextStringOperatorType Property

The filter operator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScheduleFilterType OperatorType { get; }
Public ReadOnly Property OperatorType As ScheduleFilterType
    Get
public:
property ScheduleFilterType OperatorType {
    ScheduleFilterType get ();
}
member OperatorType : ScheduleFilterType with get

Property Value

ScheduleFilterType
See Also

Reference

FilterOperatorAndTextString Class


FilterOperatorAndTextString Methods

The FilterOperatorAndTextString type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FilterOperatorAndTextString Class


FilterOperatorAndTextString.Dispose Method

FilterOperatorAndTextStringDispose Method

Releases all resources used by the FilterOperatorAndTextString

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FilterOperatorAndTextString Class


FilterRule Class

Defines a boolean operation that can be used to cull elements from a document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterRule
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilterRule : IDisposable
Public Class FilterRule
    Implements IDisposable
public ref class FilterRule : IDisposable
type FilterRule =
    class
        interface IDisposable
    end

The FilterRule type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the FilterRule
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterRule
Autodesk.Revit.DBFilterCategoryRule
Autodesk.Revit.DBFilterInverseRule
Autodesk.Revit.DBFilterValueRule
Autodesk.Revit.DBParameterValuePresenceRule
Autodesk.Revit.DBSharedParameterApplicableRule


FilterRule Properties

The FilterRule type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

FilterRule Class


FilterRule.IsValidObject Property

FilterRuleIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

FilterRule Class


FilterRule Methods

The FilterRule type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FilterRule Class


FilterRule.Dispose Method

FilterRuleDispose Method

Releases all resources used by the FilterRule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FilterRule Class


FilterRule.ElementPasses Method

FilterRuleElementPasses Method

Derived classes override this method to implement the test that determines whether the given element passes this rule or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ElementPasses(
    Element element
)
Public Function ElementPasses (
    element As Element
) As Boolean
public:
bool ElementPasses(
    Element^ element
)
member ElementPasses :
        element : Element -> bool

Parameters

element Element
The element to test against the rule.

Return Value

Boolean
True if the element satisfies the rule, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FilterRule Class


FilterRule.GetRuleParameter Method

FilterRuleGetRuleParameter Method

Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GetRuleParameter()
Public Function GetRuleParameter As ElementId
public:
ElementId^ GetRuleParameter()
member GetRuleParameter : unit -> ElementId

Return Value

ElementId
The parameter id if there is an associated parameter, or invalidElementId if not.
See Also

Reference

FilterRule Class


FilterStringBeginsWith Class

Tests whether string values from the document begin with a certain string.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterStringRuleEvaluator
Autodesk.Revit.DBFilterStringBeginsWith

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilterStringBeginsWith : FilterStringRuleEvaluator
Public Class FilterStringBeginsWith
    Inherits FilterStringRuleEvaluator
public ref class FilterStringBeginsWith : public FilterStringRuleEvaluator
type FilterStringBeginsWith =
    class
        inherit FilterStringRuleEvaluator
    end

The FilterStringBeginsWith type exposes the following members.

Constructors
 | Name | Description
Public method | FilterStringBeginsWith | Constructs an instance of FilterStringBeginsWith.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterStringRuleEvaluator)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterStringRuleEvaluator)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
All string comparisons in this class are performed in the case-insensitive manner.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FilterStringBeginsWith Constructor

Constructs an instance of FilterStringBeginsWith.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterStringBeginsWith()
Public Sub New
public:
FilterStringBeginsWith()
new : unit -> FilterStringBeginsWith
See Also

Reference

FilterStringBeginsWith Class


FilterStringBeginsWith Properties

The FilterStringBeginsWith type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterStringRuleEvaluator)
Top
See Also

Reference

FilterStringBeginsWith Class


FilterStringBeginsWith Methods

The FilterStringBeginsWith type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterStringRuleEvaluator)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FilterStringBeginsWith Class


FilterStringContains Class

Tests whether string values from the document contain a certain string.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterStringRuleEvaluator
Autodesk.Revit.DBFilterStringContains

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilterStringContains : FilterStringRuleEvaluator
Public Class FilterStringContains
    Inherits FilterStringRuleEvaluator
public ref class FilterStringContains : public FilterStringRuleEvaluator
type FilterStringContains =
    class
        inherit FilterStringRuleEvaluator
    end

The FilterStringContains type exposes the following members.

Constructors
 | Name | Description
Public method | FilterStringContains | Constructs an instance of FilterStringContains.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterStringRuleEvaluator)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterStringRuleEvaluator)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
All string comparisons in this class are performed in the case-insensitive manner.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FilterStringContains Constructor

Constructs an instance of FilterStringContains.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterStringContains()
Public Sub New
public:
FilterStringContains()
new : unit -> FilterStringContains
See Also

Reference

FilterStringContains Class


FilterStringContains Properties

The FilterStringContains type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterStringRuleEvaluator)
Top
See Also

Reference

FilterStringContains Class


FilterStringContains Methods

The FilterStringContains type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterStringRuleEvaluator)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FilterStringContains Class


FilterStringEndsWith Class

Tests whether string values from the document end with a certain string.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterStringRuleEvaluator
Autodesk.Revit.DBFilterStringEndsWith

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilterStringEndsWith : FilterStringRuleEvaluator
Public Class FilterStringEndsWith
    Inherits FilterStringRuleEvaluator
public ref class FilterStringEndsWith : public FilterStringRuleEvaluator
type FilterStringEndsWith =
    class
        inherit FilterStringRuleEvaluator
    end

The FilterStringEndsWith type exposes the following members.

Constructors
 | Name | Description
Public method | FilterStringEndsWith | Constructs an instance of FilterStringEndsWith.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterStringRuleEvaluator)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterStringRuleEvaluator)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
All string comparisons in this class are performed in the case-insensitive manner.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FilterStringEndsWith Constructor

Constructs an instance of FilterStringEndsWith.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterStringEndsWith()
Public Sub New
public:
FilterStringEndsWith()
new : unit -> FilterStringEndsWith
See Also

Reference

FilterStringEndsWith Class


FilterStringEndsWith Properties

The FilterStringEndsWith type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterStringRuleEvaluator)
Top
See Also

Reference

FilterStringEndsWith Class


FilterStringEndsWith Methods

The FilterStringEndsWith type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterStringRuleEvaluator)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FilterStringEndsWith Class


FilterStringEquals Class

Tests whether string values from the document match a certain string.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterStringRuleEvaluator
Autodesk.Revit.DBFilterStringEquals

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilterStringEquals : FilterStringRuleEvaluator
Public Class FilterStringEquals
    Inherits FilterStringRuleEvaluator
public ref class FilterStringEquals : public FilterStringRuleEvaluator
type FilterStringEquals =
    class
        inherit FilterStringRuleEvaluator
    end

The FilterStringEquals type exposes the following members.

Constructors
 | Name | Description
Public method | FilterStringEquals | Constructs an instance of FilterStringEquals.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterStringRuleEvaluator)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterStringRuleEvaluator)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
All string comparisons in this class are performed in the case-insensitive manner.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FilterStringEquals Constructor

Constructs an instance of FilterStringEquals.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterStringEquals()
Public Sub New
public:
FilterStringEquals()
new : unit -> FilterStringEquals
See Also

Reference

FilterStringEquals Class


FilterStringEquals Properties

The FilterStringEquals type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterStringRuleEvaluator)
Top
See Also

Reference

FilterStringEquals Class


FilterStringEquals Methods

The FilterStringEquals type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterStringRuleEvaluator)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FilterStringEquals Class


FilterStringGreater Class

Tests whether string values from the document would sort after a certain string.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterStringRuleEvaluator
Autodesk.Revit.DBFilterStringGreater

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilterStringGreater : FilterStringRuleEvaluator
Public Class FilterStringGreater
    Inherits FilterStringRuleEvaluator
public ref class FilterStringGreater : public FilterStringRuleEvaluator
type FilterStringGreater =
    class
        inherit FilterStringRuleEvaluator
    end

The FilterStringGreater type exposes the following members.

Constructors
 | Name | Description
Public method | FilterStringGreater | Constructs an instance of FilterStringGreater.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterStringRuleEvaluator)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterStringRuleEvaluator)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
All string comparisons in this class are performed in the case-insensitive manner.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FilterStringGreater Constructor

Constructs an instance of FilterStringGreater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterStringGreater()
Public Sub New
public:
FilterStringGreater()
new : unit -> FilterStringGreater
See Also

Reference

FilterStringGreater Class


FilterStringGreater Properties

The FilterStringGreater type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterStringRuleEvaluator)
Top
See Also

Reference

FilterStringGreater Class


FilterStringGreater Methods

The FilterStringGreater type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterStringRuleEvaluator)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FilterStringGreater Class


FilterStringGreaterOrEqual Class

Tests whether string values from the document would sort after or match a certain string.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterStringRuleEvaluator
Autodesk.Revit.DBFilterStringGreaterOrEqual

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilterStringGreaterOrEqual : FilterStringRuleEvaluator
Public Class FilterStringGreaterOrEqual
    Inherits FilterStringRuleEvaluator
public ref class FilterStringGreaterOrEqual : public FilterStringRuleEvaluator
type FilterStringGreaterOrEqual =
    class
        inherit FilterStringRuleEvaluator
    end

The FilterStringGreaterOrEqual type exposes the following members.

Constructors
 | Name | Description
Public method | FilterStringGreaterOrEqual | Constructs an instance of FilterStringGreaterOrEqual.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterStringRuleEvaluator)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterStringRuleEvaluator)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
All string comparisons in this class are performed in the case-insensitive manner.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FilterStringGreaterOrEqual Constructor

Constructs an instance of FilterStringGreaterOrEqual.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterStringGreaterOrEqual()
Public Sub New
public:
FilterStringGreaterOrEqual()
new : unit -> FilterStringGreaterOrEqual
See Also

Reference

FilterStringGreaterOrEqual Class


FilterStringGreaterOrEqual Properties

The FilterStringGreaterOrEqual type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterStringRuleEvaluator)
Top
See Also

Reference

FilterStringGreaterOrEqual Class


FilterStringGreaterOrEqual Methods

The FilterStringGreaterOrEqual type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterStringRuleEvaluator)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FilterStringGreaterOrEqual Class


FilterStringLess Class

Tests whether string values from the document would sort before a certain string.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterStringRuleEvaluator
Autodesk.Revit.DBFilterStringLess

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilterStringLess : FilterStringRuleEvaluator
Public Class FilterStringLess
    Inherits FilterStringRuleEvaluator
public ref class FilterStringLess : public FilterStringRuleEvaluator
type FilterStringLess =
    class
        inherit FilterStringRuleEvaluator
    end

The FilterStringLess type exposes the following members.

Constructors
 | Name | Description
Public method | FilterStringLess | Constructs an instance of FilterStringLess.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterStringRuleEvaluator)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterStringRuleEvaluator)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
All string comparisons in this class are performed in the case-insensitive manner.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FilterStringLess Constructor

Constructs an instance of FilterStringLess.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterStringLess()
Public Sub New
public:
FilterStringLess()
new : unit -> FilterStringLess
See Also

Reference

FilterStringLess Class


FilterStringLess Properties

The FilterStringLess type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterStringRuleEvaluator)
Top
See Also

Reference

FilterStringLess Class


FilterStringLess Methods

The FilterStringLess type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterStringRuleEvaluator)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FilterStringLess Class


FilterStringLessOrEqual Class

Tests whether string values from the document would sort before or match a certain string.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterStringRuleEvaluator
Autodesk.Revit.DBFilterStringLessOrEqual

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilterStringLessOrEqual : FilterStringRuleEvaluator
Public Class FilterStringLessOrEqual
    Inherits FilterStringRuleEvaluator
public ref class FilterStringLessOrEqual : public FilterStringRuleEvaluator
type FilterStringLessOrEqual =
    class
        inherit FilterStringRuleEvaluator
    end

The FilterStringLessOrEqual type exposes the following members.

Constructors
 | Name | Description
Public method | FilterStringLessOrEqual | Constructs an instance of FilterStringLessOrEqual.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterStringRuleEvaluator)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterStringRuleEvaluator)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
All string comparisons in this class are performed in the case-insensitive manner.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FilterStringLessOrEqual Constructor

Constructs an instance of FilterStringLessOrEqual.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterStringLessOrEqual()
Public Sub New
public:
FilterStringLessOrEqual()
new : unit -> FilterStringLessOrEqual
See Also

Reference

FilterStringLessOrEqual Class


FilterStringLessOrEqual Properties

The FilterStringLessOrEqual type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterStringRuleEvaluator)
Top
See Also

Reference

FilterStringLessOrEqual Class


FilterStringLessOrEqual Methods

The FilterStringLessOrEqual type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterStringRuleEvaluator)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FilterStringLessOrEqual Class


FilterStringRule Class

A filter rule that operates on string values in a Revit project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterRule
Autodesk.Revit.DBFilterValueRule
Autodesk.Revit.DBFilterStringRule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilterStringRule : FilterValueRule
Public Class FilterStringRule
    Inherits FilterValueRule
public ref class FilterStringRule : public FilterValueRule
type FilterStringRule =
    class
        inherit FilterValueRule
    end

The FilterStringRule type exposes the following members.

Constructors
 | Name | Description
Public method | FilterStringRule | Constructs an instance of FilterStringRule.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule)
Public property | RuleString | The user-supplied string against which strings from a Revit document will be tested.
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterRule)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetEvaluator | Gets the evaluator that implements the test for this rule.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetEvaluator | Sets the evaluator that implements the test for this rule.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
All string comparisons in this class are performed in the case-insensitive manner.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FilterStringRule Constructor

Constructs an instance of FilterStringRule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterStringRule(
    FilterableValueProvider valueProvider,
    FilterStringRuleEvaluator evaluator,
    string ruleString
)
Public Sub New (
    valueProvider As FilterableValueProvider,
    evaluator As FilterStringRuleEvaluator,
    ruleString As String
)
public:
FilterStringRule(
    FilterableValueProvider^ valueProvider,
    FilterStringRuleEvaluator^ evaluator,
    String^ ruleString
)
new :
        valueProvider : FilterableValueProvider *
        evaluator : FilterStringRuleEvaluator *
        ruleString : string -> FilterStringRule

Parameters

valueProvider FilterableValueProvider
A pointer to a "value provider" object that will extract values from a Revit document.
evaluator FilterStringRuleEvaluator
A pointer to the filter rule evaluator object that implements the desired test. The built-in evaluators implement commonly used tests for strings such as begins-with, ends-with, contains, equal, etc.
ruleString String
The user-supplied string against which strings from a Revit document will be tested.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FilterStringRule Class


FilterStringRule Properties

The FilterStringRule type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule)
Public property | RuleString | The user-supplied string against which strings from a Revit document will be tested.
Top
See Also

Reference

FilterStringRule Class


FilterStringRule.RuleString Property

FilterStringRuleRuleString Property

The user-supplied string against which strings from a Revit document will be tested.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string RuleString { get; set; }
Public Property RuleString As String
    Get
    Set
public:
property String^ RuleString {
    String^ get ();
    void set (String^ value);
}
member RuleString : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

FilterStringRule Class


FilterStringRule Methods

The FilterStringRule type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterRule)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetEvaluator | Gets the evaluator that implements the test for this rule.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetEvaluator | Sets the evaluator that implements the test for this rule.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FilterStringRule Class


FilterStringRule.GetEvaluator Method

FilterStringRuleGetEvaluator Method

Gets the evaluator that implements the test for this rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilterStringRuleEvaluator GetEvaluator()
Public Function GetEvaluator As FilterStringRuleEvaluator
public:
FilterStringRuleEvaluator^ GetEvaluator()
member GetEvaluator : unit -> FilterStringRuleEvaluator

Return Value

FilterStringRuleEvaluator
See Also

Reference

FilterStringRule Class


FilterStringRule.SetEvaluator Method

FilterStringRuleSetEvaluator Method

Sets the evaluator that implements the test for this rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetEvaluator(
    FilterStringRuleEvaluator evaluator
)
Public Sub SetEvaluator (
    evaluator As FilterStringRuleEvaluator
)
public:
void SetEvaluator(
    FilterStringRuleEvaluator^ evaluator
)
member SetEvaluator :
        evaluator : FilterStringRuleEvaluator -> unit

Parameters

evaluator FilterStringRuleEvaluator
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FilterStringRule Class


FilterStringRuleEvaluator Class

Base for all classes that compare string values from Revit to a user-supplied filter value
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterStringRuleEvaluator
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilterStringRuleEvaluator : IDisposable
Public Class FilterStringRuleEvaluator
    Implements IDisposable
public ref class FilterStringRuleEvaluator : IDisposable
type FilterStringRuleEvaluator =
    class
        interface IDisposable
    end

The FilterStringRuleEvaluator type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the FilterStringRuleEvaluator
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterStringRuleEvaluator
Autodesk.Revit.DBFilterStringBeginsWith
Autodesk.Revit.DBFilterStringContains
Autodesk.Revit.DBFilterStringEndsWith
Autodesk.Revit.DBFilterStringEquals
Autodesk.Revit.DBFilterStringGreater
Autodesk.Revit.DBFilterStringGreaterOrEqual
Autodesk.Revit.DBFilterStringLess
Autodesk.Revit.DBFilterStringLessOrEqual


FilterStringRuleEvaluator Properties

The FilterStringRuleEvaluator type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

FilterStringRuleEvaluator Class


FilterStringRuleEvaluator.IsValidObject Property

FilterStringRuleEvaluatorIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

FilterStringRuleEvaluator Class


FilterStringRuleEvaluator Methods

The FilterStringRuleEvaluator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FilterStringRuleEvaluator Class


FilterStringRuleEvaluator.Dispose Method

FilterStringRuleEvaluatorDispose Method

Releases all resources used by the FilterStringRuleEvaluator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FilterStringRuleEvaluator Class


FilterStringRuleEvaluator.Evaluate Method

FilterStringRuleEvaluatorEvaluate Method

Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Evaluate(
    string lhs,
    string rhs,
    bool caseSensitive
)
Public Function Evaluate (
    lhs As String,
    rhs As String,
    caseSensitive As Boolean
) As Boolean
public:
bool Evaluate(
    String^ lhs,
    String^ rhs,
    bool caseSensitive
)
member Evaluate :
        lhs : string *
        rhs : string *
        caseSensitive : bool -> bool

Parameters

lhs String
A value from an element in the document.
rhs String
The user-supplied value against which values from the document are tested.
caseSensitive Boolean
If true, string comparisons are done case-sensitively.

Return Value

Boolean
True if the given arguments satisfy the condition, otherwise false.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
The arguments may be thought of as the left and right operands of a binary expression; for example, "a < b", "x >= 100", etc. The left operand comes from an element in the Revit document (e.g., the value of a parameter.) The right operand is supplied by the user when creating the filter that contains the rule that uses this evaluator.
See Also

Reference

FilterStringRuleEvaluator Class


FilterValueRule Class

A rule that filters on a particular value of an element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterRule
Autodesk.Revit.DBFilterValueRule
Autodesk.Revit.DBFilterNumericValueRule
Autodesk.Revit.DBFilterStringRule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FilterValueRule : FilterRule
Public Class FilterValueRule
    Inherits FilterRule
public ref class FilterValueRule : public FilterRule
type FilterValueRule =
    class
        inherit FilterRule
    end

The FilterValueRule type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterRule)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FilterValueRule Properties

The FilterValueRule type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule)
Top
See Also

Reference

FilterValueRule Class


FilterValueRule Methods

The FilterValueRule type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterRule)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FilterValueRule Class


FindReferenceTarget Enumeration

The type of reference to find from a ReferenceIntersector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum FindReferenceTarget
Public Enumeration FindReferenceTarget
public enum class FindReferenceTarget
type FindReferenceTarget
Members
Member name | Value | Description
Element | 1 | An element.
Mesh | 2 | A mesh.
Edge | 4 | An edge.
Curve | 8 | A curve.
Face | 16 | A face.
All | 31 | All target types.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FitDirectionType Enumeration

This enum is used to define the direction to fit the number of pixels defined by PixelSize.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum FitDirectionType
Public Enumeration FitDirectionType
public enum class FitDirectionType
type FitDirectionType
Members
Member name | Value | Description
Horizontal | 0 | Fit a specific number of pixels in horizontal direction.
Vertical | 1 | Fit a specific number of pixels in vertical direction.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FittingAndAccessoryCalculationType Enumeration

The MEP fitting and accessory pressure drop calculation type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum FittingAndAccessoryCalculationType
Public Enumeration FittingAndAccessoryCalculationType
public enum class FittingAndAccessoryCalculationType
type FittingAndAccessoryCalculationType
Members
Member name | Value | Description
Undefined | 0 | Undefined fitting and accessory pressure drop calculation type.
CalculatePressureDrop | 1 | To calculate the pressure drop of the fitting and accessory.
CalculateDefaultSettings | 2 | To calculate the default settings of the fitting and accessory.
ValidateCurrentSettings | 4 | To validate the current settings of the fitting and accessory.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FittingAngleUsage Enumeration

An enumerated type representing the options for how to limit the angle values applicable to fitting content.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum FittingAngleUsage
Public Enumeration FittingAngleUsage
public enum class FittingAngleUsage
type FittingAngleUsage
Members
Member name | Value | Description
UseAnyAngle | 0 | Uses any angle supported by fitting content.
UseAnAngleIncrement | 1 | Uses the increment to determine the angle value.
UseSpecificAngles | 2 | Uses only the angles specified.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Floor Class

An object that represents a Floor within the Autodesk Revit project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBHostObject
Autodesk.Revit.DBCeilingAndFloor
Autodesk.Revit.DBFloor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Floor : CeilingAndFloor
Public Class Floor
    Inherits CeilingAndFloor
public ref class Floor : public CeilingAndFloor
type Floor =
    class
        inherit CeilingAndFloor
    end

The Floor type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FloorType | Retrieves/sets an object that represents the type of the floor.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SketchId | Returns id of the sketch.
Public property | SlabShapeEditor | Obsolete. Get the SlabShapeEditor used for slab shape editing.
Public property | SpanDirectionAngle | Retrieve the span direction angle of the floor.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create(Document, IListCurveLoop, ElementId, ElementId) | Creates a new instance of architectural floor within the project.
 | Create(Document, IListCurveLoop, ElementId, ElementId, Boolean, Line, Double) | Creates a new instance of floor within the project.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject)
 | GetDefaultFloorType | Returns id of default floor type.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetNormalAtVerticalProjectionPoint | Return a surface normal on either the top or bottom face of a floor slab at a point corresponding to the vertical projection of an arbitrary point in project space.
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSlabShapeEditor | Gets a SlabShapeEditor that can be used to add or modify points of this Floor.
Public method | GetSpanDirectionSymbolIds | Retrieves span direction symbol ElementIds.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetVerticalProjectionPoint | Return a surface point on either the top or bottom face of a floor slab corresponding to the vertical projection of an arbitrary point in project space.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object.
Example
C#
VB
C++
F#
Copy
public void ShowFloorInfo(Floor floor)
{
    string message = "Floor : ";
    // Get Floor type name
    message += "\nFloor type name is : " + floor.FloorType.Name;
    try
    {
        // Get Floor span direction angle
        message += "\nFloor span direction angle is : " + floor.SpanDirectionAngle;
    }
    catch (Exception)
    {
        // an exception is thrown if floor is non-structural
        message += "\nFloor is non-structural.";
    }

    TaskDialog.Show("Revit",message);

}
Public Sub ShowFloorInfo(floor As Floor)
 Dim message As String = "Floor : "
 ' Get Floor type name
 message += vbLf & "Floor type name is : " & Convert.ToString(floor.FloorType.Name)
    Try
        ' Get Floor span direction angle
        message += vbLf & "Floor span direction angle is : " & Convert.ToString(floor.SpanDirectionAngle)
    Catch generatedExceptionName As Exception
        ' an exception is thrown if floor is non-structural
        message += vbLf & "Floor is non-structural."
    End Try

    TaskDialog.Show("Revit", message)

End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Floor Properties

The Floor type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FloorType | Retrieves/sets an object that represents the type of the floor.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SketchId | Returns id of the sketch.
Public property | SlabShapeEditor | Obsolete. Get the SlabShapeEditor used for slab shape editing.
Public property | SpanDirectionAngle | Retrieve the span direction angle of the floor.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

Floor Class


Floor.FloorType Property

FloorFloorType Property

Retrieves/sets an object that represents the type of the floor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FloorType FloorType { get; set; }
Public Property FloorType As FloorType
    Get
    Set
public:
property FloorType^ FloorType {
    FloorType^ get ();
    void set (FloorType^ value);
}
member FloorType : FloorType with get, set

Property Value

FloorType
Exceptions
Exception | Condition
ArgumentException | When setting this property: Floor type is not valid for this floor.
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
The floor type can be used to access the multi layered structure of a floor.
See Also

Reference

Floor Class


Floor.SketchId Property

FloorSketchId Property

Returns id of the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId SketchId { get; }
Public ReadOnly Property SketchId As ElementId
    Get
public:
property ElementId^ SketchId {
    ElementId^ get ();
}
member SketchId : ElementId with get

Property Value

ElementId
See Also

Reference

Floor Class


Floor.SlabShapeEditor Property

FloorSlabShapeEditor Property

Note: This API is now obsolete.

Get the SlabShapeEditor used for slab shape editing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is deprecated in Revit 2024 and may be removed in a future version of Revit. Use GetSlabShapeEditor() instead.")]
public SlabShapeEditor SlabShapeEditor { get; }
<ObsoleteAttribute("This method is deprecated in Revit 2024 and may be removed in a future version of Revit. Use GetSlabShapeEditor() instead.")>
Public ReadOnly Property SlabShapeEditor As SlabShapeEditor
    Get
public:
[ObsoleteAttribute(L"This method is deprecated in Revit 2024 and may be removed in a future version of Revit. Use GetSlabShapeEditor() instead.")]
property SlabShapeEditor^ SlabShapeEditor {
    SlabShapeEditor^ get ();
}
[<ObsoleteAttribute("This method is deprecated in Revit 2024 and may be removed in a future version of Revit. Use GetSlabShapeEditor() instead.")>]
member SlabShapeEditor : SlabShapeEditor with get

Property Value

SlabShapeEditor
Remarks
Only flat and horizontal floor is valid for slab shape edit. Otherwise, ShapeEditor will be .
See Also

Reference

Floor Class


Floor.SpanDirectionAngle Property

FloorSpanDirectionAngle Property

Retrieve the span direction angle of the floor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double SpanDirectionAngle { get; set; }
Public Property SpanDirectionAngle As Double
    Get
    Set
public:
property double SpanDirectionAngle {
    double get ();
    void set (double value);
}
member SpanDirectionAngle : float with get, set

Property Value

Double
Exceptions
Exception | Condition
InvalidOperationException | When setting this property:
Remarks
The angle returned is in radians. An exception will be thrown if the floor is non structural.
See Also

Reference

Floor Class


Floor Methods

The Floor type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create(Document, IListCurveLoop, ElementId, ElementId) | Creates a new instance of architectural floor within the project.
 | Create(Document, IListCurveLoop, ElementId, ElementId, Boolean, Line, Double) | Creates a new instance of floor within the project.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject)
 | GetDefaultFloorType | Returns id of default floor type.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetNormalAtVerticalProjectionPoint | Return a surface normal on either the top or bottom face of a floor slab at a point corresponding to the vertical projection of an arbitrary point in project space.
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSlabShapeEditor | Gets a SlabShapeEditor that can be used to add or modify points of this Floor.
Public method | GetSpanDirectionSymbolIds | Retrieves span direction symbol ElementIds.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetVerticalProjectionPoint | Return a surface point on either the top or bottom face of a floor slab corresponding to the vertical projection of an arbitrary point in project space.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Floor Class


Floor.Create Method

FloorCreate Method

Overload List
Name | Description
Create(Document, IListCurveLoop, ElementId, ElementId) | Creates a new instance of architectural floor within the project.
Create(Document, IListCurveLoop, ElementId, ElementId, Boolean, Line, Double) | Creates a new instance of floor within the project.
Top
See Also

Reference

Floor Class


Floor.Create(Document, IList<CurveLoop>, ElementId, ElementId) Method

FloorCreate(Document, IListCurveLoop, ElementId, ElementId) Method

Creates a new instance of architectural floor within the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Floor Create(
    Document document,
    IList<CurveLoop> profile,
    ElementId floorTypeId,
    ElementId levelId
)
Public Shared Function Create (
    document As Document,
    profile As IList(Of CurveLoop),
    floorTypeId As ElementId,
    levelId As ElementId
) As Floor
public:
static Floor^ Create(
    Document^ document,
    IList<CurveLoop^>^ profile,
    ElementId^ floorTypeId,
    ElementId^ levelId
)
static member Create :
        document : Document *
        profile : IList<CurveLoop> *
        floorTypeId : ElementId *
        levelId : ElementId -> Floor

Parameters

document Document
The document in which the new floor is created.
profile IList CurveLoop
An array of planar curve loops that represent the profile of the floor.
floorTypeId ElementId
Id of the floor type to be used by the new Floor.
levelId ElementId
Id of the level on which the floor is to be placed.

Return Value

Floor
If successful a new floor object within the project.
Exceptions
Exception | Condition
ArgumentException | The ElementId levelId is not a Level. -or- The floorTypeId does not correspond to a FloorType. -or- The input curve loops cannot compose a valid boundary, that means: the "curveLoops" collection is empty; or some curve loops intersect with each other; or each curve loop is not closed individually; or each curve loop is not planar; or each curve loop is not in a plane parallel to the horizontal(XY) plane; or input curves contain at least one helical curve. -or- Input curves build invalid sketch. -or- Failed to create curve elements.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Cannot generate a sketch. -or- Failed to create new element.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
To validate curve loop profile use BoundaryValidation. To get default floor type use GetDefaultFloorType(Document, Boolean).
Example
C#
VB
C++
F#
Copy
/// The example below shows how to use Floor.Create method to create a new structural floor (slab) on one level
/// using a geometry profile and a floor type.
/// In this sample, the geometry profile is a CurveLoop of lines, you can also use arcs, ellipses and splines.
Floor CreateFloor(Document document, Level level)
{
   // Get a floor type for floor creation
   ElementId floorTypeId = Floor.GetDefaultFloorType(document, false);

   // Build a floor profile for the floor creation
   XYZ first = new XYZ(0, 0, 0);
   XYZ second = new XYZ(20, 0, 0);
   XYZ third = new XYZ(20, 15, 0);
   XYZ fourth = new XYZ(0, 15, 0);
   CurveLoop profile = new CurveLoop();
   profile.Append(Line.CreateBound(first, second));
   profile.Append(Line.CreateBound(second, third));
   profile.Append(Line.CreateBound(third, fourth));
   profile.Append(Line.CreateBound(fourth, first));

   return Floor.Create(document, new List<CurveLoop> { profile }, floorTypeId, level.Id);
}
Private Function CreateFloor(application As UIApplication, level As Level) As Floor
   ' Get the Revit document
   Dim document As Autodesk.Revit.DB.Document = application.ActiveUIDocument.Document

   ' Get the application creation object
   Dim appCreation As Autodesk.Revit.Creation.Application = application.Application.Create

   ' Get a floor type for floor creation
   Dim collector As New FilteredElementCollector(document)
   collector.OfClass(GetType(FloorType))
   Dim floorType As FloorType = TryCast(collector.FirstElement(), FloorType)

   ' Build a floor profile for the floor creation
   Dim first As New XYZ(0, 0, 0)
   Dim second As New XYZ(20, 0, 0)
   Dim third As New XYZ(20, 15, 0)
   Dim fourth As New XYZ(0, 15, 0)
   Dim profile As New CurveLoop()
   profile.Append(Line.CreateBound(first, second))
   profile.Append(Line.CreateBound(second, third))
   profile.Append(Line.CreateBound(third, fourth))
   profile.Append(Line.CreateBound(fourth, first))

   Return Floor.Create(document, New List(Of CurveLoop)({profile}), floorType.Id, level.Id)
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

C#
VB
C++
F#
Copy
/// The example below shows how to use Floor.Create method to create a new Floor with specified elevation, on one level
/// using a geometry profile and a floor type.
/// It shows how to adapt your code that used NewFloor and NewSlab methods, which are obsolete since 2022.
/// In this sample, the geometry profile is a CurveLoop of lines, you can also use arcs, ellipses and splines.
Floor CreateFloorAtElevation(Document document, double elevation)
{
   // Get a floor type for floor creation
   // You must provide a valid floor type (unlike in now obsolete NewFloor and NewSlab methods).
   ElementId floorTypeId = Floor.GetDefaultFloorType(document, false);

   // Get a level
   // You must provide a valid level (unlike in now obsolete NewFloor and NewSlab methods).
   double offset;
   ElementId levelId = Level.GetNearestLevelId(document, elevation, out offset);

   // Build a floor profile for the floor creation
   XYZ first = new XYZ(0, 0, 0);
   XYZ second = new XYZ(20, 0, 0);
   XYZ third = new XYZ(20, 15, 0);
   XYZ fourth = new XYZ(0, 15, 0);
   CurveLoop profile = new CurveLoop();
   profile.Append(Line.CreateBound(first, second));
   profile.Append(Line.CreateBound(second, third));
   profile.Append(Line.CreateBound(third, fourth));
   profile.Append(Line.CreateBound(fourth, first));

   // The elevation of the curve loops is not taken into account (unlike in now obsolete NewFloor and NewSlab methods).
   // If the default elevation is not what you want, you need to set it explicitly.
   var floor = Floor.Create(document, new List<CurveLoop> { profile }, floorTypeId, levelId);
   Parameter param = floor.get_Parameter(BuiltInParameter.FLOOR_HEIGHTABOVELEVEL_PARAM);
   param.Set(offset);

   return floor;
}
Private Function CreateFloorAtElevation(ByVal document As Document, ByVal elevation As Double) As Floor
   ' Get a floor type for floor creation
   ' You must provide a valid floor type (unlike in now obsolete NewFloor and NewSlab methods).
   Dim floorTypeId As ElementId = Autodesk.Revit.DB.Floor.GetDefaultFloorType(document, False)

   ' Get a level
   ' You must provide a valid level (unlike in now obsolete NewFloor and NewSlab methods).
   Dim offset As Double
   Dim levelId = Level.GetNearestLevelId(document, elevation, offset)

   ' Build a floor profile for the floor creation
   Dim first As XYZ = New XYZ(0, 0, 0)
   Dim second As XYZ = New XYZ(20, 0, 0)
   Dim third As XYZ = New XYZ(20, 15, 0)
   Dim fourth As XYZ = New XYZ(0, 15, 0)
   Dim profile As CurveLoop = New CurveLoop()
   profile.Append(Line.CreateBound(first, second))
   profile.Append(Line.CreateBound(second, third))
   profile.Append(Line.CreateBound(third, fourth))
   profile.Append(Line.CreateBound(fourth, first))

   ' The elevation of the curve loops is not taken into account (unlike in now obsolete NewFloor and NewSlab methods).
   ' If the default elevation is not what you want, you need to set it explicitly.
   Dim floor = Autodesk.Revit.DB.Floor.Create(document, New List(Of CurveLoop) From {
             profile
         }, floorTypeId, levelId)
   Dim param As Parameter = floor.Parameter(BuiltInParameter.FLOOR_HEIGHTABOVELEVEL_PARAM)
   param.Set(offset)
   Return floor
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Floor Class
Create Overload


Floor.Create(Document, IList<CurveLoop>, ElementId, ElementId, Boolean, Line, Double) Method

FloorCreate(Document, IListCurveLoop, ElementId, ElementId, Boolean, Line, Double) Method

Creates a new instance of floor within the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Floor Create(
    Document document,
    IList<CurveLoop> profile,
    ElementId floorTypeId,
    ElementId levelId,
    bool isStructural,
    Line slopeArrow,
    double slope
)
Public Shared Function Create (
    document As Document,
    profile As IList(Of CurveLoop),
    floorTypeId As ElementId,
    levelId As ElementId,
    isStructural As Boolean,
    slopeArrow As Line,
    slope As Double
) As Floor
public:
static Floor^ Create(
    Document^ document,
    IList<CurveLoop^>^ profile,
    ElementId^ floorTypeId,
    ElementId^ levelId,
    bool isStructural,
    Line^ slopeArrow,
    double slope
)
static member Create :
        document : Document *
        profile : IList<CurveLoop> *
        floorTypeId : ElementId *
        levelId : ElementId *
        isStructural : bool *
        slopeArrow : Line *
        slope : float -> Floor

Parameters

document Document
The document in which the new floor is created.
profile IList CurveLoop
An array of planar curve loops that represent the profile of the floor.
floorTypeId ElementId
Id of the floor type to be used by the new Floor.
levelId ElementId
Id of the level on which the floor is to be placed.
isStructural Boolean
True if new floor should be structural, false if architectural.
slopeArrow Line
A line used to control the slope angle of the Floor. It must be horizontal. If slopeArrow is , the horizontal floor will be created.
slope Double
The slope angle. If slopeArrow is , this parameter will be ignored.

Return Value

Floor
If successful a new floor object within the project.
Exceptions
Exception | Condition
ArgumentException | The ElementId levelId is not a Level. -or- The floorTypeId does not correspond to a FloorType. -or- The input curve loops cannot compose a valid boundary, that means: the "curveLoops" collection is empty; or some curve loops intersect with each other; or each curve loop is not closed individually; or each curve loop is not planar; or each curve loop is not in a plane parallel to the horizontal(XY) plane; or input curves contain at least one helical curve. -or- The slopeArrow must be a horizontal line. -or- Input curves build invalid sketch. -or- Failed to create curve elements.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Cannot generate a sketch. -or- Failed to create new element.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
To validate curve loop profile use BoundaryValidation. To get default floor type use GetDefaultFloorType(Document, Boolean).
Example
C#
VB
C++
F#
Copy
/// The example below shows how to use Floor.Create method to create a new slopped floor on one level
/// using a geometry profile and a floor type.
/// In this sample, the geometry profile is a CurveLoop of lines, you can also use arcs, ellipses and splines.
Floor CreateSlopedFloor(Document document, Level level)
{
   // Get a floor type for floor creation
   ElementId floorTypeId = Floor.GetDefaultFloorType(document, false);

   // Build a floor profile for the floor creation
   XYZ first = new XYZ(0, 0, 0);
   XYZ second = new XYZ(20, 0, 0);
   XYZ third = new XYZ(20, 20, 0);
   XYZ fourth = new XYZ(0, 20, 0);
   CurveLoop profile = new CurveLoop();
   profile.Append(Line.CreateBound(first, second));
   profile.Append(Line.CreateBound(second, third));
   profile.Append(Line.CreateBound(third, fourth));
   profile.Append(Line.CreateBound(fourth, first));

   Line slopeArrow = Line.CreateBound(new XYZ(10, 10, 0), new XYZ(11, 10, 0));
   return Floor.Create(document, new List<CurveLoop> { profile }, floorTypeId, level.Id, true, slopeArrow, Math.PI / 2);
}
Private Function CreateSlopedFloor(ByVal document As Document, ByVal level As Level) As Floor
   Dim floorTypeId As ElementId = Floor.GetDefaultFloorType(document, False)
   Dim first As XYZ = New XYZ(0, 0, 0)
   Dim second As XYZ = New XYZ(20, 0, 0)
   Dim third As XYZ = New XYZ(20, 20, 0)
   Dim fourth As XYZ = New XYZ(0, 20, 0)
   Dim profile As CurveLoop = New CurveLoop()
   profile.Append(Line.CreateBound(first, second))
   profile.Append(Line.CreateBound(second, third))
   profile.Append(Line.CreateBound(third, fourth))
   profile.Append(Line.CreateBound(fourth, first))
   Dim slopeArrow As Line = Line.CreateBound(New XYZ(10, 10, 0), New XYZ(11, 10, 0))
   Return Floor.Create(document, New List(Of CurveLoop) From {
          profile
      }, floorTypeId, level.Id, True, slopeArrow, Math.PI / 2)
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Floor Class
Create Overload


Floor.GetDefaultFloorType Method

FloorGetDefaultFloorType Method

Returns id of default floor type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ElementId GetDefaultFloorType(
    Document document,
    bool isFoundation
)
Public Shared Function GetDefaultFloorType (
    document As Document,
    isFoundation As Boolean
) As ElementId
public:
static ElementId^ GetDefaultFloorType(
    Document^ document,
    bool isFoundation
)
static member GetDefaultFloorType :
        document : Document *
        isFoundation : bool -> ElementId

Parameters

document Document
The document.
isFoundation Boolean
True to return id of foundation floor type.

Return Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

Floor Class


Floor.GetNormalAtVerticalProjectionPoint Method

FloorGetNormalAtVerticalProjectionPoint Method

Return a surface normal on either the top or bottom face of a floor slab at a point corresponding to the vertical projection of an arbitrary point in project space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ GetNormalAtVerticalProjectionPoint(
    XYZ modelLocation,
    FloorFace floorFace
)
Public Function GetNormalAtVerticalProjectionPoint (
    modelLocation As XYZ,
    floorFace As FloorFace
) As XYZ
public:
XYZ^ GetNormalAtVerticalProjectionPoint(
    XYZ^ modelLocation,
    FloorFace floorFace
)
member GetNormalAtVerticalProjectionPoint :
        modelLocation : XYZ *
        floorFace : FloorFace -> XYZ

Parameters

modelLocation XYZ
A point in project coordinates whose vertical projection will determine the location at which the normal will be taken.
floorFace FloorFace
A flag determining whether the top or bottom face of the floor should be used.

Return Value

XYZ
Normal vector on the slab at the projection point.
Remarks
If the floor is shape edited, the floor location at which we attempt to take the normal must be within the boundaries of a face on the slab. Otherwise the method will return .
See Also

Reference

Floor Class


Floor.GetSlabShapeEditor Method

FloorGetSlabShapeEditor Method

Gets a SlabShapeEditor that can be used to add or modify points of this Floor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SlabShapeEditor GetSlabShapeEditor()
Public Function GetSlabShapeEditor As SlabShapeEditor
public:
SlabShapeEditor^ GetSlabShapeEditor()
member GetSlabShapeEditor : unit -> SlabShapeEditor

Return Value

SlabShapeEditor
The SlabShapeEditor object
See Also

Reference

Floor Class


Floor.GetSpanDirectionSymbolIds Method

FloorGetSpanDirectionSymbolIds Method

Retrieves span direction symbol ElementIds.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetSpanDirectionSymbolIds()
Public Function GetSpanDirectionSymbolIds As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetSpanDirectionSymbolIds()
member GetSpanDirectionSymbolIds : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
A collection of Element Ids of span direction symbol elements
Remarks
The element types of the Ids of these symbols determine if the floor has one way or two way span direction graphics.
See Also

Reference

Floor Class


Floor.GetVerticalProjectionPoint Method

FloorGetVerticalProjectionPoint Method

Return a surface point on either the top or bottom face of a floor slab corresponding to the vertical projection of an arbitrary point in project space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ GetVerticalProjectionPoint(
    XYZ modelLocation,
    FloorFace floorFace
)
Public Function GetVerticalProjectionPoint (
    modelLocation As XYZ,
    floorFace As FloorFace
) As XYZ
public:
XYZ^ GetVerticalProjectionPoint(
    XYZ^ modelLocation,
    FloorFace floorFace
)
member GetVerticalProjectionPoint :
        modelLocation : XYZ *
        floorFace : FloorFace -> XYZ

Parameters

modelLocation XYZ
A point in project coordinates that will be projected to the slab top or bottom face.
floorFace FloorFace
A flag determining whether the top or bottom face of the floor should be used.

Return Value

XYZ
Slab surface point for the vertically projected model point.
Remarks
If the floor is shape edited, the surface location must be within the boundaries of a face on the slab. Otherwise the method will return .
See Also

Reference

Floor Class


FloorFace Enumeration

An enumerated type listing floor face types (top or bottom)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum FloorFace
Public Enumeration FloorFace
public enum class FloorFace
type FloorFace
Members
Member name | Value | Description
Top | 0 |
Bottom | 1 |
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FloorType Class

An object that specifies the type of a floor in Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBHostObjAttributes
Autodesk.Revit.DBFloorType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FloorType : HostObjAttributes
Public Class FloorType
    Inherits HostObjAttributes
public ref class FloorType : public HostObjAttributes
type FloorType =
    class
        inherit HostObjAttributes
    end

The FloorType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsFoundationSlab | Returns whether the element FloorAttributes type is FoundationSlab.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | StructuralMaterialId | Returns the identifier of the material that defines the element's structural analysis properties.
Public property | ThermalProperties | The calculated and settable thermal properties of the FloorType
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The structural layers of the floor can be accessed via this object.
Example
C#
VB
C++
F#
Copy
public void GetInfo_FloorType(FloorType floorType)
{
    string message;
    // Get whether FloorType is a foundation slab
    message = "If is foundation slab : " + floorType.IsFoundationSlab;
    TaskDialog.Show("Revit",message);
}
Public Sub GetInfo_FloorType(floorType As FloorType)
    Dim message As String
    ' Get whether FloorType is a foundation slab
    message = "If is foundation slab : " & Convert.ToString(floorType.IsFoundationSlab)
    TaskDialog.Show("Revit", message)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FloorType Properties

The FloorType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsFoundationSlab | Returns whether the element FloorAttributes type is FoundationSlab.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | StructuralMaterialId | Returns the identifier of the material that defines the element's structural analysis properties.
Public property | ThermalProperties | The calculated and settable thermal properties of the FloorType
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

FloorType Class


FloorType.IsFoundationSlab Property

FloorTypeIsFoundationSlab Property

Returns whether the element FloorAttributes type is FoundationSlab.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsFoundationSlab { get; }
Public ReadOnly Property IsFoundationSlab As Boolean
    Get
public:
property bool IsFoundationSlab {
    bool get ();
}
member IsFoundationSlab : bool with get

Property Value

Boolean
See Also

Reference

FloorType Class


FloorType.StructuralMaterialId Property

FloorTypeStructuralMaterialId Property

Returns the identifier of the material that defines the element's structural analysis properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId StructuralMaterialId { get; set; }
Public Property StructuralMaterialId As ElementId
    Get
    Set
public:
property ElementId^ StructuralMaterialId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member StructuralMaterialId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
InvalidOperationException | When setting this property: the floor does not have a structural material
See Also

Reference

FloorType Class


FloorType.ThermalProperties Property

FloorTypeThermalProperties Property

The calculated and settable thermal properties of the FloorType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ThermalProperties ThermalProperties { get; }
Public ReadOnly Property ThermalProperties As ThermalProperties
    Get
public:
property ThermalProperties^ ThermalProperties {
    ThermalProperties^ get ();
}
member ThermalProperties : ThermalProperties with get

Property Value

ThermalProperties
Exceptions
Exception | Condition
InvalidOperationException | the floor does not have thermal properties.
See Also

Reference

FloorType Class


FloorType Methods

The FloorType type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FloorType Class


FlowDirectionType Enumeration

An enumerated type listing direction types for a connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum FlowDirectionType
Public Enumeration FlowDirectionType
public enum class FlowDirectionType
type FlowDirectionType
Members
Member name | Value | Description
Bidirectional | 0 | Flow bidirectional
In | 1 | Flow in
Out | 2 | Flow out
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FolderItemInfo Class

Contains data for each folder item in the organization settings of the project browser including folder parameter Id and folder name.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFolderItemInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FolderItemInfo : IDisposable
Public Class FolderItemInfo
    Implements IDisposable
public ref class FolderItemInfo : IDisposable
type FolderItemInfo =
    class
        interface IDisposable
    end

The FolderItemInfo type exposes the following members.

Properties
 | Name | Description
Public property | ElementId | The folder parameter Id
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The folder name
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the FolderItemInfo
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
FolderItemInfo is the return value of BrowserOrganization.GetFolderItems().
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FolderItemInfo Properties

The FolderItemInfo type exposes the following members.

Properties
 | Name | Description
Public property | ElementId | The folder parameter Id
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The folder name
Top
See Also

Reference

FolderItemInfo Class


FolderItemInfo.ElementId Property

FolderItemInfoElementId Property

The folder parameter Id

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId ElementId { get; }
Public ReadOnly Property ElementId As ElementId
    Get
public:
property ElementId^ ElementId {
    ElementId^ get ();
}
member ElementId : ElementId with get

Property Value

ElementId
See Also

Reference

FolderItemInfo Class


FolderItemInfo.IsValidObject Property

FolderItemInfoIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

FolderItemInfo Class


FolderItemInfo.Name Property

FolderItemInfoName Property

The folder name

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

String
See Also

Reference

FolderItemInfo Class


FolderItemInfo Methods

The FolderItemInfo type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FolderItemInfo Class


FolderItemInfo.Dispose Method

FolderItemInfoDispose Method

Releases all resources used by the FolderItemInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FolderItemInfo Class


FootPrintRoof Class

Represents kinds of FootPrintRoofs.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBHostObject
Autodesk.Revit.DBRoofBase
Autodesk.Revit.DBFootPrintRoof

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FootPrintRoof : RoofBase
Public Class FootPrintRoof
    Inherits RoofBase
public ref class FootPrintRoof : public RoofBase
type FootPrintRoof =
    class
        inherit RoofBase
    end

The FootPrintRoof type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CurtainGrids | Retrieve all the CurtainGrid objects of a FootPrintRoof.
Public property | DefinesSlope | Retrieve or set the DefinesSlope of the curve.
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | EaveCuts | Retrieve or set the EaveCutterType. (Inherited from RoofBase)
Public property | ExtendIntoWall | Retrieve or set whether extend into wall the curve.
Public property | FasciaDepth | Retrieve or set the FasciaDepth. (Inherited from RoofBase)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | Offset | Retrieve or set the Offset of the curve.
Public property | Overhang | Retrieve or set the Overhang of the curve.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | RoofType | Retrieve or set the Type. (Inherited from RoofBase)
Public property | SlabShapeEditor | Obsolete. Get the SlabShapeEditor used for slab shape editing. (Inherited from RoofBase)
Public property | SlopeAngle | Retrieve or set the SlopeAngle of the curve.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetProfiles | Retrieve all the curveLoops of FootPrintRoof.
Public method | GetSlabShapeEditor | Gets a SlabShapeEditor that can used to add or modify points of this RoofBase. (Inherited from RoofBase)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The FootPrintRoof object represents some kinds of FootPrintRoof in Revit. The RoofType property is used to distinguish the type of the roof.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FootPrintRoof Properties

The FootPrintRoof type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CurtainGrids | Retrieve all the CurtainGrid objects of a FootPrintRoof.
Public property | DefinesSlope | Retrieve or set the DefinesSlope of the curve.
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | EaveCuts | Retrieve or set the EaveCutterType. (Inherited from RoofBase)
Public property | ExtendIntoWall | Retrieve or set whether extend into wall the curve.
Public property | FasciaDepth | Retrieve or set the FasciaDepth. (Inherited from RoofBase)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | Offset | Retrieve or set the Offset of the curve.
Public property | Overhang | Retrieve or set the Overhang of the curve.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | RoofType | Retrieve or set the Type. (Inherited from RoofBase)
Public property | SlabShapeEditor | Obsolete. Get the SlabShapeEditor used for slab shape editing. (Inherited from RoofBase)
Public property | SlopeAngle | Retrieve or set the SlopeAngle of the curve.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

FootPrintRoof Class


FootPrintRoof.CurtainGrids Property

FootPrintRoofCurtainGrids Property

Retrieve all the CurtainGrid objects of a FootPrintRoof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurtainGridSet CurtainGrids { get; }
Public ReadOnly Property CurtainGrids As CurtainGridSet
    Get
public:
property CurtainGridSet^ CurtainGrids {
    CurtainGridSet^ get ();
}
member CurtainGrids : CurtainGridSet with get

Property Value

CurtainGridSet
Remarks
Only applicable when the object is a Curtain FootPrintRoof.
See Also

Reference

FootPrintRoof Class


FootPrintRoof.DefinesSlope Property

FootPrintRoofDefinesSlope Property

Retrieve or set the DefinesSlope of the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool this[
    ModelCurve pCurve
] { get; set; }
Public Property DefinesSlope (
    pCurve As ModelCurve
) As Boolean
    Get
    Set
public:
property bool DefinesSlope[ModelCurve^ pCurve] {
    bool get (ModelCurve^ pCurve);
    void set (ModelCurve^ pCurve, bool value);
}
member DefinesSlope : bool with get, set

Parameters

pCurve ModelCurve

Property Value

Boolean
See Also

Reference

FootPrintRoof Class


FootPrintRoof.ExtendIntoWall Property

FootPrintRoofExtendIntoWall Property

Retrieve or set whether extend into wall the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool this[
    ModelCurve pCurve
] { get; set; }
Public Property ExtendIntoWall (
    pCurve As ModelCurve
) As Boolean
    Get
    Set
public:
property bool ExtendIntoWall[ModelCurve^ pCurve] {
    bool get (ModelCurve^ pCurve);
    void set (ModelCurve^ pCurve, bool value);
}
member ExtendIntoWall : bool with get, set

Parameters

pCurve ModelCurve

Property Value

Boolean
Remarks
Only applicable when the FootPrintRoof is created with Pick Walls.
See Also

Reference

FootPrintRoof Class


FootPrintRoof.Offset Property

FootPrintRoofOffset Property

Retrieve or set the Offset of the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double this[
    ModelCurve pCurve
] { get; set; }
Public Property Offset (
    pCurve As ModelCurve
) As Double
    Get
    Set
public:
property double Offset[ModelCurve^ pCurve] {
    double get (ModelCurve^ pCurve);
    void set (ModelCurve^ pCurve, double value);
}
member Offset : float with get, set

Parameters

pCurve ModelCurve

Property Value

Double
See Also

Reference

FootPrintRoof Class


FootPrintRoof.Overhang Property

FootPrintRoofOverhang Property

Retrieve or set the Overhang of the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double this[
    ModelCurve pCurve
] { get; set; }
Public Property Overhang (
    pCurve As ModelCurve
) As Double
    Get
    Set
public:
property double Overhang[ModelCurve^ pCurve] {
    double get (ModelCurve^ pCurve);
    void set (ModelCurve^ pCurve, double value);
}
member Overhang : float with get, set

Parameters

pCurve ModelCurve

Property Value

Double
Remarks
Only applicable when the FootPrintRoof is created with Pick Walls.
See Also

Reference

FootPrintRoof Class


FootPrintRoof.SlopeAngle Property

FootPrintRoofSlopeAngle Property

Retrieve or set the SlopeAngle of the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double this[
    ModelCurve pCurve
] { get; set; }
Public Property SlopeAngle (
    pCurve As ModelCurve
) As Double
    Get
    Set
public:
property double SlopeAngle[ModelCurve^ pCurve] {
    double get (ModelCurve^ pCurve);
    void set (ModelCurve^ pCurve, double value);
}
member SlopeAngle : float with get, set

Parameters

pCurve ModelCurve

Property Value

Double
Remarks
The value is a "slope" measurement. For example, 0.5 is one unit of rise for each 2 units of run. This creates a slope of 26.57 degrees (the arctangent of 0.5).
See Also

Reference

FootPrintRoof Class


FootPrintRoof Methods

The FootPrintRoof type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetProfiles | Retrieve all the curveLoops of FootPrintRoof.
Public method | GetSlabShapeEditor | Gets a SlabShapeEditor that can used to add or modify points of this RoofBase. (Inherited from RoofBase)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FootPrintRoof Class


FootPrintRoof.GetProfiles Method

FootPrintRoofGetProfiles Method

Retrieve all the curveLoops of FootPrintRoof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ModelCurveArrArray GetProfiles()
Public Function GetProfiles As ModelCurveArrArray
public:
ModelCurveArrArray^ GetProfiles()
member GetProfiles : unit -> ModelCurveArrArray

Return Value

ModelCurveArrArray
See Also

Reference

FootPrintRoof Class


ForgeTypeId Class

This class holds a string that uniquely identifies a Forge schema.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBForgeTypeId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ForgeTypeId : IDisposable
Public Class ForgeTypeId
    Implements IDisposable
public ref class ForgeTypeId : IDisposable
type ForgeTypeId =
    class
        interface IDisposable
    end

The ForgeTypeId type exposes the following members.

Constructors
 | Name | Description
Public method | ForgeTypeId | Constructs a ForgeTypeId holding an empty schema identifier.
Public method | ForgeTypeId(String) | Constructs a ForgeTypeId holding the given schema identifier.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | TypeId | The schema identifier.
Top
Methods
 | Name | Description
Public method | Clear | Sets the typeId to an empty string
Public method | Dispose | Releases all resources used by the ForgeTypeId
Public method | Empty | Checks if the typeId is an empty string
Public method | Equals | Determines whether this ForgeTypeId is equal to another. (Overrides ObjectEquals(Object))
Public method | GetHashCode | Returns the hash code for this ForgeTypeId (Overrides ObjectGetHashCode)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | NameEquals | Returns true if the typeid string held by this ForgeTypeId is equal to that held by the given ForgeTypeId, excluding the version number. The version number of a typeid string follows a hyphen character. This function compares the typeid strings up to the first hyphen. This is the default equality comparison method for the ForgeTypeId class, used by the equality operator (==).
Public method | StrictlyEquals | Returns true if the entire typeid string held by this ForgeTypeId is exactly equal to that held by the given ForgeTypeId. For the default equality comparison used by the equality operator (==), see NameEquals(ForgeTypeId).
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Operators
Name | Description
Equality(ForgeTypeId, ForgeTypeId) |
Inequality(ForgeTypeId, ForgeTypeId) |
LessThan(ForgeTypeId, ForgeTypeId) |
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ForgeTypeId Constructor

Overload List
 | Name | Description
Public method | ForgeTypeId | Constructs a ForgeTypeId holding an empty schema identifier.
Public method | ForgeTypeId(String) | Constructs a ForgeTypeId holding the given schema identifier.
Top
See Also

Reference

ForgeTypeId Class


ForgeTypeId Constructor

Constructs a ForgeTypeId holding an empty schema identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ForgeTypeId()
Public Sub New
public:
ForgeTypeId()
new : unit -> ForgeTypeId
See Also

Reference

ForgeTypeId Class
ForgeTypeId Overload


ForgeTypeId(String) Constructor

Constructs a ForgeTypeId holding the given schema identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ForgeTypeId(
    string typeId
)
Public Sub New (
    typeId As String
)
public:
ForgeTypeId(
    String^ typeId
)
new :
        typeId : string -> ForgeTypeId

Parameters

typeId String
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ForgeTypeId Class
ForgeTypeId Overload


ForgeTypeId Properties

The ForgeTypeId type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | TypeId | The schema identifier.
Top
See Also

Reference

ForgeTypeId Class


ForgeTypeId.IsValidObject Property

ForgeTypeIdIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ForgeTypeId Class


ForgeTypeId.TypeId Property

ForgeTypeIdTypeId Property

The schema identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TypeId { get; set; }
Public Property TypeId As String
    Get
    Set
public:
property String^ TypeId {
    String^ get ();
    void set (String^ value);
}
member TypeId : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ForgeTypeId Class


ForgeTypeId Methods

The ForgeTypeId type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Sets the typeId to an empty string
Public method | Dispose |
Public method | Empty | Checks if the typeId is an empty string
Public method | Equals | Determines whether this ForgeTypeId is equal to another. (Overrides ObjectEquals(Object))
Public method | GetHashCode | Returns the hash code for this ForgeTypeId (Overrides ObjectGetHashCode)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | NameEquals | Returns true if the typeid string held by this ForgeTypeId is equal to that held by the given ForgeTypeId, excluding the version number. The version number of a typeid string follows a hyphen character. This function compares the typeid strings up to the first hyphen. This is the default equality comparison method for the ForgeTypeId class, used by the equality operator (==).
Public method | StrictlyEquals | Returns true if the entire typeid string held by this ForgeTypeId is exactly equal to that held by the given ForgeTypeId. For the default equality comparison used by the equality operator (==), see NameEquals(ForgeTypeId).
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ForgeTypeId Class


ForgeTypeId.Clear Method

ForgeTypeIdClear Method

Sets the typeId to an empty string

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ForgeTypeId Clear()
Public Function Clear As ForgeTypeId
public:
ForgeTypeId^ Clear()
member Clear : unit -> ForgeTypeId

Return Value

ForgeTypeId
See Also

Reference

ForgeTypeId Class


ForgeTypeId.Dispose Method

ForgeTypeIdDispose Method

Releases all resources used by the ForgeTypeId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ForgeTypeId Class


ForgeTypeId.Empty Method

ForgeTypeIdEmpty Method

Checks if the typeId is an empty string

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Empty()
Public Function Empty As Boolean
public:
bool Empty()
member Empty : unit -> bool

Return Value

Boolean
See Also

Reference

ForgeTypeId Class


ForgeTypeId.Equals Method

ForgeTypeIdEquals Method

Determines whether this ForgeTypeId is equal to another.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object other
)
Public Overrides Function Equals (
    other As Object
) As Boolean
public:
virtual bool Equals(
    Object^ other
) override
abstract Equals :
        other : Object -> bool
override Equals :
        other : Object -> bool

Parameters

other Object
The ForgeTypeId with which to compare this ForgeTypeId.

Return Value

Boolean
True if the given ForgeTypeId is equal to this one, or false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was NULL
See Also

Reference

ForgeTypeId Class


ForgeTypeId.GetHashCode Method

ForgeTypeIdGetHashCode Method

Returns the hash code for this ForgeTypeId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Int32
A 32-bit signed integer hash code.
See Also

Reference

ForgeTypeId Class


ForgeTypeId.NameEquals Method

ForgeTypeIdNameEquals Method

Returns true if the typeid string held by this ForgeTypeId is equal to that held by the given ForgeTypeId, excluding the version number. The version number of a typeid string follows a hyphen character. This function compares the typeid strings up to the first hyphen. This is the default equality comparison method for the ForgeTypeId class, used by the equality operator (==).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool NameEquals(
    ForgeTypeId other
)
Public Function NameEquals (
    other As ForgeTypeId
) As Boolean
public:
bool NameEquals(
    ForgeTypeId^ other
)
member NameEquals :
        other : ForgeTypeId -> bool

Parameters

other ForgeTypeId

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ForgeTypeId Class


ForgeTypeId.StrictlyEquals Method

ForgeTypeIdStrictlyEquals Method

Returns true if the entire typeid string held by this ForgeTypeId is exactly equal to that held by the given ForgeTypeId. For the default equality comparison used by the equality operator (==), see NameEquals(ForgeTypeId).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool StrictlyEquals(
    ForgeTypeId other
)
Public Function StrictlyEquals (
    other As ForgeTypeId
) As Boolean
public:
bool StrictlyEquals(
    ForgeTypeId^ other
)
member StrictlyEquals :
        other : ForgeTypeId -> bool

Parameters

other ForgeTypeId

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ForgeTypeId Class


ForgeTypeId Operators

The ForgeTypeId type exposes the following members.

Operators
Name | Description
Equality(ForgeTypeId, ForgeTypeId) |
Inequality(ForgeTypeId, ForgeTypeId) |
LessThan(ForgeTypeId, ForgeTypeId) |
Top
See Also

Reference

ForgeTypeId Class


ForgeTypeId.Equality Operator

ForgeTypeIdEquality Operator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool operator ==(
    ForgeTypeId lhs,
    ForgeTypeId rhs
)
Public Shared Operator = (
    lhs As ForgeTypeId,
    rhs As ForgeTypeId
) As Boolean
public:
static bool operator ==(
    ForgeTypeId^ lhs,
    ForgeTypeId^ rhs
)
static let inline (=)
        lhs : ForgeTypeId *
        rhs : ForgeTypeId  : bool

Parameters

lhs ForgeTypeId
rhs ForgeTypeId

Return Value

Boolean
See Also

Reference

ForgeTypeId Class


ForgeTypeId.Inequality Operator

ForgeTypeIdInequality Operator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool operator !=(
    ForgeTypeId lhs,
    ForgeTypeId rhs
)
Public Shared Operator <> (
    lhs As ForgeTypeId,
    rhs As ForgeTypeId
) As Boolean
public:
static bool operator !=(
    ForgeTypeId^ lhs,
    ForgeTypeId^ rhs
)
static let inline (<>)
        lhs : ForgeTypeId *
        rhs : ForgeTypeId  : bool

Parameters

lhs ForgeTypeId
rhs ForgeTypeId

Return Value

Boolean
See Also

Reference

ForgeTypeId Class


ForgeTypeId.LessThan Operator

ForgeTypeIdLessThan Operator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool operator <(
    ForgeTypeId lhs,
    ForgeTypeId rhs
)
Public Shared Operator < (
    lhs As ForgeTypeId,
    rhs As ForgeTypeId
) As Boolean
public:
static bool operator <(
    ForgeTypeId^ lhs,
    ForgeTypeId^ rhs
)
static let inline (<)
        lhs : ForgeTypeId *
        rhs : ForgeTypeId  : bool

Parameters

lhs ForgeTypeId
rhs ForgeTypeId

Return Value

Boolean
See Also

Reference

ForgeTypeId Class


Form Class

An object that represents a Form within the Autodesk Revit Massing Family.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBCombinableElement
Autodesk.Revit.DBGenericForm
Autodesk.Revit.DBForm

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Form : GenericForm
Public Class Form
    Inherits GenericForm
public ref class Form : public GenericForm
type Form =
    class
        inherit GenericForm
    end

The Form type exposes the following members.

Properties
 | Name | Description
Public property | AreProfilesConstrained | Get/set if the form's profiles are constrained.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | BaseOffset | Retrieve/set the base offset of the form object. It is only valid for locked form.
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CurveLoopReferencesOnProfile | The curve references in certain curve loop, specified by profile index and curve loop index.
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HasOneOrMoreReferenceProfiles | Tell if the form has any reference profile.
Public property | HasOpenGeometry | Tell if the form has an open geometry.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsInXRayMode | Get/set if the form is in X-Ray mode.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Get and Set the Name property (Inherited from GenericForm)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | PathCurveCount | The number of curves in the form path.
Public property | PathCurveReference | The curve reference in the path, specified by curve index.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ProfileCount | The number of profiles in the form.
Public property | ProfileCurveLoopCount | The number of curve loops in certain profile, specified by profile index.
Public property | Subcategory | The subcategory. (Inherited from GenericForm)
Public property | TopOffset | Retrieve/set the top offset of the form object. It is only valid for locked form.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | AddEdge(Reference, Reference) | Add an edge to the form, connecting two edges on same/different profile, by a pair of specified points.
Public method | AddEdge(Reference, XYZ) | Add an edge to the form, connecting two edges on different profiles, by a specified face of the form and a point on face.
Public method | AddEdge(Reference, Double, Reference, Double) | Add an edge to the form, connecting two edges on same/different profile, by a pair of specified edge/param.
Public method | AddProfile | Add a profile into the form, by a specified edge/param.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | CanManipulateProfile | Tell if a profile can be deleted/moved/rotated.
Public method | CanManipulateSubElement | Tell if a sub element can be deleted/moved/rotated/scaled.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | ConstrainProfiles | Constrain form profiles using the specified profile as primary. This is an advanced version of property "AreProfilesConstrained", allowing specify the primary profile.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteProfile | Delete a profile of the form.
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubElement | Delete a face/edge/curve/vertex of the form, specified by a reference.
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetControlPoints | Given an edge or a curve or a face, return all control points lying on it (in form of geometry references).
Public method | GetCurvesAndEdgesReference | Given a point, return all edges and curves that it is lying on.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPathCurveIndexByCurveReference | Given a reference to certain curve in the path, return its index.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetProfileAndCurveLoopIndexFromReference | Given a reference to certain curve or edge, get the index of its profile and curve loop respectively.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsAutoCreaseEdge | Tell if an edge is an auto-crease on a top/bottom cap face.
Public method | IsBeginningFace | Given a face, tell if it is a beginning cap face.
Public method | IsConnectingEdge | Tell if an edge is a connecting edge on a side face. Connecting edges connect vertices on different profiles.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsCurveReference | Tell if the pick is the reference to a curve of the form.
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsEdgeReference | Tell if the pick is the reference to an edge of the form.
Public method | IsEndFace | Given a face, tell if it is an end cap face.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsFaceReference | Tell if the pick is the reference to a face of the form.
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsProfileEdge | Tell if an edge or curve is generated from a profile.
Public method | IsReferenceOnlyProfile | Tell if the profile is made by referencing existing geometry in the Revit model.
Public method | IsSideFace | Given a face, tell if it is a side face.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | IsVertexReference | Tell if the pick is the reference to a vertex of the form.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
 | MoveProfile | Move a profile of the form, specified by a reference, and an offset vector.
 | MoveSubElement | Move a face/edge/curve/vertex of the form, specified by a reference, and an offset vector.
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | Rehost(Reference, XYZ) | Rehost Form to edge, face or curve.
Public method | Rehost(SketchPlane, XYZ) | Rehost Form to sketch plane
Public method | RotateProfile | Rotate a profile of the form, by a specified angle around a given axis.
Public method | RotateSubElement | Rotate a face/edge/curve/vertex of the form, by a specified angle around a given axis.
Public method | ScaleProfile | Scale a profile of the form, by a specified origin and scale factor.
Public method | ScaleSubElement | Scale a face/edge/curve/vertex of the form, by a specified origin and scale factor.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
For any reference returned from a Form method, its GeometryObject will become invalid after a form modification method, e.g. MoveSubElement. Call the method on the Form object to retrieve the new reference if it is needed after the modification.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Form Properties

The Form type exposes the following members.

Properties
 | Name | Description
Public property | AreProfilesConstrained | Get/set if the form's profiles are constrained.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | BaseOffset | Retrieve/set the base offset of the form object. It is only valid for locked form.
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CurveLoopReferencesOnProfile | The curve references in certain curve loop, specified by profile index and curve loop index.
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HasOneOrMoreReferenceProfiles | Tell if the form has any reference profile.
Public property | HasOpenGeometry | Tell if the form has an open geometry.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsInXRayMode | Get/set if the form is in X-Ray mode.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Get and Set the Name property (Inherited from GenericForm)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | PathCurveCount | The number of curves in the form path.
Public property | PathCurveReference | The curve reference in the path, specified by curve index.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ProfileCount | The number of profiles in the form.
Public property | ProfileCurveLoopCount | The number of curve loops in certain profile, specified by profile index.
Public property | Subcategory | The subcategory. (Inherited from GenericForm)
Public property | TopOffset | Retrieve/set the top offset of the form object. It is only valid for locked form.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

Form Class


Form.AreProfilesConstrained Property

FormAreProfilesConstrained Property

Get/set if the form's profiles are constrained.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AreProfilesConstrained { get; set; }
Public Property AreProfilesConstrained As Boolean
    Get
    Set
public:
property bool AreProfilesConstrained {
    bool get ();
    void set (bool value);
}
member AreProfilesConstrained : bool with get, set

Property Value

Boolean
Exceptions
Exception | Condition
InvalidOperationException | When setting this property to 'true' This operation can only be performed on a swept blend form.
See Also

Reference

Form Class


Form.BaseOffset Property

FormBaseOffset Property

Retrieve/set the base offset of the form object. It is only valid for locked form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double BaseOffset { get; set; }
Public Property BaseOffset As Double
    Get
    Set
public:
property double BaseOffset {
    double get ();
    void set (double value);
}
member BaseOffset : float with get, set

Property Value

Double
Exceptions
Exception | Condition
InvalidOperationException | Thrown when this is not a locked form.
ArgumentException | Thrown when the value is invalid.
ApplicationException | Thrown when it fail to get/set BaseOffset.
See Also

Reference

Form Class


Form.CurveLoopReferencesOnProfile Property

FormCurveLoopReferencesOnProfile Property

The curve references in certain curve loop, specified by profile index and curve loop index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReferenceArray this[
    int profileIndex,
    int curveLoopIndex
] { get; }
Public ReadOnly Property CurveLoopReferencesOnProfile (
    profileIndex As Integer,
    curveLoopIndex As Integer
) As ReferenceArray
    Get
public:
property ReferenceArray^ CurveLoopReferencesOnProfile[int profileIndex, int curveLoopIndex] {
    ReferenceArray^ get (int profileIndex, int curveLoopIndex);
}
member CurveLoopReferencesOnProfile : ReferenceArray with get

Parameters

profileIndex Int32
Index to specify the profile, should be within 0 and (ProfileCount - 1).
curveLoopIndex Int32
Index to specify the curve loop, should be within 0 and (CurveLoopCount - 1).

Property Value

ReferenceArray
See Also

Reference

Form Class


Form.HasOneOrMoreReferenceProfiles Property

FormHasOneOrMoreReferenceProfiles Property

Tell if the form has any reference profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasOneOrMoreReferenceProfiles { get; }
Public ReadOnly Property HasOneOrMoreReferenceProfiles As Boolean
    Get
public:
property bool HasOneOrMoreReferenceProfiles {
    bool get ();
}
member HasOneOrMoreReferenceProfiles : bool with get

Property Value

Boolean
See Also

Reference

Form Class


Form.HasOpenGeometry Property

FormHasOpenGeometry Property

Tell if the form has an open geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasOpenGeometry { get; }
Public ReadOnly Property HasOpenGeometry As Boolean
    Get
public:
property bool HasOpenGeometry {
    bool get ();
}
member HasOpenGeometry : bool with get

Property Value

Boolean
See Also

Reference

Form Class


Form.IsInXRayMode Property

FormIsInXRayMode Property

Get/set if the form is in X-Ray mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsInXRayMode { get; set; }
Public Property IsInXRayMode As Boolean
    Get
    Set
public:
property bool IsInXRayMode {
    bool get ();
    void set (bool value);
}
member IsInXRayMode : bool with get, set

Property Value

Boolean
See Also

Reference

Form Class


Form.PathCurveCount Property

FormPathCurveCount Property

The number of curves in the form path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int PathCurveCount { get; }
Public ReadOnly Property PathCurveCount As Integer
    Get
public:
property int PathCurveCount {
    int get ();
}
member PathCurveCount : int with get

Property Value

Int32
See Also

Reference

Form Class


Form.PathCurveReference Property

FormPathCurveReference Property

The curve reference in the path, specified by curve index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Reference this[
    int curveIndex
] { get; }
Public ReadOnly Property PathCurveReference (
    curveIndex As Integer
) As Reference
    Get
public:
property Reference^ PathCurveReference[int curveIndex] {
    Reference^ get (int curveIndex);
}
member PathCurveReference : Reference with get

Parameters

curveIndex Int32
Index to specify the curve in path

Property Value

Reference
See Also

Reference

Form Class


Form.ProfileCount Property

FormProfileCount Property

The number of profiles in the form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ProfileCount { get; }
Public ReadOnly Property ProfileCount As Integer
    Get
public:
property int ProfileCount {
    int get ();
}
member ProfileCount : int with get

Property Value

Int32
See Also

Reference

Form Class


Form.ProfileCurveLoopCount Property

FormProfileCurveLoopCount Property

The number of curve loops in certain profile, specified by profile index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int this[
    int index
] { get; }
Public ReadOnly Property ProfileCurveLoopCount (
    index As Integer
) As Integer
    Get
public:
property int ProfileCurveLoopCount[int index] {
    int get (int index);
}
member ProfileCurveLoopCount : int with get

Parameters

index Int32
Index to specify the profile, should be within 0 and (ProfileCount - 1).

Property Value

Int32
See Also

Reference

Form Class


Form.TopOffset Property

FormTopOffset Property

Retrieve/set the top offset of the form object. It is only valid for locked form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double TopOffset { get; set; }
Public Property TopOffset As Double
    Get
    Set
public:
property double TopOffset {
    double get ();
    void set (double value);
}
member TopOffset : float with get, set

Property Value

Double
Exceptions
Exception | Condition
InvalidOperationException | Thrown when this is not a locked form.
ArgumentException | Thrown when the value is invalid.
ApplicationException | Thrown when it fail to get/set TopOffset.
See Also

Reference

Form Class


Form Methods

The Form type exposes the following members.

Methods
 | Name | Description
Public method | AddEdge(Reference, Reference) | Add an edge to the form, connecting two edges on same/different profile, by a pair of specified points.
Public method | AddEdge(Reference, XYZ) | Add an edge to the form, connecting two edges on different profiles, by a specified face of the form and a point on face.
Public method | AddEdge(Reference, Double, Reference, Double) | Add an edge to the form, connecting two edges on same/different profile, by a pair of specified edge/param.
Public method | AddProfile | Add a profile into the form, by a specified edge/param.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | CanManipulateProfile | Tell if a profile can be deleted/moved/rotated.
Public method | CanManipulateSubElement | Tell if a sub element can be deleted/moved/rotated/scaled.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | ConstrainProfiles | Constrain form profiles using the specified profile as primary. This is an advanced version of property "AreProfilesConstrained", allowing specify the primary profile.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteProfile | Delete a profile of the form.
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubElement | Delete a face/edge/curve/vertex of the form, specified by a reference.
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetControlPoints | Given an edge or a curve or a face, return all control points lying on it (in form of geometry references).
Public method | GetCurvesAndEdgesReference | Given a point, return all edges and curves that it is lying on.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPathCurveIndexByCurveReference | Given a reference to certain curve in the path, return its index.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetProfileAndCurveLoopIndexFromReference | Given a reference to certain curve or edge, get the index of its profile and curve loop respectively.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsAutoCreaseEdge | Tell if an edge is an auto-crease on a top/bottom cap face.
Public method | IsBeginningFace | Given a face, tell if it is a beginning cap face.
Public method | IsConnectingEdge | Tell if an edge is a connecting edge on a side face. Connecting edges connect vertices on different profiles.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsCurveReference | Tell if the pick is the reference to a curve of the form.
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsEdgeReference | Tell if the pick is the reference to an edge of the form.
Public method | IsEndFace | Given a face, tell if it is an end cap face.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsFaceReference | Tell if the pick is the reference to a face of the form.
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsProfileEdge | Tell if an edge or curve is generated from a profile.
Public method | IsReferenceOnlyProfile | Tell if the profile is made by referencing existing geometry in the Revit model.
Public method | IsSideFace | Given a face, tell if it is a side face.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | IsVertexReference | Tell if the pick is the reference to a vertex of the form.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
 | MoveProfile | Move a profile of the form, specified by a reference, and an offset vector.
 | MoveSubElement | Move a face/edge/curve/vertex of the form, specified by a reference, and an offset vector.
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | Rehost(Reference, XYZ) | Rehost Form to edge, face or curve.
Public method | Rehost(SketchPlane, XYZ) | Rehost Form to sketch plane
Public method | RotateProfile | Rotate a profile of the form, by a specified angle around a given axis.
Public method | RotateSubElement | Rotate a face/edge/curve/vertex of the form, by a specified angle around a given axis.
Public method | ScaleProfile | Scale a profile of the form, by a specified origin and scale factor.
Public method | ScaleSubElement | Scale a face/edge/curve/vertex of the form, by a specified origin and scale factor.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Form Class


Form.AddEdge Method

FormAddEdge Method

Overload List
 | Name | Description
Public method | AddEdge(Reference, Reference) | Add an edge to the form, connecting two edges on same/different profile, by a pair of specified points.
Public method | AddEdge(Reference, XYZ) | Add an edge to the form, connecting two edges on different profiles, by a specified face of the form and a point on face.
Public method | AddEdge(Reference, Double, Reference, Double) | Add an edge to the form, connecting two edges on same/different profile, by a pair of specified edge/param.
Top
See Also

Reference

Form Class


Form.AddEdge(Reference, Reference) Method

FormAddEdge(Reference, Reference) Method

Add an edge to the form, connecting two edges on same/different profile, by a pair of specified points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddEdge(
    Reference startPointReference,
    Reference endPointReference
)
Public Sub AddEdge (
    startPointReference As Reference,
    endPointReference As Reference
)
public:
void AddEdge(
    Reference^ startPointReference,
    Reference^ endPointReference
)
member AddEdge :
        startPointReference : Reference *
        endPointReference : Reference -> unit

Parameters

startPointReference Reference
The geometry reference of start point
endPointReference Reference
The geometry reference of end point
See Also

Reference

Form Class
AddEdge Overload


Form.AddEdge(Reference, XYZ) Method

FormAddEdge(Reference, XYZ) Method

Add an edge to the form, connecting two edges on different profiles, by a specified face of the form and a point on face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddEdge(
    Reference faceReference,
    XYZ point
)
Public Sub AddEdge (
    faceReference As Reference,
    point As XYZ
)
public:
void AddEdge(
    Reference^ faceReference,
    XYZ^ point
)
member AddEdge :
        faceReference : Reference *
        point : XYZ -> unit

Parameters

faceReference Reference
The geometry reference of face
point XYZ
A point on the face, defining the position of edge to be created.
See Also

Reference

Form Class
AddEdge Overload


Form.AddEdge(Reference, Double, Reference, Double) Method

FormAddEdge(Reference, Double, Reference, Double) Method

Add an edge to the form, connecting two edges on same/different profile, by a pair of specified edge/param.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddEdge(
    Reference startEdgeReference,
    double startParam,
    Reference endEdgeReference,
    double endParam
)
Public Sub AddEdge (
    startEdgeReference As Reference,
    startParam As Double,
    endEdgeReference As Reference,
    endParam As Double
)
public:
void AddEdge(
    Reference^ startEdgeReference,
    double startParam,
    Reference^ endEdgeReference,
    double endParam
)
member AddEdge :
        startEdgeReference : Reference *
        startParam : float *
        endEdgeReference : Reference *
        endParam : float -> unit

Parameters

startEdgeReference Reference
The geometry reference of start edge
startParam Double
The param on start edge to specify the location.
endEdgeReference Reference
The geometry reference of end edge
endParam Double
The param on end edge to specify the location.
See Also

Reference

Form Class
AddEdge Overload


Form.AddProfile Method

FormAddProfile Method

Add a profile into the form, by a specified edge/param.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int AddProfile(
    Reference edgeReference,
    double param
)
Public Function AddProfile (
    edgeReference As Reference,
    param As Double
) As Integer
public:
int AddProfile(
    Reference^ edgeReference,
    double param
)
member AddProfile :
        edgeReference : Reference *
        param : float -> int

Parameters

edgeReference Reference
The geometry reference of edge.
param Double
The param on edge to specify the location.

Return Value

Int32
Index of newly created profile.
See Also

Reference

Form Class


Form.CanManipulateProfile Method

FormCanManipulateProfile Method

Tell if a profile can be deleted/moved/rotated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanManipulateProfile(
    int profileIndex
)
Public Function CanManipulateProfile (
    profileIndex As Integer
) As Boolean
public:
bool CanManipulateProfile(
    int profileIndex
)
member CanManipulateProfile :
        profileIndex : int -> bool

Parameters

profileIndex Int32
Index to specify the profile.

Return Value

Boolean
See Also

Reference

Form Class


Form.CanManipulateSubElement Method

FormCanManipulateSubElement Method

Tell if a sub element can be deleted/moved/rotated/scaled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanManipulateSubElement(
    Reference subElementReference
)
Public Function CanManipulateSubElement (
    subElementReference As Reference
) As Boolean
public:
bool CanManipulateSubElement(
    Reference^ subElementReference
)
member CanManipulateSubElement :
        subElementReference : Reference -> bool

Parameters

subElementReference Reference
The geometry reference of face/edge/curve/vertex

Return Value

Boolean
See Also

Reference

Form Class


Form.ConstrainProfiles Method

FormConstrainProfiles Method

Constrain form profiles using the specified profile as primary. This is an advanced version of property "AreProfilesConstrained", allowing specify the primary profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ConstrainProfiles(
    int primaryProfileIndex
)
Public Sub ConstrainProfiles (
    primaryProfileIndex As Integer
)
public:
void ConstrainProfiles(
    int primaryProfileIndex
)
member ConstrainProfiles :
        primaryProfileIndex : int -> unit

Parameters

primaryProfileIndex Int32
Index to specify the profile used as primary profile.
Exceptions
Exception | Condition
InvalidOperationException | This operation can only be performed on a swept blend form.
See Also

Reference

Form Class


Form.DeleteProfile Method

FormDeleteProfile Method

Delete a profile of the form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void DeleteProfile(
    int profileIndex
)
Public Sub DeleteProfile (
    profileIndex As Integer
)
public:
void DeleteProfile(
    int profileIndex
)
member DeleteProfile :
        profileIndex : int -> unit

Parameters

profileIndex Int32
Index to specify the profile.
See Also

Reference

Form Class


Form.DeleteSubElement Method

FormDeleteSubElement Method

Delete a face/edge/curve/vertex of the form, specified by a reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void DeleteSubElement(
    Reference subElementReference
)
Public Sub DeleteSubElement (
    subElementReference As Reference
)
public:
void DeleteSubElement(
    Reference^ subElementReference
)
member DeleteSubElement :
        subElementReference : Reference -> unit

Parameters

subElementReference Reference
The geometry reference of face/edge/curve/vertex
See Also

Reference

Form Class


Form.GetControlPoints Method

FormGetControlPoints Method

Given an edge or a curve or a face, return all control points lying on it (in form of geometry references).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReferenceArray GetControlPoints(
    Reference curveOrEdgeOrFaceReference
)
Public Function GetControlPoints (
    curveOrEdgeOrFaceReference As Reference
) As ReferenceArray
public:
ReferenceArray^ GetControlPoints(
    Reference^ curveOrEdgeOrFaceReference
)
member GetControlPoints :
        curveOrEdgeOrFaceReference : Reference -> ReferenceArray

Parameters

curveOrEdgeOrFaceReference Reference
The reference of an edge or curve or face.

Return Value

ReferenceArray
Reference array containing all control points lying on it.
See Also

Reference

Form Class


Form.GetCurvesAndEdgesReference Method

FormGetCurvesAndEdgesReference Method

Given a point, return all edges and curves that it is lying on.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReferenceArray GetCurvesAndEdgesReference(
    Reference pointReference
)
Public Function GetCurvesAndEdgesReference (
    pointReference As Reference
) As ReferenceArray
public:
ReferenceArray^ GetCurvesAndEdgesReference(
    Reference^ pointReference
)
member GetCurvesAndEdgesReference :
        pointReference : Reference -> ReferenceArray

Parameters

pointReference Reference
The reference of a point.

Return Value

ReferenceArray
Reference array containing all edges and curves that the point is lying on.
See Also

Reference

Form Class


Form.GetPathCurveIndexByCurveReference Method

FormGetPathCurveIndexByCurveReference Method

Given a reference to certain curve in the path, return its index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetPathCurveIndexByCurveReference(
    Reference curveReference
)
Public Function GetPathCurveIndexByCurveReference (
    curveReference As Reference
) As Integer
public:
int GetPathCurveIndexByCurveReference(
    Reference^ curveReference
)
member GetPathCurveIndexByCurveReference :
        curveReference : Reference -> int

Parameters

curveReference Reference
Reference to the curve in path

Return Value

Int32
See Also

Reference

Form Class


Form.GetProfileAndCurveLoopIndexFromReference Method

FormGetProfileAndCurveLoopIndexFromReference Method

Given a reference to certain curve or edge, get the index of its profile and curve loop respectively.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void GetProfileAndCurveLoopIndexFromReference(
    Reference curveOrEdgeReference,
    ref int profileIndex,
    ref int curveLoopIndex
)
Public Sub GetProfileAndCurveLoopIndexFromReference (
    curveOrEdgeReference As Reference,
    ByRef profileIndex As Integer,
    ByRef curveLoopIndex As Integer
)
public:
void GetProfileAndCurveLoopIndexFromReference(
    Reference^ curveOrEdgeReference,
    int% profileIndex,
    int% curveLoopIndex
)
member GetProfileAndCurveLoopIndexFromReference :
        curveOrEdgeReference : Reference *
        profileIndex : int byref *
        curveLoopIndex : int byref -> unit

Parameters

curveOrEdgeReference Reference
Reference to a curve/edge that is part of one profile
profileIndex Int32
Profile index for output
curveLoopIndex Int32
Curve loop index for output
See Also

Reference

Form Class


Form.IsAutoCreaseEdge Method

FormIsAutoCreaseEdge Method

Tell if an edge is an auto-crease on a top/bottom cap face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsAutoCreaseEdge(
    Reference edgeReference
)
Public Function IsAutoCreaseEdge (
    edgeReference As Reference
) As Boolean
public:
bool IsAutoCreaseEdge(
    Reference^ edgeReference
)
member IsAutoCreaseEdge :
        edgeReference : Reference -> bool

Parameters

edgeReference Reference
The reference of the edge to be checked.

Return Value

Boolean
See Also

Reference

Form Class


Form.IsBeginningFace Method

FormIsBeginningFace Method

Given a face, tell if it is a beginning cap face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsBeginningFace(
    Reference faceReference
)
Public Function IsBeginningFace (
    faceReference As Reference
) As Boolean
public:
bool IsBeginningFace(
    Reference^ faceReference
)
member IsBeginningFace :
        faceReference : Reference -> bool

Parameters

faceReference Reference
The reference of the face to be checked.

Return Value

Boolean
See Also

Reference

Form Class


Form.IsConnectingEdge Method

FormIsConnectingEdge Method

Tell if an edge is a connecting edge on a side face. Connecting edges connect vertices on different profiles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsConnectingEdge(
    Reference edgeReference
)
Public Function IsConnectingEdge (
    edgeReference As Reference
) As Boolean
public:
bool IsConnectingEdge(
    Reference^ edgeReference
)
member IsConnectingEdge :
        edgeReference : Reference -> bool

Parameters

edgeReference Reference
The reference of the edge to be checked.

Return Value

Boolean
See Also

Reference

Form Class


Form.IsCurveReference Method

FormIsCurveReference Method

Tell if the pick is the reference to a curve of the form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCurveReference(
    Reference curveReference
)
Public Function IsCurveReference (
    curveReference As Reference
) As Boolean
public:
bool IsCurveReference(
    Reference^ curveReference
)
member IsCurveReference :
        curveReference : Reference -> bool

Parameters

curveReference Reference
Reference to be checked.

Return Value

Boolean
See Also

Reference

Form Class


Form.IsEdgeReference Method

FormIsEdgeReference Method

Tell if the pick is the reference to an edge of the form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEdgeReference(
    Reference edgeReference
)
Public Function IsEdgeReference (
    edgeReference As Reference
) As Boolean
public:
bool IsEdgeReference(
    Reference^ edgeReference
)
member IsEdgeReference :
        edgeReference : Reference -> bool

Parameters

edgeReference Reference
Reference to be checked.

Return Value

Boolean
See Also

Reference

Form Class


Form.IsEndFace Method

FormIsEndFace Method

Given a face, tell if it is an end cap face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEndFace(
    Reference faceReference
)
Public Function IsEndFace (
    faceReference As Reference
) As Boolean
public:
bool IsEndFace(
    Reference^ faceReference
)
member IsEndFace :
        faceReference : Reference -> bool

Parameters

faceReference Reference
The reference of the face to be checked.

Return Value

Boolean
See Also

Reference

Form Class


Form.IsFaceReference Method

FormIsFaceReference Method

Tell if the pick is the reference to a face of the form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsFaceReference(
    Reference faceReference
)
Public Function IsFaceReference (
    faceReference As Reference
) As Boolean
public:
bool IsFaceReference(
    Reference^ faceReference
)
member IsFaceReference :
        faceReference : Reference -> bool

Parameters

faceReference Reference
Reference to be checked.

Return Value

Boolean
See Also

Reference

Form Class


Form.IsProfileEdge Method

FormIsProfileEdge Method

Tell if an edge or curve is generated from a profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsProfileEdge(
    Reference curveOrEdgeReference
)
Public Function IsProfileEdge (
    curveOrEdgeReference As Reference
) As Boolean
public:
bool IsProfileEdge(
    Reference^ curveOrEdgeReference
)
member IsProfileEdge :
        curveOrEdgeReference : Reference -> bool

Parameters

curveOrEdgeReference Reference
The reference of the edge or curve to be checked.

Return Value

Boolean
See Also

Reference

Form Class


Form.IsReferenceOnlyProfile Method

FormIsReferenceOnlyProfile Method

Tell if the profile is made by referencing existing geometry in the Revit model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsReferenceOnlyProfile(
    int profileIndex
)
Public Function IsReferenceOnlyProfile (
    profileIndex As Integer
) As Boolean
public:
bool IsReferenceOnlyProfile(
    int profileIndex
)
member IsReferenceOnlyProfile :
        profileIndex : int -> bool

Parameters

profileIndex Int32
Index to specify the profile to be checked.

Return Value

Boolean
See Also

Reference

Form Class


Form.IsSideFace Method

FormIsSideFace Method

Given a face, tell if it is a side face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSideFace(
    Reference faceReference
)
Public Function IsSideFace (
    faceReference As Reference
) As Boolean
public:
bool IsSideFace(
    Reference^ faceReference
)
member IsSideFace :
        faceReference : Reference -> bool

Parameters

faceReference Reference
The reference of the face to be checked.

Return Value

Boolean
See Also

Reference

Form Class


Form.IsVertexReference Method

FormIsVertexReference Method

Tell if the pick is the reference to a vertex of the form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsVertexReference(
    Reference vertexReference
)
Public Function IsVertexReference (
    vertexReference As Reference
) As Boolean
public:
bool IsVertexReference(
    Reference^ vertexReference
)
member IsVertexReference :
        vertexReference : Reference -> bool

Parameters

vertexReference Reference
Reference to be checked.

Return Value

Boolean
See Also

Reference

Form Class


Form.MoveProfile Method

FormMoveProfile Method

Move a profile of the form, specified by a reference, and an offset vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void MoveProfile(
    int profileIndex,
    XYZ offset
)
Public Sub MoveProfile (
    profileIndex As Integer,
    offset As XYZ
)
public:
void MoveProfile(
    int profileIndex,
    XYZ^ offset
)
member MoveProfile :
        profileIndex : int *
        offset : XYZ -> unit

Parameters

profileIndex Int32
Index to specify the profile.
offset XYZ
The vector by which the element is to be moved.
Example
C#
VB
C++
F#
Copy
public void MoveForm(Form form)
{
    int profileCount = form.ProfileCount;
    if (form.ProfileCount > 0)
    {
        int profileIndex = 0;   // modify the first form only
        if (form.CanManipulateProfile(profileIndex))
        {
            XYZ offset = new XYZ(-25, 0, 0);
            form.MoveProfile(profileIndex, offset);
        }
    }
}
Public Sub MoveForm(form As Form)
    Dim profileCount As Integer = form.ProfileCount
    If form.ProfileCount > 0 Then
        Dim profileIndex As Integer = 0
        ' modify the first form only
        If form.CanManipulateProfile(profileIndex) Then
            Dim offset As New XYZ(-25, 0, 0)
            form.MoveProfile(profileIndex, offset)
        End If
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Form Class


Form.MoveSubElement Method

FormMoveSubElement Method

Move a face/edge/curve/vertex of the form, specified by a reference, and an offset vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void MoveSubElement(
    Reference subElementReference,
    XYZ offset
)
Public Sub MoveSubElement (
    subElementReference As Reference,
    offset As XYZ
)
public:
void MoveSubElement(
    Reference^ subElementReference,
    XYZ^ offset
)
member MoveSubElement :
        subElementReference : Reference *
        offset : XYZ -> unit

Parameters

subElementReference Reference
The geometry reference of face/edge/curve/vertex
offset XYZ
The vector by which the element is to be moved.
Example
C#
VB
C++
F#
Copy
public void MoveSubElement(Form form)
{
    if (form.ProfileCount > 0)
    {
        int profileIndex = 0;   // get first profile
        ReferenceArray ra = form.get_CurveLoopReferencesOnProfile(profileIndex, 0);
        foreach (Reference r in ra)
        {
            ReferenceArray ra2 = form.GetControlPoints(r);
            foreach (Reference r2 in ra2)
            {
                Point vertex = document.GetElement(r2).GetGeometryObjectFromReference(r2) as Point;

                XYZ offset = new XYZ(0, 15, 0);
                form.MoveSubElement(r2, offset);
                break;  // just move the first point
            }
        }
    }
}
Public Sub MoveSubElement(form As Form)
    If form.ProfileCount > 0 Then
        Dim profileIndex As Integer = 0
        ' get first profile
        Dim ra As ReferenceArray = form.CurveLoopReferencesOnProfile(profileIndex, 0)
        For Each r As Reference In ra
            Dim ra2 As ReferenceArray = form.GetControlPoints(r)
            For Each r2 As Reference In ra2
                Dim vertex As Point = TryCast(document.GetElement(r2).GetGeometryObjectFromReference(r2), Point)

                Dim offset As New XYZ(0, 15, 0)
                form.MoveSubElement(r2, offset)
                    ' just move the first point
                Exit For
            Next
        Next
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Form Class


Form.Rehost Method

FormRehost Method

Overload List
 | Name | Description
Public method | Rehost(Reference, XYZ) | Rehost Form to edge, face or curve.
Public method | Rehost(SketchPlane, XYZ) | Rehost Form to sketch plane
Top
See Also

Reference

Form Class


Form.Rehost(Reference, XYZ) Method

FormRehost(Reference, XYZ) Method

Rehost Form to edge, face or curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Rehost(
    Reference hostRef,
    XYZ location
)
Public Sub Rehost (
    hostRef As Reference,
    location As XYZ
)
public:
void Rehost(
    Reference^ hostRef,
    XYZ^ location
)
member Rehost :
        hostRef : Reference *
        location : XYZ -> unit

Parameters

hostRef Reference
The geometry reference on which to rehost the form.
location XYZ
The location to which to Rehost the form.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the hostRef or location is .
InvalidOperationException | Thrown when rehosting Form failed.
See Also

Reference

Form Class
Rehost Overload


Form.Rehost(SketchPlane, XYZ) Method

FormRehost(SketchPlane, XYZ) Method

Rehost Form to sketch plane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Rehost(
    SketchPlane sketchPlane,
    XYZ location
)
Public Sub Rehost (
    sketchPlane As SketchPlane,
    location As XYZ
)
public:
void Rehost(
    SketchPlane^ sketchPlane,
    XYZ^ location
)
member Rehost :
        sketchPlane : SketchPlane *
        location : XYZ -> unit

Parameters

sketchPlane SketchPlane
The sketch plane on which to rehost the form.
location XYZ
The location to which to Rehost the form.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the sketchPlane or location is .
InvalidOperationException | Thrown when rehosting Form failed.
See Also

Reference

Form Class
Rehost Overload


Form.RotateProfile Method

FormRotateProfile Method

Rotate a profile of the form, by a specified angle around a given axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RotateProfile(
    int profileIndex,
    Line axis,
    double angle
)
Public Sub RotateProfile (
    profileIndex As Integer,
    axis As Line,
    angle As Double
)
public:
void RotateProfile(
    int profileIndex,
    Line^ axis,
    double angle
)
member RotateProfile :
        profileIndex : int *
        axis : Line *
        angle : float -> unit

Parameters

profileIndex Int32
Index to specify the profile.
axis Line
An unbounded line that represents the axis of rotation.
angle Double
The angle, in radians, by which the element is to be rotated around the specified axis.
See Also

Reference

Form Class


Form.RotateSubElement Method

FormRotateSubElement Method

Rotate a face/edge/curve/vertex of the form, by a specified angle around a given axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RotateSubElement(
    Reference subElementReference,
    Line axis,
    double angle
)
Public Sub RotateSubElement (
    subElementReference As Reference,
    axis As Line,
    angle As Double
)
public:
void RotateSubElement(
    Reference^ subElementReference,
    Line^ axis,
    double angle
)
member RotateSubElement :
        subElementReference : Reference *
        axis : Line *
        angle : float -> unit

Parameters

subElementReference Reference
The geometry reference of face/edge/curve/vertex
axis Line
An unbounded line that represents the axis of rotation.
angle Double
The angle, in radians, by which the element is to be rotated around the specified axis.
See Also

Reference

Form Class


Form.ScaleProfile Method

FormScaleProfile Method

Scale a profile of the form, by a specified origin and scale factor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ScaleProfile(
    int profileIndex,
    double factor,
    XYZ origin
)
Public Sub ScaleProfile (
    profileIndex As Integer,
    factor As Double,
    origin As XYZ
)
public:
void ScaleProfile(
    int profileIndex,
    double factor,
    XYZ^ origin
)
member ScaleProfile :
        profileIndex : int *
        factor : float *
        origin : XYZ -> unit

Parameters

profileIndex Int32
Index to specify the profile.
factor Double
The scale factor, it should be large than zero.
origin XYZ
The origin where scale happens.
See Also

Reference

Form Class


Form.ScaleSubElement Method

FormScaleSubElement Method

Scale a face/edge/curve/vertex of the form, by a specified origin and scale factor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ScaleSubElement(
    Reference subElementReference,
    double factor,
    XYZ origin
)
Public Sub ScaleSubElement (
    subElementReference As Reference,
    factor As Double,
    origin As XYZ
)
public:
void ScaleSubElement(
    Reference^ subElementReference,
    double factor,
    XYZ^ origin
)
member ScaleSubElement :
        subElementReference : Reference *
        factor : float *
        origin : XYZ -> unit

Parameters

subElementReference Reference
The geometry reference of face/edge/curve/vertex
factor Double
The scale factor, it should be large than zero.
origin XYZ
The origin where scale happens.
See Also

Reference

Form Class


FormArray Class

An array that contains form objects.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBFormArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FormArray : APIObject, IEnumerable
Public Class FormArray
    Inherits APIObject
    Implements IEnumerable
public ref class FormArray : public APIObject,
    IEnumerable
type FormArray =
    class
        inherit APIObject
        interface IEnumerable
    end

The FormArray type exposes the following members.

Constructors
 | Name | Description
Public method | FormArray | Initializes a new instance of the FormArray class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets a form at a specified index within the array.
Public property | Size | Returns the number of forms that are in the array.
Top
Methods
 | Name | Description
Public method | Append |
Public method | Clear | Removes every form from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FormArray Constructor

Initializes a new instance of the FormArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormArray()
Public Sub New
public:
FormArray()
new : unit -> FormArray
See Also

Reference

FormArray Class


FormArray Properties

The FormArray type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets a form at a specified index within the array.
Public property | Size | Returns the number of forms that are in the array.
Top
See Also

Reference

FormArray Class


FormArray.IsEmpty Property

FormArrayIsEmpty Property

Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Boolean
Remarks
If the array is empty then True will be returned, otherwise False.
See Also

Reference

FormArray Class


FormArray.Item Property

FormArrayItem Property

Gets or sets a form at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Form this[
    int index
] { get; set; }
Public Overridable Property Item (
    index As Integer
) As Form
    Get
    Set
public:
virtual property Form^ Item[int index] {
    Form^ get (int index);
    void set (int index, Form^ value);
}
abstract Item : Form with get, set
override Item : Form with get, set

Parameters

index Int32
The index of the form to be set or retrieved.

Return Value

Form
Returns the form at the specified index.
See Also

Reference

FormArray Class


FormArray.Size Property

FormArraySize Property

Returns the number of forms that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
abstract Size : int with get
override Size : int with get

Property Value

Int32
See Also

Reference

FormArray Class


FormArray Methods

The FormArray type exposes the following members.

Methods
 | Name | Description
Public method | Append |
Public method | Clear | Removes every form from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FormArray Class


FormArray.Append Method

FormArrayAppend Method

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Append(
    Form item
)
Public Overridable Sub Append (
    item As Form
)
public:
virtual void Append(
    Form^ item
)
abstract Append :
        item : Form -> unit
override Append :
        item : Form -> unit

Parameters

item Form
See Also

Reference

FormArray Class


FormArray.Clear Method

FormArrayClear Method

Removes every form from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

FormArray Class


FormArray.ForwardIterator Method

FormArrayForwardIterator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual FormArrayIterator ForwardIterator()
Public Overridable Function ForwardIterator As FormArrayIterator
public:
virtual FormArrayIterator^ ForwardIterator()
abstract ForwardIterator : unit -> FormArrayIterator
override ForwardIterator : unit -> FormArrayIterator

Return Value

FormArrayIterator
Returns a forward moving iterator to the array.
See Also

Reference

FormArray Class


FormArray.GetEnumerator Method

FormArrayGetEnumerator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

IEnumerator
Returns a forward moving iterator to the array.

Implements

IEnumerableGetEnumerator
See Also

Reference

FormArray Class


FormArray.Insert Method

FormArrayInsert Method

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Insert(
    Form item,
    int index
)
Public Overridable Sub Insert (
    item As Form,
    index As Integer
)
public:
virtual void Insert(
    Form^ item,
    int index
)
abstract Insert :
        item : Form *
        index : int -> unit
override Insert :
        item : Form *
        index : int -> unit

Parameters

item Form
index Int32
See Also

Reference

FormArray Class


FormArray.ReverseIterator Method

FormArrayReverseIterator Method

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual FormArrayIterator ReverseIterator()
Public Overridable Function ReverseIterator As FormArrayIterator
public:
virtual FormArrayIterator^ ReverseIterator()
abstract ReverseIterator : unit -> FormArrayIterator
override ReverseIterator : unit -> FormArrayIterator

Return Value

FormArrayIterator
Returns a backward moving iterator to the array.
See Also

Reference

FormArray Class


FormArrayIterator Class

An iterator to a form array.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBFormArrayIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class FormArrayIterator : APIObject,
    IEnumerator
Public MustInherit Class FormArrayIterator
    Inherits APIObject
    Implements IEnumerator
public ref class FormArrayIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type FormArrayIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The FormArrayIterator type exposes the following members.

Constructors
 | Name | Description
Public method | FormArrayIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FormArrayIterator Constructor

For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormArrayIterator()
Public Sub New
public:
FormArrayIterator()
new : unit -> FormArrayIterator
Remarks
This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.
See Also

Reference

FormArrayIterator Class


FormArrayIterator Properties

The FormArrayIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

FormArrayIterator Class


FormArrayIterator.Current Property

FormArrayIteratorCurrent Property

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}
abstract Current : Object with get
override Current : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.
See Also

Reference

FormArrayIterator Class


FormArrayIterator Methods

The FormArrayIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FormArrayIterator Class


FormArrayIterator.MoveNext Method

FormArrayIteratorMoveNext Method

Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumeratorMoveNext
Remarks
MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.
See Also

Reference

FormArrayIterator Class


FormArrayIterator.Reset Method

FormArrayIteratorReset Method

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
Remarks
The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.
See Also

Reference

FormArrayIterator Class


FormatOptions Class

Options for formatting numbers with units.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFormatOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FormatOptions : IDisposable
Public Class FormatOptions
    Implements IDisposable
public ref class FormatOptions : IDisposable
type FormatOptions =
    class
        interface IDisposable
    end

The FormatOptions type exposes the following members.

Constructors
 | Name | Description
Public method | FormatOptions | Creates a new FormatOptions object that represents default formatting.
Public method | FormatOptions(ForgeTypeId) | Creates a new FormatOptions object that represents custom formatting.
Public method | FormatOptions(FormatOptions) | Creates a copy of a FormatOptions object.
Public method | FormatOptions(ForgeTypeId, ForgeTypeId) | Creates a new FormatOptions object that represents custom formatting.
Top
Properties
 | Name | Description
Public property | Accuracy | The accuracy to which values will be rounded.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | RoundingMethod | The method used to round values: round to nearest, round up, or round down.
Public property | SuppressLeadingZeros | Indicates if leading zeros should be suppressed in feet and fractional inches.
Public property | SuppressSpaces | Indicates if spaces around the dash should be suppressed in feet and fractional inches.
Public property | SuppressTrailingZeros | Indicates if trailing zeros after the decimal point should be suppressed.
Public property | UseDefault | Indicates whether default or custom formatting should be used.
Public property | UseDigitGrouping | Indicates if digit grouping symbols should be displayed.
Public property | UsePlusPrefix | Indicates if a plus sign prefix should be displayed for positive and zero values.
Top
Methods
 | Name | Description
Public method | CanHaveSymbol | Checks whether a symbol can be specified to display the unit in this FormatOptions.
 | CanHaveSymbol(ForgeTypeId) | Checks whether a symbol can be specified to display a given unit.
Public method | CanSuppressLeadingZeros | Checks whether leading zeros can be suppressed for the display unit in this FormatOptions.
 | CanSuppressLeadingZeros(ForgeTypeId) | Checks whether leading zeros can be suppressed for a given unit.
Public method | CanSuppressSpaces | Checks whether spaces can be suppressed for the display unit in this FormatOptions.
 | CanSuppressSpaces(ForgeTypeId) | Checks whether spaces can be suppressed for a given unit.
Public method | CanSuppressTrailingZeros | Checks whether trailing zeros can be suppressed for the display unit in this FormatOptions.
 | CanSuppressTrailingZeros(ForgeTypeId) | Checks whether trailing zeros can be suppressed for a given unit.
Public method | CanUsePlusPrefix | Checks whether a plus prefix can be displayed for the display unit in this FormatOptions.
 | CanUsePlusPrefix(ForgeTypeId) | Checks whether a plus prefix can be displayed for a given unit.
Public method | Dispose | Releases all resources used by the FormatOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetSymbolTypeId | Gets the identifier of the symbol indicating the unit quantifying the value.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetUnitTypeId | Gets the identifier of the unit used to quantify values.
Public method | GetValidSymbols | Gets the identifiers of all valid symbols for the unit in this FormatOptions.
 | GetValidSymbols(ForgeTypeId) | Gets the identifiers of all valid symbols for a given unit.
Public method | IsValidAccuracy(Double) | Checks whether an accuracy is valid for the display unit in this FormatOptions.
 | IsValidAccuracy(ForgeTypeId, Double) | Checks whether an accuracy is valid for a given unit.
Public method | IsValidForSpec | Checks whether this FormatOptions is valid for a given spec.
Public method | IsValidSymbol(ForgeTypeId) | Checks whether a symbol is valid for the unit in this FormatOptions.
 | IsValidSymbol(ForgeTypeId, ForgeTypeId) | Checks whether a symbol is valid for a given unit.
Public method | SetSymbolTypeId | Sets the symbol that should be displayed to indicate the unit quantifying the value.
Public method | SetUnitTypeId | Sets the unit used to quantify values.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

The FormatOptions class contains settings that control how to format numbers with units as strings. It contains those settings that are typically chosen by an end user in the Format dialog and stored in the document.

The FormatOptions class is used in two different ways. A FormatOptions object in the Units class represents the default settings for the document. A FormatOptions object used elsewhere represents settings that may optionally override the default settings.

The UseDefault property controls whether a FormatOptions object represents default or custom formatting. If UseDefault is true, formatting will be according to the default settings in the Units class, and none of the other settings in the object are meaningful. If UseDefault is false, the object contains custom settings that override the default settings in the Units class. UseDefault is always false for FormatOptions objects in the Units class.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FormatOptions Constructor

Overload List
 | Name | Description
Public method | FormatOptions | Creates a new FormatOptions object that represents default formatting.
Public method | FormatOptions(ForgeTypeId) | Creates a new FormatOptions object that represents custom formatting.
Public method | FormatOptions(FormatOptions) | Creates a copy of a FormatOptions object.
Public method | FormatOptions(ForgeTypeId, ForgeTypeId) | Creates a new FormatOptions object that represents custom formatting.
Top
See Also

Reference

FormatOptions Class


FormatOptions Constructor

Creates a new FormatOptions object that represents default formatting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormatOptions()
Public Sub New
public:
FormatOptions()
new : unit -> FormatOptions
See Also

Reference

FormatOptions Class
FormatOptions Overload


FormatOptions(ForgeTypeId) Constructor

Creates a new FormatOptions object that represents custom formatting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormatOptions(
    ForgeTypeId unitTypeId
)
Public Sub New (
    unitTypeId As ForgeTypeId
)
public:
FormatOptions(
    ForgeTypeId^ unitTypeId
)
new :
        unitTypeId : ForgeTypeId -> FormatOptions

Parameters

unitTypeId ForgeTypeId
Identifier of the unit to display.
Exceptions
Exception | Condition
ArgumentException | unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType).
ArgumentNullException | A non-optional argument was null
See Also

Reference

FormatOptions Class
FormatOptions Overload


FormatOptions(FormatOptions) Constructor

Creates a copy of a FormatOptions object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormatOptions(
    FormatOptions other
)
Public Sub New (
    other As FormatOptions
)
public:
FormatOptions(
    FormatOptions^ other
)
new :
        other : FormatOptions -> FormatOptions

Parameters

other FormatOptions
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FormatOptions Class
FormatOptions Overload


FormatOptions(ForgeTypeId, ForgeTypeId) Constructor

Creates a new FormatOptions object that represents custom formatting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormatOptions(
    ForgeTypeId unitTypeId,
    ForgeTypeId symbolTypeId
)
Public Sub New (
    unitTypeId As ForgeTypeId,
    symbolTypeId As ForgeTypeId
)
public:
FormatOptions(
    ForgeTypeId^ unitTypeId,
    ForgeTypeId^ symbolTypeId
)
new :
        unitTypeId : ForgeTypeId *
        symbolTypeId : ForgeTypeId -> FormatOptions

Parameters

unitTypeId ForgeTypeId
Identifier of the unit to display.
symbolTypeId ForgeTypeId
Identifier of the symbol with which to render the unit.
Exceptions
Exception | Condition
ArgumentException | unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType). -or- symbolTypeId is not a valid symbol for unitTypeId.
ArgumentNullException | A non-optional argument was null
See Also

Reference

FormatOptions Class
FormatOptions Overload


FormatOptions Properties

The FormatOptions type exposes the following members.

Properties
 | Name | Description
Public property | Accuracy | The accuracy to which values will be rounded.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | RoundingMethod | The method used to round values: round to nearest, round up, or round down.
Public property | SuppressLeadingZeros | Indicates if leading zeros should be suppressed in feet and fractional inches.
Public property | SuppressSpaces | Indicates if spaces around the dash should be suppressed in feet and fractional inches.
Public property | SuppressTrailingZeros | Indicates if trailing zeros after the decimal point should be suppressed.
Public property | UseDefault | Indicates whether default or custom formatting should be used.
Public property | UseDigitGrouping | Indicates if digit grouping symbols should be displayed.
Public property | UsePlusPrefix | Indicates if a plus sign prefix should be displayed for positive and zero values.
Top
See Also

Reference

FormatOptions Class


FormatOptions.Accuracy Property

FormatOptionsAccuracy Property

The accuracy to which values will be rounded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Accuracy { get; set; }
Public Property Accuracy As Double
    Get
    Set
public:
property double Accuracy {
    double get ();
    void set (double value);
}
member Accuracy : float with get, set

Property Value

Double
The accuracy. The default depends on the display unit.
Exceptions
Exception | Condition
ArgumentException | When setting this property: accuracy is not a valid accuracy for the display unit in this FormatOptions.
InvalidOperationException | UseDefault is true in this FormatOptions.
Remarks

Formatted values will be rounded to the nearest multiple of the accuracy value.

Accuracy is specified in display units, not in Revit's internal units.

For DUT_GENERAL, the accuracy value is always 0.000001 and cannot be set to another value. DUT_GENERAL is a special display unit that always rounds to six decimal places and suppresses trailing zeros, roughly equivalent to DUT_FIXED with the accuracy set to 0.000001 and SuppressTrailingZeros set to true.

For other display units, a wide range of accuracy values may be specified. All values from 1.0e-12 to 1.0e12 will be accepted, but the specified value will be automatically adjusted to the nearest supported value if necessary. For best results, the accuracy value should be chosen to be compatible with the display unit:

  • For most display units, the value is displayed as a decimal number, and the accuracy should typically be a power of 10, for example 1.0 to round to 0 decimal places or 0.001 to round to 3 decimal places. Other values can be used, for example 0.25 to round to the nearest 0.25 (displayed with 2 decimal places) or 2.0 to round to the nearest even integer (displayed with 0 decimal places). The specified accuracy will automatically be rounded to the nearest positive multiple of 1.0e-12.
  • For DUT_FRACTIONAL_INCHES, DUT_RISE_OVER_INCHES, and DUT_RISE_OVER_120_INCHES, the accuracy should typically be a power of 2, for example 0.25 to round to the nearest 1/4". Other values can be used, for example 6.0 to round to the nearest 6" or 1.5 to round to the nearest 1 1/2". For DUT_FEET_FRACTIONAL_INCHES, DUT_RISE_OVER_FOOT, and DUT_RISE_OVER_10_FEET, similar accuracy values can be used but they must be divided by 12 because the accuracy is specified in feet. The specified accuracy will automatically be rounded to the nearest positive multiple of 1/2^20 inches.
  • For DUT_DEGREES_AND_MINUTES, the accuracy should typically be a power of 10 divided by 3600 to round seconds to a specific number of decimal places, for example 1.0 / 3600.0 to round seconds to 0 decimal places or 0.01 / 3600.0 to round seconds to 2 decimal places. The specified accuracy will automatically be rounded to the nearest positive multiple of 1.0e-8 seconds.
See Also

Reference

FormatOptions Class


FormatOptions.IsValidObject Property

FormatOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

FormatOptions Class


FormatOptions.RoundingMethod Property

FormatOptionsRoundingMethod Property

The method used to round values: round to nearest, round up, or round down.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RoundingMethod RoundingMethod { get; set; }
Public Property RoundingMethod As RoundingMethod
    Get
    Set
public:
property RoundingMethod RoundingMethod {
    RoundingMethod get ();
    void set (RoundingMethod value);
}
member RoundingMethod : RoundingMethod with get, set

Property Value

RoundingMethod
The rounding method. The default is Nearest.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | UseDefault is true in this FormatOptions.
Remarks
The RoundingMethod property is currently only supported for rebar parameters. A FormatOptions object containing any rounding method may be returned by Element.GetParameterFormatOptions() and may be passed to the formatting and parsing utilities in the UnitFormatUtils class. FormatOptions objects used in other contexts must contain the default rounding method (Nearest).
See Also

Reference

FormatOptions Class


FormatOptions.SuppressLeadingZeros Property

FormatOptionsSuppressLeadingZeros Property

Indicates if leading zeros should be suppressed in feet and fractional inches.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SuppressLeadingZeros { get; set; }
Public Property SuppressLeadingZeros As Boolean
    Get
    Set
public:
property bool SuppressLeadingZeros {
    bool get ();
    void set (bool value);
}
member SuppressLeadingZeros : bool with get, set

Property Value

Boolean
True if leading zeros should be suppressed, false otherwise. The default is false.
Exceptions
Exception | Condition
InvalidOperationException | UseDefault is true in this FormatOptions. -or- When setting this property: SuppressLeadingZeros was set to true but leading zeros cannot be suppressed for the display unit in this FormatOptions.
Remarks

This property is applicable to display units related to feet and fractional inches:

  • DUT_FEET_FRACTIONAL_INCHES
  • DUT_RISE_OVER_FOOT
  • DUT_RISE_OVER_10_FEET

When SuppressLeadingZeros is true:

  • If the foot component of the value is zero (the value is less than one foot), it will not be displayed. For example, 0' - 2 3/4" will be displayed as 2 3/4".
  • If both the foot and integer inch components of the value are zero (the value is less than one inch), neither will be displayed. For example, 0' - 0 3/4" will be displayed as 3/4".
  • However, an integer inch component of zero will be displayed if the foot component is non-zero. For example 1' - 0 3/4" will be displayed as 1' - 0 3/4".
See Also

Reference

FormatOptions Class


FormatOptions.SuppressSpaces Property

FormatOptionsSuppressSpaces Property

Indicates if spaces around the dash should be suppressed in feet and fractional inches.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SuppressSpaces { get; set; }
Public Property SuppressSpaces As Boolean
    Get
    Set
public:
property bool SuppressSpaces {
    bool get ();
    void set (bool value);
}
member SuppressSpaces : bool with get, set

Property Value

Boolean
True if spaces should be suppressed, false otherwise. The default is false.
Exceptions
Exception | Condition
InvalidOperationException | UseDefault is true in this FormatOptions. -or- When setting this property: SuppressSpaces was set to true but spaces cannot be suppressed for the display unit in this FormatOptions.
Remarks

This property is applicable to display units related to feet and fractional inches:

  • DUT_FEET_FRACTIONAL_INCHES
  • DUT_RISE_OVER_FOOT
  • DUT_RISE_OVER_10_FEET

When SuppressLeadingZeros is true, spaces will not be inserted before and after the dash separating feet from inches. For example, 1' - 2 3/4" will be displayed as 1'-2 3/4".

See Also

Reference

FormatOptions Class


FormatOptions.SuppressTrailingZeros Property

FormatOptionsSuppressTrailingZeros Property

Indicates if trailing zeros after the decimal point should be suppressed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SuppressTrailingZeros { get; set; }
Public Property SuppressTrailingZeros As Boolean
    Get
    Set
public:
property bool SuppressTrailingZeros {
    bool get ();
    void set (bool value);
}
member SuppressTrailingZeros : bool with get, set

Property Value

Boolean
True if trailing zeros should be suppressed, false otherwise. The default is false.
Exceptions
Exception | Condition
InvalidOperationException | UseDefault is true in this FormatOptions. -or- When setting this property: SuppressTrailingZeros was set to true but trailing zeros cannot be suppressed for the display unit in this FormatOptions.
Remarks

This property is applicable to display units which are formatted as a decimal number. It is not applicable to the following display units which have specialized formatting:

  • DUT_GENERAL
  • DUT_FEET_FRACTIONAL_INCHES
  • DUT_FRACTIONAL_INCHES
  • DUT_METERS_CENTIMETERS
  • DUT_DEGREES_AND_MINUTES
  • DUT_RISE_OVER_INCHES
  • DUT_RISE_OVER_120_INCHES
  • DUT_RISE_OVER_FOOT
  • DUT_RISE_OVER_10_FEET

When SuppressTrailingZeros is true, trailing zeros to the right of the decimal point will not be displayed. For example, 1.200 will be displayed as 1.2.

Trailing zeros are always suppressed for DUT_GENERAL, and the SuppressTrailingZeros property is not used.

See Also

Reference

FormatOptions Class


FormatOptions.UseDefault Property

FormatOptionsUseDefault Property

Indicates whether default or custom formatting should be used.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UseDefault { get; set; }
Public Property UseDefault As Boolean
    Get
    Set
public:
property bool UseDefault {
    bool get ();
    void set (bool value);
}
member UseDefault : bool with get, set

Property Value

Boolean
True if default formatting should be used; false if custom formatting should be used.
Remarks
If UseDefault is true, formatting will be according to the default settings in the Units class, and none of the other settings in the object are meaningful. If UseDefault is false, the object contains custom settings that override the default settings in the Units class. UseDefault is always false for FormatOptions objects in the Units class.
See Also

Reference

FormatOptions Class


FormatOptions.UseDigitGrouping Property

FormatOptionsUseDigitGrouping Property

Indicates if digit grouping symbols should be displayed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UseDigitGrouping { get; set; }
Public Property UseDigitGrouping As Boolean
    Get
    Set
public:
property bool UseDigitGrouping {
    bool get ();
    void set (bool value);
}
member UseDigitGrouping : bool with get, set

Property Value

Boolean
True if digit grouping symbols should be displayed, false otherwise. The default is false.
Exceptions
Exception | Condition
InvalidOperationException | UseDefault is true in this FormatOptions.
Remarks
When UseDigitGrouping is true, digit grouping symbols (i.e. thousands separators) will be displayed when needed. For example, 123456789.00 may be displayed as 123,456,789.00. The precise display is determined by the DigitGroupingSymbol and DigitGroupingAmount properties of the Units class.
See Also

Reference

FormatOptions Class


FormatOptions.UsePlusPrefix Property

FormatOptionsUsePlusPrefix Property

Indicates if a plus sign prefix should be displayed for positive and zero values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UsePlusPrefix { get; set; }
Public Property UsePlusPrefix As Boolean
    Get
    Set
public:
property bool UsePlusPrefix {
    bool get ();
    void set (bool value);
}
member UsePlusPrefix : bool with get, set

Property Value

Boolean
True if a plus prefix should be displayed, false otherwise. The default is false.
Exceptions
Exception | Condition
InvalidOperationException | UseDefault is true in this FormatOptions. -or- When setting this property: UsePlusPrefix was set to true but a plus prefix cannot be displayed for the display unit in this FormatOptions.
Remarks

This property is applicable to length display units (e.g. meters or feet). It is not currently supported for other unit types like area or force. The UI also does not permit it to be enabled in the Units class that represents the document's default settings, but that restriction is not enforced in the API.

When UsePlusPrefix is true, a plus sign ("+") will be displayed before positive and zero values, just as a minus sign ("-") is displayed before negative values. For example, 1.234 will be displayed as +1.234 and 0.0 will be displayed as +0.0.

See Also

Reference

FormatOptions Class


FormatOptions Methods

The FormatOptions type exposes the following members.

Methods
 | Name | Description
Public method | CanHaveSymbol | Checks whether a symbol can be specified to display the unit in this FormatOptions.
 | CanHaveSymbol(ForgeTypeId) | Checks whether a symbol can be specified to display a given unit.
Public method | CanSuppressLeadingZeros | Checks whether leading zeros can be suppressed for the display unit in this FormatOptions.
 | CanSuppressLeadingZeros(ForgeTypeId) | Checks whether leading zeros can be suppressed for a given unit.
Public method | CanSuppressSpaces | Checks whether spaces can be suppressed for the display unit in this FormatOptions.
 | CanSuppressSpaces(ForgeTypeId) | Checks whether spaces can be suppressed for a given unit.
Public method | CanSuppressTrailingZeros | Checks whether trailing zeros can be suppressed for the display unit in this FormatOptions.
 | CanSuppressTrailingZeros(ForgeTypeId) | Checks whether trailing zeros can be suppressed for a given unit.
Public method | CanUsePlusPrefix | Checks whether a plus prefix can be displayed for the display unit in this FormatOptions.
 | CanUsePlusPrefix(ForgeTypeId) | Checks whether a plus prefix can be displayed for a given unit.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetSymbolTypeId | Gets the identifier of the symbol indicating the unit quantifying the value.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetUnitTypeId | Gets the identifier of the unit used to quantify values.
Public method | GetValidSymbols | Gets the identifiers of all valid symbols for the unit in this FormatOptions.
 | GetValidSymbols(ForgeTypeId) | Gets the identifiers of all valid symbols for a given unit.
Public method | IsValidAccuracy(Double) | Checks whether an accuracy is valid for the display unit in this FormatOptions.
 | IsValidAccuracy(ForgeTypeId, Double) | Checks whether an accuracy is valid for a given unit.
Public method | IsValidForSpec | Checks whether this FormatOptions is valid for a given spec.
Public method | IsValidSymbol(ForgeTypeId) | Checks whether a symbol is valid for the unit in this FormatOptions.
 | IsValidSymbol(ForgeTypeId, ForgeTypeId) | Checks whether a symbol is valid for a given unit.
Public method | SetSymbolTypeId | Sets the symbol that should be displayed to indicate the unit quantifying the value.
Public method | SetUnitTypeId | Sets the unit used to quantify values.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FormatOptions Class


FormatOptions.CanHaveSymbol Method

FormatOptionsCanHaveSymbol Method

Overload List
 | Name | Description
Public method | CanHaveSymbol | Checks whether a symbol can be specified to display the unit in this FormatOptions.
 | CanHaveSymbol(ForgeTypeId) | Checks whether a symbol can be specified to display a given unit.
Top
See Also

Reference

FormatOptions Class


FormatOptions.CanHaveSymbol Method

FormatOptionsCanHaveSymbol Method

Checks whether a symbol can be specified to display the unit in this FormatOptions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanHaveSymbol()
Public Function CanHaveSymbol As Boolean
public:
bool CanHaveSymbol()
member CanHaveSymbol : unit -> bool

Return Value

Boolean
True if a symbol can be specified, false otherwise.
Exceptions
Exception | Condition
InvalidOperationException | UseDefault is true in this FormatOptions.
See Also

Reference

FormatOptions Class
CanHaveSymbol Overload


FormatOptions.CanHaveSymbol(ForgeTypeId) Method

FormatOptionsCanHaveSymbol(ForgeTypeId) Method

Checks whether a symbol can be specified to display a given unit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CanHaveSymbol(
    ForgeTypeId unitTypeId
)
Public Shared Function CanHaveSymbol (
    unitTypeId As ForgeTypeId
) As Boolean
public:
static bool CanHaveSymbol(
    ForgeTypeId^ unitTypeId
)
static member CanHaveSymbol :
        unitTypeId : ForgeTypeId -> bool

Parameters

unitTypeId ForgeTypeId
Identifier of the unit.

Return Value

Boolean
True if a symbol can be specified, false otherwise.
Exceptions
Exception | Condition
ArgumentException | unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType).
ArgumentNullException | A non-optional argument was null
See Also

Reference

FormatOptions Class
CanHaveSymbol Overload


FormatOptions.CanSuppressLeadingZeros Method

FormatOptionsCanSuppressLeadingZeros Method

Overload List
 | Name | Description
Public method | CanSuppressLeadingZeros | Checks whether leading zeros can be suppressed for the display unit in this FormatOptions.
 | CanSuppressLeadingZeros(ForgeTypeId) | Checks whether leading zeros can be suppressed for a given unit.
Top
See Also

Reference

FormatOptions Class


FormatOptions.CanSuppressLeadingZeros Method

FormatOptionsCanSuppressLeadingZeros Method

Checks whether leading zeros can be suppressed for the display unit in this FormatOptions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanSuppressLeadingZeros()
Public Function CanSuppressLeadingZeros As Boolean
public:
bool CanSuppressLeadingZeros()
member CanSuppressLeadingZeros : unit -> bool

Return Value

Boolean
True if leading zeros can be suppressed, false otherwise.
Exceptions
Exception | Condition
InvalidOperationException | UseDefault is true in this FormatOptions.
See Also

Reference

FormatOptions Class
CanSuppressLeadingZeros Overload


FormatOptions.CanSuppressLeadingZeros(ForgeTypeId) Method

FormatOptionsCanSuppressLeadingZeros(ForgeTypeId) Method

Checks whether leading zeros can be suppressed for a given unit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CanSuppressLeadingZeros(
    ForgeTypeId unitTypeId
)
Public Shared Function CanSuppressLeadingZeros (
    unitTypeId As ForgeTypeId
) As Boolean
public:
static bool CanSuppressLeadingZeros(
    ForgeTypeId^ unitTypeId
)
static member CanSuppressLeadingZeros :
        unitTypeId : ForgeTypeId -> bool

Parameters

unitTypeId ForgeTypeId
Identifier of the unit.

Return Value

Boolean
True if leading zeros can be suppressed, false otherwise.
Exceptions
Exception | Condition
ArgumentException | unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType).
ArgumentNullException | A non-optional argument was null
See Also

Reference

FormatOptions Class
CanSuppressLeadingZeros Overload


FormatOptions.CanSuppressSpaces Method

FormatOptionsCanSuppressSpaces Method

Overload List
 | Name | Description
Public method | CanSuppressSpaces | Checks whether spaces can be suppressed for the display unit in this FormatOptions.
 | CanSuppressSpaces(ForgeTypeId) | Checks whether spaces can be suppressed for a given unit.
Top
See Also

Reference

FormatOptions Class


FormatOptions.CanSuppressSpaces Method

FormatOptionsCanSuppressSpaces Method

Checks whether spaces can be suppressed for the display unit in this FormatOptions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanSuppressSpaces()
Public Function CanSuppressSpaces As Boolean
public:
bool CanSuppressSpaces()
member CanSuppressSpaces : unit -> bool

Return Value

Boolean
True if spaces can be suppressed, false otherwise.
Exceptions
Exception | Condition
InvalidOperationException | UseDefault is true in this FormatOptions.
See Also

Reference

FormatOptions Class
CanSuppressSpaces Overload


FormatOptions.CanSuppressSpaces(ForgeTypeId) Method

FormatOptionsCanSuppressSpaces(ForgeTypeId) Method

Checks whether spaces can be suppressed for a given unit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CanSuppressSpaces(
    ForgeTypeId unitTypeId
)
Public Shared Function CanSuppressSpaces (
    unitTypeId As ForgeTypeId
) As Boolean
public:
static bool CanSuppressSpaces(
    ForgeTypeId^ unitTypeId
)
static member CanSuppressSpaces :
        unitTypeId : ForgeTypeId -> bool

Parameters

unitTypeId ForgeTypeId
Identifier of the unit.

Return Value

Boolean
True if spaces can be suppressed, false otherwise.
Exceptions
Exception | Condition
ArgumentException | unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType).
ArgumentNullException | A non-optional argument was null
See Also

Reference

FormatOptions Class
CanSuppressSpaces Overload


FormatOptions.CanSuppressTrailingZeros Method

FormatOptionsCanSuppressTrailingZeros Method

Overload List
 | Name | Description
Public method | CanSuppressTrailingZeros | Checks whether trailing zeros can be suppressed for the display unit in this FormatOptions.
 | CanSuppressTrailingZeros(ForgeTypeId) | Checks whether trailing zeros can be suppressed for a given unit.
Top
See Also

Reference

FormatOptions Class


FormatOptions.CanSuppressTrailingZeros Method

FormatOptionsCanSuppressTrailingZeros Method

Checks whether trailing zeros can be suppressed for the display unit in this FormatOptions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanSuppressTrailingZeros()
Public Function CanSuppressTrailingZeros As Boolean
public:
bool CanSuppressTrailingZeros()
member CanSuppressTrailingZeros : unit -> bool

Return Value

Boolean
True if trailing zeros can be suppressed, false otherwise.
Exceptions
Exception | Condition
InvalidOperationException | UseDefault is true in this FormatOptions.
See Also

Reference

FormatOptions Class
CanSuppressTrailingZeros Overload


FormatOptions.CanSuppressTrailingZeros(ForgeTypeId) Method

FormatOptionsCanSuppressTrailingZeros(ForgeTypeId) Method

Checks whether trailing zeros can be suppressed for a given unit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CanSuppressTrailingZeros(
    ForgeTypeId unitTypeId
)
Public Shared Function CanSuppressTrailingZeros (
    unitTypeId As ForgeTypeId
) As Boolean
public:
static bool CanSuppressTrailingZeros(
    ForgeTypeId^ unitTypeId
)
static member CanSuppressTrailingZeros :
        unitTypeId : ForgeTypeId -> bool

Parameters

unitTypeId ForgeTypeId
Identifier of the unit.

Return Value

Boolean
True if trailing zeros can be suppressed, false otherwise.
Exceptions
Exception | Condition
ArgumentException | unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType).
ArgumentNullException | A non-optional argument was null
See Also

Reference

FormatOptions Class
CanSuppressTrailingZeros Overload


FormatOptions.CanUsePlusPrefix Method

FormatOptionsCanUsePlusPrefix Method

Overload List
 | Name | Description
Public method | CanUsePlusPrefix | Checks whether a plus prefix can be displayed for the display unit in this FormatOptions.
 | CanUsePlusPrefix(ForgeTypeId) | Checks whether a plus prefix can be displayed for a given unit.
Top
See Also

Reference

FormatOptions Class


FormatOptions.CanUsePlusPrefix Method

FormatOptionsCanUsePlusPrefix Method

Checks whether a plus prefix can be displayed for the display unit in this FormatOptions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanUsePlusPrefix()
Public Function CanUsePlusPrefix As Boolean
public:
bool CanUsePlusPrefix()
member CanUsePlusPrefix : unit -> bool

Return Value

Boolean
True if a plus prefix can be displayed, false otherwise.
Exceptions
Exception | Condition
InvalidOperationException | UseDefault is true in this FormatOptions.
See Also

Reference

FormatOptions Class
CanUsePlusPrefix Overload


FormatOptions.CanUsePlusPrefix(ForgeTypeId) Method

FormatOptionsCanUsePlusPrefix(ForgeTypeId) Method

Checks whether a plus prefix can be displayed for a given unit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CanUsePlusPrefix(
    ForgeTypeId unitTypeId
)
Public Shared Function CanUsePlusPrefix (
    unitTypeId As ForgeTypeId
) As Boolean
public:
static bool CanUsePlusPrefix(
    ForgeTypeId^ unitTypeId
)
static member CanUsePlusPrefix :
        unitTypeId : ForgeTypeId -> bool

Parameters

unitTypeId ForgeTypeId
Identifier of the unit.

Return Value

Boolean
True if a plus prefix can be displayed, false otherwise.
Exceptions
Exception | Condition
ArgumentException | unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType).
ArgumentNullException | A non-optional argument was null
See Also

Reference

FormatOptions Class
CanUsePlusPrefix Overload


FormatOptions.Dispose Method

FormatOptionsDispose Method

Releases all resources used by the FormatOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FormatOptions Class


FormatOptions.GetSymbolTypeId Method

FormatOptionsGetSymbolTypeId Method

Gets the identifier of the symbol indicating the unit quantifying the value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ForgeTypeId GetSymbolTypeId()
Public Function GetSymbolTypeId As ForgeTypeId
public:
ForgeTypeId^ GetSymbolTypeId()
member GetSymbolTypeId : unit -> ForgeTypeId

Return Value

ForgeTypeId
The symbol identifier. An empty identifier string indicates no symbol.
Exceptions
Exception | Condition
InvalidOperationException | UseDefault is true in this FormatOptions.
See Also

Reference

FormatOptions Class


FormatOptions.GetUnitTypeId Method

FormatOptionsGetUnitTypeId Method

Gets the identifier of the unit used to quantify values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ForgeTypeId GetUnitTypeId()
Public Function GetUnitTypeId As ForgeTypeId
public:
ForgeTypeId^ GetUnitTypeId()
member GetUnitTypeId : unit -> ForgeTypeId

Return Value

ForgeTypeId
Exceptions
Exception | Condition
InvalidOperationException | UseDefault is true in this FormatOptions.
Remarks
Most units, such as square feet or degrees, are formatted as decimal decimal numbers. Other units may be displayed with specialized formatting methods like "feet and fractional inches" or "degrees, minutes and seconds".
See Also

Reference

FormatOptions Class


FormatOptions.GetValidSymbols Method

FormatOptionsGetValidSymbols Method

Overload List
 | Name | Description
Public method | GetValidSymbols | Gets the identifiers of all valid symbols for the unit in this FormatOptions.
 | GetValidSymbols(ForgeTypeId) | Gets the identifiers of all valid symbols for a given unit.
Top
See Also

Reference

FormatOptions Class


FormatOptions.GetValidSymbols Method

FormatOptionsGetValidSymbols Method

Gets the identifiers of all valid symbols for the unit in this FormatOptions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ForgeTypeId> GetValidSymbols()
Public Function GetValidSymbols As IList(Of ForgeTypeId)
public:
IList<ForgeTypeId^>^ GetValidSymbols()
member GetValidSymbols : unit -> IList<ForgeTypeId>

Return Value

IList ForgeTypeId
Identifiers of the valid symbols.
Exceptions
Exception | Condition
InvalidOperationException | UseDefault is true in this FormatOptions.
See Also

Reference

FormatOptions Class
GetValidSymbols Overload


FormatOptions.GetValidSymbols(ForgeTypeId) Method

FormatOptionsGetValidSymbols(ForgeTypeId) Method

Gets the identifiers of all valid symbols for a given unit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<ForgeTypeId> GetValidSymbols(
    ForgeTypeId unitTypeId
)
Public Shared Function GetValidSymbols (
    unitTypeId As ForgeTypeId
) As IList(Of ForgeTypeId)
public:
static IList<ForgeTypeId^>^ GetValidSymbols(
    ForgeTypeId^ unitTypeId
)
static member GetValidSymbols :
        unitTypeId : ForgeTypeId -> IList<ForgeTypeId>

Parameters

unitTypeId ForgeTypeId
Identifier of the unit.

Return Value

IList ForgeTypeId
Identifiers of the valid symbols.
Exceptions
Exception | Condition
ArgumentException | unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType).
ArgumentNullException | A non-optional argument was null
See Also

Reference

FormatOptions Class
GetValidSymbols Overload


FormatOptions.IsValidAccuracy Method

FormatOptionsIsValidAccuracy Method

Overload List
 | Name | Description
Public method | IsValidAccuracy(Double) | Checks whether an accuracy is valid for the display unit in this FormatOptions.
 | IsValidAccuracy(ForgeTypeId, Double) | Checks whether an accuracy is valid for a given unit.
Top
See Also

Reference

FormatOptions Class


FormatOptions.IsValidAccuracy(Double) Method

FormatOptionsIsValidAccuracy(Double) Method

Checks whether an accuracy is valid for the display unit in this FormatOptions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidAccuracy(
    double accuracy
)
Public Function IsValidAccuracy (
    accuracy As Double
) As Boolean
public:
bool IsValidAccuracy(
    double accuracy
)
member IsValidAccuracy :
        accuracy : float -> bool

Parameters

accuracy Double
The accuracy to check.

Return Value

Boolean
True if the accuracy is valid, false otherwise.
Exceptions
Exception | Condition
InvalidOperationException | UseDefault is true in this FormatOptions.
Remarks
See the Accuracy property for details on valid accuracy values.
See Also

Reference

FormatOptions Class
IsValidAccuracy Overload


FormatOptions.IsValidAccuracy(ForgeTypeId, Double) Method

FormatOptionsIsValidAccuracy(ForgeTypeId, Double) Method

Checks whether an accuracy is valid for a given unit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidAccuracy(
    ForgeTypeId unitTypeId,
    double accuracy
)
Public Shared Function IsValidAccuracy (
    unitTypeId As ForgeTypeId,
    accuracy As Double
) As Boolean
public:
static bool IsValidAccuracy(
    ForgeTypeId^ unitTypeId,
    double accuracy
)
static member IsValidAccuracy :
        unitTypeId : ForgeTypeId *
        accuracy : float -> bool

Parameters

unitTypeId ForgeTypeId
Identifier of the unit.
accuracy Double
The accuracy to check.

Return Value

Boolean
True if the accuracy is valid, false otherwise.
Exceptions
Exception | Condition
ArgumentException | unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType).
ArgumentNullException | A non-optional argument was null
Remarks
See the Accuracy property for details on valid accuracy values.
See Also

Reference

FormatOptions Class
IsValidAccuracy Overload


FormatOptions.IsValidForSpec Method

FormatOptionsIsValidForSpec Method

Checks whether this FormatOptions is valid for a given spec.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidForSpec(
    ForgeTypeId specTypeId
)
Public Function IsValidForSpec (
    specTypeId As ForgeTypeId
) As Boolean
public:
bool IsValidForSpec(
    ForgeTypeId^ specTypeId
)
member IsValidForSpec :
        specTypeId : ForgeTypeId -> bool

Parameters

specTypeId ForgeTypeId
Identifier of the spec.

Return Value

Boolean
True if the FormatOptions is valid, false otherwise.
Exceptions
Exception | Condition
ArgumentException | specTypeId is not a measurable spec identifier. See UnitUtils.IsMeasurableSpec(ForgeTypeId).
ArgumentNullException | A non-optional argument was null
Remarks
The FormatOptions is valid if UseDefault is true or if the unit in the FormatOptions is valid for the spec. See UnitUtils.IsValidUnit(ForgeTypeId, ForgeTypeId) and UnitUtils.GetValidUnits(ForgeTypeId).
See Also

Reference

FormatOptions Class


FormatOptions.IsValidSymbol Method

FormatOptionsIsValidSymbol Method

Overload List
 | Name | Description
Public method | IsValidSymbol(ForgeTypeId) | Checks whether a symbol is valid for the unit in this FormatOptions.
 | IsValidSymbol(ForgeTypeId, ForgeTypeId) | Checks whether a symbol is valid for a given unit.
Top
See Also

Reference

FormatOptions Class


FormatOptions.IsValidSymbol(ForgeTypeId) Method

FormatOptionsIsValidSymbol(ForgeTypeId) Method

Checks whether a symbol is valid for the unit in this FormatOptions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidSymbol(
    ForgeTypeId symbolTypeId
)
Public Function IsValidSymbol (
    symbolTypeId As ForgeTypeId
) As Boolean
public:
bool IsValidSymbol(
    ForgeTypeId^ symbolTypeId
)
member IsValidSymbol :
        symbolTypeId : ForgeTypeId -> bool

Parameters

symbolTypeId ForgeTypeId
Identifier of the symbol to check.

Return Value

Boolean
True if the symbol is valid, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | UseDefault is true in this FormatOptions.
See Also

Reference

FormatOptions Class
IsValidSymbol Overload


FormatOptions.IsValidSymbol(ForgeTypeId, ForgeTypeId) Method

FormatOptionsIsValidSymbol(ForgeTypeId, ForgeTypeId) Method

Checks whether a symbol is valid for a given unit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidSymbol(
    ForgeTypeId unitTypeId,
    ForgeTypeId symbolTypeId
)
Public Shared Function IsValidSymbol (
    unitTypeId As ForgeTypeId,
    symbolTypeId As ForgeTypeId
) As Boolean
public:
static bool IsValidSymbol(
    ForgeTypeId^ unitTypeId,
    ForgeTypeId^ symbolTypeId
)
static member IsValidSymbol :
        unitTypeId : ForgeTypeId *
        symbolTypeId : ForgeTypeId -> bool

Parameters

unitTypeId ForgeTypeId
Identifier of the unit.
symbolTypeId ForgeTypeId
Identifier of the symbol to check.

Return Value

Boolean
True if the symbol is valid, false otherwise.
Exceptions
Exception | Condition
ArgumentException | unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType).
ArgumentNullException | A non-optional argument was null
See Also

Reference

FormatOptions Class
IsValidSymbol Overload


FormatOptions.SetSymbolTypeId Method

FormatOptionsSetSymbolTypeId Method

Sets the symbol that should be displayed to indicate the unit quantifying the value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetSymbolTypeId(
    ForgeTypeId symbolTypeId
)
Public Sub SetSymbolTypeId (
    symbolTypeId As ForgeTypeId
)
public:
void SetSymbolTypeId(
    ForgeTypeId^ symbolTypeId
)
member SetSymbolTypeId :
        symbolTypeId : ForgeTypeId -> unit

Parameters

symbolTypeId ForgeTypeId
The symbol identifier. An empty identifier string indicates no symbol.
Exceptions
Exception | Condition
ArgumentException | symbolTypeId is not a valid symbol for the unit in this FormatOptions.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | UseDefault is true in this FormatOptions.
See Also

Reference

FormatOptions Class


FormatOptions.SetUnitTypeId Method

FormatOptionsSetUnitTypeId Method

Sets the unit used to quantify values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormatOptions SetUnitTypeId(
    ForgeTypeId unitTypeId
)
Public Function SetUnitTypeId (
    unitTypeId As ForgeTypeId
) As FormatOptions
public:
FormatOptions^ SetUnitTypeId(
    ForgeTypeId^ unitTypeId
)
member SetUnitTypeId :
        unitTypeId : ForgeTypeId -> FormatOptions

Parameters

unitTypeId ForgeTypeId
The unit identifier.

Return Value

FormatOptions
Exceptions
Exception | Condition
ArgumentException | unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType).
ArgumentNullException | A non-optional argument was null
InvalidOperationException | UseDefault is true in this FormatOptions.
See Also

Reference

FormatOptions Class


FormatStatus Enumeration

An enumerated type indicating the formatting status of a range of characters in FormattedText

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum FormatStatus
Public Enumeration FormatStatus
public enum class FormatStatus
type FormatStatus
Members
Member name | Value | Description
None | 0 | None of the characters in the range has the specified format.
All | 1 | All of the characters in the range have the specified format.
Mixed | 2 | The characters in the format have mixed formatting.
Remarks
The character formatting includes
  • Bold
  • Italic
  • Underline
  • SuperScript
  • Subscript
  • All Caps
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FormattedText Class

FormattedText is used to create, edit and format text in a TextNote or to query the text and format properties of a TextNode
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFormattedText

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FormattedText : IDisposable
Public Class FormattedText
    Implements IDisposable
public ref class FormattedText : IDisposable
type FormattedText =
    class
        interface IDisposable
    end

The FormattedText type exposes the following members.

Constructors
 | Name | Description
Public method | FormattedText | Creates a new default FormattedText object, which contains only a carriage return character and has no formatting.
 | FormattedText(String) | Creates a new FormattedText object with unformatted text.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
 | AsTextRange | Returns a TextRange object that represents the entire text.
Public method | Dispose | Releases all resources used by the FormattedText
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | Find | Returns a text range identifying the first occurrence of the given string within the text, starting from a given index.
Public method | GetAllCapsStatus | Returns whether All, None or a Mixed of characters in the entire text are in all caps.
Public method | GetAllCapsStatus(TextRange) | Returns whether All, None or a Mixed set of characters in a given text range are in all caps.
Public method | GetBoldStatus | Returns whether All, None or a Mixed of characters in the entire text are bold.
Public method | GetBoldStatus(TextRange) | Returns whether All, None or a Mixed set of characters in a given text range are bold.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIndentLevel | Returns the indent level of the paragraphs in the text range.
Public method | GetItalicStatus | Returns whether All, None or a Mixed of characters in the entire text are italic.
Public method | GetItalicStatus(TextRange) | Returns whether All, None or a Mixed set of characters in a given text range are italic.
Public method | GetListStartNumber | Returns the list start number of the paragraphs in a given text range.
Public method | GetListType | Returns the ListType of a paragraph.
Public method | GetMaximumIndentLevel | Returns the maximum allowed indent level
Public method | GetMaximumListStartNumber | Returns the maximum allowed list start number.
Public method | GetMinimumListStartNumber | Returns the minumum allowed list start number.
Public method | GetPlainText | Returns the entire text in a plain text form.
Public method | GetPlainText(TextRange) | Returns a substring of the text in a plain text form. The start and end of the substring is identified by a given TextRange.
Public method | GetSubscriptStatus | Returns whether All, None or a Mixed of characters in the entire text are subscripted.
Public method | GetSubscriptStatus(TextRange) | Returns whether All, None or a Mixed set of characters in a given text range are subscripted.
Public method | GetSuperscriptStatus | Returns whether All, None or a Mixed of characters in the entire text are superscripted.
Public method | GetSuperscriptStatus(TextRange) | Returns whether All, None or a Mixed set of characters in a given text range are superscripted.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetUnderlineStatus | Returns whether All, None or a Mixed of characters in the entire text are underlined.
Public method | GetUnderlineStatus(TextRange) | Returns whether All, None or a Mixed set of characters in a given text range are underlined.
Public method | SetAllCapsStatus(Boolean) | Sets the characters in the entire text to be in all caps or not.
Public method | SetAllCapsStatus(TextRange, Boolean) | Sets the characters in a given text range to be in all caps or not.
Public method | SetBoldStatus(Boolean) | Sets the characters in the entire text to be bold or not bold.
Public method | SetBoldStatus(TextRange, Boolean) | Sets the characters in a given text range to be bold or not bold.
Public method | SetIndentLevel | Sets the number of tab stops that the paragraph should be indented.
Public method | SetItalicStatus(Boolean) | Sets the characters in the entire text to be italic or not italic.
Public method | SetItalicStatus(TextRange, Boolean) | Sets the characters in a given text range to be italic or not italic.
Public method | SetListStartNumber | Sets the list start number on the paragraphs in a given text range.
 | SetListType | Sets the ListType of a paragraph.
Public method | SetPlainText(String) | Sets the entire text with the given text in a plain text form.
Public method | SetPlainText(TextRange, String) | Sets the text with the given text in a plain text form in a range.
Public method | SetSubscriptStatus(Boolean) | Sets the characters in the entire text to be subscript or not subscript.
Public method | SetSubscriptStatus(TextRange, Boolean) | Sets the characters in a given text range to be subscript or not subscript.
Public method | SetSuperscriptStatus(Boolean) | Sets the characters in the entire text to be superscript or not superscript.
Public method | SetSuperscriptStatus(TextRange, Boolean) | Sets the characters in a given text range to be superscript or not superscript.
Public method | SetUnderlineStatus(Boolean) | Sets the characters in the entire text to be underlined or not underlined.
Public method | SetUnderlineStatus(TextRange, Boolean) | Sets the characters in a given text range to be underlined or not underlined.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

An instance of FormattedText can be obtained from a TextNote (See TextNote.GetFormattedText()) or from a TextNode (See TextNode.GetFormattedText())

It is also possible to create a new instance of FormattedText and assign it to a TextNote (See TextNote.SetFormattedText()) This will result in a TextNote with text with the specified formatting applied

Formatted text can be used to:

  • Create formatted text for a new TextNote
  • Edit, Find and Replace text in an existing TextNote
  • Modify formatting of text in an existing TextNote
  • Or query the text and formatting a TextNote or a TextNode

Formatted text can be populated with plain text by using its constructor FormattedText(String) that takes a string, or by using the SetPlainText(String) method.

In addition, selected ranges of text can be added, removed, or replaced with the SetPlainText(TextRange, String) method by specifying a TextRange.

Use the Find(String, Int32, Boolean, Boolean) method to find the location of existing text.

Formatted text can have up to 30,000 characters. All characters, except the linefeed character ('\n'), are allowed. This means that you should not use the 'Environment.NewLine' property, since that includes a linefeed character. Use the carriage return character ('\r') to terminate a paragraph. And use a vertical tab character ('\v') to create a new line without terminating the paragraph.

Formatted text allows for individual characters to be formatted. The following formatting can be applied.

  • Bold
  • Italic
  • Underline
  • Superscript/Subscript
  • All Caps
Use SetBoldStatus(TextRange, Boolean)) , SetItalicStatus(TextRange, Boolean)) , SetUnderlineStatus(TextRange, Boolean)) , SetSuperscriptStatus(TextRange, Boolean)) , SetSubscriptStatus(TextRange, Boolean)) , or SetAllCapsStatus(TextRange, Boolean)) to set the character formatting on a range of text.

Use GetBoldStatus(TextRange)) , GetItalicStatus(TextRange)) , GetUnderlineStatus(TextRange)) , GetSuperscriptStatus(TextRange)) , GetSubscriptStatus(TextRange)) , or GetAllCapsStatus(TextRange)) to get the character formatting of a range of text.

Text can be broken up in paragraphs. Paragraphs are terminated by a carriage return character ('\r').

Each paragraph can be indented several levels deep. For each additional level the indentation increments by one tab size. The total indentation is the product of a tab size and the indent level. Use SetIndentLevel(TextRange, Int32) to set the level of indenting up to a maximum indent level that can be obtained from GetMaximumIndentLevel Use GetIndentLevel(TextRange) to find the indent level of a given range of text.

Note that the tab size is determined by the object that will contain the FormattedText.

In the case of a TextNote the tab size is a property of the TextNoteType returned from TextNote.TextNoteType. The tab size can be found by calling the ParameterGuid with TEXT_TAB_SIZE on the TextNoteType obtained from the TextNote

In the case of a TextNode the tab size can be obtained from its TabSize property

Formatted text can also be used to create numbered or bulleted paragraphs with the SetListType(TextRange, ListType) method.

The following ListType options are available:

  • Bullet
  • ArabicNumbers
  • LowerCaseLetters
  • UpperCaseLetters
Paragraphs with a ListType other than None are considered to be 'list' paragraphs. Consecutive list paragraphs with the same indentation level are treated as part of the same list. A list ends when a list paragraph is followed by
  • a paragraph that has None
  • or a list paragraph that has a lower indentation level, i.e. is indented less. (See GetIndentLevel(TextRange))
Note that a list will continue uninterrupted after list paragraphs that have higher indentation level. These paragraphs form a 'sub-list' of the list they interrupt. Sub-lists can have their own sub-sub-lists. The nesting level is only limited by the maximum indent level. Using SetIndentLevel(TextRange, Int32) it is therefore possible to create multi-level lists.

FormattedText will keep lists consistent. That means that list paragraphs will automatically get sequential numbers or letters. It also means that if the list type of one of the paragraphs in a list is changed then that change is propagated to all the paragraphs in that list. Note that this will not affect the list type of any nested sub-lists.

Use a vertical tab character ('\v') to insert a line without a bullet or number. Since this does not end the paragraph this will allow the list to continue to the next paragraph.

Example
C#
VB
C++
F#
Copy
public void FormatText(TextNote textNote)
{
    // TextNote created with "New sample text"
    FormattedText formatText = textNote.GetFormattedText();

    // italicize "New"
    TextRange range = new TextRange(0, 3);
    formatText.SetItalicStatus(range, true);

    // make "sample" bold
    range = formatText.Find("sample", 0, false, true);
    if (range.Length > 0)
        formatText.SetBoldStatus(range, true);

    // make "text" underlined
    range = formatText.Find("text", 0, false, true);
    if (range.Length > 0)
        formatText.SetUnderlineStatus(range, true);

    // make all text uppercase
    formatText.SetAllCapsStatus(true);

    textNote.SetFormattedText(formatText);
}
Public Sub FormatText(textNote As TextNote)
    ' TextNote created with "New sample text"
    Dim formatText__1 As FormattedText = textNote.GetFormattedText()

    ' italicize "New"
    Dim range As New TextRange(0, 3)
    formatText__1.SetItalicStatus(range, True)

    ' make "sample" bold
    range = formatText__1.Find("sample", 0, False, True)
    If range.Length > 0 Then
        formatText__1.SetBoldStatus(range, True)
    End If

    ' make "text" underlined
    range = formatText__1.Find("text", 0, False, True)
    If range.Length > 0 Then
        formatText__1.SetUnderlineStatus(range, True)
    End If

    ' make all text uppercase
    formatText__1.SetAllCapsStatus(True)

    textNote.SetFormattedText(formatText__1)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FormattedText Constructor

Overload List
 | Name | Description
Public method | FormattedText | Creates a new default FormattedText object, which contains only a carriage return character and has no formatting.
 | FormattedText(String) | Creates a new FormattedText object with unformatted text.
Top
See Also

Reference

FormattedText Class


FormattedText Constructor

Creates a new default FormattedText object, which contains only a carriage return character and has no formatting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormattedText()
Public Sub New
public:
FormattedText()
new : unit -> FormattedText
See Also

Reference

FormattedText Class
FormattedText Overload


FormattedText(String) Constructor

Creates a new FormattedText object with unformatted text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormattedText(
    string plainText
)
Public Sub New (
    plainText As String
)
public:
FormattedText(
    String^ plainText
)
new :
        plainText : string -> FormattedText

Parameters

plainText String
The text in a plain text form.
Exceptions
Exception | Condition
ArgumentException | plainText (excluding a carriage return character ('\r') at the end) has more than 30,000 characters. -or- plainText contains invalid characters such as a newline character.
ArgumentNullException | A non-optional argument was null
Remarks
The given text should have no more than 30,000 characters. Line feed characters ('/n') are not allowed. An empty string is allowed.
Example
C#
VB
C++
F#
Copy
public void ReformatText(TextNote textNote, string textToChange)
{
    String plainText = textNote.Text;
    FormattedText formattedText = new FormattedText(plainText);

    TextRange foundRange = formattedText.Find(textToChange, 0, false, true);
    while (foundRange.Length > 0)
    {
        formattedText.SetBoldStatus(foundRange, true);
        foundRange = formattedText.Find(textToChange, foundRange.End, false, true);
    }

    textNote.SetFormattedText(formattedText);
}
Public Sub ReformatText(textNote As TextNote, textToChange As String)
    Dim plainText As [String] = textNote.Text
    Dim formattedText As New FormattedText(plainText)

    Dim foundRange As TextRange = formattedText.Find(textToChange, 0, False, True)
    While foundRange.Length > 0
        formattedText.SetBoldStatus(foundRange, True)
        foundRange = formattedText.Find(textToChange, foundRange.[End], False, True)
    End While

    textNote.SetFormattedText(formattedText)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

FormattedText Class
FormattedText Overload


FormattedText Properties

The FormattedText type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

FormattedText Class


FormattedText.IsValidObject Property

FormattedTextIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

FormattedText Class


FormattedText Methods

The FormattedText type exposes the following members.

Methods
 | Name | Description
 | AsTextRange | Returns a TextRange object that represents the entire text.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | Find | Returns a text range identifying the first occurrence of the given string within the text, starting from a given index.
Public method | GetAllCapsStatus | Returns whether All, None or a Mixed of characters in the entire text are in all caps.
Public method | GetAllCapsStatus(TextRange) | Returns whether All, None or a Mixed set of characters in a given text range are in all caps.
Public method | GetBoldStatus | Returns whether All, None or a Mixed of characters in the entire text are bold.
Public method | GetBoldStatus(TextRange) | Returns whether All, None or a Mixed set of characters in a given text range are bold.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIndentLevel | Returns the indent level of the paragraphs in the text range.
Public method | GetItalicStatus | Returns whether All, None or a Mixed of characters in the entire text are italic.
Public method | GetItalicStatus(TextRange) | Returns whether All, None or a Mixed set of characters in a given text range are italic.
Public method | GetListStartNumber | Returns the list start number of the paragraphs in a given text range.
Public method | GetListType | Returns the ListType of a paragraph.
Public method | GetMaximumIndentLevel | Returns the maximum allowed indent level
Public method | GetMaximumListStartNumber | Returns the maximum allowed list start number.
Public method | GetMinimumListStartNumber | Returns the minumum allowed list start number.
Public method | GetPlainText | Returns the entire text in a plain text form.
Public method | GetPlainText(TextRange) | Returns a substring of the text in a plain text form. The start and end of the substring is identified by a given TextRange.
Public method | GetSubscriptStatus | Returns whether All, None or a Mixed of characters in the entire text are subscripted.
Public method | GetSubscriptStatus(TextRange) | Returns whether All, None or a Mixed set of characters in a given text range are subscripted.
Public method | GetSuperscriptStatus | Returns whether All, None or a Mixed of characters in the entire text are superscripted.
Public method | GetSuperscriptStatus(TextRange) | Returns whether All, None or a Mixed set of characters in a given text range are superscripted.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetUnderlineStatus | Returns whether All, None or a Mixed of characters in the entire text are underlined.
Public method | GetUnderlineStatus(TextRange) | Returns whether All, None or a Mixed set of characters in a given text range are underlined.
Public method | SetAllCapsStatus(Boolean) | Sets the characters in the entire text to be in all caps or not.
Public method | SetAllCapsStatus(TextRange, Boolean) | Sets the characters in a given text range to be in all caps or not.
Public method | SetBoldStatus(Boolean) | Sets the characters in the entire text to be bold or not bold.
Public method | SetBoldStatus(TextRange, Boolean) | Sets the characters in a given text range to be bold or not bold.
Public method | SetIndentLevel | Sets the number of tab stops that the paragraph should be indented.
Public method | SetItalicStatus(Boolean) | Sets the characters in the entire text to be italic or not italic.
Public method | SetItalicStatus(TextRange, Boolean) | Sets the characters in a given text range to be italic or not italic.
Public method | SetListStartNumber | Sets the list start number on the paragraphs in a given text range.
 | SetListType | Sets the ListType of a paragraph.
Public method | SetPlainText(String) | Sets the entire text with the given text in a plain text form.
Public method | SetPlainText(TextRange, String) | Sets the text with the given text in a plain text form in a range.
Public method | SetSubscriptStatus(Boolean) | Sets the characters in the entire text to be subscript or not subscript.
Public method | SetSubscriptStatus(TextRange, Boolean) | Sets the characters in a given text range to be subscript or not subscript.
Public method | SetSuperscriptStatus(Boolean) | Sets the characters in the entire text to be superscript or not superscript.
Public method | SetSuperscriptStatus(TextRange, Boolean) | Sets the characters in a given text range to be superscript or not superscript.
Public method | SetUnderlineStatus(Boolean) | Sets the characters in the entire text to be underlined or not underlined.
Public method | SetUnderlineStatus(TextRange, Boolean) | Sets the characters in a given text range to be underlined or not underlined.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FormattedText Class


FormattedText.AsTextRange Method

FormattedTextAsTextRange Method

Returns a TextRange object that represents the entire text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TextRange AsTextRange()
Public Function AsTextRange As TextRange
public:
TextRange^ AsTextRange()
member AsTextRange : unit -> TextRange

Return Value

TextRange
The TextRange object that represents the entire text.
Remarks
This range includes a carriage return character ('\r') that is always present. As a result the range can never be an empty range.
Example
C#
VB
C++
F#
Copy
public void AppendText(TextNote textNote)
{
    FormattedText formatText = textNote.GetFormattedText();

    TextRange range = formatText.AsTextRange();

    range.Start = range.End - 1;
    // set Length to 0 to insert
    range.Length = 0;
    string someNewText = "\rThis is a new paragraph\vThis is a new line without a paragraph break\r";
    formatText.SetPlainText(range, someNewText);

    // get range for entire text
    range = formatText.AsTextRange();
    range.Start = range.End - 1;
    range.Length = 0;
    string someListText = "\rBulleted List item 1\rItem 2\vSecond line for Item 2\rThird bullet point";
    formatText.SetPlainText(range, someListText);
    range.Start++;
    range.Length = someListText.Length;
    formatText.SetListType(range, ListType.Bullet);

    if (formatText.GetAllCapsStatus(range) != FormatStatus.None)
    {
        formatText.SetAllCapsStatus(range, false);
    }

    textNote.SetFormattedText(formatText);
}
Public Sub AppendText(textNote As TextNote)
    Dim formatText As FormattedText = textNote.GetFormattedText()

    Dim range As TextRange = formatText.AsTextRange()

    range.Start = range.[End] - 1
    ' set Length to 0 to insert
    range.Length = 0
    Dim someNewText As String = vbCr & "This is a new paragraph" & vbVerticalTab & "This is a new line without a paragraph break" & vbCr
    formatText.SetPlainText(range, someNewText)

    ' get range for entire text
    range = formatText.AsTextRange()
    range.Start = range.[End] - 1
    range.Length = 0
    Dim someListText As String = vbCr & "Bulleted List item 1" & vbCr & "Item 2" & vbVerticalTab & "Second line for Item 2" & vbCr & "Third bullet point"
    formatText.SetPlainText(range, someListText)
    range.Start += 1
    range.Length = someListText.Length
    formatText.SetListType(range, ListType.Bullet)

    If formatText.GetAllCapsStatus(range) <> FormatStatus.None Then
        formatText.SetAllCapsStatus(range, False)
    End If

    textNote.SetFormattedText(formatText)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

FormattedText Class


FormattedText.Dispose Method

FormattedTextDispose Method

Releases all resources used by the FormattedText

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FormattedText Class


FormattedText.Find Method

FormattedTextFind Method

Returns a text range identifying the first occurrence of the given string within the text, starting from a given index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TextRange Find(
    string searchString,
    int startIndex,
    bool matchCase,
    bool matchWholeWord
)
Public Function Find (
    searchString As String,
    startIndex As Integer,
    matchCase As Boolean,
    matchWholeWord As Boolean
) As TextRange
public:
TextRange^ Find(
    String^ searchString,
    int startIndex,
    bool matchCase,
    bool matchWholeWord
)
member Find :
        searchString : string *
        startIndex : int *
        matchCase : bool *
        matchWholeWord : bool -> TextRange

Parameters

searchString String
The text to search for.
startIndex Int32
The start index to search within the text.
matchCase Boolean
True if the case must match when searching the formatted text, false to search in a case-insensitive manner.
matchWholeWord Boolean
True if the match must be a whole word when searching the formatted text, false otherwise.

Return Value

TextRange
The text range identified.
Exceptions
Exception | Condition
ArgumentException | searchString is an empty string. -or- searchString contains invalid characters such as a newline character.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | The given value for startIndex is negative.
Remarks
Returns an empty text range:
  • if the given string cannot be found in the text.
  • if the given start index is beyond the length of the entire text.
The search can be case-sensitive or case-insensitive. The search can be set to match whole words or part of words.
Example
C#
VB
C++
F#
Copy
#region Autodesk.Revit.DB.FormattedText.#ctor(System.String)
public void ReformatText(TextNote textNote, string textToChange)
{
    String plainText = textNote.Text;
    FormattedText formattedText = new FormattedText(plainText);

    TextRange foundRange = formattedText.Find(textToChange, 0, false, true);
    while (foundRange.Length > 0)
    {
        formattedText.SetBoldStatus(foundRange, true);
        foundRange = formattedText.Find(textToChange, foundRange.End, false, true);
    }

    textNote.SetFormattedText(formattedText);
}
#endregion
#Region "Autodesk.Revit.DB.FormattedText.#ctor(System.String)"
        Public Sub ReformatText(textNote As TextNote, textToChange As String)
            Dim plainText As [String] = textNote.Text
            Dim formattedText As New FormattedText(plainText)

            Dim foundRange As TextRange = formattedText.Find(textToChange, 0, False, True)
            While foundRange.Length > 0
                formattedText.SetBoldStatus(foundRange, True)
                foundRange = formattedText.Find(textToChange, foundRange.[End], False, True)
            End While

            textNote.SetFormattedText(formattedText)
        End Sub
#End Region

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

FormattedText Class


FormattedText.GetAllCapsStatus Method

FormattedTextGetAllCapsStatus Method

Overload List
 | Name | Description
Public method | GetAllCapsStatus | Returns whether All, None or a Mixed of characters in the entire text are in all caps.
Public method | GetAllCapsStatus(TextRange) | Returns whether All, None or a Mixed set of characters in a given text range are in all caps.
Top
See Also

Reference

FormattedText Class


FormattedText.GetAllCapsStatus Method

FormattedTextGetAllCapsStatus Method

Returns whether All, None or a Mixed of characters in the entire text are in all caps.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormatStatus GetAllCapsStatus()
Public Function GetAllCapsStatus As FormatStatus
public:
FormatStatus GetAllCapsStatus()
member GetAllCapsStatus : unit -> FormatStatus

Return Value

FormatStatus
The format status of all caps on characters FormatStatus.
Remarks
This function only returns All or None if the entire text contains one character.
See Also

Reference

FormattedText Class
GetAllCapsStatus Overload


FormattedText.GetAllCapsStatus(TextRange) Method

FormattedTextGetAllCapsStatus(TextRange) Method

Returns whether All, None or a Mixed set of characters in a given text range are in all caps.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormatStatus GetAllCapsStatus(
    TextRange textRange
)
Public Function GetAllCapsStatus (
    textRange As TextRange
) As FormatStatus
public:
FormatStatus GetAllCapsStatus(
    TextRange^ textRange
)
member GetAllCapsStatus :
        textRange : TextRange -> FormatStatus

Parameters

textRange TextRange
The given text range.

Return Value

FormatStatus
The format status of all caps on characters FormatStatus.
Exceptions
Exception | Condition
ArgumentException | This text range is empty. -or- This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text.
ArgumentNullException | A non-optional argument was null
Remarks
This function only returns All or None if the text contains one character. The given text range should not be empty.
See Also

Reference

FormattedText Class
GetAllCapsStatus Overload


FormattedText.GetBoldStatus Method

FormattedTextGetBoldStatus Method

Overload List
 | Name | Description
Public method | GetBoldStatus | Returns whether All, None or a Mixed of characters in the entire text are bold.
Public method | GetBoldStatus(TextRange) | Returns whether All, None or a Mixed set of characters in a given text range are bold.
Top
See Also

Reference

FormattedText Class


FormattedText.GetBoldStatus Method

FormattedTextGetBoldStatus Method

Returns whether All, None or a Mixed of characters in the entire text are bold.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormatStatus GetBoldStatus()
Public Function GetBoldStatus As FormatStatus
public:
FormatStatus GetBoldStatus()
member GetBoldStatus : unit -> FormatStatus

Return Value

FormatStatus
The format status of bold on characters FormatStatus.
Remarks
This function only returns All or None if the entire text contains one character.
See Also

Reference

FormattedText Class
GetBoldStatus Overload


FormattedText.GetBoldStatus(TextRange) Method

FormattedTextGetBoldStatus(TextRange) Method

Returns whether All, None or a Mixed set of characters in a given text range are bold.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormatStatus GetBoldStatus(
    TextRange textRange
)
Public Function GetBoldStatus (
    textRange As TextRange
) As FormatStatus
public:
FormatStatus GetBoldStatus(
    TextRange^ textRange
)
member GetBoldStatus :
        textRange : TextRange -> FormatStatus

Parameters

textRange TextRange
The given text range.

Return Value

FormatStatus
The format status of bold on characters FormatStatus.
Exceptions
Exception | Condition
ArgumentException | This text range is empty. -or- This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text.
ArgumentNullException | A non-optional argument was null
Remarks
This function only returns All or None if the text contains one character. The given text range should not be empty.
See Also

Reference

FormattedText Class
GetBoldStatus Overload


FormattedText.GetIndentLevel Method

FormattedTextGetIndentLevel Method

Returns the indent level of the paragraphs in the text range.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetIndentLevel(
    TextRange textRange
)
Public Function GetIndentLevel (
    textRange As TextRange
) As Integer
public:
int GetIndentLevel(
    TextRange^ textRange
)
member GetIndentLevel :
        textRange : TextRange -> int

Parameters

textRange TextRange
The given text range.

Return Value

Int32
The indentation level of the paragraphs in the range.
Exceptions
Exception | Condition
ArgumentException | This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text.
ArgumentNullException | A non-optional argument was null
Remarks
Returns -1 if the range contains multiple paragraphs with different indent levels.
See Also

Reference

FormattedText Class


FormattedText.GetItalicStatus Method

FormattedTextGetItalicStatus Method

Overload List
 | Name | Description
Public method | GetItalicStatus | Returns whether All, None or a Mixed of characters in the entire text are italic.
Public method | GetItalicStatus(TextRange) | Returns whether All, None or a Mixed set of characters in a given text range are italic.
Top
See Also

Reference

FormattedText Class


FormattedText.GetItalicStatus Method

FormattedTextGetItalicStatus Method

Returns whether All, None or a Mixed of characters in the entire text are italic.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormatStatus GetItalicStatus()
Public Function GetItalicStatus As FormatStatus
public:
FormatStatus GetItalicStatus()
member GetItalicStatus : unit -> FormatStatus

Return Value

FormatStatus
The format status of italic on characters FormatStatus.
Remarks
This function only returns All or None if the entire text contains one character.
See Also

Reference

FormattedText Class
GetItalicStatus Overload


FormattedText.GetItalicStatus(TextRange) Method

FormattedTextGetItalicStatus(TextRange) Method

Returns whether All, None or a Mixed set of characters in a given text range are italic.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormatStatus GetItalicStatus(
    TextRange textRange
)
Public Function GetItalicStatus (
    textRange As TextRange
) As FormatStatus
public:
FormatStatus GetItalicStatus(
    TextRange^ textRange
)
member GetItalicStatus :
        textRange : TextRange -> FormatStatus

Parameters

textRange TextRange
The given text range.

Return Value

FormatStatus
The format status of italic on characters FormatStatus.
Exceptions
Exception | Condition
ArgumentException | This text range is empty. -or- This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text.
ArgumentNullException | A non-optional argument was null
Remarks
This function only returns All or None if the text contains one character. The given text range should not be empty.
See Also

Reference

FormattedText Class
GetItalicStatus Overload


FormattedText.GetListStartNumber Method

FormattedTextGetListStartNumber Method

Returns the list start number of the paragraphs in a given text range.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetListStartNumber(
    TextRange textRange
)
Public Function GetListStartNumber (
    textRange As TextRange
) As Integer
public:
int GetListStartNumber(
    TextRange^ textRange
)
member GetListStartNumber :
        textRange : TextRange -> int

Parameters

textRange TextRange
The given text range.

Return Value

Int32
The list start number of the text range.
Exceptions
Exception | Condition
ArgumentException | This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text.
ArgumentNullException | A non-optional argument was null
Remarks
Returns -1 if there is a mix of list start values in the range or if there are paragraphs in different lists or sub-lists in the range or if there are paragraphs of type None or Bullet in the range.
See Also

Reference

FormattedText Class


FormattedText.GetListType Method

FormattedTextGetListType Method

Returns the ListType of a paragraph.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ListType GetListType(
    TextRange textRange
)
Public Function GetListType (
    textRange As TextRange
) As ListType
public:
ListType GetListType(
    TextRange^ textRange
)
member GetListType :
        textRange : TextRange -> ListType

Parameters

textRange TextRange
The given text range.

Return Value

ListType
The ListType of the paragraph.
Exceptions
Exception | Condition
ArgumentException | This text range is empty. -or- This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text.
ArgumentNullException | A non-optional argument was null
Remarks
This function returns the list type of all paragraphs contained in the given range. Returns None if the paragraph is not in a list. Returns Mixed if the list types don't match between the paragraphs.
See Also

Reference

FormattedText Class


FormattedText.GetMaximumIndentLevel Method

FormattedTextGetMaximumIndentLevel Method

Returns the maximum allowed indent level

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetMaximumIndentLevel()
Public Function GetMaximumIndentLevel As Integer
public:
int GetMaximumIndentLevel()
member GetMaximumIndentLevel : unit -> int

Return Value

Int32
See Also

Reference

FormattedText Class


FormattedText.GetMaximumListStartNumber Method

FormattedTextGetMaximumListStartNumber Method

Returns the maximum allowed list start number.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetMaximumListStartNumber()
Public Function GetMaximumListStartNumber As Integer
public:
int GetMaximumListStartNumber()
member GetMaximumListStartNumber : unit -> int

Return Value

Int32
See Also

Reference

FormattedText Class


FormattedText.GetMinimumListStartNumber Method

FormattedTextGetMinimumListStartNumber Method

Returns the minumum allowed list start number.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetMinimumListStartNumber()
Public Function GetMinimumListStartNumber As Integer
public:
int GetMinimumListStartNumber()
member GetMinimumListStartNumber : unit -> int

Return Value

Int32
See Also

Reference

FormattedText Class


FormattedText.GetPlainText Method

FormattedTextGetPlainText Method

Overload List
 | Name | Description
Public method | GetPlainText | Returns the entire text in a plain text form.
Public method | GetPlainText(TextRange) | Returns a substring of the text in a plain text form. The start and end of the substring is identified by a given TextRange.
Top
See Also

Reference

FormattedText Class


FormattedText.GetPlainText Method

FormattedTextGetPlainText Method

Returns the entire text in a plain text form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetPlainText()
Public Function GetPlainText As String
public:
String^ GetPlainText()
member GetPlainText : unit -> string

Return Value

String
The entire text in a plain text form.
Remarks
The text includes a carriage return character ('\r') that is always present. As a result this method will never return an empty string.
See Also

Reference

FormattedText Class
GetPlainText Overload


FormattedText.GetPlainText(TextRange) Method

FormattedTextGetPlainText(TextRange) Method

Returns a substring of the text in a plain text form. The start and end of the substring is identified by a given TextRange.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetPlainText(
    TextRange textRange
)
Public Function GetPlainText (
    textRange As TextRange
) As String
public:
String^ GetPlainText(
    TextRange^ textRange
)
member GetPlainText :
        textRange : TextRange -> string

Parameters

textRange TextRange
The given TextRange.

Return Value

String
The substring of the text in a plain text form.
Exceptions
Exception | Condition
ArgumentException | This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text.
ArgumentNullException | A non-optional argument was null
See Also

Reference

FormattedText Class
GetPlainText Overload


FormattedText.GetSubscriptStatus Method

FormattedTextGetSubscriptStatus Method

Overload List
 | Name | Description
Public method | GetSubscriptStatus | Returns whether All, None or a Mixed of characters in the entire text are subscripted.
Public method | GetSubscriptStatus(TextRange) | Returns whether All, None or a Mixed set of characters in a given text range are subscripted.
Top
See Also

Reference

FormattedText Class


FormattedText.GetSubscriptStatus Method

FormattedTextGetSubscriptStatus Method

Returns whether All, None or a Mixed of characters in the entire text are subscripted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormatStatus GetSubscriptStatus()
Public Function GetSubscriptStatus As FormatStatus
public:
FormatStatus GetSubscriptStatus()
member GetSubscriptStatus : unit -> FormatStatus

Return Value

FormatStatus
The format status of subscript on characters FormatStatus.
Remarks
This function only returns All or None if the entire text contains one character.
See Also

Reference

FormattedText Class
GetSubscriptStatus Overload


FormattedText.GetSubscriptStatus(TextRange) Method

FormattedTextGetSubscriptStatus(TextRange) Method

Returns whether All, None or a Mixed set of characters in a given text range are subscripted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormatStatus GetSubscriptStatus(
    TextRange textRange
)
Public Function GetSubscriptStatus (
    textRange As TextRange
) As FormatStatus
public:
FormatStatus GetSubscriptStatus(
    TextRange^ textRange
)
member GetSubscriptStatus :
        textRange : TextRange -> FormatStatus

Parameters

textRange TextRange
The given text range.

Return Value

FormatStatus
The format status of subscript on characters FormatStatus.
Exceptions
Exception | Condition
ArgumentException | This text range is empty. -or- This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text.
ArgumentNullException | A non-optional argument was null
Remarks
This function only returns All or None if the text contains one character. The given text range should not be empty.
See Also

Reference

FormattedText Class
GetSubscriptStatus Overload


FormattedText.GetSuperscriptStatus Method

FormattedTextGetSuperscriptStatus Method

Overload List
 | Name | Description
Public method | GetSuperscriptStatus | Returns whether All, None or a Mixed of characters in the entire text are superscripted.
Public method | GetSuperscriptStatus(TextRange) | Returns whether All, None or a Mixed set of characters in a given text range are superscripted.
Top
See Also

Reference

FormattedText Class


FormattedText.GetSuperscriptStatus Method

FormattedTextGetSuperscriptStatus Method

Returns whether All, None or a Mixed of characters in the entire text are superscripted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormatStatus GetSuperscriptStatus()
Public Function GetSuperscriptStatus As FormatStatus
public:
FormatStatus GetSuperscriptStatus()
member GetSuperscriptStatus : unit -> FormatStatus

Return Value

FormatStatus
The format status of superscript on characters FormatStatus.
Remarks
This function only returns All or None if the entire text contains one character.
See Also

Reference

FormattedText Class
GetSuperscriptStatus Overload


FormattedText.GetSuperscriptStatus(TextRange) Method

FormattedTextGetSuperscriptStatus(TextRange) Method

Returns whether All, None or a Mixed set of characters in a given text range are superscripted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormatStatus GetSuperscriptStatus(
    TextRange textRange
)
Public Function GetSuperscriptStatus (
    textRange As TextRange
) As FormatStatus
public:
FormatStatus GetSuperscriptStatus(
    TextRange^ textRange
)
member GetSuperscriptStatus :
        textRange : TextRange -> FormatStatus

Parameters

textRange TextRange
The given text range.

Return Value

FormatStatus
The format status of superscript on characters FormatStatus.
Exceptions
Exception | Condition
ArgumentException | This text range is empty. -or- This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text.
ArgumentNullException | A non-optional argument was null
Remarks
This function only returns All or None if the text contains one character. The given text range should not be empty.
See Also

Reference

FormattedText Class
GetSuperscriptStatus Overload


FormattedText.GetUnderlineStatus Method

FormattedTextGetUnderlineStatus Method

Overload List
 | Name | Description
Public method | GetUnderlineStatus | Returns whether All, None or a Mixed of characters in the entire text are underlined.
Public method | GetUnderlineStatus(TextRange) | Returns whether All, None or a Mixed set of characters in a given text range are underlined.
Top
See Also

Reference

FormattedText Class


FormattedText.GetUnderlineStatus Method

FormattedTextGetUnderlineStatus Method

Returns whether All, None or a Mixed of characters in the entire text are underlined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormatStatus GetUnderlineStatus()
Public Function GetUnderlineStatus As FormatStatus
public:
FormatStatus GetUnderlineStatus()
member GetUnderlineStatus : unit -> FormatStatus

Return Value

FormatStatus
The format status of underline on characters FormatStatus.
Remarks
This function only returns All or None if the entire text contains one character.
See Also

Reference

FormattedText Class
GetUnderlineStatus Overload


FormattedText.GetUnderlineStatus(TextRange) Method

FormattedTextGetUnderlineStatus(TextRange) Method

Returns whether All, None or a Mixed set of characters in a given text range are underlined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormatStatus GetUnderlineStatus(
    TextRange textRange
)
Public Function GetUnderlineStatus (
    textRange As TextRange
) As FormatStatus
public:
FormatStatus GetUnderlineStatus(
    TextRange^ textRange
)
member GetUnderlineStatus :
        textRange : TextRange -> FormatStatus

Parameters

textRange TextRange
The given text range.

Return Value

FormatStatus
The format status of underline on characters FormatStatus.
Exceptions
Exception | Condition
ArgumentException | This text range is empty. -or- This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text.
ArgumentNullException | A non-optional argument was null
Remarks
This function only returns All or None if the text contains one character. The given text range should not be empty.
See Also

Reference

FormattedText Class
GetUnderlineStatus Overload


FormattedText.SetAllCapsStatus Method

FormattedTextSetAllCapsStatus Method

Overload List
 | Name | Description
Public method | SetAllCapsStatus(Boolean) | Sets the characters in the entire text to be in all caps or not.
Public method | SetAllCapsStatus(TextRange, Boolean) | Sets the characters in a given text range to be in all caps or not.
Top
See Also

Reference

FormattedText Class


FormattedText.SetAllCapsStatus(Boolean) Method

FormattedTextSetAllCapsStatus(Boolean) Method

Sets the characters in the entire text to be in all caps or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetAllCapsStatus(
    bool isAllCaps
)
Public Sub SetAllCapsStatus (
    isAllCaps As Boolean
)
public:
void SetAllCapsStatus(
    bool isAllCaps
)
member SetAllCapsStatus :
        isAllCaps : bool -> unit

Parameters

isAllCaps Boolean
The desired all caps status of characters in the entire text. True to set all capped, false to set not all capped.
See Also

Reference

FormattedText Class
SetAllCapsStatus Overload


FormattedText.SetAllCapsStatus(TextRange, Boolean) Method

FormattedTextSetAllCapsStatus(TextRange, Boolean) Method

Sets the characters in a given text range to be in all caps or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetAllCapsStatus(
    TextRange textRange,
    bool isAllCaps
)
Public Sub SetAllCapsStatus (
    textRange As TextRange,
    isAllCaps As Boolean
)
public:
void SetAllCapsStatus(
    TextRange^ textRange,
    bool isAllCaps
)
member SetAllCapsStatus :
        textRange : TextRange *
        isAllCaps : bool -> unit

Parameters

textRange TextRange
The given text range.
isAllCaps Boolean
The desired all caps status of characters in the given text range. True will render all characters in all caps. False will revert the characters back to their original mixed case.
Exceptions
Exception | Condition
ArgumentException | This text range is empty. -or- This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text.
ArgumentNullException | A non-optional argument was null
Remarks

Removing the all caps status will revert the characters back to their original case. It will not make them lower case.

The given text range should not be empty.

See Also

Reference

FormattedText Class
SetAllCapsStatus Overload


FormattedText.SetBoldStatus Method

FormattedTextSetBoldStatus Method

Overload List
 | Name | Description
Public method | SetBoldStatus(Boolean) | Sets the characters in the entire text to be bold or not bold.
Public method | SetBoldStatus(TextRange, Boolean) | Sets the characters in a given text range to be bold or not bold.
Top
See Also

Reference

FormattedText Class


FormattedText.SetBoldStatus(Boolean) Method

FormattedTextSetBoldStatus(Boolean) Method

Sets the characters in the entire text to be bold or not bold.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetBoldStatus(
    bool isBold
)
Public Sub SetBoldStatus (
    isBold As Boolean
)
public:
void SetBoldStatus(
    bool isBold
)
member SetBoldStatus :
        isBold : bool -> unit

Parameters

isBold Boolean
The desired bold status of characters in the entire text. True to set bold, false to set not bold.
See Also

Reference

FormattedText Class
SetBoldStatus Overload


FormattedText.SetBoldStatus(TextRange, Boolean) Method

FormattedTextSetBoldStatus(TextRange, Boolean) Method

Sets the characters in a given text range to be bold or not bold.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetBoldStatus(
    TextRange textRange,
    bool isBold
)
Public Sub SetBoldStatus (
    textRange As TextRange,
    isBold As Boolean
)
public:
void SetBoldStatus(
    TextRange^ textRange,
    bool isBold
)
member SetBoldStatus :
        textRange : TextRange *
        isBold : bool -> unit

Parameters

textRange TextRange
The given text range.
isBold Boolean
The desired bold status of characters in the given text range. True to set bold, false to set not bold.
Exceptions
Exception | Condition
ArgumentException | This text range is empty. -or- This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text.
ArgumentNullException | A non-optional argument was null
Remarks

To make the numbers or letters in a list bold, apply the bold status to the carriage return character that ends the list paragraph.

The given text range should not be empty.

See Also

Reference

FormattedText Class
SetBoldStatus Overload


FormattedText.SetIndentLevel Method

FormattedTextSetIndentLevel Method

Sets the number of tab stops that the paragraph should be indented.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetIndentLevel(
    TextRange textRange,
    int level
)
Public Sub SetIndentLevel (
    textRange As TextRange,
    level As Integer
)
public:
void SetIndentLevel(
    TextRange^ textRange,
    int level
)
member SetIndentLevel :
        textRange : TextRange *
        level : int -> unit

Parameters

textRange TextRange
The given text range.
level Int32
The level set on the paragraph.
Exceptions
Exception | Condition
ArgumentException | This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text. -or- This level is too large to set on a paragraph.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | The given value for level is negative.
Remarks

The indent level is the number of tab stops by which each paragraph will be indented.

Note that adjoining paragraphs that have the same indent level and have a list type other than None are considered part of a numbered list. Changing the indent level of paragraphs that are bulleted or numbered (i.e. paragraphs that have a list type other than None) may cause other changes to the document as the changed paragraphs may join or leave a list. Which will cause the other paragraphs in those lists to be renumbered.

This function applies the nesting level to all paragraphs contained in the given range. The level set on the paragraph cannot be negative and cannot be larger than the value returned by GetMaximumIndentLevel .

See Also

Reference

FormattedText Class


FormattedText.SetItalicStatus Method

FormattedTextSetItalicStatus Method

Overload List
 | Name | Description
Public method | SetItalicStatus(Boolean) | Sets the characters in the entire text to be italic or not italic.
Public method | SetItalicStatus(TextRange, Boolean) | Sets the characters in a given text range to be italic or not italic.
Top
See Also

Reference

FormattedText Class


FormattedText.SetItalicStatus(Boolean) Method

FormattedTextSetItalicStatus(Boolean) Method

Sets the characters in the entire text to be italic or not italic.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetItalicStatus(
    bool isItalic
)
Public Sub SetItalicStatus (
    isItalic As Boolean
)
public:
void SetItalicStatus(
    bool isItalic
)
member SetItalicStatus :
        isItalic : bool -> unit

Parameters

isItalic Boolean
The desired italic status of characters in the entire text. True to set italic, false to set not italic.
See Also

Reference

FormattedText Class
SetItalicStatus Overload


FormattedText.SetItalicStatus(TextRange, Boolean) Method

FormattedTextSetItalicStatus(TextRange, Boolean) Method

Sets the characters in a given text range to be italic or not italic.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetItalicStatus(
    TextRange textRange,
    bool isItalic
)
Public Sub SetItalicStatus (
    textRange As TextRange,
    isItalic As Boolean
)
public:
void SetItalicStatus(
    TextRange^ textRange,
    bool isItalic
)
member SetItalicStatus :
        textRange : TextRange *
        isItalic : bool -> unit

Parameters

textRange TextRange
The given text range.
isItalic Boolean
The desired italic status of characters in the given text range. True to set italic, false to set not italic.
Exceptions
Exception | Condition
ArgumentException | This text range is empty. -or- This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text.
ArgumentNullException | A non-optional argument was null
Remarks

To make the numbers or letters in a list italic, apply the italic status to the carriage return character that ends the list paragraph.

The given text range should not be empty.

See Also

Reference

FormattedText Class
SetItalicStatus Overload


FormattedText.SetListStartNumber Method

FormattedTextSetListStartNumber Method

Sets the list start number on the paragraphs in a given text range.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetListStartNumber(
    TextRange textRange,
    int value
)
Public Sub SetListStartNumber (
    textRange As TextRange,
    value As Integer
)
public:
void SetListStartNumber(
    TextRange^ textRange,
    int value
)
member SetListStartNumber :
        textRange : TextRange *
        value : int -> unit

Parameters

textRange TextRange
The given text range.
value Int32
The list start number to be set on the text range.
Exceptions
Exception | Condition
ArgumentException | This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text. -or- This list start number is not valid. A valid value must be in the range given by the methods GetMinimumListStartNumber and GetMaximumListStartNumber. -or- Cannot set list start number on this text range. The range contains paragraphs on which list start number cannot be set. List start number can be set on pararaphs of type ArabicNumbers, LowerCaseLetters and UpperCaseLetters. List start number can only be set for top-level paragraphs in a list; that is, they cannot be set to paragraphs which are part of a sub-list.
ArgumentNullException | A non-optional argument was null
Remarks

List start number is the number of the first paragraph in a numbered list.

List start number can be set on paragraphs of type ArabicNumbers, LowerCaseLetters and UpperCaseLetters. List start number can only be set for top-level paragraphs in a list; that is, they cannot be set to paragraphs which are part of a sub-list.

For paragraphs of type LowerCaseLetters and UpperCaseLetters the list start number represents the letter in the order it appears in the alphabet. For example, for paragraphs of type LowerCaseLetters, list start number of 2 will result in a list start "b."; list start number of 27 will result in a list start "aa.".

Adjoining paragraphs which have a list type other than None are considered part of a numbered list. Changing the list start number of numbered paragraphs will cause changes to the numbers of the rest of the paragraphs in the same list.

This function applies the list start number to the given range. The list start number must be in the range given by the methods GetMinimumListStartNumber and GetMaximumListStartNumber.

See Also

Reference

FormattedText Class


FormattedText.SetListType Method

FormattedTextSetListType Method

Sets the ListType of a paragraph.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetListType(
    TextRange textRange,
    ListType listType
)
Public Sub SetListType (
    textRange As TextRange,
    listType As ListType
)
public:
void SetListType(
    TextRange^ textRange,
    ListType listType
)
member SetListType :
        textRange : TextRange *
        listType : ListType -> unit

Parameters

textRange TextRange
The given text range.
listType ListType
The ListType to set on the paragraph.
Exceptions
Exception | Condition
ArgumentException | This text range is empty. -or- This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text. -or- This list type is not valid to set on a paragraph.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Remarks

This function applies the ListType to all paragraphs contained in the given range.

The following ListType options are available:

  • Bullet
  • ArabicNumbers
  • LowerCaseLetters
  • UpperCaseLetters

Set the list type to None if the paragraph should not be in a list.

The list type cannot be set to Mixed.

Paragraphs with a ListType other than None are considered to be 'list' paragraphs.

Consecutive list paragraphs with the same indentation level are treated as part of the same list. A list ends when a list paragraph is followed by

  • a paragraph that has None
  • or a list paragraph that has a lower indentation level, (i.e. is indented less)
Note that a list will continue uninterrupted after list paragraphs that have higher indentation level. These paragraphs are considered a 'sub-list'. Using SetIndentLevel(TextRange, Int32) it is therefore possible to create multi-level lists. Note that sub-lists can have their own sub-sub-lists. The nesting level is only limited by the maximum indent level.

FormattedText will keep lists consistent. That means that numbered paragraphs will automatically get sequential numbers or letters. It also means that if the list type of one paragraphs in the list is changed then that change is propagated to all the paragraphs in that list. Even if those paragraphs were not in the input text range. Note that this will not affect the list type of any nested sub-lists.

Use a vertical tab character ('\v') to insert a line without a bullet or number. Since this does not end the paragraph this will allow the list to continue to the next paragraph.

Example
C#
VB
C++
F#
Copy
#region Autodesk.Revit.DB.FormattedText.AsTextRange()
public void AppendText(TextNote textNote)
{
    FormattedText formatText = textNote.GetFormattedText();

    TextRange range = formatText.AsTextRange();

    range.Start = range.End - 1;
    // set Length to 0 to insert
    range.Length = 0;
    string someNewText = "\rThis is a new paragraph\vThis is a new line without a paragraph break\r";
    formatText.SetPlainText(range, someNewText);

    // get range for entire text
    range = formatText.AsTextRange();
    range.Start = range.End - 1;
    range.Length = 0;
    string someListText = "\rBulleted List item 1\rItem 2\vSecond line for Item 2\rThird bullet point";
    formatText.SetPlainText(range, someListText);
    range.Start++;
    range.Length = someListText.Length;
    formatText.SetListType(range, ListType.Bullet);

    if (formatText.GetAllCapsStatus(range) != FormatStatus.None)
    {
        formatText.SetAllCapsStatus(range, false);
    }

    textNote.SetFormattedText(formatText);
}
#endregion
#Region "Autodesk.Revit.DB.FormattedText.AsTextRange()"
        Public Sub AppendText(textNote As TextNote)
            Dim formatText As FormattedText = textNote.GetFormattedText()

            Dim range As TextRange = formatText.AsTextRange()

            range.Start = range.[End] - 1
            ' set Length to 0 to insert
            range.Length = 0
            Dim someNewText As String = vbCr & "This is a new paragraph" & vbVerticalTab & "This is a new line without a paragraph break" & vbCr
            formatText.SetPlainText(range, someNewText)

            ' get range for entire text
            range = formatText.AsTextRange()
            range.Start = range.[End] - 1
            range.Length = 0
            Dim someListText As String = vbCr & "Bulleted List item 1" & vbCr & "Item 2" & vbVerticalTab & "Second line for Item 2" & vbCr & "Third bullet point"
            formatText.SetPlainText(range, someListText)
            range.Start += 1
            range.Length = someListText.Length
            formatText.SetListType(range, ListType.Bullet)

            If formatText.GetAllCapsStatus(range) <> FormatStatus.None Then
                formatText.SetAllCapsStatus(range, False)
            End If

            textNote.SetFormattedText(formatText)
        End Sub
#End Region

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

FormattedText Class


FormattedText.SetPlainText Method

FormattedTextSetPlainText Method

Overload List
 | Name | Description
Public method | SetPlainText(String) | Sets the entire text with the given text in a plain text form.
Public method | SetPlainText(TextRange, String) | Sets the text with the given text in a plain text form in a range.
Top
See Also

Reference

FormattedText Class


FormattedText.SetPlainText(String) Method

FormattedTextSetPlainText(String) Method

Sets the entire text with the given text in a plain text form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetPlainText(
    string plainText
)
Public Sub SetPlainText (
    plainText As String
)
public:
void SetPlainText(
    String^ plainText
)
member SetPlainText :
        plainText : string -> unit

Parameters

plainText String
The given text in a plain text form.
Exceptions
Exception | Condition
ArgumentException | plainText (excluding a carriage return character ('\r') at the end) has more than 30,000 characters. -or- plainText contains invalid characters such as a newline character.
ArgumentNullException | A non-optional argument was null
Remarks
Any individual formatting present before will be lost after applying this function and the text will have uniform formatting. If the text does not end with a carriage return character ('\r') one will be added. An empty string is allowed. The given text should have no more than 30,000 characters, not counting a terminating carriage return character ('\r'). Newline characters ('\n') are not allowed.
See Also

Reference

FormattedText Class
SetPlainText Overload


FormattedText.SetPlainText(TextRange, String) Method

FormattedTextSetPlainText(TextRange, String) Method

Sets the text with the given text in a plain text form in a range.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetPlainText(
    TextRange textRange,
    string plainText
)
Public Sub SetPlainText (
    textRange As TextRange,
    plainText As String
)
public:
void SetPlainText(
    TextRange^ textRange,
    String^ plainText
)
member SetPlainText :
        textRange : TextRange *
        plainText : string -> unit

Parameters

textRange TextRange
The given text range.
plainText String
The given text in a plain text form.
Exceptions
Exception | Condition
ArgumentException | This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text. -or- plainText contains invalid characters such as a newline character. -or- plainText (excluding a carriage return character ('\r') at the end) has more than 30,000 characters. -or- Replacing the text in textRange with plainText will exceed 30,000 characters.
ArgumentNullException | A non-optional argument was null
Remarks
Any individual formatting present in the range before will be lost after applying this function and the text in the range will have uniform formatting. The given text will be inserted if the given text range is empty. The given text should have no more than 30,000 characters. The the resulting text may not exceed 30,000 characters. Newline characters ('\n') are not allowed.
See Also

Reference

FormattedText Class
SetPlainText Overload


FormattedText.SetSubscriptStatus Method

FormattedTextSetSubscriptStatus Method

Overload List
 | Name | Description
Public method | SetSubscriptStatus(Boolean) | Sets the characters in the entire text to be subscript or not subscript.
Public method | SetSubscriptStatus(TextRange, Boolean) | Sets the characters in a given text range to be subscript or not subscript.
Top
See Also

Reference

FormattedText Class


FormattedText.SetSubscriptStatus(Boolean) Method

FormattedTextSetSubscriptStatus(Boolean) Method

Sets the characters in the entire text to be subscript or not subscript.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetSubscriptStatus(
    bool isSubscript
)
Public Sub SetSubscriptStatus (
    isSubscript As Boolean
)
public:
void SetSubscriptStatus(
    bool isSubscript
)
member SetSubscriptStatus :
        isSubscript : bool -> unit

Parameters

isSubscript Boolean
The desired subscript status of characters in the entire text. True to set subscript, false to set not subscript.
Remarks
If the characters are set to be subscript, they cannot be superscript. This sets the superscript status to false.
See Also

Reference

FormattedText Class
SetSubscriptStatus Overload


FormattedText.SetSubscriptStatus(TextRange, Boolean) Method

FormattedTextSetSubscriptStatus(TextRange, Boolean) Method

Sets the characters in a given text range to be subscript or not subscript.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetSubscriptStatus(
    TextRange textRange,
    bool isSubscript
)
Public Sub SetSubscriptStatus (
    textRange As TextRange,
    isSubscript As Boolean
)
public:
void SetSubscriptStatus(
    TextRange^ textRange,
    bool isSubscript
)
member SetSubscriptStatus :
        textRange : TextRange *
        isSubscript : bool -> unit

Parameters

textRange TextRange
The given text range.
isSubscript Boolean
The desired subscript status of characters in the given text range. True to set subscript, false to set not subscript.
Exceptions
Exception | Condition
ArgumentException | This text range is empty. -or- This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text.
ArgumentNullException | A non-optional argument was null
Remarks

Superscript and subscript are mutually exclusive. Applying the subscript status will automatically remove the superscript status.

The given text range should not be empty.

See Also

Reference

FormattedText Class
SetSubscriptStatus Overload


FormattedText.SetSuperscriptStatus Method

FormattedTextSetSuperscriptStatus Method

Overload List
 | Name | Description
Public method | SetSuperscriptStatus(Boolean) | Sets the characters in the entire text to be superscript or not superscript.
Public method | SetSuperscriptStatus(TextRange, Boolean) | Sets the characters in a given text range to be superscript or not superscript.
Top
See Also

Reference

FormattedText Class


FormattedText.SetSuperscriptStatus(Boolean) Method

FormattedTextSetSuperscriptStatus(Boolean) Method

Sets the characters in the entire text to be superscript or not superscript.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetSuperscriptStatus(
    bool isSuperscript
)
Public Sub SetSuperscriptStatus (
    isSuperscript As Boolean
)
public:
void SetSuperscriptStatus(
    bool isSuperscript
)
member SetSuperscriptStatus :
        isSuperscript : bool -> unit

Parameters

isSuperscript Boolean
The desired superscript status of characters in the entire text. True to set superscript, false to set not superscript.
Remarks
If the characters are set to be superscript, they cannot be subscript. This sets the subscript status to false.
See Also

Reference

FormattedText Class
SetSuperscriptStatus Overload


FormattedText.SetSuperscriptStatus(TextRange, Boolean) Method

FormattedTextSetSuperscriptStatus(TextRange, Boolean) Method

Sets the characters in a given text range to be superscript or not superscript.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetSuperscriptStatus(
    TextRange textRange,
    bool isSuperscript
)
Public Sub SetSuperscriptStatus (
    textRange As TextRange,
    isSuperscript As Boolean
)
public:
void SetSuperscriptStatus(
    TextRange^ textRange,
    bool isSuperscript
)
member SetSuperscriptStatus :
        textRange : TextRange *
        isSuperscript : bool -> unit

Parameters

textRange TextRange
The given text range.
isSuperscript Boolean
The desired superscript status of characters in the given text range. True to set superscript, false to set not superscript.
Exceptions
Exception | Condition
ArgumentException | This text range is empty. -or- This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text.
ArgumentNullException | A non-optional argument was null
Remarks

Superscript and subscript are mutually exclusive. Applying the superscript status will automatically remove the subscript status.

The given text range should not be empty.

See Also

Reference

FormattedText Class
SetSuperscriptStatus Overload


FormattedText.SetUnderlineStatus Method

FormattedTextSetUnderlineStatus Method

Overload List
 | Name | Description
Public method | SetUnderlineStatus(Boolean) | Sets the characters in the entire text to be underlined or not underlined.
Public method | SetUnderlineStatus(TextRange, Boolean) | Sets the characters in a given text range to be underlined or not underlined.
Top
See Also

Reference

FormattedText Class


FormattedText.SetUnderlineStatus(Boolean) Method

FormattedTextSetUnderlineStatus(Boolean) Method

Sets the characters in the entire text to be underlined or not underlined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetUnderlineStatus(
    bool isUnderlined
)
Public Sub SetUnderlineStatus (
    isUnderlined As Boolean
)
public:
void SetUnderlineStatus(
    bool isUnderlined
)
member SetUnderlineStatus :
        isUnderlined : bool -> unit

Parameters

isUnderlined Boolean
The desired underline status of characters in the entire text. True to set underlined, false to set not underlined.
See Also

Reference

FormattedText Class
SetUnderlineStatus Overload


FormattedText.SetUnderlineStatus(TextRange, Boolean) Method

FormattedTextSetUnderlineStatus(TextRange, Boolean) Method

Sets the characters in a given text range to be underlined or not underlined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetUnderlineStatus(
    TextRange textRange,
    bool isUnderlined
)
Public Sub SetUnderlineStatus (
    textRange As TextRange,
    isUnderlined As Boolean
)
public:
void SetUnderlineStatus(
    TextRange^ textRange,
    bool isUnderlined
)
member SetUnderlineStatus :
        textRange : TextRange *
        isUnderlined : bool -> unit

Parameters

textRange TextRange
The given text range.
isUnderlined Boolean
The desired underline status of characters in the given text range. True to set underlined, false to set not underlined.
Exceptions
Exception | Condition
ArgumentException | This text range is empty. -or- This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text.
ArgumentNullException | A non-optional argument was null
Remarks

Bullets, numbers, or letters of a list can not be underlined.

The given text range should not be empty.

See Also

Reference

FormattedText Class
SetUnderlineStatus Overload


FormatValueOptions Class

Options for formatting numbers with units into strings.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFormatValueOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FormatValueOptions : IDisposable
Public Class FormatValueOptions
    Implements IDisposable
public ref class FormatValueOptions : IDisposable
type FormatValueOptions =
    class
        interface IDisposable
    end

The FormatValueOptions type exposes the following members.

Constructors
 | Name | Description
Public method | FormatValueOptions | Creates a new FormatValueOptions object with default settings.
Top
Properties
 | Name | Description
Public property | AppendUnitSymbol | Indicates if a unit symbol should be appended regardless of the settings in the FormatOptions.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the FormatValueOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetFormatOptions | Gets the FormatOptions to optionally override the default settings in the Units class.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetFormatOptions | Sets the FormatOptions to optionally override the default settings in the Units class.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FormatValueOptions Constructor

Creates a new FormatValueOptions object with default settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormatValueOptions()
Public Sub New
public:
FormatValueOptions()
new : unit -> FormatValueOptions
See Also

Reference

FormatValueOptions Class


FormatValueOptions Properties

The FormatValueOptions type exposes the following members.

Properties
 | Name | Description
Public property | AppendUnitSymbol | Indicates if a unit symbol should be appended regardless of the settings in the FormatOptions.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

FormatValueOptions Class


FormatValueOptions.AppendUnitSymbol Property

FormatValueOptionsAppendUnitSymbol Property

Indicates if a unit symbol should be appended regardless of the settings in the FormatOptions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AppendUnitSymbol { get; set; }
Public Property AppendUnitSymbol As Boolean
    Get
    Set
public:
property bool AppendUnitSymbol {
    bool get ();
    void set (bool value);
}
member AppendUnitSymbol : bool with get, set

Property Value

Boolean
True to force a unit symbol to be appended; false to use the settings specified by the FormatOptions. The default is false.
See Also

Reference

FormatValueOptions Class


FormatValueOptions.IsValidObject Property

FormatValueOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

FormatValueOptions Class


FormatValueOptions Methods

The FormatValueOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetFormatOptions | Gets the FormatOptions to optionally override the default settings in the Units class.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetFormatOptions | Sets the FormatOptions to optionally override the default settings in the Units class.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FormatValueOptions Class


FormatValueOptions.Dispose Method

FormatValueOptionsDispose Method

Releases all resources used by the FormatValueOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FormatValueOptions Class


FormatValueOptions.GetFormatOptions Method

FormatValueOptionsGetFormatOptions Method

Gets the FormatOptions to optionally override the default settings in the Units class.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormatOptions GetFormatOptions()
Public Function GetFormatOptions As FormatOptions
public:
FormatOptions^ GetFormatOptions()
member GetFormatOptions : unit -> FormatOptions

Return Value

FormatOptions
A copy of the FormatOptions.
Remarks
By default, the FormatOptions represents default formatting (UseDefault is true) and the FormatOptions in the Units class will be used.
See Also

Reference

FormatValueOptions Class


FormatValueOptions.SetFormatOptions Method

FormatValueOptionsSetFormatOptions Method

Sets the FormatOptions to optionally override the default settings in the Units class.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetFormatOptions(
    FormatOptions formatOptions
)
Public Sub SetFormatOptions (
    formatOptions As FormatOptions
)
public:
void SetFormatOptions(
    FormatOptions^ formatOptions
)
member SetFormatOptions :
        formatOptions : FormatOptions -> unit

Parameters

formatOptions FormatOptions
The FormatOptions.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
By default, the FormatOptions represents default formatting (UseDefault is true) and the FormatOptions in the Units class will be used.
See Also

Reference

FormatValueOptions Class


FormulaManager Class

A class to access and query information about formula engine in Revit models.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFormulaManager

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FormulaManager : IDisposable
Public Class FormulaManager
    Implements IDisposable
public ref class FormulaManager : IDisposable
type FormulaManager =
    class
        interface IDisposable
    end

The FormulaManager type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the FormulaManager
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | Evaluate | Evaluates value of the formula
 | GetFunctions | Gets list of function names supported by formula engine
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
 | GetOperators | Gets list of operator names supported by formula engine
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
 | Validate | Validates the formuls
Top
Remarks
Formula manager
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FormulaManager Properties

The FormulaManager type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

FormulaManager Class


FormulaManager.IsValidObject Property

FormulaManagerIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

FormulaManager Class


FormulaManager Methods

The FormulaManager type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | Evaluate | Evaluates value of the formula
 | GetFunctions | Gets list of function names supported by formula engine
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
 | GetOperators | Gets list of operator names supported by formula engine
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
 | Validate | Validates the formuls
Top
See Also

Reference

FormulaManager Class


FormulaManager.Dispose Method

FormulaManagerDispose Method

Releases all resources used by the FormulaManager

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FormulaManager Class


FormulaManager.Evaluate Method

FormulaManagerEvaluate Method

Evaluates value of the formula

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string Evaluate(
    ElementId parameterId,
    Document document,
    string formula
)
Public Shared Function Evaluate (
    parameterId As ElementId,
    document As Document,
    formula As String
) As String
public:
static String^ Evaluate(
    ElementId^ parameterId,
    Document^ document,
    String^ formula
)
static member Evaluate :
        parameterId : ElementId *
        document : Document *
        formula : string -> string

Parameters

parameterId ElementId
document Document
formula String

Return Value

String
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
It evaluates formula using list of global or family parameters depends on document type.
See Also

Reference

FormulaManager Class


FormulaManager.GetFunctions Method

FormulaManagerGetFunctions Method

Gets list of function names supported by formula engine

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<string> GetFunctions()
Public Shared Function GetFunctions As IList(Of String)
public:
static IList<String^>^ GetFunctions()
static member GetFunctions : unit -> IList<string>

Return Value

IList String
See Also

Reference

FormulaManager Class


FormulaManager.GetOperators Method

FormulaManagerGetOperators Method

Gets list of operator names supported by formula engine

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<string> GetOperators()
Public Shared Function GetOperators As IList(Of String)
public:
static IList<String^>^ GetOperators()
static member GetOperators : unit -> IList<string>

Return Value

IList String
See Also

Reference

FormulaManager Class


FormulaManager.Validate Method

FormulaManagerValidate Method

Validates the formuls

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string Validate(
    ElementId parameterId,
    Document document,
    string formula
)
Public Shared Function Validate (
    parameterId As ElementId,
    document As Document,
    formula As String
) As String
public:
static String^ Validate(
    ElementId^ parameterId,
    Document^ document,
    String^ formula
)
static member Validate :
        parameterId : ElementId *
        document : Document *
        formula : string -> string

Parameters

parameterId ElementId
document Document
formula String

Return Value

String
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
It validates formula using list of global or family parameters depends on document type.
See Also

Reference

FormulaManager Class


FormUtils Class

Define Form utility functions
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFormUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class FormUtils
Public NotInheritable Class FormUtils
public ref class FormUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type FormUtils = class end

The FormUtils type exposes the following members.

Methods
Name | Description
CanBeDissolved | Validates that input contains one or more form elements or geom combinations containing form elements.
DissolveForms(Document, ICollectionElementId) | Dissolves a collection of form elements into their defining elements.
DissolveForms(Document, ICollectionElementId, ICollectionElementId) | Dissolves a collection of form elements into their defining elements.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FormUtils Methods

The FormUtils type exposes the following members.

Methods
Name | Description
CanBeDissolved | Validates that input contains one or more form elements or geom combinations containing form elements.
DissolveForms(Document, ICollectionElementId) | Dissolves a collection of form elements into their defining elements.
DissolveForms(Document, ICollectionElementId, ICollectionElementId) | Dissolves a collection of form elements into their defining elements.
Top
See Also

Reference

FormUtils Class


FormUtils.CanBeDissolved Method

FormUtilsCanBeDissolved Method

Validates that input contains one or more form elements or geom combinations containing form elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CanBeDissolved(
    Document ADoc,
    ICollection<ElementId> elements
)
Public Shared Function CanBeDissolved (
    ADoc As Document,
    elements As ICollection(Of ElementId)
) As Boolean
public:
static bool CanBeDissolved(
    Document^ ADoc,
    ICollection<ElementId^>^ elements
)
static member CanBeDissolved :
        ADoc : Document *
        elements : ICollection<ElementId> -> bool

Parameters

ADoc Document
The document.
elements ICollection ElementId
A collection of elements.

Return Value

Boolean
True if inputs contain one or more form elements. Non-form element inputs are ignored. False if none of the inputs are form elements or do not contain form elements.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FormUtils Class


FormUtils.DissolveForms Method

FormUtilsDissolveForms Method

Overload List
Name | Description
DissolveForms(Document, ICollectionElementId) | Dissolves a collection of form elements into their defining elements.
DissolveForms(Document, ICollectionElementId, ICollectionElementId) | Dissolves a collection of form elements into their defining elements.
Top
See Also

Reference

FormUtils Class


FormUtils.DissolveForms(Document, ICollection<ElementId>) Method

FormUtilsDissolveForms(Document, ICollectionElementId) Method

Dissolves a collection of form elements into their defining elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ICollection<ElementId> DissolveForms(
    Document ADoc,
    ICollection<ElementId> elements
)
Public Shared Function DissolveForms (
    ADoc As Document,
    elements As ICollection(Of ElementId)
) As ICollection(Of ElementId)
public:
static ICollection<ElementId^>^ DissolveForms(
    Document^ ADoc,
    ICollection<ElementId^>^ elements
)
static member DissolveForms :
        ADoc : Document *
        elements : ICollection<ElementId> -> ICollection<ElementId>

Parameters

ADoc Document
The document
elements ICollection ElementId
A collection of element IDs of Forms and GeomCombinations that contain Forms that will be dissolved.

Return Value

ICollection ElementId
A collection of curve element ids from the profiles and paths of the dissolved forms.
Exceptions
Exception | Condition
ArgumentException | The elements do not include Forms that can be dissolved.
ArgumentNullException | A non-optional argument was null
See Also

Reference

FormUtils Class
DissolveForms Overload


FormUtils.DissolveForms(Document, ICollection<ElementId>, ICollection<ElementId>) Method

FormUtilsDissolveForms(Document, ICollectionElementId, ICollectionElementId) Method

Dissolves a collection of form elements into their defining elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ICollection<ElementId> DissolveForms(
    Document ADoc,
    ICollection<ElementId> elements,
    out ICollection<ElementId> ProfileOriginPointSet
)
Public Shared Function DissolveForms (
    ADoc As Document,
    elements As ICollection(Of ElementId),
    <OutAttribute> ByRef ProfileOriginPointSet As ICollection(Of ElementId)
) As ICollection(Of ElementId)
public:
static ICollection<ElementId^>^ DissolveForms(
    Document^ ADoc,
    ICollection<ElementId^>^ elements,
    [OutAttribute] ICollection<ElementId^>^% ProfileOriginPointSet
)
static member DissolveForms :
        ADoc : Document *
        elements : ICollection<ElementId> *
        ProfileOriginPointSet : ICollection<ElementId> byref -> ICollection<ElementId>

Parameters

ADoc Document
The document
elements ICollection ElementId
A collection of element IDs of Forms and GeomCombinations that contain Forms that will be dissolved.
ProfileOriginPointSet ICollection ElementId
A collection of the point element ids that represent the 'origin' of the profiles

Return Value

ICollection ElementId
A collection of curve element ids from the profiles and paths of the dissolved forms.
Exceptions
Exception | Condition
ArgumentException | The elements do not include Forms that can be dissolved.
ArgumentNullException | A non-optional argument was null
Remarks
Profile origin points define the workplane of form profiles and paths and their curves. The profile origin point represents a coordinate system with an origin (reference point) which can be manipulated to move the curves of a profile together as a unit after dissolve. Profile origin points may themselves be constrained to other parts of the model or parts of the form, based on how the form was created/constructed. This is done through the reference point hosting mechanism.
See Also

Reference

FormUtils Class
DissolveForms Overload


Frame Class

A Frame comprises three vectors at a base point in 3D space.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFrame

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Frame : IDisposable
Public Class Frame
    Implements IDisposable
public ref class Frame : IDisposable
type Frame =
    class
        interface IDisposable
    end

The Frame type exposes the following members.

Constructors
 | Name | Description
Public method | Frame | Default constructor. Uses global origin and standard basis vectors.
Public method | Frame(XYZ, XYZ, XYZ, XYZ) | Constructor that takes the frame's base point and three basis vectors.
Top
Properties
 | Name | Description
Public property | BasisX | The first basis vector of the frame.
Public property | BasisY | The second basis vector of the frame.
Public property | BasisZ | The third basis vector of the frame.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Origin | The frame's base point.
Top
Methods
 | Name | Description
 | CanDefineRevitGeometry | Tests whether the supplied Frame object may be used to define a Revit curve or surface. In order to satisfy the requirements the Frame must be orthonormal and its origin is expected to lie within the Revit design limits IsWithinLengthLimits(XYZ).
Public method | Dispose | Releases all resources used by the Frame
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsOrthogonal | Determines if this frame's basis vectors are orthogonal.
Public method | IsOrthonormal | Determines if this frame's basis vectors are orthonormal.
Public method | IsRightHanded | Determine if this frame's basis is right-handed.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | Transform | Applies the input transform to this frame.
Top
Remarks
A Frame consists of three vectors at a base point in 3D space. The vectors need not be orthogonal, have unit length, or even be linearly independent, although in practice Frames will usually have linearly independent vectors. Frames may be used to represent a coordinate frame of reference, a moving frame field on a curve, or for other purposes.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Frame Constructor

Overload List
 | Name | Description
Public method | Frame | Default constructor. Uses global origin and standard basis vectors.
Public method | Frame(XYZ, XYZ, XYZ, XYZ) | Constructor that takes the frame's base point and three basis vectors.
Top
See Also

Reference

Frame Class


Frame Constructor

Default constructor. Uses global origin and standard basis vectors.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Frame()
Public Sub New
public:
Frame()
new : unit -> Frame
See Also

Reference

Frame Class
Frame Overload


Frame(XYZ, XYZ, XYZ, XYZ) Constructor

Constructor that takes the frame's base point and three basis vectors.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Frame(
    XYZ origin,
    XYZ vec1,
    XYZ vec2,
    XYZ vec3
)
Public Sub New (
    origin As XYZ,
    vec1 As XYZ,
    vec2 As XYZ,
    vec3 As XYZ
)
public:
Frame(
    XYZ^ origin,
    XYZ^ vec1,
    XYZ^ vec2,
    XYZ^ vec3
)
new :
        origin : XYZ *
        vec1 : XYZ *
        vec2 : XYZ *
        vec3 : XYZ -> Frame

Parameters

origin XYZ
The frame's base point.
vec1 XYZ
The frame's first basis vector.
vec2 XYZ
The frame's second basis vector.
vec3 XYZ
The frame's third basis vector.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

Frame Class
Frame Overload


Frame Properties

The Frame type exposes the following members.

Properties
 | Name | Description
Public property | BasisX | The first basis vector of the frame.
Public property | BasisY | The second basis vector of the frame.
Public property | BasisZ | The third basis vector of the frame.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Origin | The frame's base point.
Top
See Also

Reference

Frame Class


Frame.BasisX Property

FrameBasisX Property

The first basis vector of the frame.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ BasisX { get; set; }
Public Property BasisX As XYZ
    Get
    Set
public:
property XYZ^ BasisX {
    XYZ^ get ();
    void set (XYZ^ value);
}
member BasisX : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

Frame Class


Frame.BasisY Property

FrameBasisY Property

The second basis vector of the frame.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ BasisY { get; set; }
Public Property BasisY As XYZ
    Get
    Set
public:
property XYZ^ BasisY {
    XYZ^ get ();
    void set (XYZ^ value);
}
member BasisY : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

Frame Class


Frame.BasisZ Property

FrameBasisZ Property

The third basis vector of the frame.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ BasisZ { get; set; }
Public Property BasisZ As XYZ
    Get
    Set
public:
property XYZ^ BasisZ {
    XYZ^ get ();
    void set (XYZ^ value);
}
member BasisZ : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

Frame Class


Frame.IsValidObject Property

FrameIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

Frame Class


Frame.Origin Property

FrameOrigin Property

The frame's base point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Origin { get; set; }
Public Property Origin As XYZ
    Get
    Set
public:
property XYZ^ Origin {
    XYZ^ get ();
    void set (XYZ^ value);
}
member Origin : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

Frame Class


Frame Methods

The Frame type exposes the following members.

Methods
 | Name | Description
 | CanDefineRevitGeometry | Tests whether the supplied Frame object may be used to define a Revit curve or surface. In order to satisfy the requirements the Frame must be orthonormal and its origin is expected to lie within the Revit design limits IsWithinLengthLimits(XYZ).
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsOrthogonal | Determines if this frame's basis vectors are orthogonal.
Public method | IsOrthonormal | Determines if this frame's basis vectors are orthonormal.
Public method | IsRightHanded | Determine if this frame's basis is right-handed.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | Transform | Applies the input transform to this frame.
Top
See Also

Reference

Frame Class


Frame.CanDefineRevitGeometry Method

FrameCanDefineRevitGeometry Method

Tests whether the supplied Frame object may be used to define a Revit curve or surface. In order to satisfy the requirements the Frame must be orthonormal and its origin is expected to lie within the Revit design limits IsWithinLengthLimits(XYZ).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CanDefineRevitGeometry(
    Frame frameOfReference
)
Public Shared Function CanDefineRevitGeometry (
    frameOfReference As Frame
) As Boolean
public:
static bool CanDefineRevitGeometry(
    Frame^ frameOfReference
)
static member CanDefineRevitGeometry :
        frameOfReference : Frame -> bool

Parameters

frameOfReference Frame
Frame to be validated.

Return Value

Boolean
True if this Frame may be used as a local frame of reference, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Certain Revit curve and surface types are defined using a local frame of reference.
See Also

Reference

Frame Class


Frame.Dispose Method

FrameDispose Method

Releases all resources used by the Frame

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

Frame Class


Frame.IsOrthogonal Method

FrameIsOrthogonal Method

Determines if this frame's basis vectors are orthogonal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsOrthogonal()
Public Function IsOrthogonal As Boolean
public:
bool IsOrthogonal()
member IsOrthogonal : unit -> bool

Return Value

Boolean
True if this frame's basis vectors are orthogonal, false if not.
See Also

Reference

Frame Class


Frame.IsOrthonormal Method

FrameIsOrthonormal Method

Determines if this frame's basis vectors are orthonormal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsOrthonormal()
Public Function IsOrthonormal As Boolean
public:
bool IsOrthonormal()
member IsOrthonormal : unit -> bool

Return Value

Boolean
True if this frame's basis vectors are orthonormal, false if not.
Remarks
"Orthonormal" means that the three vectors are orthogonal and each of them has unit length.
See Also

Reference

Frame Class


Frame.IsRightHanded Method

FrameIsRightHanded Method

Determine if this frame's basis is right-handed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsRightHanded()
Public Function IsRightHanded As Boolean
public:
bool IsRightHanded()
member IsRightHanded : unit -> bool

Return Value

Boolean
True if this frame's basis is right-handed, false if not.
Remarks
The three basis vectors are "right-handed" if the triple vector product [vecX, vecY, vecZ] is positive, or equivalently if dot(vecX x vecY, vecZ) is positive, where "dot" represents the dot product.
See Also

Reference

Frame Class


Frame.Transform Method

FrameTransform Method

Applies the input transform to this frame.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Transform(
    Transform trf
)
Public Sub Transform (
    trf As Transform
)
public:
void Transform(
    Transform^ trf
)
member Transform :
        trf : Transform -> unit

Parameters

trf Transform
The transform to apply to the frame.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | this operation failed.
See Also

Reference

Frame Class


FramingShapeClassification Enumeration

This enumeration is used to classify MEP Ancillary Framing shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum FramingShapeClassification
Public Enumeration FramingShapeClassification
public enum class FramingShapeClassification
type FramingShapeClassification
Members
Member name | Value | Description
Linear | 0 |
Circular | 1 |
Oval | 2 |
Other | 3 |
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FreeFormElement Class

A Free Form Element that contains non-parametric geometry created from an input solid outline.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBCombinableElement
Autodesk.Revit.DBGenericForm
Autodesk.Revit.DBFreeFormElement

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FreeFormElement : GenericForm
Public Class FreeFormElement
    Inherits GenericForm
public ref class FreeFormElement : public GenericForm
type FreeFormElement =
    class
        inherit GenericForm
    end

The FreeFormElement type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Get and Set the Name property (Inherited from GenericForm)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Subcategory | The subcategory. (Inherited from GenericForm)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | CanOffsetFace | Determines if the input face of the FreeFormElement can be offset.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new FreeFormElement from a copy of the input geometry.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetFaceOffset | Offsets a planar face of the free form element a certain distance in the normal direction.
Public method | SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UpdateSolidGeometry | Updates the geometry of the FreeForm element to the given shape preserving References to the existing geometry where possible (see remarks for rules).
Top
Remarks
The element can participate in joins and void cuts with other combinable elements.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


FreeFormElement Properties

The FreeFormElement type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Get and Set the Name property (Inherited from GenericForm)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Subcategory | The subcategory. (Inherited from GenericForm)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

FreeFormElement Class


FreeFormElement Methods

The FreeFormElement type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | CanOffsetFace | Determines if the input face of the FreeFormElement can be offset.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new FreeFormElement from a copy of the input geometry.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetFaceOffset | Offsets a planar face of the free form element a certain distance in the normal direction.
Public method | SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UpdateSolidGeometry | Updates the geometry of the FreeForm element to the given shape preserving References to the existing geometry where possible (see remarks for rules).
Top
See Also

Reference

FreeFormElement Class


FreeFormElement.CanOffsetFace Method

FreeFormElementCanOffsetFace Method

Determines if the input face of the FreeFormElement can be offset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanOffsetFace(
    Face face
)
Public Function CanOffsetFace (
    face As Face
) As Boolean
public:
bool CanOffsetFace(
    Face^ face
)
member CanOffsetFace :
        face : Face -> bool

Parameters

face Face
The face to be checked.

Return Value

Boolean
True if the face can be offset, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FreeFormElement Class


FreeFormElement.Create Method

FreeFormElementCreate Method

Creates a new FreeFormElement from a copy of the input geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FreeFormElement Create(
    Document document,
    Solid geometry
)
Public Shared Function Create (
    document As Document,
    geometry As Solid
) As FreeFormElement
public:
static FreeFormElement^ Create(
    Document^ document,
    Solid^ geometry
)
static member Create :
        document : Document *
        geometry : Solid -> FreeFormElement

Parameters

document Document
The document in which the element is to be created.
geometry Solid
The input geometry.

Return Value

FreeFormElement
returns a new FreeFormElement
Exceptions
Exception | Condition
ArgumentException | document is not a family document, nor a document editing an in-place family.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
See Also

Reference

FreeFormElement Class


FreeFormElement.SetFaceOffset Method

FreeFormElementSetFaceOffset Method

Offsets a planar face of the free form element a certain distance in the normal direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetFaceOffset(
    Face face,
    double offset
)
Public Sub SetFaceOffset (
    face As Face,
    offset As Double
)
public:
void SetFaceOffset(
    Face^ face,
    double offset
)
member SetFaceOffset :
        face : Face *
        offset : float -> unit

Parameters

face Face
The face to offset.
offset Double
The magnitude of the offset. A positive value offsets out of the input solid. A negative value offsets into the solid shape.
Exceptions
Exception | Condition
ArgumentException | face does not belong to the solid. -or- The face to be offset should be planar and satisfy constraints of its parent element.
ArgumentNullException | A non-optional argument was null
See Also

Reference

FreeFormElement Class


FreeFormElement.UpdateSolidGeometry Method

FreeFormElementUpdateSolidGeometry Method

Updates the geometry of the FreeForm element to the given shape preserving References to the existing geometry where possible (see remarks for rules).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void UpdateSolidGeometry(
    Solid newGeometry
)
Public Sub UpdateSolidGeometry (
    newGeometry As Solid
)
public:
void UpdateSolidGeometry(
    Solid^ newGeometry
)
member UpdateSolidGeometry :
        newGeometry : Solid -> unit

Parameters

newGeometry Solid
The new geometry to set in the FreeForm element.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Rules for preserving References:
  • First preserve faces as Reference when exclusively coincident with existing faces.
  • Then preserve faces as Reference if exclusively parallel to existing faces.
  • Then preserve faces as Reference if exclusive at small angle to the existing faces.
  • Any other faces are will not be preserved as a Reference.
Edges are preserved as References if and only if exclusively bound to faces that are also preserved as References.
See Also

Reference

FreeFormElement Class


GBXMLExportOptions Class

Green-Building XML Export options.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBGBXMLExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GBXMLExportOptions : IDisposable
Public Class GBXMLExportOptions
    Implements IDisposable
public ref class GBXMLExportOptions : IDisposable
type GBXMLExportOptions =
    class
        interface IDisposable
    end

The GBXMLExportOptions type exposes the following members.

Constructors
 | Name | Description
Public method | GBXMLExportOptions | Constructs a new instance of the options used to export a model in gbXML (green-building) format.
Public method | GBXMLExportOptions(IListElementId, IListElementId) | Constructs a new instance of the options used to export a mass model to gbXML.
Top
Properties
 | Name | Description
Public property | Encoding | The encoding options to go into the processing instruction for the exported gbXML file.
Public property | ExportAnalyticalSystems | Indicates if the gbXML should contain analytical system elements (e.g., Water Loop, Air System, and Zone Equipment).
Public property | ExportEnergyModelType | The energy model type from which gbXML will be exported.
Public property | IsConceptual | Indicates if the exported gbXML is based on a conceptual energy analytical model from a conceptual mass model.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the GBXMLExportOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMassIds | Gets a list of masses to use as shading surfaces in the exported gbXML--these masses must not have mass floors or mass zones so as not to end up with duplicate surface information in the gbXML output.
Public method | GetMassZoneIds | Gets a list of mass zones to analyze in the exported gbXML.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


GBXMLExportOptions Constructor

Overload List
 | Name | Description
Public method | GBXMLExportOptions | Constructs a new instance of the options used to export a model in gbXML (green-building) format.
Public method | GBXMLExportOptions(IListElementId, IListElementId) | Constructs a new instance of the options used to export a mass model to gbXML.
Top
See Also

Reference

GBXMLExportOptions Class


GBXMLExportOptions Constructor

Constructs a new instance of the options used to export a model in gbXML (green-building) format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GBXMLExportOptions()
Public Sub New
public:
GBXMLExportOptions()
new : unit -> GBXMLExportOptions
See Also

Reference

GBXMLExportOptions Class
GBXMLExportOptions Overload


GBXMLExportOptions(IList<ElementId>, IList<ElementId>) Constructor

GBXMLExportOptions(IListElementId, IListElementId) Constructor

Constructs a new instance of the options used to export a mass model to gbXML.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GBXMLExportOptions(
    IList<ElementId> massZoneIds,
    IList<ElementId> massIds
)
Public Sub New (
    massZoneIds As IList(Of ElementId),
    massIds As IList(Of ElementId)
)
public:
GBXMLExportOptions(
    IList<ElementId^>^ massZoneIds,
    IList<ElementId^>^ massIds
)
new :
        massZoneIds : IList<ElementId> *
        massIds : IList<ElementId> -> GBXMLExportOptions

Parameters

massZoneIds IList ElementId
Indicates the mass zones to analyze in the exported gbXML.
massIds IList ElementId
Indicates the masses to use as shading surfaces in the exported gbXML--these masses must not have mass floors or mass zones so as not to end up with duplicate surface information in the gbXML output.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

GBXMLExportOptions Class
GBXMLExportOptions Overload


GBXMLExportOptions Properties

The GBXMLExportOptions type exposes the following members.

Properties
 | Name | Description
Public property | Encoding | The encoding options to go into the processing instruction for the exported gbXML file.
Public property | ExportAnalyticalSystems | Indicates if the gbXML should contain analytical system elements (e.g., Water Loop, Air System, and Zone Equipment).
Public property | ExportEnergyModelType | The energy model type from which gbXML will be exported.
Public property | IsConceptual | Indicates if the exported gbXML is based on a conceptual energy analytical model from a conceptual mass model.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

GBXMLExportOptions Class


GBXMLExportOptions.Encoding Property

GBXMLExportOptionsEncoding Property

The encoding options to go into the processing instruction for the exported gbXML file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Encoding { get; }
Public ReadOnly Property Encoding As String
    Get
public:
property String^ Encoding {
    String^ get ();
}
member Encoding : string with get

Property Value

String
See Also

Reference

GBXMLExportOptions Class


GBXMLExportOptions.ExportAnalyticalSystems Property

GBXMLExportOptionsExportAnalyticalSystems Property

Indicates if the gbXML should contain analytical system elements (e.g., Water Loop, Air System, and Zone Equipment).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ExportAnalyticalSystems { get; set; }
Public Property ExportAnalyticalSystems As Boolean
    Get
    Set
public:
property bool ExportAnalyticalSystems {
    bool get ();
    void set (bool value);
}
member ExportAnalyticalSystems : bool with get, set

Property Value

Boolean
See Also

Reference

GBXMLExportOptions Class


GBXMLExportOptions.ExportEnergyModelType Property

GBXMLExportOptionsExportEnergyModelType Property

The energy model type from which gbXML will be exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportEnergyModelType ExportEnergyModelType { get; set; }
Public Property ExportEnergyModelType As ExportEnergyModelType
    Get
    Set
public:
property ExportEnergyModelType ExportEnergyModelType {
    ExportEnergyModelType get ();
    void set (ExportEnergyModelType value);
}
member ExportEnergyModelType : ExportEnergyModelType with get, set

Property Value

ExportEnergyModelType
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
Default value is SpatialElement.
See Also

Reference

GBXMLExportOptions Class


GBXMLExportOptions.IsConceptual Property

GBXMLExportOptionsIsConceptual Property

Indicates if the exported gbXML is based on a conceptual energy analytical model from a conceptual mass model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsConceptual { get; }
Public ReadOnly Property IsConceptual As Boolean
    Get
public:
property bool IsConceptual {
    bool get ();
}
member IsConceptual : bool with get

Property Value

Boolean
See Also

Reference

GBXMLExportOptions Class


GBXMLExportOptions.IsValidObject Property

GBXMLExportOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

GBXMLExportOptions Class


GBXMLExportOptions Methods

The GBXMLExportOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMassIds | Gets a list of masses to use as shading surfaces in the exported gbXML--these masses must not have mass floors or mass zones so as not to end up with duplicate surface information in the gbXML output.
Public method | GetMassZoneIds | Gets a list of mass zones to analyze in the exported gbXML.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

GBXMLExportOptions Class


GBXMLExportOptions.Dispose Method

GBXMLExportOptionsDispose Method

Releases all resources used by the GBXMLExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

GBXMLExportOptions Class


GBXMLExportOptions.GetMassIds Method

GBXMLExportOptionsGetMassIds Method

Gets a list of masses to use as shading surfaces in the exported gbXML--these masses must not have mass floors or mass zones so as not to end up with duplicate surface information in the gbXML output.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ElementId> GetMassIds()
Public Function GetMassIds As IList(Of ElementId)
public:
IList<ElementId^>^ GetMassIds()
member GetMassIds : unit -> IList<ElementId>

Return Value

IList ElementId
The ids of the masses.
See Also

Reference

GBXMLExportOptions Class


GBXMLExportOptions.GetMassZoneIds Method

GBXMLExportOptionsGetMassZoneIds Method

Gets a list of mass zones to analyze in the exported gbXML.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ElementId> GetMassZoneIds()
Public Function GetMassZoneIds As IList(Of ElementId)
public:
IList<ElementId^>^ GetMassZoneIds()
member GetMassZoneIds : unit -> IList<ElementId>

Return Value

IList ElementId
The ids of the mass zones.
See Also

Reference

GBXMLExportOptions Class


GBXMLImportOptions Class

Import options for Green-Building XML format.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBGBXMLImportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GBXMLImportOptions
Public Class GBXMLImportOptions
public ref class GBXMLImportOptions
type GBXMLImportOptions = class end

The GBXMLImportOptions type exposes the following members.

Constructors
 | Name | Description
Public method | GBXMLImportOptions | Default constructor. Sets all options to their default values.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Not used currently. Reserved for future use.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


GBXMLImportOptions Constructor

Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GBXMLImportOptions()
Public Sub New
public:
GBXMLImportOptions()
new : unit -> GBXMLImportOptions
See Also

Reference

GBXMLImportOptions Class


GBXMLImportOptions Methods

The GBXMLImportOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

GBXMLImportOptions Class


GenericForm Class

Provides access to the Generic Form model in Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBCombinableElement
Autodesk.Revit.DBGenericForm
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GenericForm : CombinableElement
Public Class GenericForm
    Inherits CombinableElement
public ref class GenericForm : public CombinableElement
type GenericForm =
    class
        inherit CombinableElement
    end

The GenericForm type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Get and Set the Name property (Overrides ElementName)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Subcategory | The subcategory.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | Visible | The visibility of the GenericForm.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetVisibility | Gets the visibility for the generic form.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetVisibility | Sets the visibility for the generic form.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The Generic Form object can be queried for a generic form for use in family modeling and massing. It is the base class of Sweep, Blend, Extrusion, Revolution.
See Also

Reference

Autodesk.Revit.DB Namespace
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBCombinableElement
Autodesk.Revit.DBGenericForm
Autodesk.Revit.DBBlend
Autodesk.Revit.DBExtrusion
Autodesk.Revit.DBForm
Autodesk.Revit.DBFreeFormElement
Autodesk.Revit.DBRevolution
Autodesk.Revit.DBSweep
Autodesk.Revit.DBSweptBlend


GenericForm Properties

The GenericForm type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Get and Set the Name property (Overrides ElementName)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Subcategory | The subcategory.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | Visible | The visibility of the GenericForm.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

GenericForm Class


GenericForm.IsSolid Property

GenericFormIsSolid Property

Identifies if the GenericForm is a solid or a void element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSolid { get; }
Public ReadOnly Property IsSolid As Boolean
    Get
public:
property bool IsSolid {
    bool get ();
}
member IsSolid : bool with get

Property Value

Boolean
True if the form is a solid, false if the solid is a void element.
See Also

Reference

GenericForm Class


GenericForm.Name Property

GenericFormName Property

Get and Set the Name property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string Name { set; }
Public Overrides WriteOnly Property Name As String
    Set
public:
virtual property String^ Name {
    void set (String^ value) override;
}
abstract Name : string with set
override Name : string with set

Property Value

String
Remarks
The method set is override to forbid the user to change the Name. When the user tries to call the method set for GenericForm object, an InvalidOperationException will be thrown.
See Also

Reference

GenericForm Class


GenericForm.Subcategory Property

GenericFormSubcategory Property

The subcategory.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Category Subcategory { get; set; }
Public Property Subcategory As Category
    Get
    Set
public:
property Category^ Subcategory {
    Category^ get ();
    void set (Category^ value);
}
member Subcategory : Category with get, set

Property Value

Category
Remarks
The subcategory can be set to either the family category or one of its subcategories.
See Also

Reference

GenericForm Class


GenericForm.Visible Property

GenericFormVisible Property

The visibility of the GenericForm.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Visible { get; }
Public ReadOnly Property Visible As Boolean
    Get
public:
property bool Visible {
    bool get ();
}
member Visible : bool with get

Property Value

Boolean
True if the form is visible, false if it is hidden.
See Also

Reference

GenericForm Class


GenericForm Methods

The GenericForm type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetVisibility | Gets the visibility for the generic form.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetVisibility | Sets the visibility for the generic form.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

GenericForm Class


GenericForm.GetVisibility Method

GenericFormGetVisibility Method

Gets the visibility for the generic form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyElementVisibility GetVisibility()
Public Function GetVisibility As FamilyElementVisibility
public:
FamilyElementVisibility^ GetVisibility()
member GetVisibility : unit -> FamilyElementVisibility

Return Value

FamilyElementVisibility
A copy of visibility settings for the generic form.
See Also

Reference

GenericForm Class


GenericForm.SetVisibility Method

GenericFormSetVisibility Method

Sets the visibility for the generic form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetVisibility(
    FamilyElementVisibility visibility
)
Public Sub SetVisibility (
    visibility As FamilyElementVisibility
)
public:
void SetVisibility(
    FamilyElementVisibility^ visibility
)
member SetVisibility :
        visibility : FamilyElementVisibility -> unit

Parameters

visibility FamilyElementVisibility
Exceptions
Exception | Condition
ArgumentNullException | Thrown when visibility is .
InvalidOperationException | Thrown when regeneration failed.
Remarks
The visibility of the generic form geometry can be changed for different types of views and detail levels in the project.
See Also

Reference

GenericForm Class


GenericImportOptions Class

Generic Import options.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBGenericImportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class GenericImportOptions
Public MustInherit Class GenericImportOptions
public ref class GenericImportOptions abstract
[<AbstractClassAttribute>]
type GenericImportOptions = class end

The GenericImportOptions type exposes the following members.

Properties
 | Name | Description
Public property | RefPoint | Reference point (in Revit) to which the image is going to be inserted.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


GenericImportOptions Properties

The GenericImportOptions type exposes the following members.

Properties
 | Name | Description
Public property | RefPoint | Reference point (in Revit) to which the image is going to be inserted.
Top
See Also

Reference

GenericImportOptions Class


GenericImportOptions.RefPoint Property

GenericImportOptionsRefPoint Property

Reference point (in Revit) to which the image is going to be inserted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ RefPoint { get; set; }
Public Property RefPoint As XYZ
    Get
    Set
public:
property XYZ^ RefPoint {
    XYZ^ get ();
    void set (XYZ^ value);
}
member RefPoint : XYZ with get, set

Property Value

XYZ
Remarks
If , the image will be inserted to the Revit's origin.
See Also

Reference

GenericImportOptions Class


GenericImportOptions Methods

The GenericImportOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

GenericImportOptions Class


GeomCombination Class

An element created by Join and Cut operations applied to combinable elements in an Autodesk Revit family document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBCombinableElement
Autodesk.Revit.DBGeomCombination

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GeomCombination : CombinableElement
Public Class GeomCombination
    Inherits CombinableElement
public ref class GeomCombination : public CombinableElement
type GeomCombination =
    class
        inherit CombinableElement
    end

The GeomCombination type exposes the following members.

Properties
 | Name | Description
Public property | AllMembers | All elements that are joined in this geometry combination.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


GeomCombination Properties

The GeomCombination type exposes the following members.

Properties
 | Name | Description
Public property | AllMembers | All elements that are joined in this geometry combination.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

GeomCombination Class


GeomCombination.AllMembers Property

GeomCombinationAllMembers Property

All elements that are joined in this geometry combination.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CombinableElementArray AllMembers { get; }
Public ReadOnly Property AllMembers As CombinableElementArray
    Get
public:
property CombinableElementArray^ AllMembers {
    CombinableElementArray^ get ();
}
member AllMembers : CombinableElementArray with get

Property Value

CombinableElementArray
Exceptions
Exception | Condition
InvalidOperationException | Thrown when this geometry combination has already been deleted.
Remarks
All members are generic forms, for more information, refer toGenericForm.
See Also

Reference

GeomCombination Class


GeomCombination Methods

The GeomCombination type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

GeomCombination Class


GeomCombinationSet Class

A set that contains GeomCombination objects.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGeomCombinationSet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GeomCombinationSet : APIObject,
    IEnumerable
Public Class GeomCombinationSet
    Inherits APIObject
    Implements IEnumerable
public ref class GeomCombinationSet : public APIObject,
    IEnumerable
type GeomCombinationSet =
    class
        inherit APIObject
        interface IEnumerable
    end

The GeomCombinationSet type exposes the following members.

Constructors
 | Name | Description
Public method | GeomCombinationSet | Initializes a new instance of the GeomCombinationSet class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Size | Returns the number of GeomCombinations that are in the set.
Top
Methods
 | Name | Description
Public method | Clear | Removes every item GeomCombination the set, rendering it empty.
Public method | Contains | Tests for the existence of an GeomCombination within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase | Removes a specified GeomCombination from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified element into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


GeomCombinationSet Constructor

Initializes a new instance of the GeomCombinationSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GeomCombinationSet()
Public Sub New
public:
GeomCombinationSet()
new : unit -> GeomCombinationSet
See Also

Reference

GeomCombinationSet Class


GeomCombinationSet Properties

The GeomCombinationSet type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Size | Returns the number of GeomCombinations that are in the set.
Top
See Also

Reference

GeomCombinationSet Class


GeomCombinationSet.IsEmpty Property

GeomCombinationSetIsEmpty Property

Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Boolean
Remarks
If the set is empty then True will be returned, otherwise False.
See Also

Reference

GeomCombinationSet Class


GeomCombinationSet.Size Property

GeomCombinationSetSize Property

Returns the number of GeomCombinations that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
abstract Size : int with get
override Size : int with get

Property Value

Int32
See Also

Reference

GeomCombinationSet Class


GeomCombinationSet Methods

The GeomCombinationSet type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Removes every item GeomCombination the set, rendering it empty.
Public method | Contains | Tests for the existence of an GeomCombination within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase | Removes a specified GeomCombination from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified element into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

GeomCombinationSet Class


GeomCombinationSet.Clear Method

GeomCombinationSetClear Method

Removes every item GeomCombination the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

GeomCombinationSet Class


GeomCombinationSet.Contains Method

GeomCombinationSetContains Method

Tests for the existence of an GeomCombination within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Contains(
    GeomCombination item
)
Public Overridable Function Contains (
    item As GeomCombination
) As Boolean
public:
virtual bool Contains(
    GeomCombination^ item
)
abstract Contains :
        item : GeomCombination -> bool
override Contains :
        item : GeomCombination -> bool

Parameters

item GeomCombination
The element to be searched for.

Return Value

Boolean
The Contains method returns True if the GeomCombination is within the set, otherwise False.
See Also

Reference

GeomCombinationSet Class


GeomCombinationSet.Erase Method

GeomCombinationSetErase Method

Removes a specified GeomCombination from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Erase(
    GeomCombination item
)
Public Overridable Function Erase (
    item As GeomCombination
) As Integer
public:
virtual int Erase(
    GeomCombination^ item
)
abstract Erase :
        item : GeomCombination -> int
override Erase :
        item : GeomCombination -> int

Parameters

item GeomCombination
The GeomCombination to be erased.

Return Value

Int32
The number of GeomCombinations that were erased from the set.
See Also

Reference

GeomCombinationSet Class


GeomCombinationSet.ForwardIterator Method

GeomCombinationSetForwardIterator Method

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual GeomCombinationSetIterator ForwardIterator()
Public Overridable Function ForwardIterator As GeomCombinationSetIterator
public:
virtual GeomCombinationSetIterator^ ForwardIterator()
abstract ForwardIterator : unit -> GeomCombinationSetIterator
override ForwardIterator : unit -> GeomCombinationSetIterator

Return Value

GeomCombinationSetIterator
Returns a forward moving iterator to the set.
See Also

Reference

GeomCombinationSet Class


GeomCombinationSet.GetEnumerator Method

GeomCombinationSetGetEnumerator Method

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

IEnumerator
Returns a forward moving iterator to the set.

Implements

IEnumerableGetEnumerator
See Also

Reference

GeomCombinationSet Class


GeomCombinationSet.Insert Method

GeomCombinationSetInsert Method

Insert the specified element into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Insert(
    GeomCombination item
)
Public Overridable Function Insert (
    item As GeomCombination
) As Boolean
public:
virtual bool Insert(
    GeomCombination^ item
)
abstract Insert :
        item : GeomCombination -> bool
override Insert :
        item : GeomCombination -> bool

Parameters

item GeomCombination
The GeomCombination to be inserted into the set.

Return Value

Boolean
Returns whether the GeomCombination was inserted into the set.
See Also

Reference

GeomCombinationSet Class


GeomCombinationSet.ReverseIterator Method

GeomCombinationSetReverseIterator Method

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual GeomCombinationSetIterator ReverseIterator()
Public Overridable Function ReverseIterator As GeomCombinationSetIterator
public:
virtual GeomCombinationSetIterator^ ReverseIterator()
abstract ReverseIterator : unit -> GeomCombinationSetIterator
override ReverseIterator : unit -> GeomCombinationSetIterator

Return Value

GeomCombinationSetIterator
Returns a backward moving iterator to the set.
See Also

Reference

GeomCombinationSet Class


GeomCombinationSetIterator Class

An iterator to a GeomCombination set.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGeomCombinationSetIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class GeomCombinationSetIterator : APIObject,
    IEnumerator
Public MustInherit Class GeomCombinationSetIterator
    Inherits APIObject
    Implements IEnumerator
public ref class GeomCombinationSetIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type GeomCombinationSetIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The GeomCombinationSetIterator type exposes the following members.

Constructors
 | Name | Description
Public method | GeomCombinationSetIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


GeomCombinationSetIterator Constructor

For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GeomCombinationSetIterator()
Public Sub New
public:
GeomCombinationSetIterator()
new : unit -> GeomCombinationSetIterator
Remarks
This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.
See Also

Reference

GeomCombinationSetIterator Class


GeomCombinationSetIterator Properties

The GeomCombinationSetIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

GeomCombinationSetIterator Class


GeomCombinationSetIterator.Current Property

GeomCombinationSetIteratorCurrent Property

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}
abstract Current : Object with get
override Current : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.
See Also

Reference

GeomCombinationSetIterator Class


GeomCombinationSetIterator Methods

The GeomCombinationSetIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

GeomCombinationSetIterator Class


GeomCombinationSetIterator.MoveNext Method

GeomCombinationSetIteratorMoveNext Method

Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumeratorMoveNext
Remarks
MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.
See Also

Reference

GeomCombinationSetIterator Class


GeomCombinationSetIterator.Reset Method

GeomCombinationSetIteratorReset Method

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
Remarks
The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.
See Also

Reference

GeomCombinationSetIterator Class


GeometryCreationUtilities Class

A utility that allows construction of basic solid shapes.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBGeometryCreationUtilities

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class GeometryCreationUtilities
Public NotInheritable Class GeometryCreationUtilities
public ref class GeometryCreationUtilities abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type GeometryCreationUtilities = class end

The GeometryCreationUtilities type exposes the following members.

Methods
Name | Description
CreateBlendGeometry(CurveLoop, CurveLoop, ICollectionVertexPair) | Creates a solid by blending two closed curve loops lying in non-coincident planes.
CreateBlendGeometry(CurveLoop, CurveLoop, ICollectionVertexPair, SolidOptions) | Creates a solid by blending two closed curve loops lying in non-coincident planes.
CreateExtrusionGeometry(IListCurveLoop, XYZ, Double) | Creates a solid by linearly extruding one or more closed coplanar curve loops.
CreateExtrusionGeometry(IListCurveLoop, XYZ, Double, SolidOptions) | Creates a solid by linearly extruding one or more closed coplanar curve loops.
CreateFixedReferenceSweptGeometry(CurveLoop, Int32, Double, IListCurveLoop, XYZ) | Creates a solid by sweeping one or more closed coplanar curve loops along a path while keeping the profile plane oriented so that a line in the plane that is initially perpendicular to a given fixed direction remains perpendicular as the profile is swept along the path.
CreateFixedReferenceSweptGeometry(CurveLoop, Int32, Double, IListCurveLoop, XYZ, SolidOptions) | Creates a solid by sweeping one or more closed coplanar curve loops along a path while keeping the profile plane oriented so that a line in the plane that is initially perpendicular to a given fixed direction remains perpendicular as the profile is swept along the path.
CreateLoftGeometry | Creates a solid or open shell geometry by lofting between a sequence of curve loops.
CreateRevolvedGeometry(Frame, IListCurveLoop, Double, Double) | Creates a solid of revolution by revolving a set of closed curve loops around an axis by a specified angle.
CreateRevolvedGeometry(Frame, IListCurveLoop, Double, Double, SolidOptions) | Creates a solid of revolution by revolving a set of closed curve loops around an axis by a specified angle.
CreateSweptBlendGeometry(Curve, IListDouble, IListCurveLoop, IListICollectionVertexPair) | Creates a solid by simultaneously sweeping and blending two or more closed planar curve loops along a single curve.
CreateSweptBlendGeometry(Curve, IListDouble, IListCurveLoop, IListICollectionVertexPair, SolidOptions) | Creates a solid by simultaneously sweeping and blending two or more closed planar curve loops along a single curve.
CreateSweptGeometry(CurveLoop, Int32, Double, IListCurveLoop) | Creates a solid by sweeping one or more closed coplanar curve loops along a path.
CreateSweptGeometry(CurveLoop, Int32, Double, IListCurveLoop, SolidOptions) | Creates a solid by sweeping one or more closed coplanar curve loops along a path.
Top
Remarks
The shapes created by these utilities are not a part of any Revit document, but can be used in conjunction with other geometric utilities from within API applications.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


GeometryCreationUtilities Methods

The GeometryCreationUtilities type exposes the following members.

Methods
Name | Description
CreateBlendGeometry(CurveLoop, CurveLoop, ICollectionVertexPair) | Creates a solid by blending two closed curve loops lying in non-coincident planes.
CreateBlendGeometry(CurveLoop, CurveLoop, ICollectionVertexPair, SolidOptions) | Creates a solid by blending two closed curve loops lying in non-coincident planes.
CreateExtrusionGeometry(IListCurveLoop, XYZ, Double) | Creates a solid by linearly extruding one or more closed coplanar curve loops.
CreateExtrusionGeometry(IListCurveLoop, XYZ, Double, SolidOptions) | Creates a solid by linearly extruding one or more closed coplanar curve loops.
CreateFixedReferenceSweptGeometry(CurveLoop, Int32, Double, IListCurveLoop, XYZ) | Creates a solid by sweeping one or more closed coplanar curve loops along a path while keeping the profile plane oriented so that a line in the plane that is initially perpendicular to a given fixed direction remains perpendicular as the profile is swept along the path.
CreateFixedReferenceSweptGeometry(CurveLoop, Int32, Double, IListCurveLoop, XYZ, SolidOptions) | Creates a solid by sweeping one or more closed coplanar curve loops along a path while keeping the profile plane oriented so that a line in the plane that is initially perpendicular to a given fixed direction remains perpendicular as the profile is swept along the path.
CreateLoftGeometry | Creates a solid or open shell geometry by lofting between a sequence of curve loops.
CreateRevolvedGeometry(Frame, IListCurveLoop, Double, Double) | Creates a solid of revolution by revolving a set of closed curve loops around an axis by a specified angle.
CreateRevolvedGeometry(Frame, IListCurveLoop, Double, Double, SolidOptions) | Creates a solid of revolution by revolving a set of closed curve loops around an axis by a specified angle.
CreateSweptBlendGeometry(Curve, IListDouble, IListCurveLoop, IListICollectionVertexPair) | Creates a solid by simultaneously sweeping and blending two or more closed planar curve loops along a single curve.
CreateSweptBlendGeometry(Curve, IListDouble, IListCurveLoop, IListICollectionVertexPair, SolidOptions) | Creates a solid by simultaneously sweeping and blending two or more closed planar curve loops along a single curve.
CreateSweptGeometry(CurveLoop, Int32, Double, IListCurveLoop) | Creates a solid by sweeping one or more closed coplanar curve loops along a path.
CreateSweptGeometry(CurveLoop, Int32, Double, IListCurveLoop, SolidOptions) | Creates a solid by sweeping one or more closed coplanar curve loops along a path.
Top
See Also

Reference

GeometryCreationUtilities Class


GeometryCreationUtilities.CreateBlendGeometry Method

GeometryCreationUtilitiesCreateBlendGeometry Method

Overload List
Name | Description
CreateBlendGeometry(CurveLoop, CurveLoop, ICollectionVertexPair) | Creates a solid by blending two closed curve loops lying in non-coincident planes.
CreateBlendGeometry(CurveLoop, CurveLoop, ICollectionVertexPair, SolidOptions) | Creates a solid by blending two closed curve loops lying in non-coincident planes.
Top
See Also

Reference

GeometryCreationUtilities Class


GeometryCreationUtilities.CreateBlendGeometry(CurveLoop, CurveLoop, ICollection<VertexPair>) Method

GeometryCreationUtilitiesCreateBlendGeometry(CurveLoop, CurveLoop, ICollectionVertexPair) Method

Creates a solid by blending two closed curve loops lying in non-coincident planes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Solid CreateBlendGeometry(
    CurveLoop firstLoop,
    CurveLoop secondLoop,
    ICollection<VertexPair> vertexPairs
)
Public Shared Function CreateBlendGeometry (
    firstLoop As CurveLoop,
    secondLoop As CurveLoop,
    vertexPairs As ICollection(Of VertexPair)
) As Solid
public:
static Solid^ CreateBlendGeometry(
    CurveLoop^ firstLoop,
    CurveLoop^ secondLoop,
    ICollection<VertexPair^>^ vertexPairs
)
static member CreateBlendGeometry :
        firstLoop : CurveLoop *
        secondLoop : CurveLoop *
        vertexPairs : ICollection<VertexPair> -> Solid

Parameters

firstLoop CurveLoop
The first curve loop. The loop must be a closed planar loop without intersections or degeneracies. No orientation conditions are imposed. The loop may not contain just one closed curve - split such a loop into two or more curves beforehand.
secondLoop CurveLoop
The second curve loop, satisfying the same conditions as the first loop. The planes of the first and second loops must not be coincident, but they need not be parallel.
vertexPairs ICollection VertexPair
This input specifies how the two profile loops should be connected. If null, the function chooses vertex connections that will result in a geometrically reasonable blend.

Return Value

Solid
The requested solid.
Exceptions
Exception | Condition
ArgumentException | The first profile CurveLoop do not satisfy the input requirements. -or- The second profile CurveLoop do not satisfy the input requirements.
ArgumentNullException | A non-optional argument was null
See Also

Reference

GeometryCreationUtilities Class
CreateBlendGeometry Overload


GeometryCreationUtilities.CreateBlendGeometry(CurveLoop, CurveLoop, ICollection<VertexPair>, SolidOptions) Method

GeometryCreationUtilitiesCreateBlendGeometry(CurveLoop, CurveLoop, ICollectionVertexPair, SolidOptions) Method

Creates a solid by blending two closed curve loops lying in non-coincident planes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Solid CreateBlendGeometry(
    CurveLoop firstLoop,
    CurveLoop secondLoop,
    ICollection<VertexPair> vertexPairs,
    SolidOptions solidOptions
)
Public Shared Function CreateBlendGeometry (
    firstLoop As CurveLoop,
    secondLoop As CurveLoop,
    vertexPairs As ICollection(Of VertexPair),
    solidOptions As SolidOptions
) As Solid
public:
static Solid^ CreateBlendGeometry(
    CurveLoop^ firstLoop,
    CurveLoop^ secondLoop,
    ICollection<VertexPair^>^ vertexPairs,
    SolidOptions^ solidOptions
)
static member CreateBlendGeometry :
        firstLoop : CurveLoop *
        secondLoop : CurveLoop *
        vertexPairs : ICollection<VertexPair> *
        solidOptions : SolidOptions -> Solid

Parameters

firstLoop CurveLoop
The first curve loop. The loop must be a closed planar loop without intersections or degeneracies. No orientation conditions are imposed. The loop must be a closed planar loop without intersections or degeneracies. No orientation conditions are imposed. The loop may not contain just one closed curve - split such a loop into two or more curves beforehand.
secondLoop CurveLoop
The second curve loop, satisfying the same conditions as the first loop. The planes of the first and second loops must not be coincident, but they need not be parallel.
vertexPairs ICollection VertexPair
This input specifies how the two profile loops should be connected. If null, the function chooses vertex connections that will result in a geometrically reasonable blend.
solidOptions SolidOptions
The optional information to control the properties of the Solid.

Return Value

Solid
The requested solid.
Exceptions
Exception | Condition
ArgumentException | The first profile CurveLoop do not satisfy the input requirements. -or- The second profile CurveLoop do not satisfy the input requirements.
ArgumentNullException | A non-optional argument was null
See Also

Reference

GeometryCreationUtilities Class
CreateBlendGeometry Overload


GeometryCreationUtilities.CreateExtrusionGeometry Method

GeometryCreationUtilitiesCreateExtrusionGeometry Method

Overload List
Name | Description
CreateExtrusionGeometry(IListCurveLoop, XYZ, Double) | Creates a solid by linearly extruding one or more closed coplanar curve loops.
CreateExtrusionGeometry(IListCurveLoop, XYZ, Double, SolidOptions) | Creates a solid by linearly extruding one or more closed coplanar curve loops.
Top
See Also

Reference

GeometryCreationUtilities Class


GeometryCreationUtilities.CreateExtrusionGeometry(IList<CurveLoop>, XYZ, Double) Method

GeometryCreationUtilitiesCreateExtrusionGeometry(IListCurveLoop, XYZ, Double) Method

Creates a solid by linearly extruding one or more closed coplanar curve loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Solid CreateExtrusionGeometry(
    IList<CurveLoop> profileLoops,
    XYZ extrusionDir,
    double extrusionDist
)
Public Shared Function CreateExtrusionGeometry (
    profileLoops As IList(Of CurveLoop),
    extrusionDir As XYZ,
    extrusionDist As Double
) As Solid
public:
static Solid^ CreateExtrusionGeometry(
    IList<CurveLoop^>^ profileLoops,
    XYZ^ extrusionDir,
    double extrusionDist
)
static member CreateExtrusionGeometry :
        profileLoops : IList<CurveLoop> *
        extrusionDir : XYZ *
        extrusionDist : float -> Solid

Parameters

profileLoops IList CurveLoop
The profile loops to be extruded. The loops must be closed, coplanar, and without intersections, self-intersections, or degeneracies. No loop may contain just one closed curve - split such loops into two or more curves beforehand. No conditions are imposed on the orientations of the loops: this function will use copies of the input loops that have been oriented as necessary to conform to Revit's orientation conventions.
extrusionDir XYZ
The direction in which to extrude the profile loops. This vector must be non-zero and transverse (i.e., not parallel) to the plane of the profile loops. Its length is irrelevant; only its direction is used.
extrusionDist Double
The positive distance by which the loops are to be extruded in the direction of the input extrusionDir.

Return Value

Solid
The requested solid.
Exceptions
Exception | Condition
ArgumentException | The profile CurveLoops do not satisfy the input requirements. -or- The Input extrusionDir must be a non-zero vector. The normal of the loop plane should not be perpendicular to the given extrusionDir. -or- The input argument extrusionDist must be positive.
ArgumentNullException | A non-optional argument was null
See Also

Reference

GeometryCreationUtilities Class
CreateExtrusionGeometry Overload


GeometryCreationUtilities.CreateExtrusionGeometry(IList<CurveLoop>, XYZ, Double, SolidOptions) Method

GeometryCreationUtilitiesCreateExtrusionGeometry(IListCurveLoop, XYZ, Double, SolidOptions) Method

Creates a solid by linearly extruding one or more closed coplanar curve loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Solid CreateExtrusionGeometry(
    IList<CurveLoop> profileLoops,
    XYZ extrusionDir,
    double extrusionDist,
    SolidOptions solidOptions
)
Public Shared Function CreateExtrusionGeometry (
    profileLoops As IList(Of CurveLoop),
    extrusionDir As XYZ,
    extrusionDist As Double,
    solidOptions As SolidOptions
) As Solid
public:
static Solid^ CreateExtrusionGeometry(
    IList<CurveLoop^>^ profileLoops,
    XYZ^ extrusionDir,
    double extrusionDist,
    SolidOptions^ solidOptions
)
static member CreateExtrusionGeometry :
        profileLoops : IList<CurveLoop> *
        extrusionDir : XYZ *
        extrusionDist : float *
        solidOptions : SolidOptions -> Solid

Parameters

profileLoops IList CurveLoop
The profile loops to be extruded. The loops must be closed, coplanar, and without intersections, self-intersections, or degeneracies. No loop may contain just one closed curve - split such loops into two or more curves beforehand. No conditions are imposed on the orientations of the loops: this function will use copies of the input loops that have been oriented as necessary to conform to Revit's orientation conventions.
extrusionDir XYZ
The direction in which to extrude the profile loops. This vector must be non-zero and transverse (i.e., not parallel) to the plane of the profile loops. Its length is irrelevant; only its direction is used.
extrusionDist Double
The positive distance by which the loops are to be extruded in the direction of the input extrusionDir.
solidOptions SolidOptions
The optional information to control the properties of the Solid.

Return Value

Solid
The requested solid.
Exceptions
Exception | Condition
ArgumentException | The profile CurveLoops do not satisfy the input requirements. -or- The Input extrusionDir must be a non-zero vector. The normal of the loop plane should not be perpendicular to the given extrusionDir. -or- The input argument extrusionDist must be positive.
ArgumentNullException | A non-optional argument was null
See Also

Reference

GeometryCreationUtilities Class
CreateExtrusionGeometry Overload


GeometryCreationUtilities.CreateFixedReferenceSweptGeometry Method

GeometryCreationUtilitiesCreateFixedReferenceSweptGeometry Method

Overload List
Name | Description
CreateFixedReferenceSweptGeometry(CurveLoop, Int32, Double, IListCurveLoop, XYZ) | Creates a solid by sweeping one or more closed coplanar curve loops along a path while keeping the profile plane oriented so that a line in the plane that is initially perpendicular to a given fixed direction remains perpendicular as the profile is swept along the path.
CreateFixedReferenceSweptGeometry(CurveLoop, Int32, Double, IListCurveLoop, XYZ, SolidOptions) | Creates a solid by sweeping one or more closed coplanar curve loops along a path while keeping the profile plane oriented so that a line in the plane that is initially perpendicular to a given fixed direction remains perpendicular as the profile is swept along the path.
Top
See Also

Reference

GeometryCreationUtilities Class


GeometryCreationUtilities.CreateFixedReferenceSweptGeometry(CurveLoop, Int32, Double, IList<CurveLoop>, XYZ) Method

GeometryCreationUtilitiesCreateFixedReferenceSweptGeometry(CurveLoop, Int32, Double, IListCurveLoop, XYZ) Method

Creates a solid by sweeping one or more closed coplanar curve loops along a path while keeping the profile plane oriented so that a line in the plane that is initially perpendicular to a given fixed direction remains perpendicular as the profile is swept along the path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Solid CreateFixedReferenceSweptGeometry(
    CurveLoop sweepPath,
    int pathAttachmentCrvIdx,
    double pathAttachmentParam,
    IList<CurveLoop> profileLoops,
    XYZ fixedReferenceDirection
)
Public Shared Function CreateFixedReferenceSweptGeometry (
    sweepPath As CurveLoop,
    pathAttachmentCrvIdx As Integer,
    pathAttachmentParam As Double,
    profileLoops As IList(Of CurveLoop),
    fixedReferenceDirection As XYZ
) As Solid
public:
static Solid^ CreateFixedReferenceSweptGeometry(
    CurveLoop^ sweepPath,
    int pathAttachmentCrvIdx,
    double pathAttachmentParam,
    IList<CurveLoop^>^ profileLoops,
    XYZ^ fixedReferenceDirection
)
static member CreateFixedReferenceSweptGeometry :
        sweepPath : CurveLoop *
        pathAttachmentCrvIdx : int *
        pathAttachmentParam : float *
        profileLoops : IList<CurveLoop> *
        fixedReferenceDirection : XYZ -> Solid

Parameters

sweepPath CurveLoop
The sweep path, consisting of a set of contiguous curves. The path may be open or closed, but should not otherwise have any self-intersections. The path may be planar or non-planar. With the exception of path curves that lie in a plane parallel to %fixedReferenceDirection%, the curve's tangent should be nowhere parallel to %fixedReferenceDirection%. If the sweep path has corners, the solid segments that meet at a corner may not meet smoothly.
pathAttachmentCrvIdx Int32
The index of the curve in the sweep path where the profile loops are situated. Indexing starts at 0. Together with pathAttachmentParam, this specifies the profile's attachment point.
pathAttachmentParam Double
Parameter of the path curve specified by pathAttachmentCrvIdx. The profile curves must lie in the plane orthogonal to the path at this attachment point.
profileLoops IList CurveLoop
The curve loops defining the planar domain to be swept along the path. No conditions are imposed on the orientations of the loops; this function will use copies of the input loops that have been oriented as necessary to conform to Revit's orientation conventions. Restrictions:
  • The loops must lie in the plane orthogonal to the path at the attachment point as defined above.
  • The curve loop(s) must be closed and should define a single planar domain (one outer loop and, optionally, one or more inner loops).
  • The curve loops must be without intersections, self-intersections, or degeneracies.
  • No loop may contain just one closed curve - split such loops into two or more curves beforehand.
fixedReferenceDirection XYZ
A unit vector specifying the fixed direction used to control how the profile plane is swept along the path; see the description and remarks above.

Return Value

Solid
The requested solid.
Exceptions
Exception | Condition
ArgumentException | The input argument sweepPath should at least contain one curve. -or- The input argument pathAttachmentCrvIdx is not valid. -or- The profile CurveLoops do not satisfy the input requirements.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | fixedReferenceDirection is not length 1.0.
Remarks
The profile loops must lie in a plane orthogonal to the sweep path at some attachment point along the path. An example where this method is useful is in constructing railings. If the fixed direction is the upward vertical, a line in the profile plane that is initially horizontal will remain horizontal as the profile is swept along the path. This property can be used to ensure that the top of the railing remains horizontal all along the railing. The STEP ISO 10303-42 and IFC standards define a "Fixed Reference Sweep" similar to this sweep method, though there are some minor technical differences:
  • The STEP ISO reference describes a specific parameterization of the swept surface, whereas we do not guarantee any particular parameterization (partly because we simplify the surface when possible).
  • Neither reference mentions what should be done if the sweep pathâ€™s tangent is tangent to the reference direction at some point(s) or along the entire directrix.
  • Both references impose unnecessary conditions, and they're inconsistent: STEP says "the swept_curve is required to be a curve lying in the plane z = 0" while IFC says "The SweptArea shall lie in the plane z = 0" (SweptArea is the profile being swept).
See Also

Reference

GeometryCreationUtilities Class
CreateFixedReferenceSweptGeometry Overload


GeometryCreationUtilities.CreateFixedReferenceSweptGeometry(CurveLoop, Int32, Double, IList<CurveLoop>, XYZ, SolidOptions) Method

GeometryCreationUtilitiesCreateFixedReferenceSweptGeometry(CurveLoop, Int32, Double, IListCurveLoop, XYZ, SolidOptions) Method

Creates a solid by sweeping one or more closed coplanar curve loops along a path while keeping the profile plane oriented so that a line in the plane that is initially perpendicular to a given fixed direction remains perpendicular as the profile is swept along the path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Solid CreateFixedReferenceSweptGeometry(
    CurveLoop sweepPath,
    int pathAttachmentCrvIdx,
    double pathAttachmentParam,
    IList<CurveLoop> profileLoops,
    XYZ fixedReferenceDirection,
    SolidOptions solidOptions
)
Public Shared Function CreateFixedReferenceSweptGeometry (
    sweepPath As CurveLoop,
    pathAttachmentCrvIdx As Integer,
    pathAttachmentParam As Double,
    profileLoops As IList(Of CurveLoop),
    fixedReferenceDirection As XYZ,
    solidOptions As SolidOptions
) As Solid
public:
static Solid^ CreateFixedReferenceSweptGeometry(
    CurveLoop^ sweepPath,
    int pathAttachmentCrvIdx,
    double pathAttachmentParam,
    IList<CurveLoop^>^ profileLoops,
    XYZ^ fixedReferenceDirection,
    SolidOptions^ solidOptions
)
static member CreateFixedReferenceSweptGeometry :
        sweepPath : CurveLoop *
        pathAttachmentCrvIdx : int *
        pathAttachmentParam : float *
        profileLoops : IList<CurveLoop> *
        fixedReferenceDirection : XYZ *
        solidOptions : SolidOptions -> Solid

Parameters

sweepPath CurveLoop
The sweep path, consisting of a set of contiguous curves. The path may be open or closed, but should not otherwise have any self-intersections. The path may be planar or non-planar. With the exception of path curves that lie in a plane parallel to %fixedReferenceDirection%, the curve's tangent should be nowhere parallel to %fixedReferenceDirection%. If the sweep path has corners, the solid segments that meet at a corner may not meet smoothly.
pathAttachmentCrvIdx Int32
The index of the curve in the sweep path where the profile loops are situated. Indexing starts at 0. Together with pathAttachmentParam, this specifies the profile's attachment point.
pathAttachmentParam Double
Parameter of the path curve specified by pathAttachmentCrvIdx. The profile curves must lie in the plane orthogonal to the path at this attachment point.
profileLoops IList CurveLoop
The curve loops defining the planar domain to be swept along the path. No conditions are imposed on the orientations of the loops; this function will use copies of the input loops that have been oriented as necessary to conform to Revit's orientation conventions. Restrictions:
  • The loops must lie in the plane orthogonal to the path at the attachment point as defined above.
  • The curve loop(s) must be closed and should define a single planar domain (one outer loop and, optionally, one or more inner loops).
  • The curve loops must be without intersections, self-intersections, or degeneracies.
  • No loop may contain just one closed curve - split such loops into two or more curves beforehand.
fixedReferenceDirection XYZ
A unit vector specifying the fixed direction used to control how the profile plane is swept along the path; see the description and remarks above. The profile CurveLoops do not satisfy the input requirements.
solidOptions SolidOptions
The optional information to control the properties of the Solid.

Return Value

Solid
The requested solid.
Exceptions
Exception | Condition
ArgumentException | The input argument sweepPath should at least contain one curve. -or- The input argument pathAttachmentCrvIdx is not valid. -or-
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | fixedReferenceDirection is not length 1.0.
Remarks
The profile loops must lie in a plane orthogonal to the sweep path at some attachment point along the path. An example where this method is useful is in constructing railings. If the fixed direction is the upward vertical, a line in the profile plane that is initially horizontal will remain horizontal as the profile is swept along the path. This property can be used to ensure that the top of the railing remains horizontal all along the railing. The STEP ISO 10303-42 and IFC standards define a "Fixed Reference Sweep" similar to this sweep method, though there are some minor technical differences:
  • The STEP ISO reference describes a specific parameterization of the swept surface, whereas we do not guarantee any particular parameterization (partly because we simplify the surface when possible).
  • Neither reference mentions what should be done if the sweep pathâ€™s tangent is tangent to the reference direction at some point(s) or along the entire directrix.
  • Both references impose unnecessary conditions, and they're inconsistent: STEP says "the swept_curve is required to be a curve lying in the plane z = 0" while IFC says "The SweptArea shall lie in the plane z = 0" (SweptArea is the profile being swept).
See Also

Reference

GeometryCreationUtilities Class
CreateFixedReferenceSweptGeometry Overload


GeometryCreationUtilities.CreateLoftGeometry Method

GeometryCreationUtilitiesCreateLoftGeometry Method

Creates a solid or open shell geometry by lofting between a sequence of curve loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Solid CreateLoftGeometry(
    IList<CurveLoop> profileLoops,
    SolidOptions solidOptions
)
Public Shared Function CreateLoftGeometry (
    profileLoops As IList(Of CurveLoop),
    solidOptions As SolidOptions
) As Solid
public:
static Solid^ CreateLoftGeometry(
    IList<CurveLoop^>^ profileLoops,
    SolidOptions^ solidOptions
)
static member CreateLoftGeometry :
        profileLoops : IList<CurveLoop> *
        solidOptions : SolidOptions -> Solid

Parameters

profileLoops IList CurveLoop
The array of curve loops, where the order of the array determines the lofting sequence used.
solidOptions SolidOptions
The optional information to control the properties of the solid or open shell.

Return Value

Solid
The requested solid or open shell.
Exceptions
Exception | Condition
ArgumentException | The number of profile CurveLoops is less than 2.
ArgumentNullException | A non-optional argument was null
Remarks
If all the curve loops are closed it will create a solid. No loop may contain just one closed curve - split such loops into two or more curves beforehand. If all the curve loops are open, then create an open shell. If there are both open and closed loops, only the first and/or last loop are allowed to be open, others (if they exist) must be closed. A solid will be created in this case. The surface of the solid or open shell will pass through these profiles blending smoothly between the profiles. Each profile loop must be free of intersections and degeneracies. No orientation conditions on the loops are imposed.
See Also

Reference

GeometryCreationUtilities Class


GeometryCreationUtilities.CreateRevolvedGeometry Method

GeometryCreationUtilitiesCreateRevolvedGeometry Method

Overload List
Name | Description
CreateRevolvedGeometry(Frame, IListCurveLoop, Double, Double) | Creates a solid of revolution by revolving a set of closed curve loops around an axis by a specified angle.
CreateRevolvedGeometry(Frame, IListCurveLoop, Double, Double, SolidOptions) | Creates a solid of revolution by revolving a set of closed curve loops around an axis by a specified angle.
Top
See Also

Reference

GeometryCreationUtilities Class


GeometryCreationUtilities.CreateRevolvedGeometry(Frame, IList<CurveLoop>, Double, Double) Method

GeometryCreationUtilitiesCreateRevolvedGeometry(Frame, IListCurveLoop, Double, Double) Method

Creates a solid of revolution by revolving a set of closed curve loops around an axis by a specified angle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Solid CreateRevolvedGeometry(
    Frame coordinateFrame,
    IList<CurveLoop> profileLoops,
    double startAngle,
    double endAngle
)
Public Shared Function CreateRevolvedGeometry (
    coordinateFrame As Frame,
    profileLoops As IList(Of CurveLoop),
    startAngle As Double,
    endAngle As Double
) As Solid
public:
static Solid^ CreateRevolvedGeometry(
    Frame^ coordinateFrame,
    IList<CurveLoop^>^ profileLoops,
    double startAngle,
    double endAngle
)
static member CreateRevolvedGeometry :
        coordinateFrame : Frame *
        profileLoops : IList<CurveLoop> *
        startAngle : float *
        endAngle : float -> Solid

Parameters

coordinateFrame Frame
A right-handed orthonormal frame of vectors. The frame's z-vector is the axis of revolution. The start and end angle inputs refer to this frame.
profileLoops IList CurveLoop
The profile loops to be revolved. No conditions are imposed on the orientations of the loops. This function will use copies of the input loops that have been oriented as necessary to conform to Revit's orientation conventions. Restrictions:
  • The loops must lie in the xz coordinate plane of the input coordinate frame.
  • The curve loop(s) must be closed and must define a single planar domain (one outer loop and, optionally, one or more inner loops).
  • The curve loops must be without intersections, self-intersections, or degeneracies.
  • The loops must lie on the "right" side of the z axis (where x >= 0).
  • No loop may contain just one closed curve - split such loops into two or more curves beforehand.
startAngle Double
The start angle for the revolution, in radians, measured counter-clockwise from the coordinate frame's x-axis as viewed looking down the frame's z-axis.
endAngle Double
The end angle for the revolution, using the same conventions as the start angle. The end angle may be less than (but not equal to) the start angle. The total angle of revolution, equal to the absolute value of (endAngle â€“ startAngle), must be at most 2*PI.

Return Value

Solid
The requested solid. Note that if less than a full revolution is used, planar end faces will be added as part of the solid.
Exceptions
Exception | Condition
ArgumentException | The input argument coordinateFrame should be a right-handed orthonormal frame of vectors. -or- The profile CurveLoops do not satisfy the input requirements. -or- The absolute value of %(endAngle â€“ startAngle)%, must be at most 2*PI.
ArgumentNullException | A non-optional argument was null
See Also

Reference

GeometryCreationUtilities Class
CreateRevolvedGeometry Overload


GeometryCreationUtilities.CreateRevolvedGeometry(Frame, IList<CurveLoop>, Double, Double, SolidOptions) Method

GeometryCreationUtilitiesCreateRevolvedGeometry(Frame, IListCurveLoop, Double, Double, SolidOptions) Method

Creates a solid of revolution by revolving a set of closed curve loops around an axis by a specified angle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Solid CreateRevolvedGeometry(
    Frame coordinateFrame,
    IList<CurveLoop> profileLoops,
    double startAngle,
    double endAngle,
    SolidOptions solidOptions
)
Public Shared Function CreateRevolvedGeometry (
    coordinateFrame As Frame,
    profileLoops As IList(Of CurveLoop),
    startAngle As Double,
    endAngle As Double,
    solidOptions As SolidOptions
) As Solid
public:
static Solid^ CreateRevolvedGeometry(
    Frame^ coordinateFrame,
    IList<CurveLoop^>^ profileLoops,
    double startAngle,
    double endAngle,
    SolidOptions^ solidOptions
)
static member CreateRevolvedGeometry :
        coordinateFrame : Frame *
        profileLoops : IList<CurveLoop> *
        startAngle : float *
        endAngle : float *
        solidOptions : SolidOptions -> Solid

Parameters

coordinateFrame Frame
A right-handed orthonormal frame of vectors. The frame's z-vector is the axis of revolution. The start and end angle inputs refer to this frame.
profileLoops IList CurveLoop
The profile loops to be revolved. No conditions are imposed on the orientations of the loops. This function will use copies of the input loops that have been oriented as necessary to conform to Revit's orientation conventions. Restrictions:
  • The loops must lie in the xz coordinate plane of the input coordinate frame.
  • The curve loop(s) must be closed and must define a single planar domain (one outer loop and, optionally, one or more inner loops).
  • The curve loops must be without intersections, self-intersections, or degeneracies.
  • The loops must lie on the "right" side of the z axis (where x >= 0).
  • No loop may contain just one closed curve - split such loops into two or more curves beforehand.
startAngle Double
The start angle for the revolution, in radians, measured counter-clockwise from the coordinate frame's x-axis as viewed looking down the frame's z-axis.
endAngle Double
The end angle for the revolution, using the same conventions as the start angle. The end angle may be less than (but not equal to) the start angle. The total angle of revolution, equal to the absolute value of (endAngle â€“ startAngle), must be at most 2*PI.
solidOptions SolidOptions
The optional information to control the properties of the Solid.

Return Value

Solid
The requested solid. Note that if less than a full revolution is used, planar end faces will be added as part of the solid.
Exceptions
Exception | Condition
ArgumentException | The input argument coordinateFrame should be a right-handed orthonormal frame of vectors. -or- The profile CurveLoops do not satisfy the input requirements. -or- The absolute value of %(endAngle â€“ startAngle)%, must be at most 2*PI.
ArgumentNullException | A non-optional argument was null
See Also

Reference

GeometryCreationUtilities Class
CreateRevolvedGeometry Overload


GeometryCreationUtilities.CreateSweptBlendGeometry Method

GeometryCreationUtilitiesCreateSweptBlendGeometry Method

Overload List
Name | Description
CreateSweptBlendGeometry(Curve, IListDouble, IListCurveLoop, IListICollectionVertexPair) | Creates a solid by simultaneously sweeping and blending two or more closed planar curve loops along a single curve.
CreateSweptBlendGeometry(Curve, IListDouble, IListCurveLoop, IListICollectionVertexPair, SolidOptions) | Creates a solid by simultaneously sweeping and blending two or more closed planar curve loops along a single curve.
Top
See Also

Reference

GeometryCreationUtilities Class


GeometryCreationUtilities.CreateSweptBlendGeometry(Curve, IList<Double>, IList<CurveLoop>, IList<ICollection<VertexPair>>) Method

GeometryCreationUtilitiesCreateSweptBlendGeometry(Curve, IListDouble, IListCurveLoop, IListICollectionVertexPair) Method

Creates a solid by simultaneously sweeping and blending two or more closed planar curve loops along a single curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Solid CreateSweptBlendGeometry(
    Curve pathCurve,
    IList<double> pathParams,
    IList<CurveLoop> profileLoops,
    IList<ICollection<VertexPair>> vertexPairs
)
Public Shared Function CreateSweptBlendGeometry (
    pathCurve As Curve,
    pathParams As IList(Of Double),
    profileLoops As IList(Of CurveLoop),
    vertexPairs As IList(Of ICollection(Of VertexPair))
) As Solid
public:
static Solid^ CreateSweptBlendGeometry(
    Curve^ pathCurve,
    IList<double>^ pathParams,
    IList<CurveLoop^>^ profileLoops,
    IList<ICollection<VertexPair^>^>^ vertexPairs
)
static member CreateSweptBlendGeometry :
        pathCurve : Curve *
        pathParams : IList<float> *
        profileLoops : IList<CurveLoop> *
        vertexPairs : IList<ICollection<VertexPair>> -> Solid

Parameters

pathCurve Curve
The sweep path, consisting of a single bounded, open curve.
pathParams IList Double
An increasing sequence of parameters along the path curve (lying within the curve's bounds). These parameters specify the locations of the planes orthogonal to the path that contain the profile loops. This array must have the same size as the input array "profileLoops".
profileLoops IList CurveLoop
Closed, planar curve loops arrayed along the path. No loop may contain just one closed curve - split such loops into two or more curves beforehand. The solid will have these profiles as cross-sections at the points specified by the input pathParams. The solid will blend smoothly between the profiles. This array must have the same size as the input array "pathParams", and each profile loop must lie in the plane orthogonal to the path at the point specified by the corresponding entry in the input array "pathParams". Each profile loop must define a single planar domain and must be free of intersections and degeneracies. No orientation conditions on the loops are imposed.
vertexPairs IList ICollection VertexPair
This input specifies how adjacent profile loops should be connected. It must contain one less element than the "profileLoops" input, and entry vertexPairs[idx] specifies how profileLoops[idx] and profileLoops[idx+1] should be connected (indexing starts at 0).

Return Value

Solid
The requested solid.
Exceptions
Exception | Condition
ArgumentException | The input pathCurve is a helical curve and is not supported for this operation. -or- The input argument pathCurve should be bounded. The input argument pathCurve should be non-degenerate. -or- The input argument pathParams should be an increasing array. -or- The profile CurveLoops do not satisfy the input requirements.
ArgumentNullException | A non-optional argument was null
See Also

Reference

GeometryCreationUtilities Class
CreateSweptBlendGeometry Overload


GeometryCreationUtilities.CreateSweptBlendGeometry(Curve, IList<Double>, IList<CurveLoop>, IList<ICollection<VertexPair>>, SolidOptions) Method

GeometryCreationUtilitiesCreateSweptBlendGeometry(Curve, IListDouble, IListCurveLoop, IListICollectionVertexPair, SolidOptions) Method

Creates a solid by simultaneously sweeping and blending two or more closed planar curve loops along a single curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Solid CreateSweptBlendGeometry(
    Curve pathCurve,
    IList<double> pathParams,
    IList<CurveLoop> profileLoops,
    IList<ICollection<VertexPair>> vertexPairs,
    SolidOptions solidOptions
)
Public Shared Function CreateSweptBlendGeometry (
    pathCurve As Curve,
    pathParams As IList(Of Double),
    profileLoops As IList(Of CurveLoop),
    vertexPairs As IList(Of ICollection(Of VertexPair)),
    solidOptions As SolidOptions
) As Solid
public:
static Solid^ CreateSweptBlendGeometry(
    Curve^ pathCurve,
    IList<double>^ pathParams,
    IList<CurveLoop^>^ profileLoops,
    IList<ICollection<VertexPair^>^>^ vertexPairs,
    SolidOptions^ solidOptions
)
static member CreateSweptBlendGeometry :
        pathCurve : Curve *
        pathParams : IList<float> *
        profileLoops : IList<CurveLoop> *
        vertexPairs : IList<ICollection<VertexPair>> *
        solidOptions : SolidOptions -> Solid

Parameters

pathCurve Curve
The sweep path, consisting of a single bounded, open curve.
pathParams IList Double
An increasing sequence of parameters along the path curve (lying within the curve's bounds). These parameters specify the locations of the planes orthogonal to the path that contain the profile loops. This array must have the same size as the input array "profileLoops".
profileLoops IList CurveLoop
Closed, planar curve loops arrayed along the path. No loop may contain just one closed curve - split such loops into two or more curves beforehand. The solid will have these profiles as cross-sections at the points specified by the input pathParams. The solid will blend smoothly between the profiles. This array must have the same size as the input array "pathParams", and each profile loop must lie in the plane orthogonal to the path at the point specified by the corresponding entry in the input array "pathParams". Each profile loop must define a single planar domain and must be free of intersections and degeneracies. No orientation conditions on the loops are imposed.
vertexPairs IList ICollection VertexPair
This input specifies how adjacent profile loops should be connected. It must contain one less element than the "profileLoops" input, and entry vertexPairs[idx] specifies how profileLoops[idx] and profileLoops[idx+1] should be connected (indexing starts at 0).
solidOptions SolidOptions
The optional information to control the properties of the Solid.

Return Value

Solid
The requested solid.
Exceptions
Exception | Condition
ArgumentException | The input pathCurve is a helical curve and is not supported for this operation. -or- The input argument pathCurve should be bounded. The input argument pathCurve should be non-degenerate. -or- The input argument pathParams should be an increasing array. -or- The profile CurveLoops do not satisfy the input requirements.
ArgumentNullException | A non-optional argument was null
See Also

Reference

GeometryCreationUtilities Class
CreateSweptBlendGeometry Overload


GeometryCreationUtilities.CreateSweptGeometry Method

GeometryCreationUtilitiesCreateSweptGeometry Method

Overload List
Name | Description
CreateSweptGeometry(CurveLoop, Int32, Double, IListCurveLoop) | Creates a solid by sweeping one or more closed coplanar curve loops along a path.
CreateSweptGeometry(CurveLoop, Int32, Double, IListCurveLoop, SolidOptions) | Creates a solid by sweeping one or more closed coplanar curve loops along a path.
Top
See Also

Reference

GeometryCreationUtilities Class


GeometryCreationUtilities.CreateSweptGeometry(CurveLoop, Int32, Double, IList<CurveLoop>) Method

GeometryCreationUtilitiesCreateSweptGeometry(CurveLoop, Int32, Double, IListCurveLoop) Method

Creates a solid by sweeping one or more closed coplanar curve loops along a path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Solid CreateSweptGeometry(
    CurveLoop sweepPath,
    int pathAttachmentCrvIdx,
    double pathAttachmentParam,
    IList<CurveLoop> profileLoops
)
Public Shared Function CreateSweptGeometry (
    sweepPath As CurveLoop,
    pathAttachmentCrvIdx As Integer,
    pathAttachmentParam As Double,
    profileLoops As IList(Of CurveLoop)
) As Solid
public:
static Solid^ CreateSweptGeometry(
    CurveLoop^ sweepPath,
    int pathAttachmentCrvIdx,
    double pathAttachmentParam,
    IList<CurveLoop^>^ profileLoops
)
static member CreateSweptGeometry :
        sweepPath : CurveLoop *
        pathAttachmentCrvIdx : int *
        pathAttachmentParam : float *
        profileLoops : IList<CurveLoop> -> Solid

Parameters

sweepPath CurveLoop
The sweep path, consisting of a set of contiguous curves. The path may be open or closed, but should not otherwise have any self-intersections. The path may be planar or non-planar.
pathAttachmentCrvIdx Int32
The index of the curve in the sweep path where the profile loops are situated. Indexing starts at 0. Together with pathAttachmentParam, this specifies the profile's attachment point.
pathAttachmentParam Double
Parameter of the path curve specified by pathAttachmentCrvIdx. The profile curves must lie in the plane orthogonal to the path at this attachment point.
profileLoops IList CurveLoop
The curve loops defining the planar domain to be swept along the path. No conditions are imposed on the orientations of the loops: this function will use copies of the input loops that have been oriented as necessary to conform to Revit's orientation conventions. Restrictions:
  • The loops must lie in the plane orthogonal to the path at the attachment point as defined above.
  • The curve loop(s) must be closed and should define a single planar domain (one outer loop and, optionally, one or more inner loops)
  • The curve loops must be without intersections, self-intersections, or degeneracies.
  • No loop may contain just one closed curve - split such loops into two or more curves beforehand.

Return Value

Solid
The requested solid.
Exceptions
Exception | Condition
ArgumentException | The input argument sweepPath should at least contain one curve. -or- The input argument pathAttachmentCrvIdx is not valid. The given attachment point doesn't lie in the plane of the Curve Loop. -or- The profile CurveLoops do not satisfy the input requirements.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Failed to create the swept solid.
Remarks
The profile loops must lie in a plane orthogonal to the sweep path at some attachment point along the path.
See Also

Reference

GeometryCreationUtilities Class
CreateSweptGeometry Overload


GeometryCreationUtilities.CreateSweptGeometry(CurveLoop, Int32, Double, IList<CurveLoop>, SolidOptions) Method

GeometryCreationUtilitiesCreateSweptGeometry(CurveLoop, Int32, Double, IListCurveLoop, SolidOptions) Method

Creates a solid by sweeping one or more closed coplanar curve loops along a path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Solid CreateSweptGeometry(
    CurveLoop sweepPath,
    int pathAttachmentCrvIdx,
    double pathAttachmentParam,
    IList<CurveLoop> profileLoops,
    SolidOptions solidOptions
)
Public Shared Function CreateSweptGeometry (
    sweepPath As CurveLoop,
    pathAttachmentCrvIdx As Integer,
    pathAttachmentParam As Double,
    profileLoops As IList(Of CurveLoop),
    solidOptions As SolidOptions
) As Solid
public:
static Solid^ CreateSweptGeometry(
    CurveLoop^ sweepPath,
    int pathAttachmentCrvIdx,
    double pathAttachmentParam,
    IList<CurveLoop^>^ profileLoops,
    SolidOptions^ solidOptions
)
static member CreateSweptGeometry :
        sweepPath : CurveLoop *
        pathAttachmentCrvIdx : int *
        pathAttachmentParam : float *
        profileLoops : IList<CurveLoop> *
        solidOptions : SolidOptions -> Solid

Parameters

sweepPath CurveLoop
The sweep path, consisting of a set of contiguous curves. The path may be open or closed, but should not otherwise have any self-intersections. The path may be planar or non-planar.
pathAttachmentCrvIdx Int32
The index of the curve in the sweep path where the profile loops are situated. Indexing starts at 0. Together with pathAttachmentParam, this specifies the profile's attachment point.
pathAttachmentParam Double
Parameter of the path curve specified by pathAttachmentCrvIdx. The profile curves must lie in the plane orthogonal to the path at this attachment point.
profileLoops IList CurveLoop
The curve loops defining the planar domain to be swept along the path. No conditions are imposed on the orientations of the loops: this function will use copies of the input loops that have been oriented as necessary to conform to Revit's orientation conventions. Restrictions:
  • The loops must lie in the plane orthogonal to the path at the attachment point as defined above.
  • The curve loop(s) must be closed and should define a single planar domain (one outer loop and, optionally, one or more inner loops)
  • The curve loops must be without intersections, self-intersections, or degeneracies.
  • No loop may contain just one closed curve - split such loops into two or more curves beforehand.
solidOptions SolidOptions
The optional information to control the properties of the Solid.

Return Value

Solid
The requested solid.
Exceptions
Exception | Condition
ArgumentException | The input argument sweepPath should at least contain one curve. -or- The input argument pathAttachmentCrvIdx is not valid. The given attachment point doesn't lie in the plane of the Curve Loop. -or- The profile CurveLoops do not satisfy the input requirements.
ArgumentNullException | A non-optional argument was null
Remarks
The profile loops must lie in a plane orthogonal to the sweep path at some attachment point along the path.
See Also

Reference

GeometryCreationUtilities Class
CreateSweptGeometry Overload


GeometryElement Class

Geometric representation of an element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGeometryObject
Autodesk.Revit.DBGeometryElement

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GeometryElement : GeometryObject,
    IEnumerable<GeometryObject>
Public Class GeometryElement
    Inherits GeometryObject
    Implements IEnumerable(Of GeometryObject)
public ref class GeometryElement : public GeometryObject,
    IEnumerable<GeometryObject^>
type GeometryElement =
    class
        inherit GeometryObject
        interface IEnumerable<GeometryObject>
    end

The GeometryElement type exposes the following members.

Properties
 | Name | Description
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject)
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | MaterialElement | Element describing the material from which this element is composed.
Public property | Visibility | The visibility. (Inherited from GeometryObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject)
Public method | GetBoundingBox | Retrieves a box that encloses the geometry element.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Protected method | GetEnumeratorNG | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject)
Public method | GetTransformed | Returns a transformed copy of the geometry in this element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This class contains geometric primitives that are generated from the parametric description of the element. The member geometric primitives can be obtained directly from this object using the capabilities of IEnumerable.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


GeometryElement Properties

The GeometryElement type exposes the following members.

Properties
 | Name | Description
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject)
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | MaterialElement | Element describing the material from which this element is composed.
Public property | Visibility | The visibility. (Inherited from GeometryObject)
Top
See Also

Reference

GeometryElement Class


GeometryElement.MaterialElement Property

GeometryElementMaterialElement Property

Element describing the material from which this element is composed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Material MaterialElement { get; }
Public ReadOnly Property MaterialElement As Material
    Get
public:
property Material^ MaterialElement {
    Material^ get ();
}
member MaterialElement : Material with get

Property Value

Material
See Also

Reference

GeometryElement Class


GeometryElement Methods

The GeometryElement type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject)
Public method | GetBoundingBox | Retrieves a box that encloses the geometry element.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Protected method | GetEnumeratorNG | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject)
Public method | GetTransformed | Returns a transformed copy of the geometry in this element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

GeometryElement Class


GeometryElement.GetBoundingBox Method

GeometryElementGetBoundingBox Method

Retrieves a box that encloses the geometry element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BoundingBoxXYZ GetBoundingBox()
Public Function GetBoundingBox As BoundingBoxXYZ
public:
BoundingBoxXYZ^ GetBoundingBox()
member GetBoundingBox : unit -> BoundingBoxXYZ

Return Value

BoundingBoxXYZ
The bounding box.
Remarks

Note: If the GeometryElement was obtained via Element.get_Geometry from an Element containing 2D geometry but no 3D geometry, the bounding box returned by this function may not be empty because it takes the 2D geometry into account.

See Also

Reference

GeometryElement Class


GeometryElement.GetEnumerator Method

GeometryElementGetEnumerator Method

Returns an enumerator that iterates through the collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator<GeometryObject> GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator(Of GeometryObject)
public:
virtual IEnumerator<GeometryObject^>^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator<GeometryObject>
override GetEnumerator : unit -> IEnumerator<GeometryObject>

Return Value

IEnumerator GeometryObject
An IEnumerator(GeometryObject) object that can be used to iterate through the collection.

Implements

IEnumerableTGetEnumerator
See Also

Reference

GeometryElement Class


GeometryElement.GetEnumeratorNG Method

GeometryElementGetEnumeratorNG Method

Returns an enumerator that iterates through the collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
internal IEnumerator GetEnumeratorNG()
Friend Function GetEnumeratorNG As IEnumerator
internal:
virtual IEnumerator^ GetEnumeratorNG() sealed
internal abstract GetEnumeratorNG : unit -> IEnumerator
internal override GetEnumeratorNG : unit -> IEnumerator

Return Value

IEnumerator
An IEnumerator(GeometryObject) object that can be used to iterate through the collection.

Implements

IEnumerableGetEnumerator
See Also

Reference

GeometryElement Class


GeometryElement.GetTransformed Method

GeometryElementGetTransformed Method

Returns a transformed copy of the geometry in this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GeometryElement GetTransformed(
    Transform transform
)
Public Function GetTransformed (
    transform As Transform
) As GeometryElement
public:
GeometryElement^ GetTransformed(
    Transform^ transform
)
member GetTransformed :
        transform : Transform -> GeometryElement

Parameters

transform Transform
The transformation to apply to the geometry.

Return Value

GeometryElement
Exceptions
Exception | Condition
ArgumentException | Transform is not conformal
See Also

Reference

GeometryElement Class


GeometryInstance Class

An instance of another element (symbol), specially positioned by this element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGeometryObject
Autodesk.Revit.DBGeometryInstance

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GeometryInstance : GeometryObject
Public Class GeometryInstance
    Inherits GeometryObject
public ref class GeometryInstance : public GeometryObject
type GeometryInstance =
    class
        inherit GeometryObject
    end

The GeometryInstance type exposes the following members.

Properties
 | Name | Description
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject)
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | SymbolGeometry | The geometric representation of the symbol which generates this instance.
 | Transform | The affine transformation from the local coordinate space of the symbol into the coordinate space of the instance.
Public property | Visibility | The visibility. (Inherited from GeometryObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject)
Public method | GetDocument | Gets the document that contains the symbol of this instance.
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject)
Public method | GetInstanceGeometry | Computes the geometric representation of the instance.
Public method | GetInstanceGeometry(Transform) | Computes a transformation of the geometric representation of the instance.
Public method | GetSymbolGeometry | Computes the geometric representation of the symbol which generates this instance.
Public method | GetSymbolGeometry(Transform) | Computes a transformation of the geometric representation of the symbol which generates this instance.
Public method | GetSymbolGeometryId | Gets the SymbolGeometryId that contains data about the symbol of this instance.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
A GeometryInstance represents a set of geometry stored by Revit in a default configuration, and then transformed into the proper location as a result of the properties of the element. The most common situation where GeometryInstances are encountered is in Family instances. Revit uses GeometryInstances to allow it to store a single copy of the geometry for a given family and reuse it in multiple instances. Note that not all Family instances will include GeometryInstances. When Revit needs to make a unique copy of the family geometry for a given instance (because of the effect of local joins, intersections, and other factors related to the instance placement) no GeometryInstance will be encountered; instead the Solid geometry will be found at the top level of the hierarchy. Another example of GeometryInstance usage is in Rebar element visible in fine 3D Views. Here, each segement of a rebar is a GeometryInstance. In this case the Symbol Element is contaning all the geometries that are instanced. A GeometryInstance offers the ability to read its geometry through the GetSymbolGeometry() and GetInstanceGeometry() methods. These methods return another Autodesk.Revit.DB.GeometryElement which can be parsed just like the first level return.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


GeometryInstance Properties

The GeometryInstance type exposes the following members.

Properties
 | Name | Description
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject)
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | SymbolGeometry | The geometric representation of the symbol which generates this instance.
 | Transform | The affine transformation from the local coordinate space of the symbol into the coordinate space of the instance.
Public property | Visibility | The visibility. (Inherited from GeometryObject)
Top
See Also

Reference

GeometryInstance Class


GeometryInstance.SymbolGeometry Property

GeometryInstanceSymbolGeometry Property

The geometric representation of the symbol which generates this instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GeometryElement SymbolGeometry { get; }
Public ReadOnly Property SymbolGeometry As GeometryElement
    Get
public:
property GeometryElement^ SymbolGeometry {
    GeometryElement^ get ();
}
member SymbolGeometry : GeometryElement with get

Property Value

GeometryElement
Remarks
The geometry will be in the local coordinate space of the symbol. The context of this instance object (such as effective material) will be applied to the symbol. Note that retrieving the value of this property involves extensive parsing or Revit's data structures, so try to minimize calls if performance is critical. Geometry will be parsed with the same options as those used when this object was retrieved. The value of this property and the results of the method GetSymbolGeometry(void) are identical.
See Also

Reference

GeometryInstance Class


GeometryInstance.Transform Property

GeometryInstanceTransform Property

The affine transformation from the local coordinate space of the symbol into the coordinate space of the instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Transform Transform { get; }
Public ReadOnly Property Transform As Transform
    Get
public:
property Transform^ Transform {
    Transform^ get ();
}
member Transform : Transform with get

Property Value

Transform
Example
C#
VB
C++
F#
Copy
public void GetAndTransformCurve(Autodesk.Revit.ApplicationServices.Application app,
    Autodesk.Revit.DB.Element element, Options geoOptions)
{
    // Get geometry element of the selected element
    Autodesk.Revit.DB.GeometryElement geoElement = element.get_Geometry(geoOptions);

    // Get geometry object
    foreach (GeometryObject geoObject in geoElement)
    {
        // Get the geometry instance which contains the geometry information
       Autodesk.Revit.DB.GeometryInstance instance =
           geoObject as Autodesk.Revit.DB.GeometryInstance;
        if (null != instance)
        {
            foreach (GeometryObject o in instance.SymbolGeometry)
            {
                // Get curve
                Curve curve = o as Curve;
                if (curve != null)
                {
                    // transfrom the curve to make it in the instance's coordinate space
                    curve = curve.CreateTransformed(instance.Transform);
                }
            }
        }
    }
}
Public Sub GetAndTransformCurve(app As Autodesk.Revit.ApplicationServices.Application, element As Autodesk.Revit.DB.Element, geoOptions As Options)
    ' Get geometry element of the selected element
    Dim geoElement As Autodesk.Revit.DB.GeometryElement = element.Geometry(geoOptions)

    ' Get geometry object
    For Each geoObject As GeometryObject In geoElement
        ' Get the geometry instance which contains the geometry information
        Dim instance As Autodesk.Revit.DB.GeometryInstance = TryCast(geoObject, Autodesk.Revit.DB.GeometryInstance)
        If instance IsNot Nothing Then
            For Each o As GeometryObject In instance.SymbolGeometry
                ' Get curve
                Dim curve As Curve = TryCast(o, Curve)
                If curve IsNot Nothing Then
                    ' transfrom the curve to make it in the instance's coordinate space
                    curve = curve.CreateTransformed(instance.Transform)
                End If
            Next
        End If
    Next
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

GeometryInstance Class


GeometryInstance Methods

The GeometryInstance type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject)
Public method | GetDocument | Gets the document that contains the symbol of this instance.
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject)
Public method | GetInstanceGeometry | Computes the geometric representation of the instance.
Public method | GetInstanceGeometry(Transform) | Computes a transformation of the geometric representation of the instance.
Public method | GetSymbolGeometry | Computes the geometric representation of the symbol which generates this instance.
Public method | GetSymbolGeometry(Transform) | Computes a transformation of the geometric representation of the symbol which generates this instance.
Public method | GetSymbolGeometryId | Gets the SymbolGeometryId that contains data about the symbol of this instance.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

GeometryInstance Class


GeometryInstance.GetDocument Method

GeometryInstanceGetDocument Method

Gets the document that contains the symbol of this instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Document GetDocument()
Public Function GetDocument As Document
public:
Document^ GetDocument()
member GetDocument : unit -> Document

Return Value

Document
Returns the document that contains the symbol of this instance.
See Also

Reference

GeometryInstance Class


GeometryInstance.GetInstanceGeometry Method

GeometryInstanceGetInstanceGeometry Method

Overload List
 | Name | Description
Public method | GetInstanceGeometry | Computes the geometric representation of the instance.
Public method | GetInstanceGeometry(Transform) | Computes a transformation of the geometric representation of the instance.
Top
See Also

Reference

GeometryInstance Class


GeometryInstance.GetInstanceGeometry Method

GeometryInstanceGetInstanceGeometry Method

Computes the geometric representation of the instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GeometryElement GetInstanceGeometry()
Public Function GetInstanceGeometry As GeometryElement
public:
GeometryElement^ GetInstanceGeometry()
member GetInstanceGeometry : unit -> GeometryElement

Return Value

GeometryElement
An element which contains the computed geometry for the instance.
Remarks
The geometry will be in the coordinate system of the model that owns this instance. The context of the instance object (such as effective material) will be applied to the symbol. Note that this method involves extensive parsing or Revit's data structures, so try to minimize calls if performance is critical. Geometry will be parsed with the same options as those used when this object was retrieved. This method returns a copy of the Revit geometry. It is suitable for use in a tool which extracts geometry to another format or carries out a geometric analysis; however, because it returns a copy the references found in the geometry objects contained in this element are not suitable for creating new Revit elements referencing the original element (for example, dimensioning). Only the geometry returned by GetSymbolGeometry() with no transform can be used for that purpose.
See Also

Reference

GeometryInstance Class
GetInstanceGeometry Overload


GeometryInstance.GetInstanceGeometry(Transform) Method

GeometryInstanceGetInstanceGeometry(Transform) Method

Computes a transformation of the geometric representation of the instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GeometryElement GetInstanceGeometry(
    Transform transform
)
Public Function GetInstanceGeometry (
    transform As Transform
) As GeometryElement
public:
GeometryElement^ GetInstanceGeometry(
    Transform^ transform
)
member GetInstanceGeometry :
        transform : Transform -> GeometryElement

Parameters

transform Transform
The transformation to apply to the geometry.

Return Value

GeometryElement
An element which contains the computed geometry for the transformed instance.
Exceptions
Exception | Condition
ArgumentException | Transform is not conformal
Remarks
The context of the instance object (such as effective material) will be applied to the symbol. Note that this method involves extensive parsing or Revit's data structures, so try to minimize calls if performance is critical. Geometry will be parsed with the same options as those used when this object was retrieved. This method returns a copy of the Revit geometry. It is suitable for use in a tool which extracts geometry to another format or carries out a geometric analysis; however, because it returns a copy the references found in the geometry objects contained in this element are not suitable for creating new Revit elements referencing the original element (for example, dimensioning). Only the geometry returned by GetSymbolGeometry() with no transform can be used for that purpose.
See Also

Reference

GeometryInstance Class
GetInstanceGeometry Overload


GeometryInstance.GetSymbolGeometry Method

GeometryInstanceGetSymbolGeometry Method

Overload List
 | Name | Description
Public method | GetSymbolGeometry | Computes the geometric representation of the symbol which generates this instance.
Public method | GetSymbolGeometry(Transform) | Computes a transformation of the geometric representation of the symbol which generates this instance.
Top
See Also

Reference

GeometryInstance Class


GeometryInstance.GetSymbolGeometry Method

GeometryInstanceGetSymbolGeometry Method

Computes the geometric representation of the symbol which generates this instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GeometryElement GetSymbolGeometry()
Public Function GetSymbolGeometry As GeometryElement
public:
GeometryElement^ GetSymbolGeometry()
member GetSymbolGeometry : unit -> GeometryElement

Return Value

GeometryElement
An element which contains the computed geometry for the symbol.
Remarks
The geometry will be in the local coordinate space of the symbol. The context of this instance object (such as effective material) will be applied to the symbol. Note that this method involves extensive parsing or Revit's data structures, so try to minimize calls if performance is critical. Geometry will be parsed with the same options as those used when this object was retrieved. The results of the method and the value of the SymbolGeometry property are identical. This method returns the actual Revit geometry. Unlike other methods which extract transformed copies of the geometry, the return value of this method is suitable for creating new Revit elements referencing the original element (for example, dimensioning).
See Also

Reference

GeometryInstance Class
GetSymbolGeometry Overload


GeometryInstance.GetSymbolGeometry(Transform) Method

GeometryInstanceGetSymbolGeometry(Transform) Method

Computes a transformation of the geometric representation of the symbol which generates this instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GeometryElement GetSymbolGeometry(
    Transform transform
)
Public Function GetSymbolGeometry (
    transform As Transform
) As GeometryElement
public:
GeometryElement^ GetSymbolGeometry(
    Transform^ transform
)
member GetSymbolGeometry :
        transform : Transform -> GeometryElement

Parameters

transform Transform
The transformation to apply to the geometry.

Return Value

GeometryElement
An element which contains the computed geometry for the transformed symbol.
Exceptions
Exception | Condition
ArgumentException | Transform is not conformal
Remarks
The context of this instance object (such as effective material) will be applied to the symbol. Note that this method involves extensive parsing or Revit's data structures, so try to minimize calls if performance is critical. Geometry will be parsed with the same options as those used when this object was retrieved. This method returns a copy of the Revit geometry. It is suitable for use in a tool which extracts geometry to another format or carries out a geometric analysis; however, because it returns a copy the references found in the geometry objects contained in this element are not suitable for creating new Revit elements referencing the original element (for example, dimensioning). Only the geometry returned by GetSymbolGeometry() with no transform can be used for that purpose.
See Also

Reference

GeometryInstance Class
GetSymbolGeometry Overload


GeometryInstance.GetSymbolGeometryId Method

GeometryInstanceGetSymbolGeometryId Method

Gets the SymbolGeometryId that contains data about the symbol of this instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SymbolGeometryId GetSymbolGeometryId()
Public Function GetSymbolGeometryId As SymbolGeometryId
public:
SymbolGeometryId^ GetSymbolGeometryId()
member GetSymbolGeometryId : unit -> SymbolGeometryId

Return Value

SymbolGeometryId
Returns the SymbolGeometryId that contains data about the symbol of this instance.
Remarks
Use the strings returned by SymbolGeometryId.AsIdentifier(bool) to check if two GeometryInstance point to the same geometry of the symbol.
See Also

Reference

GeometryInstance Class


GeometryObject Class

The common base class for all geometric primitives.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGeometryObject
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GeometryObject : APIObject
Public Class GeometryObject
    Inherits APIObject
public ref class GeometryObject : public APIObject
type GeometryObject =
    class
        inherit APIObject
    end

The GeometryObject type exposes the following members.

Properties
 | Name | Description
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement.
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Visibility | The visibility.
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object))
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Overrides ObjectGetHashCode)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Operators
Name | Description
Equality(GeometryObject, GeometryObject) | Determines whether two GeometryObjects are the same.
Inequality(GeometryObject, GeometryObject) | Determines whether two GeometryObjects are different.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGeometryObject
Autodesk.Revit.DBCurve
Autodesk.Revit.DBEdge
Autodesk.Revit.DBFace
Autodesk.Revit.DBGeometryElement
Autodesk.Revit.DBGeometryInstance
Autodesk.Revit.DBMesh
Autodesk.Revit.DBPoint
Autodesk.Revit.DBPolyLine
Autodesk.Revit.DBProfile
Autodesk.Revit.DBSolid


GeometryObject Properties

The GeometryObject type exposes the following members.

Properties
 | Name | Description
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement.
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Visibility | The visibility.
Top
See Also

Reference

GeometryObject Class


GeometryObject.GraphicsStyleId Property

GeometryObjectGraphicsStyleId Property

The ElementId of the GeometryObject's GraphicsStyle

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GraphicsStyleId { get; }
Public ReadOnly Property GraphicsStyleId As ElementId
    Get
public:
property ElementId^ GraphicsStyleId {
    ElementId^ get ();
}
member GraphicsStyleId : ElementId with get

Property Value

ElementId
Remarks
This property provides the id of the GraphicsStyle assigned to the GeometryObject. This can be used to find the category of the object.
Example
C#
VB
C++
F#
Copy
// find the name of the GraphicsSytleCategory for every geometric primitive in a family instance
        Options options = app.Create.NewGeometryOptions();
        GeometryElement geomElem = element.get_Geometry(options);
        foreach (GeometryObject geomObj in geomElem)
        {
            GeometryInstance geomInst = geomObj as GeometryInstance;
            if (geomInst != null)
            {
                foreach (Object obj in geomInst.SymbolGeometry)
                {
                    GeometryObject geomObject = obj as GeometryObject;
                    GraphicsStyle gStyle = doc.GetElement(geomObject.GraphicsStyleId) as GraphicsStyle;
                    if (gStyle != null)
                    {
                        string gstyleName = gStyle.GraphicsStyleCategory.Name;
                    }
                }
            }
        }
' find the name of the GraphicsSytleCategory for every geometric primitive in a family instance
Dim options As Options = app.Create.NewGeometryOptions()
Dim geomElem As GeometryElement = element.Geometry(options)
For Each geomObj As GeometryObject In geomElem
    Dim geomInst As GeometryInstance = TryCast(geomObj, GeometryInstance)
    If geomInst IsNot Nothing Then
        For Each obj As [Object] In geomInst.SymbolGeometry
            Dim geomObject As GeometryObject = TryCast(obj, GeometryObject)
            Dim gStyle As GraphicsStyle = TryCast(doc.GetElement(geomObject.GraphicsStyleId), GraphicsStyle)
            If gStyle IsNot Nothing Then
                Dim gstyleName As String = gStyle.GraphicsStyleCategory.Name
            End If
        Next
    End If

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

GeometryObject Class


GeometryObject.Id Property

GeometryObjectId Property

A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Id { get; }
Public ReadOnly Property Id As Integer
    Get
public:
property int Id {
    int get ();
}
member Id : int with get

Property Value

Int32
Remarks
This id can be stored and used for future referencing. The reference should be stable between minor geometric changes and modifications, but may not remain valid if there are major changes to the element or its surroundings. Note that the id may be negative(and thus invalid for referencing) if obtained from view - specific geometry, or if obtained from most GeometryObjects created in memory by the API. Negative ids cannot be used for referencing. These integer ids should not be used for comparison purposes(other than to check if they are equivalent or not). Nothing should be assumed about rules about how an element populates the sequence of different numeric values as this may change based on the element's definition.
See Also

Reference

GeometryObject Class


GeometryObject.IsElementGeometry Property

GeometryObjectIsElementGeometry Property

Indicates whether this geometry is obtained directly from an Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsElementGeometry { get; }
Public ReadOnly Property IsElementGeometry As Boolean
    Get
public:
property bool IsElementGeometry {
    bool get ();
}
member IsElementGeometry : bool with get

Property Value

Boolean
See Also

Reference

GeometryObject Class


GeometryObject.Visibility Property

GeometryObjectVisibility Property

The visibility.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Visibility Visibility { get; set; }
Public Property Visibility As Visibility
    Get
    Set
public:
property Visibility Visibility {
    Visibility get ();
    void set (Visibility value);
}
member Visibility : Visibility with get, set

Property Value

Visibility
Remarks
The visibility of this object has no effect on the visibility of objects contained within this object. For example, the visibility of a Solid may be Contextual but the faces within that solid may still be Visible.
See Also

Reference

GeometryObject Class


GeometryObject Methods

The GeometryObject type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object))
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Overrides ObjectGetHashCode)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

GeometryObject Class


GeometryObject.Equals Method

GeometryObjectEquals Method

Determines whether the specified Object is equal to the current Object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj Object
Another object.

Return Value

Boolean
Remarks
This compares the internal identifiers of the geometry, and doesn't compare them geometrically.
See Also

Reference

GeometryObject Class


GeometryObject.GetHashCode Method

GeometryObjectGetHashCode Method

Gets the integer value of the geometry object as hash code

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Int32
See Also

Reference

GeometryObject Class


GeometryObject Operators

The GeometryObject type exposes the following members.

Operators
Name | Description
Equality(GeometryObject, GeometryObject) | Determines whether two GeometryObjects are the same.
Inequality(GeometryObject, GeometryObject) | Determines whether two GeometryObjects are different.
Top
See Also

Reference

GeometryObject Class


GeometryObject.Equality Operator

GeometryObjectEquality Operator

Determines whether two GeometryObjects are the same.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool operator ==(
    GeometryObject first,
    GeometryObject second
)
Public Shared Operator = (
    first As GeometryObject,
    second As GeometryObject
) As Boolean
public:
static bool operator ==(
    GeometryObject^ first,
    GeometryObject^ second
)
static let inline (=)
        first : GeometryObject *
        second : GeometryObject  : bool

Parameters

first GeometryObject
The first GeometryObject.
second GeometryObject
The second GeometryObject.

Return Value

Boolean
True if the GeometryObjects are the same; otherwise, false.
Remarks
This compares the internal identifiers of the geometry, and doesn't compare them geometrically.
See Also

Reference

GeometryObject Class


GeometryObject.Inequality Operator

GeometryObjectInequality Operator

Determines whether two GeometryObjects are different.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool operator !=(
    GeometryObject first,
    GeometryObject second
)
Public Shared Operator <> (
    first As GeometryObject,
    second As GeometryObject
) As Boolean
public:
static bool operator !=(
    GeometryObject^ first,
    GeometryObject^ second
)
static let inline (<>)
        first : GeometryObject *
        second : GeometryObject  : bool

Parameters

first GeometryObject
The first GeometryObject.
second GeometryObject
The second GeometryObject.

Return Value

Boolean
True if the GeometryObjects are different; otherwise, false.
Remarks
This compares the internal identifiers of the geometry, and doesn't compare them geometrically.
See Also

Reference

GeometryObject Class


GlobalParameter Class

This class represents a GlobalParameter element in Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBParameterElement
Autodesk.Revit.DBGlobalParameter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GlobalParameter : ParameterElement
Public Class GlobalParameter
    Inherits ParameterElement
public ref class GlobalParameter : public ParameterElement
type GlobalParameter =
    class
        inherit ParameterElement
    end

The GlobalParameter type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsDrivenByDimension | Indicates whether this parameter is driven by a dimension or not.
Public property | IsDrivenByFormula | Indicates whether this parameter is driven by a formula or not.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsReporting | Indicates whether this is a reporting global parameter or not.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanChangeReporting | Tests whether the global parameter permits a change of its current value of the IsReporting attribute.
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | CanLabelDimension | Tests whether a dimension can be labeled by the global parameter.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new Global Parameter in the given document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAffectedElements | Returns all elements of which properties are driven by this global parameter.
Public method | GetAffectedGlobalParameters | Returns all other global parameters which refer to this global parameter in their formulas.
 | GetDefinition | Get the definition representing this parameter element. (Inherited from ParameterElement)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFormula | Returns the parameter's expression in form of a string.
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLabeledDimensions | Returns all dimension elements that are currently labeled by this global parameter.
Public method | GetLabelName | Returns the name of this parameter's label, which is used to label dimension elements.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetValue | Obtains the curent value of the global parameter.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasValidTypeForReporting | Tests that the global parameter has data of a type that supports reporting.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidFormula | Tests that the given expression is a valid as formula for this parameter.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
 | LabelDimension | Labels a dimension with this global parameter.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
 | SetDrivingDimension | Set a dimension to drive the value of this parameter.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
 | SetFormula | Sets a formula expression for this parameter.
 | SetValue | Sets a new value of the global parameter.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UnlabelDimension | Unlabels a dimension that is currently labeled by this global parameter.
Top
Remarks

Global parameters can be used to drive values of dimensions or other elements' parameters. Also, a global parameter can be driven by a selected dimension, the value of which then determines the value of the global parameter. Such parameters can further be used to drive values of other elements' parameters.

See also the GlobalParametersManager class for methods that operate upon global parameters of a document, such as getting all defined global parameters and testing whether a global parameter of certain name already exists or not.

Reporting vs. Non-Reporting parameters

There are several ways global parameters can be categorized, but probably the most significant categorization stems from the IsReporting property which divides global parameters into two groups - Reporting and Non-Reporting. The significance of reporting parameters lays in the fact that their values are driven by the dimension that has been labeled by a reporting parameter. It means that the value of a reporting parameter reflects the value of a dimension (length or angle) and gets updated anytime the dimension changes. Non-Reporting parameters behave in the opposite manner - they drive value of dimensions that have been labeled by them, which results in controlling the model's geometry through global parameters' values.

Reporting parameters are limited in several ways. They can be only of Length or Angle type, a requirement due to the fact that a dimension must be able to drive the value. For the same reason reporting parameters may not have formulas.

Non-Reporting parameters, on the other way, can be of almost any type (Length, Integer, Area, etc.) with the exception of ElementId type. Also, Non-Reporting parameters may have assigned formulas in which other global parameters may be used as arguments. This way one global parameter's value can be derived from other parameter (or parameters), and the other parameter can be either reporting or non-reporting.

Creating Global Parameters

Global parameters get created via the static method Create(Document, String, ForgeTypeId). It is important to note that each new parameter must have a name that is unique within the document. Parameters are created as non-reporting initially, but programmers are free to modify the IsReporting property once a global parameter is created and is of an eligible type. The programmer can call the HasValidTypeForReporting when in doubt whether parameters of a certain data type can be made reporting. Note, that a parameter may not be made reporting after more than one dimension has been labeled by it. It is because reporting parameter can label (and be driven) by one dimension only.

An alternative way of making a parameter reporting is via the SetDrivingDimension(ElementId) method which labels one dimension by a global parameter and also makes the parameter reporting if it is not reporting yet.

Other important properties of global parameters are IsDrivenByDimension and IsDrivenByFormula, which are mutually exclusive - a parameter that has a formula assigned cannot be driven by a dimension (nor can be reporting) and vice versa.

Global Parameters with formulas

Like with family parameters, formulas may be assigned to non-reporting global parameters using the SetFormula(String) method (paired with GetFormula to query the current formula.) Formulas may include all standard arithmetic operations and logical operations (as functions and, or, not.) Input to logical operations must be Boolean values (parameters of YesNo type). Consequently, arithmetic operations can be applied to numeric values only. While there are no operations supported for string (text) arguments, strings can be used as results of a logical If operation. Depending on their type (and units), parameters of different value types can be combined. However, unit-less values such as Integer and Number (double) may only be combined with each other. Since formulas can get quite complicated, the method IsValidFormula(String) is available for the programmer to ensure a formula is valid in order to avoid potential exception due to applying an invalid formula.

Labeling dimensions

Probably the most notable feature of global parameters is their ability to "Label" dimensions, a process that establishes dependency of a dimension on a global parameter (or vice versa, depending on the reporting status.) One parameter can label any number of dimensions as long as the parameter is non-reporting. If the parameter labels a multi-segment dimension, values of all segments of this dimension will be equal to the parameter's value. As mentioned above, reporting parameter can label one dimension only, and this dimension can have only one segment. Methods and properties related to labeling include: LabelDimension(ElementId), UnlabelDimension(ElementId), and GetLabeledDimensions. Also in this set is the CanLabelDimension(ElementId) method which indicates whether or not a particular dimension can be labeled. Presently, only single linear dimensions and angles are permitted.

Elements affected by a Global Parameter

Global parameters can be associated with other global parameters as well as regular family instance parameters (which may report global parameters as their values via the assignment formula.) There are two methods available to find relations among parameters: GetAffectedGlobalParameters and GetAffectedElements. The former returns all other global parameters that refer to a particular global parameter in their respective formulas. The other method returns a set of all elements of which some parameters are controlled by the global parameter. These two methods together with the GetLabeledDimensions can help the programmer in figuring out how model elements relate to each other via global parameters.

Methods for maintaining associations between element properties and global parameters can be found in the Parameter class.

Getting and setting the value of a Global Parameter

All global parameters, formula-driven, dimension-driven, or independent, have values. A value can be obtained by calling the GetValue method. The object returned by that method is an instance of one of the classes derived from ParameterValue class. The concrete instance is determined by the type of the global parameter (specified upon creation.) Parameters that are neither formula-driven nor dimension-driven (reporting) can have a value assigned. The method to use is SetValue(ParameterValue) and it accepts the same type of ParameterValue that is returned by SetValue. However, the type can also be deduced easily: Text parameters accept only StringParameterValue. Integer and YesNo parameters accept only IntegerParameterValue. All other parameters accept only DoubleParameterValue.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


GlobalParameter Properties

The GlobalParameter type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsDrivenByDimension | Indicates whether this parameter is driven by a dimension or not.
Public property | IsDrivenByFormula | Indicates whether this parameter is driven by a formula or not.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsReporting | Indicates whether this is a reporting global parameter or not.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

GlobalParameter Class


GlobalParameter.IsDrivenByDimension Property

GlobalParameterIsDrivenByDimension Property

Indicates whether this parameter is driven by a dimension or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsDrivenByDimension { get; }
Public ReadOnly Property IsDrivenByDimension As Boolean
    Get
public:
property bool IsDrivenByDimension {
    bool get ();
}
member IsDrivenByDimension : bool with get

Property Value

Boolean
Remarks

Only reporting parameters can be driven by dimensions. Thus, to drive a parameter by a dimension, the parameter must first be set as reporting before it is used to label the driving dimension.

Note that the value of this property is always the opposite of the IsDrivenByFormula property. It is so because a parameter of which value is evaluated by a formula cannot be driven by a dimension, and vice versa.

See Also

Reference

GlobalParameter Class


GlobalParameter.IsDrivenByFormula Property

GlobalParameterIsDrivenByFormula Property

Indicates whether this parameter is driven by a formula or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsDrivenByFormula { get; }
Public ReadOnly Property IsDrivenByFormula As Boolean
    Get
public:
property bool IsDrivenByFormula {
    bool get ();
}
member IsDrivenByFormula : bool with get

Property Value

Boolean
Remarks

Note that the value of this property is always the opposite of the IsDrivenByDimension property. It is so because a parameter of which value is evaluated by a formula cannot be driven by a dimension, and vice versa.

See Also

Reference

GlobalParameter Class


GlobalParameter.IsReporting Property

GlobalParameterIsReporting Property

Indicates whether this is a reporting global parameter or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsReporting { get; set; }
Public Property IsReporting As Boolean
    Get
    Set
public:
property bool IsReporting {
    bool get ();
    void set (bool value);
}
member IsReporting : bool with get, set

Property Value

Boolean
True if the parameter is reporting, False otherwise.
Exceptions
Exception | Condition
ArgumentException | When setting this property: This is a formula-driven parameter. As such it does not allow the current operation. -or- When setting this property: This non-reporting global parameter has already labeled other dimensions (more then 1). It cannot, therefore, be made reporting and dimension-driven before un-labeling all the dependent dimensions first. -or- When setting this property: The global parameter is not of a type that may be used with reporting. Generally, a reporting parameter must be either of type Length or Angle. -or- When setting this property: Currently reporting parameters may not be changed if they are driven by a dimension that cannot have its value set by a global parameter, such as an arc-length, locked, or multi-segment dimension.
Remarks

When a global parameter is declared as reporting, it takes its value from the one driving dimension it is set to label. To be declared as reporting, a parameter must be labeling no more than one single-segment dimension. If a global parameter is not labeling any dimensions at the time it is declared as reporting, its value stays unchanged until a driving dimension is labeled with it.

Reporting parameters can be (currently) only of type Length or Angle, but programmers can always call the HasValidTypeForReporting first when in doubt about whether a global parameter has a data type eligible for reporting.

See Also

Reference

GlobalParameter Class


GlobalParameter Methods

The GlobalParameter type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanChangeReporting | Tests whether the global parameter permits a change of its current value of the IsReporting attribute.
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | CanLabelDimension | Tests whether a dimension can be labeled by the global parameter.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new Global Parameter in the given document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAffectedElements | Returns all elements of which properties are driven by this global parameter.
Public method | GetAffectedGlobalParameters | Returns all other global parameters which refer to this global parameter in their formulas.
 | GetDefinition | Get the definition representing this parameter element. (Inherited from ParameterElement)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFormula | Returns the parameter's expression in form of a string.
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLabeledDimensions | Returns all dimension elements that are currently labeled by this global parameter.
Public method | GetLabelName | Returns the name of this parameter's label, which is used to label dimension elements.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetValue | Obtains the curent value of the global parameter.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasValidTypeForReporting | Tests that the global parameter has data of a type that supports reporting.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidFormula | Tests that the given expression is a valid as formula for this parameter.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
 | LabelDimension | Labels a dimension with this global parameter.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
 | SetDrivingDimension | Set a dimension to drive the value of this parameter.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
 | SetFormula | Sets a formula expression for this parameter.
 | SetValue | Sets a new value of the global parameter.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UnlabelDimension | Unlabels a dimension that is currently labeled by this global parameter.
Top
See Also

Reference

GlobalParameter Class


GlobalParameter.CanChangeReporting Method

GlobalParameterCanChangeReporting Method

Tests whether the global parameter permits a change of its current value of the IsReporting attribute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanChangeReporting()
Public Function CanChangeReporting As Boolean
public:
bool CanChangeReporting()
member CanChangeReporting : unit -> bool

Return Value

Boolean
Returns True if the change is allowed; False otherwise.
See Also

Reference

GlobalParameter Class


GlobalParameter.CanLabelDimension Method

GlobalParameterCanLabelDimension Method

Tests whether a dimension can be labeled by the global parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanLabelDimension(
    ElementId dimensionId
)
Public Function CanLabelDimension (
    dimensionId As ElementId
) As Boolean
public:
bool CanLabelDimension(
    ElementId^ dimensionId
)
member CanLabelDimension :
        dimensionId : ElementId -> bool

Parameters

dimensionId ElementId
Id of a dimension element.

Return Value

Boolean
True of the input dimension can be labeled by this global parameter; False oterwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Possible causes include a dimension that cannot be labeled at all, or it is of other than Linear or Angular type, or does not have the appropriate labeling parameter. Another reason for this method returning False is that the data type of this global parameter is not suitable for labeling (i.e. it contains neither Length nor Angle value), or the parameter is reporting and the dimension has more than one segment.
See Also

Reference

GlobalParameter Class


GlobalParameter.Create Method

GlobalParameterCreate Method

Creates a new Global Parameter in the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static GlobalParameter Create(
    Document document,
    string name,
    ForgeTypeId specTypeId
)
Public Shared Function Create (
    document As Document,
    name As String,
    specTypeId As ForgeTypeId
) As GlobalParameter
public:
static GlobalParameter^ Create(
    Document^ document,
    String^ name,
    ForgeTypeId^ specTypeId
)
static member Create :
        document : Document *
        name : string *
        specTypeId : ForgeTypeId -> GlobalParameter

Parameters

document Document
Document in which the new parameter is to be created
name String
The name of the new parameter. It must be unique in the document
specTypeId ForgeTypeId
Identifier of the spec describing the parameter's data type.

Return Value

GlobalParameter
An instance of the new global parameter
Exceptions
Exception | Condition
ArgumentException | Global parameters are not supported in the given document. A possible cause is that it is not a project document, for global parameters are not supported in Revit families. -or- name is an empty string. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- A global parameter with the given name already exists in the document. -or- specTypeId is not a spec identifier.
ArgumentNullException | A non-optional argument was null
Remarks
Global parameters may be created only in Project documents, not in families.

Each global parameter must have a valid name that is unique within the document. To test whether a name is unique, use the IsUniqueName(Document, String) method.

While global parameters can be created with almost any type of data, there is a few types that are not currently supported, such as the ElementId type. Programmers can test whether a particular data type is appropriate for a global parameter by using the [!:SpecUtils.IsSpec(ForgeTypeId)] method.

Parameters are created as non-reporting initially, but programmers are free to modify the IsReporting property once a global parameter is created and happens to be of a type eligible for reporting.

See Also

Reference

GlobalParameter Class


GlobalParameter.GetAffectedElements Method

GlobalParameterGetAffectedElements Method

Returns all elements of which properties are driven by this global parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ISet<ElementId> GetAffectedElements()
Public Function GetAffectedElements As ISet(Of ElementId)
public:
ISet<ElementId^>^ GetAffectedElements()
member GetAffectedElements : unit -> ISet<ElementId>

Return Value

ISet ElementId
Collection of Element Ids.
Remarks
The returned collection does not include dimensions labeled by this global parameter. To get the labeled dimensions use the GetLabeledDimensions method. Other global parameters that may be affected by this one (in their formulas) are also excluded from the returned collection. To get the set of affected global parameters use the GetAffectedGlobalParameters method.
See Also

Reference

GlobalParameter Class


GlobalParameter.GetAffectedGlobalParameters Method

GlobalParameterGetAffectedGlobalParameters Method

Returns all other global parameters which refer to this global parameter in their formulas.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ISet<ElementId> GetAffectedGlobalParameters()
Public Function GetAffectedGlobalParameters As ISet(Of ElementId)
public:
ISet<ElementId^>^ GetAffectedGlobalParameters()
member GetAffectedGlobalParameters : unit -> ISet<ElementId>

Return Value

ISet ElementId
Collection of Element Ids.
Remarks
The method returns other global parameters that directly (in their formulas) refer to this parameter. For example, if P1 refers to P0 (e.g. [= 2.5 * P0]), and P2 refers to P1 (e.g. [= P1 + 3.14]), then the set of parameters affected directly by P0 would only contain one parameter - P1. Naturally, be using this method repeatedly, firts on P0 and then P1 (assuming the above example), the programmer can eventually collect all depending global parameters, whether they refer to P0 directly or indirectly.
See Also

Reference

GlobalParameter Class


GlobalParameter.GetFormula Method

GlobalParameterGetFormula Method

Returns the parameter's expression in form of a string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetFormula()
Public Function GetFormula As String
public:
String^ GetFormula()
member GetFormula : unit -> string

Return Value

String
The string representing the expression assigned to the parameter.
Remarks
Returns an empty string a case the parameter is not determined by a formula, or if the the expression cannot be converted to a string.
See Also

Reference

GlobalParameter Class


GlobalParameter.GetLabeledDimensions Method

GlobalParameterGetLabeledDimensions Method

Returns all dimension elements that are currently labeled by this global parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ISet<ElementId> GetLabeledDimensions()
Public Function GetLabeledDimensions As ISet(Of ElementId)
public:
ISet<ElementId^>^ GetLabeledDimensions()
member GetLabeledDimensions : unit -> ISet<ElementId>

Return Value

ISet ElementId
Collection of Element Ids.
Remarks
In case of a reporting parameter the returned collection will contain at most one element - the driving dimension, if it has been set already. It is because reporting parameters may have only one dimension labeled. For non-reporting parameters the set would contain all dimensions that have been labeled by this global parameter.
See Also

Reference

GlobalParameter Class


GlobalParameter.GetLabelName Method

GlobalParameterGetLabelName Method

Returns the name of this parameter's label, which is used to label dimension elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetLabelName()
Public Function GetLabelName As String
public:
String^ GetLabelName()
member GetLabelName : unit -> string

Return Value

String
The name of the parameter's label.
Remarks
Note that a Label equals a parameter's name if the parameters is non-reporting. Reporting parameters, however, have their labels suffixed by a special string to make it obvious the parameters is reporting (thus suitable to be driven by a dimension.)
See Also

Reference

GlobalParameter Class


GlobalParameter.GetValue Method

GlobalParameterGetValue Method

Obtains the curent value of the global parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ParameterValue GetValue()
Public Function GetValue As ParameterValue
public:
ParameterValue^ GetValue()
member GetValue : unit -> ParameterValue

Return Value

ParameterValue
An instance of one of the classes derived from the ParameterValue base class.
Remarks

Note that a value is always returned regardless of whether the parameter is formula-driven, or dimension-driven, or independent.

The returned ParameterValue is casted-up an instance of one of the derived classes, such as DoubleParameterValue or IntegerParameterValue.

See Also

Reference

GlobalParameter Class


GlobalParameter.HasValidTypeForReporting Method

GlobalParameterHasValidTypeForReporting Method

Tests that the global parameter has data of a type that supports reporting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasValidTypeForReporting()
Public Function HasValidTypeForReporting As Boolean
public:
bool HasValidTypeForReporting()
member HasValidTypeForReporting : unit -> bool

Return Value

Boolean
True if the parameter has data of a type that supports reporting; False otherwise.
Remarks
Only few data types can be used for reporting parmeters. Currently, reporting global parameters must be either of type Lenght or Angle - basically, they need to be value-driven by standard dimensions.
See Also

Reference

GlobalParameter Class


GlobalParameter.IsValidFormula Method

GlobalParameterIsValidFormula Method

Tests that the given expression is a valid as formula for this parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidFormula(
    string expression
)
Public Function IsValidFormula (
    expression As String
) As Boolean
public:
bool IsValidFormula(
    String^ expression
)
member IsValidFormula :
        expression : string -> bool

Parameters

expression String

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Use this method to test validity of a formula before assigning it to a global parameter when in doubt whether it is an acceptable expression or not.
See Also

Reference

GlobalParameter Class


GlobalParameter.LabelDimension Method

GlobalParameterLabelDimension Method

Labels a dimension with this global parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void LabelDimension(
    ElementId dimensionId
)
Public Sub LabelDimension (
    dimensionId As ElementId
)
public:
void LabelDimension(
    ElementId^ dimensionId
)
member LabelDimension :
        dimensionId : ElementId -> unit

Parameters

dimensionId ElementId
Id of a dimension element.
Exceptions
Exception | Condition
ArgumentException | Given element Id is not of a valid dimension element. -or- Dimension with the Id of dimensionId cannot be labeled by this global parameter. Possible causes include the dimension cannot be labeled at all, or it is a dimension of other than Linear or Angular type, or the Dimension object does not have the appropriate labeling parameter, or the dimension has more than one segment and the parameter is reporting.
ArgumentNullException | A non-optional argument was null
Remarks

When a dimension is labeled by a global parameters, then its value is either controlled by the parameter (non-reporting), or drives the value of the parameter (reporting). It is important to note that a reporting parameter can label at most one dimension object - meaning, a parameter can be driven by one dimension only. If the dimension has several segments and is labeled by a non-reprting parameter, the value of each segment will be driven by this parameter. Multi-segmented dimensions cannot be labeled by reporting parameters.

If the dimension is already labeled by another global parameter, labeling it again will automatically detach it from that parameter.

Presently, not just any kind of dimensions may be labeled by a global parameter. Typically only single Linear and Angular dimensions can be labeled, but there are other restrictions in effect too. Also, for the value of the parameter and dimension labeled by it depend on each other, the data type of the global parameters must be either Length or Angle, since those are the only units a dimension can represent. Refer to the [!:CanLabelDimension(Autodesk::Revit::DB::ElementId)] method to find out whether a particular dimension element may be labeled or not.

Example
C#
VB
C++
F#
Copy
/// <summary>
/// Creates a global parameter and uses it to label the set of given dimension elements
/// </summary>
/// <param name="document">Revit project document that contains the dimension.</param>
/// <param name="gpname">A name of the global parameter to create.</param>
/// <param name="value">Initial value of the global parameter</param>
/// <param name="dimset">A collection of dimension elements to drive by a global parameter</param>
/// <returns>Number of actually labeled dimension</returns>
public int DriveSelectedDimensions(Document document, string name, double value, ISet<ElementId> dimset)
{
    if (!GlobalParametersManager.AreGlobalParametersAllowed(document))
        throw new System.InvalidOperationException("Global parameters are not permitted in the given document");

    if (!GlobalParametersManager.IsUniqueName(document, name))
        throw new System.ArgumentException("Global parameter with such name already exists in the document", "name");

    if (value <= 0.0)
        throw new System.ArgumentException("Value of a global parameter that drives dimension must be a positive number", "value");

    int nLabeledDims = 0;   // number of labeled dimensions (for testing)

    // creation of any element must be in a transaction
    using (Transaction trans = new Transaction(document, "Create Global Parameter"))
    {
        trans.Start();

        // create a GP with the given name and type Length
        // Note: Length (or Angle) is required type of global parameters that are to label a dimension
        GlobalParameter newgp = GlobalParameter.Create(document, name, SpecTypeId.Length);
        if (newgp != null)
        {
            newgp.SetValue(new DoubleParameterValue(value));

            // use the parameter to label the given dimensions
            foreach (ElementId elemid in dimset)
            {
                // not just any dimension is allowed to be labeled
                // check first to avoid exceptions
                if (newgp.CanLabelDimension(elemid))
                {
                    newgp.LabelDimension(elemid);
                    nLabeledDims += 1;
                }
            }

            trans.Commit();
        }
    }

    // for illustration purposes only, we'll test the results of our modifications

    // 1.) Check the new parameter can be found

    ElementId gpid = GlobalParametersManager.FindByName(document,name);
    if (gpid == ElementId.InvalidElementId)
    {
        TaskDialog.Show("Error", "Failed to find a newly created global parameter");
    }

    GlobalParameter gp = document.GetElement(gpid) as GlobalParameter;

    // 2. Check the number of labeled dimension is as expected

    ISet<ElementId> labeledSet = gp.GetLabeledDimensions();
    if (labeledSet.Count != nLabeledDims)
    {
        TaskDialog.Show("Error", "Have not found all the dimension that were labeled.");
    }

    return labeledSet.Count;
}
' <summary>
' Creates a global parameter and uses it to label the set of given dimension elements
' </summary>
' <param name="document">Revit project document that contains the dimension.</param>
' <param name="gpname">A name of the global parameter to create.</param>
' <param name="value">Initial value of the global parameter</param>
' <param name="dimset">A collection of dimension elements to drive by a global parameter</param>
' <returns>Number of actually labeled dimension</returns>
Public Function DriveSelectedDimensions(document As Document, name As String, value As Double, dimset As ISet(Of ElementId)) As Integer
    If Not GlobalParametersManager.AreGlobalParametersAllowed(document) Then
        Throw New System.InvalidOperationException("Global parameters are not permitted in the given document")
    End If

    If Not GlobalParametersManager.IsUniqueName(document, name) Then
        Throw New System.ArgumentException("Global parameter with such name already exists in the document", "name")
    End If

    If value <= 0.0 Then
        Throw New System.ArgumentException("Value of a global parameter that drives dimension must be a positive number", "value")
    End If

    Dim nLabeledDims As Integer = 0
    ' number of labeled dimensions (for testing)
    ' creation of any element must be in a transaction
    Using trans As New Transaction(document, "Create Global Parameter")
        trans.Start()

    ' create a GP with the given name and type Length
    ' Note: Length (or Angle) is required type of global parameters that are to label a dimension
    Dim newgp As GlobalParameter = GlobalParameter.Create(document, name, SpecTypeId.Length)
    If newgp IsNot Nothing Then
            newgp.SetValue(New DoubleParameterValue(value))

            ' use the parameter to label the given dimensions
            For Each elemid As ElementId In dimset
                ' not just any dimension is allowed to be labeled
                ' check first to avoid exceptions
                If newgp.CanLabelDimension(elemid) Then
                    newgp.LabelDimension(elemid)
                    nLabeledDims += 1
                End If
            Next

            trans.Commit()
        End If
    End Using

    ' for illustration purposes only, we'll test the results of our modifications

    ' 1.) Check the new parameter can be found

    Dim gpid As ElementId = GlobalParametersManager.FindByName(document, name)
    If gpid = ElementId.InvalidElementId Then
        TaskDialog.Show("Error", "Failed to find a newly created global parameter")
    End If

    Dim gp As GlobalParameter = TryCast(document.GetElement(gpid), GlobalParameter)

    ' 2. Check the number of labeled dimension is as expected

    Dim labeledSet As ISet(Of ElementId) = gp.GetLabeledDimensions()
    If labeledSet.Count <> nLabeledDims Then
        TaskDialog.Show("Error", "Have not found all the dimension that were labeled.")
    End If

    Return labeledSet.Count
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

GlobalParameter Class


GlobalParameter.SetDrivingDimension Method

GlobalParameterSetDrivingDimension Method

Set a dimension to drive the value of this parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetDrivingDimension(
    ElementId dimensionId
)
Public Sub SetDrivingDimension (
    dimensionId As ElementId
)
public:
void SetDrivingDimension(
    ElementId^ dimensionId
)
member SetDrivingDimension :
        dimensionId : ElementId -> unit

Parameters

dimensionId ElementId
Id of a dimension element.
Exceptions
Exception | Condition
ArgumentException | Given element Id is not of a valid dimension element. -or- Dimension with the Id of dimensionId cannot be labeled by this global parameter. Possible causes include the dimension cannot be labeled at all, or it is a dimension of other than Linear or Angular type, or the Dimension object does not have the appropriate labeling parameter, or the dimension has more than one segment and the parameter is reporting.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This is a formula-driven parameter. As such it does not allow the current operation. -or- This non-reporting global parameter has already labeled other dimension segments (more then 1). It cannot, therefore, be made reporting and dimension-driven before un-labeling all the dependent dimensions first.
Remarks

This method is a combined action of two steps: a) Making the parameter reporting if it is not yet, and b) Labeling the given dimension with it. Because of that, the parameter must be eligible for reporting - i.e must be of certain types, and must not be used to label more than one dimensions yet.

In case this parameter is already driven by another dimension, the other dimension will be unlabeled first before the given one is labeled. It is because a reporting parameter can only label one dimension at a time (i.e. it can be driven by one dimension only.)

Example
C#
VB
C++
F#
Copy
/// <summary>
/// Make a global parameter to be driven by the value of a dimension.
/// </summary>
/// <param name="document">Revit project document containing the global parameter and dimension elements.</param>
/// <param name="gpid">ElementId of a global parameter.</param>
/// <param name="dimid">ElementId of a dimension element.</param>
public bool AssignDrivingDimension(Document document, ElementId gpid, ElementId dimid)
{
    // we expect to find the global parameter in the document
    GlobalParameter gp = document.GetElement(gpid) as GlobalParameter;
    if (gp == null)
        return false;

    // we expect to find the given dimension in the document
    Dimension dim = document.GetElement(dimid) as Dimension;
    if (dim == null)
        return false;

    // not every global parameter can label
    // and not every dimension can be labeled
    if (!gp.CanLabelDimension(dimid))
        return false;

    // we need a transaction to modify the model
    using (Transaction trans = new Transaction(document,"Assign a driving dimension"))
    {
        trans.Start();

        // we cannot assign a driving dimension to a global
        // parameter that is already used to label other dimensions
        ISet<ElementId> dimset = gp.GetLabeledDimensions();
        foreach (ElementId elemid in dimset)
        {
            gp.UnlabelDimension(elemid);
        }

        // with the GP free of all previously labels (if there were any)
        gp.SetDrivingDimension(dimid);

        // we should be able to commit, but we test the result anyway
        if (trans.Commit() != TransactionStatus.Committed)
            return false;
    }

    return true;
}
' <summary>
' Make a global parameter to be driven by the value of a dimension.
' </summary>
' <param name="document">Revit project document containing the global parameter and dimension elements.</param>
' <param name="gpid">ElementId of a global parameter.</param>
' <param name="dimid">ElementId of a dimension element.</param>
Public Function AssignDrivingDimension(document As Document, gpid As ElementId, dimid As ElementId) As Boolean
    ' we expect to find the global parameter in the document
    Dim gp As GlobalParameter = TryCast(document.GetElement(gpid), GlobalParameter)
    If gp Is Nothing Then
        Return False
    End If

    ' we expect to find the given dimension in the document
    Dim [dim] As Dimension = TryCast(document.GetElement(dimid), Dimension)
    If [dim] Is Nothing Then
        Return False
    End If

    ' not every global parameter can label
    ' and not every dimension can be labeled
    If Not gp.CanLabelDimension(dimid) Then
        Return False
    End If

    ' we need a transaction to modify the model
    Using trans As New Transaction(document, "Assign a driving dimension")
        trans.Start()

        ' we cannot assign a driving dimension to a global
        ' parameter that is already used to label other dimensions
        Dim dimset As ISet(Of ElementId) = gp.GetLabeledDimensions()
        For Each elemid As ElementId In dimset
            gp.UnlabelDimension(elemid)
        Next

        ' with the GP free of all previously labels (if there were any)
        gp.SetDrivingDimension(dimid)

        ' we should be able to commit, but we test the result anyway
        If trans.Commit() <> TransactionStatus.Committed Then
            Return False
        End If
    End Using

    Return True
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

GlobalParameter Class


GlobalParameter.SetFormula Method

GlobalParameterSetFormula Method

Sets a formula expression for this parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetFormula(
    string expression
)
Public Sub SetFormula (
    expression As String
)
public:
void SetFormula(
    String^ expression
)
member SetFormula :
        expression : string -> unit

Parameters

expression String
Valid formula string.
Exceptions
Exception | Condition
ArgumentException | The given expression argument is not valid as a formula for this parameter.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This is a non-reporting global parameter. As such it does not allow the current operation.
Remarks
An assigned expression will compute the parameter's actual value.

In order to set a formula, the global parameter must be non-reporting. Therefore a reporting parameter must be changed to non-reporting first before assigning a formula.

Value of the evaluated formula must be compatible with the value-type of the parameter. For example, it is permitted to use Integer parameters in a formula assigned to a Double (Number) parameter, or vice versa. It is not allowed, however, to use Length or Angle arguments in a formula in a parameter of which type is ether Integer or Number. To test whether a formula is valid for a global parameter, the method IsValidFormula(String) can be used.

An empty string can be used to remove an existing formula. When a formula is removed, the parameter retains its value as it was previously computed using the formula.

Formulas may include all standard arithmetic operations and logical operations (as functions and, or, not.) Input to logical operations must be Boolean values (parameters of YesNo type). Consequently, arithmetic operations can be applied to numeric values only. While there are no operations supported for string (text) arguments, strings can be used as results of a logical If operation.

Example
C#
VB
C++
F#
Copy
/// <summary>
/// Create global parameters and then set a formula to one so it has a value of
/// either of two other parameters depending on the boolean value of the forth one.
/// </summary>
/// <param name="document">Revit project document in which we create global parameters.</param>
public void SetCombinationParameters(Document document)
{
    GlobalParameter gpB = null;
    GlobalParameter gpT = null;
    GlobalParameter gpF = null;
    GlobalParameter gpX = null;

    int TRUE = 1;
    int FALSE = 0;

    // transaction to create global parameters and set their values
    using (Transaction trans = new Transaction(document, "Creating global parameters"))
    {
        // create 4 new global parameters

        trans.Start();

        gpB = GlobalParameter.Create(document, "GPB", SpecTypeId.Boolean.YesNo);
        gpT = GlobalParameter.Create(document, "GPT", SpecTypeId.String.Text);
        gpF = GlobalParameter.Create(document, "GPF", SpecTypeId.String.Text);
        gpX = GlobalParameter.Create(document, "GPX", SpecTypeId.String.Text);

        // assign initial values and a formula to the global parameters

        gpB.SetValue(new IntegerParameterValue(TRUE));
        gpT.SetValue(new StringParameterValue("TypeA"));
        gpF.SetValue(new StringParameterValue("TypeB"));

        // Set the formula to GPX so that its final value is either the value of GPT (TypeA)
        // or GPF (TypeB) depending on whether the value of GPB is True or False.
        // Note: in this particular case we are certain the formula is valid, but if weren't
        // certain, we could use a validation method as we are now going to illustrate here:
        string expression = "if(GPB,GPT,GPF)"; // XPX <== if (GPB == TRUE) then GPT else GPF
        if (gpX.IsValidFormula(expression))
        {
            gpX.SetFormula(expression);
        }

        trans.Commit();
    }

    // we can test that the formula works
    // since the boolean value is TRUE, the value of the GPX parameter
    // should be the same as the value of the GPT parameters

    StringParameterValue sTrue = gpT.GetValue() as StringParameterValue;
    StringParameterValue sFalse = gpF.GetValue() as StringParameterValue;
    StringParameterValue sValue = gpX.GetValue() as StringParameterValue;

    if (sValue.Value != sTrue.Value)
    {
        TaskDialog.Show("Error", "Unexpected value of a global parameter");
    }

    // we can also test that evaluation of the formula is affected by changes

    using (Transaction trans = new Transaction(document, "Change value of a YesNo parameter"))
    {
        trans.Start();
        gpB.SetValue(new IntegerParameterValue(FALSE));
        trans.Commit();
    }

    sValue = gpX.GetValue() as StringParameterValue;

    if (sValue.Value != sFalse.Value)
    {
        TaskDialog.Show("Error", "Unexpected value of a global parameter");
    }

}
' <summary>
' Create global parameters and then set a formula to one so it has a value of
' either of two other parameters depending on the boolean value of the forth one.
' </summary>
' <param name="document">Revit project document in which we create global parameters.</param>
Public Sub SetCombinationParameters(document As Document)
    Dim gpB As GlobalParameter = Nothing
    Dim gpT As GlobalParameter = Nothing
    Dim gpF As GlobalParameter = Nothing
    Dim gpX As GlobalParameter = Nothing

    Dim [TRUE] As Integer = 1
    Dim [FALSE] As Integer = 0

    ' transaction to create global parameters and set their values
    Using trans As New Transaction(document, "Creating global parameters")
        ' create 4 new global parameters

        trans.Start()

    gpB = GlobalParameter.Create(document, "GPB", SpecTypeId.Boolean.YesNo)
    gpT = GlobalParameter.Create(document, "GPT", SpecTypeId.String.Text)
    gpF = GlobalParameter.Create(document, "GPF", SpecTypeId.String.Text)
    gpX = GlobalParameter.Create(document, "GPX", SpecTypeId.String.Text)

    ' assign initial values and a formula to the global parameters

    gpB.SetValue(New IntegerParameterValue([TRUE]))
        gpT.SetValue(New StringParameterValue("TypeA"))
        gpF.SetValue(New StringParameterValue("TypeB"))

        ' Set the formula to GPX so that its final value is either the value of GPT (TypeA)
        ' or GPF (TypeB) depending on whether the value of GPB is True or False.
        ' Note: in this particular case we are certain the formula is valid, but if weren't
        ' certain, we could use a validation method as we are now going to illustrate here:
        Dim expression As String = "if(GPB,GPT,GPF)"
        ' XPX <== if (GPB == TRUE) then GPT else GPF
        If gpX.IsValidFormula(expression) Then
            gpX.SetFormula(expression)
        End If

        trans.Commit()
    End Using

    ' we can test that the formula works
    ' since the boolean value is TRUE, the value of the GPX parameter
    ' should be the same as the value of the GPT parameters

    Dim sTrue As StringParameterValue = TryCast(gpT.GetValue(), StringParameterValue)
    Dim sFalse As StringParameterValue = TryCast(gpF.GetValue(), StringParameterValue)
    Dim sValue As StringParameterValue = TryCast(gpX.GetValue(), StringParameterValue)

    If sValue.Value <> sTrue.Value Then
        TaskDialog.Show("Error", "Unexpected value of a global parameter")
    End If

    ' we can also test that evaluation of the formula is affected by changes

    Using trans As New Transaction(document, "Change value of a YesNo parameter")
        trans.Start()
        gpB.SetValue(New IntegerParameterValue([FALSE]))
        trans.Commit()
    End Using

    sValue = TryCast(gpX.GetValue(), StringParameterValue)

    If sValue.Value <> sFalse.Value Then
        TaskDialog.Show("Error", "Unexpected value of a global parameter")
    End If

End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

GlobalParameter Class


GlobalParameter.SetValue Method

GlobalParameterSetValue Method

Sets a new value of the global parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetValue(
    ParameterValue value
)
Public Sub SetValue (
    value As ParameterValue
)
public:
void SetValue(
    ParameterValue^ value
)
member SetValue :
        value : ParameterValue -> unit

Parameters

value ParameterValue
An instance of one of the value classes derived from ParameterValue.
Exceptions
Exception | Condition
ArgumentException | The given value argument is not a valid instance of ParameterValue! -or- The given parameter value arguments is not of the storage type the global parameter expects.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This is a formula-driven parameter. As such it does not allow the current operation. -or- This is a dimension-driven parameter. As such it does not allow the current operation.
Remarks

Note that a value can only be set for parameters that are neither formula-driven nor dimension-driven, as those have their values determined by evaluating the formula or by the dimension, respectively.

The argument this method accepts is of the same type of ParameterValue that is returned by GetValue. However, the type can also be easily deduced: Text parameters accept only StringParameterValue. Integer and YesNo parameters accept only IntegerParameterValue. All other types of parameters accept only DoubleParameterValue. Curiously, the actual value of a YesNo parameter can be only either 0 or 1.

Example
C#
VB
C++
F#
Copy
/// <summary>
/// Modifies values of certain types of global parameters so that
/// - integer values will be incremented by one
/// - double values will be multiplied by two
/// - boolean values will be negated
/// </summary>
/// <param name="document">Revit project document in which we create global parameters.</param>
/// <param name="gpset">A set of ElementIds of global parameter elements</param>
/// <returns>Number of actually modified values</returns>
public int ModifyGlobalParametersValues(Document document, ISet<ElementId> gpset)
{
    int nChangedValues = 0;     // number of values changed

    // we need a transaction to modify the model
    using (Transaction trans = new Transaction(document, "Change global parameters values"))
    {
        trans.Start();

        foreach(ElementId gpid in gpset)
        {
            // filter out element Ids that are not of a global parameters
            // (in production code, this would be an assert-able situation)
            if (!GlobalParametersManager.IsValidGlobalParameter(document, gpid))
                continue;

            // get the current value of the global parameter
            GlobalParameter gp = document.GetElement(gpid) as GlobalParameter;
            ParameterValue gpvalue = gp.GetValue();

            // test whether it is a Double or Integer
            if (gp.GetType() == typeof(DoubleParameterValue))
            {
                DoubleParameterValue dvalue = gpvalue as DoubleParameterValue;
                dvalue.Value *= 2.0;
                gp.SetValue(dvalue);
                nChangedValues += 1;
            }
            else if (gp.GetType() == typeof(IntegerParameterValue))
            {
                // Integer values may represent Boolean parameters too
                IntegerParameterValue ivalue = gpvalue as IntegerParameterValue;
                if (gp.GetDefinition().GetDataType() == SpecTypeId.Boolean.YesNo)
                {
                    ivalue.Value = (ivalue.Value == 0) ? 1 : 0;
                }
                else   // common integers
                {
                    ivalue.Value += 1;
                }
                gp.SetValue(ivalue);
                nChangedValues += 1;
            }
        }

        trans.Commit();
    }

    return nChangedValues;
}
' <summary>
' Modifies values of certain types of global parameters so that
' - integer values will be incremented by one
' - double values will be multiplied by two
' - boolean values will be negated
' </summary>
' <param name="document">Revit project document in which we create global parameters.</param>
' <param name="gpset">A set of ElementIds of global parameter elements</param>
' <returns>Number of actually modified values</returns>
Public Function ModifyGlobalParametersValues(document As Document, gpset As ISet(Of ElementId)) As Integer
    Dim nChangedValues As Integer = 0
    ' number of values changed
    ' we need a transaction to modify the model
    Using trans As New Transaction(document, "Change global parameters values")
        trans.Start()

        For Each gpid As ElementId In gpset
            ' filter out element Ids that are not of a global parameters
            ' (in production code, this would be an assert-able situation)
            If Not GlobalParametersManager.IsValidGlobalParameter(document, gpid) Then
                Continue For
            End If

            ' get the current value of the global parameter
            Dim gp As GlobalParameter = TryCast(document.GetElement(gpid), GlobalParameter)
            Dim gpvalue As ParameterValue = gp.GetValue()

            ' test whether it is a Double or Integer
            If gp.[GetType]() = GetType(DoubleParameterValue) Then
                Dim dvalue As DoubleParameterValue = TryCast(gpvalue, DoubleParameterValue)
                dvalue.Value *= 2.0
                gp.SetValue(dvalue)
                nChangedValues += 1
            ElseIf gp.[GetType]() = GetType(IntegerParameterValue) Then
                ' Integer values may represent Boolean parameters too
                Dim ivalue As IntegerParameterValue = TryCast(gpvalue, IntegerParameterValue)
          If gp.GetDefinition().GetDataType() = SpecTypeId.Boolean.YesNo Then
             ivalue.Value = If((ivalue.Value = 0), 1, 0)
          Else
             ' common integers
             ivalue.Value += 1
                End If
                gp.SetValue(ivalue)
                nChangedValues += 1
            End If
        Next

        trans.Commit()
    End Using

    Return nChangedValues
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

GlobalParameter Class


GlobalParameter.UnlabelDimension Method

GlobalParameterUnlabelDimension Method

Unlabels a dimension that is currently labeled by this global parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void UnlabelDimension(
    ElementId dimensionId
)
Public Sub UnlabelDimension (
    dimensionId As ElementId
)
public:
void UnlabelDimension(
    ElementId^ dimensionId
)
member UnlabelDimension :
        dimensionId : ElementId -> unit

Parameters

dimensionId ElementId
Id of a dimension element.
Exceptions
Exception | Condition
ArgumentException | Given element Id is not of a valid dimension element. -or- The given dimension (dimensionId) is not labeled by this global parameter.
ArgumentNullException | A non-optional argument was null
Remarks
It is assumed that the given dimension element is presently labeled by this parameter. If it is not, this method throws an exception.
See Also

Reference

GlobalParameter Class


GlobalParametersManager Class

A class to access and query information about global parameters in Revit models.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBGlobalParametersManager

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GlobalParametersManager : IDisposable
Public Class GlobalParametersManager
    Implements IDisposable
public ref class GlobalParametersManager : IDisposable
type GlobalParametersManager =
    class
        interface IDisposable
    end

The GlobalParametersManager type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
 | AreGlobalParametersAllowed | Tests whether global parameters are allowed in the given document.
Public method | Dispose | Releases all resources used by the GlobalParametersManager
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | FindByName | Finds whether a global parameter with the given name exists in the input document.
 | GetAllGlobalParameters | Returns all global parameters available in the given document.
 | GetGlobalParametersOrdered | Returns all global paramters in an ordered array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | IsUniqueName | Tests whether a name is unique among existing global parameters of a given document.
 | IsValidGlobalParameter | Tests whether an ElementId is of a global parameter in the given document.
 | MoveParameterDownOrder | Moves given paramerer Down in the current order.
 | MoveParameterUpOrder | Moves given paramerer Up in the current order.
 | SortParameters | Sorts global parameters in the desired order.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

This class provides access to general information and data of Global Parameter elements in a particular model. First of all, it is important to know that global parameters can be had in main project document; there are not supported in family documents. Availability of global parameters in a document can be tested by calling AreGlobalParametersAllowed(Document) method.

Global Parameter in a document can be obtained by calling either GetAllGlobalParameters(Document) or FindByName(Document, String). The former returns a set of all global parameters in the document, while the latter returns just the requested one, providing it exists.

Each global parameters must be created with a valid name that is unique in the scope of the document. To test whether a particular name is unique, programmer can use the IsUniqueName(Document, String) method.

More details about creating and manipulating global parameters can be found in the description of the GlobalParameter class.

Example
C#
VB
C++
F#
Copy
/// <summary>
/// Counts all global parameter elements defined in the given document.
/// </summary>
/// <param name="document">Revit project document.</param>
/// <returns>Total number of all global parameter elements in the document</returns>
public int CountAllGlobalParameters(Document document)
{
    // Global parameters are not available in all documents.
    // They are available in projects, but not in families.
    if (GlobalParametersManager.AreGlobalParametersAllowed(document))
    {
        return GlobalParametersManager.GetAllGlobalParameters(document).Count;
    }

    return 0;   // no global parameters in this document
}
' <summary>
' Counts all global parameter elements defined in the given document.
' </summary>
' <param name="document">Revit project document.</param>
' <returns>Total number of all global parameter elements in the document</returns>
Public Function CountAllGlobalParameters(document As Document) As Integer
    ' Global parameters are not available in all documents.
    ' They are available in projects, but not in families.
    If GlobalParametersManager.AreGlobalParametersAllowed(document) Then
        Return GlobalParametersManager.GetAllGlobalParameters(document).Count
    End If

    Return 0
    ' no global parameters in this document
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


GlobalParametersManager Properties

The GlobalParametersManager type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

GlobalParametersManager Class


GlobalParametersManager.IsValidObject Property

GlobalParametersManagerIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

GlobalParametersManager Class


GlobalParametersManager Methods

The GlobalParametersManager type exposes the following members.

Methods
 | Name | Description
 | AreGlobalParametersAllowed | Tests whether global parameters are allowed in the given document.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | FindByName | Finds whether a global parameter with the given name exists in the input document.
 | GetAllGlobalParameters | Returns all global parameters available in the given document.
 | GetGlobalParametersOrdered | Returns all global paramters in an ordered array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | IsUniqueName | Tests whether a name is unique among existing global parameters of a given document.
 | IsValidGlobalParameter | Tests whether an ElementId is of a global parameter in the given document.
 | MoveParameterDownOrder | Moves given paramerer Down in the current order.
 | MoveParameterUpOrder | Moves given paramerer Up in the current order.
 | SortParameters | Sorts global parameters in the desired order.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

GlobalParametersManager Class


GlobalParametersManager.AreGlobalParametersAllowed Method

GlobalParametersManagerAreGlobalParametersAllowed Method

Tests whether global parameters are allowed in the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool AreGlobalParametersAllowed(
    Document document
)
Public Shared Function AreGlobalParametersAllowed (
    document As Document
) As Boolean
public:
static bool AreGlobalParametersAllowed(
    Document^ document
)
static member AreGlobalParametersAllowed :
        document : Document -> bool

Parameters

document Document
A revit document of interest.

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
First of all, global parameters can be had in main project documents only; they are not supported in family documents. However, there may also be other circumstances due to which global parameters may be disallowed in a particular project, either temporarily or permanently.
Example
C#
VB
C++
F#
Copy
/// <summary>
/// Tests whether there are any global parameters present in the given document
/// </summary>
/// <param name="document">Revit project document.</param>
/// <returns>A set of ElementIds of global parameter elements</returns>
public bool ContainsGlobalParameters(Document document)
{
    // Global parameters are not available in all documents.
    // They are available in projects, but not in families.
    if (GlobalParametersManager.AreGlobalParametersAllowed(document))
    {
        return (GlobalParametersManager.GetAllGlobalParameters(document).Count > 0);
    }

    return false;
}
' <summary>
' Tests whether there are any global parameters present in the given document
' </summary>
' <param name="document">Revit project document.</param>
' <returns>A set of ElementIds of global parameter elements</returns>
Public Function ContainsGlobalParameters(document As Document) As Boolean
    ' Global parameters are not available in all documents.
    ' They are available in projects, but not in families.
    If GlobalParametersManager.AreGlobalParametersAllowed(document) Then
        Return (GlobalParametersManager.GetAllGlobalParameters(document).Count > 0)
    End If

    Return False
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

GlobalParametersManager Class


GlobalParametersManager.Dispose Method

GlobalParametersManagerDispose Method

Releases all resources used by the GlobalParametersManager

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

GlobalParametersManager Class


GlobalParametersManager.FindByName Method

GlobalParametersManagerFindByName Method

Finds whether a global parameter with the given name exists in the input document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ElementId FindByName(
    Document document,
    string name
)
Public Shared Function FindByName (
    document As Document,
    name As String
) As ElementId
public:
static ElementId^ FindByName(
    Document^ document,
    String^ name
)
static member FindByName :
        document : Document *
        name : string -> ElementId

Parameters

document Document
The document expected to contain the global parameter.
name String
Name of the global parameter

Return Value

ElementId
ElementId of the parameter element, or InvalidElementId if it was not found.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
No exception is thrown when no parameter with such a name exists in the document; instead, the method returns an ElementId.InvalidElementId.
Example
C#
VB
C++
F#
Copy
/// <summary>
/// Tries to find a global parameter by its name.
/// </summary>
/// <param name="document">Revit project document.</param>
/// <param name="name">Name of a global parameter.</param>
/// <returns>An Element Id of the global parameter, or InvalidElementId if none found</returns>
public ElementId GetGlobalParameterByName(Document document, String name)
{
    // Global parameters are not available in all documents.
    // They are available in projects, but not in families.
    if (GlobalParametersManager.AreGlobalParametersAllowed(document))
    {
        return GlobalParametersManager.FindByName(document, name);
    }

    // return an empty set if global parameters are not available in the document
    return ElementId.InvalidElementId;
}
' <summary>
' Tries to find a global parameter by its name.
' </summary>
' <param name="document">Revit project document.</param>
' <param name="name">Name of a global parameter.</param>
' <returns>An Element Id of the global parameter, or InvalidElementId if none found</returns>
Public Function GetGlobalParameterByName(document As Document, name As [String]) As ElementId
    ' Global parameters are not available in all documents.
    ' They are available in projects, but not in families.
    If GlobalParametersManager.AreGlobalParametersAllowed(document) Then
        Return GlobalParametersManager.FindByName(document, name)
    End If

    ' return an empty set if global parameters are not available in the document
    Return ElementId.InvalidElementId
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

GlobalParametersManager Class


GlobalParametersManager.GetAllGlobalParameters Method

GlobalParametersManagerGetAllGlobalParameters Method

Returns all global parameters available in the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ISet<ElementId> GetAllGlobalParameters(
    Document document
)
Public Shared Function GetAllGlobalParameters (
    document As Document
) As ISet(Of ElementId)
public:
static ISet<ElementId^>^ GetAllGlobalParameters(
    Document^ document
)
static member GetAllGlobalParameters :
        document : Document -> ISet<ElementId>

Parameters

document Document
The document containing the global parameters

Return Value

ISet ElementId
A collection of Element Ids of global parameter elements.
Exceptions
Exception | Condition
ArgumentException | Global parameters are not supported in the given document. A possible cause is that it is not a project document, for global parameters are not supported in Revit families.
ArgumentNullException | A non-optional argument was null
Example
C#
VB
C++
F#
Copy
/// <summary>
/// Returns all global parameter elements defined in the given document.
/// </summary>
/// <param name="document">Revit project document.</param>
/// <returns>A set of ElementIds of global parameter elements</returns>
public ISet<ElementId> GetAllGlobalParameters(Document document)
{
    // Global parameters are not available in all documents.
    // They are available in projects, but not in families.
    if (GlobalParametersManager.AreGlobalParametersAllowed(document))
    {
        return GlobalParametersManager.GetAllGlobalParameters(document);
    }

    // return an empty set if global parameters are not available in the document
    return new HashSet<ElementId>();
}
' <summary>
' Returns all global parameter elements defined in the given document.
' </summary>
' <param name="document">Revit project document.</param>
' <returns>A set of ElementIds of global parameter elements</returns>
Public Function GetAllGlobalParameters(document As Document) As ISet(Of ElementId)
    ' Global parameters are not available in all documents.
    ' They are available in projects, but not in families.
    If GlobalParametersManager.AreGlobalParametersAllowed(document) Then
        Return GlobalParametersManager.GetAllGlobalParameters(document)
    End If

    ' return an empty set if global parameters are not available in the document
    Return New HashSet(Of ElementId)()
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

GlobalParametersManager Class


GlobalParametersManager.GetGlobalParametersOrdered Method

GlobalParametersManagerGetGlobalParametersOrdered Method

Returns all global paramters in an ordered array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<ElementId> GetGlobalParametersOrdered(
    Document document
)
Public Shared Function GetGlobalParametersOrdered (
    document As Document
) As IList(Of ElementId)
public:
static IList<ElementId^>^ GetGlobalParametersOrdered(
    Document^ document
)
static member GetGlobalParametersOrdered :
        document : Document -> IList<ElementId>

Parameters

document Document
Document containing the requested global parameters

Return Value

IList ElementId
An array of Element Ids of all Global Parameters in the document.
Exceptions
Exception | Condition
ArgumentException | Global parameters are not supported in the given document. A possible cause is that it is not a project document, for global parameters are not supported in Revit families.
ArgumentNullException | A non-optional argument was null
Remarks

The order of the items coresponds to the order at which global parameters appear in Revit UI when shown in the standard Global Parameters dialog. However, the order of parameters is serialized in the document, thus available on the DB level as well.

See Also

Reference

GlobalParametersManager Class


GlobalParametersManager.IsUniqueName Method

GlobalParametersManagerIsUniqueName Method

Tests whether a name is unique among existing global parameters of a given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsUniqueName(
    Document document,
    string name
)
Public Shared Function IsUniqueName (
    document As Document,
    name As String
) As Boolean
public:
static bool IsUniqueName(
    Document^ document,
    String^ name
)
static member IsUniqueName :
        document : Document *
        name : string -> bool

Parameters

document Document
Document in which a new parameter is to be added.
name String
A name of a parameter being added.

Return Value

Boolean
True if the given %name% does not exist yet among existing global parameters nof the document; False otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Typically, this method is used before a new global parameters is created, for all global parameters must have their names unique in the scope of a document.
Example
C#
VB
C++
F#
Copy
/// <summary>
/// Creates or finds a global parameter of a given name.
/// </summary>
/// <param name="document">Revit project document.</param>
/// <param name="name">Name of a global parameter.</param>
/// <returns>An Element Id of the global parameter</returns>
public GlobalParameter GetOrCreateAGlobalParameter(Document document, String name)
{
    GlobalParameter gp = null;

    // Global parameters are not available in all documents.
    // They are available in projects, but not in families.
    if (GlobalParametersManager.AreGlobalParametersAllowed(document))
    {
        if (GlobalParametersManager.IsUniqueName(document,name))
        {
            // if the name is not unique, the global parameter must exist already
            gp = document.GetElement(GlobalParametersManager.FindByName(document, name)) as GlobalParameter;
        }
        else
        {
            // A global parameter with such a name does not exist yet;
            // Let's create a new one (assume the type is Number)
            using (Transaction trans = new Transaction(document, "Create Global Parameter"))
            {
                trans.Start();
                gp = GlobalParameter.Create(document,name, SpecTypeId.Number);
                trans.Commit();
            }
        }
    }

    return gp;
}
' <summary>
' Creates or finds a global parameter of a given name.
' </summary>
' <param name="document">Revit project document.</param>
' <param name="name">Name of a global parameter.</param>
' <returns>An Element Id of the global parameter</returns>
Public Function GetOrCreateAGlobalParameter(document As Document, name As [String]) As GlobalParameter
    Dim gp As GlobalParameter = Nothing

    ' Global parameters are not available in all documents.
    ' They are available in projects, but not in families.
    If GlobalParametersManager.AreGlobalParametersAllowed(document) Then
        If GlobalParametersManager.IsUniqueName(document, name) Then
            ' if the name is not unique, the global parameter must exist already
            gp = TryCast(document.GetElement(GlobalParametersManager.FindByName(document, name)), GlobalParameter)
        Else
            ' A global parameter with such a name does not exist yet;
            ' Let's create a new one (assume the type is Number)
            Using trans As New Transaction(document, "Create Global Parameter")
                trans.Start()
          gp = GlobalParameter.Create(document, name, SpecTypeId.Number)
          trans.Commit()
            End Using
        End If
    End If

    Return gp
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

GlobalParametersManager Class


GlobalParametersManager.IsValidGlobalParameter Method

GlobalParametersManagerIsValidGlobalParameter Method

Tests whether an ElementId is of a global parameter in the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidGlobalParameter(
    Document document,
    ElementId parameterId
)
Public Shared Function IsValidGlobalParameter (
    document As Document,
    parameterId As ElementId
) As Boolean
public:
static bool IsValidGlobalParameter(
    Document^ document,
    ElementId^ parameterId
)
static member IsValidGlobalParameter :
        document : Document *
        parameterId : ElementId -> bool

Parameters

document Document
The document containing the global parameter.
parameterId ElementId
Id of a global parameter

Return Value

Boolean
Returns True if the Id is of a valid global parameter; False otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

GlobalParametersManager Class


GlobalParametersManager.MoveParameterDownOrder Method

GlobalParametersManagerMoveParameterDownOrder Method

Moves given paramerer Down in the current order.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool MoveParameterDownOrder(
    Document document,
    ElementId parameterId
)
Public Shared Function MoveParameterDownOrder (
    document As Document,
    parameterId As ElementId
) As Boolean
public:
static bool MoveParameterDownOrder(
    Document^ document,
    ElementId^ parameterId
)
static member MoveParameterDownOrder :
        document : Document *
        parameterId : ElementId -> bool

Parameters

document Document
Document containing the give global parameter
parameterId ElementId
The parameter to move Down

Return Value

Boolean
Indicates whether the parameter could be moved Down in order or not.
Exceptions
Exception | Condition
ArgumentException | Global parameters are not supported in the given document. A possible cause is that it is not a project document, for global parameters are not supported in Revit families. -or- The input parameterId is not of a valid global parameter of the given document.
ArgumentNullException | A non-optional argument was null
Remarks

A parameter can only be moved within its parameter group, meaning that repeated moving a parameter will not push the parameter out of and into the next (in order) parameter group. When a parameter can no longer move because it is at the boundary of its group, this method returns False.

This operation has no effect on the global parameters themselves. The rearranged order is only visible in the standard Global Parameters dialog. However, the order of parameters is serialized in the document, thus available on the DB level as well.

See Also

Reference

GlobalParametersManager Class


GlobalParametersManager.MoveParameterUpOrder Method

GlobalParametersManagerMoveParameterUpOrder Method

Moves given paramerer Up in the current order.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool MoveParameterUpOrder(
    Document document,
    ElementId parameterId
)
Public Shared Function MoveParameterUpOrder (
    document As Document,
    parameterId As ElementId
) As Boolean
public:
static bool MoveParameterUpOrder(
    Document^ document,
    ElementId^ parameterId
)
static member MoveParameterUpOrder :
        document : Document *
        parameterId : ElementId -> bool

Parameters

document Document
Document containing the give global parameter
parameterId ElementId
The parameter to move up

Return Value

Boolean
Indicates whether the parameter could be moved Up in order or not.
Exceptions
Exception | Condition
ArgumentException | Global parameters are not supported in the given document. A possible cause is that it is not a project document, for global parameters are not supported in Revit families. -or- The input parameterId is not of a valid global parameter of the given document.
ArgumentNullException | A non-optional argument was null
Remarks

A parameter can only be moved within its parameter group, meaning that repeated moving a parameter will not push the parameter out of and into the next (in order) parameter group. When a parameter can no longer move because it is at the boundary of its group, this method returns False.

This operation has no effect on the global parameters themselves. The rearranged order is only visible in the standard Global Parameters dialog. However, the order of parameters is serialized in the document, thus available on the DB level as well.

See Also

Reference

GlobalParametersManager Class


GlobalParametersManager.SortParameters Method

GlobalParametersManagerSortParameters Method

Sorts global parameters in the desired order.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void SortParameters(
    Document document,
    ParametersOrder order
)
Public Shared Sub SortParameters (
    document As Document,
    order As ParametersOrder
)
public:
static void SortParameters(
    Document^ document,
    ParametersOrder order
)
static member SortParameters :
        document : Document *
        order : ParametersOrder -> unit

Parameters

document Document
Document containing the global parameters to be sorted
order ParametersOrder
Desired sorting order
Exceptions
Exception | Condition
ArgumentException | Global parameters are not supported in the given document. A possible cause is that it is not a project document, for global parameters are not supported in Revit families.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Remarks

All global parameters are sorted, but only within the range of their respective parameter group.

This operation has no effect on the global parameters themselves. The sorted order is only visible in the standard Global Parameters dialog. However, the order of parameters is serialized in the document, thus available on the DB level as well.

See Also

Reference

GlobalParametersManager Class


GradientBackgroundSettings Class

Represents the view gradient background settings.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBackgroundSettings
Autodesk.Revit.DBGradientBackgroundSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GradientBackgroundSettings : BackgroundSettings
Public Class GradientBackgroundSettings
    Inherits BackgroundSettings
public ref class GradientBackgroundSettings : public BackgroundSettings
type GradientBackgroundSettings =
    class
        inherit BackgroundSettings
    end

The GradientBackgroundSettings type exposes the following members.

Properties
 | Name | Description
Public property | GroundColor | The color of the ground.
Public property | HorizonColor | The color of the horizon.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BackgroundSettings)
Public property | SkyColor | The color of the top of the sky.
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from BackgroundSettings)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The colors of the background are interpolated for the pixels corresponding to the sky - from the "sky color" (top) to the "horizon color" (bottom). The ground is represented with a solid color ("ground color").
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


GradientBackgroundSettings Properties

The GradientBackgroundSettings type exposes the following members.

Properties
 | Name | Description
Public property | GroundColor | The color of the ground.
Public property | HorizonColor | The color of the horizon.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BackgroundSettings)
Public property | SkyColor | The color of the top of the sky.
Top
See Also

Reference

GradientBackgroundSettings Class


GradientBackgroundSettings.GroundColor Property

GradientBackgroundSettingsGroundColor Property

The color of the ground.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color GroundColor { get; set; }
Public Property GroundColor As Color
    Get
    Set
public:
property Color^ GroundColor {
    Color^ get ();
    void set (Color^ value);
}
member GroundColor : Color with get, set

Property Value

Color
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

GradientBackgroundSettings Class


GradientBackgroundSettings.HorizonColor Property

GradientBackgroundSettingsHorizonColor Property

The color of the horizon.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color HorizonColor { get; set; }
Public Property HorizonColor As Color
    Get
    Set
public:
property Color^ HorizonColor {
    Color^ get ();
    void set (Color^ value);
}
member HorizonColor : Color with get, set

Property Value

Color
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

GradientBackgroundSettings Class


GradientBackgroundSettings.SkyColor Property

GradientBackgroundSettingsSkyColor Property

The color of the top of the sky.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color SkyColor { get; set; }
Public Property SkyColor As Color
    Get
    Set
public:
property Color^ SkyColor {
    Color^ get ();
    void set (Color^ value);
}
member SkyColor : Color with get, set

Property Value

Color
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

GradientBackgroundSettings Class


GradientBackgroundSettings Methods

The GradientBackgroundSettings type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from BackgroundSettings)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

GradientBackgroundSettings Class


GraphicsStyle Class

The graphics style instance in Autodesk Revit document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBGraphicsStyle

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GraphicsStyle : Element
Public Class GraphicsStyle
    Inherits Element
public ref class GraphicsStyle : public Element
type GraphicsStyle =
    class
        inherit Element
    end

The GraphicsStyle type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GraphicsStyleCategory | The graphics style category.
Public property | GraphicsStyleType | The graphics style type.
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


GraphicsStyle Properties

The GraphicsStyle type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GraphicsStyleCategory | The graphics style category.
Public property | GraphicsStyleType | The graphics style type.
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

GraphicsStyle Class


GraphicsStyle.GraphicsStyleCategory Property

GraphicsStyleGraphicsStyleCategory Property

The graphics style category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Category GraphicsStyleCategory { get; }
Public ReadOnly Property GraphicsStyleCategory As Category
    Get
public:
property Category^ GraphicsStyleCategory {
    Category^ get ();
}
member GraphicsStyleCategory : Category with get

Property Value

Category
See Also

Reference

GraphicsStyle Class


GraphicsStyle.GraphicsStyleType Property

GraphicsStyleGraphicsStyleType Property

The graphics style type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GraphicsStyleType GraphicsStyleType { get; }
Public ReadOnly Property GraphicsStyleType As GraphicsStyleType
    Get
public:
property GraphicsStyleType GraphicsStyleType {
    GraphicsStyleType get ();
}
member GraphicsStyleType : GraphicsStyleType with get

Property Value

GraphicsStyleType
See Also

Reference

GraphicsStyle Class


GraphicsStyle Methods

The GraphicsStyle type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

GraphicsStyle Class


GraphicsStyleType Enumeration

Describes the type of graphics style.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum GraphicsStyleType
Public Enumeration GraphicsStyleType
public enum class GraphicsStyleType
type GraphicsStyleType
Members
Member name | Value | Description
Projection | 1 | Projection.
Cut | 2 | Cut.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Grid Class

Represents a single grid line within Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBDatumPlane
Autodesk.Revit.DBGrid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Grid : DatumPlane
Public Class Grid
    Inherits DatumPlane
public ref class Grid : public DatumPlane
type Grid =
    class
        inherit DatumPlane
    end

The Grid type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | Curve | Retrieves an object that represents the geometry of the grid line.
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsCurved | Identifies if the grid line is curved or straight.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | AddLeader | Adds a default Leader for the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders). (Inherited from DatumPlane)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanBeVisibleInView | Checks if the datum plane can be visible in the view. (Inherited from DatumPlane)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create(Document, Arc) | Creates a new radial grid line.
 | Create(Document, Line) | Creates a new grid line.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetCurvesInView | Gets a collection of curves representing the DatumPlane element in the given view. (Inherited from DatumPlane)
Public method | GetDatumExtentTypeInView | Identifies whether the curve representing the datum plane is displayed according to its actual 3d extents, or else according to a view specific setting. (Inherited from DatumPlane)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExtents | Gets the extents of the grid in the model.
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLeader | Gets a copy of the leader applied to the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders). (Inherited from DatumPlane)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPropagationViews | Gets a list of candidate views which are parallel to the current view and to which the extents of the datum may be propagated. (Inherited from DatumPlane)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasBubbleInView | Identifies if the DatumPlane has bubble or not. (Inherited from DatumPlane)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HideBubbleInView | Hides the bubble in a view. This method does not apply to Reference planes. (Inherited from DatumPlane)
Public method | IsBubbleVisibleInView | Identifies if the bubble is visible or not in a view. (Inherited from DatumPlane)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsCurveValidInView | Checks if the curve is valid to be as the extents for the datum plane in a view. The curve must be bound and coincident with the original one of the datum plane. (Inherited from DatumPlane)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsLeaderValid | Identifies if the leader valid or not for this DatumPlane. This method does not apply to Reference planes (which do not support leaders). (Inherited from DatumPlane)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | Maximize3DExtents | Computes the 3d extents of all model geometry and levels, and extends the 3d extents of this datum surface to include the model extents. (Inherited from DatumPlane)
Public method | PropagateToViews | Propagates the extents applied to this datum in the view to the specified parallel views. (Inherited from DatumPlane)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetCurveInView | Sets the extents to match the curve. (Inherited from DatumPlane)
Public method | SetDatumExtentType | Sets whether the curve representing the datum plane is displayed according to its 3d extents, or else according to a view specific setting. (Inherited from DatumPlane)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetLeader | Sets the leader to the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders). (Inherited from DatumPlane)
Public method | SetVerticalExtents | Adjusts the grid to extend through only the vertical range between bottom and top.
Public method | ShowBubbleInView | Shows the bubble in a view. This method does not apply to Reference planes. (Inherited from DatumPlane)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
A Grid is a DatumPlane, so it is actually a three dimensional surface. It can be either a plane parallel to the project z-axis, or else a cylinder whose axis is parallel to the project z-xis. [!:Autodesk::Revit::DatumPlane]
Example
C#
VB
C++
F#
Copy
public void GetInfo_Grid(Grid grid)
{
    string message = "Grid : ";

    // Show IsCurved property
    message += "\nIf grid is Arc : " + grid.IsCurved;

    // Show Curve information
    Autodesk.Revit.DB.Curve curve = grid.Curve;
    if (grid.IsCurved)
    {
        // if the curve is an arc, give center and radius information
        Autodesk.Revit.DB.Arc arc = curve as Autodesk.Revit.DB.Arc;
        message += "\nArc's radius: " + arc.Radius;
        message += "\nArc's center:  (" + XYZToString(arc.Center);
    }
    else
    {
        // if the curve is a line, give length information
        Autodesk.Revit.DB.Line line = curve as Autodesk.Revit.DB.Line;
        message += "\nLine's Length: " + line.Length;
    }
    // Get curve start point
    message += "\nStart point: " + XYZToString(curve.GetEndPoint(0));
    // Get curve end point
    message += "; End point: " + XYZToString(curve.GetEndPoint(0));

    TaskDialog.Show("Revit",message);
}

// output the point's three coordinates
string XYZToString(XYZ point)
{
    return "(" + point.X + ", " + point.Y + ", " + point.Z + ")";
}
Public Sub GetInfo_Grid(grid As Grid)
    Dim message As String = "Grid : "

    ' Show IsCurved property
    message += vbLf & "If grid is Arc : " & Convert.ToString(grid.IsCurved)

    ' Show Curve information
    Dim curve As Autodesk.Revit.DB.Curve = grid.Curve
    If grid.IsCurved Then
        ' if the curve is an arc, give center and radius information
        Dim arc As Autodesk.Revit.DB.Arc = TryCast(curve, Autodesk.Revit.DB.Arc)
        message += vbLf & "Arc's radius: " + arc.Radius
        message += vbLf & "Arc's center:  (" & XYZToString(arc.Center)
    Else
        ' if the curve is a line, give length information
        Dim line As Autodesk.Revit.DB.Line = TryCast(curve, Autodesk.Revit.DB.Line)
        message += vbLf & "Line's Length: " + line.Length
    End If
    ' Get curve start point
    message += vbLf & "Start point: " & XYZToString(curve.GetEndPoint(0))
    ' Get curve end point
    message += "; End point: " & XYZToString(curve.GetEndPoint(0))

    TaskDialog.Show("Revit", message)
End Sub

' output the point's three coordinates
Private Function XYZToString(point As XYZ) As String
    Return "(" & Convert.ToString(point.X) & ", " & Convert.ToString(point.Y) & ", " & Convert.ToString(point.Z) & ")"
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Grid Properties

The Grid type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | Curve | Retrieves an object that represents the geometry of the grid line.
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsCurved | Identifies if the grid line is curved or straight.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

Grid Class


Grid.Curve Property

GridCurve Property

Retrieves an object that represents the geometry of the grid line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Curve Curve { get; }
Public ReadOnly Property Curve As Curve
    Get
public:
property Curve^ Curve {
    Curve^ get ();
}
member Curve : Curve with get

Property Value

Curve
Remarks
The geometry can either be an arc or a curve. The IsCurved property can be used to determine this.
See Also

Reference

Grid Class


Grid.IsCurved Property

GridIsCurved Property

Identifies if the grid line is curved or straight.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCurved { get; }
Public ReadOnly Property IsCurved As Boolean
    Get
public:
property bool IsCurved {
    bool get ();
}
member IsCurved : bool with get

Property Value

Boolean
Remarks
A value of True is returned if the grid line is an arc or False if the grid line is straight. Use the Curve property to retrieve an object that represents the geometry of the grid line.
See Also

Reference

Grid Class


Grid Methods

The Grid type exposes the following members.

Methods
 | Name | Description
Public method | AddLeader | Adds a default Leader for the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders). (Inherited from DatumPlane)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanBeVisibleInView | Checks if the datum plane can be visible in the view. (Inherited from DatumPlane)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create(Document, Arc) | Creates a new radial grid line.
 | Create(Document, Line) | Creates a new grid line.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetCurvesInView | Gets a collection of curves representing the DatumPlane element in the given view. (Inherited from DatumPlane)
Public method | GetDatumExtentTypeInView | Identifies whether the curve representing the datum plane is displayed according to its actual 3d extents, or else according to a view specific setting. (Inherited from DatumPlane)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExtents | Gets the extents of the grid in the model.
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLeader | Gets a copy of the leader applied to the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders). (Inherited from DatumPlane)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPropagationViews | Gets a list of candidate views which are parallel to the current view and to which the extents of the datum may be propagated. (Inherited from DatumPlane)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasBubbleInView | Identifies if the DatumPlane has bubble or not. (Inherited from DatumPlane)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HideBubbleInView | Hides the bubble in a view. This method does not apply to Reference planes. (Inherited from DatumPlane)
Public method | IsBubbleVisibleInView | Identifies if the bubble is visible or not in a view. (Inherited from DatumPlane)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsCurveValidInView | Checks if the curve is valid to be as the extents for the datum plane in a view. The curve must be bound and coincident with the original one of the datum plane. (Inherited from DatumPlane)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsLeaderValid | Identifies if the leader valid or not for this DatumPlane. This method does not apply to Reference planes (which do not support leaders). (Inherited from DatumPlane)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | Maximize3DExtents | Computes the 3d extents of all model geometry and levels, and extends the 3d extents of this datum surface to include the model extents. (Inherited from DatumPlane)
Public method | PropagateToViews | Propagates the extents applied to this datum in the view to the specified parallel views. (Inherited from DatumPlane)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetCurveInView | Sets the extents to match the curve. (Inherited from DatumPlane)
Public method | SetDatumExtentType | Sets whether the curve representing the datum plane is displayed according to its 3d extents, or else according to a view specific setting. (Inherited from DatumPlane)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetLeader | Sets the leader to the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders). (Inherited from DatumPlane)
Public method | SetVerticalExtents | Adjusts the grid to extend through only the vertical range between bottom and top.
Public method | ShowBubbleInView | Shows the bubble in a view. This method does not apply to Reference planes. (Inherited from DatumPlane)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Grid Class


Grid.Create Method

GridCreate Method

Overload List
Name | Description
Create(Document, Arc) | Creates a new radial grid line.
Create(Document, Line) | Creates a new grid line.
Top
See Also

Reference

Grid Class


Grid.Create(Document, Arc) Method

GridCreate(Document, Arc) Method

Creates a new radial grid line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Grid Create(
    Document document,
    Arc arc
)
Public Shared Function Create (
    document As Document,
    arc As Arc
) As Grid
public:
static Grid^ Create(
    Document^ document,
    Arc^ arc
)
static member Create :
        document : Document *
        arc : Arc -> Grid

Parameters

document Document
The document in which the new instance is created.
arc Arc
An arc object that represents the location of the new grid line.

Return Value

Grid
The newly created grid line.
Exceptions
Exception | Condition
ArgumentException | document is not a project document. -or- The input arc is not on horizontal plane.
ArgumentNullException | A non-optional argument was null
Remarks
The arc should be on a horizontal plane.
Example
C#
VB
C++
F#
Copy
// Create the geometry arc which the grid locates
XYZ end0 = new XYZ(0, 0, 0);
XYZ end1 = new XYZ(10, 40, 0);
XYZ pointOnCurve = new XYZ(5, 7, 0);
Arc geomArc = Arc.Create(end0, end1, pointOnCurve);

// Create a grid using the geometry arc
Grid arcGrid = Grid.Create(document, geomArc);

if (null == arcGrid)
{
    throw new Exception("Create a new curved grid failed.");
}

// Modify the name of the created grid
arcGrid.Name = "New Name2";
   ' Create the geometry arc which the grid locates
   Dim end0 As New XYZ(0, 0, 0)
   Dim end1 As New XYZ(10, 40, 0)
   Dim pointOnCurve As New XYZ(5, 7, 0)
   Dim geomArc As Arc = Arc.Create(end0, end1, pointOnCurve)

   ' Create a grid using the geometry arc
Dim arcGrid As Grid = Grid.Create(document, geomArc)

   If arcGrid Is Nothing Then
       Throw New Exception("Create a new curved grid failed.")
   End If

   ' Modify the name of the created grid
   arcGrid.Name = "New Name2"

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Grid Class
Create Overload


Grid.Create(Document, Line) Method

GridCreate(Document, Line) Method

Creates a new grid line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Grid Create(
    Document document,
    Line line
)
Public Shared Function Create (
    document As Document,
    line As Line
) As Grid
public:
static Grid^ Create(
    Document^ document,
    Line^ line
)
static member Create :
        document : Document *
        line : Line -> Grid

Parameters

document Document
The document in which the new instance is created.
line Line
A line which represents the location of the grid line.

Return Value

Grid
The newly created grid line.
Exceptions
Exception | Condition
ArgumentException | document is not a project document. -or- The input line is not on horizontal plane.
ArgumentNullException | A non-optional argument was null
Remarks
The line should be on a horizontal plane.
Example
C#
VB
C++
F#
Copy
// Create the geometry line which the grid locates
 XYZ start = new XYZ(0, 0, 0);
 XYZ end = new XYZ(30, 30, 0);
 Line geomLine = Line.CreateBound(start, end);

 // Create a grid using the geometry line
 Grid lineGrid = Grid.Create(document, geomLine);

 if (null == lineGrid)
 {
     throw new Exception("Create a new straight grid failed.");
 }

 // Modify the name of the created grid
 lineGrid.Name = "New Name1";
   ' Create the geometry line which the grid locates
   Dim start As New XYZ(0, 0, 0)
   Dim [end] As New XYZ(30, 30, 0)
   Dim geomLine As Line = Line.CreateBound(start, [end])

   ' Create a grid using the geometry line
Dim lineGrid As Grid = Grid.Create(document, geomLine)

   If lineGrid Is Nothing Then
       Throw New Exception("Create a new straight grid failed.")
   End If

   ' Modify the name of the created grid
   lineGrid.Name = "New Name1"

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Grid Class
Create Overload


Grid.GetExtents Method

GridGetExtents Method

Gets the extents of the grid in the model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Outline GetExtents()
Public Function GetExtents As Outline
public:
Outline^ GetExtents()
member GetExtents : unit -> Outline

Return Value

Outline
The extents are the 3D bounding box surrounding the grid. The Z coordinates of the box are used by Revit to determine if the grid should be displayed in a corresponding view plan (if the grid is linear). The extents are not used for arc grids.
See Also

Reference

Grid Class


Grid.SetVerticalExtents Method

GridSetVerticalExtents Method

Adjusts the grid to extend through only the vertical range between bottom and top.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetVerticalExtents(
    double bottom,
    double top
)
Public Sub SetVerticalExtents (
    bottom As Double,
    top As Double
)
public:
void SetVerticalExtents(
    double bottom,
    double top
)
member SetVerticalExtents :
        bottom : float *
        top : float -> unit

Parameters

bottom Double
The bottom range of the grid extents. It must be a valid number and below the top range.
top Double
The top range of the grid extents. It must be a valid number and above the bottom range.
Exceptions
Exception | Condition
ArgumentException | The bottom and top ranges are reversed for the extents.
ArgumentOutOfRangeException | The given value for bottom must be no more than 30000 feet in absolute value. -or- The given value for top must be no more than 30000 feet in absolute value.
InvalidOperationException | Couldn't change the extents of the grid.
See Also

Reference

Grid Class


GridNode Structure

A structure that represents a particular location in (U,V) from a grid.
Inheritance Hierarchy
SystemObject
SystemValueType
Autodesk.Revit.DBGridNode

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public struct GridNode
Public Structure GridNode
public value class GridNode
[<SealedAttribute>]
type GridNode =
    struct
        inherit ValueType
    end

The GridNode type exposes the following members.

Constructors
 | Name | Description
Public method | GridNode | Initializes a new instance of the GridNode class
Top
Properties
 | Name | Description
Public property | UIndex | The node's index along the U axis.
Public property | VIndex | The node's index along the V axis.
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


GridNode Constructor

Initializes a new instance of the GridNode class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GridNode(
    int uIndex,
    int vIndex
)
Public Sub New (
    uIndex As Integer,
    vIndex As Integer
)
public:
GridNode(
    int uIndex,
    int vIndex
)
new :
        uIndex : int *
        vIndex : int -> GridNode

Parameters

uIndex Int32
vIndex Int32
See Also

Reference

GridNode Structure


GridNode Properties

The GridNode type exposes the following members.

Properties
 | Name | Description
Public property | UIndex | The node's index along the U axis.
Public property | VIndex | The node's index along the V axis.
Top
See Also

Reference

GridNode Structure


GridNode.UIndex Property

GridNodeUIndex Property

The node's index along the U axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int UIndex { get; set; }
Public Property UIndex As Integer
    Get
    Set
public:
property int UIndex {
    int get ();
    void set (int value);
}
member UIndex : int with get, set

Property Value

Int32
See Also

Reference

GridNode Structure


GridNode.VIndex Property

GridNodeVIndex Property

The node's index along the V axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int VIndex { get; set; }
Public Property VIndex As Integer
    Get
    Set
public:
property int VIndex {
    int get ();
    void set (int value);
}
member VIndex : int with get, set

Property Value

Int32
See Also

Reference

GridNode Structure


GridNode Methods

The GridNode type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType)
Top
See Also

Reference

GridNode Structure


GridNodeLocation Enumeration

Location of a grid node relative to the face boundary. See DividedSurface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum GridNodeLocation
Public Enumeration GridNodeLocation
public enum class GridNodeLocation
type GridNodeLocation
Members
Member name | Value | Description
Interior | 0 |
Boundary | 1 |
Exterior | 2 |
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


GridSegmentDirection Enumeration

Specify one of the four adjacent segments to a GridNode. See DividedSurface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum GridSegmentDirection
Public Enumeration GridSegmentDirection
public enum class GridSegmentDirection
type GridSegmentDirection
Members
Member name | Value | Description
PositiveU | 0 |
NegativeU | 1 |
PositiveV | 2 |
NegativeV | 3 |
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


GridType Class

An object that represents a grid type.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBLineAndTextAttrSymbol
Autodesk.Revit.DBGridType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GridType : LineAndTextAttrSymbol
Public Class GridType
    Inherits LineAndTextAttrSymbol
public ref class GridType : public LineAndTextAttrSymbol
type GridType =
    class
        inherit LineAndTextAttrSymbol
    end

The GridType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


GridType Properties

The GridType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

GridType Class


GridType Methods

The GridType type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

GridType Class


Group Class

An element representing a single instance of a group of elements that may be placed many times in a project or family.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBGroup

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Group : Element
Public Class Group
    Inherits Element
public ref class Group : public Element
type Group =
    class
        inherit Element
    end

The Group type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | AttachedParentId | Indicates the Id of the parent group this group is attached to.
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | GroupType | Get or set the type of the group.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsAttached | Indicates wether or not this group is attached to a parent group.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | Location | This property is used to find the physical location of a group within project. (Overrides ElementLocation)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAvailableAttachedDetailGroupTypeIds | Returns the attached detail groups available for this group type.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMemberIds | Retrieves all the member ElementIds of the group.
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetShownAttachedDetailGroupTypeIds | Returns the attached detail groups which have displayed instances for this group type in the input view.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HideAllAttachedDetailGroups | Hides all the available attached detail groups for this element group type that are compatible with the input view type.
Public method | HideAttachedDetailGroups | Hides the element group's attached detail groups of the input group type that are compatible with the input view.
Public method | IsCompatibleAttachedDetailGroupType | Checks if the orientation of the input attached detail group matches the input view's orientation.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ShowAllAttachedDetailGroups | Shows all the available attached detail groups for this element group type that are compatible with the input view type.
Public method | ShowAttachedDetailGroups | Shows the element group's attached detail groups of the input group type that are compatible with the input view.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UngroupMembers | Ungroups the group.
Top
Remarks
Grouping elements is useful when you need to create entities that represent repeating layouts or are common to many building projects, such as hotel rooms, apartments, or repeating floors.
Example
C#
VB
C++
F#
Copy
private void ShowGroupInformation(Autodesk.Revit.DB.Document document, Autodesk.Revit.DB.Element element)
{
    // Get group information for the selected element
    String prompt = null;
    if (element.GroupId.Equals(ElementId.InvalidElementId))
    {
        prompt = "The element isn't in any group.";
    }
    else
    {
       Autodesk.Revit.DB.Group group = document.GetElement(element.GroupId) as Autodesk.Revit.DB.Group;

        prompt = "The element " + element.Id.ToString() + " is in a group.";
        prompt += "\nThe group id is " + group.Id.ToString();
        prompt += "\nThe group's category is " + group.Category.Name;
        prompt += "\nAll group contained element ids are:";
        IList<ElementId> memberIds = group.GetMemberIds();
        foreach (ElementId id in memberIds)
        {
            prompt += "\n\t" + id.ToString();
        }
    }

    TaskDialog.Show("Revit",prompt);
}
Private Sub ShowGroupInformation(document As Autodesk.Revit.DB.Document, element As Autodesk.Revit.DB.Element)
    ' Get group information for the selected element
    Dim prompt As [String] = Nothing
    If element.GroupId.Equals(ElementId.InvalidElementId) Then
        prompt = "The element isn't in any group."
    Else
        Dim group As Autodesk.Revit.DB.Group = TryCast(document.GetElement(element.GroupId), Autodesk.Revit.DB.Group)

        prompt = "The element " & element.Id.ToString() & " is in a group."
        prompt += vbLf & "The group id is " + group.Id.ToString()
        prompt += vbLf & "The group's category is " + group.Category.Name
        prompt += vbLf & "All group contained element ids are:"
        Dim memberIds As IList(Of ElementId) = group.GetMemberIds()
        For Each id As ElementId In memberIds
            prompt += vbLf & vbTab + id.ToString()
        Next
    End If

    TaskDialog.Show("Revit", prompt)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

C#
VB
C++
F#
Copy
// Change the default group name to a new name �MyGroup�
group.GroupType.Name = "MyGroup";
' Change the default group name to a new name �MyGroup�
group.GroupType.Name = "MyGroup"

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

C#
VB
C++
F#
Copy
public void GetInfo_Group(Group group)
{
    string message = "Group : ";

    // Show the group type name
    message += "\nGroup type name is : " + group.GroupType.Name;

    // Show the name of the elements contained in the group
    message += "\nThe members contained in this group are:";
    IList<ElementId> groupMembers = group.GetMemberIds();
    foreach (ElementId memberId in groupMembers)
    {

        message += "\n\tGroup member id : " + memberId.ToString();
    }

    message += "\nAll member will now be removed from group.";
    group.UngroupMembers();

    TaskDialog.Show("Revit",message);
}
Public Sub GetInfo_Group(group As Group)
    Dim message As String = "Group : "

    ' Show the group type name
    message += vbLf & "Group type name is : " & Convert.ToString(group.GroupType.Name)

    ' Show the name of the elements contained in the group
    message += vbLf & "The members contained in this group are:"
    Dim groupMembers As IList(Of ElementId) = group.GetMemberIds()
    For Each memberId As ElementId In groupMembers

        message += vbLf & vbTab & "Group member id : " + memberId.ToString()
    Next

    message += vbLf & "All member will now be removed from group."
    group.UngroupMembers()

    TaskDialog.Show("Revit", message)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Group Properties

The Group type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | AttachedParentId | Indicates the Id of the parent group this group is attached to.
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | GroupType | Get or set the type of the group.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsAttached | Indicates wether or not this group is attached to a parent group.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | Location | This property is used to find the physical location of a group within project. (Overrides ElementLocation)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

Group Class


Group.AttachedParentId Property

GroupAttachedParentId Property

Indicates the Id of the parent group this group is attached to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId AttachedParentId { get; }
Public ReadOnly Property AttachedParentId As ElementId
    Get
public:
property ElementId^ AttachedParentId {
    ElementId^ get ();
}
member AttachedParentId : ElementId with get

Property Value

ElementId
See Also

Reference

Group Class


Group.GroupType Property

GroupGroupType Property

Get or set the type of the group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual GroupType GroupType { get; set; }
Public Overridable Property GroupType As GroupType
    Get
    Set
public:
virtual property GroupType^ GroupType {
    GroupType^ get ();
    void set (GroupType^ value);
}
abstract GroupType : GroupType with get, set
override GroupType : GroupType with get, set

Property Value

GroupType
Remarks
By setting this property the group can be swapped to a different kind of group.
See Also

Reference

Group Class


Group.IsAttached Property

GroupIsAttached Property

Indicates wether or not this group is attached to a parent group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsAttached { get; }
Public ReadOnly Property IsAttached As Boolean
    Get
public:
property bool IsAttached {
    bool get ();
}
member IsAttached : bool with get

Property Value

Boolean
See Also

Reference

Group Class


Group.Location Property

GroupLocation Property

This property is used to find the physical location of a group within project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Location Location { get; }
Public Overrides ReadOnly Property Location As Location
    Get
public:
virtual property Location^ Location {
    Location^ get () override;
}
abstract Location : Location with get
override Location : Location with get

Property Value

Location
Remarks
The Location property returns an object that can be used to find the location of an object within the project. Groups return a point location object.
See Also

Reference

Group Class


Group Methods

The Group type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAvailableAttachedDetailGroupTypeIds | Returns the attached detail groups available for this group type.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMemberIds | Retrieves all the member ElementIds of the group.
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetShownAttachedDetailGroupTypeIds | Returns the attached detail groups which have displayed instances for this group type in the input view.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HideAllAttachedDetailGroups | Hides all the available attached detail groups for this element group type that are compatible with the input view type.
Public method | HideAttachedDetailGroups | Hides the element group's attached detail groups of the input group type that are compatible with the input view.
Public method | IsCompatibleAttachedDetailGroupType | Checks if the orientation of the input attached detail group matches the input view's orientation.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ShowAllAttachedDetailGroups | Shows all the available attached detail groups for this element group type that are compatible with the input view type.
Public method | ShowAttachedDetailGroups | Shows the element group's attached detail groups of the input group type that are compatible with the input view.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UngroupMembers | Ungroups the group.
Top
See Also

Reference

Group Class


Group.GetAvailableAttachedDetailGroupTypeIds Method

GroupGetAvailableAttachedDetailGroupTypeIds Method

Returns the attached detail groups available for this group type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ISet<ElementId> GetAvailableAttachedDetailGroupTypeIds()
Public Function GetAvailableAttachedDetailGroupTypeIds As ISet(Of ElementId)
public:
ISet<ElementId^>^ GetAvailableAttachedDetailGroupTypeIds()
member GetAvailableAttachedDetailGroupTypeIds : unit -> ISet<ElementId>

Return Value

ISet ElementId
Returns the collection of attached detail group Ids that match this group's type.
Exceptions
Exception | Condition
InvalidOperationException | The input group is not a model group and can therefore not have attached detail groups.
See Also

Reference

Group Class


Group.GetMemberIds Method

GroupGetMemberIds Method

Retrieves all the member ElementIds of the group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ElementId> GetMemberIds()
Public Function GetMemberIds As IList(Of ElementId)
public:
IList<ElementId^>^ GetMemberIds()
member GetMemberIds : unit -> IList<ElementId>

Return Value

IList ElementId
An ordered list of the members within the group. The order of this list can be used to match members between other instances of the group.
See Also

Reference

Group Class


Group.GetShownAttachedDetailGroupTypeIds Method

GroupGetShownAttachedDetailGroupTypeIds Method

Returns the attached detail groups which have displayed instances for this group type in the input view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ISet<ElementId> GetShownAttachedDetailGroupTypeIds(
    View view
)
Public Function GetShownAttachedDetailGroupTypeIds (
    view As View
) As ISet(Of ElementId)
public:
ISet<ElementId^>^ GetShownAttachedDetailGroupTypeIds(
    View^ view
)
member GetShownAttachedDetailGroupTypeIds :
        view : View -> ISet<ElementId>

Parameters

view View
The view in which the attached detail groups are displayed.

Return Value

ISet ElementId
The collection of attached detail group Ids that match this group's type.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The input group is not a model group and can therefore not have attached detail groups.
See Also

Reference

Group Class


Group.HideAllAttachedDetailGroups Method

GroupHideAllAttachedDetailGroups Method

Hides all the available attached detail groups for this element group type that are compatible with the input view type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void HideAllAttachedDetailGroups(
    View view
)
Public Sub HideAllAttachedDetailGroups (
    view As View
)
public:
void HideAllAttachedDetailGroups(
    View^ view
)
member HideAllAttachedDetailGroups :
        view : View -> unit

Parameters

view View
The view that the attached detail groups must be compatible with.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The input group is not a model group and can therefore not have attached detail groups.
See Also

Reference

Group Class


Group.HideAttachedDetailGroups Method

GroupHideAttachedDetailGroups Method

Hides the element group's attached detail groups of the input group type that are compatible with the input view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void HideAttachedDetailGroups(
    View view,
    ElementId detailGroupTypeId
)
Public Sub HideAttachedDetailGroups (
    view As View,
    detailGroupTypeId As ElementId
)
public:
void HideAttachedDetailGroups(
    View^ view,
    ElementId^ detailGroupTypeId
)
member HideAttachedDetailGroups :
        view : View *
        detailGroupTypeId : ElementId -> unit

Parameters

view View
The view that the attached detail groups must be compatible with.
detailGroupTypeId ElementId
Only attached detail groups of this type will be hidden.
Exceptions
Exception | Condition
ArgumentException | The attached detail group detailGroupTypeId does not match the input view's orientation.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The input group is not a model group and can therefore not have attached detail groups.
See Also

Reference

Group Class


Group.IsCompatibleAttachedDetailGroupType Method

GroupIsCompatibleAttachedDetailGroupType Method

Checks if the orientation of the input attached detail group matches the input view's orientation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCompatibleAttachedDetailGroupType(
    View view,
    ElementId detailGroupTypeId
)
Public Function IsCompatibleAttachedDetailGroupType (
    view As View,
    detailGroupTypeId As ElementId
) As Boolean
public:
bool IsCompatibleAttachedDetailGroupType(
    View^ view,
    ElementId^ detailGroupTypeId
)
member IsCompatibleAttachedDetailGroupType :
        view : View *
        detailGroupTypeId : ElementId -> bool

Parameters

view View
The view that the input attached detail group must be compatible with.
detailGroupTypeId ElementId
The attached detail group that will be checked for compatibility with the input view.

Return Value

Boolean
Returns true if the input attached detail group is compatible with the input view and false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The input group is not a model group and can therefore not have attached detail groups.
Remarks
Currently, detail groups in perpendicular elevation views (for example, North and East views) are considered compatible. When showing these detail groups, an error (FailureMessage) based on id can be generated if the orientation of the annotations do not match the orientation of the target view (for example, the failure definition DimensionPerpendicularToView). To prevent displaying detail groups in the wrong view, you can check the OwnerViewId of a detail group to make sure it matches the view in which you are trying to display it.
See Also

Reference

Group Class


Group.ShowAllAttachedDetailGroups Method

GroupShowAllAttachedDetailGroups Method

Shows all the available attached detail groups for this element group type that are compatible with the input view type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ShowAllAttachedDetailGroups(
    View view
)
Public Sub ShowAllAttachedDetailGroups (
    view As View
)
public:
void ShowAllAttachedDetailGroups(
    View^ view
)
member ShowAllAttachedDetailGroups :
        view : View -> unit

Parameters

view View
The view that the attached detail groups must be compatible with.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The input group is not a model group and can therefore not have attached detail groups. -or- This exception is thrown if this group's attached detail groups cannot be found in the current document.
Remarks
Currently, perpendicular elevation views (for example, North and East views) are considered compatible when deciding whether or not to allow a detail group to be displayed in a view. The show operation may generate an error (FailureMessage) based on id if the orientation of the annotations do not match the orientation of the target view (for example, the failure definition DimensionPerpendicularToView). To prevent displaying detail groups in the wrong view, you can check the OwnerViewId of a detail group to make sure it matches the view in which you are trying to display it.
See Also

Reference

Group Class


Group.ShowAttachedDetailGroups Method

GroupShowAttachedDetailGroups Method

Shows the element group's attached detail groups of the input group type that are compatible with the input view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ShowAttachedDetailGroups(
    View view,
    ElementId detailGroupTypeId
)
Public Sub ShowAttachedDetailGroups (
    view As View,
    detailGroupTypeId As ElementId
)
public:
void ShowAttachedDetailGroups(
    View^ view,
    ElementId^ detailGroupTypeId
)
member ShowAttachedDetailGroups :
        view : View *
        detailGroupTypeId : ElementId -> unit

Parameters

view View
The view that the attached detail groups must be compatible with.
detailGroupTypeId ElementId
Only attached detail groups of this type will be shown.
Exceptions
Exception | Condition
ArgumentException | The attached detail group detailGroupTypeId does not match the input view's orientation.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The input group is not a model group and can therefore not have attached detail groups. -or- This exception is thrown if the input attached detail group cannot be found in the current document.
Remarks
Currently, perpendicular elevation views (for example, North and East views) are considered compatible when deciding whether or not to allow a detail group to be displayed in a view. The show operation may generate an error (FailureMessage) based on id if the orientation of the annotations do not match the orientation of the target view (for example, the failure definition DimensionPerpendicularToView). To prevent displaying detail groups in the wrong view, you can check the OwnerViewId of a detail group to make sure it matches the view in which you are trying to display it.
See Also

Reference

Group Class


Group.UngroupMembers Method

GroupUngroupMembers Method

Ungroups the group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> UngroupMembers()
Public Function UngroupMembers As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ UngroupMembers()
member UngroupMembers : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
If successful, the ids of the members of group are returned.
Exceptions
Exception | Condition
InvalidOperationException | Thrown if the group cannot be ungrouped.
Remarks
Removes all the members from the group and deletes the group. Note that the reference to this group object will become invalid once this method is called.
See Also

Reference

Group Class


GroupLoadOptions Class

A class containing options for loading a group from a file.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBGroupLoadOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GroupLoadOptions : IDisposable
Public Class GroupLoadOptions
    Implements IDisposable
public ref class GroupLoadOptions : IDisposable
type GroupLoadOptions =
    class
        interface IDisposable
    end

The GroupLoadOptions type exposes the following members.

Constructors
 | Name | Description
Public method | GroupLoadOptions | Creates a new instance of a GroupLoadOptions object.
Top
Properties
 | Name | Description
Public property | IncludeAttachedDetails | True if attached detail groups should be included, false otherwise. The default value is .
Public property | IncludeGrids | True if grids should be brought in from the input file, false otherwise. The default value is .
Public property | IncludeLevels | True if levels should be brought in from the input file, false otherwise. The default value is .
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ReplaceDuplicatedGroups | If there are groups with the same names in source and destination documents set this property to to replace existing groups, otherwise the operation will be canceled. The default value is .
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the GroupLoadOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetDuplicateTypeNamesHandler | Returns current duplicate type names handler or if none is set.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetDuplicateTypeNamesHandler | Sets a custom duplicate type names handler. If this value is not set, the default handler is used. By default, Revit displays a modal dialog with options to either copy new types only, or cancel the operation.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


GroupLoadOptions Constructor

Creates a new instance of a GroupLoadOptions object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GroupLoadOptions()
Public Sub New
public:
GroupLoadOptions()
new : unit -> GroupLoadOptions
See Also

Reference

GroupLoadOptions Class


GroupLoadOptions Properties

The GroupLoadOptions type exposes the following members.

Properties
 | Name | Description
Public property | IncludeAttachedDetails | True if attached detail groups should be included, false otherwise. The default value is .
Public property | IncludeGrids | True if grids should be brought in from the input file, false otherwise. The default value is .
Public property | IncludeLevels | True if levels should be brought in from the input file, false otherwise. The default value is .
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ReplaceDuplicatedGroups | If there are groups with the same names in source and destination documents set this property to to replace existing groups, otherwise the operation will be canceled. The default value is .
Top
See Also

Reference

GroupLoadOptions Class


GroupLoadOptions.IncludeAttachedDetails Property

GroupLoadOptionsIncludeAttachedDetails Property

True if attached detail groups should be included, false otherwise. The default value is .

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IncludeAttachedDetails { get; set; }
Public Property IncludeAttachedDetails As Boolean
    Get
    Set
public:
property bool IncludeAttachedDetails {
    bool get ();
    void set (bool value);
}
member IncludeAttachedDetails : bool with get, set

Property Value

Boolean
See Also

Reference

GroupLoadOptions Class


GroupLoadOptions.IncludeGrids Property

GroupLoadOptionsIncludeGrids Property

True if grids should be brought in from the input file, false otherwise. The default value is .

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IncludeGrids { get; set; }
Public Property IncludeGrids As Boolean
    Get
    Set
public:
property bool IncludeGrids {
    bool get ();
    void set (bool value);
}
member IncludeGrids : bool with get, set

Property Value

Boolean
See Also

Reference

GroupLoadOptions Class


GroupLoadOptions.IncludeLevels Property

GroupLoadOptionsIncludeLevels Property

True if levels should be brought in from the input file, false otherwise. The default value is .

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IncludeLevels { get; set; }
Public Property IncludeLevels As Boolean
    Get
    Set
public:
property bool IncludeLevels {
    bool get ();
    void set (bool value);
}
member IncludeLevels : bool with get, set

Property Value

Boolean
See Also

Reference

GroupLoadOptions Class


GroupLoadOptions.IsValidObject Property

GroupLoadOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

GroupLoadOptions Class


GroupLoadOptions.ReplaceDuplicatedGroups Property

GroupLoadOptionsReplaceDuplicatedGroups Property

If there are groups with the same names in source and destination documents set this property to to replace existing groups, otherwise the operation will be canceled. The default value is .

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ReplaceDuplicatedGroups { get; set; }
Public Property ReplaceDuplicatedGroups As Boolean
    Get
    Set
public:
property bool ReplaceDuplicatedGroups {
    bool get ();
    void set (bool value);
}
member ReplaceDuplicatedGroups : bool with get, set

Property Value

Boolean
See Also

Reference

GroupLoadOptions Class


GroupLoadOptions Methods

The GroupLoadOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetDuplicateTypeNamesHandler | Returns current duplicate type names handler or if none is set.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetDuplicateTypeNamesHandler | Sets a custom duplicate type names handler. If this value is not set, the default handler is used. By default, Revit displays a modal dialog with options to either copy new types only, or cancel the operation.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

GroupLoadOptions Class


GroupLoadOptions.Dispose Method

GroupLoadOptionsDispose Method

Releases all resources used by the GroupLoadOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

GroupLoadOptions Class


GroupLoadOptions.GetDuplicateTypeNamesHandler Method

GroupLoadOptionsGetDuplicateTypeNamesHandler Method

Returns current duplicate type names handler or if none is set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IDuplicateTypeNamesHandler GetDuplicateTypeNamesHandler()
Public Function GetDuplicateTypeNamesHandler As IDuplicateTypeNamesHandler
public:
IDuplicateTypeNamesHandler^ GetDuplicateTypeNamesHandler()
member GetDuplicateTypeNamesHandler : unit -> IDuplicateTypeNamesHandler

Return Value

IDuplicateTypeNamesHandler
See Also

Reference

GroupLoadOptions Class


GroupLoadOptions.SetDuplicateTypeNamesHandler Method

GroupLoadOptionsSetDuplicateTypeNamesHandler Method

Sets a custom duplicate type names handler. If this value is not set, the default handler is used. By default, Revit displays a modal dialog with options to either copy new types only, or cancel the operation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetDuplicateTypeNamesHandler(
    IDuplicateTypeNamesHandler handler
)
Public Sub SetDuplicateTypeNamesHandler (
    handler As IDuplicateTypeNamesHandler
)
public:
void SetDuplicateTypeNamesHandler(
    IDuplicateTypeNamesHandler^ handler
)
member SetDuplicateTypeNamesHandler :
        handler : IDuplicateTypeNamesHandler -> unit

Parameters

handler IDuplicateTypeNamesHandler
The duplicate type names handler.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

GroupLoadOptions Class


GroupNode Class

A node that represents set of individual elements grouped together in some form, such as an instance of a family or linked Revit file, or an instance of a part of symbol's geometry.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRenderNode
Autodesk.Revit.DBGroupNode
Autodesk.Revit.DBInstanceNode
Autodesk.Revit.DBLinkNode

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GroupNode : RenderNode
Public Class GroupNode
    Inherits RenderNode
public ref class GroupNode : public RenderNode
type GroupNode =
    class
        inherit RenderNode
    end

The GroupNode type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode)
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from RenderNode)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetTransform | A transformation matrix associated with the node.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


GroupNode Properties

The GroupNode type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode)
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode)
Top
See Also

Reference

GroupNode Class


GroupNode Methods

The GroupNode type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from RenderNode)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetTransform | A transformation matrix associated with the node.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

GroupNode Class


GroupNode.GetTransform Method

GroupNodeGetTransform Method

A transformation matrix associated with the node.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Transform GetTransform()
Public Function GetTransform As Transform
public:
Transform^ GetTransform()
member GetTransform : unit -> Transform

Return Value

Transform
See Also

Reference

GroupNode Class


GroupSet Class

An set that contains groups.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGroupSet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GroupSet : APIObject, IEnumerable
Public Class GroupSet
    Inherits APIObject
    Implements IEnumerable
public ref class GroupSet : public APIObject,
    IEnumerable
type GroupSet =
    class
        inherit APIObject
        interface IEnumerable
    end

The GroupSet type exposes the following members.

Constructors
 | Name | Description
Public method | GroupSet | Initializes a new instance of the GroupSet class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Size | Returns the number of groups that are in the set.
Top
Methods
 | Name | Description
Public method | Clear | Removes every group from the set, rendering it empty.
Public method | Contains | Tests for the existence of a group within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase | Removes a specified group from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified group into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


GroupSet Constructor

Initializes a new instance of the GroupSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GroupSet()
Public Sub New
public:
GroupSet()
new : unit -> GroupSet
See Also

Reference

GroupSet Class


GroupSet Properties

The GroupSet type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Size | Returns the number of groups that are in the set.
Top
See Also

Reference

GroupSet Class


GroupSet.IsEmpty Property

GroupSetIsEmpty Property

Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Boolean
Remarks
If the set is empty then True will be returned, otherwise False.
See Also

Reference

GroupSet Class


GroupSet.Size Property

GroupSetSize Property

Returns the number of groups that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
abstract Size : int with get
override Size : int with get

Property Value

Int32
See Also

Reference

GroupSet Class


GroupSet Methods

The GroupSet type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Removes every group from the set, rendering it empty.
Public method | Contains | Tests for the existence of a group within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase | Removes a specified group from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified group into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

GroupSet Class


GroupSet.Clear Method

GroupSetClear Method

Removes every group from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

GroupSet Class


GroupSet.Contains Method

GroupSetContains Method

Tests for the existence of a group within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Contains(
    Group item
)
Public Overridable Function Contains (
    item As Group
) As Boolean
public:
virtual bool Contains(
    Group^ item
)
abstract Contains :
        item : Group -> bool
override Contains :
        item : Group -> bool

Parameters

item Group
The group to be searched for.

Return Value

Boolean
The Contains method returns True if the group is within the set, otherwise False.
See Also

Reference

GroupSet Class


GroupSet.Erase Method

GroupSetErase Method

Removes a specified group from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Erase(
    Group item
)
Public Overridable Function Erase (
    item As Group
) As Integer
public:
virtual int Erase(
    Group^ item
)
abstract Erase :
        item : Group -> int
override Erase :
        item : Group -> int

Parameters

item Group
The group to be erased.

Return Value

Int32
The number of groups that were erased from the set.
See Also

Reference

GroupSet Class


GroupSet.ForwardIterator Method

GroupSetForwardIterator Method

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual GroupSetIterator ForwardIterator()
Public Overridable Function ForwardIterator As GroupSetIterator
public:
virtual GroupSetIterator^ ForwardIterator()
abstract ForwardIterator : unit -> GroupSetIterator
override ForwardIterator : unit -> GroupSetIterator

Return Value

GroupSetIterator
Returns a forward moving iterator to the set.
See Also

Reference

GroupSet Class


GroupSet.GetEnumerator Method

GroupSetGetEnumerator Method

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

IEnumerator
Returns a forward moving iterator to the set.

Implements

IEnumerableGetEnumerator
See Also

Reference

GroupSet Class


GroupSet.Insert Method

GroupSetInsert Method

Insert the specified group into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Insert(
    Group item
)
Public Overridable Function Insert (
    item As Group
) As Boolean
public:
virtual bool Insert(
    Group^ item
)
abstract Insert :
        item : Group -> bool
override Insert :
        item : Group -> bool

Parameters

item Group
The group to be inserted into the set.

Return Value

Boolean
Returns whether the group was inserted into the set.
See Also

Reference

GroupSet Class


GroupSet.ReverseIterator Method

GroupSetReverseIterator Method

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual GroupSetIterator ReverseIterator()
Public Overridable Function ReverseIterator As GroupSetIterator
public:
virtual GroupSetIterator^ ReverseIterator()
abstract ReverseIterator : unit -> GroupSetIterator
override ReverseIterator : unit -> GroupSetIterator

Return Value

GroupSetIterator
Returns a backward moving iterator to the set.
See Also

Reference

GroupSet Class


GroupSetIterator Class

An iterator to a group set.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGroupSetIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class GroupSetIterator : APIObject,
    IEnumerator
Public MustInherit Class GroupSetIterator
    Inherits APIObject
    Implements IEnumerator
public ref class GroupSetIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type GroupSetIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The GroupSetIterator type exposes the following members.

Constructors
 | Name | Description
Public method | GroupSetIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


GroupSetIterator Constructor

For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GroupSetIterator()
Public Sub New
public:
GroupSetIterator()
new : unit -> GroupSetIterator
Remarks
This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.
See Also

Reference

GroupSetIterator Class


GroupSetIterator Properties

The GroupSetIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

GroupSetIterator Class


GroupSetIterator.Current Property

GroupSetIteratorCurrent Property

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}
abstract Current : Object with get
override Current : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.
See Also

Reference

GroupSetIterator Class


GroupSetIterator Methods

The GroupSetIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

GroupSetIterator Class


GroupSetIterator.MoveNext Method

GroupSetIteratorMoveNext Method

Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumeratorMoveNext
Remarks
MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.
See Also

Reference

GroupSetIterator Class


GroupSetIterator.Reset Method

GroupSetIteratorReset Method

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
Remarks
The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.
See Also

Reference

GroupSetIterator Class


GroupType Class

An element representing a group of elements that may be placed many times in a project or family.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBGroupType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GroupType : ElementType
Public Class GroupType
    Inherits ElementType
public ref class GroupType : public ElementType
type GroupType =
    class
        inherit ElementType
    end

The GroupType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | Groups | Retrieve a set of all the groups that have this type.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAvailableAttachedDetailGroupTypeIds | Returns the attached detail groups available for this element group type.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
 | LoadFrom | Replaces the group with the contents of the input file.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Grouping elements is useful when you need to create entities that represent repeating layouts or are common to many building projects, such as hotel rooms, apartments, or repeating floors.
Example
C#
VB
C++
F#
Copy
public void GetInfo_GroupType(GroupType groupType)
{
    string message = "GroupType";
    //Retrieve a set of all the groups that have this type.
    foreach (Group group in groupType.Groups)
    {
        // Get GroupType group name
        message = "\nThe group type name is : " + groupType.Name;
        //Returns all the members of the group.
        message += "\nThe types and ids of the group members are : ";
        IList<ElementId> groupMembers = group.GetMemberIds();
        foreach (ElementId memberId in groupMembers)
        {
            Element element = group.Document.GetElement(memberId);
            // Get GroupType group element id
            message += "\n\t" + element.GetType().Name + " : " + memberId.ToString();
        }
    }
    TaskDialog.Show("Revit",message);
}
Public Sub GetInfo_GroupType(groupType As GroupType)
    Dim message As String = "GroupType"
    'Retrieve a set of all the groups that have this type.
    For Each group As Group In groupType.Groups
        ' Get GroupType group name
        message = vbLf & "The group type name is : " & Convert.ToString(groupType.Name)
        'Returns all the members of the group.
        message += vbLf & "The types and ids of the group members are : "
        Dim groupMembers As IList(Of ElementId) = group.GetMemberIds()
        For Each memberId As ElementId In groupMembers
            Dim element As Element = group.Document.GetElement(memberId)
            ' Get GroupType group element id
            message += (vbLf & vbTab + element.[GetType]().Name & " : ") + memberId.Value
        Next
    Next
    TaskDialog.Show("Revit", message)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


GroupType Properties

The GroupType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | Groups | Retrieve a set of all the groups that have this type.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

GroupType Class


GroupType.Groups Property

GroupTypeGroups Property

Retrieve a set of all the groups that have this type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GroupSet Groups { get; }
Public ReadOnly Property Groups As GroupSet
    Get
public:
property GroupSet^ Groups {
    GroupSet^ get ();
}
member Groups : GroupSet with get

Return Value

GroupSet
A set of group objects that all share this group type.
Remarks
All groups returned by this property belong to this group type. A groups type can be changed by using the GroupType property on the group object, in which case it will no longer belong to this type but it will belong to the new type instead.
See Also

Reference

GroupType Class


GroupType Methods

The GroupType type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAvailableAttachedDetailGroupTypeIds | Returns the attached detail groups available for this element group type.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
 | LoadFrom | Replaces the group with the contents of the input file.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

GroupType Class


GroupType.GetAvailableAttachedDetailGroupTypeIds Method

GroupTypeGetAvailableAttachedDetailGroupTypeIds Method

Returns the attached detail groups available for this element group type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ISet<ElementId> GetAvailableAttachedDetailGroupTypeIds()
Public Function GetAvailableAttachedDetailGroupTypeIds As ISet(Of ElementId)
public:
ISet<ElementId^>^ GetAvailableAttachedDetailGroupTypeIds()
member GetAvailableAttachedDetailGroupTypeIds : unit -> ISet<ElementId>

Return Value

ISet ElementId
Returns the collection of attached detail group Ids that match this group's type.
See Also

Reference

GroupType Class


GroupType.LoadFrom Method

GroupTypeLoadFrom Method

Replaces the group with the contents of the input file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void LoadFrom(
    string fileName,
    GroupLoadOptions options
)
Public Sub LoadFrom (
    fileName As String,
    options As GroupLoadOptions
)
public:
void LoadFrom(
    String^ fileName,
    GroupLoadOptions^ options
)
member LoadFrom :
        fileName : string *
        options : GroupLoadOptions -> unit

Parameters

fileName String
The file to be used for the replacment.
options GroupLoadOptions
Group load options.
Exceptions
Exception | Condition
ArgumentException | Not a valid RVT file.
ArgumentNullException | A non-optional argument was null
FileArgumentNotFoundException | The given fileName does not exist.
InvalidOperationException | The element "this GroupType" is in a document which is in an edit mode or is in family mode. -or- The element "this GroupType" does not belong to a project document. -or- The GroupType is not a Model group type and can't be reloaded.
ModificationForbiddenException | The document containing this GroupType is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document containing this GroupType is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document containing this GroupType has no open transaction.
Example
C#
VB
C++
F#
Copy
public void LoadGroup(Group group, string filePath)
{
   GroupLoadOptions options = new GroupLoadOptions();
   options.ReplaceDuplicatedGroups = true;
   options.SetDuplicateTypeNamesHandler(new CustomDuplicateTypeNamesHandler());

   group.GroupType.LoadFrom(filePath, options);
}

class CustomDuplicateTypeNamesHandler : IDuplicateTypeNamesHandler
{
   public DuplicateTypeAction OnDuplicateTypeNamesFound(DuplicateTypeNamesHandlerArgs args)
   {
      return DuplicateTypeAction.UseDestinationTypes;
   }
}
Public Sub LoadGroup(ByVal group As Group, ByVal filePath As String)
    Dim options As GroupLoadOptions = New GroupLoadOptions()
    options.ReplaceDuplicatedGroups = True
    options.SetDuplicateTypeNamesHandler(New CustomDuplicateTypeNamesHandler())

    group.GroupType.LoadFrom(filePath, options)
End Sub

Friend Class CustomDuplicateTypeNamesHandler
    Implements IDuplicateTypeNamesHandler
    Public Function OnDuplicateTypeNamesFound(ByVal args As DuplicateTypeNamesHandlerArgs) As DuplicateTypeAction Implements IDuplicateTypeNamesHandler.OnDuplicateTypeNamesFound
        Return DuplicateTypeAction.UseDestinationTypes
    End Function
End Class

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

GroupType Class


GroupTypeId Class

This class contains constants identifying parameter groups.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBGroupTypeId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class GroupTypeId
Public NotInheritable Class GroupTypeId
public ref class GroupTypeId abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type GroupTypeId = class end

The GroupTypeId type exposes the following members.

Properties
Name | Description
AdskModelProperties | Model Properties.
AlternateUnits | Alternate Units.
AnalysisResults | Analysis Results.
AnalyticalAlignment | Analytical Alignment.
AnalyticalModel | Analytical Model.
AnalyticalProperties | Analytical Properties.
Area | Area.
ConceptualEnergyData | Conceptual Energy Data.
ConceptualEnergyDataBuildingServices | Energy Model - Building Services.
Constraints | Constraints.
Construction | Construction.
ContinuousrailBeginBottomExtension | Extension (Beginning/Bottom).
ContinuousrailEndTopExtension | Extension (End/Top).
CouplerArray | Set.
CurtainGrid | Grid.
CurtainGridHoriz | Horizontal Grid.
CurtainGridn1 | Grid 1.
CurtainGridn2 | Grid 2.
CurtainGridU | U Grid.
CurtainGridV | V Grid.
CurtainGridVert | Vertical Grid.
CurtainMullionHoriz | Horizontal Mullions.
CurtainMullionn1 | Grid 1 Mullions.
CurtainMullionn2 | Grid 2 Mullions.
CurtainMullionVert | Vertical Mullions.
Data | Data.
Display | Display.
DivisionGeometry | Division Geometry.
Electrical | Electrical.
ElectricalAnalysis | Electrical Analysis.
ElectricalCircuiting | Electrical - Circuiting.
ElectricalEngineering | Electrical Engineering.
ElectricalLighting | Electrical - Lighting.
ElectricalLoads | Electrical - Loads.
EnergyAnalysis | Energy Analysis.
EnergyAnalysisAdvanced | Advanced.
EnergyAnalysisBldgConsMtlThermalProps | Material Thermal Properties.
EnergyAnalysisBuildingData | Building Data.
EnergyAnalysisConceptualModel | Energy Analytical Model.
EnergyAnalysisDetailedAndConceptualModels | Essential.
EnergyAnalysisDetailedModel | Detailed Model.
EnergyAnalysisRoomSpaceData | Room/Space Data.
FabricationProductData | Fabrication Product Data.
FireProtection | Fire Protection.
Fitting | Fittings.
Flexible | Adaptive Component.
Forces | Forces.
General | General.
GeoLocation | Geolocation.
Geometry | Geometry.
GeometryPositioning | Geometric Position.
Graphics | Graphics.
GreenBuilding | Green Building Properties.
IdentityData | Identity Data.
Ifc | IFC Parameters.
Insulation | Insulation.
Length | Length.
LifeSafety | Life Safety.
LightPhotometrics | Photometrics.
Lining | Lining.
Materials | Materials and Finishes.
Mechanical | Mechanical.
MechanicalAirflow | Mechanical - Flow.
MechanicalLoads | Mechanical - Loads.
Moments | Moments.
Nodes | Nodes.
OverallLegend | Overall Legend.
Pattern | Pattern.
PatternApplication | Pattern Application.
Phasing | Phasing.
Plumbing | Plumbing.
PrimaryEnd | Primary End.
PrimaryUnits | Primary Units.
Profile | Profile.
Profilen1 | Profile 1.
Profilen2 | Profile 2.
RailingSystemFamilyHandrails | Handrail 1.
RailingSystemFamilySegmentPattern | Segment Pattern (default).
RailingSystemFamilyTopRail | Top Rail.
RailingSystemSecondaryFamilyHandrails | Handrail 2.
RailingSystemSegmentPatternRemainder | Pattern Remainder.
RailingSystemSegmentPatternRepeat | Pattern Repeat.
RailingSystemSegmentPosts | Posts.
RailingSystemSegmentUGrid | U Grid.
RailingSystemSegmentVGrid | V Grid.
RebarArray | Rebar Set.
RebarSystemLayers | Layers.
Reference | Reference.
ReleasesMemberForces | Releases / Member Forces.
RotationAbout | Rotation about.
RouteAnalysis | Route Analysis.
SecondaryEnd | Secondary End.
SegmentsFittings | Segments and Fittings.
SlabShapeEdit | Slab Shape Edit.
SplitProfileDimensions | Dimensions (linear units or % of thickness).
StairRisers | Risers.
StairsCalculatorRules | Calculation Rules.
StairsOpenEndConnection | End Connection.
StairsSupports | Supports.
StairsTreadsRisers | Threads/Risers.
StairStringers | Stringers.
StairsWinders | Winders.
StairTreads | Treads.
Structural | Structural.
StructuralAnalysis | Structural Analysis.
StructuralSectionDimensions | Structural Section Dimensions.
StructuralSectionGeometry | Structural Section Geometry.
Support | Supports.
SystemtypeRisedrop | Rise / Drop.
Termination | Terminations.
Text | Text.
Title | Title Text.
ToposolidSubdivision | Sub-Division.
TranslationIn | Translation in.
TrussFamilyBottomChord | Bottom Chords.
TrussFamilyDiagWeb | Diagonal Webs.
TrussFamilyTopChord | Top Chords.
TrussFamilyVertWeb | Vertical Webs.
Underlay | Underlay.
ViewCamera | Camera.
ViewExtents | Extents.
Visibility | Visibility.
Visualization | Visualization.
WallCrossSectionDefinition | Cross-Section Definition.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


GroupTypeId Properties

The GroupTypeId type exposes the following members.

Properties
Name | Description
AdskModelProperties | Model Properties.
AlternateUnits | Alternate Units.
AnalysisResults | Analysis Results.
AnalyticalAlignment | Analytical Alignment.
AnalyticalModel | Analytical Model.
AnalyticalProperties | Analytical Properties.
Area | Area.
ConceptualEnergyData | Conceptual Energy Data.
ConceptualEnergyDataBuildingServices | Energy Model - Building Services.
Constraints | Constraints.
Construction | Construction.
ContinuousrailBeginBottomExtension | Extension (Beginning/Bottom).
ContinuousrailEndTopExtension | Extension (End/Top).
CouplerArray | Set.
CurtainGrid | Grid.
CurtainGridHoriz | Horizontal Grid.
CurtainGridn1 | Grid 1.
CurtainGridn2 | Grid 2.
CurtainGridU | U Grid.
CurtainGridV | V Grid.
CurtainGridVert | Vertical Grid.
CurtainMullionHoriz | Horizontal Mullions.
CurtainMullionn1 | Grid 1 Mullions.
CurtainMullionn2 | Grid 2 Mullions.
CurtainMullionVert | Vertical Mullions.
Data | Data.
Display | Display.
DivisionGeometry | Division Geometry.
Electrical | Electrical.
ElectricalAnalysis | Electrical Analysis.
ElectricalCircuiting | Electrical - Circuiting.
ElectricalEngineering | Electrical Engineering.
ElectricalLighting | Electrical - Lighting.
ElectricalLoads | Electrical - Loads.
EnergyAnalysis | Energy Analysis.
EnergyAnalysisAdvanced | Advanced.
EnergyAnalysisBldgConsMtlThermalProps | Material Thermal Properties.
EnergyAnalysisBuildingData | Building Data.
EnergyAnalysisConceptualModel | Energy Analytical Model.
EnergyAnalysisDetailedAndConceptualModels | Essential.
EnergyAnalysisDetailedModel | Detailed Model.
EnergyAnalysisRoomSpaceData | Room/Space Data.
FabricationProductData | Fabrication Product Data.
FireProtection | Fire Protection.
Fitting | Fittings.
Flexible | Adaptive Component.
Forces | Forces.
General | General.
GeoLocation | Geolocation.
Geometry | Geometry.
GeometryPositioning | Geometric Position.
Graphics | Graphics.
GreenBuilding | Green Building Properties.
IdentityData | Identity Data.
Ifc | IFC Parameters.
Insulation | Insulation.
Length | Length.
LifeSafety | Life Safety.
LightPhotometrics | Photometrics.
Lining | Lining.
Materials | Materials and Finishes.
Mechanical | Mechanical.
MechanicalAirflow | Mechanical - Flow.
MechanicalLoads | Mechanical - Loads.
Moments | Moments.
Nodes | Nodes.
OverallLegend | Overall Legend.
Pattern | Pattern.
PatternApplication | Pattern Application.
Phasing | Phasing.
Plumbing | Plumbing.
PrimaryEnd | Primary End.
PrimaryUnits | Primary Units.
Profile | Profile.
Profilen1 | Profile 1.
Profilen2 | Profile 2.
RailingSystemFamilyHandrails | Handrail 1.
RailingSystemFamilySegmentPattern | Segment Pattern (default).
RailingSystemFamilyTopRail | Top Rail.
RailingSystemSecondaryFamilyHandrails | Handrail 2.
RailingSystemSegmentPatternRemainder | Pattern Remainder.
RailingSystemSegmentPatternRepeat | Pattern Repeat.
RailingSystemSegmentPosts | Posts.
RailingSystemSegmentUGrid | U Grid.
RailingSystemSegmentVGrid | V Grid.
RebarArray | Rebar Set.
RebarSystemLayers | Layers.
Reference | Reference.
ReleasesMemberForces | Releases / Member Forces.
RotationAbout | Rotation about.
RouteAnalysis | Route Analysis.
SecondaryEnd | Secondary End.
SegmentsFittings | Segments and Fittings.
SlabShapeEdit | Slab Shape Edit.
SplitProfileDimensions | Dimensions (linear units or % of thickness).
StairRisers | Risers.
StairsCalculatorRules | Calculation Rules.
StairsOpenEndConnection | End Connection.
StairsSupports | Supports.
StairsTreadsRisers | Threads/Risers.
StairStringers | Stringers.
StairsWinders | Winders.
StairTreads | Treads.
Structural | Structural.
StructuralAnalysis | Structural Analysis.
StructuralSectionDimensions | Structural Section Dimensions.
StructuralSectionGeometry | Structural Section Geometry.
Support | Supports.
SystemtypeRisedrop | Rise / Drop.
Termination | Terminations.
Text | Text.
Title | Title Text.
ToposolidSubdivision | Sub-Division.
TranslationIn | Translation in.
TrussFamilyBottomChord | Bottom Chords.
TrussFamilyDiagWeb | Diagonal Webs.
TrussFamilyTopChord | Top Chords.
TrussFamilyVertWeb | Vertical Webs.
Underlay | Underlay.
ViewCamera | Camera.
ViewExtents | Extents.
Visibility | Visibility.
Visualization | Visualization.
WallCrossSectionDefinition | Cross-Section Definition.
Top
See Also

Reference

GroupTypeId Class


GroupTypeId.AdskModelProperties Property

GroupTypeIdAdskModelProperties Property

Model Properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AdskModelProperties { get; }
Public Shared ReadOnly Property AdskModelProperties As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AdskModelProperties {
    ForgeTypeId^ get ();
}
static member AdskModelProperties : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.AlternateUnits Property

GroupTypeIdAlternateUnits Property

Alternate Units.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AlternateUnits { get; }
Public Shared ReadOnly Property AlternateUnits As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AlternateUnits {
    ForgeTypeId^ get ();
}
static member AlternateUnits : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.AnalysisResults Property

GroupTypeIdAnalysisResults Property

Analysis Results.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalysisResults { get; }
Public Shared ReadOnly Property AnalysisResults As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalysisResults {
    ForgeTypeId^ get ();
}
static member AnalysisResults : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.AnalyticalAlignment Property

GroupTypeIdAnalyticalAlignment Property

Analytical Alignment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalAlignment { get; }
Public Shared ReadOnly Property AnalyticalAlignment As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalAlignment {
    ForgeTypeId^ get ();
}
static member AnalyticalAlignment : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.AnalyticalModel Property

GroupTypeIdAnalyticalModel Property

Analytical Model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalModel { get; }
Public Shared ReadOnly Property AnalyticalModel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalModel {
    ForgeTypeId^ get ();
}
static member AnalyticalModel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.AnalyticalProperties Property

GroupTypeIdAnalyticalProperties Property

Analytical Properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalProperties { get; }
Public Shared ReadOnly Property AnalyticalProperties As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalProperties {
    ForgeTypeId^ get ();
}
static member AnalyticalProperties : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.Area Property

GroupTypeIdArea Property

Area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Area { get; }
Public Shared ReadOnly Property Area As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Area {
    ForgeTypeId^ get ();
}
static member Area : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.ConceptualEnergyData Property

GroupTypeIdConceptualEnergyData Property

Conceptual Energy Data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ConceptualEnergyData { get; }
Public Shared ReadOnly Property ConceptualEnergyData As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ConceptualEnergyData {
    ForgeTypeId^ get ();
}
static member ConceptualEnergyData : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.ConceptualEnergyDataBuildingServices Property

GroupTypeIdConceptualEnergyDataBuildingServices Property

Energy Model - Building Services.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ConceptualEnergyDataBuildingServices { get; }
Public Shared ReadOnly Property ConceptualEnergyDataBuildingServices As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ConceptualEnergyDataBuildingServices {
    ForgeTypeId^ get ();
}
static member ConceptualEnergyDataBuildingServices : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.Constraints Property

GroupTypeIdConstraints Property

Constraints.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Constraints { get; }
Public Shared ReadOnly Property Constraints As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Constraints {
    ForgeTypeId^ get ();
}
static member Constraints : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.Construction Property

GroupTypeIdConstruction Property

Construction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Construction { get; }
Public Shared ReadOnly Property Construction As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Construction {
    ForgeTypeId^ get ();
}
static member Construction : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.ContinuousrailBeginBottomExtension Property

GroupTypeIdContinuousrailBeginBottomExtension Property

Extension (Beginning/Bottom).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ContinuousrailBeginBottomExtension { get; }
Public Shared ReadOnly Property ContinuousrailBeginBottomExtension As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ContinuousrailBeginBottomExtension {
    ForgeTypeId^ get ();
}
static member ContinuousrailBeginBottomExtension : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.ContinuousrailEndTopExtension Property

GroupTypeIdContinuousrailEndTopExtension Property

Extension (End/Top).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ContinuousrailEndTopExtension { get; }
Public Shared ReadOnly Property ContinuousrailEndTopExtension As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ContinuousrailEndTopExtension {
    ForgeTypeId^ get ();
}
static member ContinuousrailEndTopExtension : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.CouplerArray Property

GroupTypeIdCouplerArray Property

Set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CouplerArray { get; }
Public Shared ReadOnly Property CouplerArray As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CouplerArray {
    ForgeTypeId^ get ();
}
static member CouplerArray : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.CurtainGrid Property

GroupTypeIdCurtainGrid Property

Grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtainGrid { get; }
Public Shared ReadOnly Property CurtainGrid As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtainGrid {
    ForgeTypeId^ get ();
}
static member CurtainGrid : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.CurtainGridHoriz Property

GroupTypeIdCurtainGridHoriz Property

Horizontal Grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtainGridHoriz { get; }
Public Shared ReadOnly Property CurtainGridHoriz As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtainGridHoriz {
    ForgeTypeId^ get ();
}
static member CurtainGridHoriz : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.CurtainGridn1 Property

GroupTypeIdCurtainGridn1 Property

Grid 1.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtainGridn1 { get; }
Public Shared ReadOnly Property CurtainGridn1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtainGridn1 {
    ForgeTypeId^ get ();
}
static member CurtainGridn1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.CurtainGridn2 Property

GroupTypeIdCurtainGridn2 Property

Grid 2.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtainGridn2 { get; }
Public Shared ReadOnly Property CurtainGridn2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtainGridn2 {
    ForgeTypeId^ get ();
}
static member CurtainGridn2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.CurtainGridU Property

GroupTypeIdCurtainGridU Property

U Grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtainGridU { get; }
Public Shared ReadOnly Property CurtainGridU As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtainGridU {
    ForgeTypeId^ get ();
}
static member CurtainGridU : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.CurtainGridV Property

GroupTypeIdCurtainGridV Property

V Grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtainGridV { get; }
Public Shared ReadOnly Property CurtainGridV As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtainGridV {
    ForgeTypeId^ get ();
}
static member CurtainGridV : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.CurtainGridVert Property

GroupTypeIdCurtainGridVert Property

Vertical Grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtainGridVert { get; }
Public Shared ReadOnly Property CurtainGridVert As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtainGridVert {
    ForgeTypeId^ get ();
}
static member CurtainGridVert : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.CurtainMullionHoriz Property

GroupTypeIdCurtainMullionHoriz Property

Horizontal Mullions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtainMullionHoriz { get; }
Public Shared ReadOnly Property CurtainMullionHoriz As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtainMullionHoriz {
    ForgeTypeId^ get ();
}
static member CurtainMullionHoriz : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.CurtainMullionn1 Property

GroupTypeIdCurtainMullionn1 Property

Grid 1 Mullions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtainMullionn1 { get; }
Public Shared ReadOnly Property CurtainMullionn1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtainMullionn1 {
    ForgeTypeId^ get ();
}
static member CurtainMullionn1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.CurtainMullionn2 Property

GroupTypeIdCurtainMullionn2 Property

Grid 2 Mullions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtainMullionn2 { get; }
Public Shared ReadOnly Property CurtainMullionn2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtainMullionn2 {
    ForgeTypeId^ get ();
}
static member CurtainMullionn2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.CurtainMullionVert Property

GroupTypeIdCurtainMullionVert Property

Vertical Mullions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtainMullionVert { get; }
Public Shared ReadOnly Property CurtainMullionVert As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtainMullionVert {
    ForgeTypeId^ get ();
}
static member CurtainMullionVert : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.Data Property

GroupTypeIdData Property

Data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Data { get; }
Public Shared ReadOnly Property Data As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Data {
    ForgeTypeId^ get ();
}
static member Data : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.Display Property

GroupTypeIdDisplay Property

Display.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Display { get; }
Public Shared ReadOnly Property Display As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Display {
    ForgeTypeId^ get ();
}
static member Display : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.DivisionGeometry Property

GroupTypeIdDivisionGeometry Property

Division Geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DivisionGeometry { get; }
Public Shared ReadOnly Property DivisionGeometry As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DivisionGeometry {
    ForgeTypeId^ get ();
}
static member DivisionGeometry : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.Electrical Property

GroupTypeIdElectrical Property

Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Electrical { get; }
Public Shared ReadOnly Property Electrical As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Electrical {
    ForgeTypeId^ get ();
}
static member Electrical : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.ElectricalAnalysis Property

GroupTypeIdElectricalAnalysis Property

Electrical Analysis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ElectricalAnalysis { get; }
Public Shared ReadOnly Property ElectricalAnalysis As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ElectricalAnalysis {
    ForgeTypeId^ get ();
}
static member ElectricalAnalysis : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.ElectricalCircuiting Property

GroupTypeIdElectricalCircuiting Property

Electrical - Circuiting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ElectricalCircuiting { get; }
Public Shared ReadOnly Property ElectricalCircuiting As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ElectricalCircuiting {
    ForgeTypeId^ get ();
}
static member ElectricalCircuiting : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.ElectricalEngineering Property

GroupTypeIdElectricalEngineering Property

Electrical Engineering.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ElectricalEngineering { get; }
Public Shared ReadOnly Property ElectricalEngineering As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ElectricalEngineering {
    ForgeTypeId^ get ();
}
static member ElectricalEngineering : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.ElectricalLighting Property

GroupTypeIdElectricalLighting Property

Electrical - Lighting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ElectricalLighting { get; }
Public Shared ReadOnly Property ElectricalLighting As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ElectricalLighting {
    ForgeTypeId^ get ();
}
static member ElectricalLighting : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.ElectricalLoads Property

GroupTypeIdElectricalLoads Property

Electrical - Loads.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ElectricalLoads { get; }
Public Shared ReadOnly Property ElectricalLoads As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ElectricalLoads {
    ForgeTypeId^ get ();
}
static member ElectricalLoads : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.EnergyAnalysis Property

GroupTypeIdEnergyAnalysis Property

Energy Analysis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EnergyAnalysis { get; }
Public Shared ReadOnly Property EnergyAnalysis As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EnergyAnalysis {
    ForgeTypeId^ get ();
}
static member EnergyAnalysis : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.EnergyAnalysisAdvanced Property

GroupTypeIdEnergyAnalysisAdvanced Property

Advanced.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EnergyAnalysisAdvanced { get; }
Public Shared ReadOnly Property EnergyAnalysisAdvanced As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EnergyAnalysisAdvanced {
    ForgeTypeId^ get ();
}
static member EnergyAnalysisAdvanced : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.EnergyAnalysisBldgConsMtlThermalProps Property

GroupTypeIdEnergyAnalysisBldgConsMtlThermalProps Property

Material Thermal Properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EnergyAnalysisBldgConsMtlThermalProps { get; }
Public Shared ReadOnly Property EnergyAnalysisBldgConsMtlThermalProps As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EnergyAnalysisBldgConsMtlThermalProps {
    ForgeTypeId^ get ();
}
static member EnergyAnalysisBldgConsMtlThermalProps : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.EnergyAnalysisBuildingData Property

GroupTypeIdEnergyAnalysisBuildingData Property

Building Data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EnergyAnalysisBuildingData { get; }
Public Shared ReadOnly Property EnergyAnalysisBuildingData As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EnergyAnalysisBuildingData {
    ForgeTypeId^ get ();
}
static member EnergyAnalysisBuildingData : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.EnergyAnalysisConceptualModel Property

GroupTypeIdEnergyAnalysisConceptualModel Property

Energy Analytical Model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EnergyAnalysisConceptualModel { get; }
Public Shared ReadOnly Property EnergyAnalysisConceptualModel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EnergyAnalysisConceptualModel {
    ForgeTypeId^ get ();
}
static member EnergyAnalysisConceptualModel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.EnergyAnalysisDetailedAndConceptualModels Property

GroupTypeIdEnergyAnalysisDetailedAndConceptualModels Property

Essential.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EnergyAnalysisDetailedAndConceptualModels { get; }
Public Shared ReadOnly Property EnergyAnalysisDetailedAndConceptualModels As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EnergyAnalysisDetailedAndConceptualModels {
    ForgeTypeId^ get ();
}
static member EnergyAnalysisDetailedAndConceptualModels : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.EnergyAnalysisDetailedModel Property

GroupTypeIdEnergyAnalysisDetailedModel Property

Detailed Model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EnergyAnalysisDetailedModel { get; }
Public Shared ReadOnly Property EnergyAnalysisDetailedModel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EnergyAnalysisDetailedModel {
    ForgeTypeId^ get ();
}
static member EnergyAnalysisDetailedModel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.EnergyAnalysisRoomSpaceData Property

GroupTypeIdEnergyAnalysisRoomSpaceData Property

Room/Space Data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EnergyAnalysisRoomSpaceData { get; }
Public Shared ReadOnly Property EnergyAnalysisRoomSpaceData As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EnergyAnalysisRoomSpaceData {
    ForgeTypeId^ get ();
}
static member EnergyAnalysisRoomSpaceData : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.FabricationProductData Property

GroupTypeIdFabricationProductData Property

Fabrication Product Data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationProductData { get; }
Public Shared ReadOnly Property FabricationProductData As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationProductData {
    ForgeTypeId^ get ();
}
static member FabricationProductData : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.FireProtection Property

GroupTypeIdFireProtection Property

Fire Protection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FireProtection { get; }
Public Shared ReadOnly Property FireProtection As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FireProtection {
    ForgeTypeId^ get ();
}
static member FireProtection : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.Fitting Property

GroupTypeIdFitting Property

Fittings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Fitting { get; }
Public Shared ReadOnly Property Fitting As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Fitting {
    ForgeTypeId^ get ();
}
static member Fitting : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.Flexible Property

GroupTypeIdFlexible Property

Adaptive Component.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Flexible { get; }
Public Shared ReadOnly Property Flexible As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Flexible {
    ForgeTypeId^ get ();
}
static member Flexible : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.Forces Property

GroupTypeIdForces Property

Forces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Forces { get; }
Public Shared ReadOnly Property Forces As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Forces {
    ForgeTypeId^ get ();
}
static member Forces : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.General Property

GroupTypeIdGeneral Property

General.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId General { get; }
Public Shared ReadOnly Property General As ForgeTypeId
    Get
public:
static property ForgeTypeId^ General {
    ForgeTypeId^ get ();
}
static member General : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.GeoLocation Property

GroupTypeIdGeoLocation Property

Geolocation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GeoLocation { get; }
Public Shared ReadOnly Property GeoLocation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GeoLocation {
    ForgeTypeId^ get ();
}
static member GeoLocation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.Geometry Property

GroupTypeIdGeometry Property

Geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Geometry { get; }
Public Shared ReadOnly Property Geometry As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Geometry {
    ForgeTypeId^ get ();
}
static member Geometry : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.GeometryPositioning Property

GroupTypeIdGeometryPositioning Property

Geometric Position.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GeometryPositioning { get; }
Public Shared ReadOnly Property GeometryPositioning As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GeometryPositioning {
    ForgeTypeId^ get ();
}
static member GeometryPositioning : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.Graphics Property

GroupTypeIdGraphics Property

Graphics.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Graphics { get; }
Public Shared ReadOnly Property Graphics As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Graphics {
    ForgeTypeId^ get ();
}
static member Graphics : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.GreenBuilding Property

GroupTypeIdGreenBuilding Property

Green Building Properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GreenBuilding { get; }
Public Shared ReadOnly Property GreenBuilding As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GreenBuilding {
    ForgeTypeId^ get ();
}
static member GreenBuilding : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.IdentityData Property

GroupTypeIdIdentityData Property

Identity Data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId IdentityData { get; }
Public Shared ReadOnly Property IdentityData As ForgeTypeId
    Get
public:
static property ForgeTypeId^ IdentityData {
    ForgeTypeId^ get ();
}
static member IdentityData : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.Ifc Property

GroupTypeIdIfc Property

IFC Parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Ifc { get; }
Public Shared ReadOnly Property Ifc As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Ifc {
    ForgeTypeId^ get ();
}
static member Ifc : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.Insulation Property

GroupTypeIdInsulation Property

Insulation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Insulation { get; }
Public Shared ReadOnly Property Insulation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Insulation {
    ForgeTypeId^ get ();
}
static member Insulation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.Length Property

GroupTypeIdLength Property

Length.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Length { get; }
Public Shared ReadOnly Property Length As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Length {
    ForgeTypeId^ get ();
}
static member Length : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.LifeSafety Property

GroupTypeIdLifeSafety Property

Life Safety.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LifeSafety { get; }
Public Shared ReadOnly Property LifeSafety As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LifeSafety {
    ForgeTypeId^ get ();
}
static member LifeSafety : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.LightPhotometrics Property

GroupTypeIdLightPhotometrics Property

Photometrics.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LightPhotometrics { get; }
Public Shared ReadOnly Property LightPhotometrics As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LightPhotometrics {
    ForgeTypeId^ get ();
}
static member LightPhotometrics : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.Lining Property

GroupTypeIdLining Property

Lining.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Lining { get; }
Public Shared ReadOnly Property Lining As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Lining {
    ForgeTypeId^ get ();
}
static member Lining : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.Materials Property

GroupTypeIdMaterials Property

Materials and Finishes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Materials { get; }
Public Shared ReadOnly Property Materials As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Materials {
    ForgeTypeId^ get ();
}
static member Materials : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.Mechanical Property

GroupTypeIdMechanical Property

Mechanical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Mechanical { get; }
Public Shared ReadOnly Property Mechanical As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Mechanical {
    ForgeTypeId^ get ();
}
static member Mechanical : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.MechanicalAirflow Property

GroupTypeIdMechanicalAirflow Property

Mechanical - Flow.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MechanicalAirflow { get; }
Public Shared ReadOnly Property MechanicalAirflow As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MechanicalAirflow {
    ForgeTypeId^ get ();
}
static member MechanicalAirflow : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.MechanicalLoads Property

GroupTypeIdMechanicalLoads Property

Mechanical - Loads.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MechanicalLoads { get; }
Public Shared ReadOnly Property MechanicalLoads As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MechanicalLoads {
    ForgeTypeId^ get ();
}
static member MechanicalLoads : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.Moments Property

GroupTypeIdMoments Property

Moments.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Moments { get; }
Public Shared ReadOnly Property Moments As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Moments {
    ForgeTypeId^ get ();
}
static member Moments : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.Nodes Property

GroupTypeIdNodes Property

Nodes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Nodes { get; }
Public Shared ReadOnly Property Nodes As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Nodes {
    ForgeTypeId^ get ();
}
static member Nodes : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.OverallLegend Property

GroupTypeIdOverallLegend Property

Overall Legend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId OverallLegend { get; }
Public Shared ReadOnly Property OverallLegend As ForgeTypeId
    Get
public:
static property ForgeTypeId^ OverallLegend {
    ForgeTypeId^ get ();
}
static member OverallLegend : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.Pattern Property

GroupTypeIdPattern Property

Pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Pattern { get; }
Public Shared ReadOnly Property Pattern As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Pattern {
    ForgeTypeId^ get ();
}
static member Pattern : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.PatternApplication Property

GroupTypeIdPatternApplication Property

Pattern Application.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PatternApplication { get; }
Public Shared ReadOnly Property PatternApplication As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PatternApplication {
    ForgeTypeId^ get ();
}
static member PatternApplication : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.Phasing Property

GroupTypeIdPhasing Property

Phasing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Phasing { get; }
Public Shared ReadOnly Property Phasing As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Phasing {
    ForgeTypeId^ get ();
}
static member Phasing : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.Plumbing Property

GroupTypeIdPlumbing Property

Plumbing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Plumbing { get; }
Public Shared ReadOnly Property Plumbing As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Plumbing {
    ForgeTypeId^ get ();
}
static member Plumbing : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.PrimaryEnd Property

GroupTypeIdPrimaryEnd Property

Primary End.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PrimaryEnd { get; }
Public Shared ReadOnly Property PrimaryEnd As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PrimaryEnd {
    ForgeTypeId^ get ();
}
static member PrimaryEnd : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.PrimaryUnits Property

GroupTypeIdPrimaryUnits Property

Primary Units.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PrimaryUnits { get; }
Public Shared ReadOnly Property PrimaryUnits As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PrimaryUnits {
    ForgeTypeId^ get ();
}
static member PrimaryUnits : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.Profile Property

GroupTypeIdProfile Property

Profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Profile { get; }
Public Shared ReadOnly Property Profile As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Profile {
    ForgeTypeId^ get ();
}
static member Profile : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.Profilen1 Property

GroupTypeIdProfilen1 Property

Profile 1.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Profilen1 { get; }
Public Shared ReadOnly Property Profilen1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Profilen1 {
    ForgeTypeId^ get ();
}
static member Profilen1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.Profilen2 Property

GroupTypeIdProfilen2 Property

Profile 2.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Profilen2 { get; }
Public Shared ReadOnly Property Profilen2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Profilen2 {
    ForgeTypeId^ get ();
}
static member Profilen2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.RailingSystemFamilyHandrails Property

GroupTypeIdRailingSystemFamilyHandrails Property

Handrail 1.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RailingSystemFamilyHandrails { get; }
Public Shared ReadOnly Property RailingSystemFamilyHandrails As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RailingSystemFamilyHandrails {
    ForgeTypeId^ get ();
}
static member RailingSystemFamilyHandrails : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.RailingSystemFamilySegmentPattern Property

GroupTypeIdRailingSystemFamilySegmentPattern Property

Segment Pattern (default).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RailingSystemFamilySegmentPattern { get; }
Public Shared ReadOnly Property RailingSystemFamilySegmentPattern As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RailingSystemFamilySegmentPattern {
    ForgeTypeId^ get ();
}
static member RailingSystemFamilySegmentPattern : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.RailingSystemFamilyTopRail Property

GroupTypeIdRailingSystemFamilyTopRail Property

Top Rail.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RailingSystemFamilyTopRail { get; }
Public Shared ReadOnly Property RailingSystemFamilyTopRail As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RailingSystemFamilyTopRail {
    ForgeTypeId^ get ();
}
static member RailingSystemFamilyTopRail : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.RailingSystemSecondaryFamilyHandrails Property

GroupTypeIdRailingSystemSecondaryFamilyHandrails Property

Handrail 2.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RailingSystemSecondaryFamilyHandrails { get; }
Public Shared ReadOnly Property RailingSystemSecondaryFamilyHandrails As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RailingSystemSecondaryFamilyHandrails {
    ForgeTypeId^ get ();
}
static member RailingSystemSecondaryFamilyHandrails : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.RailingSystemSegmentPatternRemainder Property

GroupTypeIdRailingSystemSegmentPatternRemainder Property

Pattern Remainder.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RailingSystemSegmentPatternRemainder { get; }
Public Shared ReadOnly Property RailingSystemSegmentPatternRemainder As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RailingSystemSegmentPatternRemainder {
    ForgeTypeId^ get ();
}
static member RailingSystemSegmentPatternRemainder : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.RailingSystemSegmentPatternRepeat Property

GroupTypeIdRailingSystemSegmentPatternRepeat Property

Pattern Repeat.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RailingSystemSegmentPatternRepeat { get; }
Public Shared ReadOnly Property RailingSystemSegmentPatternRepeat As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RailingSystemSegmentPatternRepeat {
    ForgeTypeId^ get ();
}
static member RailingSystemSegmentPatternRepeat : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.RailingSystemSegmentPosts Property

GroupTypeIdRailingSystemSegmentPosts Property

Posts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RailingSystemSegmentPosts { get; }
Public Shared ReadOnly Property RailingSystemSegmentPosts As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RailingSystemSegmentPosts {
    ForgeTypeId^ get ();
}
static member RailingSystemSegmentPosts : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.RailingSystemSegmentUGrid Property

GroupTypeIdRailingSystemSegmentUGrid Property

U Grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RailingSystemSegmentUGrid { get; }
Public Shared ReadOnly Property RailingSystemSegmentUGrid As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RailingSystemSegmentUGrid {
    ForgeTypeId^ get ();
}
static member RailingSystemSegmentUGrid : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.RailingSystemSegmentVGrid Property

GroupTypeIdRailingSystemSegmentVGrid Property

V Grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RailingSystemSegmentVGrid { get; }
Public Shared ReadOnly Property RailingSystemSegmentVGrid As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RailingSystemSegmentVGrid {
    ForgeTypeId^ get ();
}
static member RailingSystemSegmentVGrid : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.RebarArray Property

GroupTypeIdRebarArray Property

Rebar Set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarArray { get; }
Public Shared ReadOnly Property RebarArray As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarArray {
    ForgeTypeId^ get ();
}
static member RebarArray : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.RebarSystemLayers Property

GroupTypeIdRebarSystemLayers Property

Layers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemLayers { get; }
Public Shared ReadOnly Property RebarSystemLayers As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemLayers {
    ForgeTypeId^ get ();
}
static member RebarSystemLayers : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.Reference Property

GroupTypeIdReference Property

Reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Reference { get; }
Public Shared ReadOnly Property Reference As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Reference {
    ForgeTypeId^ get ();
}
static member Reference : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.ReleasesMemberForces Property

GroupTypeIdReleasesMemberForces Property

Releases / Member Forces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ReleasesMemberForces { get; }
Public Shared ReadOnly Property ReleasesMemberForces As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ReleasesMemberForces {
    ForgeTypeId^ get ();
}
static member ReleasesMemberForces : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.RotationAbout Property

GroupTypeIdRotationAbout Property

Rotation about.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RotationAbout { get; }
Public Shared ReadOnly Property RotationAbout As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RotationAbout {
    ForgeTypeId^ get ();
}
static member RotationAbout : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.RouteAnalysis Property

GroupTypeIdRouteAnalysis Property

Route Analysis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RouteAnalysis { get; }
Public Shared ReadOnly Property RouteAnalysis As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RouteAnalysis {
    ForgeTypeId^ get ();
}
static member RouteAnalysis : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.SecondaryEnd Property

GroupTypeIdSecondaryEnd Property

Secondary End.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SecondaryEnd { get; }
Public Shared ReadOnly Property SecondaryEnd As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SecondaryEnd {
    ForgeTypeId^ get ();
}
static member SecondaryEnd : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.SegmentsFittings Property

GroupTypeIdSegmentsFittings Property

Segments and Fittings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SegmentsFittings { get; }
Public Shared ReadOnly Property SegmentsFittings As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SegmentsFittings {
    ForgeTypeId^ get ();
}
static member SegmentsFittings : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.SlabShapeEdit Property

GroupTypeIdSlabShapeEdit Property

Slab Shape Edit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SlabShapeEdit { get; }
Public Shared ReadOnly Property SlabShapeEdit As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SlabShapeEdit {
    ForgeTypeId^ get ();
}
static member SlabShapeEdit : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.SplitProfileDimensions Property

GroupTypeIdSplitProfileDimensions Property

Dimensions (linear units or % of thickness).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SplitProfileDimensions { get; }
Public Shared ReadOnly Property SplitProfileDimensions As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SplitProfileDimensions {
    ForgeTypeId^ get ();
}
static member SplitProfileDimensions : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.StairRisers Property

GroupTypeIdStairRisers Property

Risers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairRisers { get; }
Public Shared ReadOnly Property StairRisers As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairRisers {
    ForgeTypeId^ get ();
}
static member StairRisers : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.StairsCalculatorRules Property

GroupTypeIdStairsCalculatorRules Property

Calculation Rules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsCalculatorRules { get; }
Public Shared ReadOnly Property StairsCalculatorRules As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsCalculatorRules {
    ForgeTypeId^ get ();
}
static member StairsCalculatorRules : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.StairsOpenEndConnection Property

GroupTypeIdStairsOpenEndConnection Property

End Connection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsOpenEndConnection { get; }
Public Shared ReadOnly Property StairsOpenEndConnection As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsOpenEndConnection {
    ForgeTypeId^ get ();
}
static member StairsOpenEndConnection : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.StairsSupports Property

GroupTypeIdStairsSupports Property

Supports.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsSupports { get; }
Public Shared ReadOnly Property StairsSupports As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsSupports {
    ForgeTypeId^ get ();
}
static member StairsSupports : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.StairsTreadsRisers Property

GroupTypeIdStairsTreadsRisers Property

Threads/Risers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsTreadsRisers { get; }
Public Shared ReadOnly Property StairsTreadsRisers As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsTreadsRisers {
    ForgeTypeId^ get ();
}
static member StairsTreadsRisers : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.StairStringers Property

GroupTypeIdStairStringers Property

Stringers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairStringers { get; }
Public Shared ReadOnly Property StairStringers As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairStringers {
    ForgeTypeId^ get ();
}
static member StairStringers : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.StairsWinders Property

GroupTypeIdStairsWinders Property

Winders.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsWinders { get; }
Public Shared ReadOnly Property StairsWinders As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsWinders {
    ForgeTypeId^ get ();
}
static member StairsWinders : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.StairTreads Property

GroupTypeIdStairTreads Property

Treads.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairTreads { get; }
Public Shared ReadOnly Property StairTreads As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairTreads {
    ForgeTypeId^ get ();
}
static member StairTreads : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.Structural Property

GroupTypeIdStructural Property

Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Structural { get; }
Public Shared ReadOnly Property Structural As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Structural {
    ForgeTypeId^ get ();
}
static member Structural : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.StructuralAnalysis Property

GroupTypeIdStructuralAnalysis Property

Structural Analysis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralAnalysis { get; }
Public Shared ReadOnly Property StructuralAnalysis As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralAnalysis {
    ForgeTypeId^ get ();
}
static member StructuralAnalysis : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.StructuralSectionDimensions Property

GroupTypeIdStructuralSectionDimensions Property

Structural Section Dimensions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionDimensions { get; }
Public Shared ReadOnly Property StructuralSectionDimensions As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionDimensions {
    ForgeTypeId^ get ();
}
static member StructuralSectionDimensions : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.StructuralSectionGeometry Property

GroupTypeIdStructuralSectionGeometry Property

Structural Section Geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionGeometry { get; }
Public Shared ReadOnly Property StructuralSectionGeometry As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionGeometry {
    ForgeTypeId^ get ();
}
static member StructuralSectionGeometry : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.Support Property

GroupTypeIdSupport Property

Supports.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Support { get; }
Public Shared ReadOnly Property Support As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Support {
    ForgeTypeId^ get ();
}
static member Support : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.SystemtypeRisedrop Property

GroupTypeIdSystemtypeRisedrop Property

Rise / Drop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SystemtypeRisedrop { get; }
Public Shared ReadOnly Property SystemtypeRisedrop As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SystemtypeRisedrop {
    ForgeTypeId^ get ();
}
static member SystemtypeRisedrop : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.Termination Property

GroupTypeIdTermination Property

Terminations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Termination { get; }
Public Shared ReadOnly Property Termination As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Termination {
    ForgeTypeId^ get ();
}
static member Termination : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.Text Property

GroupTypeIdText Property

Text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Text { get; }
Public Shared ReadOnly Property Text As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Text {
    ForgeTypeId^ get ();
}
static member Text : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.Title Property

GroupTypeIdTitle Property

Title Text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Title { get; }
Public Shared ReadOnly Property Title As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Title {
    ForgeTypeId^ get ();
}
static member Title : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.ToposolidSubdivision Property

GroupTypeIdToposolidSubdivision Property

Sub-Division.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ToposolidSubdivision { get; }
Public Shared ReadOnly Property ToposolidSubdivision As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ToposolidSubdivision {
    ForgeTypeId^ get ();
}
static member ToposolidSubdivision : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.TranslationIn Property

GroupTypeIdTranslationIn Property

Translation in.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TranslationIn { get; }
Public Shared ReadOnly Property TranslationIn As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TranslationIn {
    ForgeTypeId^ get ();
}
static member TranslationIn : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.TrussFamilyBottomChord Property

GroupTypeIdTrussFamilyBottomChord Property

Bottom Chords.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TrussFamilyBottomChord { get; }
Public Shared ReadOnly Property TrussFamilyBottomChord As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TrussFamilyBottomChord {
    ForgeTypeId^ get ();
}
static member TrussFamilyBottomChord : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.TrussFamilyDiagWeb Property

GroupTypeIdTrussFamilyDiagWeb Property

Diagonal Webs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TrussFamilyDiagWeb { get; }
Public Shared ReadOnly Property TrussFamilyDiagWeb As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TrussFamilyDiagWeb {
    ForgeTypeId^ get ();
}
static member TrussFamilyDiagWeb : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.TrussFamilyTopChord Property

GroupTypeIdTrussFamilyTopChord Property

Top Chords.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TrussFamilyTopChord { get; }
Public Shared ReadOnly Property TrussFamilyTopChord As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TrussFamilyTopChord {
    ForgeTypeId^ get ();
}
static member TrussFamilyTopChord : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.TrussFamilyVertWeb Property

GroupTypeIdTrussFamilyVertWeb Property

Vertical Webs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TrussFamilyVertWeb { get; }
Public Shared ReadOnly Property TrussFamilyVertWeb As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TrussFamilyVertWeb {
    ForgeTypeId^ get ();
}
static member TrussFamilyVertWeb : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.Underlay Property

GroupTypeIdUnderlay Property

Underlay.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Underlay { get; }
Public Shared ReadOnly Property Underlay As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Underlay {
    ForgeTypeId^ get ();
}
static member Underlay : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.ViewCamera Property

GroupTypeIdViewCamera Property

Camera.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewCamera { get; }
Public Shared ReadOnly Property ViewCamera As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewCamera {
    ForgeTypeId^ get ();
}
static member ViewCamera : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.ViewExtents Property

GroupTypeIdViewExtents Property

Extents.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewExtents { get; }
Public Shared ReadOnly Property ViewExtents As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewExtents {
    ForgeTypeId^ get ();
}
static member ViewExtents : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.Visibility Property

GroupTypeIdVisibility Property

Visibility.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Visibility { get; }
Public Shared ReadOnly Property Visibility As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Visibility {
    ForgeTypeId^ get ();
}
static member Visibility : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.Visualization Property

GroupTypeIdVisualization Property

Visualization.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Visualization { get; }
Public Shared ReadOnly Property Visualization As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Visualization {
    ForgeTypeId^ get ();
}
static member Visualization : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GroupTypeId.WallCrossSectionDefinition Property

GroupTypeIdWallCrossSectionDefinition Property

Cross-Section Definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WallCrossSectionDefinition { get; }
Public Shared ReadOnly Property WallCrossSectionDefinition As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WallCrossSectionDefinition {
    ForgeTypeId^ get ();
}
static member WallCrossSectionDefinition : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

GroupTypeId Class


GuidEnum Class

Base class of all GUID-based enum classes.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBGuidEnum
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GuidEnum
Public Class GuidEnum
public ref class GuidEnum
type GuidEnum = class end

The GuidEnum type exposes the following members.

Constructors
 | Name | Description
Public method | GuidEnum | Creates an Guid-based enum instance with the supplied name and GUID. GUID-based enum instance can be compared by this guid value.
Top
Properties
 | Name | Description
Public property | Guid | The Guid of GUID-based enum object.
Top
Methods
 | Name | Description
Public method | Equals | Compares two Guid-based enum object based on their concrete class and GUID value. (Overrides ObjectEquals(Object))
Public method | GetHashCode | Generates a hash code for this Guid-based enum object. (Overrides ObjectGetHashCode)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBGuidEnum
Autodesk.Revit.DBExternalResourceType
Autodesk.Revit.DB.ExternalServiceExternalServiceId
Autodesk.Revit.DBFailureDefinitionId
Autodesk.Revit.DBNumberingSchemaType
Autodesk.Revit.DBPerformanceAdviserRuleId
Autodesk.Revit.UIDockablePaneId


GuidEnum Constructor

Creates an Guid-based enum instance with the supplied name and GUID. GUID-based enum instance can be compared by this guid value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GuidEnum(
    Guid guid
)
Public Sub New (
    guid As Guid
)
public:
GuidEnum(
    Guid guid
)
new :
        guid : Guid -> GuidEnum

Parameters

guid Guid
The GUID of this GUID-based enum.
See Also

Reference

GuidEnum Class


GuidEnum Properties

The GuidEnum type exposes the following members.

Properties
 | Name | Description
Public property | Guid | The Guid of GUID-based enum object.
Top
See Also

Reference

GuidEnum Class


GuidEnum.Guid Property

GuidEnumGuid Property

The Guid of GUID-based enum object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid Guid { get; }
Public ReadOnly Property Guid As Guid
    Get
public:
property Guid Guid {
    Guid get ();
}
member Guid : Guid with get

Property Value

Guid
See Also

Reference

GuidEnum Class


GuidEnum Methods

The GuidEnum type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares two Guid-based enum object based on their concrete class and GUID value. (Overrides ObjectEquals(Object))
Public method | GetHashCode | Generates a hash code for this Guid-based enum object. (Overrides ObjectGetHashCode)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

GuidEnum Class


GuidEnum.Equals Method

GuidEnumEquals Method

Compares two Guid-based enum object based on their concrete class and GUID value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj Object

Return Value

Boolean
See Also

Reference

GuidEnum Class


GuidEnum.GetHashCode Method

GuidEnumGetHashCode Method

Generates a hash code for this Guid-based enum object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Int32
See Also

Reference

GuidEnum Class


HasNoValueFilterRule Class

Tests whether an element's parameter doesn't have a value.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterRule
Autodesk.Revit.DBParameterValuePresenceRule
Autodesk.Revit.DBHasNoValueFilterRule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class HasNoValueFilterRule : ParameterValuePresenceRule
Public Class HasNoValueFilterRule
    Inherits ParameterValuePresenceRule
public ref class HasNoValueFilterRule : public ParameterValuePresenceRule
type HasNoValueFilterRule =
    class
        inherit ParameterValuePresenceRule
    end

The HasNoValueFilterRule type exposes the following members.

Constructors
 | Name | Description
Public method | HasNoValueFilterRule | constructs an instance of HasNoValueFilterRule.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule)
Public property | Parameter | The parameter which will be evaluated to pass this rule. (Inherited from ParameterValuePresenceRule)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterRule)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


HasNoValueFilterRule Constructor

constructs an instance of HasNoValueFilterRule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public HasNoValueFilterRule(
    ElementId parameter
)
Public Sub New (
    parameter As ElementId
)
public:
HasNoValueFilterRule(
    ElementId^ parameter
)
new :
        parameter : ElementId -> HasNoValueFilterRule

Parameters

parameter ElementId
The parameter that an element must not have a value for to pass this rule.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

HasNoValueFilterRule Class


HasNoValueFilterRule Properties

The HasNoValueFilterRule type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule)
Public property | Parameter | The parameter which will be evaluated to pass this rule. (Inherited from ParameterValuePresenceRule)
Top
See Also

Reference

HasNoValueFilterRule Class


HasNoValueFilterRule Methods

The HasNoValueFilterRule type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterRule)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

HasNoValueFilterRule Class


HasValueFilterRule Class

Tests whether an element's parameter has a value.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterRule
Autodesk.Revit.DBParameterValuePresenceRule
Autodesk.Revit.DBHasValueFilterRule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class HasValueFilterRule : ParameterValuePresenceRule
Public Class HasValueFilterRule
    Inherits ParameterValuePresenceRule
public ref class HasValueFilterRule : public ParameterValuePresenceRule
type HasValueFilterRule =
    class
        inherit ParameterValuePresenceRule
    end

The HasValueFilterRule type exposes the following members.

Constructors
 | Name | Description
Public method | HasValueFilterRule | constructs an instance of HasValueFilterRule.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule)
Public property | Parameter | The parameter which will be evaluated to pass this rule. (Inherited from ParameterValuePresenceRule)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterRule)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


HasValueFilterRule Constructor

constructs an instance of HasValueFilterRule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public HasValueFilterRule(
    ElementId parameter
)
Public Sub New (
    parameter As ElementId
)
public:
HasValueFilterRule(
    ElementId^ parameter
)
new :
        parameter : ElementId -> HasValueFilterRule

Parameters

parameter ElementId
The parameter that an element must have a value for to pass this rule.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

HasValueFilterRule Class


HasValueFilterRule Properties

The HasValueFilterRule type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule)
Public property | Parameter | The parameter which will be evaluated to pass this rule. (Inherited from ParameterValuePresenceRule)
Top
See Also

Reference

HasValueFilterRule Class


HasValueFilterRule Methods

The HasValueFilterRule type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterRule)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

HasValueFilterRule Class


HermiteFace Class

A cubic hermite spline face of a 3d solid or open shell.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGeometryObject
Autodesk.Revit.DBFace
Autodesk.Revit.DBHermiteFace

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class HermiteFace : Face
Public Class HermiteFace
    Inherits Face
public ref class HermiteFace : public Face
type HermiteFace =
    class
        inherit Face
    end

The HermiteFace type exposes the following members.

Properties
 | Name | Description
Public property | Area | The area of this face. (Inherited from Face)
Public property | EdgeLoops | A collection of edge loops. Each edge loop represents one of the closed boundaries of the face. (Inherited from Face)
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject)
Public property | HasRegions | Identifies if the face contains regions (which can be created, for example, by the Split Face command). (Inherited from Face)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject)
Public property | IsCyclic | Indicates whether the underlying surface is periodic in the specified parametric direction. (Inherited from Face)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject)
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate). (Inherited from Face)
Public property | MaterialElementId | The element ID of the material from which this face is composed. (Inherited from Face)
Public property | MixedDerivs | Mixed derivatives of the surface.
Public property | OrientationMatchesSurfaceOrientation | Returns true if this face's orientation matches the orientation of the face's surface, false if they have opposite orientations. (Inherited from Face)
Public property | Params | Parameters of the surface.
Public property | Period | The period of the underlying surface in the specified parametric direction. (Inherited from Face)
Public property | Points | Interpolation points of the surface.
Public property | Reference | Returns a stable reference to the face. (Inherited from Face)
Public property | Tangents | Tangents of the surface.
Public property | Visibility | The visibility. (Inherited from GeometryObject)
Top
Methods
 | Name | Description
Public method | ComputeDerivatives | Returns the first partial derivatives of the underlying surface at the specified point. (Inherited from Face)
Public method | ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face)
Public method | ComputeSecondDerivatives | Returns the second partial derivatives of the face at the specified point. (Inherited from Face)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject)
Public method | Evaluate | Evaluates and returns the XYZ coordinates of a point at the indicated UV parameterization of the face. (Inherited from Face)
Public method | GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face)
Public method | GetEdgesAsCurveLoops | Returns a list of closed curve loops that correspond to the edge loops of the face. Curves in each curve loop correspond to individual edges. (Inherited from Face)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject)
Public method | GetRegions | Gets the face regions (created, for example, by the Split Face command) of the face. (Inherited from Face)
Public method | GetSurface | Returns a copy of this face's surface. (Inherited from Face)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face)
Public method | Intersect(Face) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face)
Public method | Intersect(Curve, IntersectionResultArray) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face)
Public method | Intersect(Face, Curve) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face)
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face)
Public method | IsInside(UV, IntersectionResult) | Indicates whether the specified point is within this face and outputs additional information about the point location. (Inherited from Face)
Public method | Project | Projects the specified point on the face. (Inherited from Face)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
 | Triangulate | Returns a triangular mesh approximation to the face. (Inherited from Face)
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face. (Inherited from Face)
Top
Remarks
Hermite faces are defined by cubic hermite spline surfaces bounded by edge loops. The surfaces provide natural UV parameterization to the faces.
Example
C#
VB
C++
F#
Copy
private void GetHermiteFaceInfo(Face face)
{
    HermiteFace hermiteFace = face as HermiteFace;
    if (null != hermiteFace)
    {
        IList<XYZ> points = hermiteFace.Points;
        IList<XYZ> derivs = hermiteFace.MixedDerivs;
        DoubleArray faceParams = hermiteFace.get_Params(0);
        IList<XYZ> tangents = hermiteFace.get_Tangents(0);
    }
}
Private Sub GetHermiteFaceInfo(face As Face)
    Dim hermiteFace As HermiteFace = TryCast(face, HermiteFace)
    If hermiteFace IsNot Nothing Then
        Dim points As IList(Of XYZ) = hermiteFace.Points
        Dim derivs As IList(Of XYZ) = hermiteFace.MixedDerivs
        Dim faceParams As DoubleArray = hermiteFace.Params(0)
        Dim tangents As IList(Of XYZ) = hermiteFace.Tangents(0)
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


HermiteFace Properties

The HermiteFace type exposes the following members.

Properties
 | Name | Description
Public property | Area | The area of this face. (Inherited from Face)
Public property | EdgeLoops | A collection of edge loops. Each edge loop represents one of the closed boundaries of the face. (Inherited from Face)
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject)
Public property | HasRegions | Identifies if the face contains regions (which can be created, for example, by the Split Face command). (Inherited from Face)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject)
Public property | IsCyclic | Indicates whether the underlying surface is periodic in the specified parametric direction. (Inherited from Face)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject)
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate). (Inherited from Face)
Public property | MaterialElementId | The element ID of the material from which this face is composed. (Inherited from Face)
Public property | MixedDerivs | Mixed derivatives of the surface.
Public property | OrientationMatchesSurfaceOrientation | Returns true if this face's orientation matches the orientation of the face's surface, false if they have opposite orientations. (Inherited from Face)
Public property | Params | Parameters of the surface.
Public property | Period | The period of the underlying surface in the specified parametric direction. (Inherited from Face)
Public property | Points | Interpolation points of the surface.
Public property | Reference | Returns a stable reference to the face. (Inherited from Face)
Public property | Tangents | Tangents of the surface.
Public property | Visibility | The visibility. (Inherited from GeometryObject)
Top
See Also

Reference

HermiteFace Class


HermiteFace.MixedDerivs Property

HermiteFaceMixedDerivs Property

Mixed derivatives of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<XYZ> MixedDerivs { get; }
Public ReadOnly Property MixedDerivs As IList(Of XYZ)
    Get
public:
property IList<XYZ^>^ MixedDerivs {
    IList<XYZ^>^ get ();
}
member MixedDerivs : IList<XYZ> with get

Property Value

IList XYZ
See Also

Reference

HermiteFace Class


HermiteFace.Params Property

HermiteFaceParams Property

Parameters of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DoubleArray this[
    int index
] { get; }
Public ReadOnly Property Params (
    index As Integer
) As DoubleArray
    Get
public:
property DoubleArray^ Params[int index] {
    DoubleArray^ get (int index);
}
member Params : DoubleArray with get

Parameters

index Int32

Property Value

DoubleArray
See Also

Reference

HermiteFace Class


HermiteFace.Points Property

HermiteFacePoints Property

Interpolation points of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<XYZ> Points { get; }
Public ReadOnly Property Points As IList(Of XYZ)
    Get
public:
property IList<XYZ^>^ Points {
    IList<XYZ^>^ get ();
}
member Points : IList<XYZ> with get

Property Value

IList XYZ
See Also

Reference

HermiteFace Class


HermiteFace.Tangents Property

HermiteFaceTangents Property

Tangents of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<XYZ> this[
    int index
] { get; }
Public ReadOnly Property Tangents (
    index As Integer
) As IList(Of XYZ)
    Get
public:
property IList<XYZ^>^ Tangents[int index] {
    IList<XYZ^>^ get (int index);
}
member Tangents : IList<XYZ> with get

Parameters

index Int32

Property Value

IList XYZ
See Also

Reference

HermiteFace Class


HermiteFace Methods

The HermiteFace type exposes the following members.

Methods
 | Name | Description
Public method | ComputeDerivatives | Returns the first partial derivatives of the underlying surface at the specified point. (Inherited from Face)
Public method | ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face)
Public method | ComputeSecondDerivatives | Returns the second partial derivatives of the face at the specified point. (Inherited from Face)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject)
Public method | Evaluate | Evaluates and returns the XYZ coordinates of a point at the indicated UV parameterization of the face. (Inherited from Face)
Public method | GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face)
Public method | GetEdgesAsCurveLoops | Returns a list of closed curve loops that correspond to the edge loops of the face. Curves in each curve loop correspond to individual edges. (Inherited from Face)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject)
Public method | GetRegions | Gets the face regions (created, for example, by the Split Face command) of the face. (Inherited from Face)
Public method | GetSurface | Returns a copy of this face's surface. (Inherited from Face)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face)
Public method | Intersect(Face) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face)
Public method | Intersect(Curve, IntersectionResultArray) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face)
Public method | Intersect(Face, Curve) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face)
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face)
Public method | IsInside(UV, IntersectionResult) | Indicates whether the specified point is within this face and outputs additional information about the point location. (Inherited from Face)
Public method | Project | Projects the specified point on the face. (Inherited from Face)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
 | Triangulate | Returns a triangular mesh approximation to the face. (Inherited from Face)
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face. (Inherited from Face)
Top
See Also

Reference

HermiteFace Class


HermiteSpline Class

A Hermite spline.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGeometryObject
Autodesk.Revit.DBCurve
Autodesk.Revit.DBHermiteSpline

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class HermiteSpline : Curve
Public Class HermiteSpline
    Inherits Curve
public ref class HermiteSpline : public Curve
type HermiteSpline =
    class
        inherit Curve
    end

The HermiteSpline type exposes the following members.

Properties
 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve)
Public property | ControlPoints | The control points of the Hermite spline.
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve)
Public property | IsClosed | Describes whether the curve is closed. (Inherited from Curve)
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject)
Public property | IsPeriodic | Returns whether the Hermite spline is periodic or not.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Length | The exact length of the curve. (Inherited from Curve)
Public property | Parameters | Returns the params of the Hermite spline.
Public property | Period | The period of this curve. (Inherited from Curve)
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve)
Public property | Tangents | Returns the tangents of the Hermite spline.
Public property | Visibility | The visibility. (Inherited from GeometryObject)
Top
Methods
 | Name | Description
Public method | Clone | Returns a copy of this curve. (Inherited from Curve)
Public method | ComputeClosestPoints | Find the closest points between two curves. Closest points mean closest pairs of points, each pair consisting of a point on this, say P1, and a point on other curve, say P2. P1 and P2 are closest locally. Each pairs of closest points will be represented by the corresponding parameter values with respect to the two curves and the 3d points. A closest pair is also known as a pair of critical points of the distance function between points of the two curves. If the input parameter returnAllCriticalPoints is set to false, then the function will return only pairs with minimum distance. (Inherited from Curve)
Public method | ComputeDerivatives | Returns the vectors describing the curve at the specified parameter. (Inherited from Curve)
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve)
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve)
 | Create(IListXYZ, Boolean) | Creates a Hermite spline with default tangency at its endpoints.
 | Create(IListXYZ, Boolean, HermiteSplineTangents) | Creates a Hermite spline with specified tangency at its endpoints.
Public method | CreateOffset | Creates a new curve that is an offset of the existing curve. (Inherited from Curve)
Public method | CreateReversed | Creates a new curve with the opposite orientation of the existing curve. (Inherited from Curve)
Public method | CreateTransformed | Crates a new instance of a curve as a transformation of this curve. (Inherited from Curve)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject)
Public method | Evaluate | Evaluates and returns the point that matches a parameter along the curve. (Inherited from Curve)
Public method | GetEndParameter | Returns the raw parameter value at the start or end of this curve. (Inherited from Curve)
Public method | GetEndPoint | Returns the 3D point at the start or end of this curve. (Inherited from Curve)
Public method | GetEndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve)
Public method | Intersect(Curve, IntersectionResultArray) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve)
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve)
Public method | IsInside(Double, Int32) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve)
Public method | MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve)
Public method | MakeUnbound | Makes this curve unbound. (Inherited from Curve)
Public method | Project | Projects the specified point on this curve. (Inherited from Curve)
Public method | SetGraphicsStyleId | Sets the graphics style id for this curve. (Inherited from Curve)
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The Hermite spline lies in the plane defined by control points.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


HermiteSpline Properties

The HermiteSpline type exposes the following members.

Properties
 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve)
Public property | ControlPoints | The control points of the Hermite spline.
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve)
Public property | IsClosed | Describes whether the curve is closed. (Inherited from Curve)
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject)
Public property | IsPeriodic | Returns whether the Hermite spline is periodic or not.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Length | The exact length of the curve. (Inherited from Curve)
Public property | Parameters | Returns the params of the Hermite spline.
Public property | Period | The period of this curve. (Inherited from Curve)
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve)
Public property | Tangents | Returns the tangents of the Hermite spline.
Public property | Visibility | The visibility. (Inherited from GeometryObject)
Top
See Also

Reference

HermiteSpline Class


HermiteSpline.ControlPoints Property

HermiteSplineControlPoints Property

The control points of the Hermite spline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<XYZ> ControlPoints { get; set; }
Public Property ControlPoints As IList(Of XYZ)
    Get
    Set
public:
property IList<XYZ^>^ ControlPoints {
    IList<XYZ^>^ get ();
    void set (IList<XYZ^>^ value);
}
member ControlPoints : IList<XYZ> with get, set

Property Value

IList XYZ
See Also

Reference

HermiteSpline Class


HermiteSpline.IsPeriodic Property

HermiteSplineIsPeriodic Property

Returns whether the Hermite spline is periodic or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsPeriodic { get; }
Public ReadOnly Property IsPeriodic As Boolean
    Get
public:
property bool IsPeriodic {
    bool get ();
}
member IsPeriodic : bool with get

Property Value

Boolean
See Also

Reference

HermiteSpline Class


HermiteSpline.Parameters Property

HermiteSplineParameters Property

Returns the params of the Hermite spline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DoubleArray Parameters { get; }
Public ReadOnly Property Parameters As DoubleArray
    Get
public:
property DoubleArray^ Parameters {
    DoubleArray^ get ();
}
member Parameters : DoubleArray with get

Property Value

DoubleArray
See Also

Reference

HermiteSpline Class


HermiteSpline.Tangents Property

HermiteSplineTangents Property

Returns the tangents of the Hermite spline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<XYZ> Tangents { get; }
Public ReadOnly Property Tangents As IList(Of XYZ)
    Get
public:
property IList<XYZ^>^ Tangents {
    IList<XYZ^>^ get ();
}
member Tangents : IList<XYZ> with get

Property Value

IList XYZ
See Also

Reference

HermiteSpline Class


HermiteSpline Methods

The HermiteSpline type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Returns a copy of this curve. (Inherited from Curve)
Public method | ComputeClosestPoints | Find the closest points between two curves. Closest points mean closest pairs of points, each pair consisting of a point on this, say P1, and a point on other curve, say P2. P1 and P2 are closest locally. Each pairs of closest points will be represented by the corresponding parameter values with respect to the two curves and the 3d points. A closest pair is also known as a pair of critical points of the distance function between points of the two curves. If the input parameter returnAllCriticalPoints is set to false, then the function will return only pairs with minimum distance. (Inherited from Curve)
Public method | ComputeDerivatives | Returns the vectors describing the curve at the specified parameter. (Inherited from Curve)
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve)
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve)
 | Create(IListXYZ, Boolean) | Creates a Hermite spline with default tangency at its endpoints.
 | Create(IListXYZ, Boolean, HermiteSplineTangents) | Creates a Hermite spline with specified tangency at its endpoints.
Public method | CreateOffset | Creates a new curve that is an offset of the existing curve. (Inherited from Curve)
Public method | CreateReversed | Creates a new curve with the opposite orientation of the existing curve. (Inherited from Curve)
Public method | CreateTransformed | Crates a new instance of a curve as a transformation of this curve. (Inherited from Curve)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject)
Public method | Evaluate | Evaluates and returns the point that matches a parameter along the curve. (Inherited from Curve)
Public method | GetEndParameter | Returns the raw parameter value at the start or end of this curve. (Inherited from Curve)
Public method | GetEndPoint | Returns the 3D point at the start or end of this curve. (Inherited from Curve)
Public method | GetEndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve)
Public method | Intersect(Curve, IntersectionResultArray) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve)
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve)
Public method | IsInside(Double, Int32) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve)
Public method | MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve)
Public method | MakeUnbound | Makes this curve unbound. (Inherited from Curve)
Public method | Project | Projects the specified point on this curve. (Inherited from Curve)
Public method | SetGraphicsStyleId | Sets the graphics style id for this curve. (Inherited from Curve)
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

HermiteSpline Class


HermiteSpline.Create Method

HermiteSplineCreate Method

Overload List
Name | Description
Create(IListXYZ, Boolean) | Creates a Hermite spline with default tangency at its endpoints.
Create(IListXYZ, Boolean, HermiteSplineTangents) | Creates a Hermite spline with specified tangency at its endpoints.
Top
See Also

Reference

HermiteSpline Class


HermiteSpline.Create(IList<XYZ>, Boolean) Method

HermiteSplineCreate(IListXYZ, Boolean) Method

Creates a Hermite spline with default tangency at its endpoints.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static HermiteSpline Create(
    IList<XYZ> controlPoints,
    bool periodic
)
Public Shared Function Create (
    controlPoints As IList(Of XYZ),
    periodic As Boolean
) As HermiteSpline
public:
static HermiteSpline^ Create(
    IList<XYZ^>^ controlPoints,
    bool periodic
)
static member Create :
        controlPoints : IList<XYZ> *
        periodic : bool -> HermiteSpline

Parameters

controlPoints IList XYZ
The control points of the Hermite spline.
periodic Boolean
True if the Hermite spline is to be periodic, false otherwise.

Return Value

HermiteSpline
The new HermiteSpline object.
Exceptions
Exception | Condition
ArgumentException | The control points array is invalid, because it doesn't contain the minimum number of points (2).
ArgumentNullException | A non-optional argument was NULL
ArgumentsInconsistentException | Curve length is too small for Revit's tolerance (as identified by Application.ShortCurveTolerance).
InvalidOperationException | Unable to construct valid HermiteSpline from given inputs.
Remarks
The tangents at the ends of the spline are computed from the control points.
See Also

Reference

HermiteSpline Class
Create Overload


HermiteSpline.Create(IList<XYZ>, Boolean, HermiteSplineTangents) Method

HermiteSplineCreate(IListXYZ, Boolean, HermiteSplineTangents) Method

Creates a Hermite spline with specified tangency at its endpoints.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static HermiteSpline Create(
    IList<XYZ> controlPoints,
    bool periodic,
    HermiteSplineTangents tangents
)
Public Shared Function Create (
    controlPoints As IList(Of XYZ),
    periodic As Boolean,
    tangents As HermiteSplineTangents
) As HermiteSpline
public:
static HermiteSpline^ Create(
    IList<XYZ^>^ controlPoints,
    bool periodic,
    HermiteSplineTangents^ tangents
)
static member Create :
        controlPoints : IList<XYZ> *
        periodic : bool *
        tangents : HermiteSplineTangents -> HermiteSpline

Parameters

controlPoints IList XYZ
The control points of the Hermite spline.
periodic Boolean
True if the Hermite spline is to be periodic, false otherwise.
tangents HermiteSplineTangents
The object which indicates tangency at the start, the end, or both ends of the curve.

Return Value

HermiteSpline
The new HermiteSpline object.
Exceptions
Exception | Condition
ArgumentException | The control points array is invalid, because it doesn't contain the minimum number of points (2).
ArgumentNullException | A non-optional argument was NULL
ArgumentsInconsistentException | Curve length is too small for Revit's tolerance (as identified by Application.ShortCurveTolerance).
InvalidOperationException | Unable to construct valid HermiteSpline from given inputs.
See Also

Reference

HermiteSpline Class
Create Overload


HermiteSplineTangents Class

This class indicates tangency at the start, the end, or both ends of the curve.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBHermiteSplineTangents

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class HermiteSplineTangents : IDisposable
Public Class HermiteSplineTangents
    Implements IDisposable
public ref class HermiteSplineTangents : IDisposable
type HermiteSplineTangents =
    class
        interface IDisposable
    end

The HermiteSplineTangents type exposes the following members.

Constructors
 | Name | Description
Public method | HermiteSplineTangents | Constructs a new default instance of the class, with tangent vectors uninitialized.
Top
Properties
 | Name | Description
Public property | EndTangent | The tangent vector at the end of the curve.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | StartTangent | The tangent vector at the start of the curve.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the HermiteSplineTangents
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Initially, the tangent vectors will not be set, and no tangency condition will be imposed when the curve is created.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


HermiteSplineTangents Constructor

Constructs a new default instance of the class, with tangent vectors uninitialized.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public HermiteSplineTangents()
Public Sub New
public:
HermiteSplineTangents()
new : unit -> HermiteSplineTangents
See Also

Reference

HermiteSplineTangents Class


HermiteSplineTangents Properties

The HermiteSplineTangents type exposes the following members.

Properties
 | Name | Description
Public property | EndTangent | The tangent vector at the end of the curve.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | StartTangent | The tangent vector at the start of the curve.
Top
See Also

Reference

HermiteSplineTangents Class


HermiteSplineTangents.EndTangent Property

HermiteSplineTangentsEndTangent Property

The tangent vector at the end of the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ EndTangent { get; set; }
Public Property EndTangent As XYZ
    Get
    Set
public:
property XYZ^ EndTangent {
    XYZ^ get ();
    void set (XYZ^ value);
}
member EndTangent : XYZ with get, set

Property Value

XYZ
This must be a nomalized unit vector.
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
ArgumentOutOfRangeException | When setting this property: endTangent has zero length.
InapplicableDataException | The end tangent value is not set.
See Also

Reference

HermiteSplineTangents Class


HermiteSplineTangents.IsValidObject Property

HermiteSplineTangentsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

HermiteSplineTangents Class


HermiteSplineTangents.StartTangent Property

HermiteSplineTangentsStartTangent Property

The tangent vector at the start of the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ StartTangent { get; set; }
Public Property StartTangent As XYZ
    Get
    Set
public:
property XYZ^ StartTangent {
    XYZ^ get ();
    void set (XYZ^ value);
}
member StartTangent : XYZ with get, set

Property Value

XYZ
This must be a nomalized unit vector.
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
ArgumentOutOfRangeException | When setting this property: startTangent is not length 1.0.
InapplicableDataException | The start tangent value is not set.
See Also

Reference

HermiteSplineTangents Class


HermiteSplineTangents Methods

The HermiteSplineTangents type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

HermiteSplineTangents Class


HermiteSplineTangents.Dispose Method

HermiteSplineTangentsDispose Method

Releases all resources used by the HermiteSplineTangents

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

HermiteSplineTangents Class


HermiteSurface Class

A Hermite Surface.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSurface
Autodesk.Revit.DBHermiteSurface

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class HermiteSurface : Surface
Public Class HermiteSurface
    Inherits Surface
public ref class HermiteSurface : public Surface
type HermiteSurface =
    class
        inherit Surface
    end

The HermiteSurface type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Surface)
Public property | OrientationMatchesParametricOrientation | Indicates whether this Surface's orientation is the same as or opposite to its parametric orientation. (Inherited from Surface)
Top
Methods
 | Name | Description
 | Create(Int32, Int32, IListXYZ) | Create a non-periodic Hermite surface using a net of 3D points as input.
 | Create(Int32, Int32, IListXYZ, Boolean, Boolean) | Create a Hermite surface using a net of 3D points as input. Specify periodicity in U and V direction.
Public method | Dispose | (Inherited from Surface)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBoundingBoxUV | Gets the UV bounding box of the surface. (Inherited from Surface)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsValid | Checks whether this HermiteSurface object is valid.
Public method | Project | Project a 3D point orthogonally onto a surface (to find the nearest point). Throws InvalidOperationException if the projection fails. (Inherited from Surface)
Public method | ProjectWithGuessPoint | Project a 3D point orthogonally onto a surface (to find the nearest point). This method is meant to be used when a good approximate solution for the projection is available. Throws InvalidOperationException if the projection fails. (Inherited from Surface)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


HermiteSurface Properties

The HermiteSurface type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Surface)
Public property | OrientationMatchesParametricOrientation | Indicates whether this Surface's orientation is the same as or opposite to its parametric orientation. (Inherited from Surface)
Top
See Also

Reference

HermiteSurface Class


HermiteSurface Methods

The HermiteSurface type exposes the following members.

Methods
 | Name | Description
 | Create(Int32, Int32, IListXYZ) | Create a non-periodic Hermite surface using a net of 3D points as input.
 | Create(Int32, Int32, IListXYZ, Boolean, Boolean) | Create a Hermite surface using a net of 3D points as input. Specify periodicity in U and V direction.
Public method | Dispose | (Inherited from Surface)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBoundingBoxUV | Gets the UV bounding box of the surface. (Inherited from Surface)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsValid | Checks whether this HermiteSurface object is valid.
Public method | Project | Project a 3D point orthogonally onto a surface (to find the nearest point). Throws InvalidOperationException if the projection fails. (Inherited from Surface)
Public method | ProjectWithGuessPoint | Project a 3D point orthogonally onto a surface (to find the nearest point). This method is meant to be used when a good approximate solution for the projection is available. Throws InvalidOperationException if the projection fails. (Inherited from Surface)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

HermiteSurface Class


HermiteSurface.Create Method

HermiteSurfaceCreate Method

Overload List
Name | Description
Create(Int32, Int32, IListXYZ) | Create a non-periodic Hermite surface using a net of 3D points as input.
Create(Int32, Int32, IListXYZ, Boolean, Boolean) | Create a Hermite surface using a net of 3D points as input. Specify periodicity in U and V direction.
Top
See Also

Reference

HermiteSurface Class


HermiteSurface.Create(Int32, Int32, IList<XYZ>) Method

HermiteSurfaceCreate(Int32, Int32, IListXYZ) Method

Create a non-periodic Hermite surface using a net of 3D points as input.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static HermiteSurface Create(
    int nU,
    int nV,
    IList<XYZ> points
)
Public Shared Function Create (
    nU As Integer,
    nV As Integer,
    points As IList(Of XYZ)
) As HermiteSurface
public:
static HermiteSurface^ Create(
    int nU,
    int nV,
    IList<XYZ^>^ points
)
static member Create :
        nU : int *
        nV : int *
        points : IList<XYZ> -> HermiteSurface

Parameters

nU Int32
Number of points in U direction.
nV Int32
Number of points in V direction.
points IList XYZ
Array of points. Must contain nU*nV points.

Return Value

HermiteSurface
A Hermite surface object created from input data.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentsInconsistentException | Thrown when the input arguments are inconsistent. The most common case is incorrect number of items in one of the lists.
Remarks
Points form a net of nU * nV 3D points. Suitable defaults will be used for other surface parameters. See other Create() functions if greater control over input is desired.
See Also

Reference

HermiteSurface Class
Create Overload


HermiteSurface.Create(Int32, Int32, IList<XYZ>, Boolean, Boolean) Method

HermiteSurfaceCreate(Int32, Int32, IListXYZ, Boolean, Boolean) Method

Create a Hermite surface using a net of 3D points as input. Specify periodicity in U and V direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static HermiteSurface Create(
    int nU,
    int nV,
    IList<XYZ> points,
    bool periodicU,
    bool periodicV
)
Public Shared Function Create (
    nU As Integer,
    nV As Integer,
    points As IList(Of XYZ),
    periodicU As Boolean,
    periodicV As Boolean
) As HermiteSurface
public:
static HermiteSurface^ Create(
    int nU,
    int nV,
    IList<XYZ^>^ points,
    bool periodicU,
    bool periodicV
)
static member Create :
        nU : int *
        nV : int *
        points : IList<XYZ> *
        periodicU : bool *
        periodicV : bool -> HermiteSurface

Parameters

nU Int32
Number of points in U direction.
nV Int32
Number of points in V direction.
points IList XYZ
Array of points. Must contain nU*nV points.
periodicU Boolean
Periodicity in U direction
periodicV Boolean
Periodicity in V direction

Return Value

HermiteSurface
A Hermite surface object created from input data.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentsInconsistentException | Thrown when the input arguments are inconsistent. The most common case is incorrect number of items in one of the lists.
Remarks
Points form a net of nU * nV (less one each if periodic) 3D points.
See Also

Reference

HermiteSurface Class
Create Overload


HermiteSurface.IsValid Method

HermiteSurfaceIsValid Method

Checks whether this HermiteSurface object is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValid()
Public Function IsValid As Boolean
public:
bool IsValid()
member IsValid : unit -> bool

Return Value

Boolean
True if this is a valid Hermite Surface, false otherwise.
Remarks
An attempt to access or compute data in an invalid Hermite Surface will cause an exception.
See Also

Reference

HermiteSurface Class


HiddenLineViewsType Enumeration

An enumerated type listing all Hidden Line Views types of Print Setting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum HiddenLineViewsType
Public Enumeration HiddenLineViewsType
public enum class HiddenLineViewsType
type HiddenLineViewsType
Members
Member name | Value | Description
VectorProcessing | 0 | The type of Hidden Line Views is Vector Processing (fast).
RasterProcessing | 1 | The type of Hidden Line Views is Raster Processing.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


HomeCamera Class

A structure that contains information about the camera and view for the Home view orientation stored in the model.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBHomeCamera

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class HomeCamera : IDisposable
Public Class HomeCamera
    Implements IDisposable
public ref class HomeCamera : IDisposable
type HomeCamera =
    class
        interface IDisposable
    end

The HomeCamera type exposes the following members.

Constructors
 | Name | Description
Public method | HomeCamera | Constructs a new copy of the input HomeCamera object.
Top
Properties
 | Name | Description
Public property | BottomAngleOfFieldOfView | The bottom angle of the field of view.
Public property | Center | The zoom or orbit center.
Public property | EyePosition | The eye position point.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LeftAngleOfFieldOfView | The left angle of the field of view.
Public property | OrthogonalProjectionHeight | The height of orthogonal projection view volume.
Public property | OrthogonalProjectionWidth | The width of orthogonal projection view volume.
Public property | Pivot | The pivot point.
Public property | RightAngleOfFieldOfView | The right angle of the field of view.
Public property | TopAngleOfFieldOfView | The top angle of the field of view.
Public property | UpDirection | The up direction vector.
Public property | ViewId | The id of the view which is associated to this document's Home view orientation.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the HomeCamera
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


HomeCamera Constructor

Constructs a new copy of the input HomeCamera object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public HomeCamera(
    HomeCamera other
)
Public Sub New (
    other As HomeCamera
)
public:
HomeCamera(
    HomeCamera^ other
)
new :
        other : HomeCamera -> HomeCamera

Parameters

other HomeCamera
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

HomeCamera Class


HomeCamera Properties

The HomeCamera type exposes the following members.

Properties
 | Name | Description
Public property | BottomAngleOfFieldOfView | The bottom angle of the field of view.
Public property | Center | The zoom or orbit center.
Public property | EyePosition | The eye position point.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LeftAngleOfFieldOfView | The left angle of the field of view.
Public property | OrthogonalProjectionHeight | The height of orthogonal projection view volume.
Public property | OrthogonalProjectionWidth | The width of orthogonal projection view volume.
Public property | Pivot | The pivot point.
Public property | RightAngleOfFieldOfView | The right angle of the field of view.
Public property | TopAngleOfFieldOfView | The top angle of the field of view.
Public property | UpDirection | The up direction vector.
Public property | ViewId | The id of the view which is associated to this document's Home view orientation.
Top
See Also

Reference

HomeCamera Class


HomeCamera.BottomAngleOfFieldOfView Property

HomeCameraBottomAngleOfFieldOfView Property

The bottom angle of the field of view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double BottomAngleOfFieldOfView { get; }
Public ReadOnly Property BottomAngleOfFieldOfView As Double
    Get
public:
property double BottomAngleOfFieldOfView {
    double get ();
}
member BottomAngleOfFieldOfView : float with get

Property Value

Double
See Also

Reference

HomeCamera Class


HomeCamera.Center Property

HomeCameraCenter Property

The zoom or orbit center.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Center { get; }
Public ReadOnly Property Center As XYZ
    Get
public:
property XYZ^ Center {
    XYZ^ get ();
}
member Center : XYZ with get

Property Value

XYZ
See Also

Reference

HomeCamera Class


HomeCamera.EyePosition Property

HomeCameraEyePosition Property

The eye position point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ EyePosition { get; }
Public ReadOnly Property EyePosition As XYZ
    Get
public:
property XYZ^ EyePosition {
    XYZ^ get ();
}
member EyePosition : XYZ with get

Property Value

XYZ
See Also

Reference

HomeCamera Class


HomeCamera.IsValidObject Property

HomeCameraIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

HomeCamera Class


HomeCamera.LeftAngleOfFieldOfView Property

HomeCameraLeftAngleOfFieldOfView Property

The left angle of the field of view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double LeftAngleOfFieldOfView { get; }
Public ReadOnly Property LeftAngleOfFieldOfView As Double
    Get
public:
property double LeftAngleOfFieldOfView {
    double get ();
}
member LeftAngleOfFieldOfView : float with get

Property Value

Double
See Also

Reference

HomeCamera Class


HomeCamera.OrthogonalProjectionHeight Property

HomeCameraOrthogonalProjectionHeight Property

The height of orthogonal projection view volume.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double OrthogonalProjectionHeight { get; }
Public ReadOnly Property OrthogonalProjectionHeight As Double
    Get
public:
property double OrthogonalProjectionHeight {
    double get ();
}
member OrthogonalProjectionHeight : float with get

Property Value

Double
See Also

Reference

HomeCamera Class


HomeCamera.OrthogonalProjectionWidth Property

HomeCameraOrthogonalProjectionWidth Property

The width of orthogonal projection view volume.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double OrthogonalProjectionWidth { get; }
Public ReadOnly Property OrthogonalProjectionWidth As Double
    Get
public:
property double OrthogonalProjectionWidth {
    double get ();
}
member OrthogonalProjectionWidth : float with get

Property Value

Double
See Also

Reference

HomeCamera Class


HomeCamera.Pivot Property

HomeCameraPivot Property

The pivot point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Pivot { get; }
Public ReadOnly Property Pivot As XYZ
    Get
public:
property XYZ^ Pivot {
    XYZ^ get ();
}
member Pivot : XYZ with get

Property Value

XYZ
See Also

Reference

HomeCamera Class


HomeCamera.RightAngleOfFieldOfView Property

HomeCameraRightAngleOfFieldOfView Property

The right angle of the field of view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double RightAngleOfFieldOfView { get; }
Public ReadOnly Property RightAngleOfFieldOfView As Double
    Get
public:
property double RightAngleOfFieldOfView {
    double get ();
}
member RightAngleOfFieldOfView : float with get

Property Value

Double
See Also

Reference

HomeCamera Class


HomeCamera.TopAngleOfFieldOfView Property

HomeCameraTopAngleOfFieldOfView Property

The top angle of the field of view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double TopAngleOfFieldOfView { get; }
Public ReadOnly Property TopAngleOfFieldOfView As Double
    Get
public:
property double TopAngleOfFieldOfView {
    double get ();
}
member TopAngleOfFieldOfView : float with get

Property Value

Double
See Also

Reference

HomeCamera Class


HomeCamera.UpDirection Property

HomeCameraUpDirection Property

The up direction vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ UpDirection { get; }
Public ReadOnly Property UpDirection As XYZ
    Get
public:
property XYZ^ UpDirection {
    XYZ^ get ();
}
member UpDirection : XYZ with get

Property Value

XYZ
See Also

Reference

HomeCamera Class


HomeCamera.ViewId Property

HomeCameraViewId Property

The id of the view which is associated to this document's Home view orientation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId ViewId { get; }
Public ReadOnly Property ViewId As ElementId
    Get
public:
property ElementId^ ViewId {
    ElementId^ get ();
}
member ViewId : ElementId with get

Property Value

ElementId
Remarks
A view can be associated to the document's Home view orientation by the View Cube menu option "Set Current View as Home". Only one view is associated to the Home view orientation at any given time in the document.
See Also

Reference

HomeCamera Class


HomeCamera Methods

The HomeCamera type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

HomeCamera Class


HomeCamera.Dispose Method

HomeCameraDispose Method

Releases all resources used by the HomeCamera

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

HomeCamera Class


HorizontalAlign Enumeration

Horizontal alignment of model text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum HorizontalAlign
Public Enumeration HorizontalAlign
public enum class HorizontalAlign
type HorizontalAlign
Members
Member name | Value | Description
Left | 64 |
Center | 128 |
Right | 256 |
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


HorizontalAlignmentStyle Enumeration

Declares the horizontal alignment style of font.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum HorizontalAlignmentStyle
Public Enumeration HorizontalAlignmentStyle
public enum class HorizontalAlignmentStyle
type HorizontalAlignmentStyle
Members
Member name | Value | Description
Left | 0 | Alignment to left
Center | 1 | Alignment to center
Right | 2 | Alignment to right
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


HorizontalTextAlignment Enumeration

Supported types of horizontal alignment of a text element and text justification within the text containing box.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum HorizontalTextAlignment
Public Enumeration HorizontalTextAlignment
public enum class HorizontalTextAlignment
type HorizontalTextAlignment
Members
Member name | Value | Description
Left | 0 | Text is Left justified inside the containing text box, and the left side of the text box remains in place as the width changes.
Right | 1 | Text is Right justified inside the containing text box, and the right side of the text box remains in place as the width changes.
Center | 2 | Text is Center justified inside the containing text box, and the center side of the text box remains in place as the width changes.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


HostedSweep Class

An object that represents an object hosted by an edge of a roof or floor within the Autodesk Revit project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBHostObject
Autodesk.Revit.DBHostedSweep
Autodesk.Revit.DB.ArchitectureFascia
Autodesk.Revit.DB.ArchitectureGutter
Autodesk.Revit.DBSlabEdge

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class HostedSweep : HostObject
Public MustInherit Class HostedSweep
    Inherits HostObject
public ref class HostedSweep abstract : public HostObject
[<AbstractClassAttribute>]
type HostedSweep =
    class
        inherit HostObject
    end

The HostedSweep type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Retrieve/set the angle of the hosted sweep object relative its references (Unit : Radian).
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HorizontalFlipped | Retrieve the horizontal flip status of the hosted sweep object.
Public property | HorizontalOffset | Retrieve/set the horizontal offset of the hosted sweep object.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | Length | Retrieve the length of the hosted sweep object.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ReferenceCurve | The curve on which the hosted sweep segment is created.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | VerticalFlipped | Retrieve the vertical flip status of the hosted sweep object.
Public property | VerticalOffset | Retrieve/set the vertical offset of the hosted sweep object.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | AddSegment | Add segments to the hosted sweep object.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEndPointParameter | Retrieve segment's start point or end point parameter.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HorizontalFlip | Flip the hosted sweep object along horizontal line.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveSegment | Remove segments from the hosted sweep object.
Public method | SetEndPointParameter | Set segment's start point or end point parameter.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | VerticalFlip | Flip the hosted sweep object along vertical line.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


HostedSweep Properties

The HostedSweep type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Retrieve/set the angle of the hosted sweep object relative its references (Unit : Radian).
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HorizontalFlipped | Retrieve the horizontal flip status of the hosted sweep object.
Public property | HorizontalOffset | Retrieve/set the horizontal offset of the hosted sweep object.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | Length | Retrieve the length of the hosted sweep object.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ReferenceCurve | The curve on which the hosted sweep segment is created.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | VerticalFlipped | Retrieve the vertical flip status of the hosted sweep object.
Public property | VerticalOffset | Retrieve/set the vertical offset of the hosted sweep object.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

HostedSweep Class


HostedSweep.Angle Property

HostedSweepAngle Property

Retrieve/set the angle of the hosted sweep object relative its references (Unit : Radian).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Angle { get; set; }
Public Property Angle As Double
    Get
    Set
public:
property double Angle {
    double get ();
    void set (double value);
}
member Angle : float with get, set

Property Value

Double
See Also

Reference

HostedSweep Class


HostedSweep.HorizontalFlipped Property

HostedSweepHorizontalFlipped Property

Retrieve the horizontal flip status of the hosted sweep object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HorizontalFlipped { get; }
Public ReadOnly Property HorizontalFlipped As Boolean
    Get
public:
property bool HorizontalFlipped {
    bool get ();
}
member HorizontalFlipped : bool with get

Property Value

Boolean
See Also

Reference

HostedSweep Class


HostedSweep.HorizontalOffset Property

HostedSweepHorizontalOffset Property

Retrieve/set the horizontal offset of the hosted sweep object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double HorizontalOffset { get; set; }
Public Property HorizontalOffset As Double
    Get
    Set
public:
property double HorizontalOffset {
    double get ();
    void set (double value);
}
member HorizontalOffset : float with get, set

Property Value

Double
See Also

Reference

HostedSweep Class


HostedSweep.Length Property

HostedSweepLength Property

Retrieve the length of the hosted sweep object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Length { get; }
Public ReadOnly Property Length As Double
    Get
public:
property double Length {
    double get ();
}
member Length : float with get

Property Value

Double
See Also

Reference

HostedSweep Class


HostedSweep.ReferenceCurve Property

HostedSweepReferenceCurve Property

The curve on which the hosted sweep segment is created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Curve this[
    Reference targetRef
] { get; }
Public ReadOnly Property ReferenceCurve (
    targetRef As Reference
) As Curve
    Get
public:
property Curve^ ReferenceCurve[Reference^ targetRef] {
    Curve^ get (Reference^ targetRef);
}
member ReferenceCurve : Curve with get

Parameters

targetRef Reference
Reference of the curve that hosts the object.

Property Value

Curve
Exceptions
Exception | Condition
InvalidOperationException | Thrown when regeneration fails.
See Also

Reference

HostedSweep Class


HostedSweep.VerticalFlipped Property

HostedSweepVerticalFlipped Property

Retrieve the vertical flip status of the hosted sweep object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool VerticalFlipped { get; }
Public ReadOnly Property VerticalFlipped As Boolean
    Get
public:
property bool VerticalFlipped {
    bool get ();
}
member VerticalFlipped : bool with get

Property Value

Boolean
See Also

Reference

HostedSweep Class


HostedSweep.VerticalOffset Property

HostedSweepVerticalOffset Property

Retrieve/set the vertical offset of the hosted sweep object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double VerticalOffset { get; set; }
Public Property VerticalOffset As Double
    Get
    Set
public:
property double VerticalOffset {
    double get ();
    void set (double value);
}
member VerticalOffset : float with get, set

Property Value

Double
See Also

Reference

HostedSweep Class


HostedSweep Methods

The HostedSweep type exposes the following members.

Methods
 | Name | Description
Public method | AddSegment | Add segments to the hosted sweep object.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEndPointParameter | Retrieve segment's start point or end point parameter.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HorizontalFlip | Flip the hosted sweep object along horizontal line.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveSegment | Remove segments from the hosted sweep object.
Public method | SetEndPointParameter | Set segment's start point or end point parameter.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | VerticalFlip | Flip the hosted sweep object along vertical line.
Top
See Also

Reference

HostedSweep Class


HostedSweep.AddSegment Method

HostedSweepAddSegment Method

Add segments to the hosted sweep object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract void AddSegment(
    Reference targetRef
)
Public MustOverride Sub AddSegment (
    targetRef As Reference
)
public:
virtual void AddSegment(
    Reference^ targetRef
) abstract
abstract AddSegment :
        targetRef : Reference -> unit

Parameters

targetRef Reference
See Also

Reference

HostedSweep Class


HostedSweep.GetEndPointParameter Method

HostedSweepGetEndPointParameter Method

Retrieve segment's start point or end point parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetEndPointParameter(
    Reference targetRef,
    int endIdx
)
Public Function GetEndPointParameter (
    targetRef As Reference,
    endIdx As Integer
) As Double
public:
double GetEndPointParameter(
    Reference^ targetRef,
    int endIdx
)
member GetEndPointParameter :
        targetRef : Reference *
        endIdx : int -> float

Parameters

targetRef Reference
Segment's reference whose parameter want to be get.
endIdx Int32
Start point (=0) or end point (=1).

Return Value

Double
Start point or end point parameter.
Exceptions
Exception | Condition
InvalidOperationException | Thrown when regeneration fails.
See Also

Reference

HostedSweep Class


HostedSweep.HorizontalFlip Method

HostedSweepHorizontalFlip Method

Flip the hosted sweep object along horizontal line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void HorizontalFlip()
Public Sub HorizontalFlip
public:
void HorizontalFlip()
member HorizontalFlip : unit -> unit
See Also

Reference

HostedSweep Class


HostedSweep.RemoveSegment Method

HostedSweepRemoveSegment Method

Remove segments from the hosted sweep object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveSegment(
    Reference targetRef
)
Public Sub RemoveSegment (
    targetRef As Reference
)
public:
void RemoveSegment(
    Reference^ targetRef
)
member RemoveSegment :
        targetRef : Reference -> unit

Parameters

targetRef Reference
Segment's reference which want to be removed.
Exceptions
Exception | Condition
InvalidOperationException | Thrown when regeneration fails.
See Also

Reference

HostedSweep Class


HostedSweep.SetEndPointParameter Method

HostedSweepSetEndPointParameter Method

Set segment's start point or end point parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SetEndPointParameter(
    Reference targetRef,
    int endIdx,
    double param
)
Public Function SetEndPointParameter (
    targetRef As Reference,
    endIdx As Integer,
    param As Double
) As Boolean
public:
bool SetEndPointParameter(
    Reference^ targetRef,
    int endIdx,
    double param
)
member SetEndPointParameter :
        targetRef : Reference *
        endIdx : int *
        param : float -> bool

Parameters

targetRef Reference
Segment's reference whose parameter want to be set.
endIdx Int32
Start point (=0) or end point (=1).
param Double
Value of parameter.

Return Value

Boolean
true if operation success.
Exceptions
Exception | Condition
InvalidOperationException | Thrown when regeneration fails.
See Also

Reference

HostedSweep Class


HostedSweep.VerticalFlip Method

HostedSweepVerticalFlip Method

Flip the hosted sweep object along vertical line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void VerticalFlip()
Public Sub VerticalFlip
public:
void VerticalFlip()
member VerticalFlip : unit -> unit
See Also

Reference

HostedSweep Class


HostedSweepType Class

An object that represents the attributes for sweep host objects in Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBHostObjAttributes
Autodesk.Revit.DBHostedSweepType
Autodesk.Revit.DB.ArchitectureFasciaType
Autodesk.Revit.DB.ArchitectureGutterType
Autodesk.Revit.DBSlabEdgeType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class HostedSweepType : HostObjAttributes
Public Class HostedSweepType
    Inherits HostObjAttributes
public ref class HostedSweepType : public HostObjAttributes
type HostedSweepType =
    class
        inherit HostObjAttributes
    end

The HostedSweepType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


HostedSweepType Properties

The HostedSweepType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

HostedSweepType Class


HostedSweepType Methods

The HostedSweepType type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

HostedSweepType Class


HostObjAttributes Class

An object that represents characteristics of several kinds of type.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBHostObjAttributes
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class HostObjAttributes : ElementType
Public Class HostObjAttributes
    Inherits ElementType
public ref class HostObjAttributes : public ElementType
type HostObjAttributes =
    class
        inherit ElementType
    end

The HostObjAttributes type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetCompoundStructure | Sets the compound structure of the element.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This object provides access to structural layering components for any object derived from it, such as wall types and floor types.
See Also

Reference

Autodesk.Revit.DB Namespace
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBHostObjAttributes
Autodesk.Revit.DBBuildingPadType
Autodesk.Revit.DBCeilingType
Autodesk.Revit.DBCurtainSystemType
Autodesk.Revit.DBFloorType
Autodesk.Revit.DBHostedSweepType
Autodesk.Revit.DBMEPCurveType
Autodesk.Revit.DBRoofType
Autodesk.Revit.DBToposolidType
Autodesk.Revit.DBWallFoundationType
Autodesk.Revit.DBWallType


HostObjAttributes Properties

The HostObjAttributes type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

HostObjAttributes Class


HostObjAttributes Methods

The HostObjAttributes type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetCompoundStructure | Sets the compound structure of the element.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

HostObjAttributes Class


HostObjAttributes.GetCompoundStructure Method

HostObjAttributesGetCompoundStructure Method

Returns an object that represents the compound structure of the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CompoundStructure GetCompoundStructure()
Public Function GetCompoundStructure As CompoundStructure
public:
CompoundStructure^ GetCompoundStructure()
member GetCompoundStructure : unit -> CompoundStructure

Return Value

CompoundStructure
Remarks
A copy of the compound structure is returned and changes made to it will not apply to the type until SetCompoundStructure is called. From this object the layers of a compound structure can be accessed. If the element does not have a compound structure then this method will return .
See Also

Reference

HostObjAttributes Class


HostObjAttributes.SetCompoundStructure Method

HostObjAttributesSetCompoundStructure Method

Sets the compound structure of the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetCompoundStructure(
    CompoundStructure compoundStructure
)
Public Sub SetCompoundStructure (
    compoundStructure As CompoundStructure
)
public:
void SetCompoundStructure(
    CompoundStructure^ compoundStructure
)
member SetCompoundStructure :
        compoundStructure : CompoundStructure -> unit

Parameters

compoundStructure CompoundStructure
See Also

Reference

HostObjAttributes Class


HostObject Class

A base class that provides support for all objects that can host other objects, such as walls roofs, and floors.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBHostObject
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class HostObject : Element
Public Class HostObject
    Inherits Element
public ref class HostObject : public Element
type HostObject =
    class
        inherit Element
    end

The HostObject type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FindInserts | Gets the ids of the instances inserted into this host object.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBHostObject
Autodesk.Revit.DBCeilingAndFloor
Autodesk.Revit.DBCurtainGridLine
Autodesk.Revit.DBCurtainSystemBase
Autodesk.Revit.DBFaceToposolid
Autodesk.Revit.DBFaceWall
Autodesk.Revit.DBHostedSweep
Autodesk.Revit.DBMEPCurve
Autodesk.Revit.DBRoofBase
Autodesk.Revit.DBWall
Autodesk.Revit.DBWallFoundation
Autodesk.Revit.DBWallSweep


HostObject Properties

The HostObject type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

HostObject Class


HostObject Methods

The HostObject type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FindInserts | Gets the ids of the instances inserted into this host object.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

HostObject Class


HostObject.FindInserts Method

HostObjectFindInserts Method

Gets the ids of the instances inserted into this host object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ElementId> FindInserts(
    bool addRectOpenings,
    bool includeShadows,
    bool includeEmbeddedWalls,
    bool includeSharedEmbeddedInserts
)
Public Function FindInserts (
    addRectOpenings As Boolean,
    includeShadows As Boolean,
    includeEmbeddedWalls As Boolean,
    includeSharedEmbeddedInserts As Boolean
) As IList(Of ElementId)
public:
IList<ElementId^>^ FindInserts(
    bool addRectOpenings,
    bool includeShadows,
    bool includeEmbeddedWalls,
    bool includeSharedEmbeddedInserts
)
member FindInserts :
        addRectOpenings : bool *
        includeShadows : bool *
        includeEmbeddedWalls : bool *
        includeSharedEmbeddedInserts : bool -> IList<ElementId>

Parameters

addRectOpenings Boolean
True if rectangular openings should be included in the return.
includeShadows Boolean
True if shadows should be included in the return.
includeEmbeddedWalls Boolean
True if embedded walls should be included in the return.
includeSharedEmbeddedInserts Boolean
True if shared embedded inserts should be included in the return.

Return Value

IList ElementId
All the insertable instances' ids.
See Also

Reference

HostObject Class


HostObjectUtils Class

These are generic host object utilities.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBHostObjectUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class HostObjectUtils
Public NotInheritable Class HostObjectUtils
public ref class HostObjectUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type HostObjectUtils = class end

The HostObjectUtils type exposes the following members.

Methods
Name | Description
GetBottomFaces | Returns the bottom faces for this host object.
GetSideFaces | Returns the major side faces for this host object.
GetTopFaces | Returns the top faces for this host object.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


HostObjectUtils Methods

The HostObjectUtils type exposes the following members.

Methods
Name | Description
GetBottomFaces | Returns the bottom faces for this host object.
GetSideFaces | Returns the major side faces for this host object.
GetTopFaces | Returns the top faces for this host object.
Top
See Also

Reference

HostObjectUtils Class


HostObjectUtils.GetBottomFaces Method

HostObjectUtilsGetBottomFaces Method

Returns the bottom faces for this host object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<Reference> GetBottomFaces(
    HostObject hostObject
)
Public Shared Function GetBottomFaces (
    hostObject As HostObject
) As IList(Of Reference)
public:
static IList<Reference^>^ GetBottomFaces(
    HostObject^ hostObject
)
static member GetBottomFaces :
        hostObject : HostObject -> IList<Reference>

Parameters

hostObject HostObject
The host object.

Return Value

IList Reference
An array of references to the faces which are at the bottom of this element.
Exceptions
Exception | Condition
ArgumentException | This host object does not support access to top or bottom faces.
ArgumentNullException | A non-optional argument was null
Remarks
This utility supports host objects whose bottom faces represent one of the boundaries of CompoundStructure (such as roofs, floors or ceilings).
See Also

Reference

HostObjectUtils Class


HostObjectUtils.GetSideFaces Method

HostObjectUtilsGetSideFaces Method

Returns the major side faces for this host object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<Reference> GetSideFaces(
    HostObject hostObject,
    ShellLayerType side
)
Public Shared Function GetSideFaces (
    hostObject As HostObject,
    side As ShellLayerType
) As IList(Of Reference)
public:
static IList<Reference^>^ GetSideFaces(
    HostObject^ hostObject,
    ShellLayerType side
)
static member GetSideFaces :
        hostObject : HostObject *
        side : ShellLayerType -> IList<Reference>

Parameters

hostObject HostObject
The host object.
side ShellLayerType
The side of the host object.

Return Value

IList Reference
An array of references to the faces which are on the given side of this element.
Exceptions
Exception | Condition
ArgumentException | This host object does not support access to side faces.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Remarks
This utility supports host objects whose CompoundStructure is nominally oriented vertically. It outputs faces which are at the boundary of the CompoundStructure (such as Walls and FaceWalls).
See Also

Reference

HostObjectUtils Class


HostObjectUtils.GetTopFaces Method

HostObjectUtilsGetTopFaces Method

Returns the top faces for this host object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<Reference> GetTopFaces(
    HostObject hostObject
)
Public Shared Function GetTopFaces (
    hostObject As HostObject
) As IList(Of Reference)
public:
static IList<Reference^>^ GetTopFaces(
    HostObject^ hostObject
)
static member GetTopFaces :
        hostObject : HostObject -> IList<Reference>

Parameters

hostObject HostObject
The host object.

Return Value

IList Reference
An array of references to the faces which are at the top of this element.
Exceptions
Exception | Condition
ArgumentException | This host object does not support access to top or bottom faces.
ArgumentNullException | A non-optional argument was null
Remarks
This utility supports host objects whose top faces represent one of the boundaries of CompoundStructure (such as roofs, floors or ceilings).
See Also

Reference

HostObjectUtils Class


ICentralLockedCallback Interface

An interface that may be used to control Revit's behavior when it tries to lock central and is blocked because another user already has locked central.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICentralLockedCallback
Public Interface ICentralLockedCallback
public interface class ICentralLockedCallback
type ICentralLockedCallback = interface end

The ICentralLockedCallback type exposes the following members.

Methods
 | Name | Description
Public method | ShouldWaitForLockAvailability | Returns whether Revit should wait and try again to acquire the lock on central.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ICentralLockedCallback Methods

The ICentralLockedCallback type exposes the following members.

Methods
 | Name | Description
Public method | ShouldWaitForLockAvailability | Returns whether Revit should wait and try again to acquire the lock on central.
Top
See Also

Reference

ICentralLockedCallback Interface


ICentralLockedCallback.ShouldWaitForLockAvailability Method

ICentralLockedCallbackShouldWaitForLockAvailability Method

Returns whether Revit should wait and try again to acquire the lock on central.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ShouldWaitForLockAvailability()
Function ShouldWaitForLockAvailability As Boolean
bool ShouldWaitForLockAvailability()
abstract ShouldWaitForLockAvailability : unit -> bool

Return Value

Boolean
True means wait and try again later. False means immediately give up.
See Also

Reference

ICentralLockedCallback Interface


IConnector Interface

An interface which provides access to connector in Autodesk Revit MEP document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IConnector
Public Interface IConnector
public interface class IConnector
type IConnector = interface end

The IConnector type exposes the following members.

Properties
 | Name | Description
Public property | CoordinateSystem | The coordinate system of the connector.
Public property | Domain | The domain of the connector.
Public property | Height | The height of the connector.
Public property | Origin | The location of the connector in family document.
Public property | Radius | The radius of the connector.
Public property | Shape | The shape of the connector.
Public property | Width | The width of the connector.
Top
Remarks
This interface is shared by Connector, ConnectorElement.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


IConnector Properties

The IConnector type exposes the following members.

Properties
 | Name | Description
Public property | CoordinateSystem | The coordinate system of the connector.
Public property | Domain | The domain of the connector.
Public property | Height | The height of the connector.
Public property | Origin | The location of the connector in family document.
Public property | Radius | The radius of the connector.
Public property | Shape | The shape of the connector.
Public property | Width | The width of the connector.
Top
See Also

Reference

IConnector Interface


IConnector.CoordinateSystem Property

IConnectorCoordinateSystem Property

The coordinate system of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Transform CoordinateSystem { get; }
ReadOnly Property CoordinateSystem As Transform
    Get
property Transform^ CoordinateSystem {
    Transform^ get ();
}
abstract CoordinateSystem : Transform with get

Property Value

Transform
Remarks
The Z axis of the coordinate system is the normal to the plane of the connector.
See Also

Reference

IConnector Interface


IConnector.Domain Property

IConnectorDomain Property

The domain of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
Domain Domain { get; }
ReadOnly Property Domain As Domain
    Get
property Domain Domain {
    Domain get ();
}
abstract Domain : Domain with get

Property Value

Domain
Remarks
This property is used to retrieve the domain of the connector.
See Also

Reference

IConnector Interface


IConnector.Height Property

IConnectorHeight Property

The height of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
double Height { get; }
ReadOnly Property Height As Double
    Get
property double Height {
    double get ();
}
abstract Height : float with get

Property Value

Double
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the connector's shape is not rectangular.
Remarks
This property is used to retrieve the height of the connector.
See Also

Reference

IConnector Interface


IConnector.Origin Property

IConnectorOrigin Property

The location of the connector in family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
XYZ Origin { get; }
ReadOnly Property Origin As XYZ
    Get
property XYZ^ Origin {
    XYZ^ get ();
}
abstract Origin : XYZ with get

Property Value

XYZ
Remarks
This property is used to retrieve the origin of the connector.
See Also

Reference

IConnector Interface


IConnector.Radius Property

IConnectorRadius Property

The radius of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
double Radius { get; }
ReadOnly Property Radius As Double
    Get
property double Radius {
    double get ();
}
abstract Radius : float with get

Property Value

Double
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the connector's shape is not round.
Remarks
This property is used to retrieve the radius of the connector.
See Also

Reference

IConnector Interface


IConnector.Shape Property

IConnectorShape Property

The shape of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
ConnectorProfileType Shape { get; }
ReadOnly Property Shape As ConnectorProfileType
    Get
property ConnectorProfileType Shape {
    ConnectorProfileType get ();
}
abstract Shape : ConnectorProfileType with get

Property Value

ConnectorProfileType
Exceptions
Exception | Condition
InvalidOperationException | Throw when this connector has no shape.
Remarks
This property is used to retrieve the shape of the connector.
See Also

Reference

IConnector Interface


IConnector.Width Property

IConnectorWidth Property

The width of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
double Width { get; }
ReadOnly Property Width As Double
    Get
property double Width {
    double get ();
}
abstract Width : float with get

Property Value

Double
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the connector's shape is not rectangular.
Remarks
This property is used to retrieve the width of the connector.
See Also

Reference

IConnector Interface


ICustomFieldProperties Interface

Represents the base class for the properties of a custom field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ICustomFieldProperties
Public Interface ICustomFieldProperties
public interface class ICustomFieldProperties
type ICustomFieldProperties = interface end

The ICustomFieldProperties type exposes the following members.

Methods
 | Name | Description
Public method | AreEqualTo | Identifies if the custom field properties are equal or not.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ICustomFieldProperties Methods

The ICustomFieldProperties type exposes the following members.

Methods
 | Name | Description
Public method | AreEqualTo | Identifies if the custom field properties are equal or not.
Top
See Also

Reference

ICustomFieldProperties Interface


ICustomFieldProperties.AreEqualTo Method

ICustomFieldPropertiesAreEqualTo Method

Identifies if the custom field properties are equal or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool AreEqualTo(
    ICustomFieldProperties otherProperties
)
Function AreEqualTo (
    otherProperties As ICustomFieldProperties
) As Boolean
bool AreEqualTo(
    ICustomFieldProperties^ otherProperties
)
abstract AreEqualTo :
        otherProperties : ICustomFieldProperties -> bool

Parameters

otherProperties ICustomFieldProperties
The other properties.

Return Value

Boolean
Returns true if the custom field properties are equal, false otherwise.
See Also

Reference

ICustomFieldProperties Interface


IDataConversionMonitor Interface

A base class for an application-specific logger. It should be used to track errors during conversion and/or , track conversion progress, cancel a conversion process if necessary. Implementing a logger class is optional, but highly recommended for all but most basic data converters. The base class is UI- and language-independent. It is up to the using app to implement UI. Language-specifc data may be used to communicate information to application users. English should be used to communicate data of interest to Revit development.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IDataConversionMonitor
Public Interface IDataConversionMonitor
public interface class IDataConversionMonitor
type IDataConversionMonitor = interface end

The IDataConversionMonitor type exposes the following members.

Methods
Name | Description
Public method | GetVerbosity | Reports requested verbosity level
Public method | ProcessMessage | The default implementation ignores input and always returns true. The using app should override the behavior as necessary. Some examples of overridden behavior are 1. Someone is developing a classic Revit add-on that imports STEP AP 203 solids. She will implement a log object such that a) At each imported face (logMessage() called with LogMessage::FaceCreated as first argument) the log object will update count of imported faces and call an application-specific progress indicator where appropriate b) If the app gets a cancel request between the calls to logMessage(), the next call will return false. The Import API will then cancel the conversion and clean up the intermediate data. 2. Someone is implementing a web service to convert IFC files to RVT. As a part of that service UI, the user would like to cancel the conversion on the first error in order to avoid being charged for storage/processor time. The implementation of logMessage() in that case would be different: the cancellation request would be based on severity of the error. The app would probably want to keep a detailed count of entities converted. 3. Someone is implementing an IFC importer. Each API call is fast enough that cancelation/progress requests are handled by the application. Problems with data should be reported to the user, but the conversion should go on regardless. The app collects its own conversion statistics. The app developer implements logMessage() to accumulate reported errors and appends the formatted results to her conversion report. The overloaded logMessage() always returns true, since all cancellations are handled by the app.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


IDataConversionMonitor Methods

The IDataConversionMonitor type exposes the following members.

Methods
Name | Description
Public method | GetVerbosity | Reports requested verbosity level
Public method | ProcessMessage | The default implementation ignores input and always returns true. The using app should override the behavior as necessary. Some examples of overridden behavior are 1. Someone is developing a classic Revit add-on that imports STEP AP 203 solids. She will implement a log object such that a) At each imported face (logMessage() called with LogMessage::FaceCreated as first argument) the log object will update count of imported faces and call an application-specific progress indicator where appropriate b) If the app gets a cancel request between the calls to logMessage(), the next call will return false. The Import API will then cancel the conversion and clean up the intermediate data. 2. Someone is implementing a web service to convert IFC files to RVT. As a part of that service UI, the user would like to cancel the conversion on the first error in order to avoid being charged for storage/processor time. The implementation of logMessage() in that case would be different: the cancellation request would be based on severity of the error. The app would probably want to keep a detailed count of entities converted. 3. Someone is implementing an IFC importer. Each API call is fast enough that cancelation/progress requests are handled by the application. Problems with data should be reported to the user, but the conversion should go on regardless. The app collects its own conversion statistics. The app developer implements logMessage() to accumulate reported errors and appends the formatted results to her conversion report. The overloaded logMessage() always returns true, since all cancellations are handled by the app.
Top
See Also

Reference

IDataConversionMonitor Interface


IDataConversionMonitor.GetVerbosity Method

IDataConversionMonitorGetVerbosity Method

Reports requested verbosity level

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
DataExchangeMessageVerbosity GetVerbosity()
Function GetVerbosity As DataExchangeMessageVerbosity
DataExchangeMessageVerbosity GetVerbosity()
abstract GetVerbosity : unit -> DataExchangeMessageVerbosity

Return Value

DataExchangeMessageVerbosity
See Also

Reference

IDataConversionMonitor Interface


IDataConversionMonitor.ProcessMessage Method

IDataConversionMonitorProcessMessage Method

The default implementation ignores input and always returns true. The using app should override the behavior as necessary. Some examples of overridden behavior are 1. Someone is developing a classic Revit add-on that imports STEP AP 203 solids. She will implement a log object such that a) At each imported face (logMessage() called with LogMessage::FaceCreated as first argument) the log object will update count of imported faces and call an application-specific progress indicator where appropriate b) If the app gets a cancel request between the calls to logMessage(), the next call will return false. The Import API will then cancel the conversion and clean up the intermediate data. 2. Someone is implementing a web service to convert IFC files to RVT. As a part of that service UI, the user would like to cancel the conversion on the first error in order to avoid being charged for storage/processor time. The implementation of logMessage() in that case would be different: the cancellation request would be based on severity of the error. The app would probably want to keep a detailed count of entities converted. 3. Someone is implementing an IFC importer. Each API call is fast enough that cancelation/progress requests are handled by the application. Problems with data should be reported to the user, but the conversion should go on regardless. The app collects its own conversion statistics. The app developer implements logMessage() to accumulate reported errors and appends the formatted results to her conversion report. The overloaded logMessage() always returns true, since all cancellations are handled by the app.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ProcessMessage(
    DataExchangeMessageId messageId,
    DataExchangeMessageSeverity messageSeverity,
    IList<string> entityIds
)
Function ProcessMessage (
    messageId As DataExchangeMessageId,
    messageSeverity As DataExchangeMessageSeverity,
    entityIds As IList(Of String)
) As Boolean
bool ProcessMessage(
    DataExchangeMessageId messageId,
    DataExchangeMessageSeverity messageSeverity,
    IList<String^>^ entityIds
)
abstract ProcessMessage :
        messageId : DataExchangeMessageId *
        messageSeverity : DataExchangeMessageSeverity *
        entityIds : IList<string> -> bool

Parameters

messageId DataExchangeMessageId
Indicates a specific event during data conversion.
messageSeverity DataExchangeMessageSeverity
Indicates a severity of the event.
entityIds IList String
Input objects affected by the reported event.

Return Value

Boolean
If the function returns true, the import API will continue conversion. Otherwise, it will be cancelled and all intermediate data reset.
See Also

Reference

IDataConversionMonitor Interface


IDuplicateTypeNamesHandler Interface

An interface for custom handlers of duplicate type names encountered during a paste operation. When the destination document contains types that have the same names as the types being copied, but different internals, a decision must be made on how to proceed - whether to cancel the operation or continue, but only copy types with unique names.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IDuplicateTypeNamesHandler
Public Interface IDuplicateTypeNamesHandler
public interface class IDuplicateTypeNamesHandler
type IDuplicateTypeNamesHandler = interface end

The IDuplicateTypeNamesHandler type exposes the following members.

Methods
 | Name | Description
Public method | OnDuplicateTypeNamesFound | Called when the destination document contains types with the same names as the types being copied.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


IDuplicateTypeNamesHandler Methods

The IDuplicateTypeNamesHandler type exposes the following members.

Methods
 | Name | Description
Public method | OnDuplicateTypeNamesFound | Called when the destination document contains types with the same names as the types being copied.
Top
See Also

Reference

IDuplicateTypeNamesHandler Interface


IDuplicateTypeNamesHandler.OnDuplicateTypeNamesFound Method

IDuplicateTypeNamesHandlerOnDuplicateTypeNamesFound Method

Called when the destination document contains types with the same names as the types being copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
DuplicateTypeAction OnDuplicateTypeNamesFound(
    DuplicateTypeNamesHandlerArgs args
)
Function OnDuplicateTypeNamesFound (
    args As DuplicateTypeNamesHandlerArgs
) As DuplicateTypeAction
DuplicateTypeAction OnDuplicateTypeNamesFound(
    DuplicateTypeNamesHandlerArgs^ args
)
abstract OnDuplicateTypeNamesFound :
        args : DuplicateTypeNamesHandlerArgs -> DuplicateTypeAction

Parameters

args DuplicateTypeNamesHandlerArgs
The information about the types with duplicate names.

Return Value

DuplicateTypeAction
The action to be taken: copy only types with unique names or cancel the operation.
See Also

Reference

IDuplicateTypeNamesHandler Interface


IExportContext Interface

An interface that is used in custom export to process a Revit model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IExportContext
Public Interface IExportContext
public interface class IExportContext
type IExportContext = interface end

The IExportContext type exposes the following members.

Methods
 | Name | Description
Public method | Finish | This method is called at the very end of the export process, after all entities were processed (or after the process was cancelled).
Public method | IsCanceled | This method is queried at the beginning of every element.
 | OnElementBegin | This method marks the beginning of an element to be exported.
Public method | OnElementEnd | This method marks the end of an element being exported.
 | OnFaceBegin | This method marks the beginning of a Face to be exported.
Public method | OnFaceEnd | This method marks the end of the current face being exported.
 | OnInstanceBegin | This method marks the start of processing of an instance node (e.g. a family instance).
Public method | OnInstanceEnd | This method marks the end of processing of an Instance Node (e.g. a family instance).
 | OnLight | This method marks the beginning of export of a light which is enabled for rendering.
 | OnLinkBegin | This method marks the beginning of a link instance to be exported.
Public method | OnLinkEnd | This method marks the end of a link instance being exported.
 | OnMaterial | This method marks a change of the material.
 | OnPolymesh | This method is called when a tessellated polymesh of a 3d face is being output.
Public method | OnRPC | This method marks the beginning of export of an RPC object.
 | OnViewBegin | This method marks the beginning of a 3D view to be exported.
Public method | OnViewEnd | This method marks the end of a 3D view being exported.
 | Start | This method is called at the very start of the export process, still before the first entity of the model was send out.
Top
Remarks

An instance of a class that implements this interface is passed in as a parameter of the CustomExporter constructor. The methods of the context are then called at times of exporting entities of the model.

This is a base class for two other interfaces derived from it: IPhotoRenderContext and IModelExportContext. This base class contains methods that are common to both the leaf interfaces. Although it is still possible to use classes deriving directly from this base interface (for backward compatibility), future applications should implement the new leaf interfaces only.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


IExportContext Methods

The IExportContext type exposes the following members.

Methods
 | Name | Description
Public method | Finish | This method is called at the very end of the export process, after all entities were processed (or after the process was cancelled).
Public method | IsCanceled | This method is queried at the beginning of every element.
 | OnElementBegin | This method marks the beginning of an element to be exported.
Public method | OnElementEnd | This method marks the end of an element being exported.
 | OnFaceBegin | This method marks the beginning of a Face to be exported.
Public method | OnFaceEnd | This method marks the end of the current face being exported.
 | OnInstanceBegin | This method marks the start of processing of an instance node (e.g. a family instance).
Public method | OnInstanceEnd | This method marks the end of processing of an Instance Node (e.g. a family instance).
 | OnLight | This method marks the beginning of export of a light which is enabled for rendering.
 | OnLinkBegin | This method marks the beginning of a link instance to be exported.
Public method | OnLinkEnd | This method marks the end of a link instance being exported.
 | OnMaterial | This method marks a change of the material.
 | OnPolymesh | This method is called when a tessellated polymesh of a 3d face is being output.
Public method | OnRPC | This method marks the beginning of export of an RPC object.
 | OnViewBegin | This method marks the beginning of a 3D view to be exported.
Public method | OnViewEnd | This method marks the end of a 3D view being exported.
 | Start | This method is called at the very start of the export process, still before the first entity of the model was send out.
Top
See Also

Reference

IExportContext Interface


IExportContext.Finish Method

IExportContextFinish Method

This method is called at the very end of the export process, after all entities were processed (or after the process was cancelled).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Finish()
Sub Finish
void Finish()
abstract Finish : unit -> unit
See Also

Reference

IExportContext Interface


IExportContext.IsCanceled Method

IExportContextIsCanceled Method

This method is queried at the beginning of every element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsCanceled()
Function IsCanceled As Boolean
bool IsCanceled()
abstract IsCanceled : unit -> bool

Return Value

Boolean
Return True if you wish to cancel the exporting process, or False otherwise.
See Also

Reference

IExportContext Interface


IExportContext.OnElementBegin Method

IExportContextOnElementBegin Method

This method marks the beginning of an element to be exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
RenderNodeAction OnElementBegin(
    ElementId elementId
)
Function OnElementBegin (
    elementId As ElementId
) As RenderNodeAction
RenderNodeAction OnElementBegin(
    ElementId^ elementId
)
abstract OnElementBegin :
        elementId : ElementId -> RenderNodeAction

Parameters

elementId ElementId
The Id of the element that is about to be processed.

Return Value

RenderNodeAction
Return RenderNodeAction.Skip if you wish to skip exporting this element, or return RenderNodeAction.Proceed otherwise.
Remarks
This method is never called for 2D export (see cref="Autodesk::Revit::DB::IExportContext2D").
Example
C#
VB
C++
F#
Copy
/// <summary>
/// Often it is found beneficial to keep a stack of th element(s)
/// currently being processed, so it can be refer to it from other
/// methods of the export context.
/// </summary>
Stack<ElementId> m_elementStack = new Stack<ElementId>();

ElementId CurrentElementId()
{
   return (m_elementStack.Count > 0) ? m_elementStack.Peek() : ElementId.InvalidElementId;
}

/// <summary>
/// Method that indicates the start of processing an element.
/// </summary>
public RenderNodeAction OnElementBegin(ElementId elementId)
{
   // We may find it useful to remember this element's Id.
   // So we can refer to it in methods invoked during the
   // export process of this element
   m_elementStack.Push(elementId);

   // We can use the element's Id to find out more about the element being processed.
   // For example, we can test if the element is a wall; if it is, we can get more
   // information about the wall and then we can proceed with the export, which will
   // continue with processing geometry of the element. Elements that are not wall
   // will be skipped.

   Wall theWall = m_document.GetElement(elementId) as Wall;
   if (theWall != null)
   {
      double wallVolume = theWall.get_Parameter(BuiltInParameter.HOST_VOLUME_COMPUTED).AsDouble();
      return RenderNodeAction.Proceed;
   }
   else
   {
      return RenderNodeAction.Skip;
   }
}

/// <summary>
/// Method that indicates the end of processing an element
/// </summary>
public void OnElementEnd(ElementId elementId)
{
   // Note: this method is invoked even for elements that were skipped.

   m_elementStack.Pop();
}
' <summary>
' Often it is found beneficial to keep a stack of th element(s)
' currently being processed, so it can be refer to it from other
' methods of the export context.
' </summary>
Private m_elementStack As New Stack(Of ElementId)()

Private Function CurrentElementId() As ElementId
    Return If((m_elementStack.Count > 0), m_elementStack.Peek(), ElementId.InvalidElementId)
End Function

' <summary>
' Method that indicates the start of processing an element.
' </summary>
Public Function OnElementBegin(elementId As ElementId) As RenderNodeAction Implements IExportContext.OnElementBegin
    ' We may find it useful to remember this element's Id.
    ' So we can refer to it in methods invoked during the
    ' export process of this element
    m_elementStack.Push(elementId)

    ' We can use the element's Id to find out more about the element being processed.
    ' For example, we can test if the element is a wall; if it is, we can get more
    ' information about the wall and then we can proceed with the export, which will
    ' continue with processing geometry of the element. Elements that are not wall
    ' will be skipped.

    Dim theWall As Wall = TryCast(m_document.GetElement(elementId), Wall)
    If theWall IsNot Nothing Then
        Dim wallVolume As Double = theWall.Parameter(BuiltInParameter.HOST_VOLUME_COMPUTED).AsDouble()
        Return RenderNodeAction.Proceed
    Else
        Return RenderNodeAction.Skip
    End If
End Function

' <summary>
' Method that indicates the end of processing an element
' </summary>
Public Sub OnElementEnd(elementId As ElementId) Implements IExportContext.OnElementEnd
    ' Note: this method is invoked even for elements that were skipped.

    m_elementStack.Pop()
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

IExportContext Interface


IExportContext.OnElementEnd Method

IExportContextOnElementEnd Method

This method marks the end of an element being exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void OnElementEnd(
    ElementId elementId
)
Sub OnElementEnd (
    elementId As ElementId
)
void OnElementEnd(
    ElementId^ elementId
)
abstract OnElementEnd :
        elementId : ElementId -> unit

Parameters

elementId ElementId
The Id of the element that has just been processed.
Remarks
This method is never called for 2D export (see cref="Autodesk::Revit::DB::IExportContext2D").
See Also

Reference

IExportContext Interface


IExportContext.OnFaceBegin Method

IExportContextOnFaceBegin Method

This method marks the beginning of a Face to be exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
RenderNodeAction OnFaceBegin(
    FaceNode node
)
Function OnFaceBegin (
    node As FaceNode
) As RenderNodeAction
RenderNodeAction OnFaceBegin(
    FaceNode^ node
)
abstract OnFaceBegin :
        node : FaceNode -> RenderNodeAction

Parameters

node FaceNode
An output node that represents a Face.

Return Value

RenderNodeAction
Return RenderNodeAction. Proceed if you wish to receive geometry (polymesh) for this face, or return RenderNodeAction.Skip otherwise.
Remarks
Note that this method (as well as OnFaceEnd) is invoked only if the custom exporter was set up to include geometric objects in the output stream. See IncludeGeometricObjects for mode details.
Example
C#
VB
C++
F#
Copy
/// <summary>
/// This code demonstrates how to process face geometry
/// </summary>
/// <remarks>
/// This method is invoked only if the custom exporter was set to include faces.
/// </remarks>
public RenderNodeAction OnFaceBegin(FaceNode node)
{
   // Get the get the actual geometric face and all information about it
   // and its edges by using standard API for Face and Edge
   Face theFace = node.GetFace();
   double area = theFace.Area;
   if (theFace.HasRegions)
   {
      IList<Face> regionedFaces = theFace.GetRegions();
   }

   // We can either skip this face or proceed with rendering it depending on
   // whether our export process can handle face geometry or not. If we choose
   // to proceed, we get calls to export tessellated meshes for this face.
   if (true == ExportAFace(theFace))
   {
      return RenderNodeAction.Skip;
   }
   return RenderNodeAction.Proceed;
}

/// <summary>
/// This code marks the end of processing a face
/// </summary>
/// <remarks>
/// This method is invoked only if the custom exporter was set to include faces.
/// </remarks>
public void OnFaceEnd(FaceNode node)
{
   // Note: This method is invoked even for faces that were skipped.
}

/// <summary>
/// Assuming this would be the method that processes faces and exports them in our proprietary format.
/// </summary>
/// <remarks>
/// For example, we can decide that our format supports planar faces only, but no curved surfaces.
/// Or we can support basic surfaces only (planar, spherical, cylindrical), but not complex faces.
/// This is, naturally, depending on what a particular custom exporter is designed to output.
/// </remarks>
/// <returns>
/// Should return True if the face could be handled (exported), False otherwise.
/// </returns>
private bool ExportAFace(Face face)
{
   return false;  // in this case,
}
' <summary>
' This code demonstrates how to process face geometry
' </summary>
' <remarks>
' This method is invoked only if the custom exporter was set to include faces.
' </remarks>
Public Function OnFaceBegin(node As FaceNode) As RenderNodeAction Implements IExportContext.OnFaceBegin
    ' Get the get the actual geometric face and all information about it
    ' and its edges by using standard API for Face and Edge
    Dim theFace As Face = node.GetFace()
    Dim area As Double = theFace.Area
    If theFace.HasRegions Then
        Dim regionedFaces As IList(Of Face) = theFace.GetRegions()
    End If

    ' We can either skip this face or proceed with rendering it depending on
    ' whether our export process can handle face geometry or not. If we choose
    ' to proceed, we get calls to export tessellated meshes for this face.
    If True = ExportAFace(theFace) Then
        Return RenderNodeAction.Skip
    End If
    Return RenderNodeAction.Proceed
End Function

' <summary>
' This code marks the end of processing a face
' </summary>
' <remarks>
' This method is invoked only if the custom exporter was set to include faces.
' </remarks>
Public Sub OnFaceEnd(node As FaceNode) Implements IExportContext.OnFaceEnd
    ' Note: This method is invoked even for faces that were skipped.
End Sub

' <summary>
' Assuming this would be the method that processes faces and exports them in our proprietary format.
' </summary>
' <remarks>
' For example, we can decide that our format supports planar faces only, but no curved surfaces.
' Or we can support basic surfaces only (planar, spherical, cylindrical), but not complex faces.
' This is, naturally, depending on what a particular custom exporter is designed to output.
' </remarks>
' <returns>
' Should return True if the face could be handled (exported), False otherwise.
' </returns>
Private Function ExportAFace(face As Face) As Boolean
    Return False
    ' in this case,
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

IExportContext Interface


IExportContext.OnFaceEnd Method

IExportContextOnFaceEnd Method

This method marks the end of the current face being exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void OnFaceEnd(
    FaceNode node
)
Sub OnFaceEnd (
    node As FaceNode
)
void OnFaceEnd(
    FaceNode^ node
)
abstract OnFaceEnd :
        node : FaceNode -> unit

Parameters

node FaceNode
An output node that represents a Face.
See Also

Reference

IExportContext Interface


IExportContext.OnInstanceBegin Method

IExportContextOnInstanceBegin Method

This method marks the start of processing of an instance node (e.g. a family instance).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
RenderNodeAction OnInstanceBegin(
    InstanceNode node
)
Function OnInstanceBegin (
    node As InstanceNode
) As RenderNodeAction
RenderNodeAction OnInstanceBegin(
    InstanceNode^ node
)
abstract OnInstanceBegin :
        node : InstanceNode -> RenderNodeAction

Parameters

node InstanceNode

Return Value

RenderNodeAction
Return RenderNodeAction.Skip if you wish to skip processing this family instance, or return RenderNodeAction.Proceed otherwise.
Example
C#
VB
C++
F#
Copy
/// <summary>
/// This method marks the start of processing of an Instance node (e.g. a family instance).
/// </summary>
public RenderNodeAction OnInstanceBegin(InstanceNode node)
{
   // We can get particular information about the family instance and its type if we need to
   ElementId symbolId = node.GetSymbolGeometryId().SymbolId;
   FamilySymbol famSymbol = m_document.GetElement(symbolId) as FamilySymbol;

   // Typically, an export context has to manage a stack of transformation
   // for all nested objects, such as instances, lights, links, etc.
   // A combined transformation needs to be applied to the incoming geometry
   // (providing all geometry is to be flattened in the resultant format.)
   m_TransformationStack.Push(m_TransformationStack.Peek().Multiply(node.GetTransform()));

   // We can either skip this instance or proceed with rendering it.
   return RenderNodeAction.Proceed;
}

/// <summary>
/// This method marks the end of processing of an Instance Node (e.g. a family instance).
/// </summary>
public void OnInstanceEnd(InstanceNode node)
{
   // Note: This method is invoked even for instances that were skipped.

   // If we maintain a transformation stack, we need to remove the latest one from it.
   m_TransformationStack.Pop();
}
' <summary>
' This method marks the end of processing of an Instance Node (e.g. a family instance).
' </summary>
Public Function OnInstanceBegin(node As InstanceNode) As RenderNodeAction Implements IExportContext.OnInstanceBegin
    ' We can get particular information about the family instance and its type if we need to
    Dim symbolId As ElementId = node.GetSymbolGeometryId().SymbolId
    Dim famSymbol As FamilySymbol = TryCast(m_document.GetElement(symbolId), FamilySymbol)

    ' Typically, an export context has to manage a stack of transformation
    ' for all nested objects, such as instances, lights, links, etc.
    ' A combined transformation needs to be applied to the incoming geometry
    ' (providing all geometry is to be flattened in the resultant format.)
    m_TransformationStack.Push(m_TransformationStack.Peek().Multiply(node.GetTransform()))

    ' We can either skip this instance or proceed with rendering it.
    Return RenderNodeAction.Proceed
End Function

' <summary>
' This method marks the end of processing a family instance
' </summary>
Public Sub OnInstanceEnd(node As InstanceNode) Implements IExportContext.OnInstanceEnd
    ' Note: This method is invoked even for instances that were skipped.

    ' If we maintain a transformation stack, we need to remove the latest one from it.
    m_TransformationStack.Pop()
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

IExportContext Interface


IExportContext.OnInstanceEnd Method

IExportContextOnInstanceEnd Method

This method marks the end of processing of an Instance Node (e.g. a family instance).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void OnInstanceEnd(
    InstanceNode node
)
Sub OnInstanceEnd (
    node As InstanceNode
)
void OnInstanceEnd(
    InstanceNode^ node
)
abstract OnInstanceEnd :
        node : InstanceNode -> unit

Parameters

node InstanceNode
An output node that represents a family instance.
See Also

Reference

IExportContext Interface


IExportContext.OnLight Method

IExportContextOnLight Method

This method marks the beginning of export of a light which is enabled for rendering.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void OnLight(
    LightNode node
)
Sub OnLight (
    node As LightNode
)
void OnLight(
    LightNode^ node
)
abstract OnLight :
        node : LightNode -> unit

Parameters

node LightNode
A node describing the light object.
Remarks
This method is only called for photo-rendering export (a custom exporter that implements IPhotoRenderContext).
Example
C#
VB
C++
F#
Copy
/// <summary>
/// This method is called for instances of lights
/// </summary>
/// <remarks>
/// The Light API can be used to get more information about each particular light
/// </remarks>
public void OnLight(LightNode node)
{
   // Obtain local transform data of the light object.
   Transform lightTrf = node.GetTransform();

   // Note: 1. If your light coordinate system differs from the one in REvit,
   //   The light's local transform should be adjusted to reflect the difference.

   // Note 2. This local transform describes the light source position and light direction data.
   //   It means the "TiltAngle" property of a spot light has already been accounted for.

   // If a stack of transformation is maintained by the context object,
   // the current combined transform will be multiplied by the local transform.
   Transform lightWorldTrf = m_TransformationStack.Peek().Multiply(lightTrf);

}
' <summary>
' This method is called for instances of lights
' </summary>
' <remarks>
' The Light API can be used to get more information about each particular light
' </remarks>
Public Sub OnLight(node As LightNode) Implements IExportContext.OnLight
    ' Obtain local transform data of the light object.
    Dim lightTrf As Transform = node.GetTransform()

    ' Note: 1. If your light coordinate system differs from the one in REvit,
    '   The light's local transform should be adjusted to reflect the difference.

    ' Note 2. This local transform describes the light source position and light direction data.
    '   It means the "TiltAngle" property of a spot light has already been accounted for.

    ' If a stack of transformation is maintained by the context object,
    ' the current combined transform will be multiplied by the local transform.
    Dim lightWorldTrf As Transform = m_TransformationStack.Peek().Multiply(lightTrf)

End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

IExportContext Interface


IExportContext.OnLinkBegin Method

IExportContextOnLinkBegin Method

This method marks the beginning of a link instance to be exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
RenderNodeAction OnLinkBegin(
    LinkNode node
)
Function OnLinkBegin (
    node As LinkNode
) As RenderNodeAction
RenderNodeAction OnLinkBegin(
    LinkNode^ node
)
abstract OnLinkBegin :
        node : LinkNode -> RenderNodeAction

Parameters

node LinkNode

Return Value

RenderNodeAction
Return RenderNodeAction.Skip if you wish to skip processing this link instance, or return RenderNodeAction.Proceed otherwise.
Example
C#
VB
C++
F#
Copy
/// <summary>
/// This code demonstrates how to process instances of Revit links.
/// </summary>
public RenderNodeAction OnLinkBegin(LinkNode node)
{
   // We can get more information about the Revit Link and its type if we need to
   ElementId symbolId = node.SymbolId;
   RevitLinkType linkType = m_document.GetElement(symbolId) as RevitLinkType;
   String linkDocumentName = linkType.Name;

   // Typically, an export context has to manage a stack of transformation
   // for all nested objects, such as instances, lights, links, etc.
   // A combined transformation needs to be applied to the incoming geometry
   // (providing all geometry is to be flattened in the resultant format.)
   m_TransformationStack.Push(m_TransformationStack.Peek().Multiply(node.GetTransform()));

   // We can either skip this link instance or proceed with rendering it
   return RenderNodeAction.Proceed;
}

/// <summary>
/// This method marks the end of processing a Revit link
/// </summary>
public void OnLinkEnd(LinkNode node)
{
   // Note: This method is invoked even for instances that were skipped.

   // If we maintain a transformation stack, we need to remove the latest one from it.
   m_TransformationStack.Pop();
}
' <summary>
' This code demonstrates how to process instances of Revit links.
' </summary>
Public Function OnLinkBegin(node As LinkNode) As RenderNodeAction Implements IExportContext.OnLinkBegin
    ' We can get more information about the Revit Link and its type if we need to
    Dim symbolId As ElementId = node.SymbolId
    Dim linkType As RevitLinkType = TryCast(m_document.GetElement(symbolId), RevitLinkType)
    Dim linkDocumentName As [String] = linkType.Name

    ' Typically, an export context has to manage a stack of transformation
    ' for all nested objects, such as instances, lights, links, etc.
    ' A combined transformation needs to be applied to the incoming geometry
    ' (providing all geometry is to be flattened in the resultant format.)
    m_TransformationStack.Push(m_TransformationStack.Peek().Multiply(node.GetTransform()))

    ' We can either skip this link instance or proceed with rendering it
    Return RenderNodeAction.Proceed
End Function

' <summary>
' This method marks the end of processing a Revit link
' </summary>
Public Sub OnLinkEnd(node As LinkNode) Implements IExportContext.OnLinkEnd
    ' Note: This method is invoked even for instances that were skipped.

    ' If we maintain a transformation stack, we need to remove the latest one from it.
    m_TransformationStack.Pop()
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

IExportContext Interface


IExportContext.OnLinkEnd Method

IExportContextOnLinkEnd Method

This method marks the end of a link instance being exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void OnLinkEnd(
    LinkNode node
)
Sub OnLinkEnd (
    node As LinkNode
)
void OnLinkEnd(
    LinkNode^ node
)
abstract OnLinkEnd :
        node : LinkNode -> unit

Parameters

node LinkNode
An output node that represents a Revit link.
See Also

Reference

IExportContext Interface


IExportContext.OnMaterial Method

IExportContextOnMaterial Method

This method marks a change of the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void OnMaterial(
    MaterialNode node
)
Sub OnMaterial (
    node As MaterialNode
)
void OnMaterial(
    MaterialNode^ node
)
abstract OnMaterial :
        node : MaterialNode -> unit

Parameters

node MaterialNode
A node describing the current material.
Example
C#
VB
C++
F#
Copy
ElementId currentMaterialId = ElementId.InvalidElementId;
Color currentColor = new Color(0,0,0);
double currentTransparency = 0;
Asset currentAppearance = null;

/// <summary>
/// This code demonstrates how to process material information
/// </summary>
/// <remarks>
/// OnMaterial method can be invoked for every single out-coming mesh
/// even when the material has not actually changed. Thus it is usually
/// beneficial to store the current material and only get its attributes
/// when the material actually changes.
/// </remarks>
public void OnMaterial(MaterialNode node)
{
   // acquire properties of the material if it is different
   // than the material we have set as the currently applicable
   if (currentMaterialId != node.MaterialId)
   {
      if (node.MaterialId != ElementId.InvalidElementId)
      {
         currentColor = node.Color;
         currentTransparency = node.Transparency;
      }
      else
      {
         // the default material is being used in this case
      }

      // Appearance Asset is mainly for Revit internal use. However, if it is utilized
      // in the export context, it needs to be checked whether or not the asset of the
      // material is overridden by some local modification (e.g. by applying a decal)

      if (node.HasOverriddenAppearance)
      {
         currentAppearance = node.GetAppearanceOverride();
      }
      else
      {
         currentAppearance = node.GetAppearance();
      }
   }
}
Private currentMaterialId As ElementId = ElementId.InvalidElementId
Private currentColor As New Color(0, 0, 0)
Private currentTransparency As Double = 0
Private currentAppearance As Asset = Nothing

' <summary>
' This code demonstrates how to process material information
' </summary>
' <remarks>
' OnMaterial method can be invoked for every single out-coming mesh
' even when the material has not actually changed. Thus it is usually
' beneficial to store the current material and only get its attributes
' when the material actually changes.
' </remarks>
Public Sub OnMaterial(node As MaterialNode) Implements IExportContext.OnMaterial
    ' acquire properties of the material if it is different
    ' than the material we have set as the currently applicable
    If currentMaterialId <> node.MaterialId Then
        If node.MaterialId <> ElementId.InvalidElementId Then
            currentColor = node.Color
            currentTransparency = node.Transparency
            ' the default material is being used in this case
        Else
        End If

        ' Appearance Asset is mainly for Revit internal use. However, if it is utilized
        ' in the export context, it needs to be checked whether or not the asset of the
        ' material is overridden by some local modification (e.g. by applying a decal)

        If node.HasOverriddenAppearance Then
            currentAppearance = node.GetAppearanceOverride()
        Else
            currentAppearance = node.GetAppearance()
        End If
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

IExportContext Interface


IExportContext.OnPolymesh Method

IExportContextOnPolymesh Method

This method is called when a tessellated polymesh of a 3d face is being output.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void OnPolymesh(
    PolymeshTopology node
)
Sub OnPolymesh (
    node As PolymeshTopology
)
void OnPolymesh(
    PolymeshTopology^ node
)
abstract OnPolymesh :
        node : PolymeshTopology -> unit

Parameters

node PolymeshTopology
A node representing topology of the polymesh
Example
C#
VB
C++
F#
Copy
/// <summary>
/// This method is called up for every face that was processed and tessellated
/// </summary>
/// <remarks>
/// The node provides all information about geometric topology if the mesh.
/// It is assumed that a concrete exporter would consume the part it can
/// understand and/or support (vertices, normals, UVs, etc.) and convert
/// them into the final, export format.
/// </remarks>
public void OnPolymesh(PolymeshTopology node)
{
   // Note: the current material will get applied to the polymesh.

   // If a stack of transformation is maintained by the context object,
   // the current combined transform will be applied to the points.
   Transform currentTransform = m_TransformationStack.Peek();

   // basic properties of the mesh

   int numberOfFacet = node.NumberOfFacets;
   int numberOfPoints = node.NumberOfPoints;
   int numberOfUVs = node.NumberOfUVs;
   int numberOfNormal = node.NumberOfNormals;

   // Note: Normals are associated with either points or facets of the polymesh
   // The export code must account for different processing of these two cases.

   // A) process points of the polymesh

   if( node.DistributionOfNormals == DistributionOfNormals.AtEachPoint )
   {
      ExportMeshPoints(node.GetPoints(), currentTransform, node.GetNormals() );
   }
   else if( node.DistributionOfNormals == DistributionOfNormals.OnePerFace )
   {
      ExportMeshPoints(node.GetPoints(), currentTransform, node.GetNormal(0) );
   }
   else  // DistributionOfNormals.OnEachFacet
   {
      // In this case, there is normal vector associated with each facet
      // Depending on the export, our format either support this case,
      // of we would have to determine what normals to apply at each
      // point by a way of combining normal of the surrounding facets.
      ExportMeshPoints(node.GetPoints(), currentTransform );
   }

   // B Process facets of the polymesh

   if( node.DistributionOfNormals == DistributionOfNormals.OnEachFacet )
   {
      ExportMeshFacets(node.GetFacets(), node.GetNormals() );
   }
   else
   {
      ExportMeshFacets(node.GetFacets(), null );
   }

   // B) Process UV coordinates if available (and applicable)

   if( node.NumberOfUVs > 0 )
   {
      ExportMeshUVs( node.GetUVs() );
   }
}

private void ExportMeshPoints(IList<XYZ> points, Transform trf, IList<XYZ> normals)
{
   // process points with normals
}

private void ExportMeshPoints(IList<XYZ> points, Transform trf, XYZ normal)
{
   // process points with only one normal vector (a planar face)
}

private void ExportMeshPoints(IList<XYZ> points, Transform trf)
{
   // process points without normal (assuming normals are associated with facets instead)
}

private void ExportMeshFacets(IList<PolymeshFacet> facets, IList<XYZ> normals)
{
   if (normals == null)
   {
      // process facets without normals  (assuming normals are associated with points instead)
   }
   else
   {
      // process facets with normals
   }
}

private void ExportMeshUVs(IList<UV> UVs)
{
   // process UVs
}
' <summary>
' This method is called up for every face that was processed and tessellated
' </summary>
' <remarks>
' The node provides all information about geometric topology if the mesh.
' It is assumed that a concrete exporter would consume the part it can
' understand and/or support (vertices, normals, UVs, etc.) and convert
' them into the final, export format.
' </remarks>
Public Sub OnPolymesh(node As PolymeshTopology) Implements IExportContext.OnPolymesh
    ' Note: the current material will get applied to the polymesh.

    ' If a stack of transformation is maintained by the context object,
    ' the current combined transform will be applied to the points.
    Dim currentTransform As Transform = m_TransformationStack.Peek()

    ' basic properties of the mesh

    Dim numberOfFacet As Integer = node.NumberOfFacets
    Dim numberOfPoints As Integer = node.NumberOfPoints
    Dim numberOfUVs As Integer = node.NumberOfUVs
    Dim numberOfNormal As Integer = node.NumberOfNormals

    ' Note: Normals are associated with either points or facets of the polymesh
    ' The export code must account for different processing of these two cases.

    ' A) process points of the polymesh

    If node.DistributionOfNormals = DistributionOfNormals.AtEachPoint Then
        ExportMeshPoints(node.GetPoints(), currentTransform, node.GetNormals())
    ElseIf node.DistributionOfNormals = DistributionOfNormals.OnePerFace Then
        ExportMeshPoints(node.GetPoints(), currentTransform, node.GetNormal(0))
    Else
        ' DistributionOfNormals.OnEachFacet
        ' In this case, there is normal vector associated with each facet
        ' Depending on the export, our format either support this case,
        ' of we would have to determine what normals to apply at each
        ' point by a way of combining normal of the surrounding facets.
        ExportMeshPoints(node.GetPoints(), currentTransform)
    End If

    ' B Process facets of the polymesh

    If node.DistributionOfNormals = DistributionOfNormals.OnEachFacet Then
        ExportMeshFacets(node.GetFacets(), node.GetNormals())
    Else
        ExportMeshFacets(node.GetFacets(), Nothing)
    End If

    ' B) Process UV coordinates if available (and applicable)

    If node.NumberOfUVs > 0 Then
        ExportMeshUVs(node.GetUVs())
    End If
End Sub

Private Sub ExportMeshPoints(points As IList(Of XYZ), trf As Transform, normals As IList(Of XYZ))
    ' process points with normals
End Sub

Private Sub ExportMeshPoints(points As IList(Of XYZ), trf As Transform, normal As XYZ)
    ' process points with only one normal vector (a planar face)
End Sub

Private Sub ExportMeshPoints(points As IList(Of XYZ), trf As Transform)
    ' process points without normal (assuming normals are associated with facets instead)
End Sub

Private Sub ExportMeshFacets(facets As IList(Of PolymeshFacet), normals As IList(Of XYZ))
    ' process facets without normals  (assuming normals are associated with points instead)
    If normals Is Nothing Then
        ' process facets with normals
    Else
    End If
End Sub

Private Sub ExportMeshUVs(UVs As IList(Of UV))
    ' process UVs
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

IExportContext Interface


IExportContext.OnRPC Method

IExportContextOnRPC Method

This method marks the beginning of export of an RPC object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void OnRPC(
    RPCNode node
)
Sub OnRPC (
    node As RPCNode
)
void OnRPC(
    RPCNode^ node
)
abstract OnRPC :
        node : RPCNode -> unit

Parameters

node RPCNode
A node with asset information about the RPC object.
Remarks
This method is only called for photo-rendering export (a custom exporter that implements IPhotoRenderContext). When an RPC object is encountered for a model context export (a custom exporter that implements IModelExportContext), the RPC object will be provided as a polymesh (via OnPolymesh(PolymeshTopology)).
See Also

Reference

IExportContext Interface


IExportContext.OnViewBegin Method

IExportContextOnViewBegin Method

This method marks the beginning of a 3D view to be exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
RenderNodeAction OnViewBegin(
    ViewNode node
)
Function OnViewBegin (
    node As ViewNode
) As RenderNodeAction
RenderNodeAction OnViewBegin(
    ViewNode^ node
)
abstract OnViewBegin :
        node : ViewNode -> RenderNodeAction

Parameters

node ViewNode
Geometry node associated with the view.

Return Value

RenderNodeAction
Return RenderNodeAction.Skip if you wish to skip exporting this view, or return RenderNodeAction.Proceed otherwise.
Example
C#
VB
C++
F#
Copy
/// <summary>
/// This method marks the start of processing a view (a 3D view)
/// </summary>
public RenderNodeAction OnViewBegin(ViewNode node)
{
   // If we did not do so before we invoked the custom export
   // we can get information about the view from the supplied view node,
   // That includes : rendering settings, sun settings, camera data, etc.

   // Get the view information from the node.
   View3D theView = m_document.GetElement(node.ViewId) as View3D;
   string viewName = theView.Name;

   // Get the view's Orientation information.
   ViewOrientation3D theOrientation = theView.GetOrientation();

   // Get the view's camera information, such as whether is a perspective view.
   CameraInfo camera = node.GetCameraInfo();
   bool isPerspective = camera.IsPespective;

   // Get the view's render setting information, such as background style.
   RenderingSettings renderSettings = theView.GetRenderingSettings();
   BackgroundStyle bkStyle = renderSettings.BackgroundStyle;

   // Get the view's sun related information
   SunAndShadowSettings sun = theView.SunAndShadowSettings;

   // We can also determine whether we need to process instance of light objects (OnLight)
   bool needToExportLight =
      (renderSettings.LightingSource != LightingSource.ExteriorSun) &&
      (renderSettings.LightingSource != LightingSource.InteriorSun);

   // We can either skip this view or proceed with rendering it
   return RenderNodeAction.Proceed;
}

/// <summary>
/// This method marks the end of processing a view (a 3D view)
/// </summary>
public void OnViewEnd(ElementId elementId)
{
   // elementId it indicates which view has just been exported

   // Note: This method is invoked even for a view that was skipped.
}
' <summary>
' This method marks the start of processing a view (a 3D view)
' </summary>
Public Function OnViewBegin(node As ViewNode) As RenderNodeAction Implements IExportContext.OnViewBegin
    ' If we did not do so before we invoked the custom export
    ' we can get information about the view from the supplied view node,
    ' That includes : rendering settings, sun settings, camera data, etc.

    ' Get the view information from the node.
    Dim theView As View3D = TryCast(m_document.GetElement(node.ViewId), View3D)
    Dim viewName As String = theView.Name

    ' Get the view's Orientation information.
    Dim theOrientation As ViewOrientation3D = theView.GetOrientation()

    ' Get the view's camera information, such as whether is a perspective view.
    Dim camera As CameraInfo = node.GetCameraInfo()
    Dim isPerspective As Boolean = camera.IsPespective

    ' Get the view's render setting information, such as background style.
    Dim renderSettings As RenderingSettings = theView.GetRenderingSettings()
    Dim bkStyle As BackgroundStyle = renderSettings.BackgroundStyle

    ' Get the view's sun related information
    Dim sun As SunAndShadowSettings = theView.SunAndShadowSettings

    ' We can also determine whether we need to process instance of light objects (OnLight)
    Dim needToExportLight As Boolean = (renderSettings.LightingSource <> LightingSource.ExteriorSun) AndAlso (renderSettings.LightingSource <> LightingSource.InteriorSun)

    ' We can either skip this view or proceed with rendering it
    Return RenderNodeAction.Proceed
End Function

' <summary>
' This method marks the end of processing a view (a 3D view)
' </summary>
Public Sub OnViewEnd(elementId As ElementId) Implements IExportContext.OnViewEnd
    ' elementId it indicates which view has just been exported

    ' Note: This method is invoked even for a view that was skipped.
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

IExportContext Interface


IExportContext.OnViewEnd Method

IExportContextOnViewEnd Method

This method marks the end of a 3D view being exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void OnViewEnd(
    ElementId elementId
)
Sub OnViewEnd (
    elementId As ElementId
)
void OnViewEnd(
    ElementId^ elementId
)
abstract OnViewEnd :
        elementId : ElementId -> unit

Parameters

elementId ElementId
The Id of the 3D view that has just been processed.
See Also

Reference

IExportContext Interface


IExportContext.Start Method

IExportContextStart Method

This method is called at the very start of the export process, still before the first entity of the model was send out.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool Start()
Function Start As Boolean
bool Start()
abstract Start : unit -> bool

Return Value

Boolean
Return True if you are ready to proceed with processing the export.
Example
C#
VB
C++
F#
Copy
// A context would typically maintain a variable for the document being exported
private Document m_document = null;

// Some contexts may find it useful to have a flag indicating
// whether or not the process should be canceled (see Is
private bool m_cancelled = false;

// Typically, an export context has to manage a stack of transformation
// for all nested objects, such as instances, lights, links, etc.
private Stack<Transform> m_TransformationStack = new Stack<Transform>();

/// <summary>
/// Assuming that instance variables gets initiated in the context's constructor
/// </summary>
/// <param name="document"></param>
public MyExportContext(Document document)
{
   m_document = document;
   m_TransformationStack.Push(Transform.Identity);
}

/// <summary>
/// This method is the starting point of the export process.
/// </summary>
/// <remarks>
/// The method is called only once and is typically used to prepare
/// the context object, e.g. crate or open the output files,
/// or establish a connection to an on-line renderer, etc.
/// </remarks>
/// <returns>
/// Return true if the export process it good to start.
/// </returns>
public bool Start()
{
   return true;
}

/// <summary>
/// This method establishes the final point of the export process.
/// </summary>
/// <remarks>
/// Resources (such as files, pipes, threads, etc.) used by the context
/// should be properly released/closed inside this method.
/// </remarks>
public void Finish()
{
}

/// <summary>
/// This method is invoked many times during the export process.
/// </summary>
/// <remarks>
/// Depending on internal condition of the context, it can be decided
/// whether the export is to be immediately canceled or not.
/// </remarks>
public bool IsCanceled()
{
   return m_cancelled;
}
' A context would typically maintain a variable for the document being exported
Private m_document As Document = Nothing

' Some contexts may find it useful to have a flag indicating
' whether or not the process should be canceled (see Is
Private m_cancelled As Boolean = False

' Typically, an export context has to manage a stack of transformation
' for all nested objects, such as instances, lights, links, etc.
Private m_TransformationStack As New Stack(Of Transform)()

' <summary>
' Assuming that instance variables gets initiated in the context's constructor
' </summary>
' <param name="document"></param>
Public Sub New(document As Document)
    m_document = document
    m_TransformationStack.Push(Transform.Identity)
End Sub

' <summary>
' This method is the starting point of the export process.
' </summary>
' <remarks>
' The method is called only once and is typically used to prepare
' the context object, e.g. crate or open the output files,
' or establish a connection to an on-line renderer, etc.
' </remarks>
' <returns>
' Return true if the export process it good to start.
' </returns>
Public Function Start() As Boolean Implements IExportContext.Start
    Return True
End Function

' <summary>
' This method establishes the final point of the export process.
' </summary>
' <remarks>
' Resources (such as files, pipes, threads, etc.) used by the context
' should be properly released/closed inside this method.
' </remarks>
Public Sub Finish() Implements IExportContext.Finish
End Sub

' <summary>
' This method is invoked many times during the export process.
' </summary>
' <remarks>
' Depending on internal condition of the context, it can be decided
' whether the export is to be immediately canceled or not.
' </remarks>
Public Function IsCanceled() As Boolean Implements IExportContext.IsCanceled
    Return m_cancelled
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

IExportContext Interface


IExportContext2D Interface

An interface that is used in custom export to export 2D views of a Revit model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IExportContext2D : IExportContextBase
Public Interface IExportContext2D
    Inherits IExportContextBase
public interface class IExportContext2D : IExportContextBase
type IExportContext2D =
    interface
        interface IExportContextBase
    end

The IExportContext2D type exposes the following members.

Methods
Name | Description
Public method OnCurve This method is called when a Curve is being output.
(Inherited from IExportContextBase)
Public method | OnElementBegin2D | This method marks the beginning of an element to be exported.
Public method | OnElementEnd2D | This method marks the end of an element being exported.
Public method | OnFaceEdge2D | This method is called when a Face edge is being output.
Public method | OnFaceSilhouette2D | This method is called when a Face silhouette is being output.
Public method OnLineSegment This method is called after unhandled curve was tessellated to line segments and sent to the output.

Note for 2D export: if the export is performed for the view in non-Wireframe display style, then

  • this method is called outside of view, instance and link begin/end calls but still between OnElementBegin2D/OnElementEnd2D calls
  • this method is never called for annotation elements, i.e. their geometry should be processed in methods OnCurve and OnPolyline

(Inherited from IExportContextBase)
Public method OnPolyline This method is called when a Polyline is being output.
(Inherited from IExportContextBase)
Public method OnPolylineSegments This method is called after unhandled curve was tessellated to polyline segments and sent to the output.

Note for 2D export: if the export is performed for the view in non-Wireframe display style, then

  • this method is called outside of view, instance and link begin/end calls but still between OnElementBegin2D/OnElementEnd2D calls
  • this method is never called for annotation elements, i.e. their geometry should be processed in methods OnCurve and OnPolyline

(Inherited from IExportContextBase)
Public method OnText This method is called when a text annotation object is being output.
(Inherited from IExportContextBase)
Top
Remarks

An instance of a class that implements this interface is passed in as a parameter of the CustomExporter constructor. The interface methods are then called at times of drawing entities that are currently visible in the view being exported.

With this type of export context used to perform a custom export, Revit will traverse the model and output the model's geometry as if in the process of regular displaying or exporting a 2D View. It means that any geometry which is visible in an open view (taking any current visibility setting applicable to the view) will be processed and output. Optionally, annotation objects are also output.

Note 1. Curves passed to calls OnFaceEdge2D(FaceEdgeNode) and OnFaceSilhouette2D(FaceSilhouetteNode) may be partially duplicating each other.

Note 2. If element E is a FamilyInstance and it contains an imported instance then:

  • between the calls to OnElementBegin2D/OnElementEnd2D for element E there will be calls to OnInstanceBegin/OnInstanceEnd with the "node" argument pointing to the element with its symbol being of category BuiltInCategories.OST_ImportObjectStyles
  • all geometry exported for the element E has to be additionally subject to the transform T=E.GetTotalTransform()

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


IExportContext2D Methods

The IExportContext2D type exposes the following members.

Methods
Name | Description
Public method OnCurve This method is called when a Curve is being output.
(Inherited from IExportContextBase)
Public method | OnElementBegin2D | This method marks the beginning of an element to be exported.
Public method | OnElementEnd2D | This method marks the end of an element being exported.
Public method | OnFaceEdge2D | This method is called when a Face edge is being output.
Public method | OnFaceSilhouette2D | This method is called when a Face silhouette is being output.
Public method OnLineSegment This method is called after unhandled curve was tessellated to line segments and sent to the output.

Note for 2D export: if the export is performed for the view in non-Wireframe display style, then

  • this method is called outside of view, instance and link begin/end calls but still between OnElementBegin2D/OnElementEnd2D calls
  • this method is never called for annotation elements, i.e. their geometry should be processed in methods OnCurve and OnPolyline

(Inherited from IExportContextBase)
Public method OnPolyline This method is called when a Polyline is being output.
(Inherited from IExportContextBase)
Public method OnPolylineSegments This method is called after unhandled curve was tessellated to polyline segments and sent to the output.

Note for 2D export: if the export is performed for the view in non-Wireframe display style, then

  • this method is called outside of view, instance and link begin/end calls but still between OnElementBegin2D/OnElementEnd2D calls
  • this method is never called for annotation elements, i.e. their geometry should be processed in methods OnCurve and OnPolyline

(Inherited from IExportContextBase)
Public method OnText This method is called when a text annotation object is being output.
(Inherited from IExportContextBase)
Top
See Also

Reference

IExportContext2D Interface


IExportContext2D.OnElementBegin2D Method

IExportContext2DOnElementBegin2D Method

This method marks the beginning of an element to be exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
RenderNodeAction OnElementBegin2D(
    ElementNode node
)
Function OnElementBegin2D (
    node As ElementNode
) As RenderNodeAction
RenderNodeAction OnElementBegin2D(
    ElementNode^ node
)
abstract OnElementBegin2D :
        node : ElementNode -> RenderNodeAction

Parameters

node ElementNode
Node representing the element that is about to start being exported. Contains element ID and document.

Return Value

RenderNodeAction
Return RenderNodeAction.Skip if you wish to skip exporting this element, or return RenderNodeAction.Proceed otherwise.
Remarks
For views having non-Wireframe display style, geometry of elements is output outside of view, instance and link begin/end brackets. Therefore the argument to this method is ElementNode that has both element ID and the host document.
See Also

Reference

IExportContext2D Interface


IExportContext2D.OnElementEnd2D Method

IExportContext2DOnElementEnd2D Method

This method marks the end of an element being exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void OnElementEnd2D(
    ElementNode node
)
Sub OnElementEnd2D (
    node As ElementNode
)
void OnElementEnd2D(
    ElementNode^ node
)
abstract OnElementEnd2D :
        node : ElementNode -> unit

Parameters

node ElementNode
An output node that represents an element.
Remarks
For views having non-Wireframe display style, geometry of elements is output outside of view, instance and link begin/end brackets. Therefore the argument to this method is ElementNode that has both element ID and the host document.
See Also

Reference

IExportContext2D Interface


IExportContext2D.OnFaceEdge2D Method

IExportContext2DOnFaceEdge2D Method

This method is called when a Face edge is being output.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
RenderNodeAction OnFaceEdge2D(
    FaceEdgeNode node
)
Function OnFaceEdge2D (
    node As FaceEdgeNode
) As RenderNodeAction
RenderNodeAction OnFaceEdge2D(
    FaceEdgeNode^ node
)
abstract OnFaceEdge2D :
        node : FaceEdgeNode -> RenderNodeAction

Parameters

node FaceEdgeNode
An output node that represents a Face edge.

Return Value

RenderNodeAction
Return RenderNodeAction.Proceed if you wish to receive tessellated geometry (line or polyline segments) for this face edge, or otherwise return RenderNodeAction.Skip.

Note: if the export is performed for the view in non-Wireframe display style tesselated geometry will be output regardless of the return value.

Remarks

Note that this method is invoked only if the custom exporter was set up to include geometric objects in the output stream. See IncludeGeometricObjects for mode details.

Note: if the export is performed for the view in non-Wireframe display style this method will be called regardless of whether the object will be eventially output, i.e. even if it's occluded by another element.

See Also

Reference

IExportContext2D Interface


IExportContext2D.OnFaceSilhouette2D Method

IExportContext2DOnFaceSilhouette2D Method

This method is called when a Face silhouette is being output.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
RenderNodeAction OnFaceSilhouette2D(
    FaceSilhouetteNode node
)
Function OnFaceSilhouette2D (
    node As FaceSilhouetteNode
) As RenderNodeAction
RenderNodeAction OnFaceSilhouette2D(
    FaceSilhouetteNode^ node
)
abstract OnFaceSilhouette2D :
        node : FaceSilhouetteNode -> RenderNodeAction

Parameters

node FaceSilhouetteNode
An output node that represents a Face silhouette.

Return Value

RenderNodeAction
Return RenderNodeAction.Proceed if you wish to receive tessellated geometry (line or polyline segments) for this face silhouette, or otherwise return RenderNodeAction.Skip.

Note: if the export is performed for the view in non-Wireframe display style tesselated geometry will be output regardless of the return value.

Remarks

Note that this method is invoked only if the custom exporter was set up to include geometric objects in the output stream. See IncludeGeometricObjects for mode details.

Note: if the export is performed for the view in non-Wireframe display style this method will be called regardless of whether the object will be eventially output, i.e. even if it's occluded by another element.

See Also

Reference

IExportContext2D Interface


IExportContextBase Interface

An interface that as common base for IModelExportContext and IExportContext2D.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IExportContextBase : IExportContext
Public Interface IExportContextBase
    Inherits IExportContext
public interface class IExportContextBase : IExportContext
type IExportContextBase =
    interface
        interface IExportContext
    end

The IExportContextBase type exposes the following members.

Methods
Name | Description
Public method Finish This method is called at the very end of the export process, after all entities were processed (or after the process was cancelled).
(Inherited from IExportContext)
Public method IsCanceled This method is queried at the beginning of every element.
(Inherited from IExportContext)
Public method | OnCurve | This method is called when a Curve is being output.
OnElementBegin This method marks the beginning of an element to be exported.
(Inherited from IExportContext)
Public method OnElementEnd This method marks the end of an element being exported.
(Inherited from IExportContext)
OnFaceBegin This method marks the beginning of a Face to be exported.
(Inherited from IExportContext)
Public method OnFaceEnd This method marks the end of the current face being exported.
(Inherited from IExportContext)
OnInstanceBegin This method marks the start of processing of an instance node (e.g. a family instance).
(Inherited from IExportContext)
Public method OnInstanceEnd This method marks the end of processing of an Instance Node (e.g. a family instance).
(Inherited from IExportContext)
OnLight This method marks the beginning of export of a light which is enabled for rendering.
(Inherited from IExportContext)
Public method OnLineSegment This method is called after unhandled curve was tessellated to line segments and sent to the output.

Note for 2D export: if the export is performed for the view in non-Wireframe display style, then

  • this method is called outside of view, instance and link begin/end calls but still between OnElementBegin2D/OnElementEnd2D calls
  • this method is never called for annotation elements, i.e. their geometry should be processed in methods OnCurve and OnPolyline

OnLinkBegin This method marks the beginning of a link instance to be exported.
(Inherited from IExportContext)
Public method OnLinkEnd This method marks the end of a link instance being exported.
(Inherited from IExportContext)
OnMaterial This method marks a change of the material.
(Inherited from IExportContext)
Public method | OnPolyline | This method is called when a Polyline is being output.
Public method OnPolylineSegments This method is called after unhandled curve was tessellated to polyline segments and sent to the output.

Note for 2D export: if the export is performed for the view in non-Wireframe display style, then

  • this method is called outside of view, instance and link begin/end calls but still between OnElementBegin2D/OnElementEnd2D calls
  • this method is never called for annotation elements, i.e. their geometry should be processed in methods OnCurve and OnPolyline

OnPolymesh This method is called when a tessellated polymesh of a 3d face is being output.
(Inherited from IExportContext)
Public method OnRPC This method marks the beginning of export of an RPC object.
(Inherited from IExportContext)
Public method | OnText | This method is called when a text annotation object is being output.
OnViewBegin This method marks the beginning of a 3D view to be exported.
(Inherited from IExportContext)
Public method OnViewEnd This method marks the end of a 3D view being exported.
(Inherited from IExportContext)
Start This method is called at the very start of the export process, still before the first entity of the model was send out.
(Inherited from IExportContext)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


IExportContextBase Methods

The IExportContextBase type exposes the following members.

Methods
Name | Description
Public method Finish This method is called at the very end of the export process, after all entities were processed (or after the process was cancelled).
(Inherited from IExportContext)
Public method IsCanceled This method is queried at the beginning of every element.
(Inherited from IExportContext)
Public method | OnCurve | This method is called when a Curve is being output.
OnElementBegin This method marks the beginning of an element to be exported.
(Inherited from IExportContext)
Public method OnElementEnd This method marks the end of an element being exported.
(Inherited from IExportContext)
OnFaceBegin This method marks the beginning of a Face to be exported.
(Inherited from IExportContext)
Public method OnFaceEnd This method marks the end of the current face being exported.
(Inherited from IExportContext)
OnInstanceBegin This method marks the start of processing of an instance node (e.g. a family instance).
(Inherited from IExportContext)
Public method OnInstanceEnd This method marks the end of processing of an Instance Node (e.g. a family instance).
(Inherited from IExportContext)
OnLight This method marks the beginning of export of a light which is enabled for rendering.
(Inherited from IExportContext)
Public method OnLineSegment This method is called after unhandled curve was tessellated to line segments and sent to the output.

Note for 2D export: if the export is performed for the view in non-Wireframe display style, then

  • this method is called outside of view, instance and link begin/end calls but still between OnElementBegin2D/OnElementEnd2D calls
  • this method is never called for annotation elements, i.e. their geometry should be processed in methods OnCurve and OnPolyline

OnLinkBegin This method marks the beginning of a link instance to be exported.
(Inherited from IExportContext)
Public method OnLinkEnd This method marks the end of a link instance being exported.
(Inherited from IExportContext)
OnMaterial This method marks a change of the material.
(Inherited from IExportContext)
Public method | OnPolyline | This method is called when a Polyline is being output.
Public method OnPolylineSegments This method is called after unhandled curve was tessellated to polyline segments and sent to the output.

Note for 2D export: if the export is performed for the view in non-Wireframe display style, then

  • this method is called outside of view, instance and link begin/end calls but still between OnElementBegin2D/OnElementEnd2D calls
  • this method is never called for annotation elements, i.e. their geometry should be processed in methods OnCurve and OnPolyline

OnPolymesh This method is called when a tessellated polymesh of a 3d face is being output.
(Inherited from IExportContext)
Public method OnRPC This method marks the beginning of export of an RPC object.
(Inherited from IExportContext)
Public method | OnText | This method is called when a text annotation object is being output.
OnViewBegin This method marks the beginning of a 3D view to be exported.
(Inherited from IExportContext)
Public method OnViewEnd This method marks the end of a 3D view being exported.
(Inherited from IExportContext)
Start This method is called at the very start of the export process, still before the first entity of the model was send out.
(Inherited from IExportContext)
Top
See Also

Reference

IExportContextBase Interface


IExportContextBase.OnCurve Method

IExportContextBaseOnCurve Method

This method is called when a Curve is being output.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
RenderNodeAction OnCurve(
    CurveNode node
)
Function OnCurve (
    node As CurveNode
) As RenderNodeAction
RenderNodeAction OnCurve(
    CurveNode^ node
)
abstract OnCurve :
        node : CurveNode -> RenderNodeAction

Parameters

node CurveNode
An output node that represents a Curve.

Return Value

RenderNodeAction
Return RenderNodeAction.Proceed if you wish to receive tessellated geometry (line or polyline segments) for this curve, or otherwise return RenderNodeAction.Skip.

Note for 2D export: if the export is performed for the view in non-Wireframe display style tesselated geometry will be output regardless of the return value.

Remarks

Note that this method is invoked only if the custom exporter was set up to include geometric objects in the output stream. See IncludeGeometricObjects for mode details.

The curve can be one of the geometric object that derive from the Curve class, e.g. Line, Arc, NurbeSpline, etc. To get to the specific properties of the particular class, the curve obtained from the input node first needs to be cast accordingly depending on the curve's actual type.

Note for 2D export: if the export is performed for the view in non-Wireframe display style this method will be called regardless of whether the object will be eventially output, i.e. even if it's occluded by another element.

See Also

Reference

IExportContextBase Interface


IExportContextBase.OnLineSegment Method

IExportContextBaseOnLineSegment Method

This method is called after unhandled curve was tessellated to line segments and sent to the output.

Note for 2D export: if the export is performed for the view in non-Wireframe display style, then

  • this method is called outside of view, instance and link begin/end calls but still between OnElementBegin2D/OnElementEnd2D calls
  • this method is never called for annotation elements, i.e. their geometry should be processed in methods OnCurve and OnPolyline

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void OnLineSegment(
    LineSegment segment
)
Sub OnLineSegment (
    segment As LineSegment
)
void OnLineSegment(
    LineSegment^ segment
)
abstract OnLineSegment :
        segment : LineSegment -> unit

Parameters

segment LineSegment
A structure describing the line segment.
See Also

Reference

IExportContextBase Interface


IExportContextBase.OnPolyline Method

IExportContextBaseOnPolyline Method

This method is called when a Polyline is being output.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
RenderNodeAction OnPolyline(
    PolylineNode node
)
Function OnPolyline (
    node As PolylineNode
) As RenderNodeAction
RenderNodeAction OnPolyline(
    PolylineNode^ node
)
abstract OnPolyline :
        node : PolylineNode -> RenderNodeAction

Parameters

node PolylineNode
An output node that represents a Polyline.

Return Value

RenderNodeAction
Return RenderNodeAction.Proceed if you wish to receive tessellated geometry (polyline segments) for this polyline, or otherwise return RenderNodeAction.Skip.

Note for 2D export: if the export is performed for the view in non-Wireframe display style tesselated geometry will be output regardless of the return value.

Remarks
Note that this method is invoked only if the custom exporter was set up to include geometric objects in the output stream. See IncludeGeometricObjects for mode details.

Note for 2D export: if the export is performed for the view in non-Wireframe display style this method will be called regardless of whether the object will be eventially output, i.e. even if it's occluded by another element.

See Also

Reference

IExportContextBase Interface


IExportContextBase.OnPolylineSegments Method

IExportContextBaseOnPolylineSegments Method

This method is called after unhandled curve was tessellated to polyline segments and sent to the output.

Note for 2D export: if the export is performed for the view in non-Wireframe display style, then

  • this method is called outside of view, instance and link begin/end calls but still between OnElementBegin2D/OnElementEnd2D calls
  • this method is never called for annotation elements, i.e. their geometry should be processed in methods OnCurve and OnPolyline

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void OnPolylineSegments(
    PolylineSegments segments
)
Sub OnPolylineSegments (
    segments As PolylineSegments
)
void OnPolylineSegments(
    PolylineSegments^ segments
)
abstract OnPolylineSegments :
        segments : PolylineSegments -> unit

Parameters

segments PolylineSegments
A structure describing the polyline segments.
See Also

Reference

IExportContextBase Interface


IExportContextBase.OnText Method

IExportContextBaseOnText Method

This method is called when a text annotation object is being output.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void OnText(
    TextNode node
)
Sub OnText (
    node As TextNode
)
void OnText(
    TextNode^ node
)
abstract OnText :
        node : TextNode -> unit

Parameters

node TextNode
An output node that represents a text annotation.
See Also

Reference

IExportContextBase Interface


IExtension Interface

An interface that supports the additional operation for Extension Status

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IExtension
Public Interface IExtension
public interface class IExtension
type IExtension = interface end

The IExtension type exposes the following members.

Properties
 | Name | Description
Public property | Extended | Retrieves or set the extension status at the end
Public property | HasMiter | Retrieves the miter status at the end
Public property | IsMiterLocked | Retrieves or set the miter locked status at the end.
Public property | SymbolicExtended | Retrieves or set the symbolic extension status at the end
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


IExtension Properties

The IExtension type exposes the following members.

Properties
 | Name | Description
Public property | Extended | Retrieves or set the extension status at the end
Public property | HasMiter | Retrieves the miter status at the end
Public property | IsMiterLocked | Retrieves or set the miter locked status at the end.
Public property | SymbolicExtended | Retrieves or set the symbolic extension status at the end
Top
See Also

Reference

IExtension Interface


IExtension.Extended Property

IExtensionExtended Property

Retrieves or set the extension status at the end

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool this[
    int index
] { get; set; }
Property Extended (
    index As Integer
) As Boolean
    Get
    Set
property bool Extended[int index] {
    bool get (int index);
    void set (int index, bool value);
}
abstract Extended : bool with get, set

Parameters

index Int32

Property Value

Boolean
Remarks
Property index must be 0 or 1 to indicate two ends, otherwise exceptions will be thrown. For beams, if the beam extension status is changed, other status such as the symbolic extension status, miter status, miter locked status, and other beams extension status will be changed automatically at the same time. This change can protect that a join can have up to two extended beams, if there are two extended beams at the join, they shall be mitered.
See Also

Reference

IExtension Interface


IExtension.HasMiter Property

IExtensionHasMiter Property

Retrieves the miter status at the end

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool this[
    int index
] { get; }
ReadOnly Property HasMiter (
    index As Integer
) As Boolean
    Get
property bool HasMiter[int index] {
    bool get (int index);
}
abstract HasMiter : bool with get

Parameters

index Int32

Property Value

Boolean
Remarks
Property index must be 0 or 1 to indicate two ends, otherwise exceptions will be thrown. For beams, this can check whether the beam is mitered with other beams at the end
See Also

Reference

IExtension Interface


IExtension.IsMiterLocked Property

IExtensionIsMiterLocked Property

Retrieves or set the miter locked status at the end.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool this[
    int index
] { get; set; }
Property IsMiterLocked (
    index As Integer
) As Boolean
    Get
    Set
property bool IsMiterLocked[int index] {
    bool get (int index);
    void set (int index, bool value);
}
abstract IsMiterLocked : bool with get, set

Parameters

index Int32

Property Value

Boolean
Remarks
Property index must be 0 or 1 to indicate two ends, otherwise exceptions will be thrown. For beams, only if the beam is extended and is mitered with other beams at the end, it can be locked. Otherwise, the setting is invalid
See Also

Reference

IExtension Interface


IExtension.SymbolicExtended Property

IExtensionSymbolicExtended Property

Retrieves or set the symbolic extension status at the end

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool this[
    int index
] { get; set; }
Property SymbolicExtended (
    index As Integer
) As Boolean
    Get
    Set
property bool SymbolicExtended[int index] {
    bool get (int index);
    void set (int index, bool value);
}
abstract SymbolicExtended : bool with get, set

Parameters

index Int32

Property Value

Boolean
Remarks
Property index must be 0 or 1 to indicate two ends, otherwise exceptions will be thrown. For beams, symbolic extension setting only works when the beam is extended, mitered, and miter locked at the end. Otherwise the setting is invalid
See Also

Reference

IExtension Interface


IExternalDBApplication Interface

An interface that supports addition of DB-level external applications to Revit, to subscribe to DB-level events and updaters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IExternalDBApplication
Public Interface IExternalDBApplication
public interface class IExternalDBApplication
type IExternalDBApplication = interface end

The IExternalDBApplication type exposes the following members.

Methods
 | Name | Description
Public method | OnShutdown | Implement this method to execute some tasks when Autodesk Revit shuts down.
Public method | OnStartup | Implement this method to execute some tasks when Autodesk Revit starts.
Top
Remarks
DB-level applications are permitted to add DB-level events and updaters to the session. They cannot create or modify UI.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


IExternalDBApplication Methods

The IExternalDBApplication type exposes the following members.

Methods
 | Name | Description
Public method | OnShutdown | Implement this method to execute some tasks when Autodesk Revit shuts down.
Public method | OnStartup | Implement this method to execute some tasks when Autodesk Revit starts.
Top
See Also

Reference

IExternalDBApplication Interface


IExternalDBApplication.OnShutdown Method

IExternalDBApplicationOnShutdown Method

Implement this method to execute some tasks when Autodesk Revit shuts down.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
ExternalDBApplicationResult OnShutdown(
    ControlledApplication application
)
Function OnShutdown (
    application As ControlledApplication
) As ExternalDBApplicationResult
ExternalDBApplicationResult OnShutdown(
    ControlledApplication^ application
)
abstract OnShutdown :
        application : ControlledApplication -> ExternalDBApplicationResult

Parameters

application ControlledApplication
Handle to the Revit Application object.

Return Value

ExternalDBApplicationResult
Indicates if the external db application completes its work successfully.
See Also

Reference

IExternalDBApplication Interface


IExternalDBApplication.OnStartup Method

IExternalDBApplicationOnStartup Method

Implement this method to execute some tasks when Autodesk Revit starts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
ExternalDBApplicationResult OnStartup(
    ControlledApplication application
)
Function OnStartup (
    application As ControlledApplication
) As ExternalDBApplicationResult
ExternalDBApplicationResult OnStartup(
    ControlledApplication^ application
)
abstract OnStartup :
        application : ControlledApplication -> ExternalDBApplicationResult

Parameters

application ControlledApplication
Handle to the Revit Application object.

Return Value

ExternalDBApplicationResult
Indicates if the external db application completes its work successfully.
Remarks
Typically, event handlers and updaters are registered in this method.
See Also

Reference

IExternalDBApplication Interface


IExternalResourceServer Interface

The interface used to provide custom implementation to provide access to external resources (such as linked files) from arbitrary locations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IExternalResourceServer : IExternalServer
Public Interface IExternalResourceServer
    Inherits IExternalServer
public interface class IExternalResourceServer : IExternalServer
type IExternalResourceServer =
    interface
        interface IExternalServer
    end

The IExternalResourceServer type exposes the following members.

Methods
 | Name | Description
Public method | AreSameResources | Implement this method to indicate whether two given resources are the same.
Public method | GetDescription | Implement this method to return a description of the server. (Inherited from IExternalServer)
Public method | GetIconPath | Implement this method to return the path to an icon file which will be displayed in Revit user interfaces associated to this server.
Public method | GetInformationLink | The method that Revit will invoke to obtain a URL address which provides more information about the server.
Public method | GetInSessionPath | Implement this method to provide the path that should be used for display and browsing to a given ExternalResourceReference during this Revit session.
Public method | GetName | Implement this method to return the name of the server. (Inherited from IExternalServer)
Public method | GetResourceVersionStatus | Implement this method to indicate whether the given version of a resource is the most current version of the data.
Public method | GetServerId | Implement this method to return the id of the server. (Inherited from IExternalServer)
Public method | GetServiceId | Implement this method to return the id of the service. (Inherited from IExternalServer)
Public method | GetShortName | Implement this method to return the short name of the server.
Public method | GetTypeSpecificServerOperations | Implement this method to get operations supported by the external server for a particular type of external resource.
Public method | GetVendorId | Implement this method to return the id of the vendor of the server. (Inherited from IExternalServer)
Public method | IsResourceWellFormed | Implement this method to check whether the given ExternalResourceReference is formatted correctly for this server.
Public method | LoadResource | Implement this method to load the requested resource.
Public method | SetupBrowserData | Implement this method to setup external resource browser data which will be accessed in Revit external resource browser UI.
Public method | SupportsExternalResourceType | Implement this method to indicate whether the server can provide data for a specified type of external resource.
Top
Remarks

Certain resources used in a Revit model are stored outside of the .rvt file. For example, the data used for keynotes, images used as decals during rendering, CAD links, and Revit links are all stored outside the model. Creating a new implementation of this server allows the server to supply one or more types of such resources from an arbitrary source. For example, a server could provide the keynote data from a database or from a file format that Revit does not support.

If a model references resources supplied by this server, Revit will request the resource from the server when it is required. Most external resources are loaded into memory at the time the model is loaded. The server will also be invoked if the resource is explicitly reloaded.

IExternalResourceServer can declare that a resource is already up-to-date via GetResourceVersionStatus(ExternalResourceReference) If the resource is up-to-date, Revit will skip loading to improve performance.

Each resource load request will be associated with a GUID, so that server implementers can uniquely identify a given load request. This may be useful to, for example, store server-side errors associated with an attempt to load a particular resource.

If your server handles Revit or CAD links, you must take special care with link paths. When one of these file types is uploaded to your server, any nested references should be brought to the server along with the main link. Your server will need to repath any nested reference itself; Revit will not handle this automatically.

In the case of DWG links, your server will also need to download and possibly repath any xrefs when LoadResource is called for the top-level link. Revit will only request the top-level link directly.

In the case of Revit links, the ExternalResourceReferences for any nested links will also need to be modified in the host document. The host document should reference the Revit links at their server locations, not their local file locations. Revit may not be able to find links if the paths are not set up correctly. See [!:Autodesk::Revit::DB::TransmissionData::ReadTransmissionData] to inspect the set of links contained within a Revit model. See [!:Autodesk::Revit::DB::RevitLinkType::LoadFrom] to reload a Revit link from a server version.

Here is an example which uses nested Revit links: A user has a Revit model containing one link, Link.rvt, which contains one nested link, Nest.rvt. The user uploads Link.rvt to a server, using an add-in provided by that server. The server provider must also take Nest.rvt. Further, the server provider must open Link.rvt and modify the reference to Nest.rvt so that it references the version on the server. Otherwise, Revit will not be able to find Nest.rvt when another user tries to load Link.rvt from the server.

The external resource framework has been designed to allow server authors to display UI related to the resource load operation and UI browse operation. No UI should be displayed directly from an IExternalResourceServer. Instead, developers should create an IExternalResourceUIServer which will handle UI tasks on behalf of the IExternalResourceServer. For more information, see the documentation for the LoadResource(Guid, ExternalResourceType, ExternalResourceReference, ExternalResourceLoadContext, ExternalResourceLoadContent) and SetupBrowserData(ExternalResourceBrowserData) methods.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


IExternalResourceServer Methods

The IExternalResourceServer type exposes the following members.

Methods
 | Name | Description
Public method | AreSameResources | Implement this method to indicate whether two given resources are the same.
Public method | GetDescription | Implement this method to return a description of the server. (Inherited from IExternalServer)
Public method | GetIconPath | Implement this method to return the path to an icon file which will be displayed in Revit user interfaces associated to this server.
Public method | GetInformationLink | The method that Revit will invoke to obtain a URL address which provides more information about the server.
Public method | GetInSessionPath | Implement this method to provide the path that should be used for display and browsing to a given ExternalResourceReference during this Revit session.
Public method | GetName | Implement this method to return the name of the server. (Inherited from IExternalServer)
Public method | GetResourceVersionStatus | Implement this method to indicate whether the given version of a resource is the most current version of the data.
Public method | GetServerId | Implement this method to return the id of the server. (Inherited from IExternalServer)
Public method | GetServiceId | Implement this method to return the id of the service. (Inherited from IExternalServer)
Public method | GetShortName | Implement this method to return the short name of the server.
Public method | GetTypeSpecificServerOperations | Implement this method to get operations supported by the external server for a particular type of external resource.
Public method | GetVendorId | Implement this method to return the id of the vendor of the server. (Inherited from IExternalServer)
Public method | IsResourceWellFormed | Implement this method to check whether the given ExternalResourceReference is formatted correctly for this server.
Public method | LoadResource | Implement this method to load the requested resource.
Public method | SetupBrowserData | Implement this method to setup external resource browser data which will be accessed in Revit external resource browser UI.
Public method | SupportsExternalResourceType | Implement this method to indicate whether the server can provide data for a specified type of external resource.
Top
See Also

Reference

IExternalResourceServer Interface


IExternalResourceServer.AreSameResources Method

IExternalResourceServerAreSameResources Method

Implement this method to indicate whether two given resources are the same.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool AreSameResources(
    IDictionary<string, string> reference1,
    IDictionary<string, string> reference2
)
Function AreSameResources (
    reference1 As IDictionary(Of String, String),
    reference2 As IDictionary(Of String, String)
) As Boolean
bool AreSameResources(
    IDictionary<String^, String^>^ reference1,
    IDictionary<String^, String^>^ reference2
)
abstract AreSameResources :
        reference1 : IDictionary<string, string> *
        reference2 : IDictionary<string, string> -> bool

Parameters

reference1 IDictionary String, String
reference2 IDictionary String, String

Return Value

Boolean
True if two given resources are the same; otherwise false.
See Also

Reference

IExternalResourceServer Interface


IExternalResourceServer.GetIconPath Method

IExternalResourceServerGetIconPath Method

Implement this method to return the path to an icon file which will be displayed in Revit user interfaces associated to this server.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetIconPath()
Function GetIconPath As String
String^ GetIconPath()
abstract GetIconPath : unit -> string

Return Value

String
The image file of the server.
Remarks

The specified image will be displayed in the browser dialogs when the user is selecting a resource of a compatible type.

The return must be the full path to an icon file containing 48x48, 32x32 and 16x16 pixel images.

If this method returns anything other than a valid icon file, a default image will be used for the server.

See Also

Reference

IExternalResourceServer Interface


IExternalResourceServer.GetInformationLink Method

IExternalResourceServerGetInformationLink Method

The method that Revit will invoke to obtain a URL address which provides more information about the server.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetInformationLink()
Function GetInformationLink As String
String^ GetInformationLink()
abstract GetInformationLink : unit -> string

Return Value

String
The URL providing server information.
See Also

Reference

IExternalResourceServer Interface


IExternalResourceServer.GetInSessionPath Method

IExternalResourceServerGetInSessionPath Method

Implement this method to provide the path that should be used for display and browsing to a given ExternalResourceReference during this Revit session.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetInSessionPath(
    ExternalResourceReference reference,
    string originalDisplayPath
)
Function GetInSessionPath (
    reference As ExternalResourceReference,
    originalDisplayPath As String
) As String
String^ GetInSessionPath(
    ExternalResourceReference^ reference,
    String^ originalDisplayPath
)
abstract GetInSessionPath :
        reference : ExternalResourceReference *
        originalDisplayPath : string -> string

Parameters

reference ExternalResourceReference
The ExternalResourceReference for which Revit is requesting the in session display path.
originalDisplayPath String
The path that was provided for the resource when the resource was originally loaded into the model.

Return Value

String
The display path that should be used for this resource for this session of Revit.
Remarks
This method allows an IExternalResourceServer to override the path that is used within this Revit session to display and browse to a specific ExternalResourceReference. This method is provided to accommodate IExternalResourceServers that may present different paths under different circumstances. For example, an IExternalResourceServer might implement this method to return a display path that uses the appropriate language for the user's current locale. An IExternalResourceServer could also use this method to present the appropriate name if the user has renamed this resource since the last time it was loaded. If the IExternalResourceServer does not need to customize the display path, it can return the originalDisplayPath parameter.

Revit will invoke this method when the model is first loaded or before calling LoadResource(Guid, ExternalResourceType, ExternalResourceReference, ExternalResourceLoadContext, ExternalResourceLoadContent) and cache the result in the ExternalResourceReference.

Do not rely on this path to look up an ExternalResourceReference, as the path is neither unique nor stable. It isn't unique because multiple servers might use the same server name and display name format. It isn't stable because some servers allow renaming, and because a server might change its name at some point.

See Also

Reference

IExternalResourceServer Interface


IExternalResourceServer.GetResourceVersionStatus Method

IExternalResourceServerGetResourceVersionStatus Method

Implement this method to indicate whether the given version of a resource is the most current version of the data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
ResourceVersionStatus GetResourceVersionStatus(
    ExternalResourceReference reference
)
Function GetResourceVersionStatus (
    reference As ExternalResourceReference
) As ResourceVersionStatus
ResourceVersionStatus GetResourceVersionStatus(
    ExternalResourceReference^ reference
)
abstract GetResourceVersionStatus :
        reference : ExternalResourceReference -> ResourceVersionStatus

Parameters

reference ExternalResourceReference
The ExternalResourceReference to check.

Return Value

ResourceVersionStatus
An enum indicating whether the resource is current, out of date, or of unknown status.
Remarks

If Revit already has a version of this resource loaded, Revit will invoke this method to check whether the resource's data will change if LoadResource(Guid, ExternalResourceType, ExternalResourceReference, ExternalResourceLoadContext, ExternalResourceLoadContent) is called. If this method returns ResourceVersionStatus.Current, then Revit will improve model performance by not calling LoadResource(Guid, ExternalResourceType, ExternalResourceReference, ExternalResourceLoadContext, ExternalResourceLoadContent).

Note that this method may also be invoked to determine the behavior of certain elements within the user interface. For example, it may be used to warn the user if they are about to execute certain expensive operations (such as printing) with an outdated version of this resource.

Servers which encounter errors should return ResourceVersionStatus.Unknown. Revit will reload resources whose version status is unknown, but will not display out-of-date warnings to the user on printing.

See Also

Reference

IExternalResourceServer Interface


IExternalResourceServer.GetShortName Method

IExternalResourceServerGetShortName Method

Implement this method to return the short name of the server.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetShortName()
Function GetShortName As String
String^ GetShortName()
abstract GetShortName : unit -> string

Return Value

String
The short name of the server.
Remarks
The name is a unique path prefix included in full paths to external resources provided by this server. It is recommended that the short name length is at least 3 characters to make it useful for users to identify the server easily.

To ensure the server can be registered successfully, the name should match restrictions below:

  • The name cannot be empty or consist of only whitespace characters.
  • The name should not include any invalid characters such as \/:*?"<>|.
  • The name cannot duplicate any other external resource server names.
  • The name should not duplicate a Revit reserved path prefix(case insensitive), including: RSN, A360, buzzsaw, vault, redspark, ftp, http, https, files, file.
See Also

Reference

IExternalResourceServer Interface


IExternalResourceServer.GetTypeSpecificServerOperations Method

IExternalResourceServerGetTypeSpecificServerOperations Method

Implement this method to get operations supported by the external server for a particular type of external resource.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void GetTypeSpecificServerOperations(
    ExternalResourceServerExtensions extensions
)
Sub GetTypeSpecificServerOperations (
    extensions As ExternalResourceServerExtensions
)
void GetTypeSpecificServerOperations(
    ExternalResourceServerExtensions^ extensions
)
abstract GetTypeSpecificServerOperations :
        extensions : ExternalResourceServerExtensions -> unit

Parameters

extensions ExternalResourceServerExtensions
The class which owns sub-interface classes, each of which has methods related to a particular type of external resource.
Remarks

Through this method, some specific operations for a paritcular type of external resource, such as Open(and Unload) and shared coordinates for Revit Link, can be set in a class ExternalResourceServerExtensions.

ExternalResourceServerExtensions is able to own sub-interface classes, each of which has methods related to a particular type of external resource.

See Also

Reference

IExternalResourceServer Interface


IExternalResourceServer.IsResourceWellFormed Method

IExternalResourceServerIsResourceWellFormed Method

Implement this method to check whether the given ExternalResourceReference is formatted correctly for this server.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsResourceWellFormed(
    ExternalResourceReference extRef
)
Function IsResourceWellFormed (
    extRef As ExternalResourceReference
) As Boolean
bool IsResourceWellFormed(
    ExternalResourceReference^ extRef
)
abstract IsResourceWellFormed :
        extRef : ExternalResourceReference -> bool

Parameters

extRef ExternalResourceReference
The ExternalResourceReference to check.

Return Value

Boolean
True if the ExternalResourceReference represents a well-formed resource. False otherwise.
Remarks

Different servers will have different requirements.

A server which loads references from a website might require that the reference map contain a key called "URL" and a value that is a valid URL.

A server which loads references from a network drive might require a key called "Drive" with a value that represents a drive name, plus a key called "Path" with a value that corresponds to a path relative to the root of the drive.

This function should not check that the resource exists on the server. It should only check that the resource is formatted correctly.

See Also

Reference

IExternalResourceServer Interface


IExternalResourceServer.LoadResource Method

IExternalResourceServerLoadResource Method

Implement this method to load the requested resource.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void LoadResource(
    Guid loadRequestId,
    ExternalResourceType resourceType,
    ExternalResourceReference desiredResource,
    ExternalResourceLoadContext loadContext,
    ExternalResourceLoadContent loadResults
)
Sub LoadResource (
    loadRequestId As Guid,
    resourceType As ExternalResourceType,
    desiredResource As ExternalResourceReference,
    loadContext As ExternalResourceLoadContext,
    loadResults As ExternalResourceLoadContent
)
void LoadResource(
    Guid loadRequestId,
    ExternalResourceType^ resourceType,
    ExternalResourceReference^ desiredResource,
    ExternalResourceLoadContext^ loadContext,
    ExternalResourceLoadContent^ loadResults
)
abstract LoadResource :
        loadRequestId : Guid *
        resourceType : ExternalResourceType *
        desiredResource : ExternalResourceReference *
        loadContext : ExternalResourceLoadContext *
        loadResults : ExternalResourceLoadContent -> unit

Parameters

loadRequestId Guid
The id uniquely identifying the load request.
resourceType ExternalResourceType
The type of resource requested.
desiredResource ExternalResourceReference
The specific resource that should be loaded.
loadContext ExternalResourceLoadContext
A class containing info about the context of the load request.
loadResults ExternalResourceLoadContent
The data returned by the server as a result of this load operation. Revit will ensure that this argument is the appropriate subclass of ExternalResourceLoadContent for the type of data.
Remarks

This method will be invoked when Revit needs to load a resource supplied by this server.

Revit provides four key pieces of information to the server:

  • A GUID identifying the load request.
  • The type of external resource that Revit is requesting, such as keynote data, linked Revit/CAD files, etc.
  • An ExternalResourceReference object, which contains information, such as a filename, the version, or other data, that identifies the specific resource that Revit needs from the server.
  • An ExternalResourceLoadContext object, which contains information about the context of the load request. For example, the ExternalResourceLoadContext contains information describing whether the load came about as a result of a user action or an automatic action.

The server returns the results of the load request back to Revit via the loadResults argument, which will be a sub-class of ExternalResourceLoadContent. This object will contain appropriate data structures to hold the actual resource data (content) required by Revit for the specified ExternalResourceType.

Server authors may also wish to display UI related to the resource load operation, particularly when errors occur while loading or creating the content. The UI should not be created by the IExternalResourceServer. Instead, the server author should implement an IExternalResourcesUIServer which will handle all UI-related tasks. The external services framework supports data sharing between, and coordinates the actions of, the two types of servers as follows:

  1. Each ExternalResourceLoadContent sub-class is designed to hold data related to errors that may have occurred while loading or creating the content the specified ExternalResourceType. The IExternalResourceServer should set this data as needed in the LoadResource(Guid, ExternalResourceType, ExternalResourceReference, ExternalResourceLoadContext, ExternalResourceLoadContent) method.
  2. The error data, along with ExternalResourceReference and other information associated with the attempt to load the external resource, is stored internally by Revit until a time when it is appropriate to display UI.
  3. When appropriate, the framework will invoke the HandleLoadResourceResults method of any IExternalResourceUIServer that is associated with the IExternalResourceServer, and will pass the error data and other information to the UIServer for possible display in the Revit UI.

Note that instead of using the ExternalResourceLoadContent object, the IExternalResourceServer can store its own error information. Subsequently, when the external services framework invokes the IExternalResourceUIServer's HandleLoadResourceResults method, the IExternalResourceUIServer can communicate directly with its associated IExternalResourceServer - using whatever interface the server developer has implemented - to retrieve the required messages and error data for display in the UI. Revit provides a GUID to LoadResource(Guid, ExternalResourceType, ExternalResourceReference, ExternalResourceLoadContext, ExternalResourceLoadContent), to facilitate identification of individual load requests.

See Also

Reference

IExternalResourceServer Interface


IExternalResourceServer.SetupBrowserData Method

IExternalResourceServerSetupBrowserData Method

Implement this method to setup external resource browser data which will be accessed in Revit external resource browser UI.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void SetupBrowserData(
    ExternalResourceBrowserData browseData
)
Sub SetupBrowserData (
    browseData As ExternalResourceBrowserData
)
void SetupBrowserData(
    ExternalResourceBrowserData^ browseData
)
abstract SetupBrowserData :
        browseData : ExternalResourceBrowserData -> unit

Parameters

browseData ExternalResourceBrowserData
The input context to match the external resources and browser results returned by the server.
Remarks
If errors occur during setup, store this information externally, and then retrieve and deal with the errors during the call to HandleBrowseResult() of your IExternalResourceUIServer.
See Also

Reference

IExternalResourceServer Interface


IExternalResourceServer.SupportsExternalResourceType Method

IExternalResourceServerSupportsExternalResourceType Method

Implement this method to indicate whether the server can provide data for a specified type of external resource.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool SupportsExternalResourceType(
    ExternalResourceType type
)
Function SupportsExternalResourceType (
    type As ExternalResourceType
) As Boolean
bool SupportsExternalResourceType(
    ExternalResourceType^ type
)
abstract SupportsExternalResourceType :
        type : ExternalResourceType -> bool

Parameters

type ExternalResourceType
The ExternalResourceType of interest to the caller. For example, KeynoteTable - to determine if the server provides data for Revit's keynote table.

Return Value

Boolean
True if the server supports the specified type of external resource
See Also

Reference

IExternalResourceServer Interface


IFailuresPreprocessor Interface

An interface that may be used to perform a preprocessing step to either filter out anticipated transaction failures or to mark certain failures as non-continuable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IFailuresPreprocessor
Public Interface IFailuresPreprocessor
public interface class IFailuresPreprocessor
type IFailuresPreprocessor = interface end

The IFailuresPreprocessor type exposes the following members.

Methods
 | Name | Description
Public method | PreprocessFailures | This method is called when there have been failures found at the end of a transaction and Revit is about to start processing them.
Top
Remarks
This interface, if provided, is invoked when there are failures found at the end of a transaction. An instance of this interface can be set in the failure handling options of transaction object.
Example
C#
VB
C++
F#
Copy
public class RoomWarningSwallower : IFailuresPreprocessor
{
    public FailureProcessingResult PreprocessFailures(FailuresAccessor failuresAccessor)
    {
        IList<FailureMessageAccessor> failList = new List<FailureMessageAccessor>();
        // Inside event handler, get all warnings
        failList = failuresAccessor.GetFailureMessages();
        foreach (FailureMessageAccessor failure in failList)
        {
            // check FailureDefinitionIds against ones that you want to dismiss,
            FailureDefinitionId failID = failure.GetFailureDefinitionId();
            // prevent Revit from showing Unenclosed room warnings
            if (failID == BuiltInFailures.RoomFailures.RoomNotEnclosed)
            {
                failuresAccessor.DeleteWarning(failure);
            }
        }

        return FailureProcessingResult.Continue;
    }
}
Public Class RoomWarningSwallower
    Implements IFailuresPreprocessor
    Public Function PreprocessFailures(failuresAccessor As FailuresAccessor) As FailureProcessingResult Implements IFailuresPreprocessor.PreprocessFailures
        Dim failList As IList(Of FailureMessageAccessor) = New List(Of FailureMessageAccessor)()
        ' Inside event handler, get all warnings
        failList = failuresAccessor.GetFailureMessages()
        For Each failure As FailureMessageAccessor In failList
            ' check FailureDefinitionIds against ones that you want to dismiss,
            Dim failID As FailureDefinitionId = failure.GetFailureDefinitionId()
            ' prevent Revit from showing Unenclosed room warnings
            If failID = BuiltInFailures.RoomFailures.RoomNotEnclosed Then
                failuresAccessor.DeleteWarning(failure)
            End If
        Next

        Return FailureProcessingResult.[Continue]
    End Function
End Class

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


IFailuresPreprocessor Methods

The IFailuresPreprocessor type exposes the following members.

Methods
 | Name | Description
Public method | PreprocessFailures | This method is called when there have been failures found at the end of a transaction and Revit is about to start processing them.
Top
See Also

Reference

IFailuresPreprocessor Interface


IFailuresPreprocessor.PreprocessFailures Method

IFailuresPreprocessorPreprocessFailures Method

This method is called when there have been failures found at the end of a transaction and Revit is about to start processing them.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
FailureProcessingResult PreprocessFailures(
    FailuresAccessor failuresAccessor
)
Function PreprocessFailures (
    failuresAccessor As FailuresAccessor
) As FailureProcessingResult
FailureProcessingResult PreprocessFailures(
    FailuresAccessor^ failuresAccessor
)
abstract PreprocessFailures :
        failuresAccessor : FailuresAccessor -> FailureProcessingResult

Parameters

failuresAccessor FailuresAccessor
The Interface class that provides access to the failure information.

Return Value

FailureProcessingResult
Notifies end of transaction code about further actions required. Return values are interpreted as follows:
  • Continue - the failure processing will continue. Failures will be shown to the user, even if they were addressed by this method.
  • ProceedWithCommit - end of transaction checks and failure processing will restart from the beginning. If some failures were resolved here, they will be removed and not delivered to the user. ProceedWithCommit cannot be returned if transaction is being rolled back.
  • ProceedWithRollBack - the failure processing will continue. Failures will be shown to the user, but user will have no option to resolve or ignore them - only cancel option will be available. If intent is to roll back transaction without showing failures to the user, it can be achieved by setting failure handling option to remove failures before returning ProceedWithRollBack.
Other return values are not allowed.
See Also

Reference

IFailuresPreprocessor Interface


IFailuresProcessor Interface

To create your own UI or fully automated tool to process Revit Failures, derive a class from this interface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IFailuresProcessor
Public Interface IFailuresProcessor
public interface class IFailuresProcessor
type IFailuresProcessor = interface end

The IFailuresProcessor type exposes the following members.

Methods
 | Name | Description
Public method | Dismiss | This method is being called in case of exception or document destruction to dismiss any possible pending failure UI that may have left on the screen
Public method | ProcessFailures | Method that Revit will invoke to process failures at the end of transaction.
Top
Remarks
To override Revit default Failures Processing UI, instantiate your own processor derived from this interface and register it in Revit application.
Example
C#
VB
C++
F#
Copy
[Autodesk.Revit.Attributes.Transaction(Autodesk.Revit.Attributes.TransactionMode.Manual)]

public class MyFailuresUI : IExternalApplication
{
    static AddInId m_appId = new AddInId(new Guid("9F179363-B349-4541-823F-A2DDB2B86AF3"));
    public Result OnStartup(UIControlledApplication application)
    {
        IFailuresProcessor myFailUI = new FailUI();
        Autodesk.Revit.ApplicationServices.Application.RegisterFailuresProcessor(myFailUI);
        return Result.Succeeded;
    }

    public Result OnShutdown(UIControlledApplication application)
    {
        return Result.Succeeded;
    }

    public class FailUI : IFailuresProcessor
    {
        public void Dismiss(Document document)
        {
            // This method is being called in case of exception or document destruction to
            // dismiss any possible pending failure UI that may have left on the screen
        }

        public FailureProcessingResult ProcessFailures(FailuresAccessor failuresAccessor)
        {
            IList<FailureResolutionType> resolutionTypeList = new List<FailureResolutionType>();
            IList<FailureMessageAccessor> failList = new List<FailureMessageAccessor>();
            // Inside event handler, get all warnings
            failList = failuresAccessor.GetFailureMessages();
            string errorString = "";
            bool hasFailures = false;
            foreach (FailureMessageAccessor failure in failList)
            {
                // check how many resolutions types were attempted to try to prevent
                // entering infinite loop
                resolutionTypeList = failuresAccessor.GetAttemptedResolutionTypes(failure);
                if (resolutionTypeList.Count >= 3)
                {
                    TaskDialog.Show("Error", "Cannot resolve failures - transaction will be rolled back.");
                    return FailureProcessingResult.ProceedWithRollBack;
                }

                errorString += "IDs ";
                foreach (ElementId id in failure.GetFailingElementIds())
                {
                    errorString += id.ToString() + ", ";
                    hasFailures = true;
                }
                errorString += "\nWill be deleted because: " + failure.GetDescriptionText() + "\n";
                failuresAccessor.DeleteElements(failure.GetFailingElementIds() as IList<ElementId>);
            }
            if (hasFailures)
            {
                TaskDialog.Show("Error", errorString);
                return FailureProcessingResult.ProceedWithCommit;
            }

            return FailureProcessingResult.Continue;
        }
    }
}
<Autodesk.Revit.Attributes.Transaction(Autodesk.Revit.Attributes.TransactionMode.Manual)> _
Public Class MyFailuresUI
    Implements IExternalApplication
    Shared m_appId As New AddInId(New Guid("9F179363-B349-4541-823F-A2DDB2B86AF3"))
    Public Function OnStartup(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnStartup
        Dim myFailUI As IFailuresProcessor = New FailUI()
        'Autodesk.Revit.ApplicationServices.Application.RegisterFailuresProcessor(myFailUI);
        Return Result.Succeeded
    End Function

    Public Function OnShutdown(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnShutdown
        Return Result.Succeeded
    End Function

    Public Class FailUI
        Implements IFailuresProcessor
        Public Sub Dismiss(document As Document) Implements IFailuresProcessor.Dismiss
            ' This method is being called in case of exception or document destruction to
            ' dismiss any possible pending failure UI that may have left on the screen
        End Sub

        Public Function ProcessFailures(failuresAccessor As FailuresAccessor) As FailureProcessingResult Implements IFailuresProcessor.ProcessFailures
            Dim resolutionTypeList As IList(Of FailureResolutionType) = New List(Of FailureResolutionType)()
            Dim failList As IList(Of FailureMessageAccessor) = New List(Of FailureMessageAccessor)()
            ' Inside event handler, get all warnings
            failList = failuresAccessor.GetFailureMessages()
            Dim errorString As String = ""
            Dim hasFailures As Boolean = False
            For Each failure As FailureMessageAccessor In failList
                ' check how many resolutions types were attempted to try to prevent
                ' entering infinite loop
                resolutionTypeList = failuresAccessor.GetAttemptedResolutionTypes(failure)
                If resolutionTypeList.Count >= 3 Then
                    TaskDialog.Show("Error", "Cannot resolve failures - transaction will be rolled back.")
                    Return FailureProcessingResult.ProceedWithRollBack
                End If

                errorString += "IDs "
                For Each id As ElementId In failure.GetFailingElementIds()
                    errorString += id.ToString() + ", "
                    hasFailures = True
                Next
                errorString += vbLf & "Will be deleted because: " + failure.GetDescriptionText() + vbLf
                failuresAccessor.DeleteElements(TryCast(failure.GetFailingElementIds(), IList(Of ElementId)))
            Next
            If hasFailures Then
                TaskDialog.Show("Error", errorString)
                Return FailureProcessingResult.ProceedWithCommit
            End If

            Return FailureProcessingResult.[Continue]
        End Function
    End Class
End Class

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


IFailuresProcessor Methods

The IFailuresProcessor type exposes the following members.

Methods
 | Name | Description
Public method | Dismiss | This method is being called in case of exception or document destruction to dismiss any possible pending failure UI that may have left on the screen
Public method | ProcessFailures | Method that Revit will invoke to process failures at the end of transaction.
Top
See Also

Reference

IFailuresProcessor Interface


IFailuresProcessor.Dismiss Method

IFailuresProcessorDismiss Method

This method is being called in case of exception or document destruction to dismiss any possible pending failure UI that may have left on the screen

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Dismiss(
    Document document
)
Sub Dismiss (
    document As Document
)
void Dismiss(
    Document^ document
)
abstract Dismiss :
        document : Document -> unit

Parameters

document Document
Document for which pending failures processing UI should be dismissed
See Also

Reference

IFailuresProcessor Interface


IFailuresProcessor.ProcessFailures Method

IFailuresProcessorProcessFailures Method

Method that Revit will invoke to process failures at the end of transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
FailureProcessingResult ProcessFailures(
    FailuresAccessor data
)
Function ProcessFailures (
    data As FailuresAccessor
) As FailureProcessingResult
FailureProcessingResult ProcessFailures(
    FailuresAccessor^ data
)
abstract ProcessFailures :
        data : FailuresAccessor -> FailureProcessingResult

Parameters

data FailuresAccessor
Provides all necessary data to perform the resolution of failures.

Return Value

FailureProcessingResult
The result of the failures processing.
  • Continue - Should be returned if there were no failures or highest failure severity was "Warning" and all warnings were deleted. If some failures are still present and "Continue" is returned, it will be treated as "ProceedWithRollback". Note: If this method has attempted to resolve failures, it should return "ProceedWithCommit" to repeat end of transaction checks and failures processing.
  • ProceedWithCommit - End of transaction checks and failure processing will restart from the beginning. If some failures were resolved, they will be removed and not delivered to the user. ProceedWithCommit cannot be returned if transaction is being rolled back.
  • ProceedWithRollBack - Transaction will be rolled back even if Commit was originally requested.
  • WaitForUserInput - Should be returned if method has activated modeless user interaction and is waiting for an external event (typically user input) to complete failures processing.
Remarks
This method is invoked after some failures may have been handled by any FailuresPreprocessor and/or FailureProcessing event subscribers.
See Also

Reference

IFailuresProcessor Interface


IFamilyLoadOptions Interface

An interface class which provide the callback for family load options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IFamilyLoadOptions
Public Interface IFamilyLoadOptions
public interface class IFamilyLoadOptions
type IFamilyLoadOptions = interface end

The IFamilyLoadOptions type exposes the following members.

Methods
 | Name | Description
Public method | OnFamilyFound | A method called when the family was found in the target document.
Public method | OnSharedFamilyFound | A method called when the shared family was found in the target document.
Top
Remarks

If the family is not loaded, or if the family is loaded but unchanged, the situation will never trigger and OnFamilyFound(Boolean, Boolean) and OnSharedFamilyFound(Family, Boolean, FamilySource, Boolean) will not be called. Only if the family is loaded and changed should the interface methods be called.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


IFamilyLoadOptions Methods

The IFamilyLoadOptions type exposes the following members.

Methods
 | Name | Description
Public method | OnFamilyFound | A method called when the family was found in the target document.
Public method | OnSharedFamilyFound | A method called when the shared family was found in the target document.
Top
See Also

Reference

IFamilyLoadOptions Interface


IFamilyLoadOptions.OnFamilyFound Method

IFamilyLoadOptionsOnFamilyFound Method

A method called when the family was found in the target document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool OnFamilyFound(
    bool familyInUse,
    out bool overwriteParameterValues
)
Function OnFamilyFound (
    familyInUse As Boolean,
    <OutAttribute> ByRef overwriteParameterValues As Boolean
) As Boolean
bool OnFamilyFound(
    bool familyInUse,
    [OutAttribute] bool% overwriteParameterValues
)
abstract OnFamilyFound :
        familyInUse : bool *
        overwriteParameterValues : bool byref -> bool

Parameters

familyInUse Boolean
Indicates if one or more instances of the family is placed in the project.
overwriteParameterValues Boolean
This determines whether or not to overwrite the parameter values of existing types. The default value is false.

Return Value

Boolean
Return true to continue loading the family, false to cancel.
Remarks
Triggered only when the family is both loaded and changed.
See Also

Reference

IFamilyLoadOptions Interface


IFamilyLoadOptions.OnSharedFamilyFound Method

IFamilyLoadOptionsOnSharedFamilyFound Method

A method called when the shared family was found in the target document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool OnSharedFamilyFound(
    Family sharedFamily,
    bool familyInUse,
    out FamilySource source,
    out bool overwriteParameterValues
)
Function OnSharedFamilyFound (
    sharedFamily As Family,
    familyInUse As Boolean,
    <OutAttribute> ByRef source As FamilySource,
    <OutAttribute> ByRef overwriteParameterValues As Boolean
) As Boolean
bool OnSharedFamilyFound(
    Family^ sharedFamily,
    bool familyInUse,
    [OutAttribute] FamilySource% source,
    [OutAttribute] bool% overwriteParameterValues
)
abstract OnSharedFamilyFound :
        sharedFamily : Family *
        familyInUse : bool *
        source : FamilySource byref *
        overwriteParameterValues : bool byref -> bool

Parameters

sharedFamily Family
The shared family in the current family document.
familyInUse Boolean
Indicates if one or more instances of the family is placed in the project.
source FamilySource
This indicates if the family will load from the project or the current family.
overwriteParameterValues Boolean
This indicates whether or not to overwrite the parameter values of existing types.

Return Value

Boolean
Return true to continue loading the family, false to cancel.
Remarks
Triggered only when the family is both loaded and changed.
See Also

Reference

IFamilyLoadOptions Interface


IFCBuiltInCategoryKey Class

A key used to represent an item stored in a template.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBIFCBuiltInCategoryKey

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class IFCBuiltInCategoryKey : IDisposable
Public Class IFCBuiltInCategoryKey
    Implements IDisposable
public ref class IFCBuiltInCategoryKey : IDisposable
type IFCBuiltInCategoryKey =
    class
        interface IDisposable
    end

The IFCBuiltInCategoryKey type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the IFCBuiltInCategoryKey
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


IFCBuiltInCategoryKey Properties

The IFCBuiltInCategoryKey type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

IFCBuiltInCategoryKey Class


IFCBuiltInCategoryKey.IsValidObject Property

IFCBuiltInCategoryKeyIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

IFCBuiltInCategoryKey Class


IFCBuiltInCategoryKey Methods

The IFCBuiltInCategoryKey type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

IFCBuiltInCategoryKey Class


IFCBuiltInCategoryKey.Dispose Method

IFCBuiltInCategoryKeyDispose Method

Releases all resources used by the IFCBuiltInCategoryKey

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

IFCBuiltInCategoryKey Class


IFCCategoryTemplate Class

Represents an element that contains an IFC category mapping template stored in a Revit document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBIFCCategoryTemplate

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class IFCCategoryTemplate : Element
Public Class IFCCategoryTemplate
    Inherits Element
public ref class IFCCategoryTemplate : public Element
type IFCCategoryTemplate =
    class
        inherit Element
    end

The IFCCategoryTemplate type exposes the following members.

Constructors
 | Name | Description
Public method | IFCCategoryTemplate | Custom constructor for this element.
Top
Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | CopyTemplate | Create copy of mapping template with new name.
 | Create | Create a IFC category mapping template with default values.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | ExportToFile | Export mapping template to a text file.
 | FindByName | Returns mapping template element by name.
 | GetActiveTemplate | Gets the active mapping template element in the document.
Public method | GetCategoryMappingTable | Gets the table that contains a mapping from Revit categories to IFC entities.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMappingInfoById | Gets a copy of ifc mapping info by category id.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
 | GetOrCreateInSessionTemplate | Gets the in-session non-serializable template or create new.
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
 | ImportFromFile | Import mapping template from a text file.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
 | IsValidName | Returns result that the proposed name is valid and not exist in the specified document.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
 | ListNames | Returns a list of names of ifc export mapping templates.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
 | ResetActiveTemplate | Sets the mapping template element to be the active mapping template in the document.
Public method | ResetCategoryToDefault | Reset one category, sub-category, or special category in the current mapping table to the default values defined in Revit
Public method | SetActiveTemplate | Sets the mapping template element to be the active mapping template in the document.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetMappingInfo(IDictionaryExportIFCCategoryKey, ExportIFCCategoryInfo) | Set the mapping info for multiple keys.
Public method | SetMappingInfo(ExportIFCCategoryKey, ExportIFCCategoryInfo) | Set the mapping info for the key.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UpdateCategoryList | Updates the mapping table with the categories from the document.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


IFCCategoryTemplate Constructor

Custom constructor for this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IFCCategoryTemplate(
    Document document
)
Public Sub New (
    document As Document
)
public:
IFCCategoryTemplate(
    Document^ document
)
new :
        document : Document -> IFCCategoryTemplate

Parameters

document Document
Document where created template is saved.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

IFCCategoryTemplate Class


IFCCategoryTemplate Properties

The IFCCategoryTemplate type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

IFCCategoryTemplate Class


IFCCategoryTemplate Methods

The IFCCategoryTemplate type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | CopyTemplate | Create copy of mapping template with new name.
 | Create | Create a IFC category mapping template with default values.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | ExportToFile | Export mapping template to a text file.
 | FindByName | Returns mapping template element by name.
 | GetActiveTemplate | Gets the active mapping template element in the document.
Public method | GetCategoryMappingTable | Gets the table that contains a mapping from Revit categories to IFC entities.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMappingInfoById | Gets a copy of ifc mapping info by category id.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
 | GetOrCreateInSessionTemplate | Gets the in-session non-serializable template or create new.
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
 | ImportFromFile | Import mapping template from a text file.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
 | IsValidName | Returns result that the proposed name is valid and not exist in the specified document.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
 | ListNames | Returns a list of names of ifc export mapping templates.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
 | ResetActiveTemplate | Sets the mapping template element to be the active mapping template in the document.
Public method | ResetCategoryToDefault | Reset one category, sub-category, or special category in the current mapping table to the default values defined in Revit
Public method | SetActiveTemplate | Sets the mapping template element to be the active mapping template in the document.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetMappingInfo(IDictionaryExportIFCCategoryKey, ExportIFCCategoryInfo) | Set the mapping info for multiple keys.
Public method | SetMappingInfo(ExportIFCCategoryKey, ExportIFCCategoryInfo) | Set the mapping info for the key.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UpdateCategoryList | Updates the mapping table with the categories from the document.
Top
See Also

Reference

IFCCategoryTemplate Class


IFCCategoryTemplate.CopyTemplate Method

IFCCategoryTemplateCopyTemplate Method

Create copy of mapping template with new name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IFCCategoryTemplate CopyTemplate(
    Document document,
    string copyTemplateName
)
Public Function CopyTemplate (
    document As Document,
    copyTemplateName As String
) As IFCCategoryTemplate
public:
IFCCategoryTemplate^ CopyTemplate(
    Document^ document,
    String^ copyTemplateName
)
member CopyTemplate :
        document : Document *
        copyTemplateName : string -> IFCCategoryTemplate

Parameters

document Document
A Revit document.
copyTemplateName String
A name for copied template name.

Return Value

IFCCategoryTemplate
The copied mapping template element.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Failed to create IFCCategoryTemplate element.
See Also

Reference

IFCCategoryTemplate Class


IFCCategoryTemplate.Create Method

IFCCategoryTemplateCreate Method

Create a IFC category mapping template with default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IFCCategoryTemplate Create(
    Document document,
    string name
)
Public Shared Function Create (
    document As Document,
    name As String
) As IFCCategoryTemplate
public:
static IFCCategoryTemplate^ Create(
    Document^ document,
    String^ name
)
static member Create :
        document : Document *
        name : string -> IFCCategoryTemplate

Parameters

document Document
Document where created mapping template is saved.
name String
The name specified to this mapping template.

Return Value

IFCCategoryTemplate
The new mapping template instance.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

IFCCategoryTemplate Class


IFCCategoryTemplate.ExportToFile Method

IFCCategoryTemplateExportToFile Method

Export mapping template to a text file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ExportToFile(
    Document document,
    string fileName
)
Public Sub ExportToFile (
    document As Document,
    fileName As String
)
public:
void ExportToFile(
    Document^ document,
    String^ fileName
)
member ExportToFile :
        document : Document *
        fileName : string -> unit

Parameters

document Document
A Revit document.
fileName String
A full text file name.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
FileAccessException | Failed to access the text file.
See Also

Reference

IFCCategoryTemplate Class


IFCCategoryTemplate.FindByName Method

IFCCategoryTemplateFindByName Method

Returns mapping template element by name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IFCCategoryTemplate FindByName(
    Document document,
    string name
)
Public Shared Function FindByName (
    document As Document,
    name As String
) As IFCCategoryTemplate
public:
static IFCCategoryTemplate^ FindByName(
    Document^ document,
    String^ name
)
static member FindByName :
        document : Document *
        name : string -> IFCCategoryTemplate

Parameters

document Document
The document to find the mapping template with the specified name.
name String
Name of the mapping template to find.

Return Value

IFCCategoryTemplate
The mapping template element, or if not found.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

IFCCategoryTemplate Class


IFCCategoryTemplate.GetActiveTemplate Method

IFCCategoryTemplateGetActiveTemplate Method

Gets the active mapping template element in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IFCCategoryTemplate GetActiveTemplate(
    Document document
)
Public Shared Function GetActiveTemplate (
    document As Document
) As IFCCategoryTemplate
public:
static IFCCategoryTemplate^ GetActiveTemplate(
    Document^ document
)
static member GetActiveTemplate :
        document : Document -> IFCCategoryTemplate

Parameters

document Document
The document to find the active mapping template.

Return Value

IFCCategoryTemplate
The active mapping template, or if none.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

IFCCategoryTemplate Class


IFCCategoryTemplate.GetCategoryMappingTable Method

IFCCategoryTemplateGetCategoryMappingTable Method

Gets the table that contains a mapping from Revit categories to IFC entities.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IDictionary<ExportIFCCategoryKey, ExportIFCCategoryInfo> GetCategoryMappingTable(
    Document document
)
Public Function GetCategoryMappingTable (
    document As Document
) As IDictionary(Of ExportIFCCategoryKey, ExportIFCCategoryInfo)
public:
IDictionary<ExportIFCCategoryKey^, ExportIFCCategoryInfo^>^ GetCategoryMappingTable(
    Document^ document
)
member GetCategoryMappingTable :
        document : Document -> IDictionary<ExportIFCCategoryKey, ExportIFCCategoryInfo>

Parameters

document Document
The document.

Return Value

IDictionary ExportIFCCategoryKey, ExportIFCCategoryInfo
The mapping table.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

IFCCategoryTemplate Class


IFCCategoryTemplate.GetMappingInfoById Method

IFCCategoryTemplateGetMappingInfoById Method

Gets a copy of ifc mapping info by category id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportIFCCategoryInfo GetMappingInfoById(
    Document document,
    ElementId categoryId,
    CustomSubCategoryId customSubCategoryId
)
Public Function GetMappingInfoById (
    document As Document,
    categoryId As ElementId,
    customSubCategoryId As CustomSubCategoryId
) As ExportIFCCategoryInfo
public:
ExportIFCCategoryInfo^ GetMappingInfoById(
    Document^ document,
    ElementId^ categoryId,
    CustomSubCategoryId customSubCategoryId
)
member GetMappingInfoById :
        document : Document *
        categoryId : ElementId *
        customSubCategoryId : CustomSubCategoryId -> ExportIFCCategoryInfo

Parameters

document Document
A Revit document.
categoryId ElementId
The category id.
customSubCategoryId CustomSubCategoryId
The custom subcategory id.

Return Value

ExportIFCCategoryInfo
Return the info for this category.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

IFCCategoryTemplate Class


IFCCategoryTemplate.GetOrCreateInSessionTemplate Method

IFCCategoryTemplateGetOrCreateInSessionTemplate Method

Gets the in-session non-serializable template or create new.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IFCCategoryTemplate GetOrCreateInSessionTemplate(
    Document document
)
Public Shared Function GetOrCreateInSessionTemplate (
    document As Document
) As IFCCategoryTemplate
public:
static IFCCategoryTemplate^ GetOrCreateInSessionTemplate(
    Document^ document
)
static member GetOrCreateInSessionTemplate :
        document : Document -> IFCCategoryTemplate

Parameters

document Document
The document to find the in-session mapping template.

Return Value

IFCCategoryTemplate
The mapping template, or if none.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

IFCCategoryTemplate Class


IFCCategoryTemplate.ImportFromFile Method

IFCCategoryTemplateImportFromFile Method

Import mapping template from a text file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IFCCategoryTemplate ImportFromFile(
    Document document,
    string fileName,
    string templateName
)
Public Shared Function ImportFromFile (
    document As Document,
    fileName As String,
    templateName As String
) As IFCCategoryTemplate
public:
static IFCCategoryTemplate^ ImportFromFile(
    Document^ document,
    String^ fileName,
    String^ templateName
)
static member ImportFromFile :
        document : Document *
        fileName : string *
        templateName : string -> IFCCategoryTemplate

Parameters

document Document
A Revit document.
fileName String
A full text file name.
templateName String
A mapping template name.

Return Value

IFCCategoryTemplate
The mapping template element.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
FileAccessException | Failed to access the text file.
InvalidOperationException | Failed to create IFCCategoryTemplate element.
See Also

Reference

IFCCategoryTemplate Class


IFCCategoryTemplate.IsValidName Method

IFCCategoryTemplateIsValidName Method

Returns result that the proposed name is valid and not exist in the specified document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidName(
    Document document,
    string name
)
Public Shared Function IsValidName (
    document As Document,
    name As String
) As Boolean
public:
static bool IsValidName(
    Document^ document,
    String^ name
)
static member IsValidName :
        document : Document *
        name : string -> bool

Parameters

document Document
Document to check
name String
Name to check.

Return Value

Boolean
Whether or not the name is valid.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Name can't contains following characters, such as { } [ ] | ; < > ? ` ~ \ : \r \n \f \t \v. Name can't be blank. If true, the name is valid and not exist in specified document. If false, the name is not a valid name which means it does not exist in specified document.
See Also

Reference

IFCCategoryTemplate Class


IFCCategoryTemplate.ListNames Method

IFCCategoryTemplateListNames Method

Returns a list of names of ifc export mapping templates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<string> ListNames(
    Document document
)
Public Shared Function ListNames (
    document As Document
) As IList(Of String)
public:
static IList<String^>^ ListNames(
    Document^ document
)
static member ListNames :
        document : Document -> IList<string>

Parameters

document Document
A Revit document to retrieve names from.

Return Value

IList String
An array of strings representing names of predefined setups.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

IFCCategoryTemplate Class


IFCCategoryTemplate.ResetActiveTemplate Method

IFCCategoryTemplateResetActiveTemplate Method

Sets the mapping template element to be the active mapping template in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void ResetActiveTemplate(
    Document document
)
Public Shared Sub ResetActiveTemplate (
    document As Document
)
public:
static void ResetActiveTemplate(
    Document^ document
)
static member ResetActiveTemplate :
        document : Document -> unit

Parameters

document Document
The document to set.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
See Also

Reference

IFCCategoryTemplate Class


IFCCategoryTemplate.ResetCategoryToDefault Method

IFCCategoryTemplateResetCategoryToDefault Method

Reset one category, sub-category, or special category in the current mapping table to the default values defined in Revit

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportIFCCategoryInfo ResetCategoryToDefault(
    ExportIFCCategoryKey categoryKey
)
Public Function ResetCategoryToDefault (
    categoryKey As ExportIFCCategoryKey
) As ExportIFCCategoryInfo
public:
ExportIFCCategoryInfo^ ResetCategoryToDefault(
    ExportIFCCategoryKey^ categoryKey
)
member ResetCategoryToDefault :
        categoryKey : ExportIFCCategoryKey -> ExportIFCCategoryInfo

Parameters

categoryKey ExportIFCCategoryKey
The selected category information.

Return Value

ExportIFCCategoryInfo
The default information.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

IFCCategoryTemplate Class


IFCCategoryTemplate.SetActiveTemplate Method

IFCCategoryTemplateSetActiveTemplate Method

Sets the mapping template element to be the active mapping template in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetActiveTemplate(
    Document document
)
Public Sub SetActiveTemplate (
    document As Document
)
public:
void SetActiveTemplate(
    Document^ document
)
member SetActiveTemplate :
        document : Document -> unit

Parameters

document Document
The document to set.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
See Also

Reference

IFCCategoryTemplate Class


IFCCategoryTemplate.SetMappingInfo Method

IFCCategoryTemplateSetMappingInfo Method

Overload List
 | Name | Description
Public method | SetMappingInfo(IDictionaryExportIFCCategoryKey, ExportIFCCategoryInfo) | Set the mapping info for multiple keys.
Public method | SetMappingInfo(ExportIFCCategoryKey, ExportIFCCategoryInfo) | Set the mapping info for the key.
Top
See Also

Reference

IFCCategoryTemplate Class


IFCCategoryTemplate.SetMappingInfo(IDictionary<ExportIFCCategoryKey, ExportIFCCategoryInfo>) Method

IFCCategoryTemplateSetMappingInfo(IDictionaryExportIFCCategoryKey, ExportIFCCategoryInfo) Method

Set the mapping info for multiple keys.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetMappingInfo(
    IDictionary<ExportIFCCategoryKey, ExportIFCCategoryInfo> newMap
)
Public Sub SetMappingInfo (
    newMap As IDictionary(Of ExportIFCCategoryKey, ExportIFCCategoryInfo)
)
public:
void SetMappingInfo(
    IDictionary<ExportIFCCategoryKey^, ExportIFCCategoryInfo^>^ newMap
)
member SetMappingInfo :
        newMap : IDictionary<ExportIFCCategoryKey, ExportIFCCategoryInfo> -> unit

Parameters

newMap IDictionary ExportIFCCategoryKey, ExportIFCCategoryInfo
The updated map.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

IFCCategoryTemplate Class
SetMappingInfo Overload


IFCCategoryTemplate.SetMappingInfo(ExportIFCCategoryKey, ExportIFCCategoryInfo) Method

IFCCategoryTemplateSetMappingInfo(ExportIFCCategoryKey, ExportIFCCategoryInfo) Method

Set the mapping info for the key.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetMappingInfo(
    ExportIFCCategoryKey key,
    ExportIFCCategoryInfo info
)
Public Sub SetMappingInfo (
    key As ExportIFCCategoryKey,
    info As ExportIFCCategoryInfo
)
public:
void SetMappingInfo(
    ExportIFCCategoryKey^ key,
    ExportIFCCategoryInfo^ info
)
member SetMappingInfo :
        key : ExportIFCCategoryKey *
        info : ExportIFCCategoryInfo -> unit

Parameters

key ExportIFCCategoryKey
The key.
info ExportIFCCategoryInfo
The info.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

IFCCategoryTemplate Class
SetMappingInfo Overload


IFCCategoryTemplate.UpdateCategoryList Method

IFCCategoryTemplateUpdateCategoryList Method

Updates the mapping table with the categories from the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void UpdateCategoryList(
    Document document
)
Public Sub UpdateCategoryList (
    document As Document
)
public:
void UpdateCategoryList(
    Document^ document
)
member UpdateCategoryList :
        document : Document -> unit

Parameters

document Document
A Revit document to retrieve names from.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

IFCCategoryTemplate Class


IFCExportElement Enumeration

An enumerated type defining if an element is exported to IFC or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum IFCExportElement
Public Enumeration IFCExportElement
public enum class IFCExportElement
type IFCExportElement
Members
Member name | Value | Description
ByType | 0 | Export element to IFC according to type settings.
Yes | 1 | Export element to IFC regardless of type or category settings.
No | 2 | Don't export element to IFC regardless of type or category settings.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


IFCExportElementType Enumeration

An enumerated type defining if an element type is exported to IFC or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum IFCExportElementType
Public Enumeration IFCExportElementType
public enum class IFCExportElementType
type IFCExportElementType
Members
Member name | Value | Description
Default | 0 | Export element type to IFC according to category or Revit element settings.
Yes | 1 | Export element type to IFC regardless of category or Revit element settings.
No | 2 | Don't export element type to IFC regardless of category or Revit element settings.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


IFCExportOptions Class

IFC Export options.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBIFCExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class IFCExportOptions : IDisposable
Public Class IFCExportOptions
    Implements IDisposable
public ref class IFCExportOptions : IDisposable
type IFCExportOptions =
    class
        interface IDisposable
    end

The IFCExportOptions type exposes the following members.

Constructors
 | Name | Description
Public method | IFCExportOptions | Default constructor. Initializes FileVersion to Default. WallAndColumnSplitting and ExportBaseQuantities are set to false. FamilyMappingFile is set to empty.
Public method | IFCExportOptions(IFCExportOptions) | Creates a copy of an IFCExportOptions.
Top
Properties
 | Name | Description
Public property | ExportBaseQuantities | Option to export IFC standard quantities currently supported by Revit.
Public property | FamilyMappingFile | Path to a file containing family mapping.
Public property | FileVersion | IFC file version.
Public property | FilterViewId | Id of the view whose visibility settings will govern the contents in the exported IFC file.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SpaceBoundaryLevel | Level of space boundaries exported in IFC file.
Public property | WallAndColumnSplitting | Option to allow division of multi-level walls and columns by levels.
Top
Methods
 | Name | Description
Public method | AddOption | Adds a new named option to the options structure.
Public method | Assign | Assigns the values of the IFCExportOptions to this options object.
Public method | Dispose | Releases all resources used by the IFCExportOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


IFCExportOptions Constructor

Overload List
 | Name | Description
Public method | IFCExportOptions | Default constructor. Initializes FileVersion to Default. WallAndColumnSplitting and ExportBaseQuantities are set to false. FamilyMappingFile is set to empty.
Public method | IFCExportOptions(IFCExportOptions) | Creates a copy of an IFCExportOptions.
Top
See Also

Reference

IFCExportOptions Class


IFCExportOptions Constructor

Default constructor. Initializes FileVersion to Default. WallAndColumnSplitting and ExportBaseQuantities are set to false. FamilyMappingFile is set to empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IFCExportOptions()
Public Sub New
public:
IFCExportOptions()
new : unit -> IFCExportOptions
See Also

Reference

IFCExportOptions Class
IFCExportOptions Overload


IFCExportOptions(IFCExportOptions) Constructor

Creates a copy of an IFCExportOptions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IFCExportOptions(
    IFCExportOptions from
)
Public Sub New (
    from As IFCExportOptions
)
public:
IFCExportOptions(
    IFCExportOptions^ from
)
new :
        from : IFCExportOptions -> IFCExportOptions

Parameters

from IFCExportOptions
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

IFCExportOptions Class
IFCExportOptions Overload


IFCExportOptions Properties

The IFCExportOptions type exposes the following members.

Properties
 | Name | Description
Public property | ExportBaseQuantities | Option to export IFC standard quantities currently supported by Revit.
Public property | FamilyMappingFile | Path to a file containing family mapping.
Public property | FileVersion | IFC file version.
Public property | FilterViewId | Id of the view whose visibility settings will govern the contents in the exported IFC file.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SpaceBoundaryLevel | Level of space boundaries exported in IFC file.
Public property | WallAndColumnSplitting | Option to allow division of multi-level walls and columns by levels.
Top
See Also

Reference

IFCExportOptions Class


IFCExportOptions.ExportBaseQuantities Property

IFCExportOptionsExportBaseQuantities Property

Option to export IFC standard quantities currently supported by Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ExportBaseQuantities { get; set; }
Public Property ExportBaseQuantities As Boolean
    Get
    Set
public:
property bool ExportBaseQuantities {
    bool get ();
    void set (bool value);
}
member ExportBaseQuantities : bool with get, set

Property Value

Boolean
Remarks
IFC has created a list of common quantities (e.g. length, area, volume, etc.) that can optionally be exported along with the 3D representation for many element types (e.g. walls, columns, doors). Setting this option to true will cause the export procedure to include the set of IFC quantities that Revit currently supports. Default is false.
See Also

Reference

IFCExportOptions Class


IFCExportOptions.FamilyMappingFile Property

IFCExportOptionsFamilyMappingFile Property

Path to a file containing family mapping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FamilyMappingFile { get; set; }
Public Property FamilyMappingFile As String
    Get
    Set
public:
property String^ FamilyMappingFile {
    String^ get ();
    void set (String^ value);
}
member FamilyMappingFile : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
The file, if specified, contains data describing how to map generic family instances to IFC containers (element types). This property may be empty, in which case the current mapping will be used. The default is an empty string.
See Also

Reference

IFCExportOptions Class


IFCExportOptions.FileVersion Property

IFCExportOptionsFileVersion Property

IFC file version.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IFCVersion FileVersion { get; set; }
Public Property FileVersion As IFCVersion
    Get
    Set
public:
property IFCVersion FileVersion {
    IFCVersion get ();
    void set (IFCVersion value);
}
member FileVersion : IFCVersion with get, set

Property Value

IFCVersion
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
Default is IFCVersion.Default.
See Also

Reference

IFCExportOptions Class


IFCExportOptions.FilterViewId Property

IFCExportOptionsFilterViewId Property

Id of the view whose visibility settings will govern the contents in the exported IFC file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId FilterViewId { get; set; }
Public Property FilterViewId As ElementId
    Get
    Set
public:
property ElementId^ FilterViewId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member FilterViewId : ElementId with get, set

Property Value

ElementId
This should be set to the id of the view, or InvalidElementId if there is to be no special filtering applied (all model elements will be exported). Default is InvalidElementId.
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

IFCExportOptions Class


IFCExportOptions.IsValidObject Property

IFCExportOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

IFCExportOptions Class


IFCExportOptions.SpaceBoundaryLevel Property

IFCExportOptionsSpaceBoundaryLevel Property

Level of space boundaries exported in IFC file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int SpaceBoundaryLevel { get; set; }
Public Property SpaceBoundaryLevel As Integer
    Get
    Set
public:
property int SpaceBoundaryLevel {
    int get ();
    void set (int value);
}
member SpaceBoundaryLevel : int with get, set

Property Value

Int32
Remarks
There are three valid values for this integer:
0 = export no space boundaries.  This can save space if the receiving application doesn't use them.
1 = export 1st level space boundaries.  This is the default.
2 = export 2nd level space boundaries.  This is primarily for use in energy analysis programs, and the GSA.
Default is 1.
See Also

Reference

IFCExportOptions Class


IFCExportOptions.WallAndColumnSplitting Property

IFCExportOptionsWallAndColumnSplitting Property

Option to allow division of multi-level walls and columns by levels.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool WallAndColumnSplitting { get; set; }
Public Property WallAndColumnSplitting As Boolean
    Get
    Set
public:
property bool WallAndColumnSplitting {
    bool get ();
    void set (bool value);
}
member WallAndColumnSplitting : bool with get, set

Property Value

Boolean
Remarks
This option will always be considered true when FileVersion is IFC-BCA. For other File Versions, default is false.
See Also

Reference

IFCExportOptions Class


IFCExportOptions Methods

The IFCExportOptions type exposes the following members.

Methods
 | Name | Description
Public method | AddOption | Adds a new named option to the options structure.
Public method | Assign | Assigns the values of the IFCExportOptions to this options object.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

IFCExportOptions Class


IFCExportOptions.AddOption Method

IFCExportOptionsAddOption Method

Adds a new named option to the options structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddOption(
    string name,
    string value
)
Public Sub AddOption (
    name As String,
    value As String
)
public:
void AddOption(
    String^ name,
    String^ value
)
member AddOption :
        name : string *
        value : string -> unit

Parameters

name String
The option name.
value String
The option value.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Named options can be used to set options not accessible through the standard IFC export user interface. It is up to the implementation of the IExporterIFC interface to customize export behavior based on these options.
See Also

Reference

IFCExportOptions Class


IFCExportOptions.Assign Method

IFCExportOptionsAssign Method

Assigns the values of the IFCExportOptions to this options object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Assign(
    IFCExportOptions sourceOptions
)
Public Sub Assign (
    sourceOptions As IFCExportOptions
)
public:
void Assign(
    IFCExportOptions^ sourceOptions
)
member Assign :
        sourceOptions : IFCExportOptions -> unit

Parameters

sourceOptions IFCExportOptions
The source IFCExportOptions.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

IFCExportOptions Class


IFCExportOptions.Dispose Method

IFCExportOptionsDispose Method

Releases all resources used by the IFCExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

IFCExportOptions Class


IFCVersion Enumeration

An enumerated type listing available IFC file versions into which a file may be exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum IFCVersion
Public Enumeration IFCVersion
public enum class IFCVersion
type IFCVersion
Members
Member name | Value | Description
Default | 0 | The Autodesk Revit application's default export format. Note that this may change as the defaults change in the Revit user interface.
IFCBCA | 8 | IFC BCA file format. This is a certified variant of IFC 2x2 used for submitting files to the Singapore BCA ePlan Check Server.
IFC2x2 | 9 | IFC 2x2 file format.
IFC2x3 | 10 | IFC 2x3 file format.
IFCCOBIE | 17 | IFC GSA COBIE 2010 file format. This is a variant of IFC 2x3 used for submitting files that are COBIE 2010-complaint.
IFC2x3CV2 | 21 | IFC 2x3 Coordination View 2.0 file format. This is a variant of IFC 2x3 used for exporting files using the Coordination View 2.0 model view.
IFC4 | 23 | IFC 4 file format.
IFC2x3FM | 24 | IFC2x3 Extended FM Handover View
IFC4RV | 25 | IFC4 Reference View
IFC4DTV | 26 | IFC4 Design Transfer View
IFC2x3BFM | 27 | IFC2x3 Basic FM Handover View
IFC4x3 | 29 | IFC4x3 file format
IFCSG | 30 | IFC-SG MVD based on IFC4
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


IGetLocalPathForOpenCallback Interface

The interface used to provide custom support for the "Open (and Unload)" command for Revit Links obtained as external resources.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IGetLocalPathForOpenCallback
Public Interface IGetLocalPathForOpenCallback
public interface class IGetLocalPathForOpenCallback
type IGetLocalPathForOpenCallback = interface end

The IGetLocalPathForOpenCallback type exposes the following members.

Methods
 | Name | Description
Public method | GetLocalPathForOpen | Implement this method to specify the local path from where a copy of a Revit link external resource can be opened for modification without interfering with its use as a link in other open documents.
Top
Remarks

Revit documents that are linked into host documents are read-only. If the user wishes to edit a linked Revit file they can use the "Open (and Unload)" command to unload the link, and automatically load it directly as a top-level, modifiable document (Revit files cannot be edited while they are being used as links). To support this operation for Revit links obtained as external resources, IExternalResourceServer authors should implement this callback. They should return a local path from where Revit can open the linked document for edit. Ideally, this should be a path that is different than the location from where it has been loaded as a link.

Once the user opens a link as a top-level document, they will presumably make changes to it and save it. It is the responsibility of the server to upload whatever changes the user makes so that the version stored on the server remains the most current. Server providers can determine when changes have been made by the user to local file by watching for the DocumentSaved event.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


IGetLocalPathForOpenCallback Methods

The IGetLocalPathForOpenCallback type exposes the following members.

Methods
 | Name | Description
Public method | GetLocalPathForOpen | Implement this method to specify the local path from where a copy of a Revit link external resource can be opened for modification without interfering with its use as a link in other open documents.
Top
See Also

Reference

IGetLocalPathForOpenCallback Interface


IGetLocalPathForOpenCallback.GetLocalPathForOpen Method

IGetLocalPathForOpenCallbackGetLocalPathForOpen Method

Implement this method to specify the local path from where a copy of a Revit link external resource can be opened for modification without interfering with its use as a link in other open documents.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetLocalPathForOpen(
    ExternalResourceReference desiredResource
)
Function GetLocalPathForOpen (
    desiredResource As ExternalResourceReference
) As String
String^ GetLocalPathForOpen(
    ExternalResourceReference^ desiredResource
)
abstract GetLocalPathForOpen :
        desiredResource : ExternalResourceReference -> string

Parameters

desiredResource ExternalResourceReference
The ExternalResourceReference that needs to be opened for modification by Revit.

Return Value

String
The local path from where Revit can open the linked file as its own top-level document.
See Also

Reference

IGetLocalPathForOpenCallback Interface


ImageBackgroundSettings Class

Represents the rendering image background settings.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBackgroundSettings
Autodesk.Revit.DBImageBackgroundSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ImageBackgroundSettings : BackgroundSettings
Public Class ImageBackgroundSettings
    Inherits BackgroundSettings
public ref class ImageBackgroundSettings : public BackgroundSettings
type ImageBackgroundSettings =
    class
        inherit BackgroundSettings
    end

The ImageBackgroundSettings type exposes the following members.

Properties
 | Name | Description
Public property | BackgroundImageFit | The background image fit type.
Public property | FilePath | File path of the image for the rendering background.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BackgroundSettings)
Public property | OffsetHeight | The vertical offset of the rendering image to the rendering region.
Public property | OffsetWidth | The horizontal offset of the rendering image to the rendering region.
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from BackgroundSettings)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ImageBackgroundSettings Properties

The ImageBackgroundSettings type exposes the following members.

Properties
 | Name | Description
Public property | BackgroundImageFit | The background image fit type.
Public property | FilePath | File path of the image for the rendering background.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BackgroundSettings)
Public property | OffsetHeight | The vertical offset of the rendering image to the rendering region.
Public property | OffsetWidth | The horizontal offset of the rendering image to the rendering region.
Top
See Also

Reference

ImageBackgroundSettings Class


ImageBackgroundSettings.BackgroundImageFit Property

ImageBackgroundSettingsBackgroundImageFit Property

The background image fit type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BackgroundImageFit BackgroundImageFit { get; set; }
Public Property BackgroundImageFit As BackgroundImageFit
    Get
    Set
public:
property BackgroundImageFit BackgroundImageFit {
    BackgroundImageFit get ();
    void set (BackgroundImageFit value);
}
member BackgroundImageFit : BackgroundImageFit with get, set

Property Value

BackgroundImageFit
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
This value indicates how scale should be applied to the image in order to fit it to a page or screen.
See Also

Reference

ImageBackgroundSettings Class


ImageBackgroundSettings.FilePath Property

ImageBackgroundSettingsFilePath Property

File path of the image for the rendering background.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FilePath { get; set; }
Public Property FilePath As String
    Get
    Set
public:
property String^ FilePath {
    String^ get ();
    void set (String^ value);
}
member FilePath : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentException | When setting this property: The file specified by path is not an image file. A valid image file should be in one of the following formats: bmp, jpg, jpeg, png, tif.
ArgumentNullException | When setting this property: A non-optional argument was null
FileArgumentNotFoundException | When setting this property: The file specified by path doesn't exist.
See Also

Reference

ImageBackgroundSettings Class


ImageBackgroundSettings.OffsetHeight Property

ImageBackgroundSettingsOffsetHeight Property

The vertical offset of the rendering image to the rendering region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double OffsetHeight { get; set; }
Public Property OffsetHeight As Double
    Get
    Set
public:
property double OffsetHeight {
    double get ();
    void set (double value);
}
member OffsetHeight : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The given value for height must be no more than 30000 feet in absolute value.
See Also

Reference

ImageBackgroundSettings Class


ImageBackgroundSettings.OffsetWidth Property

ImageBackgroundSettingsOffsetWidth Property

The horizontal offset of the rendering image to the rendering region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double OffsetWidth { get; set; }
Public Property OffsetWidth As Double
    Get
    Set
public:
property double OffsetWidth {
    double get ();
    void set (double value);
}
member OffsetWidth : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The given value for width must be no more than 30000 feet in absolute value.
See Also

Reference

ImageBackgroundSettings Class


ImageBackgroundSettings Methods

The ImageBackgroundSettings type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from BackgroundSettings)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ImageBackgroundSettings Class


ImageExportOptions Class

This class defines options for exporting views and sheets as an image.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBImageExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ImageExportOptions : IDisposable
Public Class ImageExportOptions
    Implements IDisposable
public ref class ImageExportOptions : IDisposable
type ImageExportOptions =
    class
        interface IDisposable
    end

The ImageExportOptions type exposes the following members.

Constructors
 | Name | Description
Public method | ImageExportOptions | Constructs a new instance of the options class used to produce images.
Top
Properties
 | Name | Description
Public property | ExportRange | The export range defining which view(s) will be exported.
Public property | FilePath | The file name and path for the exported file.
Public property | FitDirection | The fit direction. Used only if ZoomType is FitToPage.
Public property | HLRandWFViewsFileType | File type for exported HLR and wireframe views.
Public property | ImageResolution | The image resolution in dots per inch.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | PixelSize | The pixel size of an image in one direction. Used only if ZoomType is FitToPage.
Public property | ShadowViewsFileType | The file type for exported shadow views.
Public property | ShouldCreateWebSite | Whether or not to create a web site with a page for each export. Used only when ExportRange is SetOfViews.
Public property | ViewName | The name of the view to be created.
Public property | Zoom | The value for Zoom (as a percentage). Used only when ZoomType is Zoom.
Public property | ZoomType | The zoom type, which defines how the image size is determined.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ImageExportOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | GetFileName | Gets the file name that will be produced when exporting a view to an image.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetViewsAndSheets | Gets a list of views and sheets to be exported. Used only when ExportRange is SetOfViews.
 | IsValidFileName | Verify if File name is valid
 | IsValidForSaveToProjectAsImage | Verify if ImageExportOptions object is valid for calling saveToProjectAsImage
Public method | SetViewsAndSheets | Sets a list of views and sheets to be exported. Used only when ExportRange is SetOfViews.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ImageExportOptions Constructor

Constructs a new instance of the options class used to produce images.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImageExportOptions()
Public Sub New
public:
ImageExportOptions()
new : unit -> ImageExportOptions
See Also

Reference

ImageExportOptions Class


ImageExportOptions Properties

The ImageExportOptions type exposes the following members.

Properties
 | Name | Description
Public property | ExportRange | The export range defining which view(s) will be exported.
Public property | FilePath | The file name and path for the exported file.
Public property | FitDirection | The fit direction. Used only if ZoomType is FitToPage.
Public property | HLRandWFViewsFileType | File type for exported HLR and wireframe views.
Public property | ImageResolution | The image resolution in dots per inch.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | PixelSize | The pixel size of an image in one direction. Used only if ZoomType is FitToPage.
Public property | ShadowViewsFileType | The file type for exported shadow views.
Public property | ShouldCreateWebSite | Whether or not to create a web site with a page for each export. Used only when ExportRange is SetOfViews.
Public property | ViewName | The name of the view to be created.
Public property | Zoom | The value for Zoom (as a percentage). Used only when ZoomType is Zoom.
Public property | ZoomType | The zoom type, which defines how the image size is determined.
Top
See Also

Reference

ImageExportOptions Class


ImageExportOptions.ExportRange Property

ImageExportOptionsExportRange Property

The export range defining which view(s) will be exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportRange ExportRange { get; set; }
Public Property ExportRange As ExportRange
    Get
    Set
public:
property ExportRange ExportRange {
    ExportRange get ();
    void set (ExportRange value);
}
member ExportRange : ExportRange with get, set

Property Value

ExportRange
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
Note that SetOfViews is not an acceptable value if these options are used to save an image to a project as a new view.
See Also

Reference

ImageExportOptions Class


ImageExportOptions.FilePath Property

ImageExportOptionsFilePath Property

The file name and path for the exported file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FilePath { get; set; }
Public Property FilePath As String
    Get
    Set
public:
property String^ FilePath {
    String^ get ();
    void set (String^ value);
}
member FilePath : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentException | When setting this property: The input file path is not valid.
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
If ExportRange is SetOfViews, the name of each view or sheet will be appended to the name provided for each exported file. This field is ignored if used to save an image to a project as a new view.
See Also

Reference

ImageExportOptions Class


ImageExportOptions.FitDirection Property

ImageExportOptionsFitDirection Property

The fit direction. Used only if ZoomType is FitToPage.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FitDirectionType FitDirection { get; set; }
Public Property FitDirection As FitDirectionType
    Get
    Set
public:
property FitDirectionType FitDirection {
    FitDirectionType get ();
    void set (FitDirectionType value);
}
member FitDirection : FitDirectionType with get, set

Property Value

FitDirectionType
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
The default is Horizontal.
See Also

Reference

ImageExportOptions Class


ImageExportOptions.HLRandWFViewsFileType Property

ImageExportOptionsHLRandWFViewsFileType Property

File type for exported HLR and wireframe views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImageFileType HLRandWFViewsFileType { get; set; }
Public Property HLRandWFViewsFileType As ImageFileType
    Get
    Set
public:
property ImageFileType HLRandWFViewsFileType {
    ImageFileType get ();
    void set (ImageFileType value);
}
member HLRandWFViewsFileType : ImageFileType with get, set

Property Value

ImageFileType
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
The default is JPEGMedium. This field is ignored if used to save an image to a project as a new view.
See Also

Reference

ImageExportOptions Class


ImageExportOptions.ImageResolution Property

ImageExportOptionsImageResolution Property

The image resolution in dots per inch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImageResolution ImageResolution { get; set; }
Public Property ImageResolution As ImageResolution
    Get
    Set
public:
property ImageResolution ImageResolution {
    ImageResolution get ();
    void set (ImageResolution value);
}
member ImageResolution : ImageResolution with get, set

Property Value

ImageResolution
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
The default is DPI_72.
See Also

Reference

ImageExportOptions Class


ImageExportOptions.IsValidObject Property

ImageExportOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ImageExportOptions Class


ImageExportOptions.PixelSize Property

ImageExportOptionsPixelSize Property

The pixel size of an image in one direction. Used only if ZoomType is FitToPage.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int PixelSize { get; set; }
Public Property PixelSize As Integer
    Get
    Set
public:
property int PixelSize {
    int get ();
    void set (int value);
}
member PixelSize : int with get, set

Property Value

Int32
Exceptions
Exception | Condition
ArgumentException | When setting this property: The PixelSize value is outside the permitted range.
Remarks
The default is 512 pixels.
See Also

Reference

ImageExportOptions Class


ImageExportOptions.ShadowViewsFileType Property

ImageExportOptionsShadowViewsFileType Property

The file type for exported shadow views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImageFileType ShadowViewsFileType { get; set; }
Public Property ShadowViewsFileType As ImageFileType
    Get
    Set
public:
property ImageFileType ShadowViewsFileType {
    ImageFileType get ();
    void set (ImageFileType value);
}
member ShadowViewsFileType : ImageFileType with get, set

Property Value

ImageFileType
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
The default is JPEGMedium. This field is ignored if used to save an image to a project as a new view.
See Also

Reference

ImageExportOptions Class


ImageExportOptions.ShouldCreateWebSite Property

ImageExportOptionsShouldCreateWebSite Property

Whether or not to create a web site with a page for each export. Used only when ExportRange is SetOfViews.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldCreateWebSite { get; set; }
Public Property ShouldCreateWebSite As Boolean
    Get
    Set
public:
property bool ShouldCreateWebSite {
    bool get ();
    void set (bool value);
}
member ShouldCreateWebSite : bool with get, set

Property Value

Boolean
Remarks
The default is false. This field is ignored if used to save an image to a project as a new view.
See Also

Reference

ImageExportOptions Class


ImageExportOptions.ViewName Property

ImageExportOptionsViewName Property

The name of the view to be created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ViewName { get; set; }
Public Property ViewName As String
    Get
    Set
public:
property String^ ViewName {
    String^ get ();
    void set (String^ value);
}
member ViewName : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
This field is used only to save an image to a project as a new view.
See Also

Reference

ImageExportOptions Class


ImageExportOptions.Zoom Property

ImageExportOptionsZoom Property

The value for Zoom (as a percentage). Used only when ZoomType is Zoom.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Zoom { get; set; }
Public Property Zoom As Integer
    Get
    Set
public:
property int Zoom {
    int get ();
    void set (int value);
}
member Zoom : int with get, set

Property Value

Int32
Exceptions
Exception | Condition
ArgumentException | When setting this property: The Zoom value is outside the permitted range.
Remarks
The default is 50.
See Also

Reference

ImageExportOptions Class


ImageExportOptions.ZoomType Property

ImageExportOptionsZoomType Property

The zoom type, which defines how the image size is determined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ZoomFitType ZoomType { get; set; }
Public Property ZoomType As ZoomFitType
    Get
    Set
public:
property ZoomFitType ZoomType {
    ZoomFitType get ();
    void set (ZoomFitType value);
}
member ZoomType : ZoomFitType with get, set

Property Value

ZoomFitType
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
The default is FitToPage.
See Also

Reference

ImageExportOptions Class


ImageExportOptions Methods

The ImageExportOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | GetFileName | Gets the file name that will be produced when exporting a view to an image.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetViewsAndSheets | Gets a list of views and sheets to be exported. Used only when ExportRange is SetOfViews.
 | IsValidFileName | Verify if File name is valid
 | IsValidForSaveToProjectAsImage | Verify if ImageExportOptions object is valid for calling saveToProjectAsImage
Public method | SetViewsAndSheets | Sets a list of views and sheets to be exported. Used only when ExportRange is SetOfViews.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ImageExportOptions Class


ImageExportOptions.Dispose Method

ImageExportOptionsDispose Method

Releases all resources used by the ImageExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ImageExportOptions Class


ImageExportOptions.GetFileName Method

ImageExportOptionsGetFileName Method

Gets the file name that will be produced when exporting a view to an image.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetFileName(
    Document aDoc,
    ElementId dbViewId
)
Public Shared Function GetFileName (
    aDoc As Document,
    dbViewId As ElementId
) As String
public:
static String^ GetFileName(
    Document^ aDoc,
    ElementId^ dbViewId
)
static member GetFileName :
        aDoc : Document *
        dbViewId : ElementId -> string

Parameters

aDoc Document
The document that owns the view.
dbViewId ElementId
View which is to be exported as image.

Return Value

String
The generated exported image file name.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ImageExportOptions Class


ImageExportOptions.GetViewsAndSheets Method

ImageExportOptionsGetViewsAndSheets Method

Gets a list of views and sheets to be exported. Used only when ExportRange is SetOfViews.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ElementId> GetViewsAndSheets()
Public Function GetViewsAndSheets As IList(Of ElementId)
public:
IList<ElementId^>^ GetViewsAndSheets()
member GetViewsAndSheets : unit -> IList<ElementId>

Return Value

IList ElementId
The ids of the views and sheets.
See Also

Reference

ImageExportOptions Class


ImageExportOptions.IsValidFileName Method

ImageExportOptionsIsValidFileName Method

Verify if File name is valid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidFileName(
    string filePath
)
Public Shared Function IsValidFileName (
    filePath As String
) As Boolean
public:
static bool IsValidFileName(
    String^ filePath
)
static member IsValidFileName :
        filePath : string -> bool

Parameters

filePath String
File path to be tested for valid file name

Return Value

Boolean
True if File name is valid; false otherwise
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ImageExportOptions Class


ImageExportOptions.IsValidForSaveToProjectAsImage Method

ImageExportOptionsIsValidForSaveToProjectAsImage Method

Verify if ImageExportOptions object is valid for calling saveToProjectAsImage

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidForSaveToProjectAsImage(
    ImageExportOptions options,
    Document doc
)
Public Shared Function IsValidForSaveToProjectAsImage (
    options As ImageExportOptions,
    doc As Document
) As Boolean
public:
static bool IsValidForSaveToProjectAsImage(
    ImageExportOptions^ options,
    Document^ doc
)
static member IsValidForSaveToProjectAsImage :
        options : ImageExportOptions *
        doc : Document -> bool

Parameters

options ImageExportOptions
ImageExportOptions object to be validated
doc Document
Document for view name verification

Return Value

Boolean
True if ImageExportOptions object is valid for calling saveToProjectAsImage; false otherwise
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ImageExportOptions Class


ImageExportOptions.SetViewsAndSheets Method

ImageExportOptionsSetViewsAndSheets Method

Sets a list of views and sheets to be exported. Used only when ExportRange is SetOfViews.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetViewsAndSheets(
    IList<ElementId> viewsAndSheets
)
Public Sub SetViewsAndSheets (
    viewsAndSheets As IList(Of ElementId)
)
public:
void SetViewsAndSheets(
    IList<ElementId^>^ viewsAndSheets
)
member SetViewsAndSheets :
        viewsAndSheets : IList<ElementId> -> unit

Parameters

viewsAndSheets IList ElementId
The ids of the views and sheets.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ImageExportOptions Class


ImageFileType Enumeration

This enum is used to define exported file type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ImageFileType
Public Enumeration ImageFileType
public enum class ImageFileType
type ImageFileType
Members
Member name | Value | Description
BMP | 0 | BMP
JPEGLossless | 1 | JPEG with high quality picture
JPEGMedium | 2 | JPEG with medium quality picture
JPEGSmallest | 3 | JPEG with lower quality picture and small file size
PNG | 4 | PNG
TARGA | 5 | TARGA
TIFF | 6 | TIFF
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ImageInstance Class

An element that represents an instance of an image placed in a view
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBImageInstance

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ImageInstance : Element
Public Class ImageInstance
    Inherits Element
public ref class ImageInstance : public Element
type ImageInstance =
    class
        inherit Element
    end

The ImageInstance type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanHaveSnaps | When true the ImageInstance has snaps that can be enabled with the EnableSnaps property
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | DrawLayer | The layer the ImageInstance will be drawn in.
Public property | EnableSnaps | When true the ImageInstance will have its snaps enabled, but only if CanHaveSnaps is true
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | Height | The height of the ImageInstance.
Public property | HeightScale | The factor applied to the ImageType to calculate the Height of the ImageInstance.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | LockProportions | When true the proportion of Width to Height will be maintained
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | Width | The width of the ImageInstance.
Public property | WidthScale | The factor applied to the width of the ImageType to calculate the Width of the ImageInstance.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new ImageInstance element placed in a view.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLocation | Returns the location of one of the points of the ImageInstance
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
 | IsValidView | Check that the view is a valid view for ImageInstance elements
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetLocation | Moves the ImageInstance to the specified location
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ImageInstance Properties

The ImageInstance type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanHaveSnaps | When true the ImageInstance has snaps that can be enabled with the EnableSnaps property
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | DrawLayer | The layer the ImageInstance will be drawn in.
Public property | EnableSnaps | When true the ImageInstance will have its snaps enabled, but only if CanHaveSnaps is true
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | Height | The height of the ImageInstance.
Public property | HeightScale | The factor applied to the ImageType to calculate the Height of the ImageInstance.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | LockProportions | When true the proportion of Width to Height will be maintained
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | Width | The width of the ImageInstance.
Public property | WidthScale | The factor applied to the width of the ImageType to calculate the Width of the ImageInstance.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

ImageInstance Class


ImageInstance.CanHaveSnaps Property

ImageInstanceCanHaveSnaps Property

When true the ImageInstance has snaps that can be enabled with the EnableSnaps property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanHaveSnaps { get; }
Public ReadOnly Property CanHaveSnaps As Boolean
    Get
public:
property bool CanHaveSnaps {
    bool get ();
}
member CanHaveSnaps : bool with get

Property Value

Boolean
Remarks
Snaps are only available for images based on PDF files that are vector based.
See Also

Reference

ImageInstance Class


ImageInstance.DrawLayer Property

ImageInstanceDrawLayer Property

The layer the ImageInstance will be drawn in.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DrawLayer DrawLayer { get; set; }
Public Property DrawLayer As DrawLayer
    Get
    Set
public:
property DrawLayer DrawLayer {
    DrawLayer get ();
    void set (DrawLayer value);
}
member DrawLayer : DrawLayer with get, set

Property Value

DrawLayer
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ImageInstance Class


ImageInstance.EnableSnaps Property

ImageInstanceEnableSnaps Property

When true the ImageInstance will have its snaps enabled, but only if CanHaveSnaps is true

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool EnableSnaps { get; set; }
Public Property EnableSnaps As Boolean
    Get
    Set
public:
property bool EnableSnaps {
    bool get ();
    void set (bool value);
}
member EnableSnaps : bool with get, set

Property Value

Boolean
Exceptions
Exception | Condition
ArgumentException | When setting this property: The image does not have snaps
See Also

Reference

ImageInstance Class


ImageInstance.Height Property

ImageInstanceHeight Property

The height of the ImageInstance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Height { get; set; }
Public Property Height As Double
    Get
    Set
public:
property double Height {
    double get ();
    void set (double value);
}
member Height : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentException | When setting this property: The given value for height results in a width that is more than 30000 feet because LockProportions is set to true.
ArgumentOutOfRangeException | When setting this property: The given value for height must be between 0 and 30000 feet.
Remarks
If LockProportions is true, then changes to the Height will also result in changes to the Width.
See Also

Reference

ImageInstance Class


ImageInstance.HeightScale Property

ImageInstanceHeightScale Property

The factor applied to the ImageType to calculate the Height of the ImageInstance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double HeightScale { get; set; }
Public Property HeightScale As Double
    Get
    Set
public:
property double HeightScale {
    double get ();
    void set (double value);
}
member HeightScale : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentException | When setting this property: The given value for heightScale results in a height that is more than 30000 feet. -or- When setting this property: The given value for heightScale results in a width that is more than 30000 feet because LockProportions is set to true.
ArgumentOutOfRangeException | When setting this property: The given value for heightScale must be non-negative.
Remarks
If LockProportions is true, then changes to the HeightScale will also result in changes to the WidthScale.
See Also

Reference

ImageInstance Class


ImageInstance.LockProportions Property

ImageInstanceLockProportions Property

When true the proportion of Width to Height will be maintained

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool LockProportions { get; set; }
Public Property LockProportions As Boolean
    Get
    Set
public:
property bool LockProportions {
    bool get ();
    void set (bool value);
}
member LockProportions : bool with get, set

Property Value

Boolean
See Also

Reference

ImageInstance Class


ImageInstance.Width Property

ImageInstanceWidth Property

The width of the ImageInstance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Width { get; set; }
Public Property Width As Double
    Get
    Set
public:
property double Width {
    double get ();
    void set (double value);
}
member Width : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentException | When setting this property: The given value for width results in a height that is more than 30000 feet because LockProportions is set to true.
ArgumentOutOfRangeException | When setting this property: The given value for width must be between 0 and 30000 feet.
Remarks
If LockProportions is true, then changes to the Width will also result in changes to the Height.
See Also

Reference

ImageInstance Class


ImageInstance.WidthScale Property

ImageInstanceWidthScale Property

The factor applied to the width of the ImageType to calculate the Width of the ImageInstance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double WidthScale { get; set; }
Public Property WidthScale As Double
    Get
    Set
public:
property double WidthScale {
    double get ();
    void set (double value);
}
member WidthScale : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentException | When setting this property: The given value for widthScale results in a width that is more than 30000 feet. -or- When setting this property: The given value for widthScale results in a height that is more than 30000 feet because LockProportions is set to true.
ArgumentOutOfRangeException | When setting this property: The given value for widthScale must be non-negative.
Remarks
If LockProportions is true, then changes to the WidthScale will also result in changes to the HeightScale.
See Also

Reference

ImageInstance Class


ImageInstance Methods

The ImageInstance type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new ImageInstance element placed in a view.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLocation | Returns the location of one of the points of the ImageInstance
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
 | IsValidView | Check that the view is a valid view for ImageInstance elements
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetLocation | Moves the ImageInstance to the specified location
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ImageInstance Class


ImageInstance.Create Method

ImageInstanceCreate Method

Creates a new ImageInstance element placed in a view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ImageInstance Create(
    Document document,
    View view,
    ElementId imageTypeId,
    ImagePlacementOptions placementOptions
)
Public Shared Function Create (
    document As Document,
    view As View,
    imageTypeId As ElementId,
    placementOptions As ImagePlacementOptions
) As ImageInstance
public:
static ImageInstance^ Create(
    Document^ document,
    View^ view,
    ElementId^ imageTypeId,
    ImagePlacementOptions^ placementOptions
)
static member Create :
        document : Document *
        view : View *
        imageTypeId : ElementId *
        placementOptions : ImagePlacementOptions -> ImageInstance

Parameters

document Document
The document.
view View
The view in which the image will be placed.
imageTypeId ElementId
The id of the ImageType element for this ImageInstance.
placementOptions ImagePlacementOptions
Options that specify where the ImageInstance should be placed.

Return Value

ImageInstance
The new ImageInstance.
Exceptions
Exception | Condition
ArgumentException | The given view cannot contain ImageInstance elements -or- The given imageTypeId can not be used as a ImageType for ImageInstance elements -or- The given placementOptions specify a location that is more than 10 miles from the origin of the model.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
See Also

Reference

ImageInstance Class


ImageInstance.GetLocation Method

ImageInstanceGetLocation Method

Returns the location of one of the points of the ImageInstance

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ GetLocation(
    BoxPlacement placementPoint
)
Public Function GetLocation (
    placementPoint As BoxPlacement
) As XYZ
public:
XYZ^ GetLocation(
    BoxPlacement placementPoint
)
member GetLocation :
        placementPoint : BoxPlacement -> XYZ

Parameters

placementPoint BoxPlacement
The placementPoint specifies for which point of the ImageInstance the location should be returned.

Return Value

XYZ
The location of the specified point
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ImageInstance Class


ImageInstance.IsValidView Method

ImageInstanceIsValidView Method

Check that the view is a valid view for ImageInstance elements

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidView(
    View view
)
Public Shared Function IsValidView (
    view As View
) As Boolean
public:
static bool IsValidView(
    View^ view
)
static member IsValidView :
        view : View -> bool

Parameters

view View
The view to validate

Return Value

Boolean
True if the view can contain ImageInstance elements. False otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ImageInstance Class


ImageInstance.SetLocation Method

ImageInstanceSetLocation Method

Moves the ImageInstance to the specified location

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetLocation(
    XYZ newLocation,
    BoxPlacement placementPoint
)
Public Sub SetLocation (
    newLocation As XYZ,
    placementPoint As BoxPlacement
)
public:
void SetLocation(
    XYZ^ newLocation,
    BoxPlacement placementPoint
)
member SetLocation :
        newLocation : XYZ *
        placementPoint : BoxPlacement -> unit

Parameters

newLocation XYZ
The new location of the specified point
placementPoint BoxPlacement
The placementPoint specifies which point of the ImageInstance should be placed at the given location.
Exceptions
Exception | Condition
ArgumentException | The given newLocation is more than 10 miles from the origin of the model
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ImageInstance Class


ImagePlacementOptions Class

ImagePlacementOptions are used to describe where an ImageInstance should be placed in a view
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBImagePlacementOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ImagePlacementOptions : IDisposable
Public Class ImagePlacementOptions
    Implements IDisposable
public ref class ImagePlacementOptions : IDisposable
type ImagePlacementOptions =
    class
        interface IDisposable
    end

The ImagePlacementOptions type exposes the following members.

Constructors
 | Name | Description
Public method | ImagePlacementOptions | Constructs a new ImagePlacementOptions that will place an ImageInstance with its center at the origin of the model
Public method | ImagePlacementOptions(XYZ, BoxPlacement) | Constructs a new ImagePlacementOptions for placing an ImageInstance
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Location | The location in the model where a point of the ImageInstance, determined by the PlacementPoint property, is going to be inserted.
Public property | PlacementPoint | Identifies which point of the ImageInstance will be aligned to the Location
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ImagePlacementOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ImagePlacementOptions Constructor

Overload List
 | Name | Description
Public method | ImagePlacementOptions | Constructs a new ImagePlacementOptions that will place an ImageInstance with its center at the origin of the model
Public method | ImagePlacementOptions(XYZ, BoxPlacement) | Constructs a new ImagePlacementOptions for placing an ImageInstance
Top
See Also

Reference

ImagePlacementOptions Class


ImagePlacementOptions Constructor

Constructs a new ImagePlacementOptions that will place an ImageInstance with its center at the origin of the model

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImagePlacementOptions()
Public Sub New
public:
ImagePlacementOptions()
new : unit -> ImagePlacementOptions
See Also

Reference

ImagePlacementOptions Class
ImagePlacementOptions Overload


ImagePlacementOptions(XYZ, BoxPlacement) Constructor

Constructs a new ImagePlacementOptions for placing an ImageInstance

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImagePlacementOptions(
    XYZ location,
    BoxPlacement placementPoint
)
Public Sub New (
    location As XYZ,
    placementPoint As BoxPlacement
)
public:
ImagePlacementOptions(
    XYZ^ location,
    BoxPlacement placementPoint
)
new :
        location : XYZ *
        placementPoint : BoxPlacement -> ImagePlacementOptions

Parameters

location XYZ
The location where the image will be placed
placementPoint BoxPlacement
The point of the image that will be aligned to the location in the view
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ImagePlacementOptions Class
ImagePlacementOptions Overload


ImagePlacementOptions Properties

The ImagePlacementOptions type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Location | The location in the model where a point of the ImageInstance, determined by the PlacementPoint property, is going to be inserted.
Public property | PlacementPoint | Identifies which point of the ImageInstance will be aligned to the Location
Top
See Also

Reference

ImagePlacementOptions Class


ImagePlacementOptions.IsValidObject Property

ImagePlacementOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ImagePlacementOptions Class


ImagePlacementOptions.Location Property

ImagePlacementOptionsLocation Property

The location in the model where a point of the ImageInstance, determined by the PlacementPoint property, is going to be inserted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Location { get; set; }
Public Property Location As XYZ
    Get
    Set
public:
property XYZ^ Location {
    XYZ^ get ();
    void set (XYZ^ value);
}
member Location : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
The location represents a point in the model where the ImageInstance will be placed. The location of the image in the view is determined by the projection of this point onto the plane of the view. This means that in a plan view, for example, the z-coordinate has no effect.
See Also

Reference

ImagePlacementOptions Class


ImagePlacementOptions.PlacementPoint Property

ImagePlacementOptionsPlacementPoint Property

Identifies which point of the ImageInstance will be aligned to the Location

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BoxPlacement PlacementPoint { get; set; }
Public Property PlacementPoint As BoxPlacement
    Get
    Set
public:
property BoxPlacement PlacementPoint {
    BoxPlacement get ();
    void set (BoxPlacement value);
}
member PlacementPoint : BoxPlacement with get, set

Property Value

BoxPlacement
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
The location of the corners of the image in the model depends on the size and orientation of the ImageInstance and the orientation of the view it is placed in.
See Also

Reference

ImagePlacementOptions Class


ImagePlacementOptions Methods

The ImagePlacementOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ImagePlacementOptions Class


ImagePlacementOptions.Dispose Method

ImagePlacementOptionsDispose Method

Releases all resources used by the ImagePlacementOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ImagePlacementOptions Class


ImageResolution Enumeration

This enum is used to define image resolution in order to calculate the image size.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ImageResolution
Public Enumeration ImageResolution
public enum class ImageResolution
type ImageResolution
Members
Member name | Value | Description
DPI_72 | 0 | 72 dpi
DPI_150 | 1 | 150 dpi
DPI_300 | 2 | 300 dpi
DPI_600 | 3 | 600 dpi
Remarks
This is used only if the Zoom option for ZoomType is set.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ImageType Class

Represents a type containing a raster based image. ImageInstances of this type can be placed in 2D views, sheets, and schedules.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBImageType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ImageType : ElementType
Public Class ImageType
    Inherits ElementType
public ref class ImageType : public ElementType
type ImageType =
    class
        inherit ElementType
    end

The ImageType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | ExternalResourceType | The type of external resources that represents images.
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | Height | The vertical size of the image
Public property | HeightInPixels | Number of pixels in the vertical direction of the image
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
Public property | PageNumber | The number of the page in a multi-page file, that was used to create the image in the ImageType.
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Path | The path to the file from which the ImageType was loaded.
Public property | PathType | The path type that was used to refer to the file from which the ImageType was loaded.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Resolution | The size of the pixels in the image, expressed in dots-per-inch (dpi)
Public property | Source | The source of the image in the ImageType.
Public property | Status | The status of the image
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | Width | The horizontal size of the image
Public property | WidthInPixels | Number of pixels in the horizontal direction of the image
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | CanReload | Check whether the ImageType can be reloaded from file.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new ImageType element and loads the image into it.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetImage | Get the bitmap image stored in the image symbol.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | Reload | Reloads the ImageType from the file found at the location specified by the Path property, using the same PageNumber and resolution.
Public method | ReloadFrom | Reloads the image in the ImageType from a new image file, and for a new PageNumber.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | Unload | Unload the linked image.
Top
Remarks

ImageType elements are created with the ImageType.Create(Document, ImageTypeOptions) method.

ImageType elements can be loaded from the following file types: *.bmp, *.jpg, *.jpeg, *.png, *.tif.

In addition, when PDF support is available, ImageType elements can also be loaded from *.pdf files. See: IsPDFImportAvailable

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ImageType Properties

The ImageType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | ExternalResourceType | The type of external resources that represents images.
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | Height | The vertical size of the image
Public property | HeightInPixels | Number of pixels in the vertical direction of the image
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
Public property | PageNumber | The number of the page in a multi-page file, that was used to create the image in the ImageType.
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Path | The path to the file from which the ImageType was loaded.
Public property | PathType | The path type that was used to refer to the file from which the ImageType was loaded.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Resolution | The size of the pixels in the image, expressed in dots-per-inch (dpi)
Public property | Source | The source of the image in the ImageType.
Public property | Status | The status of the image
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | Width | The horizontal size of the image
Public property | WidthInPixels | Number of pixels in the horizontal direction of the image
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

ImageType Class


ImageType.ExternalResourceType Property

ImageTypeExternalResourceType Property

The type of external resources that represents images.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ExternalResourceType ExternalResourceType { get; }
Public Shared ReadOnly Property ExternalResourceType As ExternalResourceType
    Get
public:
static property ExternalResourceType^ ExternalResourceType {
    ExternalResourceType^ get ();
}
static member ExternalResourceType : ExternalResourceType with get

Property Value

ExternalResourceType
See Also

Reference

ImageType Class


ImageType.Height Property

ImageTypeHeight Property

The vertical size of the image

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Height { get; }
Public ReadOnly Property Height As Double
    Get
public:
property double Height {
    double get ();
}
member Height : float with get

Property Value

Double
See Also

Reference

ImageType Class


ImageType.HeightInPixels Property

ImageTypeHeightInPixels Property

Number of pixels in the vertical direction of the image

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int HeightInPixels { get; }
Public ReadOnly Property HeightInPixels As Integer
    Get
public:
property int HeightInPixels {
    int get ();
}
member HeightInPixels : int with get

Property Value

Int32
See Also

Reference

ImageType Class


ImageType.PageNumber Property

ImageTypePageNumber Property

The number of the page in a multi-page file, that was used to create the image in the ImageType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int PageNumber { get; }
Public ReadOnly Property PageNumber As Integer
    Get
public:
property int PageNumber {
    int get ();
}
member PageNumber : int with get

Property Value

Int32
Remarks
This number is set when the ImageType is created or reloaded.
See Also

Reference

ImageType Class


ImageType.Path Property

ImageTypePath Property

The path to the file from which the ImageType was loaded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Path { get; }
Public ReadOnly Property Path As String
    Get
public:
property String^ Path {
    String^ get ();
}
member Path : string with get

Property Value

String
Remarks

The path string can be in one of several formats: absolute local, relative local, or server (indicating that the file was provided by an external server). The format is determined by PathType

The path can be an empty string, for example for (but not limited to) ImageTypes created using "Save to Project as Image".

See Also

Reference

ImageType Class


ImageType.PathType Property

ImageTypePathType Property

The path type that was used to refer to the file from which the ImageType was loaded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PathType PathType { get; }
Public ReadOnly Property PathType As PathType
    Get
public:
property PathType PathType {
    PathType get ();
}
member PathType : PathType with get

Property Value

PathType
See Also

Reference

ImageType Class


ImageType.Resolution Property

ImageTypeResolution Property

The size of the pixels in the image, expressed in dots-per-inch (dpi)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Resolution { get; }
Public ReadOnly Property Resolution As Double
    Get
public:
property double Resolution {
    double get ();
}
member Resolution : float with get

Property Value

Double
See Also

Reference

ImageType Class


ImageType.Source Property

ImageTypeSource Property

The source of the image in the ImageType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImageTypeSource Source { get; }
Public ReadOnly Property Source As ImageTypeSource
    Get
public:
property ImageTypeSource Source {
    ImageTypeSource get ();
}
member Source : ImageTypeSource with get

Property Value

ImageTypeSource
See Also

Reference

ImageType Class


ImageType.Status Property

ImageTypeStatus Property

The status of the image

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImageTypeStatus Status { get; }
Public ReadOnly Property Status As ImageTypeStatus
    Get
public:
property ImageTypeStatus Status {
    ImageTypeStatus get ();
}
member Status : ImageTypeStatus with get

Property Value

ImageTypeStatus
See Also

Reference

ImageType Class


ImageType.Width Property

ImageTypeWidth Property

The horizontal size of the image

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Width { get; }
Public ReadOnly Property Width As Double
    Get
public:
property double Width {
    double get ();
}
member Width : float with get

Property Value

Double
See Also

Reference

ImageType Class


ImageType.WidthInPixels Property

ImageTypeWidthInPixels Property

Number of pixels in the horizontal direction of the image

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int WidthInPixels { get; }
Public ReadOnly Property WidthInPixels As Integer
    Get
public:
property int WidthInPixels {
    int get ();
}
member WidthInPixels : int with get

Property Value

Int32
See Also

Reference

ImageType Class


ImageType Methods

The ImageType type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | CanReload | Check whether the ImageType can be reloaded from file.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new ImageType element and loads the image into it.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetImage | Get the bitmap image stored in the image symbol.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | Reload | Reloads the ImageType from the file found at the location specified by the Path property, using the same PageNumber and resolution.
Public method | ReloadFrom | Reloads the image in the ImageType from a new image file, and for a new PageNumber.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | Unload | Unload the linked image.
Top
See Also

Reference

ImageType Class


ImageType.CanReload Method

ImageTypeCanReload Method

Check whether the ImageType can be reloaded from file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanReload()
Public Function CanReload As Boolean
public:
bool CanReload()
member CanReload : unit -> bool

Return Value

Boolean
True if the ImageType can be reloaded. False, otherwise.
Remarks
The test first determines the candidate path for reloading the ImageType. Then the test checks that the corresponding file is a valid image file, that it is unencrypted, and that it contains the page corresponding to PageNumber.
See Also

Reference

ImageType Class


ImageType.Create Method

ImageTypeCreate Method

Creates a new ImageType element and loads the image into it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ImageType Create(
    Document document,
    ImageTypeOptions options
)
Public Shared Function Create (
    document As Document,
    options As ImageTypeOptions
) As ImageType
public:
static ImageType^ Create(
    Document^ document,
    ImageTypeOptions^ options
)
static member Create :
        document : Document *
        options : ImageTypeOptions -> ImageType

Parameters

document Document
The document.
options ImageTypeOptions
Options that specify what image to load.

Return Value

ImageType
The new ImageType.
Exceptions
Exception | Condition
ArgumentException | The image filename is an empty string. -or- The image file is not a supported image file type. -or- The image file is password protected. -or- The image file does not contain the requested page number. -or- The image file could not be read and may be corrupt. -or- An error occurred while handling the external resource corresponding to the image.
ArgumentNullException | A non-optional argument was null
FileArgumentNotFoundException | The image file does not exist.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks

The ImageType will be created but will not be placed into any view.

See Also

Reference

ImageType Class


ImageType.GetImage Method

ImageTypeGetImage Method

Get the bitmap image stored in the image symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Bitmap GetImage()
Public Function GetImage As Bitmap
public:
Bitmap^ GetImage()
member GetImage : unit -> Bitmap

Return Value

Bitmap
The bitmap image at the original loaded image size.
See Also

Reference

ImageType Class


ImageType.Reload Method

ImageTypeReload Method

Reloads the ImageType from the file found at the location specified by the Path property, using the same PageNumber and resolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Reload()
Public Sub Reload
public:
void Reload()
member Reload : unit -> unit
Exceptions
Exception | Condition
FileNotFoundException | The file represented by Path does not exist.
InvalidOperationException | This ImageType was not loaded from a file. -or- The file represented by Path is not a supported image file type. -or- The image file represented by Path is a password protected PDF file. -or- The image file represented by Path does not contain the page specified by PageNumber. -or- The image file represented by Path could not be read and may be corrupt. -or- An error occurred while handling the external resource corresponding to the image.
ModificationForbiddenException | The document containing this ImageType is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document containing this ImageType is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document containing this ImageType has no open transaction.
Remarks
If reload fails (because the image file doesn't exist, cannot be read, or does not have the correct page), the currently loaded image will remain unchanged.
See Also

Reference

ImageType Class


ImageType.ReloadFrom Method

ImageTypeReloadFrom Method

Reloads the image in the ImageType from a new image file, and for a new PageNumber.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ReloadFrom(
    ImageTypeOptions options
)
Public Sub ReloadFrom (
    options As ImageTypeOptions
)
public:
void ReloadFrom(
    ImageTypeOptions^ options
)
member ReloadFrom :
        options : ImageTypeOptions -> unit

Parameters

options ImageTypeOptions
Options that specify what image to load.
Exceptions
Exception | Condition
ArgumentException | options.Path is an empty string. -or- The file represented by options.Path is not a supported image file type. -or- The image file represented by options.Path is a password protected PDF file. -or- The image file represented by options.Path does not contain the page specified by options.PageNumber. -or- The image file represented by options.Path could not be read and may be corrupt. -or- An error occurred while handling the external resource corresponding to the image.
ArgumentNullException | A non-optional argument was null
FileArgumentNotFoundException | The file represented by options.Path does not exist.
InvalidOperationException | This ImageType was not loaded from a file.
ModificationForbiddenException | The document containing this ImageType is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document containing this ImageType is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document containing this ImageType has no open transaction.
Remarks
If reload fails (because the image file doesn't exist, cannot be read, or does not have the requested page number), the currently loaded image will remain unchanged.
See Also

Reference

ImageType Class


ImageType.Unload Method

ImageTypeUnload Method

Unload the linked image.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Unload()
Public Sub Unload
public:
void Unload()
member Unload : unit -> unit
Exceptions
Exception | Condition
InvalidOperationException | This ImageType is not a link.
ModificationForbiddenException | The document containing this ImageType is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document containing this ImageType is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document containing this ImageType has no open transaction.
See Also

Reference

ImageType Class


ImageTypeOptions Class

Represents the options used in ImageType::Create(Document, ImageTypeOptions) and ImageType.ReloadFrom(ImageTypeOptions) methods.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBImageTypeOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ImageTypeOptions : IDisposable
Public Class ImageTypeOptions
    Implements IDisposable
public ref class ImageTypeOptions : IDisposable
type ImageTypeOptions =
    class
        interface IDisposable
    end

The ImageTypeOptions type exposes the following members.

Constructors
Name | Description
Public method | ImageTypeOptions(ExternalResourceReference, ImageTypeSource) | Constructs a new instance of the ImageTypeOptions object.
Public method ImageTypeOptions(String, Boolean, ImageTypeSource)

Constructs a new instance of the ImageTypeOptions object.

The provided string path must specify a local file. The path can be absolute or relative to the project's location.

This constructor saves an additional setting that indicates whether the imagetype will be a link or an import.

Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | PageNumber | The page in the file to be used for the image
Public property | Path | The path of the file that specifies the image to be used.
Public property | Resolution | The Resolution of the image is expressed in dots-per-inch and hence determines the size of a pixel in the image.
Public property | SourceType | Indicates whether the image type is a link or an import.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ImageTypeOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsValid | If true the ImageTypeOptions can be used to create or reload an ImageType.
Public method | SetExternalResourceReference | Update the external resource reference to an image.
Public method | SetPath(String) | Update the path of the file that specifies the image to be used. The provided string path must specify a local file. The path can be absolute or relative to the project's location. ImageType will respectively use an absolute or relative path.
Public method | SetPath(String, Boolean) | Update the path of the file that specifies the image to be used. The provided string path must specify a local file. The path can be absolute or relative to the project's location. Additionally, indicate whether the path used by ImageType should be absolute or relative.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

ImageTypeOptions are used to describe how an ImageType should be created from an image file.

ImageTypeOptions are used to specify the location of the image file to use for the image using either a string path or an ExternalResourceReference.

ImageTypeOptions are used to specify if the file path should be stored as an absolute path, or a relative path. A relative path is relative to the location of the project file, unless the file is workshared, in which case the relative path is relative to the location of the central file. Note that the relative path option is only available if the project file has been saved.

ImageTypeOptions are used to specify whether the image should be imported or linked. For imported images the image data is added to the Revit project file. For linked images the image data is reloaded everytime the project file is opened. Linked images are only available if they were reloaded successfully, while imported images are always available.

For PDF files the ImageTypeOptions can be used to specify which page in the PDF file to use for the image. For raster based image files the page number must be 1 (the default).

ImageTypeOptions can be used to specify the resolution (in pixels per inch) to use for the image. For PDF files the resolution is used to determine how many pixels to use when rasterizing the PDF page. Using a higher resolution will increase the number of pixels. This will add more detail, but it will also make rendering the image slower. In addition, it will likely increase the amount of data stored in the project when the image is imported.

Raster based images have a fixed number of pixels. As a result, the resolution has no effect on the amount of detail or the amount of data that is stored. The resolution is only used to determine the size of image. Doubling the resolution will make the image appear half the size.

When a file is accessed with the help of an external server, it is likely that a local cache of the file will be created temporarily. ImageTypeOptions may refer to the cached copy of the file internally. For this reason, ImageTypeOptions should be treated as a transient object whose purpose is to become an argument to ImageType.Create(Document, ImageTypeOptions) or ImageType.ReloadFrom(ImageTypeOptions). An application should not create an ImageTypeOptions object and hold onto it for a long time.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ImageTypeOptions Constructor

Overload List
Name | Description
Public method | ImageTypeOptions(ExternalResourceReference, ImageTypeSource) | Constructs a new instance of the ImageTypeOptions object.
Public method ImageTypeOptions(String, Boolean, ImageTypeSource)

Constructs a new instance of the ImageTypeOptions object.

The provided string path must specify a local file. The path can be absolute or relative to the project's location.

This constructor saves an additional setting that indicates whether the imagetype will be a link or an import.

Top
See Also

Reference

ImageTypeOptions Class


ImageTypeOptions(ExternalResourceReference, ImageTypeSource) Constructor

Constructs a new instance of the ImageTypeOptions object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImageTypeOptions(
    ExternalResourceReference resourceReference,
    ImageTypeSource sourceType
)
Public Sub New (
    resourceReference As ExternalResourceReference,
    sourceType As ImageTypeSource
)
public:
ImageTypeOptions(
    ExternalResourceReference^ resourceReference,
    ImageTypeSource sourceType
)
new :
        resourceReference : ExternalResourceReference *
        sourceType : ImageTypeSource -> ImageTypeOptions

Parameters

resourceReference ExternalResourceReference
An external resource reference to an image.
sourceType ImageTypeSource
Specifies the image type source. Valid values are 'Import' and 'Link'.
Exceptions
Exception | Condition
ArgumentException | The ImageType source is not correct. Only Link or Import values are allowed.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Remarks

ImageTypeOptions uses an external resource reference to determine the local path that will be used to open the image file. The operation to obtain the local path requires the resource to be loaded and is performed at a later time when the local path is needed, for example, for validation. See also LoadResource method of IExternalResourceServer.

When the provided external resource reference contains a local file path, the information can include an indication that the path should be treated as a relative path.

See Also

Reference

ImageTypeOptions Class
ImageTypeOptions Overload


ImageTypeOptions(String, Boolean, ImageTypeSource) Constructor

Constructs a new instance of the ImageTypeOptions object.

The provided string path must specify a local file. The path can be absolute or relative to the project's location.

This constructor saves an additional setting that indicates whether the imagetype will be a link or an import.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImageTypeOptions(
    string path,
    bool useRelativePath,
    ImageTypeSource sourceType
)
Public Sub New (
    path As String,
    useRelativePath As Boolean,
    sourceType As ImageTypeSource
)
public:
ImageTypeOptions(
    String^ path,
    bool useRelativePath,
    ImageTypeSource sourceType
)
new :
        path : string *
        useRelativePath : bool *
        sourceType : ImageTypeSource -> ImageTypeOptions

Parameters

path String
The file path that specifies the image to be used.
useRelativePath Boolean
True if ImageType should use a relative path, false otherwise.
sourceType ImageTypeSource
Specifies the image type source. Valid values are 'Import' and 'Link'.
Exceptions
Exception | Condition
ArgumentException | The ImageType source is not correct. Only Link or Import values are allowed.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ImageTypeOptions Class
ImageTypeOptions Overload


ImageTypeOptions Properties

The ImageTypeOptions type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | PageNumber | The page in the file to be used for the image
Public property | Path | The path of the file that specifies the image to be used.
Public property | Resolution | The Resolution of the image is expressed in dots-per-inch and hence determines the size of a pixel in the image.
Public property | SourceType | Indicates whether the image type is a link or an import.
Top
See Also

Reference

ImageTypeOptions Class


ImageTypeOptions.IsValidObject Property

ImageTypeOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ImageTypeOptions Class


ImageTypeOptions.PageNumber Property

ImageTypeOptionsPageNumber Property

The page in the file to be used for the image

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int PageNumber { get; set; }
Public Property PageNumber As Integer
    Get
    Set
public:
property int PageNumber {
    int get ();
    void set (int value);
}
member PageNumber : int with get, set

Property Value

Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The given value for pageNumber is not positive.
Remarks
The default value of this property is 1. This default is appropriate for most file types. This should be used for files, such as PDF files, that can have multiple pages. Valid values range from 1 to the number of pages in the file.
See Also

Reference

ImageTypeOptions Class


ImageTypeOptions.Path Property

ImageTypeOptionsPath Property

The path of the file that specifies the image to be used.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Path { get; }
Public ReadOnly Property Path As String
    Get
public:
property String^ Path {
    String^ get ();
}
member Path : string with get

Property Value

String
See Also

Reference

ImageTypeOptions Class


ImageTypeOptions.Resolution Property

ImageTypeOptionsResolution Property

The Resolution of the image is expressed in dots-per-inch and hence determines the size of a pixel in the image.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Resolution { get; set; }
Public Property Resolution As Double
    Get
    Set
public:
property double Resolution {
    double get ();
    void set (double value);
}
member Resolution : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The given value for resolution must be positive.
Remarks

For raster based image formats (*.bmp, *.jpg, *.jpeg, *.png, *.tif) the Resolution is used to calculate the size of the image from the number of pixels in the horizontal and vertical directions.

For PDF files, which have a known paper size, the Resolution is used to control the amount of detail to capture in the image. Increasing the Resolution of PDF based images will add more detail to the image, but will also increase the amount of data stored in the project file.

The default value of this property is 72 dpi.

See Also

Reference

ImageTypeOptions Class


ImageTypeOptions.SourceType Property

ImageTypeOptionsSourceType Property

Indicates whether the image type is a link or an import.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImageTypeSource SourceType { get; set; }
Public Property SourceType As ImageTypeSource
    Get
    Set
public:
property ImageTypeSource SourceType {
    ImageTypeSource get ();
    void set (ImageTypeSource value);
}
member SourceType : ImageTypeSource with get, set

Property Value

ImageTypeSource
Exceptions
Exception | Condition
ArgumentException | When setting this property: The ImageType source is not correct. Only Link or Import values are allowed.
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
Use this property with the method ImageType::Create to create a linked image type. Use this property with the method ImageType::ReloadFrom to convert an import image type to a link and vice versa. Valid values are 'Import' and 'Link'.
See Also

Reference

ImageTypeOptions Class


ImageTypeOptions Methods

The ImageTypeOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsValid | If true the ImageTypeOptions can be used to create or reload an ImageType.
Public method | SetExternalResourceReference | Update the external resource reference to an image.
Public method | SetPath(String) | Update the path of the file that specifies the image to be used. The provided string path must specify a local file. The path can be absolute or relative to the project's location. ImageType will respectively use an absolute or relative path.
Public method | SetPath(String, Boolean) | Update the path of the file that specifies the image to be used. The provided string path must specify a local file. The path can be absolute or relative to the project's location. Additionally, indicate whether the path used by ImageType should be absolute or relative.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ImageTypeOptions Class


ImageTypeOptions.Dispose Method

ImageTypeOptionsDispose Method

Releases all resources used by the ImageTypeOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ImageTypeOptions Class


ImageTypeOptions.IsValid Method

ImageTypeOptionsIsValid Method

If true the ImageTypeOptions can be used to create or reload an ImageType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValid(
    Document document
)
Public Function IsValid (
    document As Document
) As Boolean
public:
bool IsValid(
    Document^ document
)
member IsValid :
        document : Document -> bool

Parameters

document Document
The document.

Return Value

Boolean
Returns True if the options can be used to create or reload an ImageType. False otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
This method returns true if all the following checks are true:
  • The Path points to a file that is a supported image file type.
  • The Path points to a file that is not encrypted, which can happen for PDF files.
  • The Path points to a file that contains the specified PageNumber.
  • Only imported images are allowed in family documents.
See Also

Reference

ImageTypeOptions Class


ImageTypeOptions.SetExternalResourceReference Method

ImageTypeOptionsSetExternalResourceReference Method

Update the external resource reference to an image.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetExternalResourceReference(
    ExternalResourceReference resourceReference
)
Public Sub SetExternalResourceReference (
    resourceReference As ExternalResourceReference
)
public:
void SetExternalResourceReference(
    ExternalResourceReference^ resourceReference
)
member SetExternalResourceReference :
        resourceReference : ExternalResourceReference -> unit

Parameters

resourceReference ExternalResourceReference
An external resource reference to an image.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ImageTypeOptions Class


ImageTypeOptions.SetPath Method

ImageTypeOptionsSetPath Method

Overload List
 | Name | Description
Public method | SetPath(String) | Update the path of the file that specifies the image to be used. The provided string path must specify a local file. The path can be absolute or relative to the project's location. ImageType will respectively use an absolute or relative path.
Public method | SetPath(String, Boolean) | Update the path of the file that specifies the image to be used. The provided string path must specify a local file. The path can be absolute or relative to the project's location. Additionally, indicate whether the path used by ImageType should be absolute or relative.
Top
See Also

Reference

ImageTypeOptions Class


ImageTypeOptions.SetPath(String) Method

ImageTypeOptionsSetPath(String) Method

Update the path of the file that specifies the image to be used.

The provided string path must specify a local file. The path can be absolute or relative to the project's location. ImageType will respectively use an absolute or relative path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetPath(
    string path
)
Public Sub SetPath (
    path As String
)
public:
void SetPath(
    String^ path
)
member SetPath :
        path : string -> unit

Parameters

path String
The file path that specifies the image to be used.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ImageTypeOptions Class
SetPath Overload


ImageTypeOptions.SetPath(String, Boolean) Method

ImageTypeOptionsSetPath(String, Boolean) Method

Update the path of the file that specifies the image to be used.

The provided string path must specify a local file. The path can be absolute or relative to the project's location.

Additionally, indicate whether the path used by ImageType should be absolute or relative.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetPath(
    string path,
    bool useRelativePath
)
Public Sub SetPath (
    path As String,
    useRelativePath As Boolean
)
public:
void SetPath(
    String^ path,
    bool useRelativePath
)
member SetPath :
        path : string *
        useRelativePath : bool -> unit

Parameters

path String
The file path that specifies the image to be used.
useRelativePath Boolean
True if ImageType should use a relative path, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ImageTypeOptions Class
SetPath Overload


ImageTypeSource Enumeration

The source of the data used to generate the image.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ImageTypeSource
Public Enumeration ImageTypeSource
public enum class ImageTypeSource
type ImageTypeSource
Members
Member name | Value | Description
Link | 0 | The image data is from an externally linked image file.
Import | 1 | The image data was imported into the Revit document.
Internal | 2 | The image data was created internally. These are rendering images or views saved in the project as images.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ImageTypeStatus Enumeration

Indicates the current state of the contents of the ImageType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ImageTypeStatus
Public Enumeration ImageTypeStatus
public enum class ImageTypeStatus
type ImageTypeStatus
Members
Member name | Value | Description
Unknown | 0 | The linked image has not yet been loaded. No image is available. This status is only returned before the document is fully opened.
Loaded | 1 | The linked image was successfully loaded.
FailedToLoad 2

The linked image could not be loaded from file.

Some possible reasons are:
  • The file could not be found
  • The file could be corrupt or not contain image data
  • In case of PDF files, the file might be encrypted or not have the requested page
Unloaded | 3 | The linked images was unloaded by the user. No image is available.
Imported | 4 | The image was imported and is available.
Generated | 5 | The internally created image is available.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ImageView Class

Class for ImageView views
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBView
Autodesk.Revit.DBViewDrafting
Autodesk.Revit.DBImageView

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ImageView : ViewDrafting
Public Class ImageView
    Inherits ViewDrafting
public ref class ImageView : public ViewDrafting
type ImageView =
    class
        inherit ViewDrafting
    end

The ImageView type exposes the following members.

Properties
 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View)
Public property | AreAnalyticalModelCategoriesHidden | Indicates if analytical model categories are currently hidden in the view. (Inherited from View)
Public property | AreAnnotationCategoriesHidden | Indicates if annotation categories are currently hidden in the view. (Inherited from View)
Public property | AreCoordinationModelHandlesHidden | Indicates if Coordination Model handles are currently hidden in the view. (Inherited from View)
Public property | AreImportCategoriesHidden | Indicates if import categories are currently hidden in the view. (Inherited from View)
Public property | AreModelCategoriesHidden | Indicates if model categories are currently hidden in the view. (Inherited from View)
Public property | ArePointCloudsHidden | Indicates if point clouds are currently hidden in the view. (Inherited from View)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CropBox | The Crop Box applied to the view, or an outline encompassing the crop region applied to the view. (Inherited from View)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | DetailLevel | The detail level of this view. (Inherited from View)
Public property | Discipline | The Discipline of the view. (Inherited from View)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | GenLevel | The level for the view. (Inherited from View)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | ImageInstanceId | Id of the image in the view.
Public property | IsAssemblyView | Indicates if the view is assembly view. (Inherited from View)
Public property | IsCallout | Indicates if the view is a callout view. (Inherited from View)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | Origin | Returns the origin of the screen. (Inherited from View)
Public property | Outline | The bounds of the view in paper space (in feet). (Inherited from View)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | RevealConstraintsMode | Indicates whether the Reveal Constraints mode is activated in the view. (Inherited from View)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View)
Public property | Scale | The scale of the view. (Inherited from View)
Public property | ShadowIntensity | The intesity of cast shadows - 0 = no shadows, 100 = black. (Inherited from View)
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View)
Public property | SunlightIntensity | The intensity of the simulated (directional) sunlight. 0 = no directional light; maximum value is 100. (Inherited from View)
Public property | TemporaryViewModes | Data of temporary view modes associated with this view. (Inherited from View)
Public property | Title | The view title. This consists of the view name plus other modifiers, such as the view type, sheet number, area scheme, and/or assembly type, depending on the specifics of the view. (Inherited from View)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | ViewTemplateId | The id of the template view that controls this view's parameters. (Inherited from View)
 | ViewType | The type of the view. (Inherited from View)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | AddFilter | Adds a filter to the view. (Inherited from View)
Public method | AllowsAnalysisDisplay | Identifies if this view allows display of Analysis results. (Inherited from View)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of the input view that are not controlled by the current view template. (Inherited from View)
Public method | AreGraphicsOverridesAllowed | Determines if Visibility/Graphics Overriddes can be applied to the view. (Inherited from View)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanApplyColorFillScheme | Checks if the id can be applied as the scheme id of specified category to this view. (Inherited from View)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanCategoryBeHidden | Checks whether the category can be hidden in the view. (Inherited from View)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanEnableTemporaryViewPropertiesMode | Indicates if Temporary View Properties mode can be applied for view in current state. (Inherited from View)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified (Inherited from View)
Public method | CanUseDepthCueing | Indicates if view can use Depth Cueing (Inherited from View)
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes (Inherited from View)
Public method | CanViewBeDuplicated | Identifies if this view can be duplicated. (Inherited from View)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View)
 | ConvertToIndependent | Convert the dependent view to independent. (Inherited from View)
 | Create | Create an ImageView containing an image imported from disk.
Public method | CreateViewTemplate | Creates a new view template instance from this view instance. (Inherited from View)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View)
Public method | Dispose | (Inherited from Element)
 | Duplicate | Duplicates this view. (Inherited from View)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View)
Public method | EnableTemporaryViewPropertiesMode | Turns Temporary View Properties mode on or off. In this mode, any changes made to the view are temporary and will be discarded once the mode is disabled. (Inherited from View)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetBackground | Returns the current background set for the view. (Inherited from View)
Public method | GetCalloutParentId | Gets ID of the callout parent view. (Inherited from View)
Public method | GetCategoryHidden | Checks if elements of the given category are set to be invisible (hidden) in this view. (Inherited from View)
Public method | GetCategoryOverrides | Gets graphic overrides for a category in view. (Inherited from View)
Public method | GetColorFillSchemeId | Returns id of the color fill scheme element applied to the view. (Inherited from View)
Public method | GetCropRegionShapeManager | Returns an object for managing view crop region shape. (Inherited from View)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View)
Public method | GetDepthCueing | Returns the current depth cueing settings for the view. (Inherited from View)
Public method | GetDirectContext3DHandleOverrides | Returns DirectContext3D handle overrides object for the view. (Inherited from View)
Public method | GetElementOverrides | Gets graphic overrides for an element in the view. (Inherited from View)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFilterOverrides | Gets graphic overrides that a filter applies to the view. (Inherited from View)
Public method | GetFilters | Gets the filters applied to the view. (Inherited from View)
Public method | GetFilterVisibility | Gets the visibility of the elements associated with a filter. (Inherited from View)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIsFilterEnabled | Identifies if the filter is enabled in this view. (Inherited from View)
 | GetLinkOverrides | Gets the graphic overrides of a RevitLinkType or RevitLinkInstance in view. (Inherited from View)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetModelToProjectionTransforms | Gets the transforms from the model space to the view projection space. (Inherited from View)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetNonControlledTemplateParameterIds | Returns a list of parameters that are not marked as included when this view is used as a template. (Inherited from View)
Public method | GetOrderedFilters | Gets the filters applied to the view in the order they are applied. (Inherited from View)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPlacementOnSheetStatus | Determines if this view placed on a sheet completely or partially. (Inherited from View)
Public method | GetPointCloudOverrides | Returns point cloud overrides object for the view. (Inherited from View)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View)
Public method | GetReferenceCallouts | Returns element ids of all reference callouts in the view. (Inherited from View)
Public method | GetReferenceElevations | Returns element ids of all reference elevations in the view. (Inherited from View)
Public method | GetReferenceSections | Returns element ids of all reference sections in the view. (Inherited from View)
Public method | GetSketchyLines | Returns the current sketchy lines settings for the view. (Inherited from View)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTemplateParameterIds | Returns a list of parameter ids that may be controlled when this view is assigned as a template. (Inherited from View)
Public method | GetTemporaryViewPropertiesId | When Temporary View Properties mode is in progress it provides view id that overrode settings for current view. Outside Temporary View Properties mode InvalidElementId will be returned. (Inherited from View)
Public method | GetTemporaryViewPropertiesName | When Temporary View Properties mode is in progress, name of applied template is returned. Outside Temporary View Properties mode, empty string will be returned. (Inherited from View)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetViewDisplayModel | Returns the current view display model settings for the view. (Inherited from View)
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View)
Public method | HasDetailLevel | Check if the view has a Detail Level property (Inherited from View)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property (Inherited from View)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property (Inherited from View)
Public method | HasViewTransforms | Returns true if the view reports model space to view projection space transforms. (Inherited from View)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View)
Public method | IsCategoryOverridable | Checks whether the category can have graphic overrides in this view. (Inherited from View)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsFilterApplied | Indicates if a filter is applied to the view. (Inherited from View)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View)
Public method | IsTemporaryViewPropertiesModeEnabled | Returns true when Temporary View Properties mode is in progress, false otherwise. (Inherited from View)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | IsValidViewTemplate | Verifies that the view represented by templateId can be set as the controlling view template for this view. (Inherited from View)
Public method | IsViewValidForTemplateCreation | Verifies that the view is valid for template creation. (Inherited from View)
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | Print | Print this view with the default view template and using the print setting of the current active document. (Inherited from View)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveCalloutParent | Replaces callout parent ID with InvalidElementId. (Inherited from View)
Public method | RemoveFilter | Removes a filter from the view. (Inherited from View)
 | RemoveLinkOverrides | Deletes the graphical link overrides in the current view. (Inherited from View)
Public method | RestoreCalloutParent | Restores callout parent ID to the original view ID if that view is still available. (Inherited from View)
Public method | SetBackground | Sets the background for the view. Background can only be set for 3d views and for Sections/Elevations. (Inherited from View)
Public method | SetCategoryHidden | Sets if elements of the given category will be visible in this view. (Inherited from View)
Public method | SetCategoryOverrides | Sets graphic overrides for a category in view. (Inherited from View)
Public method | SetColorFillSchemeId | Applies color fill scheme to this view. (Inherited from View)
Public method | SetDepthCueing | Sets the depth cueing settings for the view. (Inherited from View)
Public method | SetElementOverrides | Sets graphic overrides for an element in the view. (Inherited from View)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
 | SetFilterOverrides | Sets the overrides associated with a filter. (Inherited from View)
Public method | SetFilterVisibility | Sets the visibility of the elements associated with a filter. (Inherited from View)
Public method | SetIsFilterEnabled | Sets the filter enabled flag. (Inherited from View)
 | SetLinkOverrides | Sets the graphic overrides of a RevitLinkType or RevitLinkInstance in the view. (Inherited from View)
Public method | SetNonControlledTemplateParameterIds | Sets the parameters that will not be included when this view is used as a template. (Inherited from View)
Public method | SetSketchyLines | Sets the sketchy lines settings for the view. (Inherited from View)
Public method | SetViewDisplayModel | Sets the view display model settings for the view. (Inherited from View)
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View)
 | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View)
Public method | SupportedColorFillCategoryIds | Returns collection of all category ids that correspond to elements that can potentially be colored in this view according to a color fill scheme. The set may be different depending on the view type. (Inherited from View)
Public method | SupportsRevealConstraints | Checks that the view can have the Reveal Constraints mode activated. (Inherited from View)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ImageView Properties

The ImageView type exposes the following members.

Properties
 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View)
Public property | AreAnalyticalModelCategoriesHidden | Indicates if analytical model categories are currently hidden in the view. (Inherited from View)
Public property | AreAnnotationCategoriesHidden | Indicates if annotation categories are currently hidden in the view. (Inherited from View)
Public property | AreCoordinationModelHandlesHidden | Indicates if Coordination Model handles are currently hidden in the view. (Inherited from View)
Public property | AreImportCategoriesHidden | Indicates if import categories are currently hidden in the view. (Inherited from View)
Public property | AreModelCategoriesHidden | Indicates if model categories are currently hidden in the view. (Inherited from View)
Public property | ArePointCloudsHidden | Indicates if point clouds are currently hidden in the view. (Inherited from View)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CropBox | The Crop Box applied to the view, or an outline encompassing the crop region applied to the view. (Inherited from View)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | DetailLevel | The detail level of this view. (Inherited from View)
Public property | Discipline | The Discipline of the view. (Inherited from View)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | GenLevel | The level for the view. (Inherited from View)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | ImageInstanceId | Id of the image in the view.
Public property | IsAssemblyView | Indicates if the view is assembly view. (Inherited from View)
Public property | IsCallout | Indicates if the view is a callout view. (Inherited from View)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | Origin | Returns the origin of the screen. (Inherited from View)
Public property | Outline | The bounds of the view in paper space (in feet). (Inherited from View)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | RevealConstraintsMode | Indicates whether the Reveal Constraints mode is activated in the view. (Inherited from View)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View)
Public property | Scale | The scale of the view. (Inherited from View)
Public property | ShadowIntensity | The intesity of cast shadows - 0 = no shadows, 100 = black. (Inherited from View)
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View)
Public property | SunlightIntensity | The intensity of the simulated (directional) sunlight. 0 = no directional light; maximum value is 100. (Inherited from View)
Public property | TemporaryViewModes | Data of temporary view modes associated with this view. (Inherited from View)
Public property | Title | The view title. This consists of the view name plus other modifiers, such as the view type, sheet number, area scheme, and/or assembly type, depending on the specifics of the view. (Inherited from View)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | ViewTemplateId | The id of the template view that controls this view's parameters. (Inherited from View)
 | ViewType | The type of the view. (Inherited from View)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

ImageView Class


ImageView.ImageInstanceId Property

ImageViewImageInstanceId Property

Id of the image in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId ImageInstanceId { get; }
Public ReadOnly Property ImageInstanceId As ElementId
    Get
public:
property ElementId^ ImageInstanceId {
    ElementId^ get ();
}
member ImageInstanceId : ElementId with get

Property Value

ElementId
See Also

Reference

ImageView Class


ImageView Methods

The ImageView type exposes the following members.

Methods
 | Name | Description
Public method | AddFilter | Adds a filter to the view. (Inherited from View)
Public method | AllowsAnalysisDisplay | Identifies if this view allows display of Analysis results. (Inherited from View)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of the input view that are not controlled by the current view template. (Inherited from View)
Public method | AreGraphicsOverridesAllowed | Determines if Visibility/Graphics Overriddes can be applied to the view. (Inherited from View)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanApplyColorFillScheme | Checks if the id can be applied as the scheme id of specified category to this view. (Inherited from View)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanCategoryBeHidden | Checks whether the category can be hidden in the view. (Inherited from View)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanEnableTemporaryViewPropertiesMode | Indicates if Temporary View Properties mode can be applied for view in current state. (Inherited from View)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified (Inherited from View)
Public method | CanUseDepthCueing | Indicates if view can use Depth Cueing (Inherited from View)
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes (Inherited from View)
Public method | CanViewBeDuplicated | Identifies if this view can be duplicated. (Inherited from View)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View)
 | ConvertToIndependent | Convert the dependent view to independent. (Inherited from View)
 | Create | Create an ImageView containing an image imported from disk.
Public method | CreateViewTemplate | Creates a new view template instance from this view instance. (Inherited from View)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View)
Public method | Dispose | (Inherited from Element)
 | Duplicate | Duplicates this view. (Inherited from View)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View)
Public method | EnableTemporaryViewPropertiesMode | Turns Temporary View Properties mode on or off. In this mode, any changes made to the view are temporary and will be discarded once the mode is disabled. (Inherited from View)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetBackground | Returns the current background set for the view. (Inherited from View)
Public method | GetCalloutParentId | Gets ID of the callout parent view. (Inherited from View)
Public method | GetCategoryHidden | Checks if elements of the given category are set to be invisible (hidden) in this view. (Inherited from View)
Public method | GetCategoryOverrides | Gets graphic overrides for a category in view. (Inherited from View)
Public method | GetColorFillSchemeId | Returns id of the color fill scheme element applied to the view. (Inherited from View)
Public method | GetCropRegionShapeManager | Returns an object for managing view crop region shape. (Inherited from View)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View)
Public method | GetDepthCueing | Returns the current depth cueing settings for the view. (Inherited from View)
Public method | GetDirectContext3DHandleOverrides | Returns DirectContext3D handle overrides object for the view. (Inherited from View)
Public method | GetElementOverrides | Gets graphic overrides for an element in the view. (Inherited from View)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFilterOverrides | Gets graphic overrides that a filter applies to the view. (Inherited from View)
Public method | GetFilters | Gets the filters applied to the view. (Inherited from View)
Public method | GetFilterVisibility | Gets the visibility of the elements associated with a filter. (Inherited from View)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIsFilterEnabled | Identifies if the filter is enabled in this view. (Inherited from View)
 | GetLinkOverrides | Gets the graphic overrides of a RevitLinkType or RevitLinkInstance in view. (Inherited from View)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetModelToProjectionTransforms | Gets the transforms from the model space to the view projection space. (Inherited from View)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetNonControlledTemplateParameterIds | Returns a list of parameters that are not marked as included when this view is used as a template. (Inherited from View)
Public method | GetOrderedFilters | Gets the filters applied to the view in the order they are applied. (Inherited from View)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPlacementOnSheetStatus | Determines if this view placed on a sheet completely or partially. (Inherited from View)
Public method | GetPointCloudOverrides | Returns point cloud overrides object for the view. (Inherited from View)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View)
Public method | GetReferenceCallouts | Returns element ids of all reference callouts in the view. (Inherited from View)
Public method | GetReferenceElevations | Returns element ids of all reference elevations in the view. (Inherited from View)
Public method | GetReferenceSections | Returns element ids of all reference sections in the view. (Inherited from View)
Public method | GetSketchyLines | Returns the current sketchy lines settings for the view. (Inherited from View)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTemplateParameterIds | Returns a list of parameter ids that may be controlled when this view is assigned as a template. (Inherited from View)
Public method | GetTemporaryViewPropertiesId | When Temporary View Properties mode is in progress it provides view id that overrode settings for current view. Outside Temporary View Properties mode InvalidElementId will be returned. (Inherited from View)
Public method | GetTemporaryViewPropertiesName | When Temporary View Properties mode is in progress, name of applied template is returned. Outside Temporary View Properties mode, empty string will be returned. (Inherited from View)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetViewDisplayModel | Returns the current view display model settings for the view. (Inherited from View)
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View)
Public method | HasDetailLevel | Check if the view has a Detail Level property (Inherited from View)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property (Inherited from View)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property (Inherited from View)
Public method | HasViewTransforms | Returns true if the view reports model space to view projection space transforms. (Inherited from View)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View)
Public method | IsCategoryOverridable | Checks whether the category can have graphic overrides in this view. (Inherited from View)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsFilterApplied | Indicates if a filter is applied to the view. (Inherited from View)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View)
Public method | IsTemporaryViewPropertiesModeEnabled | Returns true when Temporary View Properties mode is in progress, false otherwise. (Inherited from View)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | IsValidViewTemplate | Verifies that the view represented by templateId can be set as the controlling view template for this view. (Inherited from View)
Public method | IsViewValidForTemplateCreation | Verifies that the view is valid for template creation. (Inherited from View)
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | Print | Print this view with the default view template and using the print setting of the current active document. (Inherited from View)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveCalloutParent | Replaces callout parent ID with InvalidElementId. (Inherited from View)
Public method | RemoveFilter | Removes a filter from the view. (Inherited from View)
 | RemoveLinkOverrides | Deletes the graphical link overrides in the current view. (Inherited from View)
Public method | RestoreCalloutParent | Restores callout parent ID to the original view ID if that view is still available. (Inherited from View)
Public method | SetBackground | Sets the background for the view. Background can only be set for 3d views and for Sections/Elevations. (Inherited from View)
Public method | SetCategoryHidden | Sets if elements of the given category will be visible in this view. (Inherited from View)
Public method | SetCategoryOverrides | Sets graphic overrides for a category in view. (Inherited from View)
Public method | SetColorFillSchemeId | Applies color fill scheme to this view. (Inherited from View)
Public method | SetDepthCueing | Sets the depth cueing settings for the view. (Inherited from View)
Public method | SetElementOverrides | Sets graphic overrides for an element in the view. (Inherited from View)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
 | SetFilterOverrides | Sets the overrides associated with a filter. (Inherited from View)
Public method | SetFilterVisibility | Sets the visibility of the elements associated with a filter. (Inherited from View)
Public method | SetIsFilterEnabled | Sets the filter enabled flag. (Inherited from View)
 | SetLinkOverrides | Sets the graphic overrides of a RevitLinkType or RevitLinkInstance in the view. (Inherited from View)
Public method | SetNonControlledTemplateParameterIds | Sets the parameters that will not be included when this view is used as a template. (Inherited from View)
Public method | SetSketchyLines | Sets the sketchy lines settings for the view. (Inherited from View)
Public method | SetViewDisplayModel | Sets the view display model settings for the view. (Inherited from View)
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View)
 | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View)
Public method | SupportedColorFillCategoryIds | Returns collection of all category ids that correspond to elements that can potentially be colored in this view according to a color fill scheme. The set may be different depending on the view type. (Inherited from View)
Public method | SupportsRevealConstraints | Checks that the view can have the Reveal Constraints mode activated. (Inherited from View)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View)
Top
See Also

Reference

ImageView Class


ImageView.Create Method

ImageViewCreate Method

Create an ImageView containing an image imported from disk.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ImageView Create(
    Document document,
    ImageTypeOptions options
)
Public Shared Function Create (
    document As Document,
    options As ImageTypeOptions
) As ImageView
public:
static ImageView^ Create(
    Document^ document,
    ImageTypeOptions^ options
)
static member Create :
        document : Document *
        options : ImageTypeOptions -> ImageView

Parameters

document Document
The document in which to create the view.
options ImageTypeOptions
Options that specify what image to load.

Return Value

ImageView
The newly created view.
Exceptions
Exception | Condition
ArgumentException | document is not a project document. -or- The image filename is an empty string. -or- The image file is not a supported image file type. -or- The image file is password protected. -or- The image file does not contain the requested page number. -or- The image file could not be read and may be corrupt. -or- An error occurred while handling the external resource corresponding to the image.
ArgumentNullException | A non-optional argument was null
FileArgumentNotFoundException | The image file does not exist.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
See Also

Reference

ImageView Class


IModelExportContext Interface

An interface that is used in custom export to export 3D views of a Revit model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IModelExportContext : IExportContextBase
Public Interface IModelExportContext
    Inherits IExportContextBase
public interface class IModelExportContext : IExportContextBase
type IModelExportContext =
    interface
        interface IExportContextBase
    end

The IModelExportContext type exposes the following members.

Methods
Name | Description
Public method OnCurve This method is called when a Curve is being output.
(Inherited from IExportContextBase)
Public method OnLineSegment This method is called after unhandled curve was tessellated to line segments and sent to the output.

Note for 2D export: if the export is performed for the view in non-Wireframe display style, then

  • this method is called outside of view, instance and link begin/end calls but still between OnElementBegin2D/OnElementEnd2D calls
  • this method is never called for annotation elements, i.e. their geometry should be processed in methods OnCurve and OnPolyline

(Inherited from IExportContextBase)
Public method | OnPoint | This method is called when a Point is being output.
Public method OnPolyline This method is called when a Polyline is being output.
(Inherited from IExportContextBase)
Public method OnPolylineSegments This method is called after unhandled curve was tessellated to polyline segments and sent to the output.

Note for 2D export: if the export is performed for the view in non-Wireframe display style, then

  • this method is called outside of view, instance and link begin/end calls but still between OnElementBegin2D/OnElementEnd2D calls
  • this method is never called for annotation elements, i.e. their geometry should be processed in methods OnCurve and OnPolyline

(Inherited from IExportContextBase)
Public method OnText This method is called when a text annotation object is being output.
(Inherited from IExportContextBase)
Top
Remarks

An instance of a class that implements this interface is passed in as a parameter of the CustomExporter constructor. The interface methods are then called at times of drawing entities that are currently visible in the view being exported.

With this type of export context used to perform a custom export, Revit will traverse the model and output the model's geometry as if in the process of regular displaying or exporting a 3D View. It means that any geometry which is visible in an open view (taking any current visibility setting applicable to the view) will be processed and output.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


IModelExportContext Methods

The IModelExportContext type exposes the following members.

Methods
Name | Description
Public method OnCurve This method is called when a Curve is being output.
(Inherited from IExportContextBase)
Public method OnLineSegment This method is called after unhandled curve was tessellated to line segments and sent to the output.

Note for 2D export: if the export is performed for the view in non-Wireframe display style, then

  • this method is called outside of view, instance and link begin/end calls but still between OnElementBegin2D/OnElementEnd2D calls
  • this method is never called for annotation elements, i.e. their geometry should be processed in methods OnCurve and OnPolyline

(Inherited from IExportContextBase)
Public method | OnPoint | This method is called when a Point is being output.
Public method OnPolyline This method is called when a Polyline is being output.
(Inherited from IExportContextBase)
Public method OnPolylineSegments This method is called after unhandled curve was tessellated to polyline segments and sent to the output.

Note for 2D export: if the export is performed for the view in non-Wireframe display style, then

  • this method is called outside of view, instance and link begin/end calls but still between OnElementBegin2D/OnElementEnd2D calls
  • this method is never called for annotation elements, i.e. their geometry should be processed in methods OnCurve and OnPolyline

(Inherited from IExportContextBase)
Public method OnText This method is called when a text annotation object is being output.
(Inherited from IExportContextBase)
Top
See Also

Reference

IModelExportContext Interface


IModelExportContext.OnPoint Method

IModelExportContextOnPoint Method

This method is called when a Point is being output.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
RenderNodeAction OnPoint(
    PointNode node
)
Function OnPoint (
    node As PointNode
) As RenderNodeAction
RenderNodeAction OnPoint(
    PointNode^ node
)
abstract OnPoint :
        node : PointNode -> RenderNodeAction

Parameters

node PointNode
An output node that represents a Point.

Return Value

RenderNodeAction
Return RenderNodeAction.Proceed if you wish to receive low-level geometry (line segments) for this point, or otherwise return RenderNodeAction.Skip.
Remarks
Note that this method is invoked only if the custom exporter was set up to include geometric objects in the output stream. See IncludeGeometricObjects for mode details.
See Also

Reference

IModelExportContext Interface


ImportColorMode Enumeration

An enumerated type listing how colors are handled in an import process.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ImportColorMode
Public Enumeration ImportColorMode
public enum class ImportColorMode
type ImportColorMode
Members
Member name | Value | Description
Preserved | 0 | Colors in the imported drawing are preserved.
Inverted | 1 | Colors in the imported drawing are inverted.
BlackAndWhite | 2 | Colors in the imported drawing are converted to Black and White.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ImportExportFileFormat Enumeration

Describes formats supported by import / export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ImportExportFileFormat
Public Enumeration ImportExportFileFormat
public enum class ImportExportFileFormat
type ImportExportFileFormat
Members
Member name | Value | Description
DWG | 1 | DWG format
DWF | 2 | DWF format
DWFX | 4 | DWFX format
GBXML | 6 | GBXML format
FBX | 7 | FBX format
Image | 8 | Image format
DGN | 9 | DGN format
Civil3D | 10 | Civil3D format. Obsolete.
Inventor | 11 | Inventor format
DXF | 12 | DXF format
SAT | 13 | SAT format
IFC | 14 | IFC format
NWC | 15 | Navisworks format
PDF | 16 | PDF format
STL | 17 | STL format
AXM | 19 | AXM format
OBJ | 20 | OBJ format
STEP | 23 | STEP format
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ImportIFCOptions Class

Provides access to settings that control linking and opening IFC files.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBImportIFCOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ImportIFCOptions : IDisposable
Public Class ImportIFCOptions
    Implements IDisposable
public ref class ImportIFCOptions : IDisposable
type ImportIFCOptions =
    class
        interface IDisposable
    end

The ImportIFCOptions type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LinkProcessor | Specifies the engine to use while doing a Link IFC operation.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ImportIFCOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
 | GetImportIFCOptions | Returns the current Revit instance's ImportIFCOptions.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
These settings are stored in the Revit.ini file. All documents in Revit instances which use this Revit.ini will follow these settings.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ImportIFCOptions Properties

The ImportIFCOptions type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LinkProcessor | Specifies the engine to use while doing a Link IFC operation.
Top
See Also

Reference

ImportIFCOptions Class


ImportIFCOptions.IsValidObject Property

ImportIFCOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ImportIFCOptions Class


ImportIFCOptions.LinkProcessor Property

ImportIFCOptionsLinkProcessor Property

Specifies the engine to use while doing a Link IFC operation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string LinkProcessor { get; set; }
Public Property LinkProcessor As String
    Get
    Set
public:
property String^ LinkProcessor {
    String^ get ();
    void set (String^ value);
}
member LinkProcessor : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
This setting allows the user to revert to the legacy Revit link IFC code when linking in IFC files, to preserve old behavior. There are three supported options: Default: let Revit decide the best processor. Legacy: use only the legacy Revit Link IFC processor. AnyCAD: use AnyCAD to help Link IFC files. Any other value (or no entry) will behave as "Default".
See Also

Reference

ImportIFCOptions Class


ImportIFCOptions Methods

The ImportIFCOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
 | GetImportIFCOptions | Returns the current Revit instance's ImportIFCOptions.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ImportIFCOptions Class


ImportIFCOptions.Dispose Method

ImportIFCOptionsDispose Method

Releases all resources used by the ImportIFCOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ImportIFCOptions Class


ImportIFCOptions.GetImportIFCOptions Method

ImportIFCOptionsGetImportIFCOptions Method

Returns the current Revit instance's ImportIFCOptions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ImportIFCOptions GetImportIFCOptions()
Public Shared Function GetImportIFCOptions As ImportIFCOptions
public:
static ImportIFCOptions^ GetImportIFCOptions()
static member GetImportIFCOptions : unit -> ImportIFCOptions

Return Value

ImportIFCOptions
The ImportIFCOptions for the current Revit instance.
See Also

Reference

ImportIFCOptions Class


ImportInstance Class

An element created during either import or link operation. It is an instance of CADLinkType.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBInstance
Autodesk.Revit.DBImportInstance

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ImportInstance : Instance
Public Class ImportInstance
    Inherits Instance
public ref class ImportInstance : public Instance
type ImportInstance =
    class
        inherit Instance
    end

The ImportInstance type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsLinked | Identifies whether this instance is a linked object rather than imported one.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create(Document, ElementId, View) | Creates a new instance of an existing DWG link type.
 | Create(Document, View, ExternalResourceReference, DGNImportOptions, LinkLoadResult) | Creates a new instance of DGN link type from an external resource reference and loads the linked file.
 | Create(Document, View, ExternalResourceReference, DWGImportOptions, LinkLoadResult) | Creates a new instance of DWG link type from an external resource reference and loads the linked file.
 | Create(Document, View, ExternalResourceReference, ImportOptions3DM, LinkLoadResult) | Creates a new instance of 3DM link type from an external resource reference and loads the linked file.
 | Create(Document, View, ExternalResourceReference, OBJImportOptions, LinkLoadResult) | Creates a new instance of OBJ link type from an external resource reference and loads the linked file.
 | Create(Document, View, ExternalResourceReference, SATImportOptions, LinkLoadResult) | Creates a new instance of SAT link type from an external resource reference and loads the linked file.
 | Create(Document, View, ExternalResourceReference, SKPImportOptions, LinkLoadResult) | Creates a new instance of SKP link type from an external resource reference and loads the linked file.
 | Create(Document, View, ExternalResourceReference, STEPImportOptions, LinkLoadResult) | Creates a new instance of STEP link type from an external resource reference and loads the linked file.
 | Create(Document, View, ExternalResourceReference, STLImportOptions, LinkLoadResult) | Creates a new instance of STL link type from an external resource reference and loads the linked file.
 | Create(Document, View, String, DWGImportOptions, LinkLoadResult) | Creates a new instance of DWG or DXF link type from a file path and loads the linked file.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances. (Inherited from Instance)
Public method | GetTransform | Gets the transform of the instance. (Inherited from Instance)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetVisibility | Gets the visibility for the import instance in a family document.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetVisibility | Sets the visibility for the import instance in a family document.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ImportInstance Properties

The ImportInstance type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsLinked | Identifies whether this instance is a linked object rather than imported one.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

ImportInstance Class


ImportInstance.IsLinked Property

ImportInstanceIsLinked Property

Identifies whether this instance is a linked object rather than imported one.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsLinked { get; }
Public ReadOnly Property IsLinked As Boolean
    Get
public:
property bool IsLinked {
    bool get ();
}
member IsLinked : bool with get

Property Value

Boolean
Remarks
True if the instance was imported as a link to an external file. False if the instance was imported as a copy of data from an external file.
See Also

Reference

ImportInstance Class


ImportInstance Methods

The ImportInstance type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create(Document, ElementId, View) | Creates a new instance of an existing DWG link type.
 | Create(Document, View, ExternalResourceReference, DGNImportOptions, LinkLoadResult) | Creates a new instance of DGN link type from an external resource reference and loads the linked file.
 | Create(Document, View, ExternalResourceReference, DWGImportOptions, LinkLoadResult) | Creates a new instance of DWG link type from an external resource reference and loads the linked file.
 | Create(Document, View, ExternalResourceReference, ImportOptions3DM, LinkLoadResult) | Creates a new instance of 3DM link type from an external resource reference and loads the linked file.
 | Create(Document, View, ExternalResourceReference, OBJImportOptions, LinkLoadResult) | Creates a new instance of OBJ link type from an external resource reference and loads the linked file.
 | Create(Document, View, ExternalResourceReference, SATImportOptions, LinkLoadResult) | Creates a new instance of SAT link type from an external resource reference and loads the linked file.
 | Create(Document, View, ExternalResourceReference, SKPImportOptions, LinkLoadResult) | Creates a new instance of SKP link type from an external resource reference and loads the linked file.
 | Create(Document, View, ExternalResourceReference, STEPImportOptions, LinkLoadResult) | Creates a new instance of STEP link type from an external resource reference and loads the linked file.
 | Create(Document, View, ExternalResourceReference, STLImportOptions, LinkLoadResult) | Creates a new instance of STL link type from an external resource reference and loads the linked file.
 | Create(Document, View, String, DWGImportOptions, LinkLoadResult) | Creates a new instance of DWG or DXF link type from a file path and loads the linked file.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances. (Inherited from Instance)
Public method | GetTransform | Gets the transform of the instance. (Inherited from Instance)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetVisibility | Gets the visibility for the import instance in a family document.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetVisibility | Sets the visibility for the import instance in a family document.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ImportInstance Class


ImportInstance.Create Method

ImportInstanceCreate Method

Overload List
Name | Description
Create(Document, ElementId, View) | Creates a new instance of an existing DWG link type.
Create(Document, View, ExternalResourceReference, DGNImportOptions, LinkLoadResult) | Creates a new instance of DGN link type from an external resource reference and loads the linked file.
Create(Document, View, ExternalResourceReference, DWGImportOptions, LinkLoadResult) | Creates a new instance of DWG link type from an external resource reference and loads the linked file.
Create(Document, View, ExternalResourceReference, ImportOptions3DM, LinkLoadResult) | Creates a new instance of 3DM link type from an external resource reference and loads the linked file.
Create(Document, View, ExternalResourceReference, OBJImportOptions, LinkLoadResult) | Creates a new instance of OBJ link type from an external resource reference and loads the linked file.
Create(Document, View, ExternalResourceReference, SATImportOptions, LinkLoadResult) | Creates a new instance of SAT link type from an external resource reference and loads the linked file.
Create(Document, View, ExternalResourceReference, SKPImportOptions, LinkLoadResult) | Creates a new instance of SKP link type from an external resource reference and loads the linked file.
Create(Document, View, ExternalResourceReference, STEPImportOptions, LinkLoadResult) | Creates a new instance of STEP link type from an external resource reference and loads the linked file.
Create(Document, View, ExternalResourceReference, STLImportOptions, LinkLoadResult) | Creates a new instance of STL link type from an external resource reference and loads the linked file.
Create(Document, View, String, DWGImportOptions, LinkLoadResult) | Creates a new instance of DWG or DXF link type from a file path and loads the linked file.
Top
See Also

Reference

ImportInstance Class


ImportInstance.Create(Document, ElementId, View) Method

ImportInstanceCreate(Document, ElementId, View) Method

Creates a new instance of an existing DWG link type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ImportInstance Create(
    Document document,
    ElementId typeId,
    View DBView
)
Public Shared Function Create (
    document As Document,
    typeId As ElementId,
    DBView As View
) As ImportInstance
public:
static ImportInstance^ Create(
    Document^ document,
    ElementId^ typeId,
    View^ DBView
)
static member Create :
        document : Document *
        typeId : ElementId *
        DBView : View -> ImportInstance

Parameters

document Document
The document in which to create the new instacne of DWG link type.
typeId ElementId
The element id of the existing DWG link type.
DBView View
The view into which the new instance of DWG link type will be created.

Return Value

ImportInstance
The new instance of the given DWG link type.
Exceptions
Exception | Condition
ArgumentException | document is not a project document. -or- document is in an edit mode. -or- The view is not printable. -or- The element id is not of a valid CADLinkType.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks

This function regenerates the input document.

See Also

Reference

ImportInstance Class
Create Overload


ImportInstance.Create(Document, View, ExternalResourceReference, DGNImportOptions, LinkLoadResult) Method

ImportInstanceCreate(Document, View, ExternalResourceReference, DGNImportOptions, LinkLoadResult) Method

Creates a new instance of DGN link type from an external resource reference and loads the linked file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ImportInstance Create(
    Document document,
    View DBView,
    ExternalResourceReference resourceReference,
    DGNImportOptions options,
    out LinkLoadResult linkLoadResult
)
Public Shared Function Create (
    document As Document,
    DBView As View,
    resourceReference As ExternalResourceReference,
    options As DGNImportOptions,
    <OutAttribute> ByRef linkLoadResult As LinkLoadResult
) As ImportInstance
public:
static ImportInstance^ Create(
    Document^ document,
    View^ DBView,
    ExternalResourceReference^ resourceReference,
    DGNImportOptions^ options,
    [OutAttribute] LinkLoadResult^% linkLoadResult
)
static member Create :
        document : Document *
        DBView : View *
        resourceReference : ExternalResourceReference *
        options : DGNImportOptions *
        linkLoadResult : LinkLoadResult byref -> ImportInstance

Parameters

document Document
The document in which to create the DGN link.
DBView View
The view into which the DGN link will be created.
resourceReference ExternalResourceReference
The external resource reference describing the source of the DGN link.
options DGNImportOptions
Various import options applicable to the DGN format. If , all options will be set to their respective default values.
linkLoadResult LinkLoadResult
An object containing the results of creating and loading the DGN link. It contains the ElementId of the new created DGN link type.

Return Value

ImportInstance
The new instance of DGN link type created.
Exceptions
Exception | Condition
ArgumentException | document is not a project document. -or- document is in an edit mode. -or- Import is temporarily disabled. -or- The view is not printable. -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view. -or- One or more strings describing layer selection is invalid or empty. -or- The scale is not valid as a CustomScale for use during import. -or- The server referenced by the ExternalResourceReference does not exist or does not implement IExternalResourceServer. -or- The server referenced by the ExternalResourceReference cannot support CAD links. -or- The ExternalResourceReference (resourceReference) is not in a format that is supported by its server.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
OptionalFunctionalityNotAvailableException | The DGN Import/Link module is not available in the installed Revit.
Remarks

This function creates a new DGN link type as well as a new instance of this DGN link type. The new instance of DGN link type is returned by this function and the element id of the new DGN link type is contained in the LinkLoadResult.

If the given external resource reference of the DWG link is already used by an existing DGN link type, a new instance of this existing DGN link type is created and returned. The element id of the existing DGN link type is contained in the LinkLoadResult.

This function regenerates the input document.

See Also

Reference

ImportInstance Class
Create Overload


ImportInstance.Create(Document, View, ExternalResourceReference, DWGImportOptions, LinkLoadResult) Method

ImportInstanceCreate(Document, View, ExternalResourceReference, DWGImportOptions, LinkLoadResult) Method

Creates a new instance of DWG link type from an external resource reference and loads the linked file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ImportInstance Create(
    Document document,
    View DBView,
    ExternalResourceReference resourceReference,
    DWGImportOptions options,
    out LinkLoadResult linkLoadResult
)
Public Shared Function Create (
    document As Document,
    DBView As View,
    resourceReference As ExternalResourceReference,
    options As DWGImportOptions,
    <OutAttribute> ByRef linkLoadResult As LinkLoadResult
) As ImportInstance
public:
static ImportInstance^ Create(
    Document^ document,
    View^ DBView,
    ExternalResourceReference^ resourceReference,
    DWGImportOptions^ options,
    [OutAttribute] LinkLoadResult^% linkLoadResult
)
static member Create :
        document : Document *
        DBView : View *
        resourceReference : ExternalResourceReference *
        options : DWGImportOptions *
        linkLoadResult : LinkLoadResult byref -> ImportInstance

Parameters

document Document
The document in which to create the DWG link.
DBView View
The view into which the DWG link will be created.
resourceReference ExternalResourceReference
The external resource reference describing the source of the DWG link.
options DWGImportOptions
Various import options applicable to the DWG format. If , all options will be set to their respective default values.
linkLoadResult LinkLoadResult
An object containing the results of creating and loading the DWG link. It contains the ElementId of the new created DWG link type.

Return Value

ImportInstance
The new instance of DWG link type created.
Exceptions
Exception | Condition
ArgumentException | document is not a project document. -or- document is in an edit mode. -or- Import is temporarily disabled. -or- The view is not printable. -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view. -or- One or more strings describing layer selection is invalid or empty. -or- The line weights are not valid; either it contains an invalid number of line weights, or a line weight outside the valid range. -or- The scale is not valid as a CustomScale for use during import. -or- The server referenced by the ExternalResourceReference does not exist or does not implement IExternalResourceServer. -or- The server referenced by the ExternalResourceReference cannot support CAD links. -or- The ExternalResourceReference (resourceReference) is not in a format that is supported by its server.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
OptionalFunctionalityNotAvailableException | The DWG Import/Link module is not available in the installed Revit.
Remarks

This function creates a new DWG link type as well as a new instance of this DWG link type. The new instance of DWG link type is returned by this function and the element id of the new DWG link type is contained in the LinkLoadResult.

If the given external resource reference of the DWG link is already used by an existing DWG link type, a new instance of this existing DWG link type is created and returned. The element id of the existing DWG link type is contained in the LinkLoadResult.

This function regenerates the input document.

See Also

Reference

ImportInstance Class
Create Overload


ImportInstance.Create(Document, View, ExternalResourceReference, ImportOptions3DM, LinkLoadResult) Method

ImportInstanceCreate(Document, View, ExternalResourceReference, ImportOptions3DM, LinkLoadResult) Method

Creates a new instance of 3DM link type from an external resource reference and loads the linked file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ImportInstance Create(
    Document document,
    View DBView,
    ExternalResourceReference resourceReference,
    ImportOptions3DM options,
    out LinkLoadResult linkLoadResult
)
Public Shared Function Create (
    document As Document,
    DBView As View,
    resourceReference As ExternalResourceReference,
    options As ImportOptions3DM,
    <OutAttribute> ByRef linkLoadResult As LinkLoadResult
) As ImportInstance
public:
static ImportInstance^ Create(
    Document^ document,
    View^ DBView,
    ExternalResourceReference^ resourceReference,
    ImportOptions3DM^ options,
    [OutAttribute] LinkLoadResult^% linkLoadResult
)
static member Create :
        document : Document *
        DBView : View *
        resourceReference : ExternalResourceReference *
        options : ImportOptions3DM *
        linkLoadResult : LinkLoadResult byref -> ImportInstance

Parameters

document Document
The document in which to create the 3DM link.
DBView View
The view into which the 3DM link will be created.
resourceReference ExternalResourceReference
The external resource reference describing the source of the 3DM link.
options ImportOptions3DM
Various import options applicable to the 3DM format. If , all options will be set to their respective default values.
linkLoadResult LinkLoadResult
An object containing the results of creating and loading the 3DM link. It contains the ElementId of the new created 3DM link type.

Return Value

ImportInstance
The new instance of 3DM link type created.
Exceptions
Exception | Condition
ArgumentException | document is not a project document. -or- document is in an edit mode. -or- Import is temporarily disabled. -or- The view is not printable. -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view. -or- One or more strings describing layer selection is invalid or empty. -or- The scale is not valid as a CustomScale for use during import. -or- The server referenced by the ExternalResourceReference does not exist or does not implement IExternalResourceServer. -or- The server referenced by the ExternalResourceReference cannot support CAD links. -or- The ExternalResourceReference (resourceReference) is not in a format that is supported by its server.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
OptionalFunctionalityNotAvailableException | The 3DM Import/Link module is not available in the installed Revit.
Remarks

This function creates a new 3DM link type as well as a new instance of this 3DM link type. The new instance of 3DM link type is returned by this function and the element id of the new 3DM link type is contained in the LinkLoadResult.

If the given external resource reference of the 3DM link is already used by an existing 3DM link type, a new instance of this existing 3DM link type is created and returned. The element id of the existing 3DM link type is contained in the LinkLoadResult.

This function regenerates the input document.

See Also

Reference

ImportInstance Class
Create Overload


ImportInstance.Create(Document, View, ExternalResourceReference, OBJImportOptions, LinkLoadResult) Method

ImportInstanceCreate(Document, View, ExternalResourceReference, OBJImportOptions, LinkLoadResult) Method

Creates a new instance of OBJ link type from an external resource reference and loads the linked file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ImportInstance Create(
    Document document,
    View DBView,
    ExternalResourceReference resourceReference,
    OBJImportOptions options,
    out LinkLoadResult linkLoadResult
)
Public Shared Function Create (
    document As Document,
    DBView As View,
    resourceReference As ExternalResourceReference,
    options As OBJImportOptions,
    <OutAttribute> ByRef linkLoadResult As LinkLoadResult
) As ImportInstance
public:
static ImportInstance^ Create(
    Document^ document,
    View^ DBView,
    ExternalResourceReference^ resourceReference,
    OBJImportOptions^ options,
    [OutAttribute] LinkLoadResult^% linkLoadResult
)
static member Create :
        document : Document *
        DBView : View *
        resourceReference : ExternalResourceReference *
        options : OBJImportOptions *
        linkLoadResult : LinkLoadResult byref -> ImportInstance

Parameters

document Document
The document in which to create the OBJ link.
DBView View
The view into which the OBJ link will be created.
resourceReference ExternalResourceReference
The external resource reference describing the source of the OBJ link.
options OBJImportOptions
Various import options applicable to the OBJ format. If , all options will be set to their respective default values.
linkLoadResult LinkLoadResult
An object containing the results of creating and loading the OBJ link. It contains the ElementId of the new created OBJ link type.

Return Value

ImportInstance
The new instance of OBJ link type created.
Exceptions
Exception | Condition
ArgumentException | document is not a project document. -or- document is in an edit mode. -or- Import is temporarily disabled. -or- The view is not printable. -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view. -or- One or more strings describing layer selection is invalid or empty. -or- The scale is not valid as a CustomScale for use during import. -or- The server referenced by the ExternalResourceReference does not exist or does not implement IExternalResourceServer. -or- The server referenced by the ExternalResourceReference cannot support CAD links. -or- The ExternalResourceReference (resourceReference) is not in a format that is supported by its server.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
OptionalFunctionalityNotAvailableException | The OBJ Import/Link module is not available in the installed Revit.
Remarks

This function creates a new OBJ link type as well as a new instance of this OBJ link type. The new instance of OBJ link type is returned by this function and the element id of the new OBJ link type is contained in the LinkLoadResult.

If the given external resource reference of the OBJ link is already used by an existing OBJ link type, a new instance of this existing OBJ link type is created and returned. The element id of the existing OBJ link type is contained in the LinkLoadResult.

This function regenerates the input document.

See Also

Reference

ImportInstance Class
Create Overload


ImportInstance.Create(Document, View, ExternalResourceReference, SATImportOptions, LinkLoadResult) Method

ImportInstanceCreate(Document, View, ExternalResourceReference, SATImportOptions, LinkLoadResult) Method

Creates a new instance of SAT link type from an external resource reference and loads the linked file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ImportInstance Create(
    Document document,
    View DBView,
    ExternalResourceReference resourceReference,
    SATImportOptions options,
    out LinkLoadResult linkLoadResult
)
Public Shared Function Create (
    document As Document,
    DBView As View,
    resourceReference As ExternalResourceReference,
    options As SATImportOptions,
    <OutAttribute> ByRef linkLoadResult As LinkLoadResult
) As ImportInstance
public:
static ImportInstance^ Create(
    Document^ document,
    View^ DBView,
    ExternalResourceReference^ resourceReference,
    SATImportOptions^ options,
    [OutAttribute] LinkLoadResult^% linkLoadResult
)
static member Create :
        document : Document *
        DBView : View *
        resourceReference : ExternalResourceReference *
        options : SATImportOptions *
        linkLoadResult : LinkLoadResult byref -> ImportInstance

Parameters

document Document
The document in which to create the SAT link.
DBView View
The view into which the SAT link will be created.
resourceReference ExternalResourceReference
The external resource reference describing the source of the DGN link.
options SATImportOptions
Various import options applicable to the SAT format. If , all options will be set to their respective default values.
linkLoadResult LinkLoadResult
An object containing the results of creating and loading the SAT link. It contains the ElementId of the new created SAT link type.

Return Value

ImportInstance
The new instance of SAT link type created.
Exceptions
Exception | Condition
ArgumentException | document is not a project document. -or- document is in an edit mode. -or- Import is temporarily disabled. -or- The view is not printable. -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view. -or- One or more strings describing layer selection is invalid or empty. -or- The scale is not valid as a CustomScale for use during import. -or- The server referenced by the ExternalResourceReference does not exist or does not implement IExternalResourceServer. -or- The server referenced by the ExternalResourceReference cannot support CAD links. -or- The ExternalResourceReference (resourceReference) is not in a format that is supported by its server.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
OptionalFunctionalityNotAvailableException | The SAT Import/Link module is not available in the installed Revit.
Remarks

This function creates a new SAT link type as well as a new instance of this SAT link type. The new instance of SAT link type is returned by this function and the element id of the new SAT link type is contained in the LinkLoadResult.

If the given external resource reference of the DWG link is already used by an existing SAT link type, a new instance of this existing SAT link type is created and returned. The element id of the existing SAT link type is contained in the LinkLoadResult.

This function regenerates the input document.

See Also

Reference

ImportInstance Class
Create Overload


ImportInstance.Create(Document, View, ExternalResourceReference, SKPImportOptions, LinkLoadResult) Method

ImportInstanceCreate(Document, View, ExternalResourceReference, SKPImportOptions, LinkLoadResult) Method

Creates a new instance of SKP link type from an external resource reference and loads the linked file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ImportInstance Create(
    Document document,
    View DBView,
    ExternalResourceReference resourceReference,
    SKPImportOptions options,
    out LinkLoadResult linkLoadResult
)
Public Shared Function Create (
    document As Document,
    DBView As View,
    resourceReference As ExternalResourceReference,
    options As SKPImportOptions,
    <OutAttribute> ByRef linkLoadResult As LinkLoadResult
) As ImportInstance
public:
static ImportInstance^ Create(
    Document^ document,
    View^ DBView,
    ExternalResourceReference^ resourceReference,
    SKPImportOptions^ options,
    [OutAttribute] LinkLoadResult^% linkLoadResult
)
static member Create :
        document : Document *
        DBView : View *
        resourceReference : ExternalResourceReference *
        options : SKPImportOptions *
        linkLoadResult : LinkLoadResult byref -> ImportInstance

Parameters

document Document
The document in which to create the SKP link.
DBView View
The view into which the SKP link will be created.
resourceReference ExternalResourceReference
The external resource reference describing the source of the SKP link.
options SKPImportOptions
Various import options applicable to the SKP format. If , all options will be set to their respective default values.
linkLoadResult LinkLoadResult
An object containing the results of creating and loading the SKP link. It contains the ElementId of the new created SKP link type.

Return Value

ImportInstance
The new instance of SKP link type created.
Exceptions
Exception | Condition
ArgumentException | document is not a project document. -or- document is in an edit mode. -or- Import is temporarily disabled. -or- The view is not printable. -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view. -or- One or more strings describing layer selection is invalid or empty. -or- The scale is not valid as a CustomScale for use during import. -or- The server referenced by the ExternalResourceReference does not exist or does not implement IExternalResourceServer. -or- The server referenced by the ExternalResourceReference cannot support CAD links. -or- The ExternalResourceReference (resourceReference) is not in a format that is supported by its server.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
OptionalFunctionalityNotAvailableException | The SKP Import/Link module is not available in the installed Revit.
Remarks

This function creates a new SKP link type as well as a new instance of this SKP link type. The new instance of SKP link type is returned by this function and the element id of the new SKP link type is contained in the LinkLoadResult.

If the given external resource reference of the SKP link is already used by an existing SKP link type, a new instance of this existing SKP link type is created and returned. The element id of the existing SKP link type is contained in the LinkLoadResult.

This function regenerates the input document.

See Also

Reference

ImportInstance Class
Create Overload


ImportInstance.Create(Document, View, ExternalResourceReference, STEPImportOptions, LinkLoadResult) Method

ImportInstanceCreate(Document, View, ExternalResourceReference, STEPImportOptions, LinkLoadResult) Method

Creates a new instance of STEP link type from an external resource reference and loads the linked file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ImportInstance Create(
    Document document,
    View DBView,
    ExternalResourceReference resourceReference,
    STEPImportOptions options,
    out LinkLoadResult linkLoadResult
)
Public Shared Function Create (
    document As Document,
    DBView As View,
    resourceReference As ExternalResourceReference,
    options As STEPImportOptions,
    <OutAttribute> ByRef linkLoadResult As LinkLoadResult
) As ImportInstance
public:
static ImportInstance^ Create(
    Document^ document,
    View^ DBView,
    ExternalResourceReference^ resourceReference,
    STEPImportOptions^ options,
    [OutAttribute] LinkLoadResult^% linkLoadResult
)
static member Create :
        document : Document *
        DBView : View *
        resourceReference : ExternalResourceReference *
        options : STEPImportOptions *
        linkLoadResult : LinkLoadResult byref -> ImportInstance

Parameters

document Document
The document in which to create the STEP link.
DBView View
The view into which the STEP link will be created.
resourceReference ExternalResourceReference
The external resource reference describing the source of the STEP link.
options STEPImportOptions
Various import options applicable to the STEP format. If , all options will be set to their respective default values.
linkLoadResult LinkLoadResult
An object containing the results of creating and loading the STEP link. It contains the ElementId of the new created STEP link type.

Return Value

ImportInstance
The new instance of STEP link type created.
Exceptions
Exception | Condition
ArgumentException | document is not a project document. -or- document is in an edit mode. -or- Import is temporarily disabled. -or- The view is not printable. -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view. -or- One or more strings describing layer selection is invalid or empty. -or- The scale is not valid as a CustomScale for use during import. -or- The server referenced by the ExternalResourceReference does not exist or does not implement IExternalResourceServer. -or- The server referenced by the ExternalResourceReference cannot support CAD links. -or- The ExternalResourceReference (resourceReference) is not in a format that is supported by its server.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
OptionalFunctionalityNotAvailableException | The STEP Import/Link module is not available in the installed Revit.
Remarks

This function creates a new STEP link type as well as a new instance of this STEP link type. The new instance of STEP link type is returned by this function and the element id of the new STEP link type is contained in the LinkLoadResult.

If the given external resource reference of the STEP link is already used by an existing STEP link type, a new instance of this existing STEP link type is created and returned. The element id of the existing STEP link type is contained in the LinkLoadResult.

This function regenerates the input document.

See Also

Reference

ImportInstance Class
Create Overload


ImportInstance.Create(Document, View, ExternalResourceReference, STLImportOptions, LinkLoadResult) Method

ImportInstanceCreate(Document, View, ExternalResourceReference, STLImportOptions, LinkLoadResult) Method

Creates a new instance of STL link type from an external resource reference and loads the linked file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ImportInstance Create(
    Document document,
    View DBView,
    ExternalResourceReference resourceReference,
    STLImportOptions options,
    out LinkLoadResult linkLoadResult
)
Public Shared Function Create (
    document As Document,
    DBView As View,
    resourceReference As ExternalResourceReference,
    options As STLImportOptions,
    <OutAttribute> ByRef linkLoadResult As LinkLoadResult
) As ImportInstance
public:
static ImportInstance^ Create(
    Document^ document,
    View^ DBView,
    ExternalResourceReference^ resourceReference,
    STLImportOptions^ options,
    [OutAttribute] LinkLoadResult^% linkLoadResult
)
static member Create :
        document : Document *
        DBView : View *
        resourceReference : ExternalResourceReference *
        options : STLImportOptions *
        linkLoadResult : LinkLoadResult byref -> ImportInstance

Parameters

document Document
The document in which to create the STL link.
DBView View
The view into which the STL link will be created.
resourceReference ExternalResourceReference
The external resource reference describing the source of the STL link.
options STLImportOptions
Various import options applicable to the STL format. If , all options will be set to their respective default values.
linkLoadResult LinkLoadResult
An object containing the results of creating and loading the STL link. It contains the ElementId of the new created STL link type.

Return Value

ImportInstance
The new instance of STL link type created.
Exceptions
Exception | Condition
ArgumentException | document is not a project document. -or- document is in an edit mode. -or- Import is temporarily disabled. -or- The view is not printable. -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view. -or- One or more strings describing layer selection is invalid or empty. -or- The scale is not valid as a CustomScale for use during import. -or- The server referenced by the ExternalResourceReference does not exist or does not implement IExternalResourceServer. -or- The server referenced by the ExternalResourceReference cannot support CAD links. -or- The ExternalResourceReference (resourceReference) is not in a format that is supported by its server.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
OptionalFunctionalityNotAvailableException | The STL Import/Link module is not available in the installed Revit.
Remarks

This function creates a new STL link type as well as a new instance of this STL link type. The new instance of STL link type is returned by this function and the element id of the new STL link type is contained in the LinkLoadResult.

If the given external resource reference of the STL link is already used by an existing STL link type, a new instance of this existing STL link type is created and returned. The element id of the existing STL link type is contained in the LinkLoadResult.

This function regenerates the input document.

See Also

Reference

ImportInstance Class
Create Overload


ImportInstance.Create(Document, View, String, DWGImportOptions, LinkLoadResult) Method

ImportInstanceCreate(Document, View, String, DWGImportOptions, LinkLoadResult) Method

Creates a new instance of DWG or DXF link type from a file path and loads the linked file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ImportInstance Create(
    Document document,
    View DBView,
    string path,
    DWGImportOptions options,
    out LinkLoadResult linkLoadResult
)
Public Shared Function Create (
    document As Document,
    DBView As View,
    path As String,
    options As DWGImportOptions,
    <OutAttribute> ByRef linkLoadResult As LinkLoadResult
) As ImportInstance
public:
static ImportInstance^ Create(
    Document^ document,
    View^ DBView,
    String^ path,
    DWGImportOptions^ options,
    [OutAttribute] LinkLoadResult^% linkLoadResult
)
static member Create :
        document : Document *
        DBView : View *
        path : string *
        options : DWGImportOptions *
        linkLoadResult : LinkLoadResult byref -> ImportInstance

Parameters

document Document
The document in which to create the DWG or DXF link.
DBView View
The view into which the DWG or DXF link will be created.
path String
The full path of the DWG or DXF file to link. The path must exist and must be a valid DWG or DXF file.
options DWGImportOptions
Various import options applicable to the DWG format. If , all options will be set to their respective default values.
linkLoadResult LinkLoadResult
An object containing the results of creating and loading the DWG or DXF link. It contains the ElementId of the new created DWG or DXF link type.

Return Value

ImportInstance
The new instance of DWG or DXF link type.
Exceptions
Exception | Condition
ArgumentException | document is not a project document. -or- document is in an edit mode. -or- Import is temporarily disabled. -or- The view is not printable. -or- NullOrEmpty -or- Not a valid file for DWG import (.dwg and .dxf files are valid). -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view. -or- One or more strings describing layer selection is invalid or empty. -or- The line weights are not valid; either it contains an invalid number of line weights, or a line weight outside the valid range. -or- The scale is not valid as a CustomScale for use during import.
ArgumentNullException | A non-optional argument was null
FileArgumentNotFoundException | The given path does not exist.
InvalidOperationException | Place by shared, and the host model and the link do not share the same coordinate system. Or place by shared, and the shared coordinates of the host model do not match the GIS coordinate system of the link.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
OptionalFunctionalityNotAvailableException | The DWG Import/Link module is not available in the installed Revit.
Remarks

This function creates a new DWG or DXF link type as well as a new instance of this link type. The new instance of DWG or DXF link type is returned by this function and the element id of the new DWG or DXF link type is contained in the LinkLoadResult.

If the given full path of the DWG or DXF file to link is already used by an existing DWG or DXF link type, a new instance of this existing DWG or DXF link type will be created and returned. The element id of the existing DWG or DXF link type is contained in the LinkLoadResult.

This function regenerates the input document.

See Also

Reference

ImportInstance Class
Create Overload


ImportInstance.GetVisibility Method

ImportInstanceGetVisibility Method

Gets the visibility for the import instance in a family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyElementVisibility GetVisibility()
Public Function GetVisibility As FamilyElementVisibility
public:
FamilyElementVisibility^ GetVisibility()
member GetVisibility : unit -> FamilyElementVisibility

Return Value

FamilyElementVisibility
A copy of visibility settings for the import instance in a family document.
See Also

Reference

ImportInstance Class


ImportInstance.SetVisibility Method

ImportInstanceSetVisibility Method

Sets the visibility for the import instance in a family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetVisibility(
    FamilyElementVisibility visibility
)
Public Sub SetVisibility (
    visibility As FamilyElementVisibility
)
public:
void SetVisibility(
    FamilyElementVisibility^ visibility
)
member SetVisibility :
        visibility : FamilyElementVisibility -> unit

Parameters

visibility FamilyElementVisibility
Exceptions
Exception | Condition
ArgumentNullException | Thrown when visibility is .
InvalidOperationException | Thrown when regeneration failed, or the import instance is in a project document.
Remarks
The visibility of the import instance geometry can be changed for different types of views and detail levels in the family document.
See Also

Reference

ImportInstance Class


ImportOptions3DM Class

The import options used to import 3DM format files.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBaseImportOptions
Autodesk.Revit.DBImportOptions3DM

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ImportOptions3DM : BaseImportOptions
Public Class ImportOptions3DM
    Inherits BaseImportOptions
public ref class ImportOptions3DM : public BaseImportOptions
type ImportOptions3DM =
    class
        inherit BaseImportOptions
    end

The ImportOptions3DM type exposes the following members.

Constructors
 | Name | Description
Public method | ImportOptions3DM | Constructs a new instance of ImportOptions3DM with default values of all properties.
Public method | ImportOptions3DM(ImportOptions3DM) | Constructs a new instance of ImportOptions3DM as a copy of the provided import options.
Top
Properties
 | Name | Description
Public property | AutoCorrectAlmostVHLines | Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines. (Inherited from BaseImportOptions)
Public property | ColorMode | Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors. (Inherited from BaseImportOptions)
Public property | CustomScale | Scaling the import. If this is defined and a valid value (> 0.0), it takes priority over units. (Inherited from BaseImportOptions)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BaseImportOptions)
Public property | OrientToView | Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false) (Inherited from BaseImportOptions)
Public property | Placement | Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates. (Inherited from BaseImportOptions)
Public property | ReferencePoint | The 3D point in the document where the imported instance will be inserted. If not explicitly set, the instance will be inserted at the document origin. (Inherited from BaseImportOptions)
Public property | ThisViewOnly | Imports drawings into the view that was passed into the import method. This option is not available in 3D views. (Inherited from BaseImportOptions)
Public property | Unit | The unit of measure for imported geometry. (Inherited from BaseImportOptions)
Public property | VisibleLayersOnly | Only import the visible layers. (Inherited from BaseImportOptions)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from BaseImportOptions)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetDefaultLengthUnit | Get the default length unit used for importing unitless files. (Inherited from BaseImportOptions)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLayerSelection | Get all set layers name which user want to import into Revit. (Inherited from BaseImportOptions)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetDefaultLengthUnit | Set the default length unit used for importing unitless files. (Inherited from BaseImportOptions)
Public method | SetLayerSelection | Set the layers name which user want to import into Revit. (Inherited from BaseImportOptions)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ImportOptions3DM Constructor

Overload List
 | Name | Description
Public method | ImportOptions3DM | Constructs a new instance of ImportOptions3DM with default values of all properties.
Public method | ImportOptions3DM(ImportOptions3DM) | Constructs a new instance of ImportOptions3DM as a copy of the provided import options.
Top
See Also

Reference

ImportOptions3DM Class


ImportOptions3DM Constructor

Constructs a new instance of ImportOptions3DM with default values of all properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImportOptions3DM()
Public Sub New
public:
ImportOptions3DM()
new : unit -> ImportOptions3DM
See Also

Reference

ImportOptions3DM Class
ImportOptions3DM Overload


ImportOptions3DM(ImportOptions3DM) Constructor

Constructs a new instance of ImportOptions3DM as a copy of the provided import options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImportOptions3DM(
    ImportOptions3DM option
)
Public Sub New (
    option As ImportOptions3DM
)
public:
ImportOptions3DM(
    ImportOptions3DM^ option
)
new :
        option : ImportOptions3DM -> ImportOptions3DM

Parameters

option ImportOptions3DM
The 3DM import options to be copied.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ImportOptions3DM Class
ImportOptions3DM Overload


ImportOptions3DM Properties

The ImportOptions3DM type exposes the following members.

Properties
 | Name | Description
Public property | AutoCorrectAlmostVHLines | Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines. (Inherited from BaseImportOptions)
Public property | ColorMode | Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors. (Inherited from BaseImportOptions)
Public property | CustomScale | Scaling the import. If this is defined and a valid value (> 0.0), it takes priority over units. (Inherited from BaseImportOptions)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BaseImportOptions)
Public property | OrientToView | Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false) (Inherited from BaseImportOptions)
Public property | Placement | Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates. (Inherited from BaseImportOptions)
Public property | ReferencePoint | The 3D point in the document where the imported instance will be inserted. If not explicitly set, the instance will be inserted at the document origin. (Inherited from BaseImportOptions)
Public property | ThisViewOnly | Imports drawings into the view that was passed into the import method. This option is not available in 3D views. (Inherited from BaseImportOptions)
Public property | Unit | The unit of measure for imported geometry. (Inherited from BaseImportOptions)
Public property | VisibleLayersOnly | Only import the visible layers. (Inherited from BaseImportOptions)
Top
See Also

Reference

ImportOptions3DM Class


ImportOptions3DM Methods

The ImportOptions3DM type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from BaseImportOptions)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetDefaultLengthUnit | Get the default length unit used for importing unitless files. (Inherited from BaseImportOptions)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLayerSelection | Get all set layers name which user want to import into Revit. (Inherited from BaseImportOptions)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetDefaultLengthUnit | Set the default length unit used for importing unitless files. (Inherited from BaseImportOptions)
Public method | SetLayerSelection | Set the layers name which user want to import into Revit. (Inherited from BaseImportOptions)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ImportOptions3DM Class


ImportPlacement Enumeration

An enumerated type listing possible placement modes for imported drawings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ImportPlacement
Public Enumeration ImportPlacement
public enum class ImportPlacement
type ImportPlacement
Members
Member name | Value | Description
Site | 0 | Placement at Base Point. Useful for Revit links only. There must be a reference point in order for this option to be valid.
Origin | 1 | Placement at the Origin. If reference point is provided, then the import is placed so the point is at the model's origin. If no point is provided, then the document's origin is matched with the model's origin.
Centered | 2 | Placement at the Center. If reference point is provided, then the import is placed so the point is at the model's center. If no point is provided, then the document's center is matched with the model's origin.
Shared | 3 | Placement with respect to the shared coordinates. Revit Building places the imported geometry according to its location with respect to the shared coordinates between the two files. There must be shared coordinates in a Revit document in order for this option to be valid.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ImportUnit Enumeration

An enumerated type listing possible target units for CAD Import.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ImportUnit
Public Enumeration ImportUnit
public enum class ImportUnit
type ImportUnit
Members
Member name | Value | Description
Default | 0 | Unit (if available) from the document that is getting imported.
Foot | 1 | Feet and Inches in fractional notation.
Inch | 2 | Inches in fractional notation.
Meter | 3 | Meters as decimal values.
Decimeter | 4 | Decimeters as decimal values.
Centimeter | 5 | Centimeters as decimal values.
Millimeter | 6 | Millimeters as decimal values.
Custom | 7 | Custom values as decimal values
USSurveyFoot | 8 | US survey feet as decimal values
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


INavisworksExporter Interface

The interface used to implement a Navisworks exporter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface INavisworksExporter : IExternalServer
Public Interface INavisworksExporter
    Inherits IExternalServer
public interface class INavisworksExporter : IExternalServer
type INavisworksExporter =
    interface
        interface IExternalServer
    end

The INavisworksExporter type exposes the following members.

Methods
 | Name | Description
Public method | Export | The method that Revit will invoke to perform an export to Navisworks.
Public method | GetDescription | Implement this method to return a description of the server. (Inherited from IExternalServer)
Public method | GetName | Implement this method to return the name of the server. (Inherited from IExternalServer)
Public method | GetServerId | Implement this method to return the id of the server. (Inherited from IExternalServer)
Public method | GetServiceId | Implement this method to return the id of the service. (Inherited from IExternalServer)
Public method | GetVendorId | Implement this method to return the id of the vendor of the server. (Inherited from IExternalServer)
Public method | ValidateExportOptions | Determines if the inputs are valid, and returns an error message if not.
Top
Remarks
Implement this interface and register an instance of the derived class with the Navisworks external service.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


INavisworksExporter Methods

The INavisworksExporter type exposes the following members.

Methods
 | Name | Description
Public method | Export | The method that Revit will invoke to perform an export to Navisworks.
Public method | GetDescription | Implement this method to return a description of the server. (Inherited from IExternalServer)
Public method | GetName | Implement this method to return the name of the server. (Inherited from IExternalServer)
Public method | GetServerId | Implement this method to return the id of the server. (Inherited from IExternalServer)
Public method | GetServiceId | Implement this method to return the id of the service. (Inherited from IExternalServer)
Public method | GetVendorId | Implement this method to return the id of the vendor of the server. (Inherited from IExternalServer)
Public method | ValidateExportOptions | Determines if the inputs are valid, and returns an error message if not.
Top
See Also

Reference

INavisworksExporter Interface


INavisworksExporter.Export Method

INavisworksExporterExport Method

The method that Revit will invoke to perform an export to Navisworks.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Export(
    Document document,
    string folder,
    string name,
    NavisworksExportOptions options
)
Sub Export (
    document As Document,
    folder As String,
    name As String,
    options As NavisworksExportOptions
)
void Export(
    Document^ document,
    String^ folder,
    String^ name,
    NavisworksExportOptions^ options
)
abstract Export :
        document : Document *
        folder : string *
        name : string *
        options : NavisworksExportOptions -> unit

Parameters

document Document
The document to export.
folder String
The folder path.
name String
The file name.
options NavisworksExportOptions
The export options.
See Also

Reference

INavisworksExporter Interface


INavisworksExporter.ValidateExportOptions Method

INavisworksExporterValidateExportOptions Method

Determines if the inputs are valid, and returns an error message if not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool ValidateExportOptions(
    Document document,
    string folder,
    string name,
    NavisworksExportOptions options,
    out string exceptionMessage
)
Function ValidateExportOptions (
    document As Document,
    folder As String,
    name As String,
    options As NavisworksExportOptions,
    <OutAttribute> ByRef exceptionMessage As String
) As Boolean
bool ValidateExportOptions(
    Document^ document,
    String^ folder,
    String^ name,
    NavisworksExportOptions^ options,
    [OutAttribute] String^% exceptionMessage
)
abstract ValidateExportOptions :
        document : Document *
        folder : string *
        name : string *
        options : NavisworksExportOptions *
        exceptionMessage : string byref -> bool

Parameters

document Document
The document to export.
folder String
The folder path.
name String
The file name.
options NavisworksExportOptions
The export options.
exceptionMessage String
The message to show in the exception thrown. This is not an end-user visible message, it is a developer message, and does not have to be localized. Ignored if the function returns true.

Return Value

Boolean
True if the options are valid, false otherwise.
See Also

Reference

INavisworksExporter Interface


InCanvasControlData Class

Represents a collection of data which is used by [!:Autodesk::Revit::DB::TemporaryGraphicsManager] to create and update an in-canvas control.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBInCanvasControlData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class InCanvasControlData : IDisposable
Public Class InCanvasControlData
    Implements IDisposable
public ref class InCanvasControlData : IDisposable
type InCanvasControlData =
    class
        interface IDisposable
    end

The InCanvasControlData type exposes the following members.

Constructors
 | Name | Description
Public method | InCanvasControlData(String) | Constructs an InCanvasControlData with specific values assigned.
Public method | InCanvasControlData(String, XYZ) | Constructs an InCanvasControlData with specific values assigned.
Top
Properties
 | Name | Description
Public property | ImagePath | The path to the image file to be used. This must be an absolute path to a location on disk.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Position | The position of the in-canvas control in model coordinates.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the InCanvasControlData
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

So far, only bitmap file is supported for ImagePath. The rendered image is the same size in pixel dimensions as the original one. To get a better result, the caller should prepare the image with proper size, for exmaple: 32x32 or 64x64 in pixels, before use. To achive a "transparent" backgound color effect over the provided bitmap, the bitmap should use color RGB(0, 128, 128) as its background and it will be cleared during rendering by Revit.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


InCanvasControlData Constructor

Overload List
 | Name | Description
Public method | InCanvasControlData(String) | Constructs an InCanvasControlData with specific values assigned.
Public method | InCanvasControlData(String, XYZ) | Constructs an InCanvasControlData with specific values assigned.
Top
See Also

Reference

InCanvasControlData Class


InCanvasControlData(String) Constructor

Constructs an InCanvasControlData with specific values assigned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public InCanvasControlData(
    string imagePath
)
Public Sub New (
    imagePath As String
)
public:
InCanvasControlData(
    String^ imagePath
)
new :
        imagePath : string -> InCanvasControlData

Parameters

imagePath String
File path with the image to be used. This must be an absolute path to a location on disk.
Exceptions
Exception | Condition
ArgumentException | The file format specified by imagePath is an unsupported format - only *.bmp files are supported. -or- The file path specified by imagePath is not absolute.
ArgumentNullException | A non-optional argument was null
FileArgumentNotFoundException | The file specified by imagePath doesn't exist.
See Also

Reference

InCanvasControlData Class
InCanvasControlData Overload


InCanvasControlData(String, XYZ) Constructor

Constructs an InCanvasControlData with specific values assigned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public InCanvasControlData(
    string imagePath,
    XYZ position
)
Public Sub New (
    imagePath As String,
    position As XYZ
)
public:
InCanvasControlData(
    String^ imagePath,
    XYZ^ position
)
new :
        imagePath : string *
        position : XYZ -> InCanvasControlData

Parameters

imagePath String
File path with the image to be used. This must be an absolute path to a location on disk.
position XYZ
The position to be used.
Exceptions
Exception | Condition
ArgumentException | The file format specified by imagePath is an unsupported format - only *.bmp files are supported. -or- The file path specified by imagePath is not absolute.
ArgumentNullException | A non-optional argument was null
FileArgumentNotFoundException | The file specified by imagePath doesn't exist.
See Also

Reference

InCanvasControlData Class
InCanvasControlData Overload


InCanvasControlData Properties

The InCanvasControlData type exposes the following members.

Properties
 | Name | Description
Public property | ImagePath | The path to the image file to be used. This must be an absolute path to a location on disk.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Position | The position of the in-canvas control in model coordinates.
Top
See Also

Reference

InCanvasControlData Class


InCanvasControlData.ImagePath Property

InCanvasControlDataImagePath Property

The path to the image file to be used. This must be an absolute path to a location on disk.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ImagePath { get; set; }
Public Property ImagePath As String
    Get
    Set
public:
property String^ ImagePath {
    String^ get ();
    void set (String^ value);
}
member ImagePath : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentException | When setting this property: The file format specified by imagePath is an unsupported format - only *.bmp files are supported. -or- When setting this property: The file path specified by imagePath is not absolute.
ArgumentNullException | When setting this property: A non-optional argument was null
FileArgumentNotFoundException | When setting this property: The file specified by imagePath doesn't exist.
See Also

Reference

InCanvasControlData Class


InCanvasControlData.IsValidObject Property

InCanvasControlDataIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

InCanvasControlData Class


InCanvasControlData.Position Property

InCanvasControlDataPosition Property

The position of the in-canvas control in model coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Position { get; set; }
Public Property Position As XYZ
    Get
    Set
public:
property XYZ^ Position {
    XYZ^ get ();
    void set (XYZ^ value);
}
member Position : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

InCanvasControlData Class


InCanvasControlData Methods

The InCanvasControlData type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

InCanvasControlData Class


InCanvasControlData.Dispose Method

InCanvasControlDataDispose Method

Releases all resources used by the InCanvasControlData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

InCanvasControlData Class


IndependentTag Class

Represents tag annotations in Revit. getBBoxCorers in MultipleAlignmentHelper needs access to some protected members.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBIndependentTag
Autodesk.Revit.DBSpanDirectionSymbol
Autodesk.Revit.DB.StructureFabricReinSpanSymbol
Autodesk.Revit.DB.StructurePathReinSpanSymbol
Autodesk.Revit.DB.StructureRebarSystemSpanSymbol

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class IndependentTag : Element
Public Class IndependentTag
    Inherits Element
public ref class IndependentTag : public Element
type IndependentTag =
    class
        inherit Element
    end

The IndependentTag type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HasLeader | Identifies if a tag has at least one visible leader, or if all leaders are hidden.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsMaterialTag | Identifies if it is a material tag or not.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsMulticategoryTag | Identifies if it is a multi-category tag or not.
Public property | IsOrphaned | Identifies if the tag is orphaned or not.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LeaderEndCondition | The leader end condition of the tag, such as if the end of the leader is attached to the host or free floating.
Public property | LeadersPresentationMode | Identifies the Presentation Mode that is applied to tag leaders.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | MergeElbows | Identifies if the leaders' elbows are merged or not. If they are are merged, all elbows are in the same point and they move together.
Public property | MultiLeader | Returns if the tag if referencing multiple elements and/or sub-elements.
Public property | MultiReferenceAnnotationId | The multi-reference annotation which owns this tag.
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | RotationAngle | The rotation angle of the tag relative to its view
Public property | TagHeadPosition | The position of the head of tag in model coordinates.
Public property | TagOrientation | The tag orientation of the tag's head, such as horizontal or vertical.
Public property | TagText | The text associated with the tag. If there are several strings assiciated with the tag, the strings will be returned concatenated.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | AddReferences | Adds the provided list of references to the tag's list of references.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | CanLeaderEndConditionBeAssigned | Checks whether the LeaderEndCondition can be changed.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create(Document, ElementId, ElementId, Reference, Boolean, TagOrientation, XYZ) | Places a tag on an element or subelement.
 | Create(Document, ElementId, Reference, Boolean, TagMode, TagOrientation, XYZ) | Places a tag on an element or subelement.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLeaderElbow | Returns the position of the elbow of the tag's leader that points to specified reference. Position of leader's elbow.
Public method | GetLeaderEnd | Returns the end position of the tag's leader that points to specified reference.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTaggedElementIds | Returns a set of LinkElementId for all tagged elements, if any. A LinkElementId will be provided for each subelement that is being referenced by the tag.
Public method | GetTaggedLocalElementIds | Returns a set of IDs for all tagged local elements, if any. A local element ID will be provided for each subelement that is being referenced by the tag. Set of all the element ids in the local file. For each subelement a local element id will be provided.
Public method | GetTaggedLocalElements | Get the tagged local elements, if any. An Element will be provided for each subelement that is being referenced by the tag.
Public method | GetTaggedReferences | Get the host references of the tag. An array of all the tagged references.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasLeaderElbow | Whether the tag's leader that points to the reference has an elbow point or not.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasTagBehavior | Checks if the IndependentTag has a tag behavior.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsLeaderVisible | Returns if leader that points to specified reference is visible or not.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsTaggedOnSubelement | Returns true if the any of the tagged references is a subelement.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveReferences | Removes the provided list of references from the tag's list of references.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetIsLeaderVisible | Set tag's leader that points to specified reference to be visible or not. This option can be set only if the LeadersPresentationMode is ShowSpecificLeaders.
Public method | SetLeaderElbow | Set the position of the elbow of the tag's leader that points to specified reference. If this tag is a multileader tag and the elbows are merged, the input position will be set to all leaders.
Public method | SetLeaderEnd | Set the end position of the tag's leader that points to specified reference.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
IndependentTag represents single-category tags, multi-category tags, material tags, and zone tags. IndependentTag is also the base class for other annotations like keynote tags and span symbols. Room, area and space tags are not derived from IndependentTag. [!:Autodesk::Revit::DB::SpatialElementTag] for more information.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


IndependentTag Properties

The IndependentTag type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HasLeader | Identifies if a tag has at least one visible leader, or if all leaders are hidden.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsMaterialTag | Identifies if it is a material tag or not.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsMulticategoryTag | Identifies if it is a multi-category tag or not.
Public property | IsOrphaned | Identifies if the tag is orphaned or not.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LeaderEndCondition | The leader end condition of the tag, such as if the end of the leader is attached to the host or free floating.
Public property | LeadersPresentationMode | Identifies the Presentation Mode that is applied to tag leaders.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | MergeElbows | Identifies if the leaders' elbows are merged or not. If they are are merged, all elbows are in the same point and they move together.
Public property | MultiLeader | Returns if the tag if referencing multiple elements and/or sub-elements.
Public property | MultiReferenceAnnotationId | The multi-reference annotation which owns this tag.
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | RotationAngle | The rotation angle of the tag relative to its view
Public property | TagHeadPosition | The position of the head of tag in model coordinates.
Public property | TagOrientation | The tag orientation of the tag's head, such as horizontal or vertical.
Public property | TagText | The text associated with the tag. If there are several strings assiciated with the tag, the strings will be returned concatenated.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

IndependentTag Class


IndependentTag.HasLeader Property

IndependentTagHasLeader Property

Identifies if a tag has at least one visible leader, or if all leaders are hidden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasLeader { get; set; }
Public Property HasLeader As Boolean
    Get
    Set
public:
property bool HasLeader {
    bool get ();
    void set (bool value);
}
member HasLeader : bool with get, set

Property Value

Boolean
True if at least one leader is visible, false if all leaders are hidden. Setting the property to true, it will make all leaders visible.
Exceptions
Exception | Condition
InvalidOperationException | When setting this property: The IndependentTag object does not have a tag behavior. -or- When setting this property: For this tag leaders are not allowed.
See Also

Reference

IndependentTag Class


IndependentTag.IsMaterialTag Property

IndependentTagIsMaterialTag Property

Identifies if it is a material tag or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsMaterialTag { get; }
Public ReadOnly Property IsMaterialTag As Boolean
    Get
public:
property bool IsMaterialTag {
    bool get ();
}
member IsMaterialTag : bool with get

Property Value

Boolean
See Also

Reference

IndependentTag Class


IndependentTag.IsMulticategoryTag Property

IndependentTagIsMulticategoryTag Property

Identifies if it is a multi-category tag or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsMulticategoryTag { get; }
Public ReadOnly Property IsMulticategoryTag As Boolean
    Get
public:
property bool IsMulticategoryTag {
    bool get ();
}
member IsMulticategoryTag : bool with get

Property Value

Boolean
See Also

Reference

IndependentTag Class


IndependentTag.IsOrphaned Property

IndependentTagIsOrphaned Property

Identifies if the tag is orphaned or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsOrphaned { get; }
Public ReadOnly Property IsOrphaned As Boolean
    Get
public:
property bool IsOrphaned {
    bool get ();
}
member IsOrphaned : bool with get

Property Value

Boolean
Remarks
Orphaned tags are those tags that are associated with one or more linked host that is missing. Tags become orphaned when one or more associated linked host is missing from the link.
See Also

Reference

IndependentTag Class


IndependentTag.LeaderEndCondition Property

IndependentTagLeaderEndCondition Property

The leader end condition of the tag, such as if the end of the leader is attached to the host or free floating.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LeaderEndCondition LeaderEndCondition { get; set; }
Public Property LeaderEndCondition As LeaderEndCondition
    Get
    Set
public:
property LeaderEndCondition LeaderEndCondition {
    LeaderEndCondition get ();
    void set (LeaderEndCondition value);
}
member LeaderEndCondition : LeaderEndCondition with get, set

Property Value

LeaderEndCondition
Exceptions
Exception | Condition
ArgumentException | When setting this property: LeaderEndCondition cannot be assigned.
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | The IndependentTag object does not have a tag behavior. -or- When setting this property: For this tag leaders are not allowed.
Remarks
LeaderEndCondition enumerates the supported leader end conditions. Material tags and material keynotes can only use the free end condition.
See Also

Reference

IndependentTag Class


IndependentTag.LeadersPresentationMode Property

IndependentTagLeadersPresentationMode Property

Identifies the Presentation Mode that is applied to tag leaders.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LeadersPresentationMode LeadersPresentationMode { get; set; }
Public Property LeadersPresentationMode As LeadersPresentationMode
    Get
    Set
public:
property LeadersPresentationMode LeadersPresentationMode {
    LeadersPresentationMode get ();
    void set (LeadersPresentationMode value);
}
member LeadersPresentationMode : LeadersPresentationMode with get, set

Property Value

LeadersPresentationMode
Exceptions
Exception | Condition
ArgumentException | When setting this property: The LeadersPresentationMode LeadersPresentationMode.ShowOnlyOne or LeadersPresentationMode.ShowSpecificLeaders can't be set to a tag with only one leader.
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | The IndependentTag object does not have a tag behavior. -or- When setting this property: For this tag leaders are not allowed.
See Also

Reference

IndependentTag Class


IndependentTag.MergeElbows Property

IndependentTagMergeElbows Property

Identifies if the leaders' elbows are merged or not. If they are are merged, all elbows are in the same point and they move together.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool MergeElbows { get; set; }
Public Property MergeElbows As Boolean
    Get
    Set
public:
property bool MergeElbows {
    bool get ();
    void set (bool value);
}
member MergeElbows : bool with get, set

Property Value

Boolean
Exceptions
Exception | Condition
InvalidOperationException | The IndependentTag object does not have a tag behavior. -or- When setting this property: For this tag leaders are not allowed. -or- When setting this property: Can't merge elbows for tags that are part of a multi-reference annotation.
See Also

Reference

IndependentTag Class


IndependentTag.MultiLeader Property

IndependentTagMultiLeader Property

Returns if the tag if referencing multiple elements and/or sub-elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool MultiLeader { get; }
Public ReadOnly Property MultiLeader As Boolean
    Get
public:
property bool MultiLeader {
    bool get ();
}
member MultiLeader : bool with get

Property Value

Boolean
See Also

Reference

IndependentTag Class


IndependentTag.MultiReferenceAnnotationId Property

IndependentTagMultiReferenceAnnotationId Property

The multi-reference annotation which owns this tag.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId MultiReferenceAnnotationId { get; }
Public ReadOnly Property MultiReferenceAnnotationId As ElementId
    Get
public:
property ElementId^ MultiReferenceAnnotationId {
    ElementId^ get ();
}
member MultiReferenceAnnotationId : ElementId with get

Property Value

ElementId
Remarks
[!:Autodesk::Revit::DB::MultiReferenceAnnotation] for more information.
See Also

Reference

IndependentTag Class


IndependentTag.RotationAngle Property

IndependentTagRotationAngle Property

The rotation angle of the tag relative to its view

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double RotationAngle { get; set; }
Public Property RotationAngle As Double
    Get
    Set
public:
property double RotationAngle {
    double get ();
    void set (double value);
}
member RotationAngle : float with get, set

Property Value

Double
Exceptions
Exception | Condition
InvalidOperationException | When setting this property: Angle can only be changed for AnyModelDirection orientation
See Also

Reference

IndependentTag Class


IndependentTag.TagHeadPosition Property

IndependentTagTagHeadPosition Property

The position of the head of tag in model coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ TagHeadPosition { get; set; }
Public Property TagHeadPosition As XYZ
    Get
    Set
public:
property XYZ^ TagHeadPosition {
    XYZ^ get ();
    void set (XYZ^ value);
}
member TagHeadPosition : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
The depth of the tag head position in the view does not matter because tags are drawn over model geometry in the view.
See Also

Reference

IndependentTag Class


IndependentTag.TagOrientation Property

IndependentTagTagOrientation Property

The tag orientation of the tag's head, such as horizontal or vertical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TagOrientation TagOrientation { get; set; }
Public Property TagOrientation As TagOrientation
    Get
    Set
public:
property TagOrientation TagOrientation {
    TagOrientation get ();
    void set (TagOrientation value);
}
member TagOrientation : TagOrientation with get, set

Property Value

TagOrientation
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
TagOrientation for the supported orientations. Tags from types that have rotate with component turned on ignore the TagOrientation property. Tags that are not in tag mode ignores the TagOrientation property.
See Also

Reference

IndependentTag Class


IndependentTag.TagText Property

IndependentTagTagText Property

The text associated with the tag. If there are several strings assiciated with the tag, the strings will be returned concatenated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TagText { get; }
Public ReadOnly Property TagText As String
    Get
public:
property String^ TagText {
    String^ get ();
}
member TagText : string with get

Property Value

String
Exceptions
Exception | Condition
InvalidOperationException | The IndependentTag object does not have a tag behavior. -or- The tagging element is in the link.
See Also

Reference

IndependentTag Class


IndependentTag Methods

The IndependentTag type exposes the following members.

Methods
 | Name | Description
Public method | AddReferences | Adds the provided list of references to the tag's list of references.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | CanLeaderEndConditionBeAssigned | Checks whether the LeaderEndCondition can be changed.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create(Document, ElementId, ElementId, Reference, Boolean, TagOrientation, XYZ) | Places a tag on an element or subelement.
 | Create(Document, ElementId, Reference, Boolean, TagMode, TagOrientation, XYZ) | Places a tag on an element or subelement.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLeaderElbow | Returns the position of the elbow of the tag's leader that points to specified reference. Position of leader's elbow.
Public method | GetLeaderEnd | Returns the end position of the tag's leader that points to specified reference.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTaggedElementIds | Returns a set of LinkElementId for all tagged elements, if any. A LinkElementId will be provided for each subelement that is being referenced by the tag.
Public method | GetTaggedLocalElementIds | Returns a set of IDs for all tagged local elements, if any. A local element ID will be provided for each subelement that is being referenced by the tag. Set of all the element ids in the local file. For each subelement a local element id will be provided.
Public method | GetTaggedLocalElements | Get the tagged local elements, if any. An Element will be provided for each subelement that is being referenced by the tag.
Public method | GetTaggedReferences | Get the host references of the tag. An array of all the tagged references.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasLeaderElbow | Whether the tag's leader that points to the reference has an elbow point or not.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasTagBehavior | Checks if the IndependentTag has a tag behavior.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsLeaderVisible | Returns if leader that points to specified reference is visible or not.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsTaggedOnSubelement | Returns true if the any of the tagged references is a subelement.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveReferences | Removes the provided list of references from the tag's list of references.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetIsLeaderVisible | Set tag's leader that points to specified reference to be visible or not. This option can be set only if the LeadersPresentationMode is ShowSpecificLeaders.
Public method | SetLeaderElbow | Set the position of the elbow of the tag's leader that points to specified reference. If this tag is a multileader tag and the elbows are merged, the input position will be set to all leaders.
Public method | SetLeaderEnd | Set the end position of the tag's leader that points to specified reference.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

IndependentTag Class


IndependentTag.AddReferences Method

IndependentTagAddReferences Method

Adds the provided list of references to the tag's list of references.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddReferences(
    IList<Reference> referencesToTag
)
Public Sub AddReferences (
    referencesToTag As IList(Of Reference)
)
public:
void AddReferences(
    IList<Reference^>^ referencesToTag
)
member AddReferences :
        referencesToTag : IList<Reference> -> unit

Parameters

referencesToTag IList Reference
References to be tagged.
Exceptions
Exception | Condition
ArgumentException | The operation failed. Please verify that the references are all taggable and that they are not already tagged. -or- This type of tag does not support multiple references.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The IndependentTag object does not have a tag behavior. -or- Modifying tag references for MRA owned tag from API is not allowed.
Remarks

The references must pass the following requirements to be added:

  • Must not be owned by MRA element.
  • Must not be already tagged.
  • Must be of the same category when TagMode is TM_ADDBY_CATEGORY.
  • Must be taggable by this tag type.
  • For multiple references, the tag type must have this functionality supported in the UI.
If any of the above rules is not fulfilled, the execution will be stopped and an exception will be thrown

See Also

Reference

IndependentTag Class


IndependentTag.CanLeaderEndConditionBeAssigned Method

IndependentTagCanLeaderEndConditionBeAssigned Method

Checks whether the LeaderEndCondition can be changed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanLeaderEndConditionBeAssigned(
    LeaderEndCondition leaderEndCondition
)
Public Function CanLeaderEndConditionBeAssigned (
    leaderEndCondition As LeaderEndCondition
) As Boolean
public:
bool CanLeaderEndConditionBeAssigned(
    LeaderEndCondition leaderEndCondition
)
member CanLeaderEndConditionBeAssigned :
        leaderEndCondition : LeaderEndCondition -> bool

Parameters

leaderEndCondition LeaderEndCondition
The leader end condition to check.

Return Value

Boolean
True if the leader end condition of the tag can be assigned, or false otherwise.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Remarks
Material tags and material keynotes can only use the free end condition.
See Also

Reference

IndependentTag Class


IndependentTag.Create Method

IndependentTagCreate Method

Overload List
Name | Description
Create(Document, ElementId, ElementId, Reference, Boolean, TagOrientation, XYZ) | Places a tag on an element or subelement.
Create(Document, ElementId, Reference, Boolean, TagMode, TagOrientation, XYZ) | Places a tag on an element or subelement.
Top
See Also

Reference

IndependentTag Class


IndependentTag.Create(Document, ElementId, ElementId, Reference, Boolean, TagOrientation, XYZ) Method

IndependentTagCreate(Document, ElementId, ElementId, Reference, Boolean, TagOrientation, XYZ) Method

Places a tag on an element or subelement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IndependentTag Create(
    Document document,
    ElementId symId,
    ElementId ownerDBViewId,
    Reference referenceToTag,
    bool addLeader,
    TagOrientation tagOrientation,
    XYZ pnt
)
Public Shared Function Create (
    document As Document,
    symId As ElementId,
    ownerDBViewId As ElementId,
    referenceToTag As Reference,
    addLeader As Boolean,
    tagOrientation As TagOrientation,
    pnt As XYZ
) As IndependentTag
public:
static IndependentTag^ Create(
    Document^ document,
    ElementId^ symId,
    ElementId^ ownerDBViewId,
    Reference^ referenceToTag,
    bool addLeader,
    TagOrientation tagOrientation,
    XYZ^ pnt
)
static member Create :
        document : Document *
        symId : ElementId *
        ownerDBViewId : ElementId *
        referenceToTag : Reference *
        addLeader : bool *
        tagOrientation : TagOrientation *
        pnt : XYZ -> IndependentTag

Parameters

document Document
The document to which the tag will be added.
symId ElementId
The id for the FamilySymbol which determines the tag's type.
ownerDBViewId ElementId
The view in which the tag will be visible.
referenceToTag Reference
The host reference of the tag. The reference can be to an element or subelement in a local or linked document.
addLeader Boolean
When true, the tag will be created with a straight leader with an attached end.
tagOrientation TagOrientation
The orientation of the tag's head.
pnt XYZ
For tags without leaders, this point is the position of the tag head. For tags with leaders, this point is the end point of the leader, and a leader of default length will be created from this point to the tag head.

Return Value

IndependentTag
If successful the new tag is returned.
Exceptions
Exception | Condition
ArgumentException | The ElementId ownerDBViewId does not correspond to a View. -or- The ElementId ownerDBViewId is a view template. -or- The ElementId ownerDBViewId is a perspective view. -or- The 3D view ownerDBViewId is not locked. -or- The ElementId symId does not correspond to a FamilySymbol. -or- The reference can not be tagged.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InternalException | Tag creation failed.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
See Also

Reference

IndependentTag Class
Create Overload


IndependentTag.Create(Document, ElementId, Reference, Boolean, TagMode, TagOrientation, XYZ) Method

IndependentTagCreate(Document, ElementId, Reference, Boolean, TagMode, TagOrientation, XYZ) Method

Places a tag on an element or subelement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IndependentTag Create(
    Document document,
    ElementId ownerDBViewId,
    Reference referenceToTag,
    bool addLeader,
    TagMode tagMode,
    TagOrientation tagOrientation,
    XYZ pnt
)
Public Shared Function Create (
    document As Document,
    ownerDBViewId As ElementId,
    referenceToTag As Reference,
    addLeader As Boolean,
    tagMode As TagMode,
    tagOrientation As TagOrientation,
    pnt As XYZ
) As IndependentTag
public:
static IndependentTag^ Create(
    Document^ document,
    ElementId^ ownerDBViewId,
    Reference^ referenceToTag,
    bool addLeader,
    TagMode tagMode,
    TagOrientation tagOrientation,
    XYZ^ pnt
)
static member Create :
        document : Document *
        ownerDBViewId : ElementId *
        referenceToTag : Reference *
        addLeader : bool *
        tagMode : TagMode *
        tagOrientation : TagOrientation *
        pnt : XYZ -> IndependentTag

Parameters

document Document
The document to which the tag will be added.
ownerDBViewId ElementId
The view in which the tag will be visible.
referenceToTag Reference
The host reference of the tag. The reference can be to an element or subelement in a local or linked document.
addLeader Boolean
When true, the tag will be created with a straight leader with an attached end.
tagMode TagMode
This argument determines the type of tag that will be created. Tag by category, multi-category tag, and material tag are allowed.
tagOrientation TagOrientation
The orientation of the tag's head.
pnt XYZ
For tags without leaders, this point is the position of the tag head. For tags with leaders, this point is the end point of the leader, and a leader of default length will be created from this point to the tag head.

Return Value

IndependentTag
If successful the new tag is returned.
Exceptions
Exception | Condition
ArgumentException | The ElementId ownerDBViewId does not correspond to a View. -or- The ElementId ownerDBViewId is a view template. -or- The ElementId ownerDBViewId is a perspective view. -or- The 3D view ownerDBViewId is not locked. -or- The reference can not be tagged.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InternalException | Tag creation failed.
InvalidOperationException | There is no loaded tag type that can be used when tagging referenceToTag with tagMode.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
Single category tags, multi-category tags and material tags can be placed.
Example
C#
VB
C++
F#
Copy
private IndependentTag CreateIndependentTag(Autodesk.Revit.DB.Document document, Wall wall)
{
    // make sure active view is not a 3D view
    Autodesk.Revit.DB.View view = document.ActiveView;

    // define tag mode and tag orientation for new tag
    TagMode tagMode = TagMode.TM_ADDBY_CATEGORY;
    TagOrientation tagorn = TagOrientation.Horizontal;

    // Add the tag to the middle of the wall
    LocationCurve wallLoc = wall.Location as LocationCurve;
    XYZ wallStart = wallLoc.Curve.GetEndPoint(0);
    XYZ wallEnd = wallLoc.Curve.GetEndPoint(1);
    XYZ wallMid = wallLoc.Curve.Evaluate(0.5, true);
    Reference wallRef = new Reference(wall);

    IndependentTag newTag = IndependentTag.Create(document, view.Id,  wallRef, true, tagMode, tagorn, wallMid);
    if (null == newTag)
    {
        throw new Exception("Create IndependentTag Failed.");
    }

    // newTag.TagText is read-only, so we change the Type Mark type parameter to
    // set the tag text.  The label parameter for the tag family determines
    // what type parameter is used for the tag text.

    WallType type = wall.WallType;

    Parameter foundParameter = type.LookupParameter("Type Mark");
    bool result = foundParameter.Set("Hello");

    // set leader mode free
    // otherwise leader end point move with elbow point

    newTag.LeaderEndCondition = LeaderEndCondition.Free;
    XYZ elbowPnt = wallMid + new XYZ(5.0, 5.0, 0.0);
    newTag.SetLeaderElbow(wallRef, elbowPnt);
    XYZ headerPnt = wallMid + new XYZ(10.0, 10.0, 0.0);
    newTag.TagHeadPosition = headerPnt;

    // change tag orientation to AnyModelDirection
    newTag.TagOrientation = TagOrientation.AnyModelDirection;

    // change tag rotation angle to PI/4
    newTag.RotationAngle = Math.PI / 4;

    return newTag;
}
Private Function CreateIndependentTag(document As Autodesk.Revit.DB.Document, wall As Wall) As IndependentTag
      ' make sure active view is not a 3D view
      Dim view As Autodesk.Revit.DB.View = document.ActiveView

      ' define tag mode and tag orientation for new tag
      Dim tagMode__1 As TagMode = TagMode.TM_ADDBY_CATEGORY
      Dim tagorn As TagOrientation = TagOrientation.Horizontal

      ' Add the tag to the middle of the wall
      Dim wallLoc As LocationCurve = TryCast(wall.Location, LocationCurve)
      Dim wallStart As XYZ = wallLoc.Curve.GetEndPoint(0)
      Dim wallEnd As XYZ = wallLoc.Curve.GetEndPoint(1)
      Dim wallMid As XYZ = wallLoc.Curve.Evaluate(0.5, True)
   Dim WallRef As Reference = New Reference(wall)

   Dim newTag As IndependentTag = IndependentTag.Create(document, view.Id, wallRef, True, tagMode__1, tagorn, wallMid)
      If newTag Is Nothing Then
          Throw New Exception("Create IndependentTag Failed.")
      End If

      ' newTag.TagText is read-only, so we change the Type Mark type parameter to
      ' set the tag text.  The label parameter for the tag family determines
      ' what type parameter is used for the tag text.

      Dim type As WallType = wall.WallType

      Dim foundParameter As Parameter = type.LookupParameter("Type Mark")
      Dim result As Boolean = foundParameter.[Set]("Hello")

      ' set leader mode free
      ' otherwise leader end point move with elbow point

      newTag.LeaderEndCondition = LeaderEndCondition.Free
      Dim elbowPnt As XYZ = wallMid + New XYZ(5.0, 5.0, 0.0)
      newTag.SetLeaderElbow(WallRef, elbowPnt)
      Dim headerPnt As XYZ = wallMid + New XYZ(10.0, 10.0, 0.0)
      newTag.TagHeadPosition = headerPnt

      ' change tag orientation to AnyModelDirection
      newTag.TagOrientation = TagOrientation.AnyModelDirection

      ' change tag rotation angle to PI/4
      newTag.RotationAngle = Math.PI / 4

      Return newTag
  End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

IndependentTag Class
Create Overload


IndependentTag.GetLeaderElbow Method

IndependentTagGetLeaderElbow Method

Returns the position of the elbow of the tag's leader that points to specified reference. Position of leader's elbow.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ GetLeaderElbow(
    Reference referenceTagged
)
Public Function GetLeaderElbow (
    referenceTagged As Reference
) As XYZ
public:
XYZ^ GetLeaderElbow(
    Reference^ referenceTagged
)
member GetLeaderElbow :
        referenceTagged : Reference -> XYZ

Parameters

referenceTagged Reference
The reference which is tagged.

Return Value

XYZ
Exceptions
Exception | Condition
ArgumentException | The specified reference does not have a leader or its leader is straight. -or- The specified reference is not currently tagged.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The IndependentTag object does not have a tag behavior.
Remarks
Straight leaders do not have elbow points.
See Also

Reference

IndependentTag Class


IndependentTag.GetLeaderEnd Method

IndependentTagGetLeaderEnd Method

Returns the end position of the tag's leader that points to specified reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ GetLeaderEnd(
    Reference referenceTagged
)
Public Function GetLeaderEnd (
    referenceTagged As Reference
) As XYZ
public:
XYZ^ GetLeaderEnd(
    Reference^ referenceTagged
)
member GetLeaderEnd :
        referenceTagged : Reference -> XYZ

Parameters

referenceTagged Reference
The reference which is tagged.

Return Value

XYZ
Point representing the end position of tag's leader
Exceptions
Exception | Condition
ArgumentException | There is no leader end because the tag does not use a free end leader or the leader is not visible. -or- The specified reference is not currently tagged.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The IndependentTag object does not have a tag behavior.
Remarks
Tags with attached leaders or no leaders do not support leader ends. LeaderEndCondition for the tag's leader condition.
See Also

Reference

IndependentTag Class


IndependentTag.GetTaggedElementIds Method

IndependentTagGetTaggedElementIds Method

Returns a set of LinkElementId for all tagged elements, if any. A LinkElementId will be provided for each subelement that is being referenced by the tag.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<LinkElementId> GetTaggedElementIds()
Public Function GetTaggedElementIds As ICollection(Of LinkElementId)
public:
ICollection<LinkElementId^>^ GetTaggedElementIds()
member GetTaggedElementIds : unit -> ICollection<LinkElementId>

Return Value

ICollection LinkElementId
Set of all the tagged elements ids for both local and linked files.
Remarks
All the returned LinkElementIds will be valid even when IsOrphaned is true.
See Also

Reference

IndependentTag Class


IndependentTag.GetTaggedLocalElementIds Method

IndependentTagGetTaggedLocalElementIds Method

Returns a set of IDs for all tagged local elements, if any. A local element ID will be provided for each subelement that is being referenced by the tag. Set of all the element ids in the local file. For each subelement a local element id will be provided.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ISet<ElementId> GetTaggedLocalElementIds()
Public Function GetTaggedLocalElementIds As ISet(Of ElementId)
public:
ISet<ElementId^>^ GetTaggedLocalElementIds()
member GetTaggedLocalElementIds : unit -> ISet<ElementId>

Return Value

ISet ElementId
See Also

Reference

IndependentTag Class


IndependentTag.GetTaggedLocalElements Method

IndependentTagGetTaggedLocalElements Method

Get the tagged local elements, if any. An Element will be provided for each subelement that is being referenced by the tag.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<Element> GetTaggedLocalElements()
Public Function GetTaggedLocalElements As ICollection(Of Element)
public:
ICollection<Element^>^ GetTaggedLocalElements()
member GetTaggedLocalElements : unit -> ICollection<Element>

Return Value

ICollection Element
All tagged elements from the local document, or for orphan tags and tagged elements in linked documents.
See Also

Reference

IndependentTag Class


IndependentTag.GetTaggedReferences Method

IndependentTagGetTaggedReferences Method

Get the host references of the tag. An array of all the tagged references.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<Reference> GetTaggedReferences()
Public Function GetTaggedReferences As IList(Of Reference)
public:
IList<Reference^>^ GetTaggedReferences()
member GetTaggedReferences : unit -> IList<Reference>

Return Value

IList Reference
Remarks
The references can be to an element or subelement in a local or linked document.
See Also

Reference

IndependentTag Class


IndependentTag.HasLeaderElbow Method

IndependentTagHasLeaderElbow Method

Whether the tag's leader that points to the reference has an elbow point or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasLeaderElbow(
    Reference referenceTagged
)
Public Function HasLeaderElbow (
    referenceTagged As Reference
) As Boolean
public:
bool HasLeaderElbow(
    Reference^ referenceTagged
)
member HasLeaderElbow :
        referenceTagged : Reference -> bool

Parameters

referenceTagged Reference

Return Value

Boolean
True if the reference has a leader with an elbow point, or false otherwise.
Exceptions
Exception | Condition
ArgumentException | The specified reference is not currently tagged. -or- The leader for the tagged reference isn't visible.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The IndependentTag object does not have a tag behavior.
See Also

Reference

IndependentTag Class


IndependentTag.HasTagBehavior Method

IndependentTagHasTagBehavior Method

Checks if the IndependentTag has a tag behavior.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasTagBehavior()
Public Function HasTagBehavior As Boolean
public:
bool HasTagBehavior()
member HasTagBehavior : unit -> bool

Return Value

Boolean
Remarks
When the IndependentTag object does not have a tag behavior, functions related to references, leaders and orientation will throw an exception. In this case, the element may be used for geometry augmentation. [!:Autodesk::Revit::Proxy::DB::IGeometryAugmentationServer] The list of functions that would fail if not in tag mode: [M:Autodesk.Revit.DB.IndependentTag.AddReferences(System.Collections.Generic.IList`1{Autodesk.Revit.DB.Reference})] GetLeaderElbow(Reference) GetLeaderEnd(Reference) HasLeader HasLeaderElbow(Reference) IsLeaderVisible(Reference) LeaderEndCondition LeadersPresentationMode MergeElbows [M:Autodesk.Revit.DB.IndependentTag.RemoveReferences(System.Collections.Generic.IList`1{Autodesk.Revit.DB.Reference})] SetIsLeaderVisible(Reference, Boolean) SetLeaderEnd(Reference, XYZ) SetLeaderElbow(Reference, XYZ) TagOrientation TagText
See Also

Reference

IndependentTag Class


IndependentTag.IsLeaderVisible Method

IndependentTagIsLeaderVisible Method

Returns if leader that points to specified reference is visible or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsLeaderVisible(
    Reference referenceTagged
)
Public Function IsLeaderVisible (
    referenceTagged As Reference
) As Boolean
public:
bool IsLeaderVisible(
    Reference^ referenceTagged
)
member IsLeaderVisible :
        referenceTagged : Reference -> bool

Parameters

referenceTagged Reference
The reference which is tagged.

Return Value

Boolean
Returns true if leader that points to specified reference is visible, false otherwise.
Exceptions
Exception | Condition
ArgumentException | The specified reference is not currently tagged.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The IndependentTag object does not have a tag behavior.
See Also

Reference

IndependentTag Class


IndependentTag.IsTaggedOnSubelement Method

IndependentTagIsTaggedOnSubelement Method

Returns true if the any of the tagged references is a subelement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsTaggedOnSubelement()
Public Function IsTaggedOnSubelement As Boolean
public:
bool IsTaggedOnSubelement()
member IsTaggedOnSubelement : unit -> bool

Return Value

Boolean
See Also

Reference

IndependentTag Class


IndependentTag.RemoveReferences Method

IndependentTagRemoveReferences Method

Removes the provided list of references from the tag's list of references.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveReferences(
    IList<Reference> referencesToRemove
)
Public Sub RemoveReferences (
    referencesToRemove As IList(Of Reference)
)
public:
void RemoveReferences(
    IList<Reference^>^ referencesToRemove
)
member RemoveReferences :
        referencesToRemove : IList<Reference> -> unit

Parameters

referencesToRemove IList Reference
References to be removed from tag.
Exceptions
Exception | Condition
ArgumentException | The operation failed. Please verify that the references are all tagged before removing them.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The IndependentTag object does not have a tag behavior. -or- Modifying tag references for MRA owned tag from API is not allowed.
Remarks
If the tag is owned by MRA element, an exception will be thrown.
See Also

Reference

IndependentTag Class


IndependentTag.SetIsLeaderVisible Method

IndependentTagSetIsLeaderVisible Method

Set tag's leader that points to specified reference to be visible or not. This option can be set only if the LeadersPresentationMode is ShowSpecificLeaders.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetIsLeaderVisible(
    Reference referenceTagged,
    bool visible
)
Public Sub SetIsLeaderVisible (
    referenceTagged As Reference,
    visible As Boolean
)
public:
void SetIsLeaderVisible(
    Reference^ referenceTagged,
    bool visible
)
member SetIsLeaderVisible :
        referenceTagged : Reference *
        visible : bool -> unit

Parameters

referenceTagged Reference
The reference which is tagged.
visible Boolean
True for showing the leader, false to hide it.
Exceptions
Exception | Condition
ArgumentException | The specified reference is not currently tagged.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The IndependentTag object does not have a tag behavior. -or- For this tag leaders are not allowed. -or- The LeadersPresentationMode should be set to ShowSpecificLeaders.
See Also

Reference

IndependentTag Class


IndependentTag.SetLeaderElbow Method

IndependentTagSetLeaderElbow Method

Set the position of the elbow of the tag's leader that points to specified reference. If this tag is a multileader tag and the elbows are merged, the input position will be set to all leaders.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetLeaderElbow(
    Reference referenceTagged,
    XYZ elbowPosition
)
Public Sub SetLeaderElbow (
    referenceTagged As Reference,
    elbowPosition As XYZ
)
public:
void SetLeaderElbow(
    Reference^ referenceTagged,
    XYZ^ elbowPosition
)
member SetLeaderElbow :
        referenceTagged : Reference *
        elbowPosition : XYZ -> unit

Parameters

referenceTagged Reference
The reference which is tagged.
elbowPosition XYZ
The position of the elbow.
Exceptions
Exception | Condition
ArgumentException | The specified reference is not currently tagged. -or- The leader for the tagged reference isn't visible.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The IndependentTag object does not have a tag behavior. -or- For this tag leaders are not allowed.
Remarks
Straight leaders do not have elbow points.
See Also

Reference

IndependentTag Class


IndependentTag.SetLeaderEnd Method

IndependentTagSetLeaderEnd Method

Set the end position of the tag's leader that points to specified reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetLeaderEnd(
    Reference referenceTagged,
    XYZ pointEnd
)
Public Sub SetLeaderEnd (
    referenceTagged As Reference,
    pointEnd As XYZ
)
public:
void SetLeaderEnd(
    Reference^ referenceTagged,
    XYZ^ pointEnd
)
member SetLeaderEnd :
        referenceTagged : Reference *
        pointEnd : XYZ -> unit

Parameters

referenceTagged Reference
The reference which is tagged.
pointEnd XYZ
Point representing the end position of tag's leader
Exceptions
Exception | Condition
ArgumentException | There is no leader end because the tag does not use a free end leader or the leader is not visible. -or- The specified reference is not currently tagged.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The IndependentTag object does not have a tag behavior. -or- For this tag leaders are not allowed.
Remarks
Tags with attached leaders or no leaders do not support leader ends. LeaderEndCondition for the tag's leader condition.
See Also

Reference

IndependentTag Class


InsertableObject Class

A base class you all types that are insertable.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBInsertableObject
Autodesk.Revit.DBFamilySymbol

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class InsertableObject : ElementType
Public Class InsertableObject
    Inherits ElementType
public ref class InsertableObject : public ElementType
type InsertableObject =
    class
        inherit ElementType
    end

The InsertableObject type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


InsertableObject Properties

The InsertableObject type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

InsertableObject Class


InsertableObject Methods

The InsertableObject type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

InsertableObject Class


InsertOrientation Enumeration

The allowed values for the INSERT_ORIENTATION parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum InsertOrientation
Public Enumeration InsertOrientation
public enum class InsertOrientation
type InsertOrientation
Members
Member name | Value | Description
Vertical | 0 | Insert is vertical regardless of the wall's slant.
Slanted | 1 | Insert is aligned with the Slanted wall's slant direction.
Exterior | 2 | Insert is aligned with the Tapered wall's exterior face.
Interior | 3 | Insert is aligned with the Tapered wall's interior face.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


InSessionPrintSetting Class

Represents the in-session Print Setup (Application Menu->Print->Print Setup) within Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBInSessionPrintSetting

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class InSessionPrintSetting : IPrintSetting,
    IDisposable
Public Class InSessionPrintSetting
    Implements IPrintSetting, IDisposable
public ref class InSessionPrintSetting : IPrintSetting,
    IDisposable
type InSessionPrintSetting =
    class
        interface IPrintSetting
        interface IDisposable
    end

The InSessionPrintSetting type exposes the following members.

Properties
 | Name | Description
Public property | PrintParameters | Returns the Parameters of Print Setup.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the InSessionPrintSetting
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The in-session PrintSetting can't be stored in document.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


InSessionPrintSetting Properties

The InSessionPrintSetting type exposes the following members.

Properties
 | Name | Description
Public property | PrintParameters | Returns the Parameters of Print Setup.
Top
See Also

Reference

InSessionPrintSetting Class


InSessionPrintSetting.PrintParameters Property

InSessionPrintSettingPrintParameters Property

Returns the Parameters of Print Setup.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual PrintParameters PrintParameters { get; }
Public Overridable ReadOnly Property PrintParameters As PrintParameters
    Get
public:
virtual property PrintParameters^ PrintParameters {
    PrintParameters^ get ();
}
abstract PrintParameters : PrintParameters with get
override PrintParameters : PrintParameters with get

Property Value

PrintParameters

Implements

IPrintSettingPrintParameters
Remarks
The Parameters of Print Setup. Refer to the Print Setup dialog in Revit for details.
See Also

Reference

InSessionPrintSetting Class


InSessionPrintSetting Methods

The InSessionPrintSetting type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

InSessionPrintSetting Class


InSessionPrintSetting.Dispose Method

InSessionPrintSettingDispose Method

Releases all resources used by the InSessionPrintSetting

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

InSessionPrintSetting Class


InSessionViewSheetSet Class

Represents the in-session ViewSheetSet.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBInSessionViewSheetSet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class InSessionViewSheetSet : IViewSheetSet,
    IDisposable
Public Class InSessionViewSheetSet
    Implements IViewSheetSet, IDisposable
public ref class InSessionViewSheetSet : IViewSheetSet,
    IDisposable
type InSessionViewSheetSet =
    class
        interface IViewSheetSet
        interface IDisposable
    end

The InSessionViewSheetSet type exposes the following members.

Properties
 | Name | Description
Public property | IsAutomatic | Automatic order or manual order.
Public property | OrderedViewList | Ordered views.
Public property | SheetOrganizationId | ElementId to the BrowserOrganization for sheets.
Public property | ViewOrganizationId | ElementId to the BrowserOrganization for non-sheet views.
Public property | Views | The views.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the InSessionViewSheetSet
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The in-session ViewSheetSet can't be stored in document.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


InSessionViewSheetSet Properties

The InSessionViewSheetSet type exposes the following members.

Properties
 | Name | Description
Public property | IsAutomatic | Automatic order or manual order.
Public property | OrderedViewList | Ordered views.
Public property | SheetOrganizationId | ElementId to the BrowserOrganization for sheets.
Public property | ViewOrganizationId | ElementId to the BrowserOrganization for non-sheet views.
Public property | Views | The views.
Top
See Also

Reference

InSessionViewSheetSet Class


InSessionViewSheetSet.IsAutomatic Property

InSessionViewSheetSetIsAutomatic Property

Automatic order or manual order.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsAutomatic { get; set; }
Public Overridable Property IsAutomatic As Boolean
    Get
    Set
public:
virtual property bool IsAutomatic {
    bool get ();
    void set (bool value);
}
abstract IsAutomatic : bool with get, set
override IsAutomatic : bool with get, set

Property Value

Boolean

Implements

IViewSheetSetIsAutomatic
See Also

Reference

InSessionViewSheetSet Class


InSessionViewSheetSet.OrderedViewList Property

InSessionViewSheetSetOrderedViewList Property

Ordered views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IReadOnlyList<View> OrderedViewList { get; set; }
Public Overridable Property OrderedViewList As IReadOnlyList(Of View)
    Get
    Set
public:
virtual property IReadOnlyList<View^>^ OrderedViewList {
    IReadOnlyList<View^>^ get ();
    void set (IReadOnlyList<View^>^ value);
}
abstract OrderedViewList : IReadOnlyList<View> with get, set
override OrderedViewList : IReadOnlyList<View> with get, set

Property Value

IReadOnlyList View

Implements

IViewSheetSetOrderedViewList
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input ordered view list is .
InvalidOperationException | Thrown when the set operation failed due to invalid view which cannot be printed.
See Also

Reference

InSessionViewSheetSet Class


InSessionViewSheetSet.SheetOrganizationId Property

InSessionViewSheetSetSheetOrganizationId Property

ElementId to the BrowserOrganization for sheets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ElementId SheetOrganizationId { get; set; }
Public Overridable Property SheetOrganizationId As ElementId
    Get
    Set
public:
virtual property ElementId^ SheetOrganizationId {
    ElementId^ get ();
    void set (ElementId^ value);
}
abstract SheetOrganizationId : ElementId with get, set
override SheetOrganizationId : ElementId with get, set

Property Value

ElementId

Implements

IViewSheetSetSheetOrganizationId
Exceptions
Exception | Condition
ArgumentException | Thrown when the ElementId does not reference to BrowserOrganization, or the target type of BrowserOrganization is incompatible.
See Also

Reference

InSessionViewSheetSet Class


InSessionViewSheetSet.ViewOrganizationId Property

InSessionViewSheetSetViewOrganizationId Property

ElementId to the BrowserOrganization for non-sheet views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ElementId ViewOrganizationId { get; set; }
Public Overridable Property ViewOrganizationId As ElementId
    Get
    Set
public:
virtual property ElementId^ ViewOrganizationId {
    ElementId^ get ();
    void set (ElementId^ value);
}
abstract ViewOrganizationId : ElementId with get, set
override ViewOrganizationId : ElementId with get, set

Property Value

ElementId

Implements

IViewSheetSetViewOrganizationId
Exceptions
Exception | Condition
ArgumentException | Thrown when the ElementId does not reference to BrowserOrganization, or the target type of BrowserOrganization is incompatible.
See Also

Reference

InSessionViewSheetSet Class


InSessionViewSheetSet.Views Property

InSessionViewSheetSetViews Property

The views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ViewSet Views { get; set; }
Public Overridable Property Views As ViewSet
    Get
    Set
public:
virtual property ViewSet^ Views {
    ViewSet^ get ();
    void set (ViewSet^ value);
}
abstract Views : ViewSet with get, set
override Views : ViewSet with get, set

Property Value

ViewSet

Implements

IViewSheetSetViews
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input views is .
InvalidOperationException | Thrown when the set operation failed due to invalid view which cannot be printed.
See Also

Reference

InSessionViewSheetSet Class


InSessionViewSheetSet Methods

The InSessionViewSheetSet type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

InSessionViewSheetSet Class


InSessionViewSheetSet.Dispose Method

InSessionViewSheetSetDispose Method

Releases all resources used by the InSessionViewSheetSet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

InSessionViewSheetSet Class


Instance Class

The base class for all instance objects.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBInstance
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Instance : Element
Public Class Instance
    Inherits Element
public ref class Instance : public Element
type Instance =
    class
        inherit Element
    end

The Instance type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances.
Public method | GetTransform | Gets the transform of the instance.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBInstance
Autodesk.Revit.DBFamilyInstance
Autodesk.Revit.DBImportInstance
Autodesk.Revit.DBPointCloudInstance
Autodesk.Revit.DBProjectLocation
Autodesk.Revit.DBRevitLinkInstance


Instance Properties

The Instance type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

Instance Class


Instance Methods

The Instance type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances.
Public method | GetTransform | Gets the transform of the instance.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Instance Class


Instance.GetTotalTransform Method

InstanceGetTotalTransform Method

Gets the total transform, which includes the true north transform for instances like import instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Transform GetTotalTransform()
Public Function GetTotalTransform As Transform
public:
Transform^ GetTotalTransform()
member GetTotalTransform : unit -> Transform

Return Value

Transform
The calculated total transform.
Remarks
For most of other instances, it simply returns the inherent transform.
See Also

Reference

Instance Class


Instance.GetTransform Method

InstanceGetTransform Method

Gets the transform of the instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Transform GetTransform()
Public Function GetTransform As Transform
public:
Transform^ GetTransform()
member GetTransform : unit -> Transform

Return Value

Transform
The inherent transform.
See Also

Reference

Instance Class


InstanceBinding Class

The InstanceBinding object is used to signify a binding between a parameter definition and a parameter on each instance of an element, such as a wall.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBBinding
Autodesk.Revit.DBElementBinding
Autodesk.Revit.DBInstanceBinding

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class InstanceBinding : ElementBinding
Public Class InstanceBinding
    Inherits ElementBinding
public ref class InstanceBinding : public ElementBinding
type InstanceBinding =
    class
        inherit ElementBinding
    end

The InstanceBinding type exposes the following members.

Constructors
 | Name | Description
Public method | InstanceBinding | Constructs an empty instance binding.
Public method | InstanceBinding(CategorySet) | Constructs an instance binding with the set of categories passed.
Top
Properties
 | Name | Description
Public property | Categories | Retrieve or set the categories to which a parameter definition will be bound. (Inherited from ElementBinding)
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Once bound the parameter will appear on all instance of the element and changing the parameter on any one single instance will not change the value on any other instance.
Example
C#
VB
C++
F#
Copy
public bool SetNewParameterToInstanceWall(UIApplication app, DefinitionFile myDefinitionFile)
{
    // create a new group in the shared parameters file
    DefinitionGroups myGroups = myDefinitionFile.Groups;
    DefinitionGroup myGroup = myGroups.Create("MyParameters1");

    // create an instance definition in definition group MyParameters
    ExternalDefinitionCreationOptions option = new ExternalDefinitionCreationOptions("Instance_ProductDate", SpecTypeId.String.Text);
    // Don't let the user modify the value, only the API
    option.UserModifiable = false;
    // Set tooltip
    option.Description = "Wall product date";
    Definition myDefinition_ProductDate = myGroup.Definitions.Create(option);

    // create a category set and insert category of wall to it
    CategorySet myCategories = app.Application.Create.NewCategorySet();
    // use BuiltInCategory to get category of wall
    Category myCategory = Category.GetCategory(app.ActiveUIDocument.Document, BuiltInCategory.OST_Walls);

    myCategories.Insert(myCategory);

    //Create an instance of InstanceBinding
    InstanceBinding instanceBinding = app.Application.Create.NewInstanceBinding(myCategories);

    // Get the BingdingMap of current document.
    BindingMap bindingMap = app.ActiveUIDocument.Document.ParameterBindings;

    // Bind the definitions to the document
    bool instanceBindOK = bindingMap.Insert(myDefinition_ProductDate,
                                    instanceBinding, GroupTypeId.Text);
    return instanceBindOK;
}
Public Function SetNewParameterToInstanceWall(app As UIApplication, myDefinitionFile As DefinitionFile) As Boolean
   ' create a new group in the shared parameters file
   Dim myGroups As DefinitionGroups = myDefinitionFile.Groups
   Dim myGroup As DefinitionGroup = myGroups.Create("MyParameters1")

   ' create an instance definition in definition group MyParameters
   Dim [option] As New ExternalDefinitionCreationOptions("Instance_ProductDate", SpecTypeId.String.Text)
   ' Don't let the user modify the value, only the API
   [option].UserModifiable = False
   ' Set tooltip
   [option].Description = "Wall product date"
   Dim myDefinition_ProductDate As Definition = myGroup.Definitions.Create([option])

   ' create a category set and insert category of wall to it
   Dim myCategories As CategorySet = app.Application.Create.NewCategorySet()
   ' use BuiltInCategory to get category of wall
   Dim myCategory As Category = Category.GetCategory(app.ActiveUIDocument.Document, BuiltInCategory.OST_Walls)

   myCategories.Insert(myCategory)

   'Create an instance of InstanceBinding
   Dim instanceBinding As InstanceBinding = app.Application.Create.NewInstanceBinding(myCategories)

   ' Get the BingdingMap of current document.
   Dim bindingMap As BindingMap = app.ActiveUIDocument.Document.ParameterBindings

      ' Bind the definitions to the document
      Dim instanceBindOK As Boolean = bindingMap.Insert(myDefinition_ProductDate, instanceBinding, GroupTypeId.Text)
      Return instanceBindOK
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


InstanceBinding Constructor

Overload List
 | Name | Description
Public method | InstanceBinding | Constructs an empty instance binding.
Public method | InstanceBinding(CategorySet) | Constructs an instance binding with the set of categories passed.
Top
See Also

Reference

InstanceBinding Class


InstanceBinding Constructor

Constructs an empty instance binding.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public InstanceBinding()
Public Sub New
public:
InstanceBinding()
new : unit -> InstanceBinding
Remarks
Categories can be set a later time by using the Categories property of this object.
See Also

Reference

InstanceBinding Class
InstanceBinding Overload


InstanceBinding(CategorySet) Constructor

Constructs an instance binding with the set of categories passed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public InstanceBinding(
    CategorySet categories
)
Public Sub New (
    categories As CategorySet
)
public:
InstanceBinding(
    CategorySet^ categories
)
new :
        categories : CategorySet -> InstanceBinding

Parameters

categories CategorySet
Remarks
Categories can be set or changed at a later time by using the Categories property of this object.
See Also

Reference

InstanceBinding Class
InstanceBinding Overload


InstanceBinding Properties

The InstanceBinding type exposes the following members.

Properties
 | Name | Description
Public property | Categories | Retrieve or set the categories to which a parameter definition will be bound. (Inherited from ElementBinding)
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

InstanceBinding Class


InstanceBinding Methods

The InstanceBinding type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

InstanceBinding Class


InstanceNode Class

An output node that represents an instance of a geometry. It can be an instance of FamilyInstance, or it can be and instance of a part of symbol's geometry.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRenderNode
Autodesk.Revit.DBGroupNode
Autodesk.Revit.DBInstanceNode

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class InstanceNode : GroupNode
Public Class InstanceNode
    Inherits GroupNode
public ref class InstanceNode : public GroupNode
type InstanceNode =
    class
        inherit GroupNode
    end

The InstanceNode type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode)
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from RenderNode)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetSymbolGeometryId | Gets the SymbolGeometryId associated with the node.
Public method | GetTransform | A transformation matrix associated with the node. (Inherited from GroupNode)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
See also: OnInstanceBegin(InstanceNode). The SymbolGeometryId. contains the data for comparing if two InstanceNode points to the same geometry.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


InstanceNode Properties

The InstanceNode type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode)
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode)
Top
See Also

Reference

InstanceNode Class


InstanceNode Methods

The InstanceNode type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from RenderNode)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetSymbolGeometryId | Gets the SymbolGeometryId associated with the node.
Public method | GetTransform | A transformation matrix associated with the node. (Inherited from GroupNode)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

InstanceNode Class


InstanceNode.GetSymbolGeometryId Method

InstanceNodeGetSymbolGeometryId Method

Gets the SymbolGeometryId associated with the node.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SymbolGeometryId GetSymbolGeometryId()
Public Function GetSymbolGeometryId As SymbolGeometryId
public:
SymbolGeometryId^ GetSymbolGeometryId()
member GetSymbolGeometryId : unit -> SymbolGeometryId

Return Value

SymbolGeometryId
Remarks
Use the strings returned by SymbolGeometryId.AsIdentifier(bool) to check if two nodes point to the same geometry of the symbol.
See Also

Reference

InstanceNode Class


InstanceVoidCutUtils Class

Utilities for cutting elements by unattached voids in family instances.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBInstanceVoidCutUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class InstanceVoidCutUtils
Public NotInheritable Class InstanceVoidCutUtils
public ref class InstanceVoidCutUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type InstanceVoidCutUtils = class end

The InstanceVoidCutUtils type exposes the following members.

Methods
Name | Description
AddInstanceVoidCut | Add a cut to an element using the unattached voids inside a cutting instance.
CanBeCutWithVoid | Indicates if the element can be cut by an instance with unattached voids.
GetCuttingVoidInstances | Return ids of the instances with unattached voids cutting the element.
GetElementsBeingCut | Return ids of the elements being cut by the instance
InstanceVoidCutExists | Check whether the instance is cutting the element
IsVoidInstanceCuttingElement | Indicates if the element is a family instance with unattached voids that can cut other elements.
RemoveInstanceVoidCut | Remove a cut applied to the element by a cutting instance with unattached voids.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


InstanceVoidCutUtils Methods

The InstanceVoidCutUtils type exposes the following members.

Methods
Name | Description
AddInstanceVoidCut | Add a cut to an element using the unattached voids inside a cutting instance.
CanBeCutWithVoid | Indicates if the element can be cut by an instance with unattached voids.
GetCuttingVoidInstances | Return ids of the instances with unattached voids cutting the element.
GetElementsBeingCut | Return ids of the elements being cut by the instance
InstanceVoidCutExists | Check whether the instance is cutting the element
IsVoidInstanceCuttingElement | Indicates if the element is a family instance with unattached voids that can cut other elements.
RemoveInstanceVoidCut | Remove a cut applied to the element by a cutting instance with unattached voids.
Top
See Also

Reference

InstanceVoidCutUtils Class


InstanceVoidCutUtils.AddInstanceVoidCut Method

InstanceVoidCutUtilsAddInstanceVoidCut Method

Add a cut to an element using the unattached voids inside a cutting instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void AddInstanceVoidCut(
    Document document,
    Element element,
    Element cuttingInstance
)
Public Shared Sub AddInstanceVoidCut (
    document As Document,
    element As Element,
    cuttingInstance As Element
)
public:
static void AddInstanceVoidCut(
    Document^ document,
    Element^ element,
    Element^ cuttingInstance
)
static member AddInstanceVoidCut :
        document : Document *
        element : Element *
        cuttingInstance : Element -> unit

Parameters

document Document
The document containing the two elements
element Element
The element to be cut
cuttingInstance Element
The cutting family instance
Exceptions
Exception | Condition
ArgumentException | The element cannot be cut with a void instance. -or- The element is not a family instance with an unattached void that can cut.
ArgumentNullException | A non-optional argument was null
ForbiddenForDynamicUpdateException | This method may not be called during dynamic update.
InvalidOperationException | Failed to cut element with the instances
Example
C#
VB
C++
F#
Copy
// Cut a beam with 3 instances of a void-cutting family
// The Family Parameter "Cut with Voids When Loaded" must be true for the cutting family
void CutBeamWithFamilyVoid(Autodesk.Revit.DB.Document doc, FamilyInstance beam, FamilySymbol cuttingSymbol)
{
    LocationCurve lc = beam.Location as LocationCurve;
    Curve beamCurve = lc.Curve;

    for (int i = 1; i <= 3; i++)
    {
        XYZ beamLocation = beamCurve.Evaluate(i * 0.25, true); // position on the beam for this cutting instance
        beamLocation = beamLocation - XYZ.BasisZ; // adjust for top-aligned curve

        Level level = doc.GetElement(beam.LevelId) as Level;
        FamilyInstance cuttingInstance = doc.Create.NewFamilyInstance(beamLocation, cuttingSymbol, level, StructuralType.NonStructural);
        InstanceVoidCutUtils.AddInstanceVoidCut(doc, beam, cuttingInstance);
    }
}
' Cut a beam with 3 instances of a void-cutting family
' The Family Parameter "Cut with Voids When Loaded" must be true for the cutting family
Private Sub CutBeamWithFamilyVoid(doc As Autodesk.Revit.DB.Document, beam As FamilyInstance, cuttingSymbol As FamilySymbol)
    Dim lc As LocationCurve = TryCast(beam.Location, LocationCurve)
    Dim beamCurve As Curve = lc.Curve

    For i As Integer = 1 To 3
        Dim beamLocation As XYZ = beamCurve.Evaluate(i * 0.25, True)
        ' position on the beam for this cutting instance
        beamLocation = beamLocation - XYZ.BasisZ
        ' adjust for top-aligned curve
        Dim level As Level = TryCast(doc.GetElement(beam.LevelId), Level)
        Dim cuttingInstance As FamilyInstance = doc.Create.NewFamilyInstance(beamLocation, cuttingSymbol, level, StructuralType.NonStructural)
        InstanceVoidCutUtils.AddInstanceVoidCut(doc, beam, cuttingInstance)
    Next
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

InstanceVoidCutUtils Class


InstanceVoidCutUtils.CanBeCutWithVoid Method

InstanceVoidCutUtilsCanBeCutWithVoid Method

Indicates if the element can be cut by an instance with unattached voids.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CanBeCutWithVoid(
    Element element
)
Public Shared Function CanBeCutWithVoid (
    element As Element
) As Boolean
public:
static bool CanBeCutWithVoid(
    Element^ element
)
static member CanBeCutWithVoid :
        element : Element -> bool

Parameters

element Element
The element to be cut

Return Value

Boolean
Returns true if the element can be cut by an instance with unattached voids.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Elements in a project can be cut if they are host elements or family instances with a category Generic Model or one of the structural categories.
See Also

Reference

InstanceVoidCutUtils Class


InstanceVoidCutUtils.GetCuttingVoidInstances Method

InstanceVoidCutUtilsGetCuttingVoidInstances Method

Return ids of the instances with unattached voids cutting the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ICollection<ElementId> GetCuttingVoidInstances(
    Element element
)
Public Shared Function GetCuttingVoidInstances (
    element As Element
) As ICollection(Of ElementId)
public:
static ICollection<ElementId^>^ GetCuttingVoidInstances(
    Element^ element
)
static member GetCuttingVoidInstances :
        element : Element -> ICollection<ElementId>

Parameters

element Element
The element being cut

Return Value

ICollection ElementId
Ids of instances with unattached voids that cut this element
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

InstanceVoidCutUtils Class


InstanceVoidCutUtils.GetElementsBeingCut Method

InstanceVoidCutUtilsGetElementsBeingCut Method

Return ids of the elements being cut by the instance

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ICollection<ElementId> GetElementsBeingCut(
    Element cuttingInstance
)
Public Shared Function GetElementsBeingCut (
    cuttingInstance As Element
) As ICollection(Of ElementId)
public:
static ICollection<ElementId^>^ GetElementsBeingCut(
    Element^ cuttingInstance
)
static member GetElementsBeingCut :
        cuttingInstance : Element -> ICollection<ElementId>

Parameters

cuttingInstance Element
The cutting family instance

Return Value

ICollection ElementId
Ids of elements being cut by cuttingInstance
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

InstanceVoidCutUtils Class


InstanceVoidCutUtils.InstanceVoidCutExists Method

InstanceVoidCutUtilsInstanceVoidCutExists Method

Check whether the instance is cutting the element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool InstanceVoidCutExists(
    Element element,
    Element cuttingInstance
)
Public Shared Function InstanceVoidCutExists (
    element As Element,
    cuttingInstance As Element
) As Boolean
public:
static bool InstanceVoidCutExists(
    Element^ element,
    Element^ cuttingInstance
)
static member InstanceVoidCutExists :
        element : Element *
        cuttingInstance : Element -> bool

Parameters

element Element
The element being cut
cuttingInstance Element
The cutting family instance

Return Value

Boolean
Returns true if the instance is cutting the element.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

InstanceVoidCutUtils Class


InstanceVoidCutUtils.IsVoidInstanceCuttingElement Method

InstanceVoidCutUtilsIsVoidInstanceCuttingElement Method

Indicates if the element is a family instance with unattached voids that can cut other elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsVoidInstanceCuttingElement(
    Element element
)
Public Shared Function IsVoidInstanceCuttingElement (
    element As Element
) As Boolean
public:
static bool IsVoidInstanceCuttingElement(
    Element^ element
)
static member IsVoidInstanceCuttingElement :
        element : Element -> bool

Parameters

element Element
The cutting family instance

Return Value

Boolean
Returns true if the element is a family instance with unattached voids that can cut other elements.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
A family instance can cut if the family has unattached voids and the family's parameter "Cut with Voids When Loaded" is checked.
See Also

Reference

InstanceVoidCutUtils Class


InstanceVoidCutUtils.RemoveInstanceVoidCut Method

InstanceVoidCutUtilsRemoveInstanceVoidCut Method

Remove a cut applied to the element by a cutting instance with unattached voids.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void RemoveInstanceVoidCut(
    Document document,
    Element element,
    Element cuttingInstance
)
Public Shared Sub RemoveInstanceVoidCut (
    document As Document,
    element As Element,
    cuttingInstance As Element
)
public:
static void RemoveInstanceVoidCut(
    Document^ document,
    Element^ element,
    Element^ cuttingInstance
)
static member RemoveInstanceVoidCut :
        document : Document *
        element : Element *
        cuttingInstance : Element -> unit

Parameters

document Document
The document containing the two elements
element Element
The element being cut
cuttingInstance Element
The cutting family instance
Exceptions
Exception | Condition
ArgumentException | No instance void cut exists between the two elements.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Failed to remove the instance cut from the element
Example
C#
VB
C++
F#
Copy
// remove all cuts in all family instances created by void-cutting instances
void RemoveVoidCuts(Autodesk.Revit.DB.Document doc, FamilySymbol cuttingSymbol)
{
    FilteredElementCollector collector = new FilteredElementCollector(doc);
    collector.WherePasses(new FamilyInstanceFilter(doc, cuttingSymbol.Id)); // find elements that are family instances of the cutting family

    foreach (FamilyInstance instance in collector)
    {
        foreach (ElementId elementId in InstanceVoidCutUtils.GetElementsBeingCut(instance)) // elements being cut by this instance of the cutting family
        {
            InstanceVoidCutUtils.RemoveInstanceVoidCut(doc, doc.GetElement(elementId), instance); // remove the cut
        }
    }
}
' remove all cuts in all family instances created by void-cutting instances
Private Sub RemoveVoidCuts(doc As Autodesk.Revit.DB.Document, cuttingSymbol As FamilySymbol)
    Dim collector As New FilteredElementCollector(doc)
    collector.WherePasses(New FamilyInstanceFilter(doc, cuttingSymbol.Id))
    ' find elements that are family instances of the cutting family
    For Each instance As FamilyInstance In collector
        For Each elementId As ElementId In InstanceVoidCutUtils.GetElementsBeingCut(instance)
            ' elements being cut by this instance of the cutting family
                ' remove the cut
            InstanceVoidCutUtils.RemoveInstanceVoidCut(doc, doc.GetElement(elementId), instance)
        Next
    Next
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

InstanceVoidCutUtils Class


InsulationLiningBase Class

Acts as the base class for duct insulation, pipe insulation and duct lining elements.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBHostObject
Autodesk.Revit.DBMEPCurve
Autodesk.Revit.DBInsulationLiningBase
Autodesk.Revit.DB.MechanicalDuctInsulation
Autodesk.Revit.DB.MechanicalDuctLining
Autodesk.Revit.DB.PlumbingPipeInsulation

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class InsulationLiningBase : MEPCurve
Public Class InsulationLiningBase
    Inherits MEPCurve
public ref class InsulationLiningBase : public MEPCurve
type InsulationLiningBase =
    class
        inherit MEPCurve
    end

The InsulationLiningBase type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Diameter | The diameter of the MEP curve. (Inherited from MEPCurve)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | Height | The height of the MEP curve. (Inherited from MEPCurve)
Public property | HostElementId | The id of the host element for the insulation or lining element.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | MEPSystem | The system of the MEP curve. (Inherited from MEPCurve)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve)
Public property | Thickness | Thickness of the insulation or lining element.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | Width | The width of the MEP curve. (Inherited from MEPCurve)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
 | GetInsulationIds | Returns the ids of the insulation elements associated to a given element.
 | GetLiningIds | Returns the ids of the lining elements associated to a given element.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
 | IsValidThickness | Identifies if the given thickness value is valid for assignment to insulation or lining elements.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


InsulationLiningBase Properties

The InsulationLiningBase type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Diameter | The diameter of the MEP curve. (Inherited from MEPCurve)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | Height | The height of the MEP curve. (Inherited from MEPCurve)
Public property | HostElementId | The id of the host element for the insulation or lining element.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | MEPSystem | The system of the MEP curve. (Inherited from MEPCurve)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve)
Public property | Thickness | Thickness of the insulation or lining element.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | Width | The width of the MEP curve. (Inherited from MEPCurve)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

InsulationLiningBase Class


InsulationLiningBase.HostElementId Property

InsulationLiningBaseHostElementId Property

The id of the host element for the insulation or lining element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId HostElementId { get; }
Public ReadOnly Property HostElementId As ElementId
    Get
public:
property ElementId^ HostElementId {
    ElementId^ get ();
}
member HostElementId : ElementId with get

Property Value

ElementId
See Also

Reference

InsulationLiningBase Class


InsulationLiningBase.Thickness Property

InsulationLiningBaseThickness Property

Thickness of the insulation or lining element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Thickness { get; set; }
Public Property Thickness As Double
    Get
    Set
public:
property double Thickness {
    double get ();
    void set (double value);
}
member Thickness : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentException | When setting this property: Thickness is not valid for assignment to insulation or lining elements.
See Also

Reference

InsulationLiningBase Class


InsulationLiningBase Methods

The InsulationLiningBase type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
 | GetInsulationIds | Returns the ids of the insulation elements associated to a given element.
 | GetLiningIds | Returns the ids of the lining elements associated to a given element.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
 | IsValidThickness | Identifies if the given thickness value is valid for assignment to insulation or lining elements.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

InsulationLiningBase Class


InsulationLiningBase.GetInsulationIds Method

InsulationLiningBaseGetInsulationIds Method

Returns the ids of the insulation elements associated to a given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ICollection<ElementId> GetInsulationIds(
    Document document,
    ElementId elemId
)
Public Shared Function GetInsulationIds (
    document As Document,
    elemId As ElementId
) As ICollection(Of ElementId)
public:
static ICollection<ElementId^>^ GetInsulationIds(
    Document^ document,
    ElementId^ elemId
)
static member GetInsulationIds :
        document : Document *
        elemId : ElementId -> ICollection<ElementId>

Parameters

document Document
The document.
elemId ElementId
The element.

Return Value

ICollection ElementId
A collection of the ids of the insulation elements.
Exceptions
Exception | Condition
ArgumentException | This id does not represent a valid host for insulation.
ArgumentNullException | A non-optional argument was null
See Also

Reference

InsulationLiningBase Class


InsulationLiningBase.GetLiningIds Method

InsulationLiningBaseGetLiningIds Method

Returns the ids of the lining elements associated to a given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ICollection<ElementId> GetLiningIds(
    Document document,
    ElementId elemId
)
Public Shared Function GetLiningIds (
    document As Document,
    elemId As ElementId
) As ICollection(Of ElementId)
public:
static ICollection<ElementId^>^ GetLiningIds(
    Document^ document,
    ElementId^ elemId
)
static member GetLiningIds :
        document : Document *
        elemId : ElementId -> ICollection<ElementId>

Parameters

document Document
The document.
elemId ElementId
The element.

Return Value

ICollection ElementId
A collection of the ids of the lining elements.
Exceptions
Exception | Condition
ArgumentException | This id does not represent a duct, fitting, or accessory element.
ArgumentNullException | A non-optional argument was null
See Also

Reference

InsulationLiningBase Class


InsulationLiningBase.IsValidThickness Method

InsulationLiningBaseIsValidThickness Method

Identifies if the given thickness value is valid for assignment to insulation or lining elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidThickness(
    double thickness
)
Public Shared Function IsValidThickness (
    thickness As Double
) As Boolean
public:
static bool IsValidThickness(
    double thickness
)
static member IsValidThickness :
        thickness : float -> bool

Parameters

thickness Double
Thickness of the insulation and lining elements.

Return Value

Boolean
True if the thickness is valid, false otherwise.
See Also

Reference

InsulationLiningBase Class


IntegerParameterValue Class

A class that holds an Integer value of a parameter element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBParameterValue
Autodesk.Revit.DBIntegerParameterValue

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class IntegerParameterValue : ParameterValue
Public Class IntegerParameterValue
    Inherits ParameterValue
public ref class IntegerParameterValue : public ParameterValue
type IntegerParameterValue =
    class
        inherit ParameterValue
    end

The IntegerParameterValue type exposes the following members.

Constructors
 | Name | Description
Public method | IntegerParameterValue | Default constructor
Public method | IntegerParameterValue(Int32) | Value constructor
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ParameterValue)
Public property | Value | The stored value
Top
Methods
 | Name | Description
Public method | Copy | Makes an identical copy of the given parameter value. (Inherited from ParameterValue)
Public method | Dispose | (Inherited from ParameterValue)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqual | Tests equality with another instance of the same class. (Inherited from ParameterValue)
Public method | IsSameType | Tests another instance is of the same value type. (Inherited from ParameterValue)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


IntegerParameterValue Constructor

Overload List
 | Name | Description
Public method | IntegerParameterValue | Default constructor
Public method | IntegerParameterValue(Int32) | Value constructor
Top
See Also

Reference

IntegerParameterValue Class


IntegerParameterValue Constructor

Default constructor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IntegerParameterValue()
Public Sub New
public:
IntegerParameterValue()
new : unit -> IntegerParameterValue
See Also

Reference

IntegerParameterValue Class
IntegerParameterValue Overload


IntegerParameterValue(Int32) Constructor

Value constructor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IntegerParameterValue(
    int value
)
Public Sub New (
    value As Integer
)
public:
IntegerParameterValue(
    int value
)
new :
        value : int -> IntegerParameterValue

Parameters

value Int32
See Also

Reference

IntegerParameterValue Class
IntegerParameterValue Overload


IntegerParameterValue Properties

The IntegerParameterValue type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ParameterValue)
Public property | Value | The stored value
Top
See Also

Reference

IntegerParameterValue Class


IntegerParameterValue.Value Property

IntegerParameterValueValue Property

The stored value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Value { get; set; }
Public Property Value As Integer
    Get
    Set
public:
property int Value {
    int get ();
    void set (int value);
}
member Value : int with get, set

Property Value

Int32
See Also

Reference

IntegerParameterValue Class


IntegerParameterValue Methods

The IntegerParameterValue type exposes the following members.

Methods
 | Name | Description
Public method | Copy | Makes an identical copy of the given parameter value. (Inherited from ParameterValue)
Public method | Dispose | (Inherited from ParameterValue)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqual | Tests equality with another instance of the same class. (Inherited from ParameterValue)
Public method | IsSameType | Tests another instance is of the same value type. (Inherited from ParameterValue)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

IntegerParameterValue Class


IntegerRange Class

A class to define a range of a sequence of consecutive integer numbers
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBIntegerRange

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class IntegerRange : IDisposable
Public Class IntegerRange
    Implements IDisposable
public ref class IntegerRange : IDisposable
type IntegerRange =
    class
        interface IDisposable
    end

The IntegerRange type exposes the following members.

Properties
 | Name | Description
Public property | High | The upper limit of the range
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Low | The lower limit of the range
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the IntegerRange
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


IntegerRange Properties

The IntegerRange type exposes the following members.

Properties
 | Name | Description
Public property | High | The upper limit of the range
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Low | The lower limit of the range
Top
See Also

Reference

IntegerRange Class


IntegerRange.High Property

IntegerRangeHigh Property

The upper limit of the range

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int High { get; }
Public ReadOnly Property High As Integer
    Get
public:
property int High {
    int get ();
}
member High : int with get

Property Value

Int32
See Also

Reference

IntegerRange Class


IntegerRange.IsValidObject Property

IntegerRangeIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

IntegerRange Class


IntegerRange.Low Property

IntegerRangeLow Property

The lower limit of the range

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Low { get; }
Public ReadOnly Property Low As Integer
    Get
public:
property int Low {
    int get ();
}
member Low : int with get

Property Value

Int32
See Also

Reference

IntegerRange Class


IntegerRange Methods

The IntegerRange type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

IntegerRange Class


IntegerRange.Dispose Method

IntegerRangeDispose Method

Releases all resources used by the IntegerRange

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

IntegerRange Class


InternalDefinition Class

This object represents a parameter definition in an Autodesk Revit model.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBDefinition
Autodesk.Revit.DBInternalDefinition

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class InternalDefinition : Definition,
    IDisposable
Public Class InternalDefinition
    Inherits Definition
    Implements IDisposable
public ref class InternalDefinition : public Definition,
    IDisposable
type InternalDefinition =
    class
        inherit Definition
        interface IDisposable
    end

The InternalDefinition type exposes the following members.

Properties
 | Name | Description
Public property | BuiltInParameter | Tests whether this definition identifies a built-in parameter or not.
Public property | Id | The id of the parameter.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The user-visible name for the parameter. (Overrides DefinitionName)
Public property | VariesAcrossGroups | Whether or not the parameter values can vary across group members.
Public property | Visible | Indicates if the parameter is visible in the Autodesk Revit user interface.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the InternalDefinition
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | GetDataType | Gets a ForgeTypeId identifying the data type describing values of the parameter. (Inherited from Definition)
Public method | GetGroupTypeId | Gets the identifier of the built-in parameter group to which the parameter defined by this definition belongs. (Overrides DefinitionGetGroupTypeId)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetParameterTypeId | Tests whether this definition identifies a built-in parameter or not.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeId | Gets the identifier of the parameter.
Public method | SetAllowVaryBetweenGroups | Whether or not the parameter values can vary across group members.
Public method | SetGroupTypeId | Sets the built-in parameter group to which the parameter defined by this definition belongs.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


InternalDefinition Properties

The InternalDefinition type exposes the following members.

Properties
 | Name | Description
Public property | BuiltInParameter | Tests whether this definition identifies a built-in parameter or not.
Public property | Id | The id of the parameter.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | The user-visible name for the parameter. (Overrides DefinitionName)
Public property | VariesAcrossGroups | Whether or not the parameter values can vary across group members.
Public property | Visible | Indicates if the parameter is visible in the Autodesk Revit user interface.
Top
See Also

Reference

InternalDefinition Class


InternalDefinition.BuiltInParameter Property

InternalDefinitionBuiltInParameter Property

Tests whether this definition identifies a built-in parameter or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BuiltInParameter BuiltInParameter { get; }
Public ReadOnly Property BuiltInParameter As BuiltInParameter
    Get
public:
property BuiltInParameter BuiltInParameter {
    BuiltInParameter get ();
}
member BuiltInParameter : BuiltInParameter with get

Property Value

BuiltInParameter
Remarks
For a build-in parameter this property equals one of the BuiltInParameter enumerated values. For custom-defined parameters, such as shared, global, or family parameters the value is always BuiltInParameter.INVALID.
See Also

Reference

InternalDefinition Class


InternalDefinition.Id Property

InternalDefinitionId Property

The id of the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId Id { get; }
Public ReadOnly Property Id As ElementId
    Get
public:
property ElementId^ Id {
    ElementId^ get ();
}
member Id : ElementId with get

Property Value

ElementId
See Also

Reference

InternalDefinition Class


InternalDefinition.IsValidObject Property

InternalDefinitionIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

InternalDefinition Class


InternalDefinition.Name Property

InternalDefinitionName Property

The user-visible name for the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string Name { get; }
Public Overrides ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () override;
}
abstract Name : string with get
override Name : string with get

Property Value

String
See Also

Reference

InternalDefinition Class


InternalDefinition.VariesAcrossGroups Property

InternalDefinitionVariesAcrossGroups Property

Whether or not the parameter values can vary across group members.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool VariesAcrossGroups { get; }
Public ReadOnly Property VariesAcrossGroups As Boolean
    Get
public:
property bool VariesAcrossGroups {
    bool get ();
}
member VariesAcrossGroups : bool with get

Property Value

Boolean
True if the values of this parameter can vary across the related members of group instances. False if the values will be consistent across the related members in group instances.
See Also

Reference

InternalDefinition Class


InternalDefinition.Visible Property

InternalDefinitionVisible Property

Indicates if the parameter is visible in the Autodesk Revit user interface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Visible { get; }
Public Overridable ReadOnly Property Visible As Boolean
    Get
public:
virtual property bool Visible {
    bool get ();
}
abstract Visible : bool with get
override Visible : bool with get

Property Value

Boolean
Remarks
The visible property controls whether a shared parameter is hidden from the user. This is useful if you wish to add data to an element that is only meaningful to your application and not to the user. This value can only be set when the shared parameter definition is created.
See Also

Reference

InternalDefinition Class


InternalDefinition Methods

The InternalDefinition type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | GetDataType | Gets a ForgeTypeId identifying the data type describing values of the parameter. (Inherited from Definition)
Public method | GetGroupTypeId | Gets the identifier of the built-in parameter group to which the parameter defined by this definition belongs. (Overrides DefinitionGetGroupTypeId)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetParameterTypeId | Tests whether this definition identifies a built-in parameter or not.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeId | Gets the identifier of the parameter.
Public method | SetAllowVaryBetweenGroups | Whether or not the parameter values can vary across group members.
Public method | SetGroupTypeId | Sets the built-in parameter group to which the parameter defined by this definition belongs.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

InternalDefinition Class


InternalDefinition.Dispose Method

InternalDefinitionDispose Method

Releases all resources used by the InternalDefinition

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

InternalDefinition Class


InternalDefinition.GetGroupTypeId Method

InternalDefinitionGetGroupTypeId Method

Gets the identifier of the built-in parameter group to which the parameter defined by this definition belongs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ForgeTypeId GetGroupTypeId()
Public Overrides Function GetGroupTypeId As ForgeTypeId
public:
virtual ForgeTypeId^ GetGroupTypeId() override
abstract GetGroupTypeId : unit -> ForgeTypeId
override GetGroupTypeId : unit -> ForgeTypeId

Return Value

ForgeTypeId
See Also

Reference

InternalDefinition Class


InternalDefinition.GetParameterTypeId Method

InternalDefinitionGetParameterTypeId Method

Tests whether this definition identifies a built-in parameter or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ForgeTypeId GetParameterTypeId()
Public Function GetParameterTypeId As ForgeTypeId
public:
ForgeTypeId^ GetParameterTypeId()
member GetParameterTypeId : unit -> ForgeTypeId

Return Value

ForgeTypeId
Remarks
For a built-in parameter this method returns one of the ParameterTypeId static properties. For custom-defined parameters, such as shared, global, or family parameters the value is null.
See Also

Reference

InternalDefinition Class


InternalDefinition.GetTypeId Method

InternalDefinitionGetTypeId Method

Gets the identifier of the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ForgeTypeId GetTypeId()
Public Function GetTypeId As ForgeTypeId
public:
ForgeTypeId^ GetTypeId()
member GetTypeId : unit -> ForgeTypeId

Return Value

ForgeTypeId
See Also

Reference

InternalDefinition Class


InternalDefinition.SetAllowVaryBetweenGroups Method

InternalDefinitionSetAllowVaryBetweenGroups Method

Whether or not the parameter values can vary across group members.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> SetAllowVaryBetweenGroups(
    Document document,
    bool allowVaryBetweenGroups
)
Public Function SetAllowVaryBetweenGroups (
    document As Document,
    allowVaryBetweenGroups As Boolean
) As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ SetAllowVaryBetweenGroups(
    Document^ document,
    bool allowVaryBetweenGroups
)
member SetAllowVaryBetweenGroups :
        document : Document *
        allowVaryBetweenGroups : bool -> ICollection<ElementId>

Parameters

document Document
The document of this parameter.
allowVaryBetweenGroups Boolean
Whether this parameter should be allowed to vary between groups.

Return Value

ICollection ElementId
The ids of elements that were updated to align the values between groups.
Exceptions
Exception | Condition
ArgumentException | This parameter does not support the specified value of allowVaryBetweenGroups. -or- document is not a project document.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
When a parameter is set to not vary between groups Revit will automatically align the parameter values of any elements that actually varied between group instances.
See Also

Reference

InternalDefinition Class


InternalDefinition.SetGroupTypeId Method

InternalDefinitionSetGroupTypeId Method

Sets the built-in parameter group to which the parameter defined by this definition belongs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetGroupTypeId(
    ForgeTypeId groupTypeId
)
Public Sub SetGroupTypeId (
    groupTypeId As ForgeTypeId
)
public:
void SetGroupTypeId(
    ForgeTypeId^ groupTypeId
)
member SetGroupTypeId :
        groupTypeId : ForgeTypeId -> unit

Parameters

groupTypeId ForgeTypeId
Identifier of the built-in parameter group.
Remarks
The parameter group can be changed, but only for parameters that are not built in. In other words: This method is only valid for parameter definitions for which GetParameterTypeId() returns a null identifier.
See Also

Reference

InternalDefinition Class


InternalDefinitions Class

This object blocks attempts to create new internal definitions as they are not permitted.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBDefinitions
Autodesk.Revit.DBInternalDefinitions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class InternalDefinitions : Definitions
Public Class InternalDefinitions
    Inherits Definitions
public ref class InternalDefinitions : public Definitions
type InternalDefinitions =
    class
        inherit Definitions
    end

The InternalDefinitions type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Identifies if the definitions collection is empty. (Inherited from Definitions)
Public property | Item | Retrieves a definition by a given name. (Inherited from Definitions)
Public property | Size | The number of definitions in the collection. (Inherited from Definitions)
Top
Methods
 | Name | Description
Public method | Contains | Tests for the existence of a definition within the set. (Inherited from Definitions)
Public method | Create | Creates a new parameter definition using specified options. (Inherited from Definitions)
Public method | Dispose | (Inherited from Definitions)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Definitions)
Public method | GetEnumerator | Retrieves an enumerator to the collection. (Inherited from Definitions)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


InternalDefinitions Properties

The InternalDefinitions type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Identifies if the definitions collection is empty. (Inherited from Definitions)
Public property | Item | Retrieves a definition by a given name. (Inherited from Definitions)
Public property | Size | The number of definitions in the collection. (Inherited from Definitions)
Top
See Also

Reference

InternalDefinitions Class


InternalDefinitions Methods

The InternalDefinitions type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Tests for the existence of a definition within the set. (Inherited from Definitions)
Public method | Create | Creates a new parameter definition using specified options. (Inherited from Definitions)
Public method | Dispose | (Inherited from Definitions)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Definitions)
Public method | GetEnumerator | Retrieves an enumerator to the collection. (Inherited from Definitions)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

InternalDefinitions Class


InternalOrigin Class

A class representing the origin of internal coordinate system. Each Revit project contains one InternalOrigin.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBInternalOrigin

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class InternalOrigin : Element
Public Class InternalOrigin
    Inherits Element
public ref class InternalOrigin : public Element
type InternalOrigin =
    class
        inherit Element
    end

The InternalOrigin type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Position | The position of the InternalOrigin.
Public property | SharedPosition | The position of the InternalOrigin relative to the active ProjectLocation set for the document.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
 | Get | Gets the internal origin for the document.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The internal origin cannot be selected (e.g. as a reference) nor can it be modified.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


InternalOrigin Properties

The InternalOrigin type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Position | The position of the InternalOrigin.
Public property | SharedPosition | The position of the InternalOrigin relative to the active ProjectLocation set for the document.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

InternalOrigin Class


InternalOrigin.Position Property

InternalOriginPosition Property

The position of the InternalOrigin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Position { get; }
Public ReadOnly Property Position As XYZ
    Get
public:
property XYZ^ Position {
    XYZ^ get ();
}
member Position : XYZ with get

Property Value

XYZ
See Also

Reference

InternalOrigin Class


InternalOrigin.SharedPosition Property

InternalOriginSharedPosition Property

The position of the InternalOrigin relative to the active ProjectLocation set for the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ SharedPosition { get; }
Public ReadOnly Property SharedPosition As XYZ
    Get
public:
property XYZ^ SharedPosition {
    XYZ^ get ();
}
member SharedPosition : XYZ with get

Property Value

XYZ
See Also

Reference

InternalOrigin Class


InternalOrigin Methods

The InternalOrigin type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
 | Get | Gets the internal origin for the document.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

InternalOrigin Class


InternalOrigin.Get Method

InternalOriginGet Method

Gets the internal origin for the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static InternalOrigin Get(
    Document document
)
Public Shared Function Get (
    document As Document
) As InternalOrigin
public:
static InternalOrigin^ Get(
    Document^ document
)
static member Get :
        document : Document -> InternalOrigin

Parameters

document Document
Revit document from which to get the internal origin.

Return Value

InternalOrigin
The internal origin of the document.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

InternalOrigin Class


IntersectingElementData Class

Stores information of an element that intersects with another element
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBIntersectingElementData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class IntersectingElementData : IDisposable
Public Class IntersectingElementData
    Implements IDisposable
public ref class IntersectingElementData : IDisposable
type IntersectingElementData =
    class
        interface IDisposable
    end

The IntersectingElementData type exposes the following members.

Properties
 | Name | Description
Public property | IntersectedElementId | Id of the intersected element.
Public property | IntersectingElementId | Id of the intersecting element.
Public property | IntersectionType | The intersection type.
Public property | IntersectionVolume | The intersection volume.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the IntersectingElementData
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


IntersectingElementData Properties

The IntersectingElementData type exposes the following members.

Properties
 | Name | Description
Public property | IntersectedElementId | Id of the intersected element.
Public property | IntersectingElementId | Id of the intersecting element.
Public property | IntersectionType | The intersection type.
Public property | IntersectionVolume | The intersection volume.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

IntersectingElementData Class


IntersectingElementData.IntersectedElementId Property

IntersectingElementDataIntersectedElementId Property

Id of the intersected element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId IntersectedElementId { get; }
Public ReadOnly Property IntersectedElementId As ElementId
    Get
public:
property ElementId^ IntersectedElementId {
    ElementId^ get ();
}
member IntersectedElementId : ElementId with get

Property Value

ElementId
See Also

Reference

IntersectingElementData Class


IntersectingElementData.IntersectingElementId Property

IntersectingElementDataIntersectingElementId Property

Id of the intersecting element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId IntersectingElementId { get; }
Public ReadOnly Property IntersectingElementId As ElementId
    Get
public:
property ElementId^ IntersectingElementId {
    ElementId^ get ();
}
member IntersectingElementId : ElementId with get

Property Value

ElementId
See Also

Reference

IntersectingElementData Class


IntersectingElementData.IntersectionType Property

IntersectingElementDataIntersectionType Property

The intersection type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IntersectionType IntersectionType { get; }
Public ReadOnly Property IntersectionType As IntersectionType
    Get
public:
property IntersectionType IntersectionType {
    IntersectionType get ();
}
member IntersectionType : IntersectionType with get

Property Value

IntersectionType
See Also

Reference

IntersectingElementData Class


IntersectingElementData.IntersectionVolume Property

IntersectingElementDataIntersectionVolume Property

The intersection volume.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double IntersectionVolume { get; }
Public ReadOnly Property IntersectionVolume As Double
    Get
public:
property double IntersectionVolume {
    double get ();
}
member IntersectionVolume : float with get

Property Value

Double
See Also

Reference

IntersectingElementData Class


IntersectingElementData.IsValidObject Property

IntersectingElementDataIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

IntersectingElementData Class


IntersectingElementData Methods

The IntersectingElementData type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

IntersectingElementData Class


IntersectingElementData.Dispose Method

IntersectingElementDataDispose Method

Releases all resources used by the IntersectingElementData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

IntersectingElementData Class


IntersectionResult Class

This class captures results of intersecting geometric entities. "Intersecting" is meant in generalized sense, so the same class will be used for projection, containment, etc. Refer to the documentation of the method providing the result for the precise meaning of properties.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBIntersectionResult

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class IntersectionResult : APIObject
Public Class IntersectionResult
    Inherits APIObject
public ref class IntersectionResult : public APIObject
type IntersectionResult =
    class
        inherit APIObject
    end

The IntersectionResult type exposes the following members.

Constructors
 | Name | Description
Public method | IntersectionResult | Initializes a new instance of the IntersectionResult class
Top
Properties
 | Name | Description
Public property | Distance | Distance from the original object to located point.
Public property | EdgeObject | Edge of the face close to the point of intersection.
Public property | EdgeParameter | Parameter of a point on the edge closest to the point of intersection.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Parameter | 1d parameter of the point of intersection.
Public property | UVPoint | 2d (or two 1d) parameters of the point of intersection.
Public property | XYZPoint | Point of intersection in local 3d coordinates.
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


IntersectionResult Constructor

Initializes a new instance of the IntersectionResult class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IntersectionResult()
Public Sub New
public:
IntersectionResult()
new : unit -> IntersectionResult
See Also

Reference

IntersectionResult Class


IntersectionResult Properties

The IntersectionResult type exposes the following members.

Properties
 | Name | Description
Public property | Distance | Distance from the original object to located point.
Public property | EdgeObject | Edge of the face close to the point of intersection.
Public property | EdgeParameter | Parameter of a point on the edge closest to the point of intersection.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Parameter | 1d parameter of the point of intersection.
Public property | UVPoint | 2d (or two 1d) parameters of the point of intersection.
Public property | XYZPoint | Point of intersection in local 3d coordinates.
Top
See Also

Reference

IntersectionResult Class


IntersectionResult.Distance Property

IntersectionResultDistance Property

Distance from the original object to located point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Distance { get; }
Public ReadOnly Property Distance As Double
    Get
public:
property double Distance {
    double get ();
}
member Distance : float with get

Property Value

Double
Exceptions
Exception | Condition
InvalidOperationException | Thrown in the getter when this property has not been set by the method providing the result.
See Also

Reference

IntersectionResult Class


IntersectionResult.EdgeObject Property

IntersectionResultEdgeObject Property

Edge of the face close to the point of intersection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Edge EdgeObject { get; }
Public ReadOnly Property EdgeObject As Edge
    Get
public:
property Edge^ EdgeObject {
    Edge^ get ();
}
member EdgeObject : Edge with get

Property Value

Edge
Exceptions
Exception | Condition
InvalidOperationException | Thrown in the getter when this property has not been set by the method providing the result.
See Also

Reference

IntersectionResult Class


IntersectionResult.EdgeParameter Property

IntersectionResultEdgeParameter Property

Parameter of a point on the edge closest to the point of intersection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double EdgeParameter { get; }
Public ReadOnly Property EdgeParameter As Double
    Get
public:
property double EdgeParameter {
    double get ();
}
member EdgeParameter : float with get

Property Value

Double
Exceptions
Exception | Condition
InvalidOperationException | Thrown in the getter when this property has not been set by the method providing the result.
See Also

Reference

IntersectionResult Class


IntersectionResult.Parameter Property

IntersectionResultParameter Property

1d parameter of the point of intersection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Parameter { get; }
Public ReadOnly Property Parameter As Double
    Get
public:
property double Parameter {
    double get ();
}
member Parameter : float with get

Property Value

Double
Exceptions
Exception | Condition
InvalidOperationException | Thrown in the getter when this property has not been set by the method providing the result.
See Also

Reference

IntersectionResult Class


IntersectionResult.UVPoint Property

IntersectionResultUVPoint Property

2d (or two 1d) parameters of the point of intersection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public UV UVPoint { get; }
Public ReadOnly Property UVPoint As UV
    Get
public:
property UV^ UVPoint {
    UV^ get ();
}
member UVPoint : UV with get

Property Value

UV
Exceptions
Exception | Condition
InvalidOperationException | Thrown in the getter when this property has not been set by the method providing the result.
See Also

Reference

IntersectionResult Class


IntersectionResult.XYZPoint Property

IntersectionResultXYZPoint Property

Point of intersection in local 3d coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ XYZPoint { get; }
Public ReadOnly Property XYZPoint As XYZ
    Get
public:
property XYZ^ XYZPoint {
    XYZ^ get ();
}
member XYZPoint : XYZ with get

Property Value

XYZ
Exceptions
Exception | Condition
InvalidOperationException | Thrown in the getter when this property has not been set by the method providing the result.
See Also

Reference

IntersectionResult Class


IntersectionResult Methods

The IntersectionResult type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

IntersectionResult Class


IntersectionResultArray Class

An array that can contain any type of object.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBIntersectionResultArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class IntersectionResultArray : APIObject,
    IEnumerable
Public Class IntersectionResultArray
    Inherits APIObject
    Implements IEnumerable
public ref class IntersectionResultArray : public APIObject,
    IEnumerable
type IntersectionResultArray =
    class
        inherit APIObject
        interface IEnumerable
    end

The IntersectionResultArray type exposes the following members.

Constructors
 | Name | Description
Public method | IntersectionResultArray | Initializes a new instance of the IntersectionResultArray class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.
Top
Methods
 | Name | Description
Public method | Append |
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


IntersectionResultArray Constructor

Initializes a new instance of the IntersectionResultArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IntersectionResultArray()
Public Sub New
public:
IntersectionResultArray()
new : unit -> IntersectionResultArray
See Also

Reference

IntersectionResultArray Class


IntersectionResultArray Properties

The IntersectionResultArray type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.
Top
See Also

Reference

IntersectionResultArray Class


IntersectionResultArray.IsEmpty Property

IntersectionResultArrayIsEmpty Property

Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Boolean
Remarks
If the array is empty then True will be returned, otherwise False.
See Also

Reference

IntersectionResultArray Class


IntersectionResultArray.Item Property

IntersectionResultArrayItem Property

Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IntersectionResult this[
    int index
] { get; set; }
Public Overridable Property Item (
    index As Integer
) As IntersectionResult
    Get
    Set
public:
virtual property IntersectionResult^ Item[int index] {
    IntersectionResult^ get (int index);
    void set (int index, IntersectionResult^ value);
}
abstract Item : IntersectionResult with get, set
override Item : IntersectionResult with get, set

Parameters

index Int32
The index of the item to be set or retrieved.

Return Value

IntersectionResult
Returns the object at the specified index.
See Also

Reference

IntersectionResultArray Class


IntersectionResultArray.Size Property

IntersectionResultArraySize Property

Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
abstract Size : int with get
override Size : int with get

Property Value

Int32
See Also

Reference

IntersectionResultArray Class


IntersectionResultArray Methods

The IntersectionResultArray type exposes the following members.

Methods
 | Name | Description
Public method | Append |
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

IntersectionResultArray Class


IntersectionResultArray.Append Method

IntersectionResultArrayAppend Method

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Append(
    IntersectionResult item
)
Public Overridable Sub Append (
    item As IntersectionResult
)
public:
virtual void Append(
    IntersectionResult^ item
)
abstract Append :
        item : IntersectionResult -> unit
override Append :
        item : IntersectionResult -> unit

Parameters

item IntersectionResult
See Also

Reference

IntersectionResultArray Class


IntersectionResultArray.Clear Method

IntersectionResultArrayClear Method

Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

IntersectionResultArray Class


IntersectionResultArray.ForwardIterator Method

IntersectionResultArrayForwardIterator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IntersectionResultArrayIterator ForwardIterator()
Public Overridable Function ForwardIterator As IntersectionResultArrayIterator
public:
virtual IntersectionResultArrayIterator^ ForwardIterator()
abstract ForwardIterator : unit -> IntersectionResultArrayIterator
override ForwardIterator : unit -> IntersectionResultArrayIterator

Return Value

IntersectionResultArrayIterator
Returns a forward moving iterator to the array.
See Also

Reference

IntersectionResultArray Class


IntersectionResultArray.GetEnumerator Method

IntersectionResultArrayGetEnumerator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

IEnumerator
Returns a forward moving iterator to the array.

Implements

IEnumerableGetEnumerator
See Also

Reference

IntersectionResultArray Class


IntersectionResultArray.Insert Method

IntersectionResultArrayInsert Method

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Insert(
    IntersectionResult item,
    int index
)
Public Overridable Sub Insert (
    item As IntersectionResult,
    index As Integer
)
public:
virtual void Insert(
    IntersectionResult^ item,
    int index
)
abstract Insert :
        item : IntersectionResult *
        index : int -> unit
override Insert :
        item : IntersectionResult *
        index : int -> unit

Parameters

item IntersectionResult
index Int32
See Also

Reference

IntersectionResultArray Class


IntersectionResultArray.ReverseIterator Method

IntersectionResultArrayReverseIterator Method

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IntersectionResultArrayIterator ReverseIterator()
Public Overridable Function ReverseIterator As IntersectionResultArrayIterator
public:
virtual IntersectionResultArrayIterator^ ReverseIterator()
abstract ReverseIterator : unit -> IntersectionResultArrayIterator
override ReverseIterator : unit -> IntersectionResultArrayIterator

Return Value

IntersectionResultArrayIterator
Returns a backward moving iterator to the array.
See Also

Reference

IntersectionResultArray Class


IntersectionResultArrayIterator Class

An iterator to a array.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBIntersectionResultArrayIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class IntersectionResultArrayIterator : APIObject,
    IEnumerator
Public MustInherit Class IntersectionResultArrayIterator
    Inherits APIObject
    Implements IEnumerator
public ref class IntersectionResultArrayIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type IntersectionResultArrayIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The IntersectionResultArrayIterator type exposes the following members.

Constructors
 | Name | Description
Public method | IntersectionResultArrayIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


IntersectionResultArrayIterator Constructor

For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IntersectionResultArrayIterator()
Public Sub New
public:
IntersectionResultArrayIterator()
new : unit -> IntersectionResultArrayIterator
Remarks
This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.
See Also

Reference

IntersectionResultArrayIterator Class


IntersectionResultArrayIterator Properties

The IntersectionResultArrayIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

IntersectionResultArrayIterator Class


IntersectionResultArrayIterator.Current Property

IntersectionResultArrayIteratorCurrent Property

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}
abstract Current : Object with get
override Current : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.
See Also

Reference

IntersectionResultArrayIterator Class


IntersectionResultArrayIterator Methods

The IntersectionResultArrayIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

IntersectionResultArrayIterator Class


IntersectionResultArrayIterator.MoveNext Method

IntersectionResultArrayIteratorMoveNext Method

Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumeratorMoveNext
Remarks
MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.
See Also

Reference

IntersectionResultArrayIterator Class


IntersectionResultArrayIterator.Reset Method

IntersectionResultArrayIteratorReset Method

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
Remarks
The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.
See Also

Reference

IntersectionResultArrayIterator Class


IntersectionType Enumeration

Intersection type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum IntersectionType
Public Enumeration IntersectionType
public enum class IntersectionType
type IntersectionType
Members
Member name | Value | Description
Cut | 0 | Cut
Excavate | 1 | Excavate
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


IOnLocalLinkSharedCoordinatesSavedCallback Interface

A callback for notifying an IExternalResourceServer that shared coordinates changes have been saved back to one of the Revit or DWG links provided by that server.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IOnLocalLinkSharedCoordinatesSavedCallback
Public Interface IOnLocalLinkSharedCoordinatesSavedCallback
public interface class IOnLocalLinkSharedCoordinatesSavedCallback
type IOnLocalLinkSharedCoordinatesSavedCallback = interface end

The IOnLocalLinkSharedCoordinatesSavedCallback type exposes the following members.

Methods
 | Name | Description
Public method | OnLocalLinkSharedCoordinatesSaved | Revit will call this method whenever shared coordinates changes are saved to a linked document provided by an IExternalResourceServer. This call is a notification to the server provider that one of their Revit or DWG links has changed locally, and they should upload the new version back to their server.
Top
Remarks
Revit will call OnLocalLinkSharedCoordinatesSaved whenever shared coordinates changes are saved to a linked document which is provided by an external server. This is a notification to the server provider so they can copy the updated link back up to their server.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


IOnLocalLinkSharedCoordinatesSavedCallback Methods

The IOnLocalLinkSharedCoordinatesSavedCallback type exposes the following members.

Methods
 | Name | Description
Public method | OnLocalLinkSharedCoordinatesSaved | Revit will call this method whenever shared coordinates changes are saved to a linked document provided by an IExternalResourceServer. This call is a notification to the server provider that one of their Revit or DWG links has changed locally, and they should upload the new version back to their server.
Top
See Also

Reference

IOnLocalLinkSharedCoordinatesSavedCallback Interface


IOnLocalLinkSharedCoordinatesSavedCallback.OnLocalLinkSharedCoordinatesSaved Method

IOnLocalLinkSharedCoordinatesSavedCallbackOnLocalLinkSharedCoordinatesSaved Method

Revit will call this method whenever shared coordinates changes are saved to a linked document provided by an IExternalResourceServer. This call is a notification to the server provider that one of their Revit or DWG links has changed locally, and they should upload the new version back to their server.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void OnLocalLinkSharedCoordinatesSaved(
    ExternalResourceReference changedResource
)
Sub OnLocalLinkSharedCoordinatesSaved (
    changedResource As ExternalResourceReference
)
void OnLocalLinkSharedCoordinatesSaved(
    ExternalResourceReference^ changedResource
)
abstract OnLocalLinkSharedCoordinatesSaved :
        changedResource : ExternalResourceReference -> unit

Parameters

changedResource ExternalResourceReference
The ExternalResourceReference whose shared coordinates have been saved.
See Also

Reference

IOnLocalLinkSharedCoordinatesSavedCallback Interface


IOpenFromCloudCallback Interface

An interface that may be used to control Revit's behavior when opening a cloud model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IOpenFromCloudCallback
Public Interface IOpenFromCloudCallback
public interface class IOpenFromCloudCallback
type IOpenFromCloudCallback = interface end

The IOpenFromCloudCallback type exposes the following members.

Methods
 | Name | Description
Public method | OnOpenConflict | A method called when the conflict is happen during the model opening.
Top
Example
C#
Copy
class OpenFromCloudCallback : IOpenFromCloudCallback
{
   public OpenConflictResult OnOpenConflict(OpenConflictScenario scenario)
   {
      switch (scenario)
      {
         case OpenConflictScenario.OutOfDate:
            // Continue to open the model so that I can save my local changes to the central model
            return OpenConflictResult.KeepLocalChanges;

         case OpenConflictScenario.VersionArchived:
            // My local model is far behind the central model, so discard my local changes regardless what they are
            return OpenConflictResult.DiscardLocalChangesAndOpenLatestVersion;

         case OpenConflictScenario.Relinquished:
         case OpenConflictScenario.Rollback:
            // Detach the loal model from its central model, to examine local changes
            return OpenConflictResult.DetachFromCentral;
      }

      return OpenConflictResult.Cancel;
   }
}

static Document OpenCloudModelWithCallback(Application application, ModelPath modelPath)
{
   OpenOptions options = new OpenOptions();
   OpenFromCloudCallback callback = new OpenFromCloudCallback();

   return application.OpenDocumentFile(modelPath, options, callback);
}
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


IOpenFromCloudCallback Methods

The IOpenFromCloudCallback type exposes the following members.

Methods
 | Name | Description
Public method | OnOpenConflict | A method called when the conflict is happen during the model opening.
Top
See Also

Reference

IOpenFromCloudCallback Interface


IOpenFromCloudCallback.OnOpenConflict Method

IOpenFromCloudCallbackOnOpenConflict Method

A method called when the conflict is happen during the model opening.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
OpenConflictResult OnOpenConflict(
    OpenConflictScenario scenario
)
Function OnOpenConflict (
    scenario As OpenConflictScenario
) As OpenConflictResult
OpenConflictResult OnOpenConflict(
    OpenConflictScenario scenario
)
abstract OnOpenConflict :
        scenario : OpenConflictScenario -> OpenConflictResult

Parameters

scenario OpenConflictScenario
The scenario of the conflict.

Return Value

OpenConflictResult
Returns the result to indicate whether to keep the unsynchronized change, or open the latest version or cancel the open action.
See Also

Reference

IOpenFromCloudCallback Interface


IPerformanceAdviserRule Interface

Base class to derive specific performance adviser rules from.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IPerformanceAdviserRule
Public Interface IPerformanceAdviserRule
public interface class IPerformanceAdviserRule
type IPerformanceAdviserRule = interface end

The IPerformanceAdviserRule type exposes the following members.

Methods
 | Name | Description
Public method | ExecuteElementCheck | Invoked by performance advisor for each element to be checked.
Public method | FinalizeCheck | Invoked by performance advisor once in the end of the check.
Public method | GetDescription | Retrieves the description of the rule.
Public method | GetElementFilter | Retrieves a filter to restrict elements to be checked.
Public method | GetName | Retrieves the name of the rule.
Public method | InitCheck | Invoked by performance advisor once in the beginning of the check. If rule checks document as a whole, the check can be performed in this method.
Public method | WillCheckElements | Reports if rule needs to be executed on individual elements.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


IPerformanceAdviserRule Methods

The IPerformanceAdviserRule type exposes the following members.

Methods
 | Name | Description
Public method | ExecuteElementCheck | Invoked by performance advisor for each element to be checked.
Public method | FinalizeCheck | Invoked by performance advisor once in the end of the check.
Public method | GetDescription | Retrieves the description of the rule.
Public method | GetElementFilter | Retrieves a filter to restrict elements to be checked.
Public method | GetName | Retrieves the name of the rule.
Public method | InitCheck | Invoked by performance advisor once in the beginning of the check. If rule checks document as a whole, the check can be performed in this method.
Public method | WillCheckElements | Reports if rule needs to be executed on individual elements.
Top
See Also

Reference

IPerformanceAdviserRule Interface


IPerformanceAdviserRule.ExecuteElementCheck Method

IPerformanceAdviserRuleExecuteElementCheck Method

Invoked by performance advisor for each element to be checked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void ExecuteElementCheck(
    Document document,
    Element element
)
Sub ExecuteElementCheck (
    document As Document,
    element As Element
)
void ExecuteElementCheck(
    Document^ document,
    Element^ element
)
abstract ExecuteElementCheck :
        document : Document *
        element : Element -> unit

Parameters

document Document
Document for which performance problems are being checked.
element Element
The Element being checked for performance problems.
See Also

Reference

IPerformanceAdviserRule Interface


IPerformanceAdviserRule.FinalizeCheck Method

IPerformanceAdviserRuleFinalizeCheck Method

Invoked by performance advisor once in the end of the check.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void FinalizeCheck(
    Document document
)
Sub FinalizeCheck (
    document As Document
)
void FinalizeCheck(
    Document^ document
)
abstract FinalizeCheck :
        document : Document -> unit

Parameters

document Document
Document for which performance problems are being checked.
See Also

Reference

IPerformanceAdviserRule Interface


IPerformanceAdviserRule.GetDescription Method

IPerformanceAdviserRuleGetDescription Method

Retrieves the description of the rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetDescription()
Function GetDescription As String
String^ GetDescription()
abstract GetDescription : unit -> string

Return Value

String
The description of the rule.
Remarks
Method should return a brief (one-two sentences) description of the rule. String should be localized.
See Also

Reference

IPerformanceAdviserRule Interface


IPerformanceAdviserRule.GetElementFilter Method

IPerformanceAdviserRuleGetElementFilter Method

Retrieves a filter to restrict elements to be checked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
ElementFilter GetElementFilter(
    Document document
)
Function GetElementFilter (
    document As Document
) As ElementFilter
ElementFilter^ GetElementFilter(
    Document^ document
)
abstract GetElementFilter :
        document : Document -> ElementFilter

Parameters

document Document
Document for which performance problems are being checked.

Return Value

ElementFilter
The filter to restrict elements to be checked.
Remarks
If the rule needs to be executed on individual elements, it should return a filter that defines what elements the rule should apply to. Otherwise, nothing (i.e. null) should be returned. If filter is returned, it should stay valid till the end of the check.
See Also

Reference

IPerformanceAdviserRule Interface


IPerformanceAdviserRule.GetName Method

IPerformanceAdviserRuleGetName Method

Retrieves the name of the rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetName()
Function GetName As String
String^ GetName()
abstract GetName : unit -> string

Return Value

String
The name of the rule.
Remarks
Method should return a short string naming the rule, typically as a one word in TitleCase. String should be localized.
See Also

Reference

IPerformanceAdviserRule Interface


IPerformanceAdviserRule.InitCheck Method

IPerformanceAdviserRuleInitCheck Method

Invoked by performance advisor once in the beginning of the check. If rule checks document as a whole, the check can be performed in this method.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void InitCheck(
    Document document
)
Sub InitCheck (
    document As Document
)
void InitCheck(
    Document^ document
)
abstract InitCheck :
        document : Document -> unit

Parameters

document Document
Document for which performance problems are being checked.
See Also

Reference

IPerformanceAdviserRule Interface


IPerformanceAdviserRule.WillCheckElements Method

IPerformanceAdviserRuleWillCheckElements Method

Reports if rule needs to be executed on individual elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool WillCheckElements()
Function WillCheckElements As Boolean
bool WillCheckElements()
abstract WillCheckElements : unit -> bool

Return Value

Boolean
True if rule needs to be executed on individual elements.
See Also

Reference

IPerformanceAdviserRule Interface


IPhotoRenderContext Interface

An interface that is used in custom export to render 3D views of a Revit model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IPhotoRenderContext : IExportContext
Public Interface IPhotoRenderContext
    Inherits IExportContext
public interface class IPhotoRenderContext : IExportContext
type IPhotoRenderContext =
    interface
        interface IExportContext
    end

The IPhotoRenderContext type exposes the following members.

Methods
 | Name | Description
Public method | Finish | This method is called at the very end of the export process, after all entities were processed (or after the process was cancelled). (Inherited from IExportContext)
Public method | IsCanceled | This method is queried at the beginning of every element. (Inherited from IExportContext)
 | OnElementBegin | This method marks the beginning of an element to be exported. (Inherited from IExportContext)
Public method | OnElementEnd | This method marks the end of an element being exported. (Inherited from IExportContext)
 | OnFaceBegin | This method marks the beginning of a Face to be exported. (Inherited from IExportContext)
Public method | OnFaceEnd | This method marks the end of the current face being exported. (Inherited from IExportContext)
 | OnInstanceBegin | This method marks the start of processing of an instance node (e.g. a family instance). (Inherited from IExportContext)
Public method | OnInstanceEnd | This method marks the end of processing of an Instance Node (e.g. a family instance). (Inherited from IExportContext)
 | OnLight | This method marks the beginning of export of a light which is enabled for rendering. (Inherited from IExportContext)
 | OnLinkBegin | This method marks the beginning of a link instance to be exported. (Inherited from IExportContext)
Public method | OnLinkEnd | This method marks the end of a link instance being exported. (Inherited from IExportContext)
 | OnMaterial | This method marks a change of the material. (Inherited from IExportContext)
 | OnPolymesh | This method is called when a tessellated polymesh of a 3d face is being output. (Inherited from IExportContext)
Public method | OnRPC | This method marks the beginning of export of an RPC object. (Inherited from IExportContext)
 | OnViewBegin | This method marks the beginning of a 3D view to be exported. (Inherited from IExportContext)
Public method | OnViewEnd | This method marks the end of a 3D view being exported. (Inherited from IExportContext)
 | Start | This method is called at the very start of the export process, still before the first entity of the model was send out. (Inherited from IExportContext)
Top
Remarks

An instance of a class that implements this interface is passed in as a parameter of the CustomExporter constructor. The interface methods are then called at times of rendering entities that are currently visible in the view being rendered.

With this type of export context used to perform a custom export, Revit will traverse the model and output the model's geometry as if processing the Render command invoked via the UI. It means that only such elements that have actual geometry and are suitable to appear in a rendered view will be processed and output.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


IPhotoRenderContext Methods

The IPhotoRenderContext type exposes the following members.

Methods
 | Name | Description
Public method | Finish | This method is called at the very end of the export process, after all entities were processed (or after the process was cancelled). (Inherited from IExportContext)
Public method | IsCanceled | This method is queried at the beginning of every element. (Inherited from IExportContext)
 | OnElementBegin | This method marks the beginning of an element to be exported. (Inherited from IExportContext)
Public method | OnElementEnd | This method marks the end of an element being exported. (Inherited from IExportContext)
 | OnFaceBegin | This method marks the beginning of a Face to be exported. (Inherited from IExportContext)
Public method | OnFaceEnd | This method marks the end of the current face being exported. (Inherited from IExportContext)
 | OnInstanceBegin | This method marks the start of processing of an instance node (e.g. a family instance). (Inherited from IExportContext)
Public method | OnInstanceEnd | This method marks the end of processing of an Instance Node (e.g. a family instance). (Inherited from IExportContext)
 | OnLight | This method marks the beginning of export of a light which is enabled for rendering. (Inherited from IExportContext)
 | OnLinkBegin | This method marks the beginning of a link instance to be exported. (Inherited from IExportContext)
Public method | OnLinkEnd | This method marks the end of a link instance being exported. (Inherited from IExportContext)
 | OnMaterial | This method marks a change of the material. (Inherited from IExportContext)
 | OnPolymesh | This method is called when a tessellated polymesh of a 3d face is being output. (Inherited from IExportContext)
Public method | OnRPC | This method marks the beginning of export of an RPC object. (Inherited from IExportContext)
 | OnViewBegin | This method marks the beginning of a 3D view to be exported. (Inherited from IExportContext)
Public method | OnViewEnd | This method marks the end of a 3D view being exported. (Inherited from IExportContext)
 | Start | This method is called at the very start of the export process, still before the first entity of the model was send out. (Inherited from IExportContext)
Top
See Also

Reference

IPhotoRenderContext Interface


IPrintSetting Interface

An interface which represents the Print Setup (Application Menu->Print->Print Setup) within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IPrintSetting
Public Interface IPrintSetting
public interface class IPrintSetting
type IPrintSetting = interface end

The IPrintSetting type exposes the following members.

Properties
 | Name | Description
Public property | PrintParameters | Returns the Parameters of Print Setup.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


IPrintSetting Properties

The IPrintSetting type exposes the following members.

Properties
 | Name | Description
Public property | PrintParameters | Returns the Parameters of Print Setup.
Top
See Also

Reference

IPrintSetting Interface


IPrintSetting.PrintParameters Property

IPrintSettingPrintParameters Property

Returns the Parameters of Print Setup.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
PrintParameters PrintParameters { get; }
ReadOnly Property PrintParameters As PrintParameters
    Get
property PrintParameters^ PrintParameters {
    PrintParameters^ get ();
}
abstract PrintParameters : PrintParameters with get

Property Value

PrintParameters
Remarks
The Parameters of Print Setup. Refer to the Print Setup dialog in Revit for details.
See Also

Reference

IPrintSetting Interface


ISaveSharedCoordinatesCallback Interface

An interface that may be used to control Revit when trying to unload or reload a Revit link with changes in shared coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ISaveSharedCoordinatesCallback
Public Interface ISaveSharedCoordinatesCallback
public interface class ISaveSharedCoordinatesCallback
type ISaveSharedCoordinatesCallback = interface end

The ISaveSharedCoordinatesCallback type exposes the following members.

Methods
 | Name | Description
Public method | GetSaveModifiedLinksOption | Determines whether Revit should save the link, not save the link, or discard shared positioning entirely.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ISaveSharedCoordinatesCallback Methods

The ISaveSharedCoordinatesCallback type exposes the following members.

Methods
 | Name | Description
Public method | GetSaveModifiedLinksOption | Determines whether Revit should save the link, not save the link, or discard shared positioning entirely.
Top
See Also

Reference

ISaveSharedCoordinatesCallback Interface


ISaveSharedCoordinatesCallback.GetSaveModifiedLinksOption Method

ISaveSharedCoordinatesCallbackGetSaveModifiedLinksOption Method

Determines whether Revit should save the link, not save the link, or discard shared positioning entirely.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
SaveModifiedLinksOptions GetSaveModifiedLinksOption(
    RevitLinkType link
)
Function GetSaveModifiedLinksOption (
    link As RevitLinkType
) As SaveModifiedLinksOptions
SaveModifiedLinksOptions GetSaveModifiedLinksOption(
    RevitLinkType^ link
)
abstract GetSaveModifiedLinksOption :
        link : RevitLinkType -> SaveModifiedLinksOptions

Parameters

link RevitLinkType
The Revit link which has modified shared coordinates.

Return Value

SaveModifiedLinksOptions
The options when saving a linked file which has been modified in-memory by shared coordinates operations.
See Also

Reference

ISaveSharedCoordinatesCallback Interface


ISaveSharedCoordinatesCallbackForUnloadLocally Interface

An interface that is used to control Revit when trying to unload locally a Revit link with changes in shared coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ISaveSharedCoordinatesCallbackForUnloadLocally
Public Interface ISaveSharedCoordinatesCallbackForUnloadLocally
public interface class ISaveSharedCoordinatesCallbackForUnloadLocally
type ISaveSharedCoordinatesCallbackForUnloadLocally = interface end

The ISaveSharedCoordinatesCallbackForUnloadLocally type exposes the following members.

Methods
 | Name | Description
Public method | GetSaveModifiedLinksOptionForUnloadLocally | Determines whether Revit should save the link or not prior to unloading the link locally.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ISaveSharedCoordinatesCallbackForUnloadLocally Methods

The ISaveSharedCoordinatesCallbackForUnloadLocally type exposes the following members.

Methods
 | Name | Description
Public method | GetSaveModifiedLinksOptionForUnloadLocally | Determines whether Revit should save the link or not prior to unloading the link locally.
Top
See Also

Reference

ISaveSharedCoordinatesCallbackForUnloadLocally Interface


ISaveSharedCoordinatesCallbackForUnloadLocally.GetSaveModifiedLinksOptionForUnloadLocally Method

ISaveSharedCoordinatesCallbackForUnloadLocallyGetSaveModifiedLinksOptionForUnloadLocally Method

Determines whether Revit should save the link or not prior to unloading the link locally.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
SaveModifiedLinksOptionsForUnloadLocally GetSaveModifiedLinksOptionForUnloadLocally(
    RevitLinkType link
)
Function GetSaveModifiedLinksOptionForUnloadLocally (
    link As RevitLinkType
) As SaveModifiedLinksOptionsForUnloadLocally
SaveModifiedLinksOptionsForUnloadLocally GetSaveModifiedLinksOptionForUnloadLocally(
    RevitLinkType^ link
)
abstract GetSaveModifiedLinksOptionForUnloadLocally :
        link : RevitLinkType -> SaveModifiedLinksOptionsForUnloadLocally

Parameters

link RevitLinkType
The Revit link which has modified shared coordinates.

Return Value

SaveModifiedLinksOptionsForUnloadLocally
The saving option when unloading locally a linked file which has been modified in-memory by shared coordinates operations.
See Also

Reference

ISaveSharedCoordinatesCallbackForUnloadLocally Interface


ITransactionFinalizer Interface

An interface that may be used to perform a custom action at the end of a transaction. A method of the interface will be called when a transaction is either committed or rolled back.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ITransactionFinalizer
Public Interface ITransactionFinalizer
public interface class ITransactionFinalizer
type ITransactionFinalizer = interface end

The ITransactionFinalizer type exposes the following members.

Methods
 | Name | Description
Public method | OnCommitted | This method is called at the end of committing a transaction
Public method | OnRolledBack | This method is called at the end of rolling back a transaction
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ITransactionFinalizer Methods

The ITransactionFinalizer type exposes the following members.

Methods
 | Name | Description
Public method | OnCommitted | This method is called at the end of committing a transaction
Public method | OnRolledBack | This method is called at the end of rolling back a transaction
Top
See Also

Reference

ITransactionFinalizer Interface


ITransactionFinalizer.OnCommitted Method

ITransactionFinalizerOnCommitted Method

This method is called at the end of committing a transaction

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void OnCommitted(
    Document document,
    string strTransactionName
)
Sub OnCommitted (
    document As Document,
    strTransactionName As String
)
void OnCommitted(
    Document^ document,
    String^ strTransactionName
)
abstract OnCommitted :
        document : Document *
        strTransactionName : string -> unit

Parameters

document Document
The document associated with the transaction
strTransactionName String
The transaction's name
See Also

Reference

ITransactionFinalizer Interface


ITransactionFinalizer.OnRolledBack Method

ITransactionFinalizerOnRolledBack Method

This method is called at the end of rolling back a transaction

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void OnRolledBack(
    Document document,
    string strTransactionName
)
Sub OnRolledBack (
    document As Document,
    strTransactionName As String
)
void OnRolledBack(
    Document^ document,
    String^ strTransactionName
)
abstract OnRolledBack :
        document : Document *
        strTransactionName : string -> unit

Parameters

document Document
The document associated with the transaction
strTransactionName String
The transaction's name
See Also

Reference

ITransactionFinalizer Interface


ITransientElementMaker Interface

The interface to be implemented by an application that creates transient element(s) in Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface ITransientElementMaker
Public Interface ITransientElementMaker
public interface class ITransientElementMaker
type ITransientElementMaker = interface end

The ITransientElementMaker type exposes the following members.

Methods
 | Name | Description
Public method | Execute | Implement this method to create transient elements.
Top
Remarks

An instance of the implemented interface is passed as an argument to the Document.MakeTransientElements() method, which will call back the Execute method of the interface.

During the execution of the method Revit will allow creation of certain elements, such as DirectShape, and will make them automatically transient . See (IsTransient for more details about transient elements.)

The code within the Execute method is not allowed to modify the model in any other way. An attempt to change the model or create elements of other kinds will result in an exception. This indirectly means that methods using a transaction internally are not allowed either. Such methods include document Save and SaveAs, certain import and export methods, creating links, syncing with central, etc.

Regenerating the model is also not allowed for the entire duration of the Execute method.

This interface is passed to MakeTransientElements(ITransientElementMaker) which does the actual transient element creation.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ITransientElementMaker Methods

The ITransientElementMaker type exposes the following members.

Methods
 | Name | Description
Public method | Execute | Implement this method to create transient elements.
Top
See Also

Reference

ITransientElementMaker Interface


ITransientElementMaker.Execute Method

ITransientElementMakerExecute Method

Implement this method to create transient elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Execute()
Sub Execute
void Execute()
abstract Execute : unit -> unit
See Also

Reference

ITransientElementMaker Interface


IUpdater Interface

The interface used to create an updater capable of reacting to changes in the Revit model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IUpdater
Public Interface IUpdater
public interface class IUpdater
type IUpdater = interface end

The IUpdater type exposes the following members.

Methods
 | Name | Description
Public method | Execute | The method that Revit will invoke to perform an update.
Public method | GetAdditionalInformation | Auxiliary text that Revit will use to inform the end user when the Updater is not loaded
Public method | GetChangePriority | Identifies the nature of the change the Updater will be performing Used to identify order of execution of updaters Called once during registration of the updater
Public method | GetUpdaterId | Returns globally unique updater id - used to identify the Updater Called once during registration of the updater
Public method | GetUpdaterName | Returns a name that the Updater can be identified by to the user
Top
Remarks
Implement this interface and register an instance of the derived class with the UpdaterRegistry.
Example
C#
VB
C++
F#
Copy
public class WallUpdaterApplication : Autodesk.Revit.UI.IExternalApplication
{
    public Result OnStartup(UIControlledApplication application)
    {
        // Register wall updater with Revit
        WallUpdater updater = new WallUpdater(application.ActiveAddInId);
        UpdaterRegistry.RegisterUpdater(updater);

        // Change Scope = any Wall element
        ElementClassFilter wallFilter = new ElementClassFilter(typeof(Wall));

        // Change type = element addition
        UpdaterRegistry.AddTrigger(updater.GetUpdaterId(), wallFilter,
                                    Element.GetChangeTypeElementAddition());
        return Result.Succeeded;
    }

    public Result OnShutdown(UIControlledApplication application)
    {
        WallUpdater updater = new WallUpdater(application.ActiveAddInId);
        UpdaterRegistry.UnregisterUpdater(updater.GetUpdaterId());
        return Result.Succeeded;
    }
}

public class WallUpdater : IUpdater
{
    static AddInId m_appId;
    static UpdaterId m_updaterId;
    WallType m_wallType = null;

    // constructor takes the AddInId for the add-in associated with this updater
    public WallUpdater(AddInId id)
    {
        m_appId = id;
        m_updaterId = new UpdaterId(m_appId, new Guid("FBFBF6B2-4C06-42d4-97C1-D1B4EB593EFF"));
    }

    public void Execute(UpdaterData data)
    {
        Document doc = data.GetDocument();

        // Cache the wall type
        if (m_wallType == null)
        {
            FilteredElementCollector collector = new FilteredElementCollector(doc);
            collector.OfClass(typeof(WallType));
            var wallTypes = from element in collector
                            where
                                element.Name == "Exterior - Brick on CMU"
                            select element;
            if (wallTypes.Count<Element>() > 0)
            {
                m_wallType = wallTypes.Cast<WallType>().ElementAt<WallType>(0);
            }
        }

        if (m_wallType != null)
        {
            // Change the wall to the cached wall type.
            foreach (ElementId addedElemId in data.GetAddedElementIds())
            {
                Wall wall = doc.GetElement(addedElemId) as Wall;
                if (wall != null)
                {
                    wall.WallType = m_wallType;
                }
            }
        }
    }

    public string GetAdditionalInformation()
    {
        return "Wall type updater example: updates all newly created walls to a special wall";
    }

    public ChangePriority GetChangePriority()
    {
        return ChangePriority.FloorsRoofsStructuralWalls;
    }

    public UpdaterId GetUpdaterId()
    {
        return m_updaterId;
    }

    public string GetUpdaterName()
    {
        return "Wall Type Updater";
    }
}
Public Class WallUpdaterApplication
    Implements Autodesk.Revit.UI.IExternalApplication
    Public Function OnStartup(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnStartup
        ' Register wall updater with Revit
        Dim updater As New WallUpdater(application.ActiveAddInId)
        UpdaterRegistry.RegisterUpdater(updater)

        ' Change Scope = any Wall element
        Dim wallFilter As New ElementClassFilter(GetType(Wall))

        ' Change type = element addition
        UpdaterRegistry.AddTrigger(updater.GetUpdaterId(), wallFilter, Element.GetChangeTypeElementAddition())
        Return Result.Succeeded
    End Function

    Public Function OnShutdown(application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnShutdown
        Dim updater As New WallUpdater(application.ActiveAddInId)
        UpdaterRegistry.UnregisterUpdater(updater.GetUpdaterId())
        Return Result.Succeeded
    End Function
End Class

Public Class WallUpdater
    Implements IUpdater
    Shared m_appId As AddInId
    Shared m_updaterId As UpdaterId
    Private m_wallType As WallType = Nothing

    ' constructor takes the AddInId for the add-in associated with this updater
    Public Sub New(id As AddInId)
        m_appId = id
        m_updaterId = New UpdaterId(m_appId, New Guid("FBFBF6B2-4C06-42d4-97C1-D1B4EB593EFF"))
    End Sub

    Public Sub Execute(data As UpdaterData) Implements IUpdater.Execute
        Dim doc As Document = data.GetDocument()

        ' Cache the wall type
        If m_wallType Is Nothing Then
            Dim collector As New FilteredElementCollector(doc)
            collector.OfClass(GetType(WallType))
            Dim wallTypes As System.Collections.Generic.IEnumerable(Of Autodesk.Revit.DB.Element)
            wallTypes = From element In collector _
             Where element.Name = "Exterior - Brick on CMU" _
             Select element
            If wallTypes.Count() > 0 Then
                m_wallType = wallTypes.Cast(Of WallType)().ElementAt(0)
            End If
        End If

        If m_wallType IsNot Nothing Then
            ' Change the wall to the cached wall type.
            For Each addedElemId As ElementId In data.GetAddedElementIds()
                Dim wall As Wall = TryCast(doc.GetElement(addedElemId), Wall)
                If wall IsNot Nothing Then
                    wall.WallType = m_wallType
                End If
            Next
        End If
    End Sub

    Public Function GetAdditionalInformation() As String Implements IUpdater.GetAdditionalInformation
        Return "Wall type updater example: updates all newly created walls to a special wall"
    End Function

    Public Function GetChangePriority() As ChangePriority Implements IUpdater.GetChangePriority
        Return ChangePriority.FloorsRoofsStructuralWalls
    End Function

    Public Function GetUpdaterId() As UpdaterId Implements IUpdater.GetUpdaterId
        Return m_updaterId
    End Function

    Public Function GetUpdaterName() As String Implements IUpdater.GetUpdaterName
        Return "Wall Type Updater"
    End Function
End Class

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


IUpdater Methods

The IUpdater type exposes the following members.

Methods
 | Name | Description
Public method | Execute | The method that Revit will invoke to perform an update.
Public method | GetAdditionalInformation | Auxiliary text that Revit will use to inform the end user when the Updater is not loaded
Public method | GetChangePriority | Identifies the nature of the change the Updater will be performing Used to identify order of execution of updaters Called once during registration of the updater
Public method | GetUpdaterId | Returns globally unique updater id - used to identify the Updater Called once during registration of the updater
Public method | GetUpdaterName | Returns a name that the Updater can be identified by to the user
Top
See Also

Reference

IUpdater Interface


IUpdater.Execute Method

IUpdaterExecute Method

The method that Revit will invoke to perform an update.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
void Execute(
    UpdaterData data
)
Sub Execute (
    data As UpdaterData
)
void Execute(
    UpdaterData^ data
)
abstract Execute :
        data : UpdaterData -> unit

Parameters

data UpdaterData
Provides all necessary data needed to perform the update, including the document and information about the changes that triggered the update.
Remarks

The purpose of this method is to allow your updater to react to changes that have been made to the document, and make appropriate related changes to the same document. Although it can be used to also update data outside of the document, such changes will not become part of the original transaction and will not be subject to undo or redo when the original transaction is undone or redone. If you do use this method to modify data outside of the document, you should also subscribe to the DocumentChanged event to update your data when the original transaction is undone or redone.

The method is invoked by Revit at the end of a document transaction in which elements that matched the UpdateTrigger for this Updater were added, changed or deleted. The method may be invoked more than once for the same transaction due to changes made by other Updaters.

All changes to the document made during the invocation of this method will become a part of the invoking transaction, and maintained for undo and redo operations. When implementing this method you may not open any new transactions (an exception will be thrown), but you may use sub-transactions as required.

The following methods may not be called while executing an Updater, because they introduce cross references between elements. A ForbiddenForDynamicUpdateException will be thrown when an updater attempts to call any of these methods:

  • void Autodesk.Revit.DB.ViewSheet.AddView(Autodesk.Revit.DB.View, Autodesk.Revit.DB.UV)
  • Autodesk.Revit.DB.Family Autodesk.Revit.DB.Document.LoadFamily(Autodesk.Revit.DB.Document, Autodesk.Revit.DB.IFamilyLoadOptions)
  • Autodesk.Revit.DB.Structure.AreaReinforcement Autodesk.Revit.Creation.Document.NewAreaReinforcement(Autodesk.Revit.DB.Element, Autodesk.Revit.DB.CurveArray, Autodesk.Revit.DB.XYZ)
  • Autodesk.Revit.DB.Structure.PathReinforcement Autodesk.Revit.Creation.Document.NewPathReinforcement(Autodesk.Revit.DB.Element, Autodesk.Revit.DB.CurveArray, bool)
  • void Autodesk.Revit.DB.MEPSystem.Add(Autodesk.Revit.DB.ConnectorSet)

Although the following methods are allowed during execution of an updater, they can also throw ForbiddenForDynamicUpdateException when cross-references between elements are established as a result of the call. One such example could be creating a face wall that intersect with an existing face wall, so those two would have to be joined together. Apply caution when calling these methods from an updater:

  • Autodesk.Revit.DB.ElementSet Autodesk.Revit.Creation.ItemFactoryBase.NewFamilyInstances(System.Collections.Generic.List<Autodesk.Revit.Creation.FamilyInstanceCreationData>)
  • Autodesk.Revit.DB.FamilyInstance Autodesk.Revit.Creation.ItemFactoryBase.NewFamilyInstance(Autodesk.Revit.DB.XYZ, Autodesk.Revit.DB.FamilySymbol, Autodesk.Revit.DB.Element,Autodesk.Revit.DB.Structure.StructuralType)
  • Autodesk.Revit.DB.FamilyInstance Autodesk.Revit.Creation.ItemFactoryBase.NewFamilyInstance(Autodesk.Revit.DB.XYZ, Autodesk.Revit.DB.FamilySymbol, Autodesk.Revit.DB.Level,Autodesk.Revit.DB.Structure.StructuralType)
  • Autodesk.Revit.DB.FamilyInstance Autodesk.Revit.Creation.Document.NewFamilyInstance(Autodesk.Revit.DB.XYZ, Autodesk.Revit.DB.FamilySymbol, Autodesk.Revit.DB.Element, Autodesk.Revit.DB.Level, Autodesk.Revit.DB.Structure.StructuralType)
  • Autodesk.Revit.DB.FaceWall Autodesk.Revit.DB.FaceWall.Create(Autodesk.Revit.DB.Document, Autodesk.Revit.DB.ElementId, Autodesk.Revit.DB.WallLocationLine, Autodesk.Revit.DB.Reference)

Some UI methods may not be called while executing an Updater too, otherwise ForbiddenForDynamicUpdateException will be thrown. Such methods include: PickObject, PickObjects, PickElementsByRectangle, PickPoint, PickOne and WindowSelect.

Also, most of the methods of the UpdaterRegistry class may not be called during an updater's execution otherwise an InvalidOperationException would be thrown.

In addition to the forbidden methods listed above, other API methods that require documents to be in transaction-free state may not be called either. Such methods include but are not limited to Save, SaveAs, Close, LoadFamily, etc. Please refer to the documentation of the respective methods for more information.

See Also

Reference

IUpdater Interface


IUpdater.GetAdditionalInformation Method

IUpdaterGetAdditionalInformation Method

Auxiliary text that Revit will use to inform the end user when the Updater is not loaded

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetAdditionalInformation()
Function GetAdditionalInformation As String
String^ GetAdditionalInformation()
abstract GetAdditionalInformation : unit -> string

Return Value

String
See Also

Reference

IUpdater Interface


IUpdater.GetChangePriority Method

IUpdaterGetChangePriority Method

Identifies the nature of the change the Updater will be performing Used to identify order of execution of updaters Called once during registration of the updater

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
ChangePriority GetChangePriority()
Function GetChangePriority As ChangePriority
ChangePriority GetChangePriority()
abstract GetChangePriority : unit -> ChangePriority

Return Value

ChangePriority
See Also

Reference

IUpdater Interface


IUpdater.GetUpdaterId Method

IUpdaterGetUpdaterId Method

Returns globally unique updater id - used to identify the Updater Called once during registration of the updater

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
UpdaterId GetUpdaterId()
Function GetUpdaterId As UpdaterId
UpdaterId^ GetUpdaterId()
abstract GetUpdaterId : unit -> UpdaterId

Return Value

UpdaterId
See Also

Reference

IUpdater Interface


IUpdater.GetUpdaterName Method

IUpdaterGetUpdaterName Method

Returns a name that the Updater can be identified by to the user

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
string GetUpdaterName()
Function GetUpdaterName As String
String^ GetUpdaterName()
abstract GetUpdaterName : unit -> string

Return Value

String
See Also

Reference

IUpdater Interface


IViewSheetSet Interface

This interface represents a selected set of views/sheets which will be used for printing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public interface IViewSheetSet
Public Interface IViewSheetSet
public interface class IViewSheetSet
type IViewSheetSet = interface end

The IViewSheetSet type exposes the following members.

Properties
 | Name | Description
Public property | IsAutomatic | Automatic order or manual order.
Public property | OrderedViewList | Ordered views.
Public property | SheetOrganizationId | ElementId to the BrowserOrganization for sheets.
Public property | ViewOrganizationId | ElementId to the BrowserOrganization for non-sheet views.
Public property | Views | The views.
Top
Example
C#
VB
C++
F#
Copy
private void SwitchToAutomaticOrder(Document doc, ViewSheetSetting viewSheetSetting)
{
   IViewSheetSet viewSheetSet = viewSheetSetting.CurrentViewSheetSet;
   var sheetBrowserOrg = BrowserOrganization.GetCurrentBrowserOrganizationForSheets(doc);
   var viewBrowserOrg = BrowserOrganization.GetCurrentBrowserOrganizationForViews(doc);
   viewSheetSet.SheetOrganizationId = sheetBrowserOrg.Id;
   viewSheetSet.ViewOrganizationId = viewBrowserOrg.Id;
   viewSheetSet.IsAutomatic = true; // IsAutomatic must be true then views and sheets will be ordered by Browser Organization
}

private void SwitchToCustomOrder(Document doc, ViewSheetSetting viewSheetSetting, IReadOnlyList<View> customViews)
{
   IViewSheetSet viewSheetSet = viewSheetSetting.CurrentViewSheetSet;
   // IsAutomatic must be false, then OrderedViewList will be organized in custom order
   // Note that the moment you set IsAutomatic from true to false, the order in OrderedViewList will be organized by Browser Organization
   viewSheetSet.IsAutomatic = false; // IMPORTANT: IsAutomatic before assigning OrderedViewList
   viewSheetSet.OrderedViewList = customViews;
}
Private Sub SwitchToAutomaticOrder(ByVal doc As Document, ByVal viewSheetSetting As ViewSheetSetting)
    Dim viewSheetSet = viewSheetSetting.CurrentViewSheetSet
    Dim sheetBrowserOrg = BrowserOrganization.GetCurrentBrowserOrganizationForSheets(doc)
    Dim viewBrowserOrg = BrowserOrganization.GetCurrentBrowserOrganizationForViews(doc)
    viewSheetSet.SheetOrganizationId = sheetBrowserOrg.Id
    viewSheetSet.ViewOrganizationId = viewBrowserOrg.Id
    viewSheetSet.IsAutomatic = True ' IsAutomatic must be true then views and sheets will be ordered by Browser Organization
End Sub

Private Sub SwitchToCustomOrder(ByVal doc As Document, ByVal viewSheetSetting As ViewSheetSetting, ByVal customViews As IReadOnlyList(Of View))
    Dim viewSheetSet = viewSheetSetting.CurrentViewSheetSet
    ' IsAutomatic must be false, then OrderedViewList will be organized in custom order
    ' Note that the moment you set IsAutomatic from true to false, the order in OrderedViewList will be organized by Browser Organization
    viewSheetSet.IsAutomatic = False ' IMPORTANT: IsAutomatic before assigning OrderedViewList
    viewSheetSet.OrderedViewList = customViews
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


IViewSheetSet Properties

The IViewSheetSet type exposes the following members.

Properties
 | Name | Description
Public property | IsAutomatic | Automatic order or manual order.
Public property | OrderedViewList | Ordered views.
Public property | SheetOrganizationId | ElementId to the BrowserOrganization for sheets.
Public property | ViewOrganizationId | ElementId to the BrowserOrganization for non-sheet views.
Public property | Views | The views.
Top
See Also

Reference

IViewSheetSet Interface


IViewSheetSet.IsAutomatic Property

IViewSheetSetIsAutomatic Property

Automatic order or manual order.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
bool IsAutomatic { get; set; }
Property IsAutomatic As Boolean
    Get
    Set
property bool IsAutomatic {
    bool get ();
    void set (bool value);
}
abstract IsAutomatic : bool with get, set

Property Value

Boolean
See Also

Reference

IViewSheetSet Interface


IViewSheetSet.OrderedViewList Property

IViewSheetSetOrderedViewList Property

Ordered views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
IReadOnlyList<View> OrderedViewList { get; set; }
Property OrderedViewList As IReadOnlyList(Of View)
    Get
    Set
property IReadOnlyList<View^>^ OrderedViewList {
    IReadOnlyList<View^>^ get ();
    void set (IReadOnlyList<View^>^ value);
}
abstract OrderedViewList : IReadOnlyList<View> with get, set

Property Value

IReadOnlyList View
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input ordered view list is .
InvalidOperationException | Thrown when the set operation failed due to invalid view which cannot be printed.
See Also

Reference

IViewSheetSet Interface


IViewSheetSet.SheetOrganizationId Property

IViewSheetSetSheetOrganizationId Property

ElementId to the BrowserOrganization for sheets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
ElementId SheetOrganizationId { get; set; }
Property SheetOrganizationId As ElementId
    Get
    Set
property ElementId^ SheetOrganizationId {
    ElementId^ get ();
    void set (ElementId^ value);
}
abstract SheetOrganizationId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentException | Thrown when the ElementId does not reference to BrowserOrganization, or the target type of BrowserOrganization is incompatible.
See Also

Reference

IViewSheetSet Interface


IViewSheetSet.ViewOrganizationId Property

IViewSheetSetViewOrganizationId Property

ElementId to the BrowserOrganization for non-sheet views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
ElementId ViewOrganizationId { get; set; }
Property ViewOrganizationId As ElementId
    Get
    Set
property ElementId^ ViewOrganizationId {
    ElementId^ get ();
    void set (ElementId^ value);
}
abstract ViewOrganizationId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentException | Thrown when the ElementId does not reference to BrowserOrganization, or the target type of BrowserOrganization is incompatible.
See Also

Reference

IViewSheetSet Interface


IViewSheetSet.Views Property

IViewSheetSetViews Property

The views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
ViewSet Views { get; set; }
Property Views As ViewSet
    Get
    Set
property ViewSet^ Views {
    ViewSet^ get ();
    void set (ViewSet^ value);
}
abstract Views : ViewSet with get, set

Property Value

ViewSet
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input views is .
InvalidOperationException | Thrown when the set operation failed due to invalid view which cannot be printed.
See Also

Reference

IViewSheetSet Interface


JoinGeometryUtils Class

Utilities for joining and unjoining elements, and for managing the order in which elements are joined.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBJoinGeometryUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class JoinGeometryUtils
Public NotInheritable Class JoinGeometryUtils
public ref class JoinGeometryUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type JoinGeometryUtils = class end

The JoinGeometryUtils type exposes the following members.

Methods
Name | Description
AreElementsJoined | Determines whether two elements are joined.
GetJoinedElements | Returns all elements joined to given element.
IsCuttingElementInJoin | Determines whether the first of two joined elements is cutting the second element.
JoinGeometry | Creates clean joins between two elements that share a common face.
SwitchJoinOrder | Reverses the order in which two elements are joined.
UnjoinGeometry | Removes a join between two elements.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


JoinGeometryUtils Methods

The JoinGeometryUtils type exposes the following members.

Methods
Name | Description
AreElementsJoined | Determines whether two elements are joined.
GetJoinedElements | Returns all elements joined to given element.
IsCuttingElementInJoin | Determines whether the first of two joined elements is cutting the second element.
JoinGeometry | Creates clean joins between two elements that share a common face.
SwitchJoinOrder | Reverses the order in which two elements are joined.
UnjoinGeometry | Removes a join between two elements.
Top
See Also

Reference

JoinGeometryUtils Class


JoinGeometryUtils.AreElementsJoined Method

JoinGeometryUtilsAreElementsJoined Method

Determines whether two elements are joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool AreElementsJoined(
    Document document,
    Element firstElement,
    Element secondElement
)
Public Shared Function AreElementsJoined (
    document As Document,
    firstElement As Element,
    secondElement As Element
) As Boolean
public:
static bool AreElementsJoined(
    Document^ document,
    Element^ firstElement,
    Element^ secondElement
)
static member AreElementsJoined :
        document : Document *
        firstElement : Element *
        secondElement : Element -> bool

Parameters

document Document
The document containing the two elements.
firstElement Element
The first element.
secondElement Element
The second element.

Return Value

Boolean
True if the two elements are joined.
Exceptions
Exception | Condition
ArgumentException | document is not a project document. -or- The element firstElement was not found in the given document. -or- The element secondElement was not found in the given document.
ArgumentNullException | A non-optional argument was null
Remarks
This functionality is not available for family documents.
See Also

Reference

JoinGeometryUtils Class


JoinGeometryUtils.GetJoinedElements Method

JoinGeometryUtilsGetJoinedElements Method

Returns all elements joined to given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ICollection<ElementId> GetJoinedElements(
    Document document,
    Element element
)
Public Shared Function GetJoinedElements (
    document As Document,
    element As Element
) As ICollection(Of ElementId)
public:
static ICollection<ElementId^>^ GetJoinedElements(
    Document^ document,
    Element^ element
)
static member GetJoinedElements :
        document : Document *
        element : Element -> ICollection<ElementId>

Parameters

document Document
The document containing the element.
element Element
The element.

Return Value

ICollection ElementId
The set of elements that are joined to the given element.
Exceptions
Exception | Condition
ArgumentException | document is not a project document. -or- The element element was not found in the given document.
ArgumentNullException | A non-optional argument was null
Remarks
This functionality is not available for family documents.
See Also

Reference

JoinGeometryUtils Class


JoinGeometryUtils.IsCuttingElementInJoin Method

JoinGeometryUtilsIsCuttingElementInJoin Method

Determines whether the first of two joined elements is cutting the second element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsCuttingElementInJoin(
    Document document,
    Element firstElement,
    Element secondElement
)
Public Shared Function IsCuttingElementInJoin (
    document As Document,
    firstElement As Element,
    secondElement As Element
) As Boolean
public:
static bool IsCuttingElementInJoin(
    Document^ document,
    Element^ firstElement,
    Element^ secondElement
)
static member IsCuttingElementInJoin :
        document : Document *
        firstElement : Element *
        secondElement : Element -> bool

Parameters

document Document
The document containing the two elements.
firstElement Element
The first element.
secondElement Element
The second element.

Return Value

Boolean
True if the secondElement is cut by the firstElement, false if the secondElement is cut by the firstElement.
Exceptions
Exception | Condition
ArgumentException | document is not a project document. -or- The element firstElement was not found in the given document. -or- The element secondElement was not found in the given document. -or- The elements are not joined.
ArgumentNullException | A non-optional argument was null
Remarks
This functionality is not available for family documents.
See Also

Reference

JoinGeometryUtils Class


JoinGeometryUtils.JoinGeometry Method

JoinGeometryUtilsJoinGeometry Method

Creates clean joins between two elements that share a common face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void JoinGeometry(
    Document document,
    Element firstElement,
    Element secondElement
)
Public Shared Sub JoinGeometry (
    document As Document,
    firstElement As Element,
    secondElement As Element
)
public:
static void JoinGeometry(
    Document^ document,
    Element^ firstElement,
    Element^ secondElement
)
static member JoinGeometry :
        document : Document *
        firstElement : Element *
        secondElement : Element -> unit

Parameters

document Document
The document containing the two elements.
firstElement Element
The first element to be joined.
secondElement Element
The second element to be joined. This element must not be joined to the first element.
Exceptions
Exception | Condition
ArgumentException | document is not a project document. -or- The element firstElement was not found in the given document. -or- The element secondElement was not found in the given document. -or- The elements are already joined. -or- The elements cannot be joined.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Please remove or add segments on curtain grids instead of joining or unjoining geometry of the panels.
Remarks
The visible edge between joined elements is removed. The joined elements then share the same line weight and fill pattern. This functionality is not available for family documents.
See Also

Reference

JoinGeometryUtils Class


JoinGeometryUtils.SwitchJoinOrder Method

JoinGeometryUtilsSwitchJoinOrder Method

Reverses the order in which two elements are joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void SwitchJoinOrder(
    Document document,
    Element firstElement,
    Element secondElement
)
Public Shared Sub SwitchJoinOrder (
    document As Document,
    firstElement As Element,
    secondElement As Element
)
public:
static void SwitchJoinOrder(
    Document^ document,
    Element^ firstElement,
    Element^ secondElement
)
static member SwitchJoinOrder :
        document : Document *
        firstElement : Element *
        secondElement : Element -> unit

Parameters

document Document
The document containing the two elements.
firstElement Element
The first element.
secondElement Element
The second element. This element must be joined to the first element.
Exceptions
Exception | Condition
ArgumentException | document is not a project document. -or- The element firstElement was not found in the given document. -or- The element secondElement was not found in the given document. -or- The elements are not joined. -or- The elements cannot be joined.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Unable to switch the join order of these elements.
Remarks
The cutting element becomes the cut element and vice versa after the join order is switched. This functionality is not available for family documents.
See Also

Reference

JoinGeometryUtils Class


JoinGeometryUtils.UnjoinGeometry Method

JoinGeometryUtilsUnjoinGeometry Method

Removes a join between two elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void UnjoinGeometry(
    Document document,
    Element firstElement,
    Element secondElement
)
Public Shared Sub UnjoinGeometry (
    document As Document,
    firstElement As Element,
    secondElement As Element
)
public:
static void UnjoinGeometry(
    Document^ document,
    Element^ firstElement,
    Element^ secondElement
)
static member UnjoinGeometry :
        document : Document *
        firstElement : Element *
        secondElement : Element -> unit

Parameters

document Document
The document containing the two elements.
firstElement Element
The first element to be unjoined.
secondElement Element
The second element to be unjoined. This element must be joined to the fist element.
Exceptions
Exception | Condition
ArgumentException | document is not a project document. -or- The element firstElement was not found in the given document. -or- The element secondElement was not found in the given document. -or- The elements are not joined. -or- The elements cannot be unjoined.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Please remove or add segments on curtain grids instead of joining or unjoining geometry of the panels.
Remarks
This functionality is not available for family documents.
See Also

Reference

JoinGeometryUtils Class


JoinType Enumeration

The type of join at the end of an element. The join type affects only the graphic treatment, i.e. cleaning of the end, not the physical join behavior.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum JoinType
Public Enumeration JoinType
public enum class JoinType
type JoinType
Members
Member name | Value | Description
Abut | 0 | Abut Join
Miter | 1 | Miter Join
SquareOff | 2 | Square-off Join
Extension | 3 | Extension Join
None | -1 | No join type
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


JunctionType Enumeration

An enumerated type listing all the junction types for MEP curve types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum JunctionType
Public Enumeration JunctionType
public enum class JunctionType
type JunctionType
Members
Member name | Value | Description
Tap | 0 | The junction type is tap.
Tee | 1 | The junction type is tee.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


KeyBasedTreeEntries Class

A collection of KeyBasedTreeEntry objects that make up the key-based tree.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBKeyBasedTreeEntries
Autodesk.Revit.DBClassificationEntries
Autodesk.Revit.DBKeynoteEntries

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class KeyBasedTreeEntries : IEnumerable<KeyBasedTreeEntry>,
    IDisposable
Public Class KeyBasedTreeEntries
    Implements IEnumerable(Of KeyBasedTreeEntry), IDisposable
public ref class KeyBasedTreeEntries : IEnumerable<KeyBasedTreeEntry^>,
    IDisposable
type KeyBasedTreeEntries =
    class
        interface IEnumerable<KeyBasedTreeEntry>
        interface IDisposable
    end

The KeyBasedTreeEntries type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the KeyBasedTreeEntries
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | FindEntry | Finds the KeyBasedTreeEntry associated with the given key value.
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetKeyBasedTreeEntriesIterator | Returns a KeyBasedTreeEntriesIterator that iterates through the collection.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


KeyBasedTreeEntries Properties

The KeyBasedTreeEntries type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

KeyBasedTreeEntries Class


KeyBasedTreeEntries.IsValidObject Property

KeyBasedTreeEntriesIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

KeyBasedTreeEntries Class


KeyBasedTreeEntries Methods

The KeyBasedTreeEntries type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | FindEntry | Finds the KeyBasedTreeEntry associated with the given key value.
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetKeyBasedTreeEntriesIterator | Returns a KeyBasedTreeEntriesIterator that iterates through the collection.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

KeyBasedTreeEntries Class


KeyBasedTreeEntries.Dispose Method

KeyBasedTreeEntriesDispose Method

Releases all resources used by the KeyBasedTreeEntries

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

KeyBasedTreeEntries Class


KeyBasedTreeEntries.FindEntry Method

KeyBasedTreeEntriesFindEntry Method

Finds the KeyBasedTreeEntry associated with the given key value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyBasedTreeEntry FindEntry(
    string key
)
Public Function FindEntry (
    key As String
) As KeyBasedTreeEntry
public:
KeyBasedTreeEntry^ FindEntry(
    String^ key
)
member FindEntry :
        key : string -> KeyBasedTreeEntry

Parameters

key String
The specified key value.

Return Value

KeyBasedTreeEntry
The KeyBasedTreeEntry corresponds to the given key value.
Exceptions
Exception | Condition
ArgumentException | key is an empty string.
ArgumentNullException | A non-optional argument was null
Remarks
If no matching KeyBasedTreeEntry can be found, null will be returned; The given key value cannot be an empty string.
See Also

Reference

KeyBasedTreeEntries Class


KeyBasedTreeEntries.GetBasicIEnumerator Method

KeyBasedTreeEntriesGetBasicIEnumerator Method

Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
internal virtual IEnumerator GetBasicIEnumerator()
Friend Overridable Function GetBasicIEnumerator As IEnumerator
internal:
virtual IEnumerator^ GetBasicIEnumerator()
internal abstract GetBasicIEnumerator : unit -> IEnumerator
internal override GetBasicIEnumerator : unit -> IEnumerator

Return Value

IEnumerator
An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerableGetEnumerator
See Also

Reference

KeyBasedTreeEntries Class


KeyBasedTreeEntries.GetEnumerator Method

KeyBasedTreeEntriesGetEnumerator Method

Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator<KeyBasedTreeEntry> GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator(Of KeyBasedTreeEntry)
public:
virtual IEnumerator<KeyBasedTreeEntry^>^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator<KeyBasedTreeEntry>
override GetEnumerator : unit -> IEnumerator<KeyBasedTreeEntry>

Return Value

IEnumerator KeyBasedTreeEntry
An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerableTGetEnumerator
See Also

Reference

KeyBasedTreeEntries Class


KeyBasedTreeEntries.GetKeyBasedTreeEntriesIterator Method

KeyBasedTreeEntriesGetKeyBasedTreeEntriesIterator Method

Returns a KeyBasedTreeEntriesIterator that iterates through the collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyBasedTreeEntriesIterator GetKeyBasedTreeEntriesIterator()
Public Function GetKeyBasedTreeEntriesIterator As KeyBasedTreeEntriesIterator
public:
KeyBasedTreeEntriesIterator^ GetKeyBasedTreeEntriesIterator()
member GetKeyBasedTreeEntriesIterator : unit -> KeyBasedTreeEntriesIterator

Return Value

KeyBasedTreeEntriesIterator
A KeyBasedTreeEntriesIterator object that can be used to iterate through KeyBasedTreeEntry objects in the collection.
See Also

Reference

KeyBasedTreeEntries Class


KeyBasedTreeEntriesIterator Class

An iterator to a set of KeyBasedTreeEntry objects.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBKeyBasedTreeEntriesIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class KeyBasedTreeEntriesIterator : IEnumerator<KeyBasedTreeEntry>
Public Class KeyBasedTreeEntriesIterator
    Implements IEnumerator(Of KeyBasedTreeEntry)
public ref class KeyBasedTreeEntriesIterator : IEnumerator<KeyBasedTreeEntry^>
type KeyBasedTreeEntriesIterator =
    class
        interface IEnumerator<KeyBasedTreeEntry>
    end

The KeyBasedTreeEntriesIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the KeyBasedTreeEntriesIterator
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next item.
Public method | Reset | Resets the iterator to the initial state.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


KeyBasedTreeEntriesIterator Properties

The KeyBasedTreeEntriesIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

KeyBasedTreeEntriesIterator Class


KeyBasedTreeEntriesIterator.Current Property

KeyBasedTreeEntriesIteratorCurrent Property

Gets the item at the current position of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual KeyBasedTreeEntry Current { get; }
Public Overridable ReadOnly Property Current As KeyBasedTreeEntry
    Get
public:
virtual property KeyBasedTreeEntry^ Current {
    KeyBasedTreeEntry^ get ();
}
abstract Current : KeyBasedTreeEntry with get
override Current : KeyBasedTreeEntry with get

Property Value

KeyBasedTreeEntry

Implements

IEnumeratorTCurrent
Exceptions
Exception | Condition
InvalidOperationException | There is no current item in the iterator.
Remarks
There is no current item if the iterator has not started yet or has been done.
See Also

Reference

KeyBasedTreeEntriesIterator Class


KeyBasedTreeEntriesIterator.CurrentObject Property

KeyBasedTreeEntriesIteratorCurrentObject Property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
internal Object CurrentObject { get; }
Friend ReadOnly Property CurrentObject As Object
    Get
internal:
virtual property Object^ CurrentObject {
    Object^ get () sealed;
}
internal abstract CurrentObject : Object with get
internal override CurrentObject : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
See Also

Reference

KeyBasedTreeEntriesIterator Class


KeyBasedTreeEntriesIterator.IsValidObject Property

KeyBasedTreeEntriesIteratorIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

KeyBasedTreeEntriesIterator Class


KeyBasedTreeEntriesIterator Methods

The KeyBasedTreeEntriesIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next item.
Public method | Reset | Resets the iterator to the initial state.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

KeyBasedTreeEntriesIterator Class


KeyBasedTreeEntriesIterator.Dispose Method

KeyBasedTreeEntriesIteratorDispose Method

Releases all resources used by the KeyBasedTreeEntriesIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit
See Also

Reference

KeyBasedTreeEntriesIterator Class


KeyBasedTreeEntriesIterator.IsDone Method

KeyBasedTreeEntriesIteratorIsDone Method

Identifies if the iteration has completed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsDone()
Public Overridable Function IsDone As Boolean
public:
virtual bool IsDone()
abstract IsDone : unit -> bool
override IsDone : unit -> bool

Return Value

Boolean
True if the iteration has no more items. False if there are more items to be iterated.
See Also

Reference

KeyBasedTreeEntriesIterator Class


KeyBasedTreeEntriesIterator.MoveNext Method

KeyBasedTreeEntriesIteratorMoveNext Method

Increments the iterator to the next item.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
True if there is a next available item in this iterator. False if the iterator has completed all available items.
See Also

Reference

KeyBasedTreeEntriesIterator Class


KeyBasedTreeEntriesIterator.Reset Method

KeyBasedTreeEntriesIteratorReset Method

Resets the iterator to the initial state.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit
See Also

Reference

KeyBasedTreeEntriesIterator Class


KeyBasedTreeEntriesLoadContent Class

This class is used by IExternalResourceServers to return KeyBasedTreeEntries data to Revit when their LoadResource method is invoked.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExternalResourceLoadContent
Autodesk.Revit.DBKeyBasedTreeEntriesLoadContent

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class KeyBasedTreeEntriesLoadContent : ExternalResourceLoadContent
Public Class KeyBasedTreeEntriesLoadContent
    Inherits ExternalResourceLoadContent
public ref class KeyBasedTreeEntriesLoadContent : public ExternalResourceLoadContent
type KeyBasedTreeEntriesLoadContent =
    class
        inherit ExternalResourceLoadContent
    end

The KeyBasedTreeEntriesLoadContent type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ExternalResourceLoadContent)
Public property | LoadStatus | A value to indicate the status of an external resource load operation. IExternalResourceServers should set this in the LoadResource() method. (Inherited from ExternalResourceLoadContent)
Public property | Version | The version of the external data that the server is providing in this object. (Inherited from ExternalResourceLoadContent)
Top
Methods
 | Name | Description
Public method | AddEntry | Adds one KeyBasedTreeEntry to this KeyBasedTreeEntriesLoadContent, which is used to build a KeyBasedTreeEntries object by BuildEntries function.
Public method | BuildEntries | Builds a KeyBasedTreeEntries object.
Public method | CanAddEntry | Verifies if the KeyBasedTreeEntry could be added in this KeyBasedTreeEntriesLoadContent.
Public method | Dispose | (Inherited from ExternalResourceLoadContent)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetEntries | Gets a copy of KeyBasedTreeEntries object owned by this KeyBasedTreeEntriesLoadContent object.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLoadResults | Returns a copy of the KeyBasedTreeEntriesLoadResults owned by this KeyBasedTreeEntriesLoadContent object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | IsEntriesBuilt | Verifies that the KeyBasedTreeEntries object owned by a KeyBasedTreeEntriesLoadContent object is built.
Public method | Reset | Clears KeyBasedTreeEntriesLoadContent object, including KeyBasedTreeEntries and KeyBasedTreeEntriesLoadResults, owned by this KeyBasedTreeEntriesLoadContent object.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

The class contains a KeyBasedTreeEntries object which should hold the KeyBasedTreeEntries data generated by the IExternalResourceServer.

An ExternalResourceServer can create the KeyBasedTreeEntries from an arbitrary data source by using AddEntry to add individual KeyBasedTreeEntries. Once all the desired entries have been added, BuildEntries can be called to construct the KeyBasedTreeEntries object from the individual entries that were added.

KeyBasedTreeEntriesLoadContent must have a built KeyBasedTreeEntries before its LoadStatus property can be set to ExternalResourceLoadStatus.Success.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


KeyBasedTreeEntriesLoadContent Properties

The KeyBasedTreeEntriesLoadContent type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ExternalResourceLoadContent)
Public property | LoadStatus | A value to indicate the status of an external resource load operation. IExternalResourceServers should set this in the LoadResource() method. (Inherited from ExternalResourceLoadContent)
Public property | Version | The version of the external data that the server is providing in this object. (Inherited from ExternalResourceLoadContent)
Top
See Also

Reference

KeyBasedTreeEntriesLoadContent Class


KeyBasedTreeEntriesLoadContent Methods

The KeyBasedTreeEntriesLoadContent type exposes the following members.

Methods
 | Name | Description
Public method | AddEntry | Adds one KeyBasedTreeEntry to this KeyBasedTreeEntriesLoadContent, which is used to build a KeyBasedTreeEntries object by BuildEntries function.
Public method | BuildEntries | Builds a KeyBasedTreeEntries object.
Public method | CanAddEntry | Verifies if the KeyBasedTreeEntry could be added in this KeyBasedTreeEntriesLoadContent.
Public method | Dispose | (Inherited from ExternalResourceLoadContent)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetEntries | Gets a copy of KeyBasedTreeEntries object owned by this KeyBasedTreeEntriesLoadContent object.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLoadResults | Returns a copy of the KeyBasedTreeEntriesLoadResults owned by this KeyBasedTreeEntriesLoadContent object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | IsEntriesBuilt | Verifies that the KeyBasedTreeEntries object owned by a KeyBasedTreeEntriesLoadContent object is built.
Public method | Reset | Clears KeyBasedTreeEntriesLoadContent object, including KeyBasedTreeEntries and KeyBasedTreeEntriesLoadResults, owned by this KeyBasedTreeEntriesLoadContent object.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

KeyBasedTreeEntriesLoadContent Class


KeyBasedTreeEntriesLoadContent.AddEntry Method

KeyBasedTreeEntriesLoadContentAddEntry Method

Adds one KeyBasedTreeEntry to this KeyBasedTreeEntriesLoadContent, which is used to build a KeyBasedTreeEntries object by BuildEntries function.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AddEntry(
    KeyBasedTreeEntry entry
)
Public Function AddEntry (
    entry As KeyBasedTreeEntry
) As Boolean
public:
bool AddEntry(
    KeyBasedTreeEntry^ entry
)
member AddEntry :
        entry : KeyBasedTreeEntry -> bool

Parameters

entry KeyBasedTreeEntry
The entry to be added.

Return Value

Boolean
Returns true if an entry is added into the entry data set successfully, returns false if an entry fails to be added because this entry is invalid or a duplicate of one in the entry data set.
Exceptions
Exception | Condition
ArgumentException | The KeyBasedTreeEntry object is not appropriate to be added in this KeyBasedTreeEntriesLoadContent.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The KeyBasedTreeEntries object owned by this KeyBasedTreeEntriesLoadContent object is built already. Adding more KeyBasedTreeEntries as well as repeated building, is not supported.
Remarks
The entry will not be added if it is invalid or duplicate with the added entries.
See Also

Reference

KeyBasedTreeEntriesLoadContent Class


KeyBasedTreeEntriesLoadContent.BuildEntries Method

KeyBasedTreeEntriesLoadContentBuildEntries Method

Builds a KeyBasedTreeEntries object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void BuildEntries()
Public Sub BuildEntries
public:
void BuildEntries()
member BuildEntries : unit -> unit
Exceptions
Exception | Condition
InvalidOperationException | The KeyBasedTreeEntries object owned by this KeyBasedTreeEntriesLoadContent object is built already. Adding more KeyBasedTreeEntries as well as repeated building, is not supported.
Remarks
This method will take all the entries that have been added, create a KeyBasedTreeEntries object out of these entries, and also record possible errors that occurred while constructing this KeyBasedTreeEntries object. After this function is called, no more entries can be added. And repeated calling of this function is not allowed either.
See Also

Reference

KeyBasedTreeEntriesLoadContent Class


KeyBasedTreeEntriesLoadContent.CanAddEntry Method

KeyBasedTreeEntriesLoadContentCanAddEntry Method

Verifies if the KeyBasedTreeEntry could be added in this KeyBasedTreeEntriesLoadContent.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanAddEntry(
    KeyBasedTreeEntry entry
)
Public Function CanAddEntry (
    entry As KeyBasedTreeEntry
) As Boolean
public:
bool CanAddEntry(
    KeyBasedTreeEntry^ entry
)
member CanAddEntry :
        entry : KeyBasedTreeEntry -> bool

Parameters

entry KeyBasedTreeEntry
The KeyBasedTreeEntry object to be checked.

Return Value

Boolean
True if the KeyBasedTreeEntry could be added in, otherwise false.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

KeyBasedTreeEntriesLoadContent Class


KeyBasedTreeEntriesLoadContent.GetEntries Method

KeyBasedTreeEntriesLoadContentGetEntries Method

Gets a copy of KeyBasedTreeEntries object owned by this KeyBasedTreeEntriesLoadContent object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyBasedTreeEntries GetEntries()
Public Function GetEntries As KeyBasedTreeEntries
public:
KeyBasedTreeEntries^ GetEntries()
member GetEntries : unit -> KeyBasedTreeEntries

Return Value

KeyBasedTreeEntries
A copy of KeyBasedTreeEntries object owned by this KeyBasedTreeEntriesLoadContent object.
Exceptions
Exception | Condition
InvalidOperationException | The KeyBasedTreeEntries object owned by this KeyBasedTreeEntriesLoadContent object is not built yet. The information about this KeyBasedTreeEntries object is not available.
See Also

Reference

KeyBasedTreeEntriesLoadContent Class


KeyBasedTreeEntriesLoadContent.GetLoadResults Method

KeyBasedTreeEntriesLoadContentGetLoadResults Method

Returns a copy of the KeyBasedTreeEntriesLoadResults owned by this KeyBasedTreeEntriesLoadContent object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyBasedTreeEntriesLoadResults GetLoadResults()
Public Function GetLoadResults As KeyBasedTreeEntriesLoadResults
public:
KeyBasedTreeEntriesLoadResults^ GetLoadResults()
member GetLoadResults : unit -> KeyBasedTreeEntriesLoadResults

Return Value

KeyBasedTreeEntriesLoadResults
A copy of a KeyBasedTreeEntriesLoadResults owned by this KeyBasedTreeEntriesLoadContent object.
Remarks
IExternalResourceServers can use this object to report data and results back to Revit from their LoadResource methods.
See Also

Reference

KeyBasedTreeEntriesLoadContent Class


KeyBasedTreeEntriesLoadContent.IsEntriesBuilt Method

KeyBasedTreeEntriesLoadContentIsEntriesBuilt Method

Verifies that the KeyBasedTreeEntries object owned by a KeyBasedTreeEntriesLoadContent object is built.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsEntriesBuilt(
    KeyBasedTreeEntriesLoadContent content
)
Public Shared Function IsEntriesBuilt (
    content As KeyBasedTreeEntriesLoadContent
) As Boolean
public:
static bool IsEntriesBuilt(
    KeyBasedTreeEntriesLoadContent^ content
)
static member IsEntriesBuilt :
        content : KeyBasedTreeEntriesLoadContent -> bool

Parameters

content KeyBasedTreeEntriesLoadContent
The KeyBasedTreeEntriesLoadContent object to be checked.

Return Value

Boolean
True if the KeyBasedTreeEntries object is built already, otherwise false.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

KeyBasedTreeEntriesLoadContent Class


KeyBasedTreeEntriesLoadContent.Reset Method

KeyBasedTreeEntriesLoadContentReset Method

Clears KeyBasedTreeEntriesLoadContent object, including KeyBasedTreeEntries and KeyBasedTreeEntriesLoadResults, owned by this KeyBasedTreeEntriesLoadContent object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Reset()
Public Sub Reset
public:
void Reset()
member Reset : unit -> unit
Remarks
This method can be used to clear all data that has been added to this KeyBasedTreeEntriesLoadContent object to date so that the caller can start adding and building KeyBasedTreeEntries again.
See Also

Reference

KeyBasedTreeEntriesLoadContent Class


KeyBasedTreeEntriesLoadResults Class

This class contains the results and status information regarding an attempt to load the KeyBasedTreeEntries from an External Resource.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBKeyBasedTreeEntriesLoadResults

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class KeyBasedTreeEntriesLoadResults : IDisposable
Public Class KeyBasedTreeEntriesLoadResults
    Implements IDisposable
public ref class KeyBasedTreeEntriesLoadResults : IDisposable
type KeyBasedTreeEntriesLoadResults =
    class
        interface IDisposable
    end

The KeyBasedTreeEntriesLoadResults type exposes the following members.

Constructors
 | Name | Description
Public method | KeyBasedTreeEntriesLoadResults | Creates an empty KeyBasedTreeEntriesLoadResults.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the KeyBasedTreeEntriesLoadResults
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetFailureMessages | Get all error or warnings created while attempting to load KeyBasedTreeEntries.
Public method | GetFileReadErrors | Gets the names of any files which could not be read due to access errors.
Public method | GetFileSyntaxErrors | Gets all the records in the key-based tree data text file that could not be parsed into KeyBasedTreeEntries.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetKeyBasedTreeEntryErrors | Gets information about KeyBasedTreeEntry objects that could not be included in the KeyBasedTreeEntries object due to errors.
Public method | GetKeyBasedTreeEntryErrors(KeyBasedTreeEntryErrorType) | Gets information about specific KeyBasedTreeEntry objects that could not be included in the KeyBasedTreeEntries object due to errors of a particular type.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

A KeyBasedTreeEntriesLoadResults object is returned by the KeynoteTable or AssemblyCodeTable API methods LoadFrom() and Reload() so that callers can determine whether the KeynoteTable or AssemblyCodeTable was updated successfully and what, if any, errors occurred.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


KeyBasedTreeEntriesLoadResults Constructor

Creates an empty KeyBasedTreeEntriesLoadResults.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyBasedTreeEntriesLoadResults()
Public Sub New
public:
KeyBasedTreeEntriesLoadResults()
new : unit -> KeyBasedTreeEntriesLoadResults
See Also

Reference

KeyBasedTreeEntriesLoadResults Class


KeyBasedTreeEntriesLoadResults Properties

The KeyBasedTreeEntriesLoadResults type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

KeyBasedTreeEntriesLoadResults Class


KeyBasedTreeEntriesLoadResults.IsValidObject Property

KeyBasedTreeEntriesLoadResultsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

KeyBasedTreeEntriesLoadResults Class


KeyBasedTreeEntriesLoadResults Methods

The KeyBasedTreeEntriesLoadResults type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetFailureMessages | Get all error or warnings created while attempting to load KeyBasedTreeEntries.
Public method | GetFileReadErrors | Gets the names of any files which could not be read due to access errors.
Public method | GetFileSyntaxErrors | Gets all the records in the key-based tree data text file that could not be parsed into KeyBasedTreeEntries.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetKeyBasedTreeEntryErrors | Gets information about KeyBasedTreeEntry objects that could not be included in the KeyBasedTreeEntries object due to errors.
Public method | GetKeyBasedTreeEntryErrors(KeyBasedTreeEntryErrorType) | Gets information about specific KeyBasedTreeEntry objects that could not be included in the KeyBasedTreeEntries object due to errors of a particular type.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

KeyBasedTreeEntriesLoadResults Class


KeyBasedTreeEntriesLoadResults.Dispose Method

KeyBasedTreeEntriesLoadResultsDispose Method

Releases all resources used by the KeyBasedTreeEntriesLoadResults

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

KeyBasedTreeEntriesLoadResults Class


KeyBasedTreeEntriesLoadResults.GetFailureMessages Method

KeyBasedTreeEntriesLoadResultsGetFailureMessages Method

Get all error or warnings created while attempting to load KeyBasedTreeEntries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<FailureMessage> GetFailureMessages()
Public Function GetFailureMessages As IList(Of FailureMessage)
public:
IList<FailureMessage^>^ GetFailureMessages()
member GetFailureMessages : unit -> IList<FailureMessage>

Return Value

IList FailureMessage
A collection of FailureMessage objects, if any errors or warnings were encountered while loading and building the KeyBasedTreeEntries.
Remarks

Revit does not post these warnings. They are provided as a convenience to the API user, who may wish to post them.

The information in the warnings is also captured in the other error functions of KeyBasedTreeEntriesLoadResults.

See Also

Reference

KeyBasedTreeEntriesLoadResults Class


KeyBasedTreeEntriesLoadResults.GetFileReadErrors Method

KeyBasedTreeEntriesLoadResultsGetFileReadErrors Method

Gets the names of any files which could not be read due to access errors.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<string> GetFileReadErrors()
Public Function GetFileReadErrors As IList(Of String)
public:
IList<String^>^ GetFileReadErrors()
member GetFileReadErrors : unit -> IList<string>

Return Value

IList String
An array of strings containing the filenames of files which could not be read.
Remarks
Only applies to KeyBasedTreeEntries built from text files.
See Also

Reference

KeyBasedTreeEntriesLoadResults Class


KeyBasedTreeEntriesLoadResults.GetFileSyntaxErrors Method

KeyBasedTreeEntriesLoadResultsGetFileSyntaxErrors Method

Gets all the records in the key-based tree data text file that could not be parsed into KeyBasedTreeEntries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<string> GetFileSyntaxErrors()
Public Function GetFileSyntaxErrors As IList(Of String)
public:
IList<String^>^ GetFileSyntaxErrors()
member GetFileSyntaxErrors : unit -> IList<string>

Return Value

IList String
An array of strings that are copies of the records in the text file that could not be parsed.
Remarks
Only applies to KeyBasedTreeEntries built from text files.
See Also

Reference

KeyBasedTreeEntriesLoadResults Class


KeyBasedTreeEntriesLoadResults.GetKeyBasedTreeEntryErrors Method

KeyBasedTreeEntriesLoadResultsGetKeyBasedTreeEntryErrors Method

Overload List
 | Name | Description
Public method | GetKeyBasedTreeEntryErrors | Gets information about KeyBasedTreeEntry objects that could not be included in the KeyBasedTreeEntries object due to errors.
Public method | GetKeyBasedTreeEntryErrors(KeyBasedTreeEntryErrorType) | Gets information about specific KeyBasedTreeEntry objects that could not be included in the KeyBasedTreeEntries object due to errors of a particular type.
Top
See Also

Reference

KeyBasedTreeEntriesLoadResults Class


KeyBasedTreeEntriesLoadResults.GetKeyBasedTreeEntryErrors Method

KeyBasedTreeEntriesLoadResultsGetKeyBasedTreeEntryErrors Method

Gets information about KeyBasedTreeEntry objects that could not be included in the KeyBasedTreeEntries object due to errors.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<KeyBasedTreeEntryError> GetKeyBasedTreeEntryErrors()
Public Function GetKeyBasedTreeEntryErrors As IList(Of KeyBasedTreeEntryError)
public:
IList<KeyBasedTreeEntryError^>^ GetKeyBasedTreeEntryErrors()
member GetKeyBasedTreeEntryErrors : unit -> IList<KeyBasedTreeEntryError>

Return Value

IList KeyBasedTreeEntryError
An array of copies of the KeyBasedTreeEntryErrors contained in this object.
See Also

Reference

KeyBasedTreeEntriesLoadResults Class
GetKeyBasedTreeEntryErrors Overload


KeyBasedTreeEntriesLoadResults.GetKeyBasedTreeEntryErrors(KeyBasedTreeEntryErrorType) Method

KeyBasedTreeEntriesLoadResultsGetKeyBasedTreeEntryErrors(KeyBasedTreeEntryErrorType) Method

Gets information about specific KeyBasedTreeEntry objects that could not be included in the KeyBasedTreeEntries object due to errors of a particular type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<KeyBasedTreeEntryError> GetKeyBasedTreeEntryErrors(
    KeyBasedTreeEntryErrorType type
)
Public Function GetKeyBasedTreeEntryErrors (
    type As KeyBasedTreeEntryErrorType
) As IList(Of KeyBasedTreeEntryError)
public:
IList<KeyBasedTreeEntryError^>^ GetKeyBasedTreeEntryErrors(
    KeyBasedTreeEntryErrorType type
)
member GetKeyBasedTreeEntryErrors :
        type : KeyBasedTreeEntryErrorType -> IList<KeyBasedTreeEntryError>

Parameters

type KeyBasedTreeEntryErrorType
The type of KeyBasedTreeEntryError to be returned.

Return Value

IList KeyBasedTreeEntryError
An array of copies of the KeyBasedTreeEntryErrors contained in this object matching the type specified.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

KeyBasedTreeEntriesLoadResults Class
GetKeyBasedTreeEntryErrors Overload


KeyBasedTreeEntry Class

A key-based tree entry, containing the key, parent key, and children keys (if applicable).
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBKeyBasedTreeEntry
Autodesk.Revit.DBClassificationEntry
Autodesk.Revit.DBKeynoteEntry

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class KeyBasedTreeEntry : IDisposable
Public Class KeyBasedTreeEntry
    Implements IDisposable
public ref class KeyBasedTreeEntry : IDisposable
type KeyBasedTreeEntry =
    class
        interface IDisposable
    end

The KeyBasedTreeEntry type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Key | The key of this entry.
Public property | ParentKey | The parent key of this entry.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the KeyBasedTreeEntry
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetChildrenKeys | Gets a collection containing the keys of all children entry objects from this entry.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


KeyBasedTreeEntry Properties

The KeyBasedTreeEntry type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Key | The key of this entry.
Public property | ParentKey | The parent key of this entry.
Top
See Also

Reference

KeyBasedTreeEntry Class


KeyBasedTreeEntry.IsValidObject Property

KeyBasedTreeEntryIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

KeyBasedTreeEntry Class


KeyBasedTreeEntry.Key Property

KeyBasedTreeEntryKey Property

The key of this entry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Key { get; }
Public ReadOnly Property Key As String
    Get
public:
property String^ Key {
    String^ get ();
}
member Key : string with get

Property Value

String
Remarks
This value will be used to do retrieval, sort and comparison. This value should not be empty.
See Also

Reference

KeyBasedTreeEntry Class


KeyBasedTreeEntry.ParentKey Property

KeyBasedTreeEntryParentKey Property

The parent key of this entry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ParentKey { get; }
Public ReadOnly Property ParentKey As String
    Get
public:
property String^ ParentKey {
    String^ get ();
}
member ParentKey : string with get

Property Value

String
Remarks
This value will be the empty string if this entry does not have a parent.
See Also

Reference

KeyBasedTreeEntry Class


KeyBasedTreeEntry Methods

The KeyBasedTreeEntry type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetChildrenKeys | Gets a collection containing the keys of all children entry objects from this entry.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

KeyBasedTreeEntry Class


KeyBasedTreeEntry.Dispose Method

KeyBasedTreeEntryDispose Method

Releases all resources used by the KeyBasedTreeEntry

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

KeyBasedTreeEntry Class


KeyBasedTreeEntry.GetChildrenKeys Method

KeyBasedTreeEntryGetChildrenKeys Method

Gets a collection containing the keys of all children entry objects from this entry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<string> GetChildrenKeys()
Public Function GetChildrenKeys As IList(Of String)
public:
IList<String^>^ GetChildrenKeys()
member GetChildrenKeys : unit -> IList<string>

Return Value

IList String
The collection containing the keys of all children entry objects from this entry.
Remarks
To look up the entry object corresponding to the child keys using KeyBasedTreeEntries.FindEntry().
See Also

Reference

KeyBasedTreeEntry Class


KeyBasedTreeEntryError Class

This class contains information about a problem encountered while creating a KeyBasedTreeEntries object.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBKeyBasedTreeEntryError

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class KeyBasedTreeEntryError : IDisposable
Public Class KeyBasedTreeEntryError
    Implements IDisposable
public ref class KeyBasedTreeEntryError : IDisposable
type KeyBasedTreeEntryError =
    class
        interface IDisposable
    end

The KeyBasedTreeEntryError type exposes the following members.

Properties
 | Name | Description
Public property | ErrorType | Indicates which of possible types of problems with loading and/or building a KeyBasedTreeEntries that this KeyBasedTreeEntryError represents.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the KeyBasedTreeEntryError
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetEntry | Gets the entry for which an error occurred while building the KeyBasedTreeEntries object.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This problem might be a duplicate entry, or an error in the specified parent-child relationships, or something else. See BuiltInKeyBasedTreeEntryErrorType for details.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


KeyBasedTreeEntryError Properties

The KeyBasedTreeEntryError type exposes the following members.

Properties
 | Name | Description
Public property | ErrorType | Indicates which of possible types of problems with loading and/or building a KeyBasedTreeEntries that this KeyBasedTreeEntryError represents.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

KeyBasedTreeEntryError Class


KeyBasedTreeEntryError.ErrorType Property

KeyBasedTreeEntryErrorErrorType Property

Indicates which of possible types of problems with loading and/or building a KeyBasedTreeEntries that this KeyBasedTreeEntryError represents.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyBasedTreeEntryErrorType ErrorType { get; }
Public ReadOnly Property ErrorType As KeyBasedTreeEntryErrorType
    Get
public:
property KeyBasedTreeEntryErrorType ErrorType {
    KeyBasedTreeEntryErrorType get ();
}
member ErrorType : KeyBasedTreeEntryErrorType with get

Property Value

KeyBasedTreeEntryErrorType
See Also

Reference

KeyBasedTreeEntryError Class


KeyBasedTreeEntryError.IsValidObject Property

KeyBasedTreeEntryErrorIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

KeyBasedTreeEntryError Class


KeyBasedTreeEntryError Methods

The KeyBasedTreeEntryError type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetEntry | Gets the entry for which an error occurred while building the KeyBasedTreeEntries object.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

KeyBasedTreeEntryError Class


KeyBasedTreeEntryError.Dispose Method

KeyBasedTreeEntryErrorDispose Method

Releases all resources used by the KeyBasedTreeEntryError

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

KeyBasedTreeEntryError Class


KeyBasedTreeEntryError.GetEntry Method

KeyBasedTreeEntryErrorGetEntry Method

Gets the entry for which an error occurred while building the KeyBasedTreeEntries object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyBasedTreeEntry GetEntry()
Public Function GetEntry As KeyBasedTreeEntry
public:
KeyBasedTreeEntry^ GetEntry()
member GetEntry : unit -> KeyBasedTreeEntry

Return Value

KeyBasedTreeEntry
A copy of the KeyBasedTreeEntry.
See Also

Reference

KeyBasedTreeEntryError Class


KeyBasedTreeEntryErrorType Enumeration

An Enum indicating the type of error associated with a KeyBasedTreeEntry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum KeyBasedTreeEntryErrorType
Public Enumeration KeyBasedTreeEntryErrorType
public enum class KeyBasedTreeEntryErrorType
type KeyBasedTreeEntryErrorType
Members
Member name | Value | Description
DuplicateEntry | 0 | The same entry appears more than once in the KeyBasedTreeEntries object.
MissingParent | 1 | The parent specified for a entry does not exist in the KeyBasedTreeEntires object.
CircularParentage | 2 | A sub-node has been specified as a parent of one of its ancestors.
InvalidClassificationCode | 3 | The classification code does not match the level and parent code.
BadClassificationLevel | 4 | The classification level is not an integer in range between 1 and 5 inclusive.
BadClassificationCategoryId | 5 | The classification category id is not Revit BuiltInCategory id.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


KeyBasedTreeEntryTable Class

KeyBasedTreeEntryTable represents the collection of key-based tree entries for a document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBKeyBasedTreeEntryTable
Autodesk.Revit.DBAssemblyCodeTable
Autodesk.Revit.DBKeynoteTable

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class KeyBasedTreeEntryTable : Element
Public Class KeyBasedTreeEntryTable
    Inherits Element
public ref class KeyBasedTreeEntryTable : public Element
type KeyBasedTreeEntryTable =
    class
        inherit Element
    end

The KeyBasedTreeEntryTable type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetKeyBasedTreeEntries | Gets the KeyBasedTreeEntries for this table.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LoadFrom | Loads KeyBasedTreeEntries from the specified external resource into this KeyBasedTreeEntryTable.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | Reload | Reloads KeyBasedTreeEntries from their currently-stored location into this KeyBasedTreeEntryTable.
Public method | ServerSupports | Checks if the server referenced by the given ExternalResourceReference supports the ExternalResourceReferenceType of this KeyBasedTreeEntryTable.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


KeyBasedTreeEntryTable Properties

The KeyBasedTreeEntryTable type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

KeyBasedTreeEntryTable Class


KeyBasedTreeEntryTable Methods

The KeyBasedTreeEntryTable type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetKeyBasedTreeEntries | Gets the KeyBasedTreeEntries for this table.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LoadFrom | Loads KeyBasedTreeEntries from the specified external resource into this KeyBasedTreeEntryTable.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | Reload | Reloads KeyBasedTreeEntries from their currently-stored location into this KeyBasedTreeEntryTable.
Public method | ServerSupports | Checks if the server referenced by the given ExternalResourceReference supports the ExternalResourceReferenceType of this KeyBasedTreeEntryTable.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

KeyBasedTreeEntryTable Class


KeyBasedTreeEntryTable.GetKeyBasedTreeEntries Method

KeyBasedTreeEntryTableGetKeyBasedTreeEntries Method

Gets the KeyBasedTreeEntries for this table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeyBasedTreeEntries GetKeyBasedTreeEntries()
Public Function GetKeyBasedTreeEntries As KeyBasedTreeEntries
public:
KeyBasedTreeEntries^ GetKeyBasedTreeEntries()
member GetKeyBasedTreeEntries : unit -> KeyBasedTreeEntries

Return Value

KeyBasedTreeEntries
The KeyBasedTreeEntries for this table.
See Also

Reference

KeyBasedTreeEntryTable Class


KeyBasedTreeEntryTable.LoadFrom Method

KeyBasedTreeEntryTableLoadFrom Method

Loads KeyBasedTreeEntries from the specified external resource into this KeyBasedTreeEntryTable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExternalResourceLoadStatus LoadFrom(
    ExternalResourceReference desiredResourceReference,
    KeyBasedTreeEntriesLoadResults loadResults
)
Public Function LoadFrom (
    desiredResourceReference As ExternalResourceReference,
    loadResults As KeyBasedTreeEntriesLoadResults
) As ExternalResourceLoadStatus
public:
ExternalResourceLoadStatus LoadFrom(
    ExternalResourceReference^ desiredResourceReference,
    KeyBasedTreeEntriesLoadResults^ loadResults
)
member LoadFrom :
        desiredResourceReference : ExternalResourceReference *
        loadResults : KeyBasedTreeEntriesLoadResults -> ExternalResourceLoadStatus

Parameters

desiredResourceReference ExternalResourceReference
An external resource reference describing the source of the desired KeyBasedTreeEntry data.
loadResults KeyBasedTreeEntriesLoadResults

If provided, Revit will use this object to store any errors or warnings that were encountered.

This argument may be .

Return Value

ExternalResourceLoadStatus
Returns whether the operation succeeded or failed.
Exceptions
Exception | Condition
ArgumentException | The server referenced by the ExternalResourceReference does not exist or does not implement IExternalResourceServer. -or- The server referenced by the ExternalResourceReference cannot support the ExternalResourceReferenceType of this KeyBasedTreeEntryTable. -or- The ExternalResourceReference (desiredResourceReference) is not in a format that is supported by its server.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document containing this KeyBasedTreeEntryTable is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document containing this KeyBasedTreeEntryTable is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document containing this KeyBasedTreeEntryTable has no open transaction.
See Also

Reference

KeyBasedTreeEntryTable Class


KeyBasedTreeEntryTable.Reload Method

KeyBasedTreeEntryTableReload Method

Reloads KeyBasedTreeEntries from their currently-stored location into this KeyBasedTreeEntryTable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExternalResourceLoadStatus Reload(
    KeyBasedTreeEntriesLoadResults loadResults
)
Public Function Reload (
    loadResults As KeyBasedTreeEntriesLoadResults
) As ExternalResourceLoadStatus
public:
ExternalResourceLoadStatus Reload(
    KeyBasedTreeEntriesLoadResults^ loadResults
)
member Reload :
        loadResults : KeyBasedTreeEntriesLoadResults -> ExternalResourceLoadStatus

Parameters

loadResults KeyBasedTreeEntriesLoadResults

If provided, Revit will use this object to store any errors or warnings that were encountered. Note that if the KeyBasedTreeEntries in the model are already up to date, no errors or warnings will be added to this object.

This argument may be .

Return Value

ExternalResourceLoadStatus
Returns the outcome of the reload operation.
Exceptions
Exception | Condition
ModificationForbiddenException | The document containing this KeyBasedTreeEntryTable is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document containing this KeyBasedTreeEntryTable is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document containing this KeyBasedTreeEntryTable has no open transaction.
Remarks
Revit will try to read KeyBasedTreeEntries from the resource reference stored within the KeyBasedTreeEntryTable. If the operation fails, the table will be unchanged.
See Also

Reference

KeyBasedTreeEntryTable Class


KeyBasedTreeEntryTable.ServerSupports Method

KeyBasedTreeEntryTableServerSupports Method

Checks if the server referenced by the given ExternalResourceReference supports the ExternalResourceReferenceType of this KeyBasedTreeEntryTable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ServerSupports(
    ExternalResourceReference extRef
)
Public Function ServerSupports (
    extRef As ExternalResourceReference
) As Boolean
public:
bool ServerSupports(
    ExternalResourceReference^ extRef
)
member ServerSupports :
        extRef : ExternalResourceReference -> bool

Parameters

extRef ExternalResourceReference
The ExternalResourceReference to check.

Return Value

Boolean
True if the ExternalResourceReference refers to a server that supports the ExternalResourceReferenceType of this KeyBasedTreeEntryTable. False otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

KeyBasedTreeEntryTable Class


KeynoteEntries Class

A collection of KeynoteEntry objects that make up the keynote table.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBKeyBasedTreeEntries
Autodesk.Revit.DBKeynoteEntries

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class KeynoteEntries : KeyBasedTreeEntries
Public Class KeynoteEntries
    Inherits KeyBasedTreeEntries
public ref class KeynoteEntries : public KeyBasedTreeEntries
type KeynoteEntries =
    class
        inherit KeyBasedTreeEntries
    end

The KeynoteEntries type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from KeyBasedTreeEntries)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from KeyBasedTreeEntries)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | FindEntry | Finds the KeyBasedTreeEntry associated with the given key value. (Inherited from KeyBasedTreeEntries)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection. (Inherited from KeyBasedTreeEntries)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from KeyBasedTreeEntries)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetKeyBasedTreeEntriesIterator | Returns a KeyBasedTreeEntriesIterator that iterates through the collection. (Inherited from KeyBasedTreeEntries)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | LoadKeynoteEntriesFromFile | Loads the contents of a keynote text file into the provided KeyBasedTreeEntriesLoadContent.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


KeynoteEntries Properties

The KeynoteEntries type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from KeyBasedTreeEntries)
Top
See Also

Reference

KeynoteEntries Class


KeynoteEntries Methods

The KeynoteEntries type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from KeyBasedTreeEntries)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | FindEntry | Finds the KeyBasedTreeEntry associated with the given key value. (Inherited from KeyBasedTreeEntries)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection. (Inherited from KeyBasedTreeEntries)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from KeyBasedTreeEntries)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetKeyBasedTreeEntriesIterator | Returns a KeyBasedTreeEntriesIterator that iterates through the collection. (Inherited from KeyBasedTreeEntries)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | LoadKeynoteEntriesFromFile | Loads the contents of a keynote text file into the provided KeyBasedTreeEntriesLoadContent.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

KeynoteEntries Class


KeynoteEntries.LoadKeynoteEntriesFromFile Method

KeynoteEntriesLoadKeynoteEntriesFromFile Method

Loads the contents of a keynote text file into the provided KeyBasedTreeEntriesLoadContent.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool LoadKeynoteEntriesFromFile(
    string filePath,
    KeyBasedTreeEntriesLoadContent keynoteContent
)
Public Shared Function LoadKeynoteEntriesFromFile (
    filePath As String,
    keynoteContent As KeyBasedTreeEntriesLoadContent
) As Boolean
public:
static bool LoadKeynoteEntriesFromFile(
    String^ filePath,
    KeyBasedTreeEntriesLoadContent^ keynoteContent
)
static member LoadKeynoteEntriesFromFile :
        filePath : string *
        keynoteContent : KeyBasedTreeEntriesLoadContent -> bool

Parameters

filePath String
The full path of the existing keynotefile.
keynoteContent KeyBasedTreeEntriesLoadContent
The keynote entries read from the filePath will be added to this object. A KeyBasedTreeEntriesLoadContent object will also be updated to contain status information, including information about any errors that occurred while reading the keynote entries from the specified file.

Return Value

Boolean
True if reading the keynote file succeeds; False if the keynote file cannot be read.
Exceptions
Exception | Condition
ArgumentException | filePath is an empty string. -or- The KeyBasedTreeEntries object owned by this KeyBasedTreeEntriesLoadContent object is built already. Adding more KeyBasedTreeEntries as well as repeated building, is not supported.
ArgumentNullException | A non-optional argument was null
InvalidPathArgumentException | The destination file name includes one or more invalid characters.
Remarks
The entries read from the file will be added to any existing entries read from other files before this reading operation in the provided KeyBasedTreeEntriesLoadContent. if file A was read, and then file B was failed to read, all the entries from file A will still be there to build KeynoteEntries object.
See Also

Reference

KeynoteEntries Class


KeynoteEntry Class

Represents an entry in the keynote table, containing the key value, keynote text, and parent key (if applicable).
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBKeyBasedTreeEntry
Autodesk.Revit.DBKeynoteEntry

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class KeynoteEntry : KeyBasedTreeEntry
Public Class KeynoteEntry
    Inherits KeyBasedTreeEntry
public ref class KeynoteEntry : public KeyBasedTreeEntry
type KeynoteEntry =
    class
        inherit KeyBasedTreeEntry
    end

The KeynoteEntry type exposes the following members.

Constructors
 | Name | Description
Public method | KeynoteEntry(String, String) | Constructs a new KeynoteEntry from the given key name and keynote text. KeynoteEntry objects created from this constructor will not have parents.
Public method | KeynoteEntry(String, String, String) | Constructs a new KeynoteEntry from the given key name, parent key name, and keynote text.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from KeyBasedTreeEntry)
Public property | Key | The key of this entry. (Inherited from KeyBasedTreeEntry)
Public property | KeynoteText | The text associated with this KeynoteEntry.
Public property | ParentKey | The parent key of this entry. (Inherited from KeyBasedTreeEntry)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from KeyBasedTreeEntry)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetChildrenKeys | Gets a collection containing the keys of all children entry objects from this entry. (Inherited from KeyBasedTreeEntry)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


KeynoteEntry Constructor

Overload List
 | Name | Description
Public method | KeynoteEntry(String, String) | Constructs a new KeynoteEntry from the given key name and keynote text. KeynoteEntry objects created from this constructor will not have parents.
Public method | KeynoteEntry(String, String, String) | Constructs a new KeynoteEntry from the given key name, parent key name, and keynote text.
Top
See Also

Reference

KeynoteEntry Class


KeynoteEntry(String, String) Constructor

Constructs a new KeynoteEntry from the given key name and keynote text. KeynoteEntry objects created from this constructor will not have parents.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeynoteEntry(
    string key,
    string text
)
Public Sub New (
    key As String,
    text As String
)
public:
KeynoteEntry(
    String^ key,
    String^ text
)
new :
        key : string *
        text : string -> KeynoteEntry

Parameters

key String
The key of this KeynoteEntry
text String
The text associated with this KeynoteEntry
Exceptions
Exception | Condition
ArgumentException | key is an empty string.
ArgumentNullException | A non-optional argument was null
See Also

Reference

KeynoteEntry Class
KeynoteEntry Overload


KeynoteEntry(String, String, String) Constructor

Constructs a new KeynoteEntry from the given key name, parent key name, and keynote text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public KeynoteEntry(
    string key,
    string parentKey,
    string text
)
Public Sub New (
    key As String,
    parentKey As String,
    text As String
)
public:
KeynoteEntry(
    String^ key,
    String^ parentKey,
    String^ text
)
new :
        key : string *
        parentKey : string *
        text : string -> KeynoteEntry

Parameters

key String
The key of this KeynoteEntry.
parentKey String
The parent key of this KeynoteEntry. Empty string means this KeynoteEntry does not have a parent.
text String
The text associated with this KeynoteEntry
Exceptions
Exception | Condition
ArgumentException | key is an empty string.
ArgumentNullException | A non-optional argument was null
See Also

Reference

KeynoteEntry Class
KeynoteEntry Overload


KeynoteEntry Properties

The KeynoteEntry type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from KeyBasedTreeEntry)
Public property | Key | The key of this entry. (Inherited from KeyBasedTreeEntry)
Public property | KeynoteText | The text associated with this KeynoteEntry.
Public property | ParentKey | The parent key of this entry. (Inherited from KeyBasedTreeEntry)
Top
See Also

Reference

KeynoteEntry Class


KeynoteEntry.KeynoteText Property

KeynoteEntryKeynoteText Property

The text associated with this KeynoteEntry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string KeynoteText { get; }
Public ReadOnly Property KeynoteText As String
    Get
public:
property String^ KeynoteText {
    String^ get ();
}
member KeynoteText : string with get

Property Value

String
Remarks
This value does not have to be set; if not set, the property returns an empty string.
See Also

Reference

KeynoteEntry Class


KeynoteEntry Methods

The KeynoteEntry type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from KeyBasedTreeEntry)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetChildrenKeys | Gets a collection containing the keys of all children entry objects from this entry. (Inherited from KeyBasedTreeEntry)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

KeynoteEntry Class


KeynoteTable Class

KeynoteTable represents the collection of keynotes (KeynoteEntries) for a document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBKeyBasedTreeEntryTable
Autodesk.Revit.DBKeynoteTable

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class KeynoteTable : KeyBasedTreeEntryTable
Public Class KeynoteTable
    Inherits KeyBasedTreeEntryTable
public ref class KeynoteTable : public KeyBasedTreeEntryTable
type KeynoteTable =
    class
        inherit KeyBasedTreeEntryTable
    end

The KeynoteTable type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetKeyBasedTreeEntries | Gets the KeyBasedTreeEntries for this table. (Inherited from KeyBasedTreeEntryTable)
 | GetKeynoteTable | Gets the KeynoteTable from a Revit document.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LoadFrom | Loads KeyBasedTreeEntries from the specified external resource into this KeyBasedTreeEntryTable. (Inherited from KeyBasedTreeEntryTable)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | Reload | Reloads KeyBasedTreeEntries from their currently-stored location into this KeyBasedTreeEntryTable. (Inherited from KeyBasedTreeEntryTable)
Public method | ServerSupports | Checks if the server referenced by the given ExternalResourceReference supports the ExternalResourceReferenceType of this KeyBasedTreeEntryTable. (Inherited from KeyBasedTreeEntryTable)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


KeynoteTable Properties

The KeynoteTable type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

KeynoteTable Class


KeynoteTable Methods

The KeynoteTable type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetKeyBasedTreeEntries | Gets the KeyBasedTreeEntries for this table. (Inherited from KeyBasedTreeEntryTable)
 | GetKeynoteTable | Gets the KeynoteTable from a Revit document.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LoadFrom | Loads KeyBasedTreeEntries from the specified external resource into this KeyBasedTreeEntryTable. (Inherited from KeyBasedTreeEntryTable)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | Reload | Reloads KeyBasedTreeEntries from their currently-stored location into this KeyBasedTreeEntryTable. (Inherited from KeyBasedTreeEntryTable)
Public method | ServerSupports | Checks if the server referenced by the given ExternalResourceReference supports the ExternalResourceReferenceType of this KeyBasedTreeEntryTable. (Inherited from KeyBasedTreeEntryTable)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

KeynoteTable Class


KeynoteTable.GetKeynoteTable Method

KeynoteTableGetKeynoteTable Method

Gets the KeynoteTable from a Revit document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static KeynoteTable GetKeynoteTable(
    Document aDoc
)
Public Shared Function GetKeynoteTable (
    aDoc As Document
) As KeynoteTable
public:
static KeynoteTable^ GetKeynoteTable(
    Document^ aDoc
)
static member GetKeynoteTable :
        aDoc : Document -> KeynoteTable

Parameters

aDoc Document
The Revit document.

Return Value

KeynoteTable
The KeynoteTable.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

KeynoteTable Class


LabelType Enumeration

The label type in dimension equality formats.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum LabelType
Public Enumeration LabelType
public enum class LabelType
type LabelType
Members
Member name | Value | Description
NumberOfWitnessLines | 0 | The number of witness lines of the dimension.
NumberOfSegments | 1 | The number of segments of the dimension.
LengthOfSegment | 2 | The length of segments of the dimension.
TotalLength | 3 | The total length of the dimension.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LabelUtils Class

Used to obtain user-visible names for enums.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBLabelUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LabelUtils : IDisposable
Public Class LabelUtils
    Implements IDisposable
public ref class LabelUtils : IDisposable
type LabelUtils =
    class
        interface IDisposable
    end

The LabelUtils type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the LabelUtils
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
 | GetLabelFor(BuiltInCategory) | Gets the user-visible name for a BuiltInCategory.
 | GetLabelFor(BuiltInParameter) | Gets the user-visible name for a BuiltInParameter.
 | GetLabelFor(BuiltInParameter, LanguageType) | Gets the user-visible name for a BuiltInParameter in a specific LanguageType.
 | GetLabelFor(DuctLossMethodType, Document) | Gets the user-visible name for a DuctLossMethodType.
 | GetLabelFor(gbXMLBuildingType, Document) | Gets the user-visible name for a gbXMLBuildingType.
 | GetLabelFor(PipeFlowState, Document) | Gets the user-visible name for a PipeFlowState.
 | GetLabelFor(PipeLossMethodType, Document) | Gets the user-visible name for a PipeLossMethodType.
 | GetLabelForBuiltInParameter(ForgeTypeId) | Gets the user-visible name for a built-in parameter.
 | GetLabelForBuiltInParameter(ForgeTypeId, LanguageType) | Gets the user-visible name for a built-in parameter in a specific LanguageType.
 | GetLabelForDiscipline | Gets the user-visible name for a discipline.
 | GetLabelForGroup | Gets the user-visible name for a built-in parameter group. To get the name of parameter group "Other", pass an empty, default-constructed ForgeTypeId.
 | GetLabelForSpec | Gets the user-visible name for a spec.
 | GetLabelForSymbol | Gets the user-visible name for a symbol.
 | GetLabelForUnit | Gets the user-visible name for a unit.
 | GetStructuralSectionShapeName | Gets the user-visible name for a StructuralSectionShape.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LabelUtils Properties

The LabelUtils type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

LabelUtils Class


LabelUtils.IsValidObject Property

LabelUtilsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

LabelUtils Class


LabelUtils Methods

The LabelUtils type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
 | GetLabelFor(BuiltInCategory) | Gets the user-visible name for a BuiltInCategory.
 | GetLabelFor(BuiltInParameter) | Gets the user-visible name for a BuiltInParameter.
 | GetLabelFor(BuiltInParameter, LanguageType) | Gets the user-visible name for a BuiltInParameter in a specific LanguageType.
 | GetLabelFor(DuctLossMethodType, Document) | Gets the user-visible name for a DuctLossMethodType.
 | GetLabelFor(gbXMLBuildingType, Document) | Gets the user-visible name for a gbXMLBuildingType.
 | GetLabelFor(PipeFlowState, Document) | Gets the user-visible name for a PipeFlowState.
 | GetLabelFor(PipeLossMethodType, Document) | Gets the user-visible name for a PipeLossMethodType.
 | GetLabelForBuiltInParameter(ForgeTypeId) | Gets the user-visible name for a built-in parameter.
 | GetLabelForBuiltInParameter(ForgeTypeId, LanguageType) | Gets the user-visible name for a built-in parameter in a specific LanguageType.
 | GetLabelForDiscipline | Gets the user-visible name for a discipline.
 | GetLabelForGroup | Gets the user-visible name for a built-in parameter group. To get the name of parameter group "Other", pass an empty, default-constructed ForgeTypeId.
 | GetLabelForSpec | Gets the user-visible name for a spec.
 | GetLabelForSymbol | Gets the user-visible name for a symbol.
 | GetLabelForUnit | Gets the user-visible name for a unit.
 | GetStructuralSectionShapeName | Gets the user-visible name for a StructuralSectionShape.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LabelUtils Class


LabelUtils.Dispose Method

LabelUtilsDispose Method

Releases all resources used by the LabelUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

LabelUtils Class


LabelUtils.GetLabelFor Method

LabelUtilsGetLabelFor Method

Overload List
Name | Description
GetLabelFor(BuiltInCategory) | Gets the user-visible name for a BuiltInCategory.
GetLabelFor(BuiltInParameter) | Gets the user-visible name for a BuiltInParameter.
GetLabelFor(BuiltInParameter, LanguageType) | Gets the user-visible name for a BuiltInParameter in a specific LanguageType.
GetLabelFor(DuctLossMethodType, Document) | Gets the user-visible name for a DuctLossMethodType.
GetLabelFor(gbXMLBuildingType, Document) | Gets the user-visible name for a gbXMLBuildingType.
GetLabelFor(PipeFlowState, Document) | Gets the user-visible name for a PipeFlowState.
GetLabelFor(PipeLossMethodType, Document) | Gets the user-visible name for a PipeLossMethodType.
Top
See Also

Reference

LabelUtils Class


LabelUtils.GetLabelFor(BuiltInCategory) Method

LabelUtilsGetLabelFor(BuiltInCategory) Method

Gets the user-visible name for a BuiltInCategory.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetLabelFor(
    BuiltInCategory builtInCategory
)
Public Shared Function GetLabelFor (
    builtInCategory As BuiltInCategory
) As String
public:
static String^ GetLabelFor(
    BuiltInCategory builtInCategory
)
static member GetLabelFor :
        builtInCategory : BuiltInCategory -> string

Parameters

builtInCategory BuiltInCategory
The BuiltInCategory to get the user-visible name.

Return Value

String
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the builtin category is not valid.
Remarks
The name is obtained in the current Revit language.
See Also

Reference

LabelUtils Class
GetLabelFor Overload


LabelUtils.GetLabelFor(BuiltInParameter) Method

LabelUtilsGetLabelFor(BuiltInParameter) Method

Gets the user-visible name for a BuiltInParameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetLabelFor(
    BuiltInParameter builtInParam
)
Public Shared Function GetLabelFor (
    builtInParam As BuiltInParameter
) As String
public:
static String^ GetLabelFor(
    BuiltInParameter builtInParam
)
static member GetLabelFor :
        builtInParam : BuiltInParameter -> string

Parameters

builtInParam BuiltInParameter
The BuiltInParameter to get the user-visible name.

Return Value

String
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the BuiltInParameter cannot be found.
Remarks
The name is obtained in the current Revit language.
See Also

Reference

LabelUtils Class
GetLabelFor Overload


LabelUtils.GetLabelFor(BuiltInParameter, LanguageType) Method

LabelUtilsGetLabelFor(BuiltInParameter, LanguageType) Method

Gets the user-visible name for a BuiltInParameter in a specific LanguageType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetLabelFor(
    BuiltInParameter builtInParam,
    LanguageType language
)
Public Shared Function GetLabelFor (
    builtInParam As BuiltInParameter,
    language As LanguageType
) As String
public:
static String^ GetLabelFor(
    BuiltInParameter builtInParam,
    LanguageType language
)
static member GetLabelFor :
        builtInParam : BuiltInParameter *
        language : LanguageType -> string

Parameters

builtInParam BuiltInParameter
The BuiltInParameter to get the user-visible name.
language LanguageType
The desired LanguageType to get the user-visible name in.

Return Value

String
The BuiltInParameter name in the desired LanguageType.
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the BuiltInParameter cannot be found.
InvalidOperationException | Thrown when the desired LanguageType cannot be found for the BuiltInParameter name.
See Also

Reference

LabelUtils Class
GetLabelFor Overload


LabelUtils.GetLabelFor(DuctLossMethodType, Document) Method

LabelUtilsGetLabelFor(DuctLossMethodType, Document) Method

Gets the user-visible name for a DuctLossMethodType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetLabelFor(
    DuctLossMethodType ductLossMethodType,
    Document doc
)
Public Shared Function GetLabelFor (
    ductLossMethodType As DuctLossMethodType,
    doc As Document
) As String
public:
static String^ GetLabelFor(
    DuctLossMethodType ductLossMethodType,
    Document^ doc
)
static member GetLabelFor :
        ductLossMethodType : DuctLossMethodType *
        doc : Document -> string

Parameters

ductLossMethodType DuctLossMethodType
The DuctLossMethodType to get the user-visible name.
doc Document
The document from which to get the DuctLossMethodType.

Return Value

String
Exceptions
Exception | Condition
InvalidOperationException | Thrown when information for the input DuctLossMethodType cannot be found.
Remarks
The name is obtained in the current Revit language.
See Also

Reference

LabelUtils Class
GetLabelFor Overload


LabelUtils.GetLabelFor(gbXMLBuildingType, Document) Method

LabelUtilsGetLabelFor(gbXMLBuildingType, Document) Method

Gets the user-visible name for a gbXMLBuildingType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetLabelFor(
    gbXMLBuildingType buildingType,
    Document document
)
Public Shared Function GetLabelFor (
    buildingType As gbXMLBuildingType,
    document As Document
) As String
public:
static String^ GetLabelFor(
    gbXMLBuildingType buildingType,
    Document^ document
)
static member GetLabelFor :
        buildingType : gbXMLBuildingType *
        document : Document -> string

Parameters

buildingType gbXMLBuildingType
The gbXMLBuildingType to get the user-visible name.
document Document
The document from which to get the gbXMLBuildingType.

Return Value

String
Exceptions
Exception | Condition
ArgumentException | The input gXMLBuildingType is not available in the document.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Remarks
The name is obtained in the current Revit language.
See Also

Reference

LabelUtils Class
GetLabelFor Overload


LabelUtils.GetLabelFor(PipeFlowState, Document) Method

LabelUtilsGetLabelFor(PipeFlowState, Document) Method

Gets the user-visible name for a PipeFlowState.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetLabelFor(
    PipeFlowState pipeFlowState,
    Document doc
)
Public Shared Function GetLabelFor (
    pipeFlowState As PipeFlowState,
    doc As Document
) As String
public:
static String^ GetLabelFor(
    PipeFlowState pipeFlowState,
    Document^ doc
)
static member GetLabelFor :
        pipeFlowState : PipeFlowState *
        doc : Document -> string

Parameters

pipeFlowState PipeFlowState
The PipeFlowState to get the user-visible name.
doc Document
The document from which to get the PipeFlowState.

Return Value

String
Exceptions
Exception | Condition
InvalidOperationException | Thrown when information for the input PipeFlowState cannot be found.
Remarks
The name is obtained in the current Revit language.
See Also

Reference

LabelUtils Class
GetLabelFor Overload


LabelUtils.GetLabelFor(PipeLossMethodType, Document) Method

LabelUtilsGetLabelFor(PipeLossMethodType, Document) Method

Gets the user-visible name for a PipeLossMethodType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetLabelFor(
    PipeLossMethodType pipeLossMethodType,
    Document doc
)
Public Shared Function GetLabelFor (
    pipeLossMethodType As PipeLossMethodType,
    doc As Document
) As String
public:
static String^ GetLabelFor(
    PipeLossMethodType pipeLossMethodType,
    Document^ doc
)
static member GetLabelFor :
        pipeLossMethodType : PipeLossMethodType *
        doc : Document -> string

Parameters

pipeLossMethodType PipeLossMethodType
The PipeLossMethodType to get the user-visible name.
doc Document
The document from which to get the PipeLossMethodType.

Return Value

String
Exceptions
Exception | Condition
InvalidOperationException | Thrown when information for the input PipeLossMethodType cannot be found.
Remarks
The name is obtained in the current Revit language.
See Also

Reference

LabelUtils Class
GetLabelFor Overload


LabelUtils.GetLabelForBuiltInParameter Method

LabelUtilsGetLabelForBuiltInParameter Method

Overload List
Name | Description
GetLabelForBuiltInParameter(ForgeTypeId) | Gets the user-visible name for a built-in parameter.
GetLabelForBuiltInParameter(ForgeTypeId, LanguageType) | Gets the user-visible name for a built-in parameter in a specific LanguageType.
Top
See Also

Reference

LabelUtils Class


LabelUtils.GetLabelForBuiltInParameter(ForgeTypeId) Method

LabelUtilsGetLabelForBuiltInParameter(ForgeTypeId) Method

Gets the user-visible name for a built-in parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetLabelForBuiltInParameter(
    ForgeTypeId parameterTypeId
)
Public Shared Function GetLabelForBuiltInParameter (
    parameterTypeId As ForgeTypeId
) As String
public:
static String^ GetLabelForBuiltInParameter(
    ForgeTypeId^ parameterTypeId
)
static member GetLabelForBuiltInParameter :
        parameterTypeId : ForgeTypeId -> string

Parameters

parameterTypeId ForgeTypeId
Identifier of the built-in parameter to get the user-visible name.

Return Value

String
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the built-in parameter cannot be found.
Remarks
The name is obtained in the current Revit language.
See Also

Reference

LabelUtils Class
GetLabelForBuiltInParameter Overload


LabelUtils.GetLabelForBuiltInParameter(ForgeTypeId, LanguageType) Method

LabelUtilsGetLabelForBuiltInParameter(ForgeTypeId, LanguageType) Method

Gets the user-visible name for a built-in parameter in a specific LanguageType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetLabelForBuiltInParameter(
    ForgeTypeId parameterTypeId,
    LanguageType language
)
Public Shared Function GetLabelForBuiltInParameter (
    parameterTypeId As ForgeTypeId,
    language As LanguageType
) As String
public:
static String^ GetLabelForBuiltInParameter(
    ForgeTypeId^ parameterTypeId,
    LanguageType language
)
static member GetLabelForBuiltInParameter :
        parameterTypeId : ForgeTypeId *
        language : LanguageType -> string

Parameters

parameterTypeId ForgeTypeId
Identifier of the built-in parameter to get the user-visible name.
language LanguageType
The desired LanguageType to get the user-visible name in.

Return Value

String
The built-in parameter name in the desired LanguageType.
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the built-in parameter cannot be found.
InvalidOperationException | Thrown when the desired LanguageType cannot be found for the built-in parameter name.
See Also

Reference

LabelUtils Class
GetLabelForBuiltInParameter Overload


LabelUtils.GetLabelForDiscipline Method

LabelUtilsGetLabelForDiscipline Method

Gets the user-visible name for a discipline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetLabelForDiscipline(
    ForgeTypeId disciplineTypeId
)
Public Shared Function GetLabelForDiscipline (
    disciplineTypeId As ForgeTypeId
) As String
public:
static String^ GetLabelForDiscipline(
    ForgeTypeId^ disciplineTypeId
)
static member GetLabelForDiscipline :
        disciplineTypeId : ForgeTypeId -> string

Parameters

disciplineTypeId ForgeTypeId
Identifier of the discipline.

Return Value

String
Exceptions
Exception | Condition
ArgumentException | Discipline must have a definition.
ArgumentNullException | A non-optional argument was null
Remarks
The name is obtained in the current Revit language.
See Also

Reference

LabelUtils Class


LabelUtils.GetLabelForGroup Method

LabelUtilsGetLabelForGroup Method

Gets the user-visible name for a built-in parameter group. To get the name of parameter group "Other", pass an empty, default-constructed ForgeTypeId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetLabelForGroup(
    ForgeTypeId groupTypeId
)
Public Shared Function GetLabelForGroup (
    groupTypeId As ForgeTypeId
) As String
public:
static String^ GetLabelForGroup(
    ForgeTypeId^ groupTypeId
)
static member GetLabelForGroup :
        groupTypeId : ForgeTypeId -> string

Parameters

groupTypeId ForgeTypeId
The identifier of the parameter group to get the user-visible name, or an empty ForgeTypeId for group "Other".

Return Value

String
Remarks
The name is obtained in the current Revit language.
See Also

Reference

LabelUtils Class


LabelUtils.GetLabelForSpec Method

LabelUtilsGetLabelForSpec Method

Gets the user-visible name for a spec.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetLabelForSpec(
    ForgeTypeId specTypeId
)
Public Shared Function GetLabelForSpec (
    specTypeId As ForgeTypeId
) As String
public:
static String^ GetLabelForSpec(
    ForgeTypeId^ specTypeId
)
static member GetLabelForSpec :
        specTypeId : ForgeTypeId -> string

Parameters

specTypeId ForgeTypeId
Identifier of the spec to get the user-visible name.

Return Value

String
Exceptions
Exception | Condition
ArgumentException | The given identifier is neither a spec nor a category.
ArgumentNullException | A non-optional argument was null
Remarks
The name is obtained in the current Revit language. If the given identifier is a category, this method returns the name of the Family Type spec with that category, e.g. "Family Type: Walls".
See Also

Reference

LabelUtils Class


LabelUtils.GetLabelForSymbol Method

LabelUtilsGetLabelForSymbol Method

Gets the user-visible name for a symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetLabelForSymbol(
    ForgeTypeId symbolTypeId
)
Public Shared Function GetLabelForSymbol (
    symbolTypeId As ForgeTypeId
) As String
public:
static String^ GetLabelForSymbol(
    ForgeTypeId^ symbolTypeId
)
static member GetLabelForSymbol :
        symbolTypeId : ForgeTypeId -> string

Parameters

symbolTypeId ForgeTypeId
Identifier of the symbol to get the user-visible name.

Return Value

String
Exceptions
Exception | Condition
ArgumentException | Symbol must have a definition.
ArgumentNullException | A non-optional argument was null
Remarks
The name is obtained in the current Revit language.
See Also

Reference

LabelUtils Class


LabelUtils.GetLabelForUnit Method

LabelUtilsGetLabelForUnit Method

Gets the user-visible name for a unit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetLabelForUnit(
    ForgeTypeId unitTypeId
)
Public Shared Function GetLabelForUnit (
    unitTypeId As ForgeTypeId
) As String
public:
static String^ GetLabelForUnit(
    ForgeTypeId^ unitTypeId
)
static member GetLabelForUnit :
        unitTypeId : ForgeTypeId -> string

Parameters

unitTypeId ForgeTypeId
Identifier of the unit to get the user-visible name.

Return Value

String
Exceptions
Exception | Condition
ArgumentException | Cannot find DisplayUnitTypeInfo for the given unit identifier.
ArgumentNullException | A non-optional argument was null
Remarks
The name is obtained in the current Revit language.
See Also

Reference

LabelUtils Class


LabelUtils.GetStructuralSectionShapeName Method

LabelUtilsGetStructuralSectionShapeName Method

Gets the user-visible name for a StructuralSectionShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetStructuralSectionShapeName(
    StructuralSectionShape shape
)
Public Shared Function GetStructuralSectionShapeName (
    shape As StructuralSectionShape
) As String
public:
static String^ GetStructuralSectionShapeName(
    StructuralSectionShape shape
)
static member GetStructuralSectionShapeName :
        shape : StructuralSectionShape -> string

Parameters

shape StructuralSectionShape
The StructuralSectionShape to get the user-visible name.

Return Value

String
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

LabelUtils Class


LayerCategoryType Enumeration

An enumerated type listing category types supported in an ExportLayerTable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum LayerCategoryType
Public Enumeration LayerCategoryType
public enum class LayerCategoryType
type LayerCategoryType
Members
Member name | Value | Description
Model | 0 | Model categories.
Annotation | 1 | Annotation categories.
AnalyticalModel | 2 | AnalyticalModel categories.
Imported | 3 | Imported categories.
Modifier | 4 | A special value related to modifiers.
Unsorted | -1 | A default unsorted type.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LayerModifier Class

A modifier used to designate extra strings to appear in the exported layer name.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBLayerModifier

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LayerModifier : IDisposable
Public Class LayerModifier
    Implements IDisposable
public ref class LayerModifier : IDisposable
type LayerModifier =
    class
        interface IDisposable
    end

The LayerModifier type exposes the following members.

Constructors
 | Name | Description
Public method | LayerModifier | Constructs a new LayerModifier with default values.
Public method | LayerModifier(ModifierType, String) | Constructs a new LayerModifier with modifierType and separator.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ModifierType | The modifier type of LayerModifier.
Public property | Separator | The separator string that will follow this modifier in the export layer name.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the LayerModifier
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
A modifier consists of a type (from ModifierType and an optional separator. Apply a modifier to one or more ExportLayerInfo objects to modify the layer name that will be assigned when a Revit object is exported.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LayerModifier Constructor

Overload List
 | Name | Description
Public method | LayerModifier | Constructs a new LayerModifier with default values.
Public method | LayerModifier(ModifierType, String) | Constructs a new LayerModifier with modifierType and separator.
Top
See Also

Reference

LayerModifier Class


LayerModifier Constructor

Constructs a new LayerModifier with default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LayerModifier()
Public Sub New
public:
LayerModifier()
new : unit -> LayerModifier
See Also

Reference

LayerModifier Class
LayerModifier Overload


LayerModifier(ModifierType, String) Constructor

Constructs a new LayerModifier with modifierType and separator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LayerModifier(
    ModifierType modifierType,
    string separator
)
Public Sub New (
    modifierType As ModifierType,
    separator As String
)
public:
LayerModifier(
    ModifierType modifierType,
    String^ separator
)
new :
        modifierType : ModifierType *
        separator : string -> LayerModifier

Parameters

modifierType ModifierType
The modifier type.
separator String
The separator string that will follow this modifier in the export layer name.
Exceptions
Exception | Condition
ArgumentException | The provided separator contains invalid characters (most special characters are invalid).
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

LayerModifier Class
LayerModifier Overload


LayerModifier Properties

The LayerModifier type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ModifierType | The modifier type of LayerModifier.
Public property | Separator | The separator string that will follow this modifier in the export layer name.
Top
See Also

Reference

LayerModifier Class


LayerModifier.IsValidObject Property

LayerModifierIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

LayerModifier Class


LayerModifier.ModifierType Property

LayerModifierModifierType Property

The modifier type of LayerModifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ModifierType ModifierType { get; set; }
Public Property ModifierType As ModifierType
    Get
    Set
public:
property ModifierType ModifierType {
    ModifierType get ();
    void set (ModifierType value);
}
member ModifierType : ModifierType with get, set

Property Value

ModifierType
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

LayerModifier Class


LayerModifier.Separator Property

LayerModifierSeparator Property

The separator string that will follow this modifier in the export layer name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Separator { get; set; }
Public Property Separator As String
    Get
    Set
public:
property String^ Separator {
    String^ get ();
    void set (String^ value);
}
member Separator : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

LayerModifier Class


LayerModifier Methods

The LayerModifier type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LayerModifier Class


LayerModifier.Dispose Method

LayerModifierDispose Method

Releases all resources used by the LayerModifier

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

LayerModifier Class


LayoutRule Class

The LayoutRule object is a base object for all type of layout rules for Beam System within the Autodesk Revit API.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBLayoutRule
Autodesk.Revit.DBLayoutRuleClearSpacing
Autodesk.Revit.DBLayoutRuleFixedDistance
Autodesk.Revit.DBLayoutRuleFixedNumber
Autodesk.Revit.DBLayoutRuleMaximumSpacing

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class LayoutRule : APIObject
Public MustInherit Class LayoutRule
    Inherits APIObject
public ref class LayoutRule abstract : public APIObject
[<AbstractClassAttribute>]
type LayoutRule =
    class
        inherit APIObject
    end

The LayoutRule type exposes the following members.

Properties
Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This class just used as the base class of those concrete LayoutRule classes.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LayoutRule Properties

The LayoutRule type exposes the following members.

Properties
Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

LayoutRule Class


LayoutRule Methods

The LayoutRule type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LayoutRule Class


LayoutRuleClearSpacing Class

This class indicate the layout rule of a Beam System is Clear-Spacing.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBLayoutRule
Autodesk.Revit.DBLayoutRuleClearSpacing

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LayoutRuleClearSpacing : LayoutRule
Public Class LayoutRuleClearSpacing
    Inherits LayoutRule
public ref class LayoutRuleClearSpacing : public LayoutRule
type LayoutRuleClearSpacing =
    class
        inherit LayoutRule
    end

The LayoutRuleClearSpacing type exposes the following members.

Constructors
 | Name | Description
Public method | LayoutRuleClearSpacing | Constructor of LayoutRuleFixedDistance. Create LayoutRuleFixedDistance with the values passed in.
Top
Properties
 | Name | Description
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | JustifyType | Get or set the type of justification.
Public property | Spacing | Get or set the spacing of the beam system.
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
To use this type of LayoutRule, the distance between the beams and the justify-type must be set.
Example
C#
VB
C++
F#
Copy
private bool LayoutRuleClearSpacingInformation(BeamSystem beamSystem)
{
    //get the layoutRule of the beamsystem
    Autodesk.Revit.DB.LayoutRule layoutRule = beamSystem.LayoutRule;

    string message = "BeamSystem layout rule : " + layoutRule;

    //create a new instance of the LayoutRuleClearSpacing class
    LayoutRuleClearSpacing myLayoutRuleClearSpacing =
             new LayoutRuleClearSpacing(10.0, BeamSystemJustifyType.Beginning);

    //set the new layoutRule to the beamsystem
    beamSystem.LayoutRule = myLayoutRuleClearSpacing;

    LayoutRuleClearSpacing clearSpacing = beamSystem.LayoutRule as LayoutRuleClearSpacing;
    if (null == clearSpacing)
    {
        return false;
    }

    //try to get the property value of the beamsystem LayoutRule
    BeamSystemJustifyType justifyType = clearSpacing.JustifyType;

    double spacing = clearSpacing.Spacing;

    message += "\nNew BeamSystem layout rule: " + clearSpacing;
    message += "\nNew BeamSystem spacing: " + spacing;
    message += "\nNew BeamSystem justification: " + justifyType;

    TaskDialog.Show("Revit",message);

    return true;
}
Private Function LayoutRuleClearSpacingInformation(beamSystem As BeamSystem) As Boolean
    'get the layoutRule of the beamsystem
    Dim layoutRule As Autodesk.Revit.DB.LayoutRule = beamSystem.LayoutRule

    Dim message As String = "BeamSystem layout rule : " & layoutRule.ToString()

    'create a new instance of the LayoutRuleClearSpacing class
    Dim myLayoutRuleClearSpacing As New LayoutRuleClearSpacing(10.0, BeamSystemJustifyType.Beginning)

    'set the new layoutRule to the beamsystem
    beamSystem.LayoutRule = myLayoutRuleClearSpacing

    Dim clearSpacing As LayoutRuleClearSpacing = TryCast(beamSystem.LayoutRule, LayoutRuleClearSpacing)
    If clearSpacing Is Nothing Then
        Return False
    End If

    'try to get the property value of the beamsystem LayoutRule
    Dim justifyType As BeamSystemJustifyType = clearSpacing.JustifyType

    Dim spacing As Double = clearSpacing.Spacing

    message += vbLf & "New BeamSystem layout rule: " & clearSpacing.ToString()
    message += vbLf & "New BeamSystem spacing: " & spacing
    message += vbLf & "New BeamSystem justification: " & justifyType

    TaskDialog.Show("Revit", message)

    Return True
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LayoutRuleClearSpacing Constructor

Constructor of LayoutRuleFixedDistance. Create LayoutRuleFixedDistance with the values passed in.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LayoutRuleClearSpacing(
    double spacing,
    BeamSystemJustifyType justifyType
)
Public Sub New (
    spacing As Double,
    justifyType As BeamSystemJustifyType
)
public:
LayoutRuleClearSpacing(
    double spacing,
    BeamSystemJustifyType justifyType
)
new :
        spacing : float *
        justifyType : BeamSystemJustifyType -> LayoutRuleClearSpacing

Parameters

spacing Double
The value of spacing must be in [0, 30000).
justifyType BeamSystemJustifyType
The type of the justification, it's corresponding to the items in the element properties dialog.
Remarks
The value of spacing must be in [0, 30000), but in fact the spacing should not be too small or too great.
See Also

Reference

LayoutRuleClearSpacing Class


LayoutRuleClearSpacing Properties

The LayoutRuleClearSpacing type exposes the following members.

Properties
 | Name | Description
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | JustifyType | Get or set the type of justification.
Public property | Spacing | Get or set the spacing of the beam system.
Top
See Also

Reference

LayoutRuleClearSpacing Class


LayoutRuleClearSpacing.JustifyType Property

LayoutRuleClearSpacingJustifyType Property

Get or set the type of justification.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BeamSystemJustifyType JustifyType { get; set; }
Public Property JustifyType As BeamSystemJustifyType
    Get
    Set
public:
property BeamSystemJustifyType JustifyType {
    BeamSystemJustifyType get ();
    void set (BeamSystemJustifyType value);
}
member JustifyType : BeamSystemJustifyType with get, set

Property Value

BeamSystemJustifyType
Remarks
The justifyType passed in must be a valid object.
See Also

Reference

LayoutRuleClearSpacing Class


LayoutRuleClearSpacing.Spacing Property

LayoutRuleClearSpacingSpacing Property

Get or set the spacing of the beam system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Spacing { get; set; }
Public Property Spacing As Double
    Get
    Set
public:
property double Spacing {
    double get ();
    void set (double value);
}
member Spacing : float with get, set

Property Value

Double
Remarks
The value of spacing must be in [0, 30000), but in fact the spacing should not be too small or too great.
See Also

Reference

LayoutRuleClearSpacing Class


LayoutRuleClearSpacing Methods

The LayoutRuleClearSpacing type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LayoutRuleClearSpacing Class


LayoutRuleFixedDistance Class

This class indicate the layout rule of a Beam System is Fixed-Distance.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBLayoutRule
Autodesk.Revit.DBLayoutRuleFixedDistance

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LayoutRuleFixedDistance : LayoutRule
Public Class LayoutRuleFixedDistance
    Inherits LayoutRule
public ref class LayoutRuleFixedDistance : public LayoutRule
type LayoutRuleFixedDistance =
    class
        inherit LayoutRule
    end

The LayoutRuleFixedDistance type exposes the following members.

Constructors
 | Name | Description
Public method | LayoutRuleFixedDistance | Constructor of LayoutRuleFixedDistance. Create LayoutRuleFixedDistance with the values passed in.
Top
Properties
 | Name | Description
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | JustifyType | Get or set the type of justification.
Public property | Spacing | Get or set spacing of the Beam System.
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
To use this type of LayoutRule, the distance between the beams and the justify-type must be set.
Example
C#
VB
C++
F#
Copy
private bool LayoutRuleFixedDistanceInformation(BeamSystem beamSystem)
{
    //get the layoutRule of the beamsystem
    Autodesk.Revit.DB.LayoutRule layoutRule = beamSystem.LayoutRule;

    string message = "BeamSystem layout rule : " + layoutRule;

    //create a new instance of the LayoutRuleClearSpacing class
    LayoutRuleFixedDistance myLayoutRuleFixedDistance =
                new LayoutRuleFixedDistance(10.0, BeamSystemJustifyType.End);

    //set the new layoutRule to the beamsystem
    beamSystem.LayoutRule = myLayoutRuleFixedDistance;

    LayoutRuleFixedDistance fixedDistance = beamSystem.LayoutRule as LayoutRuleFixedDistance;
    if (null == fixedDistance)
    {
        return false;
    }
    //try to get the property value of the beamsystem LayoutRule
    BeamSystemJustifyType justifyType = fixedDistance.JustifyType;

    double spacing = fixedDistance.Spacing;

    message += "\nNew BeamSystem layout rule: " + fixedDistance;
    message += "\nNew BeamSystem spacing: " + spacing;
    message += "\nNew BeamSystem justification: " + justifyType;

    TaskDialog.Show("Revit",message);

    return true;
}
Private Function LayoutRuleFixedDistanceInformation(beamSystem As BeamSystem) As Boolean
    'get the layoutRule of the beamsystem
    Dim layoutRule As Autodesk.Revit.DB.LayoutRule = beamSystem.LayoutRule

    Dim message As String = "BeamSystem layout rule : " & layoutRule.ToString()

    'create a new instance of the LayoutRuleClearSpacing class
    Dim myLayoutRuleFixedDistance As New LayoutRuleFixedDistance(10.0, BeamSystemJustifyType.[End])

    'set the new layoutRule to the beamsystem
    beamSystem.LayoutRule = myLayoutRuleFixedDistance

    Dim fixedDistance As LayoutRuleFixedDistance = TryCast(beamSystem.LayoutRule, LayoutRuleFixedDistance)
    If fixedDistance Is Nothing Then
        Return False
    End If
    'try to get the property value of the beamsystem LayoutRule
    Dim justifyType As BeamSystemJustifyType = fixedDistance.JustifyType

    Dim spacing As Double = fixedDistance.Spacing

    message += vbLf & "New BeamSystem layout rule: " & fixedDistance.ToString()
    message += vbLf & "New BeamSystem spacing: " & spacing
    message += vbLf & "New BeamSystem justification: " & justifyType

    TaskDialog.Show("Revit", message)

    Return True
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LayoutRuleFixedDistance Constructor

Constructor of LayoutRuleFixedDistance. Create LayoutRuleFixedDistance with the values passed in.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LayoutRuleFixedDistance(
    double spacing,
    BeamSystemJustifyType justifyType
)
Public Sub New (
    spacing As Double,
    justifyType As BeamSystemJustifyType
)
public:
LayoutRuleFixedDistance(
    double spacing,
    BeamSystemJustifyType justifyType
)
new :
        spacing : float *
        justifyType : BeamSystemJustifyType -> LayoutRuleFixedDistance

Parameters

spacing Double
The value of spacing must be between 0 and 30000.
justifyType BeamSystemJustifyType
The type of the justification, it's corresponding to the items in the element properties dialog.
See Also

Reference

LayoutRuleFixedDistance Class


LayoutRuleFixedDistance Properties

The LayoutRuleFixedDistance type exposes the following members.

Properties
 | Name | Description
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | JustifyType | Get or set the type of justification.
Public property | Spacing | Get or set spacing of the Beam System.
Top
See Also

Reference

LayoutRuleFixedDistance Class


LayoutRuleFixedDistance.JustifyType Property

LayoutRuleFixedDistanceJustifyType Property

Get or set the type of justification.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BeamSystemJustifyType JustifyType { get; set; }
Public Property JustifyType As BeamSystemJustifyType
    Get
    Set
public:
property BeamSystemJustifyType JustifyType {
    BeamSystemJustifyType get ();
    void set (BeamSystemJustifyType value);
}
member JustifyType : BeamSystemJustifyType with get, set

Property Value

BeamSystemJustifyType
Remarks
The justifyType passed in must be a valid object.
See Also

Reference

LayoutRuleFixedDistance Class


LayoutRuleFixedDistance.Spacing Property

LayoutRuleFixedDistanceSpacing Property

Get or set spacing of the Beam System.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Spacing { get; set; }
Public Property Spacing As Double
    Get
    Set
public:
property double Spacing {
    double get ();
    void set (double value);
}
member Spacing : float with get, set

Property Value

Double
Remarks
The value of spacing must be between 0 and 30000.
See Also

Reference

LayoutRuleFixedDistance Class


LayoutRuleFixedDistance Methods

The LayoutRuleFixedDistance type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LayoutRuleFixedDistance Class


LayoutRuleFixedNumber Class

This class indicate the layout rule of a Beam System is Fixed-Number.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBLayoutRule
Autodesk.Revit.DBLayoutRuleFixedNumber

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LayoutRuleFixedNumber : LayoutRule
Public Class LayoutRuleFixedNumber
    Inherits LayoutRule
public ref class LayoutRuleFixedNumber : public LayoutRule
type LayoutRuleFixedNumber =
    class
        inherit LayoutRule
    end

The LayoutRuleFixedNumber type exposes the following members.

Constructors
 | Name | Description
Public method | LayoutRuleFixedNumber | Constructor of LayoutRuleFixedNumber.
Top
Properties
 | Name | Description
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | NumberOfLines | Get or set the number of the beams in a beam system.
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
To use this type of LayoutRule, only the number of the beams must be set.
Example
C#
VB
C++
F#
Copy
private bool LayoutRuleFixedNumberInformation(BeamSystem beamSystem)
{
    //get the layoutRule of the beamsystem
    Autodesk.Revit.DB.LayoutRule layoutRule = beamSystem.LayoutRule;

    string message = "BeamSystem layout rule : " + layoutRule;

    //create a new instance of the LayoutRuleClearSpacing class
    LayoutRuleFixedNumber myLayoutRuleFixedNumber =
                        new LayoutRuleFixedNumber(8);

    //set the new layoutRule to the beamsystem
    beamSystem.LayoutRule = myLayoutRuleFixedNumber;

    LayoutRuleFixedNumber fixedNumber = beamSystem.LayoutRule as LayoutRuleFixedNumber;

    if (null == fixedNumber)
    {
        return false;
    }
    //try to get the property value of the beamsystem LayoutRule
    int numberOfLines = fixedNumber.NumberOfLines;

    message += "\nNew BeamSystem layout rule: " + fixedNumber;
    message += "\nNew BeamSystem number of beams: " + numberOfLines;

    TaskDialog.Show("Revit",message);

    return true;
}
Private Function LayoutRuleFixedNumberInformation(beamSystem As BeamSystem) As Boolean
    'get the layoutRule of the beamsystem
    Dim layoutRule As Autodesk.Revit.DB.LayoutRule = beamSystem.LayoutRule

    Dim message As String = "BeamSystem layout rule : " & layoutRule.ToString()

    'create a new instance of the LayoutRuleClearSpacing class
    Dim myLayoutRuleFixedNumber As New LayoutRuleFixedNumber(8)

    'set the new layoutRule to the beamsystem
    beamSystem.LayoutRule = myLayoutRuleFixedNumber

    Dim fixedNumber As LayoutRuleFixedNumber = TryCast(beamSystem.LayoutRule, LayoutRuleFixedNumber)

    If fixedNumber Is Nothing Then
        Return False
    End If
    'try to get the property value of the beamsystem LayoutRule
    Dim numberOfLines As Integer = fixedNumber.NumberOfLines

    message += vbLf & "New BeamSystem layout rule: " & fixedNumber.ToString()
    message += vbLf & "New BeamSystem number of beams: " & numberOfLines

    TaskDialog.Show("Revit", message)

    Return True
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LayoutRuleFixedNumber Constructor

Constructor of LayoutRuleFixedNumber.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LayoutRuleFixedNumber(
    int numberOfLines
)
Public Sub New (
    numberOfLines As Integer
)
public:
LayoutRuleFixedNumber(
    int numberOfLines
)
new :
        numberOfLines : int -> LayoutRuleFixedNumber

Parameters

numberOfLines Int32
The value of numberOfLines must be positive.
Remarks
Create a LayoutRuleFixedNumber object with the number of the beams and this number must be positive.
See Also

Reference

LayoutRuleFixedNumber Class


LayoutRuleFixedNumber Properties

The LayoutRuleFixedNumber type exposes the following members.

Properties
 | Name | Description
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | NumberOfLines | Get or set the number of the beams in a beam system.
Top
See Also

Reference

LayoutRuleFixedNumber Class


LayoutRuleFixedNumber.NumberOfLines Property

LayoutRuleFixedNumberNumberOfLines Property

Get or set the number of the beams in a beam system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int NumberOfLines { get; set; }
Public Property NumberOfLines As Integer
    Get
    Set
public:
property int NumberOfLines {
    int get ();
    void set (int value);
}
member NumberOfLines : int with get, set

Property Value

Int32
Remarks
The number must be positive.
See Also

Reference

LayoutRuleFixedNumber Class


LayoutRuleFixedNumber Methods

The LayoutRuleFixedNumber type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LayoutRuleFixedNumber Class


LayoutRuleMaximumSpacing Class

This class indicate the layout rule of a Beam System is Max-Spacing.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBLayoutRule
Autodesk.Revit.DBLayoutRuleMaximumSpacing

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LayoutRuleMaximumSpacing : LayoutRule
Public Class LayoutRuleMaximumSpacing
    Inherits LayoutRule
public ref class LayoutRuleMaximumSpacing : public LayoutRule
type LayoutRuleMaximumSpacing =
    class
        inherit LayoutRule
    end

The LayoutRuleMaximumSpacing type exposes the following members.

Constructors
 | Name | Description
Public method | LayoutRuleMaximumSpacing | Constructor of LayoutRuleMaximumSpacing.
Top
Properties
 | Name | Description
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Spacing | Get or set the spacing of the beam system.
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
To use this type of LayoutRule, only the maximum spacing must be set and it must be in (0, 30000).
Example
C#
VB
C++
F#
Copy
private bool LayoutRuleMaximumSpacingInformation(BeamSystem beamSystem)
{
    //get the layoutRule of the beamsystem
    Autodesk.Revit.DB.LayoutRule layoutRule = beamSystem.LayoutRule;

    string message = "BeamSystem layout rule : " + layoutRule;

    //create a new instance of the LayoutRuleClearSpacing class
    LayoutRuleMaximumSpacing myLayoutRuleMaximumSpacing =
                        new LayoutRuleMaximumSpacing(10.0);

    //set the new layoutRule to the beamsystem
    beamSystem.LayoutRule = myLayoutRuleMaximumSpacing;

    LayoutRuleMaximumSpacing maximunSpacing = beamSystem.LayoutRule as LayoutRuleMaximumSpacing;
    if (null == maximunSpacing)
    {
        return false;
    }
    //try to get the property value of the beamsystem LayoutRule
    double spacing = maximunSpacing.Spacing;

    message += "\nNew BeamSystem layout rule: " + maximunSpacing;
    message += "\nNew BeamSystem maximum spacing: " + spacing;

    TaskDialog.Show("Revit",message);

    return true;
}
Private Function LayoutRuleMaximumSpacingInformation(beamSystem As BeamSystem) As Boolean
    'get the layoutRule of the beamsystem
    Dim layoutRule As Autodesk.Revit.DB.LayoutRule = beamSystem.LayoutRule

    Dim message As String = "BeamSystem layout rule : " & layoutRule.ToString()

    'create a new instance of the LayoutRuleClearSpacing class
    Dim myLayoutRuleMaximumSpacing As New LayoutRuleMaximumSpacing(10.0)

    'set the new layoutRule to the beamsystem
    beamSystem.LayoutRule = myLayoutRuleMaximumSpacing

    Dim maximunSpacing As LayoutRuleMaximumSpacing = TryCast(beamSystem.LayoutRule, LayoutRuleMaximumSpacing)
    If maximunSpacing Is Nothing Then
        Return False
    End If
    'try to get the property value of the beamsystem LayoutRule
    Dim spacing As Double = maximunSpacing.Spacing

    message += vbLf & "New BeamSystem layout rule: " & maximunSpacing.ToString()
    message += vbLf & "New BeamSystem maximum spacing: " & spacing

    TaskDialog.Show("Revit", message)

    Return True
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LayoutRuleMaximumSpacing Constructor

Constructor of LayoutRuleMaximumSpacing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LayoutRuleMaximumSpacing(
    double spacing
)
Public Sub New (
    spacing As Double
)
public:
LayoutRuleMaximumSpacing(
    double spacing
)
new :
        spacing : float -> LayoutRuleMaximumSpacing

Parameters

spacing Double
The value of spacing must be in (0, 30000).
Remarks
The value of spacing must be in (0, 30000), but in fact the spacing should not be too small or too great.
See Also

Reference

LayoutRuleMaximumSpacing Class


LayoutRuleMaximumSpacing Properties

The LayoutRuleMaximumSpacing type exposes the following members.

Properties
 | Name | Description
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Spacing | Get or set the spacing of the beam system.
Top
See Also

Reference

LayoutRuleMaximumSpacing Class


LayoutRuleMaximumSpacing.Spacing Property

LayoutRuleMaximumSpacingSpacing Property

Get or set the spacing of the beam system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Spacing { get; set; }
Public Property Spacing As Double
    Get
    Set
public:
property double Spacing {
    double get ();
    void set (double value);
}
member Spacing : float with get, set

Property Value

Double
Remarks
The value of spacing must be in (0, 30000), but in fact the spacing should not be too small or too great.
See Also

Reference

LayoutRuleMaximumSpacing Class


LayoutRuleMaximumSpacing Methods

The LayoutRuleMaximumSpacing type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LayoutRuleMaximumSpacing Class


Leader Class

A leader object that can be attached to annotation elements such as text notes.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBLeader

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Leader : APIObject
Public Class Leader
    Inherits APIObject
public ref class Leader : public APIObject
type Leader =
    class
        inherit APIObject
    end

The Leader type exposes the following members.

Properties
 | Name | Description
Public property | Anchor | Anchor point of the Leader
Public property | Elbow | Elbow point of the Leader.
Public property | End | End point of the Leader.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LeaderShape | Geometric style of the leader
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
For information on how to attach or get leaders to/from a text annotation refer to corresponding methods of TextNote class.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Leader Properties

The Leader type exposes the following members.

Properties
 | Name | Description
Public property | Anchor | Anchor point of the Leader
Public property | Elbow | Elbow point of the Leader.
Public property | End | End point of the Leader.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LeaderShape | Geometric style of the leader
Top
See Also

Reference

Leader Class


Leader.Anchor Property

LeaderAnchor Property

Anchor point of the Leader

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Anchor { get; }
Public ReadOnly Property Anchor As XYZ
    Get
public:
property XYZ^ Anchor {
    XYZ^ get ();
}
member Anchor : XYZ with get

Property Value

XYZ
Remarks
Anchor is the leader's point that is attached to an annotation (a tag, note, etc.) This is a read-only property, for the this point gets always computed based on various properties of the annotation element.
See Also

Reference

Leader Class


Leader.Elbow Property

LeaderElbow Property

Elbow point of the Leader.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Elbow { get; set; }
Public Property Elbow As XYZ
    Get
    Set
public:
property XYZ^ Elbow {
    XYZ^ get ();
    void set (XYZ^ value);
}
member Elbow : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
ArgumentException | When setting this property: A valid point must not be father then 10 miles (approx. 16 km) from the origin. -or- When setting this property: An arc leader may not have its Elbow point placed at the current position of the leader's Anchor or End point.
ArgumentNullException | When setting this property: A non-optional argument was null
InvalidOperationException | When setting this property: The leader is not currently owned by a valid element. A probable reason for that could be if the element has been independently deleted, or the leader has never been properly initialized.
Remarks

This is the mid-point of the leader and its purpose depends on the shape of the leader. For arc-shaped leaders it defines the radius of the arc. For a kinked leader it divides the leader line and shoulder line.

Note that straight-line leaders do not have an actual elbow; however, the value can still be obtained, although it will always equal the current anchor point. Consequently, an elbow point can be set even on a straight-line leader, but doing so will automatically change the leader's shape property.

It is allowed to set the Elbow point of a kinked leader to equal either the end point or anchor point of the leader. Doing so will effectively change the leader's shape to a straight line. However, the elbow of an arc leader is never allowed to be placed on either the end or anchor point.

See Also

Reference

Leader Class


Leader.End Property

LeaderEnd Property

End point of the Leader.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ End { get; set; }
Public Property End As XYZ
    Get
    Set
public:
property XYZ^ End {
    XYZ^ get ();
    void set (XYZ^ value);
}
member End : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
ArgumentException | When setting this property: A valid point must not be father then 10 miles (approx. 16 km) from the origin. -or- When setting this property: The leader's End point may not be placed at the current position of the Anchor or Elbow point.
ArgumentNullException | When setting this property: A non-optional argument was null
InvalidOperationException | When setting this property: The leader is not currently owned by a valid element. A probable reason for that could be if the element has been independently deleted, or the leader has never been properly initialized.
Remarks
The End point is the leader's end that points to the object being annotated.
See Also

Reference

Leader Class


Leader.IsValidObject Property

LeaderIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

Leader Class


Leader.LeaderShape Property

LeaderLeaderShape Property

Geometric style of the leader

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LeaderShape LeaderShape { get; }
Public ReadOnly Property LeaderShape As LeaderShape
    Get
public:
property LeaderShape LeaderShape {
    LeaderShape get ();
}
member LeaderShape : LeaderShape with get

Property Value

LeaderShape
Exceptions
Exception | Condition
InvalidOperationException | The leader is not currently owned by a valid element. A probable reason for that could be if the element has been independently deleted, or the leader has never been properly initialized.
Remarks
While this property cannot be changed directly, it can change, with limitations, as an effect of other changes to either the leader itself or the annotation element the leader is associated with. For example, straight-line leaders have no elbow points; but if an elbow point is set for a straight leader, which is allowed, it will effectively change the leader's shape to a kinked line.
See Also

Reference

Leader Class


Leader Methods

The Leader type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Leader Class


LeaderArray Class

An array that can contain any number of leaders.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBLeaderArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LeaderArray : APIObject,
    IEnumerable
Public Class LeaderArray
    Inherits APIObject
    Implements IEnumerable
public ref class LeaderArray : public APIObject,
    IEnumerable
type LeaderArray =
    class
        inherit APIObject
        interface IEnumerable
    end

The LeaderArray type exposes the following members.

Constructors
 | Name | Description
Public method | LeaderArray | Initializes a new instance of the LeaderArray class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.
Top
Methods
 | Name | Description
Public method | Append | Add the item to the end of the array.
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified item into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LeaderArray Constructor

Initializes a new instance of the LeaderArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LeaderArray()
Public Sub New
public:
LeaderArray()
new : unit -> LeaderArray
See Also

Reference

LeaderArray Class


LeaderArray Properties

The LeaderArray type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.
Top
See Also

Reference

LeaderArray Class


LeaderArray.IsEmpty Property

LeaderArrayIsEmpty Property

Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Boolean
Remarks
If the array is empty then True will be returned, otherwise False.
See Also

Reference

LeaderArray Class


LeaderArray.Item Property

LeaderArrayItem Property

Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Leader this[
    int index
] { get; set; }
Public Overridable Property Item (
    index As Integer
) As Leader
    Get
    Set
public:
virtual property Leader^ Item[int index] {
    Leader^ get (int index);
    void set (int index, Leader^ value);
}
abstract Item : Leader with get, set
override Item : Leader with get, set

Parameters

index Int32
The index of the item to be set or retrieved.

Return Value

Leader
Returns the object at the specified index.
See Also

Reference

LeaderArray Class


LeaderArray.Size Property

LeaderArraySize Property

Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
abstract Size : int with get
override Size : int with get

Property Value

Int32
See Also

Reference

LeaderArray Class


LeaderArray Methods

The LeaderArray type exposes the following members.

Methods
 | Name | Description
Public method | Append | Add the item to the end of the array.
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified item into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LeaderArray Class


LeaderArray.Append Method

LeaderArrayAppend Method

Add the item to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Append(
    Leader item
)
Public Overridable Sub Append (
    item As Leader
)
public:
virtual void Append(
    Leader^ item
)
abstract Append :
        item : Leader -> unit
override Append :
        item : Leader -> unit

Parameters

item Leader
The item to be added.
See Also

Reference

LeaderArray Class


LeaderArray.Clear Method

LeaderArrayClear Method

Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

LeaderArray Class


LeaderArray.ForwardIterator Method

LeaderArrayForwardIterator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual LeaderArrayIterator ForwardIterator()
Public Overridable Function ForwardIterator As LeaderArrayIterator
public:
virtual LeaderArrayIterator^ ForwardIterator()
abstract ForwardIterator : unit -> LeaderArrayIterator
override ForwardIterator : unit -> LeaderArrayIterator

Return Value

LeaderArrayIterator
Returns a forward moving iterator to the array.
See Also

Reference

LeaderArray Class


LeaderArray.GetEnumerator Method

LeaderArrayGetEnumerator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

IEnumerator
Returns a forward moving iterator to the array.

Implements

IEnumerableGetEnumerator
See Also

Reference

LeaderArray Class


LeaderArray.Insert Method

LeaderArrayInsert Method

Insert the specified item into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Insert(
    Leader item,
    int index
)
Public Overridable Sub Insert (
    item As Leader,
    index As Integer
)
public:
virtual void Insert(
    Leader^ item,
    int index
)
abstract Insert :
        item : Leader *
        index : int -> unit
override Insert :
        item : Leader *
        index : int -> unit

Parameters

item Leader
The item to be inserted into the array.
index Int32
The item will be inserted before this index.

Return Value

Returns whether the item was inserted into the array.
See Also

Reference

LeaderArray Class


LeaderArray.ReverseIterator Method

LeaderArrayReverseIterator Method

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual LeaderArrayIterator ReverseIterator()
Public Overridable Function ReverseIterator As LeaderArrayIterator
public:
virtual LeaderArrayIterator^ ReverseIterator()
abstract ReverseIterator : unit -> LeaderArrayIterator
override ReverseIterator : unit -> LeaderArrayIterator

Return Value

LeaderArrayIterator
Returns a backward moving iterator to the array.
See Also

Reference

LeaderArray Class


LeaderArrayIterator Class

An iterator to an array of leaders.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBLeaderArrayIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class LeaderArrayIterator : APIObject,
    IEnumerator
Public MustInherit Class LeaderArrayIterator
    Inherits APIObject
    Implements IEnumerator
public ref class LeaderArrayIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type LeaderArrayIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The LeaderArrayIterator type exposes the following members.

Constructors
 | Name | Description
Public method | LeaderArrayIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LeaderArrayIterator Constructor

For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LeaderArrayIterator()
Public Sub New
public:
LeaderArrayIterator()
new : unit -> LeaderArrayIterator
Remarks
This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.
See Also

Reference

LeaderArrayIterator Class


LeaderArrayIterator Properties

The LeaderArrayIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

LeaderArrayIterator Class


LeaderArrayIterator.Current Property

LeaderArrayIteratorCurrent Property

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}
abstract Current : Object with get
override Current : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.
See Also

Reference

LeaderArrayIterator Class


LeaderArrayIterator Methods

The LeaderArrayIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LeaderArrayIterator Class


LeaderArrayIterator.MoveNext Method

LeaderArrayIteratorMoveNext Method

Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumeratorMoveNext
Remarks
MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.
See Also

Reference

LeaderArrayIterator Class


LeaderArrayIterator.Reset Method

LeaderArrayIteratorReset Method

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
Remarks
The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.
See Also

Reference

LeaderArrayIterator Class


LeaderAtachement Enumeration

Supported types of vertical attachments of a leader to a text note.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum LeaderAtachement
Public Enumeration LeaderAtachement
public enum class LeaderAtachement
type LeaderAtachement
Members
Member name | Value | Description
TopLine | 0 | Leaders are attached at the position of the top (first) line of the text box, and, unless the text's border is visible, the leader's shoulder line extends all the way to the text, minus the current value of text border offset.
Midpoint | 1 | Leaders are aligned vertically with the midpoint of the text box and their shoulder line always ends at the box' border regardless of whether the border is visible on not.
BottomLine | 2 | Leaders are attached at the position of the bottom (last) line of the text box, and, unless the text's border is visible, the leader's shoulder line extends all the way to the text, minus the current value of text border offset.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LeaderEndCondition Enumeration

An enumerated type listing Leader end conditions that are supported for IndependentTags.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum LeaderEndCondition
Public Enumeration LeaderEndCondition
public enum class LeaderEndCondition
type LeaderEndCondition
Members
Member name | Value | Description
Attached | 0 | The Leader of the tag is attached.
Free | 1 | The Leader of the tag is free.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LeaderShape Enumeration

Supported geometric shapes of annotation leaders.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum LeaderShape
Public Enumeration LeaderShape
public enum class LeaderShape
type LeaderShape
Members
Member name | Value | Description
Straight | 0 | A single straight line between the end point and anchor point.
Kinked | 1 | A kinked line with a shoulder defined by an elbow point.
Arc | 2 | An arc between between the end point and anchor point. In this shape the elbow point controls the arc's radius.
Remarks
Although the [!:Autodesk::Revit::DB::Leader] class supports all available shapes, not all types of leaders may have the option to change its shape. For example, leaders of text annotations can be of any shape, while leaders of level lines are never curved.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LeadersPresentationMode Enumeration

Leaders Presentation Mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum LeadersPresentationMode
Public Enumeration LeadersPresentationMode
public enum class LeadersPresentationMode
type LeadersPresentationMode
Members
Member name | Value | Description
ShowAll | 0 | Show all tag leaders.
HideAll | 1 | Hide all tag leaders.
ShowOnlyOne | 2 | Show only one leader.
ShowSpecificLeaders | 3 | Show specific leaders.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Level Class

Represents a Level within Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBDatumPlane
Autodesk.Revit.DBLevel

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Level : DatumPlane
Public Class Level
    Inherits DatumPlane
public ref class Level : public DatumPlane
type Level =
    class
        inherit DatumPlane
    end

The Level type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | Elevation | Retrieves or changes the elevation above or below the ground level.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ProjectElevation | Retrieves the elevation relative to project origin, no matter what values of the Elevation Base parameter is set.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | AddLeader | Adds a default Leader for the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders). (Inherited from DatumPlane)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanBeVisibleInView | Checks if the datum plane can be visible in the view. (Inherited from DatumPlane)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new instance of level based on an input elevation.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FindAssociatedPlanViewId | Finds the id of the first available associated floor or structural plan view associated with this level.
Public method | GetCurvesInView | Gets a collection of curves representing the DatumPlane element in the given view. (Inherited from DatumPlane)
Public method | GetDatumExtentTypeInView | Identifies whether the curve representing the datum plane is displayed according to its actual 3d extents, or else according to a view specific setting. (Inherited from DatumPlane)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLeader | Gets a copy of the leader applied to the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders). (Inherited from DatumPlane)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
 | GetNearestLevelId(Document, Double) | Returns id of the Level which is closest to the specified elevation.
 | GetNearestLevelId(Document, Double, Double) | Returns id of the Level which is closest to the specified elevation.
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPlaneReference | Returns a reference to this element as a plane.
Public method | GetPropagationViews | Gets a list of candidate views which are parallel to the current view and to which the extents of the datum may be propagated. (Inherited from DatumPlane)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasBubbleInView | Identifies if the DatumPlane has bubble or not. (Inherited from DatumPlane)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HideBubbleInView | Hides the bubble in a view. This method does not apply to Reference planes. (Inherited from DatumPlane)
Public method | IsBubbleVisibleInView | Identifies if the bubble is visible or not in a view. (Inherited from DatumPlane)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsCurveValidInView | Checks if the curve is valid to be as the extents for the datum plane in a view. The curve must be bound and coincident with the original one of the datum plane. (Inherited from DatumPlane)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsLeaderValid | Identifies if the leader valid or not for this DatumPlane. This method does not apply to Reference planes (which do not support leaders). (Inherited from DatumPlane)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | Maximize3DExtents | Computes the 3d extents of all model geometry and levels, and extends the 3d extents of this datum surface to include the model extents. (Inherited from DatumPlane)
Public method | PropagateToViews | Propagates the extents applied to this datum in the view to the specified parallel views. (Inherited from DatumPlane)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetCurveInView | Sets the extents to match the curve. (Inherited from DatumPlane)
Public method | SetDatumExtentType | Sets whether the curve representing the datum plane is displayed according to its 3d extents, or else according to a view specific setting. (Inherited from DatumPlane)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetLeader | Sets the leader to the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders). (Inherited from DatumPlane)
Public method | ShowBubbleInView | Shows the bubble in a view. This method does not apply to Reference planes. (Inherited from DatumPlane)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
A Level is conceptually a horizontal rectangle of finite extents. It appears as a straight line in views that intersect the rectangle. The straight line represents the projection of the rectangle onto the view. The Name property can be used to retrieve the user visible name of the level that appears in the level bubble.
Example
C#
VB
C++
F#
Copy
private void GetLevelInformation(Autodesk.Revit.DB.Element element)
{
    // Get the level object to which the element is assigned.
    if (element.LevelId.Equals(ElementId.InvalidElementId))
    {
        TaskDialog.Show("Revit","The element isn't based on a level.");
    }
    else
    {
        Level level = element.Document.GetElement(element.LevelId) as Level;

        // Format the prompt information(Name and elevation)
        String prompt = "The element is based on a level.";
        prompt += "\nThe level name is:  " + level.Name;
        prompt += "\nThe level elevation is:  " + level.Elevation;

        // Show the information to the user.
        TaskDialog.Show("Revit",prompt);
    }
}
Private Sub GetLevelInformation(element As Autodesk.Revit.DB.Element)
    ' Get the level object to which the element is assigned.
    If element.LevelId.Equals(ElementId.InvalidElementId) Then
        TaskDialog.Show("Revit", "The element isn't based on a level.")
    Else
        Dim level As Level = TryCast(element.Document.GetElement(element.LevelId), Level)

        ' Format the prompt information(Name and elevation)
        Dim prompt As [String] = "The element is based on a level."
        prompt += vbLf & "The level name is:  " + level.Name
        prompt += vbLf & "The level elevation is:  " + level.Elevation

        ' Show the information to the user.
        TaskDialog.Show("Revit", prompt)
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

C#
VB
C++
F#
Copy
private void Getinfo_Level(Document document)
{
    StringBuilder levelInformation = new StringBuilder();
    int levelNumber = 0;
    FilteredElementCollector collector = new FilteredElementCollector(document);
    ICollection<Element> collection = collector.OfClass(typeof(Level)).ToElements();
    foreach (Element e in collection)
    {
        Level level = e as Level;

        if (null != level)
        {
            // keep track of number of levels
            levelNumber++;

            //get the name of the level
            levelInformation.Append("\nLevel Name: " + level.Name);

            //get the elevation of the level
            levelInformation.Append("\n\tElevation: " + level.Elevation);

            // get the project elevation of the level
            levelInformation.Append("\n\tProject Elevation: " + level.ProjectElevation);
        }
    }

    //number of total levels in current document
    levelInformation.Append("\n\n There are " + levelNumber + " levels in the document!");

    //show the level information in the messagebox
    TaskDialog.Show("Revit",levelInformation.ToString());
}
Private Sub Getinfo_Level(document As Document)
    Dim levelInformation As New StringBuilder()
    Dim levelNumber As Integer = 0
    Dim collector As New FilteredElementCollector(document)
    Dim collection As ICollection(Of Element) = collector.OfClass(GetType(Level)).ToElements()
    For Each e As Element In collection
        Dim level As Level = TryCast(e, Level)

        If level IsNot Nothing Then
            ' keep track of number of levels
            levelNumber += 1

            'get the name of the level
            levelInformation.Append(vbLf & "Level Name: " + level.Name)

            'get the elevation of the level
            levelInformation.Append(vbLf & vbTab & "Elevation: " + level.Elevation)

            ' get the project elevation of the level
            levelInformation.Append(vbLf & vbTab & "Project Elevation: " + level.ProjectElevation)
        End If
    Next

    'number of total levels in current document
    levelInformation.Append(vbLf & vbLf & " There are " & levelNumber & " levels in the document!")

    'show the level information in the messagebox
    TaskDialog.Show("Revit", levelInformation.ToString())
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Level Properties

The Level type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | Elevation | Retrieves or changes the elevation above or below the ground level.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ProjectElevation | Retrieves the elevation relative to project origin, no matter what values of the Elevation Base parameter is set.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

Level Class


Level.Elevation Property

LevelElevation Property

Retrieves or changes the elevation above or below the ground level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Elevation { get; set; }
Public Property Elevation As Double
    Get
    Set
public:
property double Elevation {
    double get ();
    void set (double value);
}
member Elevation : float with get, set

Property Value

Double
Remarks
This property retrieves or changes the elevation above or below the ground level of the project. If the Elevation Base parameter is set to Project, the elevation is relative to project origin. If the Elevation Base parameter is set to Shared, the elevation is relative to shared origin which can be changed by relocate operation. The value is given in decimal feet.
See Also

Reference

Level Class


Level.ProjectElevation Property

LevelProjectElevation Property

Retrieves the elevation relative to project origin, no matter what values of the Elevation Base parameter is set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double ProjectElevation { get; }
Public ReadOnly Property ProjectElevation As Double
    Get
public:
property double ProjectElevation {
    double get ();
}
member ProjectElevation : float with get

Property Value

Double
Remarks
This read only property returns the elevation relative to project origin.
See Also

Reference

Level Class


Level Methods

The Level type exposes the following members.

Methods
 | Name | Description
Public method | AddLeader | Adds a default Leader for the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders). (Inherited from DatumPlane)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanBeVisibleInView | Checks if the datum plane can be visible in the view. (Inherited from DatumPlane)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new instance of level based on an input elevation.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FindAssociatedPlanViewId | Finds the id of the first available associated floor or structural plan view associated with this level.
Public method | GetCurvesInView | Gets a collection of curves representing the DatumPlane element in the given view. (Inherited from DatumPlane)
Public method | GetDatumExtentTypeInView | Identifies whether the curve representing the datum plane is displayed according to its actual 3d extents, or else according to a view specific setting. (Inherited from DatumPlane)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLeader | Gets a copy of the leader applied to the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders). (Inherited from DatumPlane)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
 | GetNearestLevelId(Document, Double) | Returns id of the Level which is closest to the specified elevation.
 | GetNearestLevelId(Document, Double, Double) | Returns id of the Level which is closest to the specified elevation.
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPlaneReference | Returns a reference to this element as a plane.
Public method | GetPropagationViews | Gets a list of candidate views which are parallel to the current view and to which the extents of the datum may be propagated. (Inherited from DatumPlane)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasBubbleInView | Identifies if the DatumPlane has bubble or not. (Inherited from DatumPlane)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HideBubbleInView | Hides the bubble in a view. This method does not apply to Reference planes. (Inherited from DatumPlane)
Public method | IsBubbleVisibleInView | Identifies if the bubble is visible or not in a view. (Inherited from DatumPlane)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsCurveValidInView | Checks if the curve is valid to be as the extents for the datum plane in a view. The curve must be bound and coincident with the original one of the datum plane. (Inherited from DatumPlane)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsLeaderValid | Identifies if the leader valid or not for this DatumPlane. This method does not apply to Reference planes (which do not support leaders). (Inherited from DatumPlane)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | Maximize3DExtents | Computes the 3d extents of all model geometry and levels, and extends the 3d extents of this datum surface to include the model extents. (Inherited from DatumPlane)
Public method | PropagateToViews | Propagates the extents applied to this datum in the view to the specified parallel views. (Inherited from DatumPlane)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetCurveInView | Sets the extents to match the curve. (Inherited from DatumPlane)
Public method | SetDatumExtentType | Sets whether the curve representing the datum plane is displayed according to its 3d extents, or else according to a view specific setting. (Inherited from DatumPlane)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetLeader | Sets the leader to the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders). (Inherited from DatumPlane)
Public method | ShowBubbleInView | Shows the bubble in a view. This method does not apply to Reference planes. (Inherited from DatumPlane)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Level Class


Level.Create Method

LevelCreate Method

Creates a new instance of level based on an input elevation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Level Create(
    Document document,
    double elevation
)
Public Shared Function Create (
    document As Document,
    elevation As Double
) As Level
public:
static Level^ Create(
    Document^ document,
    double elevation
)
static member Create :
        document : Document *
        elevation : float -> Level

Parameters

document Document
The document in which the new instance is created
elevation Double
The elevation of the level to be created.

Return Value

Level
The newly created level instance.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Example
C#
VB
C++
F#
Copy
Level CreateLevel(Autodesk.Revit.DB.Document document)
{
    // The elevation to apply to the new level
    double elevation = 20.0;

    // Begin to create a level
    Level level = Level.Create(document, elevation);
    if (null == level)
    {
        throw new Exception("Create a new level failed.");
    }

    // Change the level name
    level.Name = "New level";

    return level;
}
Private Function CreateLevel(document As Autodesk.Revit.DB.Document) As Level
   ' The elevation to apply to the new level
   Dim elevation As Double = 20.0

   ' Begin to create a level
   Dim level As Level = level.Create(document, elevation)
   If level Is Nothing Then
      Throw New Exception("Create a new level failed.")
   End If

   ' Change the level name
   level.Name = "New level"

   Return level
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Level Class


Level.FindAssociatedPlanViewId Method

LevelFindAssociatedPlanViewId Method

Finds the id of the first available associated floor or structural plan view associated with this level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId FindAssociatedPlanViewId()
Public Function FindAssociatedPlanViewId As ElementId
public:
ElementId^ FindAssociatedPlanViewId()
member FindAssociatedPlanViewId : unit -> ElementId

Return Value

ElementId
Remarks
The view id returned is determined by the same rules associated with the Revit tool "Go to Floor Plan". Many levels may actually have more than one associated floor plan id and this routine will only return the first one found. If no associated view is found, InvalidElementId is returned.
See Also

Reference

Level Class


Level.GetNearestLevelId Method

LevelGetNearestLevelId Method

Overload List
Name | Description
GetNearestLevelId(Document, Double) | Returns id of the Level which is closest to the specified elevation.
GetNearestLevelId(Document, Double, Double) | Returns id of the Level which is closest to the specified elevation.
Top
See Also

Reference

Level Class


Level.GetNearestLevelId(Document, Double) Method

LevelGetNearestLevelId(Document, Double) Method

Returns id of the Level which is closest to the specified elevation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ElementId GetNearestLevelId(
    Document document,
    double elevation
)
Public Shared Function GetNearestLevelId (
    document As Document,
    elevation As Double
) As ElementId
public:
static ElementId^ GetNearestLevelId(
    Document^ document,
    double elevation
)
static member GetNearestLevelId :
        document : Document *
        elevation : float -> ElementId

Parameters

document Document
The document.
elevation Double
Target Elevation.

Return Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
The level can be at, above or below the target elevation. If there is more than one Level at the same distance from the elevation, the Level with the lowest Id will be returned.
See Also

Reference

Level Class
GetNearestLevelId Overload


Level.GetNearestLevelId(Document, Double, Double) Method

LevelGetNearestLevelId(Document, Double, Double) Method

Returns id of the Level which is closest to the specified elevation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ElementId GetNearestLevelId(
    Document document,
    double elevation,
    out double offset
)
Public Shared Function GetNearestLevelId (
    document As Document,
    elevation As Double,
    <OutAttribute> ByRef offset As Double
) As ElementId
public:
static ElementId^ GetNearestLevelId(
    Document^ document,
    double elevation,
    [OutAttribute] double% offset
)
static member GetNearestLevelId :
        document : Document *
        elevation : float *
        offset : float byref -> ElementId

Parameters

document Document
The document.
elevation Double
Target Elevation.
offset Double
Vertical offset from the level to the target elevation.

Return Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
The level can be at, above or below the target elevation. If there is more than one Level at the same distance from the elevation, the Level with the lowest Id will be returned.
See Also

Reference

Level Class
GetNearestLevelId Overload


Level.GetPlaneReference Method

LevelGetPlaneReference Method

Returns a reference to this element as a plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Reference GetPlaneReference()
Public Function GetPlaneReference As Reference
public:
Reference^ GetPlaneReference()
member GetPlaneReference : unit -> Reference

Return Value

Reference
See Also

Reference

Level Class


LevelAssociationData Class

This class holds information related to Level.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBLevelAssociationData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LevelAssociationData : IDisposable
Public Class LevelAssociationData
    Implements IDisposable
public ref class LevelAssociationData : IDisposable
type LevelAssociationData =
    class
        interface IDisposable
    end

The LevelAssociationData type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the LevelAssociationData
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAssociatedLevel | Returns the Associated Level id.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
 | GetLevelAssociationData | Returns LevelAssociationData associated with this element, if it exists.
Public method | GetLevelOffset | Returns the offset from the Associated Level.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetAssociatedLevel | Sets the Associated Level.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LevelAssociationData Properties

The LevelAssociationData type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

LevelAssociationData Class


LevelAssociationData.IsValidObject Property

LevelAssociationDataIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

LevelAssociationData Class


LevelAssociationData Methods

The LevelAssociationData type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAssociatedLevel | Returns the Associated Level id.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
 | GetLevelAssociationData | Returns LevelAssociationData associated with this element, if it exists.
Public method | GetLevelOffset | Returns the offset from the Associated Level.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetAssociatedLevel | Sets the Associated Level.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LevelAssociationData Class


LevelAssociationData.Dispose Method

LevelAssociationDataDispose Method

Releases all resources used by the LevelAssociationData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

LevelAssociationData Class


LevelAssociationData.GetAssociatedLevel Method

LevelAssociationDataGetAssociatedLevel Method

Returns the Associated Level id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GetAssociatedLevel()
Public Function GetAssociatedLevel As ElementId
public:
ElementId^ GetAssociatedLevel()
member GetAssociatedLevel : unit -> ElementId

Return Value

ElementId
See Also

Reference

LevelAssociationData Class


LevelAssociationData.GetLevelAssociationData Method

LevelAssociationDataGetLevelAssociationData Method

Returns LevelAssociationData associated with this element, if it exists.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static LevelAssociationData GetLevelAssociationData(
    Element element
)
Public Shared Function GetLevelAssociationData (
    element As Element
) As LevelAssociationData
public:
static LevelAssociationData^ GetLevelAssociationData(
    Element^ element
)
static member GetLevelAssociationData :
        element : Element -> LevelAssociationData

Parameters

element Element
The element from which we try to obtain LevelAssociationData.

Return Value

LevelAssociationData
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
If the input element doesn't have LevelAssociationData than it retuns .
See Also

Reference

LevelAssociationData Class


LevelAssociationData.GetLevelOffset Method

LevelAssociationDataGetLevelOffset Method

Returns the offset from the Associated Level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetLevelOffset()
Public Function GetLevelOffset As Double
public:
double GetLevelOffset()
member GetLevelOffset : unit -> float

Return Value

Double
See Also

Reference

LevelAssociationData Class


LevelAssociationData.SetAssociatedLevel Method

LevelAssociationDataSetAssociatedLevel Method

Sets the Associated Level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetAssociatedLevel(
    ElementId levelId
)
Public Sub SetAssociatedLevel (
    levelId As ElementId
)
public:
void SetAssociatedLevel(
    ElementId^ levelId
)
member SetAssociatedLevel :
        levelId : ElementId -> unit

Parameters

levelId ElementId
The id of the Level.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | this operation failed.
See Also

Reference

LevelAssociationData Class


LevelType Class

An object that represents a Level type.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBLineAndTextAttrSymbol
Autodesk.Revit.DBLevelType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LevelType : LineAndTextAttrSymbol
Public Class LevelType
    Inherits LineAndTextAttrSymbol
public ref class LevelType : public LineAndTextAttrSymbol
type LevelType =
    class
        inherit LineAndTextAttrSymbol
    end

The LevelType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LevelType Properties

The LevelType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

LevelType Class


LevelType Methods

The LevelType type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LevelType Class


LightAndMaterialAccuracyMode Enumeration

An enumerated type containing possible Light and Material Accuracy modes for Raytracer render.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum LightAndMaterialAccuracyMode
Public Enumeration LightAndMaterialAccuracyMode
public enum class LightAndMaterialAccuracyMode
type LightAndMaterialAccuracyMode
Members
Member name | Value | Description
Simplified | 1 | Rough and semi-rough materials are approximated. Consequently, materials may look more shinier than expected. Lighting is approximated so shadows will lack in details.
Advanced | 2 | Soft shadows and soft reflections from semi-rough materials will be rendered with a high quality level. This is the standard setting that you typically want to rely on for final high quality renderings.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LightingSource Enumeration

Indicates the lighting scheme type in rendering settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum LightingSource
Public Enumeration LightingSource
public enum class LightingSource
type LightingSource
Members
Member name | Value | Description
ExteriorSun | 21 | Exterior source of light, sun only.
ExteriorSunAndArtificial | 22 | Exterior source of light, sun and artificial light.
ExteriorArtificial | 23 | Exterior source of light, artificial light only.
InteriorSun | 24 | Interior source of light, sun only.
InteriorSunAndArtificial | 25 | Interior source of light, sun and artificial light.
InteriorArtificial | 26 | Interior source of light, artificial light only.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LightNode Class

This class represents a Light element in a model-exporting process.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRenderNode
Autodesk.Revit.DBContentNode
Autodesk.Revit.DBLightNode

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LightNode : ContentNode
Public Class LightNode
    Inherits ContentNode
public ref class LightNode : public ContentNode
type LightNode =
    class
        inherit ContentNode
    end

The LightNode type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode)
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from RenderNode)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAsset | Returns an an instance of an Asset object, which contains definitions of the content node. (Inherited from ContentNode)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetTransform | A transformation matrix associated with the node. (Inherited from ContentNode)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
See also: OnLight(LightNode).
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LightNode Properties

The LightNode type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode)
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode)
Top
See Also

Reference

LightNode Class


LightNode Methods

The LightNode type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from RenderNode)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAsset | Returns an an instance of an Asset object, which contains definitions of the content node. (Inherited from ContentNode)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetTransform | A transformation matrix associated with the node. (Inherited from ContentNode)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LightNode Class


Line Class

A line in space.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGeometryObject
Autodesk.Revit.DBCurve
Autodesk.Revit.DBLine

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Line : Curve
Public Class Line
    Inherits Curve
public ref class Line : public Curve
type Line =
    class
        inherit Curve
    end

The Line type exposes the following members.

Properties
 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve)
Public property | Direction | Returns the direction of the line.
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve)
Public property | IsClosed | Describes whether the curve is closed. (Inherited from Curve)
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject)
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Length | The exact length of the curve. (Inherited from Curve)
Public property | Origin | Returns the origin of the line.
Public property | Period | The period of this curve. (Inherited from Curve)
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve)
Public property | Visibility | The visibility. (Inherited from GeometryObject)
Top
Methods
 | Name | Description
Public method | Clone | Returns a copy of this curve. (Inherited from Curve)
Public method | ComputeClosestPoints | Find the closest points between two curves. Closest points mean closest pairs of points, each pair consisting of a point on this, say P1, and a point on other curve, say P2. P1 and P2 are closest locally. Each pairs of closest points will be represented by the corresponding parameter values with respect to the two curves and the 3d points. A closest pair is also known as a pair of critical points of the distance function between points of the two curves. If the input parameter returnAllCriticalPoints is set to false, then the function will return only pairs with minimum distance. (Inherited from Curve)
Public method | ComputeDerivatives | Returns the vectors describing the curve at the specified parameter. (Inherited from Curve)
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve)
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve)
 | CreateBound | Creates a new instance of a bound linear curve.
Public method | CreateOffset | Creates a new curve that is an offset of the existing curve. (Inherited from Curve)
Public method | CreateReversed | Creates a new curve with the opposite orientation of the existing curve. (Inherited from Curve)
Public method | CreateTransformed | Crates a new instance of a curve as a transformation of this curve. (Inherited from Curve)
 | CreateUnbound | Creates a new instance of an unbound linear curve.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject)
Public method | Evaluate | Evaluates and returns the point that matches a parameter along the curve. (Inherited from Curve)
Public method | GetEndParameter | Returns the raw parameter value at the start or end of this curve. (Inherited from Curve)
Public method | GetEndPoint | Returns the 3D point at the start or end of this curve. (Inherited from Curve)
Public method | GetEndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve)
Public method | Intersect(Curve, IntersectionResultArray) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve)
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve)
Public method | IsInside(Double, Int32) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve)
Public method | MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve)
Public method | MakeUnbound | Makes this curve unbound. (Inherited from Curve)
Public method | Project | Projects the specified point on this curve. (Inherited from Curve)
Public method | SetGraphicsStyleId | Sets the graphics style id for this curve. (Inherited from Curve)
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Line Properties

The Line type exposes the following members.

Properties
 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve)
Public property | Direction | Returns the direction of the line.
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve)
Public property | IsClosed | Describes whether the curve is closed. (Inherited from Curve)
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject)
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Length | The exact length of the curve. (Inherited from Curve)
Public property | Origin | Returns the origin of the line.
Public property | Period | The period of this curve. (Inherited from Curve)
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve)
Public property | Visibility | The visibility. (Inherited from GeometryObject)
Top
See Also

Reference

Line Class


Line.Direction Property

LineDirection Property

Returns the direction of the line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Direction { get; }
Public ReadOnly Property Direction As XYZ
    Get
public:
property XYZ^ Direction {
    XYZ^ get ();
}
member Direction : XYZ with get

Property Value

XYZ
See Also

Reference

Line Class


Line.Origin Property

LineOrigin Property

Returns the origin of the line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Origin { get; }
Public ReadOnly Property Origin As XYZ
    Get
public:
property XYZ^ Origin {
    XYZ^ get ();
}
member Origin : XYZ with get

Property Value

XYZ
See Also

Reference

Line Class


Line Methods

The Line type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Returns a copy of this curve. (Inherited from Curve)
Public method | ComputeClosestPoints | Find the closest points between two curves. Closest points mean closest pairs of points, each pair consisting of a point on this, say P1, and a point on other curve, say P2. P1 and P2 are closest locally. Each pairs of closest points will be represented by the corresponding parameter values with respect to the two curves and the 3d points. A closest pair is also known as a pair of critical points of the distance function between points of the two curves. If the input parameter returnAllCriticalPoints is set to false, then the function will return only pairs with minimum distance. (Inherited from Curve)
Public method | ComputeDerivatives | Returns the vectors describing the curve at the specified parameter. (Inherited from Curve)
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve)
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve)
 | CreateBound | Creates a new instance of a bound linear curve.
Public method | CreateOffset | Creates a new curve that is an offset of the existing curve. (Inherited from Curve)
Public method | CreateReversed | Creates a new curve with the opposite orientation of the existing curve. (Inherited from Curve)
Public method | CreateTransformed | Crates a new instance of a curve as a transformation of this curve. (Inherited from Curve)
 | CreateUnbound | Creates a new instance of an unbound linear curve.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject)
Public method | Evaluate | Evaluates and returns the point that matches a parameter along the curve. (Inherited from Curve)
Public method | GetEndParameter | Returns the raw parameter value at the start or end of this curve. (Inherited from Curve)
Public method | GetEndPoint | Returns the 3D point at the start or end of this curve. (Inherited from Curve)
Public method | GetEndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve)
Public method | Intersect(Curve, IntersectionResultArray) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve)
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve)
Public method | IsInside(Double, Int32) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve)
Public method | MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve)
Public method | MakeUnbound | Makes this curve unbound. (Inherited from Curve)
Public method | Project | Projects the specified point on this curve. (Inherited from Curve)
Public method | SetGraphicsStyleId | Sets the graphics style id for this curve. (Inherited from Curve)
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Line Class


Line.CreateBound Method

LineCreateBound Method

Creates a new instance of a bound linear curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Line CreateBound(
    XYZ endpoint1,
    XYZ endpoint2
)
Public Shared Function CreateBound (
    endpoint1 As XYZ,
    endpoint2 As XYZ
) As Line
public:
static Line^ CreateBound(
    XYZ^ endpoint1,
    XYZ^ endpoint2
)
static member CreateBound :
        endpoint1 : XYZ *
        endpoint2 : XYZ -> Line

Parameters

endpoint1 XYZ
The first line endpoint.
endpoint2 XYZ
The second line endpoint.

Return Value

Line
The new bound line.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was NULL
ArgumentsInconsistentException | Curve length is too small for Revit's tolerance (as identified by Application.ShortCurveTolerance).
Example
C#
VB
C++
F#
Copy
// define start and end for bound line
XYZ startPoint = new XYZ(0, 0, 0);
XYZ endPoint = new XYZ(10, 10, 10);

// create line
Line line = Line.CreateBound(startPoint, endPoint);
' define start and end for bound line
Dim startPoint As New XYZ(0, 0, 0)
Dim endPoint As New XYZ(10, 10, 10)

' create line
Dim line__1 As Line = Line.CreateBound(startPoint, endPoint)

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Line Class


Line.CreateUnbound Method

LineCreateUnbound Method

Creates a new instance of an unbound linear curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Line CreateUnbound(
    XYZ origin,
    XYZ direction
)
Public Shared Function CreateUnbound (
    origin As XYZ,
    direction As XYZ
) As Line
public:
static Line^ CreateUnbound(
    XYZ^ origin,
    XYZ^ direction
)
static member CreateUnbound :
        origin : XYZ *
        direction : XYZ -> Line

Parameters

origin XYZ
The origin of the unbound line.
direction XYZ
The direction of the unbound line.

Return Value

Line
The new unbound line.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was NULL
ArgumentOutOfRangeException | direction has zero length.
ArgumentsInconsistentException | Vector and origin cannot form a proper unbound line.
Example
C#
VB
C++
F#
Copy
// define start point and direction for unbound line
XYZ startPoint = new XYZ(0, 0, 0);
XYZ directionPt = new XYZ(10, 10, 10);

// create line
Line line = Line.CreateUnbound(startPoint, directionPt);
' define start point and direction for unbound line
Dim startPoint As New XYZ(0, 0, 0)
Dim directionPt As New XYZ(10, 10, 10)

' create line
Dim line__1 As Line = Line.CreateUnbound(startPoint, directionPt)

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Line Class


LineAndTextAttrSymbol Class

An object that represents a dimension style.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBLineAndTextAttrSymbol
Autodesk.Revit.DBFilledRegionType
Autodesk.Revit.DBGridType
Autodesk.Revit.DBLevelType
Autodesk.Revit.DBTextElementType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LineAndTextAttrSymbol : ElementType
Public Class LineAndTextAttrSymbol
    Inherits ElementType
public ref class LineAndTextAttrSymbol : public ElementType
type LineAndTextAttrSymbol =
    class
        inherit ElementType
    end

The LineAndTextAttrSymbol type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LineAndTextAttrSymbol Properties

The LineAndTextAttrSymbol type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

LineAndTextAttrSymbol Class


LineAndTextAttrSymbol Methods

The LineAndTextAttrSymbol type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LineAndTextAttrSymbol Class


LinearArray Class

An object that represents an Array created linearly within the Revit project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBBaseArray
Autodesk.Revit.DBLinearArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LinearArray : BaseArray
Public Class LinearArray
    Inherits BaseArray
public ref class LinearArray : public BaseArray
type LinearArray =
    class
        inherit BaseArray
    end

The LinearArray type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | Label | The family parameter label of the BaseArray. (Inherited from BaseArray)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Get and Set the Name property (Inherited from BaseArray)
Public property | NumMembers | Retrieves or changes the number of arrayed members. Array placeholder members in the family environment are not counted. (Overrides BaseArrayNumMembers)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
 | ArrayElementsWithoutAssociation | Creates a new linear array from a set of elements.
 | ArrayElementWithoutAssociation | Creates a new linear array from a single element.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create(Document, View, ElementId, Int32, XYZ, ArrayAnchorMember) | Creates a new linear array element from a single element.
 | Create(Document, View, ICollectionElementId, Int32, XYZ, ArrayAnchorMember) | Creates a new linear array element from a set of elements.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetCopiedMemberIds | Retrieves the copied member ids from the array. The first item in an array contains the original elements from which the array was created. All other items in the array are copies. (Overrides BaseArrayGetCopiedMemberIds)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
 | GetMinimumSize | Returns the minimum size for a linear array based on the document.
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetNumberOfMembersIncludingPlaceholders | Returns the number of items in an array, including placeholder items in families.
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetOriginalMemberIds | Retrieves the ids for the original elements from which the array was created. These elements form the first item in the array. (Overrides BaseArrayGetOriginalMemberIds)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
 | IsElementArrayable | Indicates whether the input element is arrayable.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
 | IsValidArraySize | Obsolete. This indicates whether the input count is valid in the project environment.
 | IsValidNumberOfMembers | This indicates whether the input count is a valid size for an array based on the document.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LinearArray Properties

The LinearArray type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | Label | The family parameter label of the BaseArray. (Inherited from BaseArray)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Get and Set the Name property (Inherited from BaseArray)
Public property | NumMembers | Retrieves or changes the number of arrayed members. Array placeholder members in the family environment are not counted. (Overrides BaseArrayNumMembers)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

LinearArray Class


LinearArray.NumMembers Property

LinearArrayNumMembers Property

Retrieves or changes the number of arrayed members. Array placeholder members in the family environment are not counted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int NumMembers { get; set; }
Public Overrides Property NumMembers As Integer
    Get
    Set
public:
virtual property int NumMembers {
    int get () override;
    void set (int value) override;
}
abstract NumMembers : int with get, set
override NumMembers : int with get, set

Property Value

Int32
See Also

Reference

LinearArray Class


LinearArray Methods

The LinearArray type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
 | ArrayElementsWithoutAssociation | Creates a new linear array from a set of elements.
 | ArrayElementWithoutAssociation | Creates a new linear array from a single element.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create(Document, View, ElementId, Int32, XYZ, ArrayAnchorMember) | Creates a new linear array element from a single element.
 | Create(Document, View, ICollectionElementId, Int32, XYZ, ArrayAnchorMember) | Creates a new linear array element from a set of elements.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetCopiedMemberIds | Retrieves the copied member ids from the array. The first item in an array contains the original elements from which the array was created. All other items in the array are copies. (Overrides BaseArrayGetCopiedMemberIds)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
 | GetMinimumSize | Returns the minimum size for a linear array based on the document.
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetNumberOfMembersIncludingPlaceholders | Returns the number of items in an array, including placeholder items in families.
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetOriginalMemberIds | Retrieves the ids for the original elements from which the array was created. These elements form the first item in the array. (Overrides BaseArrayGetOriginalMemberIds)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
 | IsElementArrayable | Indicates whether the input element is arrayable.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
 | IsValidArraySize | Obsolete. This indicates whether the input count is valid in the project environment.
 | IsValidNumberOfMembers | This indicates whether the input count is a valid size for an array based on the document.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LinearArray Class


LinearArray.ArrayElementsWithoutAssociation Method

LinearArrayArrayElementsWithoutAssociation Method

Creates a new linear array from a set of elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ICollection<ElementId> ArrayElementsWithoutAssociation(
    Document aDoc,
    View dBView,
    ICollection<ElementId> ids,
    int count,
    XYZ translationToAnchorMember,
    ArrayAnchorMember anchorMember
)
Public Shared Function ArrayElementsWithoutAssociation (
    aDoc As Document,
    dBView As View,
    ids As ICollection(Of ElementId),
    count As Integer,
    translationToAnchorMember As XYZ,
    anchorMember As ArrayAnchorMember
) As ICollection(Of ElementId)
public:
static ICollection<ElementId^>^ ArrayElementsWithoutAssociation(
    Document^ aDoc,
    View^ dBView,
    ICollection<ElementId^>^ ids,
    int count,
    XYZ^ translationToAnchorMember,
    ArrayAnchorMember anchorMember
)
static member ArrayElementsWithoutAssociation :
        aDoc : Document *
        dBView : View *
        ids : ICollection<ElementId> *
        count : int *
        translationToAnchorMember : XYZ *
        anchorMember : ArrayAnchorMember -> ICollection<ElementId>

Parameters

aDoc Document
The document.
dBView View
The view. If it is a 2d view, translation vector must be in the view plane if elements include view-specific elements. If elements include view-specific elements, they must belong to this view.
ids ICollection ElementId
The elements to array.
count Int32
The number of array members to create including the initial element grouping. Must between 2 and 200 in projects, and between 0 and 200 in families.
translationToAnchorMember XYZ
The translation vector for the array.
anchorMember ArrayAnchorMember
Indicates if the translation vector specifies the location of the second member of the array, or the last member of the array.

Return Value

ICollection ElementId
The ids of the elements created during the operation.
Exceptions
Exception | Condition
ArgumentException | The given element id set is empty. -or- One or more elements in ids do not exist in the document. -or- One or more elements in ids is owned by different views and thus cannot be arrayed together. -or- One or more elements in ids is not arrayable. -or- count must be between 2 and 200 in project documents and between 0 and 200 in family documents. -or- The view is invalid for specific view elements array. -or- The translation point vector is invalid to array the element.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | Failed to create the linear array.
Remarks
The resulting elements will not be associated with an array element.
See Also

Reference

LinearArray Class


LinearArray.ArrayElementWithoutAssociation Method

LinearArrayArrayElementWithoutAssociation Method

Creates a new linear array from a single element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ICollection<ElementId> ArrayElementWithoutAssociation(
    Document aDoc,
    View dBView,
    ElementId id,
    int count,
    XYZ translationToAnchorMember,
    ArrayAnchorMember anchorMember
)
Public Shared Function ArrayElementWithoutAssociation (
    aDoc As Document,
    dBView As View,
    id As ElementId,
    count As Integer,
    translationToAnchorMember As XYZ,
    anchorMember As ArrayAnchorMember
) As ICollection(Of ElementId)
public:
static ICollection<ElementId^>^ ArrayElementWithoutAssociation(
    Document^ aDoc,
    View^ dBView,
    ElementId^ id,
    int count,
    XYZ^ translationToAnchorMember,
    ArrayAnchorMember anchorMember
)
static member ArrayElementWithoutAssociation :
        aDoc : Document *
        dBView : View *
        id : ElementId *
        count : int *
        translationToAnchorMember : XYZ *
        anchorMember : ArrayAnchorMember -> ICollection<ElementId>

Parameters

aDoc Document
The document.
dBView View
The view. If it is a 2d view, translation vector must be in the view plane if the element is a view-specific element.
id ElementId
The element to array.
count Int32
The number of array members to create including the initial element grouping. Must between 2 and 200 in projects, and between 0 and 200 in families.
translationToAnchorMember XYZ
The translation vector for the array.
anchorMember ArrayAnchorMember
Indicates if the translation vector specifies the location of the second member of the array, or the last member of the array.

Return Value

ICollection ElementId
The ids of the elements created during the operation.
Exceptions
Exception | Condition
ArgumentException | The element id does not exist in the document -or- id is not arrayable. -or- count must be between 2 and 200 in project documents and between 0 and 200 in family documents. -or- The view is invalid for specific view elements array. -or- The translation point vector is invalid to array the element.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | Failed to create the linear array.
Remarks
The resulting elements will not be associated with an array element.
See Also

Reference

LinearArray Class


LinearArray.Create Method

LinearArrayCreate Method

Overload List
Name | Description
Create(Document, View, ElementId, Int32, XYZ, ArrayAnchorMember) | Creates a new linear array element from a single element.
Create(Document, View, ICollectionElementId, Int32, XYZ, ArrayAnchorMember) | Creates a new linear array element from a set of elements.
Top
See Also

Reference

LinearArray Class


LinearArray.Create(Document, View, ElementId, Int32, XYZ, ArrayAnchorMember) Method

LinearArrayCreate(Document, View, ElementId, Int32, XYZ, ArrayAnchorMember) Method

Creates a new linear array element from a single element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static LinearArray Create(
    Document aDoc,
    View dBView,
    ElementId id,
    int count,
    XYZ translationToAnchorMember,
    ArrayAnchorMember anchorMember
)
Public Shared Function Create (
    aDoc As Document,
    dBView As View,
    id As ElementId,
    count As Integer,
    translationToAnchorMember As XYZ,
    anchorMember As ArrayAnchorMember
) As LinearArray
public:
static LinearArray^ Create(
    Document^ aDoc,
    View^ dBView,
    ElementId^ id,
    int count,
    XYZ^ translationToAnchorMember,
    ArrayAnchorMember anchorMember
)
static member Create :
        aDoc : Document *
        dBView : View *
        id : ElementId *
        count : int *
        translationToAnchorMember : XYZ *
        anchorMember : ArrayAnchorMember -> LinearArray

Parameters

aDoc Document
The document.
dBView View
The view. If it is a 2d view, translation vector must be in the view plane if the element is a view-specific element.
id ElementId
The element to array.
count Int32
The number of array members to create including the initial element grouping. Must between 2 and 200 in projects, and between 0 and 200 in families.
translationToAnchorMember XYZ
The translation vector for the array.
anchorMember ArrayAnchorMember
Indicates if the translation vector specifies the location of the second member of the array, or the last member of the array.

Return Value

LinearArray
The new linear array element.
Exceptions
Exception | Condition
ArgumentException | The element id does not exist in the document -or- id is not arrayable. -or- count must be between 2 and 200 in project documents and between 0 and 200 in family documents. -or- The view is invalid for specific view elements array. -or- The translation point vector is invalid to array the element.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | Failed to create the linear array.
See Also

Reference

LinearArray Class
Create Overload


LinearArray.Create(Document, View, ICollection<ElementId>, Int32, XYZ, ArrayAnchorMember) Method

LinearArrayCreate(Document, View, ICollectionElementId, Int32, XYZ, ArrayAnchorMember) Method

Creates a new linear array element from a set of elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static LinearArray Create(
    Document aDoc,
    View dBView,
    ICollection<ElementId> ids,
    int count,
    XYZ translationToAnchorMember,
    ArrayAnchorMember anchorMember
)
Public Shared Function Create (
    aDoc As Document,
    dBView As View,
    ids As ICollection(Of ElementId),
    count As Integer,
    translationToAnchorMember As XYZ,
    anchorMember As ArrayAnchorMember
) As LinearArray
public:
static LinearArray^ Create(
    Document^ aDoc,
    View^ dBView,
    ICollection<ElementId^>^ ids,
    int count,
    XYZ^ translationToAnchorMember,
    ArrayAnchorMember anchorMember
)
static member Create :
        aDoc : Document *
        dBView : View *
        ids : ICollection<ElementId> *
        count : int *
        translationToAnchorMember : XYZ *
        anchorMember : ArrayAnchorMember -> LinearArray

Parameters

aDoc Document
The document.
dBView View
The view. If it is a 2d view, translation vector must be in the view plane if elements include view-specific elements. If elements include view-specific elements, they must belong to this view.
ids ICollection ElementId
The elements to array.
count Int32
The number of array members to create including the initial element grouping. Must between 2 and 200 in projects, and between 0 and 200 in families.
translationToAnchorMember XYZ
The translation vector for the array.
anchorMember ArrayAnchorMember
Indicates if the translation vector specifies the location of the second member of the array, or the last member of the array.

Return Value

LinearArray
The new linear array element.
Exceptions
Exception | Condition
ArgumentException | The given element id set is empty. -or- One or more elements in ids do not exist in the document. -or- One or more elements in ids is owned by different views and thus cannot be arrayed together. -or- One or more elements in ids is not arrayable. -or- count must be between 2 and 200 in project documents and between 0 and 200 in family documents. -or- The view is invalid for specific view elements array. -or- The translation point vector is invalid to array the element.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | Failed to create the linear array.
See Also

Reference

LinearArray Class
Create Overload


LinearArray.GetCopiedMemberIds Method

LinearArrayGetCopiedMemberIds Method

Retrieves the copied member ids from the array. The first item in an array contains the original elements from which the array was created. All other items in the array are copies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ICollection<ElementId> GetCopiedMemberIds()
Public Overrides Function GetCopiedMemberIds As ICollection(Of ElementId)
public:
virtual ICollection<ElementId^>^ GetCopiedMemberIds() override
abstract GetCopiedMemberIds : unit -> ICollection<ElementId>
override GetCopiedMemberIds : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
The copied member ids of the Array
Remarks
Note that in the family environment, arrays of count 0 or 1 use a placeholder item for the first copied item. The member ids from the placeholder item are returned too.
See Also

Reference

LinearArray Class


LinearArray.GetMinimumSize Method

LinearArrayGetMinimumSize Method

Returns the minimum size for a linear array based on the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int GetMinimumSize(
    Document document
)
Public Shared Function GetMinimumSize (
    document As Document
) As Integer
public:
static int GetMinimumSize(
    Document^ document
)
static member GetMinimumSize :
        document : Document -> int

Parameters

document Document
The document.

Return Value

Int32
The minimum size of an array.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
This value is 2 in projects and 0 in families.
See Also

Reference

LinearArray Class


LinearArray.GetNumberOfMembersIncludingPlaceholders Method

LinearArrayGetNumberOfMembersIncludingPlaceholders Method

Returns the number of items in an array, including placeholder items in families.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetNumberOfMembersIncludingPlaceholders()
Public Function GetNumberOfMembersIncludingPlaceholders As Integer
public:
int GetNumberOfMembersIncludingPlaceholders()
member GetNumberOfMembersIncludingPlaceholders : unit -> int

Return Value

Int32
The number of elements in an array, including placeholder items in families.
Remarks
To find the number of placeholder elements in a family, subtract the value of the NumMembers property from this value.
See Also

Reference

LinearArray Class


LinearArray.GetOriginalMemberIds Method

LinearArrayGetOriginalMemberIds Method

Retrieves the ids for the original elements from which the array was created. These elements form the first item in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ICollection<ElementId> GetOriginalMemberIds()
Public Overrides Function GetOriginalMemberIds As ICollection(Of ElementId)
public:
virtual ICollection<ElementId^>^ GetOriginalMemberIds() override
abstract GetOriginalMemberIds : unit -> ICollection<ElementId>
override GetOriginalMemberIds : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
The original member ids of the Array
Remarks
In the family environment, arrays with count 0 use the original elements as a placeholder item for the first array item. The ids of the original elements from which the array was created are returned even for arrays of count 0.
See Also

Reference

LinearArray Class


LinearArray.IsElementArrayable Method

LinearArrayIsElementArrayable Method

Indicates whether the input element is arrayable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsElementArrayable(
    Document aDoc,
    ElementId id
)
Public Shared Function IsElementArrayable (
    aDoc As Document,
    id As ElementId
) As Boolean
public:
static bool IsElementArrayable(
    Document^ aDoc,
    ElementId^ id
)
static member IsElementArrayable :
        aDoc : Document *
        id : ElementId -> bool

Parameters

aDoc Document
The document.
id ElementId
The element id.

Return Value

Boolean
True if the input element is arrayable, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

LinearArray Class


LinearArray.IsValidArraySize Method

LinearArrayIsValidArraySize Method

Note: This API is now obsolete.

This indicates whether the input count is valid in the project environment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is deprecated in Revit 2025 and may be removed in a later version of Revit. We suggest you use the 'IsValidNumberOfMembers' method instead.")]
public static bool IsValidArraySize(
    int count
)
<ObsoleteAttribute("This method is deprecated in Revit 2025 and may be removed in a later version of Revit. We suggest you use the 'IsValidNumberOfMembers' method instead.")>
Public Shared Function IsValidArraySize (
    count As Integer
) As Boolean
public:
[ObsoleteAttribute(L"This method is deprecated in Revit 2025 and may be removed in a later version of Revit. We suggest you use the 'IsValidNumberOfMembers' method instead.")]
static bool IsValidArraySize(
    int count
)
[<ObsoleteAttribute("This method is deprecated in Revit 2025 and may be removed in a later version of Revit. We suggest you use the 'IsValidNumberOfMembers' method instead.")>]
static member IsValidArraySize :
        count : int -> bool

Parameters

count Int32
The count.

Return Value

Boolean
True if the input count is between 2 and 200, false otherwise.
See Also

Reference

LinearArray Class


LinearArray.IsValidNumberOfMembers Method

LinearArrayIsValidNumberOfMembers Method

This indicates whether the input count is a valid size for an array based on the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidNumberOfMembers(
    int count,
    Document pADoc
)
Public Shared Function IsValidNumberOfMembers (
    count As Integer,
    pADoc As Document
) As Boolean
public:
static bool IsValidNumberOfMembers(
    int count,
    Document^ pADoc
)
static member IsValidNumberOfMembers :
        count : int *
        pADoc : Document -> bool

Parameters

count Int32
The count.
pADoc Document
The document.

Return Value

Boolean
True if an array can be set to the specified count in the given document, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
In project documents, the array count must be between 2 and 200. In family documents, the array count must be between 0 and 200.
See Also

Reference

LinearArray Class


LinearDimension Class

LinearDimString
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBDimension
Autodesk.Revit.DBLinearDimension

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LinearDimension : Dimension
Public Class LinearDimension
    Inherits Dimension
public ref class LinearDimension : public Dimension
type LinearDimension =
    class
        inherit Dimension
    end

The LinearDimension type exposes the following members.

Properties
 | Name | Description
Public property | Above | The text shown above the segment's value. (Inherited from Dimension)
Public property | AreReferencesAvailable | Indicates if this dimension's references can be resolved. (Inherited from Dimension)
Public property | AreSegmentsEqual | Indicates if all segments are forced to be equal. (Inherited from Dimension)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | Below | The text shown below the segment's value. (Inherited from Dimension)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | Curve | A curve that represents the dimension line. (Inherited from Dimension)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | DimensionShape | The shape of this dimension. (Inherited from Dimension)
Public property | DimensionType | The dimension style of this dimension. (Inherited from Dimension)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyLabel | The family parameter label of the dimension. (Inherited from Dimension)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HasLeader | True if dimension has leader, false otherwise. (Inherited from Dimension)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsLocked | Indicates if this dimension is locked. (Inherited from Dimension)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValid | Indicates if this dimension is valid. (Inherited from Dimension)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LeaderEndPosition | The position of the dimension's leader end point. (Inherited from Dimension)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Retrieves or changes the name associated with the Dimension. (Inherited from Dimension)
Public property | NumberOfSegments | The number of segments for the dimension. (Inherited from Dimension)
Public property | Origin | The dimension origin. (Inherited from Dimension)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Prefix | The text shown before the segment's value. (Inherited from Dimension)
Public property | References | Returns an array of geometric references to which the dimension is attached. (Inherited from Dimension)
Public property | Segments | The segments in the dimension. (Inherited from Dimension)
Public property | Suffix | The text shown after the segment's value. (Inherited from Dimension)
 | TextPosition | The position of the dimension text's drag point. (Inherited from Dimension)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | Value | The value of the dimension. (Inherited from Dimension)
Public property | ValueOverride | The text that replaces the segment's value. (Inherited from Dimension)
Public property | ValueString | The dimension value as a user visible string. (Inherited from Dimension)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | View | Supplies the view that contains the dimension if the dimension is view specific. (Inherited from Dimension)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new instance of an Linear Dimension element within the project.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasOneSegment | Determines whether a dimension has one segment. (Inherited from Dimension)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsTextPositionAdjustable | Indicates if this dimension is supported to set/get TextPosition/LeaderEndPosition. (Inherited from Dimension)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | ResetTextPosition | Resets the text position of the dimension to the initial position determined by its type and parameters. (Inherited from Dimension)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LinearDimension Properties

The LinearDimension type exposes the following members.

Properties
 | Name | Description
Public property | Above | The text shown above the segment's value. (Inherited from Dimension)
Public property | AreReferencesAvailable | Indicates if this dimension's references can be resolved. (Inherited from Dimension)
Public property | AreSegmentsEqual | Indicates if all segments are forced to be equal. (Inherited from Dimension)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | Below | The text shown below the segment's value. (Inherited from Dimension)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | Curve | A curve that represents the dimension line. (Inherited from Dimension)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | DimensionShape | The shape of this dimension. (Inherited from Dimension)
Public property | DimensionType | The dimension style of this dimension. (Inherited from Dimension)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyLabel | The family parameter label of the dimension. (Inherited from Dimension)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HasLeader | True if dimension has leader, false otherwise. (Inherited from Dimension)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsLocked | Indicates if this dimension is locked. (Inherited from Dimension)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValid | Indicates if this dimension is valid. (Inherited from Dimension)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LeaderEndPosition | The position of the dimension's leader end point. (Inherited from Dimension)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Retrieves or changes the name associated with the Dimension. (Inherited from Dimension)
Public property | NumberOfSegments | The number of segments for the dimension. (Inherited from Dimension)
Public property | Origin | The dimension origin. (Inherited from Dimension)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Prefix | The text shown before the segment's value. (Inherited from Dimension)
Public property | References | Returns an array of geometric references to which the dimension is attached. (Inherited from Dimension)
Public property | Segments | The segments in the dimension. (Inherited from Dimension)
Public property | Suffix | The text shown after the segment's value. (Inherited from Dimension)
 | TextPosition | The position of the dimension text's drag point. (Inherited from Dimension)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | Value | The value of the dimension. (Inherited from Dimension)
Public property | ValueOverride | The text that replaces the segment's value. (Inherited from Dimension)
Public property | ValueString | The dimension value as a user visible string. (Inherited from Dimension)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | View | Supplies the view that contains the dimension if the dimension is view specific. (Inherited from Dimension)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

LinearDimension Class


LinearDimension Methods

The LinearDimension type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new instance of an Linear Dimension element within the project.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasOneSegment | Determines whether a dimension has one segment. (Inherited from Dimension)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsTextPositionAdjustable | Indicates if this dimension is supported to set/get TextPosition/LeaderEndPosition. (Inherited from Dimension)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | ResetTextPosition | Resets the text position of the dimension to the initial position determined by its type and parameters. (Inherited from Dimension)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LinearDimension Class


LinearDimension.Create Method

LinearDimensionCreate Method

Creates a new instance of an Linear Dimension element within the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static LinearDimension Create(
    Document document,
    View dbView,
    Line line,
    IList<Reference> references
)
Public Shared Function Create (
    document As Document,
    dbView As View,
    line As Line,
    references As IList(Of Reference)
) As LinearDimension
public:
static LinearDimension^ Create(
    Document^ document,
    View^ dbView,
    Line^ line,
    IList<Reference^>^ references
)
static member Create :
        document : Document *
        dbView : View *
        line : Line *
        references : IList<Reference> -> LinearDimension

Parameters

document Document
The document where new Linear Dimension is created.
dbView View
The view in which the Linear Dimension will appear.
line Line
The line of the annotation
references IList Reference
references that the Linear Dimension will witness.

Return Value

LinearDimension
The newly created Linear Dimension instance, or if the operation fails.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

LinearDimension Class


LinePattern Class

Represents a line pattern definition.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBLinePattern

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LinePattern : IDisposable
Public Class LinePattern
    Implements IDisposable
public ref class LinePattern : IDisposable
type LinePattern =
    class
        interface IDisposable
    end

The LinePattern type exposes the following members.

Constructors
 | Name | Description
Public method | LinePattern | Creates a simple line pattern.
Public method | LinePattern(String) | Creates a line pattern with given name.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | Line pattern name.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the LinePattern
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetSegments | Gets the sequence of segments that defines this line pattern.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetSegments | Sets the sequence of segments that defines this line pattern.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
A line pattern is a pattern of dashes and dots used to control the way the lines of an object are drawn in Revit. Line patterns are used in the definition of GraphicsStyle objects. A line pattern is defined by a repeating sequence segments. Each segment is a dash, a dot or a space. A line pattern definition must contain an even number of segments, starting with a visible segment (a dash or a dot) and alternating between visible segments and spaces.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LinePattern Constructor

Overload List
 | Name | Description
Public method | LinePattern | Creates a simple line pattern.
Public method | LinePattern(String) | Creates a line pattern with given name.
Top
See Also

Reference

LinePattern Class


LinePattern Constructor

Creates a simple line pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LinePattern()
Public Sub New
public:
LinePattern()
new : unit -> LinePattern
See Also

Reference

LinePattern Class
LinePattern Overload


LinePattern(String) Constructor

Creates a line pattern with given name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LinePattern(
    string name
)
Public Sub New (
    name As String
)
public:
LinePattern(
    String^ name
)
new :
        name : string -> LinePattern

Parameters

name String
The name.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

LinePattern Class
LinePattern Overload


LinePattern Properties

The LinePattern type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | Line pattern name.
Top
See Also

Reference

LinePattern Class


LinePattern.IsValidObject Property

LinePatternIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

LinePattern Class


LinePattern.Name Property

LinePatternName Property

Line pattern name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

LinePattern Class


LinePattern Methods

The LinePattern type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetSegments | Gets the sequence of segments that defines this line pattern.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetSegments | Sets the sequence of segments that defines this line pattern.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LinePattern Class


LinePattern.Dispose Method

LinePatternDispose Method

Releases all resources used by the LinePattern

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

LinePattern Class


LinePattern.GetSegments Method

LinePatternGetSegments Method

Gets the sequence of segments that defines this line pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<LinePatternSegment> GetSegments()
Public Function GetSegments As IList(Of LinePatternSegment)
public:
IList<LinePatternSegment^>^ GetSegments()
member GetSegments : unit -> IList<LinePatternSegment>

Return Value

IList LinePatternSegment
The sequence of segments.
See Also

Reference

LinePattern Class


LinePattern.SetSegments Method

LinePatternSetSegments Method

Sets the sequence of segments that defines this line pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetSegments(
    IList<LinePatternSegment> lineSegs
)
Public Sub SetSegments (
    lineSegs As IList(Of LinePatternSegment)
)
public:
void SetSegments(
    IList<LinePatternSegment^>^ lineSegs
)
member SetSegments :
        lineSegs : IList<LinePatternSegment> -> unit

Parameters

lineSegs IList LinePatternSegment
The sequence of segments.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

LinePattern Class


LinePatternElement Class

An element that represents a line pattern.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBLinePatternElement

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LinePatternElement : Element
Public Class LinePatternElement
    Inherits Element
public ref class LinePatternElement : public Element
type LinePatternElement =
    class
        inherit Element
    end

The LinePatternElement type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new LinePatternElement.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLinePattern | Gets the LinePattern associated to this element.
 | GetLinePattern(Document, ElementId) | Gets the LinePattern associated to an element or from a built-in line pattern.
 | GetLinePatternElementByName | Retrieves the LinePatternElement by its name.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
 | GetSolidPatternId | Gets the solid line pattern element id.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetLinePattern | Sets the LinePattern associated to this element.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The LinePatternElement represents a line pattern in a project. It enables the user to retrieve, modify or create a line pattern in a project.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LinePatternElement Properties

The LinePatternElement type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

LinePatternElement Class


LinePatternElement Methods

The LinePatternElement type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new LinePatternElement.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLinePattern | Gets the LinePattern associated to this element.
 | GetLinePattern(Document, ElementId) | Gets the LinePattern associated to an element or from a built-in line pattern.
 | GetLinePatternElementByName | Retrieves the LinePatternElement by its name.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
 | GetSolidPatternId | Gets the solid line pattern element id.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetLinePattern | Sets the LinePattern associated to this element.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LinePatternElement Class


LinePatternElement.Create Method

LinePatternElementCreate Method

Creates a new LinePatternElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static LinePatternElement Create(
    Document document,
    LinePattern linePattern
)
Public Shared Function Create (
    document As Document,
    linePattern As LinePattern
) As LinePatternElement
public:
static LinePatternElement^ Create(
    Document^ document,
    LinePattern^ linePattern
)
static member Create :
        document : Document *
        linePattern : LinePattern -> LinePatternElement

Parameters

document Document
The document in which to create the LinePatternElement.
linePattern LinePattern
The LinePattern associated to the newly created LinePatternElement.

Return Value

LinePatternElement
The newly created LinePatternElement.
Exceptions
Exception | Condition
ArgumentException | The Line Pattern is not valid.
ArgumentNullException | A non-optional argument was null
See Also

Reference

LinePatternElement Class


LinePatternElement.GetLinePattern Method

LinePatternElementGetLinePattern Method

Overload List
 | Name | Description
Public method | GetLinePattern | Gets the LinePattern associated to this element.
 | GetLinePattern(Document, ElementId) | Gets the LinePattern associated to an element or from a built-in line pattern.
Top
See Also

Reference

LinePatternElement Class


LinePatternElement.GetLinePattern Method

LinePatternElementGetLinePattern Method

Gets the LinePattern associated to this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LinePattern GetLinePattern()
Public Function GetLinePattern As LinePattern
public:
LinePattern^ GetLinePattern()
member GetLinePattern : unit -> LinePattern

Return Value

LinePattern
A copy of LinePattern object.
See Also

Reference

LinePatternElement Class
GetLinePattern Overload


LinePatternElement.GetLinePattern(Document, ElementId) Method

LinePatternElementGetLinePattern(Document, ElementId) Method

Gets the LinePattern associated to an element or from a built-in line pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static LinePattern GetLinePattern(
    Document document,
    ElementId elementId
)
Public Shared Function GetLinePattern (
    document As Document,
    elementId As ElementId
) As LinePattern
public:
static LinePattern^ GetLinePattern(
    Document^ document,
    ElementId^ elementId
)
static member GetLinePattern :
        document : Document *
        elementId : ElementId -> LinePattern

Parameters

document Document
The document in which to retrieve the LinePattern.
elementId ElementId
The ElementId of the LinePatternElement or the built-in line pattern id.

Return Value

LinePattern
A copy of LinePattern object. if the ElementId doesn't represent a line pattern element or built-in line pattern. for Solid.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

LinePatternElement Class
GetLinePattern Overload


LinePatternElement.GetLinePatternElementByName Method

LinePatternElementGetLinePatternElementByName Method

Retrieves the LinePatternElement by its name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static LinePatternElement GetLinePatternElementByName(
    Document document,
    string name
)
Public Shared Function GetLinePatternElementByName (
    document As Document,
    name As String
) As LinePatternElement
public:
static LinePatternElement^ GetLinePatternElementByName(
    Document^ document,
    String^ name
)
static member GetLinePatternElementByName :
        document : Document *
        name : string -> LinePatternElement

Parameters

document Document
The document in which to retrieve the LinePatternElement.
name String
The name of the LinePatternElement.

Return Value

LinePatternElement
The LinePatternElement.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

LinePatternElement Class


LinePatternElement.GetSolidPatternId Method

LinePatternElementGetSolidPatternId Method

Gets the solid line pattern element id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ElementId GetSolidPatternId()
Public Shared Function GetSolidPatternId As ElementId
public:
static ElementId^ GetSolidPatternId()
static member GetSolidPatternId : unit -> ElementId

Return Value

ElementId
The element id of the solid line pattern.
Remarks
Note that Solid is special. It isn't a line pattern at all -- it is a special code that tells drawing and export code to use solid lines rather than patterned lines. Solid is visible to the user when selecting line patterns.
See Also

Reference

LinePatternElement Class


LinePatternElement.SetLinePattern Method

LinePatternElementSetLinePattern Method

Sets the LinePattern associated to this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetLinePattern(
    LinePattern newLinePattern
)
Public Sub SetLinePattern (
    newLinePattern As LinePattern
)
public:
void SetLinePattern(
    LinePattern^ newLinePattern
)
member SetLinePattern :
        newLinePattern : LinePattern -> unit

Parameters

newLinePattern LinePattern
The new LinePattern object.
Exceptions
Exception | Condition
ArgumentException | The Line Pattern is not valid.
ArgumentNullException | A non-optional argument was null
Remarks
The data stored inside the input LinePattern will be copied into this element. The input LinePattern itself will not be associated with the element.
See Also

Reference

LinePatternElement Class


LinePatternSegment Class

Represents a segment in a line pattern.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBLinePatternSegment

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LinePatternSegment : IDisposable
Public Class LinePatternSegment
    Implements IDisposable
public ref class LinePatternSegment : IDisposable
type LinePatternSegment =
    class
        interface IDisposable
    end

The LinePatternSegment type exposes the following members.

Constructors
 | Name | Description
Public method | LinePatternSegment | Creates a line pattern segment.
Public method | LinePatternSegment(LinePatternSegmentType, Double) | Creates a line pattern segment with given type and length.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Length | Gets and sets the length of the segment.
Public property | Type | Gets and sets the type of the segment.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the LinePatternSegment
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LinePatternSegment Constructor

Overload List
 | Name | Description
Public method | LinePatternSegment | Creates a line pattern segment.
Public method | LinePatternSegment(LinePatternSegmentType, Double) | Creates a line pattern segment with given type and length.
Top
See Also

Reference

LinePatternSegment Class


LinePatternSegment Constructor

Creates a line pattern segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LinePatternSegment()
Public Sub New
public:
LinePatternSegment()
new : unit -> LinePatternSegment
See Also

Reference

LinePatternSegment Class
LinePatternSegment Overload


LinePatternSegment(LinePatternSegmentType, Double) Constructor

Creates a line pattern segment with given type and length.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LinePatternSegment(
    LinePatternSegmentType type,
    double length
)
Public Sub New (
    type As LinePatternSegmentType,
    length As Double
)
public:
LinePatternSegment(
    LinePatternSegmentType type,
    double length
)
new :
        type : LinePatternSegmentType *
        length : float -> LinePatternSegment

Parameters

type LinePatternSegmentType
The segment type.
length Double
The length.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

LinePatternSegment Class
LinePatternSegment Overload


LinePatternSegment Properties

The LinePatternSegment type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Length | Gets and sets the length of the segment.
Public property | Type | Gets and sets the type of the segment.
Top
See Also

Reference

LinePatternSegment Class


LinePatternSegment.IsValidObject Property

LinePatternSegmentIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

LinePatternSegment Class


LinePatternSegment.Length Property

LinePatternSegmentLength Property

Gets and sets the length of the segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Length { get; set; }
Public Property Length As Double
    Get
    Set
public:
property double Length {
    double get ();
    void set (double value);
}
member Length : float with get, set

Property Value

Double
The length of the segment.
See Also

Reference

LinePatternSegment Class


LinePatternSegment.Type Property

LinePatternSegmentType Property

Gets and sets the type of the segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LinePatternSegmentType Type { get; set; }
Public Property Type As LinePatternSegmentType
    Get
    Set
public:
property LinePatternSegmentType Type {
    LinePatternSegmentType get ();
    void set (LinePatternSegmentType value);
}
member Type : LinePatternSegmentType with get, set

Property Value

LinePatternSegmentType
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

LinePatternSegment Class


LinePatternSegment Methods

The LinePatternSegment type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LinePatternSegment Class


LinePatternSegment.Dispose Method

LinePatternSegmentDispose Method

Releases all resources used by the LinePatternSegment

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

LinePatternSegment Class


LinePatternSegmentType Enumeration

Represents the type of a line pattern segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum LinePatternSegmentType
Public Enumeration LinePatternSegmentType
public enum class LinePatternSegmentType
type LinePatternSegmentType
Members
Member name | Value | Description
Dash | 0 | A dash
Space | 1 | A space
Dot | 2 | A dot
Invalid | 3 |
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LineProperties Class

A structure that has access to the pen properties of lines/curves that are currently being drawn/exported via an export context during a custom export process.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBLineProperties

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LineProperties : IDisposable
Public Class LineProperties
    Implements IDisposable
public ref class LineProperties : IDisposable
type LineProperties =
    class
        interface IDisposable
    end

The LineProperties type exposes the following members.

Properties
 | Name | Description
Public property | Color | The current color used when drawing lines/curves.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LineWidth | The current width (thickness) of the pen stroke when drawing lines/curves.
Public property | PatternId | Id of the current Line pattern element used when drawing lines/curves.
Public property | Transparency | The current transparency level to be applied to the current color.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the LineProperties
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
For more about using properties of this class refer to the interface IModelExportContext and its methods which handle geometric objects such as OnCurve(CurveNode), OnLineSegment(LineSegment), etc. LineProperties are available as a read-only property on the respective output nodes, i.e. CurveNode, LineSegment, etc.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LineProperties Properties

The LineProperties type exposes the following members.

Properties
 | Name | Description
Public property | Color | The current color used when drawing lines/curves.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LineWidth | The current width (thickness) of the pen stroke when drawing lines/curves.
Public property | PatternId | Id of the current Line pattern element used when drawing lines/curves.
Public property | Transparency | The current transparency level to be applied to the current color.
Top
See Also

Reference

LineProperties Class


LineProperties.Color Property

LinePropertiesColor Property

The current color used when drawing lines/curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color Color { get; }
Public ReadOnly Property Color As Color
    Get
public:
property Color^ Color {
    Color^ get ();
}
member Color : Color with get

Property Value

Color
See Also

Reference

LineProperties Class


LineProperties.IsValidObject Property

LinePropertiesIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

LineProperties Class


LineProperties.LineWidth Property

LinePropertiesLineWidth Property

The current width (thickness) of the pen stroke when drawing lines/curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double LineWidth { get; }
Public ReadOnly Property LineWidth As Double
    Get
public:
property double LineWidth {
    double get ();
}
member LineWidth : float with get

Property Value

Double
See Also

Reference

LineProperties Class


LineProperties.PatternId Property

LinePropertiesPatternId Property

Id of the current Line pattern element used when drawing lines/curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId PatternId { get; }
Public ReadOnly Property PatternId As ElementId
    Get
public:
property ElementId^ PatternId {
    ElementId^ get ();
}
member PatternId : ElementId with get

Property Value

ElementId
See Also

Reference

LineProperties Class


LineProperties.Transparency Property

LinePropertiesTransparency Property

The current transparency level to be applied to the current color.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Transparency { get; }
Public ReadOnly Property Transparency As Integer
    Get
public:
property int Transparency {
    int get ();
}
member Transparency : int with get

Property Value

Int32
See Also

Reference

LineProperties Class


LineProperties Methods

The LineProperties type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LineProperties Class


LineProperties.Dispose Method

LinePropertiesDispose Method

Releases all resources used by the LineProperties

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

LineProperties Class


LineScaling Enumeration

An enumerated type listing possible LineType scaling modes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum LineScaling
Public Enumeration LineScaling
public enum class LineScaling
type LineScaling
Members
Member name | Value | Description
ViewScale | 0 | Exporting lines as they were scaled by view scale. This option preserves visual fidelity.
ModelSpace | 1 | Modelspace scaling. LTSCALE is set to view scale and PSLTSCALE to 0.
PaperSpace | 2 | Paperspace scaling. Specifies the value 1 for both LTSCALE and PSLTSCALE.
Remarks
Whichever option is chosen, line type definitions are created so a dashed line always begins and ends with a dash. Using these options does change the default behavior of exported DWGs. Some lines expected to be dashed may appear solid or in a different scale.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LineSegment Class

An output node that represents a tessellated line segment.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBLineSegment

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LineSegment : IDisposable
Public Class LineSegment
    Implements IDisposable
public ref class LineSegment : IDisposable
type LineSegment =
    class
        interface IDisposable
    end

The LineSegment type exposes the following members.

Properties
 | Name | Description
Public property | EndParameter | Parameter associated with the end point.
Public property | EndPoint | End point of the line segment.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LineProperties | Access to the line (pen) properties of the line
Public property | StartParameter | Parameter associated with the start point.
Public property | StartPoint | Start point of the line segment.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the LineSegment
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
See also: OnLineSegment(LineSegment).
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LineSegment Properties

The LineSegment type exposes the following members.

Properties
 | Name | Description
Public property | EndParameter | Parameter associated with the end point.
Public property | EndPoint | End point of the line segment.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LineProperties | Access to the line (pen) properties of the line
Public property | StartParameter | Parameter associated with the start point.
Public property | StartPoint | Start point of the line segment.
Top
See Also

Reference

LineSegment Class


LineSegment.EndParameter Property

LineSegmentEndParameter Property

Parameter associated with the end point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double EndParameter { get; }
Public ReadOnly Property EndParameter As Double
    Get
public:
property double EndParameter {
    double get ();
}
member EndParameter : float with get

Property Value

Double
See Also

Reference

LineSegment Class


LineSegment.EndPoint Property

LineSegmentEndPoint Property

End point of the line segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ EndPoint { get; }
Public ReadOnly Property EndPoint As XYZ
    Get
public:
property XYZ^ EndPoint {
    XYZ^ get ();
}
member EndPoint : XYZ with get

Property Value

XYZ
See Also

Reference

LineSegment Class


LineSegment.IsValidObject Property

LineSegmentIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

LineSegment Class


LineSegment.LineProperties Property

LineSegmentLineProperties Property

Access to the line (pen) properties of the line

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LineProperties LineProperties { get; }
Public ReadOnly Property LineProperties As LineProperties
    Get
public:
property LineProperties^ LineProperties {
    LineProperties^ get ();
}
member LineProperties : LineProperties with get

Property Value

LineProperties
See Also

Reference

LineSegment Class


LineSegment.StartParameter Property

LineSegmentStartParameter Property

Parameter associated with the start point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double StartParameter { get; }
Public ReadOnly Property StartParameter As Double
    Get
public:
property double StartParameter {
    double get ();
}
member StartParameter : float with get

Property Value

Double
See Also

Reference

LineSegment Class


LineSegment.StartPoint Property

LineSegmentStartPoint Property

Start point of the line segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ StartPoint { get; }
Public ReadOnly Property StartPoint As XYZ
    Get
public:
property XYZ^ StartPoint {
    XYZ^ get ();
}
member StartPoint : XYZ with get

Property Value

XYZ
See Also

Reference

LineSegment Class


LineSegment Methods

The LineSegment type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LineSegment Class


LineSegment.Dispose Method

LineSegmentDispose Method

Releases all resources used by the LineSegment

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

LineSegment Class


LinkConversionData Class

This class contains the information necessary to re-create a Revit document from an external source.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBLinkConversionData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LinkConversionData : IDisposable
Public Class LinkConversionData
    Implements IDisposable
public ref class LinkConversionData : IDisposable
type LinkConversionData =
    class
        interface IDisposable
    end

The LinkConversionData type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Path | The path to the source data used to generate the model.
Public property | ServerId | The service responsible for converting the data into a Revit file.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the LinkConversionData
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetOptions | Extra information used during the creation of the Revit document.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LinkConversionData Properties

The LinkConversionData type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Path | The path to the source data used to generate the model.
Public property | ServerId | The service responsible for converting the data into a Revit file.
Top
See Also

Reference

LinkConversionData Class


LinkConversionData.IsValidObject Property

LinkConversionDataIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

LinkConversionData Class


LinkConversionData.Path Property

LinkConversionDataPath Property

The path to the source data used to generate the model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Path { get; }
Public ReadOnly Property Path As String
    Get
public:
property String^ Path {
    String^ get ();
}
member Path : string with get

Property Value

String
See Also

Reference

LinkConversionData Class


LinkConversionData.ServerId Property

LinkConversionDataServerId Property

The service responsible for converting the data into a Revit file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid ServerId { get; }
Public ReadOnly Property ServerId As Guid
    Get
public:
property Guid ServerId {
    Guid get ();
}
member ServerId : Guid with get

Property Value

Guid
See Also

Reference

LinkConversionData Class


LinkConversionData Methods

The LinkConversionData type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetOptions | Extra information used during the creation of the Revit document.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LinkConversionData Class


LinkConversionData.Dispose Method

LinkConversionDataDispose Method

Releases all resources used by the LinkConversionData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

LinkConversionData Class


LinkConversionData.GetOptions Method

LinkConversionDataGetOptions Method

Extra information used during the creation of the Revit document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IDictionary<string, string> GetOptions()
Public Function GetOptions As IDictionary(Of String, String)
public:
IDictionary<String^, String^>^ GetOptions()
member GetOptions : unit -> IDictionary<string, string>

Return Value

IDictionary String, String
The extra information used during the creation of the Revit document.
See Also

Reference

LinkConversionData Class


LinkedFileStatus Enumeration

Enum displaying the loaded status of a linked file

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum LinkedFileStatus
Public Enumeration LinkedFileStatus
public enum class LinkedFileStatus
type LinkedFileStatus
Members
Member name | Value | Description
Loaded | 0 | The link is loaded.
Unloaded | 1 | The link is unloaded.
Imported | 2 | The element represented by this value was imported into Revit rather than linked into Revit.
NotFound | 3 | The linked file was not able to be found the last time Revit tried to load it.
CanBeUpgraded | 4 | The linked point cloud file is obsolete and can be indexed into new format.
InClosedWorkset | 5 | The linked file is in a closed workset and will not be displayed.
LocallyUnloaded | 6 | The linked file is unloaded for the specific user. (If the linked file is both unloaded for the specific user and unloaded for all users, the link will report LinkedFileStatus.Unloaded.)
Invalid | -1 | This value is the uninitialized value for the enum. It indicates that the link has not been properly initialized.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LinkElementId Class

LinkElementId represents an element in a linked document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBLinkElementId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LinkElementId
Public Class LinkElementId
public ref class LinkElementId
type LinkElementId = class end

The LinkElementId type exposes the following members.

Constructors
 | Name | Description
Public method | LinkElementId(ElementId) | Creates a new LinkElementId representing an element in the host document.
Public method | LinkElementId(ElementId, ElementId) | Creates a new LinkElementId representing an element in a linked document.
Top
Properties
 | Name | Description
Public property | HostElementId | The id of the element in the host, or invalidElementId if there is a link.
Public property | LinkedElementId | The id of the element in the link, or invalidElementId if no link.
Public property | LinkInstanceId | The id of the link, or invalidElementId if no link.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object))
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Operators
Name | Description
Equality(LinkElementId, LinkElementId) | Determines whether these two LinkElementIds are the same.
Inequality(LinkElementId, LinkElementId) | Determines whether these two LinkElementIds are different.
Top
Remarks
The id contains two element ids:
  1. The id of the linked model element in host document.
  2. The id of the element in the linked model document.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LinkElementId Constructor

Overload List
 | Name | Description
Public method | LinkElementId(ElementId) | Creates a new LinkElementId representing an element in the host document.
Public method | LinkElementId(ElementId, ElementId) | Creates a new LinkElementId representing an element in a linked document.
Top
See Also

Reference

LinkElementId Class


LinkElementId(ElementId) Constructor

Creates a new LinkElementId representing an element in the host document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LinkElementId(
    ElementId elementId
)
Public Sub New (
    elementId As ElementId
)
public:
LinkElementId(
    ElementId^ elementId
)
new :
        elementId : ElementId -> LinkElementId

Parameters

elementId ElementId
The id of the element in the host document.
See Also

Reference

LinkElementId Class
LinkElementId Overload


LinkElementId(ElementId, ElementId) Constructor

Creates a new LinkElementId representing an element in a linked document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LinkElementId(
    ElementId linkInstanceId,
    ElementId elementId
)
Public Sub New (
    linkInstanceId As ElementId,
    elementId As ElementId
)
public:
LinkElementId(
    ElementId^ linkInstanceId,
    ElementId^ elementId
)
new :
        linkInstanceId : ElementId *
        elementId : ElementId -> LinkElementId

Parameters

linkInstanceId ElementId
The id of the linked model element in the host document.
elementId ElementId
The id of the element in the linked model document.
See Also

Reference

LinkElementId Class
LinkElementId Overload


LinkElementId Properties

The LinkElementId type exposes the following members.

Properties
 | Name | Description
Public property | HostElementId | The id of the element in the host, or invalidElementId if there is a link.
Public property | LinkedElementId | The id of the element in the link, or invalidElementId if no link.
Public property | LinkInstanceId | The id of the link, or invalidElementId if no link.
Top
See Also

Reference

LinkElementId Class


LinkElementId.HostElementId Property

LinkElementIdHostElementId Property

The id of the element in the host, or invalidElementId if there is a link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId HostElementId { get; }
Public ReadOnly Property HostElementId As ElementId
    Get
public:
property ElementId^ HostElementId {
    ElementId^ get ();
}
member HostElementId : ElementId with get

Property Value

ElementId
See Also

Reference

LinkElementId Class


LinkElementId.LinkedElementId Property

LinkElementIdLinkedElementId Property

The id of the element in the link, or invalidElementId if no link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId LinkedElementId { get; }
Public ReadOnly Property LinkedElementId As ElementId
    Get
public:
property ElementId^ LinkedElementId {
    ElementId^ get ();
}
member LinkedElementId : ElementId with get

Property Value

ElementId
See Also

Reference

LinkElementId Class


LinkElementId.LinkInstanceId Property

LinkElementIdLinkInstanceId Property

The id of the link, or invalidElementId if no link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId LinkInstanceId { get; }
Public ReadOnly Property LinkInstanceId As ElementId
    Get
public:
property ElementId^ LinkInstanceId {
    ElementId^ get ();
}
member LinkInstanceId : ElementId with get

Property Value

ElementId
See Also

Reference

LinkElementId Class


LinkElementId Methods

The LinkElementId type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object))
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LinkElementId Class


LinkElementId.Equals Method

LinkElementIdEquals Method

Determines whether the specified Object is equal to the current Object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj Object
Another object.

Return Value

Boolean
See Also

Reference

LinkElementId Class


LinkElementId Operators

The LinkElementId type exposes the following members.

Operators
Name | Description
Equality(LinkElementId, LinkElementId) | Determines whether these two LinkElementIds are the same.
Inequality(LinkElementId, LinkElementId) | Determines whether these two LinkElementIds are different.
Top
See Also

Reference

LinkElementId Class


LinkElementId.Equality Operator

LinkElementIdEquality Operator

Determines whether these two LinkElementIds are the same.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool operator ==(
    LinkElementId first,
    LinkElementId second
)
Public Shared Operator = (
    first As LinkElementId,
    second As LinkElementId
) As Boolean
public:
static bool operator ==(
    LinkElementId^ first,
    LinkElementId^ second
)
static let inline (=)
        first : LinkElementId *
        second : LinkElementId  : bool

Parameters

first LinkElementId
The first LinkElementId.
second LinkElementId
The second LinkElementId.

Return Value

Boolean
True if the LinkElementIds are the same; otherwise, false.
See Also

Reference

LinkElementId Class


LinkElementId.Inequality Operator

LinkElementIdInequality Operator

Determines whether these two LinkElementIds are different.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool operator !=(
    LinkElementId first,
    LinkElementId second
)
Public Shared Operator <> (
    first As LinkElementId,
    second As LinkElementId
) As Boolean
public:
static bool operator !=(
    LinkElementId^ first,
    LinkElementId^ second
)
static let inline (<>)
        first : LinkElementId *
        second : LinkElementId  : bool

Parameters

first LinkElementId
The first LinkElementId.
second LinkElementId
The second LinkElementId.

Return Value

Boolean
True if the LinkElementIds are different; otherwise, false.
See Also

Reference

LinkElementId Class


LinkLoadContent Class

This class is used by IExternalResourceServers to return Link data to Revit when their LoadResource method is invoked. It also contains additional information used by IExternalResourceUIServers to display link load status results to the user.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBExternalResourceLoadContent
Autodesk.Revit.DBLinkLoadContent

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LinkLoadContent : ExternalResourceLoadContent
Public Class LinkLoadContent
    Inherits ExternalResourceLoadContent
public ref class LinkLoadContent : public ExternalResourceLoadContent
type LinkLoadContent =
    class
        inherit ExternalResourceLoadContent
    end

The LinkLoadContent type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ExternalResourceLoadContent)
Public property | LoadStatus | A value to indicate the status of an external resource load operation. IExternalResourceServers should set this in the LoadResource() method. (Inherited from ExternalResourceLoadContent)
Public property | Version | The version of the external data that the server is providing in this object. (Inherited from ExternalResourceLoadContent)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from ExternalResourceLoadContent)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLinkDataPath | Returns the Link data path owned by this LinkLoadContent object.
Public method | GetLinkLoadResult | Retrieves the LinkLoadResult of the attempt to load or reload a Revit link.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetLinkDataPath | Sets the Link data path owned by this LinkLoadContent object.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

This class handles Revit links.

Revit links must be loaded from a path accessible to Revit. Server implementors should provide Revit with a ModelPath representing a location from which to load the link. Revit will handle the actual file loading.

Servers which represent non-local file locations will need to create their own implementation for copying or moving files to a Revit-accessible location.

The link data path used for link loading may be different from the path displayed to the user. The link data path represents the literal location of the file, whereas the link's display path represents what the user sees as the name of the link. See [!:Autodesk::Revit::DB::ExternalResourceReference::InSessionPath] for more details on display paths.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LinkLoadContent Properties

The LinkLoadContent type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ExternalResourceLoadContent)
Public property | LoadStatus | A value to indicate the status of an external resource load operation. IExternalResourceServers should set this in the LoadResource() method. (Inherited from ExternalResourceLoadContent)
Public property | Version | The version of the external data that the server is providing in this object. (Inherited from ExternalResourceLoadContent)
Top
See Also

Reference

LinkLoadContent Class


LinkLoadContent Methods

The LinkLoadContent type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from ExternalResourceLoadContent)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLinkDataPath | Returns the Link data path owned by this LinkLoadContent object.
Public method | GetLinkLoadResult | Retrieves the LinkLoadResult of the attempt to load or reload a Revit link.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetLinkDataPath | Sets the Link data path owned by this LinkLoadContent object.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LinkLoadContent Class


LinkLoadContent.GetLinkDataPath Method

LinkLoadContentGetLinkDataPath Method

Returns the Link data path owned by this LinkLoadContent object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ModelPath GetLinkDataPath()
Public Function GetLinkDataPath As ModelPath
public:
ModelPath^ GetLinkDataPath()
member GetLinkDataPath : unit -> ModelPath

Return Value

ModelPath
The Links data path owned by this LinkLoadContent object.
Remarks
This path represents the physical location of the link. Revit will attempt to load the link from this location.
See Also

Reference

LinkLoadContent Class


LinkLoadContent.GetLinkLoadResult Method

LinkLoadContentGetLinkLoadResult Method

Retrieves the LinkLoadResult of the attempt to load or reload a Revit link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LinkLoadResult GetLinkLoadResult()
Public Function GetLinkLoadResult As LinkLoadResult
public:
LinkLoadResult^ GetLinkLoadResult()
member GetLinkLoadResult : unit -> LinkLoadResult

Return Value

LinkLoadResult
A LinkLoadObject containing the status and other information about an attempt by Revit to load a Revit link.
Remarks

A LinkLoadResult object is included in the LinkLoadContent class so that IExternalResourceUIServers will have additional information about the status of the link to display to the user.

The LinkLoadResult is added to the LinkLoadContent object during the load operation, after the IExternalResourceServer LoadResource method has been called. Consequently, this method will return NULL if called from the LoadResource method of an IExternalResourceServer.

See Also

Reference

LinkLoadContent Class


LinkLoadContent.SetLinkDataPath Method

LinkLoadContentSetLinkDataPath Method

Sets the Link data path owned by this LinkLoadContent object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetLinkDataPath(
    ModelPath linkPath
)
Public Sub SetLinkDataPath (
    linkPath As ModelPath
)
public:
void SetLinkDataPath(
    ModelPath^ linkPath
)
member SetLinkDataPath :
        linkPath : ModelPath -> unit

Parameters

linkPath ModelPath
The Links data path set for this LinkLoadContent object.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks

This path must be a location accessible to Revit. Revit will attempt to load the link from this location.

See Also

Reference

LinkLoadContent Class


LinkLoadResult Class

This class stores the results of trying to load a single linked model.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBLinkLoadResult

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LinkLoadResult : IDisposable
Public Class LinkLoadResult
    Implements IDisposable
public ref class LinkLoadResult : IDisposable
type LinkLoadResult =
    class
        interface IDisposable
    end

The LinkLoadResult type exposes the following members.

Constructors
 | Name | Description
Public method | LinkLoadResult | Constructs a new uninitialized LinkLoadResult object.
Public method | LinkLoadResult(LinkLoadResult) | Constructs a new copy of the input LinkLoadResult object.
Top
Properties
 | Name | Description
Public property | ElementId | The id of the created or loaded linked model.
Public property | IsCircularLink | True if these results are part of a link cycle.
Public property | IsNested | True if these results represent a nested link; false otherwise.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LoadResult | Holds the results of creating or loading a link. Results can be LinkLoadResultType.LinkLoaded for success, or a variety of errors. See LinkLoadResultType for the full list.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the LinkLoadResult
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCentralModelName | Gets the central model's name. If the link is not workshared, this returns an empty FilePath. If the link is itself a central model, this returns the link's name.
Public method | GetExternalResourceReference | Gets a copy of the ExternalResourceReference corresponding to the link.
Public method | GetExternalResourceReferencesFromFailedLoads | Searches this and all nested LinkLoadResults, and returns a list of ExternalResourceReferences for the links that failed to load.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLinkLoadResult | Searches this LinkLoadResult and all nested LinkLoadResults for the load operation results of a specified ExternalResourceReference.
Public method | GetModelName | Gets the name of the model.
Public method | GetNestedLinkLoadResults | Gets the results for this link's nested links.
Public method | GetParentModelName | Returns the name of the parent of the linked model, or an empty FilePath if the link is a top-level link.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | IsCodeSuccess | Check if load result code signifies success.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LinkLoadResult Constructor

Overload List
 | Name | Description
Public method | LinkLoadResult | Constructs a new uninitialized LinkLoadResult object.
Public method | LinkLoadResult(LinkLoadResult) | Constructs a new copy of the input LinkLoadResult object.
Top
See Also

Reference

LinkLoadResult Class


LinkLoadResult Constructor

Constructs a new uninitialized LinkLoadResult object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LinkLoadResult()
Public Sub New
public:
LinkLoadResult()
new : unit -> LinkLoadResult
See Also

Reference

LinkLoadResult Class
LinkLoadResult Overload


LinkLoadResult(LinkLoadResult) Constructor

Constructs a new copy of the input LinkLoadResult object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LinkLoadResult(
    LinkLoadResult other
)
Public Sub New (
    other As LinkLoadResult
)
public:
LinkLoadResult(
    LinkLoadResult^ other
)
new :
        other : LinkLoadResult -> LinkLoadResult

Parameters

other LinkLoadResult
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

LinkLoadResult Class
LinkLoadResult Overload


LinkLoadResult Properties

The LinkLoadResult type exposes the following members.

Properties
 | Name | Description
Public property | ElementId | The id of the created or loaded linked model.
Public property | IsCircularLink | True if these results are part of a link cycle.
Public property | IsNested | True if these results represent a nested link; false otherwise.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LoadResult | Holds the results of creating or loading a link. Results can be LinkLoadResultType.LinkLoaded for success, or a variety of errors. See LinkLoadResultType for the full list.
Top
See Also

Reference

LinkLoadResult Class


LinkLoadResult.ElementId Property

LinkLoadResultElementId Property

The id of the created or loaded linked model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId ElementId { get; }
Public ReadOnly Property ElementId As ElementId
    Get
public:
property ElementId^ ElementId {
    ElementId^ get ();
}
member ElementId : ElementId with get

Property Value

ElementId
Remarks
This may be invalidElementId if there were errors (for example, LinkLoadResultType.SameModelAsHost causes no link to be created).
See Also

Reference

LinkLoadResult Class


LinkLoadResult.IsCircularLink Property

LinkLoadResultIsCircularLink Property

True if these results are part of a link cycle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCircularLink { get; }
Public ReadOnly Property IsCircularLink As Boolean
    Get
public:
property bool IsCircularLink {
    bool get ();
}
member IsCircularLink : bool with get

Property Value

Boolean
Remarks
A link cycle occurs when, for example, model A links model B as an attachment, which links model C as an attachment, which links model A as an attachment. Revit will only load one copy of model A; it will ignore the instance of A linked under C. Circular links do not abort the load process, so they do not appear as a result type in LinkLoadResultType.Enum. This property is only relevant for LinkLoadResult object for RvtLinkSymbol. ie. when getIsRvtLink() is true.
See Also

Reference

LinkLoadResult Class


LinkLoadResult.IsNested Property

LinkLoadResultIsNested Property

True if these results represent a nested link; false otherwise.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsNested { get; }
Public ReadOnly Property IsNested As Boolean
    Get
public:
property bool IsNested {
    bool get ();
}
member IsNested : bool with get

Property Value

Boolean
Remarks
This property is only relevant for LinkLoadResult object for RvtLinkSymbol. ie. when getIsRvtLink() is true.
See Also

Reference

LinkLoadResult Class


LinkLoadResult.IsValidObject Property

LinkLoadResultIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

LinkLoadResult Class


LinkLoadResult.LoadResult Property

LinkLoadResultLoadResult Property

Holds the results of creating or loading a link. Results can be LinkLoadResultType.LinkLoaded for success, or a variety of errors. See LinkLoadResultType for the full list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LinkLoadResultType LoadResult { get; }
Public ReadOnly Property LoadResult As LinkLoadResultType
    Get
public:
property LinkLoadResultType LoadResult {
    LinkLoadResultType get ();
}
member LoadResult : LinkLoadResultType with get

Property Value

LinkLoadResultType
See Also

Reference

LinkLoadResult Class


LinkLoadResult Methods

The LinkLoadResult type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCentralModelName | Gets the central model's name. If the link is not workshared, this returns an empty FilePath. If the link is itself a central model, this returns the link's name.
Public method | GetExternalResourceReference | Gets a copy of the ExternalResourceReference corresponding to the link.
Public method | GetExternalResourceReferencesFromFailedLoads | Searches this and all nested LinkLoadResults, and returns a list of ExternalResourceReferences for the links that failed to load.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLinkLoadResult | Searches this LinkLoadResult and all nested LinkLoadResults for the load operation results of a specified ExternalResourceReference.
Public method | GetModelName | Gets the name of the model.
Public method | GetNestedLinkLoadResults | Gets the results for this link's nested links.
Public method | GetParentModelName | Returns the name of the parent of the linked model, or an empty FilePath if the link is a top-level link.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | IsCodeSuccess | Check if load result code signifies success.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LinkLoadResult Class


LinkLoadResult.Dispose Method

LinkLoadResultDispose Method

Releases all resources used by the LinkLoadResult

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

LinkLoadResult Class


LinkLoadResult.GetCentralModelName Method

LinkLoadResultGetCentralModelName Method

Gets the central model's name. If the link is not workshared, this returns an empty FilePath. If the link is itself a central model, this returns the link's name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ModelPath GetCentralModelName()
Public Function GetCentralModelName As ModelPath
public:
ModelPath^ GetCentralModelName()
member GetCentralModelName : unit -> ModelPath

Return Value

ModelPath
Remarks
If the link could not be found or loaded, this name may be blank. This function is only relevant for LinkLoadResult object for RvtLinkSymbol. ie. when getIsRvtLink() is true.
See Also

Reference

LinkLoadResult Class


LinkLoadResult.GetExternalResourceReference Method

LinkLoadResultGetExternalResourceReference Method

Gets a copy of the ExternalResourceReference corresponding to the link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExternalResourceReference GetExternalResourceReference()
Public Function GetExternalResourceReference As ExternalResourceReference
public:
ExternalResourceReference^ GetExternalResourceReference()
member GetExternalResourceReference : unit -> ExternalResourceReference

Return Value

ExternalResourceReference
A copy of the ExternalResourceReference corresponding to the link.
See Also

Reference

LinkLoadResult Class


LinkLoadResult.GetExternalResourceReferencesFromFailedLoads Method

LinkLoadResultGetExternalResourceReferencesFromFailedLoads Method

Searches this and all nested LinkLoadResults, and returns a list of ExternalResourceReferences for the links that failed to load.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ExternalResourceReference> GetExternalResourceReferencesFromFailedLoads()
Public Function GetExternalResourceReferencesFromFailedLoads As IList(Of ExternalResourceReference)
public:
IList<ExternalResourceReference^>^ GetExternalResourceReferencesFromFailedLoads()
member GetExternalResourceReferencesFromFailedLoads : unit -> IList<ExternalResourceReference>

Return Value

IList ExternalResourceReference
A collection of link ExternalResourceReferences which failed to load.
Remarks

In cases, where a nested structure of several links were loaded, this method is intended to be a convenient way for IExternalResourceUIServers to determine whether a top-level link, or any sub-link, which failed to load properly was provided by their IExternalResourceServer or another server.

If this link and all nested links loaded successfully, then an empty list is returned.

See Also

Reference

LinkLoadResult Class


LinkLoadResult.GetLinkLoadResult Method

LinkLoadResultGetLinkLoadResult Method

Searches this LinkLoadResult and all nested LinkLoadResults for the load operation results of a specified ExternalResourceReference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LinkLoadResult GetLinkLoadResult(
    ExternalResourceReference matchExtResRef
)
Public Function GetLinkLoadResult (
    matchExtResRef As ExternalResourceReference
) As LinkLoadResult
public:
LinkLoadResult^ GetLinkLoadResult(
    ExternalResourceReference^ matchExtResRef
)
member GetLinkLoadResult :
        matchExtResRef : ExternalResourceReference -> LinkLoadResult

Parameters

matchExtResRef ExternalResourceReference
An ExternalResourceReference whose LinkLoadResults are contained in this object.

Return Value

LinkLoadResult
A LinkLoadResult object with the load results for the specified ExternalResourceReference.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks

In the case where there are multiple matches, then the LinkLoadResult closest to the top-level link will be returned. For example, if you are searching for C, starting with a top-level link, A, which links B and C, while B also links C directly, then the load results for C as a direct sub-link of A will be returned. It is expected that the LinkLoadResults for all instances of C in the nested load result tree will be the same. However, if you need to inspect each individual result, the LinkLoadResult class does provide methods to navigate the tree.

NULL is returned if a match for the ExternalResourceReference cannot be found.

See Also

Reference

LinkLoadResult Class


LinkLoadResult.GetModelName Method

LinkLoadResultGetModelName Method

Gets the name of the model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ModelPath GetModelName()
Public Function GetModelName As ModelPath
public:
ModelPath^ GetModelName()
member GetModelName : unit -> ModelPath

Return Value

ModelPath
See Also

Reference

LinkLoadResult Class


LinkLoadResult.GetNestedLinkLoadResults Method

LinkLoadResultGetNestedLinkLoadResults Method

Gets the results for this link's nested links.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IDictionary<string, LinkLoadResult> GetNestedLinkLoadResults()
Public Function GetNestedLinkLoadResults As IDictionary(Of String, LinkLoadResult)
public:
IDictionary<String^, LinkLoadResult^>^ GetNestedLinkLoadResults()
member GetNestedLinkLoadResults : unit -> IDictionary<string, LinkLoadResult>

Return Value

IDictionary String, LinkLoadResult

A map from nested link paths to the load results for that nested link.

For links from external servers, the "path" will be the display name of the link.

Remarks
This function is only relevant for LinkLoadResult object for RvtLinkSymbol. ie. when getIsRvtLink() is true.
See Also

Reference

LinkLoadResult Class


LinkLoadResult.GetParentModelName Method

LinkLoadResultGetParentModelName Method

Returns the name of the parent of the linked model, or an empty FilePath if the link is a top-level link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ModelPath GetParentModelName()
Public Function GetParentModelName As ModelPath
public:
ModelPath^ GetParentModelName()
member GetParentModelName : unit -> ModelPath

Return Value

ModelPath
Remarks
This function is only relevant for LinkLoadResult object for RvtLinkSymbol. ie. when getIsRvtLink() is true.
See Also

Reference

LinkLoadResult Class


LinkLoadResult.IsCodeSuccess Method

LinkLoadResultIsCodeSuccess Method

Check if load result code signifies success.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsCodeSuccess(
    LinkLoadResultType code
)
Public Shared Function IsCodeSuccess (
    code As LinkLoadResultType
) As Boolean
public:
static bool IsCodeSuccess(
    LinkLoadResultType code
)
static member IsCodeSuccess :
        code : LinkLoadResultType -> bool

Parameters

code LinkLoadResultType
Load result code to be verified.

Return Value

Boolean
True if LinkLoadResultType argument is success, false otherwise.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

LinkLoadResult Class


LinkLoadResultType Enumeration

Enum listing the possible results after loading a linked model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum LinkLoadResultType
Public Enumeration LinkLoadResultType
public enum class LinkLoadResultType
type LinkLoadResultType
Members
Member name | Value | Description
Uninitialized | 0 | Revit has not tried to load the link, possibly because it is a nested link and its parent failed to load.
LinkLoaded | 1 | The linked model loaded correctly.
LinkNotFound | 2 | The linked model could not be found.
LinkNotOpenable | 3 | An error occurred trying to read the linked model. It could happen if a wrong link type is trying to be loaded.
LinkOpenAsHost | 4 | The linked model is already opened directly in Revit.
SameModelAsHost | 5 | The linked model has the same path as the currently active document.
SameCentralModelAsHost | 6 | Either the linked model and its host document are both locals of the same central model, or one is a local and the other is its central.
LinkNotLoadedOtherError | 7 | An unknown error occurred.
LinkMayBeUpgraded | 8 | Point cloud link loaded correctly but is obsolete and may be upgraded.
ExternalServerMissing | 9 | The external add-in required to load this link model could not be found.
LinkExists | 10 | Revit already has a link with the input location, so no new link can be created.
CouldNotChangeViewReference | 12 | The link previously had an invalid view reference and either no new view was provided or the input view was not usable for linking CAD files.
UsedExisting | 13 | Revit already has a link with the input location, so the same link is been reused.
Remarks
For all values except LinkLoadResultType.LinkLoaded, the linked model is not loaded and no new link is created (if Revit was trying to create a link).
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LinkNode Class

An output node that represents a linked Revit document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRenderNode
Autodesk.Revit.DBGroupNode
Autodesk.Revit.DBLinkNode

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LinkNode : GroupNode
Public Class LinkNode
    Inherits GroupNode
public ref class LinkNode : public GroupNode
type LinkNode =
    class
        inherit GroupNode
    end

The LinkNode type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode)
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode)
Public property | SymbolId | Identifies the Id of the symbol associated with the node.
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from RenderNode)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetDocument | Returns the document associated with the link.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetTransform | A transformation matrix associated with the node. (Inherited from GroupNode)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
See also: OnLinkBegin(LinkNode).
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LinkNode Properties

The LinkNode type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode)
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode)
Public property | SymbolId | Identifies the Id of the symbol associated with the node.
Top
See Also

Reference

LinkNode Class


LinkNode.SymbolId Property

LinkNodeSymbolId Property

Identifies the Id of the symbol associated with the node.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId SymbolId { get; }
Public ReadOnly Property SymbolId As ElementId
    Get
public:
property ElementId^ SymbolId {
    ElementId^ get ();
}
member SymbolId : ElementId with get

Property Value

ElementId
See Also

Reference

LinkNode Class


LinkNode Methods

The LinkNode type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from RenderNode)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetDocument | Returns the document associated with the link.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetTransform | A transformation matrix associated with the node. (Inherited from GroupNode)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LinkNode Class


LinkNode.GetDocument Method

LinkNodeGetDocument Method

Returns the document associated with the link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Document GetDocument()
Public Function GetDocument As Document
public:
Document^ GetDocument()
member GetDocument : unit -> Document

Return Value

Document
Instance of a Document
Remarks
The document is in read-only state. Transactions are not allowed in it.
See Also

Reference

LinkNode Class


LinkOperations Class

This class is used to extend the IExternalResourceServer interface with methods to support operations for elements that are LinkTypes.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBLinkOperations
Autodesk.Revit.DBCADLinkOperations
Autodesk.Revit.DBRevitLinkOperations

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LinkOperations : IDisposable
Public Class LinkOperations
    Implements IDisposable
public ref class LinkOperations : IDisposable
type LinkOperations =
    class
        interface IDisposable
    end

The LinkOperations type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the LinkOperations
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetOnLocalLinkSharedCoordinatesSavedCallback | Sets the callback that will be called when the Revit user saves new shared coordinate settings to a linked document obtained from an IExternalResourceServer.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LinkOperations Properties

The LinkOperations type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

LinkOperations Class


LinkOperations.IsValidObject Property

LinkOperationsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

LinkOperations Class


LinkOperations Methods

The LinkOperations type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetOnLocalLinkSharedCoordinatesSavedCallback | Sets the callback that will be called when the Revit user saves new shared coordinate settings to a linked document obtained from an IExternalResourceServer.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LinkOperations Class


LinkOperations.Dispose Method

LinkOperationsDispose Method

Releases all resources used by the LinkOperations

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

LinkOperations Class


LinkOperations.SetOnLocalLinkSharedCoordinatesSavedCallback Method

LinkOperationsSetOnLocalLinkSharedCoordinatesSavedCallback Method

Sets the callback that will be called when the Revit user saves new shared coordinate settings to a linked document obtained from an IExternalResourceServer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetOnLocalLinkSharedCoordinatesSavedCallback(
    IOnLocalLinkSharedCoordinatesSavedCallback onLocalLinkSharedCoordinatesSaved
)
Public Sub SetOnLocalLinkSharedCoordinatesSavedCallback (
    onLocalLinkSharedCoordinatesSaved As IOnLocalLinkSharedCoordinatesSavedCallback
)
public:
void SetOnLocalLinkSharedCoordinatesSavedCallback(
    IOnLocalLinkSharedCoordinatesSavedCallback^ onLocalLinkSharedCoordinatesSaved
)
member SetOnLocalLinkSharedCoordinatesSavedCallback :
        onLocalLinkSharedCoordinatesSaved : IOnLocalLinkSharedCoordinatesSavedCallback -> unit

Parameters

onLocalLinkSharedCoordinatesSaved IOnLocalLinkSharedCoordinatesSavedCallback
An IOnLocalLinkSharedCoordinatesSavedCallback object that can respond when the user saves new shared coordinates to a Revit link document obtained from IExternalResourceServer.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

LinkOperations Class


LinkOriginFileType Enumeration

Enum determining whether the source type of a temporary rvt link is an ifc.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum LinkOriginFileType
Public Enumeration LinkOriginFileType
public enum class LinkOriginFileType
type LinkOriginFileType
Members
Member name | Value | Description
RVT | 0 | Default RVT, curently only support ifc.
IFC | 1 | The original link file is an ifc file.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LinkVisibility Enumeration

Link visibility types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum LinkVisibility
Public Enumeration LinkVisibility
public enum class LinkVisibility
type LinkVisibility
Members
Member name | Value | Description
ByHostView | 0 |
ByLinkView | 1 |
Custom | 2 |
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ListType Enumeration

An enumerated type indicating the style of list item for paragraphs that are part of ordered or unordered lists in FormattedText.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ListType
Public Enumeration ListType
public enum class ListType
type ListType
Members
Member name | Value | Description
Mixed | 0 | This value may be returned by FormattedText.GetListType() when there are multiple list types in the selected range.
None | 1 | The paragraph is not a part of a list.
Bullet | 2 | The paragraph is a part of a bulleted list.
ArabicNumbers | 3 | The paragraph is a part of an ordered list with Arabic number headings.
LowerCaseLetters | 4 | The paragraph is a part of an ordered list with lower-case letter headings.
UpperCaseLetters | 5 | The paragraph is a part of an ordered list with upper-case letter headings.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LoadedFamilyIntegrityCheck Class

Functions for checking the integrity of loaded families.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBLoadedFamilyIntegrityCheck

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class LoadedFamilyIntegrityCheck
Public NotInheritable Class LoadedFamilyIntegrityCheck
public ref class LoadedFamilyIntegrityCheck abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type LoadedFamilyIntegrityCheck = class end

The LoadedFamilyIntegrityCheck type exposes the following members.

Methods
Name | Description
CheckAllFamilies | Check that all families loaded in the host document have their content documents.
CheckAllFamiliesSlow | Check integrity of content documents of all families loaded in the host document.
CheckFamily | Check that the loaded family has its content document.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LoadedFamilyIntegrityCheck Methods

The LoadedFamilyIntegrityCheck type exposes the following members.

Methods
Name | Description
CheckAllFamilies | Check that all families loaded in the host document have their content documents.
CheckAllFamiliesSlow | Check integrity of content documents of all families loaded in the host document.
CheckFamily | Check that the loaded family has its content document.
Top
See Also

Reference

LoadedFamilyIntegrityCheck Class


LoadedFamilyIntegrityCheck.CheckAllFamilies Method

LoadedFamilyIntegrityCheckCheckAllFamilies Method

Check that all families loaded in the host document have their content documents.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CheckAllFamilies(
    Document ADoc,
    ISet<ElementId> corruptFamilyIds
)
Public Shared Function CheckAllFamilies (
    ADoc As Document,
    corruptFamilyIds As ISet(Of ElementId)
) As Boolean
public:
static bool CheckAllFamilies(
    Document^ ADoc,
    ISet<ElementId^>^ corruptFamilyIds
)
static member CheckAllFamilies :
        ADoc : Document *
        corruptFamilyIds : ISet<ElementId> -> bool

Parameters

ADoc Document
The host document.
corruptFamilyIds ISet ElementId
Return ids of families that need to be reloaded because their content documents are missing.

Return Value

Boolean
Returns true if all loaded families have their content documents.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

LoadedFamilyIntegrityCheck Class


LoadedFamilyIntegrityCheck.CheckAllFamiliesSlow Method

LoadedFamilyIntegrityCheckCheckAllFamiliesSlow Method

Check integrity of content documents of all families loaded in the host document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CheckAllFamiliesSlow(
    Document ADoc,
    ISet<ElementId> corruptFamilyIds
)
Public Shared Function CheckAllFamiliesSlow (
    ADoc As Document,
    corruptFamilyIds As ISet(Of ElementId)
) As Boolean
public:
static bool CheckAllFamiliesSlow(
    Document^ ADoc,
    ISet<ElementId^>^ corruptFamilyIds
)
static member CheckAllFamiliesSlow :
        ADoc : Document *
        corruptFamilyIds : ISet<ElementId> -> bool

Parameters

ADoc Document
The host document.
corruptFamilyIds ISet ElementId
Return ids of families that need to be reloaded because their content documents are missing or corrupt.

Return Value

Boolean
Returns true if all content documents are usable.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
This check is slow as it invloves traversal of all content documents. It also dumps data about bad families into the journal, as well as the whole content tree into the dump file.
See Also

Reference

LoadedFamilyIntegrityCheck Class


LoadedFamilyIntegrityCheck.CheckFamily Method

LoadedFamilyIntegrityCheckCheckFamily Method

Check that the loaded family has its content document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CheckFamily(
    Document ADoc,
    ElementId familyId
)
Public Shared Function CheckFamily (
    ADoc As Document,
    familyId As ElementId
) As Boolean
public:
static bool CheckFamily(
    Document^ ADoc,
    ElementId^ familyId
)
static member CheckFamily :
        ADoc : Document *
        familyId : ElementId -> bool

Parameters

ADoc Document
The host document.
familyId ElementId
The id of the family to check.

Return Value

Boolean
Returns true if the family has its content document.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

LoadedFamilyIntegrityCheck Class


LoadOperationType Enumeration

An enum indicating whether a resource load operation was triggered by a user action or an automatic process.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum LoadOperationType
Public Enumeration LoadOperationType
public enum class LoadOperationType
type LoadOperationType
Members
Member name | Value | Description
Automatic | 0 | The load operation was triggered automatically by another operation.
Explicit | 1 | The load operation was triggered by an explicit reload action on the part of the user.
Remarks

This enum is provided so that an external resource server can decide how much feedback it wishes to provide to the user.

For example, Revit automatically loads all resources on file open. This may cause many external resources to load at once. The server may wish to provide truncated error messages.

Reload() and LoadFrom() operations from the API are considered to be LoadOperationType.Explicit.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Location Class

Provides location functionality for all elements.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBLocation
Autodesk.Revit.DBLocationCurve
Autodesk.Revit.DBLocationPoint

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Location : APIObject
Public Class Location
    Inherits APIObject
public ref class Location : public APIObject
type Location =
    class
        inherit APIObject
    end

The Location type exposes the following members.

Properties
Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | Move | Move the element within the project by a specified vector.
 | Rotate | Rotate the element within the project by a specified angle around a given axis.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The location object provides the ability to translate and rotate elements. More detailed location information and control can be found by using the derivatives of this object, such as LocationPoint or LocationCurve.
Example
C#
VB
C++
F#
Copy
void ShowLocationUsage(Autodesk.Revit.ApplicationServices.Application application, Wall wall)
{
    // Get the location instance.
    Autodesk.Revit.DB.Location position = wall.Location;

    // Check whether the wall is pinned.
    if (wall.Pinned)
    {
        throw new Exception("The wall has been pinned.");
    }

    // Move the wall location, it provides same function as Move method of Document class.
    XYZ direction = new XYZ(10, 0, 0);
    bool result = position.Move(direction);
    if (!result)
    {
        throw new Exception("Move wall location failed.");
    }

    // Rotate the wall location, it provides same function as Rotate method of Document class.
    XYZ axisStart = new XYZ(0, 0, 0);
    XYZ axisEnd = new XYZ(0, 0, 1);
    Line axis = Line.CreateUnbound(axisStart, axisEnd);
    result = position.Rotate(axis, 30);
    if (!result)
    {
        throw new Exception("Rotate wall location failed.");
    }
}
Private Sub ShowLocationUsage(application As Autodesk.Revit.ApplicationServices.Application, wall As Wall)
    ' Get the location instance.
    Dim position As Autodesk.Revit.DB.Location = wall.Location

    ' Check whether the wall is pinned.
    If wall.Pinned Then
        Throw New Exception("The wall has been pinned.")
    End If

    ' Move the wall location, it provides same function as Move method of Document class.
    Dim direction As New XYZ(10, 0, 0)
    Dim result As Boolean = position.Move(direction)
    If Not result Then
        Throw New Exception("Move wall location failed.")
    End If

    ' Rotate the wall location, it provides same function as Rotate method of Document class.
    Dim axisStart As New XYZ(0, 0, 0)
    Dim axisEnd As New XYZ(0, 0, 1)
    Dim axis As Line = Line.CreateUnbound(axisStart, axisEnd)
    result = position.Rotate(axis, 30)
    If Not result Then
        Throw New Exception("Rotate wall location failed.")
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Location Properties

The Location type exposes the following members.

Properties
Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

Location Class


Location Methods

The Location type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | Move | Move the element within the project by a specified vector.
 | Rotate | Rotate the element within the project by a specified angle around a given axis.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Location Class


Location.Move Method

LocationMove Method

Move the element within the project by a specified vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Move(
    XYZ translation
)
Public Function Move (
    translation As XYZ
) As Boolean
public:
bool Move(
    XYZ^ translation
)
member Move :
        translation : XYZ -> bool

Parameters

translation XYZ
The vector by which the element is to be moved.

Return Value

Boolean
If the element is moved successfully then the method return True, otherwise False.
Remarks
The move method is used to move an element within the project. Other elements may also be moved when this element is moved, for example: if the element is wall and it contains windows, the windows will also be moved.
Example
C#
VB
C++
F#
Copy
bool MoveUsingLocationCurve(Autodesk.Revit.ApplicationServices.Application application, Wall wall)
{
    LocationCurve wallLine = wall.Location as LocationCurve;
    XYZ translationVec = new XYZ(10, 20, 0);
    return (wallLine.Move(translationVec));
}
Private Function MoveUsingLocationCurve(application As Autodesk.Revit.ApplicationServices.Application, wall As Wall) As Boolean
    Dim wallLine As LocationCurve = TryCast(wall.Location, LocationCurve)
    Dim translationVec As New XYZ(10, 20, 0)
    Return (wallLine.Move(translationVec))
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Location Class


Location.Rotate Method

LocationRotate Method

Rotate the element within the project by a specified angle around a given axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Rotate(
    Line axis,
    double angle
)
Public Function Rotate (
    axis As Line,
    angle As Double
) As Boolean
public:
bool Rotate(
    Line^ axis,
    double angle
)
member Rotate :
        axis : Line *
        angle : float -> bool

Parameters

axis Line
An unbounded line that represents the axis of rotation.
angle Double
The angle, in radians, by which the element is to be rotated around the specified axis.

Return Value

Boolean
If the element is rotate successfully then the method returns True, otherwise False.
Remarks
The rotate method is used to rotate an element within the project. Other elements may also be rotated when this element is rotated because they are dependent upon the element being rotated. An unbounded line for the axis can be created by using the Application.Create object and its methods.
Example
C#
VB
C++
F#
Copy
bool LocationRotate(Autodesk.Revit.ApplicationServices.Application application, Autodesk.Revit.DB.Element element)
{
    bool rotated = false;
    // Rotate the element via its location curve.
    LocationCurve curve = element.Location as LocationCurve;
    if (null != curve)
    {
        Curve line = curve.Curve;
        XYZ aa = line.GetEndPoint(0);
        XYZ cc = new XYZ(aa.X, aa.Y, aa.Z + 10);
        Line axis = Line.CreateBound(aa, cc);
        rotated = curve.Rotate(axis, Math.PI / 2.0);
    }

    return rotated;
}
Private Function LocationRotate(application As Autodesk.Revit.ApplicationServices.Application, element As Autodesk.Revit.DB.Element) As Boolean
    Dim rotated As Boolean = False
    ' Rotate the element via its location curve.
    Dim curve As LocationCurve = TryCast(element.Location, LocationCurve)
    If curve IsNot Nothing Then
        Dim line__1 As Curve = curve.Curve
        Dim aa As XYZ = line__1.GetEndPoint(0)
        Dim cc As New XYZ(aa.X, aa.Y, aa.Z + 10)
        Dim axis As Line = Line.CreateBound(aa, cc)
        rotated = curve.Rotate(axis, Math.PI / 2.0)
    End If

    Return rotated
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Location Class


LocationCurve Class

Provides location functionality for all elements that are based upon a curve.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBLocation
Autodesk.Revit.DBLocationCurve

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LocationCurve : Location
Public Class LocationCurve
    Inherits Location
public ref class LocationCurve : public Location
type LocationCurve =
    class
        inherit Location
    end

The LocationCurve type exposes the following members.

Properties
 | Name | Description
 | Curve | Provides the ability to get and set the curve of a curve based element.
Public property | ElementsAtJoin | Get all elements joining to the end of this element's location curve or change the order of elements participation in the end join with this location curve's end.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | JoinType | Get/change the type of the join at the specified end.
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | Move | Move the element within the project by a specified vector. (Inherited from Location)
 | Rotate | Rotate the element within the project by a specified angle around a given axis. (Inherited from Location)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The location line objects adds additional functionality to its base location object class. This includes reading and writing the curve contained within the element.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LocationCurve Properties

The LocationCurve type exposes the following members.

Properties
 | Name | Description
 | Curve | Provides the ability to get and set the curve of a curve based element.
Public property | ElementsAtJoin | Get all elements joining to the end of this element's location curve or change the order of elements participation in the end join with this location curve's end.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | JoinType | Get/change the type of the join at the specified end.
Top
See Also

Reference

LocationCurve Class


LocationCurve.Curve Property

LocationCurveCurve Property

Provides the ability to get and set the curve of a curve based element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Curve Curve { get; set; }
Public Property Curve As Curve
    Get
    Set
public:
property Curve^ Curve {
    Curve^ get ();
    void set (Curve^ value);
}
member Curve : Curve with get, set

Property Value

Curve
Remarks
This property can be used to set the location of curve based element to any desired position. Many elements are curve based. Some examples are walls, beams and braces.
Example
C#
VB
C++
F#
Copy
void MoveUsingCurveParam(Autodesk.Revit.ApplicationServices.Application application, Wall wall)
{
    LocationCurve wallLine = wall.Location as LocationCurve;
    XYZ p1 = XYZ.Zero;
    XYZ p2 = new XYZ(10, 20, 0);
    Line newWallLine = Line.CreateBound(p1, p2);

    // Change the wall line to a new line.
    wallLine.Curve = newWallLine;
}
Private Sub MoveUsingCurveParam(application As Autodesk.Revit.ApplicationServices.Application, wall As Wall)
    Dim wallLine As LocationCurve = TryCast(wall.Location, LocationCurve)
    Dim p1 As XYZ = XYZ.Zero
    Dim p2 As New XYZ(10, 20, 0)
    Dim newWallLine As Line = Line.CreateBound(p1, p2)

    ' Change the wall line to a new line.
    wallLine.Curve = newWallLine
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

LocationCurve Class


LocationCurve.ElementsAtJoin Property

LocationCurveElementsAtJoin Property

Get all elements joining to the end of this element's location curve or change the order of elements participation in the end join with this location curve's end.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementArray this[
    int end
] { get; set; }
Public Property ElementsAtJoin (
    end As Integer
) As ElementArray
    Get
    Set
public:
property ElementArray^ ElementsAtJoin[int end] {
    ElementArray^ get (int end);
    void set (int end, ElementArray^ value);
}
member ElementsAtJoin : ElementArray with get, set

Parameters

end Int32
The end at which the join occurs.

Property Value

ElementArray
Remarks
The list of elements is expected to be a permutation of the elements already in the join at the end. It is expected that no new elements will be introduced, and existing ones will not be removed.
See Also

Reference

LocationCurve Class


LocationCurve.JoinType Property

LocationCurveJoinType Property

Get/change the type of the join at the specified end.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public JoinType this[
    int end
] { get; set; }
Public Property JoinType (
    end As Integer
) As JoinType
    Get
    Set
public:
property JoinType JoinType[int end] {
    JoinType get (int end);
    void set (int end, JoinType value);
}
member JoinType : JoinType with get, set

Parameters

end Int32
The end of the location curve driver under question.

Property Value

JoinType
Exceptions
Exception | Condition
InvalidOperationException | The element is neither a wall nor a concrete beam when it tries to get the property. The element is not a wall when it tries to set the property.
InvalidOperationException | A failure occurred while attempting to set the new type.
Remarks
This property allows to get join type of wall and concrete beam and to set wall's join type. The new join type is expected to be different from the current one for this end.
See Also

Reference

LocationCurve Class


LocationCurve Methods

The LocationCurve type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | Move | Move the element within the project by a specified vector. (Inherited from Location)
 | Rotate | Rotate the element within the project by a specified angle around a given axis. (Inherited from Location)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LocationCurve Class


LocationPoint Class

Provides location functionality for all elements that have a single insertion point.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBLocation
Autodesk.Revit.DBLocationPoint

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LocationPoint : Location
Public Class LocationPoint
    Inherits Location
public ref class LocationPoint : public Location
type LocationPoint =
    class
        inherit Location
    end

The LocationPoint type exposes the following members.

Properties
 | Name | Description
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
 | Point | The physical location of the element.
Public property | Rotation | The angle of rotation around the insertion point, in radians.
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | Move | Move the element within the project by a specified vector. (Inherited from Location)
 | Rotate | Rotate the element within the project by a specified angle around a given axis. (Inherited from Location)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The location point objects adds additional functionality to its base location object class. This includes setting the elements location to a specific point and retrieving its rotation around its insertion point. Inplace families do not have a single insertion point and therefore do not have meaningful LocationPoint data.
Example
C#
VB
C++
F#
Copy
void LocationInformation(LocationPoint position)
{
    String prompt = "The selected column location information:";
    prompt += "\nPoint:  (" + position.Point.X + ", "
            + position.Point.Y + ", " + position.Point.Z + ")";
    prompt += "\nRotation: " + position.Rotation;

    TaskDialog.Show("Revit",prompt);
}

bool LocationRotate(Autodesk.Revit.ApplicationServices.Application application, Autodesk.Revit.DB.Element element)
{
    bool rotated = false;
    LocationPoint location = element.Location as LocationPoint;

    if (null != location)
    {
        XYZ aa = location.Point;
        XYZ cc = new XYZ(aa.X, aa.Y, aa.Z + 10);
        Line axis = Line.CreateBound(aa,cc);
        rotated = location.Rotate(axis, Math.PI / 2.0);
    }

    return rotated;
}
Private Sub LocationInformation(position As LocationPoint)
    Dim prompt As [String] = "The selected column location information:"
    prompt += vbLf & "Point:  (" & Convert.ToString(position.Point.X) & ", " & Convert.ToString(position.Point.Y) & ", " & Convert.ToString(position.Point.Z) & ")"
    prompt += vbLf & "Rotation: " & Convert.ToString(position.Rotation)

    TaskDialog.Show("Revit", prompt)
End Sub

Private Function LocationRotate(application As Autodesk.Revit.ApplicationServices.Application, element As Autodesk.Revit.DB.Element) As Boolean
    Dim rotated As Boolean = False
    Dim location As LocationPoint = TryCast(element.Location, LocationPoint)

    If location IsNot Nothing Then
        Dim aa As XYZ = location.Point
        Dim cc As New XYZ(aa.X, aa.Y, aa.Z + 10)
        Dim axis As Line = Line.CreateBound(aa, cc)
        rotated = location.Rotate(axis, Math.PI / 2.0)
    End If

    Return rotated
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LocationPoint Properties

The LocationPoint type exposes the following members.

Properties
 | Name | Description
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
 | Point | The physical location of the element.
Public property | Rotation | The angle of rotation around the insertion point, in radians.
Top
See Also

Reference

LocationPoint Class


LocationPoint.Point Property

LocationPointPoint Property

The physical location of the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Point { get; set; }
Public Property Point As XYZ
    Get
    Set
public:
property XYZ^ Point {
    XYZ^ get ();
    void set (XYZ^ value);
}
member Point : XYZ with get, set

Property Value

XYZ
Remarks
Setting this property is not supported for some elements supporting LocationPoints, such as SpotDimensions.
Example
C#
VB
C++
F#
Copy
void LocationMove(FamilyInstance column)
{
    LocationPoint columnPoint = column.Location as LocationPoint;
    if (null != columnPoint)
    {
        XYZ newLocation = new XYZ(10, 20, 0);
        // Move the column to the new location
        columnPoint.Point = newLocation;
    }
}
Private Sub LocationMove(column As FamilyInstance)
    Dim columnPoint As LocationPoint = TryCast(column.Location, LocationPoint)
    If columnPoint IsNot Nothing Then
        Dim newLocation As New XYZ(10, 20, 0)
        ' Move the column to the new location
        columnPoint.Point = newLocation
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

LocationPoint Class


LocationPoint.Rotation Property

LocationPointRotation Property

The angle of rotation around the insertion point, in radians.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Rotation { get; }
Public ReadOnly Property Rotation As Double
    Get
public:
property double Rotation {
    double get ();
}
member Rotation : float with get

Property Value

Double
Remarks
For view-based elements, the rotation angle is in the plane of the associated view. For model elements, the rotation angle is measured relative to the default coordinate system. This property is not supported for some elements supporting LocationPoints, such as AssemblyInstances, Groups, ModelText, Room, and SpotDimensions.
See Also

Reference

LocationPoint Class


LocationPoint Methods

The LocationPoint type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | Move | Move the element within the project by a specified vector. (Inherited from Location)
 | Rotate | Rotate the element within the project by a specified angle around a given axis. (Inherited from Location)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LocationPoint Class


LogicalAndFilter Class

A filter that contains a set of filters. The filter passes when all filters in the set pass.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementLogicalFilter
Autodesk.Revit.DBLogicalAndFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LogicalAndFilter : ElementLogicalFilter
Public Class LogicalAndFilter
    Inherits ElementLogicalFilter
public ref class LogicalAndFilter : public ElementLogicalFilter
type LogicalAndFilter =
    class
        inherit ElementLogicalFilter
    end

The LogicalAndFilter type exposes the following members.

Constructors
 | Name | Description
Public method | LogicalAndFilter(IListElementFilter) | Constructs a new instance of the logical filter with any number of input filters.
Public method | LogicalAndFilter(ElementFilter, ElementFilter) | Constructs a new instance of the logical filter with two input filters.
Top
Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetFilters | Returns an array of copies of the filters that are logically combined by this ElementLogicalFilter. (Inherited from ElementLogicalFilter)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | SetFilters | Replaces current filters in the logical filter with any number of input filters. (Inherited from ElementLogicalFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The component filters may be reordered by Revit to cause the quickest acting filters to be evaluated first.
Example
C#
VB
C++
F#
Copy
// Find all door instances in the project by finding all elements that both belong to the door
// category and are family instances.
ElementClassFilter familyInstanceFilter = new ElementClassFilter(typeof(FamilyInstance));

// Create a category filter for Doors
ElementCategoryFilter doorsCategoryfilter = new ElementCategoryFilter(BuiltInCategory.OST_Doors);

// Create a logic And filter for all Door FamilyInstances
LogicalAndFilter doorInstancesFilter = new LogicalAndFilter(familyInstanceFilter, doorsCategoryfilter);

// Apply the filter to the elements in the active document
FilteredElementCollector collector = new FilteredElementCollector(document);
IList<Element> doors = collector.WherePasses(doorInstancesFilter).ToElements();
' Find all door instances in the project by finding all elements that both belong to the door
' category and are family instances.
Dim familyInstanceFilter As New ElementClassFilter(GetType(FamilyInstance))

' Create a category filter for Doors
Dim doorsCategoryfilter As New ElementCategoryFilter(BuiltInCategory.OST_Doors)

' Create a logic And filter for all Door FamilyInstances
Dim doorInstancesFilter As New LogicalAndFilter(familyInstanceFilter, doorsCategoryfilter)

' Apply the filter to the elements in the active document
Dim collector As New FilteredElementCollector(document)
Dim doors As IList(Of Element) = collector.WherePasses(doorInstancesFilter).ToElements()

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LogicalAndFilter Constructor

Overload List
 | Name | Description
Public method | LogicalAndFilter(IListElementFilter) | Constructs a new instance of the logical filter with any number of input filters.
Public method | LogicalAndFilter(ElementFilter, ElementFilter) | Constructs a new instance of the logical filter with two input filters.
Top
See Also

Reference

LogicalAndFilter Class


LogicalAndFilter(IList<ElementFilter>) Constructor

LogicalAndFilter(IListElementFilter) Constructor

Constructs a new instance of the logical filter with any number of input filters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LogicalAndFilter(
    IList<ElementFilter> filters
)
Public Sub New (
    filters As IList(Of ElementFilter)
)
public:
LogicalAndFilter(
    IList<ElementFilter^>^ filters
)
new :
        filters : IList<ElementFilter> -> LogicalAndFilter

Parameters

filters IList ElementFilter
A collection of input filters.
Exceptions
Exception | Condition
ArgumentException | The filter collection is empty, or contains invalid inputs.
ArgumentNullException | A non-optional argument was null
Remarks
The input filters will be copied.
See Also

Reference

LogicalAndFilter Class
LogicalAndFilter Overload


LogicalAndFilter(ElementFilter, ElementFilter) Constructor

Constructs a new instance of the logical filter with two input filters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LogicalAndFilter(
    ElementFilter filter1,
    ElementFilter filter2
)
Public Sub New (
    filter1 As ElementFilter,
    filter2 As ElementFilter
)
public:
LogicalAndFilter(
    ElementFilter^ filter1,
    ElementFilter^ filter2
)
new :
        filter1 : ElementFilter *
        filter2 : ElementFilter -> LogicalAndFilter

Parameters

filter1 ElementFilter
The first filter.
filter2 ElementFilter
The second filter.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
The input filters will be copied.
See Also

Reference

LogicalAndFilter Class
LogicalAndFilter Overload


LogicalAndFilter Properties

The LogicalAndFilter type exposes the following members.

Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
See Also

Reference

LogicalAndFilter Class


LogicalAndFilter Methods

The LogicalAndFilter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetFilters | Returns an array of copies of the filters that are logically combined by this ElementLogicalFilter. (Inherited from ElementLogicalFilter)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | SetFilters | Replaces current filters in the logical filter with any number of input filters. (Inherited from ElementLogicalFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LogicalAndFilter Class


LogicalOrFilter Class

A filter that contains a set of filters. The filter passes when any filter in the set passes.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementLogicalFilter
Autodesk.Revit.DBLogicalOrFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LogicalOrFilter : ElementLogicalFilter
Public Class LogicalOrFilter
    Inherits ElementLogicalFilter
public ref class LogicalOrFilter : public ElementLogicalFilter
type LogicalOrFilter =
    class
        inherit ElementLogicalFilter
    end

The LogicalOrFilter type exposes the following members.

Constructors
 | Name | Description
Public method | LogicalOrFilter(IListElementFilter) | Constructs a new instance of the logical filter with any number of input filters.
Public method | LogicalOrFilter(ElementFilter, ElementFilter) | Constructs a new instance of the logical filter with two input filters.
Top
Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetFilters | Returns an array of copies of the filters that are logically combined by this ElementLogicalFilter. (Inherited from ElementLogicalFilter)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | SetFilters | Replaces current filters in the logical filter with any number of input filters. (Inherited from ElementLogicalFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The component filters may be reordered by Revit to cause the quickest acting filters to be evaluated first.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


LogicalOrFilter Constructor

Overload List
 | Name | Description
Public method | LogicalOrFilter(IListElementFilter) | Constructs a new instance of the logical filter with any number of input filters.
Public method | LogicalOrFilter(ElementFilter, ElementFilter) | Constructs a new instance of the logical filter with two input filters.
Top
See Also

Reference

LogicalOrFilter Class


LogicalOrFilter(IList<ElementFilter>) Constructor

LogicalOrFilter(IListElementFilter) Constructor

Constructs a new instance of the logical filter with any number of input filters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LogicalOrFilter(
    IList<ElementFilter> filters
)
Public Sub New (
    filters As IList(Of ElementFilter)
)
public:
LogicalOrFilter(
    IList<ElementFilter^>^ filters
)
new :
        filters : IList<ElementFilter> -> LogicalOrFilter

Parameters

filters IList ElementFilter
A collection of input filters.
Exceptions
Exception | Condition
ArgumentException | The filter collection is empty, or contains invalid inputs.
ArgumentNullException | A non-optional argument was null
See Also

Reference

LogicalOrFilter Class
LogicalOrFilter Overload


LogicalOrFilter(ElementFilter, ElementFilter) Constructor

Constructs a new instance of the logical filter with two input filters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LogicalOrFilter(
    ElementFilter filter1,
    ElementFilter filter2
)
Public Sub New (
    filter1 As ElementFilter,
    filter2 As ElementFilter
)
public:
LogicalOrFilter(
    ElementFilter^ filter1,
    ElementFilter^ filter2
)
new :
        filter1 : ElementFilter *
        filter2 : ElementFilter -> LogicalOrFilter

Parameters

filter1 ElementFilter
The first filter.
filter2 ElementFilter
The second filter.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

LogicalOrFilter Class
LogicalOrFilter Overload


LogicalOrFilter Properties

The LogicalOrFilter type exposes the following members.

Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
See Also

Reference

LogicalOrFilter Class


LogicalOrFilter Methods

The LogicalOrFilter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetFilters | Returns an array of copies of the filters that are logically combined by this ElementLogicalFilter. (Inherited from ElementLogicalFilter)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | SetFilters | Replaces current filters in the logical filter with any number of input filters. (Inherited from ElementLogicalFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

LogicalOrFilter Class


MarginType Enumeration

An enumerated type listing all Margin types of Print Setting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum MarginType
Public Enumeration MarginType
public enum class MarginType
type MarginType
Members
Member name | Value | Description
NoMargin | 0 | The type of Margin is No Margin.
PrinterLimit | 1 | The type of Margin is Printer Limit.
UserDefined | 2 | The type of Margin is User Defined.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


MassDisplayTemporaryOverrideType Enumeration

This enum identifies the mass display overrides.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum MassDisplayTemporaryOverrideType
Public Enumeration MassDisplayTemporaryOverrideType
public enum class MassDisplayTemporaryOverrideType
type MassDisplayTemporaryOverrideType
Members
Member name | Value | Description
ShowMassByViewSettings | 0 | Mass will be displayed in each view based on the visibility settings of that view.
ShowMassFormAndFloors | 1 | Mass form and mass floor subcategories will be displayed in all views.
ShowMassSurfaceTypes | 2 | Mass energy analysis surface subcategories (and Mass Floors) will be displayed.
ShowMassZonesAndShades | 3 | Mass zone and mass shade subcategories will be displayed.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


MassInstanceUtils Class

A static class that contains methods for processing curves driven by points.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBMassInstanceUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MassInstanceUtils : IDisposable
Public Class MassInstanceUtils
    Implements IDisposable
public ref class MassInstanceUtils : IDisposable
type MassInstanceUtils =
    class
        interface IDisposable
    end

The MassInstanceUtils type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
 | AddMassLevelDataToMassInstance | Create a MassLevelData (Mass Floor) to associate a Level with a mass instance.
Public method | Dispose | Releases all resources used by the MassInstanceUtils
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | GetGrossFloorArea | Get the total occupiable floor area represented by a mass instance.
 | GetGrossSurfaceArea | Get the total exterior building surface area represented by a mass instance.
 | GetGrossVolume | Get the total building volume represented by a mass instance.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
 | GetJoinedElementIds | Get the ElementIds of Elements that are joined to a mass instance.
 | GetMassLevelDataIds | Get the ElementIds of the MassLevelDatas (Mass Floors) associated with a mass instance.
 | GetMassLevelIds | Get the ElementIds of the Levels associated with a mass instance.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | RemoveMassLevelDataFromMassInstance | Delete the MassLevelData (Mass Floor) that associates a Level with a mass instance.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


MassInstanceUtils Properties

The MassInstanceUtils type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

MassInstanceUtils Class


MassInstanceUtils.IsValidObject Property

MassInstanceUtilsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

MassInstanceUtils Class


MassInstanceUtils Methods

The MassInstanceUtils type exposes the following members.

Methods
 | Name | Description
 | AddMassLevelDataToMassInstance | Create a MassLevelData (Mass Floor) to associate a Level with a mass instance.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | GetGrossFloorArea | Get the total occupiable floor area represented by a mass instance.
 | GetGrossSurfaceArea | Get the total exterior building surface area represented by a mass instance.
 | GetGrossVolume | Get the total building volume represented by a mass instance.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
 | GetJoinedElementIds | Get the ElementIds of Elements that are joined to a mass instance.
 | GetMassLevelDataIds | Get the ElementIds of the MassLevelDatas (Mass Floors) associated with a mass instance.
 | GetMassLevelIds | Get the ElementIds of the Levels associated with a mass instance.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | RemoveMassLevelDataFromMassInstance | Delete the MassLevelData (Mass Floor) that associates a Level with a mass instance.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MassInstanceUtils Class


MassInstanceUtils.AddMassLevelDataToMassInstance Method

MassInstanceUtilsAddMassLevelDataToMassInstance Method

Create a MassLevelData (Mass Floor) to associate a Level with a mass instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ElementId AddMassLevelDataToMassInstance(
    Document document,
    ElementId massInstanceId,
    ElementId levelId
)
Public Shared Function AddMassLevelDataToMassInstance (
    document As Document,
    massInstanceId As ElementId,
    levelId As ElementId
) As ElementId
public:
static ElementId^ AddMassLevelDataToMassInstance(
    Document^ document,
    ElementId^ massInstanceId,
    ElementId^ levelId
)
static member AddMassLevelDataToMassInstance :
        document : Document *
        massInstanceId : ElementId *
        levelId : ElementId -> ElementId

Parameters

document Document
The Document.
massInstanceId ElementId
The ElementId of the mass instance.
levelId ElementId
The ElementId of the Level to associate with the mass instance.

Return Value

ElementId
The ElementId of the MassLevelData that was created, or the existing ElementId if it was already in added.
Exceptions
Exception | Condition
ArgumentException | The ElementId massInstanceId is not a mass instance. -or- The ElementId levelId is not a Level.
ArgumentNullException | A non-optional argument was null
See Also

Reference

MassInstanceUtils Class


MassInstanceUtils.Dispose Method

MassInstanceUtilsDispose Method

Releases all resources used by the MassInstanceUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

MassInstanceUtils Class


MassInstanceUtils.GetGrossFloorArea Method

MassInstanceUtilsGetGrossFloorArea Method

Get the total occupiable floor area represented by a mass instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static double GetGrossFloorArea(
    Document document,
    ElementId massInstanceId
)
Public Shared Function GetGrossFloorArea (
    document As Document,
    massInstanceId As ElementId
) As Double
public:
static double GetGrossFloorArea(
    Document^ document,
    ElementId^ massInstanceId
)
static member GetGrossFloorArea :
        document : Document *
        massInstanceId : ElementId -> float

Parameters

document Document
The Document.
massInstanceId ElementId
The ElementId of the mass instance.

Return Value

Double
The gross floor area in square feet.
Exceptions
Exception | Condition
ArgumentException | The ElementId massInstanceId is not a mass instance.
ArgumentNullException | A non-optional argument was null
Remarks
The area is computed from the cross sections that are created by intersecting the associated Levels with the mass instance Geometry.
See Also

Reference

MassInstanceUtils Class


MassInstanceUtils.GetGrossSurfaceArea Method

MassInstanceUtilsGetGrossSurfaceArea Method

Get the total exterior building surface area represented by a mass instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static double GetGrossSurfaceArea(
    Document document,
    ElementId massInstanceId
)
Public Shared Function GetGrossSurfaceArea (
    document As Document,
    massInstanceId As ElementId
) As Double
public:
static double GetGrossSurfaceArea(
    Document^ document,
    ElementId^ massInstanceId
)
static member GetGrossSurfaceArea :
        document : Document *
        massInstanceId : ElementId -> float

Parameters

document Document
The Document.
massInstanceId ElementId
The ElementId of the mass instance.

Return Value

Double
The gross surface area in square feet.
Exceptions
Exception | Condition
ArgumentException | The ElementId massInstanceId is not a mass instance.
ArgumentNullException | A non-optional argument was null
See Also

Reference

MassInstanceUtils Class


MassInstanceUtils.GetGrossVolume Method

MassInstanceUtilsGetGrossVolume Method

Get the total building volume represented by a mass instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static double GetGrossVolume(
    Document document,
    ElementId massInstanceId
)
Public Shared Function GetGrossVolume (
    document As Document,
    massInstanceId As ElementId
) As Double
public:
static double GetGrossVolume(
    Document^ document,
    ElementId^ massInstanceId
)
static member GetGrossVolume :
        document : Document *
        massInstanceId : ElementId -> float

Parameters

document Document
The Document.
massInstanceId ElementId
The ElementId of the mass instance.

Return Value

Double
The gross volume in cubic feet.
Exceptions
Exception | Condition
ArgumentException | The ElementId massInstanceId is not a mass instance.
ArgumentNullException | A non-optional argument was null
See Also

Reference

MassInstanceUtils Class


MassInstanceUtils.GetJoinedElementIds Method

MassInstanceUtilsGetJoinedElementIds Method

Get the ElementIds of Elements that are joined to a mass instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<ElementId> GetJoinedElementIds(
    Document document,
    ElementId massInstanceId
)
Public Shared Function GetJoinedElementIds (
    document As Document,
    massInstanceId As ElementId
) As IList(Of ElementId)
public:
static IList<ElementId^>^ GetJoinedElementIds(
    Document^ document,
    ElementId^ massInstanceId
)
static member GetJoinedElementIds :
        document : Document *
        massInstanceId : ElementId -> IList<ElementId>

Parameters

document Document
The Document.
massInstanceId ElementId
The ElementId of the mass instance.

Return Value

IList ElementId
ElementIds of Elements joined to the mass instance.
Exceptions
Exception | Condition
ArgumentException | The ElementId massInstanceId is not a mass instance.
ArgumentNullException | A non-optional argument was null
See Also

Reference

MassInstanceUtils Class


MassInstanceUtils.GetMassLevelDataIds Method

MassInstanceUtilsGetMassLevelDataIds Method

Get the ElementIds of the MassLevelDatas (Mass Floors) associated with a mass instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<ElementId> GetMassLevelDataIds(
    Document document,
    ElementId massInstanceId
)
Public Shared Function GetMassLevelDataIds (
    document As Document,
    massInstanceId As ElementId
) As IList(Of ElementId)
public:
static IList<ElementId^>^ GetMassLevelDataIds(
    Document^ document,
    ElementId^ massInstanceId
)
static member GetMassLevelDataIds :
        document : Document *
        massInstanceId : ElementId -> IList<ElementId>

Parameters

document Document
The Document.
massInstanceId ElementId
The ElementId of the mass instance.

Return Value

IList ElementId
The ElementIds of the MassLevelDatas.
Exceptions
Exception | Condition
ArgumentException | The ElementId massInstanceId is not a mass instance.
ArgumentNullException | A non-optional argument was null
See Also

Reference

MassInstanceUtils Class


MassInstanceUtils.GetMassLevelIds Method

MassInstanceUtilsGetMassLevelIds Method

Get the ElementIds of the Levels associated with a mass instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<ElementId> GetMassLevelIds(
    Document document,
    ElementId massInstanceId
)
Public Shared Function GetMassLevelIds (
    document As Document,
    massInstanceId As ElementId
) As IList(Of ElementId)
public:
static IList<ElementId^>^ GetMassLevelIds(
    Document^ document,
    ElementId^ massInstanceId
)
static member GetMassLevelIds :
        document : Document *
        massInstanceId : ElementId -> IList<ElementId>

Parameters

document Document
The Document.
massInstanceId ElementId
The ElementId of the mass instance.

Return Value

IList ElementId
The ElementIds of the Levels
Exceptions
Exception | Condition
ArgumentException | The ElementId massInstanceId is not a mass instance.
ArgumentNullException | A non-optional argument was null
See Also

Reference

MassInstanceUtils Class


MassInstanceUtils.RemoveMassLevelDataFromMassInstance Method

MassInstanceUtilsRemoveMassLevelDataFromMassInstance Method

Delete the MassLevelData (Mass Floor) that associates a Level with a mass instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void RemoveMassLevelDataFromMassInstance(
    Document document,
    ElementId massInstanceId,
    ElementId levelId
)
Public Shared Sub RemoveMassLevelDataFromMassInstance (
    document As Document,
    massInstanceId As ElementId,
    levelId As ElementId
)
public:
static void RemoveMassLevelDataFromMassInstance(
    Document^ document,
    ElementId^ massInstanceId,
    ElementId^ levelId
)
static member RemoveMassLevelDataFromMassInstance :
        document : Document *
        massInstanceId : ElementId *
        levelId : ElementId -> unit

Parameters

document Document
The Document.
massInstanceId ElementId
The ElementId of the mass instance.
levelId ElementId
The ElementId of the Level to disassociate from the mass instance.
Exceptions
Exception | Condition
ArgumentException | The ElementId massInstanceId is not a mass instance. -or- The ElementId levelId is not a Level.
ArgumentNullException | A non-optional argument was null
Remarks
Alternatively, you could just delete the MassLevelData.
See Also

Reference

MassInstanceUtils Class


Material Class

Represents a material element within an Autodesk Revit project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBMaterial

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Material : Element
Public Class Material
    Inherits Element
public ref class Material : public Element
type Material =
    class
        inherit Element
    end

The Material type exposes the following members.

Properties
 | Name | Description
 | AppearanceAssetId | The ElementId of the AppearanceAssetElement.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | Color | The color of the material.
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CutBackgroundPatternColor | The color of the material cut background pattern.
Public property | CutBackgroundPatternId | The id of the FillPatternElement used as the background pattern of faces with this material in cut views.
Public property | CutForegroundPatternColor | The color of the material cut foreground pattern.
Public property | CutForegroundPatternId | The id of the FillPatternElement used as the foreground pattern of faces with this material in cut views.
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | MaterialCategory | The name of the material category, e.g. 'Wood'
Public property | MaterialClass | The name of the general material type, e.g. 'Wood.'
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Shininess | The shininess of the material.
Public property | Smoothness | The smoothness of the material.
Public property | StructuralAssetId | The ElementId of the structural PropertySetElement.
Public property | SurfaceBackgroundPatternColor | The color of the material surface background pattern.
Public property | SurfaceBackgroundPatternId | The id of the FillPatternElement used as the background pattern of faces with this material in normal views.
Public property | SurfaceForegroundPatternColor | The color of the material surface foreground pattern.
Public property | SurfaceForegroundPatternId | The id of the FillPatternElement used as the foreground pattern of faces with this material in normal views.
Public property | ThermalAssetId | The ElementId of the thermal PropertySetElement.
Public property | Transparency | The transparency of the material.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | UseRenderAppearanceForShading | True to use the render appearance settings for shaded view appearance; false to use the material's color and transparency value for shaded view appearance.
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | ClearMaterialAspect | Removes an aspect from the material.
 | Create | Creates a new material.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
 | Duplicate | Duplicates the material
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
 | IsMaterialOrValidDefault | Validates whether the specified element id is a material element.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
 | IsNameUnique | Validates whether the material name is unique in document.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetMaterialAspectByPropertySet | Sets an aspect of the material to a shared property set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Example
C#
VB
C++
F#
Copy
private void GetMaterialInformation(Material material)
{
   StringBuilder message = new StringBuilder("Material : " + material.Name);
   //color of the material
   message.Append(string.Format("\nColor: Red[{0}]; Green[{1}]; Blue[{2}]",
                   material.Color.Red, material.Color.Green, material.Color.Blue));

   //foreground cut pattern and pattern color of the material
   FillPatternElement cutForegroundPattern = material.Document.GetElement(material.CutForegroundPatternId) as FillPatternElement;
   if (null != cutForegroundPattern)
   {
      message.Append("\nCut Foreground Pattern: " + cutForegroundPattern.Name);
      message.Append(string.Format("\nCut Foreground Pattern Color: Red[{0}]; Green[{1}]; Blue[{2}]",
                      material.CutForegroundPatternColor.Red, material.CutForegroundPatternColor.Green, material.CutForegroundPatternColor.Blue));
   }

   //foreground surface pattern and pattern color of the material
   FillPatternElement surfaceForegroundPattern = material.Document.GetElement(material.SurfaceForegroundPatternId) as FillPatternElement;
   if (null != surfaceForegroundPattern)
   {
      message.Append("\nSurface Foreground Pattern: " + surfaceForegroundPattern.Name);
      message.Append(string.Format("\nSurface Foreground Pattern Color: Red[{0}]; Green[{1}]; Blue[{2}]",
                      material.SurfaceForegroundPatternColor.Red, material.SurfaceForegroundPatternColor.Green, material.SurfaceForegroundPatternColor.Blue));
   }

   //background cut pattern and pattern color of the material
   FillPatternElement cutBackgroundPattern = material.Document.GetElement(material.CutBackgroundPatternId) as FillPatternElement;
   if (null != cutBackgroundPattern)
   {
      message.Append("\nCut Background Pattern: " + cutBackgroundPattern.Name);
      message.Append(string.Format("\nCut Background Pattern Color: Red[{0}]; Green[{1}]; Blue[{2}]",
                      material.CutBackgroundPatternColor.Red, material.CutBackgroundPatternColor.Green, material.CutBackgroundPatternColor.Blue));
   }

   //background surface pattern and pattern color of the material
   FillPatternElement surfaceBackgroundPattern = material.Document.GetElement(material.SurfaceBackgroundPatternId) as FillPatternElement;
   if (null != surfaceBackgroundPattern)
   {
      message.Append("\nSurface Background Pattern: " + surfaceBackgroundPattern.Name);
      message.Append(string.Format("\nSurface Background Pattern Color: Red[{0}]; Green[{1}]; Blue[{2}]",
                      material.SurfaceBackgroundPatternColor.Red, material.SurfaceBackgroundPatternColor.Green, material.SurfaceBackgroundPatternColor.Blue));
   }

   //some shading property of the material
   int shininess = material.Shininess;
   message.Append("\nShininess: " + shininess);
   int smoothness = material.Smoothness;
   message.Append("\nSmoothness: " + smoothness);
   int transparency = material.Transparency;
   message.Append("\nTransparency: " + transparency);

   TaskDialog.Show("Revit", message.ToString());
}
Private Sub GetMaterialInformation(material As Material)
    Dim message As New StringBuilder("Material : " & Convert.ToString(material.Name))
    'color of the material
    message.Append(String.Format(vbLf & "Color: Red[{0}]; Green[{1}]; Blue[{2}]", material.Color.Red, material.Color.Green, material.Color.Blue))

    'foreground cut pattern and pattern color of the material
    Dim cutForegroundPattern As FillPatternElement = TryCast(material.Document.GetElement(material.CutForegroundPatternId), FillPatternElement)
    If cutForegroundPattern IsNot Nothing Then
        message.Append(vbLf & "Cut Foreground Pattern: " + cutForegroundPattern.Name)
        message.Append(String.Format(vbLf & "Cut Foreground Pattern Color: Red[{0}]; Green[{1}]; Blue[{2}]", material.CutForegroundPatternColor.Red, material.CutForegroundPatternColor.Green, material.CutForegroundPatternColor.Blue))
    End If

    'foreground surface pattern and pattern color of the material
    Dim surfaceForegroundPattern As FillPatternElement = TryCast(material.Document.GetElement(material.SurfaceForegroundPatternId), FillPatternElement)
    If surfaceForegroundPattern IsNot Nothing Then
        message.Append(vbLf & "Surface Foreground Pattern: " + surfaceForegroundPattern.Name)
        message.Append(String.Format(vbLf & "Surface Foreground Pattern Color: Red[{0}]; Green[{1}]; Blue[{2}]", material.SurfaceForegroundPatternColor.Red, material.SurfaceForegroundPatternColor.Green, material.SurfaceForegroundPatternColor.Blue))
    End If

    'background cut pattern and pattern color of the material
    Dim cutBackgroundPattern As FillPatternElement = TryCast(material.Document.GetElement(material.CutBackgroundPatternId), FillPatternElement)
    If cutBackgroundPattern IsNot Nothing Then
        message.Append(vbLf & "Cut Background Pattern: " + cutBackgroundPattern.Name)
        message.Append(String.Format(vbLf & "Cut Background Pattern Color: Red[{0}]; Green[{1}]; Blue[{2}]", material.CutBackgroundPatternColor.Red, material.CutBackgroundPatternColor.Green, material.CutBackgroundPatternColor.Blue))
    End If

    'background surface pattern and pattern color of the material
    Dim surfaceBackgroundPattern As FillPatternElement = TryCast(material.Document.GetElement(material.SurfaceBackgroundPatternId), FillPatternElement)
    If surfaceBackgroundPattern IsNot Nothing Then
        message.Append(vbLf & "Surface Background Pattern: " + surfaceBackgroundPattern.Name)
        message.Append(String.Format(vbLf & "Surface Background Pattern Color: Red[{0}]; Green[{1}]; Blue[{2}]", material.SurfaceBackgroundPatternColor.Red, material.SurfaceBackgroundPatternColor.Green, material.SurfaceBackgroundPatternColor.Blue))
    End If

    'some shading property of the material
    Dim shininess As Integer = material.Shininess
    message.Append(vbLf & "Shininess: " & shininess)
    Dim smoothness As Integer = material.Smoothness
    message.Append(vbLf & "Smoothness: " & smoothness)
    Dim transparency As Integer = material.Transparency
    message.Append(vbLf & "Transparency: " & transparency)

    TaskDialog.Show("Revit", message.ToString())
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Material Properties

The Material type exposes the following members.

Properties
 | Name | Description
 | AppearanceAssetId | The ElementId of the AppearanceAssetElement.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | Color | The color of the material.
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CutBackgroundPatternColor | The color of the material cut background pattern.
Public property | CutBackgroundPatternId | The id of the FillPatternElement used as the background pattern of faces with this material in cut views.
Public property | CutForegroundPatternColor | The color of the material cut foreground pattern.
Public property | CutForegroundPatternId | The id of the FillPatternElement used as the foreground pattern of faces with this material in cut views.
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | MaterialCategory | The name of the material category, e.g. 'Wood'
Public property | MaterialClass | The name of the general material type, e.g. 'Wood.'
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Shininess | The shininess of the material.
Public property | Smoothness | The smoothness of the material.
Public property | StructuralAssetId | The ElementId of the structural PropertySetElement.
Public property | SurfaceBackgroundPatternColor | The color of the material surface background pattern.
Public property | SurfaceBackgroundPatternId | The id of the FillPatternElement used as the background pattern of faces with this material in normal views.
Public property | SurfaceForegroundPatternColor | The color of the material surface foreground pattern.
Public property | SurfaceForegroundPatternId | The id of the FillPatternElement used as the foreground pattern of faces with this material in normal views.
Public property | ThermalAssetId | The ElementId of the thermal PropertySetElement.
Public property | Transparency | The transparency of the material.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | UseRenderAppearanceForShading | True to use the render appearance settings for shaded view appearance; false to use the material's color and transparency value for shaded view appearance.
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

Material Class


Material.AppearanceAssetId Property

MaterialAppearanceAssetId Property

The ElementId of the AppearanceAssetElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId AppearanceAssetId { get; set; }
Public Property AppearanceAssetId As ElementId
    Get
    Set
public:
property ElementId^ AppearanceAssetId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member AppearanceAssetId : ElementId with get, set

Property Value

ElementId
The id of the AppearanceAssetElement, or InvalidElementId if the material does not have an associated appearance asset.
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
This is the id to the element that contains visual material information used for rendering. In some cases where the material is created without setting up custom render appearance properties (for example, when the material is created via an import, or when it is created by the API), this property will be InvalidElementId. In that situation the standard material properties such as Color and Transparency will dictate the appearance of the material during rendering.
Example
C#
VB
C++
F#
Copy
private void ReadMaterialAppearanceProp(Document document, Material material)
{
   ElementId appearanceId = material.AppearanceAssetId;
   AppearanceAssetElement appearanceElem = document.GetElement(appearanceId) as AppearanceAssetElement;
   Asset theAsset = appearanceElem.GetRenderingAsset();
   string libraryName = theAsset.LibraryName;
   string title = theAsset.Title;

   // The predefined asset can be empty. at this time, get the system appearance asset instead.
   if (theAsset.Size == 0)
   {
      IList<Asset> systemAppearanceAssets = document.Application.GetAssets(AssetType.Appearance);
      foreach (Asset systemAsset in systemAppearanceAssets)
      {
         if(theAsset.LibraryName == systemAsset.LibraryName
            && theAsset.Name == systemAsset.Name)
         {
            // Read the Asset information here.
            break;
         }
      }
   }
}
Private Sub ReadMaterialAppearanceProp(document As Document, material As Material)
    Dim appearanceId As ElementId = material.AppearanceAssetId
    Dim appearanceElem As AppearanceAssetElement = TryCast(document.GetElement(appearanceId), AppearanceAssetElement)
    Dim theAsset As Asset = appearanceElem.GetRenderingAsset()
    Dim libraryName As String = theAsset.LibraryName
    Dim title As String = theAsset.Title

    ' The predefined asset can be empty. at this time, get the system appearance asset instead.
    If theAsset.Size = 0 Then
        Dim systemAppearanceAssets As IList(Of Asset) = document.Application.GetAssets(AssetType.Appearance)
        For Each systemAsset As Asset In systemAppearanceAssets
            If theAsset.LibraryName = systemAsset.LibraryName AndAlso theAsset.Name = systemAsset.Name Then
                ' Read the Asset information here.
                Exit For
            End If
        Next
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Material Class


Material.Color Property

MaterialColor Property

The color of the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color Color { get; set; }
Public Property Color As Color
    Get
    Set
public:
property Color^ Color {
    Color^ get ();
    void set (Color^ value);
}
member Color : Color with get, set

Property Value

Color
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

Material Class


Material.CutBackgroundPatternColor Property

MaterialCutBackgroundPatternColor Property

The color of the material cut background pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color CutBackgroundPatternColor { get; set; }
Public Property CutBackgroundPatternColor As Color
    Get
    Set
public:
property Color^ CutBackgroundPatternColor {
    Color^ get ();
    void set (Color^ value);
}
member CutBackgroundPatternColor : Color with get, set

Property Value

Color
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

Material Class


Material.CutBackgroundPatternId Property

MaterialCutBackgroundPatternId Property

The id of the FillPatternElement used as the background pattern of faces with this material in cut views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId CutBackgroundPatternId { get; set; }
Public Property CutBackgroundPatternId As ElementId
    Get
    Set
public:
property ElementId^ CutBackgroundPatternId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member CutBackgroundPatternId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentException | When setting this property: The element id must represent a valid FillPatternElement. -or- When setting this property: The FillPattern target must be a drafting pattern.
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
The FillPattern used for a cut pattern must have a 'Drafting' target.
See Also

Reference

Material Class


Material.CutForegroundPatternColor Property

MaterialCutForegroundPatternColor Property

The color of the material cut foreground pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color CutForegroundPatternColor { get; set; }
Public Property CutForegroundPatternColor As Color
    Get
    Set
public:
property Color^ CutForegroundPatternColor {
    Color^ get ();
    void set (Color^ value);
}
member CutForegroundPatternColor : Color with get, set

Property Value

Color
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

Material Class


Material.CutForegroundPatternId Property

MaterialCutForegroundPatternId Property

The id of the FillPatternElement used as the foreground pattern of faces with this material in cut views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId CutForegroundPatternId { get; set; }
Public Property CutForegroundPatternId As ElementId
    Get
    Set
public:
property ElementId^ CutForegroundPatternId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member CutForegroundPatternId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentException | When setting this property: The element id must represent a valid FillPatternElement. -or- When setting this property: The FillPattern target must be a drafting pattern.
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
The FillPattern used for a cut foreground pattern must have a 'Drafting' target.
See Also

Reference

Material Class


Material.MaterialCategory Property

MaterialMaterialCategory Property

The name of the material category, e.g. 'Wood'

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string MaterialCategory { get; set; }
Public Property MaterialCategory As String
    Get
    Set
public:
property String^ MaterialCategory {
    String^ get ();
    void set (String^ value);
}
member MaterialCategory : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

Material Class


Material.MaterialClass Property

MaterialMaterialClass Property

The name of the general material type, e.g. 'Wood.'

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string MaterialClass { get; set; }
Public Property MaterialClass As String
    Get
    Set
public:
property String^ MaterialClass {
    String^ get ();
    void set (String^ value);
}
member MaterialClass : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

Material Class


Material.Shininess Property

MaterialShininess Property

The shininess of the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Shininess { get; set; }
Public Property Shininess As Integer
    Get
    Set
public:
property int Shininess {
    int get ();
    void set (int value);
}
member Shininess : int with get, set

Property Value

Int32
The value ranges from 0 to 128.
Exceptions
Exception | Condition
ArgumentException | When setting this property: values for shininess must be between 0 and 128
See Also

Reference

Material Class


Material.Smoothness Property

MaterialSmoothness Property

The smoothness of the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Smoothness { get; set; }
Public Property Smoothness As Integer
    Get
    Set
public:
property int Smoothness {
    int get ();
    void set (int value);
}
member Smoothness : int with get, set

Property Value

Int32
The value ranges from 0 to 100.
Exceptions
Exception | Condition
ArgumentException | When setting this property: values for shininess must be between 0 and 128
See Also

Reference

Material Class


Material.StructuralAssetId Property

MaterialStructuralAssetId Property

The ElementId of the structural PropertySetElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId StructuralAssetId { get; set; }
Public Property StructuralAssetId As ElementId
    Get
    Set
public:
property ElementId^ StructuralAssetId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member StructuralAssetId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

Material Class


Material.SurfaceBackgroundPatternColor Property

MaterialSurfaceBackgroundPatternColor Property

The color of the material surface background pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color SurfaceBackgroundPatternColor { get; set; }
Public Property SurfaceBackgroundPatternColor As Color
    Get
    Set
public:
property Color^ SurfaceBackgroundPatternColor {
    Color^ get ();
    void set (Color^ value);
}
member SurfaceBackgroundPatternColor : Color with get, set

Property Value

Color
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

Material Class


Material.SurfaceBackgroundPatternId Property

MaterialSurfaceBackgroundPatternId Property

The id of the FillPatternElement used as the background pattern of faces with this material in normal views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId SurfaceBackgroundPatternId { get; set; }
Public Property SurfaceBackgroundPatternId As ElementId
    Get
    Set
public:
property ElementId^ SurfaceBackgroundPatternId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member SurfaceBackgroundPatternId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentException | When setting this property: The element id must represent a valid FillPatternElement. -or- When setting this property: The FillPattern target must be a drafting pattern.
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
The FillPattern used for a background pattern must have a 'Drafting' target.
See Also

Reference

Material Class


Material.SurfaceForegroundPatternColor Property

MaterialSurfaceForegroundPatternColor Property

The color of the material surface foreground pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color SurfaceForegroundPatternColor { get; set; }
Public Property SurfaceForegroundPatternColor As Color
    Get
    Set
public:
property Color^ SurfaceForegroundPatternColor {
    Color^ get ();
    void set (Color^ value);
}
member SurfaceForegroundPatternColor : Color with get, set

Property Value

Color
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

Material Class


Material.SurfaceForegroundPatternId Property

MaterialSurfaceForegroundPatternId Property

The id of the FillPatternElement used as the foreground pattern of faces with this material in normal views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId SurfaceForegroundPatternId { get; set; }
Public Property SurfaceForegroundPatternId As ElementId
    Get
    Set
public:
property ElementId^ SurfaceForegroundPatternId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member SurfaceForegroundPatternId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentException | When setting this property: The element id must represent a valid FillPatternElement.
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
The FillPattern used for a surface foreground pattern can have a 'Drafting' or a 'Model' target.
See Also

Reference

Material Class


Material.ThermalAssetId Property

MaterialThermalAssetId Property

The ElementId of the thermal PropertySetElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId ThermalAssetId { get; set; }
Public Property ThermalAssetId As ElementId
    Get
    Set
public:
property ElementId^ ThermalAssetId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member ThermalAssetId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

Material Class


Material.Transparency Property

MaterialTransparency Property

The transparency of the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Transparency { get; set; }
Public Property Transparency As Integer
    Get
    Set
public:
property int Transparency {
    int get ();
    void set (int value);
}
member Transparency : int with get, set

Property Value

Int32
The value ranges from 0 to 100.
Exceptions
Exception | Condition
ArgumentException | When setting this property: values for shininess must be between 0 and 128
See Also

Reference

Material Class


Material.UseRenderAppearanceForShading Property

MaterialUseRenderAppearanceForShading Property

True to use the render appearance settings for shaded view appearance; false to use the material's color and transparency value for shaded view appearance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UseRenderAppearanceForShading { get; set; }
Public Property UseRenderAppearanceForShading As Boolean
    Get
    Set
public:
property bool UseRenderAppearanceForShading {
    bool get ();
    void set (bool value);
}
member UseRenderAppearanceForShading : bool with get, set

Property Value

Boolean
See Also

Reference

Material Class


Material Methods

The Material type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | ClearMaterialAspect | Removes an aspect from the material.
 | Create | Creates a new material.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
 | Duplicate | Duplicates the material
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
 | IsMaterialOrValidDefault | Validates whether the specified element id is a material element.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
 | IsNameUnique | Validates whether the material name is unique in document.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetMaterialAspectByPropertySet | Sets an aspect of the material to a shared property set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Material Class


Material.ClearMaterialAspect Method

MaterialClearMaterialAspect Method

Removes an aspect from the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ClearMaterialAspect(
    MaterialAspect aspect
)
Public Sub ClearMaterialAspect (
    aspect As MaterialAspect
)
public:
void ClearMaterialAspect(
    MaterialAspect aspect
)
member ClearMaterialAspect :
        aspect : MaterialAspect -> unit

Parameters

aspect MaterialAspect
The material aspect.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

Material Class


Material.Create Method

MaterialCreate Method

Creates a new material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ElementId Create(
    Document document,
    string name
)
Public Shared Function Create (
    document As Document,
    name As String
) As ElementId
public:
static ElementId^ Create(
    Document^ document,
    String^ name
)
static member Create :
        document : Document *
        name : string -> ElementId

Parameters

document Document
The document in which to create the material.
name String
The name of the new material.

Return Value

ElementId
Identifier of the new material.
Exceptions
Exception | Condition
ArgumentException | name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- The given value for name is already in use as a material element name.
ArgumentNullException | A non-optional argument was null
Example
C#
VB
C++
F#
Copy
//Create the material
ElementId materialId = Material.Create(document, "My Material");
Material material = document.GetElement(materialId) as Material;

//Create a new property set that can be used by this material
StructuralAsset strucAsset = new StructuralAsset("My Property Set", StructuralAssetClass.Concrete);
strucAsset.Behavior = StructuralBehavior.Isotropic;
strucAsset.Density = 232.0;

//Assign the property set to the material.
PropertySetElement pse = PropertySetElement.Create(document, strucAsset);
material.SetMaterialAspectByPropertySet(MaterialAspect.Structural, pse.Id);
'Create the material
Dim materialId As ElementId = Material.Create(document, "My Material")
Dim material__1 As Material = TryCast(document.GetElement(materialId), Material)

'Create a new property set that can be used by this material
Dim strucAsset As New StructuralAsset("My Property Set", StructuralAssetClass.Concrete)
strucAsset.Behavior = StructuralBehavior.Isotropic
strucAsset.Density = 232.0

'Assign the property set to the material.
Dim pse As PropertySetElement = PropertySetElement.Create(document, strucAsset)
material__1.SetMaterialAspectByPropertySet(MaterialAspect.Structural, pse.Id)

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Material Class


Material.Duplicate Method

MaterialDuplicate Method

Duplicates the material

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Material Duplicate(
    string name
)
Public Function Duplicate (
    name As String
) As Material
public:
Material^ Duplicate(
    String^ name
)
member Duplicate :
        name : string -> Material

Parameters

name String
Name of the new material - this name must be correctly structured for Revit use and not duplicate the name of another material in the document.

Return Value

Material
The new material.
Exceptions
Exception | Condition
ArgumentException | name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- The given value for name is already in use as a material element name.
ArgumentNullException | A non-optional argument was null
Remarks
If duplication fails for reasons unrelated to the name, will be returned.
Example
C#
VB
C++
F#
Copy
private bool DuplicateMaterial(Material material)
{
   bool duplicated = false;
   //try to duplicate a new instance of Material class using duplicate method
   //make sure the name of new material is unique in MaterailSet
   string newName = "new" + material.Name;
   Material myMaterial = material.Duplicate(newName);
   if (null == myMaterial)
   {
      TaskDialog.Show("Revit", "Failed to duplicate a material!");
   }
   else
   {
      duplicated = true;
   }

   return duplicated;
}
Private Function DuplicateMaterial(material As Material) As Boolean
    Dim duplicated As Boolean = False
    'try to duplicate a new instance of Material class using duplicate method
    'make sure the name of new material is unique in MaterailSet
    Dim newName As String = "new" & Convert.ToString(material.Name)
    Dim myMaterial As Material = material.Duplicate(newName)
    If myMaterial Is Nothing Then
        TaskDialog.Show("Revit", "Failed to duplicate a material!")
    Else
        duplicated = True
    End If

    Return duplicated
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Material Class


Material.IsMaterialOrValidDefault Method

MaterialIsMaterialOrValidDefault Method

Validates whether the specified element id is a material element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsMaterialOrValidDefault(
    Element pElem,
    ElementId materialId
)
Public Shared Function IsMaterialOrValidDefault (
    pElem As Element,
    materialId As ElementId
) As Boolean
public:
static bool IsMaterialOrValidDefault(
    Element^ pElem,
    ElementId^ materialId
)
static member IsMaterialOrValidDefault :
        pElem : Element *
        materialId : ElementId -> bool

Parameters

pElem Element
An element which will be applied the material
materialId ElementId
The element id to be checked.

Return Value

Boolean
True if the element a material element or invalidElementId, which means take material from category, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

Material Class


Material.IsNameUnique Method

MaterialIsNameUnique Method

Validates whether the material name is unique in document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsNameUnique(
    Document aDocument,
    string name
)
Public Shared Function IsNameUnique (
    aDocument As Document,
    name As String
) As Boolean
public:
static bool IsNameUnique(
    Document^ aDocument,
    String^ name
)
static member IsNameUnique :
        aDocument : Document *
        name : string -> bool

Parameters

aDocument Document
The document in which the name is being tested for uniqueness.
name String
The name tested for uniqueness.

Return Value

Boolean
Returns true if the name is unique, and false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

Material Class


Material.SetMaterialAspectByPropertySet Method

MaterialSetMaterialAspectByPropertySet Method

Sets an aspect of the material to a shared property set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetMaterialAspectByPropertySet(
    MaterialAspect aspect,
    ElementId propertySetId
)
Public Sub SetMaterialAspectByPropertySet (
    aspect As MaterialAspect,
    propertySetId As ElementId
)
public:
void SetMaterialAspectByPropertySet(
    MaterialAspect aspect,
    ElementId^ propertySetId
)
member SetMaterialAspectByPropertySet :
        aspect : MaterialAspect *
        propertySetId : ElementId -> unit

Parameters

aspect MaterialAspect
The material aspect.
propertySetId ElementId
Identifier of a shared property set (an instance of PropertySetElement).
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

Material Class


MaterialAspect Enumeration

A list of all material aspects that a material can store PropertySetElements for.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum MaterialAspect
Public Enumeration MaterialAspect
public enum class MaterialAspect
type MaterialAspect
Members
Member name | Value | Description
Structural | 0 | Structural
Thermal | 1 | Thermal
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


MaterialFunctionAssignment Enumeration

Used in class CompoundStructure to specify the function of a layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum MaterialFunctionAssignment
Public Enumeration MaterialFunctionAssignment
public enum class MaterialFunctionAssignment
type MaterialFunctionAssignment
Members
Member name | Value | Description
None | 0 | Priority = 0 This is deprecated and should not be used.
Structure | 1 | Priority = 1 (highest priority)
Substrate | 2 | Priority = 2
Insulation | 3 | Priority = 3
Finish1 | 4 | Priority = 4
Finish2 | 5 | Priority = 5
Membrane | 100 | A membrane layer must have thickness 0. It is not represented graphically.
StructuralDeck | 200 | Indicates layer is a structural deck.
Remarks
The function is used primarily to determine layer priority which affects how layers of distinct elements interact at a join. Typically, layers penetrate lower priority layers and merge with layers of the same priority.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


MaterialNode Class

This class represents a change of material during a model-exporting process.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRenderNode
Autodesk.Revit.DBMaterialNode

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MaterialNode : RenderNode
Public Class MaterialNode
    Inherits RenderNode
public ref class MaterialNode : public RenderNode
type MaterialNode =
    class
        inherit RenderNode
    end

The MaterialNode type exposes the following members.

Properties
 | Name | Description
Public property | Color | The color the material is being rendered at
Public property | Glossiness | The level of glossiness of the material
Public property | HasOverriddenAppearance | Identifies if the default rendering appearance the material has is being overridden.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode)
Public property | MaterialId | The Id of the element assocated with this material in the model.
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode)
Public property | Smoothness | The level of smoothness of the material.
Public property | ThumbnailFile | The path if a file that contains a thumbnail image of the material.
Public property | Transparency | The value of transparency the material is being rendered with
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from RenderNode)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAppearance | Appearance properties associated with the material.
Public method | GetAppearanceOverride | Returns appearance properties that override the preset appearance of the material.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

Output nodes following this node are to be assumed using the material. The material remains in effect until another material node is sent to the output.

See also: OnMaterial(MaterialNode).

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


MaterialNode Properties

The MaterialNode type exposes the following members.

Properties
 | Name | Description
Public property | Color | The color the material is being rendered at
Public property | Glossiness | The level of glossiness of the material
Public property | HasOverriddenAppearance | Identifies if the default rendering appearance the material has is being overridden.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode)
Public property | MaterialId | The Id of the element assocated with this material in the model.
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode)
Public property | Smoothness | The level of smoothness of the material.
Public property | ThumbnailFile | The path if a file that contains a thumbnail image of the material.
Public property | Transparency | The value of transparency the material is being rendered with
Top
See Also

Reference

MaterialNode Class


MaterialNode.Color Property

MaterialNodeColor Property

The color the material is being rendered at

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color Color { get; }
Public ReadOnly Property Color As Color
    Get
public:
property Color^ Color {
    Color^ get ();
}
member Color : Color with get

Property Value

Color
Remarks
The value may differ from the default color property of the material, because it might have been overridden by rendering settings.
See Also

Reference

MaterialNode Class


MaterialNode.Glossiness Property

MaterialNodeGlossiness Property

The level of glossiness of the material

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Glossiness { get; }
Public ReadOnly Property Glossiness As Integer
    Get
public:
property int Glossiness {
    int get ();
}
member Glossiness : int with get

Property Value

Int32
See Also

Reference

MaterialNode Class


MaterialNode.HasOverriddenAppearance Property

MaterialNodeHasOverriddenAppearance Property

Identifies if the default rendering appearance the material has is being overridden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasOverriddenAppearance { get; }
Public ReadOnly Property HasOverriddenAppearance As Boolean
    Get
public:
property bool HasOverriddenAppearance {
    bool get ();
}
member HasOverriddenAppearance : bool with get

Property Value

Boolean
See Also

Reference

MaterialNode Class


MaterialNode.MaterialId Property

MaterialNodeMaterialId Property

The Id of the element assocated with this material in the model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId MaterialId { get; }
Public ReadOnly Property MaterialId As ElementId
    Get
public:
property ElementId^ MaterialId {
    ElementId^ get ();
}
member MaterialId : ElementId with get

Property Value

ElementId
Remarks
It is possible that no specific material is applied to a face, in which case the default material is used, and this property returns an InvalidElementId.
See Also

Reference

MaterialNode Class


MaterialNode.Smoothness Property

MaterialNodeSmoothness Property

The level of smoothness of the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Smoothness { get; }
Public ReadOnly Property Smoothness As Integer
    Get
public:
property int Smoothness {
    int get ();
}
member Smoothness : int with get

Property Value

Int32
See Also

Reference

MaterialNode Class


MaterialNode.ThumbnailFile Property

MaterialNodeThumbnailFile Property

The path if a file that contains a thumbnail image of the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ThumbnailFile { get; }
Public ReadOnly Property ThumbnailFile As String
    Get
public:
property String^ ThumbnailFile {
    String^ get ();
}
member ThumbnailFile : string with get

Property Value

String
See Also

Reference

MaterialNode Class


MaterialNode.Transparency Property

MaterialNodeTransparency Property

The value of transparency the material is being rendered with

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Transparency { get; }
Public ReadOnly Property Transparency As Double
    Get
public:
property double Transparency {
    double get ();
}
member Transparency : float with get

Property Value

Double
See Also

Reference

MaterialNode Class


MaterialNode Methods

The MaterialNode type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from RenderNode)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAppearance | Appearance properties associated with the material.
Public method | GetAppearanceOverride | Returns appearance properties that override the preset appearance of the material.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MaterialNode Class


MaterialNode.GetAppearance Method

MaterialNodeGetAppearance Method

Appearance properties associated with the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Asset GetAppearance()
Public Function GetAppearance As Asset
public:
Asset^ GetAppearance()
member GetAppearance : unit -> Asset

Return Value

Asset
An instance of a rendering material asset
Remarks
Properties and attributes of the material's appearance can be accessed using the standard interface of the Asset class.

The structure of the properties, including their types and names is proprietary and as such it is not always useful to anyone who is not familiar with the particular schema. Also, the structure is not standardized and may change over time, therefore it is not recommended relaying on any appearance property to be present.

See Also

Reference

MaterialNode Class


MaterialNode.GetAppearanceOverride Method

MaterialNodeGetAppearanceOverride Method

Returns appearance properties that override the preset appearance of the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Asset GetAppearanceOverride()
Public Function GetAppearanceOverride As Asset
public:
Asset^ GetAppearanceOverride()
member GetAppearanceOverride : unit -> Asset

Return Value

Asset
An instance of a rendering material asset, of null if there is no override.
Remarks
The returned instance of an Asset is valid only if there is an overide, which happens if there are decals applied to the face that has the base material. In such cases the rendering engine takes the asset of the material and merges it with the decal, which results to this override asset. If there are no decals, this instance is null and the HasOverriddenAppearance returns False.
See Also

Reference

MaterialNode Class


MaterialPropertyPathType Enumeration

Enum class indicating kinds of paths which ExternalFileReferenceType.Material references can have.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum MaterialPropertyPathType
Public Enumeration MaterialPropertyPathType
public enum class MaterialPropertyPathType
type MaterialPropertyPathType
Members
Member name | Value | Description
General | 0 | General image, for various material types
Transparency | 1 | Transparency image, for generic materials
Cutouts | 2 | Cutouts image, for generic or metal materials
Bump | 3 | Bump pattern, for generic materials
FinishBumps | 4 | Finish bumps, pattern for various material types
ReliefPattern | 5 | Relief pattern, for various material types
Weathering | 6 | Weathering image, for concrete materials
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


MathComparisonUtils Class

This class contains a set of mathematical utilities to compare doubles, using the internal tolerance.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBMathComparisonUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class MathComparisonUtils
Public NotInheritable Class MathComparisonUtils
public ref class MathComparisonUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type MathComparisonUtils = class end

The MathComparisonUtils type exposes the following members.

Methods
Name | Description
IsAlmostEqual | Checks if two doubles are almost equal, using the internal tolerance.
IsAlmostZero | Checks if value is almost zero, using the internal tolerance.
IsGreaterThan | Checks if value1 is strictly greater than value2, using the internal tolerance.
IsGreaterThanOrAlmostEqual | Checks if value1 is greater than or almost equal to value2, using the internal tolerance.
IsLessThan | Checks if value1 is strictly less than value2, using the internal tolerance.
IsLessThanOrAlmostEqual | Checks if value1 is less than or almost equal to value2, using the internal tolerance.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


MathComparisonUtils Methods

The MathComparisonUtils type exposes the following members.

Methods
Name | Description
IsAlmostEqual | Checks if two doubles are almost equal, using the internal tolerance.
IsAlmostZero | Checks if value is almost zero, using the internal tolerance.
IsGreaterThan | Checks if value1 is strictly greater than value2, using the internal tolerance.
IsGreaterThanOrAlmostEqual | Checks if value1 is greater than or almost equal to value2, using the internal tolerance.
IsLessThan | Checks if value1 is strictly less than value2, using the internal tolerance.
IsLessThanOrAlmostEqual | Checks if value1 is less than or almost equal to value2, using the internal tolerance.
Top
See Also

Reference

MathComparisonUtils Class


MathComparisonUtils.IsAlmostEqual Method

MathComparisonUtilsIsAlmostEqual Method

Checks if two doubles are almost equal, using the internal tolerance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsAlmostEqual(
    double value1,
    double value2
)
Public Shared Function IsAlmostEqual (
    value1 As Double,
    value2 As Double
) As Boolean
public:
static bool IsAlmostEqual(
    double value1,
    double value2
)
static member IsAlmostEqual :
        value1 : float *
        value2 : float -> bool

Parameters

value1 Double
The first value.
value2 Double
The second value.

Return Value

Boolean
True if two doubles are almost equal, false otherwise.
Exceptions
Exception | Condition
ArgumentException | The given value for value1 is not finite -or- The given value for value2 is not finite
See Also

Reference

MathComparisonUtils Class


MathComparisonUtils.IsAlmostZero Method

MathComparisonUtilsIsAlmostZero Method

Checks if value is almost zero, using the internal tolerance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsAlmostZero(
    double value
)
Public Shared Function IsAlmostZero (
    value As Double
) As Boolean
public:
static bool IsAlmostZero(
    double value
)
static member IsAlmostZero :
        value : float -> bool

Parameters

value Double
The value to check.

Return Value

Boolean
True if value is almost zero, false otherwise.
Exceptions
Exception | Condition
ArgumentException | The given value for value is not finite
See Also

Reference

MathComparisonUtils Class


MathComparisonUtils.IsGreaterThan Method

MathComparisonUtilsIsGreaterThan Method

Checks if value1 is strictly greater than value2, using the internal tolerance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsGreaterThan(
    double value1,
    double value2
)
Public Shared Function IsGreaterThan (
    value1 As Double,
    value2 As Double
) As Boolean
public:
static bool IsGreaterThan(
    double value1,
    double value2
)
static member IsGreaterThan :
        value1 : float *
        value2 : float -> bool

Parameters

value1 Double
The first value.
value2 Double
The second value.

Return Value

Boolean
True if value1 is strictly greater than value2, false otherwise.
Exceptions
Exception | Condition
ArgumentException | The given value for value1 is not finite -or- The given value for value2 is not finite
See Also

Reference

MathComparisonUtils Class


MathComparisonUtils.IsGreaterThanOrAlmostEqual Method

MathComparisonUtilsIsGreaterThanOrAlmostEqual Method

Checks if value1 is greater than or almost equal to value2, using the internal tolerance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsGreaterThanOrAlmostEqual(
    double value1,
    double value2
)
Public Shared Function IsGreaterThanOrAlmostEqual (
    value1 As Double,
    value2 As Double
) As Boolean
public:
static bool IsGreaterThanOrAlmostEqual(
    double value1,
    double value2
)
static member IsGreaterThanOrAlmostEqual :
        value1 : float *
        value2 : float -> bool

Parameters

value1 Double
The first value.
value2 Double
The second value.

Return Value

Boolean
True if value1 is greater than or almost equal to value2, false otherwise.
Exceptions
Exception | Condition
ArgumentException | The given value for value1 is not finite -or- The given value for value2 is not finite
See Also

Reference

MathComparisonUtils Class


MathComparisonUtils.IsLessThan Method

MathComparisonUtilsIsLessThan Method

Checks if value1 is strictly less than value2, using the internal tolerance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsLessThan(
    double value1,
    double value2
)
Public Shared Function IsLessThan (
    value1 As Double,
    value2 As Double
) As Boolean
public:
static bool IsLessThan(
    double value1,
    double value2
)
static member IsLessThan :
        value1 : float *
        value2 : float -> bool

Parameters

value1 Double
The first value.
value2 Double
The second value.

Return Value

Boolean
True if value1 is strictly less than value2, false otherwise.
Exceptions
Exception | Condition
ArgumentException | The given value for value1 is not finite -or- The given value for value2 is not finite
See Also

Reference

MathComparisonUtils Class


MathComparisonUtils.IsLessThanOrAlmostEqual Method

MathComparisonUtilsIsLessThanOrAlmostEqual Method

Checks if value1 is less than or almost equal to value2, using the internal tolerance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsLessThanOrAlmostEqual(
    double value1,
    double value2
)
Public Shared Function IsLessThanOrAlmostEqual (
    value1 As Double,
    value2 As Double
) As Boolean
public:
static bool IsLessThanOrAlmostEqual(
    double value1,
    double value2
)
static member IsLessThanOrAlmostEqual :
        value1 : float *
        value2 : float -> bool

Parameters

value1 Double
The first value.
value2 Double
The second value.

Return Value

Boolean
True if value1 is less than or almost equal to value2, false otherwise.
Exceptions
Exception | Condition
ArgumentException | The given value for value1 is not finite -or- The given value for value2 is not finite
See Also

Reference

MathComparisonUtils Class


MEPAnalyticalConnection Class

Represents an analytical element that connects mechanical equipment to piping network.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBHostObject
Autodesk.Revit.DBMEPCurve
Autodesk.Revit.DBMEPAnalyticalConnection

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MEPAnalyticalConnection : MEPCurve
Public Class MEPAnalyticalConnection
    Inherits MEPCurve
public ref class MEPAnalyticalConnection : public MEPCurve
type MEPAnalyticalConnection =
    class
        inherit MEPCurve
    end

The MEPAnalyticalConnection type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Diameter | The diameter of the MEP curve. (Inherited from MEPCurve)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | Height | The height of the MEP curve. (Inherited from MEPCurve)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | MEPSystem | The system of the MEP curve. (Inherited from MEPCurve)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | Width | The width of the MEP curve. (Inherited from MEPCurve)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
 | CanSupportAnalyticalConnection | Checks if the connector can support the analytical connection.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new analytical connection between two open connectors.
 | CreateMultipleConnections | Creates new analytical connections between the equipment connector and the nearest point on the curves.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFlow | Gets the flow value of this analytical connection.
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The analytical connection takes mechanical equipment into account of network flow/pressure analysis. The connection remains the same even if the mechanical equipment moves and rotates. It enables a fast establishment of piping network to analyze the flow and pressure, especially at the early stage of the design process.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


MEPAnalyticalConnection Properties

The MEPAnalyticalConnection type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Diameter | The diameter of the MEP curve. (Inherited from MEPCurve)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | Height | The height of the MEP curve. (Inherited from MEPCurve)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | MEPSystem | The system of the MEP curve. (Inherited from MEPCurve)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | Width | The width of the MEP curve. (Inherited from MEPCurve)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

MEPAnalyticalConnection Class


MEPAnalyticalConnection Methods

The MEPAnalyticalConnection type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
 | CanSupportAnalyticalConnection | Checks if the connector can support the analytical connection.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new analytical connection between two open connectors.
 | CreateMultipleConnections | Creates new analytical connections between the equipment connector and the nearest point on the curves.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFlow | Gets the flow value of this analytical connection.
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MEPAnalyticalConnection Class


MEPAnalyticalConnection.CanSupportAnalyticalConnection Method

MEPAnalyticalConnectionCanSupportAnalyticalConnection Method

Checks if the connector can support the analytical connection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CanSupportAnalyticalConnection(
    Connector connector
)
Public Shared Function CanSupportAnalyticalConnection (
    connector As Connector
) As Boolean
public:
static bool CanSupportAnalyticalConnection(
    Connector^ connector
)
static member CanSupportAnalyticalConnection :
        connector : Connector -> bool

Parameters

connector Connector
The testing connector.

Return Value

Boolean
True if the connector can support the network flow/pressure analysis, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

MEPAnalyticalConnection Class


MEPAnalyticalConnection.Create Method

MEPAnalyticalConnectionCreate Method

Creates a new analytical connection between two open connectors.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static MEPAnalyticalConnection Create(
    Document doc,
    ElementId typeId,
    Connector startConnector,
    Connector endConnector
)
Public Shared Function Create (
    doc As Document,
    typeId As ElementId,
    startConnector As Connector,
    endConnector As Connector
) As MEPAnalyticalConnection
public:
static MEPAnalyticalConnection^ Create(
    Document^ doc,
    ElementId^ typeId,
    Connector^ startConnector,
    Connector^ endConnector
)
static member Create :
        doc : Document *
        typeId : ElementId *
        startConnector : Connector *
        endConnector : Connector -> MEPAnalyticalConnection

Parameters

doc Document
The document where the new element is created.
typeId ElementId
The type of new analytical connection.
startConnector Connector
The open connector on the equipment side, whose level is inherited by the analytical connection.
endConnector Connector
The open connector on the network.

Return Value

MEPAnalyticalConnection
The newly created analytical connection element.
Exceptions
Exception | Condition
ArgumentException | Invalid connection type. -or- The connector does not support analytical connection.
ArgumentNullException | A non-optional argument was null
See Also

Reference

MEPAnalyticalConnection Class


MEPAnalyticalConnection.CreateMultipleConnections Method

MEPAnalyticalConnectionCreateMultipleConnections Method

Creates new analytical connections between the equipment connector and the nearest point on the curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ISet<ElementId> CreateMultipleConnections(
    Document doc,
    ElementId typeId,
    IList<Connector> equipmentOpenConnectors,
    IList<ElementId> curveIdsToConnect
)
Public Shared Function CreateMultipleConnections (
    doc As Document,
    typeId As ElementId,
    equipmentOpenConnectors As IList(Of Connector),
    curveIdsToConnect As IList(Of ElementId)
) As ISet(Of ElementId)
public:
static ISet<ElementId^>^ CreateMultipleConnections(
    Document^ doc,
    ElementId^ typeId,
    IList<Connector^>^ equipmentOpenConnectors,
    IList<ElementId^>^ curveIdsToConnect
)
static member CreateMultipleConnections :
        doc : Document *
        typeId : ElementId *
        equipmentOpenConnectors : IList<Connector> *
        curveIdsToConnect : IList<ElementId> -> ISet<ElementId>

Parameters

doc Document
The document where the new elements are created.
typeId ElementId
The type of new analytical connections.
equipmentOpenConnectors IList Connector
The open equipment connectors to be analytically connected.
curveIdsToConnect IList ElementId
The curves which the equipment is connected to.

Return Value

ISet ElementId
The new analytical connection elements.
Exceptions
Exception | Condition
ArgumentException | Invalid connection type. -or- Not all connectors support the analytical connection. -or- No connector included. -or- Not all elements are valid curve ids. -or- No curve included.
ArgumentNullException | A non-optional argument was null
See Also

Reference

MEPAnalyticalConnection Class


MEPAnalyticalConnection.GetFlow Method

MEPAnalyticalConnectionGetFlow Method

Gets the flow value of this analytical connection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetFlow()
Public Function GetFlow As Double
public:
double GetFlow()
member GetFlow : unit -> float

Return Value

Double
The flow value.
Remarks
If the network flow is asynchronously calculated, this method would wait until the calculation is completed. This ensures the returned flow value is always up to date.
See Also

Reference

MEPAnalyticalConnection Class


MEPAnalyticalConnectionType Class

Represents an analytical connection type between mechanical equipment and piping network.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBMEPAnalyticalConnectionType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MEPAnalyticalConnectionType : ElementType
Public Class MEPAnalyticalConnectionType
    Inherits ElementType
public ref class MEPAnalyticalConnectionType : public ElementType
type MEPAnalyticalConnectionType =
    class
        inherit ElementType
    end

The MEPAnalyticalConnectionType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | PressureLoss | The pressure loss of this analytical connection type.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates an analytical connection type element.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
 | FindTypeByName | Finds the analytical connection type by its name.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
 | IsNameUnused | Checks if this is an unused name.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


MEPAnalyticalConnectionType Properties

The MEPAnalyticalConnectionType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | PressureLoss | The pressure loss of this analytical connection type.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

MEPAnalyticalConnectionType Class


MEPAnalyticalConnectionType.PressureLoss Property

MEPAnalyticalConnectionTypePressureLoss Property

The pressure loss of this analytical connection type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double PressureLoss { get; set; }
Public Property PressureLoss As Double
    Get
    Set
public:
property double PressureLoss {
    double get ();
    void set (double value);
}
member PressureLoss : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The given value for pressureLoss must be non-negative.
See Also

Reference

MEPAnalyticalConnectionType Class


MEPAnalyticalConnectionType Methods

The MEPAnalyticalConnectionType type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates an analytical connection type element.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
 | FindTypeByName | Finds the analytical connection type by its name.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
 | IsNameUnused | Checks if this is an unused name.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MEPAnalyticalConnectionType Class


MEPAnalyticalConnectionType.Create Method

MEPAnalyticalConnectionTypeCreate Method

Creates an analytical connection type element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static MEPAnalyticalConnectionType Create(
    Document doc,
    string name
)
Public Shared Function Create (
    doc As Document,
    name As String
) As MEPAnalyticalConnectionType
public:
static MEPAnalyticalConnectionType^ Create(
    Document^ doc,
    String^ name
)
static member Create :
        doc : Document *
        name : string -> MEPAnalyticalConnectionType

Parameters

doc Document
The document.
name String
The name of the analytical type to be created.

Return Value

MEPAnalyticalConnectionType
The created analytical connection type element.
Exceptions
Exception | Condition
ArgumentException | This name is already used by an existing analytical connection type in the document. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- name is an empty string.
ArgumentNullException | A non-optional argument was null
Remarks
The newly created type would have the default pressure loss being 0. Use ElementType.duplicate to copy from any existing type.
See Also

Reference

MEPAnalyticalConnectionType Class


MEPAnalyticalConnectionType.FindTypeByName Method

MEPAnalyticalConnectionTypeFindTypeByName Method

Finds the analytical connection type by its name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ElementId FindTypeByName(
    Document doc,
    string name
)
Public Shared Function FindTypeByName (
    doc As Document,
    name As String
) As ElementId
public:
static ElementId^ FindTypeByName(
    Document^ doc,
    String^ name
)
static member FindTypeByName :
        doc : Document *
        name : string -> ElementId

Parameters

doc Document
The document where the analytical conneciton type is expected.
name String
The name of the expected analytical connection type.

Return Value

ElementId
The element id of matched analytical connection type, otherwise invalidElementId.
Exceptions
Exception | Condition
ArgumentException | name is an empty string.
ArgumentNullException | A non-optional argument was null
See Also

Reference

MEPAnalyticalConnectionType Class


MEPAnalyticalConnectionType.IsNameUnused Method

MEPAnalyticalConnectionTypeIsNameUnused Method

Checks if this is an unused name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsNameUnused(
    Document doc,
    string name
)
Public Shared Function IsNameUnused (
    doc As Document,
    name As String
) As Boolean
public:
static bool IsNameUnused(
    Document^ doc,
    String^ name
)
static member IsNameUnused :
        doc : Document *
        name : string -> bool

Parameters

doc Document
The document.
name String
The name to be verified.

Return Value

Boolean
True if not used by an existing analytical connection type in this document, false if used.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

MEPAnalyticalConnectionType Class


MEPCalculationServerInfo Class

a struct to hold the information about a MEP calucation servers
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBMEPCalculationServerInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MEPCalculationServerInfo : IDisposable
Public Class MEPCalculationServerInfo
    Implements IDisposable
public ref class MEPCalculationServerInfo : IDisposable
type MEPCalculationServerInfo =
    class
        interface IDisposable
    end

The MEPCalculationServerInfo type exposes the following members.

Constructors
 | Name | Description
Public method | MEPCalculationServerInfo | Constructs a new MEPCalculationServerInfo with default settings.
Public method | MEPCalculationServerInfo(IExternalServer) | Create a new MEPCalculationServerInfo by an external server.
Public method | MEPCalculationServerInfo(MEPCalculationServerInfo) | Constructs a new copy of the input MEPCalculationServerInfo object.
Top
Properties
 | Name | Description
Public property | Description | The Description of the server.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
 | PipeUseDefinitionOnTypeGUID | The guid value ("3BF616F9-6B98-4A21-80FF-DA1120C8F6D6") of Use Definition On Type. It is not a server id, but a guid to tell if the loss method is "Use Definition On Type" or not. If the loss method is "Use Definition On Type", we use the loss method of the family type to calculate.
Public property | ServerId | The Id of the server.
Public property | ServerName | The Name of the server.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the MEPCalculationServerInfo
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
 | GetMEPCalculationServerInfo | Gets a MEPCalculationServerInfo by family instance.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


MEPCalculationServerInfo Constructor

Overload List
 | Name | Description
Public method | MEPCalculationServerInfo | Constructs a new MEPCalculationServerInfo with default settings.
Public method | MEPCalculationServerInfo(IExternalServer) | Create a new MEPCalculationServerInfo by an external server.
Public method | MEPCalculationServerInfo(MEPCalculationServerInfo) | Constructs a new copy of the input MEPCalculationServerInfo object.
Top
See Also

Reference

MEPCalculationServerInfo Class


MEPCalculationServerInfo Constructor

Constructs a new MEPCalculationServerInfo with default settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MEPCalculationServerInfo()
Public Sub New
public:
MEPCalculationServerInfo()
new : unit -> MEPCalculationServerInfo
See Also

Reference

MEPCalculationServerInfo Class
MEPCalculationServerInfo Overload


MEPCalculationServerInfo(IExternalServer) Constructor

Create a new MEPCalculationServerInfo by an external server.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MEPCalculationServerInfo(
    IExternalServer server
)
Public Sub New (
    server As IExternalServer
)
public:
MEPCalculationServerInfo(
    IExternalServer^ server
)
new :
        server : IExternalServer -> MEPCalculationServerInfo

Parameters

server IExternalServer
The external server.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

MEPCalculationServerInfo Class
MEPCalculationServerInfo Overload


MEPCalculationServerInfo(MEPCalculationServerInfo) Constructor

Constructs a new copy of the input MEPCalculationServerInfo object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MEPCalculationServerInfo(
    MEPCalculationServerInfo other
)
Public Sub New (
    other As MEPCalculationServerInfo
)
public:
MEPCalculationServerInfo(
    MEPCalculationServerInfo^ other
)
new :
        other : MEPCalculationServerInfo -> MEPCalculationServerInfo

Parameters

other MEPCalculationServerInfo
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

MEPCalculationServerInfo Class
MEPCalculationServerInfo Overload


MEPCalculationServerInfo Properties

The MEPCalculationServerInfo type exposes the following members.

Properties
 | Name | Description
Public property | Description | The Description of the server.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
 | PipeUseDefinitionOnTypeGUID | The guid value ("3BF616F9-6B98-4A21-80FF-DA1120C8F6D6") of Use Definition On Type. It is not a server id, but a guid to tell if the loss method is "Use Definition On Type" or not. If the loss method is "Use Definition On Type", we use the loss method of the family type to calculate.
Public property | ServerId | The Id of the server.
Public property | ServerName | The Name of the server.
Top
See Also

Reference

MEPCalculationServerInfo Class


MEPCalculationServerInfo.Description Property

MEPCalculationServerInfoDescription Property

The Description of the server.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

MEPCalculationServerInfo Class


MEPCalculationServerInfo.IsValidObject Property

MEPCalculationServerInfoIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

MEPCalculationServerInfo Class


MEPCalculationServerInfo.PipeUseDefinitionOnTypeGUID Property

MEPCalculationServerInfoPipeUseDefinitionOnTypeGUID Property

The guid value ("3BF616F9-6B98-4A21-80FF-DA1120C8F6D6") of Use Definition On Type. It is not a server id, but a guid to tell if the loss method is "Use Definition On Type" or not. If the loss method is "Use Definition On Type", we use the loss method of the family type to calculate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Guid PipeUseDefinitionOnTypeGUID { get; }
Public Shared ReadOnly Property PipeUseDefinitionOnTypeGUID As Guid
    Get
public:
static property Guid PipeUseDefinitionOnTypeGUID {
    Guid get ();
}
static member PipeUseDefinitionOnTypeGUID : Guid with get

Property Value

Guid
See Also

Reference

MEPCalculationServerInfo Class


MEPCalculationServerInfo.ServerId Property

MEPCalculationServerInfoServerId Property

The Id of the server.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid ServerId { get; set; }
Public Property ServerId As Guid
    Get
    Set
public:
property Guid ServerId {
    Guid get ();
    void set (Guid value);
}
member ServerId : Guid with get, set

Property Value

Guid
See Also

Reference

MEPCalculationServerInfo Class


MEPCalculationServerInfo.ServerName Property

MEPCalculationServerInfoServerName Property

The Name of the server.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ServerName { get; set; }
Public Property ServerName As String
    Get
    Set
public:
property String^ ServerName {
    String^ get ();
    void set (String^ value);
}
member ServerName : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

MEPCalculationServerInfo Class


MEPCalculationServerInfo Methods

The MEPCalculationServerInfo type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
 | GetMEPCalculationServerInfo | Gets a MEPCalculationServerInfo by family instance.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MEPCalculationServerInfo Class


MEPCalculationServerInfo.Dispose Method

MEPCalculationServerInfoDispose Method

Releases all resources used by the MEPCalculationServerInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

MEPCalculationServerInfo Class


MEPCalculationServerInfo.GetMEPCalculationServerInfo Method

MEPCalculationServerInfoGetMEPCalculationServerInfo Method

Gets a MEPCalculationServerInfo by family instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static MEPCalculationServerInfo GetMEPCalculationServerInfo(
    FamilyInstance famInst
)
Public Shared Function GetMEPCalculationServerInfo (
    famInst As FamilyInstance
) As MEPCalculationServerInfo
public:
static MEPCalculationServerInfo^ GetMEPCalculationServerInfo(
    FamilyInstance^ famInst
)
static member GetMEPCalculationServerInfo :
        famInst : FamilyInstance -> MEPCalculationServerInfo

Parameters

famInst FamilyInstance
The family instance.

Return Value

MEPCalculationServerInfo
The MEPCalculationServerInfo.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

MEPCalculationServerInfo Class


MEPConnectorInfo Class

MEP connector information.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBMEPConnectorInfo
Autodesk.Revit.DBMEPFamilyConnectorInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MEPConnectorInfo : IDisposable
Public Class MEPConnectorInfo
    Implements IDisposable
public ref class MEPConnectorInfo : IDisposable
type MEPConnectorInfo =
    class
        interface IDisposable
    end

The MEPConnectorInfo type exposes the following members.

Properties
 | Name | Description
Public property | IsPrimary | True if this is the primary connector.
Public property | IsSecondary | True if this is the secondary connector.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LinkedConnector | The linked connector or if there is no linked connector
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the MEPConnectorInfo
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


MEPConnectorInfo Properties

The MEPConnectorInfo type exposes the following members.

Properties
 | Name | Description
Public property | IsPrimary | True if this is the primary connector.
Public property | IsSecondary | True if this is the secondary connector.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LinkedConnector | The linked connector or if there is no linked connector
Top
See Also

Reference

MEPConnectorInfo Class


MEPConnectorInfo.IsPrimary Property

MEPConnectorInfoIsPrimary Property

True if this is the primary connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsPrimary { get; }
Public ReadOnly Property IsPrimary As Boolean
    Get
public:
property bool IsPrimary {
    bool get ();
}
member IsPrimary : bool with get

Property Value

Boolean
See Also

Reference

MEPConnectorInfo Class


MEPConnectorInfo.IsSecondary Property

MEPConnectorInfoIsSecondary Property

True if this is the secondary connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSecondary { get; }
Public ReadOnly Property IsSecondary As Boolean
    Get
public:
property bool IsSecondary {
    bool get ();
}
member IsSecondary : bool with get

Property Value

Boolean
See Also

Reference

MEPConnectorInfo Class


MEPConnectorInfo.IsValidObject Property

MEPConnectorInfoIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

MEPConnectorInfo Class


MEPConnectorInfo.LinkedConnector Property

MEPConnectorInfoLinkedConnector Property

The linked connector or if there is no linked connector

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Connector LinkedConnector { get; }
Public ReadOnly Property LinkedConnector As Connector
    Get
public:
property Connector^ LinkedConnector {
    Connector^ get ();
}
member LinkedConnector : Connector with get

Property Value

Connector
See Also

Reference

MEPConnectorInfo Class


MEPConnectorInfo Methods

The MEPConnectorInfo type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MEPConnectorInfo Class


MEPConnectorInfo.Dispose Method

MEPConnectorInfoDispose Method

Releases all resources used by the MEPConnectorInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

MEPConnectorInfo Class


MEPCurve Class

A curve object for duct or pipe blend elements.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBHostObject
Autodesk.Revit.DBMEPCurve
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MEPCurve : HostObject
Public Class MEPCurve
    Inherits HostObject
public ref class MEPCurve : public HostObject
type MEPCurve =
    class
        inherit HostObject
    end

The MEPCurve type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | ConnectorManager | The connector manager of this MEP curve.
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Diameter | The diameter of the MEP curve.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | Height | The height of the MEP curve.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LevelOffset | The offset of the MEP curve.
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | MEPSystem | The system of the MEP curve.
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ReferenceLevel | The reference level of the MEP curve.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | Width | The width of the MEP curve.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The curve object is only available in the Autodesk Revit MEP product.
See Also

Reference

Autodesk.Revit.DB Namespace
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBHostObject
Autodesk.Revit.DBMEPCurve
Autodesk.Revit.DB.ElectricalCableTrayConduitBase
Autodesk.Revit.DB.ElectricalWire
Autodesk.Revit.DBInsulationLiningBase
Autodesk.Revit.DB.MechanicalDuct
Autodesk.Revit.DB.MechanicalFlexDuct
Autodesk.Revit.DBMEPAnalyticalConnection
Autodesk.Revit.DB.PlumbingFlexPipe
Autodesk.Revit.DB.PlumbingPipe


MEPCurve Properties

The MEPCurve type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | ConnectorManager | The connector manager of this MEP curve.
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Diameter | The diameter of the MEP curve.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | Height | The height of the MEP curve.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LevelOffset | The offset of the MEP curve.
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | MEPSystem | The system of the MEP curve.
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ReferenceLevel | The reference level of the MEP curve.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | Width | The width of the MEP curve.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

MEPCurve Class


MEPCurve.ConnectorManager Property

MEPCurveConnectorManager Property

The connector manager of this MEP curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConnectorManager ConnectorManager { get; }
Public ReadOnly Property ConnectorManager As ConnectorManager
    Get
public:
property ConnectorManager^ ConnectorManager {
    ConnectorManager^ get ();
}
member ConnectorManager : ConnectorManager with get

Property Value

ConnectorManager
See Also

Reference

MEPCurve Class


MEPCurve.Diameter Property

MEPCurveDiameter Property

The diameter of the MEP curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Diameter { get; }
Public ReadOnly Property Diameter As Double
    Get
public:
property double Diameter {
    double get ();
}
member Diameter : float with get

Property Value

Double
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the MEP curve's Shape is not round.
Remarks
This property is used to retrieve the diameter of the MEP curve.
See Also

Reference

MEPCurve Class


MEPCurve.Height Property

MEPCurveHeight Property

The height of the MEP curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Height { get; }
Public ReadOnly Property Height As Double
    Get
public:
property double Height {
    double get ();
}
member Height : float with get

Property Value

Double
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the MEP curve's Shape is not rectangular.
Remarks
This property is used to retrieve the height of the MEP curve.
See Also

Reference

MEPCurve Class


MEPCurve.LevelOffset Property

MEPCurveLevelOffset Property

The offset of the MEP curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double LevelOffset { get; set; }
Public Property LevelOffset As Double
    Get
    Set
public:
property double LevelOffset {
    double get ();
    void set (double value);
}
member LevelOffset : float with get, set

Property Value

Double
Remarks
This property is used to retrieve the offset of the MEP curve. If the curve is not in a horizontal plane, this value will be the start point's offset.
See Also

Reference

MEPCurve Class


MEPCurve.MEPSystem Property

MEPCurveMEPSystem Property

The system of the MEP curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MEPSystem MEPSystem { get; }
Public ReadOnly Property MEPSystem As MEPSystem
    Get
public:
property MEPSystem^ MEPSystem {
    MEPSystem^ get ();
}
member MEPSystem : MEPSystem with get

Property Value

MEPSystem
Remarks
Returns the system of this MEP curve. If the curve does not belong to any systems, the value will be . If the curve belongs to more than one system, the first available value is returned.
See Also

Reference

MEPCurve Class


MEPCurve.ReferenceLevel Property

MEPCurveReferenceLevel Property

The reference level of the MEP curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Level ReferenceLevel { get; set; }
Public Property ReferenceLevel As Level
    Get
    Set
public:
property Level^ ReferenceLevel {
    Level^ get ();
    void set (Level^ value);
}
member ReferenceLevel : Level with get, set

Property Value

Level
Remarks
This property is used to retrieve the reference level of the MEP curve. If the curve is not in a horizontal plane, this value will be the start point's reference level.
See Also

Reference

MEPCurve Class


MEPCurve.Width Property

MEPCurveWidth Property

The width of the MEP curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Width { get; }
Public ReadOnly Property Width As Double
    Get
public:
property double Width {
    double get ();
}
member Width : float with get

Property Value

Double
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the MEP curve's shape is not rectangular.
Remarks
This property is used to retrieve the width of the MEP curve.
See Also

Reference

MEPCurve Class


MEPCurve Methods

The MEPCurve type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MEPCurve Class


MEPCurveType Class

The base type class for MEP curves, such as ducts, pipes, cable trays and conduits.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBHostObjAttributes
Autodesk.Revit.DBMEPCurveType
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MEPCurveType : HostObjAttributes
Public Class MEPCurveType
    Inherits HostObjAttributes
public ref class MEPCurveType : public HostObjAttributes
type MEPCurveType =
    class
        inherit HostObjAttributes
    end

The MEPCurveType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | Cross | The default cross fitting of the MEP curve type.
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | Elbow | The default elbow fitting of the MEP curve type.
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | MultiShapeTransition | The default multi shape transition fitting of the MEP curve type.
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | PreferredJunctionType | The preferred junction type of the MEP curve type.
Public property | Roughness | The roughness of the MEP curve type. For PipeTypes, please use Segment::Roughness
Public property | RoutingPreferenceManager | The RoutingPreferenceManager for the MEPCurveType
Public property | Shape | The shape of the profile.
Public property | Tap | The default tap fitting of the MEP curve type.
Public property | Tee | The default tee fitting of the MEP curve type.
Public property | Transition | The default transition fitting of the MEP curve type.
Public property | Union | The default union fitting of the MEP curve type.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBHostObjAttributes
Autodesk.Revit.DBMEPCurveType
Autodesk.Revit.DB.ElectricalCableTrayType
Autodesk.Revit.DB.ElectricalConduitType
Autodesk.Revit.DB.MechanicalDuctType
Autodesk.Revit.DB.MechanicalFlexDuctType
Autodesk.Revit.DB.PlumbingFlexPipeType
Autodesk.Revit.DB.PlumbingPipeType


MEPCurveType Properties

The MEPCurveType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | Cross | The default cross fitting of the MEP curve type.
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | Elbow | The default elbow fitting of the MEP curve type.
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | MultiShapeTransition | The default multi shape transition fitting of the MEP curve type.
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | PreferredJunctionType | The preferred junction type of the MEP curve type.
Public property | Roughness | The roughness of the MEP curve type. For PipeTypes, please use Segment::Roughness
Public property | RoutingPreferenceManager | The RoutingPreferenceManager for the MEPCurveType
Public property | Shape | The shape of the profile.
Public property | Tap | The default tap fitting of the MEP curve type.
Public property | Tee | The default tee fitting of the MEP curve type.
Public property | Transition | The default transition fitting of the MEP curve type.
Public property | Union | The default union fitting of the MEP curve type.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

MEPCurveType Class


MEPCurveType.Cross Property

MEPCurveTypeCross Property

The default cross fitting of the MEP curve type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilySymbol Cross { get; set; }
Public Property Cross As FamilySymbol
    Get
    Set
public:
property FamilySymbol^ Cross {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}
member Cross : FamilySymbol with get, set

Property Value

FamilySymbol
Remarks
This property is used to retrieve the default cross fitting of the MEP curve type, and can be if there is no default value. Use RoutingPreferenceManager to set this property for PipeType MEPCurves.
See Also

Reference

MEPCurveType Class


MEPCurveType.Elbow Property

MEPCurveTypeElbow Property

The default elbow fitting of the MEP curve type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilySymbol Elbow { get; set; }
Public Property Elbow As FamilySymbol
    Get
    Set
public:
property FamilySymbol^ Elbow {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}
member Elbow : FamilySymbol with get, set

Property Value

FamilySymbol
Remarks
This property is used to retrieve the default elbow fitting of the MEP curve type, and can be if there is no default value. Use RoutingPreferenceManager to set this property for PipeType MEPCurves.
See Also

Reference

MEPCurveType Class


MEPCurveType.MultiShapeTransition Property

MEPCurveTypeMultiShapeTransition Property

The default multi shape transition fitting of the MEP curve type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilySymbol MultiShapeTransition { get; set; }
Public Property MultiShapeTransition As FamilySymbol
    Get
    Set
public:
property FamilySymbol^ MultiShapeTransition {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}
member MultiShapeTransition : FamilySymbol with get, set

Property Value

FamilySymbol
Remarks
This property is used to retrieve the default multi shape transition fitting of the MEP curve type, and can be if there is no default value. Use RoutingPreferenceManager to set this property for PipeType MEPCurves.
See Also

Reference

MEPCurveType Class


MEPCurveType.PreferredJunctionType Property

MEPCurveTypePreferredJunctionType Property

The preferred junction type of the MEP curve type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public JunctionType PreferredJunctionType { get; set; }
Public Property PreferredJunctionType As JunctionType
    Get
    Set
public:
property JunctionType PreferredJunctionType {
    JunctionType get ();
    void set (JunctionType value);
}
member PreferredJunctionType : JunctionType with get, set

Property Value

JunctionType
Remarks
Use RoutingPreferenceManager to set this property for PipeType MEPCurves.
See Also

Reference

MEPCurveType Class


MEPCurveType.Roughness Property

MEPCurveTypeRoughness Property

The roughness of the MEP curve type. For PipeTypes, please use Segment::Roughness

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Roughness { get; set; }
Public Property Roughness As Double
    Get
    Set
public:
property double Roughness {
    double get ();
    void set (double value);
}
member Roughness : float with get, set

Property Value

Double
See Also

Reference

MEPCurveType Class


MEPCurveType.RoutingPreferenceManager Property

MEPCurveTypeRoutingPreferenceManager Property

The RoutingPreferenceManager for the MEPCurveType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RoutingPreferenceManager RoutingPreferenceManager { get; }
Public ReadOnly Property RoutingPreferenceManager As RoutingPreferenceManager
    Get
public:
property RoutingPreferenceManager^ RoutingPreferenceManager {
    RoutingPreferenceManager^ get ();
}
member RoutingPreferenceManager : RoutingPreferenceManager with get

Property Value

RoutingPreferenceManager
See Also

Reference

MEPCurveType Class


MEPCurveType.Shape Property

MEPCurveTypeShape Property

The shape of the profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConnectorProfileType Shape { get; }
Public ReadOnly Property Shape As ConnectorProfileType
    Get
public:
property ConnectorProfileType Shape {
    ConnectorProfileType get ();
}
member Shape : ConnectorProfileType with get

Property Value

ConnectorProfileType
See Also

Reference

MEPCurveType Class


MEPCurveType.Tap Property

MEPCurveTypeTap Property

The default tap fitting of the MEP curve type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilySymbol Tap { get; set; }
Public Property Tap As FamilySymbol
    Get
    Set
public:
property FamilySymbol^ Tap {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}
member Tap : FamilySymbol with get, set

Property Value

FamilySymbol
Remarks
This property is used to retrieve the default tap fitting of the MEP curve type, and can be if there is no default value. Use RoutingPreferenceManager to set this property for PipeType MEPCurves.
See Also

Reference

MEPCurveType Class


MEPCurveType.Tee Property

MEPCurveTypeTee Property

The default tee fitting of the MEP curve type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilySymbol Tee { get; set; }
Public Property Tee As FamilySymbol
    Get
    Set
public:
property FamilySymbol^ Tee {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}
member Tee : FamilySymbol with get, set

Property Value

FamilySymbol
Remarks
This property is used to retrieve the default tee fitting of the MEP curve type, and can be if there is no default value. Use RoutingPreferenceManager to set this property for PipeType MEPCurves.
See Also

Reference

MEPCurveType Class


MEPCurveType.Transition Property

MEPCurveTypeTransition Property

The default transition fitting of the MEP curve type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilySymbol Transition { get; set; }
Public Property Transition As FamilySymbol
    Get
    Set
public:
property FamilySymbol^ Transition {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}
member Transition : FamilySymbol with get, set

Property Value

FamilySymbol
Remarks
This property is used to retrieve the default transition fitting of the MEP curve type, and can be if there is no default value. Use RoutingPreferenceManager to set this property for PipeType MEPCurves.
See Also

Reference

MEPCurveType Class


MEPCurveType.Union Property

MEPCurveTypeUnion Property

The default union fitting of the MEP curve type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilySymbol Union { get; set; }
Public Property Union As FamilySymbol
    Get
    Set
public:
property FamilySymbol^ Union {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}
member Union : FamilySymbol with get, set

Property Value

FamilySymbol
Remarks
This property is used to retrieve the default union fitting of the MEP curve type, and can be if there is no default value. Use RoutingPreferenceManager to set this property for PipeType MEPCurves.
See Also

Reference

MEPCurveType Class


MEPCurveType Methods

The MEPCurveType type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MEPCurveType Class


MEPFamilyConnectorInfo Class

MEP family connector information.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBMEPConnectorInfo
Autodesk.Revit.DBMEPFamilyConnectorInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MEPFamilyConnectorInfo : MEPConnectorInfo
Public Class MEPFamilyConnectorInfo
    Inherits MEPConnectorInfo
public ref class MEPFamilyConnectorInfo : public MEPConnectorInfo
type MEPFamilyConnectorInfo =
    class
        inherit MEPConnectorInfo
    end

The MEPFamilyConnectorInfo type exposes the following members.

Properties
 | Name | Description
Public property | IsPrimary | True if this is the primary connector. (Inherited from MEPConnectorInfo)
Public property | IsSecondary | True if this is the secondary connector. (Inherited from MEPConnectorInfo)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from MEPConnectorInfo)
Public property | LinkedConnector | The linked connector or if there is no linked connector (Inherited from MEPConnectorInfo)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from MEPConnectorInfo)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAssociateFamilyParameterId | Gets the associate family parameter id of the specified connector parameter id.
Public method | GetConnectorParameterValue | Gets the parameter value of the specified connector parameter id.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


MEPFamilyConnectorInfo Properties

The MEPFamilyConnectorInfo type exposes the following members.

Properties
 | Name | Description
Public property | IsPrimary | True if this is the primary connector. (Inherited from MEPConnectorInfo)
Public property | IsSecondary | True if this is the secondary connector. (Inherited from MEPConnectorInfo)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from MEPConnectorInfo)
Public property | LinkedConnector | The linked connector or if there is no linked connector (Inherited from MEPConnectorInfo)
Top
See Also

Reference

MEPFamilyConnectorInfo Class


MEPFamilyConnectorInfo Methods

The MEPFamilyConnectorInfo type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from MEPConnectorInfo)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAssociateFamilyParameterId | Gets the associate family parameter id of the specified connector parameter id.
Public method | GetConnectorParameterValue | Gets the parameter value of the specified connector parameter id.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MEPFamilyConnectorInfo Class


MEPFamilyConnectorInfo.GetAssociateFamilyParameterId Method

MEPFamilyConnectorInfoGetAssociateFamilyParameterId Method

Gets the associate family parameter id of the specified connector parameter id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GetAssociateFamilyParameterId(
    ElementId connectorParameterId
)
Public Function GetAssociateFamilyParameterId (
    connectorParameterId As ElementId
) As ElementId
public:
ElementId^ GetAssociateFamilyParameterId(
    ElementId^ connectorParameterId
)
member GetAssociateFamilyParameterId :
        connectorParameterId : ElementId -> ElementId

Parameters

connectorParameterId ElementId
connectorParameterId is defined in the family connector element.

Return Value

ElementId
Returns valid ElementId if the connectorParameterId associates to one family parameter; otherwise returns invalid ElementId.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

MEPFamilyConnectorInfo Class


MEPFamilyConnectorInfo.GetConnectorParameterValue Method

MEPFamilyConnectorInfoGetConnectorParameterValue Method

Gets the parameter value of the specified connector parameter id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ParameterValue GetConnectorParameterValue(
    ElementId connectorParameterId
)
Public Function GetConnectorParameterValue (
    connectorParameterId As ElementId
) As ParameterValue
public:
ParameterValue^ GetConnectorParameterValue(
    ElementId^ connectorParameterId
)
member GetConnectorParameterValue :
        connectorParameterId : ElementId -> ParameterValue

Parameters

connectorParameterId ElementId
connectorParameterId is defined in the family connector element.

Return Value

ParameterValue
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

MEPFamilyConnectorInfo Class


MEPModel Class

Supports all MEP models that are persistent within the Autodesk Revit project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBMEPModel
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MEPModel : APIObject
Public Class MEPModel
    Inherits APIObject
public ref class MEPModel : public APIObject
type MEPModel =
    class
        inherit APIObject
    end

The MEPModel type exposes the following members.

Properties
 | Name | Description
Public property | ConnectorManager | Retrieves the Connector Manager from this MEPModel.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAssignedElectricalSystems | Retrieves the electrical systems this electrical panel currently is assigned to.
Public method | GetElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBMEPModel
Autodesk.Revit.DB.ElectricalElectricalEquipment
Autodesk.Revit.DB.ElectricalLightingDevice
Autodesk.Revit.DB.ElectricalLightingFixture
Autodesk.Revit.DB.MechanicalMechanicalEquipment
Autodesk.Revit.DB.MechanicalMechanicalFitting


MEPModel Properties

The MEPModel type exposes the following members.

Properties
 | Name | Description
Public property | ConnectorManager | Retrieves the Connector Manager from this MEPModel.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

MEPModel Class


MEPModel.ConnectorManager Property

MEPModelConnectorManager Property

Retrieves the Connector Manager from this MEPModel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConnectorManager ConnectorManager { get; }
Public ReadOnly Property ConnectorManager As ConnectorManager
    Get
public:
property ConnectorManager^ ConnectorManager {
    ConnectorManager^ get ();
}
member ConnectorManager : ConnectorManager with get

Property Value

ConnectorManager
See Also

Reference

MEPModel Class


MEPModel.IsValidObject Property

MEPModelIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

MEPModel Class


MEPModel Methods

The MEPModel type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAssignedElectricalSystems | Retrieves the electrical systems this electrical panel currently is assigned to.
Public method | GetElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MEPModel Class


MEPModel.GetAssignedElectricalSystems Method

MEPModelGetAssignedElectricalSystems Method

Retrieves the electrical systems this electrical panel currently is assigned to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ISet<ElectricalSystem> GetAssignedElectricalSystems()
Public Function GetAssignedElectricalSystems As ISet(Of ElectricalSystem)
public:
ISet<ElectricalSystem^>^ GetAssignedElectricalSystems()
member GetAssignedElectricalSystems : unit -> ISet<ElectricalSystem>

Return Value

ISet ElectricalSystem
Remarks
This property returns a set of Electrical Systems. If there are no electrical systems created for this model, this property will be an empty set. This method supersedes an older AssignedElectricalSystems property which has been deprecated.
See Also

Reference

MEPModel Class


MEPModel.GetElectricalSystems Method

MEPModelGetElectricalSystems Method

Retrieves the electrical systems that are currently created using this MEPModel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ISet<ElectricalSystem> GetElectricalSystems()
Public Function GetElectricalSystems As ISet(Of ElectricalSystem)
public:
ISet<ElectricalSystem^>^ GetElectricalSystems()
member GetElectricalSystems : unit -> ISet<ElectricalSystem>

Return Value

ISet ElectricalSystem
Remarks
This property returns a set of Electrical Systems. If there are no electrical systems created for this model, this property will be an empty set. This method supersedes an older ElectricalSystems property which has been deprecated.
See Also

Reference

MEPModel Class


MEPSize Class

Stores the basic size information for an MEP duct, pipe, cable tray, or conduit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBMEPSize

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MEPSize : IDisposable
Public Class MEPSize
    Implements IDisposable
public ref class MEPSize : IDisposable
type MEPSize =
    class
        interface IDisposable
    end

The MEPSize type exposes the following members.

Constructors
 | Name | Description
Public method | MEPSize | Constructs an object that stores the basic size information for MEP duct, pipe, cable tray and conduit.
Top
Properties
 | Name | Description
Public property | InnerDiameter | Inner diameter
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NominalDiameter | Nominal diameter
Public property | OuterDiameter | Outer diameter
Public property | UsedInSizeLists | Whether it is used in size lists.
Public property | UsedInSizing | Whether is used in sizing.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the MEPSize
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


MEPSize Constructor

Constructs an object that stores the basic size information for MEP duct, pipe, cable tray and conduit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MEPSize(
    double nominalDiameter,
    double innerDiameter,
    double outerDiameter,
    bool usedInSizeLists,
    bool usedInSizing
)
Public Sub New (
    nominalDiameter As Double,
    innerDiameter As Double,
    outerDiameter As Double,
    usedInSizeLists As Boolean,
    usedInSizing As Boolean
)
public:
MEPSize(
    double nominalDiameter,
    double innerDiameter,
    double outerDiameter,
    bool usedInSizeLists,
    bool usedInSizing
)
new :
        nominalDiameter : float *
        innerDiameter : float *
        outerDiameter : float *
        usedInSizeLists : bool *
        usedInSizing : bool -> MEPSize

Parameters

nominalDiameter Double
Nominal diameter. The value should be a valid, positive Revit length.
innerDiameter Double
Inner diameter. The value should be a valid, positive Revit length.
outerDiameter Double
Outer diameter. The value should be a valid, positive Revit length.
usedInSizeLists Boolean
Whether it is used in size lists.
usedInSizing Boolean
Whether is used in sizing.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The given value for nominalDiameter must be greater than 0 and no more than 30000 feet. -or- The given value for innerDiameter must be greater than 0 and no more than 30000 feet. -or- The given value for outerDiameter must be greater than 0 and no more than 30000 feet.
See Also

Reference

MEPSize Class


MEPSize Properties

The MEPSize type exposes the following members.

Properties
 | Name | Description
Public property | InnerDiameter | Inner diameter
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NominalDiameter | Nominal diameter
Public property | OuterDiameter | Outer diameter
Public property | UsedInSizeLists | Whether it is used in size lists.
Public property | UsedInSizing | Whether is used in sizing.
Top
See Also

Reference

MEPSize Class


MEPSize.InnerDiameter Property

MEPSizeInnerDiameter Property

Inner diameter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double InnerDiameter { get; }
Public ReadOnly Property InnerDiameter As Double
    Get
public:
property double InnerDiameter {
    double get ();
}
member InnerDiameter : float with get

Property Value

Double
See Also

Reference

MEPSize Class


MEPSize.IsValidObject Property

MEPSizeIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

MEPSize Class


MEPSize.NominalDiameter Property

MEPSizeNominalDiameter Property

Nominal diameter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double NominalDiameter { get; }
Public ReadOnly Property NominalDiameter As Double
    Get
public:
property double NominalDiameter {
    double get ();
}
member NominalDiameter : float with get

Property Value

Double
See Also

Reference

MEPSize Class


MEPSize.OuterDiameter Property

MEPSizeOuterDiameter Property

Outer diameter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double OuterDiameter { get; }
Public ReadOnly Property OuterDiameter As Double
    Get
public:
property double OuterDiameter {
    double get ();
}
member OuterDiameter : float with get

Property Value

Double
See Also

Reference

MEPSize Class


MEPSize.UsedInSizeLists Property

MEPSizeUsedInSizeLists Property

Whether it is used in size lists.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UsedInSizeLists { get; }
Public ReadOnly Property UsedInSizeLists As Boolean
    Get
public:
property bool UsedInSizeLists {
    bool get ();
}
member UsedInSizeLists : bool with get

Property Value

Boolean
See Also

Reference

MEPSize Class


MEPSize.UsedInSizing Property

MEPSizeUsedInSizing Property

Whether is used in sizing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UsedInSizing { get; }
Public ReadOnly Property UsedInSizing As Boolean
    Get
public:
property bool UsedInSizing {
    bool get ();
}
member UsedInSizing : bool with get

Property Value

Boolean
See Also

Reference

MEPSize Class


MEPSize Methods

The MEPSize type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MEPSize Class


MEPSize.Dispose Method

MEPSizeDispose Method

Releases all resources used by the MEPSize

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

MEPSize Class


MEPSupportUtils Class

General utility methods for the Autodesk Revit MEP Supporting components.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBMEPSupportUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class MEPSupportUtils
Public NotInheritable Class MEPSupportUtils
public ref class MEPSupportUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type MEPSupportUtils = class end

The MEPSupportUtils type exposes the following members.

Methods
Name | Description
CreateDuctworkStiffener | Create family based stiffener on the specified fabrication ductwork.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


MEPSupportUtils Methods

The MEPSupportUtils type exposes the following members.

Methods
Name | Description
CreateDuctworkStiffener | Create family based stiffener on the specified fabrication ductwork.
Top
See Also

Reference

MEPSupportUtils Class


MEPSupportUtils.CreateDuctworkStiffener Method

MEPSupportUtilsCreateDuctworkStiffener Method

Create family based stiffener on the specified fabrication ductwork.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FamilyInstance CreateDuctworkStiffener(
    Document document,
    ElementId familySymbolId,
    ElementId hostId,
    double distanceFromHostEnd
)
Public Shared Function CreateDuctworkStiffener (
    document As Document,
    familySymbolId As ElementId,
    hostId As ElementId,
    distanceFromHostEnd As Double
) As FamilyInstance
public:
static FamilyInstance^ CreateDuctworkStiffener(
    Document^ document,
    ElementId^ familySymbolId,
    ElementId^ hostId,
    double distanceFromHostEnd
)
static member CreateDuctworkStiffener :
        document : Document *
        familySymbolId : ElementId *
        hostId : ElementId *
        distanceFromHostEnd : float -> FamilyInstance

Parameters

document Document
The document.
familySymbolId ElementId
The id of a stiffener FamilySymbol.
hostId ElementId
The id of the host ductwork.
distanceFromHostEnd Double
The distance from the host primary end to place the hosted instance. Units are in feet (ft).

Return Value

FamilyInstance
The new stiffener family instance.
Exceptions
Exception | Condition
ArgumentException | document is not a project document. -or- familySymbolId is not a valid Element identifier. -or- hostId is not a valid Element identifier. -or- Invalid familySymbolId for stiffeners. -or- Host is not a straight ductwork.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | The distance from host primary end is out of range.
InvalidOperationException | The profiles of family symbol and host are mismatch.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
RegenerationFailedException | Failed to create stiffener due to document regenerate error.
See Also

Reference

MEPSupportUtils Class


MEPSystem Class

A system in the Autodesk Revit MEP product.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBMEPSystem
Autodesk.Revit.DB.ElectricalElectricalSystem
Autodesk.Revit.DB.MechanicalMechanicalSystem
Autodesk.Revit.DB.PlumbingPipingSystem

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MEPSystem : Element
Public Class MEPSystem
    Inherits Element
public ref class MEPSystem : public Element
type MEPSystem =
    class
        inherit Element
    end

The MEPSystem type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | BaseEquipment | The base panel or equipment of the system.
Public property | BaseEquipmentConnector | The connector within base equipment which is used to connect with system.
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | ConnectorManager | Connector manager of the system.
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | Elements | Terminal elements in the system.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HasDesignParts | Indicates if the system has one or more design parts.
Public property | HasFabricationParts | Indicates if the system has one or more fabrication parts.
Public property | HasPlaceholders | Indicates if the system has one or more placeholders.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsEmpty | Indicates if the system is empty or not.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsMultipleNetwork | Indicates if the system is well connected or not. The flag will enable the "Divide System" button.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValid | Indicates if the system is valid or not. atom AtomValidateSystem default false
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | PressureLossOfCriticalPath | The total pressure loss of the sections in critical path.
Public property | SectionsCount | The number of sections.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | Add | Add elements into the system and connect them with the system using given connectors.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | DivideSystem | Divide the phyisical networks in the system and create a new system for each network.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetCriticalPathSectionNumbers | Obtains a list of the critical path section numbers.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPhysicalNetworksNumber | Get the physical networks number in the system.
Public method | GetSectionByIndex | Get the section from the index.
Public method | GetSectionByNumber | Get the Section from section number
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSystemDividable | Checks if the system is dividable. The system is dividable if there is more than one physical network in the system. Currently, only HVAC and piping systems support dividing.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | Remove(ConnectorSet) | Removes connectors from system.
Public method | Remove(ICollectionElementId) | Remove elements from system.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This is the base class for electrical, mechanical and piping systems, available only in the Autodesk Revit MEP product.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


MEPSystem Properties

The MEPSystem type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | BaseEquipment | The base panel or equipment of the system.
Public property | BaseEquipmentConnector | The connector within base equipment which is used to connect with system.
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | ConnectorManager | Connector manager of the system.
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | Elements | Terminal elements in the system.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HasDesignParts | Indicates if the system has one or more design parts.
Public property | HasFabricationParts | Indicates if the system has one or more fabrication parts.
Public property | HasPlaceholders | Indicates if the system has one or more placeholders.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsEmpty | Indicates if the system is empty or not.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsMultipleNetwork | Indicates if the system is well connected or not. The flag will enable the "Divide System" button.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValid | Indicates if the system is valid or not. atom AtomValidateSystem default false
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | PressureLossOfCriticalPath | The total pressure loss of the sections in critical path.
Public property | SectionsCount | The number of sections.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

MEPSystem Class


MEPSystem.BaseEquipment Property

MEPSystemBaseEquipment Property

The base panel or equipment of the system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyInstance BaseEquipment { get; }
Public ReadOnly Property BaseEquipment As FamilyInstance
    Get
public:
property FamilyInstance^ BaseEquipment {
    FamilyInstance^ get ();
}
member BaseEquipment : FamilyInstance with get

Property Value

FamilyInstance
See Also

Reference

MEPSystem Class


MEPSystem.BaseEquipmentConnector Property

MEPSystemBaseEquipmentConnector Property

The connector within base equipment which is used to connect with system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Connector BaseEquipmentConnector { get; }
Public ReadOnly Property BaseEquipmentConnector As Connector
    Get
public:
property Connector^ BaseEquipmentConnector {
    Connector^ get ();
}
member BaseEquipmentConnector : Connector with get

Return Value

Connector
Returns the connector which connects with the system within base equipment if base equipment has been assigned to system, otherwise returns .
See Also

Reference

MEPSystem Class


MEPSystem.ConnectorManager Property

MEPSystemConnectorManager Property

Connector manager of the system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConnectorManager ConnectorManager { get; }
Public ReadOnly Property ConnectorManager As ConnectorManager
    Get
public:
property ConnectorManager^ ConnectorManager {
    ConnectorManager^ get ();
}
member ConnectorManager : ConnectorManager with get

Property Value

ConnectorManager
Remarks
The connector manager includes connectors which are used to connect with terminal elements and base equipment.
See Also

Reference

MEPSystem Class


MEPSystem.Elements Property

MEPSystemElements Property

Terminal elements in the system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementSet Elements { get; }
Public ReadOnly Property Elements As ElementSet
    Get
public:
property ElementSet^ Elements {
    ElementSet^ get ();
}
member Elements : ElementSet with get

Property Value

ElementSet
Remarks
The return value is a read only collection and doesn't include the base equipment or panel.
See Also

Reference

MEPSystem Class


MEPSystem.HasDesignParts Property

MEPSystemHasDesignParts Property

Indicates if the system has one or more design parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasDesignParts { get; }
Public ReadOnly Property HasDesignParts As Boolean
    Get
public:
property bool HasDesignParts {
    bool get ();
}
member HasDesignParts : bool with get

Property Value

Boolean
See Also

Reference

MEPSystem Class


MEPSystem.HasFabricationParts Property

MEPSystemHasFabricationParts Property

Indicates if the system has one or more fabrication parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasFabricationParts { get; }
Public ReadOnly Property HasFabricationParts As Boolean
    Get
public:
property bool HasFabricationParts {
    bool get ();
}
member HasFabricationParts : bool with get

Property Value

Boolean
See Also

Reference

MEPSystem Class


MEPSystem.HasPlaceholders Property

MEPSystemHasPlaceholders Property

Indicates if the system has one or more placeholders.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasPlaceholders { get; }
Public ReadOnly Property HasPlaceholders As Boolean
    Get
public:
property bool HasPlaceholders {
    bool get ();
}
member HasPlaceholders : bool with get

Property Value

Boolean
See Also

Reference

MEPSystem Class


MEPSystem.IsEmpty Property

MEPSystemIsEmpty Property

Indicates if the system is empty or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEmpty { get; }
Public ReadOnly Property IsEmpty As Boolean
    Get
public:
property bool IsEmpty {
    bool get ();
}
member IsEmpty : bool with get

Property Value

Boolean
Remarks
returns true if the system doesn't contain any components
See Also

Reference

MEPSystem Class


MEPSystem.IsMultipleNetwork Property

MEPSystemIsMultipleNetwork Property

Indicates if the system is well connected or not. The flag will enable the "Divide System" button.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsMultipleNetwork { get; }
Public ReadOnly Property IsMultipleNetwork As Boolean
    Get
public:
property bool IsMultipleNetwork {
    bool get ();
}
member IsMultipleNetwork : bool with get

Property Value

Boolean
See Also

Reference

MEPSystem Class


MEPSystem.IsValid Property

MEPSystemIsValid Property

Indicates if the system is valid or not. atom AtomValidateSystem default false

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValid { get; }
Public ReadOnly Property IsValid As Boolean
    Get
public:
property bool IsValid {
    bool get ();
}
member IsValid : bool with get

Property Value

Boolean
See Also

Reference

MEPSystem Class


MEPSystem.PressureLossOfCriticalPath Property

MEPSystemPressureLossOfCriticalPath Property

The total pressure loss of the sections in critical path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double PressureLossOfCriticalPath { get; }
Public ReadOnly Property PressureLossOfCriticalPath As Double
    Get
public:
property double PressureLossOfCriticalPath {
    double get ();
}
member PressureLossOfCriticalPath : float with get

Property Value

Double
See Also

Reference

MEPSystem Class


MEPSystem.SectionsCount Property

MEPSystemSectionsCount Property

The number of sections.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int SectionsCount { get; }
Public ReadOnly Property SectionsCount As Integer
    Get
public:
property int SectionsCount {
    int get ();
}
member SectionsCount : int with get

Property Value

Int32
See Also

Reference

MEPSystem Class


MEPSystem Methods

The MEPSystem type exposes the following members.

Methods
 | Name | Description
Public method | Add | Add elements into the system and connect them with the system using given connectors.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | DivideSystem | Divide the phyisical networks in the system and create a new system for each network.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetCriticalPathSectionNumbers | Obtains a list of the critical path section numbers.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPhysicalNetworksNumber | Get the physical networks number in the system.
Public method | GetSectionByIndex | Get the section from the index.
Public method | GetSectionByNumber | Get the Section from section number
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSystemDividable | Checks if the system is dividable. The system is dividable if there is more than one physical network in the system. Currently, only HVAC and piping systems support dividing.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | Remove(ConnectorSet) | Removes connectors from system.
Public method | Remove(ICollectionElementId) | Remove elements from system.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MEPSystem Class


MEPSystem.Add Method

MEPSystemAdd Method

Add elements into the system and connect them with the system using given connectors.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Add(
    ConnectorSet connectors
)
Public Overridable Sub Add (
    connectors As ConnectorSet
)
public:
virtual void Add(
    ConnectorSet^ connectors
)
abstract Add :
        connectors : ConnectorSet -> unit
override Add :
        connectors : ConnectorSet -> unit

Parameters

connectors ConnectorSet
Connectors which are used to connect with the system.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument connectors is , or any connector in that collection is .
ArgumentException | Throw when any of the input connectors have been already used, or when they don't share the same domain or system type as the system.
InvalidOperationException | Thrown when the operation failed.
ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.
Remarks
Note: this method may not be called during dynamic update.
See Also

Reference

MEPSystem Class


MEPSystem.DivideSystem Method

MEPSystemDivideSystem Method

Divide the phyisical networks in the system and create a new system for each network.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> DivideSystem(
    Document ADoc
)
Public Function DivideSystem (
    ADoc As Document
) As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ DivideSystem(
    Document^ ADoc
)
member DivideSystem :
        ADoc : Document -> ICollection<ElementId>

Parameters

ADoc Document
The document.

Return Value

ICollection ElementId
The id of new created systems.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The system is not dividable.
Remarks
This function only works for Hvac and Piping system.
See Also

Reference

MEPSystem Class


MEPSystem.GetCriticalPathSectionNumbers Method

MEPSystemGetCriticalPathSectionNumbers Method

Obtains a list of the critical path section numbers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<int> GetCriticalPathSectionNumbers()
Public Function GetCriticalPathSectionNumbers As IList(Of Integer)
public:
IList<int>^ GetCriticalPathSectionNumbers()
member GetCriticalPathSectionNumbers : unit -> IList<int>

Return Value

IList Int32
The section numbers.
Remarks
The section numbers are returned in order in the direction of flow.
See Also

Reference

MEPSystem Class


MEPSystem.GetPhysicalNetworksNumber Method

MEPSystemGetPhysicalNetworksNumber Method

Get the physical networks number in the system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetPhysicalNetworksNumber()
Public Function GetPhysicalNetworksNumber As Integer
public:
int GetPhysicalNetworksNumber()
member GetPhysicalNetworksNumber : unit -> int

Return Value

Int32
The number of physical networks.
See Also

Reference

MEPSystem Class


MEPSystem.GetSectionByIndex Method

MEPSystemGetSectionByIndex Method

Get the section from the index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MEPSection GetSectionByIndex(
    int index
)
Public Function GetSectionByIndex (
    index As Integer
) As MEPSection
public:
MEPSection^ GetSectionByIndex(
    int index
)
member GetSectionByIndex :
        index : int -> MEPSection

Parameters

index Int32
The index of the section in the system.

Return Value

MEPSection
The section.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The section index is out of range.
See Also

Reference

MEPSystem Class


MEPSystem.GetSectionByNumber Method

MEPSystemGetSectionByNumber Method

Get the Section from section number

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MEPSection GetSectionByNumber(
    int sectionNumber
)
Public Function GetSectionByNumber (
    sectionNumber As Integer
) As MEPSection
public:
MEPSection^ GetSectionByNumber(
    int sectionNumber
)
member GetSectionByNumber :
        sectionNumber : int -> MEPSection

Parameters

sectionNumber Int32
The Section number.

Return Value

MEPSection
The section. if the no section exists for the input section number.
See Also

Reference

MEPSystem Class


MEPSystem.IsSystemDividable Method

MEPSystemIsSystemDividable Method

Checks if the system is dividable. The system is dividable if there is more than one physical network in the system. Currently, only HVAC and piping systems support dividing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSystemDividable()
Public Function IsSystemDividable As Boolean
public:
bool IsSystemDividable()
member IsSystemDividable : unit -> bool

Return Value

Boolean
True if the system can be divided.
See Also

Reference

MEPSystem Class


MEPSystem.Remove Method

MEPSystemRemove Method

Overload List
 | Name | Description
Public method | Remove(ConnectorSet) | Removes connectors from system.
Public method | Remove(ICollectionElementId) | Remove elements from system.
Top
See Also

Reference

MEPSystem Class


MEPSystem.Remove(ConnectorSet) Method

MEPSystemRemove(ConnectorSet) Method

Removes connectors from system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Remove(
    ConnectorSet connectors
)
Public Sub Remove (
    connectors As ConnectorSet
)
public:
void Remove(
    ConnectorSet^ connectors
)
member Remove :
        connectors : ConnectorSet -> unit

Parameters

connectors ConnectorSet
The connectors to be removed from the system.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument elements is , or any element in that collection is .
ArgumentException | Thrown when some of the connectors can't be removed, or when trying to remove all connectors from the system.
InvalidOperationException | Thrown when the operation failed.
See Also

Reference

MEPSystem Class
Remove Overload


MEPSystem.Remove(ICollection<ElementId>) Method

MEPSystemRemove(ICollectionElementId) Method

Remove elements from system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Remove(
    ICollection<ElementId> elementIds
)
Public Overridable Sub Remove (
    elementIds As ICollection(Of ElementId)
)
public:
virtual void Remove(
    ICollection<ElementId^>^ elementIds
)
abstract Remove :
        elementIds : ICollection<ElementId> -> unit
override Remove :
        elementIds : ICollection<ElementId> -> unit

Parameters

elementIds ICollection ElementId
The elements to be removed from the system.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument elements is , or any element in that collection is .
ArgumentException | Thrown when some of the elements can't be removed, or when trying to remove all elements from the system. The element which connect to the base equipment can't be removed,
InvalidOperationException | Thrown when the operation failed.
Remarks
It is forbidden to remove all terminal elements from system. Terminal elements will be removed from the system automatically after removing this system from document.
See Also

Reference

MEPSystem Class
Remove Overload


MEPSystemClassification Enumeration

This enumeration is used to classify MEP connectors and systems and drives certain behavior for a particular system type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum MEPSystemClassification
Public Enumeration MEPSystemClassification
public enum class MEPSystemClassification
type MEPSystemClassification
Members
Member name | Value | Description
UndefinedSystemClassification | 0 | A system classification not yet defined
SupplyAir | 1 | A supply air duct system
ReturnAir | 2 | A return air duct system
ExhaustAir | 3 | Obsolete classification not used anymore
OtherAir | 4 | An user classified air duct system
DataCircuit | 5 | An electrical data circuit
PowerCircuit | 6 | An electrical circuit
SupplyHydronic | 7 | A hydronic supply piping system
ReturnHydronic | 8 | A hydronic return piping system
Telephone | 9 | An electrical circuit classified as telephone
Security | 10 | An electrical security circuit
FireAlarm | 11 | An electrical fire alarm circuit
NurseCall | 12 | An electrical circuit classified as nurse call
Controls | 13 | An electrical circuit classified as controls
Communication | 14 | An electrical circuit classified as communication
CondensateDrain | 15 | Reserved for future use
Sanitary | 16 | A sanitary piping system
Vent | 17 | A piping ventilation system
Storm | 18 | Reserved for future use
DomesticHotWater | 19 | A hot water piping system
DomesticColdWater | 20 | A cold water piping system
Recirculation | 21 | Reserved for future use
OtherPipe | 22 | An user classified piping system
FireProtectWet | 23 | A wet fire protection system
FireProtectDry | 24 | A dry fire protection system
FireProtectPreaction | 25 | A preaction fire protection system
FireProtectOther | 26 | A user defined fire protection system
SwitchTopology | 27 | An electrical switch system
Fitting | 28 | Reserved for application usage, used for UI filtering in Family Editor
Global | 29 | Reserved for application usage, used for UI filtering in Family Editor
PowerBalanced | 30 | Equivalent with PowerCircuit
PowerUnBalanced | 31 | Equivalent with PowerCircuit
CableTrayConduit | 32 | Indicates the default type for cable trays and conduits
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


MEPSystemType Class

A system type in the Autodesk Revit MEP product.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBMEPSystemType
Autodesk.Revit.DB.MechanicalMechanicalSystemType
Autodesk.Revit.DB.PlumbingPipingSystemType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MEPSystemType : ElementType
Public Class MEPSystemType
    Inherits ElementType
public ref class MEPSystemType : public ElementType
type MEPSystemType =
    class
        inherit ElementType
    end

The MEPSystemType type exposes the following members.

Properties
 | Name | Description
Public property | Abbreviation | Identifies the abbreviation, the short name, for the system type
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CalculationLevel | Identifies the calculation level for the system type.
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
Public property | FillColor | Indicates the color that should override the fill color for all components in the system.
Public property | FillPatternId | Indicates the fill pattern id that should override the fill pattern id for all components in the system.
Public property | FillVisible | Indicates the visibility of the fill pattern for all components in the system.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LineColor | Indicates the color that should override the line color for all components in the system.
Public property | LinePatternId | Indicates the line pattern id that should override the line pattern id for all components in the system.
Public property | LineWeight | Indicates the weight that should override the line weight for all components in the system.
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | MaterialId | Indicates the material id that should override the material for all components in the system.
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SystemClassification | Identifies the classification for the system type
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This is the base class for mechanical and piping system types, available only in the Autodesk Revit MEP product.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


MEPSystemType Properties

The MEPSystemType type exposes the following members.

Properties
 | Name | Description
Public property | Abbreviation | Identifies the abbreviation, the short name, for the system type
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CalculationLevel | Identifies the calculation level for the system type.
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
Public property | FillColor | Indicates the color that should override the fill color for all components in the system.
Public property | FillPatternId | Indicates the fill pattern id that should override the fill pattern id for all components in the system.
Public property | FillVisible | Indicates the visibility of the fill pattern for all components in the system.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LineColor | Indicates the color that should override the line color for all components in the system.
Public property | LinePatternId | Indicates the line pattern id that should override the line pattern id for all components in the system.
Public property | LineWeight | Indicates the weight that should override the line weight for all components in the system.
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | MaterialId | Indicates the material id that should override the material for all components in the system.
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SystemClassification | Identifies the classification for the system type
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

MEPSystemType Class


MEPSystemType.Abbreviation Property

MEPSystemTypeAbbreviation Property

Identifies the abbreviation, the short name, for the system type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Abbreviation { get; set; }
Public Property Abbreviation As String
    Get
    Set
public:
property String^ Abbreviation {
    String^ get ();
    void set (String^ value);
}
member Abbreviation : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

MEPSystemType Class


MEPSystemType.CalculationLevel Property

MEPSystemTypeCalculationLevel Property

Identifies the calculation level for the system type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SystemCalculationLevel CalculationLevel { get; set; }
Public Property CalculationLevel As SystemCalculationLevel
    Get
    Set
public:
property SystemCalculationLevel CalculationLevel {
    SystemCalculationLevel get ();
    void set (SystemCalculationLevel value);
}
member CalculationLevel : SystemCalculationLevel with get, set

Property Value

SystemCalculationLevel
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

MEPSystemType Class


MEPSystemType.FillColor Property

MEPSystemTypeFillColor Property

Indicates the color that should override the fill color for all components in the system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color FillColor { get; set; }
Public Property FillColor As Color
    Get
    Set
public:
property Color^ FillColor {
    Color^ get ();
    void set (Color^ value);
}
member FillColor : Color with get, set

Property Value

Color
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

MEPSystemType Class


MEPSystemType.FillPatternId Property

MEPSystemTypeFillPatternId Property

Indicates the fill pattern id that should override the fill pattern id for all components in the system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId FillPatternId { get; set; }
Public Property FillPatternId As ElementId
    Get
    Set
public:
property ElementId^ FillPatternId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member FillPatternId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

MEPSystemType Class


MEPSystemType.FillVisible Property

MEPSystemTypeFillVisible Property

Indicates the visibility of the fill pattern for all components in the system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool FillVisible { get; set; }
Public Property FillVisible As Boolean
    Get
    Set
public:
property bool FillVisible {
    bool get ();
    void set (bool value);
}
member FillVisible : bool with get, set

Property Value

Boolean
See Also

Reference

MEPSystemType Class


MEPSystemType.LineColor Property

MEPSystemTypeLineColor Property

Indicates the color that should override the line color for all components in the system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color LineColor { get; set; }
Public Property LineColor As Color
    Get
    Set
public:
property Color^ LineColor {
    Color^ get ();
    void set (Color^ value);
}
member LineColor : Color with get, set

Property Value

Color
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

MEPSystemType Class


MEPSystemType.LinePatternId Property

MEPSystemTypeLinePatternId Property

Indicates the line pattern id that should override the line pattern id for all components in the system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId LinePatternId { get; set; }
Public Property LinePatternId As ElementId
    Get
    Set
public:
property ElementId^ LinePatternId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member LinePatternId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

MEPSystemType Class


MEPSystemType.LineWeight Property

MEPSystemTypeLineWeight Property

Indicates the weight that should override the line weight for all components in the system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int LineWeight { get; set; }
Public Property LineWeight As Integer
    Get
    Set
public:
property int LineWeight {
    int get ();
    void set (int value);
}
member LineWeight : int with get, set

Property Value

Int32
See Also

Reference

MEPSystemType Class


MEPSystemType.MaterialId Property

MEPSystemTypeMaterialId Property

Indicates the material id that should override the material for all components in the system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId MaterialId { get; set; }
Public Property MaterialId As ElementId
    Get
    Set
public:
property ElementId^ MaterialId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member MaterialId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

MEPSystemType Class


MEPSystemType.SystemClassification Property

MEPSystemTypeSystemClassification Property

Identifies the classification for the system type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MEPSystemClassification SystemClassification { get; }
Public ReadOnly Property SystemClassification As MEPSystemClassification
    Get
public:
property MEPSystemClassification SystemClassification {
    MEPSystemClassification get ();
}
member SystemClassification : MEPSystemClassification with get

Property Value

MEPSystemClassification
Remarks
The system classification drives certain behavior such as sizing and connections to other systems
See Also

Reference

MEPSystemType Class


MEPSystemType Methods

The MEPSystemType type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MEPSystemType Class


Mesh Class

A triangular mesh.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGeometryObject
Autodesk.Revit.DBMesh

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Mesh : GeometryObject
Public Class Mesh
    Inherits GeometryObject
public ref class Mesh : public GeometryObject
type Mesh =
    class
        inherit GeometryObject
    end

The Mesh type exposes the following members.

Properties
 | Name | Description
Public property | DistributionOfNormals | Indicates the distribution of normal vectors along the tessellated mesh surface.
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject)
Public property | IsClosed | Indicates whether the mesh is closed.
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject)
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | MaterialElementId | Element ID of the material from which this mesh is composed.
Public property | NumberOfNormals | The number of normals associated with the mesh.
Public property | NumTriangles | The number of triangles that the mesh contains.
Public property | Transformed | Transforms this mesh and returns the result.
Public property | Triangle | Retrieves a specific triangle.
Public property | Vertices | Retrieves all vertices used to define this mesh. Intended for indexed access.
Public property | Visibility | The visibility. (Inherited from GeometryObject)
Top
Methods
 | Name | Description
Public method | ComputeSurfaceArea | Computes and returns the surface area of the mesh. The surface area is the sum of the areas of the constituent facets of the mesh.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject)
Public method | GetNormal | Returns a normal unit vector at the given index.
Public method | GetNormals | Returns all normals assigned to the mesh.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Meshes are generated during triangulation of faces. They can also be encountered directly in Revit geometry (typically imported geometry). Meshes contain a single array of Vertices, and a corresponding array of triangles. Triangles can be accessed by index from TriangleInt32, and reference 3 vertices from the Vertices array.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Mesh Properties

The Mesh type exposes the following members.

Properties
 | Name | Description
Public property | DistributionOfNormals | Indicates the distribution of normal vectors along the tessellated mesh surface.
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject)
Public property | IsClosed | Indicates whether the mesh is closed.
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject)
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | MaterialElementId | Element ID of the material from which this mesh is composed.
Public property | NumberOfNormals | The number of normals associated with the mesh.
Public property | NumTriangles | The number of triangles that the mesh contains.
Public property | Transformed | Transforms this mesh and returns the result.
Public property | Triangle | Retrieves a specific triangle.
Public property | Vertices | Retrieves all vertices used to define this mesh. Intended for indexed access.
Public property | Visibility | The visibility. (Inherited from GeometryObject)
Top
See Also

Reference

Mesh Class


Mesh.DistributionOfNormals Property

MeshDistributionOfNormals Property

Indicates the distribution of normal vectors along the tessellated mesh surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DistributionOfNormals DistributionOfNormals { get; }
Public ReadOnly Property DistributionOfNormals As DistributionOfNormals
    Get
public:
property DistributionOfNormals DistributionOfNormals {
    DistributionOfNormals get ();
}
member DistributionOfNormals : DistributionOfNormals with get

Property Value

DistributionOfNormals
See Also

Reference

Mesh Class


Mesh.IsClosed Property

MeshIsClosed Property

Indicates whether the mesh is closed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsClosed { get; }
Public ReadOnly Property IsClosed As Boolean
    Get
public:
property bool IsClosed {
    bool get ();
}
member IsClosed : bool with get

Property Value

Boolean
Remarks
Every time this property is accessed, it is computed from scratch, so accessing it multiple times will come at a performance cost. A mesh is closed when each of its edges has two (or more) faces. If an edge has more than two faces (meaning that it's a non-manifold edge), the mesh still may be closed.
See Also

Reference

Mesh Class


Mesh.MaterialElementId Property

MeshMaterialElementId Property

Element ID of the material from which this mesh is composed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId MaterialElementId { get; }
Public ReadOnly Property MaterialElementId As ElementId
    Get
public:
property ElementId^ MaterialElementId {
    ElementId^ get ();
}
member MaterialElementId : ElementId with get

Property Value

ElementId
See Also

Reference

Mesh Class


Mesh.NumberOfNormals Property

MeshNumberOfNormals Property

The number of normals associated with the mesh.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int NumberOfNormals { get; }
Public ReadOnly Property NumberOfNormals As Integer
    Get
public:
property int NumberOfNormals {
    int get ();
}
member NumberOfNormals : int with get

Property Value

Int32
Remarks
The number is always equal either to '1', or the number of facets, or the number of points. The DistributionOfNormals property indicates how normals are distributed along the polymesh. If there is only one normal available, it applies to the entire mesh. Curved surfaces have normal vectors associated with either every facet or every point/vertex of the tessellated polymesh.
See Also

Reference

Mesh Class


Mesh.NumTriangles Property

MeshNumTriangles Property

The number of triangles that the mesh contains.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int NumTriangles { get; }
Public ReadOnly Property NumTriangles As Integer
    Get
public:
property int NumTriangles {
    int get ();
}
member NumTriangles : int with get

Property Value

Int32
See Also

Reference

Mesh Class


Mesh.Transformed Property

MeshTransformed Property

Transforms this mesh and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Mesh this[
    Transform transform
] { get; }
Public ReadOnly Property Transformed (
    transform As Transform
) As Mesh
    Get
public:
property Mesh^ Transformed[Transform^ transform] {
    Mesh^ get (Transform^ transform);
}
member Transformed : Mesh with get

Parameters

transform Transform
The transformation used to transform the profile.

Return Value

Mesh
The transformed mesh.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the handle of the specified transformation is .
See Also

Reference

Mesh Class


Mesh.Triangle Property

MeshTriangle Property

Retrieves a specific triangle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MeshTriangle this[
    int idx
] { get; }
Public ReadOnly Property Triangle (
    idx As Integer
) As MeshTriangle
    Get
public:
property MeshTriangle^ Triangle[int idx] {
    MeshTriangle^ get (int idx);
}
member Triangle : MeshTriangle with get

Parameters

idx Int32
Index of the triangle, must be in [0, NumTriangles).

Property Value

MeshTriangle
See Also

Reference

Mesh Class


Mesh.Vertices Property

MeshVertices Property

Retrieves all vertices used to define this mesh. Intended for indexed access.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<XYZ> Vertices { get; }
Public ReadOnly Property Vertices As IList(Of XYZ)
    Get
public:
property IList<XYZ^>^ Vertices {
    IList<XYZ^>^ get ();
}
member Vertices : IList<XYZ> with get

Property Value

IList XYZ
See Also

Reference

Mesh Class


Mesh Methods

The Mesh type exposes the following members.

Methods
 | Name | Description
Public method | ComputeSurfaceArea | Computes and returns the surface area of the mesh. The surface area is the sum of the areas of the constituent facets of the mesh.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject)
Public method | GetNormal | Returns a normal unit vector at the given index.
Public method | GetNormals | Returns all normals assigned to the mesh.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Mesh Class


Mesh.ComputeSurfaceArea Method

MeshComputeSurfaceArea Method

Computes and returns the surface area of the mesh. The surface area is the sum of the areas of the constituent facets of the mesh.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double ComputeSurfaceArea()
Public Function ComputeSurfaceArea As Double
public:
double ComputeSurfaceArea()
member ComputeSurfaceArea : unit -> float

Return Value

Double
A double, representing the surface area.
See Also

Reference

Mesh Class


Mesh.GetNormal Method

MeshGetNormal Method

Returns a normal unit vector at the given index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ GetNormal(
    int idx
)
Public Function GetNormal (
    idx As Integer
) As XYZ
public:
XYZ^ GetNormal(
    int idx
)
member GetNormal :
        idx : int -> XYZ

Parameters

idx Int32
A zero-based index. It must be consistent with the DistributionOfNormals.

Return Value

XYZ
XYZ value representing a normal unit vector.
Exceptions
Exception | Condition
ArgumentException | The given value is not a valid index of a normal of the mesh. A valid value is not negative and is smaller than the number of normals in the mesh.
See Also

Reference

Mesh Class


Mesh.GetNormals Method

MeshGetNormals Method

Returns all normals assigned to the mesh.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<XYZ> GetNormals()
Public Function GetNormals As IList(Of XYZ)
public:
IList<XYZ^>^ GetNormals()
member GetNormals : unit -> IList<XYZ>

Return Value

IList XYZ
An array of XYZ values, each representing a normal unit vector.
See Also

Reference

Mesh Class


MeshFromGeometryOperationIssue Enumeration

Issues encountered while constructing meshes as fallbacks for geometrical operations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum MeshFromGeometryOperationIssue
Public Enumeration MeshFromGeometryOperationIssue
public enum class MeshFromGeometryOperationIssue
type MeshFromGeometryOperationIssue
Members
Member name | Value | Description
AllFine | 0 | No issues were encountered. Issues of this type should not be present in MeshFromGeometryOperationResult.
NoUsableCurveLoopsInInput | 1 | While one or more curve loops were expected as one of the input parameters while building a mesh, no loops containing curves were provided.
MissingCurveLoopsInInput | 2 | While several curve loops were expected as one of the input parameters while building a mesh, some of them were not provided.
EmptyCurveLoopsInInput | 3 | Among curve loops expected as input parameters while building a mesh, some are empty.
CurveLoopsWithoutCurvesInInput | 4 | Among curve loops expected as input parameters while building a mesh, some are not empty, but do not have any curves.
NonPlanarProfileLoop | 5 | Among curve loops expected as input parameters while building a mesh, some are not planar.
InputCurveLoopProblemWithFallback | 6 | An unidentified problem with an input curve loop. A fallback is attempted.
InputCurveLoopWrongOpenFlag | 7 | An input curve has incorrect open flag.
NonContinuousInputCurveLoop | 8 | A non-continuous input curve loop. Either wrong curve flips or genuine gaps.
MissingCurvesInInputLoop | 9 | An input curve loop has missing curves.
InternalUtilityError | 10 | An internal Revit problem. Issues of this type should not normally be present in MeshFromGeometryOperationResult. Please notify Autodesk support if encountered.
InternalMissingError | 11 | An internal Revit problem. Issues of this type should not be present in TessellatedShapeBuilderResult. Please notify Autodesk support if encountered.
InternalError | 12 | An internal Revit problem. Issues of this type should not normally be present in MeshFromGeometryOperationResult. Please notify Autodesk support if encountered.
NotSetYet | 13 | An issue has not been set yet.
NumberOfIssueTypes | 14 | Not a code of some issue, but the number of known types of issues. Issues of this type should not be present in TessellatedShapeBuilderResult. Please notify Autodesk support if encountered
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


MeshFromGeometryOperationResult Class

Describes what TessellatedShapeBuilder has built.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBMeshFromGeometryOperationResult

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MeshFromGeometryOperationResult : IDisposable
Public Class MeshFromGeometryOperationResult
    Implements IDisposable
public ref class MeshFromGeometryOperationResult : IDisposable
type MeshFromGeometryOperationResult =
    class
        interface IDisposable
    end

The MeshFromGeometryOperationResult type exposes the following members.

Properties
 | Name | Description
Public property | HasInvalidData | Whether the provided data for which this result was obtained were internally inconsistent and could not be used in its entirety. For example, for extrusion operation, profile loops were degenerate or improperly oriented with respect to the extrsuion direction.
Public property | IsMeshAvailable | Shows whether the result still contains the mesh which was constructed, if any, or whether it has been relinquished by 'getMesh'. The former is true, the later is false.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Tessellated | Whether while constructing a mesh, it was necessary to extrude polylines instead of non-linear curves from the profile loops.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the MeshFromGeometryOperationResult
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIssues | Returns the array of issues encountered while building a mesh.
Public method | GetMesh | This returns a valid mesh only for the first call. Later calls will throw an exception as the mesh is no longer valid in this object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


MeshFromGeometryOperationResult Properties

The MeshFromGeometryOperationResult type exposes the following members.

Properties
 | Name | Description
Public property | HasInvalidData | Whether the provided data for which this result was obtained were internally inconsistent and could not be used in its entirety. For example, for extrusion operation, profile loops were degenerate or improperly oriented with respect to the extrsuion direction.
Public property | IsMeshAvailable | Shows whether the result still contains the mesh which was constructed, if any, or whether it has been relinquished by 'getMesh'. The former is true, the later is false.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Tessellated | Whether while constructing a mesh, it was necessary to extrude polylines instead of non-linear curves from the profile loops.
Top
See Also

Reference

MeshFromGeometryOperationResult Class


MeshFromGeometryOperationResult.HasInvalidData Property

MeshFromGeometryOperationResultHasInvalidData Property

Whether the provided data for which this result was obtained were internally inconsistent and could not be used in its entirety. For example, for extrusion operation, profile loops were degenerate or improperly oriented with respect to the extrsuion direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasInvalidData { get; }
Public ReadOnly Property HasInvalidData As Boolean
    Get
public:
property bool HasInvalidData {
    bool get ();
}
member HasInvalidData : bool with get

Property Value

Boolean
Remarks
This variable does not capture presence or absence of intersections between different profile loops.
See Also

Reference

MeshFromGeometryOperationResult Class


MeshFromGeometryOperationResult.IsMeshAvailable Property

MeshFromGeometryOperationResultIsMeshAvailable Property

Shows whether the result still contains the mesh which was constructed, if any, or whether it has been relinquished by 'getMesh'. The former is true, the later is false.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsMeshAvailable { get; }
Public ReadOnly Property IsMeshAvailable As Boolean
    Get
public:
property bool IsMeshAvailable {
    bool get ();
}
member IsMeshAvailable : bool with get

Property Value

Boolean
See Also

Reference

MeshFromGeometryOperationResult Class


MeshFromGeometryOperationResult.IsValidObject Property

MeshFromGeometryOperationResultIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

MeshFromGeometryOperationResult Class


MeshFromGeometryOperationResult.Tessellated Property

MeshFromGeometryOperationResultTessellated Property

Whether while constructing a mesh, it was necessary to extrude polylines instead of non-linear curves from the profile loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Tessellated { get; }
Public ReadOnly Property Tessellated As Boolean
    Get
public:
property bool Tessellated {
    bool get ();
}
member Tessellated : bool with get

Property Value

Boolean
See Also

Reference

MeshFromGeometryOperationResult Class


MeshFromGeometryOperationResult Methods

The MeshFromGeometryOperationResult type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIssues | Returns the array of issues encountered while building a mesh.
Public method | GetMesh | This returns a valid mesh only for the first call. Later calls will throw an exception as the mesh is no longer valid in this object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MeshFromGeometryOperationResult Class


MeshFromGeometryOperationResult.Dispose Method

MeshFromGeometryOperationResultDispose Method

Releases all resources used by the MeshFromGeometryOperationResult

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

MeshFromGeometryOperationResult Class


MeshFromGeometryOperationResult.GetIssues Method

MeshFromGeometryOperationResultGetIssues Method

Returns the array of issues encountered while building a mesh.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<MeshFromGeometryOperationIssue> GetIssues()
Public Function GetIssues As IList(Of MeshFromGeometryOperationIssue)
public:
IList<MeshFromGeometryOperationIssue>^ GetIssues()
member GetIssues : unit -> IList<MeshFromGeometryOperationIssue>

Return Value

IList MeshFromGeometryOperationIssue
Array of issues encountered while building a mesh.
See Also

Reference

MeshFromGeometryOperationResult Class


MeshFromGeometryOperationResult.GetMesh Method

MeshFromGeometryOperationResultGetMesh Method

This returns a valid mesh only for the first call. Later calls will throw an exception as the mesh is no longer valid in this object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Mesh GetMesh()
Public Function GetMesh As Mesh
public:
Mesh^ GetMesh()
member GetMesh : unit -> Mesh

Return Value

Mesh
Mesh which built.
Exceptions
Exception | Condition
InvalidOperationException | The Mesh has already been accessed by a previous GetMesh() call, and is no longer available for use.
See Also

Reference

MeshFromGeometryOperationResult Class


MeshTriangle Class

One triangle of a mesh.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBMeshTriangle

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MeshTriangle
Public Class MeshTriangle
public ref class MeshTriangle
type MeshTriangle = class end

The MeshTriangle type exposes the following members.

Properties
 | Name | Description
Public property | Index | The index of the vertex in the Vertices array of the mesh, for indexed access.
Public property | Vertex | A vertex of the triangle.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


MeshTriangle Properties

The MeshTriangle type exposes the following members.

Properties
 | Name | Description
Public property | Index | The index of the vertex in the Vertices array of the mesh, for indexed access.
Public property | Vertex | A vertex of the triangle.
Top
See Also

Reference

MeshTriangle Class


MeshTriangle.Index Property

MeshTriangleIndex Property

The index of the vertex in the Vertices array of the mesh, for indexed access.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public uint this[
    int idx
] { get; }
Public ReadOnly Property Index (
    idx As Integer
) As UInteger
    Get
public:
property unsigned int Index[int idx] {
    unsigned int get (int idx);
}
member Index : uint32 with get

Parameters

idx Int32
Index of the vertex in the triangle: 0, 1 or 2.

Property Value

UInt32
See Also

Reference

MeshTriangle Class


MeshTriangle.Vertex Property

MeshTriangleVertex Property

A vertex of the triangle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ this[
    int idx
] { get; }
Public ReadOnly Property Vertex (
    idx As Integer
) As XYZ
    Get
public:
property XYZ^ Vertex[int idx] {
    XYZ^ get (int idx);
}
member Vertex : XYZ with get

Parameters

idx Int32
Index of the vertex in the triangle: 0, 1 or 2.

Property Value

XYZ
See Also

Reference

MeshTriangle Class


MeshTriangle Methods

The MeshTriangle type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MeshTriangle Class


ModelArc Class

Represents a ModelArc within Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBCurveElement
Autodesk.Revit.DBModelCurve
Autodesk.Revit.DBModelArc

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ModelArc : ModelCurve
Public Class ModelArc
    Inherits ModelCurve
public ref class ModelArc : public ModelCurve
type ModelArc =
    class
        inherit ModelCurve
    end

The ModelArc type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CurveElementType | Type of the curve element. (Inherited from CurveElement)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement)
Public property | Subcategory | The subcategory. (Inherited from ModelCurve)
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element. (Inherited from CurveElement)
Public property | TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeToReferenceLine | Changes this curve to a reference curve. (Inherited from ModelCurve)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement)
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement)
Public method | SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from ModelCurve::geometryCurve property.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ModelArc Properties

The ModelArc type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CurveElementType | Type of the curve element. (Inherited from CurveElement)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement)
Public property | Subcategory | The subcategory. (Inherited from ModelCurve)
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element. (Inherited from CurveElement)
Public property | TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

ModelArc Class


ModelArc Methods

The ModelArc type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeToReferenceLine | Changes this curve to a reference curve. (Inherited from ModelCurve)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement)
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement)
Public method | SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ModelArc Class


ModelCurve Class

A model element that exists in 3D space and is visible in all views of a Revit project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBCurveElement
Autodesk.Revit.DBModelCurve
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ModelCurve : CurveElement
Public Class ModelCurve
    Inherits CurveElement
public ref class ModelCurve : public CurveElement
type ModelCurve =
    class
        inherit CurveElement
    end

The ModelCurve type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CurveElementType | Type of the curve element. (Inherited from CurveElement)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsReferenceLine | Indicates if this curve is a reference curve.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement)
Public property | Subcategory | The subcategory.
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element. (Inherited from CurveElement)
Public property | TrussCurveType | The truss curve type of this model curve.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeToReferenceLine | Changes this curve to a reference curve.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetVisibility | Gets the visibility for the model curve in a family document.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement)
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement)
Public method | SetVisibility | Sets the visibility for the model curve in a family document.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBCurveElement
Autodesk.Revit.DBModelCurve
Autodesk.Revit.DBModelArc
Autodesk.Revit.DBModelEllipse
Autodesk.Revit.DBModelHermiteSpline
Autodesk.Revit.DBModelLine
Autodesk.Revit.DBModelNurbSpline


ModelCurve Properties

The ModelCurve type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CurveElementType | Type of the curve element. (Inherited from CurveElement)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsReferenceLine | Indicates if this curve is a reference curve.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement)
Public property | Subcategory | The subcategory.
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element. (Inherited from CurveElement)
Public property | TrussCurveType | The truss curve type of this model curve.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

ModelCurve Class


ModelCurve.IsReferenceLine Property

ModelCurveIsReferenceLine Property

Indicates if this curve is a reference curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsReferenceLine { get; }
Public ReadOnly Property IsReferenceLine As Boolean
    Get
public:
property bool IsReferenceLine {
    bool get ();
}
member IsReferenceLine : bool with get

Property Value

Boolean
See Also

Reference

ModelCurve Class


ModelCurve.Subcategory Property

ModelCurveSubcategory Property

The subcategory.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GraphicsStyle Subcategory { get; set; }
Public Property Subcategory As GraphicsStyle
    Get
    Set
public:
property GraphicsStyle^ Subcategory {
    GraphicsStyle^ get ();
    void set (GraphicsStyle^ value);
}
member Subcategory : GraphicsStyle with get, set

Property Value

GraphicsStyle
Remarks
If the family category is non-cuttable, the subcategory can be set to be the family category or one of its subcategories. If the family category is cuttable, the subcategory can be set as the graphics styles of the family category, its subcategories, or the invisible lines graphics style.
See Also

Reference

ModelCurve Class


ModelCurve.TrussCurveType Property

ModelCurveTrussCurveType Property

The truss curve type of this model curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TrussCurveType TrussCurveType { get; set; }
Public Property TrussCurveType As TrussCurveType
    Get
    Set
public:
property TrussCurveType TrussCurveType {
    TrussCurveType get ();
    void set (TrussCurveType value);
}
member TrussCurveType : TrussCurveType with get, set

Property Value

TrussCurveType
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown when the assigned value for TrussCurveType is invalid.
InvalidOperationException | Thrown when attempting to set this property to a curve not in a truss family.
InvalidOperationException | Thrown when attempting to change truss curves to NonTrussCurve, or when the truss curve type may not be applied to curves of this shape (webs must be linear, and chords must be linear or arc).
Remarks
This property is applicable only to curves in Truss families.
See Also

Reference

ModelCurve Class


ModelCurve Methods

The ModelCurve type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeToReferenceLine | Changes this curve to a reference curve.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetVisibility | Gets the visibility for the model curve in a family document.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement)
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement)
Public method | SetVisibility | Sets the visibility for the model curve in a family document.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ModelCurve Class


ModelCurve.ChangeToReferenceLine Method

ModelCurveChangeToReferenceLine Method

Changes this curve to a reference curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ChangeToReferenceLine()
Public Sub ChangeToReferenceLine
public:
void ChangeToReferenceLine()
member ChangeToReferenceLine : unit -> unit
See Also

Reference

ModelCurve Class


ModelCurve.GetVisibility Method

ModelCurveGetVisibility Method

Gets the visibility for the model curve in a family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyElementVisibility GetVisibility()
Public Function GetVisibility As FamilyElementVisibility
public:
FamilyElementVisibility^ GetVisibility()
member GetVisibility : unit -> FamilyElementVisibility

Return Value

FamilyElementVisibility
A copy of visibility settings for the model curve in a family document.
See Also

Reference

ModelCurve Class


ModelCurve.SetVisibility Method

ModelCurveSetVisibility Method

Sets the visibility for the model curve in a family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetVisibility(
    FamilyElementVisibility visibility
)
Public Sub SetVisibility (
    visibility As FamilyElementVisibility
)
public:
void SetVisibility(
    FamilyElementVisibility^ visibility
)
member SetVisibility :
        visibility : FamilyElementVisibility -> unit

Parameters

visibility FamilyElementVisibility
Exceptions
Exception | Condition
ArgumentNullException | Thrown when visibility is .
InvalidOperationException | Thrown when regeneration failed, or the model curve is in a project document.
Remarks
The visibility of the model curve geometry can be changed for different types of views and detail levels in the family document.
See Also

Reference

ModelCurve Class


ModelCurveArrArray Class

An array that can contain any type of object.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBModelCurveArrArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ModelCurveArrArray : APIObject,
    IEnumerable
Public Class ModelCurveArrArray
    Inherits APIObject
    Implements IEnumerable
public ref class ModelCurveArrArray : public APIObject,
    IEnumerable
type ModelCurveArrArray =
    class
        inherit APIObject
        interface IEnumerable
    end

The ModelCurveArrArray type exposes the following members.

Constructors
 | Name | Description
Public method | ModelCurveArrArray | Initializes a new instance of the ModelCurveArrArray class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.
Top
Methods
 | Name | Description
Public method | Append |
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ModelCurveArrArray Constructor

Initializes a new instance of the ModelCurveArrArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ModelCurveArrArray()
Public Sub New
public:
ModelCurveArrArray()
new : unit -> ModelCurveArrArray
See Also

Reference

ModelCurveArrArray Class


ModelCurveArrArray Properties

The ModelCurveArrArray type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.
Top
See Also

Reference

ModelCurveArrArray Class


ModelCurveArrArray.IsEmpty Property

ModelCurveArrArrayIsEmpty Property

Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Boolean
Remarks
If the array is empty then True will be returned, otherwise False.
See Also

Reference

ModelCurveArrArray Class


ModelCurveArrArray.Item Property

ModelCurveArrArrayItem Property

Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ModelCurveArray this[
    int index
] { get; set; }
Public Overridable Property Item (
    index As Integer
) As ModelCurveArray
    Get
    Set
public:
virtual property ModelCurveArray^ Item[int index] {
    ModelCurveArray^ get (int index);
    void set (int index, ModelCurveArray^ value);
}
abstract Item : ModelCurveArray with get, set
override Item : ModelCurveArray with get, set

Parameters

index Int32
The index of the item to be set or retrieved.

Return Value

ModelCurveArray
Returns the object at the specified index.
See Also

Reference

ModelCurveArrArray Class


ModelCurveArrArray.Size Property

ModelCurveArrArraySize Property

Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
abstract Size : int with get
override Size : int with get

Property Value

Int32
See Also

Reference

ModelCurveArrArray Class


ModelCurveArrArray Methods

The ModelCurveArrArray type exposes the following members.

Methods
 | Name | Description
Public method | Append |
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ModelCurveArrArray Class


ModelCurveArrArray.Append Method

ModelCurveArrArrayAppend Method

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Append(
    ModelCurveArray item
)
Public Overridable Sub Append (
    item As ModelCurveArray
)
public:
virtual void Append(
    ModelCurveArray^ item
)
abstract Append :
        item : ModelCurveArray -> unit
override Append :
        item : ModelCurveArray -> unit

Parameters

item ModelCurveArray
See Also

Reference

ModelCurveArrArray Class


ModelCurveArrArray.Clear Method

ModelCurveArrArrayClear Method

Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

ModelCurveArrArray Class


ModelCurveArrArray.ForwardIterator Method

ModelCurveArrArrayForwardIterator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ModelCurveArrArrayIterator ForwardIterator()
Public Overridable Function ForwardIterator As ModelCurveArrArrayIterator
public:
virtual ModelCurveArrArrayIterator^ ForwardIterator()
abstract ForwardIterator : unit -> ModelCurveArrArrayIterator
override ForwardIterator : unit -> ModelCurveArrArrayIterator

Return Value

ModelCurveArrArrayIterator
Returns a forward moving iterator to the array.
See Also

Reference

ModelCurveArrArray Class


ModelCurveArrArray.GetEnumerator Method

ModelCurveArrArrayGetEnumerator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

IEnumerator
Returns a forward moving iterator to the array.

Implements

IEnumerableGetEnumerator
See Also

Reference

ModelCurveArrArray Class


ModelCurveArrArray.Insert Method

ModelCurveArrArrayInsert Method

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Insert(
    ModelCurveArray item,
    int index
)
Public Overridable Sub Insert (
    item As ModelCurveArray,
    index As Integer
)
public:
virtual void Insert(
    ModelCurveArray^ item,
    int index
)
abstract Insert :
        item : ModelCurveArray *
        index : int -> unit
override Insert :
        item : ModelCurveArray *
        index : int -> unit

Parameters

item ModelCurveArray
index Int32
See Also

Reference

ModelCurveArrArray Class


ModelCurveArrArray.ReverseIterator Method

ModelCurveArrArrayReverseIterator Method

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ModelCurveArrArrayIterator ReverseIterator()
Public Overridable Function ReverseIterator As ModelCurveArrArrayIterator
public:
virtual ModelCurveArrArrayIterator^ ReverseIterator()
abstract ReverseIterator : unit -> ModelCurveArrArrayIterator
override ReverseIterator : unit -> ModelCurveArrArrayIterator

Return Value

ModelCurveArrArrayIterator
Returns a backward moving iterator to the array.
See Also

Reference

ModelCurveArrArray Class


ModelCurveArrArrayIterator Class

An iterator to a array.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBModelCurveArrArrayIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class ModelCurveArrArrayIterator : APIObject,
    IEnumerator
Public MustInherit Class ModelCurveArrArrayIterator
    Inherits APIObject
    Implements IEnumerator
public ref class ModelCurveArrArrayIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type ModelCurveArrArrayIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The ModelCurveArrArrayIterator type exposes the following members.

Constructors
 | Name | Description
Public method | ModelCurveArrArrayIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ModelCurveArrArrayIterator Constructor

For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ModelCurveArrArrayIterator()
Public Sub New
public:
ModelCurveArrArrayIterator()
new : unit -> ModelCurveArrArrayIterator
Remarks
This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.
See Also

Reference

ModelCurveArrArrayIterator Class


ModelCurveArrArrayIterator Properties

The ModelCurveArrArrayIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

ModelCurveArrArrayIterator Class


ModelCurveArrArrayIterator.Current Property

ModelCurveArrArrayIteratorCurrent Property

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}
abstract Current : Object with get
override Current : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.
See Also

Reference

ModelCurveArrArrayIterator Class


ModelCurveArrArrayIterator Methods

The ModelCurveArrArrayIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ModelCurveArrArrayIterator Class


ModelCurveArrArrayIterator.MoveNext Method

ModelCurveArrArrayIteratorMoveNext Method

Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumeratorMoveNext
Remarks
MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.
See Also

Reference

ModelCurveArrArrayIterator Class


ModelCurveArrArrayIterator.Reset Method

ModelCurveArrArrayIteratorReset Method

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
Remarks
The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.
See Also

Reference

ModelCurveArrArrayIterator Class


ModelCurveArray Class

An array that contains model curves.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBModelCurveArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ModelCurveArray : APIObject,
    IEnumerable
Public Class ModelCurveArray
    Inherits APIObject
    Implements IEnumerable
public ref class ModelCurveArray : public APIObject,
    IEnumerable
type ModelCurveArray =
    class
        inherit APIObject
        interface IEnumerable
    end

The ModelCurveArray type exposes the following members.

Constructors
 | Name | Description
Public method | ModelCurveArray | Initializes a new instance of the ModelCurveArray class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets a model curve at a specified index within the array.
Public property | Size | Returns the number of model curves that are in the array.
Top
Methods
 | Name | Description
Public method | Append | Add the model curve to the end of the array.
Public method | Clear | Removes every model curve from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified model curve into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ModelCurveArray Constructor

Initializes a new instance of the ModelCurveArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ModelCurveArray()
Public Sub New
public:
ModelCurveArray()
new : unit -> ModelCurveArray
See Also

Reference

ModelCurveArray Class


ModelCurveArray Properties

The ModelCurveArray type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets a model curve at a specified index within the array.
Public property | Size | Returns the number of model curves that are in the array.
Top
See Also

Reference

ModelCurveArray Class


ModelCurveArray.IsEmpty Property

ModelCurveArrayIsEmpty Property

Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Boolean
Remarks
If the array is empty then True will be returned, otherwise False.
See Also

Reference

ModelCurveArray Class


ModelCurveArray.Item Property

ModelCurveArrayItem Property

Gets or sets a model curve at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ModelCurve this[
    int index
] { get; set; }
Public Overridable Property Item (
    index As Integer
) As ModelCurve
    Get
    Set
public:
virtual property ModelCurve^ Item[int index] {
    ModelCurve^ get (int index);
    void set (int index, ModelCurve^ value);
}
abstract Item : ModelCurve with get, set
override Item : ModelCurve with get, set

Parameters

index Int32
The index of the model curve to be set or retrieved.

Return Value

ModelCurve
Returns the model curve at the specified index.
See Also

Reference

ModelCurveArray Class


ModelCurveArray.Size Property

ModelCurveArraySize Property

Returns the number of model curves that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
abstract Size : int with get
override Size : int with get

Property Value

Int32
See Also

Reference

ModelCurveArray Class


ModelCurveArray Methods

The ModelCurveArray type exposes the following members.

Methods
 | Name | Description
Public method | Append | Add the model curve to the end of the array.
Public method | Clear | Removes every model curve from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified model curve into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ModelCurveArray Class


ModelCurveArray.Append Method

ModelCurveArrayAppend Method

Add the model curve to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Append(
    ModelCurve item
)
Public Overridable Sub Append (
    item As ModelCurve
)
public:
virtual void Append(
    ModelCurve^ item
)
abstract Append :
        item : ModelCurve -> unit
override Append :
        item : ModelCurve -> unit

Parameters

item ModelCurve
The model curve to be added.
See Also

Reference

ModelCurveArray Class


ModelCurveArray.Clear Method

ModelCurveArrayClear Method

Removes every model curve from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

ModelCurveArray Class


ModelCurveArray.ForwardIterator Method

ModelCurveArrayForwardIterator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ModelCurveArrayIterator ForwardIterator()
Public Overridable Function ForwardIterator As ModelCurveArrayIterator
public:
virtual ModelCurveArrayIterator^ ForwardIterator()
abstract ForwardIterator : unit -> ModelCurveArrayIterator
override ForwardIterator : unit -> ModelCurveArrayIterator

Return Value

ModelCurveArrayIterator
Returns a forward moving iterator to the array.
See Also

Reference

ModelCurveArray Class


ModelCurveArray.GetEnumerator Method

ModelCurveArrayGetEnumerator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

IEnumerator
Returns a forward moving iterator to the array.

Implements

IEnumerableGetEnumerator
See Also

Reference

ModelCurveArray Class


ModelCurveArray.Insert Method

ModelCurveArrayInsert Method

Insert the specified model curve into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Insert(
    ModelCurve item,
    int index
)
Public Overridable Sub Insert (
    item As ModelCurve,
    index As Integer
)
public:
virtual void Insert(
    ModelCurve^ item,
    int index
)
abstract Insert :
        item : ModelCurve *
        index : int -> unit
override Insert :
        item : ModelCurve *
        index : int -> unit

Parameters

item ModelCurve
The model curve to be inserted into the array.
index Int32
The model curve will be inserted before this index.

Return Value

Returns whether the model curve was inserted into the array.
See Also

Reference

ModelCurveArray Class


ModelCurveArray.ReverseIterator Method

ModelCurveArrayReverseIterator Method

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ModelCurveArrayIterator ReverseIterator()
Public Overridable Function ReverseIterator As ModelCurveArrayIterator
public:
virtual ModelCurveArrayIterator^ ReverseIterator()
abstract ReverseIterator : unit -> ModelCurveArrayIterator
override ReverseIterator : unit -> ModelCurveArrayIterator

Return Value

ModelCurveArrayIterator
Returns a backward moving iterator to the array.
See Also

Reference

ModelCurveArray Class


ModelCurveArrayIterator Class

An iterator to a model curve array.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBModelCurveArrayIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class ModelCurveArrayIterator : APIObject,
    IEnumerator
Public MustInherit Class ModelCurveArrayIterator
    Inherits APIObject
    Implements IEnumerator
public ref class ModelCurveArrayIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type ModelCurveArrayIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The ModelCurveArrayIterator type exposes the following members.

Constructors
 | Name | Description
Public method | ModelCurveArrayIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ModelCurveArrayIterator Constructor

For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ModelCurveArrayIterator()
Public Sub New
public:
ModelCurveArrayIterator()
new : unit -> ModelCurveArrayIterator
Remarks
This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.
See Also

Reference

ModelCurveArrayIterator Class


ModelCurveArrayIterator Properties

The ModelCurveArrayIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

ModelCurveArrayIterator Class


ModelCurveArrayIterator.Current Property

ModelCurveArrayIteratorCurrent Property

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}
abstract Current : Object with get
override Current : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.
See Also

Reference

ModelCurveArrayIterator Class


ModelCurveArrayIterator Methods

The ModelCurveArrayIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ModelCurveArrayIterator Class


ModelCurveArrayIterator.MoveNext Method

ModelCurveArrayIteratorMoveNext Method

Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumeratorMoveNext
Remarks
MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.
See Also

Reference

ModelCurveArrayIterator Class


ModelCurveArrayIterator.Reset Method

ModelCurveArrayIteratorReset Method

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
Remarks
The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.
See Also

Reference

ModelCurveArrayIterator Class


ModelCurveNode Class

A base class of output nodes that represent various model curves.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRenderNode
Autodesk.Revit.DBModelCurveNode
Autodesk.Revit.DBCurveNode
Autodesk.Revit.DBPointNode
Autodesk.Revit.DBPolylineNode

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ModelCurveNode : RenderNode
Public Class ModelCurveNode
    Inherits RenderNode
public ref class ModelCurveNode : public RenderNode
type ModelCurveNode =
    class
        inherit RenderNode
    end

The ModelCurveNode type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode)
Public property | LineProperties | Access to the line (pen) properties of the curve being drawn
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from RenderNode)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ModelCurveNode Properties

The ModelCurveNode type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode)
Public property | LineProperties | Access to the line (pen) properties of the curve being drawn
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode)
Top
See Also

Reference

ModelCurveNode Class


ModelCurveNode.LineProperties Property

ModelCurveNodeLineProperties Property

Access to the line (pen) properties of the curve being drawn

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LineProperties LineProperties { get; }
Public ReadOnly Property LineProperties As LineProperties
    Get
public:
property LineProperties^ LineProperties {
    LineProperties^ get ();
}
member LineProperties : LineProperties with get

Property Value

LineProperties
See Also

Reference

ModelCurveNode Class


ModelCurveNode Methods

The ModelCurveNode type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from RenderNode)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ModelCurveNode Class


ModelEllipse Class

Represents a ModelEllipse within Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBCurveElement
Autodesk.Revit.DBModelCurve
Autodesk.Revit.DBModelEllipse

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ModelEllipse : ModelCurve
Public Class ModelEllipse
    Inherits ModelCurve
public ref class ModelEllipse : public ModelCurve
type ModelEllipse =
    class
        inherit ModelCurve
    end

The ModelEllipse type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CurveElementType | Type of the curve element. (Inherited from CurveElement)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement)
Public property | Subcategory | The subcategory. (Inherited from ModelCurve)
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element. (Inherited from CurveElement)
Public property | TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeToReferenceLine | Changes this curve to a reference curve. (Inherited from ModelCurve)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement)
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement)
Public method | SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from ModelCurve::geometryCurve property.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ModelEllipse Properties

The ModelEllipse type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CurveElementType | Type of the curve element. (Inherited from CurveElement)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement)
Public property | Subcategory | The subcategory. (Inherited from ModelCurve)
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element. (Inherited from CurveElement)
Public property | TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

ModelEllipse Class


ModelEllipse Methods

The ModelEllipse type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeToReferenceLine | Changes this curve to a reference curve. (Inherited from ModelCurve)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement)
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement)
Public method | SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ModelEllipse Class


ModelHermiteSpline Class

Represents a ModelHermiteSpline within Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBCurveElement
Autodesk.Revit.DBModelCurve
Autodesk.Revit.DBModelHermiteSpline

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ModelHermiteSpline : ModelCurve
Public Class ModelHermiteSpline
    Inherits ModelCurve
public ref class ModelHermiteSpline : public ModelCurve
type ModelHermiteSpline =
    class
        inherit ModelCurve
    end

The ModelHermiteSpline type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CurveElementType | Type of the curve element. (Inherited from CurveElement)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement)
Public property | Subcategory | The subcategory. (Inherited from ModelCurve)
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element. (Inherited from CurveElement)
Public property | TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeToReferenceLine | Changes this curve to a reference curve. (Inherited from ModelCurve)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement)
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement)
Public method | SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from ModelCurve::geometryCurve property.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ModelHermiteSpline Properties

The ModelHermiteSpline type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CurveElementType | Type of the curve element. (Inherited from CurveElement)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement)
Public property | Subcategory | The subcategory. (Inherited from ModelCurve)
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element. (Inherited from CurveElement)
Public property | TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

ModelHermiteSpline Class


ModelHermiteSpline Methods

The ModelHermiteSpline type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeToReferenceLine | Changes this curve to a reference curve. (Inherited from ModelCurve)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement)
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement)
Public method | SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ModelHermiteSpline Class


ModelLine Class

Represents a ModelLine within Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBCurveElement
Autodesk.Revit.DBModelCurve
Autodesk.Revit.DBModelLine

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ModelLine : ModelCurve
Public Class ModelLine
    Inherits ModelCurve
public ref class ModelLine : public ModelCurve
type ModelLine =
    class
        inherit ModelCurve
    end

The ModelLine type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CurveElementType | Type of the curve element. (Inherited from CurveElement)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement)
Public property | Subcategory | The subcategory. (Inherited from ModelCurve)
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element. (Inherited from CurveElement)
Public property | TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeToReferenceLine | Changes this curve to a reference curve. (Inherited from ModelCurve)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement)
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement)
Public method | SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Geometry-related functionality is provided by the geometry curve object from the ModelCurve::geometryCurve property.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ModelLine Properties

The ModelLine type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CurveElementType | Type of the curve element. (Inherited from CurveElement)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement)
Public property | Subcategory | The subcategory. (Inherited from ModelCurve)
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element. (Inherited from CurveElement)
Public property | TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

ModelLine Class


ModelLine Methods

The ModelLine type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeToReferenceLine | Changes this curve to a reference curve. (Inherited from ModelCurve)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement)
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement)
Public method | SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ModelLine Class


ModelNurbSpline Class

Represents a ModelNurbSpline within Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBCurveElement
Autodesk.Revit.DBModelCurve
Autodesk.Revit.DBModelNurbSpline

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ModelNurbSpline : ModelCurve
Public Class ModelNurbSpline
    Inherits ModelCurve
public ref class ModelNurbSpline : public ModelCurve
type ModelNurbSpline =
    class
        inherit ModelCurve
    end

The ModelNurbSpline type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CurveElementType | Type of the curve element. (Inherited from CurveElement)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement)
Public property | Subcategory | The subcategory. (Inherited from ModelCurve)
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element. (Inherited from CurveElement)
Public property | TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeToReferenceLine | Changes this curve to a reference curve. (Inherited from ModelCurve)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement)
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement)
Public method | SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from ModelCurve::geometryCurve property.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ModelNurbSpline Properties

The ModelNurbSpline type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CurveElementType | Type of the curve element. (Inherited from CurveElement)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement)
Public property | Subcategory | The subcategory. (Inherited from ModelCurve)
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element. (Inherited from CurveElement)
Public property | TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

ModelNurbSpline Class


ModelNurbSpline Methods

The ModelNurbSpline type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeToReferenceLine | Changes this curve to a reference curve. (Inherited from ModelCurve)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement)
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement)
Public method | SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ModelNurbSpline Class


ModelPath Class

A path to a file stored on a disk or on a server.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBModelPath
Autodesk.Revit.DBFilePath
Autodesk.Revit.DBServerPath

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ModelPath : IDisposable
Public Class ModelPath
    Implements IDisposable
public ref class ModelPath : IDisposable
type ModelPath =
    class
        interface IDisposable
    end

The ModelPath type exposes the following members.

Properties
 | Name | Description
Public property | CentralServerPath | The path to the location of the central Revit server or cloud.
Public property | CloudPath | Whether this path represents a path on an Autodesk server such as BIM360.
Public property | Empty | Whether this path is empty
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Region | The region of the BIM 360 Docs or Autodesk Docs account and project which contains this model.
Public property | ServerPath | Whether this path is a server path (as opposed to a file path or cloud path)
Top
Methods
 | Name | Description
Public method | Compare | Compares this ModelPath with another
Public method | Dispose | Releases all resources used by the ModelPath
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetModelGUID | A GUID identifying the Revit cloud model.
Public method | GetProjectGUID | A GUID identifying the BIM 360 Docs or Autodesk Docs project to which the model is associated.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
ModelPaths are paths to another file. They can refer to Revit models, or to any of Revit's external file references (DWG links, for example.) Paths can be relative or absolute, but they must include an extension indicating what kind of file it is. Relative paths are generally relative to the currently opened document. If the current document is workshared, paths will be treated as relative to the central model. To create a ModelPath, use the derived classes FilePath , ServerPath, or use [!:Autodesk::Revit::DB::ModelPathUtils::ConvertCloudGUIDsToCloudPath(System::Guid, System::Guid)] for a cloud model path. The class ModelPathUtils contains utility functions for converting ModelPaths to and from strings.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ModelPath Properties

The ModelPath type exposes the following members.

Properties
 | Name | Description
Public property | CentralServerPath | The path to the location of the central Revit server or cloud.
Public property | CloudPath | Whether this path represents a path on an Autodesk server such as BIM360.
Public property | Empty | Whether this path is empty
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Region | The region of the BIM 360 Docs or Autodesk Docs account and project which contains this model.
Public property | ServerPath | Whether this path is a server path (as opposed to a file path or cloud path)
Top
See Also

Reference

ModelPath Class


ModelPath.CentralServerPath Property

ModelPathCentralServerPath Property

The path to the location of the central Revit server or cloud.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string CentralServerPath { get; }
Public ReadOnly Property CentralServerPath As String
    Get
public:
property String^ CentralServerPath {
    String^ get ();
}
member CentralServerPath : string with get

Property Value

String
See Also

Reference

ModelPath Class


ModelPath.CloudPath Property

ModelPathCloudPath Property

Whether this path represents a path on an Autodesk server such as BIM360.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CloudPath { get; }
Public ReadOnly Property CloudPath As Boolean
    Get
public:
property bool CloudPath {
    bool get ();
}
member CloudPath : bool with get

Property Value

Boolean
See Also

Reference

ModelPath Class


ModelPath.Empty Property

ModelPathEmpty Property

Whether this path is empty

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Empty { get; }
Public ReadOnly Property Empty As Boolean
    Get
public:
property bool Empty {
    bool get ();
}
member Empty : bool with get

Property Value

Boolean
See Also

Reference

ModelPath Class


ModelPath.IsValidObject Property

ModelPathIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ModelPath Class


ModelPath.Region Property

ModelPathRegion Property

The region of the BIM 360 Docs or Autodesk Docs account and project which contains this model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Region { get; }
Public ReadOnly Property Region As String
    Get
public:
property String^ Region {
    String^ get ();
}
member Region : string with get

Property Value

String
See Also

Reference

ModelPath Class


ModelPath.ServerPath Property

ModelPathServerPath Property

Whether this path is a server path (as opposed to a file path or cloud path)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ServerPath { get; }
Public ReadOnly Property ServerPath As Boolean
    Get
public:
property bool ServerPath {
    bool get ();
}
member ServerPath : bool with get

Property Value

Boolean
See Also

Reference

ModelPath Class


ModelPath Methods

The ModelPath type exposes the following members.

Methods
 | Name | Description
Public method | Compare | Compares this ModelPath with another
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetModelGUID | A GUID identifying the Revit cloud model.
Public method | GetProjectGUID | A GUID identifying the BIM 360 Docs or Autodesk Docs project to which the model is associated.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ModelPath Class


ModelPath.Compare Method

ModelPathCompare Method

Compares this ModelPath with another

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Compare(
    ModelPath otherPath
)
Public Function Compare (
    otherPath As ModelPath
) As Integer
public:
int Compare(
    ModelPath^ otherPath
)
member Compare :
        otherPath : ModelPath -> int

Parameters

otherPath ModelPath
The path to compare against.

Return Value

Int32
A signed integer indicating the lexical relationship between two ModelPaths. Value is less than zero if this path is less than the given path; zero if the two are the same; and more than zero otherwise
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
The comparison is case-insensitive.
See Also

Reference

ModelPath Class


ModelPath.Dispose Method

ModelPathDispose Method

Releases all resources used by the ModelPath

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ModelPath Class


ModelPath.GetModelGUID Method

ModelPathGetModelGUID Method

A GUID identifying the Revit cloud model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid GetModelGUID()
Public Function GetModelGUID As Guid
public:
Guid GetModelGUID()
member GetModelGUID : unit -> Guid

Return Value

Guid
See Also

Reference

ModelPath Class


ModelPath.GetProjectGUID Method

ModelPathGetProjectGUID Method

A GUID identifying the BIM 360 Docs or Autodesk Docs project to which the model is associated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid GetProjectGUID()
Public Function GetProjectGUID As Guid
public:
Guid GetProjectGUID()
member GetProjectGUID : unit -> Guid

Return Value

Guid
See Also

Reference

ModelPath Class


ModelPathUtils Class

Utility functions using ModelPaths
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBModelPathUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ModelPathUtils
Public NotInheritable Class ModelPathUtils
public ref class ModelPathUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ModelPathUtils = class end

The ModelPathUtils type exposes the following members.

Properties
Name | Description
CloudRegionEMEA | The name of cloud region EMEA.
CloudRegionUS | The name of cloud region US.
Top
Methods
Name | Description
ConvertCloudGUIDsToCloudPath | Converts a pair of cloud project and model GUIDs to a valid cloud path.
ConvertModelPathToUserVisiblePath | Gets a string version of the path of a given ModelPath.
ConvertUserVisiblePathToModelPath | Converts a user-visible path (string) to a ModelPath.
IsValidUserVisibleFullServerPath | Determines whether the given string represents a valid server path.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ModelPathUtils Properties

The ModelPathUtils type exposes the following members.

Properties
Name | Description
CloudRegionEMEA | The name of cloud region EMEA.
CloudRegionUS | The name of cloud region US.
Top
See Also

Reference

ModelPathUtils Class


ModelPathUtils.CloudRegionEMEA Property

ModelPathUtilsCloudRegionEMEA Property

The name of cloud region EMEA.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CloudRegionEMEA { get; }
Public Shared ReadOnly Property CloudRegionEMEA As String
    Get
public:
static property String^ CloudRegionEMEA {
    String^ get ();
}
static member CloudRegionEMEA : string with get

Property Value

String
See Also

Reference

ModelPathUtils Class


ModelPathUtils.CloudRegionUS Property

ModelPathUtilsCloudRegionUS Property

The name of cloud region US.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string CloudRegionUS { get; }
Public Shared ReadOnly Property CloudRegionUS As String
    Get
public:
static property String^ CloudRegionUS {
    String^ get ();
}
static member CloudRegionUS : string with get

Property Value

String
See Also

Reference

ModelPathUtils Class


ModelPathUtils Methods

The ModelPathUtils type exposes the following members.

Methods
Name | Description
ConvertCloudGUIDsToCloudPath | Converts a pair of cloud project and model GUIDs to a valid cloud path.
ConvertModelPathToUserVisiblePath | Gets a string version of the path of a given ModelPath.
ConvertUserVisiblePathToModelPath | Converts a user-visible path (string) to a ModelPath.
IsValidUserVisibleFullServerPath | Determines whether the given string represents a valid server path.
Top
See Also

Reference

ModelPathUtils Class


ModelPathUtils.ConvertCloudGUIDsToCloudPath Method

ModelPathUtilsConvertCloudGUIDsToCloudPath Method

Converts a pair of cloud project and model GUIDs to a valid cloud path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ModelPath ConvertCloudGUIDsToCloudPath(
    string region,
    Guid projectGuid,
    Guid modelGuid
)
Public Shared Function ConvertCloudGUIDsToCloudPath (
    region As String,
    projectGuid As Guid,
    modelGuid As Guid
) As ModelPath
public:
static ModelPath^ ConvertCloudGUIDsToCloudPath(
    String^ region,
    Guid projectGuid,
    Guid modelGuid
)
static member ConvertCloudGUIDsToCloudPath :
        region : string *
        projectGuid : Guid *
        modelGuid : Guid -> ModelPath

Parameters

region String
The region of the BIM 360 Docs or Autodesk Docs account and project which contains this model. Please see the reference values, like CloudRegionUS and CloudRegionEMEA, and the new regions from release note.
projectGuid Guid
The GUID of the cloud project which contains the model.
modelGuid Guid
The GUID of the Revit cloud model.

Return Value

ModelPath
The cloud model path.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
CentralModelException | The cloud project is missing.
RevitServerCommunicationException | The central server could not be reached.
RevitServerUnauthenticatedUserException | You must sign in to Autodesk 360 in order to complete action.
RevitServerUnauthorizedException | You are unauthorized to access this resource.
See Also

Reference

ModelPathUtils Class


ModelPathUtils.ConvertModelPathToUserVisiblePath Method

ModelPathUtilsConvertModelPathToUserVisiblePath Method

Gets a string version of the path of a given ModelPath.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string ConvertModelPathToUserVisiblePath(
    ModelPath path
)
Public Shared Function ConvertModelPathToUserVisiblePath (
    path As ModelPath
) As String
public:
static String^ ConvertModelPathToUserVisiblePath(
    ModelPath^ path
)
static member ConvertModelPathToUserVisiblePath :
        path : ModelPath -> string

Parameters

path ModelPath
A ModelPath representing a file path or a server path.

Return Value

String
The path in string form
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ModelPathUtils Class


ModelPathUtils.ConvertUserVisiblePathToModelPath Method

ModelPathUtilsConvertUserVisiblePathToModelPath Method

Converts a user-visible path (string) to a ModelPath.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ModelPath ConvertUserVisiblePathToModelPath(
    string strPath
)
Public Shared Function ConvertUserVisiblePathToModelPath (
    strPath As String
) As ModelPath
public:
static ModelPath^ ConvertUserVisiblePathToModelPath(
    String^ strPath
)
static member ConvertUserVisiblePathToModelPath :
        strPath : string -> ModelPath

Parameters

strPath String
The path in string form, like RSN://{HostNodeName}/school/project.rvt

Return Value

ModelPath
A ModelPath representing either a server or file path.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
The path may be a server or file path.
See Also

Reference

ModelPathUtils Class


ModelPathUtils.IsValidUserVisibleFullServerPath Method

ModelPathUtilsIsValidUserVisibleFullServerPath Method

Determines whether the given string represents a valid server path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidUserVisibleFullServerPath(
    string strPath
)
Public Shared Function IsValidUserVisibleFullServerPath (
    strPath As String
) As Boolean
public:
static bool IsValidUserVisibleFullServerPath(
    String^ strPath
)
static member IsValidUserVisibleFullServerPath :
        strPath : string -> bool

Parameters

strPath String
The path, in string form

Return Value

Boolean
True if the given path is a valid server path, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks

ServerPaths must refer to Revit models.

ServerPaths are relative to the central server location, and are of the form "RSN://{HostNodeName}/{model_path}".

The {model_path} portion is a relative path to a Revit model. For example:

  • RSN://EXS/hospital.rvt
  • RSN://EXS.autodesk.com/Old Files/hotel2.rvt
  • RSN://EXS.autodesk.com/Old Files/Last Week/Tuesday\hotel2.rvt
are all valid server paths.
  • //EXS/Old Files/.rvt
  • EXS/hospital
are not valid server paths. If this function returns false, it does not necessarily mean the given path is a file path. It may be a malformed string.
See Also

Reference

ModelPathUtils Class


ModelText Class

A model text element in an Autodesk Revit family document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBModelText

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ModelText : Element
Public Class ModelText
    Inherits Element
public ref class ModelText : public Element
type ModelText =
    class
        inherit Element
    end

The ModelText type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
Public property | Depth | The depth of the model text.
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HorizontalAlignment | The horizontal alignment.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | Location | This property is used to find the physical location of an instance within project. (Overrides ElementLocation)
Public property | ModelTextType | The type for the model text.
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Subcategory | The subcategory.
Public property | Text | The text string in the model text.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetVisibility | Gets the visibility for the model text in a family document.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetVisibility | Sets the visibility for the model text in a family document.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ModelText Properties

The ModelText type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
Public property | Depth | The depth of the model text.
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HorizontalAlignment | The horizontal alignment.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | Location | This property is used to find the physical location of an instance within project. (Overrides ElementLocation)
Public property | ModelTextType | The type for the model text.
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Subcategory | The subcategory.
Public property | Text | The text string in the model text.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

ModelText Class


ModelText.Depth Property

ModelTextDepth Property

The depth of the model text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Depth { get; set; }
Public Property Depth As Double
    Get
    Set
public:
property double Depth {
    double get ();
    void set (double value);
}
member Depth : float with get, set

Property Value

Double
See Also

Reference

ModelText Class


ModelText.HorizontalAlignment Property

ModelTextHorizontalAlignment Property

The horizontal alignment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public HorizontalAlign HorizontalAlignment { get; set; }
Public Property HorizontalAlignment As HorizontalAlign
    Get
    Set
public:
property HorizontalAlign HorizontalAlignment {
    HorizontalAlign get ();
    void set (HorizontalAlign value);
}
member HorizontalAlignment : HorizontalAlign with get, set

Property Value

HorizontalAlign
Exceptions
Exception | Condition
ArgumentException | Thrown when an invalid value is assigned to the property.
See Also

Reference

ModelText Class


ModelText.Location Property

ModelTextLocation Property

This property is used to find the physical location of an instance within project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Location Location { get; }
Public Overrides ReadOnly Property Location As Location
    Get
public:
virtual property Location^ Location {
    Location^ get () override;
}
abstract Location : Location with get
override Location : Location with get

Property Value

Location
See Also

Reference

ModelText Class


ModelText.ModelTextType Property

ModelTextModelTextType Property

The type for the model text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ModelTextType ModelTextType { get; set; }
Public Property ModelTextType As ModelTextType
    Get
    Set
public:
property ModelTextType^ ModelTextType {
    ModelTextType^ get ();
    void set (ModelTextType^ value);
}
member ModelTextType : ModelTextType with get, set

Property Value

ModelTextType
Exceptions
Exception | Condition
ArgumentNullException | Thrown when is assigned to this property.
See Also

Reference

ModelText Class


ModelText.Subcategory Property

ModelTextSubcategory Property

The subcategory.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Category Subcategory { get; set; }
Public Property Subcategory As Category
    Get
    Set
public:
property Category^ Subcategory {
    Category^ get ();
    void set (Category^ value);
}
member Subcategory : Category with get, set

Property Value

Category
Remarks
The subcategory can be set to either the family category or one of its subcategories.
See Also

Reference

ModelText Class


ModelText.Text Property

ModelTextText Property

The text string in the model text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
member Text : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | Thrown when is assigned to text.
ArgumentException | Thrown when an empty string is assigned to text.
See Also

Reference

ModelText Class


ModelText Methods

The ModelText type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetVisibility | Gets the visibility for the model text in a family document.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetVisibility | Sets the visibility for the model text in a family document.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ModelText Class


ModelText.GetVisibility Method

ModelTextGetVisibility Method

Gets the visibility for the model text in a family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyElementVisibility GetVisibility()
Public Function GetVisibility As FamilyElementVisibility
public:
FamilyElementVisibility^ GetVisibility()
member GetVisibility : unit -> FamilyElementVisibility

Return Value

FamilyElementVisibility
A copy of visibility settings for the model text in a family document.
See Also

Reference

ModelText Class


ModelText.SetVisibility Method

ModelTextSetVisibility Method

Sets the visibility for the model text in a family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetVisibility(
    FamilyElementVisibility visibility
)
Public Sub SetVisibility (
    visibility As FamilyElementVisibility
)
public:
void SetVisibility(
    FamilyElementVisibility^ visibility
)
member SetVisibility :
        visibility : FamilyElementVisibility -> unit

Parameters

visibility FamilyElementVisibility
Exceptions
Exception | Condition
ArgumentNullException | Thrown when visibility is .
InvalidOperationException | Thrown when regeneration failed, or the model curve is in a project document.
Remarks
The visibility of the model text geometry can be changed for different types of views and detail levels in the family document.
See Also

Reference

ModelText Class


ModelTextType Class

A model text type symbol in the Autodesk Revit Family document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBModelTextType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ModelTextType : ElementType
Public Class ModelTextType
    Inherits ElementType
public ref class ModelTextType : public ElementType
type ModelTextType =
    class
        inherit ElementType
    end

The ModelTextType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ModelTextType Properties

The ModelTextType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

ModelTextType Class


ModelTextType Methods

The ModelTextType type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ModelTextType Class


ModelUpdatesStatus Enumeration

Indicates whether an element in the current model has additional user changes in the central model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ModelUpdatesStatus
Public Enumeration ModelUpdatesStatus
public enum class ModelUpdatesStatus
type ModelUpdatesStatus
Members
Member name | Value | Description
CurrentWithCentral | 0 | The element has no additional changes in the central model.
NotYetInCentral | 1 | The element is new in the current model and has not been saved to the central model. Note that this status will apply to newly created elements even if they are created in the central model.
DeletedInCentral | 2 | The element has been deleted in the central model.
UpdatedInCentral | 3 | The element has additional user changes in the central model. A reload latest will be required before it can be modified in the current model.
Remarks

Note that this status only indicates that the element has user changes in the central model. A user change is typically an action specifically taken by a user. Making a user change to an element requires that the user making the change reload all other user changes made to the element in the central model. Making a user change also causes the element to be checked out to the current user so other users will not be able to make user changes to the same element.

Elements can also be modified by system changes. A system change is one which is done automatically by Revit to fully update the model after a user change occurs. Users may make changes to an element in their local model even if the element contains additional system changes in the central model.

Example: Suppose Alice and Bob are working on the same model. Alice moves a wall which contains windows. Then Alice synchronizes with the central file. The wall was explicitly changed by Alice and so it will report as "UpdatedInCentral" in Bob's model. Bob would have to reload latest before he could make user changes to that wall. In contrast, Revit automatically moved the windows with the wall, so the windows do not contain any user changes. The windows would therefore report "CurrentWithCentral" and Bob would be allowed to modify them in his local model without reloading latest.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ModifierType Enumeration

An enumerated type listing options to appear in the exported layer name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ModifierType
Public Enumeration ModifierType
public enum class ModifierType
type ModifierType
Members
Member name | Value | Description
Category | 0 | Signals that the name of the category will appear in the layer name.
Custom1 | 1 | Signals that the first custom string will appear in the layer name.
Custom2 | 2 | Signals that the second custom string will appear in the layer name.
Custom3 | 3 | Signals that the third custom string will appear in the layer name.
FireRating | 4 | Signals that the value of fire rating will appear in the layer name.
Function | 5 | Signals that the value of function will appear in the layer name.
Level | 6 | Signals that the name of the level will appear in the layer name.
PhaseCreated | 7 | Signals that the name of the created phase will appear in the layer name.
PhaseDemolished | 8 | Signals that the name of the demolition phase will appear in the layer name.
PhaseStatus | 9 | Signals that the value of of phase status will appear in the layer name.
UnknownType | -1 | An unknown (default) type of modifier, not acceptable for assignment.
StructuralMaterialType | 10 | Signals that the value of structural material type will appear in the layer name.
StructuralUsage | 11 | Signals that the value of structural usage will appear in the layer name.
SystemName | 12 | Signals that the system name will appear in the layer name.
SystemType | 13 | Signals that the system type will appear in the layer name.
Underlay | 14 | Signals that the name of the underlay will appear in the layer name.
ViewType | 15 | Signals that the view type will appear in the layer name.
Workset | 16 | Signals that the name of the workset will appear in the layer name.
AnalyzesAs | 17 | Signals that the value of the AnalyzesAs parameter will appear in the layer name.
SystemClassification | 18 | Signals that the system classification will appear in the layer name.
DomainType | 19 | Signals that the domain type will appear in the layer name.
FabricationService | 20 | Signals that the fabrication service will appear in the layer name.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Mullion Class

Represents a CurtainGrid within Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBInstance
Autodesk.Revit.DBFamilyInstance
Autodesk.Revit.DBMullion

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Mullion : FamilyInstance
Public Class Mullion
    Inherits FamilyInstance
public ref class Mullion : public FamilyInstance
type Mullion =
    class
        inherit FamilyInstance
    end

The Mullion type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanFlipFacing | Property to test whether the orientation of family instance facing can be flipped. (Inherited from FamilyInstance)
Public property | CanFlipHand | Property to test whether the orientation of family instance hand can be flipped. (Inherited from FamilyInstance)
Public property | CanFlipWorkPlane | Identifies if the instance can flip its work plane. (Inherited from FamilyInstance)
Public property | CanRotate | Property to test whether the family instance can be rotated by 180 degrees. (Inherited from FamilyInstance)
Public property | CanSplit | Identifies whether a particular family instance can be split at a point on it's defining curve (by Split(Double)). (Inherited from FamilyInstance)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | ExtensionUtility | Property to check whether the instance can be extended and return the interface for extension operation. (Inherited from FamilyInstance)
Public property | FacingFlipped | Property to test whether the orientation of family instance facing is flipped. (Inherited from FamilyInstance)
Public property | FacingOrientation | Property to get the orientation of family instance facing. (Inherited from FamilyInstance)
Public property | FromRoom | The "From Room" set for the door or window in the last phase of the project. (Inherited from FamilyInstance)
Public property | FromRoomPhase | (Inherited from FamilyInstance)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HandFlipped | Property to test whether the orientation of family instance hand is flipped. (Inherited from FamilyInstance)
Public property | HandOrientation | Property to get the orientation of family instance hand. (Inherited from FamilyInstance)
Public property | HasSpatialElementCalculationPoint | Identifies if this instance has a single SpatialElementCalculationPoint used as the search point for Revit to identify if the instance is inside a room or space. (Inherited from FamilyInstance)
Public property | HasSpatialElementFromToCalculationPoints | Identifies if this instance has a pair of SpatialElementCalculationPoints used as the search points for Revit to identify if the instance lies between up to two rooms or spaces. (Inherited from FamilyInstance)
Public property | Host | If the instance is contained within another element, this property returns the containing element. An instance that is face hosted will return the element containing the face. (Inherited from FamilyInstance)
Public property | HostFace | Property to get the reference to the host face of family instance. (Inherited from FamilyInstance)
Public property | HostParameter | If the instance is hosted by a wall, this property returns the parameter value of the insertion point of the instance along the wall's location curve, as long as the family of the instance isn't work plane based. (Inherited from FamilyInstance)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | Invisible | Property to test whether the family instance is invisible. (Inherited from FamilyInstance)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsSlantedColumn | Indicates if the family instance is a slanted column. (Inherited from FamilyInstance)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | IsWorkPlaneFlipped | Identifies if the instance's work plane is flipped. (Inherited from FamilyInstance)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | Location | This property is used to find the physical location of an instance within project. (Inherited from FamilyInstance)
Public property | LocationCurve | This method get the curve location of the current Mullion.
Public property | Lock | Get - to get whether the Mullion line is locked. Set - Lock/unlock the Mullion.
Public property | Lockable | Get - to get whether the Mullion can be lock or unlock.
Public property | MEPModel | Retrieves the MEP model for the family instance. (Inherited from FamilyInstance)
Public property | Mirrored | Property to test whether the family instance is mirrored. (only one axis is flipped) (Inherited from FamilyInstance)
Public property | MullionType | The MullionType style of this Mullion. Get - to access type of mullion Set - change type of mullion. If the mullion is locked, InvalidOperationException exception will be thrown.
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Room | The room in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance)
Public property | RoomPhase | (Inherited from FamilyInstance)
Public property | Space | The space in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance)
Public property | SpacePhase | (Inherited from FamilyInstance)
Public property | StructuralMaterialId | Identifies the material that defines the instance's structural analysis properties. (Inherited from FamilyInstance)
Public property | StructuralMaterialType | This property returns the physical material from which the instance is made. (Inherited from FamilyInstance)
 | StructuralType | Provides the primary structural type of the instance, such as beam or column etc. (Inherited from FamilyInstance)
Public property | StructuralUsage | Provides the primary structural usage of the instance, such as brace, girder etc. (Inherited from FamilyInstance)
Public property | SuperComponent | Property to get the super component of current family instance. (Inherited from FamilyInstance)
 | Symbol | Returns or changes the FamilySymbol object that represents the type of the instance. (Inherited from FamilyInstance)
Public property | ToRoom | The "To Room" set for the door or window in the last phase of the project. (Inherited from FamilyInstance)
Public property | ToRoomPhase | (Inherited from FamilyInstance)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | AddCoping | Adds a coping (cut) to a steel beam. (Inherited from FamilyInstance)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | BreakMullion | This method is used to break the current Mullion at ends with its neighboring mullions.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | flipFacing | The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance)
Public method | FlipFromToRoom | Flips the settings of "From Room" and "To Room" for the door or window instance. (Inherited from FamilyInstance)
Public method | flipHand | The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance)
Public method | GetCopingIds | Lists the elements currently used as coping cutters for this element. (Inherited from FamilyInstance)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFamilyPointPlacementReferences | Returns the Point Placement References for the Family Instance. (Inherited from FamilyInstance)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetOriginalGeometry | Returns the original geometry of the instance, before the instance is modified by joins, cuts, coping, extensions, or other post-processing. (Inherited from FamilyInstance)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetReferenceByName | Gets the family instance reference corresponding to the named reference plane in the instance's family. (Inherited from FamilyInstance)
Public method | GetReferenceName | Gets the name of the reference plane in the family corresponding to the given family instance reference. (Inherited from FamilyInstance)
Public method | GetReferences | Gets family instance references corresponding to the reference planes or reference lines of the given reference type in the instance's family. (Inherited from FamilyInstance)
Public method | GetReferenceType | Gets the type of the reference plane or reference line in the instance's family corresponding to the given family instance reference. (Inherited from FamilyInstance)
Public method | GetSpatialElementCalculationPoint | Gets the location of the calculation point for this instance. (Inherited from FamilyInstance)
Public method | GetSpatialElementFromToCalculationPoints | Gets the locations for the calculation points for this instance. (Inherited from FamilyInstance)
 | GetSubComponentIds | Gets the sub component ElementIds of the current family instance. (Inherited from FamilyInstance)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetSweptProfile | Gets the object that describes the profile that is swept along the driving curve for this instance. (Inherited from FamilyInstance)
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances. (Inherited from Instance)
Public method | GetTransform | Gets the transform of the instance. (Inherited from Instance)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasModifiedGeometry | Identifies if the geometry of this FamilyInstance has been modified from the automatically generated default. (Inherited from FamilyInstance)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasSweptProfile | Indicates if this instance can be represented as a swept profile. (Inherited from FamilyInstance)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | JoinMullion | This method is used to control the join condition the current Mullion with its neighboring mullions.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveCoping | Removes a coping (cut) from a steel beam. (Inherited from FamilyInstance)
Public method | rotate | The family instance will be flipped by 180 degrees. If it can not be rotated, return false, otherwise return true. (Inherited from FamilyInstance)
Public method | SetCopingIds | Specifies the set of coping cutters on this element. (Inherited from FamilyInstance)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | Split | Splits the family instance element at a point on its defining curve. (Inherited from FamilyInstance)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Mullion Properties

The Mullion type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanFlipFacing | Property to test whether the orientation of family instance facing can be flipped. (Inherited from FamilyInstance)
Public property | CanFlipHand | Property to test whether the orientation of family instance hand can be flipped. (Inherited from FamilyInstance)
Public property | CanFlipWorkPlane | Identifies if the instance can flip its work plane. (Inherited from FamilyInstance)
Public property | CanRotate | Property to test whether the family instance can be rotated by 180 degrees. (Inherited from FamilyInstance)
Public property | CanSplit | Identifies whether a particular family instance can be split at a point on it's defining curve (by Split(Double)). (Inherited from FamilyInstance)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | ExtensionUtility | Property to check whether the instance can be extended and return the interface for extension operation. (Inherited from FamilyInstance)
Public property | FacingFlipped | Property to test whether the orientation of family instance facing is flipped. (Inherited from FamilyInstance)
Public property | FacingOrientation | Property to get the orientation of family instance facing. (Inherited from FamilyInstance)
Public property | FromRoom | The "From Room" set for the door or window in the last phase of the project. (Inherited from FamilyInstance)
Public property | FromRoomPhase | (Inherited from FamilyInstance)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HandFlipped | Property to test whether the orientation of family instance hand is flipped. (Inherited from FamilyInstance)
Public property | HandOrientation | Property to get the orientation of family instance hand. (Inherited from FamilyInstance)
Public property | HasSpatialElementCalculationPoint | Identifies if this instance has a single SpatialElementCalculationPoint used as the search point for Revit to identify if the instance is inside a room or space. (Inherited from FamilyInstance)
Public property | HasSpatialElementFromToCalculationPoints | Identifies if this instance has a pair of SpatialElementCalculationPoints used as the search points for Revit to identify if the instance lies between up to two rooms or spaces. (Inherited from FamilyInstance)
Public property | Host | If the instance is contained within another element, this property returns the containing element. An instance that is face hosted will return the element containing the face. (Inherited from FamilyInstance)
Public property | HostFace | Property to get the reference to the host face of family instance. (Inherited from FamilyInstance)
Public property | HostParameter | If the instance is hosted by a wall, this property returns the parameter value of the insertion point of the instance along the wall's location curve, as long as the family of the instance isn't work plane based. (Inherited from FamilyInstance)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | Invisible | Property to test whether the family instance is invisible. (Inherited from FamilyInstance)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsSlantedColumn | Indicates if the family instance is a slanted column. (Inherited from FamilyInstance)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | IsWorkPlaneFlipped | Identifies if the instance's work plane is flipped. (Inherited from FamilyInstance)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | Location | This property is used to find the physical location of an instance within project. (Inherited from FamilyInstance)
Public property | LocationCurve | This method get the curve location of the current Mullion.
Public property | Lock | Get - to get whether the Mullion line is locked. Set - Lock/unlock the Mullion.
Public property | Lockable | Get - to get whether the Mullion can be lock or unlock.
Public property | MEPModel | Retrieves the MEP model for the family instance. (Inherited from FamilyInstance)
Public property | Mirrored | Property to test whether the family instance is mirrored. (only one axis is flipped) (Inherited from FamilyInstance)
Public property | MullionType | The MullionType style of this Mullion. Get - to access type of mullion Set - change type of mullion. If the mullion is locked, InvalidOperationException exception will be thrown.
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Room | The room in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance)
Public property | RoomPhase | (Inherited from FamilyInstance)
Public property | Space | The space in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance)
Public property | SpacePhase | (Inherited from FamilyInstance)
Public property | StructuralMaterialId | Identifies the material that defines the instance's structural analysis properties. (Inherited from FamilyInstance)
Public property | StructuralMaterialType | This property returns the physical material from which the instance is made. (Inherited from FamilyInstance)
 | StructuralType | Provides the primary structural type of the instance, such as beam or column etc. (Inherited from FamilyInstance)
Public property | StructuralUsage | Provides the primary structural usage of the instance, such as brace, girder etc. (Inherited from FamilyInstance)
Public property | SuperComponent | Property to get the super component of current family instance. (Inherited from FamilyInstance)
 | Symbol | Returns or changes the FamilySymbol object that represents the type of the instance. (Inherited from FamilyInstance)
Public property | ToRoom | The "To Room" set for the door or window in the last phase of the project. (Inherited from FamilyInstance)
Public property | ToRoomPhase | (Inherited from FamilyInstance)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

Mullion Class


Mullion.LocationCurve Property

MullionLocationCurve Property

This method get the curve location of the current Mullion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Curve LocationCurve { get; }
Public ReadOnly Property LocationCurve As Curve
    Get
public:
property Curve^ LocationCurve {
    Curve^ get ();
}
member LocationCurve : Curve with get

Property Value

Curve
See Also

Reference

Mullion Class


Mullion.Lock Property

MullionLock Property

Get - to get whether the Mullion line is locked. Set - Lock/unlock the Mullion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Lock { get; set; }
Public Property Lock As Boolean
    Get
    Set
public:
property bool Lock {
    bool get ();
    void set (bool value);
}
member Lock : bool with get, set

Property Value

Boolean
See Also

Reference

Mullion Class


Mullion.Lockable Property

MullionLockable Property

Get - to get whether the Mullion can be lock or unlock.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Lockable { get; }
Public ReadOnly Property Lockable As Boolean
    Get
public:
property bool Lockable {
    bool get ();
}
member Lockable : bool with get

Property Value

Boolean
See Also

Reference

Mullion Class


Mullion.MullionType Property

MullionMullionType Property

The MullionType style of this Mullion. Get - to access type of mullion Set - change type of mullion. If the mullion is locked, InvalidOperationException exception will be thrown.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MullionType MullionType { get; set; }
Public Property MullionType As MullionType
    Get
    Set
public:
property MullionType^ MullionType {
    MullionType^ get ();
    void set (MullionType^ value);
}
member MullionType : MullionType with get, set

Property Value

MullionType
See Also

Reference

Mullion Class


Mullion Methods

The Mullion type exposes the following members.

Methods
 | Name | Description
Public method | AddCoping | Adds a coping (cut) to a steel beam. (Inherited from FamilyInstance)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | BreakMullion | This method is used to break the current Mullion at ends with its neighboring mullions.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | flipFacing | The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance)
Public method | FlipFromToRoom | Flips the settings of "From Room" and "To Room" for the door or window instance. (Inherited from FamilyInstance)
Public method | flipHand | The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance)
Public method | GetCopingIds | Lists the elements currently used as coping cutters for this element. (Inherited from FamilyInstance)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFamilyPointPlacementReferences | Returns the Point Placement References for the Family Instance. (Inherited from FamilyInstance)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetOriginalGeometry | Returns the original geometry of the instance, before the instance is modified by joins, cuts, coping, extensions, or other post-processing. (Inherited from FamilyInstance)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetReferenceByName | Gets the family instance reference corresponding to the named reference plane in the instance's family. (Inherited from FamilyInstance)
Public method | GetReferenceName | Gets the name of the reference plane in the family corresponding to the given family instance reference. (Inherited from FamilyInstance)
Public method | GetReferences | Gets family instance references corresponding to the reference planes or reference lines of the given reference type in the instance's family. (Inherited from FamilyInstance)
Public method | GetReferenceType | Gets the type of the reference plane or reference line in the instance's family corresponding to the given family instance reference. (Inherited from FamilyInstance)
Public method | GetSpatialElementCalculationPoint | Gets the location of the calculation point for this instance. (Inherited from FamilyInstance)
Public method | GetSpatialElementFromToCalculationPoints | Gets the locations for the calculation points for this instance. (Inherited from FamilyInstance)
 | GetSubComponentIds | Gets the sub component ElementIds of the current family instance. (Inherited from FamilyInstance)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetSweptProfile | Gets the object that describes the profile that is swept along the driving curve for this instance. (Inherited from FamilyInstance)
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances. (Inherited from Instance)
Public method | GetTransform | Gets the transform of the instance. (Inherited from Instance)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasModifiedGeometry | Identifies if the geometry of this FamilyInstance has been modified from the automatically generated default. (Inherited from FamilyInstance)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasSweptProfile | Indicates if this instance can be represented as a swept profile. (Inherited from FamilyInstance)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | JoinMullion | This method is used to control the join condition the current Mullion with its neighboring mullions.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveCoping | Removes a coping (cut) from a steel beam. (Inherited from FamilyInstance)
Public method | rotate | The family instance will be flipped by 180 degrees. If it can not be rotated, return false, otherwise return true. (Inherited from FamilyInstance)
Public method | SetCopingIds | Specifies the set of coping cutters on this element. (Inherited from FamilyInstance)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | Split | Splits the family instance element at a point on its defining curve. (Inherited from FamilyInstance)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Mullion Class


Mullion.BreakMullion Method

MullionBreakMullion Method

This method is used to break the current Mullion at ends with its neighboring mullions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void BreakMullion()
Public Sub BreakMullion
public:
void BreakMullion()
member BreakMullion : unit -> unit
Remarks
The mullions being perpendicular to it will be joined accordingly.
See Also

Reference

Mullion Class


Mullion.JoinMullion Method

MullionJoinMullion Method

This method is used to control the join condition the current Mullion with its neighboring mullions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void JoinMullion()
Public Sub JoinMullion
public:
void JoinMullion()
member JoinMullion : unit -> unit
Remarks
The mullions being perpendicular to it will be broken accordingly.
See Also

Reference

Mullion Class


MullionType Class

An object that represents a mullion type.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBInsertableObject
Autodesk.Revit.DBFamilySymbol
Autodesk.Revit.DBMullionType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MullionType : FamilySymbol
Public Class MullionType
    Inherits FamilySymbol
public ref class MullionType : public FamilySymbol
type MullionType =
    class
        inherit FamilySymbol
    end

The MullionType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | Family | The Family object to which the symbol belongs. (Inherited from FamilySymbol)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsActive | Identifies whether the symbol is active. (Inherited from FamilySymbol)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | StructuralMaterialType | This property returns the physical material from which the type is made. (Inherited from FamilySymbol)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | Activate | Activates the symbol to ensure that its geometry is accessible. (Inherited from FamilySymbol)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveStructuralSection | Identifies if this FamilySymbol can have a structural section. (Inherited from FamilySymbol)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFamilyPointLocations | Returns the Point Locations for the Family Symbol. (Inherited from FamilySymbol)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetStructuralSection | Gets the structural section from element. (Inherited from FamilySymbol)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetThermalProperties | Gets the thermal properties for the given FamilySymbol. (Inherited from FamilySymbol)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasThermalProperties | Identifies if this FamilySymbol can include thermal properties. (Inherited from FamilySymbol)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetStructuralSection | Sets the structural section in element. (Inherited from FamilySymbol)
Public method | SetThermalProperties | Sets the thermal properties for the given FamilySymbol. (Inherited from FamilySymbol)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


MullionType Properties

The MullionType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | Family | The Family object to which the symbol belongs. (Inherited from FamilySymbol)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsActive | Identifies whether the symbol is active. (Inherited from FamilySymbol)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | StructuralMaterialType | This property returns the physical material from which the type is made. (Inherited from FamilySymbol)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

MullionType Class


MullionType Methods

The MullionType type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Activates the symbol to ensure that its geometry is accessible. (Inherited from FamilySymbol)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveStructuralSection | Identifies if this FamilySymbol can have a structural section. (Inherited from FamilySymbol)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFamilyPointLocations | Returns the Point Locations for the Family Symbol. (Inherited from FamilySymbol)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetStructuralSection | Gets the structural section from element. (Inherited from FamilySymbol)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetThermalProperties | Gets the thermal properties for the given FamilySymbol. (Inherited from FamilySymbol)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasThermalProperties | Identifies if this FamilySymbol can include thermal properties. (Inherited from FamilySymbol)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetStructuralSection | Sets the structural section in element. (Inherited from FamilySymbol)
Public method | SetThermalProperties | Sets the thermal properties for the given FamilySymbol. (Inherited from FamilySymbol)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MullionType Class


MullionTypeSet Class

A set that contains mullion types.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBMullionTypeSet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MullionTypeSet : APIObject,
    IEnumerable
Public Class MullionTypeSet
    Inherits APIObject
    Implements IEnumerable
public ref class MullionTypeSet : public APIObject,
    IEnumerable
type MullionTypeSet =
    class
        inherit APIObject
        interface IEnumerable
    end

The MullionTypeSet type exposes the following members.

Constructors
 | Name | Description
Public method | MullionTypeSet | Initializes a new instance of the MullionTypeSet class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Size | Returns the number of mullion types that are in the set.
Top
Methods
 | Name | Description
Public method | Clear | Removes every mullion type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a mullion type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase | Removes a specified mullion type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified mullion type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


MullionTypeSet Constructor

Initializes a new instance of the MullionTypeSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MullionTypeSet()
Public Sub New
public:
MullionTypeSet()
new : unit -> MullionTypeSet
See Also

Reference

MullionTypeSet Class


MullionTypeSet Properties

The MullionTypeSet type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Size | Returns the number of mullion types that are in the set.
Top
See Also

Reference

MullionTypeSet Class


MullionTypeSet.IsEmpty Property

MullionTypeSetIsEmpty Property

Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Boolean
Remarks
If the set is empty then True will be returned, otherwise False.
See Also

Reference

MullionTypeSet Class


MullionTypeSet.Size Property

MullionTypeSetSize Property

Returns the number of mullion types that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
abstract Size : int with get
override Size : int with get

Property Value

Int32
See Also

Reference

MullionTypeSet Class


MullionTypeSet Methods

The MullionTypeSet type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Removes every mullion type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a mullion type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase | Removes a specified mullion type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified mullion type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MullionTypeSet Class


MullionTypeSet.Clear Method

MullionTypeSetClear Method

Removes every mullion type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

MullionTypeSet Class


MullionTypeSet.Contains Method

MullionTypeSetContains Method

Tests for the existence of a mullion type within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Contains(
    MullionType item
)
Public Overridable Function Contains (
    item As MullionType
) As Boolean
public:
virtual bool Contains(
    MullionType^ item
)
abstract Contains :
        item : MullionType -> bool
override Contains :
        item : MullionType -> bool

Parameters

item MullionType
The mullion type to be searched for.

Return Value

Boolean
The Contains method returns True if the mullion type is within the set, otherwise False.
See Also

Reference

MullionTypeSet Class


MullionTypeSet.Erase Method

MullionTypeSetErase Method

Removes a specified mullion type from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Erase(
    MullionType item
)
Public Overridable Function Erase (
    item As MullionType
) As Integer
public:
virtual int Erase(
    MullionType^ item
)
abstract Erase :
        item : MullionType -> int
override Erase :
        item : MullionType -> int

Parameters

item MullionType
The mullion type to be erased.

Return Value

Int32
The number of mullion types that were erased from the set.
See Also

Reference

MullionTypeSet Class


MullionTypeSet.ForwardIterator Method

MullionTypeSetForwardIterator Method

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual MullionTypeSetIterator ForwardIterator()
Public Overridable Function ForwardIterator As MullionTypeSetIterator
public:
virtual MullionTypeSetIterator^ ForwardIterator()
abstract ForwardIterator : unit -> MullionTypeSetIterator
override ForwardIterator : unit -> MullionTypeSetIterator

Return Value

MullionTypeSetIterator
Returns a forward moving iterator to the set.
See Also

Reference

MullionTypeSet Class


MullionTypeSet.GetEnumerator Method

MullionTypeSetGetEnumerator Method

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

IEnumerator
Returns a forward moving iterator to the set.

Implements

IEnumerableGetEnumerator
See Also

Reference

MullionTypeSet Class


MullionTypeSet.Insert Method

MullionTypeSetInsert Method

Insert the specified mullion type into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Insert(
    MullionType item
)
Public Overridable Function Insert (
    item As MullionType
) As Boolean
public:
virtual bool Insert(
    MullionType^ item
)
abstract Insert :
        item : MullionType -> bool
override Insert :
        item : MullionType -> bool

Parameters

item MullionType
The mullion type to be inserted into the set.

Return Value

Boolean
Returns whether the mullion type was inserted into the set.
See Also

Reference

MullionTypeSet Class


MullionTypeSet.ReverseIterator Method

MullionTypeSetReverseIterator Method

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual MullionTypeSetIterator ReverseIterator()
Public Overridable Function ReverseIterator As MullionTypeSetIterator
public:
virtual MullionTypeSetIterator^ ReverseIterator()
abstract ReverseIterator : unit -> MullionTypeSetIterator
override ReverseIterator : unit -> MullionTypeSetIterator

Return Value

MullionTypeSetIterator
Returns a backward moving iterator to the set.
See Also

Reference

MullionTypeSet Class


MullionTypeSetIterator Class

An iterator to a mullion type set.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBMullionTypeSetIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class MullionTypeSetIterator : APIObject,
    IEnumerator
Public MustInherit Class MullionTypeSetIterator
    Inherits APIObject
    Implements IEnumerator
public ref class MullionTypeSetIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type MullionTypeSetIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The MullionTypeSetIterator type exposes the following members.

Constructors
 | Name | Description
Public method | MullionTypeSetIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


MullionTypeSetIterator Constructor

For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MullionTypeSetIterator()
Public Sub New
public:
MullionTypeSetIterator()
new : unit -> MullionTypeSetIterator
Remarks
This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.
See Also

Reference

MullionTypeSetIterator Class


MullionTypeSetIterator Properties

The MullionTypeSetIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

MullionTypeSetIterator Class


MullionTypeSetIterator.Current Property

MullionTypeSetIteratorCurrent Property

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}
abstract Current : Object with get
override Current : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.
See Also

Reference

MullionTypeSetIterator Class


MullionTypeSetIterator Methods

The MullionTypeSetIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MullionTypeSetIterator Class


MullionTypeSetIterator.MoveNext Method

MullionTypeSetIteratorMoveNext Method

Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumeratorMoveNext
Remarks
MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.
See Also

Reference

MullionTypeSetIterator Class


MullionTypeSetIterator.Reset Method

MullionTypeSetIteratorReset Method

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
Remarks
The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.
See Also

Reference

MullionTypeSetIterator Class


MultipleValuesIndicationSettings Class

MultipleValuesIndicationSettings is an element which contains project-wide settings for multiple values indication in Properties Palette and schedules.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBMultipleValuesIndicationSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MultipleValuesIndicationSettings : Element
Public Class MultipleValuesIndicationSettings
    Inherits Element
public ref class MultipleValuesIndicationSettings : public Element
type MultipleValuesIndicationSettings =
    class
        inherit Element
    end

The MultipleValuesIndicationSettings type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | Custom | If true, CustomValue is used as multiple values indication, otherwise a hardcoded standard value.
Public property | CustomValue | Value used as multiple values indication if Custom is set to true.
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | Value | Value to be used as multiple values indication in the document. If Custom is true, returns CustomValue, otherwise returns a hardcoded standard value.
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
 | GetMultipleValuesIndicationSettings | Returns the MultipleValuesIndicationSettings element for a given document.
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


MultipleValuesIndicationSettings Properties

The MultipleValuesIndicationSettings type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | Custom | If true, CustomValue is used as multiple values indication, otherwise a hardcoded standard value.
Public property | CustomValue | Value used as multiple values indication if Custom is set to true.
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | Value | Value to be used as multiple values indication in the document. If Custom is true, returns CustomValue, otherwise returns a hardcoded standard value.
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

MultipleValuesIndicationSettings Class


MultipleValuesIndicationSettings.Custom Property

MultipleValuesIndicationSettingsCustom Property

If true, CustomValue is used as multiple values indication, otherwise a hardcoded standard value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Custom { get; set; }
Public Property Custom As Boolean
    Get
    Set
public:
property bool Custom {
    bool get ();
    void set (bool value);
}
member Custom : bool with get, set

Property Value

Boolean
See Also

Reference

MultipleValuesIndicationSettings Class


MultipleValuesIndicationSettings.CustomValue Property

MultipleValuesIndicationSettingsCustomValue Property

Value used as multiple values indication if Custom is set to true.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string CustomValue { get; set; }
Public Property CustomValue As String
    Get
    Set
public:
property String^ CustomValue {
    String^ get ();
    void set (String^ value);
}
member CustomValue : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

MultipleValuesIndicationSettings Class


MultipleValuesIndicationSettings.Value Property

MultipleValuesIndicationSettingsValue Property

Value to be used as multiple values indication in the document. If Custom is true, returns CustomValue, otherwise returns a hardcoded standard value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Value { get; }
Public ReadOnly Property Value As String
    Get
public:
property String^ Value {
    String^ get ();
}
member Value : string with get

Property Value

String
See Also

Reference

MultipleValuesIndicationSettings Class


MultipleValuesIndicationSettings Methods

The MultipleValuesIndicationSettings type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
 | GetMultipleValuesIndicationSettings | Returns the MultipleValuesIndicationSettings element for a given document.
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MultipleValuesIndicationSettings Class


MultipleValuesIndicationSettings.GetMultipleValuesIndicationSettings Method

MultipleValuesIndicationSettingsGetMultipleValuesIndicationSettings Method

Returns the MultipleValuesIndicationSettings element for a given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static MultipleValuesIndicationSettings GetMultipleValuesIndicationSettings(
    Document cda
)
Public Shared Function GetMultipleValuesIndicationSettings (
    cda As Document
) As MultipleValuesIndicationSettings
public:
static MultipleValuesIndicationSettings^ GetMultipleValuesIndicationSettings(
    Document^ cda
)
static member GetMultipleValuesIndicationSettings :
        cda : Document -> MultipleValuesIndicationSettings

Parameters

cda Document
The document for which to get the MultipleValuesIndicationSettings element.

Return Value

MultipleValuesIndicationSettings

Returns the MultipleValuesIndicationSettings element in project documents or for family documents

.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Project documents have a MultipleValuesIndicationSettings element, one per document. Family documents do not have MultipleValuesIndicationSettings elements.
See Also

Reference

MultipleValuesIndicationSettings Class


MultiReferenceAnnotation Class

Multi-reference annotations are annotations pointing to more than one reference, consisting of a dimension and associated tag.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBMultiReferenceAnnotation

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MultiReferenceAnnotation : Element
Public Class MultiReferenceAnnotation
    Inherits Element
public ref class MultiReferenceAnnotation : public Element
type MultiReferenceAnnotation =
    class
        inherit Element
    end

The MultiReferenceAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | DimensionId | The child dimension owned by this multi-reference annotation.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | TagId | The child IndependentTag owned by this multi-reference annotation.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
 | AreElementsValidForMultiReferenceAnnotation | The method validates if the input elements match the element category id for the MultiReferenceAnnotationType.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
 | AreReferencesValidForLinearDimension | If the DimensionStyleType is Linear, validates that the references are valid for an aligned multi-reference annotation.
 | AreReferencesValidForLinearFixedDimension | If the DimensionStyleType is LinearFixed, validates that the references are valid for an aligned multi-reference annotation.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new MultiReferenceAnnotation.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
 | Is3DViewValidForDimension | If the DimensionStyle is LinearFixed, it cannot be created in a 3D View. If the DimensionStyle is Linear, it cannot be created in a 3D View if the view direction is perpendicular to the current work plane normal. Returns true if the ownerViewId is not a 3D view.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
 | IsLinearFixedDimensionDirectionValid | If the DimensionStyleType is LinearFixed, this function verifies that the dimension line direction matches either the view's vertical or horizontal direction.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Multi-reference annotations can be used to label and dimension Rebar elements, and are labeled in the user interface as "Multi-rebar annotations". MultiReferenceAnnotation is the annotation object instance. This class includes a reference to the associated dimension and tag element.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


MultiReferenceAnnotation Properties

The MultiReferenceAnnotation type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | DimensionId | The child dimension owned by this multi-reference annotation.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | TagId | The child IndependentTag owned by this multi-reference annotation.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

MultiReferenceAnnotation Class


MultiReferenceAnnotation.DimensionId Property

MultiReferenceAnnotationDimensionId Property

The child dimension owned by this multi-reference annotation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId DimensionId { get; }
Public ReadOnly Property DimensionId As ElementId
    Get
public:
property ElementId^ DimensionId {
    ElementId^ get ();
}
member DimensionId : ElementId with get

Property Value

ElementId
See Also

Reference

MultiReferenceAnnotation Class


MultiReferenceAnnotation.TagId Property

MultiReferenceAnnotationTagId Property

The child IndependentTag owned by this multi-reference annotation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId TagId { get; }
Public ReadOnly Property TagId As ElementId
    Get
public:
property ElementId^ TagId {
    ElementId^ get ();
}
member TagId : ElementId with get

Property Value

ElementId
See Also

Reference

MultiReferenceAnnotation Class


MultiReferenceAnnotation Methods

The MultiReferenceAnnotation type exposes the following members.

Methods
 | Name | Description
 | AreElementsValidForMultiReferenceAnnotation | The method validates if the input elements match the element category id for the MultiReferenceAnnotationType.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
 | AreReferencesValidForLinearDimension | If the DimensionStyleType is Linear, validates that the references are valid for an aligned multi-reference annotation.
 | AreReferencesValidForLinearFixedDimension | If the DimensionStyleType is LinearFixed, validates that the references are valid for an aligned multi-reference annotation.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new MultiReferenceAnnotation.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
 | Is3DViewValidForDimension | If the DimensionStyle is LinearFixed, it cannot be created in a 3D View. If the DimensionStyle is Linear, it cannot be created in a 3D View if the view direction is perpendicular to the current work plane normal. Returns true if the ownerViewId is not a 3D view.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
 | IsLinearFixedDimensionDirectionValid | If the DimensionStyleType is LinearFixed, this function verifies that the dimension line direction matches either the view's vertical or horizontal direction.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MultiReferenceAnnotation Class


MultiReferenceAnnotation.AreElementsValidForMultiReferenceAnnotation Method

MultiReferenceAnnotationAreElementsValidForMultiReferenceAnnotation Method

The method validates if the input elements match the element category id for the MultiReferenceAnnotationType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool AreElementsValidForMultiReferenceAnnotation(
    Document document,
    MultiReferenceAnnotationOptions options
)
Public Shared Function AreElementsValidForMultiReferenceAnnotation (
    document As Document,
    options As MultiReferenceAnnotationOptions
) As Boolean
public:
static bool AreElementsValidForMultiReferenceAnnotation(
    Document^ document,
    MultiReferenceAnnotationOptions^ options
)
static member AreElementsValidForMultiReferenceAnnotation :
        document : Document *
        options : MultiReferenceAnnotationOptions -> bool

Parameters

document Document
The document for the multi-reference annotation.
options MultiReferenceAnnotationOptions
The creation options for the new MultiReferenceAnnotation.

Return Value

Boolean
Returns true if the input elements match the element category id for the MultiReferenceAnnotationType, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

MultiReferenceAnnotation Class


MultiReferenceAnnotation.AreReferencesValidForLinearDimension Method

MultiReferenceAnnotationAreReferencesValidForLinearDimension Method

If the DimensionStyleType is Linear, validates that the references are valid for an aligned multi-reference annotation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool AreReferencesValidForLinearDimension(
    Document document,
    ElementId ownerViewId,
    MultiReferenceAnnotationOptions options
)
Public Shared Function AreReferencesValidForLinearDimension (
    document As Document,
    ownerViewId As ElementId,
    options As MultiReferenceAnnotationOptions
) As Boolean
public:
static bool AreReferencesValidForLinearDimension(
    Document^ document,
    ElementId^ ownerViewId,
    MultiReferenceAnnotationOptions^ options
)
static member AreReferencesValidForLinearDimension :
        document : Document *
        ownerViewId : ElementId *
        options : MultiReferenceAnnotationOptions -> bool

Parameters

document Document
The document for the multi-reference annotation.
ownerViewId ElementId
The view in which the multi-reference annotation will appear.
options MultiReferenceAnnotationOptions
Options containing the references which the dimension will witness.

Return Value

Boolean
True DimensionStyleType does not equal Linear or if an aligned multi-reference annotation can be created from the references.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

MultiReferenceAnnotation Class


MultiReferenceAnnotation.AreReferencesValidForLinearFixedDimension Method

MultiReferenceAnnotationAreReferencesValidForLinearFixedDimension Method

If the DimensionStyleType is LinearFixed, validates that the references are valid for an aligned multi-reference annotation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool AreReferencesValidForLinearFixedDimension(
    Document document,
    ElementId ownerViewId,
    MultiReferenceAnnotationOptions options
)
Public Shared Function AreReferencesValidForLinearFixedDimension (
    document As Document,
    ownerViewId As ElementId,
    options As MultiReferenceAnnotationOptions
) As Boolean
public:
static bool AreReferencesValidForLinearFixedDimension(
    Document^ document,
    ElementId^ ownerViewId,
    MultiReferenceAnnotationOptions^ options
)
static member AreReferencesValidForLinearFixedDimension :
        document : Document *
        ownerViewId : ElementId *
        options : MultiReferenceAnnotationOptions -> bool

Parameters

document Document
The document for the multi-reference annotation.
ownerViewId ElementId
The view in which the multi-reference annotation will appear.
options MultiReferenceAnnotationOptions
Options containing the references which the dimension will witness.

Return Value

Boolean
True DimensionStyleType does not equal LinearFixed or if an aligned multi-reference annotation can be created from the references.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

MultiReferenceAnnotation Class


MultiReferenceAnnotation.Create Method

MultiReferenceAnnotationCreate Method

Creates a new MultiReferenceAnnotation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static MultiReferenceAnnotation Create(
    Document document,
    ElementId ownerViewId,
    MultiReferenceAnnotationOptions options
)
Public Shared Function Create (
    document As Document,
    ownerViewId As ElementId,
    options As MultiReferenceAnnotationOptions
) As MultiReferenceAnnotation
public:
static MultiReferenceAnnotation^ Create(
    Document^ document,
    ElementId^ ownerViewId,
    MultiReferenceAnnotationOptions^ options
)
static member Create :
        document : Document *
        ownerViewId : ElementId *
        options : MultiReferenceAnnotationOptions -> MultiReferenceAnnotation

Parameters

document Document
The document to which the new MultiReferenceAnnotation will be added.
ownerViewId ElementId
The view in which the multi-reference annotation will appear.
options MultiReferenceAnnotationOptions
The creation options for the new MultiReferenceAnnotation.

Return Value

MultiReferenceAnnotation
The new MultiReferenceAnnotation.
Exceptions
Exception | Condition
ArgumentException | document is not a project document. -or- The ElementId ownerViewId does not correspond to a View. -or- The ElementId ownerViewId is a view template. -or- The ElementId ownerViewId is a perspective view. -or- The 3D view ownerViewId is not locked. -or- The input 3D view cannot be used to place a MultiReferenceAnnotation object. -or- dimension line direction and dimension plane normal are not orthogonal. -or- There is at least one element that doesn't match the reference category of the MultiReferenceAnnotationType, or there are no elements. -or- for DimensionStyleType LinearFixed dimensions the dimension line direction must be parallel to either the view's vertical or horizontal direction. -or- some references can't be used with a DimensionStyleType Linear dimension of this direction. References must either appear as points in the view or be linear references which are perpendicular to the dimension line. -or- some references can't be used with a DimensionStyleType LinearFixed dimension. Only references which appear as points in the view can be used.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
New linear Dimension and IndependentTag elements will be created as children of the MultiReferenceAnnotation. The IndependentTag will only be created if the MultiReferenceAnnotationType property TagTypeId is valid.
See Also

Reference

MultiReferenceAnnotation Class


MultiReferenceAnnotation.Is3DViewValidForDimension Method

MultiReferenceAnnotationIs3DViewValidForDimension Method

If the DimensionStyle is LinearFixed, it cannot be created in a 3D View. If the DimensionStyle is Linear, it cannot be created in a 3D View if the view direction is perpendicular to the current work plane normal. Returns true if the ownerViewId is not a 3D view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool Is3DViewValidForDimension(
    Document document,
    ElementId ownerViewId,
    MultiReferenceAnnotationOptions options
)
Public Shared Function Is3DViewValidForDimension (
    document As Document,
    ownerViewId As ElementId,
    options As MultiReferenceAnnotationOptions
) As Boolean
public:
static bool Is3DViewValidForDimension(
    Document^ document,
    ElementId^ ownerViewId,
    MultiReferenceAnnotationOptions^ options
)
static member Is3DViewValidForDimension :
        document : Document *
        ownerViewId : ElementId *
        options : MultiReferenceAnnotationOptions -> bool

Parameters

document Document
The document for the multi-reference annotation.
ownerViewId ElementId
The view in which the multi-reference annotation will appear.
options MultiReferenceAnnotationOptions
Options containing the references which the dimension will witness.

Return Value

Boolean
True if the view is suitable for placing the MultiReferenceAnnotation. False otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

MultiReferenceAnnotation Class


MultiReferenceAnnotation.IsLinearFixedDimensionDirectionValid Method

MultiReferenceAnnotationIsLinearFixedDimensionDirectionValid Method

If the DimensionStyleType is LinearFixed, this function verifies that the dimension line direction matches either the view's vertical or horizontal direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsLinearFixedDimensionDirectionValid(
    Document document,
    ElementId viewId,
    MultiReferenceAnnotationOptions options
)
Public Shared Function IsLinearFixedDimensionDirectionValid (
    document As Document,
    viewId As ElementId,
    options As MultiReferenceAnnotationOptions
) As Boolean
public:
static bool IsLinearFixedDimensionDirectionValid(
    Document^ document,
    ElementId^ viewId,
    MultiReferenceAnnotationOptions^ options
)
static member IsLinearFixedDimensionDirectionValid :
        document : Document *
        viewId : ElementId *
        options : MultiReferenceAnnotationOptions -> bool

Parameters

document Document
The document for the view.
viewId ElementId
The view in which the dimension line direction will be tested.
options MultiReferenceAnnotationOptions
Options containing the DimensionStyleType and dimension line direction to test.

Return Value

Boolean
True if the DimensionStyleType is LinearFixed and the dimension line direction can be used in the view. True if the DimensionStyleType is not LinearFixed.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

MultiReferenceAnnotation Class


MultiReferenceAnnotationOptions Class

Options which control the creation of MultiReferenceAnnotations.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBMultiReferenceAnnotationOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MultiReferenceAnnotationOptions : IDisposable
Public Class MultiReferenceAnnotationOptions
    Implements IDisposable
public ref class MultiReferenceAnnotationOptions : IDisposable
type MultiReferenceAnnotationOptions =
    class
        interface IDisposable
    end

The MultiReferenceAnnotationOptions type exposes the following members.

Constructors
 | Name | Description
Public method | MultiReferenceAnnotationOptions | Create an instance of Multi-Reference Annotation Options set with default values.
Top
Properties
 | Name | Description
Public property | DimensionLineDirection | The direction vector of the dimension line.
Public property | DimensionLineOrigin | The origin point for the dimension line.
Public property | DimensionPlaneNormal | The normal vector to the dimension plane.
Public property | DimensionStyleType | The dimension style type to be used by the new MultiReferenceAnnotation.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MultiReferenceAnnotationType | The MultiReferenceAnnotationType to be used by the new MultiReferenceAnnotation.
Public property | TagHasLeader | When true the tag will be created with an attached leader. When false the tag will be created without a leader.
Public property | TagHeadPosition | The position for the tag's head.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the MultiReferenceAnnotationOptions
Public method | ElementsMatchReferenceCategory | Verifies that all of the elements match the reference category required by the MultiReferenceAnnotationType.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAdditionalReferencesToDimension | Gets the additional references which the dimension will witness.
Public method | GetElementsToDimension | Gets the elements which the dimension will witness.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsAllowedDimensionStyleType | Only Linear and LinearFixed dimension style types are allowed for new MultiReferenceAnnotations.
Public method | ReferencesDontMatchReferenceCategory | Verifies that all of the references belongs to elements which doesn't match the reference category required by the MultiReferenceAnnotationType.
Public method | SetAdditionalReferencesToDimension | Sets the additional references which the dimension will witness.
Public method | SetElementsToDimension | Sets the elements which the dimension will witness.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
MultiReferenceAnnotationOptions include the specification of the associated elements and options for the dimension and tag placement.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


MultiReferenceAnnotationOptions Constructor

Create an instance of Multi-Reference Annotation Options set with default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MultiReferenceAnnotationOptions(
    MultiReferenceAnnotationType multiReferenceAnnotationType
)
Public Sub New (
    multiReferenceAnnotationType As MultiReferenceAnnotationType
)
public:
MultiReferenceAnnotationOptions(
    MultiReferenceAnnotationType^ multiReferenceAnnotationType
)
new :
        multiReferenceAnnotationType : MultiReferenceAnnotationType -> MultiReferenceAnnotationOptions

Parameters

multiReferenceAnnotationType MultiReferenceAnnotationType
The MultiReferenceAnnotationType to be used by the new MultiReferenceAnnotation.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

MultiReferenceAnnotationOptions Class


MultiReferenceAnnotationOptions Properties

The MultiReferenceAnnotationOptions type exposes the following members.

Properties
 | Name | Description
Public property | DimensionLineDirection | The direction vector of the dimension line.
Public property | DimensionLineOrigin | The origin point for the dimension line.
Public property | DimensionPlaneNormal | The normal vector to the dimension plane.
Public property | DimensionStyleType | The dimension style type to be used by the new MultiReferenceAnnotation.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MultiReferenceAnnotationType | The MultiReferenceAnnotationType to be used by the new MultiReferenceAnnotation.
Public property | TagHasLeader | When true the tag will be created with an attached leader. When false the tag will be created without a leader.
Public property | TagHeadPosition | The position for the tag's head.
Top
See Also

Reference

MultiReferenceAnnotationOptions Class


MultiReferenceAnnotationOptions.DimensionLineDirection Property

MultiReferenceAnnotationOptionsDimensionLineDirection Property

The direction vector of the dimension line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ DimensionLineDirection { get; set; }
Public Property DimensionLineDirection As XYZ
    Get
    Set
public:
property XYZ^ DimensionLineDirection {
    XYZ^ get ();
    void set (XYZ^ value);
}
member DimensionLineDirection : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
ArgumentOutOfRangeException | When setting this property: dimensionLineDirection is not length 1.0.
See Also

Reference

MultiReferenceAnnotationOptions Class


MultiReferenceAnnotationOptions.DimensionLineOrigin Property

MultiReferenceAnnotationOptionsDimensionLineOrigin Property

The origin point for the dimension line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ DimensionLineOrigin { get; set; }
Public Property DimensionLineOrigin As XYZ
    Get
    Set
public:
property XYZ^ DimensionLineOrigin {
    XYZ^ get ();
    void set (XYZ^ value);
}
member DimensionLineOrigin : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

MultiReferenceAnnotationOptions Class


MultiReferenceAnnotationOptions.DimensionPlaneNormal Property

MultiReferenceAnnotationOptionsDimensionPlaneNormal Property

The normal vector to the dimension plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ DimensionPlaneNormal { get; set; }
Public Property DimensionPlaneNormal As XYZ
    Get
    Set
public:
property XYZ^ DimensionPlaneNormal {
    XYZ^ get ();
    void set (XYZ^ value);
}
member DimensionPlaneNormal : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
ArgumentOutOfRangeException | When setting this property: dimensionPlaneNormal is not length 1.0.
See Also

Reference

MultiReferenceAnnotationOptions Class


MultiReferenceAnnotationOptions.DimensionStyleType Property

MultiReferenceAnnotationOptionsDimensionStyleType Property

The dimension style type to be used by the new MultiReferenceAnnotation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DimensionStyleType DimensionStyleType { get; set; }
Public Property DimensionStyleType As DimensionStyleType
    Get
    Set
public:
property DimensionStyleType DimensionStyleType {
    DimensionStyleType get ();
    void set (DimensionStyleType value);
}
member DimensionStyleType : DimensionStyleType with get, set

Property Value

DimensionStyleType
Exceptions
Exception | Condition
ArgumentException | When setting this property: dimensionStyleType must be either Linear or LinearFixed to be used by MultiReferenceAnnotations.
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
Only Linear and LinearFixed types are allowed.
See Also

Reference

MultiReferenceAnnotationOptions Class


MultiReferenceAnnotationOptions.IsValidObject Property

MultiReferenceAnnotationOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

MultiReferenceAnnotationOptions Class


MultiReferenceAnnotationOptions.MultiReferenceAnnotationType Property

MultiReferenceAnnotationOptionsMultiReferenceAnnotationType Property

The MultiReferenceAnnotationType to be used by the new MultiReferenceAnnotation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MultiReferenceAnnotationType MultiReferenceAnnotationType { get; }
Public ReadOnly Property MultiReferenceAnnotationType As MultiReferenceAnnotationType
    Get
public:
property MultiReferenceAnnotationType^ MultiReferenceAnnotationType {
    MultiReferenceAnnotationType^ get ();
}
member MultiReferenceAnnotationType : MultiReferenceAnnotationType with get

Property Value

MultiReferenceAnnotationType
See Also

Reference

MultiReferenceAnnotationOptions Class


MultiReferenceAnnotationOptions.TagHasLeader Property

MultiReferenceAnnotationOptionsTagHasLeader Property

When true the tag will be created with an attached leader. When false the tag will be created without a leader.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool TagHasLeader { get; set; }
Public Property TagHasLeader As Boolean
    Get
    Set
public:
property bool TagHasLeader {
    bool get ();
    void set (bool value);
}
member TagHasLeader : bool with get, set

Property Value

Boolean
See Also

Reference

MultiReferenceAnnotationOptions Class


MultiReferenceAnnotationOptions.TagHeadPosition Property

MultiReferenceAnnotationOptionsTagHeadPosition Property

The position for the tag's head.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ TagHeadPosition { get; set; }
Public Property TagHeadPosition As XYZ
    Get
    Set
public:
property XYZ^ TagHeadPosition {
    XYZ^ get ();
    void set (XYZ^ value);
}
member TagHeadPosition : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

MultiReferenceAnnotationOptions Class


MultiReferenceAnnotationOptions Methods

The MultiReferenceAnnotationOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | ElementsMatchReferenceCategory | Verifies that all of the elements match the reference category required by the MultiReferenceAnnotationType.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAdditionalReferencesToDimension | Gets the additional references which the dimension will witness.
Public method | GetElementsToDimension | Gets the elements which the dimension will witness.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsAllowedDimensionStyleType | Only Linear and LinearFixed dimension style types are allowed for new MultiReferenceAnnotations.
Public method | ReferencesDontMatchReferenceCategory | Verifies that all of the references belongs to elements which doesn't match the reference category required by the MultiReferenceAnnotationType.
Public method | SetAdditionalReferencesToDimension | Sets the additional references which the dimension will witness.
Public method | SetElementsToDimension | Sets the elements which the dimension will witness.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MultiReferenceAnnotationOptions Class


MultiReferenceAnnotationOptions.Dispose Method

MultiReferenceAnnotationOptionsDispose Method

Releases all resources used by the MultiReferenceAnnotationOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

MultiReferenceAnnotationOptions Class


MultiReferenceAnnotationOptions.ElementsMatchReferenceCategory Method

MultiReferenceAnnotationOptionsElementsMatchReferenceCategory Method

Verifies that all of the elements match the reference category required by the MultiReferenceAnnotationType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ElementsMatchReferenceCategory(
    ICollection<ElementId> elements
)
Public Function ElementsMatchReferenceCategory (
    elements As ICollection(Of ElementId)
) As Boolean
public:
bool ElementsMatchReferenceCategory(
    ICollection<ElementId^>^ elements
)
member ElementsMatchReferenceCategory :
        elements : ICollection<ElementId> -> bool

Parameters

elements ICollection ElementId
The elements to test.

Return Value

Boolean
True if all the elements match the reference category required by the MultiReferenceAnnotationType.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

MultiReferenceAnnotationOptions Class


MultiReferenceAnnotationOptions.GetAdditionalReferencesToDimension Method

MultiReferenceAnnotationOptionsGetAdditionalReferencesToDimension Method

Gets the additional references which the dimension will witness.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<Reference> GetAdditionalReferencesToDimension()
Public Function GetAdditionalReferencesToDimension As IList(Of Reference)
public:
IList<Reference^>^ GetAdditionalReferencesToDimension()
member GetAdditionalReferencesToDimension : unit -> IList<Reference>

Return Value

IList Reference
The additional references which the dimension will witness.
Remarks
These references may be to elements of other categories than the reference category returned by MultiReferenceAnnotationType.
See Also

Reference

MultiReferenceAnnotationOptions Class


MultiReferenceAnnotationOptions.GetElementsToDimension Method

MultiReferenceAnnotationOptionsGetElementsToDimension Method

Gets the elements which the dimension will witness.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetElementsToDimension()
Public Function GetElementsToDimension As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetElementsToDimension()
member GetElementsToDimension : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
The elements which the dimension will witness.
See Also

Reference

MultiReferenceAnnotationOptions Class


MultiReferenceAnnotationOptions.IsAllowedDimensionStyleType Method

MultiReferenceAnnotationOptionsIsAllowedDimensionStyleType Method

Only Linear and LinearFixed dimension style types are allowed for new MultiReferenceAnnotations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsAllowedDimensionStyleType(
    DimensionStyleType dimensionStyleType
)
Public Function IsAllowedDimensionStyleType (
    dimensionStyleType As DimensionStyleType
) As Boolean
public:
bool IsAllowedDimensionStyleType(
    DimensionStyleType dimensionStyleType
)
member IsAllowedDimensionStyleType :
        dimensionStyleType : DimensionStyleType -> bool

Parameters

dimensionStyleType DimensionStyleType
The dimension style type to test.

Return Value

Boolean
True if the type is allowed.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

MultiReferenceAnnotationOptions Class


MultiReferenceAnnotationOptions.ReferencesDontMatchReferenceCategory Method

MultiReferenceAnnotationOptionsReferencesDontMatchReferenceCategory Method

Verifies that all of the references belongs to elements which doesn't match the reference category required by the MultiReferenceAnnotationType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ReferencesDontMatchReferenceCategory(
    IList<Reference> references
)
Public Function ReferencesDontMatchReferenceCategory (
    references As IList(Of Reference)
) As Boolean
public:
bool ReferencesDontMatchReferenceCategory(
    IList<Reference^>^ references
)
member ReferencesDontMatchReferenceCategory :
        references : IList<Reference> -> bool

Parameters

references IList Reference
The references to test.

Return Value

Boolean
Returns true if the element categories of all tested references do not match the element category required by the MultiReferenceAnnotationType.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

MultiReferenceAnnotationOptions Class


MultiReferenceAnnotationOptions.SetAdditionalReferencesToDimension Method

MultiReferenceAnnotationOptionsSetAdditionalReferencesToDimension Method

Sets the additional references which the dimension will witness.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetAdditionalReferencesToDimension(
    IList<Reference> referencesToDimension
)
Public Sub SetAdditionalReferencesToDimension (
    referencesToDimension As IList(Of Reference)
)
public:
void SetAdditionalReferencesToDimension(
    IList<Reference^>^ referencesToDimension
)
member SetAdditionalReferencesToDimension :
        referencesToDimension : IList<Reference> -> unit

Parameters

referencesToDimension IList Reference
The additional references which the dimension will witness.
Exceptions
Exception | Condition
ArgumentException | Some references come from elements which directly match the reference category required by the MultiReferenceAnnotationType. For those elements please use SetElementsToDimension.
ArgumentNullException | A non-optional argument was null
Remarks
The additional references to dimension cannot come from the same category as the MultiReferenceAnnotationType's reference category.
See Also

Reference

MultiReferenceAnnotationOptions Class


MultiReferenceAnnotationOptions.SetElementsToDimension Method

MultiReferenceAnnotationOptionsSetElementsToDimension Method

Sets the elements which the dimension will witness.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetElementsToDimension(
    ICollection<ElementId> elementsToDimension
)
Public Sub SetElementsToDimension (
    elementsToDimension As ICollection(Of ElementId)
)
public:
void SetElementsToDimension(
    ICollection<ElementId^>^ elementsToDimension
)
member SetElementsToDimension :
        elementsToDimension : ICollection<ElementId> -> unit

Parameters

elementsToDimension ICollection ElementId
The elements which the dimension will witness.
Exceptions
Exception | Condition
ArgumentException | some elements do not match the reference category required by the MultiReferenceAnnotationType.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The MultiReferenceAnnotationType assigned to the options can't create MultiReferenceAnnotations by element.
Remarks
The dimension will automatically find geometric references in the elements.
See Also

Reference

MultiReferenceAnnotationOptions Class


MultiReferenceAnnotationType Class

The type for MultiReferenceAnnotation.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBMultiReferenceAnnotationType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MultiReferenceAnnotationType : ElementType
Public Class MultiReferenceAnnotationType
    Inherits ElementType
public ref class MultiReferenceAnnotationType : public ElementType
type MultiReferenceAnnotationType =
    class
        inherit ElementType
    end

The MultiReferenceAnnotationType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | DimensionStyleId | The dimension style which will be used by the child dimension of the multi-reference annotation.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | GroupTagHeads | Controls if parameter values for the annotation's references will be reported in one grouped tag head or if every reference will get its own tag head.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ReferenceCategoryId | The category of elements to which this annotation applies.
Public property | ShowDimensionText | Controls if text from the multi-reference annotation's dimension will be shown.
Public property | TagTypeId | The tag type which will be used by the child tag the multi-reference annotation.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | CreateDefault | Creates the first MultiReferenceAnnotationType element and adds it to the document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAllowedTagCategory | Returns the category ID for the tag types which can be used by this multi-reference annotation type.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsAllowedDimensionStyle | Checks if the dimension style can be used with multi-reference annotations.
Public method | IsAllowedReferenceCategory | Checks if the reference category can be used with multi-reference annotations.
 | IsAllowedTagCategory | Returns true if tag types belonging to this category can be used with multi-reference annotation types.
Public method | IsAllowedTagType | Checks if the tag type can be assigned to this multi-reference annotation type.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Multi-reference annotations can be used to label and dimension Rebar elements, and are labeled in the user interface as "Multi-rebar annotations". The type specifies the tag and dimension types to be used in the multi-reference annotation, as well as associated display settings.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


MultiReferenceAnnotationType Properties

The MultiReferenceAnnotationType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | DimensionStyleId | The dimension style which will be used by the child dimension of the multi-reference annotation.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | GroupTagHeads | Controls if parameter values for the annotation's references will be reported in one grouped tag head or if every reference will get its own tag head.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ReferenceCategoryId | The category of elements to which this annotation applies.
Public property | ShowDimensionText | Controls if text from the multi-reference annotation's dimension will be shown.
Public property | TagTypeId | The tag type which will be used by the child tag the multi-reference annotation.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

MultiReferenceAnnotationType Class


MultiReferenceAnnotationType.DimensionStyleId Property

MultiReferenceAnnotationTypeDimensionStyleId Property

The dimension style which will be used by the child dimension of the multi-reference annotation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId DimensionStyleId { get; set; }
Public Property DimensionStyleId As ElementId
    Get
    Set
public:
property ElementId^ DimensionStyleId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member DimensionStyleId : ElementId with get, set

Property Value

ElementId
Only linear dimension styles can be used.
Exceptions
Exception | Condition
ArgumentException | When setting this property: The dimension style is not allowed.
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

MultiReferenceAnnotationType Class


MultiReferenceAnnotationType.GroupTagHeads Property

MultiReferenceAnnotationTypeGroupTagHeads Property

Controls if parameter values for the annotation's references will be reported in one grouped tag head or if every reference will get its own tag head.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool GroupTagHeads { get; set; }
Public Property GroupTagHeads As Boolean
    Get
    Set
public:
property bool GroupTagHeads {
    bool get ();
    void set (bool value);
}
member GroupTagHeads : bool with get, set

Property Value

Boolean
When false, each reference will get one tag head. When true, if all references report the same parameter values, a single tag head will be created.
See Also

Reference

MultiReferenceAnnotationType Class


MultiReferenceAnnotationType.ReferenceCategoryId Property

MultiReferenceAnnotationTypeReferenceCategoryId Property

The category of elements to which this annotation applies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId ReferenceCategoryId { get; }
Public ReadOnly Property ReferenceCategoryId As ElementId
    Get
public:
property ElementId^ ReferenceCategoryId {
    ElementId^ get ();
}
member ReferenceCategoryId : ElementId with get

Property Value

ElementId
Remarks
The TagTypeId will be cleared because the user must set a new tag type of an appropriate category.
See Also

Reference

MultiReferenceAnnotationType Class


MultiReferenceAnnotationType.ShowDimensionText Property

MultiReferenceAnnotationTypeShowDimensionText Property

Controls if text from the multi-reference annotation's dimension will be shown.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShowDimensionText { get; set; }
Public Property ShowDimensionText As Boolean
    Get
    Set
public:
property bool ShowDimensionText {
    bool get ();
    void set (bool value);
}
member ShowDimensionText : bool with get, set

Property Value

Boolean
When false, all dimension text including segment values will be hidden. When true, all dimension text will be shown.
See Also

Reference

MultiReferenceAnnotationType Class


MultiReferenceAnnotationType.TagTypeId Property

MultiReferenceAnnotationTypeTagTypeId Property

The tag type which will be used by the child tag the multi-reference annotation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId TagTypeId { get; set; }
Public Property TagTypeId As ElementId
    Get
    Set
public:
property ElementId^ TagTypeId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member TagTypeId : ElementId with get, set

Property Value

ElementId
The tag type must be able to tag elements belonging to the multi-reference annotation's reference category.
Exceptions
Exception | Condition
ArgumentException | When setting this property: The tag type is not allowed.
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

MultiReferenceAnnotationType Class


MultiReferenceAnnotationType Methods

The MultiReferenceAnnotationType type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | CreateDefault | Creates the first MultiReferenceAnnotationType element and adds it to the document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAllowedTagCategory | Returns the category ID for the tag types which can be used by this multi-reference annotation type.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsAllowedDimensionStyle | Checks if the dimension style can be used with multi-reference annotations.
Public method | IsAllowedReferenceCategory | Checks if the reference category can be used with multi-reference annotations.
 | IsAllowedTagCategory | Returns true if tag types belonging to this category can be used with multi-reference annotation types.
Public method | IsAllowedTagType | Checks if the tag type can be assigned to this multi-reference annotation type.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MultiReferenceAnnotationType Class


MultiReferenceAnnotationType.CreateDefault Method

MultiReferenceAnnotationTypeCreateDefault Method

Creates the first MultiReferenceAnnotationType element and adds it to the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static MultiReferenceAnnotationType CreateDefault(
    Document document
)
Public Shared Function CreateDefault (
    document As Document
) As MultiReferenceAnnotationType
public:
static MultiReferenceAnnotationType^ CreateDefault(
    Document^ document
)
static member CreateDefault :
        document : Document -> MultiReferenceAnnotationType

Parameters

document Document
The document to be modified.

Return Value

MultiReferenceAnnotationType
The new MultiReferenceAnnotationType element.
Exceptions
Exception | Condition
ArgumentException | document is not a project document. -or- There are existing MultiReferenceAnnotationTypes in the document.
ArgumentNullException | A non-optional argument was null
Remarks
If there is no existing MultiReferenceAnnotationType a new one will be created, otherwise an exception will be thrown. Use Duplicate(String) to create all further MultiReferenceAnnotationTypes. The default MultiReferenceAnnotationType will use the document's current default linear dimension style and will have Structural Rebar as its reference category. No tag type will be set for the new MultiReferenceAnnotationType.
See Also

Reference

MultiReferenceAnnotationType Class


MultiReferenceAnnotationType.GetAllowedTagCategory Method

MultiReferenceAnnotationTypeGetAllowedTagCategory Method

Returns the category ID for the tag types which can be used by this multi-reference annotation type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GetAllowedTagCategory()
Public Function GetAllowedTagCategory As ElementId
public:
ElementId^ GetAllowedTagCategory()
member GetAllowedTagCategory : unit -> ElementId

Return Value

ElementId
The allowed tag category ID.
Remarks
The allowed tag category is determined by the reference category of this multi-reference annotation type.
See Also

Reference

MultiReferenceAnnotationType Class


MultiReferenceAnnotationType.IsAllowedDimensionStyle Method

MultiReferenceAnnotationTypeIsAllowedDimensionStyle Method

Checks if the dimension style can be used with multi-reference annotations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsAllowedDimensionStyle(
    ElementId dimensionStyleId
)
Public Function IsAllowedDimensionStyle (
    dimensionStyleId As ElementId
) As Boolean
public:
bool IsAllowedDimensionStyle(
    ElementId^ dimensionStyleId
)
member IsAllowedDimensionStyle :
        dimensionStyleId : ElementId -> bool

Parameters

dimensionStyleId ElementId
The dimension style to check.

Return Value

Boolean
True if the dimension style can be used by multi-reference annotations.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Only linear dimension styles are allowed.
See Also

Reference

MultiReferenceAnnotationType Class


MultiReferenceAnnotationType.IsAllowedReferenceCategory Method

MultiReferenceAnnotationTypeIsAllowedReferenceCategory Method

Checks if the reference category can be used with multi-reference annotations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsAllowedReferenceCategory(
    ElementId referenceCategoryId
)
Public Function IsAllowedReferenceCategory (
    referenceCategoryId As ElementId
) As Boolean
public:
bool IsAllowedReferenceCategory(
    ElementId^ referenceCategoryId
)
member IsAllowedReferenceCategory :
        referenceCategoryId : ElementId -> bool

Parameters

referenceCategoryId ElementId
The reference category to check.

Return Value

Boolean
True when the reference category can be used by multi-reference annotations.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Only Structural Rebar is allowed.
See Also

Reference

MultiReferenceAnnotationType Class


MultiReferenceAnnotationType.IsAllowedTagCategory Method

MultiReferenceAnnotationTypeIsAllowedTagCategory Method

Returns true if tag types belonging to this category can be used with multi-reference annotation types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsAllowedTagCategory(
    ElementId tagCategoryId
)
Public Shared Function IsAllowedTagCategory (
    tagCategoryId As ElementId
) As Boolean
public:
static bool IsAllowedTagCategory(
    ElementId^ tagCategoryId
)
static member IsAllowedTagCategory :
        tagCategoryId : ElementId -> bool

Parameters

tagCategoryId ElementId
The tag category to test.

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Only Structural Rebar Tags are allowed.
See Also

Reference

MultiReferenceAnnotationType Class


MultiReferenceAnnotationType.IsAllowedTagType Method

MultiReferenceAnnotationTypeIsAllowedTagType Method

Checks if the tag type can be assigned to this multi-reference annotation type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsAllowedTagType(
    ElementId tagTypeId
)
Public Function IsAllowedTagType (
    tagTypeId As ElementId
) As Boolean
public:
bool IsAllowedTagType(
    ElementId^ tagTypeId
)
member IsAllowedTagType :
        tagTypeId : ElementId -> bool

Parameters

tagTypeId ElementId
The tag type to test.

Return Value

Boolean
True if the tag type exclusively tags elements from the multi-reference annotation's reference category.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Only tag types which exclusively tag elements from the multi-reference annotation's reference category can be used.
See Also

Reference

MultiReferenceAnnotationType Class


MultiSegmentGrid Class

This element acts as a multi-segmented Grid. The individual grids associated to the MultiSegmentGrid behave as a single unit and all share the same text. They inherit their type (GridType) from the MultiSegmentGrid.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBMultiSegmentGrid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MultiSegmentGrid : Element
Public Class MultiSegmentGrid
    Inherits Element
public ref class MultiSegmentGrid : public Element
type MultiSegmentGrid =
    class
        inherit Element
    end

The MultiSegmentGrid type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Text | name shared by grids in this MultiSegmentGrid
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
 | AreGridsInSameMultiSegmentGrid | Determine whether two Grids are members of the same GridChain.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Create a MultiSegmentGrid element from the specified curve loop.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetGridIds | Get the element ids of the Grids that make up this MultiSegmentGrid.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
 | GetMultiSegementGridId | Retrieve the element id of the MultiSegmentGrid of which the specified Grid is a member.
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
 | IsValidCurveLoop | Identifies whether the specified curve loop is valid for creation of a MultiSegmentGrid.
 | IsValidSketchPlaneId | Identifies whether provided element id corresponds to a SketchPlane that is valid for GridChain creation.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


MultiSegmentGrid Properties

The MultiSegmentGrid type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Text | name shared by grids in this MultiSegmentGrid
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

MultiSegmentGrid Class


MultiSegmentGrid.Text Property

MultiSegmentGridText Property

name shared by grids in this MultiSegmentGrid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
member Text : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

MultiSegmentGrid Class


MultiSegmentGrid Methods

The MultiSegmentGrid type exposes the following members.

Methods
 | Name | Description
 | AreGridsInSameMultiSegmentGrid | Determine whether two Grids are members of the same GridChain.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Create a MultiSegmentGrid element from the specified curve loop.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetGridIds | Get the element ids of the Grids that make up this MultiSegmentGrid.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
 | GetMultiSegementGridId | Retrieve the element id of the MultiSegmentGrid of which the specified Grid is a member.
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
 | IsValidCurveLoop | Identifies whether the specified curve loop is valid for creation of a MultiSegmentGrid.
 | IsValidSketchPlaneId | Identifies whether provided element id corresponds to a SketchPlane that is valid for GridChain creation.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MultiSegmentGrid Class


MultiSegmentGrid.AreGridsInSameMultiSegmentGrid Method

MultiSegmentGridAreGridsInSameMultiSegmentGrid Method

Determine whether two Grids are members of the same GridChain.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool AreGridsInSameMultiSegmentGrid(
    Grid grid1,
    Grid grid2
)
Public Shared Function AreGridsInSameMultiSegmentGrid (
    grid1 As Grid,
    grid2 As Grid
) As Boolean
public:
static bool AreGridsInSameMultiSegmentGrid(
    Grid^ grid1,
    Grid^ grid2
)
static member AreGridsInSameMultiSegmentGrid :
        grid1 : Grid *
        grid2 : Grid -> bool

Parameters

grid1 Grid
A Grid.
grid2 Grid
A Grid.

Return Value

Boolean
Returns true if both of the specified Grids are associated to the same MultiSegmentGrid, i.e. getMultiSegementGridId returns the same valid element id for both Grids.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

MultiSegmentGrid Class


MultiSegmentGrid.Create Method

MultiSegmentGridCreate Method

Create a MultiSegmentGrid element from the specified curve loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ElementId Create(
    Document document,
    ElementId typeId,
    CurveLoop curveLoop,
    ElementId sketchPlaneId
)
Public Shared Function Create (
    document As Document,
    typeId As ElementId,
    curveLoop As CurveLoop,
    sketchPlaneId As ElementId
) As ElementId
public:
static ElementId^ Create(
    Document^ document,
    ElementId^ typeId,
    CurveLoop^ curveLoop,
    ElementId^ sketchPlaneId
)
static member Create :
        document : Document *
        typeId : ElementId *
        curveLoop : CurveLoop *
        sketchPlaneId : ElementId -> ElementId

Parameters

document Document
The document in which to create the MultiSegmentGrid.
typeId ElementId
Element id of a GridType element.
curveLoop CurveLoop
An open curve loop consisting of lines and arcs.
sketchPlaneId ElementId
Element id of a SketchPlane for the curves elements that will be created from the curveLoop.

Return Value

ElementId
The element id of the new MultiSegmentGrid element.
Exceptions
Exception | Condition
ArgumentException | The element id should refer to a valid horizontal SketchPlane. -or- The element id should refer to a GridType element. -or- The curve loop should be an open loop consisting of lines and arcs.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
For each curve in the curve loop, a corresponding Grid will be created.
See Also

Reference

MultiSegmentGrid Class


MultiSegmentGrid.GetGridIds Method

MultiSegmentGridGetGridIds Method

Get the element ids of the Grids that make up this MultiSegmentGrid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetGridIds()
Public Function GetGridIds As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetGridIds()
member GetGridIds : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
Element ids of Grids that make up this MultiSegmentGrid.
See Also

Reference

MultiSegmentGrid Class


MultiSegmentGrid.GetMultiSegementGridId Method

MultiSegmentGridGetMultiSegementGridId Method

Retrieve the element id of the MultiSegmentGrid of which the specified Grid is a member.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ElementId GetMultiSegementGridId(
    Grid grid
)
Public Shared Function GetMultiSegementGridId (
    grid As Grid
) As ElementId
public:
static ElementId^ GetMultiSegementGridId(
    Grid^ grid
)
static member GetMultiSegementGridId :
        grid : Grid -> ElementId

Parameters

grid Grid
A Grid.

Return Value

ElementId
The element id of the associated GridChain. If the Grid is not associated to a GridChain, this will return invalidElementId.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

MultiSegmentGrid Class


MultiSegmentGrid.IsValidCurveLoop Method

MultiSegmentGridIsValidCurveLoop Method

Identifies whether the specified curve loop is valid for creation of a MultiSegmentGrid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidCurveLoop(
    CurveLoop curveLoop
)
Public Shared Function IsValidCurveLoop (
    curveLoop As CurveLoop
) As Boolean
public:
static bool IsValidCurveLoop(
    CurveLoop^ curveLoop
)
static member IsValidCurveLoop :
        curveLoop : CurveLoop -> bool

Parameters

curveLoop CurveLoop
The curve loop.

Return Value

Boolean
True if the curve loop is an open curve loop consisting of lines and arcs, and false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

MultiSegmentGrid Class


MultiSegmentGrid.IsValidSketchPlaneId Method

MultiSegmentGridIsValidSketchPlaneId Method

Identifies whether provided element id corresponds to a SketchPlane that is valid for GridChain creation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidSketchPlaneId(
    Document document,
    ElementId elemId
)
Public Shared Function IsValidSketchPlaneId (
    document As Document,
    elemId As ElementId
) As Boolean
public:
static bool IsValidSketchPlaneId(
    Document^ document,
    ElementId^ elemId
)
static member IsValidSketchPlaneId :
        document : Document *
        elemId : ElementId -> bool

Parameters

document Document
The document.
elemId ElementId
Element id.

Return Value

Boolean
True if elemId is the element id of a horizontal SketchPlane.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

MultiSegmentGrid Class


NamingUtils Class

A collection of utilities related to element naming.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBNamingUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class NamingUtils
Public NotInheritable Class NamingUtils
public ref class NamingUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type NamingUtils = class end

The NamingUtils type exposes the following members.

Methods
Name | Description
CompareNames | Compares two object name strings using Revit's comparison rules.
IsValidName | Identifies if the input string is valid for use as an object name in Revit.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


NamingUtils Methods

The NamingUtils type exposes the following members.

Methods
Name | Description
CompareNames | Compares two object name strings using Revit's comparison rules.
IsValidName | Identifies if the input string is valid for use as an object name in Revit.
Top
See Also

Reference

NamingUtils Class


NamingUtils.CompareNames Method

NamingUtilsCompareNames Method

Compares two object name strings using Revit's comparison rules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int CompareNames(
    string nameA,
    string nameB
)
Public Shared Function CompareNames (
    nameA As String,
    nameB As String
) As Integer
public:
static int CompareNames(
    String^ nameA,
    String^ nameB
)
static member CompareNames :
        nameA : string *
        nameB : string -> int

Parameters

nameA String
The first object name to compare.
nameB String
The second object name to compare.

Return Value

Int32
An integer indicating the result of the lexical comparison between the two names. Less than zero if nameA comes before nameB in the ordering, zero if nameA and nameB are equivalent, and greater than zero if nameA is comes after nameB in the ordering.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks

This routine is similar to System.String.Compare(), but uses Revit rules for comparison. This involves breaking the names into alphabetic and numeric tokens and comparing tokens individually. Neither comparand is allowed to be .

Note that this routine does consider case in comparing names. Some Revit element types disallow assignment of names where the only difference with existing names is the case of one or more characters, while other element types do not have this restriction. This routine does not take the particular element type into account, so it may not identify all "duplicates" if the names are to be used for some element types. Attempting to set the name on the target Element should provide the final indication of whether it is valid.

See Also

Reference

NamingUtils Class


NamingUtils.IsValidName Method

NamingUtilsIsValidName Method

Identifies if the input string is valid for use as an object name in Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidName(
    string string
)
Public Shared Function IsValidName (
    string As String
) As Boolean
public:
static bool IsValidName(
    String^ string
)
static member IsValidName :
        string : string -> bool

Parameters

string String
The name to validate.

Return Value

Boolean
True if the name is valid for use as a name in Revit, false if it contains prohibited characters and is invalid.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
This routine checks only for prohibited characters in the string. When setting the name for an object there are other specific considerations which are checked (for example, the same name cannot be used twice for different elements of the same type). This routine does not check those conditions.
See Also

Reference

NamingUtils Class


NavisworksCoordinates Enumeration

An enumerated type listing possible Coordinates of Navisworks Exporter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum NavisworksCoordinates
Public Enumeration NavisworksCoordinates
public enum class NavisworksCoordinates
type NavisworksCoordinates
Members
Member name | Value | Description
Internal | 0 | Use Revit internal coordinates.
Shared | 1 | Shared coordinates can be viewed and modified outside of Revit.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


NavisworksExportOptions Class

Options which controls the Navisworks export.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBNavisworksExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class NavisworksExportOptions : IDisposable
Public Class NavisworksExportOptions
    Implements IDisposable
public ref class NavisworksExportOptions : IDisposable
type NavisworksExportOptions =
    class
        interface IDisposable
    end

The NavisworksExportOptions type exposes the following members.

Constructors
 | Name | Description
Public method | NavisworksExportOptions | Create an instance of Navisworks Export Options set with default values.
Top
Properties
 | Name | Description
Public property | ConvertElementProperties | True to convert element properties, false otherwise. Default value is false.
Public property | ConvertLights | True to convert lights, false otherwise. Default value is false.
Public property | ConvertLinkedCADFormats | True to convert linked CAD formats, false otherwise. Default value is true.
Public property | Coordinates | Options which specifies the coordinates of Navisworks Exporter. Default value is Shared.
Public property | DivideFileIntoLevels | True to divide file into levels, false otherwise. Default value is true.
Public property | ExportElementIds | True to export Revit element ids, false to skip these values. Default value is true.
Public property | ExportLinks | True to export Revit links found in the main model, false to skip links. Default value is false.
Public property | ExportParts | True to export Revit part elements, false to export the original parent elements. Default value is false.
Public property | ExportRoomAsAttribute | True to export data for each room converts into a single shared room attribute, false otherwise. Default value is true.
Public property | ExportRoomGeometry | True to export Revit room geometry, false otherwise. Default value is true.
Public property | ExportScope | Options which specifies the export scope of Navisworks Exporter. Default value is Model.
Public property | ExportUrls | True to export URL parameters, false otherwise. Default value is true.
Public property | FacetingFactor | Faceting factor. Default value is 1.0.
Public property | FindMissingMaterials | True if the file exporter looks for a match for the materials missing from the export, false otherwise. Default value is true.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Parameters | Options which specifies the parameter conversion of Navisworks Exporter. Default value is All.
Public property | ViewId | The element id of the view to export. InvalidElementId by default. Used only when ExportScope = View.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the NavisworksExportOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetSelectedElementIds | Returns the element ids of the elements to export. Empty by default.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetSelectedElementIds | Sets the element ids of the elements to export. Used only when ExportScope = SelectedElements.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


NavisworksExportOptions Constructor

Create an instance of Navisworks Export Options set with default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public NavisworksExportOptions()
Public Sub New
public:
NavisworksExportOptions()
new : unit -> NavisworksExportOptions
See Also

Reference

NavisworksExportOptions Class


NavisworksExportOptions Properties

The NavisworksExportOptions type exposes the following members.

Properties
 | Name | Description
Public property | ConvertElementProperties | True to convert element properties, false otherwise. Default value is false.
Public property | ConvertLights | True to convert lights, false otherwise. Default value is false.
Public property | ConvertLinkedCADFormats | True to convert linked CAD formats, false otherwise. Default value is true.
Public property | Coordinates | Options which specifies the coordinates of Navisworks Exporter. Default value is Shared.
Public property | DivideFileIntoLevels | True to divide file into levels, false otherwise. Default value is true.
Public property | ExportElementIds | True to export Revit element ids, false to skip these values. Default value is true.
Public property | ExportLinks | True to export Revit links found in the main model, false to skip links. Default value is false.
Public property | ExportParts | True to export Revit part elements, false to export the original parent elements. Default value is false.
Public property | ExportRoomAsAttribute | True to export data for each room converts into a single shared room attribute, false otherwise. Default value is true.
Public property | ExportRoomGeometry | True to export Revit room geometry, false otherwise. Default value is true.
Public property | ExportScope | Options which specifies the export scope of Navisworks Exporter. Default value is Model.
Public property | ExportUrls | True to export URL parameters, false otherwise. Default value is true.
Public property | FacetingFactor | Faceting factor. Default value is 1.0.
Public property | FindMissingMaterials | True if the file exporter looks for a match for the materials missing from the export, false otherwise. Default value is true.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Parameters | Options which specifies the parameter conversion of Navisworks Exporter. Default value is All.
Public property | ViewId | The element id of the view to export. InvalidElementId by default. Used only when ExportScope = View.
Top
See Also

Reference

NavisworksExportOptions Class


NavisworksExportOptions.ConvertElementProperties Property

NavisworksExportOptionsConvertElementProperties Property

True to convert element properties, false otherwise. Default value is false.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ConvertElementProperties { get; set; }
Public Property ConvertElementProperties As Boolean
    Get
    Set
public:
property bool ConvertElementProperties {
    bool get ();
    void set (bool value);
}
member ConvertElementProperties : bool with get, set

Property Value

Boolean
See Also

Reference

NavisworksExportOptions Class


NavisworksExportOptions.ConvertLights Property

NavisworksExportOptionsConvertLights Property

True to convert lights, false otherwise. Default value is false.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ConvertLights { get; set; }
Public Property ConvertLights As Boolean
    Get
    Set
public:
property bool ConvertLights {
    bool get ();
    void set (bool value);
}
member ConvertLights : bool with get, set

Property Value

Boolean
See Also

Reference

NavisworksExportOptions Class


NavisworksExportOptions.ConvertLinkedCADFormats Property

NavisworksExportOptionsConvertLinkedCADFormats Property

True to convert linked CAD formats, false otherwise. Default value is true.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ConvertLinkedCADFormats { get; set; }
Public Property ConvertLinkedCADFormats As Boolean
    Get
    Set
public:
property bool ConvertLinkedCADFormats {
    bool get ();
    void set (bool value);
}
member ConvertLinkedCADFormats : bool with get, set

Property Value

Boolean
See Also

Reference

NavisworksExportOptions Class


NavisworksExportOptions.Coordinates Property

NavisworksExportOptionsCoordinates Property

Options which specifies the coordinates of Navisworks Exporter. Default value is Shared.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public NavisworksCoordinates Coordinates { get; set; }
Public Property Coordinates As NavisworksCoordinates
    Get
    Set
public:
property NavisworksCoordinates Coordinates {
    NavisworksCoordinates get ();
    void set (NavisworksCoordinates value);
}
member Coordinates : NavisworksCoordinates with get, set

Property Value

NavisworksCoordinates
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

NavisworksExportOptions Class


NavisworksExportOptions.DivideFileIntoLevels Property

NavisworksExportOptionsDivideFileIntoLevels Property

True to divide file into levels, false otherwise. Default value is true.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool DivideFileIntoLevels { get; set; }
Public Property DivideFileIntoLevels As Boolean
    Get
    Set
public:
property bool DivideFileIntoLevels {
    bool get ();
    void set (bool value);
}
member DivideFileIntoLevels : bool with get, set

Property Value

Boolean
See Also

Reference

NavisworksExportOptions Class


NavisworksExportOptions.ExportElementIds Property

NavisworksExportOptionsExportElementIds Property

True to export Revit element ids, false to skip these values. Default value is true.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ExportElementIds { get; set; }
Public Property ExportElementIds As Boolean
    Get
    Set
public:
property bool ExportElementIds {
    bool get ();
    void set (bool value);
}
member ExportElementIds : bool with get, set

Property Value

Boolean
See Also

Reference

NavisworksExportOptions Class


NavisworksExportOptions.ExportLinks Property

NavisworksExportOptionsExportLinks Property

True to export Revit links found in the main model, false to skip links. Default value is false.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ExportLinks { get; set; }
Public Property ExportLinks As Boolean
    Get
    Set
public:
property bool ExportLinks {
    bool get ();
    void set (bool value);
}
member ExportLinks : bool with get, set

Property Value

Boolean
See Also

Reference

NavisworksExportOptions Class


NavisworksExportOptions.ExportParts Property

NavisworksExportOptionsExportParts Property

True to export Revit part elements, false to export the original parent elements. Default value is false.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ExportParts { get; set; }
Public Property ExportParts As Boolean
    Get
    Set
public:
property bool ExportParts {
    bool get ();
    void set (bool value);
}
member ExportParts : bool with get, set

Property Value

Boolean
See Also

Reference

NavisworksExportOptions Class


NavisworksExportOptions.ExportRoomAsAttribute Property

NavisworksExportOptionsExportRoomAsAttribute Property

True to export data for each room converts into a single shared room attribute, false otherwise. Default value is true.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ExportRoomAsAttribute { get; set; }
Public Property ExportRoomAsAttribute As Boolean
    Get
    Set
public:
property bool ExportRoomAsAttribute {
    bool get ();
    void set (bool value);
}
member ExportRoomAsAttribute : bool with get, set

Property Value

Boolean
See Also

Reference

NavisworksExportOptions Class


NavisworksExportOptions.ExportRoomGeometry Property

NavisworksExportOptionsExportRoomGeometry Property

True to export Revit room geometry, false otherwise. Default value is true.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ExportRoomGeometry { get; set; }
Public Property ExportRoomGeometry As Boolean
    Get
    Set
public:
property bool ExportRoomGeometry {
    bool get ();
    void set (bool value);
}
member ExportRoomGeometry : bool with get, set

Property Value

Boolean
See Also

Reference

NavisworksExportOptions Class


NavisworksExportOptions.ExportScope Property

NavisworksExportOptionsExportScope Property

Options which specifies the export scope of Navisworks Exporter. Default value is Model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public NavisworksExportScope ExportScope { get; set; }
Public Property ExportScope As NavisworksExportScope
    Get
    Set
public:
property NavisworksExportScope ExportScope {
    NavisworksExportScope get ();
    void set (NavisworksExportScope value);
}
member ExportScope : NavisworksExportScope with get, set

Property Value

NavisworksExportScope
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

NavisworksExportOptions Class


NavisworksExportOptions.ExportUrls Property

NavisworksExportOptionsExportUrls Property

True to export URL parameters, false otherwise. Default value is true.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ExportUrls { get; set; }
Public Property ExportUrls As Boolean
    Get
    Set
public:
property bool ExportUrls {
    bool get ();
    void set (bool value);
}
member ExportUrls : bool with get, set

Property Value

Boolean
See Also

Reference

NavisworksExportOptions Class


NavisworksExportOptions.FacetingFactor Property

NavisworksExportOptionsFacetingFactor Property

Faceting factor. Default value is 1.0.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double FacetingFactor { get; set; }
Public Property FacetingFactor As Double
    Get
    Set
public:
property double FacetingFactor {
    double get ();
    void set (double value);
}
member FacetingFactor : float with get, set

Property Value

Double
See Also

Reference

NavisworksExportOptions Class


NavisworksExportOptions.FindMissingMaterials Property

NavisworksExportOptionsFindMissingMaterials Property

True if the file exporter looks for a match for the materials missing from the export, false otherwise. Default value is true.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool FindMissingMaterials { get; set; }
Public Property FindMissingMaterials As Boolean
    Get
    Set
public:
property bool FindMissingMaterials {
    bool get ();
    void set (bool value);
}
member FindMissingMaterials : bool with get, set

Property Value

Boolean
See Also

Reference

NavisworksExportOptions Class


NavisworksExportOptions.IsValidObject Property

NavisworksExportOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

NavisworksExportOptions Class


NavisworksExportOptions.Parameters Property

NavisworksExportOptionsParameters Property

Options which specifies the parameter conversion of Navisworks Exporter. Default value is All.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public NavisworksParameters Parameters { get; set; }
Public Property Parameters As NavisworksParameters
    Get
    Set
public:
property NavisworksParameters Parameters {
    NavisworksParameters get ();
    void set (NavisworksParameters value);
}
member Parameters : NavisworksParameters with get, set

Property Value

NavisworksParameters
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

NavisworksExportOptions Class


NavisworksExportOptions.ViewId Property

NavisworksExportOptionsViewId Property

The element id of the view to export. InvalidElementId by default. Used only when ExportScope = View.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId ViewId { get; set; }
Public Property ViewId As ElementId
    Get
    Set
public:
property ElementId^ ViewId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member ViewId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

NavisworksExportOptions Class


NavisworksExportOptions Methods

The NavisworksExportOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetSelectedElementIds | Returns the element ids of the elements to export. Empty by default.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetSelectedElementIds | Sets the element ids of the elements to export. Used only when ExportScope = SelectedElements.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

NavisworksExportOptions Class


NavisworksExportOptions.Dispose Method

NavisworksExportOptionsDispose Method

Releases all resources used by the NavisworksExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

NavisworksExportOptions Class


NavisworksExportOptions.GetSelectedElementIds Method

NavisworksExportOptionsGetSelectedElementIds Method

Returns the element ids of the elements to export. Empty by default.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetSelectedElementIds()
Public Function GetSelectedElementIds As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetSelectedElementIds()
member GetSelectedElementIds : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
See Also

Reference

NavisworksExportOptions Class


NavisworksExportOptions.SetSelectedElementIds Method

NavisworksExportOptionsSetSelectedElementIds Method

Sets the element ids of the elements to export. Used only when ExportScope = SelectedElements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetSelectedElementIds(
    ICollection<ElementId> ids
)
Public Sub SetSelectedElementIds (
    ids As ICollection(Of ElementId)
)
public:
void SetSelectedElementIds(
    ICollection<ElementId^>^ ids
)
member SetSelectedElementIds :
        ids : ICollection<ElementId> -> unit

Parameters

ids ICollection ElementId
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

NavisworksExportOptions Class


NavisworksExportScope Enumeration

An enumerated type listing possible "Element Scopes" of Navisworks Exporter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum NavisworksExportScope
Public Enumeration NavisworksExportScope
public enum class NavisworksExportScope
type NavisworksExportScope
Members
Member name | Value | Description
Model | 0 | Export all elements in the document.
View | 1 | Export the elements in a view.
SelectedElements | 2 | Export the selected elements.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


NavisworksParameters Enumeration

An enumerated type listing possible "Parameter conversions" of Navisworks Exporter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum NavisworksParameters
Public Enumeration NavisworksParameters
public enum class NavisworksParameters
type NavisworksParameters
Members
Member name | Value | Description
None | 0 | The file exporter does not convert parameters.
Elements | 1 | The file exporter converts parameters for all found elements.
All | 2 | The file exporter converts parameters for all found elements, including the referenced elements. As a result, extra property tabs are available in Autodesk Navisworks.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


NestedFamilyTypeReference Class

A proxy element representing a nested family type.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBNestedFamilyTypeReference

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class NestedFamilyTypeReference : Element
Public Class NestedFamilyTypeReference
    Inherits Element
public ref class NestedFamilyTypeReference : public Element
type NestedFamilyTypeReference =
    class
        inherit Element
    end

The NestedFamilyTypeReference type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | CategoryId | Category Id of the referenced family
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Name of the referenced family
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | TypeName | Type of the referenced family
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

This element represents a value of a FamilyType Parameter of a Loaded Family. Each such element corresponds to a nested FamilyType Element in the original Family Document where the family was defined.

This element stores only basic information about the nested FamilyType, such as the name of the Type, name of the Family, and a Category.

These elements are very low-level and thus bypassed by standard element filters. However, it is possible to obtain a set of applicable elements of this class for a FamilyType parameter of a family by calling [!:Autodesk::Revit::DB::Family::GetFamilyTypeParameterValues]

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


NestedFamilyTypeReference Properties

The NestedFamilyTypeReference type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | CategoryId | Category Id of the referenced family
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Name of the referenced family
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | TypeName | Type of the referenced family
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

NestedFamilyTypeReference Class


NestedFamilyTypeReference.CategoryId Property

NestedFamilyTypeReferenceCategoryId Property

Category Id of the referenced family

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId CategoryId { get; }
Public ReadOnly Property CategoryId As ElementId
    Get
public:
property ElementId^ CategoryId {
    ElementId^ get ();
}
member CategoryId : ElementId with get

Property Value

ElementId
See Also

Reference

NestedFamilyTypeReference Class


NestedFamilyTypeReference.FamilyName Property

NestedFamilyTypeReferenceFamilyName Property

Name of the referenced family

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FamilyName { get; }
Public ReadOnly Property FamilyName As String
    Get
public:
property String^ FamilyName {
    String^ get ();
}
member FamilyName : string with get

Property Value

String
See Also

Reference

NestedFamilyTypeReference Class


NestedFamilyTypeReference.TypeName Property

NestedFamilyTypeReferenceTypeName Property

Type of the referenced family

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TypeName { get; }
Public ReadOnly Property TypeName As String
    Get
public:
property String^ TypeName {
    String^ get ();
}
member TypeName : string with get

Property Value

String
See Also

Reference

NestedFamilyTypeReference Class


NestedFamilyTypeReference Methods

The NestedFamilyTypeReference type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

NestedFamilyTypeReference Class


NullParameterValue Class

A class that represent an empty (null) value of a parameter element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBParameterValue
Autodesk.Revit.DBNullParameterValue

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class NullParameterValue : ParameterValue
Public Class NullParameterValue
    Inherits ParameterValue
public ref class NullParameterValue : public ParameterValue
type NullParameterValue =
    class
        inherit ParameterValue
    end

The NullParameterValue type exposes the following members.

Constructors
 | Name | Description
Public method | NullParameterValue | Default constructor
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ParameterValue)
Top
Methods
 | Name | Description
Public method | Copy | Makes an identical copy of the given parameter value. (Inherited from ParameterValue)
Public method | Dispose | (Inherited from ParameterValue)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqual | Tests equality with another instance of the same class. (Inherited from ParameterValue)
Public method | IsSameType | Tests another instance is of the same value type. (Inherited from ParameterValue)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


NullParameterValue Constructor

Default constructor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public NullParameterValue()
Public Sub New
public:
NullParameterValue()
new : unit -> NullParameterValue
See Also

Reference

NullParameterValue Class


NullParameterValue Properties

The NullParameterValue type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ParameterValue)
Top
See Also

Reference

NullParameterValue Class


NullParameterValue Methods

The NullParameterValue type exposes the following members.

Methods
 | Name | Description
Public method | Copy | Makes an identical copy of the given parameter value. (Inherited from ParameterValue)
Public method | Dispose | (Inherited from ParameterValue)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqual | Tests equality with another instance of the same class. (Inherited from ParameterValue)
Public method | IsSameType | Tests another instance is of the same value type. (Inherited from ParameterValue)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

NullParameterValue Class


NumberingSchema Class

A class to support assigning numbers to elements of a particular kind for the purpose of tagging and scheduling them.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBNumberingSchema

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class NumberingSchema : Element
Public Class NumberingSchema
    Inherits Element
public ref class NumberingSchema : public Element
type NumberingSchema =
    class
        inherit Element
    end

The NumberingSchema type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
 | MaximumStartingNumber | A static property defining the maximum number a numbering sequence can use as its starting number (the lowest number in the sequence).
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | NumberingParameterId | Id of the parameter that stores values of the numbers on enumerated elements.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SchemaType | Identifies the kind of elements/objects this numbering schema is used for.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | AppendSequence | Appends all elements of one numbering sequence to the end of another sequence.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | AssignElementsToSequence | Assigns the input elements to a sequence identified by the given partition name.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeNumber | Replaces an existing number with a new one (that does not exist yet).
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
 | GetMinimumNumberOfDigits | Returns the minimum number of digits to be used for formating the Number parameter of all enumerable elements of the given document.
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
 | GetNumberingSchema | Returns an instance of the specified Numbering Schema in the given document.
Public method | GetNumberingSequences | Returns all numbering sequences within this numbering schema.
Public method | GetNumbers | Returns all numbers currently used in the given numbering sequence
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
 | GetSchemasInDocument | Returns a set of Ids of all Numbering Schema elements for a given document.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
 | IsValidPartitionName | Tests if the given string can be used as a name for a numbering partition.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | MergeSequences | Merges all elements from given numbering sequences to a new sequence.
 | MoveSequence | Moves all elements of a numbering sequence from one partition to another.
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveGaps | Removes gaps, if any, in a numbering sequence
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
 | SetMinimumNumberOfDigits | Sets a new value for the minimum number of digits to be used for formating the Number parameter of all numbered elements of the given document.
Public method | ShiftNumbers | Shifts all numbers in the sequence so the starting number has the given value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

Each NumberingSchema controls numbering of elements of one particular kind, typically of the same category such as Rebar or Fabric Reinforcement. Instances of NumberingSchema are also elements and there is always only one of each type in every Revit document. Available types of all built-in numbering schemas are enumerated in NumberingSchemaTypes class. At present, schema elements cannot be manually added, deleted, or copied. Attempts to do so will result in a failure warning and/or exceptions thrown.

Elements (e.g. Rebar) belonging to a particular schema (e.g. NumberingSchemaTypes.StructuralNumberingSchemas.Rebar) are organized and numbered in sequences. A sequence is a collection of elements that share the same numbering partition as defined by their respective values of the Partition parameter (NUMBER_PARTITION_PARAM). For a numbering sequence to exist it must contain at least one element. In other words, a sequence is established once there is at least one element of which the partition parameter has a value that differs from other elements (in the same numbering schema). If the last element is removed (deleted or moved to a different sequence) the then empty sequence ceases to exist.

Elements get assigned to sequences either upon their creation (based on the then current numbering partition value), or by explicitly modifying the Partition parameter of an element, or by using the AssignElementsToSequence method. It is highly recommended using that method over explicitly changing the Partition parameter, because the methods applies changes to sequences and element numbers immediately, while changed parameters get into effect only after the current transaction is closed.

In addition to directly or indirectly changing the Partition parameter of elements, numbering sequences can be reorganized by using methods of the NumberingSchema class. The MoveSequence method moves all elements of an existing sequence to a new sequence that does not exist yet in the schema, thus effectively renaming the Partition parameter on all the affected elements. The AppendSequence method removes all elements from one sequence and appends them to elements of another existing sequence while applying the matching policy. The method MergeSequences takes elements of all specified sequences and moves them all into a newly created sequence. All the merged elements will be renumbered and matched as needed based on the matching algorithm.

Elements in different sequences are numbered independently, meaning that there may be elements with the same number in two sequences even though the elements are different. Likewise, there may be perfectly identical elements in two or more sequences bearing different numbers. However, within each one numbering sequence any two identical elements will always have the same number, while different elements will never have the same number within a numbering sequence. Revit refers to this rule as the matching policy.

Enumerable elements are always numbered automatically upon their creation. Each new element will get an incrementally higher number. However, thanks to the matching policy, new elements that match existing elements within the same sequence will get the same number assigned. Elements will keep their assigned numbers as long as it is possible. This means, for example, that if some previously created elements (e.g. Rebar) get deleted, all remaining elements (within the same numbering sequence) will keep their numbers, which may result in gaps in the respective numbering sequence. Gaps can be removed by invoking RemoveGaps for sequences in which gaps are not desired.

Numbers are stored as values of a numbering parameter on each numbered element. The Id of the parameter is obtained by querying the NumberingParameterId property. The value of the number can be obtained by querying the parameter for the respective numbered element. The value is read-only and thus cannot be set; it is always computed based on relations of elements across numbering partitions and the matching policy within the numbering sequence of each element.

Even though numbers are always assigned automatically to all elements of a schema, the method ChangeNumber gives the programmer a way to explicitly overwrite a specific number as long as the new number is unique in the numbering sequence. The caller specifies a number to be changed and a new value that is to be applied, providing the value does not exist yet in the same numbering sequence. Although this operation may seem rather limited, it provides the programmer with freedom to change practically any number even if it may be achieved in multiple steps.

Example
C#
VB
C++
F#
Copy
/// <summary>
/// This function consolidates the numbers on Rebar elements by removing
/// any remaining gaps in numbering sequences and setting the start number
/// of each sequence so numbers in sequences do not overlap.
/// </summary>
/// <param name="document">The document in which Rebar numbers are to be consolidated</param>
private void ConsolidateRebarNumbers(Document document)
{
    // Obtain a schema object for a particular kind of elements
    NumberingSchema schema = NumberingSchema.GetNumberingSchema(document,NumberingSchemaTypes.StructuralNumberingSchemas.Rebar);

    // Collect the names of partitions of all the numbering sequences currently contained in the schema
    IList<string> sequences = schema.GetNumberingSequences();

    using (Transaction transaction = new Transaction(document))
    {
        // Changes to numbers must be made inside a transaction
        transaction.Start("Consolidate Rebar Numbers");

        // First we make sure numbers in all sequences are consecutive
        // by removing possible gaps in numbers. Note: RemoveGaps does
        // nothing for a sequence where there are no gaps present.

        // We also want to find what the maximum range of numbers is
        // of all the sequences (the one the widest span of used numbers)
        int maxRange = 0;

        foreach (string name in sequences)
        {
            schema.RemoveGaps(name);

            // Here we use First() from the Linq extension.
            // There is always at least one range in every sequence,
            // and after gaps are closed there is exactly one range.
            IntegerRange range = schema.GetNumbers(name).First();
            int rangeSpan = 1 + (range.High - range.Low);
            if (rangeSpan > maxRange)
            {
                maxRange = rangeSpan;
            }
        }

        // Next we give sequences different start numbers
        // starting with 100 and then stepping by at least
        // the maximum range we found in the previous step
        int startNumber = 100;

        // We round the range up to the closest 100
        int step = 100 * (int)((maxRange + 99) / 100.0);

        foreach (string name in sequences)
        {
            schema.ShiftNumbers(name, startNumber);
            startNumber += step;
        }

        transaction.Commit();
    }
}
''' <summary>
''' This function consolidates the numbers on Rebar elements by removing
''' any remaining gaps in numbering sequences and setting the start number
''' of each sequence so numbers in sequences do not overlap.
''' </summary>
''' <param name="document">The document in which Rebar numbers are to be consolidated</param>
Private Sub ConsolidateRebarNumbers(document As Document)
    ' Obtain a schema object for a particular kind of elements
    Dim schema As NumberingSchema = NumberingSchema.GetNumberingSchema(document, NumberingSchemaTypes.StructuralNumberingSchemas.Rebar)

    ' Collect the names of partitions of all the numbering sequences currently contained in the schema
    Dim sequences As IList(Of String) = schema.GetNumberingSequences()

    Using transaction As New Transaction(document)
        ' Changes to numbers must be made inside a transaction
        transaction.Start("Consolidate Rebar Numbers")

        ' First we make sure numbers in all sequences are consecutive
        ' by removing possible gaps in numbers. Note: RemoveGaps does
        ' nothing for a sequence where there are no gaps present.

        ' We also want to find what the maximum range of numbers is
        ' of all the sequences (the one the widest span of used numbers)
        Dim maxRange As Integer = 0

        For Each name As String In sequences
            schema.RemoveGaps(name)

            ' Here we use First() from the Linq extension.
            ' There is always at least one range in every sequence,
            ' and after gaps are closed there is exactly one range.
            Dim range As IntegerRange = schema.GetNumbers(name).First()
            Dim rangeSpan As Integer = 1 + (range.High - range.Low)
            If rangeSpan > maxRange Then
                maxRange = rangeSpan
            End If
        Next

        ' Next we give sequences different start numbers
        ' starting with 100 and then stepping by at least
        ' the maximum range we found in the previous step
        Dim startNumber As Integer = 100

        ' We round the range up to the closest 100
        Dim [step] As Integer = 100 * CInt(Math.Truncate((maxRange + 99) / 100.0))

        For Each name As String In sequences
            schema.ShiftNumbers(name, startNumber)
            startNumber += [step]
        Next

        transaction.Commit()
    End Using
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


NumberingSchema Properties

The NumberingSchema type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
 | MaximumStartingNumber | A static property defining the maximum number a numbering sequence can use as its starting number (the lowest number in the sequence).
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | NumberingParameterId | Id of the parameter that stores values of the numbers on enumerated elements.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SchemaType | Identifies the kind of elements/objects this numbering schema is used for.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

NumberingSchema Class


NumberingSchema.MaximumStartingNumber Property

NumberingSchemaMaximumStartingNumber Property

A static property defining the maximum number a numbering sequence can use as its starting number (the lowest number in the sequence).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int MaximumStartingNumber { get; }
Public Shared ReadOnly Property MaximumStartingNumber As Integer
    Get
public:
static property int MaximumStartingNumber {
    int get ();
}
static member MaximumStartingNumber : int with get

Property Value

Int32
Remarks
Use this method to ensure a value given to the ShiftNumbers is within the valid range.
See Also

Reference

NumberingSchema Class


NumberingSchema.NumberingParameterId Property

NumberingSchemaNumberingParameterId Property

Id of the parameter that stores values of the numbers on enumerated elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId NumberingParameterId { get; }
Public ReadOnly Property NumberingParameterId As ElementId
    Get
public:
property ElementId^ NumberingParameterId {
    ElementId^ get ();
}
member NumberingParameterId : ElementId with get

Property Value

ElementId
Remarks

Values of numbers can be obtained by querying this parameter for the respective numbered element. The value is read-only and thus cannot be set; it is always computed based on the order of created elements and the matching policy within each numbering sequence.

Note: Although the parameter cannot be changed directly, it can be modified indirectly (with restrictions) using the ChangeNumber(String, Int32, Int32) method.

See Also

Reference

NumberingSchema Class


NumberingSchema.SchemaType Property

NumberingSchemaSchemaType Property

Identifies the kind of elements/objects this numbering schema is used for.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public NumberingSchemaType SchemaType { get; }
Public ReadOnly Property SchemaType As NumberingSchemaType
    Get
public:
property NumberingSchemaType^ SchemaType {
    NumberingSchemaType^ get ();
}
member SchemaType : NumberingSchemaType with get

Property Value

NumberingSchemaType
See Also

Reference

NumberingSchema Class


NumberingSchema Methods

The NumberingSchema type exposes the following members.

Methods
 | Name | Description
Public method | AppendSequence | Appends all elements of one numbering sequence to the end of another sequence.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | AssignElementsToSequence | Assigns the input elements to a sequence identified by the given partition name.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeNumber | Replaces an existing number with a new one (that does not exist yet).
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
 | GetMinimumNumberOfDigits | Returns the minimum number of digits to be used for formating the Number parameter of all enumerable elements of the given document.
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
 | GetNumberingSchema | Returns an instance of the specified Numbering Schema in the given document.
Public method | GetNumberingSequences | Returns all numbering sequences within this numbering schema.
Public method | GetNumbers | Returns all numbers currently used in the given numbering sequence
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
 | GetSchemasInDocument | Returns a set of Ids of all Numbering Schema elements for a given document.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
 | IsValidPartitionName | Tests if the given string can be used as a name for a numbering partition.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | MergeSequences | Merges all elements from given numbering sequences to a new sequence.
 | MoveSequence | Moves all elements of a numbering sequence from one partition to another.
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveGaps | Removes gaps, if any, in a numbering sequence
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
 | SetMinimumNumberOfDigits | Sets a new value for the minimum number of digits to be used for formating the Number parameter of all numbered elements of the given document.
Public method | ShiftNumbers | Shifts all numbers in the sequence so the starting number has the given value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

NumberingSchema Class


NumberingSchema.AppendSequence Method

NumberingSchemaAppendSequence Method

Appends all elements of one numbering sequence to the end of another sequence.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AppendSequence(
    string fromPartition,
    string toPartition
)
Public Sub AppendSequence (
    fromPartition As String,
    toPartition As String
)
public:
void AppendSequence(
    String^ fromPartition,
    String^ toPartition
)
member AppendSequence :
        fromPartition : string *
        toPartition : string -> unit

Parameters

fromPartition String
Name of the partition that determines which numbering sequence to append. The sequence must exist already, otherwise an exception will be thrown.
toPartition String
Name of a partition into which the source sequence is going to be appended. The sequence must exist already, otherwise an exception will be thrown.
Exceptions
Exception | Condition
ArgumentException | The sequence fromPartition does not exist in the schema. -or- The sequence toPartition does not exist in the schema. -or- Given partition names fromPartition and toPartition must be different.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Either the schema or its document cannot be modified at present. -or- Thrown if there is an element that cannot have new value of the NUMBER_PARTITION_PARAM parameter assigned. It may be an indication that the element is not free to be edited at present.
Remarks

All numbers assigned to elements in the target sequence remain the same, but numbers in the source sequence (the one getting appended) will change. Elements that match elements in the target sequence will get the same numbers assigned. Remaining elements will get consecutive numbers in the creation order of the elements starting with the next highest number available in the target sequence.

This operation modifies the Partition parameter of all elements in the sequence that is getting appended. Therefore, all its elements must be accessible for editing, otherwise this operation will fail.

Elements can be appended only to a sequence that already exists. In order to reassign elements of one sequence to a partition that does not exist yet, use either the MoveSequence or MergeSequences methods.

See Also

Reference

NumberingSchema Class


NumberingSchema.AssignElementsToSequence Method

NumberingSchemaAssignElementsToSequence Method

Assigns the input elements to a sequence identified by the given partition name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AssignElementsToSequence(
    ISet<ElementId> elementIds,
    string partitionName
)
Public Sub AssignElementsToSequence (
    elementIds As ISet(Of ElementId),
    partitionName As String
)
public:
void AssignElementsToSequence(
    ISet<ElementId^>^ elementIds,
    String^ partitionName
)
member AssignElementsToSequence :
        elementIds : ISet<ElementId> *
        partitionName : string -> unit

Parameters

elementIds ISet ElementId
Ids of elements which are to be added to a sequence. All elements must be valid and belonging to this schema.
partitionName String
Name of the target sequence's partition
Exceptions
Exception | Condition
ArgumentException | the given partitionName cannot be used as a valid name of a numbering partition because it contains characters that are considered invalid, such as non-printable characters or those that cannot be used in a file's name. -or- Thrown when elementIds contains Ids that are either invalid or of elements not from this schema.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Either the schema or its document cannot be modified at present. -or- Thrown if there is an element that cannot have new value of the NUMBER_PARTITION_PARAM parameter assigned. It may be an indication that the element is not free to be edited at present.
Remarks

Elements will be added to the sequence by changing the value of their Partition parameter. The difference between this method and changing the parameter value explicitly is that the method here causes sequences to get assigned and renumbered automatically and immediately without needing to commit a transaction first.

A numbering sequence for the given partition does not need to exist yet; it will get created automatically by this method as needed.

The elements' numbers are likely to be affected by this operation, which is to be expected. The values of assigned numbers will depend on whether the given sequence already exists or not. In both cases the elements will get renumbered in order of their original creation, but the first value will be 1 if the sequence does not exist yet, respectively the next highest number if the sequence does exist already. The general matching policy is always applied causing matched elements to have the same number.

A special case is considered when the given elements are all the elements of one sequence and are being assigned to a sequence that does not exist yet. Such an operation is identical in effect to the MoveSequence method and all the elements will keep their numbers unchanged.

See Also

Reference

NumberingSchema Class


NumberingSchema.ChangeNumber Method

NumberingSchemaChangeNumber Method

Replaces an existing number with a new one (that does not exist yet).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ElementId> ChangeNumber(
    string partition,
    int fromNumber,
    int toNumber
)
Public Function ChangeNumber (
    partition As String,
    fromNumber As Integer,
    toNumber As Integer
) As IList(Of ElementId)
public:
IList<ElementId^>^ ChangeNumber(
    String^ partition,
    int fromNumber,
    int toNumber
)
member ChangeNumber :
        partition : string *
        fromNumber : int *
        toNumber : int -> IList<ElementId>

Parameters

partition String
Name of the partition that identifies the sequence containing the number to be changed.
fromNumber Int32
Number to be changed; there must already be an element with that number in the sequence.
toNumber Int32
Number to change to; no element must have this number yet in the sequence.

Return Value

IList ElementId
A collection of elements affected by the change of the number
Exceptions
Exception | Condition
ArgumentException | The sequence partition does not exist in the schema. -or- The specified sequence does not contain any elements with the given fromNumber. -or- There already are elements with the given toNumber in the specified sequence.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | The value of toNumber must be in the range from 1 to the maximum value for an Integer type
InvalidOperationException | Either the schema or its document cannot be modified at present.
Remarks

This method gives the caller the ability to overwrite any number used in a given numbering sequence as long as the new number does not exist in the same sequence yet. If an attempt is made to replace a number by another that already exists, an exception will be thrown.

The new number will automatically be applied to all elements that bear the original number, thus those elements must be free to be modified. A collection of element Ids of all the affected elements is returned by this method.

The method is independent of the sequence's current starting number that might have been assigned previously, meaning that the new number will be accepted even if it is lower than the previously set start number in the sequence.

See Also

Reference

NumberingSchema Class


NumberingSchema.GetMinimumNumberOfDigits Method

NumberingSchemaGetMinimumNumberOfDigits Method

Returns the minimum number of digits to be used for formating the Number parameter of all enumerable elements of the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int GetMinimumNumberOfDigits(
    Document document
)
Public Shared Function GetMinimumNumberOfDigits (
    document As Document
) As Integer
public:
static int GetMinimumNumberOfDigits(
    Document^ document
)
static member GetMinimumNumberOfDigits :
        document : Document -> int

Parameters

document Document
The document this value is going to be applied to.

Return Value

Int32
The current number of formatting digits
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks

The number is used by all numbering schemas in the document.

The value can be modified by using the SetMinimumNumberOfDigits(Document, Int32) method.

See Also

Reference

NumberingSchema Class


NumberingSchema.GetNumberingSchema Method

NumberingSchemaGetNumberingSchema Method

Returns an instance of the specified Numbering Schema in the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static NumberingSchema GetNumberingSchema(
    Document document,
    NumberingSchemaType schemaType
)
Public Shared Function GetNumberingSchema (
    document As Document,
    schemaType As NumberingSchemaType
) As NumberingSchema
public:
static NumberingSchema^ GetNumberingSchema(
    Document^ document,
    NumberingSchemaType^ schemaType
)
static member GetNumberingSchema :
        document : Document *
        schemaType : NumberingSchemaType -> NumberingSchema

Parameters

document Document
A document to get the numbering schema from.
schemaType NumberingSchemaType
The type of a built-in schema to get.

Return Value

NumberingSchema
Instance of the specified schema.
Exceptions
Exception | Condition
ArgumentException | The given schemaType has an invalid Id.
ArgumentNullException | A non-optional argument was null
See Also

Reference

NumberingSchema Class


NumberingSchema.GetNumberingSequences Method

NumberingSchemaGetNumberingSequences Method

Returns all numbering sequences within this numbering schema.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<string> GetNumberingSequences()
Public Function GetNumberingSequences As IList(Of String)
public:
IList<String^>^ GetNumberingSequences()
member GetNumberingSequences : unit -> IList<string>

Return Value

IList String
A collection of partition names of all numbering sequences currently present in this schema.
Remarks

The collection may be empty if there are no elements yet in this schema.

One of the strings can be an empty string, which would indicate presence of the default partition into which elements automatically belong if left unassigned to any other partition

See Also

Reference

NumberingSchema Class


NumberingSchema.GetNumbers Method

NumberingSchemaGetNumbers Method

Returns all numbers currently used in the given numbering sequence

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<IntegerRange> GetNumbers(
    string partition
)
Public Function GetNumbers (
    partition As String
) As IList(Of IntegerRange)
public:
IList<IntegerRange^>^ GetNumbers(
    String^ partition
)
member GetNumbers :
        partition : string -> IList<IntegerRange>

Parameters

partition String
Name of the partition that identifies the sequence. The sequence must exist.

Return Value

IList IntegerRange
A collection of integer ranges
Exceptions
Exception | Condition
ArgumentException | The sequence partition does not exist in the schema.
ArgumentNullException | A non-optional argument was null
Remarks

Numbers are returned as a collection of ranges, where each range is a pair of two integer values, Low and High. As long as there is no gap currently in the sequence, there will be only one range.

See Also

Reference

NumberingSchema Class


NumberingSchema.GetSchemasInDocument Method

NumberingSchemaGetSchemasInDocument Method

Returns a set of Ids of all Numbering Schema elements for a given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ISet<ElementId> GetSchemasInDocument(
    Document document
)
Public Shared Function GetSchemasInDocument (
    document As Document
) As ISet(Of ElementId)
public:
static ISet<ElementId^>^ GetSchemasInDocument(
    Document^ document
)
static member GetSchemasInDocument :
        document : Document -> ISet<ElementId>

Parameters

document Document
A document to get numbering schema from.

Return Value

ISet ElementId
Ids of NumberingSchema elements. An empty set if no schemas are found in the given document.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

NumberingSchema Class


NumberingSchema.IsValidPartitionName Method

NumberingSchemaIsValidPartitionName Method

Tests if the given string can be used as a name for a numbering partition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidPartitionName(
    string name,
    out string message
)
Public Shared Function IsValidPartitionName (
    name As String,
    <OutAttribute> ByRef message As String
) As Boolean
public:
static bool IsValidPartitionName(
    String^ name,
    [OutAttribute] String^% message
)
static member IsValidPartitionName :
        name : string *
        message : string byref -> bool

Parameters

name String
A name to validate.
message String
Optional string to receive an error message to possibly show to the end user in case the name is found invalid. This argument may be null.

Return Value

Boolean
Returns True if the name can be used; or False if the string contains invalid characters.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
For a name to be considered valid it must contain only printable characters excluding any characters that may not be used in name of a file.
See Also

Reference

NumberingSchema Class


NumberingSchema.MergeSequences Method

NumberingSchemaMergeSequences Method

Merges all elements from given numbering sequences to a new sequence.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void MergeSequences(
    IList<string> sourcePartitions,
    string newPartition
)
Public Sub MergeSequences (
    sourcePartitions As IList(Of String),
    newPartition As String
)
public:
void MergeSequences(
    IList<String^>^ sourcePartitions,
    String^ newPartition
)
member MergeSequences :
        sourcePartitions : IList<string> *
        newPartition : string -> unit

Parameters

sourcePartitions IList String
A collection of partition names identifying the sequences to be merged together. There must be at least two names in the list. All the sequences must exist already.
newPartition String
Name of a new partition into which the source sequences will be merged. Leading and trailing white space is ignored in the given string and will be removed automatically.
Exceptions
Exception | Condition
ArgumentException | The sourcePartitions list must contain at least two names. -or- Either one or more sequences in the sourcePartitions list does not exist in the schema, or the list contains duplicated names. -or- The sequence newPartition does already exist in the schema. -or- the given newPartition cannot be used as a valid name of a numbering partition because it contains characters that are considered invalid, such as non-printable characters or those that cannot be used in a file's name.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Either the schema or its document cannot be modified at present. -or- Thrown if there is an element that cannot have new value of the NUMBER_PARTITION_PARAM parameter assigned. It may be an indication that the element is not free to be edited at present.
Remarks

Upon a successful merge, all elements in the new merged sequence will be renumbered in order of the element creation. There will be no gaps.

There must not be a sequence for the target partition in the schema yet, otherwise an exception will be thrown.

This operation modifies the Partition parameter of all elements in the sequences that are being merged. Therefore, all its elements must be accessible for editing, otherwise this operation will fail.

See Also

Reference

NumberingSchema Class


NumberingSchema.MoveSequence Method

NumberingSchemaMoveSequence Method

Moves all elements of a numbering sequence from one partition to another.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void MoveSequence(
    string fromPartition,
    string newPartition
)
Public Sub MoveSequence (
    fromPartition As String,
    newPartition As String
)
public:
void MoveSequence(
    String^ fromPartition,
    String^ newPartition
)
member MoveSequence :
        fromPartition : string *
        newPartition : string -> unit

Parameters

fromPartition String
Name of the partition that determines which numbering sequence to move. The sequence must exist already, otherwise an exception will be thrown.
newPartition String
Name of a partition into which the source sequence is going to be moved. The schema must not have a sequence for this partition yet (i.e. the schema does not have an element that was assigned to such a partition.)

Leading and trailing white space is ignored in the given string and will be removed automatically.

Exceptions
Exception | Condition
ArgumentException | The sequence fromPartition does not exist in the schema. -or- The sequence newPartition does already exist in the schema. -or- the given newPartition cannot be used as a valid name of a numbering partition because it contains characters that are considered invalid, such as non-printable characters or those that cannot be used in a file's name.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Either the schema or its document cannot be modified at present. -or- Thrown if there is an element that cannot have new value of the NUMBER_PARTITION_PARAM parameter assigned. It may be an indication that the element is not free to be edited at present.
Remarks

All numbers assigned to elements in the sequence remain the same.

This operation modifies the Partition parameter of all elements in the given sequence. Therefore, all the elements must be accessible for editing.

Elements can be moved only to a partition that does not exist yet. To move elements to an existing partition use the AppendSequence method.

Example
C#
VB
C++
F#
Copy
/// <summary>
/// This method uses multiple moving operations to swap numbers
/// for Rebars in two numbering sequences. The sequences are
/// identified by the names of two numbering partitions.
/// </summary>
/// <param name="document">Document to modify</param>
/// <param name="part1">Name of the partition of one numbering sequence</param>
/// <param name="part2">Name of the partition of another numbering sequence</param>
private void SwapNumberingSequences(Document document, string part1, string part2)
{
    // Obtain a schema object for a particular kind of elements
    NumberingSchema schema = NumberingSchema.GetNumberingSchema(document,NumberingSchemaTypes.StructuralNumberingSchemas.Rebar);

    using (Transaction transaction = new Transaction(document))
    {
        // Changes to numbering sequences must be made inside a transaction
        transaction.Start("Swap Numbering Sequences");

        // We will use a temporary partition for the swap operation,
        // for the move operation only works if the target partition
        // does not exist yet in the same numbering schema.
        // (We assume this TEMPORARY partition does not exist.)
        string tempPartition = "TEMPORARY";

        // Step 1
        // First we move all elements from one sequence into
        // a partition we know does not exist. This action will
        // create the temporary partition and remove the original
        // one (part1).
        schema.MoveSequence(part1, tempPartition);

        // Step 2
        // With the sequence in partition 'part1' removed
        // we can now move elements from the second sequence to it.
        // This action will re-create a sequence in partition 'part1'
        // and remove the sequence in partition 'part2'
        schema.MoveSequence(part2, part1);

        // Step 3
        // Finally, we can move elements 'parked' in the temporary
        // sequence to partition 'part2', for that partition was
        // removed in the previous step and thus can now be created
        // again. The temporary partition will be automatically
        // removed upon completing this step.
        schema.MoveSequence(tempPartition, part2);

        transaction.Commit();
    }
}
''' <summary>
''' This method uses multiple moving operations to swap numbers
''' for Rebars in two numbering sequences. The sequences are
''' identified by the names of two numbering partitions.
''' </summary>
''' <param name="document">Document to modify</param>
''' <param name="part1">Name of the partition of one numbering sequence</param>
''' <param name="part2">Name of the partition of another numbering sequence</param>
Private Sub SwapNumberingSequences(document As Document, part1 As String, part2 As String)
    ' Obtain a schema object for a particular kind of elements
    Dim schema As NumberingSchema = NumberingSchema.GetNumberingSchema(document, NumberingSchemaTypes.StructuralNumberingSchemas.Rebar)

    Using transaction As New Transaction(document)
        ' Changes to numbering sequences must be made inside a transaction
        transaction.Start("Swap Numbering Sequences")

        ' We will use a temporary partition for the swap operation,
        ' for the move operation only works if the target partition
        ' does not exist yet in the same numbering schema.
        ' (We assume this TEMPORARY partition does not exist.)
        Dim tempPartition As String = "TEMPORARY"

        ' Step 1
        ' First we move all elements from one sequence into
        ' a partition we know does not exist. This action will
        ' create the temporary partition and remove the original
        ' one (part1).
        schema.MoveSequence(part1, tempPartition)

        ' Step 2
        ' With the sequence in partition 'part1' removed
        ' we can now move elements from the second sequence to it.
        ' This action will re-create a sequence in partition 'part1'
        ' and remove the sequence in partition 'part2'
        schema.MoveSequence(part2, part1)

        ' Step 3
        ' Finally, we can move elements 'parked' in the temporary
        ' sequence to partition 'part2', for that partition was
        ' removed in the previous step and thus can now be created
        ' again. The temporary partition will be automatically
        ' removed upon completing this step.
        schema.MoveSequence(tempPartition, part2)

        transaction.Commit()
    End Using
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

NumberingSchema Class


NumberingSchema.RemoveGaps Method

NumberingSchemaRemoveGaps Method

Removes gaps, if any, in a numbering sequence

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveGaps(
    string partition
)
Public Sub RemoveGaps (
    partition As String
)
public:
void RemoveGaps(
    String^ partition
)
member RemoveGaps :
        partition : string -> unit

Parameters

partition String
Name of the partition that identifies the sequence. The sequence must exist.
Exceptions
Exception | Condition
ArgumentException | The sequence partition does not exist in the schema.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Either the schema or its document cannot be modified at present.
Remarks
Gaps are removed by shifting numbers above each gap down by the amount of numbers skipped in the gap. The lowest number in the sequence will remain unchanged.
See Also

Reference

NumberingSchema Class


NumberingSchema.SetMinimumNumberOfDigits Method

NumberingSchemaSetMinimumNumberOfDigits Method

Sets a new value for the minimum number of digits to be used for formating the Number parameter of all numbered elements of the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void SetMinimumNumberOfDigits(
    Document document,
    int value
)
Public Shared Sub SetMinimumNumberOfDigits (
    document As Document,
    value As Integer
)
public:
static void SetMinimumNumberOfDigits(
    Document^ document,
    int value
)
static member SetMinimumNumberOfDigits :
        document : Document *
        value : int -> unit

Parameters

document Document
The document in which the new value will be in applied.
value Int32
New value for the minimum number of digits.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | The minimum number of digits must be in range from 1 to 10.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks

Valid values range from 1 to 10. Numbers with fewer digits than the minimum number will be padded with leading zeros.

The value affects all numbering schemas. Thus, once set, numbers for Rebar and Reinforcement Fabric will be formatted with the same minimum number of digits.

The current value can obtained by invoking the GetMinimumNumberOfDigits(Document) method.

See Also

Reference

NumberingSchema Class


NumberingSchema.ShiftNumbers Method

NumberingSchemaShiftNumbers Method

Shifts all numbers in the sequence so the starting number has the given value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ShiftNumbers(
    string partition,
    int firstNumber
)
Public Sub ShiftNumbers (
    partition As String,
    firstNumber As Integer
)
public:
void ShiftNumbers(
    String^ partition,
    int firstNumber
)
member ShiftNumbers :
        partition : string *
        firstNumber : int -> unit

Parameters

partition String
Name of the partition that identifies the sequence. The sequence must exist.
firstNumber Int32
Value for the new first (lowest) number of the sequence.
Exceptions
Exception | Condition
ArgumentException | The sequence partition does not exist in the schema.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | firstNumber must be in range between 1 and MaximumStartingNumber.
InvalidOperationException | Either the schema or its document cannot be modified at present.
Remarks

A shift of all numbers in the sequence will be computed and applied so the first (lowest) number in the sequence would have the given value. All the other numbers will then be shifted relatively by the same amount.

Any existing gaps in the current numbering sequence will be preserved.

Shifts that would make the start number less than 1 or bigger than MaximumStartingNumber are considered invalid.

See Also

Reference

NumberingSchema Class


NumberingSchemaType Class

A type for identifying a NumberingSchema of a particular kind.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBGuidEnum
Autodesk.Revit.DBNumberingSchemaType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class NumberingSchemaType : GuidEnum
Public Class NumberingSchemaType
    Inherits GuidEnum
public ref class NumberingSchemaType : public GuidEnum
type NumberingSchemaType =
    class
        inherit GuidEnum
    end

The NumberingSchemaType type exposes the following members.

Constructors
 | Name | Description
Public method | NumberingSchemaType | Creates a new NumberingSchemaType instance.
Top
Properties
 | Name | Description
Public property | Guid | The Guid of GUID-based enum object. (Inherited from GuidEnum)
Top
Methods
 | Name | Description
Public method | Equals | Compares two Guid-based enum object based on their concrete class and GUID value. (Inherited from GuidEnum)
Public method | GetHashCode | Generates a hash code for this Guid-based enum object. (Inherited from GuidEnum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Operators
Name | Description
Equality(NumberingSchemaType, NumberingSchemaType) | Compares two NumberingSchemaType instances.
Inequality(NumberingSchemaType, NumberingSchemaType) | Compares two NumberingSchemaType instances.
Top
Remarks

Each numbering schema is applicable to a certain category of Revit elements. For example, the Rebar numbering schema (built-in) is used and only applicable to Rebar elements. With that schema present, all Rebar elements automatically will get their respective numbers and those numbers would not correspond in any way to numbers of other enumerable elements that belong to different numbering schemas.

There are only built-in schemas available currently.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


NumberingSchemaType Constructor

Creates a new NumberingSchemaType instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public NumberingSchemaType(
    Guid guid
)
Public Sub New (
    guid As Guid
)
public:
NumberingSchemaType(
    Guid guid
)
new :
        guid : Guid -> NumberingSchemaType

Parameters

guid Guid
The identifier for the NumberingSchemaType.
See Also

Reference

NumberingSchemaType Class


NumberingSchemaType Properties

The NumberingSchemaType type exposes the following members.

Properties
 | Name | Description
Public property | Guid | The Guid of GUID-based enum object. (Inherited from GuidEnum)
Top
See Also

Reference

NumberingSchemaType Class


NumberingSchemaType Methods

The NumberingSchemaType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares two Guid-based enum object based on their concrete class and GUID value. (Inherited from GuidEnum)
Public method | GetHashCode | Generates a hash code for this Guid-based enum object. (Inherited from GuidEnum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

NumberingSchemaType Class


NumberingSchemaType Operators

The NumberingSchemaType type exposes the following members.

Operators
Name | Description
Equality(NumberingSchemaType, NumberingSchemaType) | Compares two NumberingSchemaType instances.
Inequality(NumberingSchemaType, NumberingSchemaType) | Compares two NumberingSchemaType instances.
Top
See Also

Reference

NumberingSchemaType Class


NumberingSchemaType.Equality Operator

NumberingSchemaTypeEquality Operator

Compares two NumberingSchemaType instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool operator ==(
    NumberingSchemaType first,
    NumberingSchemaType second
)
Public Shared Operator = (
    first As NumberingSchemaType,
    second As NumberingSchemaType
) As Boolean
public:
static bool operator ==(
    NumberingSchemaType^ first,
    NumberingSchemaType^ second
)
static let inline (=)
        first : NumberingSchemaType *
        second : NumberingSchemaType  : bool

Parameters

first NumberingSchemaType
The first NumberingSchemaType.
second NumberingSchemaType
The second NumberingSchemaType.

Return Value

Boolean
True if the inputs are identical, false if they are different.
See Also

Reference

NumberingSchemaType Class


NumberingSchemaType.Inequality Operator

NumberingSchemaTypeInequality Operator

Compares two NumberingSchemaType instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool operator !=(
    NumberingSchemaType first,
    NumberingSchemaType second
)
Public Shared Operator <> (
    first As NumberingSchemaType,
    second As NumberingSchemaType
) As Boolean
public:
static bool operator !=(
    NumberingSchemaType^ first,
    NumberingSchemaType^ second
)
static let inline (<>)
        first : NumberingSchemaType *
        second : NumberingSchemaType  : bool

Parameters

first NumberingSchemaType
The first NumberingSchemaType.
second NumberingSchemaType
The second NumberingSchemaType.

Return Value

Boolean
True if the inputs are different, false if they are identical.
See Also

Reference

NumberingSchemaType Class


NumberingSchemaTypes Class

Provides a container of all Revit built-in NumberingSchemaType instances.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBNumberingSchemaTypes

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class NumberingSchemaTypes
Public NotInheritable Class NumberingSchemaTypes
public ref class NumberingSchemaTypes abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type NumberingSchemaTypes = class end
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


NumberingSchemaTypes.StructuralNumberingSchemas Class

NumberingSchemaTypesStructuralNumberingSchemas Class

A collection of types of built-in Numbering Schemas that are used for numbering structure elements.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBNumberingSchemaTypesStructuralNumberingSchemas

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class StructuralNumberingSchemas
Public NotInheritable Class StructuralNumberingSchemas
public ref class StructuralNumberingSchemas abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type StructuralNumberingSchemas = class end

The NumberingSchemaTypesStructuralNumberingSchemas type exposes the following members.

Properties
Name | Description
Rebar | Built-in schema used for numbering rebar elements
RebarCoupler | Built-in schema used for numbering rebar coupler elements
ReinforcementFabric | Built-in schema used for numbering fabric reinforcement elements
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


StructuralNumberingSchemas Properties

The NumberingSchemaTypesStructuralNumberingSchemas type exposes the following members.

Properties
Name | Description
Rebar | Built-in schema used for numbering rebar elements
RebarCoupler | Built-in schema used for numbering rebar coupler elements
ReinforcementFabric | Built-in schema used for numbering fabric reinforcement elements
Top
See Also

Reference

NumberingSchemaTypesStructuralNumberingSchemas Class


NumberingSchemaTypes.StructuralNumberingSchemas.Rebar Property

NumberingSchemaTypesStructuralNumberingSchemasRebar Property

Built-in schema used for numbering rebar elements

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static NumberingSchemaType Rebar { get; }
Public Shared ReadOnly Property Rebar As NumberingSchemaType
    Get
public:
static property NumberingSchemaType^ Rebar {
    NumberingSchemaType^ get ();
}
static member Rebar : NumberingSchemaType with get

Property Value

NumberingSchemaType
See Also

Reference

NumberingSchemaTypesStructuralNumberingSchemas Class


NumberingSchemaTypes.StructuralNumberingSchemas.RebarCoupler Property

NumberingSchemaTypesStructuralNumberingSchemasRebarCoupler Property

Built-in schema used for numbering rebar coupler elements

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static NumberingSchemaType RebarCoupler { get; }
Public Shared ReadOnly Property RebarCoupler As NumberingSchemaType
    Get
public:
static property NumberingSchemaType^ RebarCoupler {
    NumberingSchemaType^ get ();
}
static member RebarCoupler : NumberingSchemaType with get

Property Value

NumberingSchemaType
See Also

Reference

NumberingSchemaTypesStructuralNumberingSchemas Class


NumberingSchemaTypes.StructuralNumberingSchemas.ReinforcementFabric Property

NumberingSchemaTypesStructuralNumberingSchemasReinforcementFabric Property

Built-in schema used for numbering fabric reinforcement elements

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static NumberingSchemaType ReinforcementFabric { get; }
Public Shared ReadOnly Property ReinforcementFabric As NumberingSchemaType
    Get
public:
static property NumberingSchemaType^ ReinforcementFabric {
    NumberingSchemaType^ get ();
}
static member ReinforcementFabric : NumberingSchemaType with get

Property Value

NumberingSchemaType
See Also

Reference

NumberingSchemaTypesStructuralNumberingSchemas Class


NumberSystem Class

An annotation that consists of a series of numeric tags attached to and describing a host element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBNumberSystem

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class NumberSystem : Element
Public Class NumberSystem
    Inherits Element
public ref class NumberSystem : public Element
type NumberSystem =
    class
        inherit Element
    end

The NumberSystem type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | JustifyOffset | The offset to the justification curve.
Public property | JustifyOption | The number justify option of number system.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | NumberDisplayRule | The display rule of the number system.
Public property | NumberedElementId | The LinkElementId of the numbered host element.
Public property | NumberOrientation | The number orientation of number system.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | PlacementLevelId | The id of the base level of stairs on which the NumberSystem is placed.
Public property | ReferenceOffset | The offset to the reference curve.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create(Document, ElementId, LinkElementId, Reference) | Creates a new instance of a NumberSystem associated to a host element and a view.
 | Create(Document, ElementId, LinkElementId, StairsNumberSystemReferenceOption, LinkElementId) | Creates a new instance of a NumberSystem associated to a host element, a view, and a reference level of stairs if in a multistory stairs.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetReferencePick | Gets the reference curve.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetReferencePick | Sets the reference pick.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
For a component-based stair, you can display tread/riser numbers for a run in plan, elevation, or section view. Sketch-based stair is not supported.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


NumberSystem Properties

The NumberSystem type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | JustifyOffset | The offset to the justification curve.
Public property | JustifyOption | The number justify option of number system.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | NumberDisplayRule | The display rule of the number system.
Public property | NumberedElementId | The LinkElementId of the numbered host element.
Public property | NumberOrientation | The number orientation of number system.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | PlacementLevelId | The id of the base level of stairs on which the NumberSystem is placed.
Public property | ReferenceOffset | The offset to the reference curve.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

NumberSystem Class


NumberSystem.JustifyOffset Property

NumberSystemJustifyOffset Property

The offset to the justification curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double JustifyOffset { get; set; }
Public Property JustifyOffset As Double
    Get
    Set
public:
property double JustifyOffset {
    double get ();
    void set (double value);
}
member JustifyOffset : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The given value for justifyOffset must be no more than 30000 feet in absolute value.
See Also

Reference

NumberSystem Class


NumberSystem.JustifyOption Property

NumberSystemJustifyOption Property

The number justify option of number system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public NumberSystemJustifyOption JustifyOption { get; set; }
Public Property JustifyOption As NumberSystemJustifyOption
    Get
    Set
public:
property NumberSystemJustifyOption JustifyOption {
    NumberSystemJustifyOption get ();
    void set (NumberSystemJustifyOption value);
}
member JustifyOption : NumberSystemJustifyOption with get, set

Property Value

NumberSystemJustifyOption
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

NumberSystem Class


NumberSystem.NumberDisplayRule Property

NumberSystemNumberDisplayRule Property

The display rule of the number system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public NumberSystemDisplayRule NumberDisplayRule { get; set; }
Public Property NumberDisplayRule As NumberSystemDisplayRule
    Get
    Set
public:
property NumberSystemDisplayRule NumberDisplayRule {
    NumberSystemDisplayRule get ();
    void set (NumberSystemDisplayRule value);
}
member NumberDisplayRule : NumberSystemDisplayRule with get, set

Property Value

NumberSystemDisplayRule
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

NumberSystem Class


NumberSystem.NumberedElementId Property

NumberSystemNumberedElementId Property

The LinkElementId of the numbered host element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LinkElementId NumberedElementId { get; }
Public ReadOnly Property NumberedElementId As LinkElementId
    Get
public:
property LinkElementId^ NumberedElementId {
    LinkElementId^ get ();
}
member NumberedElementId : LinkElementId with get

Property Value

LinkElementId
See Also

Reference

NumberSystem Class


NumberSystem.NumberOrientation Property

NumberSystemNumberOrientation Property

The number orientation of number system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TagOrientation NumberOrientation { get; set; }
Public Property NumberOrientation As TagOrientation
    Get
    Set
public:
property TagOrientation NumberOrientation {
    TagOrientation get ();
    void set (TagOrientation value);
}
member NumberOrientation : TagOrientation with get, set

Property Value

TagOrientation
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: Orientation AnyModelDirection is not supported -or- When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

NumberSystem Class


NumberSystem.PlacementLevelId Property

NumberSystemPlacementLevelId Property

The id of the base level of stairs on which the NumberSystem is placed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LinkElementId PlacementLevelId { get; }
Public ReadOnly Property PlacementLevelId As LinkElementId
    Get
public:
property LinkElementId^ PlacementLevelId {
    LinkElementId^ get ();
}
member PlacementLevelId : LinkElementId with get

Property Value

LinkElementId
Remarks
In multistory stairs, a stairs element could be a stair group or individual stair, this level could be the base level of group member or stairs element.
See Also

Reference

NumberSystem Class


NumberSystem.ReferenceOffset Property

NumberSystemReferenceOffset Property

The offset to the reference curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double ReferenceOffset { get; set; }
Public Property ReferenceOffset As Double
    Get
    Set
public:
property double ReferenceOffset {
    double get ();
    void set (double value);
}
member ReferenceOffset : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The given value for referenceOffset must be no more than 30000 feet in absolute value.
See Also

Reference

NumberSystem Class


NumberSystem Methods

The NumberSystem type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create(Document, ElementId, LinkElementId, Reference) | Creates a new instance of a NumberSystem associated to a host element and a view.
 | Create(Document, ElementId, LinkElementId, StairsNumberSystemReferenceOption, LinkElementId) | Creates a new instance of a NumberSystem associated to a host element, a view, and a reference level of stairs if in a multistory stairs.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetReferencePick | Gets the reference curve.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetReferencePick | Sets the reference pick.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

NumberSystem Class


NumberSystem.Create Method

NumberSystemCreate Method

Overload List
Name | Description
Create(Document, ElementId, LinkElementId, Reference) | Creates a new instance of a NumberSystem associated to a host element and a view.
Create(Document, ElementId, LinkElementId, StairsNumberSystemReferenceOption, LinkElementId) | Creates a new instance of a NumberSystem associated to a host element, a view, and a reference level of stairs if in a multistory stairs.
Top
See Also

Reference

NumberSystem Class


NumberSystem.Create(Document, ElementId, LinkElementId, Reference) Method

NumberSystemCreate(Document, ElementId, LinkElementId, Reference) Method

Creates a new instance of a NumberSystem associated to a host element and a view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static NumberSystem Create(
    Document document,
    ElementId viewId,
    LinkElementId numberedElementId,
    Reference referenceCurve
)
Public Shared Function Create (
    document As Document,
    viewId As ElementId,
    numberedElementId As LinkElementId,
    referenceCurve As Reference
) As NumberSystem
public:
static NumberSystem^ Create(
    Document^ document,
    ElementId^ viewId,
    LinkElementId^ numberedElementId,
    Reference^ referenceCurve
)
static member Create :
        document : Document *
        viewId : ElementId *
        numberedElementId : LinkElementId *
        referenceCurve : Reference -> NumberSystem

Parameters

document Document
The document.
viewId ElementId
The view in which the NumberSystem will be created.
numberedElementId LinkElementId
The host id on which the NumberSystem will be created.
referenceCurve Reference
The reference curve along which the NumberSystem will be created. It is suggested to get the new reference via GetNumberSystemReference() from the host element.

Return Value

NumberSystem
The created NumberSystem.
Exceptions
Exception | Condition
ArgumentException | viewId is not valid for placement of a NumberSystem (only floor plan views and elevation views are permitted). -or- numberedElementId is not valid as a host for NumberSystem (only StairsRun elements are permitted in this release). -or- The referenceCurve is not valid for NumberSystem on numberedElementId. -or- The numberedElementId already has a NumberSystem.
ArgumentNullException | A non-optional argument was null
See Also

Reference

NumberSystem Class
Create Overload


NumberSystem.Create(Document, ElementId, LinkElementId, StairsNumberSystemReferenceOption, LinkElementId) Method

NumberSystemCreate(Document, ElementId, LinkElementId, StairsNumberSystemReferenceOption, LinkElementId) Method

Creates a new instance of a NumberSystem associated to a host element, a view, and a reference level of stairs if in a multistory stairs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static NumberSystem Create(
    Document document,
    ElementId viewId,
    LinkElementId hostElementId,
    StairsNumberSystemReferenceOption referenceOption,
    LinkElementId placementLevelId
)
Public Shared Function Create (
    document As Document,
    viewId As ElementId,
    hostElementId As LinkElementId,
    referenceOption As StairsNumberSystemReferenceOption,
    placementLevelId As LinkElementId
) As NumberSystem
public:
static NumberSystem^ Create(
    Document^ document,
    ElementId^ viewId,
    LinkElementId^ hostElementId,
    StairsNumberSystemReferenceOption referenceOption,
    LinkElementId^ placementLevelId
)
static member Create :
        document : Document *
        viewId : ElementId *
        hostElementId : LinkElementId *
        referenceOption : StairsNumberSystemReferenceOption *
        placementLevelId : LinkElementId -> NumberSystem

Parameters

document Document
The document.
viewId ElementId
The view in which the NumberSystem will be created.
hostElementId LinkElementId
The host id on which the NumberSystem will be created.
referenceOption StairsNumberSystemReferenceOption
The reference option of the NumberSystem.
placementLevelId LinkElementId
The id of the level on which the NumberSystem will be placed. The placement level must be one of the base levels of a stairs group members. It is suggested to get the level from MultistoryStairs.GetStairsPlacementLevels().

Return Value

NumberSystem
The created NumberSystem.
Exceptions
Exception | Condition
ArgumentException | viewId is not valid for placement of a NumberSystem (only floor plan views and elevation views are permitted). -or- hostElementId is not valid as a host for NumberSystem (only StairsRun elements are permitted in this release). -or- The reference option is not valid for a NumberSystem. -or- The placementLevelId is not one of the stairs base levels. -or- The hostElementId already has a number system.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Remarks
In multistory stairs, a stairs element could be a stair group or individual stair. This method allows to add a NumberSystem for a run of an individual stairs or a stairs group member on the placementLevelId.
See Also

Reference

NumberSystem Class
Create Overload


NumberSystem.GetReferencePick Method

NumberSystemGetReferencePick Method

Gets the reference curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Reference GetReferencePick()
Public Function GetReferencePick As Reference
public:
Reference^ GetReferencePick()
member GetReferencePick : unit -> Reference

Return Value

Reference
The pick of reference curve.
See Also

Reference

NumberSystem Class


NumberSystem.SetReferencePick Method

NumberSystemSetReferencePick Method

Sets the reference pick.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetReferencePick(
    Reference referencePick
)
Public Sub SetReferencePick (
    referencePick As Reference
)
public:
void SetReferencePick(
    Reference^ referencePick
)
member SetReferencePick :
        referencePick : Reference -> unit

Parameters

referencePick Reference
The pick to set.
Exceptions
Exception | Condition
ArgumentException | The referencePick is not a valid reference.
ArgumentNullException | A non-optional argument was null
Remarks
It is suggested to get the new reference via GetNumberSystemReference() from the host element.
See Also

Reference

NumberSystem Class


NumberSystemDisplayRule Enumeration

The available options for display of numeric values in the number system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum NumberSystemDisplayRule
Public Enumeration NumberSystemDisplayRule
public enum class NumberSystemDisplayRule
type NumberSystemDisplayRule
Members
Member name | Value | Description
All | 0 | The number system will display all the numbers.
Odd | 1 | The number system will only display the odd numbers.
Even | 2 | The number system will only display the even numbers.
StartAndEnd | 3 | The number system will only display the start and end numbers.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


NumberSystemJustifyOption Enumeration

The available options for justification of the numbers in a number system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum NumberSystemJustifyOption
Public Enumeration NumberSystemJustifyOption
public enum class NumberSystemJustifyOption
type NumberSystemJustifyOption
Members
Member name | Value | Description
Front | 0 | The number will locate in front of the annotated object along the annotating direction.
Center | 1 | The number will locate in the center of the annotated object along the annotating direction.
Back | 2 | The number will locate in back of the annotated object along the annotating direction.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


NumericRevisionSettings Class

Contains settings that apply to Revisions with the Numeric RevisionNumberType.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBNumericRevisionSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class NumericRevisionSettings : IDisposable
Public Class NumericRevisionSettings
    Implements IDisposable
public ref class NumericRevisionSettings : IDisposable
type NumericRevisionSettings =
    class
        interface IDisposable
    end

The NumericRevisionSettings type exposes the following members.

Constructors
 | Name | Description
Public method | NumericRevisionSettings | Constructs a NumericRevisionSettings with a simple, default numbering sequence.
Public method | NumericRevisionSettings(NumericRevisionSettings) | Constructs a new copy of the input NumericRevisionSettings object.
Public method | NumericRevisionSettings(Int32, String, String) | Constructs a NumericRevisionSettings object.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MinimumDigits | Controls the minimum number of digits for a revision number.
Public property | Prefix | The prefix string that will be prepended to the number of each revision with Numeric RevisionNumberingType.
Public property | StartNumber | The start number for the sequence.
Public property | Suffix | The suffix string that will be appended to the number of each revision with Numeric RevisionNumberingType.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the NumericRevisionSettings
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqual | Determines whether a specified NumericRevisionSettings is the same as 'this'.
Public method | IsValid | Determines whether the NumericRevisionSettings object is in a valid state.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


NumericRevisionSettings Constructor

Overload List
 | Name | Description
Public method | NumericRevisionSettings | Constructs a NumericRevisionSettings with a simple, default numbering sequence.
Public method | NumericRevisionSettings(NumericRevisionSettings) | Constructs a new copy of the input NumericRevisionSettings object.
Public method | NumericRevisionSettings(Int32, String, String) | Constructs a NumericRevisionSettings object.
Top
See Also

Reference

NumericRevisionSettings Class


NumericRevisionSettings Constructor

Constructs a NumericRevisionSettings with a simple, default numbering sequence.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public NumericRevisionSettings()
Public Sub New
public:
NumericRevisionSettings()
new : unit -> NumericRevisionSettings
Remarks
Initializes startNumber to 1. The prefix and suffix strings are set to empty.
See Also

Reference

NumericRevisionSettings Class
NumericRevisionSettings Overload


NumericRevisionSettings(NumericRevisionSettings) Constructor

Constructs a new copy of the input NumericRevisionSettings object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public NumericRevisionSettings(
    NumericRevisionSettings other
)
Public Sub New (
    other As NumericRevisionSettings
)
public:
NumericRevisionSettings(
    NumericRevisionSettings^ other
)
new :
        other : NumericRevisionSettings -> NumericRevisionSettings

Parameters

other NumericRevisionSettings
Exceptions
Exception | Condition
ArgumentException | other is not a valid NumericRevisionSettings.
ArgumentNullException | A non-optional argument was null
See Also

Reference

NumericRevisionSettings Class
NumericRevisionSettings Overload


NumericRevisionSettings(Int32, String, String) Constructor

Constructs a NumericRevisionSettings object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public NumericRevisionSettings(
    int startNumber,
    string prefix,
    string suffix
)
Public Sub New (
    startNumber As Integer,
    prefix As String,
    suffix As String
)
public:
NumericRevisionSettings(
    int startNumber,
    String^ prefix,
    String^ suffix
)
new :
        startNumber : int *
        prefix : string *
        suffix : string -> NumericRevisionSettings

Parameters

startNumber Int32
The start number for the sequence.
prefix String
The prefix string for each revision number in the sequence.
suffix String
The suffix string for each revision number in the sequence.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | The given value for startNumber is negative.
Remarks
The starting number parameter accepts any non-negative integer, and the prefix and suffix strings are allowed to be empty.
See Also

Reference

NumericRevisionSettings Class
NumericRevisionSettings Overload


NumericRevisionSettings Properties

The NumericRevisionSettings type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MinimumDigits | Controls the minimum number of digits for a revision number.
Public property | Prefix | The prefix string that will be prepended to the number of each revision with Numeric RevisionNumberingType.
Public property | StartNumber | The start number for the sequence.
Public property | Suffix | The suffix string that will be appended to the number of each revision with Numeric RevisionNumberingType.
Top
See Also

Reference

NumericRevisionSettings Class


NumericRevisionSettings.IsValidObject Property

NumericRevisionSettingsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

NumericRevisionSettings Class


NumericRevisionSettings.MinimumDigits Property

NumericRevisionSettingsMinimumDigits Property

Controls the minimum number of digits for a revision number.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int MinimumDigits { get; set; }
Public Property MinimumDigits As Integer
    Get
    Set
public:
property int MinimumDigits {
    int get ();
    void set (int value);
}
member MinimumDigits : int with get, set

Property Value

Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The given value for minimumDigits is not positive.
Remarks
Use MinimumDigits to force the minimum number of digits for a revision number. Zeros will be added to the front of the revision number until the minimum number of digits is satisfied. For example, if MinimumDigits is 3, then 9 will be printed as 009 and 10 will be printed as 010. If MinimumDigits is 1, then no zeros are added to the front of the revision number. The default value for MinimumDigits is 1. Values less than 1 are not allowed.
See Also

Reference

NumericRevisionSettings Class


NumericRevisionSettings.Prefix Property

NumericRevisionSettingsPrefix Property

The prefix string that will be prepended to the number of each revision with Numeric RevisionNumberingType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Prefix { get; set; }
Public Property Prefix As String
    Get
    Set
public:
property String^ Prefix {
    String^ get ();
    void set (String^ value);
}
member Prefix : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

NumericRevisionSettings Class


NumericRevisionSettings.StartNumber Property

NumericRevisionSettingsStartNumber Property

The start number for the sequence.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int StartNumber { get; set; }
Public Property StartNumber As Integer
    Get
    Set
public:
property int StartNumber {
    int get ();
    void set (int value);
}
member StartNumber : int with get, set

Property Value

Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The given value for number is negative.
See Also

Reference

NumericRevisionSettings Class


NumericRevisionSettings.Suffix Property

NumericRevisionSettingsSuffix Property

The suffix string that will be appended to the number of each revision with Numeric RevisionNumberingType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Suffix { get; set; }
Public Property Suffix As String
    Get
    Set
public:
property String^ Suffix {
    String^ get ();
    void set (String^ value);
}
member Suffix : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

NumericRevisionSettings Class


NumericRevisionSettings Methods

The NumericRevisionSettings type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqual | Determines whether a specified NumericRevisionSettings is the same as 'this'.
Public method | IsValid | Determines whether the NumericRevisionSettings object is in a valid state.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

NumericRevisionSettings Class


NumericRevisionSettings.Dispose Method

NumericRevisionSettingsDispose Method

Releases all resources used by the NumericRevisionSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

NumericRevisionSettings Class


NumericRevisionSettings.IsEqual Method

NumericRevisionSettingsIsEqual Method

Determines whether a specified NumericRevisionSettings is the same as 'this'.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEqual(
    NumericRevisionSettings other
)
Public Function IsEqual (
    other As NumericRevisionSettings
) As Boolean
public:
bool IsEqual(
    NumericRevisionSettings^ other
)
member IsEqual :
        other : NumericRevisionSettings -> bool

Parameters

other NumericRevisionSettings
The specified NumericRevisionSettings with which to compare.

Return Value

Boolean
True, if two NumericRevisionSettings are the same.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
The two NumericRevisionSettings are regarded as the same only if they have the same start number, prefix and suffix strings.
See Also

Reference

NumericRevisionSettings Class


NumericRevisionSettings.IsValid Method

NumericRevisionSettingsIsValid Method

Determines whether the NumericRevisionSettings object is in a valid state.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValid()
Public Function IsValid As Boolean
public:
bool IsValid()
member IsValid : unit -> bool

Return Value

Boolean
True if the NumericRevisionSettings is valid.
Remarks
The NumericRevisionSettings should at least contain a non-negative start number.
See Also

Reference

NumericRevisionSettings Class


NurbSpline Class

A nurb spline.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGeometryObject
Autodesk.Revit.DBCurve
Autodesk.Revit.DBNurbSpline

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class NurbSpline : Curve
Public Class NurbSpline
    Inherits Curve
public ref class NurbSpline : public Curve
type NurbSpline =
    class
        inherit Curve
    end

The NurbSpline type exposes the following members.

Properties
 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve)
Public property | CtrlPoints | Returns the control points of the nurb spline.
Public property | Degree | Returns the degree of the nurb spline.
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve)
Public property | IsClosed | Describes whether the curve is closed. (Inherited from Curve)
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject)
Public property | isRational | Returns whether the nurb spline is rational or not.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Knots | Return/set the knots of the nurb spline.
Public property | Length | The exact length of the curve. (Inherited from Curve)
Public property | Period | The period of this curve. (Inherited from Curve)
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve)
Public property | Visibility | The visibility. (Inherited from GeometryObject)
Public property | Weights | Returns the weights of the nurb spline.
Top
Methods
 | Name | Description
Public method | Clone | Returns a copy of this curve. (Inherited from Curve)
Public method | ComputeClosestPoints | Find the closest points between two curves. Closest points mean closest pairs of points, each pair consisting of a point on this, say P1, and a point on other curve, say P2. P1 and P2 are closest locally. Each pairs of closest points will be represented by the corresponding parameter values with respect to the two curves and the 3d points. A closest pair is also known as a pair of critical points of the distance function between points of the two curves. If the input parameter returnAllCriticalPoints is set to false, then the function will return only pairs with minimum distance. (Inherited from Curve)
Public method | ComputeDerivatives | Returns the vectors describing the curve at the specified parameter. (Inherited from Curve)
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve)
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve)
 | Create | Creates a new geometric NurbSpline object from a HermiteSpline.
 | CreateCurve(HermiteSpline) | Creates a new geometric Curve object by converting the given HermiteSpline. The created curve may be a NURBSpline or a simpler curve such as line or arc.
 | CreateCurve(IListXYZ, IListDouble) | Creates a new geometric Curve object from NURBS curve data containing just control points and weights. The created curve may be a NURBSpline or a simpler curve such as line or arc.
 | CreateCurve(Int32, IListDouble, IListXYZ) | Creates a new geometric Curve object from NURBS curve data, which does not include weights. The created curve may be a NURBSpline or a simpler curve such as line or arc.
 | CreateCurve(Int32, IListDouble, IListXYZ, IListDouble) | Creates a new geometric Curve object from NURBS curve data, which includes weights. The created curve may be a NURBSpline or a simpler curve such as line or arc.
Public method | CreateOffset | Creates a new curve that is an offset of the existing curve. (Inherited from Curve)
Public method | CreateReversed | Creates a new curve with the opposite orientation of the existing curve. (Inherited from Curve)
Public method | CreateTransformed | Crates a new instance of a curve as a transformation of this curve. (Inherited from Curve)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject)
Public method | Evaluate | Evaluates and returns the point that matches a parameter along the curve. (Inherited from Curve)
Public method | GetEndParameter | Returns the raw parameter value at the start or end of this curve. (Inherited from Curve)
Public method | GetEndPoint | Returns the 3D point at the start or end of this curve. (Inherited from Curve)
Public method | GetEndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve)
Public method | Intersect(Curve, IntersectionResultArray) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve)
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve)
Public method | IsInside(Double, Int32) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve)
Public method | MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve)
Public method | MakeUnbound | Makes this curve unbound. (Inherited from Curve)
Public method | Project | Projects the specified point on this curve. (Inherited from Curve)
Public method | SetControlPointsAndWeights | Set the control points, weights simultaneously.
Public method | SetGraphicsStyleId | Sets the graphics style id for this curve. (Inherited from Curve)
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The nurb spline lies in the plane defined by control point, weight,knots,degree.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


NurbSpline Properties

The NurbSpline type exposes the following members.

Properties
 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve)
Public property | CtrlPoints | Returns the control points of the nurb spline.
Public property | Degree | Returns the degree of the nurb spline.
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve)
Public property | IsClosed | Describes whether the curve is closed. (Inherited from Curve)
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject)
Public property | isRational | Returns whether the nurb spline is rational or not.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Knots | Return/set the knots of the nurb spline.
Public property | Length | The exact length of the curve. (Inherited from Curve)
Public property | Period | The period of this curve. (Inherited from Curve)
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve)
Public property | Visibility | The visibility. (Inherited from GeometryObject)
Public property | Weights | Returns the weights of the nurb spline.
Top
See Also

Reference

NurbSpline Class


NurbSpline.CtrlPoints Property

NurbSplineCtrlPoints Property

Returns the control points of the nurb spline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<XYZ> CtrlPoints { get; }
Public ReadOnly Property CtrlPoints As IList(Of XYZ)
    Get
public:
property IList<XYZ^>^ CtrlPoints {
    IList<XYZ^>^ get ();
}
member CtrlPoints : IList<XYZ> with get

Property Value

IList XYZ
See Also

Reference

NurbSpline Class


NurbSpline.Degree Property

NurbSplineDegree Property

Returns the degree of the nurb spline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Degree { get; }
Public ReadOnly Property Degree As Integer
    Get
public:
property int Degree {
    int get ();
}
member Degree : int with get

Property Value

Int32
See Also

Reference

NurbSpline Class


NurbSpline.isRational Property

NurbSplineisRational Property

Returns whether the nurb spline is rational or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool isRational { get; }
Public ReadOnly Property isRational As Boolean
    Get
public:
property bool isRational {
    bool get ();
}
member isRational : bool with get

Property Value

Boolean
See Also

Reference

NurbSpline Class


NurbSpline.Knots Property

NurbSplineKnots Property

Return/set the knots of the nurb spline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DoubleArray Knots { get; set; }
Public Property Knots As DoubleArray
    Get
    Set
public:
property DoubleArray^ Knots {
    DoubleArray^ get ();
    void set (DoubleArray^ value);
}
member Knots : DoubleArray with get, set

Property Value

DoubleArray
See Also

Reference

NurbSpline Class


NurbSpline.Weights Property

NurbSplineWeights Property

Returns the weights of the nurb spline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DoubleArray Weights { get; }
Public ReadOnly Property Weights As DoubleArray
    Get
public:
property DoubleArray^ Weights {
    DoubleArray^ get ();
}
member Weights : DoubleArray with get

Property Value

DoubleArray
See Also

Reference

NurbSpline Class


NurbSpline Methods

The NurbSpline type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Returns a copy of this curve. (Inherited from Curve)
Public method | ComputeClosestPoints | Find the closest points between two curves. Closest points mean closest pairs of points, each pair consisting of a point on this, say P1, and a point on other curve, say P2. P1 and P2 are closest locally. Each pairs of closest points will be represented by the corresponding parameter values with respect to the two curves and the 3d points. A closest pair is also known as a pair of critical points of the distance function between points of the two curves. If the input parameter returnAllCriticalPoints is set to false, then the function will return only pairs with minimum distance. (Inherited from Curve)
Public method | ComputeDerivatives | Returns the vectors describing the curve at the specified parameter. (Inherited from Curve)
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve)
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve)
 | Create | Creates a new geometric NurbSpline object from a HermiteSpline.
 | CreateCurve(HermiteSpline) | Creates a new geometric Curve object by converting the given HermiteSpline. The created curve may be a NURBSpline or a simpler curve such as line or arc.
 | CreateCurve(IListXYZ, IListDouble) | Creates a new geometric Curve object from NURBS curve data containing just control points and weights. The created curve may be a NURBSpline or a simpler curve such as line or arc.
 | CreateCurve(Int32, IListDouble, IListXYZ) | Creates a new geometric Curve object from NURBS curve data, which does not include weights. The created curve may be a NURBSpline or a simpler curve such as line or arc.
 | CreateCurve(Int32, IListDouble, IListXYZ, IListDouble) | Creates a new geometric Curve object from NURBS curve data, which includes weights. The created curve may be a NURBSpline or a simpler curve such as line or arc.
Public method | CreateOffset | Creates a new curve that is an offset of the existing curve. (Inherited from Curve)
Public method | CreateReversed | Creates a new curve with the opposite orientation of the existing curve. (Inherited from Curve)
Public method | CreateTransformed | Crates a new instance of a curve as a transformation of this curve. (Inherited from Curve)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject)
Public method | Evaluate | Evaluates and returns the point that matches a parameter along the curve. (Inherited from Curve)
Public method | GetEndParameter | Returns the raw parameter value at the start or end of this curve. (Inherited from Curve)
Public method | GetEndPoint | Returns the 3D point at the start or end of this curve. (Inherited from Curve)
Public method | GetEndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve)
Public method | Intersect(Curve, IntersectionResultArray) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve)
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve)
Public method | IsInside(Double, Int32) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve)
Public method | MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve)
Public method | MakeUnbound | Makes this curve unbound. (Inherited from Curve)
Public method | Project | Projects the specified point on this curve. (Inherited from Curve)
Public method | SetControlPointsAndWeights | Set the control points, weights simultaneously.
Public method | SetGraphicsStyleId | Sets the graphics style id for this curve. (Inherited from Curve)
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

NurbSpline Class


NurbSpline.Create Method

NurbSplineCreate Method

Creates a new geometric NurbSpline object from a HermiteSpline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static NurbSpline Create(
    HermiteSpline hermiteSpline
)
Public Shared Function Create (
    hermiteSpline As HermiteSpline
) As NurbSpline
public:
static NurbSpline^ Create(
    HermiteSpline^ hermiteSpline
)
static member Create :
        hermiteSpline : HermiteSpline -> NurbSpline

Parameters

hermiteSpline HermiteSpline
The hermite spline that will be converted to NurbSpline.

Return Value

NurbSpline
The new NurbSpline object.
See Also

Reference

NurbSpline Class


NurbSpline.CreateCurve Method

NurbSplineCreateCurve Method

Overload List
Name | Description
CreateCurve(HermiteSpline) | Creates a new geometric Curve object by converting the given HermiteSpline. The created curve may be a NURBSpline or a simpler curve such as line or arc.
CreateCurve(IListXYZ, IListDouble) | Creates a new geometric Curve object from NURBS curve data containing just control points and weights. The created curve may be a NURBSpline or a simpler curve such as line or arc.
CreateCurve(Int32, IListDouble, IListXYZ) | Creates a new geometric Curve object from NURBS curve data, which does not include weights. The created curve may be a NURBSpline or a simpler curve such as line or arc.
CreateCurve(Int32, IListDouble, IListXYZ, IListDouble) | Creates a new geometric Curve object from NURBS curve data, which includes weights. The created curve may be a NURBSpline or a simpler curve such as line or arc.
Top
See Also

Reference

NurbSpline Class


NurbSpline.CreateCurve(HermiteSpline) Method

NurbSplineCreateCurve(HermiteSpline) Method

Creates a new geometric Curve object by converting the given HermiteSpline. The created curve may be a NURBSpline or a simpler curve such as line or arc.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Curve CreateCurve(
    HermiteSpline hermiteSpline
)
Public Shared Function CreateCurve (
    hermiteSpline As HermiteSpline
) As Curve
public:
static Curve^ CreateCurve(
    HermiteSpline^ hermiteSpline
)
static member CreateCurve :
        hermiteSpline : HermiteSpline -> Curve

Parameters

hermiteSpline HermiteSpline
The HermiteSpline that will be converted.

Return Value

Curve
The new Curve object.
Exceptions
Exception | Condition
ArgumentException | The given hermite spline has to be non-periodic. -or- Curve length is too small for Revit's tolerance (as identified by Application.ShortCurveTolerance).
ArgumentNullException | A non-optional argument was NULL
Remarks
The function does not support periodic Hermite curve.
See Also

Reference

NurbSpline Class
CreateCurve Overload


NurbSpline.CreateCurve(IList<XYZ>, IList<Double>) Method

NurbSplineCreateCurve(IListXYZ, IListDouble) Method

Creates a new geometric Curve object from NURBS curve data containing just control points and weights. The created curve may be a NURBSpline or a simpler curve such as line or arc.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Curve CreateCurve(
    IList<XYZ> controlPoints,
    IList<double> weights
)
Public Shared Function CreateCurve (
    controlPoints As IList(Of XYZ),
    weights As IList(Of Double)
) As Curve
public:
static Curve^ CreateCurve(
    IList<XYZ^>^ controlPoints,
    IList<double>^ weights
)
static member CreateCurve :
        controlPoints : IList<XYZ> *
        weights : IList<float> -> Curve

Parameters

controlPoints IList XYZ
The control points of the NURBSpline.
weights IList Double
The weights of the NURBSpline.

Return Value

Curve
The new Curve object.
Exceptions
Exception | Condition
ArgumentException | The number of control points must be at least 2. -or- The number of weights must be the same as the number of control points and all weights must be positive.
ArgumentNullException | A non-optional argument was NULL
ArgumentsInconsistentException | Curve length is too small for Revit's tolerance (as identified by Application.ShortCurveTolerance).
Remarks
There must be at least 2 control points. The number of weights must be equal to the the number of control points. The values of all weights must be positive.
See Also

Reference

NurbSpline Class
CreateCurve Overload


NurbSpline.CreateCurve(Int32, IList<Double>, IList<XYZ>) Method

NurbSplineCreateCurve(Int32, IListDouble, IListXYZ) Method

Creates a new geometric Curve object from NURBS curve data, which does not include weights. The created curve may be a NURBSpline or a simpler curve such as line or arc.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Curve CreateCurve(
    int degree,
    IList<double> knots,
    IList<XYZ> controlPoints
)
Public Shared Function CreateCurve (
    degree As Integer,
    knots As IList(Of Double),
    controlPoints As IList(Of XYZ)
) As Curve
public:
static Curve^ CreateCurve(
    int degree,
    IList<double>^ knots,
    IList<XYZ^>^ controlPoints
)
static member CreateCurve :
        degree : int *
        knots : IList<float> *
        controlPoints : IList<XYZ> -> Curve

Parameters

degree Int32
The degree of the NURBSpline.
knots IList Double
The knots of the NURBSpline.
controlPoints IList XYZ
The control points of the NURBSpline.

Return Value

Curve
The new Curve object.
Exceptions
Exception | Condition
ArgumentException | The degree must be at least 1. -or- The number of control points must be greater than degree. -or- The number of knots must equal the sum of number of control points, degree and 1. -or- An interior knot must not repeat itself more than degree times.
ArgumentNullException | A non-optional argument was NULL
ArgumentsInconsistentException | Curve length is too small for Revit's tolerance (as identified by Application.ShortCurveTolerance).
Remarks
Degree must be 1 or greater. The number of control points must be greater than degree. The number of knots must equal the sum of degree, number of controlPoints and 1. The distinct knot values (ignoring multiplicities) must be in increasing order. The first degree+1 knots should be identical, as should the last degree+1 knots. The multiplicities of other (interior) knots should be less than degree -1.
See Also

Reference

NurbSpline Class
CreateCurve Overload


NurbSpline.CreateCurve(Int32, IList<Double>, IList<XYZ>, IList<Double>) Method

NurbSplineCreateCurve(Int32, IListDouble, IListXYZ, IListDouble) Method

Creates a new geometric Curve object from NURBS curve data, which includes weights. The created curve may be a NURBSpline or a simpler curve such as line or arc.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Curve CreateCurve(
    int degree,
    IList<double> knots,
    IList<XYZ> controlPoints,
    IList<double> weights
)
Public Shared Function CreateCurve (
    degree As Integer,
    knots As IList(Of Double),
    controlPoints As IList(Of XYZ),
    weights As IList(Of Double)
) As Curve
public:
static Curve^ CreateCurve(
    int degree,
    IList<double>^ knots,
    IList<XYZ^>^ controlPoints,
    IList<double>^ weights
)
static member CreateCurve :
        degree : int *
        knots : IList<float> *
        controlPoints : IList<XYZ> *
        weights : IList<float> -> Curve

Parameters

degree Int32
The degree of the NURBSpline.
knots IList Double
The knots of the NURBSpline.
controlPoints IList XYZ
The control points of the NURBSpline.
weights IList Double
The weights of the NURBSpline.

Return Value

Curve
The new Curve object.
Exceptions
Exception | Condition
ArgumentException | The degree must be at least 1. -or- The number of control points must be greater than degree. -or- The number of knots must equal the sum of number of control points, degree and 1. -or- An interior knot must not repeat itself more than degree times. -or- The number of weights must be the same as the number of control points and all weights must be positive.
ArgumentNullException | A non-optional argument was NULL
ArgumentsInconsistentException | Curve length is too small for Revit's tolerance (as identified by Application.ShortCurveTolerance).
Remarks
Degree must be 1 or greater. The number of control points must be greater than degree. The number of knots must equal the sum of degree, number of controlPoints and 1. The distinct knot values (ignoring multiplicities) must be in increasing order. The first degree+1 knots should be identical, as should the last degree+1 knots. The multiplicities of other (interior) knots should be less than degree -1. The number of weights must be equal to the the number of control points. The values of all weights must be positive.
See Also

Reference

NurbSpline Class
CreateCurve Overload


NurbSpline.SetControlPointsAndWeights Method

NurbSplineSetControlPointsAndWeights Method

Set the control points, weights simultaneously.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetControlPointsAndWeights(
    IList<XYZ> ctrlPoints,
    DoubleArray weights
)
Public Sub SetControlPointsAndWeights (
    ctrlPoints As IList(Of XYZ),
    weights As DoubleArray
)
public:
void SetControlPointsAndWeights(
    IList<XYZ^>^ ctrlPoints,
    DoubleArray^ weights
)
member SetControlPointsAndWeights :
        ctrlPoints : IList<XYZ> *
        weights : DoubleArray -> unit

Parameters

ctrlPoints IList XYZ
weights DoubleArray
See Also

Reference

NurbSpline Class


NurbsSurfaceData Class

A class used to represent the definition of a NURBS surface.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBNurbsSurfaceData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class NurbsSurfaceData : IDisposable
Public Class NurbsSurfaceData
    Implements IDisposable
public ref class NurbsSurfaceData : IDisposable
type NurbsSurfaceData =
    class
        interface IDisposable
    end

The NurbsSurfaceData type exposes the following members.

Constructors
 | Name | Description
Public method | NurbsSurfaceData | Copy constructor.
Top
Properties
 | Name | Description
Public property | DegreeU | The degree of the spline in the u-direction.
Public property | DegreeV | The degree of the spline in the v-direction.
Public property | IsRational | Tells if the spline is rational or not. If it is true (rational), then the NURBS is a piecewise rational polynomial function. If it is false (non-rational), then the NURBS is a piecewise polynomial function.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ReverseOrientation | If true, the surface's orientation is opposite to the canonical parametric orientation, otherwise it is the same. The canonical parametric orientation is a counter-clockwise sense of rotation in the uv-parameter plane. Extrinsically, the oriented normal vector for the canonical parametric orientation points in the direction of the cross product dS/du x dS/dv, which S(u, v) is the parameterized surface.
Top
Methods
 | Name | Description
 | Create | Construct NurbsSurfaceData based on NURBS surface data, where the weights are supplied. The NURBS surface will be (piecewise) polynomial if all the weights are equal, rational if not. Note: A rational polynomial is a quotient of two polynomials; this includes a polynomial, which can be thought of as a quotient with denominator equal to 1.
Public method | Dispose | Releases all resources used by the NurbsSurfaceData
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetControlPoints | Get the list of control points.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetKnotsU | Get the list of knots in the u-direction.
Public method | GetKnotsV | Get the list of knots in the v-direction.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetWeights | Get the list of weights.
Public method | IsValid | Check if the object contains a valid NurbsSurfaceData.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


NurbsSurfaceData Constructor

Copy constructor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public NurbsSurfaceData(
    NurbsSurfaceData other
)
Public Sub New (
    other As NurbsSurfaceData
)
public:
NurbsSurfaceData(
    NurbsSurfaceData^ other
)
new :
        other : NurbsSurfaceData -> NurbsSurfaceData

Parameters

other NurbsSurfaceData
The NurbsSurfaceData to copy.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

NurbsSurfaceData Class


NurbsSurfaceData Properties

The NurbsSurfaceData type exposes the following members.

Properties
 | Name | Description
Public property | DegreeU | The degree of the spline in the u-direction.
Public property | DegreeV | The degree of the spline in the v-direction.
Public property | IsRational | Tells if the spline is rational or not. If it is true (rational), then the NURBS is a piecewise rational polynomial function. If it is false (non-rational), then the NURBS is a piecewise polynomial function.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ReverseOrientation | If true, the surface's orientation is opposite to the canonical parametric orientation, otherwise it is the same. The canonical parametric orientation is a counter-clockwise sense of rotation in the uv-parameter plane. Extrinsically, the oriented normal vector for the canonical parametric orientation points in the direction of the cross product dS/du x dS/dv, which S(u, v) is the parameterized surface.
Top
See Also

Reference

NurbsSurfaceData Class


NurbsSurfaceData.DegreeU Property

NurbsSurfaceDataDegreeU Property

The degree of the spline in the u-direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int DegreeU { get; }
Public ReadOnly Property DegreeU As Integer
    Get
public:
property int DegreeU {
    int get ();
}
member DegreeU : int with get

Property Value

Int32
See Also

Reference

NurbsSurfaceData Class


NurbsSurfaceData.DegreeV Property

NurbsSurfaceDataDegreeV Property

The degree of the spline in the v-direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int DegreeV { get; }
Public ReadOnly Property DegreeV As Integer
    Get
public:
property int DegreeV {
    int get ();
}
member DegreeV : int with get

Property Value

Int32
See Also

Reference

NurbsSurfaceData Class


NurbsSurfaceData.IsRational Property

NurbsSurfaceDataIsRational Property

Tells if the spline is rational or not. If it is true (rational), then the NURBS is a piecewise rational polynomial function. If it is false (non-rational), then the NURBS is a piecewise polynomial function.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsRational { get; }
Public ReadOnly Property IsRational As Boolean
    Get
public:
property bool IsRational {
    bool get ();
}
member IsRational : bool with get

Property Value

Boolean
See Also

Reference

NurbsSurfaceData Class


NurbsSurfaceData.IsValidObject Property

NurbsSurfaceDataIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

NurbsSurfaceData Class


NurbsSurfaceData.ReverseOrientation Property

NurbsSurfaceDataReverseOrientation Property

If true, the surface's orientation is opposite to the canonical parametric orientation, otherwise it is the same. The canonical parametric orientation is a counter-clockwise sense of rotation in the uv-parameter plane. Extrinsically, the oriented normal vector for the canonical parametric orientation points in the direction of the cross product dS/du x dS/dv, which S(u, v) is the parameterized surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ReverseOrientation { get; }
Public ReadOnly Property ReverseOrientation As Boolean
    Get
public:
property bool ReverseOrientation {
    bool get ();
}
member ReverseOrientation : bool with get

Property Value

Boolean
See Also

Reference

NurbsSurfaceData Class


NurbsSurfaceData Methods

The NurbsSurfaceData type exposes the following members.

Methods
 | Name | Description
 | Create | Construct NurbsSurfaceData based on NURBS surface data, where the weights are supplied. The NURBS surface will be (piecewise) polynomial if all the weights are equal, rational if not. Note: A rational polynomial is a quotient of two polynomials; this includes a polynomial, which can be thought of as a quotient with denominator equal to 1.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetControlPoints | Get the list of control points.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetKnotsU | Get the list of knots in the u-direction.
Public method | GetKnotsV | Get the list of knots in the v-direction.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetWeights | Get the list of weights.
Public method | IsValid | Check if the object contains a valid NurbsSurfaceData.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

NurbsSurfaceData Class


NurbsSurfaceData.Create Method

NurbsSurfaceDataCreate Method

Construct NurbsSurfaceData based on NURBS surface data, where the weights are supplied. The NURBS surface will be (piecewise) polynomial if all the weights are equal, rational if not. Note: A rational polynomial is a quotient of two polynomials; this includes a polynomial, which can be thought of as a quotient with denominator equal to 1.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static NurbsSurfaceData Create(
    int degreeU,
    int degreeV,
    IList<double> knotsU,
    IList<double> knotsV,
    IList<XYZ> controlPoints,
    IList<double> weights,
    bool bReverseOrientation
)
Public Shared Function Create (
    degreeU As Integer,
    degreeV As Integer,
    knotsU As IList(Of Double),
    knotsV As IList(Of Double),
    controlPoints As IList(Of XYZ),
    weights As IList(Of Double),
    bReverseOrientation As Boolean
) As NurbsSurfaceData
public:
static NurbsSurfaceData^ Create(
    int degreeU,
    int degreeV,
    IList<double>^ knotsU,
    IList<double>^ knotsV,
    IList<XYZ^>^ controlPoints,
    IList<double>^ weights,
    bool bReverseOrientation
)
static member Create :
        degreeU : int *
        degreeV : int *
        knotsU : IList<float> *
        knotsV : IList<float> *
        controlPoints : IList<XYZ> *
        weights : IList<float> *
        bReverseOrientation : bool -> NurbsSurfaceData

Parameters

degreeU Int32
The degree of the spline in the u-direction; must be positive.
degreeV Int32
The degree of the spline in the v-direction; must be positive.
knotsU IList Double
Knot values in the u-direction. The number of knots in the u-direction must be at least 2 * (degreeU + 1).
knotsV IList Double
Knot values in the v-direction. The number of knots in the v-direction must be at least 2 * (degreeV + 1).
controlPoints IList XYZ
One dimensional array of points representing the two dimensional net of control points of the NURBS surface in u and v directions.

The total number of control points must equal numControlPtsU times numControlPtsV, where numControlPtsU and numControlPtsV are the numbers of control points in u and v directions, and they must satisfy the following conditions:

  • numControlPtsU = number of knots in u - degreeU - 1.
  • numControlPtsV = number of knots in v - degreeV - 1.
The convention for 2d (idxU, idxV) to 1d (idx) conversion of array indexes: idxV first. That is, idxU is outer loop and idxV is inner loop. In other words, idx = idxU * numControlPtsV + idxV.

weights IList Double
Array of weights assigned to the control points. The number of weights must equal the number of control points. All weights should be greater than zero.
bReverseOrientation Boolean
If true, the surface's orientation is opposite to the canonical parametric orientation, otherwise it is the same. The canonical parametric orientation is a counter-clockwise sense of rotation in the uv-parameter plane. Extrinsically, the oriented normal vector for the canonical parametric orientation points in the direction of the cross product dS/du x dS/dv, which S(u, v) is the parameterized surface.

Return Value

NurbsSurfaceData
Exceptions
Exception | Condition
ArgumentException | The U-degree value must be at least 1. -or- The V-degree value must be at least 1. -or- The number of knots in the U direction must be at least 2 times the U-degree plus 1. -or- The number of knots in the V direction must be at least 2 times the V-degree plus 1. -or- The number of control points must equal (number of U-knots - U-degree - 1) * (number of V-knots - V-degree - 1). -or- The number of weights must be the same as the number of control points and all weights must be positive or all zero.
ArgumentNullException | A non-optional argument was null
See Also

Reference

NurbsSurfaceData Class


NurbsSurfaceData.Dispose Method

NurbsSurfaceDataDispose Method

Releases all resources used by the NurbsSurfaceData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

NurbsSurfaceData Class


NurbsSurfaceData.GetControlPoints Method

NurbsSurfaceDataGetControlPoints Method

Get the list of control points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<XYZ> GetControlPoints()
Public Function GetControlPoints As IList(Of XYZ)
public:
IList<XYZ^>^ GetControlPoints()
member GetControlPoints : unit -> IList<XYZ>

Return Value

IList XYZ
See Also

Reference

NurbsSurfaceData Class


NurbsSurfaceData.GetKnotsU Method

NurbsSurfaceDataGetKnotsU Method

Get the list of knots in the u-direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<double> GetKnotsU()
Public Function GetKnotsU As IList(Of Double)
public:
IList<double>^ GetKnotsU()
member GetKnotsU : unit -> IList<float>

Return Value

IList Double
See Also

Reference

NurbsSurfaceData Class


NurbsSurfaceData.GetKnotsV Method

NurbsSurfaceDataGetKnotsV Method

Get the list of knots in the v-direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<double> GetKnotsV()
Public Function GetKnotsV As IList(Of Double)
public:
IList<double>^ GetKnotsV()
member GetKnotsV : unit -> IList<float>

Return Value

IList Double
See Also

Reference

NurbsSurfaceData Class


NurbsSurfaceData.GetWeights Method

NurbsSurfaceDataGetWeights Method

Get the list of weights.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<double> GetWeights()
Public Function GetWeights As IList(Of Double)
public:
IList<double>^ GetWeights()
member GetWeights : unit -> IList<float>

Return Value

IList Double
See Also

Reference

NurbsSurfaceData Class


NurbsSurfaceData.IsValid Method

NurbsSurfaceDataIsValid Method

Check if the object contains a valid NurbsSurfaceData.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValid()
Public Function IsValid As Boolean
public:
bool IsValid()
member IsValid : unit -> bool

Return Value

Boolean
True if it is a valid NurbsSurfaceData, false otherwise.
See Also

Reference

NurbsSurfaceData Class


OBJExportOptions Class

The export options used by exporting to OBJ file format.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBIMExportOptions
Autodesk.Revit.DBOBJExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class OBJExportOptions : BIMExportOptions
Public Class OBJExportOptions
    Inherits BIMExportOptions
public ref class OBJExportOptions : public BIMExportOptions
type OBJExportOptions =
    class
        inherit BIMExportOptions
    end

The OBJExportOptions type exposes the following members.

Constructors
 | Name | Description
Public method | OBJExportOptions | Constructs a new instance of OBJExportOptions with default values of all properties.
Public method | OBJExportOptions(ExportResolution) | Constructs a new instance of OBJExportOptions with all predefined tessellation settings, depending on export resolution type. Note: in case of Custom resolution type, tessellation settings won't be predefined and will have default values.
Top
Properties
 | Name | Description
Public property | GridAspectRatio | The maximum aspect ratio allowed in the grid placed across the face. The minimum allowed value is 1.0. The maximum allowed value is 10.0. By default this property is ignored.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BIMExportOptions)
Public property | MaxEdgeLength | The maximum length allowed for any chord on an edge or between any two adjacent grid lines. This is a percentage value. By exporting, the real value of maximum edge length is calculated as a percent from the length of the diameter of the body bounding box. The minimum allowed value is 0.1%. The maximum allowed value is 10.0%. By default this property is ignored.
Public property | NormalTolerance | The maximum change in the surface normal between adjacent nodes in the mesh. This property is defined in degrees. The minimum allowed value is 1.0 degrees. The maximum allowed value is 45.0 degrees. Default value is 15.0 degrees.
Public property | SurfaceTolerance | The maximum distance between mesh triangles and model geometry. This is a percentage value. By exporting, the real value of surface tolerance is calculated as a percent from the length of the diameter of the body bounding box. The minimum allowed value is 0.001%. The maximum allowed value is 1.0%. Default value is 0.1%.
Public property | TargetUnit | The unit type of geometry in the resultant OBJ file. Default value is ExportUnit::Default.
Public property | ViewId | The element id of the 3D view to export. InvalidElementId by default. (Inherited from BIMExportOptions)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from BIMExportOptions)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsGridAspectRatioSet | Checks whether the GridAspectRatio tessellation parameter is explicitly set.
Public method | IsMaxEdgeLengthSet | Checks whether the MaxEdgeLength tessellation parameter is explicitly set.
Public method | IsNormalToleranceSet | Checks whether the NormalTolerance tessellation parameter is explicitly set.
Public method | IsSurfaceToleranceSet | Checks whether the SurfaceTolerance tessellation parameter is explicitly set.
 | IsValidForGridAspectRatio | Checks whether the value is allowed (is in the allowed range) for GridAspectRatio tessellation parameter.
 | IsValidForMaxEdgeLength | Checks whether the value is allowed (is in the allowed range) for MaxEdgeLength tessellation parameter.
 | IsValidForNormalTolerance | Checks whether the value is allowed (is in the allowed range) for NormalTolerance tessellation parameter.
 | IsValidForSurfaceTolerance | Checks whether the value is allowed (is in the allowed range) for SurfaceTolerance tessellation parameter.
Public method | SetTessellationSettings | Sets all the tessellation parameters to its predefined values for the given resolution type.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


OBJExportOptions Constructor

Overload List
 | Name | Description
Public method | OBJExportOptions | Constructs a new instance of OBJExportOptions with default values of all properties.
Public method | OBJExportOptions(ExportResolution) | Constructs a new instance of OBJExportOptions with all predefined tessellation settings, depending on export resolution type. Note: in case of Custom resolution type, tessellation settings won't be predefined and will have default values.
Top
See Also

Reference

OBJExportOptions Class


OBJExportOptions Constructor

Constructs a new instance of OBJExportOptions with default values of all properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OBJExportOptions()
Public Sub New
public:
OBJExportOptions()
new : unit -> OBJExportOptions
See Also

Reference

OBJExportOptions Class
OBJExportOptions Overload


OBJExportOptions(ExportResolution) Constructor

Constructs a new instance of OBJExportOptions with all predefined tessellation settings, depending on export resolution type. Note: in case of Custom resolution type, tessellation settings won't be predefined and will have default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OBJExportOptions(
    ExportResolution resolutionType
)
Public Sub New (
    resolutionType As ExportResolution
)
public:
OBJExportOptions(
    ExportResolution resolutionType
)
new :
        resolutionType : ExportResolution -> OBJExportOptions

Parameters

resolutionType ExportResolution
The type of export resolution.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

OBJExportOptions Class
OBJExportOptions Overload


OBJExportOptions Properties

The OBJExportOptions type exposes the following members.

Properties
 | Name | Description
Public property | GridAspectRatio | The maximum aspect ratio allowed in the grid placed across the face. The minimum allowed value is 1.0. The maximum allowed value is 10.0. By default this property is ignored.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BIMExportOptions)
Public property | MaxEdgeLength | The maximum length allowed for any chord on an edge or between any two adjacent grid lines. This is a percentage value. By exporting, the real value of maximum edge length is calculated as a percent from the length of the diameter of the body bounding box. The minimum allowed value is 0.1%. The maximum allowed value is 10.0%. By default this property is ignored.
Public property | NormalTolerance | The maximum change in the surface normal between adjacent nodes in the mesh. This property is defined in degrees. The minimum allowed value is 1.0 degrees. The maximum allowed value is 45.0 degrees. Default value is 15.0 degrees.
Public property | SurfaceTolerance | The maximum distance between mesh triangles and model geometry. This is a percentage value. By exporting, the real value of surface tolerance is calculated as a percent from the length of the diameter of the body bounding box. The minimum allowed value is 0.001%. The maximum allowed value is 1.0%. Default value is 0.1%.
Public property | TargetUnit | The unit type of geometry in the resultant OBJ file. Default value is ExportUnit::Default.
Public property | ViewId | The element id of the 3D view to export. InvalidElementId by default. (Inherited from BIMExportOptions)
Top
See Also

Reference

OBJExportOptions Class


OBJExportOptions.GridAspectRatio Property

OBJExportOptionsGridAspectRatio Property

The maximum aspect ratio allowed in the grid placed across the face. The minimum allowed value is 1.0. The maximum allowed value is 10.0. By default this property is ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GridAspectRatio { get; set; }
Public Property GridAspectRatio As Double
    Get
    Set
public:
property double GridAspectRatio {
    double get ();
    void set (double value);
}
member GridAspectRatio : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The value gridAspectRatio is outside the allowable range of values for GridAspectRatio tessellation parameter.
InvalidOperationException | GridAspectRatio tessellation parameter is default (hasn't been explicitly set by the user) and cannot be obtained now.
Remarks
This property can be set by using export resolution type (by creation of OBJExportOptions or using [!:Autodesk::Revit::DB::OBJExportOptions::setTessellationSettings(ExportResolution::Enum)] method). In the case of Fine, Medium and Coarse resolutions, this property has the same value (10.0) and it is considered as explicitly set by the user. In the case of Custom resolution type, this property is only allowed to be obtained if it has been explicitly set.
See Also

Reference

OBJExportOptions Class


OBJExportOptions.MaxEdgeLength Property

OBJExportOptionsMaxEdgeLength Property

The maximum length allowed for any chord on an edge or between any two adjacent grid lines. This is a percentage value. By exporting, the real value of maximum edge length is calculated as a percent from the length of the diameter of the body bounding box. The minimum allowed value is 0.1%. The maximum allowed value is 10.0%. By default this property is ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double MaxEdgeLength { get; set; }
Public Property MaxEdgeLength As Double
    Get
    Set
public:
property double MaxEdgeLength {
    double get ();
    void set (double value);
}
member MaxEdgeLength : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The value maxEdgeLength is outside the allowable range of values for MaxEdgeLength tessellation parameter.
InvalidOperationException | MaxEdgeLength tessellation parameter is default (hasn't been explicitly set by the user) and cannot be obtained now.
Remarks
This property can be set by using export resolution type (by creation of OBJExportOptions or using [!:Autodesk::Revit::DB::OBJExportOptions::setTessellationSettings(ExportResolution::Enum)] method). In the case of Fine, Medium and Coarse resolutions, this property has the same value (10.0%) and it is considered as explicitly set by the user. In the case of Custom resolution type, this property is only allowed to be obtained if it has been explicitly set.
See Also

Reference

OBJExportOptions Class


OBJExportOptions.NormalTolerance Property

OBJExportOptionsNormalTolerance Property

The maximum change in the surface normal between adjacent nodes in the mesh. This property is defined in degrees. The minimum allowed value is 1.0 degrees. The maximum allowed value is 45.0 degrees. Default value is 15.0 degrees.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double NormalTolerance { get; set; }
Public Property NormalTolerance As Double
    Get
    Set
public:
property double NormalTolerance {
    double get ();
    void set (double value);
}
member NormalTolerance : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The value normalTolerance is outside the allowable range of values for NormalTolerance tessellation parameter.
InvalidOperationException | NormalTolerance tessellation parameter is default (hasn't been explicitly set by the user) and cannot be obtained now.
Remarks
This property can be set by using export resolution type (by creation of OBJExportOptions or using [!:Autodesk::Revit::DB::OBJExportOptions::setTessellationSettings(ExportResolution::Enum)] method). In the case of Fine (10.0 degrees), Medium (15.0 degrees) and Coarse (30.0 degrees) resolutions, this property is considered as explicitly set by the user. In the case of Custom resolution type, this property is only allowed to be obtained if it has been explicitly set.
See Also

Reference

OBJExportOptions Class


OBJExportOptions.SurfaceTolerance Property

OBJExportOptionsSurfaceTolerance Property

The maximum distance between mesh triangles and model geometry. This is a percentage value. By exporting, the real value of surface tolerance is calculated as a percent from the length of the diameter of the body bounding box. The minimum allowed value is 0.001%. The maximum allowed value is 1.0%. Default value is 0.1%.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double SurfaceTolerance { get; set; }
Public Property SurfaceTolerance As Double
    Get
    Set
public:
property double SurfaceTolerance {
    double get ();
    void set (double value);
}
member SurfaceTolerance : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The value surfaceTolerance is outside the allowable range of values for SurfaceTolerance tessellation parameter.
InvalidOperationException | SurfaceTolerance tessellation parameter is default (hasn't been explicitly set by the user) and cannot be obtained now.
Remarks
This property can be set by using export resolution type (by creation of OBJExportOptions or using [!:Autodesk::Revit::DB::OBJExportOptions::setTessellationSettings(ExportResolution::Enum)] method). In the case of Fine (0.005%), Medium (0.016%) and Coarse (0.04%) resolutions, this property is considered as explicitly set by the user. In the case of Custom resolution type, this property is only allowed to be obtained if it has been explicitly set.
See Also

Reference

OBJExportOptions Class


OBJExportOptions.TargetUnit Property

OBJExportOptionsTargetUnit Property

The unit type of geometry in the resultant OBJ file. Default value is ExportUnit::Default.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportUnit TargetUnit { get; set; }
Public Property TargetUnit As ExportUnit
    Get
    Set
public:
property ExportUnit TargetUnit {
    ExportUnit get ();
    void set (ExportUnit value);
}
member TargetUnit : ExportUnit with get, set

Property Value

ExportUnit
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

OBJExportOptions Class


OBJExportOptions Methods

The OBJExportOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from BIMExportOptions)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsGridAspectRatioSet | Checks whether the GridAspectRatio tessellation parameter is explicitly set.
Public method | IsMaxEdgeLengthSet | Checks whether the MaxEdgeLength tessellation parameter is explicitly set.
Public method | IsNormalToleranceSet | Checks whether the NormalTolerance tessellation parameter is explicitly set.
Public method | IsSurfaceToleranceSet | Checks whether the SurfaceTolerance tessellation parameter is explicitly set.
 | IsValidForGridAspectRatio | Checks whether the value is allowed (is in the allowed range) for GridAspectRatio tessellation parameter.
 | IsValidForMaxEdgeLength | Checks whether the value is allowed (is in the allowed range) for MaxEdgeLength tessellation parameter.
 | IsValidForNormalTolerance | Checks whether the value is allowed (is in the allowed range) for NormalTolerance tessellation parameter.
 | IsValidForSurfaceTolerance | Checks whether the value is allowed (is in the allowed range) for SurfaceTolerance tessellation parameter.
Public method | SetTessellationSettings | Sets all the tessellation parameters to its predefined values for the given resolution type.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

OBJExportOptions Class


OBJExportOptions.IsGridAspectRatioSet Method

OBJExportOptionsIsGridAspectRatioSet Method

Checks whether the GridAspectRatio tessellation parameter is explicitly set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsGridAspectRatioSet()
Public Function IsGridAspectRatioSet As Boolean
public:
bool IsGridAspectRatioSet()
member IsGridAspectRatioSet : unit -> bool

Return Value

Boolean
True if GridAspectRatio tessellation parameter is explicitly set, false otherwise.
See Also

Reference

OBJExportOptions Class


OBJExportOptions.IsMaxEdgeLengthSet Method

OBJExportOptionsIsMaxEdgeLengthSet Method

Checks whether the MaxEdgeLength tessellation parameter is explicitly set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsMaxEdgeLengthSet()
Public Function IsMaxEdgeLengthSet As Boolean
public:
bool IsMaxEdgeLengthSet()
member IsMaxEdgeLengthSet : unit -> bool

Return Value

Boolean
True if MaxEdgeLength tessellation parameter is explicitly set, false otherwise.
See Also

Reference

OBJExportOptions Class


OBJExportOptions.IsNormalToleranceSet Method

OBJExportOptionsIsNormalToleranceSet Method

Checks whether the NormalTolerance tessellation parameter is explicitly set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsNormalToleranceSet()
Public Function IsNormalToleranceSet As Boolean
public:
bool IsNormalToleranceSet()
member IsNormalToleranceSet : unit -> bool

Return Value

Boolean
True if NormalTolerance tessellation parameter is explicitly set, false otherwise.
See Also

Reference

OBJExportOptions Class


OBJExportOptions.IsSurfaceToleranceSet Method

OBJExportOptionsIsSurfaceToleranceSet Method

Checks whether the SurfaceTolerance tessellation parameter is explicitly set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSurfaceToleranceSet()
Public Function IsSurfaceToleranceSet As Boolean
public:
bool IsSurfaceToleranceSet()
member IsSurfaceToleranceSet : unit -> bool

Return Value

Boolean
True if SurfaceTolerance tessellation parameter is explicitly set, false otherwise.
See Also

Reference

OBJExportOptions Class


OBJExportOptions.IsValidForGridAspectRatio Method

OBJExportOptionsIsValidForGridAspectRatio Method

Checks whether the value is allowed (is in the allowed range) for GridAspectRatio tessellation parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidForGridAspectRatio(
    double value
)
Public Shared Function IsValidForGridAspectRatio (
    value As Double
) As Boolean
public:
static bool IsValidForGridAspectRatio(
    double value
)
static member IsValidForGridAspectRatio :
        value : float -> bool

Parameters

value Double
The value to be checked.

Return Value

Boolean
True if the value is valid for GridAspectRatio, false otherwise.
See Also

Reference

OBJExportOptions Class


OBJExportOptions.IsValidForMaxEdgeLength Method

OBJExportOptionsIsValidForMaxEdgeLength Method

Checks whether the value is allowed (is in the allowed range) for MaxEdgeLength tessellation parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidForMaxEdgeLength(
    double value
)
Public Shared Function IsValidForMaxEdgeLength (
    value As Double
) As Boolean
public:
static bool IsValidForMaxEdgeLength(
    double value
)
static member IsValidForMaxEdgeLength :
        value : float -> bool

Parameters

value Double
The value to be checked.

Return Value

Boolean
True if the value is valid for MaxEdgeLength, false otherwise.
See Also

Reference

OBJExportOptions Class


OBJExportOptions.IsValidForNormalTolerance Method

OBJExportOptionsIsValidForNormalTolerance Method

Checks whether the value is allowed (is in the allowed range) for NormalTolerance tessellation parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidForNormalTolerance(
    double value
)
Public Shared Function IsValidForNormalTolerance (
    value As Double
) As Boolean
public:
static bool IsValidForNormalTolerance(
    double value
)
static member IsValidForNormalTolerance :
        value : float -> bool

Parameters

value Double
The value to be checked.

Return Value

Boolean
True if the value is valid for NormalTolerance, false otherwise.
See Also

Reference

OBJExportOptions Class


OBJExportOptions.IsValidForSurfaceTolerance Method

OBJExportOptionsIsValidForSurfaceTolerance Method

Checks whether the value is allowed (is in the allowed range) for SurfaceTolerance tessellation parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidForSurfaceTolerance(
    double value
)
Public Shared Function IsValidForSurfaceTolerance (
    value As Double
) As Boolean
public:
static bool IsValidForSurfaceTolerance(
    double value
)
static member IsValidForSurfaceTolerance :
        value : float -> bool

Parameters

value Double
The value to be checked.

Return Value

Boolean
True if the value is valid for SurfaceTolerance, false otherwise.
See Also

Reference

OBJExportOptions Class


OBJExportOptions.SetTessellationSettings Method

OBJExportOptionsSetTessellationSettings Method

Sets all the tessellation parameters to its predefined values for the given resolution type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetTessellationSettings(
    ExportResolution resolutionType
)
Public Sub SetTessellationSettings (
    resolutionType As ExportResolution
)
public:
void SetTessellationSettings(
    ExportResolution resolutionType
)
member SetTessellationSettings :
        resolutionType : ExportResolution -> unit

Parameters

resolutionType ExportResolution
Type of exporting resolution.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

OBJExportOptions Class


OBJImportOptions Class

The import options used to import OBJ format files.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBaseImportOptions
Autodesk.Revit.DBOBJImportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class OBJImportOptions : BaseImportOptions
Public Class OBJImportOptions
    Inherits BaseImportOptions
public ref class OBJImportOptions : public BaseImportOptions
type OBJImportOptions =
    class
        inherit BaseImportOptions
    end

The OBJImportOptions type exposes the following members.

Constructors
 | Name | Description
Public method | OBJImportOptions | Constructs a new instance of OBJImportOptions with default values of all properties.
Public method | OBJImportOptions(OBJImportOptions) | Constructs a new instance of OBJImportOptions as a copy of the import options.
Top
Properties
 | Name | Description
Public property | AutoCorrectAlmostVHLines | Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines. (Inherited from BaseImportOptions)
Public property | ColorMode | Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors. (Inherited from BaseImportOptions)
Public property | CustomScale | Scaling the import. If this is defined and a valid value (> 0.0), it takes priority over units. (Inherited from BaseImportOptions)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BaseImportOptions)
Public property | OrientToView | Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false) (Inherited from BaseImportOptions)
Public property | Placement | Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates. (Inherited from BaseImportOptions)
Public property | ReferencePoint | The 3D point in the document where the imported instance will be inserted. If not explicitly set, the instance will be inserted at the document origin. (Inherited from BaseImportOptions)
Public property | ThisViewOnly | Imports drawings into the view that was passed into the import method. This option is not available in 3D views. (Inherited from BaseImportOptions)
Public property | Unit | The unit of measure for imported geometry. (Inherited from BaseImportOptions)
Public property | VisibleLayersOnly | Only import the visible layers. (Inherited from BaseImportOptions)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from BaseImportOptions)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetDefaultLengthUnit | Get the default length unit used for importing unitless files. (Inherited from BaseImportOptions)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLayerSelection | Get all set layers name which user want to import into Revit. (Inherited from BaseImportOptions)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetDefaultLengthUnit | Set the default length unit used for importing unitless files. (Inherited from BaseImportOptions)
Public method | SetLayerSelection | Set the layers name which user want to import into Revit. (Inherited from BaseImportOptions)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


OBJImportOptions Constructor

Overload List
 | Name | Description
Public method | OBJImportOptions | Constructs a new instance of OBJImportOptions with default values of all properties.
Public method | OBJImportOptions(OBJImportOptions) | Constructs a new instance of OBJImportOptions as a copy of the import options.
Top
See Also

Reference

OBJImportOptions Class


OBJImportOptions Constructor

Constructs a new instance of OBJImportOptions with default values of all properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OBJImportOptions()
Public Sub New
public:
OBJImportOptions()
new : unit -> OBJImportOptions
See Also

Reference

OBJImportOptions Class
OBJImportOptions Overload


OBJImportOptions(OBJImportOptions) Constructor

Constructs a new instance of OBJImportOptions as a copy of the import options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OBJImportOptions(
    OBJImportOptions option
)
Public Sub New (
    option As OBJImportOptions
)
public:
OBJImportOptions(
    OBJImportOptions^ option
)
new :
        option : OBJImportOptions -> OBJImportOptions

Parameters

option OBJImportOptions
The OBJ options to be copied.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

OBJImportOptions Class
OBJImportOptions Overload


OBJImportOptions Properties

The OBJImportOptions type exposes the following members.

Properties
 | Name | Description
Public property | AutoCorrectAlmostVHLines | Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines. (Inherited from BaseImportOptions)
Public property | ColorMode | Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors. (Inherited from BaseImportOptions)
Public property | CustomScale | Scaling the import. If this is defined and a valid value (> 0.0), it takes priority over units. (Inherited from BaseImportOptions)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BaseImportOptions)
Public property | OrientToView | Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false) (Inherited from BaseImportOptions)
Public property | Placement | Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates. (Inherited from BaseImportOptions)
Public property | ReferencePoint | The 3D point in the document where the imported instance will be inserted. If not explicitly set, the instance will be inserted at the document origin. (Inherited from BaseImportOptions)
Public property | ThisViewOnly | Imports drawings into the view that was passed into the import method. This option is not available in 3D views. (Inherited from BaseImportOptions)
Public property | Unit | The unit of measure for imported geometry. (Inherited from BaseImportOptions)
Public property | VisibleLayersOnly | Only import the visible layers. (Inherited from BaseImportOptions)
Top
See Also

Reference

OBJImportOptions Class


OBJImportOptions Methods

The OBJImportOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from BaseImportOptions)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetDefaultLengthUnit | Get the default length unit used for importing unitless files. (Inherited from BaseImportOptions)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLayerSelection | Get all set layers name which user want to import into Revit. (Inherited from BaseImportOptions)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetDefaultLengthUnit | Set the default length unit used for importing unitless files. (Inherited from BaseImportOptions)
Public method | SetLayerSelection | Set the layers name which user want to import into Revit. (Inherited from BaseImportOptions)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

OBJImportOptions Class


OffsetSurface Class

A mathematical representation of an offset surface.

Definition of offset surface, quoted from the STEP manual ISO 10303-42:2000(E): This is a procedural definition of a simple offset surface at a normal distance from the originating surface. Distance may be positive, negative, or zero to indicate the preferred side of the surface. The offset surface takes its parametrization directly from that of its basis surface, corresponding points having identical parameter values. The offset surface is parametrized as O(u, v) = S(u, v) + d*N(u, v), where N(u, v) is the oriented unit normal vector of the basis surface S at parameter value (u, v), and d is the signed offset distance.

In Revit, we restrict the types of basis surfaces for which an OffsetSurf can be created for the following reasons:

  • The offsets of Plane, CylindricalSurface, ConicalSurface and RevolvedSurface are of the same type as the original surface and they have closed form solutions. So those surfaces are not taken as basis surfaces of the OffsetSurface class. That leaves HermiteSurface and RuledSurface.
  • As a Revit surface, we require the OffsetSurface to be C2 continuous. That implies that the basis surface should be C3 continuous. That is because the OffsetSurface evaluation involves the normal of the basis surface and the order of continuity of the normal is one less than that of the surface.
  • HermiteSurfaces in general are not C3 continuous, even though some of them can be. A RuledSurface will be C3 continuous if its parametric curves are C3 continuous. So we don't allow a HermiteSurface to be a basis surface and allow only RuledSurfaces whose parametric curves are C3 continuous as basis surfaces of the OffsetSurface class.

The OffsetSurface class will own a copy of the basis surface and use it for many of its methods, which may implicitly assume that the OffsetSurface and the basis surface have the same envelope. So we keep the envelopes of the OffsetSurf and its basis surface in sync.

Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSurface
Autodesk.Revit.DBOffsetSurface

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class OffsetSurface : Surface
Public Class OffsetSurface
    Inherits Surface
public ref class OffsetSurface : public Surface
type OffsetSurface =
    class
        inherit Surface
    end

The OffsetSurface type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Surface)
Public property | OrientationMatchesParametricOrientation | Indicates whether this Surface's orientation is the same as or opposite to its parametric orientation. (Inherited from Surface)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from Surface)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBasisSurface | Returns a copy of basis surface of this OffsetSurface.
Public method | GetBoundingBoxUV | Gets the UV bounding box of the surface. (Inherited from Surface)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetOffsetDistance | Returns offset distance of this OffsetSurface.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsOrientationSameAsBasisSurface | Indicates whether the orientation of the OffsetSurface is same as that of its basis surface, in the sense that their oriented normals at any (u, v) have the same direction.
Public method | Project | Project a 3D point orthogonally onto a surface (to find the nearest point). Throws InvalidOperationException if the projection fails. (Inherited from Surface)
Public method | ProjectWithGuessPoint | Project a 3D point orthogonally onto a surface (to find the nearest point). This method is meant to be used when a good approximate solution for the projection is available. Throws InvalidOperationException if the projection fails. (Inherited from Surface)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


OffsetSurface Properties

The OffsetSurface type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Surface)
Public property | OrientationMatchesParametricOrientation | Indicates whether this Surface's orientation is the same as or opposite to its parametric orientation. (Inherited from Surface)
Top
See Also

Reference

OffsetSurface Class


OffsetSurface Methods

The OffsetSurface type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from Surface)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBasisSurface | Returns a copy of basis surface of this OffsetSurface.
Public method | GetBoundingBoxUV | Gets the UV bounding box of the surface. (Inherited from Surface)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetOffsetDistance | Returns offset distance of this OffsetSurface.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsOrientationSameAsBasisSurface | Indicates whether the orientation of the OffsetSurface is same as that of its basis surface, in the sense that their oriented normals at any (u, v) have the same direction.
Public method | Project | Project a 3D point orthogonally onto a surface (to find the nearest point). Throws InvalidOperationException if the projection fails. (Inherited from Surface)
Public method | ProjectWithGuessPoint | Project a 3D point orthogonally onto a surface (to find the nearest point). This method is meant to be used when a good approximate solution for the projection is available. Throws InvalidOperationException if the projection fails. (Inherited from Surface)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

OffsetSurface Class


OffsetSurface.GetBasisSurface Method

OffsetSurfaceGetBasisSurface Method

Returns a copy of basis surface of this OffsetSurface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Surface GetBasisSurface()
Public Function GetBasisSurface As Surface
public:
Surface^ GetBasisSurface()
member GetBasisSurface : unit -> Surface

Return Value

Surface
Basis surface of this OffsetSurface.
See Also

Reference

OffsetSurface Class


OffsetSurface.GetOffsetDistance Method

OffsetSurfaceGetOffsetDistance Method

Returns offset distance of this OffsetSurface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetOffsetDistance()
Public Function GetOffsetDistance As Double
public:
double GetOffsetDistance()
member GetOffsetDistance : unit -> float

Return Value

Double
Offset distance of this OffsetSurface.
See Also

Reference

OffsetSurface Class


OffsetSurface.IsOrientationSameAsBasisSurface Method

OffsetSurfaceIsOrientationSameAsBasisSurface Method

Indicates whether the orientation of the OffsetSurface is same as that of its basis surface, in the sense that their oriented normals at any (u, v) have the same direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsOrientationSameAsBasisSurface()
Public Function IsOrientationSameAsBasisSurface As Boolean
public:
bool IsOrientationSameAsBasisSurface()
member IsOrientationSameAsBasisSurface : unit -> bool

Return Value

Boolean
True if the orientation of the OffsetSurface is same as that of its basis surface, false otherwise.
See Also

Reference

OffsetSurface Class


OpenConflictResult Enumeration

The result of the open conflict.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum OpenConflictResult
Public Enumeration OpenConflictResult
public enum class OpenConflictResult
type OpenConflictResult
Members
Member name | Value | Description
KeepLocalChanges | 0 | Keeps the local changes and open the model.
DiscardLocalChangesAndOpenLatestVersion | 1 | Discard the local changes and open the latest version of the model.
Cancel | 2 | Cancel the open action.
DetachFromCentral | 3 | Detach the model from its central model, with worksets preserved.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


OpenConflictScenario Enumeration

The kinds of conflicts happened during open.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum OpenConflictScenario
Public Enumeration OpenConflictScenario
public enum class OpenConflictScenario
type OpenConflictScenario
Members
Member name | Value | Description
Rollback | 0 | Central model is restored to an earlier version.
Relinquished | 1 | Ownership to model elements is relinquished.
OutOfDate | 2 | Model is out of date.
VersionArchived | 3 | Last central version merged into the local model has been archived in the central model.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


OpenForeignOption Enumeration

Options for opening files saved by an application that was not developed or licensed by Autodesk.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum OpenForeignOption
Public Enumeration OpenForeignOption
public enum class OpenForeignOption
type OpenForeignOption
Members
Member name | Value | Description
Open | 0 | Do not show any prompt to the user if a foreign file is detected. Proceed to open.
DoNotOpen | 1 | Do not show any prompt to the user if a foreign file is detected. Cancel this operation (do not open the file).
Prompt | 2 | If possible, show a prompt to the user if a foreign file is detected. The operation may proceed or cancel based on the response.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Opening Class

An opening in an Autodesk Revit project or family document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBOpening

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Opening : Element
Public Class Opening
    Inherits Element
public ref class Opening : public Element
type Opening =
    class
        inherit Element
    end

The Opening type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | BoundaryCurves | The geometry information for non-rectangular openings in project documents, or for all openings in family documents.
Public property | BoundaryRect | Retrieves the geometry information if the opening boundary is a rect.
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | Host | Retrieves the host element of this opening.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsRectBoundary | Retrieves the information whether the opening has a rectangular boundary.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsTransparentIn3D | Indicates if the opening is transparent in 3D view when loaded into the project.
Public property | IsTransparentInElevation | Indicates if the opening is transparent in elevation view when loaded into the project.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SketchId | Returns id of the Sketch or invalidElementId if element deon't own the Sketch.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The object represents a variety of different types of openings:
  • A rectangular opening in a wall created by two boundary points in a revit project.
  • An opening created by a set of curves applied to a roof, floor, ceiling, beam, brace or column.
  • A vertical shaft opening extending one or more levels.
  • A simple opening created on a wall or ceiling in a family document.
Depending upon the type of opening, some of the properties of this class will not be available. This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. This object also supports access to a structural analytical model but this feature is only available with Autodesk Revit Structure.
Example
C#
VB
C++
F#
Copy
private void Getinfo_Opening(Opening opening)
{
    string message = "Opening:";

    //get the host element of this opening
    message += "\nThe id of the opening's host element is : " + opening.Host.Id.ToString();

    //get the information whether the opening has a rect boundary
    //If the opening has a rect boundary, we can get the geometry information from BoundaryRect property.
    //Otherwise we should get the geometry information from BoundaryCurves property
    if (opening.IsRectBoundary)
    {
        message += "\nThe opening has a rectangular boundary.";
        //array contains two XYZ objects: the max and min coords of boundary
        IList<XYZ> boundaryRect = opening.BoundaryRect;

        //get the coordinate value of the min coordinate point
        XYZ point = opening.BoundaryRect[0];
        message += "\nMin coordinate point:(" + point.X + ", "
                                + point.Y + ", " + point.Z + ")";

        //get the coordinate value of the Max coordinate point
        point = opening.BoundaryRect[1];
        message += "\nMax coordinate point: (" + point.X + ", "
                                + point.Y + ", " + point.Z + ")";
    }
    else
    {
        message += "\nThe opening doesn't have a rectangular boundary.";
        // Get curve number
        int curves = opening.BoundaryCurves.Size;
        message += "\nNumber of curves is : " + curves;
        for (int i = 0; i < curves; i++)
        {
            Autodesk.Revit.DB.Curve curve = opening.BoundaryCurves.get_Item(i);
            // Get curve start point
            message += "\nCurve start point: " + XYZToString(curve.GetEndPoint(0));
            // Get curve end point
            message += "; Curve end point: " + XYZToString(curve.GetEndPoint(1));
        }
    }
    TaskDialog.Show("Revit",message);
}

// output the point's three coordinates
string XYZToString(XYZ point)
{
    return "(" + point.X + ", " + point.Y + ", " + point.Z + ")";
}
Private Sub Getinfo_Opening(opening As Opening)
    Dim message As String = "Opening:"

    'get the host element of this opening
    message += vbLf & "The id of the opening's host element is : " & opening.Host.Id.ToString()

    'get the information whether the opening has a rect boundary
    'If the opening has a rect boundary, we can get the geometry information from BoundaryRect property.
    'Otherwise we should get the geometry information from BoundaryCurves property
    If opening.IsRectBoundary Then
        message += vbLf & "The opening has a rectangular boundary."
        'array contains two XYZ objects: the max and min coords of boundary
        Dim boundaryRect As IList(Of XYZ) = opening.BoundaryRect

        'get the coordinate value of the min coordinate point
        Dim point As XYZ = opening.BoundaryRect(0)
        message += ((vbLf & "Min coordinate point:(" + point.X & ", ") + point.Y & ", ") + point.Z & ")"

        'get the coordinate value of the Max coordinate point
        point = opening.BoundaryRect(1)
        message += ((vbLf & "Max coordinate point: (" + point.X & ", ") + point.Y & ", ") + point.Z & ")"
    Else
        message += vbLf & "The opening doesn't have a rectangular boundary."
        ' Get curve number
        Dim curves As Integer = opening.BoundaryCurves.Size
        message += vbLf & "Number of curves is : " & curves
        For i As Integer = 0 To curves - 1
            Dim curve As Autodesk.Revit.DB.Curve = opening.BoundaryCurves.Item(i)
            ' Get curve start point
            message += vbLf & "Curve start point: " & XYZToString(curve.GetEndPoint(0))
            ' Get curve end point
            message += "; Curve end point: " & XYZToString(curve.GetEndPoint(1))
        Next
    End If
    TaskDialog.Show("Revit", message)
End Sub

' output the point's three coordinates
Private Function XYZToString(point As XYZ) As String
    Return "(" & Convert.ToString(point.X) & ", " & Convert.ToString(point.Y) & ", " & Convert.ToString(point.Z) & ")"
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Opening Properties

The Opening type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | BoundaryCurves | The geometry information for non-rectangular openings in project documents, or for all openings in family documents.
Public property | BoundaryRect | Retrieves the geometry information if the opening boundary is a rect.
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | Host | Retrieves the host element of this opening.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsRectBoundary | Retrieves the information whether the opening has a rectangular boundary.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsTransparentIn3D | Indicates if the opening is transparent in 3D view when loaded into the project.
Public property | IsTransparentInElevation | Indicates if the opening is transparent in elevation view when loaded into the project.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SketchId | Returns id of the Sketch or invalidElementId if element deon't own the Sketch.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

Opening Class


Opening.BoundaryCurves Property

OpeningBoundaryCurves Property

The geometry information for non-rectangular openings in project documents, or for all openings in family documents.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurveArray BoundaryCurves { get; }
Public ReadOnly Property BoundaryCurves As CurveArray
    Get
public:
property CurveArray^ BoundaryCurves {
    CurveArray^ get ();
}
member BoundaryCurves : CurveArray with get

Property Value

CurveArray
Remarks
If IsRectBoundary is true, this value is .
See Also

Reference

Opening Class


Opening.BoundaryRect Property

OpeningBoundaryRect Property

Retrieves the geometry information if the opening boundary is a rect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<XYZ> BoundaryRect { get; }
Public ReadOnly Property BoundaryRect As IList(Of XYZ)
    Get
public:
property IList<XYZ^>^ BoundaryRect {
    IList<XYZ^>^ get ();
}
member BoundaryRect : IList<XYZ> with get

Property Value

IList XYZ
Remarks
If IsRectBoundary is false, this value is .
See Also

Reference

Opening Class


Opening.Host Property

OpeningHost Property

Retrieves the host element of this opening.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Element Host { get; }
Public ReadOnly Property Host As Element
    Get
public:
property Element^ Host {
    Element^ get ();
}
member Host : Element with get

Property Value

Element
See Also

Reference

Opening Class


Opening.IsRectBoundary Property

OpeningIsRectBoundary Property

Retrieves the information whether the opening has a rectangular boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsRectBoundary { get; }
Public ReadOnly Property IsRectBoundary As Boolean
    Get
public:
property bool IsRectBoundary {
    bool get ();
}
member IsRectBoundary : bool with get

Property Value

Boolean
Remarks
If the opening has a rectangular boundary, we can get the geometry information from BoundaryRect property. Otherwise we should get the geometry information from BoundaryCurves property.
See Also

Reference

Opening Class


Opening.IsTransparentIn3D Property

OpeningIsTransparentIn3D Property

Indicates if the opening is transparent in 3D view when loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsTransparentIn3D { get; set; }
Public Property IsTransparentIn3D As Boolean
    Get
    Set
public:
property bool IsTransparentIn3D {
    bool get ();
    void set (bool value);
}
member IsTransparentIn3D : bool with get, set

Property Value

Boolean
Exceptions
Exception | Condition
InvalidOperationException | Thrown when access this property in an opening belonging to a Revit project document.
Remarks
This property is only valid in Revit family documents.
See Also

Reference

Opening Class


Opening.IsTransparentInElevation Property

OpeningIsTransparentInElevation Property

Indicates if the opening is transparent in elevation view when loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsTransparentInElevation { get; set; }
Public Property IsTransparentInElevation As Boolean
    Get
    Set
public:
property bool IsTransparentInElevation {
    bool get ();
    void set (bool value);
}
member IsTransparentInElevation : bool with get, set

Property Value

Boolean
Exceptions
Exception | Condition
InvalidOperationException | Thrown when access this property in an opening belonging to a Revit project document.
Remarks
This property is only valid in Revit family documents.
See Also

Reference

Opening Class


Opening.SketchId Property

OpeningSketchId Property

Returns id of the Sketch or invalidElementId if element deon't own the Sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId SketchId { get; }
Public ReadOnly Property SketchId As ElementId
    Get
public:
property ElementId^ SketchId {
    ElementId^ get ();
}
member SketchId : ElementId with get

Property Value

ElementId
See Also

Reference

Opening Class


Opening Methods

The Opening type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Opening Class


OpeningWrappingCondition Enumeration

Used by CompoundStructure to describe which shell layers participate in wrapping at openings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum OpeningWrappingCondition
Public Enumeration OpeningWrappingCondition
public enum class OpeningWrappingCondition
type OpeningWrappingCondition
Members
Member name | Value | Description
None | 0 | None of the shell layers participate in wrapping at openings.
Exterior | 1 | Only the exterior shell layers participate in wrapping at openings.
Interior | 2 | Only the interior shell layers participate in wrapping at openings.
ExteriorAndInterior | 3 | Both interior and exterior shell layers participate in wrapping at openings.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


OpenOptions Class

This class contains options available for opening a document from disk.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBOpenOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class OpenOptions : IDisposable
Public Class OpenOptions
    Implements IDisposable
public ref class OpenOptions : IDisposable
type OpenOptions =
    class
        interface IDisposable
    end

The OpenOptions type exposes the following members.

Constructors
 | Name | Description
Public method | OpenOptions | Constructs a new instance of the options class using default values.
Top
Properties
 | Name | Description
Public property | AllowOpeningLocalByWrongUser | Specifies whether a local file is allowed to be opened as read-only by a user other than its owner.
Public property | Audit | Specifies whether to expand all elements in order to check for corruption.
Public property | DetachFromCentralOption | An option that specifies whether or not a workset-enabled document is detached from its central document.
Public property | IgnoreExtensibleStorageSchemaConflict | Specifies whether to ignore the error of schema conflict.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OpenForeignOption | An option that specifies how to open files saved by an application that was not developed or licensed by Autodesk.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the OpenOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetOpenWorksetsConfiguration | Gets the object used to configure the worksets to open when the model is opened.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | SetOpenWorksetsConfiguration | Sets the object used to configure the worksets to open when the model is opened.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


OpenOptions Constructor

Constructs a new instance of the options class using default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OpenOptions()
Public Sub New
public:
OpenOptions()
new : unit -> OpenOptions
See Also

Reference

OpenOptions Class


OpenOptions Properties

The OpenOptions type exposes the following members.

Properties
 | Name | Description
Public property | AllowOpeningLocalByWrongUser | Specifies whether a local file is allowed to be opened as read-only by a user other than its owner.
Public property | Audit | Specifies whether to expand all elements in order to check for corruption.
Public property | DetachFromCentralOption | An option that specifies whether or not a workset-enabled document is detached from its central document.
Public property | IgnoreExtensibleStorageSchemaConflict | Specifies whether to ignore the error of schema conflict.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OpenForeignOption | An option that specifies how to open files saved by an application that was not developed or licensed by Autodesk.
Top
See Also

Reference

OpenOptions Class


OpenOptions.AllowOpeningLocalByWrongUser Property

OpenOptionsAllowOpeningLocalByWrongUser Property

Specifies whether a local file is allowed to be opened as read-only by a user other than its owner.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AllowOpeningLocalByWrongUser { get; set; }
Public Property AllowOpeningLocalByWrongUser As Boolean
    Get
    Set
public:
property bool AllowOpeningLocalByWrongUser {
    bool get ();
    void set (bool value);
}
member AllowOpeningLocalByWrongUser : bool with get, set

Property Value

Boolean
Remarks
The default is false. This option is ignored for central and non-workshared models.
See Also

Reference

OpenOptions Class


OpenOptions.Audit Property

OpenOptionsAudit Property

Specifies whether to expand all elements in order to check for corruption.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Audit { get; set; }
Public Property Audit As Boolean
    Get
    Set
public:
property bool Audit {
    bool get ();
    void set (bool value);
}
member Audit : bool with get, set

Property Value

Boolean
Remarks
The default is false. Setting this to true will increase the time and memory required to open the file.
See Also

Reference

OpenOptions Class


OpenOptions.DetachFromCentralOption Property

OpenOptionsDetachFromCentralOption Property

An option that specifies whether or not a workset-enabled document is detached from its central document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DetachFromCentralOption DetachFromCentralOption { get; set; }
Public Property DetachFromCentralOption As DetachFromCentralOption
    Get
    Set
public:
property DetachFromCentralOption DetachFromCentralOption {
    DetachFromCentralOption get ();
    void set (DetachFromCentralOption value);
}
member DetachFromCentralOption : DetachFromCentralOption with get, set

Property Value

DetachFromCentralOption
The default value is DetachFromCentralOption.DoNotDetach.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

OpenOptions Class


OpenOptions.IgnoreExtensibleStorageSchemaConflict Property

OpenOptionsIgnoreExtensibleStorageSchemaConflict Property

Specifies whether to ignore the error of schema conflict.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IgnoreExtensibleStorageSchemaConflict { get; set; }
Public Property IgnoreExtensibleStorageSchemaConflict As Boolean
    Get
    Set
public:
property bool IgnoreExtensibleStorageSchemaConflict {
    bool get ();
    void set (bool value);
}
member IgnoreExtensibleStorageSchemaConflict : bool with get, set

Property Value

Boolean
Remarks
The default is false. Setting this to true will ignore the exception of schema conflict while opening the model. Data in the existing schema with the same ID will be erased from the model.
See Also

Reference

OpenOptions Class


OpenOptions.IsValidObject Property

OpenOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

OpenOptions Class


OpenOptions.OpenForeignOption Property

OpenOptionsOpenForeignOption Property

An option that specifies how to open files saved by an application that was not developed or licensed by Autodesk.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OpenForeignOption OpenForeignOption { get; set; }
Public Property OpenForeignOption As OpenForeignOption
    Get
    Set
public:
property OpenForeignOption OpenForeignOption {
    OpenForeignOption get ();
    void set (OpenForeignOption value);
}
member OpenForeignOption : OpenForeignOption with get, set

Property Value

OpenForeignOption
The default value is OpenForeignOption.Open.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

OpenOptions Class


OpenOptions Methods

The OpenOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetOpenWorksetsConfiguration | Gets the object used to configure the worksets to open when the model is opened.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | SetOpenWorksetsConfiguration | Sets the object used to configure the worksets to open when the model is opened.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

OpenOptions Class


OpenOptions.Dispose Method

OpenOptionsDispose Method

Releases all resources used by the OpenOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

OpenOptions Class


OpenOptions.GetOpenWorksetsConfiguration Method

OpenOptionsGetOpenWorksetsConfiguration Method

Gets the object used to configure the worksets to open when the model is opened.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WorksetConfiguration GetOpenWorksetsConfiguration()
Public Function GetOpenWorksetsConfiguration As WorksetConfiguration
public:
WorksetConfiguration^ GetOpenWorksetsConfiguration()
member GetOpenWorksetsConfiguration : unit -> WorksetConfiguration

Return Value

WorksetConfiguration
The options. If , all user-created worksets will be opened.
See Also

Reference

OpenOptions Class


OpenOptions.SetOpenWorksetsConfiguration Method

OpenOptionsSetOpenWorksetsConfiguration Method

Sets the object used to configure the worksets to open when the model is opened.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetOpenWorksetsConfiguration(
    WorksetConfiguration openConfiguration
)
Public Sub SetOpenWorksetsConfiguration (
    openConfiguration As WorksetConfiguration
)
public:
void SetOpenWorksetsConfiguration(
    WorksetConfiguration^ openConfiguration
)
member SetOpenWorksetsConfiguration :
        openConfiguration : WorksetConfiguration -> unit

Parameters

openConfiguration WorksetConfiguration
The options. If , all user-created worksets will be opened.
Remarks
These options are ignored for non-workshared models.
Example
C#
VB
C++
F#
Copy
Document OpenDocumentWithWorksets(Application app, ModelPath projectPath)
{
    Document doc = null;
    try
    {
        // Get info on all the user worksets in the project prior to opening
        IList<WorksetPreview> worksets = WorksharingUtils.GetUserWorksetInfo(projectPath);
        IList<WorksetId> worksetIds = new List<WorksetId>();
        // Find two predetermined worksets
        foreach (WorksetPreview worksetPrev in worksets)
        {
            if (worksetPrev.Name.CompareTo("Workset1") == 0 ||
                worksetPrev.Name.CompareTo("Workset2") == 0)
            {
                worksetIds.Add(worksetPrev.Id);
            }
        }

        OpenOptions openOptions = new OpenOptions();
        // Setup config to close all worksets by default
        WorksetConfiguration openConfig = new WorksetConfiguration(WorksetConfigurationOption.CloseAllWorksets);
        // Set list of worksets for opening
        openConfig.Open(worksetIds);
        openOptions.SetOpenWorksetsConfiguration(openConfig);
        doc = app.OpenDocumentFile(projectPath, openOptions);
    }
    catch (Exception e)
    {
        TaskDialog.Show("Open File Failed", e.Message);
    }

    return doc;
}
Private Function OpenDocumentWithWorksets(app As Application, projectPath As ModelPath) As Document
    Dim doc As Document = Nothing
    Try
        ' Get info on all the user worksets in the project prior to opening
        Dim worksets As IList(Of WorksetPreview) = WorksharingUtils.GetUserWorksetInfo(projectPath)
        Dim worksetIds As IList(Of WorksetId) = New List(Of WorksetId)()
        ' Find two predetermined worksets
        For Each worksetPrev As WorksetPreview In worksets
            If worksetPrev.Name.CompareTo("Workset1") = 0 OrElse worksetPrev.Name.CompareTo("Workset2") = 0 Then
                worksetIds.Add(worksetPrev.Id)
            End If
        Next

        Dim openOptions As New OpenOptions()
        ' Setup config to close all worksets by default
        Dim openConfig As New WorksetConfiguration(WorksetConfigurationOption.CloseAllWorksets)
        ' Set list of worksets for opening
        openConfig.Open(worksetIds)
        openOptions.SetOpenWorksetsConfiguration(openConfig)
        doc = app.OpenDocumentFile(projectPath, openOptions)
    Catch e As Exception
        TaskDialog.Show("Open File Failed", e.Message)
    End Try

    Return doc
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

OpenOptions Class


OptionalFunctionalityUtils Class

A collection of utilities that can be used to determine if a particular set of functionality is installed and available.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBOptionalFunctionalityUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class OptionalFunctionalityUtils
Public NotInheritable Class OptionalFunctionalityUtils
public ref class OptionalFunctionalityUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type OptionalFunctionalityUtils = class end

The OptionalFunctionalityUtils type exposes the following members.

Methods
Name | Description
Is3DMImportLinkAvailable | Checks whether the 3DM Import/Link functionality is available in the installed Revit.
IsAXMImportLinkAvailable | Checks whether the AXM Import/Link functionality is available in the installed Revit.
IsDGNExportAvailable | Checks whether the DGN Export functionality is available in the installed Revit.
IsDGNImportLinkAvailable | Checks whether the DGN Import/Link functionality is available in the installed Revit.
IsDWFExportAvailable | Checks whether the DWF/DWFx Export functionality is available in the installed Revit.
IsDWGExportAvailable | Checks whether the DWG Export functionality is available in the installed Revit.
IsDWGImportLinkAvailable | Checks whether the DWG Import/Link functionality is available in the installed Revit.
IsDXFExportAvailable | Checks whether the DXF Export functionality is available in the installed Revit.
IsFBXExportAvailable | Checks whether the FBX Export functionality is available in the installed Revit.
IsGraphicsAvailable | Checks whether the graphics functionality is available to support display, print, and export functionality.
IsIFCAvailable | Checks whether IFC functionality is available in the installed Revit.
IsNavisworksExporterAvailable | Checks whether a Navisworks Exporter is available in the installed Revit.
IsOBJImportLinkAvailable | Checks whether the OBJ Import/Link functionality is available in the installed Revit.
IsPDFImportAvailable | Obsolete. Checks whether PDF import is available in the installed Revit.
IsSATImportLinkAvailable | Checks whether the SAT Import/Link functionality is available in the installed Revit.
IsShapeImporterAvailable | Checks whether the ShapeImporter functionality is available in the installed Revit.
IsSKPImportLinkAvailable | Checks whether the SKP Import/Link functionality is available in the installed Revit.
IsSTEPImportLinkAvailable | Checks whether the STEP Import/Link functionality is available in the installed Revit.
IsSTLImportLinkAvailable | Checks whether the STL Import/Link functionality is available in the installed Revit.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


OptionalFunctionalityUtils Methods

The OptionalFunctionalityUtils type exposes the following members.

Methods
Name | Description
Is3DMImportLinkAvailable | Checks whether the 3DM Import/Link functionality is available in the installed Revit.
IsAXMImportLinkAvailable | Checks whether the AXM Import/Link functionality is available in the installed Revit.
IsDGNExportAvailable | Checks whether the DGN Export functionality is available in the installed Revit.
IsDGNImportLinkAvailable | Checks whether the DGN Import/Link functionality is available in the installed Revit.
IsDWFExportAvailable | Checks whether the DWF/DWFx Export functionality is available in the installed Revit.
IsDWGExportAvailable | Checks whether the DWG Export functionality is available in the installed Revit.
IsDWGImportLinkAvailable | Checks whether the DWG Import/Link functionality is available in the installed Revit.
IsDXFExportAvailable | Checks whether the DXF Export functionality is available in the installed Revit.
IsFBXExportAvailable | Checks whether the FBX Export functionality is available in the installed Revit.
IsGraphicsAvailable | Checks whether the graphics functionality is available to support display, print, and export functionality.
IsIFCAvailable | Checks whether IFC functionality is available in the installed Revit.
IsNavisworksExporterAvailable | Checks whether a Navisworks Exporter is available in the installed Revit.
IsOBJImportLinkAvailable | Checks whether the OBJ Import/Link functionality is available in the installed Revit.
IsPDFImportAvailable | Obsolete. Checks whether PDF import is available in the installed Revit.
IsSATImportLinkAvailable | Checks whether the SAT Import/Link functionality is available in the installed Revit.
IsShapeImporterAvailable | Checks whether the ShapeImporter functionality is available in the installed Revit.
IsSKPImportLinkAvailable | Checks whether the SKP Import/Link functionality is available in the installed Revit.
IsSTEPImportLinkAvailable | Checks whether the STEP Import/Link functionality is available in the installed Revit.
IsSTLImportLinkAvailable | Checks whether the STL Import/Link functionality is available in the installed Revit.
Top
See Also

Reference

OptionalFunctionalityUtils Class


OptionalFunctionalityUtils.Is3DMImportLinkAvailable Method

OptionalFunctionalityUtilsIs3DMImportLinkAvailable Method

Checks whether the 3DM Import/Link functionality is available in the installed Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool Is3DMImportLinkAvailable()
Public Shared Function Is3DMImportLinkAvailable As Boolean
public:
static bool Is3DMImportLinkAvailable()
static member Is3DMImportLinkAvailable : unit -> bool

Return Value

Boolean
True if the 3DM Import/Link functionality is available in the installed Revit.
Remarks
3DM Import/Link is optional functionality that does not have to be part of the Revit installation.
See Also

Reference

OptionalFunctionalityUtils Class


OptionalFunctionalityUtils.IsAXMImportLinkAvailable Method

OptionalFunctionalityUtilsIsAXMImportLinkAvailable Method

Checks whether the AXM Import/Link functionality is available in the installed Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsAXMImportLinkAvailable()
Public Shared Function IsAXMImportLinkAvailable As Boolean
public:
static bool IsAXMImportLinkAvailable()
static member IsAXMImportLinkAvailable : unit -> bool

Return Value

Boolean
True if the AXM Import/Link functionality is available in the installed Revit.
Remarks
AXM Import/Link is optional functionality that does not have to be part of the Revit installation.
See Also

Reference

OptionalFunctionalityUtils Class


OptionalFunctionalityUtils.IsDGNExportAvailable Method

OptionalFunctionalityUtilsIsDGNExportAvailable Method

Checks whether the DGN Export functionality is available in the installed Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsDGNExportAvailable()
Public Shared Function IsDGNExportAvailable As Boolean
public:
static bool IsDGNExportAvailable()
static member IsDGNExportAvailable : unit -> bool

Return Value

Boolean
True if the DGN Export functionality is available in the installed Revit.
Remarks
DGN Export requires presence of certain modules that are optional and may not be part of the installed Revit.
See Also

Reference

OptionalFunctionalityUtils Class


OptionalFunctionalityUtils.IsDGNImportLinkAvailable Method

OptionalFunctionalityUtilsIsDGNImportLinkAvailable Method

Checks whether the DGN Import/Link functionality is available in the installed Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsDGNImportLinkAvailable()
Public Shared Function IsDGNImportLinkAvailable As Boolean
public:
static bool IsDGNImportLinkAvailable()
static member IsDGNImportLinkAvailable : unit -> bool

Return Value

Boolean
True if the DGN Import/Link functionality is available in the installed Revit.
Remarks
DGN Import/Link is optional functionality that does not have to be part of the Revit installation.
See Also

Reference

OptionalFunctionalityUtils Class


OptionalFunctionalityUtils.IsDWFExportAvailable Method

OptionalFunctionalityUtilsIsDWFExportAvailable Method

Checks whether the DWF/DWFx Export functionality is available in the installed Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsDWFExportAvailable()
Public Shared Function IsDWFExportAvailable As Boolean
public:
static bool IsDWFExportAvailable()
static member IsDWFExportAvailable : unit -> bool

Return Value

Boolean
True if the DWF/DWFx Export functionality is available in the installed Revit.
Remarks
DWF/DWFx Export requires presence of certain modules that are optional and may not be part of the installed Revit.
See Also

Reference

OptionalFunctionalityUtils Class


OptionalFunctionalityUtils.IsDWGExportAvailable Method

OptionalFunctionalityUtilsIsDWGExportAvailable Method

Checks whether the DWG Export functionality is available in the installed Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsDWGExportAvailable()
Public Shared Function IsDWGExportAvailable As Boolean
public:
static bool IsDWGExportAvailable()
static member IsDWGExportAvailable : unit -> bool

Return Value

Boolean
True if the DWG Export functionality is available in the installed Revit.
Remarks
DWG Export requires presence of certain modules that are optional and may not be part of the installed Revit.
See Also

Reference

OptionalFunctionalityUtils Class


OptionalFunctionalityUtils.IsDWGImportLinkAvailable Method

OptionalFunctionalityUtilsIsDWGImportLinkAvailable Method

Checks whether the DWG Import/Link functionality is available in the installed Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsDWGImportLinkAvailable()
Public Shared Function IsDWGImportLinkAvailable As Boolean
public:
static bool IsDWGImportLinkAvailable()
static member IsDWGImportLinkAvailable : unit -> bool

Return Value

Boolean
True if the DWG Import/Link functionality is available in the installed Revit.
Remarks
DWG Import/Link is optional functionality that does not have to be part of the Revit installation.
See Also

Reference

OptionalFunctionalityUtils Class


OptionalFunctionalityUtils.IsDXFExportAvailable Method

OptionalFunctionalityUtilsIsDXFExportAvailable Method

Checks whether the DXF Export functionality is available in the installed Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsDXFExportAvailable()
Public Shared Function IsDXFExportAvailable As Boolean
public:
static bool IsDXFExportAvailable()
static member IsDXFExportAvailable : unit -> bool

Return Value

Boolean
True if the DXF Export functionality is available in the installed Revit.
Remarks
DXF Export requires presence of certain modules that are optional and may not be part of the installed Revit.
See Also

Reference

OptionalFunctionalityUtils Class


OptionalFunctionalityUtils.IsFBXExportAvailable Method

OptionalFunctionalityUtilsIsFBXExportAvailable Method

Checks whether the FBX Export functionality is available in the installed Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsFBXExportAvailable()
Public Shared Function IsFBXExportAvailable As Boolean
public:
static bool IsFBXExportAvailable()
static member IsFBXExportAvailable : unit -> bool

Return Value

Boolean
True if the FBX Export functionality is available in the installed Revit.
Remarks
FBX Export requires presence of certain modules that are optional and may not be part of the installed Revit.
See Also

Reference

OptionalFunctionalityUtils Class


OptionalFunctionalityUtils.IsGraphicsAvailable Method

OptionalFunctionalityUtilsIsGraphicsAvailable Method

Checks whether the graphics functionality is available to support display, print, and export functionality.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsGraphicsAvailable()
Public Shared Function IsGraphicsAvailable As Boolean
public:
static bool IsGraphicsAvailable()
static member IsGraphicsAvailable : unit -> bool

Return Value

Boolean
True if the Graphics functionality is available in the installed Revit.
Remarks
Graphics functionality is optional functionality that does not have to be part of the Revit installation.
See Also

Reference

OptionalFunctionalityUtils Class


OptionalFunctionalityUtils.IsIFCAvailable Method

OptionalFunctionalityUtilsIsIFCAvailable Method

Checks whether IFC functionality is available in the installed Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsIFCAvailable()
Public Shared Function IsIFCAvailable As Boolean
public:
static bool IsIFCAvailable()
static member IsIFCAvailable : unit -> bool

Return Value

Boolean
True if the IFC functionality is available in the installed Revit.
Remarks
IFC Import/Export requires presence of certain modules that are optional and may not be part of the installed Revit.
See Also

Reference

OptionalFunctionalityUtils Class


OptionalFunctionalityUtils.IsNavisworksExporterAvailable Method

OptionalFunctionalityUtilsIsNavisworksExporterAvailable Method

Checks whether a Navisworks Exporter is available in the installed Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsNavisworksExporterAvailable()
Public Shared Function IsNavisworksExporterAvailable As Boolean
public:
static bool IsNavisworksExporterAvailable()
static member IsNavisworksExporterAvailable : unit -> bool

Return Value

Boolean
True if a Navisworks Exporter is available in the installed Revit.
Remarks
A Navisworks exporter is registered via an external add-in. If no add-in has registered an exporter, this will not be a part of the session.
See Also

Reference

OptionalFunctionalityUtils Class


OptionalFunctionalityUtils.IsOBJImportLinkAvailable Method

OptionalFunctionalityUtilsIsOBJImportLinkAvailable Method

Checks whether the OBJ Import/Link functionality is available in the installed Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsOBJImportLinkAvailable()
Public Shared Function IsOBJImportLinkAvailable As Boolean
public:
static bool IsOBJImportLinkAvailable()
static member IsOBJImportLinkAvailable : unit -> bool

Return Value

Boolean
True if the OBJ Import/Link functionality is available in the installed Revit.
Remarks
OBJ Import/Link is optional functionality that does not have to be a part of the Revit installation.
See Also

Reference

OptionalFunctionalityUtils Class


OptionalFunctionalityUtils.IsPDFImportAvailable Method

OptionalFunctionalityUtilsIsPDFImportAvailable Method

Note: This API is now obsolete.

Checks whether PDF import is available in the installed Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is deprecated in Revit 2024 because it will always return true. It will be removed in a future version of Revit")]
public static bool IsPDFImportAvailable()
<ObsoleteAttribute("This method is deprecated in Revit 2024 because it will always return true. It will be removed in a future version of Revit")>
Public Shared Function IsPDFImportAvailable As Boolean
public:
[ObsoleteAttribute(L"This method is deprecated in Revit 2024 because it will always return true. It will be removed in a future version of Revit")]
static bool IsPDFImportAvailable()
[<ObsoleteAttribute("This method is deprecated in Revit 2024 because it will always return true. It will be removed in a future version of Revit")>]
static member IsPDFImportAvailable : unit -> bool

Return Value

Boolean
True if a PDF import is available in the installed Revit.
Remarks
PDF Import requires the presence of certain modules that are optional and may not be part of the installed Revit.
See Also

Reference

OptionalFunctionalityUtils Class


OptionalFunctionalityUtils.IsSATImportLinkAvailable Method

OptionalFunctionalityUtilsIsSATImportLinkAvailable Method

Checks whether the SAT Import/Link functionality is available in the installed Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsSATImportLinkAvailable()
Public Shared Function IsSATImportLinkAvailable As Boolean
public:
static bool IsSATImportLinkAvailable()
static member IsSATImportLinkAvailable : unit -> bool

Return Value

Boolean
True if the SAT Import/Link functionality is available in the installed Revit.
Remarks
SAT Import/Link is optional functionality that does not have to be part of the Revit installation.
See Also

Reference

OptionalFunctionalityUtils Class


OptionalFunctionalityUtils.IsShapeImporterAvailable Method

OptionalFunctionalityUtilsIsShapeImporterAvailable Method

Checks whether the ShapeImporter functionality is available in the installed Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsShapeImporterAvailable()
Public Shared Function IsShapeImporterAvailable As Boolean
public:
static bool IsShapeImporterAvailable()
static member IsShapeImporterAvailable : unit -> bool

Return Value

Boolean
True if the ShapeImporter functionality is available in the installed Revit.
See Also

Reference

OptionalFunctionalityUtils Class


OptionalFunctionalityUtils.IsSKPImportLinkAvailable Method

OptionalFunctionalityUtilsIsSKPImportLinkAvailable Method

Checks whether the SKP Import/Link functionality is available in the installed Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsSKPImportLinkAvailable()
Public Shared Function IsSKPImportLinkAvailable As Boolean
public:
static bool IsSKPImportLinkAvailable()
static member IsSKPImportLinkAvailable : unit -> bool

Return Value

Boolean
True if the SKP Import/Link functionality is available in the installed Revit.
Remarks
SKP Import/Link is optional functionality that does not have to be part of the Revit installation.
See Also

Reference

OptionalFunctionalityUtils Class


OptionalFunctionalityUtils.IsSTEPImportLinkAvailable Method

OptionalFunctionalityUtilsIsSTEPImportLinkAvailable Method

Checks whether the STEP Import/Link functionality is available in the installed Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsSTEPImportLinkAvailable()
Public Shared Function IsSTEPImportLinkAvailable As Boolean
public:
static bool IsSTEPImportLinkAvailable()
static member IsSTEPImportLinkAvailable : unit -> bool

Return Value

Boolean
True if the STEP Import/Link functionality is available in the installed Revit.
Remarks
STEP Import/Link is optional functionality that does not have to be a part of the Revit installation.
See Also

Reference

OptionalFunctionalityUtils Class


OptionalFunctionalityUtils.IsSTLImportLinkAvailable Method

OptionalFunctionalityUtilsIsSTLImportLinkAvailable Method

Checks whether the STL Import/Link functionality is available in the installed Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsSTLImportLinkAvailable()
Public Shared Function IsSTLImportLinkAvailable As Boolean
public:
static bool IsSTLImportLinkAvailable()
static member IsSTLImportLinkAvailable : unit -> bool

Return Value

Boolean
True if the STL Import/Link functionality is available in the installed Revit.
Remarks
STL Import/Link is optional functionality that does not have to be a part of the Revit installation.
See Also

Reference

OptionalFunctionalityUtils Class


Options Class

User preferences for parsing of geometry.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Options : APIObject
Public Class Options
    Inherits APIObject
public ref class Options : public APIObject
type Options =
    class
        inherit APIObject
    end

The Options type exposes the following members.

Constructors
 | Name | Description
Public method | Options | Creates a default Options object.
Public method | Options(Options) | Copy constructor.
Top
Properties
 | Name | Description
Public property | ComputeReferences | Determines whether or not references to geometric objects are computed.
Public property | DetailLevel | The detail level for the geometry extracted with these options.
Public property | IncludeNonVisibleObjects | Whether to extract element geometry objects not set as Visible. The default is false.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | View | The view used for geometry extraction.
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This class determines the output of the Element.Geometry property.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Options Constructor

Overload List
 | Name | Description
Public method | Options | Creates a default Options object.
Public method | Options(Options) | Copy constructor.
Top
See Also

Reference

Options Class


Options Constructor

Creates a default Options object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Options()
Public Sub New
public:
Options()
new : unit -> Options
Remarks
Defaults to medium detail, no references and no view.
See Also

Reference

Options Class
Options Overload


Options(Options) Constructor

Copy constructor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Options(
    Options pOptions
)
Public Sub New (
    pOptions As Options
)
public:
Options(
    Options^ pOptions
)
new :
        pOptions : Options -> Options

Parameters

pOptions Options
See Also

Reference

Options Class
Options Overload


Options Properties

The Options type exposes the following members.

Properties
 | Name | Description
Public property | ComputeReferences | Determines whether or not references to geometric objects are computed.
Public property | DetailLevel | The detail level for the geometry extracted with these options.
Public property | IncludeNonVisibleObjects | Whether to extract element geometry objects not set as Visible. The default is false.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | View | The view used for geometry extraction.
Top
See Also

Reference

Options Class


Options.ComputeReferences Property

OptionsComputeReferences Property

Determines whether or not references to geometric objects are computed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ComputeReferences { get; set; }
Public Property ComputeReferences As Boolean
    Get
    Set
public:
property bool ComputeReferences {
    bool get ();
    void set (bool value);
}
member ComputeReferences : bool with get, set

Property Value

Boolean
See Also

Reference

Options Class


Options.DetailLevel Property

OptionsDetailLevel Property

The detail level for the geometry extracted with these options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ViewDetailLevel DetailLevel { get; set; }
Public Property DetailLevel As ViewDetailLevel
    Get
    Set
public:
property ViewDetailLevel DetailLevel {
    ViewDetailLevel get ();
    void set (ViewDetailLevel value);
}
member DetailLevel : ViewDetailLevel with get, set

Property Value

ViewDetailLevel
Exceptions
Exception | Condition
InvalidOperationException | Thrown when setting this property, if View is already set. When View is set the detail level of the view is used.
See Also

Reference

Options Class


Options.IncludeNonVisibleObjects Property

OptionsIncludeNonVisibleObjects Property

Whether to extract element geometry objects not set as Visible. The default is false.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IncludeNonVisibleObjects { get; set; }
Public Property IncludeNonVisibleObjects As Boolean
    Get
    Set
public:
property bool IncludeNonVisibleObjects {
    bool get ();
    void set (bool value);
}
member IncludeNonVisibleObjects : bool with get, set

Property Value

Boolean
See Also

Reference

Options Class


Options.View Property

OptionsView Property

The view used for geometry extraction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public View View { get; set; }
Public Property View As View
    Get
    Set
public:
property View^ View {
    View^ get ();
    void set (View^ value);
}
member View : View with get, set

Property Value

View
Exceptions
Exception | Condition
ArgumentNullException | Thrown when setting this property with a .
InvalidOperationException | Thrown when setting this property, if DetailLevel is already set. When DetailLevel is set view-specific geometry can't be extracted.
Remarks
If a view-specific version of an element exists, it will be extracted in the retrieval of geometry. Also, the detail level of the geometry will be taken from the view's detail level.
See Also

Reference

Options Class


Options Methods

The Options type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Options Class


OrdinateDimensionLineStyle Enumeration

The ordinate dimension line style.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum OrdinateDimensionLineStyle
Public Enumeration OrdinateDimensionLineStyle
public enum class OrdinateDimensionLineStyle
type OrdinateDimensionLineStyle
Members
Member name | Value | Description
None | 0 | Shows no dimension line. When you select the dimension line in the drawing area, a hidden line displays.
Continuous | 1 | Displays the dimension line as continuous.
Segmented | 2 | Segments the dimension line. Specify the length of the segments with the DimensionLineLength property.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


OrdinateDimensionSetting Class

Represents a collection of Ordinate Dimension settings that can be associated to an ordinate DimensionType.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBOrdinateDimensionSetting

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class OrdinateDimensionSetting : IDisposable
Public Class OrdinateDimensionSetting
    Implements IDisposable
public ref class OrdinateDimensionSetting : IDisposable
type OrdinateDimensionSetting =
    class
        interface IDisposable
    end

The OrdinateDimensionSetting type exposes the following members.

Constructors
 | Name | Description
Public method | OrdinateDimensionSetting | Constructs a new OrdinateDimensionSetting object with default settings.
Top
Properties
 | Name | Description
Public property | DimensionLineLength | Specifies the dimension line segment length. This setting is enabled when Dimension Line Style is Segmented.
Public property | DimensionLineStyle | Specifies the dimension line style.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OriginTickMarkId | Specifies the id of the tick mark element to use for the dimension origin.
Public property | OriginVisibility | Specifies thevisibility of the origin witness line for the ordinate dimension (this is the first witness line in the string).
Public property | TextOrientation | Specifies where to align the dimension text.
Public property | TextPosition | Specifies the dimension text position.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the OrdinateDimensionSetting
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


OrdinateDimensionSetting Constructor

Constructs a new OrdinateDimensionSetting object with default settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OrdinateDimensionSetting()
Public Sub New
public:
OrdinateDimensionSetting()
new : unit -> OrdinateDimensionSetting
See Also

Reference

OrdinateDimensionSetting Class


OrdinateDimensionSetting Properties

The OrdinateDimensionSetting type exposes the following members.

Properties
 | Name | Description
Public property | DimensionLineLength | Specifies the dimension line segment length. This setting is enabled when Dimension Line Style is Segmented.
Public property | DimensionLineStyle | Specifies the dimension line style.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OriginTickMarkId | Specifies the id of the tick mark element to use for the dimension origin.
Public property | OriginVisibility | Specifies thevisibility of the origin witness line for the ordinate dimension (this is the first witness line in the string).
Public property | TextOrientation | Specifies where to align the dimension text.
Public property | TextPosition | Specifies the dimension text position.
Top
See Also

Reference

OrdinateDimensionSetting Class


OrdinateDimensionSetting.DimensionLineLength Property

OrdinateDimensionSettingDimensionLineLength Property

Specifies the dimension line segment length. This setting is enabled when Dimension Line Style is Segmented.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double DimensionLineLength { get; set; }
Public Property DimensionLineLength As Double
    Get
    Set
public:
property double DimensionLineLength {
    double get ();
    void set (double value);
}
member DimensionLineLength : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The given value for dimensionLineLength must be greater than 0 and no more than 30000 feet.
See Also

Reference

OrdinateDimensionSetting Class


OrdinateDimensionSetting.DimensionLineStyle Property

OrdinateDimensionSettingDimensionLineStyle Property

Specifies the dimension line style.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OrdinateDimensionLineStyle DimensionLineStyle { get; set; }
Public Property DimensionLineStyle As OrdinateDimensionLineStyle
    Get
    Set
public:
property OrdinateDimensionLineStyle DimensionLineStyle {
    OrdinateDimensionLineStyle get ();
    void set (OrdinateDimensionLineStyle value);
}
member DimensionLineStyle : OrdinateDimensionLineStyle with get, set

Property Value

OrdinateDimensionLineStyle
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

OrdinateDimensionSetting Class


OrdinateDimensionSetting.IsValidObject Property

OrdinateDimensionSettingIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

OrdinateDimensionSetting Class


OrdinateDimensionSetting.OriginTickMarkId Property

OrdinateDimensionSettingOriginTickMarkId Property

Specifies the id of the tick mark element to use for the dimension origin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId OriginTickMarkId { get; set; }
Public Property OriginTickMarkId As ElementId
    Get
    Set
public:
property ElementId^ OriginTickMarkId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member OriginTickMarkId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

OrdinateDimensionSetting Class


OrdinateDimensionSetting.OriginVisibility Property

OrdinateDimensionSettingOriginVisibility Property

Specifies thevisibility of the origin witness line for the ordinate dimension (this is the first witness line in the string).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OrdinateOriginVisibility OriginVisibility { get; set; }
Public Property OriginVisibility As OrdinateOriginVisibility
    Get
    Set
public:
property OrdinateOriginVisibility OriginVisibility {
    OrdinateOriginVisibility get ();
    void set (OrdinateOriginVisibility value);
}
member OriginVisibility : OrdinateOriginVisibility with get, set

Property Value

OrdinateOriginVisibility
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

OrdinateDimensionSetting Class


OrdinateDimensionSetting.TextOrientation Property

OrdinateDimensionSettingTextOrientation Property

Specifies where to align the dimension text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OrdinateTextOrientation TextOrientation { get; set; }
Public Property TextOrientation As OrdinateTextOrientation
    Get
    Set
public:
property OrdinateTextOrientation TextOrientation {
    OrdinateTextOrientation get ();
    void set (OrdinateTextOrientation value);
}
member TextOrientation : OrdinateTextOrientation with get, set

Property Value

OrdinateTextOrientation
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

OrdinateDimensionSetting Class


OrdinateDimensionSetting.TextPosition Property

OrdinateDimensionSettingTextPosition Property

Specifies the dimension text position.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OrdinateTextPosition TextPosition { get; set; }
Public Property TextPosition As OrdinateTextPosition
    Get
    Set
public:
property OrdinateTextPosition TextPosition {
    OrdinateTextPosition get ();
    void set (OrdinateTextPosition value);
}
member TextPosition : OrdinateTextPosition with get, set

Property Value

OrdinateTextPosition
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

OrdinateDimensionSetting Class


OrdinateDimensionSetting Methods

The OrdinateDimensionSetting type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

OrdinateDimensionSetting Class


OrdinateDimensionSetting.Dispose Method

OrdinateDimensionSettingDispose Method

Releases all resources used by the OrdinateDimensionSetting

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

OrdinateDimensionSetting Class


OrdinateOriginVisibility Enumeration

The ordinate origin visibility.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum OrdinateOriginVisibility
Public Enumeration OrdinateOriginVisibility
public enum class OrdinateOriginVisibility
type OrdinateOriginVisibility
Members
Member name | Value | Description
None | 0 | Does not show the origin witness line, tick mark, or text (0'-0").
WitnessLineWithText | 1 | Shows the origin witness line, tick mark and text (0'-0").
WitnessLineOnly | 2 | Shows the origin witness line and tick mark.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


OrdinateTextOrientation Enumeration

The ordinate dimension text orientation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum OrdinateTextOrientation
Public Enumeration OrdinateTextOrientation
public enum class OrdinateTextOrientation
type OrdinateTextOrientation
Members
Member name | Value | Description
ParallelToDimensionLine | 0 | The dimension text orientation will be parallel to dimension line.
ParallelToWitnessLine | 1 | The dimension text orientation will be parallel to witness line.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


OrdinateTextPosition Enumeration

The ordinate dimension text position.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum OrdinateTextPosition
Public Enumeration OrdinateTextPosition
public enum class OrdinateTextPosition
type OrdinateTextPosition
Members
Member name | Value | Description
EndOfWitnessLine | 0 | The dimension text position will be at the end of witness line.
NextToWitnessLine | 1 | The dimension text position will be next to witness line.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Outline Class

Outline is a generic object that provides a bounding box/bounding outline. It supports operations to scale and transform. It also supports intersections and contains operations.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBOutline

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Outline : IDisposable
Public Class Outline
    Implements IDisposable
public ref class Outline : IDisposable
type Outline =
    class
        interface IDisposable
    end

The Outline type exposes the following members.

Constructors
 | Name | Description
Public method | Outline(Outline) | Constructs a new copy of the input Outline object.
Public method | Outline(XYZ, XYZ) | Constructor that uses a minimum and maximum XYZ point to initialize the outline.
Top
Properties
 | Name | Description
Public property | IsEmpty | Identifies if the outline represents an empty outline.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MaximumPoint | The maximum point of the bounding box.
Public property | MinimumPoint | The minimum point of the bounding box.
Top
Methods
 | Name | Description
Public method | AddPoint | Adds a point to the bounding box, expanding it if the point is outside the existing boundary.
Public method | Contains | Determine if this Outline contains the specified point to within a tolerance.
Public method | ContainsOtherOutline | Determine if this Outline contains another Outline to within tolerance.
Public method | Dispose | Releases all resources used by the Outline
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetDiagonalLength | Get the length of outline's diagonal. If called on empty outline, 0. is returned
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Intersects | Determine if this Outline intersects the input Outline to within a specified tolerance.
Public method | IsScaleValid | Checks if given scale is valid. Should be greater than zero.
Public method | Scale | Scales the bounding box by given scale.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Outline Constructor

Overload List
 | Name | Description
Public method | Outline(Outline) | Constructs a new copy of the input Outline object.
Public method | Outline(XYZ, XYZ) | Constructor that uses a minimum and maximum XYZ point to initialize the outline.
Top
See Also

Reference

Outline Class


Outline(Outline) Constructor

Constructs a new copy of the input Outline object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Outline(
    Outline other
)
Public Sub New (
    other As Outline
)
public:
Outline(
    Outline^ other
)
new :
        other : Outline -> Outline

Parameters

other Outline
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

Outline Class
Outline Overload


Outline(XYZ, XYZ) Constructor

Constructor that uses a minimum and maximum XYZ point to initialize the outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Outline(
    XYZ minimumPoint,
    XYZ maximumPoint
)
Public Sub New (
    minimumPoint As XYZ,
    maximumPoint As XYZ
)
public:
Outline(
    XYZ^ minimumPoint,
    XYZ^ maximumPoint
)
new :
        minimumPoint : XYZ *
        maximumPoint : XYZ -> Outline

Parameters

minimumPoint XYZ
The minimum point
maximumPoint XYZ
The maximum point.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

Outline Class
Outline Overload


Outline Properties

The Outline type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Identifies if the outline represents an empty outline.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MaximumPoint | The maximum point of the bounding box.
Public property | MinimumPoint | The minimum point of the bounding box.
Top
See Also

Reference

Outline Class


Outline.IsEmpty Property

OutlineIsEmpty Property

Identifies if the outline represents an empty outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEmpty { get; }
Public ReadOnly Property IsEmpty As Boolean
    Get
public:
property bool IsEmpty {
    bool get ();
}
member IsEmpty : bool with get

Property Value

Boolean
See Also

Reference

Outline Class


Outline.IsValidObject Property

OutlineIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

Outline Class


Outline.MaximumPoint Property

OutlineMaximumPoint Property

The maximum point of the bounding box.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ MaximumPoint { get; set; }
Public Property MaximumPoint As XYZ
    Get
    Set
public:
property XYZ^ MaximumPoint {
    XYZ^ get ();
    void set (XYZ^ value);
}
member MaximumPoint : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

Outline Class


Outline.MinimumPoint Property

OutlineMinimumPoint Property

The minimum point of the bounding box.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ MinimumPoint { get; set; }
Public Property MinimumPoint As XYZ
    Get
    Set
public:
property XYZ^ MinimumPoint {
    XYZ^ get ();
    void set (XYZ^ value);
}
member MinimumPoint : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

Outline Class


Outline Methods

The Outline type exposes the following members.

Methods
 | Name | Description
Public method | AddPoint | Adds a point to the bounding box, expanding it if the point is outside the existing boundary.
Public method | Contains | Determine if this Outline contains the specified point to within a tolerance.
Public method | ContainsOtherOutline | Determine if this Outline contains another Outline to within tolerance.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetDiagonalLength | Get the length of outline's diagonal. If called on empty outline, 0. is returned
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Intersects | Determine if this Outline intersects the input Outline to within a specified tolerance.
Public method | IsScaleValid | Checks if given scale is valid. Should be greater than zero.
Public method | Scale | Scales the bounding box by given scale.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Outline Class


Outline.AddPoint Method

OutlineAddPoint Method

Adds a point to the bounding box, expanding it if the point is outside the existing boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddPoint(
    XYZ point
)
Public Sub AddPoint (
    point As XYZ
)
public:
void AddPoint(
    XYZ^ point
)
member AddPoint :
        point : XYZ -> unit

Parameters

point XYZ
The point to add.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

Outline Class


Outline.Contains Method

OutlineContains Method

Determine if this Outline contains the specified point to within a tolerance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Contains(
    XYZ point,
    double tolerance
)
Public Function Contains (
    point As XYZ,
    tolerance As Double
) As Boolean
public:
bool Contains(
    XYZ^ point,
    double tolerance
)
member Contains :
        point : XYZ *
        tolerance : float -> bool

Parameters

point XYZ
The point to test for containment.
tolerance Double
The tolerance to use when determining whether the point is contained. Defaults to zero.

Return Value

Boolean
True if this outline contains the given point, or false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
If the tolerance is positive, the point may lie up to the tolerance amount outside the outline in each coordinate. If the tolerance is negative, the point must lie at least the tolerance amount inside the outline in each coordinate.
See Also

Reference

Outline Class


Outline.ContainsOtherOutline Method

OutlineContainsOtherOutline Method

Determine if this Outline contains another Outline to within tolerance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ContainsOtherOutline(
    Outline otherOutline,
    double tolerance
)
Public Function ContainsOtherOutline (
    otherOutline As Outline,
    tolerance As Double
) As Boolean
public:
bool ContainsOtherOutline(
    Outline^ otherOutline,
    double tolerance
)
member ContainsOtherOutline :
        otherOutline : Outline *
        tolerance : float -> bool

Parameters

otherOutline Outline
The outline to test for containment.
tolerance Double
The tolerance to use when determining whether the point is contained. Defaults to zero.

Return Value

Boolean
True if this outline contains the given outline, or false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
If the tolerance is positive, the other Outline may extend the tolerance distance outside of this Outline in each coordinate. If the tolerance is negative, the other Outline must lie at least the tolerance distance inside of this Outline in each coordinate to be a match.
See Also

Reference

Outline Class


Outline.Dispose Method

OutlineDispose Method

Releases all resources used by the Outline

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

Outline Class


Outline.GetDiagonalLength Method

OutlineGetDiagonalLength Method

Get the length of outline's diagonal. If called on empty outline, 0. is returned

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetDiagonalLength()
Public Function GetDiagonalLength As Double
public:
double GetDiagonalLength()
member GetDiagonalLength : unit -> float

Return Value

Double
The length of the diagonal.
See Also

Reference

Outline Class


Outline.Intersects Method

OutlineIntersects Method

Determine if this Outline intersects the input Outline to within a specified tolerance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Intersects(
    Outline outline,
    double tolerance
)
Public Function Intersects (
    outline As Outline,
    tolerance As Double
) As Boolean
public:
bool Intersects(
    Outline^ outline,
    double tolerance
)
member Intersects :
        outline : Outline *
        tolerance : float -> bool

Parameters

outline Outline
The outline to test for intersection with this one.
tolerance Double
The tolerance to use when determining intersection. Defaults to zero.

Return Value

Boolean
True if the given outline intersects this outline.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
If the tolerance is positive, the outlines may be separated by the tolerance distance in each coordinate. If the tolerance is negative, the outlines must overlap by at least the tolerance distance in each coordinate.
See Also

Reference

Outline Class


Outline.IsScaleValid Method

OutlineIsScaleValid Method

Checks if given scale is valid. Should be greater than zero.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsScaleValid(
    double scale
)
Public Function IsScaleValid (
    scale As Double
) As Boolean
public:
bool IsScaleValid(
    double scale
)
member IsScaleValid :
        scale : float -> bool

Parameters

scale Double
The scale.

Return Value

Boolean
True if the scale is valid, false otherwise.
See Also

Reference

Outline Class


Outline.Scale Method

OutlineScale Method

Scales the bounding box by given scale.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Scale(
    double scale
)
Public Sub Scale (
    scale As Double
)
public:
void Scale(
    double scale
)
member Scale :
        scale : float -> unit

Parameters

scale Double
The scale value. It should be greater than zero.
Exceptions
Exception | Condition
ArgumentException | The scale is invalid.
See Also

Reference

Outline Class


OverrideGraphicSettings Class

Settings to override display of elements in a view.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBOverrideGraphicSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class OverrideGraphicSettings : IDisposable
Public Class OverrideGraphicSettings
    Implements IDisposable
public ref class OverrideGraphicSettings : IDisposable
type OverrideGraphicSettings =
    class
        interface IDisposable
    end

The OverrideGraphicSettings type exposes the following members.

Constructors
 | Name | Description
Public method | OverrideGraphicSettings | Creates a new instance of an OverrideGraphicSettings object.
Public method | OverrideGraphicSettings(OverrideGraphicSettings) | Creates a new instance of an OverrideGraphicSettings object based on an existing OverrideGraphicSettings object.
Top
Properties
 | Name | Description
Public property | CutBackgroundPatternColor | The override color of the background pattern of cut faces.
Public property | CutBackgroundPatternId | The ElementId of the cut face background fill pattern override. A value of InvalidElementId means no override is set.
Public property | CutForegroundPatternColor | The override color of the foreground pattern of cut faces.
Public property | CutForegroundPatternId | The ElementId of the cut face foreground fill pattern override. A value of InvalidElementId means no override is set.
Public property | CutLineColor | Cut surface line color.
Public property | CutLinePatternId | ElementId of the cut surface line pattern.
Public property | CutLineWeight | Cut surface line weight.
Public property | DetailLevel | The detail level.
Public property | Halftone | Value of the halftone override.
 | InvalidPenNumber | The invalidPenNumber for clearing line weight overrides.
Public property | IsCutBackgroundPatternVisible | The visibility of the cut face background fill pattern.
Public property | IsCutForegroundPatternVisible | The visibility of the cut face foreground fill pattern.
Public property | IsSurfaceBackgroundPatternVisible | The visibility of the surface background fill pattern.
Public property | IsSurfaceForegroundPatternVisible | The visibility of the surface foreground fill pattern.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ProjectionLineColor | Projection surface line color.
Public property | ProjectionLinePatternId | Id of the projection surface line pattern.
Public property | ProjectionLineWeight | The projection surface line weight.
Public property | SurfaceBackgroundPatternColor | The override color of the surface background pattern.
Public property | SurfaceBackgroundPatternId | The ElementId of the surface background fill pattern override. A value of InvalidElementId means no override is set.
Public property | SurfaceForegroundPatternColor | The override color of the surface foreground pattern.
Public property | SurfaceForegroundPatternId | The ElementId of the surface foreground fill pattern override. A value of InvalidElementId means no override is set.
Public property | Transparency | Transparency of surfaces.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the OverrideGraphicSettings
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetCutBackgroundPatternColor | Sets the override color of the background pattern of cut faces.
Public method | SetCutBackgroundPatternId | Sets the ElementId of the cut face background pattern override. The fill pattern must be a drafting pattern. A value of InvalidElementId means no override is set.
Public method | SetCutBackgroundPatternVisible | Sets the visibility of the cut face background fill pattern.
Public method | SetCutForegroundPatternColor | Sets the override color of the foreground pattern of cut faces.
Public method | SetCutForegroundPatternId | Sets the ElementId of the cut face foreground pattern override. The fill pattern must be a drafting pattern. A value of InvalidElementId means no override is set.
Public method | SetCutForegroundPatternVisible | Sets the visibility of the cut face foreground fill pattern.
Public method | SetCutLineColor | Sets the cut surface line color.
Public method | SetCutLinePatternId | Sets the ElementId of the cut surface line pattern.
Public method | SetCutLineWeight | Sets the cut surface line weight.
Public method | SetDetailLevel | Sets the detail level.
Public method | SetHalftone | Sets the halftone value.
Public method | SetProjectionLineColor | Sets the projection surface line color.
Public method | SetProjectionLinePatternId | Sets the ElementId of the projection surface line pattern.
Public method | SetProjectionLineWeight | Sets the projection surface line weight.
Public method | SetSurfaceBackgroundPatternColor | Sets the override color of the surface background pattern.
Public method | SetSurfaceBackgroundPatternId | Sets the ElementId of the surface background pattern override. The fill pattern must be a drafting pattern. A value of InvalidElementId means no override is set.
Public method | SetSurfaceBackgroundPatternVisible | Sets the visibility of the surface background fill pattern.
Public method | SetSurfaceForegroundPatternColor | Sets the override color of the surface foreground pattern.
Public method | SetSurfaceForegroundPatternId | Sets the ElementId of the surface foreground pattern override. The fill pattern must be a drafting pattern. A value of InvalidElementId means no override is set.
Public method | SetSurfaceForegroundPatternVisible | Sets the visibility of the surface foreground fill pattern.
Public method | SetSurfaceTransparency | Sets the projection surface transparency.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


OverrideGraphicSettings Constructor

Overload List
 | Name | Description
Public method | OverrideGraphicSettings | Creates a new instance of an OverrideGraphicSettings object.
Public method | OverrideGraphicSettings(OverrideGraphicSettings) | Creates a new instance of an OverrideGraphicSettings object based on an existing OverrideGraphicSettings object.
Top
See Also

Reference

OverrideGraphicSettings Class


OverrideGraphicSettings Constructor

Creates a new instance of an OverrideGraphicSettings object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OverrideGraphicSettings()
Public Sub New
public:
OverrideGraphicSettings()
new : unit -> OverrideGraphicSettings
See Also

Reference

OverrideGraphicSettings Class
OverrideGraphicSettings Overload


OverrideGraphicSettings(OverrideGraphicSettings) Constructor

Creates a new instance of an OverrideGraphicSettings object based on an existing OverrideGraphicSettings object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OverrideGraphicSettings(
    OverrideGraphicSettings overrideGraphicSettings
)
Public Sub New (
    overrideGraphicSettings As OverrideGraphicSettings
)
public:
OverrideGraphicSettings(
    OverrideGraphicSettings^ overrideGraphicSettings
)
new :
        overrideGraphicSettings : OverrideGraphicSettings -> OverrideGraphicSettings

Parameters

overrideGraphicSettings OverrideGraphicSettings
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

OverrideGraphicSettings Class
OverrideGraphicSettings Overload


OverrideGraphicSettings Properties

The OverrideGraphicSettings type exposes the following members.

Properties
 | Name | Description
Public property | CutBackgroundPatternColor | The override color of the background pattern of cut faces.
Public property | CutBackgroundPatternId | The ElementId of the cut face background fill pattern override. A value of InvalidElementId means no override is set.
Public property | CutForegroundPatternColor | The override color of the foreground pattern of cut faces.
Public property | CutForegroundPatternId | The ElementId of the cut face foreground fill pattern override. A value of InvalidElementId means no override is set.
Public property | CutLineColor | Cut surface line color.
Public property | CutLinePatternId | ElementId of the cut surface line pattern.
Public property | CutLineWeight | Cut surface line weight.
Public property | DetailLevel | The detail level.
Public property | Halftone | Value of the halftone override.
 | InvalidPenNumber | The invalidPenNumber for clearing line weight overrides.
Public property | IsCutBackgroundPatternVisible | The visibility of the cut face background fill pattern.
Public property | IsCutForegroundPatternVisible | The visibility of the cut face foreground fill pattern.
Public property | IsSurfaceBackgroundPatternVisible | The visibility of the surface background fill pattern.
Public property | IsSurfaceForegroundPatternVisible | The visibility of the surface foreground fill pattern.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ProjectionLineColor | Projection surface line color.
Public property | ProjectionLinePatternId | Id of the projection surface line pattern.
Public property | ProjectionLineWeight | The projection surface line weight.
Public property | SurfaceBackgroundPatternColor | The override color of the surface background pattern.
Public property | SurfaceBackgroundPatternId | The ElementId of the surface background fill pattern override. A value of InvalidElementId means no override is set.
Public property | SurfaceForegroundPatternColor | The override color of the surface foreground pattern.
Public property | SurfaceForegroundPatternId | The ElementId of the surface foreground fill pattern override. A value of InvalidElementId means no override is set.
Public property | Transparency | Transparency of surfaces.
Top
See Also

Reference

OverrideGraphicSettings Class


OverrideGraphicSettings.CutBackgroundPatternColor Property

OverrideGraphicSettingsCutBackgroundPatternColor Property

The override color of the background pattern of cut faces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color CutBackgroundPatternColor { get; }
Public ReadOnly Property CutBackgroundPatternColor As Color
    Get
public:
property Color^ CutBackgroundPatternColor {
    Color^ get ();
}
member CutBackgroundPatternColor : Color with get

Property Value

Color
See Also

Reference

OverrideGraphicSettings Class


OverrideGraphicSettings.CutBackgroundPatternId Property

OverrideGraphicSettingsCutBackgroundPatternId Property

The ElementId of the cut face background fill pattern override. A value of InvalidElementId means no override is set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId CutBackgroundPatternId { get; }
Public ReadOnly Property CutBackgroundPatternId As ElementId
    Get
public:
property ElementId^ CutBackgroundPatternId {
    ElementId^ get ();
}
member CutBackgroundPatternId : ElementId with get

Property Value

ElementId
See Also

Reference

OverrideGraphicSettings Class


OverrideGraphicSettings.CutForegroundPatternColor Property

OverrideGraphicSettingsCutForegroundPatternColor Property

The override color of the foreground pattern of cut faces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color CutForegroundPatternColor { get; }
Public ReadOnly Property CutForegroundPatternColor As Color
    Get
public:
property Color^ CutForegroundPatternColor {
    Color^ get ();
}
member CutForegroundPatternColor : Color with get

Property Value

Color
See Also

Reference

OverrideGraphicSettings Class


OverrideGraphicSettings.CutForegroundPatternId Property

OverrideGraphicSettingsCutForegroundPatternId Property

The ElementId of the cut face foreground fill pattern override. A value of InvalidElementId means no override is set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId CutForegroundPatternId { get; }
Public ReadOnly Property CutForegroundPatternId As ElementId
    Get
public:
property ElementId^ CutForegroundPatternId {
    ElementId^ get ();
}
member CutForegroundPatternId : ElementId with get

Property Value

ElementId
See Also

Reference

OverrideGraphicSettings Class


OverrideGraphicSettings.CutLineColor Property

OverrideGraphicSettingsCutLineColor Property

Cut surface line color.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color CutLineColor { get; }
Public ReadOnly Property CutLineColor As Color
    Get
public:
property Color^ CutLineColor {
    Color^ get ();
}
member CutLineColor : Color with get

Property Value

Color
See Also

Reference

OverrideGraphicSettings Class


OverrideGraphicSettings.CutLinePatternId Property

OverrideGraphicSettingsCutLinePatternId Property

ElementId of the cut surface line pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId CutLinePatternId { get; }
Public ReadOnly Property CutLinePatternId As ElementId
    Get
public:
property ElementId^ CutLinePatternId {
    ElementId^ get ();
}
member CutLinePatternId : ElementId with get

Property Value

ElementId
See Also

Reference

OverrideGraphicSettings Class


OverrideGraphicSettings.CutLineWeight Property

OverrideGraphicSettingsCutLineWeight Property

Cut surface line weight.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int CutLineWeight { get; }
Public ReadOnly Property CutLineWeight As Integer
    Get
public:
property int CutLineWeight {
    int get ();
}
member CutLineWeight : int with get

Property Value

Int32
See Also

Reference

OverrideGraphicSettings Class


OverrideGraphicSettings.DetailLevel Property

OverrideGraphicSettingsDetailLevel Property

The detail level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ViewDetailLevel DetailLevel { get; }
Public ReadOnly Property DetailLevel As ViewDetailLevel
    Get
public:
property ViewDetailLevel DetailLevel {
    ViewDetailLevel get ();
}
member DetailLevel : ViewDetailLevel with get

Property Value

ViewDetailLevel
See Also

Reference

OverrideGraphicSettings Class


OverrideGraphicSettings.Halftone Property

OverrideGraphicSettingsHalftone Property

Value of the halftone override.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Halftone { get; }
Public ReadOnly Property Halftone As Boolean
    Get
public:
property bool Halftone {
    bool get ();
}
member Halftone : bool with get

Property Value

Boolean
See Also

Reference

OverrideGraphicSettings Class


OverrideGraphicSettings.InvalidPenNumber Property

OverrideGraphicSettingsInvalidPenNumber Property

The invalidPenNumber for clearing line weight overrides.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int InvalidPenNumber { get; }
Public Shared ReadOnly Property InvalidPenNumber As Integer
    Get
public:
static property int InvalidPenNumber {
    int get ();
}
static member InvalidPenNumber : int with get

Property Value

Int32
See Also

Reference

OverrideGraphicSettings Class


OverrideGraphicSettings.IsCutBackgroundPatternVisible Property

OverrideGraphicSettingsIsCutBackgroundPatternVisible Property

The visibility of the cut face background fill pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCutBackgroundPatternVisible { get; }
Public ReadOnly Property IsCutBackgroundPatternVisible As Boolean
    Get
public:
property bool IsCutBackgroundPatternVisible {
    bool get ();
}
member IsCutBackgroundPatternVisible : bool with get

Property Value

Boolean
See Also

Reference

OverrideGraphicSettings Class


OverrideGraphicSettings.IsCutForegroundPatternVisible Property

OverrideGraphicSettingsIsCutForegroundPatternVisible Property

The visibility of the cut face foreground fill pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCutForegroundPatternVisible { get; }
Public ReadOnly Property IsCutForegroundPatternVisible As Boolean
    Get
public:
property bool IsCutForegroundPatternVisible {
    bool get ();
}
member IsCutForegroundPatternVisible : bool with get

Property Value

Boolean
See Also

Reference

OverrideGraphicSettings Class


OverrideGraphicSettings.IsSurfaceBackgroundPatternVisible Property

OverrideGraphicSettingsIsSurfaceBackgroundPatternVisible Property

The visibility of the surface background fill pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSurfaceBackgroundPatternVisible { get; }
Public ReadOnly Property IsSurfaceBackgroundPatternVisible As Boolean
    Get
public:
property bool IsSurfaceBackgroundPatternVisible {
    bool get ();
}
member IsSurfaceBackgroundPatternVisible : bool with get

Property Value

Boolean
See Also

Reference

OverrideGraphicSettings Class


OverrideGraphicSettings.IsSurfaceForegroundPatternVisible Property

OverrideGraphicSettingsIsSurfaceForegroundPatternVisible Property

The visibility of the surface foreground fill pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSurfaceForegroundPatternVisible { get; }
Public ReadOnly Property IsSurfaceForegroundPatternVisible As Boolean
    Get
public:
property bool IsSurfaceForegroundPatternVisible {
    bool get ();
}
member IsSurfaceForegroundPatternVisible : bool with get

Property Value

Boolean
See Also

Reference

OverrideGraphicSettings Class


OverrideGraphicSettings.IsValidObject Property

OverrideGraphicSettingsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

OverrideGraphicSettings Class


OverrideGraphicSettings.ProjectionLineColor Property

OverrideGraphicSettingsProjectionLineColor Property

Projection surface line color.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color ProjectionLineColor { get; }
Public ReadOnly Property ProjectionLineColor As Color
    Get
public:
property Color^ ProjectionLineColor {
    Color^ get ();
}
member ProjectionLineColor : Color with get

Property Value

Color
See Also

Reference

OverrideGraphicSettings Class


OverrideGraphicSettings.ProjectionLinePatternId Property

OverrideGraphicSettingsProjectionLinePatternId Property

Id of the projection surface line pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId ProjectionLinePatternId { get; }
Public ReadOnly Property ProjectionLinePatternId As ElementId
    Get
public:
property ElementId^ ProjectionLinePatternId {
    ElementId^ get ();
}
member ProjectionLinePatternId : ElementId with get

Property Value

ElementId
See Also

Reference

OverrideGraphicSettings Class


OverrideGraphicSettings.ProjectionLineWeight Property

OverrideGraphicSettingsProjectionLineWeight Property

The projection surface line weight.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ProjectionLineWeight { get; }
Public ReadOnly Property ProjectionLineWeight As Integer
    Get
public:
property int ProjectionLineWeight {
    int get ();
}
member ProjectionLineWeight : int with get

Property Value

Int32
See Also

Reference

OverrideGraphicSettings Class


OverrideGraphicSettings.SurfaceBackgroundPatternColor Property

OverrideGraphicSettingsSurfaceBackgroundPatternColor Property

The override color of the surface background pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color SurfaceBackgroundPatternColor { get; }
Public ReadOnly Property SurfaceBackgroundPatternColor As Color
    Get
public:
property Color^ SurfaceBackgroundPatternColor {
    Color^ get ();
}
member SurfaceBackgroundPatternColor : Color with get

Property Value

Color
See Also

Reference

OverrideGraphicSettings Class


OverrideGraphicSettings.SurfaceBackgroundPatternId Property

OverrideGraphicSettingsSurfaceBackgroundPatternId Property

The ElementId of the surface background fill pattern override. A value of InvalidElementId means no override is set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId SurfaceBackgroundPatternId { get; }
Public ReadOnly Property SurfaceBackgroundPatternId As ElementId
    Get
public:
property ElementId^ SurfaceBackgroundPatternId {
    ElementId^ get ();
}
member SurfaceBackgroundPatternId : ElementId with get

Property Value

ElementId
See Also

Reference

OverrideGraphicSettings Class


OverrideGraphicSettings.SurfaceForegroundPatternColor Property

OverrideGraphicSettingsSurfaceForegroundPatternColor Property

The override color of the surface foreground pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color SurfaceForegroundPatternColor { get; }
Public ReadOnly Property SurfaceForegroundPatternColor As Color
    Get
public:
property Color^ SurfaceForegroundPatternColor {
    Color^ get ();
}
member SurfaceForegroundPatternColor : Color with get

Property Value

Color
See Also

Reference

OverrideGraphicSettings Class


OverrideGraphicSettings.SurfaceForegroundPatternId Property

OverrideGraphicSettingsSurfaceForegroundPatternId Property

The ElementId of the surface foreground fill pattern override. A value of InvalidElementId means no override is set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId SurfaceForegroundPatternId { get; }
Public ReadOnly Property SurfaceForegroundPatternId As ElementId
    Get
public:
property ElementId^ SurfaceForegroundPatternId {
    ElementId^ get ();
}
member SurfaceForegroundPatternId : ElementId with get

Property Value

ElementId
See Also

Reference

OverrideGraphicSettings Class


OverrideGraphicSettings.Transparency Property

OverrideGraphicSettingsTransparency Property

Transparency of surfaces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Transparency { get; }
Public ReadOnly Property Transparency As Integer
    Get
public:
property int Transparency {
    int get ();
}
member Transparency : int with get

Property Value

Int32
See Also

Reference

OverrideGraphicSettings Class


OverrideGraphicSettings Methods

The OverrideGraphicSettings type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetCutBackgroundPatternColor | Sets the override color of the background pattern of cut faces.
Public method | SetCutBackgroundPatternId | Sets the ElementId of the cut face background pattern override. The fill pattern must be a drafting pattern. A value of InvalidElementId means no override is set.
Public method | SetCutBackgroundPatternVisible | Sets the visibility of the cut face background fill pattern.
Public method | SetCutForegroundPatternColor | Sets the override color of the foreground pattern of cut faces.
Public method | SetCutForegroundPatternId | Sets the ElementId of the cut face foreground pattern override. The fill pattern must be a drafting pattern. A value of InvalidElementId means no override is set.
Public method | SetCutForegroundPatternVisible | Sets the visibility of the cut face foreground fill pattern.
Public method | SetCutLineColor | Sets the cut surface line color.
Public method | SetCutLinePatternId | Sets the ElementId of the cut surface line pattern.
Public method | SetCutLineWeight | Sets the cut surface line weight.
Public method | SetDetailLevel | Sets the detail level.
Public method | SetHalftone | Sets the halftone value.
Public method | SetProjectionLineColor | Sets the projection surface line color.
Public method | SetProjectionLinePatternId | Sets the ElementId of the projection surface line pattern.
Public method | SetProjectionLineWeight | Sets the projection surface line weight.
Public method | SetSurfaceBackgroundPatternColor | Sets the override color of the surface background pattern.
Public method | SetSurfaceBackgroundPatternId | Sets the ElementId of the surface background pattern override. The fill pattern must be a drafting pattern. A value of InvalidElementId means no override is set.
Public method | SetSurfaceBackgroundPatternVisible | Sets the visibility of the surface background fill pattern.
Public method | SetSurfaceForegroundPatternColor | Sets the override color of the surface foreground pattern.
Public method | SetSurfaceForegroundPatternId | Sets the ElementId of the surface foreground pattern override. The fill pattern must be a drafting pattern. A value of InvalidElementId means no override is set.
Public method | SetSurfaceForegroundPatternVisible | Sets the visibility of the surface foreground fill pattern.
Public method | SetSurfaceTransparency | Sets the projection surface transparency.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

OverrideGraphicSettings Class


OverrideGraphicSettings.Dispose Method

OverrideGraphicSettingsDispose Method

Releases all resources used by the OverrideGraphicSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

OverrideGraphicSettings Class


OverrideGraphicSettings.SetCutBackgroundPatternColor Method

OverrideGraphicSettingsSetCutBackgroundPatternColor Method

Sets the override color of the background pattern of cut faces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OverrideGraphicSettings SetCutBackgroundPatternColor(
    Color color
)
Public Function SetCutBackgroundPatternColor (
    color As Color
) As OverrideGraphicSettings
public:
OverrideGraphicSettings^ SetCutBackgroundPatternColor(
    Color^ color
)
member SetCutBackgroundPatternColor :
        color : Color -> OverrideGraphicSettings

Parameters

color Color
Value of the cut face background color for the override. InvalidColorValue means no override is set.

Return Value

OverrideGraphicSettings
Reference to the changed object.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

OverrideGraphicSettings Class


OverrideGraphicSettings.SetCutBackgroundPatternId Method

OverrideGraphicSettingsSetCutBackgroundPatternId Method

Sets the ElementId of the cut face background pattern override. The fill pattern must be a drafting pattern. A value of InvalidElementId means no override is set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OverrideGraphicSettings SetCutBackgroundPatternId(
    ElementId fillPatternId
)
Public Function SetCutBackgroundPatternId (
    fillPatternId As ElementId
) As OverrideGraphicSettings
public:
OverrideGraphicSettings^ SetCutBackgroundPatternId(
    ElementId^ fillPatternId
)
member SetCutBackgroundPatternId :
        fillPatternId : ElementId -> OverrideGraphicSettings

Parameters

fillPatternId ElementId
Value of the cut face background fill pattern override.

Return Value

OverrideGraphicSettings
Reference to the changed object.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

OverrideGraphicSettings Class


OverrideGraphicSettings.SetCutBackgroundPatternVisible Method

OverrideGraphicSettingsSetCutBackgroundPatternVisible Method

Sets the visibility of the cut face background fill pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OverrideGraphicSettings SetCutBackgroundPatternVisible(
    bool fillPatternVisible
)
Public Function SetCutBackgroundPatternVisible (
    fillPatternVisible As Boolean
) As OverrideGraphicSettings
public:
OverrideGraphicSettings^ SetCutBackgroundPatternVisible(
    bool fillPatternVisible
)
member SetCutBackgroundPatternVisible :
        fillPatternVisible : bool -> OverrideGraphicSettings

Parameters

fillPatternVisible Boolean
Value of the visibility of the cut face background fill pattern.

Return Value

OverrideGraphicSettings
Reference to the changed object.
See Also

Reference

OverrideGraphicSettings Class


OverrideGraphicSettings.SetCutForegroundPatternColor Method

OverrideGraphicSettingsSetCutForegroundPatternColor Method

Sets the override color of the foreground pattern of cut faces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OverrideGraphicSettings SetCutForegroundPatternColor(
    Color color
)
Public Function SetCutForegroundPatternColor (
    color As Color
) As OverrideGraphicSettings
public:
OverrideGraphicSettings^ SetCutForegroundPatternColor(
    Color^ color
)
member SetCutForegroundPatternColor :
        color : Color -> OverrideGraphicSettings

Parameters

color Color
Value of the cut face foreground color for the override. InvalidColorValue means no override is set.

Return Value

OverrideGraphicSettings
Reference to the changed object.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

OverrideGraphicSettings Class


OverrideGraphicSettings.SetCutForegroundPatternId Method

OverrideGraphicSettingsSetCutForegroundPatternId Method

Sets the ElementId of the cut face foreground pattern override. The fill pattern must be a drafting pattern. A value of InvalidElementId means no override is set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OverrideGraphicSettings SetCutForegroundPatternId(
    ElementId fillPatternId
)
Public Function SetCutForegroundPatternId (
    fillPatternId As ElementId
) As OverrideGraphicSettings
public:
OverrideGraphicSettings^ SetCutForegroundPatternId(
    ElementId^ fillPatternId
)
member SetCutForegroundPatternId :
        fillPatternId : ElementId -> OverrideGraphicSettings

Parameters

fillPatternId ElementId
Value of the cut face foreground fill pattern override.

Return Value

OverrideGraphicSettings
Reference to the changed object.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

OverrideGraphicSettings Class


OverrideGraphicSettings.SetCutForegroundPatternVisible Method

OverrideGraphicSettingsSetCutForegroundPatternVisible Method

Sets the visibility of the cut face foreground fill pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OverrideGraphicSettings SetCutForegroundPatternVisible(
    bool fillPatternVisible
)
Public Function SetCutForegroundPatternVisible (
    fillPatternVisible As Boolean
) As OverrideGraphicSettings
public:
OverrideGraphicSettings^ SetCutForegroundPatternVisible(
    bool fillPatternVisible
)
member SetCutForegroundPatternVisible :
        fillPatternVisible : bool -> OverrideGraphicSettings

Parameters

fillPatternVisible Boolean
Value of the visibility of the cut face foreground fill pattern.

Return Value

OverrideGraphicSettings
Reference to the changed object.
See Also

Reference

OverrideGraphicSettings Class


OverrideGraphicSettings.SetCutLineColor Method

OverrideGraphicSettingsSetCutLineColor Method

Sets the cut surface line color.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OverrideGraphicSettings SetCutLineColor(
    Color color
)
Public Function SetCutLineColor (
    color As Color
) As OverrideGraphicSettings
public:
OverrideGraphicSettings^ SetCutLineColor(
    Color^ color
)
member SetCutLineColor :
        color : Color -> OverrideGraphicSettings

Parameters

color Color
Value of the cut surface line color for the override. InvalidColorValue means no override is set.

Return Value

OverrideGraphicSettings
Reference to the changed object.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

OverrideGraphicSettings Class


OverrideGraphicSettings.SetCutLinePatternId Method

OverrideGraphicSettingsSetCutLinePatternId Method

Sets the ElementId of the cut surface line pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OverrideGraphicSettings SetCutLinePatternId(
    ElementId linePatternId
)
Public Function SetCutLinePatternId (
    linePatternId As ElementId
) As OverrideGraphicSettings
public:
OverrideGraphicSettings^ SetCutLinePatternId(
    ElementId^ linePatternId
)
member SetCutLinePatternId :
        linePatternId : ElementId -> OverrideGraphicSettings

Parameters

linePatternId ElementId
ElementId of the cut surface line pattern for the override. InvalidElementId means no override is set.

Return Value

OverrideGraphicSettings
Reference to the changed object.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

OverrideGraphicSettings Class


OverrideGraphicSettings.SetCutLineWeight Method

OverrideGraphicSettingsSetCutLineWeight Method

Sets the cut surface line weight.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OverrideGraphicSettings SetCutLineWeight(
    int lineWeight
)
Public Function SetCutLineWeight (
    lineWeight As Integer
) As OverrideGraphicSettings
public:
OverrideGraphicSettings^ SetCutLineWeight(
    int lineWeight
)
member SetCutLineWeight :
        lineWeight : int -> OverrideGraphicSettings

Parameters

lineWeight Int32
Value of the cut surface line weight for the override. InvalidPenNumber means no override is set.

Return Value

OverrideGraphicSettings
Reference to the changed object.
Exceptions
Exception | Condition
ArgumentException | Line weight must be a positive integer less than 17 or invalidPenNumber.
See Also

Reference

OverrideGraphicSettings Class


OverrideGraphicSettings.SetDetailLevel Method

OverrideGraphicSettingsSetDetailLevel Method

Sets the detail level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OverrideGraphicSettings SetDetailLevel(
    ViewDetailLevel detailLevel
)
Public Function SetDetailLevel (
    detailLevel As ViewDetailLevel
) As OverrideGraphicSettings
public:
OverrideGraphicSettings^ SetDetailLevel(
    ViewDetailLevel detailLevel
)
member SetDetailLevel :
        detailLevel : ViewDetailLevel -> OverrideGraphicSettings

Parameters

detailLevel ViewDetailLevel
Value of the detail level. ViewDetailLevel.Undefined means no override is set.

Return Value

OverrideGraphicSettings
Reference to the changed object.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

OverrideGraphicSettings Class


OverrideGraphicSettings.SetHalftone Method

OverrideGraphicSettingsSetHalftone Method

Sets the halftone value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OverrideGraphicSettings SetHalftone(
    bool halftone
)
Public Function SetHalftone (
    halftone As Boolean
) As OverrideGraphicSettings
public:
OverrideGraphicSettings^ SetHalftone(
    bool halftone
)
member SetHalftone :
        halftone : bool -> OverrideGraphicSettings

Parameters

halftone Boolean
True if the override displays in halftone, false otherwise.

Return Value

OverrideGraphicSettings
Reference to the changed object.
See Also

Reference

OverrideGraphicSettings Class


OverrideGraphicSettings.SetProjectionLineColor Method

OverrideGraphicSettingsSetProjectionLineColor Method

Sets the projection surface line color.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OverrideGraphicSettings SetProjectionLineColor(
    Color color
)
Public Function SetProjectionLineColor (
    color As Color
) As OverrideGraphicSettings
public:
OverrideGraphicSettings^ SetProjectionLineColor(
    Color^ color
)
member SetProjectionLineColor :
        color : Color -> OverrideGraphicSettings

Parameters

color Color
Value of the projection surface line color for the override. InvalidColorValue means no override is set.

Return Value

OverrideGraphicSettings
Reference to the changed object.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

OverrideGraphicSettings Class


OverrideGraphicSettings.SetProjectionLinePatternId Method

OverrideGraphicSettingsSetProjectionLinePatternId Method

Sets the ElementId of the projection surface line pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OverrideGraphicSettings SetProjectionLinePatternId(
    ElementId linePatternId
)
Public Function SetProjectionLinePatternId (
    linePatternId As ElementId
) As OverrideGraphicSettings
public:
OverrideGraphicSettings^ SetProjectionLinePatternId(
    ElementId^ linePatternId
)
member SetProjectionLinePatternId :
        linePatternId : ElementId -> OverrideGraphicSettings

Parameters

linePatternId ElementId
ElementId of the projection surface line pattern for the override. InvalidElementId means no override is set.

Return Value

OverrideGraphicSettings
Reference to the changed object.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

OverrideGraphicSettings Class


OverrideGraphicSettings.SetProjectionLineWeight Method

OverrideGraphicSettingsSetProjectionLineWeight Method

Sets the projection surface line weight.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OverrideGraphicSettings SetProjectionLineWeight(
    int lineWeight
)
Public Function SetProjectionLineWeight (
    lineWeight As Integer
) As OverrideGraphicSettings
public:
OverrideGraphicSettings^ SetProjectionLineWeight(
    int lineWeight
)
member SetProjectionLineWeight :
        lineWeight : int -> OverrideGraphicSettings

Parameters

lineWeight Int32
Value of the projection surface line weight for the override. InvalidPenNumber means no override is set.

Return Value

OverrideGraphicSettings
Reference to the changed object.
Exceptions
Exception | Condition
ArgumentException | Line weight must be a positive integer less than 17 or invalidPenNumber.
See Also

Reference

OverrideGraphicSettings Class


OverrideGraphicSettings.SetSurfaceBackgroundPatternColor Method

OverrideGraphicSettingsSetSurfaceBackgroundPatternColor Method

Sets the override color of the surface background pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OverrideGraphicSettings SetSurfaceBackgroundPatternColor(
    Color color
)
Public Function SetSurfaceBackgroundPatternColor (
    color As Color
) As OverrideGraphicSettings
public:
OverrideGraphicSettings^ SetSurfaceBackgroundPatternColor(
    Color^ color
)
member SetSurfaceBackgroundPatternColor :
        color : Color -> OverrideGraphicSettings

Parameters

color Color
Value of the surface background color for the override. InvalidColorValue means no override is set.

Return Value

OverrideGraphicSettings
Reference to the changed object.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

OverrideGraphicSettings Class


OverrideGraphicSettings.SetSurfaceBackgroundPatternId Method

OverrideGraphicSettingsSetSurfaceBackgroundPatternId Method

Sets the ElementId of the surface background pattern override. The fill pattern must be a drafting pattern. A value of InvalidElementId means no override is set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OverrideGraphicSettings SetSurfaceBackgroundPatternId(
    ElementId fillPatternId
)
Public Function SetSurfaceBackgroundPatternId (
    fillPatternId As ElementId
) As OverrideGraphicSettings
public:
OverrideGraphicSettings^ SetSurfaceBackgroundPatternId(
    ElementId^ fillPatternId
)
member SetSurfaceBackgroundPatternId :
        fillPatternId : ElementId -> OverrideGraphicSettings

Parameters

fillPatternId ElementId
Value of the surface background fill pattern override.

Return Value

OverrideGraphicSettings
Reference to the changed object.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

OverrideGraphicSettings Class


OverrideGraphicSettings.SetSurfaceBackgroundPatternVisible Method

OverrideGraphicSettingsSetSurfaceBackgroundPatternVisible Method

Sets the visibility of the surface background fill pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OverrideGraphicSettings SetSurfaceBackgroundPatternVisible(
    bool fillPatternVisible
)
Public Function SetSurfaceBackgroundPatternVisible (
    fillPatternVisible As Boolean
) As OverrideGraphicSettings
public:
OverrideGraphicSettings^ SetSurfaceBackgroundPatternVisible(
    bool fillPatternVisible
)
member SetSurfaceBackgroundPatternVisible :
        fillPatternVisible : bool -> OverrideGraphicSettings

Parameters

fillPatternVisible Boolean
Value of the visibility of the surface background fill pattern.

Return Value

OverrideGraphicSettings
Reference to the changed object.
See Also

Reference

OverrideGraphicSettings Class


OverrideGraphicSettings.SetSurfaceForegroundPatternColor Method

OverrideGraphicSettingsSetSurfaceForegroundPatternColor Method

Sets the override color of the surface foreground pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OverrideGraphicSettings SetSurfaceForegroundPatternColor(
    Color color
)
Public Function SetSurfaceForegroundPatternColor (
    color As Color
) As OverrideGraphicSettings
public:
OverrideGraphicSettings^ SetSurfaceForegroundPatternColor(
    Color^ color
)
member SetSurfaceForegroundPatternColor :
        color : Color -> OverrideGraphicSettings

Parameters

color Color
Value of the surface foreground color for the override. InvalidColorValue means no override is set.

Return Value

OverrideGraphicSettings
Reference to the changed object.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

OverrideGraphicSettings Class


OverrideGraphicSettings.SetSurfaceForegroundPatternId Method

OverrideGraphicSettingsSetSurfaceForegroundPatternId Method

Sets the ElementId of the surface foreground pattern override. The fill pattern must be a drafting pattern. A value of InvalidElementId means no override is set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OverrideGraphicSettings SetSurfaceForegroundPatternId(
    ElementId fillPatternId
)
Public Function SetSurfaceForegroundPatternId (
    fillPatternId As ElementId
) As OverrideGraphicSettings
public:
OverrideGraphicSettings^ SetSurfaceForegroundPatternId(
    ElementId^ fillPatternId
)
member SetSurfaceForegroundPatternId :
        fillPatternId : ElementId -> OverrideGraphicSettings

Parameters

fillPatternId ElementId
Value of the surface foreground fill pattern override.

Return Value

OverrideGraphicSettings
Reference to the changed object.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

OverrideGraphicSettings Class


OverrideGraphicSettings.SetSurfaceForegroundPatternVisible Method

OverrideGraphicSettingsSetSurfaceForegroundPatternVisible Method

Sets the visibility of the surface foreground fill pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OverrideGraphicSettings SetSurfaceForegroundPatternVisible(
    bool fillPatternVisible
)
Public Function SetSurfaceForegroundPatternVisible (
    fillPatternVisible As Boolean
) As OverrideGraphicSettings
public:
OverrideGraphicSettings^ SetSurfaceForegroundPatternVisible(
    bool fillPatternVisible
)
member SetSurfaceForegroundPatternVisible :
        fillPatternVisible : bool -> OverrideGraphicSettings

Parameters

fillPatternVisible Boolean
Value of the visibility of the surface foreground fill pattern.

Return Value

OverrideGraphicSettings
Reference to the changed object.
See Also

Reference

OverrideGraphicSettings Class


OverrideGraphicSettings.SetSurfaceTransparency Method

OverrideGraphicSettingsSetSurfaceTransparency Method

Sets the projection surface transparency.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OverrideGraphicSettings SetSurfaceTransparency(
    int transparency
)
Public Function SetSurfaceTransparency (
    transparency As Integer
) As OverrideGraphicSettings
public:
OverrideGraphicSettings^ SetSurfaceTransparency(
    int transparency
)
member SetSurfaceTransparency :
        transparency : int -> OverrideGraphicSettings

Parameters

transparency Int32
Value of the transparency of the projection surface (0 = opaque, 100 = fully transparent).

Return Value

OverrideGraphicSettings
Reference to the changed object.
Exceptions
Exception | Condition
ArgumentException | Transparency must be greater than 0 and less than 100.
See Also

Reference

OverrideGraphicSettings Class


OverridePermissions Enumeration

Types of overrides that can be applied to a category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum OverridePermissions
Public Enumeration OverridePermissions
public enum class OverridePermissions
type OverridePermissions
Members
Member name | Value | Description
ViewDetailLevel | 1 | View detail level
Halftone | 2 | Halftone
CutLines | 3 | Cut lines
CutFills | 4 | Cut fills
ProjectionLines | 5 | Projection lines
ProjectionFills | 6 | Projection fills
Surfaces | 7 | Surface transparency
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PageOrientationType Enumeration

An enumerated type listing all Page Orientation types of Print Setting

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum PageOrientationType
Public Enumeration PageOrientationType
public enum class PageOrientationType
type PageOrientationType
Members
Member name | Value | Description
Portrait | 0 | The type of Page Orientation is Portrait
Landscape | 1 | The type of Page Orientation is Landscape
Auto | 2 | Auto Page Orientation
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Panel Class

This object represents a curtain panel.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBInstance
Autodesk.Revit.DBFamilyInstance
Autodesk.Revit.DBPanel

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Panel : FamilyInstance
Public Class Panel
    Inherits FamilyInstance
public ref class Panel : public FamilyInstance
type Panel =
    class
        inherit FamilyInstance
    end

The Panel type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanFlipFacing | Property to test whether the orientation of family instance facing can be flipped. (Inherited from FamilyInstance)
Public property | CanFlipHand | Property to test whether the orientation of family instance hand can be flipped. (Inherited from FamilyInstance)
Public property | CanFlipWorkPlane | Identifies if the instance can flip its work plane. (Inherited from FamilyInstance)
Public property | CanRotate | Property to test whether the family instance can be rotated by 180 degrees. (Inherited from FamilyInstance)
Public property | CanSplit | Identifies whether a particular family instance can be split at a point on it's defining curve (by Split(Double)). (Inherited from FamilyInstance)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | ExtensionUtility | Property to check whether the instance can be extended and return the interface for extension operation. (Inherited from FamilyInstance)
Public property | FacingFlipped | Property to test whether the orientation of family instance facing is flipped. (Inherited from FamilyInstance)
Public property | FacingOrientation | Property to get the orientation of family instance facing. (Inherited from FamilyInstance)
Public property | FromRoom | The "From Room" set for the door or window in the last phase of the project. (Inherited from FamilyInstance)
Public property | FromRoomPhase | (Inherited from FamilyInstance)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HandFlipped | Property to test whether the orientation of family instance hand is flipped. (Inherited from FamilyInstance)
Public property | HandOrientation | Property to get the orientation of family instance hand. (Inherited from FamilyInstance)
Public property | HasSpatialElementCalculationPoint | Identifies if this instance has a single SpatialElementCalculationPoint used as the search point for Revit to identify if the instance is inside a room or space. (Inherited from FamilyInstance)
Public property | HasSpatialElementFromToCalculationPoints | Identifies if this instance has a pair of SpatialElementCalculationPoints used as the search points for Revit to identify if the instance lies between up to two rooms or spaces. (Inherited from FamilyInstance)
Public property | Host | If the instance is contained within another element, this property returns the containing element. An instance that is face hosted will return the element containing the face. (Inherited from FamilyInstance)
Public property | HostFace | Property to get the reference to the host face of family instance. (Inherited from FamilyInstance)
Public property | HostParameter | If the instance is hosted by a wall, this property returns the parameter value of the insertion point of the instance along the wall's location curve, as long as the family of the instance isn't work plane based. (Inherited from FamilyInstance)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | Invisible | Property to test whether the family instance is invisible. (Inherited from FamilyInstance)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsSlantedColumn | Indicates if the family instance is a slanted column. (Inherited from FamilyInstance)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | IsWorkPlaneFlipped | Identifies if the instance's work plane is flipped. (Inherited from FamilyInstance)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | Location | This property is used to find the physical location of an instance within project. (Inherited from FamilyInstance)
Public property | Lockable | This property is used to know whether a panel can be locked.
Public property | MEPModel | Retrieves the MEP model for the family instance. (Inherited from FamilyInstance)
Public property | Mirrored | Property to test whether the family instance is mirrored. (only one axis is flipped) (Inherited from FamilyInstance)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
Public property | PanelType | The Panel style of this Panel.
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Room | The room in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance)
Public property | RoomPhase | (Inherited from FamilyInstance)
Public property | Space | The space in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance)
Public property | SpacePhase | (Inherited from FamilyInstance)
Public property | StructuralMaterialId | Identifies the material that defines the instance's structural analysis properties. (Inherited from FamilyInstance)
Public property | StructuralMaterialType | This property returns the physical material from which the instance is made. (Inherited from FamilyInstance)
 | StructuralType | Provides the primary structural type of the instance, such as beam or column etc. (Inherited from FamilyInstance)
Public property | StructuralUsage | Provides the primary structural usage of the instance, such as brace, girder etc. (Inherited from FamilyInstance)
Public property | SuperComponent | Property to get the super component of current family instance. (Inherited from FamilyInstance)
 | Symbol | Returns or changes the FamilySymbol object that represents the type of the instance. (Inherited from FamilyInstance)
Public property | ToRoom | The "To Room" set for the door or window in the last phase of the project. (Inherited from FamilyInstance)
Public property | ToRoomPhase | (Inherited from FamilyInstance)
Public property | Transform | This property is used to find the transform of a curtain panel within project.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | AddCoping | Adds a coping (cut) to a steel beam. (Inherited from FamilyInstance)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FindHostPanel | Finds the id of the host panel (i.e., wall) associated with this panel. If a host panel is present, then it is displayed instead of the curtain panel.
Public method | flipFacing | The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance)
Public method | FlipFromToRoom | Flips the settings of "From Room" and "To Room" for the door or window instance. (Inherited from FamilyInstance)
Public method | flipHand | The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance)
Public method | GetCopingIds | Lists the elements currently used as coping cutters for this element. (Inherited from FamilyInstance)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFamilyPointPlacementReferences | Returns the Point Placement References for the Family Instance. (Inherited from FamilyInstance)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetOriginalGeometry | Returns the original geometry of the instance, before the instance is modified by joins, cuts, coping, extensions, or other post-processing. (Inherited from FamilyInstance)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetReferenceByName | Gets the family instance reference corresponding to the named reference plane in the instance's family. (Inherited from FamilyInstance)
Public method | GetReferenceName | Gets the name of the reference plane in the family corresponding to the given family instance reference. (Inherited from FamilyInstance)
Public method | GetReferences | Gets family instance references corresponding to the reference planes or reference lines of the given reference type in the instance's family. (Inherited from FamilyInstance)
Public method | GetReferenceType | Gets the type of the reference plane or reference line in the instance's family corresponding to the given family instance reference. (Inherited from FamilyInstance)
Public method | GetRefGridLines | This method is used to get the reference gridlines.
Public method | GetSpatialElementCalculationPoint | Gets the location of the calculation point for this instance. (Inherited from FamilyInstance)
Public method | GetSpatialElementFromToCalculationPoints | Gets the locations for the calculation points for this instance. (Inherited from FamilyInstance)
 | GetSubComponentIds | Gets the sub component ElementIds of the current family instance. (Inherited from FamilyInstance)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetSweptProfile | Gets the object that describes the profile that is swept along the driving curve for this instance. (Inherited from FamilyInstance)
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances. (Inherited from Instance)
Public method | GetTransform | Gets the transform of the instance. (Inherited from Instance)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasModifiedGeometry | Identifies if the geometry of this FamilyInstance has been modified from the automatically generated default. (Inherited from FamilyInstance)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasSweptProfile | Indicates if this instance can be represented as a swept profile. (Inherited from FamilyInstance)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveCoping | Removes a coping (cut) from a steel beam. (Inherited from FamilyInstance)
Public method | rotate | The family instance will be flipped by 180 degrees. If it can not be rotated, return false, otherwise return true. (Inherited from FamilyInstance)
Public method | SetCopingIds | Specifies the set of coping cutters on this element. (Inherited from FamilyInstance)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | Split | Splits the family instance element at a point on its defining curve. (Inherited from FamilyInstance)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Panel Properties

The Panel type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanFlipFacing | Property to test whether the orientation of family instance facing can be flipped. (Inherited from FamilyInstance)
Public property | CanFlipHand | Property to test whether the orientation of family instance hand can be flipped. (Inherited from FamilyInstance)
Public property | CanFlipWorkPlane | Identifies if the instance can flip its work plane. (Inherited from FamilyInstance)
Public property | CanRotate | Property to test whether the family instance can be rotated by 180 degrees. (Inherited from FamilyInstance)
Public property | CanSplit | Identifies whether a particular family instance can be split at a point on it's defining curve (by Split(Double)). (Inherited from FamilyInstance)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | ExtensionUtility | Property to check whether the instance can be extended and return the interface for extension operation. (Inherited from FamilyInstance)
Public property | FacingFlipped | Property to test whether the orientation of family instance facing is flipped. (Inherited from FamilyInstance)
Public property | FacingOrientation | Property to get the orientation of family instance facing. (Inherited from FamilyInstance)
Public property | FromRoom | The "From Room" set for the door or window in the last phase of the project. (Inherited from FamilyInstance)
Public property | FromRoomPhase | (Inherited from FamilyInstance)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HandFlipped | Property to test whether the orientation of family instance hand is flipped. (Inherited from FamilyInstance)
Public property | HandOrientation | Property to get the orientation of family instance hand. (Inherited from FamilyInstance)
Public property | HasSpatialElementCalculationPoint | Identifies if this instance has a single SpatialElementCalculationPoint used as the search point for Revit to identify if the instance is inside a room or space. (Inherited from FamilyInstance)
Public property | HasSpatialElementFromToCalculationPoints | Identifies if this instance has a pair of SpatialElementCalculationPoints used as the search points for Revit to identify if the instance lies between up to two rooms or spaces. (Inherited from FamilyInstance)
Public property | Host | If the instance is contained within another element, this property returns the containing element. An instance that is face hosted will return the element containing the face. (Inherited from FamilyInstance)
Public property | HostFace | Property to get the reference to the host face of family instance. (Inherited from FamilyInstance)
Public property | HostParameter | If the instance is hosted by a wall, this property returns the parameter value of the insertion point of the instance along the wall's location curve, as long as the family of the instance isn't work plane based. (Inherited from FamilyInstance)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | Invisible | Property to test whether the family instance is invisible. (Inherited from FamilyInstance)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsSlantedColumn | Indicates if the family instance is a slanted column. (Inherited from FamilyInstance)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | IsWorkPlaneFlipped | Identifies if the instance's work plane is flipped. (Inherited from FamilyInstance)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | Location | This property is used to find the physical location of an instance within project. (Inherited from FamilyInstance)
Public property | Lockable | This property is used to know whether a panel can be locked.
Public property | MEPModel | Retrieves the MEP model for the family instance. (Inherited from FamilyInstance)
Public property | Mirrored | Property to test whether the family instance is mirrored. (only one axis is flipped) (Inherited from FamilyInstance)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
Public property | PanelType | The Panel style of this Panel.
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Room | The room in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance)
Public property | RoomPhase | (Inherited from FamilyInstance)
Public property | Space | The space in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance)
Public property | SpacePhase | (Inherited from FamilyInstance)
Public property | StructuralMaterialId | Identifies the material that defines the instance's structural analysis properties. (Inherited from FamilyInstance)
Public property | StructuralMaterialType | This property returns the physical material from which the instance is made. (Inherited from FamilyInstance)
 | StructuralType | Provides the primary structural type of the instance, such as beam or column etc. (Inherited from FamilyInstance)
Public property | StructuralUsage | Provides the primary structural usage of the instance, such as brace, girder etc. (Inherited from FamilyInstance)
Public property | SuperComponent | Property to get the super component of current family instance. (Inherited from FamilyInstance)
 | Symbol | Returns or changes the FamilySymbol object that represents the type of the instance. (Inherited from FamilyInstance)
Public property | ToRoom | The "To Room" set for the door or window in the last phase of the project. (Inherited from FamilyInstance)
Public property | ToRoomPhase | (Inherited from FamilyInstance)
Public property | Transform | This property is used to find the transform of a curtain panel within project.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

Panel Class


Panel.Lockable Property

PanelLockable Property

This property is used to know whether a panel can be locked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Lockable { get; }
Public ReadOnly Property Lockable As Boolean
    Get
public:
property bool Lockable {
    bool get ();
}
member Lockable : bool with get

Property Value

Boolean
Remarks
If the panel can be locked, return true, else false.
See Also

Reference

Panel Class


Panel.PanelType Property

PanelPanelType Property

The Panel style of this Panel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PanelType PanelType { get; set; }
Public Property PanelType As PanelType
    Get
    Set
public:
property PanelType^ PanelType {
    PanelType^ get ();
    void set (PanelType^ value);
}
member PanelType : PanelType with get, set

Property Value

PanelType
Remarks
The Symbol property can be used to retrieve the kind of the panel. This property can also be used to change the type of a panel by setting it to a different type. All the panel types in the project can be found using the Document.CurtainPanelTypes property.
See Also

Reference

Panel Class


Panel.Transform Property

PanelTransform Property

This property is used to find the transform of a curtain panel within project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Transform Transform { get; }
Public ReadOnly Property Transform As Transform
    Get
public:
property Transform^ Transform {
    Transform^ get ();
}
member Transform : Transform with get

Property Value

Transform
Remarks
The Transform property returns a Autodesk::Revit::DB::Transform object that can be used to find the transfer matrix of a curtain panel within the project.
See Also

Reference

Panel Class


Panel Methods

The Panel type exposes the following members.

Methods
 | Name | Description
Public method | AddCoping | Adds a coping (cut) to a steel beam. (Inherited from FamilyInstance)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FindHostPanel | Finds the id of the host panel (i.e., wall) associated with this panel. If a host panel is present, then it is displayed instead of the curtain panel.
Public method | flipFacing | The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance)
Public method | FlipFromToRoom | Flips the settings of "From Room" and "To Room" for the door or window instance. (Inherited from FamilyInstance)
Public method | flipHand | The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance)
Public method | GetCopingIds | Lists the elements currently used as coping cutters for this element. (Inherited from FamilyInstance)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFamilyPointPlacementReferences | Returns the Point Placement References for the Family Instance. (Inherited from FamilyInstance)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetOriginalGeometry | Returns the original geometry of the instance, before the instance is modified by joins, cuts, coping, extensions, or other post-processing. (Inherited from FamilyInstance)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetReferenceByName | Gets the family instance reference corresponding to the named reference plane in the instance's family. (Inherited from FamilyInstance)
Public method | GetReferenceName | Gets the name of the reference plane in the family corresponding to the given family instance reference. (Inherited from FamilyInstance)
Public method | GetReferences | Gets family instance references corresponding to the reference planes or reference lines of the given reference type in the instance's family. (Inherited from FamilyInstance)
Public method | GetReferenceType | Gets the type of the reference plane or reference line in the instance's family corresponding to the given family instance reference. (Inherited from FamilyInstance)
Public method | GetRefGridLines | This method is used to get the reference gridlines.
Public method | GetSpatialElementCalculationPoint | Gets the location of the calculation point for this instance. (Inherited from FamilyInstance)
Public method | GetSpatialElementFromToCalculationPoints | Gets the locations for the calculation points for this instance. (Inherited from FamilyInstance)
 | GetSubComponentIds | Gets the sub component ElementIds of the current family instance. (Inherited from FamilyInstance)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetSweptProfile | Gets the object that describes the profile that is swept along the driving curve for this instance. (Inherited from FamilyInstance)
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances. (Inherited from Instance)
Public method | GetTransform | Gets the transform of the instance. (Inherited from Instance)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasModifiedGeometry | Identifies if the geometry of this FamilyInstance has been modified from the automatically generated default. (Inherited from FamilyInstance)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasSweptProfile | Indicates if this instance can be represented as a swept profile. (Inherited from FamilyInstance)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveCoping | Removes a coping (cut) from a steel beam. (Inherited from FamilyInstance)
Public method | rotate | The family instance will be flipped by 180 degrees. If it can not be rotated, return false, otherwise return true. (Inherited from FamilyInstance)
Public method | SetCopingIds | Specifies the set of coping cutters on this element. (Inherited from FamilyInstance)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | Split | Splits the family instance element at a point on its defining curve. (Inherited from FamilyInstance)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Panel Class


Panel.FindHostPanel Method

PanelFindHostPanel Method

Finds the id of the host panel (i.e., wall) associated with this panel. If a host panel is present, then it is displayed instead of the curtain panel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId FindHostPanel()
Public Function FindHostPanel As ElementId
public:
ElementId^ FindHostPanel()
member FindHostPanel : unit -> ElementId

Return Value

ElementId
Element id of the host panel associated with this panel. Otherwise, InvalidElementId is returned
See Also

Reference

Panel Class


Panel.GetRefGridLines Method

PanelGetRefGridLines Method

This method is used to get the reference gridlines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void GetRefGridLines(
    ref ElementId uGridLineId,
    ref ElementId vGridLineId
)
Public Sub GetRefGridLines (
    ByRef uGridLineId As ElementId,
    ByRef vGridLineId As ElementId
)
public:
void GetRefGridLines(
    ElementId^% uGridLineId,
    ElementId^% vGridLineId
)
member GetRefGridLines :
        uGridLineId : ElementId byref *
        vGridLineId : ElementId byref -> unit

Parameters

uGridLineId ElementId
vGridLineId ElementId
See Also

Reference

Panel Class


PanelType Class

An object that represents a curtain panel type.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBInsertableObject
Autodesk.Revit.DBFamilySymbol
Autodesk.Revit.DBPanelType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PanelType : FamilySymbol
Public Class PanelType
    Inherits FamilySymbol
public ref class PanelType : public FamilySymbol
type PanelType =
    class
        inherit FamilySymbol
    end

The PanelType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | Family | The Family object to which the symbol belongs. (Inherited from FamilySymbol)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsActive | Identifies whether the symbol is active. (Inherited from FamilySymbol)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | StructuralMaterialType | This property returns the physical material from which the type is made. (Inherited from FamilySymbol)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | Activate | Activates the symbol to ensure that its geometry is accessible. (Inherited from FamilySymbol)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveStructuralSection | Identifies if this FamilySymbol can have a structural section. (Inherited from FamilySymbol)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFamilyPointLocations | Returns the Point Locations for the Family Symbol. (Inherited from FamilySymbol)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetStructuralSection | Gets the structural section from element. (Inherited from FamilySymbol)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetThermalProperties | Gets the thermal properties for the given FamilySymbol. (Inherited from FamilySymbol)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasThermalProperties | Identifies if this FamilySymbol can include thermal properties. (Inherited from FamilySymbol)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetStructuralSection | Sets the structural section in element. (Inherited from FamilySymbol)
Public method | SetThermalProperties | Sets the thermal properties for the given FamilySymbol. (Inherited from FamilySymbol)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PanelType Properties

The PanelType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | Family | The Family object to which the symbol belongs. (Inherited from FamilySymbol)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsActive | Identifies whether the symbol is active. (Inherited from FamilySymbol)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | StructuralMaterialType | This property returns the physical material from which the type is made. (Inherited from FamilySymbol)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

PanelType Class


PanelType Methods

The PanelType type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Activates the symbol to ensure that its geometry is accessible. (Inherited from FamilySymbol)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveStructuralSection | Identifies if this FamilySymbol can have a structural section. (Inherited from FamilySymbol)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFamilyPointLocations | Returns the Point Locations for the Family Symbol. (Inherited from FamilySymbol)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetStructuralSection | Gets the structural section from element. (Inherited from FamilySymbol)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetThermalProperties | Gets the thermal properties for the given FamilySymbol. (Inherited from FamilySymbol)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasThermalProperties | Identifies if this FamilySymbol can include thermal properties. (Inherited from FamilySymbol)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetStructuralSection | Sets the structural section in element. (Inherited from FamilySymbol)
Public method | SetThermalProperties | Sets the thermal properties for the given FamilySymbol. (Inherited from FamilySymbol)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PanelType Class


PanelTypeSet Class

A set that contains panel types.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBPanelTypeSet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PanelTypeSet : APIObject,
    IEnumerable
Public Class PanelTypeSet
    Inherits APIObject
    Implements IEnumerable
public ref class PanelTypeSet : public APIObject,
    IEnumerable
type PanelTypeSet =
    class
        inherit APIObject
        interface IEnumerable
    end

The PanelTypeSet type exposes the following members.

Constructors
 | Name | Description
Public method | PanelTypeSet | Initializes a new instance of the PanelTypeSet class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Size | Returns the number of panel types that are in the set.
Top
Methods
 | Name | Description
Public method | Clear | Removes every panel type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a panel type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase | Removes a specified panel type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified panel type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PanelTypeSet Constructor

Initializes a new instance of the PanelTypeSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PanelTypeSet()
Public Sub New
public:
PanelTypeSet()
new : unit -> PanelTypeSet
See Also

Reference

PanelTypeSet Class


PanelTypeSet Properties

The PanelTypeSet type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Size | Returns the number of panel types that are in the set.
Top
See Also

Reference

PanelTypeSet Class


PanelTypeSet.IsEmpty Property

PanelTypeSetIsEmpty Property

Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Boolean
Remarks
If the set is empty then True will be returned, otherwise False.
See Also

Reference

PanelTypeSet Class


PanelTypeSet.Size Property

PanelTypeSetSize Property

Returns the number of panel types that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
abstract Size : int with get
override Size : int with get

Property Value

Int32
See Also

Reference

PanelTypeSet Class


PanelTypeSet Methods

The PanelTypeSet type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Removes every panel type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a panel type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase | Removes a specified panel type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified panel type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PanelTypeSet Class


PanelTypeSet.Clear Method

PanelTypeSetClear Method

Removes every panel type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

PanelTypeSet Class


PanelTypeSet.Contains Method

PanelTypeSetContains Method

Tests for the existence of a panel type within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Contains(
    PanelType item
)
Public Overridable Function Contains (
    item As PanelType
) As Boolean
public:
virtual bool Contains(
    PanelType^ item
)
abstract Contains :
        item : PanelType -> bool
override Contains :
        item : PanelType -> bool

Parameters

item PanelType
The panel type to be searched for.

Return Value

Boolean
The Contains method returns True if the panel type is within the set, otherwise False.
See Also

Reference

PanelTypeSet Class


PanelTypeSet.Erase Method

PanelTypeSetErase Method

Removes a specified panel type from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Erase(
    PanelType item
)
Public Overridable Function Erase (
    item As PanelType
) As Integer
public:
virtual int Erase(
    PanelType^ item
)
abstract Erase :
        item : PanelType -> int
override Erase :
        item : PanelType -> int

Parameters

item PanelType
The panel type to be erased.

Return Value

Int32
The number of panel types that were erased from the set.
See Also

Reference

PanelTypeSet Class


PanelTypeSet.ForwardIterator Method

PanelTypeSetForwardIterator Method

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual PanelTypeSetIterator ForwardIterator()
Public Overridable Function ForwardIterator As PanelTypeSetIterator
public:
virtual PanelTypeSetIterator^ ForwardIterator()
abstract ForwardIterator : unit -> PanelTypeSetIterator
override ForwardIterator : unit -> PanelTypeSetIterator

Return Value

PanelTypeSetIterator
Returns a forward moving iterator to the set.
See Also

Reference

PanelTypeSet Class


PanelTypeSet.GetEnumerator Method

PanelTypeSetGetEnumerator Method

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

IEnumerator
Returns a forward moving iterator to the set.

Implements

IEnumerableGetEnumerator
See Also

Reference

PanelTypeSet Class


PanelTypeSet.Insert Method

PanelTypeSetInsert Method

Insert the specified panel type into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Insert(
    PanelType item
)
Public Overridable Function Insert (
    item As PanelType
) As Boolean
public:
virtual bool Insert(
    PanelType^ item
)
abstract Insert :
        item : PanelType -> bool
override Insert :
        item : PanelType -> bool

Parameters

item PanelType
The panel type to be inserted into the set.

Return Value

Boolean
Returns whether the panel type was inserted into the set.
See Also

Reference

PanelTypeSet Class


PanelTypeSet.ReverseIterator Method

PanelTypeSetReverseIterator Method

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual PanelTypeSetIterator ReverseIterator()
Public Overridable Function ReverseIterator As PanelTypeSetIterator
public:
virtual PanelTypeSetIterator^ ReverseIterator()
abstract ReverseIterator : unit -> PanelTypeSetIterator
override ReverseIterator : unit -> PanelTypeSetIterator

Return Value

PanelTypeSetIterator
Returns a backward moving iterator to the set.
See Also

Reference

PanelTypeSet Class


PanelTypeSetIterator Class

An iterator to a panel type set.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBPanelTypeSetIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class PanelTypeSetIterator : APIObject,
    IEnumerator
Public MustInherit Class PanelTypeSetIterator
    Inherits APIObject
    Implements IEnumerator
public ref class PanelTypeSetIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type PanelTypeSetIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The PanelTypeSetIterator type exposes the following members.

Constructors
 | Name | Description
Public method | PanelTypeSetIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PanelTypeSetIterator Constructor

For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PanelTypeSetIterator()
Public Sub New
public:
PanelTypeSetIterator()
new : unit -> PanelTypeSetIterator
Remarks
This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.
See Also

Reference

PanelTypeSetIterator Class


PanelTypeSetIterator Properties

The PanelTypeSetIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

PanelTypeSetIterator Class


PanelTypeSetIterator.Current Property

PanelTypeSetIteratorCurrent Property

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}
abstract Current : Object with get
override Current : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.
See Also

Reference

PanelTypeSetIterator Class


PanelTypeSetIterator Methods

The PanelTypeSetIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PanelTypeSetIterator Class


PanelTypeSetIterator.MoveNext Method

PanelTypeSetIteratorMoveNext Method

Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumeratorMoveNext
Remarks
MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.
See Also

Reference

PanelTypeSetIterator Class


PanelTypeSetIterator.Reset Method

PanelTypeSetIteratorReset Method

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
Remarks
The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.
See Also

Reference

PanelTypeSetIterator Class


PaperPlacementType Enumeration

An enumerated type listing all Paper Placement types of Print Setting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum PaperPlacementType
Public Enumeration PaperPlacementType
public enum class PaperPlacementType
type PaperPlacementType
Members
Member name | Value | Description
Center | 0 | The type of Paper Placement is Center.
LowerLeft | 1 | The type of Paper Placement is LowerLeft.
Margins | 1 | The type of Paper Placement is Margins. It's obsolete, use LowerLeft instead.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PaperSize Class

An object that represents a Paper Size of Print Setup within the Autodesk Revit project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBPaperSize

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PaperSize : APIObject
Public Class PaperSize
    Inherits APIObject
public ref class PaperSize : public APIObject
type PaperSize =
    class
        inherit APIObject
    end

The PaperSize type exposes the following members.

Properties
 | Name | Description
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Name | Retrieve the paper size name of current project.
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This object derived from the APIObject base object.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PaperSize Properties

The PaperSize type exposes the following members.

Properties
 | Name | Description
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Name | Retrieve the paper size name of current project.
Top
See Also

Reference

PaperSize Class


PaperSize.Name Property

PaperSizeName Property

Retrieve the paper size name of current project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

String
See Also

Reference

PaperSize Class


PaperSize Methods

The PaperSize type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PaperSize Class


PaperSizeSet Class

A set that can contain any number of paper size objects.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBPaperSizeSet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PaperSizeSet : APIObject,
    IEnumerable
Public Class PaperSizeSet
    Inherits APIObject
    Implements IEnumerable
public ref class PaperSizeSet : public APIObject,
    IEnumerable
type PaperSizeSet =
    class
        inherit APIObject
        interface IEnumerable
    end

The PaperSizeSet type exposes the following members.

Constructors
 | Name | Description
Public method | PaperSizeSet | Initializes a new instance of the PaperSizeSet class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Size | Returns the number of objects that are in the set.
Top
Methods
 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of an item within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase | Removes a specified object from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified item into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PaperSizeSet Constructor

Initializes a new instance of the PaperSizeSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PaperSizeSet()
Public Sub New
public:
PaperSizeSet()
new : unit -> PaperSizeSet
See Also

Reference

PaperSizeSet Class


PaperSizeSet Properties

The PaperSizeSet type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Size | Returns the number of objects that are in the set.
Top
See Also

Reference

PaperSizeSet Class


PaperSizeSet.IsEmpty Property

PaperSizeSetIsEmpty Property

Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Boolean
Remarks
If the set is empty then True will be returned, otherwise False.
See Also

Reference

PaperSizeSet Class


PaperSizeSet.Size Property

PaperSizeSetSize Property

Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
abstract Size : int with get
override Size : int with get

Property Value

Int32
See Also

Reference

PaperSizeSet Class


PaperSizeSet Methods

The PaperSizeSet type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of an item within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase | Removes a specified object from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified item into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PaperSizeSet Class


PaperSizeSet.Clear Method

PaperSizeSetClear Method

Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

PaperSizeSet Class


PaperSizeSet.Contains Method

PaperSizeSetContains Method

Tests for the existence of an item within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Contains(
    PaperSize item
)
Public Overridable Function Contains (
    item As PaperSize
) As Boolean
public:
virtual bool Contains(
    PaperSize^ item
)
abstract Contains :
        item : PaperSize -> bool
override Contains :
        item : PaperSize -> bool

Parameters

item PaperSize
The item to be searched for.

Return Value

Boolean
The Contains method returns True if the item is within the set, otherwise False.
See Also

Reference

PaperSizeSet Class


PaperSizeSet.Erase Method

PaperSizeSetErase Method

Removes a specified object from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Erase(
    PaperSize item
)
Public Overridable Function Erase (
    item As PaperSize
) As Integer
public:
virtual int Erase(
    PaperSize^ item
)
abstract Erase :
        item : PaperSize -> int
override Erase :
        item : PaperSize -> int

Parameters

item PaperSize
The item to be erased.

Return Value

Int32
The number of items that were erased from the set.
See Also

Reference

PaperSizeSet Class


PaperSizeSet.ForwardIterator Method

PaperSizeSetForwardIterator Method

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual PaperSizeSetIterator ForwardIterator()
Public Overridable Function ForwardIterator As PaperSizeSetIterator
public:
virtual PaperSizeSetIterator^ ForwardIterator()
abstract ForwardIterator : unit -> PaperSizeSetIterator
override ForwardIterator : unit -> PaperSizeSetIterator

Return Value

PaperSizeSetIterator
Returns a forward moving iterator to the set.
See Also

Reference

PaperSizeSet Class


PaperSizeSet.GetEnumerator Method

PaperSizeSetGetEnumerator Method

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

IEnumerator
Returns a forward moving iterator to the set.

Implements

IEnumerableGetEnumerator
See Also

Reference

PaperSizeSet Class


PaperSizeSet.Insert Method

PaperSizeSetInsert Method

Insert the specified item into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Insert(
    PaperSize item
)
Public Overridable Function Insert (
    item As PaperSize
) As Boolean
public:
virtual bool Insert(
    PaperSize^ item
)
abstract Insert :
        item : PaperSize -> bool
override Insert :
        item : PaperSize -> bool

Parameters

item PaperSize
The item to be inserted into the set.

Return Value

Boolean
Returns whether the item was inserted into the set.
See Also

Reference

PaperSizeSet Class


PaperSizeSet.ReverseIterator Method

PaperSizeSetReverseIterator Method

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual PaperSizeSetIterator ReverseIterator()
Public Overridable Function ReverseIterator As PaperSizeSetIterator
public:
virtual PaperSizeSetIterator^ ReverseIterator()
abstract ReverseIterator : unit -> PaperSizeSetIterator
override ReverseIterator : unit -> PaperSizeSetIterator

Return Value

PaperSizeSetIterator
Returns a backward moving iterator to the set.
See Also

Reference

PaperSizeSet Class


PaperSizeSetIterator Class

An iterator to a set of paper size objects.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBPaperSizeSetIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class PaperSizeSetIterator : APIObject,
    IEnumerator
Public MustInherit Class PaperSizeSetIterator
    Inherits APIObject
    Implements IEnumerator
public ref class PaperSizeSetIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type PaperSizeSetIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The PaperSizeSetIterator type exposes the following members.

Constructors
 | Name | Description
Public method | PaperSizeSetIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PaperSizeSetIterator Constructor

For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PaperSizeSetIterator()
Public Sub New
public:
PaperSizeSetIterator()
new : unit -> PaperSizeSetIterator
Remarks
This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.
See Also

Reference

PaperSizeSetIterator Class


PaperSizeSetIterator Properties

The PaperSizeSetIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

PaperSizeSetIterator Class


PaperSizeSetIterator.Current Property

PaperSizeSetIteratorCurrent Property

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}
abstract Current : Object with get
override Current : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.
See Also

Reference

PaperSizeSetIterator Class


PaperSizeSetIterator Methods

The PaperSizeSetIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PaperSizeSetIterator Class


PaperSizeSetIterator.MoveNext Method

PaperSizeSetIteratorMoveNext Method

Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumeratorMoveNext
Remarks
MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.
See Also

Reference

PaperSizeSetIterator Class


PaperSizeSetIterator.Reset Method

PaperSizeSetIteratorReset Method

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
Remarks
The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.
See Also

Reference

PaperSizeSetIterator Class


PaperSource Class

An object that represents a Paper Source of Print Setup within the Autodesk Revit project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBPaperSource

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PaperSource : APIObject
Public Class PaperSource
    Inherits APIObject
public ref class PaperSource : public APIObject
type PaperSource =
    class
        inherit APIObject
    end

The PaperSource type exposes the following members.

Properties
 | Name | Description
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Name | Retrieve the paper source name of current project.
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This object derived from the APIObject base object.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PaperSource Properties

The PaperSource type exposes the following members.

Properties
 | Name | Description
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Name | Retrieve the paper source name of current project.
Top
See Also

Reference

PaperSource Class


PaperSource.Name Property

PaperSourceName Property

Retrieve the paper source name of current project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

String
See Also

Reference

PaperSource Class


PaperSource Methods

The PaperSource type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PaperSource Class


PaperSourceSet Class

A set that can contain any number of paper source objects.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBPaperSourceSet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PaperSourceSet : APIObject,
    IEnumerable
Public Class PaperSourceSet
    Inherits APIObject
    Implements IEnumerable
public ref class PaperSourceSet : public APIObject,
    IEnumerable
type PaperSourceSet =
    class
        inherit APIObject
        interface IEnumerable
    end

The PaperSourceSet type exposes the following members.

Constructors
 | Name | Description
Public method | PaperSourceSet | Initializes a new instance of the PaperSourceSet class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Size | Returns the number of objects that are in the set.
Top
Methods
 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of an item within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase | Removes a specified object from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PaperSourceSet Constructor

Initializes a new instance of the PaperSourceSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PaperSourceSet()
Public Sub New
public:
PaperSourceSet()
new : unit -> PaperSourceSet
See Also

Reference

PaperSourceSet Class


PaperSourceSet Properties

The PaperSourceSet type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Size | Returns the number of objects that are in the set.
Top
See Also

Reference

PaperSourceSet Class


PaperSourceSet.IsEmpty Property

PaperSourceSetIsEmpty Property

Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Boolean
Remarks
If the set is empty then True will be returned, otherwise False.
See Also

Reference

PaperSourceSet Class


PaperSourceSet.Size Property

PaperSourceSetSize Property

Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
abstract Size : int with get
override Size : int with get

Property Value

Int32
See Also

Reference

PaperSourceSet Class


PaperSourceSet Methods

The PaperSourceSet type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of an item within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase | Removes a specified object from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PaperSourceSet Class


PaperSourceSet.Clear Method

PaperSourceSetClear Method

Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

PaperSourceSet Class


PaperSourceSet.Contains Method

PaperSourceSetContains Method

Tests for the existence of an item within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Contains(
    PaperSource item
)
Public Overridable Function Contains (
    item As PaperSource
) As Boolean
public:
virtual bool Contains(
    PaperSource^ item
)
abstract Contains :
        item : PaperSource -> bool
override Contains :
        item : PaperSource -> bool

Parameters

item PaperSource
The item to be searched for.

Return Value

Boolean
The Contains method returns True if the item is within the set, otherwise False.
See Also

Reference

PaperSourceSet Class


PaperSourceSet.Erase Method

PaperSourceSetErase Method

Removes a specified object from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Erase(
    PaperSource item
)
Public Overridable Function Erase (
    item As PaperSource
) As Integer
public:
virtual int Erase(
    PaperSource^ item
)
abstract Erase :
        item : PaperSource -> int
override Erase :
        item : PaperSource -> int

Parameters

item PaperSource
The item to be erased.

Return Value

Int32
The number of items that were erased from the set.
See Also

Reference

PaperSourceSet Class


PaperSourceSet.ForwardIterator Method

PaperSourceSetForwardIterator Method

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual PaperSourceSetIterator ForwardIterator()
Public Overridable Function ForwardIterator As PaperSourceSetIterator
public:
virtual PaperSourceSetIterator^ ForwardIterator()
abstract ForwardIterator : unit -> PaperSourceSetIterator
override ForwardIterator : unit -> PaperSourceSetIterator

Return Value

PaperSourceSetIterator
Returns a forward moving iterator to the set.
See Also

Reference

PaperSourceSet Class


PaperSourceSet.GetEnumerator Method

PaperSourceSetGetEnumerator Method

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

IEnumerator
Returns a forward moving iterator to the set.

Implements

IEnumerableGetEnumerator
See Also

Reference

PaperSourceSet Class


PaperSourceSet.Insert Method

PaperSourceSetInsert Method

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Insert(
    PaperSource item
)
Public Overridable Function Insert (
    item As PaperSource
) As Boolean
public:
virtual bool Insert(
    PaperSource^ item
)
abstract Insert :
        item : PaperSource -> bool
override Insert :
        item : PaperSource -> bool

Parameters

item PaperSource

Return Value

Boolean
See Also

Reference

PaperSourceSet Class


PaperSourceSet.ReverseIterator Method

PaperSourceSetReverseIterator Method

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual PaperSourceSetIterator ReverseIterator()
Public Overridable Function ReverseIterator As PaperSourceSetIterator
public:
virtual PaperSourceSetIterator^ ReverseIterator()
abstract ReverseIterator : unit -> PaperSourceSetIterator
override ReverseIterator : unit -> PaperSourceSetIterator

Return Value

PaperSourceSetIterator
Returns a backward moving iterator to the set.
See Also

Reference

PaperSourceSet Class


PaperSourceSetIterator Class

An iterator to a set of paper source objects.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBPaperSourceSetIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class PaperSourceSetIterator : APIObject,
    IEnumerator
Public MustInherit Class PaperSourceSetIterator
    Inherits APIObject
    Implements IEnumerator
public ref class PaperSourceSetIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type PaperSourceSetIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The PaperSourceSetIterator type exposes the following members.

Constructors
 | Name | Description
Public method | PaperSourceSetIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PaperSourceSetIterator Constructor

For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PaperSourceSetIterator()
Public Sub New
public:
PaperSourceSetIterator()
new : unit -> PaperSourceSetIterator
Remarks
This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.
See Also

Reference

PaperSourceSetIterator Class


PaperSourceSetIterator Properties

The PaperSourceSetIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

PaperSourceSetIterator Class


PaperSourceSetIterator.Current Property

PaperSourceSetIteratorCurrent Property

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}
abstract Current : Object with get
override Current : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.
See Also

Reference

PaperSourceSetIterator Class


PaperSourceSetIterator Methods

The PaperSourceSetIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PaperSourceSetIterator Class


PaperSourceSetIterator.MoveNext Method

PaperSourceSetIteratorMoveNext Method

Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumeratorMoveNext
Remarks
MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.
See Also

Reference

PaperSourceSetIterator Class


PaperSourceSetIterator.Reset Method

PaperSourceSetIteratorReset Method

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
Remarks
The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.
See Also

Reference

PaperSourceSetIterator Class


Parameter Class

The parameter object contains the value data assigned to that parameter.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBParameter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Parameter : APIObject
Public Class Parameter
    Inherits APIObject
public ref class Parameter : public APIObject
type Parameter =
    class
        inherit APIObject
    end

The Parameter type exposes the following members.

Properties
 | Name | Description
Public property | Definition | Returns the Definition object that describes the data type, name and other details of the parameter.
Public property | Element | The element to which this parameter belongs.
Public property | GUID | The Guid for a shared parameter.
Public property | HasValue | Identifies if the parameter has an assigned value.
Public property | Id | The id of the parameter.
Public property | IsReadOnly | Get the readonly property of the parameter. (Overrides APIObjectIsReadOnly)
Public property | IsShared | Identifies if the parameter is a shared parameter.
Public property | StorageType | Describes the type that is used internally within the parameter to store its value.
Public property | UserModifiable | Indicates whether the interactive user can modify the value of this parameter.
Top
Methods
 | Name | Description
Public method | AsDouble | Provides access to the double precision number within the parameter.
Public method | AsElementId | Provides access to the Autodesk::Revit::DB::ElementId^ stored within the parameter.
Public method | AsInteger | Provides access to the integer number within the parameter.
Public method | AssociateWithGlobalParameter | Associates this parameter with a global parameter in the same document.
Public method | AsString | Provides access to the string contents of the parameter.
 | AsValueString | Get the parameter value as a string with units.
Public method | AsValueString(FormatOptions) | Get the parameter value as a string with units.
Public method | CanBeAssociatedWithGlobalParameter | Tests whether this parameter can be associated with the given global parameter.
Public method | CanBeAssociatedWithGlobalParameters | Tests whether this parameter can be associated with any global parameter.
Public method | ClearValue | Clears the parameter to its initial value.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | DissociateFromGlobalParameter | Dissociates this parameter from a global parameter.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAssociatedGlobalParameter | Returns a global parameter, if any, currently associated with this parameter.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeId | Gets the identifier of the parameter.
Public method | GetUnitTypeId | Gets the identifier of the unit quantifying the parameter value.
 | Set(Double) | Sets the parameter to a new real number value.
Public method | Set(ElementId) | Sets the parameter to a new element id.
Public method | Set(Int32) | Sets the parameter to a new integer value.
 | Set(String) | Sets the parameter to a new string of text.
 | SetMultiple | Sets multiple parameters to new values.
 | SetValueString | Set the parameter value according to the input string.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The piece of data contained within the parameter can be either a Double, Integer, String or ElementId. The parameter object can be retrieved from any Element object using either a built in id, definition object or shared parameter guid. All Elements within Autodesk Revit contain Parameters. These are options that can be accessed in a generic fashion. Revit contains many built in parameter types but users and now developers, via the API, can add their own parameters in the form of shared parameters. The developer should become familiar with the Revit user interface for added and managing parameters and shared parameters before using this API. The user interface components can be found in the following locations: Element Properties dialog, Shared Parameters dialog (available from the File menu), Project Parameters dialog (available from the Settings menu), Family Types dialog (available from the Settings menu when editing a family). There are several relationships between the objects that make up the APIs exposure of parameters. The parameter object contains the data value. Parameter objects can be retrieved from Elements if you know its built-in id, its definition or its shared parameter guid. Each parameter has a definition. New parameters can be added to Elements by adding a ParameterBinding object to the Document object.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Parameter Properties

The Parameter type exposes the following members.

Properties
 | Name | Description
Public property | Definition | Returns the Definition object that describes the data type, name and other details of the parameter.
Public property | Element | The element to which this parameter belongs.
Public property | GUID | The Guid for a shared parameter.
Public property | HasValue | Identifies if the parameter has an assigned value.
Public property | Id | The id of the parameter.
Public property | IsReadOnly | Get the readonly property of the parameter. (Overrides APIObjectIsReadOnly)
Public property | IsShared | Identifies if the parameter is a shared parameter.
Public property | StorageType | Describes the type that is used internally within the parameter to store its value.
Public property | UserModifiable | Indicates whether the interactive user can modify the value of this parameter.
Top
See Also

Reference

Parameter Class


Parameter.Definition Property

ParameterDefinition Property

Returns the Definition object that describes the data type, name and other details of the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Definition Definition { get; }
Public ReadOnly Property Definition As Definition
    Get
public:
property Definition^ Definition {
    Definition^ get ();
}
member Definition : Definition with get

Property Value

Definition
Remarks
This will always be an InternalDefinition object. If you want the Guid for a shared parameter, use GUID.
See Also

Reference

Parameter Class


Parameter.Element Property

ParameterElement Property

The element to which this parameter belongs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Element Element { get; }
Public ReadOnly Property Element As Element
    Get
public:
property Element^ Element {
    Element^ get ();
}
member Element : Element with get

Property Value

Element
See Also

Reference

Parameter Class


Parameter.GUID Property

ParameterGUID Property

The Guid for a shared parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid GUID { get; }
Public ReadOnly Property GUID As Guid
    Get
public:
property Guid GUID {
    Guid get ();
}
member GUID : Guid with get

Property Value

Guid
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the parameter is not a shared parameter.
See Also

Reference

Parameter Class


Parameter.HasValue Property

ParameterHasValue Property

Identifies if the parameter has an assigned value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasValue { get; }
Public ReadOnly Property HasValue As Boolean
    Get
public:
property bool HasValue {
    bool get ();
}
member HasValue : bool with get

Property Value

Boolean
See Also

Reference

Parameter Class


Parameter.Id Property

ParameterId Property

The id of the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId Id { get; }
Public ReadOnly Property Id As ElementId
    Get
public:
property ElementId^ Id {
    ElementId^ get ();
}
member Id : ElementId with get

Property Value

ElementId
See Also

Reference

Parameter Class


Parameter.IsReadOnly Property

ParameterIsReadOnly Property

Get the readonly property of the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool IsReadOnly { get; }
Public Overrides ReadOnly Property IsReadOnly As Boolean
    Get
public:
virtual property bool IsReadOnly {
    bool get () override;
}
abstract IsReadOnly : bool with get
override IsReadOnly : bool with get

Property Value

Boolean
Remarks
This function can be used to check if the parameter is read-only.
See Also

Reference

Parameter Class


Parameter.IsShared Property

ParameterIsShared Property

Identifies if the parameter is a shared parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsShared { get; }
Public ReadOnly Property IsShared As Boolean
    Get
public:
property bool IsShared {
    bool get ();
}
member IsShared : bool with get

Property Value

Boolean
See Also

Reference

Parameter Class


Parameter.StorageType Property

ParameterStorageType Property

Describes the type that is used internally within the parameter to store its value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public StorageType StorageType { get; }
Public ReadOnly Property StorageType As StorageType
    Get
public:
property StorageType StorageType {
    StorageType get ();
}
member StorageType : StorageType with get

Property Value

StorageType
Remarks
The property will return one of the following possibilities: String, Integer, Double or ElementId. Based on the value of this property the correct access and set methods should be used to retrieve and set the parameter's data value.
See Also

Reference

Parameter Class


Parameter.UserModifiable Property

ParameterUserModifiable Property

Indicates whether the interactive user can modify the value of this parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UserModifiable { get; }
Public ReadOnly Property UserModifiable As Boolean
    Get
public:
property bool UserModifiable {
    bool get ();
}
member UserModifiable : bool with get

Property Value

Boolean
Remarks
Note that for shared parameters IsReadOnly can return false for shared parameters whose UserModifiable property is also false, because the value of those parameters can be modified by the API. If a parameter is governed by a formula, IsReadOnly would return true, even if the flag for UserModifiable was set to true when the shared parameter was created.
See Also

Reference

Parameter Class


Parameter Methods

The Parameter type exposes the following members.

Methods
 | Name | Description
Public method | AsDouble | Provides access to the double precision number within the parameter.
Public method | AsElementId | Provides access to the Autodesk::Revit::DB::ElementId^ stored within the parameter.
Public method | AsInteger | Provides access to the integer number within the parameter.
Public method | AssociateWithGlobalParameter | Associates this parameter with a global parameter in the same document.
Public method | AsString | Provides access to the string contents of the parameter.
 | AsValueString | Get the parameter value as a string with units.
Public method | AsValueString(FormatOptions) | Get the parameter value as a string with units.
Public method | CanBeAssociatedWithGlobalParameter | Tests whether this parameter can be associated with the given global parameter.
Public method | CanBeAssociatedWithGlobalParameters | Tests whether this parameter can be associated with any global parameter.
Public method | ClearValue | Clears the parameter to its initial value.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | DissociateFromGlobalParameter | Dissociates this parameter from a global parameter.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAssociatedGlobalParameter | Returns a global parameter, if any, currently associated with this parameter.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetTypeId | Gets the identifier of the parameter.
Public method | GetUnitTypeId | Gets the identifier of the unit quantifying the parameter value.
 | Set(Double) | Sets the parameter to a new real number value.
Public method | Set(ElementId) | Sets the parameter to a new element id.
Public method | Set(Int32) | Sets the parameter to a new integer value.
 | Set(String) | Sets the parameter to a new string of text.
 | SetMultiple | Sets multiple parameters to new values.
 | SetValueString | Set the parameter value according to the input string.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Parameter Class


Parameter.AsDouble Method

ParameterAsDouble Method

Provides access to the double precision number within the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double AsDouble()
Public Function AsDouble As Double
public:
double AsDouble()
member AsDouble : unit -> float

Return Value

Double
The double value contained in the parameter.
Remarks
The AsDouble method should only be used if the StorageType property returns that the internal contents of the parameter is a double.
See Also

Reference

Parameter Class


Parameter.AsElementId Method

ParameterAsElementId Method

Provides access to the Autodesk::Revit::DB::ElementId^ stored within the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId AsElementId()
Public Function AsElementId As ElementId
public:
ElementId^ AsElementId()
member AsElementId : unit -> ElementId

Return Value

ElementId
The Autodesk::Revit::DB::ElementId^ contained in the parameter.
Remarks
The AsAutodesk::Revit::DB::ElementId^ method should only be used if the StorageType property returns that the internal contents of the parameter is an ElementId.
See Also

Reference

Parameter Class


Parameter.AsInteger Method

ParameterAsInteger Method

Provides access to the integer number within the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int AsInteger()
Public Function AsInteger As Integer
public:
int AsInteger()
member AsInteger : unit -> int

Return Value

Int32
The integer value contained in the parameter.
Remarks
The AsInteger method should only be used if the StorageType property returns that the internal contents of the parameter is an integer.
See Also

Reference

Parameter Class


Parameter.AssociateWithGlobalParameter Method

ParameterAssociateWithGlobalParameter Method

Associates this parameter with a global parameter in the same document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AssociateWithGlobalParameter(
    ElementId gpId
)
Public Sub AssociateWithGlobalParameter (
    gpId As ElementId
)
public:
void AssociateWithGlobalParameter(
    ElementId^ gpId
)
member AssociateWithGlobalParameter :
        gpId : ElementId -> unit

Parameters

gpId ElementId
Id of a global parameter contained in this parameter's document
Exceptions
Exception | Condition
ArgumentException | The input gpId is not of a valid global parameter of the given document. -or- This parameter does not exist in the document anymore. -or- This parameter is either not parameterizable or does not match the type of the global parameter.
ArgumentNullException | A non-optional argument was NULL
Remarks

The parameter must be parameterizable, meaning it cannot be read-only, driven by a formula, or have any other restrictions imposed by Revit.

The parameter's value type must match the type of the global parameter.

Once associated property can be later dissociated by calling the DissociateFromGlobalParameter method

See Also

Reference

Parameter Class


Parameter.AsString Method

ParameterAsString Method

Provides access to the string contents of the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string AsString()
Public Function AsString As String
public:
String^ AsString()
member AsString : unit -> string

Return Value

String
The string contained in the parameter.
Remarks
The AsString method should only be used if the StorageType property returns that the internal contents of the parameter is a string.
See Also

Reference

Parameter Class


Parameter.AsValueString Method

ParameterAsValueString Method

Overload List
 | Name | Description
 | AsValueString | Get the parameter value as a string with units.
Public method | AsValueString(FormatOptions) | Get the parameter value as a string with units.
Top
See Also

Reference

Parameter Class


Parameter.AsValueString Method

ParameterAsValueString Method

Get the parameter value as a string with units.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string AsValueString()
Public Function AsValueString As String
public:
String^ AsValueString()
member AsValueString : unit -> string

Return Value

String
The string that represents the parameter value.
Example
C#
VB
C++
F#
Copy
String ShowValueParameterInformation(Parameter attribute)
{
    string paramValue = null;
    switch (attribute.StorageType)
    {
        case StorageType.Integer:
            if (SpecTypeId.Boolean.YesNo
                                == attribute.Definition.GetDataType())
            {
                paramValue = null;
            }
            else
            {
                paramValue = attribute.AsValueString();
            }
            break;
        case StorageType.Double:
            paramValue = attribute.AsValueString();
            break;
        default:
            paramValue = null;
            break;
    }

    return paramValue;
}
Private Function ShowValueParameterInformation(attribute As Parameter) As [String]
    Dim paramValue As String = Nothing
    Select Case attribute.StorageType
        Case StorageType.[Integer]
            If SpecTypeId.Boolean.YesNo = attribute.Definition.GetDataType() Then
                paramValue = Nothing
            Else
                paramValue = attribute.AsValueString()
            End If
            Exit Select
        Case StorageType.[Double]
            paramValue = attribute.AsValueString()
            Exit Select
        Case Else
            paramValue = Nothing
            Exit Select
    End Select

    Return paramValue
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Parameter Class
AsValueString Overload


Parameter.AsValueString(FormatOptions) Method

ParameterAsValueString(FormatOptions) Method

Get the parameter value as a string with units.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string AsValueString(
    FormatOptions formatOptions
)
Public Function AsValueString (
    formatOptions As FormatOptions
) As String
public:
String^ AsValueString(
    FormatOptions^ formatOptions
)
member AsValueString :
        formatOptions : FormatOptions -> string

Parameters

formatOptions FormatOptions
Options for formatting the string.

Return Value

String
The string that represents the parameter value.
See Also

Reference

Parameter Class
AsValueString Overload


Parameter.CanBeAssociatedWithGlobalParameter Method

ParameterCanBeAssociatedWithGlobalParameter Method

Tests whether this parameter can be associated with the given global parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanBeAssociatedWithGlobalParameter(
    ElementId gpId
)
Public Function CanBeAssociatedWithGlobalParameter (
    gpId As ElementId
) As Boolean
public:
bool CanBeAssociatedWithGlobalParameter(
    ElementId^ gpId
)
member CanBeAssociatedWithGlobalParameter :
        gpId : ElementId -> bool

Parameters

gpId ElementId
Id of a global parameter contained in this parameter's document

Return Value

Boolean
True if this parameter can be associated with the given global parameter; False otherwise.
Exceptions
Exception | Condition
ArgumentException | The input gpId is not of a valid global parameter of the given document. -or- This parameter does not exist in the document anymore.
ArgumentNullException | A non-optional argument was NULL
Remarks
Only properties defined as parametrizable can be associated with global parameters. That excludes any read-only and formula-driven parameters, as well as those that have other explicit or implicit restrictions imposed by Revit.
See Also

Reference

Parameter Class


Parameter.CanBeAssociatedWithGlobalParameters Method

ParameterCanBeAssociatedWithGlobalParameters Method

Tests whether this parameter can be associated with any global parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanBeAssociatedWithGlobalParameters()
Public Function CanBeAssociatedWithGlobalParameters As Boolean
public:
bool CanBeAssociatedWithGlobalParameters()
member CanBeAssociatedWithGlobalParameters : unit -> bool

Return Value

Boolean
True if the given parameter can be associated (is parametrizable); False otherwise.
Exceptions
Exception | Condition
ArgumentException | This parameter does not exist in the document anymore.
Remarks
Only properties defined as parametrizable can be associated with global parameters. That excludes any read-only and formula-driven parameters, as well as those that have other explicit or implicit restrictions imposed by Revit.
See Also

Reference

Parameter Class


Parameter.ClearValue Method

ParameterClearValue Method

Clears the parameter to its initial value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ClearValue()
Public Function ClearValue As Boolean
public:
bool ClearValue()
member ClearValue : unit -> bool

Return Value

Boolean
The ClearValue method will return True if the parameter was successfully cleared to its initial value, otherwise false.
Exceptions
Exception | Condition
InvalidOperationException | The parameter is read-only, or the parameter is not a shared parameter, or the shared parameter has HideWhenNoValue set to false.
Remarks
This method will only succeed for Shared parameters that have their HideWhenNoValue property set to true.
See Also

Reference

Parameter Class


Parameter.DissociateFromGlobalParameter Method

ParameterDissociateFromGlobalParameter Method

Dissociates this parameter from a global parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void DissociateFromGlobalParameter()
Public Sub DissociateFromGlobalParameter
public:
void DissociateFromGlobalParameter()
member DissociateFromGlobalParameter : unit -> unit
Exceptions
Exception | Condition
ArgumentException | This parameter does not exist in the document anymore. -or- This parameter is either not parameterizable or does not match the type of the global parameter.
Remarks
It is assumed this parameter has been previously associated with the global parameter by using the [!:AssociateWithGlobalParameter(Revit::DB::ElementId^)] method.
See Also

Reference

Parameter Class


Parameter.GetAssociatedGlobalParameter Method

ParameterGetAssociatedGlobalParameter Method

Returns a global parameter, if any, currently associated with this parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GetAssociatedGlobalParameter()
Public Function GetAssociatedGlobalParameter As ElementId
public:
ElementId^ GetAssociatedGlobalParameter()
member GetAssociatedGlobalParameter : unit -> ElementId

Return Value

ElementId
Id of a global parameter or InvalidElemetnId.
Exceptions
Exception | Condition
ArgumentException | This parameter does not exist in the document anymore.
Remarks
InvalidElementId is returned in case this parameter is not associated with any global parameter. InvalidElementId is also returned if called for a parameter that cannot even be associated with a global parameters (i.e. a non-parametrizable parameter or parameter with a formula).
See Also

Reference

Parameter Class


Parameter.GetTypeId Method

ParameterGetTypeId Method

Gets the identifier of the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ForgeTypeId GetTypeId()
Public Function GetTypeId As ForgeTypeId
public:
ForgeTypeId^ GetTypeId()
member GetTypeId : unit -> ForgeTypeId

Return Value

ForgeTypeId
See Also

Reference

Parameter Class


Parameter.GetUnitTypeId Method

ParameterGetUnitTypeId Method

Gets the identifier of the unit quantifying the parameter value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ForgeTypeId GetUnitTypeId()
Public Function GetUnitTypeId As ForgeTypeId
public:
ForgeTypeId^ GetUnitTypeId()
member GetUnitTypeId : unit -> ForgeTypeId

Return Value

ForgeTypeId
Identifier of the unit of the parameter.
Exceptions
Exception | Condition
InvalidOperationException | Thrown if this parameter is not of value type.
Remarks
The property only applies to parameters of value types.
See Also

Reference

Parameter Class


Parameter.Set Method

ParameterSet Method

Sets the parameter to a new value.
Overload List
 | Name | Description
 | Set(Double) | Sets the parameter to a new real number value.
Public method | Set(ElementId) | Sets the parameter to a new element id.
Public method | Set(Int32) | Sets the parameter to a new integer value.
 | Set(String) | Sets the parameter to a new string of text.
Top
See Also

Reference

Parameter Class


Parameter.Set(Double) Method

ParameterSet(Double) Method

Sets the parameter to a new real number value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Set(
    double value
)
Public Function Set (
    value As Double
) As Boolean
public:
bool Set(
    double value
)
member Set :
        value : float -> bool

Parameters

value Double
The new double value to which the parameter is to be set.

Return Value

Boolean
The Set method will return True if the parameter was successfully set to the new value, otherwise false.
Exceptions
Exception | Condition
InvalidOperationException | The parameter is read-only.
ArgumentException | Value must be a finite number.
Remarks
You should only use this method if the StorageType property reports the type of the parameter as a Double.
Example
C#
VB
C++
F#
Copy
public bool SetParameter(Parameter parameter, double value)
{
    bool result = false;
    //if the parameter is readonly, you can�t change the value of it
    if (null != parameter && !parameter.IsReadOnly)
    {
        StorageType parameterType = parameter.StorageType;
        if (StorageType.Double != parameterType)
        {
            throw new Exception("The storagetypes of value and parameter are different!");
        }
        //If successful, the result is true
        result = parameter.Set(value);
    }

    return result;
}
Public Function SetParameter(parameter As Parameter, value As Double) As Boolean
    Dim result As Boolean = False
    'if the parameter is readonly, you can�t change the value of it
    If parameter IsNot Nothing AndAlso Not parameter.IsReadOnly Then
        Dim parameterType As StorageType = parameter.StorageType
        If StorageType.[Double] <> parameterType Then
            Throw New Exception("The storagetypes of value and parameter are different!")
        End If
        'If successful, the result is true
        result = parameter.[Set](value)
    End If

    Return result
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Parameter Class
Set Overload


Parameter.Set(ElementId) Method

ParameterSet(ElementId) Method

Sets the parameter to a new element id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Set(
    ElementId value
)
Public Function Set (
    value As ElementId
) As Boolean
public:
bool Set(
    ElementId^ value
)
member Set :
        value : ElementId -> bool

Parameters

value ElementId
The new element id to which the parameter is to be set.

Return Value

Boolean
The Set method will return True if the parameter was successfully set to the new value, otherwise false.
Exceptions
Exception | Condition
InvalidOperationException | The parameter is read-only.
Remarks
You should only use this method if the StorageType property reports the type of the parameter as an ElementId.
See Also

Reference

Parameter Class
Set Overload


Parameter.Set(Int32) Method

ParameterSet(Int32) Method

Sets the parameter to a new integer value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Set(
    int value
)
Public Function Set (
    value As Integer
) As Boolean
public:
bool Set(
    int value
)
member Set :
        value : int -> bool

Parameters

value Int32
The new integer value to which the parameter is to be set.

Return Value

Boolean
The Set method will return True if the parameter was successfully set to the new value, otherwise false.
Exceptions
Exception | Condition
InvalidOperationException | The parameter is read-only.
Remarks
You should only use this method if the StorageType property reports the type of the parameter as an integer.
See Also

Reference

Parameter Class
Set Overload


Parameter.Set(String) Method

ParameterSet(String) Method

Sets the parameter to a new string of text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Set(
    string value
)
Public Function Set (
    value As String
) As Boolean
public:
bool Set(
    String^ value
)
member Set :
        value : string -> bool

Parameters

value String
The new text value to which the parameter is to be set.

Return Value

Boolean
The Set method will return True if the parameter was successfully set to the new value, otherwise false.
Exceptions
Exception | Condition
InvalidOperationException | The parameter is read-only.
Remarks
You should only use this method if the StorageType property reports the type of the parameter as a String.
Example
C#
VB
C++
F#
Copy
void AddInstanceComment(Wall wall)
{
    // Get the comment parameter of the element instance
    Parameter commentPara = wall.get_Parameter(BuiltInParameter.ALL_MODEL_INSTANCE_COMMENTS);
    if (null != commentPara)
    {
        // Add a greeting string to the comment
        commentPara.Set("Hello Everyone.");
    }
}
Private Sub AddInstanceComment(wall As Wall)
    ' Get the comment parameter of the element instance
    Dim commentPara As Parameter = wall.Parameter(BuiltInParameter.ALL_MODEL_INSTANCE_COMMENTS)
    If commentPara IsNot Nothing Then
        ' Add a greeting string to the comment
        commentPara.[Set]("Hello Everyone.")
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Parameter Class
Set Overload


Parameter.SetMultiple Method

ParameterSetMultiple Method

Sets multiple parameters to new values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static List<Parameter> SetMultiple(
    IList<Tuple<Parameter, ParameterValue>> values
)
Public Shared Function SetMultiple (
    values As IList(Of Tuple(Of Parameter, ParameterValue))
) As List(Of Parameter)
public:
static List<Parameter^>^ SetMultiple(
    IList<Tuple<Parameter^, ParameterValue^>^>^ values
)
static member SetMultiple :
        values : IList<Tuple<Parameter, ParameterValue>> -> List<Parameter>

Parameters

values IList Tuple Parameter, ParameterValue
A list of pairs of parameters and their corresponding values.

Return Value

List Parameter
The list of parameters that were not set successfully, if any.
Exceptions
Exception | Condition
InvalidOperationException | The parameter is read-only.
ArgumentException | Value must be a finite number.
Remarks
This method is provided as a performance optimization. Note that it will throw an exception if any parameter would throw an exception, so validate ahead of time.
See Also

Reference

Parameter Class


Parameter.SetValueString Method

ParameterSetValueString Method

Set the parameter value according to the input string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SetValueString(
    string valueString
)
Public Function SetValueString (
    valueString As String
) As Boolean
public:
bool SetValueString(
    String^ valueString
)
member SetValueString :
        valueString : string -> bool

Parameters

valueString String
The string that represents the parameter value.

Return Value

Boolean
Indicates whether the parameter value is successfully set.
Remarks
The method only applies to parameters of value types.
Example
C#
VB
C++
F#
Copy
public bool SetWithValueString(Parameter foundParameter)
{
    bool result = false;
    if (!foundParameter.IsReadOnly)
    {
        //If successful, the result is true
        result = foundParameter.SetValueString("-22\'3\"");
    }
    return result;
}
Public Function SetWithValueString(foundParameter As Parameter) As Boolean
    Dim result As Boolean = False
    If Not foundParameter.IsReadOnly Then
        'If successful, the result is true
        result = foundParameter.SetValueString("-22'3""")
    End If
    Return result
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Parameter Class


ParameterDownloadOptions Class

An option class used for downloading parameters from the Parameters Service.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBParameterDownloadOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ParameterDownloadOptions : IDisposable
Public Class ParameterDownloadOptions
    Implements IDisposable
public ref class ParameterDownloadOptions : IDisposable
type ParameterDownloadOptions =
    class
        interface IDisposable
    end

The ParameterDownloadOptions type exposes the following members.

Constructors
 | Name | Description
Public method | ParameterDownloadOptions | Default constructor.
Public method | ParameterDownloadOptions(ISetElementId, Boolean, Boolean, ForgeTypeId) | Creates a new ParameterDownloadOptions instance. Category bindings are represented by an ElementIdSet populated with category identifiers.
Top
Properties
 | Name | Description
Public property | IsInstance | True if binding to Element instances, false if binding to Element types.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Visible | True if the parameter is visible to the user, false if it is hidden and accessible only via the API.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ParameterDownloadOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCategories | Get categories for binding.
Public method | GetGroupTypeId | Get properties palette group identifier.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetCategories | Set categories for binding.
Public method | SetGroupTypeId | Set properties palette group identifier.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ParameterDownloadOptions Constructor

Overload List
 | Name | Description
Public method | ParameterDownloadOptions | Default constructor.
Public method | ParameterDownloadOptions(ISetElementId, Boolean, Boolean, ForgeTypeId) | Creates a new ParameterDownloadOptions instance. Category bindings are represented by an ElementIdSet populated with category identifiers.
Top
See Also

Reference

ParameterDownloadOptions Class


ParameterDownloadOptions Constructor

Default constructor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ParameterDownloadOptions()
Public Sub New
public:
ParameterDownloadOptions()
new : unit -> ParameterDownloadOptions
See Also

Reference

ParameterDownloadOptions Class
ParameterDownloadOptions Overload


ParameterDownloadOptions(ISet<ElementId>, Boolean, Boolean, ForgeTypeId) Constructor

ParameterDownloadOptions(ISetElementId, Boolean, Boolean, ForgeTypeId) Constructor

Creates a new ParameterDownloadOptions instance. Category bindings are represented by an ElementIdSet populated with category identifiers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ParameterDownloadOptions(
    ISet<ElementId> categories,
    bool isInstance,
    bool visible,
    ForgeTypeId groupTypeId
)
Public Sub New (
    categories As ISet(Of ElementId),
    isInstance As Boolean,
    visible As Boolean,
    groupTypeId As ForgeTypeId
)
public:
ParameterDownloadOptions(
    ISet<ElementId^>^ categories,
    bool isInstance,
    bool visible,
    ForgeTypeId^ groupTypeId
)
new :
        categories : ISet<ElementId> *
        isInstance : bool *
        visible : bool *
        groupTypeId : ForgeTypeId -> ParameterDownloadOptions

Parameters

categories ISet ElementId
The category identifiers.
isInstance Boolean
True if binding to Element instances, false if binding to Element types.
visible Boolean
True if the parameter is visible to the user, false if it is hidden and accessible only via the API.
groupTypeId ForgeTypeId
Properties palette group identifier.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ParameterDownloadOptions Class
ParameterDownloadOptions Overload


ParameterDownloadOptions Properties

The ParameterDownloadOptions type exposes the following members.

Properties
 | Name | Description
Public property | IsInstance | True if binding to Element instances, false if binding to Element types.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Visible | True if the parameter is visible to the user, false if it is hidden and accessible only via the API.
Top
See Also

Reference

ParameterDownloadOptions Class


ParameterDownloadOptions.IsInstance Property

ParameterDownloadOptionsIsInstance Property

True if binding to Element instances, false if binding to Element types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsInstance { get; set; }
Public Property IsInstance As Boolean
    Get
    Set
public:
property bool IsInstance {
    bool get ();
    void set (bool value);
}
member IsInstance : bool with get, set

Property Value

Boolean
See Also

Reference

ParameterDownloadOptions Class


ParameterDownloadOptions.IsValidObject Property

ParameterDownloadOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ParameterDownloadOptions Class


ParameterDownloadOptions.Visible Property

ParameterDownloadOptionsVisible Property

True if the parameter is visible to the user, false if it is hidden and accessible only via the API.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Visible { get; set; }
Public Property Visible As Boolean
    Get
    Set
public:
property bool Visible {
    bool get ();
    void set (bool value);
}
member Visible : bool with get, set

Property Value

Boolean
See Also

Reference

ParameterDownloadOptions Class


ParameterDownloadOptions Methods

The ParameterDownloadOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCategories | Get categories for binding.
Public method | GetGroupTypeId | Get properties palette group identifier.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetCategories | Set categories for binding.
Public method | SetGroupTypeId | Set properties palette group identifier.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ParameterDownloadOptions Class


ParameterDownloadOptions.Dispose Method

ParameterDownloadOptionsDispose Method

Releases all resources used by the ParameterDownloadOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ParameterDownloadOptions Class


ParameterDownloadOptions.GetCategories Method

ParameterDownloadOptionsGetCategories Method

Get categories for binding.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ISet<ElementId> GetCategories()
Public Function GetCategories As ISet(Of ElementId)
public:
ISet<ElementId^>^ GetCategories()
member GetCategories : unit -> ISet<ElementId>

Return Value

ISet ElementId
See Also

Reference

ParameterDownloadOptions Class


ParameterDownloadOptions.GetGroupTypeId Method

ParameterDownloadOptionsGetGroupTypeId Method

Get properties palette group identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ForgeTypeId GetGroupTypeId()
Public Function GetGroupTypeId As ForgeTypeId
public:
ForgeTypeId^ GetGroupTypeId()
member GetGroupTypeId : unit -> ForgeTypeId

Return Value

ForgeTypeId
See Also

Reference

ParameterDownloadOptions Class


ParameterDownloadOptions.SetCategories Method

ParameterDownloadOptionsSetCategories Method

Set categories for binding.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetCategories(
    ISet<ElementId> categories
)
Public Sub SetCategories (
    categories As ISet(Of ElementId)
)
public:
void SetCategories(
    ISet<ElementId^>^ categories
)
member SetCategories :
        categories : ISet<ElementId> -> unit

Parameters

categories ISet ElementId
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ParameterDownloadOptions Class


ParameterDownloadOptions.SetGroupTypeId Method

ParameterDownloadOptionsSetGroupTypeId Method

Set properties palette group identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetGroupTypeId(
    ForgeTypeId groupTypeId
)
Public Sub SetGroupTypeId (
    groupTypeId As ForgeTypeId
)
public:
void SetGroupTypeId(
    ForgeTypeId^ groupTypeId
)
member SetGroupTypeId :
        groupTypeId : ForgeTypeId -> unit

Parameters

groupTypeId ForgeTypeId
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ParameterDownloadOptions Class


ParameterElement Class

An Element that stores a user-defined parameter.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBParameterElement
Autodesk.Revit.DBGlobalParameter
Autodesk.Revit.DBSharedParameterElement

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ParameterElement : Element
Public Class ParameterElement
    Inherits Element
public ref class ParameterElement : public Element
type ParameterElement =
    class
        inherit Element
    end

The ParameterElement type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
 | GetDefinition | Get the definition representing this parameter element.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Revit supports both built-in and user-defined parameters. Built-in parameters ship with the application, and they are not stored in Revit documents. User-defined parameters are dynamically created, and they are stored in the documents that use them, wrapped in ParameterElement objects. Different subclasses of ParemeterElement represent different kinds of user-defined parameters.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ParameterElement Properties

The ParameterElement type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

ParameterElement Class


ParameterElement Methods

The ParameterElement type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
 | GetDefinition | Get the definition representing this parameter element.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ParameterElement Class


ParameterElement.GetDefinition Method

ParameterElementGetDefinition Method

Get the definition representing this parameter element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public InternalDefinition GetDefinition()
Public Function GetDefinition As InternalDefinition
public:
InternalDefinition^ GetDefinition()
member GetDefinition : unit -> InternalDefinition

Return Value

InternalDefinition
The parameter.
Example
C#
VB
C++
F#
Copy
// Check if a given shared parameter in a schedule can vary across groups
public bool CanParamVaryAcrossGroups(ViewSchedule schedule, string sharedParamName)
{
    bool variesAcrossGroups = false;

    int numFields =  schedule.Definition.GetFieldCount();
    // Find the field with the given name
    for (int i = 0; i < numFields; i++)
    {
        ScheduleField field = schedule.Definition.GetField(i);
        if (field.GetName().Contains(sharedParamName))
        {
            // Get the SharedParameterElement from the field's parameter id
            SharedParameterElement spe = schedule.Document.GetElement(field.ParameterId) as SharedParameterElement;
            if (spe != null)
            {
                InternalDefinition definition = spe.GetDefinition();
                variesAcrossGroups = definition.VariesAcrossGroups;
            }
        }
    }

    return variesAcrossGroups;
}
  ' Check if a given shared parameter in a schedule can vary across groups
  Public Function CanParamVaryAcrossGroups(schedule As ViewSchedule, sharedParamName As String) As Boolean
   Dim variesAcrossGroups As Boolean = False

   Dim numFields As Integer = schedule.Definition.GetFieldCount()
   ' Find the field with the given name
   For i As Integer = 0 To numFields - 1
      Dim field As ScheduleField = schedule.Definition.GetField(i)
      If field.GetName().Contains(sharedParamName) Then
         ' Get the SharedParameterElement from the field's parameter id
         Dim spe As SharedParameterElement = TryCast(schedule.Document.GetElement(field.ParameterId), SharedParameterElement)
         If spe IsNot Nothing Then
            Dim definition As InternalDefinition = spe.GetDefinition()
            variesAcrossGroups = definition.VariesAcrossGroups
         End If
      End If
   Next

   Return variesAcrossGroups
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

ParameterElement Class


ParameterFilterElement Class

Admits elements that satisfy two conditions:
  1. The element's category must be one of a certain set of allowed categories.
  2. The element must pass a series of filter rules.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBFilterElement
Autodesk.Revit.DBParameterFilterElement

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ParameterFilterElement : FilterElement
Public Class ParameterFilterElement
    Inherits FilterElement
public ref class ParameterFilterElement : public FilterElement
type ParameterFilterElement =
    class
        inherit FilterElement
    end

The ParameterFilterElement type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | AllRuleParametersApplicable(ElementFilter) | Checks that the parameters of the rules used by the given ElementFilter are valid for this filter's categories.
 | AllRuleParametersApplicable(Document, ICollectionElementId, ElementFilter) | Checks that the parameters of the given ElementFilter (representing a combination of rules) are valid for the given set of categories.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | ClearRules | Removes all rules from this filter.
 | Create(Document, String, ICollectionElementId) | Creates a new ParameterFilterElement in the given document.
 | Create(Document, String, ICollectionElementId, ElementFilter) | Creates a new ParameterFilterElement in the given document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | ElementFilterIsAcceptableForParameterFilterElement(ElementFilter) | Checks that an ElementFilter is acceptable for use in defining the filtering rules for a ParameterFilterElement (i.e., for view filtering).
 | ElementFilterIsAcceptableForParameterFilterElement(Document, ISetElementId, ElementFilter) | Checks that an ElementFilter is acceptable for use in defining the filtering rules for a given list of categories (i.e., for view filtering).
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetCategories | Gets the categories admitted by this filter.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetElementFilter | Returns an ElementFilter representing the combination of rules used by this filter.
Public method | GetElementFilterParameters | Retrieves a list of the parameters associated with each rule in the filter.
Public method | GetElementFilterParametersForCategory | Retrieves a list of the parameters associated with all rules in the filter that are combined (using logical AND) with a FilterCategoryRule corresponding to single %categoryId%.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsNameUnique(String) | Determines whether a potential filter element name is unique. (Inherited from FilterElement)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetCategories | Sets the categories admitted by this filter.
Public method | SetElementFilter | Sets the rules that must be satisfied for a given element to pass this filter.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Example
C#
VB
C++
F#
Copy
/// <summary>
/// Create an ElementFilter representing a conjunction ("ANDing together") of FilterRules.
/// </summary>
/// <param name="filterRules">A list of FilterRules</param>
/// <returns>The ElementFilter.</returns>
private static ElementFilter CreateElementFilterFromFilterRules(IList<FilterRule> filterRules)
{
   // We use a LogicalAndFilter containing one ElementParameterFilter
   // for each FilterRule. We could alternatively create a single
   // ElementParameterFilter containing the entire list of FilterRules.
   IList<ElementFilter> elemFilters = new List<ElementFilter>();
   foreach (FilterRule filterRule in filterRules)
   {
      ElementParameterFilter elemParamFilter = new ElementParameterFilter(filterRule);
      elemFilters.Add(elemParamFilter);
   }
   LogicalAndFilter elemFilter = new LogicalAndFilter(elemFilters);

   return elemFilter;
}

/// <summary>
/// Creates a new view filter matching multiple criteria.
/// </summary>
/// <param name="doc"></param>
/// <param name="view"></param>
public static void CreateViewFilter(Document doc, View view)
  {
      List<ElementId> categories = new List<ElementId>();
      categories.Add(new ElementId(BuiltInCategory.OST_Walls));
      List<FilterRule> filterRules = new List<FilterRule>();

      using (Transaction t = new Transaction(doc, "Add view filter"))
      {
          t.Start();

          // Create filter element assocated to the input categories
          ParameterFilterElement parameterFilterElement = ParameterFilterElement.Create(doc, "Example view filter", categories);

          // Criterion 1 - wall type Function is "Exterior"
          ElementId exteriorParamId = new ElementId(BuiltInParameter.FUNCTION_PARAM);
          filterRules.Add(ParameterFilterRuleFactory.CreateEqualsRule(exteriorParamId, (int)WallFunction.Exterior));

          // Criterion 2 - wall height > some number
          ElementId lengthId = new ElementId(BuiltInParameter.CURVE_ELEM_LENGTH);
          filterRules.Add(ParameterFilterRuleFactory.CreateGreaterOrEqualRule(lengthId, 28.0, 0.0001));

          // Criterion 3 - custom shared parameter value matches string pattern
          // Get the id for the shared parameter - the ElementId is not hardcoded, so we need to get an instance of this type to find it
          Guid spGuid = new Guid("96b00b61-7f5a-4f36-a828-5cd07890a02a");
          FilteredElementCollector collector = new FilteredElementCollector(doc);
          collector.OfClass(typeof(Wall));
          Wall wall = collector.FirstElement() as Wall;

          if (wall != null)
          {
              Parameter sharedParam = wall.get_Parameter(spGuid);
              ElementId sharedParamId = sharedParam.Id;

              filterRules.Add(ParameterFilterRuleFactory.CreateBeginsWithRule(sharedParamId, "15."));
          }

          ElementFilter elemFilter = CreateElementFilterFromFilterRules(filterRules);
          parameterFilterElement.SetElementFilter(elemFilter);

          // Apply filter to view
          view.AddFilter(parameterFilterElement.Id);
          view.SetFilterVisibility(parameterFilterElement.Id, false);
          t.Commit();
      }
  }
Public Shared Sub CreateViewFilter(doc As Document, view As View)
      Dim categories As New List(Of ElementId)()
      categories.Add(New ElementId(BuiltInCategory.OST_Walls))
      Dim filterRules As New List(Of FilterRule)()

      Using t As New Transaction(doc, "Add view filter")
          t.Start()

          ' Create filter element assocated to the input categories
          Dim parameterFilterElement__1 As ParameterFilterElement = ParameterFilterElement.Create(doc, "Example view filter", categories)

          ' Criterion 1 - wall type Function is "Exterior"
          Dim exteriorParamId As New ElementId(BuiltInParameter.FUNCTION_PARAM)
          filterRules.Add(ParameterFilterRuleFactory.CreateEqualsRule(exteriorParamId, CInt(WallFunction.Exterior)))

          ' Criterion 2 - wall height > some number
          Dim lengthId As New ElementId(BuiltInParameter.CURVE_ELEM_LENGTH)
          filterRules.Add(ParameterFilterRuleFactory.CreateGreaterOrEqualRule(lengthId, 28.0, 0.0001))

          ' Criterion 3 - custom shared parameter value matches string pattern
          ' Get the id for the shared parameter - the ElementId is not hardcoded, so we need to get an instance of this type to find it
          Dim spGuid As New Guid("96b00b61-7f5a-4f36-a828-5cd07890a02a")
          Dim collector As New FilteredElementCollector(doc)
          collector.OfClass(GetType(Wall))
          Dim wall As Wall = TryCast(collector.FirstElement(), Wall)

          If wall IsNot Nothing Then
              Dim sharedParam As Parameter = wall.Parameter(spGuid)
              Dim sharedParamId As ElementId = sharedParam.Id

              filterRules.Add(ParameterFilterRuleFactory.CreateBeginsWithRule(sharedParamId, "15."))
          End If

      ' We use a LogicalAndFilter containing one ElementParameterFilter
      ' for each FilterRule. We could alternatively create a single
      ' ElementParameterFilter containing the entire list of FilterRules.
      Dim elemFilters As New List(Of ElementFilter)()
      For Each filterRule As FilterRule In filterRules
         Dim elemParamFilter As New ElementParameterFilter(filterRule)
         elemFilters.Add(elemParamFilter)
      Next
      Dim elemFilter As New LogicalAndFilter(elemFilters)
      parameterFilterElement__1.SetElementFilter(elemFilter)

      ' Apply filter to view
      view.AddFilter(parameterFilterElement__1.Id)
          view.SetFilterVisibility(parameterFilterElement__1.Id, False)
          t.Commit()
      End Using
  End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ParameterFilterElement Properties

The ParameterFilterElement type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

ParameterFilterElement Class


ParameterFilterElement Methods

The ParameterFilterElement type exposes the following members.

Methods
 | Name | Description
Public method | AllRuleParametersApplicable(ElementFilter) | Checks that the parameters of the rules used by the given ElementFilter are valid for this filter's categories.
 | AllRuleParametersApplicable(Document, ICollectionElementId, ElementFilter) | Checks that the parameters of the given ElementFilter (representing a combination of rules) are valid for the given set of categories.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | ClearRules | Removes all rules from this filter.
 | Create(Document, String, ICollectionElementId) | Creates a new ParameterFilterElement in the given document.
 | Create(Document, String, ICollectionElementId, ElementFilter) | Creates a new ParameterFilterElement in the given document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | ElementFilterIsAcceptableForParameterFilterElement(ElementFilter) | Checks that an ElementFilter is acceptable for use in defining the filtering rules for a ParameterFilterElement (i.e., for view filtering).
 | ElementFilterIsAcceptableForParameterFilterElement(Document, ISetElementId, ElementFilter) | Checks that an ElementFilter is acceptable for use in defining the filtering rules for a given list of categories (i.e., for view filtering).
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetCategories | Gets the categories admitted by this filter.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetElementFilter | Returns an ElementFilter representing the combination of rules used by this filter.
Public method | GetElementFilterParameters | Retrieves a list of the parameters associated with each rule in the filter.
Public method | GetElementFilterParametersForCategory | Retrieves a list of the parameters associated with all rules in the filter that are combined (using logical AND) with a FilterCategoryRule corresponding to single %categoryId%.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsNameUnique(String) | Determines whether a potential filter element name is unique. (Inherited from FilterElement)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetCategories | Sets the categories admitted by this filter.
Public method | SetElementFilter | Sets the rules that must be satisfied for a given element to pass this filter.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ParameterFilterElement Class


ParameterFilterElement.AllRuleParametersApplicable Method

ParameterFilterElementAllRuleParametersApplicable Method

Overload List
 | Name | Description
Public method | AllRuleParametersApplicable(ElementFilter) | Checks that the parameters of the rules used by the given ElementFilter are valid for this filter's categories.
 | AllRuleParametersApplicable(Document, ICollectionElementId, ElementFilter) | Checks that the parameters of the given ElementFilter (representing a combination of rules) are valid for the given set of categories.
Top
See Also

Reference

ParameterFilterElement Class


ParameterFilterElement.AllRuleParametersApplicable(ElementFilter) Method

ParameterFilterElementAllRuleParametersApplicable(ElementFilter) Method

Checks that the parameters of the rules used by the given ElementFilter are valid for this filter's categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AllRuleParametersApplicable(
    ElementFilter elementFilter
)
Public Function AllRuleParametersApplicable (
    elementFilter As ElementFilter
) As Boolean
public:
bool AllRuleParametersApplicable(
    ElementFilter^ elementFilter
)
member AllRuleParametersApplicable :
        elementFilter : ElementFilter -> bool

Parameters

elementFilter ElementFilter
The ElementFilter containing the rules to check.

Return Value

Boolean
True if all the parameters of the given rules are valid for this filter, otherwise false.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ParameterFilterElement Class
AllRuleParametersApplicable Overload


ParameterFilterElement.AllRuleParametersApplicable(Document, ICollection<ElementId>, ElementFilter) Method

ParameterFilterElementAllRuleParametersApplicable(Document, ICollectionElementId, ElementFilter) Method

Checks that the parameters of the given ElementFilter (representing a combination of rules) are valid for the given set of categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool AllRuleParametersApplicable(
    Document aDocument,
    ICollection<ElementId> categories,
    ElementFilter elementFilter
)
Public Shared Function AllRuleParametersApplicable (
    aDocument As Document,
    categories As ICollection(Of ElementId),
    elementFilter As ElementFilter
) As Boolean
public:
static bool AllRuleParametersApplicable(
    Document^ aDocument,
    ICollection<ElementId^>^ categories,
    ElementFilter^ elementFilter
)
static member AllRuleParametersApplicable :
        aDocument : Document *
        categories : ICollection<ElementId> *
        elementFilter : ElementFilter -> bool

Parameters

aDocument Document
The document containing the filter, categories, and parameters involved in this validation.
categories ICollection ElementId
The set of categories against which to check the rule parameters.
elementFilter ElementFilter
The ElementFilter representing the combination of rules to check.

Return Value

Boolean
True if all the parameters of the given rules are valid for this filter, otherwise false.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ParameterFilterElement Class
AllRuleParametersApplicable Overload


ParameterFilterElement.ClearRules Method

ParameterFilterElementClearRules Method

Removes all rules from this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ClearRules()
Public Sub ClearRules
public:
void ClearRules()
member ClearRules : unit -> unit
See Also

Reference

ParameterFilterElement Class


ParameterFilterElement.Create Method

ParameterFilterElementCreate Method

Overload List
Name | Description
Create(Document, String, ICollectionElementId) | Creates a new ParameterFilterElement in the given document.
Create(Document, String, ICollectionElementId, ElementFilter) | Creates a new ParameterFilterElement in the given document.
Top
See Also

Reference

ParameterFilterElement Class


ParameterFilterElement.Create(Document, String, ICollection<ElementId>) Method

ParameterFilterElementCreate(Document, String, ICollectionElementId) Method

Creates a new ParameterFilterElement in the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ParameterFilterElement Create(
    Document aDocument,
    string name,
    ICollection<ElementId> categories
)
Public Shared Function Create (
    aDocument As Document,
    name As String,
    categories As ICollection(Of ElementId)
) As ParameterFilterElement
public:
static ParameterFilterElement^ Create(
    Document^ aDocument,
    String^ name,
    ICollection<ElementId^>^ categories
)
static member Create :
        aDocument : Document *
        name : string *
        categories : ICollection<ElementId> -> ParameterFilterElement

Parameters

aDocument Document
The document in which to create the ParameterFilterElement.
name String
The user-visible name for the new ParameterFilterElement.
categories ICollection ElementId
The categories for the new ParameterFilterElement.

Return Value

ParameterFilterElement
A pointer to the new ParameterFilterElement.
Exceptions
Exception | Condition
ArgumentException | name is an empty string or contains only whitespace. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- The given value for name is already in use as a filter element name.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ParameterFilterElement Class
Create Overload


ParameterFilterElement.Create(Document, String, ICollection<ElementId>, ElementFilter) Method

ParameterFilterElementCreate(Document, String, ICollectionElementId, ElementFilter) Method

Creates a new ParameterFilterElement in the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ParameterFilterElement Create(
    Document aDocument,
    string name,
    ICollection<ElementId> categories,
    ElementFilter elementFilter
)
Public Shared Function Create (
    aDocument As Document,
    name As String,
    categories As ICollection(Of ElementId),
    elementFilter As ElementFilter
) As ParameterFilterElement
public:
static ParameterFilterElement^ Create(
    Document^ aDocument,
    String^ name,
    ICollection<ElementId^>^ categories,
    ElementFilter^ elementFilter
)
static member Create :
        aDocument : Document *
        name : string *
        categories : ICollection<ElementId> *
        elementFilter : ElementFilter -> ParameterFilterElement

Parameters

aDocument Document
The document in which to create the ParameterFilterElement.
name String
The user-visible name for the new ParameterFilterElement.
categories ICollection ElementId
The categories for the new ParameterFilterElement.
elementFilter ElementFilter
The rules for the new ParameterFilterElement, represented as an ElementFilter. ElementFilter is either an ElementParameterFilter or an ElementLogicalFilter representing a Boolean combination of ElementParameterFilters. In addition, we check that each ElementParameterFilter satisfies the following conditions: Its array of FilterRules is not empty and contains:
  • Any number of FilterRules of type FilterValueRule, FilterInverseRule, and SharedParameterApplicableRule or
  • Exactly one FilterCategoryRule containing only one category from categories stored by this ParameterFilterElement or
  • Exactly two rules: the first one is a FilterCategoryRule containing only one category from categories stored by this ParameterFilterElement and the second one is a FilterRule of type FilterValueRule, FilterInverseRule, or SharedParameterApplicableRule.
Note that cases in the second and third bullet are currently allowed only if the parent node of ElementParameterFilter is LogicalOrFilter.

Return Value

ParameterFilterElement
A pointer to the new ParameterFilterElement.
Exceptions
Exception | Condition
ArgumentException | name is an empty string or contains only whitespace. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- The given value for name is already in use as a filter element name. -or- One of the given rules refers to a parameter that does not apply to this filter's categories.
ArgumentNullException | A non-optional argument was null
ArgumentsInconsistentException | The ElementFilter is not acceptable for use by a ParameterFilterElement.
See Also

Reference

ParameterFilterElement Class
Create Overload


ParameterFilterElement.ElementFilterIsAcceptableForParameterFilterElement Method

ParameterFilterElementElementFilterIsAcceptableForParameterFilterElement Method

Overload List
 | Name | Description
Public method | ElementFilterIsAcceptableForParameterFilterElement(ElementFilter) | Checks that an ElementFilter is acceptable for use in defining the filtering rules for a ParameterFilterElement (i.e., for view filtering).
 | ElementFilterIsAcceptableForParameterFilterElement(Document, ISetElementId, ElementFilter) | Checks that an ElementFilter is acceptable for use in defining the filtering rules for a given list of categories (i.e., for view filtering).
Top
See Also

Reference

ParameterFilterElement Class


ParameterFilterElement.ElementFilterIsAcceptableForParameterFilterElement(ElementFilter) Method

ParameterFilterElementElementFilterIsAcceptableForParameterFilterElement(ElementFilter) Method

Checks that an ElementFilter is acceptable for use in defining the filtering rules for a ParameterFilterElement (i.e., for view filtering).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ElementFilterIsAcceptableForParameterFilterElement(
    ElementFilter elementFilter
)
Public Function ElementFilterIsAcceptableForParameterFilterElement (
    elementFilter As ElementFilter
) As Boolean
public:
bool ElementFilterIsAcceptableForParameterFilterElement(
    ElementFilter^ elementFilter
)
member ElementFilterIsAcceptableForParameterFilterElement :
        elementFilter : ElementFilter -> bool

Parameters

elementFilter ElementFilter
The ElementFilter to validate.

Return Value

Boolean
True if the ElementFilter is acceptable for use by an ParameterFilterElement, false if not.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
ElementFilter is either an ElementParameterFilter or an ElementLogicalFilter representing a Boolean combination of ElementParameterFilters. In addition, we check that each ElementParameterFilter satisfies the following conditions: Its array of FilterRules is not empty and contains:
  • Any number of FilterRules of type FilterValueRule, FilterInverseRule, and SharedParameterApplicableRule or
  • Exactly one FilterCategoryRule containing only one category from categories stored by this ParameterFilterElement or
  • Exactly two rules: the first one is a FilterCategoryRule containing only one category from categories stored by this ParameterFilterElement and the second one is a FilterRule of type FilterValueRule, FilterInverseRule, or SharedParameterApplicableRule.
Note that cases in the second and third bullet are currently allowed only if the parent node of ElementParameterFilter is LogicalOrFilter.
See Also

Reference

ParameterFilterElement Class
ElementFilterIsAcceptableForParameterFilterElement Overload


ParameterFilterElement.ElementFilterIsAcceptableForParameterFilterElement(Document, ISet<ElementId>, ElementFilter) Method

ParameterFilterElementElementFilterIsAcceptableForParameterFilterElement(Document, ISetElementId, ElementFilter) Method

Checks that an ElementFilter is acceptable for use in defining the filtering rules for a given list of categories (i.e., for view filtering).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool ElementFilterIsAcceptableForParameterFilterElement(
    Document aDocument,
    ISet<ElementId> categories,
    ElementFilter elementFilter
)
Public Shared Function ElementFilterIsAcceptableForParameterFilterElement (
    aDocument As Document,
    categories As ISet(Of ElementId),
    elementFilter As ElementFilter
) As Boolean
public:
static bool ElementFilterIsAcceptableForParameterFilterElement(
    Document^ aDocument,
    ISet<ElementId^>^ categories,
    ElementFilter^ elementFilter
)
static member ElementFilterIsAcceptableForParameterFilterElement :
        aDocument : Document *
        categories : ISet<ElementId> *
        elementFilter : ElementFilter -> bool

Parameters

aDocument Document
The document in which to create the ParameterFilterElement.
categories ISet ElementId
The categories for the new ParameterFilterElement.
elementFilter ElementFilter
The ElementFilter to validate.

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
ElementFilter is either an ElementParameterFilter or an ElementLogicalFilter representing a Boolean combination of ElementParameterFilters. In addition, we check that each ElementParameterFilter satisfies the following conditions: Its array of FilterRules is not empty and contains:
  • Any number of FilterRules of type FilterValueRule, FilterInverseRule, and SharedParameterApplicableRule or
  • Exactly one FilterCategoryRule containing only one category from categories stored by this ParameterFilterElement or
  • Exactly two rules: the first one is a FilterCategoryRule containing only one category from categories stored by this ParameterFilterElement and the second one is a FilterRule of type FilterValueRule, FilterInverseRule, or SharedParameterApplicableRule.
Note that cases in the second and third bullet are currently allowed only if the parent node of ElementParameterFilter is LogicalOrFilter.
See Also

Reference

ParameterFilterElement Class
ElementFilterIsAcceptableForParameterFilterElement Overload


ParameterFilterElement.GetCategories Method

ParameterFilterElementGetCategories Method

Gets the categories admitted by this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetCategories()
Public Function GetCategories As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetCategories()
member GetCategories : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
See Also

Reference

ParameterFilterElement Class


ParameterFilterElement.GetElementFilter Method

ParameterFilterElementGetElementFilter Method

Returns an ElementFilter representing the combination of rules used by this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementFilter GetElementFilter()
Public Function GetElementFilter As ElementFilter
public:
ElementFilter^ GetElementFilter()
member GetElementFilter : unit -> ElementFilter

Return Value

ElementFilter
An ElementFilter representing the rules. It may be an ElementParameterFilter representing a conjunction of one or more FilterRules, or an ElementLogicalFilter (of type LogicalAndFilter or LogicalOrFilter) representing a logical combination of FilterRules, using AND/OR operations.
Remarks
May return when no rules are sprcified in ParameterFilterElement, only categories. Note that in some situation, calling GetElementFilter after calling SetElementFilter may return an ElementFilter that is structurally different from the one passed as input to SetElementFilter. For example, if the input ElementFilter contains an ElementParameterFilter that contains more than one FilterRule, and if the view filters dialog box is used in between the calls to SetElementFilter and GetElementFilter, the output ElementFilter will use a single ElementParameterFilter for each of the FilterRules that were bundled in an input ElementParameterFilter. The two ElementFilters will be logically and functionally equivalent in the sense that any given Element will either be accepted by both ElementFilters or rejected by both ElementFilters.
See Also

Reference

ParameterFilterElement Class


ParameterFilterElement.GetElementFilterParameters Method

ParameterFilterElementGetElementFilterParameters Method

Retrieves a list of the parameters associated with each rule in the filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ISet<ElementId> GetElementFilterParameters()
Public Function GetElementFilterParameters As ISet(Of ElementId)
public:
ISet<ElementId^>^ GetElementFilterParameters()
member GetElementFilterParameters : unit -> ISet<ElementId>

Return Value

ISet ElementId
A set of parameter identifiers.
Remarks
This function returns only parameters used by this ParameterFilterElement that are common to all categories specified in this ParameterFilterElement. The ElementFilter may also contain parameters specific to one of the categories and not necessarily common to all categories specified in this ParameterFilterElement. To get those parameters, use ParameterFilterElement.GetElementFilterParametersForCategory().
See Also

Reference

ParameterFilterElement Class


ParameterFilterElement.GetElementFilterParametersForCategory Method

ParameterFilterElementGetElementFilterParametersForCategory Method

Retrieves a list of the parameters associated with all rules in the filter that are combined (using logical AND) with a FilterCategoryRule corresponding to single %categoryId%.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ISet<ElementId> GetElementFilterParametersForCategory(
    ElementId categoryId
)
Public Function GetElementFilterParametersForCategory (
    categoryId As ElementId
) As ISet(Of ElementId)
public:
ISet<ElementId^>^ GetElementFilterParametersForCategory(
    ElementId^ categoryId
)
member GetElementFilterParametersForCategory :
        categoryId : ElementId -> ISet<ElementId>

Parameters

categoryId ElementId
The category for which parameters should be found.

Return Value

ISet ElementId
A set of parameter identifiers.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Note that in the case when InvalidElementId specified as input %categoryId% this function returns parameters common to all categories used by this ParameterFilterElement, i.e. it is equivalent to ParameterFilterElement.GetElementFilterParameters().
See Also

Reference

ParameterFilterElement Class


ParameterFilterElement.SetCategories Method

ParameterFilterElementSetCategories Method

Sets the categories admitted by this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetCategories(
    ICollection<ElementId> categories
)
Public Sub SetCategories (
    categories As ICollection(Of ElementId)
)
public:
void SetCategories(
    ICollection<ElementId^>^ categories
)
member SetCategories :
        categories : ICollection<ElementId> -> unit

Parameters

categories ICollection ElementId
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks

Testing that an element's category is a member of this set is, essentially, the first rule of the filter.

Changing the set of categories will clear any rules that use parameters that are not applicable for the new set of categories.

See Also

Reference

ParameterFilterElement Class


ParameterFilterElement.SetElementFilter Method

ParameterFilterElementSetElementFilter Method

Sets the rules that must be satisfied for a given element to pass this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SetElementFilter(
    ElementFilter elementFilter
)
Public Function SetElementFilter (
    elementFilter As ElementFilter
) As Boolean
public:
bool SetElementFilter(
    ElementFilter^ elementFilter
)
member SetElementFilter :
        elementFilter : ElementFilter -> bool

Parameters

elementFilter ElementFilter
An ElementFilter representing the rules. It may be an ElementParameterFilter representing a conjunction of one or more FilterRules, or an ElementLogicalFilter (of type LogicalAndFilter or LogicalOrFilter) representing a logical combination of FilterRules, using AND/OR operations.

Return Value

Boolean
Returns true if this ParameterFilterElement was changed, false if not. It will not be changed if the input rules are equivalent to the ParameterFilterElement's existing rules.
Exceptions
Exception | Condition
ArgumentException | One of the given rules refers to a parameter that does not apply to this filter's categories.
ArgumentNullException | A non-optional argument was null
ArgumentsInconsistentException | The ElementFilter is not acceptable for use by a ParameterFilterElement.
Remarks
Note that in some situation, calling GetElementFilter after calling SetElementFilter may return an ElementFilter that is structurally different from the one passed as input to SetElementFilter. For example, if the input ElementFilter contains an ElementParameterFilter that contains more than one FilterRule, and if the view filters dialog box is used in between the calls to SetElementFilter and GetElementFilter, the output ElementFilter will use a single ElementParameterFilter for each of the FilterRules that were bundled in an input ElementParameterFilter. The two ElementFilters will be logically and functionally equivalent in the sense that any given Element will either be accepted by both ElementFilters or rejected by both ElementFilters.
See Also

Reference

ParameterFilterElement Class


ParameterFilterRuleFactory Class

Contains functions that create appropriate FilterRule objects based on the parameters given.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBParameterFilterRuleFactory

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ParameterFilterRuleFactory : IDisposable
Public Class ParameterFilterRuleFactory
    Implements IDisposable
public ref class ParameterFilterRuleFactory : IDisposable
type ParameterFilterRuleFactory =
    class
        interface IDisposable
    end

The ParameterFilterRuleFactory type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
 | CreateBeginsWithRule(ElementId, String) | Creates a filter rule that determines whether strings from the document begin with a certain string value.
 | CreateBeginsWithRule(ElementId, String, Boolean) | Obsolete. Creates a filter rule that determines whether strings from the document begin with a certain string value.
 | CreateContainsRule(ElementId, String) | Creates a filter rule that determines whether strings from the document contain a certain string value.
 | CreateContainsRule(ElementId, String, Boolean) | Obsolete. Creates a filter rule that determines whether strings from the document contain a certain string value.
 | CreateEndsWithRule(ElementId, String) | Creates a filter rule that determines whether strings from the document end with a certain string value.
 | CreateEndsWithRule(ElementId, String, Boolean) | Obsolete. Creates a filter rule that determines whether strings from the document end with a certain string value.
 | CreateEqualsRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document equal a certain value.
 | CreateEqualsRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document equal a certain value.
 | CreateEqualsRule(ElementId, String) | Creates a filter rule that determines whether strings from the document equal a certain value.
 | CreateEqualsRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document equal a certain value.
 | CreateEqualsRule(ElementId, String, Boolean) | Obsolete. Creates a filter rule that determines whether strings from the document equal a certain value.
 | CreateGreaterOrEqualRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document are greater than or equal to a certain value.
 | CreateGreaterOrEqualRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document are greater than or equal to a certain value.
 | CreateGreaterOrEqualRule(ElementId, String) | Creates a filter rule that determines whether strings from the document are greater than or equal to a certain value.
 | CreateGreaterOrEqualRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document are greater than or equal to a certain value.
 | CreateGreaterOrEqualRule(ElementId, String, Boolean) | Obsolete. Creates a filter rule that determines whether strings from the document are greater than or equal to a certain value.
 | CreateGreaterRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document are greater than a certain value.
 | CreateGreaterRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document are greater than a certain value.
 | CreateGreaterRule(ElementId, String) | Creates a filter rule that determines whether strings from the document are greater than a certain value.
 | CreateGreaterRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document are greater than a certain value.
 | CreateGreaterRule(ElementId, String, Boolean) | Obsolete. Creates a filter rule that determines whether strings from the document are greater than a certain value.
 | CreateHasNoValueParameterRule | Creates a filter rule that determines whether an element's parameter does not have a value.
 | CreateHasValueParameterRule | Creates a filter rule that determines whether an element's parameter has a value.
 | CreateIsAssociatedWithGlobalParameterRule | Creates a filter rule that determines whether a parameter is associated with a certain global parameter.
 | CreateIsNotAssociatedWithGlobalParameterRule | Creates a filter rule that determines whether a parameter is not associated with a certain global parameter.
 | CreateLessOrEqualRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document are less than or equal to a certain value.
 | CreateLessOrEqualRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document are less than or equal to a certain value.
 | CreateLessOrEqualRule(ElementId, String) | Creates a filter rule that determines whether strings from the document are less than or equal to a certain value.
 | CreateLessOrEqualRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document are less than or equal to a certain value.
 | CreateLessOrEqualRule(ElementId, String, Boolean) | Obsolete. Creates a filter rule that determines whether strings from the document are less than or equal to a certain value.
 | CreateLessRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document are less than a certain value.
 | CreateLessRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document are less than a certain value.
 | CreateLessRule(ElementId, String) | Creates a filter rule that determines whether strings from the document are less than a certain value.
 | CreateLessRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document are less than a certain value.
 | CreateLessRule(ElementId, String, Boolean) | Obsolete. Creates a filter rule that determines whether strings from the document are less than a certain value.
 | CreateNotBeginsWithRule(ElementId, String) | Creates a filter rule that determines whether strings from the document do not begin with a certain string value.
 | CreateNotBeginsWithRule(ElementId, String, Boolean) | Obsolete. Creates a filter rule that determines whether strings from the document do not begin with a certain string value.
 | CreateNotContainsRule(ElementId, String) | Creates a filter rule that determines whether strings from the document do not contain a certain string value.
 | CreateNotContainsRule(ElementId, String, Boolean) | Obsolete. Creates a filter rule that determines whether strings from the document do not contain a certain string value.
 | CreateNotEndsWithRule(ElementId, String) | Creates a filter rule that determines whether strings from the document do not end with a certain string value.
 | CreateNotEndsWithRule(ElementId, String, Boolean) | Obsolete. Creates a filter rule that determines whether strings from the document do not end with a certain string value.
 | CreateNotEqualsRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document do not equal a certain value.
 | CreateNotEqualsRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document do not equal a certain value.
 | CreateNotEqualsRule(ElementId, String) | Creates a filter rule that determines whether strings from the document do not equal a certain value.
 | CreateNotEqualsRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document do not equal a certain value.
 | CreateNotEqualsRule(ElementId, String, Boolean) | Obsolete. Creates a filter rule that determines whether strings from the document do not equal a certain value.
 | CreateSharedParameterApplicableRule | Creates a filter rule that tests elements for support of a shared parameter.
Public method | Dispose | Releases all resources used by the ParameterFilterRuleFactory
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ParameterFilterRuleFactory Properties

The ParameterFilterRuleFactory type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

ParameterFilterRuleFactory Class


ParameterFilterRuleFactory.IsValidObject Property

ParameterFilterRuleFactoryIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ParameterFilterRuleFactory Class


ParameterFilterRuleFactory Methods

The ParameterFilterRuleFactory type exposes the following members.

Methods
 | Name | Description
 | CreateBeginsWithRule(ElementId, String) | Creates a filter rule that determines whether strings from the document begin with a certain string value.
 | CreateBeginsWithRule(ElementId, String, Boolean) | Obsolete. Creates a filter rule that determines whether strings from the document begin with a certain string value.
 | CreateContainsRule(ElementId, String) | Creates a filter rule that determines whether strings from the document contain a certain string value.
 | CreateContainsRule(ElementId, String, Boolean) | Obsolete. Creates a filter rule that determines whether strings from the document contain a certain string value.
 | CreateEndsWithRule(ElementId, String) | Creates a filter rule that determines whether strings from the document end with a certain string value.
 | CreateEndsWithRule(ElementId, String, Boolean) | Obsolete. Creates a filter rule that determines whether strings from the document end with a certain string value.
 | CreateEqualsRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document equal a certain value.
 | CreateEqualsRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document equal a certain value.
 | CreateEqualsRule(ElementId, String) | Creates a filter rule that determines whether strings from the document equal a certain value.
 | CreateEqualsRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document equal a certain value.
 | CreateEqualsRule(ElementId, String, Boolean) | Obsolete. Creates a filter rule that determines whether strings from the document equal a certain value.
 | CreateGreaterOrEqualRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document are greater than or equal to a certain value.
 | CreateGreaterOrEqualRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document are greater than or equal to a certain value.
 | CreateGreaterOrEqualRule(ElementId, String) | Creates a filter rule that determines whether strings from the document are greater than or equal to a certain value.
 | CreateGreaterOrEqualRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document are greater than or equal to a certain value.
 | CreateGreaterOrEqualRule(ElementId, String, Boolean) | Obsolete. Creates a filter rule that determines whether strings from the document are greater than or equal to a certain value.
 | CreateGreaterRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document are greater than a certain value.
 | CreateGreaterRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document are greater than a certain value.
 | CreateGreaterRule(ElementId, String) | Creates a filter rule that determines whether strings from the document are greater than a certain value.
 | CreateGreaterRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document are greater than a certain value.
 | CreateGreaterRule(ElementId, String, Boolean) | Obsolete. Creates a filter rule that determines whether strings from the document are greater than a certain value.
 | CreateHasNoValueParameterRule | Creates a filter rule that determines whether an element's parameter does not have a value.
 | CreateHasValueParameterRule | Creates a filter rule that determines whether an element's parameter has a value.
 | CreateIsAssociatedWithGlobalParameterRule | Creates a filter rule that determines whether a parameter is associated with a certain global parameter.
 | CreateIsNotAssociatedWithGlobalParameterRule | Creates a filter rule that determines whether a parameter is not associated with a certain global parameter.
 | CreateLessOrEqualRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document are less than or equal to a certain value.
 | CreateLessOrEqualRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document are less than or equal to a certain value.
 | CreateLessOrEqualRule(ElementId, String) | Creates a filter rule that determines whether strings from the document are less than or equal to a certain value.
 | CreateLessOrEqualRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document are less than or equal to a certain value.
 | CreateLessOrEqualRule(ElementId, String, Boolean) | Obsolete. Creates a filter rule that determines whether strings from the document are less than or equal to a certain value.
 | CreateLessRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document are less than a certain value.
 | CreateLessRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document are less than a certain value.
 | CreateLessRule(ElementId, String) | Creates a filter rule that determines whether strings from the document are less than a certain value.
 | CreateLessRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document are less than a certain value.
 | CreateLessRule(ElementId, String, Boolean) | Obsolete. Creates a filter rule that determines whether strings from the document are less than a certain value.
 | CreateNotBeginsWithRule(ElementId, String) | Creates a filter rule that determines whether strings from the document do not begin with a certain string value.
 | CreateNotBeginsWithRule(ElementId, String, Boolean) | Obsolete. Creates a filter rule that determines whether strings from the document do not begin with a certain string value.
 | CreateNotContainsRule(ElementId, String) | Creates a filter rule that determines whether strings from the document do not contain a certain string value.
 | CreateNotContainsRule(ElementId, String, Boolean) | Obsolete. Creates a filter rule that determines whether strings from the document do not contain a certain string value.
 | CreateNotEndsWithRule(ElementId, String) | Creates a filter rule that determines whether strings from the document do not end with a certain string value.
 | CreateNotEndsWithRule(ElementId, String, Boolean) | Obsolete. Creates a filter rule that determines whether strings from the document do not end with a certain string value.
 | CreateNotEqualsRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document do not equal a certain value.
 | CreateNotEqualsRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document do not equal a certain value.
 | CreateNotEqualsRule(ElementId, String) | Creates a filter rule that determines whether strings from the document do not equal a certain value.
 | CreateNotEqualsRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document do not equal a certain value.
 | CreateNotEqualsRule(ElementId, String, Boolean) | Obsolete. Creates a filter rule that determines whether strings from the document do not equal a certain value.
 | CreateSharedParameterApplicableRule | Creates a filter rule that tests elements for support of a shared parameter.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ParameterFilterRuleFactory Class


ParameterFilterRuleFactory.CreateBeginsWithRule Method

ParameterFilterRuleFactoryCreateBeginsWithRule Method

Overload List
Name | Description
CreateBeginsWithRule(ElementId, String) | Creates a filter rule that determines whether strings from the document begin with a certain string value.
CreateBeginsWithRule(ElementId, String, Boolean) | Obsolete. Creates a filter rule that determines whether strings from the document begin with a certain string value.
Top
See Also

Reference

ParameterFilterRuleFactory Class


ParameterFilterRuleFactory.CreateBeginsWithRule(ElementId, String) Method

ParameterFilterRuleFactoryCreateBeginsWithRule(ElementId, String) Method

Creates a filter rule that determines whether strings from the document begin with a certain string value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FilterRule CreateBeginsWithRule(
    ElementId parameter,
    string value
)
Public Shared Function CreateBeginsWithRule (
    parameter As ElementId,
    value As String
) As FilterRule
public:
static FilterRule^ CreateBeginsWithRule(
    ElementId^ parameter,
    String^ value
)
static member CreateBeginsWithRule :
        parameter : ElementId *
        value : string -> FilterRule

Parameters

parameter ElementId
A string-typed parameter used to get values from the document for a given element.
value String
The user-supplied string value for which values from the document will be searched.

Return Value

FilterRule
Created filter rule object.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ParameterFilterRuleFactory Class
CreateBeginsWithRule Overload


ParameterFilterRuleFactory.CreateBeginsWithRule(ElementId, String, Boolean) Method

ParameterFilterRuleFactoryCreateBeginsWithRule(ElementId, String, Boolean) Method

Note: This API is now obsolete.

Creates a filter rule that determines whether strings from the document begin with a certain string value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
public static FilterRule CreateBeginsWithRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
<ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")>
Public Shared Function CreateBeginsWithRule (
    parameter As ElementId,
    value As String,
    caseSensitive As Boolean
) As FilterRule
public:
[ObsoleteAttribute(L"This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
static FilterRule^ CreateBeginsWithRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)
[<ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")>]
static member CreateBeginsWithRule :
        parameter : ElementId *
        value : string *
        caseSensitive : bool -> FilterRule

Parameters

parameter ElementId
A string-typed parameter used to get values from the document for a given element.
value String
The user-supplied string value for which values from the document will be searched.
caseSensitive Boolean
If true, the string comparison will be case-sensitive.

Return Value

FilterRule
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ParameterFilterRuleFactory Class
CreateBeginsWithRule Overload


ParameterFilterRuleFactory.CreateContainsRule Method

ParameterFilterRuleFactoryCreateContainsRule Method

Overload List
Name | Description
CreateContainsRule(ElementId, String) | Creates a filter rule that determines whether strings from the document contain a certain string value.
CreateContainsRule(ElementId, String, Boolean) | Obsolete. Creates a filter rule that determines whether strings from the document contain a certain string value.
Top
See Also

Reference

ParameterFilterRuleFactory Class


ParameterFilterRuleFactory.CreateContainsRule(ElementId, String) Method

ParameterFilterRuleFactoryCreateContainsRule(ElementId, String) Method

Creates a filter rule that determines whether strings from the document contain a certain string value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FilterRule CreateContainsRule(
    ElementId parameter,
    string value
)
Public Shared Function CreateContainsRule (
    parameter As ElementId,
    value As String
) As FilterRule
public:
static FilterRule^ CreateContainsRule(
    ElementId^ parameter,
    String^ value
)
static member CreateContainsRule :
        parameter : ElementId *
        value : string -> FilterRule

Parameters

parameter ElementId
A string-typed parameter used to get values from the document for a given element.
value String
The user-supplied string value for which values from the document will be searched.

Return Value

FilterRule
Created filter rule object.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ParameterFilterRuleFactory Class
CreateContainsRule Overload


ParameterFilterRuleFactory.CreateContainsRule(ElementId, String, Boolean) Method

ParameterFilterRuleFactoryCreateContainsRule(ElementId, String, Boolean) Method

Note: This API is now obsolete.

Creates a filter rule that determines whether strings from the document contain a certain string value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
public static FilterRule CreateContainsRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
<ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")>
Public Shared Function CreateContainsRule (
    parameter As ElementId,
    value As String,
    caseSensitive As Boolean
) As FilterRule
public:
[ObsoleteAttribute(L"This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
static FilterRule^ CreateContainsRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)
[<ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")>]
static member CreateContainsRule :
        parameter : ElementId *
        value : string *
        caseSensitive : bool -> FilterRule

Parameters

parameter ElementId
A string-typed parameter used to get values from the document for a given element.
value String
The user-supplied string value for which values from the document will be searched.
caseSensitive Boolean
If true, the string comparison will be case-sensitive.

Return Value

FilterRule
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ParameterFilterRuleFactory Class
CreateContainsRule Overload


ParameterFilterRuleFactory.CreateEndsWithRule Method

ParameterFilterRuleFactoryCreateEndsWithRule Method

Overload List
Name | Description
CreateEndsWithRule(ElementId, String) | Creates a filter rule that determines whether strings from the document end with a certain string value.
CreateEndsWithRule(ElementId, String, Boolean) | Obsolete. Creates a filter rule that determines whether strings from the document end with a certain string value.
Top
See Also

Reference

ParameterFilterRuleFactory Class


ParameterFilterRuleFactory.CreateEndsWithRule(ElementId, String) Method

ParameterFilterRuleFactoryCreateEndsWithRule(ElementId, String) Method

Creates a filter rule that determines whether strings from the document end with a certain string value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FilterRule CreateEndsWithRule(
    ElementId parameter,
    string value
)
Public Shared Function CreateEndsWithRule (
    parameter As ElementId,
    value As String
) As FilterRule
public:
static FilterRule^ CreateEndsWithRule(
    ElementId^ parameter,
    String^ value
)
static member CreateEndsWithRule :
        parameter : ElementId *
        value : string -> FilterRule

Parameters

parameter ElementId
A string-typed parameter used to get values from the document for a given element.
value String
The user-supplied string value for which values from the document will be searched.

Return Value

FilterRule
Created filter rule object.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ParameterFilterRuleFactory Class
CreateEndsWithRule Overload


ParameterFilterRuleFactory.CreateEndsWithRule(ElementId, String, Boolean) Method

ParameterFilterRuleFactoryCreateEndsWithRule(ElementId, String, Boolean) Method

Note: This API is now obsolete.

Creates a filter rule that determines whether strings from the document end with a certain string value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
public static FilterRule CreateEndsWithRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
<ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")>
Public Shared Function CreateEndsWithRule (
    parameter As ElementId,
    value As String,
    caseSensitive As Boolean
) As FilterRule
public:
[ObsoleteAttribute(L"This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
static FilterRule^ CreateEndsWithRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)
[<ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")>]
static member CreateEndsWithRule :
        parameter : ElementId *
        value : string *
        caseSensitive : bool -> FilterRule

Parameters

parameter ElementId
A string-typed parameter used to get values from the document for a given element.
value String
The user-supplied string value for which values from the document will be searched.
caseSensitive Boolean
If true, the string comparison will be case-sensitive.

Return Value

FilterRule
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ParameterFilterRuleFactory Class
CreateEndsWithRule Overload


ParameterFilterRuleFactory.CreateEqualsRule Method

ParameterFilterRuleFactoryCreateEqualsRule Method

Overload List
Name | Description
CreateEqualsRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document equal a certain value.
CreateEqualsRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document equal a certain value.
CreateEqualsRule(ElementId, String) | Creates a filter rule that determines whether strings from the document equal a certain value.
CreateEqualsRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document equal a certain value.
CreateEqualsRule(ElementId, String, Boolean) | Obsolete. Creates a filter rule that determines whether strings from the document equal a certain value.
Top
See Also

Reference

ParameterFilterRuleFactory Class


ParameterFilterRuleFactory.CreateEqualsRule(ElementId, ElementId) Method

ParameterFilterRuleFactoryCreateEqualsRule(ElementId, ElementId) Method

Creates a filter rule that determines whether ElementId values from the document equal a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FilterRule CreateEqualsRule(
    ElementId parameter,
    ElementId value
)
Public Shared Function CreateEqualsRule (
    parameter As ElementId,
    value As ElementId
) As FilterRule
public:
static FilterRule^ CreateEqualsRule(
    ElementId^ parameter,
    ElementId^ value
)
static member CreateEqualsRule :
        parameter : ElementId *
        value : ElementId -> FilterRule

Parameters

parameter ElementId
An ElementId-typed parameter used to get values from the document for a given element.
value ElementId
The user-supplied value against which values from the document will be compared.

Return Value

FilterRule
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ParameterFilterRuleFactory Class
CreateEqualsRule Overload


ParameterFilterRuleFactory.CreateEqualsRule(ElementId, Int32) Method

ParameterFilterRuleFactoryCreateEqualsRule(ElementId, Int32) Method

Creates a filter rule that determines whether integer values from the document equal a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FilterRule CreateEqualsRule(
    ElementId parameter,
    int value
)
Public Shared Function CreateEqualsRule (
    parameter As ElementId,
    value As Integer
) As FilterRule
public:
static FilterRule^ CreateEqualsRule(
    ElementId^ parameter,
    int value
)
static member CreateEqualsRule :
        parameter : ElementId *
        value : int -> FilterRule

Parameters

parameter ElementId
An integer-typed parameter used to get values from the document for a given element.
value Int32
The user-supplied value against which values from the document will be compared.

Return Value

FilterRule
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ParameterFilterRuleFactory Class
CreateEqualsRule Overload


ParameterFilterRuleFactory.CreateEqualsRule(ElementId, String) Method

ParameterFilterRuleFactoryCreateEqualsRule(ElementId, String) Method

Creates a filter rule that determines whether strings from the document equal a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FilterRule CreateEqualsRule(
    ElementId parameter,
    string value
)
Public Shared Function CreateEqualsRule (
    parameter As ElementId,
    value As String
) As FilterRule
public:
static FilterRule^ CreateEqualsRule(
    ElementId^ parameter,
    String^ value
)
static member CreateEqualsRule :
        parameter : ElementId *
        value : string -> FilterRule

Parameters

parameter ElementId
A string-typed parameter used to get values from the document for a given element.
value String
The user-supplied string value against which values from the document will be compared.

Return Value

FilterRule
Created filter rule object.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ParameterFilterRuleFactory Class
CreateEqualsRule Overload


ParameterFilterRuleFactory.CreateEqualsRule(ElementId, Double, Double) Method

ParameterFilterRuleFactoryCreateEqualsRule(ElementId, Double, Double) Method

Creates a filter rule that determines whether double-precision values from the document equal a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FilterRule CreateEqualsRule(
    ElementId parameter,
    double value,
    double epsilon
)
Public Shared Function CreateEqualsRule (
    parameter As ElementId,
    value As Double,
    epsilon As Double
) As FilterRule
public:
static FilterRule^ CreateEqualsRule(
    ElementId^ parameter,
    double value,
    double epsilon
)
static member CreateEqualsRule :
        parameter : ElementId *
        value : float *
        epsilon : float -> FilterRule

Parameters

parameter ElementId
A double-typed parameter used to get values from the document for a given element.
value Double
The user-supplied value against which values from the document will be compared.
epsilon Double
Defines the tolerance within which two values may be considered equal.

Return Value

FilterRule
Exceptions
Exception | Condition
ArgumentException | The given value for value is not finite -or- The given value for value is not a number -or- The given value for epsilon is not finite -or- The given value for epsilon is not a number
ArgumentNullException | A non-optional argument was null
See Also

Reference

ParameterFilterRuleFactory Class
CreateEqualsRule Overload


ParameterFilterRuleFactory.CreateEqualsRule(ElementId, String, Boolean) Method

ParameterFilterRuleFactoryCreateEqualsRule(ElementId, String, Boolean) Method

Note: This API is now obsolete.

Creates a filter rule that determines whether strings from the document equal a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
public static FilterRule CreateEqualsRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
<ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")>
Public Shared Function CreateEqualsRule (
    parameter As ElementId,
    value As String,
    caseSensitive As Boolean
) As FilterRule
public:
[ObsoleteAttribute(L"This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
static FilterRule^ CreateEqualsRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)
[<ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")>]
static member CreateEqualsRule :
        parameter : ElementId *
        value : string *
        caseSensitive : bool -> FilterRule

Parameters

parameter ElementId
A string-typed parameter used to get values from the document for a given element.
value String
The user-supplied string value against which values from the document will be compared.
caseSensitive Boolean
If true, the string comparison will be case-sensitive.

Return Value

FilterRule
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ParameterFilterRuleFactory Class
CreateEqualsRule Overload


ParameterFilterRuleFactory.CreateGreaterOrEqualRule Method

ParameterFilterRuleFactoryCreateGreaterOrEqualRule Method

Overload List
Name | Description
CreateGreaterOrEqualRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document are greater than or equal to a certain value.
CreateGreaterOrEqualRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document are greater than or equal to a certain value.
CreateGreaterOrEqualRule(ElementId, String) | Creates a filter rule that determines whether strings from the document are greater than or equal to a certain value.
CreateGreaterOrEqualRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document are greater than or equal to a certain value.
CreateGreaterOrEqualRule(ElementId, String, Boolean) | Obsolete. Creates a filter rule that determines whether strings from the document are greater than or equal to a certain value.
Top
See Also

Reference

ParameterFilterRuleFactory Class


ParameterFilterRuleFactory.CreateGreaterOrEqualRule(ElementId, ElementId) Method

ParameterFilterRuleFactoryCreateGreaterOrEqualRule(ElementId, ElementId) Method

Creates a filter rule that determines whether ElementId values from the document are greater than or equal to a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FilterRule CreateGreaterOrEqualRule(
    ElementId parameter,
    ElementId value
)
Public Shared Function CreateGreaterOrEqualRule (
    parameter As ElementId,
    value As ElementId
) As FilterRule
public:
static FilterRule^ CreateGreaterOrEqualRule(
    ElementId^ parameter,
    ElementId^ value
)
static member CreateGreaterOrEqualRule :
        parameter : ElementId *
        value : ElementId -> FilterRule

Parameters

parameter ElementId
An ElementId-typed parameter used to get values from the document for a given element.
value ElementId
The user-supplied value against which values from the document will be compared.

Return Value

FilterRule
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ParameterFilterRuleFactory Class
CreateGreaterOrEqualRule Overload


ParameterFilterRuleFactory.CreateGreaterOrEqualRule(ElementId, Int32) Method

ParameterFilterRuleFactoryCreateGreaterOrEqualRule(ElementId, Int32) Method

Creates a filter rule that determines whether integer values from the document are greater than or equal to a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FilterRule CreateGreaterOrEqualRule(
    ElementId parameter,
    int value
)
Public Shared Function CreateGreaterOrEqualRule (
    parameter As ElementId,
    value As Integer
) As FilterRule
public:
static FilterRule^ CreateGreaterOrEqualRule(
    ElementId^ parameter,
    int value
)
static member CreateGreaterOrEqualRule :
        parameter : ElementId *
        value : int -> FilterRule

Parameters

parameter ElementId
An integer-typed parameter used to get values from the document for a given element.
value Int32
The user-supplied value against which values from the document will be compared.

Return Value

FilterRule
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ParameterFilterRuleFactory Class
CreateGreaterOrEqualRule Overload


ParameterFilterRuleFactory.CreateGreaterOrEqualRule(ElementId, String) Method

ParameterFilterRuleFactoryCreateGreaterOrEqualRule(ElementId, String) Method

Creates a filter rule that determines whether strings from the document are greater than or equal to a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FilterRule CreateGreaterOrEqualRule(
    ElementId parameter,
    string value
)
Public Shared Function CreateGreaterOrEqualRule (
    parameter As ElementId,
    value As String
) As FilterRule
public:
static FilterRule^ CreateGreaterOrEqualRule(
    ElementId^ parameter,
    String^ value
)
static member CreateGreaterOrEqualRule :
        parameter : ElementId *
        value : string -> FilterRule

Parameters

parameter ElementId
A string-typed parameter used to get values from the document for a given element.
value String
The user-supplied string value against which values from the document will be compared.

Return Value

FilterRule
Created filter rule object.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
For strings, a value is "greater" than another if it would appear after the other in an alphabetically-sorted list.
See Also

Reference

ParameterFilterRuleFactory Class
CreateGreaterOrEqualRule Overload


ParameterFilterRuleFactory.CreateGreaterOrEqualRule(ElementId, Double, Double) Method

ParameterFilterRuleFactoryCreateGreaterOrEqualRule(ElementId, Double, Double) Method

Creates a filter rule that determines whether double-precision values from the document are greater than or equal to a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FilterRule CreateGreaterOrEqualRule(
    ElementId parameter,
    double value,
    double epsilon
)
Public Shared Function CreateGreaterOrEqualRule (
    parameter As ElementId,
    value As Double,
    epsilon As Double
) As FilterRule
public:
static FilterRule^ CreateGreaterOrEqualRule(
    ElementId^ parameter,
    double value,
    double epsilon
)
static member CreateGreaterOrEqualRule :
        parameter : ElementId *
        value : float *
        epsilon : float -> FilterRule

Parameters

parameter ElementId
A double-typed parameter used to get values from the document for a given element.
value Double
The user-supplied value against which values from the document will be compared.
epsilon Double
Defines the tolerance within which two values may be considered equal.

Return Value

FilterRule
Exceptions
Exception | Condition
ArgumentException | The given value for value is not finite -or- The given value for value is not a number -or- The given value for epsilon is not finite -or- The given value for epsilon is not a number
ArgumentNullException | A non-optional argument was null
Remarks
Values less than the user-supplied value but within epsilon are considered equal; therefore, such values satisfy the condition.
See Also

Reference

ParameterFilterRuleFactory Class
CreateGreaterOrEqualRule Overload


ParameterFilterRuleFactory.CreateGreaterOrEqualRule(ElementId, String, Boolean) Method

ParameterFilterRuleFactoryCreateGreaterOrEqualRule(ElementId, String, Boolean) Method

Note: This API is now obsolete.

Creates a filter rule that determines whether strings from the document are greater than or equal to a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
public static FilterRule CreateGreaterOrEqualRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
<ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")>
Public Shared Function CreateGreaterOrEqualRule (
    parameter As ElementId,
    value As String,
    caseSensitive As Boolean
) As FilterRule
public:
[ObsoleteAttribute(L"This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
static FilterRule^ CreateGreaterOrEqualRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)
[<ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")>]
static member CreateGreaterOrEqualRule :
        parameter : ElementId *
        value : string *
        caseSensitive : bool -> FilterRule

Parameters

parameter ElementId
A string-typed parameter used to get values from the document for a given element.
value String
The user-supplied string value against which values from the document will be compared.
caseSensitive Boolean
If true, the string comparison will be case-sensitive.

Return Value

FilterRule
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
For strings, a value is "greater" than another if it would appear after the other in an alphabetically-sorted list.
See Also

Reference

ParameterFilterRuleFactory Class
CreateGreaterOrEqualRule Overload


ParameterFilterRuleFactory.CreateGreaterRule Method

ParameterFilterRuleFactoryCreateGreaterRule Method

Overload List
Name | Description
CreateGreaterRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document are greater than a certain value.
CreateGreaterRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document are greater than a certain value.
CreateGreaterRule(ElementId, String) | Creates a filter rule that determines whether strings from the document are greater than a certain value.
CreateGreaterRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document are greater than a certain value.
CreateGreaterRule(ElementId, String, Boolean) | Obsolete. Creates a filter rule that determines whether strings from the document are greater than a certain value.
Top
See Also

Reference

ParameterFilterRuleFactory Class


ParameterFilterRuleFactory.CreateGreaterRule(ElementId, ElementId) Method

ParameterFilterRuleFactoryCreateGreaterRule(ElementId, ElementId) Method

Creates a filter rule that determines whether ElementId values from the document are greater than a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FilterRule CreateGreaterRule(
    ElementId parameter,
    ElementId value
)
Public Shared Function CreateGreaterRule (
    parameter As ElementId,
    value As ElementId
) As FilterRule
public:
static FilterRule^ CreateGreaterRule(
    ElementId^ parameter,
    ElementId^ value
)
static member CreateGreaterRule :
        parameter : ElementId *
        value : ElementId -> FilterRule

Parameters

parameter ElementId
An ElementId-typed parameter used to get values from the document for a given element.
value ElementId
The user-supplied value against which values from the document will be compared.

Return Value

FilterRule
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ParameterFilterRuleFactory Class
CreateGreaterRule Overload


ParameterFilterRuleFactory.CreateGreaterRule(ElementId, Int32) Method

ParameterFilterRuleFactoryCreateGreaterRule(ElementId, Int32) Method

Creates a filter rule that determines whether integer values from the document are greater than a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FilterRule CreateGreaterRule(
    ElementId parameter,
    int value
)
Public Shared Function CreateGreaterRule (
    parameter As ElementId,
    value As Integer
) As FilterRule
public:
static FilterRule^ CreateGreaterRule(
    ElementId^ parameter,
    int value
)
static member CreateGreaterRule :
        parameter : ElementId *
        value : int -> FilterRule

Parameters

parameter ElementId
An integer-typed parameter used to get values from the document for a given element.
value Int32
The user-supplied value against which values from the document will be compared.

Return Value

FilterRule
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ParameterFilterRuleFactory Class
CreateGreaterRule Overload


ParameterFilterRuleFactory.CreateGreaterRule(ElementId, String) Method

ParameterFilterRuleFactoryCreateGreaterRule(ElementId, String) Method

Creates a filter rule that determines whether strings from the document are greater than a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FilterRule CreateGreaterRule(
    ElementId parameter,
    string value
)
Public Shared Function CreateGreaterRule (
    parameter As ElementId,
    value As String
) As FilterRule
public:
static FilterRule^ CreateGreaterRule(
    ElementId^ parameter,
    String^ value
)
static member CreateGreaterRule :
        parameter : ElementId *
        value : string -> FilterRule

Parameters

parameter ElementId
A string-typed parameter used to get values from the document for a given element.
value String
The user-supplied string value against which values from the document will be compared.

Return Value

FilterRule
Created filter rule object.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
For strings, a value is "greater" than another if it would appear after the other in an alphabetically-sorted list.
See Also

Reference

ParameterFilterRuleFactory Class
CreateGreaterRule Overload


ParameterFilterRuleFactory.CreateGreaterRule(ElementId, Double, Double) Method

ParameterFilterRuleFactoryCreateGreaterRule(ElementId, Double, Double) Method

Creates a filter rule that determines whether double-precision values from the document are greater than a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FilterRule CreateGreaterRule(
    ElementId parameter,
    double value,
    double epsilon
)
Public Shared Function CreateGreaterRule (
    parameter As ElementId,
    value As Double,
    epsilon As Double
) As FilterRule
public:
static FilterRule^ CreateGreaterRule(
    ElementId^ parameter,
    double value,
    double epsilon
)
static member CreateGreaterRule :
        parameter : ElementId *
        value : float *
        epsilon : float -> FilterRule

Parameters

parameter ElementId
A double-typed parameter used to get values from the document for a given element.
value Double
The user-supplied value against which values from the document will be compared.
epsilon Double
Defines the tolerance within which two values may be considered equal.

Return Value

FilterRule
Exceptions
Exception | Condition
ArgumentException | The given value for value is not finite -or- The given value for value is not a number -or- The given value for epsilon is not finite -or- The given value for epsilon is not a number
ArgumentNullException | A non-optional argument was null
Remarks
Values greater than value but within epsilon are considered equal, not greater.
See Also

Reference

ParameterFilterRuleFactory Class
CreateGreaterRule Overload


ParameterFilterRuleFactory.CreateGreaterRule(ElementId, String, Boolean) Method

ParameterFilterRuleFactoryCreateGreaterRule(ElementId, String, Boolean) Method

Note: This API is now obsolete.

Creates a filter rule that determines whether strings from the document are greater than a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
public static FilterRule CreateGreaterRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
<ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")>
Public Shared Function CreateGreaterRule (
    parameter As ElementId,
    value As String,
    caseSensitive As Boolean
) As FilterRule
public:
[ObsoleteAttribute(L"This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
static FilterRule^ CreateGreaterRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)
[<ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")>]
static member CreateGreaterRule :
        parameter : ElementId *
        value : string *
        caseSensitive : bool -> FilterRule

Parameters

parameter ElementId
A string-typed parameter used to get values from the document for a given element.
value String
The user-supplied string value against which values from the document will be compared.
caseSensitive Boolean
If true, the string comparison will be case-sensitive.

Return Value

FilterRule
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
For strings, a value is "greater" than another if it would appear after the other in an alphabetically-sorted list.
See Also

Reference

ParameterFilterRuleFactory Class
CreateGreaterRule Overload


ParameterFilterRuleFactory.CreateHasNoValueParameterRule Method

ParameterFilterRuleFactoryCreateHasNoValueParameterRule Method

Creates a filter rule that determines whether an element's parameter does not have a value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FilterRule CreateHasNoValueParameterRule(
    ElementId parameter
)
Public Shared Function CreateHasNoValueParameterRule (
    parameter As ElementId
) As FilterRule
public:
static FilterRule^ CreateHasNoValueParameterRule(
    ElementId^ parameter
)
static member CreateHasNoValueParameterRule :
        parameter : ElementId -> FilterRule

Parameters

parameter ElementId
The parameter to be evaluated by the filter.

Return Value

FilterRule
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ParameterFilterRuleFactory Class


ParameterFilterRuleFactory.CreateHasValueParameterRule Method

ParameterFilterRuleFactoryCreateHasValueParameterRule Method

Creates a filter rule that determines whether an element's parameter has a value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FilterRule CreateHasValueParameterRule(
    ElementId parameter
)
Public Shared Function CreateHasValueParameterRule (
    parameter As ElementId
) As FilterRule
public:
static FilterRule^ CreateHasValueParameterRule(
    ElementId^ parameter
)
static member CreateHasValueParameterRule :
        parameter : ElementId -> FilterRule

Parameters

parameter ElementId
The parameter to be evaluated by the filter.

Return Value

FilterRule
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ParameterFilterRuleFactory Class


ParameterFilterRuleFactory.CreateIsAssociatedWithGlobalParameterRule Method

ParameterFilterRuleFactoryCreateIsAssociatedWithGlobalParameterRule Method

Creates a filter rule that determines whether a parameter is associated with a certain global parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FilterRule CreateIsAssociatedWithGlobalParameterRule(
    ElementId parameter,
    ElementId value
)
Public Shared Function CreateIsAssociatedWithGlobalParameterRule (
    parameter As ElementId,
    value As ElementId
) As FilterRule
public:
static FilterRule^ CreateIsAssociatedWithGlobalParameterRule(
    ElementId^ parameter,
    ElementId^ value
)
static member CreateIsAssociatedWithGlobalParameterRule :
        parameter : ElementId *
        value : ElementId -> FilterRule

Parameters

parameter ElementId
A parameter that can be associated with an existing global parameter of a compatible type.
value ElementId
The global parameter used to test the association.

Return Value

FilterRule
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ParameterFilterRuleFactory Class


ParameterFilterRuleFactory.CreateIsNotAssociatedWithGlobalParameterRule Method

ParameterFilterRuleFactoryCreateIsNotAssociatedWithGlobalParameterRule Method

Creates a filter rule that determines whether a parameter is not associated with a certain global parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FilterRule CreateIsNotAssociatedWithGlobalParameterRule(
    ElementId parameter,
    ElementId value
)
Public Shared Function CreateIsNotAssociatedWithGlobalParameterRule (
    parameter As ElementId,
    value As ElementId
) As FilterRule
public:
static FilterRule^ CreateIsNotAssociatedWithGlobalParameterRule(
    ElementId^ parameter,
    ElementId^ value
)
static member CreateIsNotAssociatedWithGlobalParameterRule :
        parameter : ElementId *
        value : ElementId -> FilterRule

Parameters

parameter ElementId
A parameter that can be associated with an existing global parameter of a compatible type.
value ElementId
The global parameter used to test the association.

Return Value

FilterRule
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ParameterFilterRuleFactory Class


ParameterFilterRuleFactory.CreateLessOrEqualRule Method

ParameterFilterRuleFactoryCreateLessOrEqualRule Method

Overload List
Name | Description
CreateLessOrEqualRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document are less than or equal to a certain value.
CreateLessOrEqualRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document are less than or equal to a certain value.
CreateLessOrEqualRule(ElementId, String) | Creates a filter rule that determines whether strings from the document are less than or equal to a certain value.
CreateLessOrEqualRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document are less than or equal to a certain value.
CreateLessOrEqualRule(ElementId, String, Boolean) | Obsolete. Creates a filter rule that determines whether strings from the document are less than or equal to a certain value.
Top
See Also

Reference

ParameterFilterRuleFactory Class


ParameterFilterRuleFactory.CreateLessOrEqualRule(ElementId, ElementId) Method

ParameterFilterRuleFactoryCreateLessOrEqualRule(ElementId, ElementId) Method

Creates a filter rule that determines whether ElementId values from the document are less than or equal to a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FilterRule CreateLessOrEqualRule(
    ElementId parameter,
    ElementId value
)
Public Shared Function CreateLessOrEqualRule (
    parameter As ElementId,
    value As ElementId
) As FilterRule
public:
static FilterRule^ CreateLessOrEqualRule(
    ElementId^ parameter,
    ElementId^ value
)
static member CreateLessOrEqualRule :
        parameter : ElementId *
        value : ElementId -> FilterRule

Parameters

parameter ElementId
An ElementId-typed parameter used to get values from the document for a given element.
value ElementId
The user-supplied value against which values from the document will be compared.

Return Value

FilterRule
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ParameterFilterRuleFactory Class
CreateLessOrEqualRule Overload


ParameterFilterRuleFactory.CreateLessOrEqualRule(ElementId, Int32) Method

ParameterFilterRuleFactoryCreateLessOrEqualRule(ElementId, Int32) Method

Creates a filter rule that determines whether integer values from the document are less than or equal to a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FilterRule CreateLessOrEqualRule(
    ElementId parameter,
    int value
)
Public Shared Function CreateLessOrEqualRule (
    parameter As ElementId,
    value As Integer
) As FilterRule
public:
static FilterRule^ CreateLessOrEqualRule(
    ElementId^ parameter,
    int value
)
static member CreateLessOrEqualRule :
        parameter : ElementId *
        value : int -> FilterRule

Parameters

parameter ElementId
An integer-typed parameter used to get values from the document for a given element.
value Int32
The user-supplied value against which values from the document will be compared.

Return Value

FilterRule
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ParameterFilterRuleFactory Class
CreateLessOrEqualRule Overload


ParameterFilterRuleFactory.CreateLessOrEqualRule(ElementId, String) Method

ParameterFilterRuleFactoryCreateLessOrEqualRule(ElementId, String) Method

Creates a filter rule that determines whether strings from the document are less than or equal to a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FilterRule CreateLessOrEqualRule(
    ElementId parameter,
    string value
)
Public Shared Function CreateLessOrEqualRule (
    parameter As ElementId,
    value As String
) As FilterRule
public:
static FilterRule^ CreateLessOrEqualRule(
    ElementId^ parameter,
    String^ value
)
static member CreateLessOrEqualRule :
        parameter : ElementId *
        value : string -> FilterRule

Parameters

parameter ElementId
A string-typed parameter used to get values from the document for a given element.
value String
The user-supplied string value against which values from the document will be compared.

Return Value

FilterRule
Created filter rule object.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
For strings, a value is "less" than another if it would appear before the other in an alphabetically-sorted list.
See Also

Reference

ParameterFilterRuleFactory Class
CreateLessOrEqualRule Overload


ParameterFilterRuleFactory.CreateLessOrEqualRule(ElementId, Double, Double) Method

ParameterFilterRuleFactoryCreateLessOrEqualRule(ElementId, Double, Double) Method

Creates a filter rule that determines whether double-precision values from the document are less than or equal to a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FilterRule CreateLessOrEqualRule(
    ElementId parameter,
    double value,
    double epsilon
)
Public Shared Function CreateLessOrEqualRule (
    parameter As ElementId,
    value As Double,
    epsilon As Double
) As FilterRule
public:
static FilterRule^ CreateLessOrEqualRule(
    ElementId^ parameter,
    double value,
    double epsilon
)
static member CreateLessOrEqualRule :
        parameter : ElementId *
        value : float *
        epsilon : float -> FilterRule

Parameters

parameter ElementId
A double-typed parameter used to get values from the document for a given element.
value Double
The user-supplied value against which values from the document will be compared.
epsilon Double
Defines the tolerance within which two values may be considered equal.

Return Value

FilterRule
Exceptions
Exception | Condition
ArgumentException | The given value for value is not finite -or- The given value for value is not a number -or- The given value for epsilon is not finite -or- The given value for epsilon is not a number
ArgumentNullException | A non-optional argument was null
Remarks
Values greater than the user-supplied value but within epsilon are considered equal; therefore, such values satisfy the condition.
See Also

Reference

ParameterFilterRuleFactory Class
CreateLessOrEqualRule Overload


ParameterFilterRuleFactory.CreateLessOrEqualRule(ElementId, String, Boolean) Method

ParameterFilterRuleFactoryCreateLessOrEqualRule(ElementId, String, Boolean) Method

Note: This API is now obsolete.

Creates a filter rule that determines whether strings from the document are less than or equal to a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
public static FilterRule CreateLessOrEqualRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
<ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")>
Public Shared Function CreateLessOrEqualRule (
    parameter As ElementId,
    value As String,
    caseSensitive As Boolean
) As FilterRule
public:
[ObsoleteAttribute(L"This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
static FilterRule^ CreateLessOrEqualRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)
[<ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")>]
static member CreateLessOrEqualRule :
        parameter : ElementId *
        value : string *
        caseSensitive : bool -> FilterRule

Parameters

parameter ElementId
A string-typed parameter used to get values from the document for a given element.
value String
The user-supplied string value against which values from the document will be compared.
caseSensitive Boolean
If true, the string comparison will be case-sensitive.

Return Value

FilterRule
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
For strings, a value is "less" than another if it would appear before the other in an alphabetically-sorted list.
See Also

Reference

ParameterFilterRuleFactory Class
CreateLessOrEqualRule Overload


ParameterFilterRuleFactory.CreateLessRule Method

ParameterFilterRuleFactoryCreateLessRule Method

Overload List
Name | Description
CreateLessRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document are less than a certain value.
CreateLessRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document are less than a certain value.
CreateLessRule(ElementId, String) | Creates a filter rule that determines whether strings from the document are less than a certain value.
CreateLessRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document are less than a certain value.
CreateLessRule(ElementId, String, Boolean) | Obsolete. Creates a filter rule that determines whether strings from the document are less than a certain value.
Top
See Also

Reference

ParameterFilterRuleFactory Class


ParameterFilterRuleFactory.CreateLessRule(ElementId, ElementId) Method

ParameterFilterRuleFactoryCreateLessRule(ElementId, ElementId) Method

Creates a filter rule that determines whether ElementId values from the document are less than a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FilterRule CreateLessRule(
    ElementId parameter,
    ElementId value
)
Public Shared Function CreateLessRule (
    parameter As ElementId,
    value As ElementId
) As FilterRule
public:
static FilterRule^ CreateLessRule(
    ElementId^ parameter,
    ElementId^ value
)
static member CreateLessRule :
        parameter : ElementId *
        value : ElementId -> FilterRule

Parameters

parameter ElementId
An ElementId-typed parameter used to get values from the document for a given element.
value ElementId
The user-supplied value against which values from the document will be compared.

Return Value

FilterRule
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ParameterFilterRuleFactory Class
CreateLessRule Overload


ParameterFilterRuleFactory.CreateLessRule(ElementId, Int32) Method

ParameterFilterRuleFactoryCreateLessRule(ElementId, Int32) Method

Creates a filter rule that determines whether integer values from the document are less than a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FilterRule CreateLessRule(
    ElementId parameter,
    int value
)
Public Shared Function CreateLessRule (
    parameter As ElementId,
    value As Integer
) As FilterRule
public:
static FilterRule^ CreateLessRule(
    ElementId^ parameter,
    int value
)
static member CreateLessRule :
        parameter : ElementId *
        value : int -> FilterRule

Parameters

parameter ElementId
An integer-typed parameter used to get values from the document for a given element.
value Int32
The user-supplied value against which values from the document will be compared.

Return Value

FilterRule
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ParameterFilterRuleFactory Class
CreateLessRule Overload


ParameterFilterRuleFactory.CreateLessRule(ElementId, String) Method

ParameterFilterRuleFactoryCreateLessRule(ElementId, String) Method

Creates a filter rule that determines whether strings from the document are less than a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FilterRule CreateLessRule(
    ElementId parameter,
    string value
)
Public Shared Function CreateLessRule (
    parameter As ElementId,
    value As String
) As FilterRule
public:
static FilterRule^ CreateLessRule(
    ElementId^ parameter,
    String^ value
)
static member CreateLessRule :
        parameter : ElementId *
        value : string -> FilterRule

Parameters

parameter ElementId
A string-typed parameter used to get values from the document for a given element.
value String
The user-supplied string value against which values from the document will be compared.

Return Value

FilterRule
Created filter rule object.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
For strings, a value is "less" than another if it would appear before the other in an alphabetically-sorted list.
See Also

Reference

ParameterFilterRuleFactory Class
CreateLessRule Overload


ParameterFilterRuleFactory.CreateLessRule(ElementId, Double, Double) Method

ParameterFilterRuleFactoryCreateLessRule(ElementId, Double, Double) Method

Creates a filter rule that determines whether double-precision values from the document are less than a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FilterRule CreateLessRule(
    ElementId parameter,
    double value,
    double epsilon
)
Public Shared Function CreateLessRule (
    parameter As ElementId,
    value As Double,
    epsilon As Double
) As FilterRule
public:
static FilterRule^ CreateLessRule(
    ElementId^ parameter,
    double value,
    double epsilon
)
static member CreateLessRule :
        parameter : ElementId *
        value : float *
        epsilon : float -> FilterRule

Parameters

parameter ElementId
A double-typed parameter used to get values from the document for a given element.
value Double
The user-supplied value against which values from the document will be compared.
epsilon Double
Defines the tolerance within which two values may be considered equal.

Return Value

FilterRule
Exceptions
Exception | Condition
ArgumentException | The given value for value is not finite -or- The given value for value is not a number -or- The given value for epsilon is not finite -or- The given value for epsilon is not a number
ArgumentNullException | A non-optional argument was null
Remarks
Values less than the user-supplied value but within epsilon are considered equal, not less.
See Also

Reference

ParameterFilterRuleFactory Class
CreateLessRule Overload


ParameterFilterRuleFactory.CreateLessRule(ElementId, String, Boolean) Method

ParameterFilterRuleFactoryCreateLessRule(ElementId, String, Boolean) Method

Note: This API is now obsolete.

Creates a filter rule that determines whether strings from the document are less than a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
public static FilterRule CreateLessRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
<ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")>
Public Shared Function CreateLessRule (
    parameter As ElementId,
    value As String,
    caseSensitive As Boolean
) As FilterRule
public:
[ObsoleteAttribute(L"This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
static FilterRule^ CreateLessRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)
[<ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")>]
static member CreateLessRule :
        parameter : ElementId *
        value : string *
        caseSensitive : bool -> FilterRule

Parameters

parameter ElementId
A string-typed parameter used to get values from the document for a given element.
value String
The user-supplied string value against which values from the document will be compared.
caseSensitive Boolean
If true, the string comparison will be case-sensitive.

Return Value

FilterRule
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
For strings, a value is "less" than another if it would appear before the other in an alphabetically-sorted list.
See Also

Reference

ParameterFilterRuleFactory Class
CreateLessRule Overload


ParameterFilterRuleFactory.CreateNotBeginsWithRule Method

ParameterFilterRuleFactoryCreateNotBeginsWithRule Method

Overload List
Name | Description
CreateNotBeginsWithRule(ElementId, String) | Creates a filter rule that determines whether strings from the document do not begin with a certain string value.
CreateNotBeginsWithRule(ElementId, String, Boolean) | Obsolete. Creates a filter rule that determines whether strings from the document do not begin with a certain string value.
Top
See Also

Reference

ParameterFilterRuleFactory Class


ParameterFilterRuleFactory.CreateNotBeginsWithRule(ElementId, String) Method

ParameterFilterRuleFactoryCreateNotBeginsWithRule(ElementId, String) Method

Creates a filter rule that determines whether strings from the document do not begin with a certain string value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FilterRule CreateNotBeginsWithRule(
    ElementId parameter,
    string value
)
Public Shared Function CreateNotBeginsWithRule (
    parameter As ElementId,
    value As String
) As FilterRule
public:
static FilterRule^ CreateNotBeginsWithRule(
    ElementId^ parameter,
    String^ value
)
static member CreateNotBeginsWithRule :
        parameter : ElementId *
        value : string -> FilterRule

Parameters

parameter ElementId
A string-typed parameter used to get values from the document for a given element.
value String
The user-supplied string value for which values from the document will be searched.

Return Value

FilterRule
Created filter rule object.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ParameterFilterRuleFactory Class
CreateNotBeginsWithRule Overload


ParameterFilterRuleFactory.CreateNotBeginsWithRule(ElementId, String, Boolean) Method

ParameterFilterRuleFactoryCreateNotBeginsWithRule(ElementId, String, Boolean) Method

Note: This API is now obsolete.

Creates a filter rule that determines whether strings from the document do not begin with a certain string value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
public static FilterRule CreateNotBeginsWithRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
<ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")>
Public Shared Function CreateNotBeginsWithRule (
    parameter As ElementId,
    value As String,
    caseSensitive As Boolean
) As FilterRule
public:
[ObsoleteAttribute(L"This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
static FilterRule^ CreateNotBeginsWithRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)
[<ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")>]
static member CreateNotBeginsWithRule :
        parameter : ElementId *
        value : string *
        caseSensitive : bool -> FilterRule

Parameters

parameter ElementId
A string-typed parameter used to get values from the document for a given element.
value String
The user-supplied string value for which values from the document will be searched.
caseSensitive Boolean
If true, the string comparison will be case-sensitive.

Return Value

FilterRule
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ParameterFilterRuleFactory Class
CreateNotBeginsWithRule Overload


ParameterFilterRuleFactory.CreateNotContainsRule Method

ParameterFilterRuleFactoryCreateNotContainsRule Method

Overload List
Name | Description
CreateNotContainsRule(ElementId, String) | Creates a filter rule that determines whether strings from the document do not contain a certain string value.
CreateNotContainsRule(ElementId, String, Boolean) | Obsolete. Creates a filter rule that determines whether strings from the document do not contain a certain string value.
Top
See Also

Reference

ParameterFilterRuleFactory Class


ParameterFilterRuleFactory.CreateNotContainsRule(ElementId, String) Method

ParameterFilterRuleFactoryCreateNotContainsRule(ElementId, String) Method

Creates a filter rule that determines whether strings from the document do not contain a certain string value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FilterRule CreateNotContainsRule(
    ElementId parameter,
    string value
)
Public Shared Function CreateNotContainsRule (
    parameter As ElementId,
    value As String
) As FilterRule
public:
static FilterRule^ CreateNotContainsRule(
    ElementId^ parameter,
    String^ value
)
static member CreateNotContainsRule :
        parameter : ElementId *
        value : string -> FilterRule

Parameters

parameter ElementId
A string-typed parameter used to get values from the document for a given element.
value String
The user-supplied string value for which values from the document will be searched.

Return Value

FilterRule
Created filter rule object.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ParameterFilterRuleFactory Class
CreateNotContainsRule Overload


ParameterFilterRuleFactory.CreateNotContainsRule(ElementId, String, Boolean) Method

ParameterFilterRuleFactoryCreateNotContainsRule(ElementId, String, Boolean) Method

Note: This API is now obsolete.

Creates a filter rule that determines whether strings from the document do not contain a certain string value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
public static FilterRule CreateNotContainsRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
<ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")>
Public Shared Function CreateNotContainsRule (
    parameter As ElementId,
    value As String,
    caseSensitive As Boolean
) As FilterRule
public:
[ObsoleteAttribute(L"This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
static FilterRule^ CreateNotContainsRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)
[<ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")>]
static member CreateNotContainsRule :
        parameter : ElementId *
        value : string *
        caseSensitive : bool -> FilterRule

Parameters

parameter ElementId
A string-typed parameter used to get values from the document for a given element.
value String
The user-supplied string value for which values from the document will be searched.
caseSensitive Boolean
If true, the string comparison will be case-sensitive.

Return Value

FilterRule
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ParameterFilterRuleFactory Class
CreateNotContainsRule Overload


ParameterFilterRuleFactory.CreateNotEndsWithRule Method

ParameterFilterRuleFactoryCreateNotEndsWithRule Method

Overload List
Name | Description
CreateNotEndsWithRule(ElementId, String) | Creates a filter rule that determines whether strings from the document do not end with a certain string value.
CreateNotEndsWithRule(ElementId, String, Boolean) | Obsolete. Creates a filter rule that determines whether strings from the document do not end with a certain string value.
Top
See Also

Reference

ParameterFilterRuleFactory Class


ParameterFilterRuleFactory.CreateNotEndsWithRule(ElementId, String) Method

ParameterFilterRuleFactoryCreateNotEndsWithRule(ElementId, String) Method

Creates a filter rule that determines whether strings from the document do not end with a certain string value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FilterRule CreateNotEndsWithRule(
    ElementId parameter,
    string value
)
Public Shared Function CreateNotEndsWithRule (
    parameter As ElementId,
    value As String
) As FilterRule
public:
static FilterRule^ CreateNotEndsWithRule(
    ElementId^ parameter,
    String^ value
)
static member CreateNotEndsWithRule :
        parameter : ElementId *
        value : string -> FilterRule

Parameters

parameter ElementId
A string-typed parameter used to get values from the document for a given element.
value String
The user-supplied string value for which values from the document will be searched.

Return Value

FilterRule
Created filter rule object.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ParameterFilterRuleFactory Class
CreateNotEndsWithRule Overload


ParameterFilterRuleFactory.CreateNotEndsWithRule(ElementId, String, Boolean) Method

ParameterFilterRuleFactoryCreateNotEndsWithRule(ElementId, String, Boolean) Method

Note: This API is now obsolete.

Creates a filter rule that determines whether strings from the document do not end with a certain string value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
public static FilterRule CreateNotEndsWithRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
<ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")>
Public Shared Function CreateNotEndsWithRule (
    parameter As ElementId,
    value As String,
    caseSensitive As Boolean
) As FilterRule
public:
[ObsoleteAttribute(L"This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
static FilterRule^ CreateNotEndsWithRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)
[<ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")>]
static member CreateNotEndsWithRule :
        parameter : ElementId *
        value : string *
        caseSensitive : bool -> FilterRule

Parameters

parameter ElementId
A string-typed parameter used to get values from the document for a given element.
value String
The user-supplied string value for which values from the document will be searched.
caseSensitive Boolean
If true, the string comparison will be case-sensitive.

Return Value

FilterRule
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ParameterFilterRuleFactory Class
CreateNotEndsWithRule Overload


ParameterFilterRuleFactory.CreateNotEqualsRule Method

ParameterFilterRuleFactoryCreateNotEqualsRule Method

Overload List
Name | Description
CreateNotEqualsRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document do not equal a certain value.
CreateNotEqualsRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document do not equal a certain value.
CreateNotEqualsRule(ElementId, String) | Creates a filter rule that determines whether strings from the document do not equal a certain value.
CreateNotEqualsRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document do not equal a certain value.
CreateNotEqualsRule(ElementId, String, Boolean) | Obsolete. Creates a filter rule that determines whether strings from the document do not equal a certain value.
Top
See Also

Reference

ParameterFilterRuleFactory Class


ParameterFilterRuleFactory.CreateNotEqualsRule(ElementId, ElementId) Method

ParameterFilterRuleFactoryCreateNotEqualsRule(ElementId, ElementId) Method

Creates a filter rule that determines whether ElementId values from the document do not equal a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FilterRule CreateNotEqualsRule(
    ElementId parameter,
    ElementId value
)
Public Shared Function CreateNotEqualsRule (
    parameter As ElementId,
    value As ElementId
) As FilterRule
public:
static FilterRule^ CreateNotEqualsRule(
    ElementId^ parameter,
    ElementId^ value
)
static member CreateNotEqualsRule :
        parameter : ElementId *
        value : ElementId -> FilterRule

Parameters

parameter ElementId
An ElementId-typed parameter used to get values from the document for a given element.
value ElementId
The user-supplied value against which values from the document will be compared.

Return Value

FilterRule
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ParameterFilterRuleFactory Class
CreateNotEqualsRule Overload


ParameterFilterRuleFactory.CreateNotEqualsRule(ElementId, Int32) Method

ParameterFilterRuleFactoryCreateNotEqualsRule(ElementId, Int32) Method

Creates a filter rule that determines whether integer values from the document do not equal a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FilterRule CreateNotEqualsRule(
    ElementId parameter,
    int value
)
Public Shared Function CreateNotEqualsRule (
    parameter As ElementId,
    value As Integer
) As FilterRule
public:
static FilterRule^ CreateNotEqualsRule(
    ElementId^ parameter,
    int value
)
static member CreateNotEqualsRule :
        parameter : ElementId *
        value : int -> FilterRule

Parameters

parameter ElementId
An integer-typed parameter used to get values from the document for a given element.
value Int32
The user-supplied value against which values from the document will be compared.

Return Value

FilterRule
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ParameterFilterRuleFactory Class
CreateNotEqualsRule Overload


ParameterFilterRuleFactory.CreateNotEqualsRule(ElementId, String) Method

ParameterFilterRuleFactoryCreateNotEqualsRule(ElementId, String) Method

Creates a filter rule that determines whether strings from the document do not equal a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FilterRule CreateNotEqualsRule(
    ElementId parameter,
    string value
)
Public Shared Function CreateNotEqualsRule (
    parameter As ElementId,
    value As String
) As FilterRule
public:
static FilterRule^ CreateNotEqualsRule(
    ElementId^ parameter,
    String^ value
)
static member CreateNotEqualsRule :
        parameter : ElementId *
        value : string -> FilterRule

Parameters

parameter ElementId
A string-typed parameter used to get values from the document for a given element.
value String
The user-supplied string value against which values from the document will be compared.

Return Value

FilterRule
Created filter rule object.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ParameterFilterRuleFactory Class
CreateNotEqualsRule Overload


ParameterFilterRuleFactory.CreateNotEqualsRule(ElementId, Double, Double) Method

ParameterFilterRuleFactoryCreateNotEqualsRule(ElementId, Double, Double) Method

Creates a filter rule that determines whether double-precision values from the document do not equal a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FilterRule CreateNotEqualsRule(
    ElementId parameter,
    double value,
    double epsilon
)
Public Shared Function CreateNotEqualsRule (
    parameter As ElementId,
    value As Double,
    epsilon As Double
) As FilterRule
public:
static FilterRule^ CreateNotEqualsRule(
    ElementId^ parameter,
    double value,
    double epsilon
)
static member CreateNotEqualsRule :
        parameter : ElementId *
        value : float *
        epsilon : float -> FilterRule

Parameters

parameter ElementId
A double-typed parameter used to get values from the document for a given element.
value Double
The user-supplied value against which values from the document will be compared.
epsilon Double
Defines the tolerance within which two values may be considered equal.

Return Value

FilterRule
Exceptions
Exception | Condition
ArgumentException | The given value for value is not finite -or- The given value for value is not a number -or- The given value for epsilon is not finite -or- The given value for epsilon is not a number
ArgumentNullException | A non-optional argument was null
See Also

Reference

ParameterFilterRuleFactory Class
CreateNotEqualsRule Overload


ParameterFilterRuleFactory.CreateNotEqualsRule(ElementId, String, Boolean) Method

ParameterFilterRuleFactoryCreateNotEqualsRule(ElementId, String, Boolean) Method

Note: This API is now obsolete.

Creates a filter rule that determines whether strings from the document do not equal a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
public static FilterRule CreateNotEqualsRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
<ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")>
Public Shared Function CreateNotEqualsRule (
    parameter As ElementId,
    value As String,
    caseSensitive As Boolean
) As FilterRule
public:
[ObsoleteAttribute(L"This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
static FilterRule^ CreateNotEqualsRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)
[<ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")>]
static member CreateNotEqualsRule :
        parameter : ElementId *
        value : string *
        caseSensitive : bool -> FilterRule

Parameters

parameter ElementId
A string-typed parameter used to get values from the document for a given element.
value String
The user-supplied string value against which values from the document will be compared.
caseSensitive Boolean
If true, the string comparison will be case-sensitive.

Return Value

FilterRule
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ParameterFilterRuleFactory Class
CreateNotEqualsRule Overload


ParameterFilterRuleFactory.CreateSharedParameterApplicableRule Method

ParameterFilterRuleFactoryCreateSharedParameterApplicableRule Method

Creates a filter rule that tests elements for support of a shared parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static FilterRule CreateSharedParameterApplicableRule(
    string parameterName
)
Public Shared Function CreateSharedParameterApplicableRule (
    parameterName As String
) As FilterRule
public:
static FilterRule^ CreateSharedParameterApplicableRule(
    String^ parameterName
)
static member CreateSharedParameterApplicableRule :
        parameterName : string -> FilterRule

Parameters

parameterName String
The name of the parameter that elements must support to satisfy this rule.

Return Value

FilterRule
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ParameterFilterRuleFactory Class


ParameterFilterRuleFactory.Dispose Method

ParameterFilterRuleFactoryDispose Method

Releases all resources used by the ParameterFilterRuleFactory

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ParameterFilterRuleFactory Class


ParameterFilterUtilities Class

Contains static utility functions for enumerating the categories and parameters that are available for use by ParameterFilterElement objects.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBParameterFilterUtilities

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ParameterFilterUtilities
Public NotInheritable Class ParameterFilterUtilities
public ref class ParameterFilterUtilities abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ParameterFilterUtilities = class end

The ParameterFilterUtilities type exposes the following members.

Methods
Name | Description
GetAllFilterableCategories | Returns the set of categories that may be used in a ParameterFilterElement.
GetFilterableParametersInCommon | Returns the filterable parameters common to the given categories.
GetInapplicableParameters | Returns the parameters that are not among the set of filterable parameters common to the given categories.
IsParameterApplicable | Used to determine whether the element supports the given parameter.
RemoveUnfilterableCategories | Removes from the given set the categories that are not filterable.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ParameterFilterUtilities Methods

The ParameterFilterUtilities type exposes the following members.

Methods
Name | Description
GetAllFilterableCategories | Returns the set of categories that may be used in a ParameterFilterElement.
GetFilterableParametersInCommon | Returns the filterable parameters common to the given categories.
GetInapplicableParameters | Returns the parameters that are not among the set of filterable parameters common to the given categories.
IsParameterApplicable | Used to determine whether the element supports the given parameter.
RemoveUnfilterableCategories | Removes from the given set the categories that are not filterable.
Top
See Also

Reference

ParameterFilterUtilities Class


ParameterFilterUtilities.GetAllFilterableCategories Method

ParameterFilterUtilitiesGetAllFilterableCategories Method

Returns the set of categories that may be used in a ParameterFilterElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ICollection<ElementId> GetAllFilterableCategories()
Public Shared Function GetAllFilterableCategories As ICollection(Of ElementId)
public:
static ICollection<ElementId^>^ GetAllFilterableCategories()
static member GetAllFilterableCategories : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
The set of all filterable categories.
See Also

Reference

ParameterFilterUtilities Class


ParameterFilterUtilities.GetFilterableParametersInCommon Method

ParameterFilterUtilitiesGetFilterableParametersInCommon Method

Returns the filterable parameters common to the given categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ICollection<ElementId> GetFilterableParametersInCommon(
    Document aDoc,
    ICollection<ElementId> categories
)
Public Shared Function GetFilterableParametersInCommon (
    aDoc As Document,
    categories As ICollection(Of ElementId)
) As ICollection(Of ElementId)
public:
static ICollection<ElementId^>^ GetFilterableParametersInCommon(
    Document^ aDoc,
    ICollection<ElementId^>^ categories
)
static member GetFilterableParametersInCommon :
        aDoc : Document *
        categories : ICollection<ElementId> -> ICollection<ElementId>

Parameters

aDoc Document
The document containing the categories and parameters to query.
categories ICollection ElementId
The categories for which to determine the common parameters.

Return Value

ICollection ElementId
The set of filterable parameters common to the given categories.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks

A filterable category in Revit has a set of filterable parameters. The filterable parameters common to a set of categories is the intersection of all these filterable parameter sets.

This set defines the set of parameters that may be used to define a rule on a ParameterFilterElement with a certain set of categories.

See Also

Reference

ParameterFilterUtilities Class


ParameterFilterUtilities.GetInapplicableParameters Method

ParameterFilterUtilitiesGetInapplicableParameters Method

Returns the parameters that are not among the set of filterable parameters common to the given categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<ElementId> GetInapplicableParameters(
    Document aDoc,
    ICollection<ElementId> categories,
    IList<ElementId> parameters
)
Public Shared Function GetInapplicableParameters (
    aDoc As Document,
    categories As ICollection(Of ElementId),
    parameters As IList(Of ElementId)
) As IList(Of ElementId)
public:
static IList<ElementId^>^ GetInapplicableParameters(
    Document^ aDoc,
    ICollection<ElementId^>^ categories,
    IList<ElementId^>^ parameters
)
static member GetInapplicableParameters :
        aDoc : Document *
        categories : ICollection<ElementId> *
        parameters : IList<ElementId> -> IList<ElementId>

Parameters

aDoc Document
The document containing the categories and parameters to query.
categories ICollection ElementId
The categories that define the set of possibly filterable parameters.
parameters IList ElementId
The parameters desired for use in a parameter filter.

Return Value

IList ElementId
A list of parameters from the given array that are not valid for use in a parameter filter with the given categories.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ParameterFilterUtilities Class


ParameterFilterUtilities.IsParameterApplicable Method

ParameterFilterUtilitiesIsParameterApplicable Method

Used to determine whether the element supports the given parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsParameterApplicable(
    Element element,
    ElementId parameter
)
Public Shared Function IsParameterApplicable (
    element As Element,
    parameter As ElementId
) As Boolean
public:
static bool IsParameterApplicable(
    Element^ element,
    ElementId^ parameter
)
static member IsParameterApplicable :
        element : Element *
        parameter : ElementId -> bool

Parameters

element Element
The element to query for support of the given parameter.
parameter ElementId
The parameter for which to query support.

Return Value

Boolean
True if the element supports the given parameter, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
This operation is supported for external (e.g., shared, project) parameters only.
See Also

Reference

ParameterFilterUtilities Class


ParameterFilterUtilities.RemoveUnfilterableCategories Method

ParameterFilterUtilitiesRemoveUnfilterableCategories Method

Removes from the given set the categories that are not filterable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ICollection<ElementId> RemoveUnfilterableCategories(
    ICollection<ElementId> categories
)
Public Shared Function RemoveUnfilterableCategories (
    categories As ICollection(Of ElementId)
) As ICollection(Of ElementId)
public:
static ICollection<ElementId^>^ RemoveUnfilterableCategories(
    ICollection<ElementId^>^ categories
)
static member RemoveUnfilterableCategories :
        categories : ICollection<ElementId> -> ICollection<ElementId>

Parameters

categories ICollection ElementId
The set of categories to check.

Return Value

ICollection ElementId
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ParameterFilterUtilities Class


ParameterMap Class

A map that can contain a mapping of a parameter name (a String) to a parameter.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBParameterMap

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ParameterMap : APIObject,
    IEnumerable
Public Class ParameterMap
    Inherits APIObject
    Implements IEnumerable
public ref class ParameterMap : public APIObject,
    IEnumerable
type ParameterMap =
    class
        inherit APIObject
        interface IEnumerable
    end

The ParameterMap type exposes the following members.

Constructors
 | Name | Description
Public method | ParameterMap | Initializes a new instance of the ParameterMap class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the map is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets an item at a specified key within the map.
Public property | Size | Returns the number of objects that are in the map.
Top
Methods
 | Name | Description
Public method | Clear | Removes every item from the map, rendering it empty.
Public method | Contains | Tests for the existence of a key within the map.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase | Removes a object with the specified key from the map.
Public method | ForwardIterator | Retrieve a forward moving iterator to the map.
Public method | GetEnumerator | Retrieve a forward moving iterator to the map.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified item with the specified key into the map.
Public method | ReverseIterator | Retrieve a backward moving iterator to the map.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ParameterMap Constructor

Initializes a new instance of the ParameterMap class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ParameterMap()
Public Sub New
public:
ParameterMap()
new : unit -> ParameterMap
See Also

Reference

ParameterMap Class


ParameterMap Properties

The ParameterMap type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the map is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets an item at a specified key within the map.
Public property | Size | Returns the number of objects that are in the map.
Top
See Also

Reference

ParameterMap Class


ParameterMap.IsEmpty Property

ParameterMapIsEmpty Property

Test to see if the map is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Boolean
Remarks
If the map is empty then True will be returned, otherwise False.
See Also

Reference

ParameterMap Class


ParameterMap.Item Property

ParameterMapItem Property

Gets or sets an item at a specified key within the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Parameter this[
    string key
] { get; set; }
Public Overridable Property Item (
    key As String
) As Parameter
    Get
    Set
public:
virtual property Parameter^ Item[String^ key] {
    Parameter^ get (String^ key);
    void set (String^ key, Parameter^ value);
}
abstract Item : Parameter with get, set
override Item : Parameter with get, set

Parameters

key String
The key of the item to be set or retrieved.

Return Value

Parameter
Returns the object at the specified key.
See Also

Reference

ParameterMap Class


ParameterMap.Size Property

ParameterMapSize Property

Returns the number of objects that are in the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
abstract Size : int with get
override Size : int with get

Property Value

Int32
See Also

Reference

ParameterMap Class


ParameterMap Methods

The ParameterMap type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Removes every item from the map, rendering it empty.
Public method | Contains | Tests for the existence of a key within the map.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase | Removes a object with the specified key from the map.
Public method | ForwardIterator | Retrieve a forward moving iterator to the map.
Public method | GetEnumerator | Retrieve a forward moving iterator to the map.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified item with the specified key into the map.
Public method | ReverseIterator | Retrieve a backward moving iterator to the map.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ParameterMap Class


ParameterMap.Clear Method

ParameterMapClear Method

Removes every item from the map, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

ParameterMap Class


ParameterMap.Contains Method

ParameterMapContains Method

Tests for the existence of a key within the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Contains(
    string key
)
Public Overridable Function Contains (
    key As String
) As Boolean
public:
virtual bool Contains(
    String^ key
)
abstract Contains :
        key : string -> bool
override Contains :
        key : string -> bool

Parameters

key String
The key to be searched for.

Return Value

Boolean
The Contains method returns True if the key is within the map, otherwise False.
See Also

Reference

ParameterMap Class


ParameterMap.Erase Method

ParameterMapErase Method

Removes a object with the specified key from the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Erase(
    string key
)
Public Overridable Function Erase (
    key As String
) As Integer
public:
virtual int Erase(
    String^ key
)
abstract Erase :
        key : string -> int
override Erase :
        key : string -> int

Parameters

key String
The key of the item to be erased.

Return Value

Int32
The number of items that were erased from the map.
See Also

Reference

ParameterMap Class


ParameterMap.ForwardIterator Method

ParameterMapForwardIterator Method

Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ParameterMapIterator ForwardIterator()
Public Overridable Function ForwardIterator As ParameterMapIterator
public:
virtual ParameterMapIterator^ ForwardIterator()
abstract ForwardIterator : unit -> ParameterMapIterator
override ForwardIterator : unit -> ParameterMapIterator

Return Value

ParameterMapIterator
Returns a forward moving iterator to the map.
See Also

Reference

ParameterMap Class


ParameterMap.GetEnumerator Method

ParameterMapGetEnumerator Method

Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

IEnumerator
Returns a forward moving iterator to the map.

Implements

IEnumerableGetEnumerator
See Also

Reference

ParameterMap Class


ParameterMap.Insert Method

ParameterMapInsert Method

Insert the specified item with the specified key into the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Insert(
    string key,
    Parameter item
)
Public Overridable Function Insert (
    key As String,
    item As Parameter
) As Boolean
public:
virtual bool Insert(
    String^ key,
    Parameter^ item
)
abstract Insert :
        key : string *
        item : Parameter -> bool
override Insert :
        key : string *
        item : Parameter -> bool

Parameters

key String
The key to be used for inserting the item into the map.
item Parameter
The item to be inserted into the map.

Return Value

Boolean
Returns whether the item was inserted into the map.
See Also

Reference

ParameterMap Class


ParameterMap.ReverseIterator Method

ParameterMapReverseIterator Method

Retrieve a backward moving iterator to the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ParameterMapIterator ReverseIterator()
Public Overridable Function ReverseIterator As ParameterMapIterator
public:
virtual ParameterMapIterator^ ReverseIterator()
abstract ReverseIterator : unit -> ParameterMapIterator
override ReverseIterator : unit -> ParameterMapIterator

Return Value

ParameterMapIterator
Returns a backward moving iterator to the map.
See Also

Reference

ParameterMap Class


ParameterMapIterator Class

An iterator to a map relating a parameter name (the key, a String) to a parameter.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBParameterMapIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class ParameterMapIterator : APIObject,
    IEnumerator
Public MustInherit Class ParameterMapIterator
    Inherits APIObject
    Implements IEnumerator
public ref class ParameterMapIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type ParameterMapIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The ParameterMapIterator type exposes the following members.

Constructors
 | Name | Description
Public method | ParameterMapIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Key | Retrieves the key that is the current focus of the iterator.
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the map.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ParameterMapIterator Constructor

For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ParameterMapIterator()
Public Sub New
public:
ParameterMapIterator()
new : unit -> ParameterMapIterator
Remarks
This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.
See Also

Reference

ParameterMapIterator Class


ParameterMapIterator Properties

The ParameterMapIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Key | Retrieves the key that is the current focus of the iterator.
Top
See Also

Reference

ParameterMapIterator Class


ParameterMapIterator.Current Property

ParameterMapIteratorCurrent Property

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}
abstract Current : Object with get
override Current : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.
See Also

Reference

ParameterMapIterator Class


ParameterMapIterator.Key Property

ParameterMapIteratorKey Property

Retrieves the key that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string Key { get; }
Public Overridable ReadOnly Property Key As String
    Get
public:
virtual property String^ Key {
    String^ get ();
}
abstract Key : string with get
override Key : string with get

Property Value

String
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid key as per expected behavior of IEnumerator.
See Also

Reference

ParameterMapIterator Class


ParameterMapIterator Methods

The ParameterMapIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the map.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ParameterMapIterator Class


ParameterMapIterator.MoveNext Method

ParameterMapIteratorMoveNext Method

Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the map.

Implements

IEnumeratorMoveNext
Remarks
MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.
See Also

Reference

ParameterMapIterator Class


ParameterMapIterator.Reset Method

ParameterMapIteratorReset Method

Bring the iterator back to the start of the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
Remarks
The Reset method will return the iterator back to the start of the map in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.
See Also

Reference

ParameterMapIterator Class


ParameterSet Class

A set that contains parameters.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBParameterSet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ParameterSet : APIObject,
    IEnumerable
Public Class ParameterSet
    Inherits APIObject
    Implements IEnumerable
public ref class ParameterSet : public APIObject,
    IEnumerable
type ParameterSet =
    class
        inherit APIObject
        interface IEnumerable
    end

The ParameterSet type exposes the following members.

Constructors
 | Name | Description
Public method | ParameterSet | Initializes a new instance of the ParameterSet class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Size | Returns the number of parameters that are in the set.
Top
Methods
 | Name | Description
Public method | Clear | Removes every parameter from the set, rendering it empty.
Public method | Contains | Tests for the existence of a parameter within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase | Removes a specified parameter from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified parameter into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ParameterSet Constructor

Initializes a new instance of the ParameterSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ParameterSet()
Public Sub New
public:
ParameterSet()
new : unit -> ParameterSet
See Also

Reference

ParameterSet Class


ParameterSet Properties

The ParameterSet type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Size | Returns the number of parameters that are in the set.
Top
See Also

Reference

ParameterSet Class


ParameterSet.IsEmpty Property

ParameterSetIsEmpty Property

Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Boolean
Remarks
If the set is empty then True will be returned, otherwise False.
See Also

Reference

ParameterSet Class


ParameterSet.Size Property

ParameterSetSize Property

Returns the number of parameters that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
abstract Size : int with get
override Size : int with get

Property Value

Int32
See Also

Reference

ParameterSet Class


ParameterSet Methods

The ParameterSet type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Removes every parameter from the set, rendering it empty.
Public method | Contains | Tests for the existence of a parameter within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase | Removes a specified parameter from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified parameter into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ParameterSet Class


ParameterSet.Clear Method

ParameterSetClear Method

Removes every parameter from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

ParameterSet Class


ParameterSet.Contains Method

ParameterSetContains Method

Tests for the existence of a parameter within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Contains(
    Parameter item
)
Public Overridable Function Contains (
    item As Parameter
) As Boolean
public:
virtual bool Contains(
    Parameter^ item
)
abstract Contains :
        item : Parameter -> bool
override Contains :
        item : Parameter -> bool

Parameters

item Parameter
The parameter to be searched for.

Return Value

Boolean
The Contains method returns True if the parameter is within the set, otherwise False.
See Also

Reference

ParameterSet Class


ParameterSet.Erase Method

ParameterSetErase Method

Removes a specified parameter from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Erase(
    Parameter item
)
Public Overridable Function Erase (
    item As Parameter
) As Integer
public:
virtual int Erase(
    Parameter^ item
)
abstract Erase :
        item : Parameter -> int
override Erase :
        item : Parameter -> int

Parameters

item Parameter
The parameter to be erased.

Return Value

Int32
The number of parameters that were erased from the set.
See Also

Reference

ParameterSet Class


ParameterSet.ForwardIterator Method

ParameterSetForwardIterator Method

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ParameterSetIterator ForwardIterator()
Public Overridable Function ForwardIterator As ParameterSetIterator
public:
virtual ParameterSetIterator^ ForwardIterator()
abstract ForwardIterator : unit -> ParameterSetIterator
override ForwardIterator : unit -> ParameterSetIterator

Return Value

ParameterSetIterator
Returns a forward moving iterator to the set.
See Also

Reference

ParameterSet Class


ParameterSet.GetEnumerator Method

ParameterSetGetEnumerator Method

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

IEnumerator
Returns a forward moving iterator to the set.

Implements

IEnumerableGetEnumerator
See Also

Reference

ParameterSet Class


ParameterSet.Insert Method

ParameterSetInsert Method

Insert the specified parameter into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Insert(
    Parameter item
)
Public Overridable Function Insert (
    item As Parameter
) As Boolean
public:
virtual bool Insert(
    Parameter^ item
)
abstract Insert :
        item : Parameter -> bool
override Insert :
        item : Parameter -> bool

Parameters

item Parameter
The parameter to be inserted into the set.

Return Value

Boolean
Returns whether the parameter was inserted into the set.
See Also

Reference

ParameterSet Class


ParameterSet.ReverseIterator Method

ParameterSetReverseIterator Method

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ParameterSetIterator ReverseIterator()
Public Overridable Function ReverseIterator As ParameterSetIterator
public:
virtual ParameterSetIterator^ ReverseIterator()
abstract ReverseIterator : unit -> ParameterSetIterator
override ReverseIterator : unit -> ParameterSetIterator

Return Value

ParameterSetIterator
Returns a backward moving iterator to the set.
See Also

Reference

ParameterSet Class


ParameterSetIterator Class

An iterator to a parameter set.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBParameterSetIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class ParameterSetIterator : APIObject,
    IEnumerator
Public MustInherit Class ParameterSetIterator
    Inherits APIObject
    Implements IEnumerator
public ref class ParameterSetIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type ParameterSetIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The ParameterSetIterator type exposes the following members.

Constructors
 | Name | Description
Public method | ParameterSetIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ParameterSetIterator Constructor

For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ParameterSetIterator()
Public Sub New
public:
ParameterSetIterator()
new : unit -> ParameterSetIterator
Remarks
This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.
See Also

Reference

ParameterSetIterator Class


ParameterSetIterator Properties

The ParameterSetIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

ParameterSetIterator Class


ParameterSetIterator.Current Property

ParameterSetIteratorCurrent Property

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}
abstract Current : Object with get
override Current : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.
See Also

Reference

ParameterSetIterator Class


ParameterSetIterator Methods

The ParameterSetIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ParameterSetIterator Class


ParameterSetIterator.MoveNext Method

ParameterSetIteratorMoveNext Method

Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumeratorMoveNext
Remarks
MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.
See Also

Reference

ParameterSetIterator Class


ParameterSetIterator.Reset Method

ParameterSetIteratorReset Method

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
Remarks
The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.
See Also

Reference

ParameterSetIterator Class


ParametersOrder Enumeration

The order of the parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ParametersOrder
Public Enumeration ParametersOrder
public enum class ParametersOrder
type ParametersOrder
Members
Member name | Value | Description
Ascending | 0 | Sort parameters are in ascending(A-Z) order.
Descending | 1 | Sort parameters are in descending(Z-A) order.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ParameterTypeId Class

Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBParameterTypeId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ParameterTypeId
Public NotInheritable Class ParameterTypeId
public ref class ParameterTypeId abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ParameterTypeId = class end

The ParameterTypeId type exposes the following members.

Properties
Name | Description
ActualMaxRidgeHeightParam | "Maximum Ridge Height"
AlignmentStationLabelDistance | "Distance": Currently not in use
AlignmentStationLabelIncludeStation | "Include Station"
AlignmentStationLabelIndStation | "Station Indicator"
AlignmentStationLabelSetEndStation | "Alignment Label Set End Station"
AlignmentStationLabelSetInterval | "Alignment Station Label Set Interval": The text is not used directly anywhere in the UI, instead the XAML specifies its own string for the value's label.
AlignmentStationLabelSetOffset | "Alignment Station Label Set Offset": The text is not used directly anywhere in the UI, instead the XAML specifies its own string for the value's label.
AlignmentStationLabelSetStartStation | "Alignment Label Set Start Station"
AlignmentStationLabelStationValue | "Station Value"
AlignmentStationPrefix | "Station Prefix"
AlignmentStationSuffix | "Station Suffix"
AllGridRotationForDivisionRule | "All Grid Rotation"
AllModelDescription | "Description"
AllModelImage | "Image"
AllModelInstanceComments | "Comments"
AllModelManufacturer | "Manufacturer"
AllModelModel | "Model"
AllModelTypeComments | "Type Comments"
AllModelTypeImage | "Type Image"
AllModelUrl | "URL"
AllowAutoEmbed | "Automatically Embed"
AllowMultipleSelection | "Allow Multiple Selection": This is used by the UI to allow selection of multiple elements.
AlternateUnits | "Alternate Units"
AlternateUnitsPrefix | "Alternate Units Prefix"
AlternateUnitsSuffix | "Alternate Units Suffix"
AlwaysZeroLength | "Base Offset"
AnalyticalAbsorptance | "Absorptance"
AnalyticalAdjacentSpace | "Adjacent Analytical Space"
AnalyticalDefineThermalPropertiesBy | "Define Thermal Properties by"
AnalyticalElementHasAssociation | "Has Association": Used for Analytical Member, Analytical Panel, Structural Columns, Structural Framing, Floors, Walls, Structural Foundation
AnalyticalElementPhysicalAsset | "Physical Material Asset": Used for Analytical Elements.
AnalyticalElementStructuralRole | "Structural Role": Used for Analytical Elements
AnalyticalGeometryIsValid | "Analytical Model Correct"
AnalyticalHeatTransferCoefficient | "Heat Transfer Coefficient (U)"
AnalyticalLinkReleaseRotationX | "X Rotation"
AnalyticalLinkReleaseRotationY | "Y Rotation"
AnalyticalLinkReleaseRotationZ | "Z Rotation"
AnalyticalLinkReleaseTranslationX | "X Translation"
AnalyticalLinkReleaseTranslationY | "Y Translation"
AnalyticalLinkReleaseTranslationZ | "Z Translation"
AnalyticalMemberForceEndAllNonZero | "All non 0 forces at end"
AnalyticalMemberForceEndFx | "End Fx"
AnalyticalMemberForceEndFy | "End Fy"
AnalyticalMemberForceEndFz | "End Fz"
AnalyticalMemberForceEndMx | "End Mx"
AnalyticalMemberForceEndMy | "End My"
AnalyticalMemberForceEndMz | "End Mz"
AnalyticalMemberForceStartAllNonZero | "All non 0 forces at start"
AnalyticalMemberForceStartFx | "Start Fx"
AnalyticalMemberForceStartFy | "Start Fy"
AnalyticalMemberForceStartFz | "Start Fz"
AnalyticalMemberForceStartMx | "Start Mx"
AnalyticalMemberForceStartMy | "Start My"
AnalyticalMemberForceStartMz | "Start Mz"
AnalyticalMemberRotation | "Cross-Section Rotation": Used for Analytical Member
AnalyticalMemberSectionType | "Section Type": The id of the type from the structural Family assigned to the analytical member.
AnalyticalModelArea | "Area": The Area of Analytical Model
AnalyticalModelBaseAlignmentMethod | "Base Alignment Method"
AnalyticalModelBaseExtensionMethod | "Base Extension Method"
AnalyticalModelBaseYProjection | "Base y Projection"
AnalyticalModelBaseZProjection | "Base z Projection"
AnalyticalModelCodeChecking | "Code Checking": Used for Analytical wall, Analytical beam, Analytical column, Analytical floor, Analytical wall foundations, Analytical isolated foundations, Analytical foundations slab, Anaytical brace
AnalyticalModelColumnBaseExtension | "Base x Projection"
AnalyticalModelColumnTopExtension | "Top x Projection"
AnalyticalModelEndAlignmentMethod | "End Alignment Method"
AnalyticalModelEndProjectionOrthogonal | "End Projection Orthogonal"
AnalyticalModelEndYProjection | "End y Projection"
AnalyticalModelEndZProjection | "End z Projection"
AnalyticalModelFloorAlignmentMethod | "Alignment Method"
AnalyticalModelFloorProjection | "z Projection"
AnalyticalModelFoundationsMark | "Foundation Number": Used for isolated, wall foundations
AnalyticalModelLength | "Length": The length of Analytical Model
AnalyticalModelManuallyAdjusted | "Manually Adjusted"
AnalyticalModelNodesMark | "Node Number": Used for nodes
AnalyticalModelPerimeter | "Perimeter": The Perimeter of Analytical Model
AnalyticalModelPhysicalType | "Family Type": the Family Type of the physical element associated with the Analytical Model
AnalyticalModelRotation | "Cross-Section Rotation": The rotation of Analytical Model
AnalyticalModelSketchAlignmentMethod | "Alignment Method"
AnalyticalModelSketchProjection | "In-Plane Projection"
AnalyticalModelStartAlignmentMethod | "Start Alignment Method"
AnalyticalModelStartProjectionOrthogonal | "Start Projection Orthogonal"
AnalyticalModelStartYProjection | "Start y Projection"
AnalyticalModelStartZProjection | "Start z Projection"
AnalyticalModelStickElementsMark | "Member Number": Used for beams, braces, columns
AnalyticalModelSurfaceElementsMark | "Surface Number": Used for floors, slabs, walls
AnalyticalModelTopAlignmentMethod | "Top Alignment Method"
AnalyticalModelTopExtensionMethod | "Top Extension Method"
AnalyticalModelTopYProjection | "Top y Projection"
AnalyticalModelTopZProjection | "Top z Projection"
AnalyticalModelWallAlignmentMethod | "Alignment Method"
AnalyticalModelWallBaseProjection | "Base y Projection"
AnalyticalModelWallProjection | "z Projection"
AnalyticalModelWallTopProjection | "Top y Projection"
AnalyticalNodeCanBeHosted | "Can Be Hosted": Specifies of the Analytical Node can be hosted or not.
AnalyticalNodeConnectionStatus | "Connection Status"
AnalyticalNodeType | "Node Type": Specifies the type of the Analytical Node: hosted or not.
AnalyticalPanelThickness | "Thickness": Used for Analytical Panel
AnalyticalRoughness | "Roughness"
AnalyticalSolarHeatGainCoefficient | "Solar Heat Gain Coefficient"
AnalyticalSpace | "Analytical Space"
AnalyticalSurface | "Analytical Surface"
AnalyticalThermalMass | "Thermal Mass"
AnalyticalThermalResistance | "Thermal Resistance (R)"
AnalyticalVisualLightTransmittance | "Visual Light Transmittance"
AnalyticalZone | "Analytical Zone"
AnalyticalZoneName | "Name"
AnalyticConstruction | "Analytic Construction"
AnalyticConstructionGbxmlTypeid | "Construction Type Id"
AnalyticConstructionLookupTable | "Analytic Construction"
AnyPatternIdParam | "Fill Pattern"
AnyPatternIdParamNoNo | "Fill Pattern"
ArcCenterMark | "Center Marks"
ArcElemFixKeepConcentric | "Keep Concentric"
ArcLeaderParam | "Arc Leaders"
ArcWallCntrMrkVisible | "Center Mark Visible"
AreaSchemeId | "Area Scheme Id"
AreaSchemeName | "Name"
AreaType | "Area Type"
AreaTypeText | "Area Type"
ArrowCentered | "Tick Mark Centered"
ArrowClosed | "Arrow Closed"
ArrowFilled | "Fill Tick"
ArrowheadEndAtRiser | "End at Riser"
ArrowheadType | "Arrowhead Type"
ArrowSize | "Tick Size"
ArrowType | "Arrow Style"
AssemblyName | "Assembly Name"
AssemblyNamingCategory | "Naming Category"
AssemblyPrecastFreeze | "Disable Precast Updates"
AssignTemplateOnViewCreation | "New views are dependent on template"
AssociatedLevel | "Associated Level": The level associated with this cell.
AssociatedLevelOffset | "Associated Level Offset": The offset from the associated level.
AutoJoinCondition | "Join Condition"
AutoJoinConditionWall | "Join Condition"
AutoMullionBorder1Grid1 | "Border 1 Type"
AutoMullionBorder1Grid2 | "Border 1 Type"
AutoMullionBorder1Horiz | "Border 1 Type"
AutoMullionBorder1Vert | "Border 1 Type"
AutoMullionBorder2Grid1 | "Border 2 Type"
AutoMullionBorder2Grid2 | "Border 2 Type"
AutoMullionBorder2Horiz | "Border 2 Type"
AutoMullionBorder2Vert | "Border 2 Type"
AutoMullionInteriorGrid1 | "Interior Type"
AutoMullionInteriorGrid2 | "Interior Type"
AutoMullionInteriorHoriz | "Interior Type"
AutoMullionInteriorVert | "Interior Type"
AutoPanel | "Curtain Panel"
AutoPanelWall | "Curtain Panel"
Azimuth | "Azimuth"
BackgroundDraftPatternIdParam | "Background Fill Pattern"
BackgroundPatternColorParam | "Background Pattern Color"
BaselineDimOffset | "Baseline Offset"
BasepointAngletonParam | "Angle to True North"
BasepointEastwestParam | "E/W"
BasepointElevationParam | "Elev"
BasepointLatitudeParam | "Lat"
BasepointLongitudeParam | "Lon"
BasepointNorthsouthParam | "N/S"
BeamHJustification | "Lateral Justification"
BeamSystem3dParam | "3D"
BeamSystemTagInstParamAngle | "Beam System Tag Direction"
BeamSystemTagParamLeft | "Left"
BeamSystemTagParamRight | "Right"
BeamVJustification | "z-Direction Justification"
BeamVJustificationOtherValue | "z-Direction Offset Value"
BendingDetailAngularDimensionTextPosition | "Angle Text Position"
BendingDetailDetailLevel | "Detail Level"
BendingdetailPosition | "Bending Detail Position"
BendingDetailRepresentationFor3dBars | "View for 3D Shape"
BendingDetailSegmentLengthDimensionTextPosition | "Dimension Text Position"
BendingDetailSegmentRepresentation | "Representation"
BendingDetailTypeAngularDimensionOffset | "Angular Dimension Offset"
BendingDetailTypeAngularDimensionsEnabled | "Angular Dimensions"
BendingDetailTypeAngularDimensionsForHooksEnabled | "Hook Angles"
BendingDetailTypeAngularDimensionsMeasurement | "Angle Measurement"
BendingDetailTypeAngularDimensionTypeId | "Angular Dimension Style"
BendingDetailTypeBendDiameterDimensionsEnabled | "Bend Diameter Dimensions"
BendingDetailTypeBendDiameterDimensionsForHooksEnabled | "Hook Bends"
BendingDetailTypeBendDiameterDimensionsForSegmentsEnabled | "Segment Bends"
BendingDetailTypeDiameterDimensionTypeId | "Diameter Dimension Style"
BendingDetailTypeOrthogonalAndOverallDimesionsEnabled | "Other Dimensions"
BendingDetailTypeRadialDimensionTypeId | "Radial Dimension Style"
BendingDetailTypeSchematicHeight | "Height"
BendingDetailTypeSchematicWidth | "Width"
BendingDetailTypeSegmentLengthDimensionsEnabled | "Segment Length Dimensions"
BendingDetailTypeSegmentLengthDimensionsForHooksEnabled | "Hook Lengths"
BendingDetailTypeSegmentLengthDimensionsOffset | "Dimension Offset"
BendingDetailTypeSegmentLengthDimensionTypeId | "Linear Dimension Style"
BendingDetailTypeSegmentLengthsDisplayOption | "Straight Segment Lengths"
BendingDetailTypeSegmentLengthsForArcsDisplayOption | "Arc Segment Lengths"
BendingDetailTypeShowAngularDimensionsFor | "Show for Angles"
BendingDetailTypeShowBarBendingUsing | "Dimension Type"
BendingDetailTypeTagTypeId | "Tag Type"
BendingDetailVaryingRebarDimension | "Varying Rebar Set Dimensions"
BentFabricParamBendDirection | "Bend Direction": Direction in which FabricSheet is bent.
BentFabricParamLongitudinalCutLength | "Longitudinal Cut Length": Bent fabric longitudinal cut length.
BentFabricParamStraightWiresLocation | "Straight Wires Location": Location of straight wires in a bent fabric.
BlendDepthParam | "Depth"
BlendEndParam | "Second End"
BlendStartParam | "First End"
BoundaryAreaRestraintX | "X Spring Modulus"
BoundaryAreaRestraintY | "Y Spring Modulus"
BoundaryAreaRestraintZ | "Z Spring Modulus"
BoundaryBearing | "Bearing"
BoundaryConditionsIsExt | "Is Boundary Conditions External?"
BoundaryConditionsType | "Boundary Conditions Type"
BoundaryDirectionRotX | "X Rotation"
BoundaryDirectionRotY | "Y Rotation"
BoundaryDirectionRotZ | "Z Rotation"
BoundaryDirectionX | "X Translation"
BoundaryDirectionY | "Y Translation"
BoundaryDirectionZ | "Z Translation"
BoundaryDistance | "Distance"
BoundaryLinearRestraintRotX | "X Spring Modulus"
BoundaryLinearRestraintX | "X Spring Modulus"
BoundaryLinearRestraintY | "Y Spring Modulus"
BoundaryLinearRestraintZ | "Z Spring Modulus"
BoundaryParamPreset | "State"
BoundaryParamPresetArea | "State"
BoundaryParamPresetLinear | "State"
BoundaryRadius | "Radius"
BoundaryRestraintRotX | "X Spring Modulus"
BoundaryRestraintRotY | "Y Spring Modulus"
BoundaryRestraintRotZ | "Z Spring Modulus"
BoundaryRestraintX | "X Spring Modulus"
BoundaryRestraintY | "Y Spring Modulus"
BoundaryRestraintZ | "Z Spring Modulus"
BoundaryXRotationFixed | "X Rotation - Fixed"
BoundaryXRotationSpring | "X Rotation - Spring"
BoundaryXTranslationFixed | "X Translation - Fixed"
BoundaryXTranslationSpring | "X Translation - Spring"
BoundaryYRotationFixed | "Y Rotation - Fixed"
BoundaryYRotationSpring | "Y Rotation - Spring"
BoundaryYTranslationFixed | "Y Translation - Fixed"
BoundaryYTranslationSpring | "Y Translation - Spring"
BoundaryZRotationFixed | "Z Rotation - Fixed"
BoundaryZRotationSpring | "Z Rotation - Spring"
BoundaryZTranslationFixed | "Z Translation - Fixed"
BoundaryZTranslationSpring | "Z Translation - Spring"
BrOrgFilter | "Filter"
BrOrgFolders | "Folders"
BuildingClosingTimeParam | "Closing Time"
BuildingCurveGstyle | "Line Style"
BuildingCurveGstylePlusInvisible | "Subcategory"
BuildingOpeningTimeParam | "Opening Time"
BuildingpadHeightabovelevelParam | "Height Offset From Level"
BuildingpadThickness | "Thickness"
BuildingUnoccupiedCoolingSetPointParam | "Unoccupied Cooling Set Point"
BuilidingPadStructureIdParam | "Structure"
CabletrayMinbendmultiplierParam | "Bend Radius Multiplier"
CalloutAttrHeadTag | "Callout Head"
CalloutCornerSheetRadius | "Corner Radius"
CalloutSyncronizeBoundOffsetFar | "Far Clip Settings"
CalloutTag | "Callout Tag"
CeilingAttrDefaultHeightParam | "Default Height above level"
CeilingAttrPatternParam | "Pattern"
CeilingAttrSpacing1Param | "Spacing Axis 1"
CeilingAttrSpacing2Param | "Spacing Axis 2"
CeilingAttrSystemnameParam | "System"
CeilingHasThicknessParam | "Has Thickness"
CeilingHeightabovelevelParam | "Height Offset From Level"
CeilingStructureIdParam | "Structure"
CeilingThickness | "Thickness"
CeilingThicknessParam | "Thickness"
CenterMarkSize | "Center Mark Size"
CircMullionRadius | "Radius"
CircuitLoadClassificationAbbreviationParam | "Load Classification Abbreviation"
CircuitLoadClassificationParam | "Load Classification"
CircuitPhaseParam | "Phase Label"
CircuitWaysParam | "Ways"
CircularFramingDiameter | "Circular Diameter"
ClearCover | "Rebar Cover"
ClearCoverBottom | "Rebar Cover - Bottom Face"
ClearCoverExterior | "Rebar Cover - Exterior Face"
ClearCoverInterior | "Rebar Cover - Interior Face"
ClearCoverOther | "Rebar Cover - Other Faces"
ClearCoverTop | "Rebar Cover - Top Face"
ClientName | "Client Name"
ClineSubcategory | "Subcategory"
CoarseScaleFillPatternColor | "Coarse Scale Fill Color"
CoarseScaleFillPatternIdParam | "Coarse Scale Fill Pattern"
ColorFillFilteredParam | "Values Displayed"
ColorFillSwatchHeightParam | "Swatch Height"
ColorFillSwatchWidthParam | "Swatch Width"
ColorSchemeLocation | "Color Scheme Location"
ColumnBaseAttachCutParam | "Base Attachment Cut"
ColumnBaseAttachedParam | "Base is Attached"
ColumnBaseAttachJustificationParam | "Attachment Justification At Base"
ColumnBaseAttachmentOffsetParam | "Offset From Attachment At Base"
ColumnLocationMark | "Column Location Mark"
ColumnTopAttachCutParam | "Top Attachment Cut"
ColumnTopAttachedParam | "Top is Attached"
ColumnTopAttachJustificationParam | "Attachment Justification At Top"
ColumnTopAttachmentOffsetParam | "Offset From Attachment At Top"
ConceptualConstructionMaterial | "Graphical Appearance"
ConduitStandardTypeParam | "Standard"
ConnectorAngle | "Angle"
ConnectorAngleOfDeflection | "Angle of Deflection"
ConnectorDiameter | "Diameter"
ConnectorEngagementLength | "Engagement Length"
ConnectorGenderType | "Connector Gender Type"
ConnectorHeight | "Height"
ConnectorIndex | "Index"
ConnectorInsideDiameter | "Inside Diameter"
ConnectorJointType | "Connector Joint Type"
ConnectorLength | "Length"
ConnectorProfileType | "Shape"
ConnectorRadius | "Radius"
ConnectorReferenceIndex | "Link Connector Index"
ConnectorUtilityParam | "Utility"
ConnectorVisibleSize | "Size on screen"
ConnectorWidth | "Width"
ConstructionIsSchematic | "Schematic"
ConstructionName | "Name"
ContinuousFootingBearingWidth | "Width"
ContinuousFootingBottomHeel | "Bottom Heel Length"
ContinuousFootingBottomToe | "Bottom Toe Length"
ContinuousFootingBreakAtInsertsDisable | "Do Not Break At Inserts"
ContinuousFootingDefaultEndExtensionLength | "Default End Extension Length"
ContinuousFootingEccentricity | "Eccentricity"
ContinuousFootingLength | "Length"
ContinuousFootingStructuralUsage | "Structural Usage"
ContinuousFootingTopHeel | "Heel Length"
ContinuousFootingTopToe | "Toe Length"
ContinuousFootingWidth | "Width"
ContinuousrailBeginningTerminationAttachmentParam | "Extension Style"
ContinuousrailBeginningTerminationTypeParam | "Beginning/Bottom Termination"
ContinuousrailDefaultJoinTypeParam | "Default Join"
ContinuousrailEndExtensionLengthParam | "Length"
ContinuousrailEndTerminationAttachmentParam | "Extension Style"
ContinuousrailEndTerminationTypeParam | "End/Top Termination"
ContinuousrailExtensionLengthParam | "Length"
ContinuousrailFilletRadiusParam | "Fillet Radius"
ContinuousrailJoinTypeParam | "Rail Path Join"
ContinuousrailLengthParam | "Length"
ContinuousrailMaterialsParam | "Material"
ContinuousrailPlusTreadDepthParam | "Plus Tread Depth"
ContinuousrailProfileTypeParam | "Profile"
ContinuousrailTransitionTypeParam | "Transitions"
ContourElevation | "Elevation"
ContourElevationStep | "Increment"
ContourLabelsElevBaseType | "Elevation Base"
ContourLabelsLinearUnits | "Units Format"
ContourLabelsPrimaryOnly | "Label primary contours only"
ContourLabelsRelativeBase | "Relative Base"
CouplerCode | "Part Number"
CouplerCoupledBarSize | "Bar Size 2"
CouplerCoupledEndtreatment | "End Treatment 2"
CouplerCoupledEngagement | "Bar Engagement 2"
CouplerLength | "Total Length"
CouplerMainBarSize | "Bar Size 1"
CouplerMainEndtreatment | "End Treatment 1"
CouplerMainEngagement | "Bar Engagement 1"
CouplerMark | "Schedule Mark"
CouplerNumber | "Coupler Number"
CouplerQuantity | "Quantity"
CouplerRotationAngle | "Coupler Rotation"
CouplerWeight | "Mass"
CouplerWidth | "External Diameter"
CoverTypeLength | "Length"
CoverTypeName | "Name"
CurtaingridAdjustBorderHoriz | "Adjust for Mullion Size"
CurtaingridAdjustBordern1 | "Adjust for Mullion Size"
CurtaingridAdjustBordern2 | "Adjust for Mullion Size"
CurtaingridAdjustBorderU | "Adjust for Mullion Size"
CurtaingridAdjustBorderV | "Adjust for Mullion Size"
CurtaingridAdjustBorderVert | "Adjust for Mullion Size"
CurtaingridAngleHoriz | "Angle"
CurtaingridAnglen1 | "Angle"
CurtaingridAnglen2 | "Angle"
CurtaingridAngleU | "Grid Rotation"
CurtaingridAngleV | "Grid Rotation"
CurtaingridAngleVert | "Angle"
CurtainGridBaseOrientation | "Grid Base Orientation"
CurtaingridBeltHoriz | "Measurement Line"
CurtaingridBeltn1 | "Measurement Line"
CurtaingridBeltn2 | "Measurement Line"
CurtaingridBeltRation1 | "Measurement Line"
CurtaingridBeltRation2 | "Measurement Line"
CurtaingridBeltRatioU | "Belt Measurement"
CurtaingridBeltRatioV | "Belt Measurement"
CurtaingridBeltU | "Belt Measurement"
CurtaingridBeltV | "Belt Measurement"
CurtaingridBeltVert | "Measurement Line"
CurtaingridOriginHoriz | "Offset"
CurtaingridOriginn1 | "Offset"
CurtaingridOriginn2 | "Offset"
CurtaingridOriginU | "Offset"
CurtaingridOriginV | "Offset"
CurtaingridOriginVert | "Offset"
CurtaingridUseCurveDist | "Use Curve Distance"
CurtaingridUseCurveDistHoriz | "Use Curve Distance"
CurtaingridUseCurveDistn1 | "Use Curve Distance"
CurtaingridUseCurveDistn2 | "Use Curve Distance"
CurtaingridUseCurveDistU | "Use Curve Distance"
CurtaingridUseCurveDistV | "Use Curve Distance"
CurtaingridUseCurveDistVert | "Use Curve Distance"
CurtainVersionParam | "Curtain version"
CurtainWallPanelHostId | "Host Id"
CurtainWallPanelsHeight | "Height"
CurtainWallPanelsWidth | "Width"
CurtainWallSyspanelOffset | "Offset"
CurtainWallSyspanelThickness | "Thickness"
CurveBottomLevel | "Bottom Level"
CurveByPointsProjectionType | "Projection Type"
CurveDeterminesOrientation | "Determines Orientation"
CurveEdgeOffset | "Wall offset"
CurveElemArcEndAngle | "Angle 2"
CurveElemArcRadius | "Radius"
CurveElemArcRange | "Range"
CurveElemArcStartAngle | "Angle 1"
CurveElemDefinesSlope | "Defines Beam System Slope"
CurveElemLength | "Length"
CurveElemLineAngle | "Angle"
CurveHeightOffset | "Offset From Base"
CurveIsDetail | "Detail Line"
CurveIsFilled | "Filled"
CurveIsMultilevel | "Multilevel Boundary"
CurveIsReferenceLine | "Is Reference Line"
CurveIsSlopeDefining | "Defines Slope"
CurveLevel | "Level"
CurveNumberOfSegments | "Number of Full Segments"
CurveParamConcreteCantilever | "Concrete Cantilever"
CurveParamSteelCantilever | "Steel Cantilever"
CurveSupportOffset | "Wall offset"
CurveTopLevel | "Top Level"
CurveVisibilityParam | "Visibility/Graphics Overrides"
CurveWallOffset | "Wall offset"
CurveWallOffsetRoofs | "Overhang"
CustMullionThick | "Thickness"
CustMullionWidth1 | "Width on side 1"
CustMullionWidth2 | "Width on side 2"
CutLineAngle | "Cut Line Angle"
CutLineDistance | "Cut Line Distance"
CutLineExtension | "Cut Line Extension"
CutLineType | "Cut Line Type"
CutMarkSymbol | "Cut Mark Symbol"
CutMarkSymbolSize | "Cut Mark Symbol Size"
CwpAddGridPrefix | "Add prefix to Grid Name"
CwpAddGridSuffix | "Add suffix to Grid Name"
CwpAddLevelPrefix | "Add prefix to Level Name"
CwpAddLevelSuffix | "Add suffix to Level Name"
CwpCopyFloorInserts | "Copy openings/inserts"
CwpCopyRoofInserts | "Copy openings"
CwpCopyWallInserts | "Copy windows/doors/openings"
CwpLevelOffset | "Offset Level"
CwpLinkedRoomParams | "Parameters"
CwpLinkedRoomPhases | "Phases"
CwpReuseExistingGrids | "Reuse matching Grids"
CwpReuseExistingLevels | "Reuse matching Levels"
CwpReuseGridsSameName | "Reuse Grids with the same name"
CwpReuseLevelsSameName | "Reuse Levels with the same name"
CwpSplitColumnsAtLevels | "Split Columns by Levels"
DatumBubbleEndn1 | "Symbol at End 1 Default"
DatumBubbleEndn2 | "Symbol at End 2 Default"
DatumBubbleLocationInElev | "Non-Plan View Symbols (Default)"
DatumPlaneDefinesOrigin | "Defines Origin"
DatumPlaneDefinesWallClosure | "Wall Closure"
DatumText | "Name"
DatumVolumeOfInterest | "Scope Box"
DecalAttributes | "Decal Attributes"
DecalHeight | "Height"
DecalLockProportions | "Lock Proportions"
DecalSubcategoryId | "Subcategory"
DecalWidth | "Width"
DefaultConstructionExtWallUnderground | "Mass Exterior Wall - Underground"
DefaultConstructionMassExteriorWall | "Mass Exterior Wall"
DefaultConstructionMassFloor | "Mass Floor"
DefaultConstructionMassGlazing | "Mass Glazing"
DefaultConstructionMassInteriorWall | "Mass Interior Wall"
DefaultConstructionMassOpening | "Mass Opening"
DefaultConstructionMassRoof | "Mass Roof"
DefaultConstructionMassShade | "Mass Shade"
DefaultConstructionMassSkylight | "Mass Skylight"
DefaultConstructionMassSlab | "Mass Slab"
DefaultViewTemplate | "View Template applied to new views"
DefinesConstantHeight | "Defines Constant Height"
DesignOptionId | "Design Option"
DesignOptionParam | "Design Option"
DiameterSymbolLocation | "Diameter Symbol Location"
DiameterSymbolText | "Diameter Symbol Text"
DimDisplayEq | "Equality Display"
DimIsreporting | "Is Reporting"
DimLabel | "Label"
DimLabelGpShow | "Show Label in View"
DimLabelIsInstance | "Is Instance Parameter"
DimLeader | "Leader"
DimLeaderArrowhead | "Tick Mark"
DimLeaderDisplayCondition | "Show Leader When Text Moves"
DimLeaderShoulderLength | "Shoulder Length"
DimLeaderType | "Leader Type"
DimLineExtension | "Dimension Line Extension"
DimNotModifiable | "Non-modifiable"
DimPrefix | "Dimension Prefix"
DimReferenceCount | "Count"
DimStyleAngularUnits | "Units Format"
DimStyleAngularUnitsAlt | "Alternate Units Format"
DimStyleCenterlinePattern | "Centerline Pattern"
DimStyleCenterlineSymbol | "Centerline Symbol"
DimStyleCenterlineTickMark | "Centerline Tick Mark"
DimStyleDimLineSnapDist | "Dimension Line Snap Distance"
DimStyleFlippedDimLineExtension | "Flipped Dimension Line Extension"
DimStyleInteriorTickMark | "Interior Tick Mark"
DimStyleLeaderTickMark | "Leader Tick Mark"
DimStyleLinearUnits | "Units Format"
DimStyleLinearUnitsAlt | "Alternate Units Format"
DimStyleReadConvention | "Read Convention"
DimStyleShowOpeningHt | "Show Opening Height"
DimStyleSuppressSpaces | "Suppress Spaces"
DimSuffix | "Dimension Suffix"
DimTextBackground | "Text Background"
DimTextLocationForLeader | "Text Location"
DimToInserts | "Dimension To Openings"
DimToInsertType | "Dimension To Opening Type"
DimToIntersectingGrids | "Dimension To Intersecting Grids"
DimToIntersectingWalls | "Dimension To Intersecting Walls"
DimTotalLength | "Total Length"
DimValueAngle | "Value"
DimValueLength | "Value"
DimWitnsLineCntrl | "Witness Line Control"
DimWitnsLineExtensionBelow | "Witness Line Length"
Directcontext3dApplicationId | "ApplicationId"
Directcontext3dLoaded | "Loaded"
Directcontext3dName | "Name"
Directcontext3dServerId | "ServerId"
Directcontext3dSourceId | "Path"
DisplacedElementDisplacementX | "X Displacement"
DisplacedElementDisplacementY | "Y Displacement"
DisplacedElementDisplacementZ | "Z Displacement"
DisplacementPathDepth | "Depth"
DisplacementPathStyle | "Style"
DistanceToCutMark | "Distance to Cut Mark"
DividedpathBeginningIndent | "Beginning Indent"
DividedpathDisplayNodeNumbers | "Show Node Numbers"
DividedpathDisplayNodes | "Display Nodes"
DividedpathDisplayReferenceCurves | "Display Path"
DividedpathDistance | "Distance"
DividedpathEndIndent | "End Indent"
DividedpathFlipDirection | "Flip Direction"
DividedpathJustification | "Justification"
DividedpathLayout | "Layout"
DividedpathLayoutFixedNumPoint | "Number"
DividedpathMaxDistance | "Maximum Distance"
DividedpathMeasurementType | "Measurement Type"
DividedpathMergedPointNum | "Total Number of Nodes"
DividedpathMinDistance | "Minimum Distance"
DividedpathTotalPathLength | "Path Length"
DividedSurfaceAllGridRotation | "All Grid Rotation"
DividedSurfaceAllPoints | "Show all points"
DividedSurfaceComponentTrimType | "Component Trim"
DividedSurfaceCoverFaceCompletely | "Cover face completely"
DividedSurfaceDisplayComponents | "Components"
DividedSurfaceDisplayDiscardeddivisionlines | "Discarded Division Lines"
DividedSurfaceDisplayGridlines | "Gridlines"
DividedSurfaceDisplayNodes | "Nodes"
DividedSurfaceDisplayOriginalSurface | "Surface"
DividedSurfaceDisplayPatternFill | "Pattern Fill"
DividedSurfaceDisplayPatternLines | "Pattern Lines"
DividedSurfaceDisplaySurfaceOption | "Display Surface Option"
DividedSurfaceEdgeNumber | "Edge number"
DividedSurfaceFacetNumber | "Facet number"
DividedSurfaceGridlinesStyle | "Gridlines Style"
DividedSurfaceGridOptionParamn1 | "Option 1"
DividedSurfaceGridOptionParamn2 | "Option 2"
DividedSurfaceOffsetFromSurface | "Offset from surface"
DividedSurfaceOriginalSurfaceMaterial | "Surface Material"
DividedSurfacePattern | "Tile Pattern"
DividedSurfacePatternFillMaterial | "Pattern Fill Material"
DividedSurfacePatternFlip | "Component Flip"
DividedSurfacePatternIndentn1 | "Indent 1"
DividedSurfacePatternIndentn2 | "Indent 2"
DividedSurfacePatternLinesStyle | "Pattern Lines Style"
DividedSurfacePatternMirror | "Component Mirror"
DividedSurfacePatternRotationAngle | "Component Rotation"
DividedSurfacePointNumber | "Point number"
DividedSurfaceRule1Suspension | "Is grid 1 suspended?"
DividedSurfaceRule2Suspension | "Is grid 2 suspended?"
DividedSurfaceSurfaceArea | "Divided Surface Area"
DividedSurfaceTileBorder | "Border Tile"
DividedSurfaceTotalEdgeLength | "Total edge length"
DivisionPattern | "Division Pattern"
DivisionProfileWidth | "Width": Width
DivisionRuleParam | "Division Rule"
DivisionSketchCurveDivisionParamsOverrideParam | "Profile Override"
DivisionSketchCurveExtentdToSilhParam | "Extend to Silhouette"
DoorConstructionType | "Construction Type"
DoorCost | "Cost"
DoorEvacuationExitType | "Exit Access"
DoorFinish | "Finish"
DoorFrameMaterial | "Frame Material"
DoorFrameType | "Frame Type"
DoorNumber | "Mark"
DoorOperationType | "Operation"
DpartAreaComputed | "Area"
DpartBaseLevel | "Base Level"
DpartBaseLevelByOriginal | "Base Level By Original"
DpartCanHostRebar | "Can host rebar"
DpartExcluded | "Excluded"
DpartHeightComputed | "Height"
DpartLayerConstruction | "Construction"
DpartLayerFunction | "Layer Function"
DpartLayerIndex | "Layer Index"
DpartLayerWidth | "Thickness"
DpartLengthComputed | "Length"
DpartMaterialByOriginal | "Material By Original"
DpartMaterialIdParam | "Material"
DpartOriginalCategory | "Original Category"
DpartOriginalCategoryId | "Original Category"
DpartOriginalFamily | "Original Family"
DpartOriginalType | "Original Type"
DpartPhaseCreatedByOriginal | "Phase Created By Original"
DpartPhaseDemolishedByOriginal | "Phase Demolished By Original"
DpartShapeModified | "Shape is modified"
DpartVolumeComputed | "Volume"
DrawForEachRun | "Draw for Each Run"
DuctInsulationThickness | "Insulation Thickness"
DuctRoughness | "Roughness"
DuctTerminalEngagementLength | "Engagement Length"
EdgeLinework | "Line Style"
EditedBy | "Edited by"
ElecticalEquipVoltage | "Voltage Comments"
ElecticalEquipWattage | "Wattage Comments"
ElemCategoryParam | "Category"
ElemCategoryParamMt | "Category"
ElemDeletableInFamily | "Deletable"
ElementIsCutting | "Solid/Void"
ElementLockedParam | "Locked"
ElemFamilyAndTypeParam | "Family and Type"
ElemFamilyParam | "Family"
ElemIsReference | "Reference"
ElemPartitionParam | "Workset"
ElemReferenceName | "Is Reference"
ElemReferenceName2dXz | "Is Reference"
ElemRoomId | "Room Id"
ElemRoomName | "Room Name"
ElemRoomNumber | "Room Number"
ElemTypeLabel | "Label"
ElemTypeParam | "Type"
ElevArrowAngle | "Arrow Angle"
ElevArrowFilled | "Filled"
ElevAssocDatum | "Associated Datum"
ElevatnTag | "Elevation Tag"
ElevReferenceLabelPos | "Reference Label Position"
ElevShape | "Shape"
ElevShowViewName | "Show View Name"
ElevSymbolId | "Elevation Mark"
ElevTextPos | "Text Position"
ElevViewNamePos | "View Name Position"
ElevWidth | "Width"
EllipseFocusMrkVisible | "Focus Marks Visible"
EllipseModificationKeepsRatio | "Keep Ratio"
EllipseXParam | "X-Radius Value for Ellipse (for Use with XAML Data Template example)"
EllipseYParam | "Y-Radius Value for Ellipse (for Use with XAML Data Template example)"
EndExtension | "End Extension"
EndJoinCutback | "End Join Cutback"
EndTreatment | "End Treatment"
EndYJustification | "End y Justification"
EndYOffsetValue | "End y Offset Value"
EndZJustification | "End z Justification"
EndZOffsetValue | "End z Offset Value"
EnergyAnalysisAdvancedOptions | "Other Options"
EnergyAnalysisBuildingOperatingSchedule | "Building Operating Schedule"
EnergyAnalysisConceptualConstruction | "Conceptual Types"
EnergyAnalysisCreateAnalyticalModel | "Create Energy Model"
EnergyAnalysisCurrentViewOnly | "Use Only Elements Visible In Current View"
EnergyAnalysisGlazingIsShaded | "Glazing is Shaded"
EnergyAnalysisHorizontalVoidThreshold | "Horizontal Void/Chase Area Threshold"
EnergyAnalysisHvacSystem | "HVAC System"
EnergyAnalysisMasszoneCoreoffset | "Perimeter Zone Depth"
EnergyAnalysisMasszoneDivideperimeter | "Perimeter Zone Division"
EnergyAnalysisMasszoneUseenergydatasettings | "Use Energy Data"
EnergyAnalysisMassZoning | "Mass Zoning"
EnergyAnalysisOutdoorAirInformationParam | "Outdoor Air Information"
EnergyAnalysisPercentageGlazing | "Target Percentage Glazing"
EnergyAnalysisPercentageSkylights | "Target Percentage Skylights"
EnergyAnalysisProjectPhase | "Phase"
EnergyAnalysisShadeDepth | "Shade Depth"
EnergyAnalysisSillHeight | "Target Sill Height"
EnergyAnalysisSkylightWidth | "Skylight Width & Depth"
EnergyAnalysisSpaceBoundingParam | "Analytical Space Bounding"
EnergyAnalysisVerticalVoidThreshold | "Average Vertical Void Height Threshold"
EqualityFormula | "Equality Formula"
EqualityTextForAngularDim | "Equality Text"
EqualityTextForContinuousLinearDim | "Equality Text"
EqualityWitnessDisplay | "Equality Witness Display"
ExcavationElementFamilyAndType | "Element Family and Type"
ExcavationElementId | "Element Id"
ExcavationVolume | "Excavation Volume"
ExcavationVolumeOnToposolid | "Excavation Volume on Toposolid"
ExchangeEntityId | "Exchange Entity ID"
ExchangeId | "Exchange ID"
ExtrusionAutoParams | "Auto ends"
ExtrusionDepthParam | "Depth"
ExtrusionEndParam | "Extrusion End"
ExtrusionLength | "Depth"
ExtrusionStartParam | "Extrusion Start"
FabricationBottomElevationIncludeInsulationOfPart | "Bottom Elevation with Insulation"
FabricationBottomElevationOfPart | "Bottom Elevation"
FabricationBottomOfPart | "Lower End Bottom of Insulation Elevation"
FabricationBranchSize | "Size of Primary Branch End"
FabricationChangeServiceParam | "Change Service"
FabricationDoublewallMaterialAbbreviation | "Double Wall Material Abbreviation"
FabricationDuctworkStiffenerSpec | "Stiffener Specification"
FabricationEndOffsetParam | "End Middle Elevation"
FabricationEndSize | "Size of Connector End"
FabricationFittingDescription | "Fabrication Fitting Description"
FabricationInsulationAbbreviation | "Insulation Abbreviation"
FabricationInsulationMaterialFinish | "Insulation Material"
FabricationInsulationSpec | "Insulation Specification"
FabricationInsulationSpecificationAbbreviation | "Insulation Specification Abbreviation"
FabricationLevelParam | "Reference Level"
FabricationMaterialAbbreviation | "Material Abbreviation"
FabricationMaterialGauge | "Material Gauge"
FabricationOffsetParam | "Middle Elevation"
FabricationPartAlias | "Alias"
FabricationPartAngle | "Angle"
FabricationPartAngleOption | "Angle Option"
FabricationPartBoughtOut | "Bought Out"
FabricationPartCutType | "Cut Type"
FabricationPartDepthIn | "Main Primary Depth"
FabricationPartDepthInOption | "Main Primary Depth Option"
FabricationPartDepthOut | "Main Secondary Depth"
FabricationPartDepthOutOption | "Main Secondary Depth Option"
FabricationPartDiameterIn | "Main Primary Diameter"
FabricationPartDiameterInOption | "Main Primary Diameter Option"
FabricationPartDiameterOut | "Main Secondary Diameter"
FabricationPartDiameterOutOption | "Main Secondary Diameter Option"
FabricationPartDoublewallMaterial | "Double Wall Material"
FabricationPartDoublewallMaterialArea | "Double Wall Material Area"
FabricationPartDoublewallMaterialThickness | "Double Wall Material Thickness"
FabricationPartInsulationArea | "Insulation Area"
FabricationPartItemNumber | "Item Number"
FabricationPartLength | "Length"
FabricationPartLengthOption | "Length Option"
FabricationPartLiningArea | "Lining Area"
FabricationPartMaterial | "Part Material"
FabricationPartMaterialThickness | "Part Material Thickness"
FabricationPartNotes | "Fabrication Notes"
FabricationPartPatNo | "Part Pattern Number"
FabricationPartSheetmetalArea | "Part Sheet Metal Area"
FabricationPartTakeoffDialogParam | "More Parameters"
FabricationPartWeight | "Weight"
FabricationPartWidthIn | "Main Primary Width"
FabricationPartWidthInOption | "Main Primary Width Option"
FabricationPartWidthOut | "Main Secondary Width"
FabricationPartWidthOutOption | "Main Secondary Width Option"
FabricationPipeInvertElevation | "Pipe Invert Elevation": This parameter is obsolete. It exists only for compatibility.
FabricationPrimarySize | "Size of Primary End"
FabricationProductCode | "Product Code"
FabricationProductDataFinishDescription | "Product Finish Description"
FabricationProductDataInstallType | "Install Type"
FabricationProductDataItemDescription | "Product Short Description"
FabricationProductDataLongDescription | "Product Long Description"
FabricationProductDataMaterialDescription | "Product Material Description"
FabricationProductDataOem | "OEM"
FabricationProductDataProduct | "Product Name"
FabricationProductDataRange | "Product Range"
FabricationProductDataSizeDescription | "Product Size Description"
FabricationProductDataSpecification | "Product Specification Description"
FabricationProductEntry | "Product Entry"
FabricationRelativeFilename | "Relative File Name"
FabricationRoutingSolutionsUiParam | "x of XX"
FabricationSecondarySize | "Size of Secondary End"
FabricationServiceAbbreviation | "Fabrication Service Abbreviation"
FabricationServiceName | "Fabrication Service Name"
FabricationServiceParam | "Fabrication Service"
FabricationSetUpDownTag | "SU/SD from Top"
FabricationSetUpDownTagFromBottom | "SU/SD from Bottom"
FabricationSlopeParam | "Slope"
FabricationSpecification | "Specification"
FabricationSpecificationAbbreviation | "Specification Abbreviation"
FabricationStartOffsetParam | "Start Middle Elevation"
FabricationTopElevationIncludeInsulationOfPart | "Top Elevation with Insulation"
FabricationTopElevationOfPart | "Top Elevation"
FabricationTopOfPart | "Upper End Top of Insulation Elevation"
FabricationVendor | "Vendor"
FabricationVendorCode | "Vendor Code"
FabricBendDiameter | "Bend Diameter": Standard Bend Diameter of Fabric Wire.
FabricNumber | "Fabric Number"
FabricParamCoverOffset | "Additional Cover Offset": Additional cover offset of the fabric distribution.
FabricParamCutByHost | "Cut by Host Cover": Single Fabric Sheet is cut or not cut by the Host Cover.
FabricParamCutOverallLength | "Cut Overall Length": Provides a real sheet Length after definition
FabricParamCutOverallWidth | "Cut Overall Width": Provides a real sheet Width after definition
FabricParamCutSheetMass | "Cut Sheet Mass": Calculated cut sheet mass [Sheet Mass per Unit Area * (Cut Overall Length * Cut Overall Width)]
FabricParamLapsplicePosition | "Lap Splice Position": Fabric lap splice position in the fabric distribution
FabricParamLocationGeneric | "Location": Fabric location in the host.
FabricParamLocationSlab | "Location": Fabric location in the slab
FabricParamLocationWall | "Location": Fabric location in the wall
FabricParamMajorLapspliceLength | "Major Lap Splice Length": Fabric lap splice length in major direction in the fabric distribution.
FabricParamMinorLapspliceLength | "Minor Lap Splice Length": Fabric lap splice length in minor direction in the fabric distribution.
FabricParamRounding | "Rounding Overrides"
FabricParamSharedFamilyKey | "Shared family key"
FabricParamSheetType | "Fabric Sheet": List all Fabric Sheet types
FabricParamSpanSymBottom | "Bottom"
FabricParamSpanSymDBottom | "D_Bottom"
FabricParamSpanSymDLeft | "D_Left"
FabricParamSpanSymDRight | "D_Right"
FabricParamSpanSymDTop | "D_Top"
FabricParamSpanSymLeft | "Left"
FabricParamSpanSymRight | "Right"
FabricParamSpanSymTop | "Top"
FabricParamSpanTagComponentReference | "Tag Component Reference"
FabricParamTagView | "Tag new members in view": List of all Plan Views and None.
FabricParamTotalSheetMass | "Total Sheet Mass": Calculated all sheet mass: Volume of Wire * Unit Weight.
FabricSheetDefaultMajorLapspliceLength | "Default Major Lap Splice Length": Default Major Lap Splice Length
FabricSheetDefaultMinorLapspliceLength | "Default Minor Lap Splice Length": Default Minor Lap Splice Length
FabricSheetLength | "Length": Length
FabricSheetMajorDirectionWireType | "Major Direction Wire Type": Major Direction Wire Type
FabricSheetMajorEndOverhang | "Major End Overhang": Major End Overhang
FabricSheetMajorLayoutPattern | "Major Layout Pattern": Major Layout Pattern
FabricSheetMajorNumberOfWires | "Major Number of Wires": Major Number of Wires
FabricSheetMajorReinforcementArea | "Major Reinforcement Area": Major Reinforcement Area
FabricSheetMajorSpacing | "Major Spacing": Major Spacing
FabricSheetMajorStartOverhang | "Major Start Overhang": Major Start Overhang
FabricSheetMass | "Sheet Mass": Sheet Mass
FabricSheetMassunit | "Sheet Mass per Unit Area": Structural Sheet Mass per Unit Area [Sheet Mass / (Overall Length * Overall Width)]
FabricSheetMinorDirectionWireType | "Minor Direction Wire Type": Minor Direction Wire Type
FabricSheetMinorEndOverhang | "Minor End Overhang": Minor End Overhang
FabricSheetMinorLayoutPattern | "Minor Layout Pattern": Minor Layout Pattern
FabricSheetMinorNumberOfWires | "Minor Number of Wires": Minor Number of Wires
FabricSheetMinorReinforcementArea | "Minor Reinforcement Area": Minor Reinforcement Area
FabricSheetMinorSpacing | "Minor Spacing": Minor Spacing
FabricSheetMinorStartOverhang | "Minor Start Overhang": Minor Start Overhang
FabricSheetOverallLength | "Overall Length": Overall Length
FabricSheetOverallWidth | "Overall Width": Overall Width
FabricSheetPhysicalMaterialAsset | "Physical Material Asset": Physical Material Asset
FabricSheetWidth | "Width": Width
FabricWireDiameter | "Nominal Diameter": Nominal Diameter of Fabric Wire.
FabricWireDistance | "Wire distance": The distance between wires
FabricWireLength | "Wire length": The wire length
FabricWireOffset | "Offset along wire direction": Offset along wire direction
FabricWireType | "Wire type": The wire type assigned
FaceroofLevelParam | "Reference Level"
FaceroofOffsetParam | "Level Offset"
FamilyAllowCutWithVoids | "Cut with Voids When Loaded"
FamilyAlwaysVertical | "Always vertical"
FamilyAutojoin | "Automatically joins geometry to walls"
FamilyBaseLevelOffsetParam | "Base Offset"
FamilyBaseLevelParam | "Base Level"
FamilyCanHostRebar | "Can host rebar"
FamilyCategoryPseudoParam | "Category"
FamilyContentPartType | "Part Type"
FamilyCurveAttachmentProportion | "Attachment Point"
FamilyCurveGstyleFor2010Mass | "Subcategory"
FamilyCurveGstylePlusInvisible | "Subcategory"
FamilyCurveGstylePlusInvisibleMinusAnalytical | "Subcategory"
FamilyCurveGstylePlusInvisiblePlusStickSym | "Subcategory"
FamilyCurveGstylePlusInvisiblePlusStickSymMinusAnalytical | "Subcategory"
FamilyElectricalMaintainAnnotationOrientation | "Maintain Annotation Orientation"
FamilyElemSubcategory | "Subcategory"
FamilyEnableCuttingInViews | "Enable Cutting in Views"
FamilyExportAsGeometry | "Always export as geometry"
FamilyFreeinstDefaultElevation | "Default Elevation"
FamilyHeightParam | "Height"
FamilyHostingBehavior | "Host"
FamilyIsElevationMarkBody | "Elevation Mark Use"
FamilyIsParametric | "Is parametric"
FamilyKeepTextReadable | "Keep text readable"
FamilyKeyExtParam | "Filter Parameter"
FamilyKeywordProtected | "Content protection enabled"
FamilyLevelParam | "Level"
FamilyLineLengthParam | "Length"
FamilyNamePseudoParam | "Family"
FamilyNestingBehavior | "Family Nesting Behavior"
FamilyRenderingType | "Render Appearance Source"
FamilyRfaPathPseudoParam | "File Path"
FamilyRotateTextWithComponent | "Rotate text with component"
FamilyRotateWithComponent | "Rotate with component"
FamilyRoughHeightParam | "Rough Height"
FamilyRoughWidthParam | "Rough Width"
FamilyRoundconnectorDimensiontype | "Round Connector Dimension"
FamilySelfOrienting | "Align to View"
FamilyShared | "Shared"
FamilyStructFootingUseCapTop | "Cap"
FamilyStructMaterialType | "Material for Model Behavior"
FamilySymbolicRep | "Symbolic Representation"
FamilyThicknessParam | "Thickness"
FamilyTopLevelOffsetParam | "Top Offset"
FamilyTopLevelParam | "Top Level"
FamilyUsagePseudoParam | "Usage"
FamilyUsePrecutShape | "Show family pre-cut in plan views"
FamilyUsingMultiple | "Multiple Join"
FamilyWidthParam | "Width"
FamilyWindowInsetParam | "Inset"
FamilyWorkPlaneBased | "Work Plane-Based"
FamilyWpbDefaultElevation | "Default Elevation"
FamProfileDefinition | "Profile Definition"
FamProfileUsage | "Profile Usage"
FasciaDepthParam | "Fascia Depth"
FasciaMaterialParam | "Material"
FasciaProfileParam | "Profile"
FbxAssetType | "Light Source"
FbxLightAtADistance | "At a distance"
FbxLightBallastLoss | "Ballast Loss"
FbxLightColorFilter | "Color Filter"
FbxLightDimmingLightColor | "Dimming Lamp Color Temperature Shift"
FbxLightEfficacy | "Efficacy"
FbxLightEmitCircleDiameter | "Emit from Circle Diameter"
FbxLightEmitLineLength | "Emit from Line Length"
FbxLightEmitRectangleLength | "Emit from Rectangle Length"
FbxLightEmitRectangleWidth | "Emit from Rectangle Width"
FbxLightEmitShapeVisible | "Emit Shape Visible in Rendering"
FbxLightIlluminance | "Illuminance"
FbxLightInitialColorCtrl | "Initial Color"
FbxLightInitialColorName | "Temperature Color"
FbxLightInitialColorTemperature | "Initial Color Temperature"
FbxLightInitialIntensity | "Initial Intensity"
FbxLightInitialIntensityInputMethod | "Initial Light Intensity Input Method"
FbxLightLampLumenDepr | "Lamp Lumen Depreciation"
FbxLightLampTiltLoss | "Lamp Tilt Loss"
FbxLightLimunousFlux | "Luminous Flux"
FbxLightLimunousIntensity | "Luminous Intensity"
FbxLightLossFactorCtrl | "Light Loss Factor"
FbxLightLossFactorMethod | "Light Loss Input Method"
FbxLightLumenaireDirt | "Luminaire Dirt Depreciation"
FbxLightPhotometricFile | "Photometric Web File"
FbxLightPhotometricFileCache | "None"
FbxLightPhotometrics | "Light Source Definition"
FbxLightPhotometricsFam | "Light Source Definition (family)"
FbxLightSourceDiameter | "Light Source Symbol Size"
FbxLightSourceLength | "Light Source Symbol Length"
FbxLightSpotBeamAngle | "Spot Beam Angle"
FbxLightSpotFieldAngle | "Spot Field Angle"
FbxLightSpotTiltAngle | "Tilt Angle"
FbxLightSurfaceLoss | "Surface Depreciation Loss"
FbxLightTemperatureLoss | "Temperature Loss"
FbxLightTotalLightLoss | "Total Light Loss Factor"
FbxLightVoltageLoss | "Voltage Loss"
FbxLightWattage | "Wattage"
FilledRegionMasking | "Masking"
FillPatternIdParam | "Cut fill pattern"
FillPatternIdParamNoNo | "Fill Pattern"
FireRating | "Fire Rating"
FixedRotation | "Fixed Rotation"
FlexibleInstanceFlip | "Flip"
FloorAttrDefaultHeightParam | "Default Height above level"
FloorAttrDefaultThicknessParam | "Default Thickness"
FloorAttrThicknessParam | "Thickness"
FloorHeightabovelevelParam | "Height Offset From Level"
FloorParamIsStructural | "Structural"
FloorParamSpanDirection | "Span Direction"
FloorStructureIdParam | "Structure"
FollowSurface | "Follow Surface"
ForegroundAnyPatternIdParam | "Foreground Fill Pattern"
ForegroundDraftPatternIdParam | "Foreground Fill Pattern"
ForegroundPatternColorParam | "Foreground Pattern Color"
FramingLengthRoundoff | "Structural Framing Length Roundoff"
FramingShapeClassification | "Framing Shape"
FrictionFactor | "Friction Factor"
FunctionParam | "Function"
GbxmlEditDataParam | "Energy Settings"
GenericDepth | "Depth"
GenericZoneName | "Name"
GeoLocation | "Shared Site"
GeomVisibilityParam | "Visibility/Graphics Overrides"
GraphicDisplayOptions | "Graphic Display Options"
GraphicDisplayOptionsBackground | "Background"
GraphicDisplayOptionsFog | "Depth Cueing"
GraphicDisplayOptionsLighting | "Lighting"
GraphicDisplayOptionsModel | "Model Display"
GraphicDisplayOptionsPhotoExposure | "Photographic Exposure"
GraphicDisplayOptionsShadows | "Shadows"
GraphicDisplayOptionsSketchyLines | "Sketchy Lines"
GraphicDisplayOptionsSsIntensity | "Sun and Shadow Intensity"
GridBankColNum | "Column"
GridBankColWidth | "Column Distance"
GridBankRowHeight | "Row Distance"
GridBankRowNum | "Row"
GridBubbleEndn1 | "Plan View Symbols End 1 (Default)"
GridBubbleEndn2 | "Plan View Symbols End 2 (Default)"
GridBubbleLinePen | "Bubble Weight Number\n"
GridCenterSegmentColor | "Center Segment Color"
GridCenterSegmentPattern | "Center Segment Pattern"
GridCenterSegmentStyle | "Center Segment"
GridCenterSegmentWeight | "Center Segment Weight"
GridEndSegmentColor | "End Segment Color"
GridEndSegmentPattern | "End Segment Pattern"
GridEndSegmentsLength | "End Segments Length"
GridEndSegmentWeight | "End Segment Weight"
GridHeadTag | "Symbol"
GridlineSpecStatus | "Type Association"
GridNetLocationMark | "Location Mark": Provides grid system association information
GroupAllowedViewTypes | "Allowed View Types"
GroupAttachedParentName | "Attached to"
GroupLevel | "Reference Level"
GroupnameParam | "Group Name for Ribbon Combo Items (for Use with XAML)"
GroupOffsetFromLevel | "Origin Level Offset"
GuideGridNameParam | "Name"
GuideGridSpacingParam | "Guide Spacing"
GutterMaterialParam | "Material"
GutterProfileParam | "Profile"
HandrailHandClearanceParam | "Hand Clearance"
HandrailHeightParam | "Height"
HandrailProjectionParam | "Projection"
HandrailSupportsJustificationParam | "Justification"
HandrailSupportsLayoutParam | "Layout"
HandrailSupportsNumberParam | "Number"
HandrailSupportsSpacingParam | "Spacing"
HandrailSupportsTypeParam | "Family"
HeadOnPlacementMethod | "Draw in Foreground"
HeavyEndPen | "Heavy End Pen Weight"
HeavyTickMarkPen | "Heavy End Pen Weight"
HighestAssociatedLevel | "Highest Associated Level": The highest level associated with this Analytical Element.
HostAreaComputed | "Area"
HostIdParam | "Host Id"
HostPanelScheduleAsPanelParam | "Categorize as"
HostPerimeterComputed | "Perimeter"
HostSseCurvedEdgeConditionParam | "Curved Edge Condition"
HostVolumeComputed | "Volume"
IconIndexParam | "Index Into Image File Name Array (for Use with XAML)"
IdParam | "Id"
IfcApplicationName | "IfcApplicationName"
IfcApplicationVersion | "IfcApplicationVersion"
IfcBuildingGuid | "IfcBuilding GUID"
IfcExportElement | "Export to IFC"
IfcExportElementAs | "Export to IFC As"
IfcExportElementType | "Export Type to IFC"
IfcExportElementTypeAs | "Export Type to IFC As"
IfcExportPredefinedtype | "IFC Predefined Type"
IfcExportPredefinedtypeType | "Type IFC Predefined Type"
IfcGuid | "IfcGUID"
IfcImportMaterialName | "IFC Material Name"
IfcOrganization | "IfcOrganization"
IfcProjectGuid | "IfcProject GUID"
IfcSiteGuid | "IfcSite GUID"
IfcTypeGuid | "Type IfcGUID"
ImportAdtComponentsDesc | "Component Description"
ImportAdtEntityHeight | "Height"
ImportAdtEntityLength | "Length"
ImportAdtEntityRoll | "Roll"
ImportAdtEntityStructType | "Structural Type Name"
ImportAdtEntityStyle | "Style Name"
ImportAdtEntityThickness | "Thickness"
ImportAdtEntityType | "Type Name"
ImportAdtEntityWidth | "Width"
ImportBackground | "Draw Layer"
ImportBaseLevel | "Work Plane"
ImportBaseLevelOffset | "Offset from Work Plane"
ImportDisplayUnits | "Import Units"
ImportInstanceCuttingInView | "Enable Cutting in Views"
ImportInstanceScale | "Instance Scale"
ImportScale | "Scale Factor"
ImportSymbolName | "Name"
IndividualExcavationVolume | "Individual Excavation Volume"
InfrastructureAlignmentDescription | "Description"
InfrastructureAlignmentDisplayedEndStation | "Displayed End Station"
InfrastructureAlignmentDisplayedStartStation | "Displayed Start Station"
InfrastructureAlignmentName | "Name"
InsertOrientation | "Orientation"
InstanceElevationParam | "Elevation from Level"
InstanceFreeHostOffsetParam | "Offset from Host"
InstanceFreeHostParam | "Host"
InstanceHeadHeightParam | "Head Height"
InstanceLengthParam | "Length"
InstanceMoveBaseWithGrids | "Move Base With Grids"
InstanceMovesWithGridParam | "Moves With Grids"
InstanceMoveTopWithGrids | "Move Top With Grids"
InstanceOffsetPosParam | "Moves With Nearby Elements"
InstanceReferenceLevelParam | "Reference Level"
InstanceScheduleOnlyLevelParam | "Schedule Level"
InstanceSillHeightParam | "Sill Height"
InstanceStructUsageParam | "Structural Usage"
InsulationScale | "Insulation Bulge to Width Ratio (1/x)"
InsulationWidth | "Insulation Width"
InteriorTickDisplay | "Interior Tick Mark Display"
IsVisibleParam | "Visible"
JoinStrengthOrder | "Abstract Join Strength Order"
JoistSystemClearSpacingParam | "Clear Spacing"
JoistSystemElemTagNewMembersView | "Tag new members in view"
JoistSystemFixedSpacingParam | "Fixed Spacing"
JoistSystemJustificationParam | "Justification"
JoistSystemLayoutRuleParam | "Layout Rule"
JoistSystemMaximumSpacingParam | "Maximum Spacing"
JoistSystemNewBeamTypeNoFamNameParam | "Beam Type (No Family Name)"
JoistSystemNewBeamTypeParam | "Beam Type"
JoistSystemNumBeamsSameType | "Num. of Beams With Same Type"
JoistSystemNumberOfLinesParam | "Number of Lines"
JoistSystemSpacingParam | "Centerline Spacing"
KeepReadable | "Keep Readable"
KeynoteNumber | "Key Value"
KeynoteParam | "Keynote"
KeynoteText | "Keynote Text"
KeySourceParam | "Key Source"
KeyValue | "Key Value"
LayerElemAreaComputed | "Area"
LayerElemBaseConstraint | "Base Constraint"
LayerElemBaseExtensionDis | "Base Extension Distance"
LayerElemCompoundElemFamily | "Compound Element Family"
LayerElemCompoundElemType | "Compound Element Type"
LayerElemFunction | "Function": Function
LayerElemIsCoreLayer | "Is Core Layer"
LayerElemIsStructuralMaterial | "Is Structural Material"
LayerElemIsVariable | "Is Variable"
LayerElemMaterials | "Material": Material
LayerElemOffsetFromHost | "Offset From Host"
LayerElemScheduleFamily | "Family"
LayerElemThickness | "Thickness": Thickness
LayerElemTopConstraint | "Top Constraint"
LayerElemTopExtensionDis | "Top Extension Distance"
LayerElemVolumeComputed | "Volume"
LayerTypeMaterials | "Material": Material
LayerTypeThickness | "Thickness": Thickness
LayoutnodeCurvetypeParam | "Curve Type Reference"
LeaderArrowhead | "Leader Arrowhead"
LeaderArrowWidth | "Arrow Width Angle"
LeaderLeftAttachment | "Left Attachment"
LeaderLength | "Leader Length"
LeaderLine | "Leader Line"
LeaderOffsetSheet | "Leader/Border Offset"
LeaderRightAttachment | "Right Attachment"
LegendComponent | "Component Type"
LegendComponentDetailLevel | "Detail Level"
LegendComponentLength | "Host Length"
LegendComponentView | "View Direction"
LevelAttrRoomComputationAutomatic | "Automatic Room Computation Height"
LevelAttrRoomComputationHeight | "Computation Height"
LevelDataFloorArea | "Floor Area"
LevelDataFloorPerimeter | "Floor Perimeter"
LevelDataMassFamilyAndTypeParam | "Mass: Family and Type"
LevelDataMassFamilyParam | "Mass: Family"
LevelDataMassInstanceComments | "Mass: Comments"
LevelDataMassTypeComments | "Mass: Type Comments"
LevelDataMassTypeDescription | "Mass: Description"
LevelDataMassTypeParam | "Mass: Type"
LevelDataOwningLevel | "Level"
LevelDataSpaceUsage | "Usage"
LevelDataSurfaceArea | "Exterior Surface Area"
LevelDataVolume | "Floor Volume"
LevelElev | "Elevation"
LevelHeadTag | "Symbol"
LevelIsBuildingStory | "Building Story"
LevelIsGroundPlane | "Is ground plane"
LevelIsStructural | "Structural"
LevelName | "Level"
LevelParam | "Level"
LevelRelativeBaseType | "Elevation Base"
LevelRoomComputationHeight | "Computation Height"
LevelUpToLevel | "Story Above"
LightingFixtureLamp | "Lamp"
LightingFixtureLightEmitter | "Light Emitter"
LightingFixtureWattage | "Wattage Comments"
LinearDimType | "Dimension String Type"
LinearFramingLength | "Length"
LineColor | "Color"
LinePattern | "Line Pattern"
LinePen | "Line Weight"
LineShapeAtCorner | "Line Shape at Landing Corner"
LoadAllNon0Loads | "All non 0 loads"
LoadAreaArea | "Area"
LoadAreaForceFx1 | "Fx 1"
LoadAreaForceFx2 | "Fx 2"
LoadAreaForceFx3 | "Fx 3"
LoadAreaForceFy1 | "Fy 1"
LoadAreaForceFy2 | "Fy 2"
LoadAreaForceFy3 | "Fy 3"
LoadAreaForceFz1 | "Fz 1"
LoadAreaForceFz2 | "Fz 2"
LoadAreaForceFz3 | "Fz 3"
LoadAreaIsProjected | "Projected Load"
LoadArrowSeparation | "Distance between arrows"
LoadAttrAreaForceScaleFactor | "Area force scale"
LoadAttrForceArrowType | "Force arrowhead"
LoadAttrForceScaleFactor | "Force scale"
LoadAttrLinearForceScaleFactor | "Linear force scale"
LoadAttrMomentArrowArc | "Moment arrowhead"
LoadAttrMomentArrowLine | "Moment arrowhead (alternate)"
LoadAttrMomentScaleFactor | "Moment scale"
LoadCaseId | "Load Case"
LoadCaseName | "Name"
LoadCaseNature | "Nature"
LoadCaseNatureText | "Nature"
LoadCaseNumber | "Case Number"
LoadCaseSubcategory | "Category"
LoadCombinationFactor | "Factor"
LoadCombinationName | "Name"
LoadComments | "Comments"
LoadDescription | "Description"
LoadForceFx | "Fx"
LoadForceFy | "Fy"
LoadForceFz | "Fz"
LoadIsConstrainedOnHost | "Is constrained on host"
LoadIsHosted | "Is Hosted"
LoadIsProjected | "Projected Load"
LoadIsReaction | "Is Reaction"
LoadIsUniform | "Uniform Load"
LoadLinearForceFx1 | "Fx 1"
LoadLinearForceFx2 | "Fx 2"
LoadLinearForceFy1 | "Fy 1"
LoadLinearForceFy2 | "Fy 2"
LoadLinearForceFz1 | "Fz 1"
LoadLinearForceFz2 | "Fz 2"
LoadLinearLength | "Length"
LoadMomentMx | "Mx"
LoadMomentMx1 | "Mx 1"
LoadMomentMx2 | "Mx 2"
LoadMomentMy | "My"
LoadMomentMy1 | "My 1"
LoadMomentMy2 | "My 2"
LoadMomentMz | "Mz"
LoadMomentMz1 | "Mz 1"
LoadMomentMz2 | "Mz 2"
LoadNatureName | "Name"
LoadUsageName | "Name"
LoadUseLocalCoordinateSystem | "Orient to"
LockAlignmentUiToggle | "Lock": This is used by the UI to allow selection of lock alignment.
LockedBaseOffset | "Negative Offset"
LockedEndOffset | "Positive Offset"
LockedStartOffset | "Negative Offset"
LockedTopOffset | "Positive Offset"
LowestAssociatedLevel | "Lowest Associated Level": The lowest level associated with this Analytical Element.
LvMullionLeg1 | "Leg 1"
LvMullionLeg2 | "Leg 2"
MarkupsCreated | "Created"
MarkupsCreator | "Creator"
MarkupsHistory | "History"
MarkupsLabel | "Label"
MarkupsModified | "Modified"
MarkupsNotes | "Notes"
MarkupsPrivate | "Private"
MarkupsStatus | "Status"
MassDataConceptualConstruction | "Conceptual Types"
MassDataGlazingIsShaded | "Glazing is Shaded"
MassDataMassExteriorWallArea | "Mass Exterior Wall Area"
MassDataMassInteriorWallArea | "Mass Interior Wall Area"
MassDataMassOpeningArea | "Mass Opening Area"
MassDataMassRoofArea | "Mass Roof Area"
MassDataMassSkylightArea | "Mass Skylight Area"
MassDataMassWindowArea | "Mass Window Area"
MassDataPercentageGlazing | "Target Percentage Glazing"
MassDataPercentageSkylights | "Target Percentage Skylights"
MassDataShadeDepth | "Shade Depth"
MassDataSillHeight | "Target Sill Height"
MassDataSkylightWidth | "Skylight Width & Depth"
MassDataSlab | "Slab"
MassDataSubcategory | "Subcategory"
MassDataSurfaceDataSource | "Values"
MassDataUnderground | "Underground"
MassFloorAreaLevels | "Mass Floors"
MassGrossArea | "Gross Floor Area"
MassGrossSurfaceArea | "Gross Surface Area"
MassGrossVolume | "Gross Volume"
MassingIntegrationLevel | "Constrain to Massing"
MassSurfacedataMaterial | "Graphical Appearance"
MassZoneConditionTypeParam | "Condition Type"
MassZoneFloorArea | "Mass Floor Area"
MassZoneMaterial | "Graphical Appearance"
MassZoneSpaceTypeParam | "Space Type"
MassZoneVolume | "Mass Zone Volume"
MatchlineBottomOffset | "Bottom Offset"
MatchlineBottomPlane | "Bottom Constraint"
MatchlineTopOffset | "Top Offset"
MatchlineTopPlane | "Top Constraint"
MaterialArea | "Area"
MaterialAspaint | "As Paint"
MaterialAssetParamAssetLibId | "Asset library id"
MaterialAssetParamCommonSharedAsset | "Sharing"
MaterialAssetParamExternalMaterialId | "External Material ID"
MaterialAssetParamSource | "Source"
MaterialAssetParamSourceUrl | "Source URL"
MaterialIdParam | "Material"
MaterialName | "Name"
MaterialParamColor | "Color"
MaterialParamGlow | "Glow"
MaterialParamShininess | "Shininess"
MaterialParamSmoothness | "Smoothness"
MaterialParamTransparency | "Transparency"
MaterialVolume | "Volume"
MeasureFromStructure | "Extend into wall (to core)"
MechanicalEquipmentSetIdParam | "Mechanical Equipment Set"
MechanicalEquipmentSetName | "Name"
MechanicalEquipmentSetOnDuty | "On Duty"
MechanicalEquipmentSetOnStandby | "On Standby"
MepAirloopFantype | "Fan"
MepAirloopHeatexchangerType | "Heat Exchanger"
MepAirloopPreheatCoiltype | "Preheat Coil"
MepAnalyticalCriticalpathParam | "Critical Path"
MepAnalyticalCriticalsequence | "Critical Sequence"
MepAnalyticalElecApparentPowerRating | "Apparent Power Rating"
MepAnalyticalElecCurrent | "Current"
MepAnalyticalElecCurrentRating | "Current Rating"
MepAnalyticalElecVoltage | "Voltage"
MepAnalyticalEquipmentName | "Name"
MepAnalyticalHeadersegment | "Header"
MepAnalyticalHydraulicloop | "Hydraulic Loop"
MepAnalyticalLoopBoundaryParam | "Loop Boundary"
MepAnalyticalLoopName | "Name"
MepAnalyticalNetwork | "Network Id"
MepAnalyticalPipeDesignflow | "Design Flow"
MepChilledWaterLoop | "Chilled Water Loop"
MepCondenserWaterLoop | "Condenser Water Loop"
MepCoolingCoilType | "Cooling Coil"
MepElecZoneEquipmentType | "Equipment Type"
MepEquipmentCalcPipingflowParam | "Calculated Flow"
MepEquipmentCalcPipingpressuredropParam | "Calculated Pressure Drop"
MepEquipmentClassification | "Classification"
MepHeatingCoilType | "Heating Coil"
MepHeatingHotwaterLoop | "Heating Hot Water Loop"
MepIgnoreFlowAnalysis | "Ignore Flow Analysis"
MepLowerBottomElevation | "Lower End Bottom Elevation"
MepLowerBottomElevationIncludeInsulation | "Lower End Bottom of Insulation Elevation"
MepLowerCenterlineElevation | "Lower End Centerline Elevation"
MepLowerTopElevation | "Lower End Top Elevation"
MepLowerTopElevationIncludeInsulation | "Lower End Top of Insulation Elevation"
MepPipeLowerInvertElevation | "Lower End Invert Elevation"
MepPipeLowerObvertElevation | "Lower End Obvert Elevation"
MepPipeUpperInvertElevation | "Upper End Invert Elevation"
MepPipeUpperObvertElevation | "Upper End Obvert Elevation"
MepPreheatHotwaterLoop | "Preheat Hot Water Loop"
MepProfileTypeParam | "Shape"
MepReheatCoilType | "Reheat Coil"
MepReheatHotwaterLoop | "Reheat Hot Water Loop"
MepSegmentElementTypename | "Type Name"
MepSegmentFamilyname | "Family Name"
MepSegmentLength | "Analytical Length"
MepSegmentSystemorservice | "System Type/Service Name"
MepSpotBottomElevation | "Spot Bottom Elevation": used for both design and fabrication components
MepSpotBottomElevationIncludeInsulation | "Spot Bottom of Insulation Elevation"
MepSpotCenterlineElevation | "Spot Centerline Elevation": used for both design and fabrication components
MepSpotTopElevation | "Spot Top Elevation": used for both design and fabrication components
MepSpotTopElevationIncludeInsulation | "Spot Top of Insulation Elevation"
MepSystemFillGraphicsOverridesParam | "Fill Pattern Graphics Overrides"
MepSystemLineGraphicsOverridesParam | "Graphic Overrides"
MepUpperBottomElevation | "Upper End Bottom Elevation"
MepUpperBottomElevationIncludeInsulation | "Upper End Bottom of Insulation Elevation"
MepUpperCenterlineElevation | "Upper End Centerline Elevation"
MepUpperTopElevation | "Upper End Top Elevation"
MepUpperTopElevationIncludeInsulation | "Upper End Top of Insulation Elevation"
MepVrfLoop | "Variable Refrigerant Flow Loop"
MepWaterloopChillertype | "Chiller Type"
MepWaterloopType | "Loop Type"
MepZoneAirLoop | "Air System"
MepZoneEquipment | "Zone Equipment"
MepZoneEquipmentBehavior | "Behavior"
MepZoneEquipmentDrawVentilation | "Draw Ventilation"
MepZoneEquipmentType | "Equipment Type"
MepZoneHotwaterLoop | "Heating Hot Water Loop"
ModelCategoryIdParam | "Subcategory"
ModelGraphicsStyle | "Visual Style"
ModelGraphicsStyleAnonDraft | "Visual Style"
ModelOrSymbolic | "Model or Symbolic"
ModelTextSize | "Text Size"
MovesWithGridParam | "Moves With Grids": Disable attachment from grids.
MullionAngle | "Angle"
MullionCornerType | "Corner Mullion"
MullionDepth | "Depth"
MullionDepth1 | "Depth 1"
MullionDepth2 | "Depth 2"
MullionFamType | "Mullion Family General Shape"
MullionOffset | "Offset"
MullionPosition | "Position"
MullionProfile | "Profile"
MultipleAlignmentUiToggle | "Multiple Alignment": This is used by the UI to allow selection of multiple elements.
MultiReferenceAnnotationDimensionStyle | "Dimension Style"
MultiReferenceAnnotationGroupTagHeads | "Group Matching Tag Heads"
MultiReferenceAnnotationReferenceCategory | "Reference Category"
MultiReferenceAnnotationShowDimensionText | "Show Dimension Text"
MultiReferenceAnnotationTagType | "Tag Family"
MultistoryStairsActualTreadDepth | "Actual Tread Depth"
MultistoryStairsRefLevel | "Reference Level": The reference level of stairs
NodeConnectionStatus | "Connection Status"
NumberPartitionParam | "Partition"
NumberSystemDisplayRule | "Display Rule"
NumberSystemJustify | "Justify"
NumberSystemJustifyOffset | "Justify Offset"
NumberSystemOrientation | "Orientation"
NumberSystemReference | "Reference"
NumberSystemReferenceOffset | "Offset from Reference"
NumberSystemTagType | "Tag Type"
NumberSystemTextSize | "Number Size"
ObjectStyleMaterialIdParam | "Object Style Material"
OffsetfacesShowShapeHandles | "Show Shape Handles"
OffsetFromReferenceBase | "Offset from Reference Base"
OmniclassCode | "OmniClass Number"
OmniclassDescription | "OmniClass Title"
OptionName | "Name"
OptionSetId | "Design Option Set Id"
OptionSetName | "Name"
OrdinateDimSetting | "Ordinate Dimension Settings"
OrientByView | "Rotate With Text"
OriginatingElementName | "Originating Element"
OvalFramingHeight | "Oval Height"
OvalFramingWidth | "Oval Width"
PaddingLength | "Padding"
PanelScheduleName | "Panel Schedule Name"
PartMakerDivisionProfileOffset | "Profile Offset"
PartmakerParamDivisionGap | "Gap"
PartMakerSplitterProfile | "Division Profile"
PartMakerSplitterProfileEdgeMatch | "Edge Match"
PartMakerSplitterProfileFlipAcross | "Profile Across Flip"
PartMakerSplitterProfileFlipAlong | "Profile Along Flip"
PathOfTravelFromRoom | "From Room"
PathOfTravelLevelName | "Level"
PathOfTravelSpeed | "Speed"
PathOfTravelTime | "Time"
PathOfTravelToRoom | "To Room"
PathOfTravelViewName | "View Name"
PathReinAddlOffset | "Additional Offset"
PathReinAlternating | "Alternating Bars"
PathReinAltOffset | "Alternating Bar - Offset"
PathReinEndHookOrient1Slab | "Primary Bar - End Hook Orientation"
PathReinEndHookOrient1Wall | "Primary Bar - End Hook Orientation"
PathReinEndHookOrient2Slab | "Alternating Bar - End Hook Orientation"
PathReinEndHookOrient2Wall | "Alternating Bar - End Hook Orientation"
PathReinEndHookTypen1 | "Primary Bar - End Hook Type"
PathReinEndHookTypen2 | "Alternating Bar - End Hook Type"
PathReinEndSpanhookAlt | "End Hook Angle Alternating"
PathReinEndSpanhookPrim | "End Hook Angle Primary"
PathReinFaceSlab | "Face"
PathReinFaceWall | "Face"
PathReinHookOrient1Slab | "Primary Bar - Hook Orientation"
PathReinHookOrient1Wall | "Primary Bar - Hook Orientation"
PathReinHookOrient2Slab | "Alternating Bar - Hook Orientation"
PathReinHookOrient2Wall | "Alternating Bar - Hook Orientation"
PathReinHookTypen1 | "Primary Bar - Start Hook Type"
PathReinHookTypen2 | "Alternating Bar - Start Hook Type"
PathReinLengthn1 | "Primary Bar - Length"
PathReinLengthn2 | "Alternating Bar - Length"
PathReinNumberOfBars | "Number Of Bars"
PathReinShapen1 | "Primary Bar - Shape"
PathReinShapen2 | "Alternating Bar - Shape"
PathReinSpacing | "Bar Spacing"
PathReinSpanhookAlt | "Start Hook Angle Alternating"
PathReinSpanhookPrim | "Start Hook Angle Primary"
PathReinSpanlengthAltOffset | "Offset"
PathReinSpanlengthBarlengthAlt | "Length (Alternating Bar)"
PathReinSpanlengthBarlengthPrim | "Length (Primary Bar)"
PathReinSpanlengthBottomAlt | "Bottom (Alternating Bar)"
PathReinSpanlengthBottomPrim | "Bottom (Primary Bar)"
PathReinSpanlengthTopAlt | "Top (Alternating Bar)"
PathReinSummary | "Summary"
PathReinTypen1 | "Primary Bar - Type"
PathReinTypen2 | "Alternating Bar - Type"
PatternIndent1ForDivisionRule | "Indent 1"
PatternIndent2ForDivisionRule | "Indent 2"
PatternMirrorForDivisionRule | "Mirror"
PeakAirflowParam | "Peak Airflow"
PeakCoolingLoadParam | "Peak Cooling Load"
PeakHeatingLoadParam | "Peak Heating Load"
PeakLatentCoolingLoad | "Peak Latent Cooling Load"
PhaseCreated | "Phase Created"
PhaseDemolished | "Phase Demolished"
PhaseName | "Name"
PhaseSequenceNumber | "Sequence Number"
PhyMaterialParamAverageModulus | "Average Modulus"
PhyMaterialParamBehavior | "Behavior"
PhyMaterialParamBending | "Bending"
PhyMaterialParamBendingReinforcement | "Bending reinforcement"
PhyMaterialParamClass | "Class"
PhyMaterialParamCompressionParallel | "Compression parallel to grain"
PhyMaterialParamCompressionPerpendicular | "Compression perpendicular to grain"
PhyMaterialParamConcreteCompression | "Concrete compression"
PhyMaterialParamExpCoeff | "Thermal expansion coefficient"
PhyMaterialParamExpCoeff1 | "Thermal expansion coefficient X"
PhyMaterialParamExpCoeff2 | "Thermal expansion coefficient Y"
PhyMaterialParamExpCoeff3 | "Thermal expansion coefficient Z"
PhyMaterialParamExpCoeffn1 | "Thermal Expansion Coefficient 1"
PhyMaterialParamExpCoeffn2 | "Thermal Expansion Coefficient 2"
PhyMaterialParamFivepercentModulusOfElacticity | "5% Modulus of Elasticity"
PhyMaterialParamGrade | "Grade"
PhyMaterialParamLightWeight | "Lightweight"
PhyMaterialParamMinimumTensileStrength | "Minimum tensile strength"
PhyMaterialParamMinimumYieldStress | "Minimum yield stress"
PhyMaterialParamPoissonMod | "Poisson ratio"
PhyMaterialParamPoissonMod1 | "Poisson ratio X"
PhyMaterialParamPoissonMod12 | "Poisson Ratio 12"
PhyMaterialParamPoissonMod2 | "Poisson ratio Y"
PhyMaterialParamPoissonMod23 | "Poisson Ratio 23"
PhyMaterialParamPoissonMod3 | "Poisson ratio Z"
PhyMaterialParamReductionFactor | "Reduction factor for shear"
PhyMaterialParamResistanceCalcStrength | "Resistance calculation strength"
PhyMaterialParamShearMod | "Shear modulus"
PhyMaterialParamShearMod1 | "Shear modulus X"
PhyMaterialParamShearMod12 | "Shear Modulus 12"
PhyMaterialParamShearMod2 | "Shear modulus Y"
PhyMaterialParamShearMod3 | "Shear modulus Z"
PhyMaterialParamShearParallel | "Shear parallel to grain"
PhyMaterialParamShearPerpendicular | "Shear perpendicular to grain"
PhyMaterialParamShearReinforcement | "Shear reinforcement yield stress"
PhyMaterialParamShearStrengthReduction | "Shear strength modification"
PhyMaterialParamSpecies | "Species"
PhyMaterialParamStructuralDensity | "Density"
PhyMaterialParamStructuralSpecificHeat | "Specific Heat"
PhyMaterialParamStructuralThermalTreated | "Thermally Treated"
PhyMaterialParamSubclass | "Subclass"
PhyMaterialParamTensionParallel | "Tension Parallel to Grain"
PhyMaterialParamTensionPerpendicular | "Tension Perpendicular to Grain"
PhyMaterialParamThermalConductivity | "Thermal Conductivity"
PhyMaterialParamThermalConductivityX | "Thermal Conductivity X"
PhyMaterialParamThermalConductivityY | "Thermal Conductivity Y"
PhyMaterialParamThermalConductivityZ | "Thermal Conductivity Z"
PhyMaterialParamType | "Material Type"
PhyMaterialParamUnitWeight | "Unit weight"
PhyMaterialParamWoodConstruction | "Construction"
PhyMaterialParamYoungMod | "Young modulus"
PhyMaterialParamYoungMod1 | "Young modulus X"
PhyMaterialParamYoungMod2 | "Young modulus Y"
PhyMaterialParamYoungMod3 | "Young modulus Z"
PhyMaterialParamYoungModn1 | "Young's Modulus 1"
PhyMaterialParamYoungModn2 | "Young's Modulus 2"
PhyMaterialProperties | "Properties"
PipeInsulationThickness | "Insulation Thickness"
PipeRoughness | "Roughness"
PipeVelocityPressure | "Velocity Pressure"
PipingConnectionType | "Connection Type"
PipingGenderType | "Gender Type"
PlacementBottom | "Bottom"
PlacementCenterX | "Center X"
PlacementCenterY | "Center Y"
PlacementLeft | "Left"
PlacementParamsShow | "Enable Position Parameters"
PlacementRight | "Right"
PlacementTop | "Top"
PlanRegionViewRange | "View Range"
PlanViewCutPlaneHeight | "Cut Plane Height"
PlanViewLevel | "Associated Level"
PlanViewNorth | "Orientation"
PlanViewRange | "View Range"
PlanViewTopClipHeight | "Top Clip Height"
PlanViewViewDir | "View Direction"
PlumbingFixturesCwConnection | "CW Connection"
PlumbingFixturesDrain | "Drain"
PlumbingFixturesHwConnection | "HW Connection"
PlumbingFixturesSupplyFitting | "Supply Fitting"
PlumbingFixturesSupplyPipe | "Supply Pipe"
PlumbingFixturesTrap | "Trap"
PlumbingFixturesVentConnection | "Vent Connection"
PlumbingFixturesWasteConnection | "Waste Connection"
PocheMatId | "Coarse Poche Material"
PointAdaptiveConstrained | "Constrained"
PointAdaptiveNumParam | "Number"
PointAdaptiveOrientationType | "Orients to"
PointAdaptiveShowNumber | "Show Placement Number"
PointAdaptiveTypeParam | "Point"
PointcloudinstanceName | "Name": The name of the instance as it will show in the Property Palette
PointcloudtypeScale | "Scale": The scale for this instance
PointElementAngle | "Angle"
PointElementChordLength | "Chord Length"
PointElementDriven | "Driven by Host"
PointElementDriving | "Driving Curve(s)"
PointElementHostedOnFaceUParam | "Hosted U Parameter"
PointElementHostedOnFaceVParam | "Hosted V Parameter"
PointElementHostedParam | "Hosted Parameter"
PointElementMeasureFrom | "Measure From"
PointElementMeasurementType | "Measurement Type"
PointElementMirrored | "Mirrored"
PointElementNonNormalizedCurveParamater | "Non-Normalized Curve Parameter"
PointElementNormalizedCurveParamater | "Normalized Curve Parameter"
PointElementNormalizedSegmentLength | "Normalized Segment Length"
PointElementOffset | "Offset"
PointElementRotationAngle | "Rotation Angle"
PointElementSegmentLength | "Segment Length"
PointElementShowNormalPlaneOnly | "Show Normal Reference Plane Only"
PointElementShowPlanes | "Show Reference Planes"
PointElementZflipped | "Flipped"
PointElevation | "Elevation"
PointFlexibleConstrained | "Constrained"
PointFlexibleNumParam | "Number"
PointFlexibleOrientationType | "Orientation"
PointFlexibleShowNumber | "Show Placement Number"
PointNameParam | "Name"
PointVisibilityParam | "Visibility/Graphics Overrides"
PreferDimSideUiFilter | "Prefer:": This is used by the UI to allow select prefer dimension side.
PreferPatternAlignUiFilter | "Pattern:": This is used by the UI to allow to select the preferred preference of aligning pattern.
PrimaryOptionId | "Primary Option Id"
Profile1Angle | "Angle"
Profile1FamType | "Profile"
Profile1FlippedHor | "Profile Is Flipped"
Profile1OffsetX | "Horizontal Profile Offset"
Profile1OffsetY | "Vertical Profile Offset"
Profile2Angle | "Angle"
Profile2FamType | "Profile"
Profile2FlippedHor | "Profile Is Flipped"
Profile2OffsetX | "Horizontal Profile Offset"
Profile2OffsetY | "Vertical Profile Offset"
ProfileAngle | "Angle"
ProfileFamType | "Profile"
ProfileFamTypePlusNone | "Profile"
ProfileFlippedHor | "Profile Is Flipped"
ProfileOffsetX | "Horizontal Profile Offset"
ProfileOffsetY | "Vertical Profile Offset"
ProfileParamAlongPath | "Parameter along path"
ProjectAddress | "Project Address"
ProjectAuthor | "Author"
ProjectBuildingName | "Building Name"
ProjectBuildingType | "Building Type"
ProjectedSurfaceArea | "Projected Area"
ProjectIssueDate | "Project Issue Date"
ProjectName | "Project Name"
ProjectNumber | "Project Number"
ProjectOrganizationDescription | "Organization Description"
ProjectOrganizationName | "Organization Name"
ProjectPostalCode | "Postal Code"
ProjectRevisionEnumeration | "Numbering"
ProjectRevisionRevisionDate | "Revision Date"
ProjectRevisionRevisionDescription | "Revision Description"
ProjectRevisionRevisionIssued | "Issued"
ProjectRevisionRevisionIssuedBy | "Issued by"
ProjectRevisionRevisionIssuedTo | "Issued to"
ProjectRevisionRevisionNum | "Revision Number"
ProjectRevisionSequenceNum | "Revision Sequence": read_only Make this read-only again when NewSchedules_DisplayTags is cleaned up
ProjectStatus | "Project Status"
PropertyArea | "Area"
PropertyAreaOpen | "Area"
PropertyAreaUnits | "Area Units, Format"
PropertyLengthUnits | "Units Format"
PropertySegmentBearing | "Bearing"
PropertySegmentDistance | "Distance"
PropertySegmentEW | "E/W"
PropertySegmentLR | "L/R"
PropertySegmentNS | "N/S"
PropertySegmentRadius | "Radius"
PropertySegmentSubcategoryId | "Subcategory"
PropertySetDescription | "Description"
PropertySetKeywords | "Keywords"
PropertySetMaterialAspect | "Material aspect"
PropertySetName | "Property Set Name"
PropertySubcategoryId | "Subcategory"
RadialArrayArcRadius | "Radius"
RadiusSymbolLocation | "Radius Symbol Location"
RadiusSymbolText | "Radius Symbol Text"
RailingSystemHandrailsHeightParam | "Height"
RailingSystemHandrailsLatteralOffset | "Lateral Offset"
RailingSystemHandrailsPositionParam | "Position"
RailingSystemHandrailsTypesParam | "Type"
RailingSystemHasTopRail | "Use Top Rail": Whether railing has top rail
RailingSystemSecondaryHandrailsHeightParam | "Height"
RailingSystemSecondaryHandrailsLatteralOffset | "Lateral Offset"
RailingSystemSecondaryHandrailsPositionParam | "Position"
RailingSystemSecondaryHandrailsTypesParam | "Type"
RailingSystemTopRailHeightParam | "Height"
RailingSystemTopRailTypesParam | "Type"
RampAttrLeftBalusterAttachPt | "Left Baluster Location"
RampAttrMaterial | "Ramp Material"
RampAttrMinInvSlope | "Ramp Max Slope (1/x)"
RampAttrRightBalusterAttachPt | "Right Baluster Location"
RampAttrShape | "Shape"
RampAttrTextFont | "Text Font"
RampAttrTextSize | "Text Size"
RampAttrThickness | "Thickness"
RampMaxRunLength | "Maximum Incline Length"
RasterEnableSnaps | "Enable Snaps"
RasterHorizontalScale | "Horizontal Scale"
RasterLockProportions | "Lock Proportions"
RasterSheetheight | "Height"
RasterSheetwidth | "Width"
RasterSymbolFilename | "Loaded from file"
RasterSymbolHeight | "Height"
RasterSymbolLinkloadStatus | "Link Status"
RasterSymbolPagenumber | "Page Number"
RasterSymbolPixelheight | "Height (pixels)"
RasterSymbolPixelwidth | "Width (pixels)"
RasterSymbolResolution | "Resolution (dpi)"
RasterSymbolViewname | "View Name"
RasterSymbolWidth | "Width"
RasterVerticalScale | "Vertical Scale"
RbsAdditionalFlow | "Additional Flow"
RbsAdjustableConnector | "Allow Slope Adjustments"
RbsAreaBasedLoadType | "Area Based Load Type"
RbsBuildingConstructionclass | "Building Infiltration Class"
RbsBuildingUseloadcredits | "Use Load Credits"
RbsCabletrayBendradius | "Bend Radius"
RbsCabletrayconduitBendorfitting | "Bend or Fitting"
RbsCabletrayconduitConnectorelemType | "Connector Type"
RbsCabletrayconduitrunLengthParam | "Length"
RbsCabletrayconduitSystemType | "System Type"
RbsCabletrayHeightParam | "Height"
RbsCabletrayRungheight | "Rung Height"
RbsCabletrayRungspace | "Rung Space"
RbsCabletrayRungwidth | "Rung Width"
RbsCabletrayrunHeightParam | "Height"
RbsCabletrayrunWidthParam | "Width"
RbsCabletrayShapetype | "Shape"
RbsCabletrayThickness | "Thickness"
RbsCabletrayWidthParam | "Width"
RbsCalculatedSize | "Size"
RbsComponentClassificationParam | "Component Classification"
RbsConduitBendradius | "Bend Radius"
RbsConduitDiameterParam | "Diameter(Trade Size)"
RbsConduitInnerDiamParam | "Inside Diameter"
RbsConduitOuterDiamParam | "Outside Diameter"
RbsConduitrunDiameterParam | "Diameter(Trade Size)"
RbsConduitrunInnerDiamParam | "Inside Diameter"
RbsConduitrunOuterDiamParam | "Outside Diameter"
RbsConduitTradesize | "Conduit Size Lookup"
RbsConnectorDescription | "Connector Description"
RbsConnectorIsprimary | "Primary Connector"
RbsConnectorOffsetObsolete | "Connector Offset"
RbsConstructionSetParam | "Schematic Types"
RbsConstructionTypeShadingfactorParam | "Internal Shading Factor"
RbsCtcBottomElevation | "Lower End Bottom Elevation"
RbsCtcServiceType | "Service Type"
RbsCtcTopElevation | "Upper End Top Elevation"
RbsCurveDiameterParam | "Diameter"
RbsCurveHeightParam | "Height"
RbsCurveHorOffsetParam | "Horizontal Justification"
RbsCurveSlope | "Slope Percentage (%)"
RbsCurveSurfaceArea | "Area"
RbsCurvetypeDefaultBendParam | "Bend"
RbsCurvetypeDefaultCapParam | "Cap"
RbsCurvetypeDefaultCrossParam | "Cross"
RbsCurvetypeDefaultElbowdownParam | "Vertical Outside Bend"
RbsCurvetypeDefaultElbowParam | "Elbow"
RbsCurvetypeDefaultElbowupParam | "Vertical Inside Bend"
RbsCurvetypeDefaultHorizontalBendParam | "Horizontal Bend"
RbsCurvetypeDefaultMechjointParam | "Flange"
RbsCurvetypeDefaultTakeoffParam | "Tap"
RbsCurvetypeDefaultTeedownParam | "Tee Down"
RbsCurvetypeDefaultTeeParam | "Tee"
RbsCurvetypeDefaultTeeupParam | "Tee Up"
RbsCurvetypeDefaultTransitionParam | "Transition"
RbsCurvetypeDefaultUnionParam | "Union"
RbsCurvetypeMaxHeightParam | "Max Height"
RbsCurvetypeMaxWidthParam | "Max Width"
RbsCurvetypeMultishapeTransitionOvalroundParam | "Multi Shape Transition Oval to Round"
RbsCurvetypeMultishapeTransitionParam | "Multi Shape Transition Rect to Round"
RbsCurvetypeMultishapeTransitionRectovalParam | "Multi Shape Transition Rect to Oval"
RbsCurvetypePreferredBranchParam | "Preferred Junction Type"
RbsCurveUtslope | "Slope"
RbsCurveVertOffsetParam | "Vertical Justification"
RbsCurveWidthParam | "Width"
RbsDistributionsysConfigParam | "Configuration"
RbsDistributionsysHlPhaseParam | "High-leg Phase"
RbsDistributionsysNumwiresParam | "Wires"
RbsDistributionsysPhaseParam | "Phase"
RbsDistributionsysVlgParam | "Line to Ground Voltage"
RbsDistributionsysVllParam | "Line to Line Voltage"
RbsDuctBottomElevation | "Lower End Bottom Elevation"
RbsDuctCalculatedSize | "Duct Size"
RbsDuctConnectorSystemClassificationParam | "System Classification"
RbsDuctFittingLossMethodParam | "Loss Method"
RbsDuctFittingLossMethodServerParam | "Loss Method"
RbsDuctFittingLossMethodSettings | "Loss Method Settings"
RbsDuctFittingLossTableParam | "ASHRAE Table"
RbsDuctFlowConfigurationParam | "Flow Configuration"
RbsDuctFlowDirectionParam | "Flow Direction"
RbsDuctFlowParam | "Flow"
RbsDuctPipeSystemAbbreviationParam | "System Abbreviation"
RbsDuctPressureDrop | "Pressure Drop"
RbsDuctRoutingPreferenceParam | "Routing Preferences"
RbsDuctSizeFormattedParam | "Size"
RbsDuctSlope | "Slope"
RbsDuctStaticPressure | "Static Pressure"
RbsDuctSystemCalculationParam | "Calculations"
RbsDuctSystemTypeParam | "System Type"
RbsDuctTopElevation | "Upper End Top Elevation"
RbsDuctTypeParam | "Duct Type"
RbsElecAmbientTemperature | "Ambient Temperature"
RbsElecAnalyticalArea | "Area"
RbsElecAnalyticalConnectedPhase | "Connected Phases"
RbsElecAnalyticalDownstreamConnectedPhases | "Downstream Connected Phases"
RbsElecAnalyticalFeederLength | "Length"
RbsElecAnalyticalHighLegPhase | "High-leg Phase"
RbsElecAnalyticalLevelId | "Level"
RbsElecAnalyticalLoadDensity | "Power Density"
RbsElecAnalyticalLoadNameParam | "Name"
RbsElecAnalyticalLoadSetOnDuty | "Quantity of Prime"
RbsElecAnalyticalLoadSetOnStandby | "Quantity on Standby"
RbsElecAnalyticalLoadSetOnTotal | "Total Quantity"
RbsElecAnalyticalLoadsInSet | "Loads in Set"
RbsElecAnalyticalLoadTypeParam | "Load Type"
RbsElecAnalyticalNumphases | "Number of Phases"
RbsElecAnalyticalSecondaryHighLegPhase | "Secondary High-leg Phase"
RbsElecAnalyticalTotalCoincidentLoad | "Total Coincident Loads"
RbsElecApparentCurrentParam | "Apparent Current"
RbsElecApparentCurrentPhaseaParam | "Apparent Current Phase A"
RbsElecApparentCurrentPhasebParam | "Apparent Current Phase B"
RbsElecApparentCurrentPhasecParam | "Apparent Current Phase C"
RbsElecApparentLoad | "Apparent Power"
RbsElecApparentLoadPhase1 | "Apparent Power Phase 1"
RbsElecApparentLoadPhase2 | "Apparent Power Phase 2"
RbsElecApparentLoadPhase3 | "Apparent Power Phase 3"
RbsElecApparentLoadPhasea | "Apparent Power Phase A"
RbsElecApparentLoadPhaseb | "Apparent Power Phase B"
RbsElecApparentLoadPhasec | "Apparent Power Phase C"
RbsElecApparentPowerDensity | "Apparent Power Density"
RbsElecBalancedLoad | "Balanced Load"
RbsElecCalcCoefficientUtilization | "Calculate Coefficient of Utilization"
RbsElecCircuitConnectionTypeParam | "Connection Type"
RbsElecCircuitFrameParam | "Frame"
RbsElecCircuitLengthParam | "Length"
RbsElecCircuitName | "Load Name"
RbsElecCircuitNaming | "Circuit Naming"
RbsElecCircuitNamingIndex | "Circuit Naming Index"
RbsElecCircuitNotesParam | "Schedule Circuit Notes"
RbsElecCircuitNumber | "Circuit Number"
RbsElecCircuitNumberingType | "Circuit Numbering Option"
RbsElecCircuitNumberOfElementsParam | "Number of Elements"
RbsElecCircuitPanelParam | "Panel"
RbsElecCircuitPathModeParam | "Path Mode"
RbsElecCircuitPathOffsetParam | "Offset"
RbsElecCircuitPrefix | "Circuit Prefix"
RbsElecCircuitPrefixSeparator | "Circuit Prefix Separator"
RbsElecCircuitRatingParam | "Rating"
RbsElecCircuitSlotIndex | "Slot Index"
RbsElecCircuitStartSlot | "Start Slot"
RbsElecCircuitType | "System Type"
RbsElecCircuitWireNumGroundsParam | "# of Ground Conductors"
RbsElecCircuitWireNumHotsParam | "# of Hot Conductors"
RbsElecCircuitWireNumNeutralsParam | "# of Neutral Conductors"
RbsElecCircuitWireNumRunsParam | "# of Runs"
RbsElecCircuitWireSizeParam | "Wire Size"
RbsElecCircuitWireTypeParam | "Wire Type"
RbsElecDemandCurrentPhasea | "Demand Current Phase A"
RbsElecDemandCurrentPhaseb | "Demand Current Phase B"
RbsElecDemandCurrentPhasec | "Demand Current Phase C"
RbsElecDemandfactorDemandloadParam | "Demand Apparent Power"
RbsElecDemandfactorLoadclassificationParam | "Load Classification"
RbsElecDemandfactorLoadParam | "Connected Apparent Power"
RbsElecDemandLoadPhasea | "Demand Apparent Power Phase A"
RbsElecDemandLoadPhaseb | "Demand Apparent Power Phase B"
RbsElecDemandLoadPhasec | "Demand Apparent Power Phase C"
RbsElecDistributionNodeLoadSet | "Load Set"
RbsElecDistributionNodeSupplyFrom | "Supply From"
RbsElecDistributionNodeSupplyFrom1 | "Supply From 1"
RbsElecDistributionNodeSupplyFrom2 | "Supply From 2"
RbsElecDistributionNodeSupplyTo | "Supply To"
RbsElecEditCircuitNamingSettingsParam | "Circuit Naming Settings"
RbsElecEnclosure | "Enclosure"
RbsElecLoadClassification | "Load Classification"
RbsElecLoadsummaryConnectedCurrentParam | "Connected Current"
RbsElecLoadsummaryConnectedLoadParam | "Connected Apparent Power"
RbsElecLoadsummaryDemandCurrentParam | "Estimated Demand Current"
RbsElecLoadsummaryDemandFactorParam | "Demand Factor"
RbsElecLoadsummaryDemandFactorRuleParam | "Description"
RbsElecLoadsummaryDemandLoadParam | "Demand Apparent Power"
RbsElecLoadsummaryLoadclassificationParam | "Load Classification"
RbsElecMains | "Mains"
RbsElecMaxCircuitsDataPanel | "Maximum Amount of Circuits"
RbsElecMaxPoleBreakers | "Max Number of Single Pole Breakers"
RbsElecModifications | "Modifications"
RbsElecMounting | "Mounting"
RbsElecNumberOfCircuits | "Max Number of Circuits"
RbsElecNumberOfPoles | "Number of Poles"
RbsElecPanelBranchCircuitApparentLoadPhasea | "Branch Circuit Apparent Power Phase A"
RbsElecPanelBranchCircuitApparentLoadPhaseb | "Branch Circuit Apparent Power Phase B"
RbsElecPanelBranchCircuitApparentLoadPhasec | "Branch Circuit Apparent Power Phase C"
RbsElecPanelBranchCircuitCurrentPhasea | "Branch Circuit Current Phase A"
RbsElecPanelBranchCircuitCurrentPhaseb | "Branch Circuit Current Phase B"
RbsElecPanelBranchCircuitCurrentPhasec | "Branch Circuit Current Phase C"
RbsElecPanelBussingParam | "Bussing"
RbsElecPanelConfigurationParam | "Panel Configuration"
RbsElecPanelCurrentPhaseaParam | "Current Phase A"
RbsElecPanelCurrentPhasebParam | "Current Phase B"
RbsElecPanelCurrentPhasecParam | "Current Phase C"
RbsElecPanelFeedParam | "Feed"
RbsElecPanelFeedThruLugsApparentLoadPhasea | "Feed Through Lugs Apparent Power Phase A"
RbsElecPanelFeedThruLugsApparentLoadPhaseb | "Feed Through Lugs Apparent Power Phase B"
RbsElecPanelFeedThruLugsApparentLoadPhasec | "Feed Through Lugs Apparent Power Phase C"
RbsElecPanelFeedThruLugsCurrentPhasea | "Feed Through Lugs Current Phase A"
RbsElecPanelFeedThruLugsCurrentPhaseb | "Feed Through Lugs Current Phase B"
RbsElecPanelFeedThruLugsCurrentPhasec | "Feed Through Lugs Current Phase C"
RbsElecPanelFeedThruLugsParam | "Feed Through Lugs"
RbsElecPanelGroundBusParam | "Ground Bus"
RbsElecPanelLocationParam | "Location"
RbsElecPanelMainstypeParam | "Mains Type"
RbsElecPanelMcbRatingParam | "MCB Rating"
RbsElecPanelName | "Panel Name"
RbsElecPanelNeutralBusParam | "Neutral Bus"
RbsElecPanelNeutralRatingParam | "Neutral Rating"
RbsElecPanelNumphasesParam | "Number of Phases"
RbsElecPanelNumwiresParam | "Number of Wires"
RbsElecPanelScheduleFooterNotesParam | "Schedule Footer Notes"
RbsElecPanelScheduleHeaderNotesParam | "Schedule Header Notes"
RbsElecPanelSubfeedLugsParam | "SubFeed Lugs"
RbsElecPanelSupplyFromParam | "Supply From"
RbsElecPanelTotalConnectedCurrentParam | "Total Connected Current"
RbsElecPanelTotalDemandCurrentParam | "Total Estimated Demand Current"
RbsElecPanelTotalDemandFactorParam | "Total Demand Factor"
RbsElecPanelTotalestloadHvacParam | "HVAC Total Demand Apparent Power"
RbsElecPanelTotalestloadLightParam | "Lighting Total Demand Apparent Power"
RbsElecPanelTotalestloadOtherParam | "Other Total Demand Apparent Power"
RbsElecPanelTotalestloadParam | "Total Demand Apparent Power"
RbsElecPanelTotalestloadPowerParam | "Power Total Demand Apparent Power"
RbsElecPanelTotalloadHvacParam | "HVAC Total Connected Apparent Power"
RbsElecPanelTotalloadLightParam | "Lighting Total Connected Apparent Power"
RbsElecPanelTotalloadOtherParam | "Other Total Connected Apparent Power"
RbsElecPanelTotalloadParam | "Total Connected Apparent Power"
RbsElecPanelTotalloadPowerParam | "Power Total Connected Apparent Power"
RbsElecPowerFactor | "Power Factor"
RbsElecPowerFactorState | "Power Factor State"
RbsElecRoomAverageIllumination | "Average Estimated Illumination"
RbsElecRoomCavityRatio | "Room Cavity Ratio"
RbsElecRoomLightingCalcLuminaireplane | "Lighting Calculation Luminaire Plane"
RbsElecRoomLightingCalcWorkplane | "Lighting Calculation Workplane"
RbsElecRoomReflectivityCeiling | "Ceiling Reflectance"
RbsElecRoomReflectivityFloor | "Floor Reflectance"
RbsElecRoomReflectivityWalls | "Wall Reflectance"
RbsElecShortCircuitRating | "Short Circuit Rating Comments"
RbsElecSwitchIdParam | "Switch ID"
RbsElectricalData | "Electrical Data"
RbsElecTrueCurrentParam | "True Current"
RbsElecTrueCurrentPhaseaParam | "True Current Phase A"
RbsElecTrueCurrentPhasebParam | "True Current Phase B"
RbsElecTrueCurrentPhasecParam | "True Current Phase C"
RbsElecTrueLoad | "True Power"
RbsElecTrueLoadPhase1 | "True Power Phase 1"
RbsElecTrueLoadPhase2 | "True Power Phase 2"
RbsElecTrueLoadPhase3 | "True Power Phase 3"
RbsElecTrueLoadPhasea | "True Power Phase A"
RbsElecTrueLoadPhaseb | "True Power Phase B"
RbsElecTrueLoadPhasec | "True Power Phase C"
RbsElecVoltage | "Voltage"
RbsElecVoltageDropParam | "Voltage Drop"
RbsElecWireCircuits | "Circuits"
RbsElecWireElevation | "Elevation"
RbsElecWireGroundAdjustment | "Ground Conductors"
RbsElecWireHotAdjustment | "Hot Conductors"
RbsElecWireNeutralAdjustment | "Neutral Conductors"
RbsElecWireShareGround | "Share Ground Conductor"
RbsElecWireShareNeutral | "Share Neutral Conductor"
RbsElecWireTickmarkState | "Tick Marks"
RbsElecWireType | "Type"
RbsEndLevelParam | "End Level"
RbsEndOffsetParam | "End Middle Elevation"
RbsEnergyAnalysisBuildingEnvelopeAnalyticalGridCellSize | "Analytical Grid Cell Size"
RbsEnergyAnalysisBuildingEnvelopeAnalyticalSpaceIdentificationResolution | "Analytical Space Resolution"
RbsEnergyAnalysisBuildingEnvelopeAnalyticalSurfaceIdentificationResolution | "Analytical Surface Resolution"
RbsEnergyAnalysisBuildingEnvelopeDeterminationParam | "Building Envelope"
RbsEnergyAnalysisExportCategoryParam | "Export Category"
RbsEnergyAnalysisExportComplexityParam | "Export Complexity"
RbsEnergyAnalysisExportGbxmlDefaultsParam | "Export Default Values"
RbsEnergyAnalysisGroundPlaneParam | "Ground Plane"
RbsEnergyAnalysisIncludeThermalProperties | "Detailed Elements"
RbsEnergyAnalysisMode | "Mode"
RbsEnergyAnalysisProjectPhaseParam | "Project Phase"
RbsEnergyAnalysisSliverSpaceTolerance | "Sliver Space Tolerance"
RbsEnergyAnalysisSurfaceAdjacentSpaceId1 | "Adjacent Space Id (1)"
RbsEnergyAnalysisSurfaceAdjacentSpaceId2 | "Adjacent Space Id (2)"
RbsEnergyAnalysisSurfaceAzimuth | "Azimuth"
RbsEnergyAnalysisSurfaceCadobjectid | "CADObjectID"
RbsEnergyAnalysisSurfaceOriginX | "Origin (X)"
RbsEnergyAnalysisSurfaceOriginY | "Origin (Y)"
RbsEnergyAnalysisSurfaceOriginZ | "Origin (Z)"
RbsEnergyAnalysisSurfaceTilt | "Tilt"
RbsEnergyAnalysisViewBuildingShellMode | "Show Analytical Building Shell"
RbsEnergyAnalysisViewCoordAxisMode | "Show a Coordinate System Symbol for each Surface"
RbsEnergyAnalysisViewInnerShellMode | "Show Inner Space Shells"
RbsEnergyAnalysisViewOuterShellMode | "Show Analytical Space Shells"
RbsEnergyAnalysisViewRbeMode | "Show Room Bounding Elements Dimmed and Underlay"
RbsEnergyAnalysisViewShadingSurfacesMode | "Show Shading Surfaces"
RbsEnergyAnalysisViewSurfacesMode | "Show Surfaces"
RbsEnergyAnalysisViewTransparentMode | "Show Surfaces Transparent"
RbsEnergyAnalysisViewUpdateSurfaces | "Update Surfaces"
RbsEqDiameterParam | "Equivalent Diameter"
RbsFamilyContentAnnotationDisplay | "Use Annotation Scale"
RbsFamilyContentDistributionSystem | "Distribution System"
RbsFamilyContentOffsetHeight | "OffsetHeight"
RbsFamilyContentOffsetWidth | "OffsetWidth"
RbsFamilyContentSecondaryDistribsys | "Secondary Distribution System"
RbsFamilyContentTakeoffFixedLength | "Takeoff Fixed Length"
RbsFamilyContentTakeoffLength | "Takeoff Length"
RbsFamilyContentTakeoffProjlength | "Takeoff Length Projection"
RbsFlexductRoundtypeParam | "Flex Duct Type"
RbsFlexDuctTypeParam | "Flex Duct Type"
RbsFlexPatternParam | "Flex Pattern"
RbsFlexPipeTypeParam | "Flex Pipe"
RbsFlowFactorParam | "Flow Factor"
RbsFlowObsolete | "Flow"
RbsFpSprinklerCoverageParam | "Coverage"
RbsFpSprinklerKFactorParam | "K-Factor"
RbsFpSprinklerOrificeParam | "Orifice"
RbsFpSprinklerOrificeSizeParam | "Orifice Size"
RbsFpSprinklerPressureClassParam | "Pressure Class"
RbsFpSprinklerResponseParam | "Response"
RbsFpSprinklerTemperatureRatingParam | "Temperature Rating"
RbsFriction | "Friction"
RbsGbxmlOpeningType | "Opening Type"
RbsGbxmlSurfaceArea | "Area"
RbsGbxmlSurfaceName | "Surface Name"
RbsGbxmlSurfaceType | "Surface Type"
RbsHvacloadDoorAreaParam | "Door Area"
RbsHvacloadDoorCoolingLoadParam | "Door Cooling Load"
RbsHvacloadFloorAreaParam | "Floor Area"
RbsHvacloadPartitionAreaParam | "Partition Area"
RbsHvacloadPartitionCoolingLoadParam | "Partition Cooling Load"
RbsHvacloadPlenumCoolingLoadParam | "Plenum Cooling Load"
RbsHvacloadRoofAreaParam | "Roof Area"
RbsHvacloadRoofCoolingLoadParam | "Roof Cooling Load"
RbsHvacloadSkylightAreaParam | "Skylight Area"
RbsHvacloadSkylightCoolingLoadParam | "Skylight Cooling Load"
RbsHvacloadWallAreaParam | "Wall Area"
RbsHvacloadWallCoolingLoadParam | "Wall Cooling Load"
RbsHvacloadWindowAreaParam | "Window Area"
RbsHvacloadWindowCoolingLoadParam | "Window Cooling Load"
RbsHydraulicDiameterParam | "Hydraulic Diameter"
RbsInsulationLiningVolume | "Volume"
RbsInsulationThickness | "Insulation Thickness"
RbsInsulationThicknessForDuct | "Insulation Thickness"
RbsInsulationThicknessForPipe | "Insulation Thickness"
RbsIsCustomFitting | "IsCustom"
RbsLiningThickness | "Lining Thickness"
RbsLiningThicknessForDuct | "Lining Thickness"
RbsLoadSubClassificationMotor | "Load Sub-Classification Motor"
RbsLookupTableName | "Lookup Table Name"
RbsLossCoefficient | "Loss Coefficient"
RbsMaxFlow | "Max Flow"
RbsMinFlow | "Min Flow"
RbsOffsetParam | "Middle Elevation"
RbsPanelScheduleSheetAppearanceInstParam | "Appearance"
RbsPanelScheduleSheetAppearanceParam | "Appearance On Sheet"
RbsParallelconduitsHorizontalNumber | "Horizontal Number for parallel conduits"
RbsParallelconduitsHorizontalOffsetValue | "Horizontal Offset value for parallel conduits"
RbsParallelconduitsVerticalNumber | "Vertical Number for parallel conduits"
RbsParallelconduitsVerticalOffsetValue | "Vertical Offset value for parallel conduits"
RbsParallelpipesHorizontalNumber | "Horizontal Number for parallel pipes"
RbsParallelpipesHorizontalOffsetValue | "Horizontal Offset value for parallel pipes"
RbsParallelpipesVerticalNumber | "Vertical Number for parallel pipes"
RbsParallelpipesVerticalOffsetValue | "Vertical Offset value for parallel pipes"
RbsPartType | "Part Type"
RbsPipeAdditionalFlowParam | "Additional Flow"
RbsPipeBottomElevation | "Lower End Bottom Elevation"
RbsPipeCalculatedSize | "Pipe Size"
RbsPipeClassParam | "Schedule/Type"
RbsPipeConnectiontypeParam | "Connection Type"
RbsPipeConnectorSystemClassificationParam | "System Classification"
RbsPipeCwfuParam | "CWFU"
RbsPipeDiameterParam | "Diameter"
RbsPipeFittingLossKfactorParam | "K Coefficient"
RbsPipeFittingLossMethodParam | "Loss Method"
RbsPipeFittingLossMethodServerParam | "Loss Method"
RbsPipeFittingLossMethodSettings | "Loss Method Settings"
RbsPipeFittingLossTableParam | "K Coefficient Table"
RbsPipeFixtureUnitsParam | "Fixture Units"
RbsPipeFlowConfigurationParam | "Flow Configuration"
RbsPipeFlowDirectionParam | "Flow Direction"
RbsPipeFlowParam | "Flow"
RbsPipeFlowStateParam | "Flow State"
RbsPipeFluidDensityParam | "Fluid Density"
RbsPipeFluidTemperatureParam | "Fluid Temperature"
RbsPipeFluidTypeParam | "Fluid Type"
RbsPipeFluidViscosityParam | "Fluid Dynamic Viscosity"
RbsPipeFrictionParam | "Friction"
RbsPipeHwfuParam | "HWFU"
RbsPipeInnerDiamParam | "Inside Diameter"
RbsPipeInsulationThickness | "Insulation Thickness"
RbsPipeInvertElevation | "Invert Elevation": This parameter is obsolete. It exists only for compatibility.
RbsPipeJointtypeParam | "Connection Type"
RbsPipeMaterialParam | "Material"
RbsPipeOuterDiameter | "Outside Diameter"
RbsPipePressuredropParam | "Pressure Drop"
RbsPipeReynoldsNumberParam | "Reynolds Number"
RbsPipeSegmentParam | "Pipe Segment"
RbsPipeSizeFormattedParam | "Size"
RbsPipeSizeMaximum | "Maximum Size"
RbsPipeSizeMinimum | "Minimum Size"
RbsPipeSlope | "Slope"
RbsPipeSlopeDefParam | "Pipe Slope Definitions"
RbsPipeSlopeOptionsDefParam | "Pipe Slope Options"
RbsPipeStaticPressure | "Static Pressure"
RbsPipeSystemCalculationParam | "Calculations"
RbsPipeSystemFixtureUnitParam | "Fixture Units"
RbsPipeTopElevation | "Upper End Top Elevation"
RbsPipeTypeFittingLossKfactorParam | "K Coefficient"
RbsPipeTypeFittingLossMethodParam | "Loss Method"
RbsPipeTypeFittingLossTableParam | "K Coefficient Table"
RbsPipeTypeParam | "Pipe Type"
RbsPipeTypeValveLossCvfactorParam | "Cv Coefficient"
RbsPipeValveLossCvfactorParam | "Cv Coefficient"
RbsPipeVelocityParam | "Velocity"
RbsPipeVolumeParam | "Volume"
RbsPipeWallThickness | "Wall Thickness"
RbsPipeWfuParam | "WFU"
RbsPipingSystemTypeParam | "System Type"
RbsPressureDrop | "Pressure Drop"
RbsProjectConstructionTypeShadingfactorParam | "Internal Shading Factor"
RbsProjectLocationParam | "Location"
RbsProjectReporttypeParam | "Report Type"
RbsReferenceFreesize | "Free Size"
RbsReferenceInsulationThickness | "Insulation Thickness": This parameter is obsolete. Use DUCT_INSULATION_THICKNESS and PIPE_INSULATION_THICKNESS.
RbsReferenceInsulationType | "Insulation Type"
RbsReferenceLiningThickness | "Lining Thickness"
RbsReferenceLiningType | "Lining Type"
RbsReferenceOverallsize | "Overall Size"
RbsReynoldsnumberParam | "Reynolds number"
RbsRoomCoefficientUtilization | "Coefficient of Utilization"
RbsRoutingPreferenceParam | "Routing Preferences"
RbsSection | "Section"
RbsSegmentDescriptionParam | "Segment Description"
RbsServiceTypeParam | "Building Service"
RbsShowProfileType | "Show Round"
RbsSizeLock | "Size Lock"
RbsStartLevelParam | "Reference Level"
RbsStartOffsetParam | "Start Middle Elevation"
RbsSystemAbbreviationParam | "Abbreviation"
RbsSystemBaseElementParam | "System Equipment"
RbsSystemClassificationParam | "System Classification"
RbsSystemFlowConversionMethodParam | "Flow Conversion Method"
RbsSystemNameParam | "System Name"
RbsSystemNumElementsParam | "Number of Elements"
RbsSystemRisedrop1linedropsymbolParam | "Single Line Drop Symbol"
RbsSystemRisedrop1linerisesymbolParam | "Single Line Rise Symbol"
RbsSystemRisedrop1lineteedownsymbolParam | "Single Line Tee Down Symbol"
RbsSystemRisedrop1lineteeupsymbolParam | "Single Line Tee Up Symbol"
RbsSystemRisedrop2linedropsymbolParam | "Two Line Drop Symbol"
RbsSystemRisedrop2linerisesymbolParam | "Two Line Rise Symbol"
RbsSystemRisedropParam | "Rise / Drop Symbol"
RbsVelocity | "Velocity"
RbsVelocityPressure | "Velocity Pressure"
RbsVoltagetypeMaxvoltageParam | "Maximum Voltage"
RbsVoltagetypeMinvoltageParam | "Minimum Voltage"
RbsVoltagetypeVoltageParam | "Actual Voltage"
RbsWireCircuitDescription | "Circuit Description"
RbsWireCircuitLoadName | "Circuit Load Name"
RbsWireConduitTypeParam | "Conduit Type"
RbsWireInsulationParam | "Insulation"
RbsWireMaterialParam | "Material"
RbsWireMaxConductorSizeParam | "Max Size"
RbsWireNeutralIncludedInBalancedLoadParam | "Neutral Included in Balanced Load"
RbsWireNeutralModeParam | "Neutral Size"
RbsWireNeutralMultiplierParam | "Neutral Multiplier"
RbsWireNumConductorsParam | "Number of Conductors"
RbsWireTemperatureRatingParam | "Temperature Rating"
RebarAlignmentOptions | "Bar Alignment"
RebarBarDeformationType | "Deformation"
RebarBarDiameter | "Bar Diameter"
RebarBarHookLengths | "Hook Lengths"
RebarBarMaximumBendRadius | "Maximum Bend Radius"
RebarBarSpliceLengths | "Splice Lengths"
RebarBarStirrupBendDiameter | "Stirrup/Tie Bend Diameter"
RebarBarStyle | "Subcategory"
RebarConstraintsStatus | "Rebar Constraint Status"
RebarContainerBarType | "Bar Type"
RebarDistributionType | "Distribution Type"
RebarElemBarSpacing | "Spacing"
RebarElemEndtreatmentEnd | "End Treatment At End"
RebarElemEndtreatmentStart | "End Treatment At Start"
RebarElementRounding | "Rounding Overrides"
RebarElementVisibility | "View Visibility States"
RebarElemHookEndOrient | "Hook Orientation At End"
RebarElemHookEndType | "Hook At End"
RebarElemHookStartOrient | "Hook Orientation At Start"
RebarElemHookStartType | "Hook At Start"
RebarElemHookStyle | "Style"
RebarElemHostMark | "Host Mark"
RebarElemLayoutRule | "Layout Rule"
RebarElemLength | "Bar Length"
RebarElemQuantityOfBars | "Quantity"
RebarElemScheduleMark | "Schedule Mark"
RebarElemTotalLength | "Total Bar Length"
RebarFreeFormHookEndPlaneAngle | "Hook Orientation At End"
RebarFreeFormHookStartPlaneAngle | "Hook Orientation At Start"
RebarGeometryType | "Geometry"
RebarHookAngle | "Hook Angle"
RebarHookLengthOverride | "Override Hook Lengths"
RebarHookLineLenFactor | "Extension Multiplier"
RebarHookRotationAtEnd | "Hook Rotation At End"
RebarHookRotationAtEndSchedulesTagsFilters | "Hook Rotation At End"
RebarHookRotationAtStart | "Hook Rotation At Start"
RebarHookRotationAtStartSchedulesTagsFilters | "Hook Rotation At Start"
RebarHookStyle | "Style"
RebarHostCategory | "Host Category"
RebarIncludeFirstBar | "Include First Bar"
RebarIncludeLastBar | "Include Last Bar"
RebarInstanceBarDiameter | "Bar Diameter"
RebarInstanceBarModelDiameter | "Model Bar Diameter"
RebarInstanceBendDiameter | "Bend Diameter"
RebarInstanceStirrupTieAttachment | "Stirrup/Tie Attachment"
RebarInternalMultiplanar | "INTERNAL: Multiplanar"
RebarInternalMultiplanarArcConnector | "INTERNAL: Multiplanar Arc Connector"
RebarInternalMultiplanarDuplicate | "INTERNAL: Multiplanar Duplicate"
RebarInternalMultiplanarEndConnector | "INTERNAL: Multiplanar End Connector"
RebarInternalMultiplanarStartConnector | "INTERNAL: Multiplanar Start Connector"
RebarMaximSuffix | "Maximum Suffix"
RebarMaximumNumber | "Maximum Rebar Number"
RebarMaxLength | "Maximum Bar Length"
RebarMinimSuffix | "Minimum Suffix"
RebarMinimumNumber | "Minimum Rebar Number"
RebarMinLength | "Minimum Bar Length"
RebarModelBarDiameter | "Model Bar Diameter"
RebarModifiedSet | "Modified Rebar Set"
RebarNumber | "Rebar Number"
RebarNumberSuffix | "Rebar Number Suffix"
RebarQuanityByDistrib | "Quantity By Rebar Set"
RebarShape | "Shape"
RebarShapeAllowedBarTypes | "Allowable Rebar Bar Types"
RebarShapeEndHookLength | "End Hook Length"
RebarShapeEndHookOffset | "End Hook Offset Length"
RebarShapeEndtreatmentEndType | "End Treatment At End"
RebarShapeEndtreatmentStartType | "End Treatment At Start"
RebarShapeHookEndType | "Hook At End"
RebarShapeHookRotationAtEnd | "Hook Rotation At End"
RebarShapeHookRotationAtStart | "Hook Rotation At Start"
RebarShapeHookStartType | "Hook At Start"
RebarShapeHookStyle | "Style"
RebarShapeImage | "Shape Image"
RebarShapeOutOfPlaneBendDiameter | "Out of Plane Bend Diameter"
RebarShapeParamEndHookTanLen | "End Tangent Hook Length"
RebarShapeParamStartHookTanLen | "Start Tangent Hook Length"
RebarShapeSpiralBaseFinishingTurns | "Base Finishing Turns"
RebarShapeSpiralHeight | "Height"
RebarShapeSpiralPitch | "Pitch"
RebarShapeSpiralTopFinishingTurns | "Top Finishing Turns"
RebarShapeStartHookLength | "Start Hook Length"
RebarShapeStartHookOffset | "Start Hook Offset Length"
RebarShapeStirrupTieAttachment | "Stirrup/Tie Attachment"
RebarSpliceLapLengthMultiplier | "Lap Length Multiplier"
RebarSpliceShiftBars | "Shift Bars"
RebarSpliceSpliceLinePosition | "Splice Position"
RebarSpliceStaggerLengthMultiplier | "Stagger Length Multiplier"
RebarStaggeredSet | "Staggered Set"
RebarStaggerOffsetAtEnd | "Offset At End"
RebarStaggerOffsetAtStart | "Offset At Start"
RebarStandardBendDiameter | "Standard Bend Diameter"
RebarStandardHookBendDiameter | "Standard Hook Bend Diameter"
RebarSystemActiveBackDirn1 | "Interior Major Direction"
RebarSystemActiveBackDirn2 | "Interior Minor Direction"
RebarSystemActiveBottomDir1Generic | "Bottom/Interior Major Direction"
RebarSystemActiveBottomDir2Generic | "Bottom/Interior Minor Direction"
RebarSystemActiveBottomDirn1 | "Bottom Major Direction"
RebarSystemActiveBottomDirn2 | "Bottom Minor Direction"
RebarSystemActiveFrontDirn1 | "Exterior Major Direction"
RebarSystemActiveFrontDirn2 | "Exterior Minor Direction"
RebarSystemActiveTopDir1Generic | "Top/Exterior Major Direction"
RebarSystemActiveTopDir2Generic | "Top/Exterior Minor Direction"
RebarSystemActiveTopDirn1 | "Top Major Direction"
RebarSystemActiveTopDirn2 | "Top Minor Direction"
RebarSystemAddlBottomOffset | "Additional Bottom Cover Offset"
RebarSystemAddlExteriorOffset | "Additional Exterior Cover Offset"
RebarSystemAddlInteriorOffset | "Additional Interior Cover Offset"
RebarSystemAddlTopOffset | "Additional Top Cover Offset"
RebarSystemBarTypeBackDirn1 | "Interior Major Bar Type"
RebarSystemBarTypeBackDirn2 | "Interior Minor Bar Type"
RebarSystemBarTypeBottomDir1Generic | "Bottom/Interior Major Bar Type"
RebarSystemBarTypeBottomDir2Generic | "Bottom/Interior Minor Bar Type"
RebarSystemBarTypeBottomDirn1 | "Bottom Major Bar Type"
RebarSystemBarTypeBottomDirn2 | "Bottom Minor Bar Type"
RebarSystemBarTypeFrontDirn1 | "Exterior Major Bar Type"
RebarSystemBarTypeFrontDirn2 | "Exterior Minor Bar Type"
RebarSystemBarTypeTopDir1Generic | "Top/Exterior Major Bar Type"
RebarSystemBarTypeTopDir2Generic | "Top/Exterior Minor Bar Type"
RebarSystemBarTypeTopDirn1 | "Top Major Bar Type"
RebarSystemBarTypeTopDirn2 | "Top Minor Bar Type"
RebarSystemBottomMajorMatchesBottomMinor | "Bottom Major and Minor Layers Match"
RebarSystemCoverBottom | "Rebar Cover Bottom/Interior"
RebarSystemCoverSide | "Rebar Cover Side/Edge"
RebarSystemCoverTop | "Rebar Cover Top/Exterior"
RebarSystemHookOrientBackDirn1 | "Interior Major Hook Orientation"
RebarSystemHookOrientBackDirn2 | "Interior Minor Hook Orientation"
RebarSystemHookOrientBottomDirn1 | "Bottom Major Hook Orientation"
RebarSystemHookOrientBottomDirn2 | "Bottom Minor Hook Orientation"
RebarSystemHookOrientFrontDirn1 | "Exterior Major Hook Orientation"
RebarSystemHookOrientFrontDirn2 | "Exterior Minor Hook Orientation"
RebarSystemHookOrientTopDirn1 | "Top Major Hook Orientation"
RebarSystemHookOrientTopDirn2 | "Top Minor Hook Orientation"
RebarSystemHookTypeBackDirn1 | "Interior Major Hook Type"
RebarSystemHookTypeBackDirn2 | "Interior Minor Hook Type"
RebarSystemHookTypeBottomDirn1 | "Bottom Major Hook Type"
RebarSystemHookTypeBottomDirn2 | "Bottom Minor Hook Type"
RebarSystemHookTypeFrontDirn1 | "Exterior Major Hook Type"
RebarSystemHookTypeFrontDirn2 | "Exterior Minor Hook Type"
RebarSystemHookTypeTopDirn1 | "Top Major Hook Type"
RebarSystemHookTypeTopDirn2 | "Top Minor Hook Type"
RebarSystemLayerSummaryBottomDir1NoSpacing | "Bottom/Interior Major (Brief)"
RebarSystemLayerSummaryBottomDir1WithSpacing | "Bottom/Interior Major"
RebarSystemLayerSummaryBottomDir2NoSpacing | "Bottom/Interior Minor (Brief)"
RebarSystemLayerSummaryBottomDir2WithSpacing | "Bottom/Interior Minor"
RebarSystemLayerSummaryDir1NoSpacing | "Major, Both Faces (Brief)"
RebarSystemLayerSummaryDir1WithSpacing | "Major, Both Faces"
RebarSystemLayerSummaryDir2NoSpacing | "Minor, Both Faces (Brief)"
RebarSystemLayerSummaryDir2WithSpacing | "Minor, Both Faces"
RebarSystemLayerSummaryNoSpacing | "Layer Summary (Brief)"
RebarSystemLayerSummaryTopDir1NoSpacing | "Top/Exterior Major (Brief)"
RebarSystemLayerSummaryTopDir1WithSpacing | "Top/Exterior Major"
RebarSystemLayerSummaryTopDir2NoSpacing | "Top/Exterior Minor (Brief)"
RebarSystemLayerSummaryTopDir2WithSpacing | "Top/Exterior Minor"
RebarSystemLayerSummaryWithSpacing | "Layer Summary"
RebarSystemLayoutRule | "Layout Rule"
RebarSystemNumberOfLinesBackDirn1 | "Interior Major Number Of Lines"
RebarSystemNumberOfLinesBackDirn2 | "Interior Minor Number Of Lines"
RebarSystemNumberOfLinesBottomDir1Generic | "Bottom/Interior Major Number Of Lines"
RebarSystemNumberOfLinesBottomDir2Generic | "Bottom/Interior Minor Number Of Lines"
RebarSystemNumberOfLinesBottomDirn1 | "Bottom Major Number Of Lines"
RebarSystemNumberOfLinesBottomDirn2 | "Bottom Minor Number Of Lines"
RebarSystemNumberOfLinesFrontDirn1 | "Exterior Major Number Of Lines"
RebarSystemNumberOfLinesFrontDirn2 | "Exterior Minor Number Of Lines"
RebarSystemNumberOfLinesTopDir1Generic | "Top/Exterior Major Number Of Lines"
RebarSystemNumberOfLinesTopDir2Generic | "Top/Exterior Minor Number Of Lines"
RebarSystemNumberOfLinesTopDirn1 | "Top Major Number Of Lines"
RebarSystemNumberOfLinesTopDirn2 | "Top Minor Number Of Lines"
RebarSystemOverride | "Override Area Reinforcement Settings"
RebarSystemSpacingBackDirn1 | "Interior Major Spacing"
RebarSystemSpacingBackDirn2 | "Interior Minor Spacing"
RebarSystemSpacingBottomDir1Generic | "Bottom/Interior Major Spacing"
RebarSystemSpacingBottomDir2Generic | "Bottom/Interior Minor Spacing"
RebarSystemSpacingBottomDirn1 | "Bottom Major Spacing"
RebarSystemSpacingBottomDirn2 | "Bottom Minor Spacing"
RebarSystemSpacingFrontDirn1 | "Exterior Major Spacing"
RebarSystemSpacingFrontDirn2 | "Exterior Minor Spacing"
RebarSystemSpacingTopDir1Generic | "Top/Exterior Major Spacing"
RebarSystemSpacingTopDir2Generic | "Top/Exterior Minor Spacing"
RebarSystemSpacingTopDirn1 | "Top Major Spacing"
RebarSystemSpacingTopDirn2 | "Top Minor Spacing"
RebarSystemSpanactiveDirn1 | "Bars In Major Direction"
RebarSystemSpanactiveDirn2 | "Bars In Minor Direction"
RebarSystemSpanhookBottomDirn2 | "Hook Angle Bottom"
RebarSystemSpanhookLeftDirn1 | "Hook Angle Left"
RebarSystemSpanhookRightDirn1 | "Hook Angle Right"
RebarSystemSpanhookTopDirn2 | "Hook Angle Top"
RebarSystemTopMajorMatchesBottomMajor | "Top and Bottom Major Layers Match"
RebarSystemTopMajorMatchesTopMinor | "Top Major and Minor Layers Match"
RebarSystemTopMinorMatchesBottomMinor | "Top and Bottom Minor Layers Match"
RebarWorkshopInstructions | "Workshop Instructions"
RectMullionThick | "Thickness"
RectMullionWidth1 | "Width on side 1"
RectMullionWidth2 | "Width on side 2"
ReferenceBaseOnHost | "Reference Base on Host"
ReferencedView | "Referenced View": The view referenced by a section or callout.
ReferenceLineSubcategory | "Subcategory"
ReferenceOtherViewUiRefView | "Reference View": This is used by the UI to allow selection of view reference.
ReferenceOtherViewUiToggle | "Reference Other View": This is used to determine whether reference other view is enable or not.
ReferenceViewerAttrTag | "View Reference Tag"
ReferenceViewerTargetView | "Target view"
ReferenceViewerUiTargetFilter | "Filter": This is used by the UI to filter the list of target views.
ReferenceViewerUiTargetView | "Target view": This is used by the UI to allow selection of target view. It allows the UI to set a filter that is incompatible with the current target view (REFERENCE_VIEWER_TARGET_VIEW).
RefTableElemName | "Key Name"
RefTableParamName | "Parameter Name"
ReinEstBarLength | "Estimated Total Bar Length"
ReinEstBarVolume | "Estimated Reinforcement Volume"
ReinEstNumberOfBars | "Estimated Number of Bars"
ReinforcementVolume | "Reinforcement Volume"
RelatedToMass | "Related to Mass"
RelativeRoughness | "Relative Roughness"
RenderPlantHeight | "Height"
RenderPlantName | "Plant Name"
RenderPlantTrimHeight | "Plant Trim Height"
RenderRpcFilename | "Render Appearance"
RenderRpcProperties | "Render Appearance Properties"
RepeatingDetailElement | "Detail"
RepeatingDetailInside | "Inside"
RepeatingDetailLayout | "Layout"
RepeatingDetailNumber | "Number"
RepeatingDetailRotation | "Detail Rotation"
RepeatingDetailSpacing | "Spacing"
RevealProfileParam | "Profile"
RevisionCloudRevision | "Revision"
RevisionCloudRevisionDate | "Revision Date"
RevisionCloudRevisionDescription | "Revision Description"
RevisionCloudRevisionIssuedBy | "Issued by"
RevisionCloudRevisionIssuedTo | "Issued to"
RevisionCloudRevisionNum | "Revision Number"
RevolutionEndAngle | "End Angle"
RevolutionStartAngle | "Start Angle"
RgbBParam | "Blue value for RGB color spec. (for Use with XAML Data Template example)"
RgbGParam | "Green value for RGB color spec. (for Use with XAML Data Template example)"
RgbRParam | "Red value for RGB color spec. (for Use with XAML Data Template example)"
RoofAttrDefaultThicknessParam | "Default Thickness"
RoofAttrThicknessParam | "Thickness"
RoofBaseLevelParam | "Base Level"
RoofConstraintLevelParam | "Reference Level"
RoofConstraintOffsetParam | "Level Offset"
RoofCurveHeightAtWall | "Plate Offset From Base"
RoofCurveHeightOffset | "Offset From Roof Base"
RoofCurveIsSlopeDefining | "Defines Roof Slope"
RoofEaveCutParam | "Rafter Cut"
RoofFacesLocation | "Picked Faces Location"
RoofLevelOffsetParam | "Base Offset From Level"
RoofRafterOrTrussParam | "Rafter or Truss"
RoofSlope | "Slope"
RoofStructureIdParam | "Structure"
RoofUptoLevelOffsetParam | "Cutoff Offset"
RoofUptoLevelParam | "Cutoff Level"
RoomActualExhaustAirflowParam | "Actual Exhaust Airflow"
RoomActualLightingLoadParam | "Actual Lighting Load"
RoomActualLightingLoadPerAreaParam | "Actual Lighting Load per area"
RoomActualPowerLoadParam | "Actual Power Load"
RoomActualPowerLoadPerAreaParam | "Actual Power Load per area"
RoomActualReturnAirflowParam | "Actual Return Airflow"
RoomActualSupplyAirflowParam | "Actual Supply Airflow"
RoomAirChangesPerHourParam | "Air Changes per Hour"
RoomArea | "Area"
RoomAreaPerPersonParam | "Area per Person"
RoomBaseHeatLoadOnParam | "Heat Load Values"
RoomBaseLightingLoadOnParam | "Base Lighting Load on"
RoomBasePowerLoadOnParam | "Base Power Load on"
RoomBaseReturnAirflowOnParam | "Return Airflow"
RoomCalculatedCoolingLoadParam | "Calculated Cooling Load"
RoomCalculatedCoolingLoadPerAreaParam | "Calculated Cooling Load per area"
RoomCalculatedHeatingLoadParam | "Calculated Heating Load"
RoomCalculatedHeatingLoadPerAreaParam | "Calculated Heating Load per area"
RoomCalculatedSupplyAirflowParam | "Calculated Supply Airflow"
RoomCalculatedSupplyAirflowPerAreaParam | "Calculated Supply Airflow per area"
RoomCalculationPoint | "Room Calculation Point"
RoomComputationHeight | "Computation Height"
RoomComputationMethod | "Computation"
RoomConditionTypeParam | "Condition Type"
RoomConstructionSetParam | "Construction Type"
RoomDepartment | "Department"
RoomDesignCoolingLoadParam | "Design Cooling Load"
RoomDesignExhaustAirflowParam | "Specified Exhaust Airflow"
RoomDesignHeatingLoadParam | "Design Heating Load"
RoomDesignLightingLoadParam | "Specified Lighting Load"
RoomDesignLightingLoadPerAreaParam | "Specified Lighting Load per area"
RoomDesignMechanicalLoadPerAreaParam | "Design HVAC Load per area"
RoomDesignOtherLoadPerAreaParam | "Design Other Load per area"
RoomDesignPowerLoadParam | "Specified Power Load"
RoomDesignPowerLoadPerAreaParam | "Specified Power Load per area"
RoomDesignReturnAirflowParam | "Specified Return Airflow"
RoomDesignSupplyAirflowParam | "Specified Supply Airflow"
RoomEditElectricalLoadsParam | "Electrical Loads"
RoomEditPeopleLoadsParam | "People"
RoomFinishBase | "Base Finish"
RoomFinishCeiling | "Ceiling Finish"
RoomFinishFloor | "Floor Finish"
RoomFinishWall | "Wall Finish"
RoomHeight | "Unbounded Height"
RoomLevelId | "Level"
RoomLightingLoadUnitsParam | "Lighting Load Units"
RoomLowerOffset | "Base Offset"
RoomName | "Name"
RoomNumber | "Number"
RoomNumberOfPeopleParam | "Number of People"
RoomOccupancy | "Occupancy"
RoomOccupancyUnitParam | "Occupancy Unit"
RoomOutdoorAirflowParam | "Outdoor Airflow"
RoomOutdoorAirflowStandardParam | "Outdoor Air Method"
RoomOutdoorAirInfoParam | "Outdoor Air Information"
RoomOutdoorAirPerAreaParam | "Outdoor Air per Area"
RoomOutdoorAirPerPersonParam | "Outdoor Air per Person"
RoomPeopleLatentHeatGainPerPersonParam | "Latent Heat Gain per person"
RoomPeopleSensibleHeatGainPerPersonParam | "Sensible Heat Gain per person"
RoomPeopleTotalHeatGainPerPersonParam | "Total Heat Gain per person"
RoomPerimeter | "Perimeter"
RoomPhase | "Phase"
RoomPhaseId | "Phase Id"
RoomPlenumLightingParam | "Plenum Lighting Contribution"
RoomPowerLoadUnitsParam | "Power Load Units"
RoomSpaceTypeParam | "Space Type"
RoomTagOrientationParam | "Orientation"
RoomUpperLevel | "Upper Limit"
RoomUpperOffset | "Limit Offset"
RoomVolume | "Volume"
RouteAnalysisSettingsParam | "Route Analysis Settings"
RoutingPreferenceParam | "Routing Preference"
RvtHostLevel | "Map Levels..."
RvtLevelOffset | "Map Levels..."
RvtLinkFileNameWithoutExt | "File Name"
RvtLinkInstanceName | "Name"
RvtLinkInstanceProjectInformation | "Project Information"
RvtLinkPhaseMap | "Phase Mapping"
RvtLinkReferenceType | "Reference Type"
RvtSourceLevel | "Map Levels..."
ScaleFactorParam | "Scale"
ScheduleBaseLevelOffsetParam | "Base Offset"
ScheduleBaseLevelParam | "Base Level"
ScheduleCategory | "Category"
ScheduleEmbeddedParam | "Embedded Schedule"
ScheduleFieldsParam | "Fields"
ScheduleFilterParam | "Filter"
ScheduleFormatParam | "Formatting"
ScheduleGroupParam | "Sorting/Grouping"
ScheduleLevelParam | "Level"
ScheduleResizeRows | "Resize Rows"
ScheduleRotationOnSheet | "Rotation on Sheet"
ScheduleRowHeightInput | "Row Height"
ScheduleSheetAppearanceParam | "Appearance"
ScheduleTopLevelOffsetParam | "Top Offset"
ScheduleTopLevelParam | "Top Level"
ScheduleTypeForBrowser | "Schedule Type"
SectionAttrHeadTag | "Section Head"
SectionAttrTailLength | "Tail length"
SectionAttrTailTag | "Section Tail"
SectionAttrTailWidth | "Tail width"
SectionBrokenDisplayStyle | "Broken Section Display Style"
SectionCoarserScalePulldownImperial | "Hide at scales coarser than"
SectionCoarserScalePulldownMetric | "Hide at scales coarser than"
SectionParentViewName | "Parent View"
SectionShowInOneViewOnly | "Show in"
SectionTag | "Section Tag"
SeekItemId | "Seek Item ID"
SelectionEditableOnly | "Editable only"
SheetApprovedBy | "Approved By"
SheetAssemblyAssemblyCode | "Assembly: Assembly Code"
SheetAssemblyAssemblyDescription | "Assembly: Assembly Description"
SheetAssemblyCost | "Assembly: Cost"
SheetAssemblyDescription | "Assembly: Description"
SheetAssemblyKeynote | "Assembly: Keynote"
SheetAssemblyManufacturer | "Assembly: Manufacturer"
SheetAssemblyModel | "Assembly: Model"
SheetAssemblyName | "Assembly: Name"
SheetAssemblyTypeComments | "Assembly: Type Comments"
SheetAssemblyTypeMark | "Assembly: Type Mark"
SheetAssemblyUrl | "Assembly: URL"
SheetCheckedBy | "Checked By"
SheetCollection | "Sheet Collection"
SheetCollectionName | "Name"
SheetCurrentRevision | "Current Revision"
SheetCurrentRevisionDate | "Current Revision Date"
SheetCurrentRevisionDescription | "Current Revision Description"
SheetCurrentRevisionIssued | "Current Revision Issued"
SheetCurrentRevisionIssuedBy | "Current Revision Issued By"
SheetCurrentRevisionIssuedTo | "Current Revision Issued To"
SheetDate | "Date/Time Stamp"
SheetDesignedBy | "Designed By"
SheetDrawnBy | "Drawn By"
SheetFilePath | "File Path"
SheetGuideGrid | "Guide Grid"
SheetHeight | "Sheet Height"
SheetIssueDate | "Sheet Issue Date"
SheetKeyNumber | "Sheet Key Number"
SheetName | "Sheet Name"
SheetNumber | "Sheet Number"
SheetRevisionsOnSheet | "Revisions on Sheet"
SheetScale | "Scale"
SheetScheduled | "Appears In Sheet List"
SheetWidth | "Sheet Width"
ShowArrowheadToCutMark | "Show Arrowhead to Cut Mark"
ShowIconParam | "Flag to display icon in Ribbon Combo Item"
ShowTitle | "Show Title"
SketchGridSpacingParam | "Work Plane Grid Spacing"
SketchPlaneParam | "Work Plane"
SlabEdgeMaterialParam | "Material"
SlabEdgeProfileParam | "Profile"
SlantedColumnBaseCutStyle | "Base Cut Style"
SlantedColumnBaseExtension | "Base Extension"
SlantedColumnGeometryTreatmentBase | "Base Geometry Alignment"
SlantedColumnGeometryTreatmentTop | "Top Geometry Alignment"
SlantedColumnTopCutStyle | "Top Cut Style"
SlantedColumnTopExtension | "Top Extension"
SlantedColumnTypeParam | "Column Style"
SlopeArrowLevelEnd | "Level at Head"
SlopeArrowLevelStart | "Level at Tail"
SlopeEndHeight | "Height Offset at Head"
SlopeStartHeight | "Height Offset at Tail"
SpaceAirChangesPerHour | "Air Changes per Hour"
SpaceAirflowPerAreaParam | "Airflow per area"
SpaceArea | "Area"
SpaceAreaPerPersonParam | "Area per person"
SpaceAssocRoomName | "Room Name"
SpaceAssocRoomNumber | "Room Number"
SpaceCarpetingParam | "Carpeting"
SpaceComposednameParam | "Composed Name"
SpaceConditionType | "Condition Type"
SpaceCoolingSetPoint | "Cooling Set Point"
SpaceDehumidificationSetPoint | "Dehumidification Set Point"
SpaceElecEquipmentRadiantPercentageParam | "Electrical Equipment Radiant"
SpaceHeatingSetPoint | "Heating Set Point"
SpaceHumidificationSetPoint | "Humidification Set Point"
SpaceInfiltrationAirflow | "Infiltration Airflow"
SpaceInfiltrationAirflowPerArea | "Infiltration Airflow per area"
SpaceInfiltrationParam | "Infiltration Airflow per area"
SpaceIsOccupiable | "Occupiable"
SpaceIsPlenum | "Plenum"
SpaceLightingLoadParam | "Lighting Load"
SpaceLightingLoadPerAreaParam | "Lighting Load per area"
SpaceLightingScheduleParam | "Lighting Schedule"
SpaceNameParam | "Name"
SpaceNumberOfPeople | "Number of People"
SpaceNumberParam | "Number"
SpaceOccupancyScheduleParam | "Occupancy Schedule"
SpaceOutdoorAirflow | "Outdoor Airflow"
SpaceOutdoorAirflowPerArea | "Outdoor Airflow per area"
SpaceOutdoorAirflowPerPerson | "Outdoor Airflow per person"
SpacePeopleActivityLevelParam | "People Activity Level"
SpacePeopleLatentHeatGainPerPersonParam | "Latent Heat Gain per person"
SpacePeopleLoadParam | "Occupancy Load"
SpacePeopleSensibleHeatGainPerPersonParam | "Sensible Heat Gain per person"
SpacePowerLoadParam | "Power Load"
SpacePowerLoadPerAreaParam | "Power Load per area"
SpacePowerScheduleParam | "Power Schedule"
SpaceReferenceLevelParam | "Reference Level"
SpaceTypeGbxml | "Space Type (gbXML)"
SpaceVolume | "Volume"
SpaceZoneName | "Zone"
SpacingAppend | "Append Position"
SpacingJustification | "Justification"
SpacingJustificationHoriz | "Justification"
SpacingJustificationn1 | "Justification"
SpacingJustificationn2 | "Justification"
SpacingJustificationU | "Justification"
SpacingJustificationV | "Justification"
SpacingJustificationVert | "Justification"
SpacingLayout | "Layout"
SpacingLayoutHoriz | "Layout"
SpacingLayoutn1 | "Layout"
SpacingLayoutn2 | "Layout"
SpacingLayoutU | "Layout"
SpacingLayoutV | "Layout"
SpacingLayoutVert | "Layout"
SpacingLength | "Spacing"
SpacingLengthHoriz | "Spacing"
SpacingLengthn1 | "Spacing"
SpacingLengthn2 | "Spacing"
SpacingLengthU | "Distance"
SpacingLengthV | "Distance"
SpacingLengthVert | "Spacing"
SpacingNumDivisions | "Number"
SpacingNumDivisionsHoriz | "Number"
SpacingNumDivisionsn1 | "Number"
SpacingNumDivisionsn2 | "Number"
SpacingNumDivisionsU | "Number"
SpacingNumDivisionsV | "Number"
SpacingNumDivisionsVert | "Number"
SpanDirInstParamAngle | "Span Direction"
SpanDirSymParamBottom | "Bottom"
SpanDirSymParamLeft | "Left"
SpanDirSymParamRight | "Right"
SpanDirSymParamTop | "Top"
SpatialFieldMgrCurrentName | "Analysis Configuration"
SpatialFieldMgrDescription | "Description"
SpatialFieldMgrLegendHeight | "Legend Height"
SpatialFieldMgrLegendHorOriginGap | "Legend Horizontal Origin Gap"
SpatialFieldMgrLegendShowConfigName | "Show Configuration Name"
SpatialFieldMgrLegendShowDescription | "Show Description"
SpatialFieldMgrLegendTextType | "Overall Legend Text"
SpatialFieldMgrLegendVertOriginGap | "Legend Vertical Origin Gap"
SpatialFieldMgrLegendWidth | "Legend Width"
SpatialFieldMgrRange | "Data Range"
SpatialFieldMgrResultsVisibility | "Results Visibility"
SpecifySlopeOrOffset | "Specify "
SpliceByRulesMaxLength | "Maximum bar length"
SpliceByRulesMinLength | "Minimum bar length"
SpliceByRulesRunout | "Runout"
SpliceLapLengthAtEnd | "Lap Length at End"
SpliceLapLengthAtStart | "Lap Length at Start"
SpliceTypeAtEnd | "Splice at End"
SpliceTypeAtStart | "Splice at Start"
SpotCoordinateBase | "Coordinate Base"
SpotCoordinateBottomPrefix | "Bottom Coordinate Prefix"
SpotCoordinateBottomSuffix | "Bottom Coordinate Suffix"
SpotCoordinateElevationPrefix | "Elevation Prefix"
SpotCoordinateElevationSuffix | "Elevation Suffix"
SpotCoordinateIncludeElevation | "Include Elevation"
SpotCoordinateTopPrefix | "Top Coordinate Prefix"
SpotCoordinateTopSuffix | "Top Coordinate Suffix"
SpotDimLeader | "Leader"
SpotDimLeaderLine | "Leader Line"
SpotDimStyleSlopeUnits | "Units Format"
SpotDimStyleSlopeUnitsAlt | "Alternate Units Format"
SpotElevBase | "Elevation Base"
SpotElevBendLeader | "Leader Shoulder"
SpotElevBotValue | "Bottom Coordinate"
SpotElevDisplayElevations | "Display Elevations"
SpotElevFlipTextVert | "Auto Mirror"
SpotElevIndBottom | "Bottom Indicator"
SpotElevIndElevation | "Elevation Indicator"
SpotElevIndEw | "East / West Indicator"
SpotElevIndNs | "North / South Indicator"
SpotElevIndTop | "Top Indicator"
SpotElevIndType | "Indicator as Prefix / Suffix"
SpotElevIndTypeBottom | "Bottom Indicator as Prefix/Suffix"
SpotElevIndTypeElevation | "Elevation Indicator as Prefix/Suffix"
SpotElevIndTypeTop | "Top Indicator as Prefix/Suffix"
SpotElevLeaderArrowhead | "Leader Arrowhead"
SpotElevLinePen | "Leader Line Weight"
SpotElevLowerPrefix | "Lower Value Prefix"
SpotElevLowerSuffix | "Lower Value Suffix"
SpotElevLowerValue | "Lower Value"
SpotElevRelativeBase | "Relative Base"
SpotElevRotateWithComponent | "Rotate with Component"
SpotElevSingleOrUpperPrefix | "Single/Upper Value Prefix"
SpotElevSingleOrUpperSuffix | "Single/Upper Value Suffix"
SpotElevSingleOrUpperValue | "Single/Upper Value"
SpotElevSymbol | "Symbol"
SpotElevTextHorizOffset | "Text Offset from Symbol"
SpotElevTextLocation | "Text Location"
SpotElevTextOrientation | "Text Orientation"
SpotElevTickMarkPen | "Leader Arrowhead Line Weight"
SpotElevTopValue | "Top Coordinate"
SpotSlopeLeaderLength | "Leader Line Length"
SpotSlopeOffsetFromReference | "Offset from Reference"
SpotSlopePrefix | "Prefix"
SpotSlopeSlopeDirection | "Slope Direction"
SpotSlopeSlopeRepresentation | "Slope Representation"
SpotSlopeSuffix | "Suffix"
SpotTextFromLeader | "Text Offset from Leader"
SsePointBasetypeEnum | "Point Base Type"
SsePointElevation | "Elevation"
SsePointElevationBaseType | "Elevation Base Type"
SsePointOffsetFromSnaps | "Offset from Snaps"
SsePointOffsetFromSurface | "Offset from Surface"
StairsActualNumberOfRisers | "Actual Number of Risers": The total number of actually created risers in model
StairsActualNumRisers | "Actual Number of Risers"
StairsActualRiserHeight | "Actual Riser Height"
StairsActualTreadDepth | "Actual Tread Depth"
StairsAttrBodyMaterial | "Monolithic Material"
StairsAttrBreakSymInCutline | "Break Symbol in Plan"
StairsAttrCalcEnabled | "Calculation Rules"
StairsAttrCalcMax | "Calculation Rules"
StairsAttrCalcMin | "Calculation Rules"
StairsAttrEqResult | "Calculation Rules"
StairsAttrFirstRiser | "Begin with Riser"
StairsAttrLandingCarriage | "Landing Carriage Height"
StairsAttrLandingsOverlapping | "Landing Overlap"
StairsAttrLastRiser | "End with Riser"
StairsAttrLeftSideStringer | "Left Stringer"
StairsAttrMaxRiserHeight | "Maximum Riser Height"
StairsAttrMinimumTreadDepth | "Minimum Tread Depth"
StairsAttrMonolithicStairs | "Monolithic Stairs"
StairsAttrNosingLength | "Nosing Length"
StairsAttrNosingPlacement | "Apply Nosing Profile"
StairsAttrNumMidStringers | "Middle Stringers"
StairsAttrRightSideStringer | "Right Stringer"
StairsAttrRiserAngle | "Riser Angle"
StairsAttrRiserMaterial | "Riser Material"
StairsAttrRiserMult | "Riser Multiplier"
StairsAttrRisersPresent | "Risers Present"
StairsAttrRiserThickness | "Riser Thickness"
StairsAttrRiserTreadConnect | "Riser to Tread Connection"
StairsAttrRiserType | "Riser Type"
StairsAttrSideStringerTypeParam | "Type of Side Stringers"
StairsAttrStairCalculator | "Calculation Rules"
StairsAttrStairsBottom | "Underside of Winder"
StairsAttrStairsCutOffset | "Extend Below Base"
StairsAttrStringerCarriage | "Stringer Carriage Height"
StairsAttrStringerHeight | "Stringer Height"
StairsAttrStringerMaterial | "Stringer Material"
StairsAttrStringerOffset | "Open Stringer Offset"
StairsAttrStringerThickness | "Stringer Thickness"
StairsAttrTextFont | "Text Font"
StairsAttrTextSize | "Text Size"
StairsAttrTreadFrontProfile | "Nosing Profile"
StairsAttrTreadMaterial | "Tread Material"
StairsAttrTreadMult | "Tread Multiplier"
StairsAttrTreadThickness | "Tread Thickness"
StairsAttrTreadWidth | "Width"
StairsAttrTrimTop | "Trim Stringers at Top"
StairsBaseLevel | "Base Level": The base level of stairs
StairsBaseLevelParam | "Base Level"
StairsBaseOffset | "Base Offset"
StairsCurveType | "Stairs Line Type"
StairsDbgShowAnnotationCutMark | "Cut by Cut Plane"
StairsDbgShowBoundary2d | "Show Stairs' Boundary 2D"
StairsDbgShowBoundary3d | "Show Stairs' Boundary 3D"
StairsDbgShowLandingBoundary | "Show Landing Boundary"
StairsDbgShowLandingFaces | "Show Landing Faces"
StairsDbgShowLandingPath | "Show Landing Path"
StairsDbgShowLeftRunBoundary2d | "Show Run's Left Boundary 2D"
StairsDbgShowLeftRunBoundary3d | "Show Run's Left Boundary 3D"
StairsDbgShowMonolithicSupportCorseGeom | "Show Monolithic Support Corse Geometry"
StairsDbgShowMonolithicSupportGeom | "Show Monolithic Support Geometry"
StairsDbgShowRightRunBoundary2d | "Show Run's Right Boundary 2D"
StairsDbgShowRightRunBoundary3d | "Show Run's Right Boundary 3D"
StairsDbgShowRunCorseGeom | "Show Run Corse Geometry"
StairsDbgShowRunGeom | "Show Run Geometry"
StairsDbgShowRunNosing | "Show Run's Nosings"
StairsDbgShowRunOutlineForPlan | "Show Run Outline For Plan"
StairsDbgShowRunPath2d | "Show Run's Path 2D"
StairsDbgShowRunPath3d | "Show Run's Path 3D"
StairsDbgShowRunRiser | "Show Run's Risers"
StairsDbgShowSupportPath | "Show Support Path"
StairsDbgShowTreadFaces | "Show Run's Tread Faces"
StairsDbgShowTriserCorseGeom | "Show Triser Corse Geometry"
StairsDbgShowTriserGeom | "Show Triser Geometry"
StairsDesiredNumberOfRisers | "Desired Number of Risers": The number of risers is calculated based on stairs height
StairsDesiredNumRisers | "Desired Number of Risers"
StairsDownText | "Down Text"
StairsEnableCalculationRuleChecking | "Enable Calculator Rules Check": Enable calculation rule checking
StairsInstAlwaysUp | "Show Up arrow in all views"
StairsInstDownArrowOn | "Down arrow"
StairsInstDownLabelOn | "Down label"
StairsInstDownLabelText | "Down text"
StairsInstUpArrowOn | "Up arrow"
StairsInstUpLabelOn | "Up label"
StairsInstUpLabelText | "Up text"
StairsLandingBaseElevation | "Relative Height": Height
StairsLandingOverridden | "Overridden": Overridden
StairsLandingStructural | "Structural": Structural
StairsLandingThickness | "Total Thickness": Thickness
StairsLandingtypeHasMonolithicSupport | "Monolithic Support": Monolithic Support
StairsLandingtypeLandingMaterial | "Monolithic Material": Landing Material
StairsLandingtypeStructure | "Structure": Structure
StairsLandingtypeThickness | "Monolithic Thickness": Default thickness
StairsLandingtypeTreadriserType | "Type": Tread/Riser Type
StairsLandingtypeUseSameTriserAsRun | "Same as Run": Same as Run
StairsMinAutomaticLandingDepth | "Minimum Automatic Landing Depth": The minimum depth of automatic landing
StairsMultistoryTopLevelParam | "Multistory Top Level"
StairsMultistoryUpToLevel | "Multistory Top Level": The top level of multi-story stairs
StairsPathFullStepArrow | "Full Step Arrow"
StairsPathStartExtension | "Start Extension"
StairsPathStartFromRiser | "Start from Riser"
StairsRailingAngledConnection | "Angled Joins"
StairsRailingBalusterBottomAngle | "Bottom Cut Angle"
StairsRailingBalusterFamily | "Baluster Family"
StairsRailingBalusterHeight | "Baluster Height"
StairsRailingBalusterIsPost | "Post"
StairsRailingBalusterLength | "Baluster Length"
StairsRailingBalusterOffset | "Baluster Offset"
StairsRailingBalusterPlacement | "Baluster Placement"
StairsRailingBalusterShape | "Baluster Shape"
StairsRailingBalusterSlopeAngle | "Slope Angle"
StairsRailingBalusterSpacing | "Baluster Separation"
StairsRailingBalusterSpacingType | "Baluster Spacing Type (Stair Railing Only)"
StairsRailingBalustersPerTread | "Balusters Per Tread (Stair Railing Only)"
StairsRailingBalusterTopAngle | "Top Cut Angle"
StairsRailingBalusterWidth | "Baluster Width"
StairsRailingBaseLevelParam | "Base Level"
StairsRailingConnection | "Rail Connections"
StairsRailingHeight | "Railing Height"
StairsRailingHeightOffset | "Base Offset"
StairsRailingHeightShiftType | "Use Landing Height Adjustment"
StairsRailingHeightShiftVal | "Landing Height Adjustment"
StairsRailingPlacementOffset | "Offset from Path"
StairsRailingRailHeight | "Rail Height"
StairsRailingRailName | "Name"
StairsRailingRailOffset | "Rail Offset"
StairsRailingRailStructure | "Rail Structure (Non-Continuous)"
StairsRailingShape | "Rail Shape"
StairsRailingTangentConnection | "Tangent Joins"
StairsRailingThickness | "Railing Thickness"
StairsRailingWidth | "Railing Width"
StairsRunActualNumberOfRisers | "Actual Number of Risers": Actual Number of Risers
StairsRunActualNumberOfTreads | "Actual Number of Treads": Actual Number of Treads
StairsRunActualRiserHeight | "Actual Riser Height": Actual Riser Height
StairsRunActualRunWidth | "Actual Run Width": Actual Run Width
StairsRunActualTreadDepth | "Actual Tread Depth": Actual Tread Depth
StairsRunBeginWithRiser | "Begin with Riser": Begin with Riser
StairsRunBottomElevation | "Relative Base Height": Relative height to stairs bottom elevation
StairsRunCcw | "CCW": Revert the run preview
StairsRunCenterMarkVisible | "Center Mark Visible": Center Mark Visible
StairsRunCreateAutoLanding | "With Automatic Landing": Create automatic landing
StairsRunEndWithRiser | "End with Riser": End with Riser
StairsRunExtendBelowRiserBase | "Extend Below Riser Base": Extend Below Base
StairsRunExtendBelowTreadBase | "Extend Below Tread Base": Extend Below Tread Base
StairsRunHeight | "Run Height": Run Height
StairsRunLocationpathJustfication | "Location Line": Location Line
StairsRunOverridden | "Overridden": Overridden
StairsRunStructural | "Structural": Structural
StairsRunTopElevation | "Relative Top Height": Top height of run
StairsRuntypeHasMonolithicSupport | "Monolithic Support": Monolithic Support
StairsRuntypeRunMaterial | "Monolithic Material": Material
StairsRuntypeStructuralDepth | "Structural Depth": Structural Depth
StairsRuntypeStructure | "Structure": Structure
StairsRuntypeTotalDepth | "Total Depth": Total Depth
StairsRuntypeUndersideSurfaceType | "Underside Surface": Underside Surface
StairsRunWidthMeasurement | "Run Width Measurement": Run Width Measurement
StairsRunWinderBeginWithStraight | "Begin with Straight Run": Winder begin with straight run
StairsRunWinderEndWithStraight | "End with Straight Run": Winder end with straight run
StairsShowDownText | "Show Down Text"
StairsShowUpText | "Show Up Text"
StairsStairsHeight | "Desired Stair Height": Stairs unconnected height
StairsStringersPresent | "Stringer Position"
StairsSupportHorizontalOffset | "Lateral Offset": Distance from center or edge of boundary
StairsSupportLandingsupportType | "Landing Support Type": Landing Support Type
StairsSupportLowerEndCut | "Lower End Cut": Lower End Cut
StairsSupportOverridden | "Overridden": Overridden
StairsSupportTrimSupportUpper | "Trim Support at Upper": Trim Support at Upper
StairsSupporttypeFlipSectionProfile | "Flip Section Profile": Flip Section Profile
StairsSupporttypeMaterial | "Material": Material
StairsSupporttypeSectionProfile | "Section Profile": Section Profile
StairsSupporttypeStructuralDepth | "Structural Depth": Structural Depth
StairsSupporttypeStructuralDepthOnLanding | "Structural Depth On Landing": Structural Depth
StairsSupporttypeStructuralDepthOnRun | "Structural Depth On Run": Structural Depth
StairsSupporttypeTopsideSurface | "Topside Surface": Topside Surface
StairsSupporttypeTotalDepth | "Total Depth": Total Depth
StairsSupporttypeUndersideSurface | "Underside Surface": Underside Surface
StairsSupporttypeWidth | "Width": Width
StairsSupportUpperEndCut | "Upper End Cut": Upper End Cut
StairsSupportVerticalOffset | "Vertical Offset": Distance of top plane of edge stringer relative to the plane connecting tread nosing
StairsTextOrientation | "Orientation"
StairsTextType | "Text Type"
StairsTopLevel | "Top Level": The top level of stairs
StairsTopLevelParam | "Top Level"
StairsTopOffset | "Top Offset"
StairsTotalNumberOfRisers | "Total Number of Risers": Total number of risers
StairsTotalNumberOfTreads | "Total Number of Treads": Total number of treads
StairsTriserIsTypeOverridden | "Overridden": (OBSOLETE) Indicate whether selected individual step is governed by default type setting.
StairsTriserNumberBaseIndex | "Tread/Riser Start Number":
StairsTriserRiserMark | "Riser Mark": (OBSOLETE)
StairsTriserRiserNumber | "Riser Number": Count the sequential number of riser in the stair.
StairsTriserTreadMark | "Tread Mark": (OBSOLETE)
StairsTriserTreadNumber | "Tread Number": Count the sequential number of tread in the stair.
StairsTrisertypeBackNosing | "Back Nosing": (OBSOLETE)
StairsTrisertypeFrontNosing | "Front Nosing": (OBSOLETE)
StairsTrisertypeLeftNosing | "Left Nosing": (OBSOLETE)
StairsTrisertypeNosingLength | "Nosing Length"
StairsTrisertypeNosingPlacement | "Apply Nosing Profile"
StairsTrisertypeNosingProfile | "Nosing Profile"
StairsTrisertypeRightNosing | "Right Nosing": (OBSOLETE)
StairsTrisertypeRiser | "Riser"
StairsTrisertypeRiserIsSlanted | "Slanted"
StairsTrisertypeRiserMaterial | "Riser Material"
StairsTrisertypeRiserProfile | "Riser Profile"
StairsTrisertypeRiserStyle | "Riser Type": (OBSOLETE)
StairsTrisertypeRiserThickness | "Riser Thickness"
StairsTrisertypeRiserTreadConnection | "Riser To Tread Connection"
StairsTrisertypeTread | "Tread"
StairsTrisertypeTreadMaterial | "Tread Material"
StairsTrisertypeTreadProfile | "Tread Profile"
StairsTrisertypeTreadThickness | "Tread Thickness"
StairstypeCalcRuleMaxResult | "Max. Result": Calculation Rule Max Result
StairstypeCalcRuleMinResult | "Min. Result": Calculation Rule Min Result
StairstypeCalcRuleRiserMultiplier | "Riser Multiplier": Calculation Rule Riser Multiplier
StairstypeCalcRuleTargetResult | "Target Result": Calculation Rule Target Result
StairstypeCalcRuleTreadMultiplier | "Tread Multiplier": Calculation Rule Tread Multiplier
StairstypeCalculationRules | "Calculation Rules": Calculation Rules
StairstypeConstructionMethod | "Construction Method":
StairstypeCutmarkType | "Cut Mark Type": Cut Mark Type
StairstypeGeomunjoinedEndCutStyle | "Connection Method": Cut Style for Geometrically Unjoined End
StairstypeHasIntermediateSupport | "Middle Support": Whether stairs is assembled
StairstypeHasLeftSupport | "Left Support":
StairstypeHasRightSupport | "Right Support":
StairstypeIntermediateSupportType | "Middle Support Type": Intermediate Support Type
StairstypeIsAssembledStairs | "Assembled Stair": Whether stairs is assembled
StairstypeLandingType | "Landing Type": Landing Type
StairstypeLeftSideSupportType | "Left Support Type": Left Side Support Type
StairstypeLeftSupportLateralOffset | "Left Lateral Offset":
StairstypeMaximumRiserHeight | "Max. Riser Height": Maximum Riser Height
StairstypeMinimumRunWidth | "Minimum Run Width": Minimum Run Width
StairstypeMinimumTreadDepth | "Min. Tread Depth": Minimum Tread Depth
StairstypeMinimumTreadWidthInsideBoundary | "Min. Tread Depth on Winder Inner Boundary": Minimum Tread Width on Inside Boundary
StairstypeNotchCustomWidth | "Custom":
StairstypeNotchExtension | "Notch Extension":
StairstypeNotchHorizontalGap | "Horizontal Gap Distance":
StairstypeNotchThickness | "Notch Thickness":
StairstypeNotchVerticalGap | "Vertical Gap Distance":
StairstypeNotchWidth | "Notch Width":
StairstypeNumberOfIntermediateSupports | "Middle Support Number": Number of intermediate supports
StairstypeRightSideSupportType | "Right Support Type": Right Side Support Type
StairstypeRightSupportLateralOffset | "Right Lateral Offset":
StairstypeRunType | "Run Type": Run Type
StairstypeShowCutline | "Show Cut Line in Plan": Show Cut Line in Plan
StairstypeShowStairPath | "Show Stair Path in Plan": Show Stair Path in Plan
StairstypeShowUpdown | "Show Up/Down in Plan": Show Up/Down in Plan
StairstypeWinderStepFrontMeasurement | "Winder Algorithm": Winder Algorithm
StairsUpText | "Up Text"
StairsWinderpatternFilletInsideCorner | "Fillet on Corner": Fillet on inside corner
StairsWinderpatternMinimumWidthCorner | "Minimum Width on Inside Boundary": Minimum Width on Inside Boundary
StairsWinderpatternMinimumWidthInsideWalkline | "Minimum Width on Inside Walk Line": Minimum width on inside walkline
StairsWinderpatternNumberOfStraightStepsAtBegin | "Parallel Treads at Start": Number of straight steps at the begin of winder
StairsWinderpatternNumberOfStraightStepsAtEnd | "Parallel Treads at End": Number of straight steps at the begin of winder
StairsWinderpatternRadiusInterior | "Fillet Radius": The fillet corner radius on the interior boundary
StairsWinderpatternStairPathOffset | "Inside Walk Line Offset": The offset from inside walk line to interior boundary
StairsWinderpatternWinderStyle | "Winder Style": Winder Style
StartExtension | "Start Extension"
StartJoinCutback | "Start Join Cutback"
StartSymbolType | "Start Symbol Type"
StartYJustification | "Start y Justification"
StartYOffsetValue | "Start y Offset Value"
StartZJustification | "Start z Justification"
StartZOffsetValue | "Start z Offset Value"
SteelElemAnchorAssembly | "Assembly"
SteelElemAnchorDiameter | "Diameter"
SteelElemAnchorGrade | "Grade"
SteelElemAnchorLength | "Length"
SteelElemAnchorOrientation | "Anchor Orientation"
SteelElemAnchorStandard | "Standard"
SteelElemAnchorTotalWeight | "Total Weight"
SteelElemBoltAssembly | "Assembly"
SteelElemBoltCoating | "Coating"
SteelElemBoltDiameter | "Diameter"
SteelElemBoltFinishCalculationAtGap | "Finish Calculation At Gap"
SteelElemBoltGrade | "Grade"
SteelElemBoltGripLength | "Grip Length"
SteelElemBoltGripLengthIncrease | "Grip Length Increase"
SteelElemBoltInverted | "Inverted"
SteelElemBoltLength | "Bolt Length"
SteelElemBoltLocation | "Location"
SteelElemBoltStandard | "Standard"
SteelElemBoltTotalWeight | "Total Weight"
SteelElemCoating | "Coating"
SteelElemContourGapWidth | "Gap Width"
SteelElemContourSide1dist | "Boundary distance 1"
SteelElemContourSide2dist | "Boundary distance 2"
SteelElemCopeAroundAxis | "Around beam axis"
SteelElemCopeAxisAngle | "Tilt angle"
SteelElemCopeDistanceAxis | "Distance from axis"
SteelElemCopeWidthx | "Cutback"
SteelElemCopeXAngle | "Cross-section rotation"
SteelElemCopeZAngle | "Plan rotation"
SteelElemCutLength | "Cut Length"
SteelElemCutType | "Type"
SteelElemExactWeight | "Exact Weight"
SteelElemHoleAlpha | "Taper Angle"
SteelElemHoleAngle | "Chamfer angle"
SteelElemHoleBackTaperThread | "Back taper thread"
SteelElemHoleDefinition | "Hole Definition"
SteelElemHoleDepth | "Hole Depth"
SteelElemHoleDepthOfBoltHead | "Depth of bolt head"
SteelElemHoleDiameter | "Diameter"
SteelElemHoleHeadDiameter | "Head diameter"
SteelElemHoleSlotDirection | "Along side 1"
SteelElemHoleSlotLength | "Length of the slot"
SteelElemHoleTapping | "Right-handed thread"
SteelElemHoleTappingHole | "Tapping hole"
SteelElemHoleType | "Type"
SteelElemMark | "Assembly Mark"
SteelElemPaintArea | "Paint Area"
SteelElemParamBoringout | "Boring out"
SteelElemParamRadius | "Radius"
SteelElemPatternEdgeDistanceX | "Edge distance on side 1"
SteelElemPatternEdgeDistanceY | "Edge distance on side 2"
SteelElemPatternIntermediateDistanceX | "Intermediate distance on side 1"
SteelElemPatternIntermediateDistanceY | "Intermediate distance on side 2"
SteelElemPatternNumber | "Number"
SteelElemPatternNumberX | "Number on side 1"
SteelElemPatternNumberY | "Number on side 2"
SteelElemPatternRadius | "Radius"
SteelElemPatternTotalLength | "Length on side 1"
SteelElemPatternTotalWidth | "Length on side 2"
SteelElemPlateArea | "Area"
SteelElemPlateExactWeight | "Exact Weight"
SteelElemPlateJustification | "Justification"
SteelElemPlateLength | "Length"
SteelElemPlatePaintArea | "Paint Area"
SteelElemPlateShortenAngle | "Angle"
SteelElemPlateShortenCutstraight | "Cut straight"
SteelElemPlateShortenSuction | "Suction"
SteelElemPlateThickness | "Thickness"
SteelElemPlateType | "Type"
SteelElemPlateVolume | "Volume"
SteelElemPlateWeight | "Weight"
SteelElemPlateWidth | "Width"
SteelElemProfileLength | "Length"
SteelElemProfileType | "Profile Type"
SteelElemProfileVolume | "Volume"
SteelElemShearstudDiameter | "Diameter"
SteelElemShearstudGrade | "Grade"
SteelElemShearstudLength | "Length"
SteelElemShearstudStandard | "Standard"
SteelElemShearstudTotalWeight | "Total Weight"
SteelElemShortenAngley | "Angle along height"
SteelElemShortenAnglez | "Angle along width"
SteelElemShortenReflength | "Length"
SteelElemSinglePartMark | "Single Part Mark"
SteelElemWeight | "Weight"
SteelElemWeldContinuous | "Continuous"
SteelElemWeldDoubleEffectivethroat | "Double Effective Throat"
SteelElemWeldDoublePrepdepth | "Double Preparation Depth"
SteelElemWeldDoubleRootopening | "Double Root Opening"
SteelElemWeldDoubleSurfaceshape | "Double Surface Shape"
SteelElemWeldDoubleText | "Double Text"
SteelElemWeldDoubleThickness | "Double Thickness"
SteelElemWeldDoubleType | "Double Type"
SteelElemWeldDoubleWeldprep | "Double Weld preparation"
SteelElemWeldLength | "Length"
SteelElemWeldLocation | "Location"
SteelElemWeldMainEffectivethroat | "Main Effective Throat"
SteelElemWeldMainPrepdepth | "Main Preparation Depth"
SteelElemWeldMainRootopening | "Main Root Opening"
SteelElemWeldMainSurfaceshape | "Surface Shape"
SteelElemWeldMainText | "Main Text"
SteelElemWeldMainThickness | "Main Thickness"
SteelElemWeldMainType | "Main Type"
SteelElemWeldMainWeldprep | "Main Weld preparation"
SteelElemWeldPitch | "Pitch"
SteelElemWeldPrefix | "Prefix"
SteelElemWeldTextModule | "Text module"
SteelElemXDistance | "Side 1"
SteelElemYDistance | "Side 2"
SteelElemZclipType | "Boundary"
StiffenerClassification | "Classification"
StructConnectionApplyTo | "Apply to"
StructConnectionBeamEnd | "End Connection"
StructConnectionBeamStart | "Start Connection"
StructConnectionColumnBase | "Base Connection"
StructConnectionColumnTop | "Top Connection"
StructConnectionCutback | "Automatic Cutback for Beams and Braces"
StructConnectionTypeName | "Name"
StructFramJoinStatus | "Join Status"
StructuralAnalyticalBeamHorizontalProjectionPlane | "Horizontal Projection"
StructuralAnalyticalBeamRigidLink | "Analytical Links"
StructuralAnalyticalColumnHorizontalProjectionPlane | "Horizontal Projection"
StructuralAnalyticalColumnRigidLink | "Analytical Links"
StructuralAnalyticalHardPoints | "Use hard-points"
StructuralAnalyticalModel | "Enable Analytical Model"
StructuralAnalyticalProjectFloorPlane | "Vertical Projection"
StructuralAnalyticalProjectMemberPlane | "Vertical Projection"
StructuralAnalyticalProjectMemberPlaneColumnBottom | "Bottom Vertical Projection"
StructuralAnalyticalProjectMemberPlaneColumnTop | "Top Vertical Projection"
StructuralAnalyticalTessDeviation | "Maximum discretized offset"
StructuralAnalyticalTessellate | "Approximate curve"
StructuralAnalyzesAs | "Analyze As"
StructuralAssetParam | "Physical Material Asset"
StructuralAttachmentBaseDistance | "Base Attachment Distance"
StructuralAttachmentBaseRatio | "Base Attachment Ratio"
StructuralAttachmentBaseReferencedend | "Base Attachment Referenced End"
StructuralAttachmentBaseType | "Base Attachment Type"
StructuralAttachmentEndLevelReference | "End Attachment Level Reference"
StructuralAttachmentEndRefelementEnd | "End of Attachment to Reference Element"
StructuralAttachmentEndType | "End Attachment Type"
StructuralAttachmentEndValueDistance | "End Attachment Distance"
StructuralAttachmentEndValueElevation | "End Attachment Elevation"
StructuralAttachmentEndValueRatio | "End attachment ratio"
StructuralAttachmentStartLevelReference | "Start Attachment Level Reference"
StructuralAttachmentStartRefelementEnd | "Start of Attachment to Reference Element"
StructuralAttachmentStartType | "Start Attachment Type"
StructuralAttachmentStartValueDistance | "Start Attachment Distance"
StructuralAttachmentStartValueElevation | "Start Attachment Elevation"
StructuralAttachmentStartValueRatio | "Start Attachment Ratio"
StructuralAttachmentTopDistance | "Top Attachment Distance"
StructuralAttachmentTopRatio | "Top Attachment Ratio"
StructuralAttachmentTopReferencedend | "Top Attachment Referenced End"
StructuralAttachmentTopType | "Top Attachment Type"
StructuralBeamCutbackForColumn | "Beam cutback in plan"
StructuralBeamEnd0Elevation | "Start Level Offset"
StructuralBeamEnd1Elevation | "End Level Offset"
StructuralBeamEndAttachmentDistance | "End Attachment Distance"
StructuralBeamEndAttachmentRefcolumnEnd | "End of Attachment to Reference Column"
StructuralBeamEndAttachmentType | "End Attachment Type"
StructuralBeamEndSupport | "Beam End Pocket Seat"
StructuralBeamOrientation | "Orientation"
StructuralBeamStartAttachmentDistance | "Start Attachment Distance"
StructuralBeamStartAttachmentRefcolumnEnd | "Start of Attachment to Reference Column"
StructuralBeamStartAttachmentType | "Start Attachment Type"
StructuralBeamStartSupport | "Beam Start Pocket Seat"
StructuralBendDirAngle | "Cross-Section Rotation"
StructuralBottomReleaseFx | "Base Fx"
StructuralBottomReleaseFy | "Base Fy"
StructuralBottomReleaseFz | "Base Fz"
StructuralBottomReleaseMx | "Base Mx"
StructuralBottomReleaseMy | "Base My"
StructuralBottomReleaseMz | "Base Mz"
StructuralBottomReleaseType | "Base Release"
StructuralBraceRepresentation | "Representation Type"
StructuralCamber | "Camber Size"
StructuralConnectionApprovalStatus | "Approval Status"
StructuralConnectionCodeCheckingStatus | "Code Checking Status"
StructuralConnectionEditRangesOfApplicability | "Modify Ranges of applicability"
StructuralConnectionEditType | "Modify Parameters"
StructuralConnectionInputElements | "Input Elements"
StructuralConnectionModifyConnectionParameters | "Detailed Parameters"
StructuralConnectionNobleStatus | "Noble Status"
StructuralConnectionOverrideType | "Override by Instance"
StructuralConnectionSymbol | "Connection Symbol"
StructuralCopingDistance | "Coping Distance"
StructuralDisplayInHiddenViews | "Display in Hidden Views"
StructuralDisplayInHiddenViewsColumn | "Display in Hidden Views"
StructuralDisplayInHiddenViewsFraming | "Display in Hidden Views"
StructuralElevationAtBottom | "Elevation at Bottom"
StructuralElevationAtBottomCore | "Elevation at Bottom Core"
StructuralElevationAtBottomSurvey | "Elevation at Bottom Survey"
StructuralElevationAtTop | "Elevation at Top"
StructuralElevationAtTopCore | "Elevation at Top Core"
StructuralElevationAtTopSurvey | "Elevation at Top Survey"
StructuralEndReleaseFx | "End Fx"
StructuralEndReleaseFy | "End Fy"
StructuralEndReleaseFz | "End Fz"
StructuralEndReleaseMx | "End Mx"
StructuralEndReleaseMy | "End My"
StructuralEndReleaseMz | "End Mz"
StructuralEndReleaseType | "End Release"
StructuralFamilyCodeName | "Code Name"
StructuralFamilyNameKey | "Family Name Key"
StructuralFloorAnalyzesAs | "Analyze As"
StructuralFloorCoreThickness | "Core Thickness"
StructuralFoundationLength | "Length"
StructuralFoundationThickness | "Foundation Thickness"
StructuralFoundationWidth | "Width"
StructuralFrameCutLength | "Cut Length"
StructuralMaterialParam | "Structural Material"
StructuralMaterialType | "Structural Material Type"
StructuralMemberForces | "Member Forces"
StructuralNumberOfStuds | "Number of studs"
StructuralReferenceLevelElevation | "Reference Level Elevation"
StructuralSectionArea | "Section Area"
StructuralSectionBottomCutHeight | "Bottom Cut Height"
StructuralSectionBottomCutWidth | "Bottom Cut Width"
StructuralSectionCantileverHeight | "Cantilever Height"
StructuralSectionCantileverLength | "Cantilever Length"
StructuralSectionCommonAlpha | "Principal Axes Angle"
StructuralSectionCommonCentroidHoriz | "Centroid Horizontal"
StructuralSectionCommonCentroidVertical | "Centroid Vertical"
StructuralSectionCommonDiameter | "Diameter"
StructuralSectionCommonElasticModulusStrongAxis | "Elastic Modulus strong axis"
StructuralSectionCommonElasticModulusWeakAxis | "Elastic Modulus weak axis"
StructuralSectionCommonHeight | "Height"
StructuralSectionCommonMomentOfInertiaStrongAxis | "Moment of Inertia strong axis"
StructuralSectionCommonMomentOfInertiaWeakAxis | "Moment of Inertia weak axis"
StructuralSectionCommonNominalWeight | "Nominal Weight"
StructuralSectionCommonPerimeter | "Perimeter"
StructuralSectionCommonPlasticModulusStrongAxis | "Plastic Modulus strong axis"
StructuralSectionCommonPlasticModulusWeakAxis | "Plastic Modulus weak axis"
StructuralSectionCommonShearAreaStrongAxis | "Shear Area strong axis"
StructuralSectionCommonShearAreaWeakAxis | "Shear Area weak axis"
StructuralSectionCommonTorsionalModulus | "Torsional Modulus"
StructuralSectionCommonTorsionalMomentOfInertia | "Torsional Moment of Inertia"
StructuralSectionCommonWarpingConstant | "Warping Constant"
StructuralSectionCommonWidth | "Width"
StructuralSectionCprofileFoldLength | "Fold Length"
StructuralSectionHssInnerfillet | "Inner Fillet"
StructuralSectionHssOuterfillet | "Outer Fillet"
StructuralSectionIshapeBoltDiameter | "Bolt Diameter"
StructuralSectionIshapeBoltSpacing | "Bolt Spacing"
StructuralSectionIshapeBoltSpacingBetweenRows | "Bolt Spacing between Rows"
StructuralSectionIshapeBoltSpacingTwoRows | "Bolt Spacing Two Rows"
StructuralSectionIshapeBoltSpacingWeb | "Bolt Spacing web"
StructuralSectionIshapeClearWebHeight | "Clear Web Height"
StructuralSectionIshapeFlangefillet | "Flange Fillet"
StructuralSectionIshapeFlangethickness | "Flange Thickness"
StructuralSectionIshapeFlangethicknessLocation | "Flange Thickness Location"
StructuralSectionIshapeFlangeToeOfFillet | "Flange Toe of Fillet"
StructuralSectionIshapeWebfillet | "Web Fillet"
StructuralSectionIshapeWebheight | "Web Height"
StructuralSectionIshapeWebthickness | "Web Thickness"
StructuralSectionIshapeWebthicknessLocation | "Web Thickness Location"
StructuralSectionIshapeWebToeOfFillet | "Web Toe of Fillet"
StructuralSectionIweldedBottomflangethickness | "Bottom Flange Thickness"
StructuralSectionIweldedBottomflangewidth | "Bottom Flange Width"
StructuralSectionIweldedTopflangethickness | "Top Flange Thickness"
StructuralSectionIweldedTopflangewidth | "Top Flange Width"
StructuralSectionLangleBoltDiameterLongerFlange | "Bolt Diameter Longer Flange"
StructuralSectionLangleBoltDiameterShorterFlange | "Bolt Diameter Shorter Flange"
StructuralSectionLangleBoltSpacing1LongerFlange | "Bolt Spacing 1 Longer Flange"
StructuralSectionLangleBoltSpacing2LongerFlange | "Bolt Spacing 2 Longer Flange"
StructuralSectionLangleBoltSpacingShorterFlange | "Bolt Spacing Shorter Flange"
StructuralSectionLprofileLipLength | "Lip Length"
StructuralSectionNameKey | "Section Name Key"
StructuralSectionPipestandardWalldesignthickness | "Wall Design Thickness"
StructuralSectionPipestandardWallnominalthickness | "Wall Nominal Thickness"
StructuralSectionShape | "Section Shape"
StructuralSectionSigmaProfileBendWidth | "Bend Width"
StructuralSectionSigmaProfileMiddleBendWidth | "Middle Bend Length"
StructuralSectionSigmaProfileTopBendWidth | "Top Bend Length"
StructuralSectionSlopedFlangeAngle | "Sloped Flange Angle"
StructuralSectionSlopedWebAngle | "Sloped Web Angle"
StructuralSectionTopCutHeight | "Top Cut Height"
StructuralSectionTopCutWidth | "Top Cut Width"
StructuralSectionTopWebFillet | "Top Web Fillet"
StructuralSectionZprofileBottomFlangeLength | "Bottom Flange Length"
StructuralStartReleaseFx | "Start Fx"
StructuralStartReleaseFy | "Start Fy"
StructuralStartReleaseFz | "Start Fz"
StructuralStartReleaseMx | "Start Mx"
StructuralStartReleaseMy | "Start My"
StructuralStartReleaseMz | "Start Mz"
StructuralStartReleaseType | "Start Release"
StructuralStickSymbolLocation | "Stick Symbol Location"
StructuralTopReleaseFx | "Top Fx"
StructuralTopReleaseFy | "Top Fy"
StructuralTopReleaseFz | "Top Fz"
StructuralTopReleaseMx | "Top Mx"
StructuralTopReleaseMy | "Top My"
StructuralTopReleaseMz | "Top Mz"
StructuralTopReleaseType | "Top Release"
StructuralWallBottomProjectionPlane | "Bottom Vertical Projection"
StructuralWallProjectionSurface | "Horizontal Projection"
StructuralWallTopProjectionPlane | "Top Vertical Projection"
SupportHandClearance | "Hand Clearance"
SupportHeight | "Height"
SurfaceArea | "Surface Area"
SurfaceName | "Name"
SurfacePatternIdParam | "Surface fill pattern"
SurfacePerimeter | "Perimeter"
SweepBaseFloorSubcategoryId | "Subcategory of Floors"
SweepBaseOffset | "Horizontal Profile Offset"
SweepBaseRoofSubcategoryId | "Subcategory of Roofs"
SweepBaseVertOffset | "Vertical Profile Offset"
SweepMaxSegAngle | "Maximum Segment Angle"
SweepTrajSegmented | "Trajectory Segmentation"
SymbolFamilyAndTypeNamesParam | "Family and Type"
SymbolFamilyNameParam | "Family Name"
SymbolIdParam | "Type Id"
SymbolNameParam | "Type Name"
SystemEquipmentSets | "Equipment Sets"
SystemsAnalysisReportFolder | "Reports Folder Path"
SystemsAnalysisReportStyle | "Report Style"
SystemZoneLevelId | "Level"
TagAngleParam | "Angle"
TagElementCount | "Host Count"
TagElevationBase | "Elevation Base"
TagHeadAlignment | "Tag Alignment"
TagHeadPosition | "Tag Position"
TagLeaderType | "Leader Type"
TagNoBreakParamStrings | "Wrap between parameters only"
TagOnPlacementUi | "Tag on Placement"
TagOrientationBehavior | "Tag Orientation"
TagOrientationParam | "Orientation"
TagSampleText | "Sample Text"
TagTag | "Label"
TemplateName | "Template"
TerminationExtensionLength | "Extension Length"
TextAlignHorz | "Horizontal Align"
TextAlignment | "Text Alignment"
TextAlignVert | "Vertical Align"
TextBackground | "Background"
TextBoxVisibility | "Show Border"
TextColor | "Color"
TextDistToLine | "Text Offset"
TextFont | "Text Font"
TextPosition | "Text Position"
TextSize | "Text Size"
TextStyleBold | "Bold"
TextStyleFont | "Font"
TextStyleItalic | "Italic"
TextStyleSize | "Size"
TextStyleUnderline | "Underline"
TextTabSize | "Tab Size"
TextText | "Text"
TextWidthScale | "Width Factor"
ThermalMaterialConductivity | "Thermal Conductivity"
ThermalMaterialDensity | "Density"
ThermalMaterialDescription | "Description"
ThermalMaterialName | "Name"
ThermalMaterialParamCompressibility | "Compressibility"
ThermalMaterialParamElectricalResistivity | "Electrical Resistivity"
ThermalMaterialParamEmissivity | "Emissivity"
ThermalMaterialParamGasViscosity | "Gas Viscosity"
ThermalMaterialParamLiquidViscosity | "Liquid Viscosity"
ThermalMaterialParamPermeability | "Permeability"
ThermalMaterialParamPorosity | "Porosity"
ThermalMaterialParamReflectivity | "Reflectivity"
ThermalMaterialParamSpecificHeatOfVaporization | "Specific Heat of Vaporization"
ThermalMaterialParamTransmitsLight | "Transmits Light"
ThermalMaterialParamVaporPressure | "Vapor Pressure"
ThermalMaterialSpecificHeatCapacity | "Specific Heat Capacity"
ThermalMaterialThickness | "Thickness"
TickMarkPen | "Tick Mark Line Weight"
TilePatternFamrefComponentExtents | "Component Extents"
TilePatternGridCellsX | "Number of horizontal cells"
TilePatternGridCellsY | "Number of vertical cells"
TilePatternGridUnitX | "Horizontal spacing"
TilePatternGridUnitY | "Vertical spacing"
Tilt | "Tilt"
TitleFont | "Font"
TitleSize | "Size"
TitleStyleBold | "Bold"
TitleStyleItalic | "Italic"
TitleStyleUnderline | "Underline"
TopographyLinkName | "Link Name"
TopographyLinkPath | "Saved Path"
ToposolidAttrThicknessParam | "Thickness"
ToposolidContourDisplaySettingsIdParam | "Contour Display"
ToposolidContourSubcategoryId | "Subcategory"
ToposolidElevationAtBottom | "Elevation at Bottom"
ToposolidElevationAtTop | "Elevation at Top"
ToposolidFacesLocation | "Picked Faces Location"
ToposolidFunctionParam | "Function"
ToposolidHeightabovelevelParam | "Height Offset From Level"
ToposolidInheritContours | "Inherit Contours"
ToposolidStructureIdParam | "Structure"
ToposolidSubdivideHeight | "Sub-divide Height"
ToposolidSubdivideMaterial | "Material"
ToposolidTypeDefaultThicknessParam | "Default Thickness"
ToposurfaceContourSubcategoryId | "Subcategory"
TotalExcavationVolume | "Total Excavation Volume"
TrapMullWidth | "Center Width"
TrussBearingChordTopBottomParam | "Bearing Chord"
TrussElementAngleParam | "Rotation Angle"
TrussElementBearingJustParam | "Bearing Vertical Justification"
TrussElementClassParam | "Engineering Type"
TrussElementCreateBottomParam | "Create Bottom Chord"
TrussElementCreateTopParam | "Create Top Chord"
TrussElementEnd0Elevation | "Start Level Offset"
TrussElementEnd1Elevation | "End Level Offset"
TrussElementReferenceLevelParam | "Reference Level"
TrussElementRotateChordsWithTruss | "Rotate Chords With Truss"
TrussElementSpanParam | "Span"
TrussElementStickJustParam | "Stick Symbol Location"
TrussElementTagNewMembersView | "Tag new members in view"
TrussFamilyBottomChordAngleParam | "Angle"
TrussFamilyBottomChordEndReleaseType | "End Release"
TrussFamilyBottomChordStartReleaseType | "Start Release"
TrussFamilyBottomChordStructuralTypesParam | "Structural Framing Type"
TrussFamilyBottomChordVerticalProjectionParam | "Analytical Vertical Projection"
TrussFamilyDiagWebAngleParam | "Angle"
TrussFamilyDiagWebEndReleaseType | "End Release"
TrussFamilyDiagWebStartReleaseType | "Start Release"
TrussFamilyDiagWebStructuralTypesParam | "Structural Framing Type"
TrussFamilyTopChordAngleParam | "Angle"
TrussFamilyTopChordEndReleaseType | "End Release"
TrussFamilyTopChordStartReleaseType | "Start Release"
TrussFamilyTopChordStructuralTypesParam | "Structural Framing Type"
TrussFamilyTopChordVerticalProjectionParam | "Analytical Vertical Projection"
TrussFamilyTransformationParam | "Web Orientation"
TrussFamilyVertWebAngleParam | "Angle"
TrussFamilyVertWebEndReleaseType | "End Release"
TrussFamilyVertWebStartReleaseType | "Start Release"
TrussFamilyVertWebStructuralTypesParam | "Structural Framing Type"
TrussFamilyWebsHaveSymbolicCutbackParam | "Webs have symbolic cutback"
TrussHeight | "Truss Height"
TrussLength | "Truss Length"
TrussNonBearingOffsetParam | "Non Bearing Offset"
TypeWallClosure | "Wall Closure"
UniformatCode | "Assembly Code"
UniformatDescription | "Assembly Description"
Use3dSnapping | "3D Snapping"
UsingMultiple | "Multiple Join"
ViewAnalysisDisplayStyle | "Default Analysis Display Style"
ViewAnalysisResultsVisibility | "Analysis Display Settings"
ViewAssociatedAssemblyInstanceId | "Associated Assembly Instance"
ViewBackClipping | "Depth Clipping"
ViewCameraOrientation | "Locked Orientation"
ViewCameraPosition | "Camera Position"
ViewCleanJoins | "Wall Join Display"
ViewDependency | "Dependency"
ViewDepth | "View Depth"
ViewDescription | "Title on Sheet"
ViewDesignOptionsConfig | "Design Option Configuration"
ViewDetailLevel | "Detail Level"
ViewDiscipline | "Discipline"
Viewer3dRenderSettings | "Rendering Settings"
ViewerAnnotationCropActive | "Annotation Crop"
ViewerBoundActiveBottom | "Bottom Clip Active"
ViewerBoundActiveFar | "Far Clip Active"
ViewerBoundActiveLeft | "Left Clip Active"
ViewerBoundActiveNear | "Near Clip Active"
ViewerBoundActiveRight | "Right Clip Active"
ViewerBoundActiveTop | "Top Clip Active"
ViewerBoundFarClipping | "Far Clipping"
ViewerBoundOffsetBottom | "Bottom Clip Offset"
ViewerBoundOffsetFar | "Far Clip Offset"
ViewerBoundOffsetLeft | "Left Clip Offset"
ViewerBoundOffsetNear | "Near Clip Offset"
ViewerBoundOffsetRight | "Right Clip Offset"
ViewerBoundOffsetTop | "Top Clip Offset"
ViewerCropRegion | "Crop View"
ViewerCropRegionDisabled | "Crop View"
ViewerCropRegionVisible | "Crop Region Visible"
ViewerDetailNumber | "Detail Number"
ViewerEyeElevation | "Eye Elevation"
ViewerIsReference | "Is a Reference"
ViewerModelClipBoxActive | "Section Box"
ViewerOptionVisibility | "Visible In Option"
ViewerPerspective | "Projection Mode"
ViewerReferenceLabel | "Reference Label"
ViewerReferenceLabelText | "Reference Label"
ViewerSheetCollection | "Sheet Collection"
ViewerSheetName | "Sheet Name"
ViewerSheetNumber | "Sheet Number"
ViewerShowUncropped | "Show uncropped"
ViewerTargetElevation | "Target Elevation"
ViewerVolumeOfInterestCrop | "Scope Box"
ViewFamily | "Family"
ViewFamilyAndTypeSchedules | "Family and Type"
ViewFamilySchedules | "Family"
ViewFixedSketchPlane | "None"
ViewGraphSchedBottomLevel | "Bottom Level"
ViewGraphSchedGridAppearance | "Grid Appearance"
ViewGraphSchedGroupSimilar | "Group Similar Locations"
ViewGraphSchedHiddenLevels | "Hidden Levels"
ViewGraphSchedLevelRelativeBaseType | "Elevation Base for Levels"
ViewGraphSchedLocationsHigh | "Column Locations End"
ViewGraphSchedLocationsLow | "Column Locations Start"
ViewGraphSchedMaterialTypes | "Material Types"
ViewGraphSchedNumberColumns | "Column Locations per Segment"
ViewGraphSchedOffGrid | "Include Off-Grid Columns"
ViewGraphSchedRowsCount | "Segments in Viewport"
ViewGraphSchedRowsFrom | "Segment Start in Viewport"
ViewGraphSchedTextAppearance | "Text Appearance"
ViewGraphSchedTitle | "Title"
ViewGraphSchedTopLevel | "Top Level"
ViewGraphSchedTotalColumns | "Total Column Locations"
ViewGraphSchedTotalRows | "Total Segments"
ViewGraphSchedUnitsFormat | "Off-Grid Units Format"
ViewGraphSunPath | "Sun Path"
ViewGraphSunPathSize | "Sun path size (%)"
ViewModelDisplayMode | "Display Model"
ViewName | "View Name"
ViewPartsVisibility | "Parts Visibility"
ViewPhase | "Phase"
ViewPhaseFilter | "Phase Filter"
ViewportAttrLabelTag | "Title"
ViewportAttrOrientationOnSheet | "Rotation on Sheet"
ViewportAttrPreserveTitlePosition | "Preserve Title Position"
ViewportAttrShowBox | "Show Box"
ViewportAttrShowExtensionLine | "Show Extension Line"
ViewportAttrShowLabel | "Show Title"
ViewportDetailNumber | "Detail Number"
ViewportPositioning | "Viewport Positioning"
ViewportScale | "View Scale"
ViewportSheetCollection | "Sheet Collection"
ViewportSheetName | "Sheet Name"
ViewportSheetNumber | "Sheet Number"
ViewportView | "View"
ViewportViewName | "View Name"
ViewReferencingDetail | "Referencing Detail"
ViewReferencingSheet | "Referencing Sheet"
ViewReferencingSheetCollection | "Referencing Sheet Collection"
ViewScale | "Scale Value 1:"
ViewScaleCustomname | "Display Name"
ViewScaleHavename | "Display Name"
ViewScalePulldownImperial | "View Scale"
ViewScalePulldownMetric | "View Scale"
ViewSchemaSettingForBuilding | "Color Scheme"
ViewSchemaSettingForSystem | "System Color Schemes"
ViewSchemaSettingForSystemTemplate | "System Color Schemes"
ViewSheetViewportInfo | "Viewport"
ViewShowGrids | "Show Grids"
ViewShowHiddenLines | "Show Hidden Lines"
ViewShowMassing | "Show Mass"
ViewSlantedColumnSymbolOffset | "Column Symbolic Offset"
ViewSolarstudyAnimationSpeedText | "Loop animation speed"
ViewSolarstudyAnimationSpeedValue | "Loop animation speed"
ViewSolarstudyCurrentStudyTypeIndex | "Study type"
ViewSolarstudyIsLightingStudyType | "Lighting study"
ViewSolarstudyIsMultidayStudyType | "Multi-day study"
ViewSolarstudyIsSingledayStudyType | "Single day study"
ViewSolarstudyIsStillimageStudyType | "Still image study"
ViewSolarstudyLightingAltitudeText | "Lighting altitude text"
ViewSolarstudyLightingAltitudeValue | "Lighting altitude"
ViewSolarstudyLightingAzimuthText | "Lighting azimuth text"
ViewSolarstudyLightingAzimuthValue | "Lighting azimuth"
ViewSolarstudyLightingPresetIndex | "Lighting presets combo"
ViewSolarstudyMultidayDatetimeText | "Multi-day date and time text"
ViewSolarstudyMultidayFrameText | "Multi-day frame text"
ViewSolarstudyMultidayFrameValue | "Multi-day frame"
ViewSolarstudyMultidayPresetIndex | "Multi-day presets combo"
ViewSolarstudyShadowsIntensityText | "Shadows intensity text"
ViewSolarstudyShadowsIntensityValue | "Shadows intensity"
ViewSolarstudySingledayDatetimeText | "Single day date and time text"
ViewSolarstudySingledayFrameText | "Single day frame text"
ViewSolarstudySingledayFrameValue | "Single day frame"
ViewSolarstudySingledayPresetIndex | "Single day presets combo"
ViewSolarstudyStillDateText | "Still date text"
ViewSolarstudyStillDateValue | "Still date"
ViewSolarstudyStillPresetIndex | "Still presets combo"
ViewSolarstudyStillTimeText | "Still time text"
ViewSolarstudyStillTimeValue | "Still time"
ViewSolarstudySunIntensityText | "Sun intensity text"
ViewSolarstudySunIntensityValue | "Sun intensity"
ViewTemplate | "View Template"
ViewTemplateForSchedule | "View Template"
ViewType | "Family and Type"
ViewTypeSchedules | "Type"
ViewUnderlayBottomId | "Range: Base Level"
ViewUnderlayOrientation | "Underlay Orientation"
ViewUnderlayTopId | "Range: Top Level"
ViewVisibleCategories | "Visibility/Graphics Overrides"
VisGraphicsAnalyticalModel | "V/G Overrides Analytical Model"
VisGraphicsAnnotation | "V/G Overrides Annotation"
VisGraphicsCoordinationModel | "V/G Overrides Coordination Model"
VisGraphicsDesignoptions | "V/G Overrides Design Options"
VisGraphicsFilters | "V/G Overrides Filters"
VisGraphicsImport | "V/G Overrides Import"
VisGraphicsModel | "V/G Overrides Model"
VisGraphicsPointClouds | "V/G Overrides Point Clouds"
VisGraphicsRvtLinks | "V/G Overrides RVT Links"
VisGraphicsWorksets | "V/G Overrides Worksets"
VoidCutsGeometry | "Cuts Geometry"
VolumeCut | "Cut"
VolumeFill | "Fill"
VolumeNet | "Net cut/fill"
VolumeOfInterestHeight | "Height"
VolumeOfInterestName | "Name"
VolumeOfInterestViewsVisible | "Views Visible"
WalkthroughFramesCount | "Walkthrough Frames"
WallAlignKeyRefParam | "Location line to align"
WallAttrDefheightParam | "Default height"
WallAttrHeightParam | "Height"
WallAttrRoomBounding | "Room Bounding"
WallAttrWidthParam | "Width"
WallBaseConstraint | "Base Constraint"
WallBaseHeightParam | "Base height"
WallBaseOffset | "Base Offset"
WallBottomExtensionDistParam | "Base Extension Distance"
WallBottomIsAttached | "Base is Attached"
WallCrossSection | "Cross-Section"
WallHeightType | "Top Constraint"
WallKeyRefParam | "Location Line"
WallLocationLineOffsetParam | "Location Line Offset"
WallSingleSlantAngleFromVertical | "Angle From Vertical"
WallStructuralSignificant | "Structural"
WallStructuralUsageParam | "Structural Usage"
WallStructureIdParam | "Structure"
WallSweepCutByInsertsParam | "Cut by Inserts"
WallSweepCutsWallParam | "Cuts Wall"
WallSweepDefaultSetbackParam | "Default Setback"
WallSweepLevelParam | "Level"
WallSweepOffsetParam | "Offset From Level"
WallSweepOrientation | "Orientation"
WallSweepProfileParam | "Profile"
WallSweepWallOffsetParam | "Offset From Wall"
WallSweepWallSubcategoryId | "Subcategory of Walls"
WallTaperedExteriorInwardAngle | "Exterior Angle"
WallTaperedInteriorInwardAngle | "Interior Angle"
WallTaperedUseInstanceAngles | "Enable Angle Overrides"
WallTaperedWidthAtBottom | "Bottom Width"
WallTaperedWidthAtTop | "Top Width"
WallTopExtensionDistParam | "Top Extension Distance"
WallTopIsAttached | "Top is Attached"
WallTopOffset | "Top Offset"
WallTypeDefaultTaperedExteriorInwardAngle | "Default Exterior Angle"
WallTypeDefaultTaperedInteriorInwardAngle | "Default Interior Angle"
WallTypeWidthMeasuredAt | "Width Measured At"
WallUserHeightParam | "Unconnected Height"
WindowTypeId | "Type Mark"
WindowtypeIsSchematic | "Schematic"
WindowTypeName | "Name"
WitnsLineExtension | "Witness Line Extension"
WitnsLineGapToElt | "Witness Line Gap to Element"
WitnsLineTickMark | "Witness Line Tick Mark"
WrappingAtEndsParam | "Wrapping at Ends"
WrappingAtInsertsParam | "Wrapping at Inserts"
YJustification | "y Justification"
YOffsetValue | "y Offset Value"
YzJustification | "yz Justification"
ZJustification | "z Justification"
ZOffsetValue | "z Offset Value"
ZoneAirChangesPerHour | "Air Changes per Hour"
ZoneAirVolumeCalculationTypeParam | "Air Volume Calculation Type"
ZoneArea | "Occupied Area"
ZoneAreaGross | "Gross Area"
ZoneCalculatedAreaPerCoolingLoadParam | "Calculated Area per Cooling Load"
ZoneCalculatedAreaPerHeatingLoadParam | "Calculated Area per Heating Load"
ZoneCalculatedCoolingLoadParam | "Calculated Cooling Load"
ZoneCalculatedCoolingLoadPerAreaParam | "Calculated Cooling Load per area"
ZoneCalculatedHeatingLoadParam | "Calculated Heating Load"
ZoneCalculatedHeatingLoadPerAreaParam | "Calculated Heating Load per area"
ZoneCalculatedHydronicCoolingflowParam | "Calculated Hydronic Cooling Flow"
ZoneCalculatedHydronicHeatingflowParam | "Calculated Hydronic Heating Flow"
ZoneCalculatedSupplyAirflowParam | "Calculated Supply Airflow"
ZoneCalculatedSupplyAirflowPerAreaParam | "Calculated Supply Airflow per area"
ZoneCoilBypassPercentageParam | "Coil Bypass"
ZoneCoolingAirTemperatureParam | "Cooling Air Temperature"
ZoneCoolingInformationParam | "Cooling Information"
ZoneCoolingSetPointParam | "Cooling Set Point"
ZoneDehumidificationSetPointParam | "Dehumidification Set Point"
ZoneDesignCoolTemperature | "Design Temperature for Cooling"
ZoneDesignHeatTemperature | "Design Temperature for Heating"
ZoneHeatingAirTemperatureParam | "Heating Air Temperature"
ZoneHeatingInformationParam | "Heating Information"
ZoneHeatingSetPointParam | "Heating Set Point"
ZoneHumidificationSetPointParam | "Humidification Set Point"
ZoneLevelId | "Level"
ZoneLevelOffset | "Level Offset"
ZoneLevelOffsetTop | "Top Offset"
ZoneName | "Name"
ZoneOaRatePerAchParam | "Outdoor Air Rate / Air Changes per Hour"
ZoneOutdoorAirInformationParam | "Outdoor Air Information"
ZoneOutsideAirFlowPerArea | "Outside Air Flow per Area"
ZoneOutsideAirFlowPerPerson | "Outside Air Flow per Person"
ZoneOutsideAirPerAreaParam | "Outdoor Air per Area"
ZoneOutsideAirPerPersonParam | "Outdoor Air per Person"
ZonePerimeter | "Perimeter"
ZonePhase | "Phase"
ZonePhaseId | "Phase Id"
ZoneServiceTypeParam | "Service Type"
ZoneSpaceOutdoorAirOptionParam | "Space Outdoor Air Option"
ZoneUseAirChangesPerHourParam | "Use Air Changes Per Hour"
ZoneUseDehumidificationSetpointParam | "Use Dehumidification Set Point"
ZoneUseHumidificationSetpointParam | "Use Humidification Set Point"
ZoneUseOutsideAirPerAreaParam | "Use Outside Air Per Area"
ZoneUseOutsideAirPerPersonParam | "Use Outside Air Per Person"
ZoneVolume | "Occupied Volume"
ZoneVolumeGross | "Gross Volume"
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ParameterTypeId Properties

The ParameterTypeId type exposes the following members.

Properties
Name | Description
ActualMaxRidgeHeightParam | "Maximum Ridge Height"
AlignmentStationLabelDistance | "Distance": Currently not in use
AlignmentStationLabelIncludeStation | "Include Station"
AlignmentStationLabelIndStation | "Station Indicator"
AlignmentStationLabelSetEndStation | "Alignment Label Set End Station"
AlignmentStationLabelSetInterval | "Alignment Station Label Set Interval": The text is not used directly anywhere in the UI, instead the XAML specifies its own string for the value's label.
AlignmentStationLabelSetOffset | "Alignment Station Label Set Offset": The text is not used directly anywhere in the UI, instead the XAML specifies its own string for the value's label.
AlignmentStationLabelSetStartStation | "Alignment Label Set Start Station"
AlignmentStationLabelStationValue | "Station Value"
AlignmentStationPrefix | "Station Prefix"
AlignmentStationSuffix | "Station Suffix"
AllGridRotationForDivisionRule | "All Grid Rotation"
AllModelDescription | "Description"
AllModelImage | "Image"
AllModelInstanceComments | "Comments"
AllModelManufacturer | "Manufacturer"
AllModelModel | "Model"
AllModelTypeComments | "Type Comments"
AllModelTypeImage | "Type Image"
AllModelUrl | "URL"
AllowAutoEmbed | "Automatically Embed"
AllowMultipleSelection | "Allow Multiple Selection": This is used by the UI to allow selection of multiple elements.
AlternateUnits | "Alternate Units"
AlternateUnitsPrefix | "Alternate Units Prefix"
AlternateUnitsSuffix | "Alternate Units Suffix"
AlwaysZeroLength | "Base Offset"
AnalyticalAbsorptance | "Absorptance"
AnalyticalAdjacentSpace | "Adjacent Analytical Space"
AnalyticalDefineThermalPropertiesBy | "Define Thermal Properties by"
AnalyticalElementHasAssociation | "Has Association": Used for Analytical Member, Analytical Panel, Structural Columns, Structural Framing, Floors, Walls, Structural Foundation
AnalyticalElementPhysicalAsset | "Physical Material Asset": Used for Analytical Elements.
AnalyticalElementStructuralRole | "Structural Role": Used for Analytical Elements
AnalyticalGeometryIsValid | "Analytical Model Correct"
AnalyticalHeatTransferCoefficient | "Heat Transfer Coefficient (U)"
AnalyticalLinkReleaseRotationX | "X Rotation"
AnalyticalLinkReleaseRotationY | "Y Rotation"
AnalyticalLinkReleaseRotationZ | "Z Rotation"
AnalyticalLinkReleaseTranslationX | "X Translation"
AnalyticalLinkReleaseTranslationY | "Y Translation"
AnalyticalLinkReleaseTranslationZ | "Z Translation"
AnalyticalMemberForceEndAllNonZero | "All non 0 forces at end"
AnalyticalMemberForceEndFx | "End Fx"
AnalyticalMemberForceEndFy | "End Fy"
AnalyticalMemberForceEndFz | "End Fz"
AnalyticalMemberForceEndMx | "End Mx"
AnalyticalMemberForceEndMy | "End My"
AnalyticalMemberForceEndMz | "End Mz"
AnalyticalMemberForceStartAllNonZero | "All non 0 forces at start"
AnalyticalMemberForceStartFx | "Start Fx"
AnalyticalMemberForceStartFy | "Start Fy"
AnalyticalMemberForceStartFz | "Start Fz"
AnalyticalMemberForceStartMx | "Start Mx"
AnalyticalMemberForceStartMy | "Start My"
AnalyticalMemberForceStartMz | "Start Mz"
AnalyticalMemberRotation | "Cross-Section Rotation": Used for Analytical Member
AnalyticalMemberSectionType | "Section Type": The id of the type from the structural Family assigned to the analytical member.
AnalyticalModelArea | "Area": The Area of Analytical Model
AnalyticalModelBaseAlignmentMethod | "Base Alignment Method"
AnalyticalModelBaseExtensionMethod | "Base Extension Method"
AnalyticalModelBaseYProjection | "Base y Projection"
AnalyticalModelBaseZProjection | "Base z Projection"
AnalyticalModelCodeChecking | "Code Checking": Used for Analytical wall, Analytical beam, Analytical column, Analytical floor, Analytical wall foundations, Analytical isolated foundations, Analytical foundations slab, Anaytical brace
AnalyticalModelColumnBaseExtension | "Base x Projection"
AnalyticalModelColumnTopExtension | "Top x Projection"
AnalyticalModelEndAlignmentMethod | "End Alignment Method"
AnalyticalModelEndProjectionOrthogonal | "End Projection Orthogonal"
AnalyticalModelEndYProjection | "End y Projection"
AnalyticalModelEndZProjection | "End z Projection"
AnalyticalModelFloorAlignmentMethod | "Alignment Method"
AnalyticalModelFloorProjection | "z Projection"
AnalyticalModelFoundationsMark | "Foundation Number": Used for isolated, wall foundations
AnalyticalModelLength | "Length": The length of Analytical Model
AnalyticalModelManuallyAdjusted | "Manually Adjusted"
AnalyticalModelNodesMark | "Node Number": Used for nodes
AnalyticalModelPerimeter | "Perimeter": The Perimeter of Analytical Model
AnalyticalModelPhysicalType | "Family Type": the Family Type of the physical element associated with the Analytical Model
AnalyticalModelRotation | "Cross-Section Rotation": The rotation of Analytical Model
AnalyticalModelSketchAlignmentMethod | "Alignment Method"
AnalyticalModelSketchProjection | "In-Plane Projection"
AnalyticalModelStartAlignmentMethod | "Start Alignment Method"
AnalyticalModelStartProjectionOrthogonal | "Start Projection Orthogonal"
AnalyticalModelStartYProjection | "Start y Projection"
AnalyticalModelStartZProjection | "Start z Projection"
AnalyticalModelStickElementsMark | "Member Number": Used for beams, braces, columns
AnalyticalModelSurfaceElementsMark | "Surface Number": Used for floors, slabs, walls
AnalyticalModelTopAlignmentMethod | "Top Alignment Method"
AnalyticalModelTopExtensionMethod | "Top Extension Method"
AnalyticalModelTopYProjection | "Top y Projection"
AnalyticalModelTopZProjection | "Top z Projection"
AnalyticalModelWallAlignmentMethod | "Alignment Method"
AnalyticalModelWallBaseProjection | "Base y Projection"
AnalyticalModelWallProjection | "z Projection"
AnalyticalModelWallTopProjection | "Top y Projection"
AnalyticalNodeCanBeHosted | "Can Be Hosted": Specifies of the Analytical Node can be hosted or not.
AnalyticalNodeConnectionStatus | "Connection Status"
AnalyticalNodeType | "Node Type": Specifies the type of the Analytical Node: hosted or not.
AnalyticalPanelThickness | "Thickness": Used for Analytical Panel
AnalyticalRoughness | "Roughness"
AnalyticalSolarHeatGainCoefficient | "Solar Heat Gain Coefficient"
AnalyticalSpace | "Analytical Space"
AnalyticalSurface | "Analytical Surface"
AnalyticalThermalMass | "Thermal Mass"
AnalyticalThermalResistance | "Thermal Resistance (R)"
AnalyticalVisualLightTransmittance | "Visual Light Transmittance"
AnalyticalZone | "Analytical Zone"
AnalyticalZoneName | "Name"
AnalyticConstruction | "Analytic Construction"
AnalyticConstructionGbxmlTypeid | "Construction Type Id"
AnalyticConstructionLookupTable | "Analytic Construction"
AnyPatternIdParam | "Fill Pattern"
AnyPatternIdParamNoNo | "Fill Pattern"
ArcCenterMark | "Center Marks"
ArcElemFixKeepConcentric | "Keep Concentric"
ArcLeaderParam | "Arc Leaders"
ArcWallCntrMrkVisible | "Center Mark Visible"
AreaSchemeId | "Area Scheme Id"
AreaSchemeName | "Name"
AreaType | "Area Type"
AreaTypeText | "Area Type"
ArrowCentered | "Tick Mark Centered"
ArrowClosed | "Arrow Closed"
ArrowFilled | "Fill Tick"
ArrowheadEndAtRiser | "End at Riser"
ArrowheadType | "Arrowhead Type"
ArrowSize | "Tick Size"
ArrowType | "Arrow Style"
AssemblyName | "Assembly Name"
AssemblyNamingCategory | "Naming Category"
AssemblyPrecastFreeze | "Disable Precast Updates"
AssignTemplateOnViewCreation | "New views are dependent on template"
AssociatedLevel | "Associated Level": The level associated with this cell.
AssociatedLevelOffset | "Associated Level Offset": The offset from the associated level.
AutoJoinCondition | "Join Condition"
AutoJoinConditionWall | "Join Condition"
AutoMullionBorder1Grid1 | "Border 1 Type"
AutoMullionBorder1Grid2 | "Border 1 Type"
AutoMullionBorder1Horiz | "Border 1 Type"
AutoMullionBorder1Vert | "Border 1 Type"
AutoMullionBorder2Grid1 | "Border 2 Type"
AutoMullionBorder2Grid2 | "Border 2 Type"
AutoMullionBorder2Horiz | "Border 2 Type"
AutoMullionBorder2Vert | "Border 2 Type"
AutoMullionInteriorGrid1 | "Interior Type"
AutoMullionInteriorGrid2 | "Interior Type"
AutoMullionInteriorHoriz | "Interior Type"
AutoMullionInteriorVert | "Interior Type"
AutoPanel | "Curtain Panel"
AutoPanelWall | "Curtain Panel"
Azimuth | "Azimuth"
BackgroundDraftPatternIdParam | "Background Fill Pattern"
BackgroundPatternColorParam | "Background Pattern Color"
BaselineDimOffset | "Baseline Offset"
BasepointAngletonParam | "Angle to True North"
BasepointEastwestParam | "E/W"
BasepointElevationParam | "Elev"
BasepointLatitudeParam | "Lat"
BasepointLongitudeParam | "Lon"
BasepointNorthsouthParam | "N/S"
BeamHJustification | "Lateral Justification"
BeamSystem3dParam | "3D"
BeamSystemTagInstParamAngle | "Beam System Tag Direction"
BeamSystemTagParamLeft | "Left"
BeamSystemTagParamRight | "Right"
BeamVJustification | "z-Direction Justification"
BeamVJustificationOtherValue | "z-Direction Offset Value"
BendingDetailAngularDimensionTextPosition | "Angle Text Position"
BendingDetailDetailLevel | "Detail Level"
BendingdetailPosition | "Bending Detail Position"
BendingDetailRepresentationFor3dBars | "View for 3D Shape"
BendingDetailSegmentLengthDimensionTextPosition | "Dimension Text Position"
BendingDetailSegmentRepresentation | "Representation"
BendingDetailTypeAngularDimensionOffset | "Angular Dimension Offset"
BendingDetailTypeAngularDimensionsEnabled | "Angular Dimensions"
BendingDetailTypeAngularDimensionsForHooksEnabled | "Hook Angles"
BendingDetailTypeAngularDimensionsMeasurement | "Angle Measurement"
BendingDetailTypeAngularDimensionTypeId | "Angular Dimension Style"
BendingDetailTypeBendDiameterDimensionsEnabled | "Bend Diameter Dimensions"
BendingDetailTypeBendDiameterDimensionsForHooksEnabled | "Hook Bends"
BendingDetailTypeBendDiameterDimensionsForSegmentsEnabled | "Segment Bends"
BendingDetailTypeDiameterDimensionTypeId | "Diameter Dimension Style"
BendingDetailTypeOrthogonalAndOverallDimesionsEnabled | "Other Dimensions"
BendingDetailTypeRadialDimensionTypeId | "Radial Dimension Style"
BendingDetailTypeSchematicHeight | "Height"
BendingDetailTypeSchematicWidth | "Width"
BendingDetailTypeSegmentLengthDimensionsEnabled | "Segment Length Dimensions"
BendingDetailTypeSegmentLengthDimensionsForHooksEnabled | "Hook Lengths"
BendingDetailTypeSegmentLengthDimensionsOffset | "Dimension Offset"
BendingDetailTypeSegmentLengthDimensionTypeId | "Linear Dimension Style"
BendingDetailTypeSegmentLengthsDisplayOption | "Straight Segment Lengths"
BendingDetailTypeSegmentLengthsForArcsDisplayOption | "Arc Segment Lengths"
BendingDetailTypeShowAngularDimensionsFor | "Show for Angles"
BendingDetailTypeShowBarBendingUsing | "Dimension Type"
BendingDetailTypeTagTypeId | "Tag Type"
BendingDetailVaryingRebarDimension | "Varying Rebar Set Dimensions"
BentFabricParamBendDirection | "Bend Direction": Direction in which FabricSheet is bent.
BentFabricParamLongitudinalCutLength | "Longitudinal Cut Length": Bent fabric longitudinal cut length.
BentFabricParamStraightWiresLocation | "Straight Wires Location": Location of straight wires in a bent fabric.
BlendDepthParam | "Depth"
BlendEndParam | "Second End"
BlendStartParam | "First End"
BoundaryAreaRestraintX | "X Spring Modulus"
BoundaryAreaRestraintY | "Y Spring Modulus"
BoundaryAreaRestraintZ | "Z Spring Modulus"
BoundaryBearing | "Bearing"
BoundaryConditionsIsExt | "Is Boundary Conditions External?"
BoundaryConditionsType | "Boundary Conditions Type"
BoundaryDirectionRotX | "X Rotation"
BoundaryDirectionRotY | "Y Rotation"
BoundaryDirectionRotZ | "Z Rotation"
BoundaryDirectionX | "X Translation"
BoundaryDirectionY | "Y Translation"
BoundaryDirectionZ | "Z Translation"
BoundaryDistance | "Distance"
BoundaryLinearRestraintRotX | "X Spring Modulus"
BoundaryLinearRestraintX | "X Spring Modulus"
BoundaryLinearRestraintY | "Y Spring Modulus"
BoundaryLinearRestraintZ | "Z Spring Modulus"
BoundaryParamPreset | "State"
BoundaryParamPresetArea | "State"
BoundaryParamPresetLinear | "State"
BoundaryRadius | "Radius"
BoundaryRestraintRotX | "X Spring Modulus"
BoundaryRestraintRotY | "Y Spring Modulus"
BoundaryRestraintRotZ | "Z Spring Modulus"
BoundaryRestraintX | "X Spring Modulus"
BoundaryRestraintY | "Y Spring Modulus"
BoundaryRestraintZ | "Z Spring Modulus"
BoundaryXRotationFixed | "X Rotation - Fixed"
BoundaryXRotationSpring | "X Rotation - Spring"
BoundaryXTranslationFixed | "X Translation - Fixed"
BoundaryXTranslationSpring | "X Translation - Spring"
BoundaryYRotationFixed | "Y Rotation - Fixed"
BoundaryYRotationSpring | "Y Rotation - Spring"
BoundaryYTranslationFixed | "Y Translation - Fixed"
BoundaryYTranslationSpring | "Y Translation - Spring"
BoundaryZRotationFixed | "Z Rotation - Fixed"
BoundaryZRotationSpring | "Z Rotation - Spring"
BoundaryZTranslationFixed | "Z Translation - Fixed"
BoundaryZTranslationSpring | "Z Translation - Spring"
BrOrgFilter | "Filter"
BrOrgFolders | "Folders"
BuildingClosingTimeParam | "Closing Time"
BuildingCurveGstyle | "Line Style"
BuildingCurveGstylePlusInvisible | "Subcategory"
BuildingOpeningTimeParam | "Opening Time"
BuildingpadHeightabovelevelParam | "Height Offset From Level"
BuildingpadThickness | "Thickness"
BuildingUnoccupiedCoolingSetPointParam | "Unoccupied Cooling Set Point"
BuilidingPadStructureIdParam | "Structure"
CabletrayMinbendmultiplierParam | "Bend Radius Multiplier"
CalloutAttrHeadTag | "Callout Head"
CalloutCornerSheetRadius | "Corner Radius"
CalloutSyncronizeBoundOffsetFar | "Far Clip Settings"
CalloutTag | "Callout Tag"
CeilingAttrDefaultHeightParam | "Default Height above level"
CeilingAttrPatternParam | "Pattern"
CeilingAttrSpacing1Param | "Spacing Axis 1"
CeilingAttrSpacing2Param | "Spacing Axis 2"
CeilingAttrSystemnameParam | "System"
CeilingHasThicknessParam | "Has Thickness"
CeilingHeightabovelevelParam | "Height Offset From Level"
CeilingStructureIdParam | "Structure"
CeilingThickness | "Thickness"
CeilingThicknessParam | "Thickness"
CenterMarkSize | "Center Mark Size"
CircMullionRadius | "Radius"
CircuitLoadClassificationAbbreviationParam | "Load Classification Abbreviation"
CircuitLoadClassificationParam | "Load Classification"
CircuitPhaseParam | "Phase Label"
CircuitWaysParam | "Ways"
CircularFramingDiameter | "Circular Diameter"
ClearCover | "Rebar Cover"
ClearCoverBottom | "Rebar Cover - Bottom Face"
ClearCoverExterior | "Rebar Cover - Exterior Face"
ClearCoverInterior | "Rebar Cover - Interior Face"
ClearCoverOther | "Rebar Cover - Other Faces"
ClearCoverTop | "Rebar Cover - Top Face"
ClientName | "Client Name"
ClineSubcategory | "Subcategory"
CoarseScaleFillPatternColor | "Coarse Scale Fill Color"
CoarseScaleFillPatternIdParam | "Coarse Scale Fill Pattern"
ColorFillFilteredParam | "Values Displayed"
ColorFillSwatchHeightParam | "Swatch Height"
ColorFillSwatchWidthParam | "Swatch Width"
ColorSchemeLocation | "Color Scheme Location"
ColumnBaseAttachCutParam | "Base Attachment Cut"
ColumnBaseAttachedParam | "Base is Attached"
ColumnBaseAttachJustificationParam | "Attachment Justification At Base"
ColumnBaseAttachmentOffsetParam | "Offset From Attachment At Base"
ColumnLocationMark | "Column Location Mark"
ColumnTopAttachCutParam | "Top Attachment Cut"
ColumnTopAttachedParam | "Top is Attached"
ColumnTopAttachJustificationParam | "Attachment Justification At Top"
ColumnTopAttachmentOffsetParam | "Offset From Attachment At Top"
ConceptualConstructionMaterial | "Graphical Appearance"
ConduitStandardTypeParam | "Standard"
ConnectorAngle | "Angle"
ConnectorAngleOfDeflection | "Angle of Deflection"
ConnectorDiameter | "Diameter"
ConnectorEngagementLength | "Engagement Length"
ConnectorGenderType | "Connector Gender Type"
ConnectorHeight | "Height"
ConnectorIndex | "Index"
ConnectorInsideDiameter | "Inside Diameter"
ConnectorJointType | "Connector Joint Type"
ConnectorLength | "Length"
ConnectorProfileType | "Shape"
ConnectorRadius | "Radius"
ConnectorReferenceIndex | "Link Connector Index"
ConnectorUtilityParam | "Utility"
ConnectorVisibleSize | "Size on screen"
ConnectorWidth | "Width"
ConstructionIsSchematic | "Schematic"
ConstructionName | "Name"
ContinuousFootingBearingWidth | "Width"
ContinuousFootingBottomHeel | "Bottom Heel Length"
ContinuousFootingBottomToe | "Bottom Toe Length"
ContinuousFootingBreakAtInsertsDisable | "Do Not Break At Inserts"
ContinuousFootingDefaultEndExtensionLength | "Default End Extension Length"
ContinuousFootingEccentricity | "Eccentricity"
ContinuousFootingLength | "Length"
ContinuousFootingStructuralUsage | "Structural Usage"
ContinuousFootingTopHeel | "Heel Length"
ContinuousFootingTopToe | "Toe Length"
ContinuousFootingWidth | "Width"
ContinuousrailBeginningTerminationAttachmentParam | "Extension Style"
ContinuousrailBeginningTerminationTypeParam | "Beginning/Bottom Termination"
ContinuousrailDefaultJoinTypeParam | "Default Join"
ContinuousrailEndExtensionLengthParam | "Length"
ContinuousrailEndTerminationAttachmentParam | "Extension Style"
ContinuousrailEndTerminationTypeParam | "End/Top Termination"
ContinuousrailExtensionLengthParam | "Length"
ContinuousrailFilletRadiusParam | "Fillet Radius"
ContinuousrailJoinTypeParam | "Rail Path Join"
ContinuousrailLengthParam | "Length"
ContinuousrailMaterialsParam | "Material"
ContinuousrailPlusTreadDepthParam | "Plus Tread Depth"
ContinuousrailProfileTypeParam | "Profile"
ContinuousrailTransitionTypeParam | "Transitions"
ContourElevation | "Elevation"
ContourElevationStep | "Increment"
ContourLabelsElevBaseType | "Elevation Base"
ContourLabelsLinearUnits | "Units Format"
ContourLabelsPrimaryOnly | "Label primary contours only"
ContourLabelsRelativeBase | "Relative Base"
CouplerCode | "Part Number"
CouplerCoupledBarSize | "Bar Size 2"
CouplerCoupledEndtreatment | "End Treatment 2"
CouplerCoupledEngagement | "Bar Engagement 2"
CouplerLength | "Total Length"
CouplerMainBarSize | "Bar Size 1"
CouplerMainEndtreatment | "End Treatment 1"
CouplerMainEngagement | "Bar Engagement 1"
CouplerMark | "Schedule Mark"
CouplerNumber | "Coupler Number"
CouplerQuantity | "Quantity"
CouplerRotationAngle | "Coupler Rotation"
CouplerWeight | "Mass"
CouplerWidth | "External Diameter"
CoverTypeLength | "Length"
CoverTypeName | "Name"
CurtaingridAdjustBorderHoriz | "Adjust for Mullion Size"
CurtaingridAdjustBordern1 | "Adjust for Mullion Size"
CurtaingridAdjustBordern2 | "Adjust for Mullion Size"
CurtaingridAdjustBorderU | "Adjust for Mullion Size"
CurtaingridAdjustBorderV | "Adjust for Mullion Size"
CurtaingridAdjustBorderVert | "Adjust for Mullion Size"
CurtaingridAngleHoriz | "Angle"
CurtaingridAnglen1 | "Angle"
CurtaingridAnglen2 | "Angle"
CurtaingridAngleU | "Grid Rotation"
CurtaingridAngleV | "Grid Rotation"
CurtaingridAngleVert | "Angle"
CurtainGridBaseOrientation | "Grid Base Orientation"
CurtaingridBeltHoriz | "Measurement Line"
CurtaingridBeltn1 | "Measurement Line"
CurtaingridBeltn2 | "Measurement Line"
CurtaingridBeltRation1 | "Measurement Line"
CurtaingridBeltRation2 | "Measurement Line"
CurtaingridBeltRatioU | "Belt Measurement"
CurtaingridBeltRatioV | "Belt Measurement"
CurtaingridBeltU | "Belt Measurement"
CurtaingridBeltV | "Belt Measurement"
CurtaingridBeltVert | "Measurement Line"
CurtaingridOriginHoriz | "Offset"
CurtaingridOriginn1 | "Offset"
CurtaingridOriginn2 | "Offset"
CurtaingridOriginU | "Offset"
CurtaingridOriginV | "Offset"
CurtaingridOriginVert | "Offset"
CurtaingridUseCurveDist | "Use Curve Distance"
CurtaingridUseCurveDistHoriz | "Use Curve Distance"
CurtaingridUseCurveDistn1 | "Use Curve Distance"
CurtaingridUseCurveDistn2 | "Use Curve Distance"
CurtaingridUseCurveDistU | "Use Curve Distance"
CurtaingridUseCurveDistV | "Use Curve Distance"
CurtaingridUseCurveDistVert | "Use Curve Distance"
CurtainVersionParam | "Curtain version"
CurtainWallPanelHostId | "Host Id"
CurtainWallPanelsHeight | "Height"
CurtainWallPanelsWidth | "Width"
CurtainWallSyspanelOffset | "Offset"
CurtainWallSyspanelThickness | "Thickness"
CurveBottomLevel | "Bottom Level"
CurveByPointsProjectionType | "Projection Type"
CurveDeterminesOrientation | "Determines Orientation"
CurveEdgeOffset | "Wall offset"
CurveElemArcEndAngle | "Angle 2"
CurveElemArcRadius | "Radius"
CurveElemArcRange | "Range"
CurveElemArcStartAngle | "Angle 1"
CurveElemDefinesSlope | "Defines Beam System Slope"
CurveElemLength | "Length"
CurveElemLineAngle | "Angle"
CurveHeightOffset | "Offset From Base"
CurveIsDetail | "Detail Line"
CurveIsFilled | "Filled"
CurveIsMultilevel | "Multilevel Boundary"
CurveIsReferenceLine | "Is Reference Line"
CurveIsSlopeDefining | "Defines Slope"
CurveLevel | "Level"
CurveNumberOfSegments | "Number of Full Segments"
CurveParamConcreteCantilever | "Concrete Cantilever"
CurveParamSteelCantilever | "Steel Cantilever"
CurveSupportOffset | "Wall offset"
CurveTopLevel | "Top Level"
CurveVisibilityParam | "Visibility/Graphics Overrides"
CurveWallOffset | "Wall offset"
CurveWallOffsetRoofs | "Overhang"
CustMullionThick | "Thickness"
CustMullionWidth1 | "Width on side 1"
CustMullionWidth2 | "Width on side 2"
CutLineAngle | "Cut Line Angle"
CutLineDistance | "Cut Line Distance"
CutLineExtension | "Cut Line Extension"
CutLineType | "Cut Line Type"
CutMarkSymbol | "Cut Mark Symbol"
CutMarkSymbolSize | "Cut Mark Symbol Size"
CwpAddGridPrefix | "Add prefix to Grid Name"
CwpAddGridSuffix | "Add suffix to Grid Name"
CwpAddLevelPrefix | "Add prefix to Level Name"
CwpAddLevelSuffix | "Add suffix to Level Name"
CwpCopyFloorInserts | "Copy openings/inserts"
CwpCopyRoofInserts | "Copy openings"
CwpCopyWallInserts | "Copy windows/doors/openings"
CwpLevelOffset | "Offset Level"
CwpLinkedRoomParams | "Parameters"
CwpLinkedRoomPhases | "Phases"
CwpReuseExistingGrids | "Reuse matching Grids"
CwpReuseExistingLevels | "Reuse matching Levels"
CwpReuseGridsSameName | "Reuse Grids with the same name"
CwpReuseLevelsSameName | "Reuse Levels with the same name"
CwpSplitColumnsAtLevels | "Split Columns by Levels"
DatumBubbleEndn1 | "Symbol at End 1 Default"
DatumBubbleEndn2 | "Symbol at End 2 Default"
DatumBubbleLocationInElev | "Non-Plan View Symbols (Default)"
DatumPlaneDefinesOrigin | "Defines Origin"
DatumPlaneDefinesWallClosure | "Wall Closure"
DatumText | "Name"
DatumVolumeOfInterest | "Scope Box"
DecalAttributes | "Decal Attributes"
DecalHeight | "Height"
DecalLockProportions | "Lock Proportions"
DecalSubcategoryId | "Subcategory"
DecalWidth | "Width"
DefaultConstructionExtWallUnderground | "Mass Exterior Wall - Underground"
DefaultConstructionMassExteriorWall | "Mass Exterior Wall"
DefaultConstructionMassFloor | "Mass Floor"
DefaultConstructionMassGlazing | "Mass Glazing"
DefaultConstructionMassInteriorWall | "Mass Interior Wall"
DefaultConstructionMassOpening | "Mass Opening"
DefaultConstructionMassRoof | "Mass Roof"
DefaultConstructionMassShade | "Mass Shade"
DefaultConstructionMassSkylight | "Mass Skylight"
DefaultConstructionMassSlab | "Mass Slab"
DefaultViewTemplate | "View Template applied to new views"
DefinesConstantHeight | "Defines Constant Height"
DesignOptionId | "Design Option"
DesignOptionParam | "Design Option"
DiameterSymbolLocation | "Diameter Symbol Location"
DiameterSymbolText | "Diameter Symbol Text"
DimDisplayEq | "Equality Display"
DimIsreporting | "Is Reporting"
DimLabel | "Label"
DimLabelGpShow | "Show Label in View"
DimLabelIsInstance | "Is Instance Parameter"
DimLeader | "Leader"
DimLeaderArrowhead | "Tick Mark"
DimLeaderDisplayCondition | "Show Leader When Text Moves"
DimLeaderShoulderLength | "Shoulder Length"
DimLeaderType | "Leader Type"
DimLineExtension | "Dimension Line Extension"
DimNotModifiable | "Non-modifiable"
DimPrefix | "Dimension Prefix"
DimReferenceCount | "Count"
DimStyleAngularUnits | "Units Format"
DimStyleAngularUnitsAlt | "Alternate Units Format"
DimStyleCenterlinePattern | "Centerline Pattern"
DimStyleCenterlineSymbol | "Centerline Symbol"
DimStyleCenterlineTickMark | "Centerline Tick Mark"
DimStyleDimLineSnapDist | "Dimension Line Snap Distance"
DimStyleFlippedDimLineExtension | "Flipped Dimension Line Extension"
DimStyleInteriorTickMark | "Interior Tick Mark"
DimStyleLeaderTickMark | "Leader Tick Mark"
DimStyleLinearUnits | "Units Format"
DimStyleLinearUnitsAlt | "Alternate Units Format"
DimStyleReadConvention | "Read Convention"
DimStyleShowOpeningHt | "Show Opening Height"
DimStyleSuppressSpaces | "Suppress Spaces"
DimSuffix | "Dimension Suffix"
DimTextBackground | "Text Background"
DimTextLocationForLeader | "Text Location"
DimToInserts | "Dimension To Openings"
DimToInsertType | "Dimension To Opening Type"
DimToIntersectingGrids | "Dimension To Intersecting Grids"
DimToIntersectingWalls | "Dimension To Intersecting Walls"
DimTotalLength | "Total Length"
DimValueAngle | "Value"
DimValueLength | "Value"
DimWitnsLineCntrl | "Witness Line Control"
DimWitnsLineExtensionBelow | "Witness Line Length"
Directcontext3dApplicationId | "ApplicationId"
Directcontext3dLoaded | "Loaded"
Directcontext3dName | "Name"
Directcontext3dServerId | "ServerId"
Directcontext3dSourceId | "Path"
DisplacedElementDisplacementX | "X Displacement"
DisplacedElementDisplacementY | "Y Displacement"
DisplacedElementDisplacementZ | "Z Displacement"
DisplacementPathDepth | "Depth"
DisplacementPathStyle | "Style"
DistanceToCutMark | "Distance to Cut Mark"
DividedpathBeginningIndent | "Beginning Indent"
DividedpathDisplayNodeNumbers | "Show Node Numbers"
DividedpathDisplayNodes | "Display Nodes"
DividedpathDisplayReferenceCurves | "Display Path"
DividedpathDistance | "Distance"
DividedpathEndIndent | "End Indent"
DividedpathFlipDirection | "Flip Direction"
DividedpathJustification | "Justification"
DividedpathLayout | "Layout"
DividedpathLayoutFixedNumPoint | "Number"
DividedpathMaxDistance | "Maximum Distance"
DividedpathMeasurementType | "Measurement Type"
DividedpathMergedPointNum | "Total Number of Nodes"
DividedpathMinDistance | "Minimum Distance"
DividedpathTotalPathLength | "Path Length"
DividedSurfaceAllGridRotation | "All Grid Rotation"
DividedSurfaceAllPoints | "Show all points"
DividedSurfaceComponentTrimType | "Component Trim"
DividedSurfaceCoverFaceCompletely | "Cover face completely"
DividedSurfaceDisplayComponents | "Components"
DividedSurfaceDisplayDiscardeddivisionlines | "Discarded Division Lines"
DividedSurfaceDisplayGridlines | "Gridlines"
DividedSurfaceDisplayNodes | "Nodes"
DividedSurfaceDisplayOriginalSurface | "Surface"
DividedSurfaceDisplayPatternFill | "Pattern Fill"
DividedSurfaceDisplayPatternLines | "Pattern Lines"
DividedSurfaceDisplaySurfaceOption | "Display Surface Option"
DividedSurfaceEdgeNumber | "Edge number"
DividedSurfaceFacetNumber | "Facet number"
DividedSurfaceGridlinesStyle | "Gridlines Style"
DividedSurfaceGridOptionParamn1 | "Option 1"
DividedSurfaceGridOptionParamn2 | "Option 2"
DividedSurfaceOffsetFromSurface | "Offset from surface"
DividedSurfaceOriginalSurfaceMaterial | "Surface Material"
DividedSurfacePattern | "Tile Pattern"
DividedSurfacePatternFillMaterial | "Pattern Fill Material"
DividedSurfacePatternFlip | "Component Flip"
DividedSurfacePatternIndentn1 | "Indent 1"
DividedSurfacePatternIndentn2 | "Indent 2"
DividedSurfacePatternLinesStyle | "Pattern Lines Style"
DividedSurfacePatternMirror | "Component Mirror"
DividedSurfacePatternRotationAngle | "Component Rotation"
DividedSurfacePointNumber | "Point number"
DividedSurfaceRule1Suspension | "Is grid 1 suspended?"
DividedSurfaceRule2Suspension | "Is grid 2 suspended?"
DividedSurfaceSurfaceArea | "Divided Surface Area"
DividedSurfaceTileBorder | "Border Tile"
DividedSurfaceTotalEdgeLength | "Total edge length"
DivisionPattern | "Division Pattern"
DivisionProfileWidth | "Width": Width
DivisionRuleParam | "Division Rule"
DivisionSketchCurveDivisionParamsOverrideParam | "Profile Override"
DivisionSketchCurveExtentdToSilhParam | "Extend to Silhouette"
DoorConstructionType | "Construction Type"
DoorCost | "Cost"
DoorEvacuationExitType | "Exit Access"
DoorFinish | "Finish"
DoorFrameMaterial | "Frame Material"
DoorFrameType | "Frame Type"
DoorNumber | "Mark"
DoorOperationType | "Operation"
DpartAreaComputed | "Area"
DpartBaseLevel | "Base Level"
DpartBaseLevelByOriginal | "Base Level By Original"
DpartCanHostRebar | "Can host rebar"
DpartExcluded | "Excluded"
DpartHeightComputed | "Height"
DpartLayerConstruction | "Construction"
DpartLayerFunction | "Layer Function"
DpartLayerIndex | "Layer Index"
DpartLayerWidth | "Thickness"
DpartLengthComputed | "Length"
DpartMaterialByOriginal | "Material By Original"
DpartMaterialIdParam | "Material"
DpartOriginalCategory | "Original Category"
DpartOriginalCategoryId | "Original Category"
DpartOriginalFamily | "Original Family"
DpartOriginalType | "Original Type"
DpartPhaseCreatedByOriginal | "Phase Created By Original"
DpartPhaseDemolishedByOriginal | "Phase Demolished By Original"
DpartShapeModified | "Shape is modified"
DpartVolumeComputed | "Volume"
DrawForEachRun | "Draw for Each Run"
DuctInsulationThickness | "Insulation Thickness"
DuctRoughness | "Roughness"
DuctTerminalEngagementLength | "Engagement Length"
EdgeLinework | "Line Style"
EditedBy | "Edited by"
ElecticalEquipVoltage | "Voltage Comments"
ElecticalEquipWattage | "Wattage Comments"
ElemCategoryParam | "Category"
ElemCategoryParamMt | "Category"
ElemDeletableInFamily | "Deletable"
ElementIsCutting | "Solid/Void"
ElementLockedParam | "Locked"
ElemFamilyAndTypeParam | "Family and Type"
ElemFamilyParam | "Family"
ElemIsReference | "Reference"
ElemPartitionParam | "Workset"
ElemReferenceName | "Is Reference"
ElemReferenceName2dXz | "Is Reference"
ElemRoomId | "Room Id"
ElemRoomName | "Room Name"
ElemRoomNumber | "Room Number"
ElemTypeLabel | "Label"
ElemTypeParam | "Type"
ElevArrowAngle | "Arrow Angle"
ElevArrowFilled | "Filled"
ElevAssocDatum | "Associated Datum"
ElevatnTag | "Elevation Tag"
ElevReferenceLabelPos | "Reference Label Position"
ElevShape | "Shape"
ElevShowViewName | "Show View Name"
ElevSymbolId | "Elevation Mark"
ElevTextPos | "Text Position"
ElevViewNamePos | "View Name Position"
ElevWidth | "Width"
EllipseFocusMrkVisible | "Focus Marks Visible"
EllipseModificationKeepsRatio | "Keep Ratio"
EllipseXParam | "X-Radius Value for Ellipse (for Use with XAML Data Template example)"
EllipseYParam | "Y-Radius Value for Ellipse (for Use with XAML Data Template example)"
EndExtension | "End Extension"
EndJoinCutback | "End Join Cutback"
EndTreatment | "End Treatment"
EndYJustification | "End y Justification"
EndYOffsetValue | "End y Offset Value"
EndZJustification | "End z Justification"
EndZOffsetValue | "End z Offset Value"
EnergyAnalysisAdvancedOptions | "Other Options"
EnergyAnalysisBuildingOperatingSchedule | "Building Operating Schedule"
EnergyAnalysisConceptualConstruction | "Conceptual Types"
EnergyAnalysisCreateAnalyticalModel | "Create Energy Model"
EnergyAnalysisCurrentViewOnly | "Use Only Elements Visible In Current View"
EnergyAnalysisGlazingIsShaded | "Glazing is Shaded"
EnergyAnalysisHorizontalVoidThreshold | "Horizontal Void/Chase Area Threshold"
EnergyAnalysisHvacSystem | "HVAC System"
EnergyAnalysisMasszoneCoreoffset | "Perimeter Zone Depth"
EnergyAnalysisMasszoneDivideperimeter | "Perimeter Zone Division"
EnergyAnalysisMasszoneUseenergydatasettings | "Use Energy Data"
EnergyAnalysisMassZoning | "Mass Zoning"
EnergyAnalysisOutdoorAirInformationParam | "Outdoor Air Information"
EnergyAnalysisPercentageGlazing | "Target Percentage Glazing"
EnergyAnalysisPercentageSkylights | "Target Percentage Skylights"
EnergyAnalysisProjectPhase | "Phase"
EnergyAnalysisShadeDepth | "Shade Depth"
EnergyAnalysisSillHeight | "Target Sill Height"
EnergyAnalysisSkylightWidth | "Skylight Width & Depth"
EnergyAnalysisSpaceBoundingParam | "Analytical Space Bounding"
EnergyAnalysisVerticalVoidThreshold | "Average Vertical Void Height Threshold"
EqualityFormula | "Equality Formula"
EqualityTextForAngularDim | "Equality Text"
EqualityTextForContinuousLinearDim | "Equality Text"
EqualityWitnessDisplay | "Equality Witness Display"
ExcavationElementFamilyAndType | "Element Family and Type"
ExcavationElementId | "Element Id"
ExcavationVolume | "Excavation Volume"
ExcavationVolumeOnToposolid | "Excavation Volume on Toposolid"
ExchangeEntityId | "Exchange Entity ID"
ExchangeId | "Exchange ID"
ExtrusionAutoParams | "Auto ends"
ExtrusionDepthParam | "Depth"
ExtrusionEndParam | "Extrusion End"
ExtrusionLength | "Depth"
ExtrusionStartParam | "Extrusion Start"
FabricationBottomElevationIncludeInsulationOfPart | "Bottom Elevation with Insulation"
FabricationBottomElevationOfPart | "Bottom Elevation"
FabricationBottomOfPart | "Lower End Bottom of Insulation Elevation"
FabricationBranchSize | "Size of Primary Branch End"
FabricationChangeServiceParam | "Change Service"
FabricationDoublewallMaterialAbbreviation | "Double Wall Material Abbreviation"
FabricationDuctworkStiffenerSpec | "Stiffener Specification"
FabricationEndOffsetParam | "End Middle Elevation"
FabricationEndSize | "Size of Connector End"
FabricationFittingDescription | "Fabrication Fitting Description"
FabricationInsulationAbbreviation | "Insulation Abbreviation"
FabricationInsulationMaterialFinish | "Insulation Material"
FabricationInsulationSpec | "Insulation Specification"
FabricationInsulationSpecificationAbbreviation | "Insulation Specification Abbreviation"
FabricationLevelParam | "Reference Level"
FabricationMaterialAbbreviation | "Material Abbreviation"
FabricationMaterialGauge | "Material Gauge"
FabricationOffsetParam | "Middle Elevation"
FabricationPartAlias | "Alias"
FabricationPartAngle | "Angle"
FabricationPartAngleOption | "Angle Option"
FabricationPartBoughtOut | "Bought Out"
FabricationPartCutType | "Cut Type"
FabricationPartDepthIn | "Main Primary Depth"
FabricationPartDepthInOption | "Main Primary Depth Option"
FabricationPartDepthOut | "Main Secondary Depth"
FabricationPartDepthOutOption | "Main Secondary Depth Option"
FabricationPartDiameterIn | "Main Primary Diameter"
FabricationPartDiameterInOption | "Main Primary Diameter Option"
FabricationPartDiameterOut | "Main Secondary Diameter"
FabricationPartDiameterOutOption | "Main Secondary Diameter Option"
FabricationPartDoublewallMaterial | "Double Wall Material"
FabricationPartDoublewallMaterialArea | "Double Wall Material Area"
FabricationPartDoublewallMaterialThickness | "Double Wall Material Thickness"
FabricationPartInsulationArea | "Insulation Area"
FabricationPartItemNumber | "Item Number"
FabricationPartLength | "Length"
FabricationPartLengthOption | "Length Option"
FabricationPartLiningArea | "Lining Area"
FabricationPartMaterial | "Part Material"
FabricationPartMaterialThickness | "Part Material Thickness"
FabricationPartNotes | "Fabrication Notes"
FabricationPartPatNo | "Part Pattern Number"
FabricationPartSheetmetalArea | "Part Sheet Metal Area"
FabricationPartTakeoffDialogParam | "More Parameters"
FabricationPartWeight | "Weight"
FabricationPartWidthIn | "Main Primary Width"
FabricationPartWidthInOption | "Main Primary Width Option"
FabricationPartWidthOut | "Main Secondary Width"
FabricationPartWidthOutOption | "Main Secondary Width Option"
FabricationPipeInvertElevation | "Pipe Invert Elevation": This parameter is obsolete. It exists only for compatibility.
FabricationPrimarySize | "Size of Primary End"
FabricationProductCode | "Product Code"
FabricationProductDataFinishDescription | "Product Finish Description"
FabricationProductDataInstallType | "Install Type"
FabricationProductDataItemDescription | "Product Short Description"
FabricationProductDataLongDescription | "Product Long Description"
FabricationProductDataMaterialDescription | "Product Material Description"
FabricationProductDataOem | "OEM"
FabricationProductDataProduct | "Product Name"
FabricationProductDataRange | "Product Range"
FabricationProductDataSizeDescription | "Product Size Description"
FabricationProductDataSpecification | "Product Specification Description"
FabricationProductEntry | "Product Entry"
FabricationRelativeFilename | "Relative File Name"
FabricationRoutingSolutionsUiParam | "x of XX"
FabricationSecondarySize | "Size of Secondary End"
FabricationServiceAbbreviation | "Fabrication Service Abbreviation"
FabricationServiceName | "Fabrication Service Name"
FabricationServiceParam | "Fabrication Service"
FabricationSetUpDownTag | "SU/SD from Top"
FabricationSetUpDownTagFromBottom | "SU/SD from Bottom"
FabricationSlopeParam | "Slope"
FabricationSpecification | "Specification"
FabricationSpecificationAbbreviation | "Specification Abbreviation"
FabricationStartOffsetParam | "Start Middle Elevation"
FabricationTopElevationIncludeInsulationOfPart | "Top Elevation with Insulation"
FabricationTopElevationOfPart | "Top Elevation"
FabricationTopOfPart | "Upper End Top of Insulation Elevation"
FabricationVendor | "Vendor"
FabricationVendorCode | "Vendor Code"
FabricBendDiameter | "Bend Diameter": Standard Bend Diameter of Fabric Wire.
FabricNumber | "Fabric Number"
FabricParamCoverOffset | "Additional Cover Offset": Additional cover offset of the fabric distribution.
FabricParamCutByHost | "Cut by Host Cover": Single Fabric Sheet is cut or not cut by the Host Cover.
FabricParamCutOverallLength | "Cut Overall Length": Provides a real sheet Length after definition
FabricParamCutOverallWidth | "Cut Overall Width": Provides a real sheet Width after definition
FabricParamCutSheetMass | "Cut Sheet Mass": Calculated cut sheet mass [Sheet Mass per Unit Area * (Cut Overall Length * Cut Overall Width)]
FabricParamLapsplicePosition | "Lap Splice Position": Fabric lap splice position in the fabric distribution
FabricParamLocationGeneric | "Location": Fabric location in the host.
FabricParamLocationSlab | "Location": Fabric location in the slab
FabricParamLocationWall | "Location": Fabric location in the wall
FabricParamMajorLapspliceLength | "Major Lap Splice Length": Fabric lap splice length in major direction in the fabric distribution.
FabricParamMinorLapspliceLength | "Minor Lap Splice Length": Fabric lap splice length in minor direction in the fabric distribution.
FabricParamRounding | "Rounding Overrides"
FabricParamSharedFamilyKey | "Shared family key"
FabricParamSheetType | "Fabric Sheet": List all Fabric Sheet types
FabricParamSpanSymBottom | "Bottom"
FabricParamSpanSymDBottom | "D_Bottom"
FabricParamSpanSymDLeft | "D_Left"
FabricParamSpanSymDRight | "D_Right"
FabricParamSpanSymDTop | "D_Top"
FabricParamSpanSymLeft | "Left"
FabricParamSpanSymRight | "Right"
FabricParamSpanSymTop | "Top"
FabricParamSpanTagComponentReference | "Tag Component Reference"
FabricParamTagView | "Tag new members in view": List of all Plan Views and None.
FabricParamTotalSheetMass | "Total Sheet Mass": Calculated all sheet mass: Volume of Wire * Unit Weight.
FabricSheetDefaultMajorLapspliceLength | "Default Major Lap Splice Length": Default Major Lap Splice Length
FabricSheetDefaultMinorLapspliceLength | "Default Minor Lap Splice Length": Default Minor Lap Splice Length
FabricSheetLength | "Length": Length
FabricSheetMajorDirectionWireType | "Major Direction Wire Type": Major Direction Wire Type
FabricSheetMajorEndOverhang | "Major End Overhang": Major End Overhang
FabricSheetMajorLayoutPattern | "Major Layout Pattern": Major Layout Pattern
FabricSheetMajorNumberOfWires | "Major Number of Wires": Major Number of Wires
FabricSheetMajorReinforcementArea | "Major Reinforcement Area": Major Reinforcement Area
FabricSheetMajorSpacing | "Major Spacing": Major Spacing
FabricSheetMajorStartOverhang | "Major Start Overhang": Major Start Overhang
FabricSheetMass | "Sheet Mass": Sheet Mass
FabricSheetMassunit | "Sheet Mass per Unit Area": Structural Sheet Mass per Unit Area [Sheet Mass / (Overall Length * Overall Width)]
FabricSheetMinorDirectionWireType | "Minor Direction Wire Type": Minor Direction Wire Type
FabricSheetMinorEndOverhang | "Minor End Overhang": Minor End Overhang
FabricSheetMinorLayoutPattern | "Minor Layout Pattern": Minor Layout Pattern
FabricSheetMinorNumberOfWires | "Minor Number of Wires": Minor Number of Wires
FabricSheetMinorReinforcementArea | "Minor Reinforcement Area": Minor Reinforcement Area
FabricSheetMinorSpacing | "Minor Spacing": Minor Spacing
FabricSheetMinorStartOverhang | "Minor Start Overhang": Minor Start Overhang
FabricSheetOverallLength | "Overall Length": Overall Length
FabricSheetOverallWidth | "Overall Width": Overall Width
FabricSheetPhysicalMaterialAsset | "Physical Material Asset": Physical Material Asset
FabricSheetWidth | "Width": Width
FabricWireDiameter | "Nominal Diameter": Nominal Diameter of Fabric Wire.
FabricWireDistance | "Wire distance": The distance between wires
FabricWireLength | "Wire length": The wire length
FabricWireOffset | "Offset along wire direction": Offset along wire direction
FabricWireType | "Wire type": The wire type assigned
FaceroofLevelParam | "Reference Level"
FaceroofOffsetParam | "Level Offset"
FamilyAllowCutWithVoids | "Cut with Voids When Loaded"
FamilyAlwaysVertical | "Always vertical"
FamilyAutojoin | "Automatically joins geometry to walls"
FamilyBaseLevelOffsetParam | "Base Offset"
FamilyBaseLevelParam | "Base Level"
FamilyCanHostRebar | "Can host rebar"
FamilyCategoryPseudoParam | "Category"
FamilyContentPartType | "Part Type"
FamilyCurveAttachmentProportion | "Attachment Point"
FamilyCurveGstyleFor2010Mass | "Subcategory"
FamilyCurveGstylePlusInvisible | "Subcategory"
FamilyCurveGstylePlusInvisibleMinusAnalytical | "Subcategory"
FamilyCurveGstylePlusInvisiblePlusStickSym | "Subcategory"
FamilyCurveGstylePlusInvisiblePlusStickSymMinusAnalytical | "Subcategory"
FamilyElectricalMaintainAnnotationOrientation | "Maintain Annotation Orientation"
FamilyElemSubcategory | "Subcategory"
FamilyEnableCuttingInViews | "Enable Cutting in Views"
FamilyExportAsGeometry | "Always export as geometry"
FamilyFreeinstDefaultElevation | "Default Elevation"
FamilyHeightParam | "Height"
FamilyHostingBehavior | "Host"
FamilyIsElevationMarkBody | "Elevation Mark Use"
FamilyIsParametric | "Is parametric"
FamilyKeepTextReadable | "Keep text readable"
FamilyKeyExtParam | "Filter Parameter"
FamilyKeywordProtected | "Content protection enabled"
FamilyLevelParam | "Level"
FamilyLineLengthParam | "Length"
FamilyNamePseudoParam | "Family"
FamilyNestingBehavior | "Family Nesting Behavior"
FamilyRenderingType | "Render Appearance Source"
FamilyRfaPathPseudoParam | "File Path"
FamilyRotateTextWithComponent | "Rotate text with component"
FamilyRotateWithComponent | "Rotate with component"
FamilyRoughHeightParam | "Rough Height"
FamilyRoughWidthParam | "Rough Width"
FamilyRoundconnectorDimensiontype | "Round Connector Dimension"
FamilySelfOrienting | "Align to View"
FamilyShared | "Shared"
FamilyStructFootingUseCapTop | "Cap"
FamilyStructMaterialType | "Material for Model Behavior"
FamilySymbolicRep | "Symbolic Representation"
FamilyThicknessParam | "Thickness"
FamilyTopLevelOffsetParam | "Top Offset"
FamilyTopLevelParam | "Top Level"
FamilyUsagePseudoParam | "Usage"
FamilyUsePrecutShape | "Show family pre-cut in plan views"
FamilyUsingMultiple | "Multiple Join"
FamilyWidthParam | "Width"
FamilyWindowInsetParam | "Inset"
FamilyWorkPlaneBased | "Work Plane-Based"
FamilyWpbDefaultElevation | "Default Elevation"
FamProfileDefinition | "Profile Definition"
FamProfileUsage | "Profile Usage"
FasciaDepthParam | "Fascia Depth"
FasciaMaterialParam | "Material"
FasciaProfileParam | "Profile"
FbxAssetType | "Light Source"
FbxLightAtADistance | "At a distance"
FbxLightBallastLoss | "Ballast Loss"
FbxLightColorFilter | "Color Filter"
FbxLightDimmingLightColor | "Dimming Lamp Color Temperature Shift"
FbxLightEfficacy | "Efficacy"
FbxLightEmitCircleDiameter | "Emit from Circle Diameter"
FbxLightEmitLineLength | "Emit from Line Length"
FbxLightEmitRectangleLength | "Emit from Rectangle Length"
FbxLightEmitRectangleWidth | "Emit from Rectangle Width"
FbxLightEmitShapeVisible | "Emit Shape Visible in Rendering"
FbxLightIlluminance | "Illuminance"
FbxLightInitialColorCtrl | "Initial Color"
FbxLightInitialColorName | "Temperature Color"
FbxLightInitialColorTemperature | "Initial Color Temperature"
FbxLightInitialIntensity | "Initial Intensity"
FbxLightInitialIntensityInputMethod | "Initial Light Intensity Input Method"
FbxLightLampLumenDepr | "Lamp Lumen Depreciation"
FbxLightLampTiltLoss | "Lamp Tilt Loss"
FbxLightLimunousFlux | "Luminous Flux"
FbxLightLimunousIntensity | "Luminous Intensity"
FbxLightLossFactorCtrl | "Light Loss Factor"
FbxLightLossFactorMethod | "Light Loss Input Method"
FbxLightLumenaireDirt | "Luminaire Dirt Depreciation"
FbxLightPhotometricFile | "Photometric Web File"
FbxLightPhotometricFileCache | "None"
FbxLightPhotometrics | "Light Source Definition"
FbxLightPhotometricsFam | "Light Source Definition (family)"
FbxLightSourceDiameter | "Light Source Symbol Size"
FbxLightSourceLength | "Light Source Symbol Length"
FbxLightSpotBeamAngle | "Spot Beam Angle"
FbxLightSpotFieldAngle | "Spot Field Angle"
FbxLightSpotTiltAngle | "Tilt Angle"
FbxLightSurfaceLoss | "Surface Depreciation Loss"
FbxLightTemperatureLoss | "Temperature Loss"
FbxLightTotalLightLoss | "Total Light Loss Factor"
FbxLightVoltageLoss | "Voltage Loss"
FbxLightWattage | "Wattage"
FilledRegionMasking | "Masking"
FillPatternIdParam | "Cut fill pattern"
FillPatternIdParamNoNo | "Fill Pattern"
FireRating | "Fire Rating"
FixedRotation | "Fixed Rotation"
FlexibleInstanceFlip | "Flip"
FloorAttrDefaultHeightParam | "Default Height above level"
FloorAttrDefaultThicknessParam | "Default Thickness"
FloorAttrThicknessParam | "Thickness"
FloorHeightabovelevelParam | "Height Offset From Level"
FloorParamIsStructural | "Structural"
FloorParamSpanDirection | "Span Direction"
FloorStructureIdParam | "Structure"
FollowSurface | "Follow Surface"
ForegroundAnyPatternIdParam | "Foreground Fill Pattern"
ForegroundDraftPatternIdParam | "Foreground Fill Pattern"
ForegroundPatternColorParam | "Foreground Pattern Color"
FramingLengthRoundoff | "Structural Framing Length Roundoff"
FramingShapeClassification | "Framing Shape"
FrictionFactor | "Friction Factor"
FunctionParam | "Function"
GbxmlEditDataParam | "Energy Settings"
GenericDepth | "Depth"
GenericZoneName | "Name"
GeoLocation | "Shared Site"
GeomVisibilityParam | "Visibility/Graphics Overrides"
GraphicDisplayOptions | "Graphic Display Options"
GraphicDisplayOptionsBackground | "Background"
GraphicDisplayOptionsFog | "Depth Cueing"
GraphicDisplayOptionsLighting | "Lighting"
GraphicDisplayOptionsModel | "Model Display"
GraphicDisplayOptionsPhotoExposure | "Photographic Exposure"
GraphicDisplayOptionsShadows | "Shadows"
GraphicDisplayOptionsSketchyLines | "Sketchy Lines"
GraphicDisplayOptionsSsIntensity | "Sun and Shadow Intensity"
GridBankColNum | "Column"
GridBankColWidth | "Column Distance"
GridBankRowHeight | "Row Distance"
GridBankRowNum | "Row"
GridBubbleEndn1 | "Plan View Symbols End 1 (Default)"
GridBubbleEndn2 | "Plan View Symbols End 2 (Default)"
GridBubbleLinePen | "Bubble Weight Number\n"
GridCenterSegmentColor | "Center Segment Color"
GridCenterSegmentPattern | "Center Segment Pattern"
GridCenterSegmentStyle | "Center Segment"
GridCenterSegmentWeight | "Center Segment Weight"
GridEndSegmentColor | "End Segment Color"
GridEndSegmentPattern | "End Segment Pattern"
GridEndSegmentsLength | "End Segments Length"
GridEndSegmentWeight | "End Segment Weight"
GridHeadTag | "Symbol"
GridlineSpecStatus | "Type Association"
GridNetLocationMark | "Location Mark": Provides grid system association information
GroupAllowedViewTypes | "Allowed View Types"
GroupAttachedParentName | "Attached to"
GroupLevel | "Reference Level"
GroupnameParam | "Group Name for Ribbon Combo Items (for Use with XAML)"
GroupOffsetFromLevel | "Origin Level Offset"
GuideGridNameParam | "Name"
GuideGridSpacingParam | "Guide Spacing"
GutterMaterialParam | "Material"
GutterProfileParam | "Profile"
HandrailHandClearanceParam | "Hand Clearance"
HandrailHeightParam | "Height"
HandrailProjectionParam | "Projection"
HandrailSupportsJustificationParam | "Justification"
HandrailSupportsLayoutParam | "Layout"
HandrailSupportsNumberParam | "Number"
HandrailSupportsSpacingParam | "Spacing"
HandrailSupportsTypeParam | "Family"
HeadOnPlacementMethod | "Draw in Foreground"
HeavyEndPen | "Heavy End Pen Weight"
HeavyTickMarkPen | "Heavy End Pen Weight"
HighestAssociatedLevel | "Highest Associated Level": The highest level associated with this Analytical Element.
HostAreaComputed | "Area"
HostIdParam | "Host Id"
HostPanelScheduleAsPanelParam | "Categorize as"
HostPerimeterComputed | "Perimeter"
HostSseCurvedEdgeConditionParam | "Curved Edge Condition"
HostVolumeComputed | "Volume"
IconIndexParam | "Index Into Image File Name Array (for Use with XAML)"
IdParam | "Id"
IfcApplicationName | "IfcApplicationName"
IfcApplicationVersion | "IfcApplicationVersion"
IfcBuildingGuid | "IfcBuilding GUID"
IfcExportElement | "Export to IFC"
IfcExportElementAs | "Export to IFC As"
IfcExportElementType | "Export Type to IFC"
IfcExportElementTypeAs | "Export Type to IFC As"
IfcExportPredefinedtype | "IFC Predefined Type"
IfcExportPredefinedtypeType | "Type IFC Predefined Type"
IfcGuid | "IfcGUID"
IfcImportMaterialName | "IFC Material Name"
IfcOrganization | "IfcOrganization"
IfcProjectGuid | "IfcProject GUID"
IfcSiteGuid | "IfcSite GUID"
IfcTypeGuid | "Type IfcGUID"
ImportAdtComponentsDesc | "Component Description"
ImportAdtEntityHeight | "Height"
ImportAdtEntityLength | "Length"
ImportAdtEntityRoll | "Roll"
ImportAdtEntityStructType | "Structural Type Name"
ImportAdtEntityStyle | "Style Name"
ImportAdtEntityThickness | "Thickness"
ImportAdtEntityType | "Type Name"
ImportAdtEntityWidth | "Width"
ImportBackground | "Draw Layer"
ImportBaseLevel | "Work Plane"
ImportBaseLevelOffset | "Offset from Work Plane"
ImportDisplayUnits | "Import Units"
ImportInstanceCuttingInView | "Enable Cutting in Views"
ImportInstanceScale | "Instance Scale"
ImportScale | "Scale Factor"
ImportSymbolName | "Name"
IndividualExcavationVolume | "Individual Excavation Volume"
InfrastructureAlignmentDescription | "Description"
InfrastructureAlignmentDisplayedEndStation | "Displayed End Station"
InfrastructureAlignmentDisplayedStartStation | "Displayed Start Station"
InfrastructureAlignmentName | "Name"
InsertOrientation | "Orientation"
InstanceElevationParam | "Elevation from Level"
InstanceFreeHostOffsetParam | "Offset from Host"
InstanceFreeHostParam | "Host"
InstanceHeadHeightParam | "Head Height"
InstanceLengthParam | "Length"
InstanceMoveBaseWithGrids | "Move Base With Grids"
InstanceMovesWithGridParam | "Moves With Grids"
InstanceMoveTopWithGrids | "Move Top With Grids"
InstanceOffsetPosParam | "Moves With Nearby Elements"
InstanceReferenceLevelParam | "Reference Level"
InstanceScheduleOnlyLevelParam | "Schedule Level"
InstanceSillHeightParam | "Sill Height"
InstanceStructUsageParam | "Structural Usage"
InsulationScale | "Insulation Bulge to Width Ratio (1/x)"
InsulationWidth | "Insulation Width"
InteriorTickDisplay | "Interior Tick Mark Display"
IsVisibleParam | "Visible"
JoinStrengthOrder | "Abstract Join Strength Order"
JoistSystemClearSpacingParam | "Clear Spacing"
JoistSystemElemTagNewMembersView | "Tag new members in view"
JoistSystemFixedSpacingParam | "Fixed Spacing"
JoistSystemJustificationParam | "Justification"
JoistSystemLayoutRuleParam | "Layout Rule"
JoistSystemMaximumSpacingParam | "Maximum Spacing"
JoistSystemNewBeamTypeNoFamNameParam | "Beam Type (No Family Name)"
JoistSystemNewBeamTypeParam | "Beam Type"
JoistSystemNumBeamsSameType | "Num. of Beams With Same Type"
JoistSystemNumberOfLinesParam | "Number of Lines"
JoistSystemSpacingParam | "Centerline Spacing"
KeepReadable | "Keep Readable"
KeynoteNumber | "Key Value"
KeynoteParam | "Keynote"
KeynoteText | "Keynote Text"
KeySourceParam | "Key Source"
KeyValue | "Key Value"
LayerElemAreaComputed | "Area"
LayerElemBaseConstraint | "Base Constraint"
LayerElemBaseExtensionDis | "Base Extension Distance"
LayerElemCompoundElemFamily | "Compound Element Family"
LayerElemCompoundElemType | "Compound Element Type"
LayerElemFunction | "Function": Function
LayerElemIsCoreLayer | "Is Core Layer"
LayerElemIsStructuralMaterial | "Is Structural Material"
LayerElemIsVariable | "Is Variable"
LayerElemMaterials | "Material": Material
LayerElemOffsetFromHost | "Offset From Host"
LayerElemScheduleFamily | "Family"
LayerElemThickness | "Thickness": Thickness
LayerElemTopConstraint | "Top Constraint"
LayerElemTopExtensionDis | "Top Extension Distance"
LayerElemVolumeComputed | "Volume"
LayerTypeMaterials | "Material": Material
LayerTypeThickness | "Thickness": Thickness
LayoutnodeCurvetypeParam | "Curve Type Reference"
LeaderArrowhead | "Leader Arrowhead"
LeaderArrowWidth | "Arrow Width Angle"
LeaderLeftAttachment | "Left Attachment"
LeaderLength | "Leader Length"
LeaderLine | "Leader Line"
LeaderOffsetSheet | "Leader/Border Offset"
LeaderRightAttachment | "Right Attachment"
LegendComponent | "Component Type"
LegendComponentDetailLevel | "Detail Level"
LegendComponentLength | "Host Length"
LegendComponentView | "View Direction"
LevelAttrRoomComputationAutomatic | "Automatic Room Computation Height"
LevelAttrRoomComputationHeight | "Computation Height"
LevelDataFloorArea | "Floor Area"
LevelDataFloorPerimeter | "Floor Perimeter"
LevelDataMassFamilyAndTypeParam | "Mass: Family and Type"
LevelDataMassFamilyParam | "Mass: Family"
LevelDataMassInstanceComments | "Mass: Comments"
LevelDataMassTypeComments | "Mass: Type Comments"
LevelDataMassTypeDescription | "Mass: Description"
LevelDataMassTypeParam | "Mass: Type"
LevelDataOwningLevel | "Level"
LevelDataSpaceUsage | "Usage"
LevelDataSurfaceArea | "Exterior Surface Area"
LevelDataVolume | "Floor Volume"
LevelElev | "Elevation"
LevelHeadTag | "Symbol"
LevelIsBuildingStory | "Building Story"
LevelIsGroundPlane | "Is ground plane"
LevelIsStructural | "Structural"
LevelName | "Level"
LevelParam | "Level"
LevelRelativeBaseType | "Elevation Base"
LevelRoomComputationHeight | "Computation Height"
LevelUpToLevel | "Story Above"
LightingFixtureLamp | "Lamp"
LightingFixtureLightEmitter | "Light Emitter"
LightingFixtureWattage | "Wattage Comments"
LinearDimType | "Dimension String Type"
LinearFramingLength | "Length"
LineColor | "Color"
LinePattern | "Line Pattern"
LinePen | "Line Weight"
LineShapeAtCorner | "Line Shape at Landing Corner"
LoadAllNon0Loads | "All non 0 loads"
LoadAreaArea | "Area"
LoadAreaForceFx1 | "Fx 1"
LoadAreaForceFx2 | "Fx 2"
LoadAreaForceFx3 | "Fx 3"
LoadAreaForceFy1 | "Fy 1"
LoadAreaForceFy2 | "Fy 2"
LoadAreaForceFy3 | "Fy 3"
LoadAreaForceFz1 | "Fz 1"
LoadAreaForceFz2 | "Fz 2"
LoadAreaForceFz3 | "Fz 3"
LoadAreaIsProjected | "Projected Load"
LoadArrowSeparation | "Distance between arrows"
LoadAttrAreaForceScaleFactor | "Area force scale"
LoadAttrForceArrowType | "Force arrowhead"
LoadAttrForceScaleFactor | "Force scale"
LoadAttrLinearForceScaleFactor | "Linear force scale"
LoadAttrMomentArrowArc | "Moment arrowhead"
LoadAttrMomentArrowLine | "Moment arrowhead (alternate)"
LoadAttrMomentScaleFactor | "Moment scale"
LoadCaseId | "Load Case"
LoadCaseName | "Name"
LoadCaseNature | "Nature"
LoadCaseNatureText | "Nature"
LoadCaseNumber | "Case Number"
LoadCaseSubcategory | "Category"
LoadCombinationFactor | "Factor"
LoadCombinationName | "Name"
LoadComments | "Comments"
LoadDescription | "Description"
LoadForceFx | "Fx"
LoadForceFy | "Fy"
LoadForceFz | "Fz"
LoadIsConstrainedOnHost | "Is constrained on host"
LoadIsHosted | "Is Hosted"
LoadIsProjected | "Projected Load"
LoadIsReaction | "Is Reaction"
LoadIsUniform | "Uniform Load"
LoadLinearForceFx1 | "Fx 1"
LoadLinearForceFx2 | "Fx 2"
LoadLinearForceFy1 | "Fy 1"
LoadLinearForceFy2 | "Fy 2"
LoadLinearForceFz1 | "Fz 1"
LoadLinearForceFz2 | "Fz 2"
LoadLinearLength | "Length"
LoadMomentMx | "Mx"
LoadMomentMx1 | "Mx 1"
LoadMomentMx2 | "Mx 2"
LoadMomentMy | "My"
LoadMomentMy1 | "My 1"
LoadMomentMy2 | "My 2"
LoadMomentMz | "Mz"
LoadMomentMz1 | "Mz 1"
LoadMomentMz2 | "Mz 2"
LoadNatureName | "Name"
LoadUsageName | "Name"
LoadUseLocalCoordinateSystem | "Orient to"
LockAlignmentUiToggle | "Lock": This is used by the UI to allow selection of lock alignment.
LockedBaseOffset | "Negative Offset"
LockedEndOffset | "Positive Offset"
LockedStartOffset | "Negative Offset"
LockedTopOffset | "Positive Offset"
LowestAssociatedLevel | "Lowest Associated Level": The lowest level associated with this Analytical Element.
LvMullionLeg1 | "Leg 1"
LvMullionLeg2 | "Leg 2"
MarkupsCreated | "Created"
MarkupsCreator | "Creator"
MarkupsHistory | "History"
MarkupsLabel | "Label"
MarkupsModified | "Modified"
MarkupsNotes | "Notes"
MarkupsPrivate | "Private"
MarkupsStatus | "Status"
MassDataConceptualConstruction | "Conceptual Types"
MassDataGlazingIsShaded | "Glazing is Shaded"
MassDataMassExteriorWallArea | "Mass Exterior Wall Area"
MassDataMassInteriorWallArea | "Mass Interior Wall Area"
MassDataMassOpeningArea | "Mass Opening Area"
MassDataMassRoofArea | "Mass Roof Area"
MassDataMassSkylightArea | "Mass Skylight Area"
MassDataMassWindowArea | "Mass Window Area"
MassDataPercentageGlazing | "Target Percentage Glazing"
MassDataPercentageSkylights | "Target Percentage Skylights"
MassDataShadeDepth | "Shade Depth"
MassDataSillHeight | "Target Sill Height"
MassDataSkylightWidth | "Skylight Width & Depth"
MassDataSlab | "Slab"
MassDataSubcategory | "Subcategory"
MassDataSurfaceDataSource | "Values"
MassDataUnderground | "Underground"
MassFloorAreaLevels | "Mass Floors"
MassGrossArea | "Gross Floor Area"
MassGrossSurfaceArea | "Gross Surface Area"
MassGrossVolume | "Gross Volume"
MassingIntegrationLevel | "Constrain to Massing"
MassSurfacedataMaterial | "Graphical Appearance"
MassZoneConditionTypeParam | "Condition Type"
MassZoneFloorArea | "Mass Floor Area"
MassZoneMaterial | "Graphical Appearance"
MassZoneSpaceTypeParam | "Space Type"
MassZoneVolume | "Mass Zone Volume"
MatchlineBottomOffset | "Bottom Offset"
MatchlineBottomPlane | "Bottom Constraint"
MatchlineTopOffset | "Top Offset"
MatchlineTopPlane | "Top Constraint"
MaterialArea | "Area"
MaterialAspaint | "As Paint"
MaterialAssetParamAssetLibId | "Asset library id"
MaterialAssetParamCommonSharedAsset | "Sharing"
MaterialAssetParamExternalMaterialId | "External Material ID"
MaterialAssetParamSource | "Source"
MaterialAssetParamSourceUrl | "Source URL"
MaterialIdParam | "Material"
MaterialName | "Name"
MaterialParamColor | "Color"
MaterialParamGlow | "Glow"
MaterialParamShininess | "Shininess"
MaterialParamSmoothness | "Smoothness"
MaterialParamTransparency | "Transparency"
MaterialVolume | "Volume"
MeasureFromStructure | "Extend into wall (to core)"
MechanicalEquipmentSetIdParam | "Mechanical Equipment Set"
MechanicalEquipmentSetName | "Name"
MechanicalEquipmentSetOnDuty | "On Duty"
MechanicalEquipmentSetOnStandby | "On Standby"
MepAirloopFantype | "Fan"
MepAirloopHeatexchangerType | "Heat Exchanger"
MepAirloopPreheatCoiltype | "Preheat Coil"
MepAnalyticalCriticalpathParam | "Critical Path"
MepAnalyticalCriticalsequence | "Critical Sequence"
MepAnalyticalElecApparentPowerRating | "Apparent Power Rating"
MepAnalyticalElecCurrent | "Current"
MepAnalyticalElecCurrentRating | "Current Rating"
MepAnalyticalElecVoltage | "Voltage"
MepAnalyticalEquipmentName | "Name"
MepAnalyticalHeadersegment | "Header"
MepAnalyticalHydraulicloop | "Hydraulic Loop"
MepAnalyticalLoopBoundaryParam | "Loop Boundary"
MepAnalyticalLoopName | "Name"
MepAnalyticalNetwork | "Network Id"
MepAnalyticalPipeDesignflow | "Design Flow"
MepChilledWaterLoop | "Chilled Water Loop"
MepCondenserWaterLoop | "Condenser Water Loop"
MepCoolingCoilType | "Cooling Coil"
MepElecZoneEquipmentType | "Equipment Type"
MepEquipmentCalcPipingflowParam | "Calculated Flow"
MepEquipmentCalcPipingpressuredropParam | "Calculated Pressure Drop"
MepEquipmentClassification | "Classification"
MepHeatingCoilType | "Heating Coil"
MepHeatingHotwaterLoop | "Heating Hot Water Loop"
MepIgnoreFlowAnalysis | "Ignore Flow Analysis"
MepLowerBottomElevation | "Lower End Bottom Elevation"
MepLowerBottomElevationIncludeInsulation | "Lower End Bottom of Insulation Elevation"
MepLowerCenterlineElevation | "Lower End Centerline Elevation"
MepLowerTopElevation | "Lower End Top Elevation"
MepLowerTopElevationIncludeInsulation | "Lower End Top of Insulation Elevation"
MepPipeLowerInvertElevation | "Lower End Invert Elevation"
MepPipeLowerObvertElevation | "Lower End Obvert Elevation"
MepPipeUpperInvertElevation | "Upper End Invert Elevation"
MepPipeUpperObvertElevation | "Upper End Obvert Elevation"
MepPreheatHotwaterLoop | "Preheat Hot Water Loop"
MepProfileTypeParam | "Shape"
MepReheatCoilType | "Reheat Coil"
MepReheatHotwaterLoop | "Reheat Hot Water Loop"
MepSegmentElementTypename | "Type Name"
MepSegmentFamilyname | "Family Name"
MepSegmentLength | "Analytical Length"
MepSegmentSystemorservice | "System Type/Service Name"
MepSpotBottomElevation | "Spot Bottom Elevation": used for both design and fabrication components
MepSpotBottomElevationIncludeInsulation | "Spot Bottom of Insulation Elevation"
MepSpotCenterlineElevation | "Spot Centerline Elevation": used for both design and fabrication components
MepSpotTopElevation | "Spot Top Elevation": used for both design and fabrication components
MepSpotTopElevationIncludeInsulation | "Spot Top of Insulation Elevation"
MepSystemFillGraphicsOverridesParam | "Fill Pattern Graphics Overrides"
MepSystemLineGraphicsOverridesParam | "Graphic Overrides"
MepUpperBottomElevation | "Upper End Bottom Elevation"
MepUpperBottomElevationIncludeInsulation | "Upper End Bottom of Insulation Elevation"
MepUpperCenterlineElevation | "Upper End Centerline Elevation"
MepUpperTopElevation | "Upper End Top Elevation"
MepUpperTopElevationIncludeInsulation | "Upper End Top of Insulation Elevation"
MepVrfLoop | "Variable Refrigerant Flow Loop"
MepWaterloopChillertype | "Chiller Type"
MepWaterloopType | "Loop Type"
MepZoneAirLoop | "Air System"
MepZoneEquipment | "Zone Equipment"
MepZoneEquipmentBehavior | "Behavior"
MepZoneEquipmentDrawVentilation | "Draw Ventilation"
MepZoneEquipmentType | "Equipment Type"
MepZoneHotwaterLoop | "Heating Hot Water Loop"
ModelCategoryIdParam | "Subcategory"
ModelGraphicsStyle | "Visual Style"
ModelGraphicsStyleAnonDraft | "Visual Style"
ModelOrSymbolic | "Model or Symbolic"
ModelTextSize | "Text Size"
MovesWithGridParam | "Moves With Grids": Disable attachment from grids.
MullionAngle | "Angle"
MullionCornerType | "Corner Mullion"
MullionDepth | "Depth"
MullionDepth1 | "Depth 1"
MullionDepth2 | "Depth 2"
MullionFamType | "Mullion Family General Shape"
MullionOffset | "Offset"
MullionPosition | "Position"
MullionProfile | "Profile"
MultipleAlignmentUiToggle | "Multiple Alignment": This is used by the UI to allow selection of multiple elements.
MultiReferenceAnnotationDimensionStyle | "Dimension Style"
MultiReferenceAnnotationGroupTagHeads | "Group Matching Tag Heads"
MultiReferenceAnnotationReferenceCategory | "Reference Category"
MultiReferenceAnnotationShowDimensionText | "Show Dimension Text"
MultiReferenceAnnotationTagType | "Tag Family"
MultistoryStairsActualTreadDepth | "Actual Tread Depth"
MultistoryStairsRefLevel | "Reference Level": The reference level of stairs
NodeConnectionStatus | "Connection Status"
NumberPartitionParam | "Partition"
NumberSystemDisplayRule | "Display Rule"
NumberSystemJustify | "Justify"
NumberSystemJustifyOffset | "Justify Offset"
NumberSystemOrientation | "Orientation"
NumberSystemReference | "Reference"
NumberSystemReferenceOffset | "Offset from Reference"
NumberSystemTagType | "Tag Type"
NumberSystemTextSize | "Number Size"
ObjectStyleMaterialIdParam | "Object Style Material"
OffsetfacesShowShapeHandles | "Show Shape Handles"
OffsetFromReferenceBase | "Offset from Reference Base"
OmniclassCode | "OmniClass Number"
OmniclassDescription | "OmniClass Title"
OptionName | "Name"
OptionSetId | "Design Option Set Id"
OptionSetName | "Name"
OrdinateDimSetting | "Ordinate Dimension Settings"
OrientByView | "Rotate With Text"
OriginatingElementName | "Originating Element"
OvalFramingHeight | "Oval Height"
OvalFramingWidth | "Oval Width"
PaddingLength | "Padding"
PanelScheduleName | "Panel Schedule Name"
PartMakerDivisionProfileOffset | "Profile Offset"
PartmakerParamDivisionGap | "Gap"
PartMakerSplitterProfile | "Division Profile"
PartMakerSplitterProfileEdgeMatch | "Edge Match"
PartMakerSplitterProfileFlipAcross | "Profile Across Flip"
PartMakerSplitterProfileFlipAlong | "Profile Along Flip"
PathOfTravelFromRoom | "From Room"
PathOfTravelLevelName | "Level"
PathOfTravelSpeed | "Speed"
PathOfTravelTime | "Time"
PathOfTravelToRoom | "To Room"
PathOfTravelViewName | "View Name"
PathReinAddlOffset | "Additional Offset"
PathReinAlternating | "Alternating Bars"
PathReinAltOffset | "Alternating Bar - Offset"
PathReinEndHookOrient1Slab | "Primary Bar - End Hook Orientation"
PathReinEndHookOrient1Wall | "Primary Bar - End Hook Orientation"
PathReinEndHookOrient2Slab | "Alternating Bar - End Hook Orientation"
PathReinEndHookOrient2Wall | "Alternating Bar - End Hook Orientation"
PathReinEndHookTypen1 | "Primary Bar - End Hook Type"
PathReinEndHookTypen2 | "Alternating Bar - End Hook Type"
PathReinEndSpanhookAlt | "End Hook Angle Alternating"
PathReinEndSpanhookPrim | "End Hook Angle Primary"
PathReinFaceSlab | "Face"
PathReinFaceWall | "Face"
PathReinHookOrient1Slab | "Primary Bar - Hook Orientation"
PathReinHookOrient1Wall | "Primary Bar - Hook Orientation"
PathReinHookOrient2Slab | "Alternating Bar - Hook Orientation"
PathReinHookOrient2Wall | "Alternating Bar - Hook Orientation"
PathReinHookTypen1 | "Primary Bar - Start Hook Type"
PathReinHookTypen2 | "Alternating Bar - Start Hook Type"
PathReinLengthn1 | "Primary Bar - Length"
PathReinLengthn2 | "Alternating Bar - Length"
PathReinNumberOfBars | "Number Of Bars"
PathReinShapen1 | "Primary Bar - Shape"
PathReinShapen2 | "Alternating Bar - Shape"
PathReinSpacing | "Bar Spacing"
PathReinSpanhookAlt | "Start Hook Angle Alternating"
PathReinSpanhookPrim | "Start Hook Angle Primary"
PathReinSpanlengthAltOffset | "Offset"
PathReinSpanlengthBarlengthAlt | "Length (Alternating Bar)"
PathReinSpanlengthBarlengthPrim | "Length (Primary Bar)"
PathReinSpanlengthBottomAlt | "Bottom (Alternating Bar)"
PathReinSpanlengthBottomPrim | "Bottom (Primary Bar)"
PathReinSpanlengthTopAlt | "Top (Alternating Bar)"
PathReinSummary | "Summary"
PathReinTypen1 | "Primary Bar - Type"
PathReinTypen2 | "Alternating Bar - Type"
PatternIndent1ForDivisionRule | "Indent 1"
PatternIndent2ForDivisionRule | "Indent 2"
PatternMirrorForDivisionRule | "Mirror"
PeakAirflowParam | "Peak Airflow"
PeakCoolingLoadParam | "Peak Cooling Load"
PeakHeatingLoadParam | "Peak Heating Load"
PeakLatentCoolingLoad | "Peak Latent Cooling Load"
PhaseCreated | "Phase Created"
PhaseDemolished | "Phase Demolished"
PhaseName | "Name"
PhaseSequenceNumber | "Sequence Number"
PhyMaterialParamAverageModulus | "Average Modulus"
PhyMaterialParamBehavior | "Behavior"
PhyMaterialParamBending | "Bending"
PhyMaterialParamBendingReinforcement | "Bending reinforcement"
PhyMaterialParamClass | "Class"
PhyMaterialParamCompressionParallel | "Compression parallel to grain"
PhyMaterialParamCompressionPerpendicular | "Compression perpendicular to grain"
PhyMaterialParamConcreteCompression | "Concrete compression"
PhyMaterialParamExpCoeff | "Thermal expansion coefficient"
PhyMaterialParamExpCoeff1 | "Thermal expansion coefficient X"
PhyMaterialParamExpCoeff2 | "Thermal expansion coefficient Y"
PhyMaterialParamExpCoeff3 | "Thermal expansion coefficient Z"
PhyMaterialParamExpCoeffn1 | "Thermal Expansion Coefficient 1"
PhyMaterialParamExpCoeffn2 | "Thermal Expansion Coefficient 2"
PhyMaterialParamFivepercentModulusOfElacticity | "5% Modulus of Elasticity"
PhyMaterialParamGrade | "Grade"
PhyMaterialParamLightWeight | "Lightweight"
PhyMaterialParamMinimumTensileStrength | "Minimum tensile strength"
PhyMaterialParamMinimumYieldStress | "Minimum yield stress"
PhyMaterialParamPoissonMod | "Poisson ratio"
PhyMaterialParamPoissonMod1 | "Poisson ratio X"
PhyMaterialParamPoissonMod12 | "Poisson Ratio 12"
PhyMaterialParamPoissonMod2 | "Poisson ratio Y"
PhyMaterialParamPoissonMod23 | "Poisson Ratio 23"
PhyMaterialParamPoissonMod3 | "Poisson ratio Z"
PhyMaterialParamReductionFactor | "Reduction factor for shear"
PhyMaterialParamResistanceCalcStrength | "Resistance calculation strength"
PhyMaterialParamShearMod | "Shear modulus"
PhyMaterialParamShearMod1 | "Shear modulus X"
PhyMaterialParamShearMod12 | "Shear Modulus 12"
PhyMaterialParamShearMod2 | "Shear modulus Y"
PhyMaterialParamShearMod3 | "Shear modulus Z"
PhyMaterialParamShearParallel | "Shear parallel to grain"
PhyMaterialParamShearPerpendicular | "Shear perpendicular to grain"
PhyMaterialParamShearReinforcement | "Shear reinforcement yield stress"
PhyMaterialParamShearStrengthReduction | "Shear strength modification"
PhyMaterialParamSpecies | "Species"
PhyMaterialParamStructuralDensity | "Density"
PhyMaterialParamStructuralSpecificHeat | "Specific Heat"
PhyMaterialParamStructuralThermalTreated | "Thermally Treated"
PhyMaterialParamSubclass | "Subclass"
PhyMaterialParamTensionParallel | "Tension Parallel to Grain"
PhyMaterialParamTensionPerpendicular | "Tension Perpendicular to Grain"
PhyMaterialParamThermalConductivity | "Thermal Conductivity"
PhyMaterialParamThermalConductivityX | "Thermal Conductivity X"
PhyMaterialParamThermalConductivityY | "Thermal Conductivity Y"
PhyMaterialParamThermalConductivityZ | "Thermal Conductivity Z"
PhyMaterialParamType | "Material Type"
PhyMaterialParamUnitWeight | "Unit weight"
PhyMaterialParamWoodConstruction | "Construction"
PhyMaterialParamYoungMod | "Young modulus"
PhyMaterialParamYoungMod1 | "Young modulus X"
PhyMaterialParamYoungMod2 | "Young modulus Y"
PhyMaterialParamYoungMod3 | "Young modulus Z"
PhyMaterialParamYoungModn1 | "Young's Modulus 1"
PhyMaterialParamYoungModn2 | "Young's Modulus 2"
PhyMaterialProperties | "Properties"
PipeInsulationThickness | "Insulation Thickness"
PipeRoughness | "Roughness"
PipeVelocityPressure | "Velocity Pressure"
PipingConnectionType | "Connection Type"
PipingGenderType | "Gender Type"
PlacementBottom | "Bottom"
PlacementCenterX | "Center X"
PlacementCenterY | "Center Y"
PlacementLeft | "Left"
PlacementParamsShow | "Enable Position Parameters"
PlacementRight | "Right"
PlacementTop | "Top"
PlanRegionViewRange | "View Range"
PlanViewCutPlaneHeight | "Cut Plane Height"
PlanViewLevel | "Associated Level"
PlanViewNorth | "Orientation"
PlanViewRange | "View Range"
PlanViewTopClipHeight | "Top Clip Height"
PlanViewViewDir | "View Direction"
PlumbingFixturesCwConnection | "CW Connection"
PlumbingFixturesDrain | "Drain"
PlumbingFixturesHwConnection | "HW Connection"
PlumbingFixturesSupplyFitting | "Supply Fitting"
PlumbingFixturesSupplyPipe | "Supply Pipe"
PlumbingFixturesTrap | "Trap"
PlumbingFixturesVentConnection | "Vent Connection"
PlumbingFixturesWasteConnection | "Waste Connection"
PocheMatId | "Coarse Poche Material"
PointAdaptiveConstrained | "Constrained"
PointAdaptiveNumParam | "Number"
PointAdaptiveOrientationType | "Orients to"
PointAdaptiveShowNumber | "Show Placement Number"
PointAdaptiveTypeParam | "Point"
PointcloudinstanceName | "Name": The name of the instance as it will show in the Property Palette
PointcloudtypeScale | "Scale": The scale for this instance
PointElementAngle | "Angle"
PointElementChordLength | "Chord Length"
PointElementDriven | "Driven by Host"
PointElementDriving | "Driving Curve(s)"
PointElementHostedOnFaceUParam | "Hosted U Parameter"
PointElementHostedOnFaceVParam | "Hosted V Parameter"
PointElementHostedParam | "Hosted Parameter"
PointElementMeasureFrom | "Measure From"
PointElementMeasurementType | "Measurement Type"
PointElementMirrored | "Mirrored"
PointElementNonNormalizedCurveParamater | "Non-Normalized Curve Parameter"
PointElementNormalizedCurveParamater | "Normalized Curve Parameter"
PointElementNormalizedSegmentLength | "Normalized Segment Length"
PointElementOffset | "Offset"
PointElementRotationAngle | "Rotation Angle"
PointElementSegmentLength | "Segment Length"
PointElementShowNormalPlaneOnly | "Show Normal Reference Plane Only"
PointElementShowPlanes | "Show Reference Planes"
PointElementZflipped | "Flipped"
PointElevation | "Elevation"
PointFlexibleConstrained | "Constrained"
PointFlexibleNumParam | "Number"
PointFlexibleOrientationType | "Orientation"
PointFlexibleShowNumber | "Show Placement Number"
PointNameParam | "Name"
PointVisibilityParam | "Visibility/Graphics Overrides"
PreferDimSideUiFilter | "Prefer:": This is used by the UI to allow select prefer dimension side.
PreferPatternAlignUiFilter | "Pattern:": This is used by the UI to allow to select the preferred preference of aligning pattern.
PrimaryOptionId | "Primary Option Id"
Profile1Angle | "Angle"
Profile1FamType | "Profile"
Profile1FlippedHor | "Profile Is Flipped"
Profile1OffsetX | "Horizontal Profile Offset"
Profile1OffsetY | "Vertical Profile Offset"
Profile2Angle | "Angle"
Profile2FamType | "Profile"
Profile2FlippedHor | "Profile Is Flipped"
Profile2OffsetX | "Horizontal Profile Offset"
Profile2OffsetY | "Vertical Profile Offset"
ProfileAngle | "Angle"
ProfileFamType | "Profile"
ProfileFamTypePlusNone | "Profile"
ProfileFlippedHor | "Profile Is Flipped"
ProfileOffsetX | "Horizontal Profile Offset"
ProfileOffsetY | "Vertical Profile Offset"
ProfileParamAlongPath | "Parameter along path"
ProjectAddress | "Project Address"
ProjectAuthor | "Author"
ProjectBuildingName | "Building Name"
ProjectBuildingType | "Building Type"
ProjectedSurfaceArea | "Projected Area"
ProjectIssueDate | "Project Issue Date"
ProjectName | "Project Name"
ProjectNumber | "Project Number"
ProjectOrganizationDescription | "Organization Description"
ProjectOrganizationName | "Organization Name"
ProjectPostalCode | "Postal Code"
ProjectRevisionEnumeration | "Numbering"
ProjectRevisionRevisionDate | "Revision Date"
ProjectRevisionRevisionDescription | "Revision Description"
ProjectRevisionRevisionIssued | "Issued"
ProjectRevisionRevisionIssuedBy | "Issued by"
ProjectRevisionRevisionIssuedTo | "Issued to"
ProjectRevisionRevisionNum | "Revision Number"
ProjectRevisionSequenceNum | "Revision Sequence": read_only Make this read-only again when NewSchedules_DisplayTags is cleaned up
ProjectStatus | "Project Status"
PropertyArea | "Area"
PropertyAreaOpen | "Area"
PropertyAreaUnits | "Area Units, Format"
PropertyLengthUnits | "Units Format"
PropertySegmentBearing | "Bearing"
PropertySegmentDistance | "Distance"
PropertySegmentEW | "E/W"
PropertySegmentLR | "L/R"
PropertySegmentNS | "N/S"
PropertySegmentRadius | "Radius"
PropertySegmentSubcategoryId | "Subcategory"
PropertySetDescription | "Description"
PropertySetKeywords | "Keywords"
PropertySetMaterialAspect | "Material aspect"
PropertySetName | "Property Set Name"
PropertySubcategoryId | "Subcategory"
RadialArrayArcRadius | "Radius"
RadiusSymbolLocation | "Radius Symbol Location"
RadiusSymbolText | "Radius Symbol Text"
RailingSystemHandrailsHeightParam | "Height"
RailingSystemHandrailsLatteralOffset | "Lateral Offset"
RailingSystemHandrailsPositionParam | "Position"
RailingSystemHandrailsTypesParam | "Type"
RailingSystemHasTopRail | "Use Top Rail": Whether railing has top rail
RailingSystemSecondaryHandrailsHeightParam | "Height"
RailingSystemSecondaryHandrailsLatteralOffset | "Lateral Offset"
RailingSystemSecondaryHandrailsPositionParam | "Position"
RailingSystemSecondaryHandrailsTypesParam | "Type"
RailingSystemTopRailHeightParam | "Height"
RailingSystemTopRailTypesParam | "Type"
RampAttrLeftBalusterAttachPt | "Left Baluster Location"
RampAttrMaterial | "Ramp Material"
RampAttrMinInvSlope | "Ramp Max Slope (1/x)"
RampAttrRightBalusterAttachPt | "Right Baluster Location"
RampAttrShape | "Shape"
RampAttrTextFont | "Text Font"
RampAttrTextSize | "Text Size"
RampAttrThickness | "Thickness"
RampMaxRunLength | "Maximum Incline Length"
RasterEnableSnaps | "Enable Snaps"
RasterHorizontalScale | "Horizontal Scale"
RasterLockProportions | "Lock Proportions"
RasterSheetheight | "Height"
RasterSheetwidth | "Width"
RasterSymbolFilename | "Loaded from file"
RasterSymbolHeight | "Height"
RasterSymbolLinkloadStatus | "Link Status"
RasterSymbolPagenumber | "Page Number"
RasterSymbolPixelheight | "Height (pixels)"
RasterSymbolPixelwidth | "Width (pixels)"
RasterSymbolResolution | "Resolution (dpi)"
RasterSymbolViewname | "View Name"
RasterSymbolWidth | "Width"
RasterVerticalScale | "Vertical Scale"
RbsAdditionalFlow | "Additional Flow"
RbsAdjustableConnector | "Allow Slope Adjustments"
RbsAreaBasedLoadType | "Area Based Load Type"
RbsBuildingConstructionclass | "Building Infiltration Class"
RbsBuildingUseloadcredits | "Use Load Credits"
RbsCabletrayBendradius | "Bend Radius"
RbsCabletrayconduitBendorfitting | "Bend or Fitting"
RbsCabletrayconduitConnectorelemType | "Connector Type"
RbsCabletrayconduitrunLengthParam | "Length"
RbsCabletrayconduitSystemType | "System Type"
RbsCabletrayHeightParam | "Height"
RbsCabletrayRungheight | "Rung Height"
RbsCabletrayRungspace | "Rung Space"
RbsCabletrayRungwidth | "Rung Width"
RbsCabletrayrunHeightParam | "Height"
RbsCabletrayrunWidthParam | "Width"
RbsCabletrayShapetype | "Shape"
RbsCabletrayThickness | "Thickness"
RbsCabletrayWidthParam | "Width"
RbsCalculatedSize | "Size"
RbsComponentClassificationParam | "Component Classification"
RbsConduitBendradius | "Bend Radius"
RbsConduitDiameterParam | "Diameter(Trade Size)"
RbsConduitInnerDiamParam | "Inside Diameter"
RbsConduitOuterDiamParam | "Outside Diameter"
RbsConduitrunDiameterParam | "Diameter(Trade Size)"
RbsConduitrunInnerDiamParam | "Inside Diameter"
RbsConduitrunOuterDiamParam | "Outside Diameter"
RbsConduitTradesize | "Conduit Size Lookup"
RbsConnectorDescription | "Connector Description"
RbsConnectorIsprimary | "Primary Connector"
RbsConnectorOffsetObsolete | "Connector Offset"
RbsConstructionSetParam | "Schematic Types"
RbsConstructionTypeShadingfactorParam | "Internal Shading Factor"
RbsCtcBottomElevation | "Lower End Bottom Elevation"
RbsCtcServiceType | "Service Type"
RbsCtcTopElevation | "Upper End Top Elevation"
RbsCurveDiameterParam | "Diameter"
RbsCurveHeightParam | "Height"
RbsCurveHorOffsetParam | "Horizontal Justification"
RbsCurveSlope | "Slope Percentage (%)"
RbsCurveSurfaceArea | "Area"
RbsCurvetypeDefaultBendParam | "Bend"
RbsCurvetypeDefaultCapParam | "Cap"
RbsCurvetypeDefaultCrossParam | "Cross"
RbsCurvetypeDefaultElbowdownParam | "Vertical Outside Bend"
RbsCurvetypeDefaultElbowParam | "Elbow"
RbsCurvetypeDefaultElbowupParam | "Vertical Inside Bend"
RbsCurvetypeDefaultHorizontalBendParam | "Horizontal Bend"
RbsCurvetypeDefaultMechjointParam | "Flange"
RbsCurvetypeDefaultTakeoffParam | "Tap"
RbsCurvetypeDefaultTeedownParam | "Tee Down"
RbsCurvetypeDefaultTeeParam | "Tee"
RbsCurvetypeDefaultTeeupParam | "Tee Up"
RbsCurvetypeDefaultTransitionParam | "Transition"
RbsCurvetypeDefaultUnionParam | "Union"
RbsCurvetypeMaxHeightParam | "Max Height"
RbsCurvetypeMaxWidthParam | "Max Width"
RbsCurvetypeMultishapeTransitionOvalroundParam | "Multi Shape Transition Oval to Round"
RbsCurvetypeMultishapeTransitionParam | "Multi Shape Transition Rect to Round"
RbsCurvetypeMultishapeTransitionRectovalParam | "Multi Shape Transition Rect to Oval"
RbsCurvetypePreferredBranchParam | "Preferred Junction Type"
RbsCurveUtslope | "Slope"
RbsCurveVertOffsetParam | "Vertical Justification"
RbsCurveWidthParam | "Width"
RbsDistributionsysConfigParam | "Configuration"
RbsDistributionsysHlPhaseParam | "High-leg Phase"
RbsDistributionsysNumwiresParam | "Wires"
RbsDistributionsysPhaseParam | "Phase"
RbsDistributionsysVlgParam | "Line to Ground Voltage"
RbsDistributionsysVllParam | "Line to Line Voltage"
RbsDuctBottomElevation | "Lower End Bottom Elevation"
RbsDuctCalculatedSize | "Duct Size"
RbsDuctConnectorSystemClassificationParam | "System Classification"
RbsDuctFittingLossMethodParam | "Loss Method"
RbsDuctFittingLossMethodServerParam | "Loss Method"
RbsDuctFittingLossMethodSettings | "Loss Method Settings"
RbsDuctFittingLossTableParam | "ASHRAE Table"
RbsDuctFlowConfigurationParam | "Flow Configuration"
RbsDuctFlowDirectionParam | "Flow Direction"
RbsDuctFlowParam | "Flow"
RbsDuctPipeSystemAbbreviationParam | "System Abbreviation"
RbsDuctPressureDrop | "Pressure Drop"
RbsDuctRoutingPreferenceParam | "Routing Preferences"
RbsDuctSizeFormattedParam | "Size"
RbsDuctSlope | "Slope"
RbsDuctStaticPressure | "Static Pressure"
RbsDuctSystemCalculationParam | "Calculations"
RbsDuctSystemTypeParam | "System Type"
RbsDuctTopElevation | "Upper End Top Elevation"
RbsDuctTypeParam | "Duct Type"
RbsElecAmbientTemperature | "Ambient Temperature"
RbsElecAnalyticalArea | "Area"
RbsElecAnalyticalConnectedPhase | "Connected Phases"
RbsElecAnalyticalDownstreamConnectedPhases | "Downstream Connected Phases"
RbsElecAnalyticalFeederLength | "Length"
RbsElecAnalyticalHighLegPhase | "High-leg Phase"
RbsElecAnalyticalLevelId | "Level"
RbsElecAnalyticalLoadDensity | "Power Density"
RbsElecAnalyticalLoadNameParam | "Name"
RbsElecAnalyticalLoadSetOnDuty | "Quantity of Prime"
RbsElecAnalyticalLoadSetOnStandby | "Quantity on Standby"
RbsElecAnalyticalLoadSetOnTotal | "Total Quantity"
RbsElecAnalyticalLoadsInSet | "Loads in Set"
RbsElecAnalyticalLoadTypeParam | "Load Type"
RbsElecAnalyticalNumphases | "Number of Phases"
RbsElecAnalyticalSecondaryHighLegPhase | "Secondary High-leg Phase"
RbsElecAnalyticalTotalCoincidentLoad | "Total Coincident Loads"
RbsElecApparentCurrentParam | "Apparent Current"
RbsElecApparentCurrentPhaseaParam | "Apparent Current Phase A"
RbsElecApparentCurrentPhasebParam | "Apparent Current Phase B"
RbsElecApparentCurrentPhasecParam | "Apparent Current Phase C"
RbsElecApparentLoad | "Apparent Power"
RbsElecApparentLoadPhase1 | "Apparent Power Phase 1"
RbsElecApparentLoadPhase2 | "Apparent Power Phase 2"
RbsElecApparentLoadPhase3 | "Apparent Power Phase 3"
RbsElecApparentLoadPhasea | "Apparent Power Phase A"
RbsElecApparentLoadPhaseb | "Apparent Power Phase B"
RbsElecApparentLoadPhasec | "Apparent Power Phase C"
RbsElecApparentPowerDensity | "Apparent Power Density"
RbsElecBalancedLoad | "Balanced Load"
RbsElecCalcCoefficientUtilization | "Calculate Coefficient of Utilization"
RbsElecCircuitConnectionTypeParam | "Connection Type"
RbsElecCircuitFrameParam | "Frame"
RbsElecCircuitLengthParam | "Length"
RbsElecCircuitName | "Load Name"
RbsElecCircuitNaming | "Circuit Naming"
RbsElecCircuitNamingIndex | "Circuit Naming Index"
RbsElecCircuitNotesParam | "Schedule Circuit Notes"
RbsElecCircuitNumber | "Circuit Number"
RbsElecCircuitNumberingType | "Circuit Numbering Option"
RbsElecCircuitNumberOfElementsParam | "Number of Elements"
RbsElecCircuitPanelParam | "Panel"
RbsElecCircuitPathModeParam | "Path Mode"
RbsElecCircuitPathOffsetParam | "Offset"
RbsElecCircuitPrefix | "Circuit Prefix"
RbsElecCircuitPrefixSeparator | "Circuit Prefix Separator"
RbsElecCircuitRatingParam | "Rating"
RbsElecCircuitSlotIndex | "Slot Index"
RbsElecCircuitStartSlot | "Start Slot"
RbsElecCircuitType | "System Type"
RbsElecCircuitWireNumGroundsParam | "# of Ground Conductors"
RbsElecCircuitWireNumHotsParam | "# of Hot Conductors"
RbsElecCircuitWireNumNeutralsParam | "# of Neutral Conductors"
RbsElecCircuitWireNumRunsParam | "# of Runs"
RbsElecCircuitWireSizeParam | "Wire Size"
RbsElecCircuitWireTypeParam | "Wire Type"
RbsElecDemandCurrentPhasea | "Demand Current Phase A"
RbsElecDemandCurrentPhaseb | "Demand Current Phase B"
RbsElecDemandCurrentPhasec | "Demand Current Phase C"
RbsElecDemandfactorDemandloadParam | "Demand Apparent Power"
RbsElecDemandfactorLoadclassificationParam | "Load Classification"
RbsElecDemandfactorLoadParam | "Connected Apparent Power"
RbsElecDemandLoadPhasea | "Demand Apparent Power Phase A"
RbsElecDemandLoadPhaseb | "Demand Apparent Power Phase B"
RbsElecDemandLoadPhasec | "Demand Apparent Power Phase C"
RbsElecDistributionNodeLoadSet | "Load Set"
RbsElecDistributionNodeSupplyFrom | "Supply From"
RbsElecDistributionNodeSupplyFrom1 | "Supply From 1"
RbsElecDistributionNodeSupplyFrom2 | "Supply From 2"
RbsElecDistributionNodeSupplyTo | "Supply To"
RbsElecEditCircuitNamingSettingsParam | "Circuit Naming Settings"
RbsElecEnclosure | "Enclosure"
RbsElecLoadClassification | "Load Classification"
RbsElecLoadsummaryConnectedCurrentParam | "Connected Current"
RbsElecLoadsummaryConnectedLoadParam | "Connected Apparent Power"
RbsElecLoadsummaryDemandCurrentParam | "Estimated Demand Current"
RbsElecLoadsummaryDemandFactorParam | "Demand Factor"
RbsElecLoadsummaryDemandFactorRuleParam | "Description"
RbsElecLoadsummaryDemandLoadParam | "Demand Apparent Power"
RbsElecLoadsummaryLoadclassificationParam | "Load Classification"
RbsElecMains | "Mains"
RbsElecMaxCircuitsDataPanel | "Maximum Amount of Circuits"
RbsElecMaxPoleBreakers | "Max Number of Single Pole Breakers"
RbsElecModifications | "Modifications"
RbsElecMounting | "Mounting"
RbsElecNumberOfCircuits | "Max Number of Circuits"
RbsElecNumberOfPoles | "Number of Poles"
RbsElecPanelBranchCircuitApparentLoadPhasea | "Branch Circuit Apparent Power Phase A"
RbsElecPanelBranchCircuitApparentLoadPhaseb | "Branch Circuit Apparent Power Phase B"
RbsElecPanelBranchCircuitApparentLoadPhasec | "Branch Circuit Apparent Power Phase C"
RbsElecPanelBranchCircuitCurrentPhasea | "Branch Circuit Current Phase A"
RbsElecPanelBranchCircuitCurrentPhaseb | "Branch Circuit Current Phase B"
RbsElecPanelBranchCircuitCurrentPhasec | "Branch Circuit Current Phase C"
RbsElecPanelBussingParam | "Bussing"
RbsElecPanelConfigurationParam | "Panel Configuration"
RbsElecPanelCurrentPhaseaParam | "Current Phase A"
RbsElecPanelCurrentPhasebParam | "Current Phase B"
RbsElecPanelCurrentPhasecParam | "Current Phase C"
RbsElecPanelFeedParam | "Feed"
RbsElecPanelFeedThruLugsApparentLoadPhasea | "Feed Through Lugs Apparent Power Phase A"
RbsElecPanelFeedThruLugsApparentLoadPhaseb | "Feed Through Lugs Apparent Power Phase B"
RbsElecPanelFeedThruLugsApparentLoadPhasec | "Feed Through Lugs Apparent Power Phase C"
RbsElecPanelFeedThruLugsCurrentPhasea | "Feed Through Lugs Current Phase A"
RbsElecPanelFeedThruLugsCurrentPhaseb | "Feed Through Lugs Current Phase B"
RbsElecPanelFeedThruLugsCurrentPhasec | "Feed Through Lugs Current Phase C"
RbsElecPanelFeedThruLugsParam | "Feed Through Lugs"
RbsElecPanelGroundBusParam | "Ground Bus"
RbsElecPanelLocationParam | "Location"
RbsElecPanelMainstypeParam | "Mains Type"
RbsElecPanelMcbRatingParam | "MCB Rating"
RbsElecPanelName | "Panel Name"
RbsElecPanelNeutralBusParam | "Neutral Bus"
RbsElecPanelNeutralRatingParam | "Neutral Rating"
RbsElecPanelNumphasesParam | "Number of Phases"
RbsElecPanelNumwiresParam | "Number of Wires"
RbsElecPanelScheduleFooterNotesParam | "Schedule Footer Notes"
RbsElecPanelScheduleHeaderNotesParam | "Schedule Header Notes"
RbsElecPanelSubfeedLugsParam | "SubFeed Lugs"
RbsElecPanelSupplyFromParam | "Supply From"
RbsElecPanelTotalConnectedCurrentParam | "Total Connected Current"
RbsElecPanelTotalDemandCurrentParam | "Total Estimated Demand Current"
RbsElecPanelTotalDemandFactorParam | "Total Demand Factor"
RbsElecPanelTotalestloadHvacParam | "HVAC Total Demand Apparent Power"
RbsElecPanelTotalestloadLightParam | "Lighting Total Demand Apparent Power"
RbsElecPanelTotalestloadOtherParam | "Other Total Demand Apparent Power"
RbsElecPanelTotalestloadParam | "Total Demand Apparent Power"
RbsElecPanelTotalestloadPowerParam | "Power Total Demand Apparent Power"
RbsElecPanelTotalloadHvacParam | "HVAC Total Connected Apparent Power"
RbsElecPanelTotalloadLightParam | "Lighting Total Connected Apparent Power"
RbsElecPanelTotalloadOtherParam | "Other Total Connected Apparent Power"
RbsElecPanelTotalloadParam | "Total Connected Apparent Power"
RbsElecPanelTotalloadPowerParam | "Power Total Connected Apparent Power"
RbsElecPowerFactor | "Power Factor"
RbsElecPowerFactorState | "Power Factor State"
RbsElecRoomAverageIllumination | "Average Estimated Illumination"
RbsElecRoomCavityRatio | "Room Cavity Ratio"
RbsElecRoomLightingCalcLuminaireplane | "Lighting Calculation Luminaire Plane"
RbsElecRoomLightingCalcWorkplane | "Lighting Calculation Workplane"
RbsElecRoomReflectivityCeiling | "Ceiling Reflectance"
RbsElecRoomReflectivityFloor | "Floor Reflectance"
RbsElecRoomReflectivityWalls | "Wall Reflectance"
RbsElecShortCircuitRating | "Short Circuit Rating Comments"
RbsElecSwitchIdParam | "Switch ID"
RbsElectricalData | "Electrical Data"
RbsElecTrueCurrentParam | "True Current"
RbsElecTrueCurrentPhaseaParam | "True Current Phase A"
RbsElecTrueCurrentPhasebParam | "True Current Phase B"
RbsElecTrueCurrentPhasecParam | "True Current Phase C"
RbsElecTrueLoad | "True Power"
RbsElecTrueLoadPhase1 | "True Power Phase 1"
RbsElecTrueLoadPhase2 | "True Power Phase 2"
RbsElecTrueLoadPhase3 | "True Power Phase 3"
RbsElecTrueLoadPhasea | "True Power Phase A"
RbsElecTrueLoadPhaseb | "True Power Phase B"
RbsElecTrueLoadPhasec | "True Power Phase C"
RbsElecVoltage | "Voltage"
RbsElecVoltageDropParam | "Voltage Drop"
RbsElecWireCircuits | "Circuits"
RbsElecWireElevation | "Elevation"
RbsElecWireGroundAdjustment | "Ground Conductors"
RbsElecWireHotAdjustment | "Hot Conductors"
RbsElecWireNeutralAdjustment | "Neutral Conductors"
RbsElecWireShareGround | "Share Ground Conductor"
RbsElecWireShareNeutral | "Share Neutral Conductor"
RbsElecWireTickmarkState | "Tick Marks"
RbsElecWireType | "Type"
RbsEndLevelParam | "End Level"
RbsEndOffsetParam | "End Middle Elevation"
RbsEnergyAnalysisBuildingEnvelopeAnalyticalGridCellSize | "Analytical Grid Cell Size"
RbsEnergyAnalysisBuildingEnvelopeAnalyticalSpaceIdentificationResolution | "Analytical Space Resolution"
RbsEnergyAnalysisBuildingEnvelopeAnalyticalSurfaceIdentificationResolution | "Analytical Surface Resolution"
RbsEnergyAnalysisBuildingEnvelopeDeterminationParam | "Building Envelope"
RbsEnergyAnalysisExportCategoryParam | "Export Category"
RbsEnergyAnalysisExportComplexityParam | "Export Complexity"
RbsEnergyAnalysisExportGbxmlDefaultsParam | "Export Default Values"
RbsEnergyAnalysisGroundPlaneParam | "Ground Plane"
RbsEnergyAnalysisIncludeThermalProperties | "Detailed Elements"
RbsEnergyAnalysisMode | "Mode"
RbsEnergyAnalysisProjectPhaseParam | "Project Phase"
RbsEnergyAnalysisSliverSpaceTolerance | "Sliver Space Tolerance"
RbsEnergyAnalysisSurfaceAdjacentSpaceId1 | "Adjacent Space Id (1)"
RbsEnergyAnalysisSurfaceAdjacentSpaceId2 | "Adjacent Space Id (2)"
RbsEnergyAnalysisSurfaceAzimuth | "Azimuth"
RbsEnergyAnalysisSurfaceCadobjectid | "CADObjectID"
RbsEnergyAnalysisSurfaceOriginX | "Origin (X)"
RbsEnergyAnalysisSurfaceOriginY | "Origin (Y)"
RbsEnergyAnalysisSurfaceOriginZ | "Origin (Z)"
RbsEnergyAnalysisSurfaceTilt | "Tilt"
RbsEnergyAnalysisViewBuildingShellMode | "Show Analytical Building Shell"
RbsEnergyAnalysisViewCoordAxisMode | "Show a Coordinate System Symbol for each Surface"
RbsEnergyAnalysisViewInnerShellMode | "Show Inner Space Shells"
RbsEnergyAnalysisViewOuterShellMode | "Show Analytical Space Shells"
RbsEnergyAnalysisViewRbeMode | "Show Room Bounding Elements Dimmed and Underlay"
RbsEnergyAnalysisViewShadingSurfacesMode | "Show Shading Surfaces"
RbsEnergyAnalysisViewSurfacesMode | "Show Surfaces"
RbsEnergyAnalysisViewTransparentMode | "Show Surfaces Transparent"
RbsEnergyAnalysisViewUpdateSurfaces | "Update Surfaces"
RbsEqDiameterParam | "Equivalent Diameter"
RbsFamilyContentAnnotationDisplay | "Use Annotation Scale"
RbsFamilyContentDistributionSystem | "Distribution System"
RbsFamilyContentOffsetHeight | "OffsetHeight"
RbsFamilyContentOffsetWidth | "OffsetWidth"
RbsFamilyContentSecondaryDistribsys | "Secondary Distribution System"
RbsFamilyContentTakeoffFixedLength | "Takeoff Fixed Length"
RbsFamilyContentTakeoffLength | "Takeoff Length"
RbsFamilyContentTakeoffProjlength | "Takeoff Length Projection"
RbsFlexductRoundtypeParam | "Flex Duct Type"
RbsFlexDuctTypeParam | "Flex Duct Type"
RbsFlexPatternParam | "Flex Pattern"
RbsFlexPipeTypeParam | "Flex Pipe"
RbsFlowFactorParam | "Flow Factor"
RbsFlowObsolete | "Flow"
RbsFpSprinklerCoverageParam | "Coverage"
RbsFpSprinklerKFactorParam | "K-Factor"
RbsFpSprinklerOrificeParam | "Orifice"
RbsFpSprinklerOrificeSizeParam | "Orifice Size"
RbsFpSprinklerPressureClassParam | "Pressure Class"
RbsFpSprinklerResponseParam | "Response"
RbsFpSprinklerTemperatureRatingParam | "Temperature Rating"
RbsFriction | "Friction"
RbsGbxmlOpeningType | "Opening Type"
RbsGbxmlSurfaceArea | "Area"
RbsGbxmlSurfaceName | "Surface Name"
RbsGbxmlSurfaceType | "Surface Type"
RbsHvacloadDoorAreaParam | "Door Area"
RbsHvacloadDoorCoolingLoadParam | "Door Cooling Load"
RbsHvacloadFloorAreaParam | "Floor Area"
RbsHvacloadPartitionAreaParam | "Partition Area"
RbsHvacloadPartitionCoolingLoadParam | "Partition Cooling Load"
RbsHvacloadPlenumCoolingLoadParam | "Plenum Cooling Load"
RbsHvacloadRoofAreaParam | "Roof Area"
RbsHvacloadRoofCoolingLoadParam | "Roof Cooling Load"
RbsHvacloadSkylightAreaParam | "Skylight Area"
RbsHvacloadSkylightCoolingLoadParam | "Skylight Cooling Load"
RbsHvacloadWallAreaParam | "Wall Area"
RbsHvacloadWallCoolingLoadParam | "Wall Cooling Load"
RbsHvacloadWindowAreaParam | "Window Area"
RbsHvacloadWindowCoolingLoadParam | "Window Cooling Load"
RbsHydraulicDiameterParam | "Hydraulic Diameter"
RbsInsulationLiningVolume | "Volume"
RbsInsulationThickness | "Insulation Thickness"
RbsInsulationThicknessForDuct | "Insulation Thickness"
RbsInsulationThicknessForPipe | "Insulation Thickness"
RbsIsCustomFitting | "IsCustom"
RbsLiningThickness | "Lining Thickness"
RbsLiningThicknessForDuct | "Lining Thickness"
RbsLoadSubClassificationMotor | "Load Sub-Classification Motor"
RbsLookupTableName | "Lookup Table Name"
RbsLossCoefficient | "Loss Coefficient"
RbsMaxFlow | "Max Flow"
RbsMinFlow | "Min Flow"
RbsOffsetParam | "Middle Elevation"
RbsPanelScheduleSheetAppearanceInstParam | "Appearance"
RbsPanelScheduleSheetAppearanceParam | "Appearance On Sheet"
RbsParallelconduitsHorizontalNumber | "Horizontal Number for parallel conduits"
RbsParallelconduitsHorizontalOffsetValue | "Horizontal Offset value for parallel conduits"
RbsParallelconduitsVerticalNumber | "Vertical Number for parallel conduits"
RbsParallelconduitsVerticalOffsetValue | "Vertical Offset value for parallel conduits"
RbsParallelpipesHorizontalNumber | "Horizontal Number for parallel pipes"
RbsParallelpipesHorizontalOffsetValue | "Horizontal Offset value for parallel pipes"
RbsParallelpipesVerticalNumber | "Vertical Number for parallel pipes"
RbsParallelpipesVerticalOffsetValue | "Vertical Offset value for parallel pipes"
RbsPartType | "Part Type"
RbsPipeAdditionalFlowParam | "Additional Flow"
RbsPipeBottomElevation | "Lower End Bottom Elevation"
RbsPipeCalculatedSize | "Pipe Size"
RbsPipeClassParam | "Schedule/Type"
RbsPipeConnectiontypeParam | "Connection Type"
RbsPipeConnectorSystemClassificationParam | "System Classification"
RbsPipeCwfuParam | "CWFU"
RbsPipeDiameterParam | "Diameter"
RbsPipeFittingLossKfactorParam | "K Coefficient"
RbsPipeFittingLossMethodParam | "Loss Method"
RbsPipeFittingLossMethodServerParam | "Loss Method"
RbsPipeFittingLossMethodSettings | "Loss Method Settings"
RbsPipeFittingLossTableParam | "K Coefficient Table"
RbsPipeFixtureUnitsParam | "Fixture Units"
RbsPipeFlowConfigurationParam | "Flow Configuration"
RbsPipeFlowDirectionParam | "Flow Direction"
RbsPipeFlowParam | "Flow"
RbsPipeFlowStateParam | "Flow State"
RbsPipeFluidDensityParam | "Fluid Density"
RbsPipeFluidTemperatureParam | "Fluid Temperature"
RbsPipeFluidTypeParam | "Fluid Type"
RbsPipeFluidViscosityParam | "Fluid Dynamic Viscosity"
RbsPipeFrictionParam | "Friction"
RbsPipeHwfuParam | "HWFU"
RbsPipeInnerDiamParam | "Inside Diameter"
RbsPipeInsulationThickness | "Insulation Thickness"
RbsPipeInvertElevation | "Invert Elevation": This parameter is obsolete. It exists only for compatibility.
RbsPipeJointtypeParam | "Connection Type"
RbsPipeMaterialParam | "Material"
RbsPipeOuterDiameter | "Outside Diameter"
RbsPipePressuredropParam | "Pressure Drop"
RbsPipeReynoldsNumberParam | "Reynolds Number"
RbsPipeSegmentParam | "Pipe Segment"
RbsPipeSizeFormattedParam | "Size"
RbsPipeSizeMaximum | "Maximum Size"
RbsPipeSizeMinimum | "Minimum Size"
RbsPipeSlope | "Slope"
RbsPipeSlopeDefParam | "Pipe Slope Definitions"
RbsPipeSlopeOptionsDefParam | "Pipe Slope Options"
RbsPipeStaticPressure | "Static Pressure"
RbsPipeSystemCalculationParam | "Calculations"
RbsPipeSystemFixtureUnitParam | "Fixture Units"
RbsPipeTopElevation | "Upper End Top Elevation"
RbsPipeTypeFittingLossKfactorParam | "K Coefficient"
RbsPipeTypeFittingLossMethodParam | "Loss Method"
RbsPipeTypeFittingLossTableParam | "K Coefficient Table"
RbsPipeTypeParam | "Pipe Type"
RbsPipeTypeValveLossCvfactorParam | "Cv Coefficient"
RbsPipeValveLossCvfactorParam | "Cv Coefficient"
RbsPipeVelocityParam | "Velocity"
RbsPipeVolumeParam | "Volume"
RbsPipeWallThickness | "Wall Thickness"
RbsPipeWfuParam | "WFU"
RbsPipingSystemTypeParam | "System Type"
RbsPressureDrop | "Pressure Drop"
RbsProjectConstructionTypeShadingfactorParam | "Internal Shading Factor"
RbsProjectLocationParam | "Location"
RbsProjectReporttypeParam | "Report Type"
RbsReferenceFreesize | "Free Size"
RbsReferenceInsulationThickness | "Insulation Thickness": This parameter is obsolete. Use DUCT_INSULATION_THICKNESS and PIPE_INSULATION_THICKNESS.
RbsReferenceInsulationType | "Insulation Type"
RbsReferenceLiningThickness | "Lining Thickness"
RbsReferenceLiningType | "Lining Type"
RbsReferenceOverallsize | "Overall Size"
RbsReynoldsnumberParam | "Reynolds number"
RbsRoomCoefficientUtilization | "Coefficient of Utilization"
RbsRoutingPreferenceParam | "Routing Preferences"
RbsSection | "Section"
RbsSegmentDescriptionParam | "Segment Description"
RbsServiceTypeParam | "Building Service"
RbsShowProfileType | "Show Round"
RbsSizeLock | "Size Lock"
RbsStartLevelParam | "Reference Level"
RbsStartOffsetParam | "Start Middle Elevation"
RbsSystemAbbreviationParam | "Abbreviation"
RbsSystemBaseElementParam | "System Equipment"
RbsSystemClassificationParam | "System Classification"
RbsSystemFlowConversionMethodParam | "Flow Conversion Method"
RbsSystemNameParam | "System Name"
RbsSystemNumElementsParam | "Number of Elements"
RbsSystemRisedrop1linedropsymbolParam | "Single Line Drop Symbol"
RbsSystemRisedrop1linerisesymbolParam | "Single Line Rise Symbol"
RbsSystemRisedrop1lineteedownsymbolParam | "Single Line Tee Down Symbol"
RbsSystemRisedrop1lineteeupsymbolParam | "Single Line Tee Up Symbol"
RbsSystemRisedrop2linedropsymbolParam | "Two Line Drop Symbol"
RbsSystemRisedrop2linerisesymbolParam | "Two Line Rise Symbol"
RbsSystemRisedropParam | "Rise / Drop Symbol"
RbsVelocity | "Velocity"
RbsVelocityPressure | "Velocity Pressure"
RbsVoltagetypeMaxvoltageParam | "Maximum Voltage"
RbsVoltagetypeMinvoltageParam | "Minimum Voltage"
RbsVoltagetypeVoltageParam | "Actual Voltage"
RbsWireCircuitDescription | "Circuit Description"
RbsWireCircuitLoadName | "Circuit Load Name"
RbsWireConduitTypeParam | "Conduit Type"
RbsWireInsulationParam | "Insulation"
RbsWireMaterialParam | "Material"
RbsWireMaxConductorSizeParam | "Max Size"
RbsWireNeutralIncludedInBalancedLoadParam | "Neutral Included in Balanced Load"
RbsWireNeutralModeParam | "Neutral Size"
RbsWireNeutralMultiplierParam | "Neutral Multiplier"
RbsWireNumConductorsParam | "Number of Conductors"
RbsWireTemperatureRatingParam | "Temperature Rating"
RebarAlignmentOptions | "Bar Alignment"
RebarBarDeformationType | "Deformation"
RebarBarDiameter | "Bar Diameter"
RebarBarHookLengths | "Hook Lengths"
RebarBarMaximumBendRadius | "Maximum Bend Radius"
RebarBarSpliceLengths | "Splice Lengths"
RebarBarStirrupBendDiameter | "Stirrup/Tie Bend Diameter"
RebarBarStyle | "Subcategory"
RebarConstraintsStatus | "Rebar Constraint Status"
RebarContainerBarType | "Bar Type"
RebarDistributionType | "Distribution Type"
RebarElemBarSpacing | "Spacing"
RebarElemEndtreatmentEnd | "End Treatment At End"
RebarElemEndtreatmentStart | "End Treatment At Start"
RebarElementRounding | "Rounding Overrides"
RebarElementVisibility | "View Visibility States"
RebarElemHookEndOrient | "Hook Orientation At End"
RebarElemHookEndType | "Hook At End"
RebarElemHookStartOrient | "Hook Orientation At Start"
RebarElemHookStartType | "Hook At Start"
RebarElemHookStyle | "Style"
RebarElemHostMark | "Host Mark"
RebarElemLayoutRule | "Layout Rule"
RebarElemLength | "Bar Length"
RebarElemQuantityOfBars | "Quantity"
RebarElemScheduleMark | "Schedule Mark"
RebarElemTotalLength | "Total Bar Length"
RebarFreeFormHookEndPlaneAngle | "Hook Orientation At End"
RebarFreeFormHookStartPlaneAngle | "Hook Orientation At Start"
RebarGeometryType | "Geometry"
RebarHookAngle | "Hook Angle"
RebarHookLengthOverride | "Override Hook Lengths"
RebarHookLineLenFactor | "Extension Multiplier"
RebarHookRotationAtEnd | "Hook Rotation At End"
RebarHookRotationAtEndSchedulesTagsFilters | "Hook Rotation At End"
RebarHookRotationAtStart | "Hook Rotation At Start"
RebarHookRotationAtStartSchedulesTagsFilters | "Hook Rotation At Start"
RebarHookStyle | "Style"
RebarHostCategory | "Host Category"
RebarIncludeFirstBar | "Include First Bar"
RebarIncludeLastBar | "Include Last Bar"
RebarInstanceBarDiameter | "Bar Diameter"
RebarInstanceBarModelDiameter | "Model Bar Diameter"
RebarInstanceBendDiameter | "Bend Diameter"
RebarInstanceStirrupTieAttachment | "Stirrup/Tie Attachment"
RebarInternalMultiplanar | "INTERNAL: Multiplanar"
RebarInternalMultiplanarArcConnector | "INTERNAL: Multiplanar Arc Connector"
RebarInternalMultiplanarDuplicate | "INTERNAL: Multiplanar Duplicate"
RebarInternalMultiplanarEndConnector | "INTERNAL: Multiplanar End Connector"
RebarInternalMultiplanarStartConnector | "INTERNAL: Multiplanar Start Connector"
RebarMaximSuffix | "Maximum Suffix"
RebarMaximumNumber | "Maximum Rebar Number"
RebarMaxLength | "Maximum Bar Length"
RebarMinimSuffix | "Minimum Suffix"
RebarMinimumNumber | "Minimum Rebar Number"
RebarMinLength | "Minimum Bar Length"
RebarModelBarDiameter | "Model Bar Diameter"
RebarModifiedSet | "Modified Rebar Set"
RebarNumber | "Rebar Number"
RebarNumberSuffix | "Rebar Number Suffix"
RebarQuanityByDistrib | "Quantity By Rebar Set"
RebarShape | "Shape"
RebarShapeAllowedBarTypes | "Allowable Rebar Bar Types"
RebarShapeEndHookLength | "End Hook Length"
RebarShapeEndHookOffset | "End Hook Offset Length"
RebarShapeEndtreatmentEndType | "End Treatment At End"
RebarShapeEndtreatmentStartType | "End Treatment At Start"
RebarShapeHookEndType | "Hook At End"
RebarShapeHookRotationAtEnd | "Hook Rotation At End"
RebarShapeHookRotationAtStart | "Hook Rotation At Start"
RebarShapeHookStartType | "Hook At Start"
RebarShapeHookStyle | "Style"
RebarShapeImage | "Shape Image"
RebarShapeOutOfPlaneBendDiameter | "Out of Plane Bend Diameter"
RebarShapeParamEndHookTanLen | "End Tangent Hook Length"
RebarShapeParamStartHookTanLen | "Start Tangent Hook Length"
RebarShapeSpiralBaseFinishingTurns | "Base Finishing Turns"
RebarShapeSpiralHeight | "Height"
RebarShapeSpiralPitch | "Pitch"
RebarShapeSpiralTopFinishingTurns | "Top Finishing Turns"
RebarShapeStartHookLength | "Start Hook Length"
RebarShapeStartHookOffset | "Start Hook Offset Length"
RebarShapeStirrupTieAttachment | "Stirrup/Tie Attachment"
RebarSpliceLapLengthMultiplier | "Lap Length Multiplier"
RebarSpliceShiftBars | "Shift Bars"
RebarSpliceSpliceLinePosition | "Splice Position"
RebarSpliceStaggerLengthMultiplier | "Stagger Length Multiplier"
RebarStaggeredSet | "Staggered Set"
RebarStaggerOffsetAtEnd | "Offset At End"
RebarStaggerOffsetAtStart | "Offset At Start"
RebarStandardBendDiameter | "Standard Bend Diameter"
RebarStandardHookBendDiameter | "Standard Hook Bend Diameter"
RebarSystemActiveBackDirn1 | "Interior Major Direction"
RebarSystemActiveBackDirn2 | "Interior Minor Direction"
RebarSystemActiveBottomDir1Generic | "Bottom/Interior Major Direction"
RebarSystemActiveBottomDir2Generic | "Bottom/Interior Minor Direction"
RebarSystemActiveBottomDirn1 | "Bottom Major Direction"
RebarSystemActiveBottomDirn2 | "Bottom Minor Direction"
RebarSystemActiveFrontDirn1 | "Exterior Major Direction"
RebarSystemActiveFrontDirn2 | "Exterior Minor Direction"
RebarSystemActiveTopDir1Generic | "Top/Exterior Major Direction"
RebarSystemActiveTopDir2Generic | "Top/Exterior Minor Direction"
RebarSystemActiveTopDirn1 | "Top Major Direction"
RebarSystemActiveTopDirn2 | "Top Minor Direction"
RebarSystemAddlBottomOffset | "Additional Bottom Cover Offset"
RebarSystemAddlExteriorOffset | "Additional Exterior Cover Offset"
RebarSystemAddlInteriorOffset | "Additional Interior Cover Offset"
RebarSystemAddlTopOffset | "Additional Top Cover Offset"
RebarSystemBarTypeBackDirn1 | "Interior Major Bar Type"
RebarSystemBarTypeBackDirn2 | "Interior Minor Bar Type"
RebarSystemBarTypeBottomDir1Generic | "Bottom/Interior Major Bar Type"
RebarSystemBarTypeBottomDir2Generic | "Bottom/Interior Minor Bar Type"
RebarSystemBarTypeBottomDirn1 | "Bottom Major Bar Type"
RebarSystemBarTypeBottomDirn2 | "Bottom Minor Bar Type"
RebarSystemBarTypeFrontDirn1 | "Exterior Major Bar Type"
RebarSystemBarTypeFrontDirn2 | "Exterior Minor Bar Type"
RebarSystemBarTypeTopDir1Generic | "Top/Exterior Major Bar Type"
RebarSystemBarTypeTopDir2Generic | "Top/Exterior Minor Bar Type"
RebarSystemBarTypeTopDirn1 | "Top Major Bar Type"
RebarSystemBarTypeTopDirn2 | "Top Minor Bar Type"
RebarSystemBottomMajorMatchesBottomMinor | "Bottom Major and Minor Layers Match"
RebarSystemCoverBottom | "Rebar Cover Bottom/Interior"
RebarSystemCoverSide | "Rebar Cover Side/Edge"
RebarSystemCoverTop | "Rebar Cover Top/Exterior"
RebarSystemHookOrientBackDirn1 | "Interior Major Hook Orientation"
RebarSystemHookOrientBackDirn2 | "Interior Minor Hook Orientation"
RebarSystemHookOrientBottomDirn1 | "Bottom Major Hook Orientation"
RebarSystemHookOrientBottomDirn2 | "Bottom Minor Hook Orientation"
RebarSystemHookOrientFrontDirn1 | "Exterior Major Hook Orientation"
RebarSystemHookOrientFrontDirn2 | "Exterior Minor Hook Orientation"
RebarSystemHookOrientTopDirn1 | "Top Major Hook Orientation"
RebarSystemHookOrientTopDirn2 | "Top Minor Hook Orientation"
RebarSystemHookTypeBackDirn1 | "Interior Major Hook Type"
RebarSystemHookTypeBackDirn2 | "Interior Minor Hook Type"
RebarSystemHookTypeBottomDirn1 | "Bottom Major Hook Type"
RebarSystemHookTypeBottomDirn2 | "Bottom Minor Hook Type"
RebarSystemHookTypeFrontDirn1 | "Exterior Major Hook Type"
RebarSystemHookTypeFrontDirn2 | "Exterior Minor Hook Type"
RebarSystemHookTypeTopDirn1 | "Top Major Hook Type"
RebarSystemHookTypeTopDirn2 | "Top Minor Hook Type"
RebarSystemLayerSummaryBottomDir1NoSpacing | "Bottom/Interior Major (Brief)"
RebarSystemLayerSummaryBottomDir1WithSpacing | "Bottom/Interior Major"
RebarSystemLayerSummaryBottomDir2NoSpacing | "Bottom/Interior Minor (Brief)"
RebarSystemLayerSummaryBottomDir2WithSpacing | "Bottom/Interior Minor"
RebarSystemLayerSummaryDir1NoSpacing | "Major, Both Faces (Brief)"
RebarSystemLayerSummaryDir1WithSpacing | "Major, Both Faces"
RebarSystemLayerSummaryDir2NoSpacing | "Minor, Both Faces (Brief)"
RebarSystemLayerSummaryDir2WithSpacing | "Minor, Both Faces"
RebarSystemLayerSummaryNoSpacing | "Layer Summary (Brief)"
RebarSystemLayerSummaryTopDir1NoSpacing | "Top/Exterior Major (Brief)"
RebarSystemLayerSummaryTopDir1WithSpacing | "Top/Exterior Major"
RebarSystemLayerSummaryTopDir2NoSpacing | "Top/Exterior Minor (Brief)"
RebarSystemLayerSummaryTopDir2WithSpacing | "Top/Exterior Minor"
RebarSystemLayerSummaryWithSpacing | "Layer Summary"
RebarSystemLayoutRule | "Layout Rule"
RebarSystemNumberOfLinesBackDirn1 | "Interior Major Number Of Lines"
RebarSystemNumberOfLinesBackDirn2 | "Interior Minor Number Of Lines"
RebarSystemNumberOfLinesBottomDir1Generic | "Bottom/Interior Major Number Of Lines"
RebarSystemNumberOfLinesBottomDir2Generic | "Bottom/Interior Minor Number Of Lines"
RebarSystemNumberOfLinesBottomDirn1 | "Bottom Major Number Of Lines"
RebarSystemNumberOfLinesBottomDirn2 | "Bottom Minor Number Of Lines"
RebarSystemNumberOfLinesFrontDirn1 | "Exterior Major Number Of Lines"
RebarSystemNumberOfLinesFrontDirn2 | "Exterior Minor Number Of Lines"
RebarSystemNumberOfLinesTopDir1Generic | "Top/Exterior Major Number Of Lines"
RebarSystemNumberOfLinesTopDir2Generic | "Top/Exterior Minor Number Of Lines"
RebarSystemNumberOfLinesTopDirn1 | "Top Major Number Of Lines"
RebarSystemNumberOfLinesTopDirn2 | "Top Minor Number Of Lines"
RebarSystemOverride | "Override Area Reinforcement Settings"
RebarSystemSpacingBackDirn1 | "Interior Major Spacing"
RebarSystemSpacingBackDirn2 | "Interior Minor Spacing"
RebarSystemSpacingBottomDir1Generic | "Bottom/Interior Major Spacing"
RebarSystemSpacingBottomDir2Generic | "Bottom/Interior Minor Spacing"
RebarSystemSpacingBottomDirn1 | "Bottom Major Spacing"
RebarSystemSpacingBottomDirn2 | "Bottom Minor Spacing"
RebarSystemSpacingFrontDirn1 | "Exterior Major Spacing"
RebarSystemSpacingFrontDirn2 | "Exterior Minor Spacing"
RebarSystemSpacingTopDir1Generic | "Top/Exterior Major Spacing"
RebarSystemSpacingTopDir2Generic | "Top/Exterior Minor Spacing"
RebarSystemSpacingTopDirn1 | "Top Major Spacing"
RebarSystemSpacingTopDirn2 | "Top Minor Spacing"
RebarSystemSpanactiveDirn1 | "Bars In Major Direction"
RebarSystemSpanactiveDirn2 | "Bars In Minor Direction"
RebarSystemSpanhookBottomDirn2 | "Hook Angle Bottom"
RebarSystemSpanhookLeftDirn1 | "Hook Angle Left"
RebarSystemSpanhookRightDirn1 | "Hook Angle Right"
RebarSystemSpanhookTopDirn2 | "Hook Angle Top"
RebarSystemTopMajorMatchesBottomMajor | "Top and Bottom Major Layers Match"
RebarSystemTopMajorMatchesTopMinor | "Top Major and Minor Layers Match"
RebarSystemTopMinorMatchesBottomMinor | "Top and Bottom Minor Layers Match"
RebarWorkshopInstructions | "Workshop Instructions"
RectMullionThick | "Thickness"
RectMullionWidth1 | "Width on side 1"
RectMullionWidth2 | "Width on side 2"
ReferenceBaseOnHost | "Reference Base on Host"
ReferencedView | "Referenced View": The view referenced by a section or callout.
ReferenceLineSubcategory | "Subcategory"
ReferenceOtherViewUiRefView | "Reference View": This is used by the UI to allow selection of view reference.
ReferenceOtherViewUiToggle | "Reference Other View": This is used to determine whether reference other view is enable or not.
ReferenceViewerAttrTag | "View Reference Tag"
ReferenceViewerTargetView | "Target view"
ReferenceViewerUiTargetFilter | "Filter": This is used by the UI to filter the list of target views.
ReferenceViewerUiTargetView | "Target view": This is used by the UI to allow selection of target view. It allows the UI to set a filter that is incompatible with the current target view (REFERENCE_VIEWER_TARGET_VIEW).
RefTableElemName | "Key Name"
RefTableParamName | "Parameter Name"
ReinEstBarLength | "Estimated Total Bar Length"
ReinEstBarVolume | "Estimated Reinforcement Volume"
ReinEstNumberOfBars | "Estimated Number of Bars"
ReinforcementVolume | "Reinforcement Volume"
RelatedToMass | "Related to Mass"
RelativeRoughness | "Relative Roughness"
RenderPlantHeight | "Height"
RenderPlantName | "Plant Name"
RenderPlantTrimHeight | "Plant Trim Height"
RenderRpcFilename | "Render Appearance"
RenderRpcProperties | "Render Appearance Properties"
RepeatingDetailElement | "Detail"
RepeatingDetailInside | "Inside"
RepeatingDetailLayout | "Layout"
RepeatingDetailNumber | "Number"
RepeatingDetailRotation | "Detail Rotation"
RepeatingDetailSpacing | "Spacing"
RevealProfileParam | "Profile"
RevisionCloudRevision | "Revision"
RevisionCloudRevisionDate | "Revision Date"
RevisionCloudRevisionDescription | "Revision Description"
RevisionCloudRevisionIssuedBy | "Issued by"
RevisionCloudRevisionIssuedTo | "Issued to"
RevisionCloudRevisionNum | "Revision Number"
RevolutionEndAngle | "End Angle"
RevolutionStartAngle | "Start Angle"
RgbBParam | "Blue value for RGB color spec. (for Use with XAML Data Template example)"
RgbGParam | "Green value for RGB color spec. (for Use with XAML Data Template example)"
RgbRParam | "Red value for RGB color spec. (for Use with XAML Data Template example)"
RoofAttrDefaultThicknessParam | "Default Thickness"
RoofAttrThicknessParam | "Thickness"
RoofBaseLevelParam | "Base Level"
RoofConstraintLevelParam | "Reference Level"
RoofConstraintOffsetParam | "Level Offset"
RoofCurveHeightAtWall | "Plate Offset From Base"
RoofCurveHeightOffset | "Offset From Roof Base"
RoofCurveIsSlopeDefining | "Defines Roof Slope"
RoofEaveCutParam | "Rafter Cut"
RoofFacesLocation | "Picked Faces Location"
RoofLevelOffsetParam | "Base Offset From Level"
RoofRafterOrTrussParam | "Rafter or Truss"
RoofSlope | "Slope"
RoofStructureIdParam | "Structure"
RoofUptoLevelOffsetParam | "Cutoff Offset"
RoofUptoLevelParam | "Cutoff Level"
RoomActualExhaustAirflowParam | "Actual Exhaust Airflow"
RoomActualLightingLoadParam | "Actual Lighting Load"
RoomActualLightingLoadPerAreaParam | "Actual Lighting Load per area"
RoomActualPowerLoadParam | "Actual Power Load"
RoomActualPowerLoadPerAreaParam | "Actual Power Load per area"
RoomActualReturnAirflowParam | "Actual Return Airflow"
RoomActualSupplyAirflowParam | "Actual Supply Airflow"
RoomAirChangesPerHourParam | "Air Changes per Hour"
RoomArea | "Area"
RoomAreaPerPersonParam | "Area per Person"
RoomBaseHeatLoadOnParam | "Heat Load Values"
RoomBaseLightingLoadOnParam | "Base Lighting Load on"
RoomBasePowerLoadOnParam | "Base Power Load on"
RoomBaseReturnAirflowOnParam | "Return Airflow"
RoomCalculatedCoolingLoadParam | "Calculated Cooling Load"
RoomCalculatedCoolingLoadPerAreaParam | "Calculated Cooling Load per area"
RoomCalculatedHeatingLoadParam | "Calculated Heating Load"
RoomCalculatedHeatingLoadPerAreaParam | "Calculated Heating Load per area"
RoomCalculatedSupplyAirflowParam | "Calculated Supply Airflow"
RoomCalculatedSupplyAirflowPerAreaParam | "Calculated Supply Airflow per area"
RoomCalculationPoint | "Room Calculation Point"
RoomComputationHeight | "Computation Height"
RoomComputationMethod | "Computation"
RoomConditionTypeParam | "Condition Type"
RoomConstructionSetParam | "Construction Type"
RoomDepartment | "Department"
RoomDesignCoolingLoadParam | "Design Cooling Load"
RoomDesignExhaustAirflowParam | "Specified Exhaust Airflow"
RoomDesignHeatingLoadParam | "Design Heating Load"
RoomDesignLightingLoadParam | "Specified Lighting Load"
RoomDesignLightingLoadPerAreaParam | "Specified Lighting Load per area"
RoomDesignMechanicalLoadPerAreaParam | "Design HVAC Load per area"
RoomDesignOtherLoadPerAreaParam | "Design Other Load per area"
RoomDesignPowerLoadParam | "Specified Power Load"
RoomDesignPowerLoadPerAreaParam | "Specified Power Load per area"
RoomDesignReturnAirflowParam | "Specified Return Airflow"
RoomDesignSupplyAirflowParam | "Specified Supply Airflow"
RoomEditElectricalLoadsParam | "Electrical Loads"
RoomEditPeopleLoadsParam | "People"
RoomFinishBase | "Base Finish"
RoomFinishCeiling | "Ceiling Finish"
RoomFinishFloor | "Floor Finish"
RoomFinishWall | "Wall Finish"
RoomHeight | "Unbounded Height"
RoomLevelId | "Level"
RoomLightingLoadUnitsParam | "Lighting Load Units"
RoomLowerOffset | "Base Offset"
RoomName | "Name"
RoomNumber | "Number"
RoomNumberOfPeopleParam | "Number of People"
RoomOccupancy | "Occupancy"
RoomOccupancyUnitParam | "Occupancy Unit"
RoomOutdoorAirflowParam | "Outdoor Airflow"
RoomOutdoorAirflowStandardParam | "Outdoor Air Method"
RoomOutdoorAirInfoParam | "Outdoor Air Information"
RoomOutdoorAirPerAreaParam | "Outdoor Air per Area"
RoomOutdoorAirPerPersonParam | "Outdoor Air per Person"
RoomPeopleLatentHeatGainPerPersonParam | "Latent Heat Gain per person"
RoomPeopleSensibleHeatGainPerPersonParam | "Sensible Heat Gain per person"
RoomPeopleTotalHeatGainPerPersonParam | "Total Heat Gain per person"
RoomPerimeter | "Perimeter"
RoomPhase | "Phase"
RoomPhaseId | "Phase Id"
RoomPlenumLightingParam | "Plenum Lighting Contribution"
RoomPowerLoadUnitsParam | "Power Load Units"
RoomSpaceTypeParam | "Space Type"
RoomTagOrientationParam | "Orientation"
RoomUpperLevel | "Upper Limit"
RoomUpperOffset | "Limit Offset"
RoomVolume | "Volume"
RouteAnalysisSettingsParam | "Route Analysis Settings"
RoutingPreferenceParam | "Routing Preference"
RvtHostLevel | "Map Levels..."
RvtLevelOffset | "Map Levels..."
RvtLinkFileNameWithoutExt | "File Name"
RvtLinkInstanceName | "Name"
RvtLinkInstanceProjectInformation | "Project Information"
RvtLinkPhaseMap | "Phase Mapping"
RvtLinkReferenceType | "Reference Type"
RvtSourceLevel | "Map Levels..."
ScaleFactorParam | "Scale"
ScheduleBaseLevelOffsetParam | "Base Offset"
ScheduleBaseLevelParam | "Base Level"
ScheduleCategory | "Category"
ScheduleEmbeddedParam | "Embedded Schedule"
ScheduleFieldsParam | "Fields"
ScheduleFilterParam | "Filter"
ScheduleFormatParam | "Formatting"
ScheduleGroupParam | "Sorting/Grouping"
ScheduleLevelParam | "Level"
ScheduleResizeRows | "Resize Rows"
ScheduleRotationOnSheet | "Rotation on Sheet"
ScheduleRowHeightInput | "Row Height"
ScheduleSheetAppearanceParam | "Appearance"
ScheduleTopLevelOffsetParam | "Top Offset"
ScheduleTopLevelParam | "Top Level"
ScheduleTypeForBrowser | "Schedule Type"
SectionAttrHeadTag | "Section Head"
SectionAttrTailLength | "Tail length"
SectionAttrTailTag | "Section Tail"
SectionAttrTailWidth | "Tail width"
SectionBrokenDisplayStyle | "Broken Section Display Style"
SectionCoarserScalePulldownImperial | "Hide at scales coarser than"
SectionCoarserScalePulldownMetric | "Hide at scales coarser than"
SectionParentViewName | "Parent View"
SectionShowInOneViewOnly | "Show in"
SectionTag | "Section Tag"
SeekItemId | "Seek Item ID"
SelectionEditableOnly | "Editable only"
SheetApprovedBy | "Approved By"
SheetAssemblyAssemblyCode | "Assembly: Assembly Code"
SheetAssemblyAssemblyDescription | "Assembly: Assembly Description"
SheetAssemblyCost | "Assembly: Cost"
SheetAssemblyDescription | "Assembly: Description"
SheetAssemblyKeynote | "Assembly: Keynote"
SheetAssemblyManufacturer | "Assembly: Manufacturer"
SheetAssemblyModel | "Assembly: Model"
SheetAssemblyName | "Assembly: Name"
SheetAssemblyTypeComments | "Assembly: Type Comments"
SheetAssemblyTypeMark | "Assembly: Type Mark"
SheetAssemblyUrl | "Assembly: URL"
SheetCheckedBy | "Checked By"
SheetCollection | "Sheet Collection"
SheetCollectionName | "Name"
SheetCurrentRevision | "Current Revision"
SheetCurrentRevisionDate | "Current Revision Date"
SheetCurrentRevisionDescription | "Current Revision Description"
SheetCurrentRevisionIssued | "Current Revision Issued"
SheetCurrentRevisionIssuedBy | "Current Revision Issued By"
SheetCurrentRevisionIssuedTo | "Current Revision Issued To"
SheetDate | "Date/Time Stamp"
SheetDesignedBy | "Designed By"
SheetDrawnBy | "Drawn By"
SheetFilePath | "File Path"
SheetGuideGrid | "Guide Grid"
SheetHeight | "Sheet Height"
SheetIssueDate | "Sheet Issue Date"
SheetKeyNumber | "Sheet Key Number"
SheetName | "Sheet Name"
SheetNumber | "Sheet Number"
SheetRevisionsOnSheet | "Revisions on Sheet"
SheetScale | "Scale"
SheetScheduled | "Appears In Sheet List"
SheetWidth | "Sheet Width"
ShowArrowheadToCutMark | "Show Arrowhead to Cut Mark"
ShowIconParam | "Flag to display icon in Ribbon Combo Item"
ShowTitle | "Show Title"
SketchGridSpacingParam | "Work Plane Grid Spacing"
SketchPlaneParam | "Work Plane"
SlabEdgeMaterialParam | "Material"
SlabEdgeProfileParam | "Profile"
SlantedColumnBaseCutStyle | "Base Cut Style"
SlantedColumnBaseExtension | "Base Extension"
SlantedColumnGeometryTreatmentBase | "Base Geometry Alignment"
SlantedColumnGeometryTreatmentTop | "Top Geometry Alignment"
SlantedColumnTopCutStyle | "Top Cut Style"
SlantedColumnTopExtension | "Top Extension"
SlantedColumnTypeParam | "Column Style"
SlopeArrowLevelEnd | "Level at Head"
SlopeArrowLevelStart | "Level at Tail"
SlopeEndHeight | "Height Offset at Head"
SlopeStartHeight | "Height Offset at Tail"
SpaceAirChangesPerHour | "Air Changes per Hour"
SpaceAirflowPerAreaParam | "Airflow per area"
SpaceArea | "Area"
SpaceAreaPerPersonParam | "Area per person"
SpaceAssocRoomName | "Room Name"
SpaceAssocRoomNumber | "Room Number"
SpaceCarpetingParam | "Carpeting"
SpaceComposednameParam | "Composed Name"
SpaceConditionType | "Condition Type"
SpaceCoolingSetPoint | "Cooling Set Point"
SpaceDehumidificationSetPoint | "Dehumidification Set Point"
SpaceElecEquipmentRadiantPercentageParam | "Electrical Equipment Radiant"
SpaceHeatingSetPoint | "Heating Set Point"
SpaceHumidificationSetPoint | "Humidification Set Point"
SpaceInfiltrationAirflow | "Infiltration Airflow"
SpaceInfiltrationAirflowPerArea | "Infiltration Airflow per area"
SpaceInfiltrationParam | "Infiltration Airflow per area"
SpaceIsOccupiable | "Occupiable"
SpaceIsPlenum | "Plenum"
SpaceLightingLoadParam | "Lighting Load"
SpaceLightingLoadPerAreaParam | "Lighting Load per area"
SpaceLightingScheduleParam | "Lighting Schedule"
SpaceNameParam | "Name"
SpaceNumberOfPeople | "Number of People"
SpaceNumberParam | "Number"
SpaceOccupancyScheduleParam | "Occupancy Schedule"
SpaceOutdoorAirflow | "Outdoor Airflow"
SpaceOutdoorAirflowPerArea | "Outdoor Airflow per area"
SpaceOutdoorAirflowPerPerson | "Outdoor Airflow per person"
SpacePeopleActivityLevelParam | "People Activity Level"
SpacePeopleLatentHeatGainPerPersonParam | "Latent Heat Gain per person"
SpacePeopleLoadParam | "Occupancy Load"
SpacePeopleSensibleHeatGainPerPersonParam | "Sensible Heat Gain per person"
SpacePowerLoadParam | "Power Load"
SpacePowerLoadPerAreaParam | "Power Load per area"
SpacePowerScheduleParam | "Power Schedule"
SpaceReferenceLevelParam | "Reference Level"
SpaceTypeGbxml | "Space Type (gbXML)"
SpaceVolume | "Volume"
SpaceZoneName | "Zone"
SpacingAppend | "Append Position"
SpacingJustification | "Justification"
SpacingJustificationHoriz | "Justification"
SpacingJustificationn1 | "Justification"
SpacingJustificationn2 | "Justification"
SpacingJustificationU | "Justification"
SpacingJustificationV | "Justification"
SpacingJustificationVert | "Justification"
SpacingLayout | "Layout"
SpacingLayoutHoriz | "Layout"
SpacingLayoutn1 | "Layout"
SpacingLayoutn2 | "Layout"
SpacingLayoutU | "Layout"
SpacingLayoutV | "Layout"
SpacingLayoutVert | "Layout"
SpacingLength | "Spacing"
SpacingLengthHoriz | "Spacing"
SpacingLengthn1 | "Spacing"
SpacingLengthn2 | "Spacing"
SpacingLengthU | "Distance"
SpacingLengthV | "Distance"
SpacingLengthVert | "Spacing"
SpacingNumDivisions | "Number"
SpacingNumDivisionsHoriz | "Number"
SpacingNumDivisionsn1 | "Number"
SpacingNumDivisionsn2 | "Number"
SpacingNumDivisionsU | "Number"
SpacingNumDivisionsV | "Number"
SpacingNumDivisionsVert | "Number"
SpanDirInstParamAngle | "Span Direction"
SpanDirSymParamBottom | "Bottom"
SpanDirSymParamLeft | "Left"
SpanDirSymParamRight | "Right"
SpanDirSymParamTop | "Top"
SpatialFieldMgrCurrentName | "Analysis Configuration"
SpatialFieldMgrDescription | "Description"
SpatialFieldMgrLegendHeight | "Legend Height"
SpatialFieldMgrLegendHorOriginGap | "Legend Horizontal Origin Gap"
SpatialFieldMgrLegendShowConfigName | "Show Configuration Name"
SpatialFieldMgrLegendShowDescription | "Show Description"
SpatialFieldMgrLegendTextType | "Overall Legend Text"
SpatialFieldMgrLegendVertOriginGap | "Legend Vertical Origin Gap"
SpatialFieldMgrLegendWidth | "Legend Width"
SpatialFieldMgrRange | "Data Range"
SpatialFieldMgrResultsVisibility | "Results Visibility"
SpecifySlopeOrOffset | "Specify "
SpliceByRulesMaxLength | "Maximum bar length"
SpliceByRulesMinLength | "Minimum bar length"
SpliceByRulesRunout | "Runout"
SpliceLapLengthAtEnd | "Lap Length at End"
SpliceLapLengthAtStart | "Lap Length at Start"
SpliceTypeAtEnd | "Splice at End"
SpliceTypeAtStart | "Splice at Start"
SpotCoordinateBase | "Coordinate Base"
SpotCoordinateBottomPrefix | "Bottom Coordinate Prefix"
SpotCoordinateBottomSuffix | "Bottom Coordinate Suffix"
SpotCoordinateElevationPrefix | "Elevation Prefix"
SpotCoordinateElevationSuffix | "Elevation Suffix"
SpotCoordinateIncludeElevation | "Include Elevation"
SpotCoordinateTopPrefix | "Top Coordinate Prefix"
SpotCoordinateTopSuffix | "Top Coordinate Suffix"
SpotDimLeader | "Leader"
SpotDimLeaderLine | "Leader Line"
SpotDimStyleSlopeUnits | "Units Format"
SpotDimStyleSlopeUnitsAlt | "Alternate Units Format"
SpotElevBase | "Elevation Base"
SpotElevBendLeader | "Leader Shoulder"
SpotElevBotValue | "Bottom Coordinate"
SpotElevDisplayElevations | "Display Elevations"
SpotElevFlipTextVert | "Auto Mirror"
SpotElevIndBottom | "Bottom Indicator"
SpotElevIndElevation | "Elevation Indicator"
SpotElevIndEw | "East / West Indicator"
SpotElevIndNs | "North / South Indicator"
SpotElevIndTop | "Top Indicator"
SpotElevIndType | "Indicator as Prefix / Suffix"
SpotElevIndTypeBottom | "Bottom Indicator as Prefix/Suffix"
SpotElevIndTypeElevation | "Elevation Indicator as Prefix/Suffix"
SpotElevIndTypeTop | "Top Indicator as Prefix/Suffix"
SpotElevLeaderArrowhead | "Leader Arrowhead"
SpotElevLinePen | "Leader Line Weight"
SpotElevLowerPrefix | "Lower Value Prefix"
SpotElevLowerSuffix | "Lower Value Suffix"
SpotElevLowerValue | "Lower Value"
SpotElevRelativeBase | "Relative Base"
SpotElevRotateWithComponent | "Rotate with Component"
SpotElevSingleOrUpperPrefix | "Single/Upper Value Prefix"
SpotElevSingleOrUpperSuffix | "Single/Upper Value Suffix"
SpotElevSingleOrUpperValue | "Single/Upper Value"
SpotElevSymbol | "Symbol"
SpotElevTextHorizOffset | "Text Offset from Symbol"
SpotElevTextLocation | "Text Location"
SpotElevTextOrientation | "Text Orientation"
SpotElevTickMarkPen | "Leader Arrowhead Line Weight"
SpotElevTopValue | "Top Coordinate"
SpotSlopeLeaderLength | "Leader Line Length"
SpotSlopeOffsetFromReference | "Offset from Reference"
SpotSlopePrefix | "Prefix"
SpotSlopeSlopeDirection | "Slope Direction"
SpotSlopeSlopeRepresentation | "Slope Representation"
SpotSlopeSuffix | "Suffix"
SpotTextFromLeader | "Text Offset from Leader"
SsePointBasetypeEnum | "Point Base Type"
SsePointElevation | "Elevation"
SsePointElevationBaseType | "Elevation Base Type"
SsePointOffsetFromSnaps | "Offset from Snaps"
SsePointOffsetFromSurface | "Offset from Surface"
StairsActualNumberOfRisers | "Actual Number of Risers": The total number of actually created risers in model
StairsActualNumRisers | "Actual Number of Risers"
StairsActualRiserHeight | "Actual Riser Height"
StairsActualTreadDepth | "Actual Tread Depth"
StairsAttrBodyMaterial | "Monolithic Material"
StairsAttrBreakSymInCutline | "Break Symbol in Plan"
StairsAttrCalcEnabled | "Calculation Rules"
StairsAttrCalcMax | "Calculation Rules"
StairsAttrCalcMin | "Calculation Rules"
StairsAttrEqResult | "Calculation Rules"
StairsAttrFirstRiser | "Begin with Riser"
StairsAttrLandingCarriage | "Landing Carriage Height"
StairsAttrLandingsOverlapping | "Landing Overlap"
StairsAttrLastRiser | "End with Riser"
StairsAttrLeftSideStringer | "Left Stringer"
StairsAttrMaxRiserHeight | "Maximum Riser Height"
StairsAttrMinimumTreadDepth | "Minimum Tread Depth"
StairsAttrMonolithicStairs | "Monolithic Stairs"
StairsAttrNosingLength | "Nosing Length"
StairsAttrNosingPlacement | "Apply Nosing Profile"
StairsAttrNumMidStringers | "Middle Stringers"
StairsAttrRightSideStringer | "Right Stringer"
StairsAttrRiserAngle | "Riser Angle"
StairsAttrRiserMaterial | "Riser Material"
StairsAttrRiserMult | "Riser Multiplier"
StairsAttrRisersPresent | "Risers Present"
StairsAttrRiserThickness | "Riser Thickness"
StairsAttrRiserTreadConnect | "Riser to Tread Connection"
StairsAttrRiserType | "Riser Type"
StairsAttrSideStringerTypeParam | "Type of Side Stringers"
StairsAttrStairCalculator | "Calculation Rules"
StairsAttrStairsBottom | "Underside of Winder"
StairsAttrStairsCutOffset | "Extend Below Base"
StairsAttrStringerCarriage | "Stringer Carriage Height"
StairsAttrStringerHeight | "Stringer Height"
StairsAttrStringerMaterial | "Stringer Material"
StairsAttrStringerOffset | "Open Stringer Offset"
StairsAttrStringerThickness | "Stringer Thickness"
StairsAttrTextFont | "Text Font"
StairsAttrTextSize | "Text Size"
StairsAttrTreadFrontProfile | "Nosing Profile"
StairsAttrTreadMaterial | "Tread Material"
StairsAttrTreadMult | "Tread Multiplier"
StairsAttrTreadThickness | "Tread Thickness"
StairsAttrTreadWidth | "Width"
StairsAttrTrimTop | "Trim Stringers at Top"
StairsBaseLevel | "Base Level": The base level of stairs
StairsBaseLevelParam | "Base Level"
StairsBaseOffset | "Base Offset"
StairsCurveType | "Stairs Line Type"
StairsDbgShowAnnotationCutMark | "Cut by Cut Plane"
StairsDbgShowBoundary2d | "Show Stairs' Boundary 2D"
StairsDbgShowBoundary3d | "Show Stairs' Boundary 3D"
StairsDbgShowLandingBoundary | "Show Landing Boundary"
StairsDbgShowLandingFaces | "Show Landing Faces"
StairsDbgShowLandingPath | "Show Landing Path"
StairsDbgShowLeftRunBoundary2d | "Show Run's Left Boundary 2D"
StairsDbgShowLeftRunBoundary3d | "Show Run's Left Boundary 3D"
StairsDbgShowMonolithicSupportCorseGeom | "Show Monolithic Support Corse Geometry"
StairsDbgShowMonolithicSupportGeom | "Show Monolithic Support Geometry"
StairsDbgShowRightRunBoundary2d | "Show Run's Right Boundary 2D"
StairsDbgShowRightRunBoundary3d | "Show Run's Right Boundary 3D"
StairsDbgShowRunCorseGeom | "Show Run Corse Geometry"
StairsDbgShowRunGeom | "Show Run Geometry"
StairsDbgShowRunNosing | "Show Run's Nosings"
StairsDbgShowRunOutlineForPlan | "Show Run Outline For Plan"
StairsDbgShowRunPath2d | "Show Run's Path 2D"
StairsDbgShowRunPath3d | "Show Run's Path 3D"
StairsDbgShowRunRiser | "Show Run's Risers"
StairsDbgShowSupportPath | "Show Support Path"
StairsDbgShowTreadFaces | "Show Run's Tread Faces"
StairsDbgShowTriserCorseGeom | "Show Triser Corse Geometry"
StairsDbgShowTriserGeom | "Show Triser Geometry"
StairsDesiredNumberOfRisers | "Desired Number of Risers": The number of risers is calculated based on stairs height
StairsDesiredNumRisers | "Desired Number of Risers"
StairsDownText | "Down Text"
StairsEnableCalculationRuleChecking | "Enable Calculator Rules Check": Enable calculation rule checking
StairsInstAlwaysUp | "Show Up arrow in all views"
StairsInstDownArrowOn | "Down arrow"
StairsInstDownLabelOn | "Down label"
StairsInstDownLabelText | "Down text"
StairsInstUpArrowOn | "Up arrow"
StairsInstUpLabelOn | "Up label"
StairsInstUpLabelText | "Up text"
StairsLandingBaseElevation | "Relative Height": Height
StairsLandingOverridden | "Overridden": Overridden
StairsLandingStructural | "Structural": Structural
StairsLandingThickness | "Total Thickness": Thickness
StairsLandingtypeHasMonolithicSupport | "Monolithic Support": Monolithic Support
StairsLandingtypeLandingMaterial | "Monolithic Material": Landing Material
StairsLandingtypeStructure | "Structure": Structure
StairsLandingtypeThickness | "Monolithic Thickness": Default thickness
StairsLandingtypeTreadriserType | "Type": Tread/Riser Type
StairsLandingtypeUseSameTriserAsRun | "Same as Run": Same as Run
StairsMinAutomaticLandingDepth | "Minimum Automatic Landing Depth": The minimum depth of automatic landing
StairsMultistoryTopLevelParam | "Multistory Top Level"
StairsMultistoryUpToLevel | "Multistory Top Level": The top level of multi-story stairs
StairsPathFullStepArrow | "Full Step Arrow"
StairsPathStartExtension | "Start Extension"
StairsPathStartFromRiser | "Start from Riser"
StairsRailingAngledConnection | "Angled Joins"
StairsRailingBalusterBottomAngle | "Bottom Cut Angle"
StairsRailingBalusterFamily | "Baluster Family"
StairsRailingBalusterHeight | "Baluster Height"
StairsRailingBalusterIsPost | "Post"
StairsRailingBalusterLength | "Baluster Length"
StairsRailingBalusterOffset | "Baluster Offset"
StairsRailingBalusterPlacement | "Baluster Placement"
StairsRailingBalusterShape | "Baluster Shape"
StairsRailingBalusterSlopeAngle | "Slope Angle"
StairsRailingBalusterSpacing | "Baluster Separation"
StairsRailingBalusterSpacingType | "Baluster Spacing Type (Stair Railing Only)"
StairsRailingBalustersPerTread | "Balusters Per Tread (Stair Railing Only)"
StairsRailingBalusterTopAngle | "Top Cut Angle"
StairsRailingBalusterWidth | "Baluster Width"
StairsRailingBaseLevelParam | "Base Level"
StairsRailingConnection | "Rail Connections"
StairsRailingHeight | "Railing Height"
StairsRailingHeightOffset | "Base Offset"
StairsRailingHeightShiftType | "Use Landing Height Adjustment"
StairsRailingHeightShiftVal | "Landing Height Adjustment"
StairsRailingPlacementOffset | "Offset from Path"
StairsRailingRailHeight | "Rail Height"
StairsRailingRailName | "Name"
StairsRailingRailOffset | "Rail Offset"
StairsRailingRailStructure | "Rail Structure (Non-Continuous)"
StairsRailingShape | "Rail Shape"
StairsRailingTangentConnection | "Tangent Joins"
StairsRailingThickness | "Railing Thickness"
StairsRailingWidth | "Railing Width"
StairsRunActualNumberOfRisers | "Actual Number of Risers": Actual Number of Risers
StairsRunActualNumberOfTreads | "Actual Number of Treads": Actual Number of Treads
StairsRunActualRiserHeight | "Actual Riser Height": Actual Riser Height
StairsRunActualRunWidth | "Actual Run Width": Actual Run Width
StairsRunActualTreadDepth | "Actual Tread Depth": Actual Tread Depth
StairsRunBeginWithRiser | "Begin with Riser": Begin with Riser
StairsRunBottomElevation | "Relative Base Height": Relative height to stairs bottom elevation
StairsRunCcw | "CCW": Revert the run preview
StairsRunCenterMarkVisible | "Center Mark Visible": Center Mark Visible
StairsRunCreateAutoLanding | "With Automatic Landing": Create automatic landing
StairsRunEndWithRiser | "End with Riser": End with Riser
StairsRunExtendBelowRiserBase | "Extend Below Riser Base": Extend Below Base
StairsRunExtendBelowTreadBase | "Extend Below Tread Base": Extend Below Tread Base
StairsRunHeight | "Run Height": Run Height
StairsRunLocationpathJustfication | "Location Line": Location Line
StairsRunOverridden | "Overridden": Overridden
StairsRunStructural | "Structural": Structural
StairsRunTopElevation | "Relative Top Height": Top height of run
StairsRuntypeHasMonolithicSupport | "Monolithic Support": Monolithic Support
StairsRuntypeRunMaterial | "Monolithic Material": Material
StairsRuntypeStructuralDepth | "Structural Depth": Structural Depth
StairsRuntypeStructure | "Structure": Structure
StairsRuntypeTotalDepth | "Total Depth": Total Depth
StairsRuntypeUndersideSurfaceType | "Underside Surface": Underside Surface
StairsRunWidthMeasurement | "Run Width Measurement": Run Width Measurement
StairsRunWinderBeginWithStraight | "Begin with Straight Run": Winder begin with straight run
StairsRunWinderEndWithStraight | "End with Straight Run": Winder end with straight run
StairsShowDownText | "Show Down Text"
StairsShowUpText | "Show Up Text"
StairsStairsHeight | "Desired Stair Height": Stairs unconnected height
StairsStringersPresent | "Stringer Position"
StairsSupportHorizontalOffset | "Lateral Offset": Distance from center or edge of boundary
StairsSupportLandingsupportType | "Landing Support Type": Landing Support Type
StairsSupportLowerEndCut | "Lower End Cut": Lower End Cut
StairsSupportOverridden | "Overridden": Overridden
StairsSupportTrimSupportUpper | "Trim Support at Upper": Trim Support at Upper
StairsSupporttypeFlipSectionProfile | "Flip Section Profile": Flip Section Profile
StairsSupporttypeMaterial | "Material": Material
StairsSupporttypeSectionProfile | "Section Profile": Section Profile
StairsSupporttypeStructuralDepth | "Structural Depth": Structural Depth
StairsSupporttypeStructuralDepthOnLanding | "Structural Depth On Landing": Structural Depth
StairsSupporttypeStructuralDepthOnRun | "Structural Depth On Run": Structural Depth
StairsSupporttypeTopsideSurface | "Topside Surface": Topside Surface
StairsSupporttypeTotalDepth | "Total Depth": Total Depth
StairsSupporttypeUndersideSurface | "Underside Surface": Underside Surface
StairsSupporttypeWidth | "Width": Width
StairsSupportUpperEndCut | "Upper End Cut": Upper End Cut
StairsSupportVerticalOffset | "Vertical Offset": Distance of top plane of edge stringer relative to the plane connecting tread nosing
StairsTextOrientation | "Orientation"
StairsTextType | "Text Type"
StairsTopLevel | "Top Level": The top level of stairs
StairsTopLevelParam | "Top Level"
StairsTopOffset | "Top Offset"
StairsTotalNumberOfRisers | "Total Number of Risers": Total number of risers
StairsTotalNumberOfTreads | "Total Number of Treads": Total number of treads
StairsTriserIsTypeOverridden | "Overridden": (OBSOLETE) Indicate whether selected individual step is governed by default type setting.
StairsTriserNumberBaseIndex | "Tread/Riser Start Number":
StairsTriserRiserMark | "Riser Mark": (OBSOLETE)
StairsTriserRiserNumber | "Riser Number": Count the sequential number of riser in the stair.
StairsTriserTreadMark | "Tread Mark": (OBSOLETE)
StairsTriserTreadNumber | "Tread Number": Count the sequential number of tread in the stair.
StairsTrisertypeBackNosing | "Back Nosing": (OBSOLETE)
StairsTrisertypeFrontNosing | "Front Nosing": (OBSOLETE)
StairsTrisertypeLeftNosing | "Left Nosing": (OBSOLETE)
StairsTrisertypeNosingLength | "Nosing Length"
StairsTrisertypeNosingPlacement | "Apply Nosing Profile"
StairsTrisertypeNosingProfile | "Nosing Profile"
StairsTrisertypeRightNosing | "Right Nosing": (OBSOLETE)
StairsTrisertypeRiser | "Riser"
StairsTrisertypeRiserIsSlanted | "Slanted"
StairsTrisertypeRiserMaterial | "Riser Material"
StairsTrisertypeRiserProfile | "Riser Profile"
StairsTrisertypeRiserStyle | "Riser Type": (OBSOLETE)
StairsTrisertypeRiserThickness | "Riser Thickness"
StairsTrisertypeRiserTreadConnection | "Riser To Tread Connection"
StairsTrisertypeTread | "Tread"
StairsTrisertypeTreadMaterial | "Tread Material"
StairsTrisertypeTreadProfile | "Tread Profile"
StairsTrisertypeTreadThickness | "Tread Thickness"
StairstypeCalcRuleMaxResult | "Max. Result": Calculation Rule Max Result
StairstypeCalcRuleMinResult | "Min. Result": Calculation Rule Min Result
StairstypeCalcRuleRiserMultiplier | "Riser Multiplier": Calculation Rule Riser Multiplier
StairstypeCalcRuleTargetResult | "Target Result": Calculation Rule Target Result
StairstypeCalcRuleTreadMultiplier | "Tread Multiplier": Calculation Rule Tread Multiplier
StairstypeCalculationRules | "Calculation Rules": Calculation Rules
StairstypeConstructionMethod | "Construction Method":
StairstypeCutmarkType | "Cut Mark Type": Cut Mark Type
StairstypeGeomunjoinedEndCutStyle | "Connection Method": Cut Style for Geometrically Unjoined End
StairstypeHasIntermediateSupport | "Middle Support": Whether stairs is assembled
StairstypeHasLeftSupport | "Left Support":
StairstypeHasRightSupport | "Right Support":
StairstypeIntermediateSupportType | "Middle Support Type": Intermediate Support Type
StairstypeIsAssembledStairs | "Assembled Stair": Whether stairs is assembled
StairstypeLandingType | "Landing Type": Landing Type
StairstypeLeftSideSupportType | "Left Support Type": Left Side Support Type
StairstypeLeftSupportLateralOffset | "Left Lateral Offset":
StairstypeMaximumRiserHeight | "Max. Riser Height": Maximum Riser Height
StairstypeMinimumRunWidth | "Minimum Run Width": Minimum Run Width
StairstypeMinimumTreadDepth | "Min. Tread Depth": Minimum Tread Depth
StairstypeMinimumTreadWidthInsideBoundary | "Min. Tread Depth on Winder Inner Boundary": Minimum Tread Width on Inside Boundary
StairstypeNotchCustomWidth | "Custom":
StairstypeNotchExtension | "Notch Extension":
StairstypeNotchHorizontalGap | "Horizontal Gap Distance":
StairstypeNotchThickness | "Notch Thickness":
StairstypeNotchVerticalGap | "Vertical Gap Distance":
StairstypeNotchWidth | "Notch Width":
StairstypeNumberOfIntermediateSupports | "Middle Support Number": Number of intermediate supports
StairstypeRightSideSupportType | "Right Support Type": Right Side Support Type
StairstypeRightSupportLateralOffset | "Right Lateral Offset":
StairstypeRunType | "Run Type": Run Type
StairstypeShowCutline | "Show Cut Line in Plan": Show Cut Line in Plan
StairstypeShowStairPath | "Show Stair Path in Plan": Show Stair Path in Plan
StairstypeShowUpdown | "Show Up/Down in Plan": Show Up/Down in Plan
StairstypeWinderStepFrontMeasurement | "Winder Algorithm": Winder Algorithm
StairsUpText | "Up Text"
StairsWinderpatternFilletInsideCorner | "Fillet on Corner": Fillet on inside corner
StairsWinderpatternMinimumWidthCorner | "Minimum Width on Inside Boundary": Minimum Width on Inside Boundary
StairsWinderpatternMinimumWidthInsideWalkline | "Minimum Width on Inside Walk Line": Minimum width on inside walkline
StairsWinderpatternNumberOfStraightStepsAtBegin | "Parallel Treads at Start": Number of straight steps at the begin of winder
StairsWinderpatternNumberOfStraightStepsAtEnd | "Parallel Treads at End": Number of straight steps at the begin of winder
StairsWinderpatternRadiusInterior | "Fillet Radius": The fillet corner radius on the interior boundary
StairsWinderpatternStairPathOffset | "Inside Walk Line Offset": The offset from inside walk line to interior boundary
StairsWinderpatternWinderStyle | "Winder Style": Winder Style
StartExtension | "Start Extension"
StartJoinCutback | "Start Join Cutback"
StartSymbolType | "Start Symbol Type"
StartYJustification | "Start y Justification"
StartYOffsetValue | "Start y Offset Value"
StartZJustification | "Start z Justification"
StartZOffsetValue | "Start z Offset Value"
SteelElemAnchorAssembly | "Assembly"
SteelElemAnchorDiameter | "Diameter"
SteelElemAnchorGrade | "Grade"
SteelElemAnchorLength | "Length"
SteelElemAnchorOrientation | "Anchor Orientation"
SteelElemAnchorStandard | "Standard"
SteelElemAnchorTotalWeight | "Total Weight"
SteelElemBoltAssembly | "Assembly"
SteelElemBoltCoating | "Coating"
SteelElemBoltDiameter | "Diameter"
SteelElemBoltFinishCalculationAtGap | "Finish Calculation At Gap"
SteelElemBoltGrade | "Grade"
SteelElemBoltGripLength | "Grip Length"
SteelElemBoltGripLengthIncrease | "Grip Length Increase"
SteelElemBoltInverted | "Inverted"
SteelElemBoltLength | "Bolt Length"
SteelElemBoltLocation | "Location"
SteelElemBoltStandard | "Standard"
SteelElemBoltTotalWeight | "Total Weight"
SteelElemCoating | "Coating"
SteelElemContourGapWidth | "Gap Width"
SteelElemContourSide1dist | "Boundary distance 1"
SteelElemContourSide2dist | "Boundary distance 2"
SteelElemCopeAroundAxis | "Around beam axis"
SteelElemCopeAxisAngle | "Tilt angle"
SteelElemCopeDistanceAxis | "Distance from axis"
SteelElemCopeWidthx | "Cutback"
SteelElemCopeXAngle | "Cross-section rotation"
SteelElemCopeZAngle | "Plan rotation"
SteelElemCutLength | "Cut Length"
SteelElemCutType | "Type"
SteelElemExactWeight | "Exact Weight"
SteelElemHoleAlpha | "Taper Angle"
SteelElemHoleAngle | "Chamfer angle"
SteelElemHoleBackTaperThread | "Back taper thread"
SteelElemHoleDefinition | "Hole Definition"
SteelElemHoleDepth | "Hole Depth"
SteelElemHoleDepthOfBoltHead | "Depth of bolt head"
SteelElemHoleDiameter | "Diameter"
SteelElemHoleHeadDiameter | "Head diameter"
SteelElemHoleSlotDirection | "Along side 1"
SteelElemHoleSlotLength | "Length of the slot"
SteelElemHoleTapping | "Right-handed thread"
SteelElemHoleTappingHole | "Tapping hole"
SteelElemHoleType | "Type"
SteelElemMark | "Assembly Mark"
SteelElemPaintArea | "Paint Area"
SteelElemParamBoringout | "Boring out"
SteelElemParamRadius | "Radius"
SteelElemPatternEdgeDistanceX | "Edge distance on side 1"
SteelElemPatternEdgeDistanceY | "Edge distance on side 2"
SteelElemPatternIntermediateDistanceX | "Intermediate distance on side 1"
SteelElemPatternIntermediateDistanceY | "Intermediate distance on side 2"
SteelElemPatternNumber | "Number"
SteelElemPatternNumberX | "Number on side 1"
SteelElemPatternNumberY | "Number on side 2"
SteelElemPatternRadius | "Radius"
SteelElemPatternTotalLength | "Length on side 1"
SteelElemPatternTotalWidth | "Length on side 2"
SteelElemPlateArea | "Area"
SteelElemPlateExactWeight | "Exact Weight"
SteelElemPlateJustification | "Justification"
SteelElemPlateLength | "Length"
SteelElemPlatePaintArea | "Paint Area"
SteelElemPlateShortenAngle | "Angle"
SteelElemPlateShortenCutstraight | "Cut straight"
SteelElemPlateShortenSuction | "Suction"
SteelElemPlateThickness | "Thickness"
SteelElemPlateType | "Type"
SteelElemPlateVolume | "Volume"
SteelElemPlateWeight | "Weight"
SteelElemPlateWidth | "Width"
SteelElemProfileLength | "Length"
SteelElemProfileType | "Profile Type"
SteelElemProfileVolume | "Volume"
SteelElemShearstudDiameter | "Diameter"
SteelElemShearstudGrade | "Grade"
SteelElemShearstudLength | "Length"
SteelElemShearstudStandard | "Standard"
SteelElemShearstudTotalWeight | "Total Weight"
SteelElemShortenAngley | "Angle along height"
SteelElemShortenAnglez | "Angle along width"
SteelElemShortenReflength | "Length"
SteelElemSinglePartMark | "Single Part Mark"
SteelElemWeight | "Weight"
SteelElemWeldContinuous | "Continuous"
SteelElemWeldDoubleEffectivethroat | "Double Effective Throat"
SteelElemWeldDoublePrepdepth | "Double Preparation Depth"
SteelElemWeldDoubleRootopening | "Double Root Opening"
SteelElemWeldDoubleSurfaceshape | "Double Surface Shape"
SteelElemWeldDoubleText | "Double Text"
SteelElemWeldDoubleThickness | "Double Thickness"
SteelElemWeldDoubleType | "Double Type"
SteelElemWeldDoubleWeldprep | "Double Weld preparation"
SteelElemWeldLength | "Length"
SteelElemWeldLocation | "Location"
SteelElemWeldMainEffectivethroat | "Main Effective Throat"
SteelElemWeldMainPrepdepth | "Main Preparation Depth"
SteelElemWeldMainRootopening | "Main Root Opening"
SteelElemWeldMainSurfaceshape | "Surface Shape"
SteelElemWeldMainText | "Main Text"
SteelElemWeldMainThickness | "Main Thickness"
SteelElemWeldMainType | "Main Type"
SteelElemWeldMainWeldprep | "Main Weld preparation"
SteelElemWeldPitch | "Pitch"
SteelElemWeldPrefix | "Prefix"
SteelElemWeldTextModule | "Text module"
SteelElemXDistance | "Side 1"
SteelElemYDistance | "Side 2"
SteelElemZclipType | "Boundary"
StiffenerClassification | "Classification"
StructConnectionApplyTo | "Apply to"
StructConnectionBeamEnd | "End Connection"
StructConnectionBeamStart | "Start Connection"
StructConnectionColumnBase | "Base Connection"
StructConnectionColumnTop | "Top Connection"
StructConnectionCutback | "Automatic Cutback for Beams and Braces"
StructConnectionTypeName | "Name"
StructFramJoinStatus | "Join Status"
StructuralAnalyticalBeamHorizontalProjectionPlane | "Horizontal Projection"
StructuralAnalyticalBeamRigidLink | "Analytical Links"
StructuralAnalyticalColumnHorizontalProjectionPlane | "Horizontal Projection"
StructuralAnalyticalColumnRigidLink | "Analytical Links"
StructuralAnalyticalHardPoints | "Use hard-points"
StructuralAnalyticalModel | "Enable Analytical Model"
StructuralAnalyticalProjectFloorPlane | "Vertical Projection"
StructuralAnalyticalProjectMemberPlane | "Vertical Projection"
StructuralAnalyticalProjectMemberPlaneColumnBottom | "Bottom Vertical Projection"
StructuralAnalyticalProjectMemberPlaneColumnTop | "Top Vertical Projection"
StructuralAnalyticalTessDeviation | "Maximum discretized offset"
StructuralAnalyticalTessellate | "Approximate curve"
StructuralAnalyzesAs | "Analyze As"
StructuralAssetParam | "Physical Material Asset"
StructuralAttachmentBaseDistance | "Base Attachment Distance"
StructuralAttachmentBaseRatio | "Base Attachment Ratio"
StructuralAttachmentBaseReferencedend | "Base Attachment Referenced End"
StructuralAttachmentBaseType | "Base Attachment Type"
StructuralAttachmentEndLevelReference | "End Attachment Level Reference"
StructuralAttachmentEndRefelementEnd | "End of Attachment to Reference Element"
StructuralAttachmentEndType | "End Attachment Type"
StructuralAttachmentEndValueDistance | "End Attachment Distance"
StructuralAttachmentEndValueElevation | "End Attachment Elevation"
StructuralAttachmentEndValueRatio | "End attachment ratio"
StructuralAttachmentStartLevelReference | "Start Attachment Level Reference"
StructuralAttachmentStartRefelementEnd | "Start of Attachment to Reference Element"
StructuralAttachmentStartType | "Start Attachment Type"
StructuralAttachmentStartValueDistance | "Start Attachment Distance"
StructuralAttachmentStartValueElevation | "Start Attachment Elevation"
StructuralAttachmentStartValueRatio | "Start Attachment Ratio"
StructuralAttachmentTopDistance | "Top Attachment Distance"
StructuralAttachmentTopRatio | "Top Attachment Ratio"
StructuralAttachmentTopReferencedend | "Top Attachment Referenced End"
StructuralAttachmentTopType | "Top Attachment Type"
StructuralBeamCutbackForColumn | "Beam cutback in plan"
StructuralBeamEnd0Elevation | "Start Level Offset"
StructuralBeamEnd1Elevation | "End Level Offset"
StructuralBeamEndAttachmentDistance | "End Attachment Distance"
StructuralBeamEndAttachmentRefcolumnEnd | "End of Attachment to Reference Column"
StructuralBeamEndAttachmentType | "End Attachment Type"
StructuralBeamEndSupport | "Beam End Pocket Seat"
StructuralBeamOrientation | "Orientation"
StructuralBeamStartAttachmentDistance | "Start Attachment Distance"
StructuralBeamStartAttachmentRefcolumnEnd | "Start of Attachment to Reference Column"
StructuralBeamStartAttachmentType | "Start Attachment Type"
StructuralBeamStartSupport | "Beam Start Pocket Seat"
StructuralBendDirAngle | "Cross-Section Rotation"
StructuralBottomReleaseFx | "Base Fx"
StructuralBottomReleaseFy | "Base Fy"
StructuralBottomReleaseFz | "Base Fz"
StructuralBottomReleaseMx | "Base Mx"
StructuralBottomReleaseMy | "Base My"
StructuralBottomReleaseMz | "Base Mz"
StructuralBottomReleaseType | "Base Release"
StructuralBraceRepresentation | "Representation Type"
StructuralCamber | "Camber Size"
StructuralConnectionApprovalStatus | "Approval Status"
StructuralConnectionCodeCheckingStatus | "Code Checking Status"
StructuralConnectionEditRangesOfApplicability | "Modify Ranges of applicability"
StructuralConnectionEditType | "Modify Parameters"
StructuralConnectionInputElements | "Input Elements"
StructuralConnectionModifyConnectionParameters | "Detailed Parameters"
StructuralConnectionNobleStatus | "Noble Status"
StructuralConnectionOverrideType | "Override by Instance"
StructuralConnectionSymbol | "Connection Symbol"
StructuralCopingDistance | "Coping Distance"
StructuralDisplayInHiddenViews | "Display in Hidden Views"
StructuralDisplayInHiddenViewsColumn | "Display in Hidden Views"
StructuralDisplayInHiddenViewsFraming | "Display in Hidden Views"
StructuralElevationAtBottom | "Elevation at Bottom"
StructuralElevationAtBottomCore | "Elevation at Bottom Core"
StructuralElevationAtBottomSurvey | "Elevation at Bottom Survey"
StructuralElevationAtTop | "Elevation at Top"
StructuralElevationAtTopCore | "Elevation at Top Core"
StructuralElevationAtTopSurvey | "Elevation at Top Survey"
StructuralEndReleaseFx | "End Fx"
StructuralEndReleaseFy | "End Fy"
StructuralEndReleaseFz | "End Fz"
StructuralEndReleaseMx | "End Mx"
StructuralEndReleaseMy | "End My"
StructuralEndReleaseMz | "End Mz"
StructuralEndReleaseType | "End Release"
StructuralFamilyCodeName | "Code Name"
StructuralFamilyNameKey | "Family Name Key"
StructuralFloorAnalyzesAs | "Analyze As"
StructuralFloorCoreThickness | "Core Thickness"
StructuralFoundationLength | "Length"
StructuralFoundationThickness | "Foundation Thickness"
StructuralFoundationWidth | "Width"
StructuralFrameCutLength | "Cut Length"
StructuralMaterialParam | "Structural Material"
StructuralMaterialType | "Structural Material Type"
StructuralMemberForces | "Member Forces"
StructuralNumberOfStuds | "Number of studs"
StructuralReferenceLevelElevation | "Reference Level Elevation"
StructuralSectionArea | "Section Area"
StructuralSectionBottomCutHeight | "Bottom Cut Height"
StructuralSectionBottomCutWidth | "Bottom Cut Width"
StructuralSectionCantileverHeight | "Cantilever Height"
StructuralSectionCantileverLength | "Cantilever Length"
StructuralSectionCommonAlpha | "Principal Axes Angle"
StructuralSectionCommonCentroidHoriz | "Centroid Horizontal"
StructuralSectionCommonCentroidVertical | "Centroid Vertical"
StructuralSectionCommonDiameter | "Diameter"
StructuralSectionCommonElasticModulusStrongAxis | "Elastic Modulus strong axis"
StructuralSectionCommonElasticModulusWeakAxis | "Elastic Modulus weak axis"
StructuralSectionCommonHeight | "Height"
StructuralSectionCommonMomentOfInertiaStrongAxis | "Moment of Inertia strong axis"
StructuralSectionCommonMomentOfInertiaWeakAxis | "Moment of Inertia weak axis"
StructuralSectionCommonNominalWeight | "Nominal Weight"
StructuralSectionCommonPerimeter | "Perimeter"
StructuralSectionCommonPlasticModulusStrongAxis | "Plastic Modulus strong axis"
StructuralSectionCommonPlasticModulusWeakAxis | "Plastic Modulus weak axis"
StructuralSectionCommonShearAreaStrongAxis | "Shear Area strong axis"
StructuralSectionCommonShearAreaWeakAxis | "Shear Area weak axis"
StructuralSectionCommonTorsionalModulus | "Torsional Modulus"
StructuralSectionCommonTorsionalMomentOfInertia | "Torsional Moment of Inertia"
StructuralSectionCommonWarpingConstant | "Warping Constant"
StructuralSectionCommonWidth | "Width"
StructuralSectionCprofileFoldLength | "Fold Length"
StructuralSectionHssInnerfillet | "Inner Fillet"
StructuralSectionHssOuterfillet | "Outer Fillet"
StructuralSectionIshapeBoltDiameter | "Bolt Diameter"
StructuralSectionIshapeBoltSpacing | "Bolt Spacing"
StructuralSectionIshapeBoltSpacingBetweenRows | "Bolt Spacing between Rows"
StructuralSectionIshapeBoltSpacingTwoRows | "Bolt Spacing Two Rows"
StructuralSectionIshapeBoltSpacingWeb | "Bolt Spacing web"
StructuralSectionIshapeClearWebHeight | "Clear Web Height"
StructuralSectionIshapeFlangefillet | "Flange Fillet"
StructuralSectionIshapeFlangethickness | "Flange Thickness"
StructuralSectionIshapeFlangethicknessLocation | "Flange Thickness Location"
StructuralSectionIshapeFlangeToeOfFillet | "Flange Toe of Fillet"
StructuralSectionIshapeWebfillet | "Web Fillet"
StructuralSectionIshapeWebheight | "Web Height"
StructuralSectionIshapeWebthickness | "Web Thickness"
StructuralSectionIshapeWebthicknessLocation | "Web Thickness Location"
StructuralSectionIshapeWebToeOfFillet | "Web Toe of Fillet"
StructuralSectionIweldedBottomflangethickness | "Bottom Flange Thickness"
StructuralSectionIweldedBottomflangewidth | "Bottom Flange Width"
StructuralSectionIweldedTopflangethickness | "Top Flange Thickness"
StructuralSectionIweldedTopflangewidth | "Top Flange Width"
StructuralSectionLangleBoltDiameterLongerFlange | "Bolt Diameter Longer Flange"
StructuralSectionLangleBoltDiameterShorterFlange | "Bolt Diameter Shorter Flange"
StructuralSectionLangleBoltSpacing1LongerFlange | "Bolt Spacing 1 Longer Flange"
StructuralSectionLangleBoltSpacing2LongerFlange | "Bolt Spacing 2 Longer Flange"
StructuralSectionLangleBoltSpacingShorterFlange | "Bolt Spacing Shorter Flange"
StructuralSectionLprofileLipLength | "Lip Length"
StructuralSectionNameKey | "Section Name Key"
StructuralSectionPipestandardWalldesignthickness | "Wall Design Thickness"
StructuralSectionPipestandardWallnominalthickness | "Wall Nominal Thickness"
StructuralSectionShape | "Section Shape"
StructuralSectionSigmaProfileBendWidth | "Bend Width"
StructuralSectionSigmaProfileMiddleBendWidth | "Middle Bend Length"
StructuralSectionSigmaProfileTopBendWidth | "Top Bend Length"
StructuralSectionSlopedFlangeAngle | "Sloped Flange Angle"
StructuralSectionSlopedWebAngle | "Sloped Web Angle"
StructuralSectionTopCutHeight | "Top Cut Height"
StructuralSectionTopCutWidth | "Top Cut Width"
StructuralSectionTopWebFillet | "Top Web Fillet"
StructuralSectionZprofileBottomFlangeLength | "Bottom Flange Length"
StructuralStartReleaseFx | "Start Fx"
StructuralStartReleaseFy | "Start Fy"
StructuralStartReleaseFz | "Start Fz"
StructuralStartReleaseMx | "Start Mx"
StructuralStartReleaseMy | "Start My"
StructuralStartReleaseMz | "Start Mz"
StructuralStartReleaseType | "Start Release"
StructuralStickSymbolLocation | "Stick Symbol Location"
StructuralTopReleaseFx | "Top Fx"
StructuralTopReleaseFy | "Top Fy"
StructuralTopReleaseFz | "Top Fz"
StructuralTopReleaseMx | "Top Mx"
StructuralTopReleaseMy | "Top My"
StructuralTopReleaseMz | "Top Mz"
StructuralTopReleaseType | "Top Release"
StructuralWallBottomProjectionPlane | "Bottom Vertical Projection"
StructuralWallProjectionSurface | "Horizontal Projection"
StructuralWallTopProjectionPlane | "Top Vertical Projection"
SupportHandClearance | "Hand Clearance"
SupportHeight | "Height"
SurfaceArea | "Surface Area"
SurfaceName | "Name"
SurfacePatternIdParam | "Surface fill pattern"
SurfacePerimeter | "Perimeter"
SweepBaseFloorSubcategoryId | "Subcategory of Floors"
SweepBaseOffset | "Horizontal Profile Offset"
SweepBaseRoofSubcategoryId | "Subcategory of Roofs"
SweepBaseVertOffset | "Vertical Profile Offset"
SweepMaxSegAngle | "Maximum Segment Angle"
SweepTrajSegmented | "Trajectory Segmentation"
SymbolFamilyAndTypeNamesParam | "Family and Type"
SymbolFamilyNameParam | "Family Name"
SymbolIdParam | "Type Id"
SymbolNameParam | "Type Name"
SystemEquipmentSets | "Equipment Sets"
SystemsAnalysisReportFolder | "Reports Folder Path"
SystemsAnalysisReportStyle | "Report Style"
SystemZoneLevelId | "Level"
TagAngleParam | "Angle"
TagElementCount | "Host Count"
TagElevationBase | "Elevation Base"
TagHeadAlignment | "Tag Alignment"
TagHeadPosition | "Tag Position"
TagLeaderType | "Leader Type"
TagNoBreakParamStrings | "Wrap between parameters only"
TagOnPlacementUi | "Tag on Placement"
TagOrientationBehavior | "Tag Orientation"
TagOrientationParam | "Orientation"
TagSampleText | "Sample Text"
TagTag | "Label"
TemplateName | "Template"
TerminationExtensionLength | "Extension Length"
TextAlignHorz | "Horizontal Align"
TextAlignment | "Text Alignment"
TextAlignVert | "Vertical Align"
TextBackground | "Background"
TextBoxVisibility | "Show Border"
TextColor | "Color"
TextDistToLine | "Text Offset"
TextFont | "Text Font"
TextPosition | "Text Position"
TextSize | "Text Size"
TextStyleBold | "Bold"
TextStyleFont | "Font"
TextStyleItalic | "Italic"
TextStyleSize | "Size"
TextStyleUnderline | "Underline"
TextTabSize | "Tab Size"
TextText | "Text"
TextWidthScale | "Width Factor"
ThermalMaterialConductivity | "Thermal Conductivity"
ThermalMaterialDensity | "Density"
ThermalMaterialDescription | "Description"
ThermalMaterialName | "Name"
ThermalMaterialParamCompressibility | "Compressibility"
ThermalMaterialParamElectricalResistivity | "Electrical Resistivity"
ThermalMaterialParamEmissivity | "Emissivity"
ThermalMaterialParamGasViscosity | "Gas Viscosity"
ThermalMaterialParamLiquidViscosity | "Liquid Viscosity"
ThermalMaterialParamPermeability | "Permeability"
ThermalMaterialParamPorosity | "Porosity"
ThermalMaterialParamReflectivity | "Reflectivity"
ThermalMaterialParamSpecificHeatOfVaporization | "Specific Heat of Vaporization"
ThermalMaterialParamTransmitsLight | "Transmits Light"
ThermalMaterialParamVaporPressure | "Vapor Pressure"
ThermalMaterialSpecificHeatCapacity | "Specific Heat Capacity"
ThermalMaterialThickness | "Thickness"
TickMarkPen | "Tick Mark Line Weight"
TilePatternFamrefComponentExtents | "Component Extents"
TilePatternGridCellsX | "Number of horizontal cells"
TilePatternGridCellsY | "Number of vertical cells"
TilePatternGridUnitX | "Horizontal spacing"
TilePatternGridUnitY | "Vertical spacing"
Tilt | "Tilt"
TitleFont | "Font"
TitleSize | "Size"
TitleStyleBold | "Bold"
TitleStyleItalic | "Italic"
TitleStyleUnderline | "Underline"
TopographyLinkName | "Link Name"
TopographyLinkPath | "Saved Path"
ToposolidAttrThicknessParam | "Thickness"
ToposolidContourDisplaySettingsIdParam | "Contour Display"
ToposolidContourSubcategoryId | "Subcategory"
ToposolidElevationAtBottom | "Elevation at Bottom"
ToposolidElevationAtTop | "Elevation at Top"
ToposolidFacesLocation | "Picked Faces Location"
ToposolidFunctionParam | "Function"
ToposolidHeightabovelevelParam | "Height Offset From Level"
ToposolidInheritContours | "Inherit Contours"
ToposolidStructureIdParam | "Structure"
ToposolidSubdivideHeight | "Sub-divide Height"
ToposolidSubdivideMaterial | "Material"
ToposolidTypeDefaultThicknessParam | "Default Thickness"
ToposurfaceContourSubcategoryId | "Subcategory"
TotalExcavationVolume | "Total Excavation Volume"
TrapMullWidth | "Center Width"
TrussBearingChordTopBottomParam | "Bearing Chord"
TrussElementAngleParam | "Rotation Angle"
TrussElementBearingJustParam | "Bearing Vertical Justification"
TrussElementClassParam | "Engineering Type"
TrussElementCreateBottomParam | "Create Bottom Chord"
TrussElementCreateTopParam | "Create Top Chord"
TrussElementEnd0Elevation | "Start Level Offset"
TrussElementEnd1Elevation | "End Level Offset"
TrussElementReferenceLevelParam | "Reference Level"
TrussElementRotateChordsWithTruss | "Rotate Chords With Truss"
TrussElementSpanParam | "Span"
TrussElementStickJustParam | "Stick Symbol Location"
TrussElementTagNewMembersView | "Tag new members in view"
TrussFamilyBottomChordAngleParam | "Angle"
TrussFamilyBottomChordEndReleaseType | "End Release"
TrussFamilyBottomChordStartReleaseType | "Start Release"
TrussFamilyBottomChordStructuralTypesParam | "Structural Framing Type"
TrussFamilyBottomChordVerticalProjectionParam | "Analytical Vertical Projection"
TrussFamilyDiagWebAngleParam | "Angle"
TrussFamilyDiagWebEndReleaseType | "End Release"
TrussFamilyDiagWebStartReleaseType | "Start Release"
TrussFamilyDiagWebStructuralTypesParam | "Structural Framing Type"
TrussFamilyTopChordAngleParam | "Angle"
TrussFamilyTopChordEndReleaseType | "End Release"
TrussFamilyTopChordStartReleaseType | "Start Release"
TrussFamilyTopChordStructuralTypesParam | "Structural Framing Type"
TrussFamilyTopChordVerticalProjectionParam | "Analytical Vertical Projection"
TrussFamilyTransformationParam | "Web Orientation"
TrussFamilyVertWebAngleParam | "Angle"
TrussFamilyVertWebEndReleaseType | "End Release"
TrussFamilyVertWebStartReleaseType | "Start Release"
TrussFamilyVertWebStructuralTypesParam | "Structural Framing Type"
TrussFamilyWebsHaveSymbolicCutbackParam | "Webs have symbolic cutback"
TrussHeight | "Truss Height"
TrussLength | "Truss Length"
TrussNonBearingOffsetParam | "Non Bearing Offset"
TypeWallClosure | "Wall Closure"
UniformatCode | "Assembly Code"
UniformatDescription | "Assembly Description"
Use3dSnapping | "3D Snapping"
UsingMultiple | "Multiple Join"
ViewAnalysisDisplayStyle | "Default Analysis Display Style"
ViewAnalysisResultsVisibility | "Analysis Display Settings"
ViewAssociatedAssemblyInstanceId | "Associated Assembly Instance"
ViewBackClipping | "Depth Clipping"
ViewCameraOrientation | "Locked Orientation"
ViewCameraPosition | "Camera Position"
ViewCleanJoins | "Wall Join Display"
ViewDependency | "Dependency"
ViewDepth | "View Depth"
ViewDescription | "Title on Sheet"
ViewDesignOptionsConfig | "Design Option Configuration"
ViewDetailLevel | "Detail Level"
ViewDiscipline | "Discipline"
Viewer3dRenderSettings | "Rendering Settings"
ViewerAnnotationCropActive | "Annotation Crop"
ViewerBoundActiveBottom | "Bottom Clip Active"
ViewerBoundActiveFar | "Far Clip Active"
ViewerBoundActiveLeft | "Left Clip Active"
ViewerBoundActiveNear | "Near Clip Active"
ViewerBoundActiveRight | "Right Clip Active"
ViewerBoundActiveTop | "Top Clip Active"
ViewerBoundFarClipping | "Far Clipping"
ViewerBoundOffsetBottom | "Bottom Clip Offset"
ViewerBoundOffsetFar | "Far Clip Offset"
ViewerBoundOffsetLeft | "Left Clip Offset"
ViewerBoundOffsetNear | "Near Clip Offset"
ViewerBoundOffsetRight | "Right Clip Offset"
ViewerBoundOffsetTop | "Top Clip Offset"
ViewerCropRegion | "Crop View"
ViewerCropRegionDisabled | "Crop View"
ViewerCropRegionVisible | "Crop Region Visible"
ViewerDetailNumber | "Detail Number"
ViewerEyeElevation | "Eye Elevation"
ViewerIsReference | "Is a Reference"
ViewerModelClipBoxActive | "Section Box"
ViewerOptionVisibility | "Visible In Option"
ViewerPerspective | "Projection Mode"
ViewerReferenceLabel | "Reference Label"
ViewerReferenceLabelText | "Reference Label"
ViewerSheetCollection | "Sheet Collection"
ViewerSheetName | "Sheet Name"
ViewerSheetNumber | "Sheet Number"
ViewerShowUncropped | "Show uncropped"
ViewerTargetElevation | "Target Elevation"
ViewerVolumeOfInterestCrop | "Scope Box"
ViewFamily | "Family"
ViewFamilyAndTypeSchedules | "Family and Type"
ViewFamilySchedules | "Family"
ViewFixedSketchPlane | "None"
ViewGraphSchedBottomLevel | "Bottom Level"
ViewGraphSchedGridAppearance | "Grid Appearance"
ViewGraphSchedGroupSimilar | "Group Similar Locations"
ViewGraphSchedHiddenLevels | "Hidden Levels"
ViewGraphSchedLevelRelativeBaseType | "Elevation Base for Levels"
ViewGraphSchedLocationsHigh | "Column Locations End"
ViewGraphSchedLocationsLow | "Column Locations Start"
ViewGraphSchedMaterialTypes | "Material Types"
ViewGraphSchedNumberColumns | "Column Locations per Segment"
ViewGraphSchedOffGrid | "Include Off-Grid Columns"
ViewGraphSchedRowsCount | "Segments in Viewport"
ViewGraphSchedRowsFrom | "Segment Start in Viewport"
ViewGraphSchedTextAppearance | "Text Appearance"
ViewGraphSchedTitle | "Title"
ViewGraphSchedTopLevel | "Top Level"
ViewGraphSchedTotalColumns | "Total Column Locations"
ViewGraphSchedTotalRows | "Total Segments"
ViewGraphSchedUnitsFormat | "Off-Grid Units Format"
ViewGraphSunPath | "Sun Path"
ViewGraphSunPathSize | "Sun path size (%)"
ViewModelDisplayMode | "Display Model"
ViewName | "View Name"
ViewPartsVisibility | "Parts Visibility"
ViewPhase | "Phase"
ViewPhaseFilter | "Phase Filter"
ViewportAttrLabelTag | "Title"
ViewportAttrOrientationOnSheet | "Rotation on Sheet"
ViewportAttrPreserveTitlePosition | "Preserve Title Position"
ViewportAttrShowBox | "Show Box"
ViewportAttrShowExtensionLine | "Show Extension Line"
ViewportAttrShowLabel | "Show Title"
ViewportDetailNumber | "Detail Number"
ViewportPositioning | "Viewport Positioning"
ViewportScale | "View Scale"
ViewportSheetCollection | "Sheet Collection"
ViewportSheetName | "Sheet Name"
ViewportSheetNumber | "Sheet Number"
ViewportView | "View"
ViewportViewName | "View Name"
ViewReferencingDetail | "Referencing Detail"
ViewReferencingSheet | "Referencing Sheet"
ViewReferencingSheetCollection | "Referencing Sheet Collection"
ViewScale | "Scale Value 1:"
ViewScaleCustomname | "Display Name"
ViewScaleHavename | "Display Name"
ViewScalePulldownImperial | "View Scale"
ViewScalePulldownMetric | "View Scale"
ViewSchemaSettingForBuilding | "Color Scheme"
ViewSchemaSettingForSystem | "System Color Schemes"
ViewSchemaSettingForSystemTemplate | "System Color Schemes"
ViewSheetViewportInfo | "Viewport"
ViewShowGrids | "Show Grids"
ViewShowHiddenLines | "Show Hidden Lines"
ViewShowMassing | "Show Mass"
ViewSlantedColumnSymbolOffset | "Column Symbolic Offset"
ViewSolarstudyAnimationSpeedText | "Loop animation speed"
ViewSolarstudyAnimationSpeedValue | "Loop animation speed"
ViewSolarstudyCurrentStudyTypeIndex | "Study type"
ViewSolarstudyIsLightingStudyType | "Lighting study"
ViewSolarstudyIsMultidayStudyType | "Multi-day study"
ViewSolarstudyIsSingledayStudyType | "Single day study"
ViewSolarstudyIsStillimageStudyType | "Still image study"
ViewSolarstudyLightingAltitudeText | "Lighting altitude text"
ViewSolarstudyLightingAltitudeValue | "Lighting altitude"
ViewSolarstudyLightingAzimuthText | "Lighting azimuth text"
ViewSolarstudyLightingAzimuthValue | "Lighting azimuth"
ViewSolarstudyLightingPresetIndex | "Lighting presets combo"
ViewSolarstudyMultidayDatetimeText | "Multi-day date and time text"
ViewSolarstudyMultidayFrameText | "Multi-day frame text"
ViewSolarstudyMultidayFrameValue | "Multi-day frame"
ViewSolarstudyMultidayPresetIndex | "Multi-day presets combo"
ViewSolarstudyShadowsIntensityText | "Shadows intensity text"
ViewSolarstudyShadowsIntensityValue | "Shadows intensity"
ViewSolarstudySingledayDatetimeText | "Single day date and time text"
ViewSolarstudySingledayFrameText | "Single day frame text"
ViewSolarstudySingledayFrameValue | "Single day frame"
ViewSolarstudySingledayPresetIndex | "Single day presets combo"
ViewSolarstudyStillDateText | "Still date text"
ViewSolarstudyStillDateValue | "Still date"
ViewSolarstudyStillPresetIndex | "Still presets combo"
ViewSolarstudyStillTimeText | "Still time text"
ViewSolarstudyStillTimeValue | "Still time"
ViewSolarstudySunIntensityText | "Sun intensity text"
ViewSolarstudySunIntensityValue | "Sun intensity"
ViewTemplate | "View Template"
ViewTemplateForSchedule | "View Template"
ViewType | "Family and Type"
ViewTypeSchedules | "Type"
ViewUnderlayBottomId | "Range: Base Level"
ViewUnderlayOrientation | "Underlay Orientation"
ViewUnderlayTopId | "Range: Top Level"
ViewVisibleCategories | "Visibility/Graphics Overrides"
VisGraphicsAnalyticalModel | "V/G Overrides Analytical Model"
VisGraphicsAnnotation | "V/G Overrides Annotation"
VisGraphicsCoordinationModel | "V/G Overrides Coordination Model"
VisGraphicsDesignoptions | "V/G Overrides Design Options"
VisGraphicsFilters | "V/G Overrides Filters"
VisGraphicsImport | "V/G Overrides Import"
VisGraphicsModel | "V/G Overrides Model"
VisGraphicsPointClouds | "V/G Overrides Point Clouds"
VisGraphicsRvtLinks | "V/G Overrides RVT Links"
VisGraphicsWorksets | "V/G Overrides Worksets"
VoidCutsGeometry | "Cuts Geometry"
VolumeCut | "Cut"
VolumeFill | "Fill"
VolumeNet | "Net cut/fill"
VolumeOfInterestHeight | "Height"
VolumeOfInterestName | "Name"
VolumeOfInterestViewsVisible | "Views Visible"
WalkthroughFramesCount | "Walkthrough Frames"
WallAlignKeyRefParam | "Location line to align"
WallAttrDefheightParam | "Default height"
WallAttrHeightParam | "Height"
WallAttrRoomBounding | "Room Bounding"
WallAttrWidthParam | "Width"
WallBaseConstraint | "Base Constraint"
WallBaseHeightParam | "Base height"
WallBaseOffset | "Base Offset"
WallBottomExtensionDistParam | "Base Extension Distance"
WallBottomIsAttached | "Base is Attached"
WallCrossSection | "Cross-Section"
WallHeightType | "Top Constraint"
WallKeyRefParam | "Location Line"
WallLocationLineOffsetParam | "Location Line Offset"
WallSingleSlantAngleFromVertical | "Angle From Vertical"
WallStructuralSignificant | "Structural"
WallStructuralUsageParam | "Structural Usage"
WallStructureIdParam | "Structure"
WallSweepCutByInsertsParam | "Cut by Inserts"
WallSweepCutsWallParam | "Cuts Wall"
WallSweepDefaultSetbackParam | "Default Setback"
WallSweepLevelParam | "Level"
WallSweepOffsetParam | "Offset From Level"
WallSweepOrientation | "Orientation"
WallSweepProfileParam | "Profile"
WallSweepWallOffsetParam | "Offset From Wall"
WallSweepWallSubcategoryId | "Subcategory of Walls"
WallTaperedExteriorInwardAngle | "Exterior Angle"
WallTaperedInteriorInwardAngle | "Interior Angle"
WallTaperedUseInstanceAngles | "Enable Angle Overrides"
WallTaperedWidthAtBottom | "Bottom Width"
WallTaperedWidthAtTop | "Top Width"
WallTopExtensionDistParam | "Top Extension Distance"
WallTopIsAttached | "Top is Attached"
WallTopOffset | "Top Offset"
WallTypeDefaultTaperedExteriorInwardAngle | "Default Exterior Angle"
WallTypeDefaultTaperedInteriorInwardAngle | "Default Interior Angle"
WallTypeWidthMeasuredAt | "Width Measured At"
WallUserHeightParam | "Unconnected Height"
WindowTypeId | "Type Mark"
WindowtypeIsSchematic | "Schematic"
WindowTypeName | "Name"
WitnsLineExtension | "Witness Line Extension"
WitnsLineGapToElt | "Witness Line Gap to Element"
WitnsLineTickMark | "Witness Line Tick Mark"
WrappingAtEndsParam | "Wrapping at Ends"
WrappingAtInsertsParam | "Wrapping at Inserts"
YJustification | "y Justification"
YOffsetValue | "y Offset Value"
YzJustification | "yz Justification"
ZJustification | "z Justification"
ZOffsetValue | "z Offset Value"
ZoneAirChangesPerHour | "Air Changes per Hour"
ZoneAirVolumeCalculationTypeParam | "Air Volume Calculation Type"
ZoneArea | "Occupied Area"
ZoneAreaGross | "Gross Area"
ZoneCalculatedAreaPerCoolingLoadParam | "Calculated Area per Cooling Load"
ZoneCalculatedAreaPerHeatingLoadParam | "Calculated Area per Heating Load"
ZoneCalculatedCoolingLoadParam | "Calculated Cooling Load"
ZoneCalculatedCoolingLoadPerAreaParam | "Calculated Cooling Load per area"
ZoneCalculatedHeatingLoadParam | "Calculated Heating Load"
ZoneCalculatedHeatingLoadPerAreaParam | "Calculated Heating Load per area"
ZoneCalculatedHydronicCoolingflowParam | "Calculated Hydronic Cooling Flow"
ZoneCalculatedHydronicHeatingflowParam | "Calculated Hydronic Heating Flow"
ZoneCalculatedSupplyAirflowParam | "Calculated Supply Airflow"
ZoneCalculatedSupplyAirflowPerAreaParam | "Calculated Supply Airflow per area"
ZoneCoilBypassPercentageParam | "Coil Bypass"
ZoneCoolingAirTemperatureParam | "Cooling Air Temperature"
ZoneCoolingInformationParam | "Cooling Information"
ZoneCoolingSetPointParam | "Cooling Set Point"
ZoneDehumidificationSetPointParam | "Dehumidification Set Point"
ZoneDesignCoolTemperature | "Design Temperature for Cooling"
ZoneDesignHeatTemperature | "Design Temperature for Heating"
ZoneHeatingAirTemperatureParam | "Heating Air Temperature"
ZoneHeatingInformationParam | "Heating Information"
ZoneHeatingSetPointParam | "Heating Set Point"
ZoneHumidificationSetPointParam | "Humidification Set Point"
ZoneLevelId | "Level"
ZoneLevelOffset | "Level Offset"
ZoneLevelOffsetTop | "Top Offset"
ZoneName | "Name"
ZoneOaRatePerAchParam | "Outdoor Air Rate / Air Changes per Hour"
ZoneOutdoorAirInformationParam | "Outdoor Air Information"
ZoneOutsideAirFlowPerArea | "Outside Air Flow per Area"
ZoneOutsideAirFlowPerPerson | "Outside Air Flow per Person"
ZoneOutsideAirPerAreaParam | "Outdoor Air per Area"
ZoneOutsideAirPerPersonParam | "Outdoor Air per Person"
ZonePerimeter | "Perimeter"
ZonePhase | "Phase"
ZonePhaseId | "Phase Id"
ZoneServiceTypeParam | "Service Type"
ZoneSpaceOutdoorAirOptionParam | "Space Outdoor Air Option"
ZoneUseAirChangesPerHourParam | "Use Air Changes Per Hour"
ZoneUseDehumidificationSetpointParam | "Use Dehumidification Set Point"
ZoneUseHumidificationSetpointParam | "Use Humidification Set Point"
ZoneUseOutsideAirPerAreaParam | "Use Outside Air Per Area"
ZoneUseOutsideAirPerPersonParam | "Use Outside Air Per Person"
ZoneVolume | "Occupied Volume"
ZoneVolumeGross | "Gross Volume"
Top
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ActualMaxRidgeHeightParam Property

ParameterTypeIdActualMaxRidgeHeightParam Property

"Maximum Ridge Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ActualMaxRidgeHeightParam { get; }
Public Shared ReadOnly Property ActualMaxRidgeHeightParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ActualMaxRidgeHeightParam {
    ForgeTypeId^ get ();
}
static member ActualMaxRidgeHeightParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AlignmentStationLabelDistance Property

ParameterTypeIdAlignmentStationLabelDistance Property

"Distance": Currently not in use

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AlignmentStationLabelDistance { get; }
Public Shared ReadOnly Property AlignmentStationLabelDistance As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AlignmentStationLabelDistance {
    ForgeTypeId^ get ();
}
static member AlignmentStationLabelDistance : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AlignmentStationLabelIncludeStation Property

ParameterTypeIdAlignmentStationLabelIncludeStation Property

"Include Station"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AlignmentStationLabelIncludeStation { get; }
Public Shared ReadOnly Property AlignmentStationLabelIncludeStation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AlignmentStationLabelIncludeStation {
    ForgeTypeId^ get ();
}
static member AlignmentStationLabelIncludeStation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AlignmentStationLabelIndStation Property

ParameterTypeIdAlignmentStationLabelIndStation Property

"Station Indicator"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AlignmentStationLabelIndStation { get; }
Public Shared ReadOnly Property AlignmentStationLabelIndStation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AlignmentStationLabelIndStation {
    ForgeTypeId^ get ();
}
static member AlignmentStationLabelIndStation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AlignmentStationLabelSetEndStation Property

ParameterTypeIdAlignmentStationLabelSetEndStation Property

"Alignment Label Set End Station"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AlignmentStationLabelSetEndStation { get; }
Public Shared ReadOnly Property AlignmentStationLabelSetEndStation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AlignmentStationLabelSetEndStation {
    ForgeTypeId^ get ();
}
static member AlignmentStationLabelSetEndStation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AlignmentStationLabelSetInterval Property

ParameterTypeIdAlignmentStationLabelSetInterval Property

"Alignment Station Label Set Interval": The text is not used directly anywhere in the UI, instead the XAML specifies its own string for the value's label.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AlignmentStationLabelSetInterval { get; }
Public Shared ReadOnly Property AlignmentStationLabelSetInterval As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AlignmentStationLabelSetInterval {
    ForgeTypeId^ get ();
}
static member AlignmentStationLabelSetInterval : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AlignmentStationLabelSetOffset Property

ParameterTypeIdAlignmentStationLabelSetOffset Property

"Alignment Station Label Set Offset": The text is not used directly anywhere in the UI, instead the XAML specifies its own string for the value's label.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AlignmentStationLabelSetOffset { get; }
Public Shared ReadOnly Property AlignmentStationLabelSetOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AlignmentStationLabelSetOffset {
    ForgeTypeId^ get ();
}
static member AlignmentStationLabelSetOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AlignmentStationLabelSetStartStation Property

ParameterTypeIdAlignmentStationLabelSetStartStation Property

"Alignment Label Set Start Station"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AlignmentStationLabelSetStartStation { get; }
Public Shared ReadOnly Property AlignmentStationLabelSetStartStation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AlignmentStationLabelSetStartStation {
    ForgeTypeId^ get ();
}
static member AlignmentStationLabelSetStartStation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AlignmentStationLabelStationValue Property

ParameterTypeIdAlignmentStationLabelStationValue Property

"Station Value"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AlignmentStationLabelStationValue { get; }
Public Shared ReadOnly Property AlignmentStationLabelStationValue As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AlignmentStationLabelStationValue {
    ForgeTypeId^ get ();
}
static member AlignmentStationLabelStationValue : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AlignmentStationPrefix Property

ParameterTypeIdAlignmentStationPrefix Property

"Station Prefix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AlignmentStationPrefix { get; }
Public Shared ReadOnly Property AlignmentStationPrefix As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AlignmentStationPrefix {
    ForgeTypeId^ get ();
}
static member AlignmentStationPrefix : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AlignmentStationSuffix Property

ParameterTypeIdAlignmentStationSuffix Property

"Station Suffix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AlignmentStationSuffix { get; }
Public Shared ReadOnly Property AlignmentStationSuffix As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AlignmentStationSuffix {
    ForgeTypeId^ get ();
}
static member AlignmentStationSuffix : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AllGridRotationForDivisionRule Property

ParameterTypeIdAllGridRotationForDivisionRule Property

"All Grid Rotation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AllGridRotationForDivisionRule { get; }
Public Shared ReadOnly Property AllGridRotationForDivisionRule As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AllGridRotationForDivisionRule {
    ForgeTypeId^ get ();
}
static member AllGridRotationForDivisionRule : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AllModelDescription Property

ParameterTypeIdAllModelDescription Property

"Description"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AllModelDescription { get; }
Public Shared ReadOnly Property AllModelDescription As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AllModelDescription {
    ForgeTypeId^ get ();
}
static member AllModelDescription : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AllModelImage Property

ParameterTypeIdAllModelImage Property

"Image"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AllModelImage { get; }
Public Shared ReadOnly Property AllModelImage As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AllModelImage {
    ForgeTypeId^ get ();
}
static member AllModelImage : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AllModelInstanceComments Property

ParameterTypeIdAllModelInstanceComments Property

"Comments"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AllModelInstanceComments { get; }
Public Shared ReadOnly Property AllModelInstanceComments As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AllModelInstanceComments {
    ForgeTypeId^ get ();
}
static member AllModelInstanceComments : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AllModelManufacturer Property

ParameterTypeIdAllModelManufacturer Property

"Manufacturer"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AllModelManufacturer { get; }
Public Shared ReadOnly Property AllModelManufacturer As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AllModelManufacturer {
    ForgeTypeId^ get ();
}
static member AllModelManufacturer : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AllModelModel Property

ParameterTypeIdAllModelModel Property

"Model"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AllModelModel { get; }
Public Shared ReadOnly Property AllModelModel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AllModelModel {
    ForgeTypeId^ get ();
}
static member AllModelModel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AllModelTypeComments Property

ParameterTypeIdAllModelTypeComments Property

"Type Comments"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AllModelTypeComments { get; }
Public Shared ReadOnly Property AllModelTypeComments As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AllModelTypeComments {
    ForgeTypeId^ get ();
}
static member AllModelTypeComments : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AllModelTypeImage Property

ParameterTypeIdAllModelTypeImage Property

"Type Image"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AllModelTypeImage { get; }
Public Shared ReadOnly Property AllModelTypeImage As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AllModelTypeImage {
    ForgeTypeId^ get ();
}
static member AllModelTypeImage : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AllModelUrl Property

ParameterTypeIdAllModelUrl Property

"URL"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AllModelUrl { get; }
Public Shared ReadOnly Property AllModelUrl As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AllModelUrl {
    ForgeTypeId^ get ();
}
static member AllModelUrl : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AllowAutoEmbed Property

ParameterTypeIdAllowAutoEmbed Property

"Automatically Embed"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AllowAutoEmbed { get; }
Public Shared ReadOnly Property AllowAutoEmbed As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AllowAutoEmbed {
    ForgeTypeId^ get ();
}
static member AllowAutoEmbed : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AllowMultipleSelection Property

ParameterTypeIdAllowMultipleSelection Property

"Allow Multiple Selection": This is used by the UI to allow selection of multiple elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AllowMultipleSelection { get; }
Public Shared ReadOnly Property AllowMultipleSelection As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AllowMultipleSelection {
    ForgeTypeId^ get ();
}
static member AllowMultipleSelection : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AlternateUnits Property

ParameterTypeIdAlternateUnits Property

"Alternate Units"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AlternateUnits { get; }
Public Shared ReadOnly Property AlternateUnits As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AlternateUnits {
    ForgeTypeId^ get ();
}
static member AlternateUnits : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AlternateUnitsPrefix Property

ParameterTypeIdAlternateUnitsPrefix Property

"Alternate Units Prefix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AlternateUnitsPrefix { get; }
Public Shared ReadOnly Property AlternateUnitsPrefix As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AlternateUnitsPrefix {
    ForgeTypeId^ get ();
}
static member AlternateUnitsPrefix : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AlternateUnitsSuffix Property

ParameterTypeIdAlternateUnitsSuffix Property

"Alternate Units Suffix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AlternateUnitsSuffix { get; }
Public Shared ReadOnly Property AlternateUnitsSuffix As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AlternateUnitsSuffix {
    ForgeTypeId^ get ();
}
static member AlternateUnitsSuffix : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AlwaysZeroLength Property

ParameterTypeIdAlwaysZeroLength Property

"Base Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AlwaysZeroLength { get; }
Public Shared ReadOnly Property AlwaysZeroLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AlwaysZeroLength {
    ForgeTypeId^ get ();
}
static member AlwaysZeroLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalAbsorptance Property

ParameterTypeIdAnalyticalAbsorptance Property

"Absorptance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalAbsorptance { get; }
Public Shared ReadOnly Property AnalyticalAbsorptance As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalAbsorptance {
    ForgeTypeId^ get ();
}
static member AnalyticalAbsorptance : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalAdjacentSpace Property

ParameterTypeIdAnalyticalAdjacentSpace Property

"Adjacent Analytical Space"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalAdjacentSpace { get; }
Public Shared ReadOnly Property AnalyticalAdjacentSpace As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalAdjacentSpace {
    ForgeTypeId^ get ();
}
static member AnalyticalAdjacentSpace : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalDefineThermalPropertiesBy Property

ParameterTypeIdAnalyticalDefineThermalPropertiesBy Property

"Define Thermal Properties by"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalDefineThermalPropertiesBy { get; }
Public Shared ReadOnly Property AnalyticalDefineThermalPropertiesBy As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalDefineThermalPropertiesBy {
    ForgeTypeId^ get ();
}
static member AnalyticalDefineThermalPropertiesBy : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalElementHasAssociation Property

ParameterTypeIdAnalyticalElementHasAssociation Property

"Has Association": Used for Analytical Member, Analytical Panel, Structural Columns, Structural Framing, Floors, Walls, Structural Foundation

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalElementHasAssociation { get; }
Public Shared ReadOnly Property AnalyticalElementHasAssociation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalElementHasAssociation {
    ForgeTypeId^ get ();
}
static member AnalyticalElementHasAssociation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalElementPhysicalAsset Property

ParameterTypeIdAnalyticalElementPhysicalAsset Property

"Physical Material Asset": Used for Analytical Elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalElementPhysicalAsset { get; }
Public Shared ReadOnly Property AnalyticalElementPhysicalAsset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalElementPhysicalAsset {
    ForgeTypeId^ get ();
}
static member AnalyticalElementPhysicalAsset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalElementStructuralRole Property

ParameterTypeIdAnalyticalElementStructuralRole Property

"Structural Role": Used for Analytical Elements

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalElementStructuralRole { get; }
Public Shared ReadOnly Property AnalyticalElementStructuralRole As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalElementStructuralRole {
    ForgeTypeId^ get ();
}
static member AnalyticalElementStructuralRole : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalGeometryIsValid Property

ParameterTypeIdAnalyticalGeometryIsValid Property

"Analytical Model Correct"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalGeometryIsValid { get; }
Public Shared ReadOnly Property AnalyticalGeometryIsValid As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalGeometryIsValid {
    ForgeTypeId^ get ();
}
static member AnalyticalGeometryIsValid : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalHeatTransferCoefficient Property

ParameterTypeIdAnalyticalHeatTransferCoefficient Property

"Heat Transfer Coefficient (U)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalHeatTransferCoefficient { get; }
Public Shared ReadOnly Property AnalyticalHeatTransferCoefficient As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalHeatTransferCoefficient {
    ForgeTypeId^ get ();
}
static member AnalyticalHeatTransferCoefficient : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalLinkReleaseRotationX Property

ParameterTypeIdAnalyticalLinkReleaseRotationX Property

"X Rotation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalLinkReleaseRotationX { get; }
Public Shared ReadOnly Property AnalyticalLinkReleaseRotationX As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalLinkReleaseRotationX {
    ForgeTypeId^ get ();
}
static member AnalyticalLinkReleaseRotationX : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalLinkReleaseRotationY Property

ParameterTypeIdAnalyticalLinkReleaseRotationY Property

"Y Rotation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalLinkReleaseRotationY { get; }
Public Shared ReadOnly Property AnalyticalLinkReleaseRotationY As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalLinkReleaseRotationY {
    ForgeTypeId^ get ();
}
static member AnalyticalLinkReleaseRotationY : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalLinkReleaseRotationZ Property

ParameterTypeIdAnalyticalLinkReleaseRotationZ Property

"Z Rotation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalLinkReleaseRotationZ { get; }
Public Shared ReadOnly Property AnalyticalLinkReleaseRotationZ As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalLinkReleaseRotationZ {
    ForgeTypeId^ get ();
}
static member AnalyticalLinkReleaseRotationZ : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalLinkReleaseTranslationX Property

ParameterTypeIdAnalyticalLinkReleaseTranslationX Property

"X Translation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalLinkReleaseTranslationX { get; }
Public Shared ReadOnly Property AnalyticalLinkReleaseTranslationX As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalLinkReleaseTranslationX {
    ForgeTypeId^ get ();
}
static member AnalyticalLinkReleaseTranslationX : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalLinkReleaseTranslationY Property

ParameterTypeIdAnalyticalLinkReleaseTranslationY Property

"Y Translation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalLinkReleaseTranslationY { get; }
Public Shared ReadOnly Property AnalyticalLinkReleaseTranslationY As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalLinkReleaseTranslationY {
    ForgeTypeId^ get ();
}
static member AnalyticalLinkReleaseTranslationY : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalLinkReleaseTranslationZ Property

ParameterTypeIdAnalyticalLinkReleaseTranslationZ Property

"Z Translation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalLinkReleaseTranslationZ { get; }
Public Shared ReadOnly Property AnalyticalLinkReleaseTranslationZ As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalLinkReleaseTranslationZ {
    ForgeTypeId^ get ();
}
static member AnalyticalLinkReleaseTranslationZ : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalMemberForceEndAllNonZero Property

ParameterTypeIdAnalyticalMemberForceEndAllNonZero Property

"All non 0 forces at end"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalMemberForceEndAllNonZero { get; }
Public Shared ReadOnly Property AnalyticalMemberForceEndAllNonZero As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalMemberForceEndAllNonZero {
    ForgeTypeId^ get ();
}
static member AnalyticalMemberForceEndAllNonZero : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalMemberForceEndFx Property

ParameterTypeIdAnalyticalMemberForceEndFx Property

"End Fx"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalMemberForceEndFx { get; }
Public Shared ReadOnly Property AnalyticalMemberForceEndFx As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalMemberForceEndFx {
    ForgeTypeId^ get ();
}
static member AnalyticalMemberForceEndFx : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalMemberForceEndFy Property

ParameterTypeIdAnalyticalMemberForceEndFy Property

"End Fy"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalMemberForceEndFy { get; }
Public Shared ReadOnly Property AnalyticalMemberForceEndFy As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalMemberForceEndFy {
    ForgeTypeId^ get ();
}
static member AnalyticalMemberForceEndFy : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalMemberForceEndFz Property

ParameterTypeIdAnalyticalMemberForceEndFz Property

"End Fz"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalMemberForceEndFz { get; }
Public Shared ReadOnly Property AnalyticalMemberForceEndFz As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalMemberForceEndFz {
    ForgeTypeId^ get ();
}
static member AnalyticalMemberForceEndFz : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalMemberForceEndMx Property

ParameterTypeIdAnalyticalMemberForceEndMx Property

"End Mx"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalMemberForceEndMx { get; }
Public Shared ReadOnly Property AnalyticalMemberForceEndMx As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalMemberForceEndMx {
    ForgeTypeId^ get ();
}
static member AnalyticalMemberForceEndMx : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalMemberForceEndMy Property

ParameterTypeIdAnalyticalMemberForceEndMy Property

"End My"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalMemberForceEndMy { get; }
Public Shared ReadOnly Property AnalyticalMemberForceEndMy As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalMemberForceEndMy {
    ForgeTypeId^ get ();
}
static member AnalyticalMemberForceEndMy : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalMemberForceEndMz Property

ParameterTypeIdAnalyticalMemberForceEndMz Property

"End Mz"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalMemberForceEndMz { get; }
Public Shared ReadOnly Property AnalyticalMemberForceEndMz As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalMemberForceEndMz {
    ForgeTypeId^ get ();
}
static member AnalyticalMemberForceEndMz : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalMemberForceStartAllNonZero Property

ParameterTypeIdAnalyticalMemberForceStartAllNonZero Property

"All non 0 forces at start"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalMemberForceStartAllNonZero { get; }
Public Shared ReadOnly Property AnalyticalMemberForceStartAllNonZero As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalMemberForceStartAllNonZero {
    ForgeTypeId^ get ();
}
static member AnalyticalMemberForceStartAllNonZero : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalMemberForceStartFx Property

ParameterTypeIdAnalyticalMemberForceStartFx Property

"Start Fx"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalMemberForceStartFx { get; }
Public Shared ReadOnly Property AnalyticalMemberForceStartFx As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalMemberForceStartFx {
    ForgeTypeId^ get ();
}
static member AnalyticalMemberForceStartFx : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalMemberForceStartFy Property

ParameterTypeIdAnalyticalMemberForceStartFy Property

"Start Fy"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalMemberForceStartFy { get; }
Public Shared ReadOnly Property AnalyticalMemberForceStartFy As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalMemberForceStartFy {
    ForgeTypeId^ get ();
}
static member AnalyticalMemberForceStartFy : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalMemberForceStartFz Property

ParameterTypeIdAnalyticalMemberForceStartFz Property

"Start Fz"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalMemberForceStartFz { get; }
Public Shared ReadOnly Property AnalyticalMemberForceStartFz As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalMemberForceStartFz {
    ForgeTypeId^ get ();
}
static member AnalyticalMemberForceStartFz : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalMemberForceStartMx Property

ParameterTypeIdAnalyticalMemberForceStartMx Property

"Start Mx"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalMemberForceStartMx { get; }
Public Shared ReadOnly Property AnalyticalMemberForceStartMx As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalMemberForceStartMx {
    ForgeTypeId^ get ();
}
static member AnalyticalMemberForceStartMx : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalMemberForceStartMy Property

ParameterTypeIdAnalyticalMemberForceStartMy Property

"Start My"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalMemberForceStartMy { get; }
Public Shared ReadOnly Property AnalyticalMemberForceStartMy As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalMemberForceStartMy {
    ForgeTypeId^ get ();
}
static member AnalyticalMemberForceStartMy : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalMemberForceStartMz Property

ParameterTypeIdAnalyticalMemberForceStartMz Property

"Start Mz"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalMemberForceStartMz { get; }
Public Shared ReadOnly Property AnalyticalMemberForceStartMz As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalMemberForceStartMz {
    ForgeTypeId^ get ();
}
static member AnalyticalMemberForceStartMz : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalMemberRotation Property

ParameterTypeIdAnalyticalMemberRotation Property

"Cross-Section Rotation": Used for Analytical Member

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalMemberRotation { get; }
Public Shared ReadOnly Property AnalyticalMemberRotation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalMemberRotation {
    ForgeTypeId^ get ();
}
static member AnalyticalMemberRotation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalMemberSectionType Property

ParameterTypeIdAnalyticalMemberSectionType Property

"Section Type": The id of the type from the structural Family assigned to the analytical member.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalMemberSectionType { get; }
Public Shared ReadOnly Property AnalyticalMemberSectionType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalMemberSectionType {
    ForgeTypeId^ get ();
}
static member AnalyticalMemberSectionType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalModelArea Property

ParameterTypeIdAnalyticalModelArea Property

"Area": The Area of Analytical Model

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalModelArea { get; }
Public Shared ReadOnly Property AnalyticalModelArea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalModelArea {
    ForgeTypeId^ get ();
}
static member AnalyticalModelArea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalModelBaseAlignmentMethod Property

ParameterTypeIdAnalyticalModelBaseAlignmentMethod Property

"Base Alignment Method"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalModelBaseAlignmentMethod { get; }
Public Shared ReadOnly Property AnalyticalModelBaseAlignmentMethod As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalModelBaseAlignmentMethod {
    ForgeTypeId^ get ();
}
static member AnalyticalModelBaseAlignmentMethod : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalModelBaseExtensionMethod Property

ParameterTypeIdAnalyticalModelBaseExtensionMethod Property

"Base Extension Method"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalModelBaseExtensionMethod { get; }
Public Shared ReadOnly Property AnalyticalModelBaseExtensionMethod As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalModelBaseExtensionMethod {
    ForgeTypeId^ get ();
}
static member AnalyticalModelBaseExtensionMethod : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalModelBaseYProjection Property

ParameterTypeIdAnalyticalModelBaseYProjection Property

"Base y Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalModelBaseYProjection { get; }
Public Shared ReadOnly Property AnalyticalModelBaseYProjection As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalModelBaseYProjection {
    ForgeTypeId^ get ();
}
static member AnalyticalModelBaseYProjection : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalModelBaseZProjection Property

ParameterTypeIdAnalyticalModelBaseZProjection Property

"Base z Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalModelBaseZProjection { get; }
Public Shared ReadOnly Property AnalyticalModelBaseZProjection As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalModelBaseZProjection {
    ForgeTypeId^ get ();
}
static member AnalyticalModelBaseZProjection : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalModelCodeChecking Property

ParameterTypeIdAnalyticalModelCodeChecking Property

"Code Checking": Used for Analytical wall, Analytical beam, Analytical column, Analytical floor, Analytical wall foundations, Analytical isolated foundations, Analytical foundations slab, Anaytical brace

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalModelCodeChecking { get; }
Public Shared ReadOnly Property AnalyticalModelCodeChecking As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalModelCodeChecking {
    ForgeTypeId^ get ();
}
static member AnalyticalModelCodeChecking : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalModelColumnBaseExtension Property

ParameterTypeIdAnalyticalModelColumnBaseExtension Property

"Base x Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalModelColumnBaseExtension { get; }
Public Shared ReadOnly Property AnalyticalModelColumnBaseExtension As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalModelColumnBaseExtension {
    ForgeTypeId^ get ();
}
static member AnalyticalModelColumnBaseExtension : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalModelColumnTopExtension Property

ParameterTypeIdAnalyticalModelColumnTopExtension Property

"Top x Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalModelColumnTopExtension { get; }
Public Shared ReadOnly Property AnalyticalModelColumnTopExtension As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalModelColumnTopExtension {
    ForgeTypeId^ get ();
}
static member AnalyticalModelColumnTopExtension : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalModelEndAlignmentMethod Property

ParameterTypeIdAnalyticalModelEndAlignmentMethod Property

"End Alignment Method"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalModelEndAlignmentMethod { get; }
Public Shared ReadOnly Property AnalyticalModelEndAlignmentMethod As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalModelEndAlignmentMethod {
    ForgeTypeId^ get ();
}
static member AnalyticalModelEndAlignmentMethod : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalModelEndProjectionOrthogonal Property

ParameterTypeIdAnalyticalModelEndProjectionOrthogonal Property

"End Projection Orthogonal"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalModelEndProjectionOrthogonal { get; }
Public Shared ReadOnly Property AnalyticalModelEndProjectionOrthogonal As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalModelEndProjectionOrthogonal {
    ForgeTypeId^ get ();
}
static member AnalyticalModelEndProjectionOrthogonal : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalModelEndYProjection Property

ParameterTypeIdAnalyticalModelEndYProjection Property

"End y Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalModelEndYProjection { get; }
Public Shared ReadOnly Property AnalyticalModelEndYProjection As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalModelEndYProjection {
    ForgeTypeId^ get ();
}
static member AnalyticalModelEndYProjection : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalModelEndZProjection Property

ParameterTypeIdAnalyticalModelEndZProjection Property

"End z Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalModelEndZProjection { get; }
Public Shared ReadOnly Property AnalyticalModelEndZProjection As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalModelEndZProjection {
    ForgeTypeId^ get ();
}
static member AnalyticalModelEndZProjection : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalModelFloorAlignmentMethod Property

ParameterTypeIdAnalyticalModelFloorAlignmentMethod Property

"Alignment Method"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalModelFloorAlignmentMethod { get; }
Public Shared ReadOnly Property AnalyticalModelFloorAlignmentMethod As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalModelFloorAlignmentMethod {
    ForgeTypeId^ get ();
}
static member AnalyticalModelFloorAlignmentMethod : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalModelFloorProjection Property

ParameterTypeIdAnalyticalModelFloorProjection Property

"z Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalModelFloorProjection { get; }
Public Shared ReadOnly Property AnalyticalModelFloorProjection As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalModelFloorProjection {
    ForgeTypeId^ get ();
}
static member AnalyticalModelFloorProjection : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalModelFoundationsMark Property

ParameterTypeIdAnalyticalModelFoundationsMark Property

"Foundation Number": Used for isolated, wall foundations

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalModelFoundationsMark { get; }
Public Shared ReadOnly Property AnalyticalModelFoundationsMark As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalModelFoundationsMark {
    ForgeTypeId^ get ();
}
static member AnalyticalModelFoundationsMark : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalModelLength Property

ParameterTypeIdAnalyticalModelLength Property

"Length": The length of Analytical Model

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalModelLength { get; }
Public Shared ReadOnly Property AnalyticalModelLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalModelLength {
    ForgeTypeId^ get ();
}
static member AnalyticalModelLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalModelManuallyAdjusted Property

ParameterTypeIdAnalyticalModelManuallyAdjusted Property

"Manually Adjusted"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalModelManuallyAdjusted { get; }
Public Shared ReadOnly Property AnalyticalModelManuallyAdjusted As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalModelManuallyAdjusted {
    ForgeTypeId^ get ();
}
static member AnalyticalModelManuallyAdjusted : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalModelNodesMark Property

ParameterTypeIdAnalyticalModelNodesMark Property

"Node Number": Used for nodes

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalModelNodesMark { get; }
Public Shared ReadOnly Property AnalyticalModelNodesMark As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalModelNodesMark {
    ForgeTypeId^ get ();
}
static member AnalyticalModelNodesMark : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalModelPerimeter Property

ParameterTypeIdAnalyticalModelPerimeter Property

"Perimeter": The Perimeter of Analytical Model

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalModelPerimeter { get; }
Public Shared ReadOnly Property AnalyticalModelPerimeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalModelPerimeter {
    ForgeTypeId^ get ();
}
static member AnalyticalModelPerimeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalModelPhysicalType Property

ParameterTypeIdAnalyticalModelPhysicalType Property

"Family Type": the Family Type of the physical element associated with the Analytical Model

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalModelPhysicalType { get; }
Public Shared ReadOnly Property AnalyticalModelPhysicalType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalModelPhysicalType {
    ForgeTypeId^ get ();
}
static member AnalyticalModelPhysicalType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalModelRotation Property

ParameterTypeIdAnalyticalModelRotation Property

"Cross-Section Rotation": The rotation of Analytical Model

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalModelRotation { get; }
Public Shared ReadOnly Property AnalyticalModelRotation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalModelRotation {
    ForgeTypeId^ get ();
}
static member AnalyticalModelRotation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalModelSketchAlignmentMethod Property

ParameterTypeIdAnalyticalModelSketchAlignmentMethod Property

"Alignment Method"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalModelSketchAlignmentMethod { get; }
Public Shared ReadOnly Property AnalyticalModelSketchAlignmentMethod As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalModelSketchAlignmentMethod {
    ForgeTypeId^ get ();
}
static member AnalyticalModelSketchAlignmentMethod : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalModelSketchProjection Property

ParameterTypeIdAnalyticalModelSketchProjection Property

"In-Plane Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalModelSketchProjection { get; }
Public Shared ReadOnly Property AnalyticalModelSketchProjection As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalModelSketchProjection {
    ForgeTypeId^ get ();
}
static member AnalyticalModelSketchProjection : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalModelStartAlignmentMethod Property

ParameterTypeIdAnalyticalModelStartAlignmentMethod Property

"Start Alignment Method"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalModelStartAlignmentMethod { get; }
Public Shared ReadOnly Property AnalyticalModelStartAlignmentMethod As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalModelStartAlignmentMethod {
    ForgeTypeId^ get ();
}
static member AnalyticalModelStartAlignmentMethod : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalModelStartProjectionOrthogonal Property

ParameterTypeIdAnalyticalModelStartProjectionOrthogonal Property

"Start Projection Orthogonal"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalModelStartProjectionOrthogonal { get; }
Public Shared ReadOnly Property AnalyticalModelStartProjectionOrthogonal As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalModelStartProjectionOrthogonal {
    ForgeTypeId^ get ();
}
static member AnalyticalModelStartProjectionOrthogonal : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalModelStartYProjection Property

ParameterTypeIdAnalyticalModelStartYProjection Property

"Start y Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalModelStartYProjection { get; }
Public Shared ReadOnly Property AnalyticalModelStartYProjection As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalModelStartYProjection {
    ForgeTypeId^ get ();
}
static member AnalyticalModelStartYProjection : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalModelStartZProjection Property

ParameterTypeIdAnalyticalModelStartZProjection Property

"Start z Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalModelStartZProjection { get; }
Public Shared ReadOnly Property AnalyticalModelStartZProjection As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalModelStartZProjection {
    ForgeTypeId^ get ();
}
static member AnalyticalModelStartZProjection : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalModelStickElementsMark Property

ParameterTypeIdAnalyticalModelStickElementsMark Property

"Member Number": Used for beams, braces, columns

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalModelStickElementsMark { get; }
Public Shared ReadOnly Property AnalyticalModelStickElementsMark As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalModelStickElementsMark {
    ForgeTypeId^ get ();
}
static member AnalyticalModelStickElementsMark : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalModelSurfaceElementsMark Property

ParameterTypeIdAnalyticalModelSurfaceElementsMark Property

"Surface Number": Used for floors, slabs, walls

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalModelSurfaceElementsMark { get; }
Public Shared ReadOnly Property AnalyticalModelSurfaceElementsMark As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalModelSurfaceElementsMark {
    ForgeTypeId^ get ();
}
static member AnalyticalModelSurfaceElementsMark : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalModelTopAlignmentMethod Property

ParameterTypeIdAnalyticalModelTopAlignmentMethod Property

"Top Alignment Method"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalModelTopAlignmentMethod { get; }
Public Shared ReadOnly Property AnalyticalModelTopAlignmentMethod As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalModelTopAlignmentMethod {
    ForgeTypeId^ get ();
}
static member AnalyticalModelTopAlignmentMethod : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalModelTopExtensionMethod Property

ParameterTypeIdAnalyticalModelTopExtensionMethod Property

"Top Extension Method"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalModelTopExtensionMethod { get; }
Public Shared ReadOnly Property AnalyticalModelTopExtensionMethod As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalModelTopExtensionMethod {
    ForgeTypeId^ get ();
}
static member AnalyticalModelTopExtensionMethod : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalModelTopYProjection Property

ParameterTypeIdAnalyticalModelTopYProjection Property

"Top y Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalModelTopYProjection { get; }
Public Shared ReadOnly Property AnalyticalModelTopYProjection As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalModelTopYProjection {
    ForgeTypeId^ get ();
}
static member AnalyticalModelTopYProjection : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalModelTopZProjection Property

ParameterTypeIdAnalyticalModelTopZProjection Property

"Top z Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalModelTopZProjection { get; }
Public Shared ReadOnly Property AnalyticalModelTopZProjection As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalModelTopZProjection {
    ForgeTypeId^ get ();
}
static member AnalyticalModelTopZProjection : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalModelWallAlignmentMethod Property

ParameterTypeIdAnalyticalModelWallAlignmentMethod Property

"Alignment Method"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalModelWallAlignmentMethod { get; }
Public Shared ReadOnly Property AnalyticalModelWallAlignmentMethod As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalModelWallAlignmentMethod {
    ForgeTypeId^ get ();
}
static member AnalyticalModelWallAlignmentMethod : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalModelWallBaseProjection Property

ParameterTypeIdAnalyticalModelWallBaseProjection Property

"Base y Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalModelWallBaseProjection { get; }
Public Shared ReadOnly Property AnalyticalModelWallBaseProjection As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalModelWallBaseProjection {
    ForgeTypeId^ get ();
}
static member AnalyticalModelWallBaseProjection : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalModelWallProjection Property

ParameterTypeIdAnalyticalModelWallProjection Property

"z Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalModelWallProjection { get; }
Public Shared ReadOnly Property AnalyticalModelWallProjection As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalModelWallProjection {
    ForgeTypeId^ get ();
}
static member AnalyticalModelWallProjection : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalModelWallTopProjection Property

ParameterTypeIdAnalyticalModelWallTopProjection Property

"Top y Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalModelWallTopProjection { get; }
Public Shared ReadOnly Property AnalyticalModelWallTopProjection As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalModelWallTopProjection {
    ForgeTypeId^ get ();
}
static member AnalyticalModelWallTopProjection : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalNodeCanBeHosted Property

ParameterTypeIdAnalyticalNodeCanBeHosted Property

"Can Be Hosted": Specifies of the Analytical Node can be hosted or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalNodeCanBeHosted { get; }
Public Shared ReadOnly Property AnalyticalNodeCanBeHosted As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalNodeCanBeHosted {
    ForgeTypeId^ get ();
}
static member AnalyticalNodeCanBeHosted : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalNodeConnectionStatus Property

ParameterTypeIdAnalyticalNodeConnectionStatus Property

"Connection Status"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalNodeConnectionStatus { get; }
Public Shared ReadOnly Property AnalyticalNodeConnectionStatus As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalNodeConnectionStatus {
    ForgeTypeId^ get ();
}
static member AnalyticalNodeConnectionStatus : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalNodeType Property

ParameterTypeIdAnalyticalNodeType Property

"Node Type": Specifies the type of the Analytical Node: hosted or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalNodeType { get; }
Public Shared ReadOnly Property AnalyticalNodeType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalNodeType {
    ForgeTypeId^ get ();
}
static member AnalyticalNodeType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalPanelThickness Property

ParameterTypeIdAnalyticalPanelThickness Property

"Thickness": Used for Analytical Panel

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalPanelThickness { get; }
Public Shared ReadOnly Property AnalyticalPanelThickness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalPanelThickness {
    ForgeTypeId^ get ();
}
static member AnalyticalPanelThickness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalRoughness Property

ParameterTypeIdAnalyticalRoughness Property

"Roughness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalRoughness { get; }
Public Shared ReadOnly Property AnalyticalRoughness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalRoughness {
    ForgeTypeId^ get ();
}
static member AnalyticalRoughness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalSolarHeatGainCoefficient Property

ParameterTypeIdAnalyticalSolarHeatGainCoefficient Property

"Solar Heat Gain Coefficient"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalSolarHeatGainCoefficient { get; }
Public Shared ReadOnly Property AnalyticalSolarHeatGainCoefficient As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalSolarHeatGainCoefficient {
    ForgeTypeId^ get ();
}
static member AnalyticalSolarHeatGainCoefficient : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalSpace Property

ParameterTypeIdAnalyticalSpace Property

"Analytical Space"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalSpace { get; }
Public Shared ReadOnly Property AnalyticalSpace As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalSpace {
    ForgeTypeId^ get ();
}
static member AnalyticalSpace : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalSurface Property

ParameterTypeIdAnalyticalSurface Property

"Analytical Surface"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalSurface { get; }
Public Shared ReadOnly Property AnalyticalSurface As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalSurface {
    ForgeTypeId^ get ();
}
static member AnalyticalSurface : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalThermalMass Property

ParameterTypeIdAnalyticalThermalMass Property

"Thermal Mass"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalThermalMass { get; }
Public Shared ReadOnly Property AnalyticalThermalMass As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalThermalMass {
    ForgeTypeId^ get ();
}
static member AnalyticalThermalMass : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalThermalResistance Property

ParameterTypeIdAnalyticalThermalResistance Property

"Thermal Resistance (R)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalThermalResistance { get; }
Public Shared ReadOnly Property AnalyticalThermalResistance As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalThermalResistance {
    ForgeTypeId^ get ();
}
static member AnalyticalThermalResistance : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalVisualLightTransmittance Property

ParameterTypeIdAnalyticalVisualLightTransmittance Property

"Visual Light Transmittance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalVisualLightTransmittance { get; }
Public Shared ReadOnly Property AnalyticalVisualLightTransmittance As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalVisualLightTransmittance {
    ForgeTypeId^ get ();
}
static member AnalyticalVisualLightTransmittance : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalZone Property

ParameterTypeIdAnalyticalZone Property

"Analytical Zone"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalZone { get; }
Public Shared ReadOnly Property AnalyticalZone As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalZone {
    ForgeTypeId^ get ();
}
static member AnalyticalZone : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticalZoneName Property

ParameterTypeIdAnalyticalZoneName Property

"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticalZoneName { get; }
Public Shared ReadOnly Property AnalyticalZoneName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticalZoneName {
    ForgeTypeId^ get ();
}
static member AnalyticalZoneName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticConstruction Property

ParameterTypeIdAnalyticConstruction Property

"Analytic Construction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticConstruction { get; }
Public Shared ReadOnly Property AnalyticConstruction As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticConstruction {
    ForgeTypeId^ get ();
}
static member AnalyticConstruction : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticConstructionGbxmlTypeid Property

ParameterTypeIdAnalyticConstructionGbxmlTypeid Property

"Construction Type Id"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticConstructionGbxmlTypeid { get; }
Public Shared ReadOnly Property AnalyticConstructionGbxmlTypeid As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticConstructionGbxmlTypeid {
    ForgeTypeId^ get ();
}
static member AnalyticConstructionGbxmlTypeid : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnalyticConstructionLookupTable Property

ParameterTypeIdAnalyticConstructionLookupTable Property

"Analytic Construction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnalyticConstructionLookupTable { get; }
Public Shared ReadOnly Property AnalyticConstructionLookupTable As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnalyticConstructionLookupTable {
    ForgeTypeId^ get ();
}
static member AnalyticConstructionLookupTable : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnyPatternIdParam Property

ParameterTypeIdAnyPatternIdParam Property

"Fill Pattern"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnyPatternIdParam { get; }
Public Shared ReadOnly Property AnyPatternIdParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnyPatternIdParam {
    ForgeTypeId^ get ();
}
static member AnyPatternIdParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AnyPatternIdParamNoNo Property

ParameterTypeIdAnyPatternIdParamNoNo Property

"Fill Pattern"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AnyPatternIdParamNoNo { get; }
Public Shared ReadOnly Property AnyPatternIdParamNoNo As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AnyPatternIdParamNoNo {
    ForgeTypeId^ get ();
}
static member AnyPatternIdParamNoNo : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ArcCenterMark Property

ParameterTypeIdArcCenterMark Property

"Center Marks"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ArcCenterMark { get; }
Public Shared ReadOnly Property ArcCenterMark As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ArcCenterMark {
    ForgeTypeId^ get ();
}
static member ArcCenterMark : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ArcElemFixKeepConcentric Property

ParameterTypeIdArcElemFixKeepConcentric Property

"Keep Concentric"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ArcElemFixKeepConcentric { get; }
Public Shared ReadOnly Property ArcElemFixKeepConcentric As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ArcElemFixKeepConcentric {
    ForgeTypeId^ get ();
}
static member ArcElemFixKeepConcentric : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ArcLeaderParam Property

ParameterTypeIdArcLeaderParam Property

"Arc Leaders"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ArcLeaderParam { get; }
Public Shared ReadOnly Property ArcLeaderParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ArcLeaderParam {
    ForgeTypeId^ get ();
}
static member ArcLeaderParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ArcWallCntrMrkVisible Property

ParameterTypeIdArcWallCntrMrkVisible Property

"Center Mark Visible"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ArcWallCntrMrkVisible { get; }
Public Shared ReadOnly Property ArcWallCntrMrkVisible As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ArcWallCntrMrkVisible {
    ForgeTypeId^ get ();
}
static member ArcWallCntrMrkVisible : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AreaSchemeId Property

ParameterTypeIdAreaSchemeId Property

"Area Scheme Id"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AreaSchemeId { get; }
Public Shared ReadOnly Property AreaSchemeId As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AreaSchemeId {
    ForgeTypeId^ get ();
}
static member AreaSchemeId : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AreaSchemeName Property

ParameterTypeIdAreaSchemeName Property

"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AreaSchemeName { get; }
Public Shared ReadOnly Property AreaSchemeName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AreaSchemeName {
    ForgeTypeId^ get ();
}
static member AreaSchemeName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AreaType Property

ParameterTypeIdAreaType Property

"Area Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AreaType { get; }
Public Shared ReadOnly Property AreaType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AreaType {
    ForgeTypeId^ get ();
}
static member AreaType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AreaTypeText Property

ParameterTypeIdAreaTypeText Property

"Area Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AreaTypeText { get; }
Public Shared ReadOnly Property AreaTypeText As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AreaTypeText {
    ForgeTypeId^ get ();
}
static member AreaTypeText : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ArrowCentered Property

ParameterTypeIdArrowCentered Property

"Tick Mark Centered"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ArrowCentered { get; }
Public Shared ReadOnly Property ArrowCentered As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ArrowCentered {
    ForgeTypeId^ get ();
}
static member ArrowCentered : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ArrowClosed Property

ParameterTypeIdArrowClosed Property

"Arrow Closed"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ArrowClosed { get; }
Public Shared ReadOnly Property ArrowClosed As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ArrowClosed {
    ForgeTypeId^ get ();
}
static member ArrowClosed : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ArrowFilled Property

ParameterTypeIdArrowFilled Property

"Fill Tick"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ArrowFilled { get; }
Public Shared ReadOnly Property ArrowFilled As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ArrowFilled {
    ForgeTypeId^ get ();
}
static member ArrowFilled : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ArrowheadEndAtRiser Property

ParameterTypeIdArrowheadEndAtRiser Property

"End at Riser"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ArrowheadEndAtRiser { get; }
Public Shared ReadOnly Property ArrowheadEndAtRiser As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ArrowheadEndAtRiser {
    ForgeTypeId^ get ();
}
static member ArrowheadEndAtRiser : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ArrowheadType Property

ParameterTypeIdArrowheadType Property

"Arrowhead Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ArrowheadType { get; }
Public Shared ReadOnly Property ArrowheadType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ArrowheadType {
    ForgeTypeId^ get ();
}
static member ArrowheadType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ArrowSize Property

ParameterTypeIdArrowSize Property

"Tick Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ArrowSize { get; }
Public Shared ReadOnly Property ArrowSize As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ArrowSize {
    ForgeTypeId^ get ();
}
static member ArrowSize : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ArrowType Property

ParameterTypeIdArrowType Property

"Arrow Style"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ArrowType { get; }
Public Shared ReadOnly Property ArrowType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ArrowType {
    ForgeTypeId^ get ();
}
static member ArrowType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AssemblyName Property

ParameterTypeIdAssemblyName Property

"Assembly Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AssemblyName { get; }
Public Shared ReadOnly Property AssemblyName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AssemblyName {
    ForgeTypeId^ get ();
}
static member AssemblyName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AssemblyNamingCategory Property

ParameterTypeIdAssemblyNamingCategory Property

"Naming Category"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AssemblyNamingCategory { get; }
Public Shared ReadOnly Property AssemblyNamingCategory As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AssemblyNamingCategory {
    ForgeTypeId^ get ();
}
static member AssemblyNamingCategory : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AssemblyPrecastFreeze Property

ParameterTypeIdAssemblyPrecastFreeze Property

"Disable Precast Updates"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AssemblyPrecastFreeze { get; }
Public Shared ReadOnly Property AssemblyPrecastFreeze As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AssemblyPrecastFreeze {
    ForgeTypeId^ get ();
}
static member AssemblyPrecastFreeze : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AssignTemplateOnViewCreation Property

ParameterTypeIdAssignTemplateOnViewCreation Property

"New views are dependent on template"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AssignTemplateOnViewCreation { get; }
Public Shared ReadOnly Property AssignTemplateOnViewCreation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AssignTemplateOnViewCreation {
    ForgeTypeId^ get ();
}
static member AssignTemplateOnViewCreation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AssociatedLevel Property

ParameterTypeIdAssociatedLevel Property

"Associated Level": The level associated with this cell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AssociatedLevel { get; }
Public Shared ReadOnly Property AssociatedLevel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AssociatedLevel {
    ForgeTypeId^ get ();
}
static member AssociatedLevel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AssociatedLevelOffset Property

ParameterTypeIdAssociatedLevelOffset Property

"Associated Level Offset": The offset from the associated level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AssociatedLevelOffset { get; }
Public Shared ReadOnly Property AssociatedLevelOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AssociatedLevelOffset {
    ForgeTypeId^ get ();
}
static member AssociatedLevelOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AutoJoinCondition Property

ParameterTypeIdAutoJoinCondition Property

"Join Condition"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AutoJoinCondition { get; }
Public Shared ReadOnly Property AutoJoinCondition As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AutoJoinCondition {
    ForgeTypeId^ get ();
}
static member AutoJoinCondition : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AutoJoinConditionWall Property

ParameterTypeIdAutoJoinConditionWall Property

"Join Condition"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AutoJoinConditionWall { get; }
Public Shared ReadOnly Property AutoJoinConditionWall As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AutoJoinConditionWall {
    ForgeTypeId^ get ();
}
static member AutoJoinConditionWall : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AutoMullionBorder1Grid1 Property

ParameterTypeIdAutoMullionBorder1Grid1 Property

"Border 1 Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AutoMullionBorder1Grid1 { get; }
Public Shared ReadOnly Property AutoMullionBorder1Grid1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AutoMullionBorder1Grid1 {
    ForgeTypeId^ get ();
}
static member AutoMullionBorder1Grid1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AutoMullionBorder1Grid2 Property

ParameterTypeIdAutoMullionBorder1Grid2 Property

"Border 1 Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AutoMullionBorder1Grid2 { get; }
Public Shared ReadOnly Property AutoMullionBorder1Grid2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AutoMullionBorder1Grid2 {
    ForgeTypeId^ get ();
}
static member AutoMullionBorder1Grid2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AutoMullionBorder1Horiz Property

ParameterTypeIdAutoMullionBorder1Horiz Property

"Border 1 Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AutoMullionBorder1Horiz { get; }
Public Shared ReadOnly Property AutoMullionBorder1Horiz As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AutoMullionBorder1Horiz {
    ForgeTypeId^ get ();
}
static member AutoMullionBorder1Horiz : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AutoMullionBorder1Vert Property

ParameterTypeIdAutoMullionBorder1Vert Property

"Border 1 Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AutoMullionBorder1Vert { get; }
Public Shared ReadOnly Property AutoMullionBorder1Vert As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AutoMullionBorder1Vert {
    ForgeTypeId^ get ();
}
static member AutoMullionBorder1Vert : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AutoMullionBorder2Grid1 Property

ParameterTypeIdAutoMullionBorder2Grid1 Property

"Border 2 Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AutoMullionBorder2Grid1 { get; }
Public Shared ReadOnly Property AutoMullionBorder2Grid1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AutoMullionBorder2Grid1 {
    ForgeTypeId^ get ();
}
static member AutoMullionBorder2Grid1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AutoMullionBorder2Grid2 Property

ParameterTypeIdAutoMullionBorder2Grid2 Property

"Border 2 Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AutoMullionBorder2Grid2 { get; }
Public Shared ReadOnly Property AutoMullionBorder2Grid2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AutoMullionBorder2Grid2 {
    ForgeTypeId^ get ();
}
static member AutoMullionBorder2Grid2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AutoMullionBorder2Horiz Property

ParameterTypeIdAutoMullionBorder2Horiz Property

"Border 2 Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AutoMullionBorder2Horiz { get; }
Public Shared ReadOnly Property AutoMullionBorder2Horiz As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AutoMullionBorder2Horiz {
    ForgeTypeId^ get ();
}
static member AutoMullionBorder2Horiz : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AutoMullionBorder2Vert Property

ParameterTypeIdAutoMullionBorder2Vert Property

"Border 2 Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AutoMullionBorder2Vert { get; }
Public Shared ReadOnly Property AutoMullionBorder2Vert As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AutoMullionBorder2Vert {
    ForgeTypeId^ get ();
}
static member AutoMullionBorder2Vert : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AutoMullionInteriorGrid1 Property

ParameterTypeIdAutoMullionInteriorGrid1 Property

"Interior Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AutoMullionInteriorGrid1 { get; }
Public Shared ReadOnly Property AutoMullionInteriorGrid1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AutoMullionInteriorGrid1 {
    ForgeTypeId^ get ();
}
static member AutoMullionInteriorGrid1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AutoMullionInteriorGrid2 Property

ParameterTypeIdAutoMullionInteriorGrid2 Property

"Interior Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AutoMullionInteriorGrid2 { get; }
Public Shared ReadOnly Property AutoMullionInteriorGrid2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AutoMullionInteriorGrid2 {
    ForgeTypeId^ get ();
}
static member AutoMullionInteriorGrid2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AutoMullionInteriorHoriz Property

ParameterTypeIdAutoMullionInteriorHoriz Property

"Interior Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AutoMullionInteriorHoriz { get; }
Public Shared ReadOnly Property AutoMullionInteriorHoriz As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AutoMullionInteriorHoriz {
    ForgeTypeId^ get ();
}
static member AutoMullionInteriorHoriz : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AutoMullionInteriorVert Property

ParameterTypeIdAutoMullionInteriorVert Property

"Interior Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AutoMullionInteriorVert { get; }
Public Shared ReadOnly Property AutoMullionInteriorVert As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AutoMullionInteriorVert {
    ForgeTypeId^ get ();
}
static member AutoMullionInteriorVert : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AutoPanel Property

ParameterTypeIdAutoPanel Property

"Curtain Panel"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AutoPanel { get; }
Public Shared ReadOnly Property AutoPanel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AutoPanel {
    ForgeTypeId^ get ();
}
static member AutoPanel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.AutoPanelWall Property

ParameterTypeIdAutoPanelWall Property

"Curtain Panel"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AutoPanelWall { get; }
Public Shared ReadOnly Property AutoPanelWall As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AutoPanelWall {
    ForgeTypeId^ get ();
}
static member AutoPanelWall : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.Azimuth Property

ParameterTypeIdAzimuth Property

"Azimuth"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Azimuth { get; }
Public Shared ReadOnly Property Azimuth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Azimuth {
    ForgeTypeId^ get ();
}
static member Azimuth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BackgroundDraftPatternIdParam Property

ParameterTypeIdBackgroundDraftPatternIdParam Property

"Background Fill Pattern"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BackgroundDraftPatternIdParam { get; }
Public Shared ReadOnly Property BackgroundDraftPatternIdParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BackgroundDraftPatternIdParam {
    ForgeTypeId^ get ();
}
static member BackgroundDraftPatternIdParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BackgroundPatternColorParam Property

ParameterTypeIdBackgroundPatternColorParam Property

"Background Pattern Color"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BackgroundPatternColorParam { get; }
Public Shared ReadOnly Property BackgroundPatternColorParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BackgroundPatternColorParam {
    ForgeTypeId^ get ();
}
static member BackgroundPatternColorParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BaselineDimOffset Property

ParameterTypeIdBaselineDimOffset Property

"Baseline Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BaselineDimOffset { get; }
Public Shared ReadOnly Property BaselineDimOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BaselineDimOffset {
    ForgeTypeId^ get ();
}
static member BaselineDimOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BasepointAngletonParam Property

ParameterTypeIdBasepointAngletonParam Property

"Angle to True North"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BasepointAngletonParam { get; }
Public Shared ReadOnly Property BasepointAngletonParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BasepointAngletonParam {
    ForgeTypeId^ get ();
}
static member BasepointAngletonParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BasepointEastwestParam Property

ParameterTypeIdBasepointEastwestParam Property

"E/W"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BasepointEastwestParam { get; }
Public Shared ReadOnly Property BasepointEastwestParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BasepointEastwestParam {
    ForgeTypeId^ get ();
}
static member BasepointEastwestParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BasepointElevationParam Property

ParameterTypeIdBasepointElevationParam Property

"Elev"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BasepointElevationParam { get; }
Public Shared ReadOnly Property BasepointElevationParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BasepointElevationParam {
    ForgeTypeId^ get ();
}
static member BasepointElevationParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BasepointLatitudeParam Property

ParameterTypeIdBasepointLatitudeParam Property

"Lat"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BasepointLatitudeParam { get; }
Public Shared ReadOnly Property BasepointLatitudeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BasepointLatitudeParam {
    ForgeTypeId^ get ();
}
static member BasepointLatitudeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BasepointLongitudeParam Property

ParameterTypeIdBasepointLongitudeParam Property

"Lon"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BasepointLongitudeParam { get; }
Public Shared ReadOnly Property BasepointLongitudeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BasepointLongitudeParam {
    ForgeTypeId^ get ();
}
static member BasepointLongitudeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BasepointNorthsouthParam Property

ParameterTypeIdBasepointNorthsouthParam Property

"N/S"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BasepointNorthsouthParam { get; }
Public Shared ReadOnly Property BasepointNorthsouthParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BasepointNorthsouthParam {
    ForgeTypeId^ get ();
}
static member BasepointNorthsouthParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BeamHJustification Property

ParameterTypeIdBeamHJustification Property

"Lateral Justification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BeamHJustification { get; }
Public Shared ReadOnly Property BeamHJustification As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BeamHJustification {
    ForgeTypeId^ get ();
}
static member BeamHJustification : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BeamSystem3dParam Property

ParameterTypeIdBeamSystem3dParam Property

"3D"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BeamSystem3dParam { get; }
Public Shared ReadOnly Property BeamSystem3dParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BeamSystem3dParam {
    ForgeTypeId^ get ();
}
static member BeamSystem3dParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BeamSystemTagInstParamAngle Property

ParameterTypeIdBeamSystemTagInstParamAngle Property

"Beam System Tag Direction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BeamSystemTagInstParamAngle { get; }
Public Shared ReadOnly Property BeamSystemTagInstParamAngle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BeamSystemTagInstParamAngle {
    ForgeTypeId^ get ();
}
static member BeamSystemTagInstParamAngle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BeamSystemTagParamLeft Property

ParameterTypeIdBeamSystemTagParamLeft Property

"Left"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BeamSystemTagParamLeft { get; }
Public Shared ReadOnly Property BeamSystemTagParamLeft As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BeamSystemTagParamLeft {
    ForgeTypeId^ get ();
}
static member BeamSystemTagParamLeft : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BeamSystemTagParamRight Property

ParameterTypeIdBeamSystemTagParamRight Property

"Right"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BeamSystemTagParamRight { get; }
Public Shared ReadOnly Property BeamSystemTagParamRight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BeamSystemTagParamRight {
    ForgeTypeId^ get ();
}
static member BeamSystemTagParamRight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BeamVJustification Property

ParameterTypeIdBeamVJustification Property

"z-Direction Justification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BeamVJustification { get; }
Public Shared ReadOnly Property BeamVJustification As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BeamVJustification {
    ForgeTypeId^ get ();
}
static member BeamVJustification : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BeamVJustificationOtherValue Property

ParameterTypeIdBeamVJustificationOtherValue Property

"z-Direction Offset Value"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BeamVJustificationOtherValue { get; }
Public Shared ReadOnly Property BeamVJustificationOtherValue As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BeamVJustificationOtherValue {
    ForgeTypeId^ get ();
}
static member BeamVJustificationOtherValue : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BendingDetailAngularDimensionTextPosition Property

ParameterTypeIdBendingDetailAngularDimensionTextPosition Property

"Angle Text Position"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BendingDetailAngularDimensionTextPosition { get; }
Public Shared ReadOnly Property BendingDetailAngularDimensionTextPosition As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BendingDetailAngularDimensionTextPosition {
    ForgeTypeId^ get ();
}
static member BendingDetailAngularDimensionTextPosition : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BendingDetailDetailLevel Property

ParameterTypeIdBendingDetailDetailLevel Property

"Detail Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BendingDetailDetailLevel { get; }
Public Shared ReadOnly Property BendingDetailDetailLevel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BendingDetailDetailLevel {
    ForgeTypeId^ get ();
}
static member BendingDetailDetailLevel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BendingdetailPosition Property

ParameterTypeIdBendingdetailPosition Property

"Bending Detail Position"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BendingdetailPosition { get; }
Public Shared ReadOnly Property BendingdetailPosition As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BendingdetailPosition {
    ForgeTypeId^ get ();
}
static member BendingdetailPosition : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BendingDetailRepresentationFor3dBars Property

ParameterTypeIdBendingDetailRepresentationFor3dBars Property

"View for 3D Shape"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BendingDetailRepresentationFor3dBars { get; }
Public Shared ReadOnly Property BendingDetailRepresentationFor3dBars As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BendingDetailRepresentationFor3dBars {
    ForgeTypeId^ get ();
}
static member BendingDetailRepresentationFor3dBars : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BendingDetailSegmentLengthDimensionTextPosition Property

ParameterTypeIdBendingDetailSegmentLengthDimensionTextPosition Property

"Dimension Text Position"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BendingDetailSegmentLengthDimensionTextPosition { get; }
Public Shared ReadOnly Property BendingDetailSegmentLengthDimensionTextPosition As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BendingDetailSegmentLengthDimensionTextPosition {
    ForgeTypeId^ get ();
}
static member BendingDetailSegmentLengthDimensionTextPosition : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BendingDetailSegmentRepresentation Property

ParameterTypeIdBendingDetailSegmentRepresentation Property

"Representation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BendingDetailSegmentRepresentation { get; }
Public Shared ReadOnly Property BendingDetailSegmentRepresentation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BendingDetailSegmentRepresentation {
    ForgeTypeId^ get ();
}
static member BendingDetailSegmentRepresentation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BendingDetailTypeAngularDimensionOffset Property

ParameterTypeIdBendingDetailTypeAngularDimensionOffset Property

"Angular Dimension Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BendingDetailTypeAngularDimensionOffset { get; }
Public Shared ReadOnly Property BendingDetailTypeAngularDimensionOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BendingDetailTypeAngularDimensionOffset {
    ForgeTypeId^ get ();
}
static member BendingDetailTypeAngularDimensionOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BendingDetailTypeAngularDimensionsEnabled Property

ParameterTypeIdBendingDetailTypeAngularDimensionsEnabled Property

"Angular Dimensions"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BendingDetailTypeAngularDimensionsEnabled { get; }
Public Shared ReadOnly Property BendingDetailTypeAngularDimensionsEnabled As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BendingDetailTypeAngularDimensionsEnabled {
    ForgeTypeId^ get ();
}
static member BendingDetailTypeAngularDimensionsEnabled : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BendingDetailTypeAngularDimensionsForHooksEnabled Property

ParameterTypeIdBendingDetailTypeAngularDimensionsForHooksEnabled Property

"Hook Angles"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BendingDetailTypeAngularDimensionsForHooksEnabled { get; }
Public Shared ReadOnly Property BendingDetailTypeAngularDimensionsForHooksEnabled As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BendingDetailTypeAngularDimensionsForHooksEnabled {
    ForgeTypeId^ get ();
}
static member BendingDetailTypeAngularDimensionsForHooksEnabled : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BendingDetailTypeAngularDimensionsMeasurement Property

ParameterTypeIdBendingDetailTypeAngularDimensionsMeasurement Property

"Angle Measurement"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BendingDetailTypeAngularDimensionsMeasurement { get; }
Public Shared ReadOnly Property BendingDetailTypeAngularDimensionsMeasurement As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BendingDetailTypeAngularDimensionsMeasurement {
    ForgeTypeId^ get ();
}
static member BendingDetailTypeAngularDimensionsMeasurement : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BendingDetailTypeAngularDimensionTypeId Property

ParameterTypeIdBendingDetailTypeAngularDimensionTypeId Property

"Angular Dimension Style"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BendingDetailTypeAngularDimensionTypeId { get; }
Public Shared ReadOnly Property BendingDetailTypeAngularDimensionTypeId As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BendingDetailTypeAngularDimensionTypeId {
    ForgeTypeId^ get ();
}
static member BendingDetailTypeAngularDimensionTypeId : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BendingDetailTypeBendDiameterDimensionsEnabled Property

ParameterTypeIdBendingDetailTypeBendDiameterDimensionsEnabled Property

"Bend Diameter Dimensions"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BendingDetailTypeBendDiameterDimensionsEnabled { get; }
Public Shared ReadOnly Property BendingDetailTypeBendDiameterDimensionsEnabled As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BendingDetailTypeBendDiameterDimensionsEnabled {
    ForgeTypeId^ get ();
}
static member BendingDetailTypeBendDiameterDimensionsEnabled : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BendingDetailTypeBendDiameterDimensionsForHooksEnabled Property

ParameterTypeIdBendingDetailTypeBendDiameterDimensionsForHooksEnabled Property

"Hook Bends"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BendingDetailTypeBendDiameterDimensionsForHooksEnabled { get; }
Public Shared ReadOnly Property BendingDetailTypeBendDiameterDimensionsForHooksEnabled As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BendingDetailTypeBendDiameterDimensionsForHooksEnabled {
    ForgeTypeId^ get ();
}
static member BendingDetailTypeBendDiameterDimensionsForHooksEnabled : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BendingDetailTypeBendDiameterDimensionsForSegmentsEnabled Property

ParameterTypeIdBendingDetailTypeBendDiameterDimensionsForSegmentsEnabled Property

"Segment Bends"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BendingDetailTypeBendDiameterDimensionsForSegmentsEnabled { get; }
Public Shared ReadOnly Property BendingDetailTypeBendDiameterDimensionsForSegmentsEnabled As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BendingDetailTypeBendDiameterDimensionsForSegmentsEnabled {
    ForgeTypeId^ get ();
}
static member BendingDetailTypeBendDiameterDimensionsForSegmentsEnabled : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BendingDetailTypeDiameterDimensionTypeId Property

ParameterTypeIdBendingDetailTypeDiameterDimensionTypeId Property

"Diameter Dimension Style"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BendingDetailTypeDiameterDimensionTypeId { get; }
Public Shared ReadOnly Property BendingDetailTypeDiameterDimensionTypeId As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BendingDetailTypeDiameterDimensionTypeId {
    ForgeTypeId^ get ();
}
static member BendingDetailTypeDiameterDimensionTypeId : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BendingDetailTypeOrthogonalAndOverallDimesionsEnabled Property

ParameterTypeIdBendingDetailTypeOrthogonalAndOverallDimesionsEnabled Property

"Other Dimensions"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BendingDetailTypeOrthogonalAndOverallDimesionsEnabled { get; }
Public Shared ReadOnly Property BendingDetailTypeOrthogonalAndOverallDimesionsEnabled As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BendingDetailTypeOrthogonalAndOverallDimesionsEnabled {
    ForgeTypeId^ get ();
}
static member BendingDetailTypeOrthogonalAndOverallDimesionsEnabled : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BendingDetailTypeRadialDimensionTypeId Property

ParameterTypeIdBendingDetailTypeRadialDimensionTypeId Property

"Radial Dimension Style"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BendingDetailTypeRadialDimensionTypeId { get; }
Public Shared ReadOnly Property BendingDetailTypeRadialDimensionTypeId As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BendingDetailTypeRadialDimensionTypeId {
    ForgeTypeId^ get ();
}
static member BendingDetailTypeRadialDimensionTypeId : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BendingDetailTypeSchematicHeight Property

ParameterTypeIdBendingDetailTypeSchematicHeight Property

"Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BendingDetailTypeSchematicHeight { get; }
Public Shared ReadOnly Property BendingDetailTypeSchematicHeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BendingDetailTypeSchematicHeight {
    ForgeTypeId^ get ();
}
static member BendingDetailTypeSchematicHeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BendingDetailTypeSchematicWidth Property

ParameterTypeIdBendingDetailTypeSchematicWidth Property

"Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BendingDetailTypeSchematicWidth { get; }
Public Shared ReadOnly Property BendingDetailTypeSchematicWidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BendingDetailTypeSchematicWidth {
    ForgeTypeId^ get ();
}
static member BendingDetailTypeSchematicWidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BendingDetailTypeSegmentLengthDimensionsEnabled Property

ParameterTypeIdBendingDetailTypeSegmentLengthDimensionsEnabled Property

"Segment Length Dimensions"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BendingDetailTypeSegmentLengthDimensionsEnabled { get; }
Public Shared ReadOnly Property BendingDetailTypeSegmentLengthDimensionsEnabled As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BendingDetailTypeSegmentLengthDimensionsEnabled {
    ForgeTypeId^ get ();
}
static member BendingDetailTypeSegmentLengthDimensionsEnabled : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BendingDetailTypeSegmentLengthDimensionsForHooksEnabled Property

ParameterTypeIdBendingDetailTypeSegmentLengthDimensionsForHooksEnabled Property

"Hook Lengths"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BendingDetailTypeSegmentLengthDimensionsForHooksEnabled { get; }
Public Shared ReadOnly Property BendingDetailTypeSegmentLengthDimensionsForHooksEnabled As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BendingDetailTypeSegmentLengthDimensionsForHooksEnabled {
    ForgeTypeId^ get ();
}
static member BendingDetailTypeSegmentLengthDimensionsForHooksEnabled : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BendingDetailTypeSegmentLengthDimensionsOffset Property

ParameterTypeIdBendingDetailTypeSegmentLengthDimensionsOffset Property

"Dimension Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BendingDetailTypeSegmentLengthDimensionsOffset { get; }
Public Shared ReadOnly Property BendingDetailTypeSegmentLengthDimensionsOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BendingDetailTypeSegmentLengthDimensionsOffset {
    ForgeTypeId^ get ();
}
static member BendingDetailTypeSegmentLengthDimensionsOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BendingDetailTypeSegmentLengthDimensionTypeId Property

ParameterTypeIdBendingDetailTypeSegmentLengthDimensionTypeId Property

"Linear Dimension Style"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BendingDetailTypeSegmentLengthDimensionTypeId { get; }
Public Shared ReadOnly Property BendingDetailTypeSegmentLengthDimensionTypeId As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BendingDetailTypeSegmentLengthDimensionTypeId {
    ForgeTypeId^ get ();
}
static member BendingDetailTypeSegmentLengthDimensionTypeId : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BendingDetailTypeSegmentLengthsDisplayOption Property

ParameterTypeIdBendingDetailTypeSegmentLengthsDisplayOption Property

"Straight Segment Lengths"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BendingDetailTypeSegmentLengthsDisplayOption { get; }
Public Shared ReadOnly Property BendingDetailTypeSegmentLengthsDisplayOption As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BendingDetailTypeSegmentLengthsDisplayOption {
    ForgeTypeId^ get ();
}
static member BendingDetailTypeSegmentLengthsDisplayOption : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BendingDetailTypeSegmentLengthsForArcsDisplayOption Property

ParameterTypeIdBendingDetailTypeSegmentLengthsForArcsDisplayOption Property

"Arc Segment Lengths"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BendingDetailTypeSegmentLengthsForArcsDisplayOption { get; }
Public Shared ReadOnly Property BendingDetailTypeSegmentLengthsForArcsDisplayOption As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BendingDetailTypeSegmentLengthsForArcsDisplayOption {
    ForgeTypeId^ get ();
}
static member BendingDetailTypeSegmentLengthsForArcsDisplayOption : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BendingDetailTypeShowAngularDimensionsFor Property

ParameterTypeIdBendingDetailTypeShowAngularDimensionsFor Property

"Show for Angles"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BendingDetailTypeShowAngularDimensionsFor { get; }
Public Shared ReadOnly Property BendingDetailTypeShowAngularDimensionsFor As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BendingDetailTypeShowAngularDimensionsFor {
    ForgeTypeId^ get ();
}
static member BendingDetailTypeShowAngularDimensionsFor : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BendingDetailTypeShowBarBendingUsing Property

ParameterTypeIdBendingDetailTypeShowBarBendingUsing Property

"Dimension Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BendingDetailTypeShowBarBendingUsing { get; }
Public Shared ReadOnly Property BendingDetailTypeShowBarBendingUsing As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BendingDetailTypeShowBarBendingUsing {
    ForgeTypeId^ get ();
}
static member BendingDetailTypeShowBarBendingUsing : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BendingDetailTypeTagTypeId Property

ParameterTypeIdBendingDetailTypeTagTypeId Property

"Tag Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BendingDetailTypeTagTypeId { get; }
Public Shared ReadOnly Property BendingDetailTypeTagTypeId As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BendingDetailTypeTagTypeId {
    ForgeTypeId^ get ();
}
static member BendingDetailTypeTagTypeId : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BendingDetailVaryingRebarDimension Property

ParameterTypeIdBendingDetailVaryingRebarDimension Property

"Varying Rebar Set Dimensions"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BendingDetailVaryingRebarDimension { get; }
Public Shared ReadOnly Property BendingDetailVaryingRebarDimension As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BendingDetailVaryingRebarDimension {
    ForgeTypeId^ get ();
}
static member BendingDetailVaryingRebarDimension : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BentFabricParamBendDirection Property

ParameterTypeIdBentFabricParamBendDirection Property

"Bend Direction": Direction in which FabricSheet is bent.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BentFabricParamBendDirection { get; }
Public Shared ReadOnly Property BentFabricParamBendDirection As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BentFabricParamBendDirection {
    ForgeTypeId^ get ();
}
static member BentFabricParamBendDirection : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BentFabricParamLongitudinalCutLength Property

ParameterTypeIdBentFabricParamLongitudinalCutLength Property

"Longitudinal Cut Length": Bent fabric longitudinal cut length.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BentFabricParamLongitudinalCutLength { get; }
Public Shared ReadOnly Property BentFabricParamLongitudinalCutLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BentFabricParamLongitudinalCutLength {
    ForgeTypeId^ get ();
}
static member BentFabricParamLongitudinalCutLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BentFabricParamStraightWiresLocation Property

ParameterTypeIdBentFabricParamStraightWiresLocation Property

"Straight Wires Location": Location of straight wires in a bent fabric.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BentFabricParamStraightWiresLocation { get; }
Public Shared ReadOnly Property BentFabricParamStraightWiresLocation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BentFabricParamStraightWiresLocation {
    ForgeTypeId^ get ();
}
static member BentFabricParamStraightWiresLocation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BlendDepthParam Property

ParameterTypeIdBlendDepthParam Property

"Depth"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BlendDepthParam { get; }
Public Shared ReadOnly Property BlendDepthParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BlendDepthParam {
    ForgeTypeId^ get ();
}
static member BlendDepthParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BlendEndParam Property

ParameterTypeIdBlendEndParam Property

"Second End"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BlendEndParam { get; }
Public Shared ReadOnly Property BlendEndParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BlendEndParam {
    ForgeTypeId^ get ();
}
static member BlendEndParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BlendStartParam Property

ParameterTypeIdBlendStartParam Property

"First End"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BlendStartParam { get; }
Public Shared ReadOnly Property BlendStartParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BlendStartParam {
    ForgeTypeId^ get ();
}
static member BlendStartParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BoundaryAreaRestraintX Property

ParameterTypeIdBoundaryAreaRestraintX Property

"X Spring Modulus"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BoundaryAreaRestraintX { get; }
Public Shared ReadOnly Property BoundaryAreaRestraintX As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BoundaryAreaRestraintX {
    ForgeTypeId^ get ();
}
static member BoundaryAreaRestraintX : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BoundaryAreaRestraintY Property

ParameterTypeIdBoundaryAreaRestraintY Property

"Y Spring Modulus"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BoundaryAreaRestraintY { get; }
Public Shared ReadOnly Property BoundaryAreaRestraintY As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BoundaryAreaRestraintY {
    ForgeTypeId^ get ();
}
static member BoundaryAreaRestraintY : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BoundaryAreaRestraintZ Property

ParameterTypeIdBoundaryAreaRestraintZ Property

"Z Spring Modulus"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BoundaryAreaRestraintZ { get; }
Public Shared ReadOnly Property BoundaryAreaRestraintZ As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BoundaryAreaRestraintZ {
    ForgeTypeId^ get ();
}
static member BoundaryAreaRestraintZ : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BoundaryBearing Property

ParameterTypeIdBoundaryBearing Property

"Bearing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BoundaryBearing { get; }
Public Shared ReadOnly Property BoundaryBearing As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BoundaryBearing {
    ForgeTypeId^ get ();
}
static member BoundaryBearing : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BoundaryConditionsIsExt Property

ParameterTypeIdBoundaryConditionsIsExt Property

"Is Boundary Conditions External?"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BoundaryConditionsIsExt { get; }
Public Shared ReadOnly Property BoundaryConditionsIsExt As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BoundaryConditionsIsExt {
    ForgeTypeId^ get ();
}
static member BoundaryConditionsIsExt : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BoundaryConditionsType Property

ParameterTypeIdBoundaryConditionsType Property

"Boundary Conditions Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BoundaryConditionsType { get; }
Public Shared ReadOnly Property BoundaryConditionsType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BoundaryConditionsType {
    ForgeTypeId^ get ();
}
static member BoundaryConditionsType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BoundaryDirectionRotX Property

ParameterTypeIdBoundaryDirectionRotX Property

"X Rotation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BoundaryDirectionRotX { get; }
Public Shared ReadOnly Property BoundaryDirectionRotX As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BoundaryDirectionRotX {
    ForgeTypeId^ get ();
}
static member BoundaryDirectionRotX : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BoundaryDirectionRotY Property

ParameterTypeIdBoundaryDirectionRotY Property

"Y Rotation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BoundaryDirectionRotY { get; }
Public Shared ReadOnly Property BoundaryDirectionRotY As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BoundaryDirectionRotY {
    ForgeTypeId^ get ();
}
static member BoundaryDirectionRotY : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BoundaryDirectionRotZ Property

ParameterTypeIdBoundaryDirectionRotZ Property

"Z Rotation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BoundaryDirectionRotZ { get; }
Public Shared ReadOnly Property BoundaryDirectionRotZ As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BoundaryDirectionRotZ {
    ForgeTypeId^ get ();
}
static member BoundaryDirectionRotZ : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BoundaryDirectionX Property

ParameterTypeIdBoundaryDirectionX Property

"X Translation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BoundaryDirectionX { get; }
Public Shared ReadOnly Property BoundaryDirectionX As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BoundaryDirectionX {
    ForgeTypeId^ get ();
}
static member BoundaryDirectionX : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BoundaryDirectionY Property

ParameterTypeIdBoundaryDirectionY Property

"Y Translation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BoundaryDirectionY { get; }
Public Shared ReadOnly Property BoundaryDirectionY As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BoundaryDirectionY {
    ForgeTypeId^ get ();
}
static member BoundaryDirectionY : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BoundaryDirectionZ Property

ParameterTypeIdBoundaryDirectionZ Property

"Z Translation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BoundaryDirectionZ { get; }
Public Shared ReadOnly Property BoundaryDirectionZ As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BoundaryDirectionZ {
    ForgeTypeId^ get ();
}
static member BoundaryDirectionZ : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BoundaryDistance Property

ParameterTypeIdBoundaryDistance Property

"Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BoundaryDistance { get; }
Public Shared ReadOnly Property BoundaryDistance As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BoundaryDistance {
    ForgeTypeId^ get ();
}
static member BoundaryDistance : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BoundaryLinearRestraintRotX Property

ParameterTypeIdBoundaryLinearRestraintRotX Property

"X Spring Modulus"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BoundaryLinearRestraintRotX { get; }
Public Shared ReadOnly Property BoundaryLinearRestraintRotX As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BoundaryLinearRestraintRotX {
    ForgeTypeId^ get ();
}
static member BoundaryLinearRestraintRotX : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BoundaryLinearRestraintX Property

ParameterTypeIdBoundaryLinearRestraintX Property

"X Spring Modulus"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BoundaryLinearRestraintX { get; }
Public Shared ReadOnly Property BoundaryLinearRestraintX As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BoundaryLinearRestraintX {
    ForgeTypeId^ get ();
}
static member BoundaryLinearRestraintX : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BoundaryLinearRestraintY Property

ParameterTypeIdBoundaryLinearRestraintY Property

"Y Spring Modulus"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BoundaryLinearRestraintY { get; }
Public Shared ReadOnly Property BoundaryLinearRestraintY As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BoundaryLinearRestraintY {
    ForgeTypeId^ get ();
}
static member BoundaryLinearRestraintY : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BoundaryLinearRestraintZ Property

ParameterTypeIdBoundaryLinearRestraintZ Property

"Z Spring Modulus"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BoundaryLinearRestraintZ { get; }
Public Shared ReadOnly Property BoundaryLinearRestraintZ As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BoundaryLinearRestraintZ {
    ForgeTypeId^ get ();
}
static member BoundaryLinearRestraintZ : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BoundaryParamPreset Property

ParameterTypeIdBoundaryParamPreset Property

"State"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BoundaryParamPreset { get; }
Public Shared ReadOnly Property BoundaryParamPreset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BoundaryParamPreset {
    ForgeTypeId^ get ();
}
static member BoundaryParamPreset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BoundaryParamPresetArea Property

ParameterTypeIdBoundaryParamPresetArea Property

"State"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BoundaryParamPresetArea { get; }
Public Shared ReadOnly Property BoundaryParamPresetArea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BoundaryParamPresetArea {
    ForgeTypeId^ get ();
}
static member BoundaryParamPresetArea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BoundaryParamPresetLinear Property

ParameterTypeIdBoundaryParamPresetLinear Property

"State"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BoundaryParamPresetLinear { get; }
Public Shared ReadOnly Property BoundaryParamPresetLinear As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BoundaryParamPresetLinear {
    ForgeTypeId^ get ();
}
static member BoundaryParamPresetLinear : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BoundaryRadius Property

ParameterTypeIdBoundaryRadius Property

"Radius"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BoundaryRadius { get; }
Public Shared ReadOnly Property BoundaryRadius As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BoundaryRadius {
    ForgeTypeId^ get ();
}
static member BoundaryRadius : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BoundaryRestraintRotX Property

ParameterTypeIdBoundaryRestraintRotX Property

"X Spring Modulus"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BoundaryRestraintRotX { get; }
Public Shared ReadOnly Property BoundaryRestraintRotX As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BoundaryRestraintRotX {
    ForgeTypeId^ get ();
}
static member BoundaryRestraintRotX : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BoundaryRestraintRotY Property

ParameterTypeIdBoundaryRestraintRotY Property

"Y Spring Modulus"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BoundaryRestraintRotY { get; }
Public Shared ReadOnly Property BoundaryRestraintRotY As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BoundaryRestraintRotY {
    ForgeTypeId^ get ();
}
static member BoundaryRestraintRotY : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BoundaryRestraintRotZ Property

ParameterTypeIdBoundaryRestraintRotZ Property

"Z Spring Modulus"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BoundaryRestraintRotZ { get; }
Public Shared ReadOnly Property BoundaryRestraintRotZ As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BoundaryRestraintRotZ {
    ForgeTypeId^ get ();
}
static member BoundaryRestraintRotZ : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BoundaryRestraintX Property

ParameterTypeIdBoundaryRestraintX Property

"X Spring Modulus"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BoundaryRestraintX { get; }
Public Shared ReadOnly Property BoundaryRestraintX As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BoundaryRestraintX {
    ForgeTypeId^ get ();
}
static member BoundaryRestraintX : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BoundaryRestraintY Property

ParameterTypeIdBoundaryRestraintY Property

"Y Spring Modulus"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BoundaryRestraintY { get; }
Public Shared ReadOnly Property BoundaryRestraintY As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BoundaryRestraintY {
    ForgeTypeId^ get ();
}
static member BoundaryRestraintY : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BoundaryRestraintZ Property

ParameterTypeIdBoundaryRestraintZ Property

"Z Spring Modulus"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BoundaryRestraintZ { get; }
Public Shared ReadOnly Property BoundaryRestraintZ As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BoundaryRestraintZ {
    ForgeTypeId^ get ();
}
static member BoundaryRestraintZ : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BoundaryXRotationFixed Property

ParameterTypeIdBoundaryXRotationFixed Property

"X Rotation - Fixed"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BoundaryXRotationFixed { get; }
Public Shared ReadOnly Property BoundaryXRotationFixed As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BoundaryXRotationFixed {
    ForgeTypeId^ get ();
}
static member BoundaryXRotationFixed : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BoundaryXRotationSpring Property

ParameterTypeIdBoundaryXRotationSpring Property

"X Rotation - Spring"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BoundaryXRotationSpring { get; }
Public Shared ReadOnly Property BoundaryXRotationSpring As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BoundaryXRotationSpring {
    ForgeTypeId^ get ();
}
static member BoundaryXRotationSpring : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BoundaryXTranslationFixed Property

ParameterTypeIdBoundaryXTranslationFixed Property

"X Translation - Fixed"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BoundaryXTranslationFixed { get; }
Public Shared ReadOnly Property BoundaryXTranslationFixed As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BoundaryXTranslationFixed {
    ForgeTypeId^ get ();
}
static member BoundaryXTranslationFixed : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BoundaryXTranslationSpring Property

ParameterTypeIdBoundaryXTranslationSpring Property

"X Translation - Spring"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BoundaryXTranslationSpring { get; }
Public Shared ReadOnly Property BoundaryXTranslationSpring As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BoundaryXTranslationSpring {
    ForgeTypeId^ get ();
}
static member BoundaryXTranslationSpring : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BoundaryYRotationFixed Property

ParameterTypeIdBoundaryYRotationFixed Property

"Y Rotation - Fixed"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BoundaryYRotationFixed { get; }
Public Shared ReadOnly Property BoundaryYRotationFixed As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BoundaryYRotationFixed {
    ForgeTypeId^ get ();
}
static member BoundaryYRotationFixed : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BoundaryYRotationSpring Property

ParameterTypeIdBoundaryYRotationSpring Property

"Y Rotation - Spring"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BoundaryYRotationSpring { get; }
Public Shared ReadOnly Property BoundaryYRotationSpring As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BoundaryYRotationSpring {
    ForgeTypeId^ get ();
}
static member BoundaryYRotationSpring : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BoundaryYTranslationFixed Property

ParameterTypeIdBoundaryYTranslationFixed Property

"Y Translation - Fixed"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BoundaryYTranslationFixed { get; }
Public Shared ReadOnly Property BoundaryYTranslationFixed As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BoundaryYTranslationFixed {
    ForgeTypeId^ get ();
}
static member BoundaryYTranslationFixed : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BoundaryYTranslationSpring Property

ParameterTypeIdBoundaryYTranslationSpring Property

"Y Translation - Spring"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BoundaryYTranslationSpring { get; }
Public Shared ReadOnly Property BoundaryYTranslationSpring As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BoundaryYTranslationSpring {
    ForgeTypeId^ get ();
}
static member BoundaryYTranslationSpring : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BoundaryZRotationFixed Property

ParameterTypeIdBoundaryZRotationFixed Property

"Z Rotation - Fixed"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BoundaryZRotationFixed { get; }
Public Shared ReadOnly Property BoundaryZRotationFixed As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BoundaryZRotationFixed {
    ForgeTypeId^ get ();
}
static member BoundaryZRotationFixed : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BoundaryZRotationSpring Property

ParameterTypeIdBoundaryZRotationSpring Property

"Z Rotation - Spring"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BoundaryZRotationSpring { get; }
Public Shared ReadOnly Property BoundaryZRotationSpring As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BoundaryZRotationSpring {
    ForgeTypeId^ get ();
}
static member BoundaryZRotationSpring : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BoundaryZTranslationFixed Property

ParameterTypeIdBoundaryZTranslationFixed Property

"Z Translation - Fixed"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BoundaryZTranslationFixed { get; }
Public Shared ReadOnly Property BoundaryZTranslationFixed As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BoundaryZTranslationFixed {
    ForgeTypeId^ get ();
}
static member BoundaryZTranslationFixed : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BoundaryZTranslationSpring Property

ParameterTypeIdBoundaryZTranslationSpring Property

"Z Translation - Spring"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BoundaryZTranslationSpring { get; }
Public Shared ReadOnly Property BoundaryZTranslationSpring As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BoundaryZTranslationSpring {
    ForgeTypeId^ get ();
}
static member BoundaryZTranslationSpring : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BrOrgFilter Property

ParameterTypeIdBrOrgFilter Property

"Filter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BrOrgFilter { get; }
Public Shared ReadOnly Property BrOrgFilter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BrOrgFilter {
    ForgeTypeId^ get ();
}
static member BrOrgFilter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BrOrgFolders Property

ParameterTypeIdBrOrgFolders Property

"Folders"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BrOrgFolders { get; }
Public Shared ReadOnly Property BrOrgFolders As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BrOrgFolders {
    ForgeTypeId^ get ();
}
static member BrOrgFolders : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BuildingClosingTimeParam Property

ParameterTypeIdBuildingClosingTimeParam Property

"Closing Time"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BuildingClosingTimeParam { get; }
Public Shared ReadOnly Property BuildingClosingTimeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BuildingClosingTimeParam {
    ForgeTypeId^ get ();
}
static member BuildingClosingTimeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BuildingCurveGstyle Property

ParameterTypeIdBuildingCurveGstyle Property

"Line Style"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BuildingCurveGstyle { get; }
Public Shared ReadOnly Property BuildingCurveGstyle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BuildingCurveGstyle {
    ForgeTypeId^ get ();
}
static member BuildingCurveGstyle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BuildingCurveGstylePlusInvisible Property

ParameterTypeIdBuildingCurveGstylePlusInvisible Property

"Subcategory"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BuildingCurveGstylePlusInvisible { get; }
Public Shared ReadOnly Property BuildingCurveGstylePlusInvisible As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BuildingCurveGstylePlusInvisible {
    ForgeTypeId^ get ();
}
static member BuildingCurveGstylePlusInvisible : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BuildingOpeningTimeParam Property

ParameterTypeIdBuildingOpeningTimeParam Property

"Opening Time"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BuildingOpeningTimeParam { get; }
Public Shared ReadOnly Property BuildingOpeningTimeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BuildingOpeningTimeParam {
    ForgeTypeId^ get ();
}
static member BuildingOpeningTimeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BuildingpadHeightabovelevelParam Property

ParameterTypeIdBuildingpadHeightabovelevelParam Property

"Height Offset From Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BuildingpadHeightabovelevelParam { get; }
Public Shared ReadOnly Property BuildingpadHeightabovelevelParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BuildingpadHeightabovelevelParam {
    ForgeTypeId^ get ();
}
static member BuildingpadHeightabovelevelParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BuildingpadThickness Property

ParameterTypeIdBuildingpadThickness Property

"Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BuildingpadThickness { get; }
Public Shared ReadOnly Property BuildingpadThickness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BuildingpadThickness {
    ForgeTypeId^ get ();
}
static member BuildingpadThickness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BuildingUnoccupiedCoolingSetPointParam Property

ParameterTypeIdBuildingUnoccupiedCoolingSetPointParam Property

"Unoccupied Cooling Set Point"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BuildingUnoccupiedCoolingSetPointParam { get; }
Public Shared ReadOnly Property BuildingUnoccupiedCoolingSetPointParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BuildingUnoccupiedCoolingSetPointParam {
    ForgeTypeId^ get ();
}
static member BuildingUnoccupiedCoolingSetPointParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.BuilidingPadStructureIdParam Property

ParameterTypeIdBuilidingPadStructureIdParam Property

"Structure"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BuilidingPadStructureIdParam { get; }
Public Shared ReadOnly Property BuilidingPadStructureIdParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BuilidingPadStructureIdParam {
    ForgeTypeId^ get ();
}
static member BuilidingPadStructureIdParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CabletrayMinbendmultiplierParam Property

ParameterTypeIdCabletrayMinbendmultiplierParam Property

"Bend Radius Multiplier"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CabletrayMinbendmultiplierParam { get; }
Public Shared ReadOnly Property CabletrayMinbendmultiplierParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CabletrayMinbendmultiplierParam {
    ForgeTypeId^ get ();
}
static member CabletrayMinbendmultiplierParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CalloutAttrHeadTag Property

ParameterTypeIdCalloutAttrHeadTag Property

"Callout Head"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CalloutAttrHeadTag { get; }
Public Shared ReadOnly Property CalloutAttrHeadTag As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CalloutAttrHeadTag {
    ForgeTypeId^ get ();
}
static member CalloutAttrHeadTag : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CalloutCornerSheetRadius Property

ParameterTypeIdCalloutCornerSheetRadius Property

"Corner Radius"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CalloutCornerSheetRadius { get; }
Public Shared ReadOnly Property CalloutCornerSheetRadius As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CalloutCornerSheetRadius {
    ForgeTypeId^ get ();
}
static member CalloutCornerSheetRadius : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CalloutSyncronizeBoundOffsetFar Property

ParameterTypeIdCalloutSyncronizeBoundOffsetFar Property

"Far Clip Settings"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CalloutSyncronizeBoundOffsetFar { get; }
Public Shared ReadOnly Property CalloutSyncronizeBoundOffsetFar As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CalloutSyncronizeBoundOffsetFar {
    ForgeTypeId^ get ();
}
static member CalloutSyncronizeBoundOffsetFar : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CalloutTag Property

ParameterTypeIdCalloutTag Property

"Callout Tag"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CalloutTag { get; }
Public Shared ReadOnly Property CalloutTag As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CalloutTag {
    ForgeTypeId^ get ();
}
static member CalloutTag : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CeilingAttrDefaultHeightParam Property

ParameterTypeIdCeilingAttrDefaultHeightParam Property

"Default Height above level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CeilingAttrDefaultHeightParam { get; }
Public Shared ReadOnly Property CeilingAttrDefaultHeightParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CeilingAttrDefaultHeightParam {
    ForgeTypeId^ get ();
}
static member CeilingAttrDefaultHeightParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CeilingAttrPatternParam Property

ParameterTypeIdCeilingAttrPatternParam Property

"Pattern"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CeilingAttrPatternParam { get; }
Public Shared ReadOnly Property CeilingAttrPatternParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CeilingAttrPatternParam {
    ForgeTypeId^ get ();
}
static member CeilingAttrPatternParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CeilingAttrSpacing1Param Property

ParameterTypeIdCeilingAttrSpacing1Param Property

"Spacing Axis 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CeilingAttrSpacing1Param { get; }
Public Shared ReadOnly Property CeilingAttrSpacing1Param As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CeilingAttrSpacing1Param {
    ForgeTypeId^ get ();
}
static member CeilingAttrSpacing1Param : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CeilingAttrSpacing2Param Property

ParameterTypeIdCeilingAttrSpacing2Param Property

"Spacing Axis 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CeilingAttrSpacing2Param { get; }
Public Shared ReadOnly Property CeilingAttrSpacing2Param As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CeilingAttrSpacing2Param {
    ForgeTypeId^ get ();
}
static member CeilingAttrSpacing2Param : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CeilingAttrSystemnameParam Property

ParameterTypeIdCeilingAttrSystemnameParam Property

"System"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CeilingAttrSystemnameParam { get; }
Public Shared ReadOnly Property CeilingAttrSystemnameParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CeilingAttrSystemnameParam {
    ForgeTypeId^ get ();
}
static member CeilingAttrSystemnameParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CeilingHasThicknessParam Property

ParameterTypeIdCeilingHasThicknessParam Property

"Has Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CeilingHasThicknessParam { get; }
Public Shared ReadOnly Property CeilingHasThicknessParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CeilingHasThicknessParam {
    ForgeTypeId^ get ();
}
static member CeilingHasThicknessParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CeilingHeightabovelevelParam Property

ParameterTypeIdCeilingHeightabovelevelParam Property

"Height Offset From Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CeilingHeightabovelevelParam { get; }
Public Shared ReadOnly Property CeilingHeightabovelevelParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CeilingHeightabovelevelParam {
    ForgeTypeId^ get ();
}
static member CeilingHeightabovelevelParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CeilingStructureIdParam Property

ParameterTypeIdCeilingStructureIdParam Property

"Structure"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CeilingStructureIdParam { get; }
Public Shared ReadOnly Property CeilingStructureIdParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CeilingStructureIdParam {
    ForgeTypeId^ get ();
}
static member CeilingStructureIdParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CeilingThickness Property

ParameterTypeIdCeilingThickness Property

"Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CeilingThickness { get; }
Public Shared ReadOnly Property CeilingThickness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CeilingThickness {
    ForgeTypeId^ get ();
}
static member CeilingThickness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CeilingThicknessParam Property

ParameterTypeIdCeilingThicknessParam Property

"Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CeilingThicknessParam { get; }
Public Shared ReadOnly Property CeilingThicknessParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CeilingThicknessParam {
    ForgeTypeId^ get ();
}
static member CeilingThicknessParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CenterMarkSize Property

ParameterTypeIdCenterMarkSize Property

"Center Mark Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CenterMarkSize { get; }
Public Shared ReadOnly Property CenterMarkSize As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CenterMarkSize {
    ForgeTypeId^ get ();
}
static member CenterMarkSize : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CircMullionRadius Property

ParameterTypeIdCircMullionRadius Property

"Radius"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CircMullionRadius { get; }
Public Shared ReadOnly Property CircMullionRadius As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CircMullionRadius {
    ForgeTypeId^ get ();
}
static member CircMullionRadius : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CircuitLoadClassificationAbbreviationParam Property

ParameterTypeIdCircuitLoadClassificationAbbreviationParam Property

"Load Classification Abbreviation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CircuitLoadClassificationAbbreviationParam { get; }
Public Shared ReadOnly Property CircuitLoadClassificationAbbreviationParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CircuitLoadClassificationAbbreviationParam {
    ForgeTypeId^ get ();
}
static member CircuitLoadClassificationAbbreviationParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CircuitLoadClassificationParam Property

ParameterTypeIdCircuitLoadClassificationParam Property

"Load Classification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CircuitLoadClassificationParam { get; }
Public Shared ReadOnly Property CircuitLoadClassificationParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CircuitLoadClassificationParam {
    ForgeTypeId^ get ();
}
static member CircuitLoadClassificationParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CircuitPhaseParam Property

ParameterTypeIdCircuitPhaseParam Property

"Phase Label"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CircuitPhaseParam { get; }
Public Shared ReadOnly Property CircuitPhaseParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CircuitPhaseParam {
    ForgeTypeId^ get ();
}
static member CircuitPhaseParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CircuitWaysParam Property

ParameterTypeIdCircuitWaysParam Property

"Ways"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CircuitWaysParam { get; }
Public Shared ReadOnly Property CircuitWaysParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CircuitWaysParam {
    ForgeTypeId^ get ();
}
static member CircuitWaysParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CircularFramingDiameter Property

ParameterTypeIdCircularFramingDiameter Property

"Circular Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CircularFramingDiameter { get; }
Public Shared ReadOnly Property CircularFramingDiameter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CircularFramingDiameter {
    ForgeTypeId^ get ();
}
static member CircularFramingDiameter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ClearCover Property

ParameterTypeIdClearCover Property

"Rebar Cover"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ClearCover { get; }
Public Shared ReadOnly Property ClearCover As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ClearCover {
    ForgeTypeId^ get ();
}
static member ClearCover : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ClearCoverBottom Property

ParameterTypeIdClearCoverBottom Property

"Rebar Cover - Bottom Face"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ClearCoverBottom { get; }
Public Shared ReadOnly Property ClearCoverBottom As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ClearCoverBottom {
    ForgeTypeId^ get ();
}
static member ClearCoverBottom : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ClearCoverExterior Property

ParameterTypeIdClearCoverExterior Property

"Rebar Cover - Exterior Face"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ClearCoverExterior { get; }
Public Shared ReadOnly Property ClearCoverExterior As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ClearCoverExterior {
    ForgeTypeId^ get ();
}
static member ClearCoverExterior : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ClearCoverInterior Property

ParameterTypeIdClearCoverInterior Property

"Rebar Cover - Interior Face"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ClearCoverInterior { get; }
Public Shared ReadOnly Property ClearCoverInterior As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ClearCoverInterior {
    ForgeTypeId^ get ();
}
static member ClearCoverInterior : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ClearCoverOther Property

ParameterTypeIdClearCoverOther Property

"Rebar Cover - Other Faces"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ClearCoverOther { get; }
Public Shared ReadOnly Property ClearCoverOther As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ClearCoverOther {
    ForgeTypeId^ get ();
}
static member ClearCoverOther : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ClearCoverTop Property

ParameterTypeIdClearCoverTop Property

"Rebar Cover - Top Face"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ClearCoverTop { get; }
Public Shared ReadOnly Property ClearCoverTop As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ClearCoverTop {
    ForgeTypeId^ get ();
}
static member ClearCoverTop : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ClientName Property

ParameterTypeIdClientName Property

"Client Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ClientName { get; }
Public Shared ReadOnly Property ClientName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ClientName {
    ForgeTypeId^ get ();
}
static member ClientName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ClineSubcategory Property

ParameterTypeIdClineSubcategory Property

"Subcategory"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ClineSubcategory { get; }
Public Shared ReadOnly Property ClineSubcategory As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ClineSubcategory {
    ForgeTypeId^ get ();
}
static member ClineSubcategory : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CoarseScaleFillPatternColor Property

ParameterTypeIdCoarseScaleFillPatternColor Property

"Coarse Scale Fill Color"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CoarseScaleFillPatternColor { get; }
Public Shared ReadOnly Property CoarseScaleFillPatternColor As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CoarseScaleFillPatternColor {
    ForgeTypeId^ get ();
}
static member CoarseScaleFillPatternColor : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CoarseScaleFillPatternIdParam Property

ParameterTypeIdCoarseScaleFillPatternIdParam Property

"Coarse Scale Fill Pattern"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CoarseScaleFillPatternIdParam { get; }
Public Shared ReadOnly Property CoarseScaleFillPatternIdParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CoarseScaleFillPatternIdParam {
    ForgeTypeId^ get ();
}
static member CoarseScaleFillPatternIdParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ColorFillFilteredParam Property

ParameterTypeIdColorFillFilteredParam Property

"Values Displayed"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ColorFillFilteredParam { get; }
Public Shared ReadOnly Property ColorFillFilteredParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ColorFillFilteredParam {
    ForgeTypeId^ get ();
}
static member ColorFillFilteredParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ColorFillSwatchHeightParam Property

ParameterTypeIdColorFillSwatchHeightParam Property

"Swatch Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ColorFillSwatchHeightParam { get; }
Public Shared ReadOnly Property ColorFillSwatchHeightParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ColorFillSwatchHeightParam {
    ForgeTypeId^ get ();
}
static member ColorFillSwatchHeightParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ColorFillSwatchWidthParam Property

ParameterTypeIdColorFillSwatchWidthParam Property

"Swatch Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ColorFillSwatchWidthParam { get; }
Public Shared ReadOnly Property ColorFillSwatchWidthParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ColorFillSwatchWidthParam {
    ForgeTypeId^ get ();
}
static member ColorFillSwatchWidthParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ColorSchemeLocation Property

ParameterTypeIdColorSchemeLocation Property

"Color Scheme Location"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ColorSchemeLocation { get; }
Public Shared ReadOnly Property ColorSchemeLocation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ColorSchemeLocation {
    ForgeTypeId^ get ();
}
static member ColorSchemeLocation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ColumnBaseAttachCutParam Property

ParameterTypeIdColumnBaseAttachCutParam Property

"Base Attachment Cut"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ColumnBaseAttachCutParam { get; }
Public Shared ReadOnly Property ColumnBaseAttachCutParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ColumnBaseAttachCutParam {
    ForgeTypeId^ get ();
}
static member ColumnBaseAttachCutParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ColumnBaseAttachedParam Property

ParameterTypeIdColumnBaseAttachedParam Property

"Base is Attached"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ColumnBaseAttachedParam { get; }
Public Shared ReadOnly Property ColumnBaseAttachedParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ColumnBaseAttachedParam {
    ForgeTypeId^ get ();
}
static member ColumnBaseAttachedParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ColumnBaseAttachJustificationParam Property

ParameterTypeIdColumnBaseAttachJustificationParam Property

"Attachment Justification At Base"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ColumnBaseAttachJustificationParam { get; }
Public Shared ReadOnly Property ColumnBaseAttachJustificationParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ColumnBaseAttachJustificationParam {
    ForgeTypeId^ get ();
}
static member ColumnBaseAttachJustificationParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ColumnBaseAttachmentOffsetParam Property

ParameterTypeIdColumnBaseAttachmentOffsetParam Property

"Offset From Attachment At Base"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ColumnBaseAttachmentOffsetParam { get; }
Public Shared ReadOnly Property ColumnBaseAttachmentOffsetParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ColumnBaseAttachmentOffsetParam {
    ForgeTypeId^ get ();
}
static member ColumnBaseAttachmentOffsetParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ColumnLocationMark Property

ParameterTypeIdColumnLocationMark Property

"Column Location Mark"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ColumnLocationMark { get; }
Public Shared ReadOnly Property ColumnLocationMark As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ColumnLocationMark {
    ForgeTypeId^ get ();
}
static member ColumnLocationMark : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ColumnTopAttachCutParam Property

ParameterTypeIdColumnTopAttachCutParam Property

"Top Attachment Cut"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ColumnTopAttachCutParam { get; }
Public Shared ReadOnly Property ColumnTopAttachCutParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ColumnTopAttachCutParam {
    ForgeTypeId^ get ();
}
static member ColumnTopAttachCutParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ColumnTopAttachedParam Property

ParameterTypeIdColumnTopAttachedParam Property

"Top is Attached"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ColumnTopAttachedParam { get; }
Public Shared ReadOnly Property ColumnTopAttachedParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ColumnTopAttachedParam {
    ForgeTypeId^ get ();
}
static member ColumnTopAttachedParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ColumnTopAttachJustificationParam Property

ParameterTypeIdColumnTopAttachJustificationParam Property

"Attachment Justification At Top"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ColumnTopAttachJustificationParam { get; }
Public Shared ReadOnly Property ColumnTopAttachJustificationParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ColumnTopAttachJustificationParam {
    ForgeTypeId^ get ();
}
static member ColumnTopAttachJustificationParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ColumnTopAttachmentOffsetParam Property

ParameterTypeIdColumnTopAttachmentOffsetParam Property

"Offset From Attachment At Top"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ColumnTopAttachmentOffsetParam { get; }
Public Shared ReadOnly Property ColumnTopAttachmentOffsetParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ColumnTopAttachmentOffsetParam {
    ForgeTypeId^ get ();
}
static member ColumnTopAttachmentOffsetParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ConceptualConstructionMaterial Property

ParameterTypeIdConceptualConstructionMaterial Property

"Graphical Appearance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ConceptualConstructionMaterial { get; }
Public Shared ReadOnly Property ConceptualConstructionMaterial As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ConceptualConstructionMaterial {
    ForgeTypeId^ get ();
}
static member ConceptualConstructionMaterial : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ConduitStandardTypeParam Property

ParameterTypeIdConduitStandardTypeParam Property

"Standard"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ConduitStandardTypeParam { get; }
Public Shared ReadOnly Property ConduitStandardTypeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ConduitStandardTypeParam {
    ForgeTypeId^ get ();
}
static member ConduitStandardTypeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ConnectorAngle Property

ParameterTypeIdConnectorAngle Property

"Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ConnectorAngle { get; }
Public Shared ReadOnly Property ConnectorAngle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ConnectorAngle {
    ForgeTypeId^ get ();
}
static member ConnectorAngle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ConnectorAngleOfDeflection Property

ParameterTypeIdConnectorAngleOfDeflection Property

"Angle of Deflection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ConnectorAngleOfDeflection { get; }
Public Shared ReadOnly Property ConnectorAngleOfDeflection As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ConnectorAngleOfDeflection {
    ForgeTypeId^ get ();
}
static member ConnectorAngleOfDeflection : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ConnectorDiameter Property

ParameterTypeIdConnectorDiameter Property

"Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ConnectorDiameter { get; }
Public Shared ReadOnly Property ConnectorDiameter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ConnectorDiameter {
    ForgeTypeId^ get ();
}
static member ConnectorDiameter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ConnectorEngagementLength Property

ParameterTypeIdConnectorEngagementLength Property

"Engagement Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ConnectorEngagementLength { get; }
Public Shared ReadOnly Property ConnectorEngagementLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ConnectorEngagementLength {
    ForgeTypeId^ get ();
}
static member ConnectorEngagementLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ConnectorGenderType Property

ParameterTypeIdConnectorGenderType Property

"Connector Gender Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ConnectorGenderType { get; }
Public Shared ReadOnly Property ConnectorGenderType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ConnectorGenderType {
    ForgeTypeId^ get ();
}
static member ConnectorGenderType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ConnectorHeight Property

ParameterTypeIdConnectorHeight Property

"Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ConnectorHeight { get; }
Public Shared ReadOnly Property ConnectorHeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ConnectorHeight {
    ForgeTypeId^ get ();
}
static member ConnectorHeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ConnectorIndex Property

ParameterTypeIdConnectorIndex Property

"Index"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ConnectorIndex { get; }
Public Shared ReadOnly Property ConnectorIndex As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ConnectorIndex {
    ForgeTypeId^ get ();
}
static member ConnectorIndex : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ConnectorInsideDiameter Property

ParameterTypeIdConnectorInsideDiameter Property

"Inside Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ConnectorInsideDiameter { get; }
Public Shared ReadOnly Property ConnectorInsideDiameter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ConnectorInsideDiameter {
    ForgeTypeId^ get ();
}
static member ConnectorInsideDiameter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ConnectorJointType Property

ParameterTypeIdConnectorJointType Property

"Connector Joint Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ConnectorJointType { get; }
Public Shared ReadOnly Property ConnectorJointType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ConnectorJointType {
    ForgeTypeId^ get ();
}
static member ConnectorJointType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ConnectorLength Property

ParameterTypeIdConnectorLength Property

"Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ConnectorLength { get; }
Public Shared ReadOnly Property ConnectorLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ConnectorLength {
    ForgeTypeId^ get ();
}
static member ConnectorLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ConnectorProfileType Property

ParameterTypeIdConnectorProfileType Property

"Shape"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ConnectorProfileType { get; }
Public Shared ReadOnly Property ConnectorProfileType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ConnectorProfileType {
    ForgeTypeId^ get ();
}
static member ConnectorProfileType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ConnectorRadius Property

ParameterTypeIdConnectorRadius Property

"Radius"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ConnectorRadius { get; }
Public Shared ReadOnly Property ConnectorRadius As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ConnectorRadius {
    ForgeTypeId^ get ();
}
static member ConnectorRadius : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ConnectorReferenceIndex Property

ParameterTypeIdConnectorReferenceIndex Property

"Link Connector Index"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ConnectorReferenceIndex { get; }
Public Shared ReadOnly Property ConnectorReferenceIndex As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ConnectorReferenceIndex {
    ForgeTypeId^ get ();
}
static member ConnectorReferenceIndex : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ConnectorUtilityParam Property

ParameterTypeIdConnectorUtilityParam Property

"Utility"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ConnectorUtilityParam { get; }
Public Shared ReadOnly Property ConnectorUtilityParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ConnectorUtilityParam {
    ForgeTypeId^ get ();
}
static member ConnectorUtilityParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ConnectorVisibleSize Property

ParameterTypeIdConnectorVisibleSize Property

"Size on screen"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ConnectorVisibleSize { get; }
Public Shared ReadOnly Property ConnectorVisibleSize As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ConnectorVisibleSize {
    ForgeTypeId^ get ();
}
static member ConnectorVisibleSize : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ConnectorWidth Property

ParameterTypeIdConnectorWidth Property

"Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ConnectorWidth { get; }
Public Shared ReadOnly Property ConnectorWidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ConnectorWidth {
    ForgeTypeId^ get ();
}
static member ConnectorWidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ConstructionIsSchematic Property

ParameterTypeIdConstructionIsSchematic Property

"Schematic"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ConstructionIsSchematic { get; }
Public Shared ReadOnly Property ConstructionIsSchematic As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ConstructionIsSchematic {
    ForgeTypeId^ get ();
}
static member ConstructionIsSchematic : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ConstructionName Property

ParameterTypeIdConstructionName Property

"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ConstructionName { get; }
Public Shared ReadOnly Property ConstructionName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ConstructionName {
    ForgeTypeId^ get ();
}
static member ConstructionName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ContinuousFootingBearingWidth Property

ParameterTypeIdContinuousFootingBearingWidth Property

"Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ContinuousFootingBearingWidth { get; }
Public Shared ReadOnly Property ContinuousFootingBearingWidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ContinuousFootingBearingWidth {
    ForgeTypeId^ get ();
}
static member ContinuousFootingBearingWidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ContinuousFootingBottomHeel Property

ParameterTypeIdContinuousFootingBottomHeel Property

"Bottom Heel Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ContinuousFootingBottomHeel { get; }
Public Shared ReadOnly Property ContinuousFootingBottomHeel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ContinuousFootingBottomHeel {
    ForgeTypeId^ get ();
}
static member ContinuousFootingBottomHeel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ContinuousFootingBottomToe Property

ParameterTypeIdContinuousFootingBottomToe Property

"Bottom Toe Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ContinuousFootingBottomToe { get; }
Public Shared ReadOnly Property ContinuousFootingBottomToe As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ContinuousFootingBottomToe {
    ForgeTypeId^ get ();
}
static member ContinuousFootingBottomToe : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ContinuousFootingBreakAtInsertsDisable Property

ParameterTypeIdContinuousFootingBreakAtInsertsDisable Property

"Do Not Break At Inserts"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ContinuousFootingBreakAtInsertsDisable { get; }
Public Shared ReadOnly Property ContinuousFootingBreakAtInsertsDisable As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ContinuousFootingBreakAtInsertsDisable {
    ForgeTypeId^ get ();
}
static member ContinuousFootingBreakAtInsertsDisable : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ContinuousFootingDefaultEndExtensionLength Property

ParameterTypeIdContinuousFootingDefaultEndExtensionLength Property

"Default End Extension Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ContinuousFootingDefaultEndExtensionLength { get; }
Public Shared ReadOnly Property ContinuousFootingDefaultEndExtensionLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ContinuousFootingDefaultEndExtensionLength {
    ForgeTypeId^ get ();
}
static member ContinuousFootingDefaultEndExtensionLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ContinuousFootingEccentricity Property

ParameterTypeIdContinuousFootingEccentricity Property

"Eccentricity"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ContinuousFootingEccentricity { get; }
Public Shared ReadOnly Property ContinuousFootingEccentricity As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ContinuousFootingEccentricity {
    ForgeTypeId^ get ();
}
static member ContinuousFootingEccentricity : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ContinuousFootingLength Property

ParameterTypeIdContinuousFootingLength Property

"Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ContinuousFootingLength { get; }
Public Shared ReadOnly Property ContinuousFootingLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ContinuousFootingLength {
    ForgeTypeId^ get ();
}
static member ContinuousFootingLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ContinuousFootingStructuralUsage Property

ParameterTypeIdContinuousFootingStructuralUsage Property

"Structural Usage"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ContinuousFootingStructuralUsage { get; }
Public Shared ReadOnly Property ContinuousFootingStructuralUsage As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ContinuousFootingStructuralUsage {
    ForgeTypeId^ get ();
}
static member ContinuousFootingStructuralUsage : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ContinuousFootingTopHeel Property

ParameterTypeIdContinuousFootingTopHeel Property

"Heel Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ContinuousFootingTopHeel { get; }
Public Shared ReadOnly Property ContinuousFootingTopHeel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ContinuousFootingTopHeel {
    ForgeTypeId^ get ();
}
static member ContinuousFootingTopHeel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ContinuousFootingTopToe Property

ParameterTypeIdContinuousFootingTopToe Property

"Toe Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ContinuousFootingTopToe { get; }
Public Shared ReadOnly Property ContinuousFootingTopToe As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ContinuousFootingTopToe {
    ForgeTypeId^ get ();
}
static member ContinuousFootingTopToe : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ContinuousFootingWidth Property

ParameterTypeIdContinuousFootingWidth Property

"Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ContinuousFootingWidth { get; }
Public Shared ReadOnly Property ContinuousFootingWidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ContinuousFootingWidth {
    ForgeTypeId^ get ();
}
static member ContinuousFootingWidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ContinuousrailBeginningTerminationAttachmentParam Property

ParameterTypeIdContinuousrailBeginningTerminationAttachmentParam Property

"Extension Style"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ContinuousrailBeginningTerminationAttachmentParam { get; }
Public Shared ReadOnly Property ContinuousrailBeginningTerminationAttachmentParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ContinuousrailBeginningTerminationAttachmentParam {
    ForgeTypeId^ get ();
}
static member ContinuousrailBeginningTerminationAttachmentParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ContinuousrailBeginningTerminationTypeParam Property

ParameterTypeIdContinuousrailBeginningTerminationTypeParam Property

"Beginning/Bottom Termination"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ContinuousrailBeginningTerminationTypeParam { get; }
Public Shared ReadOnly Property ContinuousrailBeginningTerminationTypeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ContinuousrailBeginningTerminationTypeParam {
    ForgeTypeId^ get ();
}
static member ContinuousrailBeginningTerminationTypeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ContinuousrailDefaultJoinTypeParam Property

ParameterTypeIdContinuousrailDefaultJoinTypeParam Property

"Default Join"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ContinuousrailDefaultJoinTypeParam { get; }
Public Shared ReadOnly Property ContinuousrailDefaultJoinTypeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ContinuousrailDefaultJoinTypeParam {
    ForgeTypeId^ get ();
}
static member ContinuousrailDefaultJoinTypeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ContinuousrailEndExtensionLengthParam Property

ParameterTypeIdContinuousrailEndExtensionLengthParam Property

"Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ContinuousrailEndExtensionLengthParam { get; }
Public Shared ReadOnly Property ContinuousrailEndExtensionLengthParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ContinuousrailEndExtensionLengthParam {
    ForgeTypeId^ get ();
}
static member ContinuousrailEndExtensionLengthParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ContinuousrailEndTerminationAttachmentParam Property

ParameterTypeIdContinuousrailEndTerminationAttachmentParam Property

"Extension Style"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ContinuousrailEndTerminationAttachmentParam { get; }
Public Shared ReadOnly Property ContinuousrailEndTerminationAttachmentParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ContinuousrailEndTerminationAttachmentParam {
    ForgeTypeId^ get ();
}
static member ContinuousrailEndTerminationAttachmentParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ContinuousrailEndTerminationTypeParam Property

ParameterTypeIdContinuousrailEndTerminationTypeParam Property

"End/Top Termination"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ContinuousrailEndTerminationTypeParam { get; }
Public Shared ReadOnly Property ContinuousrailEndTerminationTypeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ContinuousrailEndTerminationTypeParam {
    ForgeTypeId^ get ();
}
static member ContinuousrailEndTerminationTypeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ContinuousrailExtensionLengthParam Property

ParameterTypeIdContinuousrailExtensionLengthParam Property

"Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ContinuousrailExtensionLengthParam { get; }
Public Shared ReadOnly Property ContinuousrailExtensionLengthParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ContinuousrailExtensionLengthParam {
    ForgeTypeId^ get ();
}
static member ContinuousrailExtensionLengthParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ContinuousrailFilletRadiusParam Property

ParameterTypeIdContinuousrailFilletRadiusParam Property

"Fillet Radius"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ContinuousrailFilletRadiusParam { get; }
Public Shared ReadOnly Property ContinuousrailFilletRadiusParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ContinuousrailFilletRadiusParam {
    ForgeTypeId^ get ();
}
static member ContinuousrailFilletRadiusParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ContinuousrailJoinTypeParam Property

ParameterTypeIdContinuousrailJoinTypeParam Property

"Rail Path Join"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ContinuousrailJoinTypeParam { get; }
Public Shared ReadOnly Property ContinuousrailJoinTypeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ContinuousrailJoinTypeParam {
    ForgeTypeId^ get ();
}
static member ContinuousrailJoinTypeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ContinuousrailLengthParam Property

ParameterTypeIdContinuousrailLengthParam Property

"Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ContinuousrailLengthParam { get; }
Public Shared ReadOnly Property ContinuousrailLengthParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ContinuousrailLengthParam {
    ForgeTypeId^ get ();
}
static member ContinuousrailLengthParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ContinuousrailMaterialsParam Property

ParameterTypeIdContinuousrailMaterialsParam Property

"Material"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ContinuousrailMaterialsParam { get; }
Public Shared ReadOnly Property ContinuousrailMaterialsParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ContinuousrailMaterialsParam {
    ForgeTypeId^ get ();
}
static member ContinuousrailMaterialsParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ContinuousrailPlusTreadDepthParam Property

ParameterTypeIdContinuousrailPlusTreadDepthParam Property

"Plus Tread Depth"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ContinuousrailPlusTreadDepthParam { get; }
Public Shared ReadOnly Property ContinuousrailPlusTreadDepthParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ContinuousrailPlusTreadDepthParam {
    ForgeTypeId^ get ();
}
static member ContinuousrailPlusTreadDepthParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ContinuousrailProfileTypeParam Property

ParameterTypeIdContinuousrailProfileTypeParam Property

"Profile"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ContinuousrailProfileTypeParam { get; }
Public Shared ReadOnly Property ContinuousrailProfileTypeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ContinuousrailProfileTypeParam {
    ForgeTypeId^ get ();
}
static member ContinuousrailProfileTypeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ContinuousrailTransitionTypeParam Property

ParameterTypeIdContinuousrailTransitionTypeParam Property

"Transitions"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ContinuousrailTransitionTypeParam { get; }
Public Shared ReadOnly Property ContinuousrailTransitionTypeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ContinuousrailTransitionTypeParam {
    ForgeTypeId^ get ();
}
static member ContinuousrailTransitionTypeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ContourElevation Property

ParameterTypeIdContourElevation Property

"Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ContourElevation { get; }
Public Shared ReadOnly Property ContourElevation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ContourElevation {
    ForgeTypeId^ get ();
}
static member ContourElevation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ContourElevationStep Property

ParameterTypeIdContourElevationStep Property

"Increment"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ContourElevationStep { get; }
Public Shared ReadOnly Property ContourElevationStep As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ContourElevationStep {
    ForgeTypeId^ get ();
}
static member ContourElevationStep : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ContourLabelsElevBaseType Property

ParameterTypeIdContourLabelsElevBaseType Property

"Elevation Base"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ContourLabelsElevBaseType { get; }
Public Shared ReadOnly Property ContourLabelsElevBaseType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ContourLabelsElevBaseType {
    ForgeTypeId^ get ();
}
static member ContourLabelsElevBaseType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ContourLabelsLinearUnits Property

ParameterTypeIdContourLabelsLinearUnits Property

"Units Format"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ContourLabelsLinearUnits { get; }
Public Shared ReadOnly Property ContourLabelsLinearUnits As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ContourLabelsLinearUnits {
    ForgeTypeId^ get ();
}
static member ContourLabelsLinearUnits : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ContourLabelsPrimaryOnly Property

ParameterTypeIdContourLabelsPrimaryOnly Property

"Label primary contours only"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ContourLabelsPrimaryOnly { get; }
Public Shared ReadOnly Property ContourLabelsPrimaryOnly As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ContourLabelsPrimaryOnly {
    ForgeTypeId^ get ();
}
static member ContourLabelsPrimaryOnly : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ContourLabelsRelativeBase Property

ParameterTypeIdContourLabelsRelativeBase Property

"Relative Base"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ContourLabelsRelativeBase { get; }
Public Shared ReadOnly Property ContourLabelsRelativeBase As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ContourLabelsRelativeBase {
    ForgeTypeId^ get ();
}
static member ContourLabelsRelativeBase : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CouplerCode Property

ParameterTypeIdCouplerCode Property

"Part Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CouplerCode { get; }
Public Shared ReadOnly Property CouplerCode As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CouplerCode {
    ForgeTypeId^ get ();
}
static member CouplerCode : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CouplerCoupledBarSize Property

ParameterTypeIdCouplerCoupledBarSize Property

"Bar Size 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CouplerCoupledBarSize { get; }
Public Shared ReadOnly Property CouplerCoupledBarSize As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CouplerCoupledBarSize {
    ForgeTypeId^ get ();
}
static member CouplerCoupledBarSize : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CouplerCoupledEndtreatment Property

ParameterTypeIdCouplerCoupledEndtreatment Property

"End Treatment 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CouplerCoupledEndtreatment { get; }
Public Shared ReadOnly Property CouplerCoupledEndtreatment As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CouplerCoupledEndtreatment {
    ForgeTypeId^ get ();
}
static member CouplerCoupledEndtreatment : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CouplerCoupledEngagement Property

ParameterTypeIdCouplerCoupledEngagement Property

"Bar Engagement 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CouplerCoupledEngagement { get; }
Public Shared ReadOnly Property CouplerCoupledEngagement As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CouplerCoupledEngagement {
    ForgeTypeId^ get ();
}
static member CouplerCoupledEngagement : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CouplerLength Property

ParameterTypeIdCouplerLength Property

"Total Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CouplerLength { get; }
Public Shared ReadOnly Property CouplerLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CouplerLength {
    ForgeTypeId^ get ();
}
static member CouplerLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CouplerMainBarSize Property

ParameterTypeIdCouplerMainBarSize Property

"Bar Size 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CouplerMainBarSize { get; }
Public Shared ReadOnly Property CouplerMainBarSize As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CouplerMainBarSize {
    ForgeTypeId^ get ();
}
static member CouplerMainBarSize : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CouplerMainEndtreatment Property

ParameterTypeIdCouplerMainEndtreatment Property

"End Treatment 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CouplerMainEndtreatment { get; }
Public Shared ReadOnly Property CouplerMainEndtreatment As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CouplerMainEndtreatment {
    ForgeTypeId^ get ();
}
static member CouplerMainEndtreatment : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CouplerMainEngagement Property

ParameterTypeIdCouplerMainEngagement Property

"Bar Engagement 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CouplerMainEngagement { get; }
Public Shared ReadOnly Property CouplerMainEngagement As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CouplerMainEngagement {
    ForgeTypeId^ get ();
}
static member CouplerMainEngagement : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CouplerMark Property

ParameterTypeIdCouplerMark Property

"Schedule Mark"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CouplerMark { get; }
Public Shared ReadOnly Property CouplerMark As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CouplerMark {
    ForgeTypeId^ get ();
}
static member CouplerMark : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CouplerNumber Property

ParameterTypeIdCouplerNumber Property

"Coupler Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CouplerNumber { get; }
Public Shared ReadOnly Property CouplerNumber As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CouplerNumber {
    ForgeTypeId^ get ();
}
static member CouplerNumber : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CouplerQuantity Property

ParameterTypeIdCouplerQuantity Property

"Quantity"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CouplerQuantity { get; }
Public Shared ReadOnly Property CouplerQuantity As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CouplerQuantity {
    ForgeTypeId^ get ();
}
static member CouplerQuantity : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CouplerRotationAngle Property

ParameterTypeIdCouplerRotationAngle Property

"Coupler Rotation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CouplerRotationAngle { get; }
Public Shared ReadOnly Property CouplerRotationAngle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CouplerRotationAngle {
    ForgeTypeId^ get ();
}
static member CouplerRotationAngle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CouplerWeight Property

ParameterTypeIdCouplerWeight Property

"Mass"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CouplerWeight { get; }
Public Shared ReadOnly Property CouplerWeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CouplerWeight {
    ForgeTypeId^ get ();
}
static member CouplerWeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CouplerWidth Property

ParameterTypeIdCouplerWidth Property

"External Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CouplerWidth { get; }
Public Shared ReadOnly Property CouplerWidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CouplerWidth {
    ForgeTypeId^ get ();
}
static member CouplerWidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CoverTypeLength Property

ParameterTypeIdCoverTypeLength Property

"Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CoverTypeLength { get; }
Public Shared ReadOnly Property CoverTypeLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CoverTypeLength {
    ForgeTypeId^ get ();
}
static member CoverTypeLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CoverTypeName Property

ParameterTypeIdCoverTypeName Property

"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CoverTypeName { get; }
Public Shared ReadOnly Property CoverTypeName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CoverTypeName {
    ForgeTypeId^ get ();
}
static member CoverTypeName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurtaingridAdjustBorderHoriz Property

ParameterTypeIdCurtaingridAdjustBorderHoriz Property

"Adjust for Mullion Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtaingridAdjustBorderHoriz { get; }
Public Shared ReadOnly Property CurtaingridAdjustBorderHoriz As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtaingridAdjustBorderHoriz {
    ForgeTypeId^ get ();
}
static member CurtaingridAdjustBorderHoriz : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurtaingridAdjustBordern1 Property

ParameterTypeIdCurtaingridAdjustBordern1 Property

"Adjust for Mullion Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtaingridAdjustBordern1 { get; }
Public Shared ReadOnly Property CurtaingridAdjustBordern1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtaingridAdjustBordern1 {
    ForgeTypeId^ get ();
}
static member CurtaingridAdjustBordern1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurtaingridAdjustBordern2 Property

ParameterTypeIdCurtaingridAdjustBordern2 Property

"Adjust for Mullion Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtaingridAdjustBordern2 { get; }
Public Shared ReadOnly Property CurtaingridAdjustBordern2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtaingridAdjustBordern2 {
    ForgeTypeId^ get ();
}
static member CurtaingridAdjustBordern2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurtaingridAdjustBorderU Property

ParameterTypeIdCurtaingridAdjustBorderU Property

"Adjust for Mullion Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtaingridAdjustBorderU { get; }
Public Shared ReadOnly Property CurtaingridAdjustBorderU As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtaingridAdjustBorderU {
    ForgeTypeId^ get ();
}
static member CurtaingridAdjustBorderU : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurtaingridAdjustBorderV Property

ParameterTypeIdCurtaingridAdjustBorderV Property

"Adjust for Mullion Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtaingridAdjustBorderV { get; }
Public Shared ReadOnly Property CurtaingridAdjustBorderV As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtaingridAdjustBorderV {
    ForgeTypeId^ get ();
}
static member CurtaingridAdjustBorderV : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurtaingridAdjustBorderVert Property

ParameterTypeIdCurtaingridAdjustBorderVert Property

"Adjust for Mullion Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtaingridAdjustBorderVert { get; }
Public Shared ReadOnly Property CurtaingridAdjustBorderVert As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtaingridAdjustBorderVert {
    ForgeTypeId^ get ();
}
static member CurtaingridAdjustBorderVert : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurtaingridAngleHoriz Property

ParameterTypeIdCurtaingridAngleHoriz Property

"Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtaingridAngleHoriz { get; }
Public Shared ReadOnly Property CurtaingridAngleHoriz As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtaingridAngleHoriz {
    ForgeTypeId^ get ();
}
static member CurtaingridAngleHoriz : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurtaingridAnglen1 Property

ParameterTypeIdCurtaingridAnglen1 Property

"Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtaingridAnglen1 { get; }
Public Shared ReadOnly Property CurtaingridAnglen1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtaingridAnglen1 {
    ForgeTypeId^ get ();
}
static member CurtaingridAnglen1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurtaingridAnglen2 Property

ParameterTypeIdCurtaingridAnglen2 Property

"Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtaingridAnglen2 { get; }
Public Shared ReadOnly Property CurtaingridAnglen2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtaingridAnglen2 {
    ForgeTypeId^ get ();
}
static member CurtaingridAnglen2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurtaingridAngleU Property

ParameterTypeIdCurtaingridAngleU Property

"Grid Rotation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtaingridAngleU { get; }
Public Shared ReadOnly Property CurtaingridAngleU As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtaingridAngleU {
    ForgeTypeId^ get ();
}
static member CurtaingridAngleU : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurtaingridAngleV Property

ParameterTypeIdCurtaingridAngleV Property

"Grid Rotation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtaingridAngleV { get; }
Public Shared ReadOnly Property CurtaingridAngleV As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtaingridAngleV {
    ForgeTypeId^ get ();
}
static member CurtaingridAngleV : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurtaingridAngleVert Property

ParameterTypeIdCurtaingridAngleVert Property

"Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtaingridAngleVert { get; }
Public Shared ReadOnly Property CurtaingridAngleVert As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtaingridAngleVert {
    ForgeTypeId^ get ();
}
static member CurtaingridAngleVert : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurtainGridBaseOrientation Property

ParameterTypeIdCurtainGridBaseOrientation Property

"Grid Base Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtainGridBaseOrientation { get; }
Public Shared ReadOnly Property CurtainGridBaseOrientation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtainGridBaseOrientation {
    ForgeTypeId^ get ();
}
static member CurtainGridBaseOrientation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurtaingridBeltHoriz Property

ParameterTypeIdCurtaingridBeltHoriz Property

"Measurement Line"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtaingridBeltHoriz { get; }
Public Shared ReadOnly Property CurtaingridBeltHoriz As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtaingridBeltHoriz {
    ForgeTypeId^ get ();
}
static member CurtaingridBeltHoriz : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurtaingridBeltn1 Property

ParameterTypeIdCurtaingridBeltn1 Property

"Measurement Line"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtaingridBeltn1 { get; }
Public Shared ReadOnly Property CurtaingridBeltn1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtaingridBeltn1 {
    ForgeTypeId^ get ();
}
static member CurtaingridBeltn1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurtaingridBeltn2 Property

ParameterTypeIdCurtaingridBeltn2 Property

"Measurement Line"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtaingridBeltn2 { get; }
Public Shared ReadOnly Property CurtaingridBeltn2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtaingridBeltn2 {
    ForgeTypeId^ get ();
}
static member CurtaingridBeltn2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurtaingridBeltRation1 Property

ParameterTypeIdCurtaingridBeltRation1 Property

"Measurement Line"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtaingridBeltRation1 { get; }
Public Shared ReadOnly Property CurtaingridBeltRation1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtaingridBeltRation1 {
    ForgeTypeId^ get ();
}
static member CurtaingridBeltRation1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurtaingridBeltRation2 Property

ParameterTypeIdCurtaingridBeltRation2 Property

"Measurement Line"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtaingridBeltRation2 { get; }
Public Shared ReadOnly Property CurtaingridBeltRation2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtaingridBeltRation2 {
    ForgeTypeId^ get ();
}
static member CurtaingridBeltRation2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurtaingridBeltRatioU Property

ParameterTypeIdCurtaingridBeltRatioU Property

"Belt Measurement"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtaingridBeltRatioU { get; }
Public Shared ReadOnly Property CurtaingridBeltRatioU As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtaingridBeltRatioU {
    ForgeTypeId^ get ();
}
static member CurtaingridBeltRatioU : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurtaingridBeltRatioV Property

ParameterTypeIdCurtaingridBeltRatioV Property

"Belt Measurement"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtaingridBeltRatioV { get; }
Public Shared ReadOnly Property CurtaingridBeltRatioV As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtaingridBeltRatioV {
    ForgeTypeId^ get ();
}
static member CurtaingridBeltRatioV : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurtaingridBeltU Property

ParameterTypeIdCurtaingridBeltU Property

"Belt Measurement"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtaingridBeltU { get; }
Public Shared ReadOnly Property CurtaingridBeltU As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtaingridBeltU {
    ForgeTypeId^ get ();
}
static member CurtaingridBeltU : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurtaingridBeltV Property

ParameterTypeIdCurtaingridBeltV Property

"Belt Measurement"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtaingridBeltV { get; }
Public Shared ReadOnly Property CurtaingridBeltV As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtaingridBeltV {
    ForgeTypeId^ get ();
}
static member CurtaingridBeltV : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurtaingridBeltVert Property

ParameterTypeIdCurtaingridBeltVert Property

"Measurement Line"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtaingridBeltVert { get; }
Public Shared ReadOnly Property CurtaingridBeltVert As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtaingridBeltVert {
    ForgeTypeId^ get ();
}
static member CurtaingridBeltVert : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurtaingridOriginHoriz Property

ParameterTypeIdCurtaingridOriginHoriz Property

"Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtaingridOriginHoriz { get; }
Public Shared ReadOnly Property CurtaingridOriginHoriz As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtaingridOriginHoriz {
    ForgeTypeId^ get ();
}
static member CurtaingridOriginHoriz : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurtaingridOriginn1 Property

ParameterTypeIdCurtaingridOriginn1 Property

"Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtaingridOriginn1 { get; }
Public Shared ReadOnly Property CurtaingridOriginn1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtaingridOriginn1 {
    ForgeTypeId^ get ();
}
static member CurtaingridOriginn1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurtaingridOriginn2 Property

ParameterTypeIdCurtaingridOriginn2 Property

"Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtaingridOriginn2 { get; }
Public Shared ReadOnly Property CurtaingridOriginn2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtaingridOriginn2 {
    ForgeTypeId^ get ();
}
static member CurtaingridOriginn2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurtaingridOriginU Property

ParameterTypeIdCurtaingridOriginU Property

"Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtaingridOriginU { get; }
Public Shared ReadOnly Property CurtaingridOriginU As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtaingridOriginU {
    ForgeTypeId^ get ();
}
static member CurtaingridOriginU : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurtaingridOriginV Property

ParameterTypeIdCurtaingridOriginV Property

"Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtaingridOriginV { get; }
Public Shared ReadOnly Property CurtaingridOriginV As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtaingridOriginV {
    ForgeTypeId^ get ();
}
static member CurtaingridOriginV : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurtaingridOriginVert Property

ParameterTypeIdCurtaingridOriginVert Property

"Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtaingridOriginVert { get; }
Public Shared ReadOnly Property CurtaingridOriginVert As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtaingridOriginVert {
    ForgeTypeId^ get ();
}
static member CurtaingridOriginVert : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurtaingridUseCurveDist Property

ParameterTypeIdCurtaingridUseCurveDist Property

"Use Curve Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtaingridUseCurveDist { get; }
Public Shared ReadOnly Property CurtaingridUseCurveDist As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtaingridUseCurveDist {
    ForgeTypeId^ get ();
}
static member CurtaingridUseCurveDist : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurtaingridUseCurveDistHoriz Property

ParameterTypeIdCurtaingridUseCurveDistHoriz Property

"Use Curve Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtaingridUseCurveDistHoriz { get; }
Public Shared ReadOnly Property CurtaingridUseCurveDistHoriz As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtaingridUseCurveDistHoriz {
    ForgeTypeId^ get ();
}
static member CurtaingridUseCurveDistHoriz : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurtaingridUseCurveDistn1 Property

ParameterTypeIdCurtaingridUseCurveDistn1 Property

"Use Curve Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtaingridUseCurveDistn1 { get; }
Public Shared ReadOnly Property CurtaingridUseCurveDistn1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtaingridUseCurveDistn1 {
    ForgeTypeId^ get ();
}
static member CurtaingridUseCurveDistn1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurtaingridUseCurveDistn2 Property

ParameterTypeIdCurtaingridUseCurveDistn2 Property

"Use Curve Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtaingridUseCurveDistn2 { get; }
Public Shared ReadOnly Property CurtaingridUseCurveDistn2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtaingridUseCurveDistn2 {
    ForgeTypeId^ get ();
}
static member CurtaingridUseCurveDistn2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurtaingridUseCurveDistU Property

ParameterTypeIdCurtaingridUseCurveDistU Property

"Use Curve Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtaingridUseCurveDistU { get; }
Public Shared ReadOnly Property CurtaingridUseCurveDistU As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtaingridUseCurveDistU {
    ForgeTypeId^ get ();
}
static member CurtaingridUseCurveDistU : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurtaingridUseCurveDistV Property

ParameterTypeIdCurtaingridUseCurveDistV Property

"Use Curve Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtaingridUseCurveDistV { get; }
Public Shared ReadOnly Property CurtaingridUseCurveDistV As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtaingridUseCurveDistV {
    ForgeTypeId^ get ();
}
static member CurtaingridUseCurveDistV : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurtaingridUseCurveDistVert Property

ParameterTypeIdCurtaingridUseCurveDistVert Property

"Use Curve Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtaingridUseCurveDistVert { get; }
Public Shared ReadOnly Property CurtaingridUseCurveDistVert As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtaingridUseCurveDistVert {
    ForgeTypeId^ get ();
}
static member CurtaingridUseCurveDistVert : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurtainVersionParam Property

ParameterTypeIdCurtainVersionParam Property

"Curtain version"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtainVersionParam { get; }
Public Shared ReadOnly Property CurtainVersionParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtainVersionParam {
    ForgeTypeId^ get ();
}
static member CurtainVersionParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurtainWallPanelHostId Property

ParameterTypeIdCurtainWallPanelHostId Property

"Host Id"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtainWallPanelHostId { get; }
Public Shared ReadOnly Property CurtainWallPanelHostId As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtainWallPanelHostId {
    ForgeTypeId^ get ();
}
static member CurtainWallPanelHostId : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurtainWallPanelsHeight Property

ParameterTypeIdCurtainWallPanelsHeight Property

"Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtainWallPanelsHeight { get; }
Public Shared ReadOnly Property CurtainWallPanelsHeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtainWallPanelsHeight {
    ForgeTypeId^ get ();
}
static member CurtainWallPanelsHeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurtainWallPanelsWidth Property

ParameterTypeIdCurtainWallPanelsWidth Property

"Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtainWallPanelsWidth { get; }
Public Shared ReadOnly Property CurtainWallPanelsWidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtainWallPanelsWidth {
    ForgeTypeId^ get ();
}
static member CurtainWallPanelsWidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurtainWallSyspanelOffset Property

ParameterTypeIdCurtainWallSyspanelOffset Property

"Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtainWallSyspanelOffset { get; }
Public Shared ReadOnly Property CurtainWallSyspanelOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtainWallSyspanelOffset {
    ForgeTypeId^ get ();
}
static member CurtainWallSyspanelOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurtainWallSyspanelThickness Property

ParameterTypeIdCurtainWallSyspanelThickness Property

"Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurtainWallSyspanelThickness { get; }
Public Shared ReadOnly Property CurtainWallSyspanelThickness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurtainWallSyspanelThickness {
    ForgeTypeId^ get ();
}
static member CurtainWallSyspanelThickness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurveBottomLevel Property

ParameterTypeIdCurveBottomLevel Property

"Bottom Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurveBottomLevel { get; }
Public Shared ReadOnly Property CurveBottomLevel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurveBottomLevel {
    ForgeTypeId^ get ();
}
static member CurveBottomLevel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurveByPointsProjectionType Property

ParameterTypeIdCurveByPointsProjectionType Property

"Projection Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurveByPointsProjectionType { get; }
Public Shared ReadOnly Property CurveByPointsProjectionType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurveByPointsProjectionType {
    ForgeTypeId^ get ();
}
static member CurveByPointsProjectionType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurveDeterminesOrientation Property

ParameterTypeIdCurveDeterminesOrientation Property

"Determines Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurveDeterminesOrientation { get; }
Public Shared ReadOnly Property CurveDeterminesOrientation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurveDeterminesOrientation {
    ForgeTypeId^ get ();
}
static member CurveDeterminesOrientation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurveEdgeOffset Property

ParameterTypeIdCurveEdgeOffset Property

"Wall offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurveEdgeOffset { get; }
Public Shared ReadOnly Property CurveEdgeOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurveEdgeOffset {
    ForgeTypeId^ get ();
}
static member CurveEdgeOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurveElemArcEndAngle Property

ParameterTypeIdCurveElemArcEndAngle Property

"Angle 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurveElemArcEndAngle { get; }
Public Shared ReadOnly Property CurveElemArcEndAngle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurveElemArcEndAngle {
    ForgeTypeId^ get ();
}
static member CurveElemArcEndAngle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurveElemArcRadius Property

ParameterTypeIdCurveElemArcRadius Property

"Radius"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurveElemArcRadius { get; }
Public Shared ReadOnly Property CurveElemArcRadius As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurveElemArcRadius {
    ForgeTypeId^ get ();
}
static member CurveElemArcRadius : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurveElemArcRange Property

ParameterTypeIdCurveElemArcRange Property

"Range"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurveElemArcRange { get; }
Public Shared ReadOnly Property CurveElemArcRange As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurveElemArcRange {
    ForgeTypeId^ get ();
}
static member CurveElemArcRange : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurveElemArcStartAngle Property

ParameterTypeIdCurveElemArcStartAngle Property

"Angle 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurveElemArcStartAngle { get; }
Public Shared ReadOnly Property CurveElemArcStartAngle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurveElemArcStartAngle {
    ForgeTypeId^ get ();
}
static member CurveElemArcStartAngle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurveElemDefinesSlope Property

ParameterTypeIdCurveElemDefinesSlope Property

"Defines Beam System Slope"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurveElemDefinesSlope { get; }
Public Shared ReadOnly Property CurveElemDefinesSlope As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurveElemDefinesSlope {
    ForgeTypeId^ get ();
}
static member CurveElemDefinesSlope : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurveElemLength Property

ParameterTypeIdCurveElemLength Property

"Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurveElemLength { get; }
Public Shared ReadOnly Property CurveElemLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurveElemLength {
    ForgeTypeId^ get ();
}
static member CurveElemLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurveElemLineAngle Property

ParameterTypeIdCurveElemLineAngle Property

"Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurveElemLineAngle { get; }
Public Shared ReadOnly Property CurveElemLineAngle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurveElemLineAngle {
    ForgeTypeId^ get ();
}
static member CurveElemLineAngle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurveHeightOffset Property

ParameterTypeIdCurveHeightOffset Property

"Offset From Base"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurveHeightOffset { get; }
Public Shared ReadOnly Property CurveHeightOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurveHeightOffset {
    ForgeTypeId^ get ();
}
static member CurveHeightOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurveIsDetail Property

ParameterTypeIdCurveIsDetail Property

"Detail Line"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurveIsDetail { get; }
Public Shared ReadOnly Property CurveIsDetail As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurveIsDetail {
    ForgeTypeId^ get ();
}
static member CurveIsDetail : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurveIsFilled Property

ParameterTypeIdCurveIsFilled Property

"Filled"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurveIsFilled { get; }
Public Shared ReadOnly Property CurveIsFilled As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurveIsFilled {
    ForgeTypeId^ get ();
}
static member CurveIsFilled : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurveIsMultilevel Property

ParameterTypeIdCurveIsMultilevel Property

"Multilevel Boundary"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurveIsMultilevel { get; }
Public Shared ReadOnly Property CurveIsMultilevel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurveIsMultilevel {
    ForgeTypeId^ get ();
}
static member CurveIsMultilevel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurveIsReferenceLine Property

ParameterTypeIdCurveIsReferenceLine Property

"Is Reference Line"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurveIsReferenceLine { get; }
Public Shared ReadOnly Property CurveIsReferenceLine As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurveIsReferenceLine {
    ForgeTypeId^ get ();
}
static member CurveIsReferenceLine : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurveIsSlopeDefining Property

ParameterTypeIdCurveIsSlopeDefining Property

"Defines Slope"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurveIsSlopeDefining { get; }
Public Shared ReadOnly Property CurveIsSlopeDefining As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurveIsSlopeDefining {
    ForgeTypeId^ get ();
}
static member CurveIsSlopeDefining : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurveLevel Property

ParameterTypeIdCurveLevel Property

"Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurveLevel { get; }
Public Shared ReadOnly Property CurveLevel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurveLevel {
    ForgeTypeId^ get ();
}
static member CurveLevel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurveNumberOfSegments Property

ParameterTypeIdCurveNumberOfSegments Property

"Number of Full Segments"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurveNumberOfSegments { get; }
Public Shared ReadOnly Property CurveNumberOfSegments As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurveNumberOfSegments {
    ForgeTypeId^ get ();
}
static member CurveNumberOfSegments : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurveParamConcreteCantilever Property

ParameterTypeIdCurveParamConcreteCantilever Property

"Concrete Cantilever"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurveParamConcreteCantilever { get; }
Public Shared ReadOnly Property CurveParamConcreteCantilever As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurveParamConcreteCantilever {
    ForgeTypeId^ get ();
}
static member CurveParamConcreteCantilever : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurveParamSteelCantilever Property

ParameterTypeIdCurveParamSteelCantilever Property

"Steel Cantilever"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurveParamSteelCantilever { get; }
Public Shared ReadOnly Property CurveParamSteelCantilever As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurveParamSteelCantilever {
    ForgeTypeId^ get ();
}
static member CurveParamSteelCantilever : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurveSupportOffset Property

ParameterTypeIdCurveSupportOffset Property

"Wall offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurveSupportOffset { get; }
Public Shared ReadOnly Property CurveSupportOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurveSupportOffset {
    ForgeTypeId^ get ();
}
static member CurveSupportOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurveTopLevel Property

ParameterTypeIdCurveTopLevel Property

"Top Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurveTopLevel { get; }
Public Shared ReadOnly Property CurveTopLevel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurveTopLevel {
    ForgeTypeId^ get ();
}
static member CurveTopLevel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurveVisibilityParam Property

ParameterTypeIdCurveVisibilityParam Property

"Visibility/Graphics Overrides"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurveVisibilityParam { get; }
Public Shared ReadOnly Property CurveVisibilityParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurveVisibilityParam {
    ForgeTypeId^ get ();
}
static member CurveVisibilityParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurveWallOffset Property

ParameterTypeIdCurveWallOffset Property

"Wall offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurveWallOffset { get; }
Public Shared ReadOnly Property CurveWallOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurveWallOffset {
    ForgeTypeId^ get ();
}
static member CurveWallOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CurveWallOffsetRoofs Property

ParameterTypeIdCurveWallOffsetRoofs Property

"Overhang"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurveWallOffsetRoofs { get; }
Public Shared ReadOnly Property CurveWallOffsetRoofs As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurveWallOffsetRoofs {
    ForgeTypeId^ get ();
}
static member CurveWallOffsetRoofs : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CustMullionThick Property

ParameterTypeIdCustMullionThick Property

"Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CustMullionThick { get; }
Public Shared ReadOnly Property CustMullionThick As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CustMullionThick {
    ForgeTypeId^ get ();
}
static member CustMullionThick : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CustMullionWidth1 Property

ParameterTypeIdCustMullionWidth1 Property

"Width on side 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CustMullionWidth1 { get; }
Public Shared ReadOnly Property CustMullionWidth1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CustMullionWidth1 {
    ForgeTypeId^ get ();
}
static member CustMullionWidth1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CustMullionWidth2 Property

ParameterTypeIdCustMullionWidth2 Property

"Width on side 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CustMullionWidth2 { get; }
Public Shared ReadOnly Property CustMullionWidth2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CustMullionWidth2 {
    ForgeTypeId^ get ();
}
static member CustMullionWidth2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CutLineAngle Property

ParameterTypeIdCutLineAngle Property

"Cut Line Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CutLineAngle { get; }
Public Shared ReadOnly Property CutLineAngle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CutLineAngle {
    ForgeTypeId^ get ();
}
static member CutLineAngle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CutLineDistance Property

ParameterTypeIdCutLineDistance Property

"Cut Line Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CutLineDistance { get; }
Public Shared ReadOnly Property CutLineDistance As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CutLineDistance {
    ForgeTypeId^ get ();
}
static member CutLineDistance : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CutLineExtension Property

ParameterTypeIdCutLineExtension Property

"Cut Line Extension"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CutLineExtension { get; }
Public Shared ReadOnly Property CutLineExtension As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CutLineExtension {
    ForgeTypeId^ get ();
}
static member CutLineExtension : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CutLineType Property

ParameterTypeIdCutLineType Property

"Cut Line Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CutLineType { get; }
Public Shared ReadOnly Property CutLineType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CutLineType {
    ForgeTypeId^ get ();
}
static member CutLineType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CutMarkSymbol Property

ParameterTypeIdCutMarkSymbol Property

"Cut Mark Symbol"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CutMarkSymbol { get; }
Public Shared ReadOnly Property CutMarkSymbol As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CutMarkSymbol {
    ForgeTypeId^ get ();
}
static member CutMarkSymbol : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CutMarkSymbolSize Property

ParameterTypeIdCutMarkSymbolSize Property

"Cut Mark Symbol Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CutMarkSymbolSize { get; }
Public Shared ReadOnly Property CutMarkSymbolSize As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CutMarkSymbolSize {
    ForgeTypeId^ get ();
}
static member CutMarkSymbolSize : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CwpAddGridPrefix Property

ParameterTypeIdCwpAddGridPrefix Property

"Add prefix to Grid Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CwpAddGridPrefix { get; }
Public Shared ReadOnly Property CwpAddGridPrefix As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CwpAddGridPrefix {
    ForgeTypeId^ get ();
}
static member CwpAddGridPrefix : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CwpAddGridSuffix Property

ParameterTypeIdCwpAddGridSuffix Property

"Add suffix to Grid Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CwpAddGridSuffix { get; }
Public Shared ReadOnly Property CwpAddGridSuffix As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CwpAddGridSuffix {
    ForgeTypeId^ get ();
}
static member CwpAddGridSuffix : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CwpAddLevelPrefix Property

ParameterTypeIdCwpAddLevelPrefix Property

"Add prefix to Level Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CwpAddLevelPrefix { get; }
Public Shared ReadOnly Property CwpAddLevelPrefix As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CwpAddLevelPrefix {
    ForgeTypeId^ get ();
}
static member CwpAddLevelPrefix : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CwpAddLevelSuffix Property

ParameterTypeIdCwpAddLevelSuffix Property

"Add suffix to Level Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CwpAddLevelSuffix { get; }
Public Shared ReadOnly Property CwpAddLevelSuffix As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CwpAddLevelSuffix {
    ForgeTypeId^ get ();
}
static member CwpAddLevelSuffix : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CwpCopyFloorInserts Property

ParameterTypeIdCwpCopyFloorInserts Property

"Copy openings/inserts"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CwpCopyFloorInserts { get; }
Public Shared ReadOnly Property CwpCopyFloorInserts As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CwpCopyFloorInserts {
    ForgeTypeId^ get ();
}
static member CwpCopyFloorInserts : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CwpCopyRoofInserts Property

ParameterTypeIdCwpCopyRoofInserts Property

"Copy openings"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CwpCopyRoofInserts { get; }
Public Shared ReadOnly Property CwpCopyRoofInserts As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CwpCopyRoofInserts {
    ForgeTypeId^ get ();
}
static member CwpCopyRoofInserts : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CwpCopyWallInserts Property

ParameterTypeIdCwpCopyWallInserts Property

"Copy windows/doors/openings"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CwpCopyWallInserts { get; }
Public Shared ReadOnly Property CwpCopyWallInserts As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CwpCopyWallInserts {
    ForgeTypeId^ get ();
}
static member CwpCopyWallInserts : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CwpLevelOffset Property

ParameterTypeIdCwpLevelOffset Property

"Offset Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CwpLevelOffset { get; }
Public Shared ReadOnly Property CwpLevelOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CwpLevelOffset {
    ForgeTypeId^ get ();
}
static member CwpLevelOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CwpLinkedRoomParams Property

ParameterTypeIdCwpLinkedRoomParams Property

"Parameters"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CwpLinkedRoomParams { get; }
Public Shared ReadOnly Property CwpLinkedRoomParams As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CwpLinkedRoomParams {
    ForgeTypeId^ get ();
}
static member CwpLinkedRoomParams : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CwpLinkedRoomPhases Property

ParameterTypeIdCwpLinkedRoomPhases Property

"Phases"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CwpLinkedRoomPhases { get; }
Public Shared ReadOnly Property CwpLinkedRoomPhases As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CwpLinkedRoomPhases {
    ForgeTypeId^ get ();
}
static member CwpLinkedRoomPhases : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CwpReuseExistingGrids Property

ParameterTypeIdCwpReuseExistingGrids Property

"Reuse matching Grids"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CwpReuseExistingGrids { get; }
Public Shared ReadOnly Property CwpReuseExistingGrids As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CwpReuseExistingGrids {
    ForgeTypeId^ get ();
}
static member CwpReuseExistingGrids : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CwpReuseExistingLevels Property

ParameterTypeIdCwpReuseExistingLevels Property

"Reuse matching Levels"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CwpReuseExistingLevels { get; }
Public Shared ReadOnly Property CwpReuseExistingLevels As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CwpReuseExistingLevels {
    ForgeTypeId^ get ();
}
static member CwpReuseExistingLevels : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CwpReuseGridsSameName Property

ParameterTypeIdCwpReuseGridsSameName Property

"Reuse Grids with the same name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CwpReuseGridsSameName { get; }
Public Shared ReadOnly Property CwpReuseGridsSameName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CwpReuseGridsSameName {
    ForgeTypeId^ get ();
}
static member CwpReuseGridsSameName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CwpReuseLevelsSameName Property

ParameterTypeIdCwpReuseLevelsSameName Property

"Reuse Levels with the same name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CwpReuseLevelsSameName { get; }
Public Shared ReadOnly Property CwpReuseLevelsSameName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CwpReuseLevelsSameName {
    ForgeTypeId^ get ();
}
static member CwpReuseLevelsSameName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.CwpSplitColumnsAtLevels Property

ParameterTypeIdCwpSplitColumnsAtLevels Property

"Split Columns by Levels"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CwpSplitColumnsAtLevels { get; }
Public Shared ReadOnly Property CwpSplitColumnsAtLevels As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CwpSplitColumnsAtLevels {
    ForgeTypeId^ get ();
}
static member CwpSplitColumnsAtLevels : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DatumBubbleEndn1 Property

ParameterTypeIdDatumBubbleEndn1 Property

"Symbol at End 1 Default"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DatumBubbleEndn1 { get; }
Public Shared ReadOnly Property DatumBubbleEndn1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DatumBubbleEndn1 {
    ForgeTypeId^ get ();
}
static member DatumBubbleEndn1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DatumBubbleEndn2 Property

ParameterTypeIdDatumBubbleEndn2 Property

"Symbol at End 2 Default"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DatumBubbleEndn2 { get; }
Public Shared ReadOnly Property DatumBubbleEndn2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DatumBubbleEndn2 {
    ForgeTypeId^ get ();
}
static member DatumBubbleEndn2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DatumBubbleLocationInElev Property

ParameterTypeIdDatumBubbleLocationInElev Property

"Non-Plan View Symbols (Default)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DatumBubbleLocationInElev { get; }
Public Shared ReadOnly Property DatumBubbleLocationInElev As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DatumBubbleLocationInElev {
    ForgeTypeId^ get ();
}
static member DatumBubbleLocationInElev : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DatumPlaneDefinesOrigin Property

ParameterTypeIdDatumPlaneDefinesOrigin Property

"Defines Origin"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DatumPlaneDefinesOrigin { get; }
Public Shared ReadOnly Property DatumPlaneDefinesOrigin As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DatumPlaneDefinesOrigin {
    ForgeTypeId^ get ();
}
static member DatumPlaneDefinesOrigin : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DatumPlaneDefinesWallClosure Property

ParameterTypeIdDatumPlaneDefinesWallClosure Property

"Wall Closure"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DatumPlaneDefinesWallClosure { get; }
Public Shared ReadOnly Property DatumPlaneDefinesWallClosure As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DatumPlaneDefinesWallClosure {
    ForgeTypeId^ get ();
}
static member DatumPlaneDefinesWallClosure : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DatumText Property

ParameterTypeIdDatumText Property

"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DatumText { get; }
Public Shared ReadOnly Property DatumText As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DatumText {
    ForgeTypeId^ get ();
}
static member DatumText : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DatumVolumeOfInterest Property

ParameterTypeIdDatumVolumeOfInterest Property

"Scope Box"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DatumVolumeOfInterest { get; }
Public Shared ReadOnly Property DatumVolumeOfInterest As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DatumVolumeOfInterest {
    ForgeTypeId^ get ();
}
static member DatumVolumeOfInterest : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DecalAttributes Property

ParameterTypeIdDecalAttributes Property

"Decal Attributes"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DecalAttributes { get; }
Public Shared ReadOnly Property DecalAttributes As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DecalAttributes {
    ForgeTypeId^ get ();
}
static member DecalAttributes : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DecalHeight Property

ParameterTypeIdDecalHeight Property

"Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DecalHeight { get; }
Public Shared ReadOnly Property DecalHeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DecalHeight {
    ForgeTypeId^ get ();
}
static member DecalHeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DecalLockProportions Property

ParameterTypeIdDecalLockProportions Property

"Lock Proportions"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DecalLockProportions { get; }
Public Shared ReadOnly Property DecalLockProportions As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DecalLockProportions {
    ForgeTypeId^ get ();
}
static member DecalLockProportions : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DecalSubcategoryId Property

ParameterTypeIdDecalSubcategoryId Property

"Subcategory"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DecalSubcategoryId { get; }
Public Shared ReadOnly Property DecalSubcategoryId As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DecalSubcategoryId {
    ForgeTypeId^ get ();
}
static member DecalSubcategoryId : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DecalWidth Property

ParameterTypeIdDecalWidth Property

"Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DecalWidth { get; }
Public Shared ReadOnly Property DecalWidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DecalWidth {
    ForgeTypeId^ get ();
}
static member DecalWidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DefaultConstructionExtWallUnderground Property

ParameterTypeIdDefaultConstructionExtWallUnderground Property

"Mass Exterior Wall - Underground"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DefaultConstructionExtWallUnderground { get; }
Public Shared ReadOnly Property DefaultConstructionExtWallUnderground As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DefaultConstructionExtWallUnderground {
    ForgeTypeId^ get ();
}
static member DefaultConstructionExtWallUnderground : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DefaultConstructionMassExteriorWall Property

ParameterTypeIdDefaultConstructionMassExteriorWall Property

"Mass Exterior Wall"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DefaultConstructionMassExteriorWall { get; }
Public Shared ReadOnly Property DefaultConstructionMassExteriorWall As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DefaultConstructionMassExteriorWall {
    ForgeTypeId^ get ();
}
static member DefaultConstructionMassExteriorWall : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DefaultConstructionMassFloor Property

ParameterTypeIdDefaultConstructionMassFloor Property

"Mass Floor"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DefaultConstructionMassFloor { get; }
Public Shared ReadOnly Property DefaultConstructionMassFloor As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DefaultConstructionMassFloor {
    ForgeTypeId^ get ();
}
static member DefaultConstructionMassFloor : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DefaultConstructionMassGlazing Property

ParameterTypeIdDefaultConstructionMassGlazing Property

"Mass Glazing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DefaultConstructionMassGlazing { get; }
Public Shared ReadOnly Property DefaultConstructionMassGlazing As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DefaultConstructionMassGlazing {
    ForgeTypeId^ get ();
}
static member DefaultConstructionMassGlazing : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DefaultConstructionMassInteriorWall Property

ParameterTypeIdDefaultConstructionMassInteriorWall Property

"Mass Interior Wall"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DefaultConstructionMassInteriorWall { get; }
Public Shared ReadOnly Property DefaultConstructionMassInteriorWall As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DefaultConstructionMassInteriorWall {
    ForgeTypeId^ get ();
}
static member DefaultConstructionMassInteriorWall : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DefaultConstructionMassOpening Property

ParameterTypeIdDefaultConstructionMassOpening Property

"Mass Opening"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DefaultConstructionMassOpening { get; }
Public Shared ReadOnly Property DefaultConstructionMassOpening As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DefaultConstructionMassOpening {
    ForgeTypeId^ get ();
}
static member DefaultConstructionMassOpening : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DefaultConstructionMassRoof Property

ParameterTypeIdDefaultConstructionMassRoof Property

"Mass Roof"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DefaultConstructionMassRoof { get; }
Public Shared ReadOnly Property DefaultConstructionMassRoof As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DefaultConstructionMassRoof {
    ForgeTypeId^ get ();
}
static member DefaultConstructionMassRoof : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DefaultConstructionMassShade Property

ParameterTypeIdDefaultConstructionMassShade Property

"Mass Shade"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DefaultConstructionMassShade { get; }
Public Shared ReadOnly Property DefaultConstructionMassShade As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DefaultConstructionMassShade {
    ForgeTypeId^ get ();
}
static member DefaultConstructionMassShade : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DefaultConstructionMassSkylight Property

ParameterTypeIdDefaultConstructionMassSkylight Property

"Mass Skylight"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DefaultConstructionMassSkylight { get; }
Public Shared ReadOnly Property DefaultConstructionMassSkylight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DefaultConstructionMassSkylight {
    ForgeTypeId^ get ();
}
static member DefaultConstructionMassSkylight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DefaultConstructionMassSlab Property

ParameterTypeIdDefaultConstructionMassSlab Property

"Mass Slab"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DefaultConstructionMassSlab { get; }
Public Shared ReadOnly Property DefaultConstructionMassSlab As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DefaultConstructionMassSlab {
    ForgeTypeId^ get ();
}
static member DefaultConstructionMassSlab : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DefaultViewTemplate Property

ParameterTypeIdDefaultViewTemplate Property

"View Template applied to new views"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DefaultViewTemplate { get; }
Public Shared ReadOnly Property DefaultViewTemplate As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DefaultViewTemplate {
    ForgeTypeId^ get ();
}
static member DefaultViewTemplate : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DefinesConstantHeight Property

ParameterTypeIdDefinesConstantHeight Property

"Defines Constant Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DefinesConstantHeight { get; }
Public Shared ReadOnly Property DefinesConstantHeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DefinesConstantHeight {
    ForgeTypeId^ get ();
}
static member DefinesConstantHeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DesignOptionId Property

ParameterTypeIdDesignOptionId Property

"Design Option"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DesignOptionId { get; }
Public Shared ReadOnly Property DesignOptionId As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DesignOptionId {
    ForgeTypeId^ get ();
}
static member DesignOptionId : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DesignOptionParam Property

ParameterTypeIdDesignOptionParam Property

"Design Option"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DesignOptionParam { get; }
Public Shared ReadOnly Property DesignOptionParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DesignOptionParam {
    ForgeTypeId^ get ();
}
static member DesignOptionParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DiameterSymbolLocation Property

ParameterTypeIdDiameterSymbolLocation Property

"Diameter Symbol Location"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DiameterSymbolLocation { get; }
Public Shared ReadOnly Property DiameterSymbolLocation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DiameterSymbolLocation {
    ForgeTypeId^ get ();
}
static member DiameterSymbolLocation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DiameterSymbolText Property

ParameterTypeIdDiameterSymbolText Property

"Diameter Symbol Text"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DiameterSymbolText { get; }
Public Shared ReadOnly Property DiameterSymbolText As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DiameterSymbolText {
    ForgeTypeId^ get ();
}
static member DiameterSymbolText : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DimDisplayEq Property

ParameterTypeIdDimDisplayEq Property

"Equality Display"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DimDisplayEq { get; }
Public Shared ReadOnly Property DimDisplayEq As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DimDisplayEq {
    ForgeTypeId^ get ();
}
static member DimDisplayEq : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DimIsreporting Property

ParameterTypeIdDimIsreporting Property

"Is Reporting"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DimIsreporting { get; }
Public Shared ReadOnly Property DimIsreporting As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DimIsreporting {
    ForgeTypeId^ get ();
}
static member DimIsreporting : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DimLabel Property

ParameterTypeIdDimLabel Property

"Label"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DimLabel { get; }
Public Shared ReadOnly Property DimLabel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DimLabel {
    ForgeTypeId^ get ();
}
static member DimLabel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DimLabelGpShow Property

ParameterTypeIdDimLabelGpShow Property

"Show Label in View"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DimLabelGpShow { get; }
Public Shared ReadOnly Property DimLabelGpShow As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DimLabelGpShow {
    ForgeTypeId^ get ();
}
static member DimLabelGpShow : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DimLabelIsInstance Property

ParameterTypeIdDimLabelIsInstance Property

"Is Instance Parameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DimLabelIsInstance { get; }
Public Shared ReadOnly Property DimLabelIsInstance As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DimLabelIsInstance {
    ForgeTypeId^ get ();
}
static member DimLabelIsInstance : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DimLeader Property

ParameterTypeIdDimLeader Property

"Leader"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DimLeader { get; }
Public Shared ReadOnly Property DimLeader As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DimLeader {
    ForgeTypeId^ get ();
}
static member DimLeader : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DimLeaderArrowhead Property

ParameterTypeIdDimLeaderArrowhead Property

"Tick Mark"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DimLeaderArrowhead { get; }
Public Shared ReadOnly Property DimLeaderArrowhead As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DimLeaderArrowhead {
    ForgeTypeId^ get ();
}
static member DimLeaderArrowhead : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DimLeaderDisplayCondition Property

ParameterTypeIdDimLeaderDisplayCondition Property

"Show Leader When Text Moves"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DimLeaderDisplayCondition { get; }
Public Shared ReadOnly Property DimLeaderDisplayCondition As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DimLeaderDisplayCondition {
    ForgeTypeId^ get ();
}
static member DimLeaderDisplayCondition : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DimLeaderShoulderLength Property

ParameterTypeIdDimLeaderShoulderLength Property

"Shoulder Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DimLeaderShoulderLength { get; }
Public Shared ReadOnly Property DimLeaderShoulderLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DimLeaderShoulderLength {
    ForgeTypeId^ get ();
}
static member DimLeaderShoulderLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DimLeaderType Property

ParameterTypeIdDimLeaderType Property

"Leader Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DimLeaderType { get; }
Public Shared ReadOnly Property DimLeaderType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DimLeaderType {
    ForgeTypeId^ get ();
}
static member DimLeaderType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DimLineExtension Property

ParameterTypeIdDimLineExtension Property

"Dimension Line Extension"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DimLineExtension { get; }
Public Shared ReadOnly Property DimLineExtension As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DimLineExtension {
    ForgeTypeId^ get ();
}
static member DimLineExtension : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DimNotModifiable Property

ParameterTypeIdDimNotModifiable Property

"Non-modifiable"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DimNotModifiable { get; }
Public Shared ReadOnly Property DimNotModifiable As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DimNotModifiable {
    ForgeTypeId^ get ();
}
static member DimNotModifiable : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DimPrefix Property

ParameterTypeIdDimPrefix Property

"Dimension Prefix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DimPrefix { get; }
Public Shared ReadOnly Property DimPrefix As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DimPrefix {
    ForgeTypeId^ get ();
}
static member DimPrefix : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DimReferenceCount Property

ParameterTypeIdDimReferenceCount Property

"Count"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DimReferenceCount { get; }
Public Shared ReadOnly Property DimReferenceCount As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DimReferenceCount {
    ForgeTypeId^ get ();
}
static member DimReferenceCount : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DimStyleAngularUnits Property

ParameterTypeIdDimStyleAngularUnits Property

"Units Format"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DimStyleAngularUnits { get; }
Public Shared ReadOnly Property DimStyleAngularUnits As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DimStyleAngularUnits {
    ForgeTypeId^ get ();
}
static member DimStyleAngularUnits : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DimStyleAngularUnitsAlt Property

ParameterTypeIdDimStyleAngularUnitsAlt Property

"Alternate Units Format"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DimStyleAngularUnitsAlt { get; }
Public Shared ReadOnly Property DimStyleAngularUnitsAlt As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DimStyleAngularUnitsAlt {
    ForgeTypeId^ get ();
}
static member DimStyleAngularUnitsAlt : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DimStyleCenterlinePattern Property

ParameterTypeIdDimStyleCenterlinePattern Property

"Centerline Pattern"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DimStyleCenterlinePattern { get; }
Public Shared ReadOnly Property DimStyleCenterlinePattern As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DimStyleCenterlinePattern {
    ForgeTypeId^ get ();
}
static member DimStyleCenterlinePattern : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DimStyleCenterlineSymbol Property

ParameterTypeIdDimStyleCenterlineSymbol Property

"Centerline Symbol"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DimStyleCenterlineSymbol { get; }
Public Shared ReadOnly Property DimStyleCenterlineSymbol As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DimStyleCenterlineSymbol {
    ForgeTypeId^ get ();
}
static member DimStyleCenterlineSymbol : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DimStyleCenterlineTickMark Property

ParameterTypeIdDimStyleCenterlineTickMark Property

"Centerline Tick Mark"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DimStyleCenterlineTickMark { get; }
Public Shared ReadOnly Property DimStyleCenterlineTickMark As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DimStyleCenterlineTickMark {
    ForgeTypeId^ get ();
}
static member DimStyleCenterlineTickMark : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DimStyleDimLineSnapDist Property

ParameterTypeIdDimStyleDimLineSnapDist Property

"Dimension Line Snap Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DimStyleDimLineSnapDist { get; }
Public Shared ReadOnly Property DimStyleDimLineSnapDist As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DimStyleDimLineSnapDist {
    ForgeTypeId^ get ();
}
static member DimStyleDimLineSnapDist : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DimStyleFlippedDimLineExtension Property

ParameterTypeIdDimStyleFlippedDimLineExtension Property

"Flipped Dimension Line Extension"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DimStyleFlippedDimLineExtension { get; }
Public Shared ReadOnly Property DimStyleFlippedDimLineExtension As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DimStyleFlippedDimLineExtension {
    ForgeTypeId^ get ();
}
static member DimStyleFlippedDimLineExtension : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DimStyleInteriorTickMark Property

ParameterTypeIdDimStyleInteriorTickMark Property

"Interior Tick Mark"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DimStyleInteriorTickMark { get; }
Public Shared ReadOnly Property DimStyleInteriorTickMark As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DimStyleInteriorTickMark {
    ForgeTypeId^ get ();
}
static member DimStyleInteriorTickMark : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DimStyleLeaderTickMark Property

ParameterTypeIdDimStyleLeaderTickMark Property

"Leader Tick Mark"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DimStyleLeaderTickMark { get; }
Public Shared ReadOnly Property DimStyleLeaderTickMark As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DimStyleLeaderTickMark {
    ForgeTypeId^ get ();
}
static member DimStyleLeaderTickMark : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DimStyleLinearUnits Property

ParameterTypeIdDimStyleLinearUnits Property

"Units Format"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DimStyleLinearUnits { get; }
Public Shared ReadOnly Property DimStyleLinearUnits As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DimStyleLinearUnits {
    ForgeTypeId^ get ();
}
static member DimStyleLinearUnits : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DimStyleLinearUnitsAlt Property

ParameterTypeIdDimStyleLinearUnitsAlt Property

"Alternate Units Format"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DimStyleLinearUnitsAlt { get; }
Public Shared ReadOnly Property DimStyleLinearUnitsAlt As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DimStyleLinearUnitsAlt {
    ForgeTypeId^ get ();
}
static member DimStyleLinearUnitsAlt : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DimStyleReadConvention Property

ParameterTypeIdDimStyleReadConvention Property

"Read Convention"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DimStyleReadConvention { get; }
Public Shared ReadOnly Property DimStyleReadConvention As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DimStyleReadConvention {
    ForgeTypeId^ get ();
}
static member DimStyleReadConvention : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DimStyleShowOpeningHt Property

ParameterTypeIdDimStyleShowOpeningHt Property

"Show Opening Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DimStyleShowOpeningHt { get; }
Public Shared ReadOnly Property DimStyleShowOpeningHt As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DimStyleShowOpeningHt {
    ForgeTypeId^ get ();
}
static member DimStyleShowOpeningHt : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DimStyleSuppressSpaces Property

ParameterTypeIdDimStyleSuppressSpaces Property

"Suppress Spaces"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DimStyleSuppressSpaces { get; }
Public Shared ReadOnly Property DimStyleSuppressSpaces As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DimStyleSuppressSpaces {
    ForgeTypeId^ get ();
}
static member DimStyleSuppressSpaces : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DimSuffix Property

ParameterTypeIdDimSuffix Property

"Dimension Suffix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DimSuffix { get; }
Public Shared ReadOnly Property DimSuffix As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DimSuffix {
    ForgeTypeId^ get ();
}
static member DimSuffix : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DimTextBackground Property

ParameterTypeIdDimTextBackground Property

"Text Background"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DimTextBackground { get; }
Public Shared ReadOnly Property DimTextBackground As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DimTextBackground {
    ForgeTypeId^ get ();
}
static member DimTextBackground : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DimTextLocationForLeader Property

ParameterTypeIdDimTextLocationForLeader Property

"Text Location"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DimTextLocationForLeader { get; }
Public Shared ReadOnly Property DimTextLocationForLeader As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DimTextLocationForLeader {
    ForgeTypeId^ get ();
}
static member DimTextLocationForLeader : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DimToInserts Property

ParameterTypeIdDimToInserts Property

"Dimension To Openings"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DimToInserts { get; }
Public Shared ReadOnly Property DimToInserts As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DimToInserts {
    ForgeTypeId^ get ();
}
static member DimToInserts : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DimToInsertType Property

ParameterTypeIdDimToInsertType Property

"Dimension To Opening Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DimToInsertType { get; }
Public Shared ReadOnly Property DimToInsertType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DimToInsertType {
    ForgeTypeId^ get ();
}
static member DimToInsertType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DimToIntersectingGrids Property

ParameterTypeIdDimToIntersectingGrids Property

"Dimension To Intersecting Grids"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DimToIntersectingGrids { get; }
Public Shared ReadOnly Property DimToIntersectingGrids As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DimToIntersectingGrids {
    ForgeTypeId^ get ();
}
static member DimToIntersectingGrids : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DimToIntersectingWalls Property

ParameterTypeIdDimToIntersectingWalls Property

"Dimension To Intersecting Walls"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DimToIntersectingWalls { get; }
Public Shared ReadOnly Property DimToIntersectingWalls As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DimToIntersectingWalls {
    ForgeTypeId^ get ();
}
static member DimToIntersectingWalls : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DimTotalLength Property

ParameterTypeIdDimTotalLength Property

"Total Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DimTotalLength { get; }
Public Shared ReadOnly Property DimTotalLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DimTotalLength {
    ForgeTypeId^ get ();
}
static member DimTotalLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DimValueAngle Property

ParameterTypeIdDimValueAngle Property

"Value"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DimValueAngle { get; }
Public Shared ReadOnly Property DimValueAngle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DimValueAngle {
    ForgeTypeId^ get ();
}
static member DimValueAngle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DimValueLength Property

ParameterTypeIdDimValueLength Property

"Value"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DimValueLength { get; }
Public Shared ReadOnly Property DimValueLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DimValueLength {
    ForgeTypeId^ get ();
}
static member DimValueLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DimWitnsLineCntrl Property

ParameterTypeIdDimWitnsLineCntrl Property

"Witness Line Control"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DimWitnsLineCntrl { get; }
Public Shared ReadOnly Property DimWitnsLineCntrl As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DimWitnsLineCntrl {
    ForgeTypeId^ get ();
}
static member DimWitnsLineCntrl : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DimWitnsLineExtensionBelow Property

ParameterTypeIdDimWitnsLineExtensionBelow Property

"Witness Line Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DimWitnsLineExtensionBelow { get; }
Public Shared ReadOnly Property DimWitnsLineExtensionBelow As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DimWitnsLineExtensionBelow {
    ForgeTypeId^ get ();
}
static member DimWitnsLineExtensionBelow : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.Directcontext3dApplicationId Property

ParameterTypeIdDirectcontext3dApplicationId Property

"ApplicationId"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Directcontext3dApplicationId { get; }
Public Shared ReadOnly Property Directcontext3dApplicationId As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Directcontext3dApplicationId {
    ForgeTypeId^ get ();
}
static member Directcontext3dApplicationId : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.Directcontext3dLoaded Property

ParameterTypeIdDirectcontext3dLoaded Property

"Loaded"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Directcontext3dLoaded { get; }
Public Shared ReadOnly Property Directcontext3dLoaded As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Directcontext3dLoaded {
    ForgeTypeId^ get ();
}
static member Directcontext3dLoaded : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.Directcontext3dName Property

ParameterTypeIdDirectcontext3dName Property

"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Directcontext3dName { get; }
Public Shared ReadOnly Property Directcontext3dName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Directcontext3dName {
    ForgeTypeId^ get ();
}
static member Directcontext3dName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.Directcontext3dServerId Property

ParameterTypeIdDirectcontext3dServerId Property

"ServerId"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Directcontext3dServerId { get; }
Public Shared ReadOnly Property Directcontext3dServerId As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Directcontext3dServerId {
    ForgeTypeId^ get ();
}
static member Directcontext3dServerId : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.Directcontext3dSourceId Property

ParameterTypeIdDirectcontext3dSourceId Property

"Path"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Directcontext3dSourceId { get; }
Public Shared ReadOnly Property Directcontext3dSourceId As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Directcontext3dSourceId {
    ForgeTypeId^ get ();
}
static member Directcontext3dSourceId : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DisplacedElementDisplacementX Property

ParameterTypeIdDisplacedElementDisplacementX Property

"X Displacement"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DisplacedElementDisplacementX { get; }
Public Shared ReadOnly Property DisplacedElementDisplacementX As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DisplacedElementDisplacementX {
    ForgeTypeId^ get ();
}
static member DisplacedElementDisplacementX : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DisplacedElementDisplacementY Property

ParameterTypeIdDisplacedElementDisplacementY Property

"Y Displacement"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DisplacedElementDisplacementY { get; }
Public Shared ReadOnly Property DisplacedElementDisplacementY As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DisplacedElementDisplacementY {
    ForgeTypeId^ get ();
}
static member DisplacedElementDisplacementY : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DisplacedElementDisplacementZ Property

ParameterTypeIdDisplacedElementDisplacementZ Property

"Z Displacement"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DisplacedElementDisplacementZ { get; }
Public Shared ReadOnly Property DisplacedElementDisplacementZ As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DisplacedElementDisplacementZ {
    ForgeTypeId^ get ();
}
static member DisplacedElementDisplacementZ : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DisplacementPathDepth Property

ParameterTypeIdDisplacementPathDepth Property

"Depth"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DisplacementPathDepth { get; }
Public Shared ReadOnly Property DisplacementPathDepth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DisplacementPathDepth {
    ForgeTypeId^ get ();
}
static member DisplacementPathDepth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DisplacementPathStyle Property

ParameterTypeIdDisplacementPathStyle Property

"Style"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DisplacementPathStyle { get; }
Public Shared ReadOnly Property DisplacementPathStyle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DisplacementPathStyle {
    ForgeTypeId^ get ();
}
static member DisplacementPathStyle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DistanceToCutMark Property

ParameterTypeIdDistanceToCutMark Property

"Distance to Cut Mark"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DistanceToCutMark { get; }
Public Shared ReadOnly Property DistanceToCutMark As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DistanceToCutMark {
    ForgeTypeId^ get ();
}
static member DistanceToCutMark : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedpathBeginningIndent Property

ParameterTypeIdDividedpathBeginningIndent Property

"Beginning Indent"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedpathBeginningIndent { get; }
Public Shared ReadOnly Property DividedpathBeginningIndent As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedpathBeginningIndent {
    ForgeTypeId^ get ();
}
static member DividedpathBeginningIndent : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedpathDisplayNodeNumbers Property

ParameterTypeIdDividedpathDisplayNodeNumbers Property

"Show Node Numbers"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedpathDisplayNodeNumbers { get; }
Public Shared ReadOnly Property DividedpathDisplayNodeNumbers As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedpathDisplayNodeNumbers {
    ForgeTypeId^ get ();
}
static member DividedpathDisplayNodeNumbers : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedpathDisplayNodes Property

ParameterTypeIdDividedpathDisplayNodes Property

"Display Nodes"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedpathDisplayNodes { get; }
Public Shared ReadOnly Property DividedpathDisplayNodes As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedpathDisplayNodes {
    ForgeTypeId^ get ();
}
static member DividedpathDisplayNodes : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedpathDisplayReferenceCurves Property

ParameterTypeIdDividedpathDisplayReferenceCurves Property

"Display Path"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedpathDisplayReferenceCurves { get; }
Public Shared ReadOnly Property DividedpathDisplayReferenceCurves As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedpathDisplayReferenceCurves {
    ForgeTypeId^ get ();
}
static member DividedpathDisplayReferenceCurves : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedpathDistance Property

ParameterTypeIdDividedpathDistance Property

"Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedpathDistance { get; }
Public Shared ReadOnly Property DividedpathDistance As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedpathDistance {
    ForgeTypeId^ get ();
}
static member DividedpathDistance : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedpathEndIndent Property

ParameterTypeIdDividedpathEndIndent Property

"End Indent"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedpathEndIndent { get; }
Public Shared ReadOnly Property DividedpathEndIndent As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedpathEndIndent {
    ForgeTypeId^ get ();
}
static member DividedpathEndIndent : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedpathFlipDirection Property

ParameterTypeIdDividedpathFlipDirection Property

"Flip Direction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedpathFlipDirection { get; }
Public Shared ReadOnly Property DividedpathFlipDirection As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedpathFlipDirection {
    ForgeTypeId^ get ();
}
static member DividedpathFlipDirection : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedpathJustification Property

ParameterTypeIdDividedpathJustification Property

"Justification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedpathJustification { get; }
Public Shared ReadOnly Property DividedpathJustification As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedpathJustification {
    ForgeTypeId^ get ();
}
static member DividedpathJustification : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedpathLayout Property

ParameterTypeIdDividedpathLayout Property

"Layout"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedpathLayout { get; }
Public Shared ReadOnly Property DividedpathLayout As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedpathLayout {
    ForgeTypeId^ get ();
}
static member DividedpathLayout : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedpathLayoutFixedNumPoint Property

ParameterTypeIdDividedpathLayoutFixedNumPoint Property

"Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedpathLayoutFixedNumPoint { get; }
Public Shared ReadOnly Property DividedpathLayoutFixedNumPoint As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedpathLayoutFixedNumPoint {
    ForgeTypeId^ get ();
}
static member DividedpathLayoutFixedNumPoint : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedpathMaxDistance Property

ParameterTypeIdDividedpathMaxDistance Property

"Maximum Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedpathMaxDistance { get; }
Public Shared ReadOnly Property DividedpathMaxDistance As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedpathMaxDistance {
    ForgeTypeId^ get ();
}
static member DividedpathMaxDistance : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedpathMeasurementType Property

ParameterTypeIdDividedpathMeasurementType Property

"Measurement Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedpathMeasurementType { get; }
Public Shared ReadOnly Property DividedpathMeasurementType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedpathMeasurementType {
    ForgeTypeId^ get ();
}
static member DividedpathMeasurementType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedpathMergedPointNum Property

ParameterTypeIdDividedpathMergedPointNum Property

"Total Number of Nodes"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedpathMergedPointNum { get; }
Public Shared ReadOnly Property DividedpathMergedPointNum As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedpathMergedPointNum {
    ForgeTypeId^ get ();
}
static member DividedpathMergedPointNum : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedpathMinDistance Property

ParameterTypeIdDividedpathMinDistance Property

"Minimum Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedpathMinDistance { get; }
Public Shared ReadOnly Property DividedpathMinDistance As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedpathMinDistance {
    ForgeTypeId^ get ();
}
static member DividedpathMinDistance : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedpathTotalPathLength Property

ParameterTypeIdDividedpathTotalPathLength Property

"Path Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedpathTotalPathLength { get; }
Public Shared ReadOnly Property DividedpathTotalPathLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedpathTotalPathLength {
    ForgeTypeId^ get ();
}
static member DividedpathTotalPathLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedSurfaceAllGridRotation Property

ParameterTypeIdDividedSurfaceAllGridRotation Property

"All Grid Rotation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedSurfaceAllGridRotation { get; }
Public Shared ReadOnly Property DividedSurfaceAllGridRotation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedSurfaceAllGridRotation {
    ForgeTypeId^ get ();
}
static member DividedSurfaceAllGridRotation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedSurfaceAllPoints Property

ParameterTypeIdDividedSurfaceAllPoints Property

"Show all points"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedSurfaceAllPoints { get; }
Public Shared ReadOnly Property DividedSurfaceAllPoints As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedSurfaceAllPoints {
    ForgeTypeId^ get ();
}
static member DividedSurfaceAllPoints : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedSurfaceComponentTrimType Property

ParameterTypeIdDividedSurfaceComponentTrimType Property

"Component Trim"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedSurfaceComponentTrimType { get; }
Public Shared ReadOnly Property DividedSurfaceComponentTrimType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedSurfaceComponentTrimType {
    ForgeTypeId^ get ();
}
static member DividedSurfaceComponentTrimType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedSurfaceCoverFaceCompletely Property

ParameterTypeIdDividedSurfaceCoverFaceCompletely Property

"Cover face completely"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedSurfaceCoverFaceCompletely { get; }
Public Shared ReadOnly Property DividedSurfaceCoverFaceCompletely As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedSurfaceCoverFaceCompletely {
    ForgeTypeId^ get ();
}
static member DividedSurfaceCoverFaceCompletely : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedSurfaceDisplayComponents Property

ParameterTypeIdDividedSurfaceDisplayComponents Property

"Components"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedSurfaceDisplayComponents { get; }
Public Shared ReadOnly Property DividedSurfaceDisplayComponents As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedSurfaceDisplayComponents {
    ForgeTypeId^ get ();
}
static member DividedSurfaceDisplayComponents : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedSurfaceDisplayDiscardeddivisionlines Property

ParameterTypeIdDividedSurfaceDisplayDiscardeddivisionlines Property

"Discarded Division Lines"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedSurfaceDisplayDiscardeddivisionlines { get; }
Public Shared ReadOnly Property DividedSurfaceDisplayDiscardeddivisionlines As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedSurfaceDisplayDiscardeddivisionlines {
    ForgeTypeId^ get ();
}
static member DividedSurfaceDisplayDiscardeddivisionlines : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedSurfaceDisplayGridlines Property

ParameterTypeIdDividedSurfaceDisplayGridlines Property

"Gridlines"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedSurfaceDisplayGridlines { get; }
Public Shared ReadOnly Property DividedSurfaceDisplayGridlines As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedSurfaceDisplayGridlines {
    ForgeTypeId^ get ();
}
static member DividedSurfaceDisplayGridlines : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedSurfaceDisplayNodes Property

ParameterTypeIdDividedSurfaceDisplayNodes Property

"Nodes"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedSurfaceDisplayNodes { get; }
Public Shared ReadOnly Property DividedSurfaceDisplayNodes As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedSurfaceDisplayNodes {
    ForgeTypeId^ get ();
}
static member DividedSurfaceDisplayNodes : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedSurfaceDisplayOriginalSurface Property

ParameterTypeIdDividedSurfaceDisplayOriginalSurface Property

"Surface"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedSurfaceDisplayOriginalSurface { get; }
Public Shared ReadOnly Property DividedSurfaceDisplayOriginalSurface As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedSurfaceDisplayOriginalSurface {
    ForgeTypeId^ get ();
}
static member DividedSurfaceDisplayOriginalSurface : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedSurfaceDisplayPatternFill Property

ParameterTypeIdDividedSurfaceDisplayPatternFill Property

"Pattern Fill"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedSurfaceDisplayPatternFill { get; }
Public Shared ReadOnly Property DividedSurfaceDisplayPatternFill As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedSurfaceDisplayPatternFill {
    ForgeTypeId^ get ();
}
static member DividedSurfaceDisplayPatternFill : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedSurfaceDisplayPatternLines Property

ParameterTypeIdDividedSurfaceDisplayPatternLines Property

"Pattern Lines"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedSurfaceDisplayPatternLines { get; }
Public Shared ReadOnly Property DividedSurfaceDisplayPatternLines As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedSurfaceDisplayPatternLines {
    ForgeTypeId^ get ();
}
static member DividedSurfaceDisplayPatternLines : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedSurfaceDisplaySurfaceOption Property

ParameterTypeIdDividedSurfaceDisplaySurfaceOption Property

"Display Surface Option"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedSurfaceDisplaySurfaceOption { get; }
Public Shared ReadOnly Property DividedSurfaceDisplaySurfaceOption As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedSurfaceDisplaySurfaceOption {
    ForgeTypeId^ get ();
}
static member DividedSurfaceDisplaySurfaceOption : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedSurfaceEdgeNumber Property

ParameterTypeIdDividedSurfaceEdgeNumber Property

"Edge number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedSurfaceEdgeNumber { get; }
Public Shared ReadOnly Property DividedSurfaceEdgeNumber As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedSurfaceEdgeNumber {
    ForgeTypeId^ get ();
}
static member DividedSurfaceEdgeNumber : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedSurfaceFacetNumber Property

ParameterTypeIdDividedSurfaceFacetNumber Property

"Facet number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedSurfaceFacetNumber { get; }
Public Shared ReadOnly Property DividedSurfaceFacetNumber As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedSurfaceFacetNumber {
    ForgeTypeId^ get ();
}
static member DividedSurfaceFacetNumber : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedSurfaceGridlinesStyle Property

ParameterTypeIdDividedSurfaceGridlinesStyle Property

"Gridlines Style"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedSurfaceGridlinesStyle { get; }
Public Shared ReadOnly Property DividedSurfaceGridlinesStyle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedSurfaceGridlinesStyle {
    ForgeTypeId^ get ();
}
static member DividedSurfaceGridlinesStyle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedSurfaceGridOptionParamn1 Property

ParameterTypeIdDividedSurfaceGridOptionParamn1 Property

"Option 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedSurfaceGridOptionParamn1 { get; }
Public Shared ReadOnly Property DividedSurfaceGridOptionParamn1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedSurfaceGridOptionParamn1 {
    ForgeTypeId^ get ();
}
static member DividedSurfaceGridOptionParamn1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedSurfaceGridOptionParamn2 Property

ParameterTypeIdDividedSurfaceGridOptionParamn2 Property

"Option 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedSurfaceGridOptionParamn2 { get; }
Public Shared ReadOnly Property DividedSurfaceGridOptionParamn2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedSurfaceGridOptionParamn2 {
    ForgeTypeId^ get ();
}
static member DividedSurfaceGridOptionParamn2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedSurfaceOffsetFromSurface Property

ParameterTypeIdDividedSurfaceOffsetFromSurface Property

"Offset from surface"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedSurfaceOffsetFromSurface { get; }
Public Shared ReadOnly Property DividedSurfaceOffsetFromSurface As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedSurfaceOffsetFromSurface {
    ForgeTypeId^ get ();
}
static member DividedSurfaceOffsetFromSurface : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedSurfaceOriginalSurfaceMaterial Property

ParameterTypeIdDividedSurfaceOriginalSurfaceMaterial Property

"Surface Material"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedSurfaceOriginalSurfaceMaterial { get; }
Public Shared ReadOnly Property DividedSurfaceOriginalSurfaceMaterial As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedSurfaceOriginalSurfaceMaterial {
    ForgeTypeId^ get ();
}
static member DividedSurfaceOriginalSurfaceMaterial : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedSurfacePattern Property

ParameterTypeIdDividedSurfacePattern Property

"Tile Pattern"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedSurfacePattern { get; }
Public Shared ReadOnly Property DividedSurfacePattern As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedSurfacePattern {
    ForgeTypeId^ get ();
}
static member DividedSurfacePattern : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedSurfacePatternFillMaterial Property

ParameterTypeIdDividedSurfacePatternFillMaterial Property

"Pattern Fill Material"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedSurfacePatternFillMaterial { get; }
Public Shared ReadOnly Property DividedSurfacePatternFillMaterial As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedSurfacePatternFillMaterial {
    ForgeTypeId^ get ();
}
static member DividedSurfacePatternFillMaterial : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedSurfacePatternFlip Property

ParameterTypeIdDividedSurfacePatternFlip Property

"Component Flip"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedSurfacePatternFlip { get; }
Public Shared ReadOnly Property DividedSurfacePatternFlip As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedSurfacePatternFlip {
    ForgeTypeId^ get ();
}
static member DividedSurfacePatternFlip : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedSurfacePatternIndentn1 Property

ParameterTypeIdDividedSurfacePatternIndentn1 Property

"Indent 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedSurfacePatternIndentn1 { get; }
Public Shared ReadOnly Property DividedSurfacePatternIndentn1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedSurfacePatternIndentn1 {
    ForgeTypeId^ get ();
}
static member DividedSurfacePatternIndentn1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedSurfacePatternIndentn2 Property

ParameterTypeIdDividedSurfacePatternIndentn2 Property

"Indent 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedSurfacePatternIndentn2 { get; }
Public Shared ReadOnly Property DividedSurfacePatternIndentn2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedSurfacePatternIndentn2 {
    ForgeTypeId^ get ();
}
static member DividedSurfacePatternIndentn2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedSurfacePatternLinesStyle Property

ParameterTypeIdDividedSurfacePatternLinesStyle Property

"Pattern Lines Style"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedSurfacePatternLinesStyle { get; }
Public Shared ReadOnly Property DividedSurfacePatternLinesStyle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedSurfacePatternLinesStyle {
    ForgeTypeId^ get ();
}
static member DividedSurfacePatternLinesStyle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedSurfacePatternMirror Property

ParameterTypeIdDividedSurfacePatternMirror Property

"Component Mirror"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedSurfacePatternMirror { get; }
Public Shared ReadOnly Property DividedSurfacePatternMirror As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedSurfacePatternMirror {
    ForgeTypeId^ get ();
}
static member DividedSurfacePatternMirror : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedSurfacePatternRotationAngle Property

ParameterTypeIdDividedSurfacePatternRotationAngle Property

"Component Rotation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedSurfacePatternRotationAngle { get; }
Public Shared ReadOnly Property DividedSurfacePatternRotationAngle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedSurfacePatternRotationAngle {
    ForgeTypeId^ get ();
}
static member DividedSurfacePatternRotationAngle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedSurfacePointNumber Property

ParameterTypeIdDividedSurfacePointNumber Property

"Point number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedSurfacePointNumber { get; }
Public Shared ReadOnly Property DividedSurfacePointNumber As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedSurfacePointNumber {
    ForgeTypeId^ get ();
}
static member DividedSurfacePointNumber : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedSurfaceRule1Suspension Property

ParameterTypeIdDividedSurfaceRule1Suspension Property

"Is grid 1 suspended?"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedSurfaceRule1Suspension { get; }
Public Shared ReadOnly Property DividedSurfaceRule1Suspension As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedSurfaceRule1Suspension {
    ForgeTypeId^ get ();
}
static member DividedSurfaceRule1Suspension : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedSurfaceRule2Suspension Property

ParameterTypeIdDividedSurfaceRule2Suspension Property

"Is grid 2 suspended?"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedSurfaceRule2Suspension { get; }
Public Shared ReadOnly Property DividedSurfaceRule2Suspension As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedSurfaceRule2Suspension {
    ForgeTypeId^ get ();
}
static member DividedSurfaceRule2Suspension : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedSurfaceSurfaceArea Property

ParameterTypeIdDividedSurfaceSurfaceArea Property

"Divided Surface Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedSurfaceSurfaceArea { get; }
Public Shared ReadOnly Property DividedSurfaceSurfaceArea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedSurfaceSurfaceArea {
    ForgeTypeId^ get ();
}
static member DividedSurfaceSurfaceArea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedSurfaceTileBorder Property

ParameterTypeIdDividedSurfaceTileBorder Property

"Border Tile"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedSurfaceTileBorder { get; }
Public Shared ReadOnly Property DividedSurfaceTileBorder As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedSurfaceTileBorder {
    ForgeTypeId^ get ();
}
static member DividedSurfaceTileBorder : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DividedSurfaceTotalEdgeLength Property

ParameterTypeIdDividedSurfaceTotalEdgeLength Property

"Total edge length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DividedSurfaceTotalEdgeLength { get; }
Public Shared ReadOnly Property DividedSurfaceTotalEdgeLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DividedSurfaceTotalEdgeLength {
    ForgeTypeId^ get ();
}
static member DividedSurfaceTotalEdgeLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DivisionPattern Property

ParameterTypeIdDivisionPattern Property

"Division Pattern"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DivisionPattern { get; }
Public Shared ReadOnly Property DivisionPattern As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DivisionPattern {
    ForgeTypeId^ get ();
}
static member DivisionPattern : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DivisionProfileWidth Property

ParameterTypeIdDivisionProfileWidth Property

"Width": Width

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DivisionProfileWidth { get; }
Public Shared ReadOnly Property DivisionProfileWidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DivisionProfileWidth {
    ForgeTypeId^ get ();
}
static member DivisionProfileWidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DivisionRuleParam Property

ParameterTypeIdDivisionRuleParam Property

"Division Rule"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DivisionRuleParam { get; }
Public Shared ReadOnly Property DivisionRuleParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DivisionRuleParam {
    ForgeTypeId^ get ();
}
static member DivisionRuleParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DivisionSketchCurveDivisionParamsOverrideParam Property

ParameterTypeIdDivisionSketchCurveDivisionParamsOverrideParam Property

"Profile Override"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DivisionSketchCurveDivisionParamsOverrideParam { get; }
Public Shared ReadOnly Property DivisionSketchCurveDivisionParamsOverrideParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DivisionSketchCurveDivisionParamsOverrideParam {
    ForgeTypeId^ get ();
}
static member DivisionSketchCurveDivisionParamsOverrideParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DivisionSketchCurveExtentdToSilhParam Property

ParameterTypeIdDivisionSketchCurveExtentdToSilhParam Property

"Extend to Silhouette"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DivisionSketchCurveExtentdToSilhParam { get; }
Public Shared ReadOnly Property DivisionSketchCurveExtentdToSilhParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DivisionSketchCurveExtentdToSilhParam {
    ForgeTypeId^ get ();
}
static member DivisionSketchCurveExtentdToSilhParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DoorConstructionType Property

ParameterTypeIdDoorConstructionType Property

"Construction Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DoorConstructionType { get; }
Public Shared ReadOnly Property DoorConstructionType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DoorConstructionType {
    ForgeTypeId^ get ();
}
static member DoorConstructionType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DoorCost Property

ParameterTypeIdDoorCost Property

"Cost"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DoorCost { get; }
Public Shared ReadOnly Property DoorCost As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DoorCost {
    ForgeTypeId^ get ();
}
static member DoorCost : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DoorEvacuationExitType Property

ParameterTypeIdDoorEvacuationExitType Property

"Exit Access"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DoorEvacuationExitType { get; }
Public Shared ReadOnly Property DoorEvacuationExitType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DoorEvacuationExitType {
    ForgeTypeId^ get ();
}
static member DoorEvacuationExitType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DoorFinish Property

ParameterTypeIdDoorFinish Property

"Finish"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DoorFinish { get; }
Public Shared ReadOnly Property DoorFinish As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DoorFinish {
    ForgeTypeId^ get ();
}
static member DoorFinish : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DoorFrameMaterial Property

ParameterTypeIdDoorFrameMaterial Property

"Frame Material"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DoorFrameMaterial { get; }
Public Shared ReadOnly Property DoorFrameMaterial As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DoorFrameMaterial {
    ForgeTypeId^ get ();
}
static member DoorFrameMaterial : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DoorFrameType Property

ParameterTypeIdDoorFrameType Property

"Frame Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DoorFrameType { get; }
Public Shared ReadOnly Property DoorFrameType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DoorFrameType {
    ForgeTypeId^ get ();
}
static member DoorFrameType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DoorNumber Property

ParameterTypeIdDoorNumber Property

"Mark"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DoorNumber { get; }
Public Shared ReadOnly Property DoorNumber As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DoorNumber {
    ForgeTypeId^ get ();
}
static member DoorNumber : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DoorOperationType Property

ParameterTypeIdDoorOperationType Property

"Operation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DoorOperationType { get; }
Public Shared ReadOnly Property DoorOperationType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DoorOperationType {
    ForgeTypeId^ get ();
}
static member DoorOperationType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DpartAreaComputed Property

ParameterTypeIdDpartAreaComputed Property

"Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DpartAreaComputed { get; }
Public Shared ReadOnly Property DpartAreaComputed As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DpartAreaComputed {
    ForgeTypeId^ get ();
}
static member DpartAreaComputed : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DpartBaseLevel Property

ParameterTypeIdDpartBaseLevel Property

"Base Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DpartBaseLevel { get; }
Public Shared ReadOnly Property DpartBaseLevel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DpartBaseLevel {
    ForgeTypeId^ get ();
}
static member DpartBaseLevel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DpartBaseLevelByOriginal Property

ParameterTypeIdDpartBaseLevelByOriginal Property

"Base Level By Original"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DpartBaseLevelByOriginal { get; }
Public Shared ReadOnly Property DpartBaseLevelByOriginal As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DpartBaseLevelByOriginal {
    ForgeTypeId^ get ();
}
static member DpartBaseLevelByOriginal : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DpartCanHostRebar Property

ParameterTypeIdDpartCanHostRebar Property

"Can host rebar"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DpartCanHostRebar { get; }
Public Shared ReadOnly Property DpartCanHostRebar As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DpartCanHostRebar {
    ForgeTypeId^ get ();
}
static member DpartCanHostRebar : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DpartExcluded Property

ParameterTypeIdDpartExcluded Property

"Excluded"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DpartExcluded { get; }
Public Shared ReadOnly Property DpartExcluded As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DpartExcluded {
    ForgeTypeId^ get ();
}
static member DpartExcluded : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DpartHeightComputed Property

ParameterTypeIdDpartHeightComputed Property

"Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DpartHeightComputed { get; }
Public Shared ReadOnly Property DpartHeightComputed As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DpartHeightComputed {
    ForgeTypeId^ get ();
}
static member DpartHeightComputed : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DpartLayerConstruction Property

ParameterTypeIdDpartLayerConstruction Property

"Construction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DpartLayerConstruction { get; }
Public Shared ReadOnly Property DpartLayerConstruction As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DpartLayerConstruction {
    ForgeTypeId^ get ();
}
static member DpartLayerConstruction : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DpartLayerFunction Property

ParameterTypeIdDpartLayerFunction Property

"Layer Function"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DpartLayerFunction { get; }
Public Shared ReadOnly Property DpartLayerFunction As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DpartLayerFunction {
    ForgeTypeId^ get ();
}
static member DpartLayerFunction : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DpartLayerIndex Property

ParameterTypeIdDpartLayerIndex Property

"Layer Index"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DpartLayerIndex { get; }
Public Shared ReadOnly Property DpartLayerIndex As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DpartLayerIndex {
    ForgeTypeId^ get ();
}
static member DpartLayerIndex : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DpartLayerWidth Property

ParameterTypeIdDpartLayerWidth Property

"Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DpartLayerWidth { get; }
Public Shared ReadOnly Property DpartLayerWidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DpartLayerWidth {
    ForgeTypeId^ get ();
}
static member DpartLayerWidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DpartLengthComputed Property

ParameterTypeIdDpartLengthComputed Property

"Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DpartLengthComputed { get; }
Public Shared ReadOnly Property DpartLengthComputed As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DpartLengthComputed {
    ForgeTypeId^ get ();
}
static member DpartLengthComputed : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DpartMaterialByOriginal Property

ParameterTypeIdDpartMaterialByOriginal Property

"Material By Original"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DpartMaterialByOriginal { get; }
Public Shared ReadOnly Property DpartMaterialByOriginal As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DpartMaterialByOriginal {
    ForgeTypeId^ get ();
}
static member DpartMaterialByOriginal : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DpartMaterialIdParam Property

ParameterTypeIdDpartMaterialIdParam Property

"Material"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DpartMaterialIdParam { get; }
Public Shared ReadOnly Property DpartMaterialIdParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DpartMaterialIdParam {
    ForgeTypeId^ get ();
}
static member DpartMaterialIdParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DpartOriginalCategory Property

ParameterTypeIdDpartOriginalCategory Property

"Original Category"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DpartOriginalCategory { get; }
Public Shared ReadOnly Property DpartOriginalCategory As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DpartOriginalCategory {
    ForgeTypeId^ get ();
}
static member DpartOriginalCategory : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DpartOriginalCategoryId Property

ParameterTypeIdDpartOriginalCategoryId Property

"Original Category"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DpartOriginalCategoryId { get; }
Public Shared ReadOnly Property DpartOriginalCategoryId As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DpartOriginalCategoryId {
    ForgeTypeId^ get ();
}
static member DpartOriginalCategoryId : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DpartOriginalFamily Property

ParameterTypeIdDpartOriginalFamily Property

"Original Family"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DpartOriginalFamily { get; }
Public Shared ReadOnly Property DpartOriginalFamily As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DpartOriginalFamily {
    ForgeTypeId^ get ();
}
static member DpartOriginalFamily : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DpartOriginalType Property

ParameterTypeIdDpartOriginalType Property

"Original Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DpartOriginalType { get; }
Public Shared ReadOnly Property DpartOriginalType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DpartOriginalType {
    ForgeTypeId^ get ();
}
static member DpartOriginalType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DpartPhaseCreatedByOriginal Property

ParameterTypeIdDpartPhaseCreatedByOriginal Property

"Phase Created By Original"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DpartPhaseCreatedByOriginal { get; }
Public Shared ReadOnly Property DpartPhaseCreatedByOriginal As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DpartPhaseCreatedByOriginal {
    ForgeTypeId^ get ();
}
static member DpartPhaseCreatedByOriginal : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DpartPhaseDemolishedByOriginal Property

ParameterTypeIdDpartPhaseDemolishedByOriginal Property

"Phase Demolished By Original"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DpartPhaseDemolishedByOriginal { get; }
Public Shared ReadOnly Property DpartPhaseDemolishedByOriginal As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DpartPhaseDemolishedByOriginal {
    ForgeTypeId^ get ();
}
static member DpartPhaseDemolishedByOriginal : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DpartShapeModified Property

ParameterTypeIdDpartShapeModified Property

"Shape is modified"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DpartShapeModified { get; }
Public Shared ReadOnly Property DpartShapeModified As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DpartShapeModified {
    ForgeTypeId^ get ();
}
static member DpartShapeModified : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DpartVolumeComputed Property

ParameterTypeIdDpartVolumeComputed Property

"Volume"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DpartVolumeComputed { get; }
Public Shared ReadOnly Property DpartVolumeComputed As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DpartVolumeComputed {
    ForgeTypeId^ get ();
}
static member DpartVolumeComputed : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DrawForEachRun Property

ParameterTypeIdDrawForEachRun Property

"Draw for Each Run"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DrawForEachRun { get; }
Public Shared ReadOnly Property DrawForEachRun As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DrawForEachRun {
    ForgeTypeId^ get ();
}
static member DrawForEachRun : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DuctInsulationThickness Property

ParameterTypeIdDuctInsulationThickness Property

"Insulation Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DuctInsulationThickness { get; }
Public Shared ReadOnly Property DuctInsulationThickness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DuctInsulationThickness {
    ForgeTypeId^ get ();
}
static member DuctInsulationThickness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DuctRoughness Property

ParameterTypeIdDuctRoughness Property

"Roughness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DuctRoughness { get; }
Public Shared ReadOnly Property DuctRoughness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DuctRoughness {
    ForgeTypeId^ get ();
}
static member DuctRoughness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.DuctTerminalEngagementLength Property

ParameterTypeIdDuctTerminalEngagementLength Property

"Engagement Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DuctTerminalEngagementLength { get; }
Public Shared ReadOnly Property DuctTerminalEngagementLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DuctTerminalEngagementLength {
    ForgeTypeId^ get ();
}
static member DuctTerminalEngagementLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.EdgeLinework Property

ParameterTypeIdEdgeLinework Property

"Line Style"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EdgeLinework { get; }
Public Shared ReadOnly Property EdgeLinework As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EdgeLinework {
    ForgeTypeId^ get ();
}
static member EdgeLinework : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.EditedBy Property

ParameterTypeIdEditedBy Property

"Edited by"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EditedBy { get; }
Public Shared ReadOnly Property EditedBy As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EditedBy {
    ForgeTypeId^ get ();
}
static member EditedBy : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ElecticalEquipVoltage Property

ParameterTypeIdElecticalEquipVoltage Property

"Voltage Comments"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ElecticalEquipVoltage { get; }
Public Shared ReadOnly Property ElecticalEquipVoltage As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ElecticalEquipVoltage {
    ForgeTypeId^ get ();
}
static member ElecticalEquipVoltage : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ElecticalEquipWattage Property

ParameterTypeIdElecticalEquipWattage Property

"Wattage Comments"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ElecticalEquipWattage { get; }
Public Shared ReadOnly Property ElecticalEquipWattage As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ElecticalEquipWattage {
    ForgeTypeId^ get ();
}
static member ElecticalEquipWattage : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ElemCategoryParam Property

ParameterTypeIdElemCategoryParam Property

"Category"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ElemCategoryParam { get; }
Public Shared ReadOnly Property ElemCategoryParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ElemCategoryParam {
    ForgeTypeId^ get ();
}
static member ElemCategoryParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ElemCategoryParamMt Property

ParameterTypeIdElemCategoryParamMt Property

"Category"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ElemCategoryParamMt { get; }
Public Shared ReadOnly Property ElemCategoryParamMt As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ElemCategoryParamMt {
    ForgeTypeId^ get ();
}
static member ElemCategoryParamMt : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ElemDeletableInFamily Property

ParameterTypeIdElemDeletableInFamily Property

"Deletable"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ElemDeletableInFamily { get; }
Public Shared ReadOnly Property ElemDeletableInFamily As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ElemDeletableInFamily {
    ForgeTypeId^ get ();
}
static member ElemDeletableInFamily : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ElementIsCutting Property

ParameterTypeIdElementIsCutting Property

"Solid/Void"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ElementIsCutting { get; }
Public Shared ReadOnly Property ElementIsCutting As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ElementIsCutting {
    ForgeTypeId^ get ();
}
static member ElementIsCutting : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ElementLockedParam Property

ParameterTypeIdElementLockedParam Property

"Locked"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ElementLockedParam { get; }
Public Shared ReadOnly Property ElementLockedParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ElementLockedParam {
    ForgeTypeId^ get ();
}
static member ElementLockedParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ElemFamilyAndTypeParam Property

ParameterTypeIdElemFamilyAndTypeParam Property

"Family and Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ElemFamilyAndTypeParam { get; }
Public Shared ReadOnly Property ElemFamilyAndTypeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ElemFamilyAndTypeParam {
    ForgeTypeId^ get ();
}
static member ElemFamilyAndTypeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ElemFamilyParam Property

ParameterTypeIdElemFamilyParam Property

"Family"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ElemFamilyParam { get; }
Public Shared ReadOnly Property ElemFamilyParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ElemFamilyParam {
    ForgeTypeId^ get ();
}
static member ElemFamilyParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ElemIsReference Property

ParameterTypeIdElemIsReference Property

"Reference"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ElemIsReference { get; }
Public Shared ReadOnly Property ElemIsReference As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ElemIsReference {
    ForgeTypeId^ get ();
}
static member ElemIsReference : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ElemPartitionParam Property

ParameterTypeIdElemPartitionParam Property

"Workset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ElemPartitionParam { get; }
Public Shared ReadOnly Property ElemPartitionParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ElemPartitionParam {
    ForgeTypeId^ get ();
}
static member ElemPartitionParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ElemReferenceName Property

ParameterTypeIdElemReferenceName Property

"Is Reference"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ElemReferenceName { get; }
Public Shared ReadOnly Property ElemReferenceName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ElemReferenceName {
    ForgeTypeId^ get ();
}
static member ElemReferenceName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ElemReferenceName2dXz Property

ParameterTypeIdElemReferenceName2dXz Property

"Is Reference"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ElemReferenceName2dXz { get; }
Public Shared ReadOnly Property ElemReferenceName2dXz As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ElemReferenceName2dXz {
    ForgeTypeId^ get ();
}
static member ElemReferenceName2dXz : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ElemRoomId Property

ParameterTypeIdElemRoomId Property

"Room Id"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ElemRoomId { get; }
Public Shared ReadOnly Property ElemRoomId As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ElemRoomId {
    ForgeTypeId^ get ();
}
static member ElemRoomId : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ElemRoomName Property

ParameterTypeIdElemRoomName Property

"Room Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ElemRoomName { get; }
Public Shared ReadOnly Property ElemRoomName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ElemRoomName {
    ForgeTypeId^ get ();
}
static member ElemRoomName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ElemRoomNumber Property

ParameterTypeIdElemRoomNumber Property

"Room Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ElemRoomNumber { get; }
Public Shared ReadOnly Property ElemRoomNumber As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ElemRoomNumber {
    ForgeTypeId^ get ();
}
static member ElemRoomNumber : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ElemTypeLabel Property

ParameterTypeIdElemTypeLabel Property

"Label"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ElemTypeLabel { get; }
Public Shared ReadOnly Property ElemTypeLabel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ElemTypeLabel {
    ForgeTypeId^ get ();
}
static member ElemTypeLabel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ElemTypeParam Property

ParameterTypeIdElemTypeParam Property

"Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ElemTypeParam { get; }
Public Shared ReadOnly Property ElemTypeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ElemTypeParam {
    ForgeTypeId^ get ();
}
static member ElemTypeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ElevArrowAngle Property

ParameterTypeIdElevArrowAngle Property

"Arrow Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ElevArrowAngle { get; }
Public Shared ReadOnly Property ElevArrowAngle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ElevArrowAngle {
    ForgeTypeId^ get ();
}
static member ElevArrowAngle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ElevArrowFilled Property

ParameterTypeIdElevArrowFilled Property

"Filled"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ElevArrowFilled { get; }
Public Shared ReadOnly Property ElevArrowFilled As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ElevArrowFilled {
    ForgeTypeId^ get ();
}
static member ElevArrowFilled : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ElevAssocDatum Property

ParameterTypeIdElevAssocDatum Property

"Associated Datum"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ElevAssocDatum { get; }
Public Shared ReadOnly Property ElevAssocDatum As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ElevAssocDatum {
    ForgeTypeId^ get ();
}
static member ElevAssocDatum : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ElevatnTag Property

ParameterTypeIdElevatnTag Property

"Elevation Tag"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ElevatnTag { get; }
Public Shared ReadOnly Property ElevatnTag As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ElevatnTag {
    ForgeTypeId^ get ();
}
static member ElevatnTag : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ElevReferenceLabelPos Property

ParameterTypeIdElevReferenceLabelPos Property

"Reference Label Position"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ElevReferenceLabelPos { get; }
Public Shared ReadOnly Property ElevReferenceLabelPos As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ElevReferenceLabelPos {
    ForgeTypeId^ get ();
}
static member ElevReferenceLabelPos : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ElevShape Property

ParameterTypeIdElevShape Property

"Shape"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ElevShape { get; }
Public Shared ReadOnly Property ElevShape As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ElevShape {
    ForgeTypeId^ get ();
}
static member ElevShape : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ElevShowViewName Property

ParameterTypeIdElevShowViewName Property

"Show View Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ElevShowViewName { get; }
Public Shared ReadOnly Property ElevShowViewName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ElevShowViewName {
    ForgeTypeId^ get ();
}
static member ElevShowViewName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ElevSymbolId Property

ParameterTypeIdElevSymbolId Property

"Elevation Mark"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ElevSymbolId { get; }
Public Shared ReadOnly Property ElevSymbolId As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ElevSymbolId {
    ForgeTypeId^ get ();
}
static member ElevSymbolId : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ElevTextPos Property

ParameterTypeIdElevTextPos Property

"Text Position"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ElevTextPos { get; }
Public Shared ReadOnly Property ElevTextPos As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ElevTextPos {
    ForgeTypeId^ get ();
}
static member ElevTextPos : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ElevViewNamePos Property

ParameterTypeIdElevViewNamePos Property

"View Name Position"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ElevViewNamePos { get; }
Public Shared ReadOnly Property ElevViewNamePos As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ElevViewNamePos {
    ForgeTypeId^ get ();
}
static member ElevViewNamePos : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ElevWidth Property

ParameterTypeIdElevWidth Property

"Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ElevWidth { get; }
Public Shared ReadOnly Property ElevWidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ElevWidth {
    ForgeTypeId^ get ();
}
static member ElevWidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.EllipseFocusMrkVisible Property

ParameterTypeIdEllipseFocusMrkVisible Property

"Focus Marks Visible"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EllipseFocusMrkVisible { get; }
Public Shared ReadOnly Property EllipseFocusMrkVisible As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EllipseFocusMrkVisible {
    ForgeTypeId^ get ();
}
static member EllipseFocusMrkVisible : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.EllipseModificationKeepsRatio Property

ParameterTypeIdEllipseModificationKeepsRatio Property

"Keep Ratio"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EllipseModificationKeepsRatio { get; }
Public Shared ReadOnly Property EllipseModificationKeepsRatio As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EllipseModificationKeepsRatio {
    ForgeTypeId^ get ();
}
static member EllipseModificationKeepsRatio : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.EllipseXParam Property

ParameterTypeIdEllipseXParam Property

"X-Radius Value for Ellipse (for Use with XAML Data Template example)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EllipseXParam { get; }
Public Shared ReadOnly Property EllipseXParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EllipseXParam {
    ForgeTypeId^ get ();
}
static member EllipseXParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.EllipseYParam Property

ParameterTypeIdEllipseYParam Property

"Y-Radius Value for Ellipse (for Use with XAML Data Template example)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EllipseYParam { get; }
Public Shared ReadOnly Property EllipseYParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EllipseYParam {
    ForgeTypeId^ get ();
}
static member EllipseYParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.EndExtension Property

ParameterTypeIdEndExtension Property

"End Extension"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EndExtension { get; }
Public Shared ReadOnly Property EndExtension As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EndExtension {
    ForgeTypeId^ get ();
}
static member EndExtension : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.EndJoinCutback Property

ParameterTypeIdEndJoinCutback Property

"End Join Cutback"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EndJoinCutback { get; }
Public Shared ReadOnly Property EndJoinCutback As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EndJoinCutback {
    ForgeTypeId^ get ();
}
static member EndJoinCutback : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.EndTreatment Property

ParameterTypeIdEndTreatment Property

"End Treatment"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EndTreatment { get; }
Public Shared ReadOnly Property EndTreatment As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EndTreatment {
    ForgeTypeId^ get ();
}
static member EndTreatment : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.EndYJustification Property

ParameterTypeIdEndYJustification Property

"End y Justification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EndYJustification { get; }
Public Shared ReadOnly Property EndYJustification As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EndYJustification {
    ForgeTypeId^ get ();
}
static member EndYJustification : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.EndYOffsetValue Property

ParameterTypeIdEndYOffsetValue Property

"End y Offset Value"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EndYOffsetValue { get; }
Public Shared ReadOnly Property EndYOffsetValue As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EndYOffsetValue {
    ForgeTypeId^ get ();
}
static member EndYOffsetValue : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.EndZJustification Property

ParameterTypeIdEndZJustification Property

"End z Justification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EndZJustification { get; }
Public Shared ReadOnly Property EndZJustification As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EndZJustification {
    ForgeTypeId^ get ();
}
static member EndZJustification : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.EndZOffsetValue Property

ParameterTypeIdEndZOffsetValue Property

"End z Offset Value"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EndZOffsetValue { get; }
Public Shared ReadOnly Property EndZOffsetValue As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EndZOffsetValue {
    ForgeTypeId^ get ();
}
static member EndZOffsetValue : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.EnergyAnalysisAdvancedOptions Property

ParameterTypeIdEnergyAnalysisAdvancedOptions Property

"Other Options"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EnergyAnalysisAdvancedOptions { get; }
Public Shared ReadOnly Property EnergyAnalysisAdvancedOptions As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EnergyAnalysisAdvancedOptions {
    ForgeTypeId^ get ();
}
static member EnergyAnalysisAdvancedOptions : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.EnergyAnalysisBuildingOperatingSchedule Property

ParameterTypeIdEnergyAnalysisBuildingOperatingSchedule Property

"Building Operating Schedule"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EnergyAnalysisBuildingOperatingSchedule { get; }
Public Shared ReadOnly Property EnergyAnalysisBuildingOperatingSchedule As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EnergyAnalysisBuildingOperatingSchedule {
    ForgeTypeId^ get ();
}
static member EnergyAnalysisBuildingOperatingSchedule : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.EnergyAnalysisConceptualConstruction Property

ParameterTypeIdEnergyAnalysisConceptualConstruction Property

"Conceptual Types"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EnergyAnalysisConceptualConstruction { get; }
Public Shared ReadOnly Property EnergyAnalysisConceptualConstruction As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EnergyAnalysisConceptualConstruction {
    ForgeTypeId^ get ();
}
static member EnergyAnalysisConceptualConstruction : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.EnergyAnalysisCreateAnalyticalModel Property

ParameterTypeIdEnergyAnalysisCreateAnalyticalModel Property

"Create Energy Model"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EnergyAnalysisCreateAnalyticalModel { get; }
Public Shared ReadOnly Property EnergyAnalysisCreateAnalyticalModel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EnergyAnalysisCreateAnalyticalModel {
    ForgeTypeId^ get ();
}
static member EnergyAnalysisCreateAnalyticalModel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.EnergyAnalysisCurrentViewOnly Property

ParameterTypeIdEnergyAnalysisCurrentViewOnly Property

"Use Only Elements Visible In Current View"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EnergyAnalysisCurrentViewOnly { get; }
Public Shared ReadOnly Property EnergyAnalysisCurrentViewOnly As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EnergyAnalysisCurrentViewOnly {
    ForgeTypeId^ get ();
}
static member EnergyAnalysisCurrentViewOnly : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.EnergyAnalysisGlazingIsShaded Property

ParameterTypeIdEnergyAnalysisGlazingIsShaded Property

"Glazing is Shaded"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EnergyAnalysisGlazingIsShaded { get; }
Public Shared ReadOnly Property EnergyAnalysisGlazingIsShaded As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EnergyAnalysisGlazingIsShaded {
    ForgeTypeId^ get ();
}
static member EnergyAnalysisGlazingIsShaded : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.EnergyAnalysisHorizontalVoidThreshold Property

ParameterTypeIdEnergyAnalysisHorizontalVoidThreshold Property

"Horizontal Void/Chase Area Threshold"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EnergyAnalysisHorizontalVoidThreshold { get; }
Public Shared ReadOnly Property EnergyAnalysisHorizontalVoidThreshold As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EnergyAnalysisHorizontalVoidThreshold {
    ForgeTypeId^ get ();
}
static member EnergyAnalysisHorizontalVoidThreshold : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.EnergyAnalysisHvacSystem Property

ParameterTypeIdEnergyAnalysisHvacSystem Property

"HVAC System"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EnergyAnalysisHvacSystem { get; }
Public Shared ReadOnly Property EnergyAnalysisHvacSystem As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EnergyAnalysisHvacSystem {
    ForgeTypeId^ get ();
}
static member EnergyAnalysisHvacSystem : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.EnergyAnalysisMasszoneCoreoffset Property

ParameterTypeIdEnergyAnalysisMasszoneCoreoffset Property

"Perimeter Zone Depth"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EnergyAnalysisMasszoneCoreoffset { get; }
Public Shared ReadOnly Property EnergyAnalysisMasszoneCoreoffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EnergyAnalysisMasszoneCoreoffset {
    ForgeTypeId^ get ();
}
static member EnergyAnalysisMasszoneCoreoffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.EnergyAnalysisMasszoneDivideperimeter Property

ParameterTypeIdEnergyAnalysisMasszoneDivideperimeter Property

"Perimeter Zone Division"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EnergyAnalysisMasszoneDivideperimeter { get; }
Public Shared ReadOnly Property EnergyAnalysisMasszoneDivideperimeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EnergyAnalysisMasszoneDivideperimeter {
    ForgeTypeId^ get ();
}
static member EnergyAnalysisMasszoneDivideperimeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.EnergyAnalysisMasszoneUseenergydatasettings Property

ParameterTypeIdEnergyAnalysisMasszoneUseenergydatasettings Property

"Use Energy Data"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EnergyAnalysisMasszoneUseenergydatasettings { get; }
Public Shared ReadOnly Property EnergyAnalysisMasszoneUseenergydatasettings As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EnergyAnalysisMasszoneUseenergydatasettings {
    ForgeTypeId^ get ();
}
static member EnergyAnalysisMasszoneUseenergydatasettings : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.EnergyAnalysisMassZoning Property

ParameterTypeIdEnergyAnalysisMassZoning Property

"Mass Zoning"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EnergyAnalysisMassZoning { get; }
Public Shared ReadOnly Property EnergyAnalysisMassZoning As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EnergyAnalysisMassZoning {
    ForgeTypeId^ get ();
}
static member EnergyAnalysisMassZoning : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.EnergyAnalysisOutdoorAirInformationParam Property

ParameterTypeIdEnergyAnalysisOutdoorAirInformationParam Property

"Outdoor Air Information"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EnergyAnalysisOutdoorAirInformationParam { get; }
Public Shared ReadOnly Property EnergyAnalysisOutdoorAirInformationParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EnergyAnalysisOutdoorAirInformationParam {
    ForgeTypeId^ get ();
}
static member EnergyAnalysisOutdoorAirInformationParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.EnergyAnalysisPercentageGlazing Property

ParameterTypeIdEnergyAnalysisPercentageGlazing Property

"Target Percentage Glazing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EnergyAnalysisPercentageGlazing { get; }
Public Shared ReadOnly Property EnergyAnalysisPercentageGlazing As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EnergyAnalysisPercentageGlazing {
    ForgeTypeId^ get ();
}
static member EnergyAnalysisPercentageGlazing : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.EnergyAnalysisPercentageSkylights Property

ParameterTypeIdEnergyAnalysisPercentageSkylights Property

"Target Percentage Skylights"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EnergyAnalysisPercentageSkylights { get; }
Public Shared ReadOnly Property EnergyAnalysisPercentageSkylights As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EnergyAnalysisPercentageSkylights {
    ForgeTypeId^ get ();
}
static member EnergyAnalysisPercentageSkylights : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.EnergyAnalysisProjectPhase Property

ParameterTypeIdEnergyAnalysisProjectPhase Property

"Phase"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EnergyAnalysisProjectPhase { get; }
Public Shared ReadOnly Property EnergyAnalysisProjectPhase As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EnergyAnalysisProjectPhase {
    ForgeTypeId^ get ();
}
static member EnergyAnalysisProjectPhase : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.EnergyAnalysisShadeDepth Property

ParameterTypeIdEnergyAnalysisShadeDepth Property

"Shade Depth"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EnergyAnalysisShadeDepth { get; }
Public Shared ReadOnly Property EnergyAnalysisShadeDepth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EnergyAnalysisShadeDepth {
    ForgeTypeId^ get ();
}
static member EnergyAnalysisShadeDepth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.EnergyAnalysisSillHeight Property

ParameterTypeIdEnergyAnalysisSillHeight Property

"Target Sill Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EnergyAnalysisSillHeight { get; }
Public Shared ReadOnly Property EnergyAnalysisSillHeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EnergyAnalysisSillHeight {
    ForgeTypeId^ get ();
}
static member EnergyAnalysisSillHeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.EnergyAnalysisSkylightWidth Property

ParameterTypeIdEnergyAnalysisSkylightWidth Property

"Skylight Width & Depth"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EnergyAnalysisSkylightWidth { get; }
Public Shared ReadOnly Property EnergyAnalysisSkylightWidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EnergyAnalysisSkylightWidth {
    ForgeTypeId^ get ();
}
static member EnergyAnalysisSkylightWidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.EnergyAnalysisSpaceBoundingParam Property

ParameterTypeIdEnergyAnalysisSpaceBoundingParam Property

"Analytical Space Bounding"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EnergyAnalysisSpaceBoundingParam { get; }
Public Shared ReadOnly Property EnergyAnalysisSpaceBoundingParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EnergyAnalysisSpaceBoundingParam {
    ForgeTypeId^ get ();
}
static member EnergyAnalysisSpaceBoundingParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.EnergyAnalysisVerticalVoidThreshold Property

ParameterTypeIdEnergyAnalysisVerticalVoidThreshold Property

"Average Vertical Void Height Threshold"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EnergyAnalysisVerticalVoidThreshold { get; }
Public Shared ReadOnly Property EnergyAnalysisVerticalVoidThreshold As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EnergyAnalysisVerticalVoidThreshold {
    ForgeTypeId^ get ();
}
static member EnergyAnalysisVerticalVoidThreshold : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.EqualityFormula Property

ParameterTypeIdEqualityFormula Property

"Equality Formula"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EqualityFormula { get; }
Public Shared ReadOnly Property EqualityFormula As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EqualityFormula {
    ForgeTypeId^ get ();
}
static member EqualityFormula : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.EqualityTextForAngularDim Property

ParameterTypeIdEqualityTextForAngularDim Property

"Equality Text"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EqualityTextForAngularDim { get; }
Public Shared ReadOnly Property EqualityTextForAngularDim As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EqualityTextForAngularDim {
    ForgeTypeId^ get ();
}
static member EqualityTextForAngularDim : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.EqualityTextForContinuousLinearDim Property

ParameterTypeIdEqualityTextForContinuousLinearDim Property

"Equality Text"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EqualityTextForContinuousLinearDim { get; }
Public Shared ReadOnly Property EqualityTextForContinuousLinearDim As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EqualityTextForContinuousLinearDim {
    ForgeTypeId^ get ();
}
static member EqualityTextForContinuousLinearDim : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.EqualityWitnessDisplay Property

ParameterTypeIdEqualityWitnessDisplay Property

"Equality Witness Display"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EqualityWitnessDisplay { get; }
Public Shared ReadOnly Property EqualityWitnessDisplay As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EqualityWitnessDisplay {
    ForgeTypeId^ get ();
}
static member EqualityWitnessDisplay : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ExcavationElementFamilyAndType Property

ParameterTypeIdExcavationElementFamilyAndType Property

"Element Family and Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ExcavationElementFamilyAndType { get; }
Public Shared ReadOnly Property ExcavationElementFamilyAndType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ExcavationElementFamilyAndType {
    ForgeTypeId^ get ();
}
static member ExcavationElementFamilyAndType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ExcavationElementId Property

ParameterTypeIdExcavationElementId Property

"Element Id"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ExcavationElementId { get; }
Public Shared ReadOnly Property ExcavationElementId As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ExcavationElementId {
    ForgeTypeId^ get ();
}
static member ExcavationElementId : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ExcavationVolume Property

ParameterTypeIdExcavationVolume Property

"Excavation Volume"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ExcavationVolume { get; }
Public Shared ReadOnly Property ExcavationVolume As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ExcavationVolume {
    ForgeTypeId^ get ();
}
static member ExcavationVolume : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ExcavationVolumeOnToposolid Property

ParameterTypeIdExcavationVolumeOnToposolid Property

"Excavation Volume on Toposolid"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ExcavationVolumeOnToposolid { get; }
Public Shared ReadOnly Property ExcavationVolumeOnToposolid As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ExcavationVolumeOnToposolid {
    ForgeTypeId^ get ();
}
static member ExcavationVolumeOnToposolid : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ExchangeEntityId Property

ParameterTypeIdExchangeEntityId Property

"Exchange Entity ID"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ExchangeEntityId { get; }
Public Shared ReadOnly Property ExchangeEntityId As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ExchangeEntityId {
    ForgeTypeId^ get ();
}
static member ExchangeEntityId : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ExchangeId Property

ParameterTypeIdExchangeId Property

"Exchange ID"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ExchangeId { get; }
Public Shared ReadOnly Property ExchangeId As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ExchangeId {
    ForgeTypeId^ get ();
}
static member ExchangeId : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ExtrusionAutoParams Property

ParameterTypeIdExtrusionAutoParams Property

"Auto ends"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ExtrusionAutoParams { get; }
Public Shared ReadOnly Property ExtrusionAutoParams As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ExtrusionAutoParams {
    ForgeTypeId^ get ();
}
static member ExtrusionAutoParams : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ExtrusionDepthParam Property

ParameterTypeIdExtrusionDepthParam Property

"Depth"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ExtrusionDepthParam { get; }
Public Shared ReadOnly Property ExtrusionDepthParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ExtrusionDepthParam {
    ForgeTypeId^ get ();
}
static member ExtrusionDepthParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ExtrusionEndParam Property

ParameterTypeIdExtrusionEndParam Property

"Extrusion End"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ExtrusionEndParam { get; }
Public Shared ReadOnly Property ExtrusionEndParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ExtrusionEndParam {
    ForgeTypeId^ get ();
}
static member ExtrusionEndParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ExtrusionLength Property

ParameterTypeIdExtrusionLength Property

"Depth"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ExtrusionLength { get; }
Public Shared ReadOnly Property ExtrusionLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ExtrusionLength {
    ForgeTypeId^ get ();
}
static member ExtrusionLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ExtrusionStartParam Property

ParameterTypeIdExtrusionStartParam Property

"Extrusion Start"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ExtrusionStartParam { get; }
Public Shared ReadOnly Property ExtrusionStartParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ExtrusionStartParam {
    ForgeTypeId^ get ();
}
static member ExtrusionStartParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationBottomElevationIncludeInsulationOfPart Property

ParameterTypeIdFabricationBottomElevationIncludeInsulationOfPart Property

"Bottom Elevation with Insulation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationBottomElevationIncludeInsulationOfPart { get; }
Public Shared ReadOnly Property FabricationBottomElevationIncludeInsulationOfPart As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationBottomElevationIncludeInsulationOfPart {
    ForgeTypeId^ get ();
}
static member FabricationBottomElevationIncludeInsulationOfPart : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationBottomElevationOfPart Property

ParameterTypeIdFabricationBottomElevationOfPart Property

"Bottom Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationBottomElevationOfPart { get; }
Public Shared ReadOnly Property FabricationBottomElevationOfPart As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationBottomElevationOfPart {
    ForgeTypeId^ get ();
}
static member FabricationBottomElevationOfPart : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationBottomOfPart Property

ParameterTypeIdFabricationBottomOfPart Property

"Lower End Bottom of Insulation Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationBottomOfPart { get; }
Public Shared ReadOnly Property FabricationBottomOfPart As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationBottomOfPart {
    ForgeTypeId^ get ();
}
static member FabricationBottomOfPart : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationBranchSize Property

ParameterTypeIdFabricationBranchSize Property

"Size of Primary Branch End"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationBranchSize { get; }
Public Shared ReadOnly Property FabricationBranchSize As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationBranchSize {
    ForgeTypeId^ get ();
}
static member FabricationBranchSize : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationChangeServiceParam Property

ParameterTypeIdFabricationChangeServiceParam Property

"Change Service"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationChangeServiceParam { get; }
Public Shared ReadOnly Property FabricationChangeServiceParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationChangeServiceParam {
    ForgeTypeId^ get ();
}
static member FabricationChangeServiceParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationDoublewallMaterialAbbreviation Property

ParameterTypeIdFabricationDoublewallMaterialAbbreviation Property

"Double Wall Material Abbreviation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationDoublewallMaterialAbbreviation { get; }
Public Shared ReadOnly Property FabricationDoublewallMaterialAbbreviation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationDoublewallMaterialAbbreviation {
    ForgeTypeId^ get ();
}
static member FabricationDoublewallMaterialAbbreviation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationDuctworkStiffenerSpec Property

ParameterTypeIdFabricationDuctworkStiffenerSpec Property

"Stiffener Specification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationDuctworkStiffenerSpec { get; }
Public Shared ReadOnly Property FabricationDuctworkStiffenerSpec As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationDuctworkStiffenerSpec {
    ForgeTypeId^ get ();
}
static member FabricationDuctworkStiffenerSpec : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationEndOffsetParam Property

ParameterTypeIdFabricationEndOffsetParam Property

"End Middle Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationEndOffsetParam { get; }
Public Shared ReadOnly Property FabricationEndOffsetParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationEndOffsetParam {
    ForgeTypeId^ get ();
}
static member FabricationEndOffsetParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationEndSize Property

ParameterTypeIdFabricationEndSize Property

"Size of Connector End"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationEndSize { get; }
Public Shared ReadOnly Property FabricationEndSize As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationEndSize {
    ForgeTypeId^ get ();
}
static member FabricationEndSize : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationFittingDescription Property

ParameterTypeIdFabricationFittingDescription Property

"Fabrication Fitting Description"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationFittingDescription { get; }
Public Shared ReadOnly Property FabricationFittingDescription As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationFittingDescription {
    ForgeTypeId^ get ();
}
static member FabricationFittingDescription : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationInsulationAbbreviation Property

ParameterTypeIdFabricationInsulationAbbreviation Property

"Insulation Abbreviation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationInsulationAbbreviation { get; }
Public Shared ReadOnly Property FabricationInsulationAbbreviation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationInsulationAbbreviation {
    ForgeTypeId^ get ();
}
static member FabricationInsulationAbbreviation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationInsulationMaterialFinish Property

ParameterTypeIdFabricationInsulationMaterialFinish Property

"Insulation Material"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationInsulationMaterialFinish { get; }
Public Shared ReadOnly Property FabricationInsulationMaterialFinish As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationInsulationMaterialFinish {
    ForgeTypeId^ get ();
}
static member FabricationInsulationMaterialFinish : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationInsulationSpec Property

ParameterTypeIdFabricationInsulationSpec Property

"Insulation Specification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationInsulationSpec { get; }
Public Shared ReadOnly Property FabricationInsulationSpec As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationInsulationSpec {
    ForgeTypeId^ get ();
}
static member FabricationInsulationSpec : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationInsulationSpecificationAbbreviation Property

ParameterTypeIdFabricationInsulationSpecificationAbbreviation Property

"Insulation Specification Abbreviation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationInsulationSpecificationAbbreviation { get; }
Public Shared ReadOnly Property FabricationInsulationSpecificationAbbreviation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationInsulationSpecificationAbbreviation {
    ForgeTypeId^ get ();
}
static member FabricationInsulationSpecificationAbbreviation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationLevelParam Property

ParameterTypeIdFabricationLevelParam Property

"Reference Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationLevelParam { get; }
Public Shared ReadOnly Property FabricationLevelParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationLevelParam {
    ForgeTypeId^ get ();
}
static member FabricationLevelParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationMaterialAbbreviation Property

ParameterTypeIdFabricationMaterialAbbreviation Property

"Material Abbreviation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationMaterialAbbreviation { get; }
Public Shared ReadOnly Property FabricationMaterialAbbreviation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationMaterialAbbreviation {
    ForgeTypeId^ get ();
}
static member FabricationMaterialAbbreviation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationMaterialGauge Property

ParameterTypeIdFabricationMaterialGauge Property

"Material Gauge"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationMaterialGauge { get; }
Public Shared ReadOnly Property FabricationMaterialGauge As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationMaterialGauge {
    ForgeTypeId^ get ();
}
static member FabricationMaterialGauge : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationOffsetParam Property

ParameterTypeIdFabricationOffsetParam Property

"Middle Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationOffsetParam { get; }
Public Shared ReadOnly Property FabricationOffsetParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationOffsetParam {
    ForgeTypeId^ get ();
}
static member FabricationOffsetParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationPartAlias Property

ParameterTypeIdFabricationPartAlias Property

"Alias"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationPartAlias { get; }
Public Shared ReadOnly Property FabricationPartAlias As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationPartAlias {
    ForgeTypeId^ get ();
}
static member FabricationPartAlias : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationPartAngle Property

ParameterTypeIdFabricationPartAngle Property

"Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationPartAngle { get; }
Public Shared ReadOnly Property FabricationPartAngle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationPartAngle {
    ForgeTypeId^ get ();
}
static member FabricationPartAngle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationPartAngleOption Property

ParameterTypeIdFabricationPartAngleOption Property

"Angle Option"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationPartAngleOption { get; }
Public Shared ReadOnly Property FabricationPartAngleOption As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationPartAngleOption {
    ForgeTypeId^ get ();
}
static member FabricationPartAngleOption : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationPartBoughtOut Property

ParameterTypeIdFabricationPartBoughtOut Property

"Bought Out"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationPartBoughtOut { get; }
Public Shared ReadOnly Property FabricationPartBoughtOut As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationPartBoughtOut {
    ForgeTypeId^ get ();
}
static member FabricationPartBoughtOut : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationPartCutType Property

ParameterTypeIdFabricationPartCutType Property

"Cut Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationPartCutType { get; }
Public Shared ReadOnly Property FabricationPartCutType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationPartCutType {
    ForgeTypeId^ get ();
}
static member FabricationPartCutType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationPartDepthIn Property

ParameterTypeIdFabricationPartDepthIn Property

"Main Primary Depth"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationPartDepthIn { get; }
Public Shared ReadOnly Property FabricationPartDepthIn As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationPartDepthIn {
    ForgeTypeId^ get ();
}
static member FabricationPartDepthIn : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationPartDepthInOption Property

ParameterTypeIdFabricationPartDepthInOption Property

"Main Primary Depth Option"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationPartDepthInOption { get; }
Public Shared ReadOnly Property FabricationPartDepthInOption As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationPartDepthInOption {
    ForgeTypeId^ get ();
}
static member FabricationPartDepthInOption : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationPartDepthOut Property

ParameterTypeIdFabricationPartDepthOut Property

"Main Secondary Depth"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationPartDepthOut { get; }
Public Shared ReadOnly Property FabricationPartDepthOut As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationPartDepthOut {
    ForgeTypeId^ get ();
}
static member FabricationPartDepthOut : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationPartDepthOutOption Property

ParameterTypeIdFabricationPartDepthOutOption Property

"Main Secondary Depth Option"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationPartDepthOutOption { get; }
Public Shared ReadOnly Property FabricationPartDepthOutOption As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationPartDepthOutOption {
    ForgeTypeId^ get ();
}
static member FabricationPartDepthOutOption : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationPartDiameterIn Property

ParameterTypeIdFabricationPartDiameterIn Property

"Main Primary Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationPartDiameterIn { get; }
Public Shared ReadOnly Property FabricationPartDiameterIn As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationPartDiameterIn {
    ForgeTypeId^ get ();
}
static member FabricationPartDiameterIn : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationPartDiameterInOption Property

ParameterTypeIdFabricationPartDiameterInOption Property

"Main Primary Diameter Option"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationPartDiameterInOption { get; }
Public Shared ReadOnly Property FabricationPartDiameterInOption As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationPartDiameterInOption {
    ForgeTypeId^ get ();
}
static member FabricationPartDiameterInOption : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationPartDiameterOut Property

ParameterTypeIdFabricationPartDiameterOut Property

"Main Secondary Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationPartDiameterOut { get; }
Public Shared ReadOnly Property FabricationPartDiameterOut As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationPartDiameterOut {
    ForgeTypeId^ get ();
}
static member FabricationPartDiameterOut : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationPartDiameterOutOption Property

ParameterTypeIdFabricationPartDiameterOutOption Property

"Main Secondary Diameter Option"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationPartDiameterOutOption { get; }
Public Shared ReadOnly Property FabricationPartDiameterOutOption As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationPartDiameterOutOption {
    ForgeTypeId^ get ();
}
static member FabricationPartDiameterOutOption : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationPartDoublewallMaterial Property

ParameterTypeIdFabricationPartDoublewallMaterial Property

"Double Wall Material"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationPartDoublewallMaterial { get; }
Public Shared ReadOnly Property FabricationPartDoublewallMaterial As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationPartDoublewallMaterial {
    ForgeTypeId^ get ();
}
static member FabricationPartDoublewallMaterial : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationPartDoublewallMaterialArea Property

ParameterTypeIdFabricationPartDoublewallMaterialArea Property

"Double Wall Material Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationPartDoublewallMaterialArea { get; }
Public Shared ReadOnly Property FabricationPartDoublewallMaterialArea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationPartDoublewallMaterialArea {
    ForgeTypeId^ get ();
}
static member FabricationPartDoublewallMaterialArea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationPartDoublewallMaterialThickness Property

ParameterTypeIdFabricationPartDoublewallMaterialThickness Property

"Double Wall Material Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationPartDoublewallMaterialThickness { get; }
Public Shared ReadOnly Property FabricationPartDoublewallMaterialThickness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationPartDoublewallMaterialThickness {
    ForgeTypeId^ get ();
}
static member FabricationPartDoublewallMaterialThickness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationPartInsulationArea Property

ParameterTypeIdFabricationPartInsulationArea Property

"Insulation Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationPartInsulationArea { get; }
Public Shared ReadOnly Property FabricationPartInsulationArea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationPartInsulationArea {
    ForgeTypeId^ get ();
}
static member FabricationPartInsulationArea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationPartItemNumber Property

ParameterTypeIdFabricationPartItemNumber Property

"Item Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationPartItemNumber { get; }
Public Shared ReadOnly Property FabricationPartItemNumber As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationPartItemNumber {
    ForgeTypeId^ get ();
}
static member FabricationPartItemNumber : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationPartLength Property

ParameterTypeIdFabricationPartLength Property

"Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationPartLength { get; }
Public Shared ReadOnly Property FabricationPartLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationPartLength {
    ForgeTypeId^ get ();
}
static member FabricationPartLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationPartLengthOption Property

ParameterTypeIdFabricationPartLengthOption Property

"Length Option"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationPartLengthOption { get; }
Public Shared ReadOnly Property FabricationPartLengthOption As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationPartLengthOption {
    ForgeTypeId^ get ();
}
static member FabricationPartLengthOption : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationPartLiningArea Property

ParameterTypeIdFabricationPartLiningArea Property

"Lining Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationPartLiningArea { get; }
Public Shared ReadOnly Property FabricationPartLiningArea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationPartLiningArea {
    ForgeTypeId^ get ();
}
static member FabricationPartLiningArea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationPartMaterial Property

ParameterTypeIdFabricationPartMaterial Property

"Part Material"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationPartMaterial { get; }
Public Shared ReadOnly Property FabricationPartMaterial As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationPartMaterial {
    ForgeTypeId^ get ();
}
static member FabricationPartMaterial : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationPartMaterialThickness Property

ParameterTypeIdFabricationPartMaterialThickness Property

"Part Material Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationPartMaterialThickness { get; }
Public Shared ReadOnly Property FabricationPartMaterialThickness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationPartMaterialThickness {
    ForgeTypeId^ get ();
}
static member FabricationPartMaterialThickness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationPartNotes Property

ParameterTypeIdFabricationPartNotes Property

"Fabrication Notes"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationPartNotes { get; }
Public Shared ReadOnly Property FabricationPartNotes As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationPartNotes {
    ForgeTypeId^ get ();
}
static member FabricationPartNotes : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationPartPatNo Property

ParameterTypeIdFabricationPartPatNo Property

"Part Pattern Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationPartPatNo { get; }
Public Shared ReadOnly Property FabricationPartPatNo As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationPartPatNo {
    ForgeTypeId^ get ();
}
static member FabricationPartPatNo : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationPartSheetmetalArea Property

ParameterTypeIdFabricationPartSheetmetalArea Property

"Part Sheet Metal Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationPartSheetmetalArea { get; }
Public Shared ReadOnly Property FabricationPartSheetmetalArea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationPartSheetmetalArea {
    ForgeTypeId^ get ();
}
static member FabricationPartSheetmetalArea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationPartTakeoffDialogParam Property

ParameterTypeIdFabricationPartTakeoffDialogParam Property

"More Parameters"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationPartTakeoffDialogParam { get; }
Public Shared ReadOnly Property FabricationPartTakeoffDialogParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationPartTakeoffDialogParam {
    ForgeTypeId^ get ();
}
static member FabricationPartTakeoffDialogParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationPartWeight Property

ParameterTypeIdFabricationPartWeight Property

"Weight"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationPartWeight { get; }
Public Shared ReadOnly Property FabricationPartWeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationPartWeight {
    ForgeTypeId^ get ();
}
static member FabricationPartWeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationPartWidthIn Property

ParameterTypeIdFabricationPartWidthIn Property

"Main Primary Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationPartWidthIn { get; }
Public Shared ReadOnly Property FabricationPartWidthIn As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationPartWidthIn {
    ForgeTypeId^ get ();
}
static member FabricationPartWidthIn : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationPartWidthInOption Property

ParameterTypeIdFabricationPartWidthInOption Property

"Main Primary Width Option"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationPartWidthInOption { get; }
Public Shared ReadOnly Property FabricationPartWidthInOption As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationPartWidthInOption {
    ForgeTypeId^ get ();
}
static member FabricationPartWidthInOption : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationPartWidthOut Property

ParameterTypeIdFabricationPartWidthOut Property

"Main Secondary Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationPartWidthOut { get; }
Public Shared ReadOnly Property FabricationPartWidthOut As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationPartWidthOut {
    ForgeTypeId^ get ();
}
static member FabricationPartWidthOut : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationPartWidthOutOption Property

ParameterTypeIdFabricationPartWidthOutOption Property

"Main Secondary Width Option"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationPartWidthOutOption { get; }
Public Shared ReadOnly Property FabricationPartWidthOutOption As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationPartWidthOutOption {
    ForgeTypeId^ get ();
}
static member FabricationPartWidthOutOption : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationPipeInvertElevation Property

ParameterTypeIdFabricationPipeInvertElevation Property

"Pipe Invert Elevation": This parameter is obsolete. It exists only for compatibility.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationPipeInvertElevation { get; }
Public Shared ReadOnly Property FabricationPipeInvertElevation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationPipeInvertElevation {
    ForgeTypeId^ get ();
}
static member FabricationPipeInvertElevation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationPrimarySize Property

ParameterTypeIdFabricationPrimarySize Property

"Size of Primary End"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationPrimarySize { get; }
Public Shared ReadOnly Property FabricationPrimarySize As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationPrimarySize {
    ForgeTypeId^ get ();
}
static member FabricationPrimarySize : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationProductCode Property

ParameterTypeIdFabricationProductCode Property

"Product Code"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationProductCode { get; }
Public Shared ReadOnly Property FabricationProductCode As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationProductCode {
    ForgeTypeId^ get ();
}
static member FabricationProductCode : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationProductDataFinishDescription Property

ParameterTypeIdFabricationProductDataFinishDescription Property

"Product Finish Description"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationProductDataFinishDescription { get; }
Public Shared ReadOnly Property FabricationProductDataFinishDescription As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationProductDataFinishDescription {
    ForgeTypeId^ get ();
}
static member FabricationProductDataFinishDescription : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationProductDataInstallType Property

ParameterTypeIdFabricationProductDataInstallType Property

"Install Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationProductDataInstallType { get; }
Public Shared ReadOnly Property FabricationProductDataInstallType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationProductDataInstallType {
    ForgeTypeId^ get ();
}
static member FabricationProductDataInstallType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationProductDataItemDescription Property

ParameterTypeIdFabricationProductDataItemDescription Property

"Product Short Description"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationProductDataItemDescription { get; }
Public Shared ReadOnly Property FabricationProductDataItemDescription As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationProductDataItemDescription {
    ForgeTypeId^ get ();
}
static member FabricationProductDataItemDescription : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationProductDataLongDescription Property

ParameterTypeIdFabricationProductDataLongDescription Property

"Product Long Description"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationProductDataLongDescription { get; }
Public Shared ReadOnly Property FabricationProductDataLongDescription As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationProductDataLongDescription {
    ForgeTypeId^ get ();
}
static member FabricationProductDataLongDescription : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationProductDataMaterialDescription Property

ParameterTypeIdFabricationProductDataMaterialDescription Property

"Product Material Description"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationProductDataMaterialDescription { get; }
Public Shared ReadOnly Property FabricationProductDataMaterialDescription As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationProductDataMaterialDescription {
    ForgeTypeId^ get ();
}
static member FabricationProductDataMaterialDescription : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationProductDataOem Property

ParameterTypeIdFabricationProductDataOem Property

"OEM"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationProductDataOem { get; }
Public Shared ReadOnly Property FabricationProductDataOem As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationProductDataOem {
    ForgeTypeId^ get ();
}
static member FabricationProductDataOem : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationProductDataProduct Property

ParameterTypeIdFabricationProductDataProduct Property

"Product Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationProductDataProduct { get; }
Public Shared ReadOnly Property FabricationProductDataProduct As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationProductDataProduct {
    ForgeTypeId^ get ();
}
static member FabricationProductDataProduct : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationProductDataRange Property

ParameterTypeIdFabricationProductDataRange Property

"Product Range"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationProductDataRange { get; }
Public Shared ReadOnly Property FabricationProductDataRange As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationProductDataRange {
    ForgeTypeId^ get ();
}
static member FabricationProductDataRange : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationProductDataSizeDescription Property

ParameterTypeIdFabricationProductDataSizeDescription Property

"Product Size Description"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationProductDataSizeDescription { get; }
Public Shared ReadOnly Property FabricationProductDataSizeDescription As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationProductDataSizeDescription {
    ForgeTypeId^ get ();
}
static member FabricationProductDataSizeDescription : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationProductDataSpecification Property

ParameterTypeIdFabricationProductDataSpecification Property

"Product Specification Description"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationProductDataSpecification { get; }
Public Shared ReadOnly Property FabricationProductDataSpecification As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationProductDataSpecification {
    ForgeTypeId^ get ();
}
static member FabricationProductDataSpecification : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationProductEntry Property

ParameterTypeIdFabricationProductEntry Property

"Product Entry"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationProductEntry { get; }
Public Shared ReadOnly Property FabricationProductEntry As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationProductEntry {
    ForgeTypeId^ get ();
}
static member FabricationProductEntry : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationRelativeFilename Property

ParameterTypeIdFabricationRelativeFilename Property

"Relative File Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationRelativeFilename { get; }
Public Shared ReadOnly Property FabricationRelativeFilename As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationRelativeFilename {
    ForgeTypeId^ get ();
}
static member FabricationRelativeFilename : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationRoutingSolutionsUiParam Property

ParameterTypeIdFabricationRoutingSolutionsUiParam Property

"x of XX"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationRoutingSolutionsUiParam { get; }
Public Shared ReadOnly Property FabricationRoutingSolutionsUiParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationRoutingSolutionsUiParam {
    ForgeTypeId^ get ();
}
static member FabricationRoutingSolutionsUiParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationSecondarySize Property

ParameterTypeIdFabricationSecondarySize Property

"Size of Secondary End"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationSecondarySize { get; }
Public Shared ReadOnly Property FabricationSecondarySize As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationSecondarySize {
    ForgeTypeId^ get ();
}
static member FabricationSecondarySize : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationServiceAbbreviation Property

ParameterTypeIdFabricationServiceAbbreviation Property

"Fabrication Service Abbreviation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationServiceAbbreviation { get; }
Public Shared ReadOnly Property FabricationServiceAbbreviation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationServiceAbbreviation {
    ForgeTypeId^ get ();
}
static member FabricationServiceAbbreviation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationServiceName Property

ParameterTypeIdFabricationServiceName Property

"Fabrication Service Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationServiceName { get; }
Public Shared ReadOnly Property FabricationServiceName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationServiceName {
    ForgeTypeId^ get ();
}
static member FabricationServiceName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationServiceParam Property

ParameterTypeIdFabricationServiceParam Property

"Fabrication Service"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationServiceParam { get; }
Public Shared ReadOnly Property FabricationServiceParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationServiceParam {
    ForgeTypeId^ get ();
}
static member FabricationServiceParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationSetUpDownTag Property

ParameterTypeIdFabricationSetUpDownTag Property

"SU/SD from Top"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationSetUpDownTag { get; }
Public Shared ReadOnly Property FabricationSetUpDownTag As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationSetUpDownTag {
    ForgeTypeId^ get ();
}
static member FabricationSetUpDownTag : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationSetUpDownTagFromBottom Property

ParameterTypeIdFabricationSetUpDownTagFromBottom Property

"SU/SD from Bottom"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationSetUpDownTagFromBottom { get; }
Public Shared ReadOnly Property FabricationSetUpDownTagFromBottom As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationSetUpDownTagFromBottom {
    ForgeTypeId^ get ();
}
static member FabricationSetUpDownTagFromBottom : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationSlopeParam Property

ParameterTypeIdFabricationSlopeParam Property

"Slope"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationSlopeParam { get; }
Public Shared ReadOnly Property FabricationSlopeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationSlopeParam {
    ForgeTypeId^ get ();
}
static member FabricationSlopeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationSpecification Property

ParameterTypeIdFabricationSpecification Property

"Specification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationSpecification { get; }
Public Shared ReadOnly Property FabricationSpecification As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationSpecification {
    ForgeTypeId^ get ();
}
static member FabricationSpecification : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationSpecificationAbbreviation Property

ParameterTypeIdFabricationSpecificationAbbreviation Property

"Specification Abbreviation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationSpecificationAbbreviation { get; }
Public Shared ReadOnly Property FabricationSpecificationAbbreviation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationSpecificationAbbreviation {
    ForgeTypeId^ get ();
}
static member FabricationSpecificationAbbreviation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationStartOffsetParam Property

ParameterTypeIdFabricationStartOffsetParam Property

"Start Middle Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationStartOffsetParam { get; }
Public Shared ReadOnly Property FabricationStartOffsetParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationStartOffsetParam {
    ForgeTypeId^ get ();
}
static member FabricationStartOffsetParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationTopElevationIncludeInsulationOfPart Property

ParameterTypeIdFabricationTopElevationIncludeInsulationOfPart Property

"Top Elevation with Insulation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationTopElevationIncludeInsulationOfPart { get; }
Public Shared ReadOnly Property FabricationTopElevationIncludeInsulationOfPart As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationTopElevationIncludeInsulationOfPart {
    ForgeTypeId^ get ();
}
static member FabricationTopElevationIncludeInsulationOfPart : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationTopElevationOfPart Property

ParameterTypeIdFabricationTopElevationOfPart Property

"Top Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationTopElevationOfPart { get; }
Public Shared ReadOnly Property FabricationTopElevationOfPart As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationTopElevationOfPart {
    ForgeTypeId^ get ();
}
static member FabricationTopElevationOfPart : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationTopOfPart Property

ParameterTypeIdFabricationTopOfPart Property

"Upper End Top of Insulation Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationTopOfPart { get; }
Public Shared ReadOnly Property FabricationTopOfPart As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationTopOfPart {
    ForgeTypeId^ get ();
}
static member FabricationTopOfPart : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationVendor Property

ParameterTypeIdFabricationVendor Property

"Vendor"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationVendor { get; }
Public Shared ReadOnly Property FabricationVendor As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationVendor {
    ForgeTypeId^ get ();
}
static member FabricationVendor : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricationVendorCode Property

ParameterTypeIdFabricationVendorCode Property

"Vendor Code"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricationVendorCode { get; }
Public Shared ReadOnly Property FabricationVendorCode As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricationVendorCode {
    ForgeTypeId^ get ();
}
static member FabricationVendorCode : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricBendDiameter Property

ParameterTypeIdFabricBendDiameter Property

"Bend Diameter": Standard Bend Diameter of Fabric Wire.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricBendDiameter { get; }
Public Shared ReadOnly Property FabricBendDiameter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricBendDiameter {
    ForgeTypeId^ get ();
}
static member FabricBendDiameter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricNumber Property

ParameterTypeIdFabricNumber Property

"Fabric Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricNumber { get; }
Public Shared ReadOnly Property FabricNumber As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricNumber {
    ForgeTypeId^ get ();
}
static member FabricNumber : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricParamCoverOffset Property

ParameterTypeIdFabricParamCoverOffset Property

"Additional Cover Offset": Additional cover offset of the fabric distribution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricParamCoverOffset { get; }
Public Shared ReadOnly Property FabricParamCoverOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricParamCoverOffset {
    ForgeTypeId^ get ();
}
static member FabricParamCoverOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricParamCutByHost Property

ParameterTypeIdFabricParamCutByHost Property

"Cut by Host Cover": Single Fabric Sheet is cut or not cut by the Host Cover.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricParamCutByHost { get; }
Public Shared ReadOnly Property FabricParamCutByHost As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricParamCutByHost {
    ForgeTypeId^ get ();
}
static member FabricParamCutByHost : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricParamCutOverallLength Property

ParameterTypeIdFabricParamCutOverallLength Property

"Cut Overall Length": Provides a real sheet Length after definition

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricParamCutOverallLength { get; }
Public Shared ReadOnly Property FabricParamCutOverallLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricParamCutOverallLength {
    ForgeTypeId^ get ();
}
static member FabricParamCutOverallLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricParamCutOverallWidth Property

ParameterTypeIdFabricParamCutOverallWidth Property

"Cut Overall Width": Provides a real sheet Width after definition

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricParamCutOverallWidth { get; }
Public Shared ReadOnly Property FabricParamCutOverallWidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricParamCutOverallWidth {
    ForgeTypeId^ get ();
}
static member FabricParamCutOverallWidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricParamCutSheetMass Property

ParameterTypeIdFabricParamCutSheetMass Property

"Cut Sheet Mass": Calculated cut sheet mass [Sheet Mass per Unit Area * (Cut Overall Length * Cut Overall Width)]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricParamCutSheetMass { get; }
Public Shared ReadOnly Property FabricParamCutSheetMass As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricParamCutSheetMass {
    ForgeTypeId^ get ();
}
static member FabricParamCutSheetMass : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricParamLapsplicePosition Property

ParameterTypeIdFabricParamLapsplicePosition Property

"Lap Splice Position": Fabric lap splice position in the fabric distribution

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricParamLapsplicePosition { get; }
Public Shared ReadOnly Property FabricParamLapsplicePosition As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricParamLapsplicePosition {
    ForgeTypeId^ get ();
}
static member FabricParamLapsplicePosition : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricParamLocationGeneric Property

ParameterTypeIdFabricParamLocationGeneric Property

"Location": Fabric location in the host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricParamLocationGeneric { get; }
Public Shared ReadOnly Property FabricParamLocationGeneric As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricParamLocationGeneric {
    ForgeTypeId^ get ();
}
static member FabricParamLocationGeneric : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricParamLocationSlab Property

ParameterTypeIdFabricParamLocationSlab Property

"Location": Fabric location in the slab

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricParamLocationSlab { get; }
Public Shared ReadOnly Property FabricParamLocationSlab As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricParamLocationSlab {
    ForgeTypeId^ get ();
}
static member FabricParamLocationSlab : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricParamLocationWall Property

ParameterTypeIdFabricParamLocationWall Property

"Location": Fabric location in the wall

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricParamLocationWall { get; }
Public Shared ReadOnly Property FabricParamLocationWall As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricParamLocationWall {
    ForgeTypeId^ get ();
}
static member FabricParamLocationWall : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricParamMajorLapspliceLength Property

ParameterTypeIdFabricParamMajorLapspliceLength Property

"Major Lap Splice Length": Fabric lap splice length in major direction in the fabric distribution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricParamMajorLapspliceLength { get; }
Public Shared ReadOnly Property FabricParamMajorLapspliceLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricParamMajorLapspliceLength {
    ForgeTypeId^ get ();
}
static member FabricParamMajorLapspliceLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricParamMinorLapspliceLength Property

ParameterTypeIdFabricParamMinorLapspliceLength Property

"Minor Lap Splice Length": Fabric lap splice length in minor direction in the fabric distribution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricParamMinorLapspliceLength { get; }
Public Shared ReadOnly Property FabricParamMinorLapspliceLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricParamMinorLapspliceLength {
    ForgeTypeId^ get ();
}
static member FabricParamMinorLapspliceLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricParamRounding Property

ParameterTypeIdFabricParamRounding Property

"Rounding Overrides"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricParamRounding { get; }
Public Shared ReadOnly Property FabricParamRounding As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricParamRounding {
    ForgeTypeId^ get ();
}
static member FabricParamRounding : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricParamSharedFamilyKey Property

ParameterTypeIdFabricParamSharedFamilyKey Property

"Shared family key"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricParamSharedFamilyKey { get; }
Public Shared ReadOnly Property FabricParamSharedFamilyKey As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricParamSharedFamilyKey {
    ForgeTypeId^ get ();
}
static member FabricParamSharedFamilyKey : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricParamSheetType Property

ParameterTypeIdFabricParamSheetType Property

"Fabric Sheet": List all Fabric Sheet types

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricParamSheetType { get; }
Public Shared ReadOnly Property FabricParamSheetType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricParamSheetType {
    ForgeTypeId^ get ();
}
static member FabricParamSheetType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricParamSpanSymBottom Property

ParameterTypeIdFabricParamSpanSymBottom Property

"Bottom"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricParamSpanSymBottom { get; }
Public Shared ReadOnly Property FabricParamSpanSymBottom As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricParamSpanSymBottom {
    ForgeTypeId^ get ();
}
static member FabricParamSpanSymBottom : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricParamSpanSymDBottom Property

ParameterTypeIdFabricParamSpanSymDBottom Property

"D_Bottom"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricParamSpanSymDBottom { get; }
Public Shared ReadOnly Property FabricParamSpanSymDBottom As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricParamSpanSymDBottom {
    ForgeTypeId^ get ();
}
static member FabricParamSpanSymDBottom : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricParamSpanSymDLeft Property

ParameterTypeIdFabricParamSpanSymDLeft Property

"D_Left"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricParamSpanSymDLeft { get; }
Public Shared ReadOnly Property FabricParamSpanSymDLeft As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricParamSpanSymDLeft {
    ForgeTypeId^ get ();
}
static member FabricParamSpanSymDLeft : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricParamSpanSymDRight Property

ParameterTypeIdFabricParamSpanSymDRight Property

"D_Right"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricParamSpanSymDRight { get; }
Public Shared ReadOnly Property FabricParamSpanSymDRight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricParamSpanSymDRight {
    ForgeTypeId^ get ();
}
static member FabricParamSpanSymDRight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricParamSpanSymDTop Property

ParameterTypeIdFabricParamSpanSymDTop Property

"D_Top"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricParamSpanSymDTop { get; }
Public Shared ReadOnly Property FabricParamSpanSymDTop As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricParamSpanSymDTop {
    ForgeTypeId^ get ();
}
static member FabricParamSpanSymDTop : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricParamSpanSymLeft Property

ParameterTypeIdFabricParamSpanSymLeft Property

"Left"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricParamSpanSymLeft { get; }
Public Shared ReadOnly Property FabricParamSpanSymLeft As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricParamSpanSymLeft {
    ForgeTypeId^ get ();
}
static member FabricParamSpanSymLeft : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricParamSpanSymRight Property

ParameterTypeIdFabricParamSpanSymRight Property

"Right"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricParamSpanSymRight { get; }
Public Shared ReadOnly Property FabricParamSpanSymRight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricParamSpanSymRight {
    ForgeTypeId^ get ();
}
static member FabricParamSpanSymRight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricParamSpanSymTop Property

ParameterTypeIdFabricParamSpanSymTop Property

"Top"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricParamSpanSymTop { get; }
Public Shared ReadOnly Property FabricParamSpanSymTop As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricParamSpanSymTop {
    ForgeTypeId^ get ();
}
static member FabricParamSpanSymTop : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricParamSpanTagComponentReference Property

ParameterTypeIdFabricParamSpanTagComponentReference Property

"Tag Component Reference"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricParamSpanTagComponentReference { get; }
Public Shared ReadOnly Property FabricParamSpanTagComponentReference As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricParamSpanTagComponentReference {
    ForgeTypeId^ get ();
}
static member FabricParamSpanTagComponentReference : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricParamTagView Property

ParameterTypeIdFabricParamTagView Property

"Tag new members in view": List of all Plan Views and None.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricParamTagView { get; }
Public Shared ReadOnly Property FabricParamTagView As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricParamTagView {
    ForgeTypeId^ get ();
}
static member FabricParamTagView : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricParamTotalSheetMass Property

ParameterTypeIdFabricParamTotalSheetMass Property

"Total Sheet Mass": Calculated all sheet mass: Volume of Wire * Unit Weight.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricParamTotalSheetMass { get; }
Public Shared ReadOnly Property FabricParamTotalSheetMass As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricParamTotalSheetMass {
    ForgeTypeId^ get ();
}
static member FabricParamTotalSheetMass : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricSheetDefaultMajorLapspliceLength Property

ParameterTypeIdFabricSheetDefaultMajorLapspliceLength Property

"Default Major Lap Splice Length": Default Major Lap Splice Length

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricSheetDefaultMajorLapspliceLength { get; }
Public Shared ReadOnly Property FabricSheetDefaultMajorLapspliceLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricSheetDefaultMajorLapspliceLength {
    ForgeTypeId^ get ();
}
static member FabricSheetDefaultMajorLapspliceLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricSheetDefaultMinorLapspliceLength Property

ParameterTypeIdFabricSheetDefaultMinorLapspliceLength Property

"Default Minor Lap Splice Length": Default Minor Lap Splice Length

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricSheetDefaultMinorLapspliceLength { get; }
Public Shared ReadOnly Property FabricSheetDefaultMinorLapspliceLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricSheetDefaultMinorLapspliceLength {
    ForgeTypeId^ get ();
}
static member FabricSheetDefaultMinorLapspliceLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricSheetLength Property

ParameterTypeIdFabricSheetLength Property

"Length": Length

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricSheetLength { get; }
Public Shared ReadOnly Property FabricSheetLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricSheetLength {
    ForgeTypeId^ get ();
}
static member FabricSheetLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricSheetMajorDirectionWireType Property

ParameterTypeIdFabricSheetMajorDirectionWireType Property

"Major Direction Wire Type": Major Direction Wire Type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricSheetMajorDirectionWireType { get; }
Public Shared ReadOnly Property FabricSheetMajorDirectionWireType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricSheetMajorDirectionWireType {
    ForgeTypeId^ get ();
}
static member FabricSheetMajorDirectionWireType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricSheetMajorEndOverhang Property

ParameterTypeIdFabricSheetMajorEndOverhang Property

"Major End Overhang": Major End Overhang

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricSheetMajorEndOverhang { get; }
Public Shared ReadOnly Property FabricSheetMajorEndOverhang As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricSheetMajorEndOverhang {
    ForgeTypeId^ get ();
}
static member FabricSheetMajorEndOverhang : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricSheetMajorLayoutPattern Property

ParameterTypeIdFabricSheetMajorLayoutPattern Property

"Major Layout Pattern": Major Layout Pattern

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricSheetMajorLayoutPattern { get; }
Public Shared ReadOnly Property FabricSheetMajorLayoutPattern As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricSheetMajorLayoutPattern {
    ForgeTypeId^ get ();
}
static member FabricSheetMajorLayoutPattern : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricSheetMajorNumberOfWires Property

ParameterTypeIdFabricSheetMajorNumberOfWires Property

"Major Number of Wires": Major Number of Wires

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricSheetMajorNumberOfWires { get; }
Public Shared ReadOnly Property FabricSheetMajorNumberOfWires As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricSheetMajorNumberOfWires {
    ForgeTypeId^ get ();
}
static member FabricSheetMajorNumberOfWires : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricSheetMajorReinforcementArea Property

ParameterTypeIdFabricSheetMajorReinforcementArea Property

"Major Reinforcement Area": Major Reinforcement Area

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricSheetMajorReinforcementArea { get; }
Public Shared ReadOnly Property FabricSheetMajorReinforcementArea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricSheetMajorReinforcementArea {
    ForgeTypeId^ get ();
}
static member FabricSheetMajorReinforcementArea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricSheetMajorSpacing Property

ParameterTypeIdFabricSheetMajorSpacing Property

"Major Spacing": Major Spacing

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricSheetMajorSpacing { get; }
Public Shared ReadOnly Property FabricSheetMajorSpacing As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricSheetMajorSpacing {
    ForgeTypeId^ get ();
}
static member FabricSheetMajorSpacing : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricSheetMajorStartOverhang Property

ParameterTypeIdFabricSheetMajorStartOverhang Property

"Major Start Overhang": Major Start Overhang

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricSheetMajorStartOverhang { get; }
Public Shared ReadOnly Property FabricSheetMajorStartOverhang As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricSheetMajorStartOverhang {
    ForgeTypeId^ get ();
}
static member FabricSheetMajorStartOverhang : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricSheetMass Property

ParameterTypeIdFabricSheetMass Property

"Sheet Mass": Sheet Mass

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricSheetMass { get; }
Public Shared ReadOnly Property FabricSheetMass As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricSheetMass {
    ForgeTypeId^ get ();
}
static member FabricSheetMass : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricSheetMassunit Property

ParameterTypeIdFabricSheetMassunit Property

"Sheet Mass per Unit Area": Structural Sheet Mass per Unit Area [Sheet Mass / (Overall Length * Overall Width)]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricSheetMassunit { get; }
Public Shared ReadOnly Property FabricSheetMassunit As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricSheetMassunit {
    ForgeTypeId^ get ();
}
static member FabricSheetMassunit : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricSheetMinorDirectionWireType Property

ParameterTypeIdFabricSheetMinorDirectionWireType Property

"Minor Direction Wire Type": Minor Direction Wire Type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricSheetMinorDirectionWireType { get; }
Public Shared ReadOnly Property FabricSheetMinorDirectionWireType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricSheetMinorDirectionWireType {
    ForgeTypeId^ get ();
}
static member FabricSheetMinorDirectionWireType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricSheetMinorEndOverhang Property

ParameterTypeIdFabricSheetMinorEndOverhang Property

"Minor End Overhang": Minor End Overhang

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricSheetMinorEndOverhang { get; }
Public Shared ReadOnly Property FabricSheetMinorEndOverhang As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricSheetMinorEndOverhang {
    ForgeTypeId^ get ();
}
static member FabricSheetMinorEndOverhang : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricSheetMinorLayoutPattern Property

ParameterTypeIdFabricSheetMinorLayoutPattern Property

"Minor Layout Pattern": Minor Layout Pattern

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricSheetMinorLayoutPattern { get; }
Public Shared ReadOnly Property FabricSheetMinorLayoutPattern As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricSheetMinorLayoutPattern {
    ForgeTypeId^ get ();
}
static member FabricSheetMinorLayoutPattern : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricSheetMinorNumberOfWires Property

ParameterTypeIdFabricSheetMinorNumberOfWires Property

"Minor Number of Wires": Minor Number of Wires

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricSheetMinorNumberOfWires { get; }
Public Shared ReadOnly Property FabricSheetMinorNumberOfWires As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricSheetMinorNumberOfWires {
    ForgeTypeId^ get ();
}
static member FabricSheetMinorNumberOfWires : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricSheetMinorReinforcementArea Property

ParameterTypeIdFabricSheetMinorReinforcementArea Property

"Minor Reinforcement Area": Minor Reinforcement Area

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricSheetMinorReinforcementArea { get; }
Public Shared ReadOnly Property FabricSheetMinorReinforcementArea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricSheetMinorReinforcementArea {
    ForgeTypeId^ get ();
}
static member FabricSheetMinorReinforcementArea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricSheetMinorSpacing Property

ParameterTypeIdFabricSheetMinorSpacing Property

"Minor Spacing": Minor Spacing

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricSheetMinorSpacing { get; }
Public Shared ReadOnly Property FabricSheetMinorSpacing As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricSheetMinorSpacing {
    ForgeTypeId^ get ();
}
static member FabricSheetMinorSpacing : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricSheetMinorStartOverhang Property

ParameterTypeIdFabricSheetMinorStartOverhang Property

"Minor Start Overhang": Minor Start Overhang

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricSheetMinorStartOverhang { get; }
Public Shared ReadOnly Property FabricSheetMinorStartOverhang As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricSheetMinorStartOverhang {
    ForgeTypeId^ get ();
}
static member FabricSheetMinorStartOverhang : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricSheetOverallLength Property

ParameterTypeIdFabricSheetOverallLength Property

"Overall Length": Overall Length

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricSheetOverallLength { get; }
Public Shared ReadOnly Property FabricSheetOverallLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricSheetOverallLength {
    ForgeTypeId^ get ();
}
static member FabricSheetOverallLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricSheetOverallWidth Property

ParameterTypeIdFabricSheetOverallWidth Property

"Overall Width": Overall Width

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricSheetOverallWidth { get; }
Public Shared ReadOnly Property FabricSheetOverallWidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricSheetOverallWidth {
    ForgeTypeId^ get ();
}
static member FabricSheetOverallWidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricSheetPhysicalMaterialAsset Property

ParameterTypeIdFabricSheetPhysicalMaterialAsset Property

"Physical Material Asset": Physical Material Asset

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricSheetPhysicalMaterialAsset { get; }
Public Shared ReadOnly Property FabricSheetPhysicalMaterialAsset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricSheetPhysicalMaterialAsset {
    ForgeTypeId^ get ();
}
static member FabricSheetPhysicalMaterialAsset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricSheetWidth Property

ParameterTypeIdFabricSheetWidth Property

"Width": Width

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricSheetWidth { get; }
Public Shared ReadOnly Property FabricSheetWidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricSheetWidth {
    ForgeTypeId^ get ();
}
static member FabricSheetWidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricWireDiameter Property

ParameterTypeIdFabricWireDiameter Property

"Nominal Diameter": Nominal Diameter of Fabric Wire.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricWireDiameter { get; }
Public Shared ReadOnly Property FabricWireDiameter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricWireDiameter {
    ForgeTypeId^ get ();
}
static member FabricWireDiameter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricWireDistance Property

ParameterTypeIdFabricWireDistance Property

"Wire distance": The distance between wires

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricWireDistance { get; }
Public Shared ReadOnly Property FabricWireDistance As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricWireDistance {
    ForgeTypeId^ get ();
}
static member FabricWireDistance : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricWireLength Property

ParameterTypeIdFabricWireLength Property

"Wire length": The wire length

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricWireLength { get; }
Public Shared ReadOnly Property FabricWireLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricWireLength {
    ForgeTypeId^ get ();
}
static member FabricWireLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricWireOffset Property

ParameterTypeIdFabricWireOffset Property

"Offset along wire direction": Offset along wire direction

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricWireOffset { get; }
Public Shared ReadOnly Property FabricWireOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricWireOffset {
    ForgeTypeId^ get ();
}
static member FabricWireOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FabricWireType Property

ParameterTypeIdFabricWireType Property

"Wire type": The wire type assigned

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FabricWireType { get; }
Public Shared ReadOnly Property FabricWireType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FabricWireType {
    ForgeTypeId^ get ();
}
static member FabricWireType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FaceroofLevelParam Property

ParameterTypeIdFaceroofLevelParam Property

"Reference Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FaceroofLevelParam { get; }
Public Shared ReadOnly Property FaceroofLevelParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FaceroofLevelParam {
    ForgeTypeId^ get ();
}
static member FaceroofLevelParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FaceroofOffsetParam Property

ParameterTypeIdFaceroofOffsetParam Property

"Level Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FaceroofOffsetParam { get; }
Public Shared ReadOnly Property FaceroofOffsetParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FaceroofOffsetParam {
    ForgeTypeId^ get ();
}
static member FaceroofOffsetParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyAllowCutWithVoids Property

ParameterTypeIdFamilyAllowCutWithVoids Property

"Cut with Voids When Loaded"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyAllowCutWithVoids { get; }
Public Shared ReadOnly Property FamilyAllowCutWithVoids As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyAllowCutWithVoids {
    ForgeTypeId^ get ();
}
static member FamilyAllowCutWithVoids : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyAlwaysVertical Property

ParameterTypeIdFamilyAlwaysVertical Property

"Always vertical"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyAlwaysVertical { get; }
Public Shared ReadOnly Property FamilyAlwaysVertical As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyAlwaysVertical {
    ForgeTypeId^ get ();
}
static member FamilyAlwaysVertical : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyAutojoin Property

ParameterTypeIdFamilyAutojoin Property

"Automatically joins geometry to walls"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyAutojoin { get; }
Public Shared ReadOnly Property FamilyAutojoin As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyAutojoin {
    ForgeTypeId^ get ();
}
static member FamilyAutojoin : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyBaseLevelOffsetParam Property

ParameterTypeIdFamilyBaseLevelOffsetParam Property

"Base Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyBaseLevelOffsetParam { get; }
Public Shared ReadOnly Property FamilyBaseLevelOffsetParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyBaseLevelOffsetParam {
    ForgeTypeId^ get ();
}
static member FamilyBaseLevelOffsetParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyBaseLevelParam Property

ParameterTypeIdFamilyBaseLevelParam Property

"Base Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyBaseLevelParam { get; }
Public Shared ReadOnly Property FamilyBaseLevelParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyBaseLevelParam {
    ForgeTypeId^ get ();
}
static member FamilyBaseLevelParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyCanHostRebar Property

ParameterTypeIdFamilyCanHostRebar Property

"Can host rebar"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyCanHostRebar { get; }
Public Shared ReadOnly Property FamilyCanHostRebar As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyCanHostRebar {
    ForgeTypeId^ get ();
}
static member FamilyCanHostRebar : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyCategoryPseudoParam Property

ParameterTypeIdFamilyCategoryPseudoParam Property

"Category"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyCategoryPseudoParam { get; }
Public Shared ReadOnly Property FamilyCategoryPseudoParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyCategoryPseudoParam {
    ForgeTypeId^ get ();
}
static member FamilyCategoryPseudoParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyContentPartType Property

ParameterTypeIdFamilyContentPartType Property

"Part Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyContentPartType { get; }
Public Shared ReadOnly Property FamilyContentPartType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyContentPartType {
    ForgeTypeId^ get ();
}
static member FamilyContentPartType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyCurveAttachmentProportion Property

ParameterTypeIdFamilyCurveAttachmentProportion Property

"Attachment Point"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyCurveAttachmentProportion { get; }
Public Shared ReadOnly Property FamilyCurveAttachmentProportion As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyCurveAttachmentProportion {
    ForgeTypeId^ get ();
}
static member FamilyCurveAttachmentProportion : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyCurveGstyleFor2010Mass Property

ParameterTypeIdFamilyCurveGstyleFor2010Mass Property

"Subcategory"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyCurveGstyleFor2010Mass { get; }
Public Shared ReadOnly Property FamilyCurveGstyleFor2010Mass As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyCurveGstyleFor2010Mass {
    ForgeTypeId^ get ();
}
static member FamilyCurveGstyleFor2010Mass : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyCurveGstylePlusInvisible Property

ParameterTypeIdFamilyCurveGstylePlusInvisible Property

"Subcategory"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyCurveGstylePlusInvisible { get; }
Public Shared ReadOnly Property FamilyCurveGstylePlusInvisible As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyCurveGstylePlusInvisible {
    ForgeTypeId^ get ();
}
static member FamilyCurveGstylePlusInvisible : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyCurveGstylePlusInvisibleMinusAnalytical Property

ParameterTypeIdFamilyCurveGstylePlusInvisibleMinusAnalytical Property

"Subcategory"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyCurveGstylePlusInvisibleMinusAnalytical { get; }
Public Shared ReadOnly Property FamilyCurveGstylePlusInvisibleMinusAnalytical As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyCurveGstylePlusInvisibleMinusAnalytical {
    ForgeTypeId^ get ();
}
static member FamilyCurveGstylePlusInvisibleMinusAnalytical : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyCurveGstylePlusInvisiblePlusStickSym Property

ParameterTypeIdFamilyCurveGstylePlusInvisiblePlusStickSym Property

"Subcategory"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyCurveGstylePlusInvisiblePlusStickSym { get; }
Public Shared ReadOnly Property FamilyCurveGstylePlusInvisiblePlusStickSym As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyCurveGstylePlusInvisiblePlusStickSym {
    ForgeTypeId^ get ();
}
static member FamilyCurveGstylePlusInvisiblePlusStickSym : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyCurveGstylePlusInvisiblePlusStickSymMinusAnalytical Property

ParameterTypeIdFamilyCurveGstylePlusInvisiblePlusStickSymMinusAnalytical Property

"Subcategory"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyCurveGstylePlusInvisiblePlusStickSymMinusAnalytical { get; }
Public Shared ReadOnly Property FamilyCurveGstylePlusInvisiblePlusStickSymMinusAnalytical As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyCurveGstylePlusInvisiblePlusStickSymMinusAnalytical {
    ForgeTypeId^ get ();
}
static member FamilyCurveGstylePlusInvisiblePlusStickSymMinusAnalytical : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyElectricalMaintainAnnotationOrientation Property

ParameterTypeIdFamilyElectricalMaintainAnnotationOrientation Property

"Maintain Annotation Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyElectricalMaintainAnnotationOrientation { get; }
Public Shared ReadOnly Property FamilyElectricalMaintainAnnotationOrientation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyElectricalMaintainAnnotationOrientation {
    ForgeTypeId^ get ();
}
static member FamilyElectricalMaintainAnnotationOrientation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyElemSubcategory Property

ParameterTypeIdFamilyElemSubcategory Property

"Subcategory"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyElemSubcategory { get; }
Public Shared ReadOnly Property FamilyElemSubcategory As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyElemSubcategory {
    ForgeTypeId^ get ();
}
static member FamilyElemSubcategory : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyEnableCuttingInViews Property

ParameterTypeIdFamilyEnableCuttingInViews Property

"Enable Cutting in Views"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyEnableCuttingInViews { get; }
Public Shared ReadOnly Property FamilyEnableCuttingInViews As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyEnableCuttingInViews {
    ForgeTypeId^ get ();
}
static member FamilyEnableCuttingInViews : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyExportAsGeometry Property

ParameterTypeIdFamilyExportAsGeometry Property

"Always export as geometry"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyExportAsGeometry { get; }
Public Shared ReadOnly Property FamilyExportAsGeometry As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyExportAsGeometry {
    ForgeTypeId^ get ();
}
static member FamilyExportAsGeometry : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyFreeinstDefaultElevation Property

ParameterTypeIdFamilyFreeinstDefaultElevation Property

"Default Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyFreeinstDefaultElevation { get; }
Public Shared ReadOnly Property FamilyFreeinstDefaultElevation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyFreeinstDefaultElevation {
    ForgeTypeId^ get ();
}
static member FamilyFreeinstDefaultElevation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyHeightParam Property

ParameterTypeIdFamilyHeightParam Property

"Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyHeightParam { get; }
Public Shared ReadOnly Property FamilyHeightParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyHeightParam {
    ForgeTypeId^ get ();
}
static member FamilyHeightParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyHostingBehavior Property

ParameterTypeIdFamilyHostingBehavior Property

"Host"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyHostingBehavior { get; }
Public Shared ReadOnly Property FamilyHostingBehavior As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyHostingBehavior {
    ForgeTypeId^ get ();
}
static member FamilyHostingBehavior : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyIsElevationMarkBody Property

ParameterTypeIdFamilyIsElevationMarkBody Property

"Elevation Mark Use"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyIsElevationMarkBody { get; }
Public Shared ReadOnly Property FamilyIsElevationMarkBody As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyIsElevationMarkBody {
    ForgeTypeId^ get ();
}
static member FamilyIsElevationMarkBody : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyIsParametric Property

ParameterTypeIdFamilyIsParametric Property

"Is parametric"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyIsParametric { get; }
Public Shared ReadOnly Property FamilyIsParametric As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyIsParametric {
    ForgeTypeId^ get ();
}
static member FamilyIsParametric : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyKeepTextReadable Property

ParameterTypeIdFamilyKeepTextReadable Property

"Keep text readable"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyKeepTextReadable { get; }
Public Shared ReadOnly Property FamilyKeepTextReadable As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyKeepTextReadable {
    ForgeTypeId^ get ();
}
static member FamilyKeepTextReadable : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyKeyExtParam Property

ParameterTypeIdFamilyKeyExtParam Property

"Filter Parameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyKeyExtParam { get; }
Public Shared ReadOnly Property FamilyKeyExtParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyKeyExtParam {
    ForgeTypeId^ get ();
}
static member FamilyKeyExtParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyKeywordProtected Property

ParameterTypeIdFamilyKeywordProtected Property

"Content protection enabled"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyKeywordProtected { get; }
Public Shared ReadOnly Property FamilyKeywordProtected As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyKeywordProtected {
    ForgeTypeId^ get ();
}
static member FamilyKeywordProtected : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyLevelParam Property

ParameterTypeIdFamilyLevelParam Property

"Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyLevelParam { get; }
Public Shared ReadOnly Property FamilyLevelParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyLevelParam {
    ForgeTypeId^ get ();
}
static member FamilyLevelParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyLineLengthParam Property

ParameterTypeIdFamilyLineLengthParam Property

"Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyLineLengthParam { get; }
Public Shared ReadOnly Property FamilyLineLengthParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyLineLengthParam {
    ForgeTypeId^ get ();
}
static member FamilyLineLengthParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyNamePseudoParam Property

ParameterTypeIdFamilyNamePseudoParam Property

"Family"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyNamePseudoParam { get; }
Public Shared ReadOnly Property FamilyNamePseudoParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyNamePseudoParam {
    ForgeTypeId^ get ();
}
static member FamilyNamePseudoParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyNestingBehavior Property

ParameterTypeIdFamilyNestingBehavior Property

"Family Nesting Behavior"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyNestingBehavior { get; }
Public Shared ReadOnly Property FamilyNestingBehavior As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyNestingBehavior {
    ForgeTypeId^ get ();
}
static member FamilyNestingBehavior : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyRenderingType Property

ParameterTypeIdFamilyRenderingType Property

"Render Appearance Source"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyRenderingType { get; }
Public Shared ReadOnly Property FamilyRenderingType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyRenderingType {
    ForgeTypeId^ get ();
}
static member FamilyRenderingType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyRfaPathPseudoParam Property

ParameterTypeIdFamilyRfaPathPseudoParam Property

"File Path"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyRfaPathPseudoParam { get; }
Public Shared ReadOnly Property FamilyRfaPathPseudoParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyRfaPathPseudoParam {
    ForgeTypeId^ get ();
}
static member FamilyRfaPathPseudoParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyRotateTextWithComponent Property

ParameterTypeIdFamilyRotateTextWithComponent Property

"Rotate text with component"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyRotateTextWithComponent { get; }
Public Shared ReadOnly Property FamilyRotateTextWithComponent As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyRotateTextWithComponent {
    ForgeTypeId^ get ();
}
static member FamilyRotateTextWithComponent : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyRotateWithComponent Property

ParameterTypeIdFamilyRotateWithComponent Property

"Rotate with component"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyRotateWithComponent { get; }
Public Shared ReadOnly Property FamilyRotateWithComponent As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyRotateWithComponent {
    ForgeTypeId^ get ();
}
static member FamilyRotateWithComponent : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyRoughHeightParam Property

ParameterTypeIdFamilyRoughHeightParam Property

"Rough Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyRoughHeightParam { get; }
Public Shared ReadOnly Property FamilyRoughHeightParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyRoughHeightParam {
    ForgeTypeId^ get ();
}
static member FamilyRoughHeightParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyRoughWidthParam Property

ParameterTypeIdFamilyRoughWidthParam Property

"Rough Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyRoughWidthParam { get; }
Public Shared ReadOnly Property FamilyRoughWidthParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyRoughWidthParam {
    ForgeTypeId^ get ();
}
static member FamilyRoughWidthParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyRoundconnectorDimensiontype Property

ParameterTypeIdFamilyRoundconnectorDimensiontype Property

"Round Connector Dimension"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyRoundconnectorDimensiontype { get; }
Public Shared ReadOnly Property FamilyRoundconnectorDimensiontype As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyRoundconnectorDimensiontype {
    ForgeTypeId^ get ();
}
static member FamilyRoundconnectorDimensiontype : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilySelfOrienting Property

ParameterTypeIdFamilySelfOrienting Property

"Align to View"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilySelfOrienting { get; }
Public Shared ReadOnly Property FamilySelfOrienting As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilySelfOrienting {
    ForgeTypeId^ get ();
}
static member FamilySelfOrienting : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyShared Property

ParameterTypeIdFamilyShared Property

"Shared"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyShared { get; }
Public Shared ReadOnly Property FamilyShared As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyShared {
    ForgeTypeId^ get ();
}
static member FamilyShared : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyStructFootingUseCapTop Property

ParameterTypeIdFamilyStructFootingUseCapTop Property

"Cap"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyStructFootingUseCapTop { get; }
Public Shared ReadOnly Property FamilyStructFootingUseCapTop As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyStructFootingUseCapTop {
    ForgeTypeId^ get ();
}
static member FamilyStructFootingUseCapTop : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyStructMaterialType Property

ParameterTypeIdFamilyStructMaterialType Property

"Material for Model Behavior"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyStructMaterialType { get; }
Public Shared ReadOnly Property FamilyStructMaterialType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyStructMaterialType {
    ForgeTypeId^ get ();
}
static member FamilyStructMaterialType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilySymbolicRep Property

ParameterTypeIdFamilySymbolicRep Property

"Symbolic Representation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilySymbolicRep { get; }
Public Shared ReadOnly Property FamilySymbolicRep As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilySymbolicRep {
    ForgeTypeId^ get ();
}
static member FamilySymbolicRep : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyThicknessParam Property

ParameterTypeIdFamilyThicknessParam Property

"Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyThicknessParam { get; }
Public Shared ReadOnly Property FamilyThicknessParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyThicknessParam {
    ForgeTypeId^ get ();
}
static member FamilyThicknessParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyTopLevelOffsetParam Property

ParameterTypeIdFamilyTopLevelOffsetParam Property

"Top Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyTopLevelOffsetParam { get; }
Public Shared ReadOnly Property FamilyTopLevelOffsetParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyTopLevelOffsetParam {
    ForgeTypeId^ get ();
}
static member FamilyTopLevelOffsetParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyTopLevelParam Property

ParameterTypeIdFamilyTopLevelParam Property

"Top Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyTopLevelParam { get; }
Public Shared ReadOnly Property FamilyTopLevelParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyTopLevelParam {
    ForgeTypeId^ get ();
}
static member FamilyTopLevelParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyUsagePseudoParam Property

ParameterTypeIdFamilyUsagePseudoParam Property

"Usage"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyUsagePseudoParam { get; }
Public Shared ReadOnly Property FamilyUsagePseudoParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyUsagePseudoParam {
    ForgeTypeId^ get ();
}
static member FamilyUsagePseudoParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyUsePrecutShape Property

ParameterTypeIdFamilyUsePrecutShape Property

"Show family pre-cut in plan views"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyUsePrecutShape { get; }
Public Shared ReadOnly Property FamilyUsePrecutShape As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyUsePrecutShape {
    ForgeTypeId^ get ();
}
static member FamilyUsePrecutShape : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyUsingMultiple Property

ParameterTypeIdFamilyUsingMultiple Property

"Multiple Join"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyUsingMultiple { get; }
Public Shared ReadOnly Property FamilyUsingMultiple As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyUsingMultiple {
    ForgeTypeId^ get ();
}
static member FamilyUsingMultiple : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyWidthParam Property

ParameterTypeIdFamilyWidthParam Property

"Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyWidthParam { get; }
Public Shared ReadOnly Property FamilyWidthParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyWidthParam {
    ForgeTypeId^ get ();
}
static member FamilyWidthParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyWindowInsetParam Property

ParameterTypeIdFamilyWindowInsetParam Property

"Inset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyWindowInsetParam { get; }
Public Shared ReadOnly Property FamilyWindowInsetParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyWindowInsetParam {
    ForgeTypeId^ get ();
}
static member FamilyWindowInsetParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyWorkPlaneBased Property

ParameterTypeIdFamilyWorkPlaneBased Property

"Work Plane-Based"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyWorkPlaneBased { get; }
Public Shared ReadOnly Property FamilyWorkPlaneBased As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyWorkPlaneBased {
    ForgeTypeId^ get ();
}
static member FamilyWorkPlaneBased : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamilyWpbDefaultElevation Property

ParameterTypeIdFamilyWpbDefaultElevation Property

"Default Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamilyWpbDefaultElevation { get; }
Public Shared ReadOnly Property FamilyWpbDefaultElevation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamilyWpbDefaultElevation {
    ForgeTypeId^ get ();
}
static member FamilyWpbDefaultElevation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamProfileDefinition Property

ParameterTypeIdFamProfileDefinition Property

"Profile Definition"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamProfileDefinition { get; }
Public Shared ReadOnly Property FamProfileDefinition As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamProfileDefinition {
    ForgeTypeId^ get ();
}
static member FamProfileDefinition : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FamProfileUsage Property

ParameterTypeIdFamProfileUsage Property

"Profile Usage"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FamProfileUsage { get; }
Public Shared ReadOnly Property FamProfileUsage As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FamProfileUsage {
    ForgeTypeId^ get ();
}
static member FamProfileUsage : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FasciaDepthParam Property

ParameterTypeIdFasciaDepthParam Property

"Fascia Depth"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FasciaDepthParam { get; }
Public Shared ReadOnly Property FasciaDepthParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FasciaDepthParam {
    ForgeTypeId^ get ();
}
static member FasciaDepthParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FasciaMaterialParam Property

ParameterTypeIdFasciaMaterialParam Property

"Material"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FasciaMaterialParam { get; }
Public Shared ReadOnly Property FasciaMaterialParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FasciaMaterialParam {
    ForgeTypeId^ get ();
}
static member FasciaMaterialParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FasciaProfileParam Property

ParameterTypeIdFasciaProfileParam Property

"Profile"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FasciaProfileParam { get; }
Public Shared ReadOnly Property FasciaProfileParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FasciaProfileParam {
    ForgeTypeId^ get ();
}
static member FasciaProfileParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FbxAssetType Property

ParameterTypeIdFbxAssetType Property

"Light Source"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FbxAssetType { get; }
Public Shared ReadOnly Property FbxAssetType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FbxAssetType {
    ForgeTypeId^ get ();
}
static member FbxAssetType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FbxLightAtADistance Property

ParameterTypeIdFbxLightAtADistance Property

"At a distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FbxLightAtADistance { get; }
Public Shared ReadOnly Property FbxLightAtADistance As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FbxLightAtADistance {
    ForgeTypeId^ get ();
}
static member FbxLightAtADistance : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FbxLightBallastLoss Property

ParameterTypeIdFbxLightBallastLoss Property

"Ballast Loss"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FbxLightBallastLoss { get; }
Public Shared ReadOnly Property FbxLightBallastLoss As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FbxLightBallastLoss {
    ForgeTypeId^ get ();
}
static member FbxLightBallastLoss : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FbxLightColorFilter Property

ParameterTypeIdFbxLightColorFilter Property

"Color Filter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FbxLightColorFilter { get; }
Public Shared ReadOnly Property FbxLightColorFilter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FbxLightColorFilter {
    ForgeTypeId^ get ();
}
static member FbxLightColorFilter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FbxLightDimmingLightColor Property

ParameterTypeIdFbxLightDimmingLightColor Property

"Dimming Lamp Color Temperature Shift"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FbxLightDimmingLightColor { get; }
Public Shared ReadOnly Property FbxLightDimmingLightColor As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FbxLightDimmingLightColor {
    ForgeTypeId^ get ();
}
static member FbxLightDimmingLightColor : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FbxLightEfficacy Property

ParameterTypeIdFbxLightEfficacy Property

"Efficacy"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FbxLightEfficacy { get; }
Public Shared ReadOnly Property FbxLightEfficacy As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FbxLightEfficacy {
    ForgeTypeId^ get ();
}
static member FbxLightEfficacy : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FbxLightEmitCircleDiameter Property

ParameterTypeIdFbxLightEmitCircleDiameter Property

"Emit from Circle Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FbxLightEmitCircleDiameter { get; }
Public Shared ReadOnly Property FbxLightEmitCircleDiameter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FbxLightEmitCircleDiameter {
    ForgeTypeId^ get ();
}
static member FbxLightEmitCircleDiameter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FbxLightEmitLineLength Property

ParameterTypeIdFbxLightEmitLineLength Property

"Emit from Line Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FbxLightEmitLineLength { get; }
Public Shared ReadOnly Property FbxLightEmitLineLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FbxLightEmitLineLength {
    ForgeTypeId^ get ();
}
static member FbxLightEmitLineLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FbxLightEmitRectangleLength Property

ParameterTypeIdFbxLightEmitRectangleLength Property

"Emit from Rectangle Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FbxLightEmitRectangleLength { get; }
Public Shared ReadOnly Property FbxLightEmitRectangleLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FbxLightEmitRectangleLength {
    ForgeTypeId^ get ();
}
static member FbxLightEmitRectangleLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FbxLightEmitRectangleWidth Property

ParameterTypeIdFbxLightEmitRectangleWidth Property

"Emit from Rectangle Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FbxLightEmitRectangleWidth { get; }
Public Shared ReadOnly Property FbxLightEmitRectangleWidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FbxLightEmitRectangleWidth {
    ForgeTypeId^ get ();
}
static member FbxLightEmitRectangleWidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FbxLightEmitShapeVisible Property

ParameterTypeIdFbxLightEmitShapeVisible Property

"Emit Shape Visible in Rendering"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FbxLightEmitShapeVisible { get; }
Public Shared ReadOnly Property FbxLightEmitShapeVisible As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FbxLightEmitShapeVisible {
    ForgeTypeId^ get ();
}
static member FbxLightEmitShapeVisible : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FbxLightIlluminance Property

ParameterTypeIdFbxLightIlluminance Property

"Illuminance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FbxLightIlluminance { get; }
Public Shared ReadOnly Property FbxLightIlluminance As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FbxLightIlluminance {
    ForgeTypeId^ get ();
}
static member FbxLightIlluminance : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FbxLightInitialColorCtrl Property

ParameterTypeIdFbxLightInitialColorCtrl Property

"Initial Color"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FbxLightInitialColorCtrl { get; }
Public Shared ReadOnly Property FbxLightInitialColorCtrl As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FbxLightInitialColorCtrl {
    ForgeTypeId^ get ();
}
static member FbxLightInitialColorCtrl : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FbxLightInitialColorName Property

ParameterTypeIdFbxLightInitialColorName Property

"Temperature Color"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FbxLightInitialColorName { get; }
Public Shared ReadOnly Property FbxLightInitialColorName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FbxLightInitialColorName {
    ForgeTypeId^ get ();
}
static member FbxLightInitialColorName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FbxLightInitialColorTemperature Property

ParameterTypeIdFbxLightInitialColorTemperature Property

"Initial Color Temperature"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FbxLightInitialColorTemperature { get; }
Public Shared ReadOnly Property FbxLightInitialColorTemperature As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FbxLightInitialColorTemperature {
    ForgeTypeId^ get ();
}
static member FbxLightInitialColorTemperature : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FbxLightInitialIntensity Property

ParameterTypeIdFbxLightInitialIntensity Property

"Initial Intensity"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FbxLightInitialIntensity { get; }
Public Shared ReadOnly Property FbxLightInitialIntensity As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FbxLightInitialIntensity {
    ForgeTypeId^ get ();
}
static member FbxLightInitialIntensity : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FbxLightInitialIntensityInputMethod Property

ParameterTypeIdFbxLightInitialIntensityInputMethod Property

"Initial Light Intensity Input Method"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FbxLightInitialIntensityInputMethod { get; }
Public Shared ReadOnly Property FbxLightInitialIntensityInputMethod As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FbxLightInitialIntensityInputMethod {
    ForgeTypeId^ get ();
}
static member FbxLightInitialIntensityInputMethod : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FbxLightLampLumenDepr Property

ParameterTypeIdFbxLightLampLumenDepr Property

"Lamp Lumen Depreciation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FbxLightLampLumenDepr { get; }
Public Shared ReadOnly Property FbxLightLampLumenDepr As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FbxLightLampLumenDepr {
    ForgeTypeId^ get ();
}
static member FbxLightLampLumenDepr : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FbxLightLampTiltLoss Property

ParameterTypeIdFbxLightLampTiltLoss Property

"Lamp Tilt Loss"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FbxLightLampTiltLoss { get; }
Public Shared ReadOnly Property FbxLightLampTiltLoss As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FbxLightLampTiltLoss {
    ForgeTypeId^ get ();
}
static member FbxLightLampTiltLoss : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FbxLightLimunousFlux Property

ParameterTypeIdFbxLightLimunousFlux Property

"Luminous Flux"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FbxLightLimunousFlux { get; }
Public Shared ReadOnly Property FbxLightLimunousFlux As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FbxLightLimunousFlux {
    ForgeTypeId^ get ();
}
static member FbxLightLimunousFlux : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FbxLightLimunousIntensity Property

ParameterTypeIdFbxLightLimunousIntensity Property

"Luminous Intensity"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FbxLightLimunousIntensity { get; }
Public Shared ReadOnly Property FbxLightLimunousIntensity As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FbxLightLimunousIntensity {
    ForgeTypeId^ get ();
}
static member FbxLightLimunousIntensity : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FbxLightLossFactorCtrl Property

ParameterTypeIdFbxLightLossFactorCtrl Property

"Light Loss Factor"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FbxLightLossFactorCtrl { get; }
Public Shared ReadOnly Property FbxLightLossFactorCtrl As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FbxLightLossFactorCtrl {
    ForgeTypeId^ get ();
}
static member FbxLightLossFactorCtrl : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FbxLightLossFactorMethod Property

ParameterTypeIdFbxLightLossFactorMethod Property

"Light Loss Input Method"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FbxLightLossFactorMethod { get; }
Public Shared ReadOnly Property FbxLightLossFactorMethod As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FbxLightLossFactorMethod {
    ForgeTypeId^ get ();
}
static member FbxLightLossFactorMethod : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FbxLightLumenaireDirt Property

ParameterTypeIdFbxLightLumenaireDirt Property

"Luminaire Dirt Depreciation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FbxLightLumenaireDirt { get; }
Public Shared ReadOnly Property FbxLightLumenaireDirt As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FbxLightLumenaireDirt {
    ForgeTypeId^ get ();
}
static member FbxLightLumenaireDirt : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FbxLightPhotometricFile Property

ParameterTypeIdFbxLightPhotometricFile Property

"Photometric Web File"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FbxLightPhotometricFile { get; }
Public Shared ReadOnly Property FbxLightPhotometricFile As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FbxLightPhotometricFile {
    ForgeTypeId^ get ();
}
static member FbxLightPhotometricFile : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FbxLightPhotometricFileCache Property

ParameterTypeIdFbxLightPhotometricFileCache Property

"None"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FbxLightPhotometricFileCache { get; }
Public Shared ReadOnly Property FbxLightPhotometricFileCache As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FbxLightPhotometricFileCache {
    ForgeTypeId^ get ();
}
static member FbxLightPhotometricFileCache : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FbxLightPhotometrics Property

ParameterTypeIdFbxLightPhotometrics Property

"Light Source Definition"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FbxLightPhotometrics { get; }
Public Shared ReadOnly Property FbxLightPhotometrics As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FbxLightPhotometrics {
    ForgeTypeId^ get ();
}
static member FbxLightPhotometrics : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FbxLightPhotometricsFam Property

ParameterTypeIdFbxLightPhotometricsFam Property

"Light Source Definition (family)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FbxLightPhotometricsFam { get; }
Public Shared ReadOnly Property FbxLightPhotometricsFam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FbxLightPhotometricsFam {
    ForgeTypeId^ get ();
}
static member FbxLightPhotometricsFam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FbxLightSourceDiameter Property

ParameterTypeIdFbxLightSourceDiameter Property

"Light Source Symbol Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FbxLightSourceDiameter { get; }
Public Shared ReadOnly Property FbxLightSourceDiameter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FbxLightSourceDiameter {
    ForgeTypeId^ get ();
}
static member FbxLightSourceDiameter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FbxLightSourceLength Property

ParameterTypeIdFbxLightSourceLength Property

"Light Source Symbol Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FbxLightSourceLength { get; }
Public Shared ReadOnly Property FbxLightSourceLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FbxLightSourceLength {
    ForgeTypeId^ get ();
}
static member FbxLightSourceLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FbxLightSpotBeamAngle Property

ParameterTypeIdFbxLightSpotBeamAngle Property

"Spot Beam Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FbxLightSpotBeamAngle { get; }
Public Shared ReadOnly Property FbxLightSpotBeamAngle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FbxLightSpotBeamAngle {
    ForgeTypeId^ get ();
}
static member FbxLightSpotBeamAngle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FbxLightSpotFieldAngle Property

ParameterTypeIdFbxLightSpotFieldAngle Property

"Spot Field Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FbxLightSpotFieldAngle { get; }
Public Shared ReadOnly Property FbxLightSpotFieldAngle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FbxLightSpotFieldAngle {
    ForgeTypeId^ get ();
}
static member FbxLightSpotFieldAngle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FbxLightSpotTiltAngle Property

ParameterTypeIdFbxLightSpotTiltAngle Property

"Tilt Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FbxLightSpotTiltAngle { get; }
Public Shared ReadOnly Property FbxLightSpotTiltAngle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FbxLightSpotTiltAngle {
    ForgeTypeId^ get ();
}
static member FbxLightSpotTiltAngle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FbxLightSurfaceLoss Property

ParameterTypeIdFbxLightSurfaceLoss Property

"Surface Depreciation Loss"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FbxLightSurfaceLoss { get; }
Public Shared ReadOnly Property FbxLightSurfaceLoss As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FbxLightSurfaceLoss {
    ForgeTypeId^ get ();
}
static member FbxLightSurfaceLoss : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FbxLightTemperatureLoss Property

ParameterTypeIdFbxLightTemperatureLoss Property

"Temperature Loss"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FbxLightTemperatureLoss { get; }
Public Shared ReadOnly Property FbxLightTemperatureLoss As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FbxLightTemperatureLoss {
    ForgeTypeId^ get ();
}
static member FbxLightTemperatureLoss : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FbxLightTotalLightLoss Property

ParameterTypeIdFbxLightTotalLightLoss Property

"Total Light Loss Factor"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FbxLightTotalLightLoss { get; }
Public Shared ReadOnly Property FbxLightTotalLightLoss As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FbxLightTotalLightLoss {
    ForgeTypeId^ get ();
}
static member FbxLightTotalLightLoss : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FbxLightVoltageLoss Property

ParameterTypeIdFbxLightVoltageLoss Property

"Voltage Loss"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FbxLightVoltageLoss { get; }
Public Shared ReadOnly Property FbxLightVoltageLoss As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FbxLightVoltageLoss {
    ForgeTypeId^ get ();
}
static member FbxLightVoltageLoss : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FbxLightWattage Property

ParameterTypeIdFbxLightWattage Property

"Wattage"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FbxLightWattage { get; }
Public Shared ReadOnly Property FbxLightWattage As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FbxLightWattage {
    ForgeTypeId^ get ();
}
static member FbxLightWattage : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FilledRegionMasking Property

ParameterTypeIdFilledRegionMasking Property

"Masking"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FilledRegionMasking { get; }
Public Shared ReadOnly Property FilledRegionMasking As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FilledRegionMasking {
    ForgeTypeId^ get ();
}
static member FilledRegionMasking : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FillPatternIdParam Property

ParameterTypeIdFillPatternIdParam Property

"Cut fill pattern"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FillPatternIdParam { get; }
Public Shared ReadOnly Property FillPatternIdParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FillPatternIdParam {
    ForgeTypeId^ get ();
}
static member FillPatternIdParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FillPatternIdParamNoNo Property

ParameterTypeIdFillPatternIdParamNoNo Property

"Fill Pattern"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FillPatternIdParamNoNo { get; }
Public Shared ReadOnly Property FillPatternIdParamNoNo As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FillPatternIdParamNoNo {
    ForgeTypeId^ get ();
}
static member FillPatternIdParamNoNo : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FireRating Property

ParameterTypeIdFireRating Property

"Fire Rating"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FireRating { get; }
Public Shared ReadOnly Property FireRating As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FireRating {
    ForgeTypeId^ get ();
}
static member FireRating : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FixedRotation Property

ParameterTypeIdFixedRotation Property

"Fixed Rotation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FixedRotation { get; }
Public Shared ReadOnly Property FixedRotation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FixedRotation {
    ForgeTypeId^ get ();
}
static member FixedRotation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FlexibleInstanceFlip Property

ParameterTypeIdFlexibleInstanceFlip Property

"Flip"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FlexibleInstanceFlip { get; }
Public Shared ReadOnly Property FlexibleInstanceFlip As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FlexibleInstanceFlip {
    ForgeTypeId^ get ();
}
static member FlexibleInstanceFlip : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FloorAttrDefaultHeightParam Property

ParameterTypeIdFloorAttrDefaultHeightParam Property

"Default Height above level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FloorAttrDefaultHeightParam { get; }
Public Shared ReadOnly Property FloorAttrDefaultHeightParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FloorAttrDefaultHeightParam {
    ForgeTypeId^ get ();
}
static member FloorAttrDefaultHeightParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FloorAttrDefaultThicknessParam Property

ParameterTypeIdFloorAttrDefaultThicknessParam Property

"Default Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FloorAttrDefaultThicknessParam { get; }
Public Shared ReadOnly Property FloorAttrDefaultThicknessParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FloorAttrDefaultThicknessParam {
    ForgeTypeId^ get ();
}
static member FloorAttrDefaultThicknessParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FloorAttrThicknessParam Property

ParameterTypeIdFloorAttrThicknessParam Property

"Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FloorAttrThicknessParam { get; }
Public Shared ReadOnly Property FloorAttrThicknessParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FloorAttrThicknessParam {
    ForgeTypeId^ get ();
}
static member FloorAttrThicknessParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FloorHeightabovelevelParam Property

ParameterTypeIdFloorHeightabovelevelParam Property

"Height Offset From Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FloorHeightabovelevelParam { get; }
Public Shared ReadOnly Property FloorHeightabovelevelParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FloorHeightabovelevelParam {
    ForgeTypeId^ get ();
}
static member FloorHeightabovelevelParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FloorParamIsStructural Property

ParameterTypeIdFloorParamIsStructural Property

"Structural"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FloorParamIsStructural { get; }
Public Shared ReadOnly Property FloorParamIsStructural As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FloorParamIsStructural {
    ForgeTypeId^ get ();
}
static member FloorParamIsStructural : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FloorParamSpanDirection Property

ParameterTypeIdFloorParamSpanDirection Property

"Span Direction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FloorParamSpanDirection { get; }
Public Shared ReadOnly Property FloorParamSpanDirection As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FloorParamSpanDirection {
    ForgeTypeId^ get ();
}
static member FloorParamSpanDirection : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FloorStructureIdParam Property

ParameterTypeIdFloorStructureIdParam Property

"Structure"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FloorStructureIdParam { get; }
Public Shared ReadOnly Property FloorStructureIdParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FloorStructureIdParam {
    ForgeTypeId^ get ();
}
static member FloorStructureIdParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FollowSurface Property

ParameterTypeIdFollowSurface Property

"Follow Surface"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FollowSurface { get; }
Public Shared ReadOnly Property FollowSurface As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FollowSurface {
    ForgeTypeId^ get ();
}
static member FollowSurface : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ForegroundAnyPatternIdParam Property

ParameterTypeIdForegroundAnyPatternIdParam Property

"Foreground Fill Pattern"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ForegroundAnyPatternIdParam { get; }
Public Shared ReadOnly Property ForegroundAnyPatternIdParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ForegroundAnyPatternIdParam {
    ForgeTypeId^ get ();
}
static member ForegroundAnyPatternIdParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ForegroundDraftPatternIdParam Property

ParameterTypeIdForegroundDraftPatternIdParam Property

"Foreground Fill Pattern"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ForegroundDraftPatternIdParam { get; }
Public Shared ReadOnly Property ForegroundDraftPatternIdParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ForegroundDraftPatternIdParam {
    ForgeTypeId^ get ();
}
static member ForegroundDraftPatternIdParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ForegroundPatternColorParam Property

ParameterTypeIdForegroundPatternColorParam Property

"Foreground Pattern Color"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ForegroundPatternColorParam { get; }
Public Shared ReadOnly Property ForegroundPatternColorParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ForegroundPatternColorParam {
    ForgeTypeId^ get ();
}
static member ForegroundPatternColorParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FramingLengthRoundoff Property

ParameterTypeIdFramingLengthRoundoff Property

"Structural Framing Length Roundoff"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FramingLengthRoundoff { get; }
Public Shared ReadOnly Property FramingLengthRoundoff As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FramingLengthRoundoff {
    ForgeTypeId^ get ();
}
static member FramingLengthRoundoff : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FramingShapeClassification Property

ParameterTypeIdFramingShapeClassification Property

"Framing Shape"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FramingShapeClassification { get; }
Public Shared ReadOnly Property FramingShapeClassification As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FramingShapeClassification {
    ForgeTypeId^ get ();
}
static member FramingShapeClassification : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FrictionFactor Property

ParameterTypeIdFrictionFactor Property

"Friction Factor"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FrictionFactor { get; }
Public Shared ReadOnly Property FrictionFactor As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FrictionFactor {
    ForgeTypeId^ get ();
}
static member FrictionFactor : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.FunctionParam Property

ParameterTypeIdFunctionParam Property

"Function"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FunctionParam { get; }
Public Shared ReadOnly Property FunctionParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FunctionParam {
    ForgeTypeId^ get ();
}
static member FunctionParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.GbxmlEditDataParam Property

ParameterTypeIdGbxmlEditDataParam Property

"Energy Settings"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GbxmlEditDataParam { get; }
Public Shared ReadOnly Property GbxmlEditDataParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GbxmlEditDataParam {
    ForgeTypeId^ get ();
}
static member GbxmlEditDataParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.GenericDepth Property

ParameterTypeIdGenericDepth Property

"Depth"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GenericDepth { get; }
Public Shared ReadOnly Property GenericDepth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GenericDepth {
    ForgeTypeId^ get ();
}
static member GenericDepth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.GenericZoneName Property

ParameterTypeIdGenericZoneName Property

"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GenericZoneName { get; }
Public Shared ReadOnly Property GenericZoneName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GenericZoneName {
    ForgeTypeId^ get ();
}
static member GenericZoneName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.GeoLocation Property

ParameterTypeIdGeoLocation Property

"Shared Site"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GeoLocation { get; }
Public Shared ReadOnly Property GeoLocation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GeoLocation {
    ForgeTypeId^ get ();
}
static member GeoLocation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.GeomVisibilityParam Property

ParameterTypeIdGeomVisibilityParam Property

"Visibility/Graphics Overrides"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GeomVisibilityParam { get; }
Public Shared ReadOnly Property GeomVisibilityParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GeomVisibilityParam {
    ForgeTypeId^ get ();
}
static member GeomVisibilityParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.GraphicDisplayOptions Property

ParameterTypeIdGraphicDisplayOptions Property

"Graphic Display Options"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GraphicDisplayOptions { get; }
Public Shared ReadOnly Property GraphicDisplayOptions As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GraphicDisplayOptions {
    ForgeTypeId^ get ();
}
static member GraphicDisplayOptions : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.GraphicDisplayOptionsBackground Property

ParameterTypeIdGraphicDisplayOptionsBackground Property

"Background"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GraphicDisplayOptionsBackground { get; }
Public Shared ReadOnly Property GraphicDisplayOptionsBackground As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GraphicDisplayOptionsBackground {
    ForgeTypeId^ get ();
}
static member GraphicDisplayOptionsBackground : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.GraphicDisplayOptionsFog Property

ParameterTypeIdGraphicDisplayOptionsFog Property

"Depth Cueing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GraphicDisplayOptionsFog { get; }
Public Shared ReadOnly Property GraphicDisplayOptionsFog As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GraphicDisplayOptionsFog {
    ForgeTypeId^ get ();
}
static member GraphicDisplayOptionsFog : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.GraphicDisplayOptionsLighting Property

ParameterTypeIdGraphicDisplayOptionsLighting Property

"Lighting"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GraphicDisplayOptionsLighting { get; }
Public Shared ReadOnly Property GraphicDisplayOptionsLighting As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GraphicDisplayOptionsLighting {
    ForgeTypeId^ get ();
}
static member GraphicDisplayOptionsLighting : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.GraphicDisplayOptionsModel Property

ParameterTypeIdGraphicDisplayOptionsModel Property

"Model Display"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GraphicDisplayOptionsModel { get; }
Public Shared ReadOnly Property GraphicDisplayOptionsModel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GraphicDisplayOptionsModel {
    ForgeTypeId^ get ();
}
static member GraphicDisplayOptionsModel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.GraphicDisplayOptionsPhotoExposure Property

ParameterTypeIdGraphicDisplayOptionsPhotoExposure Property

"Photographic Exposure"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GraphicDisplayOptionsPhotoExposure { get; }
Public Shared ReadOnly Property GraphicDisplayOptionsPhotoExposure As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GraphicDisplayOptionsPhotoExposure {
    ForgeTypeId^ get ();
}
static member GraphicDisplayOptionsPhotoExposure : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.GraphicDisplayOptionsShadows Property

ParameterTypeIdGraphicDisplayOptionsShadows Property

"Shadows"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GraphicDisplayOptionsShadows { get; }
Public Shared ReadOnly Property GraphicDisplayOptionsShadows As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GraphicDisplayOptionsShadows {
    ForgeTypeId^ get ();
}
static member GraphicDisplayOptionsShadows : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.GraphicDisplayOptionsSketchyLines Property

ParameterTypeIdGraphicDisplayOptionsSketchyLines Property

"Sketchy Lines"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GraphicDisplayOptionsSketchyLines { get; }
Public Shared ReadOnly Property GraphicDisplayOptionsSketchyLines As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GraphicDisplayOptionsSketchyLines {
    ForgeTypeId^ get ();
}
static member GraphicDisplayOptionsSketchyLines : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.GraphicDisplayOptionsSsIntensity Property

ParameterTypeIdGraphicDisplayOptionsSsIntensity Property

"Sun and Shadow Intensity"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GraphicDisplayOptionsSsIntensity { get; }
Public Shared ReadOnly Property GraphicDisplayOptionsSsIntensity As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GraphicDisplayOptionsSsIntensity {
    ForgeTypeId^ get ();
}
static member GraphicDisplayOptionsSsIntensity : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.GridBankColNum Property

ParameterTypeIdGridBankColNum Property

"Column"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GridBankColNum { get; }
Public Shared ReadOnly Property GridBankColNum As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GridBankColNum {
    ForgeTypeId^ get ();
}
static member GridBankColNum : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.GridBankColWidth Property

ParameterTypeIdGridBankColWidth Property

"Column Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GridBankColWidth { get; }
Public Shared ReadOnly Property GridBankColWidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GridBankColWidth {
    ForgeTypeId^ get ();
}
static member GridBankColWidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.GridBankRowHeight Property

ParameterTypeIdGridBankRowHeight Property

"Row Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GridBankRowHeight { get; }
Public Shared ReadOnly Property GridBankRowHeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GridBankRowHeight {
    ForgeTypeId^ get ();
}
static member GridBankRowHeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.GridBankRowNum Property

ParameterTypeIdGridBankRowNum Property

"Row"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GridBankRowNum { get; }
Public Shared ReadOnly Property GridBankRowNum As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GridBankRowNum {
    ForgeTypeId^ get ();
}
static member GridBankRowNum : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.GridBubbleEndn1 Property

ParameterTypeIdGridBubbleEndn1 Property

"Plan View Symbols End 1 (Default)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GridBubbleEndn1 { get; }
Public Shared ReadOnly Property GridBubbleEndn1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GridBubbleEndn1 {
    ForgeTypeId^ get ();
}
static member GridBubbleEndn1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.GridBubbleEndn2 Property

ParameterTypeIdGridBubbleEndn2 Property

"Plan View Symbols End 2 (Default)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GridBubbleEndn2 { get; }
Public Shared ReadOnly Property GridBubbleEndn2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GridBubbleEndn2 {
    ForgeTypeId^ get ();
}
static member GridBubbleEndn2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.GridBubbleLinePen Property

ParameterTypeIdGridBubbleLinePen Property

"Bubble Weight Number\n"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GridBubbleLinePen { get; }
Public Shared ReadOnly Property GridBubbleLinePen As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GridBubbleLinePen {
    ForgeTypeId^ get ();
}
static member GridBubbleLinePen : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.GridCenterSegmentColor Property

ParameterTypeIdGridCenterSegmentColor Property

"Center Segment Color"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GridCenterSegmentColor { get; }
Public Shared ReadOnly Property GridCenterSegmentColor As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GridCenterSegmentColor {
    ForgeTypeId^ get ();
}
static member GridCenterSegmentColor : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.GridCenterSegmentPattern Property

ParameterTypeIdGridCenterSegmentPattern Property

"Center Segment Pattern"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GridCenterSegmentPattern { get; }
Public Shared ReadOnly Property GridCenterSegmentPattern As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GridCenterSegmentPattern {
    ForgeTypeId^ get ();
}
static member GridCenterSegmentPattern : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.GridCenterSegmentStyle Property

ParameterTypeIdGridCenterSegmentStyle Property

"Center Segment"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GridCenterSegmentStyle { get; }
Public Shared ReadOnly Property GridCenterSegmentStyle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GridCenterSegmentStyle {
    ForgeTypeId^ get ();
}
static member GridCenterSegmentStyle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.GridCenterSegmentWeight Property

ParameterTypeIdGridCenterSegmentWeight Property

"Center Segment Weight"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GridCenterSegmentWeight { get; }
Public Shared ReadOnly Property GridCenterSegmentWeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GridCenterSegmentWeight {
    ForgeTypeId^ get ();
}
static member GridCenterSegmentWeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.GridEndSegmentColor Property

ParameterTypeIdGridEndSegmentColor Property

"End Segment Color"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GridEndSegmentColor { get; }
Public Shared ReadOnly Property GridEndSegmentColor As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GridEndSegmentColor {
    ForgeTypeId^ get ();
}
static member GridEndSegmentColor : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.GridEndSegmentPattern Property

ParameterTypeIdGridEndSegmentPattern Property

"End Segment Pattern"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GridEndSegmentPattern { get; }
Public Shared ReadOnly Property GridEndSegmentPattern As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GridEndSegmentPattern {
    ForgeTypeId^ get ();
}
static member GridEndSegmentPattern : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.GridEndSegmentsLength Property

ParameterTypeIdGridEndSegmentsLength Property

"End Segments Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GridEndSegmentsLength { get; }
Public Shared ReadOnly Property GridEndSegmentsLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GridEndSegmentsLength {
    ForgeTypeId^ get ();
}
static member GridEndSegmentsLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.GridEndSegmentWeight Property

ParameterTypeIdGridEndSegmentWeight Property

"End Segment Weight"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GridEndSegmentWeight { get; }
Public Shared ReadOnly Property GridEndSegmentWeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GridEndSegmentWeight {
    ForgeTypeId^ get ();
}
static member GridEndSegmentWeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.GridHeadTag Property

ParameterTypeIdGridHeadTag Property

"Symbol"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GridHeadTag { get; }
Public Shared ReadOnly Property GridHeadTag As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GridHeadTag {
    ForgeTypeId^ get ();
}
static member GridHeadTag : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.GridlineSpecStatus Property

ParameterTypeIdGridlineSpecStatus Property

"Type Association"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GridlineSpecStatus { get; }
Public Shared ReadOnly Property GridlineSpecStatus As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GridlineSpecStatus {
    ForgeTypeId^ get ();
}
static member GridlineSpecStatus : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.GridNetLocationMark Property

ParameterTypeIdGridNetLocationMark Property

"Location Mark": Provides grid system association information

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GridNetLocationMark { get; }
Public Shared ReadOnly Property GridNetLocationMark As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GridNetLocationMark {
    ForgeTypeId^ get ();
}
static member GridNetLocationMark : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.GroupAllowedViewTypes Property

ParameterTypeIdGroupAllowedViewTypes Property

"Allowed View Types"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GroupAllowedViewTypes { get; }
Public Shared ReadOnly Property GroupAllowedViewTypes As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GroupAllowedViewTypes {
    ForgeTypeId^ get ();
}
static member GroupAllowedViewTypes : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.GroupAttachedParentName Property

ParameterTypeIdGroupAttachedParentName Property

"Attached to"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GroupAttachedParentName { get; }
Public Shared ReadOnly Property GroupAttachedParentName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GroupAttachedParentName {
    ForgeTypeId^ get ();
}
static member GroupAttachedParentName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.GroupLevel Property

ParameterTypeIdGroupLevel Property

"Reference Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GroupLevel { get; }
Public Shared ReadOnly Property GroupLevel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GroupLevel {
    ForgeTypeId^ get ();
}
static member GroupLevel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.GroupnameParam Property

ParameterTypeIdGroupnameParam Property

"Group Name for Ribbon Combo Items (for Use with XAML)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GroupnameParam { get; }
Public Shared ReadOnly Property GroupnameParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GroupnameParam {
    ForgeTypeId^ get ();
}
static member GroupnameParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.GroupOffsetFromLevel Property

ParameterTypeIdGroupOffsetFromLevel Property

"Origin Level Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GroupOffsetFromLevel { get; }
Public Shared ReadOnly Property GroupOffsetFromLevel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GroupOffsetFromLevel {
    ForgeTypeId^ get ();
}
static member GroupOffsetFromLevel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.GuideGridNameParam Property

ParameterTypeIdGuideGridNameParam Property

"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GuideGridNameParam { get; }
Public Shared ReadOnly Property GuideGridNameParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GuideGridNameParam {
    ForgeTypeId^ get ();
}
static member GuideGridNameParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.GuideGridSpacingParam Property

ParameterTypeIdGuideGridSpacingParam Property

"Guide Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GuideGridSpacingParam { get; }
Public Shared ReadOnly Property GuideGridSpacingParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GuideGridSpacingParam {
    ForgeTypeId^ get ();
}
static member GuideGridSpacingParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.GutterMaterialParam Property

ParameterTypeIdGutterMaterialParam Property

"Material"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GutterMaterialParam { get; }
Public Shared ReadOnly Property GutterMaterialParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GutterMaterialParam {
    ForgeTypeId^ get ();
}
static member GutterMaterialParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.GutterProfileParam Property

ParameterTypeIdGutterProfileParam Property

"Profile"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GutterProfileParam { get; }
Public Shared ReadOnly Property GutterProfileParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GutterProfileParam {
    ForgeTypeId^ get ();
}
static member GutterProfileParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.HandrailHandClearanceParam Property

ParameterTypeIdHandrailHandClearanceParam Property

"Hand Clearance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId HandrailHandClearanceParam { get; }
Public Shared ReadOnly Property HandrailHandClearanceParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ HandrailHandClearanceParam {
    ForgeTypeId^ get ();
}
static member HandrailHandClearanceParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.HandrailHeightParam Property

ParameterTypeIdHandrailHeightParam Property

"Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId HandrailHeightParam { get; }
Public Shared ReadOnly Property HandrailHeightParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ HandrailHeightParam {
    ForgeTypeId^ get ();
}
static member HandrailHeightParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.HandrailProjectionParam Property

ParameterTypeIdHandrailProjectionParam Property

"Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId HandrailProjectionParam { get; }
Public Shared ReadOnly Property HandrailProjectionParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ HandrailProjectionParam {
    ForgeTypeId^ get ();
}
static member HandrailProjectionParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.HandrailSupportsJustificationParam Property

ParameterTypeIdHandrailSupportsJustificationParam Property

"Justification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId HandrailSupportsJustificationParam { get; }
Public Shared ReadOnly Property HandrailSupportsJustificationParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ HandrailSupportsJustificationParam {
    ForgeTypeId^ get ();
}
static member HandrailSupportsJustificationParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.HandrailSupportsLayoutParam Property

ParameterTypeIdHandrailSupportsLayoutParam Property

"Layout"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId HandrailSupportsLayoutParam { get; }
Public Shared ReadOnly Property HandrailSupportsLayoutParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ HandrailSupportsLayoutParam {
    ForgeTypeId^ get ();
}
static member HandrailSupportsLayoutParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.HandrailSupportsNumberParam Property

ParameterTypeIdHandrailSupportsNumberParam Property

"Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId HandrailSupportsNumberParam { get; }
Public Shared ReadOnly Property HandrailSupportsNumberParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ HandrailSupportsNumberParam {
    ForgeTypeId^ get ();
}
static member HandrailSupportsNumberParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.HandrailSupportsSpacingParam Property

ParameterTypeIdHandrailSupportsSpacingParam Property

"Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId HandrailSupportsSpacingParam { get; }
Public Shared ReadOnly Property HandrailSupportsSpacingParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ HandrailSupportsSpacingParam {
    ForgeTypeId^ get ();
}
static member HandrailSupportsSpacingParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.HandrailSupportsTypeParam Property

ParameterTypeIdHandrailSupportsTypeParam Property

"Family"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId HandrailSupportsTypeParam { get; }
Public Shared ReadOnly Property HandrailSupportsTypeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ HandrailSupportsTypeParam {
    ForgeTypeId^ get ();
}
static member HandrailSupportsTypeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.HeadOnPlacementMethod Property

ParameterTypeIdHeadOnPlacementMethod Property

"Draw in Foreground"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId HeadOnPlacementMethod { get; }
Public Shared ReadOnly Property HeadOnPlacementMethod As ForgeTypeId
    Get
public:
static property ForgeTypeId^ HeadOnPlacementMethod {
    ForgeTypeId^ get ();
}
static member HeadOnPlacementMethod : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.HeavyEndPen Property

ParameterTypeIdHeavyEndPen Property

"Heavy End Pen Weight"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId HeavyEndPen { get; }
Public Shared ReadOnly Property HeavyEndPen As ForgeTypeId
    Get
public:
static property ForgeTypeId^ HeavyEndPen {
    ForgeTypeId^ get ();
}
static member HeavyEndPen : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.HeavyTickMarkPen Property

ParameterTypeIdHeavyTickMarkPen Property

"Heavy End Pen Weight"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId HeavyTickMarkPen { get; }
Public Shared ReadOnly Property HeavyTickMarkPen As ForgeTypeId
    Get
public:
static property ForgeTypeId^ HeavyTickMarkPen {
    ForgeTypeId^ get ();
}
static member HeavyTickMarkPen : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.HighestAssociatedLevel Property

ParameterTypeIdHighestAssociatedLevel Property

"Highest Associated Level": The highest level associated with this Analytical Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId HighestAssociatedLevel { get; }
Public Shared ReadOnly Property HighestAssociatedLevel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ HighestAssociatedLevel {
    ForgeTypeId^ get ();
}
static member HighestAssociatedLevel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.HostAreaComputed Property

ParameterTypeIdHostAreaComputed Property

"Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId HostAreaComputed { get; }
Public Shared ReadOnly Property HostAreaComputed As ForgeTypeId
    Get
public:
static property ForgeTypeId^ HostAreaComputed {
    ForgeTypeId^ get ();
}
static member HostAreaComputed : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.HostIdParam Property

ParameterTypeIdHostIdParam Property

"Host Id"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId HostIdParam { get; }
Public Shared ReadOnly Property HostIdParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ HostIdParam {
    ForgeTypeId^ get ();
}
static member HostIdParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.HostPanelScheduleAsPanelParam Property

ParameterTypeIdHostPanelScheduleAsPanelParam Property

"Categorize as"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId HostPanelScheduleAsPanelParam { get; }
Public Shared ReadOnly Property HostPanelScheduleAsPanelParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ HostPanelScheduleAsPanelParam {
    ForgeTypeId^ get ();
}
static member HostPanelScheduleAsPanelParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.HostPerimeterComputed Property

ParameterTypeIdHostPerimeterComputed Property

"Perimeter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId HostPerimeterComputed { get; }
Public Shared ReadOnly Property HostPerimeterComputed As ForgeTypeId
    Get
public:
static property ForgeTypeId^ HostPerimeterComputed {
    ForgeTypeId^ get ();
}
static member HostPerimeterComputed : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.HostSseCurvedEdgeConditionParam Property

ParameterTypeIdHostSseCurvedEdgeConditionParam Property

"Curved Edge Condition"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId HostSseCurvedEdgeConditionParam { get; }
Public Shared ReadOnly Property HostSseCurvedEdgeConditionParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ HostSseCurvedEdgeConditionParam {
    ForgeTypeId^ get ();
}
static member HostSseCurvedEdgeConditionParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.HostVolumeComputed Property

ParameterTypeIdHostVolumeComputed Property

"Volume"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId HostVolumeComputed { get; }
Public Shared ReadOnly Property HostVolumeComputed As ForgeTypeId
    Get
public:
static property ForgeTypeId^ HostVolumeComputed {
    ForgeTypeId^ get ();
}
static member HostVolumeComputed : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.IconIndexParam Property

ParameterTypeIdIconIndexParam Property

"Index Into Image File Name Array (for Use with XAML)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId IconIndexParam { get; }
Public Shared ReadOnly Property IconIndexParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ IconIndexParam {
    ForgeTypeId^ get ();
}
static member IconIndexParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.IdParam Property

ParameterTypeIdIdParam Property

"Id"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId IdParam { get; }
Public Shared ReadOnly Property IdParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ IdParam {
    ForgeTypeId^ get ();
}
static member IdParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.IfcApplicationName Property

ParameterTypeIdIfcApplicationName Property

"IfcApplicationName"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId IfcApplicationName { get; }
Public Shared ReadOnly Property IfcApplicationName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ IfcApplicationName {
    ForgeTypeId^ get ();
}
static member IfcApplicationName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.IfcApplicationVersion Property

ParameterTypeIdIfcApplicationVersion Property

"IfcApplicationVersion"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId IfcApplicationVersion { get; }
Public Shared ReadOnly Property IfcApplicationVersion As ForgeTypeId
    Get
public:
static property ForgeTypeId^ IfcApplicationVersion {
    ForgeTypeId^ get ();
}
static member IfcApplicationVersion : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.IfcBuildingGuid Property

ParameterTypeIdIfcBuildingGuid Property

"IfcBuilding GUID"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId IfcBuildingGuid { get; }
Public Shared ReadOnly Property IfcBuildingGuid As ForgeTypeId
    Get
public:
static property ForgeTypeId^ IfcBuildingGuid {
    ForgeTypeId^ get ();
}
static member IfcBuildingGuid : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.IfcExportElement Property

ParameterTypeIdIfcExportElement Property

"Export to IFC"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId IfcExportElement { get; }
Public Shared ReadOnly Property IfcExportElement As ForgeTypeId
    Get
public:
static property ForgeTypeId^ IfcExportElement {
    ForgeTypeId^ get ();
}
static member IfcExportElement : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.IfcExportElementAs Property

ParameterTypeIdIfcExportElementAs Property

"Export to IFC As"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId IfcExportElementAs { get; }
Public Shared ReadOnly Property IfcExportElementAs As ForgeTypeId
    Get
public:
static property ForgeTypeId^ IfcExportElementAs {
    ForgeTypeId^ get ();
}
static member IfcExportElementAs : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.IfcExportElementType Property

ParameterTypeIdIfcExportElementType Property

"Export Type to IFC"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId IfcExportElementType { get; }
Public Shared ReadOnly Property IfcExportElementType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ IfcExportElementType {
    ForgeTypeId^ get ();
}
static member IfcExportElementType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.IfcExportElementTypeAs Property

ParameterTypeIdIfcExportElementTypeAs Property

"Export Type to IFC As"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId IfcExportElementTypeAs { get; }
Public Shared ReadOnly Property IfcExportElementTypeAs As ForgeTypeId
    Get
public:
static property ForgeTypeId^ IfcExportElementTypeAs {
    ForgeTypeId^ get ();
}
static member IfcExportElementTypeAs : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.IfcExportPredefinedtype Property

ParameterTypeIdIfcExportPredefinedtype Property

"IFC Predefined Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId IfcExportPredefinedtype { get; }
Public Shared ReadOnly Property IfcExportPredefinedtype As ForgeTypeId
    Get
public:
static property ForgeTypeId^ IfcExportPredefinedtype {
    ForgeTypeId^ get ();
}
static member IfcExportPredefinedtype : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.IfcExportPredefinedtypeType Property

ParameterTypeIdIfcExportPredefinedtypeType Property

"Type IFC Predefined Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId IfcExportPredefinedtypeType { get; }
Public Shared ReadOnly Property IfcExportPredefinedtypeType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ IfcExportPredefinedtypeType {
    ForgeTypeId^ get ();
}
static member IfcExportPredefinedtypeType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.IfcGuid Property

ParameterTypeIdIfcGuid Property

"IfcGUID"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId IfcGuid { get; }
Public Shared ReadOnly Property IfcGuid As ForgeTypeId
    Get
public:
static property ForgeTypeId^ IfcGuid {
    ForgeTypeId^ get ();
}
static member IfcGuid : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.IfcImportMaterialName Property

ParameterTypeIdIfcImportMaterialName Property

"IFC Material Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId IfcImportMaterialName { get; }
Public Shared ReadOnly Property IfcImportMaterialName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ IfcImportMaterialName {
    ForgeTypeId^ get ();
}
static member IfcImportMaterialName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.IfcOrganization Property

ParameterTypeIdIfcOrganization Property

"IfcOrganization"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId IfcOrganization { get; }
Public Shared ReadOnly Property IfcOrganization As ForgeTypeId
    Get
public:
static property ForgeTypeId^ IfcOrganization {
    ForgeTypeId^ get ();
}
static member IfcOrganization : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.IfcProjectGuid Property

ParameterTypeIdIfcProjectGuid Property

"IfcProject GUID"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId IfcProjectGuid { get; }
Public Shared ReadOnly Property IfcProjectGuid As ForgeTypeId
    Get
public:
static property ForgeTypeId^ IfcProjectGuid {
    ForgeTypeId^ get ();
}
static member IfcProjectGuid : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.IfcSiteGuid Property

ParameterTypeIdIfcSiteGuid Property

"IfcSite GUID"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId IfcSiteGuid { get; }
Public Shared ReadOnly Property IfcSiteGuid As ForgeTypeId
    Get
public:
static property ForgeTypeId^ IfcSiteGuid {
    ForgeTypeId^ get ();
}
static member IfcSiteGuid : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.IfcTypeGuid Property

ParameterTypeIdIfcTypeGuid Property

"Type IfcGUID"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId IfcTypeGuid { get; }
Public Shared ReadOnly Property IfcTypeGuid As ForgeTypeId
    Get
public:
static property ForgeTypeId^ IfcTypeGuid {
    ForgeTypeId^ get ();
}
static member IfcTypeGuid : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ImportAdtComponentsDesc Property

ParameterTypeIdImportAdtComponentsDesc Property

"Component Description"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ImportAdtComponentsDesc { get; }
Public Shared ReadOnly Property ImportAdtComponentsDesc As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ImportAdtComponentsDesc {
    ForgeTypeId^ get ();
}
static member ImportAdtComponentsDesc : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ImportAdtEntityHeight Property

ParameterTypeIdImportAdtEntityHeight Property

"Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ImportAdtEntityHeight { get; }
Public Shared ReadOnly Property ImportAdtEntityHeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ImportAdtEntityHeight {
    ForgeTypeId^ get ();
}
static member ImportAdtEntityHeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ImportAdtEntityLength Property

ParameterTypeIdImportAdtEntityLength Property

"Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ImportAdtEntityLength { get; }
Public Shared ReadOnly Property ImportAdtEntityLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ImportAdtEntityLength {
    ForgeTypeId^ get ();
}
static member ImportAdtEntityLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ImportAdtEntityRoll Property

ParameterTypeIdImportAdtEntityRoll Property

"Roll"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ImportAdtEntityRoll { get; }
Public Shared ReadOnly Property ImportAdtEntityRoll As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ImportAdtEntityRoll {
    ForgeTypeId^ get ();
}
static member ImportAdtEntityRoll : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ImportAdtEntityStructType Property

ParameterTypeIdImportAdtEntityStructType Property

"Structural Type Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ImportAdtEntityStructType { get; }
Public Shared ReadOnly Property ImportAdtEntityStructType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ImportAdtEntityStructType {
    ForgeTypeId^ get ();
}
static member ImportAdtEntityStructType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ImportAdtEntityStyle Property

ParameterTypeIdImportAdtEntityStyle Property

"Style Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ImportAdtEntityStyle { get; }
Public Shared ReadOnly Property ImportAdtEntityStyle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ImportAdtEntityStyle {
    ForgeTypeId^ get ();
}
static member ImportAdtEntityStyle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ImportAdtEntityThickness Property

ParameterTypeIdImportAdtEntityThickness Property

"Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ImportAdtEntityThickness { get; }
Public Shared ReadOnly Property ImportAdtEntityThickness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ImportAdtEntityThickness {
    ForgeTypeId^ get ();
}
static member ImportAdtEntityThickness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ImportAdtEntityType Property

ParameterTypeIdImportAdtEntityType Property

"Type Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ImportAdtEntityType { get; }
Public Shared ReadOnly Property ImportAdtEntityType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ImportAdtEntityType {
    ForgeTypeId^ get ();
}
static member ImportAdtEntityType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ImportAdtEntityWidth Property

ParameterTypeIdImportAdtEntityWidth Property

"Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ImportAdtEntityWidth { get; }
Public Shared ReadOnly Property ImportAdtEntityWidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ImportAdtEntityWidth {
    ForgeTypeId^ get ();
}
static member ImportAdtEntityWidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ImportBackground Property

ParameterTypeIdImportBackground Property

"Draw Layer"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ImportBackground { get; }
Public Shared ReadOnly Property ImportBackground As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ImportBackground {
    ForgeTypeId^ get ();
}
static member ImportBackground : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ImportBaseLevel Property

ParameterTypeIdImportBaseLevel Property

"Work Plane"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ImportBaseLevel { get; }
Public Shared ReadOnly Property ImportBaseLevel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ImportBaseLevel {
    ForgeTypeId^ get ();
}
static member ImportBaseLevel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ImportBaseLevelOffset Property

ParameterTypeIdImportBaseLevelOffset Property

"Offset from Work Plane"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ImportBaseLevelOffset { get; }
Public Shared ReadOnly Property ImportBaseLevelOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ImportBaseLevelOffset {
    ForgeTypeId^ get ();
}
static member ImportBaseLevelOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ImportDisplayUnits Property

ParameterTypeIdImportDisplayUnits Property

"Import Units"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ImportDisplayUnits { get; }
Public Shared ReadOnly Property ImportDisplayUnits As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ImportDisplayUnits {
    ForgeTypeId^ get ();
}
static member ImportDisplayUnits : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ImportInstanceCuttingInView Property

ParameterTypeIdImportInstanceCuttingInView Property

"Enable Cutting in Views"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ImportInstanceCuttingInView { get; }
Public Shared ReadOnly Property ImportInstanceCuttingInView As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ImportInstanceCuttingInView {
    ForgeTypeId^ get ();
}
static member ImportInstanceCuttingInView : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ImportInstanceScale Property

ParameterTypeIdImportInstanceScale Property

"Instance Scale"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ImportInstanceScale { get; }
Public Shared ReadOnly Property ImportInstanceScale As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ImportInstanceScale {
    ForgeTypeId^ get ();
}
static member ImportInstanceScale : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ImportScale Property

ParameterTypeIdImportScale Property

"Scale Factor"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ImportScale { get; }
Public Shared ReadOnly Property ImportScale As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ImportScale {
    ForgeTypeId^ get ();
}
static member ImportScale : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ImportSymbolName Property

ParameterTypeIdImportSymbolName Property

"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ImportSymbolName { get; }
Public Shared ReadOnly Property ImportSymbolName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ImportSymbolName {
    ForgeTypeId^ get ();
}
static member ImportSymbolName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.IndividualExcavationVolume Property

ParameterTypeIdIndividualExcavationVolume Property

"Individual Excavation Volume"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId IndividualExcavationVolume { get; }
Public Shared ReadOnly Property IndividualExcavationVolume As ForgeTypeId
    Get
public:
static property ForgeTypeId^ IndividualExcavationVolume {
    ForgeTypeId^ get ();
}
static member IndividualExcavationVolume : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.InfrastructureAlignmentDescription Property

ParameterTypeIdInfrastructureAlignmentDescription Property

"Description"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId InfrastructureAlignmentDescription { get; }
Public Shared ReadOnly Property InfrastructureAlignmentDescription As ForgeTypeId
    Get
public:
static property ForgeTypeId^ InfrastructureAlignmentDescription {
    ForgeTypeId^ get ();
}
static member InfrastructureAlignmentDescription : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.InfrastructureAlignmentDisplayedEndStation Property

ParameterTypeIdInfrastructureAlignmentDisplayedEndStation Property

"Displayed End Station"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId InfrastructureAlignmentDisplayedEndStation { get; }
Public Shared ReadOnly Property InfrastructureAlignmentDisplayedEndStation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ InfrastructureAlignmentDisplayedEndStation {
    ForgeTypeId^ get ();
}
static member InfrastructureAlignmentDisplayedEndStation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.InfrastructureAlignmentDisplayedStartStation Property

ParameterTypeIdInfrastructureAlignmentDisplayedStartStation Property

"Displayed Start Station"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId InfrastructureAlignmentDisplayedStartStation { get; }
Public Shared ReadOnly Property InfrastructureAlignmentDisplayedStartStation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ InfrastructureAlignmentDisplayedStartStation {
    ForgeTypeId^ get ();
}
static member InfrastructureAlignmentDisplayedStartStation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.InfrastructureAlignmentName Property

ParameterTypeIdInfrastructureAlignmentName Property

"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId InfrastructureAlignmentName { get; }
Public Shared ReadOnly Property InfrastructureAlignmentName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ InfrastructureAlignmentName {
    ForgeTypeId^ get ();
}
static member InfrastructureAlignmentName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.InsertOrientation Property

ParameterTypeIdInsertOrientation Property

"Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId InsertOrientation { get; }
Public Shared ReadOnly Property InsertOrientation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ InsertOrientation {
    ForgeTypeId^ get ();
}
static member InsertOrientation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.InstanceElevationParam Property

ParameterTypeIdInstanceElevationParam Property

"Elevation from Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId InstanceElevationParam { get; }
Public Shared ReadOnly Property InstanceElevationParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ InstanceElevationParam {
    ForgeTypeId^ get ();
}
static member InstanceElevationParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.InstanceFreeHostOffsetParam Property

ParameterTypeIdInstanceFreeHostOffsetParam Property

"Offset from Host"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId InstanceFreeHostOffsetParam { get; }
Public Shared ReadOnly Property InstanceFreeHostOffsetParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ InstanceFreeHostOffsetParam {
    ForgeTypeId^ get ();
}
static member InstanceFreeHostOffsetParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.InstanceFreeHostParam Property

ParameterTypeIdInstanceFreeHostParam Property

"Host"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId InstanceFreeHostParam { get; }
Public Shared ReadOnly Property InstanceFreeHostParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ InstanceFreeHostParam {
    ForgeTypeId^ get ();
}
static member InstanceFreeHostParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.InstanceHeadHeightParam Property

ParameterTypeIdInstanceHeadHeightParam Property

"Head Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId InstanceHeadHeightParam { get; }
Public Shared ReadOnly Property InstanceHeadHeightParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ InstanceHeadHeightParam {
    ForgeTypeId^ get ();
}
static member InstanceHeadHeightParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.InstanceLengthParam Property

ParameterTypeIdInstanceLengthParam Property

"Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId InstanceLengthParam { get; }
Public Shared ReadOnly Property InstanceLengthParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ InstanceLengthParam {
    ForgeTypeId^ get ();
}
static member InstanceLengthParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.InstanceMoveBaseWithGrids Property

ParameterTypeIdInstanceMoveBaseWithGrids Property

"Move Base With Grids"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId InstanceMoveBaseWithGrids { get; }
Public Shared ReadOnly Property InstanceMoveBaseWithGrids As ForgeTypeId
    Get
public:
static property ForgeTypeId^ InstanceMoveBaseWithGrids {
    ForgeTypeId^ get ();
}
static member InstanceMoveBaseWithGrids : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.InstanceMovesWithGridParam Property

ParameterTypeIdInstanceMovesWithGridParam Property

"Moves With Grids"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId InstanceMovesWithGridParam { get; }
Public Shared ReadOnly Property InstanceMovesWithGridParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ InstanceMovesWithGridParam {
    ForgeTypeId^ get ();
}
static member InstanceMovesWithGridParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.InstanceMoveTopWithGrids Property

ParameterTypeIdInstanceMoveTopWithGrids Property

"Move Top With Grids"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId InstanceMoveTopWithGrids { get; }
Public Shared ReadOnly Property InstanceMoveTopWithGrids As ForgeTypeId
    Get
public:
static property ForgeTypeId^ InstanceMoveTopWithGrids {
    ForgeTypeId^ get ();
}
static member InstanceMoveTopWithGrids : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.InstanceOffsetPosParam Property

ParameterTypeIdInstanceOffsetPosParam Property

"Moves With Nearby Elements"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId InstanceOffsetPosParam { get; }
Public Shared ReadOnly Property InstanceOffsetPosParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ InstanceOffsetPosParam {
    ForgeTypeId^ get ();
}
static member InstanceOffsetPosParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.InstanceReferenceLevelParam Property

ParameterTypeIdInstanceReferenceLevelParam Property

"Reference Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId InstanceReferenceLevelParam { get; }
Public Shared ReadOnly Property InstanceReferenceLevelParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ InstanceReferenceLevelParam {
    ForgeTypeId^ get ();
}
static member InstanceReferenceLevelParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.InstanceScheduleOnlyLevelParam Property

ParameterTypeIdInstanceScheduleOnlyLevelParam Property

"Schedule Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId InstanceScheduleOnlyLevelParam { get; }
Public Shared ReadOnly Property InstanceScheduleOnlyLevelParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ InstanceScheduleOnlyLevelParam {
    ForgeTypeId^ get ();
}
static member InstanceScheduleOnlyLevelParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.InstanceSillHeightParam Property

ParameterTypeIdInstanceSillHeightParam Property

"Sill Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId InstanceSillHeightParam { get; }
Public Shared ReadOnly Property InstanceSillHeightParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ InstanceSillHeightParam {
    ForgeTypeId^ get ();
}
static member InstanceSillHeightParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.InstanceStructUsageParam Property

ParameterTypeIdInstanceStructUsageParam Property

"Structural Usage"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId InstanceStructUsageParam { get; }
Public Shared ReadOnly Property InstanceStructUsageParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ InstanceStructUsageParam {
    ForgeTypeId^ get ();
}
static member InstanceStructUsageParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.InsulationScale Property

ParameterTypeIdInsulationScale Property

"Insulation Bulge to Width Ratio (1/x)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId InsulationScale { get; }
Public Shared ReadOnly Property InsulationScale As ForgeTypeId
    Get
public:
static property ForgeTypeId^ InsulationScale {
    ForgeTypeId^ get ();
}
static member InsulationScale : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.InsulationWidth Property

ParameterTypeIdInsulationWidth Property

"Insulation Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId InsulationWidth { get; }
Public Shared ReadOnly Property InsulationWidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ InsulationWidth {
    ForgeTypeId^ get ();
}
static member InsulationWidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.InteriorTickDisplay Property

ParameterTypeIdInteriorTickDisplay Property

"Interior Tick Mark Display"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId InteriorTickDisplay { get; }
Public Shared ReadOnly Property InteriorTickDisplay As ForgeTypeId
    Get
public:
static property ForgeTypeId^ InteriorTickDisplay {
    ForgeTypeId^ get ();
}
static member InteriorTickDisplay : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.IsVisibleParam Property

ParameterTypeIdIsVisibleParam Property

"Visible"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId IsVisibleParam { get; }
Public Shared ReadOnly Property IsVisibleParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ IsVisibleParam {
    ForgeTypeId^ get ();
}
static member IsVisibleParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.JoinStrengthOrder Property

ParameterTypeIdJoinStrengthOrder Property

"Abstract Join Strength Order"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId JoinStrengthOrder { get; }
Public Shared ReadOnly Property JoinStrengthOrder As ForgeTypeId
    Get
public:
static property ForgeTypeId^ JoinStrengthOrder {
    ForgeTypeId^ get ();
}
static member JoinStrengthOrder : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.JoistSystemClearSpacingParam Property

ParameterTypeIdJoistSystemClearSpacingParam Property

"Clear Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId JoistSystemClearSpacingParam { get; }
Public Shared ReadOnly Property JoistSystemClearSpacingParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ JoistSystemClearSpacingParam {
    ForgeTypeId^ get ();
}
static member JoistSystemClearSpacingParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.JoistSystemElemTagNewMembersView Property

ParameterTypeIdJoistSystemElemTagNewMembersView Property

"Tag new members in view"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId JoistSystemElemTagNewMembersView { get; }
Public Shared ReadOnly Property JoistSystemElemTagNewMembersView As ForgeTypeId
    Get
public:
static property ForgeTypeId^ JoistSystemElemTagNewMembersView {
    ForgeTypeId^ get ();
}
static member JoistSystemElemTagNewMembersView : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.JoistSystemFixedSpacingParam Property

ParameterTypeIdJoistSystemFixedSpacingParam Property

"Fixed Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId JoistSystemFixedSpacingParam { get; }
Public Shared ReadOnly Property JoistSystemFixedSpacingParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ JoistSystemFixedSpacingParam {
    ForgeTypeId^ get ();
}
static member JoistSystemFixedSpacingParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.JoistSystemJustificationParam Property

ParameterTypeIdJoistSystemJustificationParam Property

"Justification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId JoistSystemJustificationParam { get; }
Public Shared ReadOnly Property JoistSystemJustificationParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ JoistSystemJustificationParam {
    ForgeTypeId^ get ();
}
static member JoistSystemJustificationParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.JoistSystemLayoutRuleParam Property

ParameterTypeIdJoistSystemLayoutRuleParam Property

"Layout Rule"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId JoistSystemLayoutRuleParam { get; }
Public Shared ReadOnly Property JoistSystemLayoutRuleParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ JoistSystemLayoutRuleParam {
    ForgeTypeId^ get ();
}
static member JoistSystemLayoutRuleParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.JoistSystemMaximumSpacingParam Property

ParameterTypeIdJoistSystemMaximumSpacingParam Property

"Maximum Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId JoistSystemMaximumSpacingParam { get; }
Public Shared ReadOnly Property JoistSystemMaximumSpacingParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ JoistSystemMaximumSpacingParam {
    ForgeTypeId^ get ();
}
static member JoistSystemMaximumSpacingParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.JoistSystemNewBeamTypeNoFamNameParam Property

ParameterTypeIdJoistSystemNewBeamTypeNoFamNameParam Property

"Beam Type (No Family Name)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId JoistSystemNewBeamTypeNoFamNameParam { get; }
Public Shared ReadOnly Property JoistSystemNewBeamTypeNoFamNameParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ JoistSystemNewBeamTypeNoFamNameParam {
    ForgeTypeId^ get ();
}
static member JoistSystemNewBeamTypeNoFamNameParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.JoistSystemNewBeamTypeParam Property

ParameterTypeIdJoistSystemNewBeamTypeParam Property

"Beam Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId JoistSystemNewBeamTypeParam { get; }
Public Shared ReadOnly Property JoistSystemNewBeamTypeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ JoistSystemNewBeamTypeParam {
    ForgeTypeId^ get ();
}
static member JoistSystemNewBeamTypeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.JoistSystemNumBeamsSameType Property

ParameterTypeIdJoistSystemNumBeamsSameType Property

"Num. of Beams With Same Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId JoistSystemNumBeamsSameType { get; }
Public Shared ReadOnly Property JoistSystemNumBeamsSameType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ JoistSystemNumBeamsSameType {
    ForgeTypeId^ get ();
}
static member JoistSystemNumBeamsSameType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.JoistSystemNumberOfLinesParam Property

ParameterTypeIdJoistSystemNumberOfLinesParam Property

"Number of Lines"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId JoistSystemNumberOfLinesParam { get; }
Public Shared ReadOnly Property JoistSystemNumberOfLinesParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ JoistSystemNumberOfLinesParam {
    ForgeTypeId^ get ();
}
static member JoistSystemNumberOfLinesParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.JoistSystemSpacingParam Property

ParameterTypeIdJoistSystemSpacingParam Property

"Centerline Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId JoistSystemSpacingParam { get; }
Public Shared ReadOnly Property JoistSystemSpacingParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ JoistSystemSpacingParam {
    ForgeTypeId^ get ();
}
static member JoistSystemSpacingParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.KeepReadable Property

ParameterTypeIdKeepReadable Property

"Keep Readable"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KeepReadable { get; }
Public Shared ReadOnly Property KeepReadable As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KeepReadable {
    ForgeTypeId^ get ();
}
static member KeepReadable : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.KeynoteNumber Property

ParameterTypeIdKeynoteNumber Property

"Key Value"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KeynoteNumber { get; }
Public Shared ReadOnly Property KeynoteNumber As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KeynoteNumber {
    ForgeTypeId^ get ();
}
static member KeynoteNumber : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.KeynoteParam Property

ParameterTypeIdKeynoteParam Property

"Keynote"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KeynoteParam { get; }
Public Shared ReadOnly Property KeynoteParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KeynoteParam {
    ForgeTypeId^ get ();
}
static member KeynoteParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.KeynoteText Property

ParameterTypeIdKeynoteText Property

"Keynote Text"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KeynoteText { get; }
Public Shared ReadOnly Property KeynoteText As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KeynoteText {
    ForgeTypeId^ get ();
}
static member KeynoteText : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.KeySourceParam Property

ParameterTypeIdKeySourceParam Property

"Key Source"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KeySourceParam { get; }
Public Shared ReadOnly Property KeySourceParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KeySourceParam {
    ForgeTypeId^ get ();
}
static member KeySourceParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.KeyValue Property

ParameterTypeIdKeyValue Property

"Key Value"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KeyValue { get; }
Public Shared ReadOnly Property KeyValue As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KeyValue {
    ForgeTypeId^ get ();
}
static member KeyValue : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LayerElemAreaComputed Property

ParameterTypeIdLayerElemAreaComputed Property

"Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LayerElemAreaComputed { get; }
Public Shared ReadOnly Property LayerElemAreaComputed As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LayerElemAreaComputed {
    ForgeTypeId^ get ();
}
static member LayerElemAreaComputed : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LayerElemBaseConstraint Property

ParameterTypeIdLayerElemBaseConstraint Property

"Base Constraint"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LayerElemBaseConstraint { get; }
Public Shared ReadOnly Property LayerElemBaseConstraint As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LayerElemBaseConstraint {
    ForgeTypeId^ get ();
}
static member LayerElemBaseConstraint : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LayerElemBaseExtensionDis Property

ParameterTypeIdLayerElemBaseExtensionDis Property

"Base Extension Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LayerElemBaseExtensionDis { get; }
Public Shared ReadOnly Property LayerElemBaseExtensionDis As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LayerElemBaseExtensionDis {
    ForgeTypeId^ get ();
}
static member LayerElemBaseExtensionDis : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LayerElemCompoundElemFamily Property

ParameterTypeIdLayerElemCompoundElemFamily Property

"Compound Element Family"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LayerElemCompoundElemFamily { get; }
Public Shared ReadOnly Property LayerElemCompoundElemFamily As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LayerElemCompoundElemFamily {
    ForgeTypeId^ get ();
}
static member LayerElemCompoundElemFamily : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LayerElemCompoundElemType Property

ParameterTypeIdLayerElemCompoundElemType Property

"Compound Element Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LayerElemCompoundElemType { get; }
Public Shared ReadOnly Property LayerElemCompoundElemType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LayerElemCompoundElemType {
    ForgeTypeId^ get ();
}
static member LayerElemCompoundElemType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LayerElemFunction Property

ParameterTypeIdLayerElemFunction Property

"Function": Function

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LayerElemFunction { get; }
Public Shared ReadOnly Property LayerElemFunction As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LayerElemFunction {
    ForgeTypeId^ get ();
}
static member LayerElemFunction : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LayerElemIsCoreLayer Property

ParameterTypeIdLayerElemIsCoreLayer Property

"Is Core Layer"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LayerElemIsCoreLayer { get; }
Public Shared ReadOnly Property LayerElemIsCoreLayer As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LayerElemIsCoreLayer {
    ForgeTypeId^ get ();
}
static member LayerElemIsCoreLayer : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LayerElemIsStructuralMaterial Property

ParameterTypeIdLayerElemIsStructuralMaterial Property

"Is Structural Material"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LayerElemIsStructuralMaterial { get; }
Public Shared ReadOnly Property LayerElemIsStructuralMaterial As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LayerElemIsStructuralMaterial {
    ForgeTypeId^ get ();
}
static member LayerElemIsStructuralMaterial : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LayerElemIsVariable Property

ParameterTypeIdLayerElemIsVariable Property

"Is Variable"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LayerElemIsVariable { get; }
Public Shared ReadOnly Property LayerElemIsVariable As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LayerElemIsVariable {
    ForgeTypeId^ get ();
}
static member LayerElemIsVariable : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LayerElemMaterials Property

ParameterTypeIdLayerElemMaterials Property

"Material": Material

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LayerElemMaterials { get; }
Public Shared ReadOnly Property LayerElemMaterials As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LayerElemMaterials {
    ForgeTypeId^ get ();
}
static member LayerElemMaterials : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LayerElemOffsetFromHost Property

ParameterTypeIdLayerElemOffsetFromHost Property

"Offset From Host"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LayerElemOffsetFromHost { get; }
Public Shared ReadOnly Property LayerElemOffsetFromHost As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LayerElemOffsetFromHost {
    ForgeTypeId^ get ();
}
static member LayerElemOffsetFromHost : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LayerElemScheduleFamily Property

ParameterTypeIdLayerElemScheduleFamily Property

"Family"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LayerElemScheduleFamily { get; }
Public Shared ReadOnly Property LayerElemScheduleFamily As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LayerElemScheduleFamily {
    ForgeTypeId^ get ();
}
static member LayerElemScheduleFamily : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LayerElemThickness Property

ParameterTypeIdLayerElemThickness Property

"Thickness": Thickness

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LayerElemThickness { get; }
Public Shared ReadOnly Property LayerElemThickness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LayerElemThickness {
    ForgeTypeId^ get ();
}
static member LayerElemThickness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LayerElemTopConstraint Property

ParameterTypeIdLayerElemTopConstraint Property

"Top Constraint"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LayerElemTopConstraint { get; }
Public Shared ReadOnly Property LayerElemTopConstraint As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LayerElemTopConstraint {
    ForgeTypeId^ get ();
}
static member LayerElemTopConstraint : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LayerElemTopExtensionDis Property

ParameterTypeIdLayerElemTopExtensionDis Property

"Top Extension Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LayerElemTopExtensionDis { get; }
Public Shared ReadOnly Property LayerElemTopExtensionDis As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LayerElemTopExtensionDis {
    ForgeTypeId^ get ();
}
static member LayerElemTopExtensionDis : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LayerElemVolumeComputed Property

ParameterTypeIdLayerElemVolumeComputed Property

"Volume"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LayerElemVolumeComputed { get; }
Public Shared ReadOnly Property LayerElemVolumeComputed As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LayerElemVolumeComputed {
    ForgeTypeId^ get ();
}
static member LayerElemVolumeComputed : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LayerTypeMaterials Property

ParameterTypeIdLayerTypeMaterials Property

"Material": Material

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LayerTypeMaterials { get; }
Public Shared ReadOnly Property LayerTypeMaterials As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LayerTypeMaterials {
    ForgeTypeId^ get ();
}
static member LayerTypeMaterials : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LayerTypeThickness Property

ParameterTypeIdLayerTypeThickness Property

"Thickness": Thickness

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LayerTypeThickness { get; }
Public Shared ReadOnly Property LayerTypeThickness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LayerTypeThickness {
    ForgeTypeId^ get ();
}
static member LayerTypeThickness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LayoutnodeCurvetypeParam Property

ParameterTypeIdLayoutnodeCurvetypeParam Property

"Curve Type Reference"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LayoutnodeCurvetypeParam { get; }
Public Shared ReadOnly Property LayoutnodeCurvetypeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LayoutnodeCurvetypeParam {
    ForgeTypeId^ get ();
}
static member LayoutnodeCurvetypeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LeaderArrowhead Property

ParameterTypeIdLeaderArrowhead Property

"Leader Arrowhead"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LeaderArrowhead { get; }
Public Shared ReadOnly Property LeaderArrowhead As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LeaderArrowhead {
    ForgeTypeId^ get ();
}
static member LeaderArrowhead : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LeaderArrowWidth Property

ParameterTypeIdLeaderArrowWidth Property

"Arrow Width Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LeaderArrowWidth { get; }
Public Shared ReadOnly Property LeaderArrowWidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LeaderArrowWidth {
    ForgeTypeId^ get ();
}
static member LeaderArrowWidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LeaderLeftAttachment Property

ParameterTypeIdLeaderLeftAttachment Property

"Left Attachment"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LeaderLeftAttachment { get; }
Public Shared ReadOnly Property LeaderLeftAttachment As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LeaderLeftAttachment {
    ForgeTypeId^ get ();
}
static member LeaderLeftAttachment : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LeaderLength Property

ParameterTypeIdLeaderLength Property

"Leader Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LeaderLength { get; }
Public Shared ReadOnly Property LeaderLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LeaderLength {
    ForgeTypeId^ get ();
}
static member LeaderLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LeaderLine Property

ParameterTypeIdLeaderLine Property

"Leader Line"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LeaderLine { get; }
Public Shared ReadOnly Property LeaderLine As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LeaderLine {
    ForgeTypeId^ get ();
}
static member LeaderLine : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LeaderOffsetSheet Property

ParameterTypeIdLeaderOffsetSheet Property

"Leader/Border Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LeaderOffsetSheet { get; }
Public Shared ReadOnly Property LeaderOffsetSheet As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LeaderOffsetSheet {
    ForgeTypeId^ get ();
}
static member LeaderOffsetSheet : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LeaderRightAttachment Property

ParameterTypeIdLeaderRightAttachment Property

"Right Attachment"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LeaderRightAttachment { get; }
Public Shared ReadOnly Property LeaderRightAttachment As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LeaderRightAttachment {
    ForgeTypeId^ get ();
}
static member LeaderRightAttachment : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LegendComponent Property

ParameterTypeIdLegendComponent Property

"Component Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LegendComponent { get; }
Public Shared ReadOnly Property LegendComponent As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LegendComponent {
    ForgeTypeId^ get ();
}
static member LegendComponent : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LegendComponentDetailLevel Property

ParameterTypeIdLegendComponentDetailLevel Property

"Detail Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LegendComponentDetailLevel { get; }
Public Shared ReadOnly Property LegendComponentDetailLevel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LegendComponentDetailLevel {
    ForgeTypeId^ get ();
}
static member LegendComponentDetailLevel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LegendComponentLength Property

ParameterTypeIdLegendComponentLength Property

"Host Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LegendComponentLength { get; }
Public Shared ReadOnly Property LegendComponentLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LegendComponentLength {
    ForgeTypeId^ get ();
}
static member LegendComponentLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LegendComponentView Property

ParameterTypeIdLegendComponentView Property

"View Direction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LegendComponentView { get; }
Public Shared ReadOnly Property LegendComponentView As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LegendComponentView {
    ForgeTypeId^ get ();
}
static member LegendComponentView : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LevelAttrRoomComputationAutomatic Property

ParameterTypeIdLevelAttrRoomComputationAutomatic Property

"Automatic Room Computation Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LevelAttrRoomComputationAutomatic { get; }
Public Shared ReadOnly Property LevelAttrRoomComputationAutomatic As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LevelAttrRoomComputationAutomatic {
    ForgeTypeId^ get ();
}
static member LevelAttrRoomComputationAutomatic : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LevelAttrRoomComputationHeight Property

ParameterTypeIdLevelAttrRoomComputationHeight Property

"Computation Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LevelAttrRoomComputationHeight { get; }
Public Shared ReadOnly Property LevelAttrRoomComputationHeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LevelAttrRoomComputationHeight {
    ForgeTypeId^ get ();
}
static member LevelAttrRoomComputationHeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LevelDataFloorArea Property

ParameterTypeIdLevelDataFloorArea Property

"Floor Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LevelDataFloorArea { get; }
Public Shared ReadOnly Property LevelDataFloorArea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LevelDataFloorArea {
    ForgeTypeId^ get ();
}
static member LevelDataFloorArea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LevelDataFloorPerimeter Property

ParameterTypeIdLevelDataFloorPerimeter Property

"Floor Perimeter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LevelDataFloorPerimeter { get; }
Public Shared ReadOnly Property LevelDataFloorPerimeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LevelDataFloorPerimeter {
    ForgeTypeId^ get ();
}
static member LevelDataFloorPerimeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LevelDataMassFamilyAndTypeParam Property

ParameterTypeIdLevelDataMassFamilyAndTypeParam Property

"Mass: Family and Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LevelDataMassFamilyAndTypeParam { get; }
Public Shared ReadOnly Property LevelDataMassFamilyAndTypeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LevelDataMassFamilyAndTypeParam {
    ForgeTypeId^ get ();
}
static member LevelDataMassFamilyAndTypeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LevelDataMassFamilyParam Property

ParameterTypeIdLevelDataMassFamilyParam Property

"Mass: Family"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LevelDataMassFamilyParam { get; }
Public Shared ReadOnly Property LevelDataMassFamilyParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LevelDataMassFamilyParam {
    ForgeTypeId^ get ();
}
static member LevelDataMassFamilyParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LevelDataMassInstanceComments Property

ParameterTypeIdLevelDataMassInstanceComments Property

"Mass: Comments"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LevelDataMassInstanceComments { get; }
Public Shared ReadOnly Property LevelDataMassInstanceComments As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LevelDataMassInstanceComments {
    ForgeTypeId^ get ();
}
static member LevelDataMassInstanceComments : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LevelDataMassTypeComments Property

ParameterTypeIdLevelDataMassTypeComments Property

"Mass: Type Comments"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LevelDataMassTypeComments { get; }
Public Shared ReadOnly Property LevelDataMassTypeComments As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LevelDataMassTypeComments {
    ForgeTypeId^ get ();
}
static member LevelDataMassTypeComments : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LevelDataMassTypeDescription Property

ParameterTypeIdLevelDataMassTypeDescription Property

"Mass: Description"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LevelDataMassTypeDescription { get; }
Public Shared ReadOnly Property LevelDataMassTypeDescription As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LevelDataMassTypeDescription {
    ForgeTypeId^ get ();
}
static member LevelDataMassTypeDescription : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LevelDataMassTypeParam Property

ParameterTypeIdLevelDataMassTypeParam Property

"Mass: Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LevelDataMassTypeParam { get; }
Public Shared ReadOnly Property LevelDataMassTypeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LevelDataMassTypeParam {
    ForgeTypeId^ get ();
}
static member LevelDataMassTypeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LevelDataOwningLevel Property

ParameterTypeIdLevelDataOwningLevel Property

"Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LevelDataOwningLevel { get; }
Public Shared ReadOnly Property LevelDataOwningLevel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LevelDataOwningLevel {
    ForgeTypeId^ get ();
}
static member LevelDataOwningLevel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LevelDataSpaceUsage Property

ParameterTypeIdLevelDataSpaceUsage Property

"Usage"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LevelDataSpaceUsage { get; }
Public Shared ReadOnly Property LevelDataSpaceUsage As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LevelDataSpaceUsage {
    ForgeTypeId^ get ();
}
static member LevelDataSpaceUsage : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LevelDataSurfaceArea Property

ParameterTypeIdLevelDataSurfaceArea Property

"Exterior Surface Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LevelDataSurfaceArea { get; }
Public Shared ReadOnly Property LevelDataSurfaceArea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LevelDataSurfaceArea {
    ForgeTypeId^ get ();
}
static member LevelDataSurfaceArea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LevelDataVolume Property

ParameterTypeIdLevelDataVolume Property

"Floor Volume"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LevelDataVolume { get; }
Public Shared ReadOnly Property LevelDataVolume As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LevelDataVolume {
    ForgeTypeId^ get ();
}
static member LevelDataVolume : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LevelElev Property

ParameterTypeIdLevelElev Property

"Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LevelElev { get; }
Public Shared ReadOnly Property LevelElev As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LevelElev {
    ForgeTypeId^ get ();
}
static member LevelElev : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LevelHeadTag Property

ParameterTypeIdLevelHeadTag Property

"Symbol"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LevelHeadTag { get; }
Public Shared ReadOnly Property LevelHeadTag As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LevelHeadTag {
    ForgeTypeId^ get ();
}
static member LevelHeadTag : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LevelIsBuildingStory Property

ParameterTypeIdLevelIsBuildingStory Property

"Building Story"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LevelIsBuildingStory { get; }
Public Shared ReadOnly Property LevelIsBuildingStory As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LevelIsBuildingStory {
    ForgeTypeId^ get ();
}
static member LevelIsBuildingStory : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LevelIsGroundPlane Property

ParameterTypeIdLevelIsGroundPlane Property

"Is ground plane"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LevelIsGroundPlane { get; }
Public Shared ReadOnly Property LevelIsGroundPlane As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LevelIsGroundPlane {
    ForgeTypeId^ get ();
}
static member LevelIsGroundPlane : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LevelIsStructural Property

ParameterTypeIdLevelIsStructural Property

"Structural"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LevelIsStructural { get; }
Public Shared ReadOnly Property LevelIsStructural As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LevelIsStructural {
    ForgeTypeId^ get ();
}
static member LevelIsStructural : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LevelName Property

ParameterTypeIdLevelName Property

"Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LevelName { get; }
Public Shared ReadOnly Property LevelName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LevelName {
    ForgeTypeId^ get ();
}
static member LevelName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LevelParam Property

ParameterTypeIdLevelParam Property

"Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LevelParam { get; }
Public Shared ReadOnly Property LevelParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LevelParam {
    ForgeTypeId^ get ();
}
static member LevelParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LevelRelativeBaseType Property

ParameterTypeIdLevelRelativeBaseType Property

"Elevation Base"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LevelRelativeBaseType { get; }
Public Shared ReadOnly Property LevelRelativeBaseType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LevelRelativeBaseType {
    ForgeTypeId^ get ();
}
static member LevelRelativeBaseType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LevelRoomComputationHeight Property

ParameterTypeIdLevelRoomComputationHeight Property

"Computation Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LevelRoomComputationHeight { get; }
Public Shared ReadOnly Property LevelRoomComputationHeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LevelRoomComputationHeight {
    ForgeTypeId^ get ();
}
static member LevelRoomComputationHeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LevelUpToLevel Property

ParameterTypeIdLevelUpToLevel Property

"Story Above"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LevelUpToLevel { get; }
Public Shared ReadOnly Property LevelUpToLevel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LevelUpToLevel {
    ForgeTypeId^ get ();
}
static member LevelUpToLevel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LightingFixtureLamp Property

ParameterTypeIdLightingFixtureLamp Property

"Lamp"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LightingFixtureLamp { get; }
Public Shared ReadOnly Property LightingFixtureLamp As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LightingFixtureLamp {
    ForgeTypeId^ get ();
}
static member LightingFixtureLamp : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LightingFixtureLightEmitter Property

ParameterTypeIdLightingFixtureLightEmitter Property

"Light Emitter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LightingFixtureLightEmitter { get; }
Public Shared ReadOnly Property LightingFixtureLightEmitter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LightingFixtureLightEmitter {
    ForgeTypeId^ get ();
}
static member LightingFixtureLightEmitter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LightingFixtureWattage Property

ParameterTypeIdLightingFixtureWattage Property

"Wattage Comments"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LightingFixtureWattage { get; }
Public Shared ReadOnly Property LightingFixtureWattage As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LightingFixtureWattage {
    ForgeTypeId^ get ();
}
static member LightingFixtureWattage : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LinearDimType Property

ParameterTypeIdLinearDimType Property

"Dimension String Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LinearDimType { get; }
Public Shared ReadOnly Property LinearDimType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LinearDimType {
    ForgeTypeId^ get ();
}
static member LinearDimType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LinearFramingLength Property

ParameterTypeIdLinearFramingLength Property

"Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LinearFramingLength { get; }
Public Shared ReadOnly Property LinearFramingLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LinearFramingLength {
    ForgeTypeId^ get ();
}
static member LinearFramingLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LineColor Property

ParameterTypeIdLineColor Property

"Color"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LineColor { get; }
Public Shared ReadOnly Property LineColor As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LineColor {
    ForgeTypeId^ get ();
}
static member LineColor : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LinePattern Property

ParameterTypeIdLinePattern Property

"Line Pattern"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LinePattern { get; }
Public Shared ReadOnly Property LinePattern As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LinePattern {
    ForgeTypeId^ get ();
}
static member LinePattern : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LinePen Property

ParameterTypeIdLinePen Property

"Line Weight"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LinePen { get; }
Public Shared ReadOnly Property LinePen As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LinePen {
    ForgeTypeId^ get ();
}
static member LinePen : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LineShapeAtCorner Property

ParameterTypeIdLineShapeAtCorner Property

"Line Shape at Landing Corner"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LineShapeAtCorner { get; }
Public Shared ReadOnly Property LineShapeAtCorner As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LineShapeAtCorner {
    ForgeTypeId^ get ();
}
static member LineShapeAtCorner : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadAllNon0Loads Property

ParameterTypeIdLoadAllNon0Loads Property

"All non 0 loads"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadAllNon0Loads { get; }
Public Shared ReadOnly Property LoadAllNon0Loads As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadAllNon0Loads {
    ForgeTypeId^ get ();
}
static member LoadAllNon0Loads : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadAreaArea Property

ParameterTypeIdLoadAreaArea Property

"Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadAreaArea { get; }
Public Shared ReadOnly Property LoadAreaArea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadAreaArea {
    ForgeTypeId^ get ();
}
static member LoadAreaArea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadAreaForceFx1 Property

ParameterTypeIdLoadAreaForceFx1 Property

"Fx 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadAreaForceFx1 { get; }
Public Shared ReadOnly Property LoadAreaForceFx1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadAreaForceFx1 {
    ForgeTypeId^ get ();
}
static member LoadAreaForceFx1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadAreaForceFx2 Property

ParameterTypeIdLoadAreaForceFx2 Property

"Fx 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadAreaForceFx2 { get; }
Public Shared ReadOnly Property LoadAreaForceFx2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadAreaForceFx2 {
    ForgeTypeId^ get ();
}
static member LoadAreaForceFx2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadAreaForceFx3 Property

ParameterTypeIdLoadAreaForceFx3 Property

"Fx 3"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadAreaForceFx3 { get; }
Public Shared ReadOnly Property LoadAreaForceFx3 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadAreaForceFx3 {
    ForgeTypeId^ get ();
}
static member LoadAreaForceFx3 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadAreaForceFy1 Property

ParameterTypeIdLoadAreaForceFy1 Property

"Fy 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadAreaForceFy1 { get; }
Public Shared ReadOnly Property LoadAreaForceFy1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadAreaForceFy1 {
    ForgeTypeId^ get ();
}
static member LoadAreaForceFy1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadAreaForceFy2 Property

ParameterTypeIdLoadAreaForceFy2 Property

"Fy 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadAreaForceFy2 { get; }
Public Shared ReadOnly Property LoadAreaForceFy2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadAreaForceFy2 {
    ForgeTypeId^ get ();
}
static member LoadAreaForceFy2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadAreaForceFy3 Property

ParameterTypeIdLoadAreaForceFy3 Property

"Fy 3"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadAreaForceFy3 { get; }
Public Shared ReadOnly Property LoadAreaForceFy3 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadAreaForceFy3 {
    ForgeTypeId^ get ();
}
static member LoadAreaForceFy3 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadAreaForceFz1 Property

ParameterTypeIdLoadAreaForceFz1 Property

"Fz 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadAreaForceFz1 { get; }
Public Shared ReadOnly Property LoadAreaForceFz1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadAreaForceFz1 {
    ForgeTypeId^ get ();
}
static member LoadAreaForceFz1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadAreaForceFz2 Property

ParameterTypeIdLoadAreaForceFz2 Property

"Fz 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadAreaForceFz2 { get; }
Public Shared ReadOnly Property LoadAreaForceFz2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadAreaForceFz2 {
    ForgeTypeId^ get ();
}
static member LoadAreaForceFz2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadAreaForceFz3 Property

ParameterTypeIdLoadAreaForceFz3 Property

"Fz 3"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadAreaForceFz3 { get; }
Public Shared ReadOnly Property LoadAreaForceFz3 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadAreaForceFz3 {
    ForgeTypeId^ get ();
}
static member LoadAreaForceFz3 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadAreaIsProjected Property

ParameterTypeIdLoadAreaIsProjected Property

"Projected Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadAreaIsProjected { get; }
Public Shared ReadOnly Property LoadAreaIsProjected As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadAreaIsProjected {
    ForgeTypeId^ get ();
}
static member LoadAreaIsProjected : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadArrowSeparation Property

ParameterTypeIdLoadArrowSeparation Property

"Distance between arrows"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadArrowSeparation { get; }
Public Shared ReadOnly Property LoadArrowSeparation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadArrowSeparation {
    ForgeTypeId^ get ();
}
static member LoadArrowSeparation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadAttrAreaForceScaleFactor Property

ParameterTypeIdLoadAttrAreaForceScaleFactor Property

"Area force scale"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadAttrAreaForceScaleFactor { get; }
Public Shared ReadOnly Property LoadAttrAreaForceScaleFactor As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadAttrAreaForceScaleFactor {
    ForgeTypeId^ get ();
}
static member LoadAttrAreaForceScaleFactor : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadAttrForceArrowType Property

ParameterTypeIdLoadAttrForceArrowType Property

"Force arrowhead"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadAttrForceArrowType { get; }
Public Shared ReadOnly Property LoadAttrForceArrowType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadAttrForceArrowType {
    ForgeTypeId^ get ();
}
static member LoadAttrForceArrowType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadAttrForceScaleFactor Property

ParameterTypeIdLoadAttrForceScaleFactor Property

"Force scale"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadAttrForceScaleFactor { get; }
Public Shared ReadOnly Property LoadAttrForceScaleFactor As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadAttrForceScaleFactor {
    ForgeTypeId^ get ();
}
static member LoadAttrForceScaleFactor : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadAttrLinearForceScaleFactor Property

ParameterTypeIdLoadAttrLinearForceScaleFactor Property

"Linear force scale"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadAttrLinearForceScaleFactor { get; }
Public Shared ReadOnly Property LoadAttrLinearForceScaleFactor As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadAttrLinearForceScaleFactor {
    ForgeTypeId^ get ();
}
static member LoadAttrLinearForceScaleFactor : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadAttrMomentArrowArc Property

ParameterTypeIdLoadAttrMomentArrowArc Property

"Moment arrowhead"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadAttrMomentArrowArc { get; }
Public Shared ReadOnly Property LoadAttrMomentArrowArc As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadAttrMomentArrowArc {
    ForgeTypeId^ get ();
}
static member LoadAttrMomentArrowArc : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadAttrMomentArrowLine Property

ParameterTypeIdLoadAttrMomentArrowLine Property

"Moment arrowhead (alternate)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadAttrMomentArrowLine { get; }
Public Shared ReadOnly Property LoadAttrMomentArrowLine As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadAttrMomentArrowLine {
    ForgeTypeId^ get ();
}
static member LoadAttrMomentArrowLine : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadAttrMomentScaleFactor Property

ParameterTypeIdLoadAttrMomentScaleFactor Property

"Moment scale"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadAttrMomentScaleFactor { get; }
Public Shared ReadOnly Property LoadAttrMomentScaleFactor As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadAttrMomentScaleFactor {
    ForgeTypeId^ get ();
}
static member LoadAttrMomentScaleFactor : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadCaseId Property

ParameterTypeIdLoadCaseId Property

"Load Case"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadCaseId { get; }
Public Shared ReadOnly Property LoadCaseId As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadCaseId {
    ForgeTypeId^ get ();
}
static member LoadCaseId : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadCaseName Property

ParameterTypeIdLoadCaseName Property

"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadCaseName { get; }
Public Shared ReadOnly Property LoadCaseName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadCaseName {
    ForgeTypeId^ get ();
}
static member LoadCaseName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadCaseNature Property

ParameterTypeIdLoadCaseNature Property

"Nature"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadCaseNature { get; }
Public Shared ReadOnly Property LoadCaseNature As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadCaseNature {
    ForgeTypeId^ get ();
}
static member LoadCaseNature : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadCaseNatureText Property

ParameterTypeIdLoadCaseNatureText Property

"Nature"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadCaseNatureText { get; }
Public Shared ReadOnly Property LoadCaseNatureText As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadCaseNatureText {
    ForgeTypeId^ get ();
}
static member LoadCaseNatureText : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadCaseNumber Property

ParameterTypeIdLoadCaseNumber Property

"Case Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadCaseNumber { get; }
Public Shared ReadOnly Property LoadCaseNumber As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadCaseNumber {
    ForgeTypeId^ get ();
}
static member LoadCaseNumber : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadCaseSubcategory Property

ParameterTypeIdLoadCaseSubcategory Property

"Category"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadCaseSubcategory { get; }
Public Shared ReadOnly Property LoadCaseSubcategory As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadCaseSubcategory {
    ForgeTypeId^ get ();
}
static member LoadCaseSubcategory : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadCombinationFactor Property

ParameterTypeIdLoadCombinationFactor Property

"Factor"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadCombinationFactor { get; }
Public Shared ReadOnly Property LoadCombinationFactor As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadCombinationFactor {
    ForgeTypeId^ get ();
}
static member LoadCombinationFactor : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadCombinationName Property

ParameterTypeIdLoadCombinationName Property

"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadCombinationName { get; }
Public Shared ReadOnly Property LoadCombinationName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadCombinationName {
    ForgeTypeId^ get ();
}
static member LoadCombinationName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadComments Property

ParameterTypeIdLoadComments Property

"Comments"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadComments { get; }
Public Shared ReadOnly Property LoadComments As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadComments {
    ForgeTypeId^ get ();
}
static member LoadComments : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadDescription Property

ParameterTypeIdLoadDescription Property

"Description"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadDescription { get; }
Public Shared ReadOnly Property LoadDescription As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadDescription {
    ForgeTypeId^ get ();
}
static member LoadDescription : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadForceFx Property

ParameterTypeIdLoadForceFx Property

"Fx"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadForceFx { get; }
Public Shared ReadOnly Property LoadForceFx As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadForceFx {
    ForgeTypeId^ get ();
}
static member LoadForceFx : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadForceFy Property

ParameterTypeIdLoadForceFy Property

"Fy"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadForceFy { get; }
Public Shared ReadOnly Property LoadForceFy As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadForceFy {
    ForgeTypeId^ get ();
}
static member LoadForceFy : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadForceFz Property

ParameterTypeIdLoadForceFz Property

"Fz"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadForceFz { get; }
Public Shared ReadOnly Property LoadForceFz As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadForceFz {
    ForgeTypeId^ get ();
}
static member LoadForceFz : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadIsConstrainedOnHost Property

ParameterTypeIdLoadIsConstrainedOnHost Property

"Is constrained on host"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadIsConstrainedOnHost { get; }
Public Shared ReadOnly Property LoadIsConstrainedOnHost As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadIsConstrainedOnHost {
    ForgeTypeId^ get ();
}
static member LoadIsConstrainedOnHost : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadIsHosted Property

ParameterTypeIdLoadIsHosted Property

"Is Hosted"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadIsHosted { get; }
Public Shared ReadOnly Property LoadIsHosted As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadIsHosted {
    ForgeTypeId^ get ();
}
static member LoadIsHosted : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadIsProjected Property

ParameterTypeIdLoadIsProjected Property

"Projected Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadIsProjected { get; }
Public Shared ReadOnly Property LoadIsProjected As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadIsProjected {
    ForgeTypeId^ get ();
}
static member LoadIsProjected : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadIsReaction Property

ParameterTypeIdLoadIsReaction Property

"Is Reaction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadIsReaction { get; }
Public Shared ReadOnly Property LoadIsReaction As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadIsReaction {
    ForgeTypeId^ get ();
}
static member LoadIsReaction : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadIsUniform Property

ParameterTypeIdLoadIsUniform Property

"Uniform Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadIsUniform { get; }
Public Shared ReadOnly Property LoadIsUniform As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadIsUniform {
    ForgeTypeId^ get ();
}
static member LoadIsUniform : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadLinearForceFx1 Property

ParameterTypeIdLoadLinearForceFx1 Property

"Fx 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadLinearForceFx1 { get; }
Public Shared ReadOnly Property LoadLinearForceFx1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadLinearForceFx1 {
    ForgeTypeId^ get ();
}
static member LoadLinearForceFx1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadLinearForceFx2 Property

ParameterTypeIdLoadLinearForceFx2 Property

"Fx 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadLinearForceFx2 { get; }
Public Shared ReadOnly Property LoadLinearForceFx2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadLinearForceFx2 {
    ForgeTypeId^ get ();
}
static member LoadLinearForceFx2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadLinearForceFy1 Property

ParameterTypeIdLoadLinearForceFy1 Property

"Fy 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadLinearForceFy1 { get; }
Public Shared ReadOnly Property LoadLinearForceFy1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadLinearForceFy1 {
    ForgeTypeId^ get ();
}
static member LoadLinearForceFy1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadLinearForceFy2 Property

ParameterTypeIdLoadLinearForceFy2 Property

"Fy 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadLinearForceFy2 { get; }
Public Shared ReadOnly Property LoadLinearForceFy2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadLinearForceFy2 {
    ForgeTypeId^ get ();
}
static member LoadLinearForceFy2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadLinearForceFz1 Property

ParameterTypeIdLoadLinearForceFz1 Property

"Fz 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadLinearForceFz1 { get; }
Public Shared ReadOnly Property LoadLinearForceFz1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadLinearForceFz1 {
    ForgeTypeId^ get ();
}
static member LoadLinearForceFz1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadLinearForceFz2 Property

ParameterTypeIdLoadLinearForceFz2 Property

"Fz 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadLinearForceFz2 { get; }
Public Shared ReadOnly Property LoadLinearForceFz2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadLinearForceFz2 {
    ForgeTypeId^ get ();
}
static member LoadLinearForceFz2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadLinearLength Property

ParameterTypeIdLoadLinearLength Property

"Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadLinearLength { get; }
Public Shared ReadOnly Property LoadLinearLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadLinearLength {
    ForgeTypeId^ get ();
}
static member LoadLinearLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadMomentMx Property

ParameterTypeIdLoadMomentMx Property

"Mx"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadMomentMx { get; }
Public Shared ReadOnly Property LoadMomentMx As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadMomentMx {
    ForgeTypeId^ get ();
}
static member LoadMomentMx : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadMomentMx1 Property

ParameterTypeIdLoadMomentMx1 Property

"Mx 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadMomentMx1 { get; }
Public Shared ReadOnly Property LoadMomentMx1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadMomentMx1 {
    ForgeTypeId^ get ();
}
static member LoadMomentMx1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadMomentMx2 Property

ParameterTypeIdLoadMomentMx2 Property

"Mx 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadMomentMx2 { get; }
Public Shared ReadOnly Property LoadMomentMx2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadMomentMx2 {
    ForgeTypeId^ get ();
}
static member LoadMomentMx2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadMomentMy Property

ParameterTypeIdLoadMomentMy Property

"My"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadMomentMy { get; }
Public Shared ReadOnly Property LoadMomentMy As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadMomentMy {
    ForgeTypeId^ get ();
}
static member LoadMomentMy : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadMomentMy1 Property

ParameterTypeIdLoadMomentMy1 Property

"My 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadMomentMy1 { get; }
Public Shared ReadOnly Property LoadMomentMy1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadMomentMy1 {
    ForgeTypeId^ get ();
}
static member LoadMomentMy1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadMomentMy2 Property

ParameterTypeIdLoadMomentMy2 Property

"My 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadMomentMy2 { get; }
Public Shared ReadOnly Property LoadMomentMy2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadMomentMy2 {
    ForgeTypeId^ get ();
}
static member LoadMomentMy2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadMomentMz Property

ParameterTypeIdLoadMomentMz Property

"Mz"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadMomentMz { get; }
Public Shared ReadOnly Property LoadMomentMz As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadMomentMz {
    ForgeTypeId^ get ();
}
static member LoadMomentMz : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadMomentMz1 Property

ParameterTypeIdLoadMomentMz1 Property

"Mz 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadMomentMz1 { get; }
Public Shared ReadOnly Property LoadMomentMz1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadMomentMz1 {
    ForgeTypeId^ get ();
}
static member LoadMomentMz1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadMomentMz2 Property

ParameterTypeIdLoadMomentMz2 Property

"Mz 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadMomentMz2 { get; }
Public Shared ReadOnly Property LoadMomentMz2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadMomentMz2 {
    ForgeTypeId^ get ();
}
static member LoadMomentMz2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadNatureName Property

ParameterTypeIdLoadNatureName Property

"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadNatureName { get; }
Public Shared ReadOnly Property LoadNatureName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadNatureName {
    ForgeTypeId^ get ();
}
static member LoadNatureName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadUsageName Property

ParameterTypeIdLoadUsageName Property

"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadUsageName { get; }
Public Shared ReadOnly Property LoadUsageName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadUsageName {
    ForgeTypeId^ get ();
}
static member LoadUsageName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LoadUseLocalCoordinateSystem Property

ParameterTypeIdLoadUseLocalCoordinateSystem Property

"Orient to"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadUseLocalCoordinateSystem { get; }
Public Shared ReadOnly Property LoadUseLocalCoordinateSystem As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadUseLocalCoordinateSystem {
    ForgeTypeId^ get ();
}
static member LoadUseLocalCoordinateSystem : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LockAlignmentUiToggle Property

ParameterTypeIdLockAlignmentUiToggle Property

"Lock": This is used by the UI to allow selection of lock alignment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LockAlignmentUiToggle { get; }
Public Shared ReadOnly Property LockAlignmentUiToggle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LockAlignmentUiToggle {
    ForgeTypeId^ get ();
}
static member LockAlignmentUiToggle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LockedBaseOffset Property

ParameterTypeIdLockedBaseOffset Property

"Negative Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LockedBaseOffset { get; }
Public Shared ReadOnly Property LockedBaseOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LockedBaseOffset {
    ForgeTypeId^ get ();
}
static member LockedBaseOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LockedEndOffset Property

ParameterTypeIdLockedEndOffset Property

"Positive Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LockedEndOffset { get; }
Public Shared ReadOnly Property LockedEndOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LockedEndOffset {
    ForgeTypeId^ get ();
}
static member LockedEndOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LockedStartOffset Property

ParameterTypeIdLockedStartOffset Property

"Negative Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LockedStartOffset { get; }
Public Shared ReadOnly Property LockedStartOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LockedStartOffset {
    ForgeTypeId^ get ();
}
static member LockedStartOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LockedTopOffset Property

ParameterTypeIdLockedTopOffset Property

"Positive Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LockedTopOffset { get; }
Public Shared ReadOnly Property LockedTopOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LockedTopOffset {
    ForgeTypeId^ get ();
}
static member LockedTopOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LowestAssociatedLevel Property

ParameterTypeIdLowestAssociatedLevel Property

"Lowest Associated Level": The lowest level associated with this Analytical Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LowestAssociatedLevel { get; }
Public Shared ReadOnly Property LowestAssociatedLevel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LowestAssociatedLevel {
    ForgeTypeId^ get ();
}
static member LowestAssociatedLevel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LvMullionLeg1 Property

ParameterTypeIdLvMullionLeg1 Property

"Leg 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LvMullionLeg1 { get; }
Public Shared ReadOnly Property LvMullionLeg1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LvMullionLeg1 {
    ForgeTypeId^ get ();
}
static member LvMullionLeg1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.LvMullionLeg2 Property

ParameterTypeIdLvMullionLeg2 Property

"Leg 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LvMullionLeg2 { get; }
Public Shared ReadOnly Property LvMullionLeg2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LvMullionLeg2 {
    ForgeTypeId^ get ();
}
static member LvMullionLeg2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MarkupsCreated Property

ParameterTypeIdMarkupsCreated Property

"Created"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MarkupsCreated { get; }
Public Shared ReadOnly Property MarkupsCreated As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MarkupsCreated {
    ForgeTypeId^ get ();
}
static member MarkupsCreated : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MarkupsCreator Property

ParameterTypeIdMarkupsCreator Property

"Creator"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MarkupsCreator { get; }
Public Shared ReadOnly Property MarkupsCreator As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MarkupsCreator {
    ForgeTypeId^ get ();
}
static member MarkupsCreator : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MarkupsHistory Property

ParameterTypeIdMarkupsHistory Property

"History"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MarkupsHistory { get; }
Public Shared ReadOnly Property MarkupsHistory As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MarkupsHistory {
    ForgeTypeId^ get ();
}
static member MarkupsHistory : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MarkupsLabel Property

ParameterTypeIdMarkupsLabel Property

"Label"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MarkupsLabel { get; }
Public Shared ReadOnly Property MarkupsLabel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MarkupsLabel {
    ForgeTypeId^ get ();
}
static member MarkupsLabel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MarkupsModified Property

ParameterTypeIdMarkupsModified Property

"Modified"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MarkupsModified { get; }
Public Shared ReadOnly Property MarkupsModified As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MarkupsModified {
    ForgeTypeId^ get ();
}
static member MarkupsModified : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MarkupsNotes Property

ParameterTypeIdMarkupsNotes Property

"Notes"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MarkupsNotes { get; }
Public Shared ReadOnly Property MarkupsNotes As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MarkupsNotes {
    ForgeTypeId^ get ();
}
static member MarkupsNotes : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MarkupsPrivate Property

ParameterTypeIdMarkupsPrivate Property

"Private"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MarkupsPrivate { get; }
Public Shared ReadOnly Property MarkupsPrivate As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MarkupsPrivate {
    ForgeTypeId^ get ();
}
static member MarkupsPrivate : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MarkupsStatus Property

ParameterTypeIdMarkupsStatus Property

"Status"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MarkupsStatus { get; }
Public Shared ReadOnly Property MarkupsStatus As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MarkupsStatus {
    ForgeTypeId^ get ();
}
static member MarkupsStatus : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MassDataConceptualConstruction Property

ParameterTypeIdMassDataConceptualConstruction Property

"Conceptual Types"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MassDataConceptualConstruction { get; }
Public Shared ReadOnly Property MassDataConceptualConstruction As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MassDataConceptualConstruction {
    ForgeTypeId^ get ();
}
static member MassDataConceptualConstruction : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MassDataGlazingIsShaded Property

ParameterTypeIdMassDataGlazingIsShaded Property

"Glazing is Shaded"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MassDataGlazingIsShaded { get; }
Public Shared ReadOnly Property MassDataGlazingIsShaded As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MassDataGlazingIsShaded {
    ForgeTypeId^ get ();
}
static member MassDataGlazingIsShaded : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MassDataMassExteriorWallArea Property

ParameterTypeIdMassDataMassExteriorWallArea Property

"Mass Exterior Wall Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MassDataMassExteriorWallArea { get; }
Public Shared ReadOnly Property MassDataMassExteriorWallArea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MassDataMassExteriorWallArea {
    ForgeTypeId^ get ();
}
static member MassDataMassExteriorWallArea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MassDataMassInteriorWallArea Property

ParameterTypeIdMassDataMassInteriorWallArea Property

"Mass Interior Wall Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MassDataMassInteriorWallArea { get; }
Public Shared ReadOnly Property MassDataMassInteriorWallArea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MassDataMassInteriorWallArea {
    ForgeTypeId^ get ();
}
static member MassDataMassInteriorWallArea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MassDataMassOpeningArea Property

ParameterTypeIdMassDataMassOpeningArea Property

"Mass Opening Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MassDataMassOpeningArea { get; }
Public Shared ReadOnly Property MassDataMassOpeningArea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MassDataMassOpeningArea {
    ForgeTypeId^ get ();
}
static member MassDataMassOpeningArea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MassDataMassRoofArea Property

ParameterTypeIdMassDataMassRoofArea Property

"Mass Roof Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MassDataMassRoofArea { get; }
Public Shared ReadOnly Property MassDataMassRoofArea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MassDataMassRoofArea {
    ForgeTypeId^ get ();
}
static member MassDataMassRoofArea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MassDataMassSkylightArea Property

ParameterTypeIdMassDataMassSkylightArea Property

"Mass Skylight Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MassDataMassSkylightArea { get; }
Public Shared ReadOnly Property MassDataMassSkylightArea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MassDataMassSkylightArea {
    ForgeTypeId^ get ();
}
static member MassDataMassSkylightArea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MassDataMassWindowArea Property

ParameterTypeIdMassDataMassWindowArea Property

"Mass Window Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MassDataMassWindowArea { get; }
Public Shared ReadOnly Property MassDataMassWindowArea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MassDataMassWindowArea {
    ForgeTypeId^ get ();
}
static member MassDataMassWindowArea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MassDataPercentageGlazing Property

ParameterTypeIdMassDataPercentageGlazing Property

"Target Percentage Glazing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MassDataPercentageGlazing { get; }
Public Shared ReadOnly Property MassDataPercentageGlazing As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MassDataPercentageGlazing {
    ForgeTypeId^ get ();
}
static member MassDataPercentageGlazing : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MassDataPercentageSkylights Property

ParameterTypeIdMassDataPercentageSkylights Property

"Target Percentage Skylights"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MassDataPercentageSkylights { get; }
Public Shared ReadOnly Property MassDataPercentageSkylights As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MassDataPercentageSkylights {
    ForgeTypeId^ get ();
}
static member MassDataPercentageSkylights : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MassDataShadeDepth Property

ParameterTypeIdMassDataShadeDepth Property

"Shade Depth"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MassDataShadeDepth { get; }
Public Shared ReadOnly Property MassDataShadeDepth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MassDataShadeDepth {
    ForgeTypeId^ get ();
}
static member MassDataShadeDepth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MassDataSillHeight Property

ParameterTypeIdMassDataSillHeight Property

"Target Sill Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MassDataSillHeight { get; }
Public Shared ReadOnly Property MassDataSillHeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MassDataSillHeight {
    ForgeTypeId^ get ();
}
static member MassDataSillHeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MassDataSkylightWidth Property

ParameterTypeIdMassDataSkylightWidth Property

"Skylight Width & Depth"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MassDataSkylightWidth { get; }
Public Shared ReadOnly Property MassDataSkylightWidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MassDataSkylightWidth {
    ForgeTypeId^ get ();
}
static member MassDataSkylightWidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MassDataSlab Property

ParameterTypeIdMassDataSlab Property

"Slab"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MassDataSlab { get; }
Public Shared ReadOnly Property MassDataSlab As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MassDataSlab {
    ForgeTypeId^ get ();
}
static member MassDataSlab : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MassDataSubcategory Property

ParameterTypeIdMassDataSubcategory Property

"Subcategory"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MassDataSubcategory { get; }
Public Shared ReadOnly Property MassDataSubcategory As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MassDataSubcategory {
    ForgeTypeId^ get ();
}
static member MassDataSubcategory : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MassDataSurfaceDataSource Property

ParameterTypeIdMassDataSurfaceDataSource Property

"Values"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MassDataSurfaceDataSource { get; }
Public Shared ReadOnly Property MassDataSurfaceDataSource As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MassDataSurfaceDataSource {
    ForgeTypeId^ get ();
}
static member MassDataSurfaceDataSource : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MassDataUnderground Property

ParameterTypeIdMassDataUnderground Property

"Underground"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MassDataUnderground { get; }
Public Shared ReadOnly Property MassDataUnderground As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MassDataUnderground {
    ForgeTypeId^ get ();
}
static member MassDataUnderground : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MassFloorAreaLevels Property

ParameterTypeIdMassFloorAreaLevels Property

"Mass Floors"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MassFloorAreaLevels { get; }
Public Shared ReadOnly Property MassFloorAreaLevels As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MassFloorAreaLevels {
    ForgeTypeId^ get ();
}
static member MassFloorAreaLevels : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MassGrossArea Property

ParameterTypeIdMassGrossArea Property

"Gross Floor Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MassGrossArea { get; }
Public Shared ReadOnly Property MassGrossArea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MassGrossArea {
    ForgeTypeId^ get ();
}
static member MassGrossArea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MassGrossSurfaceArea Property

ParameterTypeIdMassGrossSurfaceArea Property

"Gross Surface Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MassGrossSurfaceArea { get; }
Public Shared ReadOnly Property MassGrossSurfaceArea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MassGrossSurfaceArea {
    ForgeTypeId^ get ();
}
static member MassGrossSurfaceArea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MassGrossVolume Property

ParameterTypeIdMassGrossVolume Property

"Gross Volume"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MassGrossVolume { get; }
Public Shared ReadOnly Property MassGrossVolume As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MassGrossVolume {
    ForgeTypeId^ get ();
}
static member MassGrossVolume : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MassingIntegrationLevel Property

ParameterTypeIdMassingIntegrationLevel Property

"Constrain to Massing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MassingIntegrationLevel { get; }
Public Shared ReadOnly Property MassingIntegrationLevel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MassingIntegrationLevel {
    ForgeTypeId^ get ();
}
static member MassingIntegrationLevel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MassSurfacedataMaterial Property

ParameterTypeIdMassSurfacedataMaterial Property

"Graphical Appearance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MassSurfacedataMaterial { get; }
Public Shared ReadOnly Property MassSurfacedataMaterial As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MassSurfacedataMaterial {
    ForgeTypeId^ get ();
}
static member MassSurfacedataMaterial : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MassZoneConditionTypeParam Property

ParameterTypeIdMassZoneConditionTypeParam Property

"Condition Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MassZoneConditionTypeParam { get; }
Public Shared ReadOnly Property MassZoneConditionTypeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MassZoneConditionTypeParam {
    ForgeTypeId^ get ();
}
static member MassZoneConditionTypeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MassZoneFloorArea Property

ParameterTypeIdMassZoneFloorArea Property

"Mass Floor Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MassZoneFloorArea { get; }
Public Shared ReadOnly Property MassZoneFloorArea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MassZoneFloorArea {
    ForgeTypeId^ get ();
}
static member MassZoneFloorArea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MassZoneMaterial Property

ParameterTypeIdMassZoneMaterial Property

"Graphical Appearance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MassZoneMaterial { get; }
Public Shared ReadOnly Property MassZoneMaterial As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MassZoneMaterial {
    ForgeTypeId^ get ();
}
static member MassZoneMaterial : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MassZoneSpaceTypeParam Property

ParameterTypeIdMassZoneSpaceTypeParam Property

"Space Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MassZoneSpaceTypeParam { get; }
Public Shared ReadOnly Property MassZoneSpaceTypeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MassZoneSpaceTypeParam {
    ForgeTypeId^ get ();
}
static member MassZoneSpaceTypeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MassZoneVolume Property

ParameterTypeIdMassZoneVolume Property

"Mass Zone Volume"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MassZoneVolume { get; }
Public Shared ReadOnly Property MassZoneVolume As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MassZoneVolume {
    ForgeTypeId^ get ();
}
static member MassZoneVolume : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MatchlineBottomOffset Property

ParameterTypeIdMatchlineBottomOffset Property

"Bottom Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MatchlineBottomOffset { get; }
Public Shared ReadOnly Property MatchlineBottomOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MatchlineBottomOffset {
    ForgeTypeId^ get ();
}
static member MatchlineBottomOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MatchlineBottomPlane Property

ParameterTypeIdMatchlineBottomPlane Property

"Bottom Constraint"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MatchlineBottomPlane { get; }
Public Shared ReadOnly Property MatchlineBottomPlane As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MatchlineBottomPlane {
    ForgeTypeId^ get ();
}
static member MatchlineBottomPlane : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MatchlineTopOffset Property

ParameterTypeIdMatchlineTopOffset Property

"Top Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MatchlineTopOffset { get; }
Public Shared ReadOnly Property MatchlineTopOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MatchlineTopOffset {
    ForgeTypeId^ get ();
}
static member MatchlineTopOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MatchlineTopPlane Property

ParameterTypeIdMatchlineTopPlane Property

"Top Constraint"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MatchlineTopPlane { get; }
Public Shared ReadOnly Property MatchlineTopPlane As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MatchlineTopPlane {
    ForgeTypeId^ get ();
}
static member MatchlineTopPlane : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MaterialArea Property

ParameterTypeIdMaterialArea Property

"Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MaterialArea { get; }
Public Shared ReadOnly Property MaterialArea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MaterialArea {
    ForgeTypeId^ get ();
}
static member MaterialArea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MaterialAspaint Property

ParameterTypeIdMaterialAspaint Property

"As Paint"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MaterialAspaint { get; }
Public Shared ReadOnly Property MaterialAspaint As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MaterialAspaint {
    ForgeTypeId^ get ();
}
static member MaterialAspaint : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MaterialAssetParamAssetLibId Property

ParameterTypeIdMaterialAssetParamAssetLibId Property

"Asset library id"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MaterialAssetParamAssetLibId { get; }
Public Shared ReadOnly Property MaterialAssetParamAssetLibId As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MaterialAssetParamAssetLibId {
    ForgeTypeId^ get ();
}
static member MaterialAssetParamAssetLibId : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MaterialAssetParamCommonSharedAsset Property

ParameterTypeIdMaterialAssetParamCommonSharedAsset Property

"Sharing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MaterialAssetParamCommonSharedAsset { get; }
Public Shared ReadOnly Property MaterialAssetParamCommonSharedAsset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MaterialAssetParamCommonSharedAsset {
    ForgeTypeId^ get ();
}
static member MaterialAssetParamCommonSharedAsset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MaterialAssetParamExternalMaterialId Property

ParameterTypeIdMaterialAssetParamExternalMaterialId Property

"External Material ID"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MaterialAssetParamExternalMaterialId { get; }
Public Shared ReadOnly Property MaterialAssetParamExternalMaterialId As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MaterialAssetParamExternalMaterialId {
    ForgeTypeId^ get ();
}
static member MaterialAssetParamExternalMaterialId : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MaterialAssetParamSource Property

ParameterTypeIdMaterialAssetParamSource Property

"Source"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MaterialAssetParamSource { get; }
Public Shared ReadOnly Property MaterialAssetParamSource As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MaterialAssetParamSource {
    ForgeTypeId^ get ();
}
static member MaterialAssetParamSource : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MaterialAssetParamSourceUrl Property

ParameterTypeIdMaterialAssetParamSourceUrl Property

"Source URL"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MaterialAssetParamSourceUrl { get; }
Public Shared ReadOnly Property MaterialAssetParamSourceUrl As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MaterialAssetParamSourceUrl {
    ForgeTypeId^ get ();
}
static member MaterialAssetParamSourceUrl : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MaterialIdParam Property

ParameterTypeIdMaterialIdParam Property

"Material"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MaterialIdParam { get; }
Public Shared ReadOnly Property MaterialIdParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MaterialIdParam {
    ForgeTypeId^ get ();
}
static member MaterialIdParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MaterialName Property

ParameterTypeIdMaterialName Property

"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MaterialName { get; }
Public Shared ReadOnly Property MaterialName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MaterialName {
    ForgeTypeId^ get ();
}
static member MaterialName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MaterialParamColor Property

ParameterTypeIdMaterialParamColor Property

"Color"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MaterialParamColor { get; }
Public Shared ReadOnly Property MaterialParamColor As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MaterialParamColor {
    ForgeTypeId^ get ();
}
static member MaterialParamColor : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MaterialParamGlow Property

ParameterTypeIdMaterialParamGlow Property

"Glow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MaterialParamGlow { get; }
Public Shared ReadOnly Property MaterialParamGlow As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MaterialParamGlow {
    ForgeTypeId^ get ();
}
static member MaterialParamGlow : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MaterialParamShininess Property

ParameterTypeIdMaterialParamShininess Property

"Shininess"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MaterialParamShininess { get; }
Public Shared ReadOnly Property MaterialParamShininess As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MaterialParamShininess {
    ForgeTypeId^ get ();
}
static member MaterialParamShininess : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MaterialParamSmoothness Property

ParameterTypeIdMaterialParamSmoothness Property

"Smoothness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MaterialParamSmoothness { get; }
Public Shared ReadOnly Property MaterialParamSmoothness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MaterialParamSmoothness {
    ForgeTypeId^ get ();
}
static member MaterialParamSmoothness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MaterialParamTransparency Property

ParameterTypeIdMaterialParamTransparency Property

"Transparency"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MaterialParamTransparency { get; }
Public Shared ReadOnly Property MaterialParamTransparency As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MaterialParamTransparency {
    ForgeTypeId^ get ();
}
static member MaterialParamTransparency : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MaterialVolume Property

ParameterTypeIdMaterialVolume Property

"Volume"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MaterialVolume { get; }
Public Shared ReadOnly Property MaterialVolume As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MaterialVolume {
    ForgeTypeId^ get ();
}
static member MaterialVolume : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MeasureFromStructure Property

ParameterTypeIdMeasureFromStructure Property

"Extend into wall (to core)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MeasureFromStructure { get; }
Public Shared ReadOnly Property MeasureFromStructure As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MeasureFromStructure {
    ForgeTypeId^ get ();
}
static member MeasureFromStructure : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MechanicalEquipmentSetIdParam Property

ParameterTypeIdMechanicalEquipmentSetIdParam Property

"Mechanical Equipment Set"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MechanicalEquipmentSetIdParam { get; }
Public Shared ReadOnly Property MechanicalEquipmentSetIdParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MechanicalEquipmentSetIdParam {
    ForgeTypeId^ get ();
}
static member MechanicalEquipmentSetIdParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MechanicalEquipmentSetName Property

ParameterTypeIdMechanicalEquipmentSetName Property

"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MechanicalEquipmentSetName { get; }
Public Shared ReadOnly Property MechanicalEquipmentSetName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MechanicalEquipmentSetName {
    ForgeTypeId^ get ();
}
static member MechanicalEquipmentSetName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MechanicalEquipmentSetOnDuty Property

ParameterTypeIdMechanicalEquipmentSetOnDuty Property

"On Duty"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MechanicalEquipmentSetOnDuty { get; }
Public Shared ReadOnly Property MechanicalEquipmentSetOnDuty As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MechanicalEquipmentSetOnDuty {
    ForgeTypeId^ get ();
}
static member MechanicalEquipmentSetOnDuty : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MechanicalEquipmentSetOnStandby Property

ParameterTypeIdMechanicalEquipmentSetOnStandby Property

"On Standby"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MechanicalEquipmentSetOnStandby { get; }
Public Shared ReadOnly Property MechanicalEquipmentSetOnStandby As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MechanicalEquipmentSetOnStandby {
    ForgeTypeId^ get ();
}
static member MechanicalEquipmentSetOnStandby : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepAirloopFantype Property

ParameterTypeIdMepAirloopFantype Property

"Fan"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepAirloopFantype { get; }
Public Shared ReadOnly Property MepAirloopFantype As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepAirloopFantype {
    ForgeTypeId^ get ();
}
static member MepAirloopFantype : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepAirloopHeatexchangerType Property

ParameterTypeIdMepAirloopHeatexchangerType Property

"Heat Exchanger"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepAirloopHeatexchangerType { get; }
Public Shared ReadOnly Property MepAirloopHeatexchangerType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepAirloopHeatexchangerType {
    ForgeTypeId^ get ();
}
static member MepAirloopHeatexchangerType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepAirloopPreheatCoiltype Property

ParameterTypeIdMepAirloopPreheatCoiltype Property

"Preheat Coil"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepAirloopPreheatCoiltype { get; }
Public Shared ReadOnly Property MepAirloopPreheatCoiltype As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepAirloopPreheatCoiltype {
    ForgeTypeId^ get ();
}
static member MepAirloopPreheatCoiltype : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepAnalyticalCriticalpathParam Property

ParameterTypeIdMepAnalyticalCriticalpathParam Property

"Critical Path"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepAnalyticalCriticalpathParam { get; }
Public Shared ReadOnly Property MepAnalyticalCriticalpathParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepAnalyticalCriticalpathParam {
    ForgeTypeId^ get ();
}
static member MepAnalyticalCriticalpathParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepAnalyticalCriticalsequence Property

ParameterTypeIdMepAnalyticalCriticalsequence Property

"Critical Sequence"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepAnalyticalCriticalsequence { get; }
Public Shared ReadOnly Property MepAnalyticalCriticalsequence As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepAnalyticalCriticalsequence {
    ForgeTypeId^ get ();
}
static member MepAnalyticalCriticalsequence : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepAnalyticalElecApparentPowerRating Property

ParameterTypeIdMepAnalyticalElecApparentPowerRating Property

"Apparent Power Rating"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepAnalyticalElecApparentPowerRating { get; }
Public Shared ReadOnly Property MepAnalyticalElecApparentPowerRating As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepAnalyticalElecApparentPowerRating {
    ForgeTypeId^ get ();
}
static member MepAnalyticalElecApparentPowerRating : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepAnalyticalElecCurrent Property

ParameterTypeIdMepAnalyticalElecCurrent Property

"Current"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepAnalyticalElecCurrent { get; }
Public Shared ReadOnly Property MepAnalyticalElecCurrent As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepAnalyticalElecCurrent {
    ForgeTypeId^ get ();
}
static member MepAnalyticalElecCurrent : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepAnalyticalElecCurrentRating Property

ParameterTypeIdMepAnalyticalElecCurrentRating Property

"Current Rating"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepAnalyticalElecCurrentRating { get; }
Public Shared ReadOnly Property MepAnalyticalElecCurrentRating As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepAnalyticalElecCurrentRating {
    ForgeTypeId^ get ();
}
static member MepAnalyticalElecCurrentRating : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepAnalyticalElecVoltage Property

ParameterTypeIdMepAnalyticalElecVoltage Property

"Voltage"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepAnalyticalElecVoltage { get; }
Public Shared ReadOnly Property MepAnalyticalElecVoltage As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepAnalyticalElecVoltage {
    ForgeTypeId^ get ();
}
static member MepAnalyticalElecVoltage : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepAnalyticalEquipmentName Property

ParameterTypeIdMepAnalyticalEquipmentName Property

"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepAnalyticalEquipmentName { get; }
Public Shared ReadOnly Property MepAnalyticalEquipmentName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepAnalyticalEquipmentName {
    ForgeTypeId^ get ();
}
static member MepAnalyticalEquipmentName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepAnalyticalHeadersegment Property

ParameterTypeIdMepAnalyticalHeadersegment Property

"Header"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepAnalyticalHeadersegment { get; }
Public Shared ReadOnly Property MepAnalyticalHeadersegment As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepAnalyticalHeadersegment {
    ForgeTypeId^ get ();
}
static member MepAnalyticalHeadersegment : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepAnalyticalHydraulicloop Property

ParameterTypeIdMepAnalyticalHydraulicloop Property

"Hydraulic Loop"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepAnalyticalHydraulicloop { get; }
Public Shared ReadOnly Property MepAnalyticalHydraulicloop As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepAnalyticalHydraulicloop {
    ForgeTypeId^ get ();
}
static member MepAnalyticalHydraulicloop : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepAnalyticalLoopBoundaryParam Property

ParameterTypeIdMepAnalyticalLoopBoundaryParam Property

"Loop Boundary"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepAnalyticalLoopBoundaryParam { get; }
Public Shared ReadOnly Property MepAnalyticalLoopBoundaryParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepAnalyticalLoopBoundaryParam {
    ForgeTypeId^ get ();
}
static member MepAnalyticalLoopBoundaryParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepAnalyticalLoopName Property

ParameterTypeIdMepAnalyticalLoopName Property

"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepAnalyticalLoopName { get; }
Public Shared ReadOnly Property MepAnalyticalLoopName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepAnalyticalLoopName {
    ForgeTypeId^ get ();
}
static member MepAnalyticalLoopName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepAnalyticalNetwork Property

ParameterTypeIdMepAnalyticalNetwork Property

"Network Id"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepAnalyticalNetwork { get; }
Public Shared ReadOnly Property MepAnalyticalNetwork As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepAnalyticalNetwork {
    ForgeTypeId^ get ();
}
static member MepAnalyticalNetwork : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepAnalyticalPipeDesignflow Property

ParameterTypeIdMepAnalyticalPipeDesignflow Property

"Design Flow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepAnalyticalPipeDesignflow { get; }
Public Shared ReadOnly Property MepAnalyticalPipeDesignflow As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepAnalyticalPipeDesignflow {
    ForgeTypeId^ get ();
}
static member MepAnalyticalPipeDesignflow : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepChilledWaterLoop Property

ParameterTypeIdMepChilledWaterLoop Property

"Chilled Water Loop"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepChilledWaterLoop { get; }
Public Shared ReadOnly Property MepChilledWaterLoop As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepChilledWaterLoop {
    ForgeTypeId^ get ();
}
static member MepChilledWaterLoop : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepCondenserWaterLoop Property

ParameterTypeIdMepCondenserWaterLoop Property

"Condenser Water Loop"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepCondenserWaterLoop { get; }
Public Shared ReadOnly Property MepCondenserWaterLoop As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepCondenserWaterLoop {
    ForgeTypeId^ get ();
}
static member MepCondenserWaterLoop : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepCoolingCoilType Property

ParameterTypeIdMepCoolingCoilType Property

"Cooling Coil"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepCoolingCoilType { get; }
Public Shared ReadOnly Property MepCoolingCoilType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepCoolingCoilType {
    ForgeTypeId^ get ();
}
static member MepCoolingCoilType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepElecZoneEquipmentType Property

ParameterTypeIdMepElecZoneEquipmentType Property

"Equipment Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepElecZoneEquipmentType { get; }
Public Shared ReadOnly Property MepElecZoneEquipmentType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepElecZoneEquipmentType {
    ForgeTypeId^ get ();
}
static member MepElecZoneEquipmentType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepEquipmentCalcPipingflowParam Property

ParameterTypeIdMepEquipmentCalcPipingflowParam Property

"Calculated Flow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepEquipmentCalcPipingflowParam { get; }
Public Shared ReadOnly Property MepEquipmentCalcPipingflowParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepEquipmentCalcPipingflowParam {
    ForgeTypeId^ get ();
}
static member MepEquipmentCalcPipingflowParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepEquipmentCalcPipingpressuredropParam Property

ParameterTypeIdMepEquipmentCalcPipingpressuredropParam Property

"Calculated Pressure Drop"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepEquipmentCalcPipingpressuredropParam { get; }
Public Shared ReadOnly Property MepEquipmentCalcPipingpressuredropParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepEquipmentCalcPipingpressuredropParam {
    ForgeTypeId^ get ();
}
static member MepEquipmentCalcPipingpressuredropParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepEquipmentClassification Property

ParameterTypeIdMepEquipmentClassification Property

"Classification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepEquipmentClassification { get; }
Public Shared ReadOnly Property MepEquipmentClassification As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepEquipmentClassification {
    ForgeTypeId^ get ();
}
static member MepEquipmentClassification : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepHeatingCoilType Property

ParameterTypeIdMepHeatingCoilType Property

"Heating Coil"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepHeatingCoilType { get; }
Public Shared ReadOnly Property MepHeatingCoilType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepHeatingCoilType {
    ForgeTypeId^ get ();
}
static member MepHeatingCoilType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepHeatingHotwaterLoop Property

ParameterTypeIdMepHeatingHotwaterLoop Property

"Heating Hot Water Loop"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepHeatingHotwaterLoop { get; }
Public Shared ReadOnly Property MepHeatingHotwaterLoop As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepHeatingHotwaterLoop {
    ForgeTypeId^ get ();
}
static member MepHeatingHotwaterLoop : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepIgnoreFlowAnalysis Property

ParameterTypeIdMepIgnoreFlowAnalysis Property

"Ignore Flow Analysis"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepIgnoreFlowAnalysis { get; }
Public Shared ReadOnly Property MepIgnoreFlowAnalysis As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepIgnoreFlowAnalysis {
    ForgeTypeId^ get ();
}
static member MepIgnoreFlowAnalysis : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepLowerBottomElevation Property

ParameterTypeIdMepLowerBottomElevation Property

"Lower End Bottom Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepLowerBottomElevation { get; }
Public Shared ReadOnly Property MepLowerBottomElevation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepLowerBottomElevation {
    ForgeTypeId^ get ();
}
static member MepLowerBottomElevation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepLowerBottomElevationIncludeInsulation Property

ParameterTypeIdMepLowerBottomElevationIncludeInsulation Property

"Lower End Bottom of Insulation Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepLowerBottomElevationIncludeInsulation { get; }
Public Shared ReadOnly Property MepLowerBottomElevationIncludeInsulation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepLowerBottomElevationIncludeInsulation {
    ForgeTypeId^ get ();
}
static member MepLowerBottomElevationIncludeInsulation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepLowerCenterlineElevation Property

ParameterTypeIdMepLowerCenterlineElevation Property

"Lower End Centerline Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepLowerCenterlineElevation { get; }
Public Shared ReadOnly Property MepLowerCenterlineElevation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepLowerCenterlineElevation {
    ForgeTypeId^ get ();
}
static member MepLowerCenterlineElevation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepLowerTopElevation Property

ParameterTypeIdMepLowerTopElevation Property

"Lower End Top Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepLowerTopElevation { get; }
Public Shared ReadOnly Property MepLowerTopElevation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepLowerTopElevation {
    ForgeTypeId^ get ();
}
static member MepLowerTopElevation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepLowerTopElevationIncludeInsulation Property

ParameterTypeIdMepLowerTopElevationIncludeInsulation Property

"Lower End Top of Insulation Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepLowerTopElevationIncludeInsulation { get; }
Public Shared ReadOnly Property MepLowerTopElevationIncludeInsulation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepLowerTopElevationIncludeInsulation {
    ForgeTypeId^ get ();
}
static member MepLowerTopElevationIncludeInsulation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepPipeLowerInvertElevation Property

ParameterTypeIdMepPipeLowerInvertElevation Property

"Lower End Invert Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepPipeLowerInvertElevation { get; }
Public Shared ReadOnly Property MepPipeLowerInvertElevation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepPipeLowerInvertElevation {
    ForgeTypeId^ get ();
}
static member MepPipeLowerInvertElevation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepPipeLowerObvertElevation Property

ParameterTypeIdMepPipeLowerObvertElevation Property

"Lower End Obvert Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepPipeLowerObvertElevation { get; }
Public Shared ReadOnly Property MepPipeLowerObvertElevation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepPipeLowerObvertElevation {
    ForgeTypeId^ get ();
}
static member MepPipeLowerObvertElevation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepPipeUpperInvertElevation Property

ParameterTypeIdMepPipeUpperInvertElevation Property

"Upper End Invert Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepPipeUpperInvertElevation { get; }
Public Shared ReadOnly Property MepPipeUpperInvertElevation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepPipeUpperInvertElevation {
    ForgeTypeId^ get ();
}
static member MepPipeUpperInvertElevation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepPipeUpperObvertElevation Property

ParameterTypeIdMepPipeUpperObvertElevation Property

"Upper End Obvert Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepPipeUpperObvertElevation { get; }
Public Shared ReadOnly Property MepPipeUpperObvertElevation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepPipeUpperObvertElevation {
    ForgeTypeId^ get ();
}
static member MepPipeUpperObvertElevation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepPreheatHotwaterLoop Property

ParameterTypeIdMepPreheatHotwaterLoop Property

"Preheat Hot Water Loop"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepPreheatHotwaterLoop { get; }
Public Shared ReadOnly Property MepPreheatHotwaterLoop As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepPreheatHotwaterLoop {
    ForgeTypeId^ get ();
}
static member MepPreheatHotwaterLoop : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepProfileTypeParam Property

ParameterTypeIdMepProfileTypeParam Property

"Shape"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepProfileTypeParam { get; }
Public Shared ReadOnly Property MepProfileTypeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepProfileTypeParam {
    ForgeTypeId^ get ();
}
static member MepProfileTypeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepReheatCoilType Property

ParameterTypeIdMepReheatCoilType Property

"Reheat Coil"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepReheatCoilType { get; }
Public Shared ReadOnly Property MepReheatCoilType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepReheatCoilType {
    ForgeTypeId^ get ();
}
static member MepReheatCoilType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepReheatHotwaterLoop Property

ParameterTypeIdMepReheatHotwaterLoop Property

"Reheat Hot Water Loop"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepReheatHotwaterLoop { get; }
Public Shared ReadOnly Property MepReheatHotwaterLoop As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepReheatHotwaterLoop {
    ForgeTypeId^ get ();
}
static member MepReheatHotwaterLoop : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepSegmentElementTypename Property

ParameterTypeIdMepSegmentElementTypename Property

"Type Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepSegmentElementTypename { get; }
Public Shared ReadOnly Property MepSegmentElementTypename As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepSegmentElementTypename {
    ForgeTypeId^ get ();
}
static member MepSegmentElementTypename : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepSegmentFamilyname Property

ParameterTypeIdMepSegmentFamilyname Property

"Family Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepSegmentFamilyname { get; }
Public Shared ReadOnly Property MepSegmentFamilyname As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepSegmentFamilyname {
    ForgeTypeId^ get ();
}
static member MepSegmentFamilyname : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepSegmentLength Property

ParameterTypeIdMepSegmentLength Property

"Analytical Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepSegmentLength { get; }
Public Shared ReadOnly Property MepSegmentLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepSegmentLength {
    ForgeTypeId^ get ();
}
static member MepSegmentLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepSegmentSystemorservice Property

ParameterTypeIdMepSegmentSystemorservice Property

"System Type/Service Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepSegmentSystemorservice { get; }
Public Shared ReadOnly Property MepSegmentSystemorservice As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepSegmentSystemorservice {
    ForgeTypeId^ get ();
}
static member MepSegmentSystemorservice : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepSpotBottomElevation Property

ParameterTypeIdMepSpotBottomElevation Property

"Spot Bottom Elevation": used for both design and fabrication components

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepSpotBottomElevation { get; }
Public Shared ReadOnly Property MepSpotBottomElevation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepSpotBottomElevation {
    ForgeTypeId^ get ();
}
static member MepSpotBottomElevation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepSpotBottomElevationIncludeInsulation Property

ParameterTypeIdMepSpotBottomElevationIncludeInsulation Property

"Spot Bottom of Insulation Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepSpotBottomElevationIncludeInsulation { get; }
Public Shared ReadOnly Property MepSpotBottomElevationIncludeInsulation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepSpotBottomElevationIncludeInsulation {
    ForgeTypeId^ get ();
}
static member MepSpotBottomElevationIncludeInsulation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepSpotCenterlineElevation Property

ParameterTypeIdMepSpotCenterlineElevation Property

"Spot Centerline Elevation": used for both design and fabrication components

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepSpotCenterlineElevation { get; }
Public Shared ReadOnly Property MepSpotCenterlineElevation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepSpotCenterlineElevation {
    ForgeTypeId^ get ();
}
static member MepSpotCenterlineElevation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepSpotTopElevation Property

ParameterTypeIdMepSpotTopElevation Property

"Spot Top Elevation": used for both design and fabrication components

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepSpotTopElevation { get; }
Public Shared ReadOnly Property MepSpotTopElevation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepSpotTopElevation {
    ForgeTypeId^ get ();
}
static member MepSpotTopElevation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepSpotTopElevationIncludeInsulation Property

ParameterTypeIdMepSpotTopElevationIncludeInsulation Property

"Spot Top of Insulation Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepSpotTopElevationIncludeInsulation { get; }
Public Shared ReadOnly Property MepSpotTopElevationIncludeInsulation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepSpotTopElevationIncludeInsulation {
    ForgeTypeId^ get ();
}
static member MepSpotTopElevationIncludeInsulation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepSystemFillGraphicsOverridesParam Property

ParameterTypeIdMepSystemFillGraphicsOverridesParam Property

"Fill Pattern Graphics Overrides"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepSystemFillGraphicsOverridesParam { get; }
Public Shared ReadOnly Property MepSystemFillGraphicsOverridesParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepSystemFillGraphicsOverridesParam {
    ForgeTypeId^ get ();
}
static member MepSystemFillGraphicsOverridesParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepSystemLineGraphicsOverridesParam Property

ParameterTypeIdMepSystemLineGraphicsOverridesParam Property

"Graphic Overrides"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepSystemLineGraphicsOverridesParam { get; }
Public Shared ReadOnly Property MepSystemLineGraphicsOverridesParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepSystemLineGraphicsOverridesParam {
    ForgeTypeId^ get ();
}
static member MepSystemLineGraphicsOverridesParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepUpperBottomElevation Property

ParameterTypeIdMepUpperBottomElevation Property

"Upper End Bottom Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepUpperBottomElevation { get; }
Public Shared ReadOnly Property MepUpperBottomElevation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepUpperBottomElevation {
    ForgeTypeId^ get ();
}
static member MepUpperBottomElevation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepUpperBottomElevationIncludeInsulation Property

ParameterTypeIdMepUpperBottomElevationIncludeInsulation Property

"Upper End Bottom of Insulation Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepUpperBottomElevationIncludeInsulation { get; }
Public Shared ReadOnly Property MepUpperBottomElevationIncludeInsulation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepUpperBottomElevationIncludeInsulation {
    ForgeTypeId^ get ();
}
static member MepUpperBottomElevationIncludeInsulation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepUpperCenterlineElevation Property

ParameterTypeIdMepUpperCenterlineElevation Property

"Upper End Centerline Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepUpperCenterlineElevation { get; }
Public Shared ReadOnly Property MepUpperCenterlineElevation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepUpperCenterlineElevation {
    ForgeTypeId^ get ();
}
static member MepUpperCenterlineElevation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepUpperTopElevation Property

ParameterTypeIdMepUpperTopElevation Property

"Upper End Top Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepUpperTopElevation { get; }
Public Shared ReadOnly Property MepUpperTopElevation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepUpperTopElevation {
    ForgeTypeId^ get ();
}
static member MepUpperTopElevation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepUpperTopElevationIncludeInsulation Property

ParameterTypeIdMepUpperTopElevationIncludeInsulation Property

"Upper End Top of Insulation Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepUpperTopElevationIncludeInsulation { get; }
Public Shared ReadOnly Property MepUpperTopElevationIncludeInsulation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepUpperTopElevationIncludeInsulation {
    ForgeTypeId^ get ();
}
static member MepUpperTopElevationIncludeInsulation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepVrfLoop Property

ParameterTypeIdMepVrfLoop Property

"Variable Refrigerant Flow Loop"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepVrfLoop { get; }
Public Shared ReadOnly Property MepVrfLoop As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepVrfLoop {
    ForgeTypeId^ get ();
}
static member MepVrfLoop : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepWaterloopChillertype Property

ParameterTypeIdMepWaterloopChillertype Property

"Chiller Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepWaterloopChillertype { get; }
Public Shared ReadOnly Property MepWaterloopChillertype As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepWaterloopChillertype {
    ForgeTypeId^ get ();
}
static member MepWaterloopChillertype : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepWaterloopType Property

ParameterTypeIdMepWaterloopType Property

"Loop Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepWaterloopType { get; }
Public Shared ReadOnly Property MepWaterloopType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepWaterloopType {
    ForgeTypeId^ get ();
}
static member MepWaterloopType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepZoneAirLoop Property

ParameterTypeIdMepZoneAirLoop Property

"Air System"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepZoneAirLoop { get; }
Public Shared ReadOnly Property MepZoneAirLoop As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepZoneAirLoop {
    ForgeTypeId^ get ();
}
static member MepZoneAirLoop : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepZoneEquipment Property

ParameterTypeIdMepZoneEquipment Property

"Zone Equipment"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepZoneEquipment { get; }
Public Shared ReadOnly Property MepZoneEquipment As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepZoneEquipment {
    ForgeTypeId^ get ();
}
static member MepZoneEquipment : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepZoneEquipmentBehavior Property

ParameterTypeIdMepZoneEquipmentBehavior Property

"Behavior"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepZoneEquipmentBehavior { get; }
Public Shared ReadOnly Property MepZoneEquipmentBehavior As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepZoneEquipmentBehavior {
    ForgeTypeId^ get ();
}
static member MepZoneEquipmentBehavior : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepZoneEquipmentDrawVentilation Property

ParameterTypeIdMepZoneEquipmentDrawVentilation Property

"Draw Ventilation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepZoneEquipmentDrawVentilation { get; }
Public Shared ReadOnly Property MepZoneEquipmentDrawVentilation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepZoneEquipmentDrawVentilation {
    ForgeTypeId^ get ();
}
static member MepZoneEquipmentDrawVentilation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepZoneEquipmentType Property

ParameterTypeIdMepZoneEquipmentType Property

"Equipment Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepZoneEquipmentType { get; }
Public Shared ReadOnly Property MepZoneEquipmentType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepZoneEquipmentType {
    ForgeTypeId^ get ();
}
static member MepZoneEquipmentType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MepZoneHotwaterLoop Property

ParameterTypeIdMepZoneHotwaterLoop Property

"Heating Hot Water Loop"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MepZoneHotwaterLoop { get; }
Public Shared ReadOnly Property MepZoneHotwaterLoop As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MepZoneHotwaterLoop {
    ForgeTypeId^ get ();
}
static member MepZoneHotwaterLoop : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ModelCategoryIdParam Property

ParameterTypeIdModelCategoryIdParam Property

"Subcategory"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ModelCategoryIdParam { get; }
Public Shared ReadOnly Property ModelCategoryIdParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ModelCategoryIdParam {
    ForgeTypeId^ get ();
}
static member ModelCategoryIdParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ModelGraphicsStyle Property

ParameterTypeIdModelGraphicsStyle Property

"Visual Style"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ModelGraphicsStyle { get; }
Public Shared ReadOnly Property ModelGraphicsStyle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ModelGraphicsStyle {
    ForgeTypeId^ get ();
}
static member ModelGraphicsStyle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ModelGraphicsStyleAnonDraft Property

ParameterTypeIdModelGraphicsStyleAnonDraft Property

"Visual Style"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ModelGraphicsStyleAnonDraft { get; }
Public Shared ReadOnly Property ModelGraphicsStyleAnonDraft As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ModelGraphicsStyleAnonDraft {
    ForgeTypeId^ get ();
}
static member ModelGraphicsStyleAnonDraft : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ModelOrSymbolic Property

ParameterTypeIdModelOrSymbolic Property

"Model or Symbolic"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ModelOrSymbolic { get; }
Public Shared ReadOnly Property ModelOrSymbolic As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ModelOrSymbolic {
    ForgeTypeId^ get ();
}
static member ModelOrSymbolic : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ModelTextSize Property

ParameterTypeIdModelTextSize Property

"Text Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ModelTextSize { get; }
Public Shared ReadOnly Property ModelTextSize As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ModelTextSize {
    ForgeTypeId^ get ();
}
static member ModelTextSize : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MovesWithGridParam Property

ParameterTypeIdMovesWithGridParam Property

"Moves With Grids": Disable attachment from grids.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MovesWithGridParam { get; }
Public Shared ReadOnly Property MovesWithGridParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MovesWithGridParam {
    ForgeTypeId^ get ();
}
static member MovesWithGridParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MullionAngle Property

ParameterTypeIdMullionAngle Property

"Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MullionAngle { get; }
Public Shared ReadOnly Property MullionAngle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MullionAngle {
    ForgeTypeId^ get ();
}
static member MullionAngle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MullionCornerType Property

ParameterTypeIdMullionCornerType Property

"Corner Mullion"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MullionCornerType { get; }
Public Shared ReadOnly Property MullionCornerType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MullionCornerType {
    ForgeTypeId^ get ();
}
static member MullionCornerType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MullionDepth Property

ParameterTypeIdMullionDepth Property

"Depth"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MullionDepth { get; }
Public Shared ReadOnly Property MullionDepth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MullionDepth {
    ForgeTypeId^ get ();
}
static member MullionDepth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MullionDepth1 Property

ParameterTypeIdMullionDepth1 Property

"Depth 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MullionDepth1 { get; }
Public Shared ReadOnly Property MullionDepth1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MullionDepth1 {
    ForgeTypeId^ get ();
}
static member MullionDepth1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MullionDepth2 Property

ParameterTypeIdMullionDepth2 Property

"Depth 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MullionDepth2 { get; }
Public Shared ReadOnly Property MullionDepth2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MullionDepth2 {
    ForgeTypeId^ get ();
}
static member MullionDepth2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MullionFamType Property

ParameterTypeIdMullionFamType Property

"Mullion Family General Shape"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MullionFamType { get; }
Public Shared ReadOnly Property MullionFamType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MullionFamType {
    ForgeTypeId^ get ();
}
static member MullionFamType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MullionOffset Property

ParameterTypeIdMullionOffset Property

"Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MullionOffset { get; }
Public Shared ReadOnly Property MullionOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MullionOffset {
    ForgeTypeId^ get ();
}
static member MullionOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MullionPosition Property

ParameterTypeIdMullionPosition Property

"Position"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MullionPosition { get; }
Public Shared ReadOnly Property MullionPosition As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MullionPosition {
    ForgeTypeId^ get ();
}
static member MullionPosition : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MullionProfile Property

ParameterTypeIdMullionProfile Property

"Profile"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MullionProfile { get; }
Public Shared ReadOnly Property MullionProfile As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MullionProfile {
    ForgeTypeId^ get ();
}
static member MullionProfile : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MultipleAlignmentUiToggle Property

ParameterTypeIdMultipleAlignmentUiToggle Property

"Multiple Alignment": This is used by the UI to allow selection of multiple elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MultipleAlignmentUiToggle { get; }
Public Shared ReadOnly Property MultipleAlignmentUiToggle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MultipleAlignmentUiToggle {
    ForgeTypeId^ get ();
}
static member MultipleAlignmentUiToggle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MultiReferenceAnnotationDimensionStyle Property

ParameterTypeIdMultiReferenceAnnotationDimensionStyle Property

"Dimension Style"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MultiReferenceAnnotationDimensionStyle { get; }
Public Shared ReadOnly Property MultiReferenceAnnotationDimensionStyle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MultiReferenceAnnotationDimensionStyle {
    ForgeTypeId^ get ();
}
static member MultiReferenceAnnotationDimensionStyle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MultiReferenceAnnotationGroupTagHeads Property

ParameterTypeIdMultiReferenceAnnotationGroupTagHeads Property

"Group Matching Tag Heads"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MultiReferenceAnnotationGroupTagHeads { get; }
Public Shared ReadOnly Property MultiReferenceAnnotationGroupTagHeads As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MultiReferenceAnnotationGroupTagHeads {
    ForgeTypeId^ get ();
}
static member MultiReferenceAnnotationGroupTagHeads : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MultiReferenceAnnotationReferenceCategory Property

ParameterTypeIdMultiReferenceAnnotationReferenceCategory Property

"Reference Category"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MultiReferenceAnnotationReferenceCategory { get; }
Public Shared ReadOnly Property MultiReferenceAnnotationReferenceCategory As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MultiReferenceAnnotationReferenceCategory {
    ForgeTypeId^ get ();
}
static member MultiReferenceAnnotationReferenceCategory : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MultiReferenceAnnotationShowDimensionText Property

ParameterTypeIdMultiReferenceAnnotationShowDimensionText Property

"Show Dimension Text"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MultiReferenceAnnotationShowDimensionText { get; }
Public Shared ReadOnly Property MultiReferenceAnnotationShowDimensionText As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MultiReferenceAnnotationShowDimensionText {
    ForgeTypeId^ get ();
}
static member MultiReferenceAnnotationShowDimensionText : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MultiReferenceAnnotationTagType Property

ParameterTypeIdMultiReferenceAnnotationTagType Property

"Tag Family"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MultiReferenceAnnotationTagType { get; }
Public Shared ReadOnly Property MultiReferenceAnnotationTagType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MultiReferenceAnnotationTagType {
    ForgeTypeId^ get ();
}
static member MultiReferenceAnnotationTagType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MultistoryStairsActualTreadDepth Property

ParameterTypeIdMultistoryStairsActualTreadDepth Property

"Actual Tread Depth"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MultistoryStairsActualTreadDepth { get; }
Public Shared ReadOnly Property MultistoryStairsActualTreadDepth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MultistoryStairsActualTreadDepth {
    ForgeTypeId^ get ();
}
static member MultistoryStairsActualTreadDepth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.MultistoryStairsRefLevel Property

ParameterTypeIdMultistoryStairsRefLevel Property

"Reference Level": The reference level of stairs

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MultistoryStairsRefLevel { get; }
Public Shared ReadOnly Property MultistoryStairsRefLevel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MultistoryStairsRefLevel {
    ForgeTypeId^ get ();
}
static member MultistoryStairsRefLevel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.NodeConnectionStatus Property

ParameterTypeIdNodeConnectionStatus Property

"Connection Status"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId NodeConnectionStatus { get; }
Public Shared ReadOnly Property NodeConnectionStatus As ForgeTypeId
    Get
public:
static property ForgeTypeId^ NodeConnectionStatus {
    ForgeTypeId^ get ();
}
static member NodeConnectionStatus : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.NumberPartitionParam Property

ParameterTypeIdNumberPartitionParam Property

"Partition"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId NumberPartitionParam { get; }
Public Shared ReadOnly Property NumberPartitionParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ NumberPartitionParam {
    ForgeTypeId^ get ();
}
static member NumberPartitionParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.NumberSystemDisplayRule Property

ParameterTypeIdNumberSystemDisplayRule Property

"Display Rule"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId NumberSystemDisplayRule { get; }
Public Shared ReadOnly Property NumberSystemDisplayRule As ForgeTypeId
    Get
public:
static property ForgeTypeId^ NumberSystemDisplayRule {
    ForgeTypeId^ get ();
}
static member NumberSystemDisplayRule : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.NumberSystemJustify Property

ParameterTypeIdNumberSystemJustify Property

"Justify"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId NumberSystemJustify { get; }
Public Shared ReadOnly Property NumberSystemJustify As ForgeTypeId
    Get
public:
static property ForgeTypeId^ NumberSystemJustify {
    ForgeTypeId^ get ();
}
static member NumberSystemJustify : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.NumberSystemJustifyOffset Property

ParameterTypeIdNumberSystemJustifyOffset Property

"Justify Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId NumberSystemJustifyOffset { get; }
Public Shared ReadOnly Property NumberSystemJustifyOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ NumberSystemJustifyOffset {
    ForgeTypeId^ get ();
}
static member NumberSystemJustifyOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.NumberSystemOrientation Property

ParameterTypeIdNumberSystemOrientation Property

"Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId NumberSystemOrientation { get; }
Public Shared ReadOnly Property NumberSystemOrientation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ NumberSystemOrientation {
    ForgeTypeId^ get ();
}
static member NumberSystemOrientation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.NumberSystemReference Property

ParameterTypeIdNumberSystemReference Property

"Reference"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId NumberSystemReference { get; }
Public Shared ReadOnly Property NumberSystemReference As ForgeTypeId
    Get
public:
static property ForgeTypeId^ NumberSystemReference {
    ForgeTypeId^ get ();
}
static member NumberSystemReference : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.NumberSystemReferenceOffset Property

ParameterTypeIdNumberSystemReferenceOffset Property

"Offset from Reference"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId NumberSystemReferenceOffset { get; }
Public Shared ReadOnly Property NumberSystemReferenceOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ NumberSystemReferenceOffset {
    ForgeTypeId^ get ();
}
static member NumberSystemReferenceOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.NumberSystemTagType Property

ParameterTypeIdNumberSystemTagType Property

"Tag Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId NumberSystemTagType { get; }
Public Shared ReadOnly Property NumberSystemTagType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ NumberSystemTagType {
    ForgeTypeId^ get ();
}
static member NumberSystemTagType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.NumberSystemTextSize Property

ParameterTypeIdNumberSystemTextSize Property

"Number Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId NumberSystemTextSize { get; }
Public Shared ReadOnly Property NumberSystemTextSize As ForgeTypeId
    Get
public:
static property ForgeTypeId^ NumberSystemTextSize {
    ForgeTypeId^ get ();
}
static member NumberSystemTextSize : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ObjectStyleMaterialIdParam Property

ParameterTypeIdObjectStyleMaterialIdParam Property

"Object Style Material"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ObjectStyleMaterialIdParam { get; }
Public Shared ReadOnly Property ObjectStyleMaterialIdParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ObjectStyleMaterialIdParam {
    ForgeTypeId^ get ();
}
static member ObjectStyleMaterialIdParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.OffsetfacesShowShapeHandles Property

ParameterTypeIdOffsetfacesShowShapeHandles Property

"Show Shape Handles"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId OffsetfacesShowShapeHandles { get; }
Public Shared ReadOnly Property OffsetfacesShowShapeHandles As ForgeTypeId
    Get
public:
static property ForgeTypeId^ OffsetfacesShowShapeHandles {
    ForgeTypeId^ get ();
}
static member OffsetfacesShowShapeHandles : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.OffsetFromReferenceBase Property

ParameterTypeIdOffsetFromReferenceBase Property

"Offset from Reference Base"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId OffsetFromReferenceBase { get; }
Public Shared ReadOnly Property OffsetFromReferenceBase As ForgeTypeId
    Get
public:
static property ForgeTypeId^ OffsetFromReferenceBase {
    ForgeTypeId^ get ();
}
static member OffsetFromReferenceBase : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.OmniclassCode Property

ParameterTypeIdOmniclassCode Property

"OmniClass Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId OmniclassCode { get; }
Public Shared ReadOnly Property OmniclassCode As ForgeTypeId
    Get
public:
static property ForgeTypeId^ OmniclassCode {
    ForgeTypeId^ get ();
}
static member OmniclassCode : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.OmniclassDescription Property

ParameterTypeIdOmniclassDescription Property

"OmniClass Title"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId OmniclassDescription { get; }
Public Shared ReadOnly Property OmniclassDescription As ForgeTypeId
    Get
public:
static property ForgeTypeId^ OmniclassDescription {
    ForgeTypeId^ get ();
}
static member OmniclassDescription : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.OptionName Property

ParameterTypeIdOptionName Property

"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId OptionName { get; }
Public Shared ReadOnly Property OptionName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ OptionName {
    ForgeTypeId^ get ();
}
static member OptionName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.OptionSetId Property

ParameterTypeIdOptionSetId Property

"Design Option Set Id"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId OptionSetId { get; }
Public Shared ReadOnly Property OptionSetId As ForgeTypeId
    Get
public:
static property ForgeTypeId^ OptionSetId {
    ForgeTypeId^ get ();
}
static member OptionSetId : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.OptionSetName Property

ParameterTypeIdOptionSetName Property

"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId OptionSetName { get; }
Public Shared ReadOnly Property OptionSetName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ OptionSetName {
    ForgeTypeId^ get ();
}
static member OptionSetName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.OrdinateDimSetting Property

ParameterTypeIdOrdinateDimSetting Property

"Ordinate Dimension Settings"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId OrdinateDimSetting { get; }
Public Shared ReadOnly Property OrdinateDimSetting As ForgeTypeId
    Get
public:
static property ForgeTypeId^ OrdinateDimSetting {
    ForgeTypeId^ get ();
}
static member OrdinateDimSetting : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.OrientByView Property

ParameterTypeIdOrientByView Property

"Rotate With Text"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId OrientByView { get; }
Public Shared ReadOnly Property OrientByView As ForgeTypeId
    Get
public:
static property ForgeTypeId^ OrientByView {
    ForgeTypeId^ get ();
}
static member OrientByView : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.OriginatingElementName Property

ParameterTypeIdOriginatingElementName Property

"Originating Element"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId OriginatingElementName { get; }
Public Shared ReadOnly Property OriginatingElementName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ OriginatingElementName {
    ForgeTypeId^ get ();
}
static member OriginatingElementName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.OvalFramingHeight Property

ParameterTypeIdOvalFramingHeight Property

"Oval Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId OvalFramingHeight { get; }
Public Shared ReadOnly Property OvalFramingHeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ OvalFramingHeight {
    ForgeTypeId^ get ();
}
static member OvalFramingHeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.OvalFramingWidth Property

ParameterTypeIdOvalFramingWidth Property

"Oval Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId OvalFramingWidth { get; }
Public Shared ReadOnly Property OvalFramingWidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ OvalFramingWidth {
    ForgeTypeId^ get ();
}
static member OvalFramingWidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PaddingLength Property

ParameterTypeIdPaddingLength Property

"Padding"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PaddingLength { get; }
Public Shared ReadOnly Property PaddingLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PaddingLength {
    ForgeTypeId^ get ();
}
static member PaddingLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PanelScheduleName Property

ParameterTypeIdPanelScheduleName Property

"Panel Schedule Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PanelScheduleName { get; }
Public Shared ReadOnly Property PanelScheduleName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PanelScheduleName {
    ForgeTypeId^ get ();
}
static member PanelScheduleName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PartMakerDivisionProfileOffset Property

ParameterTypeIdPartMakerDivisionProfileOffset Property

"Profile Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PartMakerDivisionProfileOffset { get; }
Public Shared ReadOnly Property PartMakerDivisionProfileOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PartMakerDivisionProfileOffset {
    ForgeTypeId^ get ();
}
static member PartMakerDivisionProfileOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PartmakerParamDivisionGap Property

ParameterTypeIdPartmakerParamDivisionGap Property

"Gap"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PartmakerParamDivisionGap { get; }
Public Shared ReadOnly Property PartmakerParamDivisionGap As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PartmakerParamDivisionGap {
    ForgeTypeId^ get ();
}
static member PartmakerParamDivisionGap : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PartMakerSplitterProfile Property

ParameterTypeIdPartMakerSplitterProfile Property

"Division Profile"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PartMakerSplitterProfile { get; }
Public Shared ReadOnly Property PartMakerSplitterProfile As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PartMakerSplitterProfile {
    ForgeTypeId^ get ();
}
static member PartMakerSplitterProfile : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PartMakerSplitterProfileEdgeMatch Property

ParameterTypeIdPartMakerSplitterProfileEdgeMatch Property

"Edge Match"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PartMakerSplitterProfileEdgeMatch { get; }
Public Shared ReadOnly Property PartMakerSplitterProfileEdgeMatch As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PartMakerSplitterProfileEdgeMatch {
    ForgeTypeId^ get ();
}
static member PartMakerSplitterProfileEdgeMatch : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PartMakerSplitterProfileFlipAcross Property

ParameterTypeIdPartMakerSplitterProfileFlipAcross Property

"Profile Across Flip"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PartMakerSplitterProfileFlipAcross { get; }
Public Shared ReadOnly Property PartMakerSplitterProfileFlipAcross As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PartMakerSplitterProfileFlipAcross {
    ForgeTypeId^ get ();
}
static member PartMakerSplitterProfileFlipAcross : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PartMakerSplitterProfileFlipAlong Property

ParameterTypeIdPartMakerSplitterProfileFlipAlong Property

"Profile Along Flip"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PartMakerSplitterProfileFlipAlong { get; }
Public Shared ReadOnly Property PartMakerSplitterProfileFlipAlong As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PartMakerSplitterProfileFlipAlong {
    ForgeTypeId^ get ();
}
static member PartMakerSplitterProfileFlipAlong : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PathOfTravelFromRoom Property

ParameterTypeIdPathOfTravelFromRoom Property

"From Room"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PathOfTravelFromRoom { get; }
Public Shared ReadOnly Property PathOfTravelFromRoom As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PathOfTravelFromRoom {
    ForgeTypeId^ get ();
}
static member PathOfTravelFromRoom : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PathOfTravelLevelName Property

ParameterTypeIdPathOfTravelLevelName Property

"Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PathOfTravelLevelName { get; }
Public Shared ReadOnly Property PathOfTravelLevelName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PathOfTravelLevelName {
    ForgeTypeId^ get ();
}
static member PathOfTravelLevelName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PathOfTravelSpeed Property

ParameterTypeIdPathOfTravelSpeed Property

"Speed"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PathOfTravelSpeed { get; }
Public Shared ReadOnly Property PathOfTravelSpeed As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PathOfTravelSpeed {
    ForgeTypeId^ get ();
}
static member PathOfTravelSpeed : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PathOfTravelTime Property

ParameterTypeIdPathOfTravelTime Property

"Time"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PathOfTravelTime { get; }
Public Shared ReadOnly Property PathOfTravelTime As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PathOfTravelTime {
    ForgeTypeId^ get ();
}
static member PathOfTravelTime : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PathOfTravelToRoom Property

ParameterTypeIdPathOfTravelToRoom Property

"To Room"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PathOfTravelToRoom { get; }
Public Shared ReadOnly Property PathOfTravelToRoom As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PathOfTravelToRoom {
    ForgeTypeId^ get ();
}
static member PathOfTravelToRoom : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PathOfTravelViewName Property

ParameterTypeIdPathOfTravelViewName Property

"View Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PathOfTravelViewName { get; }
Public Shared ReadOnly Property PathOfTravelViewName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PathOfTravelViewName {
    ForgeTypeId^ get ();
}
static member PathOfTravelViewName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PathReinAddlOffset Property

ParameterTypeIdPathReinAddlOffset Property

"Additional Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PathReinAddlOffset { get; }
Public Shared ReadOnly Property PathReinAddlOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PathReinAddlOffset {
    ForgeTypeId^ get ();
}
static member PathReinAddlOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PathReinAlternating Property

ParameterTypeIdPathReinAlternating Property

"Alternating Bars"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PathReinAlternating { get; }
Public Shared ReadOnly Property PathReinAlternating As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PathReinAlternating {
    ForgeTypeId^ get ();
}
static member PathReinAlternating : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PathReinAltOffset Property

ParameterTypeIdPathReinAltOffset Property

"Alternating Bar - Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PathReinAltOffset { get; }
Public Shared ReadOnly Property PathReinAltOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PathReinAltOffset {
    ForgeTypeId^ get ();
}
static member PathReinAltOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PathReinEndHookOrient1Slab Property

ParameterTypeIdPathReinEndHookOrient1Slab Property

"Primary Bar - End Hook Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PathReinEndHookOrient1Slab { get; }
Public Shared ReadOnly Property PathReinEndHookOrient1Slab As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PathReinEndHookOrient1Slab {
    ForgeTypeId^ get ();
}
static member PathReinEndHookOrient1Slab : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PathReinEndHookOrient1Wall Property

ParameterTypeIdPathReinEndHookOrient1Wall Property

"Primary Bar - End Hook Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PathReinEndHookOrient1Wall { get; }
Public Shared ReadOnly Property PathReinEndHookOrient1Wall As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PathReinEndHookOrient1Wall {
    ForgeTypeId^ get ();
}
static member PathReinEndHookOrient1Wall : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PathReinEndHookOrient2Slab Property

ParameterTypeIdPathReinEndHookOrient2Slab Property

"Alternating Bar - End Hook Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PathReinEndHookOrient2Slab { get; }
Public Shared ReadOnly Property PathReinEndHookOrient2Slab As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PathReinEndHookOrient2Slab {
    ForgeTypeId^ get ();
}
static member PathReinEndHookOrient2Slab : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PathReinEndHookOrient2Wall Property

ParameterTypeIdPathReinEndHookOrient2Wall Property

"Alternating Bar - End Hook Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PathReinEndHookOrient2Wall { get; }
Public Shared ReadOnly Property PathReinEndHookOrient2Wall As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PathReinEndHookOrient2Wall {
    ForgeTypeId^ get ();
}
static member PathReinEndHookOrient2Wall : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PathReinEndHookTypen1 Property

ParameterTypeIdPathReinEndHookTypen1 Property

"Primary Bar - End Hook Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PathReinEndHookTypen1 { get; }
Public Shared ReadOnly Property PathReinEndHookTypen1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PathReinEndHookTypen1 {
    ForgeTypeId^ get ();
}
static member PathReinEndHookTypen1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PathReinEndHookTypen2 Property

ParameterTypeIdPathReinEndHookTypen2 Property

"Alternating Bar - End Hook Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PathReinEndHookTypen2 { get; }
Public Shared ReadOnly Property PathReinEndHookTypen2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PathReinEndHookTypen2 {
    ForgeTypeId^ get ();
}
static member PathReinEndHookTypen2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PathReinEndSpanhookAlt Property

ParameterTypeIdPathReinEndSpanhookAlt Property

"End Hook Angle Alternating"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PathReinEndSpanhookAlt { get; }
Public Shared ReadOnly Property PathReinEndSpanhookAlt As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PathReinEndSpanhookAlt {
    ForgeTypeId^ get ();
}
static member PathReinEndSpanhookAlt : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PathReinEndSpanhookPrim Property

ParameterTypeIdPathReinEndSpanhookPrim Property

"End Hook Angle Primary"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PathReinEndSpanhookPrim { get; }
Public Shared ReadOnly Property PathReinEndSpanhookPrim As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PathReinEndSpanhookPrim {
    ForgeTypeId^ get ();
}
static member PathReinEndSpanhookPrim : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PathReinFaceSlab Property

ParameterTypeIdPathReinFaceSlab Property

"Face"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PathReinFaceSlab { get; }
Public Shared ReadOnly Property PathReinFaceSlab As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PathReinFaceSlab {
    ForgeTypeId^ get ();
}
static member PathReinFaceSlab : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PathReinFaceWall Property

ParameterTypeIdPathReinFaceWall Property

"Face"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PathReinFaceWall { get; }
Public Shared ReadOnly Property PathReinFaceWall As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PathReinFaceWall {
    ForgeTypeId^ get ();
}
static member PathReinFaceWall : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PathReinHookOrient1Slab Property

ParameterTypeIdPathReinHookOrient1Slab Property

"Primary Bar - Hook Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PathReinHookOrient1Slab { get; }
Public Shared ReadOnly Property PathReinHookOrient1Slab As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PathReinHookOrient1Slab {
    ForgeTypeId^ get ();
}
static member PathReinHookOrient1Slab : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PathReinHookOrient1Wall Property

ParameterTypeIdPathReinHookOrient1Wall Property

"Primary Bar - Hook Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PathReinHookOrient1Wall { get; }
Public Shared ReadOnly Property PathReinHookOrient1Wall As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PathReinHookOrient1Wall {
    ForgeTypeId^ get ();
}
static member PathReinHookOrient1Wall : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PathReinHookOrient2Slab Property

ParameterTypeIdPathReinHookOrient2Slab Property

"Alternating Bar - Hook Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PathReinHookOrient2Slab { get; }
Public Shared ReadOnly Property PathReinHookOrient2Slab As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PathReinHookOrient2Slab {
    ForgeTypeId^ get ();
}
static member PathReinHookOrient2Slab : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PathReinHookOrient2Wall Property

ParameterTypeIdPathReinHookOrient2Wall Property

"Alternating Bar - Hook Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PathReinHookOrient2Wall { get; }
Public Shared ReadOnly Property PathReinHookOrient2Wall As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PathReinHookOrient2Wall {
    ForgeTypeId^ get ();
}
static member PathReinHookOrient2Wall : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PathReinHookTypen1 Property

ParameterTypeIdPathReinHookTypen1 Property

"Primary Bar - Start Hook Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PathReinHookTypen1 { get; }
Public Shared ReadOnly Property PathReinHookTypen1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PathReinHookTypen1 {
    ForgeTypeId^ get ();
}
static member PathReinHookTypen1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PathReinHookTypen2 Property

ParameterTypeIdPathReinHookTypen2 Property

"Alternating Bar - Start Hook Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PathReinHookTypen2 { get; }
Public Shared ReadOnly Property PathReinHookTypen2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PathReinHookTypen2 {
    ForgeTypeId^ get ();
}
static member PathReinHookTypen2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PathReinLengthn1 Property

ParameterTypeIdPathReinLengthn1 Property

"Primary Bar - Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PathReinLengthn1 { get; }
Public Shared ReadOnly Property PathReinLengthn1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PathReinLengthn1 {
    ForgeTypeId^ get ();
}
static member PathReinLengthn1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PathReinLengthn2 Property

ParameterTypeIdPathReinLengthn2 Property

"Alternating Bar - Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PathReinLengthn2 { get; }
Public Shared ReadOnly Property PathReinLengthn2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PathReinLengthn2 {
    ForgeTypeId^ get ();
}
static member PathReinLengthn2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PathReinNumberOfBars Property

ParameterTypeIdPathReinNumberOfBars Property

"Number Of Bars"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PathReinNumberOfBars { get; }
Public Shared ReadOnly Property PathReinNumberOfBars As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PathReinNumberOfBars {
    ForgeTypeId^ get ();
}
static member PathReinNumberOfBars : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PathReinShapen1 Property

ParameterTypeIdPathReinShapen1 Property

"Primary Bar - Shape"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PathReinShapen1 { get; }
Public Shared ReadOnly Property PathReinShapen1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PathReinShapen1 {
    ForgeTypeId^ get ();
}
static member PathReinShapen1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PathReinShapen2 Property

ParameterTypeIdPathReinShapen2 Property

"Alternating Bar - Shape"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PathReinShapen2 { get; }
Public Shared ReadOnly Property PathReinShapen2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PathReinShapen2 {
    ForgeTypeId^ get ();
}
static member PathReinShapen2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PathReinSpacing Property

ParameterTypeIdPathReinSpacing Property

"Bar Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PathReinSpacing { get; }
Public Shared ReadOnly Property PathReinSpacing As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PathReinSpacing {
    ForgeTypeId^ get ();
}
static member PathReinSpacing : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PathReinSpanhookAlt Property

ParameterTypeIdPathReinSpanhookAlt Property

"Start Hook Angle Alternating"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PathReinSpanhookAlt { get; }
Public Shared ReadOnly Property PathReinSpanhookAlt As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PathReinSpanhookAlt {
    ForgeTypeId^ get ();
}
static member PathReinSpanhookAlt : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PathReinSpanhookPrim Property

ParameterTypeIdPathReinSpanhookPrim Property

"Start Hook Angle Primary"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PathReinSpanhookPrim { get; }
Public Shared ReadOnly Property PathReinSpanhookPrim As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PathReinSpanhookPrim {
    ForgeTypeId^ get ();
}
static member PathReinSpanhookPrim : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PathReinSpanlengthAltOffset Property

ParameterTypeIdPathReinSpanlengthAltOffset Property

"Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PathReinSpanlengthAltOffset { get; }
Public Shared ReadOnly Property PathReinSpanlengthAltOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PathReinSpanlengthAltOffset {
    ForgeTypeId^ get ();
}
static member PathReinSpanlengthAltOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PathReinSpanlengthBarlengthAlt Property

ParameterTypeIdPathReinSpanlengthBarlengthAlt Property

"Length (Alternating Bar)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PathReinSpanlengthBarlengthAlt { get; }
Public Shared ReadOnly Property PathReinSpanlengthBarlengthAlt As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PathReinSpanlengthBarlengthAlt {
    ForgeTypeId^ get ();
}
static member PathReinSpanlengthBarlengthAlt : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PathReinSpanlengthBarlengthPrim Property

ParameterTypeIdPathReinSpanlengthBarlengthPrim Property

"Length (Primary Bar)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PathReinSpanlengthBarlengthPrim { get; }
Public Shared ReadOnly Property PathReinSpanlengthBarlengthPrim As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PathReinSpanlengthBarlengthPrim {
    ForgeTypeId^ get ();
}
static member PathReinSpanlengthBarlengthPrim : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PathReinSpanlengthBottomAlt Property

ParameterTypeIdPathReinSpanlengthBottomAlt Property

"Bottom (Alternating Bar)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PathReinSpanlengthBottomAlt { get; }
Public Shared ReadOnly Property PathReinSpanlengthBottomAlt As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PathReinSpanlengthBottomAlt {
    ForgeTypeId^ get ();
}
static member PathReinSpanlengthBottomAlt : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PathReinSpanlengthBottomPrim Property

ParameterTypeIdPathReinSpanlengthBottomPrim Property

"Bottom (Primary Bar)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PathReinSpanlengthBottomPrim { get; }
Public Shared ReadOnly Property PathReinSpanlengthBottomPrim As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PathReinSpanlengthBottomPrim {
    ForgeTypeId^ get ();
}
static member PathReinSpanlengthBottomPrim : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PathReinSpanlengthTopAlt Property

ParameterTypeIdPathReinSpanlengthTopAlt Property

"Top (Alternating Bar)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PathReinSpanlengthTopAlt { get; }
Public Shared ReadOnly Property PathReinSpanlengthTopAlt As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PathReinSpanlengthTopAlt {
    ForgeTypeId^ get ();
}
static member PathReinSpanlengthTopAlt : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PathReinSummary Property

ParameterTypeIdPathReinSummary Property

"Summary"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PathReinSummary { get; }
Public Shared ReadOnly Property PathReinSummary As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PathReinSummary {
    ForgeTypeId^ get ();
}
static member PathReinSummary : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PathReinTypen1 Property

ParameterTypeIdPathReinTypen1 Property

"Primary Bar - Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PathReinTypen1 { get; }
Public Shared ReadOnly Property PathReinTypen1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PathReinTypen1 {
    ForgeTypeId^ get ();
}
static member PathReinTypen1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PathReinTypen2 Property

ParameterTypeIdPathReinTypen2 Property

"Alternating Bar - Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PathReinTypen2 { get; }
Public Shared ReadOnly Property PathReinTypen2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PathReinTypen2 {
    ForgeTypeId^ get ();
}
static member PathReinTypen2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PatternIndent1ForDivisionRule Property

ParameterTypeIdPatternIndent1ForDivisionRule Property

"Indent 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PatternIndent1ForDivisionRule { get; }
Public Shared ReadOnly Property PatternIndent1ForDivisionRule As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PatternIndent1ForDivisionRule {
    ForgeTypeId^ get ();
}
static member PatternIndent1ForDivisionRule : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PatternIndent2ForDivisionRule Property

ParameterTypeIdPatternIndent2ForDivisionRule Property

"Indent 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PatternIndent2ForDivisionRule { get; }
Public Shared ReadOnly Property PatternIndent2ForDivisionRule As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PatternIndent2ForDivisionRule {
    ForgeTypeId^ get ();
}
static member PatternIndent2ForDivisionRule : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PatternMirrorForDivisionRule Property

ParameterTypeIdPatternMirrorForDivisionRule Property

"Mirror"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PatternMirrorForDivisionRule { get; }
Public Shared ReadOnly Property PatternMirrorForDivisionRule As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PatternMirrorForDivisionRule {
    ForgeTypeId^ get ();
}
static member PatternMirrorForDivisionRule : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PeakAirflowParam Property

ParameterTypeIdPeakAirflowParam Property

"Peak Airflow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PeakAirflowParam { get; }
Public Shared ReadOnly Property PeakAirflowParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PeakAirflowParam {
    ForgeTypeId^ get ();
}
static member PeakAirflowParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PeakCoolingLoadParam Property

ParameterTypeIdPeakCoolingLoadParam Property

"Peak Cooling Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PeakCoolingLoadParam { get; }
Public Shared ReadOnly Property PeakCoolingLoadParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PeakCoolingLoadParam {
    ForgeTypeId^ get ();
}
static member PeakCoolingLoadParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PeakHeatingLoadParam Property

ParameterTypeIdPeakHeatingLoadParam Property

"Peak Heating Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PeakHeatingLoadParam { get; }
Public Shared ReadOnly Property PeakHeatingLoadParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PeakHeatingLoadParam {
    ForgeTypeId^ get ();
}
static member PeakHeatingLoadParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PeakLatentCoolingLoad Property

ParameterTypeIdPeakLatentCoolingLoad Property

"Peak Latent Cooling Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PeakLatentCoolingLoad { get; }
Public Shared ReadOnly Property PeakLatentCoolingLoad As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PeakLatentCoolingLoad {
    ForgeTypeId^ get ();
}
static member PeakLatentCoolingLoad : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhaseCreated Property

ParameterTypeIdPhaseCreated Property

"Phase Created"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhaseCreated { get; }
Public Shared ReadOnly Property PhaseCreated As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhaseCreated {
    ForgeTypeId^ get ();
}
static member PhaseCreated : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhaseDemolished Property

ParameterTypeIdPhaseDemolished Property

"Phase Demolished"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhaseDemolished { get; }
Public Shared ReadOnly Property PhaseDemolished As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhaseDemolished {
    ForgeTypeId^ get ();
}
static member PhaseDemolished : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhaseName Property

ParameterTypeIdPhaseName Property

"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhaseName { get; }
Public Shared ReadOnly Property PhaseName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhaseName {
    ForgeTypeId^ get ();
}
static member PhaseName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhaseSequenceNumber Property

ParameterTypeIdPhaseSequenceNumber Property

"Sequence Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhaseSequenceNumber { get; }
Public Shared ReadOnly Property PhaseSequenceNumber As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhaseSequenceNumber {
    ForgeTypeId^ get ();
}
static member PhaseSequenceNumber : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamAverageModulus Property

ParameterTypeIdPhyMaterialParamAverageModulus Property

"Average Modulus"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamAverageModulus { get; }
Public Shared ReadOnly Property PhyMaterialParamAverageModulus As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamAverageModulus {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamAverageModulus : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamBehavior Property

ParameterTypeIdPhyMaterialParamBehavior Property

"Behavior"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamBehavior { get; }
Public Shared ReadOnly Property PhyMaterialParamBehavior As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamBehavior {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamBehavior : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamBending Property

ParameterTypeIdPhyMaterialParamBending Property

"Bending"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamBending { get; }
Public Shared ReadOnly Property PhyMaterialParamBending As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamBending {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamBending : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamBendingReinforcement Property

ParameterTypeIdPhyMaterialParamBendingReinforcement Property

"Bending reinforcement"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamBendingReinforcement { get; }
Public Shared ReadOnly Property PhyMaterialParamBendingReinforcement As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamBendingReinforcement {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamBendingReinforcement : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamClass Property

ParameterTypeIdPhyMaterialParamClass Property

"Class"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamClass { get; }
Public Shared ReadOnly Property PhyMaterialParamClass As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamClass {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamClass : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamCompressionParallel Property

ParameterTypeIdPhyMaterialParamCompressionParallel Property

"Compression parallel to grain"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamCompressionParallel { get; }
Public Shared ReadOnly Property PhyMaterialParamCompressionParallel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamCompressionParallel {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamCompressionParallel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamCompressionPerpendicular Property

ParameterTypeIdPhyMaterialParamCompressionPerpendicular Property

"Compression perpendicular to grain"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamCompressionPerpendicular { get; }
Public Shared ReadOnly Property PhyMaterialParamCompressionPerpendicular As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamCompressionPerpendicular {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamCompressionPerpendicular : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamConcreteCompression Property

ParameterTypeIdPhyMaterialParamConcreteCompression Property

"Concrete compression"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamConcreteCompression { get; }
Public Shared ReadOnly Property PhyMaterialParamConcreteCompression As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamConcreteCompression {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamConcreteCompression : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamExpCoeff Property

ParameterTypeIdPhyMaterialParamExpCoeff Property

"Thermal expansion coefficient"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamExpCoeff { get; }
Public Shared ReadOnly Property PhyMaterialParamExpCoeff As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamExpCoeff {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamExpCoeff : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamExpCoeff1 Property

ParameterTypeIdPhyMaterialParamExpCoeff1 Property

"Thermal expansion coefficient X"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamExpCoeff1 { get; }
Public Shared ReadOnly Property PhyMaterialParamExpCoeff1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamExpCoeff1 {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamExpCoeff1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamExpCoeff2 Property

ParameterTypeIdPhyMaterialParamExpCoeff2 Property

"Thermal expansion coefficient Y"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamExpCoeff2 { get; }
Public Shared ReadOnly Property PhyMaterialParamExpCoeff2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamExpCoeff2 {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamExpCoeff2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamExpCoeff3 Property

ParameterTypeIdPhyMaterialParamExpCoeff3 Property

"Thermal expansion coefficient Z"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamExpCoeff3 { get; }
Public Shared ReadOnly Property PhyMaterialParamExpCoeff3 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamExpCoeff3 {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamExpCoeff3 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamExpCoeffn1 Property

ParameterTypeIdPhyMaterialParamExpCoeffn1 Property

"Thermal Expansion Coefficient 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamExpCoeffn1 { get; }
Public Shared ReadOnly Property PhyMaterialParamExpCoeffn1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamExpCoeffn1 {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamExpCoeffn1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamExpCoeffn2 Property

ParameterTypeIdPhyMaterialParamExpCoeffn2 Property

"Thermal Expansion Coefficient 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamExpCoeffn2 { get; }
Public Shared ReadOnly Property PhyMaterialParamExpCoeffn2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamExpCoeffn2 {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamExpCoeffn2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamFivepercentModulusOfElacticity Property

ParameterTypeIdPhyMaterialParamFivepercentModulusOfElacticity Property

"5% Modulus of Elasticity"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamFivepercentModulusOfElacticity { get; }
Public Shared ReadOnly Property PhyMaterialParamFivepercentModulusOfElacticity As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamFivepercentModulusOfElacticity {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamFivepercentModulusOfElacticity : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamGrade Property

ParameterTypeIdPhyMaterialParamGrade Property

"Grade"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamGrade { get; }
Public Shared ReadOnly Property PhyMaterialParamGrade As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamGrade {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamGrade : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamLightWeight Property

ParameterTypeIdPhyMaterialParamLightWeight Property

"Lightweight"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamLightWeight { get; }
Public Shared ReadOnly Property PhyMaterialParamLightWeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamLightWeight {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamLightWeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamMinimumTensileStrength Property

ParameterTypeIdPhyMaterialParamMinimumTensileStrength Property

"Minimum tensile strength"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamMinimumTensileStrength { get; }
Public Shared ReadOnly Property PhyMaterialParamMinimumTensileStrength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamMinimumTensileStrength {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamMinimumTensileStrength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamMinimumYieldStress Property

ParameterTypeIdPhyMaterialParamMinimumYieldStress Property

"Minimum yield stress"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamMinimumYieldStress { get; }
Public Shared ReadOnly Property PhyMaterialParamMinimumYieldStress As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamMinimumYieldStress {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamMinimumYieldStress : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamPoissonMod Property

ParameterTypeIdPhyMaterialParamPoissonMod Property

"Poisson ratio"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamPoissonMod { get; }
Public Shared ReadOnly Property PhyMaterialParamPoissonMod As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamPoissonMod {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamPoissonMod : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamPoissonMod1 Property

ParameterTypeIdPhyMaterialParamPoissonMod1 Property

"Poisson ratio X"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamPoissonMod1 { get; }
Public Shared ReadOnly Property PhyMaterialParamPoissonMod1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamPoissonMod1 {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamPoissonMod1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamPoissonMod12 Property

ParameterTypeIdPhyMaterialParamPoissonMod12 Property

"Poisson Ratio 12"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamPoissonMod12 { get; }
Public Shared ReadOnly Property PhyMaterialParamPoissonMod12 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamPoissonMod12 {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamPoissonMod12 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamPoissonMod2 Property

ParameterTypeIdPhyMaterialParamPoissonMod2 Property

"Poisson ratio Y"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamPoissonMod2 { get; }
Public Shared ReadOnly Property PhyMaterialParamPoissonMod2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamPoissonMod2 {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamPoissonMod2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamPoissonMod23 Property

ParameterTypeIdPhyMaterialParamPoissonMod23 Property

"Poisson Ratio 23"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamPoissonMod23 { get; }
Public Shared ReadOnly Property PhyMaterialParamPoissonMod23 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamPoissonMod23 {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamPoissonMod23 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamPoissonMod3 Property

ParameterTypeIdPhyMaterialParamPoissonMod3 Property

"Poisson ratio Z"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamPoissonMod3 { get; }
Public Shared ReadOnly Property PhyMaterialParamPoissonMod3 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamPoissonMod3 {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamPoissonMod3 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamReductionFactor Property

ParameterTypeIdPhyMaterialParamReductionFactor Property

"Reduction factor for shear"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamReductionFactor { get; }
Public Shared ReadOnly Property PhyMaterialParamReductionFactor As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamReductionFactor {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamReductionFactor : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamResistanceCalcStrength Property

ParameterTypeIdPhyMaterialParamResistanceCalcStrength Property

"Resistance calculation strength"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamResistanceCalcStrength { get; }
Public Shared ReadOnly Property PhyMaterialParamResistanceCalcStrength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamResistanceCalcStrength {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamResistanceCalcStrength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamShearMod Property

ParameterTypeIdPhyMaterialParamShearMod Property

"Shear modulus"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamShearMod { get; }
Public Shared ReadOnly Property PhyMaterialParamShearMod As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamShearMod {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamShearMod : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamShearMod1 Property

ParameterTypeIdPhyMaterialParamShearMod1 Property

"Shear modulus X"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamShearMod1 { get; }
Public Shared ReadOnly Property PhyMaterialParamShearMod1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamShearMod1 {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamShearMod1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamShearMod12 Property

ParameterTypeIdPhyMaterialParamShearMod12 Property

"Shear Modulus 12"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamShearMod12 { get; }
Public Shared ReadOnly Property PhyMaterialParamShearMod12 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamShearMod12 {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamShearMod12 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamShearMod2 Property

ParameterTypeIdPhyMaterialParamShearMod2 Property

"Shear modulus Y"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamShearMod2 { get; }
Public Shared ReadOnly Property PhyMaterialParamShearMod2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamShearMod2 {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamShearMod2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamShearMod3 Property

ParameterTypeIdPhyMaterialParamShearMod3 Property

"Shear modulus Z"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamShearMod3 { get; }
Public Shared ReadOnly Property PhyMaterialParamShearMod3 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamShearMod3 {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamShearMod3 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamShearParallel Property

ParameterTypeIdPhyMaterialParamShearParallel Property

"Shear parallel to grain"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamShearParallel { get; }
Public Shared ReadOnly Property PhyMaterialParamShearParallel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamShearParallel {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamShearParallel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamShearPerpendicular Property

ParameterTypeIdPhyMaterialParamShearPerpendicular Property

"Shear perpendicular to grain"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamShearPerpendicular { get; }
Public Shared ReadOnly Property PhyMaterialParamShearPerpendicular As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamShearPerpendicular {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamShearPerpendicular : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamShearReinforcement Property

ParameterTypeIdPhyMaterialParamShearReinforcement Property

"Shear reinforcement yield stress"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamShearReinforcement { get; }
Public Shared ReadOnly Property PhyMaterialParamShearReinforcement As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamShearReinforcement {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamShearReinforcement : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamShearStrengthReduction Property

ParameterTypeIdPhyMaterialParamShearStrengthReduction Property

"Shear strength modification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamShearStrengthReduction { get; }
Public Shared ReadOnly Property PhyMaterialParamShearStrengthReduction As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamShearStrengthReduction {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamShearStrengthReduction : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamSpecies Property

ParameterTypeIdPhyMaterialParamSpecies Property

"Species"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamSpecies { get; }
Public Shared ReadOnly Property PhyMaterialParamSpecies As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamSpecies {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamSpecies : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamStructuralDensity Property

ParameterTypeIdPhyMaterialParamStructuralDensity Property

"Density"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamStructuralDensity { get; }
Public Shared ReadOnly Property PhyMaterialParamStructuralDensity As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamStructuralDensity {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamStructuralDensity : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamStructuralSpecificHeat Property

ParameterTypeIdPhyMaterialParamStructuralSpecificHeat Property

"Specific Heat"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamStructuralSpecificHeat { get; }
Public Shared ReadOnly Property PhyMaterialParamStructuralSpecificHeat As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamStructuralSpecificHeat {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamStructuralSpecificHeat : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamStructuralThermalTreated Property

ParameterTypeIdPhyMaterialParamStructuralThermalTreated Property

"Thermally Treated"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamStructuralThermalTreated { get; }
Public Shared ReadOnly Property PhyMaterialParamStructuralThermalTreated As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamStructuralThermalTreated {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamStructuralThermalTreated : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamSubclass Property

ParameterTypeIdPhyMaterialParamSubclass Property

"Subclass"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamSubclass { get; }
Public Shared ReadOnly Property PhyMaterialParamSubclass As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamSubclass {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamSubclass : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamTensionParallel Property

ParameterTypeIdPhyMaterialParamTensionParallel Property

"Tension Parallel to Grain"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamTensionParallel { get; }
Public Shared ReadOnly Property PhyMaterialParamTensionParallel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamTensionParallel {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamTensionParallel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamTensionPerpendicular Property

ParameterTypeIdPhyMaterialParamTensionPerpendicular Property

"Tension Perpendicular to Grain"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamTensionPerpendicular { get; }
Public Shared ReadOnly Property PhyMaterialParamTensionPerpendicular As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamTensionPerpendicular {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamTensionPerpendicular : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamThermalConductivity Property

ParameterTypeIdPhyMaterialParamThermalConductivity Property

"Thermal Conductivity"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamThermalConductivity { get; }
Public Shared ReadOnly Property PhyMaterialParamThermalConductivity As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamThermalConductivity {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamThermalConductivity : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamThermalConductivityX Property

ParameterTypeIdPhyMaterialParamThermalConductivityX Property

"Thermal Conductivity X"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamThermalConductivityX { get; }
Public Shared ReadOnly Property PhyMaterialParamThermalConductivityX As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamThermalConductivityX {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamThermalConductivityX : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamThermalConductivityY Property

ParameterTypeIdPhyMaterialParamThermalConductivityY Property

"Thermal Conductivity Y"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamThermalConductivityY { get; }
Public Shared ReadOnly Property PhyMaterialParamThermalConductivityY As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamThermalConductivityY {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamThermalConductivityY : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamThermalConductivityZ Property

ParameterTypeIdPhyMaterialParamThermalConductivityZ Property

"Thermal Conductivity Z"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamThermalConductivityZ { get; }
Public Shared ReadOnly Property PhyMaterialParamThermalConductivityZ As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamThermalConductivityZ {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamThermalConductivityZ : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamType Property

ParameterTypeIdPhyMaterialParamType Property

"Material Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamType { get; }
Public Shared ReadOnly Property PhyMaterialParamType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamType {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamUnitWeight Property

ParameterTypeIdPhyMaterialParamUnitWeight Property

"Unit weight"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamUnitWeight { get; }
Public Shared ReadOnly Property PhyMaterialParamUnitWeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamUnitWeight {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamUnitWeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamWoodConstruction Property

ParameterTypeIdPhyMaterialParamWoodConstruction Property

"Construction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamWoodConstruction { get; }
Public Shared ReadOnly Property PhyMaterialParamWoodConstruction As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamWoodConstruction {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamWoodConstruction : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamYoungMod Property

ParameterTypeIdPhyMaterialParamYoungMod Property

"Young modulus"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamYoungMod { get; }
Public Shared ReadOnly Property PhyMaterialParamYoungMod As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamYoungMod {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamYoungMod : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamYoungMod1 Property

ParameterTypeIdPhyMaterialParamYoungMod1 Property

"Young modulus X"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamYoungMod1 { get; }
Public Shared ReadOnly Property PhyMaterialParamYoungMod1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamYoungMod1 {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamYoungMod1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamYoungMod2 Property

ParameterTypeIdPhyMaterialParamYoungMod2 Property

"Young modulus Y"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamYoungMod2 { get; }
Public Shared ReadOnly Property PhyMaterialParamYoungMod2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamYoungMod2 {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamYoungMod2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamYoungMod3 Property

ParameterTypeIdPhyMaterialParamYoungMod3 Property

"Young modulus Z"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamYoungMod3 { get; }
Public Shared ReadOnly Property PhyMaterialParamYoungMod3 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamYoungMod3 {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamYoungMod3 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamYoungModn1 Property

ParameterTypeIdPhyMaterialParamYoungModn1 Property

"Young's Modulus 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamYoungModn1 { get; }
Public Shared ReadOnly Property PhyMaterialParamYoungModn1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamYoungModn1 {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamYoungModn1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialParamYoungModn2 Property

ParameterTypeIdPhyMaterialParamYoungModn2 Property

"Young's Modulus 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialParamYoungModn2 { get; }
Public Shared ReadOnly Property PhyMaterialParamYoungModn2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialParamYoungModn2 {
    ForgeTypeId^ get ();
}
static member PhyMaterialParamYoungModn2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PhyMaterialProperties Property

ParameterTypeIdPhyMaterialProperties Property

"Properties"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PhyMaterialProperties { get; }
Public Shared ReadOnly Property PhyMaterialProperties As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PhyMaterialProperties {
    ForgeTypeId^ get ();
}
static member PhyMaterialProperties : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PipeInsulationThickness Property

ParameterTypeIdPipeInsulationThickness Property

"Insulation Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PipeInsulationThickness { get; }
Public Shared ReadOnly Property PipeInsulationThickness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PipeInsulationThickness {
    ForgeTypeId^ get ();
}
static member PipeInsulationThickness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PipeRoughness Property

ParameterTypeIdPipeRoughness Property

"Roughness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PipeRoughness { get; }
Public Shared ReadOnly Property PipeRoughness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PipeRoughness {
    ForgeTypeId^ get ();
}
static member PipeRoughness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PipeVelocityPressure Property

ParameterTypeIdPipeVelocityPressure Property

"Velocity Pressure"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PipeVelocityPressure { get; }
Public Shared ReadOnly Property PipeVelocityPressure As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PipeVelocityPressure {
    ForgeTypeId^ get ();
}
static member PipeVelocityPressure : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PipingConnectionType Property

ParameterTypeIdPipingConnectionType Property

"Connection Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PipingConnectionType { get; }
Public Shared ReadOnly Property PipingConnectionType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PipingConnectionType {
    ForgeTypeId^ get ();
}
static member PipingConnectionType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PipingGenderType Property

ParameterTypeIdPipingGenderType Property

"Gender Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PipingGenderType { get; }
Public Shared ReadOnly Property PipingGenderType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PipingGenderType {
    ForgeTypeId^ get ();
}
static member PipingGenderType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PlacementBottom Property

ParameterTypeIdPlacementBottom Property

"Bottom"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PlacementBottom { get; }
Public Shared ReadOnly Property PlacementBottom As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PlacementBottom {
    ForgeTypeId^ get ();
}
static member PlacementBottom : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PlacementCenterX Property

ParameterTypeIdPlacementCenterX Property

"Center X"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PlacementCenterX { get; }
Public Shared ReadOnly Property PlacementCenterX As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PlacementCenterX {
    ForgeTypeId^ get ();
}
static member PlacementCenterX : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PlacementCenterY Property

ParameterTypeIdPlacementCenterY Property

"Center Y"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PlacementCenterY { get; }
Public Shared ReadOnly Property PlacementCenterY As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PlacementCenterY {
    ForgeTypeId^ get ();
}
static member PlacementCenterY : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PlacementLeft Property

ParameterTypeIdPlacementLeft Property

"Left"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PlacementLeft { get; }
Public Shared ReadOnly Property PlacementLeft As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PlacementLeft {
    ForgeTypeId^ get ();
}
static member PlacementLeft : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PlacementParamsShow Property

ParameterTypeIdPlacementParamsShow Property

"Enable Position Parameters"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PlacementParamsShow { get; }
Public Shared ReadOnly Property PlacementParamsShow As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PlacementParamsShow {
    ForgeTypeId^ get ();
}
static member PlacementParamsShow : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PlacementRight Property

ParameterTypeIdPlacementRight Property

"Right"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PlacementRight { get; }
Public Shared ReadOnly Property PlacementRight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PlacementRight {
    ForgeTypeId^ get ();
}
static member PlacementRight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PlacementTop Property

ParameterTypeIdPlacementTop Property

"Top"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PlacementTop { get; }
Public Shared ReadOnly Property PlacementTop As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PlacementTop {
    ForgeTypeId^ get ();
}
static member PlacementTop : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PlanRegionViewRange Property

ParameterTypeIdPlanRegionViewRange Property

"View Range"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PlanRegionViewRange { get; }
Public Shared ReadOnly Property PlanRegionViewRange As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PlanRegionViewRange {
    ForgeTypeId^ get ();
}
static member PlanRegionViewRange : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PlanViewCutPlaneHeight Property

ParameterTypeIdPlanViewCutPlaneHeight Property

"Cut Plane Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PlanViewCutPlaneHeight { get; }
Public Shared ReadOnly Property PlanViewCutPlaneHeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PlanViewCutPlaneHeight {
    ForgeTypeId^ get ();
}
static member PlanViewCutPlaneHeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PlanViewLevel Property

ParameterTypeIdPlanViewLevel Property

"Associated Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PlanViewLevel { get; }
Public Shared ReadOnly Property PlanViewLevel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PlanViewLevel {
    ForgeTypeId^ get ();
}
static member PlanViewLevel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PlanViewNorth Property

ParameterTypeIdPlanViewNorth Property

"Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PlanViewNorth { get; }
Public Shared ReadOnly Property PlanViewNorth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PlanViewNorth {
    ForgeTypeId^ get ();
}
static member PlanViewNorth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PlanViewRange Property

ParameterTypeIdPlanViewRange Property

"View Range"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PlanViewRange { get; }
Public Shared ReadOnly Property PlanViewRange As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PlanViewRange {
    ForgeTypeId^ get ();
}
static member PlanViewRange : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PlanViewTopClipHeight Property

ParameterTypeIdPlanViewTopClipHeight Property

"Top Clip Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PlanViewTopClipHeight { get; }
Public Shared ReadOnly Property PlanViewTopClipHeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PlanViewTopClipHeight {
    ForgeTypeId^ get ();
}
static member PlanViewTopClipHeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PlanViewViewDir Property

ParameterTypeIdPlanViewViewDir Property

"View Direction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PlanViewViewDir { get; }
Public Shared ReadOnly Property PlanViewViewDir As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PlanViewViewDir {
    ForgeTypeId^ get ();
}
static member PlanViewViewDir : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PlumbingFixturesCwConnection Property

ParameterTypeIdPlumbingFixturesCwConnection Property

"CW Connection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PlumbingFixturesCwConnection { get; }
Public Shared ReadOnly Property PlumbingFixturesCwConnection As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PlumbingFixturesCwConnection {
    ForgeTypeId^ get ();
}
static member PlumbingFixturesCwConnection : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PlumbingFixturesDrain Property

ParameterTypeIdPlumbingFixturesDrain Property

"Drain"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PlumbingFixturesDrain { get; }
Public Shared ReadOnly Property PlumbingFixturesDrain As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PlumbingFixturesDrain {
    ForgeTypeId^ get ();
}
static member PlumbingFixturesDrain : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PlumbingFixturesHwConnection Property

ParameterTypeIdPlumbingFixturesHwConnection Property

"HW Connection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PlumbingFixturesHwConnection { get; }
Public Shared ReadOnly Property PlumbingFixturesHwConnection As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PlumbingFixturesHwConnection {
    ForgeTypeId^ get ();
}
static member PlumbingFixturesHwConnection : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PlumbingFixturesSupplyFitting Property

ParameterTypeIdPlumbingFixturesSupplyFitting Property

"Supply Fitting"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PlumbingFixturesSupplyFitting { get; }
Public Shared ReadOnly Property PlumbingFixturesSupplyFitting As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PlumbingFixturesSupplyFitting {
    ForgeTypeId^ get ();
}
static member PlumbingFixturesSupplyFitting : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PlumbingFixturesSupplyPipe Property

ParameterTypeIdPlumbingFixturesSupplyPipe Property

"Supply Pipe"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PlumbingFixturesSupplyPipe { get; }
Public Shared ReadOnly Property PlumbingFixturesSupplyPipe As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PlumbingFixturesSupplyPipe {
    ForgeTypeId^ get ();
}
static member PlumbingFixturesSupplyPipe : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PlumbingFixturesTrap Property

ParameterTypeIdPlumbingFixturesTrap Property

"Trap"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PlumbingFixturesTrap { get; }
Public Shared ReadOnly Property PlumbingFixturesTrap As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PlumbingFixturesTrap {
    ForgeTypeId^ get ();
}
static member PlumbingFixturesTrap : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PlumbingFixturesVentConnection Property

ParameterTypeIdPlumbingFixturesVentConnection Property

"Vent Connection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PlumbingFixturesVentConnection { get; }
Public Shared ReadOnly Property PlumbingFixturesVentConnection As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PlumbingFixturesVentConnection {
    ForgeTypeId^ get ();
}
static member PlumbingFixturesVentConnection : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PlumbingFixturesWasteConnection Property

ParameterTypeIdPlumbingFixturesWasteConnection Property

"Waste Connection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PlumbingFixturesWasteConnection { get; }
Public Shared ReadOnly Property PlumbingFixturesWasteConnection As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PlumbingFixturesWasteConnection {
    ForgeTypeId^ get ();
}
static member PlumbingFixturesWasteConnection : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PocheMatId Property

ParameterTypeIdPocheMatId Property

"Coarse Poche Material"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PocheMatId { get; }
Public Shared ReadOnly Property PocheMatId As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PocheMatId {
    ForgeTypeId^ get ();
}
static member PocheMatId : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PointAdaptiveConstrained Property

ParameterTypeIdPointAdaptiveConstrained Property

"Constrained"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PointAdaptiveConstrained { get; }
Public Shared ReadOnly Property PointAdaptiveConstrained As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PointAdaptiveConstrained {
    ForgeTypeId^ get ();
}
static member PointAdaptiveConstrained : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PointAdaptiveNumParam Property

ParameterTypeIdPointAdaptiveNumParam Property

"Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PointAdaptiveNumParam { get; }
Public Shared ReadOnly Property PointAdaptiveNumParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PointAdaptiveNumParam {
    ForgeTypeId^ get ();
}
static member PointAdaptiveNumParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PointAdaptiveOrientationType Property

ParameterTypeIdPointAdaptiveOrientationType Property

"Orients to"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PointAdaptiveOrientationType { get; }
Public Shared ReadOnly Property PointAdaptiveOrientationType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PointAdaptiveOrientationType {
    ForgeTypeId^ get ();
}
static member PointAdaptiveOrientationType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PointAdaptiveShowNumber Property

ParameterTypeIdPointAdaptiveShowNumber Property

"Show Placement Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PointAdaptiveShowNumber { get; }
Public Shared ReadOnly Property PointAdaptiveShowNumber As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PointAdaptiveShowNumber {
    ForgeTypeId^ get ();
}
static member PointAdaptiveShowNumber : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PointAdaptiveTypeParam Property

ParameterTypeIdPointAdaptiveTypeParam Property

"Point"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PointAdaptiveTypeParam { get; }
Public Shared ReadOnly Property PointAdaptiveTypeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PointAdaptiveTypeParam {
    ForgeTypeId^ get ();
}
static member PointAdaptiveTypeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PointcloudinstanceName Property

ParameterTypeIdPointcloudinstanceName Property

"Name": The name of the instance as it will show in the Property Palette

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PointcloudinstanceName { get; }
Public Shared ReadOnly Property PointcloudinstanceName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PointcloudinstanceName {
    ForgeTypeId^ get ();
}
static member PointcloudinstanceName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PointcloudtypeScale Property

ParameterTypeIdPointcloudtypeScale Property

"Scale": The scale for this instance

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PointcloudtypeScale { get; }
Public Shared ReadOnly Property PointcloudtypeScale As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PointcloudtypeScale {
    ForgeTypeId^ get ();
}
static member PointcloudtypeScale : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PointElementAngle Property

ParameterTypeIdPointElementAngle Property

"Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PointElementAngle { get; }
Public Shared ReadOnly Property PointElementAngle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PointElementAngle {
    ForgeTypeId^ get ();
}
static member PointElementAngle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PointElementChordLength Property

ParameterTypeIdPointElementChordLength Property

"Chord Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PointElementChordLength { get; }
Public Shared ReadOnly Property PointElementChordLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PointElementChordLength {
    ForgeTypeId^ get ();
}
static member PointElementChordLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PointElementDriven Property

ParameterTypeIdPointElementDriven Property

"Driven by Host"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PointElementDriven { get; }
Public Shared ReadOnly Property PointElementDriven As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PointElementDriven {
    ForgeTypeId^ get ();
}
static member PointElementDriven : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PointElementDriving Property

ParameterTypeIdPointElementDriving Property

"Driving Curve(s)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PointElementDriving { get; }
Public Shared ReadOnly Property PointElementDriving As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PointElementDriving {
    ForgeTypeId^ get ();
}
static member PointElementDriving : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PointElementHostedOnFaceUParam Property

ParameterTypeIdPointElementHostedOnFaceUParam Property

"Hosted U Parameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PointElementHostedOnFaceUParam { get; }
Public Shared ReadOnly Property PointElementHostedOnFaceUParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PointElementHostedOnFaceUParam {
    ForgeTypeId^ get ();
}
static member PointElementHostedOnFaceUParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PointElementHostedOnFaceVParam Property

ParameterTypeIdPointElementHostedOnFaceVParam Property

"Hosted V Parameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PointElementHostedOnFaceVParam { get; }
Public Shared ReadOnly Property PointElementHostedOnFaceVParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PointElementHostedOnFaceVParam {
    ForgeTypeId^ get ();
}
static member PointElementHostedOnFaceVParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PointElementHostedParam Property

ParameterTypeIdPointElementHostedParam Property

"Hosted Parameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PointElementHostedParam { get; }
Public Shared ReadOnly Property PointElementHostedParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PointElementHostedParam {
    ForgeTypeId^ get ();
}
static member PointElementHostedParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PointElementMeasureFrom Property

ParameterTypeIdPointElementMeasureFrom Property

"Measure From"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PointElementMeasureFrom { get; }
Public Shared ReadOnly Property PointElementMeasureFrom As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PointElementMeasureFrom {
    ForgeTypeId^ get ();
}
static member PointElementMeasureFrom : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PointElementMeasurementType Property

ParameterTypeIdPointElementMeasurementType Property

"Measurement Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PointElementMeasurementType { get; }
Public Shared ReadOnly Property PointElementMeasurementType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PointElementMeasurementType {
    ForgeTypeId^ get ();
}
static member PointElementMeasurementType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PointElementMirrored Property

ParameterTypeIdPointElementMirrored Property

"Mirrored"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PointElementMirrored { get; }
Public Shared ReadOnly Property PointElementMirrored As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PointElementMirrored {
    ForgeTypeId^ get ();
}
static member PointElementMirrored : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PointElementNonNormalizedCurveParamater Property

ParameterTypeIdPointElementNonNormalizedCurveParamater Property

"Non-Normalized Curve Parameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PointElementNonNormalizedCurveParamater { get; }
Public Shared ReadOnly Property PointElementNonNormalizedCurveParamater As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PointElementNonNormalizedCurveParamater {
    ForgeTypeId^ get ();
}
static member PointElementNonNormalizedCurveParamater : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PointElementNormalizedCurveParamater Property

ParameterTypeIdPointElementNormalizedCurveParamater Property

"Normalized Curve Parameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PointElementNormalizedCurveParamater { get; }
Public Shared ReadOnly Property PointElementNormalizedCurveParamater As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PointElementNormalizedCurveParamater {
    ForgeTypeId^ get ();
}
static member PointElementNormalizedCurveParamater : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PointElementNormalizedSegmentLength Property

ParameterTypeIdPointElementNormalizedSegmentLength Property

"Normalized Segment Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PointElementNormalizedSegmentLength { get; }
Public Shared ReadOnly Property PointElementNormalizedSegmentLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PointElementNormalizedSegmentLength {
    ForgeTypeId^ get ();
}
static member PointElementNormalizedSegmentLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PointElementOffset Property

ParameterTypeIdPointElementOffset Property

"Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PointElementOffset { get; }
Public Shared ReadOnly Property PointElementOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PointElementOffset {
    ForgeTypeId^ get ();
}
static member PointElementOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PointElementRotationAngle Property

ParameterTypeIdPointElementRotationAngle Property

"Rotation Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PointElementRotationAngle { get; }
Public Shared ReadOnly Property PointElementRotationAngle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PointElementRotationAngle {
    ForgeTypeId^ get ();
}
static member PointElementRotationAngle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PointElementSegmentLength Property

ParameterTypeIdPointElementSegmentLength Property

"Segment Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PointElementSegmentLength { get; }
Public Shared ReadOnly Property PointElementSegmentLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PointElementSegmentLength {
    ForgeTypeId^ get ();
}
static member PointElementSegmentLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PointElementShowNormalPlaneOnly Property

ParameterTypeIdPointElementShowNormalPlaneOnly Property

"Show Normal Reference Plane Only"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PointElementShowNormalPlaneOnly { get; }
Public Shared ReadOnly Property PointElementShowNormalPlaneOnly As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PointElementShowNormalPlaneOnly {
    ForgeTypeId^ get ();
}
static member PointElementShowNormalPlaneOnly : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PointElementShowPlanes Property

ParameterTypeIdPointElementShowPlanes Property

"Show Reference Planes"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PointElementShowPlanes { get; }
Public Shared ReadOnly Property PointElementShowPlanes As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PointElementShowPlanes {
    ForgeTypeId^ get ();
}
static member PointElementShowPlanes : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PointElementZflipped Property

ParameterTypeIdPointElementZflipped Property

"Flipped"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PointElementZflipped { get; }
Public Shared ReadOnly Property PointElementZflipped As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PointElementZflipped {
    ForgeTypeId^ get ();
}
static member PointElementZflipped : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PointElevation Property

ParameterTypeIdPointElevation Property

"Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PointElevation { get; }
Public Shared ReadOnly Property PointElevation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PointElevation {
    ForgeTypeId^ get ();
}
static member PointElevation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PointFlexibleConstrained Property

ParameterTypeIdPointFlexibleConstrained Property

"Constrained"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PointFlexibleConstrained { get; }
Public Shared ReadOnly Property PointFlexibleConstrained As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PointFlexibleConstrained {
    ForgeTypeId^ get ();
}
static member PointFlexibleConstrained : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PointFlexibleNumParam Property

ParameterTypeIdPointFlexibleNumParam Property

"Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PointFlexibleNumParam { get; }
Public Shared ReadOnly Property PointFlexibleNumParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PointFlexibleNumParam {
    ForgeTypeId^ get ();
}
static member PointFlexibleNumParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PointFlexibleOrientationType Property

ParameterTypeIdPointFlexibleOrientationType Property

"Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PointFlexibleOrientationType { get; }
Public Shared ReadOnly Property PointFlexibleOrientationType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PointFlexibleOrientationType {
    ForgeTypeId^ get ();
}
static member PointFlexibleOrientationType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PointFlexibleShowNumber Property

ParameterTypeIdPointFlexibleShowNumber Property

"Show Placement Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PointFlexibleShowNumber { get; }
Public Shared ReadOnly Property PointFlexibleShowNumber As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PointFlexibleShowNumber {
    ForgeTypeId^ get ();
}
static member PointFlexibleShowNumber : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PointNameParam Property

ParameterTypeIdPointNameParam Property

"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PointNameParam { get; }
Public Shared ReadOnly Property PointNameParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PointNameParam {
    ForgeTypeId^ get ();
}
static member PointNameParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PointVisibilityParam Property

ParameterTypeIdPointVisibilityParam Property

"Visibility/Graphics Overrides"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PointVisibilityParam { get; }
Public Shared ReadOnly Property PointVisibilityParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PointVisibilityParam {
    ForgeTypeId^ get ();
}
static member PointVisibilityParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PreferDimSideUiFilter Property

ParameterTypeIdPreferDimSideUiFilter Property

"Prefer:": This is used by the UI to allow select prefer dimension side.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PreferDimSideUiFilter { get; }
Public Shared ReadOnly Property PreferDimSideUiFilter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PreferDimSideUiFilter {
    ForgeTypeId^ get ();
}
static member PreferDimSideUiFilter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PreferPatternAlignUiFilter Property

ParameterTypeIdPreferPatternAlignUiFilter Property

"Pattern:": This is used by the UI to allow to select the preferred preference of aligning pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PreferPatternAlignUiFilter { get; }
Public Shared ReadOnly Property PreferPatternAlignUiFilter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PreferPatternAlignUiFilter {
    ForgeTypeId^ get ();
}
static member PreferPatternAlignUiFilter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PrimaryOptionId Property

ParameterTypeIdPrimaryOptionId Property

"Primary Option Id"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PrimaryOptionId { get; }
Public Shared ReadOnly Property PrimaryOptionId As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PrimaryOptionId {
    ForgeTypeId^ get ();
}
static member PrimaryOptionId : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.Profile1Angle Property

ParameterTypeIdProfile1Angle Property

"Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Profile1Angle { get; }
Public Shared ReadOnly Property Profile1Angle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Profile1Angle {
    ForgeTypeId^ get ();
}
static member Profile1Angle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.Profile1FamType Property

ParameterTypeIdProfile1FamType Property

"Profile"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Profile1FamType { get; }
Public Shared ReadOnly Property Profile1FamType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Profile1FamType {
    ForgeTypeId^ get ();
}
static member Profile1FamType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.Profile1FlippedHor Property

ParameterTypeIdProfile1FlippedHor Property

"Profile Is Flipped"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Profile1FlippedHor { get; }
Public Shared ReadOnly Property Profile1FlippedHor As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Profile1FlippedHor {
    ForgeTypeId^ get ();
}
static member Profile1FlippedHor : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.Profile1OffsetX Property

ParameterTypeIdProfile1OffsetX Property

"Horizontal Profile Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Profile1OffsetX { get; }
Public Shared ReadOnly Property Profile1OffsetX As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Profile1OffsetX {
    ForgeTypeId^ get ();
}
static member Profile1OffsetX : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.Profile1OffsetY Property

ParameterTypeIdProfile1OffsetY Property

"Vertical Profile Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Profile1OffsetY { get; }
Public Shared ReadOnly Property Profile1OffsetY As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Profile1OffsetY {
    ForgeTypeId^ get ();
}
static member Profile1OffsetY : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.Profile2Angle Property

ParameterTypeIdProfile2Angle Property

"Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Profile2Angle { get; }
Public Shared ReadOnly Property Profile2Angle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Profile2Angle {
    ForgeTypeId^ get ();
}
static member Profile2Angle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.Profile2FamType Property

ParameterTypeIdProfile2FamType Property

"Profile"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Profile2FamType { get; }
Public Shared ReadOnly Property Profile2FamType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Profile2FamType {
    ForgeTypeId^ get ();
}
static member Profile2FamType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.Profile2FlippedHor Property

ParameterTypeIdProfile2FlippedHor Property

"Profile Is Flipped"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Profile2FlippedHor { get; }
Public Shared ReadOnly Property Profile2FlippedHor As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Profile2FlippedHor {
    ForgeTypeId^ get ();
}
static member Profile2FlippedHor : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.Profile2OffsetX Property

ParameterTypeIdProfile2OffsetX Property

"Horizontal Profile Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Profile2OffsetX { get; }
Public Shared ReadOnly Property Profile2OffsetX As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Profile2OffsetX {
    ForgeTypeId^ get ();
}
static member Profile2OffsetX : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.Profile2OffsetY Property

ParameterTypeIdProfile2OffsetY Property

"Vertical Profile Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Profile2OffsetY { get; }
Public Shared ReadOnly Property Profile2OffsetY As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Profile2OffsetY {
    ForgeTypeId^ get ();
}
static member Profile2OffsetY : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ProfileAngle Property

ParameterTypeIdProfileAngle Property

"Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ProfileAngle { get; }
Public Shared ReadOnly Property ProfileAngle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ProfileAngle {
    ForgeTypeId^ get ();
}
static member ProfileAngle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ProfileFamType Property

ParameterTypeIdProfileFamType Property

"Profile"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ProfileFamType { get; }
Public Shared ReadOnly Property ProfileFamType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ProfileFamType {
    ForgeTypeId^ get ();
}
static member ProfileFamType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ProfileFamTypePlusNone Property

ParameterTypeIdProfileFamTypePlusNone Property

"Profile"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ProfileFamTypePlusNone { get; }
Public Shared ReadOnly Property ProfileFamTypePlusNone As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ProfileFamTypePlusNone {
    ForgeTypeId^ get ();
}
static member ProfileFamTypePlusNone : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ProfileFlippedHor Property

ParameterTypeIdProfileFlippedHor Property

"Profile Is Flipped"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ProfileFlippedHor { get; }
Public Shared ReadOnly Property ProfileFlippedHor As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ProfileFlippedHor {
    ForgeTypeId^ get ();
}
static member ProfileFlippedHor : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ProfileOffsetX Property

ParameterTypeIdProfileOffsetX Property

"Horizontal Profile Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ProfileOffsetX { get; }
Public Shared ReadOnly Property ProfileOffsetX As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ProfileOffsetX {
    ForgeTypeId^ get ();
}
static member ProfileOffsetX : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ProfileOffsetY Property

ParameterTypeIdProfileOffsetY Property

"Vertical Profile Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ProfileOffsetY { get; }
Public Shared ReadOnly Property ProfileOffsetY As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ProfileOffsetY {
    ForgeTypeId^ get ();
}
static member ProfileOffsetY : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ProfileParamAlongPath Property

ParameterTypeIdProfileParamAlongPath Property

"Parameter along path"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ProfileParamAlongPath { get; }
Public Shared ReadOnly Property ProfileParamAlongPath As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ProfileParamAlongPath {
    ForgeTypeId^ get ();
}
static member ProfileParamAlongPath : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ProjectAddress Property

ParameterTypeIdProjectAddress Property

"Project Address"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ProjectAddress { get; }
Public Shared ReadOnly Property ProjectAddress As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ProjectAddress {
    ForgeTypeId^ get ();
}
static member ProjectAddress : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ProjectAuthor Property

ParameterTypeIdProjectAuthor Property

"Author"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ProjectAuthor { get; }
Public Shared ReadOnly Property ProjectAuthor As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ProjectAuthor {
    ForgeTypeId^ get ();
}
static member ProjectAuthor : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ProjectBuildingName Property

ParameterTypeIdProjectBuildingName Property

"Building Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ProjectBuildingName { get; }
Public Shared ReadOnly Property ProjectBuildingName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ProjectBuildingName {
    ForgeTypeId^ get ();
}
static member ProjectBuildingName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ProjectBuildingType Property

ParameterTypeIdProjectBuildingType Property

"Building Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ProjectBuildingType { get; }
Public Shared ReadOnly Property ProjectBuildingType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ProjectBuildingType {
    ForgeTypeId^ get ();
}
static member ProjectBuildingType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ProjectedSurfaceArea Property

ParameterTypeIdProjectedSurfaceArea Property

"Projected Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ProjectedSurfaceArea { get; }
Public Shared ReadOnly Property ProjectedSurfaceArea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ProjectedSurfaceArea {
    ForgeTypeId^ get ();
}
static member ProjectedSurfaceArea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ProjectIssueDate Property

ParameterTypeIdProjectIssueDate Property

"Project Issue Date"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ProjectIssueDate { get; }
Public Shared ReadOnly Property ProjectIssueDate As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ProjectIssueDate {
    ForgeTypeId^ get ();
}
static member ProjectIssueDate : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ProjectName Property

ParameterTypeIdProjectName Property

"Project Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ProjectName { get; }
Public Shared ReadOnly Property ProjectName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ProjectName {
    ForgeTypeId^ get ();
}
static member ProjectName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ProjectNumber Property

ParameterTypeIdProjectNumber Property

"Project Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ProjectNumber { get; }
Public Shared ReadOnly Property ProjectNumber As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ProjectNumber {
    ForgeTypeId^ get ();
}
static member ProjectNumber : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ProjectOrganizationDescription Property

ParameterTypeIdProjectOrganizationDescription Property

"Organization Description"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ProjectOrganizationDescription { get; }
Public Shared ReadOnly Property ProjectOrganizationDescription As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ProjectOrganizationDescription {
    ForgeTypeId^ get ();
}
static member ProjectOrganizationDescription : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ProjectOrganizationName Property

ParameterTypeIdProjectOrganizationName Property

"Organization Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ProjectOrganizationName { get; }
Public Shared ReadOnly Property ProjectOrganizationName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ProjectOrganizationName {
    ForgeTypeId^ get ();
}
static member ProjectOrganizationName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ProjectPostalCode Property

ParameterTypeIdProjectPostalCode Property

"Postal Code"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ProjectPostalCode { get; }
Public Shared ReadOnly Property ProjectPostalCode As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ProjectPostalCode {
    ForgeTypeId^ get ();
}
static member ProjectPostalCode : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ProjectRevisionEnumeration Property

ParameterTypeIdProjectRevisionEnumeration Property

"Numbering"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ProjectRevisionEnumeration { get; }
Public Shared ReadOnly Property ProjectRevisionEnumeration As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ProjectRevisionEnumeration {
    ForgeTypeId^ get ();
}
static member ProjectRevisionEnumeration : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ProjectRevisionRevisionDate Property

ParameterTypeIdProjectRevisionRevisionDate Property

"Revision Date"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ProjectRevisionRevisionDate { get; }
Public Shared ReadOnly Property ProjectRevisionRevisionDate As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ProjectRevisionRevisionDate {
    ForgeTypeId^ get ();
}
static member ProjectRevisionRevisionDate : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ProjectRevisionRevisionDescription Property

ParameterTypeIdProjectRevisionRevisionDescription Property

"Revision Description"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ProjectRevisionRevisionDescription { get; }
Public Shared ReadOnly Property ProjectRevisionRevisionDescription As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ProjectRevisionRevisionDescription {
    ForgeTypeId^ get ();
}
static member ProjectRevisionRevisionDescription : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ProjectRevisionRevisionIssued Property

ParameterTypeIdProjectRevisionRevisionIssued Property

"Issued"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ProjectRevisionRevisionIssued { get; }
Public Shared ReadOnly Property ProjectRevisionRevisionIssued As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ProjectRevisionRevisionIssued {
    ForgeTypeId^ get ();
}
static member ProjectRevisionRevisionIssued : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ProjectRevisionRevisionIssuedBy Property

ParameterTypeIdProjectRevisionRevisionIssuedBy Property

"Issued by"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ProjectRevisionRevisionIssuedBy { get; }
Public Shared ReadOnly Property ProjectRevisionRevisionIssuedBy As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ProjectRevisionRevisionIssuedBy {
    ForgeTypeId^ get ();
}
static member ProjectRevisionRevisionIssuedBy : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ProjectRevisionRevisionIssuedTo Property

ParameterTypeIdProjectRevisionRevisionIssuedTo Property

"Issued to"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ProjectRevisionRevisionIssuedTo { get; }
Public Shared ReadOnly Property ProjectRevisionRevisionIssuedTo As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ProjectRevisionRevisionIssuedTo {
    ForgeTypeId^ get ();
}
static member ProjectRevisionRevisionIssuedTo : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ProjectRevisionRevisionNum Property

ParameterTypeIdProjectRevisionRevisionNum Property

"Revision Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ProjectRevisionRevisionNum { get; }
Public Shared ReadOnly Property ProjectRevisionRevisionNum As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ProjectRevisionRevisionNum {
    ForgeTypeId^ get ();
}
static member ProjectRevisionRevisionNum : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ProjectRevisionSequenceNum Property

ParameterTypeIdProjectRevisionSequenceNum Property

"Revision Sequence": read_only Make this read-only again when NewSchedules_DisplayTags is cleaned up

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ProjectRevisionSequenceNum { get; }
Public Shared ReadOnly Property ProjectRevisionSequenceNum As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ProjectRevisionSequenceNum {
    ForgeTypeId^ get ();
}
static member ProjectRevisionSequenceNum : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ProjectStatus Property

ParameterTypeIdProjectStatus Property

"Project Status"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ProjectStatus { get; }
Public Shared ReadOnly Property ProjectStatus As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ProjectStatus {
    ForgeTypeId^ get ();
}
static member ProjectStatus : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PropertyArea Property

ParameterTypeIdPropertyArea Property

"Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PropertyArea { get; }
Public Shared ReadOnly Property PropertyArea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PropertyArea {
    ForgeTypeId^ get ();
}
static member PropertyArea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PropertyAreaOpen Property

ParameterTypeIdPropertyAreaOpen Property

"Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PropertyAreaOpen { get; }
Public Shared ReadOnly Property PropertyAreaOpen As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PropertyAreaOpen {
    ForgeTypeId^ get ();
}
static member PropertyAreaOpen : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PropertyAreaUnits Property

ParameterTypeIdPropertyAreaUnits Property

"Area Units, Format"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PropertyAreaUnits { get; }
Public Shared ReadOnly Property PropertyAreaUnits As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PropertyAreaUnits {
    ForgeTypeId^ get ();
}
static member PropertyAreaUnits : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PropertyLengthUnits Property

ParameterTypeIdPropertyLengthUnits Property

"Units Format"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PropertyLengthUnits { get; }
Public Shared ReadOnly Property PropertyLengthUnits As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PropertyLengthUnits {
    ForgeTypeId^ get ();
}
static member PropertyLengthUnits : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PropertySegmentBearing Property

ParameterTypeIdPropertySegmentBearing Property

"Bearing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PropertySegmentBearing { get; }
Public Shared ReadOnly Property PropertySegmentBearing As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PropertySegmentBearing {
    ForgeTypeId^ get ();
}
static member PropertySegmentBearing : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PropertySegmentDistance Property

ParameterTypeIdPropertySegmentDistance Property

"Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PropertySegmentDistance { get; }
Public Shared ReadOnly Property PropertySegmentDistance As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PropertySegmentDistance {
    ForgeTypeId^ get ();
}
static member PropertySegmentDistance : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PropertySegmentEW Property

ParameterTypeIdPropertySegmentEW Property

"E/W"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PropertySegmentEW { get; }
Public Shared ReadOnly Property PropertySegmentEW As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PropertySegmentEW {
    ForgeTypeId^ get ();
}
static member PropertySegmentEW : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PropertySegmentLR Property

ParameterTypeIdPropertySegmentLR Property

"L/R"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PropertySegmentLR { get; }
Public Shared ReadOnly Property PropertySegmentLR As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PropertySegmentLR {
    ForgeTypeId^ get ();
}
static member PropertySegmentLR : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PropertySegmentNS Property

ParameterTypeIdPropertySegmentNS Property

"N/S"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PropertySegmentNS { get; }
Public Shared ReadOnly Property PropertySegmentNS As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PropertySegmentNS {
    ForgeTypeId^ get ();
}
static member PropertySegmentNS : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PropertySegmentRadius Property

ParameterTypeIdPropertySegmentRadius Property

"Radius"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PropertySegmentRadius { get; }
Public Shared ReadOnly Property PropertySegmentRadius As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PropertySegmentRadius {
    ForgeTypeId^ get ();
}
static member PropertySegmentRadius : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PropertySegmentSubcategoryId Property

ParameterTypeIdPropertySegmentSubcategoryId Property

"Subcategory"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PropertySegmentSubcategoryId { get; }
Public Shared ReadOnly Property PropertySegmentSubcategoryId As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PropertySegmentSubcategoryId {
    ForgeTypeId^ get ();
}
static member PropertySegmentSubcategoryId : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PropertySetDescription Property

ParameterTypeIdPropertySetDescription Property

"Description"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PropertySetDescription { get; }
Public Shared ReadOnly Property PropertySetDescription As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PropertySetDescription {
    ForgeTypeId^ get ();
}
static member PropertySetDescription : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PropertySetKeywords Property

ParameterTypeIdPropertySetKeywords Property

"Keywords"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PropertySetKeywords { get; }
Public Shared ReadOnly Property PropertySetKeywords As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PropertySetKeywords {
    ForgeTypeId^ get ();
}
static member PropertySetKeywords : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PropertySetMaterialAspect Property

ParameterTypeIdPropertySetMaterialAspect Property

"Material aspect"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PropertySetMaterialAspect { get; }
Public Shared ReadOnly Property PropertySetMaterialAspect As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PropertySetMaterialAspect {
    ForgeTypeId^ get ();
}
static member PropertySetMaterialAspect : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PropertySetName Property

ParameterTypeIdPropertySetName Property

"Property Set Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PropertySetName { get; }
Public Shared ReadOnly Property PropertySetName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PropertySetName {
    ForgeTypeId^ get ();
}
static member PropertySetName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.PropertySubcategoryId Property

ParameterTypeIdPropertySubcategoryId Property

"Subcategory"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PropertySubcategoryId { get; }
Public Shared ReadOnly Property PropertySubcategoryId As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PropertySubcategoryId {
    ForgeTypeId^ get ();
}
static member PropertySubcategoryId : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RadialArrayArcRadius Property

ParameterTypeIdRadialArrayArcRadius Property

"Radius"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RadialArrayArcRadius { get; }
Public Shared ReadOnly Property RadialArrayArcRadius As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RadialArrayArcRadius {
    ForgeTypeId^ get ();
}
static member RadialArrayArcRadius : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RadiusSymbolLocation Property

ParameterTypeIdRadiusSymbolLocation Property

"Radius Symbol Location"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RadiusSymbolLocation { get; }
Public Shared ReadOnly Property RadiusSymbolLocation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RadiusSymbolLocation {
    ForgeTypeId^ get ();
}
static member RadiusSymbolLocation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RadiusSymbolText Property

ParameterTypeIdRadiusSymbolText Property

"Radius Symbol Text"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RadiusSymbolText { get; }
Public Shared ReadOnly Property RadiusSymbolText As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RadiusSymbolText {
    ForgeTypeId^ get ();
}
static member RadiusSymbolText : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RailingSystemHandrailsHeightParam Property

ParameterTypeIdRailingSystemHandrailsHeightParam Property

"Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RailingSystemHandrailsHeightParam { get; }
Public Shared ReadOnly Property RailingSystemHandrailsHeightParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RailingSystemHandrailsHeightParam {
    ForgeTypeId^ get ();
}
static member RailingSystemHandrailsHeightParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RailingSystemHandrailsLatteralOffset Property

ParameterTypeIdRailingSystemHandrailsLatteralOffset Property

"Lateral Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RailingSystemHandrailsLatteralOffset { get; }
Public Shared ReadOnly Property RailingSystemHandrailsLatteralOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RailingSystemHandrailsLatteralOffset {
    ForgeTypeId^ get ();
}
static member RailingSystemHandrailsLatteralOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RailingSystemHandrailsPositionParam Property

ParameterTypeIdRailingSystemHandrailsPositionParam Property

"Position"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RailingSystemHandrailsPositionParam { get; }
Public Shared ReadOnly Property RailingSystemHandrailsPositionParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RailingSystemHandrailsPositionParam {
    ForgeTypeId^ get ();
}
static member RailingSystemHandrailsPositionParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RailingSystemHandrailsTypesParam Property

ParameterTypeIdRailingSystemHandrailsTypesParam Property

"Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RailingSystemHandrailsTypesParam { get; }
Public Shared ReadOnly Property RailingSystemHandrailsTypesParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RailingSystemHandrailsTypesParam {
    ForgeTypeId^ get ();
}
static member RailingSystemHandrailsTypesParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RailingSystemHasTopRail Property

ParameterTypeIdRailingSystemHasTopRail Property

"Use Top Rail": Whether railing has top rail

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RailingSystemHasTopRail { get; }
Public Shared ReadOnly Property RailingSystemHasTopRail As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RailingSystemHasTopRail {
    ForgeTypeId^ get ();
}
static member RailingSystemHasTopRail : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RailingSystemSecondaryHandrailsHeightParam Property

ParameterTypeIdRailingSystemSecondaryHandrailsHeightParam Property

"Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RailingSystemSecondaryHandrailsHeightParam { get; }
Public Shared ReadOnly Property RailingSystemSecondaryHandrailsHeightParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RailingSystemSecondaryHandrailsHeightParam {
    ForgeTypeId^ get ();
}
static member RailingSystemSecondaryHandrailsHeightParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RailingSystemSecondaryHandrailsLatteralOffset Property

ParameterTypeIdRailingSystemSecondaryHandrailsLatteralOffset Property

"Lateral Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RailingSystemSecondaryHandrailsLatteralOffset { get; }
Public Shared ReadOnly Property RailingSystemSecondaryHandrailsLatteralOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RailingSystemSecondaryHandrailsLatteralOffset {
    ForgeTypeId^ get ();
}
static member RailingSystemSecondaryHandrailsLatteralOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RailingSystemSecondaryHandrailsPositionParam Property

ParameterTypeIdRailingSystemSecondaryHandrailsPositionParam Property

"Position"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RailingSystemSecondaryHandrailsPositionParam { get; }
Public Shared ReadOnly Property RailingSystemSecondaryHandrailsPositionParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RailingSystemSecondaryHandrailsPositionParam {
    ForgeTypeId^ get ();
}
static member RailingSystemSecondaryHandrailsPositionParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RailingSystemSecondaryHandrailsTypesParam Property

ParameterTypeIdRailingSystemSecondaryHandrailsTypesParam Property

"Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RailingSystemSecondaryHandrailsTypesParam { get; }
Public Shared ReadOnly Property RailingSystemSecondaryHandrailsTypesParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RailingSystemSecondaryHandrailsTypesParam {
    ForgeTypeId^ get ();
}
static member RailingSystemSecondaryHandrailsTypesParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RailingSystemTopRailHeightParam Property

ParameterTypeIdRailingSystemTopRailHeightParam Property

"Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RailingSystemTopRailHeightParam { get; }
Public Shared ReadOnly Property RailingSystemTopRailHeightParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RailingSystemTopRailHeightParam {
    ForgeTypeId^ get ();
}
static member RailingSystemTopRailHeightParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RailingSystemTopRailTypesParam Property

ParameterTypeIdRailingSystemTopRailTypesParam Property

"Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RailingSystemTopRailTypesParam { get; }
Public Shared ReadOnly Property RailingSystemTopRailTypesParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RailingSystemTopRailTypesParam {
    ForgeTypeId^ get ();
}
static member RailingSystemTopRailTypesParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RampAttrLeftBalusterAttachPt Property

ParameterTypeIdRampAttrLeftBalusterAttachPt Property

"Left Baluster Location"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RampAttrLeftBalusterAttachPt { get; }
Public Shared ReadOnly Property RampAttrLeftBalusterAttachPt As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RampAttrLeftBalusterAttachPt {
    ForgeTypeId^ get ();
}
static member RampAttrLeftBalusterAttachPt : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RampAttrMaterial Property

ParameterTypeIdRampAttrMaterial Property

"Ramp Material"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RampAttrMaterial { get; }
Public Shared ReadOnly Property RampAttrMaterial As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RampAttrMaterial {
    ForgeTypeId^ get ();
}
static member RampAttrMaterial : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RampAttrMinInvSlope Property

ParameterTypeIdRampAttrMinInvSlope Property

"Ramp Max Slope (1/x)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RampAttrMinInvSlope { get; }
Public Shared ReadOnly Property RampAttrMinInvSlope As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RampAttrMinInvSlope {
    ForgeTypeId^ get ();
}
static member RampAttrMinInvSlope : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RampAttrRightBalusterAttachPt Property

ParameterTypeIdRampAttrRightBalusterAttachPt Property

"Right Baluster Location"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RampAttrRightBalusterAttachPt { get; }
Public Shared ReadOnly Property RampAttrRightBalusterAttachPt As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RampAttrRightBalusterAttachPt {
    ForgeTypeId^ get ();
}
static member RampAttrRightBalusterAttachPt : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RampAttrShape Property

ParameterTypeIdRampAttrShape Property

"Shape"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RampAttrShape { get; }
Public Shared ReadOnly Property RampAttrShape As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RampAttrShape {
    ForgeTypeId^ get ();
}
static member RampAttrShape : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RampAttrTextFont Property

ParameterTypeIdRampAttrTextFont Property

"Text Font"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RampAttrTextFont { get; }
Public Shared ReadOnly Property RampAttrTextFont As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RampAttrTextFont {
    ForgeTypeId^ get ();
}
static member RampAttrTextFont : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RampAttrTextSize Property

ParameterTypeIdRampAttrTextSize Property

"Text Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RampAttrTextSize { get; }
Public Shared ReadOnly Property RampAttrTextSize As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RampAttrTextSize {
    ForgeTypeId^ get ();
}
static member RampAttrTextSize : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RampAttrThickness Property

ParameterTypeIdRampAttrThickness Property

"Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RampAttrThickness { get; }
Public Shared ReadOnly Property RampAttrThickness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RampAttrThickness {
    ForgeTypeId^ get ();
}
static member RampAttrThickness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RampMaxRunLength Property

ParameterTypeIdRampMaxRunLength Property

"Maximum Incline Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RampMaxRunLength { get; }
Public Shared ReadOnly Property RampMaxRunLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RampMaxRunLength {
    ForgeTypeId^ get ();
}
static member RampMaxRunLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RasterEnableSnaps Property

ParameterTypeIdRasterEnableSnaps Property

"Enable Snaps"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RasterEnableSnaps { get; }
Public Shared ReadOnly Property RasterEnableSnaps As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RasterEnableSnaps {
    ForgeTypeId^ get ();
}
static member RasterEnableSnaps : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RasterHorizontalScale Property

ParameterTypeIdRasterHorizontalScale Property

"Horizontal Scale"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RasterHorizontalScale { get; }
Public Shared ReadOnly Property RasterHorizontalScale As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RasterHorizontalScale {
    ForgeTypeId^ get ();
}
static member RasterHorizontalScale : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RasterLockProportions Property

ParameterTypeIdRasterLockProportions Property

"Lock Proportions"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RasterLockProportions { get; }
Public Shared ReadOnly Property RasterLockProportions As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RasterLockProportions {
    ForgeTypeId^ get ();
}
static member RasterLockProportions : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RasterSheetheight Property

ParameterTypeIdRasterSheetheight Property

"Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RasterSheetheight { get; }
Public Shared ReadOnly Property RasterSheetheight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RasterSheetheight {
    ForgeTypeId^ get ();
}
static member RasterSheetheight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RasterSheetwidth Property

ParameterTypeIdRasterSheetwidth Property

"Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RasterSheetwidth { get; }
Public Shared ReadOnly Property RasterSheetwidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RasterSheetwidth {
    ForgeTypeId^ get ();
}
static member RasterSheetwidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RasterSymbolFilename Property

ParameterTypeIdRasterSymbolFilename Property

"Loaded from file"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RasterSymbolFilename { get; }
Public Shared ReadOnly Property RasterSymbolFilename As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RasterSymbolFilename {
    ForgeTypeId^ get ();
}
static member RasterSymbolFilename : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RasterSymbolHeight Property

ParameterTypeIdRasterSymbolHeight Property

"Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RasterSymbolHeight { get; }
Public Shared ReadOnly Property RasterSymbolHeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RasterSymbolHeight {
    ForgeTypeId^ get ();
}
static member RasterSymbolHeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RasterSymbolLinkloadStatus Property

ParameterTypeIdRasterSymbolLinkloadStatus Property

"Link Status"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RasterSymbolLinkloadStatus { get; }
Public Shared ReadOnly Property RasterSymbolLinkloadStatus As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RasterSymbolLinkloadStatus {
    ForgeTypeId^ get ();
}
static member RasterSymbolLinkloadStatus : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RasterSymbolPagenumber Property

ParameterTypeIdRasterSymbolPagenumber Property

"Page Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RasterSymbolPagenumber { get; }
Public Shared ReadOnly Property RasterSymbolPagenumber As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RasterSymbolPagenumber {
    ForgeTypeId^ get ();
}
static member RasterSymbolPagenumber : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RasterSymbolPixelheight Property

ParameterTypeIdRasterSymbolPixelheight Property

"Height (pixels)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RasterSymbolPixelheight { get; }
Public Shared ReadOnly Property RasterSymbolPixelheight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RasterSymbolPixelheight {
    ForgeTypeId^ get ();
}
static member RasterSymbolPixelheight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RasterSymbolPixelwidth Property

ParameterTypeIdRasterSymbolPixelwidth Property

"Width (pixels)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RasterSymbolPixelwidth { get; }
Public Shared ReadOnly Property RasterSymbolPixelwidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RasterSymbolPixelwidth {
    ForgeTypeId^ get ();
}
static member RasterSymbolPixelwidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RasterSymbolResolution Property

ParameterTypeIdRasterSymbolResolution Property

"Resolution (dpi)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RasterSymbolResolution { get; }
Public Shared ReadOnly Property RasterSymbolResolution As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RasterSymbolResolution {
    ForgeTypeId^ get ();
}
static member RasterSymbolResolution : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RasterSymbolViewname Property

ParameterTypeIdRasterSymbolViewname Property

"View Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RasterSymbolViewname { get; }
Public Shared ReadOnly Property RasterSymbolViewname As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RasterSymbolViewname {
    ForgeTypeId^ get ();
}
static member RasterSymbolViewname : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RasterSymbolWidth Property

ParameterTypeIdRasterSymbolWidth Property

"Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RasterSymbolWidth { get; }
Public Shared ReadOnly Property RasterSymbolWidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RasterSymbolWidth {
    ForgeTypeId^ get ();
}
static member RasterSymbolWidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RasterVerticalScale Property

ParameterTypeIdRasterVerticalScale Property

"Vertical Scale"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RasterVerticalScale { get; }
Public Shared ReadOnly Property RasterVerticalScale As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RasterVerticalScale {
    ForgeTypeId^ get ();
}
static member RasterVerticalScale : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsAdditionalFlow Property

ParameterTypeIdRbsAdditionalFlow Property

"Additional Flow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsAdditionalFlow { get; }
Public Shared ReadOnly Property RbsAdditionalFlow As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsAdditionalFlow {
    ForgeTypeId^ get ();
}
static member RbsAdditionalFlow : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsAdjustableConnector Property

ParameterTypeIdRbsAdjustableConnector Property

"Allow Slope Adjustments"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsAdjustableConnector { get; }
Public Shared ReadOnly Property RbsAdjustableConnector As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsAdjustableConnector {
    ForgeTypeId^ get ();
}
static member RbsAdjustableConnector : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsAreaBasedLoadType Property

ParameterTypeIdRbsAreaBasedLoadType Property

"Area Based Load Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsAreaBasedLoadType { get; }
Public Shared ReadOnly Property RbsAreaBasedLoadType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsAreaBasedLoadType {
    ForgeTypeId^ get ();
}
static member RbsAreaBasedLoadType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsBuildingConstructionclass Property

ParameterTypeIdRbsBuildingConstructionclass Property

"Building Infiltration Class"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsBuildingConstructionclass { get; }
Public Shared ReadOnly Property RbsBuildingConstructionclass As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsBuildingConstructionclass {
    ForgeTypeId^ get ();
}
static member RbsBuildingConstructionclass : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsBuildingUseloadcredits Property

ParameterTypeIdRbsBuildingUseloadcredits Property

"Use Load Credits"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsBuildingUseloadcredits { get; }
Public Shared ReadOnly Property RbsBuildingUseloadcredits As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsBuildingUseloadcredits {
    ForgeTypeId^ get ();
}
static member RbsBuildingUseloadcredits : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsCabletrayBendradius Property

ParameterTypeIdRbsCabletrayBendradius Property

"Bend Radius"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsCabletrayBendradius { get; }
Public Shared ReadOnly Property RbsCabletrayBendradius As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsCabletrayBendradius {
    ForgeTypeId^ get ();
}
static member RbsCabletrayBendradius : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsCabletrayconduitBendorfitting Property

ParameterTypeIdRbsCabletrayconduitBendorfitting Property

"Bend or Fitting"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsCabletrayconduitBendorfitting { get; }
Public Shared ReadOnly Property RbsCabletrayconduitBendorfitting As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsCabletrayconduitBendorfitting {
    ForgeTypeId^ get ();
}
static member RbsCabletrayconduitBendorfitting : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsCabletrayconduitConnectorelemType Property

ParameterTypeIdRbsCabletrayconduitConnectorelemType Property

"Connector Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsCabletrayconduitConnectorelemType { get; }
Public Shared ReadOnly Property RbsCabletrayconduitConnectorelemType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsCabletrayconduitConnectorelemType {
    ForgeTypeId^ get ();
}
static member RbsCabletrayconduitConnectorelemType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsCabletrayconduitrunLengthParam Property

ParameterTypeIdRbsCabletrayconduitrunLengthParam Property

"Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsCabletrayconduitrunLengthParam { get; }
Public Shared ReadOnly Property RbsCabletrayconduitrunLengthParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsCabletrayconduitrunLengthParam {
    ForgeTypeId^ get ();
}
static member RbsCabletrayconduitrunLengthParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsCabletrayconduitSystemType Property

ParameterTypeIdRbsCabletrayconduitSystemType Property

"System Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsCabletrayconduitSystemType { get; }
Public Shared ReadOnly Property RbsCabletrayconduitSystemType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsCabletrayconduitSystemType {
    ForgeTypeId^ get ();
}
static member RbsCabletrayconduitSystemType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsCabletrayHeightParam Property

ParameterTypeIdRbsCabletrayHeightParam Property

"Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsCabletrayHeightParam { get; }
Public Shared ReadOnly Property RbsCabletrayHeightParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsCabletrayHeightParam {
    ForgeTypeId^ get ();
}
static member RbsCabletrayHeightParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsCabletrayRungheight Property

ParameterTypeIdRbsCabletrayRungheight Property

"Rung Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsCabletrayRungheight { get; }
Public Shared ReadOnly Property RbsCabletrayRungheight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsCabletrayRungheight {
    ForgeTypeId^ get ();
}
static member RbsCabletrayRungheight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsCabletrayRungspace Property

ParameterTypeIdRbsCabletrayRungspace Property

"Rung Space"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsCabletrayRungspace { get; }
Public Shared ReadOnly Property RbsCabletrayRungspace As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsCabletrayRungspace {
    ForgeTypeId^ get ();
}
static member RbsCabletrayRungspace : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsCabletrayRungwidth Property

ParameterTypeIdRbsCabletrayRungwidth Property

"Rung Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsCabletrayRungwidth { get; }
Public Shared ReadOnly Property RbsCabletrayRungwidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsCabletrayRungwidth {
    ForgeTypeId^ get ();
}
static member RbsCabletrayRungwidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsCabletrayrunHeightParam Property

ParameterTypeIdRbsCabletrayrunHeightParam Property

"Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsCabletrayrunHeightParam { get; }
Public Shared ReadOnly Property RbsCabletrayrunHeightParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsCabletrayrunHeightParam {
    ForgeTypeId^ get ();
}
static member RbsCabletrayrunHeightParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsCabletrayrunWidthParam Property

ParameterTypeIdRbsCabletrayrunWidthParam Property

"Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsCabletrayrunWidthParam { get; }
Public Shared ReadOnly Property RbsCabletrayrunWidthParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsCabletrayrunWidthParam {
    ForgeTypeId^ get ();
}
static member RbsCabletrayrunWidthParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsCabletrayShapetype Property

ParameterTypeIdRbsCabletrayShapetype Property

"Shape"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsCabletrayShapetype { get; }
Public Shared ReadOnly Property RbsCabletrayShapetype As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsCabletrayShapetype {
    ForgeTypeId^ get ();
}
static member RbsCabletrayShapetype : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsCabletrayThickness Property

ParameterTypeIdRbsCabletrayThickness Property

"Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsCabletrayThickness { get; }
Public Shared ReadOnly Property RbsCabletrayThickness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsCabletrayThickness {
    ForgeTypeId^ get ();
}
static member RbsCabletrayThickness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsCabletrayWidthParam Property

ParameterTypeIdRbsCabletrayWidthParam Property

"Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsCabletrayWidthParam { get; }
Public Shared ReadOnly Property RbsCabletrayWidthParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsCabletrayWidthParam {
    ForgeTypeId^ get ();
}
static member RbsCabletrayWidthParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsCalculatedSize Property

ParameterTypeIdRbsCalculatedSize Property

"Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsCalculatedSize { get; }
Public Shared ReadOnly Property RbsCalculatedSize As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsCalculatedSize {
    ForgeTypeId^ get ();
}
static member RbsCalculatedSize : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsComponentClassificationParam Property

ParameterTypeIdRbsComponentClassificationParam Property

"Component Classification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsComponentClassificationParam { get; }
Public Shared ReadOnly Property RbsComponentClassificationParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsComponentClassificationParam {
    ForgeTypeId^ get ();
}
static member RbsComponentClassificationParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsConduitBendradius Property

ParameterTypeIdRbsConduitBendradius Property

"Bend Radius"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsConduitBendradius { get; }
Public Shared ReadOnly Property RbsConduitBendradius As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsConduitBendradius {
    ForgeTypeId^ get ();
}
static member RbsConduitBendradius : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsConduitDiameterParam Property

ParameterTypeIdRbsConduitDiameterParam Property

"Diameter(Trade Size)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsConduitDiameterParam { get; }
Public Shared ReadOnly Property RbsConduitDiameterParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsConduitDiameterParam {
    ForgeTypeId^ get ();
}
static member RbsConduitDiameterParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsConduitInnerDiamParam Property

ParameterTypeIdRbsConduitInnerDiamParam Property

"Inside Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsConduitInnerDiamParam { get; }
Public Shared ReadOnly Property RbsConduitInnerDiamParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsConduitInnerDiamParam {
    ForgeTypeId^ get ();
}
static member RbsConduitInnerDiamParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsConduitOuterDiamParam Property

ParameterTypeIdRbsConduitOuterDiamParam Property

"Outside Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsConduitOuterDiamParam { get; }
Public Shared ReadOnly Property RbsConduitOuterDiamParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsConduitOuterDiamParam {
    ForgeTypeId^ get ();
}
static member RbsConduitOuterDiamParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsConduitrunDiameterParam Property

ParameterTypeIdRbsConduitrunDiameterParam Property

"Diameter(Trade Size)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsConduitrunDiameterParam { get; }
Public Shared ReadOnly Property RbsConduitrunDiameterParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsConduitrunDiameterParam {
    ForgeTypeId^ get ();
}
static member RbsConduitrunDiameterParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsConduitrunInnerDiamParam Property

ParameterTypeIdRbsConduitrunInnerDiamParam Property

"Inside Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsConduitrunInnerDiamParam { get; }
Public Shared ReadOnly Property RbsConduitrunInnerDiamParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsConduitrunInnerDiamParam {
    ForgeTypeId^ get ();
}
static member RbsConduitrunInnerDiamParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsConduitrunOuterDiamParam Property

ParameterTypeIdRbsConduitrunOuterDiamParam Property

"Outside Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsConduitrunOuterDiamParam { get; }
Public Shared ReadOnly Property RbsConduitrunOuterDiamParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsConduitrunOuterDiamParam {
    ForgeTypeId^ get ();
}
static member RbsConduitrunOuterDiamParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsConduitTradesize Property

ParameterTypeIdRbsConduitTradesize Property

"Conduit Size Lookup"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsConduitTradesize { get; }
Public Shared ReadOnly Property RbsConduitTradesize As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsConduitTradesize {
    ForgeTypeId^ get ();
}
static member RbsConduitTradesize : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsConnectorDescription Property

ParameterTypeIdRbsConnectorDescription Property

"Connector Description"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsConnectorDescription { get; }
Public Shared ReadOnly Property RbsConnectorDescription As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsConnectorDescription {
    ForgeTypeId^ get ();
}
static member RbsConnectorDescription : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsConnectorIsprimary Property

ParameterTypeIdRbsConnectorIsprimary Property

"Primary Connector"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsConnectorIsprimary { get; }
Public Shared ReadOnly Property RbsConnectorIsprimary As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsConnectorIsprimary {
    ForgeTypeId^ get ();
}
static member RbsConnectorIsprimary : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsConnectorOffsetObsolete Property

ParameterTypeIdRbsConnectorOffsetObsolete Property

"Connector Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsConnectorOffsetObsolete { get; }
Public Shared ReadOnly Property RbsConnectorOffsetObsolete As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsConnectorOffsetObsolete {
    ForgeTypeId^ get ();
}
static member RbsConnectorOffsetObsolete : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsConstructionSetParam Property

ParameterTypeIdRbsConstructionSetParam Property

"Schematic Types"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsConstructionSetParam { get; }
Public Shared ReadOnly Property RbsConstructionSetParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsConstructionSetParam {
    ForgeTypeId^ get ();
}
static member RbsConstructionSetParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsConstructionTypeShadingfactorParam Property

ParameterTypeIdRbsConstructionTypeShadingfactorParam Property

"Internal Shading Factor"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsConstructionTypeShadingfactorParam { get; }
Public Shared ReadOnly Property RbsConstructionTypeShadingfactorParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsConstructionTypeShadingfactorParam {
    ForgeTypeId^ get ();
}
static member RbsConstructionTypeShadingfactorParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsCtcBottomElevation Property

ParameterTypeIdRbsCtcBottomElevation Property

"Lower End Bottom Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsCtcBottomElevation { get; }
Public Shared ReadOnly Property RbsCtcBottomElevation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsCtcBottomElevation {
    ForgeTypeId^ get ();
}
static member RbsCtcBottomElevation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsCtcServiceType Property

ParameterTypeIdRbsCtcServiceType Property

"Service Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsCtcServiceType { get; }
Public Shared ReadOnly Property RbsCtcServiceType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsCtcServiceType {
    ForgeTypeId^ get ();
}
static member RbsCtcServiceType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsCtcTopElevation Property

ParameterTypeIdRbsCtcTopElevation Property

"Upper End Top Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsCtcTopElevation { get; }
Public Shared ReadOnly Property RbsCtcTopElevation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsCtcTopElevation {
    ForgeTypeId^ get ();
}
static member RbsCtcTopElevation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsCurveDiameterParam Property

ParameterTypeIdRbsCurveDiameterParam Property

"Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsCurveDiameterParam { get; }
Public Shared ReadOnly Property RbsCurveDiameterParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsCurveDiameterParam {
    ForgeTypeId^ get ();
}
static member RbsCurveDiameterParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsCurveHeightParam Property

ParameterTypeIdRbsCurveHeightParam Property

"Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsCurveHeightParam { get; }
Public Shared ReadOnly Property RbsCurveHeightParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsCurveHeightParam {
    ForgeTypeId^ get ();
}
static member RbsCurveHeightParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsCurveHorOffsetParam Property

ParameterTypeIdRbsCurveHorOffsetParam Property

"Horizontal Justification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsCurveHorOffsetParam { get; }
Public Shared ReadOnly Property RbsCurveHorOffsetParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsCurveHorOffsetParam {
    ForgeTypeId^ get ();
}
static member RbsCurveHorOffsetParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsCurveSlope Property

ParameterTypeIdRbsCurveSlope Property

"Slope Percentage (%)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsCurveSlope { get; }
Public Shared ReadOnly Property RbsCurveSlope As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsCurveSlope {
    ForgeTypeId^ get ();
}
static member RbsCurveSlope : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsCurveSurfaceArea Property

ParameterTypeIdRbsCurveSurfaceArea Property

"Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsCurveSurfaceArea { get; }
Public Shared ReadOnly Property RbsCurveSurfaceArea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsCurveSurfaceArea {
    ForgeTypeId^ get ();
}
static member RbsCurveSurfaceArea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsCurvetypeDefaultBendParam Property

ParameterTypeIdRbsCurvetypeDefaultBendParam Property

"Bend"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsCurvetypeDefaultBendParam { get; }
Public Shared ReadOnly Property RbsCurvetypeDefaultBendParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsCurvetypeDefaultBendParam {
    ForgeTypeId^ get ();
}
static member RbsCurvetypeDefaultBendParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsCurvetypeDefaultCapParam Property

ParameterTypeIdRbsCurvetypeDefaultCapParam Property

"Cap"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsCurvetypeDefaultCapParam { get; }
Public Shared ReadOnly Property RbsCurvetypeDefaultCapParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsCurvetypeDefaultCapParam {
    ForgeTypeId^ get ();
}
static member RbsCurvetypeDefaultCapParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsCurvetypeDefaultCrossParam Property

ParameterTypeIdRbsCurvetypeDefaultCrossParam Property

"Cross"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsCurvetypeDefaultCrossParam { get; }
Public Shared ReadOnly Property RbsCurvetypeDefaultCrossParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsCurvetypeDefaultCrossParam {
    ForgeTypeId^ get ();
}
static member RbsCurvetypeDefaultCrossParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsCurvetypeDefaultElbowdownParam Property

ParameterTypeIdRbsCurvetypeDefaultElbowdownParam Property

"Vertical Outside Bend"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsCurvetypeDefaultElbowdownParam { get; }
Public Shared ReadOnly Property RbsCurvetypeDefaultElbowdownParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsCurvetypeDefaultElbowdownParam {
    ForgeTypeId^ get ();
}
static member RbsCurvetypeDefaultElbowdownParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsCurvetypeDefaultElbowParam Property

ParameterTypeIdRbsCurvetypeDefaultElbowParam Property

"Elbow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsCurvetypeDefaultElbowParam { get; }
Public Shared ReadOnly Property RbsCurvetypeDefaultElbowParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsCurvetypeDefaultElbowParam {
    ForgeTypeId^ get ();
}
static member RbsCurvetypeDefaultElbowParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsCurvetypeDefaultElbowupParam Property

ParameterTypeIdRbsCurvetypeDefaultElbowupParam Property

"Vertical Inside Bend"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsCurvetypeDefaultElbowupParam { get; }
Public Shared ReadOnly Property RbsCurvetypeDefaultElbowupParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsCurvetypeDefaultElbowupParam {
    ForgeTypeId^ get ();
}
static member RbsCurvetypeDefaultElbowupParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsCurvetypeDefaultHorizontalBendParam Property

ParameterTypeIdRbsCurvetypeDefaultHorizontalBendParam Property

"Horizontal Bend"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsCurvetypeDefaultHorizontalBendParam { get; }
Public Shared ReadOnly Property RbsCurvetypeDefaultHorizontalBendParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsCurvetypeDefaultHorizontalBendParam {
    ForgeTypeId^ get ();
}
static member RbsCurvetypeDefaultHorizontalBendParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsCurvetypeDefaultMechjointParam Property

ParameterTypeIdRbsCurvetypeDefaultMechjointParam Property

"Flange"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsCurvetypeDefaultMechjointParam { get; }
Public Shared ReadOnly Property RbsCurvetypeDefaultMechjointParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsCurvetypeDefaultMechjointParam {
    ForgeTypeId^ get ();
}
static member RbsCurvetypeDefaultMechjointParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsCurvetypeDefaultTakeoffParam Property

ParameterTypeIdRbsCurvetypeDefaultTakeoffParam Property

"Tap"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsCurvetypeDefaultTakeoffParam { get; }
Public Shared ReadOnly Property RbsCurvetypeDefaultTakeoffParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsCurvetypeDefaultTakeoffParam {
    ForgeTypeId^ get ();
}
static member RbsCurvetypeDefaultTakeoffParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsCurvetypeDefaultTeedownParam Property

ParameterTypeIdRbsCurvetypeDefaultTeedownParam Property

"Tee Down"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsCurvetypeDefaultTeedownParam { get; }
Public Shared ReadOnly Property RbsCurvetypeDefaultTeedownParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsCurvetypeDefaultTeedownParam {
    ForgeTypeId^ get ();
}
static member RbsCurvetypeDefaultTeedownParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsCurvetypeDefaultTeeParam Property

ParameterTypeIdRbsCurvetypeDefaultTeeParam Property

"Tee"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsCurvetypeDefaultTeeParam { get; }
Public Shared ReadOnly Property RbsCurvetypeDefaultTeeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsCurvetypeDefaultTeeParam {
    ForgeTypeId^ get ();
}
static member RbsCurvetypeDefaultTeeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsCurvetypeDefaultTeeupParam Property

ParameterTypeIdRbsCurvetypeDefaultTeeupParam Property

"Tee Up"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsCurvetypeDefaultTeeupParam { get; }
Public Shared ReadOnly Property RbsCurvetypeDefaultTeeupParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsCurvetypeDefaultTeeupParam {
    ForgeTypeId^ get ();
}
static member RbsCurvetypeDefaultTeeupParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsCurvetypeDefaultTransitionParam Property

ParameterTypeIdRbsCurvetypeDefaultTransitionParam Property

"Transition"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsCurvetypeDefaultTransitionParam { get; }
Public Shared ReadOnly Property RbsCurvetypeDefaultTransitionParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsCurvetypeDefaultTransitionParam {
    ForgeTypeId^ get ();
}
static member RbsCurvetypeDefaultTransitionParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsCurvetypeDefaultUnionParam Property

ParameterTypeIdRbsCurvetypeDefaultUnionParam Property

"Union"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsCurvetypeDefaultUnionParam { get; }
Public Shared ReadOnly Property RbsCurvetypeDefaultUnionParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsCurvetypeDefaultUnionParam {
    ForgeTypeId^ get ();
}
static member RbsCurvetypeDefaultUnionParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsCurvetypeMaxHeightParam Property

ParameterTypeIdRbsCurvetypeMaxHeightParam Property

"Max Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsCurvetypeMaxHeightParam { get; }
Public Shared ReadOnly Property RbsCurvetypeMaxHeightParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsCurvetypeMaxHeightParam {
    ForgeTypeId^ get ();
}
static member RbsCurvetypeMaxHeightParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsCurvetypeMaxWidthParam Property

ParameterTypeIdRbsCurvetypeMaxWidthParam Property

"Max Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsCurvetypeMaxWidthParam { get; }
Public Shared ReadOnly Property RbsCurvetypeMaxWidthParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsCurvetypeMaxWidthParam {
    ForgeTypeId^ get ();
}
static member RbsCurvetypeMaxWidthParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsCurvetypeMultishapeTransitionOvalroundParam Property

ParameterTypeIdRbsCurvetypeMultishapeTransitionOvalroundParam Property

"Multi Shape Transition Oval to Round"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsCurvetypeMultishapeTransitionOvalroundParam { get; }
Public Shared ReadOnly Property RbsCurvetypeMultishapeTransitionOvalroundParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsCurvetypeMultishapeTransitionOvalroundParam {
    ForgeTypeId^ get ();
}
static member RbsCurvetypeMultishapeTransitionOvalroundParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsCurvetypeMultishapeTransitionParam Property

ParameterTypeIdRbsCurvetypeMultishapeTransitionParam Property

"Multi Shape Transition Rect to Round"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsCurvetypeMultishapeTransitionParam { get; }
Public Shared ReadOnly Property RbsCurvetypeMultishapeTransitionParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsCurvetypeMultishapeTransitionParam {
    ForgeTypeId^ get ();
}
static member RbsCurvetypeMultishapeTransitionParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsCurvetypeMultishapeTransitionRectovalParam Property

ParameterTypeIdRbsCurvetypeMultishapeTransitionRectovalParam Property

"Multi Shape Transition Rect to Oval"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsCurvetypeMultishapeTransitionRectovalParam { get; }
Public Shared ReadOnly Property RbsCurvetypeMultishapeTransitionRectovalParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsCurvetypeMultishapeTransitionRectovalParam {
    ForgeTypeId^ get ();
}
static member RbsCurvetypeMultishapeTransitionRectovalParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsCurvetypePreferredBranchParam Property

ParameterTypeIdRbsCurvetypePreferredBranchParam Property

"Preferred Junction Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsCurvetypePreferredBranchParam { get; }
Public Shared ReadOnly Property RbsCurvetypePreferredBranchParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsCurvetypePreferredBranchParam {
    ForgeTypeId^ get ();
}
static member RbsCurvetypePreferredBranchParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsCurveUtslope Property

ParameterTypeIdRbsCurveUtslope Property

"Slope"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsCurveUtslope { get; }
Public Shared ReadOnly Property RbsCurveUtslope As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsCurveUtslope {
    ForgeTypeId^ get ();
}
static member RbsCurveUtslope : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsCurveVertOffsetParam Property

ParameterTypeIdRbsCurveVertOffsetParam Property

"Vertical Justification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsCurveVertOffsetParam { get; }
Public Shared ReadOnly Property RbsCurveVertOffsetParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsCurveVertOffsetParam {
    ForgeTypeId^ get ();
}
static member RbsCurveVertOffsetParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsCurveWidthParam Property

ParameterTypeIdRbsCurveWidthParam Property

"Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsCurveWidthParam { get; }
Public Shared ReadOnly Property RbsCurveWidthParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsCurveWidthParam {
    ForgeTypeId^ get ();
}
static member RbsCurveWidthParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsDistributionsysConfigParam Property

ParameterTypeIdRbsDistributionsysConfigParam Property

"Configuration"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsDistributionsysConfigParam { get; }
Public Shared ReadOnly Property RbsDistributionsysConfigParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsDistributionsysConfigParam {
    ForgeTypeId^ get ();
}
static member RbsDistributionsysConfigParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsDistributionsysHlPhaseParam Property

ParameterTypeIdRbsDistributionsysHlPhaseParam Property

"High-leg Phase"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsDistributionsysHlPhaseParam { get; }
Public Shared ReadOnly Property RbsDistributionsysHlPhaseParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsDistributionsysHlPhaseParam {
    ForgeTypeId^ get ();
}
static member RbsDistributionsysHlPhaseParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsDistributionsysNumwiresParam Property

ParameterTypeIdRbsDistributionsysNumwiresParam Property

"Wires"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsDistributionsysNumwiresParam { get; }
Public Shared ReadOnly Property RbsDistributionsysNumwiresParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsDistributionsysNumwiresParam {
    ForgeTypeId^ get ();
}
static member RbsDistributionsysNumwiresParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsDistributionsysPhaseParam Property

ParameterTypeIdRbsDistributionsysPhaseParam Property

"Phase"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsDistributionsysPhaseParam { get; }
Public Shared ReadOnly Property RbsDistributionsysPhaseParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsDistributionsysPhaseParam {
    ForgeTypeId^ get ();
}
static member RbsDistributionsysPhaseParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsDistributionsysVlgParam Property

ParameterTypeIdRbsDistributionsysVlgParam Property

"Line to Ground Voltage"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsDistributionsysVlgParam { get; }
Public Shared ReadOnly Property RbsDistributionsysVlgParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsDistributionsysVlgParam {
    ForgeTypeId^ get ();
}
static member RbsDistributionsysVlgParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsDistributionsysVllParam Property

ParameterTypeIdRbsDistributionsysVllParam Property

"Line to Line Voltage"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsDistributionsysVllParam { get; }
Public Shared ReadOnly Property RbsDistributionsysVllParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsDistributionsysVllParam {
    ForgeTypeId^ get ();
}
static member RbsDistributionsysVllParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsDuctBottomElevation Property

ParameterTypeIdRbsDuctBottomElevation Property

"Lower End Bottom Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsDuctBottomElevation { get; }
Public Shared ReadOnly Property RbsDuctBottomElevation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsDuctBottomElevation {
    ForgeTypeId^ get ();
}
static member RbsDuctBottomElevation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsDuctCalculatedSize Property

ParameterTypeIdRbsDuctCalculatedSize Property

"Duct Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsDuctCalculatedSize { get; }
Public Shared ReadOnly Property RbsDuctCalculatedSize As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsDuctCalculatedSize {
    ForgeTypeId^ get ();
}
static member RbsDuctCalculatedSize : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsDuctConnectorSystemClassificationParam Property

ParameterTypeIdRbsDuctConnectorSystemClassificationParam Property

"System Classification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsDuctConnectorSystemClassificationParam { get; }
Public Shared ReadOnly Property RbsDuctConnectorSystemClassificationParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsDuctConnectorSystemClassificationParam {
    ForgeTypeId^ get ();
}
static member RbsDuctConnectorSystemClassificationParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsDuctFittingLossMethodParam Property

ParameterTypeIdRbsDuctFittingLossMethodParam Property

"Loss Method"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsDuctFittingLossMethodParam { get; }
Public Shared ReadOnly Property RbsDuctFittingLossMethodParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsDuctFittingLossMethodParam {
    ForgeTypeId^ get ();
}
static member RbsDuctFittingLossMethodParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsDuctFittingLossMethodServerParam Property

ParameterTypeIdRbsDuctFittingLossMethodServerParam Property

"Loss Method"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsDuctFittingLossMethodServerParam { get; }
Public Shared ReadOnly Property RbsDuctFittingLossMethodServerParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsDuctFittingLossMethodServerParam {
    ForgeTypeId^ get ();
}
static member RbsDuctFittingLossMethodServerParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsDuctFittingLossMethodSettings Property

ParameterTypeIdRbsDuctFittingLossMethodSettings Property

"Loss Method Settings"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsDuctFittingLossMethodSettings { get; }
Public Shared ReadOnly Property RbsDuctFittingLossMethodSettings As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsDuctFittingLossMethodSettings {
    ForgeTypeId^ get ();
}
static member RbsDuctFittingLossMethodSettings : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsDuctFittingLossTableParam Property

ParameterTypeIdRbsDuctFittingLossTableParam Property

"ASHRAE Table"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsDuctFittingLossTableParam { get; }
Public Shared ReadOnly Property RbsDuctFittingLossTableParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsDuctFittingLossTableParam {
    ForgeTypeId^ get ();
}
static member RbsDuctFittingLossTableParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsDuctFlowConfigurationParam Property

ParameterTypeIdRbsDuctFlowConfigurationParam Property

"Flow Configuration"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsDuctFlowConfigurationParam { get; }
Public Shared ReadOnly Property RbsDuctFlowConfigurationParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsDuctFlowConfigurationParam {
    ForgeTypeId^ get ();
}
static member RbsDuctFlowConfigurationParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsDuctFlowDirectionParam Property

ParameterTypeIdRbsDuctFlowDirectionParam Property

"Flow Direction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsDuctFlowDirectionParam { get; }
Public Shared ReadOnly Property RbsDuctFlowDirectionParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsDuctFlowDirectionParam {
    ForgeTypeId^ get ();
}
static member RbsDuctFlowDirectionParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsDuctFlowParam Property

ParameterTypeIdRbsDuctFlowParam Property

"Flow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsDuctFlowParam { get; }
Public Shared ReadOnly Property RbsDuctFlowParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsDuctFlowParam {
    ForgeTypeId^ get ();
}
static member RbsDuctFlowParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsDuctPipeSystemAbbreviationParam Property

ParameterTypeIdRbsDuctPipeSystemAbbreviationParam Property

"System Abbreviation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsDuctPipeSystemAbbreviationParam { get; }
Public Shared ReadOnly Property RbsDuctPipeSystemAbbreviationParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsDuctPipeSystemAbbreviationParam {
    ForgeTypeId^ get ();
}
static member RbsDuctPipeSystemAbbreviationParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsDuctPressureDrop Property

ParameterTypeIdRbsDuctPressureDrop Property

"Pressure Drop"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsDuctPressureDrop { get; }
Public Shared ReadOnly Property RbsDuctPressureDrop As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsDuctPressureDrop {
    ForgeTypeId^ get ();
}
static member RbsDuctPressureDrop : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsDuctRoutingPreferenceParam Property

ParameterTypeIdRbsDuctRoutingPreferenceParam Property

"Routing Preferences"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsDuctRoutingPreferenceParam { get; }
Public Shared ReadOnly Property RbsDuctRoutingPreferenceParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsDuctRoutingPreferenceParam {
    ForgeTypeId^ get ();
}
static member RbsDuctRoutingPreferenceParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsDuctSizeFormattedParam Property

ParameterTypeIdRbsDuctSizeFormattedParam Property

"Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsDuctSizeFormattedParam { get; }
Public Shared ReadOnly Property RbsDuctSizeFormattedParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsDuctSizeFormattedParam {
    ForgeTypeId^ get ();
}
static member RbsDuctSizeFormattedParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsDuctSlope Property

ParameterTypeIdRbsDuctSlope Property

"Slope"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsDuctSlope { get; }
Public Shared ReadOnly Property RbsDuctSlope As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsDuctSlope {
    ForgeTypeId^ get ();
}
static member RbsDuctSlope : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsDuctStaticPressure Property

ParameterTypeIdRbsDuctStaticPressure Property

"Static Pressure"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsDuctStaticPressure { get; }
Public Shared ReadOnly Property RbsDuctStaticPressure As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsDuctStaticPressure {
    ForgeTypeId^ get ();
}
static member RbsDuctStaticPressure : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsDuctSystemCalculationParam Property

ParameterTypeIdRbsDuctSystemCalculationParam Property

"Calculations"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsDuctSystemCalculationParam { get; }
Public Shared ReadOnly Property RbsDuctSystemCalculationParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsDuctSystemCalculationParam {
    ForgeTypeId^ get ();
}
static member RbsDuctSystemCalculationParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsDuctSystemTypeParam Property

ParameterTypeIdRbsDuctSystemTypeParam Property

"System Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsDuctSystemTypeParam { get; }
Public Shared ReadOnly Property RbsDuctSystemTypeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsDuctSystemTypeParam {
    ForgeTypeId^ get ();
}
static member RbsDuctSystemTypeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsDuctTopElevation Property

ParameterTypeIdRbsDuctTopElevation Property

"Upper End Top Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsDuctTopElevation { get; }
Public Shared ReadOnly Property RbsDuctTopElevation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsDuctTopElevation {
    ForgeTypeId^ get ();
}
static member RbsDuctTopElevation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsDuctTypeParam Property

ParameterTypeIdRbsDuctTypeParam Property

"Duct Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsDuctTypeParam { get; }
Public Shared ReadOnly Property RbsDuctTypeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsDuctTypeParam {
    ForgeTypeId^ get ();
}
static member RbsDuctTypeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecAmbientTemperature Property

ParameterTypeIdRbsElecAmbientTemperature Property

"Ambient Temperature"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecAmbientTemperature { get; }
Public Shared ReadOnly Property RbsElecAmbientTemperature As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecAmbientTemperature {
    ForgeTypeId^ get ();
}
static member RbsElecAmbientTemperature : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecAnalyticalArea Property

ParameterTypeIdRbsElecAnalyticalArea Property

"Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecAnalyticalArea { get; }
Public Shared ReadOnly Property RbsElecAnalyticalArea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecAnalyticalArea {
    ForgeTypeId^ get ();
}
static member RbsElecAnalyticalArea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecAnalyticalConnectedPhase Property

ParameterTypeIdRbsElecAnalyticalConnectedPhase Property

"Connected Phases"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecAnalyticalConnectedPhase { get; }
Public Shared ReadOnly Property RbsElecAnalyticalConnectedPhase As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecAnalyticalConnectedPhase {
    ForgeTypeId^ get ();
}
static member RbsElecAnalyticalConnectedPhase : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecAnalyticalDownstreamConnectedPhases Property

ParameterTypeIdRbsElecAnalyticalDownstreamConnectedPhases Property

"Downstream Connected Phases"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecAnalyticalDownstreamConnectedPhases { get; }
Public Shared ReadOnly Property RbsElecAnalyticalDownstreamConnectedPhases As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecAnalyticalDownstreamConnectedPhases {
    ForgeTypeId^ get ();
}
static member RbsElecAnalyticalDownstreamConnectedPhases : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecAnalyticalFeederLength Property

ParameterTypeIdRbsElecAnalyticalFeederLength Property

"Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecAnalyticalFeederLength { get; }
Public Shared ReadOnly Property RbsElecAnalyticalFeederLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecAnalyticalFeederLength {
    ForgeTypeId^ get ();
}
static member RbsElecAnalyticalFeederLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecAnalyticalHighLegPhase Property

ParameterTypeIdRbsElecAnalyticalHighLegPhase Property

"High-leg Phase"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecAnalyticalHighLegPhase { get; }
Public Shared ReadOnly Property RbsElecAnalyticalHighLegPhase As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecAnalyticalHighLegPhase {
    ForgeTypeId^ get ();
}
static member RbsElecAnalyticalHighLegPhase : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecAnalyticalLevelId Property

ParameterTypeIdRbsElecAnalyticalLevelId Property

"Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecAnalyticalLevelId { get; }
Public Shared ReadOnly Property RbsElecAnalyticalLevelId As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecAnalyticalLevelId {
    ForgeTypeId^ get ();
}
static member RbsElecAnalyticalLevelId : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecAnalyticalLoadDensity Property

ParameterTypeIdRbsElecAnalyticalLoadDensity Property

"Power Density"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecAnalyticalLoadDensity { get; }
Public Shared ReadOnly Property RbsElecAnalyticalLoadDensity As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecAnalyticalLoadDensity {
    ForgeTypeId^ get ();
}
static member RbsElecAnalyticalLoadDensity : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecAnalyticalLoadNameParam Property

ParameterTypeIdRbsElecAnalyticalLoadNameParam Property

"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecAnalyticalLoadNameParam { get; }
Public Shared ReadOnly Property RbsElecAnalyticalLoadNameParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecAnalyticalLoadNameParam {
    ForgeTypeId^ get ();
}
static member RbsElecAnalyticalLoadNameParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecAnalyticalLoadSetOnDuty Property

ParameterTypeIdRbsElecAnalyticalLoadSetOnDuty Property

"Quantity of Prime"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecAnalyticalLoadSetOnDuty { get; }
Public Shared ReadOnly Property RbsElecAnalyticalLoadSetOnDuty As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecAnalyticalLoadSetOnDuty {
    ForgeTypeId^ get ();
}
static member RbsElecAnalyticalLoadSetOnDuty : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecAnalyticalLoadSetOnStandby Property

ParameterTypeIdRbsElecAnalyticalLoadSetOnStandby Property

"Quantity on Standby"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecAnalyticalLoadSetOnStandby { get; }
Public Shared ReadOnly Property RbsElecAnalyticalLoadSetOnStandby As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecAnalyticalLoadSetOnStandby {
    ForgeTypeId^ get ();
}
static member RbsElecAnalyticalLoadSetOnStandby : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecAnalyticalLoadSetOnTotal Property

ParameterTypeIdRbsElecAnalyticalLoadSetOnTotal Property

"Total Quantity"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecAnalyticalLoadSetOnTotal { get; }
Public Shared ReadOnly Property RbsElecAnalyticalLoadSetOnTotal As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecAnalyticalLoadSetOnTotal {
    ForgeTypeId^ get ();
}
static member RbsElecAnalyticalLoadSetOnTotal : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecAnalyticalLoadsInSet Property

ParameterTypeIdRbsElecAnalyticalLoadsInSet Property

"Loads in Set"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecAnalyticalLoadsInSet { get; }
Public Shared ReadOnly Property RbsElecAnalyticalLoadsInSet As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecAnalyticalLoadsInSet {
    ForgeTypeId^ get ();
}
static member RbsElecAnalyticalLoadsInSet : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecAnalyticalLoadTypeParam Property

ParameterTypeIdRbsElecAnalyticalLoadTypeParam Property

"Load Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecAnalyticalLoadTypeParam { get; }
Public Shared ReadOnly Property RbsElecAnalyticalLoadTypeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecAnalyticalLoadTypeParam {
    ForgeTypeId^ get ();
}
static member RbsElecAnalyticalLoadTypeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecAnalyticalNumphases Property

ParameterTypeIdRbsElecAnalyticalNumphases Property

"Number of Phases"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecAnalyticalNumphases { get; }
Public Shared ReadOnly Property RbsElecAnalyticalNumphases As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecAnalyticalNumphases {
    ForgeTypeId^ get ();
}
static member RbsElecAnalyticalNumphases : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecAnalyticalSecondaryHighLegPhase Property

ParameterTypeIdRbsElecAnalyticalSecondaryHighLegPhase Property

"Secondary High-leg Phase"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecAnalyticalSecondaryHighLegPhase { get; }
Public Shared ReadOnly Property RbsElecAnalyticalSecondaryHighLegPhase As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecAnalyticalSecondaryHighLegPhase {
    ForgeTypeId^ get ();
}
static member RbsElecAnalyticalSecondaryHighLegPhase : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecAnalyticalTotalCoincidentLoad Property

ParameterTypeIdRbsElecAnalyticalTotalCoincidentLoad Property

"Total Coincident Loads"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecAnalyticalTotalCoincidentLoad { get; }
Public Shared ReadOnly Property RbsElecAnalyticalTotalCoincidentLoad As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecAnalyticalTotalCoincidentLoad {
    ForgeTypeId^ get ();
}
static member RbsElecAnalyticalTotalCoincidentLoad : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecApparentCurrentParam Property

ParameterTypeIdRbsElecApparentCurrentParam Property

"Apparent Current"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecApparentCurrentParam { get; }
Public Shared ReadOnly Property RbsElecApparentCurrentParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecApparentCurrentParam {
    ForgeTypeId^ get ();
}
static member RbsElecApparentCurrentParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecApparentCurrentPhaseaParam Property

ParameterTypeIdRbsElecApparentCurrentPhaseaParam Property

"Apparent Current Phase A"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecApparentCurrentPhaseaParam { get; }
Public Shared ReadOnly Property RbsElecApparentCurrentPhaseaParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecApparentCurrentPhaseaParam {
    ForgeTypeId^ get ();
}
static member RbsElecApparentCurrentPhaseaParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecApparentCurrentPhasebParam Property

ParameterTypeIdRbsElecApparentCurrentPhasebParam Property

"Apparent Current Phase B"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecApparentCurrentPhasebParam { get; }
Public Shared ReadOnly Property RbsElecApparentCurrentPhasebParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecApparentCurrentPhasebParam {
    ForgeTypeId^ get ();
}
static member RbsElecApparentCurrentPhasebParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecApparentCurrentPhasecParam Property

ParameterTypeIdRbsElecApparentCurrentPhasecParam Property

"Apparent Current Phase C"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecApparentCurrentPhasecParam { get; }
Public Shared ReadOnly Property RbsElecApparentCurrentPhasecParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecApparentCurrentPhasecParam {
    ForgeTypeId^ get ();
}
static member RbsElecApparentCurrentPhasecParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecApparentLoad Property

ParameterTypeIdRbsElecApparentLoad Property

"Apparent Power"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecApparentLoad { get; }
Public Shared ReadOnly Property RbsElecApparentLoad As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecApparentLoad {
    ForgeTypeId^ get ();
}
static member RbsElecApparentLoad : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecApparentLoadPhase1 Property

ParameterTypeIdRbsElecApparentLoadPhase1 Property

"Apparent Power Phase 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecApparentLoadPhase1 { get; }
Public Shared ReadOnly Property RbsElecApparentLoadPhase1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecApparentLoadPhase1 {
    ForgeTypeId^ get ();
}
static member RbsElecApparentLoadPhase1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecApparentLoadPhase2 Property

ParameterTypeIdRbsElecApparentLoadPhase2 Property

"Apparent Power Phase 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecApparentLoadPhase2 { get; }
Public Shared ReadOnly Property RbsElecApparentLoadPhase2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecApparentLoadPhase2 {
    ForgeTypeId^ get ();
}
static member RbsElecApparentLoadPhase2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecApparentLoadPhase3 Property

ParameterTypeIdRbsElecApparentLoadPhase3 Property

"Apparent Power Phase 3"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecApparentLoadPhase3 { get; }
Public Shared ReadOnly Property RbsElecApparentLoadPhase3 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecApparentLoadPhase3 {
    ForgeTypeId^ get ();
}
static member RbsElecApparentLoadPhase3 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecApparentLoadPhasea Property

ParameterTypeIdRbsElecApparentLoadPhasea Property

"Apparent Power Phase A"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecApparentLoadPhasea { get; }
Public Shared ReadOnly Property RbsElecApparentLoadPhasea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecApparentLoadPhasea {
    ForgeTypeId^ get ();
}
static member RbsElecApparentLoadPhasea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecApparentLoadPhaseb Property

ParameterTypeIdRbsElecApparentLoadPhaseb Property

"Apparent Power Phase B"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecApparentLoadPhaseb { get; }
Public Shared ReadOnly Property RbsElecApparentLoadPhaseb As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecApparentLoadPhaseb {
    ForgeTypeId^ get ();
}
static member RbsElecApparentLoadPhaseb : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecApparentLoadPhasec Property

ParameterTypeIdRbsElecApparentLoadPhasec Property

"Apparent Power Phase C"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecApparentLoadPhasec { get; }
Public Shared ReadOnly Property RbsElecApparentLoadPhasec As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecApparentLoadPhasec {
    ForgeTypeId^ get ();
}
static member RbsElecApparentLoadPhasec : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecApparentPowerDensity Property

ParameterTypeIdRbsElecApparentPowerDensity Property

"Apparent Power Density"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecApparentPowerDensity { get; }
Public Shared ReadOnly Property RbsElecApparentPowerDensity As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecApparentPowerDensity {
    ForgeTypeId^ get ();
}
static member RbsElecApparentPowerDensity : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecBalancedLoad Property

ParameterTypeIdRbsElecBalancedLoad Property

"Balanced Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecBalancedLoad { get; }
Public Shared ReadOnly Property RbsElecBalancedLoad As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecBalancedLoad {
    ForgeTypeId^ get ();
}
static member RbsElecBalancedLoad : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecCalcCoefficientUtilization Property

ParameterTypeIdRbsElecCalcCoefficientUtilization Property

"Calculate Coefficient of Utilization"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecCalcCoefficientUtilization { get; }
Public Shared ReadOnly Property RbsElecCalcCoefficientUtilization As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecCalcCoefficientUtilization {
    ForgeTypeId^ get ();
}
static member RbsElecCalcCoefficientUtilization : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecCircuitConnectionTypeParam Property

ParameterTypeIdRbsElecCircuitConnectionTypeParam Property

"Connection Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecCircuitConnectionTypeParam { get; }
Public Shared ReadOnly Property RbsElecCircuitConnectionTypeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecCircuitConnectionTypeParam {
    ForgeTypeId^ get ();
}
static member RbsElecCircuitConnectionTypeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecCircuitFrameParam Property

ParameterTypeIdRbsElecCircuitFrameParam Property

"Frame"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecCircuitFrameParam { get; }
Public Shared ReadOnly Property RbsElecCircuitFrameParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecCircuitFrameParam {
    ForgeTypeId^ get ();
}
static member RbsElecCircuitFrameParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecCircuitLengthParam Property

ParameterTypeIdRbsElecCircuitLengthParam Property

"Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecCircuitLengthParam { get; }
Public Shared ReadOnly Property RbsElecCircuitLengthParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecCircuitLengthParam {
    ForgeTypeId^ get ();
}
static member RbsElecCircuitLengthParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecCircuitName Property

ParameterTypeIdRbsElecCircuitName Property

"Load Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecCircuitName { get; }
Public Shared ReadOnly Property RbsElecCircuitName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecCircuitName {
    ForgeTypeId^ get ();
}
static member RbsElecCircuitName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecCircuitNaming Property

ParameterTypeIdRbsElecCircuitNaming Property

"Circuit Naming"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecCircuitNaming { get; }
Public Shared ReadOnly Property RbsElecCircuitNaming As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecCircuitNaming {
    ForgeTypeId^ get ();
}
static member RbsElecCircuitNaming : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecCircuitNamingIndex Property

ParameterTypeIdRbsElecCircuitNamingIndex Property

"Circuit Naming Index"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecCircuitNamingIndex { get; }
Public Shared ReadOnly Property RbsElecCircuitNamingIndex As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecCircuitNamingIndex {
    ForgeTypeId^ get ();
}
static member RbsElecCircuitNamingIndex : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecCircuitNotesParam Property

ParameterTypeIdRbsElecCircuitNotesParam Property

"Schedule Circuit Notes"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecCircuitNotesParam { get; }
Public Shared ReadOnly Property RbsElecCircuitNotesParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecCircuitNotesParam {
    ForgeTypeId^ get ();
}
static member RbsElecCircuitNotesParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecCircuitNumber Property

ParameterTypeIdRbsElecCircuitNumber Property

"Circuit Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecCircuitNumber { get; }
Public Shared ReadOnly Property RbsElecCircuitNumber As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecCircuitNumber {
    ForgeTypeId^ get ();
}
static member RbsElecCircuitNumber : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecCircuitNumberingType Property

ParameterTypeIdRbsElecCircuitNumberingType Property

"Circuit Numbering Option"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecCircuitNumberingType { get; }
Public Shared ReadOnly Property RbsElecCircuitNumberingType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecCircuitNumberingType {
    ForgeTypeId^ get ();
}
static member RbsElecCircuitNumberingType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecCircuitNumberOfElementsParam Property

ParameterTypeIdRbsElecCircuitNumberOfElementsParam Property

"Number of Elements"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecCircuitNumberOfElementsParam { get; }
Public Shared ReadOnly Property RbsElecCircuitNumberOfElementsParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecCircuitNumberOfElementsParam {
    ForgeTypeId^ get ();
}
static member RbsElecCircuitNumberOfElementsParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecCircuitPanelParam Property

ParameterTypeIdRbsElecCircuitPanelParam Property

"Panel"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecCircuitPanelParam { get; }
Public Shared ReadOnly Property RbsElecCircuitPanelParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecCircuitPanelParam {
    ForgeTypeId^ get ();
}
static member RbsElecCircuitPanelParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecCircuitPathModeParam Property

ParameterTypeIdRbsElecCircuitPathModeParam Property

"Path Mode"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecCircuitPathModeParam { get; }
Public Shared ReadOnly Property RbsElecCircuitPathModeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecCircuitPathModeParam {
    ForgeTypeId^ get ();
}
static member RbsElecCircuitPathModeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecCircuitPathOffsetParam Property

ParameterTypeIdRbsElecCircuitPathOffsetParam Property

"Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecCircuitPathOffsetParam { get; }
Public Shared ReadOnly Property RbsElecCircuitPathOffsetParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecCircuitPathOffsetParam {
    ForgeTypeId^ get ();
}
static member RbsElecCircuitPathOffsetParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecCircuitPrefix Property

ParameterTypeIdRbsElecCircuitPrefix Property

"Circuit Prefix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecCircuitPrefix { get; }
Public Shared ReadOnly Property RbsElecCircuitPrefix As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecCircuitPrefix {
    ForgeTypeId^ get ();
}
static member RbsElecCircuitPrefix : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecCircuitPrefixSeparator Property

ParameterTypeIdRbsElecCircuitPrefixSeparator Property

"Circuit Prefix Separator"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecCircuitPrefixSeparator { get; }
Public Shared ReadOnly Property RbsElecCircuitPrefixSeparator As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecCircuitPrefixSeparator {
    ForgeTypeId^ get ();
}
static member RbsElecCircuitPrefixSeparator : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecCircuitRatingParam Property

ParameterTypeIdRbsElecCircuitRatingParam Property

"Rating"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecCircuitRatingParam { get; }
Public Shared ReadOnly Property RbsElecCircuitRatingParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecCircuitRatingParam {
    ForgeTypeId^ get ();
}
static member RbsElecCircuitRatingParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecCircuitSlotIndex Property

ParameterTypeIdRbsElecCircuitSlotIndex Property

"Slot Index"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecCircuitSlotIndex { get; }
Public Shared ReadOnly Property RbsElecCircuitSlotIndex As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecCircuitSlotIndex {
    ForgeTypeId^ get ();
}
static member RbsElecCircuitSlotIndex : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecCircuitStartSlot Property

ParameterTypeIdRbsElecCircuitStartSlot Property

"Start Slot"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecCircuitStartSlot { get; }
Public Shared ReadOnly Property RbsElecCircuitStartSlot As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecCircuitStartSlot {
    ForgeTypeId^ get ();
}
static member RbsElecCircuitStartSlot : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecCircuitType Property

ParameterTypeIdRbsElecCircuitType Property

"System Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecCircuitType { get; }
Public Shared ReadOnly Property RbsElecCircuitType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecCircuitType {
    ForgeTypeId^ get ();
}
static member RbsElecCircuitType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecCircuitWireNumGroundsParam Property

ParameterTypeIdRbsElecCircuitWireNumGroundsParam Property

"# of Ground Conductors"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecCircuitWireNumGroundsParam { get; }
Public Shared ReadOnly Property RbsElecCircuitWireNumGroundsParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecCircuitWireNumGroundsParam {
    ForgeTypeId^ get ();
}
static member RbsElecCircuitWireNumGroundsParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecCircuitWireNumHotsParam Property

ParameterTypeIdRbsElecCircuitWireNumHotsParam Property

"# of Hot Conductors"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecCircuitWireNumHotsParam { get; }
Public Shared ReadOnly Property RbsElecCircuitWireNumHotsParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecCircuitWireNumHotsParam {
    ForgeTypeId^ get ();
}
static member RbsElecCircuitWireNumHotsParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecCircuitWireNumNeutralsParam Property

ParameterTypeIdRbsElecCircuitWireNumNeutralsParam Property

"# of Neutral Conductors"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecCircuitWireNumNeutralsParam { get; }
Public Shared ReadOnly Property RbsElecCircuitWireNumNeutralsParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecCircuitWireNumNeutralsParam {
    ForgeTypeId^ get ();
}
static member RbsElecCircuitWireNumNeutralsParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecCircuitWireNumRunsParam Property

ParameterTypeIdRbsElecCircuitWireNumRunsParam Property

"# of Runs"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecCircuitWireNumRunsParam { get; }
Public Shared ReadOnly Property RbsElecCircuitWireNumRunsParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecCircuitWireNumRunsParam {
    ForgeTypeId^ get ();
}
static member RbsElecCircuitWireNumRunsParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecCircuitWireSizeParam Property

ParameterTypeIdRbsElecCircuitWireSizeParam Property

"Wire Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecCircuitWireSizeParam { get; }
Public Shared ReadOnly Property RbsElecCircuitWireSizeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecCircuitWireSizeParam {
    ForgeTypeId^ get ();
}
static member RbsElecCircuitWireSizeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecCircuitWireTypeParam Property

ParameterTypeIdRbsElecCircuitWireTypeParam Property

"Wire Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecCircuitWireTypeParam { get; }
Public Shared ReadOnly Property RbsElecCircuitWireTypeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecCircuitWireTypeParam {
    ForgeTypeId^ get ();
}
static member RbsElecCircuitWireTypeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecDemandCurrentPhasea Property

ParameterTypeIdRbsElecDemandCurrentPhasea Property

"Demand Current Phase A"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecDemandCurrentPhasea { get; }
Public Shared ReadOnly Property RbsElecDemandCurrentPhasea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecDemandCurrentPhasea {
    ForgeTypeId^ get ();
}
static member RbsElecDemandCurrentPhasea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecDemandCurrentPhaseb Property

ParameterTypeIdRbsElecDemandCurrentPhaseb Property

"Demand Current Phase B"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecDemandCurrentPhaseb { get; }
Public Shared ReadOnly Property RbsElecDemandCurrentPhaseb As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecDemandCurrentPhaseb {
    ForgeTypeId^ get ();
}
static member RbsElecDemandCurrentPhaseb : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecDemandCurrentPhasec Property

ParameterTypeIdRbsElecDemandCurrentPhasec Property

"Demand Current Phase C"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecDemandCurrentPhasec { get; }
Public Shared ReadOnly Property RbsElecDemandCurrentPhasec As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecDemandCurrentPhasec {
    ForgeTypeId^ get ();
}
static member RbsElecDemandCurrentPhasec : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecDemandfactorDemandloadParam Property

ParameterTypeIdRbsElecDemandfactorDemandloadParam Property

"Demand Apparent Power"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecDemandfactorDemandloadParam { get; }
Public Shared ReadOnly Property RbsElecDemandfactorDemandloadParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecDemandfactorDemandloadParam {
    ForgeTypeId^ get ();
}
static member RbsElecDemandfactorDemandloadParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecDemandfactorLoadclassificationParam Property

ParameterTypeIdRbsElecDemandfactorLoadclassificationParam Property

"Load Classification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecDemandfactorLoadclassificationParam { get; }
Public Shared ReadOnly Property RbsElecDemandfactorLoadclassificationParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecDemandfactorLoadclassificationParam {
    ForgeTypeId^ get ();
}
static member RbsElecDemandfactorLoadclassificationParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecDemandfactorLoadParam Property

ParameterTypeIdRbsElecDemandfactorLoadParam Property

"Connected Apparent Power"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecDemandfactorLoadParam { get; }
Public Shared ReadOnly Property RbsElecDemandfactorLoadParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecDemandfactorLoadParam {
    ForgeTypeId^ get ();
}
static member RbsElecDemandfactorLoadParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecDemandLoadPhasea Property

ParameterTypeIdRbsElecDemandLoadPhasea Property

"Demand Apparent Power Phase A"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecDemandLoadPhasea { get; }
Public Shared ReadOnly Property RbsElecDemandLoadPhasea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecDemandLoadPhasea {
    ForgeTypeId^ get ();
}
static member RbsElecDemandLoadPhasea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecDemandLoadPhaseb Property

ParameterTypeIdRbsElecDemandLoadPhaseb Property

"Demand Apparent Power Phase B"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecDemandLoadPhaseb { get; }
Public Shared ReadOnly Property RbsElecDemandLoadPhaseb As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecDemandLoadPhaseb {
    ForgeTypeId^ get ();
}
static member RbsElecDemandLoadPhaseb : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecDemandLoadPhasec Property

ParameterTypeIdRbsElecDemandLoadPhasec Property

"Demand Apparent Power Phase C"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecDemandLoadPhasec { get; }
Public Shared ReadOnly Property RbsElecDemandLoadPhasec As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecDemandLoadPhasec {
    ForgeTypeId^ get ();
}
static member RbsElecDemandLoadPhasec : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecDistributionNodeLoadSet Property

ParameterTypeIdRbsElecDistributionNodeLoadSet Property

"Load Set"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecDistributionNodeLoadSet { get; }
Public Shared ReadOnly Property RbsElecDistributionNodeLoadSet As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecDistributionNodeLoadSet {
    ForgeTypeId^ get ();
}
static member RbsElecDistributionNodeLoadSet : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecDistributionNodeSupplyFrom Property

ParameterTypeIdRbsElecDistributionNodeSupplyFrom Property

"Supply From"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecDistributionNodeSupplyFrom { get; }
Public Shared ReadOnly Property RbsElecDistributionNodeSupplyFrom As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecDistributionNodeSupplyFrom {
    ForgeTypeId^ get ();
}
static member RbsElecDistributionNodeSupplyFrom : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecDistributionNodeSupplyFrom1 Property

ParameterTypeIdRbsElecDistributionNodeSupplyFrom1 Property

"Supply From 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecDistributionNodeSupplyFrom1 { get; }
Public Shared ReadOnly Property RbsElecDistributionNodeSupplyFrom1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecDistributionNodeSupplyFrom1 {
    ForgeTypeId^ get ();
}
static member RbsElecDistributionNodeSupplyFrom1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecDistributionNodeSupplyFrom2 Property

ParameterTypeIdRbsElecDistributionNodeSupplyFrom2 Property

"Supply From 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecDistributionNodeSupplyFrom2 { get; }
Public Shared ReadOnly Property RbsElecDistributionNodeSupplyFrom2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecDistributionNodeSupplyFrom2 {
    ForgeTypeId^ get ();
}
static member RbsElecDistributionNodeSupplyFrom2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecDistributionNodeSupplyTo Property

ParameterTypeIdRbsElecDistributionNodeSupplyTo Property

"Supply To"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecDistributionNodeSupplyTo { get; }
Public Shared ReadOnly Property RbsElecDistributionNodeSupplyTo As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecDistributionNodeSupplyTo {
    ForgeTypeId^ get ();
}
static member RbsElecDistributionNodeSupplyTo : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecEditCircuitNamingSettingsParam Property

ParameterTypeIdRbsElecEditCircuitNamingSettingsParam Property

"Circuit Naming Settings"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecEditCircuitNamingSettingsParam { get; }
Public Shared ReadOnly Property RbsElecEditCircuitNamingSettingsParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecEditCircuitNamingSettingsParam {
    ForgeTypeId^ get ();
}
static member RbsElecEditCircuitNamingSettingsParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecEnclosure Property

ParameterTypeIdRbsElecEnclosure Property

"Enclosure"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecEnclosure { get; }
Public Shared ReadOnly Property RbsElecEnclosure As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecEnclosure {
    ForgeTypeId^ get ();
}
static member RbsElecEnclosure : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecLoadClassification Property

ParameterTypeIdRbsElecLoadClassification Property

"Load Classification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecLoadClassification { get; }
Public Shared ReadOnly Property RbsElecLoadClassification As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecLoadClassification {
    ForgeTypeId^ get ();
}
static member RbsElecLoadClassification : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecLoadsummaryConnectedCurrentParam Property

ParameterTypeIdRbsElecLoadsummaryConnectedCurrentParam Property

"Connected Current"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecLoadsummaryConnectedCurrentParam { get; }
Public Shared ReadOnly Property RbsElecLoadsummaryConnectedCurrentParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecLoadsummaryConnectedCurrentParam {
    ForgeTypeId^ get ();
}
static member RbsElecLoadsummaryConnectedCurrentParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecLoadsummaryConnectedLoadParam Property

ParameterTypeIdRbsElecLoadsummaryConnectedLoadParam Property

"Connected Apparent Power"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecLoadsummaryConnectedLoadParam { get; }
Public Shared ReadOnly Property RbsElecLoadsummaryConnectedLoadParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecLoadsummaryConnectedLoadParam {
    ForgeTypeId^ get ();
}
static member RbsElecLoadsummaryConnectedLoadParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecLoadsummaryDemandCurrentParam Property

ParameterTypeIdRbsElecLoadsummaryDemandCurrentParam Property

"Estimated Demand Current"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecLoadsummaryDemandCurrentParam { get; }
Public Shared ReadOnly Property RbsElecLoadsummaryDemandCurrentParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecLoadsummaryDemandCurrentParam {
    ForgeTypeId^ get ();
}
static member RbsElecLoadsummaryDemandCurrentParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecLoadsummaryDemandFactorParam Property

ParameterTypeIdRbsElecLoadsummaryDemandFactorParam Property

"Demand Factor"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecLoadsummaryDemandFactorParam { get; }
Public Shared ReadOnly Property RbsElecLoadsummaryDemandFactorParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecLoadsummaryDemandFactorParam {
    ForgeTypeId^ get ();
}
static member RbsElecLoadsummaryDemandFactorParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecLoadsummaryDemandFactorRuleParam Property

ParameterTypeIdRbsElecLoadsummaryDemandFactorRuleParam Property

"Description"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecLoadsummaryDemandFactorRuleParam { get; }
Public Shared ReadOnly Property RbsElecLoadsummaryDemandFactorRuleParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecLoadsummaryDemandFactorRuleParam {
    ForgeTypeId^ get ();
}
static member RbsElecLoadsummaryDemandFactorRuleParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecLoadsummaryDemandLoadParam Property

ParameterTypeIdRbsElecLoadsummaryDemandLoadParam Property

"Demand Apparent Power"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecLoadsummaryDemandLoadParam { get; }
Public Shared ReadOnly Property RbsElecLoadsummaryDemandLoadParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecLoadsummaryDemandLoadParam {
    ForgeTypeId^ get ();
}
static member RbsElecLoadsummaryDemandLoadParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecLoadsummaryLoadclassificationParam Property

ParameterTypeIdRbsElecLoadsummaryLoadclassificationParam Property

"Load Classification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecLoadsummaryLoadclassificationParam { get; }
Public Shared ReadOnly Property RbsElecLoadsummaryLoadclassificationParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecLoadsummaryLoadclassificationParam {
    ForgeTypeId^ get ();
}
static member RbsElecLoadsummaryLoadclassificationParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecMains Property

ParameterTypeIdRbsElecMains Property

"Mains"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecMains { get; }
Public Shared ReadOnly Property RbsElecMains As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecMains {
    ForgeTypeId^ get ();
}
static member RbsElecMains : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecMaxCircuitsDataPanel Property

ParameterTypeIdRbsElecMaxCircuitsDataPanel Property

"Maximum Amount of Circuits"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecMaxCircuitsDataPanel { get; }
Public Shared ReadOnly Property RbsElecMaxCircuitsDataPanel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecMaxCircuitsDataPanel {
    ForgeTypeId^ get ();
}
static member RbsElecMaxCircuitsDataPanel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecMaxPoleBreakers Property

ParameterTypeIdRbsElecMaxPoleBreakers Property

"Max Number of Single Pole Breakers"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecMaxPoleBreakers { get; }
Public Shared ReadOnly Property RbsElecMaxPoleBreakers As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecMaxPoleBreakers {
    ForgeTypeId^ get ();
}
static member RbsElecMaxPoleBreakers : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecModifications Property

ParameterTypeIdRbsElecModifications Property

"Modifications"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecModifications { get; }
Public Shared ReadOnly Property RbsElecModifications As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecModifications {
    ForgeTypeId^ get ();
}
static member RbsElecModifications : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecMounting Property

ParameterTypeIdRbsElecMounting Property

"Mounting"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecMounting { get; }
Public Shared ReadOnly Property RbsElecMounting As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecMounting {
    ForgeTypeId^ get ();
}
static member RbsElecMounting : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecNumberOfCircuits Property

ParameterTypeIdRbsElecNumberOfCircuits Property

"Max Number of Circuits"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecNumberOfCircuits { get; }
Public Shared ReadOnly Property RbsElecNumberOfCircuits As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecNumberOfCircuits {
    ForgeTypeId^ get ();
}
static member RbsElecNumberOfCircuits : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecNumberOfPoles Property

ParameterTypeIdRbsElecNumberOfPoles Property

"Number of Poles"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecNumberOfPoles { get; }
Public Shared ReadOnly Property RbsElecNumberOfPoles As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecNumberOfPoles {
    ForgeTypeId^ get ();
}
static member RbsElecNumberOfPoles : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecPanelBranchCircuitApparentLoadPhasea Property

ParameterTypeIdRbsElecPanelBranchCircuitApparentLoadPhasea Property

"Branch Circuit Apparent Power Phase A"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecPanelBranchCircuitApparentLoadPhasea { get; }
Public Shared ReadOnly Property RbsElecPanelBranchCircuitApparentLoadPhasea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecPanelBranchCircuitApparentLoadPhasea {
    ForgeTypeId^ get ();
}
static member RbsElecPanelBranchCircuitApparentLoadPhasea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecPanelBranchCircuitApparentLoadPhaseb Property

ParameterTypeIdRbsElecPanelBranchCircuitApparentLoadPhaseb Property

"Branch Circuit Apparent Power Phase B"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecPanelBranchCircuitApparentLoadPhaseb { get; }
Public Shared ReadOnly Property RbsElecPanelBranchCircuitApparentLoadPhaseb As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecPanelBranchCircuitApparentLoadPhaseb {
    ForgeTypeId^ get ();
}
static member RbsElecPanelBranchCircuitApparentLoadPhaseb : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecPanelBranchCircuitApparentLoadPhasec Property

ParameterTypeIdRbsElecPanelBranchCircuitApparentLoadPhasec Property

"Branch Circuit Apparent Power Phase C"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecPanelBranchCircuitApparentLoadPhasec { get; }
Public Shared ReadOnly Property RbsElecPanelBranchCircuitApparentLoadPhasec As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecPanelBranchCircuitApparentLoadPhasec {
    ForgeTypeId^ get ();
}
static member RbsElecPanelBranchCircuitApparentLoadPhasec : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecPanelBranchCircuitCurrentPhasea Property

ParameterTypeIdRbsElecPanelBranchCircuitCurrentPhasea Property

"Branch Circuit Current Phase A"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecPanelBranchCircuitCurrentPhasea { get; }
Public Shared ReadOnly Property RbsElecPanelBranchCircuitCurrentPhasea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecPanelBranchCircuitCurrentPhasea {
    ForgeTypeId^ get ();
}
static member RbsElecPanelBranchCircuitCurrentPhasea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecPanelBranchCircuitCurrentPhaseb Property

ParameterTypeIdRbsElecPanelBranchCircuitCurrentPhaseb Property

"Branch Circuit Current Phase B"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecPanelBranchCircuitCurrentPhaseb { get; }
Public Shared ReadOnly Property RbsElecPanelBranchCircuitCurrentPhaseb As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecPanelBranchCircuitCurrentPhaseb {
    ForgeTypeId^ get ();
}
static member RbsElecPanelBranchCircuitCurrentPhaseb : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecPanelBranchCircuitCurrentPhasec Property

ParameterTypeIdRbsElecPanelBranchCircuitCurrentPhasec Property

"Branch Circuit Current Phase C"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecPanelBranchCircuitCurrentPhasec { get; }
Public Shared ReadOnly Property RbsElecPanelBranchCircuitCurrentPhasec As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecPanelBranchCircuitCurrentPhasec {
    ForgeTypeId^ get ();
}
static member RbsElecPanelBranchCircuitCurrentPhasec : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecPanelBussingParam Property

ParameterTypeIdRbsElecPanelBussingParam Property

"Bussing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecPanelBussingParam { get; }
Public Shared ReadOnly Property RbsElecPanelBussingParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecPanelBussingParam {
    ForgeTypeId^ get ();
}
static member RbsElecPanelBussingParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecPanelConfigurationParam Property

ParameterTypeIdRbsElecPanelConfigurationParam Property

"Panel Configuration"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecPanelConfigurationParam { get; }
Public Shared ReadOnly Property RbsElecPanelConfigurationParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecPanelConfigurationParam {
    ForgeTypeId^ get ();
}
static member RbsElecPanelConfigurationParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecPanelCurrentPhaseaParam Property

ParameterTypeIdRbsElecPanelCurrentPhaseaParam Property

"Current Phase A"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecPanelCurrentPhaseaParam { get; }
Public Shared ReadOnly Property RbsElecPanelCurrentPhaseaParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecPanelCurrentPhaseaParam {
    ForgeTypeId^ get ();
}
static member RbsElecPanelCurrentPhaseaParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecPanelCurrentPhasebParam Property

ParameterTypeIdRbsElecPanelCurrentPhasebParam Property

"Current Phase B"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecPanelCurrentPhasebParam { get; }
Public Shared ReadOnly Property RbsElecPanelCurrentPhasebParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecPanelCurrentPhasebParam {
    ForgeTypeId^ get ();
}
static member RbsElecPanelCurrentPhasebParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecPanelCurrentPhasecParam Property

ParameterTypeIdRbsElecPanelCurrentPhasecParam Property

"Current Phase C"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecPanelCurrentPhasecParam { get; }
Public Shared ReadOnly Property RbsElecPanelCurrentPhasecParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecPanelCurrentPhasecParam {
    ForgeTypeId^ get ();
}
static member RbsElecPanelCurrentPhasecParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecPanelFeedParam Property

ParameterTypeIdRbsElecPanelFeedParam Property

"Feed"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecPanelFeedParam { get; }
Public Shared ReadOnly Property RbsElecPanelFeedParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecPanelFeedParam {
    ForgeTypeId^ get ();
}
static member RbsElecPanelFeedParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecPanelFeedThruLugsApparentLoadPhasea Property

ParameterTypeIdRbsElecPanelFeedThruLugsApparentLoadPhasea Property

"Feed Through Lugs Apparent Power Phase A"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecPanelFeedThruLugsApparentLoadPhasea { get; }
Public Shared ReadOnly Property RbsElecPanelFeedThruLugsApparentLoadPhasea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecPanelFeedThruLugsApparentLoadPhasea {
    ForgeTypeId^ get ();
}
static member RbsElecPanelFeedThruLugsApparentLoadPhasea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecPanelFeedThruLugsApparentLoadPhaseb Property

ParameterTypeIdRbsElecPanelFeedThruLugsApparentLoadPhaseb Property

"Feed Through Lugs Apparent Power Phase B"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecPanelFeedThruLugsApparentLoadPhaseb { get; }
Public Shared ReadOnly Property RbsElecPanelFeedThruLugsApparentLoadPhaseb As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecPanelFeedThruLugsApparentLoadPhaseb {
    ForgeTypeId^ get ();
}
static member RbsElecPanelFeedThruLugsApparentLoadPhaseb : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecPanelFeedThruLugsApparentLoadPhasec Property

ParameterTypeIdRbsElecPanelFeedThruLugsApparentLoadPhasec Property

"Feed Through Lugs Apparent Power Phase C"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecPanelFeedThruLugsApparentLoadPhasec { get; }
Public Shared ReadOnly Property RbsElecPanelFeedThruLugsApparentLoadPhasec As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecPanelFeedThruLugsApparentLoadPhasec {
    ForgeTypeId^ get ();
}
static member RbsElecPanelFeedThruLugsApparentLoadPhasec : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecPanelFeedThruLugsCurrentPhasea Property

ParameterTypeIdRbsElecPanelFeedThruLugsCurrentPhasea Property

"Feed Through Lugs Current Phase A"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecPanelFeedThruLugsCurrentPhasea { get; }
Public Shared ReadOnly Property RbsElecPanelFeedThruLugsCurrentPhasea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecPanelFeedThruLugsCurrentPhasea {
    ForgeTypeId^ get ();
}
static member RbsElecPanelFeedThruLugsCurrentPhasea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecPanelFeedThruLugsCurrentPhaseb Property

ParameterTypeIdRbsElecPanelFeedThruLugsCurrentPhaseb Property

"Feed Through Lugs Current Phase B"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecPanelFeedThruLugsCurrentPhaseb { get; }
Public Shared ReadOnly Property RbsElecPanelFeedThruLugsCurrentPhaseb As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecPanelFeedThruLugsCurrentPhaseb {
    ForgeTypeId^ get ();
}
static member RbsElecPanelFeedThruLugsCurrentPhaseb : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecPanelFeedThruLugsCurrentPhasec Property

ParameterTypeIdRbsElecPanelFeedThruLugsCurrentPhasec Property

"Feed Through Lugs Current Phase C"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecPanelFeedThruLugsCurrentPhasec { get; }
Public Shared ReadOnly Property RbsElecPanelFeedThruLugsCurrentPhasec As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecPanelFeedThruLugsCurrentPhasec {
    ForgeTypeId^ get ();
}
static member RbsElecPanelFeedThruLugsCurrentPhasec : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecPanelFeedThruLugsParam Property

ParameterTypeIdRbsElecPanelFeedThruLugsParam Property

"Feed Through Lugs"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecPanelFeedThruLugsParam { get; }
Public Shared ReadOnly Property RbsElecPanelFeedThruLugsParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecPanelFeedThruLugsParam {
    ForgeTypeId^ get ();
}
static member RbsElecPanelFeedThruLugsParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecPanelGroundBusParam Property

ParameterTypeIdRbsElecPanelGroundBusParam Property

"Ground Bus"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecPanelGroundBusParam { get; }
Public Shared ReadOnly Property RbsElecPanelGroundBusParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecPanelGroundBusParam {
    ForgeTypeId^ get ();
}
static member RbsElecPanelGroundBusParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecPanelLocationParam Property

ParameterTypeIdRbsElecPanelLocationParam Property

"Location"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecPanelLocationParam { get; }
Public Shared ReadOnly Property RbsElecPanelLocationParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecPanelLocationParam {
    ForgeTypeId^ get ();
}
static member RbsElecPanelLocationParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecPanelMainstypeParam Property

ParameterTypeIdRbsElecPanelMainstypeParam Property

"Mains Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecPanelMainstypeParam { get; }
Public Shared ReadOnly Property RbsElecPanelMainstypeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecPanelMainstypeParam {
    ForgeTypeId^ get ();
}
static member RbsElecPanelMainstypeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecPanelMcbRatingParam Property

ParameterTypeIdRbsElecPanelMcbRatingParam Property

"MCB Rating"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecPanelMcbRatingParam { get; }
Public Shared ReadOnly Property RbsElecPanelMcbRatingParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecPanelMcbRatingParam {
    ForgeTypeId^ get ();
}
static member RbsElecPanelMcbRatingParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecPanelName Property

ParameterTypeIdRbsElecPanelName Property

"Panel Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecPanelName { get; }
Public Shared ReadOnly Property RbsElecPanelName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecPanelName {
    ForgeTypeId^ get ();
}
static member RbsElecPanelName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecPanelNeutralBusParam Property

ParameterTypeIdRbsElecPanelNeutralBusParam Property

"Neutral Bus"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecPanelNeutralBusParam { get; }
Public Shared ReadOnly Property RbsElecPanelNeutralBusParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecPanelNeutralBusParam {
    ForgeTypeId^ get ();
}
static member RbsElecPanelNeutralBusParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecPanelNeutralRatingParam Property

ParameterTypeIdRbsElecPanelNeutralRatingParam Property

"Neutral Rating"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecPanelNeutralRatingParam { get; }
Public Shared ReadOnly Property RbsElecPanelNeutralRatingParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecPanelNeutralRatingParam {
    ForgeTypeId^ get ();
}
static member RbsElecPanelNeutralRatingParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecPanelNumphasesParam Property

ParameterTypeIdRbsElecPanelNumphasesParam Property

"Number of Phases"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecPanelNumphasesParam { get; }
Public Shared ReadOnly Property RbsElecPanelNumphasesParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecPanelNumphasesParam {
    ForgeTypeId^ get ();
}
static member RbsElecPanelNumphasesParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecPanelNumwiresParam Property

ParameterTypeIdRbsElecPanelNumwiresParam Property

"Number of Wires"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecPanelNumwiresParam { get; }
Public Shared ReadOnly Property RbsElecPanelNumwiresParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecPanelNumwiresParam {
    ForgeTypeId^ get ();
}
static member RbsElecPanelNumwiresParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecPanelScheduleFooterNotesParam Property

ParameterTypeIdRbsElecPanelScheduleFooterNotesParam Property

"Schedule Footer Notes"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecPanelScheduleFooterNotesParam { get; }
Public Shared ReadOnly Property RbsElecPanelScheduleFooterNotesParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecPanelScheduleFooterNotesParam {
    ForgeTypeId^ get ();
}
static member RbsElecPanelScheduleFooterNotesParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecPanelScheduleHeaderNotesParam Property

ParameterTypeIdRbsElecPanelScheduleHeaderNotesParam Property

"Schedule Header Notes"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecPanelScheduleHeaderNotesParam { get; }
Public Shared ReadOnly Property RbsElecPanelScheduleHeaderNotesParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecPanelScheduleHeaderNotesParam {
    ForgeTypeId^ get ();
}
static member RbsElecPanelScheduleHeaderNotesParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecPanelSubfeedLugsParam Property

ParameterTypeIdRbsElecPanelSubfeedLugsParam Property

"SubFeed Lugs"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecPanelSubfeedLugsParam { get; }
Public Shared ReadOnly Property RbsElecPanelSubfeedLugsParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecPanelSubfeedLugsParam {
    ForgeTypeId^ get ();
}
static member RbsElecPanelSubfeedLugsParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecPanelSupplyFromParam Property

ParameterTypeIdRbsElecPanelSupplyFromParam Property

"Supply From"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecPanelSupplyFromParam { get; }
Public Shared ReadOnly Property RbsElecPanelSupplyFromParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecPanelSupplyFromParam {
    ForgeTypeId^ get ();
}
static member RbsElecPanelSupplyFromParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecPanelTotalConnectedCurrentParam Property

ParameterTypeIdRbsElecPanelTotalConnectedCurrentParam Property

"Total Connected Current"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecPanelTotalConnectedCurrentParam { get; }
Public Shared ReadOnly Property RbsElecPanelTotalConnectedCurrentParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecPanelTotalConnectedCurrentParam {
    ForgeTypeId^ get ();
}
static member RbsElecPanelTotalConnectedCurrentParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecPanelTotalDemandCurrentParam Property

ParameterTypeIdRbsElecPanelTotalDemandCurrentParam Property

"Total Estimated Demand Current"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecPanelTotalDemandCurrentParam { get; }
Public Shared ReadOnly Property RbsElecPanelTotalDemandCurrentParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecPanelTotalDemandCurrentParam {
    ForgeTypeId^ get ();
}
static member RbsElecPanelTotalDemandCurrentParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecPanelTotalDemandFactorParam Property

ParameterTypeIdRbsElecPanelTotalDemandFactorParam Property

"Total Demand Factor"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecPanelTotalDemandFactorParam { get; }
Public Shared ReadOnly Property RbsElecPanelTotalDemandFactorParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecPanelTotalDemandFactorParam {
    ForgeTypeId^ get ();
}
static member RbsElecPanelTotalDemandFactorParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecPanelTotalestloadHvacParam Property

ParameterTypeIdRbsElecPanelTotalestloadHvacParam Property

"HVAC Total Demand Apparent Power"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecPanelTotalestloadHvacParam { get; }
Public Shared ReadOnly Property RbsElecPanelTotalestloadHvacParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecPanelTotalestloadHvacParam {
    ForgeTypeId^ get ();
}
static member RbsElecPanelTotalestloadHvacParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecPanelTotalestloadLightParam Property

ParameterTypeIdRbsElecPanelTotalestloadLightParam Property

"Lighting Total Demand Apparent Power"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecPanelTotalestloadLightParam { get; }
Public Shared ReadOnly Property RbsElecPanelTotalestloadLightParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecPanelTotalestloadLightParam {
    ForgeTypeId^ get ();
}
static member RbsElecPanelTotalestloadLightParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecPanelTotalestloadOtherParam Property

ParameterTypeIdRbsElecPanelTotalestloadOtherParam Property

"Other Total Demand Apparent Power"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecPanelTotalestloadOtherParam { get; }
Public Shared ReadOnly Property RbsElecPanelTotalestloadOtherParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecPanelTotalestloadOtherParam {
    ForgeTypeId^ get ();
}
static member RbsElecPanelTotalestloadOtherParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecPanelTotalestloadParam Property

ParameterTypeIdRbsElecPanelTotalestloadParam Property

"Total Demand Apparent Power"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecPanelTotalestloadParam { get; }
Public Shared ReadOnly Property RbsElecPanelTotalestloadParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecPanelTotalestloadParam {
    ForgeTypeId^ get ();
}
static member RbsElecPanelTotalestloadParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecPanelTotalestloadPowerParam Property

ParameterTypeIdRbsElecPanelTotalestloadPowerParam Property

"Power Total Demand Apparent Power"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecPanelTotalestloadPowerParam { get; }
Public Shared ReadOnly Property RbsElecPanelTotalestloadPowerParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecPanelTotalestloadPowerParam {
    ForgeTypeId^ get ();
}
static member RbsElecPanelTotalestloadPowerParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecPanelTotalloadHvacParam Property

ParameterTypeIdRbsElecPanelTotalloadHvacParam Property

"HVAC Total Connected Apparent Power"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecPanelTotalloadHvacParam { get; }
Public Shared ReadOnly Property RbsElecPanelTotalloadHvacParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecPanelTotalloadHvacParam {
    ForgeTypeId^ get ();
}
static member RbsElecPanelTotalloadHvacParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecPanelTotalloadLightParam Property

ParameterTypeIdRbsElecPanelTotalloadLightParam Property

"Lighting Total Connected Apparent Power"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecPanelTotalloadLightParam { get; }
Public Shared ReadOnly Property RbsElecPanelTotalloadLightParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecPanelTotalloadLightParam {
    ForgeTypeId^ get ();
}
static member RbsElecPanelTotalloadLightParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecPanelTotalloadOtherParam Property

ParameterTypeIdRbsElecPanelTotalloadOtherParam Property

"Other Total Connected Apparent Power"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecPanelTotalloadOtherParam { get; }
Public Shared ReadOnly Property RbsElecPanelTotalloadOtherParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecPanelTotalloadOtherParam {
    ForgeTypeId^ get ();
}
static member RbsElecPanelTotalloadOtherParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecPanelTotalloadParam Property

ParameterTypeIdRbsElecPanelTotalloadParam Property

"Total Connected Apparent Power"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecPanelTotalloadParam { get; }
Public Shared ReadOnly Property RbsElecPanelTotalloadParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecPanelTotalloadParam {
    ForgeTypeId^ get ();
}
static member RbsElecPanelTotalloadParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecPanelTotalloadPowerParam Property

ParameterTypeIdRbsElecPanelTotalloadPowerParam Property

"Power Total Connected Apparent Power"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecPanelTotalloadPowerParam { get; }
Public Shared ReadOnly Property RbsElecPanelTotalloadPowerParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecPanelTotalloadPowerParam {
    ForgeTypeId^ get ();
}
static member RbsElecPanelTotalloadPowerParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecPowerFactor Property

ParameterTypeIdRbsElecPowerFactor Property

"Power Factor"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecPowerFactor { get; }
Public Shared ReadOnly Property RbsElecPowerFactor As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecPowerFactor {
    ForgeTypeId^ get ();
}
static member RbsElecPowerFactor : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecPowerFactorState Property

ParameterTypeIdRbsElecPowerFactorState Property

"Power Factor State"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecPowerFactorState { get; }
Public Shared ReadOnly Property RbsElecPowerFactorState As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecPowerFactorState {
    ForgeTypeId^ get ();
}
static member RbsElecPowerFactorState : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecRoomAverageIllumination Property

ParameterTypeIdRbsElecRoomAverageIllumination Property

"Average Estimated Illumination"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecRoomAverageIllumination { get; }
Public Shared ReadOnly Property RbsElecRoomAverageIllumination As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecRoomAverageIllumination {
    ForgeTypeId^ get ();
}
static member RbsElecRoomAverageIllumination : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecRoomCavityRatio Property

ParameterTypeIdRbsElecRoomCavityRatio Property

"Room Cavity Ratio"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecRoomCavityRatio { get; }
Public Shared ReadOnly Property RbsElecRoomCavityRatio As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecRoomCavityRatio {
    ForgeTypeId^ get ();
}
static member RbsElecRoomCavityRatio : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecRoomLightingCalcLuminaireplane Property

ParameterTypeIdRbsElecRoomLightingCalcLuminaireplane Property

"Lighting Calculation Luminaire Plane"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecRoomLightingCalcLuminaireplane { get; }
Public Shared ReadOnly Property RbsElecRoomLightingCalcLuminaireplane As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecRoomLightingCalcLuminaireplane {
    ForgeTypeId^ get ();
}
static member RbsElecRoomLightingCalcLuminaireplane : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecRoomLightingCalcWorkplane Property

ParameterTypeIdRbsElecRoomLightingCalcWorkplane Property

"Lighting Calculation Workplane"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecRoomLightingCalcWorkplane { get; }
Public Shared ReadOnly Property RbsElecRoomLightingCalcWorkplane As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecRoomLightingCalcWorkplane {
    ForgeTypeId^ get ();
}
static member RbsElecRoomLightingCalcWorkplane : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecRoomReflectivityCeiling Property

ParameterTypeIdRbsElecRoomReflectivityCeiling Property

"Ceiling Reflectance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecRoomReflectivityCeiling { get; }
Public Shared ReadOnly Property RbsElecRoomReflectivityCeiling As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecRoomReflectivityCeiling {
    ForgeTypeId^ get ();
}
static member RbsElecRoomReflectivityCeiling : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecRoomReflectivityFloor Property

ParameterTypeIdRbsElecRoomReflectivityFloor Property

"Floor Reflectance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecRoomReflectivityFloor { get; }
Public Shared ReadOnly Property RbsElecRoomReflectivityFloor As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecRoomReflectivityFloor {
    ForgeTypeId^ get ();
}
static member RbsElecRoomReflectivityFloor : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecRoomReflectivityWalls Property

ParameterTypeIdRbsElecRoomReflectivityWalls Property

"Wall Reflectance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecRoomReflectivityWalls { get; }
Public Shared ReadOnly Property RbsElecRoomReflectivityWalls As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecRoomReflectivityWalls {
    ForgeTypeId^ get ();
}
static member RbsElecRoomReflectivityWalls : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecShortCircuitRating Property

ParameterTypeIdRbsElecShortCircuitRating Property

"Short Circuit Rating Comments"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecShortCircuitRating { get; }
Public Shared ReadOnly Property RbsElecShortCircuitRating As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecShortCircuitRating {
    ForgeTypeId^ get ();
}
static member RbsElecShortCircuitRating : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecSwitchIdParam Property

ParameterTypeIdRbsElecSwitchIdParam Property

"Switch ID"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecSwitchIdParam { get; }
Public Shared ReadOnly Property RbsElecSwitchIdParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecSwitchIdParam {
    ForgeTypeId^ get ();
}
static member RbsElecSwitchIdParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElectricalData Property

ParameterTypeIdRbsElectricalData Property

"Electrical Data"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElectricalData { get; }
Public Shared ReadOnly Property RbsElectricalData As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElectricalData {
    ForgeTypeId^ get ();
}
static member RbsElectricalData : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecTrueCurrentParam Property

ParameterTypeIdRbsElecTrueCurrentParam Property

"True Current"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecTrueCurrentParam { get; }
Public Shared ReadOnly Property RbsElecTrueCurrentParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecTrueCurrentParam {
    ForgeTypeId^ get ();
}
static member RbsElecTrueCurrentParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecTrueCurrentPhaseaParam Property

ParameterTypeIdRbsElecTrueCurrentPhaseaParam Property

"True Current Phase A"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecTrueCurrentPhaseaParam { get; }
Public Shared ReadOnly Property RbsElecTrueCurrentPhaseaParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecTrueCurrentPhaseaParam {
    ForgeTypeId^ get ();
}
static member RbsElecTrueCurrentPhaseaParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecTrueCurrentPhasebParam Property

ParameterTypeIdRbsElecTrueCurrentPhasebParam Property

"True Current Phase B"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecTrueCurrentPhasebParam { get; }
Public Shared ReadOnly Property RbsElecTrueCurrentPhasebParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecTrueCurrentPhasebParam {
    ForgeTypeId^ get ();
}
static member RbsElecTrueCurrentPhasebParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecTrueCurrentPhasecParam Property

ParameterTypeIdRbsElecTrueCurrentPhasecParam Property

"True Current Phase C"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecTrueCurrentPhasecParam { get; }
Public Shared ReadOnly Property RbsElecTrueCurrentPhasecParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecTrueCurrentPhasecParam {
    ForgeTypeId^ get ();
}
static member RbsElecTrueCurrentPhasecParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecTrueLoad Property

ParameterTypeIdRbsElecTrueLoad Property

"True Power"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecTrueLoad { get; }
Public Shared ReadOnly Property RbsElecTrueLoad As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecTrueLoad {
    ForgeTypeId^ get ();
}
static member RbsElecTrueLoad : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecTrueLoadPhase1 Property

ParameterTypeIdRbsElecTrueLoadPhase1 Property

"True Power Phase 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecTrueLoadPhase1 { get; }
Public Shared ReadOnly Property RbsElecTrueLoadPhase1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecTrueLoadPhase1 {
    ForgeTypeId^ get ();
}
static member RbsElecTrueLoadPhase1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecTrueLoadPhase2 Property

ParameterTypeIdRbsElecTrueLoadPhase2 Property

"True Power Phase 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecTrueLoadPhase2 { get; }
Public Shared ReadOnly Property RbsElecTrueLoadPhase2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecTrueLoadPhase2 {
    ForgeTypeId^ get ();
}
static member RbsElecTrueLoadPhase2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecTrueLoadPhase3 Property

ParameterTypeIdRbsElecTrueLoadPhase3 Property

"True Power Phase 3"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecTrueLoadPhase3 { get; }
Public Shared ReadOnly Property RbsElecTrueLoadPhase3 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecTrueLoadPhase3 {
    ForgeTypeId^ get ();
}
static member RbsElecTrueLoadPhase3 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecTrueLoadPhasea Property

ParameterTypeIdRbsElecTrueLoadPhasea Property

"True Power Phase A"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecTrueLoadPhasea { get; }
Public Shared ReadOnly Property RbsElecTrueLoadPhasea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecTrueLoadPhasea {
    ForgeTypeId^ get ();
}
static member RbsElecTrueLoadPhasea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecTrueLoadPhaseb Property

ParameterTypeIdRbsElecTrueLoadPhaseb Property

"True Power Phase B"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecTrueLoadPhaseb { get; }
Public Shared ReadOnly Property RbsElecTrueLoadPhaseb As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecTrueLoadPhaseb {
    ForgeTypeId^ get ();
}
static member RbsElecTrueLoadPhaseb : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecTrueLoadPhasec Property

ParameterTypeIdRbsElecTrueLoadPhasec Property

"True Power Phase C"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecTrueLoadPhasec { get; }
Public Shared ReadOnly Property RbsElecTrueLoadPhasec As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecTrueLoadPhasec {
    ForgeTypeId^ get ();
}
static member RbsElecTrueLoadPhasec : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecVoltage Property

ParameterTypeIdRbsElecVoltage Property

"Voltage"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecVoltage { get; }
Public Shared ReadOnly Property RbsElecVoltage As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecVoltage {
    ForgeTypeId^ get ();
}
static member RbsElecVoltage : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecVoltageDropParam Property

ParameterTypeIdRbsElecVoltageDropParam Property

"Voltage Drop"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecVoltageDropParam { get; }
Public Shared ReadOnly Property RbsElecVoltageDropParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecVoltageDropParam {
    ForgeTypeId^ get ();
}
static member RbsElecVoltageDropParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecWireCircuits Property

ParameterTypeIdRbsElecWireCircuits Property

"Circuits"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecWireCircuits { get; }
Public Shared ReadOnly Property RbsElecWireCircuits As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecWireCircuits {
    ForgeTypeId^ get ();
}
static member RbsElecWireCircuits : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecWireElevation Property

ParameterTypeIdRbsElecWireElevation Property

"Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecWireElevation { get; }
Public Shared ReadOnly Property RbsElecWireElevation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecWireElevation {
    ForgeTypeId^ get ();
}
static member RbsElecWireElevation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecWireGroundAdjustment Property

ParameterTypeIdRbsElecWireGroundAdjustment Property

"Ground Conductors"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecWireGroundAdjustment { get; }
Public Shared ReadOnly Property RbsElecWireGroundAdjustment As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecWireGroundAdjustment {
    ForgeTypeId^ get ();
}
static member RbsElecWireGroundAdjustment : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecWireHotAdjustment Property

ParameterTypeIdRbsElecWireHotAdjustment Property

"Hot Conductors"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecWireHotAdjustment { get; }
Public Shared ReadOnly Property RbsElecWireHotAdjustment As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecWireHotAdjustment {
    ForgeTypeId^ get ();
}
static member RbsElecWireHotAdjustment : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecWireNeutralAdjustment Property

ParameterTypeIdRbsElecWireNeutralAdjustment Property

"Neutral Conductors"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecWireNeutralAdjustment { get; }
Public Shared ReadOnly Property RbsElecWireNeutralAdjustment As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecWireNeutralAdjustment {
    ForgeTypeId^ get ();
}
static member RbsElecWireNeutralAdjustment : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecWireShareGround Property

ParameterTypeIdRbsElecWireShareGround Property

"Share Ground Conductor"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecWireShareGround { get; }
Public Shared ReadOnly Property RbsElecWireShareGround As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecWireShareGround {
    ForgeTypeId^ get ();
}
static member RbsElecWireShareGround : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecWireShareNeutral Property

ParameterTypeIdRbsElecWireShareNeutral Property

"Share Neutral Conductor"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecWireShareNeutral { get; }
Public Shared ReadOnly Property RbsElecWireShareNeutral As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecWireShareNeutral {
    ForgeTypeId^ get ();
}
static member RbsElecWireShareNeutral : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecWireTickmarkState Property

ParameterTypeIdRbsElecWireTickmarkState Property

"Tick Marks"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecWireTickmarkState { get; }
Public Shared ReadOnly Property RbsElecWireTickmarkState As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecWireTickmarkState {
    ForgeTypeId^ get ();
}
static member RbsElecWireTickmarkState : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsElecWireType Property

ParameterTypeIdRbsElecWireType Property

"Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsElecWireType { get; }
Public Shared ReadOnly Property RbsElecWireType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsElecWireType {
    ForgeTypeId^ get ();
}
static member RbsElecWireType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsEndLevelParam Property

ParameterTypeIdRbsEndLevelParam Property

"End Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsEndLevelParam { get; }
Public Shared ReadOnly Property RbsEndLevelParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsEndLevelParam {
    ForgeTypeId^ get ();
}
static member RbsEndLevelParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsEndOffsetParam Property

ParameterTypeIdRbsEndOffsetParam Property

"End Middle Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsEndOffsetParam { get; }
Public Shared ReadOnly Property RbsEndOffsetParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsEndOffsetParam {
    ForgeTypeId^ get ();
}
static member RbsEndOffsetParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsEnergyAnalysisBuildingEnvelopeAnalyticalGridCellSize Property

ParameterTypeIdRbsEnergyAnalysisBuildingEnvelopeAnalyticalGridCellSize Property

"Analytical Grid Cell Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsEnergyAnalysisBuildingEnvelopeAnalyticalGridCellSize { get; }
Public Shared ReadOnly Property RbsEnergyAnalysisBuildingEnvelopeAnalyticalGridCellSize As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsEnergyAnalysisBuildingEnvelopeAnalyticalGridCellSize {
    ForgeTypeId^ get ();
}
static member RbsEnergyAnalysisBuildingEnvelopeAnalyticalGridCellSize : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsEnergyAnalysisBuildingEnvelopeAnalyticalSpaceIdentificationResolution Property

ParameterTypeIdRbsEnergyAnalysisBuildingEnvelopeAnalyticalSpaceIdentificationResolution Property

"Analytical Space Resolution"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsEnergyAnalysisBuildingEnvelopeAnalyticalSpaceIdentificationResolution { get; }
Public Shared ReadOnly Property RbsEnergyAnalysisBuildingEnvelopeAnalyticalSpaceIdentificationResolution As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsEnergyAnalysisBuildingEnvelopeAnalyticalSpaceIdentificationResolution {
    ForgeTypeId^ get ();
}
static member RbsEnergyAnalysisBuildingEnvelopeAnalyticalSpaceIdentificationResolution : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsEnergyAnalysisBuildingEnvelopeAnalyticalSurfaceIdentificationResolution Property

ParameterTypeIdRbsEnergyAnalysisBuildingEnvelopeAnalyticalSurfaceIdentificationResolution Property

"Analytical Surface Resolution"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsEnergyAnalysisBuildingEnvelopeAnalyticalSurfaceIdentificationResolution { get; }
Public Shared ReadOnly Property RbsEnergyAnalysisBuildingEnvelopeAnalyticalSurfaceIdentificationResolution As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsEnergyAnalysisBuildingEnvelopeAnalyticalSurfaceIdentificationResolution {
    ForgeTypeId^ get ();
}
static member RbsEnergyAnalysisBuildingEnvelopeAnalyticalSurfaceIdentificationResolution : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsEnergyAnalysisBuildingEnvelopeDeterminationParam Property

ParameterTypeIdRbsEnergyAnalysisBuildingEnvelopeDeterminationParam Property

"Building Envelope"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsEnergyAnalysisBuildingEnvelopeDeterminationParam { get; }
Public Shared ReadOnly Property RbsEnergyAnalysisBuildingEnvelopeDeterminationParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsEnergyAnalysisBuildingEnvelopeDeterminationParam {
    ForgeTypeId^ get ();
}
static member RbsEnergyAnalysisBuildingEnvelopeDeterminationParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsEnergyAnalysisExportCategoryParam Property

ParameterTypeIdRbsEnergyAnalysisExportCategoryParam Property

"Export Category"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsEnergyAnalysisExportCategoryParam { get; }
Public Shared ReadOnly Property RbsEnergyAnalysisExportCategoryParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsEnergyAnalysisExportCategoryParam {
    ForgeTypeId^ get ();
}
static member RbsEnergyAnalysisExportCategoryParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsEnergyAnalysisExportComplexityParam Property

ParameterTypeIdRbsEnergyAnalysisExportComplexityParam Property

"Export Complexity"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsEnergyAnalysisExportComplexityParam { get; }
Public Shared ReadOnly Property RbsEnergyAnalysisExportComplexityParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsEnergyAnalysisExportComplexityParam {
    ForgeTypeId^ get ();
}
static member RbsEnergyAnalysisExportComplexityParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsEnergyAnalysisExportGbxmlDefaultsParam Property

ParameterTypeIdRbsEnergyAnalysisExportGbxmlDefaultsParam Property

"Export Default Values"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsEnergyAnalysisExportGbxmlDefaultsParam { get; }
Public Shared ReadOnly Property RbsEnergyAnalysisExportGbxmlDefaultsParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsEnergyAnalysisExportGbxmlDefaultsParam {
    ForgeTypeId^ get ();
}
static member RbsEnergyAnalysisExportGbxmlDefaultsParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsEnergyAnalysisGroundPlaneParam Property

ParameterTypeIdRbsEnergyAnalysisGroundPlaneParam Property

"Ground Plane"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsEnergyAnalysisGroundPlaneParam { get; }
Public Shared ReadOnly Property RbsEnergyAnalysisGroundPlaneParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsEnergyAnalysisGroundPlaneParam {
    ForgeTypeId^ get ();
}
static member RbsEnergyAnalysisGroundPlaneParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsEnergyAnalysisIncludeThermalProperties Property

ParameterTypeIdRbsEnergyAnalysisIncludeThermalProperties Property

"Detailed Elements"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsEnergyAnalysisIncludeThermalProperties { get; }
Public Shared ReadOnly Property RbsEnergyAnalysisIncludeThermalProperties As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsEnergyAnalysisIncludeThermalProperties {
    ForgeTypeId^ get ();
}
static member RbsEnergyAnalysisIncludeThermalProperties : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsEnergyAnalysisMode Property

ParameterTypeIdRbsEnergyAnalysisMode Property

"Mode"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsEnergyAnalysisMode { get; }
Public Shared ReadOnly Property RbsEnergyAnalysisMode As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsEnergyAnalysisMode {
    ForgeTypeId^ get ();
}
static member RbsEnergyAnalysisMode : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsEnergyAnalysisProjectPhaseParam Property

ParameterTypeIdRbsEnergyAnalysisProjectPhaseParam Property

"Project Phase"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsEnergyAnalysisProjectPhaseParam { get; }
Public Shared ReadOnly Property RbsEnergyAnalysisProjectPhaseParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsEnergyAnalysisProjectPhaseParam {
    ForgeTypeId^ get ();
}
static member RbsEnergyAnalysisProjectPhaseParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsEnergyAnalysisSliverSpaceTolerance Property

ParameterTypeIdRbsEnergyAnalysisSliverSpaceTolerance Property

"Sliver Space Tolerance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsEnergyAnalysisSliverSpaceTolerance { get; }
Public Shared ReadOnly Property RbsEnergyAnalysisSliverSpaceTolerance As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsEnergyAnalysisSliverSpaceTolerance {
    ForgeTypeId^ get ();
}
static member RbsEnergyAnalysisSliverSpaceTolerance : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsEnergyAnalysisSurfaceAdjacentSpaceId1 Property

ParameterTypeIdRbsEnergyAnalysisSurfaceAdjacentSpaceId1 Property

"Adjacent Space Id (1)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsEnergyAnalysisSurfaceAdjacentSpaceId1 { get; }
Public Shared ReadOnly Property RbsEnergyAnalysisSurfaceAdjacentSpaceId1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsEnergyAnalysisSurfaceAdjacentSpaceId1 {
    ForgeTypeId^ get ();
}
static member RbsEnergyAnalysisSurfaceAdjacentSpaceId1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsEnergyAnalysisSurfaceAdjacentSpaceId2 Property

ParameterTypeIdRbsEnergyAnalysisSurfaceAdjacentSpaceId2 Property

"Adjacent Space Id (2)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsEnergyAnalysisSurfaceAdjacentSpaceId2 { get; }
Public Shared ReadOnly Property RbsEnergyAnalysisSurfaceAdjacentSpaceId2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsEnergyAnalysisSurfaceAdjacentSpaceId2 {
    ForgeTypeId^ get ();
}
static member RbsEnergyAnalysisSurfaceAdjacentSpaceId2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsEnergyAnalysisSurfaceAzimuth Property

ParameterTypeIdRbsEnergyAnalysisSurfaceAzimuth Property

"Azimuth"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsEnergyAnalysisSurfaceAzimuth { get; }
Public Shared ReadOnly Property RbsEnergyAnalysisSurfaceAzimuth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsEnergyAnalysisSurfaceAzimuth {
    ForgeTypeId^ get ();
}
static member RbsEnergyAnalysisSurfaceAzimuth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsEnergyAnalysisSurfaceCadobjectid Property

ParameterTypeIdRbsEnergyAnalysisSurfaceCadobjectid Property

"CADObjectID"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsEnergyAnalysisSurfaceCadobjectid { get; }
Public Shared ReadOnly Property RbsEnergyAnalysisSurfaceCadobjectid As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsEnergyAnalysisSurfaceCadobjectid {
    ForgeTypeId^ get ();
}
static member RbsEnergyAnalysisSurfaceCadobjectid : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsEnergyAnalysisSurfaceOriginX Property

ParameterTypeIdRbsEnergyAnalysisSurfaceOriginX Property

"Origin (X)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsEnergyAnalysisSurfaceOriginX { get; }
Public Shared ReadOnly Property RbsEnergyAnalysisSurfaceOriginX As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsEnergyAnalysisSurfaceOriginX {
    ForgeTypeId^ get ();
}
static member RbsEnergyAnalysisSurfaceOriginX : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsEnergyAnalysisSurfaceOriginY Property

ParameterTypeIdRbsEnergyAnalysisSurfaceOriginY Property

"Origin (Y)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsEnergyAnalysisSurfaceOriginY { get; }
Public Shared ReadOnly Property RbsEnergyAnalysisSurfaceOriginY As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsEnergyAnalysisSurfaceOriginY {
    ForgeTypeId^ get ();
}
static member RbsEnergyAnalysisSurfaceOriginY : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsEnergyAnalysisSurfaceOriginZ Property

ParameterTypeIdRbsEnergyAnalysisSurfaceOriginZ Property

"Origin (Z)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsEnergyAnalysisSurfaceOriginZ { get; }
Public Shared ReadOnly Property RbsEnergyAnalysisSurfaceOriginZ As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsEnergyAnalysisSurfaceOriginZ {
    ForgeTypeId^ get ();
}
static member RbsEnergyAnalysisSurfaceOriginZ : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsEnergyAnalysisSurfaceTilt Property

ParameterTypeIdRbsEnergyAnalysisSurfaceTilt Property

"Tilt"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsEnergyAnalysisSurfaceTilt { get; }
Public Shared ReadOnly Property RbsEnergyAnalysisSurfaceTilt As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsEnergyAnalysisSurfaceTilt {
    ForgeTypeId^ get ();
}
static member RbsEnergyAnalysisSurfaceTilt : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsEnergyAnalysisViewBuildingShellMode Property

ParameterTypeIdRbsEnergyAnalysisViewBuildingShellMode Property

"Show Analytical Building Shell"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsEnergyAnalysisViewBuildingShellMode { get; }
Public Shared ReadOnly Property RbsEnergyAnalysisViewBuildingShellMode As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsEnergyAnalysisViewBuildingShellMode {
    ForgeTypeId^ get ();
}
static member RbsEnergyAnalysisViewBuildingShellMode : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsEnergyAnalysisViewCoordAxisMode Property

ParameterTypeIdRbsEnergyAnalysisViewCoordAxisMode Property

"Show a Coordinate System Symbol for each Surface"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsEnergyAnalysisViewCoordAxisMode { get; }
Public Shared ReadOnly Property RbsEnergyAnalysisViewCoordAxisMode As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsEnergyAnalysisViewCoordAxisMode {
    ForgeTypeId^ get ();
}
static member RbsEnergyAnalysisViewCoordAxisMode : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsEnergyAnalysisViewInnerShellMode Property

ParameterTypeIdRbsEnergyAnalysisViewInnerShellMode Property

"Show Inner Space Shells"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsEnergyAnalysisViewInnerShellMode { get; }
Public Shared ReadOnly Property RbsEnergyAnalysisViewInnerShellMode As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsEnergyAnalysisViewInnerShellMode {
    ForgeTypeId^ get ();
}
static member RbsEnergyAnalysisViewInnerShellMode : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsEnergyAnalysisViewOuterShellMode Property

ParameterTypeIdRbsEnergyAnalysisViewOuterShellMode Property

"Show Analytical Space Shells"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsEnergyAnalysisViewOuterShellMode { get; }
Public Shared ReadOnly Property RbsEnergyAnalysisViewOuterShellMode As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsEnergyAnalysisViewOuterShellMode {
    ForgeTypeId^ get ();
}
static member RbsEnergyAnalysisViewOuterShellMode : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsEnergyAnalysisViewRbeMode Property

ParameterTypeIdRbsEnergyAnalysisViewRbeMode Property

"Show Room Bounding Elements Dimmed and Underlay"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsEnergyAnalysisViewRbeMode { get; }
Public Shared ReadOnly Property RbsEnergyAnalysisViewRbeMode As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsEnergyAnalysisViewRbeMode {
    ForgeTypeId^ get ();
}
static member RbsEnergyAnalysisViewRbeMode : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsEnergyAnalysisViewShadingSurfacesMode Property

ParameterTypeIdRbsEnergyAnalysisViewShadingSurfacesMode Property

"Show Shading Surfaces"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsEnergyAnalysisViewShadingSurfacesMode { get; }
Public Shared ReadOnly Property RbsEnergyAnalysisViewShadingSurfacesMode As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsEnergyAnalysisViewShadingSurfacesMode {
    ForgeTypeId^ get ();
}
static member RbsEnergyAnalysisViewShadingSurfacesMode : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsEnergyAnalysisViewSurfacesMode Property

ParameterTypeIdRbsEnergyAnalysisViewSurfacesMode Property

"Show Surfaces"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsEnergyAnalysisViewSurfacesMode { get; }
Public Shared ReadOnly Property RbsEnergyAnalysisViewSurfacesMode As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsEnergyAnalysisViewSurfacesMode {
    ForgeTypeId^ get ();
}
static member RbsEnergyAnalysisViewSurfacesMode : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsEnergyAnalysisViewTransparentMode Property

ParameterTypeIdRbsEnergyAnalysisViewTransparentMode Property

"Show Surfaces Transparent"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsEnergyAnalysisViewTransparentMode { get; }
Public Shared ReadOnly Property RbsEnergyAnalysisViewTransparentMode As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsEnergyAnalysisViewTransparentMode {
    ForgeTypeId^ get ();
}
static member RbsEnergyAnalysisViewTransparentMode : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsEnergyAnalysisViewUpdateSurfaces Property

ParameterTypeIdRbsEnergyAnalysisViewUpdateSurfaces Property

"Update Surfaces"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsEnergyAnalysisViewUpdateSurfaces { get; }
Public Shared ReadOnly Property RbsEnergyAnalysisViewUpdateSurfaces As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsEnergyAnalysisViewUpdateSurfaces {
    ForgeTypeId^ get ();
}
static member RbsEnergyAnalysisViewUpdateSurfaces : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsEqDiameterParam Property

ParameterTypeIdRbsEqDiameterParam Property

"Equivalent Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsEqDiameterParam { get; }
Public Shared ReadOnly Property RbsEqDiameterParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsEqDiameterParam {
    ForgeTypeId^ get ();
}
static member RbsEqDiameterParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsFamilyContentAnnotationDisplay Property

ParameterTypeIdRbsFamilyContentAnnotationDisplay Property

"Use Annotation Scale"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsFamilyContentAnnotationDisplay { get; }
Public Shared ReadOnly Property RbsFamilyContentAnnotationDisplay As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsFamilyContentAnnotationDisplay {
    ForgeTypeId^ get ();
}
static member RbsFamilyContentAnnotationDisplay : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsFamilyContentDistributionSystem Property

ParameterTypeIdRbsFamilyContentDistributionSystem Property

"Distribution System"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsFamilyContentDistributionSystem { get; }
Public Shared ReadOnly Property RbsFamilyContentDistributionSystem As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsFamilyContentDistributionSystem {
    ForgeTypeId^ get ();
}
static member RbsFamilyContentDistributionSystem : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsFamilyContentOffsetHeight Property

ParameterTypeIdRbsFamilyContentOffsetHeight Property

"OffsetHeight"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsFamilyContentOffsetHeight { get; }
Public Shared ReadOnly Property RbsFamilyContentOffsetHeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsFamilyContentOffsetHeight {
    ForgeTypeId^ get ();
}
static member RbsFamilyContentOffsetHeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsFamilyContentOffsetWidth Property

ParameterTypeIdRbsFamilyContentOffsetWidth Property

"OffsetWidth"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsFamilyContentOffsetWidth { get; }
Public Shared ReadOnly Property RbsFamilyContentOffsetWidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsFamilyContentOffsetWidth {
    ForgeTypeId^ get ();
}
static member RbsFamilyContentOffsetWidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsFamilyContentSecondaryDistribsys Property

ParameterTypeIdRbsFamilyContentSecondaryDistribsys Property

"Secondary Distribution System"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsFamilyContentSecondaryDistribsys { get; }
Public Shared ReadOnly Property RbsFamilyContentSecondaryDistribsys As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsFamilyContentSecondaryDistribsys {
    ForgeTypeId^ get ();
}
static member RbsFamilyContentSecondaryDistribsys : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsFamilyContentTakeoffFixedLength Property

ParameterTypeIdRbsFamilyContentTakeoffFixedLength Property

"Takeoff Fixed Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsFamilyContentTakeoffFixedLength { get; }
Public Shared ReadOnly Property RbsFamilyContentTakeoffFixedLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsFamilyContentTakeoffFixedLength {
    ForgeTypeId^ get ();
}
static member RbsFamilyContentTakeoffFixedLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsFamilyContentTakeoffLength Property

ParameterTypeIdRbsFamilyContentTakeoffLength Property

"Takeoff Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsFamilyContentTakeoffLength { get; }
Public Shared ReadOnly Property RbsFamilyContentTakeoffLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsFamilyContentTakeoffLength {
    ForgeTypeId^ get ();
}
static member RbsFamilyContentTakeoffLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsFamilyContentTakeoffProjlength Property

ParameterTypeIdRbsFamilyContentTakeoffProjlength Property

"Takeoff Length Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsFamilyContentTakeoffProjlength { get; }
Public Shared ReadOnly Property RbsFamilyContentTakeoffProjlength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsFamilyContentTakeoffProjlength {
    ForgeTypeId^ get ();
}
static member RbsFamilyContentTakeoffProjlength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsFlexductRoundtypeParam Property

ParameterTypeIdRbsFlexductRoundtypeParam Property

"Flex Duct Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsFlexductRoundtypeParam { get; }
Public Shared ReadOnly Property RbsFlexductRoundtypeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsFlexductRoundtypeParam {
    ForgeTypeId^ get ();
}
static member RbsFlexductRoundtypeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsFlexDuctTypeParam Property

ParameterTypeIdRbsFlexDuctTypeParam Property

"Flex Duct Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsFlexDuctTypeParam { get; }
Public Shared ReadOnly Property RbsFlexDuctTypeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsFlexDuctTypeParam {
    ForgeTypeId^ get ();
}
static member RbsFlexDuctTypeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsFlexPatternParam Property

ParameterTypeIdRbsFlexPatternParam Property

"Flex Pattern"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsFlexPatternParam { get; }
Public Shared ReadOnly Property RbsFlexPatternParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsFlexPatternParam {
    ForgeTypeId^ get ();
}
static member RbsFlexPatternParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsFlexPipeTypeParam Property

ParameterTypeIdRbsFlexPipeTypeParam Property

"Flex Pipe"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsFlexPipeTypeParam { get; }
Public Shared ReadOnly Property RbsFlexPipeTypeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsFlexPipeTypeParam {
    ForgeTypeId^ get ();
}
static member RbsFlexPipeTypeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsFlowFactorParam Property

ParameterTypeIdRbsFlowFactorParam Property

"Flow Factor"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsFlowFactorParam { get; }
Public Shared ReadOnly Property RbsFlowFactorParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsFlowFactorParam {
    ForgeTypeId^ get ();
}
static member RbsFlowFactorParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsFlowObsolete Property

ParameterTypeIdRbsFlowObsolete Property

"Flow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsFlowObsolete { get; }
Public Shared ReadOnly Property RbsFlowObsolete As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsFlowObsolete {
    ForgeTypeId^ get ();
}
static member RbsFlowObsolete : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsFpSprinklerCoverageParam Property

ParameterTypeIdRbsFpSprinklerCoverageParam Property

"Coverage"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsFpSprinklerCoverageParam { get; }
Public Shared ReadOnly Property RbsFpSprinklerCoverageParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsFpSprinklerCoverageParam {
    ForgeTypeId^ get ();
}
static member RbsFpSprinklerCoverageParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsFpSprinklerKFactorParam Property

ParameterTypeIdRbsFpSprinklerKFactorParam Property

"K-Factor"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsFpSprinklerKFactorParam { get; }
Public Shared ReadOnly Property RbsFpSprinklerKFactorParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsFpSprinklerKFactorParam {
    ForgeTypeId^ get ();
}
static member RbsFpSprinklerKFactorParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsFpSprinklerOrificeParam Property

ParameterTypeIdRbsFpSprinklerOrificeParam Property

"Orifice"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsFpSprinklerOrificeParam { get; }
Public Shared ReadOnly Property RbsFpSprinklerOrificeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsFpSprinklerOrificeParam {
    ForgeTypeId^ get ();
}
static member RbsFpSprinklerOrificeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsFpSprinklerOrificeSizeParam Property

ParameterTypeIdRbsFpSprinklerOrificeSizeParam Property

"Orifice Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsFpSprinklerOrificeSizeParam { get; }
Public Shared ReadOnly Property RbsFpSprinklerOrificeSizeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsFpSprinklerOrificeSizeParam {
    ForgeTypeId^ get ();
}
static member RbsFpSprinklerOrificeSizeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsFpSprinklerPressureClassParam Property

ParameterTypeIdRbsFpSprinklerPressureClassParam Property

"Pressure Class"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsFpSprinklerPressureClassParam { get; }
Public Shared ReadOnly Property RbsFpSprinklerPressureClassParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsFpSprinklerPressureClassParam {
    ForgeTypeId^ get ();
}
static member RbsFpSprinklerPressureClassParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsFpSprinklerResponseParam Property

ParameterTypeIdRbsFpSprinklerResponseParam Property

"Response"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsFpSprinklerResponseParam { get; }
Public Shared ReadOnly Property RbsFpSprinklerResponseParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsFpSprinklerResponseParam {
    ForgeTypeId^ get ();
}
static member RbsFpSprinklerResponseParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsFpSprinklerTemperatureRatingParam Property

ParameterTypeIdRbsFpSprinklerTemperatureRatingParam Property

"Temperature Rating"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsFpSprinklerTemperatureRatingParam { get; }
Public Shared ReadOnly Property RbsFpSprinklerTemperatureRatingParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsFpSprinklerTemperatureRatingParam {
    ForgeTypeId^ get ();
}
static member RbsFpSprinklerTemperatureRatingParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsFriction Property

ParameterTypeIdRbsFriction Property

"Friction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsFriction { get; }
Public Shared ReadOnly Property RbsFriction As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsFriction {
    ForgeTypeId^ get ();
}
static member RbsFriction : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsGbxmlOpeningType Property

ParameterTypeIdRbsGbxmlOpeningType Property

"Opening Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsGbxmlOpeningType { get; }
Public Shared ReadOnly Property RbsGbxmlOpeningType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsGbxmlOpeningType {
    ForgeTypeId^ get ();
}
static member RbsGbxmlOpeningType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsGbxmlSurfaceArea Property

ParameterTypeIdRbsGbxmlSurfaceArea Property

"Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsGbxmlSurfaceArea { get; }
Public Shared ReadOnly Property RbsGbxmlSurfaceArea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsGbxmlSurfaceArea {
    ForgeTypeId^ get ();
}
static member RbsGbxmlSurfaceArea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsGbxmlSurfaceName Property

ParameterTypeIdRbsGbxmlSurfaceName Property

"Surface Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsGbxmlSurfaceName { get; }
Public Shared ReadOnly Property RbsGbxmlSurfaceName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsGbxmlSurfaceName {
    ForgeTypeId^ get ();
}
static member RbsGbxmlSurfaceName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsGbxmlSurfaceType Property

ParameterTypeIdRbsGbxmlSurfaceType Property

"Surface Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsGbxmlSurfaceType { get; }
Public Shared ReadOnly Property RbsGbxmlSurfaceType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsGbxmlSurfaceType {
    ForgeTypeId^ get ();
}
static member RbsGbxmlSurfaceType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsHvacloadDoorAreaParam Property

ParameterTypeIdRbsHvacloadDoorAreaParam Property

"Door Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsHvacloadDoorAreaParam { get; }
Public Shared ReadOnly Property RbsHvacloadDoorAreaParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsHvacloadDoorAreaParam {
    ForgeTypeId^ get ();
}
static member RbsHvacloadDoorAreaParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsHvacloadDoorCoolingLoadParam Property

ParameterTypeIdRbsHvacloadDoorCoolingLoadParam Property

"Door Cooling Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsHvacloadDoorCoolingLoadParam { get; }
Public Shared ReadOnly Property RbsHvacloadDoorCoolingLoadParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsHvacloadDoorCoolingLoadParam {
    ForgeTypeId^ get ();
}
static member RbsHvacloadDoorCoolingLoadParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsHvacloadFloorAreaParam Property

ParameterTypeIdRbsHvacloadFloorAreaParam Property

"Floor Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsHvacloadFloorAreaParam { get; }
Public Shared ReadOnly Property RbsHvacloadFloorAreaParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsHvacloadFloorAreaParam {
    ForgeTypeId^ get ();
}
static member RbsHvacloadFloorAreaParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsHvacloadPartitionAreaParam Property

ParameterTypeIdRbsHvacloadPartitionAreaParam Property

"Partition Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsHvacloadPartitionAreaParam { get; }
Public Shared ReadOnly Property RbsHvacloadPartitionAreaParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsHvacloadPartitionAreaParam {
    ForgeTypeId^ get ();
}
static member RbsHvacloadPartitionAreaParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsHvacloadPartitionCoolingLoadParam Property

ParameterTypeIdRbsHvacloadPartitionCoolingLoadParam Property

"Partition Cooling Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsHvacloadPartitionCoolingLoadParam { get; }
Public Shared ReadOnly Property RbsHvacloadPartitionCoolingLoadParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsHvacloadPartitionCoolingLoadParam {
    ForgeTypeId^ get ();
}
static member RbsHvacloadPartitionCoolingLoadParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsHvacloadPlenumCoolingLoadParam Property

ParameterTypeIdRbsHvacloadPlenumCoolingLoadParam Property

"Plenum Cooling Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsHvacloadPlenumCoolingLoadParam { get; }
Public Shared ReadOnly Property RbsHvacloadPlenumCoolingLoadParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsHvacloadPlenumCoolingLoadParam {
    ForgeTypeId^ get ();
}
static member RbsHvacloadPlenumCoolingLoadParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsHvacloadRoofAreaParam Property

ParameterTypeIdRbsHvacloadRoofAreaParam Property

"Roof Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsHvacloadRoofAreaParam { get; }
Public Shared ReadOnly Property RbsHvacloadRoofAreaParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsHvacloadRoofAreaParam {
    ForgeTypeId^ get ();
}
static member RbsHvacloadRoofAreaParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsHvacloadRoofCoolingLoadParam Property

ParameterTypeIdRbsHvacloadRoofCoolingLoadParam Property

"Roof Cooling Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsHvacloadRoofCoolingLoadParam { get; }
Public Shared ReadOnly Property RbsHvacloadRoofCoolingLoadParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsHvacloadRoofCoolingLoadParam {
    ForgeTypeId^ get ();
}
static member RbsHvacloadRoofCoolingLoadParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsHvacloadSkylightAreaParam Property

ParameterTypeIdRbsHvacloadSkylightAreaParam Property

"Skylight Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsHvacloadSkylightAreaParam { get; }
Public Shared ReadOnly Property RbsHvacloadSkylightAreaParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsHvacloadSkylightAreaParam {
    ForgeTypeId^ get ();
}
static member RbsHvacloadSkylightAreaParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsHvacloadSkylightCoolingLoadParam Property

ParameterTypeIdRbsHvacloadSkylightCoolingLoadParam Property

"Skylight Cooling Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsHvacloadSkylightCoolingLoadParam { get; }
Public Shared ReadOnly Property RbsHvacloadSkylightCoolingLoadParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsHvacloadSkylightCoolingLoadParam {
    ForgeTypeId^ get ();
}
static member RbsHvacloadSkylightCoolingLoadParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsHvacloadWallAreaParam Property

ParameterTypeIdRbsHvacloadWallAreaParam Property

"Wall Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsHvacloadWallAreaParam { get; }
Public Shared ReadOnly Property RbsHvacloadWallAreaParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsHvacloadWallAreaParam {
    ForgeTypeId^ get ();
}
static member RbsHvacloadWallAreaParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsHvacloadWallCoolingLoadParam Property

ParameterTypeIdRbsHvacloadWallCoolingLoadParam Property

"Wall Cooling Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsHvacloadWallCoolingLoadParam { get; }
Public Shared ReadOnly Property RbsHvacloadWallCoolingLoadParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsHvacloadWallCoolingLoadParam {
    ForgeTypeId^ get ();
}
static member RbsHvacloadWallCoolingLoadParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsHvacloadWindowAreaParam Property

ParameterTypeIdRbsHvacloadWindowAreaParam Property

"Window Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsHvacloadWindowAreaParam { get; }
Public Shared ReadOnly Property RbsHvacloadWindowAreaParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsHvacloadWindowAreaParam {
    ForgeTypeId^ get ();
}
static member RbsHvacloadWindowAreaParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsHvacloadWindowCoolingLoadParam Property

ParameterTypeIdRbsHvacloadWindowCoolingLoadParam Property

"Window Cooling Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsHvacloadWindowCoolingLoadParam { get; }
Public Shared ReadOnly Property RbsHvacloadWindowCoolingLoadParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsHvacloadWindowCoolingLoadParam {
    ForgeTypeId^ get ();
}
static member RbsHvacloadWindowCoolingLoadParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsHydraulicDiameterParam Property

ParameterTypeIdRbsHydraulicDiameterParam Property

"Hydraulic Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsHydraulicDiameterParam { get; }
Public Shared ReadOnly Property RbsHydraulicDiameterParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsHydraulicDiameterParam {
    ForgeTypeId^ get ();
}
static member RbsHydraulicDiameterParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsInsulationLiningVolume Property

ParameterTypeIdRbsInsulationLiningVolume Property

"Volume"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsInsulationLiningVolume { get; }
Public Shared ReadOnly Property RbsInsulationLiningVolume As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsInsulationLiningVolume {
    ForgeTypeId^ get ();
}
static member RbsInsulationLiningVolume : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsInsulationThickness Property

ParameterTypeIdRbsInsulationThickness Property

"Insulation Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsInsulationThickness { get; }
Public Shared ReadOnly Property RbsInsulationThickness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsInsulationThickness {
    ForgeTypeId^ get ();
}
static member RbsInsulationThickness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsInsulationThicknessForDuct Property

ParameterTypeIdRbsInsulationThicknessForDuct Property

"Insulation Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsInsulationThicknessForDuct { get; }
Public Shared ReadOnly Property RbsInsulationThicknessForDuct As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsInsulationThicknessForDuct {
    ForgeTypeId^ get ();
}
static member RbsInsulationThicknessForDuct : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsInsulationThicknessForPipe Property

ParameterTypeIdRbsInsulationThicknessForPipe Property

"Insulation Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsInsulationThicknessForPipe { get; }
Public Shared ReadOnly Property RbsInsulationThicknessForPipe As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsInsulationThicknessForPipe {
    ForgeTypeId^ get ();
}
static member RbsInsulationThicknessForPipe : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsIsCustomFitting Property

ParameterTypeIdRbsIsCustomFitting Property

"IsCustom"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsIsCustomFitting { get; }
Public Shared ReadOnly Property RbsIsCustomFitting As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsIsCustomFitting {
    ForgeTypeId^ get ();
}
static member RbsIsCustomFitting : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsLiningThickness Property

ParameterTypeIdRbsLiningThickness Property

"Lining Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsLiningThickness { get; }
Public Shared ReadOnly Property RbsLiningThickness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsLiningThickness {
    ForgeTypeId^ get ();
}
static member RbsLiningThickness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsLiningThicknessForDuct Property

ParameterTypeIdRbsLiningThicknessForDuct Property

"Lining Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsLiningThicknessForDuct { get; }
Public Shared ReadOnly Property RbsLiningThicknessForDuct As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsLiningThicknessForDuct {
    ForgeTypeId^ get ();
}
static member RbsLiningThicknessForDuct : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsLoadSubClassificationMotor Property

ParameterTypeIdRbsLoadSubClassificationMotor Property

"Load Sub-Classification Motor"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsLoadSubClassificationMotor { get; }
Public Shared ReadOnly Property RbsLoadSubClassificationMotor As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsLoadSubClassificationMotor {
    ForgeTypeId^ get ();
}
static member RbsLoadSubClassificationMotor : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsLookupTableName Property

ParameterTypeIdRbsLookupTableName Property

"Lookup Table Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsLookupTableName { get; }
Public Shared ReadOnly Property RbsLookupTableName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsLookupTableName {
    ForgeTypeId^ get ();
}
static member RbsLookupTableName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsLossCoefficient Property

ParameterTypeIdRbsLossCoefficient Property

"Loss Coefficient"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsLossCoefficient { get; }
Public Shared ReadOnly Property RbsLossCoefficient As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsLossCoefficient {
    ForgeTypeId^ get ();
}
static member RbsLossCoefficient : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsMaxFlow Property

ParameterTypeIdRbsMaxFlow Property

"Max Flow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsMaxFlow { get; }
Public Shared ReadOnly Property RbsMaxFlow As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsMaxFlow {
    ForgeTypeId^ get ();
}
static member RbsMaxFlow : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsMinFlow Property

ParameterTypeIdRbsMinFlow Property

"Min Flow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsMinFlow { get; }
Public Shared ReadOnly Property RbsMinFlow As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsMinFlow {
    ForgeTypeId^ get ();
}
static member RbsMinFlow : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsOffsetParam Property

ParameterTypeIdRbsOffsetParam Property

"Middle Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsOffsetParam { get; }
Public Shared ReadOnly Property RbsOffsetParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsOffsetParam {
    ForgeTypeId^ get ();
}
static member RbsOffsetParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPanelScheduleSheetAppearanceInstParam Property

ParameterTypeIdRbsPanelScheduleSheetAppearanceInstParam Property

"Appearance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPanelScheduleSheetAppearanceInstParam { get; }
Public Shared ReadOnly Property RbsPanelScheduleSheetAppearanceInstParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPanelScheduleSheetAppearanceInstParam {
    ForgeTypeId^ get ();
}
static member RbsPanelScheduleSheetAppearanceInstParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPanelScheduleSheetAppearanceParam Property

ParameterTypeIdRbsPanelScheduleSheetAppearanceParam Property

"Appearance On Sheet"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPanelScheduleSheetAppearanceParam { get; }
Public Shared ReadOnly Property RbsPanelScheduleSheetAppearanceParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPanelScheduleSheetAppearanceParam {
    ForgeTypeId^ get ();
}
static member RbsPanelScheduleSheetAppearanceParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsParallelconduitsHorizontalNumber Property

ParameterTypeIdRbsParallelconduitsHorizontalNumber Property

"Horizontal Number for parallel conduits"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsParallelconduitsHorizontalNumber { get; }
Public Shared ReadOnly Property RbsParallelconduitsHorizontalNumber As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsParallelconduitsHorizontalNumber {
    ForgeTypeId^ get ();
}
static member RbsParallelconduitsHorizontalNumber : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsParallelconduitsHorizontalOffsetValue Property

ParameterTypeIdRbsParallelconduitsHorizontalOffsetValue Property

"Horizontal Offset value for parallel conduits"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsParallelconduitsHorizontalOffsetValue { get; }
Public Shared ReadOnly Property RbsParallelconduitsHorizontalOffsetValue As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsParallelconduitsHorizontalOffsetValue {
    ForgeTypeId^ get ();
}
static member RbsParallelconduitsHorizontalOffsetValue : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsParallelconduitsVerticalNumber Property

ParameterTypeIdRbsParallelconduitsVerticalNumber Property

"Vertical Number for parallel conduits"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsParallelconduitsVerticalNumber { get; }
Public Shared ReadOnly Property RbsParallelconduitsVerticalNumber As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsParallelconduitsVerticalNumber {
    ForgeTypeId^ get ();
}
static member RbsParallelconduitsVerticalNumber : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsParallelconduitsVerticalOffsetValue Property

ParameterTypeIdRbsParallelconduitsVerticalOffsetValue Property

"Vertical Offset value for parallel conduits"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsParallelconduitsVerticalOffsetValue { get; }
Public Shared ReadOnly Property RbsParallelconduitsVerticalOffsetValue As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsParallelconduitsVerticalOffsetValue {
    ForgeTypeId^ get ();
}
static member RbsParallelconduitsVerticalOffsetValue : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsParallelpipesHorizontalNumber Property

ParameterTypeIdRbsParallelpipesHorizontalNumber Property

"Horizontal Number for parallel pipes"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsParallelpipesHorizontalNumber { get; }
Public Shared ReadOnly Property RbsParallelpipesHorizontalNumber As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsParallelpipesHorizontalNumber {
    ForgeTypeId^ get ();
}
static member RbsParallelpipesHorizontalNumber : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsParallelpipesHorizontalOffsetValue Property

ParameterTypeIdRbsParallelpipesHorizontalOffsetValue Property

"Horizontal Offset value for parallel pipes"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsParallelpipesHorizontalOffsetValue { get; }
Public Shared ReadOnly Property RbsParallelpipesHorizontalOffsetValue As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsParallelpipesHorizontalOffsetValue {
    ForgeTypeId^ get ();
}
static member RbsParallelpipesHorizontalOffsetValue : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsParallelpipesVerticalNumber Property

ParameterTypeIdRbsParallelpipesVerticalNumber Property

"Vertical Number for parallel pipes"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsParallelpipesVerticalNumber { get; }
Public Shared ReadOnly Property RbsParallelpipesVerticalNumber As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsParallelpipesVerticalNumber {
    ForgeTypeId^ get ();
}
static member RbsParallelpipesVerticalNumber : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsParallelpipesVerticalOffsetValue Property

ParameterTypeIdRbsParallelpipesVerticalOffsetValue Property

"Vertical Offset value for parallel pipes"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsParallelpipesVerticalOffsetValue { get; }
Public Shared ReadOnly Property RbsParallelpipesVerticalOffsetValue As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsParallelpipesVerticalOffsetValue {
    ForgeTypeId^ get ();
}
static member RbsParallelpipesVerticalOffsetValue : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPartType Property

ParameterTypeIdRbsPartType Property

"Part Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPartType { get; }
Public Shared ReadOnly Property RbsPartType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPartType {
    ForgeTypeId^ get ();
}
static member RbsPartType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeAdditionalFlowParam Property

ParameterTypeIdRbsPipeAdditionalFlowParam Property

"Additional Flow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeAdditionalFlowParam { get; }
Public Shared ReadOnly Property RbsPipeAdditionalFlowParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeAdditionalFlowParam {
    ForgeTypeId^ get ();
}
static member RbsPipeAdditionalFlowParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeBottomElevation Property

ParameterTypeIdRbsPipeBottomElevation Property

"Lower End Bottom Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeBottomElevation { get; }
Public Shared ReadOnly Property RbsPipeBottomElevation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeBottomElevation {
    ForgeTypeId^ get ();
}
static member RbsPipeBottomElevation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeCalculatedSize Property

ParameterTypeIdRbsPipeCalculatedSize Property

"Pipe Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeCalculatedSize { get; }
Public Shared ReadOnly Property RbsPipeCalculatedSize As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeCalculatedSize {
    ForgeTypeId^ get ();
}
static member RbsPipeCalculatedSize : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeClassParam Property

ParameterTypeIdRbsPipeClassParam Property

"Schedule/Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeClassParam { get; }
Public Shared ReadOnly Property RbsPipeClassParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeClassParam {
    ForgeTypeId^ get ();
}
static member RbsPipeClassParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeConnectiontypeParam Property

ParameterTypeIdRbsPipeConnectiontypeParam Property

"Connection Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeConnectiontypeParam { get; }
Public Shared ReadOnly Property RbsPipeConnectiontypeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeConnectiontypeParam {
    ForgeTypeId^ get ();
}
static member RbsPipeConnectiontypeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeConnectorSystemClassificationParam Property

ParameterTypeIdRbsPipeConnectorSystemClassificationParam Property

"System Classification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeConnectorSystemClassificationParam { get; }
Public Shared ReadOnly Property RbsPipeConnectorSystemClassificationParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeConnectorSystemClassificationParam {
    ForgeTypeId^ get ();
}
static member RbsPipeConnectorSystemClassificationParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeCwfuParam Property

ParameterTypeIdRbsPipeCwfuParam Property

"CWFU"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeCwfuParam { get; }
Public Shared ReadOnly Property RbsPipeCwfuParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeCwfuParam {
    ForgeTypeId^ get ();
}
static member RbsPipeCwfuParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeDiameterParam Property

ParameterTypeIdRbsPipeDiameterParam Property

"Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeDiameterParam { get; }
Public Shared ReadOnly Property RbsPipeDiameterParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeDiameterParam {
    ForgeTypeId^ get ();
}
static member RbsPipeDiameterParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeFittingLossKfactorParam Property

ParameterTypeIdRbsPipeFittingLossKfactorParam Property

"K Coefficient"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeFittingLossKfactorParam { get; }
Public Shared ReadOnly Property RbsPipeFittingLossKfactorParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeFittingLossKfactorParam {
    ForgeTypeId^ get ();
}
static member RbsPipeFittingLossKfactorParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeFittingLossMethodParam Property

ParameterTypeIdRbsPipeFittingLossMethodParam Property

"Loss Method"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeFittingLossMethodParam { get; }
Public Shared ReadOnly Property RbsPipeFittingLossMethodParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeFittingLossMethodParam {
    ForgeTypeId^ get ();
}
static member RbsPipeFittingLossMethodParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeFittingLossMethodServerParam Property

ParameterTypeIdRbsPipeFittingLossMethodServerParam Property

"Loss Method"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeFittingLossMethodServerParam { get; }
Public Shared ReadOnly Property RbsPipeFittingLossMethodServerParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeFittingLossMethodServerParam {
    ForgeTypeId^ get ();
}
static member RbsPipeFittingLossMethodServerParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeFittingLossMethodSettings Property

ParameterTypeIdRbsPipeFittingLossMethodSettings Property

"Loss Method Settings"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeFittingLossMethodSettings { get; }
Public Shared ReadOnly Property RbsPipeFittingLossMethodSettings As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeFittingLossMethodSettings {
    ForgeTypeId^ get ();
}
static member RbsPipeFittingLossMethodSettings : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeFittingLossTableParam Property

ParameterTypeIdRbsPipeFittingLossTableParam Property

"K Coefficient Table"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeFittingLossTableParam { get; }
Public Shared ReadOnly Property RbsPipeFittingLossTableParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeFittingLossTableParam {
    ForgeTypeId^ get ();
}
static member RbsPipeFittingLossTableParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeFixtureUnitsParam Property

ParameterTypeIdRbsPipeFixtureUnitsParam Property

"Fixture Units"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeFixtureUnitsParam { get; }
Public Shared ReadOnly Property RbsPipeFixtureUnitsParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeFixtureUnitsParam {
    ForgeTypeId^ get ();
}
static member RbsPipeFixtureUnitsParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeFlowConfigurationParam Property

ParameterTypeIdRbsPipeFlowConfigurationParam Property

"Flow Configuration"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeFlowConfigurationParam { get; }
Public Shared ReadOnly Property RbsPipeFlowConfigurationParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeFlowConfigurationParam {
    ForgeTypeId^ get ();
}
static member RbsPipeFlowConfigurationParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeFlowDirectionParam Property

ParameterTypeIdRbsPipeFlowDirectionParam Property

"Flow Direction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeFlowDirectionParam { get; }
Public Shared ReadOnly Property RbsPipeFlowDirectionParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeFlowDirectionParam {
    ForgeTypeId^ get ();
}
static member RbsPipeFlowDirectionParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeFlowParam Property

ParameterTypeIdRbsPipeFlowParam Property

"Flow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeFlowParam { get; }
Public Shared ReadOnly Property RbsPipeFlowParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeFlowParam {
    ForgeTypeId^ get ();
}
static member RbsPipeFlowParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeFlowStateParam Property

ParameterTypeIdRbsPipeFlowStateParam Property

"Flow State"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeFlowStateParam { get; }
Public Shared ReadOnly Property RbsPipeFlowStateParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeFlowStateParam {
    ForgeTypeId^ get ();
}
static member RbsPipeFlowStateParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeFluidDensityParam Property

ParameterTypeIdRbsPipeFluidDensityParam Property

"Fluid Density"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeFluidDensityParam { get; }
Public Shared ReadOnly Property RbsPipeFluidDensityParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeFluidDensityParam {
    ForgeTypeId^ get ();
}
static member RbsPipeFluidDensityParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeFluidTemperatureParam Property

ParameterTypeIdRbsPipeFluidTemperatureParam Property

"Fluid Temperature"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeFluidTemperatureParam { get; }
Public Shared ReadOnly Property RbsPipeFluidTemperatureParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeFluidTemperatureParam {
    ForgeTypeId^ get ();
}
static member RbsPipeFluidTemperatureParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeFluidTypeParam Property

ParameterTypeIdRbsPipeFluidTypeParam Property

"Fluid Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeFluidTypeParam { get; }
Public Shared ReadOnly Property RbsPipeFluidTypeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeFluidTypeParam {
    ForgeTypeId^ get ();
}
static member RbsPipeFluidTypeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeFluidViscosityParam Property

ParameterTypeIdRbsPipeFluidViscosityParam Property

"Fluid Dynamic Viscosity"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeFluidViscosityParam { get; }
Public Shared ReadOnly Property RbsPipeFluidViscosityParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeFluidViscosityParam {
    ForgeTypeId^ get ();
}
static member RbsPipeFluidViscosityParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeFrictionParam Property

ParameterTypeIdRbsPipeFrictionParam Property

"Friction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeFrictionParam { get; }
Public Shared ReadOnly Property RbsPipeFrictionParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeFrictionParam {
    ForgeTypeId^ get ();
}
static member RbsPipeFrictionParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeHwfuParam Property

ParameterTypeIdRbsPipeHwfuParam Property

"HWFU"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeHwfuParam { get; }
Public Shared ReadOnly Property RbsPipeHwfuParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeHwfuParam {
    ForgeTypeId^ get ();
}
static member RbsPipeHwfuParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeInnerDiamParam Property

ParameterTypeIdRbsPipeInnerDiamParam Property

"Inside Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeInnerDiamParam { get; }
Public Shared ReadOnly Property RbsPipeInnerDiamParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeInnerDiamParam {
    ForgeTypeId^ get ();
}
static member RbsPipeInnerDiamParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeInsulationThickness Property

ParameterTypeIdRbsPipeInsulationThickness Property

"Insulation Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeInsulationThickness { get; }
Public Shared ReadOnly Property RbsPipeInsulationThickness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeInsulationThickness {
    ForgeTypeId^ get ();
}
static member RbsPipeInsulationThickness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeInvertElevation Property

ParameterTypeIdRbsPipeInvertElevation Property

"Invert Elevation": This parameter is obsolete. It exists only for compatibility.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeInvertElevation { get; }
Public Shared ReadOnly Property RbsPipeInvertElevation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeInvertElevation {
    ForgeTypeId^ get ();
}
static member RbsPipeInvertElevation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeJointtypeParam Property

ParameterTypeIdRbsPipeJointtypeParam Property

"Connection Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeJointtypeParam { get; }
Public Shared ReadOnly Property RbsPipeJointtypeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeJointtypeParam {
    ForgeTypeId^ get ();
}
static member RbsPipeJointtypeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeMaterialParam Property

ParameterTypeIdRbsPipeMaterialParam Property

"Material"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeMaterialParam { get; }
Public Shared ReadOnly Property RbsPipeMaterialParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeMaterialParam {
    ForgeTypeId^ get ();
}
static member RbsPipeMaterialParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeOuterDiameter Property

ParameterTypeIdRbsPipeOuterDiameter Property

"Outside Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeOuterDiameter { get; }
Public Shared ReadOnly Property RbsPipeOuterDiameter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeOuterDiameter {
    ForgeTypeId^ get ();
}
static member RbsPipeOuterDiameter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipePressuredropParam Property

ParameterTypeIdRbsPipePressuredropParam Property

"Pressure Drop"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipePressuredropParam { get; }
Public Shared ReadOnly Property RbsPipePressuredropParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipePressuredropParam {
    ForgeTypeId^ get ();
}
static member RbsPipePressuredropParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeReynoldsNumberParam Property

ParameterTypeIdRbsPipeReynoldsNumberParam Property

"Reynolds Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeReynoldsNumberParam { get; }
Public Shared ReadOnly Property RbsPipeReynoldsNumberParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeReynoldsNumberParam {
    ForgeTypeId^ get ();
}
static member RbsPipeReynoldsNumberParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeSegmentParam Property

ParameterTypeIdRbsPipeSegmentParam Property

"Pipe Segment"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeSegmentParam { get; }
Public Shared ReadOnly Property RbsPipeSegmentParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeSegmentParam {
    ForgeTypeId^ get ();
}
static member RbsPipeSegmentParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeSizeFormattedParam Property

ParameterTypeIdRbsPipeSizeFormattedParam Property

"Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeSizeFormattedParam { get; }
Public Shared ReadOnly Property RbsPipeSizeFormattedParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeSizeFormattedParam {
    ForgeTypeId^ get ();
}
static member RbsPipeSizeFormattedParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeSizeMaximum Property

ParameterTypeIdRbsPipeSizeMaximum Property

"Maximum Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeSizeMaximum { get; }
Public Shared ReadOnly Property RbsPipeSizeMaximum As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeSizeMaximum {
    ForgeTypeId^ get ();
}
static member RbsPipeSizeMaximum : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeSizeMinimum Property

ParameterTypeIdRbsPipeSizeMinimum Property

"Minimum Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeSizeMinimum { get; }
Public Shared ReadOnly Property RbsPipeSizeMinimum As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeSizeMinimum {
    ForgeTypeId^ get ();
}
static member RbsPipeSizeMinimum : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeSlope Property

ParameterTypeIdRbsPipeSlope Property

"Slope"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeSlope { get; }
Public Shared ReadOnly Property RbsPipeSlope As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeSlope {
    ForgeTypeId^ get ();
}
static member RbsPipeSlope : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeSlopeDefParam Property

ParameterTypeIdRbsPipeSlopeDefParam Property

"Pipe Slope Definitions"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeSlopeDefParam { get; }
Public Shared ReadOnly Property RbsPipeSlopeDefParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeSlopeDefParam {
    ForgeTypeId^ get ();
}
static member RbsPipeSlopeDefParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeSlopeOptionsDefParam Property

ParameterTypeIdRbsPipeSlopeOptionsDefParam Property

"Pipe Slope Options"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeSlopeOptionsDefParam { get; }
Public Shared ReadOnly Property RbsPipeSlopeOptionsDefParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeSlopeOptionsDefParam {
    ForgeTypeId^ get ();
}
static member RbsPipeSlopeOptionsDefParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeStaticPressure Property

ParameterTypeIdRbsPipeStaticPressure Property

"Static Pressure"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeStaticPressure { get; }
Public Shared ReadOnly Property RbsPipeStaticPressure As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeStaticPressure {
    ForgeTypeId^ get ();
}
static member RbsPipeStaticPressure : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeSystemCalculationParam Property

ParameterTypeIdRbsPipeSystemCalculationParam Property

"Calculations"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeSystemCalculationParam { get; }
Public Shared ReadOnly Property RbsPipeSystemCalculationParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeSystemCalculationParam {
    ForgeTypeId^ get ();
}
static member RbsPipeSystemCalculationParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeSystemFixtureUnitParam Property

ParameterTypeIdRbsPipeSystemFixtureUnitParam Property

"Fixture Units"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeSystemFixtureUnitParam { get; }
Public Shared ReadOnly Property RbsPipeSystemFixtureUnitParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeSystemFixtureUnitParam {
    ForgeTypeId^ get ();
}
static member RbsPipeSystemFixtureUnitParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeTopElevation Property

ParameterTypeIdRbsPipeTopElevation Property

"Upper End Top Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeTopElevation { get; }
Public Shared ReadOnly Property RbsPipeTopElevation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeTopElevation {
    ForgeTypeId^ get ();
}
static member RbsPipeTopElevation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeTypeFittingLossKfactorParam Property

ParameterTypeIdRbsPipeTypeFittingLossKfactorParam Property

"K Coefficient"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeTypeFittingLossKfactorParam { get; }
Public Shared ReadOnly Property RbsPipeTypeFittingLossKfactorParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeTypeFittingLossKfactorParam {
    ForgeTypeId^ get ();
}
static member RbsPipeTypeFittingLossKfactorParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeTypeFittingLossMethodParam Property

ParameterTypeIdRbsPipeTypeFittingLossMethodParam Property

"Loss Method"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeTypeFittingLossMethodParam { get; }
Public Shared ReadOnly Property RbsPipeTypeFittingLossMethodParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeTypeFittingLossMethodParam {
    ForgeTypeId^ get ();
}
static member RbsPipeTypeFittingLossMethodParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeTypeFittingLossTableParam Property

ParameterTypeIdRbsPipeTypeFittingLossTableParam Property

"K Coefficient Table"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeTypeFittingLossTableParam { get; }
Public Shared ReadOnly Property RbsPipeTypeFittingLossTableParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeTypeFittingLossTableParam {
    ForgeTypeId^ get ();
}
static member RbsPipeTypeFittingLossTableParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeTypeParam Property

ParameterTypeIdRbsPipeTypeParam Property

"Pipe Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeTypeParam { get; }
Public Shared ReadOnly Property RbsPipeTypeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeTypeParam {
    ForgeTypeId^ get ();
}
static member RbsPipeTypeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeTypeValveLossCvfactorParam Property

ParameterTypeIdRbsPipeTypeValveLossCvfactorParam Property

"Cv Coefficient"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeTypeValveLossCvfactorParam { get; }
Public Shared ReadOnly Property RbsPipeTypeValveLossCvfactorParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeTypeValveLossCvfactorParam {
    ForgeTypeId^ get ();
}
static member RbsPipeTypeValveLossCvfactorParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeValveLossCvfactorParam Property

ParameterTypeIdRbsPipeValveLossCvfactorParam Property

"Cv Coefficient"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeValveLossCvfactorParam { get; }
Public Shared ReadOnly Property RbsPipeValveLossCvfactorParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeValveLossCvfactorParam {
    ForgeTypeId^ get ();
}
static member RbsPipeValveLossCvfactorParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeVelocityParam Property

ParameterTypeIdRbsPipeVelocityParam Property

"Velocity"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeVelocityParam { get; }
Public Shared ReadOnly Property RbsPipeVelocityParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeVelocityParam {
    ForgeTypeId^ get ();
}
static member RbsPipeVelocityParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeVolumeParam Property

ParameterTypeIdRbsPipeVolumeParam Property

"Volume"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeVolumeParam { get; }
Public Shared ReadOnly Property RbsPipeVolumeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeVolumeParam {
    ForgeTypeId^ get ();
}
static member RbsPipeVolumeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeWallThickness Property

ParameterTypeIdRbsPipeWallThickness Property

"Wall Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeWallThickness { get; }
Public Shared ReadOnly Property RbsPipeWallThickness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeWallThickness {
    ForgeTypeId^ get ();
}
static member RbsPipeWallThickness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipeWfuParam Property

ParameterTypeIdRbsPipeWfuParam Property

"WFU"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipeWfuParam { get; }
Public Shared ReadOnly Property RbsPipeWfuParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipeWfuParam {
    ForgeTypeId^ get ();
}
static member RbsPipeWfuParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPipingSystemTypeParam Property

ParameterTypeIdRbsPipingSystemTypeParam Property

"System Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPipingSystemTypeParam { get; }
Public Shared ReadOnly Property RbsPipingSystemTypeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPipingSystemTypeParam {
    ForgeTypeId^ get ();
}
static member RbsPipingSystemTypeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsPressureDrop Property

ParameterTypeIdRbsPressureDrop Property

"Pressure Drop"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsPressureDrop { get; }
Public Shared ReadOnly Property RbsPressureDrop As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsPressureDrop {
    ForgeTypeId^ get ();
}
static member RbsPressureDrop : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsProjectConstructionTypeShadingfactorParam Property

ParameterTypeIdRbsProjectConstructionTypeShadingfactorParam Property

"Internal Shading Factor"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsProjectConstructionTypeShadingfactorParam { get; }
Public Shared ReadOnly Property RbsProjectConstructionTypeShadingfactorParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsProjectConstructionTypeShadingfactorParam {
    ForgeTypeId^ get ();
}
static member RbsProjectConstructionTypeShadingfactorParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsProjectLocationParam Property

ParameterTypeIdRbsProjectLocationParam Property

"Location"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsProjectLocationParam { get; }
Public Shared ReadOnly Property RbsProjectLocationParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsProjectLocationParam {
    ForgeTypeId^ get ();
}
static member RbsProjectLocationParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsProjectReporttypeParam Property

ParameterTypeIdRbsProjectReporttypeParam Property

"Report Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsProjectReporttypeParam { get; }
Public Shared ReadOnly Property RbsProjectReporttypeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsProjectReporttypeParam {
    ForgeTypeId^ get ();
}
static member RbsProjectReporttypeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsReferenceFreesize Property

ParameterTypeIdRbsReferenceFreesize Property

"Free Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsReferenceFreesize { get; }
Public Shared ReadOnly Property RbsReferenceFreesize As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsReferenceFreesize {
    ForgeTypeId^ get ();
}
static member RbsReferenceFreesize : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsReferenceInsulationThickness Property

ParameterTypeIdRbsReferenceInsulationThickness Property

"Insulation Thickness": This parameter is obsolete. Use DUCT_INSULATION_THICKNESS and PIPE_INSULATION_THICKNESS.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsReferenceInsulationThickness { get; }
Public Shared ReadOnly Property RbsReferenceInsulationThickness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsReferenceInsulationThickness {
    ForgeTypeId^ get ();
}
static member RbsReferenceInsulationThickness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsReferenceInsulationType Property

ParameterTypeIdRbsReferenceInsulationType Property

"Insulation Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsReferenceInsulationType { get; }
Public Shared ReadOnly Property RbsReferenceInsulationType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsReferenceInsulationType {
    ForgeTypeId^ get ();
}
static member RbsReferenceInsulationType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsReferenceLiningThickness Property

ParameterTypeIdRbsReferenceLiningThickness Property

"Lining Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsReferenceLiningThickness { get; }
Public Shared ReadOnly Property RbsReferenceLiningThickness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsReferenceLiningThickness {
    ForgeTypeId^ get ();
}
static member RbsReferenceLiningThickness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsReferenceLiningType Property

ParameterTypeIdRbsReferenceLiningType Property

"Lining Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsReferenceLiningType { get; }
Public Shared ReadOnly Property RbsReferenceLiningType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsReferenceLiningType {
    ForgeTypeId^ get ();
}
static member RbsReferenceLiningType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsReferenceOverallsize Property

ParameterTypeIdRbsReferenceOverallsize Property

"Overall Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsReferenceOverallsize { get; }
Public Shared ReadOnly Property RbsReferenceOverallsize As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsReferenceOverallsize {
    ForgeTypeId^ get ();
}
static member RbsReferenceOverallsize : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsReynoldsnumberParam Property

ParameterTypeIdRbsReynoldsnumberParam Property

"Reynolds number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsReynoldsnumberParam { get; }
Public Shared ReadOnly Property RbsReynoldsnumberParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsReynoldsnumberParam {
    ForgeTypeId^ get ();
}
static member RbsReynoldsnumberParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsRoomCoefficientUtilization Property

ParameterTypeIdRbsRoomCoefficientUtilization Property

"Coefficient of Utilization"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsRoomCoefficientUtilization { get; }
Public Shared ReadOnly Property RbsRoomCoefficientUtilization As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsRoomCoefficientUtilization {
    ForgeTypeId^ get ();
}
static member RbsRoomCoefficientUtilization : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsRoutingPreferenceParam Property

ParameterTypeIdRbsRoutingPreferenceParam Property

"Routing Preferences"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsRoutingPreferenceParam { get; }
Public Shared ReadOnly Property RbsRoutingPreferenceParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsRoutingPreferenceParam {
    ForgeTypeId^ get ();
}
static member RbsRoutingPreferenceParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsSection Property

ParameterTypeIdRbsSection Property

"Section"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsSection { get; }
Public Shared ReadOnly Property RbsSection As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsSection {
    ForgeTypeId^ get ();
}
static member RbsSection : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsSegmentDescriptionParam Property

ParameterTypeIdRbsSegmentDescriptionParam Property

"Segment Description"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsSegmentDescriptionParam { get; }
Public Shared ReadOnly Property RbsSegmentDescriptionParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsSegmentDescriptionParam {
    ForgeTypeId^ get ();
}
static member RbsSegmentDescriptionParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsServiceTypeParam Property

ParameterTypeIdRbsServiceTypeParam Property

"Building Service"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsServiceTypeParam { get; }
Public Shared ReadOnly Property RbsServiceTypeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsServiceTypeParam {
    ForgeTypeId^ get ();
}
static member RbsServiceTypeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsShowProfileType Property

ParameterTypeIdRbsShowProfileType Property

"Show Round"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsShowProfileType { get; }
Public Shared ReadOnly Property RbsShowProfileType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsShowProfileType {
    ForgeTypeId^ get ();
}
static member RbsShowProfileType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsSizeLock Property

ParameterTypeIdRbsSizeLock Property

"Size Lock"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsSizeLock { get; }
Public Shared ReadOnly Property RbsSizeLock As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsSizeLock {
    ForgeTypeId^ get ();
}
static member RbsSizeLock : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsStartLevelParam Property

ParameterTypeIdRbsStartLevelParam Property

"Reference Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsStartLevelParam { get; }
Public Shared ReadOnly Property RbsStartLevelParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsStartLevelParam {
    ForgeTypeId^ get ();
}
static member RbsStartLevelParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsStartOffsetParam Property

ParameterTypeIdRbsStartOffsetParam Property

"Start Middle Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsStartOffsetParam { get; }
Public Shared ReadOnly Property RbsStartOffsetParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsStartOffsetParam {
    ForgeTypeId^ get ();
}
static member RbsStartOffsetParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsSystemAbbreviationParam Property

ParameterTypeIdRbsSystemAbbreviationParam Property

"Abbreviation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsSystemAbbreviationParam { get; }
Public Shared ReadOnly Property RbsSystemAbbreviationParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsSystemAbbreviationParam {
    ForgeTypeId^ get ();
}
static member RbsSystemAbbreviationParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsSystemBaseElementParam Property

ParameterTypeIdRbsSystemBaseElementParam Property

"System Equipment"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsSystemBaseElementParam { get; }
Public Shared ReadOnly Property RbsSystemBaseElementParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsSystemBaseElementParam {
    ForgeTypeId^ get ();
}
static member RbsSystemBaseElementParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsSystemClassificationParam Property

ParameterTypeIdRbsSystemClassificationParam Property

"System Classification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsSystemClassificationParam { get; }
Public Shared ReadOnly Property RbsSystemClassificationParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsSystemClassificationParam {
    ForgeTypeId^ get ();
}
static member RbsSystemClassificationParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsSystemFlowConversionMethodParam Property

ParameterTypeIdRbsSystemFlowConversionMethodParam Property

"Flow Conversion Method"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsSystemFlowConversionMethodParam { get; }
Public Shared ReadOnly Property RbsSystemFlowConversionMethodParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsSystemFlowConversionMethodParam {
    ForgeTypeId^ get ();
}
static member RbsSystemFlowConversionMethodParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsSystemNameParam Property

ParameterTypeIdRbsSystemNameParam Property

"System Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsSystemNameParam { get; }
Public Shared ReadOnly Property RbsSystemNameParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsSystemNameParam {
    ForgeTypeId^ get ();
}
static member RbsSystemNameParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsSystemNumElementsParam Property

ParameterTypeIdRbsSystemNumElementsParam Property

"Number of Elements"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsSystemNumElementsParam { get; }
Public Shared ReadOnly Property RbsSystemNumElementsParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsSystemNumElementsParam {
    ForgeTypeId^ get ();
}
static member RbsSystemNumElementsParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsSystemRisedrop1linedropsymbolParam Property

ParameterTypeIdRbsSystemRisedrop1linedropsymbolParam Property

"Single Line Drop Symbol"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsSystemRisedrop1linedropsymbolParam { get; }
Public Shared ReadOnly Property RbsSystemRisedrop1linedropsymbolParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsSystemRisedrop1linedropsymbolParam {
    ForgeTypeId^ get ();
}
static member RbsSystemRisedrop1linedropsymbolParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsSystemRisedrop1linerisesymbolParam Property

ParameterTypeIdRbsSystemRisedrop1linerisesymbolParam Property

"Single Line Rise Symbol"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsSystemRisedrop1linerisesymbolParam { get; }
Public Shared ReadOnly Property RbsSystemRisedrop1linerisesymbolParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsSystemRisedrop1linerisesymbolParam {
    ForgeTypeId^ get ();
}
static member RbsSystemRisedrop1linerisesymbolParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsSystemRisedrop1lineteedownsymbolParam Property

ParameterTypeIdRbsSystemRisedrop1lineteedownsymbolParam Property

"Single Line Tee Down Symbol"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsSystemRisedrop1lineteedownsymbolParam { get; }
Public Shared ReadOnly Property RbsSystemRisedrop1lineteedownsymbolParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsSystemRisedrop1lineteedownsymbolParam {
    ForgeTypeId^ get ();
}
static member RbsSystemRisedrop1lineteedownsymbolParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsSystemRisedrop1lineteeupsymbolParam Property

ParameterTypeIdRbsSystemRisedrop1lineteeupsymbolParam Property

"Single Line Tee Up Symbol"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsSystemRisedrop1lineteeupsymbolParam { get; }
Public Shared ReadOnly Property RbsSystemRisedrop1lineteeupsymbolParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsSystemRisedrop1lineteeupsymbolParam {
    ForgeTypeId^ get ();
}
static member RbsSystemRisedrop1lineteeupsymbolParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsSystemRisedrop2linedropsymbolParam Property

ParameterTypeIdRbsSystemRisedrop2linedropsymbolParam Property

"Two Line Drop Symbol"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsSystemRisedrop2linedropsymbolParam { get; }
Public Shared ReadOnly Property RbsSystemRisedrop2linedropsymbolParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsSystemRisedrop2linedropsymbolParam {
    ForgeTypeId^ get ();
}
static member RbsSystemRisedrop2linedropsymbolParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsSystemRisedrop2linerisesymbolParam Property

ParameterTypeIdRbsSystemRisedrop2linerisesymbolParam Property

"Two Line Rise Symbol"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsSystemRisedrop2linerisesymbolParam { get; }
Public Shared ReadOnly Property RbsSystemRisedrop2linerisesymbolParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsSystemRisedrop2linerisesymbolParam {
    ForgeTypeId^ get ();
}
static member RbsSystemRisedrop2linerisesymbolParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsSystemRisedropParam Property

ParameterTypeIdRbsSystemRisedropParam Property

"Rise / Drop Symbol"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsSystemRisedropParam { get; }
Public Shared ReadOnly Property RbsSystemRisedropParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsSystemRisedropParam {
    ForgeTypeId^ get ();
}
static member RbsSystemRisedropParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsVelocity Property

ParameterTypeIdRbsVelocity Property

"Velocity"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsVelocity { get; }
Public Shared ReadOnly Property RbsVelocity As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsVelocity {
    ForgeTypeId^ get ();
}
static member RbsVelocity : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsVelocityPressure Property

ParameterTypeIdRbsVelocityPressure Property

"Velocity Pressure"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsVelocityPressure { get; }
Public Shared ReadOnly Property RbsVelocityPressure As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsVelocityPressure {
    ForgeTypeId^ get ();
}
static member RbsVelocityPressure : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsVoltagetypeMaxvoltageParam Property

ParameterTypeIdRbsVoltagetypeMaxvoltageParam Property

"Maximum Voltage"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsVoltagetypeMaxvoltageParam { get; }
Public Shared ReadOnly Property RbsVoltagetypeMaxvoltageParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsVoltagetypeMaxvoltageParam {
    ForgeTypeId^ get ();
}
static member RbsVoltagetypeMaxvoltageParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsVoltagetypeMinvoltageParam Property

ParameterTypeIdRbsVoltagetypeMinvoltageParam Property

"Minimum Voltage"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsVoltagetypeMinvoltageParam { get; }
Public Shared ReadOnly Property RbsVoltagetypeMinvoltageParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsVoltagetypeMinvoltageParam {
    ForgeTypeId^ get ();
}
static member RbsVoltagetypeMinvoltageParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsVoltagetypeVoltageParam Property

ParameterTypeIdRbsVoltagetypeVoltageParam Property

"Actual Voltage"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsVoltagetypeVoltageParam { get; }
Public Shared ReadOnly Property RbsVoltagetypeVoltageParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsVoltagetypeVoltageParam {
    ForgeTypeId^ get ();
}
static member RbsVoltagetypeVoltageParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsWireCircuitDescription Property

ParameterTypeIdRbsWireCircuitDescription Property

"Circuit Description"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsWireCircuitDescription { get; }
Public Shared ReadOnly Property RbsWireCircuitDescription As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsWireCircuitDescription {
    ForgeTypeId^ get ();
}
static member RbsWireCircuitDescription : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsWireCircuitLoadName Property

ParameterTypeIdRbsWireCircuitLoadName Property

"Circuit Load Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsWireCircuitLoadName { get; }
Public Shared ReadOnly Property RbsWireCircuitLoadName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsWireCircuitLoadName {
    ForgeTypeId^ get ();
}
static member RbsWireCircuitLoadName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsWireConduitTypeParam Property

ParameterTypeIdRbsWireConduitTypeParam Property

"Conduit Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsWireConduitTypeParam { get; }
Public Shared ReadOnly Property RbsWireConduitTypeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsWireConduitTypeParam {
    ForgeTypeId^ get ();
}
static member RbsWireConduitTypeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsWireInsulationParam Property

ParameterTypeIdRbsWireInsulationParam Property

"Insulation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsWireInsulationParam { get; }
Public Shared ReadOnly Property RbsWireInsulationParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsWireInsulationParam {
    ForgeTypeId^ get ();
}
static member RbsWireInsulationParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsWireMaterialParam Property

ParameterTypeIdRbsWireMaterialParam Property

"Material"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsWireMaterialParam { get; }
Public Shared ReadOnly Property RbsWireMaterialParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsWireMaterialParam {
    ForgeTypeId^ get ();
}
static member RbsWireMaterialParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsWireMaxConductorSizeParam Property

ParameterTypeIdRbsWireMaxConductorSizeParam Property

"Max Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsWireMaxConductorSizeParam { get; }
Public Shared ReadOnly Property RbsWireMaxConductorSizeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsWireMaxConductorSizeParam {
    ForgeTypeId^ get ();
}
static member RbsWireMaxConductorSizeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsWireNeutralIncludedInBalancedLoadParam Property

ParameterTypeIdRbsWireNeutralIncludedInBalancedLoadParam Property

"Neutral Included in Balanced Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsWireNeutralIncludedInBalancedLoadParam { get; }
Public Shared ReadOnly Property RbsWireNeutralIncludedInBalancedLoadParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsWireNeutralIncludedInBalancedLoadParam {
    ForgeTypeId^ get ();
}
static member RbsWireNeutralIncludedInBalancedLoadParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsWireNeutralModeParam Property

ParameterTypeIdRbsWireNeutralModeParam Property

"Neutral Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsWireNeutralModeParam { get; }
Public Shared ReadOnly Property RbsWireNeutralModeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsWireNeutralModeParam {
    ForgeTypeId^ get ();
}
static member RbsWireNeutralModeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsWireNeutralMultiplierParam Property

ParameterTypeIdRbsWireNeutralMultiplierParam Property

"Neutral Multiplier"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsWireNeutralMultiplierParam { get; }
Public Shared ReadOnly Property RbsWireNeutralMultiplierParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsWireNeutralMultiplierParam {
    ForgeTypeId^ get ();
}
static member RbsWireNeutralMultiplierParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsWireNumConductorsParam Property

ParameterTypeIdRbsWireNumConductorsParam Property

"Number of Conductors"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsWireNumConductorsParam { get; }
Public Shared ReadOnly Property RbsWireNumConductorsParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsWireNumConductorsParam {
    ForgeTypeId^ get ();
}
static member RbsWireNumConductorsParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RbsWireTemperatureRatingParam Property

ParameterTypeIdRbsWireTemperatureRatingParam Property

"Temperature Rating"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RbsWireTemperatureRatingParam { get; }
Public Shared ReadOnly Property RbsWireTemperatureRatingParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RbsWireTemperatureRatingParam {
    ForgeTypeId^ get ();
}
static member RbsWireTemperatureRatingParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarAlignmentOptions Property

ParameterTypeIdRebarAlignmentOptions Property

"Bar Alignment"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarAlignmentOptions { get; }
Public Shared ReadOnly Property RebarAlignmentOptions As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarAlignmentOptions {
    ForgeTypeId^ get ();
}
static member RebarAlignmentOptions : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarBarDeformationType Property

ParameterTypeIdRebarBarDeformationType Property

"Deformation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarBarDeformationType { get; }
Public Shared ReadOnly Property RebarBarDeformationType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarBarDeformationType {
    ForgeTypeId^ get ();
}
static member RebarBarDeformationType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarBarDiameter Property

ParameterTypeIdRebarBarDiameter Property

"Bar Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarBarDiameter { get; }
Public Shared ReadOnly Property RebarBarDiameter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarBarDiameter {
    ForgeTypeId^ get ();
}
static member RebarBarDiameter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarBarHookLengths Property

ParameterTypeIdRebarBarHookLengths Property

"Hook Lengths"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarBarHookLengths { get; }
Public Shared ReadOnly Property RebarBarHookLengths As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarBarHookLengths {
    ForgeTypeId^ get ();
}
static member RebarBarHookLengths : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarBarMaximumBendRadius Property

ParameterTypeIdRebarBarMaximumBendRadius Property

"Maximum Bend Radius"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarBarMaximumBendRadius { get; }
Public Shared ReadOnly Property RebarBarMaximumBendRadius As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarBarMaximumBendRadius {
    ForgeTypeId^ get ();
}
static member RebarBarMaximumBendRadius : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarBarSpliceLengths Property

ParameterTypeIdRebarBarSpliceLengths Property

"Splice Lengths"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarBarSpliceLengths { get; }
Public Shared ReadOnly Property RebarBarSpliceLengths As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarBarSpliceLengths {
    ForgeTypeId^ get ();
}
static member RebarBarSpliceLengths : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarBarStirrupBendDiameter Property

ParameterTypeIdRebarBarStirrupBendDiameter Property

"Stirrup/Tie Bend Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarBarStirrupBendDiameter { get; }
Public Shared ReadOnly Property RebarBarStirrupBendDiameter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarBarStirrupBendDiameter {
    ForgeTypeId^ get ();
}
static member RebarBarStirrupBendDiameter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarBarStyle Property

ParameterTypeIdRebarBarStyle Property

"Subcategory"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarBarStyle { get; }
Public Shared ReadOnly Property RebarBarStyle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarBarStyle {
    ForgeTypeId^ get ();
}
static member RebarBarStyle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarConstraintsStatus Property

ParameterTypeIdRebarConstraintsStatus Property

"Rebar Constraint Status"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarConstraintsStatus { get; }
Public Shared ReadOnly Property RebarConstraintsStatus As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarConstraintsStatus {
    ForgeTypeId^ get ();
}
static member RebarConstraintsStatus : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarContainerBarType Property

ParameterTypeIdRebarContainerBarType Property

"Bar Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarContainerBarType { get; }
Public Shared ReadOnly Property RebarContainerBarType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarContainerBarType {
    ForgeTypeId^ get ();
}
static member RebarContainerBarType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarDistributionType Property

ParameterTypeIdRebarDistributionType Property

"Distribution Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarDistributionType { get; }
Public Shared ReadOnly Property RebarDistributionType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarDistributionType {
    ForgeTypeId^ get ();
}
static member RebarDistributionType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarElemBarSpacing Property

ParameterTypeIdRebarElemBarSpacing Property

"Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarElemBarSpacing { get; }
Public Shared ReadOnly Property RebarElemBarSpacing As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarElemBarSpacing {
    ForgeTypeId^ get ();
}
static member RebarElemBarSpacing : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarElemEndtreatmentEnd Property

ParameterTypeIdRebarElemEndtreatmentEnd Property

"End Treatment At End"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarElemEndtreatmentEnd { get; }
Public Shared ReadOnly Property RebarElemEndtreatmentEnd As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarElemEndtreatmentEnd {
    ForgeTypeId^ get ();
}
static member RebarElemEndtreatmentEnd : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarElemEndtreatmentStart Property

ParameterTypeIdRebarElemEndtreatmentStart Property

"End Treatment At Start"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarElemEndtreatmentStart { get; }
Public Shared ReadOnly Property RebarElemEndtreatmentStart As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarElemEndtreatmentStart {
    ForgeTypeId^ get ();
}
static member RebarElemEndtreatmentStart : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarElementRounding Property

ParameterTypeIdRebarElementRounding Property

"Rounding Overrides"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarElementRounding { get; }
Public Shared ReadOnly Property RebarElementRounding As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarElementRounding {
    ForgeTypeId^ get ();
}
static member RebarElementRounding : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarElementVisibility Property

ParameterTypeIdRebarElementVisibility Property

"View Visibility States"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarElementVisibility { get; }
Public Shared ReadOnly Property RebarElementVisibility As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarElementVisibility {
    ForgeTypeId^ get ();
}
static member RebarElementVisibility : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarElemHookEndOrient Property

ParameterTypeIdRebarElemHookEndOrient Property

"Hook Orientation At End"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarElemHookEndOrient { get; }
Public Shared ReadOnly Property RebarElemHookEndOrient As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarElemHookEndOrient {
    ForgeTypeId^ get ();
}
static member RebarElemHookEndOrient : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarElemHookEndType Property

ParameterTypeIdRebarElemHookEndType Property

"Hook At End"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarElemHookEndType { get; }
Public Shared ReadOnly Property RebarElemHookEndType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarElemHookEndType {
    ForgeTypeId^ get ();
}
static member RebarElemHookEndType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarElemHookStartOrient Property

ParameterTypeIdRebarElemHookStartOrient Property

"Hook Orientation At Start"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarElemHookStartOrient { get; }
Public Shared ReadOnly Property RebarElemHookStartOrient As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarElemHookStartOrient {
    ForgeTypeId^ get ();
}
static member RebarElemHookStartOrient : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarElemHookStartType Property

ParameterTypeIdRebarElemHookStartType Property

"Hook At Start"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarElemHookStartType { get; }
Public Shared ReadOnly Property RebarElemHookStartType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarElemHookStartType {
    ForgeTypeId^ get ();
}
static member RebarElemHookStartType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarElemHookStyle Property

ParameterTypeIdRebarElemHookStyle Property

"Style"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarElemHookStyle { get; }
Public Shared ReadOnly Property RebarElemHookStyle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarElemHookStyle {
    ForgeTypeId^ get ();
}
static member RebarElemHookStyle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarElemHostMark Property

ParameterTypeIdRebarElemHostMark Property

"Host Mark"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarElemHostMark { get; }
Public Shared ReadOnly Property RebarElemHostMark As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarElemHostMark {
    ForgeTypeId^ get ();
}
static member RebarElemHostMark : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarElemLayoutRule Property

ParameterTypeIdRebarElemLayoutRule Property

"Layout Rule"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarElemLayoutRule { get; }
Public Shared ReadOnly Property RebarElemLayoutRule As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarElemLayoutRule {
    ForgeTypeId^ get ();
}
static member RebarElemLayoutRule : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarElemLength Property

ParameterTypeIdRebarElemLength Property

"Bar Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarElemLength { get; }
Public Shared ReadOnly Property RebarElemLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarElemLength {
    ForgeTypeId^ get ();
}
static member RebarElemLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarElemQuantityOfBars Property

ParameterTypeIdRebarElemQuantityOfBars Property

"Quantity"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarElemQuantityOfBars { get; }
Public Shared ReadOnly Property RebarElemQuantityOfBars As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarElemQuantityOfBars {
    ForgeTypeId^ get ();
}
static member RebarElemQuantityOfBars : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarElemScheduleMark Property

ParameterTypeIdRebarElemScheduleMark Property

"Schedule Mark"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarElemScheduleMark { get; }
Public Shared ReadOnly Property RebarElemScheduleMark As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarElemScheduleMark {
    ForgeTypeId^ get ();
}
static member RebarElemScheduleMark : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarElemTotalLength Property

ParameterTypeIdRebarElemTotalLength Property

"Total Bar Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarElemTotalLength { get; }
Public Shared ReadOnly Property RebarElemTotalLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarElemTotalLength {
    ForgeTypeId^ get ();
}
static member RebarElemTotalLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarFreeFormHookEndPlaneAngle Property

ParameterTypeIdRebarFreeFormHookEndPlaneAngle Property

"Hook Orientation At End"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarFreeFormHookEndPlaneAngle { get; }
Public Shared ReadOnly Property RebarFreeFormHookEndPlaneAngle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarFreeFormHookEndPlaneAngle {
    ForgeTypeId^ get ();
}
static member RebarFreeFormHookEndPlaneAngle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarFreeFormHookStartPlaneAngle Property

ParameterTypeIdRebarFreeFormHookStartPlaneAngle Property

"Hook Orientation At Start"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarFreeFormHookStartPlaneAngle { get; }
Public Shared ReadOnly Property RebarFreeFormHookStartPlaneAngle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarFreeFormHookStartPlaneAngle {
    ForgeTypeId^ get ();
}
static member RebarFreeFormHookStartPlaneAngle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarGeometryType Property

ParameterTypeIdRebarGeometryType Property

"Geometry"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarGeometryType { get; }
Public Shared ReadOnly Property RebarGeometryType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarGeometryType {
    ForgeTypeId^ get ();
}
static member RebarGeometryType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarHookAngle Property

ParameterTypeIdRebarHookAngle Property

"Hook Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarHookAngle { get; }
Public Shared ReadOnly Property RebarHookAngle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarHookAngle {
    ForgeTypeId^ get ();
}
static member RebarHookAngle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarHookLengthOverride Property

ParameterTypeIdRebarHookLengthOverride Property

"Override Hook Lengths"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarHookLengthOverride { get; }
Public Shared ReadOnly Property RebarHookLengthOverride As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarHookLengthOverride {
    ForgeTypeId^ get ();
}
static member RebarHookLengthOverride : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarHookLineLenFactor Property

ParameterTypeIdRebarHookLineLenFactor Property

"Extension Multiplier"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarHookLineLenFactor { get; }
Public Shared ReadOnly Property RebarHookLineLenFactor As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarHookLineLenFactor {
    ForgeTypeId^ get ();
}
static member RebarHookLineLenFactor : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarHookRotationAtEnd Property

ParameterTypeIdRebarHookRotationAtEnd Property

"Hook Rotation At End"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarHookRotationAtEnd { get; }
Public Shared ReadOnly Property RebarHookRotationAtEnd As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarHookRotationAtEnd {
    ForgeTypeId^ get ();
}
static member RebarHookRotationAtEnd : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarHookRotationAtEndSchedulesTagsFilters Property

ParameterTypeIdRebarHookRotationAtEndSchedulesTagsFilters Property

"Hook Rotation At End"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarHookRotationAtEndSchedulesTagsFilters { get; }
Public Shared ReadOnly Property RebarHookRotationAtEndSchedulesTagsFilters As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarHookRotationAtEndSchedulesTagsFilters {
    ForgeTypeId^ get ();
}
static member RebarHookRotationAtEndSchedulesTagsFilters : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarHookRotationAtStart Property

ParameterTypeIdRebarHookRotationAtStart Property

"Hook Rotation At Start"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarHookRotationAtStart { get; }
Public Shared ReadOnly Property RebarHookRotationAtStart As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarHookRotationAtStart {
    ForgeTypeId^ get ();
}
static member RebarHookRotationAtStart : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarHookRotationAtStartSchedulesTagsFilters Property

ParameterTypeIdRebarHookRotationAtStartSchedulesTagsFilters Property

"Hook Rotation At Start"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarHookRotationAtStartSchedulesTagsFilters { get; }
Public Shared ReadOnly Property RebarHookRotationAtStartSchedulesTagsFilters As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarHookRotationAtStartSchedulesTagsFilters {
    ForgeTypeId^ get ();
}
static member RebarHookRotationAtStartSchedulesTagsFilters : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarHookStyle Property

ParameterTypeIdRebarHookStyle Property

"Style"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarHookStyle { get; }
Public Shared ReadOnly Property RebarHookStyle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarHookStyle {
    ForgeTypeId^ get ();
}
static member RebarHookStyle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarHostCategory Property

ParameterTypeIdRebarHostCategory Property

"Host Category"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarHostCategory { get; }
Public Shared ReadOnly Property RebarHostCategory As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarHostCategory {
    ForgeTypeId^ get ();
}
static member RebarHostCategory : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarIncludeFirstBar Property

ParameterTypeIdRebarIncludeFirstBar Property

"Include First Bar"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarIncludeFirstBar { get; }
Public Shared ReadOnly Property RebarIncludeFirstBar As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarIncludeFirstBar {
    ForgeTypeId^ get ();
}
static member RebarIncludeFirstBar : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarIncludeLastBar Property

ParameterTypeIdRebarIncludeLastBar Property

"Include Last Bar"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarIncludeLastBar { get; }
Public Shared ReadOnly Property RebarIncludeLastBar As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarIncludeLastBar {
    ForgeTypeId^ get ();
}
static member RebarIncludeLastBar : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarInstanceBarDiameter Property

ParameterTypeIdRebarInstanceBarDiameter Property

"Bar Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarInstanceBarDiameter { get; }
Public Shared ReadOnly Property RebarInstanceBarDiameter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarInstanceBarDiameter {
    ForgeTypeId^ get ();
}
static member RebarInstanceBarDiameter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarInstanceBarModelDiameter Property

ParameterTypeIdRebarInstanceBarModelDiameter Property

"Model Bar Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarInstanceBarModelDiameter { get; }
Public Shared ReadOnly Property RebarInstanceBarModelDiameter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarInstanceBarModelDiameter {
    ForgeTypeId^ get ();
}
static member RebarInstanceBarModelDiameter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarInstanceBendDiameter Property

ParameterTypeIdRebarInstanceBendDiameter Property

"Bend Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarInstanceBendDiameter { get; }
Public Shared ReadOnly Property RebarInstanceBendDiameter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarInstanceBendDiameter {
    ForgeTypeId^ get ();
}
static member RebarInstanceBendDiameter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarInstanceStirrupTieAttachment Property

ParameterTypeIdRebarInstanceStirrupTieAttachment Property

"Stirrup/Tie Attachment"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarInstanceStirrupTieAttachment { get; }
Public Shared ReadOnly Property RebarInstanceStirrupTieAttachment As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarInstanceStirrupTieAttachment {
    ForgeTypeId^ get ();
}
static member RebarInstanceStirrupTieAttachment : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarInternalMultiplanar Property

ParameterTypeIdRebarInternalMultiplanar Property

"INTERNAL: Multiplanar"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarInternalMultiplanar { get; }
Public Shared ReadOnly Property RebarInternalMultiplanar As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarInternalMultiplanar {
    ForgeTypeId^ get ();
}
static member RebarInternalMultiplanar : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarInternalMultiplanarArcConnector Property

ParameterTypeIdRebarInternalMultiplanarArcConnector Property

"INTERNAL: Multiplanar Arc Connector"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarInternalMultiplanarArcConnector { get; }
Public Shared ReadOnly Property RebarInternalMultiplanarArcConnector As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarInternalMultiplanarArcConnector {
    ForgeTypeId^ get ();
}
static member RebarInternalMultiplanarArcConnector : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarInternalMultiplanarDuplicate Property

ParameterTypeIdRebarInternalMultiplanarDuplicate Property

"INTERNAL: Multiplanar Duplicate"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarInternalMultiplanarDuplicate { get; }
Public Shared ReadOnly Property RebarInternalMultiplanarDuplicate As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarInternalMultiplanarDuplicate {
    ForgeTypeId^ get ();
}
static member RebarInternalMultiplanarDuplicate : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarInternalMultiplanarEndConnector Property

ParameterTypeIdRebarInternalMultiplanarEndConnector Property

"INTERNAL: Multiplanar End Connector"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarInternalMultiplanarEndConnector { get; }
Public Shared ReadOnly Property RebarInternalMultiplanarEndConnector As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarInternalMultiplanarEndConnector {
    ForgeTypeId^ get ();
}
static member RebarInternalMultiplanarEndConnector : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarInternalMultiplanarStartConnector Property

ParameterTypeIdRebarInternalMultiplanarStartConnector Property

"INTERNAL: Multiplanar Start Connector"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarInternalMultiplanarStartConnector { get; }
Public Shared ReadOnly Property RebarInternalMultiplanarStartConnector As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarInternalMultiplanarStartConnector {
    ForgeTypeId^ get ();
}
static member RebarInternalMultiplanarStartConnector : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarMaximSuffix Property

ParameterTypeIdRebarMaximSuffix Property

"Maximum Suffix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarMaximSuffix { get; }
Public Shared ReadOnly Property RebarMaximSuffix As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarMaximSuffix {
    ForgeTypeId^ get ();
}
static member RebarMaximSuffix : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarMaximumNumber Property

ParameterTypeIdRebarMaximumNumber Property

"Maximum Rebar Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarMaximumNumber { get; }
Public Shared ReadOnly Property RebarMaximumNumber As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarMaximumNumber {
    ForgeTypeId^ get ();
}
static member RebarMaximumNumber : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarMaxLength Property

ParameterTypeIdRebarMaxLength Property

"Maximum Bar Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarMaxLength { get; }
Public Shared ReadOnly Property RebarMaxLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarMaxLength {
    ForgeTypeId^ get ();
}
static member RebarMaxLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarMinimSuffix Property

ParameterTypeIdRebarMinimSuffix Property

"Minimum Suffix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarMinimSuffix { get; }
Public Shared ReadOnly Property RebarMinimSuffix As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarMinimSuffix {
    ForgeTypeId^ get ();
}
static member RebarMinimSuffix : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarMinimumNumber Property

ParameterTypeIdRebarMinimumNumber Property

"Minimum Rebar Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarMinimumNumber { get; }
Public Shared ReadOnly Property RebarMinimumNumber As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarMinimumNumber {
    ForgeTypeId^ get ();
}
static member RebarMinimumNumber : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarMinLength Property

ParameterTypeIdRebarMinLength Property

"Minimum Bar Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarMinLength { get; }
Public Shared ReadOnly Property RebarMinLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarMinLength {
    ForgeTypeId^ get ();
}
static member RebarMinLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarModelBarDiameter Property

ParameterTypeIdRebarModelBarDiameter Property

"Model Bar Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarModelBarDiameter { get; }
Public Shared ReadOnly Property RebarModelBarDiameter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarModelBarDiameter {
    ForgeTypeId^ get ();
}
static member RebarModelBarDiameter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarModifiedSet Property

ParameterTypeIdRebarModifiedSet Property

"Modified Rebar Set"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarModifiedSet { get; }
Public Shared ReadOnly Property RebarModifiedSet As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarModifiedSet {
    ForgeTypeId^ get ();
}
static member RebarModifiedSet : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarNumber Property

ParameterTypeIdRebarNumber Property

"Rebar Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarNumber { get; }
Public Shared ReadOnly Property RebarNumber As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarNumber {
    ForgeTypeId^ get ();
}
static member RebarNumber : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarNumberSuffix Property

ParameterTypeIdRebarNumberSuffix Property

"Rebar Number Suffix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarNumberSuffix { get; }
Public Shared ReadOnly Property RebarNumberSuffix As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarNumberSuffix {
    ForgeTypeId^ get ();
}
static member RebarNumberSuffix : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarQuanityByDistrib Property

ParameterTypeIdRebarQuanityByDistrib Property

"Quantity By Rebar Set"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarQuanityByDistrib { get; }
Public Shared ReadOnly Property RebarQuanityByDistrib As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarQuanityByDistrib {
    ForgeTypeId^ get ();
}
static member RebarQuanityByDistrib : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarShape Property

ParameterTypeIdRebarShape Property

"Shape"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarShape { get; }
Public Shared ReadOnly Property RebarShape As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarShape {
    ForgeTypeId^ get ();
}
static member RebarShape : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarShapeAllowedBarTypes Property

ParameterTypeIdRebarShapeAllowedBarTypes Property

"Allowable Rebar Bar Types"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarShapeAllowedBarTypes { get; }
Public Shared ReadOnly Property RebarShapeAllowedBarTypes As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarShapeAllowedBarTypes {
    ForgeTypeId^ get ();
}
static member RebarShapeAllowedBarTypes : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarShapeEndHookLength Property

ParameterTypeIdRebarShapeEndHookLength Property

"End Hook Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarShapeEndHookLength { get; }
Public Shared ReadOnly Property RebarShapeEndHookLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarShapeEndHookLength {
    ForgeTypeId^ get ();
}
static member RebarShapeEndHookLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarShapeEndHookOffset Property

ParameterTypeIdRebarShapeEndHookOffset Property

"End Hook Offset Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarShapeEndHookOffset { get; }
Public Shared ReadOnly Property RebarShapeEndHookOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarShapeEndHookOffset {
    ForgeTypeId^ get ();
}
static member RebarShapeEndHookOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarShapeEndtreatmentEndType Property

ParameterTypeIdRebarShapeEndtreatmentEndType Property

"End Treatment At End"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarShapeEndtreatmentEndType { get; }
Public Shared ReadOnly Property RebarShapeEndtreatmentEndType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarShapeEndtreatmentEndType {
    ForgeTypeId^ get ();
}
static member RebarShapeEndtreatmentEndType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarShapeEndtreatmentStartType Property

ParameterTypeIdRebarShapeEndtreatmentStartType Property

"End Treatment At Start"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarShapeEndtreatmentStartType { get; }
Public Shared ReadOnly Property RebarShapeEndtreatmentStartType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarShapeEndtreatmentStartType {
    ForgeTypeId^ get ();
}
static member RebarShapeEndtreatmentStartType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarShapeHookEndType Property

ParameterTypeIdRebarShapeHookEndType Property

"Hook At End"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarShapeHookEndType { get; }
Public Shared ReadOnly Property RebarShapeHookEndType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarShapeHookEndType {
    ForgeTypeId^ get ();
}
static member RebarShapeHookEndType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarShapeHookRotationAtEnd Property

ParameterTypeIdRebarShapeHookRotationAtEnd Property

"Hook Rotation At End"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarShapeHookRotationAtEnd { get; }
Public Shared ReadOnly Property RebarShapeHookRotationAtEnd As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarShapeHookRotationAtEnd {
    ForgeTypeId^ get ();
}
static member RebarShapeHookRotationAtEnd : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarShapeHookRotationAtStart Property

ParameterTypeIdRebarShapeHookRotationAtStart Property

"Hook Rotation At Start"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarShapeHookRotationAtStart { get; }
Public Shared ReadOnly Property RebarShapeHookRotationAtStart As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarShapeHookRotationAtStart {
    ForgeTypeId^ get ();
}
static member RebarShapeHookRotationAtStart : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarShapeHookStartType Property

ParameterTypeIdRebarShapeHookStartType Property

"Hook At Start"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarShapeHookStartType { get; }
Public Shared ReadOnly Property RebarShapeHookStartType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarShapeHookStartType {
    ForgeTypeId^ get ();
}
static member RebarShapeHookStartType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarShapeHookStyle Property

ParameterTypeIdRebarShapeHookStyle Property

"Style"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarShapeHookStyle { get; }
Public Shared ReadOnly Property RebarShapeHookStyle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarShapeHookStyle {
    ForgeTypeId^ get ();
}
static member RebarShapeHookStyle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarShapeImage Property

ParameterTypeIdRebarShapeImage Property

"Shape Image"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarShapeImage { get; }
Public Shared ReadOnly Property RebarShapeImage As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarShapeImage {
    ForgeTypeId^ get ();
}
static member RebarShapeImage : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarShapeOutOfPlaneBendDiameter Property

ParameterTypeIdRebarShapeOutOfPlaneBendDiameter Property

"Out of Plane Bend Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarShapeOutOfPlaneBendDiameter { get; }
Public Shared ReadOnly Property RebarShapeOutOfPlaneBendDiameter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarShapeOutOfPlaneBendDiameter {
    ForgeTypeId^ get ();
}
static member RebarShapeOutOfPlaneBendDiameter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarShapeParamEndHookTanLen Property

ParameterTypeIdRebarShapeParamEndHookTanLen Property

"End Tangent Hook Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarShapeParamEndHookTanLen { get; }
Public Shared ReadOnly Property RebarShapeParamEndHookTanLen As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarShapeParamEndHookTanLen {
    ForgeTypeId^ get ();
}
static member RebarShapeParamEndHookTanLen : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarShapeParamStartHookTanLen Property

ParameterTypeIdRebarShapeParamStartHookTanLen Property

"Start Tangent Hook Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarShapeParamStartHookTanLen { get; }
Public Shared ReadOnly Property RebarShapeParamStartHookTanLen As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarShapeParamStartHookTanLen {
    ForgeTypeId^ get ();
}
static member RebarShapeParamStartHookTanLen : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarShapeSpiralBaseFinishingTurns Property

ParameterTypeIdRebarShapeSpiralBaseFinishingTurns Property

"Base Finishing Turns"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarShapeSpiralBaseFinishingTurns { get; }
Public Shared ReadOnly Property RebarShapeSpiralBaseFinishingTurns As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarShapeSpiralBaseFinishingTurns {
    ForgeTypeId^ get ();
}
static member RebarShapeSpiralBaseFinishingTurns : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarShapeSpiralHeight Property

ParameterTypeIdRebarShapeSpiralHeight Property

"Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarShapeSpiralHeight { get; }
Public Shared ReadOnly Property RebarShapeSpiralHeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarShapeSpiralHeight {
    ForgeTypeId^ get ();
}
static member RebarShapeSpiralHeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarShapeSpiralPitch Property

ParameterTypeIdRebarShapeSpiralPitch Property

"Pitch"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarShapeSpiralPitch { get; }
Public Shared ReadOnly Property RebarShapeSpiralPitch As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarShapeSpiralPitch {
    ForgeTypeId^ get ();
}
static member RebarShapeSpiralPitch : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarShapeSpiralTopFinishingTurns Property

ParameterTypeIdRebarShapeSpiralTopFinishingTurns Property

"Top Finishing Turns"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarShapeSpiralTopFinishingTurns { get; }
Public Shared ReadOnly Property RebarShapeSpiralTopFinishingTurns As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarShapeSpiralTopFinishingTurns {
    ForgeTypeId^ get ();
}
static member RebarShapeSpiralTopFinishingTurns : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarShapeStartHookLength Property

ParameterTypeIdRebarShapeStartHookLength Property

"Start Hook Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarShapeStartHookLength { get; }
Public Shared ReadOnly Property RebarShapeStartHookLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarShapeStartHookLength {
    ForgeTypeId^ get ();
}
static member RebarShapeStartHookLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarShapeStartHookOffset Property

ParameterTypeIdRebarShapeStartHookOffset Property

"Start Hook Offset Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarShapeStartHookOffset { get; }
Public Shared ReadOnly Property RebarShapeStartHookOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarShapeStartHookOffset {
    ForgeTypeId^ get ();
}
static member RebarShapeStartHookOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarShapeStirrupTieAttachment Property

ParameterTypeIdRebarShapeStirrupTieAttachment Property

"Stirrup/Tie Attachment"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarShapeStirrupTieAttachment { get; }
Public Shared ReadOnly Property RebarShapeStirrupTieAttachment As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarShapeStirrupTieAttachment {
    ForgeTypeId^ get ();
}
static member RebarShapeStirrupTieAttachment : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSpliceLapLengthMultiplier Property

ParameterTypeIdRebarSpliceLapLengthMultiplier Property

"Lap Length Multiplier"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSpliceLapLengthMultiplier { get; }
Public Shared ReadOnly Property RebarSpliceLapLengthMultiplier As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSpliceLapLengthMultiplier {
    ForgeTypeId^ get ();
}
static member RebarSpliceLapLengthMultiplier : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSpliceShiftBars Property

ParameterTypeIdRebarSpliceShiftBars Property

"Shift Bars"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSpliceShiftBars { get; }
Public Shared ReadOnly Property RebarSpliceShiftBars As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSpliceShiftBars {
    ForgeTypeId^ get ();
}
static member RebarSpliceShiftBars : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSpliceSpliceLinePosition Property

ParameterTypeIdRebarSpliceSpliceLinePosition Property

"Splice Position"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSpliceSpliceLinePosition { get; }
Public Shared ReadOnly Property RebarSpliceSpliceLinePosition As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSpliceSpliceLinePosition {
    ForgeTypeId^ get ();
}
static member RebarSpliceSpliceLinePosition : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSpliceStaggerLengthMultiplier Property

ParameterTypeIdRebarSpliceStaggerLengthMultiplier Property

"Stagger Length Multiplier"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSpliceStaggerLengthMultiplier { get; }
Public Shared ReadOnly Property RebarSpliceStaggerLengthMultiplier As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSpliceStaggerLengthMultiplier {
    ForgeTypeId^ get ();
}
static member RebarSpliceStaggerLengthMultiplier : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarStaggeredSet Property

ParameterTypeIdRebarStaggeredSet Property

"Staggered Set"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarStaggeredSet { get; }
Public Shared ReadOnly Property RebarStaggeredSet As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarStaggeredSet {
    ForgeTypeId^ get ();
}
static member RebarStaggeredSet : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarStaggerOffsetAtEnd Property

ParameterTypeIdRebarStaggerOffsetAtEnd Property

"Offset At End"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarStaggerOffsetAtEnd { get; }
Public Shared ReadOnly Property RebarStaggerOffsetAtEnd As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarStaggerOffsetAtEnd {
    ForgeTypeId^ get ();
}
static member RebarStaggerOffsetAtEnd : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarStaggerOffsetAtStart Property

ParameterTypeIdRebarStaggerOffsetAtStart Property

"Offset At Start"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarStaggerOffsetAtStart { get; }
Public Shared ReadOnly Property RebarStaggerOffsetAtStart As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarStaggerOffsetAtStart {
    ForgeTypeId^ get ();
}
static member RebarStaggerOffsetAtStart : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarStandardBendDiameter Property

ParameterTypeIdRebarStandardBendDiameter Property

"Standard Bend Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarStandardBendDiameter { get; }
Public Shared ReadOnly Property RebarStandardBendDiameter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarStandardBendDiameter {
    ForgeTypeId^ get ();
}
static member RebarStandardBendDiameter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarStandardHookBendDiameter Property

ParameterTypeIdRebarStandardHookBendDiameter Property

"Standard Hook Bend Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarStandardHookBendDiameter { get; }
Public Shared ReadOnly Property RebarStandardHookBendDiameter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarStandardHookBendDiameter {
    ForgeTypeId^ get ();
}
static member RebarStandardHookBendDiameter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemActiveBackDirn1 Property

ParameterTypeIdRebarSystemActiveBackDirn1 Property

"Interior Major Direction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemActiveBackDirn1 { get; }
Public Shared ReadOnly Property RebarSystemActiveBackDirn1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemActiveBackDirn1 {
    ForgeTypeId^ get ();
}
static member RebarSystemActiveBackDirn1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemActiveBackDirn2 Property

ParameterTypeIdRebarSystemActiveBackDirn2 Property

"Interior Minor Direction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemActiveBackDirn2 { get; }
Public Shared ReadOnly Property RebarSystemActiveBackDirn2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemActiveBackDirn2 {
    ForgeTypeId^ get ();
}
static member RebarSystemActiveBackDirn2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemActiveBottomDir1Generic Property

ParameterTypeIdRebarSystemActiveBottomDir1Generic Property

"Bottom/Interior Major Direction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemActiveBottomDir1Generic { get; }
Public Shared ReadOnly Property RebarSystemActiveBottomDir1Generic As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemActiveBottomDir1Generic {
    ForgeTypeId^ get ();
}
static member RebarSystemActiveBottomDir1Generic : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemActiveBottomDir2Generic Property

ParameterTypeIdRebarSystemActiveBottomDir2Generic Property

"Bottom/Interior Minor Direction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemActiveBottomDir2Generic { get; }
Public Shared ReadOnly Property RebarSystemActiveBottomDir2Generic As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemActiveBottomDir2Generic {
    ForgeTypeId^ get ();
}
static member RebarSystemActiveBottomDir2Generic : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemActiveBottomDirn1 Property

ParameterTypeIdRebarSystemActiveBottomDirn1 Property

"Bottom Major Direction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemActiveBottomDirn1 { get; }
Public Shared ReadOnly Property RebarSystemActiveBottomDirn1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemActiveBottomDirn1 {
    ForgeTypeId^ get ();
}
static member RebarSystemActiveBottomDirn1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemActiveBottomDirn2 Property

ParameterTypeIdRebarSystemActiveBottomDirn2 Property

"Bottom Minor Direction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemActiveBottomDirn2 { get; }
Public Shared ReadOnly Property RebarSystemActiveBottomDirn2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemActiveBottomDirn2 {
    ForgeTypeId^ get ();
}
static member RebarSystemActiveBottomDirn2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemActiveFrontDirn1 Property

ParameterTypeIdRebarSystemActiveFrontDirn1 Property

"Exterior Major Direction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemActiveFrontDirn1 { get; }
Public Shared ReadOnly Property RebarSystemActiveFrontDirn1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemActiveFrontDirn1 {
    ForgeTypeId^ get ();
}
static member RebarSystemActiveFrontDirn1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemActiveFrontDirn2 Property

ParameterTypeIdRebarSystemActiveFrontDirn2 Property

"Exterior Minor Direction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemActiveFrontDirn2 { get; }
Public Shared ReadOnly Property RebarSystemActiveFrontDirn2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemActiveFrontDirn2 {
    ForgeTypeId^ get ();
}
static member RebarSystemActiveFrontDirn2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemActiveTopDir1Generic Property

ParameterTypeIdRebarSystemActiveTopDir1Generic Property

"Top/Exterior Major Direction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemActiveTopDir1Generic { get; }
Public Shared ReadOnly Property RebarSystemActiveTopDir1Generic As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemActiveTopDir1Generic {
    ForgeTypeId^ get ();
}
static member RebarSystemActiveTopDir1Generic : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemActiveTopDir2Generic Property

ParameterTypeIdRebarSystemActiveTopDir2Generic Property

"Top/Exterior Minor Direction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemActiveTopDir2Generic { get; }
Public Shared ReadOnly Property RebarSystemActiveTopDir2Generic As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemActiveTopDir2Generic {
    ForgeTypeId^ get ();
}
static member RebarSystemActiveTopDir2Generic : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemActiveTopDirn1 Property

ParameterTypeIdRebarSystemActiveTopDirn1 Property

"Top Major Direction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemActiveTopDirn1 { get; }
Public Shared ReadOnly Property RebarSystemActiveTopDirn1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemActiveTopDirn1 {
    ForgeTypeId^ get ();
}
static member RebarSystemActiveTopDirn1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemActiveTopDirn2 Property

ParameterTypeIdRebarSystemActiveTopDirn2 Property

"Top Minor Direction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemActiveTopDirn2 { get; }
Public Shared ReadOnly Property RebarSystemActiveTopDirn2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemActiveTopDirn2 {
    ForgeTypeId^ get ();
}
static member RebarSystemActiveTopDirn2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemAddlBottomOffset Property

ParameterTypeIdRebarSystemAddlBottomOffset Property

"Additional Bottom Cover Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemAddlBottomOffset { get; }
Public Shared ReadOnly Property RebarSystemAddlBottomOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemAddlBottomOffset {
    ForgeTypeId^ get ();
}
static member RebarSystemAddlBottomOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemAddlExteriorOffset Property

ParameterTypeIdRebarSystemAddlExteriorOffset Property

"Additional Exterior Cover Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemAddlExteriorOffset { get; }
Public Shared ReadOnly Property RebarSystemAddlExteriorOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemAddlExteriorOffset {
    ForgeTypeId^ get ();
}
static member RebarSystemAddlExteriorOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemAddlInteriorOffset Property

ParameterTypeIdRebarSystemAddlInteriorOffset Property

"Additional Interior Cover Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemAddlInteriorOffset { get; }
Public Shared ReadOnly Property RebarSystemAddlInteriorOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemAddlInteriorOffset {
    ForgeTypeId^ get ();
}
static member RebarSystemAddlInteriorOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemAddlTopOffset Property

ParameterTypeIdRebarSystemAddlTopOffset Property

"Additional Top Cover Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemAddlTopOffset { get; }
Public Shared ReadOnly Property RebarSystemAddlTopOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemAddlTopOffset {
    ForgeTypeId^ get ();
}
static member RebarSystemAddlTopOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemBarTypeBackDirn1 Property

ParameterTypeIdRebarSystemBarTypeBackDirn1 Property

"Interior Major Bar Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemBarTypeBackDirn1 { get; }
Public Shared ReadOnly Property RebarSystemBarTypeBackDirn1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemBarTypeBackDirn1 {
    ForgeTypeId^ get ();
}
static member RebarSystemBarTypeBackDirn1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemBarTypeBackDirn2 Property

ParameterTypeIdRebarSystemBarTypeBackDirn2 Property

"Interior Minor Bar Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemBarTypeBackDirn2 { get; }
Public Shared ReadOnly Property RebarSystemBarTypeBackDirn2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemBarTypeBackDirn2 {
    ForgeTypeId^ get ();
}
static member RebarSystemBarTypeBackDirn2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemBarTypeBottomDir1Generic Property

ParameterTypeIdRebarSystemBarTypeBottomDir1Generic Property

"Bottom/Interior Major Bar Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemBarTypeBottomDir1Generic { get; }
Public Shared ReadOnly Property RebarSystemBarTypeBottomDir1Generic As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemBarTypeBottomDir1Generic {
    ForgeTypeId^ get ();
}
static member RebarSystemBarTypeBottomDir1Generic : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemBarTypeBottomDir2Generic Property

ParameterTypeIdRebarSystemBarTypeBottomDir2Generic Property

"Bottom/Interior Minor Bar Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemBarTypeBottomDir2Generic { get; }
Public Shared ReadOnly Property RebarSystemBarTypeBottomDir2Generic As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemBarTypeBottomDir2Generic {
    ForgeTypeId^ get ();
}
static member RebarSystemBarTypeBottomDir2Generic : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemBarTypeBottomDirn1 Property

ParameterTypeIdRebarSystemBarTypeBottomDirn1 Property

"Bottom Major Bar Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemBarTypeBottomDirn1 { get; }
Public Shared ReadOnly Property RebarSystemBarTypeBottomDirn1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemBarTypeBottomDirn1 {
    ForgeTypeId^ get ();
}
static member RebarSystemBarTypeBottomDirn1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemBarTypeBottomDirn2 Property

ParameterTypeIdRebarSystemBarTypeBottomDirn2 Property

"Bottom Minor Bar Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemBarTypeBottomDirn2 { get; }
Public Shared ReadOnly Property RebarSystemBarTypeBottomDirn2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemBarTypeBottomDirn2 {
    ForgeTypeId^ get ();
}
static member RebarSystemBarTypeBottomDirn2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemBarTypeFrontDirn1 Property

ParameterTypeIdRebarSystemBarTypeFrontDirn1 Property

"Exterior Major Bar Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemBarTypeFrontDirn1 { get; }
Public Shared ReadOnly Property RebarSystemBarTypeFrontDirn1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemBarTypeFrontDirn1 {
    ForgeTypeId^ get ();
}
static member RebarSystemBarTypeFrontDirn1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemBarTypeFrontDirn2 Property

ParameterTypeIdRebarSystemBarTypeFrontDirn2 Property

"Exterior Minor Bar Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemBarTypeFrontDirn2 { get; }
Public Shared ReadOnly Property RebarSystemBarTypeFrontDirn2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemBarTypeFrontDirn2 {
    ForgeTypeId^ get ();
}
static member RebarSystemBarTypeFrontDirn2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemBarTypeTopDir1Generic Property

ParameterTypeIdRebarSystemBarTypeTopDir1Generic Property

"Top/Exterior Major Bar Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemBarTypeTopDir1Generic { get; }
Public Shared ReadOnly Property RebarSystemBarTypeTopDir1Generic As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemBarTypeTopDir1Generic {
    ForgeTypeId^ get ();
}
static member RebarSystemBarTypeTopDir1Generic : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemBarTypeTopDir2Generic Property

ParameterTypeIdRebarSystemBarTypeTopDir2Generic Property

"Top/Exterior Minor Bar Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemBarTypeTopDir2Generic { get; }
Public Shared ReadOnly Property RebarSystemBarTypeTopDir2Generic As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemBarTypeTopDir2Generic {
    ForgeTypeId^ get ();
}
static member RebarSystemBarTypeTopDir2Generic : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemBarTypeTopDirn1 Property

ParameterTypeIdRebarSystemBarTypeTopDirn1 Property

"Top Major Bar Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemBarTypeTopDirn1 { get; }
Public Shared ReadOnly Property RebarSystemBarTypeTopDirn1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemBarTypeTopDirn1 {
    ForgeTypeId^ get ();
}
static member RebarSystemBarTypeTopDirn1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemBarTypeTopDirn2 Property

ParameterTypeIdRebarSystemBarTypeTopDirn2 Property

"Top Minor Bar Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemBarTypeTopDirn2 { get; }
Public Shared ReadOnly Property RebarSystemBarTypeTopDirn2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemBarTypeTopDirn2 {
    ForgeTypeId^ get ();
}
static member RebarSystemBarTypeTopDirn2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemBottomMajorMatchesBottomMinor Property

ParameterTypeIdRebarSystemBottomMajorMatchesBottomMinor Property

"Bottom Major and Minor Layers Match"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemBottomMajorMatchesBottomMinor { get; }
Public Shared ReadOnly Property RebarSystemBottomMajorMatchesBottomMinor As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemBottomMajorMatchesBottomMinor {
    ForgeTypeId^ get ();
}
static member RebarSystemBottomMajorMatchesBottomMinor : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemCoverBottom Property

ParameterTypeIdRebarSystemCoverBottom Property

"Rebar Cover Bottom/Interior"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemCoverBottom { get; }
Public Shared ReadOnly Property RebarSystemCoverBottom As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemCoverBottom {
    ForgeTypeId^ get ();
}
static member RebarSystemCoverBottom : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemCoverSide Property

ParameterTypeIdRebarSystemCoverSide Property

"Rebar Cover Side/Edge"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemCoverSide { get; }
Public Shared ReadOnly Property RebarSystemCoverSide As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemCoverSide {
    ForgeTypeId^ get ();
}
static member RebarSystemCoverSide : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemCoverTop Property

ParameterTypeIdRebarSystemCoverTop Property

"Rebar Cover Top/Exterior"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemCoverTop { get; }
Public Shared ReadOnly Property RebarSystemCoverTop As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemCoverTop {
    ForgeTypeId^ get ();
}
static member RebarSystemCoverTop : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemHookOrientBackDirn1 Property

ParameterTypeIdRebarSystemHookOrientBackDirn1 Property

"Interior Major Hook Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemHookOrientBackDirn1 { get; }
Public Shared ReadOnly Property RebarSystemHookOrientBackDirn1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemHookOrientBackDirn1 {
    ForgeTypeId^ get ();
}
static member RebarSystemHookOrientBackDirn1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemHookOrientBackDirn2 Property

ParameterTypeIdRebarSystemHookOrientBackDirn2 Property

"Interior Minor Hook Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemHookOrientBackDirn2 { get; }
Public Shared ReadOnly Property RebarSystemHookOrientBackDirn2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemHookOrientBackDirn2 {
    ForgeTypeId^ get ();
}
static member RebarSystemHookOrientBackDirn2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemHookOrientBottomDirn1 Property

ParameterTypeIdRebarSystemHookOrientBottomDirn1 Property

"Bottom Major Hook Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemHookOrientBottomDirn1 { get; }
Public Shared ReadOnly Property RebarSystemHookOrientBottomDirn1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemHookOrientBottomDirn1 {
    ForgeTypeId^ get ();
}
static member RebarSystemHookOrientBottomDirn1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemHookOrientBottomDirn2 Property

ParameterTypeIdRebarSystemHookOrientBottomDirn2 Property

"Bottom Minor Hook Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemHookOrientBottomDirn2 { get; }
Public Shared ReadOnly Property RebarSystemHookOrientBottomDirn2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemHookOrientBottomDirn2 {
    ForgeTypeId^ get ();
}
static member RebarSystemHookOrientBottomDirn2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemHookOrientFrontDirn1 Property

ParameterTypeIdRebarSystemHookOrientFrontDirn1 Property

"Exterior Major Hook Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemHookOrientFrontDirn1 { get; }
Public Shared ReadOnly Property RebarSystemHookOrientFrontDirn1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemHookOrientFrontDirn1 {
    ForgeTypeId^ get ();
}
static member RebarSystemHookOrientFrontDirn1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemHookOrientFrontDirn2 Property

ParameterTypeIdRebarSystemHookOrientFrontDirn2 Property

"Exterior Minor Hook Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemHookOrientFrontDirn2 { get; }
Public Shared ReadOnly Property RebarSystemHookOrientFrontDirn2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemHookOrientFrontDirn2 {
    ForgeTypeId^ get ();
}
static member RebarSystemHookOrientFrontDirn2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemHookOrientTopDirn1 Property

ParameterTypeIdRebarSystemHookOrientTopDirn1 Property

"Top Major Hook Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemHookOrientTopDirn1 { get; }
Public Shared ReadOnly Property RebarSystemHookOrientTopDirn1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemHookOrientTopDirn1 {
    ForgeTypeId^ get ();
}
static member RebarSystemHookOrientTopDirn1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemHookOrientTopDirn2 Property

ParameterTypeIdRebarSystemHookOrientTopDirn2 Property

"Top Minor Hook Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemHookOrientTopDirn2 { get; }
Public Shared ReadOnly Property RebarSystemHookOrientTopDirn2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemHookOrientTopDirn2 {
    ForgeTypeId^ get ();
}
static member RebarSystemHookOrientTopDirn2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemHookTypeBackDirn1 Property

ParameterTypeIdRebarSystemHookTypeBackDirn1 Property

"Interior Major Hook Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemHookTypeBackDirn1 { get; }
Public Shared ReadOnly Property RebarSystemHookTypeBackDirn1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemHookTypeBackDirn1 {
    ForgeTypeId^ get ();
}
static member RebarSystemHookTypeBackDirn1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemHookTypeBackDirn2 Property

ParameterTypeIdRebarSystemHookTypeBackDirn2 Property

"Interior Minor Hook Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemHookTypeBackDirn2 { get; }
Public Shared ReadOnly Property RebarSystemHookTypeBackDirn2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemHookTypeBackDirn2 {
    ForgeTypeId^ get ();
}
static member RebarSystemHookTypeBackDirn2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemHookTypeBottomDirn1 Property

ParameterTypeIdRebarSystemHookTypeBottomDirn1 Property

"Bottom Major Hook Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemHookTypeBottomDirn1 { get; }
Public Shared ReadOnly Property RebarSystemHookTypeBottomDirn1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemHookTypeBottomDirn1 {
    ForgeTypeId^ get ();
}
static member RebarSystemHookTypeBottomDirn1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemHookTypeBottomDirn2 Property

ParameterTypeIdRebarSystemHookTypeBottomDirn2 Property

"Bottom Minor Hook Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemHookTypeBottomDirn2 { get; }
Public Shared ReadOnly Property RebarSystemHookTypeBottomDirn2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemHookTypeBottomDirn2 {
    ForgeTypeId^ get ();
}
static member RebarSystemHookTypeBottomDirn2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemHookTypeFrontDirn1 Property

ParameterTypeIdRebarSystemHookTypeFrontDirn1 Property

"Exterior Major Hook Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemHookTypeFrontDirn1 { get; }
Public Shared ReadOnly Property RebarSystemHookTypeFrontDirn1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemHookTypeFrontDirn1 {
    ForgeTypeId^ get ();
}
static member RebarSystemHookTypeFrontDirn1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemHookTypeFrontDirn2 Property

ParameterTypeIdRebarSystemHookTypeFrontDirn2 Property

"Exterior Minor Hook Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemHookTypeFrontDirn2 { get; }
Public Shared ReadOnly Property RebarSystemHookTypeFrontDirn2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemHookTypeFrontDirn2 {
    ForgeTypeId^ get ();
}
static member RebarSystemHookTypeFrontDirn2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemHookTypeTopDirn1 Property

ParameterTypeIdRebarSystemHookTypeTopDirn1 Property

"Top Major Hook Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemHookTypeTopDirn1 { get; }
Public Shared ReadOnly Property RebarSystemHookTypeTopDirn1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemHookTypeTopDirn1 {
    ForgeTypeId^ get ();
}
static member RebarSystemHookTypeTopDirn1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemHookTypeTopDirn2 Property

ParameterTypeIdRebarSystemHookTypeTopDirn2 Property

"Top Minor Hook Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemHookTypeTopDirn2 { get; }
Public Shared ReadOnly Property RebarSystemHookTypeTopDirn2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemHookTypeTopDirn2 {
    ForgeTypeId^ get ();
}
static member RebarSystemHookTypeTopDirn2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemLayerSummaryBottomDir1NoSpacing Property

ParameterTypeIdRebarSystemLayerSummaryBottomDir1NoSpacing Property

"Bottom/Interior Major (Brief)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemLayerSummaryBottomDir1NoSpacing { get; }
Public Shared ReadOnly Property RebarSystemLayerSummaryBottomDir1NoSpacing As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemLayerSummaryBottomDir1NoSpacing {
    ForgeTypeId^ get ();
}
static member RebarSystemLayerSummaryBottomDir1NoSpacing : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemLayerSummaryBottomDir1WithSpacing Property

ParameterTypeIdRebarSystemLayerSummaryBottomDir1WithSpacing Property

"Bottom/Interior Major"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemLayerSummaryBottomDir1WithSpacing { get; }
Public Shared ReadOnly Property RebarSystemLayerSummaryBottomDir1WithSpacing As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemLayerSummaryBottomDir1WithSpacing {
    ForgeTypeId^ get ();
}
static member RebarSystemLayerSummaryBottomDir1WithSpacing : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemLayerSummaryBottomDir2NoSpacing Property

ParameterTypeIdRebarSystemLayerSummaryBottomDir2NoSpacing Property

"Bottom/Interior Minor (Brief)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemLayerSummaryBottomDir2NoSpacing { get; }
Public Shared ReadOnly Property RebarSystemLayerSummaryBottomDir2NoSpacing As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemLayerSummaryBottomDir2NoSpacing {
    ForgeTypeId^ get ();
}
static member RebarSystemLayerSummaryBottomDir2NoSpacing : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemLayerSummaryBottomDir2WithSpacing Property

ParameterTypeIdRebarSystemLayerSummaryBottomDir2WithSpacing Property

"Bottom/Interior Minor"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemLayerSummaryBottomDir2WithSpacing { get; }
Public Shared ReadOnly Property RebarSystemLayerSummaryBottomDir2WithSpacing As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemLayerSummaryBottomDir2WithSpacing {
    ForgeTypeId^ get ();
}
static member RebarSystemLayerSummaryBottomDir2WithSpacing : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemLayerSummaryDir1NoSpacing Property

ParameterTypeIdRebarSystemLayerSummaryDir1NoSpacing Property

"Major, Both Faces (Brief)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemLayerSummaryDir1NoSpacing { get; }
Public Shared ReadOnly Property RebarSystemLayerSummaryDir1NoSpacing As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemLayerSummaryDir1NoSpacing {
    ForgeTypeId^ get ();
}
static member RebarSystemLayerSummaryDir1NoSpacing : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemLayerSummaryDir1WithSpacing Property

ParameterTypeIdRebarSystemLayerSummaryDir1WithSpacing Property

"Major, Both Faces"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemLayerSummaryDir1WithSpacing { get; }
Public Shared ReadOnly Property RebarSystemLayerSummaryDir1WithSpacing As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemLayerSummaryDir1WithSpacing {
    ForgeTypeId^ get ();
}
static member RebarSystemLayerSummaryDir1WithSpacing : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemLayerSummaryDir2NoSpacing Property

ParameterTypeIdRebarSystemLayerSummaryDir2NoSpacing Property

"Minor, Both Faces (Brief)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemLayerSummaryDir2NoSpacing { get; }
Public Shared ReadOnly Property RebarSystemLayerSummaryDir2NoSpacing As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemLayerSummaryDir2NoSpacing {
    ForgeTypeId^ get ();
}
static member RebarSystemLayerSummaryDir2NoSpacing : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemLayerSummaryDir2WithSpacing Property

ParameterTypeIdRebarSystemLayerSummaryDir2WithSpacing Property

"Minor, Both Faces"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemLayerSummaryDir2WithSpacing { get; }
Public Shared ReadOnly Property RebarSystemLayerSummaryDir2WithSpacing As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemLayerSummaryDir2WithSpacing {
    ForgeTypeId^ get ();
}
static member RebarSystemLayerSummaryDir2WithSpacing : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemLayerSummaryNoSpacing Property

ParameterTypeIdRebarSystemLayerSummaryNoSpacing Property

"Layer Summary (Brief)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemLayerSummaryNoSpacing { get; }
Public Shared ReadOnly Property RebarSystemLayerSummaryNoSpacing As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemLayerSummaryNoSpacing {
    ForgeTypeId^ get ();
}
static member RebarSystemLayerSummaryNoSpacing : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemLayerSummaryTopDir1NoSpacing Property

ParameterTypeIdRebarSystemLayerSummaryTopDir1NoSpacing Property

"Top/Exterior Major (Brief)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemLayerSummaryTopDir1NoSpacing { get; }
Public Shared ReadOnly Property RebarSystemLayerSummaryTopDir1NoSpacing As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemLayerSummaryTopDir1NoSpacing {
    ForgeTypeId^ get ();
}
static member RebarSystemLayerSummaryTopDir1NoSpacing : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemLayerSummaryTopDir1WithSpacing Property

ParameterTypeIdRebarSystemLayerSummaryTopDir1WithSpacing Property

"Top/Exterior Major"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemLayerSummaryTopDir1WithSpacing { get; }
Public Shared ReadOnly Property RebarSystemLayerSummaryTopDir1WithSpacing As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemLayerSummaryTopDir1WithSpacing {
    ForgeTypeId^ get ();
}
static member RebarSystemLayerSummaryTopDir1WithSpacing : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemLayerSummaryTopDir2NoSpacing Property

ParameterTypeIdRebarSystemLayerSummaryTopDir2NoSpacing Property

"Top/Exterior Minor (Brief)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemLayerSummaryTopDir2NoSpacing { get; }
Public Shared ReadOnly Property RebarSystemLayerSummaryTopDir2NoSpacing As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemLayerSummaryTopDir2NoSpacing {
    ForgeTypeId^ get ();
}
static member RebarSystemLayerSummaryTopDir2NoSpacing : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemLayerSummaryTopDir2WithSpacing Property

ParameterTypeIdRebarSystemLayerSummaryTopDir2WithSpacing Property

"Top/Exterior Minor"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemLayerSummaryTopDir2WithSpacing { get; }
Public Shared ReadOnly Property RebarSystemLayerSummaryTopDir2WithSpacing As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemLayerSummaryTopDir2WithSpacing {
    ForgeTypeId^ get ();
}
static member RebarSystemLayerSummaryTopDir2WithSpacing : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemLayerSummaryWithSpacing Property

ParameterTypeIdRebarSystemLayerSummaryWithSpacing Property

"Layer Summary"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemLayerSummaryWithSpacing { get; }
Public Shared ReadOnly Property RebarSystemLayerSummaryWithSpacing As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemLayerSummaryWithSpacing {
    ForgeTypeId^ get ();
}
static member RebarSystemLayerSummaryWithSpacing : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemLayoutRule Property

ParameterTypeIdRebarSystemLayoutRule Property

"Layout Rule"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemLayoutRule { get; }
Public Shared ReadOnly Property RebarSystemLayoutRule As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemLayoutRule {
    ForgeTypeId^ get ();
}
static member RebarSystemLayoutRule : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemNumberOfLinesBackDirn1 Property

ParameterTypeIdRebarSystemNumberOfLinesBackDirn1 Property

"Interior Major Number Of Lines"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemNumberOfLinesBackDirn1 { get; }
Public Shared ReadOnly Property RebarSystemNumberOfLinesBackDirn1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemNumberOfLinesBackDirn1 {
    ForgeTypeId^ get ();
}
static member RebarSystemNumberOfLinesBackDirn1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemNumberOfLinesBackDirn2 Property

ParameterTypeIdRebarSystemNumberOfLinesBackDirn2 Property

"Interior Minor Number Of Lines"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemNumberOfLinesBackDirn2 { get; }
Public Shared ReadOnly Property RebarSystemNumberOfLinesBackDirn2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemNumberOfLinesBackDirn2 {
    ForgeTypeId^ get ();
}
static member RebarSystemNumberOfLinesBackDirn2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemNumberOfLinesBottomDir1Generic Property

ParameterTypeIdRebarSystemNumberOfLinesBottomDir1Generic Property

"Bottom/Interior Major Number Of Lines"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemNumberOfLinesBottomDir1Generic { get; }
Public Shared ReadOnly Property RebarSystemNumberOfLinesBottomDir1Generic As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemNumberOfLinesBottomDir1Generic {
    ForgeTypeId^ get ();
}
static member RebarSystemNumberOfLinesBottomDir1Generic : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemNumberOfLinesBottomDir2Generic Property

ParameterTypeIdRebarSystemNumberOfLinesBottomDir2Generic Property

"Bottom/Interior Minor Number Of Lines"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemNumberOfLinesBottomDir2Generic { get; }
Public Shared ReadOnly Property RebarSystemNumberOfLinesBottomDir2Generic As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemNumberOfLinesBottomDir2Generic {
    ForgeTypeId^ get ();
}
static member RebarSystemNumberOfLinesBottomDir2Generic : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemNumberOfLinesBottomDirn1 Property

ParameterTypeIdRebarSystemNumberOfLinesBottomDirn1 Property

"Bottom Major Number Of Lines"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemNumberOfLinesBottomDirn1 { get; }
Public Shared ReadOnly Property RebarSystemNumberOfLinesBottomDirn1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemNumberOfLinesBottomDirn1 {
    ForgeTypeId^ get ();
}
static member RebarSystemNumberOfLinesBottomDirn1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemNumberOfLinesBottomDirn2 Property

ParameterTypeIdRebarSystemNumberOfLinesBottomDirn2 Property

"Bottom Minor Number Of Lines"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemNumberOfLinesBottomDirn2 { get; }
Public Shared ReadOnly Property RebarSystemNumberOfLinesBottomDirn2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemNumberOfLinesBottomDirn2 {
    ForgeTypeId^ get ();
}
static member RebarSystemNumberOfLinesBottomDirn2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemNumberOfLinesFrontDirn1 Property

ParameterTypeIdRebarSystemNumberOfLinesFrontDirn1 Property

"Exterior Major Number Of Lines"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemNumberOfLinesFrontDirn1 { get; }
Public Shared ReadOnly Property RebarSystemNumberOfLinesFrontDirn1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemNumberOfLinesFrontDirn1 {
    ForgeTypeId^ get ();
}
static member RebarSystemNumberOfLinesFrontDirn1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemNumberOfLinesFrontDirn2 Property

ParameterTypeIdRebarSystemNumberOfLinesFrontDirn2 Property

"Exterior Minor Number Of Lines"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemNumberOfLinesFrontDirn2 { get; }
Public Shared ReadOnly Property RebarSystemNumberOfLinesFrontDirn2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemNumberOfLinesFrontDirn2 {
    ForgeTypeId^ get ();
}
static member RebarSystemNumberOfLinesFrontDirn2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemNumberOfLinesTopDir1Generic Property

ParameterTypeIdRebarSystemNumberOfLinesTopDir1Generic Property

"Top/Exterior Major Number Of Lines"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemNumberOfLinesTopDir1Generic { get; }
Public Shared ReadOnly Property RebarSystemNumberOfLinesTopDir1Generic As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemNumberOfLinesTopDir1Generic {
    ForgeTypeId^ get ();
}
static member RebarSystemNumberOfLinesTopDir1Generic : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemNumberOfLinesTopDir2Generic Property

ParameterTypeIdRebarSystemNumberOfLinesTopDir2Generic Property

"Top/Exterior Minor Number Of Lines"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemNumberOfLinesTopDir2Generic { get; }
Public Shared ReadOnly Property RebarSystemNumberOfLinesTopDir2Generic As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemNumberOfLinesTopDir2Generic {
    ForgeTypeId^ get ();
}
static member RebarSystemNumberOfLinesTopDir2Generic : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemNumberOfLinesTopDirn1 Property

ParameterTypeIdRebarSystemNumberOfLinesTopDirn1 Property

"Top Major Number Of Lines"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemNumberOfLinesTopDirn1 { get; }
Public Shared ReadOnly Property RebarSystemNumberOfLinesTopDirn1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemNumberOfLinesTopDirn1 {
    ForgeTypeId^ get ();
}
static member RebarSystemNumberOfLinesTopDirn1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemNumberOfLinesTopDirn2 Property

ParameterTypeIdRebarSystemNumberOfLinesTopDirn2 Property

"Top Minor Number Of Lines"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemNumberOfLinesTopDirn2 { get; }
Public Shared ReadOnly Property RebarSystemNumberOfLinesTopDirn2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemNumberOfLinesTopDirn2 {
    ForgeTypeId^ get ();
}
static member RebarSystemNumberOfLinesTopDirn2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemOverride Property

ParameterTypeIdRebarSystemOverride Property

"Override Area Reinforcement Settings"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemOverride { get; }
Public Shared ReadOnly Property RebarSystemOverride As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemOverride {
    ForgeTypeId^ get ();
}
static member RebarSystemOverride : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemSpacingBackDirn1 Property

ParameterTypeIdRebarSystemSpacingBackDirn1 Property

"Interior Major Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemSpacingBackDirn1 { get; }
Public Shared ReadOnly Property RebarSystemSpacingBackDirn1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemSpacingBackDirn1 {
    ForgeTypeId^ get ();
}
static member RebarSystemSpacingBackDirn1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemSpacingBackDirn2 Property

ParameterTypeIdRebarSystemSpacingBackDirn2 Property

"Interior Minor Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemSpacingBackDirn2 { get; }
Public Shared ReadOnly Property RebarSystemSpacingBackDirn2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemSpacingBackDirn2 {
    ForgeTypeId^ get ();
}
static member RebarSystemSpacingBackDirn2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemSpacingBottomDir1Generic Property

ParameterTypeIdRebarSystemSpacingBottomDir1Generic Property

"Bottom/Interior Major Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemSpacingBottomDir1Generic { get; }
Public Shared ReadOnly Property RebarSystemSpacingBottomDir1Generic As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemSpacingBottomDir1Generic {
    ForgeTypeId^ get ();
}
static member RebarSystemSpacingBottomDir1Generic : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemSpacingBottomDir2Generic Property

ParameterTypeIdRebarSystemSpacingBottomDir2Generic Property

"Bottom/Interior Minor Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemSpacingBottomDir2Generic { get; }
Public Shared ReadOnly Property RebarSystemSpacingBottomDir2Generic As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemSpacingBottomDir2Generic {
    ForgeTypeId^ get ();
}
static member RebarSystemSpacingBottomDir2Generic : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemSpacingBottomDirn1 Property

ParameterTypeIdRebarSystemSpacingBottomDirn1 Property

"Bottom Major Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemSpacingBottomDirn1 { get; }
Public Shared ReadOnly Property RebarSystemSpacingBottomDirn1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemSpacingBottomDirn1 {
    ForgeTypeId^ get ();
}
static member RebarSystemSpacingBottomDirn1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemSpacingBottomDirn2 Property

ParameterTypeIdRebarSystemSpacingBottomDirn2 Property

"Bottom Minor Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemSpacingBottomDirn2 { get; }
Public Shared ReadOnly Property RebarSystemSpacingBottomDirn2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemSpacingBottomDirn2 {
    ForgeTypeId^ get ();
}
static member RebarSystemSpacingBottomDirn2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemSpacingFrontDirn1 Property

ParameterTypeIdRebarSystemSpacingFrontDirn1 Property

"Exterior Major Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemSpacingFrontDirn1 { get; }
Public Shared ReadOnly Property RebarSystemSpacingFrontDirn1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemSpacingFrontDirn1 {
    ForgeTypeId^ get ();
}
static member RebarSystemSpacingFrontDirn1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemSpacingFrontDirn2 Property

ParameterTypeIdRebarSystemSpacingFrontDirn2 Property

"Exterior Minor Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemSpacingFrontDirn2 { get; }
Public Shared ReadOnly Property RebarSystemSpacingFrontDirn2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemSpacingFrontDirn2 {
    ForgeTypeId^ get ();
}
static member RebarSystemSpacingFrontDirn2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemSpacingTopDir1Generic Property

ParameterTypeIdRebarSystemSpacingTopDir1Generic Property

"Top/Exterior Major Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemSpacingTopDir1Generic { get; }
Public Shared ReadOnly Property RebarSystemSpacingTopDir1Generic As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemSpacingTopDir1Generic {
    ForgeTypeId^ get ();
}
static member RebarSystemSpacingTopDir1Generic : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemSpacingTopDir2Generic Property

ParameterTypeIdRebarSystemSpacingTopDir2Generic Property

"Top/Exterior Minor Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemSpacingTopDir2Generic { get; }
Public Shared ReadOnly Property RebarSystemSpacingTopDir2Generic As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemSpacingTopDir2Generic {
    ForgeTypeId^ get ();
}
static member RebarSystemSpacingTopDir2Generic : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemSpacingTopDirn1 Property

ParameterTypeIdRebarSystemSpacingTopDirn1 Property

"Top Major Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemSpacingTopDirn1 { get; }
Public Shared ReadOnly Property RebarSystemSpacingTopDirn1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemSpacingTopDirn1 {
    ForgeTypeId^ get ();
}
static member RebarSystemSpacingTopDirn1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemSpacingTopDirn2 Property

ParameterTypeIdRebarSystemSpacingTopDirn2 Property

"Top Minor Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemSpacingTopDirn2 { get; }
Public Shared ReadOnly Property RebarSystemSpacingTopDirn2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemSpacingTopDirn2 {
    ForgeTypeId^ get ();
}
static member RebarSystemSpacingTopDirn2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemSpanactiveDirn1 Property

ParameterTypeIdRebarSystemSpanactiveDirn1 Property

"Bars In Major Direction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemSpanactiveDirn1 { get; }
Public Shared ReadOnly Property RebarSystemSpanactiveDirn1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemSpanactiveDirn1 {
    ForgeTypeId^ get ();
}
static member RebarSystemSpanactiveDirn1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemSpanactiveDirn2 Property

ParameterTypeIdRebarSystemSpanactiveDirn2 Property

"Bars In Minor Direction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemSpanactiveDirn2 { get; }
Public Shared ReadOnly Property RebarSystemSpanactiveDirn2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemSpanactiveDirn2 {
    ForgeTypeId^ get ();
}
static member RebarSystemSpanactiveDirn2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemSpanhookBottomDirn2 Property

ParameterTypeIdRebarSystemSpanhookBottomDirn2 Property

"Hook Angle Bottom"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemSpanhookBottomDirn2 { get; }
Public Shared ReadOnly Property RebarSystemSpanhookBottomDirn2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemSpanhookBottomDirn2 {
    ForgeTypeId^ get ();
}
static member RebarSystemSpanhookBottomDirn2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemSpanhookLeftDirn1 Property

ParameterTypeIdRebarSystemSpanhookLeftDirn1 Property

"Hook Angle Left"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemSpanhookLeftDirn1 { get; }
Public Shared ReadOnly Property RebarSystemSpanhookLeftDirn1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemSpanhookLeftDirn1 {
    ForgeTypeId^ get ();
}
static member RebarSystemSpanhookLeftDirn1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemSpanhookRightDirn1 Property

ParameterTypeIdRebarSystemSpanhookRightDirn1 Property

"Hook Angle Right"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemSpanhookRightDirn1 { get; }
Public Shared ReadOnly Property RebarSystemSpanhookRightDirn1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemSpanhookRightDirn1 {
    ForgeTypeId^ get ();
}
static member RebarSystemSpanhookRightDirn1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemSpanhookTopDirn2 Property

ParameterTypeIdRebarSystemSpanhookTopDirn2 Property

"Hook Angle Top"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemSpanhookTopDirn2 { get; }
Public Shared ReadOnly Property RebarSystemSpanhookTopDirn2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemSpanhookTopDirn2 {
    ForgeTypeId^ get ();
}
static member RebarSystemSpanhookTopDirn2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemTopMajorMatchesBottomMajor Property

ParameterTypeIdRebarSystemTopMajorMatchesBottomMajor Property

"Top and Bottom Major Layers Match"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemTopMajorMatchesBottomMajor { get; }
Public Shared ReadOnly Property RebarSystemTopMajorMatchesBottomMajor As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemTopMajorMatchesBottomMajor {
    ForgeTypeId^ get ();
}
static member RebarSystemTopMajorMatchesBottomMajor : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemTopMajorMatchesTopMinor Property

ParameterTypeIdRebarSystemTopMajorMatchesTopMinor Property

"Top Major and Minor Layers Match"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemTopMajorMatchesTopMinor { get; }
Public Shared ReadOnly Property RebarSystemTopMajorMatchesTopMinor As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemTopMajorMatchesTopMinor {
    ForgeTypeId^ get ();
}
static member RebarSystemTopMajorMatchesTopMinor : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarSystemTopMinorMatchesBottomMinor Property

ParameterTypeIdRebarSystemTopMinorMatchesBottomMinor Property

"Top and Bottom Minor Layers Match"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarSystemTopMinorMatchesBottomMinor { get; }
Public Shared ReadOnly Property RebarSystemTopMinorMatchesBottomMinor As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarSystemTopMinorMatchesBottomMinor {
    ForgeTypeId^ get ();
}
static member RebarSystemTopMinorMatchesBottomMinor : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RebarWorkshopInstructions Property

ParameterTypeIdRebarWorkshopInstructions Property

"Workshop Instructions"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RebarWorkshopInstructions { get; }
Public Shared ReadOnly Property RebarWorkshopInstructions As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RebarWorkshopInstructions {
    ForgeTypeId^ get ();
}
static member RebarWorkshopInstructions : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RectMullionThick Property

ParameterTypeIdRectMullionThick Property

"Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RectMullionThick { get; }
Public Shared ReadOnly Property RectMullionThick As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RectMullionThick {
    ForgeTypeId^ get ();
}
static member RectMullionThick : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RectMullionWidth1 Property

ParameterTypeIdRectMullionWidth1 Property

"Width on side 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RectMullionWidth1 { get; }
Public Shared ReadOnly Property RectMullionWidth1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RectMullionWidth1 {
    ForgeTypeId^ get ();
}
static member RectMullionWidth1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RectMullionWidth2 Property

ParameterTypeIdRectMullionWidth2 Property

"Width on side 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RectMullionWidth2 { get; }
Public Shared ReadOnly Property RectMullionWidth2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RectMullionWidth2 {
    ForgeTypeId^ get ();
}
static member RectMullionWidth2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ReferenceBaseOnHost Property

ParameterTypeIdReferenceBaseOnHost Property

"Reference Base on Host"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ReferenceBaseOnHost { get; }
Public Shared ReadOnly Property ReferenceBaseOnHost As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ReferenceBaseOnHost {
    ForgeTypeId^ get ();
}
static member ReferenceBaseOnHost : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ReferencedView Property

ParameterTypeIdReferencedView Property

"Referenced View": The view referenced by a section or callout.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ReferencedView { get; }
Public Shared ReadOnly Property ReferencedView As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ReferencedView {
    ForgeTypeId^ get ();
}
static member ReferencedView : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ReferenceLineSubcategory Property

ParameterTypeIdReferenceLineSubcategory Property

"Subcategory"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ReferenceLineSubcategory { get; }
Public Shared ReadOnly Property ReferenceLineSubcategory As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ReferenceLineSubcategory {
    ForgeTypeId^ get ();
}
static member ReferenceLineSubcategory : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ReferenceOtherViewUiRefView Property

ParameterTypeIdReferenceOtherViewUiRefView Property

"Reference View": This is used by the UI to allow selection of view reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ReferenceOtherViewUiRefView { get; }
Public Shared ReadOnly Property ReferenceOtherViewUiRefView As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ReferenceOtherViewUiRefView {
    ForgeTypeId^ get ();
}
static member ReferenceOtherViewUiRefView : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ReferenceOtherViewUiToggle Property

ParameterTypeIdReferenceOtherViewUiToggle Property

"Reference Other View": This is used to determine whether reference other view is enable or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ReferenceOtherViewUiToggle { get; }
Public Shared ReadOnly Property ReferenceOtherViewUiToggle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ReferenceOtherViewUiToggle {
    ForgeTypeId^ get ();
}
static member ReferenceOtherViewUiToggle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ReferenceViewerAttrTag Property

ParameterTypeIdReferenceViewerAttrTag Property

"View Reference Tag"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ReferenceViewerAttrTag { get; }
Public Shared ReadOnly Property ReferenceViewerAttrTag As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ReferenceViewerAttrTag {
    ForgeTypeId^ get ();
}
static member ReferenceViewerAttrTag : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ReferenceViewerTargetView Property

ParameterTypeIdReferenceViewerTargetView Property

"Target view"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ReferenceViewerTargetView { get; }
Public Shared ReadOnly Property ReferenceViewerTargetView As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ReferenceViewerTargetView {
    ForgeTypeId^ get ();
}
static member ReferenceViewerTargetView : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ReferenceViewerUiTargetFilter Property

ParameterTypeIdReferenceViewerUiTargetFilter Property

"Filter": This is used by the UI to filter the list of target views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ReferenceViewerUiTargetFilter { get; }
Public Shared ReadOnly Property ReferenceViewerUiTargetFilter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ReferenceViewerUiTargetFilter {
    ForgeTypeId^ get ();
}
static member ReferenceViewerUiTargetFilter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ReferenceViewerUiTargetView Property

ParameterTypeIdReferenceViewerUiTargetView Property

"Target view": This is used by the UI to allow selection of target view. It allows the UI to set a filter that is incompatible with the current target view (REFERENCE_VIEWER_TARGET_VIEW).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ReferenceViewerUiTargetView { get; }
Public Shared ReadOnly Property ReferenceViewerUiTargetView As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ReferenceViewerUiTargetView {
    ForgeTypeId^ get ();
}
static member ReferenceViewerUiTargetView : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RefTableElemName Property

ParameterTypeIdRefTableElemName Property

"Key Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RefTableElemName { get; }
Public Shared ReadOnly Property RefTableElemName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RefTableElemName {
    ForgeTypeId^ get ();
}
static member RefTableElemName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RefTableParamName Property

ParameterTypeIdRefTableParamName Property

"Parameter Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RefTableParamName { get; }
Public Shared ReadOnly Property RefTableParamName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RefTableParamName {
    ForgeTypeId^ get ();
}
static member RefTableParamName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ReinEstBarLength Property

ParameterTypeIdReinEstBarLength Property

"Estimated Total Bar Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ReinEstBarLength { get; }
Public Shared ReadOnly Property ReinEstBarLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ReinEstBarLength {
    ForgeTypeId^ get ();
}
static member ReinEstBarLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ReinEstBarVolume Property

ParameterTypeIdReinEstBarVolume Property

"Estimated Reinforcement Volume"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ReinEstBarVolume { get; }
Public Shared ReadOnly Property ReinEstBarVolume As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ReinEstBarVolume {
    ForgeTypeId^ get ();
}
static member ReinEstBarVolume : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ReinEstNumberOfBars Property

ParameterTypeIdReinEstNumberOfBars Property

"Estimated Number of Bars"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ReinEstNumberOfBars { get; }
Public Shared ReadOnly Property ReinEstNumberOfBars As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ReinEstNumberOfBars {
    ForgeTypeId^ get ();
}
static member ReinEstNumberOfBars : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ReinforcementVolume Property

ParameterTypeIdReinforcementVolume Property

"Reinforcement Volume"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ReinforcementVolume { get; }
Public Shared ReadOnly Property ReinforcementVolume As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ReinforcementVolume {
    ForgeTypeId^ get ();
}
static member ReinforcementVolume : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RelatedToMass Property

ParameterTypeIdRelatedToMass Property

"Related to Mass"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RelatedToMass { get; }
Public Shared ReadOnly Property RelatedToMass As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RelatedToMass {
    ForgeTypeId^ get ();
}
static member RelatedToMass : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RelativeRoughness Property

ParameterTypeIdRelativeRoughness Property

"Relative Roughness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RelativeRoughness { get; }
Public Shared ReadOnly Property RelativeRoughness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RelativeRoughness {
    ForgeTypeId^ get ();
}
static member RelativeRoughness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RenderPlantHeight Property

ParameterTypeIdRenderPlantHeight Property

"Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RenderPlantHeight { get; }
Public Shared ReadOnly Property RenderPlantHeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RenderPlantHeight {
    ForgeTypeId^ get ();
}
static member RenderPlantHeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RenderPlantName Property

ParameterTypeIdRenderPlantName Property

"Plant Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RenderPlantName { get; }
Public Shared ReadOnly Property RenderPlantName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RenderPlantName {
    ForgeTypeId^ get ();
}
static member RenderPlantName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RenderPlantTrimHeight Property

ParameterTypeIdRenderPlantTrimHeight Property

"Plant Trim Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RenderPlantTrimHeight { get; }
Public Shared ReadOnly Property RenderPlantTrimHeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RenderPlantTrimHeight {
    ForgeTypeId^ get ();
}
static member RenderPlantTrimHeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RenderRpcFilename Property

ParameterTypeIdRenderRpcFilename Property

"Render Appearance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RenderRpcFilename { get; }
Public Shared ReadOnly Property RenderRpcFilename As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RenderRpcFilename {
    ForgeTypeId^ get ();
}
static member RenderRpcFilename : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RenderRpcProperties Property

ParameterTypeIdRenderRpcProperties Property

"Render Appearance Properties"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RenderRpcProperties { get; }
Public Shared ReadOnly Property RenderRpcProperties As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RenderRpcProperties {
    ForgeTypeId^ get ();
}
static member RenderRpcProperties : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RepeatingDetailElement Property

ParameterTypeIdRepeatingDetailElement Property

"Detail"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RepeatingDetailElement { get; }
Public Shared ReadOnly Property RepeatingDetailElement As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RepeatingDetailElement {
    ForgeTypeId^ get ();
}
static member RepeatingDetailElement : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RepeatingDetailInside Property

ParameterTypeIdRepeatingDetailInside Property

"Inside"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RepeatingDetailInside { get; }
Public Shared ReadOnly Property RepeatingDetailInside As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RepeatingDetailInside {
    ForgeTypeId^ get ();
}
static member RepeatingDetailInside : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RepeatingDetailLayout Property

ParameterTypeIdRepeatingDetailLayout Property

"Layout"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RepeatingDetailLayout { get; }
Public Shared ReadOnly Property RepeatingDetailLayout As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RepeatingDetailLayout {
    ForgeTypeId^ get ();
}
static member RepeatingDetailLayout : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RepeatingDetailNumber Property

ParameterTypeIdRepeatingDetailNumber Property

"Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RepeatingDetailNumber { get; }
Public Shared ReadOnly Property RepeatingDetailNumber As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RepeatingDetailNumber {
    ForgeTypeId^ get ();
}
static member RepeatingDetailNumber : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RepeatingDetailRotation Property

ParameterTypeIdRepeatingDetailRotation Property

"Detail Rotation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RepeatingDetailRotation { get; }
Public Shared ReadOnly Property RepeatingDetailRotation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RepeatingDetailRotation {
    ForgeTypeId^ get ();
}
static member RepeatingDetailRotation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RepeatingDetailSpacing Property

ParameterTypeIdRepeatingDetailSpacing Property

"Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RepeatingDetailSpacing { get; }
Public Shared ReadOnly Property RepeatingDetailSpacing As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RepeatingDetailSpacing {
    ForgeTypeId^ get ();
}
static member RepeatingDetailSpacing : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RevealProfileParam Property

ParameterTypeIdRevealProfileParam Property

"Profile"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RevealProfileParam { get; }
Public Shared ReadOnly Property RevealProfileParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RevealProfileParam {
    ForgeTypeId^ get ();
}
static member RevealProfileParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RevisionCloudRevision Property

ParameterTypeIdRevisionCloudRevision Property

"Revision"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RevisionCloudRevision { get; }
Public Shared ReadOnly Property RevisionCloudRevision As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RevisionCloudRevision {
    ForgeTypeId^ get ();
}
static member RevisionCloudRevision : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RevisionCloudRevisionDate Property

ParameterTypeIdRevisionCloudRevisionDate Property

"Revision Date"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RevisionCloudRevisionDate { get; }
Public Shared ReadOnly Property RevisionCloudRevisionDate As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RevisionCloudRevisionDate {
    ForgeTypeId^ get ();
}
static member RevisionCloudRevisionDate : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RevisionCloudRevisionDescription Property

ParameterTypeIdRevisionCloudRevisionDescription Property

"Revision Description"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RevisionCloudRevisionDescription { get; }
Public Shared ReadOnly Property RevisionCloudRevisionDescription As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RevisionCloudRevisionDescription {
    ForgeTypeId^ get ();
}
static member RevisionCloudRevisionDescription : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RevisionCloudRevisionIssuedBy Property

ParameterTypeIdRevisionCloudRevisionIssuedBy Property

"Issued by"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RevisionCloudRevisionIssuedBy { get; }
Public Shared ReadOnly Property RevisionCloudRevisionIssuedBy As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RevisionCloudRevisionIssuedBy {
    ForgeTypeId^ get ();
}
static member RevisionCloudRevisionIssuedBy : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RevisionCloudRevisionIssuedTo Property

ParameterTypeIdRevisionCloudRevisionIssuedTo Property

"Issued to"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RevisionCloudRevisionIssuedTo { get; }
Public Shared ReadOnly Property RevisionCloudRevisionIssuedTo As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RevisionCloudRevisionIssuedTo {
    ForgeTypeId^ get ();
}
static member RevisionCloudRevisionIssuedTo : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RevisionCloudRevisionNum Property

ParameterTypeIdRevisionCloudRevisionNum Property

"Revision Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RevisionCloudRevisionNum { get; }
Public Shared ReadOnly Property RevisionCloudRevisionNum As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RevisionCloudRevisionNum {
    ForgeTypeId^ get ();
}
static member RevisionCloudRevisionNum : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RevolutionEndAngle Property

ParameterTypeIdRevolutionEndAngle Property

"End Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RevolutionEndAngle { get; }
Public Shared ReadOnly Property RevolutionEndAngle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RevolutionEndAngle {
    ForgeTypeId^ get ();
}
static member RevolutionEndAngle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RevolutionStartAngle Property

ParameterTypeIdRevolutionStartAngle Property

"Start Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RevolutionStartAngle { get; }
Public Shared ReadOnly Property RevolutionStartAngle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RevolutionStartAngle {
    ForgeTypeId^ get ();
}
static member RevolutionStartAngle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RgbBParam Property

ParameterTypeIdRgbBParam Property

"Blue value for RGB color spec. (for Use with XAML Data Template example)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RgbBParam { get; }
Public Shared ReadOnly Property RgbBParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RgbBParam {
    ForgeTypeId^ get ();
}
static member RgbBParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RgbGParam Property

ParameterTypeIdRgbGParam Property

"Green value for RGB color spec. (for Use with XAML Data Template example)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RgbGParam { get; }
Public Shared ReadOnly Property RgbGParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RgbGParam {
    ForgeTypeId^ get ();
}
static member RgbGParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RgbRParam Property

ParameterTypeIdRgbRParam Property

"Red value for RGB color spec. (for Use with XAML Data Template example)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RgbRParam { get; }
Public Shared ReadOnly Property RgbRParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RgbRParam {
    ForgeTypeId^ get ();
}
static member RgbRParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoofAttrDefaultThicknessParam Property

ParameterTypeIdRoofAttrDefaultThicknessParam Property

"Default Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoofAttrDefaultThicknessParam { get; }
Public Shared ReadOnly Property RoofAttrDefaultThicknessParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoofAttrDefaultThicknessParam {
    ForgeTypeId^ get ();
}
static member RoofAttrDefaultThicknessParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoofAttrThicknessParam Property

ParameterTypeIdRoofAttrThicknessParam Property

"Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoofAttrThicknessParam { get; }
Public Shared ReadOnly Property RoofAttrThicknessParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoofAttrThicknessParam {
    ForgeTypeId^ get ();
}
static member RoofAttrThicknessParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoofBaseLevelParam Property

ParameterTypeIdRoofBaseLevelParam Property

"Base Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoofBaseLevelParam { get; }
Public Shared ReadOnly Property RoofBaseLevelParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoofBaseLevelParam {
    ForgeTypeId^ get ();
}
static member RoofBaseLevelParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoofConstraintLevelParam Property

ParameterTypeIdRoofConstraintLevelParam Property

"Reference Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoofConstraintLevelParam { get; }
Public Shared ReadOnly Property RoofConstraintLevelParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoofConstraintLevelParam {
    ForgeTypeId^ get ();
}
static member RoofConstraintLevelParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoofConstraintOffsetParam Property

ParameterTypeIdRoofConstraintOffsetParam Property

"Level Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoofConstraintOffsetParam { get; }
Public Shared ReadOnly Property RoofConstraintOffsetParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoofConstraintOffsetParam {
    ForgeTypeId^ get ();
}
static member RoofConstraintOffsetParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoofCurveHeightAtWall Property

ParameterTypeIdRoofCurveHeightAtWall Property

"Plate Offset From Base"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoofCurveHeightAtWall { get; }
Public Shared ReadOnly Property RoofCurveHeightAtWall As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoofCurveHeightAtWall {
    ForgeTypeId^ get ();
}
static member RoofCurveHeightAtWall : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoofCurveHeightOffset Property

ParameterTypeIdRoofCurveHeightOffset Property

"Offset From Roof Base"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoofCurveHeightOffset { get; }
Public Shared ReadOnly Property RoofCurveHeightOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoofCurveHeightOffset {
    ForgeTypeId^ get ();
}
static member RoofCurveHeightOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoofCurveIsSlopeDefining Property

ParameterTypeIdRoofCurveIsSlopeDefining Property

"Defines Roof Slope"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoofCurveIsSlopeDefining { get; }
Public Shared ReadOnly Property RoofCurveIsSlopeDefining As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoofCurveIsSlopeDefining {
    ForgeTypeId^ get ();
}
static member RoofCurveIsSlopeDefining : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoofEaveCutParam Property

ParameterTypeIdRoofEaveCutParam Property

"Rafter Cut"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoofEaveCutParam { get; }
Public Shared ReadOnly Property RoofEaveCutParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoofEaveCutParam {
    ForgeTypeId^ get ();
}
static member RoofEaveCutParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoofFacesLocation Property

ParameterTypeIdRoofFacesLocation Property

"Picked Faces Location"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoofFacesLocation { get; }
Public Shared ReadOnly Property RoofFacesLocation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoofFacesLocation {
    ForgeTypeId^ get ();
}
static member RoofFacesLocation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoofLevelOffsetParam Property

ParameterTypeIdRoofLevelOffsetParam Property

"Base Offset From Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoofLevelOffsetParam { get; }
Public Shared ReadOnly Property RoofLevelOffsetParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoofLevelOffsetParam {
    ForgeTypeId^ get ();
}
static member RoofLevelOffsetParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoofRafterOrTrussParam Property

ParameterTypeIdRoofRafterOrTrussParam Property

"Rafter or Truss"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoofRafterOrTrussParam { get; }
Public Shared ReadOnly Property RoofRafterOrTrussParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoofRafterOrTrussParam {
    ForgeTypeId^ get ();
}
static member RoofRafterOrTrussParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoofSlope Property

ParameterTypeIdRoofSlope Property

"Slope"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoofSlope { get; }
Public Shared ReadOnly Property RoofSlope As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoofSlope {
    ForgeTypeId^ get ();
}
static member RoofSlope : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoofStructureIdParam Property

ParameterTypeIdRoofStructureIdParam Property

"Structure"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoofStructureIdParam { get; }
Public Shared ReadOnly Property RoofStructureIdParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoofStructureIdParam {
    ForgeTypeId^ get ();
}
static member RoofStructureIdParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoofUptoLevelOffsetParam Property

ParameterTypeIdRoofUptoLevelOffsetParam Property

"Cutoff Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoofUptoLevelOffsetParam { get; }
Public Shared ReadOnly Property RoofUptoLevelOffsetParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoofUptoLevelOffsetParam {
    ForgeTypeId^ get ();
}
static member RoofUptoLevelOffsetParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoofUptoLevelParam Property

ParameterTypeIdRoofUptoLevelParam Property

"Cutoff Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoofUptoLevelParam { get; }
Public Shared ReadOnly Property RoofUptoLevelParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoofUptoLevelParam {
    ForgeTypeId^ get ();
}
static member RoofUptoLevelParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomActualExhaustAirflowParam Property

ParameterTypeIdRoomActualExhaustAirflowParam Property

"Actual Exhaust Airflow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomActualExhaustAirflowParam { get; }
Public Shared ReadOnly Property RoomActualExhaustAirflowParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomActualExhaustAirflowParam {
    ForgeTypeId^ get ();
}
static member RoomActualExhaustAirflowParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomActualLightingLoadParam Property

ParameterTypeIdRoomActualLightingLoadParam Property

"Actual Lighting Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomActualLightingLoadParam { get; }
Public Shared ReadOnly Property RoomActualLightingLoadParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomActualLightingLoadParam {
    ForgeTypeId^ get ();
}
static member RoomActualLightingLoadParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomActualLightingLoadPerAreaParam Property

ParameterTypeIdRoomActualLightingLoadPerAreaParam Property

"Actual Lighting Load per area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomActualLightingLoadPerAreaParam { get; }
Public Shared ReadOnly Property RoomActualLightingLoadPerAreaParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomActualLightingLoadPerAreaParam {
    ForgeTypeId^ get ();
}
static member RoomActualLightingLoadPerAreaParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomActualPowerLoadParam Property

ParameterTypeIdRoomActualPowerLoadParam Property

"Actual Power Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomActualPowerLoadParam { get; }
Public Shared ReadOnly Property RoomActualPowerLoadParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomActualPowerLoadParam {
    ForgeTypeId^ get ();
}
static member RoomActualPowerLoadParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomActualPowerLoadPerAreaParam Property

ParameterTypeIdRoomActualPowerLoadPerAreaParam Property

"Actual Power Load per area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomActualPowerLoadPerAreaParam { get; }
Public Shared ReadOnly Property RoomActualPowerLoadPerAreaParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomActualPowerLoadPerAreaParam {
    ForgeTypeId^ get ();
}
static member RoomActualPowerLoadPerAreaParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomActualReturnAirflowParam Property

ParameterTypeIdRoomActualReturnAirflowParam Property

"Actual Return Airflow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomActualReturnAirflowParam { get; }
Public Shared ReadOnly Property RoomActualReturnAirflowParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomActualReturnAirflowParam {
    ForgeTypeId^ get ();
}
static member RoomActualReturnAirflowParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomActualSupplyAirflowParam Property

ParameterTypeIdRoomActualSupplyAirflowParam Property

"Actual Supply Airflow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomActualSupplyAirflowParam { get; }
Public Shared ReadOnly Property RoomActualSupplyAirflowParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomActualSupplyAirflowParam {
    ForgeTypeId^ get ();
}
static member RoomActualSupplyAirflowParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomAirChangesPerHourParam Property

ParameterTypeIdRoomAirChangesPerHourParam Property

"Air Changes per Hour"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomAirChangesPerHourParam { get; }
Public Shared ReadOnly Property RoomAirChangesPerHourParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomAirChangesPerHourParam {
    ForgeTypeId^ get ();
}
static member RoomAirChangesPerHourParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomArea Property

ParameterTypeIdRoomArea Property

"Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomArea { get; }
Public Shared ReadOnly Property RoomArea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomArea {
    ForgeTypeId^ get ();
}
static member RoomArea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomAreaPerPersonParam Property

ParameterTypeIdRoomAreaPerPersonParam Property

"Area per Person"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomAreaPerPersonParam { get; }
Public Shared ReadOnly Property RoomAreaPerPersonParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomAreaPerPersonParam {
    ForgeTypeId^ get ();
}
static member RoomAreaPerPersonParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomBaseHeatLoadOnParam Property

ParameterTypeIdRoomBaseHeatLoadOnParam Property

"Heat Load Values"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomBaseHeatLoadOnParam { get; }
Public Shared ReadOnly Property RoomBaseHeatLoadOnParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomBaseHeatLoadOnParam {
    ForgeTypeId^ get ();
}
static member RoomBaseHeatLoadOnParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomBaseLightingLoadOnParam Property

ParameterTypeIdRoomBaseLightingLoadOnParam Property

"Base Lighting Load on"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomBaseLightingLoadOnParam { get; }
Public Shared ReadOnly Property RoomBaseLightingLoadOnParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomBaseLightingLoadOnParam {
    ForgeTypeId^ get ();
}
static member RoomBaseLightingLoadOnParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomBasePowerLoadOnParam Property

ParameterTypeIdRoomBasePowerLoadOnParam Property

"Base Power Load on"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomBasePowerLoadOnParam { get; }
Public Shared ReadOnly Property RoomBasePowerLoadOnParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomBasePowerLoadOnParam {
    ForgeTypeId^ get ();
}
static member RoomBasePowerLoadOnParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomBaseReturnAirflowOnParam Property

ParameterTypeIdRoomBaseReturnAirflowOnParam Property

"Return Airflow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomBaseReturnAirflowOnParam { get; }
Public Shared ReadOnly Property RoomBaseReturnAirflowOnParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomBaseReturnAirflowOnParam {
    ForgeTypeId^ get ();
}
static member RoomBaseReturnAirflowOnParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomCalculatedCoolingLoadParam Property

ParameterTypeIdRoomCalculatedCoolingLoadParam Property

"Calculated Cooling Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomCalculatedCoolingLoadParam { get; }
Public Shared ReadOnly Property RoomCalculatedCoolingLoadParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomCalculatedCoolingLoadParam {
    ForgeTypeId^ get ();
}
static member RoomCalculatedCoolingLoadParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomCalculatedCoolingLoadPerAreaParam Property

ParameterTypeIdRoomCalculatedCoolingLoadPerAreaParam Property

"Calculated Cooling Load per area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomCalculatedCoolingLoadPerAreaParam { get; }
Public Shared ReadOnly Property RoomCalculatedCoolingLoadPerAreaParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomCalculatedCoolingLoadPerAreaParam {
    ForgeTypeId^ get ();
}
static member RoomCalculatedCoolingLoadPerAreaParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomCalculatedHeatingLoadParam Property

ParameterTypeIdRoomCalculatedHeatingLoadParam Property

"Calculated Heating Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomCalculatedHeatingLoadParam { get; }
Public Shared ReadOnly Property RoomCalculatedHeatingLoadParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomCalculatedHeatingLoadParam {
    ForgeTypeId^ get ();
}
static member RoomCalculatedHeatingLoadParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomCalculatedHeatingLoadPerAreaParam Property

ParameterTypeIdRoomCalculatedHeatingLoadPerAreaParam Property

"Calculated Heating Load per area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomCalculatedHeatingLoadPerAreaParam { get; }
Public Shared ReadOnly Property RoomCalculatedHeatingLoadPerAreaParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomCalculatedHeatingLoadPerAreaParam {
    ForgeTypeId^ get ();
}
static member RoomCalculatedHeatingLoadPerAreaParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomCalculatedSupplyAirflowParam Property

ParameterTypeIdRoomCalculatedSupplyAirflowParam Property

"Calculated Supply Airflow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomCalculatedSupplyAirflowParam { get; }
Public Shared ReadOnly Property RoomCalculatedSupplyAirflowParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomCalculatedSupplyAirflowParam {
    ForgeTypeId^ get ();
}
static member RoomCalculatedSupplyAirflowParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomCalculatedSupplyAirflowPerAreaParam Property

ParameterTypeIdRoomCalculatedSupplyAirflowPerAreaParam Property

"Calculated Supply Airflow per area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomCalculatedSupplyAirflowPerAreaParam { get; }
Public Shared ReadOnly Property RoomCalculatedSupplyAirflowPerAreaParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomCalculatedSupplyAirflowPerAreaParam {
    ForgeTypeId^ get ();
}
static member RoomCalculatedSupplyAirflowPerAreaParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomCalculationPoint Property

ParameterTypeIdRoomCalculationPoint Property

"Room Calculation Point"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomCalculationPoint { get; }
Public Shared ReadOnly Property RoomCalculationPoint As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomCalculationPoint {
    ForgeTypeId^ get ();
}
static member RoomCalculationPoint : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomComputationHeight Property

ParameterTypeIdRoomComputationHeight Property

"Computation Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomComputationHeight { get; }
Public Shared ReadOnly Property RoomComputationHeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomComputationHeight {
    ForgeTypeId^ get ();
}
static member RoomComputationHeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomComputationMethod Property

ParameterTypeIdRoomComputationMethod Property

"Computation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomComputationMethod { get; }
Public Shared ReadOnly Property RoomComputationMethod As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomComputationMethod {
    ForgeTypeId^ get ();
}
static member RoomComputationMethod : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomConditionTypeParam Property

ParameterTypeIdRoomConditionTypeParam Property

"Condition Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomConditionTypeParam { get; }
Public Shared ReadOnly Property RoomConditionTypeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomConditionTypeParam {
    ForgeTypeId^ get ();
}
static member RoomConditionTypeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomConstructionSetParam Property

ParameterTypeIdRoomConstructionSetParam Property

"Construction Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomConstructionSetParam { get; }
Public Shared ReadOnly Property RoomConstructionSetParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomConstructionSetParam {
    ForgeTypeId^ get ();
}
static member RoomConstructionSetParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomDepartment Property

ParameterTypeIdRoomDepartment Property

"Department"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomDepartment { get; }
Public Shared ReadOnly Property RoomDepartment As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomDepartment {
    ForgeTypeId^ get ();
}
static member RoomDepartment : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomDesignCoolingLoadParam Property

ParameterTypeIdRoomDesignCoolingLoadParam Property

"Design Cooling Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomDesignCoolingLoadParam { get; }
Public Shared ReadOnly Property RoomDesignCoolingLoadParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomDesignCoolingLoadParam {
    ForgeTypeId^ get ();
}
static member RoomDesignCoolingLoadParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomDesignExhaustAirflowParam Property

ParameterTypeIdRoomDesignExhaustAirflowParam Property

"Specified Exhaust Airflow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomDesignExhaustAirflowParam { get; }
Public Shared ReadOnly Property RoomDesignExhaustAirflowParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomDesignExhaustAirflowParam {
    ForgeTypeId^ get ();
}
static member RoomDesignExhaustAirflowParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomDesignHeatingLoadParam Property

ParameterTypeIdRoomDesignHeatingLoadParam Property

"Design Heating Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomDesignHeatingLoadParam { get; }
Public Shared ReadOnly Property RoomDesignHeatingLoadParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomDesignHeatingLoadParam {
    ForgeTypeId^ get ();
}
static member RoomDesignHeatingLoadParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomDesignLightingLoadParam Property

ParameterTypeIdRoomDesignLightingLoadParam Property

"Specified Lighting Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomDesignLightingLoadParam { get; }
Public Shared ReadOnly Property RoomDesignLightingLoadParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomDesignLightingLoadParam {
    ForgeTypeId^ get ();
}
static member RoomDesignLightingLoadParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomDesignLightingLoadPerAreaParam Property

ParameterTypeIdRoomDesignLightingLoadPerAreaParam Property

"Specified Lighting Load per area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomDesignLightingLoadPerAreaParam { get; }
Public Shared ReadOnly Property RoomDesignLightingLoadPerAreaParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomDesignLightingLoadPerAreaParam {
    ForgeTypeId^ get ();
}
static member RoomDesignLightingLoadPerAreaParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomDesignMechanicalLoadPerAreaParam Property

ParameterTypeIdRoomDesignMechanicalLoadPerAreaParam Property

"Design HVAC Load per area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomDesignMechanicalLoadPerAreaParam { get; }
Public Shared ReadOnly Property RoomDesignMechanicalLoadPerAreaParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomDesignMechanicalLoadPerAreaParam {
    ForgeTypeId^ get ();
}
static member RoomDesignMechanicalLoadPerAreaParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomDesignOtherLoadPerAreaParam Property

ParameterTypeIdRoomDesignOtherLoadPerAreaParam Property

"Design Other Load per area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomDesignOtherLoadPerAreaParam { get; }
Public Shared ReadOnly Property RoomDesignOtherLoadPerAreaParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomDesignOtherLoadPerAreaParam {
    ForgeTypeId^ get ();
}
static member RoomDesignOtherLoadPerAreaParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomDesignPowerLoadParam Property

ParameterTypeIdRoomDesignPowerLoadParam Property

"Specified Power Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomDesignPowerLoadParam { get; }
Public Shared ReadOnly Property RoomDesignPowerLoadParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomDesignPowerLoadParam {
    ForgeTypeId^ get ();
}
static member RoomDesignPowerLoadParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomDesignPowerLoadPerAreaParam Property

ParameterTypeIdRoomDesignPowerLoadPerAreaParam Property

"Specified Power Load per area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomDesignPowerLoadPerAreaParam { get; }
Public Shared ReadOnly Property RoomDesignPowerLoadPerAreaParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomDesignPowerLoadPerAreaParam {
    ForgeTypeId^ get ();
}
static member RoomDesignPowerLoadPerAreaParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomDesignReturnAirflowParam Property

ParameterTypeIdRoomDesignReturnAirflowParam Property

"Specified Return Airflow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomDesignReturnAirflowParam { get; }
Public Shared ReadOnly Property RoomDesignReturnAirflowParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomDesignReturnAirflowParam {
    ForgeTypeId^ get ();
}
static member RoomDesignReturnAirflowParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomDesignSupplyAirflowParam Property

ParameterTypeIdRoomDesignSupplyAirflowParam Property

"Specified Supply Airflow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomDesignSupplyAirflowParam { get; }
Public Shared ReadOnly Property RoomDesignSupplyAirflowParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomDesignSupplyAirflowParam {
    ForgeTypeId^ get ();
}
static member RoomDesignSupplyAirflowParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomEditElectricalLoadsParam Property

ParameterTypeIdRoomEditElectricalLoadsParam Property

"Electrical Loads"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomEditElectricalLoadsParam { get; }
Public Shared ReadOnly Property RoomEditElectricalLoadsParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomEditElectricalLoadsParam {
    ForgeTypeId^ get ();
}
static member RoomEditElectricalLoadsParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomEditPeopleLoadsParam Property

ParameterTypeIdRoomEditPeopleLoadsParam Property

"People"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomEditPeopleLoadsParam { get; }
Public Shared ReadOnly Property RoomEditPeopleLoadsParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomEditPeopleLoadsParam {
    ForgeTypeId^ get ();
}
static member RoomEditPeopleLoadsParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomFinishBase Property

ParameterTypeIdRoomFinishBase Property

"Base Finish"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomFinishBase { get; }
Public Shared ReadOnly Property RoomFinishBase As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomFinishBase {
    ForgeTypeId^ get ();
}
static member RoomFinishBase : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomFinishCeiling Property

ParameterTypeIdRoomFinishCeiling Property

"Ceiling Finish"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomFinishCeiling { get; }
Public Shared ReadOnly Property RoomFinishCeiling As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomFinishCeiling {
    ForgeTypeId^ get ();
}
static member RoomFinishCeiling : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomFinishFloor Property

ParameterTypeIdRoomFinishFloor Property

"Floor Finish"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomFinishFloor { get; }
Public Shared ReadOnly Property RoomFinishFloor As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomFinishFloor {
    ForgeTypeId^ get ();
}
static member RoomFinishFloor : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomFinishWall Property

ParameterTypeIdRoomFinishWall Property

"Wall Finish"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomFinishWall { get; }
Public Shared ReadOnly Property RoomFinishWall As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomFinishWall {
    ForgeTypeId^ get ();
}
static member RoomFinishWall : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomHeight Property

ParameterTypeIdRoomHeight Property

"Unbounded Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomHeight { get; }
Public Shared ReadOnly Property RoomHeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomHeight {
    ForgeTypeId^ get ();
}
static member RoomHeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomLevelId Property

ParameterTypeIdRoomLevelId Property

"Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomLevelId { get; }
Public Shared ReadOnly Property RoomLevelId As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomLevelId {
    ForgeTypeId^ get ();
}
static member RoomLevelId : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomLightingLoadUnitsParam Property

ParameterTypeIdRoomLightingLoadUnitsParam Property

"Lighting Load Units"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomLightingLoadUnitsParam { get; }
Public Shared ReadOnly Property RoomLightingLoadUnitsParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomLightingLoadUnitsParam {
    ForgeTypeId^ get ();
}
static member RoomLightingLoadUnitsParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomLowerOffset Property

ParameterTypeIdRoomLowerOffset Property

"Base Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomLowerOffset { get; }
Public Shared ReadOnly Property RoomLowerOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomLowerOffset {
    ForgeTypeId^ get ();
}
static member RoomLowerOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomName Property

ParameterTypeIdRoomName Property

"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomName { get; }
Public Shared ReadOnly Property RoomName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomName {
    ForgeTypeId^ get ();
}
static member RoomName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomNumber Property

ParameterTypeIdRoomNumber Property

"Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomNumber { get; }
Public Shared ReadOnly Property RoomNumber As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomNumber {
    ForgeTypeId^ get ();
}
static member RoomNumber : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomNumberOfPeopleParam Property

ParameterTypeIdRoomNumberOfPeopleParam Property

"Number of People"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomNumberOfPeopleParam { get; }
Public Shared ReadOnly Property RoomNumberOfPeopleParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomNumberOfPeopleParam {
    ForgeTypeId^ get ();
}
static member RoomNumberOfPeopleParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomOccupancy Property

ParameterTypeIdRoomOccupancy Property

"Occupancy"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomOccupancy { get; }
Public Shared ReadOnly Property RoomOccupancy As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomOccupancy {
    ForgeTypeId^ get ();
}
static member RoomOccupancy : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomOccupancyUnitParam Property

ParameterTypeIdRoomOccupancyUnitParam Property

"Occupancy Unit"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomOccupancyUnitParam { get; }
Public Shared ReadOnly Property RoomOccupancyUnitParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomOccupancyUnitParam {
    ForgeTypeId^ get ();
}
static member RoomOccupancyUnitParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomOutdoorAirflowParam Property

ParameterTypeIdRoomOutdoorAirflowParam Property

"Outdoor Airflow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomOutdoorAirflowParam { get; }
Public Shared ReadOnly Property RoomOutdoorAirflowParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomOutdoorAirflowParam {
    ForgeTypeId^ get ();
}
static member RoomOutdoorAirflowParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomOutdoorAirflowStandardParam Property

ParameterTypeIdRoomOutdoorAirflowStandardParam Property

"Outdoor Air Method"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomOutdoorAirflowStandardParam { get; }
Public Shared ReadOnly Property RoomOutdoorAirflowStandardParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomOutdoorAirflowStandardParam {
    ForgeTypeId^ get ();
}
static member RoomOutdoorAirflowStandardParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomOutdoorAirInfoParam Property

ParameterTypeIdRoomOutdoorAirInfoParam Property

"Outdoor Air Information"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomOutdoorAirInfoParam { get; }
Public Shared ReadOnly Property RoomOutdoorAirInfoParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomOutdoorAirInfoParam {
    ForgeTypeId^ get ();
}
static member RoomOutdoorAirInfoParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomOutdoorAirPerAreaParam Property

ParameterTypeIdRoomOutdoorAirPerAreaParam Property

"Outdoor Air per Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomOutdoorAirPerAreaParam { get; }
Public Shared ReadOnly Property RoomOutdoorAirPerAreaParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomOutdoorAirPerAreaParam {
    ForgeTypeId^ get ();
}
static member RoomOutdoorAirPerAreaParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomOutdoorAirPerPersonParam Property

ParameterTypeIdRoomOutdoorAirPerPersonParam Property

"Outdoor Air per Person"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomOutdoorAirPerPersonParam { get; }
Public Shared ReadOnly Property RoomOutdoorAirPerPersonParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomOutdoorAirPerPersonParam {
    ForgeTypeId^ get ();
}
static member RoomOutdoorAirPerPersonParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomPeopleLatentHeatGainPerPersonParam Property

ParameterTypeIdRoomPeopleLatentHeatGainPerPersonParam Property

"Latent Heat Gain per person"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomPeopleLatentHeatGainPerPersonParam { get; }
Public Shared ReadOnly Property RoomPeopleLatentHeatGainPerPersonParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomPeopleLatentHeatGainPerPersonParam {
    ForgeTypeId^ get ();
}
static member RoomPeopleLatentHeatGainPerPersonParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomPeopleSensibleHeatGainPerPersonParam Property

ParameterTypeIdRoomPeopleSensibleHeatGainPerPersonParam Property

"Sensible Heat Gain per person"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomPeopleSensibleHeatGainPerPersonParam { get; }
Public Shared ReadOnly Property RoomPeopleSensibleHeatGainPerPersonParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomPeopleSensibleHeatGainPerPersonParam {
    ForgeTypeId^ get ();
}
static member RoomPeopleSensibleHeatGainPerPersonParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomPeopleTotalHeatGainPerPersonParam Property

ParameterTypeIdRoomPeopleTotalHeatGainPerPersonParam Property

"Total Heat Gain per person"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomPeopleTotalHeatGainPerPersonParam { get; }
Public Shared ReadOnly Property RoomPeopleTotalHeatGainPerPersonParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomPeopleTotalHeatGainPerPersonParam {
    ForgeTypeId^ get ();
}
static member RoomPeopleTotalHeatGainPerPersonParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomPerimeter Property

ParameterTypeIdRoomPerimeter Property

"Perimeter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomPerimeter { get; }
Public Shared ReadOnly Property RoomPerimeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomPerimeter {
    ForgeTypeId^ get ();
}
static member RoomPerimeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomPhase Property

ParameterTypeIdRoomPhase Property

"Phase"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomPhase { get; }
Public Shared ReadOnly Property RoomPhase As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomPhase {
    ForgeTypeId^ get ();
}
static member RoomPhase : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomPhaseId Property

ParameterTypeIdRoomPhaseId Property

"Phase Id"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomPhaseId { get; }
Public Shared ReadOnly Property RoomPhaseId As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomPhaseId {
    ForgeTypeId^ get ();
}
static member RoomPhaseId : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomPlenumLightingParam Property

ParameterTypeIdRoomPlenumLightingParam Property

"Plenum Lighting Contribution"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomPlenumLightingParam { get; }
Public Shared ReadOnly Property RoomPlenumLightingParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomPlenumLightingParam {
    ForgeTypeId^ get ();
}
static member RoomPlenumLightingParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomPowerLoadUnitsParam Property

ParameterTypeIdRoomPowerLoadUnitsParam Property

"Power Load Units"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomPowerLoadUnitsParam { get; }
Public Shared ReadOnly Property RoomPowerLoadUnitsParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomPowerLoadUnitsParam {
    ForgeTypeId^ get ();
}
static member RoomPowerLoadUnitsParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomSpaceTypeParam Property

ParameterTypeIdRoomSpaceTypeParam Property

"Space Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomSpaceTypeParam { get; }
Public Shared ReadOnly Property RoomSpaceTypeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomSpaceTypeParam {
    ForgeTypeId^ get ();
}
static member RoomSpaceTypeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomTagOrientationParam Property

ParameterTypeIdRoomTagOrientationParam Property

"Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomTagOrientationParam { get; }
Public Shared ReadOnly Property RoomTagOrientationParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomTagOrientationParam {
    ForgeTypeId^ get ();
}
static member RoomTagOrientationParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomUpperLevel Property

ParameterTypeIdRoomUpperLevel Property

"Upper Limit"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomUpperLevel { get; }
Public Shared ReadOnly Property RoomUpperLevel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomUpperLevel {
    ForgeTypeId^ get ();
}
static member RoomUpperLevel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomUpperOffset Property

ParameterTypeIdRoomUpperOffset Property

"Limit Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomUpperOffset { get; }
Public Shared ReadOnly Property RoomUpperOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomUpperOffset {
    ForgeTypeId^ get ();
}
static member RoomUpperOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoomVolume Property

ParameterTypeIdRoomVolume Property

"Volume"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoomVolume { get; }
Public Shared ReadOnly Property RoomVolume As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoomVolume {
    ForgeTypeId^ get ();
}
static member RoomVolume : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RouteAnalysisSettingsParam Property

ParameterTypeIdRouteAnalysisSettingsParam Property

"Route Analysis Settings"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RouteAnalysisSettingsParam { get; }
Public Shared ReadOnly Property RouteAnalysisSettingsParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RouteAnalysisSettingsParam {
    ForgeTypeId^ get ();
}
static member RouteAnalysisSettingsParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RoutingPreferenceParam Property

ParameterTypeIdRoutingPreferenceParam Property

"Routing Preference"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RoutingPreferenceParam { get; }
Public Shared ReadOnly Property RoutingPreferenceParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RoutingPreferenceParam {
    ForgeTypeId^ get ();
}
static member RoutingPreferenceParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RvtHostLevel Property

ParameterTypeIdRvtHostLevel Property

"Map Levels..."

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RvtHostLevel { get; }
Public Shared ReadOnly Property RvtHostLevel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RvtHostLevel {
    ForgeTypeId^ get ();
}
static member RvtHostLevel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RvtLevelOffset Property

ParameterTypeIdRvtLevelOffset Property

"Map Levels..."

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RvtLevelOffset { get; }
Public Shared ReadOnly Property RvtLevelOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RvtLevelOffset {
    ForgeTypeId^ get ();
}
static member RvtLevelOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RvtLinkFileNameWithoutExt Property

ParameterTypeIdRvtLinkFileNameWithoutExt Property

"File Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RvtLinkFileNameWithoutExt { get; }
Public Shared ReadOnly Property RvtLinkFileNameWithoutExt As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RvtLinkFileNameWithoutExt {
    ForgeTypeId^ get ();
}
static member RvtLinkFileNameWithoutExt : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RvtLinkInstanceName Property

ParameterTypeIdRvtLinkInstanceName Property

"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RvtLinkInstanceName { get; }
Public Shared ReadOnly Property RvtLinkInstanceName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RvtLinkInstanceName {
    ForgeTypeId^ get ();
}
static member RvtLinkInstanceName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RvtLinkInstanceProjectInformation Property

ParameterTypeIdRvtLinkInstanceProjectInformation Property

"Project Information"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RvtLinkInstanceProjectInformation { get; }
Public Shared ReadOnly Property RvtLinkInstanceProjectInformation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RvtLinkInstanceProjectInformation {
    ForgeTypeId^ get ();
}
static member RvtLinkInstanceProjectInformation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RvtLinkPhaseMap Property

ParameterTypeIdRvtLinkPhaseMap Property

"Phase Mapping"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RvtLinkPhaseMap { get; }
Public Shared ReadOnly Property RvtLinkPhaseMap As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RvtLinkPhaseMap {
    ForgeTypeId^ get ();
}
static member RvtLinkPhaseMap : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RvtLinkReferenceType Property

ParameterTypeIdRvtLinkReferenceType Property

"Reference Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RvtLinkReferenceType { get; }
Public Shared ReadOnly Property RvtLinkReferenceType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RvtLinkReferenceType {
    ForgeTypeId^ get ();
}
static member RvtLinkReferenceType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.RvtSourceLevel Property

ParameterTypeIdRvtSourceLevel Property

"Map Levels..."

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RvtSourceLevel { get; }
Public Shared ReadOnly Property RvtSourceLevel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RvtSourceLevel {
    ForgeTypeId^ get ();
}
static member RvtSourceLevel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ScaleFactorParam Property

ParameterTypeIdScaleFactorParam Property

"Scale"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ScaleFactorParam { get; }
Public Shared ReadOnly Property ScaleFactorParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ScaleFactorParam {
    ForgeTypeId^ get ();
}
static member ScaleFactorParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ScheduleBaseLevelOffsetParam Property

ParameterTypeIdScheduleBaseLevelOffsetParam Property

"Base Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ScheduleBaseLevelOffsetParam { get; }
Public Shared ReadOnly Property ScheduleBaseLevelOffsetParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ScheduleBaseLevelOffsetParam {
    ForgeTypeId^ get ();
}
static member ScheduleBaseLevelOffsetParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ScheduleBaseLevelParam Property

ParameterTypeIdScheduleBaseLevelParam Property

"Base Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ScheduleBaseLevelParam { get; }
Public Shared ReadOnly Property ScheduleBaseLevelParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ScheduleBaseLevelParam {
    ForgeTypeId^ get ();
}
static member ScheduleBaseLevelParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ScheduleCategory Property

ParameterTypeIdScheduleCategory Property

"Category"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ScheduleCategory { get; }
Public Shared ReadOnly Property ScheduleCategory As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ScheduleCategory {
    ForgeTypeId^ get ();
}
static member ScheduleCategory : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ScheduleEmbeddedParam Property

ParameterTypeIdScheduleEmbeddedParam Property

"Embedded Schedule"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ScheduleEmbeddedParam { get; }
Public Shared ReadOnly Property ScheduleEmbeddedParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ScheduleEmbeddedParam {
    ForgeTypeId^ get ();
}
static member ScheduleEmbeddedParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ScheduleFieldsParam Property

ParameterTypeIdScheduleFieldsParam Property

"Fields"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ScheduleFieldsParam { get; }
Public Shared ReadOnly Property ScheduleFieldsParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ScheduleFieldsParam {
    ForgeTypeId^ get ();
}
static member ScheduleFieldsParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ScheduleFilterParam Property

ParameterTypeIdScheduleFilterParam Property

"Filter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ScheduleFilterParam { get; }
Public Shared ReadOnly Property ScheduleFilterParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ScheduleFilterParam {
    ForgeTypeId^ get ();
}
static member ScheduleFilterParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ScheduleFormatParam Property

ParameterTypeIdScheduleFormatParam Property

"Formatting"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ScheduleFormatParam { get; }
Public Shared ReadOnly Property ScheduleFormatParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ScheduleFormatParam {
    ForgeTypeId^ get ();
}
static member ScheduleFormatParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ScheduleGroupParam Property

ParameterTypeIdScheduleGroupParam Property

"Sorting/Grouping"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ScheduleGroupParam { get; }
Public Shared ReadOnly Property ScheduleGroupParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ScheduleGroupParam {
    ForgeTypeId^ get ();
}
static member ScheduleGroupParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ScheduleLevelParam Property

ParameterTypeIdScheduleLevelParam Property

"Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ScheduleLevelParam { get; }
Public Shared ReadOnly Property ScheduleLevelParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ScheduleLevelParam {
    ForgeTypeId^ get ();
}
static member ScheduleLevelParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ScheduleResizeRows Property

ParameterTypeIdScheduleResizeRows Property

"Resize Rows"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ScheduleResizeRows { get; }
Public Shared ReadOnly Property ScheduleResizeRows As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ScheduleResizeRows {
    ForgeTypeId^ get ();
}
static member ScheduleResizeRows : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ScheduleRotationOnSheet Property

ParameterTypeIdScheduleRotationOnSheet Property

"Rotation on Sheet"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ScheduleRotationOnSheet { get; }
Public Shared ReadOnly Property ScheduleRotationOnSheet As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ScheduleRotationOnSheet {
    ForgeTypeId^ get ();
}
static member ScheduleRotationOnSheet : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ScheduleRowHeightInput Property

ParameterTypeIdScheduleRowHeightInput Property

"Row Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ScheduleRowHeightInput { get; }
Public Shared ReadOnly Property ScheduleRowHeightInput As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ScheduleRowHeightInput {
    ForgeTypeId^ get ();
}
static member ScheduleRowHeightInput : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ScheduleSheetAppearanceParam Property

ParameterTypeIdScheduleSheetAppearanceParam Property

"Appearance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ScheduleSheetAppearanceParam { get; }
Public Shared ReadOnly Property ScheduleSheetAppearanceParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ScheduleSheetAppearanceParam {
    ForgeTypeId^ get ();
}
static member ScheduleSheetAppearanceParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ScheduleTopLevelOffsetParam Property

ParameterTypeIdScheduleTopLevelOffsetParam Property

"Top Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ScheduleTopLevelOffsetParam { get; }
Public Shared ReadOnly Property ScheduleTopLevelOffsetParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ScheduleTopLevelOffsetParam {
    ForgeTypeId^ get ();
}
static member ScheduleTopLevelOffsetParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ScheduleTopLevelParam Property

ParameterTypeIdScheduleTopLevelParam Property

"Top Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ScheduleTopLevelParam { get; }
Public Shared ReadOnly Property ScheduleTopLevelParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ScheduleTopLevelParam {
    ForgeTypeId^ get ();
}
static member ScheduleTopLevelParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ScheduleTypeForBrowser Property

ParameterTypeIdScheduleTypeForBrowser Property

"Schedule Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ScheduleTypeForBrowser { get; }
Public Shared ReadOnly Property ScheduleTypeForBrowser As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ScheduleTypeForBrowser {
    ForgeTypeId^ get ();
}
static member ScheduleTypeForBrowser : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SectionAttrHeadTag Property

ParameterTypeIdSectionAttrHeadTag Property

"Section Head"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SectionAttrHeadTag { get; }
Public Shared ReadOnly Property SectionAttrHeadTag As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SectionAttrHeadTag {
    ForgeTypeId^ get ();
}
static member SectionAttrHeadTag : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SectionAttrTailLength Property

ParameterTypeIdSectionAttrTailLength Property

"Tail length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SectionAttrTailLength { get; }
Public Shared ReadOnly Property SectionAttrTailLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SectionAttrTailLength {
    ForgeTypeId^ get ();
}
static member SectionAttrTailLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SectionAttrTailTag Property

ParameterTypeIdSectionAttrTailTag Property

"Section Tail"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SectionAttrTailTag { get; }
Public Shared ReadOnly Property SectionAttrTailTag As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SectionAttrTailTag {
    ForgeTypeId^ get ();
}
static member SectionAttrTailTag : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SectionAttrTailWidth Property

ParameterTypeIdSectionAttrTailWidth Property

"Tail width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SectionAttrTailWidth { get; }
Public Shared ReadOnly Property SectionAttrTailWidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SectionAttrTailWidth {
    ForgeTypeId^ get ();
}
static member SectionAttrTailWidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SectionBrokenDisplayStyle Property

ParameterTypeIdSectionBrokenDisplayStyle Property

"Broken Section Display Style"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SectionBrokenDisplayStyle { get; }
Public Shared ReadOnly Property SectionBrokenDisplayStyle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SectionBrokenDisplayStyle {
    ForgeTypeId^ get ();
}
static member SectionBrokenDisplayStyle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SectionCoarserScalePulldownImperial Property

ParameterTypeIdSectionCoarserScalePulldownImperial Property

"Hide at scales coarser than"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SectionCoarserScalePulldownImperial { get; }
Public Shared ReadOnly Property SectionCoarserScalePulldownImperial As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SectionCoarserScalePulldownImperial {
    ForgeTypeId^ get ();
}
static member SectionCoarserScalePulldownImperial : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SectionCoarserScalePulldownMetric Property

ParameterTypeIdSectionCoarserScalePulldownMetric Property

"Hide at scales coarser than"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SectionCoarserScalePulldownMetric { get; }
Public Shared ReadOnly Property SectionCoarserScalePulldownMetric As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SectionCoarserScalePulldownMetric {
    ForgeTypeId^ get ();
}
static member SectionCoarserScalePulldownMetric : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SectionParentViewName Property

ParameterTypeIdSectionParentViewName Property

"Parent View"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SectionParentViewName { get; }
Public Shared ReadOnly Property SectionParentViewName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SectionParentViewName {
    ForgeTypeId^ get ();
}
static member SectionParentViewName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SectionShowInOneViewOnly Property

ParameterTypeIdSectionShowInOneViewOnly Property

"Show in"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SectionShowInOneViewOnly { get; }
Public Shared ReadOnly Property SectionShowInOneViewOnly As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SectionShowInOneViewOnly {
    ForgeTypeId^ get ();
}
static member SectionShowInOneViewOnly : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SectionTag Property

ParameterTypeIdSectionTag Property

"Section Tag"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SectionTag { get; }
Public Shared ReadOnly Property SectionTag As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SectionTag {
    ForgeTypeId^ get ();
}
static member SectionTag : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SeekItemId Property

ParameterTypeIdSeekItemId Property

"Seek Item ID"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SeekItemId { get; }
Public Shared ReadOnly Property SeekItemId As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SeekItemId {
    ForgeTypeId^ get ();
}
static member SeekItemId : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SelectionEditableOnly Property

ParameterTypeIdSelectionEditableOnly Property

"Editable only"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SelectionEditableOnly { get; }
Public Shared ReadOnly Property SelectionEditableOnly As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SelectionEditableOnly {
    ForgeTypeId^ get ();
}
static member SelectionEditableOnly : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SheetApprovedBy Property

ParameterTypeIdSheetApprovedBy Property

"Approved By"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SheetApprovedBy { get; }
Public Shared ReadOnly Property SheetApprovedBy As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SheetApprovedBy {
    ForgeTypeId^ get ();
}
static member SheetApprovedBy : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SheetAssemblyAssemblyCode Property

ParameterTypeIdSheetAssemblyAssemblyCode Property

"Assembly: Assembly Code"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SheetAssemblyAssemblyCode { get; }
Public Shared ReadOnly Property SheetAssemblyAssemblyCode As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SheetAssemblyAssemblyCode {
    ForgeTypeId^ get ();
}
static member SheetAssemblyAssemblyCode : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SheetAssemblyAssemblyDescription Property

ParameterTypeIdSheetAssemblyAssemblyDescription Property

"Assembly: Assembly Description"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SheetAssemblyAssemblyDescription { get; }
Public Shared ReadOnly Property SheetAssemblyAssemblyDescription As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SheetAssemblyAssemblyDescription {
    ForgeTypeId^ get ();
}
static member SheetAssemblyAssemblyDescription : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SheetAssemblyCost Property

ParameterTypeIdSheetAssemblyCost Property

"Assembly: Cost"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SheetAssemblyCost { get; }
Public Shared ReadOnly Property SheetAssemblyCost As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SheetAssemblyCost {
    ForgeTypeId^ get ();
}
static member SheetAssemblyCost : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SheetAssemblyDescription Property

ParameterTypeIdSheetAssemblyDescription Property

"Assembly: Description"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SheetAssemblyDescription { get; }
Public Shared ReadOnly Property SheetAssemblyDescription As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SheetAssemblyDescription {
    ForgeTypeId^ get ();
}
static member SheetAssemblyDescription : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SheetAssemblyKeynote Property

ParameterTypeIdSheetAssemblyKeynote Property

"Assembly: Keynote"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SheetAssemblyKeynote { get; }
Public Shared ReadOnly Property SheetAssemblyKeynote As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SheetAssemblyKeynote {
    ForgeTypeId^ get ();
}
static member SheetAssemblyKeynote : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SheetAssemblyManufacturer Property

ParameterTypeIdSheetAssemblyManufacturer Property

"Assembly: Manufacturer"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SheetAssemblyManufacturer { get; }
Public Shared ReadOnly Property SheetAssemblyManufacturer As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SheetAssemblyManufacturer {
    ForgeTypeId^ get ();
}
static member SheetAssemblyManufacturer : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SheetAssemblyModel Property

ParameterTypeIdSheetAssemblyModel Property

"Assembly: Model"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SheetAssemblyModel { get; }
Public Shared ReadOnly Property SheetAssemblyModel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SheetAssemblyModel {
    ForgeTypeId^ get ();
}
static member SheetAssemblyModel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SheetAssemblyName Property

ParameterTypeIdSheetAssemblyName Property

"Assembly: Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SheetAssemblyName { get; }
Public Shared ReadOnly Property SheetAssemblyName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SheetAssemblyName {
    ForgeTypeId^ get ();
}
static member SheetAssemblyName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SheetAssemblyTypeComments Property

ParameterTypeIdSheetAssemblyTypeComments Property

"Assembly: Type Comments"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SheetAssemblyTypeComments { get; }
Public Shared ReadOnly Property SheetAssemblyTypeComments As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SheetAssemblyTypeComments {
    ForgeTypeId^ get ();
}
static member SheetAssemblyTypeComments : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SheetAssemblyTypeMark Property

ParameterTypeIdSheetAssemblyTypeMark Property

"Assembly: Type Mark"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SheetAssemblyTypeMark { get; }
Public Shared ReadOnly Property SheetAssemblyTypeMark As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SheetAssemblyTypeMark {
    ForgeTypeId^ get ();
}
static member SheetAssemblyTypeMark : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SheetAssemblyUrl Property

ParameterTypeIdSheetAssemblyUrl Property

"Assembly: URL"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SheetAssemblyUrl { get; }
Public Shared ReadOnly Property SheetAssemblyUrl As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SheetAssemblyUrl {
    ForgeTypeId^ get ();
}
static member SheetAssemblyUrl : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SheetCheckedBy Property

ParameterTypeIdSheetCheckedBy Property

"Checked By"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SheetCheckedBy { get; }
Public Shared ReadOnly Property SheetCheckedBy As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SheetCheckedBy {
    ForgeTypeId^ get ();
}
static member SheetCheckedBy : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SheetCollection Property

ParameterTypeIdSheetCollection Property

"Sheet Collection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SheetCollection { get; }
Public Shared ReadOnly Property SheetCollection As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SheetCollection {
    ForgeTypeId^ get ();
}
static member SheetCollection : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SheetCollectionName Property

ParameterTypeIdSheetCollectionName Property

"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SheetCollectionName { get; }
Public Shared ReadOnly Property SheetCollectionName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SheetCollectionName {
    ForgeTypeId^ get ();
}
static member SheetCollectionName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SheetCurrentRevision Property

ParameterTypeIdSheetCurrentRevision Property

"Current Revision"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SheetCurrentRevision { get; }
Public Shared ReadOnly Property SheetCurrentRevision As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SheetCurrentRevision {
    ForgeTypeId^ get ();
}
static member SheetCurrentRevision : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SheetCurrentRevisionDate Property

ParameterTypeIdSheetCurrentRevisionDate Property

"Current Revision Date"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SheetCurrentRevisionDate { get; }
Public Shared ReadOnly Property SheetCurrentRevisionDate As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SheetCurrentRevisionDate {
    ForgeTypeId^ get ();
}
static member SheetCurrentRevisionDate : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SheetCurrentRevisionDescription Property

ParameterTypeIdSheetCurrentRevisionDescription Property

"Current Revision Description"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SheetCurrentRevisionDescription { get; }
Public Shared ReadOnly Property SheetCurrentRevisionDescription As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SheetCurrentRevisionDescription {
    ForgeTypeId^ get ();
}
static member SheetCurrentRevisionDescription : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SheetCurrentRevisionIssued Property

ParameterTypeIdSheetCurrentRevisionIssued Property

"Current Revision Issued"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SheetCurrentRevisionIssued { get; }
Public Shared ReadOnly Property SheetCurrentRevisionIssued As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SheetCurrentRevisionIssued {
    ForgeTypeId^ get ();
}
static member SheetCurrentRevisionIssued : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SheetCurrentRevisionIssuedBy Property

ParameterTypeIdSheetCurrentRevisionIssuedBy Property

"Current Revision Issued By"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SheetCurrentRevisionIssuedBy { get; }
Public Shared ReadOnly Property SheetCurrentRevisionIssuedBy As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SheetCurrentRevisionIssuedBy {
    ForgeTypeId^ get ();
}
static member SheetCurrentRevisionIssuedBy : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SheetCurrentRevisionIssuedTo Property

ParameterTypeIdSheetCurrentRevisionIssuedTo Property

"Current Revision Issued To"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SheetCurrentRevisionIssuedTo { get; }
Public Shared ReadOnly Property SheetCurrentRevisionIssuedTo As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SheetCurrentRevisionIssuedTo {
    ForgeTypeId^ get ();
}
static member SheetCurrentRevisionIssuedTo : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SheetDate Property

ParameterTypeIdSheetDate Property

"Date/Time Stamp"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SheetDate { get; }
Public Shared ReadOnly Property SheetDate As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SheetDate {
    ForgeTypeId^ get ();
}
static member SheetDate : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SheetDesignedBy Property

ParameterTypeIdSheetDesignedBy Property

"Designed By"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SheetDesignedBy { get; }
Public Shared ReadOnly Property SheetDesignedBy As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SheetDesignedBy {
    ForgeTypeId^ get ();
}
static member SheetDesignedBy : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SheetDrawnBy Property

ParameterTypeIdSheetDrawnBy Property

"Drawn By"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SheetDrawnBy { get; }
Public Shared ReadOnly Property SheetDrawnBy As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SheetDrawnBy {
    ForgeTypeId^ get ();
}
static member SheetDrawnBy : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SheetFilePath Property

ParameterTypeIdSheetFilePath Property

"File Path"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SheetFilePath { get; }
Public Shared ReadOnly Property SheetFilePath As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SheetFilePath {
    ForgeTypeId^ get ();
}
static member SheetFilePath : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SheetGuideGrid Property

ParameterTypeIdSheetGuideGrid Property

"Guide Grid"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SheetGuideGrid { get; }
Public Shared ReadOnly Property SheetGuideGrid As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SheetGuideGrid {
    ForgeTypeId^ get ();
}
static member SheetGuideGrid : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SheetHeight Property

ParameterTypeIdSheetHeight Property

"Sheet Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SheetHeight { get; }
Public Shared ReadOnly Property SheetHeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SheetHeight {
    ForgeTypeId^ get ();
}
static member SheetHeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SheetIssueDate Property

ParameterTypeIdSheetIssueDate Property

"Sheet Issue Date"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SheetIssueDate { get; }
Public Shared ReadOnly Property SheetIssueDate As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SheetIssueDate {
    ForgeTypeId^ get ();
}
static member SheetIssueDate : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SheetKeyNumber Property

ParameterTypeIdSheetKeyNumber Property

"Sheet Key Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SheetKeyNumber { get; }
Public Shared ReadOnly Property SheetKeyNumber As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SheetKeyNumber {
    ForgeTypeId^ get ();
}
static member SheetKeyNumber : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SheetName Property

ParameterTypeIdSheetName Property

"Sheet Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SheetName { get; }
Public Shared ReadOnly Property SheetName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SheetName {
    ForgeTypeId^ get ();
}
static member SheetName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SheetNumber Property

ParameterTypeIdSheetNumber Property

"Sheet Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SheetNumber { get; }
Public Shared ReadOnly Property SheetNumber As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SheetNumber {
    ForgeTypeId^ get ();
}
static member SheetNumber : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SheetRevisionsOnSheet Property

ParameterTypeIdSheetRevisionsOnSheet Property

"Revisions on Sheet"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SheetRevisionsOnSheet { get; }
Public Shared ReadOnly Property SheetRevisionsOnSheet As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SheetRevisionsOnSheet {
    ForgeTypeId^ get ();
}
static member SheetRevisionsOnSheet : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SheetScale Property

ParameterTypeIdSheetScale Property

"Scale"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SheetScale { get; }
Public Shared ReadOnly Property SheetScale As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SheetScale {
    ForgeTypeId^ get ();
}
static member SheetScale : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SheetScheduled Property

ParameterTypeIdSheetScheduled Property

"Appears In Sheet List"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SheetScheduled { get; }
Public Shared ReadOnly Property SheetScheduled As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SheetScheduled {
    ForgeTypeId^ get ();
}
static member SheetScheduled : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SheetWidth Property

ParameterTypeIdSheetWidth Property

"Sheet Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SheetWidth { get; }
Public Shared ReadOnly Property SheetWidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SheetWidth {
    ForgeTypeId^ get ();
}
static member SheetWidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ShowArrowheadToCutMark Property

ParameterTypeIdShowArrowheadToCutMark Property

"Show Arrowhead to Cut Mark"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ShowArrowheadToCutMark { get; }
Public Shared ReadOnly Property ShowArrowheadToCutMark As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ShowArrowheadToCutMark {
    ForgeTypeId^ get ();
}
static member ShowArrowheadToCutMark : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ShowIconParam Property

ParameterTypeIdShowIconParam Property

"Flag to display icon in Ribbon Combo Item"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ShowIconParam { get; }
Public Shared ReadOnly Property ShowIconParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ShowIconParam {
    ForgeTypeId^ get ();
}
static member ShowIconParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ShowTitle Property

ParameterTypeIdShowTitle Property

"Show Title"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ShowTitle { get; }
Public Shared ReadOnly Property ShowTitle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ShowTitle {
    ForgeTypeId^ get ();
}
static member ShowTitle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SketchGridSpacingParam Property

ParameterTypeIdSketchGridSpacingParam Property

"Work Plane Grid Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SketchGridSpacingParam { get; }
Public Shared ReadOnly Property SketchGridSpacingParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SketchGridSpacingParam {
    ForgeTypeId^ get ();
}
static member SketchGridSpacingParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SketchPlaneParam Property

ParameterTypeIdSketchPlaneParam Property

"Work Plane"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SketchPlaneParam { get; }
Public Shared ReadOnly Property SketchPlaneParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SketchPlaneParam {
    ForgeTypeId^ get ();
}
static member SketchPlaneParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SlabEdgeMaterialParam Property

ParameterTypeIdSlabEdgeMaterialParam Property

"Material"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SlabEdgeMaterialParam { get; }
Public Shared ReadOnly Property SlabEdgeMaterialParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SlabEdgeMaterialParam {
    ForgeTypeId^ get ();
}
static member SlabEdgeMaterialParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SlabEdgeProfileParam Property

ParameterTypeIdSlabEdgeProfileParam Property

"Profile"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SlabEdgeProfileParam { get; }
Public Shared ReadOnly Property SlabEdgeProfileParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SlabEdgeProfileParam {
    ForgeTypeId^ get ();
}
static member SlabEdgeProfileParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SlantedColumnBaseCutStyle Property

ParameterTypeIdSlantedColumnBaseCutStyle Property

"Base Cut Style"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SlantedColumnBaseCutStyle { get; }
Public Shared ReadOnly Property SlantedColumnBaseCutStyle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SlantedColumnBaseCutStyle {
    ForgeTypeId^ get ();
}
static member SlantedColumnBaseCutStyle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SlantedColumnBaseExtension Property

ParameterTypeIdSlantedColumnBaseExtension Property

"Base Extension"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SlantedColumnBaseExtension { get; }
Public Shared ReadOnly Property SlantedColumnBaseExtension As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SlantedColumnBaseExtension {
    ForgeTypeId^ get ();
}
static member SlantedColumnBaseExtension : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SlantedColumnGeometryTreatmentBase Property

ParameterTypeIdSlantedColumnGeometryTreatmentBase Property

"Base Geometry Alignment"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SlantedColumnGeometryTreatmentBase { get; }
Public Shared ReadOnly Property SlantedColumnGeometryTreatmentBase As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SlantedColumnGeometryTreatmentBase {
    ForgeTypeId^ get ();
}
static member SlantedColumnGeometryTreatmentBase : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SlantedColumnGeometryTreatmentTop Property

ParameterTypeIdSlantedColumnGeometryTreatmentTop Property

"Top Geometry Alignment"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SlantedColumnGeometryTreatmentTop { get; }
Public Shared ReadOnly Property SlantedColumnGeometryTreatmentTop As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SlantedColumnGeometryTreatmentTop {
    ForgeTypeId^ get ();
}
static member SlantedColumnGeometryTreatmentTop : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SlantedColumnTopCutStyle Property

ParameterTypeIdSlantedColumnTopCutStyle Property

"Top Cut Style"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SlantedColumnTopCutStyle { get; }
Public Shared ReadOnly Property SlantedColumnTopCutStyle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SlantedColumnTopCutStyle {
    ForgeTypeId^ get ();
}
static member SlantedColumnTopCutStyle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SlantedColumnTopExtension Property

ParameterTypeIdSlantedColumnTopExtension Property

"Top Extension"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SlantedColumnTopExtension { get; }
Public Shared ReadOnly Property SlantedColumnTopExtension As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SlantedColumnTopExtension {
    ForgeTypeId^ get ();
}
static member SlantedColumnTopExtension : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SlantedColumnTypeParam Property

ParameterTypeIdSlantedColumnTypeParam Property

"Column Style"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SlantedColumnTypeParam { get; }
Public Shared ReadOnly Property SlantedColumnTypeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SlantedColumnTypeParam {
    ForgeTypeId^ get ();
}
static member SlantedColumnTypeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SlopeArrowLevelEnd Property

ParameterTypeIdSlopeArrowLevelEnd Property

"Level at Head"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SlopeArrowLevelEnd { get; }
Public Shared ReadOnly Property SlopeArrowLevelEnd As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SlopeArrowLevelEnd {
    ForgeTypeId^ get ();
}
static member SlopeArrowLevelEnd : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SlopeArrowLevelStart Property

ParameterTypeIdSlopeArrowLevelStart Property

"Level at Tail"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SlopeArrowLevelStart { get; }
Public Shared ReadOnly Property SlopeArrowLevelStart As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SlopeArrowLevelStart {
    ForgeTypeId^ get ();
}
static member SlopeArrowLevelStart : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SlopeEndHeight Property

ParameterTypeIdSlopeEndHeight Property

"Height Offset at Head"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SlopeEndHeight { get; }
Public Shared ReadOnly Property SlopeEndHeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SlopeEndHeight {
    ForgeTypeId^ get ();
}
static member SlopeEndHeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SlopeStartHeight Property

ParameterTypeIdSlopeStartHeight Property

"Height Offset at Tail"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SlopeStartHeight { get; }
Public Shared ReadOnly Property SlopeStartHeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SlopeStartHeight {
    ForgeTypeId^ get ();
}
static member SlopeStartHeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpaceAirChangesPerHour Property

ParameterTypeIdSpaceAirChangesPerHour Property

"Air Changes per Hour"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpaceAirChangesPerHour { get; }
Public Shared ReadOnly Property SpaceAirChangesPerHour As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpaceAirChangesPerHour {
    ForgeTypeId^ get ();
}
static member SpaceAirChangesPerHour : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpaceAirflowPerAreaParam Property

ParameterTypeIdSpaceAirflowPerAreaParam Property

"Airflow per area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpaceAirflowPerAreaParam { get; }
Public Shared ReadOnly Property SpaceAirflowPerAreaParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpaceAirflowPerAreaParam {
    ForgeTypeId^ get ();
}
static member SpaceAirflowPerAreaParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpaceArea Property

ParameterTypeIdSpaceArea Property

"Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpaceArea { get; }
Public Shared ReadOnly Property SpaceArea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpaceArea {
    ForgeTypeId^ get ();
}
static member SpaceArea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpaceAreaPerPersonParam Property

ParameterTypeIdSpaceAreaPerPersonParam Property

"Area per person"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpaceAreaPerPersonParam { get; }
Public Shared ReadOnly Property SpaceAreaPerPersonParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpaceAreaPerPersonParam {
    ForgeTypeId^ get ();
}
static member SpaceAreaPerPersonParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpaceAssocRoomName Property

ParameterTypeIdSpaceAssocRoomName Property

"Room Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpaceAssocRoomName { get; }
Public Shared ReadOnly Property SpaceAssocRoomName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpaceAssocRoomName {
    ForgeTypeId^ get ();
}
static member SpaceAssocRoomName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpaceAssocRoomNumber Property

ParameterTypeIdSpaceAssocRoomNumber Property

"Room Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpaceAssocRoomNumber { get; }
Public Shared ReadOnly Property SpaceAssocRoomNumber As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpaceAssocRoomNumber {
    ForgeTypeId^ get ();
}
static member SpaceAssocRoomNumber : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpaceCarpetingParam Property

ParameterTypeIdSpaceCarpetingParam Property

"Carpeting"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpaceCarpetingParam { get; }
Public Shared ReadOnly Property SpaceCarpetingParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpaceCarpetingParam {
    ForgeTypeId^ get ();
}
static member SpaceCarpetingParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpaceComposednameParam Property

ParameterTypeIdSpaceComposednameParam Property

"Composed Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpaceComposednameParam { get; }
Public Shared ReadOnly Property SpaceComposednameParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpaceComposednameParam {
    ForgeTypeId^ get ();
}
static member SpaceComposednameParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpaceConditionType Property

ParameterTypeIdSpaceConditionType Property

"Condition Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpaceConditionType { get; }
Public Shared ReadOnly Property SpaceConditionType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpaceConditionType {
    ForgeTypeId^ get ();
}
static member SpaceConditionType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpaceCoolingSetPoint Property

ParameterTypeIdSpaceCoolingSetPoint Property

"Cooling Set Point"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpaceCoolingSetPoint { get; }
Public Shared ReadOnly Property SpaceCoolingSetPoint As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpaceCoolingSetPoint {
    ForgeTypeId^ get ();
}
static member SpaceCoolingSetPoint : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpaceDehumidificationSetPoint Property

ParameterTypeIdSpaceDehumidificationSetPoint Property

"Dehumidification Set Point"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpaceDehumidificationSetPoint { get; }
Public Shared ReadOnly Property SpaceDehumidificationSetPoint As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpaceDehumidificationSetPoint {
    ForgeTypeId^ get ();
}
static member SpaceDehumidificationSetPoint : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpaceElecEquipmentRadiantPercentageParam Property

ParameterTypeIdSpaceElecEquipmentRadiantPercentageParam Property

"Electrical Equipment Radiant"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpaceElecEquipmentRadiantPercentageParam { get; }
Public Shared ReadOnly Property SpaceElecEquipmentRadiantPercentageParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpaceElecEquipmentRadiantPercentageParam {
    ForgeTypeId^ get ();
}
static member SpaceElecEquipmentRadiantPercentageParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpaceHeatingSetPoint Property

ParameterTypeIdSpaceHeatingSetPoint Property

"Heating Set Point"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpaceHeatingSetPoint { get; }
Public Shared ReadOnly Property SpaceHeatingSetPoint As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpaceHeatingSetPoint {
    ForgeTypeId^ get ();
}
static member SpaceHeatingSetPoint : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpaceHumidificationSetPoint Property

ParameterTypeIdSpaceHumidificationSetPoint Property

"Humidification Set Point"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpaceHumidificationSetPoint { get; }
Public Shared ReadOnly Property SpaceHumidificationSetPoint As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpaceHumidificationSetPoint {
    ForgeTypeId^ get ();
}
static member SpaceHumidificationSetPoint : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpaceInfiltrationAirflow Property

ParameterTypeIdSpaceInfiltrationAirflow Property

"Infiltration Airflow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpaceInfiltrationAirflow { get; }
Public Shared ReadOnly Property SpaceInfiltrationAirflow As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpaceInfiltrationAirflow {
    ForgeTypeId^ get ();
}
static member SpaceInfiltrationAirflow : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpaceInfiltrationAirflowPerArea Property

ParameterTypeIdSpaceInfiltrationAirflowPerArea Property

"Infiltration Airflow per area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpaceInfiltrationAirflowPerArea { get; }
Public Shared ReadOnly Property SpaceInfiltrationAirflowPerArea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpaceInfiltrationAirflowPerArea {
    ForgeTypeId^ get ();
}
static member SpaceInfiltrationAirflowPerArea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpaceInfiltrationParam Property

ParameterTypeIdSpaceInfiltrationParam Property

"Infiltration Airflow per area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpaceInfiltrationParam { get; }
Public Shared ReadOnly Property SpaceInfiltrationParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpaceInfiltrationParam {
    ForgeTypeId^ get ();
}
static member SpaceInfiltrationParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpaceIsOccupiable Property

ParameterTypeIdSpaceIsOccupiable Property

"Occupiable"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpaceIsOccupiable { get; }
Public Shared ReadOnly Property SpaceIsOccupiable As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpaceIsOccupiable {
    ForgeTypeId^ get ();
}
static member SpaceIsOccupiable : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpaceIsPlenum Property

ParameterTypeIdSpaceIsPlenum Property

"Plenum"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpaceIsPlenum { get; }
Public Shared ReadOnly Property SpaceIsPlenum As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpaceIsPlenum {
    ForgeTypeId^ get ();
}
static member SpaceIsPlenum : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpaceLightingLoadParam Property

ParameterTypeIdSpaceLightingLoadParam Property

"Lighting Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpaceLightingLoadParam { get; }
Public Shared ReadOnly Property SpaceLightingLoadParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpaceLightingLoadParam {
    ForgeTypeId^ get ();
}
static member SpaceLightingLoadParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpaceLightingLoadPerAreaParam Property

ParameterTypeIdSpaceLightingLoadPerAreaParam Property

"Lighting Load per area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpaceLightingLoadPerAreaParam { get; }
Public Shared ReadOnly Property SpaceLightingLoadPerAreaParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpaceLightingLoadPerAreaParam {
    ForgeTypeId^ get ();
}
static member SpaceLightingLoadPerAreaParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpaceLightingScheduleParam Property

ParameterTypeIdSpaceLightingScheduleParam Property

"Lighting Schedule"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpaceLightingScheduleParam { get; }
Public Shared ReadOnly Property SpaceLightingScheduleParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpaceLightingScheduleParam {
    ForgeTypeId^ get ();
}
static member SpaceLightingScheduleParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpaceNameParam Property

ParameterTypeIdSpaceNameParam Property

"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpaceNameParam { get; }
Public Shared ReadOnly Property SpaceNameParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpaceNameParam {
    ForgeTypeId^ get ();
}
static member SpaceNameParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpaceNumberOfPeople Property

ParameterTypeIdSpaceNumberOfPeople Property

"Number of People"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpaceNumberOfPeople { get; }
Public Shared ReadOnly Property SpaceNumberOfPeople As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpaceNumberOfPeople {
    ForgeTypeId^ get ();
}
static member SpaceNumberOfPeople : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpaceNumberParam Property

ParameterTypeIdSpaceNumberParam Property

"Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpaceNumberParam { get; }
Public Shared ReadOnly Property SpaceNumberParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpaceNumberParam {
    ForgeTypeId^ get ();
}
static member SpaceNumberParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpaceOccupancyScheduleParam Property

ParameterTypeIdSpaceOccupancyScheduleParam Property

"Occupancy Schedule"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpaceOccupancyScheduleParam { get; }
Public Shared ReadOnly Property SpaceOccupancyScheduleParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpaceOccupancyScheduleParam {
    ForgeTypeId^ get ();
}
static member SpaceOccupancyScheduleParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpaceOutdoorAirflow Property

ParameterTypeIdSpaceOutdoorAirflow Property

"Outdoor Airflow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpaceOutdoorAirflow { get; }
Public Shared ReadOnly Property SpaceOutdoorAirflow As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpaceOutdoorAirflow {
    ForgeTypeId^ get ();
}
static member SpaceOutdoorAirflow : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpaceOutdoorAirflowPerArea Property

ParameterTypeIdSpaceOutdoorAirflowPerArea Property

"Outdoor Airflow per area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpaceOutdoorAirflowPerArea { get; }
Public Shared ReadOnly Property SpaceOutdoorAirflowPerArea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpaceOutdoorAirflowPerArea {
    ForgeTypeId^ get ();
}
static member SpaceOutdoorAirflowPerArea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpaceOutdoorAirflowPerPerson Property

ParameterTypeIdSpaceOutdoorAirflowPerPerson Property

"Outdoor Airflow per person"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpaceOutdoorAirflowPerPerson { get; }
Public Shared ReadOnly Property SpaceOutdoorAirflowPerPerson As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpaceOutdoorAirflowPerPerson {
    ForgeTypeId^ get ();
}
static member SpaceOutdoorAirflowPerPerson : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpacePeopleActivityLevelParam Property

ParameterTypeIdSpacePeopleActivityLevelParam Property

"People Activity Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpacePeopleActivityLevelParam { get; }
Public Shared ReadOnly Property SpacePeopleActivityLevelParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpacePeopleActivityLevelParam {
    ForgeTypeId^ get ();
}
static member SpacePeopleActivityLevelParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpacePeopleLatentHeatGainPerPersonParam Property

ParameterTypeIdSpacePeopleLatentHeatGainPerPersonParam Property

"Latent Heat Gain per person"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpacePeopleLatentHeatGainPerPersonParam { get; }
Public Shared ReadOnly Property SpacePeopleLatentHeatGainPerPersonParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpacePeopleLatentHeatGainPerPersonParam {
    ForgeTypeId^ get ();
}
static member SpacePeopleLatentHeatGainPerPersonParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpacePeopleLoadParam Property

ParameterTypeIdSpacePeopleLoadParam Property

"Occupancy Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpacePeopleLoadParam { get; }
Public Shared ReadOnly Property SpacePeopleLoadParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpacePeopleLoadParam {
    ForgeTypeId^ get ();
}
static member SpacePeopleLoadParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpacePeopleSensibleHeatGainPerPersonParam Property

ParameterTypeIdSpacePeopleSensibleHeatGainPerPersonParam Property

"Sensible Heat Gain per person"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpacePeopleSensibleHeatGainPerPersonParam { get; }
Public Shared ReadOnly Property SpacePeopleSensibleHeatGainPerPersonParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpacePeopleSensibleHeatGainPerPersonParam {
    ForgeTypeId^ get ();
}
static member SpacePeopleSensibleHeatGainPerPersonParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpacePowerLoadParam Property

ParameterTypeIdSpacePowerLoadParam Property

"Power Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpacePowerLoadParam { get; }
Public Shared ReadOnly Property SpacePowerLoadParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpacePowerLoadParam {
    ForgeTypeId^ get ();
}
static member SpacePowerLoadParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpacePowerLoadPerAreaParam Property

ParameterTypeIdSpacePowerLoadPerAreaParam Property

"Power Load per area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpacePowerLoadPerAreaParam { get; }
Public Shared ReadOnly Property SpacePowerLoadPerAreaParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpacePowerLoadPerAreaParam {
    ForgeTypeId^ get ();
}
static member SpacePowerLoadPerAreaParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpacePowerScheduleParam Property

ParameterTypeIdSpacePowerScheduleParam Property

"Power Schedule"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpacePowerScheduleParam { get; }
Public Shared ReadOnly Property SpacePowerScheduleParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpacePowerScheduleParam {
    ForgeTypeId^ get ();
}
static member SpacePowerScheduleParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpaceReferenceLevelParam Property

ParameterTypeIdSpaceReferenceLevelParam Property

"Reference Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpaceReferenceLevelParam { get; }
Public Shared ReadOnly Property SpaceReferenceLevelParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpaceReferenceLevelParam {
    ForgeTypeId^ get ();
}
static member SpaceReferenceLevelParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpaceTypeGbxml Property

ParameterTypeIdSpaceTypeGbxml Property

"Space Type (gbXML)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpaceTypeGbxml { get; }
Public Shared ReadOnly Property SpaceTypeGbxml As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpaceTypeGbxml {
    ForgeTypeId^ get ();
}
static member SpaceTypeGbxml : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpaceVolume Property

ParameterTypeIdSpaceVolume Property

"Volume"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpaceVolume { get; }
Public Shared ReadOnly Property SpaceVolume As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpaceVolume {
    ForgeTypeId^ get ();
}
static member SpaceVolume : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpaceZoneName Property

ParameterTypeIdSpaceZoneName Property

"Zone"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpaceZoneName { get; }
Public Shared ReadOnly Property SpaceZoneName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpaceZoneName {
    ForgeTypeId^ get ();
}
static member SpaceZoneName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpacingAppend Property

ParameterTypeIdSpacingAppend Property

"Append Position"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpacingAppend { get; }
Public Shared ReadOnly Property SpacingAppend As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpacingAppend {
    ForgeTypeId^ get ();
}
static member SpacingAppend : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpacingJustification Property

ParameterTypeIdSpacingJustification Property

"Justification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpacingJustification { get; }
Public Shared ReadOnly Property SpacingJustification As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpacingJustification {
    ForgeTypeId^ get ();
}
static member SpacingJustification : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpacingJustificationHoriz Property

ParameterTypeIdSpacingJustificationHoriz Property

"Justification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpacingJustificationHoriz { get; }
Public Shared ReadOnly Property SpacingJustificationHoriz As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpacingJustificationHoriz {
    ForgeTypeId^ get ();
}
static member SpacingJustificationHoriz : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpacingJustificationn1 Property

ParameterTypeIdSpacingJustificationn1 Property

"Justification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpacingJustificationn1 { get; }
Public Shared ReadOnly Property SpacingJustificationn1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpacingJustificationn1 {
    ForgeTypeId^ get ();
}
static member SpacingJustificationn1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpacingJustificationn2 Property

ParameterTypeIdSpacingJustificationn2 Property

"Justification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpacingJustificationn2 { get; }
Public Shared ReadOnly Property SpacingJustificationn2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpacingJustificationn2 {
    ForgeTypeId^ get ();
}
static member SpacingJustificationn2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpacingJustificationU Property

ParameterTypeIdSpacingJustificationU Property

"Justification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpacingJustificationU { get; }
Public Shared ReadOnly Property SpacingJustificationU As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpacingJustificationU {
    ForgeTypeId^ get ();
}
static member SpacingJustificationU : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpacingJustificationV Property

ParameterTypeIdSpacingJustificationV Property

"Justification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpacingJustificationV { get; }
Public Shared ReadOnly Property SpacingJustificationV As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpacingJustificationV {
    ForgeTypeId^ get ();
}
static member SpacingJustificationV : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpacingJustificationVert Property

ParameterTypeIdSpacingJustificationVert Property

"Justification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpacingJustificationVert { get; }
Public Shared ReadOnly Property SpacingJustificationVert As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpacingJustificationVert {
    ForgeTypeId^ get ();
}
static member SpacingJustificationVert : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpacingLayout Property

ParameterTypeIdSpacingLayout Property

"Layout"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpacingLayout { get; }
Public Shared ReadOnly Property SpacingLayout As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpacingLayout {
    ForgeTypeId^ get ();
}
static member SpacingLayout : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpacingLayoutHoriz Property

ParameterTypeIdSpacingLayoutHoriz Property

"Layout"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpacingLayoutHoriz { get; }
Public Shared ReadOnly Property SpacingLayoutHoriz As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpacingLayoutHoriz {
    ForgeTypeId^ get ();
}
static member SpacingLayoutHoriz : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpacingLayoutn1 Property

ParameterTypeIdSpacingLayoutn1 Property

"Layout"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpacingLayoutn1 { get; }
Public Shared ReadOnly Property SpacingLayoutn1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpacingLayoutn1 {
    ForgeTypeId^ get ();
}
static member SpacingLayoutn1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpacingLayoutn2 Property

ParameterTypeIdSpacingLayoutn2 Property

"Layout"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpacingLayoutn2 { get; }
Public Shared ReadOnly Property SpacingLayoutn2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpacingLayoutn2 {
    ForgeTypeId^ get ();
}
static member SpacingLayoutn2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpacingLayoutU Property

ParameterTypeIdSpacingLayoutU Property

"Layout"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpacingLayoutU { get; }
Public Shared ReadOnly Property SpacingLayoutU As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpacingLayoutU {
    ForgeTypeId^ get ();
}
static member SpacingLayoutU : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpacingLayoutV Property

ParameterTypeIdSpacingLayoutV Property

"Layout"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpacingLayoutV { get; }
Public Shared ReadOnly Property SpacingLayoutV As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpacingLayoutV {
    ForgeTypeId^ get ();
}
static member SpacingLayoutV : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpacingLayoutVert Property

ParameterTypeIdSpacingLayoutVert Property

"Layout"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpacingLayoutVert { get; }
Public Shared ReadOnly Property SpacingLayoutVert As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpacingLayoutVert {
    ForgeTypeId^ get ();
}
static member SpacingLayoutVert : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpacingLength Property

ParameterTypeIdSpacingLength Property

"Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpacingLength { get; }
Public Shared ReadOnly Property SpacingLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpacingLength {
    ForgeTypeId^ get ();
}
static member SpacingLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpacingLengthHoriz Property

ParameterTypeIdSpacingLengthHoriz Property

"Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpacingLengthHoriz { get; }
Public Shared ReadOnly Property SpacingLengthHoriz As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpacingLengthHoriz {
    ForgeTypeId^ get ();
}
static member SpacingLengthHoriz : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpacingLengthn1 Property

ParameterTypeIdSpacingLengthn1 Property

"Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpacingLengthn1 { get; }
Public Shared ReadOnly Property SpacingLengthn1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpacingLengthn1 {
    ForgeTypeId^ get ();
}
static member SpacingLengthn1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpacingLengthn2 Property

ParameterTypeIdSpacingLengthn2 Property

"Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpacingLengthn2 { get; }
Public Shared ReadOnly Property SpacingLengthn2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpacingLengthn2 {
    ForgeTypeId^ get ();
}
static member SpacingLengthn2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpacingLengthU Property

ParameterTypeIdSpacingLengthU Property

"Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpacingLengthU { get; }
Public Shared ReadOnly Property SpacingLengthU As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpacingLengthU {
    ForgeTypeId^ get ();
}
static member SpacingLengthU : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpacingLengthV Property

ParameterTypeIdSpacingLengthV Property

"Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpacingLengthV { get; }
Public Shared ReadOnly Property SpacingLengthV As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpacingLengthV {
    ForgeTypeId^ get ();
}
static member SpacingLengthV : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpacingLengthVert Property

ParameterTypeIdSpacingLengthVert Property

"Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpacingLengthVert { get; }
Public Shared ReadOnly Property SpacingLengthVert As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpacingLengthVert {
    ForgeTypeId^ get ();
}
static member SpacingLengthVert : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpacingNumDivisions Property

ParameterTypeIdSpacingNumDivisions Property

"Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpacingNumDivisions { get; }
Public Shared ReadOnly Property SpacingNumDivisions As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpacingNumDivisions {
    ForgeTypeId^ get ();
}
static member SpacingNumDivisions : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpacingNumDivisionsHoriz Property

ParameterTypeIdSpacingNumDivisionsHoriz Property

"Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpacingNumDivisionsHoriz { get; }
Public Shared ReadOnly Property SpacingNumDivisionsHoriz As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpacingNumDivisionsHoriz {
    ForgeTypeId^ get ();
}
static member SpacingNumDivisionsHoriz : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpacingNumDivisionsn1 Property

ParameterTypeIdSpacingNumDivisionsn1 Property

"Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpacingNumDivisionsn1 { get; }
Public Shared ReadOnly Property SpacingNumDivisionsn1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpacingNumDivisionsn1 {
    ForgeTypeId^ get ();
}
static member SpacingNumDivisionsn1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpacingNumDivisionsn2 Property

ParameterTypeIdSpacingNumDivisionsn2 Property

"Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpacingNumDivisionsn2 { get; }
Public Shared ReadOnly Property SpacingNumDivisionsn2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpacingNumDivisionsn2 {
    ForgeTypeId^ get ();
}
static member SpacingNumDivisionsn2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpacingNumDivisionsU Property

ParameterTypeIdSpacingNumDivisionsU Property

"Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpacingNumDivisionsU { get; }
Public Shared ReadOnly Property SpacingNumDivisionsU As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpacingNumDivisionsU {
    ForgeTypeId^ get ();
}
static member SpacingNumDivisionsU : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpacingNumDivisionsV Property

ParameterTypeIdSpacingNumDivisionsV Property

"Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpacingNumDivisionsV { get; }
Public Shared ReadOnly Property SpacingNumDivisionsV As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpacingNumDivisionsV {
    ForgeTypeId^ get ();
}
static member SpacingNumDivisionsV : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpacingNumDivisionsVert Property

ParameterTypeIdSpacingNumDivisionsVert Property

"Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpacingNumDivisionsVert { get; }
Public Shared ReadOnly Property SpacingNumDivisionsVert As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpacingNumDivisionsVert {
    ForgeTypeId^ get ();
}
static member SpacingNumDivisionsVert : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpanDirInstParamAngle Property

ParameterTypeIdSpanDirInstParamAngle Property

"Span Direction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpanDirInstParamAngle { get; }
Public Shared ReadOnly Property SpanDirInstParamAngle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpanDirInstParamAngle {
    ForgeTypeId^ get ();
}
static member SpanDirInstParamAngle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpanDirSymParamBottom Property

ParameterTypeIdSpanDirSymParamBottom Property

"Bottom"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpanDirSymParamBottom { get; }
Public Shared ReadOnly Property SpanDirSymParamBottom As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpanDirSymParamBottom {
    ForgeTypeId^ get ();
}
static member SpanDirSymParamBottom : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpanDirSymParamLeft Property

ParameterTypeIdSpanDirSymParamLeft Property

"Left"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpanDirSymParamLeft { get; }
Public Shared ReadOnly Property SpanDirSymParamLeft As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpanDirSymParamLeft {
    ForgeTypeId^ get ();
}
static member SpanDirSymParamLeft : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpanDirSymParamRight Property

ParameterTypeIdSpanDirSymParamRight Property

"Right"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpanDirSymParamRight { get; }
Public Shared ReadOnly Property SpanDirSymParamRight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpanDirSymParamRight {
    ForgeTypeId^ get ();
}
static member SpanDirSymParamRight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpanDirSymParamTop Property

ParameterTypeIdSpanDirSymParamTop Property

"Top"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpanDirSymParamTop { get; }
Public Shared ReadOnly Property SpanDirSymParamTop As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpanDirSymParamTop {
    ForgeTypeId^ get ();
}
static member SpanDirSymParamTop : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpatialFieldMgrCurrentName Property

ParameterTypeIdSpatialFieldMgrCurrentName Property

"Analysis Configuration"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpatialFieldMgrCurrentName { get; }
Public Shared ReadOnly Property SpatialFieldMgrCurrentName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpatialFieldMgrCurrentName {
    ForgeTypeId^ get ();
}
static member SpatialFieldMgrCurrentName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpatialFieldMgrDescription Property

ParameterTypeIdSpatialFieldMgrDescription Property

"Description"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpatialFieldMgrDescription { get; }
Public Shared ReadOnly Property SpatialFieldMgrDescription As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpatialFieldMgrDescription {
    ForgeTypeId^ get ();
}
static member SpatialFieldMgrDescription : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpatialFieldMgrLegendHeight Property

ParameterTypeIdSpatialFieldMgrLegendHeight Property

"Legend Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpatialFieldMgrLegendHeight { get; }
Public Shared ReadOnly Property SpatialFieldMgrLegendHeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpatialFieldMgrLegendHeight {
    ForgeTypeId^ get ();
}
static member SpatialFieldMgrLegendHeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpatialFieldMgrLegendHorOriginGap Property

ParameterTypeIdSpatialFieldMgrLegendHorOriginGap Property

"Legend Horizontal Origin Gap"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpatialFieldMgrLegendHorOriginGap { get; }
Public Shared ReadOnly Property SpatialFieldMgrLegendHorOriginGap As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpatialFieldMgrLegendHorOriginGap {
    ForgeTypeId^ get ();
}
static member SpatialFieldMgrLegendHorOriginGap : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpatialFieldMgrLegendShowConfigName Property

ParameterTypeIdSpatialFieldMgrLegendShowConfigName Property

"Show Configuration Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpatialFieldMgrLegendShowConfigName { get; }
Public Shared ReadOnly Property SpatialFieldMgrLegendShowConfigName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpatialFieldMgrLegendShowConfigName {
    ForgeTypeId^ get ();
}
static member SpatialFieldMgrLegendShowConfigName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpatialFieldMgrLegendShowDescription Property

ParameterTypeIdSpatialFieldMgrLegendShowDescription Property

"Show Description"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpatialFieldMgrLegendShowDescription { get; }
Public Shared ReadOnly Property SpatialFieldMgrLegendShowDescription As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpatialFieldMgrLegendShowDescription {
    ForgeTypeId^ get ();
}
static member SpatialFieldMgrLegendShowDescription : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpatialFieldMgrLegendTextType Property

ParameterTypeIdSpatialFieldMgrLegendTextType Property

"Overall Legend Text"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpatialFieldMgrLegendTextType { get; }
Public Shared ReadOnly Property SpatialFieldMgrLegendTextType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpatialFieldMgrLegendTextType {
    ForgeTypeId^ get ();
}
static member SpatialFieldMgrLegendTextType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpatialFieldMgrLegendVertOriginGap Property

ParameterTypeIdSpatialFieldMgrLegendVertOriginGap Property

"Legend Vertical Origin Gap"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpatialFieldMgrLegendVertOriginGap { get; }
Public Shared ReadOnly Property SpatialFieldMgrLegendVertOriginGap As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpatialFieldMgrLegendVertOriginGap {
    ForgeTypeId^ get ();
}
static member SpatialFieldMgrLegendVertOriginGap : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpatialFieldMgrLegendWidth Property

ParameterTypeIdSpatialFieldMgrLegendWidth Property

"Legend Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpatialFieldMgrLegendWidth { get; }
Public Shared ReadOnly Property SpatialFieldMgrLegendWidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpatialFieldMgrLegendWidth {
    ForgeTypeId^ get ();
}
static member SpatialFieldMgrLegendWidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpatialFieldMgrRange Property

ParameterTypeIdSpatialFieldMgrRange Property

"Data Range"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpatialFieldMgrRange { get; }
Public Shared ReadOnly Property SpatialFieldMgrRange As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpatialFieldMgrRange {
    ForgeTypeId^ get ();
}
static member SpatialFieldMgrRange : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpatialFieldMgrResultsVisibility Property

ParameterTypeIdSpatialFieldMgrResultsVisibility Property

"Results Visibility"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpatialFieldMgrResultsVisibility { get; }
Public Shared ReadOnly Property SpatialFieldMgrResultsVisibility As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpatialFieldMgrResultsVisibility {
    ForgeTypeId^ get ();
}
static member SpatialFieldMgrResultsVisibility : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpecifySlopeOrOffset Property

ParameterTypeIdSpecifySlopeOrOffset Property

"Specify "

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpecifySlopeOrOffset { get; }
Public Shared ReadOnly Property SpecifySlopeOrOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpecifySlopeOrOffset {
    ForgeTypeId^ get ();
}
static member SpecifySlopeOrOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpliceByRulesMaxLength Property

ParameterTypeIdSpliceByRulesMaxLength Property

"Maximum bar length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpliceByRulesMaxLength { get; }
Public Shared ReadOnly Property SpliceByRulesMaxLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpliceByRulesMaxLength {
    ForgeTypeId^ get ();
}
static member SpliceByRulesMaxLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpliceByRulesMinLength Property

ParameterTypeIdSpliceByRulesMinLength Property

"Minimum bar length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpliceByRulesMinLength { get; }
Public Shared ReadOnly Property SpliceByRulesMinLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpliceByRulesMinLength {
    ForgeTypeId^ get ();
}
static member SpliceByRulesMinLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpliceByRulesRunout Property

ParameterTypeIdSpliceByRulesRunout Property

"Runout"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpliceByRulesRunout { get; }
Public Shared ReadOnly Property SpliceByRulesRunout As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpliceByRulesRunout {
    ForgeTypeId^ get ();
}
static member SpliceByRulesRunout : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpliceLapLengthAtEnd Property

ParameterTypeIdSpliceLapLengthAtEnd Property

"Lap Length at End"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpliceLapLengthAtEnd { get; }
Public Shared ReadOnly Property SpliceLapLengthAtEnd As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpliceLapLengthAtEnd {
    ForgeTypeId^ get ();
}
static member SpliceLapLengthAtEnd : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpliceLapLengthAtStart Property

ParameterTypeIdSpliceLapLengthAtStart Property

"Lap Length at Start"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpliceLapLengthAtStart { get; }
Public Shared ReadOnly Property SpliceLapLengthAtStart As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpliceLapLengthAtStart {
    ForgeTypeId^ get ();
}
static member SpliceLapLengthAtStart : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpliceTypeAtEnd Property

ParameterTypeIdSpliceTypeAtEnd Property

"Splice at End"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpliceTypeAtEnd { get; }
Public Shared ReadOnly Property SpliceTypeAtEnd As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpliceTypeAtEnd {
    ForgeTypeId^ get ();
}
static member SpliceTypeAtEnd : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpliceTypeAtStart Property

ParameterTypeIdSpliceTypeAtStart Property

"Splice at Start"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpliceTypeAtStart { get; }
Public Shared ReadOnly Property SpliceTypeAtStart As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpliceTypeAtStart {
    ForgeTypeId^ get ();
}
static member SpliceTypeAtStart : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotCoordinateBase Property

ParameterTypeIdSpotCoordinateBase Property

"Coordinate Base"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotCoordinateBase { get; }
Public Shared ReadOnly Property SpotCoordinateBase As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotCoordinateBase {
    ForgeTypeId^ get ();
}
static member SpotCoordinateBase : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotCoordinateBottomPrefix Property

ParameterTypeIdSpotCoordinateBottomPrefix Property

"Bottom Coordinate Prefix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotCoordinateBottomPrefix { get; }
Public Shared ReadOnly Property SpotCoordinateBottomPrefix As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotCoordinateBottomPrefix {
    ForgeTypeId^ get ();
}
static member SpotCoordinateBottomPrefix : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotCoordinateBottomSuffix Property

ParameterTypeIdSpotCoordinateBottomSuffix Property

"Bottom Coordinate Suffix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotCoordinateBottomSuffix { get; }
Public Shared ReadOnly Property SpotCoordinateBottomSuffix As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotCoordinateBottomSuffix {
    ForgeTypeId^ get ();
}
static member SpotCoordinateBottomSuffix : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotCoordinateElevationPrefix Property

ParameterTypeIdSpotCoordinateElevationPrefix Property

"Elevation Prefix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotCoordinateElevationPrefix { get; }
Public Shared ReadOnly Property SpotCoordinateElevationPrefix As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotCoordinateElevationPrefix {
    ForgeTypeId^ get ();
}
static member SpotCoordinateElevationPrefix : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotCoordinateElevationSuffix Property

ParameterTypeIdSpotCoordinateElevationSuffix Property

"Elevation Suffix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotCoordinateElevationSuffix { get; }
Public Shared ReadOnly Property SpotCoordinateElevationSuffix As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotCoordinateElevationSuffix {
    ForgeTypeId^ get ();
}
static member SpotCoordinateElevationSuffix : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotCoordinateIncludeElevation Property

ParameterTypeIdSpotCoordinateIncludeElevation Property

"Include Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotCoordinateIncludeElevation { get; }
Public Shared ReadOnly Property SpotCoordinateIncludeElevation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotCoordinateIncludeElevation {
    ForgeTypeId^ get ();
}
static member SpotCoordinateIncludeElevation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotCoordinateTopPrefix Property

ParameterTypeIdSpotCoordinateTopPrefix Property

"Top Coordinate Prefix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotCoordinateTopPrefix { get; }
Public Shared ReadOnly Property SpotCoordinateTopPrefix As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotCoordinateTopPrefix {
    ForgeTypeId^ get ();
}
static member SpotCoordinateTopPrefix : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotCoordinateTopSuffix Property

ParameterTypeIdSpotCoordinateTopSuffix Property

"Top Coordinate Suffix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotCoordinateTopSuffix { get; }
Public Shared ReadOnly Property SpotCoordinateTopSuffix As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotCoordinateTopSuffix {
    ForgeTypeId^ get ();
}
static member SpotCoordinateTopSuffix : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotDimLeader Property

ParameterTypeIdSpotDimLeader Property

"Leader"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotDimLeader { get; }
Public Shared ReadOnly Property SpotDimLeader As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotDimLeader {
    ForgeTypeId^ get ();
}
static member SpotDimLeader : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotDimLeaderLine Property

ParameterTypeIdSpotDimLeaderLine Property

"Leader Line"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotDimLeaderLine { get; }
Public Shared ReadOnly Property SpotDimLeaderLine As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotDimLeaderLine {
    ForgeTypeId^ get ();
}
static member SpotDimLeaderLine : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotDimStyleSlopeUnits Property

ParameterTypeIdSpotDimStyleSlopeUnits Property

"Units Format"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotDimStyleSlopeUnits { get; }
Public Shared ReadOnly Property SpotDimStyleSlopeUnits As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotDimStyleSlopeUnits {
    ForgeTypeId^ get ();
}
static member SpotDimStyleSlopeUnits : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotDimStyleSlopeUnitsAlt Property

ParameterTypeIdSpotDimStyleSlopeUnitsAlt Property

"Alternate Units Format"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotDimStyleSlopeUnitsAlt { get; }
Public Shared ReadOnly Property SpotDimStyleSlopeUnitsAlt As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotDimStyleSlopeUnitsAlt {
    ForgeTypeId^ get ();
}
static member SpotDimStyleSlopeUnitsAlt : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotElevBase Property

ParameterTypeIdSpotElevBase Property

"Elevation Base"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotElevBase { get; }
Public Shared ReadOnly Property SpotElevBase As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotElevBase {
    ForgeTypeId^ get ();
}
static member SpotElevBase : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotElevBendLeader Property

ParameterTypeIdSpotElevBendLeader Property

"Leader Shoulder"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotElevBendLeader { get; }
Public Shared ReadOnly Property SpotElevBendLeader As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotElevBendLeader {
    ForgeTypeId^ get ();
}
static member SpotElevBendLeader : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotElevBotValue Property

ParameterTypeIdSpotElevBotValue Property

"Bottom Coordinate"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotElevBotValue { get; }
Public Shared ReadOnly Property SpotElevBotValue As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotElevBotValue {
    ForgeTypeId^ get ();
}
static member SpotElevBotValue : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotElevDisplayElevations Property

ParameterTypeIdSpotElevDisplayElevations Property

"Display Elevations"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotElevDisplayElevations { get; }
Public Shared ReadOnly Property SpotElevDisplayElevations As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotElevDisplayElevations {
    ForgeTypeId^ get ();
}
static member SpotElevDisplayElevations : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotElevFlipTextVert Property

ParameterTypeIdSpotElevFlipTextVert Property

"Auto Mirror"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotElevFlipTextVert { get; }
Public Shared ReadOnly Property SpotElevFlipTextVert As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotElevFlipTextVert {
    ForgeTypeId^ get ();
}
static member SpotElevFlipTextVert : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotElevIndBottom Property

ParameterTypeIdSpotElevIndBottom Property

"Bottom Indicator"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotElevIndBottom { get; }
Public Shared ReadOnly Property SpotElevIndBottom As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotElevIndBottom {
    ForgeTypeId^ get ();
}
static member SpotElevIndBottom : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotElevIndElevation Property

ParameterTypeIdSpotElevIndElevation Property

"Elevation Indicator"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotElevIndElevation { get; }
Public Shared ReadOnly Property SpotElevIndElevation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotElevIndElevation {
    ForgeTypeId^ get ();
}
static member SpotElevIndElevation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotElevIndEw Property

ParameterTypeIdSpotElevIndEw Property

"East / West Indicator"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotElevIndEw { get; }
Public Shared ReadOnly Property SpotElevIndEw As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotElevIndEw {
    ForgeTypeId^ get ();
}
static member SpotElevIndEw : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotElevIndNs Property

ParameterTypeIdSpotElevIndNs Property

"North / South Indicator"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotElevIndNs { get; }
Public Shared ReadOnly Property SpotElevIndNs As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotElevIndNs {
    ForgeTypeId^ get ();
}
static member SpotElevIndNs : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotElevIndTop Property

ParameterTypeIdSpotElevIndTop Property

"Top Indicator"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotElevIndTop { get; }
Public Shared ReadOnly Property SpotElevIndTop As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotElevIndTop {
    ForgeTypeId^ get ();
}
static member SpotElevIndTop : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotElevIndType Property

ParameterTypeIdSpotElevIndType Property

"Indicator as Prefix / Suffix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotElevIndType { get; }
Public Shared ReadOnly Property SpotElevIndType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotElevIndType {
    ForgeTypeId^ get ();
}
static member SpotElevIndType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotElevIndTypeBottom Property

ParameterTypeIdSpotElevIndTypeBottom Property

"Bottom Indicator as Prefix/Suffix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotElevIndTypeBottom { get; }
Public Shared ReadOnly Property SpotElevIndTypeBottom As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotElevIndTypeBottom {
    ForgeTypeId^ get ();
}
static member SpotElevIndTypeBottom : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotElevIndTypeElevation Property

ParameterTypeIdSpotElevIndTypeElevation Property

"Elevation Indicator as Prefix/Suffix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotElevIndTypeElevation { get; }
Public Shared ReadOnly Property SpotElevIndTypeElevation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotElevIndTypeElevation {
    ForgeTypeId^ get ();
}
static member SpotElevIndTypeElevation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotElevIndTypeTop Property

ParameterTypeIdSpotElevIndTypeTop Property

"Top Indicator as Prefix/Suffix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotElevIndTypeTop { get; }
Public Shared ReadOnly Property SpotElevIndTypeTop As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotElevIndTypeTop {
    ForgeTypeId^ get ();
}
static member SpotElevIndTypeTop : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotElevLeaderArrowhead Property

ParameterTypeIdSpotElevLeaderArrowhead Property

"Leader Arrowhead"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotElevLeaderArrowhead { get; }
Public Shared ReadOnly Property SpotElevLeaderArrowhead As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotElevLeaderArrowhead {
    ForgeTypeId^ get ();
}
static member SpotElevLeaderArrowhead : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotElevLinePen Property

ParameterTypeIdSpotElevLinePen Property

"Leader Line Weight"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotElevLinePen { get; }
Public Shared ReadOnly Property SpotElevLinePen As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotElevLinePen {
    ForgeTypeId^ get ();
}
static member SpotElevLinePen : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotElevLowerPrefix Property

ParameterTypeIdSpotElevLowerPrefix Property

"Lower Value Prefix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotElevLowerPrefix { get; }
Public Shared ReadOnly Property SpotElevLowerPrefix As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotElevLowerPrefix {
    ForgeTypeId^ get ();
}
static member SpotElevLowerPrefix : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotElevLowerSuffix Property

ParameterTypeIdSpotElevLowerSuffix Property

"Lower Value Suffix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotElevLowerSuffix { get; }
Public Shared ReadOnly Property SpotElevLowerSuffix As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotElevLowerSuffix {
    ForgeTypeId^ get ();
}
static member SpotElevLowerSuffix : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotElevLowerValue Property

ParameterTypeIdSpotElevLowerValue Property

"Lower Value"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotElevLowerValue { get; }
Public Shared ReadOnly Property SpotElevLowerValue As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotElevLowerValue {
    ForgeTypeId^ get ();
}
static member SpotElevLowerValue : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotElevRelativeBase Property

ParameterTypeIdSpotElevRelativeBase Property

"Relative Base"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotElevRelativeBase { get; }
Public Shared ReadOnly Property SpotElevRelativeBase As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotElevRelativeBase {
    ForgeTypeId^ get ();
}
static member SpotElevRelativeBase : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotElevRotateWithComponent Property

ParameterTypeIdSpotElevRotateWithComponent Property

"Rotate with Component"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotElevRotateWithComponent { get; }
Public Shared ReadOnly Property SpotElevRotateWithComponent As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotElevRotateWithComponent {
    ForgeTypeId^ get ();
}
static member SpotElevRotateWithComponent : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotElevSingleOrUpperPrefix Property

ParameterTypeIdSpotElevSingleOrUpperPrefix Property

"Single/Upper Value Prefix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotElevSingleOrUpperPrefix { get; }
Public Shared ReadOnly Property SpotElevSingleOrUpperPrefix As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotElevSingleOrUpperPrefix {
    ForgeTypeId^ get ();
}
static member SpotElevSingleOrUpperPrefix : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotElevSingleOrUpperSuffix Property

ParameterTypeIdSpotElevSingleOrUpperSuffix Property

"Single/Upper Value Suffix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotElevSingleOrUpperSuffix { get; }
Public Shared ReadOnly Property SpotElevSingleOrUpperSuffix As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotElevSingleOrUpperSuffix {
    ForgeTypeId^ get ();
}
static member SpotElevSingleOrUpperSuffix : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotElevSingleOrUpperValue Property

ParameterTypeIdSpotElevSingleOrUpperValue Property

"Single/Upper Value"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotElevSingleOrUpperValue { get; }
Public Shared ReadOnly Property SpotElevSingleOrUpperValue As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotElevSingleOrUpperValue {
    ForgeTypeId^ get ();
}
static member SpotElevSingleOrUpperValue : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotElevSymbol Property

ParameterTypeIdSpotElevSymbol Property

"Symbol"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotElevSymbol { get; }
Public Shared ReadOnly Property SpotElevSymbol As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotElevSymbol {
    ForgeTypeId^ get ();
}
static member SpotElevSymbol : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotElevTextHorizOffset Property

ParameterTypeIdSpotElevTextHorizOffset Property

"Text Offset from Symbol"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotElevTextHorizOffset { get; }
Public Shared ReadOnly Property SpotElevTextHorizOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotElevTextHorizOffset {
    ForgeTypeId^ get ();
}
static member SpotElevTextHorizOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotElevTextLocation Property

ParameterTypeIdSpotElevTextLocation Property

"Text Location"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotElevTextLocation { get; }
Public Shared ReadOnly Property SpotElevTextLocation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotElevTextLocation {
    ForgeTypeId^ get ();
}
static member SpotElevTextLocation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotElevTextOrientation Property

ParameterTypeIdSpotElevTextOrientation Property

"Text Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotElevTextOrientation { get; }
Public Shared ReadOnly Property SpotElevTextOrientation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotElevTextOrientation {
    ForgeTypeId^ get ();
}
static member SpotElevTextOrientation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotElevTickMarkPen Property

ParameterTypeIdSpotElevTickMarkPen Property

"Leader Arrowhead Line Weight"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotElevTickMarkPen { get; }
Public Shared ReadOnly Property SpotElevTickMarkPen As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotElevTickMarkPen {
    ForgeTypeId^ get ();
}
static member SpotElevTickMarkPen : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotElevTopValue Property

ParameterTypeIdSpotElevTopValue Property

"Top Coordinate"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotElevTopValue { get; }
Public Shared ReadOnly Property SpotElevTopValue As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotElevTopValue {
    ForgeTypeId^ get ();
}
static member SpotElevTopValue : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotSlopeLeaderLength Property

ParameterTypeIdSpotSlopeLeaderLength Property

"Leader Line Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotSlopeLeaderLength { get; }
Public Shared ReadOnly Property SpotSlopeLeaderLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotSlopeLeaderLength {
    ForgeTypeId^ get ();
}
static member SpotSlopeLeaderLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotSlopeOffsetFromReference Property

ParameterTypeIdSpotSlopeOffsetFromReference Property

"Offset from Reference"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotSlopeOffsetFromReference { get; }
Public Shared ReadOnly Property SpotSlopeOffsetFromReference As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotSlopeOffsetFromReference {
    ForgeTypeId^ get ();
}
static member SpotSlopeOffsetFromReference : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotSlopePrefix Property

ParameterTypeIdSpotSlopePrefix Property

"Prefix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotSlopePrefix { get; }
Public Shared ReadOnly Property SpotSlopePrefix As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotSlopePrefix {
    ForgeTypeId^ get ();
}
static member SpotSlopePrefix : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotSlopeSlopeDirection Property

ParameterTypeIdSpotSlopeSlopeDirection Property

"Slope Direction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotSlopeSlopeDirection { get; }
Public Shared ReadOnly Property SpotSlopeSlopeDirection As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotSlopeSlopeDirection {
    ForgeTypeId^ get ();
}
static member SpotSlopeSlopeDirection : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotSlopeSlopeRepresentation Property

ParameterTypeIdSpotSlopeSlopeRepresentation Property

"Slope Representation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotSlopeSlopeRepresentation { get; }
Public Shared ReadOnly Property SpotSlopeSlopeRepresentation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotSlopeSlopeRepresentation {
    ForgeTypeId^ get ();
}
static member SpotSlopeSlopeRepresentation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotSlopeSuffix Property

ParameterTypeIdSpotSlopeSuffix Property

"Suffix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotSlopeSuffix { get; }
Public Shared ReadOnly Property SpotSlopeSuffix As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotSlopeSuffix {
    ForgeTypeId^ get ();
}
static member SpotSlopeSuffix : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SpotTextFromLeader Property

ParameterTypeIdSpotTextFromLeader Property

"Text Offset from Leader"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpotTextFromLeader { get; }
Public Shared ReadOnly Property SpotTextFromLeader As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpotTextFromLeader {
    ForgeTypeId^ get ();
}
static member SpotTextFromLeader : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SsePointBasetypeEnum Property

ParameterTypeIdSsePointBasetypeEnum Property

"Point Base Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SsePointBasetypeEnum { get; }
Public Shared ReadOnly Property SsePointBasetypeEnum As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SsePointBasetypeEnum {
    ForgeTypeId^ get ();
}
static member SsePointBasetypeEnum : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SsePointElevation Property

ParameterTypeIdSsePointElevation Property

"Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SsePointElevation { get; }
Public Shared ReadOnly Property SsePointElevation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SsePointElevation {
    ForgeTypeId^ get ();
}
static member SsePointElevation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SsePointElevationBaseType Property

ParameterTypeIdSsePointElevationBaseType Property

"Elevation Base Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SsePointElevationBaseType { get; }
Public Shared ReadOnly Property SsePointElevationBaseType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SsePointElevationBaseType {
    ForgeTypeId^ get ();
}
static member SsePointElevationBaseType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SsePointOffsetFromSnaps Property

ParameterTypeIdSsePointOffsetFromSnaps Property

"Offset from Snaps"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SsePointOffsetFromSnaps { get; }
Public Shared ReadOnly Property SsePointOffsetFromSnaps As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SsePointOffsetFromSnaps {
    ForgeTypeId^ get ();
}
static member SsePointOffsetFromSnaps : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SsePointOffsetFromSurface Property

ParameterTypeIdSsePointOffsetFromSurface Property

"Offset from Surface"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SsePointOffsetFromSurface { get; }
Public Shared ReadOnly Property SsePointOffsetFromSurface As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SsePointOffsetFromSurface {
    ForgeTypeId^ get ();
}
static member SsePointOffsetFromSurface : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsActualNumberOfRisers Property

ParameterTypeIdStairsActualNumberOfRisers Property

"Actual Number of Risers": The total number of actually created risers in model

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsActualNumberOfRisers { get; }
Public Shared ReadOnly Property StairsActualNumberOfRisers As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsActualNumberOfRisers {
    ForgeTypeId^ get ();
}
static member StairsActualNumberOfRisers : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsActualNumRisers Property

ParameterTypeIdStairsActualNumRisers Property

"Actual Number of Risers"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsActualNumRisers { get; }
Public Shared ReadOnly Property StairsActualNumRisers As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsActualNumRisers {
    ForgeTypeId^ get ();
}
static member StairsActualNumRisers : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsActualRiserHeight Property

ParameterTypeIdStairsActualRiserHeight Property

"Actual Riser Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsActualRiserHeight { get; }
Public Shared ReadOnly Property StairsActualRiserHeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsActualRiserHeight {
    ForgeTypeId^ get ();
}
static member StairsActualRiserHeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsActualTreadDepth Property

ParameterTypeIdStairsActualTreadDepth Property

"Actual Tread Depth"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsActualTreadDepth { get; }
Public Shared ReadOnly Property StairsActualTreadDepth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsActualTreadDepth {
    ForgeTypeId^ get ();
}
static member StairsActualTreadDepth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsAttrBodyMaterial Property

ParameterTypeIdStairsAttrBodyMaterial Property

"Monolithic Material"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsAttrBodyMaterial { get; }
Public Shared ReadOnly Property StairsAttrBodyMaterial As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsAttrBodyMaterial {
    ForgeTypeId^ get ();
}
static member StairsAttrBodyMaterial : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsAttrBreakSymInCutline Property

ParameterTypeIdStairsAttrBreakSymInCutline Property

"Break Symbol in Plan"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsAttrBreakSymInCutline { get; }
Public Shared ReadOnly Property StairsAttrBreakSymInCutline As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsAttrBreakSymInCutline {
    ForgeTypeId^ get ();
}
static member StairsAttrBreakSymInCutline : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsAttrCalcEnabled Property

ParameterTypeIdStairsAttrCalcEnabled Property

"Calculation Rules"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsAttrCalcEnabled { get; }
Public Shared ReadOnly Property StairsAttrCalcEnabled As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsAttrCalcEnabled {
    ForgeTypeId^ get ();
}
static member StairsAttrCalcEnabled : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsAttrCalcMax Property

ParameterTypeIdStairsAttrCalcMax Property

"Calculation Rules"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsAttrCalcMax { get; }
Public Shared ReadOnly Property StairsAttrCalcMax As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsAttrCalcMax {
    ForgeTypeId^ get ();
}
static member StairsAttrCalcMax : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsAttrCalcMin Property

ParameterTypeIdStairsAttrCalcMin Property

"Calculation Rules"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsAttrCalcMin { get; }
Public Shared ReadOnly Property StairsAttrCalcMin As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsAttrCalcMin {
    ForgeTypeId^ get ();
}
static member StairsAttrCalcMin : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsAttrEqResult Property

ParameterTypeIdStairsAttrEqResult Property

"Calculation Rules"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsAttrEqResult { get; }
Public Shared ReadOnly Property StairsAttrEqResult As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsAttrEqResult {
    ForgeTypeId^ get ();
}
static member StairsAttrEqResult : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsAttrFirstRiser Property

ParameterTypeIdStairsAttrFirstRiser Property

"Begin with Riser"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsAttrFirstRiser { get; }
Public Shared ReadOnly Property StairsAttrFirstRiser As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsAttrFirstRiser {
    ForgeTypeId^ get ();
}
static member StairsAttrFirstRiser : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsAttrLandingCarriage Property

ParameterTypeIdStairsAttrLandingCarriage Property

"Landing Carriage Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsAttrLandingCarriage { get; }
Public Shared ReadOnly Property StairsAttrLandingCarriage As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsAttrLandingCarriage {
    ForgeTypeId^ get ();
}
static member StairsAttrLandingCarriage : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsAttrLandingsOverlapping Property

ParameterTypeIdStairsAttrLandingsOverlapping Property

"Landing Overlap"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsAttrLandingsOverlapping { get; }
Public Shared ReadOnly Property StairsAttrLandingsOverlapping As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsAttrLandingsOverlapping {
    ForgeTypeId^ get ();
}
static member StairsAttrLandingsOverlapping : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsAttrLastRiser Property

ParameterTypeIdStairsAttrLastRiser Property

"End with Riser"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsAttrLastRiser { get; }
Public Shared ReadOnly Property StairsAttrLastRiser As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsAttrLastRiser {
    ForgeTypeId^ get ();
}
static member StairsAttrLastRiser : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsAttrLeftSideStringer Property

ParameterTypeIdStairsAttrLeftSideStringer Property

"Left Stringer"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsAttrLeftSideStringer { get; }
Public Shared ReadOnly Property StairsAttrLeftSideStringer As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsAttrLeftSideStringer {
    ForgeTypeId^ get ();
}
static member StairsAttrLeftSideStringer : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsAttrMaxRiserHeight Property

ParameterTypeIdStairsAttrMaxRiserHeight Property

"Maximum Riser Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsAttrMaxRiserHeight { get; }
Public Shared ReadOnly Property StairsAttrMaxRiserHeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsAttrMaxRiserHeight {
    ForgeTypeId^ get ();
}
static member StairsAttrMaxRiserHeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsAttrMinimumTreadDepth Property

ParameterTypeIdStairsAttrMinimumTreadDepth Property

"Minimum Tread Depth"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsAttrMinimumTreadDepth { get; }
Public Shared ReadOnly Property StairsAttrMinimumTreadDepth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsAttrMinimumTreadDepth {
    ForgeTypeId^ get ();
}
static member StairsAttrMinimumTreadDepth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsAttrMonolithicStairs Property

ParameterTypeIdStairsAttrMonolithicStairs Property

"Monolithic Stairs"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsAttrMonolithicStairs { get; }
Public Shared ReadOnly Property StairsAttrMonolithicStairs As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsAttrMonolithicStairs {
    ForgeTypeId^ get ();
}
static member StairsAttrMonolithicStairs : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsAttrNosingLength Property

ParameterTypeIdStairsAttrNosingLength Property

"Nosing Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsAttrNosingLength { get; }
Public Shared ReadOnly Property StairsAttrNosingLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsAttrNosingLength {
    ForgeTypeId^ get ();
}
static member StairsAttrNosingLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsAttrNosingPlacement Property

ParameterTypeIdStairsAttrNosingPlacement Property

"Apply Nosing Profile"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsAttrNosingPlacement { get; }
Public Shared ReadOnly Property StairsAttrNosingPlacement As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsAttrNosingPlacement {
    ForgeTypeId^ get ();
}
static member StairsAttrNosingPlacement : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsAttrNumMidStringers Property

ParameterTypeIdStairsAttrNumMidStringers Property

"Middle Stringers"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsAttrNumMidStringers { get; }
Public Shared ReadOnly Property StairsAttrNumMidStringers As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsAttrNumMidStringers {
    ForgeTypeId^ get ();
}
static member StairsAttrNumMidStringers : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsAttrRightSideStringer Property

ParameterTypeIdStairsAttrRightSideStringer Property

"Right Stringer"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsAttrRightSideStringer { get; }
Public Shared ReadOnly Property StairsAttrRightSideStringer As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsAttrRightSideStringer {
    ForgeTypeId^ get ();
}
static member StairsAttrRightSideStringer : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsAttrRiserAngle Property

ParameterTypeIdStairsAttrRiserAngle Property

"Riser Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsAttrRiserAngle { get; }
Public Shared ReadOnly Property StairsAttrRiserAngle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsAttrRiserAngle {
    ForgeTypeId^ get ();
}
static member StairsAttrRiserAngle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsAttrRiserMaterial Property

ParameterTypeIdStairsAttrRiserMaterial Property

"Riser Material"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsAttrRiserMaterial { get; }
Public Shared ReadOnly Property StairsAttrRiserMaterial As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsAttrRiserMaterial {
    ForgeTypeId^ get ();
}
static member StairsAttrRiserMaterial : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsAttrRiserMult Property

ParameterTypeIdStairsAttrRiserMult Property

"Riser Multiplier"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsAttrRiserMult { get; }
Public Shared ReadOnly Property StairsAttrRiserMult As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsAttrRiserMult {
    ForgeTypeId^ get ();
}
static member StairsAttrRiserMult : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsAttrRisersPresent Property

ParameterTypeIdStairsAttrRisersPresent Property

"Risers Present"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsAttrRisersPresent { get; }
Public Shared ReadOnly Property StairsAttrRisersPresent As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsAttrRisersPresent {
    ForgeTypeId^ get ();
}
static member StairsAttrRisersPresent : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsAttrRiserThickness Property

ParameterTypeIdStairsAttrRiserThickness Property

"Riser Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsAttrRiserThickness { get; }
Public Shared ReadOnly Property StairsAttrRiserThickness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsAttrRiserThickness {
    ForgeTypeId^ get ();
}
static member StairsAttrRiserThickness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsAttrRiserTreadConnect Property

ParameterTypeIdStairsAttrRiserTreadConnect Property

"Riser to Tread Connection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsAttrRiserTreadConnect { get; }
Public Shared ReadOnly Property StairsAttrRiserTreadConnect As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsAttrRiserTreadConnect {
    ForgeTypeId^ get ();
}
static member StairsAttrRiserTreadConnect : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsAttrRiserType Property

ParameterTypeIdStairsAttrRiserType Property

"Riser Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsAttrRiserType { get; }
Public Shared ReadOnly Property StairsAttrRiserType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsAttrRiserType {
    ForgeTypeId^ get ();
}
static member StairsAttrRiserType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsAttrSideStringerTypeParam Property

ParameterTypeIdStairsAttrSideStringerTypeParam Property

"Type of Side Stringers"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsAttrSideStringerTypeParam { get; }
Public Shared ReadOnly Property StairsAttrSideStringerTypeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsAttrSideStringerTypeParam {
    ForgeTypeId^ get ();
}
static member StairsAttrSideStringerTypeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsAttrStairCalculator Property

ParameterTypeIdStairsAttrStairCalculator Property

"Calculation Rules"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsAttrStairCalculator { get; }
Public Shared ReadOnly Property StairsAttrStairCalculator As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsAttrStairCalculator {
    ForgeTypeId^ get ();
}
static member StairsAttrStairCalculator : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsAttrStairsBottom Property

ParameterTypeIdStairsAttrStairsBottom Property

"Underside of Winder"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsAttrStairsBottom { get; }
Public Shared ReadOnly Property StairsAttrStairsBottom As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsAttrStairsBottom {
    ForgeTypeId^ get ();
}
static member StairsAttrStairsBottom : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsAttrStairsCutOffset Property

ParameterTypeIdStairsAttrStairsCutOffset Property

"Extend Below Base"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsAttrStairsCutOffset { get; }
Public Shared ReadOnly Property StairsAttrStairsCutOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsAttrStairsCutOffset {
    ForgeTypeId^ get ();
}
static member StairsAttrStairsCutOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsAttrStringerCarriage Property

ParameterTypeIdStairsAttrStringerCarriage Property

"Stringer Carriage Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsAttrStringerCarriage { get; }
Public Shared ReadOnly Property StairsAttrStringerCarriage As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsAttrStringerCarriage {
    ForgeTypeId^ get ();
}
static member StairsAttrStringerCarriage : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsAttrStringerHeight Property

ParameterTypeIdStairsAttrStringerHeight Property

"Stringer Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsAttrStringerHeight { get; }
Public Shared ReadOnly Property StairsAttrStringerHeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsAttrStringerHeight {
    ForgeTypeId^ get ();
}
static member StairsAttrStringerHeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsAttrStringerMaterial Property

ParameterTypeIdStairsAttrStringerMaterial Property

"Stringer Material"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsAttrStringerMaterial { get; }
Public Shared ReadOnly Property StairsAttrStringerMaterial As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsAttrStringerMaterial {
    ForgeTypeId^ get ();
}
static member StairsAttrStringerMaterial : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsAttrStringerOffset Property

ParameterTypeIdStairsAttrStringerOffset Property

"Open Stringer Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsAttrStringerOffset { get; }
Public Shared ReadOnly Property StairsAttrStringerOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsAttrStringerOffset {
    ForgeTypeId^ get ();
}
static member StairsAttrStringerOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsAttrStringerThickness Property

ParameterTypeIdStairsAttrStringerThickness Property

"Stringer Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsAttrStringerThickness { get; }
Public Shared ReadOnly Property StairsAttrStringerThickness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsAttrStringerThickness {
    ForgeTypeId^ get ();
}
static member StairsAttrStringerThickness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsAttrTextFont Property

ParameterTypeIdStairsAttrTextFont Property

"Text Font"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsAttrTextFont { get; }
Public Shared ReadOnly Property StairsAttrTextFont As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsAttrTextFont {
    ForgeTypeId^ get ();
}
static member StairsAttrTextFont : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsAttrTextSize Property

ParameterTypeIdStairsAttrTextSize Property

"Text Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsAttrTextSize { get; }
Public Shared ReadOnly Property StairsAttrTextSize As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsAttrTextSize {
    ForgeTypeId^ get ();
}
static member StairsAttrTextSize : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsAttrTreadFrontProfile Property

ParameterTypeIdStairsAttrTreadFrontProfile Property

"Nosing Profile"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsAttrTreadFrontProfile { get; }
Public Shared ReadOnly Property StairsAttrTreadFrontProfile As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsAttrTreadFrontProfile {
    ForgeTypeId^ get ();
}
static member StairsAttrTreadFrontProfile : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsAttrTreadMaterial Property

ParameterTypeIdStairsAttrTreadMaterial Property

"Tread Material"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsAttrTreadMaterial { get; }
Public Shared ReadOnly Property StairsAttrTreadMaterial As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsAttrTreadMaterial {
    ForgeTypeId^ get ();
}
static member StairsAttrTreadMaterial : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsAttrTreadMult Property

ParameterTypeIdStairsAttrTreadMult Property

"Tread Multiplier"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsAttrTreadMult { get; }
Public Shared ReadOnly Property StairsAttrTreadMult As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsAttrTreadMult {
    ForgeTypeId^ get ();
}
static member StairsAttrTreadMult : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsAttrTreadThickness Property

ParameterTypeIdStairsAttrTreadThickness Property

"Tread Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsAttrTreadThickness { get; }
Public Shared ReadOnly Property StairsAttrTreadThickness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsAttrTreadThickness {
    ForgeTypeId^ get ();
}
static member StairsAttrTreadThickness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsAttrTreadWidth Property

ParameterTypeIdStairsAttrTreadWidth Property

"Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsAttrTreadWidth { get; }
Public Shared ReadOnly Property StairsAttrTreadWidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsAttrTreadWidth {
    ForgeTypeId^ get ();
}
static member StairsAttrTreadWidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsAttrTrimTop Property

ParameterTypeIdStairsAttrTrimTop Property

"Trim Stringers at Top"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsAttrTrimTop { get; }
Public Shared ReadOnly Property StairsAttrTrimTop As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsAttrTrimTop {
    ForgeTypeId^ get ();
}
static member StairsAttrTrimTop : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsBaseLevel Property

ParameterTypeIdStairsBaseLevel Property

"Base Level": The base level of stairs

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsBaseLevel { get; }
Public Shared ReadOnly Property StairsBaseLevel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsBaseLevel {
    ForgeTypeId^ get ();
}
static member StairsBaseLevel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsBaseLevelParam Property

ParameterTypeIdStairsBaseLevelParam Property

"Base Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsBaseLevelParam { get; }
Public Shared ReadOnly Property StairsBaseLevelParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsBaseLevelParam {
    ForgeTypeId^ get ();
}
static member StairsBaseLevelParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsBaseOffset Property

ParameterTypeIdStairsBaseOffset Property

"Base Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsBaseOffset { get; }
Public Shared ReadOnly Property StairsBaseOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsBaseOffset {
    ForgeTypeId^ get ();
}
static member StairsBaseOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsCurveType Property

ParameterTypeIdStairsCurveType Property

"Stairs Line Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsCurveType { get; }
Public Shared ReadOnly Property StairsCurveType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsCurveType {
    ForgeTypeId^ get ();
}
static member StairsCurveType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsDbgShowAnnotationCutMark Property

ParameterTypeIdStairsDbgShowAnnotationCutMark Property

"Cut by Cut Plane"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsDbgShowAnnotationCutMark { get; }
Public Shared ReadOnly Property StairsDbgShowAnnotationCutMark As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsDbgShowAnnotationCutMark {
    ForgeTypeId^ get ();
}
static member StairsDbgShowAnnotationCutMark : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsDbgShowBoundary2d Property

ParameterTypeIdStairsDbgShowBoundary2d Property

"Show Stairs' Boundary 2D"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsDbgShowBoundary2d { get; }
Public Shared ReadOnly Property StairsDbgShowBoundary2d As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsDbgShowBoundary2d {
    ForgeTypeId^ get ();
}
static member StairsDbgShowBoundary2d : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsDbgShowBoundary3d Property

ParameterTypeIdStairsDbgShowBoundary3d Property

"Show Stairs' Boundary 3D"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsDbgShowBoundary3d { get; }
Public Shared ReadOnly Property StairsDbgShowBoundary3d As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsDbgShowBoundary3d {
    ForgeTypeId^ get ();
}
static member StairsDbgShowBoundary3d : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsDbgShowLandingBoundary Property

ParameterTypeIdStairsDbgShowLandingBoundary Property

"Show Landing Boundary"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsDbgShowLandingBoundary { get; }
Public Shared ReadOnly Property StairsDbgShowLandingBoundary As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsDbgShowLandingBoundary {
    ForgeTypeId^ get ();
}
static member StairsDbgShowLandingBoundary : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsDbgShowLandingFaces Property

ParameterTypeIdStairsDbgShowLandingFaces Property

"Show Landing Faces"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsDbgShowLandingFaces { get; }
Public Shared ReadOnly Property StairsDbgShowLandingFaces As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsDbgShowLandingFaces {
    ForgeTypeId^ get ();
}
static member StairsDbgShowLandingFaces : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsDbgShowLandingPath Property

ParameterTypeIdStairsDbgShowLandingPath Property

"Show Landing Path"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsDbgShowLandingPath { get; }
Public Shared ReadOnly Property StairsDbgShowLandingPath As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsDbgShowLandingPath {
    ForgeTypeId^ get ();
}
static member StairsDbgShowLandingPath : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsDbgShowLeftRunBoundary2d Property

ParameterTypeIdStairsDbgShowLeftRunBoundary2d Property

"Show Run's Left Boundary 2D"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsDbgShowLeftRunBoundary2d { get; }
Public Shared ReadOnly Property StairsDbgShowLeftRunBoundary2d As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsDbgShowLeftRunBoundary2d {
    ForgeTypeId^ get ();
}
static member StairsDbgShowLeftRunBoundary2d : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsDbgShowLeftRunBoundary3d Property

ParameterTypeIdStairsDbgShowLeftRunBoundary3d Property

"Show Run's Left Boundary 3D"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsDbgShowLeftRunBoundary3d { get; }
Public Shared ReadOnly Property StairsDbgShowLeftRunBoundary3d As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsDbgShowLeftRunBoundary3d {
    ForgeTypeId^ get ();
}
static member StairsDbgShowLeftRunBoundary3d : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsDbgShowMonolithicSupportCorseGeom Property

ParameterTypeIdStairsDbgShowMonolithicSupportCorseGeom Property

"Show Monolithic Support Corse Geometry"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsDbgShowMonolithicSupportCorseGeom { get; }
Public Shared ReadOnly Property StairsDbgShowMonolithicSupportCorseGeom As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsDbgShowMonolithicSupportCorseGeom {
    ForgeTypeId^ get ();
}
static member StairsDbgShowMonolithicSupportCorseGeom : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsDbgShowMonolithicSupportGeom Property

ParameterTypeIdStairsDbgShowMonolithicSupportGeom Property

"Show Monolithic Support Geometry"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsDbgShowMonolithicSupportGeom { get; }
Public Shared ReadOnly Property StairsDbgShowMonolithicSupportGeom As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsDbgShowMonolithicSupportGeom {
    ForgeTypeId^ get ();
}
static member StairsDbgShowMonolithicSupportGeom : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsDbgShowRightRunBoundary2d Property

ParameterTypeIdStairsDbgShowRightRunBoundary2d Property

"Show Run's Right Boundary 2D"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsDbgShowRightRunBoundary2d { get; }
Public Shared ReadOnly Property StairsDbgShowRightRunBoundary2d As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsDbgShowRightRunBoundary2d {
    ForgeTypeId^ get ();
}
static member StairsDbgShowRightRunBoundary2d : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsDbgShowRightRunBoundary3d Property

ParameterTypeIdStairsDbgShowRightRunBoundary3d Property

"Show Run's Right Boundary 3D"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsDbgShowRightRunBoundary3d { get; }
Public Shared ReadOnly Property StairsDbgShowRightRunBoundary3d As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsDbgShowRightRunBoundary3d {
    ForgeTypeId^ get ();
}
static member StairsDbgShowRightRunBoundary3d : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsDbgShowRunCorseGeom Property

ParameterTypeIdStairsDbgShowRunCorseGeom Property

"Show Run Corse Geometry"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsDbgShowRunCorseGeom { get; }
Public Shared ReadOnly Property StairsDbgShowRunCorseGeom As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsDbgShowRunCorseGeom {
    ForgeTypeId^ get ();
}
static member StairsDbgShowRunCorseGeom : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsDbgShowRunGeom Property

ParameterTypeIdStairsDbgShowRunGeom Property

"Show Run Geometry"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsDbgShowRunGeom { get; }
Public Shared ReadOnly Property StairsDbgShowRunGeom As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsDbgShowRunGeom {
    ForgeTypeId^ get ();
}
static member StairsDbgShowRunGeom : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsDbgShowRunNosing Property

ParameterTypeIdStairsDbgShowRunNosing Property

"Show Run's Nosings"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsDbgShowRunNosing { get; }
Public Shared ReadOnly Property StairsDbgShowRunNosing As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsDbgShowRunNosing {
    ForgeTypeId^ get ();
}
static member StairsDbgShowRunNosing : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsDbgShowRunOutlineForPlan Property

ParameterTypeIdStairsDbgShowRunOutlineForPlan Property

"Show Run Outline For Plan"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsDbgShowRunOutlineForPlan { get; }
Public Shared ReadOnly Property StairsDbgShowRunOutlineForPlan As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsDbgShowRunOutlineForPlan {
    ForgeTypeId^ get ();
}
static member StairsDbgShowRunOutlineForPlan : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsDbgShowRunPath2d Property

ParameterTypeIdStairsDbgShowRunPath2d Property

"Show Run's Path 2D"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsDbgShowRunPath2d { get; }
Public Shared ReadOnly Property StairsDbgShowRunPath2d As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsDbgShowRunPath2d {
    ForgeTypeId^ get ();
}
static member StairsDbgShowRunPath2d : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsDbgShowRunPath3d Property

ParameterTypeIdStairsDbgShowRunPath3d Property

"Show Run's Path 3D"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsDbgShowRunPath3d { get; }
Public Shared ReadOnly Property StairsDbgShowRunPath3d As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsDbgShowRunPath3d {
    ForgeTypeId^ get ();
}
static member StairsDbgShowRunPath3d : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsDbgShowRunRiser Property

ParameterTypeIdStairsDbgShowRunRiser Property

"Show Run's Risers"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsDbgShowRunRiser { get; }
Public Shared ReadOnly Property StairsDbgShowRunRiser As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsDbgShowRunRiser {
    ForgeTypeId^ get ();
}
static member StairsDbgShowRunRiser : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsDbgShowSupportPath Property

ParameterTypeIdStairsDbgShowSupportPath Property

"Show Support Path"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsDbgShowSupportPath { get; }
Public Shared ReadOnly Property StairsDbgShowSupportPath As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsDbgShowSupportPath {
    ForgeTypeId^ get ();
}
static member StairsDbgShowSupportPath : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsDbgShowTreadFaces Property

ParameterTypeIdStairsDbgShowTreadFaces Property

"Show Run's Tread Faces"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsDbgShowTreadFaces { get; }
Public Shared ReadOnly Property StairsDbgShowTreadFaces As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsDbgShowTreadFaces {
    ForgeTypeId^ get ();
}
static member StairsDbgShowTreadFaces : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsDbgShowTriserCorseGeom Property

ParameterTypeIdStairsDbgShowTriserCorseGeom Property

"Show Triser Corse Geometry"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsDbgShowTriserCorseGeom { get; }
Public Shared ReadOnly Property StairsDbgShowTriserCorseGeom As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsDbgShowTriserCorseGeom {
    ForgeTypeId^ get ();
}
static member StairsDbgShowTriserCorseGeom : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsDbgShowTriserGeom Property

ParameterTypeIdStairsDbgShowTriserGeom Property

"Show Triser Geometry"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsDbgShowTriserGeom { get; }
Public Shared ReadOnly Property StairsDbgShowTriserGeom As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsDbgShowTriserGeom {
    ForgeTypeId^ get ();
}
static member StairsDbgShowTriserGeom : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsDesiredNumberOfRisers Property

ParameterTypeIdStairsDesiredNumberOfRisers Property

"Desired Number of Risers": The number of risers is calculated based on stairs height

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsDesiredNumberOfRisers { get; }
Public Shared ReadOnly Property StairsDesiredNumberOfRisers As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsDesiredNumberOfRisers {
    ForgeTypeId^ get ();
}
static member StairsDesiredNumberOfRisers : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsDesiredNumRisers Property

ParameterTypeIdStairsDesiredNumRisers Property

"Desired Number of Risers"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsDesiredNumRisers { get; }
Public Shared ReadOnly Property StairsDesiredNumRisers As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsDesiredNumRisers {
    ForgeTypeId^ get ();
}
static member StairsDesiredNumRisers : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsDownText Property

ParameterTypeIdStairsDownText Property

"Down Text"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsDownText { get; }
Public Shared ReadOnly Property StairsDownText As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsDownText {
    ForgeTypeId^ get ();
}
static member StairsDownText : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsEnableCalculationRuleChecking Property

ParameterTypeIdStairsEnableCalculationRuleChecking Property

"Enable Calculator Rules Check": Enable calculation rule checking

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsEnableCalculationRuleChecking { get; }
Public Shared ReadOnly Property StairsEnableCalculationRuleChecking As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsEnableCalculationRuleChecking {
    ForgeTypeId^ get ();
}
static member StairsEnableCalculationRuleChecking : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsInstAlwaysUp Property

ParameterTypeIdStairsInstAlwaysUp Property

"Show Up arrow in all views"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsInstAlwaysUp { get; }
Public Shared ReadOnly Property StairsInstAlwaysUp As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsInstAlwaysUp {
    ForgeTypeId^ get ();
}
static member StairsInstAlwaysUp : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsInstDownArrowOn Property

ParameterTypeIdStairsInstDownArrowOn Property

"Down arrow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsInstDownArrowOn { get; }
Public Shared ReadOnly Property StairsInstDownArrowOn As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsInstDownArrowOn {
    ForgeTypeId^ get ();
}
static member StairsInstDownArrowOn : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsInstDownLabelOn Property

ParameterTypeIdStairsInstDownLabelOn Property

"Down label"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsInstDownLabelOn { get; }
Public Shared ReadOnly Property StairsInstDownLabelOn As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsInstDownLabelOn {
    ForgeTypeId^ get ();
}
static member StairsInstDownLabelOn : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsInstDownLabelText Property

ParameterTypeIdStairsInstDownLabelText Property

"Down text"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsInstDownLabelText { get; }
Public Shared ReadOnly Property StairsInstDownLabelText As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsInstDownLabelText {
    ForgeTypeId^ get ();
}
static member StairsInstDownLabelText : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsInstUpArrowOn Property

ParameterTypeIdStairsInstUpArrowOn Property

"Up arrow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsInstUpArrowOn { get; }
Public Shared ReadOnly Property StairsInstUpArrowOn As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsInstUpArrowOn {
    ForgeTypeId^ get ();
}
static member StairsInstUpArrowOn : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsInstUpLabelOn Property

ParameterTypeIdStairsInstUpLabelOn Property

"Up label"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsInstUpLabelOn { get; }
Public Shared ReadOnly Property StairsInstUpLabelOn As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsInstUpLabelOn {
    ForgeTypeId^ get ();
}
static member StairsInstUpLabelOn : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsInstUpLabelText Property

ParameterTypeIdStairsInstUpLabelText Property

"Up text"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsInstUpLabelText { get; }
Public Shared ReadOnly Property StairsInstUpLabelText As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsInstUpLabelText {
    ForgeTypeId^ get ();
}
static member StairsInstUpLabelText : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsLandingBaseElevation Property

ParameterTypeIdStairsLandingBaseElevation Property

"Relative Height": Height

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsLandingBaseElevation { get; }
Public Shared ReadOnly Property StairsLandingBaseElevation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsLandingBaseElevation {
    ForgeTypeId^ get ();
}
static member StairsLandingBaseElevation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsLandingOverridden Property

ParameterTypeIdStairsLandingOverridden Property

"Overridden": Overridden

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsLandingOverridden { get; }
Public Shared ReadOnly Property StairsLandingOverridden As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsLandingOverridden {
    ForgeTypeId^ get ();
}
static member StairsLandingOverridden : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsLandingStructural Property

ParameterTypeIdStairsLandingStructural Property

"Structural": Structural

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsLandingStructural { get; }
Public Shared ReadOnly Property StairsLandingStructural As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsLandingStructural {
    ForgeTypeId^ get ();
}
static member StairsLandingStructural : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsLandingThickness Property

ParameterTypeIdStairsLandingThickness Property

"Total Thickness": Thickness

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsLandingThickness { get; }
Public Shared ReadOnly Property StairsLandingThickness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsLandingThickness {
    ForgeTypeId^ get ();
}
static member StairsLandingThickness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsLandingtypeHasMonolithicSupport Property

ParameterTypeIdStairsLandingtypeHasMonolithicSupport Property

"Monolithic Support": Monolithic Support

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsLandingtypeHasMonolithicSupport { get; }
Public Shared ReadOnly Property StairsLandingtypeHasMonolithicSupport As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsLandingtypeHasMonolithicSupport {
    ForgeTypeId^ get ();
}
static member StairsLandingtypeHasMonolithicSupport : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsLandingtypeLandingMaterial Property

ParameterTypeIdStairsLandingtypeLandingMaterial Property

"Monolithic Material": Landing Material

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsLandingtypeLandingMaterial { get; }
Public Shared ReadOnly Property StairsLandingtypeLandingMaterial As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsLandingtypeLandingMaterial {
    ForgeTypeId^ get ();
}
static member StairsLandingtypeLandingMaterial : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsLandingtypeStructure Property

ParameterTypeIdStairsLandingtypeStructure Property

"Structure": Structure

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsLandingtypeStructure { get; }
Public Shared ReadOnly Property StairsLandingtypeStructure As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsLandingtypeStructure {
    ForgeTypeId^ get ();
}
static member StairsLandingtypeStructure : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsLandingtypeThickness Property

ParameterTypeIdStairsLandingtypeThickness Property

"Monolithic Thickness": Default thickness

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsLandingtypeThickness { get; }
Public Shared ReadOnly Property StairsLandingtypeThickness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsLandingtypeThickness {
    ForgeTypeId^ get ();
}
static member StairsLandingtypeThickness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsLandingtypeTreadriserType Property

ParameterTypeIdStairsLandingtypeTreadriserType Property

"Type": Tread/Riser Type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsLandingtypeTreadriserType { get; }
Public Shared ReadOnly Property StairsLandingtypeTreadriserType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsLandingtypeTreadriserType {
    ForgeTypeId^ get ();
}
static member StairsLandingtypeTreadriserType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsLandingtypeUseSameTriserAsRun Property

ParameterTypeIdStairsLandingtypeUseSameTriserAsRun Property

"Same as Run": Same as Run

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsLandingtypeUseSameTriserAsRun { get; }
Public Shared ReadOnly Property StairsLandingtypeUseSameTriserAsRun As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsLandingtypeUseSameTriserAsRun {
    ForgeTypeId^ get ();
}
static member StairsLandingtypeUseSameTriserAsRun : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsMinAutomaticLandingDepth Property

ParameterTypeIdStairsMinAutomaticLandingDepth Property

"Minimum Automatic Landing Depth": The minimum depth of automatic landing

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsMinAutomaticLandingDepth { get; }
Public Shared ReadOnly Property StairsMinAutomaticLandingDepth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsMinAutomaticLandingDepth {
    ForgeTypeId^ get ();
}
static member StairsMinAutomaticLandingDepth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsMultistoryTopLevelParam Property

ParameterTypeIdStairsMultistoryTopLevelParam Property

"Multistory Top Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsMultistoryTopLevelParam { get; }
Public Shared ReadOnly Property StairsMultistoryTopLevelParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsMultistoryTopLevelParam {
    ForgeTypeId^ get ();
}
static member StairsMultistoryTopLevelParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsMultistoryUpToLevel Property

ParameterTypeIdStairsMultistoryUpToLevel Property

"Multistory Top Level": The top level of multi-story stairs

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsMultistoryUpToLevel { get; }
Public Shared ReadOnly Property StairsMultistoryUpToLevel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsMultistoryUpToLevel {
    ForgeTypeId^ get ();
}
static member StairsMultistoryUpToLevel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsPathFullStepArrow Property

ParameterTypeIdStairsPathFullStepArrow Property

"Full Step Arrow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsPathFullStepArrow { get; }
Public Shared ReadOnly Property StairsPathFullStepArrow As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsPathFullStepArrow {
    ForgeTypeId^ get ();
}
static member StairsPathFullStepArrow : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsPathStartExtension Property

ParameterTypeIdStairsPathStartExtension Property

"Start Extension"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsPathStartExtension { get; }
Public Shared ReadOnly Property StairsPathStartExtension As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsPathStartExtension {
    ForgeTypeId^ get ();
}
static member StairsPathStartExtension : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsPathStartFromRiser Property

ParameterTypeIdStairsPathStartFromRiser Property

"Start from Riser"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsPathStartFromRiser { get; }
Public Shared ReadOnly Property StairsPathStartFromRiser As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsPathStartFromRiser {
    ForgeTypeId^ get ();
}
static member StairsPathStartFromRiser : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRailingAngledConnection Property

ParameterTypeIdStairsRailingAngledConnection Property

"Angled Joins"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRailingAngledConnection { get; }
Public Shared ReadOnly Property StairsRailingAngledConnection As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRailingAngledConnection {
    ForgeTypeId^ get ();
}
static member StairsRailingAngledConnection : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRailingBalusterBottomAngle Property

ParameterTypeIdStairsRailingBalusterBottomAngle Property

"Bottom Cut Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRailingBalusterBottomAngle { get; }
Public Shared ReadOnly Property StairsRailingBalusterBottomAngle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRailingBalusterBottomAngle {
    ForgeTypeId^ get ();
}
static member StairsRailingBalusterBottomAngle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRailingBalusterFamily Property

ParameterTypeIdStairsRailingBalusterFamily Property

"Baluster Family"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRailingBalusterFamily { get; }
Public Shared ReadOnly Property StairsRailingBalusterFamily As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRailingBalusterFamily {
    ForgeTypeId^ get ();
}
static member StairsRailingBalusterFamily : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRailingBalusterHeight Property

ParameterTypeIdStairsRailingBalusterHeight Property

"Baluster Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRailingBalusterHeight { get; }
Public Shared ReadOnly Property StairsRailingBalusterHeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRailingBalusterHeight {
    ForgeTypeId^ get ();
}
static member StairsRailingBalusterHeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRailingBalusterIsPost Property

ParameterTypeIdStairsRailingBalusterIsPost Property

"Post"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRailingBalusterIsPost { get; }
Public Shared ReadOnly Property StairsRailingBalusterIsPost As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRailingBalusterIsPost {
    ForgeTypeId^ get ();
}
static member StairsRailingBalusterIsPost : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRailingBalusterLength Property

ParameterTypeIdStairsRailingBalusterLength Property

"Baluster Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRailingBalusterLength { get; }
Public Shared ReadOnly Property StairsRailingBalusterLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRailingBalusterLength {
    ForgeTypeId^ get ();
}
static member StairsRailingBalusterLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRailingBalusterOffset Property

ParameterTypeIdStairsRailingBalusterOffset Property

"Baluster Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRailingBalusterOffset { get; }
Public Shared ReadOnly Property StairsRailingBalusterOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRailingBalusterOffset {
    ForgeTypeId^ get ();
}
static member StairsRailingBalusterOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRailingBalusterPlacement Property

ParameterTypeIdStairsRailingBalusterPlacement Property

"Baluster Placement"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRailingBalusterPlacement { get; }
Public Shared ReadOnly Property StairsRailingBalusterPlacement As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRailingBalusterPlacement {
    ForgeTypeId^ get ();
}
static member StairsRailingBalusterPlacement : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRailingBalusterShape Property

ParameterTypeIdStairsRailingBalusterShape Property

"Baluster Shape"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRailingBalusterShape { get; }
Public Shared ReadOnly Property StairsRailingBalusterShape As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRailingBalusterShape {
    ForgeTypeId^ get ();
}
static member StairsRailingBalusterShape : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRailingBalusterSlopeAngle Property

ParameterTypeIdStairsRailingBalusterSlopeAngle Property

"Slope Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRailingBalusterSlopeAngle { get; }
Public Shared ReadOnly Property StairsRailingBalusterSlopeAngle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRailingBalusterSlopeAngle {
    ForgeTypeId^ get ();
}
static member StairsRailingBalusterSlopeAngle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRailingBalusterSpacing Property

ParameterTypeIdStairsRailingBalusterSpacing Property

"Baluster Separation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRailingBalusterSpacing { get; }
Public Shared ReadOnly Property StairsRailingBalusterSpacing As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRailingBalusterSpacing {
    ForgeTypeId^ get ();
}
static member StairsRailingBalusterSpacing : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRailingBalusterSpacingType Property

ParameterTypeIdStairsRailingBalusterSpacingType Property

"Baluster Spacing Type (Stair Railing Only)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRailingBalusterSpacingType { get; }
Public Shared ReadOnly Property StairsRailingBalusterSpacingType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRailingBalusterSpacingType {
    ForgeTypeId^ get ();
}
static member StairsRailingBalusterSpacingType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRailingBalustersPerTread Property

ParameterTypeIdStairsRailingBalustersPerTread Property

"Balusters Per Tread (Stair Railing Only)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRailingBalustersPerTread { get; }
Public Shared ReadOnly Property StairsRailingBalustersPerTread As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRailingBalustersPerTread {
    ForgeTypeId^ get ();
}
static member StairsRailingBalustersPerTread : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRailingBalusterTopAngle Property

ParameterTypeIdStairsRailingBalusterTopAngle Property

"Top Cut Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRailingBalusterTopAngle { get; }
Public Shared ReadOnly Property StairsRailingBalusterTopAngle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRailingBalusterTopAngle {
    ForgeTypeId^ get ();
}
static member StairsRailingBalusterTopAngle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRailingBalusterWidth Property

ParameterTypeIdStairsRailingBalusterWidth Property

"Baluster Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRailingBalusterWidth { get; }
Public Shared ReadOnly Property StairsRailingBalusterWidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRailingBalusterWidth {
    ForgeTypeId^ get ();
}
static member StairsRailingBalusterWidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRailingBaseLevelParam Property

ParameterTypeIdStairsRailingBaseLevelParam Property

"Base Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRailingBaseLevelParam { get; }
Public Shared ReadOnly Property StairsRailingBaseLevelParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRailingBaseLevelParam {
    ForgeTypeId^ get ();
}
static member StairsRailingBaseLevelParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRailingConnection Property

ParameterTypeIdStairsRailingConnection Property

"Rail Connections"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRailingConnection { get; }
Public Shared ReadOnly Property StairsRailingConnection As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRailingConnection {
    ForgeTypeId^ get ();
}
static member StairsRailingConnection : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRailingHeight Property

ParameterTypeIdStairsRailingHeight Property

"Railing Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRailingHeight { get; }
Public Shared ReadOnly Property StairsRailingHeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRailingHeight {
    ForgeTypeId^ get ();
}
static member StairsRailingHeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRailingHeightOffset Property

ParameterTypeIdStairsRailingHeightOffset Property

"Base Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRailingHeightOffset { get; }
Public Shared ReadOnly Property StairsRailingHeightOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRailingHeightOffset {
    ForgeTypeId^ get ();
}
static member StairsRailingHeightOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRailingHeightShiftType Property

ParameterTypeIdStairsRailingHeightShiftType Property

"Use Landing Height Adjustment"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRailingHeightShiftType { get; }
Public Shared ReadOnly Property StairsRailingHeightShiftType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRailingHeightShiftType {
    ForgeTypeId^ get ();
}
static member StairsRailingHeightShiftType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRailingHeightShiftVal Property

ParameterTypeIdStairsRailingHeightShiftVal Property

"Landing Height Adjustment"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRailingHeightShiftVal { get; }
Public Shared ReadOnly Property StairsRailingHeightShiftVal As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRailingHeightShiftVal {
    ForgeTypeId^ get ();
}
static member StairsRailingHeightShiftVal : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRailingPlacementOffset Property

ParameterTypeIdStairsRailingPlacementOffset Property

"Offset from Path"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRailingPlacementOffset { get; }
Public Shared ReadOnly Property StairsRailingPlacementOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRailingPlacementOffset {
    ForgeTypeId^ get ();
}
static member StairsRailingPlacementOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRailingRailHeight Property

ParameterTypeIdStairsRailingRailHeight Property

"Rail Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRailingRailHeight { get; }
Public Shared ReadOnly Property StairsRailingRailHeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRailingRailHeight {
    ForgeTypeId^ get ();
}
static member StairsRailingRailHeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRailingRailName Property

ParameterTypeIdStairsRailingRailName Property

"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRailingRailName { get; }
Public Shared ReadOnly Property StairsRailingRailName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRailingRailName {
    ForgeTypeId^ get ();
}
static member StairsRailingRailName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRailingRailOffset Property

ParameterTypeIdStairsRailingRailOffset Property

"Rail Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRailingRailOffset { get; }
Public Shared ReadOnly Property StairsRailingRailOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRailingRailOffset {
    ForgeTypeId^ get ();
}
static member StairsRailingRailOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRailingRailStructure Property

ParameterTypeIdStairsRailingRailStructure Property

"Rail Structure (Non-Continuous)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRailingRailStructure { get; }
Public Shared ReadOnly Property StairsRailingRailStructure As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRailingRailStructure {
    ForgeTypeId^ get ();
}
static member StairsRailingRailStructure : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRailingShape Property

ParameterTypeIdStairsRailingShape Property

"Rail Shape"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRailingShape { get; }
Public Shared ReadOnly Property StairsRailingShape As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRailingShape {
    ForgeTypeId^ get ();
}
static member StairsRailingShape : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRailingTangentConnection Property

ParameterTypeIdStairsRailingTangentConnection Property

"Tangent Joins"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRailingTangentConnection { get; }
Public Shared ReadOnly Property StairsRailingTangentConnection As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRailingTangentConnection {
    ForgeTypeId^ get ();
}
static member StairsRailingTangentConnection : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRailingThickness Property

ParameterTypeIdStairsRailingThickness Property

"Railing Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRailingThickness { get; }
Public Shared ReadOnly Property StairsRailingThickness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRailingThickness {
    ForgeTypeId^ get ();
}
static member StairsRailingThickness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRailingWidth Property

ParameterTypeIdStairsRailingWidth Property

"Railing Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRailingWidth { get; }
Public Shared ReadOnly Property StairsRailingWidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRailingWidth {
    ForgeTypeId^ get ();
}
static member StairsRailingWidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRunActualNumberOfRisers Property

ParameterTypeIdStairsRunActualNumberOfRisers Property

"Actual Number of Risers": Actual Number of Risers

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRunActualNumberOfRisers { get; }
Public Shared ReadOnly Property StairsRunActualNumberOfRisers As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRunActualNumberOfRisers {
    ForgeTypeId^ get ();
}
static member StairsRunActualNumberOfRisers : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRunActualNumberOfTreads Property

ParameterTypeIdStairsRunActualNumberOfTreads Property

"Actual Number of Treads": Actual Number of Treads

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRunActualNumberOfTreads { get; }
Public Shared ReadOnly Property StairsRunActualNumberOfTreads As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRunActualNumberOfTreads {
    ForgeTypeId^ get ();
}
static member StairsRunActualNumberOfTreads : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRunActualRiserHeight Property

ParameterTypeIdStairsRunActualRiserHeight Property

"Actual Riser Height": Actual Riser Height

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRunActualRiserHeight { get; }
Public Shared ReadOnly Property StairsRunActualRiserHeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRunActualRiserHeight {
    ForgeTypeId^ get ();
}
static member StairsRunActualRiserHeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRunActualRunWidth Property

ParameterTypeIdStairsRunActualRunWidth Property

"Actual Run Width": Actual Run Width

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRunActualRunWidth { get; }
Public Shared ReadOnly Property StairsRunActualRunWidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRunActualRunWidth {
    ForgeTypeId^ get ();
}
static member StairsRunActualRunWidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRunActualTreadDepth Property

ParameterTypeIdStairsRunActualTreadDepth Property

"Actual Tread Depth": Actual Tread Depth

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRunActualTreadDepth { get; }
Public Shared ReadOnly Property StairsRunActualTreadDepth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRunActualTreadDepth {
    ForgeTypeId^ get ();
}
static member StairsRunActualTreadDepth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRunBeginWithRiser Property

ParameterTypeIdStairsRunBeginWithRiser Property

"Begin with Riser": Begin with Riser

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRunBeginWithRiser { get; }
Public Shared ReadOnly Property StairsRunBeginWithRiser As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRunBeginWithRiser {
    ForgeTypeId^ get ();
}
static member StairsRunBeginWithRiser : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRunBottomElevation Property

ParameterTypeIdStairsRunBottomElevation Property

"Relative Base Height": Relative height to stairs bottom elevation

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRunBottomElevation { get; }
Public Shared ReadOnly Property StairsRunBottomElevation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRunBottomElevation {
    ForgeTypeId^ get ();
}
static member StairsRunBottomElevation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRunCcw Property

ParameterTypeIdStairsRunCcw Property

"CCW": Revert the run preview

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRunCcw { get; }
Public Shared ReadOnly Property StairsRunCcw As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRunCcw {
    ForgeTypeId^ get ();
}
static member StairsRunCcw : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRunCenterMarkVisible Property

ParameterTypeIdStairsRunCenterMarkVisible Property

"Center Mark Visible": Center Mark Visible

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRunCenterMarkVisible { get; }
Public Shared ReadOnly Property StairsRunCenterMarkVisible As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRunCenterMarkVisible {
    ForgeTypeId^ get ();
}
static member StairsRunCenterMarkVisible : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRunCreateAutoLanding Property

ParameterTypeIdStairsRunCreateAutoLanding Property

"With Automatic Landing": Create automatic landing

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRunCreateAutoLanding { get; }
Public Shared ReadOnly Property StairsRunCreateAutoLanding As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRunCreateAutoLanding {
    ForgeTypeId^ get ();
}
static member StairsRunCreateAutoLanding : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRunEndWithRiser Property

ParameterTypeIdStairsRunEndWithRiser Property

"End with Riser": End with Riser

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRunEndWithRiser { get; }
Public Shared ReadOnly Property StairsRunEndWithRiser As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRunEndWithRiser {
    ForgeTypeId^ get ();
}
static member StairsRunEndWithRiser : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRunExtendBelowRiserBase Property

ParameterTypeIdStairsRunExtendBelowRiserBase Property

"Extend Below Riser Base": Extend Below Base

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRunExtendBelowRiserBase { get; }
Public Shared ReadOnly Property StairsRunExtendBelowRiserBase As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRunExtendBelowRiserBase {
    ForgeTypeId^ get ();
}
static member StairsRunExtendBelowRiserBase : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRunExtendBelowTreadBase Property

ParameterTypeIdStairsRunExtendBelowTreadBase Property

"Extend Below Tread Base": Extend Below Tread Base

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRunExtendBelowTreadBase { get; }
Public Shared ReadOnly Property StairsRunExtendBelowTreadBase As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRunExtendBelowTreadBase {
    ForgeTypeId^ get ();
}
static member StairsRunExtendBelowTreadBase : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRunHeight Property

ParameterTypeIdStairsRunHeight Property

"Run Height": Run Height

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRunHeight { get; }
Public Shared ReadOnly Property StairsRunHeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRunHeight {
    ForgeTypeId^ get ();
}
static member StairsRunHeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRunLocationpathJustfication Property

ParameterTypeIdStairsRunLocationpathJustfication Property

"Location Line": Location Line

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRunLocationpathJustfication { get; }
Public Shared ReadOnly Property StairsRunLocationpathJustfication As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRunLocationpathJustfication {
    ForgeTypeId^ get ();
}
static member StairsRunLocationpathJustfication : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRunOverridden Property

ParameterTypeIdStairsRunOverridden Property

"Overridden": Overridden

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRunOverridden { get; }
Public Shared ReadOnly Property StairsRunOverridden As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRunOverridden {
    ForgeTypeId^ get ();
}
static member StairsRunOverridden : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRunStructural Property

ParameterTypeIdStairsRunStructural Property

"Structural": Structural

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRunStructural { get; }
Public Shared ReadOnly Property StairsRunStructural As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRunStructural {
    ForgeTypeId^ get ();
}
static member StairsRunStructural : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRunTopElevation Property

ParameterTypeIdStairsRunTopElevation Property

"Relative Top Height": Top height of run

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRunTopElevation { get; }
Public Shared ReadOnly Property StairsRunTopElevation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRunTopElevation {
    ForgeTypeId^ get ();
}
static member StairsRunTopElevation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRuntypeHasMonolithicSupport Property

ParameterTypeIdStairsRuntypeHasMonolithicSupport Property

"Monolithic Support": Monolithic Support

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRuntypeHasMonolithicSupport { get; }
Public Shared ReadOnly Property StairsRuntypeHasMonolithicSupport As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRuntypeHasMonolithicSupport {
    ForgeTypeId^ get ();
}
static member StairsRuntypeHasMonolithicSupport : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRuntypeRunMaterial Property

ParameterTypeIdStairsRuntypeRunMaterial Property

"Monolithic Material": Material

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRuntypeRunMaterial { get; }
Public Shared ReadOnly Property StairsRuntypeRunMaterial As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRuntypeRunMaterial {
    ForgeTypeId^ get ();
}
static member StairsRuntypeRunMaterial : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRuntypeStructuralDepth Property

ParameterTypeIdStairsRuntypeStructuralDepth Property

"Structural Depth": Structural Depth

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRuntypeStructuralDepth { get; }
Public Shared ReadOnly Property StairsRuntypeStructuralDepth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRuntypeStructuralDepth {
    ForgeTypeId^ get ();
}
static member StairsRuntypeStructuralDepth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRuntypeStructure Property

ParameterTypeIdStairsRuntypeStructure Property

"Structure": Structure

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRuntypeStructure { get; }
Public Shared ReadOnly Property StairsRuntypeStructure As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRuntypeStructure {
    ForgeTypeId^ get ();
}
static member StairsRuntypeStructure : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRuntypeTotalDepth Property

ParameterTypeIdStairsRuntypeTotalDepth Property

"Total Depth": Total Depth

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRuntypeTotalDepth { get; }
Public Shared ReadOnly Property StairsRuntypeTotalDepth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRuntypeTotalDepth {
    ForgeTypeId^ get ();
}
static member StairsRuntypeTotalDepth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRuntypeUndersideSurfaceType Property

ParameterTypeIdStairsRuntypeUndersideSurfaceType Property

"Underside Surface": Underside Surface

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRuntypeUndersideSurfaceType { get; }
Public Shared ReadOnly Property StairsRuntypeUndersideSurfaceType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRuntypeUndersideSurfaceType {
    ForgeTypeId^ get ();
}
static member StairsRuntypeUndersideSurfaceType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRunWidthMeasurement Property

ParameterTypeIdStairsRunWidthMeasurement Property

"Run Width Measurement": Run Width Measurement

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRunWidthMeasurement { get; }
Public Shared ReadOnly Property StairsRunWidthMeasurement As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRunWidthMeasurement {
    ForgeTypeId^ get ();
}
static member StairsRunWidthMeasurement : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRunWinderBeginWithStraight Property

ParameterTypeIdStairsRunWinderBeginWithStraight Property

"Begin with Straight Run": Winder begin with straight run

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRunWinderBeginWithStraight { get; }
Public Shared ReadOnly Property StairsRunWinderBeginWithStraight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRunWinderBeginWithStraight {
    ForgeTypeId^ get ();
}
static member StairsRunWinderBeginWithStraight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsRunWinderEndWithStraight Property

ParameterTypeIdStairsRunWinderEndWithStraight Property

"End with Straight Run": Winder end with straight run

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsRunWinderEndWithStraight { get; }
Public Shared ReadOnly Property StairsRunWinderEndWithStraight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsRunWinderEndWithStraight {
    ForgeTypeId^ get ();
}
static member StairsRunWinderEndWithStraight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsShowDownText Property

ParameterTypeIdStairsShowDownText Property

"Show Down Text"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsShowDownText { get; }
Public Shared ReadOnly Property StairsShowDownText As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsShowDownText {
    ForgeTypeId^ get ();
}
static member StairsShowDownText : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsShowUpText Property

ParameterTypeIdStairsShowUpText Property

"Show Up Text"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsShowUpText { get; }
Public Shared ReadOnly Property StairsShowUpText As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsShowUpText {
    ForgeTypeId^ get ();
}
static member StairsShowUpText : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsStairsHeight Property

ParameterTypeIdStairsStairsHeight Property

"Desired Stair Height": Stairs unconnected height

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsStairsHeight { get; }
Public Shared ReadOnly Property StairsStairsHeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsStairsHeight {
    ForgeTypeId^ get ();
}
static member StairsStairsHeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsStringersPresent Property

ParameterTypeIdStairsStringersPresent Property

"Stringer Position"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsStringersPresent { get; }
Public Shared ReadOnly Property StairsStringersPresent As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsStringersPresent {
    ForgeTypeId^ get ();
}
static member StairsStringersPresent : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsSupportHorizontalOffset Property

ParameterTypeIdStairsSupportHorizontalOffset Property

"Lateral Offset": Distance from center or edge of boundary

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsSupportHorizontalOffset { get; }
Public Shared ReadOnly Property StairsSupportHorizontalOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsSupportHorizontalOffset {
    ForgeTypeId^ get ();
}
static member StairsSupportHorizontalOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsSupportLandingsupportType Property

ParameterTypeIdStairsSupportLandingsupportType Property

"Landing Support Type": Landing Support Type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsSupportLandingsupportType { get; }
Public Shared ReadOnly Property StairsSupportLandingsupportType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsSupportLandingsupportType {
    ForgeTypeId^ get ();
}
static member StairsSupportLandingsupportType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsSupportLowerEndCut Property

ParameterTypeIdStairsSupportLowerEndCut Property

"Lower End Cut": Lower End Cut

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsSupportLowerEndCut { get; }
Public Shared ReadOnly Property StairsSupportLowerEndCut As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsSupportLowerEndCut {
    ForgeTypeId^ get ();
}
static member StairsSupportLowerEndCut : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsSupportOverridden Property

ParameterTypeIdStairsSupportOverridden Property

"Overridden": Overridden

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsSupportOverridden { get; }
Public Shared ReadOnly Property StairsSupportOverridden As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsSupportOverridden {
    ForgeTypeId^ get ();
}
static member StairsSupportOverridden : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsSupportTrimSupportUpper Property

ParameterTypeIdStairsSupportTrimSupportUpper Property

"Trim Support at Upper": Trim Support at Upper

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsSupportTrimSupportUpper { get; }
Public Shared ReadOnly Property StairsSupportTrimSupportUpper As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsSupportTrimSupportUpper {
    ForgeTypeId^ get ();
}
static member StairsSupportTrimSupportUpper : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsSupporttypeFlipSectionProfile Property

ParameterTypeIdStairsSupporttypeFlipSectionProfile Property

"Flip Section Profile": Flip Section Profile

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsSupporttypeFlipSectionProfile { get; }
Public Shared ReadOnly Property StairsSupporttypeFlipSectionProfile As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsSupporttypeFlipSectionProfile {
    ForgeTypeId^ get ();
}
static member StairsSupporttypeFlipSectionProfile : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsSupporttypeMaterial Property

ParameterTypeIdStairsSupporttypeMaterial Property

"Material": Material

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsSupporttypeMaterial { get; }
Public Shared ReadOnly Property StairsSupporttypeMaterial As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsSupporttypeMaterial {
    ForgeTypeId^ get ();
}
static member StairsSupporttypeMaterial : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsSupporttypeSectionProfile Property

ParameterTypeIdStairsSupporttypeSectionProfile Property

"Section Profile": Section Profile

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsSupporttypeSectionProfile { get; }
Public Shared ReadOnly Property StairsSupporttypeSectionProfile As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsSupporttypeSectionProfile {
    ForgeTypeId^ get ();
}
static member StairsSupporttypeSectionProfile : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsSupporttypeStructuralDepth Property

ParameterTypeIdStairsSupporttypeStructuralDepth Property

"Structural Depth": Structural Depth

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsSupporttypeStructuralDepth { get; }
Public Shared ReadOnly Property StairsSupporttypeStructuralDepth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsSupporttypeStructuralDepth {
    ForgeTypeId^ get ();
}
static member StairsSupporttypeStructuralDepth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsSupporttypeStructuralDepthOnLanding Property

ParameterTypeIdStairsSupporttypeStructuralDepthOnLanding Property

"Structural Depth On Landing": Structural Depth

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsSupporttypeStructuralDepthOnLanding { get; }
Public Shared ReadOnly Property StairsSupporttypeStructuralDepthOnLanding As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsSupporttypeStructuralDepthOnLanding {
    ForgeTypeId^ get ();
}
static member StairsSupporttypeStructuralDepthOnLanding : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsSupporttypeStructuralDepthOnRun Property

ParameterTypeIdStairsSupporttypeStructuralDepthOnRun Property

"Structural Depth On Run": Structural Depth

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsSupporttypeStructuralDepthOnRun { get; }
Public Shared ReadOnly Property StairsSupporttypeStructuralDepthOnRun As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsSupporttypeStructuralDepthOnRun {
    ForgeTypeId^ get ();
}
static member StairsSupporttypeStructuralDepthOnRun : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsSupporttypeTopsideSurface Property

ParameterTypeIdStairsSupporttypeTopsideSurface Property

"Topside Surface": Topside Surface

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsSupporttypeTopsideSurface { get; }
Public Shared ReadOnly Property StairsSupporttypeTopsideSurface As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsSupporttypeTopsideSurface {
    ForgeTypeId^ get ();
}
static member StairsSupporttypeTopsideSurface : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsSupporttypeTotalDepth Property

ParameterTypeIdStairsSupporttypeTotalDepth Property

"Total Depth": Total Depth

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsSupporttypeTotalDepth { get; }
Public Shared ReadOnly Property StairsSupporttypeTotalDepth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsSupporttypeTotalDepth {
    ForgeTypeId^ get ();
}
static member StairsSupporttypeTotalDepth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsSupporttypeUndersideSurface Property

ParameterTypeIdStairsSupporttypeUndersideSurface Property

"Underside Surface": Underside Surface

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsSupporttypeUndersideSurface { get; }
Public Shared ReadOnly Property StairsSupporttypeUndersideSurface As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsSupporttypeUndersideSurface {
    ForgeTypeId^ get ();
}
static member StairsSupporttypeUndersideSurface : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsSupporttypeWidth Property

ParameterTypeIdStairsSupporttypeWidth Property

"Width": Width

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsSupporttypeWidth { get; }
Public Shared ReadOnly Property StairsSupporttypeWidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsSupporttypeWidth {
    ForgeTypeId^ get ();
}
static member StairsSupporttypeWidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsSupportUpperEndCut Property

ParameterTypeIdStairsSupportUpperEndCut Property

"Upper End Cut": Upper End Cut

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsSupportUpperEndCut { get; }
Public Shared ReadOnly Property StairsSupportUpperEndCut As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsSupportUpperEndCut {
    ForgeTypeId^ get ();
}
static member StairsSupportUpperEndCut : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsSupportVerticalOffset Property

ParameterTypeIdStairsSupportVerticalOffset Property

"Vertical Offset": Distance of top plane of edge stringer relative to the plane connecting tread nosing

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsSupportVerticalOffset { get; }
Public Shared ReadOnly Property StairsSupportVerticalOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsSupportVerticalOffset {
    ForgeTypeId^ get ();
}
static member StairsSupportVerticalOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsTextOrientation Property

ParameterTypeIdStairsTextOrientation Property

"Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsTextOrientation { get; }
Public Shared ReadOnly Property StairsTextOrientation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsTextOrientation {
    ForgeTypeId^ get ();
}
static member StairsTextOrientation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsTextType Property

ParameterTypeIdStairsTextType Property

"Text Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsTextType { get; }
Public Shared ReadOnly Property StairsTextType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsTextType {
    ForgeTypeId^ get ();
}
static member StairsTextType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsTopLevel Property

ParameterTypeIdStairsTopLevel Property

"Top Level": The top level of stairs

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsTopLevel { get; }
Public Shared ReadOnly Property StairsTopLevel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsTopLevel {
    ForgeTypeId^ get ();
}
static member StairsTopLevel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsTopLevelParam Property

ParameterTypeIdStairsTopLevelParam Property

"Top Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsTopLevelParam { get; }
Public Shared ReadOnly Property StairsTopLevelParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsTopLevelParam {
    ForgeTypeId^ get ();
}
static member StairsTopLevelParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsTopOffset Property

ParameterTypeIdStairsTopOffset Property

"Top Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsTopOffset { get; }
Public Shared ReadOnly Property StairsTopOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsTopOffset {
    ForgeTypeId^ get ();
}
static member StairsTopOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsTotalNumberOfRisers Property

ParameterTypeIdStairsTotalNumberOfRisers Property

"Total Number of Risers": Total number of risers

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsTotalNumberOfRisers { get; }
Public Shared ReadOnly Property StairsTotalNumberOfRisers As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsTotalNumberOfRisers {
    ForgeTypeId^ get ();
}
static member StairsTotalNumberOfRisers : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsTotalNumberOfTreads Property

ParameterTypeIdStairsTotalNumberOfTreads Property

"Total Number of Treads": Total number of treads

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsTotalNumberOfTreads { get; }
Public Shared ReadOnly Property StairsTotalNumberOfTreads As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsTotalNumberOfTreads {
    ForgeTypeId^ get ();
}
static member StairsTotalNumberOfTreads : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsTriserIsTypeOverridden Property

ParameterTypeIdStairsTriserIsTypeOverridden Property

"Overridden": (OBSOLETE) Indicate whether selected individual step is governed by default type setting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsTriserIsTypeOverridden { get; }
Public Shared ReadOnly Property StairsTriserIsTypeOverridden As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsTriserIsTypeOverridden {
    ForgeTypeId^ get ();
}
static member StairsTriserIsTypeOverridden : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsTriserNumberBaseIndex Property

ParameterTypeIdStairsTriserNumberBaseIndex Property

"Tread/Riser Start Number":

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsTriserNumberBaseIndex { get; }
Public Shared ReadOnly Property StairsTriserNumberBaseIndex As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsTriserNumberBaseIndex {
    ForgeTypeId^ get ();
}
static member StairsTriserNumberBaseIndex : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsTriserRiserMark Property

ParameterTypeIdStairsTriserRiserMark Property

"Riser Mark": (OBSOLETE)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsTriserRiserMark { get; }
Public Shared ReadOnly Property StairsTriserRiserMark As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsTriserRiserMark {
    ForgeTypeId^ get ();
}
static member StairsTriserRiserMark : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsTriserRiserNumber Property

ParameterTypeIdStairsTriserRiserNumber Property

"Riser Number": Count the sequential number of riser in the stair.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsTriserRiserNumber { get; }
Public Shared ReadOnly Property StairsTriserRiserNumber As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsTriserRiserNumber {
    ForgeTypeId^ get ();
}
static member StairsTriserRiserNumber : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsTriserTreadMark Property

ParameterTypeIdStairsTriserTreadMark Property

"Tread Mark": (OBSOLETE)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsTriserTreadMark { get; }
Public Shared ReadOnly Property StairsTriserTreadMark As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsTriserTreadMark {
    ForgeTypeId^ get ();
}
static member StairsTriserTreadMark : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsTriserTreadNumber Property

ParameterTypeIdStairsTriserTreadNumber Property

"Tread Number": Count the sequential number of tread in the stair.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsTriserTreadNumber { get; }
Public Shared ReadOnly Property StairsTriserTreadNumber As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsTriserTreadNumber {
    ForgeTypeId^ get ();
}
static member StairsTriserTreadNumber : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsTrisertypeBackNosing Property

ParameterTypeIdStairsTrisertypeBackNosing Property

"Back Nosing": (OBSOLETE)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsTrisertypeBackNosing { get; }
Public Shared ReadOnly Property StairsTrisertypeBackNosing As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsTrisertypeBackNosing {
    ForgeTypeId^ get ();
}
static member StairsTrisertypeBackNosing : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsTrisertypeFrontNosing Property

ParameterTypeIdStairsTrisertypeFrontNosing Property

"Front Nosing": (OBSOLETE)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsTrisertypeFrontNosing { get; }
Public Shared ReadOnly Property StairsTrisertypeFrontNosing As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsTrisertypeFrontNosing {
    ForgeTypeId^ get ();
}
static member StairsTrisertypeFrontNosing : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsTrisertypeLeftNosing Property

ParameterTypeIdStairsTrisertypeLeftNosing Property

"Left Nosing": (OBSOLETE)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsTrisertypeLeftNosing { get; }
Public Shared ReadOnly Property StairsTrisertypeLeftNosing As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsTrisertypeLeftNosing {
    ForgeTypeId^ get ();
}
static member StairsTrisertypeLeftNosing : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsTrisertypeNosingLength Property

ParameterTypeIdStairsTrisertypeNosingLength Property

"Nosing Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsTrisertypeNosingLength { get; }
Public Shared ReadOnly Property StairsTrisertypeNosingLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsTrisertypeNosingLength {
    ForgeTypeId^ get ();
}
static member StairsTrisertypeNosingLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsTrisertypeNosingPlacement Property

ParameterTypeIdStairsTrisertypeNosingPlacement Property

"Apply Nosing Profile"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsTrisertypeNosingPlacement { get; }
Public Shared ReadOnly Property StairsTrisertypeNosingPlacement As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsTrisertypeNosingPlacement {
    ForgeTypeId^ get ();
}
static member StairsTrisertypeNosingPlacement : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsTrisertypeNosingProfile Property

ParameterTypeIdStairsTrisertypeNosingProfile Property

"Nosing Profile"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsTrisertypeNosingProfile { get; }
Public Shared ReadOnly Property StairsTrisertypeNosingProfile As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsTrisertypeNosingProfile {
    ForgeTypeId^ get ();
}
static member StairsTrisertypeNosingProfile : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsTrisertypeRightNosing Property

ParameterTypeIdStairsTrisertypeRightNosing Property

"Right Nosing": (OBSOLETE)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsTrisertypeRightNosing { get; }
Public Shared ReadOnly Property StairsTrisertypeRightNosing As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsTrisertypeRightNosing {
    ForgeTypeId^ get ();
}
static member StairsTrisertypeRightNosing : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsTrisertypeRiser Property

ParameterTypeIdStairsTrisertypeRiser Property

"Riser"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsTrisertypeRiser { get; }
Public Shared ReadOnly Property StairsTrisertypeRiser As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsTrisertypeRiser {
    ForgeTypeId^ get ();
}
static member StairsTrisertypeRiser : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsTrisertypeRiserIsSlanted Property

ParameterTypeIdStairsTrisertypeRiserIsSlanted Property

"Slanted"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsTrisertypeRiserIsSlanted { get; }
Public Shared ReadOnly Property StairsTrisertypeRiserIsSlanted As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsTrisertypeRiserIsSlanted {
    ForgeTypeId^ get ();
}
static member StairsTrisertypeRiserIsSlanted : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsTrisertypeRiserMaterial Property

ParameterTypeIdStairsTrisertypeRiserMaterial Property

"Riser Material"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsTrisertypeRiserMaterial { get; }
Public Shared ReadOnly Property StairsTrisertypeRiserMaterial As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsTrisertypeRiserMaterial {
    ForgeTypeId^ get ();
}
static member StairsTrisertypeRiserMaterial : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsTrisertypeRiserProfile Property

ParameterTypeIdStairsTrisertypeRiserProfile Property

"Riser Profile"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsTrisertypeRiserProfile { get; }
Public Shared ReadOnly Property StairsTrisertypeRiserProfile As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsTrisertypeRiserProfile {
    ForgeTypeId^ get ();
}
static member StairsTrisertypeRiserProfile : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsTrisertypeRiserStyle Property

ParameterTypeIdStairsTrisertypeRiserStyle Property

"Riser Type": (OBSOLETE)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsTrisertypeRiserStyle { get; }
Public Shared ReadOnly Property StairsTrisertypeRiserStyle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsTrisertypeRiserStyle {
    ForgeTypeId^ get ();
}
static member StairsTrisertypeRiserStyle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsTrisertypeRiserThickness Property

ParameterTypeIdStairsTrisertypeRiserThickness Property

"Riser Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsTrisertypeRiserThickness { get; }
Public Shared ReadOnly Property StairsTrisertypeRiserThickness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsTrisertypeRiserThickness {
    ForgeTypeId^ get ();
}
static member StairsTrisertypeRiserThickness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsTrisertypeRiserTreadConnection Property

ParameterTypeIdStairsTrisertypeRiserTreadConnection Property

"Riser To Tread Connection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsTrisertypeRiserTreadConnection { get; }
Public Shared ReadOnly Property StairsTrisertypeRiserTreadConnection As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsTrisertypeRiserTreadConnection {
    ForgeTypeId^ get ();
}
static member StairsTrisertypeRiserTreadConnection : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsTrisertypeTread Property

ParameterTypeIdStairsTrisertypeTread Property

"Tread"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsTrisertypeTread { get; }
Public Shared ReadOnly Property StairsTrisertypeTread As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsTrisertypeTread {
    ForgeTypeId^ get ();
}
static member StairsTrisertypeTread : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsTrisertypeTreadMaterial Property

ParameterTypeIdStairsTrisertypeTreadMaterial Property

"Tread Material"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsTrisertypeTreadMaterial { get; }
Public Shared ReadOnly Property StairsTrisertypeTreadMaterial As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsTrisertypeTreadMaterial {
    ForgeTypeId^ get ();
}
static member StairsTrisertypeTreadMaterial : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsTrisertypeTreadProfile Property

ParameterTypeIdStairsTrisertypeTreadProfile Property

"Tread Profile"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsTrisertypeTreadProfile { get; }
Public Shared ReadOnly Property StairsTrisertypeTreadProfile As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsTrisertypeTreadProfile {
    ForgeTypeId^ get ();
}
static member StairsTrisertypeTreadProfile : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsTrisertypeTreadThickness Property

ParameterTypeIdStairsTrisertypeTreadThickness Property

"Tread Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsTrisertypeTreadThickness { get; }
Public Shared ReadOnly Property StairsTrisertypeTreadThickness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsTrisertypeTreadThickness {
    ForgeTypeId^ get ();
}
static member StairsTrisertypeTreadThickness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairstypeCalcRuleMaxResult Property

ParameterTypeIdStairstypeCalcRuleMaxResult Property

"Max. Result": Calculation Rule Max Result

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairstypeCalcRuleMaxResult { get; }
Public Shared ReadOnly Property StairstypeCalcRuleMaxResult As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairstypeCalcRuleMaxResult {
    ForgeTypeId^ get ();
}
static member StairstypeCalcRuleMaxResult : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairstypeCalcRuleMinResult Property

ParameterTypeIdStairstypeCalcRuleMinResult Property

"Min. Result": Calculation Rule Min Result

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairstypeCalcRuleMinResult { get; }
Public Shared ReadOnly Property StairstypeCalcRuleMinResult As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairstypeCalcRuleMinResult {
    ForgeTypeId^ get ();
}
static member StairstypeCalcRuleMinResult : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairstypeCalcRuleRiserMultiplier Property

ParameterTypeIdStairstypeCalcRuleRiserMultiplier Property

"Riser Multiplier": Calculation Rule Riser Multiplier

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairstypeCalcRuleRiserMultiplier { get; }
Public Shared ReadOnly Property StairstypeCalcRuleRiserMultiplier As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairstypeCalcRuleRiserMultiplier {
    ForgeTypeId^ get ();
}
static member StairstypeCalcRuleRiserMultiplier : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairstypeCalcRuleTargetResult Property

ParameterTypeIdStairstypeCalcRuleTargetResult Property

"Target Result": Calculation Rule Target Result

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairstypeCalcRuleTargetResult { get; }
Public Shared ReadOnly Property StairstypeCalcRuleTargetResult As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairstypeCalcRuleTargetResult {
    ForgeTypeId^ get ();
}
static member StairstypeCalcRuleTargetResult : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairstypeCalcRuleTreadMultiplier Property

ParameterTypeIdStairstypeCalcRuleTreadMultiplier Property

"Tread Multiplier": Calculation Rule Tread Multiplier

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairstypeCalcRuleTreadMultiplier { get; }
Public Shared ReadOnly Property StairstypeCalcRuleTreadMultiplier As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairstypeCalcRuleTreadMultiplier {
    ForgeTypeId^ get ();
}
static member StairstypeCalcRuleTreadMultiplier : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairstypeCalculationRules Property

ParameterTypeIdStairstypeCalculationRules Property

"Calculation Rules": Calculation Rules

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairstypeCalculationRules { get; }
Public Shared ReadOnly Property StairstypeCalculationRules As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairstypeCalculationRules {
    ForgeTypeId^ get ();
}
static member StairstypeCalculationRules : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairstypeConstructionMethod Property

ParameterTypeIdStairstypeConstructionMethod Property

"Construction Method":

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairstypeConstructionMethod { get; }
Public Shared ReadOnly Property StairstypeConstructionMethod As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairstypeConstructionMethod {
    ForgeTypeId^ get ();
}
static member StairstypeConstructionMethod : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairstypeCutmarkType Property

ParameterTypeIdStairstypeCutmarkType Property

"Cut Mark Type": Cut Mark Type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairstypeCutmarkType { get; }
Public Shared ReadOnly Property StairstypeCutmarkType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairstypeCutmarkType {
    ForgeTypeId^ get ();
}
static member StairstypeCutmarkType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairstypeGeomunjoinedEndCutStyle Property

ParameterTypeIdStairstypeGeomunjoinedEndCutStyle Property

"Connection Method": Cut Style for Geometrically Unjoined End

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairstypeGeomunjoinedEndCutStyle { get; }
Public Shared ReadOnly Property StairstypeGeomunjoinedEndCutStyle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairstypeGeomunjoinedEndCutStyle {
    ForgeTypeId^ get ();
}
static member StairstypeGeomunjoinedEndCutStyle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairstypeHasIntermediateSupport Property

ParameterTypeIdStairstypeHasIntermediateSupport Property

"Middle Support": Whether stairs is assembled

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairstypeHasIntermediateSupport { get; }
Public Shared ReadOnly Property StairstypeHasIntermediateSupport As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairstypeHasIntermediateSupport {
    ForgeTypeId^ get ();
}
static member StairstypeHasIntermediateSupport : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairstypeHasLeftSupport Property

ParameterTypeIdStairstypeHasLeftSupport Property

"Left Support":

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairstypeHasLeftSupport { get; }
Public Shared ReadOnly Property StairstypeHasLeftSupport As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairstypeHasLeftSupport {
    ForgeTypeId^ get ();
}
static member StairstypeHasLeftSupport : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairstypeHasRightSupport Property

ParameterTypeIdStairstypeHasRightSupport Property

"Right Support":

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairstypeHasRightSupport { get; }
Public Shared ReadOnly Property StairstypeHasRightSupport As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairstypeHasRightSupport {
    ForgeTypeId^ get ();
}
static member StairstypeHasRightSupport : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairstypeIntermediateSupportType Property

ParameterTypeIdStairstypeIntermediateSupportType Property

"Middle Support Type": Intermediate Support Type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairstypeIntermediateSupportType { get; }
Public Shared ReadOnly Property StairstypeIntermediateSupportType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairstypeIntermediateSupportType {
    ForgeTypeId^ get ();
}
static member StairstypeIntermediateSupportType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairstypeIsAssembledStairs Property

ParameterTypeIdStairstypeIsAssembledStairs Property

"Assembled Stair": Whether stairs is assembled

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairstypeIsAssembledStairs { get; }
Public Shared ReadOnly Property StairstypeIsAssembledStairs As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairstypeIsAssembledStairs {
    ForgeTypeId^ get ();
}
static member StairstypeIsAssembledStairs : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairstypeLandingType Property

ParameterTypeIdStairstypeLandingType Property

"Landing Type": Landing Type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairstypeLandingType { get; }
Public Shared ReadOnly Property StairstypeLandingType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairstypeLandingType {
    ForgeTypeId^ get ();
}
static member StairstypeLandingType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairstypeLeftSideSupportType Property

ParameterTypeIdStairstypeLeftSideSupportType Property

"Left Support Type": Left Side Support Type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairstypeLeftSideSupportType { get; }
Public Shared ReadOnly Property StairstypeLeftSideSupportType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairstypeLeftSideSupportType {
    ForgeTypeId^ get ();
}
static member StairstypeLeftSideSupportType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairstypeLeftSupportLateralOffset Property

ParameterTypeIdStairstypeLeftSupportLateralOffset Property

"Left Lateral Offset":

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairstypeLeftSupportLateralOffset { get; }
Public Shared ReadOnly Property StairstypeLeftSupportLateralOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairstypeLeftSupportLateralOffset {
    ForgeTypeId^ get ();
}
static member StairstypeLeftSupportLateralOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairstypeMaximumRiserHeight Property

ParameterTypeIdStairstypeMaximumRiserHeight Property

"Max. Riser Height": Maximum Riser Height

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairstypeMaximumRiserHeight { get; }
Public Shared ReadOnly Property StairstypeMaximumRiserHeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairstypeMaximumRiserHeight {
    ForgeTypeId^ get ();
}
static member StairstypeMaximumRiserHeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairstypeMinimumRunWidth Property

ParameterTypeIdStairstypeMinimumRunWidth Property

"Minimum Run Width": Minimum Run Width

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairstypeMinimumRunWidth { get; }
Public Shared ReadOnly Property StairstypeMinimumRunWidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairstypeMinimumRunWidth {
    ForgeTypeId^ get ();
}
static member StairstypeMinimumRunWidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairstypeMinimumTreadDepth Property

ParameterTypeIdStairstypeMinimumTreadDepth Property

"Min. Tread Depth": Minimum Tread Depth

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairstypeMinimumTreadDepth { get; }
Public Shared ReadOnly Property StairstypeMinimumTreadDepth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairstypeMinimumTreadDepth {
    ForgeTypeId^ get ();
}
static member StairstypeMinimumTreadDepth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairstypeMinimumTreadWidthInsideBoundary Property

ParameterTypeIdStairstypeMinimumTreadWidthInsideBoundary Property

"Min. Tread Depth on Winder Inner Boundary": Minimum Tread Width on Inside Boundary

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairstypeMinimumTreadWidthInsideBoundary { get; }
Public Shared ReadOnly Property StairstypeMinimumTreadWidthInsideBoundary As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairstypeMinimumTreadWidthInsideBoundary {
    ForgeTypeId^ get ();
}
static member StairstypeMinimumTreadWidthInsideBoundary : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairstypeNotchCustomWidth Property

ParameterTypeIdStairstypeNotchCustomWidth Property

"Custom":

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairstypeNotchCustomWidth { get; }
Public Shared ReadOnly Property StairstypeNotchCustomWidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairstypeNotchCustomWidth {
    ForgeTypeId^ get ();
}
static member StairstypeNotchCustomWidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairstypeNotchExtension Property

ParameterTypeIdStairstypeNotchExtension Property

"Notch Extension":

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairstypeNotchExtension { get; }
Public Shared ReadOnly Property StairstypeNotchExtension As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairstypeNotchExtension {
    ForgeTypeId^ get ();
}
static member StairstypeNotchExtension : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairstypeNotchHorizontalGap Property

ParameterTypeIdStairstypeNotchHorizontalGap Property

"Horizontal Gap Distance":

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairstypeNotchHorizontalGap { get; }
Public Shared ReadOnly Property StairstypeNotchHorizontalGap As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairstypeNotchHorizontalGap {
    ForgeTypeId^ get ();
}
static member StairstypeNotchHorizontalGap : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairstypeNotchThickness Property

ParameterTypeIdStairstypeNotchThickness Property

"Notch Thickness":

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairstypeNotchThickness { get; }
Public Shared ReadOnly Property StairstypeNotchThickness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairstypeNotchThickness {
    ForgeTypeId^ get ();
}
static member StairstypeNotchThickness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairstypeNotchVerticalGap Property

ParameterTypeIdStairstypeNotchVerticalGap Property

"Vertical Gap Distance":

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairstypeNotchVerticalGap { get; }
Public Shared ReadOnly Property StairstypeNotchVerticalGap As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairstypeNotchVerticalGap {
    ForgeTypeId^ get ();
}
static member StairstypeNotchVerticalGap : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairstypeNotchWidth Property

ParameterTypeIdStairstypeNotchWidth Property

"Notch Width":

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairstypeNotchWidth { get; }
Public Shared ReadOnly Property StairstypeNotchWidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairstypeNotchWidth {
    ForgeTypeId^ get ();
}
static member StairstypeNotchWidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairstypeNumberOfIntermediateSupports Property

ParameterTypeIdStairstypeNumberOfIntermediateSupports Property

"Middle Support Number": Number of intermediate supports

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairstypeNumberOfIntermediateSupports { get; }
Public Shared ReadOnly Property StairstypeNumberOfIntermediateSupports As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairstypeNumberOfIntermediateSupports {
    ForgeTypeId^ get ();
}
static member StairstypeNumberOfIntermediateSupports : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairstypeRightSideSupportType Property

ParameterTypeIdStairstypeRightSideSupportType Property

"Right Support Type": Right Side Support Type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairstypeRightSideSupportType { get; }
Public Shared ReadOnly Property StairstypeRightSideSupportType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairstypeRightSideSupportType {
    ForgeTypeId^ get ();
}
static member StairstypeRightSideSupportType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairstypeRightSupportLateralOffset Property

ParameterTypeIdStairstypeRightSupportLateralOffset Property

"Right Lateral Offset":

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairstypeRightSupportLateralOffset { get; }
Public Shared ReadOnly Property StairstypeRightSupportLateralOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairstypeRightSupportLateralOffset {
    ForgeTypeId^ get ();
}
static member StairstypeRightSupportLateralOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairstypeRunType Property

ParameterTypeIdStairstypeRunType Property

"Run Type": Run Type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairstypeRunType { get; }
Public Shared ReadOnly Property StairstypeRunType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairstypeRunType {
    ForgeTypeId^ get ();
}
static member StairstypeRunType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairstypeShowCutline Property

ParameterTypeIdStairstypeShowCutline Property

"Show Cut Line in Plan": Show Cut Line in Plan

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairstypeShowCutline { get; }
Public Shared ReadOnly Property StairstypeShowCutline As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairstypeShowCutline {
    ForgeTypeId^ get ();
}
static member StairstypeShowCutline : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairstypeShowStairPath Property

ParameterTypeIdStairstypeShowStairPath Property

"Show Stair Path in Plan": Show Stair Path in Plan

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairstypeShowStairPath { get; }
Public Shared ReadOnly Property StairstypeShowStairPath As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairstypeShowStairPath {
    ForgeTypeId^ get ();
}
static member StairstypeShowStairPath : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairstypeShowUpdown Property

ParameterTypeIdStairstypeShowUpdown Property

"Show Up/Down in Plan": Show Up/Down in Plan

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairstypeShowUpdown { get; }
Public Shared ReadOnly Property StairstypeShowUpdown As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairstypeShowUpdown {
    ForgeTypeId^ get ();
}
static member StairstypeShowUpdown : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairstypeWinderStepFrontMeasurement Property

ParameterTypeIdStairstypeWinderStepFrontMeasurement Property

"Winder Algorithm": Winder Algorithm

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairstypeWinderStepFrontMeasurement { get; }
Public Shared ReadOnly Property StairstypeWinderStepFrontMeasurement As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairstypeWinderStepFrontMeasurement {
    ForgeTypeId^ get ();
}
static member StairstypeWinderStepFrontMeasurement : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsUpText Property

ParameterTypeIdStairsUpText Property

"Up Text"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsUpText { get; }
Public Shared ReadOnly Property StairsUpText As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsUpText {
    ForgeTypeId^ get ();
}
static member StairsUpText : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsWinderpatternFilletInsideCorner Property

ParameterTypeIdStairsWinderpatternFilletInsideCorner Property

"Fillet on Corner": Fillet on inside corner

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsWinderpatternFilletInsideCorner { get; }
Public Shared ReadOnly Property StairsWinderpatternFilletInsideCorner As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsWinderpatternFilletInsideCorner {
    ForgeTypeId^ get ();
}
static member StairsWinderpatternFilletInsideCorner : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsWinderpatternMinimumWidthCorner Property

ParameterTypeIdStairsWinderpatternMinimumWidthCorner Property

"Minimum Width on Inside Boundary": Minimum Width on Inside Boundary

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsWinderpatternMinimumWidthCorner { get; }
Public Shared ReadOnly Property StairsWinderpatternMinimumWidthCorner As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsWinderpatternMinimumWidthCorner {
    ForgeTypeId^ get ();
}
static member StairsWinderpatternMinimumWidthCorner : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsWinderpatternMinimumWidthInsideWalkline Property

ParameterTypeIdStairsWinderpatternMinimumWidthInsideWalkline Property

"Minimum Width on Inside Walk Line": Minimum width on inside walkline

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsWinderpatternMinimumWidthInsideWalkline { get; }
Public Shared ReadOnly Property StairsWinderpatternMinimumWidthInsideWalkline As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsWinderpatternMinimumWidthInsideWalkline {
    ForgeTypeId^ get ();
}
static member StairsWinderpatternMinimumWidthInsideWalkline : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsWinderpatternNumberOfStraightStepsAtBegin Property

ParameterTypeIdStairsWinderpatternNumberOfStraightStepsAtBegin Property

"Parallel Treads at Start": Number of straight steps at the begin of winder

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsWinderpatternNumberOfStraightStepsAtBegin { get; }
Public Shared ReadOnly Property StairsWinderpatternNumberOfStraightStepsAtBegin As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsWinderpatternNumberOfStraightStepsAtBegin {
    ForgeTypeId^ get ();
}
static member StairsWinderpatternNumberOfStraightStepsAtBegin : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsWinderpatternNumberOfStraightStepsAtEnd Property

ParameterTypeIdStairsWinderpatternNumberOfStraightStepsAtEnd Property

"Parallel Treads at End": Number of straight steps at the begin of winder

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsWinderpatternNumberOfStraightStepsAtEnd { get; }
Public Shared ReadOnly Property StairsWinderpatternNumberOfStraightStepsAtEnd As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsWinderpatternNumberOfStraightStepsAtEnd {
    ForgeTypeId^ get ();
}
static member StairsWinderpatternNumberOfStraightStepsAtEnd : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsWinderpatternRadiusInterior Property

ParameterTypeIdStairsWinderpatternRadiusInterior Property

"Fillet Radius": The fillet corner radius on the interior boundary

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsWinderpatternRadiusInterior { get; }
Public Shared ReadOnly Property StairsWinderpatternRadiusInterior As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsWinderpatternRadiusInterior {
    ForgeTypeId^ get ();
}
static member StairsWinderpatternRadiusInterior : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsWinderpatternStairPathOffset Property

ParameterTypeIdStairsWinderpatternStairPathOffset Property

"Inside Walk Line Offset": The offset from inside walk line to interior boundary

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsWinderpatternStairPathOffset { get; }
Public Shared ReadOnly Property StairsWinderpatternStairPathOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsWinderpatternStairPathOffset {
    ForgeTypeId^ get ();
}
static member StairsWinderpatternStairPathOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StairsWinderpatternWinderStyle Property

ParameterTypeIdStairsWinderpatternWinderStyle Property

"Winder Style": Winder Style

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StairsWinderpatternWinderStyle { get; }
Public Shared ReadOnly Property StairsWinderpatternWinderStyle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StairsWinderpatternWinderStyle {
    ForgeTypeId^ get ();
}
static member StairsWinderpatternWinderStyle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StartExtension Property

ParameterTypeIdStartExtension Property

"Start Extension"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StartExtension { get; }
Public Shared ReadOnly Property StartExtension As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StartExtension {
    ForgeTypeId^ get ();
}
static member StartExtension : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StartJoinCutback Property

ParameterTypeIdStartJoinCutback Property

"Start Join Cutback"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StartJoinCutback { get; }
Public Shared ReadOnly Property StartJoinCutback As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StartJoinCutback {
    ForgeTypeId^ get ();
}
static member StartJoinCutback : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StartSymbolType Property

ParameterTypeIdStartSymbolType Property

"Start Symbol Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StartSymbolType { get; }
Public Shared ReadOnly Property StartSymbolType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StartSymbolType {
    ForgeTypeId^ get ();
}
static member StartSymbolType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StartYJustification Property

ParameterTypeIdStartYJustification Property

"Start y Justification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StartYJustification { get; }
Public Shared ReadOnly Property StartYJustification As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StartYJustification {
    ForgeTypeId^ get ();
}
static member StartYJustification : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StartYOffsetValue Property

ParameterTypeIdStartYOffsetValue Property

"Start y Offset Value"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StartYOffsetValue { get; }
Public Shared ReadOnly Property StartYOffsetValue As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StartYOffsetValue {
    ForgeTypeId^ get ();
}
static member StartYOffsetValue : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StartZJustification Property

ParameterTypeIdStartZJustification Property

"Start z Justification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StartZJustification { get; }
Public Shared ReadOnly Property StartZJustification As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StartZJustification {
    ForgeTypeId^ get ();
}
static member StartZJustification : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StartZOffsetValue Property

ParameterTypeIdStartZOffsetValue Property

"Start z Offset Value"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StartZOffsetValue { get; }
Public Shared ReadOnly Property StartZOffsetValue As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StartZOffsetValue {
    ForgeTypeId^ get ();
}
static member StartZOffsetValue : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemAnchorAssembly Property

ParameterTypeIdSteelElemAnchorAssembly Property

"Assembly"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemAnchorAssembly { get; }
Public Shared ReadOnly Property SteelElemAnchorAssembly As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemAnchorAssembly {
    ForgeTypeId^ get ();
}
static member SteelElemAnchorAssembly : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemAnchorDiameter Property

ParameterTypeIdSteelElemAnchorDiameter Property

"Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemAnchorDiameter { get; }
Public Shared ReadOnly Property SteelElemAnchorDiameter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemAnchorDiameter {
    ForgeTypeId^ get ();
}
static member SteelElemAnchorDiameter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemAnchorGrade Property

ParameterTypeIdSteelElemAnchorGrade Property

"Grade"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemAnchorGrade { get; }
Public Shared ReadOnly Property SteelElemAnchorGrade As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemAnchorGrade {
    ForgeTypeId^ get ();
}
static member SteelElemAnchorGrade : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemAnchorLength Property

ParameterTypeIdSteelElemAnchorLength Property

"Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemAnchorLength { get; }
Public Shared ReadOnly Property SteelElemAnchorLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemAnchorLength {
    ForgeTypeId^ get ();
}
static member SteelElemAnchorLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemAnchorOrientation Property

ParameterTypeIdSteelElemAnchorOrientation Property

"Anchor Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemAnchorOrientation { get; }
Public Shared ReadOnly Property SteelElemAnchorOrientation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemAnchorOrientation {
    ForgeTypeId^ get ();
}
static member SteelElemAnchorOrientation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemAnchorStandard Property

ParameterTypeIdSteelElemAnchorStandard Property

"Standard"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemAnchorStandard { get; }
Public Shared ReadOnly Property SteelElemAnchorStandard As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemAnchorStandard {
    ForgeTypeId^ get ();
}
static member SteelElemAnchorStandard : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemAnchorTotalWeight Property

ParameterTypeIdSteelElemAnchorTotalWeight Property

"Total Weight"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemAnchorTotalWeight { get; }
Public Shared ReadOnly Property SteelElemAnchorTotalWeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemAnchorTotalWeight {
    ForgeTypeId^ get ();
}
static member SteelElemAnchorTotalWeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemBoltAssembly Property

ParameterTypeIdSteelElemBoltAssembly Property

"Assembly"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemBoltAssembly { get; }
Public Shared ReadOnly Property SteelElemBoltAssembly As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemBoltAssembly {
    ForgeTypeId^ get ();
}
static member SteelElemBoltAssembly : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemBoltCoating Property

ParameterTypeIdSteelElemBoltCoating Property

"Coating"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemBoltCoating { get; }
Public Shared ReadOnly Property SteelElemBoltCoating As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemBoltCoating {
    ForgeTypeId^ get ();
}
static member SteelElemBoltCoating : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemBoltDiameter Property

ParameterTypeIdSteelElemBoltDiameter Property

"Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemBoltDiameter { get; }
Public Shared ReadOnly Property SteelElemBoltDiameter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemBoltDiameter {
    ForgeTypeId^ get ();
}
static member SteelElemBoltDiameter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemBoltFinishCalculationAtGap Property

ParameterTypeIdSteelElemBoltFinishCalculationAtGap Property

"Finish Calculation At Gap"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemBoltFinishCalculationAtGap { get; }
Public Shared ReadOnly Property SteelElemBoltFinishCalculationAtGap As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemBoltFinishCalculationAtGap {
    ForgeTypeId^ get ();
}
static member SteelElemBoltFinishCalculationAtGap : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemBoltGrade Property

ParameterTypeIdSteelElemBoltGrade Property

"Grade"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemBoltGrade { get; }
Public Shared ReadOnly Property SteelElemBoltGrade As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemBoltGrade {
    ForgeTypeId^ get ();
}
static member SteelElemBoltGrade : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemBoltGripLength Property

ParameterTypeIdSteelElemBoltGripLength Property

"Grip Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemBoltGripLength { get; }
Public Shared ReadOnly Property SteelElemBoltGripLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemBoltGripLength {
    ForgeTypeId^ get ();
}
static member SteelElemBoltGripLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemBoltGripLengthIncrease Property

ParameterTypeIdSteelElemBoltGripLengthIncrease Property

"Grip Length Increase"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemBoltGripLengthIncrease { get; }
Public Shared ReadOnly Property SteelElemBoltGripLengthIncrease As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemBoltGripLengthIncrease {
    ForgeTypeId^ get ();
}
static member SteelElemBoltGripLengthIncrease : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemBoltInverted Property

ParameterTypeIdSteelElemBoltInverted Property

"Inverted"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemBoltInverted { get; }
Public Shared ReadOnly Property SteelElemBoltInverted As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemBoltInverted {
    ForgeTypeId^ get ();
}
static member SteelElemBoltInverted : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemBoltLength Property

ParameterTypeIdSteelElemBoltLength Property

"Bolt Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemBoltLength { get; }
Public Shared ReadOnly Property SteelElemBoltLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemBoltLength {
    ForgeTypeId^ get ();
}
static member SteelElemBoltLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemBoltLocation Property

ParameterTypeIdSteelElemBoltLocation Property

"Location"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemBoltLocation { get; }
Public Shared ReadOnly Property SteelElemBoltLocation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemBoltLocation {
    ForgeTypeId^ get ();
}
static member SteelElemBoltLocation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemBoltStandard Property

ParameterTypeIdSteelElemBoltStandard Property

"Standard"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemBoltStandard { get; }
Public Shared ReadOnly Property SteelElemBoltStandard As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemBoltStandard {
    ForgeTypeId^ get ();
}
static member SteelElemBoltStandard : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemBoltTotalWeight Property

ParameterTypeIdSteelElemBoltTotalWeight Property

"Total Weight"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemBoltTotalWeight { get; }
Public Shared ReadOnly Property SteelElemBoltTotalWeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemBoltTotalWeight {
    ForgeTypeId^ get ();
}
static member SteelElemBoltTotalWeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemCoating Property

ParameterTypeIdSteelElemCoating Property

"Coating"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemCoating { get; }
Public Shared ReadOnly Property SteelElemCoating As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemCoating {
    ForgeTypeId^ get ();
}
static member SteelElemCoating : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemContourGapWidth Property

ParameterTypeIdSteelElemContourGapWidth Property

"Gap Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemContourGapWidth { get; }
Public Shared ReadOnly Property SteelElemContourGapWidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemContourGapWidth {
    ForgeTypeId^ get ();
}
static member SteelElemContourGapWidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemContourSide1dist Property

ParameterTypeIdSteelElemContourSide1dist Property

"Boundary distance 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemContourSide1dist { get; }
Public Shared ReadOnly Property SteelElemContourSide1dist As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemContourSide1dist {
    ForgeTypeId^ get ();
}
static member SteelElemContourSide1dist : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemContourSide2dist Property

ParameterTypeIdSteelElemContourSide2dist Property

"Boundary distance 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemContourSide2dist { get; }
Public Shared ReadOnly Property SteelElemContourSide2dist As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemContourSide2dist {
    ForgeTypeId^ get ();
}
static member SteelElemContourSide2dist : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemCopeAroundAxis Property

ParameterTypeIdSteelElemCopeAroundAxis Property

"Around beam axis"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemCopeAroundAxis { get; }
Public Shared ReadOnly Property SteelElemCopeAroundAxis As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemCopeAroundAxis {
    ForgeTypeId^ get ();
}
static member SteelElemCopeAroundAxis : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemCopeAxisAngle Property

ParameterTypeIdSteelElemCopeAxisAngle Property

"Tilt angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemCopeAxisAngle { get; }
Public Shared ReadOnly Property SteelElemCopeAxisAngle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemCopeAxisAngle {
    ForgeTypeId^ get ();
}
static member SteelElemCopeAxisAngle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemCopeDistanceAxis Property

ParameterTypeIdSteelElemCopeDistanceAxis Property

"Distance from axis"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemCopeDistanceAxis { get; }
Public Shared ReadOnly Property SteelElemCopeDistanceAxis As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemCopeDistanceAxis {
    ForgeTypeId^ get ();
}
static member SteelElemCopeDistanceAxis : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemCopeWidthx Property

ParameterTypeIdSteelElemCopeWidthx Property

"Cutback"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemCopeWidthx { get; }
Public Shared ReadOnly Property SteelElemCopeWidthx As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemCopeWidthx {
    ForgeTypeId^ get ();
}
static member SteelElemCopeWidthx : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemCopeXAngle Property

ParameterTypeIdSteelElemCopeXAngle Property

"Cross-section rotation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemCopeXAngle { get; }
Public Shared ReadOnly Property SteelElemCopeXAngle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemCopeXAngle {
    ForgeTypeId^ get ();
}
static member SteelElemCopeXAngle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemCopeZAngle Property

ParameterTypeIdSteelElemCopeZAngle Property

"Plan rotation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemCopeZAngle { get; }
Public Shared ReadOnly Property SteelElemCopeZAngle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemCopeZAngle {
    ForgeTypeId^ get ();
}
static member SteelElemCopeZAngle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemCutLength Property

ParameterTypeIdSteelElemCutLength Property

"Cut Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemCutLength { get; }
Public Shared ReadOnly Property SteelElemCutLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemCutLength {
    ForgeTypeId^ get ();
}
static member SteelElemCutLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemCutType Property

ParameterTypeIdSteelElemCutType Property

"Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemCutType { get; }
Public Shared ReadOnly Property SteelElemCutType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemCutType {
    ForgeTypeId^ get ();
}
static member SteelElemCutType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemExactWeight Property

ParameterTypeIdSteelElemExactWeight Property

"Exact Weight"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemExactWeight { get; }
Public Shared ReadOnly Property SteelElemExactWeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemExactWeight {
    ForgeTypeId^ get ();
}
static member SteelElemExactWeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemHoleAlpha Property

ParameterTypeIdSteelElemHoleAlpha Property

"Taper Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemHoleAlpha { get; }
Public Shared ReadOnly Property SteelElemHoleAlpha As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemHoleAlpha {
    ForgeTypeId^ get ();
}
static member SteelElemHoleAlpha : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemHoleAngle Property

ParameterTypeIdSteelElemHoleAngle Property

"Chamfer angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemHoleAngle { get; }
Public Shared ReadOnly Property SteelElemHoleAngle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemHoleAngle {
    ForgeTypeId^ get ();
}
static member SteelElemHoleAngle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemHoleBackTaperThread Property

ParameterTypeIdSteelElemHoleBackTaperThread Property

"Back taper thread"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemHoleBackTaperThread { get; }
Public Shared ReadOnly Property SteelElemHoleBackTaperThread As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemHoleBackTaperThread {
    ForgeTypeId^ get ();
}
static member SteelElemHoleBackTaperThread : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemHoleDefinition Property

ParameterTypeIdSteelElemHoleDefinition Property

"Hole Definition"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemHoleDefinition { get; }
Public Shared ReadOnly Property SteelElemHoleDefinition As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemHoleDefinition {
    ForgeTypeId^ get ();
}
static member SteelElemHoleDefinition : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemHoleDepth Property

ParameterTypeIdSteelElemHoleDepth Property

"Hole Depth"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemHoleDepth { get; }
Public Shared ReadOnly Property SteelElemHoleDepth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemHoleDepth {
    ForgeTypeId^ get ();
}
static member SteelElemHoleDepth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemHoleDepthOfBoltHead Property

ParameterTypeIdSteelElemHoleDepthOfBoltHead Property

"Depth of bolt head"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemHoleDepthOfBoltHead { get; }
Public Shared ReadOnly Property SteelElemHoleDepthOfBoltHead As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemHoleDepthOfBoltHead {
    ForgeTypeId^ get ();
}
static member SteelElemHoleDepthOfBoltHead : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemHoleDiameter Property

ParameterTypeIdSteelElemHoleDiameter Property

"Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemHoleDiameter { get; }
Public Shared ReadOnly Property SteelElemHoleDiameter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemHoleDiameter {
    ForgeTypeId^ get ();
}
static member SteelElemHoleDiameter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemHoleHeadDiameter Property

ParameterTypeIdSteelElemHoleHeadDiameter Property

"Head diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemHoleHeadDiameter { get; }
Public Shared ReadOnly Property SteelElemHoleHeadDiameter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemHoleHeadDiameter {
    ForgeTypeId^ get ();
}
static member SteelElemHoleHeadDiameter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemHoleSlotDirection Property

ParameterTypeIdSteelElemHoleSlotDirection Property

"Along side 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemHoleSlotDirection { get; }
Public Shared ReadOnly Property SteelElemHoleSlotDirection As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemHoleSlotDirection {
    ForgeTypeId^ get ();
}
static member SteelElemHoleSlotDirection : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemHoleSlotLength Property

ParameterTypeIdSteelElemHoleSlotLength Property

"Length of the slot"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemHoleSlotLength { get; }
Public Shared ReadOnly Property SteelElemHoleSlotLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemHoleSlotLength {
    ForgeTypeId^ get ();
}
static member SteelElemHoleSlotLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemHoleTapping Property

ParameterTypeIdSteelElemHoleTapping Property

"Right-handed thread"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemHoleTapping { get; }
Public Shared ReadOnly Property SteelElemHoleTapping As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemHoleTapping {
    ForgeTypeId^ get ();
}
static member SteelElemHoleTapping : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemHoleTappingHole Property

ParameterTypeIdSteelElemHoleTappingHole Property

"Tapping hole"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemHoleTappingHole { get; }
Public Shared ReadOnly Property SteelElemHoleTappingHole As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemHoleTappingHole {
    ForgeTypeId^ get ();
}
static member SteelElemHoleTappingHole : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemHoleType Property

ParameterTypeIdSteelElemHoleType Property

"Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemHoleType { get; }
Public Shared ReadOnly Property SteelElemHoleType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemHoleType {
    ForgeTypeId^ get ();
}
static member SteelElemHoleType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemMark Property

ParameterTypeIdSteelElemMark Property

"Assembly Mark"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemMark { get; }
Public Shared ReadOnly Property SteelElemMark As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemMark {
    ForgeTypeId^ get ();
}
static member SteelElemMark : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemPaintArea Property

ParameterTypeIdSteelElemPaintArea Property

"Paint Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemPaintArea { get; }
Public Shared ReadOnly Property SteelElemPaintArea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemPaintArea {
    ForgeTypeId^ get ();
}
static member SteelElemPaintArea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemParamBoringout Property

ParameterTypeIdSteelElemParamBoringout Property

"Boring out"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemParamBoringout { get; }
Public Shared ReadOnly Property SteelElemParamBoringout As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemParamBoringout {
    ForgeTypeId^ get ();
}
static member SteelElemParamBoringout : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemParamRadius Property

ParameterTypeIdSteelElemParamRadius Property

"Radius"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemParamRadius { get; }
Public Shared ReadOnly Property SteelElemParamRadius As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemParamRadius {
    ForgeTypeId^ get ();
}
static member SteelElemParamRadius : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemPatternEdgeDistanceX Property

ParameterTypeIdSteelElemPatternEdgeDistanceX Property

"Edge distance on side 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemPatternEdgeDistanceX { get; }
Public Shared ReadOnly Property SteelElemPatternEdgeDistanceX As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemPatternEdgeDistanceX {
    ForgeTypeId^ get ();
}
static member SteelElemPatternEdgeDistanceX : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemPatternEdgeDistanceY Property

ParameterTypeIdSteelElemPatternEdgeDistanceY Property

"Edge distance on side 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemPatternEdgeDistanceY { get; }
Public Shared ReadOnly Property SteelElemPatternEdgeDistanceY As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemPatternEdgeDistanceY {
    ForgeTypeId^ get ();
}
static member SteelElemPatternEdgeDistanceY : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemPatternIntermediateDistanceX Property

ParameterTypeIdSteelElemPatternIntermediateDistanceX Property

"Intermediate distance on side 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemPatternIntermediateDistanceX { get; }
Public Shared ReadOnly Property SteelElemPatternIntermediateDistanceX As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemPatternIntermediateDistanceX {
    ForgeTypeId^ get ();
}
static member SteelElemPatternIntermediateDistanceX : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemPatternIntermediateDistanceY Property

ParameterTypeIdSteelElemPatternIntermediateDistanceY Property

"Intermediate distance on side 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemPatternIntermediateDistanceY { get; }
Public Shared ReadOnly Property SteelElemPatternIntermediateDistanceY As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemPatternIntermediateDistanceY {
    ForgeTypeId^ get ();
}
static member SteelElemPatternIntermediateDistanceY : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemPatternNumber Property

ParameterTypeIdSteelElemPatternNumber Property

"Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemPatternNumber { get; }
Public Shared ReadOnly Property SteelElemPatternNumber As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemPatternNumber {
    ForgeTypeId^ get ();
}
static member SteelElemPatternNumber : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemPatternNumberX Property

ParameterTypeIdSteelElemPatternNumberX Property

"Number on side 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemPatternNumberX { get; }
Public Shared ReadOnly Property SteelElemPatternNumberX As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemPatternNumberX {
    ForgeTypeId^ get ();
}
static member SteelElemPatternNumberX : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemPatternNumberY Property

ParameterTypeIdSteelElemPatternNumberY Property

"Number on side 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemPatternNumberY { get; }
Public Shared ReadOnly Property SteelElemPatternNumberY As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemPatternNumberY {
    ForgeTypeId^ get ();
}
static member SteelElemPatternNumberY : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemPatternRadius Property

ParameterTypeIdSteelElemPatternRadius Property

"Radius"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemPatternRadius { get; }
Public Shared ReadOnly Property SteelElemPatternRadius As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemPatternRadius {
    ForgeTypeId^ get ();
}
static member SteelElemPatternRadius : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemPatternTotalLength Property

ParameterTypeIdSteelElemPatternTotalLength Property

"Length on side 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemPatternTotalLength { get; }
Public Shared ReadOnly Property SteelElemPatternTotalLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemPatternTotalLength {
    ForgeTypeId^ get ();
}
static member SteelElemPatternTotalLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemPatternTotalWidth Property

ParameterTypeIdSteelElemPatternTotalWidth Property

"Length on side 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemPatternTotalWidth { get; }
Public Shared ReadOnly Property SteelElemPatternTotalWidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemPatternTotalWidth {
    ForgeTypeId^ get ();
}
static member SteelElemPatternTotalWidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemPlateArea Property

ParameterTypeIdSteelElemPlateArea Property

"Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemPlateArea { get; }
Public Shared ReadOnly Property SteelElemPlateArea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemPlateArea {
    ForgeTypeId^ get ();
}
static member SteelElemPlateArea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemPlateExactWeight Property

ParameterTypeIdSteelElemPlateExactWeight Property

"Exact Weight"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemPlateExactWeight { get; }
Public Shared ReadOnly Property SteelElemPlateExactWeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemPlateExactWeight {
    ForgeTypeId^ get ();
}
static member SteelElemPlateExactWeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemPlateJustification Property

ParameterTypeIdSteelElemPlateJustification Property

"Justification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemPlateJustification { get; }
Public Shared ReadOnly Property SteelElemPlateJustification As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemPlateJustification {
    ForgeTypeId^ get ();
}
static member SteelElemPlateJustification : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemPlateLength Property

ParameterTypeIdSteelElemPlateLength Property

"Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemPlateLength { get; }
Public Shared ReadOnly Property SteelElemPlateLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemPlateLength {
    ForgeTypeId^ get ();
}
static member SteelElemPlateLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemPlatePaintArea Property

ParameterTypeIdSteelElemPlatePaintArea Property

"Paint Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemPlatePaintArea { get; }
Public Shared ReadOnly Property SteelElemPlatePaintArea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemPlatePaintArea {
    ForgeTypeId^ get ();
}
static member SteelElemPlatePaintArea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemPlateShortenAngle Property

ParameterTypeIdSteelElemPlateShortenAngle Property

"Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemPlateShortenAngle { get; }
Public Shared ReadOnly Property SteelElemPlateShortenAngle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemPlateShortenAngle {
    ForgeTypeId^ get ();
}
static member SteelElemPlateShortenAngle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemPlateShortenCutstraight Property

ParameterTypeIdSteelElemPlateShortenCutstraight Property

"Cut straight"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemPlateShortenCutstraight { get; }
Public Shared ReadOnly Property SteelElemPlateShortenCutstraight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemPlateShortenCutstraight {
    ForgeTypeId^ get ();
}
static member SteelElemPlateShortenCutstraight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemPlateShortenSuction Property

ParameterTypeIdSteelElemPlateShortenSuction Property

"Suction"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemPlateShortenSuction { get; }
Public Shared ReadOnly Property SteelElemPlateShortenSuction As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemPlateShortenSuction {
    ForgeTypeId^ get ();
}
static member SteelElemPlateShortenSuction : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemPlateThickness Property

ParameterTypeIdSteelElemPlateThickness Property

"Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemPlateThickness { get; }
Public Shared ReadOnly Property SteelElemPlateThickness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemPlateThickness {
    ForgeTypeId^ get ();
}
static member SteelElemPlateThickness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemPlateType Property

ParameterTypeIdSteelElemPlateType Property

"Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemPlateType { get; }
Public Shared ReadOnly Property SteelElemPlateType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemPlateType {
    ForgeTypeId^ get ();
}
static member SteelElemPlateType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemPlateVolume Property

ParameterTypeIdSteelElemPlateVolume Property

"Volume"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemPlateVolume { get; }
Public Shared ReadOnly Property SteelElemPlateVolume As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemPlateVolume {
    ForgeTypeId^ get ();
}
static member SteelElemPlateVolume : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemPlateWeight Property

ParameterTypeIdSteelElemPlateWeight Property

"Weight"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemPlateWeight { get; }
Public Shared ReadOnly Property SteelElemPlateWeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemPlateWeight {
    ForgeTypeId^ get ();
}
static member SteelElemPlateWeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemPlateWidth Property

ParameterTypeIdSteelElemPlateWidth Property

"Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemPlateWidth { get; }
Public Shared ReadOnly Property SteelElemPlateWidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemPlateWidth {
    ForgeTypeId^ get ();
}
static member SteelElemPlateWidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemProfileLength Property

ParameterTypeIdSteelElemProfileLength Property

"Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemProfileLength { get; }
Public Shared ReadOnly Property SteelElemProfileLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemProfileLength {
    ForgeTypeId^ get ();
}
static member SteelElemProfileLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemProfileType Property

ParameterTypeIdSteelElemProfileType Property

"Profile Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemProfileType { get; }
Public Shared ReadOnly Property SteelElemProfileType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemProfileType {
    ForgeTypeId^ get ();
}
static member SteelElemProfileType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemProfileVolume Property

ParameterTypeIdSteelElemProfileVolume Property

"Volume"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemProfileVolume { get; }
Public Shared ReadOnly Property SteelElemProfileVolume As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemProfileVolume {
    ForgeTypeId^ get ();
}
static member SteelElemProfileVolume : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemShearstudDiameter Property

ParameterTypeIdSteelElemShearstudDiameter Property

"Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemShearstudDiameter { get; }
Public Shared ReadOnly Property SteelElemShearstudDiameter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemShearstudDiameter {
    ForgeTypeId^ get ();
}
static member SteelElemShearstudDiameter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemShearstudGrade Property

ParameterTypeIdSteelElemShearstudGrade Property

"Grade"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemShearstudGrade { get; }
Public Shared ReadOnly Property SteelElemShearstudGrade As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemShearstudGrade {
    ForgeTypeId^ get ();
}
static member SteelElemShearstudGrade : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemShearstudLength Property

ParameterTypeIdSteelElemShearstudLength Property

"Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemShearstudLength { get; }
Public Shared ReadOnly Property SteelElemShearstudLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemShearstudLength {
    ForgeTypeId^ get ();
}
static member SteelElemShearstudLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemShearstudStandard Property

ParameterTypeIdSteelElemShearstudStandard Property

"Standard"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemShearstudStandard { get; }
Public Shared ReadOnly Property SteelElemShearstudStandard As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemShearstudStandard {
    ForgeTypeId^ get ();
}
static member SteelElemShearstudStandard : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemShearstudTotalWeight Property

ParameterTypeIdSteelElemShearstudTotalWeight Property

"Total Weight"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemShearstudTotalWeight { get; }
Public Shared ReadOnly Property SteelElemShearstudTotalWeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemShearstudTotalWeight {
    ForgeTypeId^ get ();
}
static member SteelElemShearstudTotalWeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemShortenAngley Property

ParameterTypeIdSteelElemShortenAngley Property

"Angle along height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemShortenAngley { get; }
Public Shared ReadOnly Property SteelElemShortenAngley As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemShortenAngley {
    ForgeTypeId^ get ();
}
static member SteelElemShortenAngley : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemShortenAnglez Property

ParameterTypeIdSteelElemShortenAnglez Property

"Angle along width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemShortenAnglez { get; }
Public Shared ReadOnly Property SteelElemShortenAnglez As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemShortenAnglez {
    ForgeTypeId^ get ();
}
static member SteelElemShortenAnglez : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemShortenReflength Property

ParameterTypeIdSteelElemShortenReflength Property

"Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemShortenReflength { get; }
Public Shared ReadOnly Property SteelElemShortenReflength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemShortenReflength {
    ForgeTypeId^ get ();
}
static member SteelElemShortenReflength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemSinglePartMark Property

ParameterTypeIdSteelElemSinglePartMark Property

"Single Part Mark"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemSinglePartMark { get; }
Public Shared ReadOnly Property SteelElemSinglePartMark As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemSinglePartMark {
    ForgeTypeId^ get ();
}
static member SteelElemSinglePartMark : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemWeight Property

ParameterTypeIdSteelElemWeight Property

"Weight"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemWeight { get; }
Public Shared ReadOnly Property SteelElemWeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemWeight {
    ForgeTypeId^ get ();
}
static member SteelElemWeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemWeldContinuous Property

ParameterTypeIdSteelElemWeldContinuous Property

"Continuous"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemWeldContinuous { get; }
Public Shared ReadOnly Property SteelElemWeldContinuous As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemWeldContinuous {
    ForgeTypeId^ get ();
}
static member SteelElemWeldContinuous : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemWeldDoubleEffectivethroat Property

ParameterTypeIdSteelElemWeldDoubleEffectivethroat Property

"Double Effective Throat"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemWeldDoubleEffectivethroat { get; }
Public Shared ReadOnly Property SteelElemWeldDoubleEffectivethroat As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemWeldDoubleEffectivethroat {
    ForgeTypeId^ get ();
}
static member SteelElemWeldDoubleEffectivethroat : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemWeldDoublePrepdepth Property

ParameterTypeIdSteelElemWeldDoublePrepdepth Property

"Double Preparation Depth"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemWeldDoublePrepdepth { get; }
Public Shared ReadOnly Property SteelElemWeldDoublePrepdepth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemWeldDoublePrepdepth {
    ForgeTypeId^ get ();
}
static member SteelElemWeldDoublePrepdepth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemWeldDoubleRootopening Property

ParameterTypeIdSteelElemWeldDoubleRootopening Property

"Double Root Opening"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemWeldDoubleRootopening { get; }
Public Shared ReadOnly Property SteelElemWeldDoubleRootopening As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemWeldDoubleRootopening {
    ForgeTypeId^ get ();
}
static member SteelElemWeldDoubleRootopening : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemWeldDoubleSurfaceshape Property

ParameterTypeIdSteelElemWeldDoubleSurfaceshape Property

"Double Surface Shape"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemWeldDoubleSurfaceshape { get; }
Public Shared ReadOnly Property SteelElemWeldDoubleSurfaceshape As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemWeldDoubleSurfaceshape {
    ForgeTypeId^ get ();
}
static member SteelElemWeldDoubleSurfaceshape : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemWeldDoubleText Property

ParameterTypeIdSteelElemWeldDoubleText Property

"Double Text"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemWeldDoubleText { get; }
Public Shared ReadOnly Property SteelElemWeldDoubleText As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemWeldDoubleText {
    ForgeTypeId^ get ();
}
static member SteelElemWeldDoubleText : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemWeldDoubleThickness Property

ParameterTypeIdSteelElemWeldDoubleThickness Property

"Double Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemWeldDoubleThickness { get; }
Public Shared ReadOnly Property SteelElemWeldDoubleThickness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemWeldDoubleThickness {
    ForgeTypeId^ get ();
}
static member SteelElemWeldDoubleThickness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemWeldDoubleType Property

ParameterTypeIdSteelElemWeldDoubleType Property

"Double Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemWeldDoubleType { get; }
Public Shared ReadOnly Property SteelElemWeldDoubleType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemWeldDoubleType {
    ForgeTypeId^ get ();
}
static member SteelElemWeldDoubleType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemWeldDoubleWeldprep Property

ParameterTypeIdSteelElemWeldDoubleWeldprep Property

"Double Weld preparation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemWeldDoubleWeldprep { get; }
Public Shared ReadOnly Property SteelElemWeldDoubleWeldprep As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemWeldDoubleWeldprep {
    ForgeTypeId^ get ();
}
static member SteelElemWeldDoubleWeldprep : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemWeldLength Property

ParameterTypeIdSteelElemWeldLength Property

"Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemWeldLength { get; }
Public Shared ReadOnly Property SteelElemWeldLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemWeldLength {
    ForgeTypeId^ get ();
}
static member SteelElemWeldLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemWeldLocation Property

ParameterTypeIdSteelElemWeldLocation Property

"Location"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemWeldLocation { get; }
Public Shared ReadOnly Property SteelElemWeldLocation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemWeldLocation {
    ForgeTypeId^ get ();
}
static member SteelElemWeldLocation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemWeldMainEffectivethroat Property

ParameterTypeIdSteelElemWeldMainEffectivethroat Property

"Main Effective Throat"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemWeldMainEffectivethroat { get; }
Public Shared ReadOnly Property SteelElemWeldMainEffectivethroat As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemWeldMainEffectivethroat {
    ForgeTypeId^ get ();
}
static member SteelElemWeldMainEffectivethroat : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemWeldMainPrepdepth Property

ParameterTypeIdSteelElemWeldMainPrepdepth Property

"Main Preparation Depth"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemWeldMainPrepdepth { get; }
Public Shared ReadOnly Property SteelElemWeldMainPrepdepth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemWeldMainPrepdepth {
    ForgeTypeId^ get ();
}
static member SteelElemWeldMainPrepdepth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemWeldMainRootopening Property

ParameterTypeIdSteelElemWeldMainRootopening Property

"Main Root Opening"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemWeldMainRootopening { get; }
Public Shared ReadOnly Property SteelElemWeldMainRootopening As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemWeldMainRootopening {
    ForgeTypeId^ get ();
}
static member SteelElemWeldMainRootopening : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemWeldMainSurfaceshape Property

ParameterTypeIdSteelElemWeldMainSurfaceshape Property

"Surface Shape"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemWeldMainSurfaceshape { get; }
Public Shared ReadOnly Property SteelElemWeldMainSurfaceshape As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemWeldMainSurfaceshape {
    ForgeTypeId^ get ();
}
static member SteelElemWeldMainSurfaceshape : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemWeldMainText Property

ParameterTypeIdSteelElemWeldMainText Property

"Main Text"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemWeldMainText { get; }
Public Shared ReadOnly Property SteelElemWeldMainText As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemWeldMainText {
    ForgeTypeId^ get ();
}
static member SteelElemWeldMainText : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemWeldMainThickness Property

ParameterTypeIdSteelElemWeldMainThickness Property

"Main Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemWeldMainThickness { get; }
Public Shared ReadOnly Property SteelElemWeldMainThickness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemWeldMainThickness {
    ForgeTypeId^ get ();
}
static member SteelElemWeldMainThickness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemWeldMainType Property

ParameterTypeIdSteelElemWeldMainType Property

"Main Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemWeldMainType { get; }
Public Shared ReadOnly Property SteelElemWeldMainType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemWeldMainType {
    ForgeTypeId^ get ();
}
static member SteelElemWeldMainType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemWeldMainWeldprep Property

ParameterTypeIdSteelElemWeldMainWeldprep Property

"Main Weld preparation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemWeldMainWeldprep { get; }
Public Shared ReadOnly Property SteelElemWeldMainWeldprep As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemWeldMainWeldprep {
    ForgeTypeId^ get ();
}
static member SteelElemWeldMainWeldprep : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemWeldPitch Property

ParameterTypeIdSteelElemWeldPitch Property

"Pitch"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemWeldPitch { get; }
Public Shared ReadOnly Property SteelElemWeldPitch As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemWeldPitch {
    ForgeTypeId^ get ();
}
static member SteelElemWeldPitch : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemWeldPrefix Property

ParameterTypeIdSteelElemWeldPrefix Property

"Prefix"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemWeldPrefix { get; }
Public Shared ReadOnly Property SteelElemWeldPrefix As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemWeldPrefix {
    ForgeTypeId^ get ();
}
static member SteelElemWeldPrefix : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemWeldTextModule Property

ParameterTypeIdSteelElemWeldTextModule Property

"Text module"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemWeldTextModule { get; }
Public Shared ReadOnly Property SteelElemWeldTextModule As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemWeldTextModule {
    ForgeTypeId^ get ();
}
static member SteelElemWeldTextModule : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemXDistance Property

ParameterTypeIdSteelElemXDistance Property

"Side 1"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemXDistance { get; }
Public Shared ReadOnly Property SteelElemXDistance As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemXDistance {
    ForgeTypeId^ get ();
}
static member SteelElemXDistance : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemYDistance Property

ParameterTypeIdSteelElemYDistance Property

"Side 2"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemYDistance { get; }
Public Shared ReadOnly Property SteelElemYDistance As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemYDistance {
    ForgeTypeId^ get ();
}
static member SteelElemYDistance : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SteelElemZclipType Property

ParameterTypeIdSteelElemZclipType Property

"Boundary"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SteelElemZclipType { get; }
Public Shared ReadOnly Property SteelElemZclipType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SteelElemZclipType {
    ForgeTypeId^ get ();
}
static member SteelElemZclipType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StiffenerClassification Property

ParameterTypeIdStiffenerClassification Property

"Classification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StiffenerClassification { get; }
Public Shared ReadOnly Property StiffenerClassification As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StiffenerClassification {
    ForgeTypeId^ get ();
}
static member StiffenerClassification : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructConnectionApplyTo Property

ParameterTypeIdStructConnectionApplyTo Property

"Apply to"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructConnectionApplyTo { get; }
Public Shared ReadOnly Property StructConnectionApplyTo As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructConnectionApplyTo {
    ForgeTypeId^ get ();
}
static member StructConnectionApplyTo : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructConnectionBeamEnd Property

ParameterTypeIdStructConnectionBeamEnd Property

"End Connection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructConnectionBeamEnd { get; }
Public Shared ReadOnly Property StructConnectionBeamEnd As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructConnectionBeamEnd {
    ForgeTypeId^ get ();
}
static member StructConnectionBeamEnd : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructConnectionBeamStart Property

ParameterTypeIdStructConnectionBeamStart Property

"Start Connection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructConnectionBeamStart { get; }
Public Shared ReadOnly Property StructConnectionBeamStart As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructConnectionBeamStart {
    ForgeTypeId^ get ();
}
static member StructConnectionBeamStart : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructConnectionColumnBase Property

ParameterTypeIdStructConnectionColumnBase Property

"Base Connection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructConnectionColumnBase { get; }
Public Shared ReadOnly Property StructConnectionColumnBase As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructConnectionColumnBase {
    ForgeTypeId^ get ();
}
static member StructConnectionColumnBase : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructConnectionColumnTop Property

ParameterTypeIdStructConnectionColumnTop Property

"Top Connection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructConnectionColumnTop { get; }
Public Shared ReadOnly Property StructConnectionColumnTop As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructConnectionColumnTop {
    ForgeTypeId^ get ();
}
static member StructConnectionColumnTop : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructConnectionCutback Property

ParameterTypeIdStructConnectionCutback Property

"Automatic Cutback for Beams and Braces"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructConnectionCutback { get; }
Public Shared ReadOnly Property StructConnectionCutback As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructConnectionCutback {
    ForgeTypeId^ get ();
}
static member StructConnectionCutback : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructConnectionTypeName Property

ParameterTypeIdStructConnectionTypeName Property

"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructConnectionTypeName { get; }
Public Shared ReadOnly Property StructConnectionTypeName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructConnectionTypeName {
    ForgeTypeId^ get ();
}
static member StructConnectionTypeName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructFramJoinStatus Property

ParameterTypeIdStructFramJoinStatus Property

"Join Status"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructFramJoinStatus { get; }
Public Shared ReadOnly Property StructFramJoinStatus As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructFramJoinStatus {
    ForgeTypeId^ get ();
}
static member StructFramJoinStatus : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralAnalyticalBeamHorizontalProjectionPlane Property

ParameterTypeIdStructuralAnalyticalBeamHorizontalProjectionPlane Property

"Horizontal Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralAnalyticalBeamHorizontalProjectionPlane { get; }
Public Shared ReadOnly Property StructuralAnalyticalBeamHorizontalProjectionPlane As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralAnalyticalBeamHorizontalProjectionPlane {
    ForgeTypeId^ get ();
}
static member StructuralAnalyticalBeamHorizontalProjectionPlane : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralAnalyticalBeamRigidLink Property

ParameterTypeIdStructuralAnalyticalBeamRigidLink Property

"Analytical Links"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralAnalyticalBeamRigidLink { get; }
Public Shared ReadOnly Property StructuralAnalyticalBeamRigidLink As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralAnalyticalBeamRigidLink {
    ForgeTypeId^ get ();
}
static member StructuralAnalyticalBeamRigidLink : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralAnalyticalColumnHorizontalProjectionPlane Property

ParameterTypeIdStructuralAnalyticalColumnHorizontalProjectionPlane Property

"Horizontal Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralAnalyticalColumnHorizontalProjectionPlane { get; }
Public Shared ReadOnly Property StructuralAnalyticalColumnHorizontalProjectionPlane As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralAnalyticalColumnHorizontalProjectionPlane {
    ForgeTypeId^ get ();
}
static member StructuralAnalyticalColumnHorizontalProjectionPlane : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralAnalyticalColumnRigidLink Property

ParameterTypeIdStructuralAnalyticalColumnRigidLink Property

"Analytical Links"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralAnalyticalColumnRigidLink { get; }
Public Shared ReadOnly Property StructuralAnalyticalColumnRigidLink As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralAnalyticalColumnRigidLink {
    ForgeTypeId^ get ();
}
static member StructuralAnalyticalColumnRigidLink : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralAnalyticalHardPoints Property

ParameterTypeIdStructuralAnalyticalHardPoints Property

"Use hard-points"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralAnalyticalHardPoints { get; }
Public Shared ReadOnly Property StructuralAnalyticalHardPoints As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralAnalyticalHardPoints {
    ForgeTypeId^ get ();
}
static member StructuralAnalyticalHardPoints : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralAnalyticalModel Property

ParameterTypeIdStructuralAnalyticalModel Property

"Enable Analytical Model"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralAnalyticalModel { get; }
Public Shared ReadOnly Property StructuralAnalyticalModel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralAnalyticalModel {
    ForgeTypeId^ get ();
}
static member StructuralAnalyticalModel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralAnalyticalProjectFloorPlane Property

ParameterTypeIdStructuralAnalyticalProjectFloorPlane Property

"Vertical Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralAnalyticalProjectFloorPlane { get; }
Public Shared ReadOnly Property StructuralAnalyticalProjectFloorPlane As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralAnalyticalProjectFloorPlane {
    ForgeTypeId^ get ();
}
static member StructuralAnalyticalProjectFloorPlane : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralAnalyticalProjectMemberPlane Property

ParameterTypeIdStructuralAnalyticalProjectMemberPlane Property

"Vertical Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralAnalyticalProjectMemberPlane { get; }
Public Shared ReadOnly Property StructuralAnalyticalProjectMemberPlane As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralAnalyticalProjectMemberPlane {
    ForgeTypeId^ get ();
}
static member StructuralAnalyticalProjectMemberPlane : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralAnalyticalProjectMemberPlaneColumnBottom Property

ParameterTypeIdStructuralAnalyticalProjectMemberPlaneColumnBottom Property

"Bottom Vertical Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralAnalyticalProjectMemberPlaneColumnBottom { get; }
Public Shared ReadOnly Property StructuralAnalyticalProjectMemberPlaneColumnBottom As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralAnalyticalProjectMemberPlaneColumnBottom {
    ForgeTypeId^ get ();
}
static member StructuralAnalyticalProjectMemberPlaneColumnBottom : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralAnalyticalProjectMemberPlaneColumnTop Property

ParameterTypeIdStructuralAnalyticalProjectMemberPlaneColumnTop Property

"Top Vertical Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralAnalyticalProjectMemberPlaneColumnTop { get; }
Public Shared ReadOnly Property StructuralAnalyticalProjectMemberPlaneColumnTop As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralAnalyticalProjectMemberPlaneColumnTop {
    ForgeTypeId^ get ();
}
static member StructuralAnalyticalProjectMemberPlaneColumnTop : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralAnalyticalTessDeviation Property

ParameterTypeIdStructuralAnalyticalTessDeviation Property

"Maximum discretized offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralAnalyticalTessDeviation { get; }
Public Shared ReadOnly Property StructuralAnalyticalTessDeviation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralAnalyticalTessDeviation {
    ForgeTypeId^ get ();
}
static member StructuralAnalyticalTessDeviation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralAnalyticalTessellate Property

ParameterTypeIdStructuralAnalyticalTessellate Property

"Approximate curve"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralAnalyticalTessellate { get; }
Public Shared ReadOnly Property StructuralAnalyticalTessellate As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralAnalyticalTessellate {
    ForgeTypeId^ get ();
}
static member StructuralAnalyticalTessellate : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralAnalyzesAs Property

ParameterTypeIdStructuralAnalyzesAs Property

"Analyze As"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralAnalyzesAs { get; }
Public Shared ReadOnly Property StructuralAnalyzesAs As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralAnalyzesAs {
    ForgeTypeId^ get ();
}
static member StructuralAnalyzesAs : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralAssetParam Property

ParameterTypeIdStructuralAssetParam Property

"Physical Material Asset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralAssetParam { get; }
Public Shared ReadOnly Property StructuralAssetParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralAssetParam {
    ForgeTypeId^ get ();
}
static member StructuralAssetParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralAttachmentBaseDistance Property

ParameterTypeIdStructuralAttachmentBaseDistance Property

"Base Attachment Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralAttachmentBaseDistance { get; }
Public Shared ReadOnly Property StructuralAttachmentBaseDistance As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralAttachmentBaseDistance {
    ForgeTypeId^ get ();
}
static member StructuralAttachmentBaseDistance : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralAttachmentBaseRatio Property

ParameterTypeIdStructuralAttachmentBaseRatio Property

"Base Attachment Ratio"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralAttachmentBaseRatio { get; }
Public Shared ReadOnly Property StructuralAttachmentBaseRatio As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralAttachmentBaseRatio {
    ForgeTypeId^ get ();
}
static member StructuralAttachmentBaseRatio : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralAttachmentBaseReferencedend Property

ParameterTypeIdStructuralAttachmentBaseReferencedend Property

"Base Attachment Referenced End"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralAttachmentBaseReferencedend { get; }
Public Shared ReadOnly Property StructuralAttachmentBaseReferencedend As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralAttachmentBaseReferencedend {
    ForgeTypeId^ get ();
}
static member StructuralAttachmentBaseReferencedend : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralAttachmentBaseType Property

ParameterTypeIdStructuralAttachmentBaseType Property

"Base Attachment Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralAttachmentBaseType { get; }
Public Shared ReadOnly Property StructuralAttachmentBaseType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralAttachmentBaseType {
    ForgeTypeId^ get ();
}
static member StructuralAttachmentBaseType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralAttachmentEndLevelReference Property

ParameterTypeIdStructuralAttachmentEndLevelReference Property

"End Attachment Level Reference"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralAttachmentEndLevelReference { get; }
Public Shared ReadOnly Property StructuralAttachmentEndLevelReference As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralAttachmentEndLevelReference {
    ForgeTypeId^ get ();
}
static member StructuralAttachmentEndLevelReference : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralAttachmentEndRefelementEnd Property

ParameterTypeIdStructuralAttachmentEndRefelementEnd Property

"End of Attachment to Reference Element"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralAttachmentEndRefelementEnd { get; }
Public Shared ReadOnly Property StructuralAttachmentEndRefelementEnd As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralAttachmentEndRefelementEnd {
    ForgeTypeId^ get ();
}
static member StructuralAttachmentEndRefelementEnd : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralAttachmentEndType Property

ParameterTypeIdStructuralAttachmentEndType Property

"End Attachment Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralAttachmentEndType { get; }
Public Shared ReadOnly Property StructuralAttachmentEndType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralAttachmentEndType {
    ForgeTypeId^ get ();
}
static member StructuralAttachmentEndType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralAttachmentEndValueDistance Property

ParameterTypeIdStructuralAttachmentEndValueDistance Property

"End Attachment Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralAttachmentEndValueDistance { get; }
Public Shared ReadOnly Property StructuralAttachmentEndValueDistance As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralAttachmentEndValueDistance {
    ForgeTypeId^ get ();
}
static member StructuralAttachmentEndValueDistance : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralAttachmentEndValueElevation Property

ParameterTypeIdStructuralAttachmentEndValueElevation Property

"End Attachment Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralAttachmentEndValueElevation { get; }
Public Shared ReadOnly Property StructuralAttachmentEndValueElevation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralAttachmentEndValueElevation {
    ForgeTypeId^ get ();
}
static member StructuralAttachmentEndValueElevation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralAttachmentEndValueRatio Property

ParameterTypeIdStructuralAttachmentEndValueRatio Property

"End attachment ratio"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralAttachmentEndValueRatio { get; }
Public Shared ReadOnly Property StructuralAttachmentEndValueRatio As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralAttachmentEndValueRatio {
    ForgeTypeId^ get ();
}
static member StructuralAttachmentEndValueRatio : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralAttachmentStartLevelReference Property

ParameterTypeIdStructuralAttachmentStartLevelReference Property

"Start Attachment Level Reference"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralAttachmentStartLevelReference { get; }
Public Shared ReadOnly Property StructuralAttachmentStartLevelReference As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralAttachmentStartLevelReference {
    ForgeTypeId^ get ();
}
static member StructuralAttachmentStartLevelReference : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralAttachmentStartRefelementEnd Property

ParameterTypeIdStructuralAttachmentStartRefelementEnd Property

"Start of Attachment to Reference Element"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralAttachmentStartRefelementEnd { get; }
Public Shared ReadOnly Property StructuralAttachmentStartRefelementEnd As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralAttachmentStartRefelementEnd {
    ForgeTypeId^ get ();
}
static member StructuralAttachmentStartRefelementEnd : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralAttachmentStartType Property

ParameterTypeIdStructuralAttachmentStartType Property

"Start Attachment Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralAttachmentStartType { get; }
Public Shared ReadOnly Property StructuralAttachmentStartType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralAttachmentStartType {
    ForgeTypeId^ get ();
}
static member StructuralAttachmentStartType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralAttachmentStartValueDistance Property

ParameterTypeIdStructuralAttachmentStartValueDistance Property

"Start Attachment Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralAttachmentStartValueDistance { get; }
Public Shared ReadOnly Property StructuralAttachmentStartValueDistance As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralAttachmentStartValueDistance {
    ForgeTypeId^ get ();
}
static member StructuralAttachmentStartValueDistance : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralAttachmentStartValueElevation Property

ParameterTypeIdStructuralAttachmentStartValueElevation Property

"Start Attachment Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralAttachmentStartValueElevation { get; }
Public Shared ReadOnly Property StructuralAttachmentStartValueElevation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralAttachmentStartValueElevation {
    ForgeTypeId^ get ();
}
static member StructuralAttachmentStartValueElevation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralAttachmentStartValueRatio Property

ParameterTypeIdStructuralAttachmentStartValueRatio Property

"Start Attachment Ratio"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralAttachmentStartValueRatio { get; }
Public Shared ReadOnly Property StructuralAttachmentStartValueRatio As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralAttachmentStartValueRatio {
    ForgeTypeId^ get ();
}
static member StructuralAttachmentStartValueRatio : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralAttachmentTopDistance Property

ParameterTypeIdStructuralAttachmentTopDistance Property

"Top Attachment Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralAttachmentTopDistance { get; }
Public Shared ReadOnly Property StructuralAttachmentTopDistance As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralAttachmentTopDistance {
    ForgeTypeId^ get ();
}
static member StructuralAttachmentTopDistance : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralAttachmentTopRatio Property

ParameterTypeIdStructuralAttachmentTopRatio Property

"Top Attachment Ratio"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralAttachmentTopRatio { get; }
Public Shared ReadOnly Property StructuralAttachmentTopRatio As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralAttachmentTopRatio {
    ForgeTypeId^ get ();
}
static member StructuralAttachmentTopRatio : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralAttachmentTopReferencedend Property

ParameterTypeIdStructuralAttachmentTopReferencedend Property

"Top Attachment Referenced End"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralAttachmentTopReferencedend { get; }
Public Shared ReadOnly Property StructuralAttachmentTopReferencedend As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralAttachmentTopReferencedend {
    ForgeTypeId^ get ();
}
static member StructuralAttachmentTopReferencedend : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralAttachmentTopType Property

ParameterTypeIdStructuralAttachmentTopType Property

"Top Attachment Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralAttachmentTopType { get; }
Public Shared ReadOnly Property StructuralAttachmentTopType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralAttachmentTopType {
    ForgeTypeId^ get ();
}
static member StructuralAttachmentTopType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralBeamCutbackForColumn Property

ParameterTypeIdStructuralBeamCutbackForColumn Property

"Beam cutback in plan"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralBeamCutbackForColumn { get; }
Public Shared ReadOnly Property StructuralBeamCutbackForColumn As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralBeamCutbackForColumn {
    ForgeTypeId^ get ();
}
static member StructuralBeamCutbackForColumn : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralBeamEnd0Elevation Property

ParameterTypeIdStructuralBeamEnd0Elevation Property

"Start Level Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralBeamEnd0Elevation { get; }
Public Shared ReadOnly Property StructuralBeamEnd0Elevation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralBeamEnd0Elevation {
    ForgeTypeId^ get ();
}
static member StructuralBeamEnd0Elevation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralBeamEnd1Elevation Property

ParameterTypeIdStructuralBeamEnd1Elevation Property

"End Level Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralBeamEnd1Elevation { get; }
Public Shared ReadOnly Property StructuralBeamEnd1Elevation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralBeamEnd1Elevation {
    ForgeTypeId^ get ();
}
static member StructuralBeamEnd1Elevation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralBeamEndAttachmentDistance Property

ParameterTypeIdStructuralBeamEndAttachmentDistance Property

"End Attachment Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralBeamEndAttachmentDistance { get; }
Public Shared ReadOnly Property StructuralBeamEndAttachmentDistance As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralBeamEndAttachmentDistance {
    ForgeTypeId^ get ();
}
static member StructuralBeamEndAttachmentDistance : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralBeamEndAttachmentRefcolumnEnd Property

ParameterTypeIdStructuralBeamEndAttachmentRefcolumnEnd Property

"End of Attachment to Reference Column"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralBeamEndAttachmentRefcolumnEnd { get; }
Public Shared ReadOnly Property StructuralBeamEndAttachmentRefcolumnEnd As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralBeamEndAttachmentRefcolumnEnd {
    ForgeTypeId^ get ();
}
static member StructuralBeamEndAttachmentRefcolumnEnd : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralBeamEndAttachmentType Property

ParameterTypeIdStructuralBeamEndAttachmentType Property

"End Attachment Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralBeamEndAttachmentType { get; }
Public Shared ReadOnly Property StructuralBeamEndAttachmentType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralBeamEndAttachmentType {
    ForgeTypeId^ get ();
}
static member StructuralBeamEndAttachmentType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralBeamEndSupport Property

ParameterTypeIdStructuralBeamEndSupport Property

"Beam End Pocket Seat"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralBeamEndSupport { get; }
Public Shared ReadOnly Property StructuralBeamEndSupport As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralBeamEndSupport {
    ForgeTypeId^ get ();
}
static member StructuralBeamEndSupport : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralBeamOrientation Property

ParameterTypeIdStructuralBeamOrientation Property

"Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralBeamOrientation { get; }
Public Shared ReadOnly Property StructuralBeamOrientation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralBeamOrientation {
    ForgeTypeId^ get ();
}
static member StructuralBeamOrientation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralBeamStartAttachmentDistance Property

ParameterTypeIdStructuralBeamStartAttachmentDistance Property

"Start Attachment Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralBeamStartAttachmentDistance { get; }
Public Shared ReadOnly Property StructuralBeamStartAttachmentDistance As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralBeamStartAttachmentDistance {
    ForgeTypeId^ get ();
}
static member StructuralBeamStartAttachmentDistance : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralBeamStartAttachmentRefcolumnEnd Property

ParameterTypeIdStructuralBeamStartAttachmentRefcolumnEnd Property

"Start of Attachment to Reference Column"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralBeamStartAttachmentRefcolumnEnd { get; }
Public Shared ReadOnly Property StructuralBeamStartAttachmentRefcolumnEnd As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralBeamStartAttachmentRefcolumnEnd {
    ForgeTypeId^ get ();
}
static member StructuralBeamStartAttachmentRefcolumnEnd : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralBeamStartAttachmentType Property

ParameterTypeIdStructuralBeamStartAttachmentType Property

"Start Attachment Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralBeamStartAttachmentType { get; }
Public Shared ReadOnly Property StructuralBeamStartAttachmentType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralBeamStartAttachmentType {
    ForgeTypeId^ get ();
}
static member StructuralBeamStartAttachmentType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralBeamStartSupport Property

ParameterTypeIdStructuralBeamStartSupport Property

"Beam Start Pocket Seat"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralBeamStartSupport { get; }
Public Shared ReadOnly Property StructuralBeamStartSupport As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralBeamStartSupport {
    ForgeTypeId^ get ();
}
static member StructuralBeamStartSupport : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralBendDirAngle Property

ParameterTypeIdStructuralBendDirAngle Property

"Cross-Section Rotation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralBendDirAngle { get; }
Public Shared ReadOnly Property StructuralBendDirAngle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralBendDirAngle {
    ForgeTypeId^ get ();
}
static member StructuralBendDirAngle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralBottomReleaseFx Property

ParameterTypeIdStructuralBottomReleaseFx Property

"Base Fx"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralBottomReleaseFx { get; }
Public Shared ReadOnly Property StructuralBottomReleaseFx As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralBottomReleaseFx {
    ForgeTypeId^ get ();
}
static member StructuralBottomReleaseFx : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralBottomReleaseFy Property

ParameterTypeIdStructuralBottomReleaseFy Property

"Base Fy"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralBottomReleaseFy { get; }
Public Shared ReadOnly Property StructuralBottomReleaseFy As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralBottomReleaseFy {
    ForgeTypeId^ get ();
}
static member StructuralBottomReleaseFy : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralBottomReleaseFz Property

ParameterTypeIdStructuralBottomReleaseFz Property

"Base Fz"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralBottomReleaseFz { get; }
Public Shared ReadOnly Property StructuralBottomReleaseFz As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralBottomReleaseFz {
    ForgeTypeId^ get ();
}
static member StructuralBottomReleaseFz : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralBottomReleaseMx Property

ParameterTypeIdStructuralBottomReleaseMx Property

"Base Mx"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralBottomReleaseMx { get; }
Public Shared ReadOnly Property StructuralBottomReleaseMx As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralBottomReleaseMx {
    ForgeTypeId^ get ();
}
static member StructuralBottomReleaseMx : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralBottomReleaseMy Property

ParameterTypeIdStructuralBottomReleaseMy Property

"Base My"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralBottomReleaseMy { get; }
Public Shared ReadOnly Property StructuralBottomReleaseMy As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralBottomReleaseMy {
    ForgeTypeId^ get ();
}
static member StructuralBottomReleaseMy : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralBottomReleaseMz Property

ParameterTypeIdStructuralBottomReleaseMz Property

"Base Mz"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralBottomReleaseMz { get; }
Public Shared ReadOnly Property StructuralBottomReleaseMz As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralBottomReleaseMz {
    ForgeTypeId^ get ();
}
static member StructuralBottomReleaseMz : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralBottomReleaseType Property

ParameterTypeIdStructuralBottomReleaseType Property

"Base Release"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralBottomReleaseType { get; }
Public Shared ReadOnly Property StructuralBottomReleaseType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralBottomReleaseType {
    ForgeTypeId^ get ();
}
static member StructuralBottomReleaseType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralBraceRepresentation Property

ParameterTypeIdStructuralBraceRepresentation Property

"Representation Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralBraceRepresentation { get; }
Public Shared ReadOnly Property StructuralBraceRepresentation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralBraceRepresentation {
    ForgeTypeId^ get ();
}
static member StructuralBraceRepresentation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralCamber Property

ParameterTypeIdStructuralCamber Property

"Camber Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralCamber { get; }
Public Shared ReadOnly Property StructuralCamber As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralCamber {
    ForgeTypeId^ get ();
}
static member StructuralCamber : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralConnectionApprovalStatus Property

ParameterTypeIdStructuralConnectionApprovalStatus Property

"Approval Status"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralConnectionApprovalStatus { get; }
Public Shared ReadOnly Property StructuralConnectionApprovalStatus As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralConnectionApprovalStatus {
    ForgeTypeId^ get ();
}
static member StructuralConnectionApprovalStatus : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralConnectionCodeCheckingStatus Property

ParameterTypeIdStructuralConnectionCodeCheckingStatus Property

"Code Checking Status"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralConnectionCodeCheckingStatus { get; }
Public Shared ReadOnly Property StructuralConnectionCodeCheckingStatus As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralConnectionCodeCheckingStatus {
    ForgeTypeId^ get ();
}
static member StructuralConnectionCodeCheckingStatus : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralConnectionEditRangesOfApplicability Property

ParameterTypeIdStructuralConnectionEditRangesOfApplicability Property

"Modify Ranges of applicability"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralConnectionEditRangesOfApplicability { get; }
Public Shared ReadOnly Property StructuralConnectionEditRangesOfApplicability As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralConnectionEditRangesOfApplicability {
    ForgeTypeId^ get ();
}
static member StructuralConnectionEditRangesOfApplicability : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralConnectionEditType Property

ParameterTypeIdStructuralConnectionEditType Property

"Modify Parameters"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralConnectionEditType { get; }
Public Shared ReadOnly Property StructuralConnectionEditType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralConnectionEditType {
    ForgeTypeId^ get ();
}
static member StructuralConnectionEditType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralConnectionInputElements Property

ParameterTypeIdStructuralConnectionInputElements Property

"Input Elements"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralConnectionInputElements { get; }
Public Shared ReadOnly Property StructuralConnectionInputElements As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralConnectionInputElements {
    ForgeTypeId^ get ();
}
static member StructuralConnectionInputElements : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralConnectionModifyConnectionParameters Property

ParameterTypeIdStructuralConnectionModifyConnectionParameters Property

"Detailed Parameters"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralConnectionModifyConnectionParameters { get; }
Public Shared ReadOnly Property StructuralConnectionModifyConnectionParameters As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralConnectionModifyConnectionParameters {
    ForgeTypeId^ get ();
}
static member StructuralConnectionModifyConnectionParameters : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralConnectionNobleStatus Property

ParameterTypeIdStructuralConnectionNobleStatus Property

"Noble Status"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralConnectionNobleStatus { get; }
Public Shared ReadOnly Property StructuralConnectionNobleStatus As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralConnectionNobleStatus {
    ForgeTypeId^ get ();
}
static member StructuralConnectionNobleStatus : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralConnectionOverrideType Property

ParameterTypeIdStructuralConnectionOverrideType Property

"Override by Instance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralConnectionOverrideType { get; }
Public Shared ReadOnly Property StructuralConnectionOverrideType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralConnectionOverrideType {
    ForgeTypeId^ get ();
}
static member StructuralConnectionOverrideType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralConnectionSymbol Property

ParameterTypeIdStructuralConnectionSymbol Property

"Connection Symbol"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralConnectionSymbol { get; }
Public Shared ReadOnly Property StructuralConnectionSymbol As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralConnectionSymbol {
    ForgeTypeId^ get ();
}
static member StructuralConnectionSymbol : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralCopingDistance Property

ParameterTypeIdStructuralCopingDistance Property

"Coping Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralCopingDistance { get; }
Public Shared ReadOnly Property StructuralCopingDistance As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralCopingDistance {
    ForgeTypeId^ get ();
}
static member StructuralCopingDistance : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralDisplayInHiddenViews Property

ParameterTypeIdStructuralDisplayInHiddenViews Property

"Display in Hidden Views"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralDisplayInHiddenViews { get; }
Public Shared ReadOnly Property StructuralDisplayInHiddenViews As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralDisplayInHiddenViews {
    ForgeTypeId^ get ();
}
static member StructuralDisplayInHiddenViews : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralDisplayInHiddenViewsColumn Property

ParameterTypeIdStructuralDisplayInHiddenViewsColumn Property

"Display in Hidden Views"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralDisplayInHiddenViewsColumn { get; }
Public Shared ReadOnly Property StructuralDisplayInHiddenViewsColumn As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralDisplayInHiddenViewsColumn {
    ForgeTypeId^ get ();
}
static member StructuralDisplayInHiddenViewsColumn : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralDisplayInHiddenViewsFraming Property

ParameterTypeIdStructuralDisplayInHiddenViewsFraming Property

"Display in Hidden Views"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralDisplayInHiddenViewsFraming { get; }
Public Shared ReadOnly Property StructuralDisplayInHiddenViewsFraming As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralDisplayInHiddenViewsFraming {
    ForgeTypeId^ get ();
}
static member StructuralDisplayInHiddenViewsFraming : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralElevationAtBottom Property

ParameterTypeIdStructuralElevationAtBottom Property

"Elevation at Bottom"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralElevationAtBottom { get; }
Public Shared ReadOnly Property StructuralElevationAtBottom As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralElevationAtBottom {
    ForgeTypeId^ get ();
}
static member StructuralElevationAtBottom : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralElevationAtBottomCore Property

ParameterTypeIdStructuralElevationAtBottomCore Property

"Elevation at Bottom Core"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralElevationAtBottomCore { get; }
Public Shared ReadOnly Property StructuralElevationAtBottomCore As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralElevationAtBottomCore {
    ForgeTypeId^ get ();
}
static member StructuralElevationAtBottomCore : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralElevationAtBottomSurvey Property

ParameterTypeIdStructuralElevationAtBottomSurvey Property

"Elevation at Bottom Survey"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralElevationAtBottomSurvey { get; }
Public Shared ReadOnly Property StructuralElevationAtBottomSurvey As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralElevationAtBottomSurvey {
    ForgeTypeId^ get ();
}
static member StructuralElevationAtBottomSurvey : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralElevationAtTop Property

ParameterTypeIdStructuralElevationAtTop Property

"Elevation at Top"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralElevationAtTop { get; }
Public Shared ReadOnly Property StructuralElevationAtTop As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralElevationAtTop {
    ForgeTypeId^ get ();
}
static member StructuralElevationAtTop : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralElevationAtTopCore Property

ParameterTypeIdStructuralElevationAtTopCore Property

"Elevation at Top Core"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralElevationAtTopCore { get; }
Public Shared ReadOnly Property StructuralElevationAtTopCore As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralElevationAtTopCore {
    ForgeTypeId^ get ();
}
static member StructuralElevationAtTopCore : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralElevationAtTopSurvey Property

ParameterTypeIdStructuralElevationAtTopSurvey Property

"Elevation at Top Survey"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralElevationAtTopSurvey { get; }
Public Shared ReadOnly Property StructuralElevationAtTopSurvey As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralElevationAtTopSurvey {
    ForgeTypeId^ get ();
}
static member StructuralElevationAtTopSurvey : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralEndReleaseFx Property

ParameterTypeIdStructuralEndReleaseFx Property

"End Fx"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralEndReleaseFx { get; }
Public Shared ReadOnly Property StructuralEndReleaseFx As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralEndReleaseFx {
    ForgeTypeId^ get ();
}
static member StructuralEndReleaseFx : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralEndReleaseFy Property

ParameterTypeIdStructuralEndReleaseFy Property

"End Fy"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralEndReleaseFy { get; }
Public Shared ReadOnly Property StructuralEndReleaseFy As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralEndReleaseFy {
    ForgeTypeId^ get ();
}
static member StructuralEndReleaseFy : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralEndReleaseFz Property

ParameterTypeIdStructuralEndReleaseFz Property

"End Fz"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralEndReleaseFz { get; }
Public Shared ReadOnly Property StructuralEndReleaseFz As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralEndReleaseFz {
    ForgeTypeId^ get ();
}
static member StructuralEndReleaseFz : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralEndReleaseMx Property

ParameterTypeIdStructuralEndReleaseMx Property

"End Mx"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralEndReleaseMx { get; }
Public Shared ReadOnly Property StructuralEndReleaseMx As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralEndReleaseMx {
    ForgeTypeId^ get ();
}
static member StructuralEndReleaseMx : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralEndReleaseMy Property

ParameterTypeIdStructuralEndReleaseMy Property

"End My"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralEndReleaseMy { get; }
Public Shared ReadOnly Property StructuralEndReleaseMy As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralEndReleaseMy {
    ForgeTypeId^ get ();
}
static member StructuralEndReleaseMy : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralEndReleaseMz Property

ParameterTypeIdStructuralEndReleaseMz Property

"End Mz"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralEndReleaseMz { get; }
Public Shared ReadOnly Property StructuralEndReleaseMz As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralEndReleaseMz {
    ForgeTypeId^ get ();
}
static member StructuralEndReleaseMz : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralEndReleaseType Property

ParameterTypeIdStructuralEndReleaseType Property

"End Release"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralEndReleaseType { get; }
Public Shared ReadOnly Property StructuralEndReleaseType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralEndReleaseType {
    ForgeTypeId^ get ();
}
static member StructuralEndReleaseType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralFamilyCodeName Property

ParameterTypeIdStructuralFamilyCodeName Property

"Code Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralFamilyCodeName { get; }
Public Shared ReadOnly Property StructuralFamilyCodeName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralFamilyCodeName {
    ForgeTypeId^ get ();
}
static member StructuralFamilyCodeName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralFamilyNameKey Property

ParameterTypeIdStructuralFamilyNameKey Property

"Family Name Key"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralFamilyNameKey { get; }
Public Shared ReadOnly Property StructuralFamilyNameKey As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralFamilyNameKey {
    ForgeTypeId^ get ();
}
static member StructuralFamilyNameKey : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralFloorAnalyzesAs Property

ParameterTypeIdStructuralFloorAnalyzesAs Property

"Analyze As"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralFloorAnalyzesAs { get; }
Public Shared ReadOnly Property StructuralFloorAnalyzesAs As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralFloorAnalyzesAs {
    ForgeTypeId^ get ();
}
static member StructuralFloorAnalyzesAs : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralFloorCoreThickness Property

ParameterTypeIdStructuralFloorCoreThickness Property

"Core Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralFloorCoreThickness { get; }
Public Shared ReadOnly Property StructuralFloorCoreThickness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralFloorCoreThickness {
    ForgeTypeId^ get ();
}
static member StructuralFloorCoreThickness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralFoundationLength Property

ParameterTypeIdStructuralFoundationLength Property

"Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralFoundationLength { get; }
Public Shared ReadOnly Property StructuralFoundationLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralFoundationLength {
    ForgeTypeId^ get ();
}
static member StructuralFoundationLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralFoundationThickness Property

ParameterTypeIdStructuralFoundationThickness Property

"Foundation Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralFoundationThickness { get; }
Public Shared ReadOnly Property StructuralFoundationThickness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralFoundationThickness {
    ForgeTypeId^ get ();
}
static member StructuralFoundationThickness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralFoundationWidth Property

ParameterTypeIdStructuralFoundationWidth Property

"Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralFoundationWidth { get; }
Public Shared ReadOnly Property StructuralFoundationWidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralFoundationWidth {
    ForgeTypeId^ get ();
}
static member StructuralFoundationWidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralFrameCutLength Property

ParameterTypeIdStructuralFrameCutLength Property

"Cut Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralFrameCutLength { get; }
Public Shared ReadOnly Property StructuralFrameCutLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralFrameCutLength {
    ForgeTypeId^ get ();
}
static member StructuralFrameCutLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralMaterialParam Property

ParameterTypeIdStructuralMaterialParam Property

"Structural Material"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralMaterialParam { get; }
Public Shared ReadOnly Property StructuralMaterialParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralMaterialParam {
    ForgeTypeId^ get ();
}
static member StructuralMaterialParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralMaterialType Property

ParameterTypeIdStructuralMaterialType Property

"Structural Material Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralMaterialType { get; }
Public Shared ReadOnly Property StructuralMaterialType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralMaterialType {
    ForgeTypeId^ get ();
}
static member StructuralMaterialType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralMemberForces Property

ParameterTypeIdStructuralMemberForces Property

"Member Forces"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralMemberForces { get; }
Public Shared ReadOnly Property StructuralMemberForces As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralMemberForces {
    ForgeTypeId^ get ();
}
static member StructuralMemberForces : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralNumberOfStuds Property

ParameterTypeIdStructuralNumberOfStuds Property

"Number of studs"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralNumberOfStuds { get; }
Public Shared ReadOnly Property StructuralNumberOfStuds As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralNumberOfStuds {
    ForgeTypeId^ get ();
}
static member StructuralNumberOfStuds : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralReferenceLevelElevation Property

ParameterTypeIdStructuralReferenceLevelElevation Property

"Reference Level Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralReferenceLevelElevation { get; }
Public Shared ReadOnly Property StructuralReferenceLevelElevation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralReferenceLevelElevation {
    ForgeTypeId^ get ();
}
static member StructuralReferenceLevelElevation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionArea Property

ParameterTypeIdStructuralSectionArea Property

"Section Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionArea { get; }
Public Shared ReadOnly Property StructuralSectionArea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionArea {
    ForgeTypeId^ get ();
}
static member StructuralSectionArea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionBottomCutHeight Property

ParameterTypeIdStructuralSectionBottomCutHeight Property

"Bottom Cut Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionBottomCutHeight { get; }
Public Shared ReadOnly Property StructuralSectionBottomCutHeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionBottomCutHeight {
    ForgeTypeId^ get ();
}
static member StructuralSectionBottomCutHeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionBottomCutWidth Property

ParameterTypeIdStructuralSectionBottomCutWidth Property

"Bottom Cut Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionBottomCutWidth { get; }
Public Shared ReadOnly Property StructuralSectionBottomCutWidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionBottomCutWidth {
    ForgeTypeId^ get ();
}
static member StructuralSectionBottomCutWidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionCantileverHeight Property

ParameterTypeIdStructuralSectionCantileverHeight Property

"Cantilever Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionCantileverHeight { get; }
Public Shared ReadOnly Property StructuralSectionCantileverHeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionCantileverHeight {
    ForgeTypeId^ get ();
}
static member StructuralSectionCantileverHeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionCantileverLength Property

ParameterTypeIdStructuralSectionCantileverLength Property

"Cantilever Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionCantileverLength { get; }
Public Shared ReadOnly Property StructuralSectionCantileverLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionCantileverLength {
    ForgeTypeId^ get ();
}
static member StructuralSectionCantileverLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionCommonAlpha Property

ParameterTypeIdStructuralSectionCommonAlpha Property

"Principal Axes Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionCommonAlpha { get; }
Public Shared ReadOnly Property StructuralSectionCommonAlpha As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionCommonAlpha {
    ForgeTypeId^ get ();
}
static member StructuralSectionCommonAlpha : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionCommonCentroidHoriz Property

ParameterTypeIdStructuralSectionCommonCentroidHoriz Property

"Centroid Horizontal"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionCommonCentroidHoriz { get; }
Public Shared ReadOnly Property StructuralSectionCommonCentroidHoriz As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionCommonCentroidHoriz {
    ForgeTypeId^ get ();
}
static member StructuralSectionCommonCentroidHoriz : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionCommonCentroidVertical Property

ParameterTypeIdStructuralSectionCommonCentroidVertical Property

"Centroid Vertical"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionCommonCentroidVertical { get; }
Public Shared ReadOnly Property StructuralSectionCommonCentroidVertical As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionCommonCentroidVertical {
    ForgeTypeId^ get ();
}
static member StructuralSectionCommonCentroidVertical : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionCommonDiameter Property

ParameterTypeIdStructuralSectionCommonDiameter Property

"Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionCommonDiameter { get; }
Public Shared ReadOnly Property StructuralSectionCommonDiameter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionCommonDiameter {
    ForgeTypeId^ get ();
}
static member StructuralSectionCommonDiameter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionCommonElasticModulusStrongAxis Property

ParameterTypeIdStructuralSectionCommonElasticModulusStrongAxis Property

"Elastic Modulus strong axis"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionCommonElasticModulusStrongAxis { get; }
Public Shared ReadOnly Property StructuralSectionCommonElasticModulusStrongAxis As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionCommonElasticModulusStrongAxis {
    ForgeTypeId^ get ();
}
static member StructuralSectionCommonElasticModulusStrongAxis : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionCommonElasticModulusWeakAxis Property

ParameterTypeIdStructuralSectionCommonElasticModulusWeakAxis Property

"Elastic Modulus weak axis"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionCommonElasticModulusWeakAxis { get; }
Public Shared ReadOnly Property StructuralSectionCommonElasticModulusWeakAxis As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionCommonElasticModulusWeakAxis {
    ForgeTypeId^ get ();
}
static member StructuralSectionCommonElasticModulusWeakAxis : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionCommonHeight Property

ParameterTypeIdStructuralSectionCommonHeight Property

"Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionCommonHeight { get; }
Public Shared ReadOnly Property StructuralSectionCommonHeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionCommonHeight {
    ForgeTypeId^ get ();
}
static member StructuralSectionCommonHeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionCommonMomentOfInertiaStrongAxis Property

ParameterTypeIdStructuralSectionCommonMomentOfInertiaStrongAxis Property

"Moment of Inertia strong axis"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionCommonMomentOfInertiaStrongAxis { get; }
Public Shared ReadOnly Property StructuralSectionCommonMomentOfInertiaStrongAxis As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionCommonMomentOfInertiaStrongAxis {
    ForgeTypeId^ get ();
}
static member StructuralSectionCommonMomentOfInertiaStrongAxis : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionCommonMomentOfInertiaWeakAxis Property

ParameterTypeIdStructuralSectionCommonMomentOfInertiaWeakAxis Property

"Moment of Inertia weak axis"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionCommonMomentOfInertiaWeakAxis { get; }
Public Shared ReadOnly Property StructuralSectionCommonMomentOfInertiaWeakAxis As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionCommonMomentOfInertiaWeakAxis {
    ForgeTypeId^ get ();
}
static member StructuralSectionCommonMomentOfInertiaWeakAxis : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionCommonNominalWeight Property

ParameterTypeIdStructuralSectionCommonNominalWeight Property

"Nominal Weight"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionCommonNominalWeight { get; }
Public Shared ReadOnly Property StructuralSectionCommonNominalWeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionCommonNominalWeight {
    ForgeTypeId^ get ();
}
static member StructuralSectionCommonNominalWeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionCommonPerimeter Property

ParameterTypeIdStructuralSectionCommonPerimeter Property

"Perimeter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionCommonPerimeter { get; }
Public Shared ReadOnly Property StructuralSectionCommonPerimeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionCommonPerimeter {
    ForgeTypeId^ get ();
}
static member StructuralSectionCommonPerimeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionCommonPlasticModulusStrongAxis Property

ParameterTypeIdStructuralSectionCommonPlasticModulusStrongAxis Property

"Plastic Modulus strong axis"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionCommonPlasticModulusStrongAxis { get; }
Public Shared ReadOnly Property StructuralSectionCommonPlasticModulusStrongAxis As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionCommonPlasticModulusStrongAxis {
    ForgeTypeId^ get ();
}
static member StructuralSectionCommonPlasticModulusStrongAxis : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionCommonPlasticModulusWeakAxis Property

ParameterTypeIdStructuralSectionCommonPlasticModulusWeakAxis Property

"Plastic Modulus weak axis"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionCommonPlasticModulusWeakAxis { get; }
Public Shared ReadOnly Property StructuralSectionCommonPlasticModulusWeakAxis As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionCommonPlasticModulusWeakAxis {
    ForgeTypeId^ get ();
}
static member StructuralSectionCommonPlasticModulusWeakAxis : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionCommonShearAreaStrongAxis Property

ParameterTypeIdStructuralSectionCommonShearAreaStrongAxis Property

"Shear Area strong axis"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionCommonShearAreaStrongAxis { get; }
Public Shared ReadOnly Property StructuralSectionCommonShearAreaStrongAxis As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionCommonShearAreaStrongAxis {
    ForgeTypeId^ get ();
}
static member StructuralSectionCommonShearAreaStrongAxis : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionCommonShearAreaWeakAxis Property

ParameterTypeIdStructuralSectionCommonShearAreaWeakAxis Property

"Shear Area weak axis"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionCommonShearAreaWeakAxis { get; }
Public Shared ReadOnly Property StructuralSectionCommonShearAreaWeakAxis As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionCommonShearAreaWeakAxis {
    ForgeTypeId^ get ();
}
static member StructuralSectionCommonShearAreaWeakAxis : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionCommonTorsionalModulus Property

ParameterTypeIdStructuralSectionCommonTorsionalModulus Property

"Torsional Modulus"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionCommonTorsionalModulus { get; }
Public Shared ReadOnly Property StructuralSectionCommonTorsionalModulus As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionCommonTorsionalModulus {
    ForgeTypeId^ get ();
}
static member StructuralSectionCommonTorsionalModulus : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionCommonTorsionalMomentOfInertia Property

ParameterTypeIdStructuralSectionCommonTorsionalMomentOfInertia Property

"Torsional Moment of Inertia"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionCommonTorsionalMomentOfInertia { get; }
Public Shared ReadOnly Property StructuralSectionCommonTorsionalMomentOfInertia As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionCommonTorsionalMomentOfInertia {
    ForgeTypeId^ get ();
}
static member StructuralSectionCommonTorsionalMomentOfInertia : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionCommonWarpingConstant Property

ParameterTypeIdStructuralSectionCommonWarpingConstant Property

"Warping Constant"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionCommonWarpingConstant { get; }
Public Shared ReadOnly Property StructuralSectionCommonWarpingConstant As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionCommonWarpingConstant {
    ForgeTypeId^ get ();
}
static member StructuralSectionCommonWarpingConstant : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionCommonWidth Property

ParameterTypeIdStructuralSectionCommonWidth Property

"Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionCommonWidth { get; }
Public Shared ReadOnly Property StructuralSectionCommonWidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionCommonWidth {
    ForgeTypeId^ get ();
}
static member StructuralSectionCommonWidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionCprofileFoldLength Property

ParameterTypeIdStructuralSectionCprofileFoldLength Property

"Fold Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionCprofileFoldLength { get; }
Public Shared ReadOnly Property StructuralSectionCprofileFoldLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionCprofileFoldLength {
    ForgeTypeId^ get ();
}
static member StructuralSectionCprofileFoldLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionHssInnerfillet Property

ParameterTypeIdStructuralSectionHssInnerfillet Property

"Inner Fillet"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionHssInnerfillet { get; }
Public Shared ReadOnly Property StructuralSectionHssInnerfillet As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionHssInnerfillet {
    ForgeTypeId^ get ();
}
static member StructuralSectionHssInnerfillet : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionHssOuterfillet Property

ParameterTypeIdStructuralSectionHssOuterfillet Property

"Outer Fillet"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionHssOuterfillet { get; }
Public Shared ReadOnly Property StructuralSectionHssOuterfillet As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionHssOuterfillet {
    ForgeTypeId^ get ();
}
static member StructuralSectionHssOuterfillet : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionIshapeBoltDiameter Property

ParameterTypeIdStructuralSectionIshapeBoltDiameter Property

"Bolt Diameter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionIshapeBoltDiameter { get; }
Public Shared ReadOnly Property StructuralSectionIshapeBoltDiameter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionIshapeBoltDiameter {
    ForgeTypeId^ get ();
}
static member StructuralSectionIshapeBoltDiameter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionIshapeBoltSpacing Property

ParameterTypeIdStructuralSectionIshapeBoltSpacing Property

"Bolt Spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionIshapeBoltSpacing { get; }
Public Shared ReadOnly Property StructuralSectionIshapeBoltSpacing As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionIshapeBoltSpacing {
    ForgeTypeId^ get ();
}
static member StructuralSectionIshapeBoltSpacing : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionIshapeBoltSpacingBetweenRows Property

ParameterTypeIdStructuralSectionIshapeBoltSpacingBetweenRows Property

"Bolt Spacing between Rows"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionIshapeBoltSpacingBetweenRows { get; }
Public Shared ReadOnly Property StructuralSectionIshapeBoltSpacingBetweenRows As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionIshapeBoltSpacingBetweenRows {
    ForgeTypeId^ get ();
}
static member StructuralSectionIshapeBoltSpacingBetweenRows : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionIshapeBoltSpacingTwoRows Property

ParameterTypeIdStructuralSectionIshapeBoltSpacingTwoRows Property

"Bolt Spacing Two Rows"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionIshapeBoltSpacingTwoRows { get; }
Public Shared ReadOnly Property StructuralSectionIshapeBoltSpacingTwoRows As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionIshapeBoltSpacingTwoRows {
    ForgeTypeId^ get ();
}
static member StructuralSectionIshapeBoltSpacingTwoRows : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionIshapeBoltSpacingWeb Property

ParameterTypeIdStructuralSectionIshapeBoltSpacingWeb Property

"Bolt Spacing web"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionIshapeBoltSpacingWeb { get; }
Public Shared ReadOnly Property StructuralSectionIshapeBoltSpacingWeb As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionIshapeBoltSpacingWeb {
    ForgeTypeId^ get ();
}
static member StructuralSectionIshapeBoltSpacingWeb : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionIshapeClearWebHeight Property

ParameterTypeIdStructuralSectionIshapeClearWebHeight Property

"Clear Web Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionIshapeClearWebHeight { get; }
Public Shared ReadOnly Property StructuralSectionIshapeClearWebHeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionIshapeClearWebHeight {
    ForgeTypeId^ get ();
}
static member StructuralSectionIshapeClearWebHeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionIshapeFlangefillet Property

ParameterTypeIdStructuralSectionIshapeFlangefillet Property

"Flange Fillet"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionIshapeFlangefillet { get; }
Public Shared ReadOnly Property StructuralSectionIshapeFlangefillet As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionIshapeFlangefillet {
    ForgeTypeId^ get ();
}
static member StructuralSectionIshapeFlangefillet : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionIshapeFlangethickness Property

ParameterTypeIdStructuralSectionIshapeFlangethickness Property

"Flange Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionIshapeFlangethickness { get; }
Public Shared ReadOnly Property StructuralSectionIshapeFlangethickness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionIshapeFlangethickness {
    ForgeTypeId^ get ();
}
static member StructuralSectionIshapeFlangethickness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionIshapeFlangethicknessLocation Property

ParameterTypeIdStructuralSectionIshapeFlangethicknessLocation Property

"Flange Thickness Location"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionIshapeFlangethicknessLocation { get; }
Public Shared ReadOnly Property StructuralSectionIshapeFlangethicknessLocation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionIshapeFlangethicknessLocation {
    ForgeTypeId^ get ();
}
static member StructuralSectionIshapeFlangethicknessLocation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionIshapeFlangeToeOfFillet Property

ParameterTypeIdStructuralSectionIshapeFlangeToeOfFillet Property

"Flange Toe of Fillet"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionIshapeFlangeToeOfFillet { get; }
Public Shared ReadOnly Property StructuralSectionIshapeFlangeToeOfFillet As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionIshapeFlangeToeOfFillet {
    ForgeTypeId^ get ();
}
static member StructuralSectionIshapeFlangeToeOfFillet : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionIshapeWebfillet Property

ParameterTypeIdStructuralSectionIshapeWebfillet Property

"Web Fillet"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionIshapeWebfillet { get; }
Public Shared ReadOnly Property StructuralSectionIshapeWebfillet As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionIshapeWebfillet {
    ForgeTypeId^ get ();
}
static member StructuralSectionIshapeWebfillet : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionIshapeWebheight Property

ParameterTypeIdStructuralSectionIshapeWebheight Property

"Web Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionIshapeWebheight { get; }
Public Shared ReadOnly Property StructuralSectionIshapeWebheight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionIshapeWebheight {
    ForgeTypeId^ get ();
}
static member StructuralSectionIshapeWebheight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionIshapeWebthickness Property

ParameterTypeIdStructuralSectionIshapeWebthickness Property

"Web Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionIshapeWebthickness { get; }
Public Shared ReadOnly Property StructuralSectionIshapeWebthickness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionIshapeWebthickness {
    ForgeTypeId^ get ();
}
static member StructuralSectionIshapeWebthickness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionIshapeWebthicknessLocation Property

ParameterTypeIdStructuralSectionIshapeWebthicknessLocation Property

"Web Thickness Location"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionIshapeWebthicknessLocation { get; }
Public Shared ReadOnly Property StructuralSectionIshapeWebthicknessLocation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionIshapeWebthicknessLocation {
    ForgeTypeId^ get ();
}
static member StructuralSectionIshapeWebthicknessLocation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionIshapeWebToeOfFillet Property

ParameterTypeIdStructuralSectionIshapeWebToeOfFillet Property

"Web Toe of Fillet"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionIshapeWebToeOfFillet { get; }
Public Shared ReadOnly Property StructuralSectionIshapeWebToeOfFillet As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionIshapeWebToeOfFillet {
    ForgeTypeId^ get ();
}
static member StructuralSectionIshapeWebToeOfFillet : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionIweldedBottomflangethickness Property

ParameterTypeIdStructuralSectionIweldedBottomflangethickness Property

"Bottom Flange Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionIweldedBottomflangethickness { get; }
Public Shared ReadOnly Property StructuralSectionIweldedBottomflangethickness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionIweldedBottomflangethickness {
    ForgeTypeId^ get ();
}
static member StructuralSectionIweldedBottomflangethickness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionIweldedBottomflangewidth Property

ParameterTypeIdStructuralSectionIweldedBottomflangewidth Property

"Bottom Flange Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionIweldedBottomflangewidth { get; }
Public Shared ReadOnly Property StructuralSectionIweldedBottomflangewidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionIweldedBottomflangewidth {
    ForgeTypeId^ get ();
}
static member StructuralSectionIweldedBottomflangewidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionIweldedTopflangethickness Property

ParameterTypeIdStructuralSectionIweldedTopflangethickness Property

"Top Flange Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionIweldedTopflangethickness { get; }
Public Shared ReadOnly Property StructuralSectionIweldedTopflangethickness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionIweldedTopflangethickness {
    ForgeTypeId^ get ();
}
static member StructuralSectionIweldedTopflangethickness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionIweldedTopflangewidth Property

ParameterTypeIdStructuralSectionIweldedTopflangewidth Property

"Top Flange Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionIweldedTopflangewidth { get; }
Public Shared ReadOnly Property StructuralSectionIweldedTopflangewidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionIweldedTopflangewidth {
    ForgeTypeId^ get ();
}
static member StructuralSectionIweldedTopflangewidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionLangleBoltDiameterLongerFlange Property

ParameterTypeIdStructuralSectionLangleBoltDiameterLongerFlange Property

"Bolt Diameter Longer Flange"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionLangleBoltDiameterLongerFlange { get; }
Public Shared ReadOnly Property StructuralSectionLangleBoltDiameterLongerFlange As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionLangleBoltDiameterLongerFlange {
    ForgeTypeId^ get ();
}
static member StructuralSectionLangleBoltDiameterLongerFlange : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionLangleBoltDiameterShorterFlange Property

ParameterTypeIdStructuralSectionLangleBoltDiameterShorterFlange Property

"Bolt Diameter Shorter Flange"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionLangleBoltDiameterShorterFlange { get; }
Public Shared ReadOnly Property StructuralSectionLangleBoltDiameterShorterFlange As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionLangleBoltDiameterShorterFlange {
    ForgeTypeId^ get ();
}
static member StructuralSectionLangleBoltDiameterShorterFlange : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionLangleBoltSpacing1LongerFlange Property

ParameterTypeIdStructuralSectionLangleBoltSpacing1LongerFlange Property

"Bolt Spacing 1 Longer Flange"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionLangleBoltSpacing1LongerFlange { get; }
Public Shared ReadOnly Property StructuralSectionLangleBoltSpacing1LongerFlange As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionLangleBoltSpacing1LongerFlange {
    ForgeTypeId^ get ();
}
static member StructuralSectionLangleBoltSpacing1LongerFlange : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionLangleBoltSpacing2LongerFlange Property

ParameterTypeIdStructuralSectionLangleBoltSpacing2LongerFlange Property

"Bolt Spacing 2 Longer Flange"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionLangleBoltSpacing2LongerFlange { get; }
Public Shared ReadOnly Property StructuralSectionLangleBoltSpacing2LongerFlange As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionLangleBoltSpacing2LongerFlange {
    ForgeTypeId^ get ();
}
static member StructuralSectionLangleBoltSpacing2LongerFlange : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionLangleBoltSpacingShorterFlange Property

ParameterTypeIdStructuralSectionLangleBoltSpacingShorterFlange Property

"Bolt Spacing Shorter Flange"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionLangleBoltSpacingShorterFlange { get; }
Public Shared ReadOnly Property StructuralSectionLangleBoltSpacingShorterFlange As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionLangleBoltSpacingShorterFlange {
    ForgeTypeId^ get ();
}
static member StructuralSectionLangleBoltSpacingShorterFlange : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionLprofileLipLength Property

ParameterTypeIdStructuralSectionLprofileLipLength Property

"Lip Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionLprofileLipLength { get; }
Public Shared ReadOnly Property StructuralSectionLprofileLipLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionLprofileLipLength {
    ForgeTypeId^ get ();
}
static member StructuralSectionLprofileLipLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionNameKey Property

ParameterTypeIdStructuralSectionNameKey Property

"Section Name Key"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionNameKey { get; }
Public Shared ReadOnly Property StructuralSectionNameKey As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionNameKey {
    ForgeTypeId^ get ();
}
static member StructuralSectionNameKey : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionPipestandardWalldesignthickness Property

ParameterTypeIdStructuralSectionPipestandardWalldesignthickness Property

"Wall Design Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionPipestandardWalldesignthickness { get; }
Public Shared ReadOnly Property StructuralSectionPipestandardWalldesignthickness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionPipestandardWalldesignthickness {
    ForgeTypeId^ get ();
}
static member StructuralSectionPipestandardWalldesignthickness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionPipestandardWallnominalthickness Property

ParameterTypeIdStructuralSectionPipestandardWallnominalthickness Property

"Wall Nominal Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionPipestandardWallnominalthickness { get; }
Public Shared ReadOnly Property StructuralSectionPipestandardWallnominalthickness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionPipestandardWallnominalthickness {
    ForgeTypeId^ get ();
}
static member StructuralSectionPipestandardWallnominalthickness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionShape Property

ParameterTypeIdStructuralSectionShape Property

"Section Shape"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionShape { get; }
Public Shared ReadOnly Property StructuralSectionShape As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionShape {
    ForgeTypeId^ get ();
}
static member StructuralSectionShape : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionSigmaProfileBendWidth Property

ParameterTypeIdStructuralSectionSigmaProfileBendWidth Property

"Bend Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionSigmaProfileBendWidth { get; }
Public Shared ReadOnly Property StructuralSectionSigmaProfileBendWidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionSigmaProfileBendWidth {
    ForgeTypeId^ get ();
}
static member StructuralSectionSigmaProfileBendWidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionSigmaProfileMiddleBendWidth Property

ParameterTypeIdStructuralSectionSigmaProfileMiddleBendWidth Property

"Middle Bend Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionSigmaProfileMiddleBendWidth { get; }
Public Shared ReadOnly Property StructuralSectionSigmaProfileMiddleBendWidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionSigmaProfileMiddleBendWidth {
    ForgeTypeId^ get ();
}
static member StructuralSectionSigmaProfileMiddleBendWidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionSigmaProfileTopBendWidth Property

ParameterTypeIdStructuralSectionSigmaProfileTopBendWidth Property

"Top Bend Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionSigmaProfileTopBendWidth { get; }
Public Shared ReadOnly Property StructuralSectionSigmaProfileTopBendWidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionSigmaProfileTopBendWidth {
    ForgeTypeId^ get ();
}
static member StructuralSectionSigmaProfileTopBendWidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionSlopedFlangeAngle Property

ParameterTypeIdStructuralSectionSlopedFlangeAngle Property

"Sloped Flange Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionSlopedFlangeAngle { get; }
Public Shared ReadOnly Property StructuralSectionSlopedFlangeAngle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionSlopedFlangeAngle {
    ForgeTypeId^ get ();
}
static member StructuralSectionSlopedFlangeAngle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionSlopedWebAngle Property

ParameterTypeIdStructuralSectionSlopedWebAngle Property

"Sloped Web Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionSlopedWebAngle { get; }
Public Shared ReadOnly Property StructuralSectionSlopedWebAngle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionSlopedWebAngle {
    ForgeTypeId^ get ();
}
static member StructuralSectionSlopedWebAngle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionTopCutHeight Property

ParameterTypeIdStructuralSectionTopCutHeight Property

"Top Cut Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionTopCutHeight { get; }
Public Shared ReadOnly Property StructuralSectionTopCutHeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionTopCutHeight {
    ForgeTypeId^ get ();
}
static member StructuralSectionTopCutHeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionTopCutWidth Property

ParameterTypeIdStructuralSectionTopCutWidth Property

"Top Cut Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionTopCutWidth { get; }
Public Shared ReadOnly Property StructuralSectionTopCutWidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionTopCutWidth {
    ForgeTypeId^ get ();
}
static member StructuralSectionTopCutWidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionTopWebFillet Property

ParameterTypeIdStructuralSectionTopWebFillet Property

"Top Web Fillet"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionTopWebFillet { get; }
Public Shared ReadOnly Property StructuralSectionTopWebFillet As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionTopWebFillet {
    ForgeTypeId^ get ();
}
static member StructuralSectionTopWebFillet : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralSectionZprofileBottomFlangeLength Property

ParameterTypeIdStructuralSectionZprofileBottomFlangeLength Property

"Bottom Flange Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralSectionZprofileBottomFlangeLength { get; }
Public Shared ReadOnly Property StructuralSectionZprofileBottomFlangeLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralSectionZprofileBottomFlangeLength {
    ForgeTypeId^ get ();
}
static member StructuralSectionZprofileBottomFlangeLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralStartReleaseFx Property

ParameterTypeIdStructuralStartReleaseFx Property

"Start Fx"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralStartReleaseFx { get; }
Public Shared ReadOnly Property StructuralStartReleaseFx As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralStartReleaseFx {
    ForgeTypeId^ get ();
}
static member StructuralStartReleaseFx : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralStartReleaseFy Property

ParameterTypeIdStructuralStartReleaseFy Property

"Start Fy"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralStartReleaseFy { get; }
Public Shared ReadOnly Property StructuralStartReleaseFy As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralStartReleaseFy {
    ForgeTypeId^ get ();
}
static member StructuralStartReleaseFy : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralStartReleaseFz Property

ParameterTypeIdStructuralStartReleaseFz Property

"Start Fz"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralStartReleaseFz { get; }
Public Shared ReadOnly Property StructuralStartReleaseFz As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralStartReleaseFz {
    ForgeTypeId^ get ();
}
static member StructuralStartReleaseFz : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralStartReleaseMx Property

ParameterTypeIdStructuralStartReleaseMx Property

"Start Mx"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralStartReleaseMx { get; }
Public Shared ReadOnly Property StructuralStartReleaseMx As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralStartReleaseMx {
    ForgeTypeId^ get ();
}
static member StructuralStartReleaseMx : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralStartReleaseMy Property

ParameterTypeIdStructuralStartReleaseMy Property

"Start My"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralStartReleaseMy { get; }
Public Shared ReadOnly Property StructuralStartReleaseMy As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralStartReleaseMy {
    ForgeTypeId^ get ();
}
static member StructuralStartReleaseMy : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralStartReleaseMz Property

ParameterTypeIdStructuralStartReleaseMz Property

"Start Mz"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralStartReleaseMz { get; }
Public Shared ReadOnly Property StructuralStartReleaseMz As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralStartReleaseMz {
    ForgeTypeId^ get ();
}
static member StructuralStartReleaseMz : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralStartReleaseType Property

ParameterTypeIdStructuralStartReleaseType Property

"Start Release"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralStartReleaseType { get; }
Public Shared ReadOnly Property StructuralStartReleaseType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralStartReleaseType {
    ForgeTypeId^ get ();
}
static member StructuralStartReleaseType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralStickSymbolLocation Property

ParameterTypeIdStructuralStickSymbolLocation Property

"Stick Symbol Location"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralStickSymbolLocation { get; }
Public Shared ReadOnly Property StructuralStickSymbolLocation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralStickSymbolLocation {
    ForgeTypeId^ get ();
}
static member StructuralStickSymbolLocation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralTopReleaseFx Property

ParameterTypeIdStructuralTopReleaseFx Property

"Top Fx"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralTopReleaseFx { get; }
Public Shared ReadOnly Property StructuralTopReleaseFx As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralTopReleaseFx {
    ForgeTypeId^ get ();
}
static member StructuralTopReleaseFx : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralTopReleaseFy Property

ParameterTypeIdStructuralTopReleaseFy Property

"Top Fy"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralTopReleaseFy { get; }
Public Shared ReadOnly Property StructuralTopReleaseFy As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralTopReleaseFy {
    ForgeTypeId^ get ();
}
static member StructuralTopReleaseFy : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralTopReleaseFz Property

ParameterTypeIdStructuralTopReleaseFz Property

"Top Fz"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralTopReleaseFz { get; }
Public Shared ReadOnly Property StructuralTopReleaseFz As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralTopReleaseFz {
    ForgeTypeId^ get ();
}
static member StructuralTopReleaseFz : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralTopReleaseMx Property

ParameterTypeIdStructuralTopReleaseMx Property

"Top Mx"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralTopReleaseMx { get; }
Public Shared ReadOnly Property StructuralTopReleaseMx As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralTopReleaseMx {
    ForgeTypeId^ get ();
}
static member StructuralTopReleaseMx : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralTopReleaseMy Property

ParameterTypeIdStructuralTopReleaseMy Property

"Top My"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralTopReleaseMy { get; }
Public Shared ReadOnly Property StructuralTopReleaseMy As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralTopReleaseMy {
    ForgeTypeId^ get ();
}
static member StructuralTopReleaseMy : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralTopReleaseMz Property

ParameterTypeIdStructuralTopReleaseMz Property

"Top Mz"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralTopReleaseMz { get; }
Public Shared ReadOnly Property StructuralTopReleaseMz As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralTopReleaseMz {
    ForgeTypeId^ get ();
}
static member StructuralTopReleaseMz : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralTopReleaseType Property

ParameterTypeIdStructuralTopReleaseType Property

"Top Release"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralTopReleaseType { get; }
Public Shared ReadOnly Property StructuralTopReleaseType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralTopReleaseType {
    ForgeTypeId^ get ();
}
static member StructuralTopReleaseType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralWallBottomProjectionPlane Property

ParameterTypeIdStructuralWallBottomProjectionPlane Property

"Bottom Vertical Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralWallBottomProjectionPlane { get; }
Public Shared ReadOnly Property StructuralWallBottomProjectionPlane As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralWallBottomProjectionPlane {
    ForgeTypeId^ get ();
}
static member StructuralWallBottomProjectionPlane : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralWallProjectionSurface Property

ParameterTypeIdStructuralWallProjectionSurface Property

"Horizontal Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralWallProjectionSurface { get; }
Public Shared ReadOnly Property StructuralWallProjectionSurface As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralWallProjectionSurface {
    ForgeTypeId^ get ();
}
static member StructuralWallProjectionSurface : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.StructuralWallTopProjectionPlane Property

ParameterTypeIdStructuralWallTopProjectionPlane Property

"Top Vertical Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralWallTopProjectionPlane { get; }
Public Shared ReadOnly Property StructuralWallTopProjectionPlane As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralWallTopProjectionPlane {
    ForgeTypeId^ get ();
}
static member StructuralWallTopProjectionPlane : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SupportHandClearance Property

ParameterTypeIdSupportHandClearance Property

"Hand Clearance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SupportHandClearance { get; }
Public Shared ReadOnly Property SupportHandClearance As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SupportHandClearance {
    ForgeTypeId^ get ();
}
static member SupportHandClearance : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SupportHeight Property

ParameterTypeIdSupportHeight Property

"Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SupportHeight { get; }
Public Shared ReadOnly Property SupportHeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SupportHeight {
    ForgeTypeId^ get ();
}
static member SupportHeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SurfaceArea Property

ParameterTypeIdSurfaceArea Property

"Surface Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SurfaceArea { get; }
Public Shared ReadOnly Property SurfaceArea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SurfaceArea {
    ForgeTypeId^ get ();
}
static member SurfaceArea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SurfaceName Property

ParameterTypeIdSurfaceName Property

"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SurfaceName { get; }
Public Shared ReadOnly Property SurfaceName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SurfaceName {
    ForgeTypeId^ get ();
}
static member SurfaceName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SurfacePatternIdParam Property

ParameterTypeIdSurfacePatternIdParam Property

"Surface fill pattern"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SurfacePatternIdParam { get; }
Public Shared ReadOnly Property SurfacePatternIdParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SurfacePatternIdParam {
    ForgeTypeId^ get ();
}
static member SurfacePatternIdParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SurfacePerimeter Property

ParameterTypeIdSurfacePerimeter Property

"Perimeter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SurfacePerimeter { get; }
Public Shared ReadOnly Property SurfacePerimeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SurfacePerimeter {
    ForgeTypeId^ get ();
}
static member SurfacePerimeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SweepBaseFloorSubcategoryId Property

ParameterTypeIdSweepBaseFloorSubcategoryId Property

"Subcategory of Floors"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SweepBaseFloorSubcategoryId { get; }
Public Shared ReadOnly Property SweepBaseFloorSubcategoryId As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SweepBaseFloorSubcategoryId {
    ForgeTypeId^ get ();
}
static member SweepBaseFloorSubcategoryId : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SweepBaseOffset Property

ParameterTypeIdSweepBaseOffset Property

"Horizontal Profile Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SweepBaseOffset { get; }
Public Shared ReadOnly Property SweepBaseOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SweepBaseOffset {
    ForgeTypeId^ get ();
}
static member SweepBaseOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SweepBaseRoofSubcategoryId Property

ParameterTypeIdSweepBaseRoofSubcategoryId Property

"Subcategory of Roofs"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SweepBaseRoofSubcategoryId { get; }
Public Shared ReadOnly Property SweepBaseRoofSubcategoryId As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SweepBaseRoofSubcategoryId {
    ForgeTypeId^ get ();
}
static member SweepBaseRoofSubcategoryId : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SweepBaseVertOffset Property

ParameterTypeIdSweepBaseVertOffset Property

"Vertical Profile Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SweepBaseVertOffset { get; }
Public Shared ReadOnly Property SweepBaseVertOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SweepBaseVertOffset {
    ForgeTypeId^ get ();
}
static member SweepBaseVertOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SweepMaxSegAngle Property

ParameterTypeIdSweepMaxSegAngle Property

"Maximum Segment Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SweepMaxSegAngle { get; }
Public Shared ReadOnly Property SweepMaxSegAngle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SweepMaxSegAngle {
    ForgeTypeId^ get ();
}
static member SweepMaxSegAngle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SweepTrajSegmented Property

ParameterTypeIdSweepTrajSegmented Property

"Trajectory Segmentation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SweepTrajSegmented { get; }
Public Shared ReadOnly Property SweepTrajSegmented As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SweepTrajSegmented {
    ForgeTypeId^ get ();
}
static member SweepTrajSegmented : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SymbolFamilyAndTypeNamesParam Property

ParameterTypeIdSymbolFamilyAndTypeNamesParam Property

"Family and Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SymbolFamilyAndTypeNamesParam { get; }
Public Shared ReadOnly Property SymbolFamilyAndTypeNamesParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SymbolFamilyAndTypeNamesParam {
    ForgeTypeId^ get ();
}
static member SymbolFamilyAndTypeNamesParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SymbolFamilyNameParam Property

ParameterTypeIdSymbolFamilyNameParam Property

"Family Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SymbolFamilyNameParam { get; }
Public Shared ReadOnly Property SymbolFamilyNameParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SymbolFamilyNameParam {
    ForgeTypeId^ get ();
}
static member SymbolFamilyNameParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SymbolIdParam Property

ParameterTypeIdSymbolIdParam Property

"Type Id"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SymbolIdParam { get; }
Public Shared ReadOnly Property SymbolIdParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SymbolIdParam {
    ForgeTypeId^ get ();
}
static member SymbolIdParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SymbolNameParam Property

ParameterTypeIdSymbolNameParam Property

"Type Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SymbolNameParam { get; }
Public Shared ReadOnly Property SymbolNameParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SymbolNameParam {
    ForgeTypeId^ get ();
}
static member SymbolNameParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SystemEquipmentSets Property

ParameterTypeIdSystemEquipmentSets Property

"Equipment Sets"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SystemEquipmentSets { get; }
Public Shared ReadOnly Property SystemEquipmentSets As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SystemEquipmentSets {
    ForgeTypeId^ get ();
}
static member SystemEquipmentSets : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SystemsAnalysisReportFolder Property

ParameterTypeIdSystemsAnalysisReportFolder Property

"Reports Folder Path"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SystemsAnalysisReportFolder { get; }
Public Shared ReadOnly Property SystemsAnalysisReportFolder As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SystemsAnalysisReportFolder {
    ForgeTypeId^ get ();
}
static member SystemsAnalysisReportFolder : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SystemsAnalysisReportStyle Property

ParameterTypeIdSystemsAnalysisReportStyle Property

"Report Style"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SystemsAnalysisReportStyle { get; }
Public Shared ReadOnly Property SystemsAnalysisReportStyle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SystemsAnalysisReportStyle {
    ForgeTypeId^ get ();
}
static member SystemsAnalysisReportStyle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.SystemZoneLevelId Property

ParameterTypeIdSystemZoneLevelId Property

"Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SystemZoneLevelId { get; }
Public Shared ReadOnly Property SystemZoneLevelId As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SystemZoneLevelId {
    ForgeTypeId^ get ();
}
static member SystemZoneLevelId : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TagAngleParam Property

ParameterTypeIdTagAngleParam Property

"Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TagAngleParam { get; }
Public Shared ReadOnly Property TagAngleParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TagAngleParam {
    ForgeTypeId^ get ();
}
static member TagAngleParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TagElementCount Property

ParameterTypeIdTagElementCount Property

"Host Count"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TagElementCount { get; }
Public Shared ReadOnly Property TagElementCount As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TagElementCount {
    ForgeTypeId^ get ();
}
static member TagElementCount : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TagElevationBase Property

ParameterTypeIdTagElevationBase Property

"Elevation Base"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TagElevationBase { get; }
Public Shared ReadOnly Property TagElevationBase As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TagElevationBase {
    ForgeTypeId^ get ();
}
static member TagElevationBase : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TagHeadAlignment Property

ParameterTypeIdTagHeadAlignment Property

"Tag Alignment"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TagHeadAlignment { get; }
Public Shared ReadOnly Property TagHeadAlignment As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TagHeadAlignment {
    ForgeTypeId^ get ();
}
static member TagHeadAlignment : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TagHeadPosition Property

ParameterTypeIdTagHeadPosition Property

"Tag Position"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TagHeadPosition { get; }
Public Shared ReadOnly Property TagHeadPosition As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TagHeadPosition {
    ForgeTypeId^ get ();
}
static member TagHeadPosition : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TagLeaderType Property

ParameterTypeIdTagLeaderType Property

"Leader Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TagLeaderType { get; }
Public Shared ReadOnly Property TagLeaderType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TagLeaderType {
    ForgeTypeId^ get ();
}
static member TagLeaderType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TagNoBreakParamStrings Property

ParameterTypeIdTagNoBreakParamStrings Property

"Wrap between parameters only"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TagNoBreakParamStrings { get; }
Public Shared ReadOnly Property TagNoBreakParamStrings As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TagNoBreakParamStrings {
    ForgeTypeId^ get ();
}
static member TagNoBreakParamStrings : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TagOnPlacementUi Property

ParameterTypeIdTagOnPlacementUi Property

"Tag on Placement"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TagOnPlacementUi { get; }
Public Shared ReadOnly Property TagOnPlacementUi As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TagOnPlacementUi {
    ForgeTypeId^ get ();
}
static member TagOnPlacementUi : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TagOrientationBehavior Property

ParameterTypeIdTagOrientationBehavior Property

"Tag Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TagOrientationBehavior { get; }
Public Shared ReadOnly Property TagOrientationBehavior As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TagOrientationBehavior {
    ForgeTypeId^ get ();
}
static member TagOrientationBehavior : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TagOrientationParam Property

ParameterTypeIdTagOrientationParam Property

"Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TagOrientationParam { get; }
Public Shared ReadOnly Property TagOrientationParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TagOrientationParam {
    ForgeTypeId^ get ();
}
static member TagOrientationParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TagSampleText Property

ParameterTypeIdTagSampleText Property

"Sample Text"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TagSampleText { get; }
Public Shared ReadOnly Property TagSampleText As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TagSampleText {
    ForgeTypeId^ get ();
}
static member TagSampleText : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TagTag Property

ParameterTypeIdTagTag Property

"Label"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TagTag { get; }
Public Shared ReadOnly Property TagTag As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TagTag {
    ForgeTypeId^ get ();
}
static member TagTag : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TemplateName Property

ParameterTypeIdTemplateName Property

"Template"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TemplateName { get; }
Public Shared ReadOnly Property TemplateName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TemplateName {
    ForgeTypeId^ get ();
}
static member TemplateName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TerminationExtensionLength Property

ParameterTypeIdTerminationExtensionLength Property

"Extension Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TerminationExtensionLength { get; }
Public Shared ReadOnly Property TerminationExtensionLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TerminationExtensionLength {
    ForgeTypeId^ get ();
}
static member TerminationExtensionLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TextAlignHorz Property

ParameterTypeIdTextAlignHorz Property

"Horizontal Align"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TextAlignHorz { get; }
Public Shared ReadOnly Property TextAlignHorz As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TextAlignHorz {
    ForgeTypeId^ get ();
}
static member TextAlignHorz : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TextAlignment Property

ParameterTypeIdTextAlignment Property

"Text Alignment"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TextAlignment { get; }
Public Shared ReadOnly Property TextAlignment As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TextAlignment {
    ForgeTypeId^ get ();
}
static member TextAlignment : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TextAlignVert Property

ParameterTypeIdTextAlignVert Property

"Vertical Align"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TextAlignVert { get; }
Public Shared ReadOnly Property TextAlignVert As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TextAlignVert {
    ForgeTypeId^ get ();
}
static member TextAlignVert : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TextBackground Property

ParameterTypeIdTextBackground Property

"Background"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TextBackground { get; }
Public Shared ReadOnly Property TextBackground As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TextBackground {
    ForgeTypeId^ get ();
}
static member TextBackground : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TextBoxVisibility Property

ParameterTypeIdTextBoxVisibility Property

"Show Border"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TextBoxVisibility { get; }
Public Shared ReadOnly Property TextBoxVisibility As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TextBoxVisibility {
    ForgeTypeId^ get ();
}
static member TextBoxVisibility : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TextColor Property

ParameterTypeIdTextColor Property

"Color"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TextColor { get; }
Public Shared ReadOnly Property TextColor As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TextColor {
    ForgeTypeId^ get ();
}
static member TextColor : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TextDistToLine Property

ParameterTypeIdTextDistToLine Property

"Text Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TextDistToLine { get; }
Public Shared ReadOnly Property TextDistToLine As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TextDistToLine {
    ForgeTypeId^ get ();
}
static member TextDistToLine : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TextFont Property

ParameterTypeIdTextFont Property

"Text Font"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TextFont { get; }
Public Shared ReadOnly Property TextFont As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TextFont {
    ForgeTypeId^ get ();
}
static member TextFont : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TextPosition Property

ParameterTypeIdTextPosition Property

"Text Position"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TextPosition { get; }
Public Shared ReadOnly Property TextPosition As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TextPosition {
    ForgeTypeId^ get ();
}
static member TextPosition : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TextSize Property

ParameterTypeIdTextSize Property

"Text Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TextSize { get; }
Public Shared ReadOnly Property TextSize As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TextSize {
    ForgeTypeId^ get ();
}
static member TextSize : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TextStyleBold Property

ParameterTypeIdTextStyleBold Property

"Bold"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TextStyleBold { get; }
Public Shared ReadOnly Property TextStyleBold As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TextStyleBold {
    ForgeTypeId^ get ();
}
static member TextStyleBold : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TextStyleFont Property

ParameterTypeIdTextStyleFont Property

"Font"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TextStyleFont { get; }
Public Shared ReadOnly Property TextStyleFont As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TextStyleFont {
    ForgeTypeId^ get ();
}
static member TextStyleFont : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TextStyleItalic Property

ParameterTypeIdTextStyleItalic Property

"Italic"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TextStyleItalic { get; }
Public Shared ReadOnly Property TextStyleItalic As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TextStyleItalic {
    ForgeTypeId^ get ();
}
static member TextStyleItalic : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TextStyleSize Property

ParameterTypeIdTextStyleSize Property

"Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TextStyleSize { get; }
Public Shared ReadOnly Property TextStyleSize As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TextStyleSize {
    ForgeTypeId^ get ();
}
static member TextStyleSize : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TextStyleUnderline Property

ParameterTypeIdTextStyleUnderline Property

"Underline"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TextStyleUnderline { get; }
Public Shared ReadOnly Property TextStyleUnderline As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TextStyleUnderline {
    ForgeTypeId^ get ();
}
static member TextStyleUnderline : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TextTabSize Property

ParameterTypeIdTextTabSize Property

"Tab Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TextTabSize { get; }
Public Shared ReadOnly Property TextTabSize As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TextTabSize {
    ForgeTypeId^ get ();
}
static member TextTabSize : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TextText Property

ParameterTypeIdTextText Property

"Text"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TextText { get; }
Public Shared ReadOnly Property TextText As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TextText {
    ForgeTypeId^ get ();
}
static member TextText : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TextWidthScale Property

ParameterTypeIdTextWidthScale Property

"Width Factor"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TextWidthScale { get; }
Public Shared ReadOnly Property TextWidthScale As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TextWidthScale {
    ForgeTypeId^ get ();
}
static member TextWidthScale : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ThermalMaterialConductivity Property

ParameterTypeIdThermalMaterialConductivity Property

"Thermal Conductivity"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ThermalMaterialConductivity { get; }
Public Shared ReadOnly Property ThermalMaterialConductivity As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ThermalMaterialConductivity {
    ForgeTypeId^ get ();
}
static member ThermalMaterialConductivity : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ThermalMaterialDensity Property

ParameterTypeIdThermalMaterialDensity Property

"Density"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ThermalMaterialDensity { get; }
Public Shared ReadOnly Property ThermalMaterialDensity As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ThermalMaterialDensity {
    ForgeTypeId^ get ();
}
static member ThermalMaterialDensity : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ThermalMaterialDescription Property

ParameterTypeIdThermalMaterialDescription Property

"Description"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ThermalMaterialDescription { get; }
Public Shared ReadOnly Property ThermalMaterialDescription As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ThermalMaterialDescription {
    ForgeTypeId^ get ();
}
static member ThermalMaterialDescription : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ThermalMaterialName Property

ParameterTypeIdThermalMaterialName Property

"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ThermalMaterialName { get; }
Public Shared ReadOnly Property ThermalMaterialName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ThermalMaterialName {
    ForgeTypeId^ get ();
}
static member ThermalMaterialName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ThermalMaterialParamCompressibility Property

ParameterTypeIdThermalMaterialParamCompressibility Property

"Compressibility"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ThermalMaterialParamCompressibility { get; }
Public Shared ReadOnly Property ThermalMaterialParamCompressibility As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ThermalMaterialParamCompressibility {
    ForgeTypeId^ get ();
}
static member ThermalMaterialParamCompressibility : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ThermalMaterialParamElectricalResistivity Property

ParameterTypeIdThermalMaterialParamElectricalResistivity Property

"Electrical Resistivity"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ThermalMaterialParamElectricalResistivity { get; }
Public Shared ReadOnly Property ThermalMaterialParamElectricalResistivity As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ThermalMaterialParamElectricalResistivity {
    ForgeTypeId^ get ();
}
static member ThermalMaterialParamElectricalResistivity : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ThermalMaterialParamEmissivity Property

ParameterTypeIdThermalMaterialParamEmissivity Property

"Emissivity"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ThermalMaterialParamEmissivity { get; }
Public Shared ReadOnly Property ThermalMaterialParamEmissivity As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ThermalMaterialParamEmissivity {
    ForgeTypeId^ get ();
}
static member ThermalMaterialParamEmissivity : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ThermalMaterialParamGasViscosity Property

ParameterTypeIdThermalMaterialParamGasViscosity Property

"Gas Viscosity"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ThermalMaterialParamGasViscosity { get; }
Public Shared ReadOnly Property ThermalMaterialParamGasViscosity As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ThermalMaterialParamGasViscosity {
    ForgeTypeId^ get ();
}
static member ThermalMaterialParamGasViscosity : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ThermalMaterialParamLiquidViscosity Property

ParameterTypeIdThermalMaterialParamLiquidViscosity Property

"Liquid Viscosity"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ThermalMaterialParamLiquidViscosity { get; }
Public Shared ReadOnly Property ThermalMaterialParamLiquidViscosity As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ThermalMaterialParamLiquidViscosity {
    ForgeTypeId^ get ();
}
static member ThermalMaterialParamLiquidViscosity : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ThermalMaterialParamPermeability Property

ParameterTypeIdThermalMaterialParamPermeability Property

"Permeability"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ThermalMaterialParamPermeability { get; }
Public Shared ReadOnly Property ThermalMaterialParamPermeability As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ThermalMaterialParamPermeability {
    ForgeTypeId^ get ();
}
static member ThermalMaterialParamPermeability : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ThermalMaterialParamPorosity Property

ParameterTypeIdThermalMaterialParamPorosity Property

"Porosity"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ThermalMaterialParamPorosity { get; }
Public Shared ReadOnly Property ThermalMaterialParamPorosity As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ThermalMaterialParamPorosity {
    ForgeTypeId^ get ();
}
static member ThermalMaterialParamPorosity : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ThermalMaterialParamReflectivity Property

ParameterTypeIdThermalMaterialParamReflectivity Property

"Reflectivity"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ThermalMaterialParamReflectivity { get; }
Public Shared ReadOnly Property ThermalMaterialParamReflectivity As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ThermalMaterialParamReflectivity {
    ForgeTypeId^ get ();
}
static member ThermalMaterialParamReflectivity : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ThermalMaterialParamSpecificHeatOfVaporization Property

ParameterTypeIdThermalMaterialParamSpecificHeatOfVaporization Property

"Specific Heat of Vaporization"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ThermalMaterialParamSpecificHeatOfVaporization { get; }
Public Shared ReadOnly Property ThermalMaterialParamSpecificHeatOfVaporization As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ThermalMaterialParamSpecificHeatOfVaporization {
    ForgeTypeId^ get ();
}
static member ThermalMaterialParamSpecificHeatOfVaporization : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ThermalMaterialParamTransmitsLight Property

ParameterTypeIdThermalMaterialParamTransmitsLight Property

"Transmits Light"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ThermalMaterialParamTransmitsLight { get; }
Public Shared ReadOnly Property ThermalMaterialParamTransmitsLight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ThermalMaterialParamTransmitsLight {
    ForgeTypeId^ get ();
}
static member ThermalMaterialParamTransmitsLight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ThermalMaterialParamVaporPressure Property

ParameterTypeIdThermalMaterialParamVaporPressure Property

"Vapor Pressure"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ThermalMaterialParamVaporPressure { get; }
Public Shared ReadOnly Property ThermalMaterialParamVaporPressure As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ThermalMaterialParamVaporPressure {
    ForgeTypeId^ get ();
}
static member ThermalMaterialParamVaporPressure : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ThermalMaterialSpecificHeatCapacity Property

ParameterTypeIdThermalMaterialSpecificHeatCapacity Property

"Specific Heat Capacity"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ThermalMaterialSpecificHeatCapacity { get; }
Public Shared ReadOnly Property ThermalMaterialSpecificHeatCapacity As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ThermalMaterialSpecificHeatCapacity {
    ForgeTypeId^ get ();
}
static member ThermalMaterialSpecificHeatCapacity : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ThermalMaterialThickness Property

ParameterTypeIdThermalMaterialThickness Property

"Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ThermalMaterialThickness { get; }
Public Shared ReadOnly Property ThermalMaterialThickness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ThermalMaterialThickness {
    ForgeTypeId^ get ();
}
static member ThermalMaterialThickness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TickMarkPen Property

ParameterTypeIdTickMarkPen Property

"Tick Mark Line Weight"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TickMarkPen { get; }
Public Shared ReadOnly Property TickMarkPen As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TickMarkPen {
    ForgeTypeId^ get ();
}
static member TickMarkPen : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TilePatternFamrefComponentExtents Property

ParameterTypeIdTilePatternFamrefComponentExtents Property

"Component Extents"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TilePatternFamrefComponentExtents { get; }
Public Shared ReadOnly Property TilePatternFamrefComponentExtents As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TilePatternFamrefComponentExtents {
    ForgeTypeId^ get ();
}
static member TilePatternFamrefComponentExtents : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TilePatternGridCellsX Property

ParameterTypeIdTilePatternGridCellsX Property

"Number of horizontal cells"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TilePatternGridCellsX { get; }
Public Shared ReadOnly Property TilePatternGridCellsX As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TilePatternGridCellsX {
    ForgeTypeId^ get ();
}
static member TilePatternGridCellsX : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TilePatternGridCellsY Property

ParameterTypeIdTilePatternGridCellsY Property

"Number of vertical cells"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TilePatternGridCellsY { get; }
Public Shared ReadOnly Property TilePatternGridCellsY As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TilePatternGridCellsY {
    ForgeTypeId^ get ();
}
static member TilePatternGridCellsY : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TilePatternGridUnitX Property

ParameterTypeIdTilePatternGridUnitX Property

"Horizontal spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TilePatternGridUnitX { get; }
Public Shared ReadOnly Property TilePatternGridUnitX As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TilePatternGridUnitX {
    ForgeTypeId^ get ();
}
static member TilePatternGridUnitX : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TilePatternGridUnitY Property

ParameterTypeIdTilePatternGridUnitY Property

"Vertical spacing"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TilePatternGridUnitY { get; }
Public Shared ReadOnly Property TilePatternGridUnitY As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TilePatternGridUnitY {
    ForgeTypeId^ get ();
}
static member TilePatternGridUnitY : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.Tilt Property

ParameterTypeIdTilt Property

"Tilt"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Tilt { get; }
Public Shared ReadOnly Property Tilt As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Tilt {
    ForgeTypeId^ get ();
}
static member Tilt : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TitleFont Property

ParameterTypeIdTitleFont Property

"Font"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TitleFont { get; }
Public Shared ReadOnly Property TitleFont As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TitleFont {
    ForgeTypeId^ get ();
}
static member TitleFont : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TitleSize Property

ParameterTypeIdTitleSize Property

"Size"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TitleSize { get; }
Public Shared ReadOnly Property TitleSize As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TitleSize {
    ForgeTypeId^ get ();
}
static member TitleSize : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TitleStyleBold Property

ParameterTypeIdTitleStyleBold Property

"Bold"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TitleStyleBold { get; }
Public Shared ReadOnly Property TitleStyleBold As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TitleStyleBold {
    ForgeTypeId^ get ();
}
static member TitleStyleBold : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TitleStyleItalic Property

ParameterTypeIdTitleStyleItalic Property

"Italic"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TitleStyleItalic { get; }
Public Shared ReadOnly Property TitleStyleItalic As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TitleStyleItalic {
    ForgeTypeId^ get ();
}
static member TitleStyleItalic : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TitleStyleUnderline Property

ParameterTypeIdTitleStyleUnderline Property

"Underline"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TitleStyleUnderline { get; }
Public Shared ReadOnly Property TitleStyleUnderline As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TitleStyleUnderline {
    ForgeTypeId^ get ();
}
static member TitleStyleUnderline : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TopographyLinkName Property

ParameterTypeIdTopographyLinkName Property

"Link Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TopographyLinkName { get; }
Public Shared ReadOnly Property TopographyLinkName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TopographyLinkName {
    ForgeTypeId^ get ();
}
static member TopographyLinkName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TopographyLinkPath Property

ParameterTypeIdTopographyLinkPath Property

"Saved Path"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TopographyLinkPath { get; }
Public Shared ReadOnly Property TopographyLinkPath As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TopographyLinkPath {
    ForgeTypeId^ get ();
}
static member TopographyLinkPath : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ToposolidAttrThicknessParam Property

ParameterTypeIdToposolidAttrThicknessParam Property

"Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ToposolidAttrThicknessParam { get; }
Public Shared ReadOnly Property ToposolidAttrThicknessParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ToposolidAttrThicknessParam {
    ForgeTypeId^ get ();
}
static member ToposolidAttrThicknessParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ToposolidContourDisplaySettingsIdParam Property

ParameterTypeIdToposolidContourDisplaySettingsIdParam Property

"Contour Display"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ToposolidContourDisplaySettingsIdParam { get; }
Public Shared ReadOnly Property ToposolidContourDisplaySettingsIdParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ToposolidContourDisplaySettingsIdParam {
    ForgeTypeId^ get ();
}
static member ToposolidContourDisplaySettingsIdParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ToposolidContourSubcategoryId Property

ParameterTypeIdToposolidContourSubcategoryId Property

"Subcategory"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ToposolidContourSubcategoryId { get; }
Public Shared ReadOnly Property ToposolidContourSubcategoryId As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ToposolidContourSubcategoryId {
    ForgeTypeId^ get ();
}
static member ToposolidContourSubcategoryId : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ToposolidElevationAtBottom Property

ParameterTypeIdToposolidElevationAtBottom Property

"Elevation at Bottom"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ToposolidElevationAtBottom { get; }
Public Shared ReadOnly Property ToposolidElevationAtBottom As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ToposolidElevationAtBottom {
    ForgeTypeId^ get ();
}
static member ToposolidElevationAtBottom : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ToposolidElevationAtTop Property

ParameterTypeIdToposolidElevationAtTop Property

"Elevation at Top"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ToposolidElevationAtTop { get; }
Public Shared ReadOnly Property ToposolidElevationAtTop As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ToposolidElevationAtTop {
    ForgeTypeId^ get ();
}
static member ToposolidElevationAtTop : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ToposolidFacesLocation Property

ParameterTypeIdToposolidFacesLocation Property

"Picked Faces Location"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ToposolidFacesLocation { get; }
Public Shared ReadOnly Property ToposolidFacesLocation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ToposolidFacesLocation {
    ForgeTypeId^ get ();
}
static member ToposolidFacesLocation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ToposolidFunctionParam Property

ParameterTypeIdToposolidFunctionParam Property

"Function"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ToposolidFunctionParam { get; }
Public Shared ReadOnly Property ToposolidFunctionParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ToposolidFunctionParam {
    ForgeTypeId^ get ();
}
static member ToposolidFunctionParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ToposolidHeightabovelevelParam Property

ParameterTypeIdToposolidHeightabovelevelParam Property

"Height Offset From Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ToposolidHeightabovelevelParam { get; }
Public Shared ReadOnly Property ToposolidHeightabovelevelParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ToposolidHeightabovelevelParam {
    ForgeTypeId^ get ();
}
static member ToposolidHeightabovelevelParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ToposolidInheritContours Property

ParameterTypeIdToposolidInheritContours Property

"Inherit Contours"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ToposolidInheritContours { get; }
Public Shared ReadOnly Property ToposolidInheritContours As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ToposolidInheritContours {
    ForgeTypeId^ get ();
}
static member ToposolidInheritContours : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ToposolidStructureIdParam Property

ParameterTypeIdToposolidStructureIdParam Property

"Structure"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ToposolidStructureIdParam { get; }
Public Shared ReadOnly Property ToposolidStructureIdParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ToposolidStructureIdParam {
    ForgeTypeId^ get ();
}
static member ToposolidStructureIdParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ToposolidSubdivideHeight Property

ParameterTypeIdToposolidSubdivideHeight Property

"Sub-divide Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ToposolidSubdivideHeight { get; }
Public Shared ReadOnly Property ToposolidSubdivideHeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ToposolidSubdivideHeight {
    ForgeTypeId^ get ();
}
static member ToposolidSubdivideHeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ToposolidSubdivideMaterial Property

ParameterTypeIdToposolidSubdivideMaterial Property

"Material"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ToposolidSubdivideMaterial { get; }
Public Shared ReadOnly Property ToposolidSubdivideMaterial As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ToposolidSubdivideMaterial {
    ForgeTypeId^ get ();
}
static member ToposolidSubdivideMaterial : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ToposolidTypeDefaultThicknessParam Property

ParameterTypeIdToposolidTypeDefaultThicknessParam Property

"Default Thickness"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ToposolidTypeDefaultThicknessParam { get; }
Public Shared ReadOnly Property ToposolidTypeDefaultThicknessParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ToposolidTypeDefaultThicknessParam {
    ForgeTypeId^ get ();
}
static member ToposolidTypeDefaultThicknessParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ToposurfaceContourSubcategoryId Property

ParameterTypeIdToposurfaceContourSubcategoryId Property

"Subcategory"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ToposurfaceContourSubcategoryId { get; }
Public Shared ReadOnly Property ToposurfaceContourSubcategoryId As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ToposurfaceContourSubcategoryId {
    ForgeTypeId^ get ();
}
static member ToposurfaceContourSubcategoryId : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TotalExcavationVolume Property

ParameterTypeIdTotalExcavationVolume Property

"Total Excavation Volume"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TotalExcavationVolume { get; }
Public Shared ReadOnly Property TotalExcavationVolume As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TotalExcavationVolume {
    ForgeTypeId^ get ();
}
static member TotalExcavationVolume : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TrapMullWidth Property

ParameterTypeIdTrapMullWidth Property

"Center Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TrapMullWidth { get; }
Public Shared ReadOnly Property TrapMullWidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TrapMullWidth {
    ForgeTypeId^ get ();
}
static member TrapMullWidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TrussBearingChordTopBottomParam Property

ParameterTypeIdTrussBearingChordTopBottomParam Property

"Bearing Chord"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TrussBearingChordTopBottomParam { get; }
Public Shared ReadOnly Property TrussBearingChordTopBottomParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TrussBearingChordTopBottomParam {
    ForgeTypeId^ get ();
}
static member TrussBearingChordTopBottomParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TrussElementAngleParam Property

ParameterTypeIdTrussElementAngleParam Property

"Rotation Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TrussElementAngleParam { get; }
Public Shared ReadOnly Property TrussElementAngleParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TrussElementAngleParam {
    ForgeTypeId^ get ();
}
static member TrussElementAngleParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TrussElementBearingJustParam Property

ParameterTypeIdTrussElementBearingJustParam Property

"Bearing Vertical Justification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TrussElementBearingJustParam { get; }
Public Shared ReadOnly Property TrussElementBearingJustParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TrussElementBearingJustParam {
    ForgeTypeId^ get ();
}
static member TrussElementBearingJustParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TrussElementClassParam Property

ParameterTypeIdTrussElementClassParam Property

"Engineering Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TrussElementClassParam { get; }
Public Shared ReadOnly Property TrussElementClassParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TrussElementClassParam {
    ForgeTypeId^ get ();
}
static member TrussElementClassParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TrussElementCreateBottomParam Property

ParameterTypeIdTrussElementCreateBottomParam Property

"Create Bottom Chord"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TrussElementCreateBottomParam { get; }
Public Shared ReadOnly Property TrussElementCreateBottomParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TrussElementCreateBottomParam {
    ForgeTypeId^ get ();
}
static member TrussElementCreateBottomParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TrussElementCreateTopParam Property

ParameterTypeIdTrussElementCreateTopParam Property

"Create Top Chord"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TrussElementCreateTopParam { get; }
Public Shared ReadOnly Property TrussElementCreateTopParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TrussElementCreateTopParam {
    ForgeTypeId^ get ();
}
static member TrussElementCreateTopParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TrussElementEnd0Elevation Property

ParameterTypeIdTrussElementEnd0Elevation Property

"Start Level Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TrussElementEnd0Elevation { get; }
Public Shared ReadOnly Property TrussElementEnd0Elevation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TrussElementEnd0Elevation {
    ForgeTypeId^ get ();
}
static member TrussElementEnd0Elevation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TrussElementEnd1Elevation Property

ParameterTypeIdTrussElementEnd1Elevation Property

"End Level Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TrussElementEnd1Elevation { get; }
Public Shared ReadOnly Property TrussElementEnd1Elevation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TrussElementEnd1Elevation {
    ForgeTypeId^ get ();
}
static member TrussElementEnd1Elevation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TrussElementReferenceLevelParam Property

ParameterTypeIdTrussElementReferenceLevelParam Property

"Reference Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TrussElementReferenceLevelParam { get; }
Public Shared ReadOnly Property TrussElementReferenceLevelParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TrussElementReferenceLevelParam {
    ForgeTypeId^ get ();
}
static member TrussElementReferenceLevelParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TrussElementRotateChordsWithTruss Property

ParameterTypeIdTrussElementRotateChordsWithTruss Property

"Rotate Chords With Truss"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TrussElementRotateChordsWithTruss { get; }
Public Shared ReadOnly Property TrussElementRotateChordsWithTruss As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TrussElementRotateChordsWithTruss {
    ForgeTypeId^ get ();
}
static member TrussElementRotateChordsWithTruss : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TrussElementSpanParam Property

ParameterTypeIdTrussElementSpanParam Property

"Span"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TrussElementSpanParam { get; }
Public Shared ReadOnly Property TrussElementSpanParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TrussElementSpanParam {
    ForgeTypeId^ get ();
}
static member TrussElementSpanParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TrussElementStickJustParam Property

ParameterTypeIdTrussElementStickJustParam Property

"Stick Symbol Location"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TrussElementStickJustParam { get; }
Public Shared ReadOnly Property TrussElementStickJustParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TrussElementStickJustParam {
    ForgeTypeId^ get ();
}
static member TrussElementStickJustParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TrussElementTagNewMembersView Property

ParameterTypeIdTrussElementTagNewMembersView Property

"Tag new members in view"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TrussElementTagNewMembersView { get; }
Public Shared ReadOnly Property TrussElementTagNewMembersView As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TrussElementTagNewMembersView {
    ForgeTypeId^ get ();
}
static member TrussElementTagNewMembersView : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TrussFamilyBottomChordAngleParam Property

ParameterTypeIdTrussFamilyBottomChordAngleParam Property

"Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TrussFamilyBottomChordAngleParam { get; }
Public Shared ReadOnly Property TrussFamilyBottomChordAngleParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TrussFamilyBottomChordAngleParam {
    ForgeTypeId^ get ();
}
static member TrussFamilyBottomChordAngleParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TrussFamilyBottomChordEndReleaseType Property

ParameterTypeIdTrussFamilyBottomChordEndReleaseType Property

"End Release"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TrussFamilyBottomChordEndReleaseType { get; }
Public Shared ReadOnly Property TrussFamilyBottomChordEndReleaseType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TrussFamilyBottomChordEndReleaseType {
    ForgeTypeId^ get ();
}
static member TrussFamilyBottomChordEndReleaseType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TrussFamilyBottomChordStartReleaseType Property

ParameterTypeIdTrussFamilyBottomChordStartReleaseType Property

"Start Release"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TrussFamilyBottomChordStartReleaseType { get; }
Public Shared ReadOnly Property TrussFamilyBottomChordStartReleaseType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TrussFamilyBottomChordStartReleaseType {
    ForgeTypeId^ get ();
}
static member TrussFamilyBottomChordStartReleaseType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TrussFamilyBottomChordStructuralTypesParam Property

ParameterTypeIdTrussFamilyBottomChordStructuralTypesParam Property

"Structural Framing Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TrussFamilyBottomChordStructuralTypesParam { get; }
Public Shared ReadOnly Property TrussFamilyBottomChordStructuralTypesParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TrussFamilyBottomChordStructuralTypesParam {
    ForgeTypeId^ get ();
}
static member TrussFamilyBottomChordStructuralTypesParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TrussFamilyBottomChordVerticalProjectionParam Property

ParameterTypeIdTrussFamilyBottomChordVerticalProjectionParam Property

"Analytical Vertical Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TrussFamilyBottomChordVerticalProjectionParam { get; }
Public Shared ReadOnly Property TrussFamilyBottomChordVerticalProjectionParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TrussFamilyBottomChordVerticalProjectionParam {
    ForgeTypeId^ get ();
}
static member TrussFamilyBottomChordVerticalProjectionParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TrussFamilyDiagWebAngleParam Property

ParameterTypeIdTrussFamilyDiagWebAngleParam Property

"Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TrussFamilyDiagWebAngleParam { get; }
Public Shared ReadOnly Property TrussFamilyDiagWebAngleParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TrussFamilyDiagWebAngleParam {
    ForgeTypeId^ get ();
}
static member TrussFamilyDiagWebAngleParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TrussFamilyDiagWebEndReleaseType Property

ParameterTypeIdTrussFamilyDiagWebEndReleaseType Property

"End Release"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TrussFamilyDiagWebEndReleaseType { get; }
Public Shared ReadOnly Property TrussFamilyDiagWebEndReleaseType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TrussFamilyDiagWebEndReleaseType {
    ForgeTypeId^ get ();
}
static member TrussFamilyDiagWebEndReleaseType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TrussFamilyDiagWebStartReleaseType Property

ParameterTypeIdTrussFamilyDiagWebStartReleaseType Property

"Start Release"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TrussFamilyDiagWebStartReleaseType { get; }
Public Shared ReadOnly Property TrussFamilyDiagWebStartReleaseType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TrussFamilyDiagWebStartReleaseType {
    ForgeTypeId^ get ();
}
static member TrussFamilyDiagWebStartReleaseType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TrussFamilyDiagWebStructuralTypesParam Property

ParameterTypeIdTrussFamilyDiagWebStructuralTypesParam Property

"Structural Framing Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TrussFamilyDiagWebStructuralTypesParam { get; }
Public Shared ReadOnly Property TrussFamilyDiagWebStructuralTypesParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TrussFamilyDiagWebStructuralTypesParam {
    ForgeTypeId^ get ();
}
static member TrussFamilyDiagWebStructuralTypesParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TrussFamilyTopChordAngleParam Property

ParameterTypeIdTrussFamilyTopChordAngleParam Property

"Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TrussFamilyTopChordAngleParam { get; }
Public Shared ReadOnly Property TrussFamilyTopChordAngleParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TrussFamilyTopChordAngleParam {
    ForgeTypeId^ get ();
}
static member TrussFamilyTopChordAngleParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TrussFamilyTopChordEndReleaseType Property

ParameterTypeIdTrussFamilyTopChordEndReleaseType Property

"End Release"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TrussFamilyTopChordEndReleaseType { get; }
Public Shared ReadOnly Property TrussFamilyTopChordEndReleaseType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TrussFamilyTopChordEndReleaseType {
    ForgeTypeId^ get ();
}
static member TrussFamilyTopChordEndReleaseType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TrussFamilyTopChordStartReleaseType Property

ParameterTypeIdTrussFamilyTopChordStartReleaseType Property

"Start Release"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TrussFamilyTopChordStartReleaseType { get; }
Public Shared ReadOnly Property TrussFamilyTopChordStartReleaseType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TrussFamilyTopChordStartReleaseType {
    ForgeTypeId^ get ();
}
static member TrussFamilyTopChordStartReleaseType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TrussFamilyTopChordStructuralTypesParam Property

ParameterTypeIdTrussFamilyTopChordStructuralTypesParam Property

"Structural Framing Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TrussFamilyTopChordStructuralTypesParam { get; }
Public Shared ReadOnly Property TrussFamilyTopChordStructuralTypesParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TrussFamilyTopChordStructuralTypesParam {
    ForgeTypeId^ get ();
}
static member TrussFamilyTopChordStructuralTypesParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TrussFamilyTopChordVerticalProjectionParam Property

ParameterTypeIdTrussFamilyTopChordVerticalProjectionParam Property

"Analytical Vertical Projection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TrussFamilyTopChordVerticalProjectionParam { get; }
Public Shared ReadOnly Property TrussFamilyTopChordVerticalProjectionParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TrussFamilyTopChordVerticalProjectionParam {
    ForgeTypeId^ get ();
}
static member TrussFamilyTopChordVerticalProjectionParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TrussFamilyTransformationParam Property

ParameterTypeIdTrussFamilyTransformationParam Property

"Web Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TrussFamilyTransformationParam { get; }
Public Shared ReadOnly Property TrussFamilyTransformationParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TrussFamilyTransformationParam {
    ForgeTypeId^ get ();
}
static member TrussFamilyTransformationParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TrussFamilyVertWebAngleParam Property

ParameterTypeIdTrussFamilyVertWebAngleParam Property

"Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TrussFamilyVertWebAngleParam { get; }
Public Shared ReadOnly Property TrussFamilyVertWebAngleParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TrussFamilyVertWebAngleParam {
    ForgeTypeId^ get ();
}
static member TrussFamilyVertWebAngleParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TrussFamilyVertWebEndReleaseType Property

ParameterTypeIdTrussFamilyVertWebEndReleaseType Property

"End Release"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TrussFamilyVertWebEndReleaseType { get; }
Public Shared ReadOnly Property TrussFamilyVertWebEndReleaseType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TrussFamilyVertWebEndReleaseType {
    ForgeTypeId^ get ();
}
static member TrussFamilyVertWebEndReleaseType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TrussFamilyVertWebStartReleaseType Property

ParameterTypeIdTrussFamilyVertWebStartReleaseType Property

"Start Release"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TrussFamilyVertWebStartReleaseType { get; }
Public Shared ReadOnly Property TrussFamilyVertWebStartReleaseType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TrussFamilyVertWebStartReleaseType {
    ForgeTypeId^ get ();
}
static member TrussFamilyVertWebStartReleaseType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TrussFamilyVertWebStructuralTypesParam Property

ParameterTypeIdTrussFamilyVertWebStructuralTypesParam Property

"Structural Framing Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TrussFamilyVertWebStructuralTypesParam { get; }
Public Shared ReadOnly Property TrussFamilyVertWebStructuralTypesParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TrussFamilyVertWebStructuralTypesParam {
    ForgeTypeId^ get ();
}
static member TrussFamilyVertWebStructuralTypesParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TrussFamilyWebsHaveSymbolicCutbackParam Property

ParameterTypeIdTrussFamilyWebsHaveSymbolicCutbackParam Property

"Webs have symbolic cutback"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TrussFamilyWebsHaveSymbolicCutbackParam { get; }
Public Shared ReadOnly Property TrussFamilyWebsHaveSymbolicCutbackParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TrussFamilyWebsHaveSymbolicCutbackParam {
    ForgeTypeId^ get ();
}
static member TrussFamilyWebsHaveSymbolicCutbackParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TrussHeight Property

ParameterTypeIdTrussHeight Property

"Truss Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TrussHeight { get; }
Public Shared ReadOnly Property TrussHeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TrussHeight {
    ForgeTypeId^ get ();
}
static member TrussHeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TrussLength Property

ParameterTypeIdTrussLength Property

"Truss Length"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TrussLength { get; }
Public Shared ReadOnly Property TrussLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TrussLength {
    ForgeTypeId^ get ();
}
static member TrussLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TrussNonBearingOffsetParam Property

ParameterTypeIdTrussNonBearingOffsetParam Property

"Non Bearing Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TrussNonBearingOffsetParam { get; }
Public Shared ReadOnly Property TrussNonBearingOffsetParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TrussNonBearingOffsetParam {
    ForgeTypeId^ get ();
}
static member TrussNonBearingOffsetParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.TypeWallClosure Property

ParameterTypeIdTypeWallClosure Property

"Wall Closure"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TypeWallClosure { get; }
Public Shared ReadOnly Property TypeWallClosure As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TypeWallClosure {
    ForgeTypeId^ get ();
}
static member TypeWallClosure : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.UniformatCode Property

ParameterTypeIdUniformatCode Property

"Assembly Code"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId UniformatCode { get; }
Public Shared ReadOnly Property UniformatCode As ForgeTypeId
    Get
public:
static property ForgeTypeId^ UniformatCode {
    ForgeTypeId^ get ();
}
static member UniformatCode : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.UniformatDescription Property

ParameterTypeIdUniformatDescription Property

"Assembly Description"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId UniformatDescription { get; }
Public Shared ReadOnly Property UniformatDescription As ForgeTypeId
    Get
public:
static property ForgeTypeId^ UniformatDescription {
    ForgeTypeId^ get ();
}
static member UniformatDescription : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.Use3dSnapping Property

ParameterTypeIdUse3dSnapping Property

"3D Snapping"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Use3dSnapping { get; }
Public Shared ReadOnly Property Use3dSnapping As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Use3dSnapping {
    ForgeTypeId^ get ();
}
static member Use3dSnapping : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.UsingMultiple Property

ParameterTypeIdUsingMultiple Property

"Multiple Join"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId UsingMultiple { get; }
Public Shared ReadOnly Property UsingMultiple As ForgeTypeId
    Get
public:
static property ForgeTypeId^ UsingMultiple {
    ForgeTypeId^ get ();
}
static member UsingMultiple : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewAnalysisDisplayStyle Property

ParameterTypeIdViewAnalysisDisplayStyle Property

"Default Analysis Display Style"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewAnalysisDisplayStyle { get; }
Public Shared ReadOnly Property ViewAnalysisDisplayStyle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewAnalysisDisplayStyle {
    ForgeTypeId^ get ();
}
static member ViewAnalysisDisplayStyle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewAnalysisResultsVisibility Property

ParameterTypeIdViewAnalysisResultsVisibility Property

"Analysis Display Settings"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewAnalysisResultsVisibility { get; }
Public Shared ReadOnly Property ViewAnalysisResultsVisibility As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewAnalysisResultsVisibility {
    ForgeTypeId^ get ();
}
static member ViewAnalysisResultsVisibility : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewAssociatedAssemblyInstanceId Property

ParameterTypeIdViewAssociatedAssemblyInstanceId Property

"Associated Assembly Instance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewAssociatedAssemblyInstanceId { get; }
Public Shared ReadOnly Property ViewAssociatedAssemblyInstanceId As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewAssociatedAssemblyInstanceId {
    ForgeTypeId^ get ();
}
static member ViewAssociatedAssemblyInstanceId : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewBackClipping Property

ParameterTypeIdViewBackClipping Property

"Depth Clipping"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewBackClipping { get; }
Public Shared ReadOnly Property ViewBackClipping As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewBackClipping {
    ForgeTypeId^ get ();
}
static member ViewBackClipping : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewCameraOrientation Property

ParameterTypeIdViewCameraOrientation Property

"Locked Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewCameraOrientation { get; }
Public Shared ReadOnly Property ViewCameraOrientation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewCameraOrientation {
    ForgeTypeId^ get ();
}
static member ViewCameraOrientation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewCameraPosition Property

ParameterTypeIdViewCameraPosition Property

"Camera Position"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewCameraPosition { get; }
Public Shared ReadOnly Property ViewCameraPosition As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewCameraPosition {
    ForgeTypeId^ get ();
}
static member ViewCameraPosition : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewCleanJoins Property

ParameterTypeIdViewCleanJoins Property

"Wall Join Display"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewCleanJoins { get; }
Public Shared ReadOnly Property ViewCleanJoins As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewCleanJoins {
    ForgeTypeId^ get ();
}
static member ViewCleanJoins : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewDependency Property

ParameterTypeIdViewDependency Property

"Dependency"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewDependency { get; }
Public Shared ReadOnly Property ViewDependency As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewDependency {
    ForgeTypeId^ get ();
}
static member ViewDependency : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewDepth Property

ParameterTypeIdViewDepth Property

"View Depth"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewDepth { get; }
Public Shared ReadOnly Property ViewDepth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewDepth {
    ForgeTypeId^ get ();
}
static member ViewDepth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewDescription Property

ParameterTypeIdViewDescription Property

"Title on Sheet"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewDescription { get; }
Public Shared ReadOnly Property ViewDescription As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewDescription {
    ForgeTypeId^ get ();
}
static member ViewDescription : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewDesignOptionsConfig Property

ParameterTypeIdViewDesignOptionsConfig Property

"Design Option Configuration"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewDesignOptionsConfig { get; }
Public Shared ReadOnly Property ViewDesignOptionsConfig As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewDesignOptionsConfig {
    ForgeTypeId^ get ();
}
static member ViewDesignOptionsConfig : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewDetailLevel Property

ParameterTypeIdViewDetailLevel Property

"Detail Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewDetailLevel { get; }
Public Shared ReadOnly Property ViewDetailLevel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewDetailLevel {
    ForgeTypeId^ get ();
}
static member ViewDetailLevel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewDiscipline Property

ParameterTypeIdViewDiscipline Property

"Discipline"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewDiscipline { get; }
Public Shared ReadOnly Property ViewDiscipline As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewDiscipline {
    ForgeTypeId^ get ();
}
static member ViewDiscipline : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.Viewer3dRenderSettings Property

ParameterTypeIdViewer3dRenderSettings Property

"Rendering Settings"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Viewer3dRenderSettings { get; }
Public Shared ReadOnly Property Viewer3dRenderSettings As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Viewer3dRenderSettings {
    ForgeTypeId^ get ();
}
static member Viewer3dRenderSettings : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewerAnnotationCropActive Property

ParameterTypeIdViewerAnnotationCropActive Property

"Annotation Crop"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewerAnnotationCropActive { get; }
Public Shared ReadOnly Property ViewerAnnotationCropActive As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewerAnnotationCropActive {
    ForgeTypeId^ get ();
}
static member ViewerAnnotationCropActive : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewerBoundActiveBottom Property

ParameterTypeIdViewerBoundActiveBottom Property

"Bottom Clip Active"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewerBoundActiveBottom { get; }
Public Shared ReadOnly Property ViewerBoundActiveBottom As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewerBoundActiveBottom {
    ForgeTypeId^ get ();
}
static member ViewerBoundActiveBottom : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewerBoundActiveFar Property

ParameterTypeIdViewerBoundActiveFar Property

"Far Clip Active"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewerBoundActiveFar { get; }
Public Shared ReadOnly Property ViewerBoundActiveFar As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewerBoundActiveFar {
    ForgeTypeId^ get ();
}
static member ViewerBoundActiveFar : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewerBoundActiveLeft Property

ParameterTypeIdViewerBoundActiveLeft Property

"Left Clip Active"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewerBoundActiveLeft { get; }
Public Shared ReadOnly Property ViewerBoundActiveLeft As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewerBoundActiveLeft {
    ForgeTypeId^ get ();
}
static member ViewerBoundActiveLeft : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewerBoundActiveNear Property

ParameterTypeIdViewerBoundActiveNear Property

"Near Clip Active"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewerBoundActiveNear { get; }
Public Shared ReadOnly Property ViewerBoundActiveNear As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewerBoundActiveNear {
    ForgeTypeId^ get ();
}
static member ViewerBoundActiveNear : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewerBoundActiveRight Property

ParameterTypeIdViewerBoundActiveRight Property

"Right Clip Active"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewerBoundActiveRight { get; }
Public Shared ReadOnly Property ViewerBoundActiveRight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewerBoundActiveRight {
    ForgeTypeId^ get ();
}
static member ViewerBoundActiveRight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewerBoundActiveTop Property

ParameterTypeIdViewerBoundActiveTop Property

"Top Clip Active"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewerBoundActiveTop { get; }
Public Shared ReadOnly Property ViewerBoundActiveTop As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewerBoundActiveTop {
    ForgeTypeId^ get ();
}
static member ViewerBoundActiveTop : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewerBoundFarClipping Property

ParameterTypeIdViewerBoundFarClipping Property

"Far Clipping"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewerBoundFarClipping { get; }
Public Shared ReadOnly Property ViewerBoundFarClipping As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewerBoundFarClipping {
    ForgeTypeId^ get ();
}
static member ViewerBoundFarClipping : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewerBoundOffsetBottom Property

ParameterTypeIdViewerBoundOffsetBottom Property

"Bottom Clip Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewerBoundOffsetBottom { get; }
Public Shared ReadOnly Property ViewerBoundOffsetBottom As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewerBoundOffsetBottom {
    ForgeTypeId^ get ();
}
static member ViewerBoundOffsetBottom : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewerBoundOffsetFar Property

ParameterTypeIdViewerBoundOffsetFar Property

"Far Clip Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewerBoundOffsetFar { get; }
Public Shared ReadOnly Property ViewerBoundOffsetFar As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewerBoundOffsetFar {
    ForgeTypeId^ get ();
}
static member ViewerBoundOffsetFar : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewerBoundOffsetLeft Property

ParameterTypeIdViewerBoundOffsetLeft Property

"Left Clip Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewerBoundOffsetLeft { get; }
Public Shared ReadOnly Property ViewerBoundOffsetLeft As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewerBoundOffsetLeft {
    ForgeTypeId^ get ();
}
static member ViewerBoundOffsetLeft : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewerBoundOffsetNear Property

ParameterTypeIdViewerBoundOffsetNear Property

"Near Clip Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewerBoundOffsetNear { get; }
Public Shared ReadOnly Property ViewerBoundOffsetNear As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewerBoundOffsetNear {
    ForgeTypeId^ get ();
}
static member ViewerBoundOffsetNear : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewerBoundOffsetRight Property

ParameterTypeIdViewerBoundOffsetRight Property

"Right Clip Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewerBoundOffsetRight { get; }
Public Shared ReadOnly Property ViewerBoundOffsetRight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewerBoundOffsetRight {
    ForgeTypeId^ get ();
}
static member ViewerBoundOffsetRight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewerBoundOffsetTop Property

ParameterTypeIdViewerBoundOffsetTop Property

"Top Clip Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewerBoundOffsetTop { get; }
Public Shared ReadOnly Property ViewerBoundOffsetTop As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewerBoundOffsetTop {
    ForgeTypeId^ get ();
}
static member ViewerBoundOffsetTop : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewerCropRegion Property

ParameterTypeIdViewerCropRegion Property

"Crop View"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewerCropRegion { get; }
Public Shared ReadOnly Property ViewerCropRegion As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewerCropRegion {
    ForgeTypeId^ get ();
}
static member ViewerCropRegion : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewerCropRegionDisabled Property

ParameterTypeIdViewerCropRegionDisabled Property

"Crop View"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewerCropRegionDisabled { get; }
Public Shared ReadOnly Property ViewerCropRegionDisabled As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewerCropRegionDisabled {
    ForgeTypeId^ get ();
}
static member ViewerCropRegionDisabled : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewerCropRegionVisible Property

ParameterTypeIdViewerCropRegionVisible Property

"Crop Region Visible"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewerCropRegionVisible { get; }
Public Shared ReadOnly Property ViewerCropRegionVisible As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewerCropRegionVisible {
    ForgeTypeId^ get ();
}
static member ViewerCropRegionVisible : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewerDetailNumber Property

ParameterTypeIdViewerDetailNumber Property

"Detail Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewerDetailNumber { get; }
Public Shared ReadOnly Property ViewerDetailNumber As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewerDetailNumber {
    ForgeTypeId^ get ();
}
static member ViewerDetailNumber : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewerEyeElevation Property

ParameterTypeIdViewerEyeElevation Property

"Eye Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewerEyeElevation { get; }
Public Shared ReadOnly Property ViewerEyeElevation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewerEyeElevation {
    ForgeTypeId^ get ();
}
static member ViewerEyeElevation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewerIsReference Property

ParameterTypeIdViewerIsReference Property

"Is a Reference"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewerIsReference { get; }
Public Shared ReadOnly Property ViewerIsReference As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewerIsReference {
    ForgeTypeId^ get ();
}
static member ViewerIsReference : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewerModelClipBoxActive Property

ParameterTypeIdViewerModelClipBoxActive Property

"Section Box"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewerModelClipBoxActive { get; }
Public Shared ReadOnly Property ViewerModelClipBoxActive As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewerModelClipBoxActive {
    ForgeTypeId^ get ();
}
static member ViewerModelClipBoxActive : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewerOptionVisibility Property

ParameterTypeIdViewerOptionVisibility Property

"Visible In Option"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewerOptionVisibility { get; }
Public Shared ReadOnly Property ViewerOptionVisibility As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewerOptionVisibility {
    ForgeTypeId^ get ();
}
static member ViewerOptionVisibility : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewerPerspective Property

ParameterTypeIdViewerPerspective Property

"Projection Mode"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewerPerspective { get; }
Public Shared ReadOnly Property ViewerPerspective As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewerPerspective {
    ForgeTypeId^ get ();
}
static member ViewerPerspective : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewerReferenceLabel Property

ParameterTypeIdViewerReferenceLabel Property

"Reference Label"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewerReferenceLabel { get; }
Public Shared ReadOnly Property ViewerReferenceLabel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewerReferenceLabel {
    ForgeTypeId^ get ();
}
static member ViewerReferenceLabel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewerReferenceLabelText Property

ParameterTypeIdViewerReferenceLabelText Property

"Reference Label"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewerReferenceLabelText { get; }
Public Shared ReadOnly Property ViewerReferenceLabelText As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewerReferenceLabelText {
    ForgeTypeId^ get ();
}
static member ViewerReferenceLabelText : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewerSheetCollection Property

ParameterTypeIdViewerSheetCollection Property

"Sheet Collection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewerSheetCollection { get; }
Public Shared ReadOnly Property ViewerSheetCollection As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewerSheetCollection {
    ForgeTypeId^ get ();
}
static member ViewerSheetCollection : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewerSheetName Property

ParameterTypeIdViewerSheetName Property

"Sheet Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewerSheetName { get; }
Public Shared ReadOnly Property ViewerSheetName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewerSheetName {
    ForgeTypeId^ get ();
}
static member ViewerSheetName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewerSheetNumber Property

ParameterTypeIdViewerSheetNumber Property

"Sheet Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewerSheetNumber { get; }
Public Shared ReadOnly Property ViewerSheetNumber As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewerSheetNumber {
    ForgeTypeId^ get ();
}
static member ViewerSheetNumber : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewerShowUncropped Property

ParameterTypeIdViewerShowUncropped Property

"Show uncropped"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewerShowUncropped { get; }
Public Shared ReadOnly Property ViewerShowUncropped As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewerShowUncropped {
    ForgeTypeId^ get ();
}
static member ViewerShowUncropped : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewerTargetElevation Property

ParameterTypeIdViewerTargetElevation Property

"Target Elevation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewerTargetElevation { get; }
Public Shared ReadOnly Property ViewerTargetElevation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewerTargetElevation {
    ForgeTypeId^ get ();
}
static member ViewerTargetElevation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewerVolumeOfInterestCrop Property

ParameterTypeIdViewerVolumeOfInterestCrop Property

"Scope Box"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewerVolumeOfInterestCrop { get; }
Public Shared ReadOnly Property ViewerVolumeOfInterestCrop As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewerVolumeOfInterestCrop {
    ForgeTypeId^ get ();
}
static member ViewerVolumeOfInterestCrop : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewFamily Property

ParameterTypeIdViewFamily Property

"Family"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewFamily { get; }
Public Shared ReadOnly Property ViewFamily As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewFamily {
    ForgeTypeId^ get ();
}
static member ViewFamily : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewFamilyAndTypeSchedules Property

ParameterTypeIdViewFamilyAndTypeSchedules Property

"Family and Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewFamilyAndTypeSchedules { get; }
Public Shared ReadOnly Property ViewFamilyAndTypeSchedules As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewFamilyAndTypeSchedules {
    ForgeTypeId^ get ();
}
static member ViewFamilyAndTypeSchedules : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewFamilySchedules Property

ParameterTypeIdViewFamilySchedules Property

"Family"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewFamilySchedules { get; }
Public Shared ReadOnly Property ViewFamilySchedules As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewFamilySchedules {
    ForgeTypeId^ get ();
}
static member ViewFamilySchedules : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewFixedSketchPlane Property

ParameterTypeIdViewFixedSketchPlane Property

"None"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewFixedSketchPlane { get; }
Public Shared ReadOnly Property ViewFixedSketchPlane As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewFixedSketchPlane {
    ForgeTypeId^ get ();
}
static member ViewFixedSketchPlane : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewGraphSchedBottomLevel Property

ParameterTypeIdViewGraphSchedBottomLevel Property

"Bottom Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewGraphSchedBottomLevel { get; }
Public Shared ReadOnly Property ViewGraphSchedBottomLevel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewGraphSchedBottomLevel {
    ForgeTypeId^ get ();
}
static member ViewGraphSchedBottomLevel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewGraphSchedGridAppearance Property

ParameterTypeIdViewGraphSchedGridAppearance Property

"Grid Appearance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewGraphSchedGridAppearance { get; }
Public Shared ReadOnly Property ViewGraphSchedGridAppearance As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewGraphSchedGridAppearance {
    ForgeTypeId^ get ();
}
static member ViewGraphSchedGridAppearance : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewGraphSchedGroupSimilar Property

ParameterTypeIdViewGraphSchedGroupSimilar Property

"Group Similar Locations"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewGraphSchedGroupSimilar { get; }
Public Shared ReadOnly Property ViewGraphSchedGroupSimilar As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewGraphSchedGroupSimilar {
    ForgeTypeId^ get ();
}
static member ViewGraphSchedGroupSimilar : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewGraphSchedHiddenLevels Property

ParameterTypeIdViewGraphSchedHiddenLevels Property

"Hidden Levels"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewGraphSchedHiddenLevels { get; }
Public Shared ReadOnly Property ViewGraphSchedHiddenLevels As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewGraphSchedHiddenLevels {
    ForgeTypeId^ get ();
}
static member ViewGraphSchedHiddenLevels : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewGraphSchedLevelRelativeBaseType Property

ParameterTypeIdViewGraphSchedLevelRelativeBaseType Property

"Elevation Base for Levels"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewGraphSchedLevelRelativeBaseType { get; }
Public Shared ReadOnly Property ViewGraphSchedLevelRelativeBaseType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewGraphSchedLevelRelativeBaseType {
    ForgeTypeId^ get ();
}
static member ViewGraphSchedLevelRelativeBaseType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewGraphSchedLocationsHigh Property

ParameterTypeIdViewGraphSchedLocationsHigh Property

"Column Locations End"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewGraphSchedLocationsHigh { get; }
Public Shared ReadOnly Property ViewGraphSchedLocationsHigh As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewGraphSchedLocationsHigh {
    ForgeTypeId^ get ();
}
static member ViewGraphSchedLocationsHigh : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewGraphSchedLocationsLow Property

ParameterTypeIdViewGraphSchedLocationsLow Property

"Column Locations Start"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewGraphSchedLocationsLow { get; }
Public Shared ReadOnly Property ViewGraphSchedLocationsLow As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewGraphSchedLocationsLow {
    ForgeTypeId^ get ();
}
static member ViewGraphSchedLocationsLow : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewGraphSchedMaterialTypes Property

ParameterTypeIdViewGraphSchedMaterialTypes Property

"Material Types"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewGraphSchedMaterialTypes { get; }
Public Shared ReadOnly Property ViewGraphSchedMaterialTypes As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewGraphSchedMaterialTypes {
    ForgeTypeId^ get ();
}
static member ViewGraphSchedMaterialTypes : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewGraphSchedNumberColumns Property

ParameterTypeIdViewGraphSchedNumberColumns Property

"Column Locations per Segment"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewGraphSchedNumberColumns { get; }
Public Shared ReadOnly Property ViewGraphSchedNumberColumns As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewGraphSchedNumberColumns {
    ForgeTypeId^ get ();
}
static member ViewGraphSchedNumberColumns : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewGraphSchedOffGrid Property

ParameterTypeIdViewGraphSchedOffGrid Property

"Include Off-Grid Columns"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewGraphSchedOffGrid { get; }
Public Shared ReadOnly Property ViewGraphSchedOffGrid As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewGraphSchedOffGrid {
    ForgeTypeId^ get ();
}
static member ViewGraphSchedOffGrid : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewGraphSchedRowsCount Property

ParameterTypeIdViewGraphSchedRowsCount Property

"Segments in Viewport"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewGraphSchedRowsCount { get; }
Public Shared ReadOnly Property ViewGraphSchedRowsCount As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewGraphSchedRowsCount {
    ForgeTypeId^ get ();
}
static member ViewGraphSchedRowsCount : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewGraphSchedRowsFrom Property

ParameterTypeIdViewGraphSchedRowsFrom Property

"Segment Start in Viewport"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewGraphSchedRowsFrom { get; }
Public Shared ReadOnly Property ViewGraphSchedRowsFrom As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewGraphSchedRowsFrom {
    ForgeTypeId^ get ();
}
static member ViewGraphSchedRowsFrom : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewGraphSchedTextAppearance Property

ParameterTypeIdViewGraphSchedTextAppearance Property

"Text Appearance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewGraphSchedTextAppearance { get; }
Public Shared ReadOnly Property ViewGraphSchedTextAppearance As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewGraphSchedTextAppearance {
    ForgeTypeId^ get ();
}
static member ViewGraphSchedTextAppearance : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewGraphSchedTitle Property

ParameterTypeIdViewGraphSchedTitle Property

"Title"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewGraphSchedTitle { get; }
Public Shared ReadOnly Property ViewGraphSchedTitle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewGraphSchedTitle {
    ForgeTypeId^ get ();
}
static member ViewGraphSchedTitle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewGraphSchedTopLevel Property

ParameterTypeIdViewGraphSchedTopLevel Property

"Top Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewGraphSchedTopLevel { get; }
Public Shared ReadOnly Property ViewGraphSchedTopLevel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewGraphSchedTopLevel {
    ForgeTypeId^ get ();
}
static member ViewGraphSchedTopLevel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewGraphSchedTotalColumns Property

ParameterTypeIdViewGraphSchedTotalColumns Property

"Total Column Locations"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewGraphSchedTotalColumns { get; }
Public Shared ReadOnly Property ViewGraphSchedTotalColumns As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewGraphSchedTotalColumns {
    ForgeTypeId^ get ();
}
static member ViewGraphSchedTotalColumns : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewGraphSchedTotalRows Property

ParameterTypeIdViewGraphSchedTotalRows Property

"Total Segments"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewGraphSchedTotalRows { get; }
Public Shared ReadOnly Property ViewGraphSchedTotalRows As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewGraphSchedTotalRows {
    ForgeTypeId^ get ();
}
static member ViewGraphSchedTotalRows : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewGraphSchedUnitsFormat Property

ParameterTypeIdViewGraphSchedUnitsFormat Property

"Off-Grid Units Format"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewGraphSchedUnitsFormat { get; }
Public Shared ReadOnly Property ViewGraphSchedUnitsFormat As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewGraphSchedUnitsFormat {
    ForgeTypeId^ get ();
}
static member ViewGraphSchedUnitsFormat : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewGraphSunPath Property

ParameterTypeIdViewGraphSunPath Property

"Sun Path"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewGraphSunPath { get; }
Public Shared ReadOnly Property ViewGraphSunPath As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewGraphSunPath {
    ForgeTypeId^ get ();
}
static member ViewGraphSunPath : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewGraphSunPathSize Property

ParameterTypeIdViewGraphSunPathSize Property

"Sun path size (%)"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewGraphSunPathSize { get; }
Public Shared ReadOnly Property ViewGraphSunPathSize As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewGraphSunPathSize {
    ForgeTypeId^ get ();
}
static member ViewGraphSunPathSize : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewModelDisplayMode Property

ParameterTypeIdViewModelDisplayMode Property

"Display Model"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewModelDisplayMode { get; }
Public Shared ReadOnly Property ViewModelDisplayMode As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewModelDisplayMode {
    ForgeTypeId^ get ();
}
static member ViewModelDisplayMode : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewName Property

ParameterTypeIdViewName Property

"View Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewName { get; }
Public Shared ReadOnly Property ViewName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewName {
    ForgeTypeId^ get ();
}
static member ViewName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewPartsVisibility Property

ParameterTypeIdViewPartsVisibility Property

"Parts Visibility"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewPartsVisibility { get; }
Public Shared ReadOnly Property ViewPartsVisibility As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewPartsVisibility {
    ForgeTypeId^ get ();
}
static member ViewPartsVisibility : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewPhase Property

ParameterTypeIdViewPhase Property

"Phase"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewPhase { get; }
Public Shared ReadOnly Property ViewPhase As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewPhase {
    ForgeTypeId^ get ();
}
static member ViewPhase : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewPhaseFilter Property

ParameterTypeIdViewPhaseFilter Property

"Phase Filter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewPhaseFilter { get; }
Public Shared ReadOnly Property ViewPhaseFilter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewPhaseFilter {
    ForgeTypeId^ get ();
}
static member ViewPhaseFilter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewportAttrLabelTag Property

ParameterTypeIdViewportAttrLabelTag Property

"Title"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewportAttrLabelTag { get; }
Public Shared ReadOnly Property ViewportAttrLabelTag As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewportAttrLabelTag {
    ForgeTypeId^ get ();
}
static member ViewportAttrLabelTag : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewportAttrOrientationOnSheet Property

ParameterTypeIdViewportAttrOrientationOnSheet Property

"Rotation on Sheet"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewportAttrOrientationOnSheet { get; }
Public Shared ReadOnly Property ViewportAttrOrientationOnSheet As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewportAttrOrientationOnSheet {
    ForgeTypeId^ get ();
}
static member ViewportAttrOrientationOnSheet : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewportAttrPreserveTitlePosition Property

ParameterTypeIdViewportAttrPreserveTitlePosition Property

"Preserve Title Position"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewportAttrPreserveTitlePosition { get; }
Public Shared ReadOnly Property ViewportAttrPreserveTitlePosition As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewportAttrPreserveTitlePosition {
    ForgeTypeId^ get ();
}
static member ViewportAttrPreserveTitlePosition : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewportAttrShowBox Property

ParameterTypeIdViewportAttrShowBox Property

"Show Box"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewportAttrShowBox { get; }
Public Shared ReadOnly Property ViewportAttrShowBox As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewportAttrShowBox {
    ForgeTypeId^ get ();
}
static member ViewportAttrShowBox : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewportAttrShowExtensionLine Property

ParameterTypeIdViewportAttrShowExtensionLine Property

"Show Extension Line"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewportAttrShowExtensionLine { get; }
Public Shared ReadOnly Property ViewportAttrShowExtensionLine As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewportAttrShowExtensionLine {
    ForgeTypeId^ get ();
}
static member ViewportAttrShowExtensionLine : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewportAttrShowLabel Property

ParameterTypeIdViewportAttrShowLabel Property

"Show Title"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewportAttrShowLabel { get; }
Public Shared ReadOnly Property ViewportAttrShowLabel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewportAttrShowLabel {
    ForgeTypeId^ get ();
}
static member ViewportAttrShowLabel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewportDetailNumber Property

ParameterTypeIdViewportDetailNumber Property

"Detail Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewportDetailNumber { get; }
Public Shared ReadOnly Property ViewportDetailNumber As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewportDetailNumber {
    ForgeTypeId^ get ();
}
static member ViewportDetailNumber : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewportPositioning Property

ParameterTypeIdViewportPositioning Property

"Viewport Positioning"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewportPositioning { get; }
Public Shared ReadOnly Property ViewportPositioning As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewportPositioning {
    ForgeTypeId^ get ();
}
static member ViewportPositioning : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewportScale Property

ParameterTypeIdViewportScale Property

"View Scale"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewportScale { get; }
Public Shared ReadOnly Property ViewportScale As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewportScale {
    ForgeTypeId^ get ();
}
static member ViewportScale : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewportSheetCollection Property

ParameterTypeIdViewportSheetCollection Property

"Sheet Collection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewportSheetCollection { get; }
Public Shared ReadOnly Property ViewportSheetCollection As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewportSheetCollection {
    ForgeTypeId^ get ();
}
static member ViewportSheetCollection : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewportSheetName Property

ParameterTypeIdViewportSheetName Property

"Sheet Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewportSheetName { get; }
Public Shared ReadOnly Property ViewportSheetName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewportSheetName {
    ForgeTypeId^ get ();
}
static member ViewportSheetName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewportSheetNumber Property

ParameterTypeIdViewportSheetNumber Property

"Sheet Number"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewportSheetNumber { get; }
Public Shared ReadOnly Property ViewportSheetNumber As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewportSheetNumber {
    ForgeTypeId^ get ();
}
static member ViewportSheetNumber : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewportView Property

ParameterTypeIdViewportView Property

"View"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewportView { get; }
Public Shared ReadOnly Property ViewportView As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewportView {
    ForgeTypeId^ get ();
}
static member ViewportView : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewportViewName Property

ParameterTypeIdViewportViewName Property

"View Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewportViewName { get; }
Public Shared ReadOnly Property ViewportViewName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewportViewName {
    ForgeTypeId^ get ();
}
static member ViewportViewName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewReferencingDetail Property

ParameterTypeIdViewReferencingDetail Property

"Referencing Detail"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewReferencingDetail { get; }
Public Shared ReadOnly Property ViewReferencingDetail As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewReferencingDetail {
    ForgeTypeId^ get ();
}
static member ViewReferencingDetail : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewReferencingSheet Property

ParameterTypeIdViewReferencingSheet Property

"Referencing Sheet"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewReferencingSheet { get; }
Public Shared ReadOnly Property ViewReferencingSheet As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewReferencingSheet {
    ForgeTypeId^ get ();
}
static member ViewReferencingSheet : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewReferencingSheetCollection Property

ParameterTypeIdViewReferencingSheetCollection Property

"Referencing Sheet Collection"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewReferencingSheetCollection { get; }
Public Shared ReadOnly Property ViewReferencingSheetCollection As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewReferencingSheetCollection {
    ForgeTypeId^ get ();
}
static member ViewReferencingSheetCollection : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewScale Property

ParameterTypeIdViewScale Property

"Scale Value 1:"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewScale { get; }
Public Shared ReadOnly Property ViewScale As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewScale {
    ForgeTypeId^ get ();
}
static member ViewScale : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewScaleCustomname Property

ParameterTypeIdViewScaleCustomname Property

"Display Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewScaleCustomname { get; }
Public Shared ReadOnly Property ViewScaleCustomname As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewScaleCustomname {
    ForgeTypeId^ get ();
}
static member ViewScaleCustomname : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewScaleHavename Property

ParameterTypeIdViewScaleHavename Property

"Display Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewScaleHavename { get; }
Public Shared ReadOnly Property ViewScaleHavename As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewScaleHavename {
    ForgeTypeId^ get ();
}
static member ViewScaleHavename : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewScalePulldownImperial Property

ParameterTypeIdViewScalePulldownImperial Property

"View Scale"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewScalePulldownImperial { get; }
Public Shared ReadOnly Property ViewScalePulldownImperial As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewScalePulldownImperial {
    ForgeTypeId^ get ();
}
static member ViewScalePulldownImperial : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewScalePulldownMetric Property

ParameterTypeIdViewScalePulldownMetric Property

"View Scale"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewScalePulldownMetric { get; }
Public Shared ReadOnly Property ViewScalePulldownMetric As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewScalePulldownMetric {
    ForgeTypeId^ get ();
}
static member ViewScalePulldownMetric : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewSchemaSettingForBuilding Property

ParameterTypeIdViewSchemaSettingForBuilding Property

"Color Scheme"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewSchemaSettingForBuilding { get; }
Public Shared ReadOnly Property ViewSchemaSettingForBuilding As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewSchemaSettingForBuilding {
    ForgeTypeId^ get ();
}
static member ViewSchemaSettingForBuilding : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewSchemaSettingForSystem Property

ParameterTypeIdViewSchemaSettingForSystem Property

"System Color Schemes"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewSchemaSettingForSystem { get; }
Public Shared ReadOnly Property ViewSchemaSettingForSystem As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewSchemaSettingForSystem {
    ForgeTypeId^ get ();
}
static member ViewSchemaSettingForSystem : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewSchemaSettingForSystemTemplate Property

ParameterTypeIdViewSchemaSettingForSystemTemplate Property

"System Color Schemes"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewSchemaSettingForSystemTemplate { get; }
Public Shared ReadOnly Property ViewSchemaSettingForSystemTemplate As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewSchemaSettingForSystemTemplate {
    ForgeTypeId^ get ();
}
static member ViewSchemaSettingForSystemTemplate : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewSheetViewportInfo Property

ParameterTypeIdViewSheetViewportInfo Property

"Viewport"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewSheetViewportInfo { get; }
Public Shared ReadOnly Property ViewSheetViewportInfo As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewSheetViewportInfo {
    ForgeTypeId^ get ();
}
static member ViewSheetViewportInfo : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewShowGrids Property

ParameterTypeIdViewShowGrids Property

"Show Grids"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewShowGrids { get; }
Public Shared ReadOnly Property ViewShowGrids As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewShowGrids {
    ForgeTypeId^ get ();
}
static member ViewShowGrids : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewShowHiddenLines Property

ParameterTypeIdViewShowHiddenLines Property

"Show Hidden Lines"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewShowHiddenLines { get; }
Public Shared ReadOnly Property ViewShowHiddenLines As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewShowHiddenLines {
    ForgeTypeId^ get ();
}
static member ViewShowHiddenLines : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewShowMassing Property

ParameterTypeIdViewShowMassing Property

"Show Mass"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewShowMassing { get; }
Public Shared ReadOnly Property ViewShowMassing As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewShowMassing {
    ForgeTypeId^ get ();
}
static member ViewShowMassing : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewSlantedColumnSymbolOffset Property

ParameterTypeIdViewSlantedColumnSymbolOffset Property

"Column Symbolic Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewSlantedColumnSymbolOffset { get; }
Public Shared ReadOnly Property ViewSlantedColumnSymbolOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewSlantedColumnSymbolOffset {
    ForgeTypeId^ get ();
}
static member ViewSlantedColumnSymbolOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewSolarstudyAnimationSpeedText Property

ParameterTypeIdViewSolarstudyAnimationSpeedText Property

"Loop animation speed"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewSolarstudyAnimationSpeedText { get; }
Public Shared ReadOnly Property ViewSolarstudyAnimationSpeedText As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewSolarstudyAnimationSpeedText {
    ForgeTypeId^ get ();
}
static member ViewSolarstudyAnimationSpeedText : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewSolarstudyAnimationSpeedValue Property

ParameterTypeIdViewSolarstudyAnimationSpeedValue Property

"Loop animation speed"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewSolarstudyAnimationSpeedValue { get; }
Public Shared ReadOnly Property ViewSolarstudyAnimationSpeedValue As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewSolarstudyAnimationSpeedValue {
    ForgeTypeId^ get ();
}
static member ViewSolarstudyAnimationSpeedValue : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewSolarstudyCurrentStudyTypeIndex Property

ParameterTypeIdViewSolarstudyCurrentStudyTypeIndex Property

"Study type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewSolarstudyCurrentStudyTypeIndex { get; }
Public Shared ReadOnly Property ViewSolarstudyCurrentStudyTypeIndex As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewSolarstudyCurrentStudyTypeIndex {
    ForgeTypeId^ get ();
}
static member ViewSolarstudyCurrentStudyTypeIndex : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewSolarstudyIsLightingStudyType Property

ParameterTypeIdViewSolarstudyIsLightingStudyType Property

"Lighting study"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewSolarstudyIsLightingStudyType { get; }
Public Shared ReadOnly Property ViewSolarstudyIsLightingStudyType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewSolarstudyIsLightingStudyType {
    ForgeTypeId^ get ();
}
static member ViewSolarstudyIsLightingStudyType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewSolarstudyIsMultidayStudyType Property

ParameterTypeIdViewSolarstudyIsMultidayStudyType Property

"Multi-day study"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewSolarstudyIsMultidayStudyType { get; }
Public Shared ReadOnly Property ViewSolarstudyIsMultidayStudyType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewSolarstudyIsMultidayStudyType {
    ForgeTypeId^ get ();
}
static member ViewSolarstudyIsMultidayStudyType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewSolarstudyIsSingledayStudyType Property

ParameterTypeIdViewSolarstudyIsSingledayStudyType Property

"Single day study"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewSolarstudyIsSingledayStudyType { get; }
Public Shared ReadOnly Property ViewSolarstudyIsSingledayStudyType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewSolarstudyIsSingledayStudyType {
    ForgeTypeId^ get ();
}
static member ViewSolarstudyIsSingledayStudyType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewSolarstudyIsStillimageStudyType Property

ParameterTypeIdViewSolarstudyIsStillimageStudyType Property

"Still image study"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewSolarstudyIsStillimageStudyType { get; }
Public Shared ReadOnly Property ViewSolarstudyIsStillimageStudyType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewSolarstudyIsStillimageStudyType {
    ForgeTypeId^ get ();
}
static member ViewSolarstudyIsStillimageStudyType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewSolarstudyLightingAltitudeText Property

ParameterTypeIdViewSolarstudyLightingAltitudeText Property

"Lighting altitude text"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewSolarstudyLightingAltitudeText { get; }
Public Shared ReadOnly Property ViewSolarstudyLightingAltitudeText As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewSolarstudyLightingAltitudeText {
    ForgeTypeId^ get ();
}
static member ViewSolarstudyLightingAltitudeText : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewSolarstudyLightingAltitudeValue Property

ParameterTypeIdViewSolarstudyLightingAltitudeValue Property

"Lighting altitude"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewSolarstudyLightingAltitudeValue { get; }
Public Shared ReadOnly Property ViewSolarstudyLightingAltitudeValue As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewSolarstudyLightingAltitudeValue {
    ForgeTypeId^ get ();
}
static member ViewSolarstudyLightingAltitudeValue : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewSolarstudyLightingAzimuthText Property

ParameterTypeIdViewSolarstudyLightingAzimuthText Property

"Lighting azimuth text"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewSolarstudyLightingAzimuthText { get; }
Public Shared ReadOnly Property ViewSolarstudyLightingAzimuthText As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewSolarstudyLightingAzimuthText {
    ForgeTypeId^ get ();
}
static member ViewSolarstudyLightingAzimuthText : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewSolarstudyLightingAzimuthValue Property

ParameterTypeIdViewSolarstudyLightingAzimuthValue Property

"Lighting azimuth"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewSolarstudyLightingAzimuthValue { get; }
Public Shared ReadOnly Property ViewSolarstudyLightingAzimuthValue As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewSolarstudyLightingAzimuthValue {
    ForgeTypeId^ get ();
}
static member ViewSolarstudyLightingAzimuthValue : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewSolarstudyLightingPresetIndex Property

ParameterTypeIdViewSolarstudyLightingPresetIndex Property

"Lighting presets combo"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewSolarstudyLightingPresetIndex { get; }
Public Shared ReadOnly Property ViewSolarstudyLightingPresetIndex As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewSolarstudyLightingPresetIndex {
    ForgeTypeId^ get ();
}
static member ViewSolarstudyLightingPresetIndex : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewSolarstudyMultidayDatetimeText Property

ParameterTypeIdViewSolarstudyMultidayDatetimeText Property

"Multi-day date and time text"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewSolarstudyMultidayDatetimeText { get; }
Public Shared ReadOnly Property ViewSolarstudyMultidayDatetimeText As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewSolarstudyMultidayDatetimeText {
    ForgeTypeId^ get ();
}
static member ViewSolarstudyMultidayDatetimeText : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewSolarstudyMultidayFrameText Property

ParameterTypeIdViewSolarstudyMultidayFrameText Property

"Multi-day frame text"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewSolarstudyMultidayFrameText { get; }
Public Shared ReadOnly Property ViewSolarstudyMultidayFrameText As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewSolarstudyMultidayFrameText {
    ForgeTypeId^ get ();
}
static member ViewSolarstudyMultidayFrameText : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewSolarstudyMultidayFrameValue Property

ParameterTypeIdViewSolarstudyMultidayFrameValue Property

"Multi-day frame"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewSolarstudyMultidayFrameValue { get; }
Public Shared ReadOnly Property ViewSolarstudyMultidayFrameValue As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewSolarstudyMultidayFrameValue {
    ForgeTypeId^ get ();
}
static member ViewSolarstudyMultidayFrameValue : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewSolarstudyMultidayPresetIndex Property

ParameterTypeIdViewSolarstudyMultidayPresetIndex Property

"Multi-day presets combo"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewSolarstudyMultidayPresetIndex { get; }
Public Shared ReadOnly Property ViewSolarstudyMultidayPresetIndex As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewSolarstudyMultidayPresetIndex {
    ForgeTypeId^ get ();
}
static member ViewSolarstudyMultidayPresetIndex : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewSolarstudyShadowsIntensityText Property

ParameterTypeIdViewSolarstudyShadowsIntensityText Property

"Shadows intensity text"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewSolarstudyShadowsIntensityText { get; }
Public Shared ReadOnly Property ViewSolarstudyShadowsIntensityText As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewSolarstudyShadowsIntensityText {
    ForgeTypeId^ get ();
}
static member ViewSolarstudyShadowsIntensityText : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewSolarstudyShadowsIntensityValue Property

ParameterTypeIdViewSolarstudyShadowsIntensityValue Property

"Shadows intensity"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewSolarstudyShadowsIntensityValue { get; }
Public Shared ReadOnly Property ViewSolarstudyShadowsIntensityValue As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewSolarstudyShadowsIntensityValue {
    ForgeTypeId^ get ();
}
static member ViewSolarstudyShadowsIntensityValue : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewSolarstudySingledayDatetimeText Property

ParameterTypeIdViewSolarstudySingledayDatetimeText Property

"Single day date and time text"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewSolarstudySingledayDatetimeText { get; }
Public Shared ReadOnly Property ViewSolarstudySingledayDatetimeText As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewSolarstudySingledayDatetimeText {
    ForgeTypeId^ get ();
}
static member ViewSolarstudySingledayDatetimeText : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewSolarstudySingledayFrameText Property

ParameterTypeIdViewSolarstudySingledayFrameText Property

"Single day frame text"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewSolarstudySingledayFrameText { get; }
Public Shared ReadOnly Property ViewSolarstudySingledayFrameText As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewSolarstudySingledayFrameText {
    ForgeTypeId^ get ();
}
static member ViewSolarstudySingledayFrameText : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewSolarstudySingledayFrameValue Property

ParameterTypeIdViewSolarstudySingledayFrameValue Property

"Single day frame"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewSolarstudySingledayFrameValue { get; }
Public Shared ReadOnly Property ViewSolarstudySingledayFrameValue As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewSolarstudySingledayFrameValue {
    ForgeTypeId^ get ();
}
static member ViewSolarstudySingledayFrameValue : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewSolarstudySingledayPresetIndex Property

ParameterTypeIdViewSolarstudySingledayPresetIndex Property

"Single day presets combo"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewSolarstudySingledayPresetIndex { get; }
Public Shared ReadOnly Property ViewSolarstudySingledayPresetIndex As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewSolarstudySingledayPresetIndex {
    ForgeTypeId^ get ();
}
static member ViewSolarstudySingledayPresetIndex : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewSolarstudyStillDateText Property

ParameterTypeIdViewSolarstudyStillDateText Property

"Still date text"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewSolarstudyStillDateText { get; }
Public Shared ReadOnly Property ViewSolarstudyStillDateText As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewSolarstudyStillDateText {
    ForgeTypeId^ get ();
}
static member ViewSolarstudyStillDateText : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewSolarstudyStillDateValue Property

ParameterTypeIdViewSolarstudyStillDateValue Property

"Still date"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewSolarstudyStillDateValue { get; }
Public Shared ReadOnly Property ViewSolarstudyStillDateValue As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewSolarstudyStillDateValue {
    ForgeTypeId^ get ();
}
static member ViewSolarstudyStillDateValue : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewSolarstudyStillPresetIndex Property

ParameterTypeIdViewSolarstudyStillPresetIndex Property

"Still presets combo"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewSolarstudyStillPresetIndex { get; }
Public Shared ReadOnly Property ViewSolarstudyStillPresetIndex As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewSolarstudyStillPresetIndex {
    ForgeTypeId^ get ();
}
static member ViewSolarstudyStillPresetIndex : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewSolarstudyStillTimeText Property

ParameterTypeIdViewSolarstudyStillTimeText Property

"Still time text"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewSolarstudyStillTimeText { get; }
Public Shared ReadOnly Property ViewSolarstudyStillTimeText As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewSolarstudyStillTimeText {
    ForgeTypeId^ get ();
}
static member ViewSolarstudyStillTimeText : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewSolarstudyStillTimeValue Property

ParameterTypeIdViewSolarstudyStillTimeValue Property

"Still time"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewSolarstudyStillTimeValue { get; }
Public Shared ReadOnly Property ViewSolarstudyStillTimeValue As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewSolarstudyStillTimeValue {
    ForgeTypeId^ get ();
}
static member ViewSolarstudyStillTimeValue : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewSolarstudySunIntensityText Property

ParameterTypeIdViewSolarstudySunIntensityText Property

"Sun intensity text"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewSolarstudySunIntensityText { get; }
Public Shared ReadOnly Property ViewSolarstudySunIntensityText As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewSolarstudySunIntensityText {
    ForgeTypeId^ get ();
}
static member ViewSolarstudySunIntensityText : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewSolarstudySunIntensityValue Property

ParameterTypeIdViewSolarstudySunIntensityValue Property

"Sun intensity"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewSolarstudySunIntensityValue { get; }
Public Shared ReadOnly Property ViewSolarstudySunIntensityValue As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewSolarstudySunIntensityValue {
    ForgeTypeId^ get ();
}
static member ViewSolarstudySunIntensityValue : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewTemplate Property

ParameterTypeIdViewTemplate Property

"View Template"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewTemplate { get; }
Public Shared ReadOnly Property ViewTemplate As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewTemplate {
    ForgeTypeId^ get ();
}
static member ViewTemplate : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewTemplateForSchedule Property

ParameterTypeIdViewTemplateForSchedule Property

"View Template"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewTemplateForSchedule { get; }
Public Shared ReadOnly Property ViewTemplateForSchedule As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewTemplateForSchedule {
    ForgeTypeId^ get ();
}
static member ViewTemplateForSchedule : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewType Property

ParameterTypeIdViewType Property

"Family and Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewType { get; }
Public Shared ReadOnly Property ViewType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewType {
    ForgeTypeId^ get ();
}
static member ViewType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewTypeSchedules Property

ParameterTypeIdViewTypeSchedules Property

"Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewTypeSchedules { get; }
Public Shared ReadOnly Property ViewTypeSchedules As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewTypeSchedules {
    ForgeTypeId^ get ();
}
static member ViewTypeSchedules : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewUnderlayBottomId Property

ParameterTypeIdViewUnderlayBottomId Property

"Range: Base Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewUnderlayBottomId { get; }
Public Shared ReadOnly Property ViewUnderlayBottomId As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewUnderlayBottomId {
    ForgeTypeId^ get ();
}
static member ViewUnderlayBottomId : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewUnderlayOrientation Property

ParameterTypeIdViewUnderlayOrientation Property

"Underlay Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewUnderlayOrientation { get; }
Public Shared ReadOnly Property ViewUnderlayOrientation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewUnderlayOrientation {
    ForgeTypeId^ get ();
}
static member ViewUnderlayOrientation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewUnderlayTopId Property

ParameterTypeIdViewUnderlayTopId Property

"Range: Top Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewUnderlayTopId { get; }
Public Shared ReadOnly Property ViewUnderlayTopId As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewUnderlayTopId {
    ForgeTypeId^ get ();
}
static member ViewUnderlayTopId : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ViewVisibleCategories Property

ParameterTypeIdViewVisibleCategories Property

"Visibility/Graphics Overrides"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ViewVisibleCategories { get; }
Public Shared ReadOnly Property ViewVisibleCategories As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ViewVisibleCategories {
    ForgeTypeId^ get ();
}
static member ViewVisibleCategories : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.VisGraphicsAnalyticalModel Property

ParameterTypeIdVisGraphicsAnalyticalModel Property

"V/G Overrides Analytical Model"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId VisGraphicsAnalyticalModel { get; }
Public Shared ReadOnly Property VisGraphicsAnalyticalModel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ VisGraphicsAnalyticalModel {
    ForgeTypeId^ get ();
}
static member VisGraphicsAnalyticalModel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.VisGraphicsAnnotation Property

ParameterTypeIdVisGraphicsAnnotation Property

"V/G Overrides Annotation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId VisGraphicsAnnotation { get; }
Public Shared ReadOnly Property VisGraphicsAnnotation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ VisGraphicsAnnotation {
    ForgeTypeId^ get ();
}
static member VisGraphicsAnnotation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.VisGraphicsCoordinationModel Property

ParameterTypeIdVisGraphicsCoordinationModel Property

"V/G Overrides Coordination Model"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId VisGraphicsCoordinationModel { get; }
Public Shared ReadOnly Property VisGraphicsCoordinationModel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ VisGraphicsCoordinationModel {
    ForgeTypeId^ get ();
}
static member VisGraphicsCoordinationModel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.VisGraphicsDesignoptions Property

ParameterTypeIdVisGraphicsDesignoptions Property

"V/G Overrides Design Options"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId VisGraphicsDesignoptions { get; }
Public Shared ReadOnly Property VisGraphicsDesignoptions As ForgeTypeId
    Get
public:
static property ForgeTypeId^ VisGraphicsDesignoptions {
    ForgeTypeId^ get ();
}
static member VisGraphicsDesignoptions : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.VisGraphicsFilters Property

ParameterTypeIdVisGraphicsFilters Property

"V/G Overrides Filters"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId VisGraphicsFilters { get; }
Public Shared ReadOnly Property VisGraphicsFilters As ForgeTypeId
    Get
public:
static property ForgeTypeId^ VisGraphicsFilters {
    ForgeTypeId^ get ();
}
static member VisGraphicsFilters : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.VisGraphicsImport Property

ParameterTypeIdVisGraphicsImport Property

"V/G Overrides Import"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId VisGraphicsImport { get; }
Public Shared ReadOnly Property VisGraphicsImport As ForgeTypeId
    Get
public:
static property ForgeTypeId^ VisGraphicsImport {
    ForgeTypeId^ get ();
}
static member VisGraphicsImport : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.VisGraphicsModel Property

ParameterTypeIdVisGraphicsModel Property

"V/G Overrides Model"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId VisGraphicsModel { get; }
Public Shared ReadOnly Property VisGraphicsModel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ VisGraphicsModel {
    ForgeTypeId^ get ();
}
static member VisGraphicsModel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.VisGraphicsPointClouds Property

ParameterTypeIdVisGraphicsPointClouds Property

"V/G Overrides Point Clouds"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId VisGraphicsPointClouds { get; }
Public Shared ReadOnly Property VisGraphicsPointClouds As ForgeTypeId
    Get
public:
static property ForgeTypeId^ VisGraphicsPointClouds {
    ForgeTypeId^ get ();
}
static member VisGraphicsPointClouds : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.VisGraphicsRvtLinks Property

ParameterTypeIdVisGraphicsRvtLinks Property

"V/G Overrides RVT Links"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId VisGraphicsRvtLinks { get; }
Public Shared ReadOnly Property VisGraphicsRvtLinks As ForgeTypeId
    Get
public:
static property ForgeTypeId^ VisGraphicsRvtLinks {
    ForgeTypeId^ get ();
}
static member VisGraphicsRvtLinks : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.VisGraphicsWorksets Property

ParameterTypeIdVisGraphicsWorksets Property

"V/G Overrides Worksets"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId VisGraphicsWorksets { get; }
Public Shared ReadOnly Property VisGraphicsWorksets As ForgeTypeId
    Get
public:
static property ForgeTypeId^ VisGraphicsWorksets {
    ForgeTypeId^ get ();
}
static member VisGraphicsWorksets : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.VoidCutsGeometry Property

ParameterTypeIdVoidCutsGeometry Property

"Cuts Geometry"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId VoidCutsGeometry { get; }
Public Shared ReadOnly Property VoidCutsGeometry As ForgeTypeId
    Get
public:
static property ForgeTypeId^ VoidCutsGeometry {
    ForgeTypeId^ get ();
}
static member VoidCutsGeometry : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.VolumeCut Property

ParameterTypeIdVolumeCut Property

"Cut"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId VolumeCut { get; }
Public Shared ReadOnly Property VolumeCut As ForgeTypeId
    Get
public:
static property ForgeTypeId^ VolumeCut {
    ForgeTypeId^ get ();
}
static member VolumeCut : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.VolumeFill Property

ParameterTypeIdVolumeFill Property

"Fill"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId VolumeFill { get; }
Public Shared ReadOnly Property VolumeFill As ForgeTypeId
    Get
public:
static property ForgeTypeId^ VolumeFill {
    ForgeTypeId^ get ();
}
static member VolumeFill : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.VolumeNet Property

ParameterTypeIdVolumeNet Property

"Net cut/fill"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId VolumeNet { get; }
Public Shared ReadOnly Property VolumeNet As ForgeTypeId
    Get
public:
static property ForgeTypeId^ VolumeNet {
    ForgeTypeId^ get ();
}
static member VolumeNet : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.VolumeOfInterestHeight Property

ParameterTypeIdVolumeOfInterestHeight Property

"Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId VolumeOfInterestHeight { get; }
Public Shared ReadOnly Property VolumeOfInterestHeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ VolumeOfInterestHeight {
    ForgeTypeId^ get ();
}
static member VolumeOfInterestHeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.VolumeOfInterestName Property

ParameterTypeIdVolumeOfInterestName Property

"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId VolumeOfInterestName { get; }
Public Shared ReadOnly Property VolumeOfInterestName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ VolumeOfInterestName {
    ForgeTypeId^ get ();
}
static member VolumeOfInterestName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.VolumeOfInterestViewsVisible Property

ParameterTypeIdVolumeOfInterestViewsVisible Property

"Views Visible"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId VolumeOfInterestViewsVisible { get; }
Public Shared ReadOnly Property VolumeOfInterestViewsVisible As ForgeTypeId
    Get
public:
static property ForgeTypeId^ VolumeOfInterestViewsVisible {
    ForgeTypeId^ get ();
}
static member VolumeOfInterestViewsVisible : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WalkthroughFramesCount Property

ParameterTypeIdWalkthroughFramesCount Property

"Walkthrough Frames"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WalkthroughFramesCount { get; }
Public Shared ReadOnly Property WalkthroughFramesCount As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WalkthroughFramesCount {
    ForgeTypeId^ get ();
}
static member WalkthroughFramesCount : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WallAlignKeyRefParam Property

ParameterTypeIdWallAlignKeyRefParam Property

"Location line to align"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WallAlignKeyRefParam { get; }
Public Shared ReadOnly Property WallAlignKeyRefParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WallAlignKeyRefParam {
    ForgeTypeId^ get ();
}
static member WallAlignKeyRefParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WallAttrDefheightParam Property

ParameterTypeIdWallAttrDefheightParam Property

"Default height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WallAttrDefheightParam { get; }
Public Shared ReadOnly Property WallAttrDefheightParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WallAttrDefheightParam {
    ForgeTypeId^ get ();
}
static member WallAttrDefheightParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WallAttrHeightParam Property

ParameterTypeIdWallAttrHeightParam Property

"Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WallAttrHeightParam { get; }
Public Shared ReadOnly Property WallAttrHeightParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WallAttrHeightParam {
    ForgeTypeId^ get ();
}
static member WallAttrHeightParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WallAttrRoomBounding Property

ParameterTypeIdWallAttrRoomBounding Property

"Room Bounding"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WallAttrRoomBounding { get; }
Public Shared ReadOnly Property WallAttrRoomBounding As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WallAttrRoomBounding {
    ForgeTypeId^ get ();
}
static member WallAttrRoomBounding : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WallAttrWidthParam Property

ParameterTypeIdWallAttrWidthParam Property

"Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WallAttrWidthParam { get; }
Public Shared ReadOnly Property WallAttrWidthParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WallAttrWidthParam {
    ForgeTypeId^ get ();
}
static member WallAttrWidthParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WallBaseConstraint Property

ParameterTypeIdWallBaseConstraint Property

"Base Constraint"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WallBaseConstraint { get; }
Public Shared ReadOnly Property WallBaseConstraint As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WallBaseConstraint {
    ForgeTypeId^ get ();
}
static member WallBaseConstraint : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WallBaseHeightParam Property

ParameterTypeIdWallBaseHeightParam Property

"Base height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WallBaseHeightParam { get; }
Public Shared ReadOnly Property WallBaseHeightParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WallBaseHeightParam {
    ForgeTypeId^ get ();
}
static member WallBaseHeightParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WallBaseOffset Property

ParameterTypeIdWallBaseOffset Property

"Base Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WallBaseOffset { get; }
Public Shared ReadOnly Property WallBaseOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WallBaseOffset {
    ForgeTypeId^ get ();
}
static member WallBaseOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WallBottomExtensionDistParam Property

ParameterTypeIdWallBottomExtensionDistParam Property

"Base Extension Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WallBottomExtensionDistParam { get; }
Public Shared ReadOnly Property WallBottomExtensionDistParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WallBottomExtensionDistParam {
    ForgeTypeId^ get ();
}
static member WallBottomExtensionDistParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WallBottomIsAttached Property

ParameterTypeIdWallBottomIsAttached Property

"Base is Attached"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WallBottomIsAttached { get; }
Public Shared ReadOnly Property WallBottomIsAttached As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WallBottomIsAttached {
    ForgeTypeId^ get ();
}
static member WallBottomIsAttached : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WallCrossSection Property

ParameterTypeIdWallCrossSection Property

"Cross-Section"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WallCrossSection { get; }
Public Shared ReadOnly Property WallCrossSection As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WallCrossSection {
    ForgeTypeId^ get ();
}
static member WallCrossSection : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WallHeightType Property

ParameterTypeIdWallHeightType Property

"Top Constraint"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WallHeightType { get; }
Public Shared ReadOnly Property WallHeightType As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WallHeightType {
    ForgeTypeId^ get ();
}
static member WallHeightType : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WallKeyRefParam Property

ParameterTypeIdWallKeyRefParam Property

"Location Line"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WallKeyRefParam { get; }
Public Shared ReadOnly Property WallKeyRefParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WallKeyRefParam {
    ForgeTypeId^ get ();
}
static member WallKeyRefParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WallLocationLineOffsetParam Property

ParameterTypeIdWallLocationLineOffsetParam Property

"Location Line Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WallLocationLineOffsetParam { get; }
Public Shared ReadOnly Property WallLocationLineOffsetParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WallLocationLineOffsetParam {
    ForgeTypeId^ get ();
}
static member WallLocationLineOffsetParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WallSingleSlantAngleFromVertical Property

ParameterTypeIdWallSingleSlantAngleFromVertical Property

"Angle From Vertical"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WallSingleSlantAngleFromVertical { get; }
Public Shared ReadOnly Property WallSingleSlantAngleFromVertical As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WallSingleSlantAngleFromVertical {
    ForgeTypeId^ get ();
}
static member WallSingleSlantAngleFromVertical : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WallStructuralSignificant Property

ParameterTypeIdWallStructuralSignificant Property

"Structural"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WallStructuralSignificant { get; }
Public Shared ReadOnly Property WallStructuralSignificant As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WallStructuralSignificant {
    ForgeTypeId^ get ();
}
static member WallStructuralSignificant : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WallStructuralUsageParam Property

ParameterTypeIdWallStructuralUsageParam Property

"Structural Usage"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WallStructuralUsageParam { get; }
Public Shared ReadOnly Property WallStructuralUsageParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WallStructuralUsageParam {
    ForgeTypeId^ get ();
}
static member WallStructuralUsageParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WallStructureIdParam Property

ParameterTypeIdWallStructureIdParam Property

"Structure"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WallStructureIdParam { get; }
Public Shared ReadOnly Property WallStructureIdParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WallStructureIdParam {
    ForgeTypeId^ get ();
}
static member WallStructureIdParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WallSweepCutByInsertsParam Property

ParameterTypeIdWallSweepCutByInsertsParam Property

"Cut by Inserts"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WallSweepCutByInsertsParam { get; }
Public Shared ReadOnly Property WallSweepCutByInsertsParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WallSweepCutByInsertsParam {
    ForgeTypeId^ get ();
}
static member WallSweepCutByInsertsParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WallSweepCutsWallParam Property

ParameterTypeIdWallSweepCutsWallParam Property

"Cuts Wall"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WallSweepCutsWallParam { get; }
Public Shared ReadOnly Property WallSweepCutsWallParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WallSweepCutsWallParam {
    ForgeTypeId^ get ();
}
static member WallSweepCutsWallParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WallSweepDefaultSetbackParam Property

ParameterTypeIdWallSweepDefaultSetbackParam Property

"Default Setback"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WallSweepDefaultSetbackParam { get; }
Public Shared ReadOnly Property WallSweepDefaultSetbackParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WallSweepDefaultSetbackParam {
    ForgeTypeId^ get ();
}
static member WallSweepDefaultSetbackParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WallSweepLevelParam Property

ParameterTypeIdWallSweepLevelParam Property

"Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WallSweepLevelParam { get; }
Public Shared ReadOnly Property WallSweepLevelParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WallSweepLevelParam {
    ForgeTypeId^ get ();
}
static member WallSweepLevelParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WallSweepOffsetParam Property

ParameterTypeIdWallSweepOffsetParam Property

"Offset From Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WallSweepOffsetParam { get; }
Public Shared ReadOnly Property WallSweepOffsetParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WallSweepOffsetParam {
    ForgeTypeId^ get ();
}
static member WallSweepOffsetParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WallSweepOrientation Property

ParameterTypeIdWallSweepOrientation Property

"Orientation"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WallSweepOrientation { get; }
Public Shared ReadOnly Property WallSweepOrientation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WallSweepOrientation {
    ForgeTypeId^ get ();
}
static member WallSweepOrientation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WallSweepProfileParam Property

ParameterTypeIdWallSweepProfileParam Property

"Profile"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WallSweepProfileParam { get; }
Public Shared ReadOnly Property WallSweepProfileParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WallSweepProfileParam {
    ForgeTypeId^ get ();
}
static member WallSweepProfileParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WallSweepWallOffsetParam Property

ParameterTypeIdWallSweepWallOffsetParam Property

"Offset From Wall"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WallSweepWallOffsetParam { get; }
Public Shared ReadOnly Property WallSweepWallOffsetParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WallSweepWallOffsetParam {
    ForgeTypeId^ get ();
}
static member WallSweepWallOffsetParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WallSweepWallSubcategoryId Property

ParameterTypeIdWallSweepWallSubcategoryId Property

"Subcategory of Walls"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WallSweepWallSubcategoryId { get; }
Public Shared ReadOnly Property WallSweepWallSubcategoryId As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WallSweepWallSubcategoryId {
    ForgeTypeId^ get ();
}
static member WallSweepWallSubcategoryId : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WallTaperedExteriorInwardAngle Property

ParameterTypeIdWallTaperedExteriorInwardAngle Property

"Exterior Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WallTaperedExteriorInwardAngle { get; }
Public Shared ReadOnly Property WallTaperedExteriorInwardAngle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WallTaperedExteriorInwardAngle {
    ForgeTypeId^ get ();
}
static member WallTaperedExteriorInwardAngle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WallTaperedInteriorInwardAngle Property

ParameterTypeIdWallTaperedInteriorInwardAngle Property

"Interior Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WallTaperedInteriorInwardAngle { get; }
Public Shared ReadOnly Property WallTaperedInteriorInwardAngle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WallTaperedInteriorInwardAngle {
    ForgeTypeId^ get ();
}
static member WallTaperedInteriorInwardAngle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WallTaperedUseInstanceAngles Property

ParameterTypeIdWallTaperedUseInstanceAngles Property

"Enable Angle Overrides"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WallTaperedUseInstanceAngles { get; }
Public Shared ReadOnly Property WallTaperedUseInstanceAngles As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WallTaperedUseInstanceAngles {
    ForgeTypeId^ get ();
}
static member WallTaperedUseInstanceAngles : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WallTaperedWidthAtBottom Property

ParameterTypeIdWallTaperedWidthAtBottom Property

"Bottom Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WallTaperedWidthAtBottom { get; }
Public Shared ReadOnly Property WallTaperedWidthAtBottom As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WallTaperedWidthAtBottom {
    ForgeTypeId^ get ();
}
static member WallTaperedWidthAtBottom : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WallTaperedWidthAtTop Property

ParameterTypeIdWallTaperedWidthAtTop Property

"Top Width"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WallTaperedWidthAtTop { get; }
Public Shared ReadOnly Property WallTaperedWidthAtTop As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WallTaperedWidthAtTop {
    ForgeTypeId^ get ();
}
static member WallTaperedWidthAtTop : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WallTopExtensionDistParam Property

ParameterTypeIdWallTopExtensionDistParam Property

"Top Extension Distance"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WallTopExtensionDistParam { get; }
Public Shared ReadOnly Property WallTopExtensionDistParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WallTopExtensionDistParam {
    ForgeTypeId^ get ();
}
static member WallTopExtensionDistParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WallTopIsAttached Property

ParameterTypeIdWallTopIsAttached Property

"Top is Attached"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WallTopIsAttached { get; }
Public Shared ReadOnly Property WallTopIsAttached As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WallTopIsAttached {
    ForgeTypeId^ get ();
}
static member WallTopIsAttached : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WallTopOffset Property

ParameterTypeIdWallTopOffset Property

"Top Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WallTopOffset { get; }
Public Shared ReadOnly Property WallTopOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WallTopOffset {
    ForgeTypeId^ get ();
}
static member WallTopOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WallTypeDefaultTaperedExteriorInwardAngle Property

ParameterTypeIdWallTypeDefaultTaperedExteriorInwardAngle Property

"Default Exterior Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WallTypeDefaultTaperedExteriorInwardAngle { get; }
Public Shared ReadOnly Property WallTypeDefaultTaperedExteriorInwardAngle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WallTypeDefaultTaperedExteriorInwardAngle {
    ForgeTypeId^ get ();
}
static member WallTypeDefaultTaperedExteriorInwardAngle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WallTypeDefaultTaperedInteriorInwardAngle Property

ParameterTypeIdWallTypeDefaultTaperedInteriorInwardAngle Property

"Default Interior Angle"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WallTypeDefaultTaperedInteriorInwardAngle { get; }
Public Shared ReadOnly Property WallTypeDefaultTaperedInteriorInwardAngle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WallTypeDefaultTaperedInteriorInwardAngle {
    ForgeTypeId^ get ();
}
static member WallTypeDefaultTaperedInteriorInwardAngle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WallTypeWidthMeasuredAt Property

ParameterTypeIdWallTypeWidthMeasuredAt Property

"Width Measured At"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WallTypeWidthMeasuredAt { get; }
Public Shared ReadOnly Property WallTypeWidthMeasuredAt As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WallTypeWidthMeasuredAt {
    ForgeTypeId^ get ();
}
static member WallTypeWidthMeasuredAt : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WallUserHeightParam Property

ParameterTypeIdWallUserHeightParam Property

"Unconnected Height"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WallUserHeightParam { get; }
Public Shared ReadOnly Property WallUserHeightParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WallUserHeightParam {
    ForgeTypeId^ get ();
}
static member WallUserHeightParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WindowTypeId Property

ParameterTypeIdWindowTypeId Property

"Type Mark"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WindowTypeId { get; }
Public Shared ReadOnly Property WindowTypeId As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WindowTypeId {
    ForgeTypeId^ get ();
}
static member WindowTypeId : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WindowtypeIsSchematic Property

ParameterTypeIdWindowtypeIsSchematic Property

"Schematic"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WindowtypeIsSchematic { get; }
Public Shared ReadOnly Property WindowtypeIsSchematic As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WindowtypeIsSchematic {
    ForgeTypeId^ get ();
}
static member WindowtypeIsSchematic : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WindowTypeName Property

ParameterTypeIdWindowTypeName Property

"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WindowTypeName { get; }
Public Shared ReadOnly Property WindowTypeName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WindowTypeName {
    ForgeTypeId^ get ();
}
static member WindowTypeName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WitnsLineExtension Property

ParameterTypeIdWitnsLineExtension Property

"Witness Line Extension"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WitnsLineExtension { get; }
Public Shared ReadOnly Property WitnsLineExtension As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WitnsLineExtension {
    ForgeTypeId^ get ();
}
static member WitnsLineExtension : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WitnsLineGapToElt Property

ParameterTypeIdWitnsLineGapToElt Property

"Witness Line Gap to Element"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WitnsLineGapToElt { get; }
Public Shared ReadOnly Property WitnsLineGapToElt As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WitnsLineGapToElt {
    ForgeTypeId^ get ();
}
static member WitnsLineGapToElt : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WitnsLineTickMark Property

ParameterTypeIdWitnsLineTickMark Property

"Witness Line Tick Mark"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WitnsLineTickMark { get; }
Public Shared ReadOnly Property WitnsLineTickMark As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WitnsLineTickMark {
    ForgeTypeId^ get ();
}
static member WitnsLineTickMark : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WrappingAtEndsParam Property

ParameterTypeIdWrappingAtEndsParam Property

"Wrapping at Ends"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WrappingAtEndsParam { get; }
Public Shared ReadOnly Property WrappingAtEndsParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WrappingAtEndsParam {
    ForgeTypeId^ get ();
}
static member WrappingAtEndsParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.WrappingAtInsertsParam Property

ParameterTypeIdWrappingAtInsertsParam Property

"Wrapping at Inserts"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WrappingAtInsertsParam { get; }
Public Shared ReadOnly Property WrappingAtInsertsParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WrappingAtInsertsParam {
    ForgeTypeId^ get ();
}
static member WrappingAtInsertsParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.YJustification Property

ParameterTypeIdYJustification Property

"y Justification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId YJustification { get; }
Public Shared ReadOnly Property YJustification As ForgeTypeId
    Get
public:
static property ForgeTypeId^ YJustification {
    ForgeTypeId^ get ();
}
static member YJustification : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.YOffsetValue Property

ParameterTypeIdYOffsetValue Property

"y Offset Value"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId YOffsetValue { get; }
Public Shared ReadOnly Property YOffsetValue As ForgeTypeId
    Get
public:
static property ForgeTypeId^ YOffsetValue {
    ForgeTypeId^ get ();
}
static member YOffsetValue : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.YzJustification Property

ParameterTypeIdYzJustification Property

"yz Justification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId YzJustification { get; }
Public Shared ReadOnly Property YzJustification As ForgeTypeId
    Get
public:
static property ForgeTypeId^ YzJustification {
    ForgeTypeId^ get ();
}
static member YzJustification : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZJustification Property

ParameterTypeIdZJustification Property

"z Justification"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZJustification { get; }
Public Shared ReadOnly Property ZJustification As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZJustification {
    ForgeTypeId^ get ();
}
static member ZJustification : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZOffsetValue Property

ParameterTypeIdZOffsetValue Property

"z Offset Value"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZOffsetValue { get; }
Public Shared ReadOnly Property ZOffsetValue As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZOffsetValue {
    ForgeTypeId^ get ();
}
static member ZOffsetValue : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZoneAirChangesPerHour Property

ParameterTypeIdZoneAirChangesPerHour Property

"Air Changes per Hour"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZoneAirChangesPerHour { get; }
Public Shared ReadOnly Property ZoneAirChangesPerHour As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZoneAirChangesPerHour {
    ForgeTypeId^ get ();
}
static member ZoneAirChangesPerHour : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZoneAirVolumeCalculationTypeParam Property

ParameterTypeIdZoneAirVolumeCalculationTypeParam Property

"Air Volume Calculation Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZoneAirVolumeCalculationTypeParam { get; }
Public Shared ReadOnly Property ZoneAirVolumeCalculationTypeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZoneAirVolumeCalculationTypeParam {
    ForgeTypeId^ get ();
}
static member ZoneAirVolumeCalculationTypeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZoneArea Property

ParameterTypeIdZoneArea Property

"Occupied Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZoneArea { get; }
Public Shared ReadOnly Property ZoneArea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZoneArea {
    ForgeTypeId^ get ();
}
static member ZoneArea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZoneAreaGross Property

ParameterTypeIdZoneAreaGross Property

"Gross Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZoneAreaGross { get; }
Public Shared ReadOnly Property ZoneAreaGross As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZoneAreaGross {
    ForgeTypeId^ get ();
}
static member ZoneAreaGross : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZoneCalculatedAreaPerCoolingLoadParam Property

ParameterTypeIdZoneCalculatedAreaPerCoolingLoadParam Property

"Calculated Area per Cooling Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZoneCalculatedAreaPerCoolingLoadParam { get; }
Public Shared ReadOnly Property ZoneCalculatedAreaPerCoolingLoadParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZoneCalculatedAreaPerCoolingLoadParam {
    ForgeTypeId^ get ();
}
static member ZoneCalculatedAreaPerCoolingLoadParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZoneCalculatedAreaPerHeatingLoadParam Property

ParameterTypeIdZoneCalculatedAreaPerHeatingLoadParam Property

"Calculated Area per Heating Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZoneCalculatedAreaPerHeatingLoadParam { get; }
Public Shared ReadOnly Property ZoneCalculatedAreaPerHeatingLoadParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZoneCalculatedAreaPerHeatingLoadParam {
    ForgeTypeId^ get ();
}
static member ZoneCalculatedAreaPerHeatingLoadParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZoneCalculatedCoolingLoadParam Property

ParameterTypeIdZoneCalculatedCoolingLoadParam Property

"Calculated Cooling Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZoneCalculatedCoolingLoadParam { get; }
Public Shared ReadOnly Property ZoneCalculatedCoolingLoadParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZoneCalculatedCoolingLoadParam {
    ForgeTypeId^ get ();
}
static member ZoneCalculatedCoolingLoadParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZoneCalculatedCoolingLoadPerAreaParam Property

ParameterTypeIdZoneCalculatedCoolingLoadPerAreaParam Property

"Calculated Cooling Load per area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZoneCalculatedCoolingLoadPerAreaParam { get; }
Public Shared ReadOnly Property ZoneCalculatedCoolingLoadPerAreaParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZoneCalculatedCoolingLoadPerAreaParam {
    ForgeTypeId^ get ();
}
static member ZoneCalculatedCoolingLoadPerAreaParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZoneCalculatedHeatingLoadParam Property

ParameterTypeIdZoneCalculatedHeatingLoadParam Property

"Calculated Heating Load"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZoneCalculatedHeatingLoadParam { get; }
Public Shared ReadOnly Property ZoneCalculatedHeatingLoadParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZoneCalculatedHeatingLoadParam {
    ForgeTypeId^ get ();
}
static member ZoneCalculatedHeatingLoadParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZoneCalculatedHeatingLoadPerAreaParam Property

ParameterTypeIdZoneCalculatedHeatingLoadPerAreaParam Property

"Calculated Heating Load per area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZoneCalculatedHeatingLoadPerAreaParam { get; }
Public Shared ReadOnly Property ZoneCalculatedHeatingLoadPerAreaParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZoneCalculatedHeatingLoadPerAreaParam {
    ForgeTypeId^ get ();
}
static member ZoneCalculatedHeatingLoadPerAreaParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZoneCalculatedHydronicCoolingflowParam Property

ParameterTypeIdZoneCalculatedHydronicCoolingflowParam Property

"Calculated Hydronic Cooling Flow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZoneCalculatedHydronicCoolingflowParam { get; }
Public Shared ReadOnly Property ZoneCalculatedHydronicCoolingflowParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZoneCalculatedHydronicCoolingflowParam {
    ForgeTypeId^ get ();
}
static member ZoneCalculatedHydronicCoolingflowParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZoneCalculatedHydronicHeatingflowParam Property

ParameterTypeIdZoneCalculatedHydronicHeatingflowParam Property

"Calculated Hydronic Heating Flow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZoneCalculatedHydronicHeatingflowParam { get; }
Public Shared ReadOnly Property ZoneCalculatedHydronicHeatingflowParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZoneCalculatedHydronicHeatingflowParam {
    ForgeTypeId^ get ();
}
static member ZoneCalculatedHydronicHeatingflowParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZoneCalculatedSupplyAirflowParam Property

ParameterTypeIdZoneCalculatedSupplyAirflowParam Property

"Calculated Supply Airflow"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZoneCalculatedSupplyAirflowParam { get; }
Public Shared ReadOnly Property ZoneCalculatedSupplyAirflowParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZoneCalculatedSupplyAirflowParam {
    ForgeTypeId^ get ();
}
static member ZoneCalculatedSupplyAirflowParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZoneCalculatedSupplyAirflowPerAreaParam Property

ParameterTypeIdZoneCalculatedSupplyAirflowPerAreaParam Property

"Calculated Supply Airflow per area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZoneCalculatedSupplyAirflowPerAreaParam { get; }
Public Shared ReadOnly Property ZoneCalculatedSupplyAirflowPerAreaParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZoneCalculatedSupplyAirflowPerAreaParam {
    ForgeTypeId^ get ();
}
static member ZoneCalculatedSupplyAirflowPerAreaParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZoneCoilBypassPercentageParam Property

ParameterTypeIdZoneCoilBypassPercentageParam Property

"Coil Bypass"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZoneCoilBypassPercentageParam { get; }
Public Shared ReadOnly Property ZoneCoilBypassPercentageParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZoneCoilBypassPercentageParam {
    ForgeTypeId^ get ();
}
static member ZoneCoilBypassPercentageParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZoneCoolingAirTemperatureParam Property

ParameterTypeIdZoneCoolingAirTemperatureParam Property

"Cooling Air Temperature"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZoneCoolingAirTemperatureParam { get; }
Public Shared ReadOnly Property ZoneCoolingAirTemperatureParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZoneCoolingAirTemperatureParam {
    ForgeTypeId^ get ();
}
static member ZoneCoolingAirTemperatureParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZoneCoolingInformationParam Property

ParameterTypeIdZoneCoolingInformationParam Property

"Cooling Information"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZoneCoolingInformationParam { get; }
Public Shared ReadOnly Property ZoneCoolingInformationParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZoneCoolingInformationParam {
    ForgeTypeId^ get ();
}
static member ZoneCoolingInformationParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZoneCoolingSetPointParam Property

ParameterTypeIdZoneCoolingSetPointParam Property

"Cooling Set Point"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZoneCoolingSetPointParam { get; }
Public Shared ReadOnly Property ZoneCoolingSetPointParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZoneCoolingSetPointParam {
    ForgeTypeId^ get ();
}
static member ZoneCoolingSetPointParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZoneDehumidificationSetPointParam Property

ParameterTypeIdZoneDehumidificationSetPointParam Property

"Dehumidification Set Point"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZoneDehumidificationSetPointParam { get; }
Public Shared ReadOnly Property ZoneDehumidificationSetPointParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZoneDehumidificationSetPointParam {
    ForgeTypeId^ get ();
}
static member ZoneDehumidificationSetPointParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZoneDesignCoolTemperature Property

ParameterTypeIdZoneDesignCoolTemperature Property

"Design Temperature for Cooling"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZoneDesignCoolTemperature { get; }
Public Shared ReadOnly Property ZoneDesignCoolTemperature As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZoneDesignCoolTemperature {
    ForgeTypeId^ get ();
}
static member ZoneDesignCoolTemperature : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZoneDesignHeatTemperature Property

ParameterTypeIdZoneDesignHeatTemperature Property

"Design Temperature for Heating"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZoneDesignHeatTemperature { get; }
Public Shared ReadOnly Property ZoneDesignHeatTemperature As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZoneDesignHeatTemperature {
    ForgeTypeId^ get ();
}
static member ZoneDesignHeatTemperature : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZoneHeatingAirTemperatureParam Property

ParameterTypeIdZoneHeatingAirTemperatureParam Property

"Heating Air Temperature"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZoneHeatingAirTemperatureParam { get; }
Public Shared ReadOnly Property ZoneHeatingAirTemperatureParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZoneHeatingAirTemperatureParam {
    ForgeTypeId^ get ();
}
static member ZoneHeatingAirTemperatureParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZoneHeatingInformationParam Property

ParameterTypeIdZoneHeatingInformationParam Property

"Heating Information"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZoneHeatingInformationParam { get; }
Public Shared ReadOnly Property ZoneHeatingInformationParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZoneHeatingInformationParam {
    ForgeTypeId^ get ();
}
static member ZoneHeatingInformationParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZoneHeatingSetPointParam Property

ParameterTypeIdZoneHeatingSetPointParam Property

"Heating Set Point"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZoneHeatingSetPointParam { get; }
Public Shared ReadOnly Property ZoneHeatingSetPointParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZoneHeatingSetPointParam {
    ForgeTypeId^ get ();
}
static member ZoneHeatingSetPointParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZoneHumidificationSetPointParam Property

ParameterTypeIdZoneHumidificationSetPointParam Property

"Humidification Set Point"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZoneHumidificationSetPointParam { get; }
Public Shared ReadOnly Property ZoneHumidificationSetPointParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZoneHumidificationSetPointParam {
    ForgeTypeId^ get ();
}
static member ZoneHumidificationSetPointParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZoneLevelId Property

ParameterTypeIdZoneLevelId Property

"Level"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZoneLevelId { get; }
Public Shared ReadOnly Property ZoneLevelId As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZoneLevelId {
    ForgeTypeId^ get ();
}
static member ZoneLevelId : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZoneLevelOffset Property

ParameterTypeIdZoneLevelOffset Property

"Level Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZoneLevelOffset { get; }
Public Shared ReadOnly Property ZoneLevelOffset As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZoneLevelOffset {
    ForgeTypeId^ get ();
}
static member ZoneLevelOffset : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZoneLevelOffsetTop Property

ParameterTypeIdZoneLevelOffsetTop Property

"Top Offset"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZoneLevelOffsetTop { get; }
Public Shared ReadOnly Property ZoneLevelOffsetTop As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZoneLevelOffsetTop {
    ForgeTypeId^ get ();
}
static member ZoneLevelOffsetTop : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZoneName Property

ParameterTypeIdZoneName Property

"Name"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZoneName { get; }
Public Shared ReadOnly Property ZoneName As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZoneName {
    ForgeTypeId^ get ();
}
static member ZoneName : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZoneOaRatePerAchParam Property

ParameterTypeIdZoneOaRatePerAchParam Property

"Outdoor Air Rate / Air Changes per Hour"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZoneOaRatePerAchParam { get; }
Public Shared ReadOnly Property ZoneOaRatePerAchParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZoneOaRatePerAchParam {
    ForgeTypeId^ get ();
}
static member ZoneOaRatePerAchParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZoneOutdoorAirInformationParam Property

ParameterTypeIdZoneOutdoorAirInformationParam Property

"Outdoor Air Information"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZoneOutdoorAirInformationParam { get; }
Public Shared ReadOnly Property ZoneOutdoorAirInformationParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZoneOutdoorAirInformationParam {
    ForgeTypeId^ get ();
}
static member ZoneOutdoorAirInformationParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZoneOutsideAirFlowPerArea Property

ParameterTypeIdZoneOutsideAirFlowPerArea Property

"Outside Air Flow per Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZoneOutsideAirFlowPerArea { get; }
Public Shared ReadOnly Property ZoneOutsideAirFlowPerArea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZoneOutsideAirFlowPerArea {
    ForgeTypeId^ get ();
}
static member ZoneOutsideAirFlowPerArea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZoneOutsideAirFlowPerPerson Property

ParameterTypeIdZoneOutsideAirFlowPerPerson Property

"Outside Air Flow per Person"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZoneOutsideAirFlowPerPerson { get; }
Public Shared ReadOnly Property ZoneOutsideAirFlowPerPerson As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZoneOutsideAirFlowPerPerson {
    ForgeTypeId^ get ();
}
static member ZoneOutsideAirFlowPerPerson : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZoneOutsideAirPerAreaParam Property

ParameterTypeIdZoneOutsideAirPerAreaParam Property

"Outdoor Air per Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZoneOutsideAirPerAreaParam { get; }
Public Shared ReadOnly Property ZoneOutsideAirPerAreaParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZoneOutsideAirPerAreaParam {
    ForgeTypeId^ get ();
}
static member ZoneOutsideAirPerAreaParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZoneOutsideAirPerPersonParam Property

ParameterTypeIdZoneOutsideAirPerPersonParam Property

"Outdoor Air per Person"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZoneOutsideAirPerPersonParam { get; }
Public Shared ReadOnly Property ZoneOutsideAirPerPersonParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZoneOutsideAirPerPersonParam {
    ForgeTypeId^ get ();
}
static member ZoneOutsideAirPerPersonParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZonePerimeter Property

ParameterTypeIdZonePerimeter Property

"Perimeter"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZonePerimeter { get; }
Public Shared ReadOnly Property ZonePerimeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZonePerimeter {
    ForgeTypeId^ get ();
}
static member ZonePerimeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZonePhase Property

ParameterTypeIdZonePhase Property

"Phase"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZonePhase { get; }
Public Shared ReadOnly Property ZonePhase As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZonePhase {
    ForgeTypeId^ get ();
}
static member ZonePhase : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZonePhaseId Property

ParameterTypeIdZonePhaseId Property

"Phase Id"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZonePhaseId { get; }
Public Shared ReadOnly Property ZonePhaseId As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZonePhaseId {
    ForgeTypeId^ get ();
}
static member ZonePhaseId : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZoneServiceTypeParam Property

ParameterTypeIdZoneServiceTypeParam Property

"Service Type"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZoneServiceTypeParam { get; }
Public Shared ReadOnly Property ZoneServiceTypeParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZoneServiceTypeParam {
    ForgeTypeId^ get ();
}
static member ZoneServiceTypeParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZoneSpaceOutdoorAirOptionParam Property

ParameterTypeIdZoneSpaceOutdoorAirOptionParam Property

"Space Outdoor Air Option"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZoneSpaceOutdoorAirOptionParam { get; }
Public Shared ReadOnly Property ZoneSpaceOutdoorAirOptionParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZoneSpaceOutdoorAirOptionParam {
    ForgeTypeId^ get ();
}
static member ZoneSpaceOutdoorAirOptionParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZoneUseAirChangesPerHourParam Property

ParameterTypeIdZoneUseAirChangesPerHourParam Property

"Use Air Changes Per Hour"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZoneUseAirChangesPerHourParam { get; }
Public Shared ReadOnly Property ZoneUseAirChangesPerHourParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZoneUseAirChangesPerHourParam {
    ForgeTypeId^ get ();
}
static member ZoneUseAirChangesPerHourParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZoneUseDehumidificationSetpointParam Property

ParameterTypeIdZoneUseDehumidificationSetpointParam Property

"Use Dehumidification Set Point"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZoneUseDehumidificationSetpointParam { get; }
Public Shared ReadOnly Property ZoneUseDehumidificationSetpointParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZoneUseDehumidificationSetpointParam {
    ForgeTypeId^ get ();
}
static member ZoneUseDehumidificationSetpointParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZoneUseHumidificationSetpointParam Property

ParameterTypeIdZoneUseHumidificationSetpointParam Property

"Use Humidification Set Point"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZoneUseHumidificationSetpointParam { get; }
Public Shared ReadOnly Property ZoneUseHumidificationSetpointParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZoneUseHumidificationSetpointParam {
    ForgeTypeId^ get ();
}
static member ZoneUseHumidificationSetpointParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZoneUseOutsideAirPerAreaParam Property

ParameterTypeIdZoneUseOutsideAirPerAreaParam Property

"Use Outside Air Per Area"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZoneUseOutsideAirPerAreaParam { get; }
Public Shared ReadOnly Property ZoneUseOutsideAirPerAreaParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZoneUseOutsideAirPerAreaParam {
    ForgeTypeId^ get ();
}
static member ZoneUseOutsideAirPerAreaParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZoneUseOutsideAirPerPersonParam Property

ParameterTypeIdZoneUseOutsideAirPerPersonParam Property

"Use Outside Air Per Person"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZoneUseOutsideAirPerPersonParam { get; }
Public Shared ReadOnly Property ZoneUseOutsideAirPerPersonParam As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZoneUseOutsideAirPerPersonParam {
    ForgeTypeId^ get ();
}
static member ZoneUseOutsideAirPerPersonParam : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZoneVolume Property

ParameterTypeIdZoneVolume Property

"Occupied Volume"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZoneVolume { get; }
Public Shared ReadOnly Property ZoneVolume As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZoneVolume {
    ForgeTypeId^ get ();
}
static member ZoneVolume : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterTypeId.ZoneVolumeGross Property

ParameterTypeIdZoneVolumeGross Property

"Gross Volume"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ZoneVolumeGross { get; }
Public Shared ReadOnly Property ZoneVolumeGross As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ZoneVolumeGross {
    ForgeTypeId^ get ();
}
static member ZoneVolumeGross : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

ParameterTypeId Class


ParameterUtils Class

A utility class of functions related to parameters.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBParameterUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ParameterUtils
Public NotInheritable Class ParameterUtils
public ref class ParameterUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ParameterUtils = class end

The ParameterUtils type exposes the following members.

Methods
Name | Description
DownloadCompanyName | Downloads the name of the given parameter's owning account and records it in the given document. If the owning account's name is already recorded in the given document, this method returns the name without downloading it again.
DownloadParameter | Create a shared parameter element in the given document according to a parameter definition downloaded from the Parameters Service.
DownloadParameterOptions | Retrieves settings associated with the given parameter from the Parameters Service.
GetAllBuiltInGroups | Gets the identifiers of all built-in parameter groups.
GetAllBuiltInParameters | Gets the identifiers of all built-in parameters.
GetBuiltInParameter | Gets the BuiltInParameter value corresponding to built-in parameter identified by the given ForgeTypeId.
GetParameterTypeId | Gets the ForgeTypeId identifying the built-in parameter corresponding to the given BuiltInParameter value.
IsBuiltInGroup | Checks whether a ForgeTypeId identifies a built-in parameter group.
IsBuiltInParameter(ElementId) | Checks whether an ElementId identifies a built-in parameter.
IsBuiltInParameter(ForgeTypeId) | Checks whether a ForgeTypeId identifies a built-in parameter.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ParameterUtils Methods

The ParameterUtils type exposes the following members.

Methods
Name | Description
DownloadCompanyName | Downloads the name of the given parameter's owning account and records it in the given document. If the owning account's name is already recorded in the given document, this method returns the name without downloading it again.
DownloadParameter | Create a shared parameter element in the given document according to a parameter definition downloaded from the Parameters Service.
DownloadParameterOptions | Retrieves settings associated with the given parameter from the Parameters Service.
GetAllBuiltInGroups | Gets the identifiers of all built-in parameter groups.
GetAllBuiltInParameters | Gets the identifiers of all built-in parameters.
GetBuiltInParameter | Gets the BuiltInParameter value corresponding to built-in parameter identified by the given ForgeTypeId.
GetParameterTypeId | Gets the ForgeTypeId identifying the built-in parameter corresponding to the given BuiltInParameter value.
IsBuiltInGroup | Checks whether a ForgeTypeId identifies a built-in parameter group.
IsBuiltInParameter(ElementId) | Checks whether an ElementId identifies a built-in parameter.
IsBuiltInParameter(ForgeTypeId) | Checks whether a ForgeTypeId identifies a built-in parameter.
Top
See Also

Reference

ParameterUtils Class


ParameterUtils.DownloadCompanyName Method

ParameterUtilsDownloadCompanyName Method

Downloads the name of the given parameter's owning account and records it in the given document. If the owning account's name is already recorded in the given document, this method returns the name without downloading it again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string DownloadCompanyName(
    Document document,
    ForgeTypeId parameterTypeId
)
Public Shared Function DownloadCompanyName (
    document As Document,
    parameterTypeId As ForgeTypeId
) As String
public:
static String^ DownloadCompanyName(
    Document^ document,
    ForgeTypeId^ parameterTypeId
)
static member DownloadCompanyName :
        document : Document *
        parameterTypeId : ForgeTypeId -> string

Parameters

document Document
Document in which to record the name of the parameter's owning account.
parameterTypeId ForgeTypeId
Parameter identifier.

Return Value

String
Name of the owning account.
Exceptions
Exception | Condition
AccessDeniedException | Thrown when the user is not authorized to access the requested information.
ArgumentException | Thrown when the parameter identifier does not include an account identifier.
ArgumentNullException | A non-optional argument was null
[!:Autodesk::Revit::Exceptions::NetworkCommunicationError] | Thrown when communication with the remote service is unsuccessful.
ResourceNotFoundException | Thrown when the requested information is not found.
ServerInternalException | Thrown when the remote service reports an internal error.
UnauthenticatedException | Thrown when the user is not signed in.
Remarks
In Revit, the account name appears in the parameter tooltip if available.
See Also

Reference

ParameterUtils Class


ParameterUtils.DownloadParameter Method

ParameterUtilsDownloadParameter Method

Create a shared parameter element in the given document according to a parameter definition downloaded from the Parameters Service.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SharedParameterElement DownloadParameter(
    Document document,
    ParameterDownloadOptions options,
    ForgeTypeId parameterTypeId
)
Public Shared Function DownloadParameter (
    document As Document,
    options As ParameterDownloadOptions,
    parameterTypeId As ForgeTypeId
) As SharedParameterElement
public:
static SharedParameterElement^ DownloadParameter(
    Document^ document,
    ParameterDownloadOptions^ options,
    ForgeTypeId^ parameterTypeId
)
static member DownloadParameter :
        document : Document *
        options : ParameterDownloadOptions *
        parameterTypeId : ForgeTypeId -> SharedParameterElement

Parameters

document Document
Document in which to create a shared parameter from a downloaded definition.
options ParameterDownloadOptions
Parameter download options.
parameterTypeId ForgeTypeId
Parameter identifier.

Return Value

SharedParameterElement
The shared parameter instance.
Exceptions
Exception | Condition
ArgumentException | Thrown when the parameter identifier does not include a GUID, when required bindings are not assigned, when the requested group identifier does not identify a group that accommodates user-defined parameters, when a parameter with a matching GUID is already present in the given family document, when the given project document already contains an incompatible parameter definition with the same GUID, or when a parameter with a matching name is already present in the given family document.
ArgumentNullException | A non-optional argument was null
DefaultValueException | Thrown when the target document is a family and the downloaded parameter is a Family Type parameter and no family of the requisite category exists in the family document.
NetworkCommunicationException | Thrown when communication with the Parameters Service is unsuccessful.
ResourceNotFoundException | Thrown when the requested parameter definition is not found on the Parameters Service.
SchemaException | Thrown when there is an error interpreting a downloaded parameter definition.
Remarks

The identifier of a user-defined parameter definition on the Parameters Service has the form "parameters.<accountId>:<schemaId>-<versionNumber>", where <versionNumber> is a semantic version number such as "1.0.0" and <accountId> and <schemaId> are GUIDs consisting of 32 hexadecimal digits. Revit will extract the <schemaId> GUID to identify the shared parameter element.

If a shared parameter with a matching GUID is not yet present in the document, this method will attempt to obtain the parameter and apply the given bindings. If the parameter definition is already available locally, Revit will use the local definition. Otherwise, Revit will attempt to download the requested parameter definition from the Parameters Service.

The given document may be either a project or a family document. The rules for adding parameters to project and family documents differ.

For family documents, requesting a parameter with a GUID matching that of a shared parameter already present in the family document is an error.

Family parameters must have unique names. There is an error if the target document is a family and the downloaded parameter is found to have a name that matches that of a parameter already present in the family document.

Family parameters must be initialized to a default value. There is an error if the target document is a family and the downloaded parameter is a Family Type parameter and no family of the requisite category exists in the family document.

When the target document is a project, if a parameter exactly matching the given ForgeTypeId is already present in the document, this method will not download anything. Otherwise, if a local shared parameter with a GUID colliding with the given ForgeTypeId is already present in the project document, this method will download the requested parameter from the Parameters Service, validate that the requested parameter is compatible with the existing local definition, and overwrite the existing local definition according to the downloaded definition. Attempting to download an incompatible definition that collides with an existing local shared parameter is an error. If the parameter or a compatible local parameter is already present in the target project document, this method will update the existing parameter's bindings according to the given bindings. When updating bindings, new category bindings may be added to the existing parameter but existing category bindings will not be removed.

See Also

Reference

ParameterUtils Class


ParameterUtils.DownloadParameterOptions Method

ParameterUtilsDownloadParameterOptions Method

Retrieves settings associated with the given parameter from the Parameters Service.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ParameterDownloadOptions DownloadParameterOptions(
    ForgeTypeId parameterTypeId
)
Public Shared Function DownloadParameterOptions (
    parameterTypeId As ForgeTypeId
) As ParameterDownloadOptions
public:
static ParameterDownloadOptions^ DownloadParameterOptions(
    ForgeTypeId^ parameterTypeId
)
static member DownloadParameterOptions :
        parameterTypeId : ForgeTypeId -> ParameterDownloadOptions

Parameters

parameterTypeId ForgeTypeId
Parameter identifier.

Return Value

ParameterDownloadOptions
Settings associated with a parameter.
Exceptions
Exception | Condition
AccessDeniedException | Thrown when the user is not authorized to access the requested information.
ArgumentException | Thrown when the given parameter identifier is empty.
ArgumentNullException | A non-optional argument was null
[!:Autodesk::Revit::Exceptions::NetworkCommunicationError] | Thrown when communication with the Parameters Service is unsuccessful.
ResourceNotFoundException | Thrown when the requested parameter is not found.
ServerInternalException | Thrown when the Parameters Service reports an internal error.
UnauthenticatedException | Thrown when the user is not signed in.
Remarks
The settings associated with a parameter definition are accessible only to an authorized user. To retrieve them, the user must be signed in.
See Also

Reference

ParameterUtils Class


ParameterUtils.GetAllBuiltInGroups Method

ParameterUtilsGetAllBuiltInGroups Method

Gets the identifiers of all built-in parameter groups.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<ForgeTypeId> GetAllBuiltInGroups()
Public Shared Function GetAllBuiltInGroups As IList(Of ForgeTypeId)
public:
static IList<ForgeTypeId^>^ GetAllBuiltInGroups()
static member GetAllBuiltInGroups : unit -> IList<ForgeTypeId>

Return Value

IList ForgeTypeId
The built-in group identifiers.
See Also

Reference

ParameterUtils Class


ParameterUtils.GetAllBuiltInParameters Method

ParameterUtilsGetAllBuiltInParameters Method

Gets the identifiers of all built-in parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<ForgeTypeId> GetAllBuiltInParameters()
Public Shared Function GetAllBuiltInParameters As IList(Of ForgeTypeId)
public:
static IList<ForgeTypeId^>^ GetAllBuiltInParameters()
static member GetAllBuiltInParameters : unit -> IList<ForgeTypeId>

Return Value

IList ForgeTypeId
The built-in parameter identifiers.
See Also

Reference

ParameterUtils Class


ParameterUtils.GetBuiltInParameter Method

ParameterUtilsGetBuiltInParameter Method

Gets the BuiltInParameter value corresponding to built-in parameter identified by the given ForgeTypeId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static BuiltInParameter GetBuiltInParameter(
    ForgeTypeId parameterTypeId
)
Public Shared Function GetBuiltInParameter (
    parameterTypeId As ForgeTypeId
) As BuiltInParameter
public:
static BuiltInParameter GetBuiltInParameter(
    ForgeTypeId^ parameterTypeId
)
static member GetBuiltInParameter :
        parameterTypeId : ForgeTypeId -> BuiltInParameter

Parameters

parameterTypeId ForgeTypeId
The parameter identifier.

Return Value

BuiltInParameter
The BuiltInParameter value corresponding to the given parameter identifier.
Exceptions
Exception | Condition
ArgumentException | parameterTypeId is not a built-in parameter identifier. See IsBuiltInParameter(ForgeTypeId) and GetParameterTypeId(BuiltInParameter).
ArgumentNullException | A non-optional argument was NULL
See Also

Reference

ParameterUtils Class


ParameterUtils.GetParameterTypeId Method

ParameterUtilsGetParameterTypeId Method

Gets the ForgeTypeId identifying the built-in parameter corresponding to the given BuiltInParameter value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GetParameterTypeId(
    BuiltInParameter builtInParam
)
Public Shared Function GetParameterTypeId (
    builtInParam As BuiltInParameter
) As ForgeTypeId
public:
static ForgeTypeId^ GetParameterTypeId(
    BuiltInParameter builtInParam
)
static member GetParameterTypeId :
        builtInParam : BuiltInParameter -> ForgeTypeId

Parameters

builtInParam BuiltInParameter
The BuiltInParameter value.

Return Value

ForgeTypeId
Identifier of the parameter corresponding to the given BuiltInParameter value.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ParameterUtils Class


ParameterUtils.IsBuiltInGroup Method

ParameterUtilsIsBuiltInGroup Method

Checks whether a ForgeTypeId identifies a built-in parameter group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsBuiltInGroup(
    ForgeTypeId groupTypeId
)
Public Shared Function IsBuiltInGroup (
    groupTypeId As ForgeTypeId
) As Boolean
public:
static bool IsBuiltInGroup(
    ForgeTypeId^ groupTypeId
)
static member IsBuiltInGroup :
        groupTypeId : ForgeTypeId -> bool

Parameters

groupTypeId ForgeTypeId
The identifier to check.

Return Value

Boolean
True if the ForgeTypeId identifies a built-in parameter group, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
A ForgeTypeId identifies a built-in parameter group if it corresponds to a valid BuiltInParameterGroup value.
See Also

Reference

ParameterUtils Class


ParameterUtils.IsBuiltInParameter Method

ParameterUtilsIsBuiltInParameter Method

Overload List
Name | Description
IsBuiltInParameter(ElementId) | Checks whether an ElementId identifies a built-in parameter.
IsBuiltInParameter(ForgeTypeId) | Checks whether a ForgeTypeId identifies a built-in parameter.
Top
See Also

Reference

ParameterUtils Class


ParameterUtils.IsBuiltInParameter(ElementId) Method

ParameterUtilsIsBuiltInParameter(ElementId) Method

Checks whether an ElementId identifies a built-in parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsBuiltInParameter(
    ElementId parameterId
)
Public Shared Function IsBuiltInParameter (
    parameterId As ElementId
) As Boolean
public:
static bool IsBuiltInParameter(
    ElementId^ parameterId
)
static member IsBuiltInParameter :
        parameterId : ElementId -> bool

Parameters

parameterId ElementId
The identifier to check.

Return Value

Boolean
True if the ElementId identifies a built-in parameter, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
An ElementId identifies a built-in parameter if it corresponds to a valid BuiltInParameter value.
See Also

Reference

ParameterUtils Class
IsBuiltInParameter Overload


ParameterUtils.IsBuiltInParameter(ForgeTypeId) Method

ParameterUtilsIsBuiltInParameter(ForgeTypeId) Method

Checks whether a ForgeTypeId identifies a built-in parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsBuiltInParameter(
    ForgeTypeId parameterTypeId
)
Public Shared Function IsBuiltInParameter (
    parameterTypeId As ForgeTypeId
) As Boolean
public:
static bool IsBuiltInParameter(
    ForgeTypeId^ parameterTypeId
)
static member IsBuiltInParameter :
        parameterTypeId : ForgeTypeId -> bool

Parameters

parameterTypeId ForgeTypeId
The identifier to check.

Return Value

Boolean
True if the ForgeTypeId identifies a built-in parameter, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
A ForgeTypeId identifies a built-in parameter if it corresponds to a valid BuiltInParameter value.
See Also

Reference

ParameterUtils Class
IsBuiltInParameter Overload


ParameterValue Class

A class that holds a value of a parameter element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBParameterValue
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ParameterValue : IDisposable
Public Class ParameterValue
    Implements IDisposable
public ref class ParameterValue : IDisposable
type ParameterValue =
    class
        interface IDisposable
    end

The ParameterValue type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Copy | Makes an identical copy of the given parameter value.
Public method | Dispose | Releases all resources used by the ParameterValue
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqual | Tests equality with another instance of the same class.
Public method | IsSameType | Tests another instance is of the same value type.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This is a non-instantiable base class. Classes that actually store a value of a certain type are all derived from this base class, once class per each value type.
See Also

Reference

Autodesk.Revit.DB Namespace
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBParameterValue
Autodesk.Revit.DBDoubleParameterValue
Autodesk.Revit.DBElementIdParameterValue
Autodesk.Revit.DBIntegerParameterValue
Autodesk.Revit.DBNullParameterValue
Autodesk.Revit.DBStringParameterValue


ParameterValue Properties

The ParameterValue type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

ParameterValue Class


ParameterValue.IsValidObject Property

ParameterValueIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ParameterValue Class


ParameterValue Methods

The ParameterValue type exposes the following members.

Methods
 | Name | Description
Public method | Copy | Makes an identical copy of the given parameter value.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqual | Tests equality with another instance of the same class.
Public method | IsSameType | Tests another instance is of the same value type.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ParameterValue Class


ParameterValue.Copy Method

ParameterValueCopy Method

Makes an identical copy of the given parameter value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ParameterValue Copy()
Public Function Copy As ParameterValue
public:
ParameterValue^ Copy()
member Copy : unit -> ParameterValue

Return Value

ParameterValue
See Also

Reference

ParameterValue Class


ParameterValue.Dispose Method

ParameterValueDispose Method

Releases all resources used by the ParameterValue

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ParameterValue Class


ParameterValue.IsEqual Method

ParameterValueIsEqual Method

Tests equality with another instance of the same class.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEqual(
    ParameterValue other
)
Public Function IsEqual (
    other As ParameterValue
) As Boolean
public:
bool IsEqual(
    ParameterValue^ other
)
member IsEqual :
        other : ParameterValue -> bool

Parameters

other ParameterValue
The instance to compare with

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
The result is always False if the two comparands are of a different value types.
See Also

Reference

ParameterValue Class


ParameterValue.IsSameType Method

ParameterValueIsSameType Method

Tests another instance is of the same value type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSameType(
    ParameterValue other
)
Public Function IsSameType (
    other As ParameterValue
) As Boolean
public:
bool IsSameType(
    ParameterValue^ other
)
member IsSameType :
        other : ParameterValue -> bool

Parameters

other ParameterValue
The instance to compare with

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ParameterValue Class


ParameterValuePresenceRule Class

Tests whether an element's parameter has a value or not.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterRule
Autodesk.Revit.DBParameterValuePresenceRule
Autodesk.Revit.DBHasNoValueFilterRule
Autodesk.Revit.DBHasValueFilterRule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ParameterValuePresenceRule : FilterRule
Public Class ParameterValuePresenceRule
    Inherits FilterRule
public ref class ParameterValuePresenceRule : public FilterRule
type ParameterValuePresenceRule =
    class
        inherit FilterRule
    end

The ParameterValuePresenceRule type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule)
Public property | Parameter | The parameter which will be evaluated to pass this rule.
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterRule)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ParameterValuePresenceRule Properties

The ParameterValuePresenceRule type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule)
Public property | Parameter | The parameter which will be evaluated to pass this rule.
Top
See Also

Reference

ParameterValuePresenceRule Class


ParameterValuePresenceRule.Parameter Property

ParameterValuePresenceRuleParameter Property

The parameter which will be evaluated to pass this rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId Parameter { get; set; }
Public Property Parameter As ElementId
    Get
    Set
public:
property ElementId^ Parameter {
    ElementId^ get ();
    void set (ElementId^ value);
}
member Parameter : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ParameterValuePresenceRule Class


ParameterValuePresenceRule Methods

The ParameterValuePresenceRule type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterRule)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ParameterValuePresenceRule Class


ParameterValueProvider Class

Gets the value of a parameter from any element passed to GetStringValue, GetDoubleValue, GetIntegerValue, or GetElementIdValue.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterableValueProvider
Autodesk.Revit.DBParameterValueProvider

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ParameterValueProvider : FilterableValueProvider
Public Class ParameterValueProvider
    Inherits FilterableValueProvider
public ref class ParameterValueProvider : public FilterableValueProvider
type ParameterValueProvider =
    class
        inherit FilterableValueProvider
    end

The ParameterValueProvider type exposes the following members.

Constructors
 | Name | Description
Public method | ParameterValueProvider | Constructs an instance of ParameterValueProvider.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterableValueProvider)
Public property | Parameter | The parameter used to provide a string, integer, double-precision, or ElementId value on request for a given element.
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterableValueProvider)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAssociatedGlobalParameterValue | Gets a global parameter value associated with a parameter from the given element. (Inherited from FilterableValueProvider)
Public method | GetDoubleValue | Gets a double-precision numeric value from the given element. (Inherited from FilterableValueProvider)
Public method | GetElementIdValue | Gets an ElementId value from the given element. (Inherited from FilterableValueProvider)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIntegerValue | Gets an integer value from the given element. (Inherited from FilterableValueProvider)
Public method | GetStringValue | Gets a string value from the given element. (Inherited from FilterableValueProvider)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsDoubleValueSupported | Determines whether the provide can provide a double-precision numeric value for the given element. (Inherited from FilterableValueProvider)
Public method | IsElementIdValueSupported | Determines whether the provide can provide an ElementId value for the given element. (Inherited from FilterableValueProvider)
Public method | IsIntegerValueSupported | Determines whether the provide can provide an integer value for the given element. (Inherited from FilterableValueProvider)
Public method | IsStringValueSupported | Determines whether the provide can provide a string value for the given element. (Inherited from FilterableValueProvider)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

For any parameter, only one of isStringValueSupported, isDoubleValueSupported, isIntegerValueSupported, isElementIdValueSupported will return true. No attempt to convert between types is made. For example, calling GetStringValue, passing the identifier of a numeric-typed parameter will give an empty string. No exception will be thrown, and ParameterValueProvider will not attempt to convert the numeric value to a string.

If an element doesn't have the requested parameter or the element's parameter doesn't have a valid value, ParameterValueProvider will attempt to get the parameter value from the element's type - see GetTypeId.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ParameterValueProvider Constructor

Constructs an instance of ParameterValueProvider.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ParameterValueProvider(
    ElementId parameter
)
Public Sub New (
    parameter As ElementId
)
public:
ParameterValueProvider(
    ElementId^ parameter
)
new :
        parameter : ElementId -> ParameterValueProvider

Parameters

parameter ElementId
The parameter used to provide a string, integer, and double-precision, or ElementId value on request for a given element.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ParameterValueProvider Class


ParameterValueProvider Properties

The ParameterValueProvider type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterableValueProvider)
Public property | Parameter | The parameter used to provide a string, integer, double-precision, or ElementId value on request for a given element.
Top
See Also

Reference

ParameterValueProvider Class


ParameterValueProvider.Parameter Property

ParameterValueProviderParameter Property

The parameter used to provide a string, integer, double-precision, or ElementId value on request for a given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId Parameter { get; set; }
Public Property Parameter As ElementId
    Get
    Set
public:
property ElementId^ Parameter {
    ElementId^ get ();
    void set (ElementId^ value);
}
member Parameter : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ParameterValueProvider Class


ParameterValueProvider Methods

The ParameterValueProvider type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterableValueProvider)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAssociatedGlobalParameterValue | Gets a global parameter value associated with a parameter from the given element. (Inherited from FilterableValueProvider)
Public method | GetDoubleValue | Gets a double-precision numeric value from the given element. (Inherited from FilterableValueProvider)
Public method | GetElementIdValue | Gets an ElementId value from the given element. (Inherited from FilterableValueProvider)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIntegerValue | Gets an integer value from the given element. (Inherited from FilterableValueProvider)
Public method | GetStringValue | Gets a string value from the given element. (Inherited from FilterableValueProvider)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsDoubleValueSupported | Determines whether the provide can provide a double-precision numeric value for the given element. (Inherited from FilterableValueProvider)
Public method | IsElementIdValueSupported | Determines whether the provide can provide an ElementId value for the given element. (Inherited from FilterableValueProvider)
Public method | IsIntegerValueSupported | Determines whether the provide can provide an integer value for the given element. (Inherited from FilterableValueProvider)
Public method | IsStringValueSupported | Determines whether the provide can provide a string value for the given element. (Inherited from FilterableValueProvider)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ParameterValueProvider Class


Part Class

This element represents a part of another element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBPart

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Part : Element
Public Class Part
    Inherits Element
public ref class Part : public Element
type Part =
    class
        inherit Element
    end

The Part type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | Excluded | True if the part is excluded, false otherwise
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OriginalCategoryId | The category Id of the original element corresponding to this Part.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | PartMaker | The PartMaker that created this Part.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | CanOffsetFace | Checks if it is possible to offset the given face.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFaceOffset | Get face offset of the given part face.
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSourceElementIds | Gets a collection of elements from which this Part is created by the PartMaker. May return more than one source only if there is merge involved somewhere in the history of this Part.
Public method | GetSourceElementOriginalCategoryIds | Gets the category ids of the source elements which were used to form this part.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | ResetFaceOffset | Resets the offset applied to the given part face.
Public method | ResetPartShape | Resets all face offsets applied to part faces.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetFaceOffset | Offsets the given part face in the direction that points out of the solid shape with the specified amount. Negative value will offset the face into the solid shape.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
A part is associated with a PartMaker element that creates it.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Part Properties

The Part type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | Excluded | True if the part is excluded, false otherwise
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OriginalCategoryId | The category Id of the original element corresponding to this Part.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | PartMaker | The PartMaker that created this Part.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

Part Class


Part.Excluded Property

PartExcluded Property

True if the part is excluded, false otherwise

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Excluded { get; set; }
Public Property Excluded As Boolean
    Get
    Set
public:
property bool Excluded {
    bool get ();
    void set (bool value);
}
member Excluded : bool with get, set

Property Value

Boolean
See Also

Reference

Part Class


Part.OriginalCategoryId Property

PartOriginalCategoryId Property

The category Id of the original element corresponding to this Part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId OriginalCategoryId { get; set; }
Public Property OriginalCategoryId As ElementId
    Get
    Set
public:
property ElementId^ OriginalCategoryId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member OriginalCategoryId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentException | When setting this property: dPartOriginalCategoryId is not an available member of the original category ids of the elements which formed this Part.
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

Part Class


Part.PartMaker Property

PartPartMaker Property

The PartMaker that created this Part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PartMaker PartMaker { get; }
Public ReadOnly Property PartMaker As PartMaker
    Get
public:
property PartMaker^ PartMaker {
    PartMaker^ get ();
}
member PartMaker : PartMaker with get

Property Value

PartMaker
See Also

Reference

Part Class


Part Methods

The Part type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | CanOffsetFace | Checks if it is possible to offset the given face.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFaceOffset | Get face offset of the given part face.
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSourceElementIds | Gets a collection of elements from which this Part is created by the PartMaker. May return more than one source only if there is merge involved somewhere in the history of this Part.
Public method | GetSourceElementOriginalCategoryIds | Gets the category ids of the source elements which were used to form this part.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | ResetFaceOffset | Resets the offset applied to the given part face.
Public method | ResetPartShape | Resets all face offsets applied to part faces.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetFaceOffset | Offsets the given part face in the direction that points out of the solid shape with the specified amount. Negative value will offset the face into the solid shape.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Part Class


Part.CanOffsetFace Method

PartCanOffsetFace Method

Checks if it is possible to offset the given face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanOffsetFace(
    Face face
)
Public Function CanOffsetFace (
    face As Face
) As Boolean
public:
bool CanOffsetFace(
    Face^ face
)
member CanOffsetFace :
        face : Face -> bool

Parameters

face Face
face to be checked.

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

Part Class


Part.GetFaceOffset Method

PartGetFaceOffset Method

Get face offset of the given part face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetFaceOffset(
    Face face
)
Public Function GetFaceOffset (
    face As Face
) As Double
public:
double GetFaceOffset(
    Face^ face
)
member GetFaceOffset :
        face : Face -> float

Parameters

face Face
The face whose offset is required.

Return Value

Double
Returns the value of the offset.
Exceptions
Exception | Condition
ArgumentException | face does not belong to the part.
ArgumentNullException | A non-optional argument was null
See Also

Reference

Part Class


Part.GetSourceElementIds Method

PartGetSourceElementIds Method

Gets a collection of elements from which this Part is created by the PartMaker. May return more than one source only if there is merge involved somewhere in the history of this Part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<LinkElementId> GetSourceElementIds()
Public Function GetSourceElementIds As ICollection(Of LinkElementId)
public:
ICollection<LinkElementId^>^ GetSourceElementIds()
member GetSourceElementIds : unit -> ICollection<LinkElementId>

Return Value

ICollection LinkElementId
The collection of elements
Remarks
A source element is one of the elements in the original file that the PartMaker uses to create a Part. For example, a floor or a wall used to create a Part can be called a source element.
See Also

Reference

Part Class


Part.GetSourceElementOriginalCategoryIds Method

PartGetSourceElementOriginalCategoryIds Method

Gets the category ids of the source elements which were used to form this part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetSourceElementOriginalCategoryIds()
Public Function GetSourceElementOriginalCategoryIds As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetSourceElementOriginalCategoryIds()
member GetSourceElementOriginalCategoryIds : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
The category ids.
See Also

Reference

Part Class


Part.ResetFaceOffset Method

PartResetFaceOffset Method

Resets the offset applied to the given part face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetFaceOffset(
    Face face
)
Public Sub ResetFaceOffset (
    face As Face
)
public:
void ResetFaceOffset(
    Face^ face
)
member ResetFaceOffset :
        face : Face -> unit

Parameters

face Face
The face whose offset needs to be reset.
Exceptions
Exception | Condition
ArgumentException | face does not belong to the part.
ArgumentNullException | A non-optional argument was null
See Also

Reference

Part Class


Part.ResetPartShape Method

PartResetPartShape Method

Resets all face offsets applied to part faces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetPartShape()
Public Sub ResetPartShape
public:
void ResetPartShape()
member ResetPartShape : unit -> unit
See Also

Reference

Part Class


Part.SetFaceOffset Method

PartSetFaceOffset Method

Offsets the given part face in the direction that points out of the solid shape with the specified amount. Negative value will offset the face into the solid shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetFaceOffset(
    Face face,
    double offset
)
Public Sub SetFaceOffset (
    face As Face,
    offset As Double
)
public:
void SetFaceOffset(
    Face^ face,
    double offset
)
member SetFaceOffset :
        face : Face *
        offset : float -> unit

Parameters

face Face
The face to offset.
offset Double
The magnitude of the offset.
Exceptions
Exception | Condition
ArgumentException | face does not belong to the part. -or- The face to be offset should be planar and satisfy constraints of its parent element
ArgumentNullException | A non-optional argument was null
See Also

Reference

Part Class


PartEdgeConditionOrientation Enumeration

Relative orientation of the right/lower and left/upper edge condition profiles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum PartEdgeConditionOrientation
Public Enumeration PartEdgeConditionOrientation
public enum class PartEdgeConditionOrientation
type PartEdgeConditionOrientation
Members
Member name | Value | Description
Complement | 0 | Before division gap is applied the left/upper and right/lower profiles coincide and neighboring panels complement each other precisely.
Mirrored | 1 | Right/lower profile is obtained by mirroring the left/upper profile with respect to the division line. The division gap is not applied.
MirroredAndRotated | 2 | Right/lower profile is obtained first by mirroring the left/upper profile with respect to the division line and then by mirroring the result with respect to the center line of the divided thickness. The division gap is not applied.
Remarks
A family-based profile defines the shape of the left/upper profile and this value defines how a matching right/lower profile is obtained.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PartMaker Class

PartMaker is an element which takes some source elements (e.g., a wall with all its layers) and creates one or more Parts out of it. The logic according to which these Parts are created is non-trivial and PartMaker uses various PartMakerMethods which represents these logics. This element manages the strategy to make Part elements for one or more original elements.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBPartMaker

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PartMaker : Element
Public Class PartMaker
    Inherits Element
public ref class PartMaker : public Element
type PartMaker =
    class
        inherit Element
    end

The PartMaker type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSourceElementIds | Get the source elements for the PartMaker.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSourceElement | Is the element a source for this PartMaker
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetSourceElementIds | Set the source elements for the PartMaker.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PartMaker Properties

The PartMaker type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

PartMaker Class


PartMaker Methods

The PartMaker type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSourceElementIds | Get the source elements for the PartMaker.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSourceElement | Is the element a source for this PartMaker
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetSourceElementIds | Set the source elements for the PartMaker.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PartMaker Class


PartMaker.GetSourceElementIds Method

PartMakerGetSourceElementIds Method

Get the source elements for the PartMaker.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<LinkElementId> GetSourceElementIds()
Public Function GetSourceElementIds As ICollection(Of LinkElementId)
public:
ICollection<LinkElementId^>^ GetSourceElementIds()
member GetSourceElementIds : unit -> ICollection<LinkElementId>

Return Value

ICollection LinkElementId
Elements that are the sources for this PartMaker.
See Also

Reference

PartMaker Class


PartMaker.IsSourceElement Method

PartMakerIsSourceElement Method

Is the element a source for this PartMaker

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSourceElement(
    ElementId elemId
)
Public Function IsSourceElement (
    elemId As ElementId
) As Boolean
public:
bool IsSourceElement(
    ElementId^ elemId
)
member IsSourceElement :
        elemId : ElementId -> bool

Parameters

elemId ElementId

Return Value

Boolean
Returns true if elemId is among the source elements of this PartMaker
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

PartMaker Class


PartMaker.SetSourceElementIds Method

PartMakerSetSourceElementIds Method

Set the source elements for the PartMaker.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetSourceElementIds(
    ICollection<ElementId> sourceElementIds
)
Public Sub SetSourceElementIds (
    sourceElementIds As ICollection(Of ElementId)
)
public:
void SetSourceElementIds(
    ICollection<ElementId^>^ sourceElementIds
)
member SetSourceElementIds :
        sourceElementIds : ICollection<ElementId> -> unit

Parameters

sourceElementIds ICollection ElementId
Elements to be the sources for this PartMaker.
Exceptions
Exception | Condition
ArgumentException | One or more element ids was not permitted to be a source for this PartMaker Elements should be Parts that have no PartMaker yet
ArgumentNullException | A non-optional argument was null
See Also

Reference

PartMaker Class


PartMakerMethodToDivideVolumes Class

By-References dividing strategy used by PartMaker element. TODO_REFACTOR("LegacyMechanismOfMovingElements") returns true if - the Host Elements are not floors or walls - OR - the Host Elements that are referenced by this PartMaker are floors or walls - transformation has already been applied on those Host Elements
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBPartMakerMethodToDivideVolumes

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PartMakerMethodToDivideVolumes : IDisposable
Public Class PartMakerMethodToDivideVolumes
    Implements IDisposable
public ref class PartMakerMethodToDivideVolumes : IDisposable
type PartMakerMethodToDivideVolumes =
    class
        interface IDisposable
    end

The PartMakerMethodToDivideVolumes type exposes the following members.

Properties
 | Name | Description
Public property | DivisionGap | The gap which is created between matching profiles of parts.
Public property | DivisionPatternMirror | Whether pattern defined by the division rule should be mirrored before application Mirroring is similar to changing indices of u-const gridlines.
Public property | DivisionRotationAngle | Angle by which both u- and v- gridlines of the division are rotated with respect to the natural u/v-const directions of the sketch plane.
Public property | DivisionRuleId | Id of the 'DivisionRule' which is used to augment the cutting sketch.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ProfileFlipAcross | True if the corresponding left/upper parts profile are mirrored with respect to the division line. False if the profile of left/upper parts are defined directly by the profile family.
Public property | ProfileFlipAlong | True if the corresponding left/upper parts profile are mirrored with respect to the center line of the hosts to be divided. False if the profile of left/upper parts are defined directly by the profile family.
Public property | ProfileMatch | Determines how two profiles match.
Public property | ProfileOffset | The offset which is applied to a family-defined profile in the direction away from the division line and toward left/upper part to obtain its profile.
Public property | ProfileType | The id of the profile family applied to boundaries between parts.
Public property | UConstDivisionIndent | Indentation for the application of division rule's pattern across u-const gridlines (i.e., similar to changing indices of u-const gridlines).
Public property | VConstDivisionIndent | Indentation for the application of division rule's pattern across v-const gridlines (i.e., similar to changing indices of v-const gridlines).
Top
Methods
 | Name | Description
Public method | AddIntersectingReference | Adds intersecting reference with an offset.
Public method | AreElementsValidIntersectingReferences(ICollectionElementId) | Identifies if provided members are valid.
 | AreElementsValidIntersectingReferences(Document, ICollectionElementId) | Identifies if provided members are valid.
Public method | CanBeDivisionProfile(ElementId) | Checks whether a family defines a profile which can be used by this method.
 | CanBeDivisionProfile(ElementId, Document) | Checks whether a family defines a profile which can be used by this method.
Public method | Dispose | Releases all resources used by the PartMakerMethodToDivideVolumes
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetOffsetForIntersectingReference | Gets offset for the intersecting reference.
Public method | GetPlaneOfSketch | Gets the plane of the sketch.
Public method | GetSketchCurves | Populates the array with copies of curves in the sketch.
Public method | GetSplitRefsOffsets | Returns offsets for plane-defining splitters.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsElementValidIntersectingReference(ElementId) | Identifies if the provided member is valid.
 | IsElementValidIntersectingReference(Document, ElementId) | Identifies if the provided member is valid.
 | IsValidSketchPlane | Identifies if provided sketch plane is valid.
Public method | RemoveIntersectingReference | Removed intersecting reference.
Public method | SetOffsetForIntersectingReference | Sets offset for the intersecting reference.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UsesReference | Identifies if the PartMaker uses the intersecting reference.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PartMakerMethodToDivideVolumes Properties

The PartMakerMethodToDivideVolumes type exposes the following members.

Properties
 | Name | Description
Public property | DivisionGap | The gap which is created between matching profiles of parts.
Public property | DivisionPatternMirror | Whether pattern defined by the division rule should be mirrored before application Mirroring is similar to changing indices of u-const gridlines.
Public property | DivisionRotationAngle | Angle by which both u- and v- gridlines of the division are rotated with respect to the natural u/v-const directions of the sketch plane.
Public property | DivisionRuleId | Id of the 'DivisionRule' which is used to augment the cutting sketch.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ProfileFlipAcross | True if the corresponding left/upper parts profile are mirrored with respect to the division line. False if the profile of left/upper parts are defined directly by the profile family.
Public property | ProfileFlipAlong | True if the corresponding left/upper parts profile are mirrored with respect to the center line of the hosts to be divided. False if the profile of left/upper parts are defined directly by the profile family.
Public property | ProfileMatch | Determines how two profiles match.
Public property | ProfileOffset | The offset which is applied to a family-defined profile in the direction away from the division line and toward left/upper part to obtain its profile.
Public property | ProfileType | The id of the profile family applied to boundaries between parts.
Public property | UConstDivisionIndent | Indentation for the application of division rule's pattern across u-const gridlines (i.e., similar to changing indices of u-const gridlines).
Public property | VConstDivisionIndent | Indentation for the application of division rule's pattern across v-const gridlines (i.e., similar to changing indices of v-const gridlines).
Top
See Also

Reference

PartMakerMethodToDivideVolumes Class


PartMakerMethodToDivideVolumes.DivisionGap Property

PartMakerMethodToDivideVolumesDivisionGap Property

The gap which is created between matching profiles of parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double DivisionGap { get; set; }
Public Property DivisionGap As Double
    Get
    Set
public:
property double DivisionGap {
    double get ();
    void set (double value);
}
member DivisionGap : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The given value for divisionGap must be between 0 and 30000 feet.
See Also

Reference

PartMakerMethodToDivideVolumes Class


PartMakerMethodToDivideVolumes.DivisionPatternMirror Property

PartMakerMethodToDivideVolumesDivisionPatternMirror Property

Whether pattern defined by the division rule should be mirrored before application Mirroring is similar to changing indices of u-const gridlines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool DivisionPatternMirror { get; set; }
Public Property DivisionPatternMirror As Boolean
    Get
    Set
public:
property bool DivisionPatternMirror {
    bool get ();
    void set (bool value);
}
member DivisionPatternMirror : bool with get, set

Property Value

Boolean
See Also

Reference

PartMakerMethodToDivideVolumes Class


PartMakerMethodToDivideVolumes.DivisionRotationAngle Property

PartMakerMethodToDivideVolumesDivisionRotationAngle Property

Angle by which both u- and v- gridlines of the division are rotated with respect to the natural u/v-const directions of the sketch plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double DivisionRotationAngle { get; set; }
Public Property DivisionRotationAngle As Double
    Get
    Set
public:
property double DivisionRotationAngle {
    double get ();
    void set (double value);
}
member DivisionRotationAngle : float with get, set

Property Value

Double
See Also

Reference

PartMakerMethodToDivideVolumes Class


PartMakerMethodToDivideVolumes.DivisionRuleId Property

PartMakerMethodToDivideVolumesDivisionRuleId Property

Id of the 'DivisionRule' which is used to augment the cutting sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId DivisionRuleId { get; set; }
Public Property DivisionRuleId As ElementId
    Get
    Set
public:
property ElementId^ DivisionRuleId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member DivisionRuleId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentException | When setting this property: The provided element id cannot be assigned as a division rule to this PartMakerMethodToDivideVolumes.
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

PartMakerMethodToDivideVolumes Class


PartMakerMethodToDivideVolumes.IsValidObject Property

PartMakerMethodToDivideVolumesIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

PartMakerMethodToDivideVolumes Class


PartMakerMethodToDivideVolumes.ProfileFlipAcross Property

PartMakerMethodToDivideVolumesProfileFlipAcross Property

True if the corresponding left/upper parts profile are mirrored with respect to the division line. False if the profile of left/upper parts are defined directly by the profile family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ProfileFlipAcross { get; set; }
Public Property ProfileFlipAcross As Boolean
    Get
    Set
public:
property bool ProfileFlipAcross {
    bool get ();
    void set (bool value);
}
member ProfileFlipAcross : bool with get, set

Property Value

Boolean
See Also

Reference

PartMakerMethodToDivideVolumes Class


PartMakerMethodToDivideVolumes.ProfileFlipAlong Property

PartMakerMethodToDivideVolumesProfileFlipAlong Property

True if the corresponding left/upper parts profile are mirrored with respect to the center line of the hosts to be divided. False if the profile of left/upper parts are defined directly by the profile family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ProfileFlipAlong { get; set; }
Public Property ProfileFlipAlong As Boolean
    Get
    Set
public:
property bool ProfileFlipAlong {
    bool get ();
    void set (bool value);
}
member ProfileFlipAlong : bool with get, set

Property Value

Boolean
See Also

Reference

PartMakerMethodToDivideVolumes Class


PartMakerMethodToDivideVolumes.ProfileMatch Property

PartMakerMethodToDivideVolumesProfileMatch Property

Determines how two profiles match.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PartEdgeConditionOrientation ProfileMatch { get; set; }
Public Property ProfileMatch As PartEdgeConditionOrientation
    Get
    Set
public:
property PartEdgeConditionOrientation ProfileMatch {
    PartEdgeConditionOrientation get ();
    void set (PartEdgeConditionOrientation value);
}
member ProfileMatch : PartEdgeConditionOrientation with get, set

Property Value

PartEdgeConditionOrientation
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

PartMakerMethodToDivideVolumes Class


PartMakerMethodToDivideVolumes.ProfileOffset Property

PartMakerMethodToDivideVolumesProfileOffset Property

The offset which is applied to a family-defined profile in the direction away from the division line and toward left/upper part to obtain its profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double ProfileOffset { get; set; }
Public Property ProfileOffset As Double
    Get
    Set
public:
property double ProfileOffset {
    double get ();
    void set (double value);
}
member ProfileOffset : float with get, set

Property Value

Double
See Also

Reference

PartMakerMethodToDivideVolumes Class


PartMakerMethodToDivideVolumes.ProfileType Property

PartMakerMethodToDivideVolumesProfileType Property

The id of the profile family applied to boundaries between parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId ProfileType { get; set; }
Public Property ProfileType As ElementId
    Get
    Set
public:
property ElementId^ ProfileType {
    ElementId^ get ();
    void set (ElementId^ value);
}
member ProfileType : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

PartMakerMethodToDivideVolumes Class


PartMakerMethodToDivideVolumes.UConstDivisionIndent Property

PartMakerMethodToDivideVolumesUConstDivisionIndent Property

Indentation for the application of division rule's pattern across u-const gridlines (i.e., similar to changing indices of u-const gridlines).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int UConstDivisionIndent { get; set; }
Public Property UConstDivisionIndent As Integer
    Get
    Set
public:
property int UConstDivisionIndent {
    int get ();
    void set (int value);
}
member UConstDivisionIndent : int with get, set

Property Value

Int32
See Also

Reference

PartMakerMethodToDivideVolumes Class


PartMakerMethodToDivideVolumes.VConstDivisionIndent Property

PartMakerMethodToDivideVolumesVConstDivisionIndent Property

Indentation for the application of division rule's pattern across v-const gridlines (i.e., similar to changing indices of v-const gridlines).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int VConstDivisionIndent { get; set; }
Public Property VConstDivisionIndent As Integer
    Get
    Set
public:
property int VConstDivisionIndent {
    int get ();
    void set (int value);
}
member VConstDivisionIndent : int with get, set

Property Value

Int32
See Also

Reference

PartMakerMethodToDivideVolumes Class


PartMakerMethodToDivideVolumes Methods

The PartMakerMethodToDivideVolumes type exposes the following members.

Methods
 | Name | Description
Public method | AddIntersectingReference | Adds intersecting reference with an offset.
Public method | AreElementsValidIntersectingReferences(ICollectionElementId) | Identifies if provided members are valid.
 | AreElementsValidIntersectingReferences(Document, ICollectionElementId) | Identifies if provided members are valid.
Public method | CanBeDivisionProfile(ElementId) | Checks whether a family defines a profile which can be used by this method.
 | CanBeDivisionProfile(ElementId, Document) | Checks whether a family defines a profile which can be used by this method.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetOffsetForIntersectingReference | Gets offset for the intersecting reference.
Public method | GetPlaneOfSketch | Gets the plane of the sketch.
Public method | GetSketchCurves | Populates the array with copies of curves in the sketch.
Public method | GetSplitRefsOffsets | Returns offsets for plane-defining splitters.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsElementValidIntersectingReference(ElementId) | Identifies if the provided member is valid.
 | IsElementValidIntersectingReference(Document, ElementId) | Identifies if the provided member is valid.
 | IsValidSketchPlane | Identifies if provided sketch plane is valid.
Public method | RemoveIntersectingReference | Removed intersecting reference.
Public method | SetOffsetForIntersectingReference | Sets offset for the intersecting reference.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UsesReference | Identifies if the PartMaker uses the intersecting reference.
Top
See Also

Reference

PartMakerMethodToDivideVolumes Class


PartMakerMethodToDivideVolumes.AddIntersectingReference Method

PartMakerMethodToDivideVolumesAddIntersectingReference Method

Adds intersecting reference with an offset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AddIntersectingReference(
    ElementId intersectingReference,
    double offset
)
Public Function AddIntersectingReference (
    intersectingReference As ElementId,
    offset As Double
) As Boolean
public:
bool AddIntersectingReference(
    ElementId^ intersectingReference,
    double offset
)
member AddIntersectingReference :
        intersectingReference : ElementId *
        offset : float -> bool

Parameters

intersectingReference ElementId
Id of the new intersecting reference.
offset Double
The Offste for the new intersecting reference.

Return Value

Boolean
True if the PartMaker did not already use this intersecting reference and it was added, false if the PartMaker already used this intersecting reference and this call only updated its offset.
Exceptions
Exception | Condition
ArgumentException | The element id was not permitted as intersecting references. Intersecting references should be levels, grids, or reference planes.
ArgumentNullException | A non-optional argument was null
See Also

Reference

PartMakerMethodToDivideVolumes Class


PartMakerMethodToDivideVolumes.AreElementsValidIntersectingReferences Method

PartMakerMethodToDivideVolumesAreElementsValidIntersectingReferences Method

Overload List
 | Name | Description
Public method | AreElementsValidIntersectingReferences(ICollectionElementId) | Identifies if provided members are valid.
 | AreElementsValidIntersectingReferences(Document, ICollectionElementId) | Identifies if provided members are valid.
Top
See Also

Reference

PartMakerMethodToDivideVolumes Class


PartMakerMethodToDivideVolumes.AreElementsValidIntersectingReferences(ICollection<ElementId>) Method

PartMakerMethodToDivideVolumesAreElementsValidIntersectingReferences(ICollectionElementId) Method

Identifies if provided members are valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AreElementsValidIntersectingReferences(
    ICollection<ElementId> elementIds
)
Public Function AreElementsValidIntersectingReferences (
    elementIds As ICollection(Of ElementId)
) As Boolean
public:
bool AreElementsValidIntersectingReferences(
    ICollection<ElementId^>^ elementIds
)
member AreElementsValidIntersectingReferences :
        elementIds : ICollection<ElementId> -> bool

Parameters

elementIds ICollection ElementId
Element ids to be tested for validity for intersecting references.

Return Value

Boolean
True if all references are valid, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

PartMakerMethodToDivideVolumes Class
AreElementsValidIntersectingReferences Overload


PartMakerMethodToDivideVolumes.AreElementsValidIntersectingReferences(Document, ICollection<ElementId>) Method

PartMakerMethodToDivideVolumesAreElementsValidIntersectingReferences(Document, ICollectionElementId) Method

Identifies if provided members are valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool AreElementsValidIntersectingReferences(
    Document document,
    ICollection<ElementId> elementIds
)
Public Shared Function AreElementsValidIntersectingReferences (
    document As Document,
    elementIds As ICollection(Of ElementId)
) As Boolean
public:
static bool AreElementsValidIntersectingReferences(
    Document^ document,
    ICollection<ElementId^>^ elementIds
)
static member AreElementsValidIntersectingReferences :
        document : Document *
        elementIds : ICollection<ElementId> -> bool

Parameters

document Document
The document.
elementIds ICollection ElementId
Element ids to be tested for validity for intersecting references.

Return Value

Boolean
True if all references are valid, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

PartMakerMethodToDivideVolumes Class
AreElementsValidIntersectingReferences Overload


PartMakerMethodToDivideVolumes.CanBeDivisionProfile Method

PartMakerMethodToDivideVolumesCanBeDivisionProfile Method

Overload List
 | Name | Description
Public method | CanBeDivisionProfile(ElementId) | Checks whether a family defines a profile which can be used by this method.
 | CanBeDivisionProfile(ElementId, Document) | Checks whether a family defines a profile which can be used by this method.
Top
See Also

Reference

PartMakerMethodToDivideVolumes Class


PartMakerMethodToDivideVolumes.CanBeDivisionProfile(ElementId) Method

PartMakerMethodToDivideVolumesCanBeDivisionProfile(ElementId) Method

Checks whether a family defines a profile which can be used by this method.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanBeDivisionProfile(
    ElementId familyId
)
Public Function CanBeDivisionProfile (
    familyId As ElementId
) As Boolean
public:
bool CanBeDivisionProfile(
    ElementId^ familyId
)
member CanBeDivisionProfile :
        familyId : ElementId -> bool

Parameters

familyId ElementId
Element id of the family.

Return Value

Boolean
True if the family defines a profile which can be used by a part maker, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

PartMakerMethodToDivideVolumes Class
CanBeDivisionProfile Overload


PartMakerMethodToDivideVolumes.CanBeDivisionProfile(ElementId, Document) Method

PartMakerMethodToDivideVolumesCanBeDivisionProfile(ElementId, Document) Method

Checks whether a family defines a profile which can be used by this method.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CanBeDivisionProfile(
    ElementId familyId,
    Document familyDocument
)
Public Shared Function CanBeDivisionProfile (
    familyId As ElementId,
    familyDocument As Document
) As Boolean
public:
static bool CanBeDivisionProfile(
    ElementId^ familyId,
    Document^ familyDocument
)
static member CanBeDivisionProfile :
        familyId : ElementId *
        familyDocument : Document -> bool

Parameters

familyId ElementId
Element id of the family.
familyDocument Document
The document containing the family to be tested.

Return Value

Boolean
True if the family defines a profile which can be used by a part maker, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

PartMakerMethodToDivideVolumes Class
CanBeDivisionProfile Overload


PartMakerMethodToDivideVolumes.Dispose Method

PartMakerMethodToDivideVolumesDispose Method

Releases all resources used by the PartMakerMethodToDivideVolumes

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

PartMakerMethodToDivideVolumes Class


PartMakerMethodToDivideVolumes.GetOffsetForIntersectingReference Method

PartMakerMethodToDivideVolumesGetOffsetForIntersectingReference Method

Gets offset for the intersecting reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetOffsetForIntersectingReference(
    ElementId intersectingReference
)
Public Function GetOffsetForIntersectingReference (
    intersectingReference As ElementId
) As Double
public:
double GetOffsetForIntersectingReference(
    ElementId^ intersectingReference
)
member GetOffsetForIntersectingReference :
        intersectingReference : ElementId -> float

Parameters

intersectingReference ElementId
The intersecting reference to obtain offset value from.

Return Value

Double
The offset for the intersecting reference
Exceptions
Exception | Condition
ArgumentException | PartMaker does not use the specified intersecting reference.
ArgumentNullException | A non-optional argument was null
See Also

Reference

PartMakerMethodToDivideVolumes Class


PartMakerMethodToDivideVolumes.GetPlaneOfSketch Method

PartMakerMethodToDivideVolumesGetPlaneOfSketch Method

Gets the plane of the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Plane GetPlaneOfSketch()
Public Function GetPlaneOfSketch As Plane
public:
Plane^ GetPlaneOfSketch()
member GetPlaneOfSketch : unit -> Plane

Return Value

Plane
The plane of the sketch.
See Also

Reference

PartMakerMethodToDivideVolumes Class


PartMakerMethodToDivideVolumes.GetSketchCurves Method

PartMakerMethodToDivideVolumesGetSketchCurves Method

Populates the array with copies of curves in the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void GetSketchCurves(
    out IList<Curve> curveArray
)
Public Sub GetSketchCurves (
    <OutAttribute> ByRef curveArray As IList(Of Curve)
)
public:
void GetSketchCurves(
    [OutAttribute] IList<Curve^>^% curveArray
)
member GetSketchCurves :
        curveArray : IList<Curve> byref -> unit

Parameters

curveArray IList Curve
Curves in the sketch. Tags of the curves are consistent with the curve tags used in part keys.
See Also

Reference

PartMakerMethodToDivideVolumes Class


PartMakerMethodToDivideVolumes.GetSplitRefsOffsets Method

PartMakerMethodToDivideVolumesGetSplitRefsOffsets Method

Returns offsets for plane-defining splitters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IDictionary<ElementId, double> GetSplitRefsOffsets()
Public Function GetSplitRefsOffsets As IDictionary(Of ElementId, Double)
public:
IDictionary<ElementId^, double>^ GetSplitRefsOffsets()
member GetSplitRefsOffsets : unit -> IDictionary<ElementId, float>

Return Value

IDictionary ElementId, Double
See Also

Reference

PartMakerMethodToDivideVolumes Class


PartMakerMethodToDivideVolumes.IsElementValidIntersectingReference Method

PartMakerMethodToDivideVolumesIsElementValidIntersectingReference Method

Overload List
 | Name | Description
Public method | IsElementValidIntersectingReference(ElementId) | Identifies if the provided member is valid.
 | IsElementValidIntersectingReference(Document, ElementId) | Identifies if the provided member is valid.
Top
See Also

Reference

PartMakerMethodToDivideVolumes Class


PartMakerMethodToDivideVolumes.IsElementValidIntersectingReference(ElementId) Method

PartMakerMethodToDivideVolumesIsElementValidIntersectingReference(ElementId) Method

Identifies if the provided member is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsElementValidIntersectingReference(
    ElementId elementId
)
Public Function IsElementValidIntersectingReference (
    elementId As ElementId
) As Boolean
public:
bool IsElementValidIntersectingReference(
    ElementId^ elementId
)
member IsElementValidIntersectingReference :
        elementId : ElementId -> bool

Parameters

elementId ElementId
Element ids to be tested for validity for intersecting references.

Return Value

Boolean
True if the reference is valid, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

PartMakerMethodToDivideVolumes Class
IsElementValidIntersectingReference Overload


PartMakerMethodToDivideVolumes.IsElementValidIntersectingReference(Document, ElementId) Method

PartMakerMethodToDivideVolumesIsElementValidIntersectingReference(Document, ElementId) Method

Identifies if the provided member is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsElementValidIntersectingReference(
    Document document,
    ElementId elementId
)
Public Shared Function IsElementValidIntersectingReference (
    document As Document,
    elementId As ElementId
) As Boolean
public:
static bool IsElementValidIntersectingReference(
    Document^ document,
    ElementId^ elementId
)
static member IsElementValidIntersectingReference :
        document : Document *
        elementId : ElementId -> bool

Parameters

document Document
The document.
elementId ElementId
Element ids to be tested for validity for intersecting references.

Return Value

Boolean
True if the reference is valid, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

PartMakerMethodToDivideVolumes Class
IsElementValidIntersectingReference Overload


PartMakerMethodToDivideVolumes.IsValidSketchPlane Method

PartMakerMethodToDivideVolumesIsValidSketchPlane Method

Identifies if provided sketch plane is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidSketchPlane(
    Document document,
    ElementId sketchPlaneId
)
Public Shared Function IsValidSketchPlane (
    document As Document,
    sketchPlaneId As ElementId
) As Boolean
public:
static bool IsValidSketchPlane(
    Document^ document,
    ElementId^ sketchPlaneId
)
static member IsValidSketchPlane :
        document : Document *
        sketchPlaneId : ElementId -> bool

Parameters

document Document
The document.
sketchPlaneId ElementId
SketchPlane ids to be tested for validity for PartMaker.

Return Value

Boolean
True if SketchPlane valid, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

PartMakerMethodToDivideVolumes Class


PartMakerMethodToDivideVolumes.RemoveIntersectingReference Method

PartMakerMethodToDivideVolumesRemoveIntersectingReference Method

Removed intersecting reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool RemoveIntersectingReference(
    ElementId intersectingReference
)
Public Function RemoveIntersectingReference (
    intersectingReference As ElementId
) As Boolean
public:
bool RemoveIntersectingReference(
    ElementId^ intersectingReference
)
member RemoveIntersectingReference :
        intersectingReference : ElementId -> bool

Parameters

intersectingReference ElementId
Id of the intersecting reference to remove.

Return Value

Boolean
True if the PartMaker used this intersecting reference and this call removed it, false if the PartMaker did not use this intersecting reference.
Exceptions
Exception | Condition
ArgumentException | The element id was not permitted as intersecting references. Intersecting references should be levels, grids, or reference planes.
ArgumentNullException | A non-optional argument was null
See Also

Reference

PartMakerMethodToDivideVolumes Class


PartMakerMethodToDivideVolumes.SetOffsetForIntersectingReference Method

PartMakerMethodToDivideVolumesSetOffsetForIntersectingReference Method

Sets offset for the intersecting reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetOffsetForIntersectingReference(
    ElementId intersectingReference,
    double offset
)
Public Sub SetOffsetForIntersectingReference (
    intersectingReference As ElementId,
    offset As Double
)
public:
void SetOffsetForIntersectingReference(
    ElementId^ intersectingReference,
    double offset
)
member SetOffsetForIntersectingReference :
        intersectingReference : ElementId *
        offset : float -> unit

Parameters

intersectingReference ElementId
The intersecting reference that will be offset.
offset Double
The new offset.
Exceptions
Exception | Condition
ArgumentException | PartMaker does not use the specified intersecting reference.
ArgumentNullException | A non-optional argument was null
See Also

Reference

PartMakerMethodToDivideVolumes Class


PartMakerMethodToDivideVolumes.UsesReference Method

PartMakerMethodToDivideVolumesUsesReference Method

Identifies if the PartMaker uses the intersecting reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UsesReference(
    ElementId intersectingReference
)
Public Function UsesReference (
    intersectingReference As ElementId
) As Boolean
public:
bool UsesReference(
    ElementId^ intersectingReference
)
member UsesReference :
        intersectingReference : ElementId -> bool

Parameters

intersectingReference ElementId
Intersecting reference to be tested.

Return Value

Boolean
True if the intersecting reference is used by the PartMaker.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

PartMakerMethodToDivideVolumes Class


PartsVisibility Enumeration

Indicates the visibility of parts for the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum PartsVisibility
Public Enumeration PartsVisibility
public enum class PartsVisibility
type PartsVisibility
Members
Member name | Value | Description
ShowPartsOnly | 0 | Show only parts for the view.
ShowOriginalOnly | 1 | Show original elements, not parts, for the view.
ShowPartsAndOriginal | 2 | Show both original elements and parts for the view.
Unset | -1 | Parts visibility is not set for the view.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PartType Enumeration

An enumerated type listing all MEP family part types. A part type typically provides one unique set of type parameters that defines this part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum PartType
Public Enumeration PartType
public enum class PartType
type PartType
Members
Member name | Value | Description
Normal | 0 | Normal part type
DuctMounted | 1 | Duct mounted part type
JunctionBox | 2 | JunctionBox part type
AttachesTo | 3 | Attaches to part type
BreaksInto | 4 | Breaks into part type
Elbow | 5 | Elbow part type
Tee | 6 | Tee part type
Transition | 7 | Transition part type
Cross | 8 | Cross part type
Cap | 9 | Cap part type
Undefined | -1 | Undefined part type
TapPerpendicular | 10 | Tap perpendicular part type
TapAdjustable | 11 | Tap adjustable part type
Offset | 12 | Offset part type
Union | 13 | Union part type
PanelBoard | 14 | Panel board part type
Transformer | 15 | Transformer part type
SwitchBoard | 16 | Switch board part type
OtherPanel | 17 | Other panel part type
EquipmentSwitch | 18 | Equipment switch part type
Switch | 19 | Switch part type
ValveBreaksInto | 20 | Valve breaks into part type
SpudPerpendicular | 21 | Spud perpendicular part type
SpudAdjustable | 22 | Spud adjustable part type
Damper | 23 | Damper part type
Wye | 24 | Wye part type
LateralTee | 25 | Lateral tee part type
LateralCross | 26 | Lateral cross part type
Pants | 27 | Pants part type
MultiPort | 28 | Multi port part type
ValveNormal | 29 | Valve normal part type
JunctionBoxTee | 30 | JunctionBox tee part type
JunctionBoxCross | 31 | JunctionBox cross part type
PipeFlange | 32 | Pipe flange part type
JunctionBoxElbow | 34 | JunctionBox elbow part type
ChannelCableTrayElbow | 35 | Channel CableTray Elbow part type
ChannelCableTrayVerticalElbow | 36 | Channel CableTray Vertical Elbow part type
ChannelCableTrayCross | 37 | Channel CableTray Cross part type
ChannelCableTrayTee | 38 | Channel CableTray Tee part type
ChannelCableTrayTransition | 39 | Channel CableTray Transition part type
ChannelCableTrayUnion | 40 | Channel CableTray Union part type
ChannelCableTrayOffset | 41 | Channel CableTray Offset part type
ChannelCableTrayMultiPort | 42 | Channel CableTray MultiPort part type
LadderCableTrayElbow | 43 | Ladder CableTray Elbow part type
LadderCableTrayVerticalElbow | 44 | Ladder CableTray Vertical Elbow part type
LadderCableTrayCross | 45 | Ladder CableTray Cross part type
LadderCableTrayTee | 46 | Ladder CableTray Tee part type
LadderCableTrayTransition | 47 | Ladder CableTray Transition part type
LadderCableTrayUnion | 48 | Ladder CableTray Union part type
LadderCableTrayOffset | 49 | Ladder CableTray Offset part type
LadderCableTrayMultiPort | 50 | Ladder CableTray MultiPort part type
InlineSensor | 51 | Inline Sensor part type
Sensor | 52 | Sensor part type
EndCap | 53 | EndCap part type
HandrailBracketHardware | 54 | Handrail Bracket Hardware part type
PanelBracketHardware | 55 | Panel Bracket Hardware part type
TerminationHardware | 56 | Termination Hardware part type
Rails | 57 | Rails part type
Handrails | 58 | Handrails part type
TopRails | 59 | Top Rails part type
PipeMechanicalCoupling | 60 | Pipe Mechanical Coupling part type
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PartUtils Class

General Part utility methods
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBPartUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class PartUtils
Public NotInheritable Class PartUtils
public ref class PartUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type PartUtils = class end

The PartUtils type exposes the following members.

Methods
Name | Description
AreElementsValidForCreateParts | Identifies if the given elements can be used to create parts.
ArePartsValidForDivide | Identifies if provided members are valid for dividing parts.
ArePartsValidForMerge | Identifies whether Part elements may be merged.
CreateMergedPart | Create a single merged part which represents the Parts specified by partsToMerge.
CreateParts(Document, ICollectionElementId) | Creates a new set of parts out of the original elements.
CreateParts(Document, ICollectionLinkElementId) | Creates a new set of parts out of the original elements.
DivideParts | Creates divided parts out of parts.
FindMergeableClusters | Segregates a set of elements into subsets which are valid for merge.
GetAssociatedPartMaker(Document, ElementId) | Gets associated PartMaker for an element.
GetAssociatedPartMaker(Document, LinkElementId) | Gets associated PartMaker for an element.
GetAssociatedParts(Document, ElementId, Boolean, Boolean) | Returns all Parts that are associated with the given element.
GetAssociatedParts(Document, LinkElementId, Boolean, Boolean) | Returns all Parts that are associated with the given element
GetChainLengthToOriginal | Calculates the length of the longest chain of divisions/merges to reach to an original non-Part element that is the source of the tested part.
GetMergedParts | Retrieves the element ids of the source elements of a merged part.
GetPartMakerMethodToDivideVolumeFW | Obtains the object allowing access to the divided volume properties of the PartMaker.
GetSplittingCurves(Document, ElementId) | Identifies the curves that were used to create the part.
GetSplittingCurves(Document, ElementId, Plane) | Identifies the curves that were used to create the part and the plane in which they reside.
GetSplittingElements | Identifies the elements ( reference planes, levels, grids ) that were used to create the part.
HasAssociatedParts(Document, ElementId) | Checks if an element has associated parts.
HasAssociatedParts(Document, LinkElementId) | Checks if an element has associated parts.
IsMergedPart | Is the Part the result of a merge.
IsPartDerivedFromLink | Is the Part derived from link geometry.
IsValidForCreateParts | Identifies if the given element can be used to create parts.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PartUtils Methods

The PartUtils type exposes the following members.

Methods
Name | Description
AreElementsValidForCreateParts | Identifies if the given elements can be used to create parts.
ArePartsValidForDivide | Identifies if provided members are valid for dividing parts.
ArePartsValidForMerge | Identifies whether Part elements may be merged.
CreateMergedPart | Create a single merged part which represents the Parts specified by partsToMerge.
CreateParts(Document, ICollectionElementId) | Creates a new set of parts out of the original elements.
CreateParts(Document, ICollectionLinkElementId) | Creates a new set of parts out of the original elements.
DivideParts | Creates divided parts out of parts.
FindMergeableClusters | Segregates a set of elements into subsets which are valid for merge.
GetAssociatedPartMaker(Document, ElementId) | Gets associated PartMaker for an element.
GetAssociatedPartMaker(Document, LinkElementId) | Gets associated PartMaker for an element.
GetAssociatedParts(Document, ElementId, Boolean, Boolean) | Returns all Parts that are associated with the given element.
GetAssociatedParts(Document, LinkElementId, Boolean, Boolean) | Returns all Parts that are associated with the given element
GetChainLengthToOriginal | Calculates the length of the longest chain of divisions/merges to reach to an original non-Part element that is the source of the tested part.
GetMergedParts | Retrieves the element ids of the source elements of a merged part.
GetPartMakerMethodToDivideVolumeFW | Obtains the object allowing access to the divided volume properties of the PartMaker.
GetSplittingCurves(Document, ElementId) | Identifies the curves that were used to create the part.
GetSplittingCurves(Document, ElementId, Plane) | Identifies the curves that were used to create the part and the plane in which they reside.
GetSplittingElements | Identifies the elements ( reference planes, levels, grids ) that were used to create the part.
HasAssociatedParts(Document, ElementId) | Checks if an element has associated parts.
HasAssociatedParts(Document, LinkElementId) | Checks if an element has associated parts.
IsMergedPart | Is the Part the result of a merge.
IsPartDerivedFromLink | Is the Part derived from link geometry.
IsValidForCreateParts | Identifies if the given element can be used to create parts.
Top
See Also

Reference

PartUtils Class


PartUtils.AreElementsValidForCreateParts Method

PartUtilsAreElementsValidForCreateParts Method

Identifies if the given elements can be used to create parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool AreElementsValidForCreateParts(
    Document document,
    ICollection<ElementId> elementIds
)
Public Shared Function AreElementsValidForCreateParts (
    document As Document,
    elementIds As ICollection(Of ElementId)
) As Boolean
public:
static bool AreElementsValidForCreateParts(
    Document^ document,
    ICollection<ElementId^>^ elementIds
)
static member AreElementsValidForCreateParts :
        document : Document *
        elementIds : ICollection<ElementId> -> bool

Parameters

document Document
The document.
elementIds ICollection ElementId
Element ids to be tested for validity for creating parts.

Return Value

Boolean
True if all member ids are valid, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

PartUtils Class


PartUtils.ArePartsValidForDivide Method

PartUtilsArePartsValidForDivide Method

Identifies if provided members are valid for dividing parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool ArePartsValidForDivide(
    Document document,
    ICollection<ElementId> elementIdsToDivide
)
Public Shared Function ArePartsValidForDivide (
    document As Document,
    elementIdsToDivide As ICollection(Of ElementId)
) As Boolean
public:
static bool ArePartsValidForDivide(
    Document^ document,
    ICollection<ElementId^>^ elementIdsToDivide
)
static member ArePartsValidForDivide :
        document : Document *
        elementIdsToDivide : ICollection<ElementId> -> bool

Parameters

document Document
The document.
elementIdsToDivide ICollection ElementId
Element ids to be tested for validity for dividing parts.

Return Value

Boolean
True if all member ids are valid, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

PartUtils Class


PartUtils.ArePartsValidForMerge Method

PartUtilsArePartsValidForMerge Method

Identifies whether Part elements may be merged.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool ArePartsValidForMerge(
    Document document,
    ICollection<ElementId> partIds
)
Public Shared Function ArePartsValidForMerge (
    document As Document,
    partIds As ICollection(Of ElementId)
) As Boolean
public:
static bool ArePartsValidForMerge(
    Document^ document,
    ICollection<ElementId^>^ partIds
)
static member ArePartsValidForMerge :
        document : Document *
        partIds : ICollection<ElementId> -> bool

Parameters

document Document
The document.
partIds ICollection ElementId
Element ids of Parts.

Return Value

Boolean
True if all element ids correspond to Part elements, none of the parts already has associated parts, the parts have contiguous geometry, all report the same materials, and all have the same creation and demolition phases.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

PartUtils Class


PartUtils.CreateMergedPart Method

PartUtilsCreateMergedPart Method

Create a single merged part which represents the Parts specified by partsToMerge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static PartMaker CreateMergedPart(
    Document document,
    ICollection<ElementId> partIds
)
Public Shared Function CreateMergedPart (
    document As Document,
    partIds As ICollection(Of ElementId)
) As PartMaker
public:
static PartMaker^ CreateMergedPart(
    Document^ document,
    ICollection<ElementId^>^ partIds
)
static member CreateMergedPart :
        document : Document *
        partIds : ICollection<ElementId> -> PartMaker

Parameters

document Document
The document.
partIds ICollection ElementId
The elements that the merged part will be created from.

Return Value

PartMaker
The newly created PartMaker. if no parts are merged.
Exceptions
Exception | Condition
ArgumentException | One or more element ids was not suitable for merging with the others. Specified elements should all be Parts, report the same material, creation and demolition phases, and have contiguous geometry.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
See Also

Reference

PartUtils Class


PartUtils.CreateParts Method

PartUtilsCreateParts Method

Overload List
Name | Description
CreateParts(Document, ICollectionElementId) | Creates a new set of parts out of the original elements.
CreateParts(Document, ICollectionLinkElementId) | Creates a new set of parts out of the original elements.
Top
See Also

Reference

PartUtils Class


PartUtils.CreateParts(Document, ICollection<ElementId>) Method

PartUtilsCreateParts(Document, ICollectionElementId) Method

Creates a new set of parts out of the original elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void CreateParts(
    Document document,
    ICollection<ElementId> elementIds
)
Public Shared Sub CreateParts (
    document As Document,
    elementIds As ICollection(Of ElementId)
)
public:
static void CreateParts(
    Document^ document,
    ICollection<ElementId^>^ elementIds
)
static member CreateParts :
        document : Document *
        elementIds : ICollection<ElementId> -> unit

Parameters

document Document
The document containing the elements.
elementIds ICollection ElementId
The elements that parts will be created from.
Exceptions
Exception | Condition
ArgumentException | One or more element ids was not permitted for creating parts. Elements should be of a valid category and the ids should be valid and should not already be divided into parts.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
Parts will be added to the model after regeneration.
See Also

Reference

PartUtils Class
CreateParts Overload


PartUtils.CreateParts(Document, ICollection<LinkElementId>) Method

PartUtilsCreateParts(Document, ICollectionLinkElementId) Method

Creates a new set of parts out of the original elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void CreateParts(
    Document document,
    ICollection<LinkElementId> hostOrLinkElementIds
)
Public Shared Sub CreateParts (
    document As Document,
    hostOrLinkElementIds As ICollection(Of LinkElementId)
)
public:
static void CreateParts(
    Document^ document,
    ICollection<LinkElementId^>^ hostOrLinkElementIds
)
static member CreateParts :
        document : Document *
        hostOrLinkElementIds : ICollection<LinkElementId> -> unit

Parameters

document Document
The document containing the elements.
hostOrLinkElementIds ICollection LinkElementId
The elements that parts will be created from.
Exceptions
Exception | Condition
ArgumentException | One or more element ids was not permitted for creating parts. HostOrLinkElements should be of a valid category and the ids should be valid and should not already be divided into parts.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
Parts will be added to the model after regeneration. To get the ids of the parts created by this method use PartUtils.GetAssociatedParts() with the contents of hostOrLinkElementIds.
See Also

Reference

PartUtils Class
CreateParts Overload


PartUtils.DivideParts Method

PartUtilsDivideParts Method

Creates divided parts out of parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static PartMaker DivideParts(
    Document document,
    ICollection<ElementId> elementIdsToDivide,
    ICollection<ElementId> intersectingReferenceIds,
    IList<Curve> curveArray,
    ElementId sketchPlaneId
)
Public Shared Function DivideParts (
    document As Document,
    elementIdsToDivide As ICollection(Of ElementId),
    intersectingReferenceIds As ICollection(Of ElementId),
    curveArray As IList(Of Curve),
    sketchPlaneId As ElementId
) As PartMaker
public:
static PartMaker^ DivideParts(
    Document^ document,
    ICollection<ElementId^>^ elementIdsToDivide,
    ICollection<ElementId^>^ intersectingReferenceIds,
    IList<Curve^>^ curveArray,
    ElementId^ sketchPlaneId
)
static member DivideParts :
        document : Document *
        elementIdsToDivide : ICollection<ElementId> *
        intersectingReferenceIds : ICollection<ElementId> *
        curveArray : IList<Curve> *
        sketchPlaneId : ElementId -> PartMaker

Parameters

document Document
The document containing the parts.
elementIdsToDivide ICollection ElementId
The elements that will be divided.
intersectingReferenceIds ICollection ElementId
Intersecting references that will divide the elements.
curveArray IList Curve
Array of curves that will divide the elements.
sketchPlaneId ElementId
SketchPlane id for the curves that divide the elements.

Return Value

PartMaker
The newly created PartMaker. if no parts are divided.
Exceptions
Exception | Condition
ArgumentException | One or more element ids was not permitted for dividing parts. Elements should be parts that are not yet divided and maximum distance from an original has not yet been reached. -or- One or more element ids was not permitted as intersecting references. Intersecting references should be levels, grids, or reference planes. -or- The element id should refer to a valid SketchPlane. -or- The input curveArray contains at least one helical curve and is not supported for this operation. -or- The input curveArray contains at least one NULL pointer and is not supported for this operation.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
See Also

Reference

PartUtils Class


PartUtils.FindMergeableClusters Method

PartUtilsFindMergeableClusters Method

Segregates a set of elements into subsets which are valid for merge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<ICollection<ElementId>> FindMergeableClusters(
    Document doc,
    ICollection<ElementId> partIds
)
Public Shared Function FindMergeableClusters (
    doc As Document,
    partIds As ICollection(Of ElementId)
) As IList(Of ICollection(Of ElementId))
public:
static IList<ICollection<ElementId^>^>^ FindMergeableClusters(
    Document^ doc,
    ICollection<ElementId^>^ partIds
)
static member FindMergeableClusters :
        doc : Document *
        partIds : ICollection<ElementId> -> IList<ICollection<ElementId>>

Parameters

doc Document
The document.
partIds ICollection ElementId
A set of element ids.

Return Value

IList ICollection ElementId
An array of clusters such that all the elements in a single cluster are valid for merge. Each cluster will be maximal in that appending any of the other Parts specified as input will result in a collection that is not valid for merge.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Element ids in the input set that do not correspond to Part elements will be ignored, as will element ids corresponding to Part elements that already have associated parts.
See Also

Reference

PartUtils Class


PartUtils.GetAssociatedPartMaker Method

PartUtilsGetAssociatedPartMaker Method

Overload List
Name | Description
GetAssociatedPartMaker(Document, ElementId) | Gets associated PartMaker for an element.
GetAssociatedPartMaker(Document, LinkElementId) | Gets associated PartMaker for an element.
Top
See Also

Reference

PartUtils Class


PartUtils.GetAssociatedPartMaker(Document, ElementId) Method

PartUtilsGetAssociatedPartMaker(Document, ElementId) Method

Gets associated PartMaker for an element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static PartMaker GetAssociatedPartMaker(
    Document hostDocument,
    ElementId elementId
)
Public Shared Function GetAssociatedPartMaker (
    hostDocument As Document,
    elementId As ElementId
) As PartMaker
public:
static PartMaker^ GetAssociatedPartMaker(
    Document^ hostDocument,
    ElementId^ elementId
)
static member GetAssociatedPartMaker :
        hostDocument : Document *
        elementId : ElementId -> PartMaker

Parameters

hostDocument Document
The document
elementId ElementId
The id for the element to be checked for associated Parts

Return Value

PartMaker
The PartMaker element that is making Parts for this element. if there is no associated PartMaker.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

PartUtils Class
GetAssociatedPartMaker Overload


PartUtils.GetAssociatedPartMaker(Document, LinkElementId) Method

PartUtilsGetAssociatedPartMaker(Document, LinkElementId) Method

Gets associated PartMaker for an element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static PartMaker GetAssociatedPartMaker(
    Document hostDocument,
    LinkElementId hostOrLinkElementId
)
Public Shared Function GetAssociatedPartMaker (
    hostDocument As Document,
    hostOrLinkElementId As LinkElementId
) As PartMaker
public:
static PartMaker^ GetAssociatedPartMaker(
    Document^ hostDocument,
    LinkElementId^ hostOrLinkElementId
)
static member GetAssociatedPartMaker :
        hostDocument : Document *
        hostOrLinkElementId : LinkElementId -> PartMaker

Parameters

hostDocument Document
The document
hostOrLinkElementId LinkElementId
The id for the element to be checked for associated Parts

Return Value

PartMaker
The PartMaker element that is making Parts for this element. if there is no associated PartMaker.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

PartUtils Class
GetAssociatedPartMaker Overload


PartUtils.GetAssociatedParts Method

PartUtilsGetAssociatedParts Method

Overload List
Name | Description
GetAssociatedParts(Document, ElementId, Boolean, Boolean) | Returns all Parts that are associated with the given element.
GetAssociatedParts(Document, LinkElementId, Boolean, Boolean) | Returns all Parts that are associated with the given element
Top
See Also

Reference

PartUtils Class


PartUtils.GetAssociatedParts(Document, ElementId, Boolean, Boolean) Method

PartUtilsGetAssociatedParts(Document, ElementId, Boolean, Boolean) Method

Returns all Parts that are associated with the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ICollection<ElementId> GetAssociatedParts(
    Document hostDocument,
    ElementId elementId,
    bool includePartsWithAssociatedParts,
    bool includeAllChildren
)
Public Shared Function GetAssociatedParts (
    hostDocument As Document,
    elementId As ElementId,
    includePartsWithAssociatedParts As Boolean,
    includeAllChildren As Boolean
) As ICollection(Of ElementId)
public:
static ICollection<ElementId^>^ GetAssociatedParts(
    Document^ hostDocument,
    ElementId^ elementId,
    bool includePartsWithAssociatedParts,
    bool includeAllChildren
)
static member GetAssociatedParts :
        hostDocument : Document *
        elementId : ElementId *
        includePartsWithAssociatedParts : bool *
        includeAllChildren : bool -> ICollection<ElementId>

Parameters

hostDocument Document
The document of the element.
elementId ElementId
The element to be checked for associated Parts.
includePartsWithAssociatedParts Boolean
If true, include parts that have associated parts.
includeAllChildren Boolean
If true, return all associated Parts recursively for all children. If false, only return immediate children.

Return Value

ICollection ElementId
Parts that are associated to the element.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

PartUtils Class
GetAssociatedParts Overload


PartUtils.GetAssociatedParts(Document, LinkElementId, Boolean, Boolean) Method

PartUtilsGetAssociatedParts(Document, LinkElementId, Boolean, Boolean) Method

Returns all Parts that are associated with the given element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ICollection<ElementId> GetAssociatedParts(
    Document hostDocument,
    LinkElementId hostOrLinkElementId,
    bool includePartsWithAssociatedParts,
    bool includeAllChildren
)
Public Shared Function GetAssociatedParts (
    hostDocument As Document,
    hostOrLinkElementId As LinkElementId,
    includePartsWithAssociatedParts As Boolean,
    includeAllChildren As Boolean
) As ICollection(Of ElementId)
public:
static ICollection<ElementId^>^ GetAssociatedParts(
    Document^ hostDocument,
    LinkElementId^ hostOrLinkElementId,
    bool includePartsWithAssociatedParts,
    bool includeAllChildren
)
static member GetAssociatedParts :
        hostDocument : Document *
        hostOrLinkElementId : LinkElementId *
        includePartsWithAssociatedParts : bool *
        includeAllChildren : bool -> ICollection<ElementId>

Parameters

hostDocument Document
The document of the element
hostOrLinkElementId LinkElementId
The element to be checked for associated Parts.
includePartsWithAssociatedParts Boolean
If true, include parts that have associated parts
includeAllChildren Boolean
If true, return all associated Parts recursively for all children If false, only return immediate children

Return Value

ICollection ElementId
Parts that are associated to the element
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

PartUtils Class
GetAssociatedParts Overload


PartUtils.GetChainLengthToOriginal Method

PartUtilsGetChainLengthToOriginal Method

Calculates the length of the longest chain of divisions/merges to reach to an original non-Part element that is the source of the tested part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int GetChainLengthToOriginal(
    Part part
)
Public Shared Function GetChainLengthToOriginal (
    part As Part
) As Integer
public:
static int GetChainLengthToOriginal(
    Part^ part
)
static member GetChainLengthToOriginal :
        part : Part -> int

Parameters

part Part
The part to be tested

Return Value

Int32
The length of the longest chain.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

PartUtils Class


PartUtils.GetMergedParts Method

PartUtilsGetMergedParts Method

Retrieves the element ids of the source elements of a merged part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ICollection<ElementId> GetMergedParts(
    Part part
)
Public Shared Function GetMergedParts (
    part As Part
) As ICollection(Of ElementId)
public:
static ICollection<ElementId^>^ GetMergedParts(
    Part^ part
)
static member GetMergedParts :
        part : Part -> ICollection<ElementId>

Parameters

part Part
A merged part.

Return Value

ICollection ElementId
The element ids of the parts that were merged to create the specified merged part.
Exceptions
Exception | Condition
ArgumentException | The specified Part is not a merged part.
ArgumentNullException | A non-optional argument was null
See Also

Reference

PartUtils Class


PartUtils.GetPartMakerMethodToDivideVolumeFW Method

PartUtilsGetPartMakerMethodToDivideVolumeFW Method

Obtains the object allowing access to the divided volume properties of the PartMaker.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static PartMakerMethodToDivideVolumes GetPartMakerMethodToDivideVolumeFW(
    PartMaker partMaker
)
Public Shared Function GetPartMakerMethodToDivideVolumeFW (
    partMaker As PartMaker
) As PartMakerMethodToDivideVolumes
public:
static PartMakerMethodToDivideVolumes^ GetPartMakerMethodToDivideVolumeFW(
    PartMaker^ partMaker
)
static member GetPartMakerMethodToDivideVolumeFW :
        partMaker : PartMaker -> PartMakerMethodToDivideVolumes

Parameters

partMaker PartMaker
The PartMaker.

Return Value

PartMakerMethodToDivideVolumes
The object handle. Returns if the PartMaker does not represent divided volumes.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

PartUtils Class


PartUtils.GetSplittingCurves Method

PartUtilsGetSplittingCurves Method

Overload List
Name | Description
GetSplittingCurves(Document, ElementId) | Identifies the curves that were used to create the part.
GetSplittingCurves(Document, ElementId, Plane) | Identifies the curves that were used to create the part and the plane in which they reside.
Top
See Also

Reference

PartUtils Class


PartUtils.GetSplittingCurves(Document, ElementId) Method

PartUtilsGetSplittingCurves(Document, ElementId) Method

Identifies the curves that were used to create the part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<Curve> GetSplittingCurves(
    Document document,
    ElementId partId
)
Public Shared Function GetSplittingCurves (
    document As Document,
    partId As ElementId
) As IList(Of Curve)
public:
static IList<Curve^>^ GetSplittingCurves(
    Document^ document,
    ElementId^ partId
)
static member GetSplittingCurves :
        document : Document *
        partId : ElementId -> IList<Curve>

Parameters

document Document
The source document of the part.
partId ElementId
The part id.

Return Value

IList Curve
The curves that created the part. Empty if partId is not a Part or Part is not divided.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Example
C#
VB
C++
F#
Copy
public void GetCurveDividers(Part part)
{
   StringBuilder message = new StringBuilder();

   // Get curve dividers.
   IList<Curve> divisionCurves = PartUtils.GetSplittingCurves(part.Document, part.Id);

   if (divisionCurves.Count == 0)
      message.AppendLine("Part is not divided.");
   else
   {
      message.AppendLine("The dividers are : ");
      if (divisionCurves.Count > 0)
         message.AppendLine(divisionCurves.Count.ToString() + " division curves");
   }

   TaskDialog.Show("Revit", message.ToString());
}
Public Sub GetCurveDividers(ByVal part As Part)
    Dim message As StringBuilder = New StringBuilder
    ' Get curve dividers.
    Dim divisionCurves As IList(Of Curve) = PartUtils.GetSplittingCurves(part.Document, part.Id)
    If (divisionCurves.Count = 0) Then
        message.AppendLine("Part is not divided.")
    Else
        message.AppendLine("The dividers are : ")
        If (divisionCurves.Count > 0) Then
            message.AppendLine((divisionCurves.Count.ToString + " division curves"))
        End If

    End If

    TaskDialog.Show("Revit", message.ToString)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

PartUtils Class
GetSplittingCurves Overload


PartUtils.GetSplittingCurves(Document, ElementId, Plane) Method

PartUtilsGetSplittingCurves(Document, ElementId, Plane) Method

Identifies the curves that were used to create the part and the plane in which they reside.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<Curve> GetSplittingCurves(
    Document document,
    ElementId partId,
    out Plane sketchPlane
)
Public Shared Function GetSplittingCurves (
    document As Document,
    partId As ElementId,
    <OutAttribute> ByRef sketchPlane As Plane
) As IList(Of Curve)
public:
static IList<Curve^>^ GetSplittingCurves(
    Document^ document,
    ElementId^ partId,
    [OutAttribute] Plane^% sketchPlane
)
static member GetSplittingCurves :
        document : Document *
        partId : ElementId *
        sketchPlane : Plane byref -> IList<Curve>

Parameters

document Document
The source document of the part.
partId ElementId
The part id.
sketchPlane Plane
The plane in which the division curves were sketched.

Return Value

IList Curve
The curves that created the part. Empty if partId is not a part or Part is not divided.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Example
C#
VB
C++
F#
Copy
public void GetCurveDividersAndPlane(Part part)
{
   StringBuilder message = new StringBuilder();
   Plane skP = Plane.CreateByThreePoints(new XYZ(0, 0, 1), new XYZ(1, 0, 0), new XYZ(0, 1, 0));

   // Get curve dividers.
   IList<Curve> divisionCurves = PartUtils.GetSplittingCurves(part.Document, part.Id, out skP);

   if(divisionCurves.Count == 0)
      message.AppendLine("Part is not divided.");
   else
   {
      message.AppendLine("The dividers are : ");
      if(divisionCurves.Count > 0)
         message.AppendLine(divisionCurves.Count.ToString() + " division curves");
   }

   TaskDialog.Show("Revit", message.ToString());
}
Private Sub GetCurveDividersAndPlane(ByVal part As Part)
    Dim message As StringBuilder = New StringBuilder
    Dim skP As Plane = Plane.CreateByThreePoints(New XYZ(0, 0, 1), New XYZ(1, 0, 0), New XYZ(0, 1, 0))
    ' Get curve dividers.
    Dim divisionCurves As IList(Of Curve) = PartUtils.GetSplittingCurves(part.Document, part.Id, skP)
    If (divisionCurves.Count = 0) Then
        message.AppendLine("Part is not divided.")
    Else
        message.AppendLine("The dividers are : ")
        If (divisionCurves.Count > 0) Then
            message.AppendLine((divisionCurves.Count.ToString + " division curves"))
        End If

    End If

    TaskDialog.Show("Revit", message.ToString)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

PartUtils Class
GetSplittingCurves Overload


PartUtils.GetSplittingElements Method

PartUtilsGetSplittingElements Method

Identifies the elements ( reference planes, levels, grids ) that were used to create the part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ISet<ElementId> GetSplittingElements(
    Document document,
    ElementId partId
)
Public Shared Function GetSplittingElements (
    document As Document,
    partId As ElementId
) As ISet(Of ElementId)
public:
static ISet<ElementId^>^ GetSplittingElements(
    Document^ document,
    ElementId^ partId
)
static member GetSplittingElements :
        document : Document *
        partId : ElementId -> ISet<ElementId>

Parameters

document Document
The source document of the part.
partId ElementId
The part id.

Return Value

ISet ElementId
The elements that created the part. Empty if partId is not a Part or Part is not divided.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Example
C#
VB
C++
F#
Copy
public void GetElementDividers(Part part)
{
   StringBuilder message = new StringBuilder();

   // Get Element dividers.
   ISet<ElementId> divisionElements = PartUtils.GetSplittingElements(part.Document, part.Id);

   if (divisionElements.Count == 0)
      message.AppendLine("Part is not divided.");
   else
   {
      message.AppendLine("The dividers are : ");
      foreach (var reference in divisionElements)
      {
         Element element = part.Document.GetElement(reference);
         message.AppendLine(element.GetType().Name + " " + element.Id.ToString() + " ");
      }
   }

   TaskDialog.Show("Revit", message.ToString());
}
Private Sub GetElementDividers(ByVal part As Part)
    Dim message As StringBuilder = New StringBuilder
    ' Get Element dividers.
    Dim divisionElements As ISet(Of ElementId) = PartUtils.GetSplittingElements(part.Document, part.Id)
    If (divisionElements.Count = 0) Then
        message.AppendLine("Part is not divided.")
    Else
        message.AppendLine("The dividers are : ")
        For Each reference In divisionElements
            Dim element As Element = part.Document.GetElement(reference)
            message.AppendLine(element.GetType.Name + " " + element.Id.ToString)
        Next
    End If

    TaskDialog.Show("Revit", message.ToString)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

PartUtils Class


PartUtils.HasAssociatedParts Method

PartUtilsHasAssociatedParts Method

Overload List
Name | Description
HasAssociatedParts(Document, ElementId) | Checks if an element has associated parts.
HasAssociatedParts(Document, LinkElementId) | Checks if an element has associated parts.
Top
See Also

Reference

PartUtils Class


PartUtils.HasAssociatedParts(Document, ElementId) Method

PartUtilsHasAssociatedParts(Document, ElementId) Method

Checks if an element has associated parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool HasAssociatedParts(
    Document hostDocument,
    ElementId elementId
)
Public Shared Function HasAssociatedParts (
    hostDocument As Document,
    elementId As ElementId
) As Boolean
public:
static bool HasAssociatedParts(
    Document^ hostDocument,
    ElementId^ elementId
)
static member HasAssociatedParts :
        hostDocument : Document *
        elementId : ElementId -> bool

Parameters

hostDocument Document
The document.
elementId ElementId
The element to be checked for associated Parts

Return Value

Boolean
True if the element has associated Parts.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

PartUtils Class
HasAssociatedParts Overload


PartUtils.HasAssociatedParts(Document, LinkElementId) Method

PartUtilsHasAssociatedParts(Document, LinkElementId) Method

Checks if an element has associated parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool HasAssociatedParts(
    Document hostDocument,
    LinkElementId hostOrLinkElementId
)
Public Shared Function HasAssociatedParts (
    hostDocument As Document,
    hostOrLinkElementId As LinkElementId
) As Boolean
public:
static bool HasAssociatedParts(
    Document^ hostDocument,
    LinkElementId^ hostOrLinkElementId
)
static member HasAssociatedParts :
        hostDocument : Document *
        hostOrLinkElementId : LinkElementId -> bool

Parameters

hostDocument Document
The document.
hostOrLinkElementId LinkElementId
The element to be checked for associated Parts.

Return Value

Boolean
True if the element has associated Parts.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

PartUtils Class
HasAssociatedParts Overload


PartUtils.IsMergedPart Method

PartUtilsIsMergedPart Method

Is the Part the result of a merge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsMergedPart(
    Part part
)
Public Shared Function IsMergedPart (
    part As Part
) As Boolean
public:
static bool IsMergedPart(
    Part^ part
)
static member IsMergedPart :
        part : Part -> bool

Parameters

part Part

Return Value

Boolean
True if the Part is the result of a merge operation.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

PartUtils Class


PartUtils.IsPartDerivedFromLink Method

PartUtilsIsPartDerivedFromLink Method

Is the Part derived from link geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsPartDerivedFromLink(
    Part dPart
)
Public Shared Function IsPartDerivedFromLink (
    dPart As Part
) As Boolean
public:
static bool IsPartDerivedFromLink(
    Part^ dPart
)
static member IsPartDerivedFromLink :
        dPart : Part -> bool

Parameters

dPart Part

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

PartUtils Class


PartUtils.IsValidForCreateParts Method

PartUtilsIsValidForCreateParts Method

Identifies if the given element can be used to create parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidForCreateParts(
    Document document,
    LinkElementId hostOrLinkElementId
)
Public Shared Function IsValidForCreateParts (
    document As Document,
    hostOrLinkElementId As LinkElementId
) As Boolean
public:
static bool IsValidForCreateParts(
    Document^ document,
    LinkElementId^ hostOrLinkElementId
)
static member IsValidForCreateParts :
        document : Document *
        hostOrLinkElementId : LinkElementId -> bool

Parameters

document Document
The document.
hostOrLinkElementId LinkElementId
Id to be tested for validity for creating part.

Return Value

Boolean
True if this id is valid, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

PartUtils Class


Path3d Class

Provides access to the Generic 3D path object in Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBSketchBase
Autodesk.Revit.DBPath3d

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Path3d : SketchBase
Public Class Path3d
    Inherits SketchBase
public ref class Path3d : public SketchBase
type Path3d =
    class
        inherit SketchBase
    end

The Path3d type exposes the following members.

Properties
 | Name | Description
Public property | AllCurveLoops | Get all the Curve Loops of Path3d.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CurveLoop | Get the Curve Loop of Path3d via index.
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | NumCurveLoops | Get the Number of Curve Loops of Path3d.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This object represents a 3D path sketch of Sweep.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Path3d Properties

The Path3d type exposes the following members.

Properties
 | Name | Description
Public property | AllCurveLoops | Get all the Curve Loops of Path3d.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CurveLoop | Get the Curve Loop of Path3d via index.
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | NumCurveLoops | Get the Number of Curve Loops of Path3d.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

Path3d Class


Path3d.AllCurveLoops Property

Path3dAllCurveLoops Property

Get all the Curve Loops of Path3d.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurveArrArray AllCurveLoops { get; }
Public ReadOnly Property AllCurveLoops As CurveArrArray
    Get
public:
property CurveArrArray^ AllCurveLoops {
    CurveArrArray^ get ();
}
member AllCurveLoops : CurveArrArray with get

Property Value

CurveArrArray
Remarks
Returns all the Curve Loops of Path3d.
See Also

Reference

Path3d Class


Path3d.CurveLoop Property

Path3dCurveLoop Property

Get the Curve Loop of Path3d via index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurveArray this[
    int index
] { get; }
Public ReadOnly Property CurveLoop (
    index As Integer
) As CurveArray
    Get
public:
property CurveArray^ CurveLoop[int index] {
    CurveArray^ get (int index);
}
member CurveLoop : CurveArray with get

Parameters

index Int32

Property Value

CurveArray
Remarks
Returns the index order Curve Loop of Path3d.
See Also

Reference

Path3d Class


Path3d.NumCurveLoops Property

Path3dNumCurveLoops Property

Get the Number of Curve Loops of Path3d.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int NumCurveLoops { get; }
Public ReadOnly Property NumCurveLoops As Integer
    Get
public:
property int NumCurveLoops {
    int get ();
}
member NumCurveLoops : int with get

Property Value

Int32
Remarks
Returns the Number of Curve Loops of Path3d.
See Also

Reference

Path3d Class


Path3d Methods

The Path3d type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Path3d Class


PathType Enumeration

Enum determining what kind of path a given external file reference path is. Paths are valid for all types of external file references unless otherwise specified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum PathType
Public Enumeration PathType
public enum class PathType
type PathType
Members
Member name | Value | Description
Relative | 0 | The path is relative to the host file's location, or to the central model's location if the host is workshared.
Absolute | 1 | The path is an absolute path to a location on disk or the network.
Server | 2 | The path is to a Revit Server location. This value is only valid for ExternalFileReferenceType.RevitLink.
Content | 3 | The path is relative to a location in the Revit content libraries. This value is only valid for ExternalFileReferenceType.KeynoteTable, ExternalFileReferenceType.AssemblyCodeTable or ExternalFileReferenceType.Decal.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PDFExportOptions Class

Options for PDF export
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBPDFExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PDFExportOptions : IDisposable
Public Class PDFExportOptions
    Implements IDisposable
public ref class PDFExportOptions : IDisposable
type PDFExportOptions =
    class
        interface IDisposable
    end

The PDFExportOptions type exposes the following members.

Constructors
 | Name | Description
Public method | PDFExportOptions | Creates a default options object.
Top
Properties
 | Name | Description
Public property | AlwaysUseRaster | If true completely use raster processing for graphics, otherwise use vector processing as much as possible.
Public property | ColorDepth | Color depth of either black/white, gray scale or color.
Public property | Combine | Whether export all views and sheets into one PDF file or multiple files.
Public property | ExportQuality | The preferred export quality (DPI).
Public property | FileName | File name of the PDF when Combine is .
Public property | HideCropBoundaries | Whether to hide crop boundaries.
Public property | HideReferencePlane | Whether to hide reference/work planes.
Public property | HideScopeBoxes | Whether to hide scope boxes.
Public property | HideUnreferencedViewTags | Whether to hide unreferenced view tags.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MaskCoincidentLines | Whether to mask coincident lines.
Public property | OriginOffsetX | Offset between left sides of pdf content and paper. Always stored in unit of Feet.
Public property | OriginOffsetY | Offset between bottom sides of pdf content and paper. Always stored in unit of Feet.
Public property | PaperFormat | Paper format.
Public property | PaperOrientation | Paper orientation - Portrait/Landscape/Auto
Public property | PaperPlacement | Paper placement of either center or offset from corner.
Public property | RasterQuality | The preferred raster quality (DPI).
Public property | ReplaceHalftoneWithThinLines | Whether to replace halftone with thin lines.
Public property | StopOnError | Whether export process should stop when a view fails to export
Public property | ViewLinksInBlue | Whether set view links blue.
Public property | ZoomPercentage | Percentage of the zoom for the view.
Public property | ZoomType | Zoom type of either fit to page or on a specific percentage.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the PDFExportOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetExportInBackground | Execute PDF export as a background process.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetNamingRule | Gets a copy of the naming rule.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | IsValidNamingRule | Whether naming rule is valid or not.
Public method | SetExportInBackground | Execute PDF export as a background process.
Public method | SetNamingRule | Sets the naming rule.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PDFExportOptions Constructor

Creates a default options object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PDFExportOptions()
Public Sub New
public:
PDFExportOptions()
new : unit -> PDFExportOptions
See Also

Reference

PDFExportOptions Class


PDFExportOptions Properties

The PDFExportOptions type exposes the following members.

Properties
 | Name | Description
Public property | AlwaysUseRaster | If true completely use raster processing for graphics, otherwise use vector processing as much as possible.
Public property | ColorDepth | Color depth of either black/white, gray scale or color.
Public property | Combine | Whether export all views and sheets into one PDF file or multiple files.
Public property | ExportQuality | The preferred export quality (DPI).
Public property | FileName | File name of the PDF when Combine is .
Public property | HideCropBoundaries | Whether to hide crop boundaries.
Public property | HideReferencePlane | Whether to hide reference/work planes.
Public property | HideScopeBoxes | Whether to hide scope boxes.
Public property | HideUnreferencedViewTags | Whether to hide unreferenced view tags.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MaskCoincidentLines | Whether to mask coincident lines.
Public property | OriginOffsetX | Offset between left sides of pdf content and paper. Always stored in unit of Feet.
Public property | OriginOffsetY | Offset between bottom sides of pdf content and paper. Always stored in unit of Feet.
Public property | PaperFormat | Paper format.
Public property | PaperOrientation | Paper orientation - Portrait/Landscape/Auto
Public property | PaperPlacement | Paper placement of either center or offset from corner.
Public property | RasterQuality | The preferred raster quality (DPI).
Public property | ReplaceHalftoneWithThinLines | Whether to replace halftone with thin lines.
Public property | StopOnError | Whether export process should stop when a view fails to export
Public property | ViewLinksInBlue | Whether set view links blue.
Public property | ZoomPercentage | Percentage of the zoom for the view.
Public property | ZoomType | Zoom type of either fit to page or on a specific percentage.
Top
See Also

Reference

PDFExportOptions Class


PDFExportOptions.AlwaysUseRaster Property

PDFExportOptionsAlwaysUseRaster Property

If true completely use raster processing for graphics, otherwise use vector processing as much as possible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AlwaysUseRaster { get; set; }
Public Property AlwaysUseRaster As Boolean
    Get
    Set
public:
property bool AlwaysUseRaster {
    bool get ();
    void set (bool value);
}
member AlwaysUseRaster : bool with get, set

Property Value

Boolean
See Also

Reference

PDFExportOptions Class


PDFExportOptions.ColorDepth Property

PDFExportOptionsColorDepth Property

Color depth of either black/white, gray scale or color.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ColorDepthType ColorDepth { get; set; }
Public Property ColorDepth As ColorDepthType
    Get
    Set
public:
property ColorDepthType ColorDepth {
    ColorDepthType get ();
    void set (ColorDepthType value);
}
member ColorDepth : ColorDepthType with get, set

Property Value

ColorDepthType
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

PDFExportOptions Class


PDFExportOptions.Combine Property

PDFExportOptionsCombine Property

Whether export all views and sheets into one PDF file or multiple files.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Combine { get; set; }
Public Property Combine As Boolean
    Get
    Set
public:
property bool Combine {
    bool get ();
    void set (bool value);
}
member Combine : bool with get, set

Property Value

Boolean
Remarks
If , all exported views and sheets will be exported into one PDF file, whose file name would be specified by FileName. If , each exported view and sheet will have its own PDF file created, whose file name would be generated with [!:NamingRule].
See Also

Reference

PDFExportOptions Class


PDFExportOptions.ExportQuality Property

PDFExportOptionsExportQuality Property

The preferred export quality (DPI).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PDFExportQualityType ExportQuality { get; set; }
Public Property ExportQuality As PDFExportQualityType
    Get
    Set
public:
property PDFExportQualityType ExportQuality {
    PDFExportQualityType get ();
    void set (PDFExportQualityType value);
}
member ExportQuality : PDFExportQualityType with get, set

Property Value

PDFExportQualityType
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
This quality setting is the equivalent of printer resolution found in advanced printer settings. An effect of the setting is to control tessellation quality.
See Also

Reference

PDFExportOptions Class


PDFExportOptions.FileName Property

PDFExportOptionsFileName Property

File name of the PDF when Combine is .

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
member FileName : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
PDF file extension (".pdf") would be automatically appended to the result file. When Combine is , this would be ignored.
See Also

Reference

PDFExportOptions Class


PDFExportOptions.HideCropBoundaries Property

PDFExportOptionsHideCropBoundaries Property

Whether to hide crop boundaries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HideCropBoundaries { get; set; }
Public Property HideCropBoundaries As Boolean
    Get
    Set
public:
property bool HideCropBoundaries {
    bool get ();
    void set (bool value);
}
member HideCropBoundaries : bool with get, set

Property Value

Boolean
See Also

Reference

PDFExportOptions Class


PDFExportOptions.HideReferencePlane Property

PDFExportOptionsHideReferencePlane Property

Whether to hide reference/work planes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HideReferencePlane { get; set; }
Public Property HideReferencePlane As Boolean
    Get
    Set
public:
property bool HideReferencePlane {
    bool get ();
    void set (bool value);
}
member HideReferencePlane : bool with get, set

Property Value

Boolean
See Also

Reference

PDFExportOptions Class


PDFExportOptions.HideScopeBoxes Property

PDFExportOptionsHideScopeBoxes Property

Whether to hide scope boxes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HideScopeBoxes { get; set; }
Public Property HideScopeBoxes As Boolean
    Get
    Set
public:
property bool HideScopeBoxes {
    bool get ();
    void set (bool value);
}
member HideScopeBoxes : bool with get, set

Property Value

Boolean
See Also

Reference

PDFExportOptions Class


PDFExportOptions.HideUnreferencedViewTags Property

PDFExportOptionsHideUnreferencedViewTags Property

Whether to hide unreferenced view tags.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HideUnreferencedViewTags { get; set; }
Public Property HideUnreferencedViewTags As Boolean
    Get
    Set
public:
property bool HideUnreferencedViewTags {
    bool get ();
    void set (bool value);
}
member HideUnreferencedViewTags : bool with get, set

Property Value

Boolean
See Also

Reference

PDFExportOptions Class


PDFExportOptions.IsValidObject Property

PDFExportOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

PDFExportOptions Class


PDFExportOptions.MaskCoincidentLines Property

PDFExportOptionsMaskCoincidentLines Property

Whether to mask coincident lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool MaskCoincidentLines { get; set; }
Public Property MaskCoincidentLines As Boolean
    Get
    Set
public:
property bool MaskCoincidentLines {
    bool get ();
    void set (bool value);
}
member MaskCoincidentLines : bool with get, set

Property Value

Boolean
See Also

Reference

PDFExportOptions Class


PDFExportOptions.OriginOffsetX Property

PDFExportOptionsOriginOffsetX Property

Offset between left sides of pdf content and paper. Always stored in unit of Feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double OriginOffsetX { get; set; }
Public Property OriginOffsetX As Double
    Get
    Set
public:
property double OriginOffsetX {
    double get ();
    void set (double value);
}
member OriginOffsetX : float with get, set

Property Value

Double
See Also

Reference

PDFExportOptions Class


PDFExportOptions.OriginOffsetY Property

PDFExportOptionsOriginOffsetY Property

Offset between bottom sides of pdf content and paper. Always stored in unit of Feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double OriginOffsetY { get; set; }
Public Property OriginOffsetY As Double
    Get
    Set
public:
property double OriginOffsetY {
    double get ();
    void set (double value);
}
member OriginOffsetY : float with get, set

Property Value

Double
See Also

Reference

PDFExportOptions Class


PDFExportOptions.PaperFormat Property

PDFExportOptionsPaperFormat Property

Paper format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportPaperFormat PaperFormat { get; set; }
Public Property PaperFormat As ExportPaperFormat
    Get
    Set
public:
property ExportPaperFormat PaperFormat {
    ExportPaperFormat get ();
    void set (ExportPaperFormat value);
}
member PaperFormat : ExportPaperFormat with get, set

Property Value

ExportPaperFormat
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The input paper format is invalid
Remarks
When the PaperFormat is ExportPaperFormat.Default, which means "Use Sheet Size".
See Also

Reference

PDFExportOptions Class


PDFExportOptions.PaperOrientation Property

PDFExportOptionsPaperOrientation Property

Paper orientation - Portrait/Landscape/Auto

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PageOrientationType PaperOrientation { get; set; }
Public Property PaperOrientation As PageOrientationType
    Get
    Set
public:
property PageOrientationType PaperOrientation {
    PageOrientationType get ();
    void set (PageOrientationType value);
}
member PaperOrientation : PageOrientationType with get, set

Property Value

PageOrientationType
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
Ignored when the PaperFormat is ExportPaperFormat.Default, which means "Use Sheet Size".
See Also

Reference

PDFExportOptions Class


PDFExportOptions.PaperPlacement Property

PDFExportOptionsPaperPlacement Property

Paper placement of either center or offset from corner.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PaperPlacementType PaperPlacement { get; set; }
Public Property PaperPlacement As PaperPlacementType
    Get
    Set
public:
property PaperPlacementType PaperPlacement {
    PaperPlacementType get ();
    void set (PaperPlacementType value);
}
member PaperPlacement : PaperPlacementType with get, set

Property Value

PaperPlacementType
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

PDFExportOptions Class


PDFExportOptions.RasterQuality Property

PDFExportOptionsRasterQuality Property

The preferred raster quality (DPI).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RasterQualityType RasterQuality { get; set; }
Public Property RasterQuality As RasterQualityType
    Get
    Set
public:
property RasterQualityType RasterQuality {
    RasterQualityType get ();
    void set (RasterQualityType value);
}
member RasterQuality : RasterQualityType with get, set

Property Value

RasterQualityType
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

PDFExportOptions Class


PDFExportOptions.ReplaceHalftoneWithThinLines Property

PDFExportOptionsReplaceHalftoneWithThinLines Property

Whether to replace halftone with thin lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ReplaceHalftoneWithThinLines { get; set; }
Public Property ReplaceHalftoneWithThinLines As Boolean
    Get
    Set
public:
property bool ReplaceHalftoneWithThinLines {
    bool get ();
    void set (bool value);
}
member ReplaceHalftoneWithThinLines : bool with get, set

Property Value

Boolean
See Also

Reference

PDFExportOptions Class


PDFExportOptions.StopOnError Property

PDFExportOptionsStopOnError Property

Whether export process should stop when a view fails to export

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool StopOnError { get; set; }
Public Property StopOnError As Boolean
    Get
    Set
public:
property bool StopOnError {
    bool get ();
    void set (bool value);
}
member StopOnError : bool with get, set

Property Value

Boolean
See Also

Reference

PDFExportOptions Class


PDFExportOptions.ViewLinksInBlue Property

PDFExportOptionsViewLinksInBlue Property

Whether set view links blue.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ViewLinksInBlue { get; set; }
Public Property ViewLinksInBlue As Boolean
    Get
    Set
public:
property bool ViewLinksInBlue {
    bool get ();
    void set (bool value);
}
member ViewLinksInBlue : bool with get, set

Property Value

Boolean
Remarks
If true, links will be visible as blue. If false, they retain their default text color.
See Also

Reference

PDFExportOptions Class


PDFExportOptions.ZoomPercentage Property

PDFExportOptionsZoomPercentage Property

Percentage of the zoom for the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ZoomPercentage { get; set; }
Public Property ZoomPercentage As Integer
    Get
    Set
public:
property int ZoomPercentage {
    int get ();
    void set (int value);
}
member ZoomPercentage : int with get, set

Property Value

Int32
Remarks
This property would be ignored if the ZoomType is FitToPage.
See Also

Reference

PDFExportOptions Class


PDFExportOptions.ZoomType Property

PDFExportOptionsZoomType Property

Zoom type of either fit to page or on a specific percentage.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ZoomType ZoomType { get; set; }
Public Property ZoomType As ZoomType
    Get
    Set
public:
property ZoomType ZoomType {
    ZoomType get ();
    void set (ZoomType value);
}
member ZoomType : ZoomType with get, set

Property Value

ZoomType
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
This property would be ignored if the PaperFormat is Default.
See Also

Reference

PDFExportOptions Class


PDFExportOptions Methods

The PDFExportOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetExportInBackground | Execute PDF export as a background process.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetNamingRule | Gets a copy of the naming rule.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | IsValidNamingRule | Whether naming rule is valid or not.
Public method | SetExportInBackground | Execute PDF export as a background process.
Public method | SetNamingRule | Sets the naming rule.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PDFExportOptions Class


PDFExportOptions.Dispose Method

PDFExportOptionsDispose Method

Releases all resources used by the PDFExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

PDFExportOptions Class


PDFExportOptions.GetExportInBackground Method

PDFExportOptionsGetExportInBackground Method

Execute PDF export as a background process.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool GetExportInBackground()
Public Function GetExportInBackground As Boolean
public:
bool GetExportInBackground()
member GetExportInBackground : unit -> bool

Return Value

Boolean
See Also

Reference

PDFExportOptions Class


PDFExportOptions.GetNamingRule Method

PDFExportOptionsGetNamingRule Method

Gets a copy of the naming rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<TableCellCombinedParameterData> GetNamingRule()
Public Function GetNamingRule As IList(Of TableCellCombinedParameterData)
public:
IList<TableCellCombinedParameterData^>^ GetNamingRule()
member GetNamingRule : unit -> IList<TableCellCombinedParameterData>

Return Value

IList TableCellCombinedParameterData
The naming rule.
See Also

Reference

PDFExportOptions Class


PDFExportOptions.IsValidNamingRule Method

PDFExportOptionsIsValidNamingRule Method

Whether naming rule is valid or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidNamingRule(
    IList<TableCellCombinedParameterData> namingRule
)
Public Shared Function IsValidNamingRule (
    namingRule As IList(Of TableCellCombinedParameterData)
) As Boolean
public:
static bool IsValidNamingRule(
    IList<TableCellCombinedParameterData^>^ namingRule
)
static member IsValidNamingRule :
        namingRule : IList<TableCellCombinedParameterData> -> bool

Parameters

namingRule IList TableCellCombinedParameterData
The naming rule to be validated.

Return Value

Boolean
Whether or not the name is valid.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
If true, this naming rule is a valid. If false, this naming rule is not valid for empty naming rule or illegal characters, such as
C#
Copy
\ / : * ? " < > |
.
See Also

Reference

PDFExportOptions Class


PDFExportOptions.SetExportInBackground Method

PDFExportOptionsSetExportInBackground Method

Execute PDF export as a background process.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetExportInBackground(
    bool exportInBackground
)
Public Sub SetExportInBackground (
    exportInBackground As Boolean
)
public:
void SetExportInBackground(
    bool exportInBackground
)
member SetExportInBackground :
        exportInBackground : bool -> unit

Parameters

exportInBackground Boolean
Execute PDF export as a background process.
See Also

Reference

PDFExportOptions Class


PDFExportOptions.SetNamingRule Method

PDFExportOptionsSetNamingRule Method

Sets the naming rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetNamingRule(
    IList<TableCellCombinedParameterData> namingRule
)
Public Sub SetNamingRule (
    namingRule As IList(Of TableCellCombinedParameterData)
)
public:
void SetNamingRule(
    IList<TableCellCombinedParameterData^>^ namingRule
)
member SetNamingRule :
        namingRule : IList<TableCellCombinedParameterData> -> unit

Parameters

namingRule IList TableCellCombinedParameterData
The naming rule.
Exceptions
Exception | Condition
ArgumentException | The namingRule is empty or contains illegal characters.
ArgumentNullException | A non-optional argument was null
See Also

Reference

PDFExportOptions Class


PDFExportQualityType Enumeration

An enumerated type listing the options for PDF export quality.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum PDFExportQualityType
Public Enumeration PDFExportQualityType
public enum class PDFExportQualityType
type PDFExportQualityType
Members
Member name | Value | Description
DPI72 | 72 |
DPI144 | 144 |
DPI300 | 300 |
DPI600 | 600 |
DPI1200 | 1,200 |
DPI2400 | 2,400 |
DPI3600 | 3,600 |
DPI4000 | 4,000 |
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PerformanceAdviser Class

The tool to report performance problems in a given document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBPerformanceAdviser

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PerformanceAdviser : IDisposable
Public Class PerformanceAdviser
    Implements IDisposable
public ref class PerformanceAdviser : IDisposable
type PerformanceAdviser =
    class
        interface IDisposable
    end

The PerformanceAdviser type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | AddRule | Adds a performance adviser rule to the list of rules.
Public method | DeleteRule | Deletes a performance adviser rule from the list of rules.
Public method | Dispose | Releases all resources used by the PerformanceAdviser
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ExecuteAllRules | Executes all rules in the list on a given document.
Public method | ExecuteRules(Document, IListPerformanceAdviserRuleId) | Executes selected rules on a given document.
Public method | ExecuteRules(Document, IListInt32) | Executes selected rules on a given document.
Public method | GetAllRuleIds | Retrieves an enumeration of rule Ids.
Public method | GetElementFilterFromRule(Int32, Document) | Retrieves a filter to restrict elements to be checked.
Public method | GetElementFilterFromRule(PerformanceAdviserRuleId, Document) | Retrieves a filter to restrict elements to be checked.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetNumberOfRules | Retrieves number of performance adviser rules in the list.
 | GetPerformanceAdviser | Returns the only instance of PerformanceAdviser in the Application.
Public method | GetRuleDescription(Int32) | Retrieves the description of the rule.
Public method | GetRuleDescription(PerformanceAdviserRuleId) | Retrieves the description of the rule.
Public method | GetRuleId | Retrieves an id of a rule for a given index in the list.
Public method | GetRuleName(Int32) | Retrieves the name of the rule.
Public method | GetRuleName(PerformanceAdviserRuleId) | Retrieves the name of the rule.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsRuleEnabled(Int32) | Retrieves an enabled/disabled status for the given rule.
Public method | IsRuleEnabled(PerformanceAdviserRuleId) | Retrieves an enabled/disabled status for the given rule.
Public method | PostWarning | Reports a problem detected during execution of a rule.
Public method | SetRuleEnabled(Int32, Boolean) | Retrieves an enabled/disabled status for the given rule.
Public method | SetRuleEnabled(PerformanceAdviserRuleId, Boolean) | Retrieves an enabled/disabled status for the given rule.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | WillRuleCheckElements(Int32) | Reports if rule needs to be executed on individual elements.
Public method | WillRuleCheckElements(PerformanceAdviserRuleId) | Reports if rule needs to be executed on individual elements.
Top
Remarks
Class is an application-wide singleton that performs a dual role: it is a repository of rules to run in order to detect potential performance problems as well as an access point to execute checks.
Example
C#
VB
C++
F#
Copy
//Get the name of each registered PerformanceRule and then execute all of them.
foreach (PerformanceAdviserRuleId id in PerformanceAdviser.GetPerformanceAdviser().GetAllRuleIds())
{
    string ruleName = PerformanceAdviser.GetPerformanceAdviser().GetRuleName(id);
}
PerformanceAdviser.GetPerformanceAdviser().ExecuteAllRules(document);
'Get the name of each registered PerformanceRule and then execute all of them.
For Each id As PerformanceAdviserRuleId In PerformanceAdviser.GetPerformanceAdviser().GetAllRuleIds()
    Dim ruleName As String = PerformanceAdviser.GetPerformanceAdviser().GetRuleName(id)
Next
PerformanceAdviser.GetPerformanceAdviser().ExecuteAllRules(document)

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PerformanceAdviser Properties

The PerformanceAdviser type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

PerformanceAdviser Class


PerformanceAdviser.IsValidObject Property

PerformanceAdviserIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

PerformanceAdviser Class


PerformanceAdviser Methods

The PerformanceAdviser type exposes the following members.

Methods
 | Name | Description
Public method | AddRule | Adds a performance adviser rule to the list of rules.
Public method | DeleteRule | Deletes a performance adviser rule from the list of rules.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ExecuteAllRules | Executes all rules in the list on a given document.
Public method | ExecuteRules(Document, IListPerformanceAdviserRuleId) | Executes selected rules on a given document.
Public method | ExecuteRules(Document, IListInt32) | Executes selected rules on a given document.
Public method | GetAllRuleIds | Retrieves an enumeration of rule Ids.
Public method | GetElementFilterFromRule(Int32, Document) | Retrieves a filter to restrict elements to be checked.
Public method | GetElementFilterFromRule(PerformanceAdviserRuleId, Document) | Retrieves a filter to restrict elements to be checked.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetNumberOfRules | Retrieves number of performance adviser rules in the list.
 | GetPerformanceAdviser | Returns the only instance of PerformanceAdviser in the Application.
Public method | GetRuleDescription(Int32) | Retrieves the description of the rule.
Public method | GetRuleDescription(PerformanceAdviserRuleId) | Retrieves the description of the rule.
Public method | GetRuleId | Retrieves an id of a rule for a given index in the list.
Public method | GetRuleName(Int32) | Retrieves the name of the rule.
Public method | GetRuleName(PerformanceAdviserRuleId) | Retrieves the name of the rule.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsRuleEnabled(Int32) | Retrieves an enabled/disabled status for the given rule.
Public method | IsRuleEnabled(PerformanceAdviserRuleId) | Retrieves an enabled/disabled status for the given rule.
Public method | PostWarning | Reports a problem detected during execution of a rule.
Public method | SetRuleEnabled(Int32, Boolean) | Retrieves an enabled/disabled status for the given rule.
Public method | SetRuleEnabled(PerformanceAdviserRuleId, Boolean) | Retrieves an enabled/disabled status for the given rule.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | WillRuleCheckElements(Int32) | Reports if rule needs to be executed on individual elements.
Public method | WillRuleCheckElements(PerformanceAdviserRuleId) | Reports if rule needs to be executed on individual elements.
Top
See Also

Reference

PerformanceAdviser Class


PerformanceAdviser.AddRule Method

PerformanceAdviserAddRule Method

Adds a performance adviser rule to the list of rules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddRule(
    PerformanceAdviserRuleId id,
    IPerformanceAdviserRule rule
)
Public Sub AddRule (
    id As PerformanceAdviserRuleId,
    rule As IPerformanceAdviserRule
)
public:
void AddRule(
    PerformanceAdviserRuleId^ id,
    IPerformanceAdviserRule^ rule
)
member AddRule :
        id : PerformanceAdviserRuleId *
        rule : IPerformanceAdviserRule -> unit

Parameters

id PerformanceAdviserRuleId
An id of the rule to be added to the list of rules.
rule IPerformanceAdviserRule
The rule to be added
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

PerformanceAdviser Class


PerformanceAdviser.DeleteRule Method

PerformanceAdviserDeleteRule Method

Deletes a performance adviser rule from the list of rules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void DeleteRule(
    PerformanceAdviserRuleId id
)
Public Sub DeleteRule (
    id As PerformanceAdviserRuleId
)
public:
void DeleteRule(
    PerformanceAdviserRuleId^ id
)
member DeleteRule :
        id : PerformanceAdviserRuleId -> unit

Parameters

id PerformanceAdviserRuleId
An id of the rule to be deleted from the list of rules.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

PerformanceAdviser Class


PerformanceAdviser.Dispose Method

PerformanceAdviserDispose Method

Releases all resources used by the PerformanceAdviser

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

PerformanceAdviser Class


PerformanceAdviser.ExecuteAllRules Method

PerformanceAdviserExecuteAllRules Method

Executes all rules in the list on a given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<FailureMessage> ExecuteAllRules(
    Document document
)
Public Function ExecuteAllRules (
    document As Document
) As IList(Of FailureMessage)
public:
IList<FailureMessage^>^ ExecuteAllRules(
    Document^ document
)
member ExecuteAllRules :
        document : Document -> IList<FailureMessage>

Parameters

document Document
Document on which the rules will be executed.

Return Value

IList FailureMessage
Failure messages explaining performance problems detected in the document.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Disabled rules are not executed.
See Also

Reference

PerformanceAdviser Class


PerformanceAdviser.ExecuteRules Method

PerformanceAdviserExecuteRules Method

Overload List
 | Name | Description
Public method | ExecuteRules(Document, IListPerformanceAdviserRuleId) | Executes selected rules on a given document.
Public method | ExecuteRules(Document, IListInt32) | Executes selected rules on a given document.
Top
See Also

Reference

PerformanceAdviser Class


PerformanceAdviser.ExecuteRules(Document, IList<PerformanceAdviserRuleId>) Method

PerformanceAdviserExecuteRules(Document, IListPerformanceAdviserRuleId) Method

Executes selected rules on a given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<FailureMessage> ExecuteRules(
    Document document,
    IList<PerformanceAdviserRuleId> rules
)
Public Function ExecuteRules (
    document As Document,
    rules As IList(Of PerformanceAdviserRuleId)
) As IList(Of FailureMessage)
public:
IList<FailureMessage^>^ ExecuteRules(
    Document^ document,
    IList<PerformanceAdviserRuleId^>^ rules
)
member ExecuteRules :
        document : Document *
        rules : IList<PerformanceAdviserRuleId> -> IList<FailureMessage>

Parameters

document Document
Document on which the rules will be executed.
rules IList PerformanceAdviserRuleId
Ids of rules to be executed.

Return Value

IList FailureMessage
Failure messages explaining performance problems detected in the document.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

PerformanceAdviser Class
ExecuteRules Overload


PerformanceAdviser.ExecuteRules(Document, IList<Int32>) Method

PerformanceAdviserExecuteRules(Document, IListInt32) Method

Executes selected rules on a given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<FailureMessage> ExecuteRules(
    Document document,
    IList<int> rules
)
Public Function ExecuteRules (
    document As Document,
    rules As IList(Of Integer)
) As IList(Of FailureMessage)
public:
IList<FailureMessage^>^ ExecuteRules(
    Document^ document,
    IList<int>^ rules
)
member ExecuteRules :
        document : Document *
        rules : IList<int> -> IList<FailureMessage>

Parameters

document Document
Document on which the rules will be executed.
rules IList Int32
Indices of rules to be executed.

Return Value

IList FailureMessage
Failure messages explaining performance problems detected in the document.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Disabled rules are not executed.
See Also

Reference

PerformanceAdviser Class
ExecuteRules Overload


PerformanceAdviser.GetAllRuleIds Method

PerformanceAdviserGetAllRuleIds Method

Retrieves an enumeration of rule Ids.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<PerformanceAdviserRuleId> GetAllRuleIds()
Public Function GetAllRuleIds As IList(Of PerformanceAdviserRuleId)
public:
IList<PerformanceAdviserRuleId^>^ GetAllRuleIds()
member GetAllRuleIds : unit -> IList<PerformanceAdviserRuleId>

Return Value

IList PerformanceAdviserRuleId
A collection of rule Ids
See Also

Reference

PerformanceAdviser Class


PerformanceAdviser.GetElementFilterFromRule Method

PerformanceAdviserGetElementFilterFromRule Method

Overload List
 | Name | Description
Public method | GetElementFilterFromRule(Int32, Document) | Retrieves a filter to restrict elements to be checked.
Public method | GetElementFilterFromRule(PerformanceAdviserRuleId, Document) | Retrieves a filter to restrict elements to be checked.
Top
See Also

Reference

PerformanceAdviser Class


PerformanceAdviser.GetElementFilterFromRule(Int32, Document) Method

PerformanceAdviserGetElementFilterFromRule(Int32, Document) Method

Retrieves a filter to restrict elements to be checked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementFilter GetElementFilterFromRule(
    int index,
    Document document
)
Public Function GetElementFilterFromRule (
    index As Integer,
    document As Document
) As ElementFilter
public:
ElementFilter^ GetElementFilterFromRule(
    int index,
    Document^ document
)
member GetElementFilterFromRule :
        index : int *
        document : Document -> ElementFilter

Parameters

index Int32
The rule index to get information for.
document Document
Document for which performance problems are being checked.

Return Value

ElementFilter
The filter to restrict elements to be checked.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

PerformanceAdviser Class
GetElementFilterFromRule Overload


PerformanceAdviser.GetElementFilterFromRule(PerformanceAdviserRuleId, Document) Method

PerformanceAdviserGetElementFilterFromRule(PerformanceAdviserRuleId, Document) Method

Retrieves a filter to restrict elements to be checked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementFilter GetElementFilterFromRule(
    PerformanceAdviserRuleId id,
    Document document
)
Public Function GetElementFilterFromRule (
    id As PerformanceAdviserRuleId,
    document As Document
) As ElementFilter
public:
ElementFilter^ GetElementFilterFromRule(
    PerformanceAdviserRuleId^ id,
    Document^ document
)
member GetElementFilterFromRule :
        id : PerformanceAdviserRuleId *
        document : Document -> ElementFilter

Parameters

id PerformanceAdviserRuleId
The rule id to get information for.
document Document
Document for which performance problems are being checked.

Return Value

ElementFilter
The filter to restrict elements to be checked.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

PerformanceAdviser Class
GetElementFilterFromRule Overload


PerformanceAdviser.GetNumberOfRules Method

PerformanceAdviserGetNumberOfRules Method

Retrieves number of performance adviser rules in the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetNumberOfRules()
Public Function GetNumberOfRules As Integer
public:
int GetNumberOfRules()
member GetNumberOfRules : unit -> int

Return Value

Int32
Number of performance adviser rules in the list.
See Also

Reference

PerformanceAdviser Class


PerformanceAdviser.GetPerformanceAdviser Method

PerformanceAdviserGetPerformanceAdviser Method

Returns the only instance of PerformanceAdviser in the Application.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static PerformanceAdviser GetPerformanceAdviser()
Public Shared Function GetPerformanceAdviser As PerformanceAdviser
public:
static PerformanceAdviser^ GetPerformanceAdviser()
static member GetPerformanceAdviser : unit -> PerformanceAdviser

Return Value

PerformanceAdviser
The only instance of PerformanceAdviser in the Application.
See Also

Reference

PerformanceAdviser Class


PerformanceAdviser.GetRuleDescription Method

PerformanceAdviserGetRuleDescription Method

Overload List
 | Name | Description
Public method | GetRuleDescription(Int32) | Retrieves the description of the rule.
Public method | GetRuleDescription(PerformanceAdviserRuleId) | Retrieves the description of the rule.
Top
See Also

Reference

PerformanceAdviser Class


PerformanceAdviser.GetRuleDescription(Int32) Method

PerformanceAdviserGetRuleDescription(Int32) Method

Retrieves the description of the rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetRuleDescription(
    int index
)
Public Function GetRuleDescription (
    index As Integer
) As String
public:
String^ GetRuleDescription(
    int index
)
member GetRuleDescription :
        index : int -> string

Parameters

index Int32
The rule index to get information for.

Return Value

String
The description of the rule.
See Also

Reference

PerformanceAdviser Class
GetRuleDescription Overload


PerformanceAdviser.GetRuleDescription(PerformanceAdviserRuleId) Method

PerformanceAdviserGetRuleDescription(PerformanceAdviserRuleId) Method

Retrieves the description of the rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetRuleDescription(
    PerformanceAdviserRuleId id
)
Public Function GetRuleDescription (
    id As PerformanceAdviserRuleId
) As String
public:
String^ GetRuleDescription(
    PerformanceAdviserRuleId^ id
)
member GetRuleDescription :
        id : PerformanceAdviserRuleId -> string

Parameters

id PerformanceAdviserRuleId
The rule id to get information for.

Return Value

String
The description of the rule.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

PerformanceAdviser Class
GetRuleDescription Overload


PerformanceAdviser.GetRuleId Method

PerformanceAdviserGetRuleId Method

Retrieves an id of a rule for a given index in the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PerformanceAdviserRuleId GetRuleId(
    int index
)
Public Function GetRuleId (
    index As Integer
) As PerformanceAdviserRuleId
public:
PerformanceAdviserRuleId^ GetRuleId(
    int index
)
member GetRuleId :
        index : int -> PerformanceAdviserRuleId

Parameters

index Int32
The index to retrieve the rule id for.

Return Value

PerformanceAdviserRuleId
The rule id.
Exceptions
Exception | Condition
ArgumentException | The index is outside of acceptable range.
See Also

Reference

PerformanceAdviser Class


PerformanceAdviser.GetRuleName Method

PerformanceAdviserGetRuleName Method

Overload List
 | Name | Description
Public method | GetRuleName(Int32) | Retrieves the name of the rule.
Public method | GetRuleName(PerformanceAdviserRuleId) | Retrieves the name of the rule.
Top
See Also

Reference

PerformanceAdviser Class


PerformanceAdviser.GetRuleName(Int32) Method

PerformanceAdviserGetRuleName(Int32) Method

Retrieves the name of the rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetRuleName(
    int index
)
Public Function GetRuleName (
    index As Integer
) As String
public:
String^ GetRuleName(
    int index
)
member GetRuleName :
        index : int -> string

Parameters

index Int32
The rule index to get information for.

Return Value

String
The name of the rule.
See Also

Reference

PerformanceAdviser Class
GetRuleName Overload


PerformanceAdviser.GetRuleName(PerformanceAdviserRuleId) Method

PerformanceAdviserGetRuleName(PerformanceAdviserRuleId) Method

Retrieves the name of the rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetRuleName(
    PerformanceAdviserRuleId id
)
Public Function GetRuleName (
    id As PerformanceAdviserRuleId
) As String
public:
String^ GetRuleName(
    PerformanceAdviserRuleId^ id
)
member GetRuleName :
        id : PerformanceAdviserRuleId -> string

Parameters

id PerformanceAdviserRuleId
The rule id to get information for.

Return Value

String
The name of the rule.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

PerformanceAdviser Class
GetRuleName Overload


PerformanceAdviser.IsRuleEnabled Method

PerformanceAdviserIsRuleEnabled Method

Overload List
 | Name | Description
Public method | IsRuleEnabled(Int32) | Retrieves an enabled/disabled status for the given rule.
Public method | IsRuleEnabled(PerformanceAdviserRuleId) | Retrieves an enabled/disabled status for the given rule.
Top
See Also

Reference

PerformanceAdviser Class


PerformanceAdviser.IsRuleEnabled(Int32) Method

PerformanceAdviserIsRuleEnabled(Int32) Method

Retrieves an enabled/disabled status for the given rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsRuleEnabled(
    int index
)
Public Function IsRuleEnabled (
    index As Integer
) As Boolean
public:
bool IsRuleEnabled(
    int index
)
member IsRuleEnabled :
        index : int -> bool

Parameters

index Int32
The rule index to retrieve enabled/disabled status for.

Return Value

Boolean
True if rule is disabled, false otherwise.
Exceptions
Exception | Condition
ArgumentException | The index is outside of acceptable range.
See Also

Reference

PerformanceAdviser Class
IsRuleEnabled Overload


PerformanceAdviser.IsRuleEnabled(PerformanceAdviserRuleId) Method

PerformanceAdviserIsRuleEnabled(PerformanceAdviserRuleId) Method

Retrieves an enabled/disabled status for the given rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsRuleEnabled(
    PerformanceAdviserRuleId id
)
Public Function IsRuleEnabled (
    id As PerformanceAdviserRuleId
) As Boolean
public:
bool IsRuleEnabled(
    PerformanceAdviserRuleId^ id
)
member IsRuleEnabled :
        id : PerformanceAdviserRuleId -> bool

Parameters

id PerformanceAdviserRuleId
The rule id to retrieve enabled/disabled status for.

Return Value

Boolean
True if rule is disabled, false otherwise.
Exceptions
Exception | Condition
ArgumentException | The id does not correspond to any registered rule.
ArgumentNullException | A non-optional argument was null
See Also

Reference

PerformanceAdviser Class
IsRuleEnabled Overload


PerformanceAdviser.PostWarning Method

PerformanceAdviserPostWarning Method

Reports a problem detected during execution of a rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void PostWarning(
    FailureMessage message
)
Public Sub PostWarning (
    message As FailureMessage
)
public:
void PostWarning(
    FailureMessage^ message
)
member PostWarning :
        message : FailureMessage -> unit

Parameters

message FailureMessage
Warning describing the problem detected by a rule.
Exceptions
Exception | Condition
ArgumentException | The message must have severity "warning".
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Performance advisor is not executing rules.
See Also

Reference

PerformanceAdviser Class


PerformanceAdviser.SetRuleEnabled Method

PerformanceAdviserSetRuleEnabled Method

Overload List
 | Name | Description
Public method | SetRuleEnabled(Int32, Boolean) | Retrieves an enabled/disabled status for the given rule.
Public method | SetRuleEnabled(PerformanceAdviserRuleId, Boolean) | Retrieves an enabled/disabled status for the given rule.
Top
See Also

Reference

PerformanceAdviser Class


PerformanceAdviser.SetRuleEnabled(Int32, Boolean) Method

PerformanceAdviserSetRuleEnabled(Int32, Boolean) Method

Retrieves an enabled/disabled status for the given rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetRuleEnabled(
    int index,
    bool enabled
)
Public Sub SetRuleEnabled (
    index As Integer,
    enabled As Boolean
)
public:
void SetRuleEnabled(
    int index,
    bool enabled
)
member SetRuleEnabled :
        index : int *
        enabled : bool -> unit

Parameters

index Int32
The rule index to set enabled/disabled status for.
enabled Boolean
True enables the rule, false disables.
Exceptions
Exception | Condition
ArgumentException | The index is outside of acceptable range.
See Also

Reference

PerformanceAdviser Class
SetRuleEnabled Overload


PerformanceAdviser.SetRuleEnabled(PerformanceAdviserRuleId, Boolean) Method

PerformanceAdviserSetRuleEnabled(PerformanceAdviserRuleId, Boolean) Method

Retrieves an enabled/disabled status for the given rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetRuleEnabled(
    PerformanceAdviserRuleId id,
    bool enabled
)
Public Sub SetRuleEnabled (
    id As PerformanceAdviserRuleId,
    enabled As Boolean
)
public:
void SetRuleEnabled(
    PerformanceAdviserRuleId^ id,
    bool enabled
)
member SetRuleEnabled :
        id : PerformanceAdviserRuleId *
        enabled : bool -> unit

Parameters

id PerformanceAdviserRuleId
The rule id to set enabled/disabled status for.
enabled Boolean
True enables the rule, false disables.
Exceptions
Exception | Condition
ArgumentException | The id does not correspond to any registered rule.
ArgumentNullException | A non-optional argument was null
See Also

Reference

PerformanceAdviser Class
SetRuleEnabled Overload


PerformanceAdviser.WillRuleCheckElements Method

PerformanceAdviserWillRuleCheckElements Method

Overload List
 | Name | Description
Public method | WillRuleCheckElements(Int32) | Reports if rule needs to be executed on individual elements.
Public method | WillRuleCheckElements(PerformanceAdviserRuleId) | Reports if rule needs to be executed on individual elements.
Top
See Also

Reference

PerformanceAdviser Class


PerformanceAdviser.WillRuleCheckElements(Int32) Method

PerformanceAdviserWillRuleCheckElements(Int32) Method

Reports if rule needs to be executed on individual elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool WillRuleCheckElements(
    int index
)
Public Function WillRuleCheckElements (
    index As Integer
) As Boolean
public:
bool WillRuleCheckElements(
    int index
)
member WillRuleCheckElements :
        index : int -> bool

Parameters

index Int32
The rule index to get information for.

Return Value

Boolean
True if rule needs to be executed on individual elements.
See Also

Reference

PerformanceAdviser Class
WillRuleCheckElements Overload


PerformanceAdviser.WillRuleCheckElements(PerformanceAdviserRuleId) Method

PerformanceAdviserWillRuleCheckElements(PerformanceAdviserRuleId) Method

Reports if rule needs to be executed on individual elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool WillRuleCheckElements(
    PerformanceAdviserRuleId id
)
Public Function WillRuleCheckElements (
    id As PerformanceAdviserRuleId
) As Boolean
public:
bool WillRuleCheckElements(
    PerformanceAdviserRuleId^ id
)
member WillRuleCheckElements :
        id : PerformanceAdviserRuleId -> bool

Parameters

id PerformanceAdviserRuleId
The rule id to get information for.

Return Value

Boolean
True if rule needs to be executed on individual elements.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

PerformanceAdviser Class
WillRuleCheckElements Overload


PerformanceAdviserRuleId Class

The unique identifier of a PerformanceAdviserRule
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBGuidEnum
Autodesk.Revit.DBPerformanceAdviserRuleId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PerformanceAdviserRuleId : GuidEnum
Public Class PerformanceAdviserRuleId
    Inherits GuidEnum
public ref class PerformanceAdviserRuleId : public GuidEnum
type PerformanceAdviserRuleId =
    class
        inherit GuidEnum
    end

The PerformanceAdviserRuleId type exposes the following members.

Constructors
 | Name | Description
Public method | PerformanceAdviserRuleId | Creates a new PerformanceAdviserRuleId instance.
Top
Properties
 | Name | Description
Public property | Guid | The Guid of GUID-based enum object. (Inherited from GuidEnum)
Top
Methods
 | Name | Description
Public method | Equals | Compares two Guid-based enum object based on their concrete class and GUID value. (Inherited from GuidEnum)
Public method | GetHashCode | Generates a hash code for this Guid-based enum object. (Inherited from GuidEnum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Operators
Name | Description
Equality(PerformanceAdviserRuleId, PerformanceAdviserRuleId) | Compares two PerformanceAdviserRuleId instances.
Inequality(PerformanceAdviserRuleId, PerformanceAdviserRuleId) | Compares two PerformanceAdviserRuleId instances.
Top
Remarks
Each performance adviser rule registered in application must be given a unique id that can be used to identify and unregister rule later.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PerformanceAdviserRuleId Constructor

Creates a new PerformanceAdviserRuleId instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PerformanceAdviserRuleId(
    Guid guid
)
Public Sub New (
    guid As Guid
)
public:
PerformanceAdviserRuleId(
    Guid guid
)
new :
        guid : Guid -> PerformanceAdviserRuleId

Parameters

guid Guid
The identifier for the PerformanceAdviserRuleId.
See Also

Reference

PerformanceAdviserRuleId Class


PerformanceAdviserRuleId Properties

The PerformanceAdviserRuleId type exposes the following members.

Properties
 | Name | Description
Public property | Guid | The Guid of GUID-based enum object. (Inherited from GuidEnum)
Top
See Also

Reference

PerformanceAdviserRuleId Class


PerformanceAdviserRuleId Methods

The PerformanceAdviserRuleId type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Compares two Guid-based enum object based on their concrete class and GUID value. (Inherited from GuidEnum)
Public method | GetHashCode | Generates a hash code for this Guid-based enum object. (Inherited from GuidEnum)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PerformanceAdviserRuleId Class


PerformanceAdviserRuleId Operators

The PerformanceAdviserRuleId type exposes the following members.

Operators
Name | Description
Equality(PerformanceAdviserRuleId, PerformanceAdviserRuleId) | Compares two PerformanceAdviserRuleId instances.
Inequality(PerformanceAdviserRuleId, PerformanceAdviserRuleId) | Compares two PerformanceAdviserRuleId instances.
Top
See Also

Reference

PerformanceAdviserRuleId Class


PerformanceAdviserRuleId.Equality Operator

PerformanceAdviserRuleIdEquality Operator

Compares two PerformanceAdviserRuleId instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool operator ==(
    PerformanceAdviserRuleId first,
    PerformanceAdviserRuleId second
)
Public Shared Operator = (
    first As PerformanceAdviserRuleId,
    second As PerformanceAdviserRuleId
) As Boolean
public:
static bool operator ==(
    PerformanceAdviserRuleId^ first,
    PerformanceAdviserRuleId^ second
)
static let inline (=)
        first : PerformanceAdviserRuleId *
        second : PerformanceAdviserRuleId  : bool

Parameters

first PerformanceAdviserRuleId
The first PerformanceAdviserRuleId.
second PerformanceAdviserRuleId
The second PerformanceAdviserRuleId.

Return Value

Boolean
True if the inputs are identical, false if they are different.
See Also

Reference

PerformanceAdviserRuleId Class


PerformanceAdviserRuleId.Inequality Operator

PerformanceAdviserRuleIdInequality Operator

Compares two PerformanceAdviserRuleId instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool operator !=(
    PerformanceAdviserRuleId first,
    PerformanceAdviserRuleId second
)
Public Shared Operator <> (
    first As PerformanceAdviserRuleId,
    second As PerformanceAdviserRuleId
) As Boolean
public:
static bool operator !=(
    PerformanceAdviserRuleId^ first,
    PerformanceAdviserRuleId^ second
)
static let inline (<>)
        first : PerformanceAdviserRuleId *
        second : PerformanceAdviserRuleId  : bool

Parameters

first PerformanceAdviserRuleId
The first PerformanceAdviserRuleId.
second PerformanceAdviserRuleId
The second PerformanceAdviserRuleId.

Return Value

Boolean
True if the inputs are different, false if they are identical.
See Also

Reference

PerformanceAdviserRuleId Class


PerformanceAdviserRules Class

Provides a container of all Revit built-in PerformanceAdviserRuleId instances.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBPerformanceAdviserRules

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class PerformanceAdviserRules
Public NotInheritable Class PerformanceAdviserRules
public ref class PerformanceAdviserRules abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type PerformanceAdviserRules = class end
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Phase Class

Represents a phase in the life of a building.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBPhase

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Phase : Element
Public Class Phase
    Inherits Element
public ref class Phase : public Element
type Phase =
    class
        inherit Element
    end

The Phase type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The lifetime of an element within a building can be controlled by using phases. Each element will have a construction phase but only those elements that have a finite lifetime will have a destruction phase. All the phases within a project can be retrieved from the Document object.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Phase Properties

The Phase type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

Phase Class


Phase Methods

The Phase type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Phase Class


PhaseArray Class

An array that contains phase objects.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBPhaseArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PhaseArray : APIObject, IEnumerable
Public Class PhaseArray
    Inherits APIObject
    Implements IEnumerable
public ref class PhaseArray : public APIObject,
    IEnumerable
type PhaseArray =
    class
        inherit APIObject
        interface IEnumerable
    end

The PhaseArray type exposes the following members.

Constructors
 | Name | Description
Public method | PhaseArray | Initializes a new instance of the PhaseArray class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets a phase at a specified index within the array.
Public property | Size | Returns the number of phases that are in the array.
Top
Methods
 | Name | Description
Public method | Append | Add the phase to the end of the array.
Public method | Clear | Removes every phase from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified phase into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PhaseArray Constructor

Initializes a new instance of the PhaseArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PhaseArray()
Public Sub New
public:
PhaseArray()
new : unit -> PhaseArray
See Also

Reference

PhaseArray Class


PhaseArray Properties

The PhaseArray type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets a phase at a specified index within the array.
Public property | Size | Returns the number of phases that are in the array.
Top
See Also

Reference

PhaseArray Class


PhaseArray.IsEmpty Property

PhaseArrayIsEmpty Property

Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Boolean
Remarks
If the array is empty then True will be returned, otherwise False.
See Also

Reference

PhaseArray Class


PhaseArray.Item Property

PhaseArrayItem Property

Gets or sets a phase at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Phase this[
    int index
] { get; set; }
Public Overridable Property Item (
    index As Integer
) As Phase
    Get
    Set
public:
virtual property Phase^ Item[int index] {
    Phase^ get (int index);
    void set (int index, Phase^ value);
}
abstract Item : Phase with get, set
override Item : Phase with get, set

Parameters

index Int32
The index of the phase to be set or retrieved.

Return Value

Phase
Returns the phase at the specified index.
See Also

Reference

PhaseArray Class


PhaseArray.Size Property

PhaseArraySize Property

Returns the number of phases that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
abstract Size : int with get
override Size : int with get

Property Value

Int32
See Also

Reference

PhaseArray Class


PhaseArray Methods

The PhaseArray type exposes the following members.

Methods
 | Name | Description
Public method | Append | Add the phase to the end of the array.
Public method | Clear | Removes every phase from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified phase into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PhaseArray Class


PhaseArray.Append Method

PhaseArrayAppend Method

Add the phase to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Append(
    Phase item
)
Public Overridable Sub Append (
    item As Phase
)
public:
virtual void Append(
    Phase^ item
)
abstract Append :
        item : Phase -> unit
override Append :
        item : Phase -> unit

Parameters

item Phase
The phase to be added.
See Also

Reference

PhaseArray Class


PhaseArray.Clear Method

PhaseArrayClear Method

Removes every phase from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

PhaseArray Class


PhaseArray.ForwardIterator Method

PhaseArrayForwardIterator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual PhaseArrayIterator ForwardIterator()
Public Overridable Function ForwardIterator As PhaseArrayIterator
public:
virtual PhaseArrayIterator^ ForwardIterator()
abstract ForwardIterator : unit -> PhaseArrayIterator
override ForwardIterator : unit -> PhaseArrayIterator

Return Value

PhaseArrayIterator
Returns a forward moving iterator to the array.
See Also

Reference

PhaseArray Class


PhaseArray.GetEnumerator Method

PhaseArrayGetEnumerator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

IEnumerator
Returns a forward moving iterator to the array.

Implements

IEnumerableGetEnumerator
See Also

Reference

PhaseArray Class


PhaseArray.Insert Method

PhaseArrayInsert Method

Insert the specified phase into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Insert(
    Phase item,
    int index
)
Public Overridable Sub Insert (
    item As Phase,
    index As Integer
)
public:
virtual void Insert(
    Phase^ item,
    int index
)
abstract Insert :
        item : Phase *
        index : int -> unit
override Insert :
        item : Phase *
        index : int -> unit

Parameters

item Phase
The phase to be inserted into the array.
index Int32
The phase will be inserted before this index.

Return Value

Returns whether the phase was inserted into the array.
See Also

Reference

PhaseArray Class


PhaseArray.ReverseIterator Method

PhaseArrayReverseIterator Method

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual PhaseArrayIterator ReverseIterator()
Public Overridable Function ReverseIterator As PhaseArrayIterator
public:
virtual PhaseArrayIterator^ ReverseIterator()
abstract ReverseIterator : unit -> PhaseArrayIterator
override ReverseIterator : unit -> PhaseArrayIterator

Return Value

PhaseArrayIterator
Returns a backward moving iterator to the array.
See Also

Reference

PhaseArray Class


PhaseArrayIterator Class

An iterator to a phase array.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBPhaseArrayIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class PhaseArrayIterator : APIObject,
    IEnumerator
Public MustInherit Class PhaseArrayIterator
    Inherits APIObject
    Implements IEnumerator
public ref class PhaseArrayIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type PhaseArrayIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The PhaseArrayIterator type exposes the following members.

Constructors
 | Name | Description
Public method | PhaseArrayIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PhaseArrayIterator Constructor

For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PhaseArrayIterator()
Public Sub New
public:
PhaseArrayIterator()
new : unit -> PhaseArrayIterator
Remarks
This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.
See Also

Reference

PhaseArrayIterator Class


PhaseArrayIterator Properties

The PhaseArrayIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

PhaseArrayIterator Class


PhaseArrayIterator.Current Property

PhaseArrayIteratorCurrent Property

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}
abstract Current : Object with get
override Current : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.
See Also

Reference

PhaseArrayIterator Class


PhaseArrayIterator Methods

The PhaseArrayIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PhaseArrayIterator Class


PhaseArrayIterator.MoveNext Method

PhaseArrayIteratorMoveNext Method

Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumeratorMoveNext
Remarks
MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.
See Also

Reference

PhaseArrayIterator Class


PhaseArrayIterator.Reset Method

PhaseArrayIteratorReset Method

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
Remarks
The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.
See Also

Reference

PhaseArrayIterator Class


PhaseFilter Class

Represents an phase filter within Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBPhaseFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PhaseFilter : Element
Public Class PhaseFilter
    Inherits Element
public ref class PhaseFilter : public Element
type PhaseFilter =
    class
        inherit Element
    end

The PhaseFilter type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsDefault | Indicates whether this filter is the default one.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new phase filter with default status presentation.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPhaseStatusPresentation | Gets the phase status presentation.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetPhaseStatusPresentation | Sets the phase status presentation.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PhaseFilter Properties

The PhaseFilter type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsDefault | Indicates whether this filter is the default one.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

PhaseFilter Class


PhaseFilter.IsDefault Property

PhaseFilterIsDefault Property

Indicates whether this filter is the default one.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsDefault { get; }
Public ReadOnly Property IsDefault As Boolean
    Get
public:
property bool IsDefault {
    bool get ();
}
member IsDefault : bool with get

Property Value

Boolean
See Also

Reference

PhaseFilter Class


PhaseFilter Methods

The PhaseFilter type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new phase filter with default status presentation.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPhaseStatusPresentation | Gets the phase status presentation.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetPhaseStatusPresentation | Sets the phase status presentation.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PhaseFilter Class


PhaseFilter.Create Method

PhaseFilterCreate Method

Creates a new phase filter with default status presentation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static PhaseFilter Create(
    Document document,
    string name
)
Public Shared Function Create (
    document As Document,
    name As String
) As PhaseFilter
public:
static PhaseFilter^ Create(
    Document^ document,
    String^ name
)
static member Create :
        document : Document *
        name : string -> PhaseFilter

Parameters

document Document
The document.
name String
The name.

Return Value

PhaseFilter
The newly created phase filter.
Exceptions
Exception | Condition
ArgumentException | name is already in use.
ArgumentNullException | A non-optional argument was null
Remarks
The default status presentation is ShowByCategory for New status, and ShowOverriden for Existing, Demolished and Temporary statuses.
See Also

Reference

PhaseFilter Class


PhaseFilter.GetPhaseStatusPresentation Method

PhaseFilterGetPhaseStatusPresentation Method

Gets the phase status presentation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PhaseStatusPresentation GetPhaseStatusPresentation(
    ElementOnPhaseStatus status
)
Public Function GetPhaseStatusPresentation (
    status As ElementOnPhaseStatus
) As PhaseStatusPresentation
public:
PhaseStatusPresentation GetPhaseStatusPresentation(
    ElementOnPhaseStatus status
)
member GetPhaseStatusPresentation :
        status : ElementOnPhaseStatus -> PhaseStatusPresentation

Parameters

status ElementOnPhaseStatus
The element phase status.

Return Value

PhaseStatusPresentation
The phase status presentation.
Exceptions
Exception | Condition
ArgumentException | status is invalid for presentation query.
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

PhaseFilter Class


PhaseFilter.SetPhaseStatusPresentation Method

PhaseFilterSetPhaseStatusPresentation Method

Sets the phase status presentation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetPhaseStatusPresentation(
    ElementOnPhaseStatus status,
    PhaseStatusPresentation presentation
)
Public Sub SetPhaseStatusPresentation (
    status As ElementOnPhaseStatus,
    presentation As PhaseStatusPresentation
)
public:
void SetPhaseStatusPresentation(
    ElementOnPhaseStatus status,
    PhaseStatusPresentation presentation
)
member SetPhaseStatusPresentation :
        status : ElementOnPhaseStatus *
        presentation : PhaseStatusPresentation -> unit

Parameters

status ElementOnPhaseStatus
The element phase status.
presentation PhaseStatusPresentation
The phase status presentation.
Exceptions
Exception | Condition
ArgumentException | status is invalid for presentation query.
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

PhaseFilter Class


PhaseStatusPresentation Enumeration

An enumerated type listing the options for element display in a phase filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum PhaseStatusPresentation
Public Enumeration PhaseStatusPresentation
public enum class PhaseStatusPresentation
type PhaseStatusPresentation
Members
Member name | Value | Description
DontShow | 0 | Don't show elements from the given phase status.
ShowByCategory | 1 | Show elements from the given phase status by category.
ShowOverriden | 2 | Show elements from the given phase status by graphics overrides.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PlanarFace Class

A bounded face of a 3d solid or open shell.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGeometryObject
Autodesk.Revit.DBFace
Autodesk.Revit.DBPlanarFace

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PlanarFace : Face
Public Class PlanarFace
    Inherits Face
public ref class PlanarFace : public Face
type PlanarFace =
    class
        inherit Face
    end

The PlanarFace type exposes the following members.

Properties
 | Name | Description
Public property | Area | The area of this face. (Inherited from Face)
Public property | EdgeLoops | A collection of edge loops. Each edge loop represents one of the closed boundaries of the face. (Inherited from Face)
Public property | FaceNormal | Normal of the planar face.
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject)
Public property | HasRegions | Identifies if the face contains regions (which can be created, for example, by the Split Face command). (Inherited from Face)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject)
Public property | IsCyclic | Indicates whether the underlying surface is periodic in the specified parametric direction. (Inherited from Face)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject)
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate). (Inherited from Face)
Public property | MaterialElementId | The element ID of the material from which this face is composed. (Inherited from Face)
Public property | OrientationMatchesSurfaceOrientation | Returns true if this face's orientation matches the orientation of the face's surface, false if they have opposite orientations. (Inherited from Face)
Public property | Origin | Origin of the surface.
Public property | Period | The period of the underlying surface in the specified parametric direction. (Inherited from Face)
Public property | Reference | Returns a stable reference to the face. (Inherited from Face)
Public property | Visibility | The visibility. (Inherited from GeometryObject)
Public property | XVector | The X-vector of the planar face.
Public property | YVector | The Y-vector of the planar face.
Top
Methods
 | Name | Description
Public method | ComputeDerivatives | Returns the first partial derivatives of the underlying surface at the specified point. (Inherited from Face)
Public method | ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face)
Public method | ComputeSecondDerivatives | Returns the second partial derivatives of the face at the specified point. (Inherited from Face)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject)
Public method | Evaluate | Evaluates and returns the XYZ coordinates of a point at the indicated UV parameterization of the face. (Inherited from Face)
Public method | GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face)
Public method | GetEdgesAsCurveLoops | Returns a list of closed curve loops that correspond to the edge loops of the face. Curves in each curve loop correspond to individual edges. (Inherited from Face)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject)
Public method | GetRegions | Gets the face regions (created, for example, by the Split Face command) of the face. (Inherited from Face)
Public method | GetSurface | Returns a copy of this face's surface. (Inherited from Face)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face)
Public method | Intersect(Face) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face)
Public method | Intersect(Curve, IntersectionResultArray) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face)
Public method | Intersect(Face, Curve) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face)
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face)
Public method | IsInside(UV, IntersectionResult) | Indicates whether the specified point is within this face and outputs additional information about the point location. (Inherited from Face)
Public method | Project | Projects the specified point on the face. (Inherited from Face)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
 | Triangulate | Returns a triangular mesh approximation to the face. (Inherited from Face)
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face. (Inherited from Face)
Top
Remarks
Planar faces are defined by planes bounded by edge loops. The planes provide natural UV parameterization to the faces. S(u, v) = Origin + u*Vector[0] + v*Vector[1]
Example
C#
VB
C++
F#
Copy
private void GetPlanarFaceInfo(Face face)
{
    PlanarFace planarFace = face as PlanarFace;
    if (null != planarFace)
    {
       XYZ origin = planarFace.Origin;
        XYZ normal = planarFace.FaceNormal;
        XYZ vector = planarFace.XVector;
    }
}
Private Sub GetPlanarFaceInfo(face As Face)
   Dim planarFace As PlanarFace = TryCast(face, PlanarFace)
   If planarFace IsNot Nothing Then
      Dim origin As XYZ = planarFace.Origin
      Dim normal As XYZ = planarFace.FaceNormal
      Dim vector As XYZ = planarFace.XVector
   End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PlanarFace Properties

The PlanarFace type exposes the following members.

Properties
 | Name | Description
Public property | Area | The area of this face. (Inherited from Face)
Public property | EdgeLoops | A collection of edge loops. Each edge loop represents one of the closed boundaries of the face. (Inherited from Face)
Public property | FaceNormal | Normal of the planar face.
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject)
Public property | HasRegions | Identifies if the face contains regions (which can be created, for example, by the Split Face command). (Inherited from Face)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject)
Public property | IsCyclic | Indicates whether the underlying surface is periodic in the specified parametric direction. (Inherited from Face)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject)
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate). (Inherited from Face)
Public property | MaterialElementId | The element ID of the material from which this face is composed. (Inherited from Face)
Public property | OrientationMatchesSurfaceOrientation | Returns true if this face's orientation matches the orientation of the face's surface, false if they have opposite orientations. (Inherited from Face)
Public property | Origin | Origin of the surface.
Public property | Period | The period of the underlying surface in the specified parametric direction. (Inherited from Face)
Public property | Reference | Returns a stable reference to the face. (Inherited from Face)
Public property | Visibility | The visibility. (Inherited from GeometryObject)
Public property | XVector | The X-vector of the planar face.
Public property | YVector | The Y-vector of the planar face.
Top
See Also

Reference

PlanarFace Class


PlanarFace.FaceNormal Property

PlanarFaceFaceNormal Property

Normal of the planar face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ FaceNormal { get; }
Public ReadOnly Property FaceNormal As XYZ
    Get
public:
property XYZ^ FaceNormal {
    XYZ^ get ();
}
member FaceNormal : XYZ with get

Property Value

XYZ
Remarks
This property is the "face normal" vector, and thus should return a vector consistently pointing out of the solid that this face is a boundary for (if it is a part of a solid).
See Also

Reference

PlanarFace Class


PlanarFace.Origin Property

PlanarFaceOrigin Property

Origin of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Origin { get; }
Public ReadOnly Property Origin As XYZ
    Get
public:
property XYZ^ Origin {
    XYZ^ get ();
}
member Origin : XYZ with get

Property Value

XYZ
See Also

Reference

PlanarFace Class


PlanarFace.XVector Property

PlanarFaceXVector Property

The X-vector of the planar face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ XVector { get; }
Public ReadOnly Property XVector As XYZ
    Get
public:
property XYZ^ XVector {
    XYZ^ get ();
}
member XVector : XYZ with get

Property Value

XYZ
Remarks
Note that the cross product of X-vector and Y-vector may result in the reverse of the FaceNormal vector depending upon how Revit has structured this particular face.
See Also

Reference

PlanarFace Class


PlanarFace.YVector Property

PlanarFaceYVector Property

The Y-vector of the planar face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ YVector { get; }
Public ReadOnly Property YVector As XYZ
    Get
public:
property XYZ^ YVector {
    XYZ^ get ();
}
member YVector : XYZ with get

Property Value

XYZ
Remarks
Note that the cross product of X-vector and Y-vector may result in the reverse of the FaceNormal vector depending upon how Revit has structured this particular face.
See Also

Reference

PlanarFace Class


PlanarFace Methods

The PlanarFace type exposes the following members.

Methods
 | Name | Description
Public method | ComputeDerivatives | Returns the first partial derivatives of the underlying surface at the specified point. (Inherited from Face)
Public method | ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face)
Public method | ComputeSecondDerivatives | Returns the second partial derivatives of the face at the specified point. (Inherited from Face)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject)
Public method | Evaluate | Evaluates and returns the XYZ coordinates of a point at the indicated UV parameterization of the face. (Inherited from Face)
Public method | GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face)
Public method | GetEdgesAsCurveLoops | Returns a list of closed curve loops that correspond to the edge loops of the face. Curves in each curve loop correspond to individual edges. (Inherited from Face)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject)
Public method | GetRegions | Gets the face regions (created, for example, by the Split Face command) of the face. (Inherited from Face)
Public method | GetSurface | Returns a copy of this face's surface. (Inherited from Face)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face)
Public method | Intersect(Face) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face)
Public method | Intersect(Curve, IntersectionResultArray) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face)
Public method | Intersect(Face, Curve) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face)
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face)
Public method | IsInside(UV, IntersectionResult) | Indicates whether the specified point is within this face and outputs additional information about the point location. (Inherited from Face)
Public method | Project | Projects the specified point on the face. (Inherited from Face)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
 | Triangulate | Returns a triangular mesh approximation to the face. (Inherited from Face)
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face. (Inherited from Face)
Top
See Also

Reference

PlanarFace Class


PlanCircuit Class

An object that represents an enclosed area in a plan view within the Autodesk Revit project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBPlanCircuit

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PlanCircuit : APIObject
Public Class PlanCircuit
    Inherits APIObject
public ref class PlanCircuit : public APIObject
type PlanCircuit =
    class
        inherit APIObject
    end

The PlanCircuit type exposes the following members.

Properties
 | Name | Description
Public property | Area | The enclosed area of the circuit.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | IsRoomLocated | Reports whether there is a room located in this circuit.
Public property | SideNum | The number of sides in the circuit.
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetPointInside | Returns a point inside the circuit.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Plan circuits are enclosed regions as seen on a plan view. They are used to determine the boundary extents of rooms based on the placement of walls. In the Autodesk Revit API, you can use plan circuits to create new rooms.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PlanCircuit Properties

The PlanCircuit type exposes the following members.

Properties
 | Name | Description
Public property | Area | The enclosed area of the circuit.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | IsRoomLocated | Reports whether there is a room located in this circuit.
Public property | SideNum | The number of sides in the circuit.
Top
See Also

Reference

PlanCircuit Class


PlanCircuit.Area Property

PlanCircuitArea Property

The enclosed area of the circuit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Area { get; }
Public ReadOnly Property Area As Double
    Get
public:
property double Area {
    double get ();
}
member Area : float with get

Property Value

Double
See Also

Reference

PlanCircuit Class


PlanCircuit.IsRoomLocated Property

PlanCircuitIsRoomLocated Property

Reports whether there is a room located in this circuit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsRoomLocated { get; }
Public ReadOnly Property IsRoomLocated As Boolean
    Get
public:
property bool IsRoomLocated {
    bool get ();
}
member IsRoomLocated : bool with get

Property Value

Boolean
True if there is a room located in this circuit on the circuit's level, false if there is no room located in this circuit on the circuit's level.
See Also

Reference

PlanCircuit Class


PlanCircuit.SideNum Property

PlanCircuitSideNum Property

The number of sides in the circuit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int SideNum { get; }
Public ReadOnly Property SideNum As Integer
    Get
public:
property int SideNum {
    int get ();
}
member SideNum : int with get

Property Value

Int32
See Also

Reference

PlanCircuit Class


PlanCircuit Methods

The PlanCircuit type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetPointInside | Returns a point inside the circuit.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PlanCircuit Class


PlanCircuit.GetPointInside Method

PlanCircuitGetPointInside Method

Returns a point inside the circuit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public UV GetPointInside()
Public Function GetPointInside As UV
public:
UV^ GetPointInside()
member GetPointInside : unit -> UV

Return Value

UV
Exceptions
Exception | Condition
InvalidOperationException | Thrown when a valid UV point couldn't be obtained.
See Also

Reference

PlanCircuit Class


PlanCircuitSet Class

A set that can contain any number of plan circuit objects.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBPlanCircuitSet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PlanCircuitSet : APIObject,
    IEnumerable
Public Class PlanCircuitSet
    Inherits APIObject
    Implements IEnumerable
public ref class PlanCircuitSet : public APIObject,
    IEnumerable
type PlanCircuitSet =
    class
        inherit APIObject
        interface IEnumerable
    end

The PlanCircuitSet type exposes the following members.

Constructors
 | Name | Description
Public method | PlanCircuitSet | Initializes a new instance of the PlanCircuitSet class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Size | Returns the number of objects that are in the set.
Top
Methods
 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of an item within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase | Removes a specified object from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified item into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PlanCircuitSet Constructor

Initializes a new instance of the PlanCircuitSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PlanCircuitSet()
Public Sub New
public:
PlanCircuitSet()
new : unit -> PlanCircuitSet
See Also

Reference

PlanCircuitSet Class


PlanCircuitSet Properties

The PlanCircuitSet type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Size | Returns the number of objects that are in the set.
Top
See Also

Reference

PlanCircuitSet Class


PlanCircuitSet.IsEmpty Property

PlanCircuitSetIsEmpty Property

Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Boolean
Remarks
If the set is empty then True will be returned, otherwise False.
See Also

Reference

PlanCircuitSet Class


PlanCircuitSet.Size Property

PlanCircuitSetSize Property

Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
abstract Size : int with get
override Size : int with get

Property Value

Int32
See Also

Reference

PlanCircuitSet Class


PlanCircuitSet Methods

The PlanCircuitSet type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of an item within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase | Removes a specified object from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified item into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PlanCircuitSet Class


PlanCircuitSet.Clear Method

PlanCircuitSetClear Method

Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

PlanCircuitSet Class


PlanCircuitSet.Contains Method

PlanCircuitSetContains Method

Tests for the existence of an item within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Contains(
    PlanCircuit item
)
Public Overridable Function Contains (
    item As PlanCircuit
) As Boolean
public:
virtual bool Contains(
    PlanCircuit^ item
)
abstract Contains :
        item : PlanCircuit -> bool
override Contains :
        item : PlanCircuit -> bool

Parameters

item PlanCircuit
The item to be searched for.

Return Value

Boolean
The Contains method returns True if the item is within the set, otherwise False.
See Also

Reference

PlanCircuitSet Class


PlanCircuitSet.Erase Method

PlanCircuitSetErase Method

Removes a specified object from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Erase(
    PlanCircuit item
)
Public Overridable Function Erase (
    item As PlanCircuit
) As Integer
public:
virtual int Erase(
    PlanCircuit^ item
)
abstract Erase :
        item : PlanCircuit -> int
override Erase :
        item : PlanCircuit -> int

Parameters

item PlanCircuit
The item to be erased.

Return Value

Int32
The number of items that were erased from the set.
See Also

Reference

PlanCircuitSet Class


PlanCircuitSet.ForwardIterator Method

PlanCircuitSetForwardIterator Method

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual PlanCircuitSetIterator ForwardIterator()
Public Overridable Function ForwardIterator As PlanCircuitSetIterator
public:
virtual PlanCircuitSetIterator^ ForwardIterator()
abstract ForwardIterator : unit -> PlanCircuitSetIterator
override ForwardIterator : unit -> PlanCircuitSetIterator

Return Value

PlanCircuitSetIterator
Returns a forward moving iterator to the set.
See Also

Reference

PlanCircuitSet Class


PlanCircuitSet.GetEnumerator Method

PlanCircuitSetGetEnumerator Method

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

IEnumerator
Returns a forward moving iterator to the set.

Implements

IEnumerableGetEnumerator
See Also

Reference

PlanCircuitSet Class


PlanCircuitSet.Insert Method

PlanCircuitSetInsert Method

Insert the specified item into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Insert(
    PlanCircuit item
)
Public Overridable Function Insert (
    item As PlanCircuit
) As Boolean
public:
virtual bool Insert(
    PlanCircuit^ item
)
abstract Insert :
        item : PlanCircuit -> bool
override Insert :
        item : PlanCircuit -> bool

Parameters

item PlanCircuit
The item to be inserted into the set.

Return Value

Boolean
Returns whether the item was inserted into the set.
See Also

Reference

PlanCircuitSet Class


PlanCircuitSet.ReverseIterator Method

PlanCircuitSetReverseIterator Method

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual PlanCircuitSetIterator ReverseIterator()
Public Overridable Function ReverseIterator As PlanCircuitSetIterator
public:
virtual PlanCircuitSetIterator^ ReverseIterator()
abstract ReverseIterator : unit -> PlanCircuitSetIterator
override ReverseIterator : unit -> PlanCircuitSetIterator

Return Value

PlanCircuitSetIterator
Returns a backward moving iterator to the set.
See Also

Reference

PlanCircuitSet Class


PlanCircuitSetIterator Class

An iterator to a set of plan circuit objects.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBPlanCircuitSetIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class PlanCircuitSetIterator : APIObject,
    IEnumerator
Public MustInherit Class PlanCircuitSetIterator
    Inherits APIObject
    Implements IEnumerator
public ref class PlanCircuitSetIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type PlanCircuitSetIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The PlanCircuitSetIterator type exposes the following members.

Constructors
 | Name | Description
Public method | PlanCircuitSetIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PlanCircuitSetIterator Constructor

For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PlanCircuitSetIterator()
Public Sub New
public:
PlanCircuitSetIterator()
new : unit -> PlanCircuitSetIterator
Remarks
This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.
See Also

Reference

PlanCircuitSetIterator Class


PlanCircuitSetIterator Properties

The PlanCircuitSetIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

PlanCircuitSetIterator Class


PlanCircuitSetIterator.Current Property

PlanCircuitSetIteratorCurrent Property

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}
abstract Current : Object with get
override Current : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.
See Also

Reference

PlanCircuitSetIterator Class


PlanCircuitSetIterator Methods

The PlanCircuitSetIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PlanCircuitSetIterator Class


PlanCircuitSetIterator.MoveNext Method

PlanCircuitSetIteratorMoveNext Method

Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumeratorMoveNext
Remarks
MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.
See Also

Reference

PlanCircuitSetIterator Class


PlanCircuitSetIterator.Reset Method

PlanCircuitSetIteratorReset Method

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
Remarks
The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.
See Also

Reference

PlanCircuitSetIterator Class


Plane Class

A Planar surface.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSurface
Autodesk.Revit.DBPlane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Plane : Surface
Public Class Plane
    Inherits Surface
public ref class Plane : public Surface
type Plane =
    class
        inherit Surface
    end

The Plane type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Surface)
Public property | Normal | Plane normal.
Public property | OrientationMatchesParametricOrientation | Indicates whether this Surface's orientation is the same as or opposite to its parametric orientation. (Inherited from Surface)
Public property | Origin | Plane origin.
Public property | XVec | Axis defining the first parametric direction of the plane.
Public property | YVec | Axis defining the second parametric direction of the plane.
Top
Methods
 | Name | Description
 | Create | Creates a Plane object defined by a local frame of reference.
 | CreateByNormalAndOrigin | Constructs a Plane object from a normal and an origin represented as XYZ objects. Follows the standard conventions for a planar surface. The constructed Plane object will pass through origin and be perpendicular to normal. The X and Y axes of the plane will be defined arbitrarily.
 | CreateByOriginAndBasis | Creates a Plane object defined by the two orthogonal unit vectors and passing through the origin point supplied as arguments.
 | CreateByThreePoints | Creates a Plane object passing through three points supplied as arguments.
Public method | Dispose | (Inherited from Surface)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBoundingBoxUV | Gets the UV bounding box of the surface. (Inherited from Surface)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Project | Project a 3D point orthogonally onto a surface (to find the nearest point). Throws InvalidOperationException if the projection fails. (Inherited from Surface)
Public method | ProjectWithGuessPoint | Project a 3D point orthogonally onto a surface (to find the nearest point). This method is meant to be used when a good approximate solution for the projection is available. Throws InvalidOperationException if the projection fails. (Inherited from Surface)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The parametric equation of the plane is S(u, v) = origin + u*xVec + v*yVec.
Example
C#
VB
C++
F#
Copy
public void GetPlaneInfo(Plane plane)
{
    XYZ origin = plane.Origin;
    XYZ normal = plane.Normal;
    XYZ xVec = plane.XVec;
    XYZ yVec = plane.YVec;

    StringBuilder info = new StringBuilder();
    info.AppendLine("Plane Data:");
    info.AppendLine(string.Format("     Origin: ({0},{1},{2})", origin.X, origin.Y, origin.Z));
    info.AppendLine(string.Format("     Normal: ({0},{1},{2})", normal.X, normal.Y, normal.Z));
    info.AppendLine(string.Format("     XVec: ({0},{1},{2})", xVec.X, xVec.Y, xVec.Z));
    info.AppendLine(string.Format("     YVec: ({0},{1},{2})", yVec.X, yVec.Y, yVec.Z));

    TaskDialog.Show("Revit",info.ToString());
}
Public Sub GetPlaneInfo(plane As Plane)
    Dim origin As XYZ = plane.Origin
    Dim normal As XYZ = plane.Normal
    Dim xVec As XYZ = plane.XVec
    Dim yVec As XYZ = plane.YVec

    Dim info As New StringBuilder()
    info.AppendLine("Plane Data:")
    info.AppendLine(String.Format("     Origin: ({0},{1},{2})", origin.X, origin.Y, origin.Z))
    info.AppendLine(String.Format("     Normal: ({0},{1},{2})", normal.X, normal.Y, normal.Z))
    info.AppendLine(String.Format("     XVec: ({0},{1},{2})", xVec.X, xVec.Y, xVec.Z))
    info.AppendLine(String.Format("     YVec: ({0},{1},{2})", yVec.X, yVec.Y, yVec.Z))

    TaskDialog.Show("Revit", info.ToString())
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Plane Properties

The Plane type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Surface)
Public property | Normal | Plane normal.
Public property | OrientationMatchesParametricOrientation | Indicates whether this Surface's orientation is the same as or opposite to its parametric orientation. (Inherited from Surface)
Public property | Origin | Plane origin.
Public property | XVec | Axis defining the first parametric direction of the plane.
Public property | YVec | Axis defining the second parametric direction of the plane.
Top
See Also

Reference

Plane Class


Plane.Normal Property

PlaneNormal Property

Plane normal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Normal { get; }
Public ReadOnly Property Normal As XYZ
    Get
public:
property XYZ^ Normal {
    XYZ^ get ();
}
member Normal : XYZ with get

Property Value

XYZ
See Also

Reference

Plane Class


Plane.Origin Property

PlaneOrigin Property

Plane origin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Origin { get; }
Public ReadOnly Property Origin As XYZ
    Get
public:
property XYZ^ Origin {
    XYZ^ get ();
}
member Origin : XYZ with get

Property Value

XYZ
See Also

Reference

Plane Class


Plane.XVec Property

PlaneXVec Property

Axis defining the first parametric direction of the plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ XVec { get; }
Public ReadOnly Property XVec As XYZ
    Get
public:
property XYZ^ XVec {
    XYZ^ get ();
}
member XVec : XYZ with get

Property Value

XYZ
See Also

Reference

Plane Class


Plane.YVec Property

PlaneYVec Property

Axis defining the second parametric direction of the plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ YVec { get; }
Public ReadOnly Property YVec As XYZ
    Get
public:
property XYZ^ YVec {
    XYZ^ get ();
}
member YVec : XYZ with get

Property Value

XYZ
See Also

Reference

Plane Class


Plane Methods

The Plane type exposes the following members.

Methods
 | Name | Description
 | Create | Creates a Plane object defined by a local frame of reference.
 | CreateByNormalAndOrigin | Constructs a Plane object from a normal and an origin represented as XYZ objects. Follows the standard conventions for a planar surface. The constructed Plane object will pass through origin and be perpendicular to normal. The X and Y axes of the plane will be defined arbitrarily.
 | CreateByOriginAndBasis | Creates a Plane object defined by the two orthogonal unit vectors and passing through the origin point supplied as arguments.
 | CreateByThreePoints | Creates a Plane object passing through three points supplied as arguments.
Public method | Dispose | (Inherited from Surface)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBoundingBoxUV | Gets the UV bounding box of the surface. (Inherited from Surface)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Project | Project a 3D point orthogonally onto a surface (to find the nearest point). Throws InvalidOperationException if the projection fails. (Inherited from Surface)
Public method | ProjectWithGuessPoint | Project a 3D point orthogonally onto a surface (to find the nearest point). This method is meant to be used when a good approximate solution for the projection is available. Throws InvalidOperationException if the projection fails. (Inherited from Surface)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Plane Class


Plane.Create Method

PlaneCreate Method

Creates a Plane object defined by a local frame of reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Plane Create(
    Frame frameOfReference
)
Public Shared Function Create (
    frameOfReference As Frame
) As Plane
public:
static Plane^ Create(
    Frame^ frameOfReference
)
static member Create :
        frameOfReference : Frame -> Plane

Parameters

frameOfReference Frame
frameOfReference is an orthonormal frame that defines a local coordinate system for the plane being constructed.
  • Frame.Origin is a point on plane.
  • Frame.BasisZ defines the plane's normal, while Frame.BasisX and Frame.BasisY are orthogonal to the normal.
  • The frame may be either left-handed or right-handed (see Frame.IsRightHanded).

Return Value

Plane
Exceptions
Exception | Condition
ArgumentException | This Frame object may not be used as a local frame of reference.
ArgumentNullException | A non-optional argument was null
Remarks
The parametric equation of the plane is S(u, v) = Frame.Origin + u*Frame.BasisX + v*Frame.BasisY. Frame.BasisZ defines the plane's normal.
See Also

Reference

Plane Class


Plane.CreateByNormalAndOrigin Method

PlaneCreateByNormalAndOrigin Method

Constructs a Plane object from a normal and an origin represented as XYZ objects. Follows the standard conventions for a planar surface. The constructed Plane object will pass through origin and be perpendicular to normal. The X and Y axes of the plane will be defined arbitrarily.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Plane CreateByNormalAndOrigin(
    XYZ normal,
    XYZ origin
)
Public Shared Function CreateByNormalAndOrigin (
    normal As XYZ,
    origin As XYZ
) As Plane
public:
static Plane^ CreateByNormalAndOrigin(
    XYZ^ normal,
    XYZ^ origin
)
static member CreateByNormalAndOrigin :
        normal : XYZ *
        origin : XYZ -> Plane

Parameters

normal XYZ
Plane normal. Expected to be a valid non-zero length vector. Doesn't need to be a unit vector.
origin XYZ
Plane origin. Expected to lie within the Revit design limits IsWithinLengthLimits(XYZ).

Return Value

Plane
Exceptions
Exception | Condition
ArgumentException | The input point lies outside of Revit design limits.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | normal has zero length.
Remarks
This function does not guarantee a specific parameterization of the created Plane. Use Plane.Create(Frame) to enforce a specific parameterization of the created Plane object.
Example
C#
VB
C++
F#
Copy
 // Create a geometry plane in Revit application
XYZ normal = XYZ.BasisZ;    // use basis of the z-axis (0,0,1) for normal vector
XYZ origin = XYZ.Zero;  // origin is (0,0,0)
Plane geomPlane = Plane.CreateByNormalAndOrigin(normal, origin);
   ' Create a geometry plane in Revit application
   Dim normal As XYZ = XYZ.BasisZ
   ' use basis of the z-axis (0,0,1) for normal vector
   Dim origin As XYZ = XYZ.Zero
   ' origin is (0,0,0)
Dim geomPlane As Plane = Plane.CreateByNormalAndOrigin(normal, origin)

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Plane Class


Plane.CreateByOriginAndBasis Method

PlaneCreateByOriginAndBasis Method

Creates a Plane object defined by the two orthogonal unit vectors and passing through the origin point supplied as arguments.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Plane CreateByOriginAndBasis(
    XYZ origin,
    XYZ basisX,
    XYZ basisY
)
Public Shared Function CreateByOriginAndBasis (
    origin As XYZ,
    basisX As XYZ,
    basisY As XYZ
) As Plane
public:
static Plane^ CreateByOriginAndBasis(
    XYZ^ origin,
    XYZ^ basisX,
    XYZ^ basisY
)
static member CreateByOriginAndBasis :
        origin : XYZ *
        basisX : XYZ *
        basisY : XYZ -> Plane

Parameters

origin XYZ
Plane origin. Expected to lie within the Revit design limits IsWithinLengthLimits(XYZ).
basisX XYZ
First of the two unit vectors that define the plane. Must be orthogonal to the second one.
basisY XYZ
Second of the two unit vectors that define the plane. Must be orthogonal to the first one.

Return Value

Plane
Exceptions
Exception | Condition
ArgumentException | The input point lies outside of Revit design limits.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | basisX is not length 1.0. -or- basisY is not length 1.0.
ArgumentsInconsistentException | The vectors basisX and basisY are not perpendicular.
Remarks
The parametric equation of the plane is S(u, v) = origin + u*basisX + v*basisY. The plane's normal is defined as basisX.Cross(basisY).
See Also

Reference

Plane Class


Plane.CreateByThreePoints Method

PlaneCreateByThreePoints Method

Creates a Plane object passing through three points supplied as arguments.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Plane CreateByThreePoints(
    XYZ point1,
    XYZ point2,
    XYZ point3
)
Public Shared Function CreateByThreePoints (
    point1 As XYZ,
    point2 As XYZ,
    point3 As XYZ
) As Plane
public:
static Plane^ CreateByThreePoints(
    XYZ^ point1,
    XYZ^ point2,
    XYZ^ point3
)
static member CreateByThreePoints :
        point1 : XYZ *
        point2 : XYZ *
        point3 : XYZ -> Plane

Parameters

point1 XYZ
First of the three points that define a unique plane. The created Plane object will pass through these points.
point2 XYZ
Second of the three points that define a unique plane.
point3 XYZ
Third of the three points that define a unique plane.

Return Value

Plane
Exceptions
Exception | Condition
ArgumentException | The input point lies outside of Revit design limits.
ArgumentNullException | A non-optional argument was null
ArgumentsInconsistentException | Throws if the input points do not define a unique plane. This is typically caused by points being too close to each other, or all three points being on or close to a straight line.
Remarks
The points supplied as arguments must fully define a plane: they may not lie on a straight line or be too close to each other. The points must lie within the Revit design limits. This function does not guarantee a specific parameterization of the created Plane. Use Plane.Create(Frame) to enforce a specific parameterization of the created Plane object. All three points are expected to lie within the Revit design limits IsWithinLengthLimits(XYZ).
See Also

Reference

Plane Class


PlanTopology Class

An object that represents a Plan Topology within the Autodesk Revit project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBPlanTopology

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PlanTopology : APIObject
Public Class PlanTopology
    Inherits APIObject
public ref class PlanTopology : public APIObject
type PlanTopology =
    class
        inherit APIObject
    end

The PlanTopology type exposes the following members.

Properties
 | Name | Description
Public property | Circuits | The Circuits of the PlanTopology.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Level | The Level of the PlanTopology.
Public property | Phase | The phase of the PlanTopology.
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRoomIds | Retrieves room ElementIds of the PlanTopology in the last phase.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This object derived from the APIObject base object. It can be used access the properties of a Plan Topology.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PlanTopology Properties

The PlanTopology type exposes the following members.

Properties
 | Name | Description
Public property | Circuits | The Circuits of the PlanTopology.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Level | The Level of the PlanTopology.
Public property | Phase | The phase of the PlanTopology.
Top
See Also

Reference

PlanTopology Class


PlanTopology.Circuits Property

PlanTopologyCircuits Property

The Circuits of the PlanTopology.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PlanCircuitSet Circuits { get; }
Public ReadOnly Property Circuits As PlanCircuitSet
    Get
public:
property PlanCircuitSet^ Circuits {
    PlanCircuitSet^ get ();
}
member Circuits : PlanCircuitSet with get

Property Value

PlanCircuitSet
See Also

Reference

PlanTopology Class


PlanTopology.Level Property

PlanTopologyLevel Property

The Level of the PlanTopology.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Level Level { get; }
Public ReadOnly Property Level As Level
    Get
public:
property Level^ Level {
    Level^ get ();
}
member Level : Level with get

Property Value

Level
See Also

Reference

PlanTopology Class


PlanTopology.Phase Property

PlanTopologyPhase Property

The phase of the PlanTopology.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Phase Phase { get; }
Public ReadOnly Property Phase As Phase
    Get
public:
property Phase^ Phase {
    Phase^ get ();
}
member Phase : Phase with get

Property Value

Phase
See Also

Reference

PlanTopology Class


PlanTopology Methods

The PlanTopology type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRoomIds | Retrieves room ElementIds of the PlanTopology in the last phase.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PlanTopology Class


PlanTopology.GetRoomIds Method

PlanTopologyGetRoomIds Method

Retrieves room ElementIds of the PlanTopology in the last phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetRoomIds()
Public Function GetRoomIds As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetRoomIds()
member GetRoomIds : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
The PlanTopology Room ElementIds of the last phase.
Remarks
The Rooms Ids returned are in the phase of PlanTopology and the current design option.
See Also

Reference

PlanTopology Class


PlanTopologySet Class

A set that can contain any number of plan topology objects.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBPlanTopologySet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PlanTopologySet : APIObject,
    IEnumerable
Public Class PlanTopologySet
    Inherits APIObject
    Implements IEnumerable
public ref class PlanTopologySet : public APIObject,
    IEnumerable
type PlanTopologySet =
    class
        inherit APIObject
        interface IEnumerable
    end

The PlanTopologySet type exposes the following members.

Constructors
 | Name | Description
Public method | PlanTopologySet | Initializes a new instance of the PlanTopologySet class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Size | Returns the number of objects that are in the set.
Top
Methods
 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of an item within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase | Removes a specified object from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified item into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PlanTopologySet Constructor

Initializes a new instance of the PlanTopologySet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PlanTopologySet()
Public Sub New
public:
PlanTopologySet()
new : unit -> PlanTopologySet
See Also

Reference

PlanTopologySet Class


PlanTopologySet Properties

The PlanTopologySet type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Size | Returns the number of objects that are in the set.
Top
See Also

Reference

PlanTopologySet Class


PlanTopologySet.IsEmpty Property

PlanTopologySetIsEmpty Property

Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Boolean
Remarks
If the set is empty then True will be returned, otherwise False.
See Also

Reference

PlanTopologySet Class


PlanTopologySet.Size Property

PlanTopologySetSize Property

Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
abstract Size : int with get
override Size : int with get

Property Value

Int32
See Also

Reference

PlanTopologySet Class


PlanTopologySet Methods

The PlanTopologySet type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of an item within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase | Removes a specified object from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified item into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PlanTopologySet Class


PlanTopologySet.Clear Method

PlanTopologySetClear Method

Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

PlanTopologySet Class


PlanTopologySet.Contains Method

PlanTopologySetContains Method

Tests for the existence of an item within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Contains(
    PlanTopology item
)
Public Overridable Function Contains (
    item As PlanTopology
) As Boolean
public:
virtual bool Contains(
    PlanTopology^ item
)
abstract Contains :
        item : PlanTopology -> bool
override Contains :
        item : PlanTopology -> bool

Parameters

item PlanTopology
The item to be searched for.

Return Value

Boolean
The Contains method returns True if the item is within the set, otherwise False.
See Also

Reference

PlanTopologySet Class


PlanTopologySet.Erase Method

PlanTopologySetErase Method

Removes a specified object from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Erase(
    PlanTopology item
)
Public Overridable Function Erase (
    item As PlanTopology
) As Integer
public:
virtual int Erase(
    PlanTopology^ item
)
abstract Erase :
        item : PlanTopology -> int
override Erase :
        item : PlanTopology -> int

Parameters

item PlanTopology
The item to be erased.

Return Value

Int32
The number of items that were erased from the set.
See Also

Reference

PlanTopologySet Class


PlanTopologySet.ForwardIterator Method

PlanTopologySetForwardIterator Method

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual PlanTopologySetIterator ForwardIterator()
Public Overridable Function ForwardIterator As PlanTopologySetIterator
public:
virtual PlanTopologySetIterator^ ForwardIterator()
abstract ForwardIterator : unit -> PlanTopologySetIterator
override ForwardIterator : unit -> PlanTopologySetIterator

Return Value

PlanTopologySetIterator
Returns a forward moving iterator to the set.
See Also

Reference

PlanTopologySet Class


PlanTopologySet.GetEnumerator Method

PlanTopologySetGetEnumerator Method

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

IEnumerator
Returns a forward moving iterator to the set.

Implements

IEnumerableGetEnumerator
See Also

Reference

PlanTopologySet Class


PlanTopologySet.Insert Method

PlanTopologySetInsert Method

Insert the specified item into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Insert(
    PlanTopology item
)
Public Overridable Function Insert (
    item As PlanTopology
) As Boolean
public:
virtual bool Insert(
    PlanTopology^ item
)
abstract Insert :
        item : PlanTopology -> bool
override Insert :
        item : PlanTopology -> bool

Parameters

item PlanTopology
The item to be inserted into the set.

Return Value

Boolean
Returns whether the item was inserted into the set.
See Also

Reference

PlanTopologySet Class


PlanTopologySet.ReverseIterator Method

PlanTopologySetReverseIterator Method

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual PlanTopologySetIterator ReverseIterator()
Public Overridable Function ReverseIterator As PlanTopologySetIterator
public:
virtual PlanTopologySetIterator^ ReverseIterator()
abstract ReverseIterator : unit -> PlanTopologySetIterator
override ReverseIterator : unit -> PlanTopologySetIterator

Return Value

PlanTopologySetIterator
Returns a backward moving iterator to the set.
See Also

Reference

PlanTopologySet Class


PlanTopologySetIterator Class

An iterator to a set of plan topology objects.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBPlanTopologySetIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class PlanTopologySetIterator : APIObject,
    IEnumerator
Public MustInherit Class PlanTopologySetIterator
    Inherits APIObject
    Implements IEnumerator
public ref class PlanTopologySetIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type PlanTopologySetIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The PlanTopologySetIterator type exposes the following members.

Constructors
 | Name | Description
Public method | PlanTopologySetIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PlanTopologySetIterator Constructor

For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PlanTopologySetIterator()
Public Sub New
public:
PlanTopologySetIterator()
new : unit -> PlanTopologySetIterator
Remarks
This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.
See Also

Reference

PlanTopologySetIterator Class


PlanTopologySetIterator Properties

The PlanTopologySetIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

PlanTopologySetIterator Class


PlanTopologySetIterator.Current Property

PlanTopologySetIteratorCurrent Property

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}
abstract Current : Object with get
override Current : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.
See Also

Reference

PlanTopologySetIterator Class


PlanTopologySetIterator Methods

The PlanTopologySetIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PlanTopologySetIterator Class


PlanTopologySetIterator.MoveNext Method

PlanTopologySetIteratorMoveNext Method

Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumeratorMoveNext
Remarks
MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.
See Also

Reference

PlanTopologySetIterator Class


PlanTopologySetIterator.Reset Method

PlanTopologySetIteratorReset Method

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
Remarks
The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.
See Also

Reference

PlanTopologySetIterator Class


PlanViewDirection Enumeration

This enumerated type represents the possible directions for a plan view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum PlanViewDirection
Public Enumeration PlanViewDirection
public enum class PlanViewDirection
type PlanViewDirection
Members
Member name | Value | Description
Down | 0 | Revit looks down onto the plan view
Up | 1 | Revit looks up to the plan view
Undefined | -1 | View does not use Plan View Direction
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PlanViewPlane Enumeration

Locations where view range offsets can be specified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum PlanViewPlane
Public Enumeration PlanViewPlane
public enum class PlanViewPlane
type PlanViewPlane
Members
Member name | Value | Description
CutPlane | 0 | Cut Plane
TopClipPlane | 1 | Top Clip Plane
BottomClipPlane | 2 | Bottom Clip Plane
ViewDepthPlane | 3 | View Depth Plane
UnderlayBottom | 4 | Underlay Bottom Plane
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PlanViewRange Class

This class represents the view range of a plan view or a plan region. It records the element ids of the levels which a plane is relative to and the offset of each plane from that level.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBPlanViewRange

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PlanViewRange : IDisposable
Public Class PlanViewRange
    Implements IDisposable
public ref class PlanViewRange : IDisposable
type PlanViewRange =
    class
        interface IDisposable
    end

The PlanViewRange type exposes the following members.

Properties
 | Name | Description
 | Current | View range for the current plane
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
 | LevelAbove | View range for the level above the specified plane
 | LevelBelow | View range for the level below the specified plane
 | Unlimited | View range is unlimited
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the PlanViewRange
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLevelId | Get the element id of the level for a View Depth plane
Public method | GetOffset | Get the offset value associated with a View Depth plane
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetLevelId | Set the level for a View Depth plane
Public method | SetOffset | Set the offset value associated with a View Depth plane
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Example
C#
VB
C++
F#
Copy
private ElementId GetViewRangeTopClipPlane(Document doc, View view)
{
    ElementId topClipPlane = ElementId.InvalidElementId;

    if (view is ViewPlan)
    {
        ViewPlan viewPlan = view as ViewPlan;
        PlanViewRange viewRange = viewPlan.GetViewRange();

        topClipPlane = viewRange.GetLevelId(PlanViewPlane.TopClipPlane);
        double dOffset = viewRange.GetOffset(PlanViewPlane.TopClipPlane);

        if (topClipPlane != ElementId.InvalidElementId)
        {
            Element levelAbove = doc.GetElement(topClipPlane);
            TaskDialog.Show(view.Name, "Top Clip Plane: " + levelAbove.Name + "\r\nTop Offset: " + dOffset + " ft");
        }
    }

    return topClipPlane;
}
Private Function GetViewRangeTopClipPlane(doc As Document, view As View) As ElementId
    Dim topClipPlane As ElementId = ElementId.InvalidElementId

    If TypeOf view Is ViewPlan Then
        Dim viewPlan As ViewPlan = TryCast(view, ViewPlan)
        Dim viewRange As PlanViewRange = viewPlan.GetViewRange()

        topClipPlane = viewRange.GetLevelId(PlanViewPlane.TopClipPlane)
        Dim dOffset As Double = viewRange.GetOffset(PlanViewPlane.TopClipPlane)

        If topClipPlane.Value > 0 Then
            Dim levelAbove As Element = doc.GetElement(topClipPlane)
            TaskDialog.Show(view.Name, "Top Clip Plane: " + levelAbove.Name + vbCr & vbLf & "Top Offset: " + dOffset + " ft")
        End If
    End If

    Return topClipPlane
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PlanViewRange Properties

The PlanViewRange type exposes the following members.

Properties
 | Name | Description
 | Current | View range for the current plane
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
 | LevelAbove | View range for the level above the specified plane
 | LevelBelow | View range for the level below the specified plane
 | Unlimited | View range is unlimited
Top
See Also

Reference

PlanViewRange Class


PlanViewRange.Current Property

PlanViewRangeCurrent Property

View range for the current plane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ElementId Current { get; }
Public Shared ReadOnly Property Current As ElementId
    Get
public:
static property ElementId^ Current {
    ElementId^ get ();
}
static member Current : ElementId with get

Property Value

ElementId
See Also

Reference

PlanViewRange Class


PlanViewRange.IsValidObject Property

PlanViewRangeIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

PlanViewRange Class


PlanViewRange.LevelAbove Property

PlanViewRangeLevelAbove Property

View range for the level above the specified plane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ElementId LevelAbove { get; }
Public Shared ReadOnly Property LevelAbove As ElementId
    Get
public:
static property ElementId^ LevelAbove {
    ElementId^ get ();
}
static member LevelAbove : ElementId with get

Property Value

ElementId
See Also

Reference

PlanViewRange Class


PlanViewRange.LevelBelow Property

PlanViewRangeLevelBelow Property

View range for the level below the specified plane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ElementId LevelBelow { get; }
Public Shared ReadOnly Property LevelBelow As ElementId
    Get
public:
static property ElementId^ LevelBelow {
    ElementId^ get ();
}
static member LevelBelow : ElementId with get

Property Value

ElementId
See Also

Reference

PlanViewRange Class


PlanViewRange.Unlimited Property

PlanViewRangeUnlimited Property

View range is unlimited

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ElementId Unlimited { get; }
Public Shared ReadOnly Property Unlimited As ElementId
    Get
public:
static property ElementId^ Unlimited {
    ElementId^ get ();
}
static member Unlimited : ElementId with get

Property Value

ElementId
See Also

Reference

PlanViewRange Class


PlanViewRange Methods

The PlanViewRange type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLevelId | Get the element id of the level for a View Depth plane
Public method | GetOffset | Get the offset value associated with a View Depth plane
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetLevelId | Set the level for a View Depth plane
Public method | SetOffset | Set the offset value associated with a View Depth plane
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PlanViewRange Class


PlanViewRange.Dispose Method

PlanViewRangeDispose Method

Releases all resources used by the PlanViewRange

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

PlanViewRange Class


PlanViewRange.GetLevelId Method

PlanViewRangeGetLevelId Method

Get the element id of the level for a View Depth plane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GetLevelId(
    PlanViewPlane planViewPlane
)
Public Function GetLevelId (
    planViewPlane As PlanViewPlane
) As ElementId
public:
ElementId^ GetLevelId(
    PlanViewPlane planViewPlane
)
member GetLevelId :
        planViewPlane : PlanViewPlane -> ElementId

Parameters

planViewPlane PlanViewPlane
The plane whose level will be returned

Return Value

ElementId
Id of the level
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

PlanViewRange Class


PlanViewRange.GetOffset Method

PlanViewRangeGetOffset Method

Get the offset value associated with a View Depth plane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetOffset(
    PlanViewPlane planViewPlane
)
Public Function GetOffset (
    planViewPlane As PlanViewPlane
) As Double
public:
double GetOffset(
    PlanViewPlane planViewPlane
)
member GetOffset :
        planViewPlane : PlanViewPlane -> float

Parameters

planViewPlane PlanViewPlane
View Depth plane

Return Value

Double
Offset value
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

PlanViewRange Class


PlanViewRange.SetLevelId Method

PlanViewRangeSetLevelId Method

Set the level for a View Depth plane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetLevelId(
    PlanViewPlane planViewPlane,
    ElementId id
)
Public Sub SetLevelId (
    planViewPlane As PlanViewPlane,
    id As ElementId
)
public:
void SetLevelId(
    PlanViewPlane planViewPlane,
    ElementId^ id
)
member SetLevelId :
        planViewPlane : PlanViewPlane *
        id : ElementId -> unit

Parameters

planViewPlane PlanViewPlane
The View Depth plane
id ElementId
Id of the level
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

PlanViewRange Class


PlanViewRange.SetOffset Method

PlanViewRangeSetOffset Method

Set the offset value associated with a View Depth plane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetOffset(
    PlanViewPlane planViewPlane,
    double offset
)
Public Sub SetOffset (
    planViewPlane As PlanViewPlane,
    offset As Double
)
public:
void SetOffset(
    PlanViewPlane planViewPlane,
    double offset
)
member SetOffset :
        planViewPlane : PlanViewPlane *
        offset : float -> unit

Parameters

planViewPlane PlanViewPlane
View Depth plane
offset Double
Offset value
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

PlanViewRange Class


PlanViewRangeError Enumeration

Describes errors in the location of planes in a PlanViewRange object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum PlanViewRangeError
Public Enumeration PlanViewRangeError
public enum class PlanViewRangeError
type PlanViewRangeError
Members
Member name | Value | Description
TopClipBelowCutPlane | 0 | Top clip plane is below the cut plane.
BottomClipAboveCutPlane | 1 | Bottom clip plane is above the cut plane.
ViewDepthAboveBottomClip | 2 | View depth is above the bottom clip plane.
ViewDepthBelowTopClip | 3 | View depth is below the top clip plane.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PlanViewRangeLevel Enumeration

An enumerated type representing the options for setting the range for a plan view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum PlanViewRangeLevel
Public Enumeration PlanViewRangeLevel
public enum class PlanViewRangeLevel
type PlanViewRangeLevel
Members
Member name | Value | Description
Unlimited | -1 | View range is unlimited
Above | -2 | View range is the level above
Current | -3 | View range is the current level
Below | -4 | View range is the level below
Unused | -5 |
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Point Class

A 3D point.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGeometryObject
Autodesk.Revit.DBPoint

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Point : GeometryObject
Public Class Point
    Inherits GeometryObject
public ref class Point : public GeometryObject
type Point =
    class
        inherit GeometryObject
    end

The Point type exposes the following members.

Properties
 | Name | Description
Public property | Coord | Returns the coordinates of the point.
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject)
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Reference | Returns a stable reference to the point.
Public property | Visibility | The visibility. (Inherited from GeometryObject)
Top
Methods
 | Name | Description
 | Create(XYZ) | Creates a point at the given coordinates.
 | Create(XYZ, ElementId) | Creates a point at the given coordinates and assigns it the specified GraphicsStyle.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The point lies at a given XYZ coordinate location.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Point Properties

The Point type exposes the following members.

Properties
 | Name | Description
Public property | Coord | Returns the coordinates of the point.
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject)
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Reference | Returns a stable reference to the point.
Public property | Visibility | The visibility. (Inherited from GeometryObject)
Top
See Also

Reference

Point Class


Point.Coord Property

PointCoord Property

Returns the coordinates of the point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Coord { get; }
Public ReadOnly Property Coord As XYZ
    Get
public:
property XYZ^ Coord {
    XYZ^ get ();
}
member Coord : XYZ with get

Property Value

XYZ
See Also

Reference

Point Class


Point.Reference Property

PointReference Property

Returns a stable reference to the point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Reference Reference { get; }
Public ReadOnly Property Reference As Reference
    Get
public:
property Reference^ Reference {
    Reference^ get ();
}
member Reference : Reference with get

Property Value

Reference
Remarks
This value is if the corresponding geometry object does not permit referencing.
See Also

Reference

Point Class


Point Methods

The Point type exposes the following members.

Methods
 | Name | Description
 | Create(XYZ) | Creates a point at the given coordinates.
 | Create(XYZ, ElementId) | Creates a point at the given coordinates and assigns it the specified GraphicsStyle.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Point Class


Point.Create Method

PointCreate Method

Overload List
Name | Description
Create(XYZ) | Creates a point at the given coordinates.
Create(XYZ, ElementId) | Creates a point at the given coordinates and assigns it the specified GraphicsStyle.
Top
See Also

Reference

Point Class


Point.Create(XYZ) Method

PointCreate(XYZ) Method

Creates a point at the given coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Point Create(
    XYZ coord
)
Public Shared Function Create (
    coord As XYZ
) As Point
public:
static Point^ Create(
    XYZ^ coord
)
static member Create :
        coord : XYZ -> Point

Parameters

coord XYZ
The coordinates where the point will be created.

Return Value

Point
A Point object.
See Also

Reference

Point Class
Create Overload


Point.Create(XYZ, ElementId) Method

PointCreate(XYZ, ElementId) Method

Creates a point at the given coordinates and assigns it the specified GraphicsStyle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Point Create(
    XYZ coord,
    ElementId id
)
Public Shared Function Create (
    coord As XYZ,
    id As ElementId
) As Point
public:
static Point^ Create(
    XYZ^ coord,
    ElementId^ id
)
static member Create :
        coord : XYZ *
        id : ElementId -> Point

Parameters

coord XYZ
The coordinates where the point will be created.
id ElementId
The id of the GraphicsStyle element from which to apply the point properties.

Return Value

Point
A Point object.
See Also

Reference

Point Class
Create Overload


PointCloudColorMode Enumeration

Color mode of a point cloud or part of a point cloud

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum PointCloudColorMode
Public Enumeration PointCloudColorMode
public enum class PointCloudColorMode
type PointCloudColorMode
Members
Member name | Value | Description
NoOverride | 0 | Show the actual colors
FixedColor | 1 | Show a single color
Elevation | 2 | Color by elevation
Intensity | 3 | Color by intensity (reflectivity)
Normals | 4 | Color by normal vectors
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PointCloudFoundStatus Enumeration

Enumerated type representing the possible states related to searching for a point cloud file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum PointCloudFoundStatus
Public Enumeration PointCloudFoundStatus
public enum class PointCloudFoundStatus
type PointCloudFoundStatus
Members
Member name | Value | Description
Unknown | 0 | Initial state. Loading of the Point Cloud hasn't been attempted.
NotFound | 1 | File-based Point Cloud cannot be located and hence can't be loaded.
FoundOK | 2 | File-based Point Cloud has been located and can be loaded.
Invalid | 3 | File-based Point Cloud is not valid and hence can't be loaded.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PointCloudInstance Class

Represents a single instance of a point cloud in the Revit document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBInstance
Autodesk.Revit.DBPointCloudInstance

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PointCloudInstance : Instance
Public Class PointCloudInstance
    Inherits Instance
public ref class PointCloudInstance : public Instance
type PointCloudInstance =
    class
        inherit Instance
    end

The PointCloudInstance type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FilterAction | The action taken based on the results of the selection filter applied to this point cloud.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SupportsOverrides | Identifies whether the instance can have graphic overrides.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | ContainsScan | Identifies whether the instance contains a scan.
 | Create | Creates a new instance of a point cloud based on an input point cloud type and transformation.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
 | GetPoints | Extracts a collection of points based on a filter.
Public method | GetRegions | Returns array of region names.
Public method | GetScanOrigin | Returns the origin point of a scan in model coordinates.
Public method | GetScans | Returns array of scan names.
Public method | GetSelectionFilter | Returns the currently active selection filter for this point cloud.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances. (Inherited from Instance)
Public method | GetTransform | Gets the transform of the instance. (Inherited from Instance)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasColor | Returns true if at least one scan of the element have color, false otherwise.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetSelectionFilter | Sets active selection filter by cloning of the one passed to it.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PointCloudInstance Properties

The PointCloudInstance type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FilterAction | The action taken based on the results of the selection filter applied to this point cloud.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SupportsOverrides | Identifies whether the instance can have graphic overrides.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

PointCloudInstance Class


PointCloudInstance.FilterAction Property

PointCloudInstanceFilterAction Property

The action taken based on the results of the selection filter applied to this point cloud.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SelectionFilterAction FilterAction { get; set; }
Public Property FilterAction As SelectionFilterAction
    Get
    Set
public:
property SelectionFilterAction FilterAction {
    SelectionFilterAction get ();
    void set (SelectionFilterAction value);
}
member FilterAction : SelectionFilterAction with get, set

Property Value

SelectionFilterAction
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
If no selection filter is applied, changing this value will have no visible effect. The filter is provided in the coordinates of the Revit model. If the point cloud is altered (e.g. by moving, rotating, scaling or other modifications) the point cloud filter is not modified and the set of highlighted or isolated points will change. The filter action is not preserved when the Revit document is saved.
See Also

Reference

PointCloudInstance Class


PointCloudInstance.SupportsOverrides Property

PointCloudInstanceSupportsOverrides Property

Identifies whether the instance can have graphic overrides.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SupportsOverrides { get; }
Public ReadOnly Property SupportsOverrides As Boolean
    Get
public:
property bool SupportsOverrides {
    bool get ();
}
member SupportsOverrides : bool with get

Property Value

Boolean
See Also

Reference

PointCloudInstance Class


PointCloudInstance Methods

The PointCloudInstance type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | ContainsScan | Identifies whether the instance contains a scan.
 | Create | Creates a new instance of a point cloud based on an input point cloud type and transformation.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
 | GetPoints | Extracts a collection of points based on a filter.
Public method | GetRegions | Returns array of region names.
Public method | GetScanOrigin | Returns the origin point of a scan in model coordinates.
Public method | GetScans | Returns array of scan names.
Public method | GetSelectionFilter | Returns the currently active selection filter for this point cloud.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances. (Inherited from Instance)
Public method | GetTransform | Gets the transform of the instance. (Inherited from Instance)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasColor | Returns true if at least one scan of the element have color, false otherwise.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetSelectionFilter | Sets active selection filter by cloning of the one passed to it.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PointCloudInstance Class


PointCloudInstance.ContainsScan Method

PointCloudInstanceContainsScan Method

Identifies whether the instance contains a scan.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ContainsScan(
    string scanName
)
Public Function ContainsScan (
    scanName As String
) As Boolean
public:
bool ContainsScan(
    String^ scanName
)
member ContainsScan :
        scanName : string -> bool

Parameters

scanName String
Name of the scan.

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

PointCloudInstance Class


PointCloudInstance.Create Method

PointCloudInstanceCreate Method

Creates a new instance of a point cloud based on an input point cloud type and transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static PointCloudInstance Create(
    Document document,
    ElementId typeId,
    Transform transform
)
Public Shared Function Create (
    document As Document,
    typeId As ElementId,
    transform As Transform
) As PointCloudInstance
public:
static PointCloudInstance^ Create(
    Document^ document,
    ElementId^ typeId,
    Transform^ transform
)
static member Create :
        document : Document *
        typeId : ElementId *
        transform : Transform -> PointCloudInstance

Parameters

document Document
The document in which the new instance is created
typeId ElementId
The element id of the PointCloudType.
transform Transform
The transform that defines the placement of the instance in the Revit document coordinate system.

Return Value

PointCloudInstance
The newly created point cloud instance.
Exceptions
Exception | Condition
ArgumentException | The ElementId typeId is not a valid PointCloudType. -or- document is not a project document.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
See Also

Reference

PointCloudInstance Class


PointCloudInstance.GetPoints Method

PointCloudInstanceGetPoints Method

Extracts a collection of points based on a filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PointCollection GetPoints(
    PointCloudFilter filter,
    double averageDistance,
    int numPoints
)
Public Function GetPoints (
    filter As PointCloudFilter,
    averageDistance As Double,
    numPoints As Integer
) As PointCollection
public:
PointCollection^ GetPoints(
    PointCloudFilter^ filter,
    double averageDistance,
    int numPoints
)
member GetPoints :
        filter : PointCloudFilter *
        averageDistance : float *
        numPoints : int -> PointCollection

Parameters

filter PointCloudFilter
The filter to control which points are extracted. The filter should be passed in the coordinates of the Revit model.
averageDistance Double
Desired average distance between "adjacent" cloud points (Revit units of length). The smaller the averageDistance the larger number of points will be returned up to the numPoints limit. Specifying this parameter makes actual number of points returned for a given filter independent of the density of coverage produced by the scanner.
numPoints Int32
The maximum number of points requested.

Return Value

PointCollection
A collection object containing points that pass the filter, but no more than the maximum number requested.
Exceptions
Exception | Condition
ArgumentException | The number of points read must range from 1 to 1000000.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | The given value for averageDistance must be no more than 30000 feet in absolute value.
Remarks
If there are more points in the cloud passing the filter than the number requested in this function, the results may not be consistent if the same call is made again.
Example
C#
Copy
private void GetPointCloudDataByIteration(PointCloudInstance pcInstance, PointCloudFilter pointCloudFilter)
{
    // read points by iteration
    double averageDistance = 0.001;
    int numberOfPoints= 10000;
    // Get points. Number of points is determined by the needs of the client.
    PointCollection points = pcInstance.GetPoints(pointCloudFilter, averageDistance, numberOfPoints);
    foreach (CloudPoint point in points)
    {
        // Process each point
        System.Drawing.Color color = System.Drawing.ColorTranslator.FromWin32(point.Color);
        String pointDescription = String.Format("({0}, {1}, {2}, {3}", point.X, point.Y, point.Z, color.ToString());
    }
}
// read points by pointer
public unsafe void GetPointCloudDataByPointer(PointCloudInstance pcInstance, PointCloudFilter pointCloudFilter)
{
    double averageDistance = 0.001;
    int numOfPoints = 10000;
    // Get points. Number of points is determined by the needs of the client.
    PointCollection points = pcInstance.GetPoints(pointCloudFilter, averageDistance, numOfPoints);
    CloudPoint* pointBuffer = (CloudPoint*)points.GetPointBufferPointer().ToPointer();
    int totalCount = points.Count;
    for (int numberOfPoints = 0; numberOfPoints < totalCount; numberOfPoints++)
    {
        CloudPoint point = *(pointBuffer + numberOfPoints);
        // Process each point
        System.Drawing.Color color = System.Drawing.ColorTranslator.FromWin32(point.Color);
        String pointDescription = String.Format("({0}, {1}, {2}, {3}", point.X, point.Y, point.Z, color.ToString());
    }
}
See Also

Reference

PointCloudInstance Class


PointCloudInstance.GetRegions Method

PointCloudInstanceGetRegions Method

Returns array of region names.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<string> GetRegions()
Public Function GetRegions As IList(Of String)
public:
IList<String^>^ GetRegions()
member GetRegions : unit -> IList<string>

Return Value

IList String
Resulting array of region names.
See Also

Reference

PointCloudInstance Class


PointCloudInstance.GetScanOrigin Method

PointCloudInstanceGetScanOrigin Method

Returns the origin point of a scan in model coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ GetScanOrigin(
    string scanName
)
Public Function GetScanOrigin (
    scanName As String
) As XYZ
public:
XYZ^ GetScanOrigin(
    String^ scanName
)
member GetScanOrigin :
        scanName : string -> XYZ

Parameters

scanName String
Name of the scan.

Return Value

XYZ
Resulting origin point of the scan.
Exceptions
Exception | Condition
ArgumentException | PointCloudInstance does not contain scan scanName.
ArgumentNullException | A non-optional argument was null
See Also

Reference

PointCloudInstance Class


PointCloudInstance.GetScans Method

PointCloudInstanceGetScans Method

Returns array of scan names.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<string> GetScans()
Public Function GetScans As IList(Of String)
public:
IList<String^>^ GetScans()
member GetScans : unit -> IList<string>

Return Value

IList String
Resulting array of scan names.
See Also

Reference

PointCloudInstance Class


PointCloudInstance.GetSelectionFilter Method

PointCloudInstanceGetSelectionFilter Method

Returns the currently active selection filter for this point cloud.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PointCloudFilter GetSelectionFilter()
Public Function GetSelectionFilter As PointCloudFilter
public:
PointCloudFilter^ GetSelectionFilter()
member GetSelectionFilter : unit -> PointCloudFilter

Return Value

PointCloudFilter
Currently active selection filter or if none is active.
See Also

Reference

PointCloudInstance Class


PointCloudInstance.HasColor Method

PointCloudInstanceHasColor Method

Returns true if at least one scan of the element have color, false otherwise.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasColor()
Public Function HasColor As Boolean
public:
bool HasColor()
member HasColor : unit -> bool

Return Value

Boolean
True if at least one scan of the element have color, false otherwise.
See Also

Reference

PointCloudInstance Class


PointCloudInstance.SetSelectionFilter Method

PointCloudInstanceSetSelectionFilter Method

Sets active selection filter by cloning of the one passed to it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetSelectionFilter(
    PointCloudFilter pFilter
)
Public Sub SetSelectionFilter (
    pFilter As PointCloudFilter
)
public:
void SetSelectionFilter(
    PointCloudFilter^ pFilter
)
member SetSelectionFilter :
        pFilter : PointCloudFilter -> unit

Parameters

pFilter PointCloudFilter
The filter object to be made active. If is supplied, the active filter is removed.
Remarks
The filter is provided in the coordinates of the Revit model. If the point cloud is altered (e.g. by moving, rotating, scaling or other modifications) the point cloud filter is not modified and the set of highlighted or isolated points will change. The selection filter is not preserved when the Revit document is saved.
See Also

Reference

PointCloudInstance Class


PointCloudType Class

Represents a type of point cloud loaded into a Revit document. Each PointCloudType maps to a single file or identifier (depending upon the type of Point Cloud Engine which governs it).
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBPointCloudType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PointCloudType : ElementType
Public Class PointCloudType
    Inherits ElementType
public ref class PointCloudType : public ElementType
type PointCloudType =
    class
        inherit ElementType
    end

The PointCloudType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | ColorEncoding | The color encoding used by points extracted from instances of this point cloud.
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | EngineIdentifier | The identifier of the engine responsible for handling of the point cloud.
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
Public property | FoundStatus | Shows whether the Point Cloud external file could be found.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | Offset | Returns the offset stored in the point cloud.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Scale | The multiplier applied to the points in all instances of this point cloud.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new point cloud type for a given point cloud engine.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPath | Gets the path of the link source from which the points are loaded.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
 | GetReCapProject | This method provides a direct entry point to get access to an object from the ReCap SDK (ReCapWrapper.RCProject) from Revit. This object represents the point cloud from the RC file path stored in PointCloudType. The ReCap assembly AdskRcManaged.dll will need to be included into code using this method.
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PointCloudType Properties

The PointCloudType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | ColorEncoding | The color encoding used by points extracted from instances of this point cloud.
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | EngineIdentifier | The identifier of the engine responsible for handling of the point cloud.
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
Public property | FoundStatus | Shows whether the Point Cloud external file could be found.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | Offset | Returns the offset stored in the point cloud.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Scale | The multiplier applied to the points in all instances of this point cloud.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

PointCloudType Class


PointCloudType.ColorEncoding Property

PointCloudTypeColorEncoding Property

The color encoding used by points extracted from instances of this point cloud.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PointCloudColorEncoding ColorEncoding { get; }
Public ReadOnly Property ColorEncoding As PointCloudColorEncoding
    Get
public:
property PointCloudColorEncoding ColorEncoding {
    PointCloudColorEncoding get ();
}
member ColorEncoding : PointCloudColorEncoding with get

Property Value

PointCloudColorEncoding
See Also

Reference

PointCloudType Class


PointCloudType.EngineIdentifier Property

PointCloudTypeEngineIdentifier Property

The identifier of the engine responsible for handling of the point cloud.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string EngineIdentifier { get; }
Public ReadOnly Property EngineIdentifier As String
    Get
public:
property String^ EngineIdentifier {
    String^ get ();
}
member EngineIdentifier : string with get

Property Value

String
Remarks
The built-in engine provides "rcs" and "rcp" here.
See Also

Reference

PointCloudType Class


PointCloudType.FoundStatus Property

PointCloudTypeFoundStatus Property

Shows whether the Point Cloud external file could be found.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PointCloudFoundStatus FoundStatus { get; }
Public ReadOnly Property FoundStatus As PointCloudFoundStatus
    Get
public:
property PointCloudFoundStatus FoundStatus {
    PointCloudFoundStatus get ();
}
member FoundStatus : PointCloudFoundStatus with get

Property Value

PointCloudFoundStatus
See Also

Reference

PointCloudType Class


PointCloudType.Offset Property

PointCloudTypeOffset Property

Returns the offset stored in the point cloud.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Offset { get; }
Public ReadOnly Property Offset As XYZ
    Get
public:
property XYZ^ Offset {
    XYZ^ get ();
}
member Offset : XYZ with get

Property Value

XYZ
Remarks
All points are assumed to be offset by the same offset vector. The offset will be used by Revit if the user chooses to place an instance relative to another point cloud (the "Auto - Origin To Last Placed" placement option).
See Also

Reference

PointCloudType Class


PointCloudType.Scale Property

PointCloudTypeScale Property

The multiplier applied to the points in all instances of this point cloud.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Scale { get; set; }
Public Property Scale As Double
    Get
    Set
public:
property double Scale {
    double get ();
    void set (double value);
}
member Scale : float with get, set

Property Value

Double
Remarks
Scale converts the units in which the coordinates of individual points of the point cloud are interpreted.
See Also

Reference

PointCloudType Class


PointCloudType Methods

The PointCloudType type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new point cloud type for a given point cloud engine.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPath | Gets the path of the link source from which the points are loaded.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
 | GetReCapProject | This method provides a direct entry point to get access to an object from the ReCap SDK (ReCapWrapper.RCProject) from Revit. This object represents the point cloud from the RC file path stored in PointCloudType. The ReCap assembly AdskRcManaged.dll will need to be included into code using this method.
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PointCloudType Class


PointCloudType.Create Method

PointCloudTypeCreate Method

Creates a new point cloud type for a given point cloud engine.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static PointCloudType Create(
    Document document,
    string engineIdentifier,
    string typeIdentifier
)
Public Shared Function Create (
    document As Document,
    engineIdentifier As String,
    typeIdentifier As String
) As PointCloudType
public:
static PointCloudType^ Create(
    Document^ document,
    String^ engineIdentifier,
    String^ typeIdentifier
)
static member Create :
        document : Document *
        engineIdentifier : string *
        typeIdentifier : string -> PointCloudType

Parameters

document Document
The document in which to create the point cloud.
engineIdentifier String
The string identifying the engine to be invoked. It should be the file extension or engine identifier registered by the third party.
typeIdentifier String
The file name or the identification string for a non-file based engine.

Return Value

PointCloudType
The newly created PointCloudType object to be used to create instances of this point cloud.
Exceptions
Exception | Condition
ArgumentException | The engine identifier was not found in the Revit session. -or- document is not a project document.
ArgumentNullException | A non-optional argument was null
FileNotFoundException | The external file could not be found or loaded.
InvalidOperationException | Unable to create a point cloud from the third party engine.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
A list of supported engine identifiers and whether they are file-based or not can be obtained from PointCloudEngineRegistry. The method GetSupportedEngines() returns a list of the identifiers registered for engines.
Example
C#
VB
C++
F#
Copy
private PointCloudInstance CreatePointCloud(Document doc)
{
    PointCloudType type = PointCloudType.Create(doc, "rcs", "c:\\32_cafeteria.rcs");
    return (PointCloudInstance.Create(doc, type.Id, Transform.Identity));
}
Private Function CreatePointCloud(doc As Document) As PointCloudInstance
    Dim type As PointCloudType = PointCloudType.Create(doc, "rcs", "c:\32_cafeteria.rcs")
    Return (PointCloudInstance.Create(doc, type.Id, Transform.Identity))
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

PointCloudType Class


PointCloudType.GetPath Method

PointCloudTypeGetPath Method

Gets the path of the link source from which the points are loaded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ModelPath GetPath()
Public Function GetPath As ModelPath
public:
ModelPath^ GetPath()
member GetPath : unit -> ModelPath

Return Value

ModelPath
Returns the file path for a file based point cloud or null for the non-file based point cloud.
See Also

Reference

PointCloudType Class


PointCloudType.GetReCapProject Method

PointCloudTypeGetReCapProject Method

This method provides a direct entry point to get access to an object from the ReCap SDK (ReCapWrapper.RCProject) from Revit. This object represents the point cloud from the RC file path stored in PointCloudType. The ReCap assembly AdskRcManaged.dll will need to be included into code using this method.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RCProject GetReCapProject()
Public Function GetReCapProject As RCProject
public:
RCProject^ GetReCapProject()
member GetReCapProject : unit -> RCProject

Return Value

RCProject
Exceptions
Exception | Condition
FileAccessException | The file or PointCloudEngine is not ReCap based.
InvalidOperationException | Exception happens when ReCap loading the project.
Remarks
The coordinate system in RCProject is defined by Point Cloud. Please refer to ReCap SDK document for RCProject::getCoordinateSystem. If you need points converted to the modeling coordinate system in Revit, you can obtain the transformation matrix from PointCloudInstance GetTransform.
Example
C#
VB
C++
F#
Copy
private Autodesk.RealityComputing.Managed.RCProject GetRCProject(Document doc)
{
   PointCloudType type = PointCloudType.Create(doc, "rcs", "c:\\32_cafeteria.rcs");
   // Get RCProject, you need to include AdskRcManaged.dll
   Autodesk.RealityComputing.Managed.RCProject proj = type.GetReCapProject();
   // You can get access to functions from ReCap SDK, for example get total point number of ReCap project
   UInt64 numOfPoints = proj.GetNumberOfPoints();
   return type.GetReCapProject();
}
Private Function GetRCProject(ByVal doc As Document) As Autodesk.RealityComputing.Managed.RCProject
    Dim type As PointCloudType = PointCloudType.Create(doc, "rcs", "c:\32_cafeteria.rcs")
    ' Get RCProject, you need to include AdskRcManaged.dll
    Dim proj As Autodesk.RealityComputing.Managed.RCProject = type.GetReCapProject()
    ' You can get access to functions from ReCap SDK, for example get total point number of ReCap project
    Dim numOfPoints As ULong = proj.GetNumberOfPoints()
    Return type.GetReCapProject()
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

PointCloudType Class


PointElementReference Class

Base class for objects defining a way to constrain a ReferencePoint to one or more other objects in a document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBPointElementReference
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class PointElementReference
Public MustInherit Class PointElementReference
public ref class PointElementReference abstract
[<AbstractClassAttribute>]
type PointElementReference = class end

The PointElementReference type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBPointElementReference
Autodesk.Revit.DBPointOnEdge
Autodesk.Revit.DBPointOnEdgeEdgeIntersection
Autodesk.Revit.DBPointOnEdgeFaceIntersection
Autodesk.Revit.DBPointOnFace
Autodesk.Revit.DBPointOnPlane
Autodesk.Revit.DBPointRelativeToPoint


PointElementReference Methods

The PointElementReference type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PointElementReference Class


PointLocationOnCurve Class

Defines the measurement parameters necessary to create a point at a specific location on a curve.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBPointLocationOnCurve

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PointLocationOnCurve : IDisposable
Public Class PointLocationOnCurve
    Implements IDisposable
public ref class PointLocationOnCurve : IDisposable
type PointLocationOnCurve =
    class
        interface IDisposable
    end

The PointLocationOnCurve type exposes the following members.

Constructors
 | Name | Description
Public method | PointLocationOnCurve | Constructs a new instance of a class, with given or default values, to place a point on a curve.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MeasureFrom | The location on the curve from which the measurement is taken.
Public property | MeasurementType | The measurement type.
Public property | MeasurementValue | The measurement value.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the PointLocationOnCurve
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The class will store the following and provides functions to deal with them:
  • The user visible Measurement Type (driving parameter type).
  • The corresponding measurement value (driving parameter).
  • MeasureFrom that tells from where the (driving parameter) measurement is calculated.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PointLocationOnCurve Constructor

Constructs a new instance of a class, with given or default values, to place a point on a curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PointLocationOnCurve(
    PointOnCurveMeasurementType measType,
    double measValue,
    PointOnCurveMeasureFrom measFrom
)
Public Sub New (
    measType As PointOnCurveMeasurementType,
    measValue As Double,
    measFrom As PointOnCurveMeasureFrom
)
public:
PointLocationOnCurve(
    PointOnCurveMeasurementType measType,
    double measValue,
    PointOnCurveMeasureFrom measFrom
)
new :
        measType : PointOnCurveMeasurementType *
        measValue : float *
        measFrom : PointOnCurveMeasureFrom -> PointLocationOnCurve

Parameters

measType PointOnCurveMeasurementType
measValue Double
measFrom PointOnCurveMeasureFrom
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

PointLocationOnCurve Class


PointLocationOnCurve Properties

The PointLocationOnCurve type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MeasureFrom | The location on the curve from which the measurement is taken.
Public property | MeasurementType | The measurement type.
Public property | MeasurementValue | The measurement value.
Top
See Also

Reference

PointLocationOnCurve Class


PointLocationOnCurve.IsValidObject Property

PointLocationOnCurveIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

PointLocationOnCurve Class


PointLocationOnCurve.MeasureFrom Property

PointLocationOnCurveMeasureFrom Property

The location on the curve from which the measurement is taken.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PointOnCurveMeasureFrom MeasureFrom { get; set; }
Public Property MeasureFrom As PointOnCurveMeasureFrom
    Get
    Set
public:
property PointOnCurveMeasureFrom MeasureFrom {
    PointOnCurveMeasureFrom get ();
    void set (PointOnCurveMeasureFrom value);
}
member MeasureFrom : PointOnCurveMeasureFrom with get, set

Property Value

PointOnCurveMeasureFrom
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
The measure-from is not checked until this class is assigned for a particular reference point on a particular curve. At that time, the measure-from must be valid for the curve.
See Also

Reference

PointLocationOnCurve Class


PointLocationOnCurve.MeasurementType Property

PointLocationOnCurveMeasurementType Property

The measurement type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PointOnCurveMeasurementType MeasurementType { get; set; }
Public Property MeasurementType As PointOnCurveMeasurementType
    Get
    Set
public:
property PointOnCurveMeasurementType MeasurementType {
    PointOnCurveMeasurementType get ();
    void set (PointOnCurveMeasurementType value);
}
member MeasurementType : PointOnCurveMeasurementType with get, set

Property Value

PointOnCurveMeasurementType
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
The measurement type is not checked until this class is assigned for a particular reference point on a particular curve. At that time, the measurement type must be valid for the curve.
See Also

Reference

PointLocationOnCurve Class


PointLocationOnCurve.MeasurementValue Property

PointLocationOnCurveMeasurementValue Property

The measurement value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double MeasurementValue { get; set; }
Public Property MeasurementValue As Double
    Get
    Set
public:
property double MeasurementValue {
    double get ();
    void set (double value);
}
member MeasurementValue : float with get, set

Property Value

Double
Remarks
The measurement value is not checked until this class is assigned for a particular reference point on a particular curve. At that time, the measurement value must match the expected range for the curve for the given measurement type and measure-from.
See Also

Reference

PointLocationOnCurve Class


PointLocationOnCurve Methods

The PointLocationOnCurve type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PointLocationOnCurve Class


PointLocationOnCurve.Dispose Method

PointLocationOnCurveDispose Method

Releases all resources used by the PointLocationOnCurve

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

PointLocationOnCurve Class


PointNode Class

An output node that represents a 3D point.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRenderNode
Autodesk.Revit.DBModelCurveNode
Autodesk.Revit.DBPointNode

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PointNode : ModelCurveNode
Public Class PointNode
    Inherits ModelCurveNode
public ref class PointNode : public ModelCurveNode
type PointNode =
    class
        inherit ModelCurveNode
    end

The PointNode type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode)
Public property | LineProperties | Access to the line (pen) properties of the curve being drawn (Inherited from ModelCurveNode)
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from RenderNode)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetPoint | Returns the point object corresponding to the node.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
See also: OnPoint(PointNode).
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PointNode Properties

The PointNode type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode)
Public property | LineProperties | Access to the line (pen) properties of the curve being drawn (Inherited from ModelCurveNode)
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode)
Top
See Also

Reference

PointNode Class


PointNode Methods

The PointNode type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from RenderNode)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetPoint | Returns the point object corresponding to the node.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PointNode Class


PointNode.GetPoint Method

PointNodeGetPoint Method

Returns the point object corresponding to the node.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Point GetPoint()
Public Function GetPoint As Point
public:
Point^ GetPoint()
member GetPoint : unit -> Point

Return Value

Point
The point instance.
See Also

Reference

PointNode Class


PointOnCurveMeasureFrom Enumeration

Point on curve MeasureFrom - It tells from which end of the host curve the point location is measured.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum PointOnCurveMeasureFrom
Public Enumeration PointOnCurveMeasureFrom
public enum class PointOnCurveMeasureFrom
type PointOnCurveMeasureFrom
Members
Member name | Value | Description
Beginning | 1 | Beginning of the host curve.
End | 2 | End of the host curve.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PointOnCurveMeasurementType Enumeration

Point on curve measurement type Defines the types of measurements that may be used when placing a point at a designated distance along a curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum PointOnCurveMeasurementType
Public Enumeration PointOnCurveMeasurementType
public enum class PointOnCurveMeasurementType
type PointOnCurveMeasurementType
Members
Member name | Value | Description
NonNormalizedCurveParameter | 1 | The non-normalized (actual) curve parameter value of the given point. The curve parameter is the defining parameter of the curve. It is also known as the raw/natural parameter.
NormalizedCurveParameter | 2 | Normalized value of the curve parameter. It is defined for curves with user defined bounds or natural bounds, start and end. It is measured as the fraction of the curve parameter (t) over the total parametric range = (t-start) / (end-start). Its value varies between 0 and 1. 0 corresponds to the start and 1 corresponds to the end.
SegmentLength | 3 | Length of the curve segment between the start point and the given point.
NormalizedSegmentLength | 4 | Normalized segment length. It is defined for curves with user defined bounds or natural bounds. It is measured as the fraction of the segment length over the total length of the curve. Its value varies between 0 and 1. 0 corresponds to the start and 1 corresponds to the end.
ChordLength | 5 | Chord length = length of the chord (line segment) joining the start point and the given point. Also known as 3D distance
Angle | 6 | Angle - defined only for arc and circle. It is the angle subtended at the center by the portion of the curve from the star to the given point.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PointOnEdge Class

Define a ReferencePoint relative to a referenceable edge or curve on another element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBPointElementReference
Autodesk.Revit.DBPointOnEdge

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PointOnEdge : PointElementReference
Public Class PointOnEdge
    Inherits PointElementReference
public ref class PointOnEdge : public PointElementReference
type PointOnEdge =
    class
        inherit PointElementReference
    end

The PointOnEdge type exposes the following members.

Properties
 | Name | Description
Public property | LocationOnCurve | The point location on curve.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetEdgeReference | Get a copy of the edge or curve reference.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetEdgeReference | Change the edge or curve reference.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The ReferencePoint's X basis vector is constrained to the tangent vector to the curve. The Y and Z vectors are free to rotate around the curve.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PointOnEdge Properties

The PointOnEdge type exposes the following members.

Properties
 | Name | Description
Public property | LocationOnCurve | The point location on curve.
Top
See Also

Reference

PointOnEdge Class


PointOnEdge.LocationOnCurve Property

PointOnEdgeLocationOnCurve Property

The point location on curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PointLocationOnCurve LocationOnCurve { get; }
Public ReadOnly Property LocationOnCurve As PointLocationOnCurve
    Get
public:
property PointLocationOnCurve^ LocationOnCurve {
    PointLocationOnCurve^ get ();
}
member LocationOnCurve : PointLocationOnCurve with get

Property Value

PointLocationOnCurve
See Also

Reference

PointOnEdge Class


PointOnEdge Methods

The PointOnEdge type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetEdgeReference | Get a copy of the edge or curve reference.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetEdgeReference | Change the edge or curve reference.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PointOnEdge Class


PointOnEdge.GetEdgeReference Method

PointOnEdgeGetEdgeReference Method

Get a copy of the edge or curve reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Reference GetEdgeReference()
Public Function GetEdgeReference As Reference
public:
Reference^ GetEdgeReference()
member GetEdgeReference : unit -> Reference

Return Value

Reference
See Also

Reference

PointOnEdge Class


PointOnEdge.SetEdgeReference Method

PointOnEdgeSetEdgeReference Method

Change the edge or curve reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetEdgeReference(
    Reference reference
)
Public Sub SetEdgeReference (
    reference As Reference
)
public:
void SetEdgeReference(
    Reference^ reference
)
member SetEdgeReference :
        reference : Reference -> unit

Parameters

reference Reference
Remarks
The referenced element may be any model element, including FamilyInstance, FormElement, or CurveElement. The reference must be of type ElementReferenceType.REFERENCE_TYPE_LINEAR.
See Also

Reference

PointOnEdge Class


PointOnEdgeEdgeIntersection Class

Define a ReferencePoint at the intersection of two referenceable lines.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBPointElementReference
Autodesk.Revit.DBPointOnEdgeEdgeIntersection

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PointOnEdgeEdgeIntersection : PointElementReference
Public Class PointOnEdgeEdgeIntersection
    Inherits PointElementReference
public ref class PointOnEdgeEdgeIntersection : public PointElementReference
type PointOnEdgeEdgeIntersection =
    class
        inherit PointElementReference
    end

The PointOnEdgeEdgeIntersection type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetEdgeReference1 | Get a copy of the first edge or curve reference.
Public method | GetEdgeReference2 | Get a copy of the second edge or curve reference.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetEdgeReference1 | Change the first edge or curve reference.
Public method | SetEdgeReference2 | Change the second edge or curve reference.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The ReferencePoint is actually placed on the first line (Edge1) at the closest point to the second line (Edge2). Its X basis vector is constrained to be parallel to the first line.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PointOnEdgeEdgeIntersection Methods

The PointOnEdgeEdgeIntersection type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetEdgeReference1 | Get a copy of the first edge or curve reference.
Public method | GetEdgeReference2 | Get a copy of the second edge or curve reference.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetEdgeReference1 | Change the first edge or curve reference.
Public method | SetEdgeReference2 | Change the second edge or curve reference.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PointOnEdgeEdgeIntersection Class


PointOnEdgeEdgeIntersection.GetEdgeReference1 Method

PointOnEdgeEdgeIntersectionGetEdgeReference1 Method

Get a copy of the first edge or curve reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Reference GetEdgeReference1()
Public Function GetEdgeReference1 As Reference
public:
Reference^ GetEdgeReference1()
member GetEdgeReference1 : unit -> Reference

Return Value

Reference
See Also

Reference

PointOnEdgeEdgeIntersection Class


PointOnEdgeEdgeIntersection.GetEdgeReference2 Method

PointOnEdgeEdgeIntersectionGetEdgeReference2 Method

Get a copy of the second edge or curve reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Reference GetEdgeReference2()
Public Function GetEdgeReference2 As Reference
public:
Reference^ GetEdgeReference2()
member GetEdgeReference2 : unit -> Reference

Return Value

Reference
See Also

Reference

PointOnEdgeEdgeIntersection Class


PointOnEdgeEdgeIntersection.SetEdgeReference1 Method

PointOnEdgeEdgeIntersectionSetEdgeReference1 Method

Change the first edge or curve reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetEdgeReference1(
    Reference edgeReference
)
Public Sub SetEdgeReference1 (
    edgeReference As Reference
)
public:
void SetEdgeReference1(
    Reference^ edgeReference
)
member SetEdgeReference1 :
        edgeReference : Reference -> unit

Parameters

edgeReference Reference
Remarks
The referenced element may be any model element, including FamilyInstance, FormElement, or NonPlanarSketch. The reference must be of type ElementReferenceType.REFERENCE_TYPE_LINEAR, and it must correspond to a straight line.
See Also

Reference

PointOnEdgeEdgeIntersection Class


PointOnEdgeEdgeIntersection.SetEdgeReference2 Method

PointOnEdgeEdgeIntersectionSetEdgeReference2 Method

Change the second edge or curve reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetEdgeReference2(
    Reference edgeReference
)
Public Sub SetEdgeReference2 (
    edgeReference As Reference
)
public:
void SetEdgeReference2(
    Reference^ edgeReference
)
member SetEdgeReference2 :
        edgeReference : Reference -> unit

Parameters

edgeReference Reference
Remarks
The referenced element may be any model element, including FamilyInstance, FormElement, or NonPlanarSketch. The reference must be of type ElementReferenceType.REFERENCE_TYPE_LINEAR, and it must correspond to a straight line.
See Also

Reference

PointOnEdgeEdgeIntersection Class


PointOnEdgeFaceIntersection Class

Define a ReferencePoint at the intersection of a referenceable edge or curve and a referenceable face.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBPointElementReference
Autodesk.Revit.DBPointOnEdgeFaceIntersection

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PointOnEdgeFaceIntersection : PointElementReference
Public Class PointOnEdgeFaceIntersection
    Inherits PointElementReference
public ref class PointOnEdgeFaceIntersection : public PointElementReference
type PointOnEdgeFaceIntersection =
    class
        inherit PointElementReference
    end

The PointOnEdgeFaceIntersection type exposes the following members.

Properties
 | Name | Description
Public property | OrientWithEdge | Whether to orient the ReferencePoint to the edge or the face.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetEdgeReference | Get a copy of the edge or curve reference.
Public method | GetFaceReference | Get a copy of the face reference.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetEdgeReference | Change the edge or curve reference.
Public method | SetFaceReference | Change the face reference.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The ReferencePoint's orientation is partially constrained either to the edge (in the manner of PointOnEdge) or to the face (in the manner of PointOnFace).
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PointOnEdgeFaceIntersection Properties

The PointOnEdgeFaceIntersection type exposes the following members.

Properties
 | Name | Description
Public property | OrientWithEdge | Whether to orient the ReferencePoint to the edge or the face.
Top
See Also

Reference

PointOnEdgeFaceIntersection Class


PointOnEdgeFaceIntersection.OrientWithEdge Property

PointOnEdgeFaceIntersectionOrientWithEdge Property

Whether to orient the ReferencePoint to the edge or the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool OrientWithEdge { get; set; }
Public Property OrientWithEdge As Boolean
    Get
    Set
public:
property bool OrientWithEdge {
    bool get ();
    void set (bool value);
}
member OrientWithEdge : bool with get, set

Property Value

Boolean
Remarks
If true, the X basis vector will be parallel to the edge. If false, the X and Y basis vectors will be parallel to the face.
See Also

Reference

PointOnEdgeFaceIntersection Class


PointOnEdgeFaceIntersection Methods

The PointOnEdgeFaceIntersection type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetEdgeReference | Get a copy of the edge or curve reference.
Public method | GetFaceReference | Get a copy of the face reference.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetEdgeReference | Change the edge or curve reference.
Public method | SetFaceReference | Change the face reference.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PointOnEdgeFaceIntersection Class


PointOnEdgeFaceIntersection.GetEdgeReference Method

PointOnEdgeFaceIntersectionGetEdgeReference Method

Get a copy of the edge or curve reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Reference GetEdgeReference()
Public Function GetEdgeReference As Reference
public:
Reference^ GetEdgeReference()
member GetEdgeReference : unit -> Reference

Return Value

Reference
See Also

Reference

PointOnEdgeFaceIntersection Class


PointOnEdgeFaceIntersection.GetFaceReference Method

PointOnEdgeFaceIntersectionGetFaceReference Method

Get a copy of the face reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Reference GetFaceReference()
Public Function GetFaceReference As Reference
public:
Reference^ GetFaceReference()
member GetFaceReference : unit -> Reference

Return Value

Reference
See Also

Reference

PointOnEdgeFaceIntersection Class


PointOnEdgeFaceIntersection.SetEdgeReference Method

PointOnEdgeFaceIntersectionSetEdgeReference Method

Change the edge or curve reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetEdgeReference(
    Reference edgeReference
)
Public Sub SetEdgeReference (
    edgeReference As Reference
)
public:
void SetEdgeReference(
    Reference^ edgeReference
)
member SetEdgeReference :
        edgeReference : Reference -> unit

Parameters

edgeReference Reference
Remarks
The referenced element may be any model element, including FamilyInstance, FormElement, or CurveElement. The reference must be of type ElementReferenceType.REFERENCE_TYPE_LINEAR.
See Also

Reference

PointOnEdgeFaceIntersection Class


PointOnEdgeFaceIntersection.SetFaceReference Method

PointOnEdgeFaceIntersectionSetFaceReference Method

Change the face reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetFaceReference(
    Reference reference
)
Public Sub SetFaceReference (
    reference As Reference
)
public:
void SetFaceReference(
    Reference^ reference
)
member SetFaceReference :
        reference : Reference -> unit

Parameters

reference Reference
Remarks
The referenced element may be any model element, including FamilyInstance or FormElement. The reference must be of type ElementReferenceType.REFERENCE_TYPE_SURFACE, and the surface must be of type Plane. The Reference's UVPoint property is ignored.
See Also

Reference

PointOnEdgeFaceIntersection Class


PointOnFace Class

Define a ReferencePoint relative to a Face.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBPointElementReference
Autodesk.Revit.DBPointOnFace

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PointOnFace : PointElementReference
Public Class PointOnFace
    Inherits PointElementReference
public ref class PointOnFace : public PointElementReference
type PointOnFace =
    class
        inherit PointElementReference
    end

The PointOnFace type exposes the following members.

Properties
 | Name | Description
Public property | UV | The location of the point in the surface's coordinate system.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetFaceReference | Get a copy of the face reference.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetFaceReference | Change the face reference.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
A ReferencePoint on a Face has its X and Y basis vectors parallel to the Face, but is free to rotate around its Z basis vector. It must lie on the face (unlike PointOnPlane).
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PointOnFace Properties

The PointOnFace type exposes the following members.

Properties
 | Name | Description
Public property | UV | The location of the point in the surface's coordinate system.
Top
See Also

Reference

PointOnFace Class


PointOnFace.UV Property

PointOnFaceUV Property

The location of the point in the surface's coordinate system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public UV UV { get; set; }
Public Property UV As UV
    Get
    Set
public:
property UV^ UV {
    UV^ get ();
    void set (UV^ value);
}
member UV : UV with get, set

Property Value

UV
See Also

Reference

PointOnFace Class


PointOnFace Methods

The PointOnFace type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetFaceReference | Get a copy of the face reference.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetFaceReference | Change the face reference.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PointOnFace Class


PointOnFace.GetFaceReference Method

PointOnFaceGetFaceReference Method

Get a copy of the face reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Reference GetFaceReference()
Public Function GetFaceReference As Reference
public:
Reference^ GetFaceReference()
member GetFaceReference : unit -> Reference

Return Value

Reference
See Also

Reference

PointOnFace Class


PointOnFace.SetFaceReference Method

PointOnFaceSetFaceReference Method

Change the face reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetFaceReference(
    Reference reference
)
Public Sub SetFaceReference (
    reference As Reference
)
public:
void SetFaceReference(
    Reference^ reference
)
member SetFaceReference :
        reference : Reference -> unit

Parameters

reference Reference
Remarks
The referenced element may be any model element, including FamilyInstance or FormElement. The reference must be of type ElementReferenceType.REFERENCE_TYPE_SURFACE, and the surface must be of type Plane. The Reference's UVPoint property is ignored.
See Also

Reference

PointOnFace Class


PointOnPlane Class

Define a ReferencePoint relative to a planar reference.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBPointElementReference
Autodesk.Revit.DBPointOnPlane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PointOnPlane : PointElementReference
Public Class PointOnPlane
    Inherits PointElementReference
public ref class PointOnPlane : public PointElementReference
type PointOnPlane =
    class
        inherit PointElementReference
    end

The PointOnPlane type exposes the following members.

Properties
 | Name | Description
Public property | Offset | Signed offset from the plane.
Public property | Position | The coordinates of the point (or its projection) on the plane.
Public property | XVec | The X-coordinate vector of the point, in the plane's coordinate system.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetPlaneReference | The geometric plane reference.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | IsValidPlaneReference | Check whether a geometry reference corresponds to a referenceable plane.
 | NewPointOnPlane | Construct a PointOnPlane given a reference and a location in space.
Public method | SetPlaneReference | Change the geometric plane reference.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
A ReferencePoint on a plane has its X and Y basis vectors parallel to the plane, but is free to rotate around its Z basis vector. It can lie on the plane or have an offset.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PointOnPlane Properties

The PointOnPlane type exposes the following members.

Properties
 | Name | Description
Public property | Offset | Signed offset from the plane.
Public property | Position | The coordinates of the point (or its projection) on the plane.
Public property | XVec | The X-coordinate vector of the point, in the plane's coordinate system.
Top
See Also

Reference

PointOnPlane Class


PointOnPlane.Offset Property

PointOnPlaneOffset Property

Signed offset from the plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Offset { get; set; }
Public Property Offset As Double
    Get
    Set
public:
property double Offset {
    double get ();
    void set (double value);
}
member Offset : float with get, set

Property Value

Double
Remarks
The point's position is offset in the direction of the normal vector returned by the Plane.Normal property.
See Also

Reference

PointOnPlane Class


PointOnPlane.Position Property

PointOnPlanePosition Property

The coordinates of the point (or its projection) on the plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public UV Position { get; set; }
Public Property Position As UV
    Get
    Set
public:
property UV^ Position {
    UV^ get ();
    void set (UV^ value);
}
member Position : UV with get, set

Property Value

UV
See Also

Reference

PointOnPlane Class


PointOnPlane.XVec Property

PointOnPlaneXVec Property

The X-coordinate vector of the point, in the plane's coordinate system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public UV XVec { get; set; }
Public Property XVec As UV
    Get
    Set
public:
property UV^ XVec {
    UV^ get ();
    void set (UV^ value);
}
member XVec : UV with get, set

Property Value

UV
See Also

Reference

PointOnPlane Class


PointOnPlane Methods

The PointOnPlane type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetPlaneReference | The geometric plane reference.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | IsValidPlaneReference | Check whether a geometry reference corresponds to a referenceable plane.
 | NewPointOnPlane | Construct a PointOnPlane given a reference and a location in space.
Public method | SetPlaneReference | Change the geometric plane reference.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PointOnPlane Class


PointOnPlane.GetPlaneReference Method

PointOnPlaneGetPlaneReference Method

The geometric plane reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Reference GetPlaneReference()
Public Function GetPlaneReference As Reference
public:
Reference^ GetPlaneReference()
member GetPlaneReference : unit -> Reference

Return Value

Reference
A copy of the reference stored in the PointOnPlane object.
See Also

Reference

PointOnPlane Class


PointOnPlane.IsValidPlaneReference Method

PointOnPlaneIsValidPlaneReference Method

Check whether a geometry reference corresponds to a referenceable plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidPlaneReference(
    Document doc,
    Reference planeReference
)
Public Shared Function IsValidPlaneReference (
    doc As Document,
    planeReference As Reference
) As Boolean
public:
static bool IsValidPlaneReference(
    Document^ doc,
    Reference^ planeReference
)
static member IsValidPlaneReference :
        doc : Document *
        planeReference : Reference -> bool

Parameters

doc Document
planeReference Reference

Return Value

Boolean
Remarks
Valid plane references include: planar faces of solids; the PlaneReference properties of Level and SketchPlane; the Reference property of ReferencePlane.
See Also

Reference

PointOnPlane Class


PointOnPlane.NewPointOnPlane Method

PointOnPlaneNewPointOnPlane Method

Construct a PointOnPlane given a reference and a location in space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static PointOnPlane NewPointOnPlane(
    Document doc,
    Reference planeReference,
    XYZ position,
    XYZ xvec
)
Public Shared Function NewPointOnPlane (
    doc As Document,
    planeReference As Reference,
    position As XYZ,
    xvec As XYZ
) As PointOnPlane
public:
static PointOnPlane^ NewPointOnPlane(
    Document^ doc,
    Reference^ planeReference,
    XYZ^ position,
    XYZ^ xvec
)
static member NewPointOnPlane :
        doc : Document *
        planeReference : Reference *
        position : XYZ *
        xvec : XYZ -> PointOnPlane

Parameters

doc Document
The document containing the plane reference.
planeReference Reference
position XYZ
A 3-dimensional position.
xvec XYZ
The direction of the point's X-coordinate vector in the plane's coordinates. Optional; default value is the X-coordinate vector of the plane.

Return Value

PointOnPlane
A new PointOnPlane object with 2-dimensional Position, XVec, and Offset properties set to match the given 3-dimensional arguments.
See Also

Reference

PointOnPlane Class


PointOnPlane.SetPlaneReference Method

PointOnPlaneSetPlaneReference Method

Change the geometric plane reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetPlaneReference(
    Reference planeReference
)
Public Sub SetPlaneReference (
    planeReference As Reference
)
public:
void SetPlaneReference(
    Reference^ planeReference
)
member SetPlaneReference :
        planeReference : Reference -> unit

Parameters

planeReference Reference
A reference to some plane in the document. (Note: the reference must satisfy IsValidPlaneReference(), but this is not checked until this PointOnPlane object is assigned to a ReferencePoint.)
See Also

Reference

PointOnPlane Class


PointRelativeToPoint Class

Represents a point placed relative to another point.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBPointElementReference
Autodesk.Revit.DBPointRelativeToPoint

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PointRelativeToPoint : PointElementReference
Public Class PointRelativeToPoint
    Inherits PointElementReference
public ref class PointRelativeToPoint : public PointElementReference
type PointRelativeToPoint =
    class
        inherit PointElementReference
    end

The PointRelativeToPoint type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetHostPointReference | Get a copy of the host point reference.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetHostPointReference | Change the host point reference.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
For this release, the only workflow supported is that the point is placed coincident with the referenced host (a relative transformation of Transform.Identity).
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PointRelativeToPoint Methods

The PointRelativeToPoint type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetHostPointReference | Get a copy of the host point reference.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetHostPointReference | Change the host point reference.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PointRelativeToPoint Class


PointRelativeToPoint.GetHostPointReference Method

PointRelativeToPointGetHostPointReference Method

Get a copy of the host point reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Reference GetHostPointReference()
Public Function GetHostPointReference As Reference
public:
Reference^ GetHostPointReference()
member GetHostPointReference : unit -> Reference

Return Value

Reference
See Also

Reference

PointRelativeToPoint Class


PointRelativeToPoint.SetHostPointReference Method

PointRelativeToPointSetHostPointReference Method

Change the host point reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetHostPointReference(
    Reference hostPointReference
)
Public Sub SetHostPointReference (
    hostPointReference As Reference
)
public:
void SetHostPointReference(
    Reference^ hostPointReference
)
member SetHostPointReference :
        hostPointReference : Reference -> unit

Parameters

hostPointReference Reference
Remarks
Allowed references are to another Autodesk.Revit.DB.ReferencePoint element or to an Autodesk.Revit.DB.Point.
See Also

Reference

PointRelativeToPoint Class


PolyLine Class

A polyline.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGeometryObject
Autodesk.Revit.DBPolyLine

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PolyLine : GeometryObject
Public Class PolyLine
    Inherits GeometryObject
public ref class PolyLine : public GeometryObject
type PolyLine =
    class
        inherit GeometryObject
    end

The PolyLine type exposes the following members.

Properties
 | Name | Description
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject)
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | NumberOfCoordinates | Gets the number of the coordinate points.
Public property | Visibility | The visibility. (Inherited from GeometryObject)
Top
Methods
 | Name | Description
Public method | Clone | Returns a copy of this polyline.
 | Create | Creates a polyline with coordinate points provided.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject)
Public method | Evaluate | Evaluates a parameter on the polyline.
Public method | GetCoordinate | Gets the coordinate point of the specified index.
Public method | GetCoordinates | Gets the coordinate points of the polyline.
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject)
Public method | GetOutline | Gets the outline of the polyline.
Public method | GetTransformed | Gets the copy of the polyline which is applied the specified transformation.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
A polyline in space is defined by a set of coordinate points.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PolyLine Properties

The PolyLine type exposes the following members.

Properties
 | Name | Description
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject)
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | NumberOfCoordinates | Gets the number of the coordinate points.
Public property | Visibility | The visibility. (Inherited from GeometryObject)
Top
See Also

Reference

PolyLine Class


PolyLine.NumberOfCoordinates Property

PolyLineNumberOfCoordinates Property

Gets the number of the coordinate points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int NumberOfCoordinates { get; }
Public ReadOnly Property NumberOfCoordinates As Integer
    Get
public:
property int NumberOfCoordinates {
    int get ();
}
member NumberOfCoordinates : int with get

Property Value

Int32
See Also

Reference

PolyLine Class


PolyLine Methods

The PolyLine type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Returns a copy of this polyline.
 | Create | Creates a polyline with coordinate points provided.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject)
Public method | Evaluate | Evaluates a parameter on the polyline.
Public method | GetCoordinate | Gets the coordinate point of the specified index.
Public method | GetCoordinates | Gets the coordinate points of the polyline.
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject)
Public method | GetOutline | Gets the outline of the polyline.
Public method | GetTransformed | Gets the copy of the polyline which is applied the specified transformation.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PolyLine Class


PolyLine.Clone Method

PolyLineClone Method

Returns a copy of this polyline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PolyLine Clone()
Public Function Clone As PolyLine
public:
PolyLine^ Clone()
member Clone : unit -> PolyLine

Return Value

PolyLine
See Also

Reference

PolyLine Class


PolyLine.Create Method

PolyLineCreate Method

Creates a polyline with coordinate points provided.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static PolyLine Create(
    IList<XYZ> coordinates
)
Public Shared Function Create (
    coordinates As IList(Of XYZ)
) As PolyLine
public:
static PolyLine^ Create(
    IList<XYZ^>^ coordinates
)
static member Create :
        coordinates : IList<XYZ> -> PolyLine

Parameters

coordinates IList XYZ

Return Value

PolyLine
Exceptions
Exception | Condition
ArgumentException | Thrown when the count of coordinates is less than 2.
See Also

Reference

PolyLine Class


PolyLine.Evaluate Method

PolyLineEvaluate Method

Evaluates a parameter on the polyline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Evaluate(
    double param
)
Public Function Evaluate (
    param As Double
) As XYZ
public:
XYZ^ Evaluate(
    double param
)
member Evaluate :
        param : float -> XYZ

Parameters

param Double
The parameter to be evaluated. It is expected to be in [0,1] interval mapped to the bounds of the whole polyline.

Return Value

XYZ
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown when the param value is not between 0.0 and 1.0.
See Also

Reference

PolyLine Class


PolyLine.GetCoordinate Method

PolyLineGetCoordinate Method

Gets the coordinate point of the specified index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ GetCoordinate(
    int index
)
Public Function GetCoordinate (
    index As Integer
) As XYZ
public:
XYZ^ GetCoordinate(
    int index
)
member GetCoordinate :
        index : int -> XYZ

Parameters

index Int32
The index of the coordinates.

Return Value

XYZ
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown when the index value is out of range.
See Also

Reference

PolyLine Class


PolyLine.GetCoordinates Method

PolyLineGetCoordinates Method

Gets the coordinate points of the polyline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<XYZ> GetCoordinates()
Public Function GetCoordinates As IList(Of XYZ)
public:
IList<XYZ^>^ GetCoordinates()
member GetCoordinates : unit -> IList<XYZ>

Return Value

IList XYZ
See Also

Reference

PolyLine Class


PolyLine.GetOutline Method

PolyLineGetOutline Method

Gets the outline of the polyline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Outline GetOutline()
Public Function GetOutline As Outline
public:
Outline^ GetOutline()
member GetOutline : unit -> Outline

Return Value

Outline
See Also

Reference

PolyLine Class


PolyLine.GetTransformed Method

PolyLineGetTransformed Method

Gets the copy of the polyline which is applied the specified transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PolyLine GetTransformed(
    Transform transform
)
Public Function GetTransformed (
    transform As Transform
) As PolyLine
public:
PolyLine^ GetTransformed(
    Transform^ transform
)
member GetTransformed :
        transform : Transform -> PolyLine

Parameters

transform Transform

Return Value

PolyLine
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the transform is .
See Also

Reference

PolyLine Class


PolylineNode Class

An output node that represents a 3D polyline.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRenderNode
Autodesk.Revit.DBModelCurveNode
Autodesk.Revit.DBPolylineNode

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PolylineNode : ModelCurveNode
Public Class PolylineNode
    Inherits ModelCurveNode
public ref class PolylineNode : public ModelCurveNode
type PolylineNode =
    class
        inherit ModelCurveNode
    end

The PolylineNode type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode)
Public property | LineProperties | Access to the line (pen) properties of the curve being drawn (Inherited from ModelCurveNode)
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from RenderNode)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetPolyline | Returns the polyline object corresponding to the node.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
See also: OnPolyline(PolylineNode).
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PolylineNode Properties

The PolylineNode type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode)
Public property | LineProperties | Access to the line (pen) properties of the curve being drawn (Inherited from ModelCurveNode)
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode)
Top
See Also

Reference

PolylineNode Class


PolylineNode Methods

The PolylineNode type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from RenderNode)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetPolyline | Returns the polyline object corresponding to the node.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PolylineNode Class


PolylineNode.GetPolyline Method

PolylineNodeGetPolyline Method

Returns the polyline object corresponding to the node.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PolyLine GetPolyline()
Public Function GetPolyline As PolyLine
public:
PolyLine^ GetPolyline()
member GetPolyline : unit -> PolyLine

Return Value

PolyLine
The polyline instance.
See Also

Reference

PolylineNode Class


PolylineSegments Class

An output node that represents a tessellated polyline segments.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBPolylineSegments

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PolylineSegments : IDisposable
Public Class PolylineSegments
    Implements IDisposable
public ref class PolylineSegments : IDisposable
type PolylineSegments =
    class
        interface IDisposable
    end

The PolylineSegments type exposes the following members.

Properties
 | Name | Description
Public property | EndLocalParameter | Local parameter associated with the end point.
Public property | EndParameter | Parameter associated with the end point.
Public property | IsFilled | Indicates whether the area enclosed by the polyline is to be filled or not.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LineProperties | Access to the line (pen) properties of the polyline
Public property | StartLocalParameter | Local parameter associated with the start point.
Public property | StartParameter | Parameter associated with the start point.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the PolylineSegments
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetVertices | Returns an array of vertices of the polyline segments.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
See also: OnPolylineSegments(PolylineSegments).
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PolylineSegments Properties

The PolylineSegments type exposes the following members.

Properties
 | Name | Description
Public property | EndLocalParameter | Local parameter associated with the end point.
Public property | EndParameter | Parameter associated with the end point.
Public property | IsFilled | Indicates whether the area enclosed by the polyline is to be filled or not.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LineProperties | Access to the line (pen) properties of the polyline
Public property | StartLocalParameter | Local parameter associated with the start point.
Public property | StartParameter | Parameter associated with the start point.
Top
See Also

Reference

PolylineSegments Class


PolylineSegments.EndLocalParameter Property

PolylineSegmentsEndLocalParameter Property

Local parameter associated with the end point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double EndLocalParameter { get; }
Public ReadOnly Property EndLocalParameter As Double
    Get
public:
property double EndLocalParameter {
    double get ();
}
member EndLocalParameter : float with get

Property Value

Double
See Also

Reference

PolylineSegments Class


PolylineSegments.EndParameter Property

PolylineSegmentsEndParameter Property

Parameter associated with the end point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double EndParameter { get; }
Public ReadOnly Property EndParameter As Double
    Get
public:
property double EndParameter {
    double get ();
}
member EndParameter : float with get

Property Value

Double
See Also

Reference

PolylineSegments Class


PolylineSegments.IsFilled Property

PolylineSegmentsIsFilled Property

Indicates whether the area enclosed by the polyline is to be filled or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsFilled { get; }
Public ReadOnly Property IsFilled As Boolean
    Get
public:
property bool IsFilled {
    bool get ();
}
member IsFilled : bool with get

Property Value

Boolean
See Also

Reference

PolylineSegments Class


PolylineSegments.IsValidObject Property

PolylineSegmentsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

PolylineSegments Class


PolylineSegments.LineProperties Property

PolylineSegmentsLineProperties Property

Access to the line (pen) properties of the polyline

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LineProperties LineProperties { get; }
Public ReadOnly Property LineProperties As LineProperties
    Get
public:
property LineProperties^ LineProperties {
    LineProperties^ get ();
}
member LineProperties : LineProperties with get

Property Value

LineProperties
See Also

Reference

PolylineSegments Class


PolylineSegments.StartLocalParameter Property

PolylineSegmentsStartLocalParameter Property

Local parameter associated with the start point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double StartLocalParameter { get; }
Public ReadOnly Property StartLocalParameter As Double
    Get
public:
property double StartLocalParameter {
    double get ();
}
member StartLocalParameter : float with get

Property Value

Double
See Also

Reference

PolylineSegments Class


PolylineSegments.StartParameter Property

PolylineSegmentsStartParameter Property

Parameter associated with the start point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double StartParameter { get; }
Public ReadOnly Property StartParameter As Double
    Get
public:
property double StartParameter {
    double get ();
}
member StartParameter : float with get

Property Value

Double
See Also

Reference

PolylineSegments Class


PolylineSegments Methods

The PolylineSegments type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetVertices | Returns an array of vertices of the polyline segments.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PolylineSegments Class


PolylineSegments.Dispose Method

PolylineSegmentsDispose Method

Releases all resources used by the PolylineSegments

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

PolylineSegments Class


PolylineSegments.GetVertices Method

PolylineSegmentsGetVertices Method

Returns an array of vertices of the polyline segments.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<XYZ> GetVertices()
Public Function GetVertices As IList(Of XYZ)
public:
IList<XYZ^>^ GetVertices()
member GetVertices : unit -> IList<XYZ>

Return Value

IList XYZ
Array of XYZ points.
See Also

Reference

PolylineSegments Class


PolymeshFacet Class

A class representing one triangular piece - a facet - in a polymesh topology.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBPolymeshFacet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PolymeshFacet
Public Class PolymeshFacet
public ref class PolymeshFacet
type PolymeshFacet = class end

The PolymeshFacet type exposes the following members.

Constructors
 | Name | Description
Public method | PolymeshFacet | Creates a PolymeshFacet with the supplied vertices.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | V1 | The first vertex of the facet
Public property | V2 | The second vertex of the facet
Public property | V3 | The third vertex of the facet
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetVertices | Returns the three vertices that define this facet
Public method | ToString | Returns formatted string showing (V1, V2, V3) with values formatted as regular integers (Overrides ObjectToString)
Top
Remarks
It can also be used to create TopographySurface. Each facet is defined by indices of three vertices of the polymesh.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PolymeshFacet Constructor

Creates a PolymeshFacet with the supplied vertices.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PolymeshFacet(
    int v1,
    int v2,
    int v3
)
Public Sub New (
    v1 As Integer,
    v2 As Integer,
    v3 As Integer
)
public:
PolymeshFacet(
    int v1,
    int v2,
    int v3
)
new :
        v1 : int *
        v2 : int *
        v3 : int -> PolymeshFacet

Parameters

v1 Int32
The first vertex.
v2 Int32
The second vertex.
v3 Int32
The third vertex.
See Also

Reference

PolymeshFacet Class


PolymeshFacet Properties

The PolymeshFacet type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | V1 | The first vertex of the facet
Public property | V2 | The second vertex of the facet
Public property | V3 | The third vertex of the facet
Top
See Also

Reference

PolymeshFacet Class


PolymeshFacet.IsValidObject Property

PolymeshFacetIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
This property is always True for a polymesh facet.
See Also

Reference

PolymeshFacet Class


PolymeshFacet.V1 Property

PolymeshFacetV1 Property

The first vertex of the facet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int V1 { get; }
Public ReadOnly Property V1 As Integer
    Get
public:
property int V1 {
    int get ();
}
member V1 : int with get

Property Value

Int32
An index of a vertex of a polymesh.
See Also

Reference

PolymeshFacet Class


PolymeshFacet.V2 Property

PolymeshFacetV2 Property

The second vertex of the facet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int V2 { get; }
Public ReadOnly Property V2 As Integer
    Get
public:
property int V2 {
    int get ();
}
member V2 : int with get

Property Value

Int32
An index of a vertex of a polymesh.
See Also

Reference

PolymeshFacet Class


PolymeshFacet.V3 Property

PolymeshFacetV3 Property

The third vertex of the facet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int V3 { get; }
Public ReadOnly Property V3 As Integer
    Get
public:
property int V3 {
    int get ();
}
member V3 : int with get

Property Value

Int32
An index of a vertex of a polymesh.
See Also

Reference

PolymeshFacet Class


PolymeshFacet Methods

The PolymeshFacet type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetVertices | Returns the three vertices that define this facet
Public method | ToString | Returns formatted string showing (V1, V2, V3) with values formatted as regular integers (Overrides ObjectToString)
Top
See Also

Reference

PolymeshFacet Class


PolymeshFacet.GetVertices Method

PolymeshFacetGetVertices Method

Returns the three vertices that define this facet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<int> GetVertices()
Public Function GetVertices As IList(Of Integer)
public:
IList<int>^ GetVertices()
member GetVertices : unit -> IList<int>

Return Value

IList Int32
Remarks
A container with three integers (indices of the vertices) is returned.
See Also

Reference

PolymeshFacet Class


PolymeshFacet.ToString Method

PolymeshFacetToString Method

Returns formatted string showing (V1, V2, V3) with values formatted as regular integers

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

String
See Also

Reference

PolymeshFacet Class


PolymeshTopology Class

A class representing topology of a polymesh.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBPolymeshTopology

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PolymeshTopology : IDisposable
Public Class PolymeshTopology
    Implements IDisposable
public ref class PolymeshTopology : IDisposable
type PolymeshTopology =
    class
        interface IDisposable
    end

The PolymeshTopology type exposes the following members.

Properties
 | Name | Description
Public property | DistributionOfNormals | Indicates the distribution of normal vectors along the tessellated polymesh surface.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NumberOfFacets | The number of facet in the polymesh.
Public property | NumberOfNormals | The number of normals associated with the polymesh
Public property | NumberOfPoints | The number of points in the polymesh
Public property | NumberOfUVs | The number of UV coordinates available for the polymesh.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the PolymeshTopology
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetFacet | Returns a definition of one facet
Public method | GetFacets | Returns a definitions of all facets of the polymesh
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetNormal | Returns a normal vector at the given index
Public method | GetNormals | Returns all normals assigned to the polymesh
Public method | GetPoint | Returns one point at the given index.
Public method | GetPoints | Returns all points of the polymesh.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetUV | Returns one UV coordinate at the given index.
Public method | GetUVs | Returns all UV coordinates assigned to the polymesh
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Topology of a polymesh consists of a number of points and triangular facets formed by the points. Each facet is determined by three indices to the array of points. A polymesh may have UV coordinates assigned, and always has at least one normal associated. There may be more than one normal available for a non-planar polymesh; there may be as many normals as there are either facets or points in the polymesh. The DistributionOfNormals property indicates how normals are distributed along the polymesh.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PolymeshTopology Properties

The PolymeshTopology type exposes the following members.

Properties
 | Name | Description
Public property | DistributionOfNormals | Indicates the distribution of normal vectors along the tessellated polymesh surface.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NumberOfFacets | The number of facet in the polymesh.
Public property | NumberOfNormals | The number of normals associated with the polymesh
Public property | NumberOfPoints | The number of points in the polymesh
Public property | NumberOfUVs | The number of UV coordinates available for the polymesh.
Top
See Also

Reference

PolymeshTopology Class


PolymeshTopology.DistributionOfNormals Property

PolymeshTopologyDistributionOfNormals Property

Indicates the distribution of normal vectors along the tessellated polymesh surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DistributionOfNormals DistributionOfNormals { get; }
Public ReadOnly Property DistributionOfNormals As DistributionOfNormals
    Get
public:
property DistributionOfNormals DistributionOfNormals {
    DistributionOfNormals get ();
}
member DistributionOfNormals : DistributionOfNormals with get

Property Value

DistributionOfNormals
See Also

Reference

PolymeshTopology Class


PolymeshTopology.IsValidObject Property

PolymeshTopologyIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

PolymeshTopology Class


PolymeshTopology.NumberOfFacets Property

PolymeshTopologyNumberOfFacets Property

The number of facet in the polymesh.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int NumberOfFacets { get; }
Public ReadOnly Property NumberOfFacets As Integer
    Get
public:
property int NumberOfFacets {
    int get ();
}
member NumberOfFacets : int with get

Property Value

Int32
See Also

Reference

PolymeshTopology Class


PolymeshTopology.NumberOfNormals Property

PolymeshTopologyNumberOfNormals Property

The number of normals associated with the polymesh

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int NumberOfNormals { get; }
Public ReadOnly Property NumberOfNormals As Integer
    Get
public:
property int NumberOfNormals {
    int get ();
}
member NumberOfNormals : int with get

Property Value

Int32
Remarks
The number is always equal either to '1', or the number of facets, or the number of points. The DistributionOfNormals property indicates how normals are distributed along the polymesh. If there is only one normal available, it applies to the entire mesh. Curved surfaces have normal vectors associated with either every facet or every point/vertex of the tessellated polymesh.
See Also

Reference

PolymeshTopology Class


PolymeshTopology.NumberOfPoints Property

PolymeshTopologyNumberOfPoints Property

The number of points in the polymesh

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int NumberOfPoints { get; }
Public ReadOnly Property NumberOfPoints As Integer
    Get
public:
property int NumberOfPoints {
    int get ();
}
member NumberOfPoints : int with get

Property Value

Int32
See Also

Reference

PolymeshTopology Class


PolymeshTopology.NumberOfUVs Property

PolymeshTopologyNumberOfUVs Property

The number of UV coordinates available for the polymesh.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int NumberOfUVs { get; }
Public ReadOnly Property NumberOfUVs As Integer
    Get
public:
property int NumberOfUVs {
    int get ();
}
member NumberOfUVs : int with get

Property Value

Int32
Remarks
Normally, the number of UV coordinates corresponds to the number of points in a polymesh, but a polymesh does not have to have UVs assigned, in which case the value of this property is 0.
See Also

Reference

PolymeshTopology Class


PolymeshTopology Methods

The PolymeshTopology type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetFacet | Returns a definition of one facet
Public method | GetFacets | Returns a definitions of all facets of the polymesh
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetNormal | Returns a normal vector at the given index
Public method | GetNormals | Returns all normals assigned to the polymesh
Public method | GetPoint | Returns one point at the given index.
Public method | GetPoints | Returns all points of the polymesh.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetUV | Returns one UV coordinate at the given index.
Public method | GetUVs | Returns all UV coordinates assigned to the polymesh
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PolymeshTopology Class


PolymeshTopology.Dispose Method

PolymeshTopologyDispose Method

Releases all resources used by the PolymeshTopology

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

PolymeshTopology Class


PolymeshTopology.GetFacet Method

PolymeshTopologyGetFacet Method

Returns a definition of one facet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PolymeshFacet GetFacet(
    int idx
)
Public Function GetFacet (
    idx As Integer
) As PolymeshFacet
public:
PolymeshFacet^ GetFacet(
    int idx
)
member GetFacet :
        idx : int -> PolymeshFacet

Parameters

idx Int32
A zero-based index of the facet

Return Value

PolymeshFacet
An instance of PolymeshFacet that represents one facet defined by 3 vertices of the polymesh.
Exceptions
Exception | Condition
ArgumentException | The given value is not a valid index of a facet of the polymesh. A valid value is not negative and is smaller than the number of facets in the polymesh.
See Also

Reference

PolymeshTopology Class


PolymeshTopology.GetFacets Method

PolymeshTopologyGetFacets Method

Returns a definitions of all facets of the polymesh

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<PolymeshFacet> GetFacets()
Public Function GetFacets As IList(Of PolymeshFacet)
public:
IList<PolymeshFacet^>^ GetFacets()
member GetFacets : unit -> IList<PolymeshFacet>

Return Value

IList PolymeshFacet
An array of PolymeshFacet instances, each of which represents one facet defined by 3 vertices of the polymesh.
See Also

Reference

PolymeshTopology Class


PolymeshTopology.GetNormal Method

PolymeshTopologyGetNormal Method

Returns a normal vector at the given index

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ GetNormal(
    int idx
)
Public Function GetNormal (
    idx As Integer
) As XYZ
public:
XYZ^ GetNormal(
    int idx
)
member GetNormal :
        idx : int -> XYZ

Parameters

idx Int32
A zero-based index

Return Value

XYZ
XYZ value representing a normal vector
Exceptions
Exception | Condition
ArgumentException | The given value is not a valid index of a normal of the polymesh. A valid valure is not negative and is smaller than the number of normals in the polymesh.
See Also

Reference

PolymeshTopology Class


PolymeshTopology.GetNormals Method

PolymeshTopologyGetNormals Method

Returns all normals assigned to the polymesh

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<XYZ> GetNormals()
Public Function GetNormals As IList(Of XYZ)
public:
IList<XYZ^>^ GetNormals()
member GetNormals : unit -> IList<XYZ>

Return Value

IList XYZ
An array of XYZ values, each representing a normal vector
See Also

Reference

PolymeshTopology Class


PolymeshTopology.GetPoint Method

PolymeshTopologyGetPoint Method

Returns one point at the given index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ GetPoint(
    int idx
)
Public Function GetPoint (
    idx As Integer
) As XYZ
public:
XYZ^ GetPoint(
    int idx
)
member GetPoint :
        idx : int -> XYZ

Parameters

idx Int32
A zero-based index of a polymesh point

Return Value

XYZ
XYZ coordinates of the point
Exceptions
Exception | Condition
ArgumentException | The given value is not a valid index of a point of the polymesh. A valid valure is not negative and is smaller than the number of points in the polymesh.
See Also

Reference

PolymeshTopology Class


PolymeshTopology.GetPoints Method

PolymeshTopologyGetPoints Method

Returns all points of the polymesh.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<XYZ> GetPoints()
Public Function GetPoints As IList(Of XYZ)
public:
IList<XYZ^>^ GetPoints()
member GetPoints : unit -> IList<XYZ>

Return Value

IList XYZ
An array of XYZ coordinates
See Also

Reference

PolymeshTopology Class


PolymeshTopology.GetUV Method

PolymeshTopologyGetUV Method

Returns one UV coordinate at the given index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public UV GetUV(
    int idx
)
Public Function GetUV (
    idx As Integer
) As UV
public:
UV^ GetUV(
    int idx
)
member GetUV :
        idx : int -> UV

Parameters

idx Int32
A zero-based index of a UV coordinate

Return Value

UV
UV coordinates at the given index
Exceptions
Exception | Condition
ArgumentException | The given value is not a valid index of a UV coordinate of the polymesh. A valid valure is not negative and is smaller than the number of UV coordinates in the polymesh.
See Also

Reference

PolymeshTopology Class


PolymeshTopology.GetUVs Method

PolymeshTopologyGetUVs Method

Returns all UV coordinates assigned to the polymesh

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<UV> GetUVs()
Public Function GetUVs As IList(Of UV)
public:
IList<UV^>^ GetUVs()
member GetUVs : unit -> IList<UV>

Return Value

IList UV
An array of UV coordinates
See Also

Reference

PolymeshTopology Class


PreferredJunctionType Enumeration

Enumerated type representing the possible options for the preferred junction for a routine preference rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum PreferredJunctionType
Public Enumeration PreferredJunctionType
public enum class PreferredJunctionType
type PreferredJunctionType
Members
Member name | Value | Description
Tee | 0 | Tee junction type.
Tap | 1 | Tap junction type.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PreviewFamilyVisibilityMode Enumeration

Modes that control visibility of family elements depending on the currently applied Element Visibility Settings of a view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum PreviewFamilyVisibilityMode
Public Enumeration PreviewFamilyVisibilityMode
public enum class PreviewFamilyVisibilityMode
type PreviewFamilyVisibilityMode
Members
Member name | Value | Description
Off | 0 | Element Visibility is not applied. All family elements visible.
On | 1 | Element Visibility of a view is applied to show visible elements only. Elements that are cut by a reference plane will be shown with their respective cut geometry.
Uncut | 2 | Element Visibility of a view is applied to show elements visible if instance is not cut. Note that this state is only available in certain views, such as floor plan and ceilings.
Remarks
Values of this mode can be set or obtained for any view that supports it by accessing the [!:Autodesk::Revit::DB::TemporaryViewModes::PreviewFamilyVisibility] property.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PrimaryDesignOptionMemberFilter Class

A filter used to find elements contained in any primary design option of any design option set.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementSlowFilter
Autodesk.Revit.DBPrimaryDesignOptionMemberFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PrimaryDesignOptionMemberFilter : ElementSlowFilter
Public Class PrimaryDesignOptionMemberFilter
    Inherits ElementSlowFilter
public ref class PrimaryDesignOptionMemberFilter : public ElementSlowFilter
type PrimaryDesignOptionMemberFilter =
    class
        inherit ElementSlowFilter
    end

The PrimaryDesignOptionMemberFilter type exposes the following members.

Constructors
 | Name | Description
Public method | PrimaryDesignOptionMemberFilter | Constructs a new instance of a filter to match elements contained in any primary design option of any design option set.
Public method | PrimaryDesignOptionMemberFilter(Boolean) | Constructs a new instance of a filter to match elements contained in any primary design option of any design option set, with the option to invert the filter and find elements not contained in any primary design option of any design option set.
Top
Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This filter will only pass elements in a primary design option. It will not pass elements in the main model not associated to any design option. This filter is a slow filter. Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple this filter with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded.
Example
C#
VB
C++
F#
Copy
// Create a PrimaryDesignOptionMember filter to find all Walls contained within all primary design options
PrimaryDesignOptionMemberFilter filter = new PrimaryDesignOptionMemberFilter();

// Apply the filter to the elements in the active document
// Use shortcut command OfClass() to only find wall instances
FilteredElementCollector collector = new FilteredElementCollector(document);
ICollection<Element> wallsOfPrimaryOpt = collector.OfClass(typeof(Wall)).WherePasses(filter).ToElements();

// Find walls not contained within primary design options: Use inverted filter to match walls
PrimaryDesignOptionMemberFilter notPrimaryOptFilter = new PrimaryDesignOptionMemberFilter(true); // inverted filter
collector = new FilteredElementCollector(document);
ICollection<Element> notPrimaryDesignOptFounds =
    collector.OfClass(typeof(Wall)).WherePasses(notPrimaryOptFilter).ToElements();
' Create a PrimaryDesignOptionMember filter to find all Walls contained within all primary design options
Dim filter As New PrimaryDesignOptionMemberFilter()

' Apply the filter to the elements in the active document
' Use shortcut command OfClass() to only find wall instances
Dim collector As New FilteredElementCollector(document)
Dim wallsOfPrimaryOpt As ICollection(Of Element) = collector.OfClass(GetType(Wall)).WherePasses(filter).ToElements()

' Find walls not contained within primary design options: Use inverted filter to match walls
Dim notPrimaryOptFilter As New PrimaryDesignOptionMemberFilter(True)
' inverted filter
collector = New FilteredElementCollector(document)
Dim notPrimaryDesignOptFounds As ICollection(Of Element) = collector.OfClass(GetType(Wall)).WherePasses(notPrimaryOptFilter).ToElements()

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PrimaryDesignOptionMemberFilter Constructor

Overload List
 | Name | Description
Public method | PrimaryDesignOptionMemberFilter | Constructs a new instance of a filter to match elements contained in any primary design option of any design option set.
Public method | PrimaryDesignOptionMemberFilter(Boolean) | Constructs a new instance of a filter to match elements contained in any primary design option of any design option set, with the option to invert the filter and find elements not contained in any primary design option of any design option set.
Top
See Also

Reference

PrimaryDesignOptionMemberFilter Class


PrimaryDesignOptionMemberFilter Constructor

Constructs a new instance of a filter to match elements contained in any primary design option of any design option set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PrimaryDesignOptionMemberFilter()
Public Sub New
public:
PrimaryDesignOptionMemberFilter()
new : unit -> PrimaryDesignOptionMemberFilter
See Also

Reference

PrimaryDesignOptionMemberFilter Class
PrimaryDesignOptionMemberFilter Overload


PrimaryDesignOptionMemberFilter(Boolean) Constructor

Constructs a new instance of a filter to match elements contained in any primary design option of any design option set, with the option to invert the filter and find elements not contained in any primary design option of any design option set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PrimaryDesignOptionMemberFilter(
    bool inverted
)
Public Sub New (
    inverted As Boolean
)
public:
PrimaryDesignOptionMemberFilter(
    bool inverted
)
new :
        inverted : bool -> PrimaryDesignOptionMemberFilter

Parameters

inverted Boolean
True if the filter should match all elements which are not contained within a particular design option.
See Also

Reference

PrimaryDesignOptionMemberFilter Class
PrimaryDesignOptionMemberFilter Overload


PrimaryDesignOptionMemberFilter Properties

The PrimaryDesignOptionMemberFilter type exposes the following members.

Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
See Also

Reference

PrimaryDesignOptionMemberFilter Class


PrimaryDesignOptionMemberFilter Methods

The PrimaryDesignOptionMemberFilter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PrimaryDesignOptionMemberFilter Class


PrimarySizeCriterion Class

This class contains a size criterion for a RoutingPreferenceRule.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRoutingCriterionBase
Autodesk.Revit.DBPrimarySizeCriterion

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PrimarySizeCriterion : RoutingCriterionBase
Public Class PrimarySizeCriterion
    Inherits RoutingCriterionBase
public ref class PrimarySizeCriterion : public RoutingCriterionBase
type PrimarySizeCriterion =
    class
        inherit RoutingCriterionBase
    end

The PrimarySizeCriterion type exposes the following members.

Constructors
 | Name | Description
Public method | PrimarySizeCriterion | Constructs a PrimarySizeCriterion with a minimum and maximum size.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RoutingCriterionBase)
Public property | MaximumSize | The maximum size of this criterion.
Public property | MinimumSize | The minimum size of this criterion.
Top
Methods
 | Name | Description
 | All | Creates a criterion with a range of all sizes.
Public method | Dispose | (Inherited from RoutingCriterionBase)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqual | Verify if two criteria are the same. (Inherited from RoutingCriterionBase)
 | None | Creates a criterion with a range of no sizes.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PrimarySizeCriterion Constructor

Constructs a PrimarySizeCriterion with a minimum and maximum size.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PrimarySizeCriterion(
    double minimumSize,
    double maximumSize
)
Public Sub New (
    minimumSize As Double,
    maximumSize As Double
)
public:
PrimarySizeCriterion(
    double minimumSize,
    double maximumSize
)
new :
        minimumSize : float *
        maximumSize : float -> PrimarySizeCriterion

Parameters

minimumSize Double
maximumSize Double
See Also

Reference

PrimarySizeCriterion Class


PrimarySizeCriterion Properties

The PrimarySizeCriterion type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RoutingCriterionBase)
Public property | MaximumSize | The maximum size of this criterion.
Public property | MinimumSize | The minimum size of this criterion.
Top
See Also

Reference

PrimarySizeCriterion Class


PrimarySizeCriterion.MaximumSize Property

PrimarySizeCriterionMaximumSize Property

The maximum size of this criterion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double MaximumSize { get; set; }
Public Property MaximumSize As Double
    Get
    Set
public:
property double MaximumSize {
    double get ();
    void set (double value);
}
member MaximumSize : float with get, set

Property Value

Double
See Also

Reference

PrimarySizeCriterion Class


PrimarySizeCriterion.MinimumSize Property

PrimarySizeCriterionMinimumSize Property

The minimum size of this criterion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double MinimumSize { get; set; }
Public Property MinimumSize As Double
    Get
    Set
public:
property double MinimumSize {
    double get ();
    void set (double value);
}
member MinimumSize : float with get, set

Property Value

Double
See Also

Reference

PrimarySizeCriterion Class


PrimarySizeCriterion Methods

The PrimarySizeCriterion type exposes the following members.

Methods
 | Name | Description
 | All | Creates a criterion with a range of all sizes.
Public method | Dispose | (Inherited from RoutingCriterionBase)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqual | Verify if two criteria are the same. (Inherited from RoutingCriterionBase)
 | None | Creates a criterion with a range of no sizes.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PrimarySizeCriterion Class


PrimarySizeCriterion.All Method

PrimarySizeCriterionAll Method

Creates a criterion with a range of all sizes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static PrimarySizeCriterion All()
Public Shared Function All As PrimarySizeCriterion
public:
static PrimarySizeCriterion^ All()
static member All : unit -> PrimarySizeCriterion

Return Value

PrimarySizeCriterion
The new criterion.
See Also

Reference

PrimarySizeCriterion Class


PrimarySizeCriterion.None Method

PrimarySizeCriterionNone Method

Creates a criterion with a range of no sizes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static PrimarySizeCriterion None()
Public Shared Function None As PrimarySizeCriterion
public:
static PrimarySizeCriterion^ None()
static member None : unit -> PrimarySizeCriterion

Return Value

PrimarySizeCriterion
The new criterion.
See Also

Reference

PrimarySizeCriterion Class


PrinterResolution Enumeration

Controls the resolution level in rendering settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum PrinterResolution
Public Enumeration PrinterResolution
public enum class PrinterResolution
type PrinterResolution
Members
Member name | Value | Description
Low | 0 | Low printer resolution.
Medium | 1 | Medium printer resolution.
High | 2 | High printer resolution.
VeryHigh | 3 | VeryHigh printer resolution.
Remarks
It is applicable only when using printer resolution. The suitable resolution value for each resolution level is decided by default in Revit.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PrintManager Class

The PrintManager object is used to configure the global print settings.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBPrintManager

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PrintManager : APIObject
Public Class PrintManager
    Inherits APIObject
public ref class PrintManager : public APIObject
type PrintManager =
    class
        inherit APIObject
    end

The PrintManager type exposes the following members.

Properties
 | Name | Description
Public property | Collate | Indicates whether to collate of the current print.
Public property | CombinedFile | Indicates whether to combine multiple selected views/sheets into a single file.
Public property | CopyNumber | The copy number.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | IsVirtual | The virtual type in Autodesk Revit.
Public property | PaperSizes | Get all print sizes of current printer.
Public property | PaperSources | Get all print sources of current printer.
Public property | PrinterName | The name of the current printer.
Public property | PrintOrderReverse | Indicates whether to reverse the print order of the current print.
Public property | PrintRange | The print range.
Public property | PrintSetup | The PrintSetup which manages the print settings of current document.
Public property | PrintToFile | Indicates whether to print to file.
Public property | PrintToFileName | The file name when printing to file.
Public property | ViewSheetSetting | The ViewSheetSetting which manages the view/sheet set information of current document, and you can change the default view/sheet set for current project.
Top
Methods
 | Name | Description
Public method | Apply | Apply the local print settings to global for all documents.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SelectNewPrintDriver | Select a new printer.
Public method | SubmitPrint | Print the views and sheets defined in the current local PrintManager settings.
Public method | SubmitPrint(View) | Print a view with the current PrintManager settings.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Global print settings include PrintToFile, CombinedFile, PrintToFileName, PrintRange, CopyNumber, PrintOrderReverse, Collate. Once PrintManager is acquired from a document, changes of its global print setting properties are not automatically applied toward the global print setting. Should the local setting be used, the user needs to call the Apply method. If the user calls SubmitPrint methods, not only that printing will use the current state of properties of the (local) print manager, but the setting will also be applied to the global settings.
Example
C#
VB
C++
F#
Copy
private void CreateAndPrintViewSet(Document document, ViewSet viewSet)
{
    PrintManager printManager = document.PrintManager;
    printManager.PrintRange = PrintRange.Select;
    ViewSheetSetting viewSheetSetting = printManager.ViewSheetSetting;
    viewSheetSetting.CurrentViewSheetSet.Views = viewSet;
    viewSheetSetting.SaveAs("MyViewSet");
    printManager.CombinedFile = true;
    printManager.SubmitPrint();
}
Private Sub CreateAndPrintViewSet(document As Document, viewSet As ViewSet)
    Dim printManager As PrintManager = document.PrintManager
    printManager.PrintRange = PrintRange.[Select]
    Dim viewSheetSetting As ViewSheetSetting = printManager.ViewSheetSetting
    viewSheetSetting.CurrentViewSheetSet.Views = viewSet
    viewSheetSetting.SaveAs("MyViewSet")
    printManager.CombinedFile = True
    printManager.SubmitPrint()
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PrintManager Properties

The PrintManager type exposes the following members.

Properties
 | Name | Description
Public property | Collate | Indicates whether to collate of the current print.
Public property | CombinedFile | Indicates whether to combine multiple selected views/sheets into a single file.
Public property | CopyNumber | The copy number.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | IsVirtual | The virtual type in Autodesk Revit.
Public property | PaperSizes | Get all print sizes of current printer.
Public property | PaperSources | Get all print sources of current printer.
Public property | PrinterName | The name of the current printer.
Public property | PrintOrderReverse | Indicates whether to reverse the print order of the current print.
Public property | PrintRange | The print range.
Public property | PrintSetup | The PrintSetup which manages the print settings of current document.
Public property | PrintToFile | Indicates whether to print to file.
Public property | PrintToFileName | The file name when printing to file.
Public property | ViewSheetSetting | The ViewSheetSetting which manages the view/sheet set information of current document, and you can change the default view/sheet set for current project.
Top
See Also

Reference

PrintManager Class


PrintManager.Collate Property

PrintManagerCollate Property

Indicates whether to collate of the current print.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Collate { get; set; }
Public Property Collate As Boolean
    Get
    Set
public:
property bool Collate {
    bool get ();
    void set (bool value);
}
member Collate : bool with get, set

Property Value

Boolean
Exceptions
Exception | Condition
InvalidOperationException | Thrown when there is only one view or only one copy in the current settings.
Remarks
The value of this property represents the global print setting property used for print operations on any document. In order to make a change to this property, after setting it call the Apply() method, or one of the SubmitPrint() methods, which save the local changes as modifications to the global print settings.
See Also

Reference

PrintManager Class


PrintManager.CombinedFile Property

PrintManagerCombinedFile Property

Indicates whether to combine multiple selected views/sheets into a single file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CombinedFile { get; set; }
Public Property CombinedFile As Boolean
    Get
    Set
public:
property bool CombinedFile {
    bool get ();
    void set (bool value);
}
member CombinedFile : bool with get, set

Property Value

Boolean
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the current printer is not a virtual printer.
Remarks
The value of this property represents the global print setting property used for print operations on any document. In order to make a change to this property, after setting it call the Apply() method, or one of the SubmitPrint() methods, which save the local changes as modifications to the global print settings.
See Also

Reference

PrintManager Class


PrintManager.CopyNumber Property

PrintManagerCopyNumber Property

The copy number.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int CopyNumber { get; set; }
Public Property CopyNumber As Integer
    Get
    Set
public:
property int CopyNumber {
    int get ();
    void set (int value);
}
member CopyNumber : int with get, set

Property Value

Int32
Remarks
Returns 0 if current printer does not support CopyNumber property. The value of this property represents the global print setting property used for print operations on any document. In order to make a change to this property, after setting it call the Apply() method, or one of the SubmitPrint() methods, which save the local changes as modifications to the global print settings.
See Also

Reference

PrintManager Class


PrintManager.IsVirtual Property

PrintManagerIsVirtual Property

The virtual type in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VirtualPrinterType IsVirtual { get; }
Public ReadOnly Property IsVirtual As VirtualPrinterType
    Get
public:
property VirtualPrinterType IsVirtual {
    VirtualPrinterType get ();
}
member IsVirtual : VirtualPrinterType with get

Property Value

VirtualPrinterType
See Also

Reference

PrintManager Class


PrintManager.PaperSizes Property

PrintManagerPaperSizes Property

Get all print sizes of current printer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PaperSizeSet PaperSizes { get; }
Public ReadOnly Property PaperSizes As PaperSizeSet
    Get
public:
property PaperSizeSet^ PaperSizes {
    PaperSizeSet^ get ();
}
member PaperSizes : PaperSizeSet with get

Property Value

PaperSizeSet
Remarks
These are the valid paper sizes for the current printer.
See Also

Reference

PrintManager Class


PrintManager.PaperSources Property

PrintManagerPaperSources Property

Get all print sources of current printer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PaperSourceSet PaperSources { get; }
Public ReadOnly Property PaperSources As PaperSourceSet
    Get
public:
property PaperSourceSet^ PaperSources {
    PaperSourceSet^ get ();
}
member PaperSources : PaperSourceSet with get

Property Value

PaperSourceSet
Remarks
These are the valid paper source for the current printer.
See Also

Reference

PrintManager Class


PrintManager.PrinterName Property

PrintManagerPrinterName Property

The name of the current printer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string PrinterName { get; }
Public ReadOnly Property PrinterName As String
    Get
public:
property String^ PrinterName {
    String^ get ();
}
member PrinterName : string with get

Property Value

String
See Also

Reference

PrintManager Class


PrintManager.PrintOrderReverse Property

PrintManagerPrintOrderReverse Property

Indicates whether to reverse the print order of the current print.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool PrintOrderReverse { get; set; }
Public Property PrintOrderReverse As Boolean
    Get
    Set
public:
property bool PrintOrderReverse {
    bool get ();
    void set (bool value);
}
member PrintOrderReverse : bool with get, set

Property Value

Boolean
Remarks
The value of this property represents the global print setting property used for print operations on any document. In order to make a change to this property, after setting it call the Apply() method, or one of the SubmitPrint() methods, which save the local changes as modifications to the global print settings.
See Also

Reference

PrintManager Class


PrintManager.PrintRange Property

PrintManagerPrintRange Property

The print range.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PrintRange PrintRange { get; set; }
Public Property PrintRange As PrintRange
    Get
    Set
public:
property PrintRange PrintRange {
    PrintRange get ();
    void set (PrintRange value);
}
member PrintRange : PrintRange with get, set

Property Value

PrintRange
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown when the argument is out of range.
Remarks
The value of this property represents the global print setting property used for print operations on any document. In order to make a change to this property, after setting it call the Apply() method, or one of the SubmitPrint() methods, which save the local changes as modifications to the global print settings.
See Also

Reference

PrintManager Class


PrintManager.PrintSetup Property

PrintManagerPrintSetup Property

The PrintSetup which manages the print settings of current document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PrintSetup PrintSetup { get; }
Public ReadOnly Property PrintSetup As PrintSetup
    Get
public:
property PrintSetup^ PrintSetup {
    PrintSetup^ get ();
}
member PrintSetup : PrintSetup with get

Property Value

PrintSetup
Remarks
PrintSetup is an interface cluster just like File->Print->Settings->Setup or File->Print Setup in UI.
See Also

Reference

PrintManager Class


PrintManager.PrintToFile Property

PrintManagerPrintToFile Property

Indicates whether to print to file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool PrintToFile { get; set; }
Public Property PrintToFile As Boolean
    Get
    Set
public:
property bool PrintToFile {
    bool get ();
    void set (bool value);
}
member PrintToFile : bool with get, set

Property Value

Boolean
Remarks
The value of this property represents the global print setting property used for print operations on any document. In order to make a change to this property, after setting it call the Apply() method, or one of the SubmitPrint() methods, which save the local changes as modifications to the global print settings.
See Also

Reference

PrintManager Class


PrintManager.PrintToFileName Property

PrintManagerPrintToFileName Property

The file name when printing to file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string PrintToFileName { get; set; }
Public Property PrintToFileName As String
    Get
    Set
public:
property String^ PrintToFileName {
    String^ get ();
    void set (String^ value);
}
member PrintToFileName : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input file name is .
ArgumentException | Thrown when the input file name is an invalid string.
Remarks

A default file name will be used when the PrintToFile is true and PrintToFileName is not be set.

The value of this property represents the global print setting property used for print operations on any document. In order to make a change to this property, after setting it call the Apply() method, or one of the SubmitPrint() methods, which save the local changes as modifications to the global print settings.
See Also

Reference

PrintManager Class


PrintManager.ViewSheetSetting Property

PrintManagerViewSheetSetting Property

The ViewSheetSetting which manages the view/sheet set information of current document, and you can change the default view/sheet set for current project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ViewSheetSetting ViewSheetSetting { get; }
Public ReadOnly Property ViewSheetSetting As ViewSheetSetting
    Get
public:
property ViewSheetSetting^ ViewSheetSetting {
    ViewSheetSetting^ get ();
}
member ViewSheetSetting : ViewSheetSetting with get

Property Value

ViewSheetSetting
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the print range is not selected views/sheets.
See Also

Reference

PrintManager Class


PrintManager Methods

The PrintManager type exposes the following members.

Methods
 | Name | Description
Public method | Apply | Apply the local print settings to global for all documents.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SelectNewPrintDriver | Select a new printer.
Public method | SubmitPrint | Print the views and sheets defined in the current local PrintManager settings.
Public method | SubmitPrint(View) | Print a view with the current PrintManager settings.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PrintManager Class


PrintManager.Apply Method

PrintManagerApply Method

Apply the local print settings to global for all documents.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Apply()
Public Sub Apply
public:
void Apply()
member Apply : unit -> unit
Exceptions
Exception | Condition
InvalidOperationException | Thrown when this operation is not allowed in the current application mode, or the print resource is occupied by others.
Remarks
This method will change the settings for the current printer to match what is set in the Print Manager. When the user attempts to print with this printer in the future, the changes made by the API session will be visible.
See Also

Reference

PrintManager Class


PrintManager.SelectNewPrintDriver Method

PrintManagerSelectNewPrintDriver Method

Select a new printer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SelectNewPrintDriver(
    string strPrinterName
)
Public Sub SelectNewPrintDriver (
    strPrinterName As String
)
public:
void SelectNewPrintDriver(
    String^ strPrinterName
)
member SelectNewPrintDriver :
        strPrinterName : string -> unit

Parameters

strPrinterName String
The name string of new printer.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument-strPrinterName-is .
InvalidOperationException | Thrown when the assigned new printer is invalid, or the print resource is occupied by others.
Remarks
This property is the global print setting property for all documents.
See Also

Reference

PrintManager Class


PrintManager.SubmitPrint Method

PrintManagerSubmitPrint Method

Print with the current PrintManager settings.
Overload List
 | Name | Description
Public method | SubmitPrint | Print the views and sheets defined in the current local PrintManager settings.
Public method | SubmitPrint(View) | Print a view with the current PrintManager settings.
Top
See Also

Reference

PrintManager Class


PrintManager.SubmitPrint Method

PrintManagerSubmitPrint Method

Print the views and sheets defined in the current local PrintManager settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SubmitPrint()
Public Function SubmitPrint As Boolean
public:
bool SubmitPrint()
member SubmitPrint : unit -> bool

Return Value

Boolean
True if successful, otherwise False.
Exceptions
Exception | Condition
InvalidOperationException | Thrown when this operation is not allowed in the current application mode, or the print resource is occupied by others.
Remarks
PrintManager will apply the local settings to global and print the view/views/sheets which user defined with the current settings.
See Also

Reference

PrintManager Class
SubmitPrint Overload


PrintManager.SubmitPrint(View) Method

PrintManagerSubmitPrint(View) Method

Print a view with the current PrintManager settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SubmitPrint(
    View view
)
Public Function SubmitPrint (
    view As View
) As Boolean
public:
bool SubmitPrint(
    View^ view
)
member SubmitPrint :
        view : View -> bool

Parameters

view View
The User-assigned view.

Return Value

Boolean
True if successful, otherwise False.
Exceptions
Exception | Condition
InvalidOperationException | Thrown when this operation is not allowed in the current application mode, or the print resource is occupied by others.
Remarks
PrintManager will apply the local settings to global and print the user-assigned view with the current settings.
See Also

Reference

PrintManager Class
SubmitPrint Overload


PrintParameters Class

An object that contains settings used for printing the document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBPrintParameters

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PrintParameters : APIObject
Public Class PrintParameters
    Inherits APIObject
public ref class PrintParameters : public APIObject
type PrintParameters =
    class
        inherit APIObject
    end

The PrintParameters type exposes the following members.

Properties
 | Name | Description
Public property | ColorDepth | The color depth type.
Public property | HiddenLineViews | The hidden line views type.
Public property | HideCropBoundaries | Indicates whether to hide crop boundaries when printing.
Public property | HideReforWorkPlanes | Indicates whether to hide reference/work planes when printing.
Public property | HideScopeBoxes | Indicates whether to hide scope boxes when printing.
Public property | HideUnreferencedViewTags | Indicates whether to hide unreferenced view tags when printing.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | MarginType | The print margin type.
Public property | MaskCoincidentLines | Indicates whether to mask coincident lines when printing.
Public property | OriginOffsetX | The User defined X value of offset from left bottom corner. Unit is feet.
Public property | OriginOffsetY | The User defined Y value of offset from left bottom corner. Unit is feet.
Public property | PageOrientation | The Page Orientation of the Print Setting.
Public property | PaperPlacement | The paper placement type.
Public property | PaperSize | The page size.
Public property | PaperSource | The page source.
Public property | RasterQuality | The raster quality type.
Public property | ReplaceHalftoneWithThinLines | Indicates whether to replace halftone with thin lines when printing.
Public property | UserDefinedMarginX | Obsolete. The User defined X value of offset from left bottom corner. Unit is inch.
Public property | UserDefinedMarginY | Obsolete. The User defined Y value of offset from left bottom corner. Unit is inch.
Public property | ViewLinksinBlue | Indicates whether to view links in blue when printing.
Public property | Zoom | The zoom value to a percentage of the original size.
Public property | ZoomType | The zoom type.
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PrintParameters Properties

The PrintParameters type exposes the following members.

Properties
 | Name | Description
Public property | ColorDepth | The color depth type.
Public property | HiddenLineViews | The hidden line views type.
Public property | HideCropBoundaries | Indicates whether to hide crop boundaries when printing.
Public property | HideReforWorkPlanes | Indicates whether to hide reference/work planes when printing.
Public property | HideScopeBoxes | Indicates whether to hide scope boxes when printing.
Public property | HideUnreferencedViewTags | Indicates whether to hide unreferenced view tags when printing.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | MarginType | The print margin type.
Public property | MaskCoincidentLines | Indicates whether to mask coincident lines when printing.
Public property | OriginOffsetX | The User defined X value of offset from left bottom corner. Unit is feet.
Public property | OriginOffsetY | The User defined Y value of offset from left bottom corner. Unit is feet.
Public property | PageOrientation | The Page Orientation of the Print Setting.
Public property | PaperPlacement | The paper placement type.
Public property | PaperSize | The page size.
Public property | PaperSource | The page source.
Public property | RasterQuality | The raster quality type.
Public property | ReplaceHalftoneWithThinLines | Indicates whether to replace halftone with thin lines when printing.
Public property | UserDefinedMarginX | Obsolete. The User defined X value of offset from left bottom corner. Unit is inch.
Public property | UserDefinedMarginY | Obsolete. The User defined Y value of offset from left bottom corner. Unit is inch.
Public property | ViewLinksinBlue | Indicates whether to view links in blue when printing.
Public property | Zoom | The zoom value to a percentage of the original size.
Public property | ZoomType | The zoom type.
Top
See Also

Reference

PrintParameters Class


PrintParameters.ColorDepth Property

PrintParametersColorDepth Property

The color depth type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ColorDepthType ColorDepth { get; set; }
Public Property ColorDepth As ColorDepthType
    Get
    Set
public:
property ColorDepthType ColorDepth {
    ColorDepthType get ();
    void set (ColorDepthType value);
}
member ColorDepth : ColorDepthType with get, set

Property Value

ColorDepthType
See Also

Reference

PrintParameters Class


PrintParameters.HiddenLineViews Property

PrintParametersHiddenLineViews Property

The hidden line views type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public HiddenLineViewsType HiddenLineViews { get; set; }
Public Property HiddenLineViews As HiddenLineViewsType
    Get
    Set
public:
property HiddenLineViewsType HiddenLineViews {
    HiddenLineViewsType get ();
    void set (HiddenLineViewsType value);
}
member HiddenLineViews : HiddenLineViewsType with get, set

Property Value

HiddenLineViewsType
See Also

Reference

PrintParameters Class


PrintParameters.HideCropBoundaries Property

PrintParametersHideCropBoundaries Property

Indicates whether to hide crop boundaries when printing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HideCropBoundaries { get; set; }
Public Property HideCropBoundaries As Boolean
    Get
    Set
public:
property bool HideCropBoundaries {
    bool get ();
    void set (bool value);
}
member HideCropBoundaries : bool with get, set

Property Value

Boolean
See Also

Reference

PrintParameters Class


PrintParameters.HideReforWorkPlanes Property

PrintParametersHideReforWorkPlanes Property

Indicates whether to hide reference/work planes when printing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HideReforWorkPlanes { get; set; }
Public Property HideReforWorkPlanes As Boolean
    Get
    Set
public:
property bool HideReforWorkPlanes {
    bool get ();
    void set (bool value);
}
member HideReforWorkPlanes : bool with get, set

Property Value

Boolean
See Also

Reference

PrintParameters Class


PrintParameters.HideScopeBoxes Property

PrintParametersHideScopeBoxes Property

Indicates whether to hide scope boxes when printing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HideScopeBoxes { get; set; }
Public Property HideScopeBoxes As Boolean
    Get
    Set
public:
property bool HideScopeBoxes {
    bool get ();
    void set (bool value);
}
member HideScopeBoxes : bool with get, set

Property Value

Boolean
See Also

Reference

PrintParameters Class


PrintParameters.HideUnreferencedViewTags Property

PrintParametersHideUnreferencedViewTags Property

Indicates whether to hide unreferenced view tags when printing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HideUnreferencedViewTags { get; set; }
Public Property HideUnreferencedViewTags As Boolean
    Get
    Set
public:
property bool HideUnreferencedViewTags {
    bool get ();
    void set (bool value);
}
member HideUnreferencedViewTags : bool with get, set

Property Value

Boolean
See Also

Reference

PrintParameters Class


PrintParameters.MarginType Property

PrintParametersMarginType Property

The print margin type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MarginType MarginType { get; set; }
Public Property MarginType As MarginType
    Get
    Set
public:
property MarginType MarginType {
    MarginType get ();
    void set (MarginType value);
}
member MarginType : MarginType with get, set

Property Value

MarginType
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown when the input argument is out of range.
InvalidOperationException | Thrown if the PaperPlacement is not Margins type.
See Also

Reference

PrintParameters Class


PrintParameters.MaskCoincidentLines Property

PrintParametersMaskCoincidentLines Property

Indicates whether to mask coincident lines when printing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool MaskCoincidentLines { get; set; }
Public Property MaskCoincidentLines As Boolean
    Get
    Set
public:
property bool MaskCoincidentLines {
    bool get ();
    void set (bool value);
}
member MaskCoincidentLines : bool with get, set

Property Value

Boolean
See Also

Reference

PrintParameters Class


PrintParameters.OriginOffsetX Property

PrintParametersOriginOffsetX Property

The User defined X value of offset from left bottom corner. Unit is feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double OriginOffsetX { get; set; }
Public Property OriginOffsetX As Double
    Get
    Set
public:
property double OriginOffsetX {
    double get ();
    void set (double value);
}
member OriginOffsetX : float with get, set

Property Value

Double
Exceptions
Exception | Condition
InvalidOperationException | Thrown if PaperPlacement is not Margins and MarginType is not User defined type.
See Also

Reference

PrintParameters Class


PrintParameters.OriginOffsetY Property

PrintParametersOriginOffsetY Property

The User defined Y value of offset from left bottom corner. Unit is feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double OriginOffsetY { get; set; }
Public Property OriginOffsetY As Double
    Get
    Set
public:
property double OriginOffsetY {
    double get ();
    void set (double value);
}
member OriginOffsetY : float with get, set

Property Value

Double
Exceptions
Exception | Condition
InvalidOperationException | Thrown if PaperPlacement is not Margins and MarginType is not User defined type.
See Also

Reference

PrintParameters Class


PrintParameters.PageOrientation Property

PrintParametersPageOrientation Property

The Page Orientation of the Print Setting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PageOrientationType PageOrientation { get; set; }
Public Property PageOrientation As PageOrientationType
    Get
    Set
public:
property PageOrientationType PageOrientation {
    PageOrientationType get ();
    void set (PageOrientationType value);
}
member PageOrientation : PageOrientationType with get, set

Property Value

PageOrientationType
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown when the input argument is out of range.
See Also

Reference

PrintParameters Class


PrintParameters.PaperPlacement Property

PrintParametersPaperPlacement Property

The paper placement type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PaperPlacementType PaperPlacement { get; set; }
Public Property PaperPlacement As PaperPlacementType
    Get
    Set
public:
property PaperPlacementType PaperPlacement {
    PaperPlacementType get ();
    void set (PaperPlacementType value);
}
member PaperPlacement : PaperPlacementType with get, set

Property Value

PaperPlacementType
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown when the input argument is out of range.
See Also

Reference

PrintParameters Class


PrintParameters.PaperSize Property

PrintParametersPaperSize Property

The page size.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PaperSize PaperSize { get; set; }
Public Property PaperSize As PaperSize
    Get
    Set
public:
property PaperSize^ PaperSize {
    PaperSize^ get ();
    void set (PaperSize^ value);
}
member PaperSize : PaperSize with get, set

Property Value

PaperSize
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument is .
ArgumentException | Thrown when the input argument is invalid for current printer.
Remarks
User can select the candidate via PaperSizes and then set the Page source of the Print Setting.
See Also

Reference

PrintParameters Class


PrintParameters.PaperSource Property

PrintParametersPaperSource Property

The page source.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PaperSource PaperSource { get; set; }
Public Property PaperSource As PaperSource
    Get
    Set
public:
property PaperSource^ PaperSource {
    PaperSource^ get ();
    void set (PaperSource^ value);
}
member PaperSource : PaperSource with get, set

Property Value

PaperSource
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument is .
ArgumentException | Thrown when the input argument is invalid for current printer.
Remarks
User can select the candidate via PaperSources and then set the Page source of the Print Setting.
See Also

Reference

PrintParameters Class


PrintParameters.RasterQuality Property

PrintParametersRasterQuality Property

The raster quality type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RasterQualityType RasterQuality { get; set; }
Public Property RasterQuality As RasterQualityType
    Get
    Set
public:
property RasterQualityType RasterQuality {
    RasterQualityType get ();
    void set (RasterQualityType value);
}
member RasterQuality : RasterQualityType with get, set

Property Value

RasterQualityType
See Also

Reference

PrintParameters Class


PrintParameters.ReplaceHalftoneWithThinLines Property

PrintParametersReplaceHalftoneWithThinLines Property

Indicates whether to replace halftone with thin lines when printing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ReplaceHalftoneWithThinLines { get; set; }
Public Property ReplaceHalftoneWithThinLines As Boolean
    Get
    Set
public:
property bool ReplaceHalftoneWithThinLines {
    bool get ();
    void set (bool value);
}
member ReplaceHalftoneWithThinLines : bool with get, set

Property Value

Boolean
See Also

Reference

PrintParameters Class


PrintParameters.UserDefinedMarginX Property

PrintParametersUserDefinedMarginX Property

Note: This API is now obsolete.

The User defined X value of offset from left bottom corner. Unit is inch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This property is obsolete. Use OriginOffsetX instead.")]
public double UserDefinedMarginX { get; set; }
<ObsoleteAttribute("This property is obsolete. Use OriginOffsetX instead.")>
Public Property UserDefinedMarginX As Double
    Get
    Set
public:
[ObsoleteAttribute(L"This property is obsolete. Use OriginOffsetX instead.")]
property double UserDefinedMarginX {
    double get ();
    void set (double value);
}
[<ObsoleteAttribute("This property is obsolete. Use OriginOffsetX instead.")>]
member UserDefinedMarginX : float with get, set

Property Value

Double
Exceptions
Exception | Condition
InvalidOperationException | Thrown if PaperPlacement is not Margins and MarginType is not User defined type.
See Also

Reference

PrintParameters Class


PrintParameters.UserDefinedMarginY Property

PrintParametersUserDefinedMarginY Property

Note: This API is now obsolete.

The User defined Y value of offset from left bottom corner. Unit is inch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This property is obsolete. Use OriginOffsetY instead.")]
public double UserDefinedMarginY { get; set; }
<ObsoleteAttribute("This property is obsolete. Use OriginOffsetY instead.")>
Public Property UserDefinedMarginY As Double
    Get
    Set
public:
[ObsoleteAttribute(L"This property is obsolete. Use OriginOffsetY instead.")]
property double UserDefinedMarginY {
    double get ();
    void set (double value);
}
[<ObsoleteAttribute("This property is obsolete. Use OriginOffsetY instead.")>]
member UserDefinedMarginY : float with get, set

Property Value

Double
Exceptions
Exception | Condition
InvalidOperationException | Thrown if PaperPlacement is not Margins and MarginType is not User defined type.
See Also

Reference

PrintParameters Class


PrintParameters.ViewLinksinBlue Property

PrintParametersViewLinksinBlue Property

Indicates whether to view links in blue when printing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ViewLinksinBlue { get; set; }
Public Property ViewLinksinBlue As Boolean
    Get
    Set
public:
property bool ViewLinksinBlue {
    bool get ();
    void set (bool value);
}
member ViewLinksinBlue : bool with get, set

Property Value

Boolean
See Also

Reference

PrintParameters Class


PrintParameters.Zoom Property

PrintParametersZoom Property

The zoom value to a percentage of the original size.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Zoom { get; set; }
Public Property Zoom As Integer
    Get
    Set
public:
property int Zoom {
    int get ();
    void set (int value);
}
member Zoom : int with get, set

Property Value

Int32
Exceptions
Exception | Condition
InvalidOperationException | Thrown if current ZoomType is not Zoom type.
ArgumentOutOfRangeException | Thrown if input zoom value less than 1.
See Also

Reference

PrintParameters Class


PrintParameters.ZoomType Property

PrintParametersZoomType Property

The zoom type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ZoomType ZoomType { get; set; }
Public Property ZoomType As ZoomType
    Get
    Set
public:
property ZoomType ZoomType {
    ZoomType get ();
    void set (ZoomType value);
}
member ZoomType : ZoomType with get, set

Property Value

ZoomType
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown when the input argument is out of range.
See Also

Reference

PrintParameters Class


PrintParameters Methods

The PrintParameters type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PrintParameters Class


PrintRange Enumeration

An enumerated type listing all Print Range types of Print.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum PrintRange
Public Enumeration PrintRange
public enum class PrintRange
type PrintRange
Members
Member name | Value | Description
Current | 0 | A range that represents just the currently active view.
Visible | 1 | Visible portion of current window.
Select | 2 | A range that represents a list of selected views and sheets.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PrintSetting Class

Represents the Print Setup (Application Menu->Print->Print Setup) within Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBPrintSetting

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PrintSetting : Element,
    IPrintSetting
Public Class PrintSetting
    Inherits Element
    Implements IPrintSetting
public ref class PrintSetting : public Element,
    IPrintSetting
type PrintSetting =
    class
        inherit Element
        interface IPrintSetting
    end

The PrintSetting type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Returns the Name of Print Setup. (Overrides ElementName)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | PrintParameters | Returns the Parameters of Print Setup.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PrintSetting Properties

The PrintSetting type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Returns the Name of Print Setup. (Overrides ElementName)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | PrintParameters | Returns the Parameters of Print Setup.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

PrintSetting Class


PrintSetting.Name Property

PrintSettingName Property

Returns the Name of Print Setup.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string Name { get; set; }
Public Overrides Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

String
Remarks
Retrieve/set the name of Print Setup.
See Also

Reference

PrintSetting Class


PrintSetting.PrintParameters Property

PrintSettingPrintParameters Property

Returns the Parameters of Print Setup.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual PrintParameters PrintParameters { get; }
Public Overridable ReadOnly Property PrintParameters As PrintParameters
    Get
public:
virtual property PrintParameters^ PrintParameters {
    PrintParameters^ get ();
}
abstract PrintParameters : PrintParameters with get
override PrintParameters : PrintParameters with get

Property Value

PrintParameters

Implements

IPrintSettingPrintParameters
Remarks
The Parameters of Print Setup. Refer to the Print Setup dialog in Revit for details.
See Also

Reference

PrintSetting Class


PrintSetting Methods

The PrintSetting type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PrintSetting Class


PrintSetup Class

Represents the Print Setup (Application Menu->Print->Print Setup) within Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBPrintSetup

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PrintSetup : APIObject
Public Class PrintSetup
    Inherits APIObject
public ref class PrintSetup : public APIObject
type PrintSetup =
    class
        inherit APIObject
    end

The PrintSetup type exposes the following members.

Properties
 | Name | Description
Public property | CurrentPrintSetting | The current Print Setting of Print Setup.
Public property | InSession | The in-session Print Setting of Print Setup.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Delete | Delete the current print setting, and make the In-Session setting as the current one.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Rename | Rename the current print setting with the specified name.
Public method | Revert | Revert the current print setting.
Public method | Save | Save the changes for the current print setting.
Public method | SaveAs | Save the current print setting to another print setting with the specified name.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The Print Setup object can only get from PrintManager object.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PrintSetup Properties

The PrintSetup type exposes the following members.

Properties
 | Name | Description
Public property | CurrentPrintSetting | The current Print Setting of Print Setup.
Public property | InSession | The in-session Print Setting of Print Setup.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

PrintSetup Class


PrintSetup.CurrentPrintSetting Property

PrintSetupCurrentPrintSetting Property

The current Print Setting of Print Setup.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IPrintSetting CurrentPrintSetting { get; set; }
Public Property CurrentPrintSetting As IPrintSetting
    Get
    Set
public:
property IPrintSetting^ CurrentPrintSetting {
    IPrintSetting^ get ();
    void set (IPrintSetting^ value);
}
member CurrentPrintSetting : IPrintSetting with get, set

Property Value

IPrintSetting
See Also

Reference

PrintSetup Class


PrintSetup.InSession Property

PrintSetupInSession Property

The in-session Print Setting of Print Setup.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public InSessionPrintSetting InSession { get; }
Public ReadOnly Property InSession As InSessionPrintSetting
    Get
public:
property InSessionPrintSetting^ InSession {
    InSessionPrintSetting^ get ();
}
member InSession : InSessionPrintSetting with get

Property Value

InSessionPrintSetting
See Also

Reference

PrintSetup Class


PrintSetup Methods

The PrintSetup type exposes the following members.

Methods
 | Name | Description
Public method | Delete | Delete the current print setting, and make the In-Session setting as the current one.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Rename | Rename the current print setting with the specified name.
Public method | Revert | Revert the current print setting.
Public method | Save | Save the changes for the current print setting.
Public method | SaveAs | Save the current print setting to another print setting with the specified name.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PrintSetup Class


PrintSetup.Delete Method

PrintSetupDelete Method

Delete the current print setting, and make the In-Session setting as the current one.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Delete()
Public Function Delete As Boolean
public:
bool Delete()
member Delete : unit -> bool

Return Value

Boolean
False if Delete operation fails, otherwise true.
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the current print setting is In-Session.
See Also

Reference

PrintSetup Class


PrintSetup.Rename Method

PrintSetupRename Method

Rename the current print setting with the specified name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Rename(
    string newName
)
Public Function Rename (
    newName As String
) As Boolean
public:
bool Rename(
    String^ newName
)
member Rename :
        newName : string -> bool

Parameters

newName String
print setting name to be renamed as.

Return Value

Boolean
False if Rename operation fails, otherwise true.
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the input newName already exists in current print setting list.
See Also

Reference

PrintSetup Class


PrintSetup.Revert Method

PrintSetupRevert Method

Revert the current print setting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Revert()
Public Sub Revert
public:
void Revert()
member Revert : unit -> unit
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the current print setting is In-Session.
See Also

Reference

PrintSetup Class


PrintSetup.Save Method

PrintSetupSave Method

Save the changes for the current print setting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Save()
Public Function Save As Boolean
public:
bool Save()
member Save : unit -> bool

Return Value

Boolean
False if save operation fails, otherwise True.
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the current print setting is In-Session or the current print setting has not changed.
See Also

Reference

PrintSetup Class


PrintSetup.SaveAs Method

PrintSetupSaveAs Method

Save the current print setting to another print setting with the specified name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SaveAs(
    string newName
)
Public Function SaveAs (
    newName As String
) As Boolean
public:
bool SaveAs(
    String^ newName
)
member SaveAs :
        newName : string -> bool

Parameters

newName String
print setting name to be saved as.

Return Value

Boolean
False if Save As operation fails, otherwise true.
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the input newName already exists in current print setting list.
See Also

Reference

PrintSetup Class


Profile Class

A geometric profile consisting of a loop of curves.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGeometryObject
Autodesk.Revit.DBProfile

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Profile : GeometryObject
Public Class Profile
    Inherits GeometryObject
public ref class Profile : public GeometryObject
type Profile =
    class
        inherit GeometryObject
    end

The Profile type exposes the following members.

Properties
 | Name | Description
Public property | Curves | Retrieve the curves that make up the boundary of the profile.
Public property | Filled | Get or set whether the profile is filled.
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject)
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Transformed | Transforms this profile and returns the result.
Public property | Visibility | The visibility. (Inherited from GeometryObject)
Top
Methods
 | Name | Description
Public method | Clone | Returns a copy of this profile.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The profile may be filled.
Example
C#
VB
C++
F#
Copy
public void GetProfile(Element element)
{
    string messageInfo = "Profile : ";
    if (element is FamilyInstance)
    {
        FamilyInstance beam = element as FamilyInstance;
        if (beam.StructuralType == StructuralType.Beam)
        {
            // Get swept profile
            Autodesk.Revit.DB.SweptProfile sweptProfile = beam.GetSweptProfile();
            Autodesk.Revit.DB.Profile profile = sweptProfile.GetSweptProfile();
            // Get swept profile curves size
            messageInfo += "\nSelection name : " + beam.Name;
            messageInfo += "\nSwept Profile Driving Curve size is " + profile.Curves.Size;
            messageInfo += "\nProfile is filled :  " + profile.Filled;
            if (!profile.IsReadOnly)
            {
                profile.Filled = !profile.Filled;
                messageInfo += "\nProfile is filled after setting:  " + profile.Filled;
            }
            TaskDialog.Show("Revit",messageInfo);
        }
    }
}
Public Sub GetProfile(element As Element)
    Dim messageInfo As String = "Profile : "
    If TypeOf element Is FamilyInstance Then
        Dim beam As FamilyInstance = TryCast(element, FamilyInstance)
        If beam.StructuralType = StructuralType.Beam Then
       ' Get swept profile
       Dim sweptProfile As Autodesk.Revit.DB.SweptProfile = beam.GetSweptProfile()
            Dim profile As Autodesk.Revit.DB.Profile = sweptProfile.GetSweptProfile()
       ' Get swept profile curves size
            messageInfo += vbLf & "Selection name : " + beam.Name
            messageInfo += vbLf & "Swept Profile Driving Curve size is " + profile.Curves.Size
            messageInfo += vbLf & "Profile is filled :  " + profile.Filled
            If Not profile.IsReadOnly Then
                profile.Filled = Not profile.Filled
                messageInfo += vbLf & "Profile is filled after setting:  " + profile.Filled
            End If
            TaskDialog.Show("Revit", messageInfo)
        End If
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Profile Properties

The Profile type exposes the following members.

Properties
 | Name | Description
Public property | Curves | Retrieve the curves that make up the boundary of the profile.
Public property | Filled | Get or set whether the profile is filled.
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject)
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Transformed | Transforms this profile and returns the result.
Public property | Visibility | The visibility. (Inherited from GeometryObject)
Top
See Also

Reference

Profile Class


Profile.Curves Property

ProfileCurves Property

Retrieve the curves that make up the boundary of the profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurveArray Curves { get; }
Public ReadOnly Property Curves As CurveArray
    Get
public:
property CurveArray^ Curves {
    CurveArray^ get ();
}
member Curves : CurveArray with get

Property Value

CurveArray
See Also

Reference

Profile Class


Profile.Filled Property

ProfileFilled Property

Get or set whether the profile is filled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Filled { get; set; }
Public Property Filled As Boolean
    Get
    Set
public:
property bool Filled {
    bool get ();
    void set (bool value);
}
member Filled : bool with get, set

Property Value

Boolean
See Also

Reference

Profile Class


Profile.Transformed Property

ProfileTransformed Property

Transforms this profile and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Profile this[
    Transform transform
] { get; }
Public ReadOnly Property Transformed (
    transform As Transform
) As Profile
    Get
public:
property Profile^ Transformed[Transform^ transform] {
    Profile^ get (Transform^ transform);
}
member Transformed : Profile with get

Parameters

transform Transform
The transformation used to transform the profile.

Return Value

Profile
The transformed profile.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the handle of the specified transformation is .
InvalidOperationException | Thrown when failed to transform a curve in the profile.
Remarks
Transforms all the curves that define the boundary of this profile.
See Also

Reference

Profile Class


Profile Methods

The Profile type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Returns a copy of this profile.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Profile Class


Profile.Clone Method

ProfileClone Method

Returns a copy of this profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Profile Clone()
Public Function Clone As Profile
public:
Profile^ Clone()
member Clone : unit -> Profile

Return Value

Profile
See Also

Reference

Profile Class


ProfileFamilyUsage Enumeration

An enumerated type listing all types of profile families.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ProfileFamilyUsage
Public Enumeration ProfileFamilyUsage
public enum class ProfileFamilyUsage
type ProfileFamilyUsage
Members
Member name | Value | Description
Any | 0 | Any type of profile family.
WallSweep | 1 | Wall sweep.
Reveal | 2 | Reveal.
Fascia | 3 | Fascia.
Gutter | 4 | Gutter.
SlabEdge | 5 | Slab edge.
Railing | 6 | Railing.
StairNosing | 7 | Stair Nosing.
Mullion | 8 | Mullion.
SlabMetalDeck | 9 | Slab Metal Deck.
ContinuousFooting | 10 | Continuous Footing.
StairTread | 11 | Stair Tread.
StairRiser | 12 | Stair Riser.
StairSupport | 13 | Stair Support.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ProfilePlaneLocation Enumeration

Indicates the location of Sweep profile plane on the path curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ProfilePlaneLocation
Public Enumeration ProfilePlaneLocation
public enum class ProfilePlaneLocation
type ProfilePlaneLocation
Members
Member name | Value | Description
Start | 0 | Indicates the profile plane located at the start of the path curve.
MidPoint | 1 | Indicates the profile plane located at the Middle point of the path curve.
End | 2 | Indicates the profile plane located at the End of the path curve.
Remarks
Use this enum in the NewSweep() method to create generic forms.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ProjectInfo Class

An object that represents a Project Information within the Autodesk Revit project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBProjectInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ProjectInfo : Element
Public Class ProjectInfo
    Inherits Element
public ref class ProjectInfo : public Element
type ProjectInfo =
    class
        inherit Element
    end

The ProjectInfo type exposes the following members.

Properties
 | Name | Description
Public property | Address | Get or Set the Project Address of the Project Information.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | Author | Get or Set the Project Author of the Project Information.
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | BuildingName | Get or Set the Building Name of the Project Information.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | ClientName | Get or Set the Client Name of the Project Information.
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IssueDate | Get or Set the Project Issue Date of the Project Information.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Get or Set the Project Name of the Project Information.
Public property | Number | Get or Set the Project Number of the Project Information.
Public property | OrganizationDescription | Get or Set the Organization Description of the Project Information.
Public property | OrganizationName | Get or Set the Organization Name of the Project Information.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Status | Get or Set the Project Status of the Project Information.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object.
Example
C#
VB
C++
F#
Copy
ProjectInfo projectInfo = document.ProjectInformation;

if (null != projectInfo)
{
    string message = "Project information:";
    //get the project name
    message += "\nName: " + projectInfo.Name;
    string newName = "My project";
    //set the project name
    projectInfo.Name = newName;
    message += "\nProject Name after set: " + projectInfo.Name;

    //get the project number
    message += "\nNumber: " + projectInfo.Number;
    string newNumber = "TestNumber";
    //set the project number
    projectInfo.Number = newNumber;
    message += "\nProject Number after set: " + projectInfo.Number;

    //get the status of the project
    message += "\nStatus: " + projectInfo.Status;
    string newStatus = "TestStatus";
    //set the project status
    projectInfo.Status = newStatus;
    message += "\nProject status after set: " + projectInfo.Status;

    //get the address of the project
    message += "\nAddress: " + projectInfo.Address;
    string newAddress = "TestAddress";
    //set the project address
    projectInfo.Address = newAddress;
    message += "\nProject address after set: " + projectInfo.Address;

    //get the client name of the project
    message += "\nClient Name: " + projectInfo.ClientName;
    string newClient = "TestClientName";
    //set the client name
    projectInfo.ClientName = newClient;
    message += "\nProject client name after set: " + projectInfo.ClientName;

    //get the gbXmlSetting of the project
    EnergyDataSettings energyDataSetting = EnergyDataSettings.GetFromDocument(document);
    message += "\nBuilding type: " + energyDataSetting.BuildingType.ToString();

    TaskDialog.Show("Revit",message);
}
Dim projectInfo As ProjectInfo = document.ProjectInformation

If projectInfo IsNot Nothing Then
    Dim message As String = "Project information:"
    'get the project name
    message += vbLf & "Name: " + projectInfo.Name
    Dim newName As String = "My project"
    'set the project name
    projectInfo.Name = newName
    message += vbLf & "Project Name after set: " + projectInfo.Name

    'get the project number
    message += vbLf & "Number: " + projectInfo.Number
    Dim newNumber As String = "TestNumber"
    'set the project number
    projectInfo.Number = newNumber
    message += vbLf & "Project Number after set: " + projectInfo.Number

    'get the status of the project
    message += vbLf & "Status: " + projectInfo.Status
    Dim newStatus As String = "TestStatus"
    'set the project status
    projectInfo.Status = newStatus
    message += vbLf & "Project status after set: " + projectInfo.Status

    'get the address of the project
    message += vbLf & "Address: " + projectInfo.Address
    Dim newAddress As String = "TestAddress"
    'set the project address
    projectInfo.Address = newAddress
    message += vbLf & "Project address after set: " + projectInfo.Address

    'get the client name of the project
    message += vbLf & "Client Name: " + projectInfo.ClientName
    Dim newClient As String = "TestClientName"
    'set the client name
    projectInfo.ClientName = newClient
    message += vbLf & "Project client name after set: " + projectInfo.ClientName

    'get the gbXmlSetting of the project
    Dim energyDataSetting As EnergyDataSettings = EnergyDataSettings.GetFromDocument(document)
    message += vbLf & "Building type: " & energyDataSetting.BuildingType.ToString()

    TaskDialog.Show("Revit", message)
End If

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ProjectInfo Properties

The ProjectInfo type exposes the following members.

Properties
 | Name | Description
Public property | Address | Get or Set the Project Address of the Project Information.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | Author | Get or Set the Project Author of the Project Information.
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | BuildingName | Get or Set the Building Name of the Project Information.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | ClientName | Get or Set the Client Name of the Project Information.
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IssueDate | Get or Set the Project Issue Date of the Project Information.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Get or Set the Project Name of the Project Information.
Public property | Number | Get or Set the Project Number of the Project Information.
Public property | OrganizationDescription | Get or Set the Organization Description of the Project Information.
Public property | OrganizationName | Get or Set the Organization Name of the Project Information.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Status | Get or Set the Project Status of the Project Information.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

ProjectInfo Class


ProjectInfo.Address Property

ProjectInfoAddress Property

Get or Set the Project Address of the Project Information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Address { get; set; }
Public Property Address As String
    Get
    Set
public:
property String^ Address {
    String^ get ();
    void set (String^ value);
}
member Address : string with get, set

Property Value

String
Remarks
This property is used to get or set the Project Address of the Project Information.
See Also

Reference

ProjectInfo Class


ProjectInfo.Author Property

ProjectInfoAuthor Property

Get or Set the Project Author of the Project Information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Author { get; set; }
Public Property Author As String
    Get
    Set
public:
property String^ Author {
    String^ get ();
    void set (String^ value);
}
member Author : string with get, set

Property Value

String
Remarks
This property is used to get or set the Project Author of the Project Information.
See Also

Reference

ProjectInfo Class


ProjectInfo.BuildingName Property

ProjectInfoBuildingName Property

Get or Set the Building Name of the Project Information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string BuildingName { get; set; }
Public Property BuildingName As String
    Get
    Set
public:
property String^ BuildingName {
    String^ get ();
    void set (String^ value);
}
member BuildingName : string with get, set

Property Value

String
Remarks
This property is used to get or set the Project Number of the Project Information.
See Also

Reference

ProjectInfo Class


ProjectInfo.ClientName Property

ProjectInfoClientName Property

Get or Set the Client Name of the Project Information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ClientName { get; set; }
Public Property ClientName As String
    Get
    Set
public:
property String^ ClientName {
    String^ get ();
    void set (String^ value);
}
member ClientName : string with get, set

Property Value

String
Remarks
This property is used to get or set the Project Client Name of the Project Information.
See Also

Reference

ProjectInfo Class


ProjectInfo.IssueDate Property

ProjectInfoIssueDate Property

Get or Set the Project Issue Date of the Project Information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string IssueDate { get; set; }
Public Property IssueDate As String
    Get
    Set
public:
property String^ IssueDate {
    String^ get ();
    void set (String^ value);
}
member IssueDate : string with get, set

Property Value

String
Remarks
This property is used to get or set the Project Issue Date of the Project Information.
See Also

Reference

ProjectInfo Class


ProjectInfo.Name Property

ProjectInfoName Property

Get or Set the Project Name of the Project Information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

String
Remarks
This property is used to get or set the Project Name of the Project Information.
See Also

Reference

ProjectInfo Class


ProjectInfo.Number Property

ProjectInfoNumber Property

Get or Set the Project Number of the Project Information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Number { get; set; }
Public Property Number As String
    Get
    Set
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}
member Number : string with get, set

Property Value

String
Remarks
This property is used to get or set the Project Number of the Project Information.
See Also

Reference

ProjectInfo Class


ProjectInfo.OrganizationDescription Property

ProjectInfoOrganizationDescription Property

Get or Set the Organization Description of the Project Information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string OrganizationDescription { get; set; }
Public Property OrganizationDescription As String
    Get
    Set
public:
property String^ OrganizationDescription {
    String^ get ();
    void set (String^ value);
}
member OrganizationDescription : string with get, set

Property Value

String
Remarks
This property is used to get or set the Project Number of the Project Information.
See Also

Reference

ProjectInfo Class


ProjectInfo.OrganizationName Property

ProjectInfoOrganizationName Property

Get or Set the Organization Name of the Project Information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string OrganizationName { get; set; }
Public Property OrganizationName As String
    Get
    Set
public:
property String^ OrganizationName {
    String^ get ();
    void set (String^ value);
}
member OrganizationName : string with get, set

Property Value

String
Remarks
This property is used to get or set the Project Number of the Project Information.
See Also

Reference

ProjectInfo Class


ProjectInfo.Status Property

ProjectInfoStatus Property

Get or Set the Project Status of the Project Information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Status { get; set; }
Public Property Status As String
    Get
    Set
public:
property String^ Status {
    String^ get ();
    void set (String^ value);
}
member Status : string with get, set

Property Value

String
Remarks
This property is used to get or set the Project Status of the Project Information.
See Also

Reference

ProjectInfo Class


ProjectInfo Methods

The ProjectInfo type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ProjectInfo Class


ProjectLocation Class

A representation of a specific instance and location of the current project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBInstance
Autodesk.Revit.DBProjectLocation

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ProjectLocation : Instance
Public Class ProjectLocation
    Inherits Instance
public ref class ProjectLocation : public Instance
type ProjectLocation =
    class
        inherit Instance
    end

The ProjectLocation type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Create an instance of ProjectLocation in the document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
 | Duplicate | Generate a copy of this project location with the specified name.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
 | GetProjectPosition | Gets the coordinates of a point in the ProjectLocation's coordinate system.
Public method | GetSiteLocation | Gets the site location to which this project location refers.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances. (Inherited from Instance)
Public method | GetTransform | Gets the transform of the instance. (Inherited from Instance)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
 | IsProjectLocationNameUnique | Verifies that there is no existing ProjectLocation with the given name belonging to the given SiteLocation.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetProjectPosition | Sets the coordinates of a point in the ProjectLocation's coordinate system.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

When using shared coordinates, ProjectLocations can be used to specify specific locations for instances of a linked model. A ProjectLocation keeps track of the position of an instance in relationship to the project's SiteLocation.

By default, each Revit project contains at least one named location, called Internal. Existing ProjectLocation objects can be found by using the ProjectLocations property on the Document object. New project locations can be created by duplicating an existing project location using the Duplicate method, and modifying the location's project position.

See also SiteLocation
Example
C#
VB
C++
F#
Copy
public void ShowActiveProjectLocationUsage(Autodesk.Revit.DB.Document document)
{
    // Get the project location handle
    ProjectLocation projectLocation = document.ActiveProjectLocation;

    // Show the information of current project location
    XYZ origin = new XYZ(0, 0, 0);
    ProjectPosition position = projectLocation.GetProjectPosition(origin);
    if (null == position)
    {
        throw new Exception("No project position in origin point.");
    }

    // Format the prompt string to show the message.
    String prompt = "Current project location information:\n";
    prompt += "\n\t" + "Origin point position:";
    prompt += "\n\t\t" + "Angle: " + position.Angle;
    prompt += "\n\t\t" + "East to West offset: " + position.EastWest;
    prompt += "\n\t\t" + "Elevation: " + position.Elevation;
    prompt += "\n\t\t" + "North to South offset: " + position.NorthSouth;

    // Angles are in radians when coming from Revit API, so we
    // convert to degrees for display
    const double angleRatio = Math.PI / 180;   // angle conversion factor

    SiteLocation site = projectLocation.GetSiteLocation();
    prompt += "\n\t" + "Site location:";
    prompt += "\n\t\t" + "Latitude: " + site.Latitude / angleRatio + "��";
    prompt += "\n\t\t" + "Longitude: " + site.Longitude / angleRatio + "��";
    prompt += "\n\t\t" + "TimeZone: " + site.TimeZone;

    // Give the user some information
    TaskDialog.Show("Revit",prompt);
}
Public Sub ShowActiveProjectLocationUsage(document As Autodesk.Revit.DB.Document)
    ' Get the project location handle
    Dim projectLocation As ProjectLocation = document.ActiveProjectLocation

    ' Show the information of current project location
    Dim origin As New XYZ(0, 0, 0)
    Dim position As ProjectPosition = projectLocation.GetProjectPosition(origin)
    If position Is Nothing Then
        Throw New Exception("No project position in origin point.")
    End If

    ' Format the prompt string to show the message.
    Dim prompt As [String] = "Current project location information:" & vbLf
    prompt += vbLf & vbTab & "Origin point position:"
    prompt += (vbLf & vbTab & vbTab & "Angle: ") + position.Angle
    prompt += (vbLf & vbTab & vbTab & "East to West offset: ") + position.EastWest
    prompt += (vbLf & vbTab & vbTab & "Elevation: ") + position.Elevation
    prompt += (vbLf & vbTab & vbTab & "North to South offset: ") + position.NorthSouth

    ' Angles are in radians when coming from Revit API, so we
    ' convert to degrees for display
    Const angleRatio As Double = Math.PI / 180
    ' angle conversion factor
    Dim site As SiteLocation = projectLocation.GetSiteLocation()
    prompt += vbLf & vbTab & "Site location:"
    prompt += vbLf & vbTab & vbTab & "Latitude: " & site.Latitude / angleRatio & "��"
    prompt += vbLf & vbTab & vbTab & "Longitude: " & site.Longitude / angleRatio & "��"
    prompt += (vbLf & vbTab & vbTab & "TimeZone: ") + site.TimeZone

    ' Give the user some information
    TaskDialog.Show("Revit", prompt)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ProjectLocation Properties

The ProjectLocation type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

ProjectLocation Class


ProjectLocation Methods

The ProjectLocation type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Create an instance of ProjectLocation in the document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
 | Duplicate | Generate a copy of this project location with the specified name.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
 | GetProjectPosition | Gets the coordinates of a point in the ProjectLocation's coordinate system.
Public method | GetSiteLocation | Gets the site location to which this project location refers.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances. (Inherited from Instance)
Public method | GetTransform | Gets the transform of the instance. (Inherited from Instance)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
 | IsProjectLocationNameUnique | Verifies that there is no existing ProjectLocation with the given name belonging to the given SiteLocation.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetProjectPosition | Sets the coordinates of a point in the ProjectLocation's coordinate system.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ProjectLocation Class


ProjectLocation.Create Method

ProjectLocationCreate Method

Create an instance of ProjectLocation in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ProjectLocation Create(
    Document document,
    ElementId siteLocationId,
    string name
)
Public Shared Function Create (
    document As Document,
    siteLocationId As ElementId,
    name As String
) As ProjectLocation
public:
static ProjectLocation^ Create(
    Document^ document,
    ElementId^ siteLocationId,
    String^ name
)
static member Create :
        document : Document *
        siteLocationId : ElementId *
        name : string -> ProjectLocation

Parameters

document Document
The document where the new instance of ProjectLocation would be created in.
siteLocationId ElementId
The ElementId of the SiteLocation to which the new ProjectLocation would be created.
name String
The name of the instance of ProjectLocation to be created.

Return Value

ProjectLocation
The newly created instance of ProjectLocation.
Exceptions
Exception | Condition
ArgumentException | document is not a project document. -or- The element siteLocationId does not exist in the document -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- There is already a ProjectLocation with this name in the given SiteLocation.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
The created instace of ProjectLocation would have the specified name and an identity Transform.
See Also

Reference

ProjectLocation Class


ProjectLocation.Duplicate Method

ProjectLocationDuplicate Method

Generate a copy of this project location with the specified name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ProjectLocation Duplicate(
    string name
)
Public Function Duplicate (
    name As String
) As ProjectLocation
public:
ProjectLocation^ Duplicate(
    String^ name
)
member Duplicate :
        name : string -> ProjectLocation

Parameters

name String

Return Value

ProjectLocation
A new ProjectLocation which is a duplicate of this location, with the input name.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
The name must not be the same as the name of any existing locations. This function will modify the document, as the new ProjectLocation will be added to it.
Example
C#
VB
C++
F#
Copy
public ProjectLocation DuplicateLocation(Autodesk.Revit.DB.Document document, string newName)
{
    ProjectLocation currentLocation = document.ActiveProjectLocation;
    ProjectLocationSet locations = document.ProjectLocations;
    foreach (ProjectLocation projectLocation in locations)
    {
        if (projectLocation.Name == newName)
        {
            throw new Exception("The name is same as a project location's name, please change one.");
        }
    }
    return currentLocation.Duplicate(newName);
}
Public Function DuplicateLocation(document As Autodesk.Revit.DB.Document, newName As String) As ProjectLocation
    Dim currentLocation As ProjectLocation = document.ActiveProjectLocation
    Dim locations As ProjectLocationSet = document.ProjectLocations
    For Each projectLocation As ProjectLocation In locations
        If projectLocation.Name = newName Then
            Throw New Exception("The name is same as a project location's name, please change one.")
        End If
    Next
    Return currentLocation.Duplicate(newName)
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

ProjectLocation Class


ProjectLocation.GetProjectPosition Method

ProjectLocationGetProjectPosition Method

Gets the coordinates of a point in the ProjectLocation's coordinate system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ProjectPosition GetProjectPosition(
    XYZ point
)
Public Function GetProjectPosition (
    point As XYZ
) As ProjectPosition
public:
ProjectPosition^ GetProjectPosition(
    XYZ^ point
)
member GetProjectPosition :
        point : XYZ -> ProjectPosition

Parameters

point XYZ

Return Value

ProjectPosition
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Unable to use the project position's transform to calculate the point.
Remarks

When getting this value, the North/South, East/West, and Elevation values report the coordinates of the point similar to the Revit command "Report Shared Coordinates". To get the values of the transformations applied by this project location, pass XYZ.Zero.

If the project has acquired shared coordinates from a linked model, the shared coordinate transformation will be reflected in the coordinates of the transformed point returned by this property.

Example
C#
VB
C++
F#
Copy
//get and set the value of the projectlocation
public ProjectLocation GetProjectLocation(Autodesk.Revit.DB.Document document)
{
    ProjectLocation currentLocation = document.ActiveProjectLocation;

    //get the project position
    XYZ origin = new XYZ(0, 0, 0);

    const double angleRatio = Math.PI / 180;   // angle conversion factor

    ProjectPosition projectPosition = currentLocation.GetProjectPosition(origin);
    //Angle from True North
    double angle = 30.0 * angleRatio;   // convert degrees to radian
    double eastWest = 30.0;     //East to West offset
    double northSouth = 23.32;   //North to South offset
    double elevation = 22.14;    //Elevation above ground level

    //create a new project position
    ProjectPosition newPosition =
      document.Application.Create.NewProjectPosition(eastWest, northSouth, elevation, angle);

    if (null != newPosition)
    {
        //set the value of the project position
        currentLocation.SetProjectPosition(origin, newPosition);
    }

    return currentLocation;
}
'get and set the value of the projectlocation
Public Function GetProjectLocation(document As Autodesk.Revit.DB.Document) As ProjectLocation
    Dim currentLocation As ProjectLocation = document.ActiveProjectLocation

    'get the project position
    Dim origin As New XYZ(0, 0, 0)

    Const angleRatio As Double = Math.PI / 180
    ' angle conversion factor
    Dim projectPosition As ProjectPosition = currentLocation.GetProjectPosition(origin)
    'Angle from True North
    Dim angle As Double = 30.0 * angleRatio
    ' convert degrees to radian
    Dim eastWest As Double = 30.0
    'East to West offset
    Dim northSouth As Double = 23.32
    'North to South offset
    Dim elevation As Double = 22.14
    'Elevation above ground level
    'create a new project position
    Dim newPosition As ProjectPosition = document.Application.Create.NewProjectPosition(eastWest, northSouth, elevation, angle)

    If newPosition IsNot Nothing Then
        'set the value of the project position
        currentLocation.SetProjectPosition(origin, newPosition)
    End If

    Return currentLocation
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

ProjectLocation Class


ProjectLocation.GetSiteLocation Method

ProjectLocationGetSiteLocation Method

Gets the site location to which this project location refers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SiteLocation GetSiteLocation()
Public Function GetSiteLocation As SiteLocation
public:
SiteLocation^ GetSiteLocation()
member GetSiteLocation : unit -> SiteLocation

Return Value

SiteLocation
Remarks
The site location object contains the longitude, latitude, and time-zone of the entire project site.
See Also

Reference

ProjectLocation Class


ProjectLocation.IsProjectLocationNameUnique Method

ProjectLocationIsProjectLocationNameUnique Method

Verifies that there is no existing ProjectLocation with the given name belonging to the given SiteLocation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsProjectLocationNameUnique(
    Document document,
    string name,
    ElementId siteLocationId
)
Public Shared Function IsProjectLocationNameUnique (
    document As Document,
    name As String,
    siteLocationId As ElementId
) As Boolean
public:
static bool IsProjectLocationNameUnique(
    Document^ document,
    String^ name,
    ElementId^ siteLocationId
)
static member IsProjectLocationNameUnique :
        document : Document *
        name : string *
        siteLocationId : ElementId -> bool

Parameters

document Document
The document to check.
name String
The name to check.
siteLocationId ElementId
The ElementId of the SiteLocation which the ProjectLocation belongs to.

Return Value

Boolean
True if the name is unused (among ProjectLocations). False otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ProjectLocation Class


ProjectLocation.SetProjectPosition Method

ProjectLocationSetProjectPosition Method

Sets the coordinates of a point in the ProjectLocation's coordinate system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetProjectPosition(
    XYZ point,
    ProjectPosition position
)
Public Sub SetProjectPosition (
    point As XYZ,
    position As ProjectPosition
)
public:
void SetProjectPosition(
    XYZ^ point,
    ProjectPosition^ position
)
member SetProjectPosition :
        point : XYZ *
        position : ProjectPosition -> unit

Parameters

point XYZ
position ProjectPosition
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Unable to use the project position's transform to calculate the point.
Remarks
When setting this value, the transformations applied to the location are modified such that the passed point becomes the specified North/South, East/West and Elevation, and the coordinate transform will have the designated angular rotation. This is similar to the Revit command "Specify Coordinates at Point".
See Also

Reference

ProjectLocation Class


ProjectLocationSet Class

An set that contains project locations.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBProjectLocationSet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ProjectLocationSet : APIObject,
    IEnumerable
Public Class ProjectLocationSet
    Inherits APIObject
    Implements IEnumerable
public ref class ProjectLocationSet : public APIObject,
    IEnumerable
type ProjectLocationSet =
    class
        inherit APIObject
        interface IEnumerable
    end

The ProjectLocationSet type exposes the following members.

Constructors
 | Name | Description
Public method | ProjectLocationSet | Initializes a new instance of the ProjectLocationSet class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Size | Returns the number of project locations that are in the set.
Top
Methods
 | Name | Description
Public method | Clear | Removes every project location from the set, rendering it empty.
Public method | Contains | Tests for the existence of a project location within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase | Removes a specified project location from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified project location into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ProjectLocationSet Constructor

Initializes a new instance of the ProjectLocationSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ProjectLocationSet()
Public Sub New
public:
ProjectLocationSet()
new : unit -> ProjectLocationSet
See Also

Reference

ProjectLocationSet Class


ProjectLocationSet Properties

The ProjectLocationSet type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Size | Returns the number of project locations that are in the set.
Top
See Also

Reference

ProjectLocationSet Class


ProjectLocationSet.IsEmpty Property

ProjectLocationSetIsEmpty Property

Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Boolean
Remarks
If the set is empty then True will be returned, otherwise False.
See Also

Reference

ProjectLocationSet Class


ProjectLocationSet.Size Property

ProjectLocationSetSize Property

Returns the number of project locations that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
abstract Size : int with get
override Size : int with get

Property Value

Int32
See Also

Reference

ProjectLocationSet Class


ProjectLocationSet Methods

The ProjectLocationSet type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Removes every project location from the set, rendering it empty.
Public method | Contains | Tests for the existence of a project location within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase | Removes a specified project location from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified project location into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ProjectLocationSet Class


ProjectLocationSet.Clear Method

ProjectLocationSetClear Method

Removes every project location from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

ProjectLocationSet Class


ProjectLocationSet.Contains Method

ProjectLocationSetContains Method

Tests for the existence of a project location within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Contains(
    ProjectLocation item
)
Public Overridable Function Contains (
    item As ProjectLocation
) As Boolean
public:
virtual bool Contains(
    ProjectLocation^ item
)
abstract Contains :
        item : ProjectLocation -> bool
override Contains :
        item : ProjectLocation -> bool

Parameters

item ProjectLocation
The project location to be searched for.

Return Value

Boolean
The Contains method returns True if the project location is within the set, otherwise False.
See Also

Reference

ProjectLocationSet Class


ProjectLocationSet.Erase Method

ProjectLocationSetErase Method

Removes a specified project location from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Erase(
    ProjectLocation item
)
Public Overridable Function Erase (
    item As ProjectLocation
) As Integer
public:
virtual int Erase(
    ProjectLocation^ item
)
abstract Erase :
        item : ProjectLocation -> int
override Erase :
        item : ProjectLocation -> int

Parameters

item ProjectLocation
The project location to be erased.

Return Value

Int32
The number of project locations that were erased from the set.
See Also

Reference

ProjectLocationSet Class


ProjectLocationSet.ForwardIterator Method

ProjectLocationSetForwardIterator Method

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ProjectLocationSetIterator ForwardIterator()
Public Overridable Function ForwardIterator As ProjectLocationSetIterator
public:
virtual ProjectLocationSetIterator^ ForwardIterator()
abstract ForwardIterator : unit -> ProjectLocationSetIterator
override ForwardIterator : unit -> ProjectLocationSetIterator

Return Value

ProjectLocationSetIterator
Returns a forward moving iterator to the set.
See Also

Reference

ProjectLocationSet Class


ProjectLocationSet.GetEnumerator Method

ProjectLocationSetGetEnumerator Method

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

IEnumerator
Returns a forward moving iterator to the set.

Implements

IEnumerableGetEnumerator
See Also

Reference

ProjectLocationSet Class


ProjectLocationSet.Insert Method

ProjectLocationSetInsert Method

Insert the specified project location into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Insert(
    ProjectLocation item
)
Public Overridable Function Insert (
    item As ProjectLocation
) As Boolean
public:
virtual bool Insert(
    ProjectLocation^ item
)
abstract Insert :
        item : ProjectLocation -> bool
override Insert :
        item : ProjectLocation -> bool

Parameters

item ProjectLocation
The project location to be inserted into the set.

Return Value

Boolean
Returns whether the project location was inserted into the set.
See Also

Reference

ProjectLocationSet Class


ProjectLocationSet.ReverseIterator Method

ProjectLocationSetReverseIterator Method

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ProjectLocationSetIterator ReverseIterator()
Public Overridable Function ReverseIterator As ProjectLocationSetIterator
public:
virtual ProjectLocationSetIterator^ ReverseIterator()
abstract ReverseIterator : unit -> ProjectLocationSetIterator
override ReverseIterator : unit -> ProjectLocationSetIterator

Return Value

ProjectLocationSetIterator
Returns a backward moving iterator to the set.
See Also

Reference

ProjectLocationSet Class


ProjectLocationSetIterator Class

An iterator to a project location set.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBProjectLocationSetIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class ProjectLocationSetIterator : APIObject,
    IEnumerator
Public MustInherit Class ProjectLocationSetIterator
    Inherits APIObject
    Implements IEnumerator
public ref class ProjectLocationSetIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type ProjectLocationSetIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The ProjectLocationSetIterator type exposes the following members.

Constructors
 | Name | Description
Public method | ProjectLocationSetIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ProjectLocationSetIterator Constructor

For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ProjectLocationSetIterator()
Public Sub New
public:
ProjectLocationSetIterator()
new : unit -> ProjectLocationSetIterator
Remarks
This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.
See Also

Reference

ProjectLocationSetIterator Class


ProjectLocationSetIterator Properties

The ProjectLocationSetIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

ProjectLocationSetIterator Class


ProjectLocationSetIterator.Current Property

ProjectLocationSetIteratorCurrent Property

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}
abstract Current : Object with get
override Current : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.
See Also

Reference

ProjectLocationSetIterator Class


ProjectLocationSetIterator Methods

The ProjectLocationSetIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ProjectLocationSetIterator Class


ProjectLocationSetIterator.MoveNext Method

ProjectLocationSetIteratorMoveNext Method

Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumeratorMoveNext
Remarks
MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.
See Also

Reference

ProjectLocationSetIterator Class


ProjectLocationSetIterator.Reset Method

ProjectLocationSetIteratorReset Method

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
Remarks
The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.
See Also

Reference

ProjectLocationSetIterator Class


ProjectPosition Class

ProjectPosition is a class used to represent a geographical offset and rotation. It can be used to represent the position of a project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBProjectPosition

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ProjectPosition : IDisposable
Public Class ProjectPosition
    Implements IDisposable
public ref class ProjectPosition : IDisposable
type ProjectPosition =
    class
        interface IDisposable
    end

The ProjectPosition type exposes the following members.

Constructors
 | Name | Description
Public method | ProjectPosition(ProjectPosition) | Creates a copy of the ProjectPosition.
Public method | ProjectPosition(Double, Double, Double, Double) | Construct a new ProjectPosition with the specified East/West offset, North/South offset, elevation offset, and angle of rotation.
Top
Properties
 | Name | Description
Public property | Angle | Angle from True North.
Public property | EastWest | East/West offset.
Public property | Elevation | Elevation above ground level.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NorthSouth | North/South offset
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ProjectPosition
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ProjectPosition Constructor

Overload List
 | Name | Description
Public method | ProjectPosition(ProjectPosition) | Creates a copy of the ProjectPosition.
Public method | ProjectPosition(Double, Double, Double, Double) | Construct a new ProjectPosition with the specified East/West offset, North/South offset, elevation offset, and angle of rotation.
Top
See Also

Reference

ProjectPosition Class


ProjectPosition(ProjectPosition) Constructor

Creates a copy of the ProjectPosition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ProjectPosition(
    ProjectPosition other
)
Public Sub New (
    other As ProjectPosition
)
public:
ProjectPosition(
    ProjectPosition^ other
)
new :
        other : ProjectPosition -> ProjectPosition

Parameters

other ProjectPosition
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ProjectPosition Class
ProjectPosition Overload


ProjectPosition(Double, Double, Double, Double) Constructor

Construct a new ProjectPosition with the specified East/West offset, North/South offset, elevation offset, and angle of rotation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ProjectPosition(
    double ew,
    double ns,
    double elevation,
    double angle
)
Public Sub New (
    ew As Double,
    ns As Double,
    elevation As Double,
    angle As Double
)
public:
ProjectPosition(
    double ew,
    double ns,
    double elevation,
    double angle
)
new :
        ew : float *
        ns : float *
        elevation : float *
        angle : float -> ProjectPosition

Parameters

ew Double
East/West offset
ns Double
North/South offset
elevation Double
Elevation offset
angle Double
Rotation from true north, in radians
Remarks
The angle parameter must be in the range of -PI to PI. If the parameter value is outside that range, it will be shifted by 2*PI until it falls into range.
See Also

Reference

ProjectPosition Class
ProjectPosition Overload


ProjectPosition Properties

The ProjectPosition type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Angle from True North.
Public property | EastWest | East/West offset.
Public property | Elevation | Elevation above ground level.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NorthSouth | North/South offset
Top
See Also

Reference

ProjectPosition Class


ProjectPosition.Angle Property

ProjectPositionAngle Property

Angle from True North.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Angle { get; set; }
Public Property Angle As Double
    Get
    Set
public:
property double Angle {
    double get ();
    void set (double value);
}
member Angle : float with get, set

Property Value

Double
Remarks
This is the angle difference between project north and true north measured in radians. It can have a value from -PI to PI. If the parameter value is outside that range, it will be shifted by 2*PI until it falls into range.
See Also

Reference

ProjectPosition Class


ProjectPosition.EastWest Property

ProjectPositionEastWest Property

East/West offset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double EastWest { get; set; }
Public Property EastWest As Double
    Get
    Set
public:
property double EastWest {
    double get ();
    void set (double value);
}
member EastWest : float with get, set

Property Value

Double
Remarks
The offset of the project location from the site location in the east/west direction. Measured in decimal feet.
See Also

Reference

ProjectPosition Class


ProjectPosition.Elevation Property

ProjectPositionElevation Property

Elevation above ground level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Elevation { get; set; }
Public Property Elevation As Double
    Get
    Set
public:
property double Elevation {
    double get ();
    void set (double value);
}
member Elevation : float with get, set

Property Value

Double
Remarks
Negative values are allowed. Measured in decimal feet.
See Also

Reference

ProjectPosition Class


ProjectPosition.IsValidObject Property

ProjectPositionIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ProjectPosition Class


ProjectPosition.NorthSouth Property

ProjectPositionNorthSouth Property

North/South offset

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double NorthSouth { get; set; }
Public Property NorthSouth As Double
    Get
    Set
public:
property double NorthSouth {
    double get ();
    void set (double value);
}
member NorthSouth : float with get, set

Property Value

Double
Remarks
The offset of the project location from the site location in the north/south direction. Measured in decimal feet.
See Also

Reference

ProjectPosition Class


ProjectPosition Methods

The ProjectPosition type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ProjectPosition Class


ProjectPosition.Dispose Method

ProjectPositionDispose Method

Releases all resources used by the ProjectPosition

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ProjectPosition Class


PropertyLine Class

Represents kinds of PropertyLines.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBPropertyLine

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PropertyLine : Element
Public Class PropertyLine
    Inherits Element
public ref class PropertyLine : public Element
type PropertyLine =
    class
        inherit Element
    end

The PropertyLine type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PropertyLine Properties

The PropertyLine type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

PropertyLine Class


PropertyLine Methods

The PropertyLine type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PropertyLine Class


PropertySetElement Class

An element that groups together a set of related parameters.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBPropertySetElement

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PropertySetElement : Element
Public Class PropertySetElement
    Inherits Element
public ref class PropertySetElement : public Element
type PropertySetElement =
    class
        inherit Element
    end

The PropertySetElement type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create(Document, StructuralAsset) | Creates a new PropertySetElement to contain the given asset.
 | Create(Document, ThermalAsset) | Creates a new PropertySetElement to contain the given asset.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Creates a duplicate of this PropertySetElement.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
 | GetStructuralAsset | Gets a copy of the StructuralAsset.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
 | GetThermalAsset | Gets a copy of the ThermalAsset.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetStructuralAsset | Sets a copy of the given StucturalAsset to be used in the PropertySetElement.
Public method | SetThermalAsset | Sets a copy of the given ThermalAsset to be used in the PropertySetElement.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


PropertySetElement Properties

The PropertySetElement type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

PropertySetElement Class


PropertySetElement Methods

The PropertySetElement type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create(Document, StructuralAsset) | Creates a new PropertySetElement to contain the given asset.
 | Create(Document, ThermalAsset) | Creates a new PropertySetElement to contain the given asset.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Creates a duplicate of this PropertySetElement.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
 | GetStructuralAsset | Gets a copy of the StructuralAsset.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
 | GetThermalAsset | Gets a copy of the ThermalAsset.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetStructuralAsset | Sets a copy of the given StucturalAsset to be used in the PropertySetElement.
Public method | SetThermalAsset | Sets a copy of the given ThermalAsset to be used in the PropertySetElement.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

PropertySetElement Class


PropertySetElement.Create Method

PropertySetElementCreate Method

Overload List
Name | Description
Create(Document, StructuralAsset) | Creates a new PropertySetElement to contain the given asset.
Create(Document, ThermalAsset) | Creates a new PropertySetElement to contain the given asset.
Top
See Also

Reference

PropertySetElement Class


PropertySetElement.Create(Document, StructuralAsset) Method

PropertySetElementCreate(Document, StructuralAsset) Method

Creates a new PropertySetElement to contain the given asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static PropertySetElement Create(
    Document document,
    StructuralAsset structuralAsset
)
Public Shared Function Create (
    document As Document,
    structuralAsset As StructuralAsset
) As PropertySetElement
public:
static PropertySetElement^ Create(
    Document^ document,
    StructuralAsset^ structuralAsset
)
static member Create :
        document : Document *
        structuralAsset : StructuralAsset -> PropertySetElement

Parameters

document Document
The document in which to create the PropertySetElement.
structuralAsset StructuralAsset
The structural asset containing the values that will be present in the PropertySetElement.

Return Value

PropertySetElement
The new PropertySetElement.
Exceptions
Exception | Condition
ArgumentException | Thrown when the name of the asset is empty, contains prohibited characters, or is not unique
ArgumentNullException | A non-optional argument was null
See Also

Reference

PropertySetElement Class
Create Overload


PropertySetElement.Create(Document, ThermalAsset) Method

PropertySetElementCreate(Document, ThermalAsset) Method

Creates a new PropertySetElement to contain the given asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static PropertySetElement Create(
    Document document,
    ThermalAsset thermalAsset
)
Public Shared Function Create (
    document As Document,
    thermalAsset As ThermalAsset
) As PropertySetElement
public:
static PropertySetElement^ Create(
    Document^ document,
    ThermalAsset^ thermalAsset
)
static member Create :
        document : Document *
        thermalAsset : ThermalAsset -> PropertySetElement

Parameters

document Document
The document in which to create the PropertySetElement.
thermalAsset ThermalAsset
The thermal asset containing the values that will be present in the PropertySetElement.

Return Value

PropertySetElement
The new PropertySetElement.
Exceptions
Exception | Condition
ArgumentException | Thrown when the name of the asset is empty, contains prohibited characters, or is not unique
ArgumentNullException | A non-optional argument was null
See Also

Reference

PropertySetElement Class
Create Overload


PropertySetElement.Duplicate Method

PropertySetElementDuplicate Method

Creates a duplicate of this PropertySetElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PropertySetElement Duplicate(
    Document document,
    string name
)
Public Function Duplicate (
    document As Document,
    name As String
) As PropertySetElement
public:
PropertySetElement^ Duplicate(
    Document^ document,
    String^ name
)
member Duplicate :
        document : Document *
        name : string -> PropertySetElement

Parameters

document Document
The document in which to create the PropertySetElement.
name String
The name to use for the new PropertySetElement.

Return Value

PropertySetElement
The new PropertySetElement.
Exceptions
Exception | Condition
ArgumentException | The given value for name is already in use as a property set name. -or- name is an empty string. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~".
ArgumentNullException | A non-optional argument was null
See Also

Reference

PropertySetElement Class


PropertySetElement.GetStructuralAsset Method

PropertySetElementGetStructuralAsset Method

Gets a copy of the StructuralAsset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public StructuralAsset GetStructuralAsset()
Public Function GetStructuralAsset As StructuralAsset
public:
StructuralAsset^ GetStructuralAsset()
member GetStructuralAsset : unit -> StructuralAsset

Return Value

StructuralAsset
Example
C#
VB
C++
F#
Copy
private void ReadMaterialProps(Document document, Material material)
{
   ElementId strucAssetId = material.StructuralAssetId;
   if (strucAssetId != ElementId.InvalidElementId)
   {
      PropertySetElement pse = document.GetElement(strucAssetId) as PropertySetElement;
      if (pse != null)
      {
         StructuralAsset asset = pse.GetStructuralAsset();

         // Check the material behavior and only read if Isotropic
         if (asset.Behavior == StructuralBehavior.Isotropic)
         {
            // Get the class of material
            StructuralAssetClass assetClass = asset.StructuralAssetClass;

            // Get other material properties
            double poisson = asset.PoissonRatio.X;
            double youngMod = asset.YoungModulus.X;
            double thermCoeff = asset.ThermalExpansionCoefficient.X;
            double unitweight = asset.Density;
            double shearMod = asset.ShearModulus.X;

            if (assetClass == StructuralAssetClass.Metal)
            {
               double dMinStress = asset.MinimumYieldStress;
            }
            else if (assetClass == StructuralAssetClass.Concrete)
            {
               double dConcComp = asset.ConcreteCompression;
            }
         }
      }
   }
}
Private Sub ReadMaterialProps(document As Document, material As Material)
    Dim strucAssetId As ElementId = material.StructuralAssetId
    If strucAssetId <> ElementId.InvalidElementId Then
        Dim pse As PropertySetElement = TryCast(document.GetElement(strucAssetId), PropertySetElement)
        If pse IsNot Nothing Then
            Dim asset As StructuralAsset = pse.GetStructuralAsset()

            ' Check the material behavior and only read if Isotropic
            If asset.Behavior = StructuralBehavior.Isotropic Then
                ' Get the class of material
                Dim assetClass As StructuralAssetClass = asset.StructuralAssetClass

                ' Get other material properties
                Dim poisson As Double = asset.PoissonRatio.X
                Dim youngMod As Double = asset.YoungModulus.X
                Dim thermCoeff As Double = asset.ThermalExpansionCoefficient.X
                Dim unitweight As Double = asset.Density
                Dim shearMod As Double = asset.ShearModulus.X

                If assetClass = StructuralAssetClass.Metal Then
                    Dim dMinStress As Double = asset.MinimumYieldStress
                ElseIf assetClass = StructuralAssetClass.Concrete Then
                    Dim dConcComp As Double = asset.ConcreteCompression
                End If
            End If
        End If
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

PropertySetElement Class


PropertySetElement.GetThermalAsset Method

PropertySetElementGetThermalAsset Method

Gets a copy of the ThermalAsset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ThermalAsset GetThermalAsset()
Public Function GetThermalAsset As ThermalAsset
public:
ThermalAsset^ GetThermalAsset()
member GetThermalAsset : unit -> ThermalAsset

Return Value

ThermalAsset
Example
C#
VB
C++
F#
Copy
private void ReadMaterialThermalProps(Document document, Material material)
{
   ElementId thermalAssetId = material.ThermalAssetId;
   if (thermalAssetId != ElementId.InvalidElementId)
   {
      PropertySetElement pse = document.GetElement(thermalAssetId) as PropertySetElement;
      if (pse != null)
      {
         ThermalAsset asset = pse.GetThermalAsset();

         // Check the thermal material type and only read if solid
         if (asset.ThermalMaterialType == ThermalMaterialType.Solid)
         {

            // Get the properties which are supported in solid type
            bool isTransmitsLight = asset.TransmitsLight;
            double permeability = asset.Permeability;
            double porosity = asset.Porosity;
            double reflectivity = asset.Reflectivity;
            double resistivity = asset.ElectricalResistivity;
            StructuralBehavior behavior = asset.Behavior;

            // Get the other properties.
            double heatOfVaporization = asset.SpecificHeatOfVaporization;
            double emissivity = asset.Emissivity;
            double conductivity = asset.ThermalConductivity;
            double density = asset.Density;
         }
      }
   }
}
Private Sub ReadMaterialThermalProps(document As Document, material As Material)
    Dim thermalAssetId As ElementId = material.ThermalAssetId
    If thermalAssetId <> ElementId.InvalidElementId Then
        Dim pse As PropertySetElement = TryCast(document.GetElement(thermalAssetId), PropertySetElement)
        If pse IsNot Nothing Then
            Dim asset As ThermalAsset = pse.GetThermalAsset()

            ' Check the thermal material type and only read if solid
            If asset.ThermalMaterialType = ThermalMaterialType.Solid Then

                ' Get the properties which are supported in solid type
                Dim isTransmitsLight As Boolean = asset.TransmitsLight
                Dim permeability As Double = asset.Permeability
                Dim porosity As Double = asset.Porosity
                Dim reflectivity As Double = asset.Reflectivity
                Dim resistivity As Double = asset.ElectricalResistivity
                Dim behavior As StructuralBehavior = asset.Behavior

                ' Get the other properties.
                Dim heatOfVaporization As Double = asset.SpecificHeatOfVaporization
                Dim emissivity As Double = asset.Emissivity
                Dim conductivity As Double = asset.ThermalConductivity
                Dim density As Double = asset.Density
            End If
        End If
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

PropertySetElement Class


PropertySetElement.SetStructuralAsset Method

PropertySetElementSetStructuralAsset Method

Sets a copy of the given StucturalAsset to be used in the PropertySetElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetStructuralAsset(
    StructuralAsset structuralAsset
)
Public Sub SetStructuralAsset (
    structuralAsset As StructuralAsset
)
public:
void SetStructuralAsset(
    StructuralAsset^ structuralAsset
)
member SetStructuralAsset :
        structuralAsset : StructuralAsset -> unit

Parameters

structuralAsset StructuralAsset
Exceptions
Exception | Condition
ArgumentException | Thrown when the name of the asset is empty, contains prohibited characters, or is not unique
ArgumentNullException | A non-optional argument was null
See Also

Reference

PropertySetElement Class


PropertySetElement.SetThermalAsset Method

PropertySetElementSetThermalAsset Method

Sets a copy of the given ThermalAsset to be used in the PropertySetElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetThermalAsset(
    ThermalAsset thermalAsset
)
Public Sub SetThermalAsset (
    thermalAsset As ThermalAsset
)
public:
void SetThermalAsset(
    ThermalAsset^ thermalAsset
)
member SetThermalAsset :
        thermalAsset : ThermalAsset -> unit

Parameters

thermalAsset ThermalAsset
Exceptions
Exception | Condition
ArgumentException | Thrown when the name of the asset is empty, contains prohibited characters, or is not unique
ArgumentNullException | A non-optional argument was null
See Also

Reference

PropertySetElement Class


PropOverrideMode Enumeration

An enumerated type listing ways how overridden object styles get exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum PropOverrideMode
Public Enumeration PropOverrideMode
public enum class PropOverrideMode
type PropOverrideMode
Members
Member name | Value | Description
ByEntity | 0 | Category properties BYLAYER, overrides BYENTITY. Entities generated by a specific category are assigned to a layer accordingly to the layer settings. To preserve visual fidelity, overridden attributes result in entity-specific attributes
ByLayer | 1 | All properties BYLAYER, no overrides Forces all entities to follow visual properties as set by their layer. Visual fidelity is lost, but this produces the least number of layers while still providing by-layer control over exported entities.
NewLayer | 2 | All properties BYLAYER, New Layers for overrides. Visual fidelity is preserved and there is by-layer control over all entities, although number of layers in the exported file might be increased.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RadialArray Class

An object that represents an Array created along a circle arc within the Revit project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBBaseArray
Autodesk.Revit.DBRadialArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RadialArray : BaseArray
Public Class RadialArray
    Inherits BaseArray
public ref class RadialArray : public BaseArray
type RadialArray =
    class
        inherit BaseArray
    end

The RadialArray type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | Label | The family parameter label of the BaseArray. (Inherited from BaseArray)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Get and Set the Name property (Inherited from BaseArray)
Public property | NumMembers | Retrieves or changes the number of arrayed members. Array placeholder members in the family environment are not counted. (Overrides BaseArrayNumMembers)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
 | ArrayElementsWithoutAssociation | Creates a new radial array from a set of elements based on an input rotation axis.
 | ArrayElementWithoutAssociation | Creates a new radial array from a single element based on an input rotation axis.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create(Document, View, ElementId, Int32, Line, Double, ArrayAnchorMember) | Creates a new radial array element from a single element based on an input rotation axis.
 | Create(Document, View, ICollectionElementId, Int32, Line, Double, ArrayAnchorMember) | Creates a new radial array element from a set of elements based on an input rotation axis.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetCopiedMemberIds | Retrieves the copied member ids from the array. The first item in an array contains the original elements from which the array was created. All other items in the array are copies. (Overrides BaseArrayGetCopiedMemberIds)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
 | GetMinimumSize | Returns the minimum size for a radial array based on the document.
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetNumberOfMembersIncludingPlaceholders | Returns the number of items in an array, including placeholder items in families.
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetOriginalMemberIds | Retrieves the ids for the original elements from which the array was created. These elements form the first item in the array. (Overrides BaseArrayGetOriginalMemberIds)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
 | IsRotationAngleValid | This indicates whether the input angle is valid.
 | IsValidArraySize | Obsolete. This indicates whether the input count is valid in the project environment.
 | IsValidNumberOfMembers | This indicates whether the input count is a valid size for an array based on the document.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RadialArray Properties

The RadialArray type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | Label | The family parameter label of the BaseArray. (Inherited from BaseArray)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Get and Set the Name property (Inherited from BaseArray)
Public property | NumMembers | Retrieves or changes the number of arrayed members. Array placeholder members in the family environment are not counted. (Overrides BaseArrayNumMembers)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

RadialArray Class


RadialArray.NumMembers Property

RadialArrayNumMembers Property

Retrieves or changes the number of arrayed members. Array placeholder members in the family environment are not counted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int NumMembers { get; set; }
Public Overrides Property NumMembers As Integer
    Get
    Set
public:
virtual property int NumMembers {
    int get () override;
    void set (int value) override;
}
abstract NumMembers : int with get, set
override NumMembers : int with get, set

Property Value

Int32
See Also

Reference

RadialArray Class


RadialArray Methods

The RadialArray type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
 | ArrayElementsWithoutAssociation | Creates a new radial array from a set of elements based on an input rotation axis.
 | ArrayElementWithoutAssociation | Creates a new radial array from a single element based on an input rotation axis.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create(Document, View, ElementId, Int32, Line, Double, ArrayAnchorMember) | Creates a new radial array element from a single element based on an input rotation axis.
 | Create(Document, View, ICollectionElementId, Int32, Line, Double, ArrayAnchorMember) | Creates a new radial array element from a set of elements based on an input rotation axis.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetCopiedMemberIds | Retrieves the copied member ids from the array. The first item in an array contains the original elements from which the array was created. All other items in the array are copies. (Overrides BaseArrayGetCopiedMemberIds)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
 | GetMinimumSize | Returns the minimum size for a radial array based on the document.
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetNumberOfMembersIncludingPlaceholders | Returns the number of items in an array, including placeholder items in families.
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetOriginalMemberIds | Retrieves the ids for the original elements from which the array was created. These elements form the first item in the array. (Overrides BaseArrayGetOriginalMemberIds)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
 | IsRotationAngleValid | This indicates whether the input angle is valid.
 | IsValidArraySize | Obsolete. This indicates whether the input count is valid in the project environment.
 | IsValidNumberOfMembers | This indicates whether the input count is a valid size for an array based on the document.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

RadialArray Class


RadialArray.ArrayElementsWithoutAssociation Method

RadialArrayArrayElementsWithoutAssociation Method

Creates a new radial array from a set of elements based on an input rotation axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ICollection<ElementId> ArrayElementsWithoutAssociation(
    Document aDoc,
    View dBView,
    ICollection<ElementId> ids,
    int count,
    Line axis,
    double angle,
    ArrayAnchorMember anchorMember
)
Public Shared Function ArrayElementsWithoutAssociation (
    aDoc As Document,
    dBView As View,
    ids As ICollection(Of ElementId),
    count As Integer,
    axis As Line,
    angle As Double,
    anchorMember As ArrayAnchorMember
) As ICollection(Of ElementId)
public:
static ICollection<ElementId^>^ ArrayElementsWithoutAssociation(
    Document^ aDoc,
    View^ dBView,
    ICollection<ElementId^>^ ids,
    int count,
    Line^ axis,
    double angle,
    ArrayAnchorMember anchorMember
)
static member ArrayElementsWithoutAssociation :
        aDoc : Document *
        dBView : View *
        ids : ICollection<ElementId> *
        count : int *
        axis : Line *
        angle : float *
        anchorMember : ArrayAnchorMember -> ICollection<ElementId>

Parameters

aDoc Document
The document.
dBView View
The view. If it is a 2d view, translation vector must be in the view plane if elements include view-specific elements. If elements include view-specific elements, they must belong to this view.
ids ICollection ElementId
The set of elements to array. The position of the rotation axis is determined by the cumulative center of the elements' bounding boxes.
count Int32
The number of array members to create. The accepted range is from 3 to 200 in a project document, and between 0 and 200 in a family document.
axis Line
The rotation axis.
angle Double
The angle in radians of the rotation.
anchorMember ArrayAnchorMember
Indicates if the translation vector specifies the location of the second member of the array, or the last member of the array.

Return Value

ICollection ElementId
The elements created by the operation.
Exceptions
Exception | Condition
ArgumentException | The given element id set is empty. -or- One or more elements in ids do not exist in the document. -or- One or more elements in ids is owned by different views and thus cannot be arrayed together. -or- One or more elements in ids is not arrayable. -or- count must be between 3 and 200 in project documents and between 0 and 200 in family documents. -or- The view is invalid for specific view elements array. -or- The rotation axis is invalid to array the elements. -or- Angle value must be not zero.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | Failed to create the radial array.
Remarks
The resulting elements will not be associated with an array element.
See Also

Reference

RadialArray Class


RadialArray.ArrayElementWithoutAssociation Method

RadialArrayArrayElementWithoutAssociation Method

Creates a new radial array from a single element based on an input rotation axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ICollection<ElementId> ArrayElementWithoutAssociation(
    Document aDoc,
    View dBView,
    ElementId id,
    int count,
    Line axis,
    double angle,
    ArrayAnchorMember anchorMember
)
Public Shared Function ArrayElementWithoutAssociation (
    aDoc As Document,
    dBView As View,
    id As ElementId,
    count As Integer,
    axis As Line,
    angle As Double,
    anchorMember As ArrayAnchorMember
) As ICollection(Of ElementId)
public:
static ICollection<ElementId^>^ ArrayElementWithoutAssociation(
    Document^ aDoc,
    View^ dBView,
    ElementId^ id,
    int count,
    Line^ axis,
    double angle,
    ArrayAnchorMember anchorMember
)
static member ArrayElementWithoutAssociation :
        aDoc : Document *
        dBView : View *
        id : ElementId *
        count : int *
        axis : Line *
        angle : float *
        anchorMember : ArrayAnchorMember -> ICollection<ElementId>

Parameters

aDoc Document
The view. If it is a 2d view, translation vector must be in the view plane if the element is a view-specific element.
dBView View
The view.
id ElementId
The element to array. The position of the rotation axis is determined by the center of the element's bounding boxes.
count Int32
The number of array members to create. The accepted range is from 3 to 200 in a project document, and between 0 and 200 in a family document.
axis Line
The rotation axis.
angle Double
The angle in radians of the rotation.
anchorMember ArrayAnchorMember
Indicates if the translation vector specifies the location of the second member of the array, or the last member of the array.

Return Value

ICollection ElementId
The elements created by the operation.
Exceptions
Exception | Condition
ArgumentException | The element id does not exist in the document -or- id is not arrayable. -or- count must be between 3 and 200 in project documents and between 0 and 200 in family documents. -or- The view is invalid for specific view elements array. -or- The rotation axis is invalid to array the element. -or- Angle value must be not zero.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | Failed to create the radial array.
Remarks
The resulting elements will not be associated with an array element.
See Also

Reference

RadialArray Class


RadialArray.Create Method

RadialArrayCreate Method

Overload List
Name | Description
Create(Document, View, ElementId, Int32, Line, Double, ArrayAnchorMember) | Creates a new radial array element from a single element based on an input rotation axis.
Create(Document, View, ICollectionElementId, Int32, Line, Double, ArrayAnchorMember) | Creates a new radial array element from a set of elements based on an input rotation axis.
Top
See Also

Reference

RadialArray Class


RadialArray.Create(Document, View, ElementId, Int32, Line, Double, ArrayAnchorMember) Method

RadialArrayCreate(Document, View, ElementId, Int32, Line, Double, ArrayAnchorMember) Method

Creates a new radial array element from a single element based on an input rotation axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static RadialArray Create(
    Document aDoc,
    View dBView,
    ElementId id,
    int count,
    Line axis,
    double angle,
    ArrayAnchorMember anchorMember
)
Public Shared Function Create (
    aDoc As Document,
    dBView As View,
    id As ElementId,
    count As Integer,
    axis As Line,
    angle As Double,
    anchorMember As ArrayAnchorMember
) As RadialArray
public:
static RadialArray^ Create(
    Document^ aDoc,
    View^ dBView,
    ElementId^ id,
    int count,
    Line^ axis,
    double angle,
    ArrayAnchorMember anchorMember
)
static member Create :
        aDoc : Document *
        dBView : View *
        id : ElementId *
        count : int *
        axis : Line *
        angle : float *
        anchorMember : ArrayAnchorMember -> RadialArray

Parameters

aDoc Document
The document.
dBView View
The view. If it is a 2d view, translation vector must be in the view plane if the element is a view-specific element.
id ElementId
The element to array. The position of the rotation axis is determined by the center of the element's bounding boxes.
count Int32
The number of array members to create. The accepted range is from 3 to 200 in a project document, and between 0 and 200 in a family document.
axis Line
The rotation axis.
angle Double
The angle in radians of the rotation.
anchorMember ArrayAnchorMember
Indicates if the translation vector specifies the location of the second member of the array, or the last member of the array.

Return Value

RadialArray
The new radial array element.
Exceptions
Exception | Condition
ArgumentException | The element id does not exist in the document -or- id is not arrayable. -or- count must be between 3 and 200 in project documents and between 0 and 200 in family documents. -or- The view is invalid for specific view elements array. -or- The rotation axis is invalid to array the element. -or- Angle value must be not zero.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | Failed to create the radial array.
See Also

Reference

RadialArray Class
Create Overload


RadialArray.Create(Document, View, ICollection<ElementId>, Int32, Line, Double, ArrayAnchorMember) Method

RadialArrayCreate(Document, View, ICollectionElementId, Int32, Line, Double, ArrayAnchorMember) Method

Creates a new radial array element from a set of elements based on an input rotation axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static RadialArray Create(
    Document aDoc,
    View dBView,
    ICollection<ElementId> ids,
    int count,
    Line axis,
    double angle,
    ArrayAnchorMember anchorMember
)
Public Shared Function Create (
    aDoc As Document,
    dBView As View,
    ids As ICollection(Of ElementId),
    count As Integer,
    axis As Line,
    angle As Double,
    anchorMember As ArrayAnchorMember
) As RadialArray
public:
static RadialArray^ Create(
    Document^ aDoc,
    View^ dBView,
    ICollection<ElementId^>^ ids,
    int count,
    Line^ axis,
    double angle,
    ArrayAnchorMember anchorMember
)
static member Create :
        aDoc : Document *
        dBView : View *
        ids : ICollection<ElementId> *
        count : int *
        axis : Line *
        angle : float *
        anchorMember : ArrayAnchorMember -> RadialArray

Parameters

aDoc Document
The document.
dBView View
The view. If it is a 2d view, translation vector must be in the view plane if elements include view-specific elements. If elements include view-specific elements, they must belong to this view.
ids ICollection ElementId
The set of elements to array. The position of the rotation axis is determined by the cumulative center of the elements' bounding boxes.
count Int32
The number of array members to create. The accepted range is from 3 to 200 in a project document, and between 0 and 200 in a family document.
axis Line
The rotation axis.
angle Double
The angle in radians of the rotation.
anchorMember ArrayAnchorMember
Indicates if the translation vector specifies the location of the second member of the array, or the last member of the array.

Return Value

RadialArray
The new radial array element.
Exceptions
Exception | Condition
ArgumentException | The given element id set is empty. -or- One or more elements in ids do not exist in the document. -or- One or more elements in ids is owned by different views and thus cannot be arrayed together. -or- One or more elements in ids is not arrayable. -or- count must be between 3 and 200 in project documents and between 0 and 200 in family documents. -or- The view is invalid for specific view elements array. -or- The rotation axis is invalid to array the elements. -or- Angle value must be not zero.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | Failed to create the radial array.
See Also

Reference

RadialArray Class
Create Overload


RadialArray.GetCopiedMemberIds Method

RadialArrayGetCopiedMemberIds Method

Retrieves the copied member ids from the array. The first item in an array contains the original elements from which the array was created. All other items in the array are copies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ICollection<ElementId> GetCopiedMemberIds()
Public Overrides Function GetCopiedMemberIds As ICollection(Of ElementId)
public:
virtual ICollection<ElementId^>^ GetCopiedMemberIds() override
abstract GetCopiedMemberIds : unit -> ICollection<ElementId>
override GetCopiedMemberIds : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
The copied member ids of the Array
Remarks
Note that in the family environment, arrays of count less than 3 are filled with placeholder items so that there are at least 2 copied items. The member ids from these placeholder items are returned too.
See Also

Reference

RadialArray Class


RadialArray.GetMinimumSize Method

RadialArrayGetMinimumSize Method

Returns the minimum size for a radial array based on the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int GetMinimumSize(
    Document document
)
Public Shared Function GetMinimumSize (
    document As Document
) As Integer
public:
static int GetMinimumSize(
    Document^ document
)
static member GetMinimumSize :
        document : Document -> int

Parameters

document Document
The document.

Return Value

Int32
The minimum size of an array.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
This value is 3 in projects and 0 in families.
See Also

Reference

RadialArray Class


RadialArray.GetNumberOfMembersIncludingPlaceholders Method

RadialArrayGetNumberOfMembersIncludingPlaceholders Method

Returns the number of items in an array, including placeholder items in families.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetNumberOfMembersIncludingPlaceholders()
Public Function GetNumberOfMembersIncludingPlaceholders As Integer
public:
int GetNumberOfMembersIncludingPlaceholders()
member GetNumberOfMembersIncludingPlaceholders : unit -> int

Return Value

Int32
The number of elements in an array, including placeholder items in families.
Remarks
To find the number of placeholder elements in a family, subtract the value of the NumMembers property from this value.
See Also

Reference

RadialArray Class


RadialArray.GetOriginalMemberIds Method

RadialArrayGetOriginalMemberIds Method

Retrieves the ids for the original elements from which the array was created. These elements form the first item in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override ICollection<ElementId> GetOriginalMemberIds()
Public Overrides Function GetOriginalMemberIds As ICollection(Of ElementId)
public:
virtual ICollection<ElementId^>^ GetOriginalMemberIds() override
abstract GetOriginalMemberIds : unit -> ICollection<ElementId>
override GetOriginalMemberIds : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
The original member ids of the Array
Remarks
In the family environment, arrays with count 0 use the original elements as a placeholder item for the first array item. The ids of the original elements from which the array was created are returned even for arrays of count 0.
See Also

Reference

RadialArray Class


RadialArray.IsRotationAngleValid Method

RadialArrayIsRotationAngleValid Method

This indicates whether the input angle is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsRotationAngleValid(
    double angle
)
Public Shared Function IsRotationAngleValid (
    angle As Double
) As Boolean
public:
static bool IsRotationAngleValid(
    double angle
)
static member IsRotationAngleValid :
        angle : float -> bool

Parameters

angle Double
The angle.

Return Value

Boolean
True if the value of angle is not zero, false otherwise.
See Also

Reference

RadialArray Class


RadialArray.IsValidArraySize Method

RadialArrayIsValidArraySize Method

Note: This API is now obsolete.

This indicates whether the input count is valid in the project environment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is deprecated in Revit 2025 and may be removed in a later version of Revit. We suggest you use the 'IsValidNumberOfMembers' method instead.")]
public static bool IsValidArraySize(
    int count
)
<ObsoleteAttribute("This method is deprecated in Revit 2025 and may be removed in a later version of Revit. We suggest you use the 'IsValidNumberOfMembers' method instead.")>
Public Shared Function IsValidArraySize (
    count As Integer
) As Boolean
public:
[ObsoleteAttribute(L"This method is deprecated in Revit 2025 and may be removed in a later version of Revit. We suggest you use the 'IsValidNumberOfMembers' method instead.")]
static bool IsValidArraySize(
    int count
)
[<ObsoleteAttribute("This method is deprecated in Revit 2025 and may be removed in a later version of Revit. We suggest you use the 'IsValidNumberOfMembers' method instead.")>]
static member IsValidArraySize :
        count : int -> bool

Parameters

count Int32
The count.

Return Value

Boolean
True if the input count is between 3 and 200, false otherwise.
See Also

Reference

RadialArray Class


RadialArray.IsValidNumberOfMembers Method

RadialArrayIsValidNumberOfMembers Method

This indicates whether the input count is a valid size for an array based on the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidNumberOfMembers(
    int count,
    Document pADoc
)
Public Shared Function IsValidNumberOfMembers (
    count As Integer,
    pADoc As Document
) As Boolean
public:
static bool IsValidNumberOfMembers(
    int count,
    Document^ pADoc
)
static member IsValidNumberOfMembers :
        count : int *
        pADoc : Document -> bool

Parameters

count Int32
The count.
pADoc Document
The document.

Return Value

Boolean
True if an array can be set to the specified count in the given document, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
In project documents, the array count must be between 3 and 200. In family documents, the array count must be between 0 and 200.
See Also

Reference

RadialArray Class


RadialDimension Class

An object that represents an Radial Dimension within the Revit project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBDimension
Autodesk.Revit.DBRadialDimension

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RadialDimension : Dimension
Public Class RadialDimension
    Inherits Dimension
public ref class RadialDimension : public Dimension
type RadialDimension =
    class
        inherit Dimension
    end

The RadialDimension type exposes the following members.

Properties
 | Name | Description
Public property | Above | The text shown above the segment's value. (Inherited from Dimension)
Public property | AreReferencesAvailable | Indicates if this dimension's references can be resolved. (Inherited from Dimension)
Public property | AreSegmentsEqual | Indicates if all segments are forced to be equal. (Inherited from Dimension)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | Below | The text shown below the segment's value. (Inherited from Dimension)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | Curve | A curve that represents the dimension line. (Inherited from Dimension)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | DimensionShape | The shape of this dimension. (Inherited from Dimension)
Public property | DimensionType | The dimension style of this dimension. (Inherited from Dimension)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyLabel | The family parameter label of the dimension. (Inherited from Dimension)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HasLeader | True if dimension has leader, false otherwise. (Inherited from Dimension)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsLocked | Indicates if this dimension is locked. (Inherited from Dimension)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValid | Indicates if this dimension is valid. (Inherited from Dimension)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LeaderEndPosition | The position of the dimension's leader end point. (Inherited from Dimension)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Retrieves or changes the name associated with the Dimension. (Inherited from Dimension)
Public property | NumberOfSegments | The number of segments for the dimension. (Inherited from Dimension)
Public property | Origin | The dimension origin. (Inherited from Dimension)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Prefix | The text shown before the segment's value. (Inherited from Dimension)
Public property | References | Returns an array of geometric references to which the dimension is attached. (Inherited from Dimension)
Public property | Segments | The segments in the dimension. (Inherited from Dimension)
Public property | Suffix | The text shown after the segment's value. (Inherited from Dimension)
 | TextPosition | The position of the dimension text's drag point. (Inherited from Dimension)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | Value | The value of the dimension. (Inherited from Dimension)
Public property | ValueOverride | The text that replaces the segment's value. (Inherited from Dimension)
Public property | ValueString | The dimension value as a user visible string. (Inherited from Dimension)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | View | Supplies the view that contains the dimension if the dimension is view specific. (Inherited from Dimension)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new instance of an Radial Dimension element within the project.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasOneSegment | Determines whether a dimension has one segment. (Inherited from Dimension)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsTextPositionAdjustable | Indicates if this dimension is supported to set/get TextPosition/LeaderEndPosition. (Inherited from Dimension)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | ResetTextPosition | Resets the text position of the dimension to the initial position determined by its type and parameters. (Inherited from Dimension)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RadialDimension Properties

The RadialDimension type exposes the following members.

Properties
 | Name | Description
Public property | Above | The text shown above the segment's value. (Inherited from Dimension)
Public property | AreReferencesAvailable | Indicates if this dimension's references can be resolved. (Inherited from Dimension)
Public property | AreSegmentsEqual | Indicates if all segments are forced to be equal. (Inherited from Dimension)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | Below | The text shown below the segment's value. (Inherited from Dimension)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | Curve | A curve that represents the dimension line. (Inherited from Dimension)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | DimensionShape | The shape of this dimension. (Inherited from Dimension)
Public property | DimensionType | The dimension style of this dimension. (Inherited from Dimension)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyLabel | The family parameter label of the dimension. (Inherited from Dimension)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HasLeader | True if dimension has leader, false otherwise. (Inherited from Dimension)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsLocked | Indicates if this dimension is locked. (Inherited from Dimension)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValid | Indicates if this dimension is valid. (Inherited from Dimension)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LeaderEndPosition | The position of the dimension's leader end point. (Inherited from Dimension)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Retrieves or changes the name associated with the Dimension. (Inherited from Dimension)
Public property | NumberOfSegments | The number of segments for the dimension. (Inherited from Dimension)
Public property | Origin | The dimension origin. (Inherited from Dimension)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Prefix | The text shown before the segment's value. (Inherited from Dimension)
Public property | References | Returns an array of geometric references to which the dimension is attached. (Inherited from Dimension)
Public property | Segments | The segments in the dimension. (Inherited from Dimension)
Public property | Suffix | The text shown after the segment's value. (Inherited from Dimension)
 | TextPosition | The position of the dimension text's drag point. (Inherited from Dimension)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | Value | The value of the dimension. (Inherited from Dimension)
Public property | ValueOverride | The text that replaces the segment's value. (Inherited from Dimension)
Public property | ValueString | The dimension value as a user visible string. (Inherited from Dimension)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | View | Supplies the view that contains the dimension if the dimension is view specific. (Inherited from Dimension)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

RadialDimension Class


RadialDimension Methods

The RadialDimension type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new instance of an Radial Dimension element within the project.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasOneSegment | Determines whether a dimension has one segment. (Inherited from Dimension)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsTextPositionAdjustable | Indicates if this dimension is supported to set/get TextPosition/LeaderEndPosition. (Inherited from Dimension)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | ResetTextPosition | Resets the text position of the dimension to the initial position determined by its type and parameters. (Inherited from Dimension)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

RadialDimension Class


RadialDimension.Create Method

RadialDimensionCreate Method

Creates a new instance of an Radial Dimension element within the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static RadialDimension Create(
    Document document,
    View dbView,
    Reference arcRef,
    bool isDiameter
)
Public Shared Function Create (
    document As Document,
    dbView As View,
    arcRef As Reference,
    isDiameter As Boolean
) As RadialDimension
public:
static RadialDimension^ Create(
    Document^ document,
    View^ dbView,
    Reference^ arcRef,
    bool isDiameter
)
static member Create :
        document : Document *
        dbView : View *
        arcRef : Reference *
        isDiameter : bool -> RadialDimension

Parameters

document Document
The document where new Radial Dimension is created.
dbView View
The view in which the Radial Dimension will appear.
arcRef Reference
The reference which the Radial Dimension will witness.
isDiameter Boolean
Set to true to create a Diameter dimension

Return Value

RadialDimension
The newly created Radial Dimension instance, or if the operation fails.
Exceptions
Exception | Condition
ArgumentException | Reference should be an Arc reference and the origin should lie within the Arc.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
See Also

Reference

RadialDimension Class


RasterQualityType Enumeration

An enumerated type listing the options for raster quality.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum RasterQualityType
Public Enumeration RasterQualityType
public enum class RasterQualityType
type RasterQualityType
Members
Member name | Value | Description
Low | 72 | The type of Raster Quality is Low.
Medium | 150 | The type of Raster Quality is Medium.
High | 300 | The type of Raster Quality is High.
Presentation | 600 | The type of Raster Quality is Presentation.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Rectangle Class

Stores a set of four integers that represent the left, top, right and bottom of a rectangle.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRectangle

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Rectangle : IDisposable
Public Class Rectangle
    Implements IDisposable
public ref class Rectangle : IDisposable
type Rectangle =
    class
        interface IDisposable
    end

The Rectangle type exposes the following members.

Constructors
 | Name | Description
Public method | Rectangle | Create an empty Rectangle instance with values (0,0,0,0).
Public method | Rectangle(Rectangle) | Constructs a new copy of the input ScreenRectangle object.
Public method | Rectangle(Int32, Int32, Int32, Int32) | Creates an Rectangle instance with the specified four integers that represent the left, top, right and bottom of a rectangle.
Top
Properties
 | Name | Description
Public property | Bottom | The y-coordinate of the bottom-right corner of the rectangle.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Left | The x-coordinate of the top-left corner of the rectangle.
Public property | Right | The x-coordinate of the bottom-right corner of the rectangle.
Public property | Top | The y-coordinate of the top-left corner of the rectangle.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the Rectangle
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsNormalized | Returns true if the rectangle coordinates are normalized to the screen coordinate space; that is, left is less than right and top is less than bottom.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
It usually represents a rectangle on the screen. Left must be less than right and top must be less than bottom.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Rectangle Constructor

Overload List
 | Name | Description
Public method | Rectangle | Create an empty Rectangle instance with values (0,0,0,0).
Public method | Rectangle(Rectangle) | Constructs a new copy of the input ScreenRectangle object.
Public method | Rectangle(Int32, Int32, Int32, Int32) | Creates an Rectangle instance with the specified four integers that represent the left, top, right and bottom of a rectangle.
Top
See Also

Reference

Rectangle Class


Rectangle Constructor

Create an empty Rectangle instance with values (0,0,0,0).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Rectangle()
Public Sub New
public:
Rectangle()
new : unit -> Rectangle
See Also

Reference

Rectangle Class
Rectangle Overload


Rectangle(Rectangle) Constructor

Constructs a new copy of the input ScreenRectangle object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Rectangle(
    Rectangle other
)
Public Sub New (
    other As Rectangle
)
public:
Rectangle(
    Rectangle^ other
)
new :
        other : Rectangle -> Rectangle

Parameters

other Rectangle
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

Rectangle Class
Rectangle Overload


Rectangle(Int32, Int32, Int32, Int32) Constructor

Creates an Rectangle instance with the specified four integers that represent the left, top, right and bottom of a rectangle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Rectangle(
    int left,
    int top,
    int right,
    int bottom
)
Public Sub New (
    left As Integer,
    top As Integer,
    right As Integer,
    bottom As Integer
)
public:
Rectangle(
    int left,
    int top,
    int right,
    int bottom
)
new :
        left : int *
        top : int *
        right : int *
        bottom : int -> Rectangle

Parameters

left Int32
The x-coordinate of the top-left corner.
top Int32
The y-coordinate of the top-left corner.
right Int32
The x-coordinate of the bottom-right corner.
bottom Int32
The y-coordinate of the bottom-right corner.
See Also

Reference

Rectangle Class
Rectangle Overload


Rectangle Properties

The Rectangle type exposes the following members.

Properties
 | Name | Description
Public property | Bottom | The y-coordinate of the bottom-right corner of the rectangle.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Left | The x-coordinate of the top-left corner of the rectangle.
Public property | Right | The x-coordinate of the bottom-right corner of the rectangle.
Public property | Top | The y-coordinate of the top-left corner of the rectangle.
Top
See Also

Reference

Rectangle Class


Rectangle.Bottom Property

RectangleBottom Property

The y-coordinate of the bottom-right corner of the rectangle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Bottom { get; set; }
Public Property Bottom As Integer
    Get
    Set
public:
property int Bottom {
    int get ();
    void set (int value);
}
member Bottom : int with get, set

Property Value

Int32
See Also

Reference

Rectangle Class


Rectangle.IsValidObject Property

RectangleIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

Rectangle Class


Rectangle.Left Property

RectangleLeft Property

The x-coordinate of the top-left corner of the rectangle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Left { get; set; }
Public Property Left As Integer
    Get
    Set
public:
property int Left {
    int get ();
    void set (int value);
}
member Left : int with get, set

Property Value

Int32
See Also

Reference

Rectangle Class


Rectangle.Right Property

RectangleRight Property

The x-coordinate of the bottom-right corner of the rectangle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Right { get; set; }
Public Property Right As Integer
    Get
    Set
public:
property int Right {
    int get ();
    void set (int value);
}
member Right : int with get, set

Property Value

Int32
See Also

Reference

Rectangle Class


Rectangle.Top Property

RectangleTop Property

The y-coordinate of the top-left corner of the rectangle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Top { get; set; }
Public Property Top As Integer
    Get
    Set
public:
property int Top {
    int get ();
    void set (int value);
}
member Top : int with get, set

Property Value

Int32
See Also

Reference

Rectangle Class


Rectangle Methods

The Rectangle type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsNormalized | Returns true if the rectangle coordinates are normalized to the screen coordinate space; that is, left is less than right and top is less than bottom.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Rectangle Class


Rectangle.Dispose Method

RectangleDispose Method

Releases all resources used by the Rectangle

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

Rectangle Class


Rectangle.IsNormalized Method

RectangleIsNormalized Method

Returns true if the rectangle coordinates are normalized to the screen coordinate space; that is, left is less than right and top is less than bottom.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsNormalized()
Public Function IsNormalized As Boolean
public:
bool IsNormalized()
member IsNormalized : unit -> bool

Return Value

Boolean
See Also

Reference

Rectangle Class


RectangularGridSegmentOrientation Enumeration

The orientation type of rectangular grid segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum RectangularGridSegmentOrientation
Public Enumeration RectangularGridSegmentOrientation
public enum class RectangularGridSegmentOrientation
type RectangularGridSegmentOrientation
Members
Member name | Value | Description
Vertical | 0 | A vertical GridSegment
Horizontal | 1 | A horizontal GridSegment
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Reference Class

A stable reference to a geometric object in a Revit model.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBReference

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Reference : APIObject
Public Class Reference
    Inherits APIObject
public ref class Reference : public APIObject
type Reference =
    class
        inherit APIObject
    end

The Reference type exposes the following members.

Constructors
 | Name | Description
Public method | Reference | Creates a Reference with the supplied element.
Top
Properties
 | Name | Description
Public property | ElementId | The element id for this reference.
Public property | ElementReferenceType | The type of reference.
Public property | GlobalPoint | The position on which the reference is hit.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | LinkedElementId | The id of the top-level element in the linked document that is referred to by this reference.
Public property | UVPoint | The UV parameters of the reference, if the reference contains a face.
Top
Methods
 | Name | Description
Public method | Contains | Checks if given reference identifies part of object identified by this reference.
 | ConvertToStableRepresentation | Converts the reference to a stable String representation.
Public method | CreateLinkReference | Creates a Reference from a Reference in an RVT Link.
Public method | CreateReferenceInLink | Creates a Reference in an RVT Link from a Reference in the RVT host file.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EqualTo | Checks if given reference is equal to this reference.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | ParseFromStableRepresentation | Converts a stable String representation of a reference to a Reference object.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Reference Constructor

Creates a Reference with the supplied element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Reference(
    Element element
)
Public Sub New (
    element As Element
)
public:
Reference(
    Element^ element
)
new :
        element : Element -> Reference

Parameters

element Element
The element to create a reference.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the parameter is .
See Also

Reference

Reference Class


Reference Properties

The Reference type exposes the following members.

Properties
 | Name | Description
Public property | ElementId | The element id for this reference.
Public property | ElementReferenceType | The type of reference.
Public property | GlobalPoint | The position on which the reference is hit.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | LinkedElementId | The id of the top-level element in the linked document that is referred to by this reference.
Public property | UVPoint | The UV parameters of the reference, if the reference contains a face.
Top
See Also

Reference

Reference Class


Reference.ElementId Property

ReferenceElementId Property

The element id for this reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId ElementId { get; }
Public ReadOnly Property ElementId As ElementId
    Get
public:
property ElementId^ ElementId {
    ElementId^ get ();
}
member ElementId : ElementId with get

Property Value

ElementId
Remarks
InvalidElementId will be returned for references that don't refer to a particular element.
See Also

Reference

Reference Class


Reference.ElementReferenceType Property

ReferenceElementReferenceType Property

The type of reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementReferenceType ElementReferenceType { get; }
Public ReadOnly Property ElementReferenceType As ElementReferenceType
    Get
public:
property ElementReferenceType ElementReferenceType {
    ElementReferenceType get ();
}
member ElementReferenceType : ElementReferenceType with get

Property Value

ElementReferenceType
See Also

Reference

Reference Class


Reference.GlobalPoint Property

ReferenceGlobalPoint Property

The position on which the reference is hit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ GlobalPoint { get; }
Public ReadOnly Property GlobalPoint As XYZ
    Get
public:
property XYZ^ GlobalPoint {
    XYZ^ get ();
}
member GlobalPoint : XYZ with get

Return Value

XYZ
if the reference doesn't have a global point.
Remarks
When using a plan view, the Z-value of a GlobalPoint is not meaningful.
See Also

Reference

Reference Class


Reference.LinkedElementId Property

ReferenceLinkedElementId Property

The id of the top-level element in the linked document that is referred to by this reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId LinkedElementId { get; }
Public ReadOnly Property LinkedElementId As ElementId
    Get
public:
property ElementId^ LinkedElementId {
    ElementId^ get ();
}
member LinkedElementId : ElementId with get

Property Value

ElementId
Remarks
InvalidElementId will be returned for references that don't refer to an element in a linked RVT file.
See Also

Reference

Reference Class


Reference.UVPoint Property

ReferenceUVPoint Property

The UV parameters of the reference, if the reference contains a face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public UV UVPoint { get; }
Public ReadOnly Property UVPoint As UV
    Get
public:
property UV^ UVPoint {
    UV^ get ();
}
member UVPoint : UV with get

Property Value

UV
Remarks
This value is valid only for references of type REFERENCE_TYPE_SURFACE. It is for all other types.
See Also

Reference

Reference Class


Reference Methods

The Reference type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Checks if given reference identifies part of object identified by this reference.
 | ConvertToStableRepresentation | Converts the reference to a stable String representation.
Public method | CreateLinkReference | Creates a Reference from a Reference in an RVT Link.
Public method | CreateReferenceInLink | Creates a Reference in an RVT Link from a Reference in the RVT host file.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EqualTo | Checks if given reference is equal to this reference.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | ParseFromStableRepresentation | Converts a stable String representation of a reference to a Reference object.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Reference Class


Reference.Contains Method

ReferenceContains Method

Checks if given reference identifies part of object identified by this reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Contains(
    Reference reference
)
Public Function Contains (
    reference As Reference
) As Boolean
public:
bool Contains(
    Reference^ reference
)
member Contains :
        reference : Reference -> bool

Parameters

reference Reference
Another reference.

Return Value

Boolean
Returns true if given reference identifies part of object identified by this reference, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when argument is .
Remarks
Can be used to check:
  • If given Reference is a part of a particular Subelement identified by this Reference.
  • If given Reference is a part of a particular Element identified by this Reference.
The input reference can refer to a subelement or a specific geometric item from an element or subelement.
See Also

Reference

Reference Class


Reference.ConvertToStableRepresentation Method

ReferenceConvertToStableRepresentation Method

Converts the reference to a stable String representation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ConvertToStableRepresentation(
    Document document
)
Public Function ConvertToStableRepresentation (
    document As Document
) As String
public:
String^ ConvertToStableRepresentation(
    Document^ document
)
member ConvertToStableRepresentation :
        document : Document -> string

Parameters

document Document
The document.

Return Value

String
Exceptions
Exception | Condition
ArgumentNullException | document was .
InvalidObjectException | Reference contained element ids not found in this document.
Remarks
The stable representation can be used to preserve and restore the reference later in the same Revit session or even in a different session where the same document is present. Use ParseFromStableRepresentation(Document, String) to restore the reference. The representation is based on the internal Revit structure and is not intended to be parsed expect by ParseFromStableRepresentation(Document, String).
Example
C#
VB
C++
F#
Copy
public string SerializeReference(Document doc, Reference reference)
{
    String ids = String.Empty;
    ids = reference.ConvertToStableRepresentation(doc);
    TaskDialog.Show("SerializeReference", "Representation:\n" + ids);
    return ids;
}
Public Function SerializeReference(doc As Document, reference As Reference) As String
    Dim ids As [String] = [String].Empty
    ids = reference.ConvertToStableRepresentation(doc)
    TaskDialog.Show("SerializeReference", "Representation:" & vbLf + ids)
    Return ids
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Reference Class


Reference.CreateLinkReference Method

ReferenceCreateLinkReference Method

Creates a Reference from a Reference in an RVT Link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Reference CreateLinkReference(
    RevitLinkInstance revitLinkInstance
)
Public Function CreateLinkReference (
    revitLinkInstance As RevitLinkInstance
) As Reference
public:
Reference^ CreateLinkReference(
    RevitLinkInstance^ revitLinkInstance
)
member CreateLinkReference :
        revitLinkInstance : RevitLinkInstance -> Reference

Parameters

revitLinkInstance RevitLinkInstance
Id of the RevitLinkInstance that contains the reference.

Return Value

Reference
Exceptions
Exception | Condition
ArgumentNullException | Thrown when revitLinkInstance is .
Remarks
The reference that is returned can be used to create a family instance on a face in an RVT link.
See Also

Reference

Reference Class


Reference.CreateReferenceInLink Method

ReferenceCreateReferenceInLink Method

Creates a Reference in an RVT Link from a Reference in the RVT host file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Reference CreateReferenceInLink()
Public Function CreateReferenceInLink As Reference
public:
Reference^ CreateReferenceInLink()
member CreateReferenceInLink : unit -> Reference

Return Value

Reference
See Also

Reference

Reference Class


Reference.EqualTo Method

ReferenceEqualTo Method

Checks if given reference is equal to this reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool EqualTo(
    Reference reference
)
Public Function EqualTo (
    reference As Reference
) As Boolean
public:
bool EqualTo(
    Reference^ reference
)
member EqualTo :
        reference : Reference -> bool

Parameters

reference Reference
Another reference.

Return Value

Boolean
Returns true if given reference is equal to this reference, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when argument is .
See Also

Reference

Reference Class


Reference.ParseFromStableRepresentation Method

ReferenceParseFromStableRepresentation Method

Converts a stable String representation of a reference to a Reference object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Reference ParseFromStableRepresentation(
    Document document,
    string representation
)
Public Shared Function ParseFromStableRepresentation (
    document As Document,
    representation As String
) As Reference
public:
static Reference^ ParseFromStableRepresentation(
    Document^ document,
    String^ representation
)
static member ParseFromStableRepresentation :
        document : Document *
        representation : string -> Reference

Parameters

document Document
The document.
representation String
The reference representation.

Return Value

Reference
Exceptions
Exception | Condition
ArgumentNullException | One or more arguments was .
ArgumentException | Reference representation could not be successfully parsed, or element id obtained from reference representation could not be found in this document.
Remarks
Use ConvertToStableRepresentation(Document) to obtain the representation. The Reference will have only the following information set:
  • ElementReferenceType
  • ElementId
You will also be able to pass the reference to Document.GetElement(reference) and Element.GetGeometryObjectFromReference(reference) to obtain the element and geometry object referred to.
Example
C#
VB
C++
F#
Copy
public Reference ParseReference(Document doc, String str)
{
    Reference reference = Reference.ParseFromStableRepresentation(doc, str);
    if (null == reference)
    {
        TaskDialog.Show("ParseReference", "Reference is Null.");
    }
    return reference;
}
Public Function ParseReference(doc As Document, str As [String]) As Reference
    Dim reference__1 As Reference = Reference.ParseFromStableRepresentation(doc, str)
    If reference__1 Is Nothing Then
        TaskDialog.Show("ParseReference", "Reference is Null.")
    End If
    Return reference__1
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Reference Class


ReferenceableViewUtils Class

Utilities related to reference views such as reference sections and reference callouts.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBReferenceableViewUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class ReferenceableViewUtils
Public NotInheritable Class ReferenceableViewUtils
public ref class ReferenceableViewUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ReferenceableViewUtils = class end

The ReferenceableViewUtils type exposes the following members.

Methods
Name | Description
ChangeReferencedView | Changes a particular reference view (such as a reference section or reference callout) to refer to a different View.
GetReferencedViewId | Gets the id of the view referenced by a reference view (such as a reference section or reference callout).
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ReferenceableViewUtils Methods

The ReferenceableViewUtils type exposes the following members.

Methods
Name | Description
ChangeReferencedView | Changes a particular reference view (such as a reference section or reference callout) to refer to a different View.
GetReferencedViewId | Gets the id of the view referenced by a reference view (such as a reference section or reference callout).
Top
See Also

Reference

ReferenceableViewUtils Class


ReferenceableViewUtils.ChangeReferencedView Method

ReferenceableViewUtilsChangeReferencedView Method

Changes a particular reference view (such as a reference section or reference callout) to refer to a different View.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void ChangeReferencedView(
    Document document,
    ElementId referenceId,
    ElementId desiredViewId
)
Public Shared Sub ChangeReferencedView (
    document As Document,
    referenceId As ElementId,
    desiredViewId As ElementId
)
public:
static void ChangeReferencedView(
    Document^ document,
    ElementId^ referenceId,
    ElementId^ desiredViewId
)
static member ChangeReferencedView :
        document : Document *
        referenceId : ElementId *
        desiredViewId : ElementId -> unit

Parameters

document Document
The document containing the elements.
referenceId ElementId
The reference view that will be changed to refer to a different View.
desiredViewId ElementId
The id of the View that the reference section or callout will refer to.
Exceptions
Exception | Condition
ArgumentException | referenceId is not a valid reference view. -or- desiredViewId is not a view that can be referenced by referenceId.
ArgumentNullException | A non-optional argument was null
Remarks
Reference views may not refer to a View in which their own graphics (such as the section or callout graphics) will appear. If the reference view's ViewFamilyType is not appropriate for the new View, Revit will automatically change the ViewFamilyType during regeneration. This typically occurs when the referenced view is changed from a model View to a drafting View or vice-versa.
See Also

Reference

ReferenceableViewUtils Class


ReferenceableViewUtils.GetReferencedViewId Method

ReferenceableViewUtilsGetReferencedViewId Method

Gets the id of the view referenced by a reference view (such as a reference section or reference callout).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ElementId GetReferencedViewId(
    Document document,
    ElementId referenceId
)
Public Shared Function GetReferencedViewId (
    document As Document,
    referenceId As ElementId
) As ElementId
public:
static ElementId^ GetReferencedViewId(
    Document^ document,
    ElementId^ referenceId
)
static member GetReferencedViewId :
        document : Document *
        referenceId : ElementId -> ElementId

Parameters

document Document
The document containing the elements.
referenceId ElementId
The reference view that will be changed to refer to a different View.

Return Value

ElementId
The id of the referenced view.
Exceptions
Exception | Condition
ArgumentException | referenceId is not a valid reference view.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ReferenceableViewUtils Class


ReferenceArray Class

An array that contains reference objects.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBReferenceArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ReferenceArray : APIObject,
    IEnumerable
Public Class ReferenceArray
    Inherits APIObject
    Implements IEnumerable
public ref class ReferenceArray : public APIObject,
    IEnumerable
type ReferenceArray =
    class
        inherit APIObject
        interface IEnumerable
    end

The ReferenceArray type exposes the following members.

Constructors
 | Name | Description
Public method | ReferenceArray | Initializes a new instance of the ReferenceArray class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets a reference at a specified index within the array.
Public property | Size | Returns the number of references that are in the array.
Top
Methods
 | Name | Description
Public method | Append | Add the reference to the end of the array.
Public method | Clear | Removes every reference from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified reference into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ReferenceArray Constructor

Initializes a new instance of the ReferenceArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReferenceArray()
Public Sub New
public:
ReferenceArray()
new : unit -> ReferenceArray
See Also

Reference

ReferenceArray Class


ReferenceArray Properties

The ReferenceArray type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets a reference at a specified index within the array.
Public property | Size | Returns the number of references that are in the array.
Top
See Also

Reference

ReferenceArray Class


ReferenceArray.IsEmpty Property

ReferenceArrayIsEmpty Property

Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Boolean
Remarks
If the array is empty then True will be returned, otherwise False.
See Also

Reference

ReferenceArray Class


ReferenceArray.Item Property

ReferenceArrayItem Property

Gets or sets a reference at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Reference this[
    int index
] { get; set; }
Public Overridable Property Item (
    index As Integer
) As Reference
    Get
    Set
public:
virtual property Reference^ Item[int index] {
    Reference^ get (int index);
    void set (int index, Reference^ value);
}
abstract Item : Reference with get, set
override Item : Reference with get, set

Parameters

index Int32
The index of the reference to be set or retrieved.

Return Value

Reference
Returns the reference at the specified index.
See Also

Reference

ReferenceArray Class


ReferenceArray.Size Property

ReferenceArraySize Property

Returns the number of references that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
abstract Size : int with get
override Size : int with get

Property Value

Int32
See Also

Reference

ReferenceArray Class


ReferenceArray Methods

The ReferenceArray type exposes the following members.

Methods
 | Name | Description
Public method | Append | Add the reference to the end of the array.
Public method | Clear | Removes every reference from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified reference into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ReferenceArray Class


ReferenceArray.Append Method

ReferenceArrayAppend Method

Add the reference to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Append(
    Reference item
)
Public Overridable Sub Append (
    item As Reference
)
public:
virtual void Append(
    Reference^ item
)
abstract Append :
        item : Reference -> unit
override Append :
        item : Reference -> unit

Parameters

item Reference
The reference to be added.
See Also

Reference

ReferenceArray Class


ReferenceArray.Clear Method

ReferenceArrayClear Method

Removes every reference from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

ReferenceArray Class


ReferenceArray.ForwardIterator Method

ReferenceArrayForwardIterator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ReferenceArrayIterator ForwardIterator()
Public Overridable Function ForwardIterator As ReferenceArrayIterator
public:
virtual ReferenceArrayIterator^ ForwardIterator()
abstract ForwardIterator : unit -> ReferenceArrayIterator
override ForwardIterator : unit -> ReferenceArrayIterator

Return Value

ReferenceArrayIterator
Returns a forward moving iterator to the array.
See Also

Reference

ReferenceArray Class


ReferenceArray.GetEnumerator Method

ReferenceArrayGetEnumerator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

IEnumerator
Returns a forward moving iterator to the array.

Implements

IEnumerableGetEnumerator
See Also

Reference

ReferenceArray Class


ReferenceArray.Insert Method

ReferenceArrayInsert Method

Insert the specified reference into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Insert(
    Reference item,
    int index
)
Public Overridable Sub Insert (
    item As Reference,
    index As Integer
)
public:
virtual void Insert(
    Reference^ item,
    int index
)
abstract Insert :
        item : Reference *
        index : int -> unit
override Insert :
        item : Reference *
        index : int -> unit

Parameters

item Reference
The reference to be inserted into the array.
index Int32
The reference will be inserted before this index.

Return Value

Returns whether the reference was inserted into the array.
See Also

Reference

ReferenceArray Class


ReferenceArray.ReverseIterator Method

ReferenceArrayReverseIterator Method

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ReferenceArrayIterator ReverseIterator()
Public Overridable Function ReverseIterator As ReferenceArrayIterator
public:
virtual ReferenceArrayIterator^ ReverseIterator()
abstract ReverseIterator : unit -> ReferenceArrayIterator
override ReverseIterator : unit -> ReferenceArrayIterator

Return Value

ReferenceArrayIterator
Returns a backward moving iterator to the array.
See Also

Reference

ReferenceArray Class


ReferenceArrayArray Class

An array that contains ReferenceArray objects.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBReferenceArrayArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ReferenceArrayArray : APIObject,
    IEnumerable
Public Class ReferenceArrayArray
    Inherits APIObject
    Implements IEnumerable
public ref class ReferenceArrayArray : public APIObject,
    IEnumerable
type ReferenceArrayArray =
    class
        inherit APIObject
        interface IEnumerable
    end

The ReferenceArrayArray type exposes the following members.

Constructors
 | Name | Description
Public method | ReferenceArrayArray | Initializes a new instance of the ReferenceArrayArray class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets a ReferenceArray at a specified index within the array.
Public property | Size | Returns the number of ReferenceArrays that are in the array.
Top
Methods
 | Name | Description
Public method | Append |
Public method | Clear | Removes every ReferenceArray from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ReferenceArrayArray Constructor

Initializes a new instance of the ReferenceArrayArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReferenceArrayArray()
Public Sub New
public:
ReferenceArrayArray()
new : unit -> ReferenceArrayArray
See Also

Reference

ReferenceArrayArray Class


ReferenceArrayArray Properties

The ReferenceArrayArray type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets a ReferenceArray at a specified index within the array.
Public property | Size | Returns the number of ReferenceArrays that are in the array.
Top
See Also

Reference

ReferenceArrayArray Class


ReferenceArrayArray.IsEmpty Property

ReferenceArrayArrayIsEmpty Property

Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Boolean
Remarks
If the array is empty then True will be returned, otherwise False.
See Also

Reference

ReferenceArrayArray Class


ReferenceArrayArray.Item Property

ReferenceArrayArrayItem Property

Gets or sets a ReferenceArray at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ReferenceArray this[
    int index
] { get; set; }
Public Overridable Property Item (
    index As Integer
) As ReferenceArray
    Get
    Set
public:
virtual property ReferenceArray^ Item[int index] {
    ReferenceArray^ get (int index);
    void set (int index, ReferenceArray^ value);
}
abstract Item : ReferenceArray with get, set
override Item : ReferenceArray with get, set

Parameters

index Int32
The index of the ReferenceArray to be set or retrieved.

Return Value

ReferenceArray
Returns the ReferenceArray at the specified index.
See Also

Reference

ReferenceArrayArray Class


ReferenceArrayArray.Size Property

ReferenceArrayArraySize Property

Returns the number of ReferenceArrays that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
abstract Size : int with get
override Size : int with get

Property Value

Int32
See Also

Reference

ReferenceArrayArray Class


ReferenceArrayArray Methods

The ReferenceArrayArray type exposes the following members.

Methods
 | Name | Description
Public method | Append |
Public method | Clear | Removes every ReferenceArray from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ReferenceArrayArray Class


ReferenceArrayArray.Append Method

ReferenceArrayArrayAppend Method

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Append(
    ReferenceArray item
)
Public Overridable Sub Append (
    item As ReferenceArray
)
public:
virtual void Append(
    ReferenceArray^ item
)
abstract Append :
        item : ReferenceArray -> unit
override Append :
        item : ReferenceArray -> unit

Parameters

item ReferenceArray
See Also

Reference

ReferenceArrayArray Class


ReferenceArrayArray.Clear Method

ReferenceArrayArrayClear Method

Removes every ReferenceArray from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

ReferenceArrayArray Class


ReferenceArrayArray.ForwardIterator Method

ReferenceArrayArrayForwardIterator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ReferenceArrayArrayIterator ForwardIterator()
Public Overridable Function ForwardIterator As ReferenceArrayArrayIterator
public:
virtual ReferenceArrayArrayIterator^ ForwardIterator()
abstract ForwardIterator : unit -> ReferenceArrayArrayIterator
override ForwardIterator : unit -> ReferenceArrayArrayIterator

Return Value

ReferenceArrayArrayIterator
Returns a forward moving iterator to the array.
See Also

Reference

ReferenceArrayArray Class


ReferenceArrayArray.GetEnumerator Method

ReferenceArrayArrayGetEnumerator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

IEnumerator
Returns a forward moving iterator to the array.

Implements

IEnumerableGetEnumerator
See Also

Reference

ReferenceArrayArray Class


ReferenceArrayArray.Insert Method

ReferenceArrayArrayInsert Method

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Insert(
    ReferenceArray item,
    int index
)
Public Overridable Sub Insert (
    item As ReferenceArray,
    index As Integer
)
public:
virtual void Insert(
    ReferenceArray^ item,
    int index
)
abstract Insert :
        item : ReferenceArray *
        index : int -> unit
override Insert :
        item : ReferenceArray *
        index : int -> unit

Parameters

item ReferenceArray
index Int32
See Also

Reference

ReferenceArrayArray Class


ReferenceArrayArray.ReverseIterator Method

ReferenceArrayArrayReverseIterator Method

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ReferenceArrayArrayIterator ReverseIterator()
Public Overridable Function ReverseIterator As ReferenceArrayArrayIterator
public:
virtual ReferenceArrayArrayIterator^ ReverseIterator()
abstract ReverseIterator : unit -> ReferenceArrayArrayIterator
override ReverseIterator : unit -> ReferenceArrayArrayIterator

Return Value

ReferenceArrayArrayIterator
Returns a backward moving iterator to the array.
See Also

Reference

ReferenceArrayArray Class


ReferenceArrayArrayIterator Class

An iterator to a ReferenceArray array.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBReferenceArrayArrayIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class ReferenceArrayArrayIterator : APIObject,
    IEnumerator
Public MustInherit Class ReferenceArrayArrayIterator
    Inherits APIObject
    Implements IEnumerator
public ref class ReferenceArrayArrayIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type ReferenceArrayArrayIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The ReferenceArrayArrayIterator type exposes the following members.

Constructors
 | Name | Description
Public method | ReferenceArrayArrayIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ReferenceArrayArrayIterator Constructor

For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReferenceArrayArrayIterator()
Public Sub New
public:
ReferenceArrayArrayIterator()
new : unit -> ReferenceArrayArrayIterator
Remarks
This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.
See Also

Reference

ReferenceArrayArrayIterator Class


ReferenceArrayArrayIterator Properties

The ReferenceArrayArrayIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

ReferenceArrayArrayIterator Class


ReferenceArrayArrayIterator.Current Property

ReferenceArrayArrayIteratorCurrent Property

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}
abstract Current : Object with get
override Current : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.
See Also

Reference

ReferenceArrayArrayIterator Class


ReferenceArrayArrayIterator Methods

The ReferenceArrayArrayIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ReferenceArrayArrayIterator Class


ReferenceArrayArrayIterator.MoveNext Method

ReferenceArrayArrayIteratorMoveNext Method

Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumeratorMoveNext
Remarks
MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.
See Also

Reference

ReferenceArrayArrayIterator Class


ReferenceArrayArrayIterator.Reset Method

ReferenceArrayArrayIteratorReset Method

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
Remarks
The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.
See Also

Reference

ReferenceArrayArrayIterator Class


ReferenceArrayIterator Class

An iterator to a reference array.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBReferenceArrayIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class ReferenceArrayIterator : APIObject,
    IEnumerator
Public MustInherit Class ReferenceArrayIterator
    Inherits APIObject
    Implements IEnumerator
public ref class ReferenceArrayIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type ReferenceArrayIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The ReferenceArrayIterator type exposes the following members.

Constructors
 | Name | Description
Public method | ReferenceArrayIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ReferenceArrayIterator Constructor

For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReferenceArrayIterator()
Public Sub New
public:
ReferenceArrayIterator()
new : unit -> ReferenceArrayIterator
Remarks
This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.
See Also

Reference

ReferenceArrayIterator Class


ReferenceArrayIterator Properties

The ReferenceArrayIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

ReferenceArrayIterator Class


ReferenceArrayIterator.Current Property

ReferenceArrayIteratorCurrent Property

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}
abstract Current : Object with get
override Current : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.
See Also

Reference

ReferenceArrayIterator Class


ReferenceArrayIterator Methods

The ReferenceArrayIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ReferenceArrayIterator Class


ReferenceArrayIterator.MoveNext Method

ReferenceArrayIteratorMoveNext Method

Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumeratorMoveNext
Remarks
MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.
See Also

Reference

ReferenceArrayIterator Class


ReferenceArrayIterator.Reset Method

ReferenceArrayIteratorReset Method

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
Remarks
The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.
See Also

Reference

ReferenceArrayIterator Class


ReferenceBaseOnHostType Enumeration

This enumeration is used to classify the Reference Base on Host type .

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ReferenceBaseOnHostType
Public Enumeration ReferenceBaseOnHostType
public enum class ReferenceBaseOnHostType
type ReferenceBaseOnHostType
Members
Member name | Value | Description
PrimaryEnd | 0 |
SecondaryEnd | 1 |
Midpoint | 2 |
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ReferenceIntersector Class

A class used to find and return elements that intersect a ray created from an origin point and direction.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBReferenceIntersector

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ReferenceIntersector : IDisposable
Public Class ReferenceIntersector
    Implements IDisposable
public ref class ReferenceIntersector : IDisposable
type ReferenceIntersector =
    class
        interface IDisposable
    end

The ReferenceIntersector type exposes the following members.

Constructors
 | Name | Description
Public method | ReferenceIntersector(View3D) | Constructs a ReferenceIntersector which is set to return intersections from all elements and representing all reference target types.
Public method | ReferenceIntersector(ElementFilter, FindReferenceTarget, View3D) | Constructs a ReferenceIntersector which is set to return intersections from any element which passes an input filter.
Public method | ReferenceIntersector(ElementId, FindReferenceTarget, View3D) | Constructs a ReferenceIntersector which is set to return intersections from a single target element only.
Public method | ReferenceIntersector(ICollectionElementId, FindReferenceTarget, View3D) | Constructs a ReferenceIntersector which is set to return intersections from any of a set of target elements.
Top
Properties
 | Name | Description
Public property | FindReferencesInRevitLinks | Determines if references inside Revit Links should be found.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | TargetType | The type of reference to find.
Public property | ViewId | The id of the 3D view used for evaluation.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ReferenceIntersector
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Find | Projects a ray from the origin along the given direction, and returns all references from intersected elements which match the ReferenceIntersector's criteria.
Public method | FindNearest | Projects a ray from the origin along the given direction, and returns the nearest reference from intersected elements which match the ReferenceIntersector's criteria.
Public method | GetFilter | Gets the ElementFilter used in intersection testing.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetTargetElementIds | Gets the set of ElementIds to test from in intersection testing.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetFilter | Sets the ElementFilter used in intersection testing.
Public method | SetTargetElementIds | Sets the set of ElementIds to test from in intersection testing.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

An instance of this class can be constructed to return any 3D geometric element that intersects the ray created by the origin and direction, or to return a subset of elements based on filtering and flags. The caller can opt to filter the results using an ElementFilter, or by applying a specific list of acceptable elements. The caller can also specify the type of object to be returned, which might be whole elements, geometry objects, or a combination. In all cases the caller is required to supply a 3D view for evaluation; the view and visibility settings on the input view will determine if a particular element is returned (for example, hidden elements will never be returned by this tool, nor will elements whose geometry is outside the section box of the view).

The class is configured so that a single instance can be constructed and used for multiple evaluations of different rays. The results of the evaluation are not preserved between invocations on the same ReferenceIntersector.

The class also offers an option to return element results encountered in Revit Links. When the FindReferencesInRevitLinks flag is set, the results may include elements in the host document and in any RevitLinkInstance encountered, depending on the other flags set. See the remarks for FindReferencesInRevitLinks for details on how the flags affect the results obtained from links.

Example
C#
VB
C++
F#
Copy
public class RayProjection : IExternalCommand
{
    public Result Execute(ExternalCommandData revit, ref string message, ElementSet elements)
    {
        Document doc = revit.Application.ActiveUIDocument.Document;

        ICollection<ElementId> selectedIds = revit.Application.ActiveUIDocument.Selection.GetElementIds();

        // If skylight is selected, process it.
        FamilyInstance skylight = null;
        if (selectedIds.Count == 1)
        {
            foreach (ElementId id in selectedIds)
            {
                Element e = doc.GetElement(id);
                if (e is FamilyInstance)
                {
                    FamilyInstance instance = e as FamilyInstance;
                    bool isWindow = (instance.Category.BuiltInCategory == BuiltInCategory.OST_Windows);
                    bool isHostedByRoof = (instance.Host.Category.BuiltInCategory == BuiltInCategory.OST_Roofs);

                    if (isWindow && isHostedByRoof)
                    {
                        skylight = instance;
                    }
                }
            }
        }

        if (skylight == null)
        {
            message = "Please select one skylight.";
            return Result.Cancelled;
        }

        // Calculate the height
        Line line = CalculateLineAboveFloor(doc, skylight);

        // Create a model curve to show the distance
        Plane plane = Plane.CreateByNormalAndOrigin(new XYZ(1, 0, 0), line.GetEndPoint(0));
        SketchPlane sketchPlane = SketchPlane.Create(doc, plane);

        ModelCurve curve = doc.Create.NewModelCurve(line, sketchPlane);

        // Show a message with the length value
        TaskDialog.Show("Distance", "Distance to floor: " + String.Format("{0:f2}", line.Length));

        return Result.Succeeded;
    }

    /// <summary>
    /// Determines the line segment that connects the skylight to the nearest floor.
    /// </summary>
    /// <returns>The line segment.</returns>
    private Line CalculateLineAboveFloor(Document doc, FamilyInstance skylight)
    {
        // Find a 3D view to use for the ReferenceIntersector constructor
        FilteredElementCollector collector = new FilteredElementCollector(doc);
        Func<View3D, bool> isNotTemplate = v3 => !(v3.IsTemplate);
        View3D view3D = collector.OfClass(typeof(View3D)).Cast<View3D>().First<View3D>(isNotTemplate);

        // Use the center of the skylight bounding box as the start point.
        BoundingBoxXYZ box = skylight.get_BoundingBox(view3D);
        XYZ center = box.Min.Add(box.Max).Multiply(0.5);

        // Project in the negative Z direction down to the floor.
        XYZ rayDirection = new XYZ(0, 0, -1);

        ElementClassFilter filter = new ElementClassFilter(typeof(Floor));

        ReferenceIntersector refIntersector = new ReferenceIntersector(filter, FindReferenceTarget.Face, view3D);
        ReferenceWithContext referenceWithContext = refIntersector.FindNearest(center, rayDirection);

        Reference reference = referenceWithContext.GetReference();
        XYZ intersection = reference.GlobalPoint;

        // Create line segment from the start point and intersection point.
        Line result = Line.CreateBound(center, intersection);
        return result;
    }
}
<Autodesk.Revit.Attributes.Journaling(Autodesk.Revit.Attributes.JournalingMode.NoCommandData)> _
<Autodesk.Revit.Attributes.Transaction(Autodesk.Revit.Attributes.TransactionMode.Manual)> _
Public Class RayProjection
   Implements IExternalCommand
   Public Function Execute(revit As ExternalCommandData, ByRef message As String, elements As ElementSet) As Autodesk.Revit.UI.Result Implements IExternalCommand.Execute
      Dim doc As Document = revit.Application.ActiveUIDocument.Document

      Dim selectedIds As ICollection(Of ElementId) = revit.Application.ActiveUIDocument.Selection.GetElementIds()

      ' If skylight is selected, process it.
      Dim skylight As FamilyInstance = Nothing
      If selectedIds.Count = 1 Then
         For Each id As ElementId In selectedIds
            Dim e As Element = doc.GetElement(id)
            If TypeOf e Is FamilyInstance Then
               Dim instance As FamilyInstance = TryCast(e, FamilyInstance)
               Dim isWindow As Boolean = instance.Category.BuiltInCategory = BuiltInCategory.OST_Windows
               Dim isHostedByRoof As Boolean = instance.Host.Category.BuiltInCategory = BuiltInCategory.OST_Roofs

               If isWindow AndAlso isHostedByRoof Then
                  skylight = instance
               End If
            End If
         Next
      End If

      If skylight Is Nothing Then
         message = "Please select one skylight."
         Return Result.Cancelled
      End If

      ' Calculate the height
      Dim line As Line = CalculateLineAboveFloor(doc, skylight)

      ' Create a model curve to show the distance
      Dim plane As Plane = plane.CreateByNormalAndOrigin(New XYZ(1, 0, 0), line.GetEndPoint(0))
      Dim sketchPlane__1 As SketchPlane = SketchPlane.Create(doc, plane)

      Dim curve As ModelCurve = doc.Create.NewModelCurve(line, sketchPlane__1)

      ' Show a message with the length value
      TaskDialog.Show("Distance", "Distance to floor: " & [String].Format("{0:f2}", line.Length))

      Return Result.Succeeded
   End Function

   ' <summary>
   ' Determines the line segment that connects the skylight to the nearest floor.
   ' </summary>
   ' <returns>The line segment.</returns>
   Private Function CalculateLineAboveFloor(doc As Document, skylight As FamilyInstance) As Line
      ' Find a 3D view to use for the ReferenceIntersector constructor
      Dim collector As New FilteredElementCollector(doc)
      Dim isNotTemplate As Func(Of View3D, Boolean) = Function(v3) Not (v3.IsTemplate)
      Dim view3D As View3D = collector.OfClass(GetType(View3D)).Cast(Of View3D)().First(isNotTemplate)

      ' Use the center of the skylight bounding box as the start point.
      Dim box As BoundingBoxXYZ = skylight.BoundingBox(view3D)
      Dim center As XYZ = box.Min.Add(box.Max).Multiply(0.5)

      ' Project in the negative Z direction down to the floor.
      Dim rayDirection As New XYZ(0, 0, -1)

      Dim filter As New ElementClassFilter(GetType(Floor))

      Dim refIntersector As New ReferenceIntersector(filter, FindReferenceTarget.Face, view3D)
      Dim referenceWithContext As ReferenceWithContext = refIntersector.FindNearest(center, rayDirection)

      Dim reference As Reference = referenceWithContext.GetReference()
      Dim intersection As XYZ = reference.GlobalPoint

      ' Create line segment from the start point and intersection point.
      Dim result As Line = Line.CreateBound(center, intersection)
      Return result
   End Function
End Class

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ReferenceIntersector Constructor

Overload List
 | Name | Description
Public method | ReferenceIntersector(View3D) | Constructs a ReferenceIntersector which is set to return intersections from all elements and representing all reference target types.
Public method | ReferenceIntersector(ElementFilter, FindReferenceTarget, View3D) | Constructs a ReferenceIntersector which is set to return intersections from any element which passes an input filter.
Public method | ReferenceIntersector(ElementId, FindReferenceTarget, View3D) | Constructs a ReferenceIntersector which is set to return intersections from a single target element only.
Public method | ReferenceIntersector(ICollectionElementId, FindReferenceTarget, View3D) | Constructs a ReferenceIntersector which is set to return intersections from any of a set of target elements.
Top
See Also

Reference

ReferenceIntersector Class


ReferenceIntersector(View3D) Constructor

Constructs a ReferenceIntersector which is set to return intersections from all elements and representing all reference target types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReferenceIntersector(
    View3D view3d
)
Public Sub New (
    view3d As View3D
)
public:
ReferenceIntersector(
    View3D^ view3d
)
new :
        view3d : View3D -> ReferenceIntersector

Parameters

view3d View3D
The view in which to find references.
Exceptions
Exception | Condition
ArgumentException | Returns true if the view is not a view template.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ReferenceIntersector Class
ReferenceIntersector Overload


ReferenceIntersector(ElementFilter, FindReferenceTarget, View3D) Constructor

Constructs a ReferenceIntersector which is set to return intersections from any element which passes an input filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReferenceIntersector(
    ElementFilter filter,
    FindReferenceTarget targetType,
    View3D view3d
)
Public Sub New (
    filter As ElementFilter,
    targetType As FindReferenceTarget,
    view3d As View3D
)
public:
ReferenceIntersector(
    ElementFilter^ filter,
    FindReferenceTarget targetType,
    View3D^ view3d
)
new :
        filter : ElementFilter *
        targetType : FindReferenceTarget *
        view3d : View3D -> ReferenceIntersector

Parameters

filter ElementFilter
The element filter. All references will belong to elements passing this filter.
targetType FindReferenceTarget
The target type of references to return.
view3d View3D
The view in which to find references.
Exceptions
Exception | Condition
ArgumentException | Returns true if the view is not a view template.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ReferenceIntersector Class
ReferenceIntersector Overload


ReferenceIntersector(ElementId, FindReferenceTarget, View3D) Constructor

Constructs a ReferenceIntersector which is set to return intersections from a single target element only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReferenceIntersector(
    ElementId targetElementId,
    FindReferenceTarget targetType,
    View3D view3d
)
Public Sub New (
    targetElementId As ElementId,
    targetType As FindReferenceTarget,
    view3d As View3D
)
public:
ReferenceIntersector(
    ElementId^ targetElementId,
    FindReferenceTarget targetType,
    View3D^ view3d
)
new :
        targetElementId : ElementId *
        targetType : FindReferenceTarget *
        view3d : View3D -> ReferenceIntersector

Parameters

targetElementId ElementId
The target element id.
targetType FindReferenceTarget
The target type of references to return.
view3d View3D
The view in which to find references.
Exceptions
Exception | Condition
ArgumentException | Returns true if the view is not a view template.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ReferenceIntersector Class
ReferenceIntersector Overload


ReferenceIntersector(ICollection<ElementId>, FindReferenceTarget, View3D) Constructor

ReferenceIntersector(ICollectionElementId, FindReferenceTarget, View3D) Constructor

Constructs a ReferenceIntersector which is set to return intersections from any of a set of target elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReferenceIntersector(
    ICollection<ElementId> targetElementIds,
    FindReferenceTarget targetType,
    View3D view3d
)
Public Sub New (
    targetElementIds As ICollection(Of ElementId),
    targetType As FindReferenceTarget,
    view3d As View3D
)
public:
ReferenceIntersector(
    ICollection<ElementId^>^ targetElementIds,
    FindReferenceTarget targetType,
    View3D^ view3d
)
new :
        targetElementIds : ICollection<ElementId> *
        targetType : FindReferenceTarget *
        view3d : View3D -> ReferenceIntersector

Parameters

targetElementIds ICollection ElementId
The target element ids.
targetType FindReferenceTarget
The target type of references to return.
view3d View3D
The view in which to find references.
Exceptions
Exception | Condition
ArgumentException | Returns true if the view is not a view template.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ReferenceIntersector Class
ReferenceIntersector Overload


ReferenceIntersector Properties

The ReferenceIntersector type exposes the following members.

Properties
 | Name | Description
Public property | FindReferencesInRevitLinks | Determines if references inside Revit Links should be found.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | TargetType | The type of reference to find.
Public property | ViewId | The id of the 3D view used for evaluation.
Top
See Also

Reference

ReferenceIntersector Class


ReferenceIntersector.FindReferencesInRevitLinks Property

ReferenceIntersectorFindReferencesInRevitLinks Property

Determines if references inside Revit Links should be found.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool FindReferencesInRevitLinks { get; set; }
Public Property FindReferencesInRevitLinks As Boolean
    Get
    Set
public:
property bool FindReferencesInRevitLinks {
    bool get ();
    void set (bool value);
}
member FindReferencesInRevitLinks : bool with get, set

Property Value

Boolean
Remarks

If set to false, no Reference to any Element from a Revit Link will be found by the ReferenceIntersector, and you can be certain that any Reference returned will be to a host document Element only. If set to true, the results may include both References to Elements in hosts and References to Elements from a link instance.

Setting this value to true may interact with some other settings on the ReferenceIntersector. If a list of target ElementIds is set, references will be returned only if the ElementId matches the id of the intersected RevitLinkInstance. If there is a match, any intersecting elements in the link will be returned (their ids will not be compared with the target ids list). If there is an ElementFilter applied, the elements in the link will be evaluated against the stored ElementFilter.

Note that results may not be as expected if the filter applied is geometric (such as a BoundingBox filter or ElementIntersects filter). This is because the filter will be evaluated for linked elements in the coordinates of the linked model, which may not match the coordinates of the elements as they appear in the host model. Also, ElementFilters that accept a Document and/or ElementId as input during their instantiation will not correctly pass elements that appear in the link, because the filter will not be able to match link elements to the filter's criteria.

See Also

Reference

ReferenceIntersector Class


ReferenceIntersector.IsValidObject Property

ReferenceIntersectorIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ReferenceIntersector Class


ReferenceIntersector.TargetType Property

ReferenceIntersectorTargetType Property

The type of reference to find.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FindReferenceTarget TargetType { get; set; }
Public Property TargetType As FindReferenceTarget
    Get
    Set
public:
property FindReferenceTarget TargetType {
    FindReferenceTarget get ();
    void set (FindReferenceTarget value);
}
member TargetType : FindReferenceTarget with get, set

Property Value

FindReferenceTarget
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ReferenceIntersector Class


ReferenceIntersector.ViewId Property

ReferenceIntersectorViewId Property

The id of the 3D view used for evaluation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId ViewId { get; set; }
Public Property ViewId As ElementId
    Get
    Set
public:
property ElementId^ ViewId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member ViewId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentException | When setting this property: viewId is not the id of a 3D view.
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ReferenceIntersector Class


ReferenceIntersector Methods

The ReferenceIntersector type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Find | Projects a ray from the origin along the given direction, and returns all references from intersected elements which match the ReferenceIntersector's criteria.
Public method | FindNearest | Projects a ray from the origin along the given direction, and returns the nearest reference from intersected elements which match the ReferenceIntersector's criteria.
Public method | GetFilter | Gets the ElementFilter used in intersection testing.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetTargetElementIds | Gets the set of ElementIds to test from in intersection testing.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetFilter | Sets the ElementFilter used in intersection testing.
Public method | SetTargetElementIds | Sets the set of ElementIds to test from in intersection testing.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ReferenceIntersector Class


ReferenceIntersector.Dispose Method

ReferenceIntersectorDispose Method

Releases all resources used by the ReferenceIntersector

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ReferenceIntersector Class


ReferenceIntersector.Find Method

ReferenceIntersectorFind Method

Projects a ray from the origin along the given direction, and returns all references from intersected elements which match the ReferenceIntersector's criteria.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ReferenceWithContext> Find(
    XYZ origin,
    XYZ direction
)
Public Function Find (
    origin As XYZ,
    direction As XYZ
) As IList(Of ReferenceWithContext)
public:
IList<ReferenceWithContext^>^ Find(
    XYZ^ origin,
    XYZ^ direction
)
member Find :
        origin : XYZ *
        direction : XYZ -> IList<ReferenceWithContext>

Parameters

origin XYZ
The origin of the ray.
direction XYZ
The direction of the ray.

Return Value

IList ReferenceWithContext
A collection containing the intersected references.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ReferenceIntersector Class


ReferenceIntersector.FindNearest Method

ReferenceIntersectorFindNearest Method

Projects a ray from the origin along the given direction, and returns the nearest reference from intersected elements which match the ReferenceIntersector's criteria.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReferenceWithContext FindNearest(
    XYZ origin,
    XYZ direction
)
Public Function FindNearest (
    origin As XYZ,
    direction As XYZ
) As ReferenceWithContext
public:
ReferenceWithContext^ FindNearest(
    XYZ^ origin,
    XYZ^ direction
)
member FindNearest :
        origin : XYZ *
        direction : XYZ -> ReferenceWithContext

Parameters

origin XYZ
The origin of the ray.
direction XYZ
The direction of the ray.

Return Value

ReferenceWithContext
The intersected reference nearest to the ray origin, if none is found
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Note that FindNearest() is a convenience method, and other references that may be nearly the same distance from the origin can be obtained from Find(XYZ, XYZ).
See Also

Reference

ReferenceIntersector Class


ReferenceIntersector.GetFilter Method

ReferenceIntersectorGetFilter Method

Gets the ElementFilter used in intersection testing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementFilter GetFilter()
Public Function GetFilter As ElementFilter
public:
ElementFilter^ GetFilter()
member GetFilter : unit -> ElementFilter

Return Value

ElementFilter
The ElementFilter, or if no filter is set.
See Also

Reference

ReferenceIntersector Class


ReferenceIntersector.GetTargetElementIds Method

ReferenceIntersectorGetTargetElementIds Method

Gets the set of ElementIds to test from in intersection testing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetTargetElementIds()
Public Function GetTargetElementIds As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetTargetElementIds()
member GetTargetElementIds : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
The target ElementIds.
See Also

Reference

ReferenceIntersector Class


ReferenceIntersector.SetFilter Method

ReferenceIntersectorSetFilter Method

Sets the ElementFilter used in intersection testing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetFilter(
    ElementFilter filter
)
Public Sub SetFilter (
    filter As ElementFilter
)
public:
void SetFilter(
    ElementFilter^ filter
)
member SetFilter :
        filter : ElementFilter -> unit

Parameters

filter ElementFilter
The ElementFilter. Pass to remove the existing filter.
See Also

Reference

ReferenceIntersector Class


ReferenceIntersector.SetTargetElementIds Method

ReferenceIntersectorSetTargetElementIds Method

Sets the set of ElementIds to test from in intersection testing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetTargetElementIds(
    ICollection<ElementId> elementIds
)
Public Sub SetTargetElementIds (
    elementIds As ICollection(Of ElementId)
)
public:
void SetTargetElementIds(
    ICollection<ElementId^>^ elementIds
)
member SetTargetElementIds :
        elementIds : ICollection<ElementId> -> unit

Parameters

elementIds ICollection ElementId
The target ElementIds.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ReferenceIntersector Class


ReferencePlane Class

Represents a reference plane of Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBDatumPlane
Autodesk.Revit.DBReferencePlane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ReferencePlane : DatumPlane
Public Class ReferencePlane
    Inherits DatumPlane
public ref class ReferencePlane : public DatumPlane
type ReferencePlane =
    class
        inherit DatumPlane
    end

The ReferencePlane type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | BubbleEnd | The bubble end of the reference plane.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Direction | The direction of the reference plane.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FreeEnd | The free end of the reference plane.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | The name property of the reference plane.
Public property | Normal | The normal vector of the reference plane.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | AddLeader | Adds a default Leader for the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders). (Inherited from DatumPlane)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanBeVisibleInView | Checks if the datum plane can be visible in the view. (Inherited from DatumPlane)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | Flip | Flips the orientation of the reference plane.
Public method | GetCurvesInView | Gets a collection of curves representing the DatumPlane element in the given view. (Inherited from DatumPlane)
Public method | GetDatumExtentTypeInView | Identifies whether the curve representing the datum plane is displayed according to its actual 3d extents, or else according to a view specific setting. (Inherited from DatumPlane)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLeader | Gets a copy of the leader applied to the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders). (Inherited from DatumPlane)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPlane | Returns the geometry plane to which the reference plane is assigned.
Public method | GetPropagationViews | Gets a list of candidate views which are parallel to the current view and to which the extents of the datum may be propagated. (Inherited from DatumPlane)
Public method | GetReference | Returns the geometry reference of the reference plane.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasBubbleInView | Identifies if the DatumPlane has bubble or not. (Inherited from DatumPlane)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HideBubbleInView | Hides the bubble in a view. This method does not apply to Reference planes. (Inherited from DatumPlane)
Public method | IsBubbleVisibleInView | Identifies if the bubble is visible or not in a view. (Inherited from DatumPlane)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsCurveValidInView | Checks if the curve is valid to be as the extents for the datum plane in a view. The curve must be bound and coincident with the original one of the datum plane. (Inherited from DatumPlane)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsLeaderValid | Identifies if the leader valid or not for this DatumPlane. This method does not apply to Reference planes (which do not support leaders). (Inherited from DatumPlane)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | Maximize3DExtents | Computes the 3d extents of all model geometry and levels, and extends the 3d extents of this datum surface to include the model extents. (Inherited from DatumPlane)
Public method | PropagateToViews | Propagates the extents applied to this datum in the view to the specified parallel views. (Inherited from DatumPlane)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetCurveInView | Sets the extents to match the curve. (Inherited from DatumPlane)
Public method | SetDatumExtentType | Sets whether the curve representing the datum plane is displayed according to its 3d extents, or else according to a view specific setting. (Inherited from DatumPlane)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetLeader | Sets the leader to the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders). (Inherited from DatumPlane)
Public method | ShowBubbleInView | Shows the bubble in a view. This method does not apply to Reference planes. (Inherited from DatumPlane)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Example
C#
VB
C++
F#
Copy
private void Getinfo_ReferencePlane(ReferencePlane refPlane)
{
    string message = "Reference Plane: ";
    //get the bubble end of the reference plane
    XYZ bubbleEnd = refPlane.BubbleEnd;
    message += "\nBubble end: (" + bubbleEnd.X + ", "
                       + bubbleEnd.Y + ", " + bubbleEnd.Z + ")";

    //get the direction of the reference plane
    XYZ direction = refPlane.Direction;
    message += "\nDirection: (" + direction.X + ", "
                    + direction.Y + ", " + direction.Z + ")";

    //get the freeEnd of the reference plane
    XYZ freeEnd = refPlane.FreeEnd;
    message += "\nFree End: (" + freeEnd.X + ", "
                    + freeEnd.Y + ", " + freeEnd.Z + ")";

    //get the name of the reference plane
    message += "\nName: " + refPlane.Name;

    //get the normal vector of the reference plane
    XYZ normal = refPlane.Normal;
    message += "\nNormal vector: (" + normal.X + ", "
                    + normal.Y + ", " + normal.Z + ")";

    //get the geometry plane to which the reference plane assigned
    Autodesk.Revit.DB.Plane plane = refPlane.GetPlane();
    message += "\norigin of the plane: (" + plane.Origin.X + ", "
                    + plane.Origin.Y + ", " + plane.Origin.Z + ")";

    message += "\nnormal of the plane: (" + plane.Normal.X + ", "
                    + plane.Normal.Y + ", " + plane.Normal.Z + ")";

    message += "\nXvec of the plane: (" + plane.XVec.X + ", "
                    + plane.XVec.Y + ", " + plane.XVec.Z + ")";

    message += "\nYvec of the plane: (" + plane.YVec.X + ", "
                    + plane.YVec.Y + ", " + plane.YVec.Z + ")";

    TaskDialog.Show("Revit",message);
}
Private Sub Getinfo_ReferencePlane(refPlane As ReferencePlane)
    Dim message As String = "Reference Plane: "
    'get the bubble end of the reference plane
    Dim bubbleEnd As XYZ = refPlane.BubbleEnd
    message += ((vbLf & "Bubble end: (" + bubbleEnd.X & ", ") + bubbleEnd.Y & ", ") + bubbleEnd.Z & ")"

    'get the direction of the reference plane
    Dim direction As XYZ = refPlane.Direction
    message += ((vbLf & "Direction: (" + direction.X & ", ") + direction.Y & ", ") + direction.Z & ")"

    'get the freeEnd of the reference plane
    Dim freeEnd As XYZ = refPlane.FreeEnd
    message += ((vbLf & "Free End: (" + freeEnd.X & ", ") + freeEnd.Y & ", ") + freeEnd.Z & ")"

    'get the name of the reference plane
    message += vbLf & "Name: " & Convert.ToString(refPlane.Name)

    'get the normal vector of the reference plane
    Dim normal As XYZ = refPlane.Normal
    message += ((vbLf & "Normal vector: (" + normal.X & ", ") + normal.Y & ", ") + normal.Z & ")"

    'get the geometry plane to which the reference plane assigned
 Dim plane As Autodesk.Revit.DB.Plane = refPlane.GetPlane()
    message += ((vbLf & "origin of the plane: (" + plane.Origin.X & ", ") + plane.Origin.Y & ", ") + plane.Origin.Z & ")"

    message += ((vbLf & "normal of the plane: (" + plane.Normal.X & ", ") + plane.Normal.Y & ", ") + plane.Normal.Z & ")"

    message += ((vbLf & "Xvec of the plane: (" + plane.XVec.X & ", ") + plane.XVec.Y & ", ") + plane.XVec.Z & ")"

    message += ((vbLf & "Yvec of the plane: (" + plane.YVec.X & ", ") + plane.YVec.Y & ", ") + plane.YVec.Z & ")"

    TaskDialog.Show("Revit", message)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ReferencePlane Properties

The ReferencePlane type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | BubbleEnd | The bubble end of the reference plane.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Direction | The direction of the reference plane.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FreeEnd | The free end of the reference plane.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | The name property of the reference plane.
Public property | Normal | The normal vector of the reference plane.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

ReferencePlane Class


ReferencePlane.BubbleEnd Property

ReferencePlaneBubbleEnd Property

The bubble end of the reference plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ BubbleEnd { get; set; }
Public Property BubbleEnd As XYZ
    Get
    Set
public:
property XYZ^ BubbleEnd {
    XYZ^ get ();
    void set (XYZ^ value);
}
member BubbleEnd : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
When setting this property, an exception will be thrown if the bubble end is set to almost the same point as free end or if the vector from BubbleEnd -> FreeEnd is not perpendicular to the normal vector.
See Also

Reference

ReferencePlane Class


ReferencePlane.Direction Property

ReferencePlaneDirection Property

The direction of the reference plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Direction { get; set; }
Public Property Direction As XYZ
    Get
    Set
public:
property XYZ^ Direction {
    XYZ^ get ();
    void set (XYZ^ value);
}
member Direction : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
ArgumentOutOfRangeException | When setting this property: newDir has zero length.
Remarks
When setting this property, an exception will be thrown if the direction vector is not perpendicular to the normal vector.
See Also

Reference

ReferencePlane Class


ReferencePlane.FreeEnd Property

ReferencePlaneFreeEnd Property

The free end of the reference plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ FreeEnd { get; set; }
Public Property FreeEnd As XYZ
    Get
    Set
public:
property XYZ^ FreeEnd {
    XYZ^ get ();
    void set (XYZ^ value);
}
member FreeEnd : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
When setting this property, an exception will be thrown if the free end is set to almost the same point as bubble end or if the vector from BubbleEnd -> FreeEnd is not perpendicular to the normal vector.
See Also

Reference

ReferencePlane Class


ReferencePlane.Name Property

ReferencePlaneName Property

The name property of the reference plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

String
Remarks
This property overrides Element's default implementation.
See Also

Reference

ReferencePlane Class


ReferencePlane.Normal Property

ReferencePlaneNormal Property

The normal vector of the reference plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Normal { get; }
Public ReadOnly Property Normal As XYZ
    Get
public:
property XYZ^ Normal {
    XYZ^ get ();
}
member Normal : XYZ with get

Property Value

XYZ
See Also

Reference

ReferencePlane Class


ReferencePlane Methods

The ReferencePlane type exposes the following members.

Methods
 | Name | Description
Public method | AddLeader | Adds a default Leader for the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders). (Inherited from DatumPlane)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanBeVisibleInView | Checks if the datum plane can be visible in the view. (Inherited from DatumPlane)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | Flip | Flips the orientation of the reference plane.
Public method | GetCurvesInView | Gets a collection of curves representing the DatumPlane element in the given view. (Inherited from DatumPlane)
Public method | GetDatumExtentTypeInView | Identifies whether the curve representing the datum plane is displayed according to its actual 3d extents, or else according to a view specific setting. (Inherited from DatumPlane)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLeader | Gets a copy of the leader applied to the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders). (Inherited from DatumPlane)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPlane | Returns the geometry plane to which the reference plane is assigned.
Public method | GetPropagationViews | Gets a list of candidate views which are parallel to the current view and to which the extents of the datum may be propagated. (Inherited from DatumPlane)
Public method | GetReference | Returns the geometry reference of the reference plane.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasBubbleInView | Identifies if the DatumPlane has bubble or not. (Inherited from DatumPlane)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HideBubbleInView | Hides the bubble in a view. This method does not apply to Reference planes. (Inherited from DatumPlane)
Public method | IsBubbleVisibleInView | Identifies if the bubble is visible or not in a view. (Inherited from DatumPlane)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsCurveValidInView | Checks if the curve is valid to be as the extents for the datum plane in a view. The curve must be bound and coincident with the original one of the datum plane. (Inherited from DatumPlane)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsLeaderValid | Identifies if the leader valid or not for this DatumPlane. This method does not apply to Reference planes (which do not support leaders). (Inherited from DatumPlane)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | Maximize3DExtents | Computes the 3d extents of all model geometry and levels, and extends the 3d extents of this datum surface to include the model extents. (Inherited from DatumPlane)
Public method | PropagateToViews | Propagates the extents applied to this datum in the view to the specified parallel views. (Inherited from DatumPlane)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetCurveInView | Sets the extents to match the curve. (Inherited from DatumPlane)
Public method | SetDatumExtentType | Sets whether the curve representing the datum plane is displayed according to its 3d extents, or else according to a view specific setting. (Inherited from DatumPlane)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetLeader | Sets the leader to the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders). (Inherited from DatumPlane)
Public method | ShowBubbleInView | Shows the bubble in a view. This method does not apply to Reference planes. (Inherited from DatumPlane)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ReferencePlane Class


ReferencePlane.Flip Method

ReferencePlaneFlip Method

Flips the orientation of the reference plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Flip()
Public Sub Flip
public:
void Flip()
member Flip : unit -> unit
See Also

Reference

ReferencePlane Class


ReferencePlane.GetPlane Method

ReferencePlaneGetPlane Method

Returns the geometry plane to which the reference plane is assigned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Plane GetPlane()
Public Function GetPlane As Plane
public:
Plane^ GetPlane()
member GetPlane : unit -> Plane

Return Value

Plane
The geometry plane to which the reference plane is assigned.
See Also

Reference

ReferencePlane Class


ReferencePlane.GetReference Method

ReferencePlaneGetReference Method

Returns the geometry reference of the reference plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Reference GetReference()
Public Function GetReference As Reference
public:
Reference^ GetReference()
member GetReference : unit -> Reference

Return Value

Reference
The geometry reference of the reference plane.
See Also

Reference

ReferencePlane Class


ReferencePoint Class

A reference point in an Autodesk Revit family.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBReferencePoint

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ReferencePoint : Element
Public Class ReferencePoint
    Inherits Element
public ref class ReferencePoint : public Element
type ReferencePoint =
    class
        inherit Element
    end

The ReferencePoint type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | CoordinatePlaneVisibility | Visibility settings for the coordinate reference planes.
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | (Overrides ElementName)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Position | The position of the ReferencePoint.
Public property | ShowNormalReferencePlaneOnly | Whether all three coordinate planes are shown, or only the normal (XY) plane.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | Visible | Whether the point is visible when the family is loaded into a project.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetCoordinatePlaneReferenceXY | A reference for the XY plane of the coordinate system.
Public method | GetCoordinatePlaneReferenceXZ | A reference for the XZ plane of the coordinate system.
Public method | GetCoordinatePlaneReferenceYZ | A reference for the YZ plane of the coordinate system.
Public method | GetCoordinateSystem | The position and orientation of the ReferencePoint.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetHubId | Id of associated Hub.
Public method | GetInterpolatingCurves | The set of CurveByPoints elements that interpolate a ReferencePoint.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPointElementReference | Retrieve a copy of the rule that computes the location of the ReferencePoint relative to other elements in the document.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetVisibility | Gets the visibility for the point.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetCoordinateSystem | The position and orientation of the ReferencePoint.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetPointElementReference | Change the rule for computing the location of the ReferencePoint relative to other elements in the document.
Public method | SetVisibility | Sets the visibility for the point.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
A ReferencePoint represents a point in space together with a local coordinate system. ReferencePoints can be free, or constrained to other elements in several ways. When the point is constrained, the coordinate system is also constrained in certain ways.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ReferencePoint Properties

The ReferencePoint type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | CoordinatePlaneVisibility | Visibility settings for the coordinate reference planes.
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | (Overrides ElementName)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Position | The position of the ReferencePoint.
Public property | ShowNormalReferencePlaneOnly | Whether all three coordinate planes are shown, or only the normal (XY) plane.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | Visible | Whether the point is visible when the family is loaded into a project.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

ReferencePoint Class


ReferencePoint.CoordinatePlaneVisibility Property

ReferencePointCoordinatePlaneVisibility Property

Visibility settings for the coordinate reference planes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CoordinatePlaneVisibility CoordinatePlaneVisibility { get; set; }
Public Property CoordinatePlaneVisibility As CoordinatePlaneVisibility
    Get
    Set
public:
property CoordinatePlaneVisibility CoordinatePlaneVisibility {
    CoordinatePlaneVisibility get ();
    void set (CoordinatePlaneVisibility value);
}
member CoordinatePlaneVisibility : CoordinatePlaneVisibility with get, set

Property Value

CoordinatePlaneVisibility
See Also

Reference

ReferencePoint Class


ReferencePoint.Name Property

ReferencePointName Property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string Name { get; set; }
Public Overrides Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

String
See Also

Reference

ReferencePoint Class


ReferencePoint.Position Property

ReferencePointPosition Property

The position of the ReferencePoint.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Position { get; set; }
Public Property Position As XYZ
    Get
    Set
public:
property XYZ^ Position {
    XYZ^ get ();
    void set (XYZ^ value);
}
member Position : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
InvalidOperationException | Thrown when CoordinateSystem is set while the Reference property is not , and the ReferencePoint is unable to move to the new location.
Remarks
This is an alternate interface to the property CoordinateSystem.Origin. When set, the effect is the same as setting the CoordinateSystem property to the same as its current value but with a different Origin.
See Also

Reference

ReferencePoint Class


ReferencePoint.ShowNormalReferencePlaneOnly Property

ReferencePointShowNormalReferencePlaneOnly Property

Whether all three coordinate planes are shown, or only the normal (XY) plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShowNormalReferencePlaneOnly { get; set; }
Public Property ShowNormalReferencePlaneOnly As Boolean
    Get
    Set
public:
property bool ShowNormalReferencePlaneOnly {
    bool get ();
    void set (bool value);
}
member ShowNormalReferencePlaneOnly : bool with get, set

Property Value

Boolean
See Also

Reference

ReferencePoint Class


ReferencePoint.Visible Property

ReferencePointVisible Property

Whether the point is visible when the family is loaded into a project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Visible { get; set; }
Public Property Visible As Boolean
    Get
    Set
public:
property bool Visible {
    bool get ();
    void set (bool value);
}
member Visible : bool with get, set

Property Value

Boolean
See Also

Reference

ReferencePoint Class


ReferencePoint Methods

The ReferencePoint type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetCoordinatePlaneReferenceXY | A reference for the XY plane of the coordinate system.
Public method | GetCoordinatePlaneReferenceXZ | A reference for the XZ plane of the coordinate system.
Public method | GetCoordinatePlaneReferenceYZ | A reference for the YZ plane of the coordinate system.
Public method | GetCoordinateSystem | The position and orientation of the ReferencePoint.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetHubId | Id of associated Hub.
Public method | GetInterpolatingCurves | The set of CurveByPoints elements that interpolate a ReferencePoint.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPointElementReference | Retrieve a copy of the rule that computes the location of the ReferencePoint relative to other elements in the document.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetVisibility | Gets the visibility for the point.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetCoordinateSystem | The position and orientation of the ReferencePoint.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetPointElementReference | Change the rule for computing the location of the ReferencePoint relative to other elements in the document.
Public method | SetVisibility | Sets the visibility for the point.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ReferencePoint Class


ReferencePoint.GetCoordinatePlaneReferenceXY Method

ReferencePointGetCoordinatePlaneReferenceXY Method

A reference for the XY plane of the coordinate system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Reference GetCoordinatePlaneReferenceXY()
Public Function GetCoordinatePlaneReferenceXY As Reference
public:
Reference^ GetCoordinatePlaneReferenceXY()
member GetCoordinatePlaneReferenceXY : unit -> Reference

Return Value

Reference
See Also

Reference

ReferencePoint Class


ReferencePoint.GetCoordinatePlaneReferenceXZ Method

ReferencePointGetCoordinatePlaneReferenceXZ Method

A reference for the XZ plane of the coordinate system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Reference GetCoordinatePlaneReferenceXZ()
Public Function GetCoordinatePlaneReferenceXZ As Reference
public:
Reference^ GetCoordinatePlaneReferenceXZ()
member GetCoordinatePlaneReferenceXZ : unit -> Reference

Return Value

Reference
See Also

Reference

ReferencePoint Class


ReferencePoint.GetCoordinatePlaneReferenceYZ Method

ReferencePointGetCoordinatePlaneReferenceYZ Method

A reference for the YZ plane of the coordinate system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Reference GetCoordinatePlaneReferenceYZ()
Public Function GetCoordinatePlaneReferenceYZ As Reference
public:
Reference^ GetCoordinatePlaneReferenceYZ()
member GetCoordinatePlaneReferenceYZ : unit -> Reference

Return Value

Reference
See Also

Reference

ReferencePoint Class


ReferencePoint.GetCoordinateSystem Method

ReferencePointGetCoordinateSystem Method

The position and orientation of the ReferencePoint.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Transform GetCoordinateSystem()
Public Function GetCoordinateSystem As Transform
public:
Transform^ GetCoordinateSystem()
member GetCoordinateSystem : unit -> Transform

Return Value

Transform
Remarks
The position of the point is given by CoordinateSystem.Origin, and the orientation is specified by the three unit vectors CoordinateSystem.BasisX, BasisY, BasisZ.
See Also

Reference

ReferencePoint Class


ReferencePoint.GetHubId Method

ReferencePointGetHubId Method

Id of associated Hub.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GetHubId()
Public Function GetHubId As ElementId
public:
ElementId^ GetHubId()
member GetHubId : unit -> ElementId

Return Value

ElementId
See Also

Reference

ReferencePoint Class


ReferencePoint.GetInterpolatingCurves Method

ReferencePointGetInterpolatingCurves Method

The set of CurveByPoints elements that interpolate a ReferencePoint.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurveByPointsArray GetInterpolatingCurves()
Public Function GetInterpolatingCurves As CurveByPointsArray
public:
CurveByPointsArray^ GetInterpolatingCurves()
member GetInterpolatingCurves : unit -> CurveByPointsArray

Return Value

CurveByPointsArray
Remarks
A CurveByPoints is in the GetInterpolatingCurves array if and only if the ReferencePoint is in the Points array of CurveByPoints.
See Also

Reference

ReferencePoint Class


ReferencePoint.GetPointElementReference Method

ReferencePointGetPointElementReference Method

Retrieve a copy of the rule that computes the location of the ReferencePoint relative to other elements in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PointElementReference GetPointElementReference()
Public Function GetPointElementReference As PointElementReference
public:
PointElementReference^ GetPointElementReference()
member GetPointElementReference : unit -> PointElementReference

Return Value

PointElementReference
A PointElementReference object, or if the ReferencePoint does not have a reference.
See Also

Reference

ReferencePoint Class


ReferencePoint.GetVisibility Method

ReferencePointGetVisibility Method

Gets the visibility for the point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyElementVisibility GetVisibility()
Public Function GetVisibility As FamilyElementVisibility
public:
FamilyElementVisibility^ GetVisibility()
member GetVisibility : unit -> FamilyElementVisibility

Return Value

FamilyElementVisibility
A copy of visibility settings for the ReferencePoint.
See Also

Reference

ReferencePoint Class


ReferencePoint.SetCoordinateSystem Method

ReferencePointSetCoordinateSystem Method

The position and orientation of the ReferencePoint.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetCoordinateSystem(
    Transform coordinateSystem
)
Public Sub SetCoordinateSystem (
    coordinateSystem As Transform
)
public:
void SetCoordinateSystem(
    Transform^ coordinateSystem
)
member SetCoordinateSystem :
        coordinateSystem : Transform -> unit

Parameters

coordinateSystem Transform
Exceptions
Exception | Condition
ArgumentException | Thrown when coordinateSystem does not specify an orthonormal basis.
InvalidOperationException | Thrown when CoordinateSystem is set while the Reference property is not , and the ReferencePoint is unable to move to the new location.
Remarks
The position of the point is given by CoordinateSystem.Origin, and the orientation is specified by the three unit vectors CoordinateSystem.BasisX, BasisY, BasisZ. The basis vectors must be unit length and mutually perpendicular. Whenever the Reference property is not , changing the CoordinateSystem property has a compound effect. First the point is moved to the specified location. Then the point is moved to conform to its Reference, by the shortest possible distance.
See Also

Reference

ReferencePoint Class


ReferencePoint.SetPointElementReference Method

ReferencePointSetPointElementReference Method

Change the rule for computing the location of the ReferencePoint relative to other elements in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetPointElementReference(
    PointElementReference pointElementReference
)
Public Sub SetPointElementReference (
    pointElementReference As PointElementReference
)
public:
void SetPointElementReference(
    PointElementReference^ pointElementReference
)
member SetPointElementReference :
        pointElementReference : PointElementReference -> unit

Parameters

pointElementReference PointElementReference
An object specifying a rule for the location and orientation of a ReferencePoint. (Note: The ReferencePoint object does not store the pointElementReference object after this call.)
Exceptions
Exception | Condition
InvalidOperationException | Thrown when Reference is set to a non-null object, and the ReferencePoint is unable to move to the new reference.
Remarks
pointElementReference may be , in which case the ReferencePoint does not follow any other element. When Reference is changed from to a non-null value, the point moves and rotates to the prescribed location and orientation. Where the coordinate system has some freedom, it will remain as close to the old orientation as possible. When the reference is set to , the point does not move or rotate.
See Also

Reference

ReferencePoint Class


ReferencePoint.SetVisibility Method

ReferencePointSetVisibility Method

Sets the visibility for the point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetVisibility(
    FamilyElementVisibility visibility
)
Public Sub SetVisibility (
    visibility As FamilyElementVisibility
)
public:
void SetVisibility(
    FamilyElementVisibility^ visibility
)
member SetVisibility :
        visibility : FamilyElementVisibility -> unit

Parameters

visibility FamilyElementVisibility
Exceptions
Exception | Condition
ArgumentNullException | Thrown when visibility is .
InvalidOperationException | Thrown when regeneration failed.
Remarks
The visibility of the point can be changed for different types of views and detail levels in the project.
See Also

Reference

ReferencePoint Class


ReferencePointArray Class

An array that contains reference objects.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBReferencePointArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ReferencePointArray : APIObject,
    IEnumerable
Public Class ReferencePointArray
    Inherits APIObject
    Implements IEnumerable
public ref class ReferencePointArray : public APIObject,
    IEnumerable
type ReferencePointArray =
    class
        inherit APIObject
        interface IEnumerable
    end

The ReferencePointArray type exposes the following members.

Constructors
 | Name | Description
Public method | ReferencePointArray | Initializes a new instance of the ReferencePointArray class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets a reference at a specified index within the array.
Public property | Size | Returns the number of references that are in the array.
Top
Methods
 | Name | Description
Public method | Append |
Public method | Clear | Removes every reference from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ReferencePointArray Constructor

Initializes a new instance of the ReferencePointArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReferencePointArray()
Public Sub New
public:
ReferencePointArray()
new : unit -> ReferencePointArray
See Also

Reference

ReferencePointArray Class


ReferencePointArray Properties

The ReferencePointArray type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets a reference at a specified index within the array.
Public property | Size | Returns the number of references that are in the array.
Top
See Also

Reference

ReferencePointArray Class


ReferencePointArray.IsEmpty Property

ReferencePointArrayIsEmpty Property

Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Boolean
Remarks
If the array is empty then True will be returned, otherwise False.
See Also

Reference

ReferencePointArray Class


ReferencePointArray.Item Property

ReferencePointArrayItem Property

Gets or sets a reference at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ReferencePoint this[
    int index
] { get; set; }
Public Overridable Property Item (
    index As Integer
) As ReferencePoint
    Get
    Set
public:
virtual property ReferencePoint^ Item[int index] {
    ReferencePoint^ get (int index);
    void set (int index, ReferencePoint^ value);
}
abstract Item : ReferencePoint with get, set
override Item : ReferencePoint with get, set

Parameters

index Int32
The index of the reference to be set or retrieved.

Return Value

ReferencePoint
Returns the reference at the specified index.
See Also

Reference

ReferencePointArray Class


ReferencePointArray.Size Property

ReferencePointArraySize Property

Returns the number of references that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
abstract Size : int with get
override Size : int with get

Property Value

Int32
See Also

Reference

ReferencePointArray Class


ReferencePointArray Methods

The ReferencePointArray type exposes the following members.

Methods
 | Name | Description
Public method | Append |
Public method | Clear | Removes every reference from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ReferencePointArray Class


ReferencePointArray.Append Method

ReferencePointArrayAppend Method

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Append(
    ReferencePoint item
)
Public Overridable Sub Append (
    item As ReferencePoint
)
public:
virtual void Append(
    ReferencePoint^ item
)
abstract Append :
        item : ReferencePoint -> unit
override Append :
        item : ReferencePoint -> unit

Parameters

item ReferencePoint
See Also

Reference

ReferencePointArray Class


ReferencePointArray.Clear Method

ReferencePointArrayClear Method

Removes every reference from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

ReferencePointArray Class


ReferencePointArray.ForwardIterator Method

ReferencePointArrayForwardIterator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ReferencePointArrayIterator ForwardIterator()
Public Overridable Function ForwardIterator As ReferencePointArrayIterator
public:
virtual ReferencePointArrayIterator^ ForwardIterator()
abstract ForwardIterator : unit -> ReferencePointArrayIterator
override ForwardIterator : unit -> ReferencePointArrayIterator

Return Value

ReferencePointArrayIterator
Returns a forward moving iterator to the array.
See Also

Reference

ReferencePointArray Class


ReferencePointArray.GetEnumerator Method

ReferencePointArrayGetEnumerator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

IEnumerator
Returns a forward moving iterator to the array.

Implements

IEnumerableGetEnumerator
See Also

Reference

ReferencePointArray Class


ReferencePointArray.Insert Method

ReferencePointArrayInsert Method

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Insert(
    ReferencePoint item,
    int index
)
Public Overridable Sub Insert (
    item As ReferencePoint,
    index As Integer
)
public:
virtual void Insert(
    ReferencePoint^ item,
    int index
)
abstract Insert :
        item : ReferencePoint *
        index : int -> unit
override Insert :
        item : ReferencePoint *
        index : int -> unit

Parameters

item ReferencePoint
index Int32
See Also

Reference

ReferencePointArray Class


ReferencePointArray.ReverseIterator Method

ReferencePointArrayReverseIterator Method

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ReferencePointArrayIterator ReverseIterator()
Public Overridable Function ReverseIterator As ReferencePointArrayIterator
public:
virtual ReferencePointArrayIterator^ ReverseIterator()
abstract ReverseIterator : unit -> ReferencePointArrayIterator
override ReverseIterator : unit -> ReferencePointArrayIterator

Return Value

ReferencePointArrayIterator
Returns a backward moving iterator to the array.
See Also

Reference

ReferencePointArray Class


ReferencePointArrayIterator Class

An iterator to a reference array.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBReferencePointArrayIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class ReferencePointArrayIterator : APIObject,
    IEnumerator
Public MustInherit Class ReferencePointArrayIterator
    Inherits APIObject
    Implements IEnumerator
public ref class ReferencePointArrayIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type ReferencePointArrayIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The ReferencePointArrayIterator type exposes the following members.

Constructors
 | Name | Description
Public method | ReferencePointArrayIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ReferencePointArrayIterator Constructor

For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReferencePointArrayIterator()
Public Sub New
public:
ReferencePointArrayIterator()
new : unit -> ReferencePointArrayIterator
Remarks
This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.
See Also

Reference

ReferencePointArrayIterator Class


ReferencePointArrayIterator Properties

The ReferencePointArrayIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

ReferencePointArrayIterator Class


ReferencePointArrayIterator.Current Property

ReferencePointArrayIteratorCurrent Property

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}
abstract Current : Object with get
override Current : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.
See Also

Reference

ReferencePointArrayIterator Class


ReferencePointArrayIterator Methods

The ReferencePointArrayIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ReferencePointArrayIterator Class


ReferencePointArrayIterator.MoveNext Method

ReferencePointArrayIteratorMoveNext Method

Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumeratorMoveNext
Remarks
MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.
See Also

Reference

ReferencePointArrayIterator Class


ReferencePointArrayIterator.Reset Method

ReferencePointArrayIteratorReset Method

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
Remarks
The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.
See Also

Reference

ReferencePointArrayIterator Class


ReferenceType Enumeration

Reference types of curve element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ReferenceType
Public Enumeration ReferenceType
public enum class ReferenceType
type ReferenceType
Members
Member name | Value | Description
None | 0 |
WeakReference | 1 |
StrongReference | 2 |
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ReferenceWithContext Class

An object including a reference to a geometric object and related context, as instance transform etc.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBReferenceWithContext

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ReferenceWithContext : IDisposable
Public Class ReferenceWithContext
    Implements IDisposable
public ref class ReferenceWithContext : IDisposable
type ReferenceWithContext =
    class
        interface IDisposable
    end

The ReferenceWithContext type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Proximity | The proximity value to the ray's origin when the reference is returned by FindReferencesWithContextByDirection(XYZ, XYZ, View3D) or ReferenceIntersector.Find(XYZ, XYZ).
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ReferenceWithContext
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetInstanceTransform | Gets the transform of the instance.
Public method | GetReference | Gets the reference of the geometric object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The ReferenceWithContext is used as the returned value from the method [!:Autodesk::Revit::DB::Document::FindReferencesWithContextByDirection], ReferenceIntersector.Find(XYZ, XYZ), or ReferenceIntersector.FindNearest(XYZ, XYZ). It includes a reference intersecting a line extended in a certain direction from an origin point and the context of the geometric object, as the transform and proximity.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ReferenceWithContext Properties

The ReferenceWithContext type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Proximity | The proximity value to the ray's origin when the reference is returned by FindReferencesWithContextByDirection(XYZ, XYZ, View3D) or ReferenceIntersector.Find(XYZ, XYZ).
Top
See Also

Reference

ReferenceWithContext Class


ReferenceWithContext.IsValidObject Property

ReferenceWithContextIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ReferenceWithContext Class


ReferenceWithContext.Proximity Property

ReferenceWithContextProximity Property

The proximity value to the ray's origin when the reference is returned by FindReferencesWithContextByDirection(XYZ, XYZ, View3D) or ReferenceIntersector.Find(XYZ, XYZ).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Proximity { get; }
Public ReadOnly Property Proximity As Double
    Get
public:
property double Proximity {
    double get ();
}
member Proximity : float with get

Property Value

Double
See Also

Reference

ReferenceWithContext Class


ReferenceWithContext Methods

The ReferenceWithContext type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetInstanceTransform | Gets the transform of the instance.
Public method | GetReference | Gets the reference of the geometric object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ReferenceWithContext Class


ReferenceWithContext.Dispose Method

ReferenceWithContextDispose Method

Releases all resources used by the ReferenceWithContext

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ReferenceWithContext Class


ReferenceWithContext.GetInstanceTransform Method

ReferenceWithContextGetInstanceTransform Method

Gets the transform of the instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Transform GetInstanceTransform()
Public Function GetInstanceTransform As Transform
public:
Transform^ GetInstanceTransform()
member GetInstanceTransform : unit -> Transform

Return Value

Transform
The transform of an instance when the reference is returned by FindReferencesWithContextByDirection(XYZ, XYZ, View3D) or ReferenceIntersector.Find(XYZ, XYZ).
See Also

Reference

ReferenceWithContext Class


ReferenceWithContext.GetReference Method

ReferenceWithContextGetReference Method

Gets the reference of the geometric object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Reference GetReference()
Public Function GetReference As Reference
public:
Reference^ GetReference()
member GetReference : unit -> Reference

Return Value

Reference
The reference of a geometric object when it is returned by FindReferencesWithContextByDirection(XYZ, XYZ, View3D) or ReferenceIntersector.Find(XYZ, XYZ).
See Also

Reference

ReferenceWithContext Class


RelinquishedItems Class

List of elements and worksets that were relinquished by the current user.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRelinquishedItems

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RelinquishedItems : IDisposable
Public Class RelinquishedItems
    Implements IDisposable
public ref class RelinquishedItems : IDisposable
type RelinquishedItems =
    class
        interface IDisposable
    end

The RelinquishedItems type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the RelinquishedItems
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRelinquishedElements | The elements that were relinquished by the current user.
Public method | GetRelinquishedWorksets | The elements that were relinquished by the current user.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RelinquishedItems Properties

The RelinquishedItems type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

RelinquishedItems Class


RelinquishedItems.IsValidObject Property

RelinquishedItemsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

RelinquishedItems Class


RelinquishedItems Methods

The RelinquishedItems type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRelinquishedElements | The elements that were relinquished by the current user.
Public method | GetRelinquishedWorksets | The elements that were relinquished by the current user.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

RelinquishedItems Class


RelinquishedItems.Dispose Method

RelinquishedItemsDispose Method

Releases all resources used by the RelinquishedItems

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

RelinquishedItems Class


RelinquishedItems.GetRelinquishedElements Method

RelinquishedItemsGetRelinquishedElements Method

The elements that were relinquished by the current user.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetRelinquishedElements()
Public Function GetRelinquishedElements As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetRelinquishedElements()
member GetRelinquishedElements : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
See Also

Reference

RelinquishedItems Class


RelinquishedItems.GetRelinquishedWorksets Method

RelinquishedItemsGetRelinquishedWorksets Method

The elements that were relinquished by the current user.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<WorksetId> GetRelinquishedWorksets()
Public Function GetRelinquishedWorksets As ICollection(Of WorksetId)
public:
ICollection<WorksetId^>^ GetRelinquishedWorksets()
member GetRelinquishedWorksets : unit -> ICollection<WorksetId>

Return Value

ICollection WorksetId
See Also

Reference

RelinquishedItems Class


RelinquishOptions Class

Options to control behavior of relinquishing ownership of elements and worksets.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRelinquishOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RelinquishOptions : IDisposable
Public Class RelinquishOptions
    Implements IDisposable
public ref class RelinquishOptions : IDisposable
type RelinquishOptions =
    class
        interface IDisposable
    end

The RelinquishOptions type exposes the following members.

Constructors
 | Name | Description
Public method | RelinquishOptions | Constructs a new instance of RelinquishOptions.
Top
Properties
 | Name | Description
Public property | CheckedOutElements | True means all elements checked out by the current user should be relinquished. False means none of these are relinquished.
Public property | FamilyWorksets | True means all family worksets owned by the current user should be relinquished. False means none of these are relinquished.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | StandardWorksets | True means all project standards worksets owned by the current user should be relinquished. False means none of these are relinquished.
Public property | UserWorksets | True means all user-created worksets owned by the current user should be relinquished. False means none of these are relinquished.
Public property | ViewWorksets | True means all view worksets owned by the current user should be relinquished. False means none of these are relinquished.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the RelinquishOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

The settings correspond to the checkboxes in the Synchronize with Central dialog in the section "After synchronizing, relinquish the following worksets and elements:".

An element can be owned (reflected in the "Edited By" parameter) either by being checked out ("borrowed") or by belonging to a checked out workset.

Relinquishing a workset will relinquish all its unmodified elements that the current user owns.

The subtle interactions between checking out elements and checking out worksets are beyond the scope of the documentation for this class. But as an example, if a wall is borrowed (explicitly checked out) and then its workset is checked out, then the wall is no longer considered borrowed because the workset ownership implicitly grants ownership of all elements in the workset (except elements borrowed by other users).

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RelinquishOptions Constructor

Constructs a new instance of RelinquishOptions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RelinquishOptions(
    bool relinquishEverything
)
Public Sub New (
    relinquishEverything As Boolean
)
public:
RelinquishOptions(
    bool relinquishEverything
)
new :
        relinquishEverything : bool -> RelinquishOptions

Parameters

relinquishEverything Boolean
The value to apply to all of the members.
See Also

Reference

RelinquishOptions Class


RelinquishOptions Properties

The RelinquishOptions type exposes the following members.

Properties
 | Name | Description
Public property | CheckedOutElements | True means all elements checked out by the current user should be relinquished. False means none of these are relinquished.
Public property | FamilyWorksets | True means all family worksets owned by the current user should be relinquished. False means none of these are relinquished.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | StandardWorksets | True means all project standards worksets owned by the current user should be relinquished. False means none of these are relinquished.
Public property | UserWorksets | True means all user-created worksets owned by the current user should be relinquished. False means none of these are relinquished.
Public property | ViewWorksets | True means all view worksets owned by the current user should be relinquished. False means none of these are relinquished.
Top
See Also

Reference

RelinquishOptions Class


RelinquishOptions.CheckedOutElements Property

RelinquishOptionsCheckedOutElements Property

True means all elements checked out by the current user should be relinquished. False means none of these are relinquished.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CheckedOutElements { get; set; }
Public Property CheckedOutElements As Boolean
    Get
    Set
public:
property bool CheckedOutElements {
    bool get ();
    void set (bool value);
}
member CheckedOutElements : bool with get, set

Property Value

Boolean
See Also

Reference

RelinquishOptions Class


RelinquishOptions.FamilyWorksets Property

RelinquishOptionsFamilyWorksets Property

True means all family worksets owned by the current user should be relinquished. False means none of these are relinquished.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool FamilyWorksets { get; set; }
Public Property FamilyWorksets As Boolean
    Get
    Set
public:
property bool FamilyWorksets {
    bool get ();
    void set (bool value);
}
member FamilyWorksets : bool with get, set

Property Value

Boolean
See Also

Reference

RelinquishOptions Class


RelinquishOptions.IsValidObject Property

RelinquishOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

RelinquishOptions Class


RelinquishOptions.StandardWorksets Property

RelinquishOptionsStandardWorksets Property

True means all project standards worksets owned by the current user should be relinquished. False means none of these are relinquished.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool StandardWorksets { get; set; }
Public Property StandardWorksets As Boolean
    Get
    Set
public:
property bool StandardWorksets {
    bool get ();
    void set (bool value);
}
member StandardWorksets : bool with get, set

Property Value

Boolean
See Also

Reference

RelinquishOptions Class


RelinquishOptions.UserWorksets Property

RelinquishOptionsUserWorksets Property

True means all user-created worksets owned by the current user should be relinquished. False means none of these are relinquished.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UserWorksets { get; set; }
Public Property UserWorksets As Boolean
    Get
    Set
public:
property bool UserWorksets {
    bool get ();
    void set (bool value);
}
member UserWorksets : bool with get, set

Property Value

Boolean
Remarks
This defaults to false in the User Interface.
See Also

Reference

RelinquishOptions Class


RelinquishOptions.ViewWorksets Property

RelinquishOptionsViewWorksets Property

True means all view worksets owned by the current user should be relinquished. False means none of these are relinquished.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ViewWorksets { get; set; }
Public Property ViewWorksets As Boolean
    Get
    Set
public:
property bool ViewWorksets {
    bool get ();
    void set (bool value);
}
member ViewWorksets : bool with get, set

Property Value

Boolean
See Also

Reference

RelinquishOptions Class


RelinquishOptions Methods

The RelinquishOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

RelinquishOptions Class


RelinquishOptions.Dispose Method

RelinquishOptionsDispose Method

Releases all resources used by the RelinquishOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

RelinquishOptions Class


ReloadLatestOptions Class

Options to control behavior of pure reload latest (not part of synchronize with central).
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBReloadLatestOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ReloadLatestOptions : IDisposable
Public Class ReloadLatestOptions
    Implements IDisposable
public ref class ReloadLatestOptions : IDisposable
type ReloadLatestOptions =
    class
        interface IDisposable
    end

The ReloadLatestOptions type exposes the following members.

Constructors
 | Name | Description
Public method | ReloadLatestOptions | Constructs a new ReloadLatestOptions object.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ReloadLatestOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ReloadLatestOptions Constructor

Constructs a new ReloadLatestOptions object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReloadLatestOptions()
Public Sub New
public:
ReloadLatestOptions()
new : unit -> ReloadLatestOptions
See Also

Reference

ReloadLatestOptions Class


ReloadLatestOptions Properties

The ReloadLatestOptions type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

ReloadLatestOptions Class


ReloadLatestOptions.IsValidObject Property

ReloadLatestOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ReloadLatestOptions Class


ReloadLatestOptions Methods

The ReloadLatestOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ReloadLatestOptions Class


ReloadLatestOptions.Dispose Method

ReloadLatestOptionsDispose Method

Releases all resources used by the ReloadLatestOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ReloadLatestOptions Class


ReloadSwapOutInfo Class

This object contains information about fabrication parts swapped out during reload.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBReloadSwapOutInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ReloadSwapOutInfo : IDisposable
Public Class ReloadSwapOutInfo
    Implements IDisposable
public ref class ReloadSwapOutInfo : IDisposable
type ReloadSwapOutInfo =
    class
        interface IDisposable
    end

The ReloadSwapOutInfo type exposes the following members.

Properties
 | Name | Description
Public property | CurrentVersion | New version.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Part | The ElementId of part being swapped.
Public property | PreviousVersion | Previous version.
Public property | WasSwapped | Whether the swap out was successful.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ReloadSwapOutInfo
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ReloadSwapOutInfo Properties

The ReloadSwapOutInfo type exposes the following members.

Properties
 | Name | Description
Public property | CurrentVersion | New version.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Part | The ElementId of part being swapped.
Public property | PreviousVersion | Previous version.
Public property | WasSwapped | Whether the swap out was successful.
Top
See Also

Reference

ReloadSwapOutInfo Class


ReloadSwapOutInfo.CurrentVersion Property

ReloadSwapOutInfoCurrentVersion Property

New version.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int CurrentVersion { get; }
Public ReadOnly Property CurrentVersion As Integer
    Get
public:
property int CurrentVersion {
    int get ();
}
member CurrentVersion : int with get

Property Value

Int32
See Also

Reference

ReloadSwapOutInfo Class


ReloadSwapOutInfo.IsValidObject Property

ReloadSwapOutInfoIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ReloadSwapOutInfo Class


ReloadSwapOutInfo.Part Property

ReloadSwapOutInfoPart Property

The ElementId of part being swapped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId Part { get; }
Public ReadOnly Property Part As ElementId
    Get
public:
property ElementId^ Part {
    ElementId^ get ();
}
member Part : ElementId with get

Property Value

ElementId
See Also

Reference

ReloadSwapOutInfo Class


ReloadSwapOutInfo.PreviousVersion Property

ReloadSwapOutInfoPreviousVersion Property

Previous version.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int PreviousVersion { get; }
Public ReadOnly Property PreviousVersion As Integer
    Get
public:
property int PreviousVersion {
    int get ();
}
member PreviousVersion : int with get

Property Value

Int32
See Also

Reference

ReloadSwapOutInfo Class


ReloadSwapOutInfo.WasSwapped Property

ReloadSwapOutInfoWasSwapped Property

Whether the swap out was successful.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool WasSwapped { get; }
Public ReadOnly Property WasSwapped As Boolean
    Get
public:
property bool WasSwapped {
    bool get ();
}
member WasSwapped : bool with get

Property Value

Boolean
See Also

Reference

ReloadSwapOutInfo Class


ReloadSwapOutInfo Methods

The ReloadSwapOutInfo type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ReloadSwapOutInfo Class


ReloadSwapOutInfo.Dispose Method

ReloadSwapOutInfoDispose Method

Releases all resources used by the ReloadSwapOutInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ReloadSwapOutInfo Class


RenderDuration Enumeration

An enumerated type containing possible duration types to do Raytracer render.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum RenderDuration
Public Enumeration RenderDuration
public enum class RenderDuration
type RenderDuration
Members
Member name | Value | Description
ByLevel | 0 | Render by the defined iterations.
ByTime | 1 | Render by the defined time.
UntilSatisfactory | 2 | Render until satisfactory.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RenderingImageExposureSettings Class

Represents the exposure settings of rendering.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRenderingImageExposureSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RenderingImageExposureSettings : IDisposable
Public Class RenderingImageExposureSettings
    Implements IDisposable
public ref class RenderingImageExposureSettings : IDisposable
type RenderingImageExposureSettings =
    class
        interface IDisposable
    end

The RenderingImageExposureSettings type exposes the following members.

Properties
 | Name | Description
Public property | ExposureValue | The value of rendering image exposure.
Public property | Highlights | The highlights value.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Saturation | The value of rendering image saturation.
Public property | Shadows | The shadows value.
Public property | WhitePoint | The white point value.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the RenderingImageExposureSettings
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RenderingImageExposureSettings Properties

The RenderingImageExposureSettings type exposes the following members.

Properties
 | Name | Description
Public property | ExposureValue | The value of rendering image exposure.
Public property | Highlights | The highlights value.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Saturation | The value of rendering image saturation.
Public property | Shadows | The shadows value.
Public property | WhitePoint | The white point value.
Top
See Also

Reference

RenderingImageExposureSettings Class


RenderingImageExposureSettings.ExposureValue Property

RenderingImageExposureSettingsExposureValue Property

The value of rendering image exposure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double ExposureValue { get; set; }
Public Property ExposureValue As Double
    Get
    Set
public:
property double ExposureValue {
    double get ();
    void set (double value);
}
member ExposureValue : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The value of rendering image exposure is not valid. The valid range is 0 to 21.
Remarks
Default exposure value based on Lighting Scheme.
See Also

Reference

RenderingImageExposureSettings Class


RenderingImageExposureSettings.Highlights Property

RenderingImageExposureSettingsHighlights Property

The highlights value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Highlights { get; set; }
Public Property Highlights As Double
    Get
    Set
public:
property double Highlights {
    double get ();
    void set (double value);
}
member Highlights : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The value of highlights is not valid. The valid range is 0 to 1.
Remarks
Increase this value to get brighter highlights.
See Also

Reference

RenderingImageExposureSettings Class


RenderingImageExposureSettings.IsValidObject Property

RenderingImageExposureSettingsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

RenderingImageExposureSettings Class


RenderingImageExposureSettings.Saturation Property

RenderingImageExposureSettingsSaturation Property

The value of rendering image saturation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Saturation { get; set; }
Public Property Saturation As Double
    Get
    Set
public:
property double Saturation {
    double get ();
    void set (double value);
}
member Saturation : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The value of saturation is not valid. The valid range is 0 to 5.
Remarks
Increase this value to get more intense colors.
See Also

Reference

RenderingImageExposureSettings Class


RenderingImageExposureSettings.Shadows Property

RenderingImageExposureSettingsShadows Property

The shadows value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Shadows { get; set; }
Public Property Shadows As Double
    Get
    Set
public:
property double Shadows {
    double get ();
    void set (double value);
}
member Shadows : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The value of shadows is not valid. The valid range is 0.1 to 4.
Remarks
Increase this value to get darker shadows.
See Also

Reference

RenderingImageExposureSettings Class


RenderingImageExposureSettings.WhitePoint Property

RenderingImageExposureSettingsWhitePoint Property

The white point value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double WhitePoint { get; set; }
Public Property WhitePoint As Double
    Get
    Set
public:
property double WhitePoint {
    double get ();
    void set (double value);
}
member WhitePoint : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The value of white point is not valid. The valid range is 1800 to 15000.
Remarks
Specify the white balance of the rendering(measured in Kelvin). Incandescent lighting:2800 K; Daylight 6500K.
See Also

Reference

RenderingImageExposureSettings Class


RenderingImageExposureSettings Methods

The RenderingImageExposureSettings type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

RenderingImageExposureSettings Class


RenderingImageExposureSettings.Dispose Method

RenderingImageExposureSettingsDispose Method

Releases all resources used by the RenderingImageExposureSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

RenderingImageExposureSettings Class


RenderingQuality Enumeration

Indicates the rendering quality in rendering settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum RenderingQuality
Public Enumeration RenderingQuality
public enum class RenderingQuality
type RenderingQuality
Members
Member name | Value | Description
Draft | 11 | Draft level quality.
Medium | 13 | Medium level quality.
High | 14 | High level quality.
VeryHigh | 15 | Very high level quality.
Custom | 16 | Custom level quality.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RenderingQualitySettings Class

Represents the quality settings of rendering.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRenderingQualitySettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RenderingQualitySettings : IDisposable
Public Class RenderingQualitySettings
    Implements IDisposable
public ref class RenderingQualitySettings : IDisposable
type RenderingQualitySettings =
    class
        interface IDisposable
    end

The RenderingQualitySettings type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LightAndMaterialAccuracyMode | A value that controls light and material accuracy mode.
Public property | RenderDuration | A value that controls render duration.
Public property | RenderingQuality | The quality applied for rendering.
Public property | RenderLevel | The render target level as a numerical value between 1 and 40.
Public property | RenderTime | The render target time as a numerical value between 1 and 32768.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the RenderingQualitySettings
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsCustomQuality | Checks if the current rendering quality is custom or not.
Public method | IsValidRenderLevel | Validate the render level is between 1 and 40
Public method | IsValidRenderTime | Validate the render time is between 1 and 32768.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The other properties in this class can only be modified if the RenderingQuality property is currently set to Custom.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RenderingQualitySettings Properties

The RenderingQualitySettings type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LightAndMaterialAccuracyMode | A value that controls light and material accuracy mode.
Public property | RenderDuration | A value that controls render duration.
Public property | RenderingQuality | The quality applied for rendering.
Public property | RenderLevel | The render target level as a numerical value between 1 and 40.
Public property | RenderTime | The render target time as a numerical value between 1 and 32768.
Top
See Also

Reference

RenderingQualitySettings Class


RenderingQualitySettings.IsValidObject Property

RenderingQualitySettingsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

RenderingQualitySettings Class


RenderingQualitySettings.LightAndMaterialAccuracyMode Property

RenderingQualitySettingsLightAndMaterialAccuracyMode Property

A value that controls light and material accuracy mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LightAndMaterialAccuracyMode LightAndMaterialAccuracyMode { get; set; }
Public Property LightAndMaterialAccuracyMode As LightAndMaterialAccuracyMode
    Get
    Set
public:
property LightAndMaterialAccuracyMode LightAndMaterialAccuracyMode {
    LightAndMaterialAccuracyMode get ();
    void set (LightAndMaterialAccuracyMode value);
}
member LightAndMaterialAccuracyMode : LightAndMaterialAccuracyMode with get, set

Property Value

LightAndMaterialAccuracyMode
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | When setting this property: The RenderingQualitySettings does not use custom quality currently. To use custom quality, set RenderingQuality property to RenderingQuality.Custom.
Remarks
The method of the renderer engine dealing with materials and shadows.
See Also

Reference

RenderingQualitySettings Class


RenderingQualitySettings.RenderDuration Property

RenderingQualitySettingsRenderDuration Property

A value that controls render duration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RenderDuration RenderDuration { get; set; }
Public Property RenderDuration As RenderDuration
    Get
    Set
public:
property RenderDuration RenderDuration {
    RenderDuration get ();
    void set (RenderDuration value);
}
member RenderDuration : RenderDuration with get, set

Property Value

RenderDuration
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The value is not valid for RenderDuration. -or- When setting this property: A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | When setting this property: The RenderingQualitySettings does not use custom quality currently. To use custom quality, set RenderingQuality property to RenderingQuality.Custom.
Remarks
The duration of rendering.
See Also

Reference

RenderingQualitySettings Class


RenderingQualitySettings.RenderingQuality Property

RenderingQualitySettingsRenderingQuality Property

The quality applied for rendering.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RenderingQuality RenderingQuality { get; set; }
Public Property RenderingQuality As RenderingQuality
    Get
    Set
public:
property RenderingQuality RenderingQuality {
    RenderingQuality get ();
    void set (RenderingQuality value);
}
member RenderingQuality : RenderingQuality with get, set

Property Value

RenderingQuality
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

RenderingQualitySettings Class


RenderingQualitySettings.RenderLevel Property

RenderingQualitySettingsRenderLevel Property

The render target level as a numerical value between 1 and 40.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int RenderLevel { get; set; }
Public Property RenderLevel As Integer
    Get
    Set
public:
property int RenderLevel {
    int get ();
    void set (int value);
}
member RenderLevel : int with get, set

Property Value

Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The value is not valid for RenderLevel.
InvalidOperationException | When setting this property: The RenderingQualitySettings does not use custom quality currently. To use custom quality, set RenderingQuality property to RenderingQuality.Custom.
Remarks
Increase this value to increase render level.
See Also

Reference

RenderingQualitySettings Class


RenderingQualitySettings.RenderTime Property

RenderingQualitySettingsRenderTime Property

The render target time as a numerical value between 1 and 32768.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int RenderTime { get; set; }
Public Property RenderTime As Integer
    Get
    Set
public:
property int RenderTime {
    int get ();
    void set (int value);
}
member RenderTime : int with get, set

Property Value

Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The value is not valid RenderTime.
InvalidOperationException | When setting this property: The RenderingQualitySettings does not use custom quality currently. To use custom quality, set RenderingQuality property to RenderingQuality.Custom.
Remarks
Increase this value to increase render time.
See Also

Reference

RenderingQualitySettings Class


RenderingQualitySettings Methods

The RenderingQualitySettings type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsCustomQuality | Checks if the current rendering quality is custom or not.
Public method | IsValidRenderLevel | Validate the render level is between 1 and 40
Public method | IsValidRenderTime | Validate the render time is between 1 and 32768.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

RenderingQualitySettings Class


RenderingQualitySettings.Dispose Method

RenderingQualitySettingsDispose Method

Releases all resources used by the RenderingQualitySettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

RenderingQualitySettings Class


RenderingQualitySettings.IsCustomQuality Method

RenderingQualitySettingsIsCustomQuality Method

Checks if the current rendering quality is custom or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCustomQuality()
Public Function IsCustomQuality As Boolean
public:
bool IsCustomQuality()
member IsCustomQuality : unit -> bool

Return Value

Boolean
True if the current rendering quality is custom, false otherwise.
See Also

Reference

RenderingQualitySettings Class


RenderingQualitySettings.IsValidRenderLevel Method

RenderingQualitySettingsIsValidRenderLevel Method

Validate the render level is between 1 and 40

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidRenderLevel(
    int value
)
Public Function IsValidRenderLevel (
    value As Integer
) As Boolean
public:
bool IsValidRenderLevel(
    int value
)
member IsValidRenderLevel :
        value : int -> bool

Parameters

value Int32
The render level value to validate.

Return Value

Boolean
True if the render level value is in the proper range, false otherwise.
See Also

Reference

RenderingQualitySettings Class


RenderingQualitySettings.IsValidRenderTime Method

RenderingQualitySettingsIsValidRenderTime Method

Validate the render time is between 1 and 32768.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidRenderTime(
    int value
)
Public Function IsValidRenderTime (
    value As Integer
) As Boolean
public:
bool IsValidRenderTime(
    int value
)
member IsValidRenderTime :
        value : int -> bool

Parameters

value Int32
The render time value to validate.

Return Value

Boolean
True if the value is in the proper range, false otherwise.
See Also

Reference

RenderingQualitySettings Class


RenderingSettings Class

Represents the rendering settings for a 3d view.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRenderingSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RenderingSettings : IDisposable
Public Class RenderingSettings
    Implements IDisposable
public ref class RenderingSettings : IDisposable
type RenderingSettings =
    class
        interface IDisposable
    end

The RenderingSettings type exposes the following members.

Properties
 | Name | Description
Public property | BackgroundStyle | The enum value that controls the background style for rendering.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LightingSource | The lighting scheme type.
Public property | PrinterResolution | The resolution level when using printer.
Public property | ResolutionTarget | The resolution target.
Public property | ResolutionValue | The rendering resolution in dots per inch (DPI).
Public property | UsesRegionRendering | The bool value that indicates whether to use region rendering.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the RenderingSettings
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBackgroundSettings | Returns an object that represents the rendering background settings.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRenderingImageExposureSettings | Returns an object that represents the rendering image exposure settings.
Public method | GetRenderingQualitySettings | Returns an object that represents the rendering quality settings.
Public method | GetRenderingRegionOutline | Returns the outline of the rendering region.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetBackgroundSettings | Changes the rendering background settings details for the current background style.
Public method | SetRenderingImageExposureSettings | Changes the rendering image exposure settings.
Public method | SetRenderingQualitySettings | Change rendering quality settings.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Example
C#
VB
C++
F#
Copy
public void GetRenderingSettingsData(View3D view3D)
{
    RenderingSettings renderingSettings = view3D.GetRenderingSettings();

    // get print or screen resolution data
    if (renderingSettings.ResolutionTarget == ResolutionTarget.Printer) // for print resolution
    {
        PrinterResolution printResolution = renderingSettings.PrinterResolution;
        int resolutionValue = renderingSettings.ResolutionValue;
    }
    else    // for screen resolution
    {
        int resolutionValue = renderingSettings.ResolutionValue;
    }

    // Get the outline of the rendering region.
    renderingSettings.UsesRegionRendering = true;
    Outline regionOutline = renderingSettings.GetRenderingRegionOutline();
    XYZ max = regionOutline.MaximumPoint;
    XYZ min = regionOutline.MinimumPoint;

    // get lighting information.
    renderingSettings.LightingSource = LightingSource.ExteriorSun; // set lighting scheme type
    // Please note that the sun setting has been exposed in View.SunAndShadowSettings property already.
    SunAndShadowSettings sunSettings = view3D.SunAndShadowSettings;

    // get the background setting data
    switch (renderingSettings.BackgroundStyle)
    {
        case BackgroundStyle.Color: // for color style
            ColorBackgroundSettings colorBKSettings = renderingSettings.GetBackgroundSettings() as ColorBackgroundSettings;
            Color bkColor = colorBKSettings.Color;
            break;
        case BackgroundStyle.Image: // for image style
            ImageBackgroundSettings imageBKSettings = renderingSettings.GetBackgroundSettings() as ImageBackgroundSettings;
            BackgroundImageFit imageFit = imageBKSettings.BackgroundImageFit;
            string filePath = imageBKSettings.FilePath;
            break;
        case BackgroundStyle.SkyCloudy: // for sky related styles
        case BackgroundStyle.SkyFewClouds:
        case BackgroundStyle.SkyNoClouds:
        case BackgroundStyle.SkyVeryCloudy:
        case BackgroundStyle.SkyVeryFewClouds:
            SkyBackgroundSettings skyBKSettings = renderingSettings.GetBackgroundSettings() as SkyBackgroundSettings;
            //float fHaze = skyBKSettings.Haze;
            break;
        default:
            throw new InvalidOperationException("Not expected background style");
    }

    // Get the rendering image exposure settings
    RenderingImageExposureSettings exposureSettings = renderingSettings.GetRenderingImageExposureSettings();
    double imageShadows = exposureSettings.Shadows;

    // Get the rendering quality settings
    RenderingQualitySettings qualitySettings = renderingSettings.GetRenderingQualitySettings();

    if (qualitySettings.RenderingQuality == RenderingQuality.Custom)
    {
       // The user can set the data only in custom quality
       qualitySettings.RenderDuration = RenderDuration.ByTime;
       qualitySettings.RenderTime = 10;
    }
    else
    {
       // RenderLevel property value is returned according to its rendering quality style.
       // For example, it returns 1.0 for Draft quality and returns 5.0 for Medium quality.
       // RenderDuration and RenderTime property values are always the same for non-custom quality.
       int renderLevels = qualitySettings.RenderLevel;
    }
}
Public Sub GetRenderingSettingsData(view3D As View3D)
   Dim renderingSettings As RenderingSettings = view3D.GetRenderingSettings()

   ' get print or screen resolution data
   If renderingSettings.ResolutionTarget = ResolutionTarget.Printer Then
      ' for print resolution
      Dim printResolution As PrinterResolution = renderingSettings.PrinterResolution
      Dim resolutionValue As Integer = renderingSettings.ResolutionValue
   Else
      ' for screen resolution
      Dim resolutionValue As Integer = renderingSettings.ResolutionValue
   End If

   ' Get the outline of the rendering region.
   renderingSettings.UsesRegionRendering = True
   Dim regionOutline As Outline = renderingSettings.GetRenderingRegionOutline()
   Dim max As XYZ = regionOutline.MaximumPoint
   Dim min As XYZ = regionOutline.MinimumPoint

   ' get lighting information.
   renderingSettings.LightingSource = LightingSource.ExteriorSun
   ' set lighting scheme type
   ' Please note that the sun setting has been exposed in View.SunAndShadowSettings property already.
   Dim sunSettings As SunAndShadowSettings = view3D.SunAndShadowSettings

   ' get the background setting data
   Select Case renderingSettings.BackgroundStyle
      Case BackgroundStyle.Color
         ' for color style
         Dim colorBKSettings As ColorBackgroundSettings = TryCast(renderingSettings.GetBackgroundSettings(), ColorBackgroundSettings)
         Dim bkColor As Color = colorBKSettings.Color
         Exit Select
      Case BackgroundStyle.Image
         ' for image style
         Dim imageBKSettings As ImageBackgroundSettings = TryCast(renderingSettings.GetBackgroundSettings(), ImageBackgroundSettings)
         Dim imageFit As BackgroundImageFit = imageBKSettings.BackgroundImageFit
         Dim filePath As String = imageBKSettings.FilePath
         Exit Select
         ' for sky related styles
      Case BackgroundStyle.SkyCloudy, BackgroundStyle.SkyFewClouds, BackgroundStyle.SkyNoClouds, BackgroundStyle.SkyVeryCloudy, BackgroundStyle.SkyVeryFewClouds
         Dim skyBKSettings As SkyBackgroundSettings = TryCast(renderingSettings.GetBackgroundSettings(), SkyBackgroundSettings)
              'Dim haze As Single = skyBKSettings.Haze
         Exit Select
      Case Else
         Throw New InvalidOperationException("Not expected background style")
   End Select

   ' Get the rendering image exposure settings
   Dim exposureSettings As RenderingImageExposureSettings = renderingSettings.GetRenderingImageExposureSettings()
      Dim imageShadows As Double = exposureSettings.[Shadows]

  ' Get the rendering quality settings
  Dim qualitySettings As RenderingQualitySettings = renderingSettings.GetRenderingQualitySettings()

  If qualitySettings.RenderingQuality = RenderingQuality.[Custom] Then
      ' The user can set the data only in custom quality
      qualitySettings.RenderDuration = RenderDuration.ByTime
      qualitySettings.RenderTime = 10
  Else
      ' RenderLevel property value is returned according to its rendering quality style.
      ' For example, it returns 1.0 for Draft quality and returns 5.0 for Medium quality.
      ' RenderDuration and RenderTime property values are always the same for non-custom quality.
      Dim renderLevels As Integer = qualitySettings.RenderLevel
  End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RenderingSettings Properties

The RenderingSettings type exposes the following members.

Properties
 | Name | Description
Public property | BackgroundStyle | The enum value that controls the background style for rendering.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LightingSource | The lighting scheme type.
Public property | PrinterResolution | The resolution level when using printer.
Public property | ResolutionTarget | The resolution target.
Public property | ResolutionValue | The rendering resolution in dots per inch (DPI).
Public property | UsesRegionRendering | The bool value that indicates whether to use region rendering.
Top
See Also

Reference

RenderingSettings Class


RenderingSettings.BackgroundStyle Property

RenderingSettingsBackgroundStyle Property

The enum value that controls the background style for rendering.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BackgroundStyle BackgroundStyle { get; set; }
Public Property BackgroundStyle As BackgroundStyle
    Get
    Set
public:
property BackgroundStyle BackgroundStyle {
    BackgroundStyle get ();
    void set (BackgroundStyle value);
}
member BackgroundStyle : BackgroundStyle with get, set

Property Value

BackgroundStyle
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

RenderingSettings Class


RenderingSettings.IsValidObject Property

RenderingSettingsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

RenderingSettings Class


RenderingSettings.LightingSource Property

RenderingSettingsLightingSource Property

The lighting scheme type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LightingSource LightingSource { get; set; }
Public Property LightingSource As LightingSource
    Get
    Set
public:
property LightingSource LightingSource {
    LightingSource get ();
    void set (LightingSource value);
}
member LightingSource : LightingSource with get, set

Property Value

LightingSource
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

RenderingSettings Class


RenderingSettings.PrinterResolution Property

RenderingSettingsPrinterResolution Property

The resolution level when using printer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PrinterResolution PrinterResolution { get; set; }
Public Property PrinterResolution As PrinterResolution
    Get
    Set
public:
property PrinterResolution PrinterResolution {
    PrinterResolution get ();
    void set (PrinterResolution value);
}
member PrinterResolution : PrinterResolution with get, set

Property Value

PrinterResolution
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | The resolution target is not printer.
Remarks
The suitable resolution value is decided by default. You may obtain it from the ResolutionValue property.
See Also

Reference

RenderingSettings Class


RenderingSettings.ResolutionTarget Property

RenderingSettingsResolutionTarget Property

The resolution target.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ResolutionTarget ResolutionTarget { get; set; }
Public Property ResolutionTarget As ResolutionTarget
    Get
    Set
public:
property ResolutionTarget ResolutionTarget {
    ResolutionTarget get ();
    void set (ResolutionTarget value);
}
member ResolutionTarget : ResolutionTarget with get, set

Property Value

ResolutionTarget
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

RenderingSettings Class


RenderingSettings.ResolutionValue Property

RenderingSettingsResolutionValue Property

The rendering resolution in dots per inch (DPI).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ResolutionValue { get; }
Public ReadOnly Property ResolutionValue As Integer
    Get
public:
property int ResolutionValue {
    int get ();
}
member ResolutionValue : int with get

Property Value

Int32
See Also

Reference

RenderingSettings Class


RenderingSettings.UsesRegionRendering Property

RenderingSettingsUsesRegionRendering Property

The bool value that indicates whether to use region rendering.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UsesRegionRendering { get; set; }
Public Property UsesRegionRendering As Boolean
    Get
    Set
public:
property bool UsesRegionRendering {
    bool get ();
    void set (bool value);
}
member UsesRegionRendering : bool with get, set

Property Value

Boolean
See Also

Reference

RenderingSettings Class


RenderingSettings Methods

The RenderingSettings type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBackgroundSettings | Returns an object that represents the rendering background settings.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRenderingImageExposureSettings | Returns an object that represents the rendering image exposure settings.
Public method | GetRenderingQualitySettings | Returns an object that represents the rendering quality settings.
Public method | GetRenderingRegionOutline | Returns the outline of the rendering region.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetBackgroundSettings | Changes the rendering background settings details for the current background style.
Public method | SetRenderingImageExposureSettings | Changes the rendering image exposure settings.
Public method | SetRenderingQualitySettings | Change rendering quality settings.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

RenderingSettings Class


RenderingSettings.Dispose Method

RenderingSettingsDispose Method

Releases all resources used by the RenderingSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

RenderingSettings Class


RenderingSettings.GetBackgroundSettings Method

RenderingSettingsGetBackgroundSettings Method

Returns an object that represents the rendering background settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BackgroundSettings GetBackgroundSettings()
Public Function GetBackgroundSettings As BackgroundSettings
public:
BackgroundSettings^ GetBackgroundSettings()
member GetBackgroundSettings : unit -> BackgroundSettings

Return Value

BackgroundSettings
The rendering background settings.
Remarks
Different kind of settings object will be returned according to different background style. It could be SkyBackgroundSettings, ColorBackgroundSettings, or ImageBackgroundSettings.
See Also

Reference

RenderingSettings Class


RenderingSettings.GetRenderingImageExposureSettings Method

RenderingSettingsGetRenderingImageExposureSettings Method

Returns an object that represents the rendering image exposure settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RenderingImageExposureSettings GetRenderingImageExposureSettings()
Public Function GetRenderingImageExposureSettings As RenderingImageExposureSettings
public:
RenderingImageExposureSettings^ GetRenderingImageExposureSettings()
member GetRenderingImageExposureSettings : unit -> RenderingImageExposureSettings

Return Value

RenderingImageExposureSettings
The rendering image exposure settings.
See Also

Reference

RenderingSettings Class


RenderingSettings.GetRenderingQualitySettings Method

RenderingSettingsGetRenderingQualitySettings Method

Returns an object that represents the rendering quality settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RenderingQualitySettings GetRenderingQualitySettings()
Public Function GetRenderingQualitySettings As RenderingQualitySettings
public:
RenderingQualitySettings^ GetRenderingQualitySettings()
member GetRenderingQualitySettings : unit -> RenderingQualitySettings

Return Value

RenderingQualitySettings
The rendering quality settings.
See Also

Reference

RenderingSettings Class


RenderingSettings.GetRenderingRegionOutline Method

RenderingSettingsGetRenderingRegionOutline Method

Returns the outline of the rendering region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Outline GetRenderingRegionOutline()
Public Function GetRenderingRegionOutline As Outline
public:
Outline^ GetRenderingRegionOutline()
member GetRenderingRegionOutline : unit -> Outline

Return Value

Outline
The outline of the rendering region.
Exceptions
Exception | Condition
InvalidOperationException | The RenderingSettings are not currently using region rendering.
See Also

Reference

RenderingSettings Class


RenderingSettings.SetBackgroundSettings Method

RenderingSettingsSetBackgroundSettings Method

Changes the rendering background settings details for the current background style.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetBackgroundSettings(
    BackgroundSettings background
)
Public Sub SetBackgroundSettings (
    background As BackgroundSettings
)
public:
void SetBackgroundSettings(
    BackgroundSettings^ background
)
member SetBackgroundSettings :
        background : BackgroundSettings -> unit

Parameters

background BackgroundSettings
An instance of the new rendering background settings.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

RenderingSettings Class


RenderingSettings.SetRenderingImageExposureSettings Method

RenderingSettingsSetRenderingImageExposureSettings Method

Changes the rendering image exposure settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetRenderingImageExposureSettings(
    RenderingImageExposureSettings exposure
)
Public Sub SetRenderingImageExposureSettings (
    exposure As RenderingImageExposureSettings
)
public:
void SetRenderingImageExposureSettings(
    RenderingImageExposureSettings^ exposure
)
member SetRenderingImageExposureSettings :
        exposure : RenderingImageExposureSettings -> unit

Parameters

exposure RenderingImageExposureSettings
An instance of the new rendering image exposure settings.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

RenderingSettings Class


RenderingSettings.SetRenderingQualitySettings Method

RenderingSettingsSetRenderingQualitySettings Method

Change rendering quality settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetRenderingQualitySettings(
    RenderingQualitySettings settings
)
Public Sub SetRenderingQualitySettings (
    settings As RenderingQualitySettings
)
public:
void SetRenderingQualitySettings(
    RenderingQualitySettings^ settings
)
member SetRenderingQualitySettings :
        settings : RenderingQualitySettings -> unit

Parameters

settings RenderingQualitySettings
An instance of the new rendering quality settings.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

RenderingSettings Class


RenderNode Class

This is the base class of all render nodes in a model-exporting process.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRenderNode
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RenderNode : IDisposable
Public Class RenderNode
    Implements IDisposable
public ref class RenderNode : IDisposable
type RenderNode =
    class
        interface IDisposable
    end

The RenderNode type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NodeName | A readable name of the output node.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the RenderNode
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
A node can be both geometric (such as an element, light, etc.) or non-geometric (e.g. material). Some types of nodes are container modes, which include other render nodes.
See Also

Reference

Autodesk.Revit.DB Namespace
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRenderNode
Autodesk.Revit.DBContentNode
Autodesk.Revit.DBElementNode
Autodesk.Revit.DBFaceDetailNode
Autodesk.Revit.DBFaceNode
Autodesk.Revit.DBGroupNode
Autodesk.Revit.DBMaterialNode
Autodesk.Revit.DBModelCurveNode
Autodesk.Revit.DBTextNode
Autodesk.Revit.DBViewNode


RenderNode Properties

The RenderNode type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NodeName | A readable name of the output node.
Top
See Also

Reference

RenderNode Class


RenderNode.IsValidObject Property

RenderNodeIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

RenderNode Class


RenderNode.NodeName Property

RenderNodeNodeName Property

A readable name of the output node.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string NodeName { get; }
Public ReadOnly Property NodeName As String
    Get
public:
property String^ NodeName {
    String^ get ();
}
member NodeName : string with get

Property Value

String
See Also

Reference

RenderNode Class


RenderNode Methods

The RenderNode type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

RenderNode Class


RenderNode.Dispose Method

RenderNodeDispose Method

Releases all resources used by the RenderNode

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

RenderNode Class


RenderNodeAction Enumeration

Enumerated actions for processing a render node during custom export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum RenderNodeAction
Public Enumeration RenderNodeAction
public enum class RenderNodeAction
type RenderNodeAction
Members
Member name | Value | Description
Proceed | 0 | Instruct the exporter to go on with processing the node. It means the exporter will continue handling the node by processing all its child nodes, if it has any, and their geometry where it is relevant.
Skip | 1 | Instruct the exporter to skip the node. It means the exporter will not process any child nodes (nor the geometry) of the node. The respective end-node notification will still be invoked though.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RepeaterBounds Class

Represents bounds of the array of repeating references in 0, 1, or 2 dimensions. (See RepeatingReferenceSource).
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRepeaterBounds

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RepeaterBounds : IDisposable
Public Class RepeaterBounds
    Implements IDisposable
public ref class RepeaterBounds : IDisposable
type RepeaterBounds =
    class
        interface IDisposable
    end

The RepeaterBounds type exposes the following members.

Properties
 | Name | Description
Public property | DimensionCount | The number of dimensions of the bounds (0, 1 or 2 for zero, one or two dimensional arrays.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | AdjustForCyclicalBounds | Shifts the input coordinates in the cyclical dimensions so that they fall in the [lower bounds, upper bounds] range.
Public method | AreCoordinatesInBounds | Determines whether given coordinates are within the bounds.
Public method | Dispose | Releases all resources used by the RepeaterBounds
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLowerBound | Returns the smallest index of the array in the given dimension.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetUpperBound | Returns the highest index of the array in the given dimension.
Public method | IsCyclical | True if the array doesn't have finite bounds in the given dimension. Cyclical bounds indicate that the array forms a closed loop in the given dimension.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RepeaterBounds Properties

The RepeaterBounds type exposes the following members.

Properties
 | Name | Description
Public property | DimensionCount | The number of dimensions of the bounds (0, 1 or 2 for zero, one or two dimensional arrays.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

RepeaterBounds Class


RepeaterBounds.DimensionCount Property

RepeaterBoundsDimensionCount Property

The number of dimensions of the bounds (0, 1 or 2 for zero, one or two dimensional arrays.)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int DimensionCount { get; }
Public ReadOnly Property DimensionCount As Integer
    Get
public:
property int DimensionCount {
    int get ();
}
member DimensionCount : int with get

Property Value

Int32
See Also

Reference

RepeaterBounds Class


RepeaterBounds.IsValidObject Property

RepeaterBoundsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

RepeaterBounds Class


RepeaterBounds Methods

The RepeaterBounds type exposes the following members.

Methods
 | Name | Description
Public method | AdjustForCyclicalBounds | Shifts the input coordinates in the cyclical dimensions so that they fall in the [lower bounds, upper bounds] range.
Public method | AreCoordinatesInBounds | Determines whether given coordinates are within the bounds.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLowerBound | Returns the smallest index of the array in the given dimension.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetUpperBound | Returns the highest index of the array in the given dimension.
Public method | IsCyclical | True if the array doesn't have finite bounds in the given dimension. Cyclical bounds indicate that the array forms a closed loop in the given dimension.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

RepeaterBounds Class


RepeaterBounds.AdjustForCyclicalBounds Method

RepeaterBoundsAdjustForCyclicalBounds Method

Shifts the input coordinates in the cyclical dimensions so that they fall in the [lower bounds, upper bounds] range.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RepeaterCoordinates AdjustForCyclicalBounds(
    RepeaterCoordinates coordinates
)
Public Function AdjustForCyclicalBounds (
    coordinates As RepeaterCoordinates
) As RepeaterCoordinates
public:
RepeaterCoordinates^ AdjustForCyclicalBounds(
    RepeaterCoordinates^ coordinates
)
member AdjustForCyclicalBounds :
        coordinates : RepeaterCoordinates -> RepeaterCoordinates

Parameters

coordinates RepeaterCoordinates
The coordinates.

Return Value

RepeaterCoordinates
The adjusted coordinates.
Exceptions
Exception | Condition
ArgumentException | The coordinates coordinates have incompatible number of dimensions.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The bounds must have at least one dimension.
Remarks
The coordinates must have the same number of dimensions as the bounds. This method does not apply to zero dimensional bounds.
See Also

Reference

RepeaterBounds Class


RepeaterBounds.AreCoordinatesInBounds Method

RepeaterBoundsAreCoordinatesInBounds Method

Determines whether given coordinates are within the bounds.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AreCoordinatesInBounds(
    RepeaterCoordinates coordinates,
    bool treatCyclicalBoundsAsInfinite
)
Public Function AreCoordinatesInBounds (
    coordinates As RepeaterCoordinates,
    treatCyclicalBoundsAsInfinite As Boolean
) As Boolean
public:
bool AreCoordinatesInBounds(
    RepeaterCoordinates^ coordinates,
    bool treatCyclicalBoundsAsInfinite
)
member AreCoordinatesInBounds :
        coordinates : RepeaterCoordinates *
        treatCyclicalBoundsAsInfinite : bool -> bool

Parameters

coordinates RepeaterCoordinates
The coordinates.
treatCyclicalBoundsAsInfinite Boolean
True if cyclical directions should be treated as unbounded.

Return Value

Boolean
True if the coordinates are within the bounds.
Exceptions
Exception | Condition
ArgumentException | The coordinates coordinates have incompatible number of dimensions.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The bounds must have at least one dimension.
Remarks
The coordinates must have the same number of dimensions as the bounds. This method does not apply to zero dimensional bounds.
See Also

Reference

RepeaterBounds Class


RepeaterBounds.Dispose Method

RepeaterBoundsDispose Method

Releases all resources used by the RepeaterBounds

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

RepeaterBounds Class


RepeaterBounds.GetLowerBound Method

RepeaterBoundsGetLowerBound Method

Returns the smallest index of the array in the given dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetLowerBound(
    int dimension
)
Public Function GetLowerBound (
    dimension As Integer
) As Integer
public:
int GetLowerBound(
    int dimension
)
member GetLowerBound :
        dimension : int -> int

Parameters

dimension Int32
The dimension.

Return Value

Int32
The smallest index of the array in the given dimension.
Exceptions
Exception | Condition
ArgumentException | The dimension is invalid for these bounds.
InvalidOperationException | The bounds must have at least one dimension.
Remarks
The dimension begins at 0 and must be in the range [0, number of dimensions in the bounds - 1]. This method does not apply to zero dimensional bounds.
See Also

Reference

RepeaterBounds Class


RepeaterBounds.GetUpperBound Method

RepeaterBoundsGetUpperBound Method

Returns the highest index of the array in the given dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetUpperBound(
    int dimension
)
Public Function GetUpperBound (
    dimension As Integer
) As Integer
public:
int GetUpperBound(
    int dimension
)
member GetUpperBound :
        dimension : int -> int

Parameters

dimension Int32
The dimension.

Return Value

Int32
The highest index of the array in the given dimension.
Exceptions
Exception | Condition
ArgumentException | The dimension is invalid for these bounds.
InvalidOperationException | The bounds must have at least one dimension.
Remarks
The dimension begins at 0 and must be in the range [0, number of dimensions in the bounds - 1]. This method does not apply to zero dimensional bounds.
See Also

Reference

RepeaterBounds Class


RepeaterBounds.IsCyclical Method

RepeaterBoundsIsCyclical Method

True if the array doesn't have finite bounds in the given dimension. Cyclical bounds indicate that the array forms a closed loop in the given dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCyclical(
    int dimension
)
Public Function IsCyclical (
    dimension As Integer
) As Boolean
public:
bool IsCyclical(
    int dimension
)
member IsCyclical :
        dimension : int -> bool

Parameters

dimension Int32
The dimension.

Return Value

Boolean
True if the bounds are cyclical in the given dimension.
Exceptions
Exception | Condition
ArgumentException | The dimension is invalid for these bounds.
InvalidOperationException | The bounds must have at least one dimension.
Remarks
The dimension begins at 0 and must be in the range [0, number of dimensions in the bounds - 1]. This method does not apply to zero dimensional bounds.
See Also

Reference

RepeaterBounds Class


RepeaterCoordinates Class

Represents coordinates in the array of repeating references in 0, 1, or 2 dimensions.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRepeaterCoordinates

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RepeaterCoordinates : IDisposable
Public Class RepeaterCoordinates
    Implements IDisposable
public ref class RepeaterCoordinates : IDisposable
type RepeaterCoordinates =
    class
        interface IDisposable
    end

The RepeaterCoordinates type exposes the following members.

Constructors
 | Name | Description
Public method | RepeaterCoordinates | Creates zero dimensional coordinates.
Public method | RepeaterCoordinates(Int32) | Creates one dimensional coordinates.
Public method | RepeaterCoordinates(Int32, Int32) | Creates two dimensional coordinates.
Top
Properties
 | Name | Description
Public property | DimensionCount | The number of dimensions of the coordinates (0, 1 or 2 for zero, one or two dimensional arrays.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the RepeaterCoordinates
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCoordinate | Returns the coordinate in the given dimension.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RepeaterCoordinates Constructor

Overload List
 | Name | Description
Public method | RepeaterCoordinates | Creates zero dimensional coordinates.
Public method | RepeaterCoordinates(Int32) | Creates one dimensional coordinates.
Public method | RepeaterCoordinates(Int32, Int32) | Creates two dimensional coordinates.
Top
See Also

Reference

RepeaterCoordinates Class


RepeaterCoordinates Constructor

Creates zero dimensional coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RepeaterCoordinates()
Public Sub New
public:
RepeaterCoordinates()
new : unit -> RepeaterCoordinates
See Also

Reference

RepeaterCoordinates Class
RepeaterCoordinates Overload


RepeaterCoordinates(Int32) Constructor

Creates one dimensional coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RepeaterCoordinates(
    int x
)
Public Sub New (
    x As Integer
)
public:
RepeaterCoordinates(
    int x
)
new :
        x : int -> RepeaterCoordinates

Parameters

x Int32
The coordinate.
See Also

Reference

RepeaterCoordinates Class
RepeaterCoordinates Overload


RepeaterCoordinates(Int32, Int32) Constructor

Creates two dimensional coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RepeaterCoordinates(
    int x,
    int y
)
Public Sub New (
    x As Integer,
    y As Integer
)
public:
RepeaterCoordinates(
    int x,
    int y
)
new :
        x : int *
        y : int -> RepeaterCoordinates

Parameters

x Int32
The coordinate in first dimension.
y Int32
The coordinate in second dimension.
See Also

Reference

RepeaterCoordinates Class
RepeaterCoordinates Overload


RepeaterCoordinates Properties

The RepeaterCoordinates type exposes the following members.

Properties
 | Name | Description
Public property | DimensionCount | The number of dimensions of the coordinates (0, 1 or 2 for zero, one or two dimensional arrays.)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

RepeaterCoordinates Class


RepeaterCoordinates.DimensionCount Property

RepeaterCoordinatesDimensionCount Property

The number of dimensions of the coordinates (0, 1 or 2 for zero, one or two dimensional arrays.)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int DimensionCount { get; }
Public ReadOnly Property DimensionCount As Integer
    Get
public:
property int DimensionCount {
    int get ();
}
member DimensionCount : int with get

Property Value

Int32
See Also

Reference

RepeaterCoordinates Class


RepeaterCoordinates.IsValidObject Property

RepeaterCoordinatesIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

RepeaterCoordinates Class


RepeaterCoordinates Methods

The RepeaterCoordinates type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCoordinate | Returns the coordinate in the given dimension.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

RepeaterCoordinates Class


RepeaterCoordinates.Dispose Method

RepeaterCoordinatesDispose Method

Releases all resources used by the RepeaterCoordinates

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

RepeaterCoordinates Class


RepeaterCoordinates.GetCoordinate Method

RepeaterCoordinatesGetCoordinate Method

Returns the coordinate in the given dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetCoordinate(
    int dimension
)
Public Function GetCoordinate (
    dimension As Integer
) As Integer
public:
int GetCoordinate(
    int dimension
)
member GetCoordinate :
        dimension : int -> int

Parameters

dimension Int32
The dimension.

Return Value

Int32
The coordinate.
Exceptions
Exception | Condition
ArgumentException | The dimension is invalid for these coordinates.
InvalidOperationException | The coordinates must have at least one dimension.
Remarks
The dimension begins at 0 and must be in the range [0, number of dimensions in the bounds - 1]. This method does not apply to zero dimensional coordinates.
See Also

Reference

RepeaterCoordinates Class


RepeatingReferenceSource Class

Represents a collection of repeating references.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRepeatingReferenceSource

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RepeatingReferenceSource : IDisposable
Public Class RepeatingReferenceSource
    Implements IDisposable
public ref class RepeatingReferenceSource : IDisposable
type RepeatingReferenceSource =
    class
        interface IDisposable
    end

The RepeatingReferenceSource type exposes the following members.

Properties
 | Name | Description
Public property | DimensionCount | The dimension count of the repeating reference array.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the RepeatingReferenceSource
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBounds | Returns information about the boundaries of the repeating reference array.
 | GetDefaultRepeatingReferenceSource | Returns the default repeating reference source for a given element.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetReference | Returns an individual repeating reference given by coordinates in the array, or if there is no reference at the coordinates (for example if there is a hole in a divided surface.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | HasRepeatingReferenceSource | Determines whether an element has any repeating reference sources that can be used when creating component repeaters.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

The RepeatingReferenceSource class is the building block for setting up component repeaters. Repeating references are arranged in zero, one or two dimensional arrays. The RepeatingReferenceSource class represents this array of references and provides access to individual repeating references.

Note that there may be gaps in the array (for example a repeating reference source formed by a divided surface with holes, or is non-rectangular surface.)

Repeating reference sources are a property of an element. Only point elements, divided paths and divided surface elements support repeating reference sources. These element respectively have 0, 1 and 2 dimensional repeating references. Use the HasRepeatingReferenceSource() method to query whether an element supports repeating reference sources and the GetDefaultRepeatingReferenceSource() method to obtain a repeating reference source from a given element.

See the ComponentRepeater and ComponentRepeaterSlot classes for more information.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RepeatingReferenceSource Properties

The RepeatingReferenceSource type exposes the following members.

Properties
 | Name | Description
Public property | DimensionCount | The dimension count of the repeating reference array.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

RepeatingReferenceSource Class


RepeatingReferenceSource.DimensionCount Property

RepeatingReferenceSourceDimensionCount Property

The dimension count of the repeating reference array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int DimensionCount { get; }
Public ReadOnly Property DimensionCount As Integer
    Get
public:
property int DimensionCount {
    int get ();
}
member DimensionCount : int with get

Property Value

Int32
See Also

Reference

RepeatingReferenceSource Class


RepeatingReferenceSource.IsValidObject Property

RepeatingReferenceSourceIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

RepeatingReferenceSource Class


RepeatingReferenceSource Methods

The RepeatingReferenceSource type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBounds | Returns information about the boundaries of the repeating reference array.
 | GetDefaultRepeatingReferenceSource | Returns the default repeating reference source for a given element.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetReference | Returns an individual repeating reference given by coordinates in the array, or if there is no reference at the coordinates (for example if there is a hole in a divided surface.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | HasRepeatingReferenceSource | Determines whether an element has any repeating reference sources that can be used when creating component repeaters.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

RepeatingReferenceSource Class


RepeatingReferenceSource.Dispose Method

RepeatingReferenceSourceDispose Method

Releases all resources used by the RepeatingReferenceSource

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

RepeatingReferenceSource Class


RepeatingReferenceSource.GetBounds Method

RepeatingReferenceSourceGetBounds Method

Returns information about the boundaries of the repeating reference array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RepeaterBounds GetBounds()
Public Function GetBounds As RepeaterBounds
public:
RepeaterBounds^ GetBounds()
member GetBounds : unit -> RepeaterBounds

Return Value

RepeaterBounds
The bounds of the repeating reference source.
Exceptions
Exception | Condition
InvalidOperationException | The repeating reference source is no longer valid.
Remarks
See the RepeaterBounds structure for more information about repeating reference source bounds.
See Also

Reference

RepeatingReferenceSource Class


RepeatingReferenceSource.GetDefaultRepeatingReferenceSource Method

RepeatingReferenceSourceGetDefaultRepeatingReferenceSource Method

Returns the default repeating reference source for a given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static RepeatingReferenceSource GetDefaultRepeatingReferenceSource(
    Document document,
    ElementId elementId
)
Public Shared Function GetDefaultRepeatingReferenceSource (
    document As Document,
    elementId As ElementId
) As RepeatingReferenceSource
public:
static RepeatingReferenceSource^ GetDefaultRepeatingReferenceSource(
    Document^ document,
    ElementId^ elementId
)
static member GetDefaultRepeatingReferenceSource :
        document : Document *
        elementId : ElementId -> RepeatingReferenceSource

Parameters

document Document
The document that contains the element.
elementId ElementId
The id of the element.

Return Value

RepeatingReferenceSource
The default repeating reference source of the given element.
Exceptions
Exception | Condition
ArgumentException | The element elementId does not exist in the document -or- The element does not have any repeating reference sources.
ArgumentNullException | A non-optional argument was null
Remarks
The element must support repeating references. Use HasRepeatingReferenceSource() to find out whether an element has any repeating references.
See Also

Reference

RepeatingReferenceSource Class


RepeatingReferenceSource.GetReference Method

RepeatingReferenceSourceGetReference Method

Returns an individual repeating reference given by coordinates in the array, or if there is no reference at the coordinates (for example if there is a hole in a divided surface.)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Reference GetReference(
    RepeaterCoordinates coordinates
)
Public Function GetReference (
    coordinates As RepeaterCoordinates
) As Reference
public:
Reference^ GetReference(
    RepeaterCoordinates^ coordinates
)
member GetReference :
        coordinates : RepeaterCoordinates -> Reference

Parameters

coordinates RepeaterCoordinates
The coordinates in the array of repeating references.

Return Value

Reference
The repeating reference.
Exceptions
Exception | Condition
ArgumentException | The coordinates are not valid for the repeating reference source. This could be because of a mismatched dimensionality or because the coordinates are outside the bounds of the repeating reference source.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The repeating reference source is no longer valid.
Remarks
The coordinates must be within the bounds of the repeating reference source.
See Also

Reference

RepeatingReferenceSource Class


RepeatingReferenceSource.HasRepeatingReferenceSource Method

RepeatingReferenceSourceHasRepeatingReferenceSource Method

Determines whether an element has any repeating reference sources that can be used when creating component repeaters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool HasRepeatingReferenceSource(
    Document document,
    ElementId elementId
)
Public Shared Function HasRepeatingReferenceSource (
    document As Document,
    elementId As ElementId
) As Boolean
public:
static bool HasRepeatingReferenceSource(
    Document^ document,
    ElementId^ elementId
)
static member HasRepeatingReferenceSource :
        document : Document *
        elementId : ElementId -> bool

Parameters

document Document
The document that contains the element.
elementId ElementId
The id of the element.

Return Value

Boolean
True if the element has any repeating reference sources.
Exceptions
Exception | Condition
ArgumentException | The element elementId does not exist in the document
ArgumentNullException | A non-optional argument was null
See Also

Reference

RepeatingReferenceSource Class


ResolutionTarget Enumeration

Indicates the resolution target(Screen or Printer) used for rendering settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ResolutionTarget
Public Enumeration ResolutionTarget
public enum class ResolutionTarget
type ResolutionTarget
Members
Member name | Value | Description
Screen | 0 | Uses screen resolution for rendering output settings.
Printer | 1 | Uses printer resolution for rendering output settings.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ResourceVersionStatus Enumeration

An enum indicating whether a resource is current or out of date.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ResourceVersionStatus
Public Enumeration ResourceVersionStatus
public enum class ResourceVersionStatus
type ResourceVersionStatus
Members
Member name | Value | Description
Current | 0 | The resource is up-to-date; this is is the most recent version of the resource.
OutOfDate | 1 | This is not the most recent version of the resource.
Unknown | 2 | It is not known whether the resource is current.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Revision Class

Represents a single revision in the project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBRevision

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Revision : Element
Public Class Revision
    Inherits Element
public ref class Revision : public Element
type Revision =
    class
        inherit Element
    end

The Revision type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
Public property | Description | The description of this Revision.
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | Issued | Indicates whether this Revision has been issued.
Public property | IssuedBy | Indicates who has issued or will issue this Revision.
Public property | IssuedTo | Indicates to whom this Revision was or will be issued.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | RevisionDate | The date of this Revision.
Public property | RevisionNumber | The Revision number of this revision.
Public property | RevisionNumberingSequenceId | The id of the revision numbering sequence which controls this revision's numbering.
Public property | SequenceNumber | The Sequence Number of this Revision.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | Visibility | Controls the visibility of revision clouds and revision tags related to this Revision.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | CombineWithNext | Combines the specified Revision with the next Revision.
 | CombineWithPrevious | Combines the specified Revision with the previous Revision.
 | Create | Creates a new Revision in the project.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
 | GetAllRevisionIds | Returns the ids of all Revisions in the project ordered by sequence number.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
 | ReorderRevisionSequence | Reorders the sequence of Revisions in the project.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The Revision object represents the data related to a single revision in the project. Revision clouds and tags can be associated with a particular Revision object to display its properties on sheets.

The revisions in the project are stored in a specific order called the revision sequence. The revision sequence represents the conceptual sequence in which revisions will be issued.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Revision Properties

The Revision type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
Public property | Description | The description of this Revision.
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | Issued | Indicates whether this Revision has been issued.
Public property | IssuedBy | Indicates who has issued or will issue this Revision.
Public property | IssuedTo | Indicates to whom this Revision was or will be issued.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | RevisionDate | The date of this Revision.
Public property | RevisionNumber | The Revision number of this revision.
Public property | RevisionNumberingSequenceId | The id of the revision numbering sequence which controls this revision's numbering.
Public property | SequenceNumber | The Sequence Number of this Revision.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | Visibility | Controls the visibility of revision clouds and revision tags related to this Revision.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

Revision Class


Revision.Description Property

RevisionDescription Property

The description of this Revision.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
InvalidOperationException | When setting this property: This operation cannot be performed on Revisions that have already been issued.
See Also

Reference

Revision Class


Revision.Issued Property

RevisionIssued Property

Indicates whether this Revision has been issued.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Issued { get; set; }
Public Property Issued As Boolean
    Get
    Set
public:
property bool Issued {
    bool get ();
    void set (bool value);
}
member Issued : bool with get, set

Property Value

Boolean
See Also

Reference

Revision Class


Revision.IssuedBy Property

RevisionIssuedBy Property

Indicates who has issued or will issue this Revision.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string IssuedBy { get; set; }
Public Property IssuedBy As String
    Get
    Set
public:
property String^ IssuedBy {
    String^ get ();
    void set (String^ value);
}
member IssuedBy : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
InvalidOperationException | When setting this property: This operation cannot be performed on Revisions that have already been issued.
See Also

Reference

Revision Class


Revision.IssuedTo Property

RevisionIssuedTo Property

Indicates to whom this Revision was or will be issued.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string IssuedTo { get; set; }
Public Property IssuedTo As String
    Get
    Set
public:
property String^ IssuedTo {
    String^ get ();
    void set (String^ value);
}
member IssuedTo : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
InvalidOperationException | When setting this property: This operation cannot be performed on Revisions that have already been issued.
See Also

Reference

Revision Class


Revision.RevisionDate Property

RevisionRevisionDate Property

The date of this Revision.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string RevisionDate { get; set; }
Public Property RevisionDate As String
    Get
    Set
public:
property String^ RevisionDate {
    String^ get ();
    void set (String^ value);
}
member RevisionDate : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
InvalidOperationException | When setting this property: This operation cannot be performed on Revisions that have already been issued.
Remarks
The Revision date is an arbitrary String and can be blank. Revit will not attempt to interpret it as an actual date.
See Also

Reference

Revision Class


Revision.RevisionNumber Property

RevisionRevisionNumber Property

The Revision number of this revision.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string RevisionNumber { get; }
Public ReadOnly Property RevisionNumber As String
    Get
public:
property String^ RevisionNumber {
    String^ get ();
}
member RevisionNumber : string with get

Property Value

String
Exceptions
Exception | Condition
InvalidOperationException | This operation is not valid for when the revision numbering is per sheet.
Remarks
Note that this field is only available if the RevisionSettings are set to number revisions PerProject. When Revisions are numbered PerSheet, a given Revision may display a different RevisionNumber on each sheet. In this case, the revision number can be obtained by calling [!:Autodesk::Revit::DB::ViewSheet::GetRevisionNumberOnSheet()].
See Also

Reference

Revision Class


Revision.RevisionNumberingSequenceId Property

RevisionRevisionNumberingSequenceId Property

The id of the revision numbering sequence which controls this revision's numbering.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId RevisionNumberingSequenceId { get; set; }
Public Property RevisionNumberingSequenceId As ElementId
    Get
    Set
public:
property ElementId^ RevisionNumberingSequenceId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member RevisionNumberingSequenceId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentException | When setting this property: revisionNumberingSequenceId doesn't represent a RevisionNumberingSequence element.
ArgumentNullException | When setting this property: A non-optional argument was null
InvalidOperationException | When setting this property: This operation cannot be performed on Revisions that have already been issued.
See Also

Reference

Revision Class


Revision.SequenceNumber Property

RevisionSequenceNumber Property

The Sequence Number of this Revision.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int SequenceNumber { get; }
Public ReadOnly Property SequenceNumber As Integer
    Get
public:
property int SequenceNumber {
    int get ();
}
member SequenceNumber : int with get

Property Value

Int32
Remarks
Every Revision in the project will be assigned a consecutive sequence number starting with 1. This number corresponds to the ordering of the Revisions. If a Revision is deleted, subsequent Revisions will update their sequence numbers to maintain a consecutive list.
See Also

Reference

Revision Class


Revision.Visibility Property

RevisionVisibility Property

Controls the visibility of revision clouds and revision tags related to this Revision.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RevisionVisibility Visibility { get; set; }
Public Property Visibility As RevisionVisibility
    Get
    Set
public:
property RevisionVisibility Visibility {
    RevisionVisibility get ();
    void set (RevisionVisibility value);
}
member Visibility : RevisionVisibility with get, set

Property Value

RevisionVisibility
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
This property provides project-wide control over the visibility of revision clouds and tags associated with this Revision. If clouds or tags are hidden by this property they will not be visible in any views regardless of the view's settings. If clouds or tags are visible according to this property they may still be hidden on a particular view or sheet.
See Also

Reference

Revision Class


Revision Methods

The Revision type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | CombineWithNext | Combines the specified Revision with the next Revision.
 | CombineWithPrevious | Combines the specified Revision with the previous Revision.
 | Create | Creates a new Revision in the project.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
 | GetAllRevisionIds | Returns the ids of all Revisions in the project ordered by sequence number.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
 | ReorderRevisionSequence | Reorders the sequence of Revisions in the project.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Revision Class


Revision.CombineWithNext Method

RevisionCombineWithNext Method

Combines the specified Revision with the next Revision.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ISet<ElementId> CombineWithNext(
    Document document,
    ElementId revisionId
)
Public Shared Function CombineWithNext (
    document As Document,
    revisionId As ElementId
) As ISet(Of ElementId)
public:
static ISet<ElementId^>^ CombineWithNext(
    Document^ document,
    ElementId^ revisionId
)
static member CombineWithNext :
        document : Document *
        revisionId : ElementId -> ISet<ElementId>

Parameters

document Document
The Document containing the Revisions.
revisionId ElementId
The Revision that should have its clouds and tags associated with the next Revision.

Return Value

ISet ElementId
The ids of all RevisionClouds that were reassigned to the next Revision.
Exceptions
Exception | Condition
ArgumentException | revisionId is not a valid Revision. -or- This operation cannot be performed because revisionId is an issued Revision. -or- revisionId cannot be combined with the next Revision because either revisionId is the last Revision or the next Revision has already been issued.
ArgumentNullException | A non-optional argument was null
Remarks
All RevisionClouds and tags associated with the specified Revision will be reassigned to the next Revision in the model and the specified Revision will be deleted from the model. The operation can only be performed if both the specified Revision and the next one are unissued.
Example
C#
VB
C++
F#
Copy
private bool CombineRevision(Document document, Revision revision)
{
    bool combined = false;
    // Can only combine two revisions if neither have been issued
    if (revision.Issued == false)
    {
        ElementId revisionId = revision.Id;
        Revision nextRevsion = GetNextRevision(document, revisionId);
        if (nextRevsion != null && nextRevsion.Issued == false)
        {
            ISet<ElementId> revisionCloudIds = Revision.CombineWithNext(document, revisionId);
            combined = true;
            int movedClouds = revisionCloudIds.Count;
            if (movedClouds > 0)
            {
                RevisionCloud cloud = document.GetElement(revisionCloudIds.ElementAt(0)) as RevisionCloud;
                if (cloud != null)
                {
                    string msg = string.Format("Revision {0} deleted and {1} revision clouds were added to Revsion {2}",
                        revisionId.ToString(), movedClouds, cloud.RevisionId.ToString());
                    TaskDialog.Show("Revision Combined", msg);
                }
            }
        }
    }

    return combined;
}

private Revision GetNextRevision(Document document, ElementId currentRevisionId)
{
    Revision nextRevision = null;
    IList<ElementId> revisionIds = Revision.GetAllRevisionIds(document);
    int currentRevisionIndex = -1;
    for (int n = 0; n < revisionIds.Count; n++)
    {
        if (revisionIds[n] == currentRevisionId)
        {
            currentRevisionIndex = n;
            break;
        }
    }

    // if the current revision id was found and is not the last index
    if (currentRevisionIndex >= 0 && currentRevisionIndex < revisionIds.Count - 1)
    {
        ElementId nextRevisionId = revisionIds[currentRevisionIndex + 1];
        nextRevision = document.GetElement(nextRevisionId) as Revision;
    }

    return nextRevision;
}
Private Function CombineRevision(document As Document, revision__1 As Revision) As Boolean
    Dim combined As Boolean = False
    ' Can only combine two revisions if neither have been issued
    If revision__1.Issued = False Then
        Dim revisionId As ElementId = revision__1.Id
        Dim nextRevsion As Revision = GetNextRevision(document, revisionId)
        If nextRevsion IsNot Nothing AndAlso nextRevsion.Issued = False Then
            Dim revisionCloudIds As ISet(Of ElementId) = Revision.CombineWithNext(document, revisionId)
            combined = True
            Dim movedClouds As Integer = revisionCloudIds.Count
            If movedClouds > 0 Then
                Dim cloud As RevisionCloud = TryCast(document.GetElement(revisionCloudIds.ElementAt(0)), RevisionCloud)
                If cloud IsNot Nothing Then
                    Dim msg As String = String.Format("Revision {0} deleted and {1} revision clouds were added to Revsion {2}", revisionId.ToString(), movedClouds, cloud.RevisionId.ToString())
                    TaskDialog.Show("Revision Combined", msg)
                End If
            End If
        End If
    End If

    Return combined
End Function

Private Function GetNextRevision(document As Document, currentRevisionId As ElementId) As Revision
    Dim nextRevision As Revision = Nothing
    Dim revisionIds As IList(Of ElementId) = Revision.GetAllRevisionIds(document)
    Dim currentRevisionIndex As Integer = -1
    For n As Integer = 0 To revisionIds.Count - 1
        If revisionIds(n) = currentRevisionId Then
            currentRevisionIndex = n
            Exit For
        End If
    Next

    ' if the current revision id was found and is not the last index
    If currentRevisionIndex >= 0 AndAlso currentRevisionIndex < revisionIds.Count - 1 Then
        Dim nextRevisionId As ElementId = revisionIds(currentRevisionIndex + 1)
        nextRevision = TryCast(document.GetElement(nextRevisionId), Revision)
    End If

    Return nextRevision
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Revision Class


Revision.CombineWithPrevious Method

RevisionCombineWithPrevious Method

Combines the specified Revision with the previous Revision.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ISet<ElementId> CombineWithPrevious(
    Document document,
    ElementId revisionId
)
Public Shared Function CombineWithPrevious (
    document As Document,
    revisionId As ElementId
) As ISet(Of ElementId)
public:
static ISet<ElementId^>^ CombineWithPrevious(
    Document^ document,
    ElementId^ revisionId
)
static member CombineWithPrevious :
        document : Document *
        revisionId : ElementId -> ISet<ElementId>

Parameters

document Document
The Document containing the Revisions.
revisionId ElementId
The Revision that should have its clouds and tags associated with the previous Revision.

Return Value

ISet ElementId
The ids of all RevisionClouds that were reassigned to the previous Revision.
Exceptions
Exception | Condition
ArgumentException | revisionId is not a valid Revision. -or- This operation cannot be performed because revisionId is an issued Revision. -or- revisionId cannot be combined with the previous Revision because either revisionId is the first Revision or the previous Revision has already been issued.
ArgumentNullException | A non-optional argument was null
Remarks
All RevisionClouds and tags associated with the specified Revision will be reassigned to the previous Revision in the model and the specified Revision will be deleted from the model. The operation can only be performed if both the specified Revision and the previous one are unissued.
See Also

Reference

Revision Class


Revision.Create Method

RevisionCreate Method

Creates a new Revision in the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Revision Create(
    Document document
)
Public Shared Function Create (
    document As Document
) As Revision
public:
static Revision^ Create(
    Document^ document
)
static member Create :
        document : Document -> Revision

Parameters

document Document
The document of the new Revision.

Return Value

Revision
The newly created Revision.
Exceptions
Exception | Condition
ArgumentException | document is not a project document.
ArgumentNullException | A non-optional argument was null
Remarks
The new Revision will be added at the end of the sequence of existing Revisions.
Example
C#
VB
C++
F#
Copy
private Revision AddNewRevision(Document document, string description, string issuedBy, string issuedTo, ElementId sequenceNumber, DateTime date)
{
    Revision newRevision = Revision.Create(document);
    newRevision.Description = description;
    newRevision.IssuedBy = issuedBy;
    newRevision.IssuedTo = issuedTo;
    newRevision.RevisionNumberingSequenceId = sequenceNumber;
    newRevision.RevisionDate = date.ToShortDateString();
    return newRevision;
}
Private Function AddNewRevision(document As Document, description As String, issuedBy As String, issuedTo As String, sequenceNumber As ElementId, [date] As DateTime) As Revision
    Dim newRevision As Revision = Revision.Create(document)
    newRevision.Description = description
    newRevision.IssuedBy = issuedBy
    newRevision.IssuedTo = issuedTo
    newRevision.RevisionNumberingSequenceId = sequenceNumber
    newRevision.RevisionDate = [date].ToShortDateString()
    Return newRevision
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Revision Class


Revision.GetAllRevisionIds Method

RevisionGetAllRevisionIds Method

Returns the ids of all Revisions in the project ordered by sequence number.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<ElementId> GetAllRevisionIds(
    Document document
)
Public Shared Function GetAllRevisionIds (
    document As Document
) As IList(Of ElementId)
public:
static IList<ElementId^>^ GetAllRevisionIds(
    Document^ document
)
static member GetAllRevisionIds :
        document : Document -> IList<ElementId>

Parameters

document Document
The document containing the Revisions.

Return Value

IList ElementId
The ids of all the Revisions in the document ordered by sequence number.
Exceptions
Exception | Condition
ArgumentException | document is not a project document.
ArgumentNullException | A non-optional argument was null
See Also

Reference

Revision Class


Revision.ReorderRevisionSequence Method

RevisionReorderRevisionSequence Method

Reorders the sequence of Revisions in the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void ReorderRevisionSequence(
    Document document,
    IList<ElementId> newSequence
)
Public Shared Sub ReorderRevisionSequence (
    document As Document,
    newSequence As IList(Of ElementId)
)
public:
static void ReorderRevisionSequence(
    Document^ document,
    IList<ElementId^>^ newSequence
)
static member ReorderRevisionSequence :
        document : Document *
        newSequence : IList<ElementId> -> unit

Parameters

document Document
The document in which the Revision sequence should be reordered.
newSequence IList ElementId
The new sequence of Revisions.
Exceptions
Exception | Condition
ArgumentException | newSequence does not contain every Revision exactly once.
ArgumentNullException | A non-optional argument was null
Remarks
This method allows the caller to change the sequence of the Revisions within the project by specifying the new sequence. The specified sequence must include every Revision in the project exactly once.

Note that changing the sequence of Revisions can change the SequenceNumber and RevisionNumber of Revisions that have already been issued.

See Also

Reference

Revision Class


RevisionCloud Class

A RevisionCloud is a graphical "cloud" that can be displayed on a view or sheet to indicate where revisions in the model have occurred.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBRevisionCloud

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RevisionCloud : Element
Public Class RevisionCloud
    Inherits Element
public ref class RevisionCloud : public Element
type RevisionCloud =
    class
        inherit Element
    end

The RevisionCloud type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | RevisionId | The Revision associated with this RevisionCloud.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new RevisionCloud in the model.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSheetIds | Returns the ids of the ViewSheets where this RevisionCloud may appear and contribute to the sheet's revision schedule.
Public method | GetSketchCurves | Returns copies of the Curves that form this RevisionCloud.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsRevisionIssued | Indicates whether the Revision associated with this RevisionCloud has been issued.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
RevisionClouds are view specific and can be created in most graphical views, except 3D. Unlike most Elements, RevisionClouds may be added directly to a ViewSheet. Each RevisionCloud is associated with one Revision.

When a RevisionCloud is visible on a ViewSheet (either because it is directly placed on that ViewSheet or because it is visible in a View placed on the ViewSheet), any revision schedules displayed on the ViewSheet will automatically include the Revision associated with the RevisionCloud.

Note also that when a RevisionCloud is created in a ViewLegend, it is treated as a legend representation of what a RevisionCloud looks like rather than as an actual indication of a change to the model. As a result, RevisionClouds in ViewLegends will not affect the contents of revision schedules.

RevisionClouds are created from a collection of sketched curves. Each curve will have a series of "cloud bumps" drawn along it to form the appearance of a cloud. There is no requirement that the curves form closed loops.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RevisionCloud Properties

The RevisionCloud type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | RevisionId | The Revision associated with this RevisionCloud.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

RevisionCloud Class


RevisionCloud.RevisionId Property

RevisionCloudRevisionId Property

The Revision associated with this RevisionCloud.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId RevisionId { get; set; }
Public Property RevisionId As ElementId
    Get
    Set
public:
property ElementId^ RevisionId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member RevisionId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentException | When setting this property: revisionId is not a valid Revision. -or- When setting this property: This operation cannot be performed because revisionId is an issued Revision.
ArgumentNullException | When setting this property: A non-optional argument was null
InvalidOperationException | When setting this property: This operation cannot be performed on a RevisionCloud associated with a Revision that has been issued.
Remarks
This property cannot be set to a Revision that has already been issued. If this RevisionCloud is already associated with a Revision that has been issued then this property cannot be changed.
See Also

Reference

RevisionCloud Class


RevisionCloud Methods

The RevisionCloud type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new RevisionCloud in the model.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSheetIds | Returns the ids of the ViewSheets where this RevisionCloud may appear and contribute to the sheet's revision schedule.
Public method | GetSketchCurves | Returns copies of the Curves that form this RevisionCloud.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsRevisionIssued | Indicates whether the Revision associated with this RevisionCloud has been issued.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

RevisionCloud Class


RevisionCloud.Create Method

RevisionCloudCreate Method

Creates a new RevisionCloud in the model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static RevisionCloud Create(
    Document document,
    View view,
    ElementId revisionId,
    IList<Curve> curves
)
Public Shared Function Create (
    document As Document,
    view As View,
    revisionId As ElementId,
    curves As IList(Of Curve)
) As RevisionCloud
public:
static RevisionCloud^ Create(
    Document^ document,
    View^ view,
    ElementId^ revisionId,
    IList<Curve^>^ curves
)
static member Create :
        document : Document *
        view : View *
        revisionId : ElementId *
        curves : IList<Curve> -> RevisionCloud

Parameters

document Document
The document in which the RevisionCloud should be created.
view View
The View in which the RevisionCloud should appear.
revisionId ElementId
The Revision to associate with the new RevisionCloud.
curves IList Curve
The curves that will form the RevisionCloud's sketch.

Return Value

RevisionCloud
The newly created RevisionCloud.
Exceptions
Exception | Condition
ArgumentException | document is not a project document. -or- revisionId is not a valid Revision. -or- This operation cannot be performed because revisionId is an issued Revision. -or- view is not a View that can support RevisionClouds. -or- The provided Curves curves cannot be used as the basis for a RevisionCloud. Either the list is empty or one or more of the Curves could not be projected onto the View's plane.
ArgumentNullException | A non-optional argument was null
Remarks
Creates a new RevisionCloud in the specified View. The new RevisionCloud will be associated with the specified Revision. RevisionClouds can only be created if the Revision has not yet been issued.

RevisionClouds can be created in most graphical Views, excepting 3D views and graphical column schedules. Unlike most other Elements, RevisionClouds can be created directly on a ViewSheet.

RevisionClouds are created based on a series of sketched curves. There is no requirement that the curves form closed loops and self-intersections are also permitted. The curves will be automatically projected onto the appropriate plane for the View. The list of curves cannot be empty and any lines cannot be perpendicular to the View's plane. If the View is a model View, the coordinates specified for the curves will be interpreted in model space. If the View is a non-model View (such as a ViewSheet) then the coordinates will be interpreted in the View's space.

The cloud graphics will be attached to the curves under the assumption that each curve is oriented in a clockwise direction. For lines, this means that the outside of the cloud is in the direction of the line's normal vector within the View's plane. Any closed loops should therefore be oriented clockwise to create the typical cloud shape.

Example
C#
VB
C++
F#
Copy
private void CreateRevisionCloudInActiveView(Document document, Revision revision, IList<Curve> curves)
{
    using (Transaction newRevisionCloud = new Transaction(document, "Create Revision Cloud"))
    {
        newRevisionCloud.Start();
        // Can only create revision cloud for revision that is not issued
        if (revision.Issued == false)
        {
            RevisionCloud.Create(document, document.ActiveView, revision.Id, curves);
            newRevisionCloud.Commit();
        }
        else
        {
            newRevisionCloud.RollBack();
        }
    }
}
Private Sub CreateRevisionCloudInActiveView(document As Document, revision As Revision, curves As IList(Of Curve))
    Using newRevisionCloud As New Transaction(document, "Create Revision Cloud")
        newRevisionCloud.Start()
        ' Can only create revision cloud for revision that is not issued
        If revision.Issued = False Then
            RevisionCloud.Create(document, document.ActiveView, revision.Id, curves)
            newRevisionCloud.Commit()
        Else
            newRevisionCloud.RollBack()
        End If
    End Using
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

RevisionCloud Class


RevisionCloud.GetSheetIds Method

RevisionCloudGetSheetIds Method

Returns the ids of the ViewSheets where this RevisionCloud may appear and contribute to the sheet's revision schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ISet<ElementId> GetSheetIds()
Public Function GetSheetIds As ISet(Of ElementId)
public:
ISet<ElementId^>^ GetSheetIds()
member GetSheetIds : unit -> ISet<ElementId>

Return Value

ISet ElementId
The ids of the ViewSheets where this RevisionCloud may appear.
Remarks
A RevisionCloud can appear on a ViewSheet because it is drawn directly on the ViewSheet or because its owner view is placed on the ViewSheet. If the RevisionCloud is owned by a view that is a dependent view or has associated dependent views, then the RevisionCloud can also be visible on the sheets where the related dependent or primary views have been placed.

This RevisionCloud may not be visible in all ViewSheets reported by this method. Additional factors, such as the visibility settings or annotation crop of the Views or the visibility settings of the associated Revision may still cause this RevisionCloud to not appear on a particular ViewSheet.

If this RevisionCloud is owned by a ViewLegend, no sheets will be returned because the RevisionCloud will not participate in revision schedules.

See Also

Reference

RevisionCloud Class


RevisionCloud.GetSketchCurves Method

RevisionCloudGetSketchCurves Method

Returns copies of the Curves that form this RevisionCloud.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<Curve> GetSketchCurves()
Public Function GetSketchCurves As IList(Of Curve)
public:
IList<Curve^>^ GetSketchCurves()
member GetSketchCurves : unit -> IList<Curve>

Return Value

IList Curve
Copies of the sketched curves that form this RevisionCloud.
Remarks
Note that there is no requirement that the curves form closed loops or avoid self-intersections. The curves may also form multiple closed loops.
See Also

Reference

RevisionCloud Class


RevisionCloud.IsRevisionIssued Method

RevisionCloudIsRevisionIssued Method

Indicates whether the Revision associated with this RevisionCloud has been issued.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsRevisionIssued()
Public Function IsRevisionIssued As Boolean
public:
bool IsRevisionIssued()
member IsRevisionIssued : unit -> bool

Return Value

Boolean
True if the Revision has been issued, False otherwise.
See Also

Reference

RevisionCloud Class


RevisionNumbering Enumeration

The options for how revision numbers should be displayed on sheets within a project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum RevisionNumbering
Public Enumeration RevisionNumbering
public enum class RevisionNumbering
type RevisionNumbering
Members
Member name | Value | Description
PerProject | 0 | The revision numbers on a sheet will match the global Revision Sequence Number assigned to the revision.
PerSheet | 1 | The revisions on a given sheet will be automatically assigned a consecutive sequence for their revision numbers displayed on that sheet.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RevisionNumberingSequence Class

Defines the sequences by which numbers are assigned to Revisions.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBRevisionNumberingSequence

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RevisionNumberingSequence : Element
Public Class RevisionNumberingSequence
    Inherits Element
public ref class RevisionNumberingSequence : public Element
type RevisionNumberingSequence =
    class
        inherit Element
    end

The RevisionNumberingSequence type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | NumberType | Indicates the revision number type of the revision numbering sequence.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SequenceName | The name of this revision numbering sequence.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | CreateAlphanumericSequence | Creates a new alphanumeric revision numbering sequence in the document.
 | CreateNumericSequence | Creates a new numeric revision numbering sequence in the document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
 | GetAllRevisionNumberingSequences | Gets all of the revision numbering sequences from the document.
Public method | GetAlphanumericRevisionSettings | Returns a copy of the AlphanumericRevisionSettings owned by this revision numbering sequence.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetNumericRevisionSettings | Returns a copy of the NumericRevisionSettings owned by this revision numbering sequence.
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasValidAlphanumericRevisionSettings | Checks whether the revision numbering sequence owns a valid alphanumeric revision settings.
Public method | HasValidNumericRevisionSettings | Checks whether the revision numbering sequence owns a valid numeric revision settings.
Public method | HasValidRevisionSettingsForNumberType | Checks whether the revision numbering sequence owns a valid revision settings for number type.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetAlphanumericRevisionSettings | Replaces the current alphanumeric revision numbering settings with the provided settings.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetNumericRevisionSettings | Replaces the current numeric revision numbering settings with the provided settings.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Revision numbering is numeric or alphanumeric. Revision numbering is assigned to Revisions to control the numbering scheme of that Revision.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RevisionNumberingSequence Properties

The RevisionNumberingSequence type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | NumberType | Indicates the revision number type of the revision numbering sequence.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SequenceName | The name of this revision numbering sequence.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

RevisionNumberingSequence Class


RevisionNumberingSequence.NumberType Property

RevisionNumberingSequenceNumberType Property

Indicates the revision number type of the revision numbering sequence.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RevisionNumberType NumberType { get; }
Public ReadOnly Property NumberType As RevisionNumberType
    Get
public:
property RevisionNumberType NumberType {
    RevisionNumberType get ();
}
member NumberType : RevisionNumberType with get

Property Value

RevisionNumberType
Exceptions
Exception | Condition
InvalidOperationException | This RevisionNumberingSequence doesn't own a valid revision settings for number type.
Remarks
This property can be used to figure out if a revision numbering sequence is numeric or alphanumeric. The returned RevisionNumberType is either RevisionNumberType::Numeric or RevisionNumberType::Alphanumeric.
See Also

Reference

RevisionNumberingSequence Class


RevisionNumberingSequence.SequenceName Property

RevisionNumberingSequenceSequenceName Property

The name of this revision numbering sequence.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SequenceName { get; set; }
Public Property SequenceName As String
    Get
    Set
public:
property String^ SequenceName {
    String^ get ();
    void set (String^ value);
}
member SequenceName : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentException | When setting this property: sequenceName is an empty string or contains only whitespace. -or- When setting this property: sequenceName cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~".
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
This name appears in the Sheet Issues/Revisions dialog as a numbering choice for each revision.
See Also

Reference

RevisionNumberingSequence Class


RevisionNumberingSequence Methods

The RevisionNumberingSequence type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | CreateAlphanumericSequence | Creates a new alphanumeric revision numbering sequence in the document.
 | CreateNumericSequence | Creates a new numeric revision numbering sequence in the document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
 | GetAllRevisionNumberingSequences | Gets all of the revision numbering sequences from the document.
Public method | GetAlphanumericRevisionSettings | Returns a copy of the AlphanumericRevisionSettings owned by this revision numbering sequence.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetNumericRevisionSettings | Returns a copy of the NumericRevisionSettings owned by this revision numbering sequence.
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasValidAlphanumericRevisionSettings | Checks whether the revision numbering sequence owns a valid alphanumeric revision settings.
Public method | HasValidNumericRevisionSettings | Checks whether the revision numbering sequence owns a valid numeric revision settings.
Public method | HasValidRevisionSettingsForNumberType | Checks whether the revision numbering sequence owns a valid revision settings for number type.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetAlphanumericRevisionSettings | Replaces the current alphanumeric revision numbering settings with the provided settings.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetNumericRevisionSettings | Replaces the current numeric revision numbering settings with the provided settings.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

RevisionNumberingSequence Class


RevisionNumberingSequence.CreateAlphanumericSequence Method

RevisionNumberingSequenceCreateAlphanumericSequence Method

Creates a new alphanumeric revision numbering sequence in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static RevisionNumberingSequence CreateAlphanumericSequence(
    Document document,
    string name,
    AlphanumericRevisionSettings settings
)
Public Shared Function CreateAlphanumericSequence (
    document As Document,
    name As String,
    settings As AlphanumericRevisionSettings
) As RevisionNumberingSequence
public:
static RevisionNumberingSequence^ CreateAlphanumericSequence(
    Document^ document,
    String^ name,
    AlphanumericRevisionSettings^ settings
)
static member CreateAlphanumericSequence :
        document : Document *
        name : string *
        settings : AlphanumericRevisionSettings -> RevisionNumberingSequence

Parameters

document Document
The document of the new revision numbering sequence.
name String
The name for the revision numbering sequence.
settings AlphanumericRevisionSettings
The alphanumeric settings for the revision numbering sequence.

Return Value

RevisionNumberingSequence
The newly created revision numbering sequence.
Exceptions
Exception | Condition
ArgumentException | document is not a project document. -or- name is an empty string or contains only whitespace. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- settings is not a valid AlphanumericRevisionSettings.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
The new revision numbering sequence will not be assigned to any revision. Use `Revision.SetRevisionNumberingSequenceId` to apply the sequence to a revision.
See Also

Reference

RevisionNumberingSequence Class


RevisionNumberingSequence.CreateNumericSequence Method

RevisionNumberingSequenceCreateNumericSequence Method

Creates a new numeric revision numbering sequence in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static RevisionNumberingSequence CreateNumericSequence(
    Document document,
    string name,
    NumericRevisionSettings settings
)
Public Shared Function CreateNumericSequence (
    document As Document,
    name As String,
    settings As NumericRevisionSettings
) As RevisionNumberingSequence
public:
static RevisionNumberingSequence^ CreateNumericSequence(
    Document^ document,
    String^ name,
    NumericRevisionSettings^ settings
)
static member CreateNumericSequence :
        document : Document *
        name : string *
        settings : NumericRevisionSettings -> RevisionNumberingSequence

Parameters

document Document
The document of the new revision numbering sequence.
name String
The name for the revision numbering sequence.
settings NumericRevisionSettings
The numeric settings for the revision numbering sequence.

Return Value

RevisionNumberingSequence
The newly created revision numbering sequence.
Exceptions
Exception | Condition
ArgumentException | document is not a project document. -or- name is an empty string or contains only whitespace. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- settings is not a valid NumericRevisionSettings.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
The new revision numbering sequence will not be assigned to any revision. Use `Revision.SetRevisionNumberingSequenceId` to apply the sequence to a revision.
See Also

Reference

RevisionNumberingSequence Class


RevisionNumberingSequence.GetAllRevisionNumberingSequences Method

RevisionNumberingSequenceGetAllRevisionNumberingSequences Method

Gets all of the revision numbering sequences from the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ISet<ElementId> GetAllRevisionNumberingSequences(
    Document document
)
Public Shared Function GetAllRevisionNumberingSequences (
    document As Document
) As ISet(Of ElementId)
public:
static ISet<ElementId^>^ GetAllRevisionNumberingSequences(
    Document^ document
)
static member GetAllRevisionNumberingSequences :
        document : Document -> ISet<ElementId>

Parameters

document Document
The document that contains the sequences.

Return Value

ISet ElementId
The revision numbering sequences from the document.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

RevisionNumberingSequence Class


RevisionNumberingSequence.GetAlphanumericRevisionSettings Method

RevisionNumberingSequenceGetAlphanumericRevisionSettings Method

Returns a copy of the AlphanumericRevisionSettings owned by this revision numbering sequence.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AlphanumericRevisionSettings GetAlphanumericRevisionSettings()
Public Function GetAlphanumericRevisionSettings As AlphanumericRevisionSettings
public:
AlphanumericRevisionSettings^ GetAlphanumericRevisionSettings()
member GetAlphanumericRevisionSettings : unit -> AlphanumericRevisionSettings

Return Value

AlphanumericRevisionSettings
The copy of the AlphaumericRevisionSettings owned by this revision numbering sequence.
Exceptions
Exception | Condition
InvalidOperationException | This RevisionNumberingSequence doesn't own a valid alphanumeric revision settings.
See Also

Reference

RevisionNumberingSequence Class


RevisionNumberingSequence.GetNumericRevisionSettings Method

RevisionNumberingSequenceGetNumericRevisionSettings Method

Returns a copy of the NumericRevisionSettings owned by this revision numbering sequence.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public NumericRevisionSettings GetNumericRevisionSettings()
Public Function GetNumericRevisionSettings As NumericRevisionSettings
public:
NumericRevisionSettings^ GetNumericRevisionSettings()
member GetNumericRevisionSettings : unit -> NumericRevisionSettings

Return Value

NumericRevisionSettings
The copy of the NumericRevisionSettings owned by this revision numbering sequence.
Exceptions
Exception | Condition
InvalidOperationException | This RevisionNumberingSequence doesn't own a valid numeric revision settings.
See Also

Reference

RevisionNumberingSequence Class


RevisionNumberingSequence.HasValidAlphanumericRevisionSettings Method

RevisionNumberingSequenceHasValidAlphanumericRevisionSettings Method

Checks whether the revision numbering sequence owns a valid alphanumeric revision settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasValidAlphanumericRevisionSettings()
Public Function HasValidAlphanumericRevisionSettings As Boolean
public:
bool HasValidAlphanumericRevisionSettings()
member HasValidAlphanumericRevisionSettings : unit -> bool

Return Value

Boolean
True if the revision numbering sequence owns a valid alphanumeric revision settings.
See Also

Reference

RevisionNumberingSequence Class


RevisionNumberingSequence.HasValidNumericRevisionSettings Method

RevisionNumberingSequenceHasValidNumericRevisionSettings Method

Checks whether the revision numbering sequence owns a valid numeric revision settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasValidNumericRevisionSettings()
Public Function HasValidNumericRevisionSettings As Boolean
public:
bool HasValidNumericRevisionSettings()
member HasValidNumericRevisionSettings : unit -> bool

Return Value

Boolean
True if the revision numbering sequence owns a valid numeric revision settings.
See Also

Reference

RevisionNumberingSequence Class


RevisionNumberingSequence.HasValidRevisionSettingsForNumberType Method

RevisionNumberingSequenceHasValidRevisionSettingsForNumberType Method

Checks whether the revision numbering sequence owns a valid revision settings for number type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasValidRevisionSettingsForNumberType()
Public Function HasValidRevisionSettingsForNumberType As Boolean
public:
bool HasValidRevisionSettingsForNumberType()
member HasValidRevisionSettingsForNumberType : unit -> bool

Return Value

Boolean
True if the revision numbering sequence owns a valid revision settings for number type.
See Also

Reference

RevisionNumberingSequence Class


RevisionNumberingSequence.SetAlphanumericRevisionSettings Method

RevisionNumberingSequenceSetAlphanumericRevisionSettings Method

Replaces the current alphanumeric revision numbering settings with the provided settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetAlphanumericRevisionSettings(
    AlphanumericRevisionSettings settings
)
Public Sub SetAlphanumericRevisionSettings (
    settings As AlphanumericRevisionSettings
)
public:
void SetAlphanumericRevisionSettings(
    AlphanumericRevisionSettings^ settings
)
member SetAlphanumericRevisionSettings :
        settings : AlphanumericRevisionSettings -> unit

Parameters

settings AlphanumericRevisionSettings
The AlphanumericRevisionSettings to be applied to alphanumeric revision numbering.
Exceptions
Exception | Condition
ArgumentException | settings is not a valid AlphanumericRevisionSettings.
ArgumentNullException | A non-optional argument was null
See Also

Reference

RevisionNumberingSequence Class


RevisionNumberingSequence.SetNumericRevisionSettings Method

RevisionNumberingSequenceSetNumericRevisionSettings Method

Replaces the current numeric revision numbering settings with the provided settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetNumericRevisionSettings(
    NumericRevisionSettings settings
)
Public Sub SetNumericRevisionSettings (
    settings As NumericRevisionSettings
)
public:
void SetNumericRevisionSettings(
    NumericRevisionSettings^ settings
)
member SetNumericRevisionSettings :
        settings : NumericRevisionSettings -> unit

Parameters

settings NumericRevisionSettings
The NumericRevisionSettings to be applied to numeric revision numbering.
Exceptions
Exception | Condition
ArgumentException | settings is not a valid NumericRevisionSettings.
ArgumentNullException | A non-optional argument was null
See Also

Reference

RevisionNumberingSequence Class


RevisionNumberType Enumeration

Determines how a particular revision will be numbered.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum RevisionNumberType
Public Enumeration RevisionNumberType
public enum class RevisionNumberType
type RevisionNumberType
Members
Member name | Value | Description
Numeric | 0 | The Revision Number will be a number.
None | 2 | No Revision Number will be assigned.
Alphanumeric | 3 | The Revision Number will be a string taken from a user-specified sequence of arbitrary strings.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RevisionSettings Class

Provides access to project-wide settings related to revisions.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBRevisionSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RevisionSettings : Element
Public Class RevisionSettings
    Inherits Element
public ref class RevisionSettings : public Element
type RevisionSettings =
    class
        inherit Element
    end

The RevisionSettings type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | RevisionCloudSpacing | Determines the size in paper space of revision clouds drawn in a project.
Public property | RevisionNumbering | Determines how the revision number values will display on sheets.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
 | GetRevisionSettings | Returns the RevisionSettings for the given project document.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsAcceptableRevisionCloudSpacing | Rounds the given raw value and checks whether it is an acceptable cloud spacing value after it is rounded.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
 | RoundRevisionCloudSpacing | Rounds the given revision cloud spacing value according to the document's settings.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This class provides access to the project-wide settings that affect the appearance and numbering of revisions and revision clouds. The settings are only available in project documents.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RevisionSettings Properties

The RevisionSettings type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | RevisionCloudSpacing | Determines the size in paper space of revision clouds drawn in a project.
Public property | RevisionNumbering | Determines how the revision number values will display on sheets.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

RevisionSettings Class


RevisionSettings.RevisionCloudSpacing Property

RevisionSettingsRevisionCloudSpacing Property

Determines the size in paper space of revision clouds drawn in a project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double RevisionCloudSpacing { get; set; }
Public Property RevisionCloudSpacing As Double
    Get
    Set
public:
property double RevisionCloudSpacing {
    double get ();
    void set (double value);
}
member RevisionCloudSpacing : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentException | When setting this property: desiredCloudSpacing is not a valid value for the cloud spacing.
Remarks
Revision clouds in Revit are created based on a collection of sketched lines. Revit then generates a series of "cloud bumps" along those lines to create a cloud shape. This setting determines the minimum length between the start and end each "cloud bump" (measured along the line). For example, if this setting were 2" and the sketched line were 3" long, Revit would create only one 3" bump. If the line length was increased to 4", Revit would add two 2" ones. Note that a single "cloud bump" consists of two arcs of slightly different size. Revit will always draw at least one "cloud bump" for each sketched line.

This value will be interpreted by Revit in paper space rather than in model space so that all of the clouds are shown in a uniform way on a sheet.

This value will be rounded to a length that can be displayed according to the current project settings. The value may not be zero after rounding. This value may not exceed the maximum distance that can be represented as a length in Revit.

See Also

Reference

RevisionSettings Class


RevisionSettings.RevisionNumbering Property

RevisionSettingsRevisionNumbering Property

Determines how the revision number values will display on sheets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RevisionNumbering RevisionNumbering { get; set; }
Public Property RevisionNumbering As RevisionNumbering
    Get
    Set
public:
property RevisionNumbering RevisionNumbering {
    RevisionNumbering get ();
    void set (RevisionNumbering value);
}
member RevisionNumbering : RevisionNumbering with get, set

Property Value

RevisionNumbering
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
When revision clouds appear on a sheet, the revision number of each revision can be displayed either by tagging the revision cloud or by a revision schedule within the sheet's titleblock. There are two ways the number can be determined:
  • Per project: The value of the Revision numbers will always correspond to the project-wide Revision Sequence Number assigned to the revision. For example, if revision clouds for revisions with sequence numbers 5, 7, and 8 are placed on a sheet then revision tags and schedules on that sheet would display 5, 7, and 8.
  • Per sheet: Revision numbers will be assigned consecutive numbers based on the revision clouds visible on that sheet. For example, if revision clouds for revisions assigned project-wide Revision Sequence Numbers 5, 7, and 8 are placed on a sheet then revision tags and schedules on that sheet would display 1, 2, and 3. The sequence on the sheet will still follow the relative ordering of the Revision Sequence Numbers, so in this example revision 5 would be displayed as 1 on the sheet, revision 7 would be displayed as 2, etc.

Note that changing this setting may change the numbering of revisions on any existing sheets. The numbering will be changed even for revisions that are already issued.

See Also

Reference

RevisionSettings Class


RevisionSettings Methods

The RevisionSettings type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
 | GetRevisionSettings | Returns the RevisionSettings for the given project document.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsAcceptableRevisionCloudSpacing | Rounds the given raw value and checks whether it is an acceptable cloud spacing value after it is rounded.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
 | RoundRevisionCloudSpacing | Rounds the given revision cloud spacing value according to the document's settings.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

RevisionSettings Class


RevisionSettings.GetRevisionSettings Method

RevisionSettingsGetRevisionSettings Method

Returns the RevisionSettings for the given project document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static RevisionSettings GetRevisionSettings(
    Document ccda
)
Public Shared Function GetRevisionSettings (
    ccda As Document
) As RevisionSettings
public:
static RevisionSettings^ GetRevisionSettings(
    Document^ ccda
)
static member GetRevisionSettings :
        ccda : Document -> RevisionSettings

Parameters

ccda Document
The document to get the RevisionSettings from.

Return Value

RevisionSettings
The RevisionSettings for the document.
Exceptions
Exception | Condition
ArgumentException | ccda is not a project document.
ArgumentNullException | A non-optional argument was null
See Also

Reference

RevisionSettings Class


RevisionSettings.IsAcceptableRevisionCloudSpacing Method

RevisionSettingsIsAcceptableRevisionCloudSpacing Method

Rounds the given raw value and checks whether it is an acceptable cloud spacing value after it is rounded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsAcceptableRevisionCloudSpacing(
    double rawValue
)
Public Function IsAcceptableRevisionCloudSpacing (
    rawValue As Double
) As Boolean
public:
bool IsAcceptableRevisionCloudSpacing(
    double rawValue
)
member IsAcceptableRevisionCloudSpacing :
        rawValue : float -> bool

Parameters

rawValue Double
The raw value to check. This value need not be rounded prior to calling this function.

Return Value

Boolean
True if the value will be acceptable after rounding, False otherwise
Remarks
After rounding, the value must be a valid length that is greater than zero.
See Also

Reference

RevisionSettings Class


RevisionSettings.RoundRevisionCloudSpacing Method

RevisionSettingsRoundRevisionCloudSpacing Method

Rounds the given revision cloud spacing value according to the document's settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static double RoundRevisionCloudSpacing(
    Document ccda,
    double rawValue
)
Public Shared Function RoundRevisionCloudSpacing (
    ccda As Document,
    rawValue As Double
) As Double
public:
static double RoundRevisionCloudSpacing(
    Document^ ccda,
    double rawValue
)
static member RoundRevisionCloudSpacing :
        ccda : Document *
        rawValue : float -> float

Parameters

ccda Document
The document to use for rounding.
rawValue Double
The unrounded value.

Return Value

Double
The rounded revision cloud spacing.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

RevisionSettings Class


RevisionVisibility Enumeration

Determines whether Revision Clouds and Revision Tags will be visible in the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum RevisionVisibility
Public Enumeration RevisionVisibility
public enum class RevisionVisibility
type RevisionVisibility
Members
Member name | Value | Description
Hidden | 0 | Revision Clouds and Revision Tags will not be visible in the project.
CloudAndTagVisible | 1 | Revision Clouds and Revision Tags will be visible in the project.
TagVisible | 2 | Revision Tags will be visible in the project but Revision Clouds will not be.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RevitLinkGraphicsSettings Class

Settings to override display of Revit link in a view.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRevitLinkGraphicsSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RevitLinkGraphicsSettings : IDisposable
Public Class RevitLinkGraphicsSettings
    Implements IDisposable
public ref class RevitLinkGraphicsSettings : IDisposable
type RevitLinkGraphicsSettings =
    class
        interface IDisposable
    end

The RevitLinkGraphicsSettings type exposes the following members.

Constructors
 | Name | Description
Public method | RevitLinkGraphicsSettings | Creates a new RevitLinkGraphicsSettings instance.
Top
Properties
 | Name | Description
Public property | ColorFill | The color fill of RevitLinkGraphicsSettings. The color fill can be set to ByHostView or ByLinkView. Only a view that supports color fill can have this property set to ByLinkView. To check if the view supports the color fill use SupportedColorFillCategoryIds to see if there is any supported color fill category for the view. The LinkedViewId parameter must have a value assigned if this property is set to ByLinkView.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LinkedViewId | The id of the linked view associated with this RevitLinkGraphicsSettings, or InvalidElementId if no view is selected. If the LinkVisibilityType is set to ByLinkView, then there must be a valid LinkedViewId.
Public property | LinkVisibilityType | The visibility type of RevitLinkGraphicsSettings. If the type is set to ByHostView or ByLinkView, then the dependent properties of RevitLinkGraphicsSettings will be reset to their default state. The state of dependent properties can be changed later.
Public property | NestedLinks | The nested links of RevitLinkGraphicsSettings. The nested links can be set to ByHostView or ByLinkView.
Public property | ObjectStyles | The object styles of RevitLinkGraphicsSettings. The object styles can be set to ByHostView or ByLinkView.
Public property | ViewFilterType | The view filter type of RevitLinkGraphicsSettings. If the LinkVisibilityType is set to ByHostView, then the view filter type should be set to ByHostView. If the LinkVisibilityType is set to ByLinkView, then the view filter type should be set to ByLinkView. If the LinkVisibilityType is set to Custom, then the view filter type can be set to any value from LinkVisibility enum. The LinkedViewId parameter must have a value assigned if this property is set to ByLinkView. The Custom value corresponds to None option in the UI.
Public property | ViewRange | The view range of RevitLinkGraphicsSettings. The view range can be set to ByHostView or ByLinkView. Only a view that supports view range can have this property set to ByLinkView. To check if the view supports the view range use [!:Autodesk::Revit::DB::LinkVisibility::IsViewRangeSupported(Autodesk::Revit::DB::LinkVisibility)]. The LinkedViewId parameter must have a value assigned if this property is set to ByLinkView.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the RevitLinkGraphicsSettings
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetDiscipline | The linked document discipline of RevitLinkGraphicsSettings.
Public method | GetDisciplineType | The discipline type of RevitLinkGraphicsSettings.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetPhaseFilterId | The linked document phase filter id of RevitLinkGraphicsSettings, or InvalidElementId if there is no phase filter explicitly assigned.
Public method | GetPhaseFilterType | The phase filter type of RevitLinkGraphicsSettings.
Public method | GetPhaseId | The linked document phase id of RevitLinkGraphicsSettings, or InvalidElementId if there is no phase explicitly assigned.
Public method | GetPhaseType | The phase type of RevitLinkGraphicsSettings.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetViewDetailLevel | The linked document view detail level of RevitLinkGraphicsSettings.
Public method | GetViewDetailLevelType | The view detail level type of RevitLinkGraphicsSettings.
 | IsViewRangeSupported | Returns true if the input view supports ViewRange settings of RevitLinkGraphicsSettings, false otherwise.
Public method | SetDiscipline | Sets discipline and discipline type of RevitLinkGraphicsSettings.
Public method | SetPhase | Sets phase id and phase type of RevitLinkGraphicsSettings.
Public method | SetPhaseFilter | Sets phase filter id and phase filter type of RevitLinkGraphicsSettings.
Public method | SetViewDetailLevel | Sets view detail level and detail level type of RevitLinkGraphicsSettings.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RevitLinkGraphicsSettings Constructor

Creates a new RevitLinkGraphicsSettings instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RevitLinkGraphicsSettings()
Public Sub New
public:
RevitLinkGraphicsSettings()
new : unit -> RevitLinkGraphicsSettings
See Also

Reference

RevitLinkGraphicsSettings Class


RevitLinkGraphicsSettings Properties

The RevitLinkGraphicsSettings type exposes the following members.

Properties
 | Name | Description
Public property | ColorFill | The color fill of RevitLinkGraphicsSettings. The color fill can be set to ByHostView or ByLinkView. Only a view that supports color fill can have this property set to ByLinkView. To check if the view supports the color fill use SupportedColorFillCategoryIds to see if there is any supported color fill category for the view. The LinkedViewId parameter must have a value assigned if this property is set to ByLinkView.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LinkedViewId | The id of the linked view associated with this RevitLinkGraphicsSettings, or InvalidElementId if no view is selected. If the LinkVisibilityType is set to ByLinkView, then there must be a valid LinkedViewId.
Public property | LinkVisibilityType | The visibility type of RevitLinkGraphicsSettings. If the type is set to ByHostView or ByLinkView, then the dependent properties of RevitLinkGraphicsSettings will be reset to their default state. The state of dependent properties can be changed later.
Public property | NestedLinks | The nested links of RevitLinkGraphicsSettings. The nested links can be set to ByHostView or ByLinkView.
Public property | ObjectStyles | The object styles of RevitLinkGraphicsSettings. The object styles can be set to ByHostView or ByLinkView.
Public property | ViewFilterType | The view filter type of RevitLinkGraphicsSettings. If the LinkVisibilityType is set to ByHostView, then the view filter type should be set to ByHostView. If the LinkVisibilityType is set to ByLinkView, then the view filter type should be set to ByLinkView. If the LinkVisibilityType is set to Custom, then the view filter type can be set to any value from LinkVisibility enum. The LinkedViewId parameter must have a value assigned if this property is set to ByLinkView. The Custom value corresponds to None option in the UI.
Public property | ViewRange | The view range of RevitLinkGraphicsSettings. The view range can be set to ByHostView or ByLinkView. Only a view that supports view range can have this property set to ByLinkView. To check if the view supports the view range use [!:Autodesk::Revit::DB::LinkVisibility::IsViewRangeSupported(Autodesk::Revit::DB::LinkVisibility)]. The LinkedViewId parameter must have a value assigned if this property is set to ByLinkView.
Top
See Also

Reference

RevitLinkGraphicsSettings Class


RevitLinkGraphicsSettings.ColorFill Property

RevitLinkGraphicsSettingsColorFill Property

The color fill of RevitLinkGraphicsSettings. The color fill can be set to ByHostView or ByLinkView. Only a view that supports color fill can have this property set to ByLinkView. To check if the view supports the color fill use SupportedColorFillCategoryIds to see if there is any supported color fill category for the view. The LinkedViewId parameter must have a value assigned if this property is set to ByLinkView.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LinkVisibility ColorFill { get; set; }
Public Property ColorFill As LinkVisibility
    Get
    Set
public:
property LinkVisibility ColorFill {
    LinkVisibility get ();
    void set (LinkVisibility value);
}
member ColorFill : LinkVisibility with get, set

Property Value

LinkVisibility
Exceptions
Exception | Condition
ArgumentException | When setting this property: Disallowed LinkVisibility value.
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

RevitLinkGraphicsSettings Class


RevitLinkGraphicsSettings.IsValidObject Property

RevitLinkGraphicsSettingsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

RevitLinkGraphicsSettings Class


RevitLinkGraphicsSettings.LinkedViewId Property

RevitLinkGraphicsSettingsLinkedViewId Property

The id of the linked view associated with this RevitLinkGraphicsSettings, or InvalidElementId if no view is selected. If the LinkVisibilityType is set to ByLinkView, then there must be a valid LinkedViewId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId LinkedViewId { get; set; }
Public Property LinkedViewId As ElementId
    Get
    Set
public:
property ElementId^ LinkedViewId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member LinkedViewId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

RevitLinkGraphicsSettings Class


RevitLinkGraphicsSettings.LinkVisibilityType Property

RevitLinkGraphicsSettingsLinkVisibilityType Property

The visibility type of RevitLinkGraphicsSettings. If the type is set to ByHostView or ByLinkView, then the dependent properties of RevitLinkGraphicsSettings will be reset to their default state. The state of dependent properties can be changed later.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LinkVisibility LinkVisibilityType { get; set; }
Public Property LinkVisibilityType As LinkVisibility
    Get
    Set
public:
property LinkVisibility LinkVisibilityType {
    LinkVisibility get ();
    void set (LinkVisibility value);
}
member LinkVisibilityType : LinkVisibility with get, set

Property Value

LinkVisibility
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

RevitLinkGraphicsSettings Class


RevitLinkGraphicsSettings.NestedLinks Property

RevitLinkGraphicsSettingsNestedLinks Property

The nested links of RevitLinkGraphicsSettings. The nested links can be set to ByHostView or ByLinkView.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LinkVisibility NestedLinks { get; set; }
Public Property NestedLinks As LinkVisibility
    Get
    Set
public:
property LinkVisibility NestedLinks {
    LinkVisibility get ();
    void set (LinkVisibility value);
}
member NestedLinks : LinkVisibility with get, set

Property Value

LinkVisibility
Exceptions
Exception | Condition
ArgumentException | When setting this property: Disallowed LinkVisibility value.
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

RevitLinkGraphicsSettings Class


RevitLinkGraphicsSettings.ObjectStyles Property

RevitLinkGraphicsSettingsObjectStyles Property

The object styles of RevitLinkGraphicsSettings. The object styles can be set to ByHostView or ByLinkView.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LinkVisibility ObjectStyles { get; set; }
Public Property ObjectStyles As LinkVisibility
    Get
    Set
public:
property LinkVisibility ObjectStyles {
    LinkVisibility get ();
    void set (LinkVisibility value);
}
member ObjectStyles : LinkVisibility with get, set

Property Value

LinkVisibility
Exceptions
Exception | Condition
ArgumentException | When setting this property: Disallowed LinkVisibility value.
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

RevitLinkGraphicsSettings Class


RevitLinkGraphicsSettings.ViewFilterType Property

RevitLinkGraphicsSettingsViewFilterType Property

The view filter type of RevitLinkGraphicsSettings. If the LinkVisibilityType is set to ByHostView, then the view filter type should be set to ByHostView. If the LinkVisibilityType is set to ByLinkView, then the view filter type should be set to ByLinkView. If the LinkVisibilityType is set to Custom, then the view filter type can be set to any value from LinkVisibility enum. The LinkedViewId parameter must have a value assigned if this property is set to ByLinkView. The Custom value corresponds to None option in the UI.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LinkVisibility ViewFilterType { get; set; }
Public Property ViewFilterType As LinkVisibility
    Get
    Set
public:
property LinkVisibility ViewFilterType {
    LinkVisibility get ();
    void set (LinkVisibility value);
}
member ViewFilterType : LinkVisibility with get, set

Property Value

LinkVisibility
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

RevitLinkGraphicsSettings Class


RevitLinkGraphicsSettings.ViewRange Property

RevitLinkGraphicsSettingsViewRange Property

The view range of RevitLinkGraphicsSettings. The view range can be set to ByHostView or ByLinkView. Only a view that supports view range can have this property set to ByLinkView. To check if the view supports the view range use [!:Autodesk::Revit::DB::LinkVisibility::IsViewRangeSupported(Autodesk::Revit::DB::LinkVisibility)]. The LinkedViewId parameter must have a value assigned if this property is set to ByLinkView.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LinkVisibility ViewRange { get; set; }
Public Property ViewRange As LinkVisibility
    Get
    Set
public:
property LinkVisibility ViewRange {
    LinkVisibility get ();
    void set (LinkVisibility value);
}
member ViewRange : LinkVisibility with get, set

Property Value

LinkVisibility
Exceptions
Exception | Condition
ArgumentException | When setting this property: Disallowed LinkVisibility value.
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

RevitLinkGraphicsSettings Class


RevitLinkGraphicsSettings Methods

The RevitLinkGraphicsSettings type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetDiscipline | The linked document discipline of RevitLinkGraphicsSettings.
Public method | GetDisciplineType | The discipline type of RevitLinkGraphicsSettings.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetPhaseFilterId | The linked document phase filter id of RevitLinkGraphicsSettings, or InvalidElementId if there is no phase filter explicitly assigned.
Public method | GetPhaseFilterType | The phase filter type of RevitLinkGraphicsSettings.
Public method | GetPhaseId | The linked document phase id of RevitLinkGraphicsSettings, or InvalidElementId if there is no phase explicitly assigned.
Public method | GetPhaseType | The phase type of RevitLinkGraphicsSettings.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetViewDetailLevel | The linked document view detail level of RevitLinkGraphicsSettings.
Public method | GetViewDetailLevelType | The view detail level type of RevitLinkGraphicsSettings.
 | IsViewRangeSupported | Returns true if the input view supports ViewRange settings of RevitLinkGraphicsSettings, false otherwise.
Public method | SetDiscipline | Sets discipline and discipline type of RevitLinkGraphicsSettings.
Public method | SetPhase | Sets phase id and phase type of RevitLinkGraphicsSettings.
Public method | SetPhaseFilter | Sets phase filter id and phase filter type of RevitLinkGraphicsSettings.
Public method | SetViewDetailLevel | Sets view detail level and detail level type of RevitLinkGraphicsSettings.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

RevitLinkGraphicsSettings Class


RevitLinkGraphicsSettings.Dispose Method

RevitLinkGraphicsSettingsDispose Method

Releases all resources used by the RevitLinkGraphicsSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

RevitLinkGraphicsSettings Class


RevitLinkGraphicsSettings.GetDiscipline Method

RevitLinkGraphicsSettingsGetDiscipline Method

The linked document discipline of RevitLinkGraphicsSettings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ViewDiscipline GetDiscipline()
Public Function GetDiscipline As ViewDiscipline
public:
ViewDiscipline GetDiscipline()
member GetDiscipline : unit -> ViewDiscipline

Return Value

ViewDiscipline
See Also

Reference

RevitLinkGraphicsSettings Class


RevitLinkGraphicsSettings.GetDisciplineType Method

RevitLinkGraphicsSettingsGetDisciplineType Method

The discipline type of RevitLinkGraphicsSettings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LinkVisibility GetDisciplineType()
Public Function GetDisciplineType As LinkVisibility
public:
LinkVisibility GetDisciplineType()
member GetDisciplineType : unit -> LinkVisibility

Return Value

LinkVisibility
See Also

Reference

RevitLinkGraphicsSettings Class


RevitLinkGraphicsSettings.GetPhaseFilterId Method

RevitLinkGraphicsSettingsGetPhaseFilterId Method

The linked document phase filter id of RevitLinkGraphicsSettings, or InvalidElementId if there is no phase filter explicitly assigned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GetPhaseFilterId()
Public Function GetPhaseFilterId As ElementId
public:
ElementId^ GetPhaseFilterId()
member GetPhaseFilterId : unit -> ElementId

Return Value

ElementId
See Also

Reference

RevitLinkGraphicsSettings Class


RevitLinkGraphicsSettings.GetPhaseFilterType Method

RevitLinkGraphicsSettingsGetPhaseFilterType Method

The phase filter type of RevitLinkGraphicsSettings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LinkVisibility GetPhaseFilterType()
Public Function GetPhaseFilterType As LinkVisibility
public:
LinkVisibility GetPhaseFilterType()
member GetPhaseFilterType : unit -> LinkVisibility

Return Value

LinkVisibility
See Also

Reference

RevitLinkGraphicsSettings Class


RevitLinkGraphicsSettings.GetPhaseId Method

RevitLinkGraphicsSettingsGetPhaseId Method

The linked document phase id of RevitLinkGraphicsSettings, or InvalidElementId if there is no phase explicitly assigned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GetPhaseId()
Public Function GetPhaseId As ElementId
public:
ElementId^ GetPhaseId()
member GetPhaseId : unit -> ElementId

Return Value

ElementId
See Also

Reference

RevitLinkGraphicsSettings Class


RevitLinkGraphicsSettings.GetPhaseType Method

RevitLinkGraphicsSettingsGetPhaseType Method

The phase type of RevitLinkGraphicsSettings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LinkVisibility GetPhaseType()
Public Function GetPhaseType As LinkVisibility
public:
LinkVisibility GetPhaseType()
member GetPhaseType : unit -> LinkVisibility

Return Value

LinkVisibility
See Also

Reference

RevitLinkGraphicsSettings Class


RevitLinkGraphicsSettings.GetViewDetailLevel Method

RevitLinkGraphicsSettingsGetViewDetailLevel Method

The linked document view detail level of RevitLinkGraphicsSettings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ViewDetailLevel GetViewDetailLevel()
Public Function GetViewDetailLevel As ViewDetailLevel
public:
ViewDetailLevel GetViewDetailLevel()
member GetViewDetailLevel : unit -> ViewDetailLevel

Return Value

ViewDetailLevel
See Also

Reference

RevitLinkGraphicsSettings Class


RevitLinkGraphicsSettings.GetViewDetailLevelType Method

RevitLinkGraphicsSettingsGetViewDetailLevelType Method

The view detail level type of RevitLinkGraphicsSettings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LinkVisibility GetViewDetailLevelType()
Public Function GetViewDetailLevelType As LinkVisibility
public:
LinkVisibility GetViewDetailLevelType()
member GetViewDetailLevelType : unit -> LinkVisibility

Return Value

LinkVisibility
See Also

Reference

RevitLinkGraphicsSettings Class


RevitLinkGraphicsSettings.IsViewRangeSupported Method

RevitLinkGraphicsSettingsIsViewRangeSupported Method

Returns true if the input view supports ViewRange settings of RevitLinkGraphicsSettings, false otherwise.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsViewRangeSupported(
    View view
)
Public Shared Function IsViewRangeSupported (
    view As View
) As Boolean
public:
static bool IsViewRangeSupported(
    View^ view
)
static member IsViewRangeSupported :
        view : View -> bool

Parameters

view View

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

RevitLinkGraphicsSettings Class


RevitLinkGraphicsSettings.SetDiscipline Method

RevitLinkGraphicsSettingsSetDiscipline Method

Sets discipline and discipline type of RevitLinkGraphicsSettings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetDiscipline(
    LinkVisibility disciplineType,
    ViewDiscipline discipline
)
Public Sub SetDiscipline (
    disciplineType As LinkVisibility,
    discipline As ViewDiscipline
)
public:
void SetDiscipline(
    LinkVisibility disciplineType,
    ViewDiscipline discipline
)
member SetDiscipline :
        disciplineType : LinkVisibility *
        discipline : ViewDiscipline -> unit

Parameters

disciplineType LinkVisibility
The type of the discipline.
discipline ViewDiscipline
The discipline. If disciplineType is set to ByHostView or ByLinkView the discipline must be set to Architectural.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

RevitLinkGraphicsSettings Class


RevitLinkGraphicsSettings.SetPhase Method

RevitLinkGraphicsSettingsSetPhase Method

Sets phase id and phase type of RevitLinkGraphicsSettings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetPhase(
    LinkVisibility phaseType,
    ElementId phaseId
)
Public Sub SetPhase (
    phaseType As LinkVisibility,
    phaseId As ElementId
)
public:
void SetPhase(
    LinkVisibility phaseType,
    ElementId^ phaseId
)
member SetPhase :
        phaseType : LinkVisibility *
        phaseId : ElementId -> unit

Parameters

phaseType LinkVisibility
The type of the phase.
phaseId ElementId
The id of the phase from the linked document or InvalidElementId. If phaseType is set to ByHostView or ByLinkView the phaseId must be set to InvalidElementId. If phaseType is set to Custom and phaseId is InvalidElementId the phase will reference to the last phase from the linked document.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

RevitLinkGraphicsSettings Class


RevitLinkGraphicsSettings.SetPhaseFilter Method

RevitLinkGraphicsSettingsSetPhaseFilter Method

Sets phase filter id and phase filter type of RevitLinkGraphicsSettings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetPhaseFilter(
    LinkVisibility phaseFilterType,
    ElementId phaseFilterId
)
Public Sub SetPhaseFilter (
    phaseFilterType As LinkVisibility,
    phaseFilterId As ElementId
)
public:
void SetPhaseFilter(
    LinkVisibility phaseFilterType,
    ElementId^ phaseFilterId
)
member SetPhaseFilter :
        phaseFilterType : LinkVisibility *
        phaseFilterId : ElementId -> unit

Parameters

phaseFilterType LinkVisibility
The type of the phase filter.
phaseFilterId ElementId
The id of the phase filter from the linked document or InvalidElementId. If phaseFilterType is set to ByHostView or ByLinkView the phaseFilterId must be set to InvalidElementId. If phaseFilterType is set to Custom and phaseFilterId is InvalidElementId the state of the phase filter will correspond to the None option in the UI.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

RevitLinkGraphicsSettings Class


RevitLinkGraphicsSettings.SetViewDetailLevel Method

RevitLinkGraphicsSettingsSetViewDetailLevel Method

Sets view detail level and detail level type of RevitLinkGraphicsSettings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetViewDetailLevel(
    LinkVisibility viewDetailLevelType,
    ViewDetailLevel viewDetailLevel
)
Public Sub SetViewDetailLevel (
    viewDetailLevelType As LinkVisibility,
    viewDetailLevel As ViewDetailLevel
)
public:
void SetViewDetailLevel(
    LinkVisibility viewDetailLevelType,
    ViewDetailLevel viewDetailLevel
)
member SetViewDetailLevel :
        viewDetailLevelType : LinkVisibility *
        viewDetailLevel : ViewDetailLevel -> unit

Parameters

viewDetailLevelType LinkVisibility
The type of the view detail level.
viewDetailLevel ViewDetailLevel
The view detail level. If viewDetailLevelType is set to ByHostView or ByLinkView the viewDetailLevel must be set to Undefined.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

RevitLinkGraphicsSettings Class


RevitLinkInstance Class

Represents an instance of a RevitLinkType.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBInstance
Autodesk.Revit.DBRevitLinkInstance

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RevitLinkInstance : Instance
Public Class RevitLinkInstance
    Inherits Instance
public ref class RevitLinkInstance : public Instance
type RevitLinkInstance =
    class
        inherit Instance
    end

The RevitLinkInstance type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
Name | Description
Public method ArePhasesModifiable Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element.
(Inherited from Element)
Public method CanBeHidden Indicates if the element can be hidden in the view.
(Inherited from Element)
Public method CanBeLocked Identifies if the element can be locked.
(Inherited from Element)
Public method CanDeleteSubelement Checks if given subelement can be removed from the element.
(Inherited from Element)
Public method CanHaveTypeAssigned Identifies if the element can have a type assigned.
(Inherited from Element)
Public method ChangeTypeId(ElementId) Changes the type of the element.
(Inherited from Element)
Create(Document, ElementId) | Creates a new instance of a linked Revit project (RevitLinkType).
Create(Document, ElementId, ImportPlacement) | Creates a new instance of a linked Revit project (RevitLinkType).
Public method DeleteEntity Deletes the existing entity created by %schema% in the element
(Inherited from Element)
Public method DeleteSubelement Removes a subelement from the element.
(Inherited from Element)
Public method DeleteSubelements Removes the subelements from the element.
(Inherited from Element)
Public method Dispose
(Inherited from Element)
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object)
Public method EvaluateAllParameterValues Evaluates all the parameters' values of the element.
(Inherited from Element)
Public method EvaluateParameterValues Evaluate the parameters' values of the element on the given parameter ID set.
(Inherited from Element)
Public method GetDependentElements Get all elements that, from a logical point of view, are the children of this Element.
(Inherited from Element)
Public method GetEntity Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise.
(Inherited from Element)
Public method GetEntitySchemaGuids Returns the Schema guids of any Entities stored in this element.
(Inherited from Element)
Public method GetExternalFileReference Gets information pertaining to the external file referenced by the element.
(Inherited from Element)
Public method GetExternalResourceReference Gets the ExternalResourceReference associated with a specified external resource type.
(Inherited from Element)
Public method GetExternalResourceReferenceExpanded Gets the collection of ExternalResourceReference associated with a specified external resource type.
(Inherited from Element)
Public method GetExternalResourceReferences Gets the map of the external resource references referenced by the element.
(Inherited from Element)
Public method GetExternalResourceReferencesExpanded Gets the expanded map of the external resource references referenced by the element.
(Inherited from Element)
GetGeneratingElementIds Returns the ids of the element(s) that generated the input geometry object.
(Inherited from Element)
Public method GetGeometryObjectFromReference Retrieve one geometric primitive contained in the element given a reference.
(Inherited from Element)
Public method GetHashCode Serves as the default hash function.
(Inherited from Object)
Public method | GetLinkDocument | The document associated with the Revit link.
Public method GetMaterialArea Gets the area of the material with the given id.
(Inherited from Element)
Public method GetMaterialIds Gets the element ids of all materials present in the element.
(Inherited from Element)
Public method GetMaterialVolume Gets the volume of the material with the given id.
(Inherited from Element)
Public method GetMonitoredLinkElementIds Provides the link instance IDs when the element is monitoring.
(Inherited from Element)
Public method GetMonitoredLocalElementIds Provides the local element IDs when the element is monitoring.
(Inherited from Element)
Public method GetOrderedParameters Gets the parameters associated to the element in order.
(Inherited from Element)
Public method GetParameter Retrieves a parameter from the element given identifier.
(Inherited from Element)
Public method GetParameterFormatOptions Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists.
(Inherited from Element)
Public method GetParameters Retrieves the parameters from the element via the given name.
(Inherited from Element)
Public method GetPhaseStatus Gets the status of a given element in the input phase
(Inherited from Element)
Public method GetSubelements Returns the collection of element subelements.
(Inherited from Element)
Public method GetTotalTransform Gets the total transform, which includes the true north transform for instances like import instances.
(Inherited from Instance)
Public method GetTransform Gets the transform of the instance.
(Inherited from Instance)
Public method GetType Gets the Type of the current instance.
(Inherited from Object)
GetTypeId Returns the identifier of this element's type.
(Inherited from Element)
Public method GetValidTypes Obtains a set of types that are valid for this element.
(Inherited from Element)
Public method HasPhases Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.
(Inherited from Element)
Public method IsCreatedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element)
Public method IsDemolishedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element)
Public method IsExternalFileReference Determines whether this Element represents an external file.
(Inherited from Element)
Public method IsHidden Identifies if the element has been permanently hidden in the view.
(Inherited from Element)
Public method IsMonitoringLinkElement Indicate whether an element is monitoring any elements in any linked models.
(Inherited from Element)
Public method IsMonitoringLocalElement Indicate whether an element is monitoring other local elements.
(Inherited from Element)
Public method IsPhaseCreatedValid Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element.
(Inherited from Element)
Public method IsPhaseDemolishedValid Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element.
(Inherited from Element)
Public method IsValidType(ElementId) Checks if given type is valid for this element.
(Inherited from Element)
Public method LookupParameter Attempts to find a parameter on the element which has the given name.
(Inherited from Element)
Public method MoveBasePointToHostBasePoint

Moves this link instance so that the base point in the linked document is aligned to the base point in the host document. This is a one-time movement and does not set up any shared coordinates relationship.

If the rotation angle of this link instance was changed after insertion, the rotation angle can be preserved or reset to the original insertion angle.

Public method MoveOriginToHostOrigin

Moves this link instance so that the internal origin of the linked document is aligned to the internal origin of the host document. This is a one-time movement and does not set up any shared coordinates relationship.

If the rotation angle of the link instance was changed after insertion, the rotation angle can be preserved or reset to the original insertion angle.

Public method RefersToExternalResourceReference Determines whether this Element uses external resources associated with a specified external resource type.
(Inherited from Element)
Public method RefersToExternalResourceReferences Determines whether this Element uses external resources.
(Inherited from Element)
Public method SetEntity Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten.
(Inherited from Element)
Public method ToString Returns a string that represents the current object.
(Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RevitLinkInstance Properties

The RevitLinkInstance type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

RevitLinkInstance Class


RevitLinkInstance Methods

The RevitLinkInstance type exposes the following members.

Methods
Name | Description
Public method ArePhasesModifiable Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element.
(Inherited from Element)
Public method CanBeHidden Indicates if the element can be hidden in the view.
(Inherited from Element)
Public method CanBeLocked Identifies if the element can be locked.
(Inherited from Element)
Public method CanDeleteSubelement Checks if given subelement can be removed from the element.
(Inherited from Element)
Public method CanHaveTypeAssigned Identifies if the element can have a type assigned.
(Inherited from Element)
Public method ChangeTypeId(ElementId) Changes the type of the element.
(Inherited from Element)
Create(Document, ElementId) | Creates a new instance of a linked Revit project (RevitLinkType).
Create(Document, ElementId, ImportPlacement) | Creates a new instance of a linked Revit project (RevitLinkType).
Public method DeleteEntity Deletes the existing entity created by %schema% in the element
(Inherited from Element)
Public method DeleteSubelement Removes a subelement from the element.
(Inherited from Element)
Public method DeleteSubelements Removes the subelements from the element.
(Inherited from Element)
Public method Dispose
(Inherited from Element)
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object)
Public method EvaluateAllParameterValues Evaluates all the parameters' values of the element.
(Inherited from Element)
Public method EvaluateParameterValues Evaluate the parameters' values of the element on the given parameter ID set.
(Inherited from Element)
Public method GetDependentElements Get all elements that, from a logical point of view, are the children of this Element.
(Inherited from Element)
Public method GetEntity Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise.
(Inherited from Element)
Public method GetEntitySchemaGuids Returns the Schema guids of any Entities stored in this element.
(Inherited from Element)
Public method GetExternalFileReference Gets information pertaining to the external file referenced by the element.
(Inherited from Element)
Public method GetExternalResourceReference Gets the ExternalResourceReference associated with a specified external resource type.
(Inherited from Element)
Public method GetExternalResourceReferenceExpanded Gets the collection of ExternalResourceReference associated with a specified external resource type.
(Inherited from Element)
Public method GetExternalResourceReferences Gets the map of the external resource references referenced by the element.
(Inherited from Element)
Public method GetExternalResourceReferencesExpanded Gets the expanded map of the external resource references referenced by the element.
(Inherited from Element)
GetGeneratingElementIds Returns the ids of the element(s) that generated the input geometry object.
(Inherited from Element)
Public method GetGeometryObjectFromReference Retrieve one geometric primitive contained in the element given a reference.
(Inherited from Element)
Public method GetHashCode Serves as the default hash function.
(Inherited from Object)
Public method | GetLinkDocument | The document associated with the Revit link.
Public method GetMaterialArea Gets the area of the material with the given id.
(Inherited from Element)
Public method GetMaterialIds Gets the element ids of all materials present in the element.
(Inherited from Element)
Public method GetMaterialVolume Gets the volume of the material with the given id.
(Inherited from Element)
Public method GetMonitoredLinkElementIds Provides the link instance IDs when the element is monitoring.
(Inherited from Element)
Public method GetMonitoredLocalElementIds Provides the local element IDs when the element is monitoring.
(Inherited from Element)
Public method GetOrderedParameters Gets the parameters associated to the element in order.
(Inherited from Element)
Public method GetParameter Retrieves a parameter from the element given identifier.
(Inherited from Element)
Public method GetParameterFormatOptions Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists.
(Inherited from Element)
Public method GetParameters Retrieves the parameters from the element via the given name.
(Inherited from Element)
Public method GetPhaseStatus Gets the status of a given element in the input phase
(Inherited from Element)
Public method GetSubelements Returns the collection of element subelements.
(Inherited from Element)
Public method GetTotalTransform Gets the total transform, which includes the true north transform for instances like import instances.
(Inherited from Instance)
Public method GetTransform Gets the transform of the instance.
(Inherited from Instance)
Public method GetType Gets the Type of the current instance.
(Inherited from Object)
GetTypeId Returns the identifier of this element's type.
(Inherited from Element)
Public method GetValidTypes Obtains a set of types that are valid for this element.
(Inherited from Element)
Public method HasPhases Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.
(Inherited from Element)
Public method IsCreatedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element)
Public method IsDemolishedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element)
Public method IsExternalFileReference Determines whether this Element represents an external file.
(Inherited from Element)
Public method IsHidden Identifies if the element has been permanently hidden in the view.
(Inherited from Element)
Public method IsMonitoringLinkElement Indicate whether an element is monitoring any elements in any linked models.
(Inherited from Element)
Public method IsMonitoringLocalElement Indicate whether an element is monitoring other local elements.
(Inherited from Element)
Public method IsPhaseCreatedValid Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element.
(Inherited from Element)
Public method IsPhaseDemolishedValid Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element.
(Inherited from Element)
Public method IsValidType(ElementId) Checks if given type is valid for this element.
(Inherited from Element)
Public method LookupParameter Attempts to find a parameter on the element which has the given name.
(Inherited from Element)
Public method MoveBasePointToHostBasePoint

Moves this link instance so that the base point in the linked document is aligned to the base point in the host document. This is a one-time movement and does not set up any shared coordinates relationship.

If the rotation angle of this link instance was changed after insertion, the rotation angle can be preserved or reset to the original insertion angle.

Public method MoveOriginToHostOrigin

Moves this link instance so that the internal origin of the linked document is aligned to the internal origin of the host document. This is a one-time movement and does not set up any shared coordinates relationship.

If the rotation angle of the link instance was changed after insertion, the rotation angle can be preserved or reset to the original insertion angle.

Public method RefersToExternalResourceReference Determines whether this Element uses external resources associated with a specified external resource type.
(Inherited from Element)
Public method RefersToExternalResourceReferences Determines whether this Element uses external resources.
(Inherited from Element)
Public method SetEntity Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten.
(Inherited from Element)
Public method ToString Returns a string that represents the current object.
(Inherited from Object)
Top
See Also

Reference

RevitLinkInstance Class


RevitLinkInstance.Create Method

RevitLinkInstanceCreate Method

Overload List
Name | Description
Create(Document, ElementId) | Creates a new instance of a linked Revit project (RevitLinkType).
Create(Document, ElementId, ImportPlacement) | Creates a new instance of a linked Revit project (RevitLinkType).
Top
See Also

Reference

RevitLinkInstance Class


RevitLinkInstance.Create(Document, ElementId) Method

RevitLinkInstanceCreate(Document, ElementId) Method

Creates a new instance of a linked Revit project (RevitLinkType).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static RevitLinkInstance Create(
    Document document,
    ElementId revitLinkTypeId
)
Public Shared Function Create (
    document As Document,
    revitLinkTypeId As ElementId
) As RevitLinkInstance
public:
static RevitLinkInstance^ Create(
    Document^ document,
    ElementId^ revitLinkTypeId
)
static member Create :
        document : Document *
        revitLinkTypeId : ElementId -> RevitLinkInstance

Parameters

document Document
The document in which the new instance should be created.
revitLinkTypeId ElementId
The element id of the RevitLinkType.

Return Value

RevitLinkInstance
The newly-created RevitLinkInstance.
Exceptions
Exception | Condition
ArgumentException | revitLinkTypeId isn't a RevitLinkType. -or- revitLinkTypeId is not a top-level link. -or- revitLinkTypeId is not a loaded RevitLinkType -or- document is not a project document.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
Instances will be placed origin-to-origin. This function cannot be used to create instances of nested links.
Example
C#
VB
C++
F#
Copy
public void CreateLinkInstances(Document doc, ElementId linkTypeId)
{
    // Create revit link instance at origin
    RevitLinkInstance.Create(doc, linkTypeId);
    RevitLinkInstance instance2 = RevitLinkInstance.Create(doc, linkTypeId);
    Location location = instance2.Location;
    // Create a second instance of the link and offset it by 100 feet.
    location.Move(new XYZ(0, -100, 0));
}
Public Sub CreateLinkInstances(doc As Document, linkTypeId As ElementId)
   ' Create revit link instance at origin
   RevitLinkInstance.Create(doc, linkTypeId)
   Dim instance2 As RevitLinkInstance = RevitLinkInstance.Create(doc, linkTypeId)
   Dim location As Location = instance2.Location
   ' Create a second instance of the link and offset it by 100 feet.
   location.Move(New XYZ(0, -100, 0))
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

RevitLinkInstance Class
Create Overload


RevitLinkInstance.Create(Document, ElementId, ImportPlacement) Method

RevitLinkInstanceCreate(Document, ElementId, ImportPlacement) Method

Creates a new instance of a linked Revit project (RevitLinkType).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static RevitLinkInstance Create(
    Document document,
    ElementId revitLinkTypeId,
    ImportPlacement placement
)
Public Shared Function Create (
    document As Document,
    revitLinkTypeId As ElementId,
    placement As ImportPlacement
) As RevitLinkInstance
public:
static RevitLinkInstance^ Create(
    Document^ document,
    ElementId^ revitLinkTypeId,
    ImportPlacement placement
)
static member Create :
        document : Document *
        revitLinkTypeId : ElementId *
        placement : ImportPlacement -> RevitLinkInstance

Parameters

document Document
The document in which the new instance should be created.
revitLinkTypeId ElementId
The element id of the RevitLinkType.
placement ImportPlacement
The mode where to place the RevitLinkInstance. Set this option to place the view at the origin or by shared coordinates.

Return Value

RevitLinkInstance
The newly-created RevitLinkInstance.
Exceptions
Exception | Condition
ArgumentException | revitLinkTypeId isn't a RevitLinkType. -or- revitLinkTypeId is not a top-level link. -or- revitLinkTypeId is not a loaded RevitLinkType -or- document is not a project document. -or- placement isn't supported.Only Origin or Shared placement is supported.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | The placement is Shared, and the host model and the link do not share the same coordinate system. Or the placement is Shared, and the shared coordinates of the host model do not match the GIS coordinate system of the linked file.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
Instances will be placed origin-to-origin or by shared coordinates. This function cannot be used to create instances of nested links.
See Also

Reference

RevitLinkInstance Class
Create Overload


RevitLinkInstance.GetLinkDocument Method

RevitLinkInstanceGetLinkDocument Method

The document associated with the Revit link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Document GetLinkDocument()
Public Function GetLinkDocument As Document
public:
Document^ GetLinkDocument()
member GetLinkDocument : unit -> Document

Return Value

Document
Remarks
Operations that require a transaction or modify the document's status in memory (such as Save and Close) cannot be performed on this document.
See Also

Reference

RevitLinkInstance Class


RevitLinkInstance.MoveBasePointToHostBasePoint Method

RevitLinkInstanceMoveBasePointToHostBasePoint Method

Moves this link instance so that the base point in the linked document is aligned to the base point in the host document. This is a one-time movement and does not set up any shared coordinates relationship.

If the rotation angle of this link instance was changed after insertion, the rotation angle can be preserved or reset to the original insertion angle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void MoveBasePointToHostBasePoint(
    bool resetToOriginalRotation
)
Public Sub MoveBasePointToHostBasePoint (
    resetToOriginalRotation As Boolean
)
public:
void MoveBasePointToHostBasePoint(
    bool resetToOriginalRotation
)
member MoveBasePointToHostBasePoint :
        resetToOriginalRotation : bool -> unit

Parameters

resetToOriginalRotation Boolean

Sets to true if:

  • restoring the original insertion angle of the link instance after it is moved if there was a rotation \ mirror transform on the link instance.
  • there was no a rotation \ mirror transform on the link instance.

Sets to false to retain the current angle of the link instance after it is moved if there was a rotation \ mirror transform on the link instance.

Exceptions
Exception | Condition
InvalidOperationException | This RevitLinkInstance is not an instance of a loaded RevitLinkType. -or- This RevitLinkInstance is not an instance of a top-level RevitLinkType. -or- The operation is not permitted because the element is pinned.
Remarks
The link must be loaded for Revit to find the location of the link's base point. This operation can only be performed on instances of top-level links.
See Also

Reference

RevitLinkInstance Class


RevitLinkInstance.MoveOriginToHostOrigin Method

RevitLinkInstanceMoveOriginToHostOrigin Method

Moves this link instance so that the internal origin of the linked document is aligned to the internal origin of the host document. This is a one-time movement and does not set up any shared coordinates relationship.

If the rotation angle of the link instance was changed after insertion, the rotation angle can be preserved or reset to the original insertion angle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void MoveOriginToHostOrigin(
    bool resetToOriginalRotation
)
Public Sub MoveOriginToHostOrigin (
    resetToOriginalRotation As Boolean
)
public:
void MoveOriginToHostOrigin(
    bool resetToOriginalRotation
)
member MoveOriginToHostOrigin :
        resetToOriginalRotation : bool -> unit

Parameters

resetToOriginalRotation Boolean

Sets to true if:

  • restoring the original insertion angle of the link instance after it is moved if there was a rotation \ mirror transform on the link instance.
  • there was no a rotation \ mirror transform on the link instance.

Sets to false to retain the current angle of the link instance after it is moved if there was a rotation \ mirror transform on the link instance.

Exceptions
Exception | Condition
InvalidOperationException | This RevitLinkInstance is not an instance of a loaded RevitLinkType. -or- This RevitLinkInstance is not an instance of a top-level RevitLinkType. -or- The operation is not permitted because the element is pinned.
Remarks
This operation can only be performed on instances of top-level links. The internal origin is not necessarily the same location as the Project Base Point. See MoveBasePointToHostBasePoint(Boolean).
See Also

Reference

RevitLinkInstance Class


RevitLinkOperations Class

This class is used to extend the IExternalResourceServer interface with methods to support operations specifically related to Revit links.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBLinkOperations
Autodesk.Revit.DBRevitLinkOperations

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RevitLinkOperations : LinkOperations
Public Class RevitLinkOperations
    Inherits LinkOperations
public ref class RevitLinkOperations : public LinkOperations
type RevitLinkOperations =
    class
        inherit LinkOperations
    end

The RevitLinkOperations type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from LinkOperations)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from LinkOperations)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetGetLocalPathForOpenCallback | Sets the IGetLocalPathForOpenCallback that will support the "Open (and Unload)" command for Revit links obtained from an IExternalResourceServer.
Public method | SetOnLocalLinkSharedCoordinatesSavedCallback | Sets the callback that will be called when the Revit user saves new shared coordinate settings to a linked document obtained from an IExternalResourceServer. (Inherited from LinkOperations)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

The class owns single-method interfaces which are used as callbacks to perform specific operations on Revit link external resources.

An empty RevitLinkOperations instance is passed to an IExternalResourceServer (inside an ExternalResourceServerExtensions object) via the GetTypeSpecificServerOperations method. The server provider can then add their own implemented interface objects to the RevitLinkOperations, thus making them available to Revit to use as callbacks.

Supporting these additional, type-specific operations is not absolutely required, but is strongly recommended in order for users to be able to perform all the same operations they would with locally-accessed Revit links.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RevitLinkOperations Properties

The RevitLinkOperations type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from LinkOperations)
Top
See Also

Reference

RevitLinkOperations Class


RevitLinkOperations Methods

The RevitLinkOperations type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from LinkOperations)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetGetLocalPathForOpenCallback | Sets the IGetLocalPathForOpenCallback that will support the "Open (and Unload)" command for Revit links obtained from an IExternalResourceServer.
Public method | SetOnLocalLinkSharedCoordinatesSavedCallback | Sets the callback that will be called when the Revit user saves new shared coordinate settings to a linked document obtained from an IExternalResourceServer. (Inherited from LinkOperations)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

RevitLinkOperations Class


RevitLinkOperations.SetGetLocalPathForOpenCallback Method

RevitLinkOperationsSetGetLocalPathForOpenCallback Method

Sets the IGetLocalPathForOpenCallback that will support the "Open (and Unload)" command for Revit links obtained from an IExternalResourceServer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetGetLocalPathForOpenCallback(
    IGetLocalPathForOpenCallback makeLocalCopyForOpen
)
Public Sub SetGetLocalPathForOpenCallback (
    makeLocalCopyForOpen As IGetLocalPathForOpenCallback
)
public:
void SetGetLocalPathForOpenCallback(
    IGetLocalPathForOpenCallback^ makeLocalCopyForOpen
)
member SetGetLocalPathForOpenCallback :
        makeLocalCopyForOpen : IGetLocalPathForOpenCallback -> unit

Parameters

makeLocalCopyForOpen IGetLocalPathForOpenCallback
The IGetLocalPathForOpenCallback that will support the "Open (and Unload)" command.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

RevitLinkOperations Class


RevitLinkOptions Class

This class contains the options in use when creating or loading a Revit link.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRevitLinkOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RevitLinkOptions : IDisposable
Public Class RevitLinkOptions
    Implements IDisposable
public ref class RevitLinkOptions : IDisposable
type RevitLinkOptions =
    class
        interface IDisposable
    end

The RevitLinkOptions type exposes the following members.

Constructors
 | Name | Description
Public method | RevitLinkOptions(Boolean) | Creates a RevitLinkOptions object, specifying relative or absolute path type. If the link is workshared, all worksets will be opened.
Public method | RevitLinkOptions(RevitLinkOptions) | Constructs a new copy of the input RevitLinkOptions object.
Public method | RevitLinkOptions(Boolean, WorksetConfiguration) | Creates a RevitLinkOptions object, specifying relative or absolute path type, and the desired workset configuration.
Top
Properties
 | Name | Description
Public property | IsRelative | The type of path to use when creating the link. If true, Revit will store a relative path for the link. If false, Revit will store an absolute path. If the link is to a Revit Server location, isRelative must be false.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the RevitLinkOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetWorksetConfiguration | Gets the set of worksets to open when creating the link.
Public method | SetWorksetConfiguration | Sets the set of worksets to open when creating the link.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RevitLinkOptions Constructor

Overload List
 | Name | Description
Public method | RevitLinkOptions(Boolean) | Creates a RevitLinkOptions object, specifying relative or absolute path type. If the link is workshared, all worksets will be opened.
Public method | RevitLinkOptions(RevitLinkOptions) | Constructs a new copy of the input RevitLinkOptions object.
Public method | RevitLinkOptions(Boolean, WorksetConfiguration) | Creates a RevitLinkOptions object, specifying relative or absolute path type, and the desired workset configuration.
Top
See Also

Reference

RevitLinkOptions Class


RevitLinkOptions(Boolean) Constructor

Creates a RevitLinkOptions object, specifying relative or absolute path type. If the link is workshared, all worksets will be opened.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RevitLinkOptions(
    bool relative
)
Public Sub New (
    relative As Boolean
)
public:
RevitLinkOptions(
    bool relative
)
new :
        relative : bool -> RevitLinkOptions

Parameters

relative Boolean
True if the link should use a relative path. False if it should use an absolute path.
See Also

Reference

RevitLinkOptions Class
RevitLinkOptions Overload


RevitLinkOptions(RevitLinkOptions) Constructor

Constructs a new copy of the input RevitLinkOptions object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RevitLinkOptions(
    RevitLinkOptions other
)
Public Sub New (
    other As RevitLinkOptions
)
public:
RevitLinkOptions(
    RevitLinkOptions^ other
)
new :
        other : RevitLinkOptions -> RevitLinkOptions

Parameters

other RevitLinkOptions
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

RevitLinkOptions Class
RevitLinkOptions Overload


RevitLinkOptions(Boolean, WorksetConfiguration) Constructor

Creates a RevitLinkOptions object, specifying relative or absolute path type, and the desired workset configuration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RevitLinkOptions(
    bool relative,
    WorksetConfiguration config
)
Public Sub New (
    relative As Boolean,
    config As WorksetConfiguration
)
public:
RevitLinkOptions(
    bool relative,
    WorksetConfiguration^ config
)
new :
        relative : bool *
        config : WorksetConfiguration -> RevitLinkOptions

Parameters

relative Boolean
True if the link should use a relative path. False if it should use an absolute path.
config WorksetConfiguration
A WorksetConfiguration object specifying the worksets to open when creating the link. Leave as if the file is not workshared. Optionally, this may also be for a workshared file, in which case Revit will open all worksets.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

RevitLinkOptions Class
RevitLinkOptions Overload


RevitLinkOptions Properties

The RevitLinkOptions type exposes the following members.

Properties
 | Name | Description
Public property | IsRelative | The type of path to use when creating the link. If true, Revit will store a relative path for the link. If false, Revit will store an absolute path. If the link is to a Revit Server location, isRelative must be false.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

RevitLinkOptions Class


RevitLinkOptions.IsRelative Property

RevitLinkOptionsIsRelative Property

The type of path to use when creating the link. If true, Revit will store a relative path for the link. If false, Revit will store an absolute path. If the link is to a Revit Server location, isRelative must be false.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsRelative { get; set; }
Public Property IsRelative As Boolean
    Get
    Set
public:
property bool IsRelative {
    bool get ();
    void set (bool value);
}
member IsRelative : bool with get, set

Property Value

Boolean
See Also

Reference

RevitLinkOptions Class


RevitLinkOptions.IsValidObject Property

RevitLinkOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

RevitLinkOptions Class


RevitLinkOptions Methods

The RevitLinkOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetWorksetConfiguration | Gets the set of worksets to open when creating the link.
Public method | SetWorksetConfiguration | Sets the set of worksets to open when creating the link.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

RevitLinkOptions Class


RevitLinkOptions.Dispose Method

RevitLinkOptionsDispose Method

Releases all resources used by the RevitLinkOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

RevitLinkOptions Class


RevitLinkOptions.GetWorksetConfiguration Method

RevitLinkOptionsGetWorksetConfiguration Method

Gets the set of worksets to open when creating the link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WorksetConfiguration GetWorksetConfiguration()
Public Function GetWorksetConfiguration As WorksetConfiguration
public:
WorksetConfiguration^ GetWorksetConfiguration()
member GetWorksetConfiguration : unit -> WorksetConfiguration

Return Value

WorksetConfiguration
Example
C#
VB
C++
F#
Copy
public bool CreateRevitLinkWithOneWorksetOpen(Document doc, string pathName, string worksetName)
{
    FilePath path = new FilePath(pathName);
    RevitLinkOptions options = new RevitLinkOptions(true);

    // Get info on all the user worksets in the project prior to opening
    IList<WorksetPreview> worksets = WorksharingUtils.GetUserWorksetInfo(path);
    IList<WorksetId> worksetIds = new List<WorksetId>();
    // Find worksetName
    foreach (WorksetPreview worksetPrev in worksets)
    {
        if (worksetPrev.Name.CompareTo(worksetName) == 0)
        {
            worksetIds.Add(worksetPrev.Id);
            break;
        }
    }

    // close all worksets but the one specified
    WorksetConfiguration worksetConfig = new WorksetConfiguration(WorksetConfigurationOption.CloseAllWorksets);
    if (worksetIds.Count > 0)
    {
        worksetConfig.Open(worksetIds);
    }
    options.SetWorksetConfiguration(worksetConfig);

    LinkLoadResult result = RevitLinkType.Create(doc, path, options);
    RevitLinkType type = doc.GetElement(result.ElementId) as RevitLinkType;
    return (result.LoadResult == LinkLoadResultType.LinkLoaded);
}
Public Function CreateRevitLinkWithOneWorksetOpen(doc As Document, pathName As String, worksetName As String) As Boolean
   Dim path As New FilePath(pathName)
   Dim options As New RevitLinkOptions(True)

   ' Get info on all the user worksets in the project prior to opening
   Dim worksets As IList(Of WorksetPreview) = WorksharingUtils.GetUserWorksetInfo(path)
   Dim worksetIds As IList(Of WorksetId) = New List(Of WorksetId)()
   ' Find worksetName
   For Each worksetPrev As WorksetPreview In worksets
      If worksetPrev.Name.CompareTo(worksetName) = 0 Then
         worksetIds.Add(worksetPrev.Id)
         Exit For
      End If
   Next

   ' close all worksets but the one specified
   Dim worksetConfig As New WorksetConfiguration(WorksetConfigurationOption.CloseAllWorksets)
   If worksetIds.Count > 0 Then
      worksetConfig.Open(worksetIds)
   End If
   options.SetWorksetConfiguration(worksetConfig)

   Dim result As LinkLoadResult = RevitLinkType.Create(doc, path, options)
   Dim type As RevitLinkType = TryCast(doc.GetElement(result.ElementId), RevitLinkType)
   Return (result.LoadResult = LinkLoadResultType.LinkLoaded)
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

RevitLinkOptions Class


RevitLinkOptions.SetWorksetConfiguration Method

RevitLinkOptionsSetWorksetConfiguration Method

Sets the set of worksets to open when creating the link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetWorksetConfiguration(
    WorksetConfiguration config
)
Public Sub SetWorksetConfiguration (
    config As WorksetConfiguration
)
public:
void SetWorksetConfiguration(
    WorksetConfiguration^ config
)
member SetWorksetConfiguration :
        config : WorksetConfiguration -> unit

Parameters

config WorksetConfiguration
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

RevitLinkOptions Class


RevitLinkType Class

This class represents another Revit Document ("link") brought into the current one ("host").
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBRevitLinkType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RevitLinkType : ElementType
Public Class RevitLinkType
    Inherits ElementType
public ref class RevitLinkType : public ElementType
type RevitLinkType =
    class
        inherit ElementType
    end

The RevitLinkType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | AttachmentType | The attachment/overlay status of this link.
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsNestedLink | Indicates whether this link is a nested or top-level link.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LocallyUnloaded | Checks whether a Revit link in a local model is unloaded only for the current user.
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | PathType | The type of path the link uses.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create(Document, ExternalResourceReference, RevitLinkOptions) | Creates a new Revit link type from an external resource reference and loads the linked document.
 | Create(Document, ModelPath, RevitLinkOptions) | Creates a new Revit link type and loads the linked document.
 | CreateFromIFC(Document, ExternalResourceReference, String, Boolean, RevitLinkOptions) | Creates a new Revit link type from an existing Revit file created via import by reference of an asscoiated IFC file.
 | CreateFromIFC(Document, String, String, Boolean, RevitLinkOptions) | Creates a new Revit link type from an existing Revit file created via import by reference of an asscoiated IFC file.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetChildIds | Gets the ids of the immediate children of this link.
Public method | GetConversionData | Returns the optional data that is necessary to generate the Revit file for this link.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLinkedFileStatus | Returns the LinkedFileStatus of this link.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetParentId | Gets the id of this link's immediate parent.
Public method | GetPhaseMap | Returns a mapping between phases in the host document and phases in the linked document.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetRootId | Gets the id of the top-level link which this link is linked into.
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
 | GetTopLevelLink(Document, ExternalResourceReference) | Returns the ElementId of the (top-level) linked model with the given ExternalResourceReference.
 | GetTopLevelLink(Document, ModelPath) | Returns the ElementId of the (top-level) linked model with the given path.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasSaveablePositions | Determines whether the link has changes to shared positioning that could be saved.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsFromLocalPath | Checks whether the Revit link uses a local path, such as a hard drive.
Public method | IsFromRevitServer | Checks whether the Revit link is located on Revit Server.
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
 | IsLoaded | Checks whether the link with this id is loaded.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsNotLoadedIntoMultipleOpenDocuments | Checks whether the link is loaded into more than one open document in this session of Revit. If the link is loaded into multiple open documents, reload will be disabled.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | Load | Loads or reloads the Revit link from its currently-stored location. If the link is an external resource, Revit will contact the IExternalResourceServer to get the latest version of the link.
Public method | LoadFrom(ExternalResourceReference, WorksetConfiguration) | Loads or reloads the Revit link. The link will be loaded from the location given in the input ExternalResourceReference.
Public method | LoadFrom(ModelPath, WorksetConfiguration) | Loads or reloads the Revit link from disk or cloud. The link will be loaded from the input path.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | Reload | Loads or reloads the Revit link from its currently-stored location. If the link is an external resource, Revit will contact the IExternalResourceServer to get the latest version of the link.
Public method | RevertLocalUnloadStatus | Restores the workshared load status of a link that has been unloaded only for the current user, in a local copy of a workshared model.
Public method | SavePositions | Saves shared coordinates changes back to the linked document.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | Unload | Unloads the Revit link.
Public method | UnloadLocally | Unloads a Revit link for the current user only.
Public method | UpdateFromIFC(Document, ExternalResourceReference, String, Boolean) | Updates a Revit link type from an IFC file and loads the linked document.
Public method | UpdateFromIFC(Document, String, String, Boolean) | Updates a Revit link type from an IFC file and loads the linked document.
Top
Remarks
Revit links can be nested - There can exist linked files which themselves contain links. A "top-level" link is one linked directly into the host, while a "nested" link is linked into some parent link. This can go through arbitrarily many layers. Some functions give the example "A -> B -> C". This means that there is a host file, A, which has a top-level link, B, and a nested link C which has been linked into B as an attachment.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RevitLinkType Properties

The RevitLinkType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | AttachmentType | The attachment/overlay status of this link.
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsNestedLink | Indicates whether this link is a nested or top-level link.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LocallyUnloaded | Checks whether a Revit link in a local model is unloaded only for the current user.
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | PathType | The type of path the link uses.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

RevitLinkType Class


RevitLinkType.AttachmentType Property

RevitLinkTypeAttachmentType Property

The attachment/overlay status of this link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AttachmentType AttachmentType { get; set; }
Public Property AttachmentType As AttachmentType
    Get
    Set
public:
property AttachmentType AttachmentType {
    AttachmentType get ();
    void set (AttachmentType value);
}
member AttachmentType : AttachmentType with get, set

Property Value

AttachmentType
AttachmentType.Overlay if this link is an overlay, AttachmentType.Attachment if this link is an attachment.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | When setting this property: This RevitLinkType is not a top-level link.
Remarks

"Attachment" links are considered to be part of their parent link and will be brought along if their parent is linked into another document. "Overlay" links are only visible when their parent is open directly.

For example: A user has a file B which contains a link C, and they wish to link B into another file, A. If C is an overlay, C will not be loaded into A. If C is an attachment, then C will be loaded into A along with B.
See Also

Reference

RevitLinkType Class


RevitLinkType.IsNestedLink Property

RevitLinkTypeIsNestedLink Property

Indicates whether this link is a nested or top-level link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsNestedLink { get; }
Public ReadOnly Property IsNestedLink As Boolean
    Get
public:
property bool IsNestedLink {
    bool get ();
}
member IsNestedLink : bool with get

Property Value

Boolean
See Also

Reference

RevitLinkType Class


RevitLinkType.LocallyUnloaded Property

RevitLinkTypeLocallyUnloaded Property

Checks whether a Revit link in a local model is unloaded only for the current user.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool LocallyUnloaded { get; }
Public ReadOnly Property LocallyUnloaded As Boolean
    Get
public:
property bool LocallyUnloaded {
    bool get ();
}
member LocallyUnloaded : bool with get

Property Value

Boolean
Remarks
Revit links can be unloaded for both the current user and for all users. If a Revit link is in a non-workshared file or in central model, this property is false.
See Also

Reference

RevitLinkType Class


RevitLinkType.PathType Property

RevitLinkTypePathType Property

The type of path the link uses.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PathType PathType { get; set; }
Public Property PathType As PathType
    Get
    Set
public:
property PathType PathType {
    PathType get ();
    void set (PathType value);
}
member PathType : PathType with get, set

Property Value

PathType
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | The PathType of the Revit link cannot be determined (or set), because it was not loaded from a local disk drive or from Revit Server. -or- When setting this property: The PathType for the link is not valid. PathType.Content is never valid for a Revit link. To change the type to or from PathType.Server, use RevitLinkType.LoadFrom and pick a server or file path.
Remarks

You cannot change the PathType to or from PathType.Server. The path type will change automatically if you call RevitLinkType.LoadFrom with a Revit Server path.

Links from external resource servers are considered to have no path type. Attempts to access this property for an external server link will result in an exception.

See Also

Reference

RevitLinkType Class


RevitLinkType Methods

The RevitLinkType type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create(Document, ExternalResourceReference, RevitLinkOptions) | Creates a new Revit link type from an external resource reference and loads the linked document.
 | Create(Document, ModelPath, RevitLinkOptions) | Creates a new Revit link type and loads the linked document.
 | CreateFromIFC(Document, ExternalResourceReference, String, Boolean, RevitLinkOptions) | Creates a new Revit link type from an existing Revit file created via import by reference of an asscoiated IFC file.
 | CreateFromIFC(Document, String, String, Boolean, RevitLinkOptions) | Creates a new Revit link type from an existing Revit file created via import by reference of an asscoiated IFC file.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetChildIds | Gets the ids of the immediate children of this link.
Public method | GetConversionData | Returns the optional data that is necessary to generate the Revit file for this link.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLinkedFileStatus | Returns the LinkedFileStatus of this link.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetParentId | Gets the id of this link's immediate parent.
Public method | GetPhaseMap | Returns a mapping between phases in the host document and phases in the linked document.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetRootId | Gets the id of the top-level link which this link is linked into.
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
 | GetTopLevelLink(Document, ExternalResourceReference) | Returns the ElementId of the (top-level) linked model with the given ExternalResourceReference.
 | GetTopLevelLink(Document, ModelPath) | Returns the ElementId of the (top-level) linked model with the given path.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasSaveablePositions | Determines whether the link has changes to shared positioning that could be saved.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsFromLocalPath | Checks whether the Revit link uses a local path, such as a hard drive.
Public method | IsFromRevitServer | Checks whether the Revit link is located on Revit Server.
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
 | IsLoaded | Checks whether the link with this id is loaded.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsNotLoadedIntoMultipleOpenDocuments | Checks whether the link is loaded into more than one open document in this session of Revit. If the link is loaded into multiple open documents, reload will be disabled.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | Load | Loads or reloads the Revit link from its currently-stored location. If the link is an external resource, Revit will contact the IExternalResourceServer to get the latest version of the link.
Public method | LoadFrom(ExternalResourceReference, WorksetConfiguration) | Loads or reloads the Revit link. The link will be loaded from the location given in the input ExternalResourceReference.
Public method | LoadFrom(ModelPath, WorksetConfiguration) | Loads or reloads the Revit link from disk or cloud. The link will be loaded from the input path.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | Reload | Loads or reloads the Revit link from its currently-stored location. If the link is an external resource, Revit will contact the IExternalResourceServer to get the latest version of the link.
Public method | RevertLocalUnloadStatus | Restores the workshared load status of a link that has been unloaded only for the current user, in a local copy of a workshared model.
Public method | SavePositions | Saves shared coordinates changes back to the linked document.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | Unload | Unloads the Revit link.
Public method | UnloadLocally | Unloads a Revit link for the current user only.
Public method | UpdateFromIFC(Document, ExternalResourceReference, String, Boolean) | Updates a Revit link type from an IFC file and loads the linked document.
Public method | UpdateFromIFC(Document, String, String, Boolean) | Updates a Revit link type from an IFC file and loads the linked document.
Top
See Also

Reference

RevitLinkType Class


RevitLinkType.Create Method

RevitLinkTypeCreate Method

Overload List
Name | Description
Create(Document, ExternalResourceReference, RevitLinkOptions) | Creates a new Revit link type from an external resource reference and loads the linked document.
Create(Document, ModelPath, RevitLinkOptions) | Creates a new Revit link type and loads the linked document.
Top
See Also

Reference

RevitLinkType Class


RevitLinkType.Create(Document, ExternalResourceReference, RevitLinkOptions) Method

RevitLinkTypeCreate(Document, ExternalResourceReference, RevitLinkOptions) Method

Creates a new Revit link type from an external resource reference and loads the linked document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static LinkLoadResult Create(
    Document document,
    ExternalResourceReference resourceReference,
    RevitLinkOptions options
)
Public Shared Function Create (
    document As Document,
    resourceReference As ExternalResourceReference,
    options As RevitLinkOptions
) As LinkLoadResult
public:
static LinkLoadResult^ Create(
    Document^ document,
    ExternalResourceReference^ resourceReference,
    RevitLinkOptions^ options
)
static member Create :
        document : Document *
        resourceReference : ExternalResourceReference *
        options : RevitLinkOptions -> LinkLoadResult

Parameters

document Document
The document in which to create the Revit link.
resourceReference ExternalResourceReference
An external resource reference describing the source of the linked Revit document.
options RevitLinkOptions
An options class for loading Revit links. The path type information will be ignored.

Return Value

LinkLoadResult
An object containing the results of creating and loading the Revit link type. It contains the ElementId of the new link.
Exceptions
Exception | Condition
ArgumentException | document is not a project document. -or- The server referenced by the ExternalResourceReference does not exist or does not implement IExternalResourceServer. -or- The server referenced by the ExternalResourceReference cannot support Revit links. -or- The ExternalResourceReference (resourceReference) is not in a format that is supported by its server. -or- The link type referred to by the ExternalResourceReference "resourceReference" already exists in the document. You cannot create another copy of the link type. You can create instances with RevitLinkInstance.Create(), or reload the link using RevitLinkType.Reload().
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Revit cannot customize worksets for this model.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks

This function regenerates the input document.

Only the WorksetConfiguration information in the options argument will be used. The path type information will be ignored.

See Also

Reference

RevitLinkType Class
Create Overload


RevitLinkType.Create(Document, ModelPath, RevitLinkOptions) Method

RevitLinkTypeCreate(Document, ModelPath, RevitLinkOptions) Method

Creates a new Revit link type and loads the linked document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static LinkLoadResult Create(
    Document document,
    ModelPath path,
    RevitLinkOptions options
)
Public Shared Function Create (
    document As Document,
    path As ModelPath,
    options As RevitLinkOptions
) As LinkLoadResult
public:
static LinkLoadResult^ Create(
    Document^ document,
    ModelPath^ path,
    RevitLinkOptions^ options
)
static member Create :
        document : Document *
        path : ModelPath *
        options : RevitLinkOptions -> LinkLoadResult

Parameters

document Document
The document in which to create the Revit link.
path ModelPath
The path of the link to load. This may be a path of local disk, Revit Server or Cloud. This must be a full path.
options RevitLinkOptions
An options class for loading Revit links.

Return Value

LinkLoadResult
An object containing the results of creating and loading the Revit link type. It contains the ElementId of the new link.
Exceptions
Exception | Condition
ArgumentException | document is not a project document. -or- Server paths cannot be relative. -or- document already contains a linked model at path path. -or- The path to be linked in is empty. -or- The input path "path" does not represent a Revit model.
ArgumentNullException | A non-optional argument was null
FileAccessException | The model cannot be accessed due to lack of access privileges.
FileNotFoundException | The path to be linked in doesn't exist.
InvalidOperationException | The model is not allowed to access. -or- Revit cannot customize worksets for this model. -or- Revit cannot link a cloud model to non-cloud model.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
RevitServerInternalException | Could be for any of the reasons that failed on service side.
RevitServerUnauthenticatedUserException | User is not signed in with Autodesk id.
RevitServerUnauthorizedException | User is not authorized to access the specified cloud model.
Remarks
This function regenerates the input document. While the options argument allows specification of a path type, the input path argument must be a full path. Relative vs. absolute determines how Revit will store the path, but it needs a complete path to find the linked document initially.
Example
C#
VB
C++
F#
Copy
public ElementId CreateRevitLink(Document doc, string pathName)
{
    FilePath path = new FilePath(pathName);
    RevitLinkOptions options = new RevitLinkOptions(false);
    // Create new revit link storing absolute path to a file
    LinkLoadResult result = RevitLinkType.Create(doc, path, options);
    return (result.ElementId);
}
Public Function CreateRevitLink(doc As Document, pathName As String) As ElementId
   Dim path As New FilePath(pathName)
   Dim options As New RevitLinkOptions(False)
   ' Create new revit link storing absolute path to a file
   Dim result As LinkLoadResult = RevitLinkType.Create(doc, path, options)
   Return (result.ElementId)
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

RevitLinkType Class
Create Overload


RevitLinkType.CreateFromIFC Method

RevitLinkTypeCreateFromIFC Method

Overload List
Name | Description
CreateFromIFC(Document, ExternalResourceReference, String, Boolean, RevitLinkOptions) | Creates a new Revit link type from an existing Revit file created via import by reference of an asscoiated IFC file.
CreateFromIFC(Document, String, String, Boolean, RevitLinkOptions) | Creates a new Revit link type from an existing Revit file created via import by reference of an asscoiated IFC file.
Top
See Also

Reference

RevitLinkType Class


RevitLinkType.CreateFromIFC(Document, ExternalResourceReference, String, Boolean, RevitLinkOptions) Method

RevitLinkTypeCreateFromIFC(Document, ExternalResourceReference, String, Boolean, RevitLinkOptions) Method

Creates a new Revit link type from an existing Revit file created via import by reference of an asscoiated IFC file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static LinkLoadResult CreateFromIFC(
    Document document,
    ExternalResourceReference resourceReference,
    string revitLinkedFilePath,
    bool recreateLink,
    RevitLinkOptions options
)
Public Shared Function CreateFromIFC (
    document As Document,
    resourceReference As ExternalResourceReference,
    revitLinkedFilePath As String,
    recreateLink As Boolean,
    options As RevitLinkOptions
) As LinkLoadResult
public:
static LinkLoadResult^ CreateFromIFC(
    Document^ document,
    ExternalResourceReference^ resourceReference,
    String^ revitLinkedFilePath,
    bool recreateLink,
    RevitLinkOptions^ options
)
static member CreateFromIFC :
        document : Document *
        resourceReference : ExternalResourceReference *
        revitLinkedFilePath : string *
        recreateLink : bool *
        options : RevitLinkOptions -> LinkLoadResult

Parameters

document Document
The document in which to create the Revit link.
resourceReference ExternalResourceReference
An external resource reference describing the source of the IFC file used in creation.
revitLinkedFilePath String
The path of the existing Revit file that contains elements created via an import by reference operation. This must be a full path.
recreateLink Boolean
If true, the existing Revit file created via an import by reference operation will be updated based on the information in the IFC file. If false, the existing Revit file will be used as-is.
options RevitLinkOptions
An options class for loading Revit links.

Return Value

LinkLoadResult
An object containing the results of creating and loading the Revit link type. It contains the ElementId of the new link.
Exceptions
Exception | Condition
ArgumentException | document is not a project document. -or- document already contains a linked model at path revitLinkedFilePath. -or- The server referenced by the ExternalResourceReference does not exist or does not implement IExternalResourceServer. -or- The server referenced by the ExternalResourceReference cannot support IFC links. -or- The ExternalResourceReference (resourceReference) is not in a format that is supported by its server.
ArgumentNullException | A non-optional argument was null
FileAccessException | The model cannot be accessed due to lack of access privileges.
FileArgumentNotFoundException | There is not a valid Revit file at revitLinkedFilePath's location
InvalidOperationException | The file is not allowed to access. -or- Revit cannot customize worksets for this model.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks

This function is one of a series of steps necessary for linking an IFC file. To understand how it is used in context, please download the IFC open source code, and look in the Revit.IFC.Import project at Importer.ImportIFC(ImporterIFC importer), under the IFCImportAction.Link branch.

This function regenerates the input document. While the options argument allows specification of a path type, the input path argument must be a full path. Relative vs. absolute determines how Revit will store the path, but it needs a complete path to find the linked document initially.
See Also

Reference

RevitLinkType Class
CreateFromIFC Overload


RevitLinkType.CreateFromIFC(Document, String, String, Boolean, RevitLinkOptions) Method

RevitLinkTypeCreateFromIFC(Document, String, String, Boolean, RevitLinkOptions) Method

Creates a new Revit link type from an existing Revit file created via import by reference of an asscoiated IFC file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static LinkLoadResult CreateFromIFC(
    Document document,
    string ifcFilePath,
    string revitLinkedFilePath,
    bool recreateLink,
    RevitLinkOptions options
)
Public Shared Function CreateFromIFC (
    document As Document,
    ifcFilePath As String,
    revitLinkedFilePath As String,
    recreateLink As Boolean,
    options As RevitLinkOptions
) As LinkLoadResult
public:
static LinkLoadResult^ CreateFromIFC(
    Document^ document,
    String^ ifcFilePath,
    String^ revitLinkedFilePath,
    bool recreateLink,
    RevitLinkOptions^ options
)
static member CreateFromIFC :
        document : Document *
        ifcFilePath : string *
        revitLinkedFilePath : string *
        recreateLink : bool *
        options : RevitLinkOptions -> LinkLoadResult

Parameters

document Document
The document in which to create the Revit link.
ifcFilePath String
The path of the associated IFC file. This must be a full path.
revitLinkedFilePath String
The path of the existing Revit file that contains elements created via an import by reference operation. This must be a full path.
recreateLink Boolean
If true, the existing Revit file created via an import by reference operation will be updated based on the information in the IFC file. If false, the existing Revit file will be used as-is.
options RevitLinkOptions
An options class for loading Revit links.

Return Value

LinkLoadResult
An object containing the results of creating and loading the Revit link type. It contains the ElementId of the new link.
Exceptions
Exception | Condition
ArgumentException | document is not a project document. -or- The input path "ifcFilePath" does not represent an IFC file. -or- document already contains a linked model at path revitLinkedFilePath. -or- The document is a cloud model.
ArgumentNullException | A non-optional argument was null
FileAccessException | The model cannot be accessed due to lack of access privileges.
FileArgumentNotFoundException | There is not a valid Revit file at ifcFilePath's location -or- There is not a valid Revit file at revitLinkedFilePath's location
InvalidOperationException | The file is not allowed to access. -or- Revit cannot customize worksets for this model.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks

This function is one of a series of steps necessary for linking an IFC file. To understand how it is used in context, please download the IFC open source code, and look in the Revit.IFC.Import project at Importer.ImportIFC(ImporterIFC importer), under the IFCImportAction.Link branch.

This function regenerates the input document. While the options argument allows specification of a path type, the input path argument must be a full path. Relative vs. absolute determines how Revit will store the path, but it needs a complete path to find the linked document initially.
See Also

Reference

RevitLinkType Class
CreateFromIFC Overload


RevitLinkType.GetChildIds Method

RevitLinkTypeGetChildIds Method

Gets the ids of the immediate children of this link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetChildIds()
Public Function GetChildIds As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetChildIds()
member GetChildIds : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
The element ids of all links which are linked directly into this one (immediate children)
Remarks
This function only returns the ids of immediate children. Given the link structure A -> B -> C, then calling this function on A will only return B's id.
See Also

Reference

RevitLinkType Class


RevitLinkType.GetConversionData Method

RevitLinkTypeGetConversionData Method

Returns the optional data that is necessary to generate the Revit file for this link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LinkConversionData GetConversionData()
Public Function GetConversionData As LinkConversionData
public:
LinkConversionData^ GetConversionData()
member GetConversionData : unit -> LinkConversionData

Return Value

LinkConversionData
The RvtLinkConversionData containing the necessary information.
See Also

Reference

RevitLinkType Class


RevitLinkType.GetLinkedFileStatus Method

RevitLinkTypeGetLinkedFileStatus Method

Returns the LinkedFileStatus of this link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LinkedFileStatus GetLinkedFileStatus()
Public Function GetLinkedFileStatus As LinkedFileStatus
public:
LinkedFileStatus GetLinkedFileStatus()
member GetLinkedFileStatus : unit -> LinkedFileStatus

Return Value

LinkedFileStatus
See Also

Reference

RevitLinkType Class


RevitLinkType.GetParentId Method

RevitLinkTypeGetParentId Method

Gets the id of this link's immediate parent.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GetParentId()
Public Function GetParentId As ElementId
public:
ElementId^ GetParentId()
member GetParentId : unit -> ElementId

Return Value

ElementId
The id of the immediate parent of this link, or invalidElementId if this link is a top-level link.
Remarks
This function returns the immediate parent id. Given the link structure A -> B -> C, then calling this function on C will return B's id. Call GetRootId to get A's id.
See Also

Reference

RevitLinkType Class


RevitLinkType.GetPhaseMap Method

RevitLinkTypeGetPhaseMap Method

Returns a mapping between phases in the host document and phases in the linked document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IDictionary<ElementId, ElementId> GetPhaseMap()
Public Function GetPhaseMap As IDictionary(Of ElementId, ElementId)
public:
IDictionary<ElementId^, ElementId^>^ GetPhaseMap()
member GetPhaseMap : unit -> IDictionary<ElementId, ElementId>

Return Value

IDictionary ElementId, ElementId
A map from phases in the host document to phases in the linked document. The first value in each pair is the ElementId of a phase in the host document. The second value is the ElementId of the matching phase in the linked document.
Exceptions
Exception | Condition
InvalidOperationException | The RvtLinkSymbol is not loaded. -or- This Revit link doesn't have a valid phase map.
Remarks
This map is used to determine which phase in the linked document corresponds to each phase in the host document. This map is used to correctly calculate room geometry for room-bounding links. Multiple phases in the host document can correspond to the same phase in the linked document. Time order must be respected - if the host document has phases 1 and 2, and the linked document has phases A and B, it would not be proper to map 1 to B and 2 to A. If the user has not explicitly set the map values in the UI, the map will be as follows: Revit attempts to find a match for each host phase, moving in order from earliest to latest phase. First Revit will look for a phase in the linked document with the same name as the host phase. If there is no name match, the last phase in the link will be chosen as the match. Once Revit has matched a host phase to the last link phase, all other host phases will be matched to the last link phase, even if later host phases might have a name match.
See Also

Reference

RevitLinkType Class


RevitLinkType.GetRootId Method

RevitLinkTypeGetRootId Method

Gets the id of the top-level link which this link is linked into.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GetRootId()
Public Function GetRootId As ElementId
public:
ElementId^ GetRootId()
member GetRootId : unit -> ElementId

Return Value

ElementId
The id of the top-level link which this link is ultimately linked under, or invalidElementId if this link is a top-level link.
Remarks
This function will always return the id of a top-level link, or invalidElementId. Given the link structure A -> B -> C, then calling this function on C will return A's id. Call GetParentId to get B's id.
See Also

Reference

RevitLinkType Class


RevitLinkType.GetTopLevelLink Method

RevitLinkTypeGetTopLevelLink Method

Overload List
Name | Description
GetTopLevelLink(Document, ExternalResourceReference) | Returns the ElementId of the (top-level) linked model with the given ExternalResourceReference.
GetTopLevelLink(Document, ModelPath) | Returns the ElementId of the (top-level) linked model with the given path.
Top
See Also

Reference

RevitLinkType Class


RevitLinkType.GetTopLevelLink(Document, ExternalResourceReference) Method

RevitLinkTypeGetTopLevelLink(Document, ExternalResourceReference) Method

Returns the ElementId of the (top-level) linked model with the given ExternalResourceReference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ElementId GetTopLevelLink(
    Document document,
    ExternalResourceReference reference
)
Public Shared Function GetTopLevelLink (
    document As Document,
    reference As ExternalResourceReference
) As ElementId
public:
static ElementId^ GetTopLevelLink(
    Document^ document,
    ExternalResourceReference^ reference
)
static member GetTopLevelLink :
        document : Document *
        reference : ExternalResourceReference -> ElementId

Parameters

document Document
The document to look for the linked model in.
reference ExternalResourceReference
An ExternalResourceReference indicating which linked model to return.

Return Value

ElementId
The id of the link with the given ExternalResourceReference, or InvalidElementId if there is no top-level link at that location.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks

This function will not return nested links.

Revit will not check the version when checking for resource equality.

See Also

Reference

RevitLinkType Class
GetTopLevelLink Overload


RevitLinkType.GetTopLevelLink(Document, ModelPath) Method

RevitLinkTypeGetTopLevelLink(Document, ModelPath) Method

Returns the ElementId of the (top-level) linked model with the given path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ElementId GetTopLevelLink(
    Document document,
    ModelPath path
)
Public Shared Function GetTopLevelLink (
    document As Document,
    path As ModelPath
) As ElementId
public:
static ElementId^ GetTopLevelLink(
    Document^ document,
    ModelPath^ path
)
static member GetTopLevelLink :
        document : Document *
        path : ModelPath -> ElementId

Parameters

document Document
The document to look for the linked model in.
path ModelPath
A path indicating which linked model to return.

Return Value

ElementId
The id of the link with the given path, or InvalidElementId if there is no top-level link at that path.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
This function will not return nested links.
See Also

Reference

RevitLinkType Class
GetTopLevelLink Overload


RevitLinkType.HasSaveablePositions Method

RevitLinkTypeHasSaveablePositions Method

Determines whether the link has changes to shared positioning that could be saved.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasSaveablePositions()
Public Function HasSaveablePositions As Boolean
public:
bool HasSaveablePositions()
member HasSaveablePositions : unit -> bool

Return Value

Boolean
True if the link has shared positioning changes which can be saved. False if there are no changes to shared coordinates, or if the changes cannot be saved.
See Also

Reference

RevitLinkType Class


RevitLinkType.IsFromLocalPath Method

RevitLinkTypeIsFromLocalPath Method

Checks whether the Revit link uses a local path, such as a hard drive.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsFromLocalPath()
Public Function IsFromLocalPath As Boolean
public:
bool IsFromLocalPath()
member IsFromLocalPath : unit -> bool

Return Value

Boolean
Returns true if the Revit link is from a local drive.
See Also

Reference

RevitLinkType Class


RevitLinkType.IsFromRevitServer Method

RevitLinkTypeIsFromRevitServer Method

Checks whether the Revit link is located on Revit Server.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsFromRevitServer()
Public Function IsFromRevitServer As Boolean
public:
bool IsFromRevitServer()
member IsFromRevitServer : unit -> bool

Return Value

Boolean
Returns true if the Revit link is located on Revit Server.
See Also

Reference

RevitLinkType Class


RevitLinkType.IsLoaded Method

RevitLinkTypeIsLoaded Method

Checks whether the link with this id is loaded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsLoaded(
    Document document,
    ElementId typeId
)
Public Shared Function IsLoaded (
    document As Document,
    typeId As ElementId
) As Boolean
public:
static bool IsLoaded(
    Document^ document,
    ElementId^ typeId
)
static member IsLoaded :
        document : Document *
        typeId : ElementId -> bool

Parameters

document Document
A document. Revit will see if typeId corresponds to a loaded link in this document.
typeId ElementId
An element id. Revit will check if typeId corresponds to a loaded link in the given document.

Return Value

Boolean
True if typeId corresponds to a loaded RevitLinkType. False otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Returns false if typeId is not the id of a RevitLinkType.
See Also

Reference

RevitLinkType Class


RevitLinkType.IsNotLoadedIntoMultipleOpenDocuments Method

RevitLinkTypeIsNotLoadedIntoMultipleOpenDocuments Method

Checks whether the link is loaded into more than one open document in this session of Revit. If the link is loaded into multiple open documents, reload will be disabled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsNotLoadedIntoMultipleOpenDocuments()
Public Function IsNotLoadedIntoMultipleOpenDocuments As Boolean
public:
bool IsNotLoadedIntoMultipleOpenDocuments()
member IsNotLoadedIntoMultipleOpenDocuments : unit -> bool

Return Value

Boolean
True if the link is loaded into at most one open document. False if the link is loaded into more than one open document.
Remarks

Revit can open several documents which contain the same link. If this is the case, Revit cannot reload the link, as doing so would make changes to a non-active document. You will need to close one or more documents in order to modify the link.

If the link is loaded into multiple documents across multiple sessions of Revit, this function will return true. We only check the current session of Revit. It is safe to reload a link which is loaded into multiple sessions, as long as it is not loaded into more than one document in any one session.

If this function returns true, it is safe to reload the link.

See Also

Reference

RevitLinkType Class


RevitLinkType.Load Method

RevitLinkTypeLoad Method

Loads or reloads the Revit link from its currently-stored location. If the link is an external resource, Revit will contact the IExternalResourceServer to get the latest version of the link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LinkLoadResult Load()
Public Function Load As LinkLoadResult
public:
LinkLoadResult^ Load()
member Load : unit -> LinkLoadResult

Return Value

LinkLoadResult
An object containing the ElementId of the link and an enum value indicating any errors which occurred while trying to load. LinkLoadResultType.LinkLoaded indicates success.
Exceptions
Exception | Condition
FileAccessException | The model cannot be accessed due to lack of access privileges.
ForbiddenForDynamicUpdateException | The element "this RevitLinkType" is in a ducument which is in dynamic update.
InvalidOperationException | The element "this RevitLinkType" is in a family document or a document in in-place edit mode. -or- The element "this RevitLinkType" is in a document which is in an edit mode or is in family mode. -or- The element "this RevitLinkType" is in a read-only document. -or- This RevitLinkType is not a top-level link. -or- The link "this RevitLinkType" is loaded into multiple documents and cannot be reloaded. -or- The element "this RevitLinkType" is in a closed workset. -or- There is a transaction phase left open (such as a transaction, sub-transaction of transaction group) at the time of invoking this method.
Remarks

If the link is currently loaded, Revit must unload the link before reloading it. Any changes made in-memory to the link's shared coordinates will be discarded.

This function regenerates the document.

The document's Undo history will be cleared by this command. As a result, this command and others executed before it cannot be undone. All transaction phases (e.g. transactions transaction groups and sub-transaction) that were explicitly started must be finished prior to calling this method.

See Also

Reference

RevitLinkType Class


RevitLinkType.LoadFrom Method

RevitLinkTypeLoadFrom Method

Overload List
 | Name | Description
Public method | LoadFrom(ExternalResourceReference, WorksetConfiguration) | Loads or reloads the Revit link. The link will be loaded from the location given in the input ExternalResourceReference.
Public method | LoadFrom(ModelPath, WorksetConfiguration) | Loads or reloads the Revit link from disk or cloud. The link will be loaded from the input path.
Top
See Also

Reference

RevitLinkType Class


RevitLinkType.LoadFrom(ExternalResourceReference, WorksetConfiguration) Method

RevitLinkTypeLoadFrom(ExternalResourceReference, WorksetConfiguration) Method

Loads or reloads the Revit link. The link will be loaded from the location given in the input ExternalResourceReference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LinkLoadResult LoadFrom(
    ExternalResourceReference resourceReference,
    WorksetConfiguration config
)
Public Function LoadFrom (
    resourceReference As ExternalResourceReference,
    config As WorksetConfiguration
) As LinkLoadResult
public:
LinkLoadResult^ LoadFrom(
    ExternalResourceReference^ resourceReference,
    WorksetConfiguration^ config
)
member LoadFrom :
        resourceReference : ExternalResourceReference *
        config : WorksetConfiguration -> LinkLoadResult

Parameters

resourceReference ExternalResourceReference
An external resource reference describing the source of the linked Revit document.
config WorksetConfiguration

A WorksetConfiguration object indicating which worksets in the link to open.

If you want to load the same set of worksets the link previously had, leave this argument as .

Return Value

LinkLoadResult
An object containing the ElementId of the link and an enum value indicating any errors which occurred while trying to load.
Exceptions
Exception | Condition
ArgumentException | The server referenced by the ExternalResourceReference does not exist or does not implement IExternalResourceServer. -or- The server referenced by the ExternalResourceReference cannot support Revit links. -or- The ExternalResourceReference (resourceReference) is not in a format that is supported by its server.
ArgumentNullException | A non-optional argument was null
FileAccessException | The model cannot be accessed due to lack of access privileges.
ForbiddenForDynamicUpdateException | The function is not permitted during dynamic update.
InvalidOperationException | This RevitLinkType is not a top-level link. -or- The link "this RevitLinkType" is loaded into multiple documents and cannot be reloaded. -or- The element "this RevitLinkType" is in a closed workset. -or- There is a transaction phase left open (such as a transaction, sub-transaction of transaction group) at the time of invoking this method. -or- The document is read-only. It cannot be modified. -or- The document is in an edit mode or is in family mode. -or- Revit cannot customize worksets for this model.
Remarks

If the link is currently loaded, Revit must unload the link before reloading it. Any changes made in-memory to the link's shared coordinates will be discarded.

Revit does not try to validate that the input represents the "same" document. You can load a completely different document, which may invalidate references to linked elements.

This function regenerates the document.

The document's Undo history will be cleared by this command. As a result, this command and others executed before it cannot be undone. All transaction phases (e.g. transactions transaction groups and sub-transaction) that were explicitly started must be finished prior to calling this method.

See Also

Reference

RevitLinkType Class
LoadFrom Overload


RevitLinkType.LoadFrom(ModelPath, WorksetConfiguration) Method

RevitLinkTypeLoadFrom(ModelPath, WorksetConfiguration) Method

Loads or reloads the Revit link from disk or cloud. The link will be loaded from the input path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LinkLoadResult LoadFrom(
    ModelPath path,
    WorksetConfiguration config
)
Public Function LoadFrom (
    path As ModelPath,
    config As WorksetConfiguration
) As LinkLoadResult
public:
LinkLoadResult^ LoadFrom(
    ModelPath^ path,
    WorksetConfiguration^ config
)
member LoadFrom :
        path : ModelPath *
        config : WorksetConfiguration -> LinkLoadResult

Parameters

path ModelPath
A ModelPath indicating where to load the link from. This may be a path of local disk, Revit Server or Cloud. This must be an absolute path for local path.
config WorksetConfiguration

A WorksetConfiguration object indicating which worksets in the link to open.

If you want to load the same set of worksets the link previously had, leave this argument as .

Return Value

LinkLoadResult
An object containing the ElementId of the link and an enum value indicating any errors which occurred while trying to load.
Exceptions
Exception | Condition
ArgumentException | The input path "path" does not represent a Revit model.
ArgumentNullException | A non-optional argument was null
FileAccessException | The model cannot be accessed due to lack of access privileges.
ForbiddenForDynamicUpdateException | The function is not permitted during dynamic update.
InvalidOperationException | This RevitLinkType is not a top-level link. -or- The link "this RevitLinkType" is loaded into multiple documents and cannot be reloaded. -or- The element "this RevitLinkType" is in a closed workset. -or- The model is not allowed to access. -or- There is a transaction phase left open (such as a transaction, sub-transaction of transaction group) at the time of invoking this method. -or- The document is read-only. It cannot be modified. -or- The document is in an edit mode or is in family mode. -or- Revit cannot customize worksets for this model. -or- Revit cannot link a cloud model to non-cloud model.
RevitServerInternalException | Could be for any of the reasons that failed on service side.
RevitServerUnauthenticatedUserException | User is not signed in with Autodesk id.
RevitServerUnauthorizedException | User is not authorized to access the specified cloud model.
Remarks

The input path must be absolute. Revit will store an absolute or relative path internally, according to the link's settings. Revit Server paths or cloud paths are acceptable.

If the link is currently loaded, Revit must unload the link before reloading it. Any changes made in-memory to the link's shared coordinates will be discarded.

Revit does not try to validate that the input path represents the "same" document. You can load a completely different document, which may invalidate references to linked elements.

This function regenerates the document.

The document's Undo history will be cleared by this command. As a result, this command and others executed before it cannot be undone. All transaction phases (e.g. transactions transaction groups and sub-transaction) that were explicitly started must be finished prior to calling this method.

See Also

Reference

RevitLinkType Class
LoadFrom Overload


RevitLinkType.Reload Method

RevitLinkTypeReload Method

Loads or reloads the Revit link from its currently-stored location. If the link is an external resource, Revit will contact the IExternalResourceServer to get the latest version of the link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LinkLoadResult Reload()
Public Function Reload As LinkLoadResult
public:
LinkLoadResult^ Reload()
member Reload : unit -> LinkLoadResult

Return Value

LinkLoadResult
An object containing the ElementId of the link and an enum value indicating any errors which occurred while trying to load. LinkLoadResultType.LinkLoaded indicates success.
Exceptions
Exception | Condition
FileAccessException | The model cannot be accessed due to lack of access privileges.
ForbiddenForDynamicUpdateException | The element "this RevitLinkType" is in a ducument which is in dynamic update.
InvalidOperationException | The element "this RevitLinkType" is in a family document or a document in in-place edit mode. -or- The element "this RevitLinkType" is in a document which is in an edit mode or is in family mode. -or- The element "this RevitLinkType" is in a read-only document. -or- This RevitLinkType is not a top-level link. -or- The link "this RevitLinkType" is loaded into multiple documents and cannot be reloaded. -or- The element "this RevitLinkType" is in a closed workset. -or- There is a transaction phase left open (such as a transaction, sub-transaction of transaction group) at the time of invoking this method.
Remarks

If the link is currently loaded, Revit must unload the link before reloading it. Any changes made in-memory to the link's shared coordinates will be discarded.

This function regenerates the document.

The document's Undo history will be cleared by this command. As a result, this command and others executed before it cannot be undone. All transaction phases (e.g. transactions transaction groups and sub-transaction) that were explicitly started must be finished prior to calling this method.

This function is identical to RevitLinkType.Load() and is included for convenience.

See Also

Reference

RevitLinkType Class


RevitLinkType.RevertLocalUnloadStatus Method

RevitLinkTypeRevertLocalUnloadStatus Method

Restores the workshared load status of a link that has been unloaded only for the current user, in a local copy of a workshared model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LinkedFileStatus RevertLocalUnloadStatus()
Public Function RevertLocalUnloadStatus As LinkedFileStatus
public:
LinkedFileStatus RevertLocalUnloadStatus()
member RevertLocalUnloadStatus : unit -> LinkedFileStatus

Return Value

LinkedFileStatus
The link's LinkedFileStatus that has resulted from reverting the local unloaded status.
Exceptions
Exception | Condition
FileAccessException | The model cannot be accessed due to lack of access privileges.
ForbiddenForDynamicUpdateException | The element "this RevitLinkType" is in a ducument which is in dynamic update.
InvalidOperationException | The element "this RevitLinkType" is in a family document or a document in in-place edit mode. -or- The element "this RevitLinkType" is in a document which is in an edit mode or is in family mode. -or- The element "this RevitLinkType" is in a read-only document. -or- This functionality is not available in Revit LT. -or- The element "this RevitLinkType" is in non-workshared document. -or- The element "this RevitLinkType" is not in a local model: the model is not workshared or it is central. -or- This RevitLinkType is not a top-level link. -or- The link is not locally unloaded. -or- There is a transaction phase left open (such as a transaction, sub-transaction of transaction group) at the time of invoking this method.
Remarks

This function removes the local user's override of the link's workshared load status (see UnloadLocally method). That is, if the link is loaded in the central model for all worksharing users (and thus has been only unloaded for the local user), then this method will perform a full reload of the link for the local user. If the link is unloaded in the central model, then this method will simply clear the local user's unload override, so that the link will be reloaded in the local user's model, if it is ever reloaded in the central model.

This function should not be called on a Revit link:

  • in a document which is in an edit mode or is in family mode.
  • in a document which is in dynamic update.
  • in a document which is read only.
  • in a document in which there is transaction phase left open.
  • in a non-workshared file.
  • in a central model of workshared file.
  • which is nested.
  • which are not locally unloaded.

If the link is an external resource, Revit will contact the IExternalResourceServer to get the latest version of the link.

See Also

Reference

RevitLinkType Class


RevitLinkType.SavePositions Method

RevitLinkTypeSavePositions Method

Saves shared coordinates changes back to the linked document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SavePositions(
    ISaveSharedCoordinatesCallback callback
)
Public Function SavePositions (
    callback As ISaveSharedCoordinatesCallback
) As Boolean
public:
bool SavePositions(
    ISaveSharedCoordinatesCallback^ callback
)
member SavePositions :
        callback : ISaveSharedCoordinatesCallback -> bool

Parameters

callback ISaveSharedCoordinatesCallback
A callback object to resolve situations when Revit encounters modified links.

Return Value

Boolean
True if we saved the link or if there were no changes to save. False if the operation failed.
Exceptions
Exception | Condition
InvalidOperationException | Revit could not save shared coordinates changes to the link or one of its nested links.
Remarks
While this operation does not clear the document's undo history, you will not be able to undo this specific action, since it saves the link's shared coordinates changes to disk.
See Also

Reference

RevitLinkType Class


RevitLinkType.Unload Method

RevitLinkTypeUnload Method

Unloads the Revit link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Unload(
    ISaveSharedCoordinatesCallback callback
)
Public Sub Unload (
    callback As ISaveSharedCoordinatesCallback
)
public:
void Unload(
    ISaveSharedCoordinatesCallback^ callback
)
member Unload :
        callback : ISaveSharedCoordinatesCallback -> unit

Parameters

callback ISaveSharedCoordinatesCallback
A callback indicating what to do if Revit encounters links which have changes in shared coordinates. If , Revit will not save any shared coordinates changes to the link before unloading.
Exceptions
Exception | Condition
ForbiddenForDynamicUpdateException | The function is not permitted during dynamic update.
InvalidOperationException | This RevitLinkType is not a top-level link. -or- Revit could not save shared coordinates changes to the link or one of its nested links. -or- There is a transaction phase left open (such as a transaction, sub-transaction of transaction group) at the time of invoking this method. -or- The document is read-only. It cannot be modified. -or- The document is in an edit mode or is in family mode. -or- Revit cannot link a cloud model to non-cloud model
RevitServerInternalException | Could be for any of the reasons that failed on service side.
RevitServerUnauthenticatedUserException | User is not signed in with Autodesk id.
RevitServerUnauthorizedException | User is not authorized to access the specified cloud model.
Remarks

This function regenerates the document.

The document's Undo history will be cleared by this command. As a result, this command and others executed before it cannot be undone. All transaction phases (e.g. transactions transaction groups and sub-transaction) that were explicitly started must be finished prior to calling this method.

See Also

Reference

RevitLinkType Class


RevitLinkType.UnloadLocally Method

RevitLinkTypeUnloadLocally Method

Unloads a Revit link for the current user only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UnloadLocally(
    ISaveSharedCoordinatesCallbackForUnloadLocally callback
)
Public Function UnloadLocally (
    callback As ISaveSharedCoordinatesCallbackForUnloadLocally
) As Boolean
public:
bool UnloadLocally(
    ISaveSharedCoordinatesCallbackForUnloadLocally^ callback
)
member UnloadLocally :
        callback : ISaveSharedCoordinatesCallbackForUnloadLocally -> bool

Parameters

callback ISaveSharedCoordinatesCallbackForUnloadLocally
A callback indicating what to do if Revit encounters links which have changes in shared coordinates. The saving options for unloading locally only could be: save the link, not save the link. If , Revit will not save any shared coordinates changes to the link before unloading.

Return Value

Boolean
Returns true if the attempt to unload the link locally was successful.
Exceptions
Exception | Condition
FileAccessException | The model cannot be accessed due to lack of access privileges.
ForbiddenForDynamicUpdateException | The element "this RevitLinkType" is in a ducument which is in dynamic update.
InvalidOperationException | The element "this RevitLinkType" is in a family document or a document in in-place edit mode. -or- The element "this RevitLinkType" is in a document which is in an edit mode or is in family mode. -or- The element "this RevitLinkType" is in a read-only document. -or- This functionality is not available in Revit LT. -or- The element "this RevitLinkType" is in non-workshared document. -or- The element "this RevitLinkType" is not in a local model: the model is not workshared or it is central. -or- This RevitLinkType is not a top-level link. -or- The link "this RevitLinkType" is locally unloaded for current user already. -or- There is a transaction phase left open (such as a transaction, sub-transaction of transaction group) at the time of invoking this method.
Remarks

This function unloads the Revit link for the current user, instead of all users, in the workshared files.

If you want to unload the Revit link for all users, please use Unload(ISaveSharedCoordinatesCallback).

This function should not be called on a Revit link:

  • in a document which is in an edit mode or is in family mode.
  • in a document which is in dynamic update.
  • in a document which is read only.
  • in a document in which there is transaction phase left open.
  • in a non-workshared file.
  • in a central model of workshared file.
  • which is nested.
  • which is unloaded locally already.
See Also

Reference

RevitLinkType Class


RevitLinkType.UpdateFromIFC Method

RevitLinkTypeUpdateFromIFC Method

Overload List
 | Name | Description
Public method | UpdateFromIFC(Document, ExternalResourceReference, String, Boolean) | Updates a Revit link type from an IFC file and loads the linked document.
Public method | UpdateFromIFC(Document, String, String, Boolean) | Updates a Revit link type from an IFC file and loads the linked document.
Top
See Also

Reference

RevitLinkType Class


RevitLinkType.UpdateFromIFC(Document, ExternalResourceReference, String, Boolean) Method

RevitLinkTypeUpdateFromIFC(Document, ExternalResourceReference, String, Boolean) Method

Updates a Revit link type from an IFC file and loads the linked document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UpdateFromIFC(
    Document document,
    ExternalResourceReference resourceReference,
    string revitLinkedFilePath,
    bool recreateLink
)
Public Function UpdateFromIFC (
    document As Document,
    resourceReference As ExternalResourceReference,
    revitLinkedFilePath As String,
    recreateLink As Boolean
) As Boolean
public:
bool UpdateFromIFC(
    Document^ document,
    ExternalResourceReference^ resourceReference,
    String^ revitLinkedFilePath,
    bool recreateLink
)
member UpdateFromIFC :
        document : Document *
        resourceReference : ExternalResourceReference *
        revitLinkedFilePath : string *
        recreateLink : bool -> bool

Parameters

document Document
The document that contains Revit link.
resourceReference ExternalResourceReference
An external resource reference describing the source of the IFC file used in creation.
revitLinkedFilePath String
The path of the Revit file to create to hold the IFC information. This must be a full path.
recreateLink Boolean
If true, the Revit file will be updated based on the information in the IFC file. If false, the existing Revit file will be used.

Return Value

Boolean
Returns true if the update succeeded, false otherwise.
Exceptions
Exception | Condition
ArgumentException | document is not a project document. -or- The server referenced by the ExternalResourceReference does not exist or does not implement IExternalResourceServer. -or- The server referenced by the ExternalResourceReference cannot support IFC links. -or- The ExternalResourceReference (resourceReference) is not in a format that is supported by its server.
ArgumentNullException | A non-optional argument was null
FileAccessException | The model cannot be accessed due to lack of access privileges.
InvalidOperationException | The file is not allowed to access. -or- Revit cannot customize worksets for this model.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
This function regenerates the input document. While the options argument allows specification of a path type, the input path argument must be a full path. Relative vs. absolute determines how Revit will store the path, but it needs a complete path to find the linked document initially. Note that the IFC file will not be stored directly in the document; it will instead by stored in an intermediate Revit document, whose location is given by revitLinkedFilePath.
See Also

Reference

RevitLinkType Class
UpdateFromIFC Overload


RevitLinkType.UpdateFromIFC(Document, String, String, Boolean) Method

RevitLinkTypeUpdateFromIFC(Document, String, String, Boolean) Method

Updates a Revit link type from an IFC file and loads the linked document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UpdateFromIFC(
    Document document,
    string ifcFilePath,
    string revitLinkedFilePath,
    bool recreateLink
)
Public Function UpdateFromIFC (
    document As Document,
    ifcFilePath As String,
    revitLinkedFilePath As String,
    recreateLink As Boolean
) As Boolean
public:
bool UpdateFromIFC(
    Document^ document,
    String^ ifcFilePath,
    String^ revitLinkedFilePath,
    bool recreateLink
)
member UpdateFromIFC :
        document : Document *
        ifcFilePath : string *
        revitLinkedFilePath : string *
        recreateLink : bool -> bool

Parameters

document Document
The document that contains Revit link.
ifcFilePath String
The path of the IFC link to load. This must be a full path.
revitLinkedFilePath String
The path of the Revit file to create to hold the IFC information. This must be a full path.
recreateLink Boolean
If true, the Revit file will be updated based on the information in the IFC file. If false, the existing Revit file will be used.

Return Value

Boolean
Returns true if the update succeeded, false otherwise.
Exceptions
Exception | Condition
ArgumentException | document is not a project document. -or- The input path "ifcFilePath" does not represent an IFC file. -or- The document is a cloud model.
ArgumentNullException | A non-optional argument was null
FileAccessException | The model cannot be accessed due to lack of access privileges.
FileArgumentNotFoundException | There is not a valid Revit file at ifcFilePath's location
InvalidOperationException | The file is not allowed to access. -or- Revit cannot customize worksets for this model.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
This function regenerates the input document. While the options argument allows specification of a path type, the input path argument must be a full path. Relative vs. absolute determines how Revit will store the path, but it needs a complete path to find the linked document initially. Note that the IFC file will not be stored directly in the document; it will instead by stored in an intermediate Revit document, whose location is given by revitLinkedFilePath.
See Also

Reference

RevitLinkType Class
UpdateFromIFC Overload


Revolution Class

A revolution solid or void form.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBCombinableElement
Autodesk.Revit.DBGenericForm
Autodesk.Revit.DBRevolution

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Revolution : GenericForm
Public Class Revolution
    Inherits GenericForm
public ref class Revolution : public GenericForm
type Revolution =
    class
        inherit GenericForm
    end

The Revolution type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | Axis | Returns the Axis of the Revolution.
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | EndAngle | The end angle of the revolution relative to the sketch plane.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Get and Set the Name property (Inherited from GenericForm)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Sketch | Returns the Sketch of the Revolution.
Public property | StartAngle | The start angle of the revolution relative to the sketch plane.
Public property | Subcategory | The subcategory. (Inherited from GenericForm)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Revolution Properties

The Revolution type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | Axis | Returns the Axis of the Revolution.
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | EndAngle | The end angle of the revolution relative to the sketch plane.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Get and Set the Name property (Inherited from GenericForm)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Sketch | Returns the Sketch of the Revolution.
Public property | StartAngle | The start angle of the revolution relative to the sketch plane.
Public property | Subcategory | The subcategory. (Inherited from GenericForm)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

Revolution Class


Revolution.Axis Property

RevolutionAxis Property

Returns the Axis of the Revolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ModelLine Axis { get; }
Public ReadOnly Property Axis As ModelLine
    Get
public:
property ModelLine^ Axis {
    ModelLine^ get ();
}
member Axis : ModelLine with get

Property Value

ModelLine
Remarks
This property is used to retrieve the Axis of the Revolution.
See Also

Reference

Revolution Class


Revolution.EndAngle Property

RevolutionEndAngle Property

The end angle of the revolution relative to the sketch plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double EndAngle { get; set; }
Public Property EndAngle As Double
    Get
    Set
public:
property double EndAngle {
    double get ();
    void set (double value);
}
member EndAngle : float with get, set

Property Value

Double
Remarks
The direction of the angle is based on the normal of the sketch plane. A positive angle is on the same side as the normal, a negative angle on the opposite side.
See Also

Reference

Revolution Class


Revolution.Sketch Property

RevolutionSketch Property

Returns the Sketch of the Revolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Sketch Sketch { get; }
Public ReadOnly Property Sketch As Sketch
    Get
public:
property Sketch^ Sketch {
    Sketch^ get ();
}
member Sketch : Sketch with get

Property Value

Sketch
Remarks
This property is used to retrieve the Sketch of the Revolution.
See Also

Reference

Revolution Class


Revolution.StartAngle Property

RevolutionStartAngle Property

The start angle of the revolution relative to the sketch plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double StartAngle { get; set; }
Public Property StartAngle As Double
    Get
    Set
public:
property double StartAngle {
    double get ();
    void set (double value);
}
member StartAngle : float with get, set

Property Value

Double
Remarks
The direction of the angle is based on the normal of the sketch plane. A positive angle is on the same side as the normal, a negative angle on the opposite side.
See Also

Reference

Revolution Class


Revolution Methods

The Revolution type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Revolution Class


RevolvedFace Class

A revolved face of a 3d solid or open shell.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGeometryObject
Autodesk.Revit.DBFace
Autodesk.Revit.DBRevolvedFace

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RevolvedFace : Face
Public Class RevolvedFace
    Inherits Face
public ref class RevolvedFace : public Face
type RevolvedFace =
    class
        inherit Face
    end

The RevolvedFace type exposes the following members.

Properties
 | Name | Description
Public property | Area | The area of this face. (Inherited from Face)
Public property | Axis | Axis of the surface.
Public property | Curve | Profile curve of the surface.
Public property | EdgeLoops | A collection of edge loops. Each edge loop represents one of the closed boundaries of the face. (Inherited from Face)
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject)
Public property | HasRegions | Identifies if the face contains regions (which can be created, for example, by the Split Face command). (Inherited from Face)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject)
Public property | IsCyclic | Indicates whether the underlying surface is periodic in the specified parametric direction. (Inherited from Face)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject)
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate). (Inherited from Face)
Public property | MaterialElementId | The element ID of the material from which this face is composed. (Inherited from Face)
Public property | OrientationMatchesSurfaceOrientation | Returns true if this face's orientation matches the orientation of the face's surface, false if they have opposite orientations. (Inherited from Face)
Public property | Origin | Origin of the surface.
Public property | Period | The period of the underlying surface in the specified parametric direction. (Inherited from Face)
Public property | Radius | Radius of the surface.
Public property | Reference | Returns a stable reference to the face. (Inherited from Face)
Public property | Visibility | The visibility. (Inherited from GeometryObject)
Top
Methods
 | Name | Description
Public method | ComputeDerivatives | Returns the first partial derivatives of the underlying surface at the specified point. (Inherited from Face)
Public method | ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face)
Public method | ComputeSecondDerivatives | Returns the second partial derivatives of the face at the specified point. (Inherited from Face)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject)
Public method | Evaluate | Evaluates and returns the XYZ coordinates of a point at the indicated UV parameterization of the face. (Inherited from Face)
Public method | GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face)
Public method | GetEdgesAsCurveLoops | Returns a list of closed curve loops that correspond to the edge loops of the face. Curves in each curve loop correspond to individual edges. (Inherited from Face)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject)
Public method | GetRegions | Gets the face regions (created, for example, by the Split Face command) of the face. (Inherited from Face)
Public method | GetSurface | Returns a copy of this face's surface. (Inherited from Face)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face)
Public method | Intersect(Face) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face)
Public method | Intersect(Curve, IntersectionResultArray) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face)
Public method | Intersect(Face, Curve) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face)
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face)
Public method | IsInside(UV, IntersectionResult) | Indicates whether the specified point is within this face and outputs additional information about the point location. (Inherited from Face)
Public method | Project | Projects the specified point on the face. (Inherited from Face)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
 | Triangulate | Returns a triangular mesh approximation to the face. (Inherited from Face)
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face. (Inherited from Face)
Top
Remarks
Revolved faces are defined by a profile curve and a local coordinate system. For details on the parameterization, refer to the documentation for RevolvedSurface
Example
C#
VB
C++
F#
Copy
private void GetRevolvedFaceInfo(Face face)
{
    RevolvedFace revolvedFace = face as RevolvedFace;
    if (null != revolvedFace)
    {
       XYZ origin = revolvedFace.Origin;
       XYZ axis = revolvedFace.Axis;
        Curve curve = revolvedFace.Curve;
        XYZ redius = revolvedFace.get_Radius(0);
    }
}
Private Sub GetRevolvedFaceInfo(face As Face)
    Dim revolvedFace As RevolvedFace = TryCast(face, RevolvedFace)
    If revolvedFace IsNot Nothing Then
        Dim origin As XYZ = revolvedFace.Origin
        Dim axis As XYZ = revolvedFace.Axis
        Dim curve As Curve = revolvedFace.Curve
        Dim redius As XYZ = revolvedFace.Radius(0)
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RevolvedFace Properties

The RevolvedFace type exposes the following members.

Properties
 | Name | Description
Public property | Area | The area of this face. (Inherited from Face)
Public property | Axis | Axis of the surface.
Public property | Curve | Profile curve of the surface.
Public property | EdgeLoops | A collection of edge loops. Each edge loop represents one of the closed boundaries of the face. (Inherited from Face)
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject)
Public property | HasRegions | Identifies if the face contains regions (which can be created, for example, by the Split Face command). (Inherited from Face)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject)
Public property | IsCyclic | Indicates whether the underlying surface is periodic in the specified parametric direction. (Inherited from Face)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject)
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate). (Inherited from Face)
Public property | MaterialElementId | The element ID of the material from which this face is composed. (Inherited from Face)
Public property | OrientationMatchesSurfaceOrientation | Returns true if this face's orientation matches the orientation of the face's surface, false if they have opposite orientations. (Inherited from Face)
Public property | Origin | Origin of the surface.
Public property | Period | The period of the underlying surface in the specified parametric direction. (Inherited from Face)
Public property | Radius | Radius of the surface.
Public property | Reference | Returns a stable reference to the face. (Inherited from Face)
Public property | Visibility | The visibility. (Inherited from GeometryObject)
Top
See Also

Reference

RevolvedFace Class


RevolvedFace.Axis Property

RevolvedFaceAxis Property

Axis of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Axis { get; }
Public ReadOnly Property Axis As XYZ
    Get
public:
property XYZ^ Axis {
    XYZ^ get ();
}
member Axis : XYZ with get

Property Value

XYZ
See Also

Reference

RevolvedFace Class


RevolvedFace.Curve Property

RevolvedFaceCurve Property

Profile curve of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Curve Curve { get; }
Public ReadOnly Property Curve As Curve
    Get
public:
property Curve^ Curve {
    Curve^ get ();
}
member Curve : Curve with get

Property Value

Curve
See Also

Reference

RevolvedFace Class


RevolvedFace.Origin Property

RevolvedFaceOrigin Property

Origin of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Origin { get; }
Public ReadOnly Property Origin As XYZ
    Get
public:
property XYZ^ Origin {
    XYZ^ get ();
}
member Origin : XYZ with get

Property Value

XYZ
See Also

Reference

RevolvedFace Class


RevolvedFace.Radius Property

RevolvedFaceRadius Property

Radius of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ this[
    int index
] { get; }
Public ReadOnly Property Radius (
    index As Integer
) As XYZ
    Get
public:
property XYZ^ Radius[int index] {
    XYZ^ get (int index);
}
member Radius : XYZ with get

Parameters

index Int32

Property Value

XYZ
See Also

Reference

RevolvedFace Class


RevolvedFace Methods

The RevolvedFace type exposes the following members.

Methods
 | Name | Description
Public method | ComputeDerivatives | Returns the first partial derivatives of the underlying surface at the specified point. (Inherited from Face)
Public method | ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face)
Public method | ComputeSecondDerivatives | Returns the second partial derivatives of the face at the specified point. (Inherited from Face)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject)
Public method | Evaluate | Evaluates and returns the XYZ coordinates of a point at the indicated UV parameterization of the face. (Inherited from Face)
Public method | GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face)
Public method | GetEdgesAsCurveLoops | Returns a list of closed curve loops that correspond to the edge loops of the face. Curves in each curve loop correspond to individual edges. (Inherited from Face)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject)
Public method | GetRegions | Gets the face regions (created, for example, by the Split Face command) of the face. (Inherited from Face)
Public method | GetSurface | Returns a copy of this face's surface. (Inherited from Face)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face)
Public method | Intersect(Face) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face)
Public method | Intersect(Curve, IntersectionResultArray) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face)
Public method | Intersect(Face, Curve) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face)
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face)
Public method | IsInside(UV, IntersectionResult) | Indicates whether the specified point is within this face and outputs additional information about the point location. (Inherited from Face)
Public method | Project | Projects the specified point on the face. (Inherited from Face)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
 | Triangulate | Returns a triangular mesh approximation to the face. (Inherited from Face)
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face. (Inherited from Face)
Top
See Also

Reference

RevolvedFace Class


RevolvedSurface Class

A surface of revolution defined by a profile curve and a local coordinate system. The surface is obtained by rotating the curve around Z axis of the local coordinate system.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSurface
Autodesk.Revit.DBRevolvedSurface

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RevolvedSurface : Surface
Public Class RevolvedSurface
    Inherits Surface
public ref class RevolvedSurface : public Surface
type RevolvedSurface =
    class
        inherit Surface
    end

The RevolvedSurface type exposes the following members.

Properties
 | Name | Description
Public property | Axis | Axis of the revolved surface. This is the Z axis of the local coordinate system associated with this revolved surface.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Surface)
Public property | OrientationMatchesParametricOrientation | Indicates whether this Surface's orientation is the same as or opposite to its parametric orientation. (Inherited from Surface)
Public property | Origin | Center of the circle that defines the base of the revolved surface. This is the origin of the local coordinate system associated with this revolved surface.
Public property | XDir | X axis of the local coordinate system associated with this revolved surface.
Public property | YDir | X axis of the local coordinate system associated with this revolved surface.
Top
Methods
 | Name | Description
 | Create(Frame, Curve) | Creates a Surface object coincident with the surface of revolution defined by a coordinate frame and a profile curve.
 | Create(XYZ, XYZ, Curve) | Creates a Surface object coincident with the surface of revolution defined by an axis and a profile curve.
 | Create(Frame, Curve, Double, Double) | Creates a Surface object coincident with the surface of revolution defined by a coordinate frame, a profile curve, and start and end angles of revolution.
 | Create(XYZ, XYZ, Curve, Double, Double) | Creates a Surface object coincident with the surface of revolution defined by an axis, a profile curve, and start and end angles of revolution.
Public method | Dispose | (Inherited from Surface)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBoundingBoxUV | Gets the UV bounding box of the surface. (Inherited from Surface)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetProfileCurve | Returns a copy of the profile curve expressed in the surface's coordinate system.
Public method | GetProfileCurveInWorldCoordinates | Returns a copy of the profile curve expressed in the world coordinate system.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | IsValidProfileCurve(Frame, Curve) | Checks if the input profile curve is valid to create a surface of revolution in the given frame of reference.
 | IsValidProfileCurve(XYZ, XYZ, Curve) | Checks if the input profile curve is valid to create a surface of revolution around the given axis.
Public method | Project | Project a 3D point orthogonally onto a surface (to find the nearest point). Throws InvalidOperationException if the projection fails. (Inherited from Surface)
Public method | ProjectWithGuessPoint | Project a 3D point orthogonally onto a surface (to find the nearest point). This method is meant to be used when a good approximate solution for the projection is available. Throws InvalidOperationException if the projection fails. (Inherited from Surface)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The parametric equation of a surface of revolution is S(u, v) = center + C1(v)*cos(u)*xVec + C1(v)*sin(u)*yVec + C2(v)*zVec, where the profile curve in the SurfRev's xz plane has the parametric equation (C1(t), C2(t)). Note that the direction of X axis may agree or disagree with the chosen orientation of the surface.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RevolvedSurface Properties

The RevolvedSurface type exposes the following members.

Properties
 | Name | Description
Public property | Axis | Axis of the revolved surface. This is the Z axis of the local coordinate system associated with this revolved surface.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Surface)
Public property | OrientationMatchesParametricOrientation | Indicates whether this Surface's orientation is the same as or opposite to its parametric orientation. (Inherited from Surface)
Public property | Origin | Center of the circle that defines the base of the revolved surface. This is the origin of the local coordinate system associated with this revolved surface.
Public property | XDir | X axis of the local coordinate system associated with this revolved surface.
Public property | YDir | X axis of the local coordinate system associated with this revolved surface.
Top
See Also

Reference

RevolvedSurface Class


RevolvedSurface.Axis Property

RevolvedSurfaceAxis Property

Axis of the revolved surface. This is the Z axis of the local coordinate system associated with this revolved surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Axis { get; }
Public ReadOnly Property Axis As XYZ
    Get
public:
property XYZ^ Axis {
    XYZ^ get ();
}
member Axis : XYZ with get

Property Value

XYZ
See Also

Reference

RevolvedSurface Class


RevolvedSurface.Origin Property

RevolvedSurfaceOrigin Property

Center of the circle that defines the base of the revolved surface. This is the origin of the local coordinate system associated with this revolved surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Origin { get; }
Public ReadOnly Property Origin As XYZ
    Get
public:
property XYZ^ Origin {
    XYZ^ get ();
}
member Origin : XYZ with get

Property Value

XYZ
See Also

Reference

RevolvedSurface Class


RevolvedSurface.XDir Property

RevolvedSurfaceXDir Property

X axis of the local coordinate system associated with this revolved surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ XDir { get; }
Public ReadOnly Property XDir As XYZ
    Get
public:
property XYZ^ XDir {
    XYZ^ get ();
}
member XDir : XYZ with get

Property Value

XYZ
See Also

Reference

RevolvedSurface Class


RevolvedSurface.YDir Property

RevolvedSurfaceYDir Property

X axis of the local coordinate system associated with this revolved surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ YDir { get; }
Public ReadOnly Property YDir As XYZ
    Get
public:
property XYZ^ YDir {
    XYZ^ get ();
}
member YDir : XYZ with get

Property Value

XYZ
See Also

Reference

RevolvedSurface Class


RevolvedSurface Methods

The RevolvedSurface type exposes the following members.

Methods
 | Name | Description
 | Create(Frame, Curve) | Creates a Surface object coincident with the surface of revolution defined by a coordinate frame and a profile curve.
 | Create(XYZ, XYZ, Curve) | Creates a Surface object coincident with the surface of revolution defined by an axis and a profile curve.
 | Create(Frame, Curve, Double, Double) | Creates a Surface object coincident with the surface of revolution defined by a coordinate frame, a profile curve, and start and end angles of revolution.
 | Create(XYZ, XYZ, Curve, Double, Double) | Creates a Surface object coincident with the surface of revolution defined by an axis, a profile curve, and start and end angles of revolution.
Public method | Dispose | (Inherited from Surface)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBoundingBoxUV | Gets the UV bounding box of the surface. (Inherited from Surface)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetProfileCurve | Returns a copy of the profile curve expressed in the surface's coordinate system.
Public method | GetProfileCurveInWorldCoordinates | Returns a copy of the profile curve expressed in the world coordinate system.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | IsValidProfileCurve(Frame, Curve) | Checks if the input profile curve is valid to create a surface of revolution in the given frame of reference.
 | IsValidProfileCurve(XYZ, XYZ, Curve) | Checks if the input profile curve is valid to create a surface of revolution around the given axis.
Public method | Project | Project a 3D point orthogonally onto a surface (to find the nearest point). Throws InvalidOperationException if the projection fails. (Inherited from Surface)
Public method | ProjectWithGuessPoint | Project a 3D point orthogonally onto a surface (to find the nearest point). This method is meant to be used when a good approximate solution for the projection is available. Throws InvalidOperationException if the projection fails. (Inherited from Surface)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

RevolvedSurface Class


RevolvedSurface.Create Method

RevolvedSurfaceCreate Method

Overload List
Name | Description
Create(Frame, Curve) | Creates a Surface object coincident with the surface of revolution defined by a coordinate frame and a profile curve.
Create(XYZ, XYZ, Curve) | Creates a Surface object coincident with the surface of revolution defined by an axis and a profile curve.
Create(Frame, Curve, Double, Double) | Creates a Surface object coincident with the surface of revolution defined by a coordinate frame, a profile curve, and start and end angles of revolution.
Create(XYZ, XYZ, Curve, Double, Double) | Creates a Surface object coincident with the surface of revolution defined by an axis, a profile curve, and start and end angles of revolution.
Top
See Also

Reference

RevolvedSurface Class


RevolvedSurface.Create(Frame, Curve) Method

RevolvedSurfaceCreate(Frame, Curve) Method

Creates a Surface object coincident with the surface of revolution defined by a coordinate frame and a profile curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Surface Create(
    Frame frameOfReference,
    Curve profileCurve
)
Public Shared Function Create (
    frameOfReference As Frame,
    profileCurve As Curve
) As Surface
public:
static Surface^ Create(
    Frame^ frameOfReference,
    Curve^ profileCurve
)
static member Create :
        frameOfReference : Frame *
        profileCurve : Curve -> Surface

Parameters

frameOfReference Frame
frameOfReference is an orthonormal frame that defines a local coordinate system for the surface of revolution.
  • The frame can be "right-handed" or "left-handed".
  • The origin of the frame is the base of point of the axis of revolution.
  • The BasisZ of the frame is the direction of the axis.
profileCurve Curve
The profile curve, which should satisfy the following conditions:
  • It is bounded and non-degenerate.
  • It is co-planar with the axis of revolution.
  • It lies on the xz plane of the frame.
  • It lies on the right side of the axis.
  • Only the end points of the profile curve can touch the axis.

Return Value

Surface
The created surface. Note that this surface may not be of type RevolvedSurface.
Exceptions
Exception | Condition
ArgumentException | This Frame object may not be used as a local frame of reference. -or- The input profile curve is not valid to create a surface revolution in the given frame.
ArgumentNullException | A non-optional argument was null
Remarks
The returned surface may not be of type RevolvedSurface - this function will create a surface of the simplest possible type (Plane, Cylinder, etc.) that can be used to represent the required surface of revolution. Given that the surface may be simplified, this function does not guarantee any particular parameterization of the surface.
See Also

Reference

RevolvedSurface Class
Create Overload


RevolvedSurface.Create(XYZ, XYZ, Curve) Method

RevolvedSurfaceCreate(XYZ, XYZ, Curve) Method

Creates a Surface object coincident with the surface of revolution defined by an axis and a profile curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Surface Create(
    XYZ axisBasePoint,
    XYZ axisDirection,
    Curve profileCurve
)
Public Shared Function Create (
    axisBasePoint As XYZ,
    axisDirection As XYZ,
    profileCurve As Curve
) As Surface
public:
static Surface^ Create(
    XYZ^ axisBasePoint,
    XYZ^ axisDirection,
    Curve^ profileCurve
)
static member Create :
        axisBasePoint : XYZ *
        axisDirection : XYZ *
        profileCurve : Curve -> Surface

Parameters

axisBasePoint XYZ
The base point of the axis of revolution. Expected to lie within the Revit design limits IsWithinLengthLimits(XYZ).
axisDirection XYZ
The direction of the axis.
profileCurve Curve
The profile curve, which should satisfy the following conditions:
  • It is bounded and non-degenerate.
  • It is co-planar with the axis of revolution.
  • It lies on only one side of the axis.
  • Only the end points of the profile curve can touch the axis.

Return Value

Surface
The created surface. Note that this surface may not be of type RevolvedSurface.
Exceptions
Exception | Condition
ArgumentException | The input point lies outside of Revit design limits. -or- The input profile curve is not valid to create a surface revolution around the given axis.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | axisDirection has zero length.
Remarks
The returned surface may not be of type RevolvedSurface - this function will create a surface of the simplest possible type (Plane, Cylinder, etc.) that can be used to represent the required surface of revolution. Given that the surface may be simplified, this function does not guarantee any particular parameterization of the surface.
See Also

Reference

RevolvedSurface Class
Create Overload


RevolvedSurface.Create(Frame, Curve, Double, Double) Method

RevolvedSurfaceCreate(Frame, Curve, Double, Double) Method

Creates a Surface object coincident with the surface of revolution defined by a coordinate frame, a profile curve, and start and end angles of revolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Surface Create(
    Frame frameOfReference,
    Curve profileCurve,
    double startAngle,
    double endAngle
)
Public Shared Function Create (
    frameOfReference As Frame,
    profileCurve As Curve,
    startAngle As Double,
    endAngle As Double
) As Surface
public:
static Surface^ Create(
    Frame^ frameOfReference,
    Curve^ profileCurve,
    double startAngle,
    double endAngle
)
static member Create :
        frameOfReference : Frame *
        profileCurve : Curve *
        startAngle : float *
        endAngle : float -> Surface

Parameters

frameOfReference Frame
frameOfReference is an orthonormal frame that defines a local coordinate system for the surface of revolution.
  • The frame can be "right-handed" or "left-handed".
  • The origin of the frame is the base of point of the axis of revolution.
  • The BasisZ of the frame is the direction of the axis.
profileCurve Curve
The profile curve, which should satisfy the following conditions:
  • It is bounded and non-degenerate.
  • It is co-planar with the axis of revolution.
  • It lies on the xz plane of the frame.
  • It lies on the right side of the axis.
  • Only the end points of the profile curve can touch the axis.
startAngle Double
Start angle of rotation. The angles are measured around the axis of revolution, using the right-hand rule. The profile curve is at the zero angle.
endAngle Double
End angle of rotation. Start angle must be less than end angle and their difference must be less than or equal to two times PI.

Return Value

Surface
The created surface. Note that this surface may not be of type RevolvedSurface.
Exceptions
Exception | Condition
ArgumentException | This Frame object may not be used as a local frame of reference. -or- The input profile curve is not valid to create a surface revolution in the given frame.
ArgumentNullException | A non-optional argument was null
ArgumentsInconsistentException | Start angle must be less than end angle and their difference must be less than or equal to two times PI.
Remarks
The returned surface may not be of type RevolvedSurface - this function will create a surface of the simplest possible type (Plane, Cylinder, etc.) that can be used to represent the required surface of revolution. Given that the surface may be simplified, this function does not guarantee any particular parameterization of the surface.
See Also

Reference

RevolvedSurface Class
Create Overload


RevolvedSurface.Create(XYZ, XYZ, Curve, Double, Double) Method

RevolvedSurfaceCreate(XYZ, XYZ, Curve, Double, Double) Method

Creates a Surface object coincident with the surface of revolution defined by an axis, a profile curve, and start and end angles of revolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Surface Create(
    XYZ axisBasePoint,
    XYZ axisDirection,
    Curve profileCurve,
    double startAngle,
    double endAngle
)
Public Shared Function Create (
    axisBasePoint As XYZ,
    axisDirection As XYZ,
    profileCurve As Curve,
    startAngle As Double,
    endAngle As Double
) As Surface
public:
static Surface^ Create(
    XYZ^ axisBasePoint,
    XYZ^ axisDirection,
    Curve^ profileCurve,
    double startAngle,
    double endAngle
)
static member Create :
        axisBasePoint : XYZ *
        axisDirection : XYZ *
        profileCurve : Curve *
        startAngle : float *
        endAngle : float -> Surface

Parameters

axisBasePoint XYZ
The base point of the axis of revolution. Expected to lie within the Revit design limits IsWithinLengthLimits(XYZ).
axisDirection XYZ
The direction of the axis.
profileCurve Curve
The profile curve, which should satisfy the following conditions:
  • It is bounded and non-degenerate.
  • It is co-planar with the axis of revolution.
  • It lies on only one side of the axis.
  • Only the end points of the profile curve can touch the axis.
startAngle Double
Start angle of rotation. The angles are measured around the axis of revolution, using the right-hand rule. The profile curve is at the zero angle.
endAngle Double
End angle of rotation. Start angle must be less than end angle and their difference must be less than or equal to two times PI.

Return Value

Surface
The created surface. Note that this surface may not be of type RevolvedSurface.
Exceptions
Exception | Condition
ArgumentException | The input point lies outside of Revit design limits. -or- The input profile curve is not valid to create a surface revolution around the given axis.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | axisDirection has zero length.
ArgumentsInconsistentException | Start angle must be less than end angle and their difference must be less than or equal to two times PI.
Remarks
The returned surface may not be of type RevolvedSurface - this function will create a surface of the simplest possible type (Plane, Cylinder, etc.) that can be used to represent the required surface of revolution. Given that the surface may be simplified, this function does not guarantee any particular parameterization of the surface.
See Also

Reference

RevolvedSurface Class
Create Overload


RevolvedSurface.GetProfileCurve Method

RevolvedSurfaceGetProfileCurve Method

Returns a copy of the profile curve expressed in the surface's coordinate system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Curve GetProfileCurve()
Public Function GetProfileCurve As Curve
public:
Curve^ GetProfileCurve()
member GetProfileCurve : unit -> Curve

Return Value

Curve
A copy of the profile curve.
See Also

Reference

RevolvedSurface Class


RevolvedSurface.GetProfileCurveInWorldCoordinates Method

RevolvedSurfaceGetProfileCurveInWorldCoordinates Method

Returns a copy of the profile curve expressed in the world coordinate system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Curve GetProfileCurveInWorldCoordinates()
Public Function GetProfileCurveInWorldCoordinates As Curve
public:
Curve^ GetProfileCurveInWorldCoordinates()
member GetProfileCurveInWorldCoordinates : unit -> Curve

Return Value

Curve
A copy of the profile curve in the world coordinate system.
See Also

Reference

RevolvedSurface Class


RevolvedSurface.IsValidProfileCurve Method

RevolvedSurfaceIsValidProfileCurve Method

Overload List
Name | Description
IsValidProfileCurve(Frame, Curve) | Checks if the input profile curve is valid to create a surface of revolution in the given frame of reference.
IsValidProfileCurve(XYZ, XYZ, Curve) | Checks if the input profile curve is valid to create a surface of revolution around the given axis.
Top
See Also

Reference

RevolvedSurface Class


RevolvedSurface.IsValidProfileCurve(Frame, Curve) Method

RevolvedSurfaceIsValidProfileCurve(Frame, Curve) Method

Checks if the input profile curve is valid to create a surface of revolution in the given frame of reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidProfileCurve(
    Frame frameOfReference,
    Curve profileCurve
)
Public Shared Function IsValidProfileCurve (
    frameOfReference As Frame,
    profileCurve As Curve
) As Boolean
public:
static bool IsValidProfileCurve(
    Frame^ frameOfReference,
    Curve^ profileCurve
)
static member IsValidProfileCurve :
        frameOfReference : Frame *
        profileCurve : Curve -> bool

Parameters

frameOfReference Frame
frameOfReference is an orthonormal frame that defines a local coordinate system for the surface of revolution.
  • The frame can be "right-handed" or "left-handed".
  • The origin of the frame is the base of point of the axis of revolution.
  • The BasisZ of the frame is the direction of the axis.
profileCurve Curve
The profile curve.

Return Value

Boolean
True if the profile curve is valid; False otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
The validity is defined as follows:
  • The profile curve is bounded and non-degenerate.
  • It is co-planar with the axis of revolution.
  • It lies on the xz plane of the frame.
  • It lies on the right side of the axis.
  • Only the end points of the profile curve can touch the axis.
See Also

Reference

RevolvedSurface Class
IsValidProfileCurve Overload


RevolvedSurface.IsValidProfileCurve(XYZ, XYZ, Curve) Method

RevolvedSurfaceIsValidProfileCurve(XYZ, XYZ, Curve) Method

Checks if the input profile curve is valid to create a surface of revolution around the given axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidProfileCurve(
    XYZ axisBasePoint,
    XYZ axisDirection,
    Curve profileCurve
)
Public Shared Function IsValidProfileCurve (
    axisBasePoint As XYZ,
    axisDirection As XYZ,
    profileCurve As Curve
) As Boolean
public:
static bool IsValidProfileCurve(
    XYZ^ axisBasePoint,
    XYZ^ axisDirection,
    Curve^ profileCurve
)
static member IsValidProfileCurve :
        axisBasePoint : XYZ *
        axisDirection : XYZ *
        profileCurve : Curve -> bool

Parameters

axisBasePoint XYZ
The base point of the axis of revolution.
axisDirection XYZ
The direction of the axis.
profileCurve Curve
The profile curve.

Return Value

Boolean
True if the profile curve is valid; False otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
The validity is defined as follows:
  • The profile curve is bounded and non-degenerate.
  • It is co-planar with the axis of revolution.
  • It lies on only one side of the axis.
  • Only the end points of the profile curve can touch the axis.
See Also

Reference

RevolvedSurface Class
IsValidProfileCurve Overload


RoofBase Class

Represents all kinds of Roofs.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBHostObject
Autodesk.Revit.DBRoofBase
Autodesk.Revit.DBExtrusionRoof
Autodesk.Revit.DBFootPrintRoof

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RoofBase : HostObject
Public Class RoofBase
    Inherits HostObject
public ref class RoofBase : public HostObject
type RoofBase =
    class
        inherit HostObject
    end

The RoofBase type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | EaveCuts | Retrieve or set the EaveCutterType.
Public property | FasciaDepth | Retrieve or set the FasciaDepth.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | RoofType | Retrieve or set the Type.
Public property | SlabShapeEditor | Obsolete. Get the SlabShapeEditor used for slab shape editing.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSlabShapeEditor | Gets a SlabShapeEditor that can used to add or modify points of this RoofBase.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The RoofBase object represents all kinds of roof in Revit.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RoofBase Properties

The RoofBase type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | EaveCuts | Retrieve or set the EaveCutterType.
Public property | FasciaDepth | Retrieve or set the FasciaDepth.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | RoofType | Retrieve or set the Type.
Public property | SlabShapeEditor | Obsolete. Get the SlabShapeEditor used for slab shape editing.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

RoofBase Class


RoofBase.EaveCuts Property

RoofBaseEaveCuts Property

Retrieve or set the EaveCutterType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EaveCutterType EaveCuts { get; set; }
Public Property EaveCuts As EaveCutterType
    Get
    Set
public:
property EaveCutterType EaveCuts {
    EaveCutterType get ();
    void set (EaveCutterType value);
}
member EaveCuts : EaveCutterType with get, set

Property Value

EaveCutterType
See Also

Reference

RoofBase Class


RoofBase.FasciaDepth Property

RoofBaseFasciaDepth Property

Retrieve or set the FasciaDepth.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double FasciaDepth { get; set; }
Public Property FasciaDepth As Double
    Get
    Set
public:
property double FasciaDepth {
    double get ();
    void set (double value);
}
member FasciaDepth : float with get, set

Property Value

Double
Remarks
If the EaveCutterType is PlumbCut, this property doesn't make sense.
See Also

Reference

RoofBase Class


RoofBase.RoofType Property

RoofBaseRoofType Property

Retrieve or set the Type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RoofType RoofType { get; set; }
Public Property RoofType As RoofType
    Get
    Set
public:
property RoofType^ RoofType {
    RoofType^ get ();
    void set (RoofType^ value);
}
member RoofType : RoofType with get, set

Property Value

RoofType
See Also

Reference

RoofBase Class


RoofBase.SlabShapeEditor Property

RoofBaseSlabShapeEditor Property

Note: This API is now obsolete.

Get the SlabShapeEditor used for slab shape editing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is deprecated in Revit 2024 and may be removed in a future version of Revit. Use GetSlabShapeEditor() instead.")]
public SlabShapeEditor SlabShapeEditor { get; }
<ObsoleteAttribute("This method is deprecated in Revit 2024 and may be removed in a future version of Revit. Use GetSlabShapeEditor() instead.")>
Public ReadOnly Property SlabShapeEditor As SlabShapeEditor
    Get
public:
[ObsoleteAttribute(L"This method is deprecated in Revit 2024 and may be removed in a future version of Revit. Use GetSlabShapeEditor() instead.")]
property SlabShapeEditor^ SlabShapeEditor {
    SlabShapeEditor^ get ();
}
[<ObsoleteAttribute("This method is deprecated in Revit 2024 and may be removed in a future version of Revit. Use GetSlabShapeEditor() instead.")>]
member SlabShapeEditor : SlabShapeEditor with get

Property Value

SlabShapeEditor
Remarks
Roofs cannot be attached to another roof, and the roof cannot be a curtain roof. If either of these conditions is not met, the ShapeEditor will be .
See Also

Reference

RoofBase Class


RoofBase Methods

The RoofBase type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSlabShapeEditor | Gets a SlabShapeEditor that can used to add or modify points of this RoofBase.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

RoofBase Class


RoofBase.GetSlabShapeEditor Method

RoofBaseGetSlabShapeEditor Method

Gets a SlabShapeEditor that can used to add or modify points of this RoofBase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SlabShapeEditor GetSlabShapeEditor()
Public Function GetSlabShapeEditor As SlabShapeEditor
public:
SlabShapeEditor^ GetSlabShapeEditor()
member GetSlabShapeEditor : unit -> SlabShapeEditor

Return Value

SlabShapeEditor
The SlabShapeEditor object
See Also

Reference

RoofBase Class


RoofType Class

Represents a specific type of roof.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBHostObjAttributes
Autodesk.Revit.DBRoofType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RoofType : HostObjAttributes
Public Class RoofType
    Inherits HostObjAttributes
public ref class RoofType : public HostObjAttributes
type RoofType =
    class
        inherit HostObjAttributes
    end

The RoofType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ThermalProperties | The calculated and settable thermal properties of the RoofType
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
All roof type objects available in the project can be retrieved from the Document object via the RoofTypes property. Every Roof object has a RoofType property that returns a RoofType object representing the type. This same RoofType property can also be used to change the type of the roof by setting it to a different type.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RoofType Properties

The RoofType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ThermalProperties | The calculated and settable thermal properties of the RoofType
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

RoofType Class


RoofType.ThermalProperties Property

RoofTypeThermalProperties Property

The calculated and settable thermal properties of the RoofType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ThermalProperties ThermalProperties { get; }
Public ReadOnly Property ThermalProperties As ThermalProperties
    Get
public:
property ThermalProperties^ ThermalProperties {
    ThermalProperties^ get ();
}
member ThermalProperties : ThermalProperties with get

Property Value

ThermalProperties
Remarks
Returns if the roof has no thermal properties. Curtain roofs do not store thermal properties.
See Also

Reference

RoofType Class


RoofType Methods

The RoofType type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

RoofType Class


RoundingMethod Enumeration

Rounding methods

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum RoundingMethod
Public Enumeration RoundingMethod
public enum class RoundingMethod
type RoundingMethod
Members
Member name | Value | Description
Nearest | 0 | Standard rounding: Round to Nearest
Up | 1 | Round Up
Down | 2 | Round Down
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RoutingCondition Class

RoutingCondition represents routing information that is used as input when determining if a routing criterion, such as minimum or maximum diameter, is met.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRoutingCondition

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RoutingCondition : IDisposable
Public Class RoutingCondition
    Implements IDisposable
public ref class RoutingCondition : IDisposable
type RoutingCondition =
    class
        interface IDisposable
    end

The RoutingCondition type exposes the following members.

Constructors
 | Name | Description
Public method | RoutingCondition | Creates a new RoutingCondition.
Top
Properties
 | Name | Description
Public property | Diameter | The diameter of the segment or fitting specified for the routing condition.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the RoutingCondition
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RoutingCondition Constructor

Creates a new RoutingCondition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RoutingCondition(
    double diameter
)
Public Sub New (
    diameter As Double
)
public:
RoutingCondition(
    double diameter
)
new :
        diameter : float -> RoutingCondition

Parameters

diameter Double
The diameter of a routing segment.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The given value for diameter must be greater than 0 and no more than 30000 feet.
See Also

Reference

RoutingCondition Class


RoutingCondition Properties

The RoutingCondition type exposes the following members.

Properties
 | Name | Description
Public property | Diameter | The diameter of the segment or fitting specified for the routing condition.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

RoutingCondition Class


RoutingCondition.Diameter Property

RoutingConditionDiameter Property

The diameter of the segment or fitting specified for the routing condition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Diameter { get; }
Public ReadOnly Property Diameter As Double
    Get
public:
property double Diameter {
    double get ();
}
member Diameter : float with get

Property Value

Double
See Also

Reference

RoutingCondition Class


RoutingCondition.IsValidObject Property

RoutingConditionIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

RoutingCondition Class


RoutingCondition Methods

The RoutingCondition type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

RoutingCondition Class


RoutingCondition.Dispose Method

RoutingConditionDispose Method

Releases all resources used by the RoutingCondition

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

RoutingCondition Class


RoutingConditions Class

RoutingConditions contain routing information that is used as input when determining if a routing criterion, such as minimum or maximum diameter, is met.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRoutingConditions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RoutingConditions : IDisposable
Public Class RoutingConditions
    Implements IDisposable
public ref class RoutingConditions : IDisposable
type RoutingConditions =
    class
        interface IDisposable
    end

The RoutingConditions type exposes the following members.

Constructors
 | Name | Description
Public method | RoutingConditions | Constructs a new instance of a RoutingConditions object with an indicated error level for conditions that do not meet any routing preference rule.
Top
Properties
 | Name | Description
Public property | ErrorLevel | The error level that the routing preference manager should post errors if the routing conditions do not meet any routing preference rule, could be None, Warning, or Error
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | PreferredJunctionType | The junction type (Tee or Tap) to select if defined fittings of both junction types meet all routing conditions.
Top
Methods
 | Name | Description
Public method | AppendCondition | Appends a routing condition to the end of existing routing conditions. Note that the first item (indexed at 0) is the condition for the primary connector.
Public method | Clear | Clear all existing conditions
Public method | Dispose | Releases all resources used by the RoutingConditions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetConditionAt | Gets the routing condition at the specified index position.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetNumberOfConditions | Gets the number of included routing conditions.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RoutingConditions Constructor

Constructs a new instance of a RoutingConditions object with an indicated error level for conditions that do not meet any routing preference rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RoutingConditions(
    RoutingPreferenceErrorLevel errorLevel
)
Public Sub New (
    errorLevel As RoutingPreferenceErrorLevel
)
public:
RoutingConditions(
    RoutingPreferenceErrorLevel errorLevel
)
new :
        errorLevel : RoutingPreferenceErrorLevel -> RoutingConditions

Parameters

errorLevel RoutingPreferenceErrorLevel
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

RoutingConditions Class


RoutingConditions Properties

The RoutingConditions type exposes the following members.

Properties
 | Name | Description
Public property | ErrorLevel | The error level that the routing preference manager should post errors if the routing conditions do not meet any routing preference rule, could be None, Warning, or Error
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | PreferredJunctionType | The junction type (Tee or Tap) to select if defined fittings of both junction types meet all routing conditions.
Top
See Also

Reference

RoutingConditions Class


RoutingConditions.ErrorLevel Property

RoutingConditionsErrorLevel Property

The error level that the routing preference manager should post errors if the routing conditions do not meet any routing preference rule, could be None, Warning, or Error

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RoutingPreferenceErrorLevel ErrorLevel { get; set; }
Public Property ErrorLevel As RoutingPreferenceErrorLevel
    Get
    Set
public:
property RoutingPreferenceErrorLevel ErrorLevel {
    RoutingPreferenceErrorLevel get ();
    void set (RoutingPreferenceErrorLevel value);
}
member ErrorLevel : RoutingPreferenceErrorLevel with get, set

Property Value

RoutingPreferenceErrorLevel
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

RoutingConditions Class


RoutingConditions.IsValidObject Property

RoutingConditionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

RoutingConditions Class


RoutingConditions.PreferredJunctionType Property

RoutingConditionsPreferredJunctionType Property

The junction type (Tee or Tap) to select if defined fittings of both junction types meet all routing conditions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PreferredJunctionType PreferredJunctionType { get; set; }
Public Property PreferredJunctionType As PreferredJunctionType
    Get
    Set
public:
property PreferredJunctionType PreferredJunctionType {
    PreferredJunctionType get ();
    void set (PreferredJunctionType value);
}
member PreferredJunctionType : PreferredJunctionType with get, set

Property Value

PreferredJunctionType
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

RoutingConditions Class


RoutingConditions Methods

The RoutingConditions type exposes the following members.

Methods
 | Name | Description
Public method | AppendCondition | Appends a routing condition to the end of existing routing conditions. Note that the first item (indexed at 0) is the condition for the primary connector.
Public method | Clear | Clear all existing conditions
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetConditionAt | Gets the routing condition at the specified index position.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetNumberOfConditions | Gets the number of included routing conditions.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

RoutingConditions Class


RoutingConditions.AppendCondition Method

RoutingConditionsAppendCondition Method

Appends a routing condition to the end of existing routing conditions. Note that the first item (indexed at 0) is the condition for the primary connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AppendCondition(
    RoutingCondition condition
)
Public Sub AppendCondition (
    condition As RoutingCondition
)
public:
void AppendCondition(
    RoutingCondition^ condition
)
member AppendCondition :
        condition : RoutingCondition -> unit

Parameters

condition RoutingCondition
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

RoutingConditions Class


RoutingConditions.Clear Method

RoutingConditionsClear Method

Clear all existing conditions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

RoutingConditions Class


RoutingConditions.Dispose Method

RoutingConditionsDispose Method

Releases all resources used by the RoutingConditions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

RoutingConditions Class


RoutingConditions.GetConditionAt Method

RoutingConditionsGetConditionAt Method

Gets the routing condition at the specified index position.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RoutingCondition GetConditionAt(
    int index
)
Public Function GetConditionAt (
    index As Integer
) As RoutingCondition
public:
RoutingCondition^ GetConditionAt(
    int index
)
member GetConditionAt :
        index : int -> RoutingCondition

Parameters

index Int32
The 0-based index to access the collection of available conditions. The method throws the exception ArgumentOutOfRangeException if the index is out of range.

Return Value

RoutingCondition
The found routing condition.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is not within the valid range of available conditions.
See Also

Reference

RoutingConditions Class


RoutingConditions.GetNumberOfConditions Method

RoutingConditionsGetNumberOfConditions Method

Gets the number of included routing conditions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetNumberOfConditions()
Public Function GetNumberOfConditions As Integer
public:
int GetNumberOfConditions()
member GetNumberOfConditions : unit -> int

Return Value

Int32
See Also

Reference

RoutingConditions Class


RoutingCriterionBase Class

RoutingCriteriaBase is the base class for all routing criteria.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRoutingCriterionBase
Autodesk.Revit.DBPrimarySizeCriterion

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RoutingCriterionBase : IDisposable
Public Class RoutingCriterionBase
    Implements IDisposable
public ref class RoutingCriterionBase : IDisposable
type RoutingCriterionBase =
    class
        interface IDisposable
    end

The RoutingCriterionBase type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the RoutingCriterionBase
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqual | Verify if two criteria are the same.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RoutingCriterionBase Properties

The RoutingCriterionBase type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

RoutingCriterionBase Class


RoutingCriterionBase.IsValidObject Property

RoutingCriterionBaseIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

RoutingCriterionBase Class


RoutingCriterionBase Methods

The RoutingCriterionBase type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqual | Verify if two criteria are the same.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

RoutingCriterionBase Class


RoutingCriterionBase.Dispose Method

RoutingCriterionBaseDispose Method

Releases all resources used by the RoutingCriterionBase

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

RoutingCriterionBase Class


RoutingCriterionBase.IsEqual Method

RoutingCriterionBaseIsEqual Method

Verify if two criteria are the same.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEqual(
    RoutingCriterionBase pOther
)
Public Function IsEqual (
    pOther As RoutingCriterionBase
) As Boolean
public:
bool IsEqual(
    RoutingCriterionBase^ pOther
)
member IsEqual :
        pOther : RoutingCriterionBase -> bool

Parameters

pOther RoutingCriterionBase

Return Value

Boolean
True if the criterion is equal to the other, false otherwise
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

RoutingCriterionBase Class


RoutingPreferenceErrorLevel Enumeration

An enumerated type listing the options for posting errors or warnings when routing preferences are not satisfied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum RoutingPreferenceErrorLevel
Public Enumeration RoutingPreferenceErrorLevel
public enum class RoutingPreferenceErrorLevel
type RoutingPreferenceErrorLevel
Members
Member name | Value | Description
None | 0 | Do not post any warning or error if there is no rule in the routing preference satisfying the current condition.
Warning | 1 | Post Revit warnings if there is no rule in the routing preference satisfying the current condition.
Error | 2 | Post Revit errors if there is no rule in the routing preference satisfying the current condition.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RoutingPreferenceManager Class

Manages default pipe segments, fittings, and selection criteria for a given MEPCurveType
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRoutingPreferenceManager

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RoutingPreferenceManager : IDisposable
Public Class RoutingPreferenceManager
    Implements IDisposable
public ref class RoutingPreferenceManager : IDisposable
type RoutingPreferenceManager =
    class
        interface IDisposable
    end

The RoutingPreferenceManager type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OwnerId | The Id of the MEPCurveType that owns the RoutingPreferenceManager
Public property | PreferredJunctionType | The preferred junction type.
Top
Methods
 | Name | Description
Public method | AddRule(RoutingPreferenceRuleGroupType, RoutingPreferenceRule) | Adds a new routing preference rule to the rule group.
Public method | AddRule(RoutingPreferenceRuleGroupType, RoutingPreferenceRule, Int32) | Adds a new routing preference rule to the specified position in the rule group.
Public method | Dispose | Releases all resources used by the RoutingPreferenceManager
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMEPPartId | Gets a fitting or segment id of given routing preference group that meets the specified routing conditions.
Public method | GetNumberOfRules | The number of RoutingPreference rules in a group.
Public method | GetRule | Gets the specified rule.
Public method | GetSharedSizes | Gets a list of all segments of a given profile shape that define a given size.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | RemoveRule | Removes an existing routing preference rule. Thrown if the index is out of bounds.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
MEPCurveTypes contain a RoutingPreferenceManager property. The RoutingPreferenceManager contains rules for selecting segment types and sizes as well as fitting types based on user selection criteria.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RoutingPreferenceManager Properties

The RoutingPreferenceManager type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OwnerId | The Id of the MEPCurveType that owns the RoutingPreferenceManager
Public property | PreferredJunctionType | The preferred junction type.
Top
See Also

Reference

RoutingPreferenceManager Class


RoutingPreferenceManager.IsValidObject Property

RoutingPreferenceManagerIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

RoutingPreferenceManager Class


RoutingPreferenceManager.OwnerId Property

RoutingPreferenceManagerOwnerId Property

The Id of the MEPCurveType that owns the RoutingPreferenceManager

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId OwnerId { get; }
Public ReadOnly Property OwnerId As ElementId
    Get
public:
property ElementId^ OwnerId {
    ElementId^ get ();
}
member OwnerId : ElementId with get

Property Value

ElementId
See Also

Reference

RoutingPreferenceManager Class


RoutingPreferenceManager.PreferredJunctionType Property

RoutingPreferenceManagerPreferredJunctionType Property

The preferred junction type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PreferredJunctionType PreferredJunctionType { get; set; }
Public Property PreferredJunctionType As PreferredJunctionType
    Get
    Set
public:
property PreferredJunctionType PreferredJunctionType {
    PreferredJunctionType get ();
    void set (PreferredJunctionType value);
}
member PreferredJunctionType : PreferredJunctionType with get, set

Property Value

PreferredJunctionType
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

RoutingPreferenceManager Class


RoutingPreferenceManager Methods

The RoutingPreferenceManager type exposes the following members.

Methods
 | Name | Description
Public method | AddRule(RoutingPreferenceRuleGroupType, RoutingPreferenceRule) | Adds a new routing preference rule to the rule group.
Public method | AddRule(RoutingPreferenceRuleGroupType, RoutingPreferenceRule, Int32) | Adds a new routing preference rule to the specified position in the rule group.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMEPPartId | Gets a fitting or segment id of given routing preference group that meets the specified routing conditions.
Public method | GetNumberOfRules | The number of RoutingPreference rules in a group.
Public method | GetRule | Gets the specified rule.
Public method | GetSharedSizes | Gets a list of all segments of a given profile shape that define a given size.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | RemoveRule | Removes an existing routing preference rule. Thrown if the index is out of bounds.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

RoutingPreferenceManager Class


RoutingPreferenceManager.AddRule Method

RoutingPreferenceManagerAddRule Method

Overload List
 | Name | Description
Public method | AddRule(RoutingPreferenceRuleGroupType, RoutingPreferenceRule) | Adds a new routing preference rule to the rule group.
Public method | AddRule(RoutingPreferenceRuleGroupType, RoutingPreferenceRule, Int32) | Adds a new routing preference rule to the specified position in the rule group.
Top
See Also

Reference

RoutingPreferenceManager Class


RoutingPreferenceManager.AddRule(RoutingPreferenceRuleGroupType, RoutingPreferenceRule) Method

RoutingPreferenceManagerAddRule(RoutingPreferenceRuleGroupType, RoutingPreferenceRule) Method

Adds a new routing preference rule to the rule group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddRule(
    RoutingPreferenceRuleGroupType groupType,
    RoutingPreferenceRule rule
)
Public Sub AddRule (
    groupType As RoutingPreferenceRuleGroupType,
    rule As RoutingPreferenceRule
)
public:
void AddRule(
    RoutingPreferenceRuleGroupType groupType,
    RoutingPreferenceRule^ rule
)
member AddRule :
        groupType : RoutingPreferenceRuleGroupType *
        rule : RoutingPreferenceRule -> unit

Parameters

groupType RoutingPreferenceRuleGroupType
The routing preference group in which the rule should be added.
rule RoutingPreferenceRule
The new rule to be added.
Exceptions
Exception | Condition
ArgumentException | The rule cannot be added to the groupType. -or- Thrown if the index is out of bounds, or the rule is not valid for this group (e.g. an elbow may not be added to the junction group).
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

RoutingPreferenceManager Class
AddRule Overload


RoutingPreferenceManager.AddRule(RoutingPreferenceRuleGroupType, RoutingPreferenceRule, Int32) Method

RoutingPreferenceManagerAddRule(RoutingPreferenceRuleGroupType, RoutingPreferenceRule, Int32) Method

Adds a new routing preference rule to the specified position in the rule group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddRule(
    RoutingPreferenceRuleGroupType groupType,
    RoutingPreferenceRule rule,
    int index
)
Public Sub AddRule (
    groupType As RoutingPreferenceRuleGroupType,
    rule As RoutingPreferenceRule,
    index As Integer
)
public:
void AddRule(
    RoutingPreferenceRuleGroupType groupType,
    RoutingPreferenceRule^ rule,
    int index
)
member AddRule :
        groupType : RoutingPreferenceRuleGroupType *
        rule : RoutingPreferenceRule *
        index : int -> unit

Parameters

groupType RoutingPreferenceRuleGroupType
The routing preference group type in which the rule should be added.
rule RoutingPreferenceRule
The new rule to be added.
index Int32
The zero-based index position where the new rule will be added.
Exceptions
Exception | Condition
ArgumentException | index is not a valid zero-based index within groupType. -or- The rule cannot be added to the groupType. -or- Thrown if the index is out of bounds, or the rule is not valid for this group (e.g. an elbow may not be added to the junction group).
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

RoutingPreferenceManager Class
AddRule Overload


RoutingPreferenceManager.Dispose Method

RoutingPreferenceManagerDispose Method

Releases all resources used by the RoutingPreferenceManager

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

RoutingPreferenceManager Class


RoutingPreferenceManager.GetMEPPartId Method

RoutingPreferenceManagerGetMEPPartId Method

Gets a fitting or segment id of given routing preference group that meets the specified routing conditions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GetMEPPartId(
    RoutingPreferenceRuleGroupType groupType,
    RoutingConditions conditions
)
Public Function GetMEPPartId (
    groupType As RoutingPreferenceRuleGroupType,
    conditions As RoutingConditions
) As ElementId
public:
ElementId^ GetMEPPartId(
    RoutingPreferenceRuleGroupType groupType,
    RoutingConditions^ conditions
)
member GetMEPPartId :
        groupType : RoutingPreferenceRuleGroupType *
        conditions : RoutingConditions -> ElementId

Parameters

groupType RoutingPreferenceRuleGroupType
The routing preference group
conditions RoutingConditions
A set of routing conditions

Return Value

ElementId
The Id of the fitting or segment that met the given routing conditions.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

RoutingPreferenceManager Class


RoutingPreferenceManager.GetNumberOfRules Method

RoutingPreferenceManagerGetNumberOfRules Method

The number of RoutingPreference rules in a group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetNumberOfRules(
    RoutingPreferenceRuleGroupType eGroupType
)
Public Function GetNumberOfRules (
    eGroupType As RoutingPreferenceRuleGroupType
) As Integer
public:
int GetNumberOfRules(
    RoutingPreferenceRuleGroupType eGroupType
)
member GetNumberOfRules :
        eGroupType : RoutingPreferenceRuleGroupType -> int

Parameters

eGroupType RoutingPreferenceRuleGroupType

Return Value

Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

RoutingPreferenceManager Class


RoutingPreferenceManager.GetRule Method

RoutingPreferenceManagerGetRule Method

Gets the specified rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RoutingPreferenceRule GetRule(
    RoutingPreferenceRuleGroupType groupType,
    int index
)
Public Function GetRule (
    groupType As RoutingPreferenceRuleGroupType,
    index As Integer
) As RoutingPreferenceRule
public:
RoutingPreferenceRule^ GetRule(
    RoutingPreferenceRuleGroupType groupType,
    int index
)
member GetRule :
        groupType : RoutingPreferenceRuleGroupType *
        index : int -> RoutingPreferenceRule

Parameters

groupType RoutingPreferenceRuleGroupType
The routing preference group type from which the rule should be returned.
index Int32
The zero-based index where the rule should be returned.

Return Value

RoutingPreferenceRule
The rule at the specified group and zero-based index position.
Exceptions
Exception | Condition
ArgumentException | index is not a valid zero-based index within groupType. -or- Thrown if the index is out of bounds
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

RoutingPreferenceManager Class


RoutingPreferenceManager.GetSharedSizes Method

RoutingPreferenceManagerGetSharedSizes Method

Gets a list of all segments of a given profile shape that define a given size.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ElementId> GetSharedSizes(
    double size,
    ConnectorProfileType shape
)
Public Function GetSharedSizes (
    size As Double,
    shape As ConnectorProfileType
) As IList(Of ElementId)
public:
IList<ElementId^>^ GetSharedSizes(
    double size,
    ConnectorProfileType shape
)
member GetSharedSizes :
        size : float *
        shape : ConnectorProfileType -> IList<ElementId>

Parameters

size Double
The size to search for.
shape ConnectorProfileType
The profile shape of segment object.

Return Value

IList ElementId
A list of all segments that define a given size.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

RoutingPreferenceManager Class


RoutingPreferenceManager.RemoveRule Method

RoutingPreferenceManagerRemoveRule Method

Removes an existing routing preference rule. Thrown if the index is out of bounds.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveRule(
    RoutingPreferenceRuleGroupType groupType,
    int index
)
Public Sub RemoveRule (
    groupType As RoutingPreferenceRuleGroupType,
    index As Integer
)
public:
void RemoveRule(
    RoutingPreferenceRuleGroupType groupType,
    int index
)
member RemoveRule :
        groupType : RoutingPreferenceRuleGroupType *
        index : int -> unit

Parameters

groupType RoutingPreferenceRuleGroupType
The routing preference group type in which the rule should be removed.
index Int32
The index position of removed routing preference rule in the group.
Exceptions
Exception | Condition
ArgumentException | index is not a valid zero-based index within groupType. -or-
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

RoutingPreferenceManager Class


RoutingPreferenceRule Class

A class representing a rule set in MEP routing preferences.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRoutingPreferenceRule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RoutingPreferenceRule : IDisposable
Public Class RoutingPreferenceRule
    Implements IDisposable
public ref class RoutingPreferenceRule : IDisposable
type RoutingPreferenceRule =
    class
        interface IDisposable
    end

The RoutingPreferenceRule type exposes the following members.

Constructors
 | Name | Description
Public method | RoutingPreferenceRule | Constructs a RoutingPreferenceRule containing a segment or fitting Id (MEPPartId) and description.
Top
Properties
 | Name | Description
Public property | Description | The description of the routing preference rule.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MEPPartId | The referenced MEPPart (segment or fitting) type in this rule. It may be InvalidElementId if no MEPPart will be allowed when the conditions satisfy the criteria in this rule.
Public property | NumberOfCriteria | Gets the number of routing criteria.
Public property | RoutingPreferenceManager | Gets the routing preference manager that owns this rule.
Top
Methods
 | Name | Description
Public method | AddCriterion | Adds a new routing criterion.
Public method | Dispose | Releases all resources used by the RoutingPreferenceRule
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCriterion | Gets the specified criteria.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | RemoveCriteron | Removes an existing criterion.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RoutingPreferenceRule Constructor

Constructs a RoutingPreferenceRule containing a segment or fitting Id (MEPPartId) and description.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RoutingPreferenceRule(
    ElementId MEPPartId,
    string description
)
Public Sub New (
    MEPPartId As ElementId,
    description As String
)
public:
RoutingPreferenceRule(
    ElementId^ MEPPartId,
    String^ description
)
new :
        MEPPartId : ElementId *
        description : string -> RoutingPreferenceRule

Parameters

MEPPartId ElementId
The Id of the segment or fitting. InvalidElementId may be specified if no MEPPart will be allowed when the conditions satisfy the criteria in this rule.
description String
The description of the rule.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

RoutingPreferenceRule Class


RoutingPreferenceRule Properties

The RoutingPreferenceRule type exposes the following members.

Properties
 | Name | Description
Public property | Description | The description of the routing preference rule.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MEPPartId | The referenced MEPPart (segment or fitting) type in this rule. It may be InvalidElementId if no MEPPart will be allowed when the conditions satisfy the criteria in this rule.
Public property | NumberOfCriteria | Gets the number of routing criteria.
Public property | RoutingPreferenceManager | Gets the routing preference manager that owns this rule.
Top
See Also

Reference

RoutingPreferenceRule Class


RoutingPreferenceRule.Description Property

RoutingPreferenceRuleDescription Property

The description of the routing preference rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get
public:
property String^ Description {
    String^ get ();
}
member Description : string with get

Property Value

String
See Also

Reference

RoutingPreferenceRule Class


RoutingPreferenceRule.IsValidObject Property

RoutingPreferenceRuleIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

RoutingPreferenceRule Class


RoutingPreferenceRule.MEPPartId Property

RoutingPreferenceRuleMEPPartId Property

The referenced MEPPart (segment or fitting) type in this rule. It may be InvalidElementId if no MEPPart will be allowed when the conditions satisfy the criteria in this rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId MEPPartId { get; }
Public ReadOnly Property MEPPartId As ElementId
    Get
public:
property ElementId^ MEPPartId {
    ElementId^ get ();
}
member MEPPartId : ElementId with get

Property Value

ElementId
See Also

Reference

RoutingPreferenceRule Class


RoutingPreferenceRule.NumberOfCriteria Property

RoutingPreferenceRuleNumberOfCriteria Property

Gets the number of routing criteria.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int NumberOfCriteria { get; }
Public ReadOnly Property NumberOfCriteria As Integer
    Get
public:
property int NumberOfCriteria {
    int get ();
}
member NumberOfCriteria : int with get

Property Value

Int32
See Also

Reference

RoutingPreferenceRule Class


RoutingPreferenceRule.RoutingPreferenceManager Property

RoutingPreferenceRuleRoutingPreferenceManager Property

Gets the routing preference manager that owns this rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RoutingPreferenceManager RoutingPreferenceManager { get; }
Public ReadOnly Property RoutingPreferenceManager As RoutingPreferenceManager
    Get
public:
property RoutingPreferenceManager^ RoutingPreferenceManager {
    RoutingPreferenceManager^ get ();
}
member RoutingPreferenceManager : RoutingPreferenceManager with get

Property Value

RoutingPreferenceManager
See Also

Reference

RoutingPreferenceRule Class


RoutingPreferenceRule Methods

The RoutingPreferenceRule type exposes the following members.

Methods
 | Name | Description
Public method | AddCriterion | Adds a new routing criterion.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCriterion | Gets the specified criteria.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | RemoveCriteron | Removes an existing criterion.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

RoutingPreferenceRule Class


RoutingPreferenceRule.AddCriterion Method

RoutingPreferenceRuleAddCriterion Method

Adds a new routing criterion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddCriterion(
    RoutingCriterionBase myCriterion
)
Public Sub AddCriterion (
    myCriterion As RoutingCriterionBase
)
public:
void AddCriterion(
    RoutingCriterionBase^ myCriterion
)
member AddCriterion :
        myCriterion : RoutingCriterionBase -> unit

Parameters

myCriterion RoutingCriterionBase
The criterion to add.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

RoutingPreferenceRule Class


RoutingPreferenceRule.Dispose Method

RoutingPreferenceRuleDispose Method

Releases all resources used by the RoutingPreferenceRule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

RoutingPreferenceRule Class


RoutingPreferenceRule.GetCriterion Method

RoutingPreferenceRuleGetCriterion Method

Gets the specified criteria.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RoutingCriterionBase GetCriterion(
    int index
)
Public Function GetCriterion (
    index As Integer
) As RoutingCriterionBase
public:
RoutingCriterionBase^ GetCriterion(
    int index
)
member GetCriterion :
        index : int -> RoutingCriterionBase

Parameters

index Int32

Return Value

RoutingCriterionBase
The criterion at the specified zero-based index position.
Exceptions
Exception | Condition
ArgumentException | index is not a valid zero-based index. -or- Thrown if the index is out of bounds.
See Also

Reference

RoutingPreferenceRule Class


RoutingPreferenceRule.RemoveCriteron Method

RoutingPreferenceRuleRemoveCriteron Method

Removes an existing criterion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveCriteron(
    int index
)
Public Sub RemoveCriteron (
    index As Integer
)
public:
void RemoveCriteron(
    int index
)
member RemoveCriteron :
        index : int -> unit

Parameters

index Int32
The index position of removed routing preference rule in the group.
Exceptions
Exception | Condition
ArgumentException | index is not a valid zero-based index. -or- Thrown if the index is out of bounds.
See Also

Reference

RoutingPreferenceRule Class


RoutingPreferenceRuleGroupType Enumeration

Add more rule group type here.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum RoutingPreferenceRuleGroupType
Public Enumeration RoutingPreferenceRuleGroupType
public enum class RoutingPreferenceRuleGroupType
type RoutingPreferenceRuleGroupType
Members
Member name | Value | Description
Segments | 0 | The segment types (e.g. pipe stocks)
Elbows | 1 | The elbow types.
Junctions | 2 | The junction types (e.g. takeoff, tee, wye, tap).
Crosses | 3 | The cross types.
Transitions | 4 | The transition types (Note that the multi-shape transitions may have their own groups).
Unions | 5 | The union types that connect two segments together.
MechanicalJoints | 6 | The mechanical joint types that connect fitting to fitting, segment to fitting, or segment to segment.
TransitionsRectangularToRound | 7 | The multi-shape transition from the rectangular profile to the round profile.
TransitionsRectangularToOval | 8 | The multi-shape transition from the rectangular profile to the oval profile.
TransitionsOvalToRound | 9 | The multi-shape transition from the oval profile to the round profile.
Undefined | -1 | The undefined group type, the default initial value.
Caps | 10 | The cap types
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RowHeightOverrideOptions Enumeration

Describes the options for overriding schedule body row heights (applied when viewed as a ScheduleSheetInstance on a ViewSheet).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum RowHeightOverrideOptions
Public Enumeration RowHeightOverrideOptions
public enum class RowHeightOverrideOptions
type RowHeightOverrideOptions
Members
Member name | Value | Description
None | 0 | No override would be applied for the row height.
All | 1 | Override row height for any body rows in the schedule.
ImageRows | 2 | Override row height for body rows containing images in the schedule.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RPCNode Class

This class represents an RPC content in a model-exporting process.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRenderNode
Autodesk.Revit.DBContentNode
Autodesk.Revit.DBRPCNode

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RPCNode : ContentNode
Public Class RPCNode
    Inherits ContentNode
public ref class RPCNode : public ContentNode
type RPCNode =
    class
        inherit ContentNode
    end

The RPCNode type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode)
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from RenderNode)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAsset | Returns an an instance of an Asset object, which contains definitions of the content node. (Inherited from ContentNode)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetTransform | A transformation matrix associated with the node. (Inherited from ContentNode)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
See also: OnRPC(RPCNode).
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RPCNode Properties

The RPCNode type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode)
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode)
Top
See Also

Reference

RPCNode Class


RPCNode Methods

The RPCNode type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from RenderNode)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAsset | Returns an an instance of an Asset object, which contains definitions of the content node. (Inherited from ContentNode)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetTransform | A transformation matrix associated with the node. (Inherited from ContentNode)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

RPCNode Class


RuledFace Class

A ruled face of a 3d solid or open shell.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGeometryObject
Autodesk.Revit.DBFace
Autodesk.Revit.DBRuledFace

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RuledFace : Face
Public Class RuledFace
    Inherits Face
public ref class RuledFace : public Face
type RuledFace =
    class
        inherit Face
    end

The RuledFace type exposes the following members.

Properties
 | Name | Description
Public property | Area | The area of this face. (Inherited from Face)
Public property | Curve | Profile curves of the surface.
Public property | EdgeLoops | A collection of edge loops. Each edge loop represents one of the closed boundaries of the face. (Inherited from Face)
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject)
Public property | HasRegions | Identifies if the face contains regions (which can be created, for example, by the Split Face command). (Inherited from Face)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject)
Public property | IsCyclic | Indicates whether the underlying surface is periodic in the specified parametric direction. (Inherited from Face)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject)
Public property | IsExtruded | Determines if this is an extruded ruled surface.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate). (Inherited from Face)
Public property | MaterialElementId | The element ID of the material from which this face is composed. (Inherited from Face)
Public property | OrientationMatchesSurfaceOrientation | Returns true if this face's orientation matches the orientation of the face's surface, false if they have opposite orientations. (Inherited from Face)
Public property | Period | The period of the underlying surface in the specified parametric direction. (Inherited from Face)
Public property | Point | Profile points of the surface.
Public property | Reference | Returns a stable reference to the face. (Inherited from Face)
Public property | RulingsAreParallel | Determines if the rulings of this ruled surface are parallel.
Public property | Visibility | The visibility. (Inherited from GeometryObject)
Top
Methods
 | Name | Description
Public method | ComputeDerivatives | Returns the first partial derivatives of the underlying surface at the specified point. (Inherited from Face)
Public method | ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face)
Public method | ComputeSecondDerivatives | Returns the second partial derivatives of the face at the specified point. (Inherited from Face)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject)
Public method | Evaluate | Evaluates and returns the XYZ coordinates of a point at the indicated UV parameterization of the face. (Inherited from Face)
Public method | GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face)
Public method | GetEdgesAsCurveLoops | Returns a list of closed curve loops that correspond to the edge loops of the face. Curves in each curve loop correspond to individual edges. (Inherited from Face)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject)
Public method | GetRegions | Gets the face regions (created, for example, by the Split Face command) of the face. (Inherited from Face)
Public method | GetSurface | Returns a copy of this face's surface. (Inherited from Face)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face)
Public method | Intersect(Face) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face)
Public method | Intersect(Curve, IntersectionResultArray) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face)
Public method | Intersect(Face, Curve) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face)
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face)
Public method | IsInside(UV, IntersectionResult) | Indicates whether the specified point is within this face and outputs additional information about the point location. (Inherited from Face)
Public method | Project | Projects the specified point on the face. (Inherited from Face)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
 | Triangulate | Returns a triangular mesh approximation to the face. (Inherited from Face)
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face. (Inherited from Face)
Top
Remarks
A ruled surface is created by sweeping a line between two profile curves or between a curve and a point (a point and a curve). For details on the parameterization, refer to the documentation for RuledSurface.
Example
C#
VB
C++
F#
Copy
private void GetRuledFaceInfo(Face face)
{
    RuledFace ruledFace = face as RuledFace;
    if (null != ruledFace)
    {
        Curve curve = ruledFace.get_Curve(0);
        XYZ point = ruledFace.get_Point(0);
    }
}
Private Sub GetRuledFaceInfo(face As Face)
    Dim ruledFace As RuledFace = TryCast(face, RuledFace)
    If ruledFace IsNot Nothing Then
        Dim curve As Curve = ruledFace.Curve(0)
        Dim point As XYZ = ruledFace.Point(0)
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RuledFace Properties

The RuledFace type exposes the following members.

Properties
 | Name | Description
Public property | Area | The area of this face. (Inherited from Face)
Public property | Curve | Profile curves of the surface.
Public property | EdgeLoops | A collection of edge loops. Each edge loop represents one of the closed boundaries of the face. (Inherited from Face)
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject)
Public property | HasRegions | Identifies if the face contains regions (which can be created, for example, by the Split Face command). (Inherited from Face)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject)
Public property | IsCyclic | Indicates whether the underlying surface is periodic in the specified parametric direction. (Inherited from Face)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject)
Public property | IsExtruded | Determines if this is an extruded ruled surface.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate). (Inherited from Face)
Public property | MaterialElementId | The element ID of the material from which this face is composed. (Inherited from Face)
Public property | OrientationMatchesSurfaceOrientation | Returns true if this face's orientation matches the orientation of the face's surface, false if they have opposite orientations. (Inherited from Face)
Public property | Period | The period of the underlying surface in the specified parametric direction. (Inherited from Face)
Public property | Point | Profile points of the surface.
Public property | Reference | Returns a stable reference to the face. (Inherited from Face)
Public property | RulingsAreParallel | Determines if the rulings of this ruled surface are parallel.
Public property | Visibility | The visibility. (Inherited from GeometryObject)
Top
See Also

Reference

RuledFace Class


RuledFace.Curve Property

RuledFaceCurve Property

Profile curves of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Curve this[
    int index
] { get; }
Public ReadOnly Property Curve (
    index As Integer
) As Curve
    Get
public:
property Curve^ Curve[int index] {
    Curve^ get (int index);
}
member Curve : Curve with get

Parameters

index Int32

Property Value

Curve
See Also

Reference

RuledFace Class


RuledFace.IsExtruded Property

RuledFaceIsExtruded Property

Determines if this is an extruded ruled surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsExtruded { get; }
Public ReadOnly Property IsExtruded As Boolean
    Get
public:
property bool IsExtruded {
    bool get ();
}
member IsExtruded : bool with get

Property Value

Boolean
See Also

Reference

RuledFace Class


RuledFace.Point Property

RuledFacePoint Property

Profile points of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ this[
    int index
] { get; }
Public ReadOnly Property Point (
    index As Integer
) As XYZ
    Get
public:
property XYZ^ Point[int index] {
    XYZ^ get (int index);
}
member Point : XYZ with get

Parameters

index Int32

Property Value

XYZ
See Also

Reference

RuledFace Class


RuledFace.RulingsAreParallel Property

RuledFaceRulingsAreParallel Property

Determines if the rulings of this ruled surface are parallel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool RulingsAreParallel { get; }
Public ReadOnly Property RulingsAreParallel As Boolean
    Get
public:
property bool RulingsAreParallel {
    bool get ();
}
member RulingsAreParallel : bool with get

Property Value

Boolean
See Also

Reference

RuledFace Class


RuledFace Methods

The RuledFace type exposes the following members.

Methods
 | Name | Description
Public method | ComputeDerivatives | Returns the first partial derivatives of the underlying surface at the specified point. (Inherited from Face)
Public method | ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face)
Public method | ComputeSecondDerivatives | Returns the second partial derivatives of the face at the specified point. (Inherited from Face)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject)
Public method | Evaluate | Evaluates and returns the XYZ coordinates of a point at the indicated UV parameterization of the face. (Inherited from Face)
Public method | GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face)
Public method | GetEdgesAsCurveLoops | Returns a list of closed curve loops that correspond to the edge loops of the face. Curves in each curve loop correspond to individual edges. (Inherited from Face)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject)
Public method | GetRegions | Gets the face regions (created, for example, by the Split Face command) of the face. (Inherited from Face)
Public method | GetSurface | Returns a copy of this face's surface. (Inherited from Face)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face)
Public method | Intersect(Face) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face)
Public method | Intersect(Curve, IntersectionResultArray) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face)
Public method | Intersect(Face, Curve) | Calculates the intersection of the specified face with this face and returns the intersection results. (Inherited from Face)
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face)
Public method | IsInside(UV, IntersectionResult) | Indicates whether the specified point is within this face and outputs additional information about the point location. (Inherited from Face)
Public method | Project | Projects the specified point on the face. (Inherited from Face)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
 | Triangulate | Returns a triangular mesh approximation to the face. (Inherited from Face)
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face. (Inherited from Face)
Top
See Also

Reference

RuledFace Class


RuledSurface Class

A ruled surface is created by sweeping a line between two profile curves or between a curve and a point (a point and a curve). Input curve(s) must be bounded or have natural bounds.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSurface
Autodesk.Revit.DBRuledSurface

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RuledSurface : Surface
Public Class RuledSurface
    Inherits Surface
public ref class RuledSurface : public Surface
type RuledSurface =
    class
        inherit Surface
    end

The RuledSurface type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Surface)
Public property | OrientationMatchesParametricOrientation | Indicates whether this Surface's orientation is the same as or opposite to its parametric orientation. (Inherited from Surface)
Top
Methods
 | Name | Description
 | Create(Curve, Curve) | Creates a Surface object coincident with the ruled surface joining two bounded generating curves.
 | Create(Curve, XYZ) | Creates a Surface object coincident with the ruled surface joining a bounded generating curve to a point.
Public method | Dispose | (Inherited from Surface)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBoundingBoxUV | Gets the UV bounding box of the surface. (Inherited from Surface)
Public method | GetFirstProfileCurve | Returns a copy of the first profile curve if it is set.
Public method | GetFirstProfilePoint | If a point was used to define the first profile, returns a copy of that point.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetSecondProfileCurve | Returns a copy of the second profile curve if it is set.
Public method | GetSecondProfilePoint | If a point was used to define the second profile, returns a copy of that point.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HasFirstProfilePoint | Checks if a point was used to define the first profile.
Public method | HasSecondProfilePoint | Checks if a point was used to define the second profile.
Public method | Project | Project a 3D point orthogonally onto a surface (to find the nearest point). Throws InvalidOperationException if the projection fails. (Inherited from Surface)
Public method | ProjectWithGuessPoint | Project a 3D point orthogonally onto a surface (to find the nearest point). This method is meant to be used when a good approximate solution for the projection is available. Throws InvalidOperationException if the projection fails. (Inherited from Surface)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Both curves are evaluated in normalized parameters [0, 1] The parametric equations of a ruled surface are:
  • Curve C1 and curve C2 : S(u, v) = C1(u) + v * (C2(u) - C1(u));
  • Point P1 and curve C2 : S(u, v) = P1 + v * (C2(u) - P1);
  • Curve C1 and point P2 : S(u, v) = C1(u) + v * (P2 - C1(u));
The point/point case is not allowed as that would define a degenerate ruled surface.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


RuledSurface Properties

The RuledSurface type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Surface)
Public property | OrientationMatchesParametricOrientation | Indicates whether this Surface's orientation is the same as or opposite to its parametric orientation. (Inherited from Surface)
Top
See Also

Reference

RuledSurface Class


RuledSurface Methods

The RuledSurface type exposes the following members.

Methods
 | Name | Description
 | Create(Curve, Curve) | Creates a Surface object coincident with the ruled surface joining two bounded generating curves.
 | Create(Curve, XYZ) | Creates a Surface object coincident with the ruled surface joining a bounded generating curve to a point.
Public method | Dispose | (Inherited from Surface)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBoundingBoxUV | Gets the UV bounding box of the surface. (Inherited from Surface)
Public method | GetFirstProfileCurve | Returns a copy of the first profile curve if it is set.
Public method | GetFirstProfilePoint | If a point was used to define the first profile, returns a copy of that point.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetSecondProfileCurve | Returns a copy of the second profile curve if it is set.
Public method | GetSecondProfilePoint | If a point was used to define the second profile, returns a copy of that point.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HasFirstProfilePoint | Checks if a point was used to define the first profile.
Public method | HasSecondProfilePoint | Checks if a point was used to define the second profile.
Public method | Project | Project a 3D point orthogonally onto a surface (to find the nearest point). Throws InvalidOperationException if the projection fails. (Inherited from Surface)
Public method | ProjectWithGuessPoint | Project a 3D point orthogonally onto a surface (to find the nearest point). This method is meant to be used when a good approximate solution for the projection is available. Throws InvalidOperationException if the projection fails. (Inherited from Surface)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

RuledSurface Class


RuledSurface.Create Method

RuledSurfaceCreate Method

Overload List
Name | Description
Create(Curve, Curve) | Creates a Surface object coincident with the ruled surface joining two bounded generating curves.
Create(Curve, XYZ) | Creates a Surface object coincident with the ruled surface joining a bounded generating curve to a point.
Top
See Also

Reference

RuledSurface Class


RuledSurface.Create(Curve, Curve) Method

RuledSurfaceCreate(Curve, Curve) Method

Creates a Surface object coincident with the ruled surface joining two bounded generating curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Surface Create(
    Curve profileCurve1,
    Curve profileCurve2
)
Public Shared Function Create (
    profileCurve1 As Curve,
    profileCurve2 As Curve
) As Surface
public:
static Surface^ Create(
    Curve^ profileCurve1,
    Curve^ profileCurve2
)
static member Create :
        profileCurve1 : Curve *
        profileCurve2 : Curve -> Surface

Parameters

profileCurve1 Curve
The first profile curve; must be bounded and non-degenerate.
profileCurve2 Curve
The second profile curve; must be bounded and non-degenerate.

Return Value

Surface
The created surface. Note that this surface may not be of type RuledSurf.
Exceptions
Exception | Condition
ArgumentException | The input profileCurve1 is not bound. -or- The profileCurve1 is degenerate (its length is too close to zero). -or- The input profileCurve2 is not bound. -or- The profileCurve2 is degenerate (its length is too close to zero).
ArgumentNullException | A non-optional argument was null
Remarks
The returned surface may not be of type RuledSurf - this function will create a surface of the simplest possible type (Plane, CylindricalSurface, etc.) that can be used to represent the given ruled surface. Given that the surface may be simplified, this function does not guarantee any particular parameterization of the surface. The curves should be such that a ruled surface whose rulings connect points on the two curves with the same normalized coordinates has no self-intersections or interior singularities.
See Also

Reference

RuledSurface Class
Create Overload


RuledSurface.Create(Curve, XYZ) Method

RuledSurfaceCreate(Curve, XYZ) Method

Creates a Surface object coincident with the ruled surface joining a bounded generating curve to a point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Surface Create(
    Curve profileCurve,
    XYZ point
)
Public Shared Function Create (
    profileCurve As Curve,
    point As XYZ
) As Surface
public:
static Surface^ Create(
    Curve^ profileCurve,
    XYZ^ point
)
static member Create :
        profileCurve : Curve *
        point : XYZ -> Surface

Parameters

profileCurve Curve
The profile curve; must be bounded and non-degenerate.
point XYZ
The point. Expected to lie within the Revit design limits IsWithinLengthLimits(XYZ).

Return Value

Surface
The created surface. Note that this surface may not be of type RuledSurf.
Exceptions
Exception | Condition
ArgumentException | The input profileCurve is not bound. -or- The profileCurve is degenerate (its length is too close to zero). -or- The input point lies outside of Revit design limits.
ArgumentNullException | A non-optional argument was null
Remarks
The returned surface may not be of type RuledSurf - this function will create a surface of the simplest possible type (Plane, CylindricalSurface, etc.) that can be used to represent the given ruled surface. Given that the surface may be simplified, this function does not guarantee any particular parameterization of the surface.
See Also

Reference

RuledSurface Class
Create Overload


RuledSurface.GetFirstProfileCurve Method

RuledSurfaceGetFirstProfileCurve Method

Returns a copy of the first profile curve if it is set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Curve GetFirstProfileCurve()
Public Function GetFirstProfileCurve As Curve
public:
Curve^ GetFirstProfileCurve()
member GetFirstProfileCurve : unit -> Curve

Return Value

Curve
A copy of the first profile curve, if it exists. If a point was used to define the first profile, this function will return .
See Also

Reference

RuledSurface Class


RuledSurface.GetFirstProfilePoint Method

RuledSurfaceGetFirstProfilePoint Method

If a point was used to define the first profile, returns a copy of that point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ GetFirstProfilePoint()
Public Function GetFirstProfilePoint As XYZ
public:
XYZ^ GetFirstProfilePoint()
member GetFirstProfilePoint : unit -> XYZ

Return Value

XYZ
The first profile point if it was set.
Exceptions
Exception | Condition
InvalidOperationException | This surface element does not use a point to define the first profile.
See Also

Reference

RuledSurface Class


RuledSurface.GetSecondProfileCurve Method

RuledSurfaceGetSecondProfileCurve Method

Returns a copy of the second profile curve if it is set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Curve GetSecondProfileCurve()
Public Function GetSecondProfileCurve As Curve
public:
Curve^ GetSecondProfileCurve()
member GetSecondProfileCurve : unit -> Curve

Return Value

Curve
A copy of the second profile curve, if it exists. If a point was used to define the second profile, this function will return .
See Also

Reference

RuledSurface Class


RuledSurface.GetSecondProfilePoint Method

RuledSurfaceGetSecondProfilePoint Method

If a point was used to define the second profile, returns a copy of that point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ GetSecondProfilePoint()
Public Function GetSecondProfilePoint As XYZ
public:
XYZ^ GetSecondProfilePoint()
member GetSecondProfilePoint : unit -> XYZ

Return Value

XYZ
The second profile point if it was set.
Exceptions
Exception | Condition
InvalidOperationException | This surface element does not use a point to define the second profile.
See Also

Reference

RuledSurface Class


RuledSurface.HasFirstProfilePoint Method

RuledSurfaceHasFirstProfilePoint Method

Checks if a point was used to define the first profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasFirstProfilePoint()
Public Function HasFirstProfilePoint As Boolean
public:
bool HasFirstProfilePoint()
member HasFirstProfilePoint : unit -> bool

Return Value

Boolean
True if a point was used to define the first profile, false otherwise.
See Also

Reference

RuledSurface Class


RuledSurface.HasSecondProfilePoint Method

RuledSurfaceHasSecondProfilePoint Method

Checks if a point was used to define the second profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasSecondProfilePoint()
Public Function HasSecondProfilePoint As Boolean
public:
bool HasSecondProfilePoint()
member HasSecondProfilePoint : unit -> bool

Return Value

Boolean
True if a point was used to define the second profile, false otherwise.
See Also

Reference

RuledSurface Class


SATExportOptions Class

The export options used by exporting SAT format file. So far, there is no option in it.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSATExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SATExportOptions : IDisposable
Public Class SATExportOptions
    Implements IDisposable
public ref class SATExportOptions : IDisposable
type SATExportOptions =
    class
        interface IDisposable
    end

The SATExportOptions type exposes the following members.

Constructors
 | Name | Description
Public method | SATExportOptions | Constructs a new instance of SATImportOptions with default values of all properties.
Public method | SATExportOptions(SATExportOptions) | Constructs a new instance of SATImportOptions as a copy of the export options.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the SATExportOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SATExportOptions Constructor

Overload List
 | Name | Description
Public method | SATExportOptions | Constructs a new instance of SATImportOptions with default values of all properties.
Public method | SATExportOptions(SATExportOptions) | Constructs a new instance of SATImportOptions as a copy of the export options.
Top
See Also

Reference

SATExportOptions Class


SATExportOptions Constructor

Constructs a new instance of SATImportOptions with default values of all properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SATExportOptions()
Public Sub New
public:
SATExportOptions()
new : unit -> SATExportOptions
See Also

Reference

SATExportOptions Class
SATExportOptions Overload


SATExportOptions(SATExportOptions) Constructor

Constructs a new instance of SATImportOptions as a copy of the export options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SATExportOptions(
    SATExportOptions option
)
Public Sub New (
    option As SATExportOptions
)
public:
SATExportOptions(
    SATExportOptions^ option
)
new :
        option : SATExportOptions -> SATExportOptions

Parameters

option SATExportOptions
The options to be copied.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

SATExportOptions Class
SATExportOptions Overload


SATExportOptions Properties

The SATExportOptions type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

SATExportOptions Class


SATExportOptions.IsValidObject Property

SATExportOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

SATExportOptions Class


SATExportOptions Methods

The SATExportOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SATExportOptions Class


SATExportOptions.Dispose Method

SATExportOptionsDispose Method

Releases all resources used by the SATExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

SATExportOptions Class


SATImportOptions Class

The import options used to import SAT format files.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBaseImportOptions
Autodesk.Revit.DBSATImportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SATImportOptions : BaseImportOptions
Public Class SATImportOptions
    Inherits BaseImportOptions
public ref class SATImportOptions : public BaseImportOptions
type SATImportOptions =
    class
        inherit BaseImportOptions
    end

The SATImportOptions type exposes the following members.

Constructors
 | Name | Description
Public method | SATImportOptions | Constructs a new instance of SATImportOptions with default values of all properties.
Public method | SATImportOptions(SATImportOptions) | Constructs a new instance of SATImportOptions as a copy of the import options.
Top
Properties
 | Name | Description
Public property | AutoCorrectAlmostVHLines | Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines. (Inherited from BaseImportOptions)
Public property | ColorMode | Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors. (Inherited from BaseImportOptions)
Public property | CustomScale | Scaling the import. If this is defined and a valid value (> 0.0), it takes priority over units. (Inherited from BaseImportOptions)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BaseImportOptions)
Public property | OrientToView | Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false) (Inherited from BaseImportOptions)
Public property | Placement | Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates. (Inherited from BaseImportOptions)
Public property | ReferencePoint | The 3D point in the document where the imported instance will be inserted. If not explicitly set, the instance will be inserted at the document origin. (Inherited from BaseImportOptions)
Public property | ThisViewOnly | Imports drawings into the view that was passed into the import method. This option is not available in 3D views. (Inherited from BaseImportOptions)
Public property | Unit | The unit of measure for imported geometry. (Inherited from BaseImportOptions)
Public property | VisibleLayersOnly | Only import the visible layers. (Inherited from BaseImportOptions)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from BaseImportOptions)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetDefaultLengthUnit | Get the default length unit used for importing unitless files. (Inherited from BaseImportOptions)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLayerSelection | Get all set layers name which user want to import into Revit. (Inherited from BaseImportOptions)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetDefaultLengthUnit | Set the default length unit used for importing unitless files. (Inherited from BaseImportOptions)
Public method | SetLayerSelection | Set the layers name which user want to import into Revit. (Inherited from BaseImportOptions)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SATImportOptions Constructor

Overload List
 | Name | Description
Public method | SATImportOptions | Constructs a new instance of SATImportOptions with default values of all properties.
Public method | SATImportOptions(SATImportOptions) | Constructs a new instance of SATImportOptions as a copy of the import options.
Top
See Also

Reference

SATImportOptions Class


SATImportOptions Constructor

Constructs a new instance of SATImportOptions with default values of all properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SATImportOptions()
Public Sub New
public:
SATImportOptions()
new : unit -> SATImportOptions
See Also

Reference

SATImportOptions Class
SATImportOptions Overload


SATImportOptions(SATImportOptions) Constructor

Constructs a new instance of SATImportOptions as a copy of the import options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SATImportOptions(
    SATImportOptions option
)
Public Sub New (
    option As SATImportOptions
)
public:
SATImportOptions(
    SATImportOptions^ option
)
new :
        option : SATImportOptions -> SATImportOptions

Parameters

option SATImportOptions
The SAT options to be copied.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

SATImportOptions Class
SATImportOptions Overload


SATImportOptions Properties

The SATImportOptions type exposes the following members.

Properties
 | Name | Description
Public property | AutoCorrectAlmostVHLines | Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines. (Inherited from BaseImportOptions)
Public property | ColorMode | Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors. (Inherited from BaseImportOptions)
Public property | CustomScale | Scaling the import. If this is defined and a valid value (> 0.0), it takes priority over units. (Inherited from BaseImportOptions)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BaseImportOptions)
Public property | OrientToView | Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false) (Inherited from BaseImportOptions)
Public property | Placement | Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates. (Inherited from BaseImportOptions)
Public property | ReferencePoint | The 3D point in the document where the imported instance will be inserted. If not explicitly set, the instance will be inserted at the document origin. (Inherited from BaseImportOptions)
Public property | ThisViewOnly | Imports drawings into the view that was passed into the import method. This option is not available in 3D views. (Inherited from BaseImportOptions)
Public property | Unit | The unit of measure for imported geometry. (Inherited from BaseImportOptions)
Public property | VisibleLayersOnly | Only import the visible layers. (Inherited from BaseImportOptions)
Top
See Also

Reference

SATImportOptions Class


SATImportOptions Methods

The SATImportOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from BaseImportOptions)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetDefaultLengthUnit | Get the default length unit used for importing unitless files. (Inherited from BaseImportOptions)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLayerSelection | Get all set layers name which user want to import into Revit. (Inherited from BaseImportOptions)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetDefaultLengthUnit | Set the default length unit used for importing unitless files. (Inherited from BaseImportOptions)
Public method | SetLayerSelection | Set the layers name which user want to import into Revit. (Inherited from BaseImportOptions)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SATImportOptions Class


SaveAsOptions Class

This class contains options available for saving a document to disk with a new filename.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSaveAsOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SaveAsOptions : IDisposable
Public Class SaveAsOptions
    Implements IDisposable
public ref class SaveAsOptions : IDisposable
type SaveAsOptions =
    class
        interface IDisposable
    end

The SaveAsOptions type exposes the following members.

Constructors
 | Name | Description
Public method | SaveAsOptions | Default constructor.
Top
Properties
 | Name | Description
Public property | Compact | Default is false: let the OS eliminate as much or as little dead data as it wants to. True: force the OS to eliminate all dead data from the file on disk.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MaximumBackups | The maximum number of backups to keep on disk.
Public property | OverwriteExistingFile | Identifies if the operation should be able to overwrite an existing file.
Public property | PreviewViewId | The view id that will be used to generate the preview; this id is not saved to the document's permanent settings.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the SaveAsOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetWorksharingOptions | Gets Worksharing options for SaveAs.
Public method | SetWorksharingOptions | Sets Worksharing options for SaveAs.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SaveAsOptions Constructor

Default constructor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SaveAsOptions()
Public Sub New
public:
SaveAsOptions()
new : unit -> SaveAsOptions
See Also

Reference

SaveAsOptions Class


SaveAsOptions Properties

The SaveAsOptions type exposes the following members.

Properties
 | Name | Description
Public property | Compact | Default is false: let the OS eliminate as much or as little dead data as it wants to. True: force the OS to eliminate all dead data from the file on disk.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MaximumBackups | The maximum number of backups to keep on disk.
Public property | OverwriteExistingFile | Identifies if the operation should be able to overwrite an existing file.
Public property | PreviewViewId | The view id that will be used to generate the preview; this id is not saved to the document's permanent settings.
Top
See Also

Reference

SaveAsOptions Class


SaveAsOptions.Compact Property

SaveAsOptionsCompact Property

Default is false: let the OS eliminate as much or as little dead data as it wants to. True: force the OS to eliminate all dead data from the file on disk.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Compact { get; set; }
Public Property Compact As Boolean
    Get
    Set
public:
property bool Compact {
    bool get ();
    void set (bool value);
}
member Compact : bool with get, set

Property Value

Boolean
See Also

Reference

SaveAsOptions Class


SaveAsOptions.IsValidObject Property

SaveAsOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

SaveAsOptions Class


SaveAsOptions.MaximumBackups Property

SaveAsOptionsMaximumBackups Property

The maximum number of backups to keep on disk.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int MaximumBackups { get; set; }
Public Property MaximumBackups As Integer
    Get
    Set
public:
property int MaximumBackups {
    int get ();
    void set (int value);
}
member MaximumBackups : int with get, set

Property Value

Int32

A positive number means to keep at most that many backups.

The default value of -1 means to use Revit's defaults: 3 for non-workshared, 20 for workshared. After initialization, the setter can be used to choose a positive number, but cannot be used to restore this default value.

Exceptions
Exception | Condition
ArgumentException | When setting this property: The requested number of backups is out of range.
Remarks

Non-workshared models have whole-file backups, sequentially numbered.

File-based workshared models have eager, incremental backups in a backup folder adjacent to the model itself: Every save backs up all changed data and avoids recopying unchanged elements, so the latest backup is equivalent to the main copy on disk and the backup folder does not have huge amounts of redundant data.

See Also

Reference

SaveAsOptions Class


SaveAsOptions.OverwriteExistingFile Property

SaveAsOptionsOverwriteExistingFile Property

Identifies if the operation should be able to overwrite an existing file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool OverwriteExistingFile { get; set; }
Public Property OverwriteExistingFile As Boolean
    Get
    Set
public:
property bool OverwriteExistingFile {
    bool get ();
    void set (bool value);
}
member OverwriteExistingFile : bool with get, set

Property Value

Boolean
True if the SaveAs operation should silently overwrite an existing target file, if it exists. False if the operation should fail if there is already a file at the target location. Default is false.
See Also

Reference

SaveAsOptions Class


SaveAsOptions.PreviewViewId Property

SaveAsOptionsPreviewViewId Property

The view id that will be used to generate the preview; this id is not saved to the document's permanent settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId PreviewViewId { get; set; }
Public Property PreviewViewId As ElementId
    Get
    Set
public:
property ElementId^ PreviewViewId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member PreviewViewId : ElementId with get, set

Property Value

ElementId
The id must be valid for use as a preview view (check DocumentPreviewSettings.IsValidPreviewViewId()). Revit does not check validity when setting this value, only when the options are used in a call to SaveAs(). Default is InvalidElementId.
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
If this id is set to a view id, the indicated view will be used to generate the preview even if DocumentPreviewSettings.PreviewViewId is also set.
See Also

Reference

SaveAsOptions Class


SaveAsOptions Methods

The SaveAsOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetWorksharingOptions | Gets Worksharing options for SaveAs.
Public method | SetWorksharingOptions | Sets Worksharing options for SaveAs.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SaveAsOptions Class


SaveAsOptions.Dispose Method

SaveAsOptionsDispose Method

Releases all resources used by the SaveAsOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

SaveAsOptions Class


SaveAsOptions.GetWorksharingOptions Method

SaveAsOptionsGetWorksharingOptions Method

Gets Worksharing options for SaveAs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WorksharingSaveAsOptions GetWorksharingOptions()
Public Function GetWorksharingOptions As WorksharingSaveAsOptions
public:
WorksharingSaveAsOptions^ GetWorksharingOptions()
member GetWorksharingOptions : unit -> WorksharingSaveAsOptions

Return Value

WorksharingSaveAsOptions
Defaults to . For a workshared model, if default values for WorksharingSaveAsOptions are used.
See Also

Reference

SaveAsOptions Class


SaveAsOptions.SetWorksharingOptions Method

SaveAsOptionsSetWorksharingOptions Method

Sets Worksharing options for SaveAs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetWorksharingOptions(
    WorksharingSaveAsOptions worksharingOptions
)
Public Sub SetWorksharingOptions (
    worksharingOptions As WorksharingSaveAsOptions
)
public:
void SetWorksharingOptions(
    WorksharingSaveAsOptions^ worksharingOptions
)
member SetWorksharingOptions :
        worksharingOptions : WorksharingSaveAsOptions -> unit

Parameters

worksharingOptions WorksharingSaveAsOptions

Must be for a non-workshared model.

Allowed to be for a workshared model, in which case default values for WorksharingSaveAsOptions are used.

See Also

Reference

SaveAsOptions Class


SaveModifiedLinksOptions Enumeration

Class giving options when saving linked files which have been modified in-memory by shared coordinates operations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum SaveModifiedLinksOptions
Public Enumeration SaveModifiedLinksOptions
public enum class SaveModifiedLinksOptions
type SaveModifiedLinksOptions
Members
Member name | Value | Description
SaveLinks | 0 | Any modified linked files will be saved.
DoNotSaveLinks | 1 | Any modified linked files will not be saved. The links will return to their previous position the next time the file is loaded.
DisableSharedPositioning | 2 | Any modified linked files will not be saved. Additionally, stop using shared positioning with any modified files.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SaveModifiedLinksOptionsForUnloadLocally Enumeration

Class giving options when saving linked files which are unloaded locally and have been modified in-memory by shared coordinates operations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum SaveModifiedLinksOptionsForUnloadLocally
Public Enumeration SaveModifiedLinksOptionsForUnloadLocally
public enum class SaveModifiedLinksOptionsForUnloadLocally
type SaveModifiedLinksOptionsForUnloadLocally
Members
Member name | Value | Description
SaveLinks | 0 | Any modified linked files will be saved.
DoNotSaveLinks | 1 | Any modified linked files will not be saved. The links will return to their previous position the next time the file is loaded.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SaveOptions Class

This class contains options available for saving a document to disk.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSaveOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SaveOptions : IDisposable
Public Class SaveOptions
    Implements IDisposable
public ref class SaveOptions : IDisposable
type SaveOptions =
    class
        interface IDisposable
    end

The SaveOptions type exposes the following members.

Constructors
 | Name | Description
Public method | SaveOptions | Default constructor.
Top
Properties
 | Name | Description
Public property | Compact | Default is false: let the OS eliminate as much or as little dead data as it wants to. True: force the OS to eliminate all dead data from the file on disk.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | PreviewViewId | The view id that will be used to generate the preview; this id is not saved to the document's permanent settings.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the SaveOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SaveOptions Constructor

Default constructor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SaveOptions()
Public Sub New
public:
SaveOptions()
new : unit -> SaveOptions
Remarks
PreviewViewId will be InvalidElementId.
See Also

Reference

SaveOptions Class


SaveOptions Properties

The SaveOptions type exposes the following members.

Properties
 | Name | Description
Public property | Compact | Default is false: let the OS eliminate as much or as little dead data as it wants to. True: force the OS to eliminate all dead data from the file on disk.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | PreviewViewId | The view id that will be used to generate the preview; this id is not saved to the document's permanent settings.
Top
See Also

Reference

SaveOptions Class


SaveOptions.Compact Property

SaveOptionsCompact Property

Default is false: let the OS eliminate as much or as little dead data as it wants to. True: force the OS to eliminate all dead data from the file on disk.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Compact { get; set; }
Public Property Compact As Boolean
    Get
    Set
public:
property bool Compact {
    bool get ();
    void set (bool value);
}
member Compact : bool with get, set

Property Value

Boolean
See Also

Reference

SaveOptions Class


SaveOptions.IsValidObject Property

SaveOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

SaveOptions Class


SaveOptions.PreviewViewId Property

SaveOptionsPreviewViewId Property

The view id that will be used to generate the preview; this id is not saved to the document's permanent settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId PreviewViewId { get; set; }
Public Property PreviewViewId As ElementId
    Get
    Set
public:
property ElementId^ PreviewViewId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member PreviewViewId : ElementId with get, set

Property Value

ElementId
The id must be valid for use as a preview view (check DocumentPreviewSettings.IsViewIdValidForPreview()). Revit does not check validity when setting this value, only when the options are used in a call to SaveAs().
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
If this id is set, the indicated view will be used to generate the preview even if DocumentPreviewSettings.PreviewViewId is also set.
See Also

Reference

SaveOptions Class


SaveOptions Methods

The SaveOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SaveOptions Class


SaveOptions.Dispose Method

SaveOptionsDispose Method

Releases all resources used by the SaveOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

SaveOptions Class


SchedulableField Class

A non-calculated field eligible to be included in a schedule.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSchedulableField

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SchedulableField : IDisposable
Public Class SchedulableField
    Implements IDisposable
public ref class SchedulableField : IDisposable
type SchedulableField =
    class
        interface IDisposable
    end

The SchedulableField type exposes the following members.

Constructors
 | Name | Description
Public method | SchedulableField | Creates a new SchedulableField.
Public method | SchedulableField(Guid) | Creates a new SchedulableField.
Public method | SchedulableField(ScheduleFieldType) | Creates a new SchedulableField.
Public method | SchedulableField(ScheduleFieldType, ElementId) | Creates a new SchedulableField.
Top
Properties
 | Name | Description
Public property | FieldType | The type of data displayed by the field.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ParameterId | The ID of the parameter displayed by the field.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the SchedulableField
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object))
Public method | GetCustomFieldData | Gets the data associated with this custom field. If this field isn't a CustomField will return .
Public method | GetHashCode | Gets the integer value of the SchedulableField as hash code (Overrides ObjectGetHashCode)
Public method | GetName | Gets the name of the field.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Operators
Name | Description
Equality(SchedulableField, SchedulableField) | Determines whether two SchedulableField are the same.
Inequality(SchedulableField, SchedulableField) | Determines whether two SchedulableField are different.
Top
Remarks
The SchedulableField class represents a non-calculated field that is eligible to be included in a schedule. A list of fields that can be included in a schedule can be obtained from ScheduleDefinition.GetSchedulableFields.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SchedulableField Constructor

Overload List
 | Name | Description
Public method | SchedulableField | Creates a new SchedulableField.
Public method | SchedulableField(Guid) | Creates a new SchedulableField.
Public method | SchedulableField(ScheduleFieldType) | Creates a new SchedulableField.
Public method | SchedulableField(ScheduleFieldType, ElementId) | Creates a new SchedulableField.
Top
See Also

Reference

SchedulableField Class


SchedulableField Constructor

Creates a new SchedulableField.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SchedulableField()
Public Sub New
public:
SchedulableField()
new : unit -> SchedulableField
See Also

Reference

SchedulableField Class
SchedulableField Overload


SchedulableField(Guid) Constructor

Creates a new SchedulableField.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SchedulableField(
    Guid customFieldId
)
Public Sub New (
    customFieldId As Guid
)
public:
SchedulableField(
    Guid customFieldId
)
new :
        customFieldId : Guid -> SchedulableField

Parameters

customFieldId Guid
The Guid that identifies the custom field.
Exceptions
Exception | Condition
ArgumentException | The provided guid doens't represent a valid custom field.
See Also

Reference

SchedulableField Class
SchedulableField Overload


SchedulableField(ScheduleFieldType) Constructor

Creates a new SchedulableField.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SchedulableField(
    ScheduleFieldType fieldType
)
Public Sub New (
    fieldType As ScheduleFieldType
)
public:
SchedulableField(
    ScheduleFieldType fieldType
)
new :
        fieldType : ScheduleFieldType -> SchedulableField

Parameters

fieldType ScheduleFieldType
The type of data displayed by the field.
Exceptions
Exception | Condition
ArgumentException | fieldType is not a schedulable field type -or- The fieldType can't be CustomField. To create a CustomField, you should use the constructor which receives the custom field server id as a parameter.
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

SchedulableField Class
SchedulableField Overload


SchedulableField(ScheduleFieldType, ElementId) Constructor

Creates a new SchedulableField.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SchedulableField(
    ScheduleFieldType fieldType,
    ElementId parameterId
)
Public Sub New (
    fieldType As ScheduleFieldType,
    parameterId As ElementId
)
public:
SchedulableField(
    ScheduleFieldType fieldType,
    ElementId^ parameterId
)
new :
        fieldType : ScheduleFieldType *
        parameterId : ElementId -> SchedulableField

Parameters

fieldType ScheduleFieldType
The type of data displayed by the field.
parameterId ElementId
The ID of the parameter displayed by the field.
Exceptions
Exception | Condition
ArgumentException | fieldType is not a schedulable field type -or- The fieldType can't be CustomField. To create a CustomField, you should use the constructor which receives the custom field server id as a parameter.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

SchedulableField Class
SchedulableField Overload


SchedulableField Properties

The SchedulableField type exposes the following members.

Properties
 | Name | Description
Public property | FieldType | The type of data displayed by the field.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ParameterId | The ID of the parameter displayed by the field.
Top
See Also

Reference

SchedulableField Class


SchedulableField.FieldType Property

SchedulableFieldFieldType Property

The type of data displayed by the field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScheduleFieldType FieldType { get; set; }
Public Property FieldType As ScheduleFieldType
    Get
    Set
public:
property ScheduleFieldType FieldType {
    ScheduleFieldType get ();
    void set (ScheduleFieldType value);
}
member FieldType : ScheduleFieldType with get, set

Property Value

ScheduleFieldType
See ScheduleFieldType for details.
Exceptions
Exception | Condition
ArgumentException | When setting this property: fieldType is not a schedulable field type
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

SchedulableField Class


SchedulableField.IsValidObject Property

SchedulableFieldIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

SchedulableField Class


SchedulableField.ParameterId Property

SchedulableFieldParameterId Property

The ID of the parameter displayed by the field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId ParameterId { get; set; }
Public Property ParameterId As ElementId
    Get
    Set
public:
property ElementId^ ParameterId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member ParameterId : ElementId with get, set

Property Value

ElementId
The parameter ID, or InvalidElementId.
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
Most non-calculated field types require a parameter ID. The Count field doesn't have a parameter ID.
See Also

Reference

SchedulableField Class


SchedulableField Methods

The SchedulableField type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object))
Public method | GetCustomFieldData | Gets the data associated with this custom field. If this field isn't a CustomField will return .
Public method | GetHashCode | Gets the integer value of the SchedulableField as hash code (Overrides ObjectGetHashCode)
Public method | GetName | Gets the name of the field.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SchedulableField Class


SchedulableField.Dispose Method

SchedulableFieldDispose Method

Releases all resources used by the SchedulableField

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

SchedulableField Class


SchedulableField.Equals Method

SchedulableFieldEquals Method

Determines whether the specified Object is equal to the current Object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj Object
The other object to evaluate.

Return Value

Boolean
See Also

Reference

SchedulableField Class


SchedulableField.GetCustomFieldData Method

SchedulableFieldGetCustomFieldData Method

Gets the data associated with this custom field. If this field isn't a CustomField will return .

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CustomFieldData GetCustomFieldData()
Public Function GetCustomFieldData As CustomFieldData
public:
CustomFieldData^ GetCustomFieldData()
member GetCustomFieldData : unit -> CustomFieldData

Return Value

CustomFieldData
Returns the data associated with this custom field. If this field isn't a CustomField will return .
See Also

Reference

SchedulableField Class


SchedulableField.GetHashCode Method

SchedulableFieldGetHashCode Method

Gets the integer value of the SchedulableField as hash code

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Int32
See Also

Reference

SchedulableField Class


SchedulableField.GetName Method

SchedulableFieldGetName Method

Gets the name of the field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetName(
    Document document
)
Public Function GetName (
    document As Document
) As String
public:
String^ GetName(
    Document^ document
)
member GetName :
        document : Document -> string

Parameters

document Document
The document in which the field will be used.

Return Value

String
The name of the field.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The parameter doesn't exist in document.
See Also

Reference

SchedulableField Class


SchedulableField Operators

The SchedulableField type exposes the following members.

Operators
Name | Description
Equality(SchedulableField, SchedulableField) | Determines whether two SchedulableField are the same.
Inequality(SchedulableField, SchedulableField) | Determines whether two SchedulableField are different.
Top
See Also

Reference

SchedulableField Class


SchedulableField.Equality Operator

SchedulableFieldEquality Operator

Determines whether two SchedulableField are the same.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool operator ==(
    SchedulableField first,
    SchedulableField second
)
Public Shared Operator = (
    first As SchedulableField,
    second As SchedulableField
) As Boolean
public:
static bool operator ==(
    SchedulableField^ first,
    SchedulableField^ second
)
static let inline (=)
        first : SchedulableField *
        second : SchedulableField  : bool

Parameters

first SchedulableField
The first SchedulableField.
second SchedulableField
The second SchedulableField.

Return Value

Boolean
True if the SchedulableField are the same, otherwise false.
See Also

Reference

SchedulableField Class


SchedulableField.Inequality Operator

SchedulableFieldInequality Operator

Determines whether two SchedulableField are different.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool operator !=(
    SchedulableField first,
    SchedulableField second
)
Public Shared Operator <> (
    first As SchedulableField,
    second As SchedulableField
) As Boolean
public:
static bool operator !=(
    SchedulableField^ first,
    SchedulableField^ second
)
static let inline (<>)
        first : SchedulableField *
        second : SchedulableField  : bool

Parameters

first SchedulableField
The first SchedulableField.
second SchedulableField
The second SchedulableField.

Return Value

Boolean
True if the SchedulableField are different, otherwise false.
See Also

Reference

SchedulableField Class


ScheduleDefinition Class

Settings that define the contents of a schedule.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBScheduleDefinition

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ScheduleDefinition : IDisposable
Public Class ScheduleDefinition
    Implements IDisposable
public ref class ScheduleDefinition : IDisposable
type ScheduleDefinition =
    class
        interface IDisposable
    end

The ScheduleDefinition type exposes the following members.

Properties
 | Name | Description
Public property | AreaSchemeId | In an area schedule, the ID of the area scheme to display.
Public property | CategoryId | The category ID of elements appearing in the schedule.
Public property | EmbeddedDefinition | The embedded ScheduleDefinition.
Public property | FamilyId | In a note block schedule, the ID of the Generic Annotation family displayed by the schedule.
Public property | GrandTotalTitle | The title name is used to display at the grand total row. The name is "Grand total", expressed in the Revit session language, by default.
Public property | HasEmbeddedSchedule | Indicates if this ScheduleDefinition has an embedded ScheduleDefinition.
Public property | IncludeLinkedFiles | Indicates if the schedule includes elements from linked files.
Public property | IsEmbedded | Indicates if this is an embedded ScheduleDefinition.
Public property | IsFilteredBySheet | Indicates if the schedule is set to filter by sheet.
Public property | IsItemized | Indicates if the schedule displays each element on a separate row or combines multiple grouped elements onto the same row.
Public property | IsKeySchedule | Indicates if the schedule is a key schedule.
Public property | IsMaterialTakeoff | Indicates if the schedule is a material takeoff.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ShowGrandTotal | Indicates if a grand total row should be displayed at the bottom of the schedule.
Public property | ShowGrandTotalCount | Indicates if the grand total row should display a count of elements in the schedule.
Public property | ShowGrandTotalTitle | Indicates if the grand total row should display a title.
Public property | ShowGridLines | Indicates if the schedule grid lines will be visible on a sheet.
Public property | ShowHeaders | Indicates if the headers will be displayed in the schedule.
Public property | ShowTitle | Indicates if the title will be displayed in the schedule.
Top
Methods
 | Name | Description
Public method | AddEmbeddedSchedule | Adds an embedded ScheduleDefinition.
 | AddField(SchedulableField) | Adds a regular field at the end of the list.
Public method | AddField(ScheduleFieldType) | Adds a regular field at the end of the list.
Public method | AddField(ScheduleFieldType, ElementId) | Adds a regular field at the end of the list.
 | AddFilter | Adds a new filter at the end of the list.
Public method | AddSortGroupField | Adds a new sorting/grouping field at the end of the list.
Public method | CanFilter | Checks whether filters can be added to this ScheduleDefinition.
Public method | CanFilterByGlobalParameters | Checks whether a field can be used with a global parameter-based filter.
Public method | CanFilterByParameterExistence | Checks whether a field can be used with a HasParameter filter.
Public method | CanFilterBySubstring | Checks whether a field can be used with a substring-based filter.
Public method | CanFilterByValue | Checks whether a field can be used with a value-based filter.
Public method | CanFilterByValuePresence | Checks whether a field can be used with a value presence-based filter.
Public method | CanHaveEmbeddedSchedule | Indicates if this ScheduleDefinition can have an embedded ScheduleDefinition added.
Public method | CanIncludeLinkedFiles | Checks whether the schedule is a type that supports including elements from linked files.
Public method | CanSortByField | Checks whether a field can be used for sorting/grouping.
Public method | ClearFields | Removes all fields.
Public method | ClearFilters | Removes all filters.
Public method | ClearSortGroupFields | Removes all sorting/grouping fields.
Public method | Dispose | Releases all resources used by the ScheduleDefinition
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetField(Int32) | Gets a field.
Public method | GetField(ScheduleFieldId) | Gets a field.
Public method | GetFieldCount | Gets the number of fields in this ScheduleDefinition.
Public method | GetFieldId | Converts a field index to the corresponding field ID.
Public method | GetFieldIndex | Converts a field ID to the corresponding field index.
Public method | GetFieldOrder | Gets the IDs of the current list of fields in order.
Public method | GetFilter | Gets a filter.
Public method | GetFilterCount | Gets the number of filters in this ScheduleDefinition.
Public method | GetFilters | Gets all filters in this ScheduleDefinition.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetSchedulableFields | Gets a list of all non-calculated/non-combined fields that are eligible to be included in this schedule.
Public method | GetSortGroupField | Gets a sorting/grouping field.
Public method | GetSortGroupFieldCount | Gets the number of sorting/grouping fields in this ScheduleDefinition.
Public method | GetSortGroupFields | Gets all sorting/grouping fields in this ScheduleDefinition.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetValidCategoriesForEmbeddedSchedule | Get all categories that can be used for an embedded ScheduleDefinition in this ScheduleDefinition.
Public method | InsertCombinedParameterField | Adds a combined parameter field at the specified position in the list.
Public method | InsertField(SchedulableField, Int32) | Adds a regular field at the specified position in the list.
Public method | InsertField(ScheduleFieldType, Int32) | Adds a regular field at the specified position in the list.
Public method | InsertField(ScheduleFieldType, ElementId, Int32) | Adds a regular field at the specified position in the list.
Public method | InsertFilter | Adds a new filter at the specified position in the list.
Public method | InsertSortGroupField | Adds a new sorting/grouping field at the specified position in the list.
Public method | IsSchedulableField | Checks whether a non-calculated/non-combined field is eligible to be included in this schedule.
Public method | IsValidCategoryForEmbeddedSchedule | Indicates if a category can be used for an embedded ScheduleDefinition in this ScheduleDefinition.
Public method | IsValidCategoryForFilterBySheet | Checks whether a schedule can be filtered by sheet.
Public method | IsValidCombinedParameters | Checks if data is valid for combined parameters
Public method | IsValidFieldId | Checks whether a ScheduleFieldId is the ID of a field in this ScheduleDefinition.
Public method | IsValidFieldIndex | Checks whether an integer is a valid zero-based field index in this ScheduleDefinition.
Public method | RemoveEmbeddedSchedule | Removes the embedded ScheduleDefinition.
Public method | RemoveField(Int32) | Removes a field.
Public method | RemoveField(ScheduleFieldId) | Removes a field.
Public method | RemoveFilter | Removes a filter.
Public method | RemoveSortGroupField | Removes a sorting/grouping field.
Public method | SetFieldOrder | Reorders the fields in the schedule.
Public method | SetFilter | Replaces a filter.
Public method | SetFilters | Replaces all filters in this ScheduleDefinition.
Public method | SetSortGroupField | Replaces a sorting/grouping field.
Public method | SetSortGroupFields | Replaces all sorting/grouping fields in this ScheduleDefinition.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

The ScheduleDefinition class contains various settings that define the contents of a schedule view, including:

  • The schedule's category and other basic properties that determine the type of schedule.
  • A set of fields that become the columns of the schedule.
  • Filters that restrict the set of elements visible in the schedule.
  • Sorting and grouping criteria.

Most schedules contain a single ScheduleDefinition. In Revit MEP, schedules of certain categories can contain an "embedded schedule" containing elements associated with the elements in the primary schedule, for example a room schedule showing the elements inside each room or a duct system schedule showing the elements associated with each system. An embedded schedule has its own category, fields, filters, etc. Those settings are stored in a second ScheduleDefinition object.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ScheduleDefinition Properties

The ScheduleDefinition type exposes the following members.

Properties
 | Name | Description
Public property | AreaSchemeId | In an area schedule, the ID of the area scheme to display.
Public property | CategoryId | The category ID of elements appearing in the schedule.
Public property | EmbeddedDefinition | The embedded ScheduleDefinition.
Public property | FamilyId | In a note block schedule, the ID of the Generic Annotation family displayed by the schedule.
Public property | GrandTotalTitle | The title name is used to display at the grand total row. The name is "Grand total", expressed in the Revit session language, by default.
Public property | HasEmbeddedSchedule | Indicates if this ScheduleDefinition has an embedded ScheduleDefinition.
Public property | IncludeLinkedFiles | Indicates if the schedule includes elements from linked files.
Public property | IsEmbedded | Indicates if this is an embedded ScheduleDefinition.
Public property | IsFilteredBySheet | Indicates if the schedule is set to filter by sheet.
Public property | IsItemized | Indicates if the schedule displays each element on a separate row or combines multiple grouped elements onto the same row.
Public property | IsKeySchedule | Indicates if the schedule is a key schedule.
Public property | IsMaterialTakeoff | Indicates if the schedule is a material takeoff.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ShowGrandTotal | Indicates if a grand total row should be displayed at the bottom of the schedule.
Public property | ShowGrandTotalCount | Indicates if the grand total row should display a count of elements in the schedule.
Public property | ShowGrandTotalTitle | Indicates if the grand total row should display a title.
Public property | ShowGridLines | Indicates if the schedule grid lines will be visible on a sheet.
Public property | ShowHeaders | Indicates if the headers will be displayed in the schedule.
Public property | ShowTitle | Indicates if the title will be displayed in the schedule.
Top
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.AreaSchemeId Property

ScheduleDefinitionAreaSchemeId Property

In an area schedule, the ID of the area scheme to display.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId AreaSchemeId { get; }
Public ReadOnly Property AreaSchemeId As ElementId
    Get
public:
property ElementId^ AreaSchemeId {
    ElementId^ get ();
}
member AreaSchemeId : ElementId with get

Property Value

ElementId
Remarks

Schedules of the Areas category show area elements belonging to a single area scheme.

Key schedules of the Areas category apply to all area schemes, so they don't have an area scheme ID.

See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.CategoryId Property

ScheduleDefinitionCategoryId Property

The category ID of elements appearing in the schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId CategoryId { get; }
Public ReadOnly Property CategoryId As ElementId
    Get
public:
property ElementId^ CategoryId {
    ElementId^ get ();
}
member CategoryId : ElementId with get

Property Value

ElementId
Remarks
Most schedules show elements of a single category. In multi-category schedules, the category ID is InvalidElementId. In key schedules, the schedule's category is the category of elements that the keys are associated with.
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.EmbeddedDefinition Property

ScheduleDefinitionEmbeddedDefinition Property

The embedded ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScheduleDefinition EmbeddedDefinition { get; }
Public ReadOnly Property EmbeddedDefinition As ScheduleDefinition
    Get
public:
property ScheduleDefinition^ EmbeddedDefinition {
    ScheduleDefinition^ get ();
}
member EmbeddedDefinition : ScheduleDefinition with get

Property Value

ScheduleDefinition
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.FamilyId Property

ScheduleDefinitionFamilyId Property

In a note block schedule, the ID of the Generic Annotation family displayed by the schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId FamilyId { get; }
Public ReadOnly Property FamilyId As ElementId
    Get
public:
property ElementId^ FamilyId {
    ElementId^ get ();
}
member FamilyId : ElementId with get

Property Value

ElementId
Remarks
A note block is a schedule of the Generic Annotations category that shows elements of a single family rather than all elements in the category.
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.GrandTotalTitle Property

ScheduleDefinitionGrandTotalTitle Property

The title name is used to display at the grand total row. The name is "Grand total", expressed in the Revit session language, by default.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GrandTotalTitle { get; set; }
Public Property GrandTotalTitle As String
    Get
    Set
public:
property String^ GrandTotalTitle {
    String^ get ();
    void set (String^ value);
}
member GrandTotalTitle : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
InvalidOperationException | When setting this property: Display of a grand total row is not enabled. -or- When setting this property: Display of grand total title is not enabled.
Remarks
GrandTotalTitle can only be set when both ShowGrandTotal and ShowGrandTotalTitle are enabled.
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.HasEmbeddedSchedule Property

ScheduleDefinitionHasEmbeddedSchedule Property

Indicates if this ScheduleDefinition has an embedded ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasEmbeddedSchedule { get; }
Public ReadOnly Property HasEmbeddedSchedule As Boolean
    Get
public:
property bool HasEmbeddedSchedule {
    bool get ();
}
member HasEmbeddedSchedule : bool with get

Property Value

Boolean
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.IncludeLinkedFiles Property

ScheduleDefinitionIncludeLinkedFiles Property

Indicates if the schedule includes elements from linked files.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IncludeLinkedFiles { get; set; }
Public Property IncludeLinkedFiles As Boolean
    Get
    Set
public:
property bool IncludeLinkedFiles {
    bool get ();
    void set (bool value);
}
member IncludeLinkedFiles : bool with get, set

Property Value

Boolean
True if elements in linked files should be included, false otherwise.
Exceptions
Exception | Condition
InvalidOperationException | When setting this property: This ScheduleDefinition does not support including elements from linked files. -or- When setting this property: This ScheduleDefinition is an embedded ScheduleDefinition.
Remarks
For an embedded ScheduleDefinition, this setting is controlled by the primary ScheduleDefinition and cannot be set in the embedded ScheduleDefinition.
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.IsEmbedded Property

ScheduleDefinitionIsEmbedded Property

Indicates if this is an embedded ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEmbedded { get; }
Public ReadOnly Property IsEmbedded As Boolean
    Get
public:
property bool IsEmbedded {
    bool get ();
}
member IsEmbedded : bool with get

Property Value

Boolean
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.IsFilteredBySheet Property

ScheduleDefinitionIsFilteredBySheet Property

Indicates if the schedule is set to filter by sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsFilteredBySheet { get; set; }
Public Property IsFilteredBySheet As Boolean
    Get
    Set
public:
property bool IsFilteredBySheet {
    bool get ();
    void set (bool value);
}
member IsFilteredBySheet : bool with get, set

Property Value

Boolean
Exceptions
Exception | Condition
InvalidOperationException | When setting this property: The schedule category is not supported to use filter by sheet. -or- When setting this property: The Schedule is split already.
Remarks
If the schedule is set to filter by sheet, and it is placed on a particular sheet, the instance created will present only the elements visible in the Viewport(s) on that sheet.
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.IsItemized Property

ScheduleDefinitionIsItemized Property

Indicates if the schedule displays each element on a separate row or combines multiple grouped elements onto the same row.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsItemized { get; set; }
Public Property IsItemized As Boolean
    Get
    Set
public:
property bool IsItemized {
    bool get ();
    void set (bool value);
}
member IsItemized : bool with get, set

Property Value

Boolean
True if the schedule displays each element on a separate row. False if multiple grouped elements are combined on the same row.
Exceptions
Exception | Condition
InvalidOperationException | When setting this property: This ScheduleDefinition is a key schedule.
Remarks

In an itemized schedule, each scheduled element is displayed on a separate row.

In a non-itemized schedule, elements that are grouped together according to the schedule's grouping criteria are combined onto a single row. For example, if a schedule is grouped by Level and Type, elements having the same Level and Type will appear on the same row. In non-itemized schedules, the Count field can be used to display the number of elements on the row, and totaled fields will display the sum of the values from all elements on the row. If a field is not totaled and the elements on the row have different values for the field, an empty cell will be displayed.

See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.IsKeySchedule Property

ScheduleDefinitionIsKeySchedule Property

Indicates if the schedule is a key schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsKeySchedule { get; }
Public ReadOnly Property IsKeySchedule As Boolean
    Get
public:
property bool IsKeySchedule {
    bool get ();
}
member IsKeySchedule : bool with get

Property Value

Boolean
Remarks
A key schedule displays abstract "key" elements that can be used to populate parameters of ordinary model elements.
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.IsMaterialTakeoff Property

ScheduleDefinitionIsMaterialTakeoff Property

Indicates if the schedule is a material takeoff.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsMaterialTakeoff { get; }
Public ReadOnly Property IsMaterialTakeoff As Boolean
    Get
public:
property bool IsMaterialTakeoff {
    bool get ();
}
member IsMaterialTakeoff : bool with get

Property Value

Boolean
Remarks
A material takeoff is a schedule that displays information about the materials that make up elements in the model. Unlike regular schedules where each row (before grouping) represents a single element, each row in a material takeoff represents a single <element, material> pair.
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.IsValidObject Property

ScheduleDefinitionIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.ShowGrandTotal Property

ScheduleDefinitionShowGrandTotal Property

Indicates if a grand total row should be displayed at the bottom of the schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShowGrandTotal { get; set; }
Public Property ShowGrandTotal As Boolean
    Get
    Set
public:
property bool ShowGrandTotal {
    bool get ();
    void set (bool value);
}
member ShowGrandTotal : bool with get, set

Property Value

Boolean
True if a grand total row should be displayed, false otherwise.
Remarks
The grand total row displays totals of each field for which totals are enabled. It can also optionally display a title (see ShowGrandTotalTitle) and a count of elements (see ShowGrandTotalCount).
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.ShowGrandTotalCount Property

ScheduleDefinitionShowGrandTotalCount Property

Indicates if the grand total row should display a count of elements in the schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShowGrandTotalCount { get; set; }
Public Property ShowGrandTotalCount As Boolean
    Get
    Set
public:
property bool ShowGrandTotalCount {
    bool get ();
    void set (bool value);
}
member ShowGrandTotalCount : bool with get, set

Property Value

Boolean
True if an element count should be displayed, false otherwise.
Exceptions
Exception | Condition
InvalidOperationException | When setting this property: Display of a grand total row is not enabled.
Remarks
ShowGrandTotalCount can only be enabled if ShowGrandTotal is enabled.
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.ShowGrandTotalTitle Property

ScheduleDefinitionShowGrandTotalTitle Property

Indicates if the grand total row should display a title.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShowGrandTotalTitle { get; set; }
Public Property ShowGrandTotalTitle As Boolean
    Get
    Set
public:
property bool ShowGrandTotalTitle {
    bool get ();
    void set (bool value);
}
member ShowGrandTotalTitle : bool with get, set

Property Value

Boolean
True if a title should be displayed, false otherwise.
Exceptions
Exception | Condition
InvalidOperationException | When setting this property: Display of a grand total row is not enabled.
Remarks

The title consists of the text "Grand total".

ShowGrandTotalTitle can only be enabled if ShowGrandTotal is enabled.

See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.ShowGridLines Property

ScheduleDefinitionShowGridLines Property

Indicates if the schedule grid lines will be visible on a sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShowGridLines { get; set; }
Public Property ShowGridLines As Boolean
    Get
    Set
public:
property bool ShowGridLines {
    bool get ();
    void set (bool value);
}
member ShowGridLines : bool with get, set

Property Value

Boolean
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.ShowHeaders Property

ScheduleDefinitionShowHeaders Property

Indicates if the headers will be displayed in the schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShowHeaders { get; set; }
Public Property ShowHeaders As Boolean
    Get
    Set
public:
property bool ShowHeaders {
    bool get ();
    void set (bool value);
}
member ShowHeaders : bool with get, set

Property Value

Boolean
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.ShowTitle Property

ScheduleDefinitionShowTitle Property

Indicates if the title will be displayed in the schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShowTitle { get; set; }
Public Property ShowTitle As Boolean
    Get
    Set
public:
property bool ShowTitle {
    bool get ();
    void set (bool value);
}
member ShowTitle : bool with get, set

Property Value

Boolean
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition Methods

The ScheduleDefinition type exposes the following members.

Methods
 | Name | Description
Public method | AddEmbeddedSchedule | Adds an embedded ScheduleDefinition.
 | AddField(SchedulableField) | Adds a regular field at the end of the list.
Public method | AddField(ScheduleFieldType) | Adds a regular field at the end of the list.
Public method | AddField(ScheduleFieldType, ElementId) | Adds a regular field at the end of the list.
 | AddFilter | Adds a new filter at the end of the list.
Public method | AddSortGroupField | Adds a new sorting/grouping field at the end of the list.
Public method | CanFilter | Checks whether filters can be added to this ScheduleDefinition.
Public method | CanFilterByGlobalParameters | Checks whether a field can be used with a global parameter-based filter.
Public method | CanFilterByParameterExistence | Checks whether a field can be used with a HasParameter filter.
Public method | CanFilterBySubstring | Checks whether a field can be used with a substring-based filter.
Public method | CanFilterByValue | Checks whether a field can be used with a value-based filter.
Public method | CanFilterByValuePresence | Checks whether a field can be used with a value presence-based filter.
Public method | CanHaveEmbeddedSchedule | Indicates if this ScheduleDefinition can have an embedded ScheduleDefinition added.
Public method | CanIncludeLinkedFiles | Checks whether the schedule is a type that supports including elements from linked files.
Public method | CanSortByField | Checks whether a field can be used for sorting/grouping.
Public method | ClearFields | Removes all fields.
Public method | ClearFilters | Removes all filters.
Public method | ClearSortGroupFields | Removes all sorting/grouping fields.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetField(Int32) | Gets a field.
Public method | GetField(ScheduleFieldId) | Gets a field.
Public method | GetFieldCount | Gets the number of fields in this ScheduleDefinition.
Public method | GetFieldId | Converts a field index to the corresponding field ID.
Public method | GetFieldIndex | Converts a field ID to the corresponding field index.
Public method | GetFieldOrder | Gets the IDs of the current list of fields in order.
Public method | GetFilter | Gets a filter.
Public method | GetFilterCount | Gets the number of filters in this ScheduleDefinition.
Public method | GetFilters | Gets all filters in this ScheduleDefinition.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetSchedulableFields | Gets a list of all non-calculated/non-combined fields that are eligible to be included in this schedule.
Public method | GetSortGroupField | Gets a sorting/grouping field.
Public method | GetSortGroupFieldCount | Gets the number of sorting/grouping fields in this ScheduleDefinition.
Public method | GetSortGroupFields | Gets all sorting/grouping fields in this ScheduleDefinition.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetValidCategoriesForEmbeddedSchedule | Get all categories that can be used for an embedded ScheduleDefinition in this ScheduleDefinition.
Public method | InsertCombinedParameterField | Adds a combined parameter field at the specified position in the list.
Public method | InsertField(SchedulableField, Int32) | Adds a regular field at the specified position in the list.
Public method | InsertField(ScheduleFieldType, Int32) | Adds a regular field at the specified position in the list.
Public method | InsertField(ScheduleFieldType, ElementId, Int32) | Adds a regular field at the specified position in the list.
Public method | InsertFilter | Adds a new filter at the specified position in the list.
Public method | InsertSortGroupField | Adds a new sorting/grouping field at the specified position in the list.
Public method | IsSchedulableField | Checks whether a non-calculated/non-combined field is eligible to be included in this schedule.
Public method | IsValidCategoryForEmbeddedSchedule | Indicates if a category can be used for an embedded ScheduleDefinition in this ScheduleDefinition.
Public method | IsValidCategoryForFilterBySheet | Checks whether a schedule can be filtered by sheet.
Public method | IsValidCombinedParameters | Checks if data is valid for combined parameters
Public method | IsValidFieldId | Checks whether a ScheduleFieldId is the ID of a field in this ScheduleDefinition.
Public method | IsValidFieldIndex | Checks whether an integer is a valid zero-based field index in this ScheduleDefinition.
Public method | RemoveEmbeddedSchedule | Removes the embedded ScheduleDefinition.
Public method | RemoveField(Int32) | Removes a field.
Public method | RemoveField(ScheduleFieldId) | Removes a field.
Public method | RemoveFilter | Removes a filter.
Public method | RemoveSortGroupField | Removes a sorting/grouping field.
Public method | SetFieldOrder | Reorders the fields in the schedule.
Public method | SetFilter | Replaces a filter.
Public method | SetFilters | Replaces all filters in this ScheduleDefinition.
Public method | SetSortGroupField | Replaces a sorting/grouping field.
Public method | SetSortGroupFields | Replaces all sorting/grouping fields in this ScheduleDefinition.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.AddEmbeddedSchedule Method

ScheduleDefinitionAddEmbeddedSchedule Method

Adds an embedded ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddEmbeddedSchedule(
    ElementId categoryId
)
Public Sub AddEmbeddedSchedule (
    categoryId As ElementId
)
public:
void AddEmbeddedSchedule(
    ElementId^ categoryId
)
member AddEmbeddedSchedule :
        categoryId : ElementId -> unit

Parameters

categoryId ElementId
The category ID of elements to display in the embedded schedule.
Exceptions
Exception | Condition
ArgumentException | categoryId is not the ID of a category that can be used for an embedded ScheduleDefinition in this ScheduleDefinition.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This ScheduleDefinition is not a kind of schedule that supports adding an embedded ScheduleDefinition. -or- This ScheduleDefinition already has an embedded ScheduleDefinition.
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.AddField Method

ScheduleDefinitionAddField Method

Overload List
 | Name | Description
 | AddField(SchedulableField) | Adds a regular field at the end of the list.
Public method | AddField(ScheduleFieldType) | Adds a regular field at the end of the list.
Public method | AddField(ScheduleFieldType, ElementId) | Adds a regular field at the end of the list.
Top
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.AddField(SchedulableField) Method

ScheduleDefinitionAddField(SchedulableField) Method

Adds a regular field at the end of the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScheduleField AddField(
    SchedulableField schedulableField
)
Public Function AddField (
    schedulableField As SchedulableField
) As ScheduleField
public:
ScheduleField^ AddField(
    SchedulableField^ schedulableField
)
member AddField :
        schedulableField : SchedulableField -> ScheduleField

Parameters

schedulableField SchedulableField
A SchedulableField object representing the field.

Return Value

ScheduleField
The new field.
Exceptions
Exception | Condition
ArgumentException | The field specified by schedulableField may not included in this ScheduleDefinition. -or- The field specified by schedulableField is already included in this ScheduleDefinition.
ArgumentNullException | A non-optional argument was null
Example
C#
VB
C++
F#
Copy
/// <summary>
/// Add fields to view schedule.
/// </summary>
/// <param name="schedules">List of view schedule.</param>
public void AddFieldToSchedule(Document document, List<ViewSchedule> schedules)
{
    using (Transaction transaction = new Transaction(document, "Adding fields to schedule"))
    {
        transaction.Start();

        foreach (ViewSchedule vs in schedules)
        {
           //Get all schedulable fields from view schedule definition.
           IList<SchedulableField> schedulableFields = vs.Definition.GetSchedulableFields();

           foreach (SchedulableField sf in schedulableFields)
           {
               bool fieldAlreadyAdded = false;
               //Get all schedule field ids
               IList<ScheduleFieldId> ids = vs.Definition.GetFieldOrder();
               foreach (ScheduleFieldId id in ids)
               {
                   // If the GetSchedulableField() method of gotten schedule field returns same
                   // schedulable field, it means the field is already added to the view schedule.
                   if (vs.Definition.GetField(id).GetSchedulableField() == sf)
                   {
                       fieldAlreadyAdded = true;
                       break;
                   }
               }

               //If schedulable field doesn't exist in view schedule, add it.
               if (fieldAlreadyAdded == false)
               {
                   vs.Definition.AddField(sf);
               }
           }
        }

        transaction.Commit();
    }
}
' <summary>
' Add fields to view schedule.
' </summary>
' <param name="schedules">List of view schedule.</param>
Public Sub AddFieldToSchedule(document As Document, schedules As List(Of ViewSchedule))
    Using transaction As New Transaction(document, "Adding fields to schedule")
        transaction.Start()

        For Each vs As ViewSchedule In schedules
            'Get all schedulable fields from view schedule definition.
            Dim schedulableFields As IList(Of SchedulableField) = vs.Definition.GetSchedulableFields()

            For Each sf As SchedulableField In schedulableFields
                Dim fieldAlreadyAdded As Boolean = False
                'Get all schedule field ids
                Dim ids As IList(Of ScheduleFieldId) = vs.Definition.GetFieldOrder()
                For Each id As ScheduleFieldId In ids
                    ' If the GetSchedulableField() method of gotten schedule field returns same
                    ' schedulable field, it means the field is already added to the view schedule.
                    If vs.Definition.GetField(id).GetSchedulableField() = sf Then
                        fieldAlreadyAdded = True
                        Exit For
                    End If
                Next

                'If schedulable field doesn't exist in view schedule, add it.
                If fieldAlreadyAdded = False Then
                    vs.Definition.AddField(sf)
                End If
            Next
        Next

        transaction.Commit()
    End Using
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

ScheduleDefinition Class
AddField Overload


ScheduleDefinition.AddField(ScheduleFieldType) Method

ScheduleDefinitionAddField(ScheduleFieldType) Method

Adds a regular field at the end of the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScheduleField AddField(
    ScheduleFieldType fieldType
)
Public Function AddField (
    fieldType As ScheduleFieldType
) As ScheduleField
public:
ScheduleField^ AddField(
    ScheduleFieldType fieldType
)
member AddField :
        fieldType : ScheduleFieldType -> ScheduleField

Parameters

fieldType ScheduleFieldType
The type of data displayed by the field.

Return Value

ScheduleField
The new field.
Exceptions
Exception | Condition
ArgumentException | The field specified by fieldType may not included in this ScheduleDefinition. -or- The field specified by fieldType is already included in this ScheduleDefinition. -or- The fieldType can't be CustomField. To add a CustomField, you should create a Schedulable field and add it.
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ScheduleDefinition Class
AddField Overload


ScheduleDefinition.AddField(ScheduleFieldType, ElementId) Method

ScheduleDefinitionAddField(ScheduleFieldType, ElementId) Method

Adds a regular field at the end of the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScheduleField AddField(
    ScheduleFieldType fieldType,
    ElementId parameterId
)
Public Function AddField (
    fieldType As ScheduleFieldType,
    parameterId As ElementId
) As ScheduleField
public:
ScheduleField^ AddField(
    ScheduleFieldType fieldType,
    ElementId^ parameterId
)
member AddField :
        fieldType : ScheduleFieldType *
        parameterId : ElementId -> ScheduleField

Parameters

fieldType ScheduleFieldType
The type of data displayed by the field.
parameterId ElementId
The ID of the parameter displayed by the field.

Return Value

ScheduleField
The new field.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
ArgumentsInconsistentException | The field specified by fieldType and parameterId may not included in this ScheduleDefinition. -or- The field specified by fieldType and parameterId is already included in this ScheduleDefinition.
See Also

Reference

ScheduleDefinition Class
AddField Overload


ScheduleDefinition.AddFilter Method

ScheduleDefinitionAddFilter Method

Adds a new filter at the end of the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddFilter(
    ScheduleFilter filter
)
Public Sub AddFilter (
    filter As ScheduleFilter
)
public:
void AddFilter(
    ScheduleFilter^ filter
)
member AddFilter :
        filter : ScheduleFilter -> unit

Parameters

filter ScheduleFilter
The filter to add.
Exceptions
Exception | Condition
ArgumentException | The field ID is not the ID of a field in this ScheduleDefinition. -or- The field and filter type cannot be used to filter this ScheduleDefinition. -or- The filter value is not valid for the field and filter type.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This ScheduleDefinition does not support filters. -or- The resulting filter count would be greater than 8.
Example
C#
VB
C++
F#
Copy
public static void AddFilterToSchedule(ViewSchedule schedule, ElementId levelId)
{
    // Find level field
    ScheduleDefinition definition = schedule.Definition;

    ScheduleField levelField = FindField(schedule, BuiltInParameter.ROOM_LEVEL_ID);

    // Add filter
    using (Transaction t = new Transaction(schedule.Document, "Add filter"))
    {
        t.Start();

        // If field not present, add it
        if (levelField == null)
        {
            levelField = definition.AddField(ScheduleFieldType.Instance, new ElementId(BuiltInParameter.ROOM_LEVEL_ID));
        }

        // Set field to hidden
        levelField.IsHidden = true;
        ScheduleFilter filter = new ScheduleFilter(levelField.FieldId, ScheduleFilterType.Equal, levelId);
        definition.AddFilter(filter);

        t.Commit();
    }
}

/// <summary>
/// Finds an existing ScheduleField matching the given parameter
/// </summary>
/// <param name="schedule"></param>
/// <param name="paramEnum"></param>
/// <returns></returns>
public static ScheduleField FindField(ViewSchedule schedule, BuiltInParameter paramEnum)
{
    ScheduleDefinition definition = schedule.Definition;
    ScheduleField foundField = null;
    ElementId paramId = new ElementId(paramEnum);

    foreach (ScheduleFieldId fieldId in definition.GetFieldOrder())
    {
        foundField = definition.GetField(fieldId);
        if (foundField.ParameterId == paramId)
        {
            return foundField;
        }
    }

    return null;
}
Public Shared Sub AddFilterToSchedule(schedule As ViewSchedule, levelId As ElementId)
    ' Find level field
    Dim definition As ScheduleDefinition = schedule.Definition

    Dim levelField As ScheduleField = FindField(schedule, BuiltInParameter.ROOM_LEVEL_ID)

    ' Add filter
    Using t As New Transaction(schedule.Document, "Add filter")
        t.Start()

        ' If field not present, add it
        If levelField Is Nothing Then
            levelField = definition.AddField(ScheduleFieldType.Instance, New ElementId(BuiltInParameter.ROOM_LEVEL_ID))
        End If

        ' Set field to hidden
        levelField.IsHidden = True
        Dim filter As New ScheduleFilter(levelField.FieldId, ScheduleFilterType.Equal, levelId)
        definition.AddFilter(filter)

        t.Commit()
    End Using
End Sub

' <summary>
' Finds an existing ScheduleField matching the given parameter
' </summary>
' <param name="schedule"></param>
' <param name="paramEnum"></param>
' <returns></returns>
Public Shared Function FindField(schedule As ViewSchedule, paramEnum As BuiltInParameter) As ScheduleField
    Dim definition As ScheduleDefinition = schedule.Definition
    Dim foundField As ScheduleField = Nothing
    Dim paramId As New ElementId(paramEnum)

    For Each fieldId As ScheduleFieldId In definition.GetFieldOrder()
        foundField = definition.GetField(fieldId)
        If foundField.ParameterId = paramId Then
            Return foundField
        End If
    Next

    Return Nothing
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.AddSortGroupField Method

ScheduleDefinitionAddSortGroupField Method

Adds a new sorting/grouping field at the end of the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddSortGroupField(
    ScheduleSortGroupField sortGroupField
)
Public Sub AddSortGroupField (
    sortGroupField As ScheduleSortGroupField
)
public:
void AddSortGroupField(
    ScheduleSortGroupField^ sortGroupField
)
member AddSortGroupField :
        sortGroupField : ScheduleSortGroupField -> unit

Parameters

sortGroupField ScheduleSortGroupField
The sorting/grouping field to add.
Exceptions
Exception | Condition
ArgumentException | The field ID is not the ID of a field in this ScheduleDefinition. -or- The field cannot be used for sorting/grouping.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The resulting sorting/grouping field count would be greater than 4.
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.CanFilter Method

ScheduleDefinitionCanFilter Method

Checks whether filters can be added to this ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanFilter()
Public Function CanFilter As Boolean
public:
bool CanFilter()
member CanFilter : unit -> bool

Return Value

Boolean
True if this ScheduleDefinition supports filters, false otherwise.
Remarks
Key schedules and revision schedules do not support filters.
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.CanFilterByGlobalParameters Method

ScheduleDefinitionCanFilterByGlobalParameters Method

Checks whether a field can be used with a global parameter-based filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanFilterByGlobalParameters(
    ScheduleFieldId fieldId
)
Public Function CanFilterByGlobalParameters (
    fieldId As ScheduleFieldId
) As Boolean
public:
bool CanFilterByGlobalParameters(
    ScheduleFieldId^ fieldId
)
member CanFilterByGlobalParameters :
        fieldId : ScheduleFieldId -> bool

Parameters

fieldId ScheduleFieldId
The ID of the field to check.

Return Value

Boolean
True if the field can be used with a global parameter-based filter, false otherwise.
Exceptions
Exception | Condition
ArgumentException | fieldId is not the ID of a field in this ScheduleDefinition.
ArgumentNullException | A non-optional argument was null
Remarks

The global parameter-based filter types are IsAsociatedWith, IsNotAssociatedWith.

Only parameters which have a compatible type with at least one existing global parameter can be filtered.

See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.CanFilterByParameterExistence Method

ScheduleDefinitionCanFilterByParameterExistence Method

Checks whether a field can be used with a HasParameter filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanFilterByParameterExistence(
    ScheduleFieldId fieldId
)
Public Function CanFilterByParameterExistence (
    fieldId As ScheduleFieldId
) As Boolean
public:
bool CanFilterByParameterExistence(
    ScheduleFieldId^ fieldId
)
member CanFilterByParameterExistence :
        fieldId : ScheduleFieldId -> bool

Parameters

fieldId ScheduleFieldId
The ID of the field to check.

Return Value

Boolean
True if the field can be used with a HasParameter filter, false otherwise.
Exceptions
Exception | Condition
ArgumentException | fieldId is not the ID of a field in this ScheduleDefinition.
ArgumentNullException | A non-optional argument was null
Remarks
The HasParameter filter type only supports shared parameters, and only with the Instance or ElementType field types.
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.CanFilterBySubstring Method

ScheduleDefinitionCanFilterBySubstring Method

Checks whether a field can be used with a substring-based filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanFilterBySubstring(
    ScheduleFieldId fieldId
)
Public Function CanFilterBySubstring (
    fieldId As ScheduleFieldId
) As Boolean
public:
bool CanFilterBySubstring(
    ScheduleFieldId^ fieldId
)
member CanFilterBySubstring :
        fieldId : ScheduleFieldId -> bool

Parameters

fieldId ScheduleFieldId
The ID of the field to check.

Return Value

Boolean
True if the field can be used with a substring-based filter, false otherwise.
Exceptions
Exception | Condition
ArgumentException | fieldId is not the ID of a field in this ScheduleDefinition.
ArgumentNullException | A non-optional argument was null
Remarks

The substring-based filter types are Contains, NotContains, BeginsWith, NonBeginsWith, EndsWith and NotEndsWith.

Only string parameters can be filtered by substring.

See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.CanFilterByValue Method

ScheduleDefinitionCanFilterByValue Method

Checks whether a field can be used with a value-based filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanFilterByValue(
    ScheduleFieldId fieldId
)
Public Function CanFilterByValue (
    fieldId As ScheduleFieldId
) As Boolean
public:
bool CanFilterByValue(
    ScheduleFieldId^ fieldId
)
member CanFilterByValue :
        fieldId : ScheduleFieldId -> bool

Parameters

fieldId ScheduleFieldId
The ID of the field to check.

Return Value

Boolean
True if the field can be used with a value based filter, false otherwise.
Exceptions
Exception | Condition
ArgumentException | fieldId is not the ID of a field in this ScheduleDefinition.
ArgumentNullException | A non-optional argument was null
Remarks

The value-based filter types are Equal, NotEqual, GreaterThan, GreaterThanOrEqual, LessThan and LessThanOrEqual.

Only certain types of parameters can be filtered by value.

Note that some fields (for example, Workset, Family, Type, Family and Type) only support Equal, NotEqual, but not GreaterThan, GreaterThanOrEqual, LessThan and LessThanOrEqual.

See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.CanFilterByValuePresence Method

ScheduleDefinitionCanFilterByValuePresence Method

Checks whether a field can be used with a value presence-based filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanFilterByValuePresence(
    ScheduleFieldId fieldId
)
Public Function CanFilterByValuePresence (
    fieldId As ScheduleFieldId
) As Boolean
public:
bool CanFilterByValuePresence(
    ScheduleFieldId^ fieldId
)
member CanFilterByValuePresence :
        fieldId : ScheduleFieldId -> bool

Parameters

fieldId ScheduleFieldId
The ID of the field to check.

Return Value

Boolean
True if the field can be used with a value presence filter, false otherwise.
Exceptions
Exception | Condition
ArgumentException | fieldId is not the ID of a field in this ScheduleDefinition.
ArgumentNullException | A non-optional argument was null
Remarks
The value presence filter types are HasValue and HasNoValue.
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.CanHaveEmbeddedSchedule Method

ScheduleDefinitionCanHaveEmbeddedSchedule Method

Indicates if this ScheduleDefinition can have an embedded ScheduleDefinition added.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanHaveEmbeddedSchedule()
Public Function CanHaveEmbeddedSchedule As Boolean
public:
bool CanHaveEmbeddedSchedule()
member CanHaveEmbeddedSchedule : unit -> bool

Return Value

Boolean
True if this ScheduleDefinition can have an embedded ScheduleDefinition, false otherwise.
Remarks

Only schedules of the following categories can have an embedded ScheduleDefinition:

  • Rooms
  • Spaces
  • Electrical Circuits
  • Duct Systems
  • Piping Systems
  • Mechanical Equipment Sets
  • MEP Fabrication Ductwork
  • Fabrication Ductwork Stiffeners

Key schedules cannot have embedded schedules.

See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.CanIncludeLinkedFiles Method

ScheduleDefinitionCanIncludeLinkedFiles Method

Checks whether the schedule is a type that supports including elements from linked files.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanIncludeLinkedFiles()
Public Function CanIncludeLinkedFiles As Boolean
public:
bool CanIncludeLinkedFiles()
member CanIncludeLinkedFiles : unit -> bool

Return Value

Boolean
True if elements from linked files can be included, false otherwise.
Remarks
Elements from linked files can be included in schedules of normal model elements and in sheet lists, but not in most other specialized kinds of schedules.
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.CanSortByField Method

ScheduleDefinitionCanSortByField Method

Checks whether a field can be used for sorting/grouping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanSortByField(
    ScheduleFieldId fieldId
)
Public Function CanSortByField (
    fieldId As ScheduleFieldId
) As Boolean
public:
bool CanSortByField(
    ScheduleFieldId^ fieldId
)
member CanSortByField :
        fieldId : ScheduleFieldId -> bool

Parameters

fieldId ScheduleFieldId
The ID of the field to check.

Return Value

Boolean
True if the field can be used for sorting/grouping, false otherwise.
Exceptions
Exception | Condition
ArgumentException | fieldId is not the ID of a field in this ScheduleDefinition.
ArgumentNullException | A non-optional argument was null
Remarks
Schedules cannot be sorted/grouped by the Count field, Percentage fields, or Formula fields that depend on Percentage fields because those types of fields don't have meaningful values until after sorting and grouping takes place.
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.ClearFields Method

ScheduleDefinitionClearFields Method

Removes all fields.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ClearFields()
Public Sub ClearFields
public:
void ClearFields()
member ClearFields : unit -> unit
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.ClearFilters Method

ScheduleDefinitionClearFilters Method

Removes all filters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ClearFilters()
Public Sub ClearFilters
public:
void ClearFilters()
member ClearFilters : unit -> unit
Exceptions
Exception | Condition
InvalidOperationException | This ScheduleDefinition does not support filters.
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.ClearSortGroupFields Method

ScheduleDefinitionClearSortGroupFields Method

Removes all sorting/grouping fields.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ClearSortGroupFields()
Public Sub ClearSortGroupFields
public:
void ClearSortGroupFields()
member ClearSortGroupFields : unit -> unit
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.Dispose Method

ScheduleDefinitionDispose Method

Releases all resources used by the ScheduleDefinition

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.GetField Method

ScheduleDefinitionGetField Method

Overload List
 | Name | Description
Public method | GetField(Int32) | Gets a field.
Public method | GetField(ScheduleFieldId) | Gets a field.
Top
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.GetField(Int32) Method

ScheduleDefinitionGetField(Int32) Method

Gets a field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScheduleField GetField(
    int index
)
Public Function GetField (
    index As Integer
) As ScheduleField
public:
ScheduleField^ GetField(
    int index
)
member GetField :
        index : int -> ScheduleField

Parameters

index Int32
The index of the field.

Return Value

ScheduleField
The field.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is not a valid field index in this ScheduleDefinition.
See Also

Reference

ScheduleDefinition Class
GetField Overload


ScheduleDefinition.GetField(ScheduleFieldId) Method

ScheduleDefinitionGetField(ScheduleFieldId) Method

Gets a field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScheduleField GetField(
    ScheduleFieldId fieldId
)
Public Function GetField (
    fieldId As ScheduleFieldId
) As ScheduleField
public:
ScheduleField^ GetField(
    ScheduleFieldId^ fieldId
)
member GetField :
        fieldId : ScheduleFieldId -> ScheduleField

Parameters

fieldId ScheduleFieldId
The ID of the field.

Return Value

ScheduleField
The field.
Exceptions
Exception | Condition
ArgumentException | fieldId is not the ID of a field in this ScheduleDefinition.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ScheduleDefinition Class
GetField Overload


ScheduleDefinition.GetFieldCount Method

ScheduleDefinitionGetFieldCount Method

Gets the number of fields in this ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetFieldCount()
Public Function GetFieldCount As Integer
public:
int GetFieldCount()
member GetFieldCount : unit -> int

Return Value

Int32
The number of fields.
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.GetFieldId Method

ScheduleDefinitionGetFieldId Method

Converts a field index to the corresponding field ID.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScheduleFieldId GetFieldId(
    int index
)
Public Function GetFieldId (
    index As Integer
) As ScheduleFieldId
public:
ScheduleFieldId^ GetFieldId(
    int index
)
member GetFieldId :
        index : int -> ScheduleFieldId

Parameters

index Int32
The field index.

Return Value

ScheduleFieldId
The field ID.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is not a valid field index in this ScheduleDefinition.
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.GetFieldIndex Method

ScheduleDefinitionGetFieldIndex Method

Converts a field ID to the corresponding field index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetFieldIndex(
    ScheduleFieldId fieldId
)
Public Function GetFieldIndex (
    fieldId As ScheduleFieldId
) As Integer
public:
int GetFieldIndex(
    ScheduleFieldId^ fieldId
)
member GetFieldIndex :
        fieldId : ScheduleFieldId -> int

Parameters

fieldId ScheduleFieldId
The field ID.

Return Value

Int32
The field index.
Exceptions
Exception | Condition
ArgumentException | fieldId is not the ID of a field in this ScheduleDefinition.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.GetFieldOrder Method

ScheduleDefinitionGetFieldOrder Method

Gets the IDs of the current list of fields in order.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ScheduleFieldId> GetFieldOrder()
Public Function GetFieldOrder As IList(Of ScheduleFieldId)
public:
IList<ScheduleFieldId^>^ GetFieldOrder()
member GetFieldOrder : unit -> IList<ScheduleFieldId>

Return Value

IList ScheduleFieldId
The IDs of the current list of fields.
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.GetFilter Method

ScheduleDefinitionGetFilter Method

Gets a filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScheduleFilter GetFilter(
    int index
)
Public Function GetFilter (
    index As Integer
) As ScheduleFilter
public:
ScheduleFilter^ GetFilter(
    int index
)
member GetFilter :
        index : int -> ScheduleFilter

Parameters

index Int32
The index of the filter.

Return Value

ScheduleFilter
A copy of the filter.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is not a valid filter index.
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.GetFilterCount Method

ScheduleDefinitionGetFilterCount Method

Gets the number of filters in this ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetFilterCount()
Public Function GetFilterCount As Integer
public:
int GetFilterCount()
member GetFilterCount : unit -> int

Return Value

Int32
The number of filters.
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.GetFilters Method

ScheduleDefinitionGetFilters Method

Gets all filters in this ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ScheduleFilter> GetFilters()
Public Function GetFilters As IList(Of ScheduleFilter)
public:
IList<ScheduleFilter^>^ GetFilters()
member GetFilters : unit -> IList<ScheduleFilter>

Return Value

IList ScheduleFilter
A list of all filters.
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.GetSchedulableFields Method

ScheduleDefinitionGetSchedulableFields Method

Gets a list of all non-calculated/non-combined fields that are eligible to be included in this schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<SchedulableField> GetSchedulableFields()
Public Function GetSchedulableFields As IList(Of SchedulableField)
public:
IList<SchedulableField^>^ GetSchedulableFields()
member GetSchedulableFields : unit -> IList<SchedulableField>

Return Value

IList SchedulableField
A list of SchedulableField objects representing the non-calculated/non-combined fields that may be included in the schedule.
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.GetSortGroupField Method

ScheduleDefinitionGetSortGroupField Method

Gets a sorting/grouping field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScheduleSortGroupField GetSortGroupField(
    int index
)
Public Function GetSortGroupField (
    index As Integer
) As ScheduleSortGroupField
public:
ScheduleSortGroupField^ GetSortGroupField(
    int index
)
member GetSortGroupField :
        index : int -> ScheduleSortGroupField

Parameters

index Int32
The index of the sorting/grouping field.

Return Value

ScheduleSortGroupField
A copy of the sorting/grouping field.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is not a valid sorting/grouping field index.
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.GetSortGroupFieldCount Method

ScheduleDefinitionGetSortGroupFieldCount Method

Gets the number of sorting/grouping fields in this ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetSortGroupFieldCount()
Public Function GetSortGroupFieldCount As Integer
public:
int GetSortGroupFieldCount()
member GetSortGroupFieldCount : unit -> int

Return Value

Int32
The number of sorting/grouping fields.
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.GetSortGroupFields Method

ScheduleDefinitionGetSortGroupFields Method

Gets all sorting/grouping fields in this ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ScheduleSortGroupField> GetSortGroupFields()
Public Function GetSortGroupFields As IList(Of ScheduleSortGroupField)
public:
IList<ScheduleSortGroupField^>^ GetSortGroupFields()
member GetSortGroupFields : unit -> IList<ScheduleSortGroupField>

Return Value

IList ScheduleSortGroupField
A list of all sorting/grouping fields.
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.GetValidCategoriesForEmbeddedSchedule Method

ScheduleDefinitionGetValidCategoriesForEmbeddedSchedule Method

Get all categories that can be used for an embedded ScheduleDefinition in this ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetValidCategoriesForEmbeddedSchedule()
Public Function GetValidCategoriesForEmbeddedSchedule As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetValidCategoriesForEmbeddedSchedule()
member GetValidCategoriesForEmbeddedSchedule : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
The IDs of all valid categories.
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.InsertCombinedParameterField Method

ScheduleDefinitionInsertCombinedParameterField Method

Adds a combined parameter field at the specified position in the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScheduleField InsertCombinedParameterField(
    IList<TableCellCombinedParameterData> data,
    string fieldName,
    int index
)
Public Function InsertCombinedParameterField (
    data As IList(Of TableCellCombinedParameterData),
    fieldName As String,
    index As Integer
) As ScheduleField
public:
ScheduleField^ InsertCombinedParameterField(
    IList<TableCellCombinedParameterData^>^ data,
    String^ fieldName,
    int index
)
member InsertCombinedParameterField :
        data : IList<TableCellCombinedParameterData> *
        fieldName : string *
        index : int -> ScheduleField

Parameters

data IList TableCellCombinedParameterData
The combined parameters array.
fieldName String
The field name.
index Int32
The index in the list of fields.

Return Value

ScheduleField
The new field.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | index is not a valid insert position.
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.InsertField Method

ScheduleDefinitionInsertField Method

Overload List
 | Name | Description
Public method | InsertField(SchedulableField, Int32) | Adds a regular field at the specified position in the list.
Public method | InsertField(ScheduleFieldType, Int32) | Adds a regular field at the specified position in the list.
Public method | InsertField(ScheduleFieldType, ElementId, Int32) | Adds a regular field at the specified position in the list.
Top
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.InsertField(SchedulableField, Int32) Method

ScheduleDefinitionInsertField(SchedulableField, Int32) Method

Adds a regular field at the specified position in the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScheduleField InsertField(
    SchedulableField schedulableField,
    int index
)
Public Function InsertField (
    schedulableField As SchedulableField,
    index As Integer
) As ScheduleField
public:
ScheduleField^ InsertField(
    SchedulableField^ schedulableField,
    int index
)
member InsertField :
        schedulableField : SchedulableField *
        index : int -> ScheduleField

Parameters

schedulableField SchedulableField
A SchedulableField object representing the field.
index Int32
The index in the list of fields.

Return Value

ScheduleField
The new field.
Exceptions
Exception | Condition
ArgumentException | The field specified by schedulableField may not included in this ScheduleDefinition. -or- The field specified by schedulableField is already included in this ScheduleDefinition.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | index is not a valid insert position.
See Also

Reference

ScheduleDefinition Class
InsertField Overload


ScheduleDefinition.InsertField(ScheduleFieldType, Int32) Method

ScheduleDefinitionInsertField(ScheduleFieldType, Int32) Method

Adds a regular field at the specified position in the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScheduleField InsertField(
    ScheduleFieldType fieldType,
    int index
)
Public Function InsertField (
    fieldType As ScheduleFieldType,
    index As Integer
) As ScheduleField
public:
ScheduleField^ InsertField(
    ScheduleFieldType fieldType,
    int index
)
member InsertField :
        fieldType : ScheduleFieldType *
        index : int -> ScheduleField

Parameters

fieldType ScheduleFieldType
The type of data displayed by the field.
index Int32
The index in the list of fields.

Return Value

ScheduleField
The new field.
Exceptions
Exception | Condition
ArgumentException | The field specified by fieldType may not included in this ScheduleDefinition. -or- The field specified by fieldType is already included in this ScheduleDefinition. -or- The fieldType can't be CustomField. To add a CustomField, you should create a Schedulable field and add it.
ArgumentOutOfRangeException | index is not a valid insert position. -or- A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ScheduleDefinition Class
InsertField Overload


ScheduleDefinition.InsertField(ScheduleFieldType, ElementId, Int32) Method

ScheduleDefinitionInsertField(ScheduleFieldType, ElementId, Int32) Method

Adds a regular field at the specified position in the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScheduleField InsertField(
    ScheduleFieldType fieldType,
    ElementId parameterId,
    int index
)
Public Function InsertField (
    fieldType As ScheduleFieldType,
    parameterId As ElementId,
    index As Integer
) As ScheduleField
public:
ScheduleField^ InsertField(
    ScheduleFieldType fieldType,
    ElementId^ parameterId,
    int index
)
member InsertField :
        fieldType : ScheduleFieldType *
        parameterId : ElementId *
        index : int -> ScheduleField

Parameters

fieldType ScheduleFieldType
The type of data displayed by the field.
parameterId ElementId
The ID of the parameter displayed by the field.
index Int32
The index in the list of fields.

Return Value

ScheduleField
The new field.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | index is not a valid insert position. -or- A value passed for an enumeration argument is not a member of that enumeration
ArgumentsInconsistentException | The field specified by fieldType and parameterId may not included in this ScheduleDefinition. -or- The field specified by fieldType and parameterId is already included in this ScheduleDefinition.
See Also

Reference

ScheduleDefinition Class
InsertField Overload


ScheduleDefinition.InsertFilter Method

ScheduleDefinitionInsertFilter Method

Adds a new filter at the specified position in the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void InsertFilter(
    ScheduleFilter filter,
    int index
)
Public Sub InsertFilter (
    filter As ScheduleFilter,
    index As Integer
)
public:
void InsertFilter(
    ScheduleFilter^ filter,
    int index
)
member InsertFilter :
        filter : ScheduleFilter *
        index : int -> unit

Parameters

filter ScheduleFilter
The filter to add.
index Int32
The index in the list of filters.
Exceptions
Exception | Condition
ArgumentException | The field ID is not the ID of a field in this ScheduleDefinition. -or- The field and filter type cannot be used to filter this ScheduleDefinition. -or- The filter value is not valid for the field and filter type.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | index is not a valid insert position.
InvalidOperationException | This ScheduleDefinition does not support filters. -or- The resulting filter count would be greater than 8.
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.InsertSortGroupField Method

ScheduleDefinitionInsertSortGroupField Method

Adds a new sorting/grouping field at the specified position in the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void InsertSortGroupField(
    ScheduleSortGroupField sortGroupField,
    int index
)
Public Sub InsertSortGroupField (
    sortGroupField As ScheduleSortGroupField,
    index As Integer
)
public:
void InsertSortGroupField(
    ScheduleSortGroupField^ sortGroupField,
    int index
)
member InsertSortGroupField :
        sortGroupField : ScheduleSortGroupField *
        index : int -> unit

Parameters

sortGroupField ScheduleSortGroupField
The sorting/grouping field to add.
index Int32
The index in the list of sorting/grouping fields.
Exceptions
Exception | Condition
ArgumentException | The field ID is not the ID of a field in this ScheduleDefinition. -or- The field cannot be used for sorting/grouping.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | index is not a valid insert position.
InvalidOperationException | The resulting sorting/grouping field count would be greater than 4.
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.IsSchedulableField Method

ScheduleDefinitionIsSchedulableField Method

Checks whether a non-calculated/non-combined field is eligible to be included in this schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSchedulableField(
    SchedulableField schedulableField
)
Public Function IsSchedulableField (
    schedulableField As SchedulableField
) As Boolean
public:
bool IsSchedulableField(
    SchedulableField^ schedulableField
)
member IsSchedulableField :
        schedulableField : SchedulableField -> bool

Parameters

schedulableField SchedulableField
The field to check.

Return Value

Boolean
True if the field may be included in the schedule, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.IsValidCategoryForEmbeddedSchedule Method

ScheduleDefinitionIsValidCategoryForEmbeddedSchedule Method

Indicates if a category can be used for an embedded ScheduleDefinition in this ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidCategoryForEmbeddedSchedule(
    ElementId categoryId
)
Public Function IsValidCategoryForEmbeddedSchedule (
    categoryId As ElementId
) As Boolean
public:
bool IsValidCategoryForEmbeddedSchedule(
    ElementId^ categoryId
)
member IsValidCategoryForEmbeddedSchedule :
        categoryId : ElementId -> bool

Parameters

categoryId ElementId
The category ID to check.

Return Value

Boolean
True if the category can be used for an embedded ScheduleDefinition, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.IsValidCategoryForFilterBySheet Method

ScheduleDefinitionIsValidCategoryForFilterBySheet Method

Checks whether a schedule can be filtered by sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidCategoryForFilterBySheet()
Public Function IsValidCategoryForFilterBySheet As Boolean
public:
bool IsValidCategoryForFilterBySheet()
member IsValidCategoryForFilterBySheet : unit -> bool

Return Value

Boolean
True if the schedule can be filtered by sheet, false otherwise.
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.IsValidCombinedParameters Method

ScheduleDefinitionIsValidCombinedParameters Method

Checks if data is valid for combined parameters

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidCombinedParameters(
    IList<TableCellCombinedParameterData> data
)
Public Function IsValidCombinedParameters (
    data As IList(Of TableCellCombinedParameterData)
) As Boolean
public:
bool IsValidCombinedParameters(
    IList<TableCellCombinedParameterData^>^ data
)
member IsValidCombinedParameters :
        data : IList<TableCellCombinedParameterData> -> bool

Parameters

data IList TableCellCombinedParameterData
data is array of TableCellCombinedParameterData to be set as combined parameters

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.IsValidFieldId Method

ScheduleDefinitionIsValidFieldId Method

Checks whether a ScheduleFieldId is the ID of a field in this ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidFieldId(
    ScheduleFieldId fieldId
)
Public Function IsValidFieldId (
    fieldId As ScheduleFieldId
) As Boolean
public:
bool IsValidFieldId(
    ScheduleFieldId^ fieldId
)
member IsValidFieldId :
        fieldId : ScheduleFieldId -> bool

Parameters

fieldId ScheduleFieldId
The field ID to check.

Return Value

Boolean
True if the field ID is valid, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.IsValidFieldIndex Method

ScheduleDefinitionIsValidFieldIndex Method

Checks whether an integer is a valid zero-based field index in this ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidFieldIndex(
    int index
)
Public Function IsValidFieldIndex (
    index As Integer
) As Boolean
public:
bool IsValidFieldIndex(
    int index
)
member IsValidFieldIndex :
        index : int -> bool

Parameters

index Int32
The field index to check.

Return Value

Boolean
True if the field index is valid, false otherwise.
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.RemoveEmbeddedSchedule Method

ScheduleDefinitionRemoveEmbeddedSchedule Method

Removes the embedded ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveEmbeddedSchedule()
Public Sub RemoveEmbeddedSchedule
public:
void RemoveEmbeddedSchedule()
member RemoveEmbeddedSchedule : unit -> unit
Exceptions
Exception | Condition
InvalidOperationException | This ScheduleDefinition does not have an embedded ScheduleDefinition.
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.RemoveField Method

ScheduleDefinitionRemoveField Method

Overload List
 | Name | Description
Public method | RemoveField(Int32) | Removes a field.
Public method | RemoveField(ScheduleFieldId) | Removes a field.
Top
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.RemoveField(Int32) Method

ScheduleDefinitionRemoveField(Int32) Method

Removes a field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveField(
    int index
)
Public Sub RemoveField (
    index As Integer
)
public:
void RemoveField(
    int index
)
member RemoveField :
        index : int -> unit

Parameters

index Int32
The index of the field to remove.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is not a valid field index in this ScheduleDefinition.
See Also

Reference

ScheduleDefinition Class
RemoveField Overload


ScheduleDefinition.RemoveField(ScheduleFieldId) Method

ScheduleDefinitionRemoveField(ScheduleFieldId) Method

Removes a field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveField(
    ScheduleFieldId fieldId
)
Public Sub RemoveField (
    fieldId As ScheduleFieldId
)
public:
void RemoveField(
    ScheduleFieldId^ fieldId
)
member RemoveField :
        fieldId : ScheduleFieldId -> unit

Parameters

fieldId ScheduleFieldId
The ID of the field to remove.
Exceptions
Exception | Condition
ArgumentException | fieldId is not the ID of a field in this ScheduleDefinition.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ScheduleDefinition Class
RemoveField Overload


ScheduleDefinition.RemoveFilter Method

ScheduleDefinitionRemoveFilter Method

Removes a filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveFilter(
    int index
)
Public Sub RemoveFilter (
    index As Integer
)
public:
void RemoveFilter(
    int index
)
member RemoveFilter :
        index : int -> unit

Parameters

index Int32
The index of the filter to remove.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is not a valid filter index.
InvalidOperationException | This ScheduleDefinition does not support filters.
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.RemoveSortGroupField Method

ScheduleDefinitionRemoveSortGroupField Method

Removes a sorting/grouping field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveSortGroupField(
    int index
)
Public Sub RemoveSortGroupField (
    index As Integer
)
public:
void RemoveSortGroupField(
    int index
)
member RemoveSortGroupField :
        index : int -> unit

Parameters

index Int32
The index of the sorting/grouping field to remove.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is not a valid sorting/grouping field index.
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.SetFieldOrder Method

ScheduleDefinitionSetFieldOrder Method

Reorders the fields in the schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetFieldOrder(
    IList<ScheduleFieldId> fieldIds
)
Public Sub SetFieldOrder (
    fieldIds As IList(Of ScheduleFieldId)
)
public:
void SetFieldOrder(
    IList<ScheduleFieldId^>^ fieldIds
)
member SetFieldOrder :
        fieldIds : IList<ScheduleFieldId> -> unit

Parameters

fieldIds IList ScheduleFieldId
The field IDs in a new order.
Exceptions
Exception | Condition
ArgumentException | fieldIds does not contain exactly the same field IDs as this ScheduleDefinition currently contains.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.SetFilter Method

ScheduleDefinitionSetFilter Method

Replaces a filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetFilter(
    int index,
    ScheduleFilter filter
)
Public Sub SetFilter (
    index As Integer,
    filter As ScheduleFilter
)
public:
void SetFilter(
    int index,
    ScheduleFilter^ filter
)
member SetFilter :
        index : int *
        filter : ScheduleFilter -> unit

Parameters

index Int32
The index of the filter to replace.
filter ScheduleFilter
The new filter.
Exceptions
Exception | Condition
ArgumentException | The field ID is not the ID of a field in this ScheduleDefinition. -or- The field and filter type cannot be used to filter this ScheduleDefinition. -or- The filter value is not valid for the field and filter type.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | index is not a valid filter index.
InvalidOperationException | This ScheduleDefinition does not support filters.
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.SetFilters Method

ScheduleDefinitionSetFilters Method

Replaces all filters in this ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetFilters(
    IList<ScheduleFilter> filters
)
Public Sub SetFilters (
    filters As IList(Of ScheduleFilter)
)
public:
void SetFilters(
    IList<ScheduleFilter^>^ filters
)
member SetFilters :
        filters : IList<ScheduleFilter> -> unit

Parameters

filters IList ScheduleFilter
The new list of filters.
Exceptions
Exception | Condition
ArgumentException | The resulting filter count would be greater than 8. -or- A field ID is not the ID of a field in this ScheduleDefinition. -or- A field and filter type cannot be used to filter this ScheduleDefinition. -or- A filter value is not valid for the field and filter type.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This ScheduleDefinition does not support filters.
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.SetSortGroupField Method

ScheduleDefinitionSetSortGroupField Method

Replaces a sorting/grouping field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetSortGroupField(
    int index,
    ScheduleSortGroupField sortGroupField
)
Public Sub SetSortGroupField (
    index As Integer,
    sortGroupField As ScheduleSortGroupField
)
public:
void SetSortGroupField(
    int index,
    ScheduleSortGroupField^ sortGroupField
)
member SetSortGroupField :
        index : int *
        sortGroupField : ScheduleSortGroupField -> unit

Parameters

index Int32
The index of the sorting/grouping field to replace.
sortGroupField ScheduleSortGroupField
The new sorting/grouping field.
Exceptions
Exception | Condition
ArgumentException | The field ID is not the ID of a field in this ScheduleDefinition. -or- The field cannot be used for sorting/grouping.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | index is not a valid sorting/grouping field index.
See Also

Reference

ScheduleDefinition Class


ScheduleDefinition.SetSortGroupFields Method

ScheduleDefinitionSetSortGroupFields Method

Replaces all sorting/grouping fields in this ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetSortGroupFields(
    IList<ScheduleSortGroupField> sortGroupFields
)
Public Sub SetSortGroupFields (
    sortGroupFields As IList(Of ScheduleSortGroupField)
)
public:
void SetSortGroupFields(
    IList<ScheduleSortGroupField^>^ sortGroupFields
)
member SetSortGroupFields :
        sortGroupFields : IList<ScheduleSortGroupField> -> unit

Parameters

sortGroupFields IList ScheduleSortGroupField
The new list of sorting/grouping fields.
Exceptions
Exception | Condition
ArgumentException | The resulting sorting/grouping field count would be greater than 4. -or- A field ID is not the ID of a field in this ScheduleDefinition. -or- A field cannot be used for sorting/grouping.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ScheduleDefinition Class


ScheduleField Class

A field in a schedule.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBScheduleField

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ScheduleField : IDisposable
Public Class ScheduleField
    Implements IDisposable
public ref class ScheduleField : IDisposable
type ScheduleField =
    class
        interface IDisposable
    end

The ScheduleField type exposes the following members.

Properties
 | Name | Description
Public property | ColumnHeading | The column heading text.
Public property | Definition | The ScheduleDefinition that this field belongs to.
Public property | DisplayType | Indicates the chosen display type for the field.
Public property | FieldId | The ID of the field in the containing ScheduleDefinition.
Public property | FieldIndex | The index of the field in the containing ScheduleDefinition.
Public property | FieldType | The type of data displayed by the field.
Public property | GridColumnWidth | The width of the column in the editable grid view, measured in feet.
Public property | HasSchedulableField | Identifies if this ScheduleField object has access to a SchedulableField. Calculated and combined parameter fields will not have the access.
Public property | HeadingOrientation | The orientation of the column heading text.
Public property | HorizontalAlignment | The horizontal alignment of the column's data.
Public property | IsCalculatedField | Indicates if the field is a calculated field (Formula or Percentage).
Public property | IsCombinedParameterField | Indicates if the field is a combined parameter field.
Public property | IsHidden | Indicates if the field is hidden in the schedule.
Public property | IsOverridden | Indicates if the field is overridden or not.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MultipleValuesCustomText | The custom multiple values text to be used when the schedule field displays multiple element values, used when MultipleValuesDisplayType is set to Custom.
Public property | MultipleValuesDisplayType | Determines the type of multiple value indication to be used when the schedule field displays multiple element values.
Public property | MultipleValuesText | The multiple values text to be used when the schedule field displays multiple element values, as specified by the display type MultipleValuesDisplayType.
Public property | ParameterId | The ID of the parameter displayed by the field.
Public property | PercentageBy | The ID of the grouped schedule field used to calculate percentage totals.
Public property | PercentageOf | The ID of the field to calculate percentages of.
Public property | Schedule | The schedule that this field belongs to.
Public property | SheetColumnWidth | The width of the column on a sheet, measured in feet.
Public property | TotalByAssemblyType | In an assembly schedule view, indicates if totals are calculated for all assembly instances of the same type or only for a single instance.
Public property | VerticalAlignment | The vertical alignment of the column's data.
Top
Methods
 | Name | Description
Public method | CanDisplayMinMax | Indicates if this field can display minimum and maximum values.
Public method | CanTotal | Indicates if totals can be enabled for this field.
Public method | CanTotalByAssemblyType | Indicates if totals by assembly type can be enabled for this field.
Public method | CreatesCircularReferences | Checks whether a field ID would create a circular chain of references when used by the PercentageOf property of this field.
Public method | Dispose | Releases all resources used by the ScheduleField
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCombinedParameters | Gets this field's combine parameter array if applicable
Public method | GetCustomFieldData | Gets the data associated with this custom field. If this field isn't a CustomField will return .
Public method | GetFormatOptions | Gets the FormatOptions to optionally override the default settings in the Units class.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetName | Gets the name of the field.
Public method | GetSchedulableField | Gets a SchedulableField object representing this field.
Public method | GetSpecTypeId | The spec describing values of this field, if applicable.
Public method | GetStyle | Gets the style of this field.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsValidCombinedParameters | Checks if data is valid for combined parameters
Public method | ResetOverride | Resets the override of this field.
Public method | SetCombinedParameters | Sets this field's combine parameter array if applicable
 | SetFormatOptions | Sets the FormatOptions to optionally override the default settings in the Units class.
Public method | SetStyle | Sets the style of this field.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

The ScheduleField class represents a single field in a ScheduleDefinition's list of fields. Each (non-hidden) field becomes a column in the schedule.

Most commonly, a field represents an instance or type parameter of elements appearing in the schedule. Some fields represent parameters of other related elements, like the room that a scheduled element belongs to. Fields can also represent data calculated from other fields in the schedule, specifically Formula and Percentage fields. Another type of field is Custom Field. For this one, the value for each row is computed based on the (sub)elements that are grouped on that row and can have a graphic representation when the schedule is placed on a sheet.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ScheduleField Properties

The ScheduleField type exposes the following members.

Properties
 | Name | Description
Public property | ColumnHeading | The column heading text.
Public property | Definition | The ScheduleDefinition that this field belongs to.
Public property | DisplayType | Indicates the chosen display type for the field.
Public property | FieldId | The ID of the field in the containing ScheduleDefinition.
Public property | FieldIndex | The index of the field in the containing ScheduleDefinition.
Public property | FieldType | The type of data displayed by the field.
Public property | GridColumnWidth | The width of the column in the editable grid view, measured in feet.
Public property | HasSchedulableField | Identifies if this ScheduleField object has access to a SchedulableField. Calculated and combined parameter fields will not have the access.
Public property | HeadingOrientation | The orientation of the column heading text.
Public property | HorizontalAlignment | The horizontal alignment of the column's data.
Public property | IsCalculatedField | Indicates if the field is a calculated field (Formula or Percentage).
Public property | IsCombinedParameterField | Indicates if the field is a combined parameter field.
Public property | IsHidden | Indicates if the field is hidden in the schedule.
Public property | IsOverridden | Indicates if the field is overridden or not.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MultipleValuesCustomText | The custom multiple values text to be used when the schedule field displays multiple element values, used when MultipleValuesDisplayType is set to Custom.
Public property | MultipleValuesDisplayType | Determines the type of multiple value indication to be used when the schedule field displays multiple element values.
Public property | MultipleValuesText | The multiple values text to be used when the schedule field displays multiple element values, as specified by the display type MultipleValuesDisplayType.
Public property | ParameterId | The ID of the parameter displayed by the field.
Public property | PercentageBy | The ID of the grouped schedule field used to calculate percentage totals.
Public property | PercentageOf | The ID of the field to calculate percentages of.
Public property | Schedule | The schedule that this field belongs to.
Public property | SheetColumnWidth | The width of the column on a sheet, measured in feet.
Public property | TotalByAssemblyType | In an assembly schedule view, indicates if totals are calculated for all assembly instances of the same type or only for a single instance.
Public property | VerticalAlignment | The vertical alignment of the column's data.
Top
See Also

Reference

ScheduleField Class


ScheduleField.ColumnHeading Property

ScheduleFieldColumnHeading Property

The column heading text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ColumnHeading { get; set; }
Public Property ColumnHeading As String
    Get
    Set
public:
property String^ ColumnHeading {
    String^ get ();
    void set (String^ value);
}
member ColumnHeading : string with get, set

Property Value

String
The heading text.
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
On initial creation of a ScheduleField, the column heading is initialized based on the field name (typically a parameter name).
See Also

Reference

ScheduleField Class


ScheduleField.Definition Property

ScheduleFieldDefinition Property

The ScheduleDefinition that this field belongs to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScheduleDefinition Definition { get; }
Public ReadOnly Property Definition As ScheduleDefinition
    Get
public:
property ScheduleDefinition^ Definition {
    ScheduleDefinition^ get ();
}
member Definition : ScheduleDefinition with get

Property Value

ScheduleDefinition
See Also

Reference

ScheduleField Class


ScheduleField.DisplayType Property

ScheduleFieldDisplayType Property

Indicates the chosen display type for the field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScheduleFieldDisplayType DisplayType { get; set; }
Public Property DisplayType As ScheduleFieldDisplayType
    Get
    Set
public:
property ScheduleFieldDisplayType DisplayType {
    ScheduleFieldDisplayType get ();
    void set (ScheduleFieldDisplayType value);
}
member DisplayType : ScheduleFieldDisplayType with get, set

Property Value

ScheduleFieldDisplayType

The display types are: Standard - standard display type; will not display anything for multiple elements with different values. Totals - In a non-itemized schedule, totals are displayed in regular rows when multiple elements appear on the same row. Min - In a non-itemized schedule, minimum value is displayed in regular rows when multiple elements appear on the same row. Max - In a non-itemized schedule, maximum value is displayed in regular rows when multiple elements appear on the same row. MinMax - In a non-itemized schedule, Minimum/Maximum values are displayed in regular rows when multiple elements appear on the same row.

Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | When setting this property: This ScheduleField cannot display minimum and maximum values. -or- When setting this property: This ScheduleField cannot be totaled.
Remarks

This replaces the hasTotals property from 2017. The hasTotals = true is same as DisplayType::Totals; hasTotals = false is the same as DisplayType::Standard. This also adds the ability to see Min/Max for grouped elements.

See Also

Reference

ScheduleField Class


ScheduleField.FieldId Property

ScheduleFieldFieldId Property

The ID of the field in the containing ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScheduleFieldId FieldId { get; }
Public ReadOnly Property FieldId As ScheduleFieldId
    Get
public:
property ScheduleFieldId^ FieldId {
    ScheduleFieldId^ get ();
}
member FieldId : ScheduleFieldId with get

Property Value

ScheduleFieldId
See Also

Reference

ScheduleField Class


ScheduleField.FieldIndex Property

ScheduleFieldFieldIndex Property

The index of the field in the containing ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int FieldIndex { get; }
Public ReadOnly Property FieldIndex As Integer
    Get
public:
property int FieldIndex {
    int get ();
}
member FieldIndex : int with get

Property Value

Int32
See Also

Reference

ScheduleField Class


ScheduleField.FieldType Property

ScheduleFieldFieldType Property

The type of data displayed by the field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScheduleFieldType FieldType { get; }
Public ReadOnly Property FieldType As ScheduleFieldType
    Get
public:
property ScheduleFieldType FieldType {
    ScheduleFieldType get ();
}
member FieldType : ScheduleFieldType with get

Property Value

ScheduleFieldType
See Also

Reference

ScheduleField Class


ScheduleField.GridColumnWidth Property

ScheduleFieldGridColumnWidth Property

The width of the column in the editable grid view, measured in feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GridColumnWidth { get; set; }
Public Property GridColumnWidth As Double
    Get
    Set
public:
property double GridColumnWidth {
    double get ();
    void set (double value);
}
member GridColumnWidth : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: gridColumnWidth is negative.
Remarks

In a schedule with an embedded ScheduleDefinition, a column may display two fields, one from each ScheduleDefinition. In that case, the larger of the two widths is used.

It is always aligned with the SheetColumnWidth.

See Also

Reference

ScheduleField Class


ScheduleField.HasSchedulableField Property

ScheduleFieldHasSchedulableField Property

Identifies if this ScheduleField object has access to a SchedulableField. Calculated and combined parameter fields will not have the access.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasSchedulableField { get; }
Public ReadOnly Property HasSchedulableField As Boolean
    Get
public:
property bool HasSchedulableField {
    bool get ();
}
member HasSchedulableField : bool with get

Property Value

Boolean
See Also

Reference

ScheduleField Class


ScheduleField.HeadingOrientation Property

ScheduleFieldHeadingOrientation Property

The orientation of the column heading text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScheduleHeadingOrientation HeadingOrientation { get; set; }
Public Property HeadingOrientation As ScheduleHeadingOrientation
    Get
    Set
public:
property ScheduleHeadingOrientation HeadingOrientation {
    ScheduleHeadingOrientation get ();
    void set (ScheduleHeadingOrientation value);
}
member HeadingOrientation : ScheduleHeadingOrientation with get, set

Property Value

ScheduleHeadingOrientation
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ScheduleField Class


ScheduleField.HorizontalAlignment Property

ScheduleFieldHorizontalAlignment Property

The horizontal alignment of the column's data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScheduleHorizontalAlignment HorizontalAlignment { get; set; }
Public Property HorizontalAlignment As ScheduleHorizontalAlignment
    Get
    Set
public:
property ScheduleHorizontalAlignment HorizontalAlignment {
    ScheduleHorizontalAlignment get ();
    void set (ScheduleHorizontalAlignment value);
}
member HorizontalAlignment : ScheduleHorizontalAlignment with get, set

Property Value

ScheduleHorizontalAlignment
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ScheduleField Class


ScheduleField.IsCalculatedField Property

ScheduleFieldIsCalculatedField Property

Indicates if the field is a calculated field (Formula or Percentage).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCalculatedField { get; }
Public ReadOnly Property IsCalculatedField As Boolean
    Get
public:
property bool IsCalculatedField {
    bool get ();
}
member IsCalculatedField : bool with get

Property Value

Boolean
See Also

Reference

ScheduleField Class


ScheduleField.IsCombinedParameterField Property

ScheduleFieldIsCombinedParameterField Property

Indicates if the field is a combined parameter field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCombinedParameterField { get; }
Public ReadOnly Property IsCombinedParameterField As Boolean
    Get
public:
property bool IsCombinedParameterField {
    bool get ();
}
member IsCombinedParameterField : bool with get

Property Value

Boolean
See Also

Reference

ScheduleField Class


ScheduleField.IsHidden Property

ScheduleFieldIsHidden Property

Indicates if the field is hidden in the schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsHidden { get; set; }
Public Property IsHidden As Boolean
    Get
    Set
public:
property bool IsHidden {
    bool get ();
    void set (bool value);
}
member IsHidden : bool with get, set

Property Value

Boolean
True if the field is hidden, false otherwise.
Remarks
A hidden field is not displayed in the schedule, but it can be used for filtering, sorting, grouping, and conditional formatting and can be referenced by Formula and Percentage fields.
See Also

Reference

ScheduleField Class


ScheduleField.IsOverridden Property

ScheduleFieldIsOverridden Property

Indicates if the field is overridden or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsOverridden { get; }
Public ReadOnly Property IsOverridden As Boolean
    Get
public:
property bool IsOverridden {
    bool get ();
}
member IsOverridden : bool with get

Property Value

Boolean
See Also

Reference

ScheduleField Class


ScheduleField.IsValidObject Property

ScheduleFieldIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ScheduleField Class


ScheduleField.MultipleValuesCustomText Property

ScheduleFieldMultipleValuesCustomText Property

The custom multiple values text to be used when the schedule field displays multiple element values, used when MultipleValuesDisplayType is set to Custom.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string MultipleValuesCustomText { get; set; }
Public Property MultipleValuesCustomText As String
    Get
    Set
public:
property String^ MultipleValuesCustomText {
    String^ get ();
    void set (String^ value);
}
member MultipleValuesCustomText : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ScheduleField Class


ScheduleField.MultipleValuesDisplayType Property

ScheduleFieldMultipleValuesDisplayType Property

Determines the type of multiple value indication to be used when the schedule field displays multiple element values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScheduleFieldMultipleValuesDisplayType MultipleValuesDisplayType { get; set; }
Public Property MultipleValuesDisplayType As ScheduleFieldMultipleValuesDisplayType
    Get
    Set
public:
property ScheduleFieldMultipleValuesDisplayType MultipleValuesDisplayType {
    ScheduleFieldMultipleValuesDisplayType get ();
    void set (ScheduleFieldMultipleValuesDisplayType value);
}
member MultipleValuesDisplayType : ScheduleFieldMultipleValuesDisplayType with get, set

Property Value

ScheduleFieldMultipleValuesDisplayType
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
The default display type is Project, indicating that the project [!:Autodesk::Revit::DB::MultipleValuesIndicationSettings::Value] setting will be used.
See Also

Reference

ScheduleField Class


ScheduleField.MultipleValuesText Property

ScheduleFieldMultipleValuesText Property

The multiple values text to be used when the schedule field displays multiple element values, as specified by the display type MultipleValuesDisplayType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string MultipleValuesText { get; }
Public ReadOnly Property MultipleValuesText As String
    Get
public:
property String^ MultipleValuesText {
    String^ get ();
}
member MultipleValuesText : string with get

Property Value

String
See Also

Reference

ScheduleField Class


ScheduleField.ParameterId Property

ScheduleFieldParameterId Property

The ID of the parameter displayed by the field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId ParameterId { get; }
Public ReadOnly Property ParameterId As ElementId
    Get
public:
property ElementId^ ParameterId {
    ElementId^ get ();
}
member ParameterId : ElementId with get

Property Value

ElementId
Remarks
Most field types require a parameter ID. Count, Formula, and Percentage fields don't have parameter IDs.
See Also

Reference

ScheduleField Class


ScheduleField.PercentageBy Property

ScheduleFieldPercentageBy Property

The ID of the grouped schedule field used to calculate percentage totals.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScheduleFieldId PercentageBy { get; set; }
Public Property PercentageBy As ScheduleFieldId
    Get
    Set
public:
property ScheduleFieldId^ PercentageBy {
    ScheduleFieldId^ get ();
    void set (ScheduleFieldId^ value);
}
member PercentageBy : ScheduleFieldId with get, set

Property Value

ScheduleFieldId
InvalidElementId or the ID of the grouped field.
Exceptions
Exception | Condition
ArgumentException | When setting this property: percentageBy is not InvalidScheduleFieldId or the ID of a field that the schedule is grouped by.
ArgumentNullException | When setting this property: A non-optional argument was null
InvalidOperationException | When setting this property: This ScheduleField is not a percentage field.
Remarks
A Percentage field calculates what percent of the total of another field each element represents. If PercentageBy is InvalidScheduleFieldId, the total is of all elements in the schedule. If PercentageBy is the ID of one of the fields that the schedule is grouped by, the total is of all elements in that group.
See Also

Reference

ScheduleField Class


ScheduleField.PercentageOf Property

ScheduleFieldPercentageOf Property

The ID of the field to calculate percentages of.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScheduleFieldId PercentageOf { get; set; }
Public Property PercentageOf As ScheduleFieldId
    Get
    Set
public:
property ScheduleFieldId^ PercentageOf {
    ScheduleFieldId^ get ();
    void set (ScheduleFieldId^ value);
}
member PercentageOf : ScheduleFieldId with get, set

Property Value

ScheduleFieldId
The ID of the field, or InvalidElementId.
Exceptions
Exception | Condition
ArgumentException | When setting this property: percentageOf is not InvalidScheduleFieldId or the ID of a field that can be used to calculated percentages. -or- When setting this property: percentageOf would create a circular chain of references.
ArgumentNullException | When setting this property: A non-optional argument was null
InvalidOperationException | When setting this property: This ScheduleField is not a percentage field.
Remarks

A Percentage field calculates what percent of the total of another field each element represents. PercentageOf is the ID of the field used to calculate percentages. If PercentageOf is InvalidScheduleFieldId, no data is displayed.

Percentages can only be calculated for numeric fields. The Count field and other percentage fields cannot be used to calculate percentages.

See Also

Reference

ScheduleField Class


ScheduleField.Schedule Property

ScheduleFieldSchedule Property

The schedule that this field belongs to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ViewSchedule Schedule { get; }
Public ReadOnly Property Schedule As ViewSchedule
    Get
public:
property ViewSchedule^ Schedule {
    ViewSchedule^ get ();
}
member Schedule : ViewSchedule with get

Property Value

ViewSchedule
See Also

Reference

ScheduleField Class


ScheduleField.SheetColumnWidth Property

ScheduleFieldSheetColumnWidth Property

The width of the column on a sheet, measured in feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double SheetColumnWidth { get; set; }
Public Property SheetColumnWidth As Double
    Get
    Set
public:
property double SheetColumnWidth {
    double get ();
    void set (double value);
}
member SheetColumnWidth : float with get, set

Property Value

Double
The width of the column.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: sheetColumnWidth is negative.
Remarks

In a schedule with an embedded ScheduleDefinition, a column may display two fields, one from each ScheduleDefinition. In that case, the larger of the two widths is used.

It is always aligned with the GridColumnWidth.

See Also

Reference

ScheduleField Class


ScheduleField.TotalByAssemblyType Property

ScheduleFieldTotalByAssemblyType Property

In an assembly schedule view, indicates if totals are calculated for all assembly instances of the same type or only for a single instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool TotalByAssemblyType { get; set; }
Public Property TotalByAssemblyType As Boolean
    Get
    Set
public:
property bool TotalByAssemblyType {
    bool get ();
    void set (bool value);
}
member TotalByAssemblyType : bool with get, set

Property Value

Boolean
True if totals are calculated for all assembly instances. False if totals are calculated for one instance.
Exceptions
Exception | Condition
InvalidOperationException | When setting this property: This ScheduleField cannot be totaled by assembly type. -or- When setting this property: Totals are not enabled for this ScheduleField.
See Also

Reference

ScheduleField Class


ScheduleField.VerticalAlignment Property

ScheduleFieldVerticalAlignment Property

The vertical alignment of the column's data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScheduleVerticalAlignment VerticalAlignment { get; set; }
Public Property VerticalAlignment As ScheduleVerticalAlignment
    Get
    Set
public:
property ScheduleVerticalAlignment VerticalAlignment {
    ScheduleVerticalAlignment get ();
    void set (ScheduleVerticalAlignment value);
}
member VerticalAlignment : ScheduleVerticalAlignment with get, set

Property Value

ScheduleVerticalAlignment
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ScheduleField Class


ScheduleField Methods

The ScheduleField type exposes the following members.

Methods
 | Name | Description
Public method | CanDisplayMinMax | Indicates if this field can display minimum and maximum values.
Public method | CanTotal | Indicates if totals can be enabled for this field.
Public method | CanTotalByAssemblyType | Indicates if totals by assembly type can be enabled for this field.
Public method | CreatesCircularReferences | Checks whether a field ID would create a circular chain of references when used by the PercentageOf property of this field.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCombinedParameters | Gets this field's combine parameter array if applicable
Public method | GetCustomFieldData | Gets the data associated with this custom field. If this field isn't a CustomField will return .
Public method | GetFormatOptions | Gets the FormatOptions to optionally override the default settings in the Units class.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetName | Gets the name of the field.
Public method | GetSchedulableField | Gets a SchedulableField object representing this field.
Public method | GetSpecTypeId | The spec describing values of this field, if applicable.
Public method | GetStyle | Gets the style of this field.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsValidCombinedParameters | Checks if data is valid for combined parameters
Public method | ResetOverride | Resets the override of this field.
Public method | SetCombinedParameters | Sets this field's combine parameter array if applicable
 | SetFormatOptions | Sets the FormatOptions to optionally override the default settings in the Units class.
Public method | SetStyle | Sets the style of this field.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ScheduleField Class


ScheduleField.CanDisplayMinMax Method

ScheduleFieldCanDisplayMinMax Method

Indicates if this field can display minimum and maximum values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanDisplayMinMax()
Public Function CanDisplayMinMax As Boolean
public:
bool CanDisplayMinMax()
member CanDisplayMinMax : unit -> bool

Return Value

Boolean
True if this field can display minimum and maximum values, false otherwise.
See Also

Reference

ScheduleField Class


ScheduleField.CanTotal Method

ScheduleFieldCanTotal Method

Indicates if totals can be enabled for this field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanTotal()
Public Function CanTotal As Boolean
public:
bool CanTotal()
member CanTotal : unit -> bool

Return Value

Boolean
True if this field can be totaled, false otherwise.
See Also

Reference

ScheduleField Class


ScheduleField.CanTotalByAssemblyType Method

ScheduleFieldCanTotalByAssemblyType Method

Indicates if totals by assembly type can be enabled for this field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanTotalByAssemblyType()
Public Function CanTotalByAssemblyType As Boolean
public:
bool CanTotalByAssemblyType()
member CanTotalByAssemblyType : unit -> bool

Return Value

Boolean
True if this field can be totaled by assembly type, false otherwise.
See Also

Reference

ScheduleField Class


ScheduleField.CreatesCircularReferences Method

ScheduleFieldCreatesCircularReferences Method

Checks whether a field ID would create a circular chain of references when used by the PercentageOf property of this field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CreatesCircularReferences(
    ScheduleFieldId fieldId
)
Public Function CreatesCircularReferences (
    fieldId As ScheduleFieldId
) As Boolean
public:
bool CreatesCircularReferences(
    ScheduleFieldId^ fieldId
)
member CreatesCircularReferences :
        fieldId : ScheduleFieldId -> bool

Parameters

fieldId ScheduleFieldId
The field ID to check.

Return Value

Boolean
True if the field ID would create a circular chain of references, false otherwise.
Exceptions
Exception | Condition
ArgumentException | fieldId is not InvalidScheduleFieldId or the ID of a field that can be used to calculated percentages.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ScheduleField Class


ScheduleField.Dispose Method

ScheduleFieldDispose Method

Releases all resources used by the ScheduleField

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ScheduleField Class


ScheduleField.GetCombinedParameters Method

ScheduleFieldGetCombinedParameters Method

Gets this field's combine parameter array if applicable

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<TableCellCombinedParameterData> GetCombinedParameters()
Public Function GetCombinedParameters As IList(Of TableCellCombinedParameterData)
public:
IList<TableCellCombinedParameterData^>^ GetCombinedParameters()
member GetCombinedParameters : unit -> IList<TableCellCombinedParameterData>

Return Value

IList TableCellCombinedParameterData
Gets array of TableCellCombinedParameterData with the combined parameters data
See Also

Reference

ScheduleField Class


ScheduleField.GetCustomFieldData Method

ScheduleFieldGetCustomFieldData Method

Gets the data associated with this custom field. If this field isn't a CustomField will return .

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CustomFieldData GetCustomFieldData()
Public Function GetCustomFieldData As CustomFieldData
public:
CustomFieldData^ GetCustomFieldData()
member GetCustomFieldData : unit -> CustomFieldData

Return Value

CustomFieldData
Returns the data associated with this custom field. If this field isn't a CustomField will return .
See Also

Reference

ScheduleField Class


ScheduleField.GetFormatOptions Method

ScheduleFieldGetFormatOptions Method

Gets the FormatOptions to optionally override the default settings in the Units class.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormatOptions GetFormatOptions()
Public Function GetFormatOptions As FormatOptions
public:
FormatOptions^ GetFormatOptions()
member GetFormatOptions : unit -> FormatOptions

Return Value

FormatOptions
A copy of the FormatOptions.
See Also

Reference

ScheduleField Class


ScheduleField.GetName Method

ScheduleFieldGetName Method

Gets the name of the field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetName()
Public Function GetName As String
public:
String^ GetName()
member GetName : unit -> string

Return Value

String
The name of the field.
See Also

Reference

ScheduleField Class


ScheduleField.GetSchedulableField Method

ScheduleFieldGetSchedulableField Method

Gets a SchedulableField object representing this field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SchedulableField GetSchedulableField()
Public Function GetSchedulableField As SchedulableField
public:
SchedulableField^ GetSchedulableField()
member GetSchedulableField : unit -> SchedulableField

Return Value

SchedulableField
The SchedulableField object.
Exceptions
Exception | Condition
InapplicableDataException | This ScheduleField is not a schedulable field by type(non-calculated/non-combined-parameter).
Remarks
A ScheduleableField cannot be obtained for: - Calculated fields - Combined parameters
See Also

Reference

ScheduleField Class


ScheduleField.GetSpecTypeId Method

ScheduleFieldGetSpecTypeId Method

The spec describing values of this field, if applicable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ForgeTypeId GetSpecTypeId()
Public Function GetSpecTypeId As ForgeTypeId
public:
ForgeTypeId^ GetSpecTypeId()
member GetSpecTypeId : unit -> ForgeTypeId

Return Value

ForgeTypeId
Identifier of the spec, or empty if the field does not represent a number with units.
See Also

Reference

ScheduleField Class


ScheduleField.GetStyle Method

ScheduleFieldGetStyle Method

Gets the style of this field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TableCellStyle GetStyle()
Public Function GetStyle As TableCellStyle
public:
TableCellStyle^ GetStyle()
member GetStyle : unit -> TableCellStyle

Return Value

TableCellStyle
See Also

Reference

ScheduleField Class


ScheduleField.IsValidCombinedParameters Method

ScheduleFieldIsValidCombinedParameters Method

Checks if data is valid for combined parameters

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidCombinedParameters(
    IList<TableCellCombinedParameterData> data
)
Public Function IsValidCombinedParameters (
    data As IList(Of TableCellCombinedParameterData)
) As Boolean
public:
bool IsValidCombinedParameters(
    IList<TableCellCombinedParameterData^>^ data
)
member IsValidCombinedParameters :
        data : IList<TableCellCombinedParameterData> -> bool

Parameters

data IList TableCellCombinedParameterData
data is array of TableCellCombinedParameterData to be set as combined parameters

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ScheduleField Class


ScheduleField.ResetOverride Method

ScheduleFieldResetOverride Method

Resets the override of this field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetOverride()
Public Sub ResetOverride
public:
void ResetOverride()
member ResetOverride : unit -> unit
See Also

Reference

ScheduleField Class


ScheduleField.SetCombinedParameters Method

ScheduleFieldSetCombinedParameters Method

Sets this field's combine parameter array if applicable

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetCombinedParameters(
    IList<TableCellCombinedParameterData> data
)
Public Sub SetCombinedParameters (
    data As IList(Of TableCellCombinedParameterData)
)
public:
void SetCombinedParameters(
    IList<TableCellCombinedParameterData^>^ data
)
member SetCombinedParameters :
        data : IList<TableCellCombinedParameterData> -> unit

Parameters

data IList TableCellCombinedParameterData
data is array of TableCellCombinedParameterData to be set as combined parameters
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ScheduleField Class


ScheduleField.SetFormatOptions Method

ScheduleFieldSetFormatOptions Method

Sets the FormatOptions to optionally override the default settings in the Units class.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetFormatOptions(
    FormatOptions formatOptions
)
Public Sub SetFormatOptions (
    formatOptions As FormatOptions
)
public:
void SetFormatOptions(
    FormatOptions^ formatOptions
)
member SetFormatOptions :
        formatOptions : FormatOptions -> unit

Parameters

formatOptions FormatOptions
The FormatOptions.
Exceptions
Exception | Condition
ArgumentException | The display unit in formatOptions is not a valid display unit for the unit type of this ScheduleField, or the rounding method in formatOptions is not set to Nearest. See UnitUtils.IsValidDisplayUnit(UnitType, DisplayUnitType), UnitUtils.GetValidDisplayUnits(UnitType) and FormatOptions.RoundingMethod.
ArgumentNullException | A non-optional argument was null
Remarks
See the UnitType property to determine the unit type of this field.
Example
C#
VB
C++
F#
Copy
// format length units to display in feet and inches format
public void FormatLengthFields(ViewSchedule schedule)
{
    int nFields = schedule.Definition.GetFieldCount();
    for (int n = 0; n < nFields; n++)
    {
        ScheduleField field = schedule.Definition.GetField(n);
        if (field.GetSpecTypeId() == SpecTypeId.Length)
        {
            FormatOptions formatOpts = new FormatOptions();
            formatOpts.UseDefault = false;
            formatOpts.SetUnitTypeId(UnitTypeId.FeetFractionalInches);
            field.SetFormatOptions(formatOpts);
        }
    }
}
' format length units to display in feet and inches format
Public Sub FormatLengthFields(schedule As ViewSchedule)
    Dim nFields As Integer = schedule.Definition.GetFieldCount()
    For n As Integer = 0 To nFields - 1
        Dim field As ScheduleField = schedule.Definition.GetField(n)
        If field.GetSpecTypeId().Equals(SpecTypeId.Length) Then
            Dim formatOpts As New FormatOptions()
            formatOpts.UseDefault = False
            formatOpts.SetUnitTypeId(UnitTypeId.FeetFractionalInches)
            field.SetFormatOptions(formatOpts)
        End If
    Next
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

ScheduleField Class


ScheduleField.SetStyle Method

ScheduleFieldSetStyle Method

Sets the style of this field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetStyle(
    TableCellStyle style
)
Public Sub SetStyle (
    style As TableCellStyle
)
public:
void SetStyle(
    TableCellStyle^ style
)
member SetStyle :
        style : TableCellStyle -> unit

Parameters

style TableCellStyle
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ScheduleField Class


ScheduleFieldDisplayType Enumeration

Display type of schedule field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ScheduleFieldDisplayType
Public Enumeration ScheduleFieldDisplayType
public enum class ScheduleFieldDisplayType
type ScheduleFieldDisplayType
Members
Member name | Value | Description
Standard | 0 | Standard: field setting for [!:Autodesk::Revit::DB::ScheduleField::MultipleValuesText] is displayed if the values of the elements are different, otherwise, the common value will be displayed
Totals | 1 | Calculates and displays the total value
MinMax | 2 | Calculates and displays the minimum and maximum values
Max | 3 | Calculates and displays the maximum value
Min | 4 | Calculates and displays the minimum value
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ScheduleFieldId Class

The ScheduleFieldId object is used as a unique identification for a field in a schedule.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBScheduleFieldId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ScheduleFieldId
Public Class ScheduleFieldId
public ref class ScheduleFieldId
type ScheduleFieldId = class end

The ScheduleFieldId type exposes the following members.

Constructors
 | Name | Description
Public method | ScheduleFieldId | Initializes a new instance of the ScheduleFieldId class
Top
Properties
 | Name | Description
Public property | IntegerValue | Provides the value of the ScheduleFieldId as an integer.
 | InvalidScheduleFieldId | Get the invalid ScheduleFieldId whose IntegerValue is -1.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object))
Public method | GetHashCode | Gets the integer value of the id as hash code (Overrides ObjectGetHashCode)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Gets a String representation of the integer value of the id. (Overrides ObjectToString)
Top
Operators
Name | Description
Equality(ScheduleFieldId, ScheduleFieldId) | Determines whether two ScheduleFieldIds are the same.
Inequality(ScheduleFieldId, ScheduleFieldId) | Determines whether two ScheduleFieldId are different.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ScheduleFieldId Constructor

Initializes a new instance of the ScheduleFieldId class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScheduleFieldId(
    int id
)
Public Sub New (
    id As Integer
)
public:
ScheduleFieldId(
    int id
)
new :
        id : int -> ScheduleFieldId

Parameters

id Int32
See Also

Reference

ScheduleFieldId Class


ScheduleFieldId Properties

The ScheduleFieldId type exposes the following members.

Properties
 | Name | Description
Public property | IntegerValue | Provides the value of the ScheduleFieldId as an integer.
 | InvalidScheduleFieldId | Get the invalid ScheduleFieldId whose IntegerValue is -1.
Top
See Also

Reference

ScheduleFieldId Class


ScheduleFieldId.IntegerValue Property

ScheduleFieldIdIntegerValue Property

Provides the value of the ScheduleFieldId as an integer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int IntegerValue { get; }
Public ReadOnly Property IntegerValue As Integer
    Get
public:
property int IntegerValue {
    int get ();
}
member IntegerValue : int with get

Property Value

Int32
See Also

Reference

ScheduleFieldId Class


ScheduleFieldId.InvalidScheduleFieldId Property

ScheduleFieldIdInvalidScheduleFieldId Property

Get the invalid ScheduleFieldId whose IntegerValue is -1.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ScheduleFieldId InvalidScheduleFieldId { get; }
Public Shared ReadOnly Property InvalidScheduleFieldId As ScheduleFieldId
    Get
public:
static property ScheduleFieldId^ InvalidScheduleFieldId {
    ScheduleFieldId^ get ();
}
static member InvalidScheduleFieldId : ScheduleFieldId with get

Property Value

ScheduleFieldId
See Also

Reference

ScheduleFieldId Class


ScheduleFieldId Methods

The ScheduleFieldId type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object))
Public method | GetHashCode | Gets the integer value of the id as hash code (Overrides ObjectGetHashCode)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Gets a String representation of the integer value of the id. (Overrides ObjectToString)
Top
See Also

Reference

ScheduleFieldId Class


ScheduleFieldId.Equals Method

ScheduleFieldIdEquals Method

Determines whether the specified Object is equal to the current Object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj Object
The other object to evaluate.

Return Value

Boolean
See Also

Reference

ScheduleFieldId Class


ScheduleFieldId.GetHashCode Method

ScheduleFieldIdGetHashCode Method

Gets the integer value of the id as hash code

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Int32
See Also

Reference

ScheduleFieldId Class


ScheduleFieldId.ToString Method

ScheduleFieldIdToString Method

Gets a String representation of the integer value of the id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

String
See Also

Reference

ScheduleFieldId Class


ScheduleFieldId Operators

The ScheduleFieldId type exposes the following members.

Operators
Name | Description
Equality(ScheduleFieldId, ScheduleFieldId) | Determines whether two ScheduleFieldIds are the same.
Inequality(ScheduleFieldId, ScheduleFieldId) | Determines whether two ScheduleFieldId are different.
Top
See Also

Reference

ScheduleFieldId Class


ScheduleFieldId.Equality Operator

ScheduleFieldIdEquality Operator

Determines whether two ScheduleFieldIds are the same.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool operator ==(
    ScheduleFieldId first,
    ScheduleFieldId second
)
Public Shared Operator = (
    first As ScheduleFieldId,
    second As ScheduleFieldId
) As Boolean
public:
static bool operator ==(
    ScheduleFieldId^ first,
    ScheduleFieldId^ second
)
static let inline (=)
        first : ScheduleFieldId *
        second : ScheduleFieldId  : bool

Parameters

first ScheduleFieldId
The first ScheduleFieldId.
second ScheduleFieldId
The second ScheduleFieldId.

Return Value

Boolean
True if the ScheduleFieldIds are the same, otherwise false.
See Also

Reference

ScheduleFieldId Class


ScheduleFieldId.Inequality Operator

ScheduleFieldIdInequality Operator

Determines whether two ScheduleFieldId are different.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool operator !=(
    ScheduleFieldId first,
    ScheduleFieldId second
)
Public Shared Operator <> (
    first As ScheduleFieldId,
    second As ScheduleFieldId
) As Boolean
public:
static bool operator !=(
    ScheduleFieldId^ first,
    ScheduleFieldId^ second
)
static let inline (<>)
        first : ScheduleFieldId *
        second : ScheduleFieldId  : bool

Parameters

first ScheduleFieldId
The first ScheduleFieldId.
second ScheduleFieldId
The second ScheduleFieldId.

Return Value

Boolean
True if the ScheduleFieldId are different, otherwise false.
See Also

Reference

ScheduleFieldId Class


ScheduleFieldMultipleValuesDisplayType Enumeration

Define how the schedule field's multiple value is displayed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ScheduleFieldMultipleValuesDisplayType
Public Enumeration ScheduleFieldMultipleValuesDisplayType
public enum class ScheduleFieldMultipleValuesDisplayType
type ScheduleFieldMultipleValuesDisplayType
Members
Member name | Value | Description
Project | 0 | Display the project setting [!:Autodesk::Revit::DB::MultipleValuesIndicationSettings::Value].
Varies | 1 | Display a standard hardcoded text, translated for the active locale.
Custom | 2 | Display custom text per ScheduleField instance, as defined by the [!:Autodesk::Revit::DB::ScheduleField::MultipleValuesCustomText] property.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ScheduleFieldType Enumeration

The type of data displayed in a schedule field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ScheduleFieldType
Public Enumeration ScheduleFieldType
public enum class ScheduleFieldType
type ScheduleFieldType
Members
Member name | Value | Description
Instance | 0 | An instance parameter of the scheduled elements. All shared parameters also use this type, regardless of whether they are instance or type parameters.
ElementType | 1 | A type parameter of the scheduled elements.
Count | 2 | The number of elements appearing on the schedule row.
ViewBased 4

A specialized type of field used for a few parameters whose displayed values can change based on the settings of the view:

  • ROOM_AREA and ROOM_PERIMETER in room and space schedules.
  • PROJECT_REVISION_REVISION_NUM in revision schedules.
  • KEYNOTE_NUMBER in keynote legends that are numbered by sheet.
Formula | 5 | A formula calculated from the values of other fields in the schedule.
Percentage | 6 | A value indicating what percent of the total of another field each element represents.
Room | 7 | A parameter of the room that a scheduled element belongs to.
FromRoom | 8 | A parameter of the room on the "from" side of a door or window.
ToRoom | 9 | A parameter of the room on the "to" side of a door or window.
ProjectInfo | 10 | A parameter of the Project Info element in the project that the scheduled element belongs to, which may be a linked file. Only allowed in schedules that include elements from linked files.
Material | 11 | In a material takeoff, a parameter of one of the materials of a scheduled element.
MaterialQuantity | 12 | In a material takeoff, a value representing how a particular material is used within a scheduled element. The parameter ID can be MATERIAL_AREA, MATERIAL_VOLUME, or MATERIAL_ASPAINT.
RevitLinkInstance | 13 | A parameter of the RevitLinkInstance that an element in a linked file belongs to. Currently RVT_LINK_INSTANCE_NAME is the only supported parameter. Only allowed in schedules that include elements from linked files.
RevitLinkType | 14 | A parameter of the RevitLinkType that an element in a linked file belongs to. Currently RVT_LINK_FILE_NAME_WITHOUT_EXT is the only supported parameter. Only allowed in schedules that include elements from linked files.
StructuralMaterial | 15 | A parameter of the structural material of a scheduled element.
Space | 16 | A parameter of the space that a scheduled element belongs to.
Analytical | 17 | A parameter of the analytical element of a scheduled physical element.
PhysicalType | 18 | A type parameter of the physical element of a scheduled analytical element.
PhysicalInstance | 19 | An instance parameter of the physical element of a scheduled analytical element.
CombinedParameter | 20 | Combine parameters of the types that display in a specific part of a schedule. The values for the combined parameters will display in the same cell separated by a slash or other separator. You can add a prefix, suffix or sample value to the parameter.
HostCount | 23 | Counts the number of hosts with different mark.
CustomField | 24 | For this field type the value for each row is computed based on the (sub)elements that are grouped on that row and can have a graphic representation when the schedule is placed on a sheet.
Revision | 25 | A parameter of the revision element that the scheduled revision cloud element belongs to.
Views | 26 | A parameter of the primary view owning an annotation element (e.g. Revision Cloud)
Sheets | 27 | A parameter of the sheet view owning an annotation element (e.g. Revision Cloud)
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ScheduleFilter Class

A filter in a schedule.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBScheduleFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ScheduleFilter : IDisposable
Public Class ScheduleFilter
    Implements IDisposable
public ref class ScheduleFilter : IDisposable
type ScheduleFilter =
    class
        interface IDisposable
    end

The ScheduleFilter type exposes the following members.

Constructors
 | Name | Description
Public method | ScheduleFilter | Creates a new ScheduleFilter.
Public method | ScheduleFilter(ScheduleFieldId, ScheduleFilterType) | Creates a new ScheduleFilter.
Public method | ScheduleFilter(ScheduleFieldId, ScheduleFilterType, ElementId) | Creates a new ScheduleFilter.
Public method | ScheduleFilter(ScheduleFieldId, ScheduleFilterType, Double) | Creates a new ScheduleFilter.
Public method | ScheduleFilter(ScheduleFieldId, ScheduleFilterType, Int32) | Creates a new ScheduleFilter.
Public method | ScheduleFilter(ScheduleFieldId, ScheduleFilterType, String) | Creates a new ScheduleFilter.
Top
Properties
 | Name | Description
Public property | FieldId | The ID of the field used to filter the schedule.
Public property | FilterType | The filter type.
Public property | IsDoubleValue | Indicates if the filter has a double value.
Public property | IsElementIdValue | Indicates if the filter has an ElementId value.
Public property | IsIntegerValue | Indicates if the filter has an integer value.
Public property | IsNullValue | Indicates if the filter has no specified value.
Public property | IsStringValue | Indicates if the filter has a string value.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ScheduleFilter
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetDoubleValue | Gets the filter value for a filter using a double value.
Public method | GetElementIdValue | Gets the filter value for a filter using an ElementId value.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIntegerValue | Gets the filter value for a filter using an integer value.
Public method | GetStringValue | Gets the filter value for a filter using a string value.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetNullValue | Sets the filter to have no specified value (used for HasParameter filters).
Public method | SetValue(Double) | Set the filter value to a double.
Public method | SetValue(ElementId) | Set the filter value to an ElementId.
Public method | SetValue(Int32) | Set the filter value to an integer.
Public method | SetValue(String) | Set the filter value to a string.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

The ScheduleFilter class represents a single filter in a schedule. A filter is a condition that must be satisfied for an element to appear in the schedule. All filters must be satisfied for an element to appear in the schedule.

A schedule can be filtered by data that is not displayed in the schedule by marking the field used for filtering as hidden using the ScheduleField.IsHidden property.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ScheduleFilter Constructor

Overload List
 | Name | Description
Public method | ScheduleFilter | Creates a new ScheduleFilter.
Public method | ScheduleFilter(ScheduleFieldId, ScheduleFilterType) | Creates a new ScheduleFilter.
Public method | ScheduleFilter(ScheduleFieldId, ScheduleFilterType, ElementId) | Creates a new ScheduleFilter.
Public method | ScheduleFilter(ScheduleFieldId, ScheduleFilterType, Double) | Creates a new ScheduleFilter.
Public method | ScheduleFilter(ScheduleFieldId, ScheduleFilterType, Int32) | Creates a new ScheduleFilter.
Public method | ScheduleFilter(ScheduleFieldId, ScheduleFilterType, String) | Creates a new ScheduleFilter.
Top
See Also

Reference

ScheduleFilter Class


ScheduleFilter Constructor

Creates a new ScheduleFilter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScheduleFilter()
Public Sub New
public:
ScheduleFilter()
new : unit -> ScheduleFilter
See Also

Reference

ScheduleFilter Class
ScheduleFilter Overload


ScheduleFilter(ScheduleFieldId, ScheduleFilterType) Constructor

Creates a new ScheduleFilter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScheduleFilter(
    ScheduleFieldId fieldId,
    ScheduleFilterType filterType
)
Public Sub New (
    fieldId As ScheduleFieldId,
    filterType As ScheduleFilterType
)
public:
ScheduleFilter(
    ScheduleFieldId^ fieldId,
    ScheduleFilterType filterType
)
new :
        fieldId : ScheduleFieldId *
        filterType : ScheduleFilterType -> ScheduleFilter

Parameters

fieldId ScheduleFieldId
The ID of the field used to filter the schedule.
filterType ScheduleFilterType
The filter type.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ScheduleFilter Class
ScheduleFilter Overload


ScheduleFilter(ScheduleFieldId, ScheduleFilterType, ElementId) Constructor

Creates a new ScheduleFilter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScheduleFilter(
    ScheduleFieldId fieldId,
    ScheduleFilterType filterType,
    ElementId value
)
Public Sub New (
    fieldId As ScheduleFieldId,
    filterType As ScheduleFilterType,
    value As ElementId
)
public:
ScheduleFilter(
    ScheduleFieldId^ fieldId,
    ScheduleFilterType filterType,
    ElementId^ value
)
new :
        fieldId : ScheduleFieldId *
        filterType : ScheduleFilterType *
        value : ElementId -> ScheduleFilter

Parameters

fieldId ScheduleFieldId
The ID of the field used to filter the schedule.
filterType ScheduleFilterType
The filter type.
value ElementId
The filter value for a filter using an ElementId value.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ScheduleFilter Class
ScheduleFilter Overload


ScheduleFilter(ScheduleFieldId, ScheduleFilterType, Double) Constructor

Creates a new ScheduleFilter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScheduleFilter(
    ScheduleFieldId fieldId,
    ScheduleFilterType filterType,
    double value
)
Public Sub New (
    fieldId As ScheduleFieldId,
    filterType As ScheduleFilterType,
    value As Double
)
public:
ScheduleFilter(
    ScheduleFieldId^ fieldId,
    ScheduleFilterType filterType,
    double value
)
new :
        fieldId : ScheduleFieldId *
        filterType : ScheduleFilterType *
        value : float -> ScheduleFilter

Parameters

fieldId ScheduleFieldId
The ID of the field used to filter the schedule.
filterType ScheduleFilterType
The filter type.
value Double
The filter value for a filter using a double value.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ScheduleFilter Class
ScheduleFilter Overload


ScheduleFilter(ScheduleFieldId, ScheduleFilterType, Int32) Constructor

Creates a new ScheduleFilter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScheduleFilter(
    ScheduleFieldId fieldId,
    ScheduleFilterType filterType,
    int value
)
Public Sub New (
    fieldId As ScheduleFieldId,
    filterType As ScheduleFilterType,
    value As Integer
)
public:
ScheduleFilter(
    ScheduleFieldId^ fieldId,
    ScheduleFilterType filterType,
    int value
)
new :
        fieldId : ScheduleFieldId *
        filterType : ScheduleFilterType *
        value : int -> ScheduleFilter

Parameters

fieldId ScheduleFieldId
The ID of the field used to filter the schedule.
filterType ScheduleFilterType
The filter type.
value Int32
The filter value for a filter using an integer value.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ScheduleFilter Class
ScheduleFilter Overload


ScheduleFilter(ScheduleFieldId, ScheduleFilterType, String) Constructor

Creates a new ScheduleFilter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScheduleFilter(
    ScheduleFieldId fieldId,
    ScheduleFilterType filterType,
    string value
)
Public Sub New (
    fieldId As ScheduleFieldId,
    filterType As ScheduleFilterType,
    value As String
)
public:
ScheduleFilter(
    ScheduleFieldId^ fieldId,
    ScheduleFilterType filterType,
    String^ value
)
new :
        fieldId : ScheduleFieldId *
        filterType : ScheduleFilterType *
        value : string -> ScheduleFilter

Parameters

fieldId ScheduleFieldId
The ID of the field used to filter the schedule.
filterType ScheduleFilterType
The filter type.
value String
The filter value for a filter using a string value.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ScheduleFilter Class
ScheduleFilter Overload


ScheduleFilter Properties

The ScheduleFilter type exposes the following members.

Properties
 | Name | Description
Public property | FieldId | The ID of the field used to filter the schedule.
Public property | FilterType | The filter type.
Public property | IsDoubleValue | Indicates if the filter has a double value.
Public property | IsElementIdValue | Indicates if the filter has an ElementId value.
Public property | IsIntegerValue | Indicates if the filter has an integer value.
Public property | IsNullValue | Indicates if the filter has no specified value.
Public property | IsStringValue | Indicates if the filter has a string value.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

ScheduleFilter Class


ScheduleFilter.FieldId Property

ScheduleFilterFieldId Property

The ID of the field used to filter the schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScheduleFieldId FieldId { get; set; }
Public Property FieldId As ScheduleFieldId
    Get
    Set
public:
property ScheduleFieldId^ FieldId {
    ScheduleFieldId^ get ();
    void set (ScheduleFieldId^ value);
}
member FieldId : ScheduleFieldId with get, set

Property Value

ScheduleFieldId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ScheduleFilter Class


ScheduleFilter.FilterType Property

ScheduleFilterFilterType Property

The filter type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScheduleFilterType FilterType { get; set; }
Public Property FilterType As ScheduleFilterType
    Get
    Set
public:
property ScheduleFilterType FilterType {
    ScheduleFilterType get ();
    void set (ScheduleFilterType value);
}
member FilterType : ScheduleFilterType with get, set

Property Value

ScheduleFilterType
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
See ScheduleFilterType for details.
See Also

Reference

ScheduleFilter Class


ScheduleFilter.IsDoubleValue Property

ScheduleFilterIsDoubleValue Property

Indicates if the filter has a double value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsDoubleValue { get; }
Public ReadOnly Property IsDoubleValue As Boolean
    Get
public:
property bool IsDoubleValue {
    bool get ();
}
member IsDoubleValue : bool with get

Property Value

Boolean
See Also

Reference

ScheduleFilter Class


ScheduleFilter.IsElementIdValue Property

ScheduleFilterIsElementIdValue Property

Indicates if the filter has an ElementId value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsElementIdValue { get; }
Public ReadOnly Property IsElementIdValue As Boolean
    Get
public:
property bool IsElementIdValue {
    bool get ();
}
member IsElementIdValue : bool with get

Property Value

Boolean
See Also

Reference

ScheduleFilter Class


ScheduleFilter.IsIntegerValue Property

ScheduleFilterIsIntegerValue Property

Indicates if the filter has an integer value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsIntegerValue { get; }
Public ReadOnly Property IsIntegerValue As Boolean
    Get
public:
property bool IsIntegerValue {
    bool get ();
}
member IsIntegerValue : bool with get

Property Value

Boolean
See Also

Reference

ScheduleFilter Class


ScheduleFilter.IsNullValue Property

ScheduleFilterIsNullValue Property

Indicates if the filter has no specified value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsNullValue { get; }
Public ReadOnly Property IsNullValue As Boolean
    Get
public:
property bool IsNullValue {
    bool get ();
}
member IsNullValue : bool with get

Property Value

Boolean
See Also

Reference

ScheduleFilter Class


ScheduleFilter.IsStringValue Property

ScheduleFilterIsStringValue Property

Indicates if the filter has a string value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsStringValue { get; }
Public ReadOnly Property IsStringValue As Boolean
    Get
public:
property bool IsStringValue {
    bool get ();
}
member IsStringValue : bool with get

Property Value

Boolean
See Also

Reference

ScheduleFilter Class


ScheduleFilter.IsValidObject Property

ScheduleFilterIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ScheduleFilter Class


ScheduleFilter Methods

The ScheduleFilter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetDoubleValue | Gets the filter value for a filter using a double value.
Public method | GetElementIdValue | Gets the filter value for a filter using an ElementId value.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIntegerValue | Gets the filter value for a filter using an integer value.
Public method | GetStringValue | Gets the filter value for a filter using a string value.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetNullValue | Sets the filter to have no specified value (used for HasParameter filters).
Public method | SetValue(Double) | Set the filter value to a double.
Public method | SetValue(ElementId) | Set the filter value to an ElementId.
Public method | SetValue(Int32) | Set the filter value to an integer.
Public method | SetValue(String) | Set the filter value to a string.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ScheduleFilter Class


ScheduleFilter.Dispose Method

ScheduleFilterDispose Method

Releases all resources used by the ScheduleFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ScheduleFilter Class


ScheduleFilter.GetDoubleValue Method

ScheduleFilterGetDoubleValue Method

Gets the filter value for a filter using a double value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetDoubleValue()
Public Function GetDoubleValue As Double
public:
double GetDoubleValue()
member GetDoubleValue : unit -> float

Return Value

Double
The filter value.
Exceptions
Exception | Condition
InvalidOperationException | The filter value is not a double.
See Also

Reference

ScheduleFilter Class


ScheduleFilter.GetElementIdValue Method

ScheduleFilterGetElementIdValue Method

Gets the filter value for a filter using an ElementId value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GetElementIdValue()
Public Function GetElementIdValue As ElementId
public:
ElementId^ GetElementIdValue()
member GetElementIdValue : unit -> ElementId

Return Value

ElementId
The filter value.
Exceptions
Exception | Condition
InvalidOperationException | The filter value is not an ElementId.
See Also

Reference

ScheduleFilter Class


ScheduleFilter.GetIntegerValue Method

ScheduleFilterGetIntegerValue Method

Gets the filter value for a filter using an integer value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetIntegerValue()
Public Function GetIntegerValue As Integer
public:
int GetIntegerValue()
member GetIntegerValue : unit -> int

Return Value

Int32
The filter value.
Exceptions
Exception | Condition
InvalidOperationException | The filter value is not an integer.
See Also

Reference

ScheduleFilter Class


ScheduleFilter.GetStringValue Method

ScheduleFilterGetStringValue Method

Gets the filter value for a filter using a string value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetStringValue()
Public Function GetStringValue As String
public:
String^ GetStringValue()
member GetStringValue : unit -> string

Return Value

String
The filter value.
Exceptions
Exception | Condition
InvalidOperationException | The filter value is not a string.
See Also

Reference

ScheduleFilter Class


ScheduleFilter.SetNullValue Method

ScheduleFilterSetNullValue Method

Sets the filter to have no specified value (used for HasParameter filters).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetNullValue()
Public Sub SetNullValue
public:
void SetNullValue()
member SetNullValue : unit -> unit
See Also

Reference

ScheduleFilter Class


ScheduleFilter.SetValue Method

ScheduleFilterSetValue Method

Overload List
 | Name | Description
Public method | SetValue(Double) | Set the filter value to a double.
Public method | SetValue(ElementId) | Set the filter value to an ElementId.
Public method | SetValue(Int32) | Set the filter value to an integer.
Public method | SetValue(String) | Set the filter value to a string.
Top
See Also

Reference

ScheduleFilter Class


ScheduleFilter.SetValue(Double) Method

ScheduleFilterSetValue(Double) Method

Set the filter value to a double.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetValue(
    double value
)
Public Sub SetValue (
    value As Double
)
public:
void SetValue(
    double value
)
member SetValue :
        value : float -> unit

Parameters

value Double
The filter value.
See Also

Reference

ScheduleFilter Class
SetValue Overload


ScheduleFilter.SetValue(ElementId) Method

ScheduleFilterSetValue(ElementId) Method

Set the filter value to an ElementId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetValue(
    ElementId id
)
Public Sub SetValue (
    id As ElementId
)
public:
void SetValue(
    ElementId^ id
)
member SetValue :
        id : ElementId -> unit

Parameters

id ElementId
The filter value.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ScheduleFilter Class
SetValue Overload


ScheduleFilter.SetValue(Int32) Method

ScheduleFilterSetValue(Int32) Method

Set the filter value to an integer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetValue(
    int value
)
Public Sub SetValue (
    value As Integer
)
public:
void SetValue(
    int value
)
member SetValue :
        value : int -> unit

Parameters

value Int32
The filter value.
See Also

Reference

ScheduleFilter Class
SetValue Overload


ScheduleFilter.SetValue(String) Method

ScheduleFilterSetValue(String) Method

Set the filter value to a string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetValue(
    string string
)
Public Sub SetValue (
    string As String
)
public:
void SetValue(
    String^ string
)
member SetValue :
        string : string -> unit

Parameters

string String
The filter value.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ScheduleFilter Class
SetValue Overload


ScheduleFilterType Enumeration

Type of schedule filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ScheduleFilterType
Public Enumeration ScheduleFilterType
public enum class ScheduleFilterType
type ScheduleFilterType
Members
Member name | Value | Description
Invalid | 0 | An invalid filter. Do not use.
HasParameter | 1 | The element has the parameter specified by the field. Used with shared parameters. No value is specified for this filter type.
Equal | 2 | The field value is equal to the specified value.
NotEqual | 3 | The field value is not equal to the specified value.
GreaterThan | 4 | The field value is greater than the specified value.
GreaterThanOrEqual | 5 | The field value is greater than or equal to the specified value.
LessThan | 6 | Less The field value is less than to the specified value.
LessThanOrEqual | 7 | The field value is less than or equal to the specified value.
Contains | 8 | For a string field, the field value contains the specified string.
NotContains | 9 | For a string field, the field value does not contain the specified string.
BeginsWith | 10 | For a string field, the field value begins with the specified string.
NotBeginsWith | 11 | For a string field, the field value does not begin with the specified string.
EndsWith | 12 | For a string field, the field value ends with specified string.
NotEndsWith | 13 | For a string field, the field value does not end with the specified string.
IsAssociatedWithGlobalParameter | 14 | The field is associated with a specified global parameter of a compatible type
IsNotAssociatedWithGlobalParameter | 15 | The field is not associated with a specified global parameter of a compatible type
HasValue | 16 | The element has a value for the specified parameter. No value is specified.
HasNoValue | 17 | The element does not have a value for the specified parameter. No value is specified.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ScheduleHeadingOrientation Enumeration

Orientation of schedule heading.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ScheduleHeadingOrientation
Public Enumeration ScheduleHeadingOrientation
public enum class ScheduleHeadingOrientation
type ScheduleHeadingOrientation
Members
Member name | Value | Description
Horizontal | 0 | Horizontal
Vertical | 1 | Vertical
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ScheduleHeightsOnSheet Class

Heights information of a schedule on sheet.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBScheduleHeightsOnSheet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ScheduleHeightsOnSheet : IDisposable
Public Class ScheduleHeightsOnSheet
    Implements IDisposable
public ref class ScheduleHeightsOnSheet : IDisposable
type ScheduleHeightsOnSheet =
    class
        interface IDisposable
    end

The ScheduleHeightsOnSheet type exposes the following members.

Properties
 | Name | Description
Public property | ColumnHeaderHeight | The height of all schedule header part, including the gap line between header and body.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | TitleHeight | The height of schedule title on sheet view.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ScheduleHeightsOnSheet
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBodyRowHeights | Returns each row's height of schedule body on sheet view.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This class returns the heights of schedule title, column header and each body row on sheet view.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ScheduleHeightsOnSheet Properties

The ScheduleHeightsOnSheet type exposes the following members.

Properties
 | Name | Description
Public property | ColumnHeaderHeight | The height of all schedule header part, including the gap line between header and body.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | TitleHeight | The height of schedule title on sheet view.
Top
See Also

Reference

ScheduleHeightsOnSheet Class


ScheduleHeightsOnSheet.ColumnHeaderHeight Property

ScheduleHeightsOnSheetColumnHeaderHeight Property

The height of all schedule header part, including the gap line between header and body.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double ColumnHeaderHeight { get; }
Public ReadOnly Property ColumnHeaderHeight As Double
    Get
public:
property double ColumnHeaderHeight {
    double get ();
}
member ColumnHeaderHeight : float with get

Property Value

Double
See Also

Reference

ScheduleHeightsOnSheet Class


ScheduleHeightsOnSheet.IsValidObject Property

ScheduleHeightsOnSheetIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ScheduleHeightsOnSheet Class


ScheduleHeightsOnSheet.TitleHeight Property

ScheduleHeightsOnSheetTitleHeight Property

The height of schedule title on sheet view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double TitleHeight { get; }
Public ReadOnly Property TitleHeight As Double
    Get
public:
property double TitleHeight {
    double get ();
}
member TitleHeight : float with get

Property Value

Double
Remarks
If title is set to unshown, it will be 0.
See Also

Reference

ScheduleHeightsOnSheet Class


ScheduleHeightsOnSheet Methods

The ScheduleHeightsOnSheet type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBodyRowHeights | Returns each row's height of schedule body on sheet view.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ScheduleHeightsOnSheet Class


ScheduleHeightsOnSheet.Dispose Method

ScheduleHeightsOnSheetDispose Method

Releases all resources used by the ScheduleHeightsOnSheet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ScheduleHeightsOnSheet Class


ScheduleHeightsOnSheet.GetBodyRowHeights Method

ScheduleHeightsOnSheetGetBodyRowHeights Method

Returns each row's height of schedule body on sheet view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<double> GetBodyRowHeights()
Public Function GetBodyRowHeights As IList(Of Double)
public:
IList<double>^ GetBodyRowHeights()
member GetBodyRowHeights : unit -> IList<float>

Return Value

IList Double
Each row's height of schedule body on sheet view.
See Also

Reference

ScheduleHeightsOnSheet Class


ScheduleHorizontalAlignment Enumeration

Horizontal alignment of data in a schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ScheduleHorizontalAlignment
Public Enumeration ScheduleHorizontalAlignment
public enum class ScheduleHorizontalAlignment
type ScheduleHorizontalAlignment
Members
Member name | Value | Description
Left | 0 | Left aligned
Center | 1 | Center aligned
Right | 2 | Right aligned
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ScheduleSheetInstance Class

An element that represents a particular placement of a schedule on a sheet.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBScheduleSheetInstance

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ScheduleSheetInstance : Element
Public Class ScheduleSheetInstance
    Inherits Element
public ref class ScheduleSheetInstance : public Element
type ScheduleSheetInstance =
    class
        inherit Element
    end

The ScheduleSheetInstance type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTitleblockRevisionSchedule | Identifies if this ScheduleSheetInstance is a revision schedule in a titleblock family.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Point | Location on the sheet where the ScheduleInstance is placed (in sheet coordinates).
Public property | Rotation | Rotation of the ScheduleInstance.
Public property | ScheduleId | Id of the primary schedule that generates this ScheduleInstance.
Public property | SegmentIndex | The schedule segment index of this ScheduleSheetInstance.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create(Document, ElementId, ElementId, XYZ) | Create an instance of a schedule on a sheet.
 | Create(Document, ElementId, ElementId, XYZ, Int32) | Creates an instance of a schedule segment on a sheet.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

Use ScheduleSheetInstance.OwnerViewId to find the sheet on which a schedule is placed.

When a schedule is set to filter by sheet and placed on a sheet, it will create a new schedule with elements visible in the Viewport(s) on that sheet. The instance created belongs to the newly created schedule.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ScheduleSheetInstance Properties

The ScheduleSheetInstance type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTitleblockRevisionSchedule | Identifies if this ScheduleSheetInstance is a revision schedule in a titleblock family.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Point | Location on the sheet where the ScheduleInstance is placed (in sheet coordinates).
Public property | Rotation | Rotation of the ScheduleInstance.
Public property | ScheduleId | Id of the primary schedule that generates this ScheduleInstance.
Public property | SegmentIndex | The schedule segment index of this ScheduleSheetInstance.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

ScheduleSheetInstance Class


ScheduleSheetInstance.IsTitleblockRevisionSchedule Property

ScheduleSheetInstanceIsTitleblockRevisionSchedule Property

Identifies if this ScheduleSheetInstance is a revision schedule in a titleblock family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsTitleblockRevisionSchedule { get; }
Public ReadOnly Property IsTitleblockRevisionSchedule As Boolean
    Get
public:
property bool IsTitleblockRevisionSchedule {
    bool get ();
}
member IsTitleblockRevisionSchedule : bool with get

Property Value

Boolean
Remarks
These schedule instances should not be modified in the project environment. To modify the revision schedule on a titleblock, edit the titleblock family.
See Also

Reference

ScheduleSheetInstance Class


ScheduleSheetInstance.Point Property

ScheduleSheetInstancePoint Property

Location on the sheet where the ScheduleInstance is placed (in sheet coordinates).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Point { get; set; }
Public Property Point As XYZ
    Get
    Set
public:
property XYZ^ Point {
    XYZ^ get ();
    void set (XYZ^ value);
}
member Point : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
InvalidOperationException | When setting this property: This operation is prohibited for ScheduleInstances associated with revision schedules in titleblocks.
See Also

Reference

ScheduleSheetInstance Class


ScheduleSheetInstance.Rotation Property

ScheduleSheetInstanceRotation Property

Rotation of the ScheduleInstance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ViewportRotation Rotation { get; set; }
Public Property Rotation As ViewportRotation
    Get
    Set
public:
property ViewportRotation Rotation {
    ViewportRotation get ();
    void set (ViewportRotation value);
}
member Rotation : ViewportRotation with get, set

Property Value

ViewportRotation
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | When setting this property: This operation is prohibited for ScheduleInstances associated with revision schedules in titleblocks. -or- When setting this property: This operation is prohibited for ScheduleInstances that are pinned.
See Also

Reference

ScheduleSheetInstance Class


ScheduleSheetInstance.ScheduleId Property

ScheduleSheetInstanceScheduleId Property

Id of the primary schedule that generates this ScheduleInstance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId ScheduleId { get; }
Public ReadOnly Property ScheduleId As ElementId
    Get
public:
property ElementId^ ScheduleId {
    ElementId^ get ();
}
member ScheduleId : ElementId with get

Property Value

ElementId
See Also

Reference

ScheduleSheetInstance Class


ScheduleSheetInstance.SegmentIndex Property

ScheduleSheetInstanceSegmentIndex Property

The schedule segment index of this ScheduleSheetInstance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int SegmentIndex { get; set; }
Public Property SegmentIndex As Integer
    Get
    Set
public:
property int SegmentIndex {
    int get ();
    void set (int value);
}
member SegmentIndex : int with get, set

Property Value

Int32
Exceptions
Exception | Condition
ArgumentException | When setting this property: segmentIndex is not a valid segment index.
InvalidOperationException | When setting this property: The schedule of this ScheduleSheetInstance is a titleblock revision schedule or a sheet specific schedule.
Remarks
This property represents which schedule segment is referred to by this ScheduleSheetInstance. It normally starts with 0 and is less than the total number of the schedule segments, but there're some speccial cases:
  • The segment index value could be -1, which means referring to the whole schedule but not a specific segment.
  • The segment index value 0 should be considered the same as -1 if the referenced schedule is not split in normal cases.
  • The segment index value must be 0 if the schedule is a revision schedule and in a family.
  • The segment index value can't be modified if the schedule is filter by sheet. (In fact, The segment is referenced to is belongs to an internal schedule that only valid in the current view in this case.)
See Also

Reference

ScheduleSheetInstance Class


ScheduleSheetInstance Methods

The ScheduleSheetInstance type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create(Document, ElementId, ElementId, XYZ) | Create an instance of a schedule on a sheet.
 | Create(Document, ElementId, ElementId, XYZ, Int32) | Creates an instance of a schedule segment on a sheet.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ScheduleSheetInstance Class


ScheduleSheetInstance.Create Method

ScheduleSheetInstanceCreate Method

Overload List
Name | Description
Create(Document, ElementId, ElementId, XYZ) | Create an instance of a schedule on a sheet.
Create(Document, ElementId, ElementId, XYZ, Int32) | Creates an instance of a schedule segment on a sheet.
Top
See Also

Reference

ScheduleSheetInstance Class


ScheduleSheetInstance.Create(Document, ElementId, ElementId, XYZ) Method

ScheduleSheetInstanceCreate(Document, ElementId, ElementId, XYZ) Method

Create an instance of a schedule on a sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ScheduleSheetInstance Create(
    Document document,
    ElementId viewSheetId,
    ElementId scheduleId,
    XYZ origin
)
Public Shared Function Create (
    document As Document,
    viewSheetId As ElementId,
    scheduleId As ElementId,
    origin As XYZ
) As ScheduleSheetInstance
public:
static ScheduleSheetInstance^ Create(
    Document^ document,
    ElementId^ viewSheetId,
    ElementId^ scheduleId,
    XYZ^ origin
)
static member Create :
        document : Document *
        viewSheetId : ElementId *
        scheduleId : ElementId *
        origin : XYZ -> ScheduleSheetInstance

Parameters

document Document
The document
viewSheetId ElementId
The id of the sheet where the schedule will be placed.
scheduleId ElementId
The id of the schedule view.
origin XYZ
Location on the sheet where the schedule will be placed.

Return Value

ScheduleSheetInstance
The new ScheduleInstance.
Exceptions
Exception | Condition
ArgumentException | scheduleId is not a ViewSchedule that can be added to sheets. "Internal" schedules are not user-visible but are filtered by sheet or used to manage Revisions, which cannot be added to sheets. -or- viewSheetId is not a ViewSheet.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
See Also

Reference

ScheduleSheetInstance Class
Create Overload


ScheduleSheetInstance.Create(Document, ElementId, ElementId, XYZ, Int32) Method

ScheduleSheetInstanceCreate(Document, ElementId, ElementId, XYZ, Int32) Method

Creates an instance of a schedule segment on a sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ScheduleSheetInstance Create(
    Document document,
    ElementId viewSheetId,
    ElementId scheduleId,
    XYZ origin,
    int segmentIndex
)
Public Shared Function Create (
    document As Document,
    viewSheetId As ElementId,
    scheduleId As ElementId,
    origin As XYZ,
    segmentIndex As Integer
) As ScheduleSheetInstance
public:
static ScheduleSheetInstance^ Create(
    Document^ document,
    ElementId^ viewSheetId,
    ElementId^ scheduleId,
    XYZ^ origin,
    int segmentIndex
)
static member Create :
        document : Document *
        viewSheetId : ElementId *
        scheduleId : ElementId *
        origin : XYZ *
        segmentIndex : int -> ScheduleSheetInstance

Parameters

document Document
The document
viewSheetId ElementId
The id of the sheet where the schedule segment will be placed.
scheduleId ElementId
The id of the schedule view.
origin XYZ
Location on the sheet where the schedule segment will be placed.
segmentIndex Int32
The schedule segment index of the schedule instance.

Return Value

ScheduleSheetInstance
The new ScheduleInstance.
Exceptions
Exception | Condition
ArgumentException | scheduleId is not a ViewSchedule that can be added to sheets. "Internal" schedules are not user-visible but are filtered by sheet or used to manage Revisions, which cannot be added to sheets. -or- viewSheetId is not a ViewSheet. -or- segmentIndex is not a valid segment index.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
The segment index value could be -1, which means to create an instance for the entire schedule, see SegmentIndex property for more details.
See Also

Reference

ScheduleSheetInstance Class
Create Overload


ScheduleSortGroupField Class

A field that is used for sorting and/or grouping in a schedule.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBScheduleSortGroupField

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ScheduleSortGroupField : IDisposable
Public Class ScheduleSortGroupField
    Implements IDisposable
public ref class ScheduleSortGroupField : IDisposable
type ScheduleSortGroupField =
    class
        interface IDisposable
    end

The ScheduleSortGroupField type exposes the following members.

Constructors
 | Name | Description
Public method | ScheduleSortGroupField | Creates a new ScheduleSortGroupField.
Public method | ScheduleSortGroupField(ScheduleFieldId) | Creates a new ScheduleSortGroupField.
Public method | ScheduleSortGroupField(ScheduleFieldId, ScheduleSortOrder) | Creates a new ScheduleSortGroupField.
Top
Properties
 | Name | Description
Public property | FieldId | The ID of the field that the schedule will be sorted or grouped by.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ShowBlankLine | Indicates if an empty row should be displayed between groups.
Public property | ShowFooter | Indicates if a footer row should be displayed after each group.
Public property | ShowFooterCount | Indicates if the footer row should display a count of elements in the group.
Public property | ShowFooterTitle | Indicates if the footer row should display a title.
Public property | ShowHeader | Indicates if a header row should be displayed before each group.
Public property | SortOrder | Indicates if elements in the schedule will be sorted in ascending or descending order.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ScheduleSortGroupField
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

A schedule may be sorted or grouped by one or more of the schedule's fields. The ScheduleSortGroupField class represents one of the fields that the schedule is sorted or grouped by.

Sorting and grouping are related operations. In either case, elements appearing in the schedule are sorted based on their values for the field that the schedule is sorted/grouped by, which automatically causes elements with identical values to be grouped together. By enabling extra header, footer, or blank rows, visual separation between groups can be achieved.

If ScheduleDefinition.IsItemized is false, elements having the same values for all of the fields used for sorting/grouping will be combined onto the same row.

A schedule can be sorted or grouped by data that is not displayed in the schedule by marking the field used for sorting/grouping as hidden using the ScheduleField.IsHidden property.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ScheduleSortGroupField Constructor

Overload List
 | Name | Description
Public method | ScheduleSortGroupField | Creates a new ScheduleSortGroupField.
Public method | ScheduleSortGroupField(ScheduleFieldId) | Creates a new ScheduleSortGroupField.
Public method | ScheduleSortGroupField(ScheduleFieldId, ScheduleSortOrder) | Creates a new ScheduleSortGroupField.
Top
See Also

Reference

ScheduleSortGroupField Class


ScheduleSortGroupField Constructor

Creates a new ScheduleSortGroupField.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScheduleSortGroupField()
Public Sub New
public:
ScheduleSortGroupField()
new : unit -> ScheduleSortGroupField
See Also

Reference

ScheduleSortGroupField Class
ScheduleSortGroupField Overload


ScheduleSortGroupField(ScheduleFieldId) Constructor

Creates a new ScheduleSortGroupField.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScheduleSortGroupField(
    ScheduleFieldId fieldId
)
Public Sub New (
    fieldId As ScheduleFieldId
)
public:
ScheduleSortGroupField(
    ScheduleFieldId^ fieldId
)
new :
        fieldId : ScheduleFieldId -> ScheduleSortGroupField

Parameters

fieldId ScheduleFieldId
The ID of the field that the schedule will be sorted or grouped by.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ScheduleSortGroupField Class
ScheduleSortGroupField Overload


ScheduleSortGroupField(ScheduleFieldId, ScheduleSortOrder) Constructor

Creates a new ScheduleSortGroupField.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScheduleSortGroupField(
    ScheduleFieldId fieldId,
    ScheduleSortOrder sortOrder
)
Public Sub New (
    fieldId As ScheduleFieldId,
    sortOrder As ScheduleSortOrder
)
public:
ScheduleSortGroupField(
    ScheduleFieldId^ fieldId,
    ScheduleSortOrder sortOrder
)
new :
        fieldId : ScheduleFieldId *
        sortOrder : ScheduleSortOrder -> ScheduleSortGroupField

Parameters

fieldId ScheduleFieldId
The ID of the field that the schedule will be sorted or grouped by.
sortOrder ScheduleSortOrder
The sort order, ascending or descending.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ScheduleSortGroupField Class
ScheduleSortGroupField Overload


ScheduleSortGroupField Properties

The ScheduleSortGroupField type exposes the following members.

Properties
 | Name | Description
Public property | FieldId | The ID of the field that the schedule will be sorted or grouped by.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ShowBlankLine | Indicates if an empty row should be displayed between groups.
Public property | ShowFooter | Indicates if a footer row should be displayed after each group.
Public property | ShowFooterCount | Indicates if the footer row should display a count of elements in the group.
Public property | ShowFooterTitle | Indicates if the footer row should display a title.
Public property | ShowHeader | Indicates if a header row should be displayed before each group.
Public property | SortOrder | Indicates if elements in the schedule will be sorted in ascending or descending order.
Top
See Also

Reference

ScheduleSortGroupField Class


ScheduleSortGroupField.FieldId Property

ScheduleSortGroupFieldFieldId Property

The ID of the field that the schedule will be sorted or grouped by.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScheduleFieldId FieldId { get; set; }
Public Property FieldId As ScheduleFieldId
    Get
    Set
public:
property ScheduleFieldId^ FieldId {
    ScheduleFieldId^ get ();
    void set (ScheduleFieldId^ value);
}
member FieldId : ScheduleFieldId with get, set

Property Value

ScheduleFieldId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ScheduleSortGroupField Class


ScheduleSortGroupField.IsValidObject Property

ScheduleSortGroupFieldIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ScheduleSortGroupField Class


ScheduleSortGroupField.ShowBlankLine Property

ScheduleSortGroupFieldShowBlankLine Property

Indicates if an empty row should be displayed between groups.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShowBlankLine { get; set; }
Public Property ShowBlankLine As Boolean
    Get
    Set
public:
property bool ShowBlankLine {
    bool get ();
    void set (bool value);
}
member ShowBlankLine : bool with get, set

Property Value

Boolean
Remarks
True if an empty row should be displayed, false otherwise.
See Also

Reference

ScheduleSortGroupField Class


ScheduleSortGroupField.ShowFooter Property

ScheduleSortGroupFieldShowFooter Property

Indicates if a footer row should be displayed after each group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShowFooter { get; set; }
Public Property ShowFooter As Boolean
    Get
    Set
public:
property bool ShowFooter {
    bool get ();
    void set (bool value);
}
member ShowFooter : bool with get, set

Property Value

Boolean
True if a footer row should be displayed, false otherwise.
Remarks
The footer row displays totals of each field for which totals are enabled. It can also optionally display a title (see ShowFooterTitle) and a count of elements (see ShowFooterCount).
See Also

Reference

ScheduleSortGroupField Class


ScheduleSortGroupField.ShowFooterCount Property

ScheduleSortGroupFieldShowFooterCount Property

Indicates if the footer row should display a count of elements in the group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShowFooterCount { get; set; }
Public Property ShowFooterCount As Boolean
    Get
    Set
public:
property bool ShowFooterCount {
    bool get ();
    void set (bool value);
}
member ShowFooterCount : bool with get, set

Property Value

Boolean
True if an element count should be displayed, false otherwise.
Exceptions
Exception | Condition
InvalidOperationException | When setting this property: Display of footer rows is not enabled.
Remarks
ShowFooterCount can only be enabled if ShowFooter is enabled.
See Also

Reference

ScheduleSortGroupField Class


ScheduleSortGroupField.ShowFooterTitle Property

ScheduleSortGroupFieldShowFooterTitle Property

Indicates if the footer row should display a title.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShowFooterTitle { get; set; }
Public Property ShowFooterTitle As Boolean
    Get
    Set
public:
property bool ShowFooterTitle {
    bool get ();
    void set (bool value);
}
member ShowFooterTitle : bool with get, set

Property Value

Boolean
True if a title should be displayed, false otherwise.
Exceptions
Exception | Condition
InvalidOperationException | When setting this property: Display of footer rows is not enabled.
Remarks

The title consists of the value of the field that the schedule is grouped by.

ShowFooterTitle can only be enabled if ShowFooter is enabled.

See Also

Reference

ScheduleSortGroupField Class


ScheduleSortGroupField.ShowHeader Property

ScheduleSortGroupFieldShowHeader Property

Indicates if a header row should be displayed before each group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShowHeader { get; set; }
Public Property ShowHeader As Boolean
    Get
    Set
public:
property bool ShowHeader {
    bool get ();
    void set (bool value);
}
member ShowHeader : bool with get, set

Property Value

Boolean
True if a header row should be displayed, false otherwise.
Remarks
The header row displays a title consisting of the value of the field that the schedule is grouped by.
See Also

Reference

ScheduleSortGroupField Class


ScheduleSortGroupField.SortOrder Property

ScheduleSortGroupFieldSortOrder Property

Indicates if elements in the schedule will be sorted in ascending or descending order.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScheduleSortOrder SortOrder { get; set; }
Public Property SortOrder As ScheduleSortOrder
    Get
    Set
public:
property ScheduleSortOrder SortOrder {
    ScheduleSortOrder get ();
    void set (ScheduleSortOrder value);
}
member SortOrder : ScheduleSortOrder with get, set

Property Value

ScheduleSortOrder
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ScheduleSortGroupField Class


ScheduleSortGroupField Methods

The ScheduleSortGroupField type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ScheduleSortGroupField Class


ScheduleSortGroupField.Dispose Method

ScheduleSortGroupFieldDispose Method

Releases all resources used by the ScheduleSortGroupField

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ScheduleSortGroupField Class


ScheduleSortOrder Enumeration

Options for sort order of rows in a schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ScheduleSortOrder
Public Enumeration ScheduleSortOrder
public enum class ScheduleSortOrder
type ScheduleSortOrder
Members
Member name | Value | Description
Ascending | 0 | Sort in ascending order.
Descending | 1 | Sort in descending order.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ScheduleVerticalAlignment Enumeration

Vertical alignment of data in a schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ScheduleVerticalAlignment
Public Enumeration ScheduleVerticalAlignment
public enum class ScheduleVerticalAlignment
type ScheduleVerticalAlignment
Members
Member name | Value | Description
Top | 0 | Top aligned
Middle | 1 | Middle aligned
Bottom | 2 | Bottom aligned
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SectionType Enumeration

Declares the section data type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum SectionType
Public Enumeration SectionType
public enum class SectionType
type SectionType
Members
Member name | Value | Description
Header | 0 |
Body | 1 |
Summary | 2 |
Footer | 3 |
None | -1 |
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Segment Class

This element represents a segment of an MEP curve object.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBSegment
Autodesk.Revit.DB.PlumbingPipeSegment

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Segment : Element
Public Class Segment
    Inherits Element
public ref class Segment : public Element
type Segment =
    class
        inherit Element
    end

The Segment type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
Public property | Description | The description of the segment.
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | MaterialId | The ElementId of the MaterialElem.
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Roughness | The roughness value for given material.
Public property | SizeCount | The number of size objects in the segment.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | AddSize | Adds a new MEPSize to the segment.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSizes | Gets the defined sizes of the segment.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveSize | Remove the existing MEPSize with this nominal diameter from the segment.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Currently, only pipe curves can be broken into separate segment elements.
Example
C#
VB
C++
F#
Copy
private void GetPipeSegmentSizesFromDocument(Document document)
{
    FilteredElementCollector collectorPipeType = new FilteredElementCollector(document);
    collectorPipeType.OfClass(typeof(Segment));

    IEnumerable<Segment> segments = collectorPipeType.ToElements().Cast<Segment>();
    foreach (Segment segment in segments)
    {
        StringBuilder strPipeInfo = new StringBuilder();
        strPipeInfo.AppendLine("Segment: " + segment.Name);

        strPipeInfo.AppendLine("Roughness: " + segment.Roughness);

        strPipeInfo.AppendLine("Pipe Sizes:");
        double dLengthFac = 304.8;  // used to convert stored units from ft to mm for display
        foreach (MEPSize size in segment.GetSizes())
        {
            strPipeInfo.AppendLine(string.Format("Nominal: {0:F3}, ID: {1:F3}, OD: {2:F3}",
                                        size.NominalDiameter * dLengthFac, size.InnerDiameter * dLengthFac, size.OuterDiameter * dLengthFac));
        }

        Autodesk.Revit.UI.TaskDialog.Show("PipeSetting Data", strPipeInfo.ToString());
        break;
    }
}
Private Sub GetPipeSegmentSizesFromDocument(document As Document)
   Dim collectorPipeType As New FilteredElementCollector(document)
   collectorPipeType.OfClass(GetType(Segment))

   Dim segments As IEnumerable(Of Segment) = collectorPipeType.ToElements().Cast(Of Segment)()
   For Each segment As Segment In segments
      Dim strPipeInfo As New StringBuilder()
      strPipeInfo.AppendLine("Segment: " + segment.Name)

      strPipeInfo.AppendLine("Roughness: " + segment.Roughness)

      strPipeInfo.AppendLine("Pipe Sizes:")
      Dim dLengthFac As Double = 304.8
      ' used to convert stored units from ft to mm for display
      For Each size As MEPSize In segment.GetSizes()
         strPipeInfo.AppendLine(String.Format("Nominal: {0:F3}, ID: {1:F3}, OD: {2:F3}", size.NominalDiameter * dLengthFac, size.InnerDiameter * dLengthFac, size.OuterDiameter * dLengthFac))
      Next

      Autodesk.Revit.UI.TaskDialog.Show("PipeSetting Data", strPipeInfo.ToString())
      Exit For
   Next
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Segment Properties

The Segment type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
Public property | Description | The description of the segment.
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | MaterialId | The ElementId of the MaterialElem.
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Roughness | The roughness value for given material.
Public property | SizeCount | The number of size objects in the segment.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

Segment Class


Segment.Description Property

SegmentDescription Property

The description of the segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

Segment Class


Segment.MaterialId Property

SegmentMaterialId Property

The ElementId of the MaterialElem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId MaterialId { get; }
Public ReadOnly Property MaterialId As ElementId
    Get
public:
property ElementId^ MaterialId {
    ElementId^ get ();
}
member MaterialId : ElementId with get

Property Value

ElementId
See Also

Reference

Segment Class


Segment.Roughness Property

SegmentRoughness Property

The roughness value for given material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Roughness { get; set; }
Public Property Roughness As Double
    Get
    Set
public:
property double Roughness {
    double get ();
    void set (double value);
}
member Roughness : float with get, set

Property Value

Double
See Also

Reference

Segment Class


Segment.SizeCount Property

SegmentSizeCount Property

The number of size objects in the segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int SizeCount { get; }
Public ReadOnly Property SizeCount As Integer
    Get
public:
property int SizeCount {
    int get ();
}
member SizeCount : int with get

Property Value

Int32
See Also

Reference

Segment Class


Segment Methods

The Segment type exposes the following members.

Methods
 | Name | Description
Public method | AddSize | Adds a new MEPSize to the segment.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSizes | Gets the defined sizes of the segment.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveSize | Remove the existing MEPSize with this nominal diameter from the segment.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Segment Class


Segment.AddSize Method

SegmentAddSize Method

Adds a new MEPSize to the segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddSize(
    MEPSize size
)
Public Sub AddSize (
    size As MEPSize
)
public:
void AddSize(
    MEPSize^ size
)
member AddSize :
        size : MEPSize -> unit

Parameters

size MEPSize
The new MEPSize to be added.
Exceptions
Exception | Condition
ArgumentException | There is already a same size in the settings. -or- The size already exists in the segment.
ArgumentNullException | A non-optional argument was null
See Also

Reference

Segment Class


Segment.GetSizes Method

SegmentGetSizes Method

Gets the defined sizes of the segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<MEPSize> GetSizes()
Public Function GetSizes As ICollection(Of MEPSize)
public:
ICollection<MEPSize^>^ GetSizes()
member GetSizes : unit -> ICollection<MEPSize>

Return Value

ICollection MEPSize
See Also

Reference

Segment Class


Segment.RemoveSize Method

SegmentRemoveSize Method

Remove the existing MEPSize with this nominal diameter from the segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveSize(
    double nominalDiameter
)
Public Sub RemoveSize (
    nominalDiameter As Double
)
public:
void RemoveSize(
    double nominalDiameter
)
member RemoveSize :
        nominalDiameter : float -> unit

Parameters

nominalDiameter Double
The nominal diameter of the size.
Exceptions
Exception | Condition
InvalidOperationException | The last size of the segment cannot be removed.
Remarks
Does nothing if there is no existing MEPSize with this nominal diameter.
See Also

Reference

Segment Class


SelectionFilterAction Enumeration

An enumerated type containing the type of actions that may be taken with a selection filter applied to a point cloud.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum SelectionFilterAction
Public Enumeration SelectionFilterAction
public enum class SelectionFilterAction
type SelectionFilterAction
Members
Member name | Value | Description
None | 0 | Selection filter is ignored.
Highlight | 1 | Points that pass the filter are highlighted.
Isolate | 2 | Only points that pass the filter are visible.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SelectionFilterElement Class

A filter element that stores an explicit list of ElementIds. Only elements whose ElementIds are in this list will pass the filter.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBFilterElement
Autodesk.Revit.DBSelectionFilterElement

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SelectionFilterElement : FilterElement
Public Class SelectionFilterElement
    Inherits FilterElement
public ref class SelectionFilterElement : public FilterElement
type SelectionFilterElement =
    class
        inherit FilterElement
    end

The SelectionFilterElement type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | AddSet | Adds a set of ElementIds to the filter's set.
Public method | AddSingle | Adds a single ElementId to the filter's set.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | Clear | Removes all ElementIds from the filter.
Public method | Contains | Returns true if the given ElementId is a member of this filter's set.
 | Create | Creates a new SelectionFilterElement in the given document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetElementIds | Returns the set of ElementIds contained by this filter.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsEmpty | Determines whether this filter's set is empty or not.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsNameUnique(String) | Determines whether a potential filter element name is unique. (Inherited from FilterElement)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveSet | Removes a set of ElementIds from the filter's set.
Public method | RemoveSingle | Removes a single ElementId from the filter's set.
Public method | SetElementIds | Replaces the set of ElementIds contained by this filter.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Example
C#
VB
C++
F#
Copy
public static void CreateSelectionFilter(Document doc, View view)
{
    // find room tags in this view
    FilteredElementCollector collector = new FilteredElementCollector(doc, view.Id);
    collector.WherePasses(new RoomTagFilter());

    // collect tags whose room number matches criteria
    List<ElementId> tagIds = new List<ElementId>();

    foreach (RoomTag tag in collector.Cast<RoomTag>())
    {
        int number = Int32.Parse(tag.Room.Number);
        if (number % 3 == 0)
        {
            tagIds.Add(tag.Id);
        }
    }

    using (Transaction t = new Transaction(doc, "Create SelectionFilterElement"))
    {
        t.Start();

        // Create selection filter and assign ids
        SelectionFilterElement filterElement = SelectionFilterElement.Create(doc, "Room tags filter");
        filterElement.SetElementIds(tagIds);

        ElementId filterId = filterElement.Id;

        // Add the filter to the view
        view.AddFilter(filterId);

        doc.Regenerate();

        // Use the existing graphics settings, and change the color to Blue
        OverrideGraphicSettings overrideSettings = view.GetFilterOverrides(filterId);

        overrideSettings.SetProjectionLineColor(new Color(0x00, 0x00, 0xFF));

        view.SetFilterOverrides(filterId, overrideSettings);

        t.Commit();
    }
}
Public Shared Sub CreateSelectionFilter(doc As Document, view As View)
    ' find room tags in this view
    Dim collector As New FilteredElementCollector(doc, view.Id)
    collector.WherePasses(New RoomTagFilter())

    ' collect tags whose room number matches criteria
    Dim tagIds As New List(Of ElementId)()

    For Each tag As RoomTag In collector.Cast(Of RoomTag)()
        Dim number As Integer = Int32.Parse(tag.Room.Number)
        If number Mod 3 = 0 Then
            tagIds.Add(tag.Id)
        End If
    Next

    Using t As New Transaction(doc, "Create SelectionFilterElement")
        t.Start()

        ' Create selection filter and assign ids
        Dim filterElement As SelectionFilterElement = SelectionFilterElement.Create(doc, "Room tags filter")
        filterElement.SetElementIds(tagIds)

        Dim filterId As ElementId = filterElement.Id

        ' Add the filter to the view
        view.AddFilter(filterId)

        doc.Regenerate()

        ' Use the existing graphics settings, and change the color to Blue
        Dim overrideSettings As OverrideGraphicSettings = view.GetFilterOverrides(filterId)

        overrideSettings.SetProjectionLineColor(New Color(&H0, &H0, &Hff))

        view.SetFilterOverrides(filterId, overrideSettings)

        t.Commit()
    End Using
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SelectionFilterElement Properties

The SelectionFilterElement type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

SelectionFilterElement Class


SelectionFilterElement Methods

The SelectionFilterElement type exposes the following members.

Methods
 | Name | Description
Public method | AddSet | Adds a set of ElementIds to the filter's set.
Public method | AddSingle | Adds a single ElementId to the filter's set.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | Clear | Removes all ElementIds from the filter.
Public method | Contains | Returns true if the given ElementId is a member of this filter's set.
 | Create | Creates a new SelectionFilterElement in the given document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetElementIds | Returns the set of ElementIds contained by this filter.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsEmpty | Determines whether this filter's set is empty or not.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsNameUnique(String) | Determines whether a potential filter element name is unique. (Inherited from FilterElement)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveSet | Removes a set of ElementIds from the filter's set.
Public method | RemoveSingle | Removes a single ElementId from the filter's set.
Public method | SetElementIds | Replaces the set of ElementIds contained by this filter.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SelectionFilterElement Class


SelectionFilterElement.AddSet Method

SelectionFilterElementAddSet Method

Adds a set of ElementIds to the filter's set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddSet(
    ICollection<ElementId> ids
)
Public Sub AddSet (
    ids As ICollection(Of ElementId)
)
public:
void AddSet(
    ICollection<ElementId^>^ ids
)
member AddSet :
        ids : ICollection<ElementId> -> unit

Parameters

ids ICollection ElementId
The set of ElementIds to add.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

SelectionFilterElement Class


SelectionFilterElement.AddSingle Method

SelectionFilterElementAddSingle Method

Adds a single ElementId to the filter's set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddSingle(
    ElementId id
)
Public Sub AddSingle (
    id As ElementId
)
public:
void AddSingle(
    ElementId^ id
)
member AddSingle :
        id : ElementId -> unit

Parameters

id ElementId
The ElementId to add.
Exceptions
Exception | Condition
ArgumentException | Invalid ElementId
ArgumentNullException | A non-optional argument was null
See Also

Reference

SelectionFilterElement Class


SelectionFilterElement.Clear Method

SelectionFilterElementClear Method

Removes all ElementIds from the filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

SelectionFilterElement Class


SelectionFilterElement.Contains Method

SelectionFilterElementContains Method

Returns true if the given ElementId is a member of this filter's set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Contains(
    ElementId id
)
Public Function Contains (
    id As ElementId
) As Boolean
public:
bool Contains(
    ElementId^ id
)
member Contains :
        id : ElementId -> bool

Parameters

id ElementId
The ElementId to look for.

Return Value

Boolean
True if the given ElementId is a member of the filter, otherwise false.
Exceptions
Exception | Condition
ArgumentException | Invalid ElementId
ArgumentNullException | A non-optional argument was null
See Also

Reference

SelectionFilterElement Class


SelectionFilterElement.Create Method

SelectionFilterElementCreate Method

Creates a new SelectionFilterElement in the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SelectionFilterElement Create(
    Document document,
    string name
)
Public Shared Function Create (
    document As Document,
    name As String
) As SelectionFilterElement
public:
static SelectionFilterElement^ Create(
    Document^ document,
    String^ name
)
static member Create :
        document : Document *
        name : string -> SelectionFilterElement

Parameters

document Document
The document in which to create the SelectionFilterElement.
name String
The name for the new SelectionFilterElement.

Return Value

SelectionFilterElement
The new SelectionFilterElement.
Exceptions
Exception | Condition
ArgumentException | name is an empty string or contains only whitespace. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- The given value for name is already in use as a filter element name.
ArgumentNullException | A non-optional argument was null
See Also

Reference

SelectionFilterElement Class


SelectionFilterElement.GetElementIds Method

SelectionFilterElementGetElementIds Method

Returns the set of ElementIds contained by this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetElementIds()
Public Function GetElementIds As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetElementIds()
member GetElementIds : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
The set of ElementIds.
See Also

Reference

SelectionFilterElement Class


SelectionFilterElement.IsEmpty Method

SelectionFilterElementIsEmpty Method

Determines whether this filter's set is empty or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEmpty()
Public Function IsEmpty As Boolean
public:
bool IsEmpty()
member IsEmpty : unit -> bool

Return Value

Boolean
True if the set is empty, otherwise false.
See Also

Reference

SelectionFilterElement Class


SelectionFilterElement.RemoveSet Method

SelectionFilterElementRemoveSet Method

Removes a set of ElementIds from the filter's set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int RemoveSet(
    ICollection<ElementId> ids
)
Public Function RemoveSet (
    ids As ICollection(Of ElementId)
) As Integer
public:
int RemoveSet(
    ICollection<ElementId^>^ ids
)
member RemoveSet :
        ids : ICollection<ElementId> -> int

Parameters

ids ICollection ElementId
The set of ElementIds to remove.

Return Value

Int32
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

SelectionFilterElement Class


SelectionFilterElement.RemoveSingle Method

SelectionFilterElementRemoveSingle Method

Removes a single ElementId from the filter's set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveSingle(
    ElementId id
)
Public Sub RemoveSingle (
    id As ElementId
)
public:
void RemoveSingle(
    ElementId^ id
)
member RemoveSingle :
        id : ElementId -> unit

Parameters

id ElementId
The ElementId to remove.
Exceptions
Exception | Condition
ArgumentException | Invalid ElementId
ArgumentNullException | A non-optional argument was null
See Also

Reference

SelectionFilterElement Class


SelectionFilterElement.SetElementIds Method

SelectionFilterElementSetElementIds Method

Replaces the set of ElementIds contained by this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetElementIds(
    ICollection<ElementId> ids
)
Public Sub SetElementIds (
    ids As ICollection(Of ElementId)
)
public:
void SetElementIds(
    ICollection<ElementId^>^ ids
)
member SetElementIds :
        ids : ICollection<ElementId> -> unit

Parameters

ids ICollection ElementId
The new set of ElementIds.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

SelectionFilterElement Class


ServerPath Class

This class represents a path to a Revit Server location, rather than a location on disk or a network drive.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBModelPath
Autodesk.Revit.DBServerPath

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ServerPath : ModelPath
Public Class ServerPath
    Inherits ModelPath
public ref class ServerPath : public ModelPath
type ServerPath =
    class
        inherit ModelPath
    end

The ServerPath type exposes the following members.

Constructors
 | Name | Description
Public method | ServerPath | Constructs a ServerPath
Top
Properties
 | Name | Description
Public property | CentralServerPath | The path to the location of the central Revit server or cloud. (Inherited from ModelPath)
Public property | CloudPath | Whether this path represents a path on an Autodesk server such as BIM360. (Inherited from ModelPath)
Public property | Empty | Whether this path is empty (Inherited from ModelPath)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ModelPath)
Public property | Region | The region of the BIM 360 Docs or Autodesk Docs account and project which contains this model. (Inherited from ModelPath)
Public property | ServerPath | Whether this path is a server path (as opposed to a file path or cloud path) (Inherited from ModelPath)
Top
Methods
 | Name | Description
Public method | Compare | Compares this ModelPath with another (Inherited from ModelPath)
Public method | Dispose | (Inherited from ModelPath)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetModelGUID | A GUID identifying the Revit cloud model. (Inherited from ModelPath)
Public method | GetProjectGUID | A GUID identifying the BIM 360 Docs or Autodesk Docs project to which the model is associated. (Inherited from ModelPath)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

ServerPaths must refer to Revit models.

ServerPaths are relative to the central server location, and are of the form "RSN://{HostNodeName}/{model_path}".

The {model_path} portion is a relative path to a Revit model. For example, the following are valid server paths:

  • RSN://EXS/hospital.rvt
  • RSN://EXS.autodesk.com/Old Files/hotel2.rvt
  • RSN://EXS.autodesk.com/Old Files/Last Week/Tuesday\hotel2.rvt
The following would not be valid server paths:
  • //EXS/Old Files/.rvt
  • EXS/hospital
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ServerPath Constructor

Constructs a ServerPath

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ServerPath(
    string centralServerLocation,
    string path
)
Public Sub New (
    centralServerLocation As String,
    path As String
)
public:
ServerPath(
    String^ centralServerLocation,
    String^ path
)
new :
        centralServerLocation : string *
        path : string -> ServerPath

Parameters

centralServerLocation String
The name of the central Revit server
path String
The path of the model. This path must be relative.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ServerPath Class


ServerPath Properties

The ServerPath type exposes the following members.

Properties
 | Name | Description
Public property | CentralServerPath | The path to the location of the central Revit server or cloud. (Inherited from ModelPath)
Public property | CloudPath | Whether this path represents a path on an Autodesk server such as BIM360. (Inherited from ModelPath)
Public property | Empty | Whether this path is empty (Inherited from ModelPath)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ModelPath)
Public property | Region | The region of the BIM 360 Docs or Autodesk Docs account and project which contains this model. (Inherited from ModelPath)
Public property | ServerPath | Whether this path is a server path (as opposed to a file path or cloud path) (Inherited from ModelPath)
Top
See Also

Reference

ServerPath Class


ServerPath Methods

The ServerPath type exposes the following members.

Methods
 | Name | Description
Public method | Compare | Compares this ModelPath with another (Inherited from ModelPath)
Public method | Dispose | (Inherited from ModelPath)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetModelGUID | A GUID identifying the Revit cloud model. (Inherited from ModelPath)
Public method | GetProjectGUID | A GUID identifying the BIM 360 Docs or Autodesk Docs project to which the model is associated. (Inherited from ModelPath)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ServerPath Class


ServiceType Enumeration

This enumeration is used for specifying the most predominant service for the building or space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ServiceType
Public Enumeration ServiceType
public enum class ServiceType
type ServiceType
Members
Member name | Value | Description
kCentralHeatingRadiators | 0 | Service Type is CentralHeatingRadiators.
kCentralHeatingConvectors | 1 | Service Type is CentralHeatingConvectors.
kCentralHeatingRadiantFloor | 2 | Service Type is CentralHeatingRadiantFloor.
kCentralHeatingHotAir | 3 | Service Type is CentralHeatingHotAir.
kOtherRoomHeater | 4 | Service Type is OtherRoomHeater.
kRadiantHeaterFlue | 5 | Service Type is RadiantHeaterFlue.
kRadiantHeaterNoFlue | 6 | Service Type is RadiantHeaterNoFlue.
kRadiantHeaterMultiburner | 7 | Service Type is RadiantHeaterMultiburner.
kForcedConvectionHeaterFlue | 8 | Service Type is ForcedConvectionHeaterFlue.
kForcedConvectionHeaterNoFlue | 9 | Service Type is ForcedConvectionHeaterNoFlue.
kNoServiceType | -1 | Service Type is NoServiceType.
kVAVSingleDuct | 10 | Service Type is VAVSingleDuct.
kVAVDualDuct | 11 | Service Type is VAVDualDuct.
kVAVIndoorPackagedCabinet | 12 | Service Type is VAVIndoorPackagedCabinet.
kVAVTerminalReheat | 13 | Service Type is VAVTerminalReheat.
kFanCoilSystem | 14 | Service Type is FanCoilSystem.
kInductionSystem | 15 | Service Type is InductionSystem.
kConstantVolumeFixedOA | 16 | Service Type is ConstantVolumeFixedOA.
kConstantVolumeVariableOA | 17 | Service Type is ConstantVolumeVariableOA.
kConstantVolumeTerminalReheat | 18 | Service Type is ConstantVolumeTerminalReheat.
kMultizoneHotDeckColdDeck | 19 | Service Type is MultizoneHotDeckColdDeck.
kConstantVolumeDualDuct | 20 | Service Type is ConstantVolumeDualDuct.
kRadiantCooledCeilings | 21 | Service Type is RadiantCooledCeilings.
kActiveChilledBeams | 22 | Service Type is ActiveChilledBeams.
kWaterLoopHeatPump | 23 | Service Type is WaterLoopHeatPump.
kVariableRefrigerantFlow | 24 | Service Type is VariableRefrigerantFlow.
kSplitSystemsWithNaturalVentilation | 25 | Service Type is SplitSystemsWithNaturalVentilation.
kSplitSystemsWithMechanicalVentilation | 26 | Service Type is SplitSystemsWithMechanicalVentilation.
kSplitSystemsWithMechanicalVentilationWithCooling | 27 | Service Type is SplitSystemsWithMechanicalVentilationWithCooling.
Remarks
This enumerated list corresponds to the serviceType attribute in the gbXML (Green Building XML) schema and is primarily used for energy analysis.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SetComparisonResult Enumeration

An enumerated type listing all the relationship types between two sets of arbitrary nature.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum SetComparisonResult
Public Enumeration SetComparisonResult
public enum class SetComparisonResult
type SetComparisonResult
Members
Member name | Value | Description
LeftEmpty | 1 | The left set is empty and the right set is not.
RightEmpty | 2 | The right set is empty and the left set is not.
BothEmpty | 3 | Both sets are empty.
Disjoint | 4 | Both sets are not empty and don't overlap.
Overlap | 8 | The overlap of two sets is not empty and strict subset of both.
Subset | 16 | Both sets are not empty and the left set is strict subset of the right.
Superset | 32 | Both sets are not empty and the left set is strict superset of the right.
Equal | 64 | Two nonempty sets are equal.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Settings Class

The settings object provides access to general components of the Autodesk Revit application, such as Categories.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Settings : APIObject
Public Class Settings
    Inherits APIObject
public ref class Settings : public APIObject
type Settings =
    class
        inherit APIObject
    end

The Settings type exposes the following members.

Properties
 | Name | Description
Public property | Categories | Retrieves an object that provides access to all the categories contained in the Autodesk Revit application and project.
Public property | ElectricalSetting | Retrieves an object that provides access to all the electrical settings include voltage type, distribution system type, demand factor, wire type in the Autodesk Revit application and project.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | TilePatterns | Retrieves an object that provides access to the TilePattern objects in the document.
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Example
C#
VB
C++
F#
Copy
// Get some of the settings information, including categories and FillPatterns
Settings settings = document.Settings;

// Format the prompt information string
String prompt = "Setting information: ";
prompt += "\nNumber of Categories: " + settings.Categories.Size;
FilteredElementCollector fillPatternCollector = new FilteredElementCollector(document);
prompt += "\nNumber of Fill Patterns: " + fillPatternCollector.OfClass(typeof(FillPatternElement)).Count();
FilteredElementCollector linePatternCollector = new FilteredElementCollector(document);
prompt += "\nNumber of Line Patterns: " + linePatternCollector.OfClass(typeof(LinePatternElement)).Count();

// Give the user some information
TaskDialog.Show("Revit",prompt);
' Get some of the settings information, including categories and FillPatterns
Dim settings As Settings = document.Settings

' Format the prompt information string
Dim prompt As [String] = "Setting information: "
prompt += vbLf & "Number of Categories: " + settings.Categories.Size
Dim fillPatternCollector As New FilteredElementCollector(document)
prompt += vbLf & "Number of Fill Patterns: " & fillPatternCollector.OfClass(GetType(FillPatternElement)).Count()
Dim linePatternCollector As New FilteredElementCollector(document)
prompt += vbLf & "Number of Line Patterns: " & linePatternCollector.OfClass(GetType(LinePatternElement)).Count()

' Give the user some information
TaskDialog.Show("Revit", prompt)

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Settings Properties

The Settings type exposes the following members.

Properties
 | Name | Description
Public property | Categories | Retrieves an object that provides access to all the categories contained in the Autodesk Revit application and project.
Public property | ElectricalSetting | Retrieves an object that provides access to all the electrical settings include voltage type, distribution system type, demand factor, wire type in the Autodesk Revit application and project.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | TilePatterns | Retrieves an object that provides access to the TilePattern objects in the document.
Top
See Also

Reference

Settings Class


Settings.Categories Property

SettingsCategories Property

Retrieves an object that provides access to all the categories contained in the Autodesk Revit application and project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Categories Categories { get; }
Public ReadOnly Property Categories As Categories
    Get
public:
property Categories^ Categories {
    Categories^ get ();
}
member Categories : Categories with get

Property Value

Categories
See Also

Reference

Settings Class


Settings.ElectricalSetting Property

SettingsElectricalSetting Property

Retrieves an object that provides access to all the electrical settings include voltage type, distribution system type, demand factor, wire type in the Autodesk Revit application and project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElectricalSetting ElectricalSetting { get; }
Public ReadOnly Property ElectricalSetting As ElectricalSetting
    Get
public:
property ElectricalSetting^ ElectricalSetting {
    ElectricalSetting^ get ();
}
member ElectricalSetting : ElectricalSetting with get

Property Value

ElectricalSetting
Exceptions
Exception | Condition
InvalidOperationException | Electrical settings can be accessed only if Revit MEP product is available.
See Also

Reference

Settings Class


Settings.TilePatterns Property

SettingsTilePatterns Property

Retrieves an object that provides access to the TilePattern objects in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TilePatterns TilePatterns { get; }
Public ReadOnly Property TilePatterns As TilePatterns
    Get
public:
property TilePatterns^ TilePatterns {
    TilePatterns^ get ();
}
member TilePatterns : TilePatterns with get

Property Value

TilePatterns
See Also

Reference

Settings Class


Settings Methods

The Settings type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Settings Class


ShapeBuilder Class

The base class for geometry builder classes.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBShapeBuilder
Autodesk.Revit.DBBRepBuilder
Autodesk.Revit.DBTessellatedShapeBuilder
Autodesk.Revit.DBViewShapeBuilder
Autodesk.Revit.DBWireframeBuilder

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ShapeBuilder : IDisposable
Public Class ShapeBuilder
    Implements IDisposable
public ref class ShapeBuilder : IDisposable
type ShapeBuilder =
    class
        interface IDisposable
    end

The ShapeBuilder type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ShapeBuilder
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ShapeBuilder Properties

The ShapeBuilder type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

ShapeBuilder Class


ShapeBuilder.IsValidObject Property

ShapeBuilderIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ShapeBuilder Class


ShapeBuilder Methods

The ShapeBuilder type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ShapeBuilder Class


ShapeBuilder.Dispose Method

ShapeBuilderDispose Method

Releases all resources used by the ShapeBuilder

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ShapeBuilder Class


ShapeImporter Class

A utility class that supports conversion of geometry stored in an external format into a Revit geometry objects.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBShapeImporter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ShapeImporter : IDisposable
Public Class ShapeImporter
    Implements IDisposable
public ref class ShapeImporter : IDisposable
type ShapeImporter =
    class
        interface IDisposable
    end

The ShapeImporter type exposes the following members.

Constructors
 | Name | Description
Public method | ShapeImporter | Default constructor. Initializes an instance of ShapeImporter that will automatically recognize the file format from its extension (ShapeImporterSourceFormat.Auto).
Top
Properties
 | Name | Description
Public property | DefaultLengthUnit | The length unit to be used if not specified when the input is a unitless SAT file.
Public property | InputFormat | The format of the incoming data.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Convert | Converts the geometry stored in the external format into a collection of Revit geometry objects.
Public method | Dispose | Releases all resources used by the ShapeImporter
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | IsServiceAvailable | Checks whether the data conversion service is available.
Public method | SetDefaultLengthUnit | Sets the length unit to be used when the input is a unitless SAT file.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
See ShapeImporterSourceFormat for the list of supported formats.
Example
C#
VB
C++
F#
Copy
public void ReadSATFile(Document revitDoc)
{
    // Allow the user to select a SAT file.
    OpenFileDialog ofd = new OpenFileDialog();
    ofd.Filter = "SAT Files (*.sat)|*.sat";

    if (DialogResult.OK == ofd.ShowDialog())
    {
        ShapeImporter shapeImporter = new ShapeImporter();
        shapeImporter.InputFormat = ShapeImporterSourceFormat.SAT;
        IList<GeometryObject> shapes = shapeImporter.Convert(revitDoc, ofd.FileName);

        if (shapes.Count != 0)
        {
            using (Transaction tr = new Transaction(revitDoc, "Create a DirectShape"))
            {
                tr.Start();

                DirectShape dsImportedSat = DirectShape.CreateElement(revitDoc, new ElementId(BuiltInCategory.OST_Walls));
                dsImportedSat.SetShape(shapes);

                tr.Commit();
            }
        }
    }
}
Public Sub ReadSATFile(revitDoc As Document)
    ' Allow the user to select a SAT file.
    Dim ofd As New OpenFileDialog()
    ofd.Filter = "SAT Files (*.sat)|*.sat"

    If DialogResult.OK = ofd.ShowDialog() Then
        Dim shapeImporter As New ShapeImporter()
        shapeImporter.InputFormat = ShapeImporterSourceFormat.SAT
        Dim shapes As IList(Of GeometryObject) = shapeImporter.Convert(revitDoc, ofd.FileName)

        If shapes.Count <> 0 Then
            Using tr As New Transaction(revitDoc, "Create a DirectShape")
                tr.Start()

                Dim dsImportedSat As DirectShape = DirectShape.CreateElement(revitDoc, New ElementId(BuiltInCategory.OST_Walls))
                dsImportedSat.SetShape(shapes)

                tr.Commit()
            End Using
        End If
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ShapeImporter Constructor

Default constructor. Initializes an instance of ShapeImporter that will automatically recognize the file format from its extension (ShapeImporterSourceFormat.Auto).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ShapeImporter()
Public Sub New
public:
ShapeImporter()
new : unit -> ShapeImporter
See Also

Reference

ShapeImporter Class


ShapeImporter Properties

The ShapeImporter type exposes the following members.

Properties
 | Name | Description
Public property | DefaultLengthUnit | The length unit to be used if not specified when the input is a unitless SAT file.
Public property | InputFormat | The format of the incoming data.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

ShapeImporter Class


ShapeImporter.DefaultLengthUnit Property

ShapeImporterDefaultLengthUnit Property

The length unit to be used if not specified when the input is a unitless SAT file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImportUnit DefaultLengthUnit { get; }
Public ReadOnly Property DefaultLengthUnit As ImportUnit
    Get
public:
property ImportUnit DefaultLengthUnit {
    ImportUnit get ();
}
member DefaultLengthUnit : ImportUnit with get

Property Value

ImportUnit
Remarks
If the input is a unitless SAT file then this length unit will be used as a backup.
See Also

Reference

ShapeImporter Class


ShapeImporter.InputFormat Property

ShapeImporterInputFormat Property

The format of the incoming data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ShapeImporterSourceFormat InputFormat { get; set; }
Public Property InputFormat As ShapeImporterSourceFormat
    Get
    Set
public:
property ShapeImporterSourceFormat InputFormat {
    ShapeImporterSourceFormat get ();
    void set (ShapeImporterSourceFormat value);
}
member InputFormat : ShapeImporterSourceFormat with get, set

Property Value

ShapeImporterSourceFormat
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
If this option is set to Auto (the default), the file name extension will be used to determine the input format. That covers most file-based data import workflows. Specify the input format explicitly to perform an additional sanity check or if you are using a non-standard file extension.
See Also

Reference

ShapeImporter Class


ShapeImporter.IsValidObject Property

ShapeImporterIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ShapeImporter Class


ShapeImporter Methods

The ShapeImporter type exposes the following members.

Methods
 | Name | Description
Public method | Convert | Converts the geometry stored in the external format into a collection of Revit geometry objects.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | IsServiceAvailable | Checks whether the data conversion service is available.
Public method | SetDefaultLengthUnit | Sets the length unit to be used when the input is a unitless SAT file.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ShapeImporter Class


ShapeImporter.Convert Method

ShapeImporterConvert Method

Converts the geometry stored in the external format into a collection of Revit geometry objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<GeometryObject> Convert(
    Document document,
    string filename
)
Public Function Convert (
    document As Document,
    filename As String
) As IList(Of GeometryObject)
public:
IList<GeometryObject^>^ Convert(
    Document^ document,
    String^ filename
)
member Convert :
        document : Document *
        filename : string -> IList<GeometryObject>

Parameters

document Document
The Revit document where the resulting Revit geometry objects will be used. This document may need to be modified to store dependent elements such as graphics styles and/or materials.
filename String
The full path to the input file.

Return Value

IList GeometryObject
A collection of Revit geometry objects created from the incoming data.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
FileArgumentNotFoundException | The given filename does not exist.
InvalidOperationException | Data conversion service is not available.
See Also

Reference

ShapeImporter Class


ShapeImporter.Dispose Method

ShapeImporterDispose Method

Releases all resources used by the ShapeImporter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ShapeImporter Class


ShapeImporter.IsServiceAvailable Method

ShapeImporterIsServiceAvailable Method

Checks whether the data conversion service is available.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsServiceAvailable()
Public Shared Function IsServiceAvailable As Boolean
public:
static bool IsServiceAvailable()
static member IsServiceAvailable : unit -> bool

Return Value

Boolean
True if the data conversion service is available, false otherwise.
Remarks
ShapeImporter relies on optional data conversion functionality. This function checks whether it is available.
See Also

Reference

ShapeImporter Class


ShapeImporter.SetDefaultLengthUnit Method

ShapeImporterSetDefaultLengthUnit Method

Sets the length unit to be used when the input is a unitless SAT file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ShapeImporter SetDefaultLengthUnit(
    ImportUnit defaultLengthUnit
)
Public Function SetDefaultLengthUnit (
    defaultLengthUnit As ImportUnit
) As ShapeImporter
public:
ShapeImporter^ SetDefaultLengthUnit(
    ImportUnit defaultLengthUnit
)
member SetDefaultLengthUnit :
        defaultLengthUnit : ImportUnit -> ShapeImporter

Parameters

defaultLengthUnit ImportUnit
The length unit to be used for when the input is a unitless SAT file.

Return Value

ShapeImporter
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Remarks
Values ImportUnit::Default and ImportUnit::Custom are ignored. ImportUnit::Centimeter is used instead.
See Also

Reference

ShapeImporter Class


ShapeImporterSourceFormat Enumeration

An enumerated type listing the possible formats supported by the Shapeimporter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ShapeImporterSourceFormat
Public Enumeration ShapeImporterSourceFormat
public enum class ShapeImporterSourceFormat
type ShapeImporterSourceFormat
Members
Member name | Value | Description
Auto | 0 | The format of the incoming data will be determined from input file extension.
SAT | 1 | The incoming data is in SAT format (*.sat).
Rhino | 2 | The incoming data is in Rhino format (*.3dm).
SketchUp | 3 | The incoming data is in SketchUp format (*.skp).
OBJ | 4 | The incoming data is in OBJ format (*.obj).
STL | 5 | The incoming data is in STL format (*.stl).
STEP | 11 | The incoming data is in STEP format (*.step, *.stp, *.stpz).
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SharedParameterApplicableRule Class

Tests whether an element supports a shared parameter.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilterRule
Autodesk.Revit.DBSharedParameterApplicableRule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SharedParameterApplicableRule : FilterRule
Public Class SharedParameterApplicableRule
    Inherits FilterRule
public ref class SharedParameterApplicableRule : public FilterRule
type SharedParameterApplicableRule =
    class
        inherit FilterRule
    end

The SharedParameterApplicableRule type exposes the following members.

Constructors
 | Name | Description
Public method | SharedParameterApplicableRule | Constructs an instance of SharedParameterApplicableRule.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule)
Public property | ParameterName | The name of the parameter that an element must support to pass this rule.
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterRule)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SharedParameterApplicableRule Constructor

Constructs an instance of SharedParameterApplicableRule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SharedParameterApplicableRule(
    string parameterName
)
Public Sub New (
    parameterName As String
)
public:
SharedParameterApplicableRule(
    String^ parameterName
)
new :
        parameterName : string -> SharedParameterApplicableRule

Parameters

parameterName String
The name of the parameter that an element must support to pass this rule.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

SharedParameterApplicableRule Class


SharedParameterApplicableRule Properties

The SharedParameterApplicableRule type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule)
Public property | ParameterName | The name of the parameter that an element must support to pass this rule.
Top
See Also

Reference

SharedParameterApplicableRule Class


SharedParameterApplicableRule.ParameterName Property

SharedParameterApplicableRuleParameterName Property

The name of the parameter that an element must support to pass this rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ParameterName { get; set; }
Public Property ParameterName As String
    Get
    Set
public:
property String^ ParameterName {
    String^ get ();
    void set (String^ value);
}
member ParameterName : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

SharedParameterApplicableRule Class


SharedParameterApplicableRule Methods

The SharedParameterApplicableRule type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from FilterRule)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SharedParameterApplicableRule Class


SharedParameterElement Class

An element that stores the definition of a shared parameter which is loaded into the document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBParameterElement
Autodesk.Revit.DBSharedParameterElement

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SharedParameterElement : ParameterElement
Public Class SharedParameterElement
    Inherits ParameterElement
public ref class SharedParameterElement : public ParameterElement
type SharedParameterElement =
    class
        inherit ParameterElement
    end

The SharedParameterElement type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | GuidValue | The Guid that identifies this shared parameter.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new shared parameter element in the document representing the parameter stored in the input ExternalDefinition.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
 | GetDefinition | Get the definition representing this parameter element. (Inherited from ParameterElement)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
 | Lookup | Finds the shared parameter element that corresponds to the given Guid.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ShouldHideWhenNoValue | Indicates whether the parameter should be hidden from the properties palette if it has no value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Shared parameters are user-defined parameters that can be shared by multiple Revit documents. A shared parameter is identified by a GUID. Basic information of the shared parameter are accessed through GetDefinition().
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SharedParameterElement Properties

The SharedParameterElement type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | GuidValue | The Guid that identifies this shared parameter.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

SharedParameterElement Class


SharedParameterElement.GuidValue Property

SharedParameterElementGuidValue Property

The Guid that identifies this shared parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid GuidValue { get; }
Public ReadOnly Property GuidValue As Guid
    Get
public:
property Guid GuidValue {
    Guid get ();
}
member GuidValue : Guid with get

Property Value

Guid
See Also

Reference

SharedParameterElement Class


SharedParameterElement Methods

The SharedParameterElement type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new shared parameter element in the document representing the parameter stored in the input ExternalDefinition.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
 | GetDefinition | Get the definition representing this parameter element. (Inherited from ParameterElement)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
 | Lookup | Finds the shared parameter element that corresponds to the given Guid.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ShouldHideWhenNoValue | Indicates whether the parameter should be hidden from the properties palette if it has no value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SharedParameterElement Class


SharedParameterElement.Create Method

SharedParameterElementCreate Method

Creates a new shared parameter element in the document representing the parameter stored in the input ExternalDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SharedParameterElement Create(
    Document document,
    ExternalDefinition sharedParameterDefinition
)
Public Shared Function Create (
    document As Document,
    sharedParameterDefinition As ExternalDefinition
) As SharedParameterElement
public:
static SharedParameterElement^ Create(
    Document^ document,
    ExternalDefinition^ sharedParameterDefinition
)
static member Create :
        document : Document *
        sharedParameterDefinition : ExternalDefinition -> SharedParameterElement

Parameters

document Document
The document.
sharedParameterDefinition ExternalDefinition
Shared parameter definition.

Return Value

SharedParameterElement
The newly created shared parameter instance.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | A shared parameter with the assigned GUID is already loaded into the document.
See Also

Reference

SharedParameterElement Class


SharedParameterElement.Lookup Method

SharedParameterElementLookup Method

Finds the shared parameter element that corresponds to the given Guid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SharedParameterElement Lookup(
    Document document,
    Guid guidValue
)
Public Shared Function Lookup (
    document As Document,
    guidValue As Guid
) As SharedParameterElement
public:
static SharedParameterElement^ Lookup(
    Document^ document,
    Guid guidValue
)
static member Lookup :
        document : Document *
        guidValue : Guid -> SharedParameterElement

Parameters

document Document
The document.
guidValue Guid
Shared parameter Guid.

Return Value

SharedParameterElement
The retrieved shared parameter instance, or if the matching element is not found.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

SharedParameterElement Class


SharedParameterElement.ShouldHideWhenNoValue Method

SharedParameterElementShouldHideWhenNoValue Method

Indicates whether the parameter should be hidden from the properties palette if it has no value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldHideWhenNoValue()
Public Function ShouldHideWhenNoValue As Boolean
public:
bool ShouldHideWhenNoValue()
member ShouldHideWhenNoValue : unit -> bool

Return Value

Boolean
See Also

Reference

SharedParameterElement Class


SheetCollection Class

This class represents a sheet collection in Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBSheetCollection

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SheetCollection : Element
Public Class SheetCollection
    Inherits Element
public ref class SheetCollection : public Element
type SheetCollection =
    class
        inherit Element
    end

The SheetCollection type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create(Document) | Creates a new instance of sheet collection with an auto-generated name and adds it to the document.
 | Create(Document, String) | Creates a new instance of sheet collection with a specified name and adds it to the document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SheetCollection Properties

The SheetCollection type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

SheetCollection Class


SheetCollection Methods

The SheetCollection type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create(Document) | Creates a new instance of sheet collection with an auto-generated name and adds it to the document.
 | Create(Document, String) | Creates a new instance of sheet collection with a specified name and adds it to the document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SheetCollection Class


SheetCollection.Create Method

SheetCollectionCreate Method

Overload List
Name | Description
Create(Document) | Creates a new instance of sheet collection with an auto-generated name and adds it to the document.
Create(Document, String) | Creates a new instance of sheet collection with a specified name and adds it to the document.
Top
See Also

Reference

SheetCollection Class


SheetCollection.Create(Document) Method

SheetCollectionCreate(Document) Method

Creates a new instance of sheet collection with an auto-generated name and adds it to the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SheetCollection Create(
    Document document
)
Public Shared Function Create (
    document As Document
) As SheetCollection
public:
static SheetCollection^ Create(
    Document^ document
)
static member Create :
        document : Document -> SheetCollection

Parameters

document Document
The document where the sheet collection element will be created and added.

Return Value

SheetCollection
The newly created sheet collection element.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
See Also

Reference

SheetCollection Class
Create Overload


SheetCollection.Create(Document, String) Method

SheetCollectionCreate(Document, String) Method

Creates a new instance of sheet collection with a specified name and adds it to the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SheetCollection Create(
    Document document,
    string name
)
Public Shared Function Create (
    document As Document,
    name As String
) As SheetCollection
public:
static SheetCollection^ Create(
    Document^ document,
    String^ name
)
static member Create :
        document : Document *
        name : string -> SheetCollection

Parameters

document Document
The document where the sheet collection element will be created and added.
name String
The name of new sheet collection.

Return Value

SheetCollection
The newly created sheet collection element.
Exceptions
Exception | Condition
ArgumentException | name is an empty string or contains only whitespace. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- The given value for name is already in use as a sheet collection name.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
See Also

Reference

SheetCollection Class
Create Overload


SheetDuplicateOption Enumeration

Options for duplicating sheets

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum SheetDuplicateOption
Public Enumeration SheetDuplicateOption
public enum class SheetDuplicateOption
type SheetDuplicateOption
Members
Member name | Value | Description
DuplicateEmptySheet | 0 | Duplicate the sheet, only copy its title block.
DuplicateSheetWithDetailing | 1 | Duplicate the sheet, copy the title block and details.
DuplicateSheetWithViewsOnly | 2 | Duplicate the sheet. Copy its title block, details, viewports and contained views. The newly created sheet will reference the newly duplicated views.
DuplicateSheetWithViewsAndDetailing | 3 | Duplicate the sheet. Copy its title block, details, viewports, and duplicate its contained views with detailing. The newly created sheet will reference the newly duplicated views.
DuplicateSheetWithViewsAsDependent | 4 | Duplicate the sheet. Copy its title block, details, viewports, and duplicate its contained views as dependent. The newly created sheet will reference the newly duplicated dependent views.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ShellLayerType Enumeration

Used to distinguish exterior and interior shell layers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ShellLayerType
Public Enumeration ShellLayerType
public enum class ShellLayerType
type ShellLayerType
Members
Member name | Value | Description
Interior | 0 | Interior shell layer.
Exterior | 1 | Exterior shell layer.
Remarks
Used as an argument to methods of CompoundStructure that deal with shell layers.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ShowHiddenLinesValues Enumeration

Provides options for display of hidden lines in a given view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ShowHiddenLinesValues
Public Enumeration ShowHiddenLinesValues
public enum class ShowHiddenLinesValues
type ShowHiddenLinesValues
Members
Member name | Value | Description
None | 0 | Do not show any hidden lines.
ByDiscipline | 1 | Show hidden lines according to discipline.
All | 2 | Show all hidden lines.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SimpleWorksetConfiguration Enumeration

Indicates the set of user-created worksets to open in memory

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum SimpleWorksetConfiguration
Public Enumeration SimpleWorksetConfiguration
public enum class SimpleWorksetConfiguration
type SimpleWorksetConfiguration
Members
Member name | Value | Description
AllWorksets | 0 | All user-created worksets.
AllEditable | 1 | All user-created worksets checked out to the current user.
LastViewed | 2 | The set of user-created worksets last opened for this model.
AskUserToSpecify | 3 | Explicitly ask the user the specify which user-created worksets to open.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SiteLocation Class

Contains the geographical location information for the project's site.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBSiteLocation

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SiteLocation : ElementType
Public Class SiteLocation
    Inherits ElementType
public ref class SiteLocation : public ElementType
type SiteLocation =
    class
        inherit ElementType
    end

The SiteLocation type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | Elevation | The elevation of the site location.
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
Public property | GeoCoordinateSystemDefinition | The XML string which describes the geographic coordinate system.
Public property | GeoCoordinateSystemId | The geographic coordinate system ID, such as "AMG-50" and "Beijing1954/a.GK3d-40".
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | Latitude | The latitude of the site location.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Longitude | The longitude of the site location.
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | PlaceName | The place name of the site.
Public property | TimeZone | The time-zone for the site.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WeatherStationName | The name of the weather station at the site location.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | ConvertFromProjectTime | Converts project time to UTC time.
Public method | ConvertToProjectTime | Converts local time or UTC time to project time.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCompatibleWith | Checks whether the geographic coordinate system of this site is compatible with the given site . True if he geographic coordinate system of this site is compatible with the given site, false otherwise.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetGeoCoordinateSystem | Set the geographic coordinate system for this site. Similar to acquire coordinate system from a link in the UI.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Each project may have one site which dictates where in the world the project is based. On this site there may be several locations of the same project. These are represented by ProjectLocation objects. The site location object can be found by using the SiteLocation property on the Document object. The properties of this object can be changed such that it represents any location on the planet or to a known city. Cities already programmed into Revit can be found from the Cities property on the Application object.
Example
C#
VB
C++
F#
Copy
// Get the SiteLocation instance.
Autodesk.Revit.DB.SiteLocation site = document.SiteLocation;

// Angles are in radians when coming from Revit API, so we
// convert to degrees for display
const double angleRatio = Math.PI / 180;   // angle conversion factor

// Format the prompt information.
String prompt = "Current project's Site location information:";
prompt += "\n\t" + "Latitude: " + site.Latitude / angleRatio + " degrees";
prompt += "\n\t" + "Longitude: " + site.Longitude / angleRatio + " degrees";
// Give the user some information.
TaskDialog.Show("Revit",prompt);

// Change the SiteLocation property data.
site.Latitude = 0.5;    // latitude information
site.Longitude = 0.5;   // longitude information
site.TimeZone = -5;     // TimeZone information
' Get the SiteLocation instance.
Dim site As Autodesk.Revit.DB.SiteLocation = document.SiteLocation

' Angles are in radians when coming from Revit API, so we
' convert to degrees for display
Const  angleRatio As Double = Math.PI / 180
' angle conversion factor
' Format the prompt information.
Dim prompt As [String] = "Current project's Site location information:"
prompt += vbLf & vbTab & "Latitude: " & site.Latitude / angleRatio & "°"
prompt += vbLf & vbTab & "Longitude: " & site.Longitude / angleRatio & "°"
prompt += (vbLf & vbTab & "TimeZone: ") + site.TimeZone

' Give the user some information.
TaskDialog.Show("Revit", prompt)

' Change the SiteLocation property data.
site.Latitude = 0.5
' latitude information
site.Longitude = 0.5
' longitude information
site.TimeZone = -5
' TimeZone information

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SiteLocation Properties

The SiteLocation type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | Elevation | The elevation of the site location.
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
Public property | GeoCoordinateSystemDefinition | The XML string which describes the geographic coordinate system.
Public property | GeoCoordinateSystemId | The geographic coordinate system ID, such as "AMG-50" and "Beijing1954/a.GK3d-40".
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | Latitude | The latitude of the site location.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Longitude | The longitude of the site location.
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | PlaceName | The place name of the site.
Public property | TimeZone | The time-zone for the site.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WeatherStationName | The name of the weather station at the site location.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

SiteLocation Class


SiteLocation.Elevation Property

SiteLocationElevation Property

The elevation of the site location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Elevation { get; }
Public ReadOnly Property Elevation As Double
    Get
public:
property double Elevation {
    double get ();
}
member Elevation : float with get

Property Value

Double
See Also

Reference

SiteLocation Class


SiteLocation.GeoCoordinateSystemDefinition Property

SiteLocationGeoCoordinateSystemDefinition Property

The XML string which describes the geographic coordinate system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GeoCoordinateSystemDefinition { get; }
Public ReadOnly Property GeoCoordinateSystemDefinition As String
    Get
public:
property String^ GeoCoordinateSystemDefinition {
    String^ get ();
}
member GeoCoordinateSystemDefinition : string with get

Property Value

String
Remarks
If the site does not have a geographic coordinate system, it returns an empty string for this property.
See Also

Reference

SiteLocation Class


SiteLocation.GeoCoordinateSystemId Property

SiteLocationGeoCoordinateSystemId Property

The geographic coordinate system ID, such as "AMG-50" and "Beijing1954/a.GK3d-40".

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GeoCoordinateSystemId { get; }
Public ReadOnly Property GeoCoordinateSystemId As String
    Get
public:
property String^ GeoCoordinateSystemId {
    String^ get ();
}
member GeoCoordinateSystemId : string with get

Property Value

String
Remarks
If the site does not have a geographic coordinate system, it returns an empty string for this property.
See Also

Reference

SiteLocation Class


SiteLocation.Latitude Property

SiteLocationLatitude Property

The latitude of the site location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Latitude { get; set; }
Public Property Latitude As Double
    Get
    Set
public:
property double Latitude {
    double get ();
    void set (double value);
}
member Latitude : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentException | When setting this property: The latitude value is out of range. It must be between -PI/2 and PI/2.
Remarks

A property that contains the latitude of the site location. The value of this property is in radians between +PI/2 and -PI/2.

When setting this property:

  1. Revit will attempt to match the coordinates to a city it knows about, and if a match is found, will set the name accordingly.
  2. Revit will attempt to automatically adjust the time zone value to match the new Latitude value set using [!:Autodesk::Revit::DB::SunAndShadowSettings::CalculateTimeZone]. For some boundary cases, the time zone calculated may not be correct. You can set the TimeZone property directly to the correct value if necessary.
  3. Revit will attempt to automatically update the weather station associated with the location's coordinates.

See Also

Reference

SiteLocation Class


SiteLocation.Longitude Property

SiteLocationLongitude Property

The longitude of the site location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Longitude { get; set; }
Public Property Longitude As Double
    Get
    Set
public:
property double Longitude {
    double get ();
    void set (double value);
}
member Longitude : float with get, set

Property Value

Double
The longitude, in radians between -PI and PI. If the value is not between -PI and PI, it will be shifted by multiples of 2PI until it is in range.
Remarks

A property that contains the longitude of the site location. The value of this property is in radians between +PI and -PI. If the given value is not between -PI and PI, it will be shifted by multiples of 2PI until it is in range.

When setting this property:

  1. Revit will attempt to match the coordinates to a city it knows about, and if a match is found, will set the name accordingly.
  2. Revit will attempt to automatically adjust the time zone value to match the new Longitude value set using [!:Autodesk::Revit::DB::SunAndShadowSettings::CalculateTimeZone]. For some boundary cases, the time zone calculated may not be correct. You can set the TimeZone property directly to the correct value if necessary.
  3. Revit will attempt to automatically update the weather station associated with the coordinates.

See Also

Reference

SiteLocation Class


SiteLocation.PlaceName Property

SiteLocationPlaceName Property

The place name of the site.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string PlaceName { get; set; }
Public Property PlaceName As String
    Get
    Set
public:
property String^ PlaceName {
    String^ get ();
    void set (String^ value);
}
member PlaceName : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

SiteLocation Class


SiteLocation.TimeZone Property

SiteLocationTimeZone Property

The time-zone for the site.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double TimeZone { get; set; }
Public Property TimeZone As Double
    Get
    Set
public:
property double TimeZone {
    double get ();
    void set (double value);
}
member TimeZone : float with get, set

Property Value

Double
Hours ranging from -12 to +12. 0 represents GMT. Note that if the input value is not in the valid range, it will be shifted by multiples of 24 until it is in range.
Remarks
Remarks

A property that returns the time zone in which the site resides. The value is in hours, ranging from +12 hours to -12 hours with 0 being GMT. If the input value is not in the valid range, it will be shifted by multiples of 24 until it is in range.

Set this property directly if for your desired latitude and longitude, Revit's calculation does not match with the actual time zone for your location. Note that there are no restrictions preventing you from setting this to an incorrect value for the site location, and incorrect times for Solar Studies may result.

See Also

Reference

SiteLocation Class


SiteLocation.WeatherStationName Property

SiteLocationWeatherStationName Property

The name of the weather station at the site location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string WeatherStationName { get; }
Public ReadOnly Property WeatherStationName As String
    Get
public:
property String^ WeatherStationName {
    String^ get ();
}
member WeatherStationName : string with get

Property Value

String
See Also

Reference

SiteLocation Class


SiteLocation Methods

The SiteLocation type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | ConvertFromProjectTime | Converts project time to UTC time.
Public method | ConvertToProjectTime | Converts local time or UTC time to project time.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCompatibleWith | Checks whether the geographic coordinate system of this site is compatible with the given site . True if he geographic coordinate system of this site is compatible with the given site, false otherwise.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetGeoCoordinateSystem | Set the geographic coordinate system for this site. Similar to acquire coordinate system from a link in the UI.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SiteLocation Class


SiteLocation.ConvertFromProjectTime Method

SiteLocationConvertFromProjectTime Method

Converts project time to UTC time.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime ConvertFromProjectTime(
    DateTime projectTime
)
Public Function ConvertFromProjectTime (
    projectTime As DateTime
) As DateTime
public:
DateTime ConvertFromProjectTime(
    DateTime projectTime
)
member ConvertFromProjectTime :
        projectTime : DateTime -> DateTime

Parameters

projectTime DateTime
The project time.

Return Value

DateTime
Exceptions
Exception | Condition
ArgumentException | Thrown when the projectTime's kind is not Unspecified.
Remarks
Daylight savings time is not considered during this conversion.
See Also

Reference

SiteLocation Class


SiteLocation.ConvertToProjectTime Method

SiteLocationConvertToProjectTime Method

Converts local time or UTC time to project time.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime ConvertToProjectTime(
    DateTime inputTime
)
Public Function ConvertToProjectTime (
    inputTime As DateTime
) As DateTime
public:
DateTime ConvertToProjectTime(
    DateTime inputTime
)
member ConvertToProjectTime :
        inputTime : DateTime -> DateTime

Parameters

inputTime DateTime
The input local time or UTC time.

Return Value

DateTime
Exceptions
Exception | Condition
ArgumentException | Thrown when the inputTime's kind is neither Local nor Utc.
Remarks
Daylight savings time is not considered during this conversion.
See Also

Reference

SiteLocation Class


SiteLocation.IsCompatibleWith Method

SiteLocationIsCompatibleWith Method

Checks whether the geographic coordinate system of this site is compatible with the given site . True if he geographic coordinate system of this site is compatible with the given site, false otherwise.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCompatibleWith(
    SiteLocation otherSiteLocation
)
Public Function IsCompatibleWith (
    otherSiteLocation As SiteLocation
) As Boolean
public:
bool IsCompatibleWith(
    SiteLocation^ otherSiteLocation
)
member IsCompatibleWith :
        otherSiteLocation : SiteLocation -> bool

Parameters

otherSiteLocation SiteLocation

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

SiteLocation Class


SiteLocation.SetGeoCoordinateSystem Method

SiteLocationSetGeoCoordinateSystem Method

Set the geographic coordinate system for this site. Similar to acquire coordinate system from a link in the UI.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetGeoCoordinateSystem(
    string coordSystem
)
Public Sub SetGeoCoordinateSystem (
    coordSystem As String
)
public:
void SetGeoCoordinateSystem(
    String^ coordSystem
)
member SetGeoCoordinateSystem :
        coordSystem : string -> unit

Parameters

coordSystem String
The coordinate system to set for the project.
Exceptions
Exception | Condition
ArgumentException | coordSystem is an empty string or contains only whitespace. -or- The coordinate system is not valid.
ArgumentNullException | A non-optional argument was null
InternalException | Fail to update coordinate system.
InvalidOperationException | The site location does not come from the project.
Remarks
The ID, WKT or Autodesk coordinate system xml representation of the coordinate reference system definition. The xml representation is the same format get via RealDWG's API - AcDbGeoData::coordinateSystem. Optionally, the string can be prefixed by the ID's namespace and a colon (:) where the following are supported: ADSK, EPSG. If no namespace has been specified, the ID is assumed to be a default Autodesk coordinate system identifier. If no definition exists with such a code and if it consists of numbers only, the ID string is considered an EPSG code.

Valid examples are:

  • LL84 > Autodesk identifier (default)
  • ADSK:LL84 > Autodesk identifier
  • EPSG:4326 > EPSG identifier
  • 4326 > EPSG identifier
  • GEOGCS["WGS 84", DATUM["WGS_1984", SPHEROID[...]]] > WKT

See Also

Reference

SiteLocation Class


Sketch Class

Provides access to the Sketch in Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBSketchBase
Autodesk.Revit.DBSketch

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Sketch : SketchBase
Public Class Sketch
    Inherits SketchBase
public ref class Sketch : public SketchBase
type Sketch =
    class
        inherit SketchBase
    end

The Sketch type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerId | Returns id of the sketch owner element or invalidElementId if sketch does not build a geometry.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Profile | Returns the Profile of the Sketch.
Public property | SketchPlane | Returns the Sketch Plane of the Sketch.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAllElements | Returns all elements which belong to the sketch.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Sketch Properties

The Sketch type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerId | Returns id of the sketch owner element or invalidElementId if sketch does not build a geometry.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Profile | Returns the Profile of the Sketch.
Public property | SketchPlane | Returns the Sketch Plane of the Sketch.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

Sketch Class


Sketch.OwnerId Property

SketchOwnerId Property

Returns id of the sketch owner element or invalidElementId if sketch does not build a geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId OwnerId { get; }
Public ReadOnly Property OwnerId As ElementId
    Get
public:
property ElementId^ OwnerId {
    ElementId^ get ();
}
member OwnerId : ElementId with get

Property Value

ElementId
See Also

Reference

Sketch Class


Sketch.Profile Property

SketchProfile Property

Returns the Profile of the Sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurveArrArray Profile { get; }
Public ReadOnly Property Profile As CurveArrArray
    Get
public:
property CurveArrArray^ Profile {
    CurveArrArray^ get ();
}
member Profile : CurveArrArray with get

Property Value

CurveArrArray
Remarks
This property is used to retrieve the Profile of Sketch.
See Also

Reference

Sketch Class


Sketch.SketchPlane Property

SketchSketchPlane Property

Returns the Sketch Plane of the Sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SketchPlane SketchPlane { get; }
Public ReadOnly Property SketchPlane As SketchPlane
    Get
public:
property SketchPlane^ SketchPlane {
    SketchPlane^ get ();
}
member SketchPlane : SketchPlane with get

Property Value

SketchPlane
Remarks
This property is used to retrieve the Sketch Plane of Sketch.
See Also

Reference

Sketch Class


Sketch Methods

The Sketch type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAllElements | Returns all elements which belong to the sketch.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sketch Class


Sketch.GetAllElements Method

SketchGetAllElements Method

Returns all elements which belong to the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ElementId> GetAllElements()
Public Function GetAllElements As IList(Of ElementId)
public:
IList<ElementId^>^ GetAllElements()
member GetAllElements : unit -> IList<ElementId>

Return Value

IList ElementId
Returns ids of elements which belong to that sketch.
Remarks
Following elements can belong to a sketch: ModelCurve, ReferencePlane, Dimension. To get matching between Curve from Profile and ModelCurve, use [!:Autodesk::Revit::DB::Curve::Reference::ElementId].
See Also

Reference

Sketch Class


SketchBase Class

Provides access to the SketchBase in Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBSketchBase
Autodesk.Revit.DBPath3d
Autodesk.Revit.DBSketch

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SketchBase : Element
Public Class SketchBase
    Inherits Element
public ref class SketchBase : public Element
type SketchBase =
    class
        inherit Element
    end

The SketchBase type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
SketchBase is the base class of Sketch.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SketchBase Properties

The SketchBase type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

SketchBase Class


SketchBase Methods

The SketchBase type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SketchBase Class


SketchEditScope Class

A SketchEditScope allows an application to create and maintain an editing session for a Sketch.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBEditScope
Autodesk.Revit.DBSketchEditScope

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SketchEditScope : EditScope
Public Class SketchEditScope
    Inherits EditScope
public ref class SketchEditScope : public EditScope
type SketchEditScope =
    class
        inherit EditScope
    end

The SketchEditScope type exposes the following members.

Constructors
 | Name | Description
Public method | SketchEditScope | Instantiates a SketchEditScope object.
Top
Properties
 | Name | Description
Public property | IsActive | Tells if the EditScope is active. In other words, the EditScope has started but not committed/canceled yet. (Inherited from EditScope)
Public property | IsPermitted | Tells if the edit scope is permitted to start. (Inherited from EditScope)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from EditScope)
Top
Methods
 | Name | Description
Public method | Cancel | Cancels the edit scope. (Inherited from EditScope)
Public method | Commit | Finishes the edit scope. (Inherited from EditScope)
Public method | Dispose | (Inherited from EditScope)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsElementWithoutSketch | Validates if an element can have a sketch but currently does not.
Public method | IsSketchEditingSupported | Checks whether sketch can be edited.
Public method | IsSketchEditingSupportedForSketchBasedElement | Checks whether the element supports sketch editing.
Public method | Start | Starts a sketch edit mode.
 | StartWithNewSketch | Starts a sketch edit mode for an element which, at this moment, doesn't have a sketch.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Start/end of a SketchEditScope will start/end a transaction group. After a SketchEditScope is started, an application can start transactions and edit the sketch. Individual transactions the application creates inside SketchEditScope will not appear in the undo menu. All transactions committed during the edit mode will be merged into a single one which will bear the given name passed into SketchEditScope constructor.
Example
C#
Copy
public void ReplaceBoundaryLine(Document document)
{
   FilteredElementCollector floorCollector = new FilteredElementCollector(document)
      .WhereElementIsNotElementType()
      .OfCategory(BuiltInCategory.OST_Floors).OfClass(typeof(Floor));

   Floor floor = floorCollector.FirstOrDefault() as Floor;
   if (floor == null)
   {
      TaskDialog.Show("Error", "Document does not contain a floor.");
      return;
   }

   Sketch sketch = document.GetElement(floor.SketchId) as Sketch;

   Line line = null;
   foreach (CurveArray curveArray in sketch.Profile)
   {
      foreach (Curve curve in curveArray)
      {
         line = curve as Line;
         if (line != null)
         {
            break;
         }
      }
      if (line != null)
      {
         break;
      }
   }

   if (line == null)
   {
      TaskDialog.Show("Error", "Sketch does not contain a straight line.");
      return;
   }

   // Start a sketch edit scope
   SketchEditScope sketchEditScope = new SketchEditScope(document, "Replace line with an arc");
   sketchEditScope.Start(sketch.Id);

   using (Transaction transaction = new Transaction(document, "Modify sketch"))
   {
      transaction.Start();

      // Create arc
      XYZ normal = line.Direction.CrossProduct(XYZ.BasisZ).Normalize().Negate();
      XYZ middle = line.GetEndPoint(0).Add(line.Direction.Multiply(line.Length / 2));
      Curve arc = Arc.Create(line.GetEndPoint(0), line.GetEndPoint(1), middle.Add(normal.Multiply(20)));

      // Remove element referenced by the found line.
      document.Delete(line.Reference.ElementId);

      // Model curve creation automatically puts the curve into the sketch, if sketch edit scope is running.
      document.Create.NewModelCurve(arc, sketch.SketchPlane);

      transaction.Commit();
   }

   sketchEditScope.Commit(new FailuresPreprocessor());
}
C#
Copy
public void ReplaceBoundaryLine(Document document)
{
   FilteredElementCollector floorCollector = new FilteredElementCollector(document)
      .WhereElementIsNotElementType()
      .OfCategory(BuiltInCategory.OST_Floors).OfClass(typeof(Floor));

   Floor floor = floorCollector.FirstOrDefault() as Floor;
   if (floor == null)
   {
      TaskDialog.Show("Error", "Document does not contain a floor.");
      return;
   }

   Sketch sketch = document.GetElement(floor.SketchId) as Sketch;

   Line line = null;
   foreach (CurveArray curveArray in sketch.Profile)
   {
      foreach (Curve curve in curveArray)
      {
         line = curve as Line;
         if (line != null)
         {
            break;
         }
      }
      if (line != null)
      {
         break;
      }
   }

   if (line == null)
   {
      TaskDialog.Show("Error", "Sketch does not contain a straight line.");
      return;
   }

   // Start a sketch edit scope
   SketchEditScope sketchEditScope = new SketchEditScope(document, "Replace line with an arc");
   sketchEditScope.Start(sketch.Id);

   using (Transaction transaction = new Transaction(document, "Modify sketch"))
   {
      transaction.Start();

      // Create arc
      XYZ normal = line.Direction.CrossProduct(XYZ.BasisZ).Normalize().Negate();
      XYZ middle = line.GetEndPoint(0).Add(line.Direction.Multiply(line.Length / 2));
      Curve arc = Arc.Create(line.GetEndPoint(0), line.GetEndPoint(1), middle.Add(normal.Multiply(20)));

      // Remove element referenced by the found line.
      document.Delete(line.Reference.ElementId);

      // Model curve creation automatically puts the curve into the sketch, if sketch edit scope is running.
      document.Create.NewModelCurve(arc, sketch.SketchPlane);

      transaction.Commit();
   }

   sketchEditScope.Commit(new FailuresPreprocessor());
}
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SketchEditScope Constructor

Instantiates a SketchEditScope object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SketchEditScope(
    Document document,
    string transactionName
)
Public Sub New (
    document As Document,
    transactionName As String
)
public:
SketchEditScope(
    Document^ document,
    String^ transactionName
)
new :
        document : Document *
        transactionName : string -> SketchEditScope

Parameters

document Document
The document for which this SketchEditScope is going to be used.
transactionName String
The name that will appear in the Undo menu in Revit after the SketchEditScope is successfully committed.
Exceptions
Exception | Condition
ArgumentException | document is not a primary document, it is a linked document. -or- document is not a project document. -or- transactionName is an empty string.
ArgumentNullException | A non-optional argument was null
See Also

Reference

SketchEditScope Class


SketchEditScope Properties

The SketchEditScope type exposes the following members.

Properties
 | Name | Description
Public property | IsActive | Tells if the EditScope is active. In other words, the EditScope has started but not committed/canceled yet. (Inherited from EditScope)
Public property | IsPermitted | Tells if the edit scope is permitted to start. (Inherited from EditScope)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from EditScope)
Top
See Also

Reference

SketchEditScope Class


SketchEditScope Methods

The SketchEditScope type exposes the following members.

Methods
 | Name | Description
Public method | Cancel | Cancels the edit scope. (Inherited from EditScope)
Public method | Commit | Finishes the edit scope. (Inherited from EditScope)
Public method | Dispose | (Inherited from EditScope)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsElementWithoutSketch | Validates if an element can have a sketch but currently does not.
Public method | IsSketchEditingSupported | Checks whether sketch can be edited.
Public method | IsSketchEditingSupportedForSketchBasedElement | Checks whether the element supports sketch editing.
Public method | Start | Starts a sketch edit mode.
 | StartWithNewSketch | Starts a sketch edit mode for an element which, at this moment, doesn't have a sketch.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SketchEditScope Class


SketchEditScope.IsElementWithoutSketch Method

SketchEditScopeIsElementWithoutSketch Method

Validates if an element can have a sketch but currently does not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsElementWithoutSketch(
    ElementId elementId
)
Public Function IsElementWithoutSketch (
    elementId As ElementId
) As Boolean
public:
bool IsElementWithoutSketch(
    ElementId^ elementId
)
member IsElementWithoutSketch :
        elementId : ElementId -> bool

Parameters

elementId ElementId
The element id to be checked.

Return Value

Boolean
True if the element doesn't have a sketch, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

SketchEditScope Class


SketchEditScope.IsSketchEditingSupported Method

SketchEditScopeIsSketchEditingSupported Method

Checks whether sketch can be edited.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSketchEditingSupported(
    ElementId sketchId
)
Public Function IsSketchEditingSupported (
    sketchId As ElementId
) As Boolean
public:
bool IsSketchEditingSupported(
    ElementId^ sketchId
)
member IsSketchEditingSupported :
        sketchId : ElementId -> bool

Parameters

sketchId ElementId
The element id of sketch.

Return Value

Boolean
True if sketch can be edited, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
This method checks if this particular sketch can be edited. If you want to check if all sketches of an element can be edited please use IsSketchEditingSupportedForSketchBasedElement(ElementId)
See Also

Reference

SketchEditScope Class


SketchEditScope.IsSketchEditingSupportedForSketchBasedElement Method

SketchEditScopeIsSketchEditingSupportedForSketchBasedElement Method

Checks whether the element supports sketch editing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSketchEditingSupportedForSketchBasedElement(
    ElementId elemId
)
Public Function IsSketchEditingSupportedForSketchBasedElement (
    elemId As ElementId
) As Boolean
public:
bool IsSketchEditingSupportedForSketchBasedElement(
    ElementId^ elemId
)
member IsSketchEditingSupportedForSketchBasedElement :
        elemId : ElementId -> bool

Parameters

elemId ElementId
The element id to be checked.

Return Value

Boolean
True if element supports sketch editing, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
This method checks if the element supports edit to all its sketches. If you want to check if this element supports edit to a particular sketch please use IsSketchEditingSupported(ElementId).
See Also

Reference

SketchEditScope Class


SketchEditScope.Start Method

SketchEditScopeStart Method

Starts a sketch edit mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Start(
    ElementId sketchId
)
Public Sub Start (
    sketchId As ElementId
)
public:
void Start(
    ElementId^ sketchId
)
member Start :
        sketchId : ElementId -> unit

Parameters

sketchId ElementId
The Sketch element to be edited.
Exceptions
Exception | Condition
ArgumentException | The ElementId sketchId does not represent a Sketch. -or- Sketch does not support editing. -or- Failed to start the sketch edit mode.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This SketchEditScope is not permitted to start at this moment for one of the following possible reasons: The document is in read-only state, or the document is currently modifiable, or there already is another edit mode active in the document.
Remarks
The application will need to start a transaction to actually make changes to the Sketch element. SketchEditScope can only be started when there is no transaction active, thus it does not work for commands running in automatic transaction mode.
See Also

Reference

SketchEditScope Class


SketchEditScope.StartWithNewSketch Method

SketchEditScopeStartWithNewSketch Method

Starts a sketch edit mode for an element which, at this moment, doesn't have a sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void StartWithNewSketch(
    ElementId elementId
)
Public Sub StartWithNewSketch (
    elementId As ElementId
)
public:
void StartWithNewSketch(
    ElementId^ elementId
)
member StartWithNewSketch :
        elementId : ElementId -> unit

Parameters

elementId ElementId
The Element without sketch to be edited.
Exceptions
Exception | Condition
ArgumentException | The ElementId elementId already has a sketch defined. -or- Element does not support sketch editing. -or- Failed to start the sketch edit mode.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This SketchEditScope is not permitted to start at this moment for one of the following possible reasons: The document is in read-only state, or the document is currently modifiable, or there already is another edit mode active in the document. -or- Cannot create sketch.
Remarks
Some surface Revit elements (like some Walls or some Analytical Elements) does not have a valid sketch all the time so in order to edit them, we have to create a valid sketch first. The application will need to start a transaction to actually make changes to the element. SketchEditScope can only be started when there is no transaction active, thus it does not work for commands running in automatic transaction mode.
Example
C#
Copy
Document document = commandData.Application.ActiveUIDocument.Document;

//create analytical panel
AnalyticalPanel analyticalPanel = CreateAnalyticalPanel.CreateAMPanel(document);
if (analyticalPanel != null)
{
   // Start a sketch edit scope
   SketchEditScope sketchEditScope = new SketchEditScope(document, "Replace line with an arc");
   sketchEditScope.StartWithNewSketch(analyticalPanel.Id);

   using (Transaction transaction = new Transaction(document, "Modify sketch"))
   {
      transaction.Start();

      //replace a boundary line with an arc
      Line line = null;
      Sketch sketch = document.GetElement(analyticalPanel.SketchId) as Sketch;
      if (sketch != null)
      {
         foreach (CurveArray curveArray in sketch.Profile)
         {
            foreach (Curve curve in curveArray)
            {
               line = curve as Line;
               if (line != null)
               {
                  break;
               }
            }
            if (line != null)
            {
               break;
            }
         }
      }

      // Create arc
      XYZ normal = line.Direction.CrossProduct(XYZ.BasisZ).Normalize().Negate();
      XYZ middle = line.GetEndPoint(0).Add(line.Direction.Multiply(line.Length / 2));
      Curve arc = Arc.Create(line.GetEndPoint(0), line.GetEndPoint(1), middle.Add(normal.Multiply(20)));

      // Remove element referenced by the found line.
      document.Delete(line.Reference.ElementId);

      // Model curve creation automatically puts the curve into the sketch, if sketch edit scope is running.
      document.Create.NewModelCurve(arc, sketch.SketchPlane);

      transaction.Commit();
   }

   sketchEditScope.Commit(new FailurePreproccessor());

}

return Result.Succeeded;
See Also

Reference

SketchEditScope Class


SketchedStairsCurveData Class

Sketched run/landing curves overrides with height and slope
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSketchedStairsCurveData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SketchedStairsCurveData : IDisposable
Public Class SketchedStairsCurveData
    Implements IDisposable
public ref class SketchedStairsCurveData : IDisposable
type SketchedStairsCurveData =
    class
        interface IDisposable
    end

The SketchedStairsCurveData type exposes the following members.

Constructors
 | Name | Description
Public method | SketchedStairsCurveData | Construct a SketchedStairsCurveData defined by a curve associated with its height and slope type.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the SketchedStairsCurveData
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCurve | Get a copy of the curve that is formed along this boundary.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SketchedStairsCurveData Constructor

Construct a SketchedStairsCurveData defined by a curve associated with its height and slope type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SketchedStairsCurveData(
    Curve boundaryCurve,
    double height,
    SketchedCurveSlopeOption slopeType
)
Public Sub New (
    boundaryCurve As Curve,
    height As Double,
    slopeType As SketchedCurveSlopeOption
)
public:
SketchedStairsCurveData(
    Curve^ boundaryCurve,
    double height,
    SketchedCurveSlopeOption slopeType
)
new :
        boundaryCurve : Curve *
        height : float *
        slopeType : SketchedCurveSlopeOption -> SketchedStairsCurveData

Parameters

boundaryCurve Curve
height Double
slopeType SketchedCurveSlopeOption
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

SketchedStairsCurveData Class


SketchedStairsCurveData Properties

The SketchedStairsCurveData type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

SketchedStairsCurveData Class


SketchedStairsCurveData.IsValidObject Property

SketchedStairsCurveDataIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

SketchedStairsCurveData Class


SketchedStairsCurveData Methods

The SketchedStairsCurveData type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCurve | Get a copy of the curve that is formed along this boundary.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SketchedStairsCurveData Class


SketchedStairsCurveData.Dispose Method

SketchedStairsCurveDataDispose Method

Releases all resources used by the SketchedStairsCurveData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

SketchedStairsCurveData Class


SketchedStairsCurveData.GetCurve Method

SketchedStairsCurveDataGetCurve Method

Get a copy of the curve that is formed along this boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Curve GetCurve()
Public Function GetCurve As Curve
public:
Curve^ GetCurve()
member GetCurve : unit -> Curve

Return Value

Curve
A copy of the curve.
See Also

Reference

SketchedStairsCurveData Class


SketchPlane Class

Represents a sketch plane or work plane.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBSketchPlane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SketchPlane : Element
Public Class SketchPlane
    Inherits Element
public ref class SketchPlane : public Element
type SketchPlane =
    class
        inherit Element
    end

The SketchPlane type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsSuitableForModelElements | Identifies if the sketch plane can be assigned to model elements.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create(Document, ElementId) | Creates a sketch plane from a grid, reference plane, or level.
 | Create(Document, Plane) | Creates a new sketch plane from a geometric plane.
 | Create(Document, Reference) | Creates a new sketch plane from a reference to a planar face.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPlane | Returns the corresponding Plane.
Public method | GetPlaneReference | Returns a reference to this element as a plane.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
A SketchPlane object is used as an input to creation of sketch-referencing elements such as Model Curves or sketch-owning elements such as Generic Forms. The SketchPlane can be obtained from an existing element or created from a geometric plane or planar face. Note that the sketch plane element passed as input to create an element may not be the actual sketch plane assigned to that element; Revit may look for a geometrically equivalent plane to use, or may create a new one if the input plane is already used for other purposes. Some sketch planes (such as those obtained from detail curves) are suitable only for use in creating detail elements; they will be rejected when used for other element types.
Example
C#
VB
C++
F#
Copy
public void ShowSketchPlane(SketchPlane sketchPlane)
{
    // get the information of the created sketch plane
    string information = "Sketch Plane: ";
    //get the corresponding Plane
    Autodesk.Revit.DB.Plane plane = sketchPlane.GetPlane();
    //show the plane's origin point
    information += "\norigin of the plane:  " + XYZToString(plane.Origin);
    //show the plane's normal vector
    information += "\nnormal of the plane:  " + XYZToString(plane.Normal);
    //show the plane's Xvec vector
    information += "\nXvec of the plane: (" + XYZToString(plane.XVec);
    //show the plane's Yvec vector
    information += "\nYvec of the plane: (" + XYZToString(plane.YVec);

    TaskDialog.Show("Revit",information);
}

// output the point's three coordinates
string XYZToString(XYZ point)
{
    return "(" + point.X + ", " + point.Y + ", " + point.Z + ")";
}
Public Sub ShowSketchPlane(sketchPlane As SketchPlane)
    ' get the information of the created sketch plane
    Dim information As String = "Sketch Plane: "
    'get the corresponding Plane
    Dim plane As Autodesk.Revit.DB.Plane = sketchPlane.GetPlane()
    'show the plane's origin point
    information += vbLf & "origin of the plane:  " & XYZToString(plane.Origin)
    'show the plane's normal vector
    information += vbLf & "normal of the plane:  " & XYZToString(plane.Normal)
    'show the plane's Xvec vector
    information += vbLf & "Xvec of the plane: (" & XYZToString(plane.XVec)
    'show the plane's Yvec vector
    information += vbLf & "Yvec of the plane: (" & XYZToString(plane.YVec)

    TaskDialog.Show("Revit", information)
End Sub

' output the point's three coordinates
Private Function XYZToString(point As XYZ) As String
    Return "(" & Convert.ToString(point.X) & ", " & Convert.ToString(point.Y) & ", " & Convert.ToString(point.Z) & ")"
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SketchPlane Properties

The SketchPlane type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsSuitableForModelElements | Identifies if the sketch plane can be assigned to model elements.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

SketchPlane Class


SketchPlane.IsSuitableForModelElements Property

SketchPlaneIsSuitableForModelElements Property

Identifies if the sketch plane can be assigned to model elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSuitableForModelElements { get; }
Public ReadOnly Property IsSuitableForModelElements As Boolean
    Get
public:
property bool IsSuitableForModelElements {
    bool get ();
}
member IsSuitableForModelElements : bool with get

Property Value

Boolean
Remarks
Sketch planes with this property set to true are suitable to be used to create model elements. Planes where this property is false will be rejected when used to create model curves, symbolic curves, generic forms, or other sketched elements.
See Also

Reference

SketchPlane Class


SketchPlane Methods

The SketchPlane type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create(Document, ElementId) | Creates a sketch plane from a grid, reference plane, or level.
 | Create(Document, Plane) | Creates a new sketch plane from a geometric plane.
 | Create(Document, Reference) | Creates a new sketch plane from a reference to a planar face.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPlane | Returns the corresponding Plane.
Public method | GetPlaneReference | Returns a reference to this element as a plane.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SketchPlane Class


SketchPlane.Create Method

SketchPlaneCreate Method

Overload List
Name | Description
Create(Document, ElementId) | Creates a sketch plane from a grid, reference plane, or level.
Create(Document, Plane) | Creates a new sketch plane from a geometric plane.
Create(Document, Reference) | Creates a new sketch plane from a reference to a planar face.
Top
See Also

Reference

SketchPlane Class


SketchPlane.Create(Document, ElementId) Method

SketchPlaneCreate(Document, ElementId) Method

Creates a sketch plane from a grid, reference plane, or level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SketchPlane Create(
    Document document,
    ElementId datumId
)
Public Shared Function Create (
    document As Document,
    datumId As ElementId
) As SketchPlane
public:
static SketchPlane^ Create(
    Document^ document,
    ElementId^ datumId
)
static member Create :
        document : Document *
        datumId : ElementId -> SketchPlane

Parameters

document Document
The document.
datumId ElementId
The id of the grid, reference plane, or level.

Return Value

SketchPlane
The newly created sketch plane.
Exceptions
Exception | Condition
ArgumentException | datumId is not a valid Element identifier. -or- ElementId must correspond to a grid, reference plane, or level. -or- ElementId must correspond to a non-curved datum. -or- Sketch plane creation is not allowed in this family.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
See Also

Reference

SketchPlane Class
Create Overload


SketchPlane.Create(Document, Plane) Method

SketchPlaneCreate(Document, Plane) Method

Creates a new sketch plane from a geometric plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SketchPlane Create(
    Document document,
    Plane plane
)
Public Shared Function Create (
    document As Document,
    plane As Plane
) As SketchPlane
public:
static SketchPlane^ Create(
    Document^ document,
    Plane^ plane
)
static member Create :
        document : Document *
        plane : Plane -> SketchPlane

Parameters

document Document
The document.
plane Plane
The geometry plane where the sketch plane will be created.

Return Value

SketchPlane
The newly created sketch plane.
Exceptions
Exception | Condition
ArgumentException | Sketch plane creation is not allowed in this family.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
There will not be a reference relationship established from the sketch plane to the input face. To create a SketchPlane with a reference to other geometry, use the overload with a Reference input.
Example
C#
VB
C++
F#
Copy
public static SketchPlane CreateSketchPlane(Autodesk.Revit.DB.Document document, Plane plane)
{
    SketchPlane sketchPlane = null;

    // create a sketch plane using Geometry.Plane
    sketchPlane = SketchPlane.Create(document, plane);

    // throw exception if creation failed
    if (null == sketchPlane)
    {
        throw new Exception("Create the sketch plane failed.");
    }

    return sketchPlane;
}
Public Shared Function CreateSketchPlane(document As Autodesk.Revit.DB.Document, plane As Plane) As SketchPlane
    Dim sketchPlane__1 As SketchPlane = Nothing

    ' create a sketch plane using Geometry.Plane
    sketchPlane__1 = SketchPlane.Create(document, plane)

    ' throw exception if creation failed
    If sketchPlane__1 Is Nothing Then
        Throw New Exception("Create the sketch plane failed.")
    End If

    Return sketchPlane__1
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

SketchPlane Class
Create Overload


SketchPlane.Create(Document, Reference) Method

SketchPlaneCreate(Document, Reference) Method

Creates a new sketch plane from a reference to a planar face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SketchPlane Create(
    Document document,
    Reference planarFaceReference
)
Public Shared Function Create (
    document As Document,
    planarFaceReference As Reference
) As SketchPlane
public:
static SketchPlane^ Create(
    Document^ document,
    Reference^ planarFaceReference
)
static member Create :
        document : Document *
        planarFaceReference : Reference -> SketchPlane

Parameters

document Document
The document.
planarFaceReference Reference
The reference of the planar face where the sketch plane will be created.

Return Value

SketchPlane
The newly created sketch plane.
Exceptions
Exception | Condition
ArgumentException | Sketch plane creation is not allowed in this family. -or- The reference is not a planar face.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
A reference relationship will be created between the face and the sketch plane.
See Also

Reference

SketchPlane Class
Create Overload


SketchPlane.GetPlane Method

SketchPlaneGetPlane Method

Returns the corresponding Plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Plane GetPlane()
Public Function GetPlane As Plane
public:
Plane^ GetPlane()
member GetPlane : unit -> Plane

Return Value

Plane
The plane upon which elements created with this sketch plane will lie.
See Also

Reference

SketchPlane Class


SketchPlane.GetPlaneReference Method

SketchPlaneGetPlaneReference Method

Returns a reference to this element as a plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Reference GetPlaneReference()
Public Function GetPlaneReference As Reference
public:
Reference^ GetPlaneReference()
member GetPlaneReference : unit -> Reference

Return Value

Reference
The reference.
Remarks
The object returned here can be used with the PointOnPlane class.
See Also

Reference

SketchPlane Class


SKPImportOptions Class

The import options used to import SKP format files.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBaseImportOptions
Autodesk.Revit.DBSKPImportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SKPImportOptions : BaseImportOptions
Public Class SKPImportOptions
    Inherits BaseImportOptions
public ref class SKPImportOptions : public BaseImportOptions
type SKPImportOptions =
    class
        inherit BaseImportOptions
    end

The SKPImportOptions type exposes the following members.

Constructors
 | Name | Description
Public method | SKPImportOptions | Constructs a new instance of SKPImportOptions with default values of all properties.
Public method | SKPImportOptions(SKPImportOptions) | Constructs a new instance of SKPImportOptions as a copy of the import options.
Top
Properties
 | Name | Description
Public property | AutoCorrectAlmostVHLines | Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines. (Inherited from BaseImportOptions)
Public property | ColorMode | Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors. (Inherited from BaseImportOptions)
Public property | CustomScale | Scaling the import. If this is defined and a valid value (> 0.0), it takes priority over units. (Inherited from BaseImportOptions)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BaseImportOptions)
Public property | OrientToView | Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false) (Inherited from BaseImportOptions)
Public property | Placement | Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates. (Inherited from BaseImportOptions)
Public property | ReferencePoint | The 3D point in the document where the imported instance will be inserted. If not explicitly set, the instance will be inserted at the document origin. (Inherited from BaseImportOptions)
Public property | ThisViewOnly | Imports drawings into the view that was passed into the import method. This option is not available in 3D views. (Inherited from BaseImportOptions)
Public property | Unit | The unit of measure for imported geometry. (Inherited from BaseImportOptions)
Public property | VisibleLayersOnly | Only import the visible layers. (Inherited from BaseImportOptions)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from BaseImportOptions)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetDefaultLengthUnit | Get the default length unit used for importing unitless files. (Inherited from BaseImportOptions)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLayerSelection | Get all set layers name which user want to import into Revit. (Inherited from BaseImportOptions)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetDefaultLengthUnit | Set the default length unit used for importing unitless files. (Inherited from BaseImportOptions)
Public method | SetLayerSelection | Set the layers name which user want to import into Revit. (Inherited from BaseImportOptions)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SKPImportOptions Constructor

Overload List
 | Name | Description
Public method | SKPImportOptions | Constructs a new instance of SKPImportOptions with default values of all properties.
Public method | SKPImportOptions(SKPImportOptions) | Constructs a new instance of SKPImportOptions as a copy of the import options.
Top
See Also

Reference

SKPImportOptions Class


SKPImportOptions Constructor

Constructs a new instance of SKPImportOptions with default values of all properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SKPImportOptions()
Public Sub New
public:
SKPImportOptions()
new : unit -> SKPImportOptions
See Also

Reference

SKPImportOptions Class
SKPImportOptions Overload


SKPImportOptions(SKPImportOptions) Constructor

Constructs a new instance of SKPImportOptions as a copy of the import options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SKPImportOptions(
    SKPImportOptions option
)
Public Sub New (
    option As SKPImportOptions
)
public:
SKPImportOptions(
    SKPImportOptions^ option
)
new :
        option : SKPImportOptions -> SKPImportOptions

Parameters

option SKPImportOptions
The SKP options to be copied.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

SKPImportOptions Class
SKPImportOptions Overload


SKPImportOptions Properties

The SKPImportOptions type exposes the following members.

Properties
 | Name | Description
Public property | AutoCorrectAlmostVHLines | Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines. (Inherited from BaseImportOptions)
Public property | ColorMode | Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors. (Inherited from BaseImportOptions)
Public property | CustomScale | Scaling the import. If this is defined and a valid value (> 0.0), it takes priority over units. (Inherited from BaseImportOptions)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BaseImportOptions)
Public property | OrientToView | Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false) (Inherited from BaseImportOptions)
Public property | Placement | Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates. (Inherited from BaseImportOptions)
Public property | ReferencePoint | The 3D point in the document where the imported instance will be inserted. If not explicitly set, the instance will be inserted at the document origin. (Inherited from BaseImportOptions)
Public property | ThisViewOnly | Imports drawings into the view that was passed into the import method. This option is not available in 3D views. (Inherited from BaseImportOptions)
Public property | Unit | The unit of measure for imported geometry. (Inherited from BaseImportOptions)
Public property | VisibleLayersOnly | Only import the visible layers. (Inherited from BaseImportOptions)
Top
See Also

Reference

SKPImportOptions Class


SKPImportOptions Methods

The SKPImportOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from BaseImportOptions)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetDefaultLengthUnit | Get the default length unit used for importing unitless files. (Inherited from BaseImportOptions)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLayerSelection | Get all set layers name which user want to import into Revit. (Inherited from BaseImportOptions)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetDefaultLengthUnit | Set the default length unit used for importing unitless files. (Inherited from BaseImportOptions)
Public method | SetLayerSelection | Set the layers name which user want to import into Revit. (Inherited from BaseImportOptions)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SKPImportOptions Class


SkyBackgroundSettings Class

Represents the rendering sky background settings.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBackgroundSettings
Autodesk.Revit.DBSkyBackgroundSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SkyBackgroundSettings : BackgroundSettings
Public Class SkyBackgroundSettings
    Inherits BackgroundSettings
public ref class SkyBackgroundSettings : public BackgroundSettings
type SkyBackgroundSettings =
    class
        inherit BackgroundSettings
    end

The SkyBackgroundSettings type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BackgroundSettings)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from BackgroundSettings)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SkyBackgroundSettings Properties

The SkyBackgroundSettings type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BackgroundSettings)
Top
See Also

Reference

SkyBackgroundSettings Class


SkyBackgroundSettings Methods

The SkyBackgroundSettings type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from BackgroundSettings)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SkyBackgroundSettings Class


SlabEdge Class

An object that represents a slab edge within the Autodesk Revit project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBHostObject
Autodesk.Revit.DBHostedSweep
Autodesk.Revit.DBSlabEdge

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SlabEdge : HostedSweep
Public Class SlabEdge
    Inherits HostedSweep
public ref class SlabEdge : public HostedSweep
type SlabEdge =
    class
        inherit HostedSweep
    end

The SlabEdge type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Retrieve/set the angle of the hosted sweep object relative its references (Unit : Radian). (Inherited from HostedSweep)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HorizontalFlipped | Retrieve the horizontal flip status of the hosted sweep object. (Inherited from HostedSweep)
Public property | HorizontalOffset | Retrieve/set the horizontal offset of the hosted sweep object. (Inherited from HostedSweep)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | Length | Retrieve the length of the hosted sweep object. (Inherited from HostedSweep)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ReferenceCurve | The curve on which the hosted sweep segment is created. (Inherited from HostedSweep)
Public property | SlabEdgeType | Retrieves/set an object that represents the type of the SlabEdge.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | VerticalFlipped | Retrieve the vertical flip status of the hosted sweep object. (Inherited from HostedSweep)
Public property | VerticalOffset | Retrieve/set the vertical offset of the hosted sweep object. (Inherited from HostedSweep)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | AddSegment | Add segments to the slab edge. (Overrides HostedSweepAddSegment(Reference))
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEndPointParameter | Retrieve segment's start point or end point parameter. (Inherited from HostedSweep)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HorizontalFlip | Flip the hosted sweep object along horizontal line. (Inherited from HostedSweep)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveSegment | Remove segments from the hosted sweep object. (Inherited from HostedSweep)
Public method | SetEndPointParameter | Set segment's start point or end point parameter. (Inherited from HostedSweep)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | VerticalFlip | Flip the hosted sweep object along vertical line. (Inherited from HostedSweep)
Top
Remarks
This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SlabEdge Properties

The SlabEdge type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Retrieve/set the angle of the hosted sweep object relative its references (Unit : Radian). (Inherited from HostedSweep)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HorizontalFlipped | Retrieve the horizontal flip status of the hosted sweep object. (Inherited from HostedSweep)
Public property | HorizontalOffset | Retrieve/set the horizontal offset of the hosted sweep object. (Inherited from HostedSweep)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | Length | Retrieve the length of the hosted sweep object. (Inherited from HostedSweep)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ReferenceCurve | The curve on which the hosted sweep segment is created. (Inherited from HostedSweep)
Public property | SlabEdgeType | Retrieves/set an object that represents the type of the SlabEdge.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | VerticalFlipped | Retrieve the vertical flip status of the hosted sweep object. (Inherited from HostedSweep)
Public property | VerticalOffset | Retrieve/set the vertical offset of the hosted sweep object. (Inherited from HostedSweep)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

SlabEdge Class


SlabEdge.SlabEdgeType Property

SlabEdgeSlabEdgeType Property

Retrieves/set an object that represents the type of the SlabEdge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SlabEdgeType SlabEdgeType { get; set; }
Public Property SlabEdgeType As SlabEdgeType
    Get
    Set
public:
property SlabEdgeType^ SlabEdgeType {
    SlabEdgeType^ get ();
    void set (SlabEdgeType^ value);
}
member SlabEdgeType : SlabEdgeType with get, set

Property Value

SlabEdgeType
See Also

Reference

SlabEdge Class


SlabEdge Methods

The SlabEdge type exposes the following members.

Methods
 | Name | Description
Public method | AddSegment | Add segments to the slab edge. (Overrides HostedSweepAddSegment(Reference))
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEndPointParameter | Retrieve segment's start point or end point parameter. (Inherited from HostedSweep)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HorizontalFlip | Flip the hosted sweep object along horizontal line. (Inherited from HostedSweep)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveSegment | Remove segments from the hosted sweep object. (Inherited from HostedSweep)
Public method | SetEndPointParameter | Set segment's start point or end point parameter. (Inherited from HostedSweep)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | VerticalFlip | Flip the hosted sweep object along vertical line. (Inherited from HostedSweep)
Top
See Also

Reference

SlabEdge Class


SlabEdge.AddSegment Method

SlabEdgeAddSegment Method

Add segments to the slab edge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override void AddSegment(
    Reference targetRef
)
Public Overrides Sub AddSegment (
    targetRef As Reference
)
public:
virtual void AddSegment(
    Reference^ targetRef
) override
abstract AddSegment :
        targetRef : Reference -> unit
override AddSegment :
        targetRef : Reference -> unit

Parameters

targetRef Reference
Segment's reference on which want to be added.
Exceptions
Exception | Condition
ArgumentNullException | This exception will be thrown in following cases: 1. Input targetRef is . 2. Input targetRef is not but contains nothing.
InvalidOperationException | This exception will be thrown in following cases: 1. Input targetRef has already been added into the slab edge. 2. Internal code fails to create the segment object. 3. Regeneration fails.
ArgumentOutOfRangeException | This exception will be thrown if the reference is suitable for creating a slab edge as required. The reference allowed is : 1. Model Line 2. Floor's horizontal edges 3. Other slab edge's horizontal edges
See Also

Reference

SlabEdge Class


SlabEdgeType Class

An object that represents the slab edge type in Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBHostObjAttributes
Autodesk.Revit.DBHostedSweepType
Autodesk.Revit.DBSlabEdgeType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SlabEdgeType : HostedSweepType
Public Class SlabEdgeType
    Inherits HostedSweepType
public ref class SlabEdgeType : public HostedSweepType
type SlabEdgeType =
    class
        inherit HostedSweepType
    end

The SlabEdgeType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SlabEdgeType Properties

The SlabEdgeType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

SlabEdgeType Class


SlabEdgeType Methods

The SlabEdgeType type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SlabEdgeType Class


SlabShapeCrease Class

Represents a crease of a slab shape edited element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSlabShapeCrease

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SlabShapeCrease : IDisposable
Public Class SlabShapeCrease
    Implements IDisposable
public ref class SlabShapeCrease : IDisposable
type SlabShapeCrease =
    class
        interface IDisposable
    end

The SlabShapeCrease type exposes the following members.

Properties
 | Name | Description
Public property | CreaseType | The type of the crease.
Public property | Curve | The geometry of the crease.
Public property | EndPoints | The vertices of the crease.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the SlabShapeCrease
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SlabShapeCrease Properties

The SlabShapeCrease type exposes the following members.

Properties
 | Name | Description
Public property | CreaseType | The type of the crease.
Public property | Curve | The geometry of the crease.
Public property | EndPoints | The vertices of the crease.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

SlabShapeCrease Class


SlabShapeCrease.CreaseType Property

SlabShapeCreaseCreaseType Property

The type of the crease.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SlabShapeCreaseType CreaseType { get; }
Public ReadOnly Property CreaseType As SlabShapeCreaseType
    Get
public:
property SlabShapeCreaseType CreaseType {
    SlabShapeCreaseType get ();
}
member CreaseType : SlabShapeCreaseType with get

Property Value

SlabShapeCreaseType
See Also

Reference

SlabShapeCrease Class


SlabShapeCrease.Curve Property

SlabShapeCreaseCurve Property

The geometry of the crease.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Curve Curve { get; }
Public ReadOnly Property Curve As Curve
    Get
public:
property Curve^ Curve {
    Curve^ get ();
}
member Curve : Curve with get

Property Value

Curve
See Also

Reference

SlabShapeCrease Class


SlabShapeCrease.EndPoints Property

SlabShapeCreaseEndPoints Property

The vertices of the crease.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SlabShapeVertexArray EndPoints { get; }
Public ReadOnly Property EndPoints As SlabShapeVertexArray
    Get
public:
property SlabShapeVertexArray^ EndPoints {
    SlabShapeVertexArray^ get ();
}
member EndPoints : SlabShapeVertexArray with get

Property Value

SlabShapeVertexArray
See Also

Reference

SlabShapeCrease Class


SlabShapeCrease.IsValidObject Property

SlabShapeCreaseIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

SlabShapeCrease Class


SlabShapeCrease Methods

The SlabShapeCrease type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SlabShapeCrease Class


SlabShapeCrease.Dispose Method

SlabShapeCreaseDispose Method

Releases all resources used by the SlabShapeCrease

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

SlabShapeCrease Class


SlabShapeCreaseArray Class

An array that can contain any number of creases used in Slab Shape Editing.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBSlabShapeCreaseArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SlabShapeCreaseArray : APIObject,
    IEnumerable
Public Class SlabShapeCreaseArray
    Inherits APIObject
    Implements IEnumerable
public ref class SlabShapeCreaseArray : public APIObject,
    IEnumerable
type SlabShapeCreaseArray =
    class
        inherit APIObject
        interface IEnumerable
    end

The SlabShapeCreaseArray type exposes the following members.

Constructors
 | Name | Description
Public method | SlabShapeCreaseArray | Initializes a new instance of the SlabShapeCreaseArray class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.
Top
Methods
 | Name | Description
Public method | Append | Add the item to the end of the array.
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified item into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SlabShapeCreaseArray Constructor

Initializes a new instance of the SlabShapeCreaseArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SlabShapeCreaseArray()
Public Sub New
public:
SlabShapeCreaseArray()
new : unit -> SlabShapeCreaseArray
See Also

Reference

SlabShapeCreaseArray Class


SlabShapeCreaseArray Properties

The SlabShapeCreaseArray type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.
Top
See Also

Reference

SlabShapeCreaseArray Class


SlabShapeCreaseArray.IsEmpty Property

SlabShapeCreaseArrayIsEmpty Property

Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Boolean
Remarks
If the array is empty then True will be returned, otherwise False.
See Also

Reference

SlabShapeCreaseArray Class


SlabShapeCreaseArray.Item Property

SlabShapeCreaseArrayItem Property

Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual SlabShapeCrease this[
    int index
] { get; set; }
Public Overridable Property Item (
    index As Integer
) As SlabShapeCrease
    Get
    Set
public:
virtual property SlabShapeCrease^ Item[int index] {
    SlabShapeCrease^ get (int index);
    void set (int index, SlabShapeCrease^ value);
}
abstract Item : SlabShapeCrease with get, set
override Item : SlabShapeCrease with get, set

Parameters

index Int32
The index of the item to be set or retrieved.

Return Value

SlabShapeCrease
Returns the object at the specified index.
See Also

Reference

SlabShapeCreaseArray Class


SlabShapeCreaseArray.Size Property

SlabShapeCreaseArraySize Property

Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
abstract Size : int with get
override Size : int with get

Property Value

Int32
See Also

Reference

SlabShapeCreaseArray Class


SlabShapeCreaseArray Methods

The SlabShapeCreaseArray type exposes the following members.

Methods
 | Name | Description
Public method | Append | Add the item to the end of the array.
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified item into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SlabShapeCreaseArray Class


SlabShapeCreaseArray.Append Method

SlabShapeCreaseArrayAppend Method

Add the item to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Append(
    SlabShapeCrease item
)
Public Overridable Sub Append (
    item As SlabShapeCrease
)
public:
virtual void Append(
    SlabShapeCrease^ item
)
abstract Append :
        item : SlabShapeCrease -> unit
override Append :
        item : SlabShapeCrease -> unit

Parameters

item SlabShapeCrease
The item to be added.
See Also

Reference

SlabShapeCreaseArray Class


SlabShapeCreaseArray.Clear Method

SlabShapeCreaseArrayClear Method

Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

SlabShapeCreaseArray Class


SlabShapeCreaseArray.ForwardIterator Method

SlabShapeCreaseArrayForwardIterator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual SlabShapeCreaseArrayIterator ForwardIterator()
Public Overridable Function ForwardIterator As SlabShapeCreaseArrayIterator
public:
virtual SlabShapeCreaseArrayIterator^ ForwardIterator()
abstract ForwardIterator : unit -> SlabShapeCreaseArrayIterator
override ForwardIterator : unit -> SlabShapeCreaseArrayIterator

Return Value

SlabShapeCreaseArrayIterator
Returns a forward moving iterator to the array.
See Also

Reference

SlabShapeCreaseArray Class


SlabShapeCreaseArray.GetEnumerator Method

SlabShapeCreaseArrayGetEnumerator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

IEnumerator
Returns a forward moving iterator to the array.

Implements

IEnumerableGetEnumerator
See Also

Reference

SlabShapeCreaseArray Class


SlabShapeCreaseArray.Insert Method

SlabShapeCreaseArrayInsert Method

Insert the specified item into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Insert(
    SlabShapeCrease item,
    int index
)
Public Overridable Sub Insert (
    item As SlabShapeCrease,
    index As Integer
)
public:
virtual void Insert(
    SlabShapeCrease^ item,
    int index
)
abstract Insert :
        item : SlabShapeCrease *
        index : int -> unit
override Insert :
        item : SlabShapeCrease *
        index : int -> unit

Parameters

item SlabShapeCrease
The item to be inserted into the array.
index Int32
The item will be inserted before this index.

Return Value

Returns whether the item was inserted into the array.
See Also

Reference

SlabShapeCreaseArray Class


SlabShapeCreaseArray.ReverseIterator Method

SlabShapeCreaseArrayReverseIterator Method

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual SlabShapeCreaseArrayIterator ReverseIterator()
Public Overridable Function ReverseIterator As SlabShapeCreaseArrayIterator
public:
virtual SlabShapeCreaseArrayIterator^ ReverseIterator()
abstract ReverseIterator : unit -> SlabShapeCreaseArrayIterator
override ReverseIterator : unit -> SlabShapeCreaseArrayIterator

Return Value

SlabShapeCreaseArrayIterator
Returns a backward moving iterator to the array.
See Also

Reference

SlabShapeCreaseArray Class


SlabShapeCreaseArrayIterator Class

An iterator to an array of creases used for Slab Shape Editing.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBSlabShapeCreaseArrayIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class SlabShapeCreaseArrayIterator : APIObject,
    IEnumerator
Public MustInherit Class SlabShapeCreaseArrayIterator
    Inherits APIObject
    Implements IEnumerator
public ref class SlabShapeCreaseArrayIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type SlabShapeCreaseArrayIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The SlabShapeCreaseArrayIterator type exposes the following members.

Constructors
 | Name | Description
Public method | SlabShapeCreaseArrayIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SlabShapeCreaseArrayIterator Constructor

For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SlabShapeCreaseArrayIterator()
Public Sub New
public:
SlabShapeCreaseArrayIterator()
new : unit -> SlabShapeCreaseArrayIterator
Remarks
This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.
See Also

Reference

SlabShapeCreaseArrayIterator Class


SlabShapeCreaseArrayIterator Properties

The SlabShapeCreaseArrayIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

SlabShapeCreaseArrayIterator Class


SlabShapeCreaseArrayIterator.Current Property

SlabShapeCreaseArrayIteratorCurrent Property

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}
abstract Current : Object with get
override Current : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.
See Also

Reference

SlabShapeCreaseArrayIterator Class


SlabShapeCreaseArrayIterator Methods

The SlabShapeCreaseArrayIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SlabShapeCreaseArrayIterator Class


SlabShapeCreaseArrayIterator.MoveNext Method

SlabShapeCreaseArrayIteratorMoveNext Method

Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumeratorMoveNext
Remarks
MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.
See Also

Reference

SlabShapeCreaseArrayIterator Class


SlabShapeCreaseArrayIterator.Reset Method

SlabShapeCreaseArrayIteratorReset Method

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
Remarks
The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.
See Also

Reference

SlabShapeCreaseArrayIterator Class


SlabShapeCreaseType Enumeration

The type of a SlabShapeCrease

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum SlabShapeCreaseType
Public Enumeration SlabShapeCreaseType
public enum class SlabShapeCreaseType
type SlabShapeCreaseType
Members
Member name | Value | Description
Invalid | 0 | The crease is invalid.
Boundary | 1 | The crease is on boundary.
UserDrawn | 2 | The crease is created by user.
Auto | 3 | the crease is automatically generated.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SlabShapeEditor Class

An object used for Slab Shape Editing.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSlabShapeEditor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SlabShapeEditor : IDisposable
Public Class SlabShapeEditor
    Implements IDisposable
public ref class SlabShapeEditor : IDisposable
type SlabShapeEditor =
    class
        interface IDisposable
    end

The SlabShapeEditor type exposes the following members.

Properties
 | Name | Description
Public property | IsEnabled | Identifies if the slab shape editing functionality is enabled.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SlabShapeCreases | All of the creases that can be edited.
Public property | SlabShapeVertices | All of the vertices that can be edited.
Top
Methods
 | Name | Description
Public method | AddPoint | Add a point to the element.
Public method | AddPoints | Add an array of points to the element.
Public method | AddSplitLine | Add a split line to the element.
Public method | CreateCreasesFromFoldingLines | Convert selected folding lines to split lines
Public method | DeletePoint | Delete a SlabShapeVertex from the element.
Public method | Dispose | Releases all resources used by the SlabShapeEditor
Public method | DrawPoint | Obsolete. Adds a point to the corresponding slab, roof or floor.
Public method | DrawSplitLine | Obsolete. Draws a split line on the corresponding slab, roof or floor.
Public method | Enable | Enables the slab shape editing functionality.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ModifySubElement(SlabShapeCrease, Double) | Manipulates the crease on the corresponding slab, roof or floor.
Public method | ModifySubElement(SlabShapeVertex, Double) | Manipulates the vertex on the corresponding slab, roof or floor.
Public method | PickSupport | Picks an element to support the slab. This method will define split lines and create constant bearing lines for the slab.
 | ResetSlabShape | Removes the modifications made during editing and resets the element geometry back to the unmodified state.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The SlabShapeEditor can be obtained from a slab object, such as a roof or floor.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SlabShapeEditor Properties

The SlabShapeEditor type exposes the following members.

Properties
 | Name | Description
Public property | IsEnabled | Identifies if the slab shape editing functionality is enabled.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SlabShapeCreases | All of the creases that can be edited.
Public property | SlabShapeVertices | All of the vertices that can be edited.
Top
See Also

Reference

SlabShapeEditor Class


SlabShapeEditor.IsEnabled Property

SlabShapeEditorIsEnabled Property

Identifies if the slab shape editing functionality is enabled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEnabled { get; }
Public ReadOnly Property IsEnabled As Boolean
    Get
public:
property bool IsEnabled {
    bool get ();
}
member IsEnabled : bool with get

Property Value

Boolean
Remarks
If true, the creases and vertices are accessible and modifiable. If false, no creases and vertices are accessible.
See Also

Reference

SlabShapeEditor Class


SlabShapeEditor.IsValidObject Property

SlabShapeEditorIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

SlabShapeEditor Class


SlabShapeEditor.SlabShapeCreases Property

SlabShapeEditorSlabShapeCreases Property

All of the creases that can be edited.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SlabShapeCreaseArray SlabShapeCreases { get; }
Public ReadOnly Property SlabShapeCreases As SlabShapeCreaseArray
    Get
public:
property SlabShapeCreaseArray^ SlabShapeCreases {
    SlabShapeCreaseArray^ get ();
}
member SlabShapeCreases : SlabShapeCreaseArray with get

Property Value

SlabShapeCreaseArray
See Also

Reference

SlabShapeEditor Class


SlabShapeEditor.SlabShapeVertices Property

SlabShapeEditorSlabShapeVertices Property

All of the vertices that can be edited.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SlabShapeVertexArray SlabShapeVertices { get; }
Public ReadOnly Property SlabShapeVertices As SlabShapeVertexArray
    Get
public:
property SlabShapeVertexArray^ SlabShapeVertices {
    SlabShapeVertexArray^ get ();
}
member SlabShapeVertices : SlabShapeVertexArray with get

Property Value

SlabShapeVertexArray
See Also

Reference

SlabShapeEditor Class


SlabShapeEditor Methods

The SlabShapeEditor type exposes the following members.

Methods
 | Name | Description
Public method | AddPoint | Add a point to the element.
Public method | AddPoints | Add an array of points to the element.
Public method | AddSplitLine | Add a split line to the element.
Public method | CreateCreasesFromFoldingLines | Convert selected folding lines to split lines
Public method | DeletePoint | Delete a SlabShapeVertex from the element.
Public method | Dispose |
Public method | DrawPoint | Obsolete. Adds a point to the corresponding slab, roof or floor.
Public method | DrawSplitLine | Obsolete. Draws a split line on the corresponding slab, roof or floor.
Public method | Enable | Enables the slab shape editing functionality.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ModifySubElement(SlabShapeCrease, Double) | Manipulates the crease on the corresponding slab, roof or floor.
Public method | ModifySubElement(SlabShapeVertex, Double) | Manipulates the vertex on the corresponding slab, roof or floor.
Public method | PickSupport | Picks an element to support the slab. This method will define split lines and create constant bearing lines for the slab.
 | ResetSlabShape | Removes the modifications made during editing and resets the element geometry back to the unmodified state.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SlabShapeEditor Class


SlabShapeEditor.AddPoint Method

SlabShapeEditorAddPoint Method

Add a point to the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SlabShapeVertex AddPoint(
    XYZ point
)
Public Function AddPoint (
    point As XYZ
) As SlabShapeVertex
public:
SlabShapeVertex^ AddPoint(
    XYZ^ point
)
member AddPoint :
        point : XYZ -> SlabShapeVertex

Parameters

point XYZ

Return Value

SlabShapeVertex
the newly added slab shape vertex.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
The newly added point should be inside the element boundary on the x-y plane. SlabShapeEditor must be enabled before calling this method. Regenerate the document after element creation if this method is called in the same transaction.
See Also

Reference

SlabShapeEditor Class


SlabShapeEditor.AddPoints Method

SlabShapeEditorAddPoints Method

Add an array of points to the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<SlabShapeVertex> AddPoints(
    IList<XYZ> points
)
Public Function AddPoints (
    points As IList(Of XYZ)
) As IList(Of SlabShapeVertex)
public:
IList<SlabShapeVertex^>^ AddPoints(
    IList<XYZ^>^ points
)
member AddPoints :
        points : IList<XYZ> -> IList<SlabShapeVertex>

Parameters

points IList XYZ
The point array.

Return Value

IList SlabShapeVertex
The newly added slab shape vertices.
Exceptions
Exception | Condition
ArgumentException | The input points are not valid. Please check if they are distinct on the x-y plane.
ArgumentNullException | A non-optional argument was null
Remarks
The newly added points should be distinct on the x-y plane, and they should be inside the element boundary. SlabShapeEditor must be enabled before calling this method. Regenerate the document after element creation if this method is called in the same transaction.
See Also

Reference

SlabShapeEditor Class


SlabShapeEditor.AddSplitLine Method

SlabShapeEditorAddSplitLine Method

Add a split line to the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<SlabShapeCrease> AddSplitLine(
    SlabShapeVertex startVertex,
    SlabShapeVertex endVertex
)
Public Function AddSplitLine (
    startVertex As SlabShapeVertex,
    endVertex As SlabShapeVertex
) As IList(Of SlabShapeCrease)
public:
IList<SlabShapeCrease^>^ AddSplitLine(
    SlabShapeVertex^ startVertex,
    SlabShapeVertex^ endVertex
)
member AddSplitLine :
        startVertex : SlabShapeVertex *
        endVertex : SlabShapeVertex -> IList<SlabShapeCrease>

Parameters

startVertex SlabShapeVertex
Start vertex
endVertex SlabShapeVertex
End vertex

Return Value

IList SlabShapeCrease
The newly created creases after adding the split line.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Adding a split line may result in multiple creases, for example when the line crosses existing creases or boundary edges.
See Also

Reference

SlabShapeEditor Class


SlabShapeEditor.CreateCreasesFromFoldingLines Method

SlabShapeEditorCreateCreasesFromFoldingLines Method

Convert selected folding lines to split lines

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void CreateCreasesFromFoldingLines(
    Element hostObj,
    IList<Reference> references
)
Public Sub CreateCreasesFromFoldingLines (
    hostObj As Element,
    references As IList(Of Reference)
)
public:
void CreateCreasesFromFoldingLines(
    Element^ hostObj,
    IList<Reference^>^ references
)
member CreateCreasesFromFoldingLines :
        hostObj : Element *
        references : IList<Reference> -> unit

Parameters

hostObj Element
object that hosts the SlabShapeEditor
references IList Reference
References of selected folding lines.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | this operation failed.
See Also

Reference

SlabShapeEditor Class


SlabShapeEditor.DeletePoint Method

SlabShapeEditorDeletePoint Method

Delete a SlabShapeVertex from the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool DeletePoint(
    SlabShapeVertex vertex
)
Public Function DeletePoint (
    vertex As SlabShapeVertex
) As Boolean
public:
bool DeletePoint(
    SlabShapeVertex^ vertex
)
member DeletePoint :
        vertex : SlabShapeVertex -> bool

Parameters

vertex SlabShapeVertex
The SlabShapeVertex to be deleted.

Return Value

Boolean
True if the vertex is successfully deleted. False if the vertex is not found or could not be deleted.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Corner vertices are created right after the SlabShapeEditor is enabled. They are tied with the boundaries so that they could not be deleted individually. They can only be deleted using ResetSlabShape.
See Also

Reference

SlabShapeEditor Class


SlabShapeEditor.Dispose Method

SlabShapeEditorDispose Method

Releases all resources used by the SlabShapeEditor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

SlabShapeEditor Class


SlabShapeEditor.DrawPoint Method

SlabShapeEditorDrawPoint Method

Note: This API is now obsolete.

Adds a point to the corresponding slab, roof or floor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is deprecated in Revit 2025 and may be removed in a future version of Revit. Use "AddPoint" instead. ")]
public SlabShapeVertex DrawPoint(
    XYZ location
)
<ObsoleteAttribute("This method is deprecated in Revit 2025 and may be removed in a future version of Revit. Use "AddPoint" instead. ")>
Public Function DrawPoint (
    location As XYZ
) As SlabShapeVertex
public:
[ObsoleteAttribute(L"This method is deprecated in Revit 2025 and may be removed in a future version of Revit. Use "AddPoint" instead. ")]
SlabShapeVertex^ DrawPoint(
    XYZ^ location
)
[<ObsoleteAttribute("This method is deprecated in Revit 2025 and may be removed in a future version of Revit. Use "AddPoint" instead. ")>]
member DrawPoint :
        location : XYZ -> SlabShapeVertex

Parameters

location XYZ
The location of the point.

Return Value

SlabShapeVertex
The newly created vertex.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the location is .
Remarks
If the input location is not on the top face of the slab, this function will return . Drawing a point on boundary crease may increase the number of creases. This method will regenerate the document even in manual regeneration mode.
See Also

Reference

SlabShapeEditor Class


SlabShapeEditor.DrawSplitLine Method

SlabShapeEditorDrawSplitLine Method

Note: This API is now obsolete.

Draws a split line on the corresponding slab, roof or floor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is deprecated in Revit 2025 and may be removed in a future version of Revit. Use "AddSplitLine" instead. ")]
public SlabShapeCreaseArray DrawSplitLine(
    SlabShapeVertex startVertex,
    SlabShapeVertex endVertex
)
<ObsoleteAttribute("This method is deprecated in Revit 2025 and may be removed in a future version of Revit. Use "AddSplitLine" instead. ")>
Public Function DrawSplitLine (
    startVertex As SlabShapeVertex,
    endVertex As SlabShapeVertex
) As SlabShapeCreaseArray
public:
[ObsoleteAttribute(L"This method is deprecated in Revit 2025 and may be removed in a future version of Revit. Use "AddSplitLine" instead. ")]
SlabShapeCreaseArray^ DrawSplitLine(
    SlabShapeVertex^ startVertex,
    SlabShapeVertex^ endVertex
)
[<ObsoleteAttribute("This method is deprecated in Revit 2025 and may be removed in a future version of Revit. Use "AddSplitLine" instead. ")>]
member DrawSplitLine :
        startVertex : SlabShapeVertex *
        endVertex : SlabShapeVertex -> SlabShapeCreaseArray

Parameters

startVertex SlabShapeVertex
The vertex to start the split line.
endVertex SlabShapeVertex
The vertex to end the split line.

Return Value

SlabShapeCreaseArray
The newly created creases.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input vertex is .
ArgumentException | Thrown when the input vertex is invalid.
Remarks
Drawing a split line may result in multiple creases, for example when the line crosses existing creases or boundary edges.
See Also

Reference

SlabShapeEditor Class


SlabShapeEditor.Enable Method

SlabShapeEditorEnable Method

Enables the slab shape editing functionality.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Enable()
Public Sub Enable
public:
void Enable()
member Enable : unit -> unit
See Also

Reference

SlabShapeEditor Class


SlabShapeEditor.ModifySubElement Method

SlabShapeEditorModifySubElement Method

Manipulates an entity on the corresponding slab, roof or floor.
Overload List
 | Name | Description
Public method | ModifySubElement(SlabShapeCrease, Double) | Manipulates the crease on the corresponding slab, roof or floor.
Public method | ModifySubElement(SlabShapeVertex, Double) | Manipulates the vertex on the corresponding slab, roof or floor.
Top
See Also

Reference

SlabShapeEditor Class


SlabShapeEditor.ModifySubElement(SlabShapeCrease, Double) Method

SlabShapeEditorModifySubElement(SlabShapeCrease, Double) Method

Manipulates the crease on the corresponding slab, roof or floor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ModifySubElement(
    SlabShapeCrease crease,
    double offset
)
Public Sub ModifySubElement (
    crease As SlabShapeCrease,
    offset As Double
)
public:
void ModifySubElement(
    SlabShapeCrease^ crease,
    double offset
)
member ModifySubElement :
        crease : SlabShapeCrease *
        offset : float -> unit

Parameters

crease SlabShapeCrease
The crease.
offset Double
The new value of the crease offset, which is the average of offsets of its ends.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the crease is .
ArgumentException | Thrown when the crease is invalid.
See Also

Reference

SlabShapeEditor Class
ModifySubElement Overload


SlabShapeEditor.ModifySubElement(SlabShapeVertex, Double) Method

SlabShapeEditorModifySubElement(SlabShapeVertex, Double) Method

Manipulates the vertex on the corresponding slab, roof or floor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ModifySubElement(
    SlabShapeVertex vertex,
    double offset
)
Public Sub ModifySubElement (
    vertex As SlabShapeVertex,
    offset As Double
)
public:
void ModifySubElement(
    SlabShapeVertex^ vertex,
    double offset
)
member ModifySubElement :
        vertex : SlabShapeVertex *
        offset : float -> unit

Parameters

vertex SlabShapeVertex
The vertex.
offset Double
The new value of the vertex offset.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the vertex is .
ArgumentException | Thrown when the vertex is invalid.
See Also

Reference

SlabShapeEditor Class
ModifySubElement Overload


SlabShapeEditor.PickSupport Method

SlabShapeEditorPickSupport Method

Picks an element to support the slab. This method will define split lines and create constant bearing lines for the slab.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void PickSupport(
    Line gLine
)
Public Sub PickSupport (
    gLine As Line
)
public:
void PickSupport(
    Line^ gLine
)
member PickSupport :
        gLine : Line -> unit

Parameters

gLine Line
A line from a support element such as a beam.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input line is .
ArgumentException | Thrown when the input line is invalid.
See Also

Reference

SlabShapeEditor Class


SlabShapeEditor.ResetSlabShape Method

SlabShapeEditorResetSlabShape Method

Removes the modifications made during editing and resets the element geometry back to the unmodified state.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetSlabShape()
Public Sub ResetSlabShape
public:
void ResetSlabShape()
member ResetSlabShape : unit -> unit
Remarks
Calling this method will reset the slab back to its original state and disable Slab Shape Editing. If further editing is needed, call Enable again.
Example
C#
VB
C++
F#
Copy
private void ResetSlabShapes(Autodesk.Revit.DB.Document document)
{
    UIDocument uidoc = new UIDocument(document);
    ICollection<ElementId> selectedIds = uidoc.Selection.GetElementIds();
    foreach (ElementId id in selectedIds)
    {
        Floor floor = document.GetElement(id) as Floor;
        if (floor != null)
        {
            SlabShapeEditor slabShapeEditor = floor.GetSlabShapeEditor();
            slabShapeEditor.ResetSlabShape();
        }
    }

}
Private Sub ResetSlabShapes(document As Autodesk.Revit.DB.Document)
    Dim uidoc As New UIDocument(document)
    Dim selectedIds As ICollection(Of ElementId) = uidoc.Selection.GetElementIds()
    For Each id As ElementId In selectedIds
        Dim floor As Floor = TryCast(document.GetElement(id), Floor)
        If floor IsNot Nothing Then
            Dim slabShapeEditor As SlabShapeEditor = floor.GetSlabShapeEditor()
            slabShapeEditor.ResetSlabShape()
        End If
    Next

End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

SlabShapeEditor Class


SlabShapeVertex Class

Represents a vertex of a slab shape edited element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSlabShapeVertex

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SlabShapeVertex : IDisposable
Public Class SlabShapeVertex
    Implements IDisposable
public ref class SlabShapeVertex : IDisposable
type SlabShapeVertex =
    class
        interface IDisposable
    end

The SlabShapeVertex type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Position | The vertex position
Public property | VertexType | The vertex type
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the SlabShapeVertex
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SlabShapeVertex Properties

The SlabShapeVertex type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Position | The vertex position
Public property | VertexType | The vertex type
Top
See Also

Reference

SlabShapeVertex Class


SlabShapeVertex.IsValidObject Property

SlabShapeVertexIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

SlabShapeVertex Class


SlabShapeVertex.Position Property

SlabShapeVertexPosition Property

The vertex position

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Position { get; }
Public ReadOnly Property Position As XYZ
    Get
public:
property XYZ^ Position {
    XYZ^ get ();
}
member Position : XYZ with get

Property Value

XYZ
See Also

Reference

SlabShapeVertex Class


SlabShapeVertex.VertexType Property

SlabShapeVertexVertexType Property

The vertex type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SlabShapeVertexType VertexType { get; }
Public ReadOnly Property VertexType As SlabShapeVertexType
    Get
public:
property SlabShapeVertexType VertexType {
    SlabShapeVertexType get ();
}
member VertexType : SlabShapeVertexType with get

Property Value

SlabShapeVertexType
See Also

Reference

SlabShapeVertex Class


SlabShapeVertex Methods

The SlabShapeVertex type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SlabShapeVertex Class


SlabShapeVertex.Dispose Method

SlabShapeVertexDispose Method

Releases all resources used by the SlabShapeVertex

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

SlabShapeVertex Class


SlabShapeVertexArray Class

An array that can contain any number of vertices used in Slab Shape Editing.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBSlabShapeVertexArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SlabShapeVertexArray : APIObject,
    IEnumerable
Public Class SlabShapeVertexArray
    Inherits APIObject
    Implements IEnumerable
public ref class SlabShapeVertexArray : public APIObject,
    IEnumerable
type SlabShapeVertexArray =
    class
        inherit APIObject
        interface IEnumerable
    end

The SlabShapeVertexArray type exposes the following members.

Constructors
 | Name | Description
Public method | SlabShapeVertexArray | Initializes a new instance of the SlabShapeVertexArray class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.
Top
Methods
 | Name | Description
Public method | Append | Add the item to the end of the array.
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified item into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SlabShapeVertexArray Constructor

Initializes a new instance of the SlabShapeVertexArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SlabShapeVertexArray()
Public Sub New
public:
SlabShapeVertexArray()
new : unit -> SlabShapeVertexArray
See Also

Reference

SlabShapeVertexArray Class


SlabShapeVertexArray Properties

The SlabShapeVertexArray type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.
Top
See Also

Reference

SlabShapeVertexArray Class


SlabShapeVertexArray.IsEmpty Property

SlabShapeVertexArrayIsEmpty Property

Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Boolean
Remarks
If the array is empty then True will be returned, otherwise False.
See Also

Reference

SlabShapeVertexArray Class


SlabShapeVertexArray.Item Property

SlabShapeVertexArrayItem Property

Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual SlabShapeVertex this[
    int index
] { get; set; }
Public Overridable Property Item (
    index As Integer
) As SlabShapeVertex
    Get
    Set
public:
virtual property SlabShapeVertex^ Item[int index] {
    SlabShapeVertex^ get (int index);
    void set (int index, SlabShapeVertex^ value);
}
abstract Item : SlabShapeVertex with get, set
override Item : SlabShapeVertex with get, set

Parameters

index Int32
The index of the item to be set or retrieved.

Return Value

SlabShapeVertex
Returns the object at the specified index.
See Also

Reference

SlabShapeVertexArray Class


SlabShapeVertexArray.Size Property

SlabShapeVertexArraySize Property

Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
abstract Size : int with get
override Size : int with get

Property Value

Int32
See Also

Reference

SlabShapeVertexArray Class


SlabShapeVertexArray Methods

The SlabShapeVertexArray type exposes the following members.

Methods
 | Name | Description
Public method | Append | Add the item to the end of the array.
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified item into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SlabShapeVertexArray Class


SlabShapeVertexArray.Append Method

SlabShapeVertexArrayAppend Method

Add the item to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Append(
    SlabShapeVertex item
)
Public Overridable Sub Append (
    item As SlabShapeVertex
)
public:
virtual void Append(
    SlabShapeVertex^ item
)
abstract Append :
        item : SlabShapeVertex -> unit
override Append :
        item : SlabShapeVertex -> unit

Parameters

item SlabShapeVertex
The item to be added.
See Also

Reference

SlabShapeVertexArray Class


SlabShapeVertexArray.Clear Method

SlabShapeVertexArrayClear Method

Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

SlabShapeVertexArray Class


SlabShapeVertexArray.ForwardIterator Method

SlabShapeVertexArrayForwardIterator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual SlabShapeVertexArrayIterator ForwardIterator()
Public Overridable Function ForwardIterator As SlabShapeVertexArrayIterator
public:
virtual SlabShapeVertexArrayIterator^ ForwardIterator()
abstract ForwardIterator : unit -> SlabShapeVertexArrayIterator
override ForwardIterator : unit -> SlabShapeVertexArrayIterator

Return Value

SlabShapeVertexArrayIterator
Returns a forward moving iterator to the array.
See Also

Reference

SlabShapeVertexArray Class


SlabShapeVertexArray.GetEnumerator Method

SlabShapeVertexArrayGetEnumerator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

IEnumerator
Returns a forward moving iterator to the array.

Implements

IEnumerableGetEnumerator
See Also

Reference

SlabShapeVertexArray Class


SlabShapeVertexArray.Insert Method

SlabShapeVertexArrayInsert Method

Insert the specified item into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Insert(
    SlabShapeVertex item,
    int index
)
Public Overridable Sub Insert (
    item As SlabShapeVertex,
    index As Integer
)
public:
virtual void Insert(
    SlabShapeVertex^ item,
    int index
)
abstract Insert :
        item : SlabShapeVertex *
        index : int -> unit
override Insert :
        item : SlabShapeVertex *
        index : int -> unit

Parameters

item SlabShapeVertex
The item to be inserted into the array.
index Int32
The item will be inserted before this index.

Return Value

Returns whether the item was inserted into the array.
See Also

Reference

SlabShapeVertexArray Class


SlabShapeVertexArray.ReverseIterator Method

SlabShapeVertexArrayReverseIterator Method

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual SlabShapeVertexArrayIterator ReverseIterator()
Public Overridable Function ReverseIterator As SlabShapeVertexArrayIterator
public:
virtual SlabShapeVertexArrayIterator^ ReverseIterator()
abstract ReverseIterator : unit -> SlabShapeVertexArrayIterator
override ReverseIterator : unit -> SlabShapeVertexArrayIterator

Return Value

SlabShapeVertexArrayIterator
Returns a backward moving iterator to the array.
See Also

Reference

SlabShapeVertexArray Class


SlabShapeVertexArrayIterator Class

An iterator to an array of vertices used for Slab Shape Editing.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBSlabShapeVertexArrayIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class SlabShapeVertexArrayIterator : APIObject,
    IEnumerator
Public MustInherit Class SlabShapeVertexArrayIterator
    Inherits APIObject
    Implements IEnumerator
public ref class SlabShapeVertexArrayIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type SlabShapeVertexArrayIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The SlabShapeVertexArrayIterator type exposes the following members.

Constructors
 | Name | Description
Public method | SlabShapeVertexArrayIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SlabShapeVertexArrayIterator Constructor

For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SlabShapeVertexArrayIterator()
Public Sub New
public:
SlabShapeVertexArrayIterator()
new : unit -> SlabShapeVertexArrayIterator
Remarks
This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.
See Also

Reference

SlabShapeVertexArrayIterator Class


SlabShapeVertexArrayIterator Properties

The SlabShapeVertexArrayIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

SlabShapeVertexArrayIterator Class


SlabShapeVertexArrayIterator.Current Property

SlabShapeVertexArrayIteratorCurrent Property

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}
abstract Current : Object with get
override Current : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.
See Also

Reference

SlabShapeVertexArrayIterator Class


SlabShapeVertexArrayIterator Methods

The SlabShapeVertexArrayIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SlabShapeVertexArrayIterator Class


SlabShapeVertexArrayIterator.MoveNext Method

SlabShapeVertexArrayIteratorMoveNext Method

Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumeratorMoveNext
Remarks
MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.
See Also

Reference

SlabShapeVertexArrayIterator Class


SlabShapeVertexArrayIterator.Reset Method

SlabShapeVertexArrayIteratorReset Method

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
Remarks
The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.
See Also

Reference

SlabShapeVertexArrayIterator Class


SlabShapeVertexType Enumeration

The type of a SlabShapeVertex

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum SlabShapeVertexType
Public Enumeration SlabShapeVertexType
public enum class SlabShapeVertexType
type SlabShapeVertexType
Members
Member name | Value | Description
Invalid | 0 |
Corner | 1 |
Edge | 2 |
Interior | 3 |
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SlantedOrVerticalColumnType Enumeration

This enum class is used for the BuiltInParameter SLANTED_COLUMN_TYPE_PARAM.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum SlantedOrVerticalColumnType
Public Enumeration SlantedOrVerticalColumnType
public enum class SlantedOrVerticalColumnType
type SlantedOrVerticalColumnType
Members
Member name | Value | Description
CT_Vertical | 0 |
CT_Angle | 1 |
CT_EndPoint | 2 |
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Solid Class

A 3d solid.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBGeometryObject
Autodesk.Revit.DBSolid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Solid : GeometryObject
Public Class Solid
    Inherits GeometryObject
public ref class Solid : public GeometryObject
type Solid =
    class
        inherit GeometryObject
    end

The Solid type exposes the following members.

Properties
 | Name | Description
Public property | Edges | The edges that belong to the solid.
 | Faces | The faces that belong to the solid.
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject)
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | SurfaceArea | Returns the total surface area of this solid.
Public property | Visibility | The visibility. (Inherited from GeometryObject)
Public property | Volume | Returns the signed volume of this solid.
Top
Methods
 | Name | Description
Public method | ComputeCentroid | Returns the Centroid of this solid.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject)
Public method | GetBoundingBox | Retrieves a box that circumscribes the solid geometry.
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | IntersectWithCurve | Calculates and returns the intersection between a curve and this solid.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
A solid is defined by the faces and edges that form its boundary.
Example
C#
VB
C++
F#
Copy
private void GetAndTransformSolidInfo(Application application, Element element, Options geoOptions)
{
    // Get geometry element of the selected element
    Autodesk.Revit.DB.GeometryElement geoElement = element.get_Geometry(geoOptions);

    // Get geometry object
    foreach (GeometryObject geoObject in geoElement)
    {
        // Get the geometry instance which contains the geometry information
        Autodesk.Revit.DB.GeometryInstance instance = geoObject as Autodesk.Revit.DB.GeometryInstance;
        if (null != instance)
        {
            foreach (GeometryObject instObj in instance.SymbolGeometry)
            {
                Solid solid = instObj as Solid;
                if (null == solid || 0 == solid.Faces.Size || 0 == solid.Edges.Size)
                {
                    continue;
                }

                Transform instTransform = instance.Transform;
                // Get the faces and edges from solid, and transform the formed points
                foreach (Face face in solid.Faces)
                {
                    Mesh mesh = face.Triangulate();
                    foreach (XYZ ii in mesh.Vertices)
                    {
                       XYZ point = ii;
                        XYZ transformedPoint = instTransform.OfPoint(point);
                    }
                }
                foreach (Edge edge in solid.Edges)
                {
                   foreach (XYZ ii in edge.Tessellate())
                    {
                       XYZ point = ii;
                        XYZ transformedPoint = instTransform.OfPoint(point);
                    }
                }
            }
        }
    }

}
Private Sub GetAndTransformSolidInfo(application As Application, element As Element, geoOptions As Options)
    ' Get geometry element of the selected element
    Dim geoElement As Autodesk.Revit.DB.GeometryElement = element.Geometry(geoOptions)

    ' Get geometry object
    For Each geoObject As GeometryObject In geoElement
        ' Get the geometry instance which contains the geometry information
        Dim instance As Autodesk.Revit.DB.GeometryInstance = TryCast(geoObject, Autodesk.Revit.DB.GeometryInstance)
        If instance IsNot Nothing Then
            For Each instObj As GeometryObject In instance.SymbolGeometry
                Dim solid As Solid = TryCast(instObj, Solid)
                If solid Is Nothing OrElse 0 = solid.Faces.Size OrElse 0 = solid.Edges.Size Then
                    Continue For
                End If

                Dim instTransform As Transform = instance.Transform
                ' Get the faces and edges from solid, and transform the formed points
                For Each face As Face In solid.Faces
                    Dim mesh As Mesh = face.Triangulate()
                    For Each ii As XYZ In mesh.Vertices
                        Dim point As XYZ = ii
                        Dim transformedPoint As XYZ = instTransform.OfPoint(point)
                    Next
                Next
                For Each edge As Edge In solid.Edges
                    For Each ii As XYZ In edge.Tessellate()
                        Dim point As XYZ = ii
                        Dim transformedPoint As XYZ = instTransform.OfPoint(point)
                    Next
                Next
            Next
        End If
    Next

End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Solid Properties

The Solid type exposes the following members.

Properties
 | Name | Description
Public property | Edges | The edges that belong to the solid.
 | Faces | The faces that belong to the solid.
 | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject)
Public property | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject)
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | SurfaceArea | Returns the total surface area of this solid.
Public property | Visibility | The visibility. (Inherited from GeometryObject)
Public property | Volume | Returns the signed volume of this solid.
Top
See Also

Reference

Solid Class


Solid.Edges Property

SolidEdges Property

The edges that belong to the solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EdgeArray Edges { get; }
Public ReadOnly Property Edges As EdgeArray
    Get
public:
property EdgeArray^ Edges {
    EdgeArray^ get ();
}
member Edges : EdgeArray with get

Property Value

EdgeArray
See Also

Reference

Solid Class


Solid.Faces Property

SolidFaces Property

The faces that belong to the solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FaceArray Faces { get; }
Public ReadOnly Property Faces As FaceArray
    Get
public:
property FaceArray^ Faces {
    FaceArray^ get ();
}
member Faces : FaceArray with get

Property Value

FaceArray
Remarks
A face may be degenerate. This can be determined with the Face property IsTwoSided.
Example
C#
VB
C++
F#
Copy
private void GetFacesAndEdges(Wall wall)
{
    String faceInfo = "";

    Autodesk.Revit.DB.Options opt = new Options();
    Autodesk.Revit.DB.GeometryElement geomElem = wall.get_Geometry(opt);
    foreach (GeometryObject geomObj in geomElem)
    {
        Solid geomSolid = geomObj as Solid;
        if (null != geomSolid)
        {
            int faces = 0;
            double totalArea = 0;
            foreach (Face geomFace in geomSolid.Faces)
            {
                faces++;
                faceInfo += "Face " + faces + " area: " + geomFace.Area.ToString() + "\n";
                totalArea += geomFace.Area;
            }
            faceInfo += "Number of faces: " + faces + "\n";
            faceInfo += "Total area: " + totalArea.ToString() + "\n";
            foreach (Edge geomEdge in geomSolid.Edges)
            {
                // get wall's geometry edges
            }
        }
    }

    TaskDialog.Show("Revit",faceInfo);
}
Private Sub GetFacesAndEdges(wall As Wall)
    Dim faceInfo As [String] = ""

    Dim opt As Autodesk.Revit.DB.Options = New Options()
    Dim geomElem As Autodesk.Revit.DB.GeometryElement = wall.Geometry(opt)
    For Each geomObj As GeometryObject In geomElem
        Dim geomSolid As Solid = TryCast(geomObj, Solid)
        If geomSolid IsNot Nothing Then
            Dim faces As Integer = 0
            Dim totalArea As Double = 0
            For Each geomFace As Face In geomSolid.Faces
                faces += 1
                faceInfo += "Face " + faces + " area: " + geomFace.Area.ToString() + vbLf
                totalArea += geomFace.Area
            Next
            faceInfo += "Number of faces: " + faces + vbLf
            faceInfo += "Total area: " + totalArea.ToString() + vbLf
            ' get wall's geometry edges
            For Each geomEdge As Edge In geomSolid.Edges
            Next
        End If
    Next

    TaskDialog.Show("Revit", faceInfo)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Solid Class


Solid.SurfaceArea Property

SolidSurfaceArea Property

Returns the total surface area of this solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double SurfaceArea { get; }
Public ReadOnly Property SurfaceArea As Double
    Get
public:
property double SurfaceArea {
    double get ();
}
member SurfaceArea : float with get

Return Value

Double
The real number equal to the total area of this solid.
Exceptions
Exception | Condition
InvalidOperationException | Thrown when this solid is not a valid Geometry object.
Remarks
Calculates the surface area by adding together the areas of faces comprising this solid. Will slightly underestimate if curved surfaces are present.
See Also

Reference

Solid Class


Solid.Volume Property

SolidVolume Property

Returns the signed volume of this solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Volume { get; }
Public ReadOnly Property Volume As Double
    Get
public:
property double Volume {
    double get ();
}
member Volume : float with get

Return Value

Double
The real number equal to the signed volume of this solid.
Exceptions
Exception | Condition
InvalidOperationException | Thrown when this solid is not a valid Geometry object or the volume calculation failed.
Remarks
Revit attempts to compute the volume analytically, if possible. If an analytical solution is not possible, it uses tessellated faces to calculate a reasonable approximation for the volume. The calculated volume may be slightly underestimated or overestimated if curved surfaces are present.
See Also

Reference

Solid Class


Solid Methods

The Solid type exposes the following members.

Methods
 | Name | Description
Public method | ComputeCentroid | Returns the Centroid of this solid.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject)
Public method | GetBoundingBox | Retrieves a box that circumscribes the solid geometry.
Public method | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | IntersectWithCurve | Calculates and returns the intersection between a curve and this solid.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Solid Class


Solid.ComputeCentroid Method

SolidComputeCentroid Method

Returns the Centroid of this solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ ComputeCentroid()
Public Function ComputeCentroid As XYZ
public:
XYZ^ ComputeCentroid()
member ComputeCentroid : unit -> XYZ

Return Value

XYZ
The XYZ point of the Centroid of this solid.
Remarks
Calculates the centroid of the solid using an approximation, with an accuracy suitable for architectural purposes. This will correspond only with the center of gravity if the solid represents a homogeneous structure of a single material.
See Also

Reference

Solid Class


Solid.GetBoundingBox Method

SolidGetBoundingBox Method

Retrieves a box that circumscribes the solid geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BoundingBoxXYZ GetBoundingBox()
Public Function GetBoundingBox As BoundingBoxXYZ
public:
BoundingBoxXYZ^ GetBoundingBox()
member GetBoundingBox : unit -> BoundingBoxXYZ

Return Value

BoundingBoxXYZ
Remarks
The bounding box information is stored as bounds in local coordinates and a transform. So the transform is to be taken in to account when using the bounds. This is different from the bounding box returned by Element.BoundingBox in that the bounding box returned by that routine stores the bounds in modeling coordinates with an identity transform.
See Also

Reference

Solid Class


Solid.IntersectWithCurve Method

SolidIntersectWithCurve Method

Calculates and returns the intersection between a curve and this solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SolidCurveIntersection IntersectWithCurve(
    Curve curve,
    SolidCurveIntersectionOptions options
)
Public Function IntersectWithCurve (
    curve As Curve,
    options As SolidCurveIntersectionOptions
) As SolidCurveIntersection
public:
SolidCurveIntersection^ IntersectWithCurve(
    Curve^ curve,
    SolidCurveIntersectionOptions^ options
)
member IntersectWithCurve :
        curve : Curve *
        options : SolidCurveIntersectionOptions -> SolidCurveIntersection

Parameters

curve Curve
The curve.
options SolidCurveIntersectionOptions
The options. If NULL, the default options will be used.

Return Value

SolidCurveIntersection
The intersection results.
Exceptions
Exception | Condition
ArgumentException | The input curve is not bound. -or- The input solid is not a closed volume.
ArgumentNullException | A non-optional argument was NULL
Example
C#
VB
C++
F#
Copy
private void FindColumnRebarIntersections(Document document, FamilyInstance column)
{
    // We will be computing the total length of the rebar inside the column
    double totalRebarLengthInColumn = 0;

    // Find rebar hosted by this column
    RebarHostData rebarHostData = RebarHostData.GetRebarHostData(column);
    if (rebarHostData == null)
    {
        return;
    }

    IList<Rebar> rebars = rebarHostData.GetRebarsInHost();
    if (rebars.Count == 0)
    {
        return;
    }

    // Retrieve geometry of the column
    Options geomOptions = new Options();
    geomOptions.ComputeReferences = true;
    geomOptions.DetailLevel = ViewDetailLevel.Fine;
    GeometryElement elemGeometry = column.get_Geometry(geomOptions);

    // Examine all geometry primitives of the column
    foreach (GeometryObject elemPrimitive in elemGeometry)
    {

        // Skip objects that are not geometry instances
        GeometryInstance gInstance = elemPrimitive as GeometryInstance;
        if (gInstance == null)
        {
            continue;
        }

        // Retrieve geometry of each found geometry instance
        GeometryElement instGeometry = gInstance.GetInstanceGeometry();
        foreach (GeometryObject instPrimitive in instGeometry)
        {

            // Skip non-solid sobject
            Solid solid = instPrimitive as Solid;
            if (solid == null)
            {
                continue;
            }

            SolidCurveIntersectionOptions intersectOptions = new SolidCurveIntersectionOptions();
            foreach (Rebar rebar in rebars)
            {
                // Get the centerlines for the rebar to find their intersection with the column
                bool selfIntersection = false;
                bool suppresHooks = false;
                bool suppresBends = false;
                IList<Curve> curves = rebar.GetCenterlineCurves(selfIntersection, suppresHooks, suppresBends, MultiplanarOption.IncludeOnlyPlanarCurves, 0);

                // Examine every segment of every curve of the centerline
                foreach (Curve curve in curves)
                {
                    SolidCurveIntersection intersection = solid.IntersectWithCurve(curve, intersectOptions);
                    for (int segment = 0; segment <= intersection.SegmentCount - 1; segment++)
                    {
                        // Calculate length of the rebar that is inside the column
                        Curve curveInside = intersection.GetCurveSegment(segment);
                        double rebarLengthInColumn = curveInside.Length;
                        totalRebarLengthInColumn = totalRebarLengthInColumn + rebarLengthInColumn;
                    }
                }

            }
        }
    }

}
Private Sub FindColumnRebarIntersections(document As Document, column As FamilyInstance)
    ' We will be computing the total length of the rebar inside the column
    Dim totalRebarLengthInColumn As Double = 0

    ' Find rebar hosted by this column
    Dim rebarHostData__1 As RebarHostData = RebarHostData.GetRebarHostData(column)
    If rebarHostData__1 Is Nothing Then
        Return
    End If

    Dim rebars As IList(Of Rebar) = rebarHostData__1.GetRebarsInHost()
    If rebars.Count = 0 Then
        Return
    End If

    ' Retrieve geometry of the column
    Dim geomOptions As New Options()
    geomOptions.ComputeReferences = True
    geomOptions.DetailLevel = ViewDetailLevel.Fine
    Dim elemGeometry As GeometryElement = column.Geometry(geomOptions)

    ' Examine all geometry primitives of the column
    For Each elemPrimitive As GeometryObject In elemGeometry

        ' Skip objects that are not geometry instances
        Dim gInstance As GeometryInstance = TryCast(elemPrimitive, GeometryInstance)
        If gInstance Is Nothing Then
            Continue For
        End If

        ' Retrieve geometry of each found geometry instance
        Dim instGeometry As GeometryElement = gInstance.GetInstanceGeometry()
        For Each instPrimitive As GeometryObject In instGeometry

            ' Skip non-solid sobject
            Dim solid As Solid = TryCast(instPrimitive, Solid)
            If solid Is Nothing Then
                Continue For
            End If

            Dim intersectOptions As New SolidCurveIntersectionOptions()
            For Each rebar As Rebar In rebars
                ' Get the centerlines for the rebar to find their intersection with the column
                Dim selfIntersection As Boolean = False
                Dim suppresHooks As Boolean = False
                Dim suppresBends As Boolean = False
                Dim curves As IList(Of Curve) = rebar.GetCenterlineCurves(selfIntersection, suppresHooks, suppresBends, MultiplanarOption.IncludeOnlyPlanarCurves, 0)

                ' Examine every segment of every curve of the centerline
                For Each curve As Curve In curves
                    Dim intersection As SolidCurveIntersection = solid.IntersectWithCurve(curve, intersectOptions)
                    For segment As Integer = 0 To intersection.SegmentCount - 1
                        ' Calculate length of the rebar that is inside the column
                        Dim curveInside As Curve = intersection.GetCurveSegment(segment)
                        Dim rebarLengthInColumn As Double = curveInside.Length
                        totalRebarLengthInColumn = totalRebarLengthInColumn + rebarLengthInColumn
                    Next

                Next
            Next
        Next
    Next

End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Solid Class


SolidCurveIntersection Class

This class represents the results of a calculation of intersection between a solid volume and a curve.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSolidCurveIntersection

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SolidCurveIntersection : IEnumerable<Curve>,
    IDisposable
Public Class SolidCurveIntersection
    Implements IEnumerable(Of Curve), IDisposable
public ref class SolidCurveIntersection : IEnumerable<Curve^>,
    IDisposable
type SolidCurveIntersection =
    class
        interface IEnumerable<Curve>
        interface IDisposable
    end

The SolidCurveIntersection type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ResultType | The result type used to calculate the intersections.
Public property | SegmentCount | The number of segments in the results.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the SolidCurveIntersection
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetCurveSegment | Gets the curve segment generated by intersection.
Public method | GetCurveSegmentExtents | Gets the extents for the given curve segment generated by intersection.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The results contain a collection of curves and a collection of curve extents (which are the parameters of intersection from the original input curve). Depending on the SolidCurveIntersectionMode option passed when executing the calculation, the curve segments and curve extents represent either the extents of the curve which exist inside the solid, or the extents of the curve which exist outside the solid. If the curve is entirely inside the solid, and the option is CurveSegmentsOutside, or if the curve is entirely outside the solid, and the option is CurveSegmentsInside, this results object will be empty. Note that curves aligned with the bounding faces of the solid are considered to be inside by this utility.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SolidCurveIntersection Properties

The SolidCurveIntersection type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ResultType | The result type used to calculate the intersections.
Public property | SegmentCount | The number of segments in the results.
Top
See Also

Reference

SolidCurveIntersection Class


SolidCurveIntersection.IsValidObject Property

SolidCurveIntersectionIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

SolidCurveIntersection Class


SolidCurveIntersection.ResultType Property

SolidCurveIntersectionResultType Property

The result type used to calculate the intersections.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SolidCurveIntersectionMode ResultType { get; }
Public ReadOnly Property ResultType As SolidCurveIntersectionMode
    Get
public:
property SolidCurveIntersectionMode ResultType {
    SolidCurveIntersectionMode get ();
}
member ResultType : SolidCurveIntersectionMode with get

Property Value

SolidCurveIntersectionMode
See Also

Reference

SolidCurveIntersection Class


SolidCurveIntersection.SegmentCount Property

SolidCurveIntersectionSegmentCount Property

The number of segments in the results.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int SegmentCount { get; }
Public ReadOnly Property SegmentCount As Integer
    Get
public:
property int SegmentCount {
    int get ();
}
member SegmentCount : int with get

Property Value

Int32
See Also

Reference

SolidCurveIntersection Class


SolidCurveIntersection Methods

The SolidCurveIntersection type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetCurveSegment | Gets the curve segment generated by intersection.
Public method | GetCurveSegmentExtents | Gets the extents for the given curve segment generated by intersection.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SolidCurveIntersection Class


SolidCurveIntersection.Dispose Method

SolidCurveIntersectionDispose Method

Releases all resources used by the SolidCurveIntersection

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

SolidCurveIntersection Class


SolidCurveIntersection.GetBasicIEnumerator Method

SolidCurveIntersectionGetBasicIEnumerator Method

Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
internal virtual IEnumerator GetBasicIEnumerator()
Friend Overridable Function GetBasicIEnumerator As IEnumerator
internal:
virtual IEnumerator^ GetBasicIEnumerator()
internal abstract GetBasicIEnumerator : unit -> IEnumerator
internal override GetBasicIEnumerator : unit -> IEnumerator

Return Value

IEnumerator
An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerableGetEnumerator
See Also

Reference

SolidCurveIntersection Class


SolidCurveIntersection.GetCurveSegment Method

SolidCurveIntersectionGetCurveSegment Method

Gets the curve segment generated by intersection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Curve GetCurveSegment(
    int index
)
Public Function GetCurveSegment (
    index As Integer
) As Curve
public:
Curve^ GetCurveSegment(
    int index
)
member GetCurveSegment :
        index : int -> Curve

Parameters

index Int32
The index.

Return Value

Curve
The curve.
Exceptions
Exception | Condition
ArgumentException | index is out of range.
See Also

Reference

SolidCurveIntersection Class


SolidCurveIntersection.GetCurveSegmentExtents Method

SolidCurveIntersectionGetCurveSegmentExtents Method

Gets the extents for the given curve segment generated by intersection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurveExtents GetCurveSegmentExtents(
    int index
)
Public Function GetCurveSegmentExtents (
    index As Integer
) As CurveExtents
public:
CurveExtents^ GetCurveSegmentExtents(
    int index
)
member GetCurveSegmentExtents :
        index : int -> CurveExtents

Parameters

index Int32
The index.

Return Value

CurveExtents
The curve extents.
Exceptions
Exception | Condition
ArgumentException | index is out of range.
Remarks
The parameters are raw parameters based on the raw parameter extents of the original input curve.
See Also

Reference

SolidCurveIntersection Class


SolidCurveIntersection.GetEnumerator Method

SolidCurveIntersectionGetEnumerator Method

Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator<Curve> GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator(Of Curve)
public:
virtual IEnumerator<Curve^>^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator<Curve>
override GetEnumerator : unit -> IEnumerator<Curve>

Return Value

IEnumerator Curve
An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerableTGetEnumerator
See Also

Reference

SolidCurveIntersection Class


SolidCurveIntersectionMode Enumeration

Represents the types of results available for calculating the intersection between a solid and a curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum SolidCurveIntersectionMode
Public Enumeration SolidCurveIntersectionMode
public enum class SolidCurveIntersectionMode
type SolidCurveIntersectionMode
Members
Member name | Value | Description
CurveSegmentsInside | 0 | The results will include only curve segments inside the solid volume. This also will include curve segments coincident with the face(s) of the volume.
CurveSegmentsOutside | 1 | The results will include only curve segments outside the solid volume.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SolidCurveIntersectionOptions Class

This class contains the options used to calculate the intersection between a solid and a curve.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSolidCurveIntersectionOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SolidCurveIntersectionOptions : IDisposable
Public Class SolidCurveIntersectionOptions
    Implements IDisposable
public ref class SolidCurveIntersectionOptions : IDisposable
type SolidCurveIntersectionOptions =
    class
        interface IDisposable
    end

The SolidCurveIntersectionOptions type exposes the following members.

Constructors
 | Name | Description
Public method | SolidCurveIntersectionOptions | Constructs a new SolidCurveIntersectionMode with default settings.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ResultType | The type of results expected by the calculation. The default is CurveSegmentsInside.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the SolidCurveIntersectionOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SolidCurveIntersectionOptions Constructor

Constructs a new SolidCurveIntersectionMode with default settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SolidCurveIntersectionOptions()
Public Sub New
public:
SolidCurveIntersectionOptions()
new : unit -> SolidCurveIntersectionOptions
See Also

Reference

SolidCurveIntersectionOptions Class


SolidCurveIntersectionOptions Properties

The SolidCurveIntersectionOptions type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ResultType | The type of results expected by the calculation. The default is CurveSegmentsInside.
Top
See Also

Reference

SolidCurveIntersectionOptions Class


SolidCurveIntersectionOptions.IsValidObject Property

SolidCurveIntersectionOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

SolidCurveIntersectionOptions Class


SolidCurveIntersectionOptions.ResultType Property

SolidCurveIntersectionOptionsResultType Property

The type of results expected by the calculation. The default is CurveSegmentsInside.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SolidCurveIntersectionMode ResultType { get; set; }
Public Property ResultType As SolidCurveIntersectionMode
    Get
    Set
public:
property SolidCurveIntersectionMode ResultType {
    SolidCurveIntersectionMode get ();
    void set (SolidCurveIntersectionMode value);
}
member ResultType : SolidCurveIntersectionMode with get, set

Property Value

SolidCurveIntersectionMode
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

SolidCurveIntersectionOptions Class


SolidCurveIntersectionOptions Methods

The SolidCurveIntersectionOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SolidCurveIntersectionOptions Class


SolidCurveIntersectionOptions.Dispose Method

SolidCurveIntersectionOptionsDispose Method

Releases all resources used by the SolidCurveIntersectionOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

SolidCurveIntersectionOptions Class


SolidGeometry Enumeration

An enumerated type listing possible ways of exporting solids in 3D views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum SolidGeometry
Public Enumeration SolidGeometry
public enum class SolidGeometry
type SolidGeometry
Members
Member name | Value | Description
Polymesh | 0 | All visible solids are exported as polymesh.
ACIS | 1 | All visible Revit Building geometry is exported as ACIS 3D solids (except for any elements that are already a polymesh.)
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SolidGeometryOptions Class

A class containing optional information to control the geometry generation of the Solid by the SolidUtils routines.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSolidGeometryOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SolidGeometryOptions : IDisposable
Public Class SolidGeometryOptions
    Implements IDisposable
public ref class SolidGeometryOptions : IDisposable
type SolidGeometryOptions =
    class
        interface IDisposable
    end

The SolidGeometryOptions type exposes the following members.

Constructors
 | Name | Description
Public method | SolidGeometryOptions | Creates a new SolidOptions class with solid tag settings.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SolidTag | Optional solid tag for the Solid.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the SolidGeometryOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SolidGeometryOptions Constructor

Creates a new SolidOptions class with solid tag settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SolidGeometryOptions(
    int solidTag
)
Public Sub New (
    solidTag As Integer
)
public:
SolidGeometryOptions(
    int solidTag
)
new :
        solidTag : int -> SolidGeometryOptions

Parameters

solidTag Int32
The material id for the Solid.
See Also

Reference

SolidGeometryOptions Class


SolidGeometryOptions Properties

The SolidGeometryOptions type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SolidTag | Optional solid tag for the Solid.
Top
See Also

Reference

SolidGeometryOptions Class


SolidGeometryOptions.IsValidObject Property

SolidGeometryOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

SolidGeometryOptions Class


SolidGeometryOptions.SolidTag Property

SolidGeometryOptionsSolidTag Property

Optional solid tag for the Solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int SolidTag { get; set; }
Public Property SolidTag As Integer
    Get
    Set
public:
property int SolidTag {
    int get ();
    void set (int value);
}
member SolidTag : int with get, set

Property Value

Int32
See Also

Reference

SolidGeometryOptions Class


SolidGeometryOptions Methods

The SolidGeometryOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SolidGeometryOptions Class


SolidGeometryOptions.Dispose Method

SolidGeometryOptionsDispose Method

Releases all resources used by the SolidGeometryOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

SolidGeometryOptions Class


SolidOptions Class

A class containing optional information to control the properties of the Solid generated by the GeometryCreationUtilities routines.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSolidOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SolidOptions : IDisposable
Public Class SolidOptions
    Implements IDisposable
public ref class SolidOptions : IDisposable
type SolidOptions =
    class
        interface IDisposable
    end

The SolidOptions type exposes the following members.

Constructors
 | Name | Description
Public method | SolidOptions | Creates a new SolidOptions class with material and graphics style settings.
Top
Properties
 | Name | Description
Public property | ExtraFaceAndEdgeHistoryKey | Optional extra key used to create face and edge histories for the Solid. If extraFaceAndEdgeHistoryKey is higher than -1, the Solid's face and edge histories will be created depending on the geometry generation of the Solid.
Public property | GraphicsStyleId | Defines the graphics style id for the Solid.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MaterialId | Defines the material id for the Solid.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the SolidOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SolidOptions Constructor

Creates a new SolidOptions class with material and graphics style settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SolidOptions(
    ElementId materialId,
    ElementId graphicsStyleId
)
Public Sub New (
    materialId As ElementId,
    graphicsStyleId As ElementId
)
public:
SolidOptions(
    ElementId^ materialId,
    ElementId^ graphicsStyleId
)
new :
        materialId : ElementId *
        graphicsStyleId : ElementId -> SolidOptions

Parameters

materialId ElementId
The material id for the Solid.
graphicsStyleId ElementId
The graphics style id for the Solid.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

SolidOptions Class


SolidOptions Properties

The SolidOptions type exposes the following members.

Properties
 | Name | Description
Public property | ExtraFaceAndEdgeHistoryKey | Optional extra key used to create face and edge histories for the Solid. If extraFaceAndEdgeHistoryKey is higher than -1, the Solid's face and edge histories will be created depending on the geometry generation of the Solid.
Public property | GraphicsStyleId | Defines the graphics style id for the Solid.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MaterialId | Defines the material id for the Solid.
Top
See Also

Reference

SolidOptions Class


SolidOptions.ExtraFaceAndEdgeHistoryKey Property

SolidOptionsExtraFaceAndEdgeHistoryKey Property

Optional extra key used to create face and edge histories for the Solid. If extraFaceAndEdgeHistoryKey is higher than -1, the Solid's face and edge histories will be created depending on the geometry generation of the Solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ExtraFaceAndEdgeHistoryKey { get; set; }
Public Property ExtraFaceAndEdgeHistoryKey As Integer
    Get
    Set
public:
property int ExtraFaceAndEdgeHistoryKey {
    int get ();
    void set (int value);
}
member ExtraFaceAndEdgeHistoryKey : int with get, set

Property Value

Int32
See Also

Reference

SolidOptions Class


SolidOptions.GraphicsStyleId Property

SolidOptionsGraphicsStyleId Property

Defines the graphics style id for the Solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GraphicsStyleId { get; set; }
Public Property GraphicsStyleId As ElementId
    Get
    Set
public:
property ElementId^ GraphicsStyleId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member GraphicsStyleId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

SolidOptions Class


SolidOptions.IsValidObject Property

SolidOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

SolidOptions Class


SolidOptions.MaterialId Property

SolidOptionsMaterialId Property

Defines the material id for the Solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId MaterialId { get; set; }
Public Property MaterialId As ElementId
    Get
    Set
public:
property ElementId^ MaterialId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member MaterialId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

SolidOptions Class


SolidOptions Methods

The SolidOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SolidOptions Class


SolidOptions.Dispose Method

SolidOptionsDispose Method

Releases all resources used by the SolidOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

SolidOptions Class


SolidOrShellTessellationControls Class

Controls various aspects of the triangulation produced by [!:SolidUtils::tessellateSolidOrShell()] method.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSolidOrShellTessellationControls

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SolidOrShellTessellationControls : IDisposable
Public Class SolidOrShellTessellationControls
    Implements IDisposable
public ref class SolidOrShellTessellationControls : IDisposable
type SolidOrShellTessellationControls =
    class
        interface IDisposable
    end

The SolidOrShellTessellationControls type exposes the following members.

Constructors
 | Name | Description
Public method | SolidOrShellTessellationControls | Default constructor.
Top
Properties
 | Name | Description
Public property | Accuracy | A positive real number specifying how accurately a triangulation should approximate a solid or shell.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LevelOfDetail | An number between 0 and 1 (inclusive) specifying the level of detail for the triangulation of a solid or shell.
Public property | MinAngleInTriangle | A non-negative real number specifying the minimum allowed angle for any triangle in the triangulation, in radians.
Public property | MinExternalAngleBetweenTriangles | A positive real number specifying the minimum allowed value for the external angle between two adjacent triangles, in radians.
Top
Methods
 | Name | Description
Public method | DisableLevelOfDetail | Disables the use of levelOfDetail. The use of levelOfDetail is enabled by calling setLevelOfDetail (with a valid input).
Public method | Dispose | Releases all resources used by the SolidOrShellTessellationControls
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UseLevelOfDetail | Returns true if the use of levelOfDetail is enabled, false if not. The use of levelOfDetail is enabled by calling setLevelOfDetail (with a valid input).
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SolidOrShellTessellationControls Constructor

Default constructor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SolidOrShellTessellationControls()
Public Sub New
public:
SolidOrShellTessellationControls()
new : unit -> SolidOrShellTessellationControls
See Also

Reference

SolidOrShellTessellationControls Class


SolidOrShellTessellationControls Properties

The SolidOrShellTessellationControls type exposes the following members.

Properties
 | Name | Description
Public property | Accuracy | A positive real number specifying how accurately a triangulation should approximate a solid or shell.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LevelOfDetail | An number between 0 and 1 (inclusive) specifying the level of detail for the triangulation of a solid or shell.
Public property | MinAngleInTriangle | A non-negative real number specifying the minimum allowed angle for any triangle in the triangulation, in radians.
Public property | MinExternalAngleBetweenTriangles | A positive real number specifying the minimum allowed value for the external angle between two adjacent triangles, in radians.
Top
See Also

Reference

SolidOrShellTessellationControls Class


SolidOrShellTessellationControls.Accuracy Property

SolidOrShellTessellationControlsAccuracy Property

A positive real number specifying how accurately a triangulation should approximate a solid or shell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Accuracy { get; set; }
Public Property Accuracy As Double
    Get
    Set
public:
property double Accuracy {
    double get ();
    void set (double value);
}
member Accuracy : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The given value for accuracy must be greater than 0 and no more than 30000 feet.
Remarks
The maximum distance from a point on the triangulation to the nearest point on the solid or shell should be no greater than the specified accuracy. This constraint may be approximately enforced.
See Also

Reference

SolidOrShellTessellationControls Class


SolidOrShellTessellationControls.IsValidObject Property

SolidOrShellTessellationControlsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

SolidOrShellTessellationControls Class


SolidOrShellTessellationControls.LevelOfDetail Property

SolidOrShellTessellationControlsLevelOfDetail Property

An number between 0 and 1 (inclusive) specifying the level of detail for the triangulation of a solid or shell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double LevelOfDetail { get; set; }
Public Property LevelOfDetail As Double
    Get
    Set
public:
property double LevelOfDetail {
    double get ();
    void set (double value);
}
member LevelOfDetail : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The given value for levelOfDetail must lie between 0 and 1 (inclusive).
Remarks
Smaller values yield coarser triangulations (fewer triangles), while larger values yield finer triangulations (more triangles).
See Also

Reference

SolidOrShellTessellationControls Class


SolidOrShellTessellationControls.MinAngleInTriangle Property

SolidOrShellTessellationControlsMinAngleInTriangle Property

A non-negative real number specifying the minimum allowed angle for any triangle in the triangulation, in radians.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double MinAngleInTriangle { get; set; }
Public Property MinAngleInTriangle As Double
    Get
    Set
public:
property double MinAngleInTriangle {
    double get ();
    void set (double value);
}
member MinAngleInTriangle : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The given value for minAngleInTriangle must be at least 0 and less than 60 degrees, expressed in radians. The value 0 means to ignore the minimum angle constraint.
Remarks
A small value can be useful when triangulating long, thin objects, in order to keep the number of triangles small, but it can result in long, thin triangles, which are not acceptable for all applications. If the value is too large, this constraint may not be satisfiable, causing the triangulation to fail. This constraint may be approximately enforced. A value of 0 means to ignore the minimum angle constraint.
See Also

Reference

SolidOrShellTessellationControls Class


SolidOrShellTessellationControls.MinExternalAngleBetweenTriangles Property

SolidOrShellTessellationControlsMinExternalAngleBetweenTriangles Property

A positive real number specifying the minimum allowed value for the external angle between two adjacent triangles, in radians.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double MinExternalAngleBetweenTriangles { get; set; }
Public Property MinExternalAngleBetweenTriangles As Double
    Get
    Set
public:
property double MinExternalAngleBetweenTriangles {
    double get ();
    void set (double value);
}
member MinExternalAngleBetweenTriangles : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The given value for minExternalAngleBetweenTriangles must be greater than 0 and no more than 30000 feet.
Remarks
A small value yields more smoothly curved triangulated surfaces, usually at the expense of an increase in the number of triangles. Note that this setting has no effect for planar surfaces. This constraint may be approximately enforced.
See Also

Reference

SolidOrShellTessellationControls Class


SolidOrShellTessellationControls Methods

The SolidOrShellTessellationControls type exposes the following members.

Methods
 | Name | Description
Public method | DisableLevelOfDetail | Disables the use of levelOfDetail. The use of levelOfDetail is enabled by calling setLevelOfDetail (with a valid input).
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UseLevelOfDetail | Returns true if the use of levelOfDetail is enabled, false if not. The use of levelOfDetail is enabled by calling setLevelOfDetail (with a valid input).
Top
See Also

Reference

SolidOrShellTessellationControls Class


SolidOrShellTessellationControls.DisableLevelOfDetail Method

SolidOrShellTessellationControlsDisableLevelOfDetail Method

Disables the use of levelOfDetail. The use of levelOfDetail is enabled by calling setLevelOfDetail (with a valid input).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void DisableLevelOfDetail()
Public Sub DisableLevelOfDetail
public:
void DisableLevelOfDetail()
member DisableLevelOfDetail : unit -> unit
See Also

Reference

SolidOrShellTessellationControls Class


SolidOrShellTessellationControls.Dispose Method

SolidOrShellTessellationControlsDispose Method

Releases all resources used by the SolidOrShellTessellationControls

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

SolidOrShellTessellationControls Class


SolidOrShellTessellationControls.UseLevelOfDetail Method

SolidOrShellTessellationControlsUseLevelOfDetail Method

Returns true if the use of levelOfDetail is enabled, false if not. The use of levelOfDetail is enabled by calling setLevelOfDetail (with a valid input).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UseLevelOfDetail()
Public Function UseLevelOfDetail As Boolean
public:
bool UseLevelOfDetail()
member UseLevelOfDetail : unit -> bool

Return Value

Boolean
See Also

Reference

SolidOrShellTessellationControls Class


SolidSolidCutUtils Class

Exposes utilities which can cause one solid to cut another.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSolidSolidCutUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class SolidSolidCutUtils
Public NotInheritable Class SolidSolidCutUtils
public ref class SolidSolidCutUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SolidSolidCutUtils = class end

The SolidSolidCutUtils type exposes the following members.

Methods
Name | Description
AddCutBetweenSolids(Document, Element, Element) | Adds a solid-solid cut for the two elements.
AddCutBetweenSolids(Document, Element, Element, Boolean) | Adds a solid-solid cut for the two elements with the option to control splitting of faces of the cutting solid.
CanElementCutElement | Verifies if the cutting element can add a solid cut to the target element.
CutExistsBetweenElements | Checks that if there is a solid-solid cut between two elements.
GetCuttingSolids | Gets all the solids which cut the input element.
GetSolidsBeingCut | Get all the solids which are cut by the input element.
IsAllowedForSolidCut | Validates that the element is eligible for a solid-solid cut.
IsElementFromAppropriateContext | Validates that the element is from an appropriate document.
RemoveCutBetweenSolids | Removes the solid-solid cut between the two elements if it exists.
SplitFacesOfCuttingSolid | Causes the faces of the cutting element where it intersects the element it is cutting to be split or unsplit.
Top
Remarks
These utilities are applicable for the generic forms, geometry combinations and family instances in conceptual model, pattern based curtain panel, or adaptive component families, and family instances which are permitted to participate in joining in projects. Thus, for example, a beam cannot cut a wall (as the wall is not a family instance) in projects. Nor can a steel beam participate in cutting another family (because steel beams do not participate in joining).
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SolidSolidCutUtils Methods

The SolidSolidCutUtils type exposes the following members.

Methods
Name | Description
AddCutBetweenSolids(Document, Element, Element) | Adds a solid-solid cut for the two elements.
AddCutBetweenSolids(Document, Element, Element, Boolean) | Adds a solid-solid cut for the two elements with the option to control splitting of faces of the cutting solid.
CanElementCutElement | Verifies if the cutting element can add a solid cut to the target element.
CutExistsBetweenElements | Checks that if there is a solid-solid cut between two elements.
GetCuttingSolids | Gets all the solids which cut the input element.
GetSolidsBeingCut | Get all the solids which are cut by the input element.
IsAllowedForSolidCut | Validates that the element is eligible for a solid-solid cut.
IsElementFromAppropriateContext | Validates that the element is from an appropriate document.
RemoveCutBetweenSolids | Removes the solid-solid cut between the two elements if it exists.
SplitFacesOfCuttingSolid | Causes the faces of the cutting element where it intersects the element it is cutting to be split or unsplit.
Top
See Also

Reference

SolidSolidCutUtils Class


SolidSolidCutUtils.AddCutBetweenSolids Method

SolidSolidCutUtilsAddCutBetweenSolids Method

Overload List
Name | Description
AddCutBetweenSolids(Document, Element, Element) | Adds a solid-solid cut for the two elements.
AddCutBetweenSolids(Document, Element, Element, Boolean) | Adds a solid-solid cut for the two elements with the option to control splitting of faces of the cutting solid.
Top
See Also

Reference

SolidSolidCutUtils Class


SolidSolidCutUtils.AddCutBetweenSolids(Document, Element, Element) Method

SolidSolidCutUtilsAddCutBetweenSolids(Document, Element, Element) Method

Adds a solid-solid cut for the two elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void AddCutBetweenSolids(
    Document document,
    Element solidToBeCut,
    Element cuttingSolid
)
Public Shared Sub AddCutBetweenSolids (
    document As Document,
    solidToBeCut As Element,
    cuttingSolid As Element
)
public:
static void AddCutBetweenSolids(
    Document^ document,
    Element^ solidToBeCut,
    Element^ cuttingSolid
)
static member AddCutBetweenSolids :
        document : Document *
        solidToBeCut : Element *
        cuttingSolid : Element -> unit

Parameters

document Document
The document containing the two elements.
solidToBeCut Element
The solid to be cut.
cuttingSolid Element
The cutting solid.
Exceptions
Exception | Condition
ArgumentException | The element must be in a project document or in a conceptual model, pattern based curtain panel, or adaptive component family. -or- The element does not meet the condition that it must be solid and must be a GenericForm, GeomCombination, or a FamilyInstance.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Failed to add solid-solid cut for the two elements.
Remarks
This utility will split faces of cutting solid by default.
See Also

Reference

SolidSolidCutUtils Class
AddCutBetweenSolids Overload


SolidSolidCutUtils.AddCutBetweenSolids(Document, Element, Element, Boolean) Method

SolidSolidCutUtilsAddCutBetweenSolids(Document, Element, Element, Boolean) Method

Adds a solid-solid cut for the two elements with the option to control splitting of faces of the cutting solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void AddCutBetweenSolids(
    Document document,
    Element solidToBeCut,
    Element cuttingSolid,
    bool splitFacesOfCuttingSolid
)
Public Shared Sub AddCutBetweenSolids (
    document As Document,
    solidToBeCut As Element,
    cuttingSolid As Element,
    splitFacesOfCuttingSolid As Boolean
)
public:
static void AddCutBetweenSolids(
    Document^ document,
    Element^ solidToBeCut,
    Element^ cuttingSolid,
    bool splitFacesOfCuttingSolid
)
static member AddCutBetweenSolids :
        document : Document *
        solidToBeCut : Element *
        cuttingSolid : Element *
        splitFacesOfCuttingSolid : bool -> unit

Parameters

document Document
The document containing the two elements.
solidToBeCut Element
The solid to be cut.
cuttingSolid Element
The cutting solid.
splitFacesOfCuttingSolid Boolean
True to split faces of cutting solid where it intersects the solid to be cut, false otherwise.
Exceptions
Exception | Condition
ArgumentException | The element must be in a project document or in a conceptual model, pattern based curtain panel, or adaptive component family. -or- The element does not meet the condition that it must be solid and must be a GenericForm, GeomCombination, or a FamilyInstance.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Failed to add solid-solid cut for the two elements.
See Also

Reference

SolidSolidCutUtils Class
AddCutBetweenSolids Overload


SolidSolidCutUtils.CanElementCutElement Method

SolidSolidCutUtilsCanElementCutElement Method

Verifies if the cutting element can add a solid cut to the target element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CanElementCutElement(
    Element cuttingElement,
    Element cutElement,
    out CutFailureReason reason
)
Public Shared Function CanElementCutElement (
    cuttingElement As Element,
    cutElement As Element,
    <OutAttribute> ByRef reason As CutFailureReason
) As Boolean
public:
static bool CanElementCutElement(
    Element^ cuttingElement,
    Element^ cutElement,
    [OutAttribute] CutFailureReason% reason
)
static member CanElementCutElement :
        cuttingElement : Element *
        cutElement : Element *
        reason : CutFailureReason byref -> bool

Parameters

cuttingElement Element
The cutting element.
cutElement Element
The element to be cut.
reason CutFailureReason
The reason that the cutting element cannot add a solid cut to the cut element.

Return Value

Boolean
True if the cutting element can add a solid cut to the target element, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

SolidSolidCutUtils Class


SolidSolidCutUtils.CutExistsBetweenElements Method

SolidSolidCutUtilsCutExistsBetweenElements Method

Checks that if there is a solid-solid cut between two elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CutExistsBetweenElements(
    Element first,
    Element second,
    out bool firstCutsSecond
)
Public Shared Function CutExistsBetweenElements (
    first As Element,
    second As Element,
    <OutAttribute> ByRef firstCutsSecond As Boolean
) As Boolean
public:
static bool CutExistsBetweenElements(
    Element^ first,
    Element^ second,
    [OutAttribute] bool% firstCutsSecond
)
static member CutExistsBetweenElements :
        first : Element *
        second : Element *
        firstCutsSecond : bool byref -> bool

Parameters

first Element
The solid being cut or the cutting solid.
second Element
The solid being cut or the cutting solid.
firstCutsSecond Boolean
If the return value of this function is true, this indicates which element is the cutting element from the pair. True if the first solid cuts the second one, false if the second solid cuts the first one.

Return Value

Boolean
True if there is a solid-solid cut between the input elements, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

SolidSolidCutUtils Class


SolidSolidCutUtils.GetCuttingSolids Method

SolidSolidCutUtilsGetCuttingSolids Method

Gets all the solids which cut the input element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ICollection<ElementId> GetCuttingSolids(
    Element element
)
Public Shared Function GetCuttingSolids (
    element As Element
) As ICollection(Of ElementId)
public:
static ICollection<ElementId^>^ GetCuttingSolids(
    Element^ element
)
static member GetCuttingSolids :
        element : Element -> ICollection<ElementId>

Parameters

element Element
The input element.

Return Value

ICollection ElementId
The ids of the solids which cut the input element.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

SolidSolidCutUtils Class


SolidSolidCutUtils.GetSolidsBeingCut Method

SolidSolidCutUtilsGetSolidsBeingCut Method

Get all the solids which are cut by the input element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ICollection<ElementId> GetSolidsBeingCut(
    Element element
)
Public Shared Function GetSolidsBeingCut (
    element As Element
) As ICollection(Of ElementId)
public:
static ICollection<ElementId^>^ GetSolidsBeingCut(
    Element^ element
)
static member GetSolidsBeingCut :
        element : Element -> ICollection<ElementId>

Parameters

element Element
The input element.

Return Value

ICollection ElementId
The ids of the solids which are cut by the input element.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

SolidSolidCutUtils Class


SolidSolidCutUtils.IsAllowedForSolidCut Method

SolidSolidCutUtilsIsAllowedForSolidCut Method

Validates that the element is eligible for a solid-solid cut.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsAllowedForSolidCut(
    Element element
)
Public Shared Function IsAllowedForSolidCut (
    element As Element
) As Boolean
public:
static bool IsAllowedForSolidCut(
    Element^ element
)
static member IsAllowedForSolidCut :
        element : Element -> bool

Parameters

element Element
The solid to be cut or the cutting solid.

Return Value

Boolean
True if the input element can participate in a solid-solid cut. False otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
The element must be solid and must be a GenericForm, GeomCombination, or a FamilyInstance.
See Also

Reference

SolidSolidCutUtils Class


SolidSolidCutUtils.IsElementFromAppropriateContext Method

SolidSolidCutUtilsIsElementFromAppropriateContext Method

Validates that the element is from an appropriate document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsElementFromAppropriateContext(
    Element element
)
Public Shared Function IsElementFromAppropriateContext (
    element As Element
) As Boolean
public:
static bool IsElementFromAppropriateContext(
    Element^ element
)
static member IsElementFromAppropriateContext :
        element : Element -> bool

Parameters

element Element
The solid to be cut or the cutting solid.

Return Value

Boolean
True if the element is from an appropriate document for solid-solid cuts, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Currently an element from either a project document, conceptual model, pattern based curtain panel, or adaptive component family may participate in solid-solid cuts.
See Also

Reference

SolidSolidCutUtils Class


SolidSolidCutUtils.RemoveCutBetweenSolids Method

SolidSolidCutUtilsRemoveCutBetweenSolids Method

Removes the solid-solid cut between the two elements if it exists.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void RemoveCutBetweenSolids(
    Document document,
    Element first,
    Element second
)
Public Shared Sub RemoveCutBetweenSolids (
    document As Document,
    first As Element,
    second As Element
)
public:
static void RemoveCutBetweenSolids(
    Document^ document,
    Element^ first,
    Element^ second
)
static member RemoveCutBetweenSolids :
        document : Document *
        first : Element *
        second : Element -> unit

Parameters

document Document
The document containing the two elements
first Element
The solid being cut or the cutting solid.
second Element
The solid being cut or the cutting solid.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

SolidSolidCutUtils Class


SolidSolidCutUtils.SplitFacesOfCuttingSolid Method

SolidSolidCutUtilsSplitFacesOfCuttingSolid Method

Causes the faces of the cutting element where it intersects the element it is cutting to be split or unsplit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void SplitFacesOfCuttingSolid(
    Element first,
    Element second,
    bool split
)
Public Shared Sub SplitFacesOfCuttingSolid (
    first As Element,
    second As Element,
    split As Boolean
)
public:
static void SplitFacesOfCuttingSolid(
    Element^ first,
    Element^ second,
    bool split
)
static member SplitFacesOfCuttingSolid :
        first : Element *
        second : Element *
        split : bool -> unit

Parameters

first Element
The solid being cut or the cutting solid
second Element
The solid being cut or the cutting solid
split Boolean
True to split the faces of intersection, false to unsplit them.
Exceptions
Exception | Condition
ArgumentException | There is no solid-solid cut between the input elements.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Unable to split or unsplit faces of cutting solid
Remarks
There must be a cut between the input elements.
See Also

Reference

SolidSolidCutUtils Class


SolidUtils Class

Contains utility functions for solid operations.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSolidUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class SolidUtils
Public NotInheritable Class SolidUtils
public ref class SolidUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SolidUtils = class end

The SolidUtils type exposes the following members.

Methods
Name | Description
Clone | Creates a new Solid which is a copy of the input Solid.
CreateTransformed | Creates a new Solid which is the transformation of the input Solid.
FindAllEdgeEndPointsAtVertex | Find all EdgeEndPoints at a vertex identified by the input EdgeEndPoint.
IsValidForTessellation | Tests if the input solid or shell is valid for tessellation.
SplitVolumes | Splits a solid geometry into several separate solids.
TessellateSolidOrShell | This function facets (i.e., triangulates) a solid or an open shell. Each boundary component of the solid or shell is represented by a single triangulated structure.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SolidUtils Methods

The SolidUtils type exposes the following members.

Methods
Name | Description
Clone | Creates a new Solid which is a copy of the input Solid.
CreateTransformed | Creates a new Solid which is the transformation of the input Solid.
FindAllEdgeEndPointsAtVertex | Find all EdgeEndPoints at a vertex identified by the input EdgeEndPoint.
IsValidForTessellation | Tests if the input solid or shell is valid for tessellation.
SplitVolumes | Splits a solid geometry into several separate solids.
TessellateSolidOrShell | This function facets (i.e., triangulates) a solid or an open shell. Each boundary component of the solid or shell is represented by a single triangulated structure.
Top
See Also

Reference

SolidUtils Class


SolidUtils.Clone Method

SolidUtilsClone Method

Creates a new Solid which is a copy of the input Solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Solid Clone(
    Solid solid
)
Public Shared Function Clone (
    solid As Solid
) As Solid
public:
static Solid^ Clone(
    Solid^ solid
)
static member Clone :
        solid : Solid -> Solid

Parameters

solid Solid
The input solid to be copied.

Return Value

Solid
The newly created Solid.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

SolidUtils Class


SolidUtils.CreateTransformed Method

SolidUtilsCreateTransformed Method

Creates a new Solid which is the transformation of the input Solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Solid CreateTransformed(
    Solid solid,
    Transform transform
)
Public Shared Function CreateTransformed (
    solid As Solid,
    transform As Transform
) As Solid
public:
static Solid^ CreateTransformed(
    Solid^ solid,
    Transform^ transform
)
static member CreateTransformed :
        solid : Solid *
        transform : Transform -> Solid

Parameters

solid Solid
The input solid to be transformed.
transform Transform
The transform (which must be conformal).

Return Value

Solid
The newly created Solid.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | transform is not conformal. -or- transform has a scale that is negative or zero.
See Also

Reference

SolidUtils Class


SolidUtils.FindAllEdgeEndPointsAtVertex Method

SolidUtilsFindAllEdgeEndPointsAtVertex Method

Find all EdgeEndPoints at a vertex identified by the input EdgeEndPoint.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<EdgeEndPoint> FindAllEdgeEndPointsAtVertex(
    EdgeEndPoint edgeEndPoint
)
Public Shared Function FindAllEdgeEndPointsAtVertex (
    edgeEndPoint As EdgeEndPoint
) As IList(Of EdgeEndPoint)
public:
static IList<EdgeEndPoint^>^ FindAllEdgeEndPointsAtVertex(
    EdgeEndPoint^ edgeEndPoint
)
static member FindAllEdgeEndPointsAtVertex :
        edgeEndPoint : EdgeEndPoint -> IList<EdgeEndPoint>

Parameters

edgeEndPoint EdgeEndPoint
The input EdgeEndPoint that identifies the vertex.

Return Value

IList EdgeEndPoint
All EdgeEndPoints at the vertex. The input EdgeEndPoint is also included.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Failed to find all EdgeEndPoints at a vertex identified by the input EdgeEndPoint.
See Also

Reference

SolidUtils Class


SolidUtils.IsValidForTessellation Method

SolidUtilsIsValidForTessellation Method

Tests if the input solid or shell is valid for tessellation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidForTessellation(
    Solid solidOrShell
)
Public Shared Function IsValidForTessellation (
    solidOrShell As Solid
) As Boolean
public:
static bool IsValidForTessellation(
    Solid^ solidOrShell
)
static member IsValidForTessellation :
        solidOrShell : Solid -> bool

Parameters

solidOrShell Solid
The solid or shell.

Return Value

Boolean
True if the solid or shell is valid for tessellation, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

SolidUtils Class


SolidUtils.SplitVolumes Method

SolidUtilsSplitVolumes Method

Splits a solid geometry into several separate solids.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<Solid> SplitVolumes(
    Solid solid
)
Public Shared Function SplitVolumes (
    solid As Solid
) As IList(Of Solid)
public:
static IList<Solid^>^ SplitVolumes(
    Solid^ solid
)
static member SplitVolumes :
        solid : Solid -> IList<Solid>

Parameters

solid Solid
The solid.

Return Value

IList Solid
The split solid geometries.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Failed to split the solid geometry.
Remarks
If no splitting is done, a copy of the input solid will be returned in the output array.
See Also

Reference

SolidUtils Class


SolidUtils.TessellateSolidOrShell Method

SolidUtilsTessellateSolidOrShell Method

This function facets (i.e., triangulates) a solid or an open shell. Each boundary component of the solid or shell is represented by a single triangulated structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static TriangulatedSolidOrShell TessellateSolidOrShell(
    Solid solidOrShell,
    SolidOrShellTessellationControls tessellationControls
)
Public Shared Function TessellateSolidOrShell (
    solidOrShell As Solid,
    tessellationControls As SolidOrShellTessellationControls
) As TriangulatedSolidOrShell
public:
static TriangulatedSolidOrShell^ TessellateSolidOrShell(
    Solid^ solidOrShell,
    SolidOrShellTessellationControls^ tessellationControls
)
static member TessellateSolidOrShell :
        solidOrShell : Solid *
        tessellationControls : SolidOrShellTessellationControls -> TriangulatedSolidOrShell

Parameters

solidOrShell Solid
The solid or shell to be faceted.
tessellationControls SolidOrShellTessellationControls
This input controls various aspects of the triangulation.

Return Value

TriangulatedSolidOrShell
The triangulated structures corresponding to the boundary components of the input solid or the components of the input shell.
Exceptions
Exception | Condition
ArgumentException | solidOrShell is not valid for triangulation (for example, it contains no faces).
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Unable to triangulate the solid or shell.
Remarks
Every point on the triangulation of a boundary component of the solid (or shell) should lie within the 3D distance specified by the "accuracy" input of some point on the triangulation, and vice-versa. In some cases, this constraint may be implemented heuristically (not rigorously).
See Also

Reference

SolidUtils Class


SortingOrder Enumeration

Enumerated type representing the sorting order of a collection of objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum SortingOrder
Public Enumeration SortingOrder
public enum class SortingOrder
type SortingOrder
Members
Member name | Value | Description
Ascending | 1 | Ascending sorting order
Descending | 2 | Descending sorting order
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SpacingRule Class

A rule for specifying a set of equidistant, parallel gridlines within a region.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBSpacingRule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SpacingRule : APIObject
Public Class SpacingRule
    Inherits APIObject
public ref class SpacingRule : public APIObject
type SpacingRule =
    class
        inherit APIObject
    end

The SpacingRule type exposes the following members.

Properties
 | Name | Description
Public property | BeltMeasurement | On a curved surface, BeltMeasurement specifies where the grid's distances are measured.
Public property | Distance | The exact distance between layout lines.
Public property | GridlinesRotation | An additional rotation to be applied to this set of grid lines.
Public property | HasBeltMeasurement | True if the gridlines are not parallel due to surface curvature, and the BeltMeasurement property therefore applies.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Justification | The justification of the lines within the region.
Public property | Layout | A choice of several gridline layout rules.
Public property | Number | The exact number of lines in the region.
Public property | Offset | An additional offset applied to the first gridline.
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetLayoutFixedDistance | Set the Layout property to FixedDistance.
Public method | SetLayoutFixedNumber | Set the Layout property to FixedNumber.
Public method | SetLayoutMaximumSpacing | Set the Layout property to MaximumSpacing.
Public method | SetLayoutMinimumSpacing | Set the Layout property to MinimumSpacing.
Public method | SetLayoutNone | Set the Layout property to None.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SpacingRule Properties

The SpacingRule type exposes the following members.

Properties
 | Name | Description
Public property | BeltMeasurement | On a curved surface, BeltMeasurement specifies where the grid's distances are measured.
Public property | Distance | The exact distance between layout lines.
Public property | GridlinesRotation | An additional rotation to be applied to this set of grid lines.
Public property | HasBeltMeasurement | True if the gridlines are not parallel due to surface curvature, and the BeltMeasurement property therefore applies.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Justification | The justification of the lines within the region.
Public property | Layout | A choice of several gridline layout rules.
Public property | Number | The exact number of lines in the region.
Public property | Offset | An additional offset applied to the first gridline.
Top
See Also

Reference

SpacingRule Class


SpacingRule.BeltMeasurement Property

SpacingRuleBeltMeasurement Property

On a curved surface, BeltMeasurement specifies where the grid's distances are measured.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double BeltMeasurement { get; set; }
Public Property BeltMeasurement As Double
    Get
    Set
public:
property double BeltMeasurement {
    double get ();
    void set (double value);
}
member BeltMeasurement : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown when beltMeasurement is outside the range [ 0.0, 1.0 ].
InvalidOperationException | Thrown when the gridlines are guaranteed to be parallel; check the HasBeltMeasurement property before using this property.
Remarks
On a conical surface, the distance between the radial gridlines is not constant. To interpret the Distance property, a circumferential gridline is taken as the "belt." Distance is then measured along the belt. The BeltMeasurement property gives the location of the belt relative to the extremes of the surface. The belt is used whenever gridlines are not parallel. It defaults to 0.5.
See Also

Reference

SpacingRule Class


SpacingRule.Distance Property

SpacingRuleDistance Property

The exact distance between layout lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Distance { get; set; }
Public Property Distance As Double
    Get
    Set
public:
property double Distance {
    double get ();
    void set (double value);
}
member Distance : float with get, set

Property Value

Double
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the Layout property is None or FixedNumber.
Remarks
This property is only available when Layout is equal to FixedDistance, MaximumSpacing, or MinimumSpacing. Must be a positive value less than 30000'.
See Also

Reference

SpacingRule Class


SpacingRule.GridlinesRotation Property

SpacingRuleGridlinesRotation Property

An additional rotation to be applied to this set of grid lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GridlinesRotation { get; set; }
Public Property GridlinesRotation As Double
    Get
    Set
public:
property double GridlinesRotation {
    double get ();
    void set (double value);
}
member GridlinesRotation : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown when angle is outside of the range ( -PI/2, PI/2 ).
See Also

Reference

SpacingRule Class


SpacingRule.HasBeltMeasurement Property

SpacingRuleHasBeltMeasurement Property

True if the gridlines are not parallel due to surface curvature, and the BeltMeasurement property therefore applies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasBeltMeasurement { get; }
Public ReadOnly Property HasBeltMeasurement As Boolean
    Get
public:
property bool HasBeltMeasurement {
    bool get ();
}
member HasBeltMeasurement : bool with get

Property Value

Boolean
See Also

Reference

SpacingRule Class


SpacingRule.Justification Property

SpacingRuleJustification Property

The justification of the lines within the region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SpacingRuleJustification Justification { get; set; }
Public Property Justification As SpacingRuleJustification
    Get
    Set
public:
property SpacingRuleJustification Justification {
    SpacingRuleJustification get ();
    void set (SpacingRuleJustification value);
}
member Justification : SpacingRuleJustification with get, set

Property Value

SpacingRuleJustification
Remarks
This property is only available when Layout is equal to FixedDistance, FixedNumber, MaximumSpacing, or MinimumSpacing.
See Also

Reference

SpacingRule Class


SpacingRule.Layout Property

SpacingRuleLayout Property

A choice of several gridline layout rules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SpacingRuleLayout Layout { get; }
Public ReadOnly Property Layout As SpacingRuleLayout
    Get
public:
property SpacingRuleLayout Layout {
    SpacingRuleLayout get ();
}
member Layout : SpacingRuleLayout with get

Property Value

SpacingRuleLayout
Remarks
If "None" is chosen, no internal lines will be generated, but the effect is equivalent to having two lines, one at each end of the region.
See Also

Reference

SpacingRule Class


SpacingRule.Number Property

SpacingRuleNumber Property

The exact number of lines in the region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Number { get; set; }
Public Property Number As Integer
    Get
    Set
public:
property int Number {
    int get ();
    void set (int value);
}
member Number : int with get, set

Property Value

Int32
Remarks
This property is only available when Layout is equal to FixedNumber. Lines will be placed exactly at the boundaries if possible, so if your region is 100' long and you specify Number = 11, your lines will be 10' apart. Must be between 1 and 200.
See Also

Reference

SpacingRule Class


SpacingRule.Offset Property

SpacingRuleOffset Property

An additional offset applied to the first gridline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Offset { get; set; }
Public Property Offset As Double
    Get
    Set
public:
property double Offset {
    double get ();
    void set (double value);
}
member Offset : float with get, set

Property Value

Double
Remarks
Measured in feet. Must be between -30000' and 30000'.
See Also

Reference

SpacingRule Class


SpacingRule Methods

The SpacingRule type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetLayoutFixedDistance | Set the Layout property to FixedDistance.
Public method | SetLayoutFixedNumber | Set the Layout property to FixedNumber.
Public method | SetLayoutMaximumSpacing | Set the Layout property to MaximumSpacing.
Public method | SetLayoutMinimumSpacing | Set the Layout property to MinimumSpacing.
Public method | SetLayoutNone | Set the Layout property to None.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SpacingRule Class


SpacingRule.SetLayoutFixedDistance Method

SpacingRuleSetLayoutFixedDistance Method

Set the Layout property to FixedDistance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetLayoutFixedDistance(
    double distance,
    SpacingRuleJustification just,
    double gridlinesRotation,
    double offset
)
Public Sub SetLayoutFixedDistance (
    distance As Double,
    just As SpacingRuleJustification,
    gridlinesRotation As Double,
    offset As Double
)
public:
void SetLayoutFixedDistance(
    double distance,
    SpacingRuleJustification just,
    double gridlinesRotation,
    double offset
)
member SetLayoutFixedDistance :
        distance : float *
        just : SpacingRuleJustification *
        gridlinesRotation : float *
        offset : float -> unit

Parameters

distance Double
just SpacingRuleJustification
gridlinesRotation Double
offset Double
Remarks
When changing the Layout to FixedDistance, you must also simultaneously set the Distance, Justification, GridlinesRotation, and Offset properties.
See Also

Reference

SpacingRule Class


SpacingRule.SetLayoutFixedNumber Method

SpacingRuleSetLayoutFixedNumber Method

Set the Layout property to FixedNumber.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetLayoutFixedNumber(
    int number,
    SpacingRuleJustification just,
    double gridlinesRotation,
    double offset
)
Public Sub SetLayoutFixedNumber (
    number As Integer,
    just As SpacingRuleJustification,
    gridlinesRotation As Double,
    offset As Double
)
public:
void SetLayoutFixedNumber(
    int number,
    SpacingRuleJustification just,
    double gridlinesRotation,
    double offset
)
member SetLayoutFixedNumber :
        number : int *
        just : SpacingRuleJustification *
        gridlinesRotation : float *
        offset : float -> unit

Parameters

number Int32
just SpacingRuleJustification
gridlinesRotation Double
offset Double
Remarks
When changing the Layout to FixedNumber, you must also simultaneously set the Number, Justification, GridlinesRotation, and Offset properties.
See Also

Reference

SpacingRule Class


SpacingRule.SetLayoutMaximumSpacing Method

SpacingRuleSetLayoutMaximumSpacing Method

Set the Layout property to MaximumSpacing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetLayoutMaximumSpacing(
    double distance,
    SpacingRuleJustification just,
    double gridlinesRotation,
    double offset
)
Public Sub SetLayoutMaximumSpacing (
    distance As Double,
    just As SpacingRuleJustification,
    gridlinesRotation As Double,
    offset As Double
)
public:
void SetLayoutMaximumSpacing(
    double distance,
    SpacingRuleJustification just,
    double gridlinesRotation,
    double offset
)
member SetLayoutMaximumSpacing :
        distance : float *
        just : SpacingRuleJustification *
        gridlinesRotation : float *
        offset : float -> unit

Parameters

distance Double
just SpacingRuleJustification
gridlinesRotation Double
offset Double
Remarks
When changing the Layout to MaximumSpacing, you must also simultaneously set the Distance, Justification, GridlinesRotation, and Offset properties.
See Also

Reference

SpacingRule Class


SpacingRule.SetLayoutMinimumSpacing Method

SpacingRuleSetLayoutMinimumSpacing Method

Set the Layout property to MinimumSpacing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetLayoutMinimumSpacing(
    double distance,
    SpacingRuleJustification just,
    double gridlinesRotation,
    double offset
)
Public Sub SetLayoutMinimumSpacing (
    distance As Double,
    just As SpacingRuleJustification,
    gridlinesRotation As Double,
    offset As Double
)
public:
void SetLayoutMinimumSpacing(
    double distance,
    SpacingRuleJustification just,
    double gridlinesRotation,
    double offset
)
member SetLayoutMinimumSpacing :
        distance : float *
        just : SpacingRuleJustification *
        gridlinesRotation : float *
        offset : float -> unit

Parameters

distance Double
just SpacingRuleJustification
gridlinesRotation Double
offset Double
Remarks
When changing the Layout to MinimumSpacing, you must also simultaneously set the Distance, Justification, GridlinesRotation, and Offset properties.
See Also

Reference

SpacingRule Class


SpacingRule.SetLayoutNone Method

SpacingRuleSetLayoutNone Method

Set the Layout property to None.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetLayoutNone()
Public Sub SetLayoutNone
public:
void SetLayoutNone()
member SetLayoutNone : unit -> unit
Remarks
No internal lines will be generated, but the effect is equivalent to having two lines, one at each end of the region.
See Also

Reference

SpacingRule Class


SpacingRuleJustification Enumeration

Justification property of spacing rule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum SpacingRuleJustification
Public Enumeration SpacingRuleJustification
public enum class SpacingRuleJustification
type SpacingRuleJustification
Members
Member name | Value | Description
Center | 2 |
Beginning | 4 |
End | 5 |
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SpacingRuleLayout Enumeration

Rules for laying out a series of equidistant points or parallel lines

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum SpacingRuleLayout
Public Enumeration SpacingRuleLayout
public enum class SpacingRuleLayout
type SpacingRuleLayout
Members
Member name | Value | Description
None | 0 | No points or lines will be created.
FixedDistance | 1 | Points or lines are separated by a fixed distance.
FixedNumber | 2 | Fixed number of points or lines with uniform distance between them.
MaximumSpacing | 3 | Points or lines are separated by at most the max distance.
MinimumSpacing | 5 | Points or lines are separated by at least the minimum distance.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SpanDirectionSymbol Class

Represents an instance of a Span Direction Symbol in Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBIndependentTag
Autodesk.Revit.DBSpanDirectionSymbol

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SpanDirectionSymbol : IndependentTag
Public Class SpanDirectionSymbol
    Inherits IndependentTag
public ref class SpanDirectionSymbol : public IndependentTag
type SpanDirectionSymbol =
    class
        inherit IndependentTag
    end

The SpanDirectionSymbol type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HasLeader | Identifies if a tag has at least one visible leader, or if all leaders are hidden. (Inherited from IndependentTag)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsMaterialTag | Identifies if it is a material tag or not. (Inherited from IndependentTag)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsMulticategoryTag | Identifies if it is a multi-category tag or not. (Inherited from IndependentTag)
Public property | IsOrphaned | Identifies if the tag is orphaned or not. (Inherited from IndependentTag)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LeaderEndCondition | The leader end condition of the tag, such as if the end of the leader is attached to the host or free floating. (Inherited from IndependentTag)
Public property | LeadersPresentationMode | Identifies the Presentation Mode that is applied to tag leaders. (Inherited from IndependentTag)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | MergeElbows | Identifies if the leaders' elbows are merged or not. If they are are merged, all elbows are in the same point and they move together. (Inherited from IndependentTag)
Public property | MultiLeader | Returns if the tag if referencing multiple elements and/or sub-elements. (Inherited from IndependentTag)
Public property | MultiReferenceAnnotationId | The multi-reference annotation which owns this tag. (Inherited from IndependentTag)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | RotationAngle | The rotation angle of the tag relative to its view (Inherited from IndependentTag)
Public property | TagHeadPosition | The position of the head of tag in model coordinates. (Inherited from IndependentTag)
Public property | TagOrientation | The tag orientation of the tag's head, such as horizontal or vertical. (Inherited from IndependentTag)
Public property | TagText | The text associated with the tag. If there are several strings assiciated with the tag, the strings will be returned concatenated. (Inherited from IndependentTag)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | AddReferences | Adds the provided list of references to the tag's list of references. (Inherited from IndependentTag)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | CanLeaderEndConditionBeAssigned | Checks whether the LeaderEndCondition can be changed. (Inherited from IndependentTag)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Places a new instance of the Span Direction Symbol into the project relative to a particular host element and view.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
 | GetDefaultPlacementPoint | Gets the default placement point for the input element. The default position is in the middle of the bounding box of the top face.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLeaderElbow | Returns the position of the elbow of the tag's leader that points to specified reference. Position of leader's elbow. (Inherited from IndependentTag)
Public method | GetLeaderEnd | Returns the end position of the tag's leader that points to specified reference. (Inherited from IndependentTag)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTaggedElementIds | Returns a set of LinkElementId for all tagged elements, if any. A LinkElementId will be provided for each subelement that is being referenced by the tag. (Inherited from IndependentTag)
Public method | GetTaggedLocalElementIds | Returns a set of IDs for all tagged local elements, if any. A local element ID will be provided for each subelement that is being referenced by the tag. Set of all the element ids in the local file. For each subelement a local element id will be provided. (Inherited from IndependentTag)
Public method | GetTaggedLocalElements | Get the tagged local elements, if any. An Element will be provided for each subelement that is being referenced by the tag. (Inherited from IndependentTag)
Public method | GetTaggedReferences | Get the host references of the tag. An array of all the tagged references. (Inherited from IndependentTag)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasLeaderElbow | Whether the tag's leader that points to the reference has an elbow point or not. (Inherited from IndependentTag)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasTagBehavior | Checks if the IndependentTag has a tag behavior. (Inherited from IndependentTag)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsLeaderVisible | Returns if leader that points to specified reference is visible or not. (Inherited from IndependentTag)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsTaggedOnSubelement | Returns true if the any of the tagged references is a subelement. (Inherited from IndependentTag)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveReferences | Removes the provided list of references from the tag's list of references. (Inherited from IndependentTag)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetIsLeaderVisible | Set tag's leader that points to specified reference to be visible or not. This option can be set only if the LeadersPresentationMode is ShowSpecificLeaders. (Inherited from IndependentTag)
Public method | SetLeaderElbow | Set the position of the elbow of the tag's leader that points to specified reference. If this tag is a multileader tag and the elbows are merged, the input position will be set to all leaders. (Inherited from IndependentTag)
Public method | SetLeaderEnd | Set the end position of the tag's leader that points to specified reference. (Inherited from IndependentTag)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SpanDirectionSymbol Properties

The SpanDirectionSymbol type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HasLeader | Identifies if a tag has at least one visible leader, or if all leaders are hidden. (Inherited from IndependentTag)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsMaterialTag | Identifies if it is a material tag or not. (Inherited from IndependentTag)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsMulticategoryTag | Identifies if it is a multi-category tag or not. (Inherited from IndependentTag)
Public property | IsOrphaned | Identifies if the tag is orphaned or not. (Inherited from IndependentTag)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LeaderEndCondition | The leader end condition of the tag, such as if the end of the leader is attached to the host or free floating. (Inherited from IndependentTag)
Public property | LeadersPresentationMode | Identifies the Presentation Mode that is applied to tag leaders. (Inherited from IndependentTag)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | MergeElbows | Identifies if the leaders' elbows are merged or not. If they are are merged, all elbows are in the same point and they move together. (Inherited from IndependentTag)
Public property | MultiLeader | Returns if the tag if referencing multiple elements and/or sub-elements. (Inherited from IndependentTag)
Public property | MultiReferenceAnnotationId | The multi-reference annotation which owns this tag. (Inherited from IndependentTag)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | RotationAngle | The rotation angle of the tag relative to its view (Inherited from IndependentTag)
Public property | TagHeadPosition | The position of the head of tag in model coordinates. (Inherited from IndependentTag)
Public property | TagOrientation | The tag orientation of the tag's head, such as horizontal or vertical. (Inherited from IndependentTag)
Public property | TagText | The text associated with the tag. If there are several strings assiciated with the tag, the strings will be returned concatenated. (Inherited from IndependentTag)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

SpanDirectionSymbol Class


SpanDirectionSymbol Methods

The SpanDirectionSymbol type exposes the following members.

Methods
 | Name | Description
Public method | AddReferences | Adds the provided list of references to the tag's list of references. (Inherited from IndependentTag)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | CanLeaderEndConditionBeAssigned | Checks whether the LeaderEndCondition can be changed. (Inherited from IndependentTag)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Places a new instance of the Span Direction Symbol into the project relative to a particular host element and view.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
 | GetDefaultPlacementPoint | Gets the default placement point for the input element. The default position is in the middle of the bounding box of the top face.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLeaderElbow | Returns the position of the elbow of the tag's leader that points to specified reference. Position of leader's elbow. (Inherited from IndependentTag)
Public method | GetLeaderEnd | Returns the end position of the tag's leader that points to specified reference. (Inherited from IndependentTag)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTaggedElementIds | Returns a set of LinkElementId for all tagged elements, if any. A LinkElementId will be provided for each subelement that is being referenced by the tag. (Inherited from IndependentTag)
Public method | GetTaggedLocalElementIds | Returns a set of IDs for all tagged local elements, if any. A local element ID will be provided for each subelement that is being referenced by the tag. Set of all the element ids in the local file. For each subelement a local element id will be provided. (Inherited from IndependentTag)
Public method | GetTaggedLocalElements | Get the tagged local elements, if any. An Element will be provided for each subelement that is being referenced by the tag. (Inherited from IndependentTag)
Public method | GetTaggedReferences | Get the host references of the tag. An array of all the tagged references. (Inherited from IndependentTag)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasLeaderElbow | Whether the tag's leader that points to the reference has an elbow point or not. (Inherited from IndependentTag)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasTagBehavior | Checks if the IndependentTag has a tag behavior. (Inherited from IndependentTag)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsLeaderVisible | Returns if leader that points to specified reference is visible or not. (Inherited from IndependentTag)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsTaggedOnSubelement | Returns true if the any of the tagged references is a subelement. (Inherited from IndependentTag)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveReferences | Removes the provided list of references from the tag's list of references. (Inherited from IndependentTag)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetIsLeaderVisible | Set tag's leader that points to specified reference to be visible or not. This option can be set only if the LeadersPresentationMode is ShowSpecificLeaders. (Inherited from IndependentTag)
Public method | SetLeaderElbow | Set the position of the elbow of the tag's leader that points to specified reference. If this tag is a multileader tag and the elbows are merged, the input position will be set to all leaders. (Inherited from IndependentTag)
Public method | SetLeaderEnd | Set the end position of the tag's leader that points to specified reference. (Inherited from IndependentTag)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SpanDirectionSymbol Class


SpanDirectionSymbol.Create Method

SpanDirectionSymbolCreate Method

Places a new instance of the Span Direction Symbol into the project relative to a particular host element and view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SpanDirectionSymbol Create(
    Document document,
    ElementId viewId,
    LinkElementId elemIdToTag,
    XYZ headPosistion,
    ElementId symbolId
)
Public Shared Function Create (
    document As Document,
    viewId As ElementId,
    elemIdToTag As LinkElementId,
    headPosistion As XYZ,
    symbolId As ElementId
) As SpanDirectionSymbol
public:
static SpanDirectionSymbol^ Create(
    Document^ document,
    ElementId^ viewId,
    LinkElementId^ elemIdToTag,
    XYZ^ headPosistion,
    ElementId^ symbolId
)
static member Create :
        document : Document *
        viewId : ElementId *
        elemIdToTag : LinkElementId *
        headPosistion : XYZ *
        symbolId : ElementId -> SpanDirectionSymbol

Parameters

document Document
The document.
viewId ElementId
The id of the view in which the symbol should appear.
elemIdToTag LinkElementId
The ElementId of a Floor (either in the document or linked from another document).
headPosistion XYZ
The span symbol's head position.
symbolId ElementId
The id of the family symbol of this span symbol.

Return Value

SpanDirectionSymbol
Returns the newly created symbol.
Exceptions
Exception | Condition
ArgumentException | The specified viewId should represent a Plan View. -or- The specified elemIdToTag should represent a Floor element. -or- The specified symbolId isn't valid. It should be a FamilySymbol of OST_SpanDirectionSymbol category.
ArgumentNullException | A non-optional argument was null
See Also

Reference

SpanDirectionSymbol Class


SpanDirectionSymbol.GetDefaultPlacementPoint Method

SpanDirectionSymbolGetDefaultPlacementPoint Method

Gets the default placement point for the input element. The default position is in the middle of the bounding box of the top face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static XYZ GetDefaultPlacementPoint(
    Document document,
    LinkElementId elemIdToTag
)
Public Shared Function GetDefaultPlacementPoint (
    document As Document,
    elemIdToTag As LinkElementId
) As XYZ
public:
static XYZ^ GetDefaultPlacementPoint(
    Document^ document,
    LinkElementId^ elemIdToTag
)
static member GetDefaultPlacementPoint :
        document : Document *
        elemIdToTag : LinkElementId -> XYZ

Parameters

document Document
The document.
elemIdToTag LinkElementId
The ElementId of a Floor (either in the document or linked from another document).

Return Value

XYZ
Returns the default placement point for the input element. The default position is in the middle of the bounding box of the top face.
Exceptions
Exception | Condition
ArgumentException | The specified elemIdToTag should represent a Floor element.
ArgumentNullException | A non-optional argument was null
See Also

Reference

SpanDirectionSymbol Class


SpatialElement Class

Represents an enclosed area or volume in the Revit model.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBSpatialElement
Autodesk.Revit.DB.ArchitectureRoom
Autodesk.Revit.DBArea
Autodesk.Revit.DB.MechanicalSpace

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SpatialElement : Element
Public Class SpatialElement
    Inherits Element
public ref class SpatialElement : public Element
type SpatialElement =
    class
        inherit Element
    end

The SpatialElement type exposes the following members.

Properties
 | Name | Description
Public property | Area | The area.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | Level | Gets the level of the room.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | Location | The location of the element. (Overrides ElementLocation)
Public property | Name | A human readable name for the Element. (Overrides ElementName)
Public property | Number | The number.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Perimeter | The perimeter.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SpatialElementType | The spatial element type.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetBoundarySegments | Returns the boundary segments.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSpatialElementDomainData | Gets the domain data for the spatial element. The domain data contains information of different spatial elements, such as electrical load area. Currently room/space/area don't have domain data.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SpatialElement Properties

The SpatialElement type exposes the following members.

Properties
 | Name | Description
Public property | Area | The area.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | Level | Gets the level of the room.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | Location | The location of the element. (Overrides ElementLocation)
Public property | Name | A human readable name for the Element. (Overrides ElementName)
Public property | Number | The number.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Perimeter | The perimeter.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SpatialElementType | The spatial element type.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

SpatialElement Class


SpatialElement.Area Property

SpatialElementArea Property

The area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Area { get; }
Public ReadOnly Property Area As Double
    Get
public:
property double Area {
    double get ();
}
member Area : float with get

Property Value

Double
See Also

Reference

SpatialElement Class


SpatialElement.Level Property

SpatialElementLevel Property

Gets the level of the room.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Level Level { get; }
Public ReadOnly Property Level As Level
    Get
public:
property Level^ Level {
    Level^ get ();
}
member Level : Level with get

Property Value

Level
See Also

Reference

SpatialElement Class


SpatialElement.Location Property

SpatialElementLocation Property

The location of the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Location Location { get; }
Public Overrides ReadOnly Property Location As Location
    Get
public:
virtual property Location^ Location {
    Location^ get () override;
}
abstract Location : Location with get
override Location : Location with get

Property Value

Location
Remarks
This is the location of the room within the level. The Z location should be the elevation of the level and not changeable.
See Also

Reference

SpatialElement Class


SpatialElement.Name Property

SpatialElementName Property

A human readable name for the Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string Name { set; }
Public Overrides WriteOnly Property Name As String
    Set
public:
virtual property String^ Name {
    void set (String^ value) override;
}
abstract Name : string with set
override Name : string with set

Property Value

String
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the name of the element cannot be changed.
ArgumentException | Thrown when the element requires a unique name and a non-unique name is set.
Remarks
The Name property is a human readable name for the element, such as Wall.
See Also

Reference

SpatialElement Class


SpatialElement.Number Property

SpatialElementNumber Property

The number.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Number { get; set; }
Public Property Number As String
    Get
    Set
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}
member Number : string with get, set

Property Value

String
See Also

Reference

SpatialElement Class


SpatialElement.Perimeter Property

SpatialElementPerimeter Property

The perimeter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Perimeter { get; }
Public ReadOnly Property Perimeter As Double
    Get
public:
property double Perimeter {
    double get ();
}
member Perimeter : float with get

Property Value

Double
See Also

Reference

SpatialElement Class


SpatialElement.SpatialElementType Property

SpatialElementSpatialElementType Property

The spatial element type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SpatialElementType SpatialElementType { get; }
Public ReadOnly Property SpatialElementType As SpatialElementType
    Get
public:
property SpatialElementType SpatialElementType {
    SpatialElementType get ();
}
member SpatialElementType : SpatialElementType with get

Property Value

SpatialElementType
See Also

Reference

SpatialElement Class


SpatialElement Methods

The SpatialElement type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetBoundarySegments | Returns the boundary segments.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSpatialElementDomainData | Gets the domain data for the spatial element. The domain data contains information of different spatial elements, such as electrical load area. Currently room/space/area don't have domain data.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SpatialElement Class


SpatialElement.GetBoundarySegments Method

SpatialElementGetBoundarySegments Method

Returns the boundary segments.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<IList<BoundarySegment>> GetBoundarySegments(
    SpatialElementBoundaryOptions options
)
Public Function GetBoundarySegments (
    options As SpatialElementBoundaryOptions
) As IList(Of IList(Of BoundarySegment))
public:
IList<IList<BoundarySegment^>^>^ GetBoundarySegments(
    SpatialElementBoundaryOptions^ options
)
member GetBoundarySegments :
        options : SpatialElementBoundaryOptions -> IList<IList<BoundarySegment>>

Parameters

options SpatialElementBoundaryOptions
The SpatialElementBoundaryOptions.

Return Value

IList IList BoundarySegment
Remarks
This method is used to retrieve the segments that constitute the boundary of the spatial element. Each spatial element may have several regions, each of which have several segments hence the data is returned in the form of an array of boundary segment arrays. See the BoundarySegment object for more details about the segments that make up the spatial element topology.
See Also

Reference

SpatialElement Class


SpatialElement.GetSpatialElementDomainData Method

SpatialElementGetSpatialElementDomainData Method

Gets the domain data for the spatial element. The domain data contains information of different spatial elements, such as electrical load area. Currently room/space/area don't have domain data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SpatialElementDomainData GetSpatialElementDomainData()
Public Function GetSpatialElementDomainData As SpatialElementDomainData
public:
SpatialElementDomainData^ GetSpatialElementDomainData()
member GetSpatialElementDomainData : unit -> SpatialElementDomainData

Return Value

SpatialElementDomainData
Returns a pointer to the base class for specific domain requirements for the spatial element.
See Also

Reference

SpatialElement Class


SpatialElementBoundaryLocation Enumeration

An enumerated type listing boundary options of spatial element geometry calculation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum SpatialElementBoundaryLocation
Public Enumeration SpatialElementBoundaryLocation
public enum class SpatialElementBoundaryLocation
type SpatialElementBoundaryLocation
Members
Member name | Value | Description
Finish | 0 | Spatial element finish face.
Center | 1 | Spatial element centerline.
CoreBoundary | 2 | Spatial element core boundary.
CoreCenter | 3 | Spatial element core center.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SpatialElementBoundaryOptions Class

Options that can be passed to a SpatialElementBoundaryCalculator to influence the results of the calculation.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSpatialElementBoundaryOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SpatialElementBoundaryOptions : IDisposable
Public Class SpatialElementBoundaryOptions
    Implements IDisposable
public ref class SpatialElementBoundaryOptions : IDisposable
type SpatialElementBoundaryOptions =
    class
        interface IDisposable
    end

The SpatialElementBoundaryOptions type exposes the following members.

Constructors
 | Name | Description
Public method | SpatialElementBoundaryOptions | Constructs default options for calculation of the geometry of spatial elements (rooms, spaces).
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SpatialElementBoundaryLocation | The boundary of spatial element for geometry calculation.
Public property | StoreFreeBoundaryFaces | Indicates whether to include the free boundary faces in the result.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the SpatialElementBoundaryOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SpatialElementBoundaryOptions Constructor

Constructs default options for calculation of the geometry of spatial elements (rooms, spaces).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SpatialElementBoundaryOptions()
Public Sub New
public:
SpatialElementBoundaryOptions()
new : unit -> SpatialElementBoundaryOptions
See Also

Reference

SpatialElementBoundaryOptions Class


SpatialElementBoundaryOptions Properties

The SpatialElementBoundaryOptions type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SpatialElementBoundaryLocation | The boundary of spatial element for geometry calculation.
Public property | StoreFreeBoundaryFaces | Indicates whether to include the free boundary faces in the result.
Top
See Also

Reference

SpatialElementBoundaryOptions Class


SpatialElementBoundaryOptions.IsValidObject Property

SpatialElementBoundaryOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

SpatialElementBoundaryOptions Class


SpatialElementBoundaryOptions.SpatialElementBoundaryLocation Property

SpatialElementBoundaryOptionsSpatialElementBoundaryLocation Property

The boundary of spatial element for geometry calculation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SpatialElementBoundaryLocation SpatialElementBoundaryLocation { get; set; }
Public Property SpatialElementBoundaryLocation As SpatialElementBoundaryLocation
    Get
    Set
public:
property SpatialElementBoundaryLocation SpatialElementBoundaryLocation {
    SpatialElementBoundaryLocation get ();
    void set (SpatialElementBoundaryLocation value);
}
member SpatialElementBoundaryLocation : SpatialElementBoundaryLocation with get, set

Property Value

SpatialElementBoundaryLocation
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

SpatialElementBoundaryOptions Class


SpatialElementBoundaryOptions.StoreFreeBoundaryFaces Property

SpatialElementBoundaryOptionsStoreFreeBoundaryFaces Property

Indicates whether to include the free boundary faces in the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool StoreFreeBoundaryFaces { get; set; }
Public Property StoreFreeBoundaryFaces As Boolean
    Get
    Set
public:
property bool StoreFreeBoundaryFaces {
    bool get ();
    void set (bool value);
}
member StoreFreeBoundaryFaces : bool with get, set

Property Value

Boolean
Remarks
A free subface is a portion of a spatial element face that is not (partially) coincident with a face of a bounding element.
See Also

Reference

SpatialElementBoundaryOptions Class


SpatialElementBoundaryOptions Methods

The SpatialElementBoundaryOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SpatialElementBoundaryOptions Class


SpatialElementBoundaryOptions.Dispose Method

SpatialElementBoundaryOptionsDispose Method

Releases all resources used by the SpatialElementBoundaryOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

SpatialElementBoundaryOptions Class


SpatialElementBoundarySubface Class

SpatialElementBoundarySubface represents the geometry boundary information of spatial element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSpatialElementBoundarySubface

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SpatialElementBoundarySubface : IDisposable
Public Class SpatialElementBoundarySubface
    Implements IDisposable
public ref class SpatialElementBoundarySubface : IDisposable
type SpatialElementBoundarySubface =
    class
        interface IDisposable
    end

The SpatialElementBoundarySubface type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SpatialBoundaryElement | Element that gave rise to this room face.
Public property | SubfaceArisesFromElementFace | Indicates if the subface is coincident with a portion of a (possibly offset) face of the element.
Public property | SubfaceType | Type of the subface.
Public property | Valid | Indicates if the subface instance is valid and can be used.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the SpatialElementBoundarySubface
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBoundingElementFace | Returns the face of the bounding element.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetSpatialElementFace | Returns the face of the spatial element's 3D geometry.
Public method | GetSubface | Returns a face that represents the portion of the room face bounded by the boundary element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SpatialElementBoundarySubface Properties

The SpatialElementBoundarySubface type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SpatialBoundaryElement | Element that gave rise to this room face.
Public property | SubfaceArisesFromElementFace | Indicates if the subface is coincident with a portion of a (possibly offset) face of the element.
Public property | SubfaceType | Type of the subface.
Public property | Valid | Indicates if the subface instance is valid and can be used.
Top
See Also

Reference

SpatialElementBoundarySubface Class


SpatialElementBoundarySubface.IsValidObject Property

SpatialElementBoundarySubfaceIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

SpatialElementBoundarySubface Class


SpatialElementBoundarySubface.SpatialBoundaryElement Property

SpatialElementBoundarySubfaceSpatialBoundaryElement Property

Element that gave rise to this room face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LinkElementId SpatialBoundaryElement { get; }
Public ReadOnly Property SpatialBoundaryElement As LinkElementId
    Get
public:
property LinkElementId^ SpatialBoundaryElement {
    LinkElementId^ get ();
}
member SpatialBoundaryElement : LinkElementId with get

Property Value

LinkElementId
See Also

Reference

SpatialElementBoundarySubface Class


SpatialElementBoundarySubface.SubfaceArisesFromElementFace Property

SpatialElementBoundarySubfaceSubfaceArisesFromElementFace Property

Indicates if the subface is coincident with a portion of a (possibly offset) face of the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SubfaceArisesFromElementFace { get; }
Public ReadOnly Property SubfaceArisesFromElementFace As Boolean
    Get
public:
property bool SubfaceArisesFromElementFace {
    bool get ();
}
member SubfaceArisesFromElementFace : bool with get

Property Value

Boolean
See Also

Reference

SpatialElementBoundarySubface Class


SpatialElementBoundarySubface.SubfaceType Property

SpatialElementBoundarySubfaceSubfaceType Property

Type of the subface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SubfaceType SubfaceType { get; }
Public ReadOnly Property SubfaceType As SubfaceType
    Get
public:
property SubfaceType SubfaceType {
    SubfaceType get ();
}
member SubfaceType : SubfaceType with get

Property Value

SubfaceType
See Also

Reference

SpatialElementBoundarySubface Class


SpatialElementBoundarySubface.Valid Property

SpatialElementBoundarySubfaceValid Property

Indicates if the subface instance is valid and can be used.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Valid { get; }
Public ReadOnly Property Valid As Boolean
    Get
public:
property bool Valid {
    bool get ();
}
member Valid : bool with get

Property Value

Boolean
See Also

Reference

SpatialElementBoundarySubface Class


SpatialElementBoundarySubface Methods

The SpatialElementBoundarySubface type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBoundingElementFace | Returns the face of the bounding element.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetSpatialElementFace | Returns the face of the spatial element's 3D geometry.
Public method | GetSubface | Returns a face that represents the portion of the room face bounded by the boundary element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SpatialElementBoundarySubface Class


SpatialElementBoundarySubface.Dispose Method

SpatialElementBoundarySubfaceDispose Method

Releases all resources used by the SpatialElementBoundarySubface

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

SpatialElementBoundarySubface Class


SpatialElementBoundarySubface.GetBoundingElementFace Method

SpatialElementBoundarySubfaceGetBoundingElementFace Method

Returns the face of the bounding element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Face GetBoundingElementFace()
Public Function GetBoundingElementFace As Face
public:
Face^ GetBoundingElementFace()
member GetBoundingElementFace : unit -> Face

Return Value

Face
The face of the bounding element.
Remarks
Applies only if the options chosen for the extraction of the element's geometry is Finish. Faces do not contain voids in room-bounding elements (such the voids in walls created by doors and windows).
See Also

Reference

SpatialElementBoundarySubface Class


SpatialElementBoundarySubface.GetSpatialElementFace Method

SpatialElementBoundarySubfaceGetSpatialElementFace Method

Returns the face of the spatial element's 3D geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Face GetSpatialElementFace()
Public Function GetSpatialElementFace As Face
public:
Face^ GetSpatialElementFace()
member GetSpatialElementFace : unit -> Face

Return Value

Face
The face of the spatial element's 3D geometry.
See Also

Reference

SpatialElementBoundarySubface Class


SpatialElementBoundarySubface.GetSubface Method

SpatialElementBoundarySubfaceGetSubface Method

Returns a face that represents the portion of the room face bounded by the boundary element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Face GetSubface()
Public Function GetSubface As Face
public:
Face^ GetSubface()
member GetSubface : unit -> Face

Return Value

Face
The sub-face.
Remarks
If the spatial element's face is adjacent to multiple bounding elements (such as two different walls), there will be one sub-face for each portion of the spatial element's face where it is adjacent to one of those room-bounding elements. This is equivalent to the return of GetRoomFace() if the entire room face is created by the boundary element.
See Also

Reference

SpatialElementBoundarySubface Class


SpatialElementCalculationLocation Class

The Spatial Element Calculation Location is used to specify the room/space where an element should be considered as placed.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBSpatialElementCalculationLocation
Autodesk.Revit.DBSpatialElementCalculationPoint
Autodesk.Revit.DBSpatialElementFromToCalculationPoints

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SpatialElementCalculationLocation : Element
Public Class SpatialElementCalculationLocation
    Inherits Element
public ref class SpatialElementCalculationLocation : public Element
type SpatialElementCalculationLocation =
    class
        inherit Element
    end

The SpatialElementCalculationLocation type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | MarkerPosition | The position of the spatial element calculation location marker.
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
It currently has two types of calculation location: SpatialElementCalculationPoint and SpatialElementFromToCalculationPoints A user can turn on the Spatial Element Calculation Location in the family editor by setting the family's ROOM_CALCULATION_POINT parameter. A user can move the location of the Spatial Element Calculation Location in the family editor. A user can visually verify the location of the Spatial Element Calculation Point by selecting the fixture in the project.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SpatialElementCalculationLocation Properties

The SpatialElementCalculationLocation type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | MarkerPosition | The position of the spatial element calculation location marker.
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

SpatialElementCalculationLocation Class


SpatialElementCalculationLocation.MarkerPosition Property

SpatialElementCalculationLocationMarkerPosition Property

The position of the spatial element calculation location marker.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ MarkerPosition { get; }
Public ReadOnly Property MarkerPosition As XYZ
    Get
public:
property XYZ^ MarkerPosition {
    XYZ^ get ();
}
member MarkerPosition : XYZ with get

Property Value

XYZ
See Also

Reference

SpatialElementCalculationLocation Class


SpatialElementCalculationLocation Methods

The SpatialElementCalculationLocation type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SpatialElementCalculationLocation Class


SpatialElementCalculationPoint Class

SpatialElementCalculationPoint is used as the search point for family instances placement inside rooms and spaces.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBSpatialElementCalculationLocation
Autodesk.Revit.DBSpatialElementCalculationPoint

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SpatialElementCalculationPoint : SpatialElementCalculationLocation
Public Class SpatialElementCalculationPoint
    Inherits SpatialElementCalculationLocation
public ref class SpatialElementCalculationPoint : public SpatialElementCalculationLocation
type SpatialElementCalculationPoint =
    class
        inherit SpatialElementCalculationLocation
    end

The SpatialElementCalculationPoint type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | MarkerPosition | The position of the spatial element calculation location marker. (Inherited from SpatialElementCalculationLocation)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Position | The position of the "in" spatial element calculation point.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The Spatial Element Calculation Point is graphically showed as a location point marker with a "snake" line from the origin of the family. If the Spatial Element Calculation Point is turned on, this point will be used as a search point for room and space relations for all instances of this family.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SpatialElementCalculationPoint Properties

The SpatialElementCalculationPoint type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | MarkerPosition | The position of the spatial element calculation location marker. (Inherited from SpatialElementCalculationLocation)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Position | The position of the "in" spatial element calculation point.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

SpatialElementCalculationPoint Class


SpatialElementCalculationPoint.Position Property

SpatialElementCalculationPointPosition Property

The position of the "in" spatial element calculation point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Position { get; set; }
Public Property Position As XYZ
    Get
    Set
public:
property XYZ^ Position {
    XYZ^ get ();
    void set (XYZ^ value);
}
member Position : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
This is the search point where a family instance will be considered to be located inside a room/space.
See Also

Reference

SpatialElementCalculationPoint Class


SpatialElementCalculationPoint Methods

The SpatialElementCalculationPoint type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SpatialElementCalculationPoint Class


SpatialElementDomainData Class

A base class for specific domain requirements for a spatial element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSpatialElementDomainData
Autodesk.Revit.DB.ElectricalElectricalLoadAreaData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SpatialElementDomainData : IDisposable
Public Class SpatialElementDomainData
    Implements IDisposable
public ref class SpatialElementDomainData : IDisposable
type SpatialElementDomainData =
    class
        interface IDisposable
    end

The SpatialElementDomainData type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the SpatialElementDomainData
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SpatialElementDomainData Properties

The SpatialElementDomainData type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

SpatialElementDomainData Class


SpatialElementDomainData.IsValidObject Property

SpatialElementDomainDataIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

SpatialElementDomainData Class


SpatialElementDomainData Methods

The SpatialElementDomainData type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SpatialElementDomainData Class


SpatialElementDomainData.Dispose Method

SpatialElementDomainDataDispose Method

Releases all resources used by the SpatialElementDomainData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

SpatialElementDomainData Class


SpatialElementFromToCalculationPoints Class

SpatialElementFromToCalculationPoints is used to specify the search points for a family instance which connects two rooms or spaces, such as a door or window. The points determine which room or space is considered the "from" and which is considered the "to".
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBSpatialElementCalculationLocation
Autodesk.Revit.DBSpatialElementFromToCalculationPoints

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SpatialElementFromToCalculationPoints : SpatialElementCalculationLocation
Public Class SpatialElementFromToCalculationPoints
    Inherits SpatialElementCalculationLocation
public ref class SpatialElementFromToCalculationPoints : public SpatialElementCalculationLocation
type SpatialElementFromToCalculationPoints =
    class
        inherit SpatialElementCalculationLocation
    end

The SpatialElementFromToCalculationPoints type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FromPosition | The "from" position of spatial element connecting calculation point.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | MarkerPosition | The position of the spatial element calculation location marker. (Inherited from SpatialElementCalculationLocation)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ToPosition | The "to" position of spatial element connecting calculation point.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | Flip | flip the direction of the "from" and "to" points
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsAcceptableFromPosition | Checks whether a given "from" position is valid.
Public method | IsAcceptableToPosition | Checks whether a given "to" position is valid.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | MakeFromPositionAcceptable | This function takes a potential "from" point and converts it to be a similar point on the opposite side of the family's host from the "to" point if necessary.
Public method | MakeToPositionAcceptable | This function takes a potential "to" point and converts it to be a similar point on the opposite side of the family's host from the "from" point if necessary.
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SpatialElementFromToCalculationPoints Properties

The SpatialElementFromToCalculationPoints type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FromPosition | The "from" position of spatial element connecting calculation point.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | MarkerPosition | The position of the spatial element calculation location marker. (Inherited from SpatialElementCalculationLocation)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ToPosition | The "to" position of spatial element connecting calculation point.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

SpatialElementFromToCalculationPoints Class


SpatialElementFromToCalculationPoints.FromPosition Property

SpatialElementFromToCalculationPointsFromPosition Property

The "from" position of spatial element connecting calculation point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ FromPosition { get; set; }
Public Property FromPosition As XYZ
    Get
    Set
public:
property XYZ^ FromPosition {
    XYZ^ get ();
    void set (XYZ^ value);
}
member FromPosition : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
ArgumentException | When setting this property: fromPosition must be on the opposite side of the family's host from the "to" position.
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

SpatialElementFromToCalculationPoints Class


SpatialElementFromToCalculationPoints.ToPosition Property

SpatialElementFromToCalculationPointsToPosition Property

The "to" position of spatial element connecting calculation point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ ToPosition { get; set; }
Public Property ToPosition As XYZ
    Get
    Set
public:
property XYZ^ ToPosition {
    XYZ^ get ();
    void set (XYZ^ value);
}
member ToPosition : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
ArgumentException | When setting this property: toPosition must be on the opposite side of the family's host from the "from" position.
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

SpatialElementFromToCalculationPoints Class


SpatialElementFromToCalculationPoints Methods

The SpatialElementFromToCalculationPoints type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | Flip | flip the direction of the "from" and "to" points
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsAcceptableFromPosition | Checks whether a given "from" position is valid.
Public method | IsAcceptableToPosition | Checks whether a given "to" position is valid.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | MakeFromPositionAcceptable | This function takes a potential "from" point and converts it to be a similar point on the opposite side of the family's host from the "to" point if necessary.
Public method | MakeToPositionAcceptable | This function takes a potential "to" point and converts it to be a similar point on the opposite side of the family's host from the "from" point if necessary.
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SpatialElementFromToCalculationPoints Class


SpatialElementFromToCalculationPoints.Flip Method

SpatialElementFromToCalculationPointsFlip Method

flip the direction of the "from" and "to" points

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Flip()
Public Sub Flip
public:
void Flip()
member Flip : unit -> unit
See Also

Reference

SpatialElementFromToCalculationPoints Class


SpatialElementFromToCalculationPoints.IsAcceptableFromPosition Method

SpatialElementFromToCalculationPointsIsAcceptableFromPosition Method

Checks whether a given "from" position is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsAcceptableFromPosition(
    XYZ fromPosition
)
Public Function IsAcceptableFromPosition (
    fromPosition As XYZ
) As Boolean
public:
bool IsAcceptableFromPosition(
    XYZ^ fromPosition
)
member IsAcceptableFromPosition :
        fromPosition : XYZ -> bool

Parameters

fromPosition XYZ

Return Value

Boolean
True if the input is an acceptable "from" position and False otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
The "from" position and the "to" position must be on opposite sides of the family's host. Flipping the calculation point will reverse the direction.
See Also

Reference

SpatialElementFromToCalculationPoints Class


SpatialElementFromToCalculationPoints.IsAcceptableToPosition Method

SpatialElementFromToCalculationPointsIsAcceptableToPosition Method

Checks whether a given "to" position is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsAcceptableToPosition(
    XYZ toPosition
)
Public Function IsAcceptableToPosition (
    toPosition As XYZ
) As Boolean
public:
bool IsAcceptableToPosition(
    XYZ^ toPosition
)
member IsAcceptableToPosition :
        toPosition : XYZ -> bool

Parameters

toPosition XYZ

Return Value

Boolean
True if the input is an acceptable "to" position and False otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
The "from" position and the "to" position must be on opposite sides of the family's host. Flipping the calculation point will reverse the direction.
See Also

Reference

SpatialElementFromToCalculationPoints Class


SpatialElementFromToCalculationPoints.MakeFromPositionAcceptable Method

SpatialElementFromToCalculationPointsMakeFromPositionAcceptable Method

This function takes a potential "from" point and converts it to be a similar point on the opposite side of the family's host from the "to" point if necessary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ MakeFromPositionAcceptable(
    XYZ newFromLocation
)
Public Function MakeFromPositionAcceptable (
    newFromLocation As XYZ
) As XYZ
public:
XYZ^ MakeFromPositionAcceptable(
    XYZ^ newFromLocation
)
member MakeFromPositionAcceptable :
        newFromLocation : XYZ -> XYZ

Parameters

newFromLocation XYZ
The desired "from" location

Return Value

XYZ
The valid "from" location.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
If the point is already an acceptable "from" location then the original point will be returned. Otherwise, the point's X and Y will be projected onto the centerline of the family's host.
See Also

Reference

SpatialElementFromToCalculationPoints Class


SpatialElementFromToCalculationPoints.MakeToPositionAcceptable Method

SpatialElementFromToCalculationPointsMakeToPositionAcceptable Method

This function takes a potential "to" point and converts it to be a similar point on the opposite side of the family's host from the "from" point if necessary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ MakeToPositionAcceptable(
    XYZ newToLocation
)
Public Function MakeToPositionAcceptable (
    newToLocation As XYZ
) As XYZ
public:
XYZ^ MakeToPositionAcceptable(
    XYZ^ newToLocation
)
member MakeToPositionAcceptable :
        newToLocation : XYZ -> XYZ

Parameters

newToLocation XYZ
The desired "to" location

Return Value

XYZ
The valid "to" location.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
If the point is already an acceptable "to" location then the original point will be returned. Otherwise, the point's X and Y will be projected onto the centerline of the family's host.
See Also

Reference

SpatialElementFromToCalculationPoints Class


SpatialElementGeometryCalculator Class

Use this class to calculate the geometry of a spatial element and obtain the relationships between the geometry and the element's boundary elements.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSpatialElementGeometryCalculator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SpatialElementGeometryCalculator : IDisposable
Public Class SpatialElementGeometryCalculator
    Implements IDisposable
public ref class SpatialElementGeometryCalculator : IDisposable
type SpatialElementGeometryCalculator =
    class
        interface IDisposable
    end

The SpatialElementGeometryCalculator type exposes the following members.

Constructors
 | Name | Description
Public method | SpatialElementGeometryCalculator(Document) | Constructs a new calculator with default options for the geometry of spatial elements.
Public method | SpatialElementGeometryCalculator(Document, SpatialElementBoundaryOptions) | Constructs a new calculator for the geometry of spatial elements.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | CalculateSpatialElementGeometry | Compute the spatial element geometry and returns the boundary face information.
 | CanCalculateGeometry | This indicates whether the input spatial element is a valid one.
Public method | Dispose | Releases all resources used by the SpatialElementGeometryCalculator
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetOptions | The options that control the calculation.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | IsRoomOrSpace | This indicates whether the input spatial element is a room or a space.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This class maintains an internal cache for geometry it has already processed. If you intend to calculate geometry for several elements in the same project you should use a single instance of this class. Note that the cache will be cleared when any change is made to the document.
Example
C#
VB
C++
F#
Copy
// Calculate a room's geometry and find its boundary faces
SpatialElementGeometryCalculator calculator = new SpatialElementGeometryCalculator(doc);
SpatialElementGeometryResults results = calculator.CalculateSpatialElementGeometry(room); // compute the room geometry
Solid roomSolid = results.GetGeometry(); // get the solid representing the room's geometry
foreach (Face face in roomSolid.Faces)
{
    double faceArea = face.Area;
    IList<SpatialElementBoundarySubface> subfaceList = results.GetBoundaryFaceInfo(face); // get the sub-faces for the face of the room
    foreach (SpatialElementBoundarySubface subface in subfaceList)
    {
        if (subfaceList.Count > 1) // there are multiple sub-faces that define the face
        {
            double subfaceArea = subface.GetSubface().Area; // get the area of each sub-face
            // sub-faces exist in situations such as when a room-bounding wall has been
            // horizontally split and the faces of each split wall combine to create the
            // entire face of the room
        }
    }
}
' Calculate a room's geometry and find its boundary faces
Dim calculator As New SpatialElementGeometryCalculator(doc)
Dim results As SpatialElementGeometryResults = calculator.CalculateSpatialElementGeometry(room)
' compute the room geometry
Dim roomSolid As Solid = results.GetGeometry()
' get the solid representing the room's geometry
For Each face As Face In roomSolid.Faces
    Dim faceArea As Double = face.Area
    Dim subfaceList As IList(Of SpatialElementBoundarySubface) = results.GetBoundaryFaceInfo(face)
    ' get the sub-faces for the face of the room
    For Each subface As SpatialElementBoundarySubface In subfaceList
        If subfaceList.Count > 1 Then
            ' there are multiple sub-faces that define the face
            ' get the area of each sub-face
            ' sub-faces exist in situations such as when a room-bounding wall has been
            ' horizontally split and the faces of each split wall combine to create the
            ' entire face of the room
            Dim subfaceArea As Double = subface.GetSubface().Area
        End If
    Next
Next

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SpatialElementGeometryCalculator Constructor

Overload List
 | Name | Description
Public method | SpatialElementGeometryCalculator(Document) | Constructs a new calculator with default options for the geometry of spatial elements.
Public method | SpatialElementGeometryCalculator(Document, SpatialElementBoundaryOptions) | Constructs a new calculator for the geometry of spatial elements.
Top
See Also

Reference

SpatialElementGeometryCalculator Class


SpatialElementGeometryCalculator(Document) Constructor

Constructs a new calculator with default options for the geometry of spatial elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SpatialElementGeometryCalculator(
    Document aDoc
)
Public Sub New (
    aDoc As Document
)
public:
SpatialElementGeometryCalculator(
    Document^ aDoc
)
new :
        aDoc : Document -> SpatialElementGeometryCalculator

Parameters

aDoc Document
The document that contains the spatial elements.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

SpatialElementGeometryCalculator Class
SpatialElementGeometryCalculator Overload


SpatialElementGeometryCalculator(Document, SpatialElementBoundaryOptions) Constructor

Constructs a new calculator for the geometry of spatial elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SpatialElementGeometryCalculator(
    Document aDoc,
    SpatialElementBoundaryOptions options
)
Public Sub New (
    aDoc As Document,
    options As SpatialElementBoundaryOptions
)
public:
SpatialElementGeometryCalculator(
    Document^ aDoc,
    SpatialElementBoundaryOptions^ options
)
new :
        aDoc : Document *
        options : SpatialElementBoundaryOptions -> SpatialElementGeometryCalculator

Parameters

aDoc Document
The document that contains the spatial elements.
options SpatialElementBoundaryOptions
The options to control the calculation rules.
Exceptions
Exception | Condition
ArgumentException | options is not valid. Only Finish and Center of SpatialElementBoundaryLocation are allowed.
ArgumentNullException | A non-optional argument was null
See Also

Reference

SpatialElementGeometryCalculator Class
SpatialElementGeometryCalculator Overload


SpatialElementGeometryCalculator Properties

The SpatialElementGeometryCalculator type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

SpatialElementGeometryCalculator Class


SpatialElementGeometryCalculator.IsValidObject Property

SpatialElementGeometryCalculatorIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

SpatialElementGeometryCalculator Class


SpatialElementGeometryCalculator Methods

The SpatialElementGeometryCalculator type exposes the following members.

Methods
 | Name | Description
Public method | CalculateSpatialElementGeometry | Compute the spatial element geometry and returns the boundary face information.
 | CanCalculateGeometry | This indicates whether the input spatial element is a valid one.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetOptions | The options that control the calculation.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | IsRoomOrSpace | This indicates whether the input spatial element is a room or a space.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SpatialElementGeometryCalculator Class


SpatialElementGeometryCalculator.CalculateSpatialElementGeometry Method

SpatialElementGeometryCalculatorCalculateSpatialElementGeometry Method

Compute the spatial element geometry and returns the boundary face information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SpatialElementGeometryResults CalculateSpatialElementGeometry(
    SpatialElement spatialElement
)
Public Function CalculateSpatialElementGeometry (
    spatialElement As SpatialElement
) As SpatialElementGeometryResults
public:
SpatialElementGeometryResults^ CalculateSpatialElementGeometry(
    SpatialElement^ spatialElement
)
member CalculateSpatialElementGeometry :
        spatialElement : SpatialElement -> SpatialElementGeometryResults

Parameters

spatialElement SpatialElement
Specifies the spatial element needs to be computed, should be Room or Space.

Return Value

SpatialElementGeometryResults
Requested boundary face information.
Exceptions
Exception | Condition
ArgumentException | spatialElement is not a room or a space, and thus has no 3D geometry to calculate. -or- spatialElement is not enclosed in 2d or has no location, or the height is too small, and thus has no 3D geometry to calculate.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Failed to compute the given spatial element's geometry.
See Also

Reference

SpatialElementGeometryCalculator Class


SpatialElementGeometryCalculator.CanCalculateGeometry Method

SpatialElementGeometryCalculatorCanCalculateGeometry Method

This indicates whether the input spatial element is a valid one.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CanCalculateGeometry(
    SpatialElement spatialElement
)
Public Shared Function CanCalculateGeometry (
    spatialElement As SpatialElement
) As Boolean
public:
static bool CanCalculateGeometry(
    SpatialElement^ spatialElement
)
static member CanCalculateGeometry :
        spatialElement : SpatialElement -> bool

Parameters

spatialElement SpatialElement
The spatial element to be checked if its geometry can be calculated.

Return Value

Boolean
It will return false if the room/space is not enclosed in 2d or has no location, or the height is too small.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

SpatialElementGeometryCalculator Class


SpatialElementGeometryCalculator.Dispose Method

SpatialElementGeometryCalculatorDispose Method

Releases all resources used by the SpatialElementGeometryCalculator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

SpatialElementGeometryCalculator Class


SpatialElementGeometryCalculator.GetOptions Method

SpatialElementGeometryCalculatorGetOptions Method

The options that control the calculation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SpatialElementBoundaryOptions GetOptions()
Public Function GetOptions As SpatialElementBoundaryOptions
public:
SpatialElementBoundaryOptions^ GetOptions()
member GetOptions : unit -> SpatialElementBoundaryOptions

Return Value

SpatialElementBoundaryOptions
The options.
See Also

Reference

SpatialElementGeometryCalculator Class


SpatialElementGeometryCalculator.IsRoomOrSpace Method

SpatialElementGeometryCalculatorIsRoomOrSpace Method

This indicates whether the input spatial element is a room or a space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsRoomOrSpace(
    SpatialElement spatialElement
)
Public Shared Function IsRoomOrSpace (
    spatialElement As SpatialElement
) As Boolean
public:
static bool IsRoomOrSpace(
    SpatialElement^ spatialElement
)
static member IsRoomOrSpace :
        spatialElement : SpatialElement -> bool

Parameters

spatialElement SpatialElement
The spatial element to be checked if it is a room or a space or not.

Return Value

Boolean
True if the input spatial element is a room or a space, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

SpatialElementGeometryCalculator Class


SpatialElementGeometryResults Class

The results of spatial element geometry calculation.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSpatialElementGeometryResults

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SpatialElementGeometryResults : IDisposable
Public Class SpatialElementGeometryResults
    Implements IDisposable
public ref class SpatialElementGeometryResults : IDisposable
type SpatialElementGeometryResults =
    class
        interface IDisposable
    end

The SpatialElementGeometryResults type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the SpatialElementGeometryResults
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBoundaryFaceInfo | Query the spatial element boundary face information with the given face.
Public method | GetGeometry | The solid from the spatial element.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The subfaces of a SpatialElement at the base height and top height are not associated with floors, roofs, and ceilings at the same height.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SpatialElementGeometryResults Properties

The SpatialElementGeometryResults type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

SpatialElementGeometryResults Class


SpatialElementGeometryResults.IsValidObject Property

SpatialElementGeometryResultsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

SpatialElementGeometryResults Class


SpatialElementGeometryResults Methods

The SpatialElementGeometryResults type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBoundaryFaceInfo | Query the spatial element boundary face information with the given face.
Public method | GetGeometry | The solid from the spatial element.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SpatialElementGeometryResults Class


SpatialElementGeometryResults.Dispose Method

SpatialElementGeometryResultsDispose Method

Releases all resources used by the SpatialElementGeometryResults

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

SpatialElementGeometryResults Class


SpatialElementGeometryResults.GetBoundaryFaceInfo Method

SpatialElementGeometryResultsGetBoundaryFaceInfo Method

Query the spatial element boundary face information with the given face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<SpatialElementBoundarySubface> GetBoundaryFaceInfo(
    Face face
)
Public Function GetBoundaryFaceInfo (
    face As Face
) As IList(Of SpatialElementBoundarySubface)
public:
IList<SpatialElementBoundarySubface^>^ GetBoundaryFaceInfo(
    Face^ face
)
member GetBoundaryFaceInfo :
        face : Face -> IList<SpatialElementBoundarySubface>

Parameters

face Face
The face from the spatial element's geometry.

Return Value

IList SpatialElementBoundarySubface
Sub-faces related to the room bounding elements that define the spatial element face. Returns if there is no corresponding boundary information with the given face.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

SpatialElementGeometryResults Class


SpatialElementGeometryResults.GetGeometry Method

SpatialElementGeometryResultsGetGeometry Method

The solid from the spatial element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Solid GetGeometry()
Public Function GetGeometry As Solid
public:
Solid^ GetGeometry()
member GetGeometry : unit -> Solid

Return Value

Solid
Requested solid.
See Also

Reference

SpatialElementGeometryResults Class


SpatialElementTag Class

A tag attached to a SpatialElement (room, space or area) in Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBSpatialElementTag
Autodesk.Revit.DB.ArchitectureRoomTag
Autodesk.Revit.DBAreaTag
Autodesk.Revit.DB.MechanicalSpaceTag

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SpatialElementTag : Element
Public Class SpatialElementTag
    Inherits Element
public ref class SpatialElementTag : public Element
type SpatialElementTag =
    class
        inherit Element
    end

The SpatialElementTag type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HasElbow | Identifies if the tag's leader has an elbow point or not.
Public property | HasLeader | Identifies if a leader is displayed for the tag or not.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsOrphaned | Identifies if the tag is orphaned or not.
Public property | IsTaggingLink | Identifies if the tag has reference to a spatial element in a linked document or not.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LeaderElbow | The position of the leader's elbow (middle point).
Public property | LeaderEnd | The position of the leader's end.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | Location | The location of the tag. (Overrides ElementLocation)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | RotationAngle | The rotation angle of the tag relative to its view
Public property | TagHeadPosition | The position of the tag's head.
Public property | TagOrientation | The orientation of the tag.
Public property | TagText | The text displayed by the tag.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | View | The view in which the tag was placed.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
SpatialElementTag is the base class for RoomTag, SpaceTag and AreaTag. Zone tag is not derived from SpatialElementTag. See [!:Autodesk::Revit::DB::IndependentTag] for more information.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SpatialElementTag Properties

The SpatialElementTag type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HasElbow | Identifies if the tag's leader has an elbow point or not.
Public property | HasLeader | Identifies if a leader is displayed for the tag or not.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsOrphaned | Identifies if the tag is orphaned or not.
Public property | IsTaggingLink | Identifies if the tag has reference to a spatial element in a linked document or not.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LeaderElbow | The position of the leader's elbow (middle point).
Public property | LeaderEnd | The position of the leader's end.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | Location | The location of the tag. (Overrides ElementLocation)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | RotationAngle | The rotation angle of the tag relative to its view
Public property | TagHeadPosition | The position of the tag's head.
Public property | TagOrientation | The orientation of the tag.
Public property | TagText | The text displayed by the tag.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | View | The view in which the tag was placed.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

SpatialElementTag Class


SpatialElementTag.HasElbow Property

SpatialElementTagHasElbow Property

Identifies if the tag's leader has an elbow point or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasElbow { get; }
Public ReadOnly Property HasElbow As Boolean
    Get
public:
property bool HasElbow {
    bool get ();
}
member HasElbow : bool with get

Property Value

Boolean
Exceptions
Exception | Condition
InvalidOperationException | There is no leader for this tag.
Remarks
Straight leaders do not have elbow points. Use LeaderElbow to get or set elbow point.
See Also

Reference

SpatialElementTag Class


SpatialElementTag.HasLeader Property

SpatialElementTagHasLeader Property

Identifies if a leader is displayed for the tag or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasLeader { get; set; }
Public Property HasLeader As Boolean
    Get
    Set
public:
property bool HasLeader {
    bool get ();
    void set (bool value);
}
member HasLeader : bool with get, set

Property Value

Boolean
True if a leader is displayed, otherwise false.
Exceptions
Exception | Condition
InvalidOperationException | When setting this property: SpatialElementTag is orphaned. -or- When setting this property: Thrown when attempting to turn off leader of the pinned tag when the tag's head position is located outside off the host element.
See Also

Reference

SpatialElementTag Class


SpatialElementTag.IsOrphaned Property

SpatialElementTagIsOrphaned Property

Identifies if the tag is orphaned or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsOrphaned { get; }
Public ReadOnly Property IsOrphaned As Boolean
    Get
public:
property bool IsOrphaned {
    bool get ();
}
member IsOrphaned : bool with get

Property Value

Boolean
Remarks
The orphan tags are used to tag a spatial element in a link document, but the spatial element was deleted.
See Also

Reference

SpatialElementTag Class


SpatialElementTag.IsTaggingLink Property

SpatialElementTagIsTaggingLink Property

Identifies if the tag has reference to a spatial element in a linked document or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsTaggingLink { get; }
Public ReadOnly Property IsTaggingLink As Boolean
    Get
public:
property bool IsTaggingLink {
    bool get ();
}
member IsTaggingLink : bool with get

Property Value

Boolean
See Also

Reference

SpatialElementTag Class


SpatialElementTag.LeaderElbow Property

SpatialElementTagLeaderElbow Property

The position of the leader's elbow (middle point).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ LeaderElbow { get; set; }
Public Property LeaderElbow As XYZ
    Get
    Set
public:
property XYZ^ LeaderElbow {
    XYZ^ get ();
    void set (XYZ^ value);
}
member LeaderElbow : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
InvalidOperationException | There is no leader for this tag. -or- When setting this property: SpatialElementTag is pinned. -or- When setting this property: SpatialElementTag is orphaned.
Remarks
Returns the elbow point of the tag leader.
See Also

Reference

SpatialElementTag Class


SpatialElementTag.LeaderEnd Property

SpatialElementTagLeaderEnd Property

The position of the leader's end.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ LeaderEnd { get; set; }
Public Property LeaderEnd As XYZ
    Get
    Set
public:
property XYZ^ LeaderEnd {
    XYZ^ get ();
    void set (XYZ^ value);
}
member LeaderEnd : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
ArgumentException | When setting this property: The point is located outside of the spatial element.
ArgumentNullException | When setting this property: A non-optional argument was null
InvalidOperationException | There is no leader for this tag. -or- When setting this property: SpatialElementTag is pinned. -or- When setting this property: SpatialElementTag is orphaned.
Remarks
Returns the end point of the tag leader. Leader end point must be located inside of a room, space or an area. Use Room.IsPointInRoom or Space.IsPointInSpace method to check whether the leaderEnd is located in the host element or not.
See Also

Reference

SpatialElementTag Class


SpatialElementTag.Location Property

SpatialElementTagLocation Property

The location of the tag.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override Location Location { get; }
Public Overrides ReadOnly Property Location As Location
    Get
public:
virtual property Location^ Location {
    Location^ get () override;
}
abstract Location : Location with get
override Location : Location with get

Property Value

Location
Remarks
Allows you to get and set the location of the tag within the level. The Z location should be the elevation of the level and is not changeable.
See Also

Reference

SpatialElementTag Class


SpatialElementTag.RotationAngle Property

SpatialElementTagRotationAngle Property

The rotation angle of the tag relative to its view

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double RotationAngle { get; set; }
Public Property RotationAngle As Double
    Get
    Set
public:
property double RotationAngle {
    double get ();
    void set (double value);
}
member RotationAngle : float with get, set

Property Value

Double
Exceptions
Exception | Condition
InvalidOperationException | When setting this property: Angle can only be changed for Model orientation
See Also

Reference

SpatialElementTag Class


SpatialElementTag.TagHeadPosition Property

SpatialElementTagTagHeadPosition Property

The position of the tag's head.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ TagHeadPosition { get; set; }
Public Property TagHeadPosition As XYZ
    Get
    Set
public:
property XYZ^ TagHeadPosition {
    XYZ^ get ();
    void set (XYZ^ value);
}
member TagHeadPosition : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
ArgumentException | When setting this property: Head position of the tag with no leader could not be located outside of the host element.
ArgumentNullException | When setting this property: A non-optional argument was null
InvalidOperationException | When setting this property: SpatialElementTag is pinned. -or- When setting this property: SpatialElementTag is orphaned.
Remarks
Returns the end point of the tag leader. Leader end point must be located inside of a room, space or an area. Use Room.IsPointInRoom or Space.IsPointInSpace method to check whether the leaderEnd is located in the host element or not.
See Also

Reference

SpatialElementTag Class


SpatialElementTag.TagOrientation Property

SpatialElementTagTagOrientation Property

The orientation of the tag.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SpatialElementTagOrientation TagOrientation { get; set; }
Public Property TagOrientation As SpatialElementTagOrientation
    Get
    Set
public:
property SpatialElementTagOrientation TagOrientation {
    SpatialElementTagOrientation get ();
    void set (SpatialElementTagOrientation value);
}
member TagOrientation : SpatialElementTagOrientation with get, set

Property Value

SpatialElementTagOrientation
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
See [!:Autodesk::Revit::DB::getSpatialElementTagOrientation] for the supported orientations.
See Also

Reference

SpatialElementTag Class


SpatialElementTag.TagText Property

SpatialElementTagTagText Property

The text displayed by the tag.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TagText { get; }
Public ReadOnly Property TagText As String
    Get
public:
property String^ TagText {
    String^ get ();
}
member TagText : string with get

Property Value

String
Remarks
If there are several strings included in the tag, the strings will be returned concatenated.
See Also

Reference

SpatialElementTag Class


SpatialElementTag.View Property

SpatialElementTagView Property

The view in which the tag was placed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public View View { get; }
Public ReadOnly Property View As View
    Get
public:
property View^ View {
    View^ get ();
}
member View : View with get

Property Value

View
See Also

Reference

SpatialElementTag Class


SpatialElementTag Methods

The SpatialElementTag type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SpatialElementTag Class


SpatialElementTagOrientation Enumeration

An enumerated type listing tag orientation options that are supported by SpatialElementTags.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum SpatialElementTagOrientation
Public Enumeration SpatialElementTagOrientation
public enum class SpatialElementTagOrientation
type SpatialElementTagOrientation
Members
Member name | Value | Description
Horizontal | 0 | The Orientation of tag is Horizontal.
Vertical | 1 | The Orientation of tag is Vertical.
Model | 2 | The Orientation of tag is Model.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SpatialElementType Enumeration

An enumerated type listing types of spaces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum SpatialElementType
Public Enumeration SpatialElementType
public enum class SpatialElementType
type SpatialElementType
Members
Member name | Value | Description
Room | 1 | Room
Area | 2 | Area
Space | 3 | Space
ElectricalLoadArea | 4 | Electrical Load Area
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SpecialType Enumeration

An enumerated type listing special types that can appear in an ExportLayerTable. These types do not represent an independent category in Revit, but can be mapped to specific layers on export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum SpecialType
Public Enumeration SpecialType
public enum class SpecialType
type SpecialType
Members
Member name | Value | Description
InteriorWall | 1 | The special type representing interior walls.
ExteriorWall | 2 | The special type representing exterior walls.
FoundationWall | 3 | The special type representing foundation walls.
RetainingWall | 4 | The special type representing retaining walls.
Default | -1 | The default value for most Revit categories and subcategories.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SpecTypeId Class

This class contains constants identifying specs.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSpecTypeId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class SpecTypeId
Public NotInheritable Class SpecTypeId
public ref class SpecTypeId abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SpecTypeId = class end

The SpecTypeId type exposes the following members.

Properties
Name | Description
Acceleration | Acceleration, in discipline Structural.
AirFlow | Air Flow, in discipline HVAC.
AirFlowDensity | Air Flow Density, in discipline HVAC.
AirFlowDividedByCoolingLoad | Air Flow divided by Cooling Load, in discipline HVAC.
AirFlowDividedByVolume | Air Flow divided by Volume, in discipline HVAC.
Angle | Angle, in discipline Common.
AngularSpeed | Angular Speed, in discipline HVAC.
ApparentPower | Apparent Power, in discipline Electrical.
ApparentPowerDensity | Apparent Power Density, in discipline Electrical.
Area | Area, in discipline Common.
AreaDividedByCoolingLoad | Area divided by Cooling Load, in discipline HVAC.
AreaDividedByHeatingLoad | Area divided by Heating Load, in discipline HVAC.
AreaForce | Area Force, in discipline Structural.
AreaForceScale | Area Force Scale, in discipline Structural.
AreaSpringCoefficient | Area Spring Coefficient, in discipline Structural.
BarDiameter | Bar Diameter, in discipline Structural.
CableTraySize | Cable Tray Size, in discipline Electrical.
ColorTemperature | Color Temperature, in discipline Electrical.
ConduitSize | Conduit Size, in discipline Electrical.
CoolingLoad | Cooling Load, in discipline HVAC.
CoolingLoadDividedByArea | Cooling Load divided by Area, in discipline HVAC.
CoolingLoadDividedByVolume | Cooling Load divided by Volume, in discipline HVAC.
CostPerArea | Cost per Area, in discipline Common.
CostRateEnergy | Cost Rate Energy, in discipline Electrical.
CostRatePower | Cost Rate Power, in discipline Electrical.
CrackWidth | Crack Width, in discipline Structural.
CrossSection | Cross Section, in discipline HVAC.
Currency | Currency, in discipline Common.
Current | Current, in discipline Electrical.
Custom | Unrecognized custom spec.
DecimalSheetLength | Decimal Sheet Length, in discipline Common.
DemandFactor | Demand Factor, in discipline Electrical.
Diffusivity | Diffusivity, in discipline HVAC.
Displacement | Displacement/Deflection, in discipline Structural.
Distance | Distance, in discipline Common.
DuctInsulationThickness | Duct Insulation Thickness, in discipline HVAC.
DuctLiningThickness | Duct Lining Thickness, in discipline HVAC.
DuctSize | Duct Size, in discipline HVAC.
Efficacy | Efficacy, in discipline Electrical.
ElectricalFrequency | Frequency, in discipline Electrical.
ElectricalPotential | Electrical Potential, in discipline Electrical.
ElectricalPower | Power, in discipline Electrical.
ElectricalPowerDensity | Power Density, in discipline Electrical.
ElectricalResistivity | Electrical Resistivity, in discipline Electrical.
ElectricalTemperature | Temperature, in discipline Electrical.
ElectricalTemperatureDifference | Temperature Difference, in discipline Electrical.
Energy | Energy, in discipline Structural.
Factor | Factor, in discipline HVAC.
Flow | Flow, in discipline Piping.
FlowPerPower | Flow per Power, in discipline HVAC.
Force | Force, in discipline Structural.
ForceScale | Force Scale, in discipline Structural.
HeatCapacityPerArea | Heat Capacity per Area, in discipline Energy.
HeatGain | Heat Gain, in discipline HVAC.
HeatingLoad | Heating Load, in discipline HVAC.
HeatingLoadDividedByArea | Heating Load divided by Area, in discipline HVAC.
HeatingLoadDividedByVolume | Heating Load divided by Volume, in discipline HVAC.
HeatTransferCoefficient | Coefficient of Heat Transfer, in discipline Energy.
HvacDensity | Density, in discipline HVAC.
HvacEnergy | Energy, in discipline Energy.
HvacFriction | Friction, in discipline HVAC.
HvacMassPerTime | Mass per Time, in discipline HVAC.
HvacPower | Power, in discipline HVAC.
HvacPowerDensity | Power Density, in discipline HVAC.
HvacPressure | Pressure, in discipline HVAC.
HvacRoughness | Roughness, in discipline HVAC.
HvacSlope | Slope, in discipline HVAC.
HvacTemperature | Temperature, in discipline HVAC.
HvacTemperatureDifference | Temperature Difference, in discipline HVAC.
HvacVelocity | Velocity, in discipline HVAC.
HvacViscosity | Dynamic Viscosity, in discipline HVAC.
Illuminance | Illuminance, in discipline Electrical.
IsothermalMoistureCapacity | Isothermal Moisture Capacity, in discipline Energy.
Length | Length, in discipline Common.
LinearForce | Linear Force, in discipline Structural.
LinearForceScale | Linear Force Scale, in discipline Structural.
LinearMoment | Linear Moment, in discipline Structural.
LinearMomentScale | Linear Moment Scale, in discipline Structural.
LineSpringCoefficient | Line Spring Coefficient, in discipline Structural.
Luminance | Luminance, in discipline Electrical.
LuminousFlux | Luminous Flux, in discipline Electrical.
LuminousIntensity | Luminous Intensity, in discipline Electrical.
Mass | Mass, in discipline Structural.
MassDensity | Mass Density, in discipline Common.
MassPerUnitArea | Mass per Unit Area, in discipline Structural.
MassPerUnitLength | Mass per Unit Length, in discipline Structural.
Moment | Moment, in discipline Structural.
MomentOfInertia | Moment of Inertia, in discipline Structural.
MomentScale | Moment Scale, in discipline Structural.
Number | Number, in discipline Common.
Period | Period, in discipline Structural.
Permeability | Permeability, in discipline Energy.
PipeDimension | Pipe Dimension, in discipline Piping.
PipeInsulationThickness | Pipe Insulation Thickness, in discipline Piping.
PipeMassPerUnitLength | Mass per Unit Length, in discipline Piping.
PipeSize | Pipe Size, in discipline Piping.
PipingDensity | Density, in discipline Piping.
PipingFriction | Friction, in discipline Piping.
PipingMass | Mass, in discipline Piping.
PipingMassPerTime | Mass per Time, in discipline Piping.
PipingPressure | Pressure, in discipline Piping.
PipingRoughness | Roughness, in discipline Piping.
PipingSlope | Slope, in discipline Piping.
PipingTemperature | Temperature, in discipline Piping.
PipingTemperatureDifference | Temperature Difference, in discipline Piping.
PipingVelocity | Velocity, in discipline Piping.
PipingViscosity | Dynamic Viscosity, in discipline Piping.
PipingVolume | Volume, in discipline Piping.
PointSpringCoefficient | Point Spring Coefficient, in discipline Structural.
PowerPerFlow | Power per Flow, in discipline HVAC.
PowerPerLength | Power per Length, in discipline Electrical.
Pulsation | Pulsation, in discipline Structural.
ReinforcementArea | Reinforcement Area, in discipline Structural.
ReinforcementAreaPerUnitLength | Reinforcement Area per Unit Length, in discipline Structural.
ReinforcementCover | Reinforcement Cover, in discipline Structural.
ReinforcementLength | Reinforcement Length, in discipline Structural.
ReinforcementSpacing | Reinforcement Spacing, in discipline Structural.
ReinforcementVolume | Reinforcement Volume, in discipline Structural.
Rotation | Rotation, in discipline Structural.
RotationalLineSpringCoefficient | Rotational Line Spring Coefficient, in discipline Structural.
RotationalPointSpringCoefficient | Rotational Point Spring Coefficient, in discipline Structural.
RotationAngle | Rotation Angle, in discipline Common.
SectionArea | Section Area, in discipline Structural.
SectionDimension | Section Dimension, in discipline Structural.
SectionModulus | Section Modulus, in discipline Structural.
SectionProperty | Section Property, in discipline Structural.
SheetLength | Sheet Length, in discipline Common.
SiteAngle | Site Angle, in discipline Common.
Slope | Slope, in discipline Common.
SpecificHeat | Specific Heat, in discipline Energy.
SpecificHeatOfVaporization | Specific Heat of Vaporization, in discipline Energy.
Speed | Speed, in discipline Common.
Stationing | Stationing, in discipline Infrastructure.
StationingInterval | Stationing Interval, in discipline Infrastructure.
Stress | Stress, in discipline Structural.
StructuralFrequency | Frequency, in discipline Structural.
StructuralVelocity | Velocity, in discipline Structural.
SurfaceAreaPerUnitLength | Surface Area per Unit Length, in discipline Structural.
ThermalConductivity | Thermal Conductivity, in discipline Energy.
ThermalExpansionCoefficient | Thermal Expansion Coefficient, in discipline Structural.
ThermalGradientCoefficientForMoistureCapacity | Thermal Gradient Coefficient for Moisture Capacity, in discipline Energy.
ThermalMass | Thermal Mass, in discipline Energy.
ThermalResistance | Thermal Resistance, in discipline Energy.
Time | Time, in discipline Common.
UnitWeight | Unit Weight, in discipline Structural.
Volume | Volume, in discipline Common.
WarpingConstant | Warping Constant, in discipline Structural.
Wattage | Wattage, in discipline Electrical.
Weight | Weight, in discipline Structural.
WeightPerUnitLength | Weight per Unit Length, in discipline Structural.
WireDiameter | Wire Diameter, in discipline Electrical.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SpecTypeId Properties

The SpecTypeId type exposes the following members.

Properties
Name | Description
Acceleration | Acceleration, in discipline Structural.
AirFlow | Air Flow, in discipline HVAC.
AirFlowDensity | Air Flow Density, in discipline HVAC.
AirFlowDividedByCoolingLoad | Air Flow divided by Cooling Load, in discipline HVAC.
AirFlowDividedByVolume | Air Flow divided by Volume, in discipline HVAC.
Angle | Angle, in discipline Common.
AngularSpeed | Angular Speed, in discipline HVAC.
ApparentPower | Apparent Power, in discipline Electrical.
ApparentPowerDensity | Apparent Power Density, in discipline Electrical.
Area | Area, in discipline Common.
AreaDividedByCoolingLoad | Area divided by Cooling Load, in discipline HVAC.
AreaDividedByHeatingLoad | Area divided by Heating Load, in discipline HVAC.
AreaForce | Area Force, in discipline Structural.
AreaForceScale | Area Force Scale, in discipline Structural.
AreaSpringCoefficient | Area Spring Coefficient, in discipline Structural.
BarDiameter | Bar Diameter, in discipline Structural.
CableTraySize | Cable Tray Size, in discipline Electrical.
ColorTemperature | Color Temperature, in discipline Electrical.
ConduitSize | Conduit Size, in discipline Electrical.
CoolingLoad | Cooling Load, in discipline HVAC.
CoolingLoadDividedByArea | Cooling Load divided by Area, in discipline HVAC.
CoolingLoadDividedByVolume | Cooling Load divided by Volume, in discipline HVAC.
CostPerArea | Cost per Area, in discipline Common.
CostRateEnergy | Cost Rate Energy, in discipline Electrical.
CostRatePower | Cost Rate Power, in discipline Electrical.
CrackWidth | Crack Width, in discipline Structural.
CrossSection | Cross Section, in discipline HVAC.
Currency | Currency, in discipline Common.
Current | Current, in discipline Electrical.
Custom | Unrecognized custom spec.
DecimalSheetLength | Decimal Sheet Length, in discipline Common.
DemandFactor | Demand Factor, in discipline Electrical.
Diffusivity | Diffusivity, in discipline HVAC.
Displacement | Displacement/Deflection, in discipline Structural.
Distance | Distance, in discipline Common.
DuctInsulationThickness | Duct Insulation Thickness, in discipline HVAC.
DuctLiningThickness | Duct Lining Thickness, in discipline HVAC.
DuctSize | Duct Size, in discipline HVAC.
Efficacy | Efficacy, in discipline Electrical.
ElectricalFrequency | Frequency, in discipline Electrical.
ElectricalPotential | Electrical Potential, in discipline Electrical.
ElectricalPower | Power, in discipline Electrical.
ElectricalPowerDensity | Power Density, in discipline Electrical.
ElectricalResistivity | Electrical Resistivity, in discipline Electrical.
ElectricalTemperature | Temperature, in discipline Electrical.
ElectricalTemperatureDifference | Temperature Difference, in discipline Electrical.
Energy | Energy, in discipline Structural.
Factor | Factor, in discipline HVAC.
Flow | Flow, in discipline Piping.
FlowPerPower | Flow per Power, in discipline HVAC.
Force | Force, in discipline Structural.
ForceScale | Force Scale, in discipline Structural.
HeatCapacityPerArea | Heat Capacity per Area, in discipline Energy.
HeatGain | Heat Gain, in discipline HVAC.
HeatingLoad | Heating Load, in discipline HVAC.
HeatingLoadDividedByArea | Heating Load divided by Area, in discipline HVAC.
HeatingLoadDividedByVolume | Heating Load divided by Volume, in discipline HVAC.
HeatTransferCoefficient | Coefficient of Heat Transfer, in discipline Energy.
HvacDensity | Density, in discipline HVAC.
HvacEnergy | Energy, in discipline Energy.
HvacFriction | Friction, in discipline HVAC.
HvacMassPerTime | Mass per Time, in discipline HVAC.
HvacPower | Power, in discipline HVAC.
HvacPowerDensity | Power Density, in discipline HVAC.
HvacPressure | Pressure, in discipline HVAC.
HvacRoughness | Roughness, in discipline HVAC.
HvacSlope | Slope, in discipline HVAC.
HvacTemperature | Temperature, in discipline HVAC.
HvacTemperatureDifference | Temperature Difference, in discipline HVAC.
HvacVelocity | Velocity, in discipline HVAC.
HvacViscosity | Dynamic Viscosity, in discipline HVAC.
Illuminance | Illuminance, in discipline Electrical.
IsothermalMoistureCapacity | Isothermal Moisture Capacity, in discipline Energy.
Length | Length, in discipline Common.
LinearForce | Linear Force, in discipline Structural.
LinearForceScale | Linear Force Scale, in discipline Structural.
LinearMoment | Linear Moment, in discipline Structural.
LinearMomentScale | Linear Moment Scale, in discipline Structural.
LineSpringCoefficient | Line Spring Coefficient, in discipline Structural.
Luminance | Luminance, in discipline Electrical.
LuminousFlux | Luminous Flux, in discipline Electrical.
LuminousIntensity | Luminous Intensity, in discipline Electrical.
Mass | Mass, in discipline Structural.
MassDensity | Mass Density, in discipline Common.
MassPerUnitArea | Mass per Unit Area, in discipline Structural.
MassPerUnitLength | Mass per Unit Length, in discipline Structural.
Moment | Moment, in discipline Structural.
MomentOfInertia | Moment of Inertia, in discipline Structural.
MomentScale | Moment Scale, in discipline Structural.
Number | Number, in discipline Common.
Period | Period, in discipline Structural.
Permeability | Permeability, in discipline Energy.
PipeDimension | Pipe Dimension, in discipline Piping.
PipeInsulationThickness | Pipe Insulation Thickness, in discipline Piping.
PipeMassPerUnitLength | Mass per Unit Length, in discipline Piping.
PipeSize | Pipe Size, in discipline Piping.
PipingDensity | Density, in discipline Piping.
PipingFriction | Friction, in discipline Piping.
PipingMass | Mass, in discipline Piping.
PipingMassPerTime | Mass per Time, in discipline Piping.
PipingPressure | Pressure, in discipline Piping.
PipingRoughness | Roughness, in discipline Piping.
PipingSlope | Slope, in discipline Piping.
PipingTemperature | Temperature, in discipline Piping.
PipingTemperatureDifference | Temperature Difference, in discipline Piping.
PipingVelocity | Velocity, in discipline Piping.
PipingViscosity | Dynamic Viscosity, in discipline Piping.
PipingVolume | Volume, in discipline Piping.
PointSpringCoefficient | Point Spring Coefficient, in discipline Structural.
PowerPerFlow | Power per Flow, in discipline HVAC.
PowerPerLength | Power per Length, in discipline Electrical.
Pulsation | Pulsation, in discipline Structural.
ReinforcementArea | Reinforcement Area, in discipline Structural.
ReinforcementAreaPerUnitLength | Reinforcement Area per Unit Length, in discipline Structural.
ReinforcementCover | Reinforcement Cover, in discipline Structural.
ReinforcementLength | Reinforcement Length, in discipline Structural.
ReinforcementSpacing | Reinforcement Spacing, in discipline Structural.
ReinforcementVolume | Reinforcement Volume, in discipline Structural.
Rotation | Rotation, in discipline Structural.
RotationalLineSpringCoefficient | Rotational Line Spring Coefficient, in discipline Structural.
RotationalPointSpringCoefficient | Rotational Point Spring Coefficient, in discipline Structural.
RotationAngle | Rotation Angle, in discipline Common.
SectionArea | Section Area, in discipline Structural.
SectionDimension | Section Dimension, in discipline Structural.
SectionModulus | Section Modulus, in discipline Structural.
SectionProperty | Section Property, in discipline Structural.
SheetLength | Sheet Length, in discipline Common.
SiteAngle | Site Angle, in discipline Common.
Slope | Slope, in discipline Common.
SpecificHeat | Specific Heat, in discipline Energy.
SpecificHeatOfVaporization | Specific Heat of Vaporization, in discipline Energy.
Speed | Speed, in discipline Common.
Stationing | Stationing, in discipline Infrastructure.
StationingInterval | Stationing Interval, in discipline Infrastructure.
Stress | Stress, in discipline Structural.
StructuralFrequency | Frequency, in discipline Structural.
StructuralVelocity | Velocity, in discipline Structural.
SurfaceAreaPerUnitLength | Surface Area per Unit Length, in discipline Structural.
ThermalConductivity | Thermal Conductivity, in discipline Energy.
ThermalExpansionCoefficient | Thermal Expansion Coefficient, in discipline Structural.
ThermalGradientCoefficientForMoistureCapacity | Thermal Gradient Coefficient for Moisture Capacity, in discipline Energy.
ThermalMass | Thermal Mass, in discipline Energy.
ThermalResistance | Thermal Resistance, in discipline Energy.
Time | Time, in discipline Common.
UnitWeight | Unit Weight, in discipline Structural.
Volume | Volume, in discipline Common.
WarpingConstant | Warping Constant, in discipline Structural.
Wattage | Wattage, in discipline Electrical.
Weight | Weight, in discipline Structural.
WeightPerUnitLength | Weight per Unit Length, in discipline Structural.
WireDiameter | Wire Diameter, in discipline Electrical.
Top
See Also

Reference

SpecTypeId Class


SpecTypeId.Acceleration Property

SpecTypeIdAcceleration Property

Acceleration, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Acceleration { get; }
Public Shared ReadOnly Property Acceleration As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Acceleration {
    ForgeTypeId^ get ();
}
static member Acceleration : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.AirFlow Property

SpecTypeIdAirFlow Property

Air Flow, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AirFlow { get; }
Public Shared ReadOnly Property AirFlow As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AirFlow {
    ForgeTypeId^ get ();
}
static member AirFlow : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.AirFlowDensity Property

SpecTypeIdAirFlowDensity Property

Air Flow Density, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AirFlowDensity { get; }
Public Shared ReadOnly Property AirFlowDensity As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AirFlowDensity {
    ForgeTypeId^ get ();
}
static member AirFlowDensity : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.AirFlowDividedByCoolingLoad Property

SpecTypeIdAirFlowDividedByCoolingLoad Property

Air Flow divided by Cooling Load, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AirFlowDividedByCoolingLoad { get; }
Public Shared ReadOnly Property AirFlowDividedByCoolingLoad As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AirFlowDividedByCoolingLoad {
    ForgeTypeId^ get ();
}
static member AirFlowDividedByCoolingLoad : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.AirFlowDividedByVolume Property

SpecTypeIdAirFlowDividedByVolume Property

Air Flow divided by Volume, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AirFlowDividedByVolume { get; }
Public Shared ReadOnly Property AirFlowDividedByVolume As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AirFlowDividedByVolume {
    ForgeTypeId^ get ();
}
static member AirFlowDividedByVolume : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.Angle Property

SpecTypeIdAngle Property

Angle, in discipline Common.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Angle { get; }
Public Shared ReadOnly Property Angle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Angle {
    ForgeTypeId^ get ();
}
static member Angle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.AngularSpeed Property

SpecTypeIdAngularSpeed Property

Angular Speed, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AngularSpeed { get; }
Public Shared ReadOnly Property AngularSpeed As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AngularSpeed {
    ForgeTypeId^ get ();
}
static member AngularSpeed : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.ApparentPower Property

SpecTypeIdApparentPower Property

Apparent Power, in discipline Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ApparentPower { get; }
Public Shared ReadOnly Property ApparentPower As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ApparentPower {
    ForgeTypeId^ get ();
}
static member ApparentPower : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.ApparentPowerDensity Property

SpecTypeIdApparentPowerDensity Property

Apparent Power Density, in discipline Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ApparentPowerDensity { get; }
Public Shared ReadOnly Property ApparentPowerDensity As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ApparentPowerDensity {
    ForgeTypeId^ get ();
}
static member ApparentPowerDensity : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.Area Property

SpecTypeIdArea Property

Area, in discipline Common.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Area { get; }
Public Shared ReadOnly Property Area As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Area {
    ForgeTypeId^ get ();
}
static member Area : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.AreaDividedByCoolingLoad Property

SpecTypeIdAreaDividedByCoolingLoad Property

Area divided by Cooling Load, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AreaDividedByCoolingLoad { get; }
Public Shared ReadOnly Property AreaDividedByCoolingLoad As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AreaDividedByCoolingLoad {
    ForgeTypeId^ get ();
}
static member AreaDividedByCoolingLoad : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.AreaDividedByHeatingLoad Property

SpecTypeIdAreaDividedByHeatingLoad Property

Area divided by Heating Load, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AreaDividedByHeatingLoad { get; }
Public Shared ReadOnly Property AreaDividedByHeatingLoad As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AreaDividedByHeatingLoad {
    ForgeTypeId^ get ();
}
static member AreaDividedByHeatingLoad : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.AreaForce Property

SpecTypeIdAreaForce Property

Area Force, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AreaForce { get; }
Public Shared ReadOnly Property AreaForce As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AreaForce {
    ForgeTypeId^ get ();
}
static member AreaForce : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.AreaForceScale Property

SpecTypeIdAreaForceScale Property

Area Force Scale, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AreaForceScale { get; }
Public Shared ReadOnly Property AreaForceScale As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AreaForceScale {
    ForgeTypeId^ get ();
}
static member AreaForceScale : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.AreaSpringCoefficient Property

SpecTypeIdAreaSpringCoefficient Property

Area Spring Coefficient, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId AreaSpringCoefficient { get; }
Public Shared ReadOnly Property AreaSpringCoefficient As ForgeTypeId
    Get
public:
static property ForgeTypeId^ AreaSpringCoefficient {
    ForgeTypeId^ get ();
}
static member AreaSpringCoefficient : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.BarDiameter Property

SpecTypeIdBarDiameter Property

Bar Diameter, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BarDiameter { get; }
Public Shared ReadOnly Property BarDiameter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BarDiameter {
    ForgeTypeId^ get ();
}
static member BarDiameter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.CableTraySize Property

SpecTypeIdCableTraySize Property

Cable Tray Size, in discipline Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CableTraySize { get; }
Public Shared ReadOnly Property CableTraySize As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CableTraySize {
    ForgeTypeId^ get ();
}
static member CableTraySize : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.ColorTemperature Property

SpecTypeIdColorTemperature Property

Color Temperature, in discipline Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ColorTemperature { get; }
Public Shared ReadOnly Property ColorTemperature As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ColorTemperature {
    ForgeTypeId^ get ();
}
static member ColorTemperature : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.ConduitSize Property

SpecTypeIdConduitSize Property

Conduit Size, in discipline Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ConduitSize { get; }
Public Shared ReadOnly Property ConduitSize As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ConduitSize {
    ForgeTypeId^ get ();
}
static member ConduitSize : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.CoolingLoad Property

SpecTypeIdCoolingLoad Property

Cooling Load, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CoolingLoad { get; }
Public Shared ReadOnly Property CoolingLoad As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CoolingLoad {
    ForgeTypeId^ get ();
}
static member CoolingLoad : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.CoolingLoadDividedByArea Property

SpecTypeIdCoolingLoadDividedByArea Property

Cooling Load divided by Area, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CoolingLoadDividedByArea { get; }
Public Shared ReadOnly Property CoolingLoadDividedByArea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CoolingLoadDividedByArea {
    ForgeTypeId^ get ();
}
static member CoolingLoadDividedByArea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.CoolingLoadDividedByVolume Property

SpecTypeIdCoolingLoadDividedByVolume Property

Cooling Load divided by Volume, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CoolingLoadDividedByVolume { get; }
Public Shared ReadOnly Property CoolingLoadDividedByVolume As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CoolingLoadDividedByVolume {
    ForgeTypeId^ get ();
}
static member CoolingLoadDividedByVolume : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.CostPerArea Property

SpecTypeIdCostPerArea Property

Cost per Area, in discipline Common.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CostPerArea { get; }
Public Shared ReadOnly Property CostPerArea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CostPerArea {
    ForgeTypeId^ get ();
}
static member CostPerArea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.CostRateEnergy Property

SpecTypeIdCostRateEnergy Property

Cost Rate Energy, in discipline Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CostRateEnergy { get; }
Public Shared ReadOnly Property CostRateEnergy As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CostRateEnergy {
    ForgeTypeId^ get ();
}
static member CostRateEnergy : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.CostRatePower Property

SpecTypeIdCostRatePower Property

Cost Rate Power, in discipline Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CostRatePower { get; }
Public Shared ReadOnly Property CostRatePower As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CostRatePower {
    ForgeTypeId^ get ();
}
static member CostRatePower : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.CrackWidth Property

SpecTypeIdCrackWidth Property

Crack Width, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CrackWidth { get; }
Public Shared ReadOnly Property CrackWidth As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CrackWidth {
    ForgeTypeId^ get ();
}
static member CrackWidth : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.CrossSection Property

SpecTypeIdCrossSection Property

Cross Section, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CrossSection { get; }
Public Shared ReadOnly Property CrossSection As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CrossSection {
    ForgeTypeId^ get ();
}
static member CrossSection : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.Currency Property

SpecTypeIdCurrency Property

Currency, in discipline Common.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Currency { get; }
Public Shared ReadOnly Property Currency As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Currency {
    ForgeTypeId^ get ();
}
static member Currency : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.Current Property

SpecTypeIdCurrent Property

Current, in discipline Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Current { get; }
Public Shared ReadOnly Property Current As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Current {
    ForgeTypeId^ get ();
}
static member Current : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.Custom Property

SpecTypeIdCustom Property

Unrecognized custom spec.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Custom { get; }
Public Shared ReadOnly Property Custom As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Custom {
    ForgeTypeId^ get ();
}
static member Custom : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.DecimalSheetLength Property

SpecTypeIdDecimalSheetLength Property

Decimal Sheet Length, in discipline Common.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DecimalSheetLength { get; }
Public Shared ReadOnly Property DecimalSheetLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DecimalSheetLength {
    ForgeTypeId^ get ();
}
static member DecimalSheetLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.DemandFactor Property

SpecTypeIdDemandFactor Property

Demand Factor, in discipline Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DemandFactor { get; }
Public Shared ReadOnly Property DemandFactor As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DemandFactor {
    ForgeTypeId^ get ();
}
static member DemandFactor : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.Diffusivity Property

SpecTypeIdDiffusivity Property

Diffusivity, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Diffusivity { get; }
Public Shared ReadOnly Property Diffusivity As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Diffusivity {
    ForgeTypeId^ get ();
}
static member Diffusivity : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.Displacement Property

SpecTypeIdDisplacement Property

Displacement/Deflection, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Displacement { get; }
Public Shared ReadOnly Property Displacement As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Displacement {
    ForgeTypeId^ get ();
}
static member Displacement : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.Distance Property

SpecTypeIdDistance Property

Distance, in discipline Common.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Distance { get; }
Public Shared ReadOnly Property Distance As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Distance {
    ForgeTypeId^ get ();
}
static member Distance : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.DuctInsulationThickness Property

SpecTypeIdDuctInsulationThickness Property

Duct Insulation Thickness, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DuctInsulationThickness { get; }
Public Shared ReadOnly Property DuctInsulationThickness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DuctInsulationThickness {
    ForgeTypeId^ get ();
}
static member DuctInsulationThickness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.DuctLiningThickness Property

SpecTypeIdDuctLiningThickness Property

Duct Lining Thickness, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DuctLiningThickness { get; }
Public Shared ReadOnly Property DuctLiningThickness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DuctLiningThickness {
    ForgeTypeId^ get ();
}
static member DuctLiningThickness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.DuctSize Property

SpecTypeIdDuctSize Property

Duct Size, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DuctSize { get; }
Public Shared ReadOnly Property DuctSize As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DuctSize {
    ForgeTypeId^ get ();
}
static member DuctSize : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.Efficacy Property

SpecTypeIdEfficacy Property

Efficacy, in discipline Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Efficacy { get; }
Public Shared ReadOnly Property Efficacy As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Efficacy {
    ForgeTypeId^ get ();
}
static member Efficacy : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.ElectricalFrequency Property

SpecTypeIdElectricalFrequency Property

Frequency, in discipline Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ElectricalFrequency { get; }
Public Shared ReadOnly Property ElectricalFrequency As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ElectricalFrequency {
    ForgeTypeId^ get ();
}
static member ElectricalFrequency : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.ElectricalPotential Property

SpecTypeIdElectricalPotential Property

Electrical Potential, in discipline Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ElectricalPotential { get; }
Public Shared ReadOnly Property ElectricalPotential As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ElectricalPotential {
    ForgeTypeId^ get ();
}
static member ElectricalPotential : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.ElectricalPower Property

SpecTypeIdElectricalPower Property

Power, in discipline Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ElectricalPower { get; }
Public Shared ReadOnly Property ElectricalPower As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ElectricalPower {
    ForgeTypeId^ get ();
}
static member ElectricalPower : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.ElectricalPowerDensity Property

SpecTypeIdElectricalPowerDensity Property

Power Density, in discipline Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ElectricalPowerDensity { get; }
Public Shared ReadOnly Property ElectricalPowerDensity As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ElectricalPowerDensity {
    ForgeTypeId^ get ();
}
static member ElectricalPowerDensity : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.ElectricalResistivity Property

SpecTypeIdElectricalResistivity Property

Electrical Resistivity, in discipline Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ElectricalResistivity { get; }
Public Shared ReadOnly Property ElectricalResistivity As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ElectricalResistivity {
    ForgeTypeId^ get ();
}
static member ElectricalResistivity : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.ElectricalTemperature Property

SpecTypeIdElectricalTemperature Property

Temperature, in discipline Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ElectricalTemperature { get; }
Public Shared ReadOnly Property ElectricalTemperature As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ElectricalTemperature {
    ForgeTypeId^ get ();
}
static member ElectricalTemperature : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.ElectricalTemperatureDifference Property

SpecTypeIdElectricalTemperatureDifference Property

Temperature Difference, in discipline Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ElectricalTemperatureDifference { get; }
Public Shared ReadOnly Property ElectricalTemperatureDifference As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ElectricalTemperatureDifference {
    ForgeTypeId^ get ();
}
static member ElectricalTemperatureDifference : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.Energy Property

SpecTypeIdEnergy Property

Energy, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Energy { get; }
Public Shared ReadOnly Property Energy As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Energy {
    ForgeTypeId^ get ();
}
static member Energy : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.Factor Property

SpecTypeIdFactor Property

Factor, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Factor { get; }
Public Shared ReadOnly Property Factor As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Factor {
    ForgeTypeId^ get ();
}
static member Factor : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.Flow Property

SpecTypeIdFlow Property

Flow, in discipline Piping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Flow { get; }
Public Shared ReadOnly Property Flow As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Flow {
    ForgeTypeId^ get ();
}
static member Flow : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.FlowPerPower Property

SpecTypeIdFlowPerPower Property

Flow per Power, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FlowPerPower { get; }
Public Shared ReadOnly Property FlowPerPower As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FlowPerPower {
    ForgeTypeId^ get ();
}
static member FlowPerPower : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.Force Property

SpecTypeIdForce Property

Force, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Force { get; }
Public Shared ReadOnly Property Force As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Force {
    ForgeTypeId^ get ();
}
static member Force : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.ForceScale Property

SpecTypeIdForceScale Property

Force Scale, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ForceScale { get; }
Public Shared ReadOnly Property ForceScale As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ForceScale {
    ForgeTypeId^ get ();
}
static member ForceScale : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.HeatCapacityPerArea Property

SpecTypeIdHeatCapacityPerArea Property

Heat Capacity per Area, in discipline Energy.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId HeatCapacityPerArea { get; }
Public Shared ReadOnly Property HeatCapacityPerArea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ HeatCapacityPerArea {
    ForgeTypeId^ get ();
}
static member HeatCapacityPerArea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.HeatGain Property

SpecTypeIdHeatGain Property

Heat Gain, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId HeatGain { get; }
Public Shared ReadOnly Property HeatGain As ForgeTypeId
    Get
public:
static property ForgeTypeId^ HeatGain {
    ForgeTypeId^ get ();
}
static member HeatGain : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.HeatingLoad Property

SpecTypeIdHeatingLoad Property

Heating Load, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId HeatingLoad { get; }
Public Shared ReadOnly Property HeatingLoad As ForgeTypeId
    Get
public:
static property ForgeTypeId^ HeatingLoad {
    ForgeTypeId^ get ();
}
static member HeatingLoad : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.HeatingLoadDividedByArea Property

SpecTypeIdHeatingLoadDividedByArea Property

Heating Load divided by Area, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId HeatingLoadDividedByArea { get; }
Public Shared ReadOnly Property HeatingLoadDividedByArea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ HeatingLoadDividedByArea {
    ForgeTypeId^ get ();
}
static member HeatingLoadDividedByArea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.HeatingLoadDividedByVolume Property

SpecTypeIdHeatingLoadDividedByVolume Property

Heating Load divided by Volume, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId HeatingLoadDividedByVolume { get; }
Public Shared ReadOnly Property HeatingLoadDividedByVolume As ForgeTypeId
    Get
public:
static property ForgeTypeId^ HeatingLoadDividedByVolume {
    ForgeTypeId^ get ();
}
static member HeatingLoadDividedByVolume : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.HeatTransferCoefficient Property

SpecTypeIdHeatTransferCoefficient Property

Coefficient of Heat Transfer, in discipline Energy.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId HeatTransferCoefficient { get; }
Public Shared ReadOnly Property HeatTransferCoefficient As ForgeTypeId
    Get
public:
static property ForgeTypeId^ HeatTransferCoefficient {
    ForgeTypeId^ get ();
}
static member HeatTransferCoefficient : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.HvacDensity Property

SpecTypeIdHvacDensity Property

Density, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId HvacDensity { get; }
Public Shared ReadOnly Property HvacDensity As ForgeTypeId
    Get
public:
static property ForgeTypeId^ HvacDensity {
    ForgeTypeId^ get ();
}
static member HvacDensity : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.HvacEnergy Property

SpecTypeIdHvacEnergy Property

Energy, in discipline Energy.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId HvacEnergy { get; }
Public Shared ReadOnly Property HvacEnergy As ForgeTypeId
    Get
public:
static property ForgeTypeId^ HvacEnergy {
    ForgeTypeId^ get ();
}
static member HvacEnergy : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.HvacFriction Property

SpecTypeIdHvacFriction Property

Friction, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId HvacFriction { get; }
Public Shared ReadOnly Property HvacFriction As ForgeTypeId
    Get
public:
static property ForgeTypeId^ HvacFriction {
    ForgeTypeId^ get ();
}
static member HvacFriction : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.HvacMassPerTime Property

SpecTypeIdHvacMassPerTime Property

Mass per Time, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId HvacMassPerTime { get; }
Public Shared ReadOnly Property HvacMassPerTime As ForgeTypeId
    Get
public:
static property ForgeTypeId^ HvacMassPerTime {
    ForgeTypeId^ get ();
}
static member HvacMassPerTime : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.HvacPower Property

SpecTypeIdHvacPower Property

Power, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId HvacPower { get; }
Public Shared ReadOnly Property HvacPower As ForgeTypeId
    Get
public:
static property ForgeTypeId^ HvacPower {
    ForgeTypeId^ get ();
}
static member HvacPower : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.HvacPowerDensity Property

SpecTypeIdHvacPowerDensity Property

Power Density, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId HvacPowerDensity { get; }
Public Shared ReadOnly Property HvacPowerDensity As ForgeTypeId
    Get
public:
static property ForgeTypeId^ HvacPowerDensity {
    ForgeTypeId^ get ();
}
static member HvacPowerDensity : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.HvacPressure Property

SpecTypeIdHvacPressure Property

Pressure, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId HvacPressure { get; }
Public Shared ReadOnly Property HvacPressure As ForgeTypeId
    Get
public:
static property ForgeTypeId^ HvacPressure {
    ForgeTypeId^ get ();
}
static member HvacPressure : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.HvacRoughness Property

SpecTypeIdHvacRoughness Property

Roughness, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId HvacRoughness { get; }
Public Shared ReadOnly Property HvacRoughness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ HvacRoughness {
    ForgeTypeId^ get ();
}
static member HvacRoughness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.HvacSlope Property

SpecTypeIdHvacSlope Property

Slope, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId HvacSlope { get; }
Public Shared ReadOnly Property HvacSlope As ForgeTypeId
    Get
public:
static property ForgeTypeId^ HvacSlope {
    ForgeTypeId^ get ();
}
static member HvacSlope : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.HvacTemperature Property

SpecTypeIdHvacTemperature Property

Temperature, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId HvacTemperature { get; }
Public Shared ReadOnly Property HvacTemperature As ForgeTypeId
    Get
public:
static property ForgeTypeId^ HvacTemperature {
    ForgeTypeId^ get ();
}
static member HvacTemperature : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.HvacTemperatureDifference Property

SpecTypeIdHvacTemperatureDifference Property

Temperature Difference, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId HvacTemperatureDifference { get; }
Public Shared ReadOnly Property HvacTemperatureDifference As ForgeTypeId
    Get
public:
static property ForgeTypeId^ HvacTemperatureDifference {
    ForgeTypeId^ get ();
}
static member HvacTemperatureDifference : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.HvacVelocity Property

SpecTypeIdHvacVelocity Property

Velocity, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId HvacVelocity { get; }
Public Shared ReadOnly Property HvacVelocity As ForgeTypeId
    Get
public:
static property ForgeTypeId^ HvacVelocity {
    ForgeTypeId^ get ();
}
static member HvacVelocity : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.HvacViscosity Property

SpecTypeIdHvacViscosity Property

Dynamic Viscosity, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId HvacViscosity { get; }
Public Shared ReadOnly Property HvacViscosity As ForgeTypeId
    Get
public:
static property ForgeTypeId^ HvacViscosity {
    ForgeTypeId^ get ();
}
static member HvacViscosity : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.Illuminance Property

SpecTypeIdIlluminance Property

Illuminance, in discipline Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Illuminance { get; }
Public Shared ReadOnly Property Illuminance As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Illuminance {
    ForgeTypeId^ get ();
}
static member Illuminance : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.IsothermalMoistureCapacity Property

SpecTypeIdIsothermalMoistureCapacity Property

Isothermal Moisture Capacity, in discipline Energy.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId IsothermalMoistureCapacity { get; }
Public Shared ReadOnly Property IsothermalMoistureCapacity As ForgeTypeId
    Get
public:
static property ForgeTypeId^ IsothermalMoistureCapacity {
    ForgeTypeId^ get ();
}
static member IsothermalMoistureCapacity : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.Length Property

SpecTypeIdLength Property

Length, in discipline Common.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Length { get; }
Public Shared ReadOnly Property Length As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Length {
    ForgeTypeId^ get ();
}
static member Length : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.LinearForce Property

SpecTypeIdLinearForce Property

Linear Force, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LinearForce { get; }
Public Shared ReadOnly Property LinearForce As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LinearForce {
    ForgeTypeId^ get ();
}
static member LinearForce : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.LinearForceScale Property

SpecTypeIdLinearForceScale Property

Linear Force Scale, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LinearForceScale { get; }
Public Shared ReadOnly Property LinearForceScale As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LinearForceScale {
    ForgeTypeId^ get ();
}
static member LinearForceScale : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.LinearMoment Property

SpecTypeIdLinearMoment Property

Linear Moment, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LinearMoment { get; }
Public Shared ReadOnly Property LinearMoment As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LinearMoment {
    ForgeTypeId^ get ();
}
static member LinearMoment : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.LinearMomentScale Property

SpecTypeIdLinearMomentScale Property

Linear Moment Scale, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LinearMomentScale { get; }
Public Shared ReadOnly Property LinearMomentScale As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LinearMomentScale {
    ForgeTypeId^ get ();
}
static member LinearMomentScale : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.LineSpringCoefficient Property

SpecTypeIdLineSpringCoefficient Property

Line Spring Coefficient, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LineSpringCoefficient { get; }
Public Shared ReadOnly Property LineSpringCoefficient As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LineSpringCoefficient {
    ForgeTypeId^ get ();
}
static member LineSpringCoefficient : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.Luminance Property

SpecTypeIdLuminance Property

Luminance, in discipline Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Luminance { get; }
Public Shared ReadOnly Property Luminance As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Luminance {
    ForgeTypeId^ get ();
}
static member Luminance : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.LuminousFlux Property

SpecTypeIdLuminousFlux Property

Luminous Flux, in discipline Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LuminousFlux { get; }
Public Shared ReadOnly Property LuminousFlux As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LuminousFlux {
    ForgeTypeId^ get ();
}
static member LuminousFlux : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.LuminousIntensity Property

SpecTypeIdLuminousIntensity Property

Luminous Intensity, in discipline Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LuminousIntensity { get; }
Public Shared ReadOnly Property LuminousIntensity As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LuminousIntensity {
    ForgeTypeId^ get ();
}
static member LuminousIntensity : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.Mass Property

SpecTypeIdMass Property

Mass, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Mass { get; }
Public Shared ReadOnly Property Mass As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Mass {
    ForgeTypeId^ get ();
}
static member Mass : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.MassDensity Property

SpecTypeIdMassDensity Property

Mass Density, in discipline Common.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MassDensity { get; }
Public Shared ReadOnly Property MassDensity As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MassDensity {
    ForgeTypeId^ get ();
}
static member MassDensity : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.MassPerUnitArea Property

SpecTypeIdMassPerUnitArea Property

Mass per Unit Area, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MassPerUnitArea { get; }
Public Shared ReadOnly Property MassPerUnitArea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MassPerUnitArea {
    ForgeTypeId^ get ();
}
static member MassPerUnitArea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.MassPerUnitLength Property

SpecTypeIdMassPerUnitLength Property

Mass per Unit Length, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MassPerUnitLength { get; }
Public Shared ReadOnly Property MassPerUnitLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MassPerUnitLength {
    ForgeTypeId^ get ();
}
static member MassPerUnitLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.Moment Property

SpecTypeIdMoment Property

Moment, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Moment { get; }
Public Shared ReadOnly Property Moment As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Moment {
    ForgeTypeId^ get ();
}
static member Moment : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.MomentOfInertia Property

SpecTypeIdMomentOfInertia Property

Moment of Inertia, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MomentOfInertia { get; }
Public Shared ReadOnly Property MomentOfInertia As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MomentOfInertia {
    ForgeTypeId^ get ();
}
static member MomentOfInertia : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.MomentScale Property

SpecTypeIdMomentScale Property

Moment Scale, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MomentScale { get; }
Public Shared ReadOnly Property MomentScale As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MomentScale {
    ForgeTypeId^ get ();
}
static member MomentScale : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.Number Property

SpecTypeIdNumber Property

Number, in discipline Common.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Number { get; }
Public Shared ReadOnly Property Number As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Number {
    ForgeTypeId^ get ();
}
static member Number : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.Period Property

SpecTypeIdPeriod Property

Period, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Period { get; }
Public Shared ReadOnly Property Period As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Period {
    ForgeTypeId^ get ();
}
static member Period : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.Permeability Property

SpecTypeIdPermeability Property

Permeability, in discipline Energy.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Permeability { get; }
Public Shared ReadOnly Property Permeability As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Permeability {
    ForgeTypeId^ get ();
}
static member Permeability : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.PipeDimension Property

SpecTypeIdPipeDimension Property

Pipe Dimension, in discipline Piping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PipeDimension { get; }
Public Shared ReadOnly Property PipeDimension As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PipeDimension {
    ForgeTypeId^ get ();
}
static member PipeDimension : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.PipeInsulationThickness Property

SpecTypeIdPipeInsulationThickness Property

Pipe Insulation Thickness, in discipline Piping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PipeInsulationThickness { get; }
Public Shared ReadOnly Property PipeInsulationThickness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PipeInsulationThickness {
    ForgeTypeId^ get ();
}
static member PipeInsulationThickness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.PipeMassPerUnitLength Property

SpecTypeIdPipeMassPerUnitLength Property

Mass per Unit Length, in discipline Piping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PipeMassPerUnitLength { get; }
Public Shared ReadOnly Property PipeMassPerUnitLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PipeMassPerUnitLength {
    ForgeTypeId^ get ();
}
static member PipeMassPerUnitLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.PipeSize Property

SpecTypeIdPipeSize Property

Pipe Size, in discipline Piping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PipeSize { get; }
Public Shared ReadOnly Property PipeSize As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PipeSize {
    ForgeTypeId^ get ();
}
static member PipeSize : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.PipingDensity Property

SpecTypeIdPipingDensity Property

Density, in discipline Piping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PipingDensity { get; }
Public Shared ReadOnly Property PipingDensity As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PipingDensity {
    ForgeTypeId^ get ();
}
static member PipingDensity : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.PipingFriction Property

SpecTypeIdPipingFriction Property

Friction, in discipline Piping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PipingFriction { get; }
Public Shared ReadOnly Property PipingFriction As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PipingFriction {
    ForgeTypeId^ get ();
}
static member PipingFriction : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.PipingMass Property

SpecTypeIdPipingMass Property

Mass, in discipline Piping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PipingMass { get; }
Public Shared ReadOnly Property PipingMass As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PipingMass {
    ForgeTypeId^ get ();
}
static member PipingMass : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.PipingMassPerTime Property

SpecTypeIdPipingMassPerTime Property

Mass per Time, in discipline Piping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PipingMassPerTime { get; }
Public Shared ReadOnly Property PipingMassPerTime As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PipingMassPerTime {
    ForgeTypeId^ get ();
}
static member PipingMassPerTime : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.PipingPressure Property

SpecTypeIdPipingPressure Property

Pressure, in discipline Piping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PipingPressure { get; }
Public Shared ReadOnly Property PipingPressure As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PipingPressure {
    ForgeTypeId^ get ();
}
static member PipingPressure : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.PipingRoughness Property

SpecTypeIdPipingRoughness Property

Roughness, in discipline Piping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PipingRoughness { get; }
Public Shared ReadOnly Property PipingRoughness As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PipingRoughness {
    ForgeTypeId^ get ();
}
static member PipingRoughness : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.PipingSlope Property

SpecTypeIdPipingSlope Property

Slope, in discipline Piping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PipingSlope { get; }
Public Shared ReadOnly Property PipingSlope As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PipingSlope {
    ForgeTypeId^ get ();
}
static member PipingSlope : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.PipingTemperature Property

SpecTypeIdPipingTemperature Property

Temperature, in discipline Piping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PipingTemperature { get; }
Public Shared ReadOnly Property PipingTemperature As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PipingTemperature {
    ForgeTypeId^ get ();
}
static member PipingTemperature : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.PipingTemperatureDifference Property

SpecTypeIdPipingTemperatureDifference Property

Temperature Difference, in discipline Piping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PipingTemperatureDifference { get; }
Public Shared ReadOnly Property PipingTemperatureDifference As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PipingTemperatureDifference {
    ForgeTypeId^ get ();
}
static member PipingTemperatureDifference : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.PipingVelocity Property

SpecTypeIdPipingVelocity Property

Velocity, in discipline Piping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PipingVelocity { get; }
Public Shared ReadOnly Property PipingVelocity As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PipingVelocity {
    ForgeTypeId^ get ();
}
static member PipingVelocity : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.PipingViscosity Property

SpecTypeIdPipingViscosity Property

Dynamic Viscosity, in discipline Piping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PipingViscosity { get; }
Public Shared ReadOnly Property PipingViscosity As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PipingViscosity {
    ForgeTypeId^ get ();
}
static member PipingViscosity : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.PipingVolume Property

SpecTypeIdPipingVolume Property

Volume, in discipline Piping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PipingVolume { get; }
Public Shared ReadOnly Property PipingVolume As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PipingVolume {
    ForgeTypeId^ get ();
}
static member PipingVolume : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.PointSpringCoefficient Property

SpecTypeIdPointSpringCoefficient Property

Point Spring Coefficient, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PointSpringCoefficient { get; }
Public Shared ReadOnly Property PointSpringCoefficient As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PointSpringCoefficient {
    ForgeTypeId^ get ();
}
static member PointSpringCoefficient : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.PowerPerFlow Property

SpecTypeIdPowerPerFlow Property

Power per Flow, in discipline HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PowerPerFlow { get; }
Public Shared ReadOnly Property PowerPerFlow As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PowerPerFlow {
    ForgeTypeId^ get ();
}
static member PowerPerFlow : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.PowerPerLength Property

SpecTypeIdPowerPerLength Property

Power per Length, in discipline Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PowerPerLength { get; }
Public Shared ReadOnly Property PowerPerLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PowerPerLength {
    ForgeTypeId^ get ();
}
static member PowerPerLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.Pulsation Property

SpecTypeIdPulsation Property

Pulsation, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Pulsation { get; }
Public Shared ReadOnly Property Pulsation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Pulsation {
    ForgeTypeId^ get ();
}
static member Pulsation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.ReinforcementArea Property

SpecTypeIdReinforcementArea Property

Reinforcement Area, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ReinforcementArea { get; }
Public Shared ReadOnly Property ReinforcementArea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ReinforcementArea {
    ForgeTypeId^ get ();
}
static member ReinforcementArea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.ReinforcementAreaPerUnitLength Property

SpecTypeIdReinforcementAreaPerUnitLength Property

Reinforcement Area per Unit Length, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ReinforcementAreaPerUnitLength { get; }
Public Shared ReadOnly Property ReinforcementAreaPerUnitLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ReinforcementAreaPerUnitLength {
    ForgeTypeId^ get ();
}
static member ReinforcementAreaPerUnitLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.ReinforcementCover Property

SpecTypeIdReinforcementCover Property

Reinforcement Cover, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ReinforcementCover { get; }
Public Shared ReadOnly Property ReinforcementCover As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ReinforcementCover {
    ForgeTypeId^ get ();
}
static member ReinforcementCover : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.ReinforcementLength Property

SpecTypeIdReinforcementLength Property

Reinforcement Length, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ReinforcementLength { get; }
Public Shared ReadOnly Property ReinforcementLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ReinforcementLength {
    ForgeTypeId^ get ();
}
static member ReinforcementLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.ReinforcementSpacing Property

SpecTypeIdReinforcementSpacing Property

Reinforcement Spacing, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ReinforcementSpacing { get; }
Public Shared ReadOnly Property ReinforcementSpacing As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ReinforcementSpacing {
    ForgeTypeId^ get ();
}
static member ReinforcementSpacing : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.ReinforcementVolume Property

SpecTypeIdReinforcementVolume Property

Reinforcement Volume, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ReinforcementVolume { get; }
Public Shared ReadOnly Property ReinforcementVolume As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ReinforcementVolume {
    ForgeTypeId^ get ();
}
static member ReinforcementVolume : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.Rotation Property

SpecTypeIdRotation Property

Rotation, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Rotation { get; }
Public Shared ReadOnly Property Rotation As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Rotation {
    ForgeTypeId^ get ();
}
static member Rotation : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.RotationalLineSpringCoefficient Property

SpecTypeIdRotationalLineSpringCoefficient Property

Rotational Line Spring Coefficient, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RotationalLineSpringCoefficient { get; }
Public Shared ReadOnly Property RotationalLineSpringCoefficient As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RotationalLineSpringCoefficient {
    ForgeTypeId^ get ();
}
static member RotationalLineSpringCoefficient : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.RotationalPointSpringCoefficient Property

SpecTypeIdRotationalPointSpringCoefficient Property

Rotational Point Spring Coefficient, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RotationalPointSpringCoefficient { get; }
Public Shared ReadOnly Property RotationalPointSpringCoefficient As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RotationalPointSpringCoefficient {
    ForgeTypeId^ get ();
}
static member RotationalPointSpringCoefficient : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.RotationAngle Property

SpecTypeIdRotationAngle Property

Rotation Angle, in discipline Common.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RotationAngle { get; }
Public Shared ReadOnly Property RotationAngle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RotationAngle {
    ForgeTypeId^ get ();
}
static member RotationAngle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.SectionArea Property

SpecTypeIdSectionArea Property

Section Area, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SectionArea { get; }
Public Shared ReadOnly Property SectionArea As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SectionArea {
    ForgeTypeId^ get ();
}
static member SectionArea : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.SectionDimension Property

SpecTypeIdSectionDimension Property

Section Dimension, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SectionDimension { get; }
Public Shared ReadOnly Property SectionDimension As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SectionDimension {
    ForgeTypeId^ get ();
}
static member SectionDimension : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.SectionModulus Property

SpecTypeIdSectionModulus Property

Section Modulus, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SectionModulus { get; }
Public Shared ReadOnly Property SectionModulus As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SectionModulus {
    ForgeTypeId^ get ();
}
static member SectionModulus : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.SectionProperty Property

SpecTypeIdSectionProperty Property

Section Property, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SectionProperty { get; }
Public Shared ReadOnly Property SectionProperty As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SectionProperty {
    ForgeTypeId^ get ();
}
static member SectionProperty : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.SheetLength Property

SpecTypeIdSheetLength Property

Sheet Length, in discipline Common.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SheetLength { get; }
Public Shared ReadOnly Property SheetLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SheetLength {
    ForgeTypeId^ get ();
}
static member SheetLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.SiteAngle Property

SpecTypeIdSiteAngle Property

Site Angle, in discipline Common.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SiteAngle { get; }
Public Shared ReadOnly Property SiteAngle As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SiteAngle {
    ForgeTypeId^ get ();
}
static member SiteAngle : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.Slope Property

SpecTypeIdSlope Property

Slope, in discipline Common.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Slope { get; }
Public Shared ReadOnly Property Slope As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Slope {
    ForgeTypeId^ get ();
}
static member Slope : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.SpecificHeat Property

SpecTypeIdSpecificHeat Property

Specific Heat, in discipline Energy.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpecificHeat { get; }
Public Shared ReadOnly Property SpecificHeat As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpecificHeat {
    ForgeTypeId^ get ();
}
static member SpecificHeat : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.SpecificHeatOfVaporization Property

SpecTypeIdSpecificHeatOfVaporization Property

Specific Heat of Vaporization, in discipline Energy.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SpecificHeatOfVaporization { get; }
Public Shared ReadOnly Property SpecificHeatOfVaporization As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SpecificHeatOfVaporization {
    ForgeTypeId^ get ();
}
static member SpecificHeatOfVaporization : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.Speed Property

SpecTypeIdSpeed Property

Speed, in discipline Common.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Speed { get; }
Public Shared ReadOnly Property Speed As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Speed {
    ForgeTypeId^ get ();
}
static member Speed : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.Stationing Property

SpecTypeIdStationing Property

Stationing, in discipline Infrastructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Stationing { get; }
Public Shared ReadOnly Property Stationing As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Stationing {
    ForgeTypeId^ get ();
}
static member Stationing : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.StationingInterval Property

SpecTypeIdStationingInterval Property

Stationing Interval, in discipline Infrastructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StationingInterval { get; }
Public Shared ReadOnly Property StationingInterval As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StationingInterval {
    ForgeTypeId^ get ();
}
static member StationingInterval : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.Stress Property

SpecTypeIdStress Property

Stress, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Stress { get; }
Public Shared ReadOnly Property Stress As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Stress {
    ForgeTypeId^ get ();
}
static member Stress : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.StructuralFrequency Property

SpecTypeIdStructuralFrequency Property

Frequency, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralFrequency { get; }
Public Shared ReadOnly Property StructuralFrequency As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralFrequency {
    ForgeTypeId^ get ();
}
static member StructuralFrequency : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.StructuralVelocity Property

SpecTypeIdStructuralVelocity Property

Velocity, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StructuralVelocity { get; }
Public Shared ReadOnly Property StructuralVelocity As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StructuralVelocity {
    ForgeTypeId^ get ();
}
static member StructuralVelocity : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.SurfaceAreaPerUnitLength Property

SpecTypeIdSurfaceAreaPerUnitLength Property

Surface Area per Unit Length, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SurfaceAreaPerUnitLength { get; }
Public Shared ReadOnly Property SurfaceAreaPerUnitLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SurfaceAreaPerUnitLength {
    ForgeTypeId^ get ();
}
static member SurfaceAreaPerUnitLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.ThermalConductivity Property

SpecTypeIdThermalConductivity Property

Thermal Conductivity, in discipline Energy.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ThermalConductivity { get; }
Public Shared ReadOnly Property ThermalConductivity As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ThermalConductivity {
    ForgeTypeId^ get ();
}
static member ThermalConductivity : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.ThermalExpansionCoefficient Property

SpecTypeIdThermalExpansionCoefficient Property

Thermal Expansion Coefficient, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ThermalExpansionCoefficient { get; }
Public Shared ReadOnly Property ThermalExpansionCoefficient As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ThermalExpansionCoefficient {
    ForgeTypeId^ get ();
}
static member ThermalExpansionCoefficient : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.ThermalGradientCoefficientForMoistureCapacity Property

SpecTypeIdThermalGradientCoefficientForMoistureCapacity Property

Thermal Gradient Coefficient for Moisture Capacity, in discipline Energy.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ThermalGradientCoefficientForMoistureCapacity { get; }
Public Shared ReadOnly Property ThermalGradientCoefficientForMoistureCapacity As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ThermalGradientCoefficientForMoistureCapacity {
    ForgeTypeId^ get ();
}
static member ThermalGradientCoefficientForMoistureCapacity : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.ThermalMass Property

SpecTypeIdThermalMass Property

Thermal Mass, in discipline Energy.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ThermalMass { get; }
Public Shared ReadOnly Property ThermalMass As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ThermalMass {
    ForgeTypeId^ get ();
}
static member ThermalMass : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.ThermalResistance Property

SpecTypeIdThermalResistance Property

Thermal Resistance, in discipline Energy.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ThermalResistance { get; }
Public Shared ReadOnly Property ThermalResistance As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ThermalResistance {
    ForgeTypeId^ get ();
}
static member ThermalResistance : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.Time Property

SpecTypeIdTime Property

Time, in discipline Common.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Time { get; }
Public Shared ReadOnly Property Time As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Time {
    ForgeTypeId^ get ();
}
static member Time : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.UnitWeight Property

SpecTypeIdUnitWeight Property

Unit Weight, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId UnitWeight { get; }
Public Shared ReadOnly Property UnitWeight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ UnitWeight {
    ForgeTypeId^ get ();
}
static member UnitWeight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.Volume Property

SpecTypeIdVolume Property

Volume, in discipline Common.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Volume { get; }
Public Shared ReadOnly Property Volume As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Volume {
    ForgeTypeId^ get ();
}
static member Volume : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.WarpingConstant Property

SpecTypeIdWarpingConstant Property

Warping Constant, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WarpingConstant { get; }
Public Shared ReadOnly Property WarpingConstant As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WarpingConstant {
    ForgeTypeId^ get ();
}
static member WarpingConstant : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.Wattage Property

SpecTypeIdWattage Property

Wattage, in discipline Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Wattage { get; }
Public Shared ReadOnly Property Wattage As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Wattage {
    ForgeTypeId^ get ();
}
static member Wattage : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.Weight Property

SpecTypeIdWeight Property

Weight, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Weight { get; }
Public Shared ReadOnly Property Weight As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Weight {
    ForgeTypeId^ get ();
}
static member Weight : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.WeightPerUnitLength Property

SpecTypeIdWeightPerUnitLength Property

Weight per Unit Length, in discipline Structural.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WeightPerUnitLength { get; }
Public Shared ReadOnly Property WeightPerUnitLength As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WeightPerUnitLength {
    ForgeTypeId^ get ();
}
static member WeightPerUnitLength : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.WireDiameter Property

SpecTypeIdWireDiameter Property

Wire Diameter, in discipline Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WireDiameter { get; }
Public Shared ReadOnly Property WireDiameter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WireDiameter {
    ForgeTypeId^ get ();
}
static member WireDiameter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeId Class


SpecTypeId.Boolean Class

SpecTypeIdBoolean Class

This class contains constants identifying Boolean specs.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSpecTypeIdBoolean

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class Boolean
Public NotInheritable Class Boolean
public ref class Boolean abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Boolean = class end

The SpecTypeIdBoolean type exposes the following members.

Properties
Name | Description
YesNo | Yes/No, in discipline Common.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Boolean Properties

The SpecTypeIdBoolean type exposes the following members.

Properties
Name | Description
YesNo | Yes/No, in discipline Common.
Top
See Also

Reference

SpecTypeIdBoolean Class


SpecTypeId.Boolean.YesNo Property

SpecTypeIdBooleanYesNo Property

Yes/No, in discipline Common.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId YesNo { get; }
Public Shared ReadOnly Property YesNo As ForgeTypeId
    Get
public:
static property ForgeTypeId^ YesNo {
    ForgeTypeId^ get ();
}
static member YesNo : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeIdBoolean Class


SpecTypeId.Int Class

SpecTypeIdInt Class

This class contains constants identifying integer specs.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSpecTypeIdInt

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class Int
Public NotInheritable Class Int
public ref class Int abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Int = class end

The SpecTypeIdInt type exposes the following members.

Properties
Name | Description
Integer | Integer, in discipline Common.
NumberOfPoles | Number of Poles, in discipline Electrical.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Int Properties

The SpecTypeIdInt type exposes the following members.

Properties
Name | Description
Integer | Integer, in discipline Common.
NumberOfPoles | Number of Poles, in discipline Electrical.
Top
See Also

Reference

SpecTypeIdInt Class


SpecTypeId.Int.Integer Property

SpecTypeIdIntInteger Property

Integer, in discipline Common.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Integer { get; }
Public Shared ReadOnly Property Integer As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Integer {
    ForgeTypeId^ get ();
}
static member Integer : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeIdInt Class


SpecTypeId.Int.NumberOfPoles Property

SpecTypeIdIntNumberOfPoles Property

Number of Poles, in discipline Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId NumberOfPoles { get; }
Public Shared ReadOnly Property NumberOfPoles As ForgeTypeId
    Get
public:
static property ForgeTypeId^ NumberOfPoles {
    ForgeTypeId^ get ();
}
static member NumberOfPoles : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeIdInt Class


SpecTypeId.Reference Class

SpecTypeIdReference Class

This class contains constants identifying reference specs.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSpecTypeIdReference

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class Reference
Public NotInheritable Class Reference
public ref class Reference abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Reference = class end

The SpecTypeIdReference type exposes the following members.

Properties
Name | Description
FillPattern | Fill Pattern, in discipline Common.
Image | Image, in discipline Common.
LoadClassification | Load Classification, in discipline Electrical.
Material | Material, in discipline Common.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Reference Properties

The SpecTypeIdReference type exposes the following members.

Properties
Name | Description
FillPattern | Fill Pattern, in discipline Common.
Image | Image, in discipline Common.
LoadClassification | Load Classification, in discipline Electrical.
Material | Material, in discipline Common.
Top
See Also

Reference

SpecTypeIdReference Class


SpecTypeId.Reference.FillPattern Property

SpecTypeIdReferenceFillPattern Property

Fill Pattern, in discipline Common.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FillPattern { get; }
Public Shared ReadOnly Property FillPattern As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FillPattern {
    ForgeTypeId^ get ();
}
static member FillPattern : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeIdReference Class


SpecTypeId.Reference.Image Property

SpecTypeIdReferenceImage Property

Image, in discipline Common.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Image { get; }
Public Shared ReadOnly Property Image As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Image {
    ForgeTypeId^ get ();
}
static member Image : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeIdReference Class


SpecTypeId.Reference.LoadClassification Property

SpecTypeIdReferenceLoadClassification Property

Load Classification, in discipline Electrical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LoadClassification { get; }
Public Shared ReadOnly Property LoadClassification As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LoadClassification {
    ForgeTypeId^ get ();
}
static member LoadClassification : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeIdReference Class


SpecTypeId.Reference.Material Property

SpecTypeIdReferenceMaterial Property

Material, in discipline Common.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Material { get; }
Public Shared ReadOnly Property Material As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Material {
    ForgeTypeId^ get ();
}
static member Material : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeIdReference Class


SpecTypeId.String Class

SpecTypeIdString Class

This class contains constants identifying string specs.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSpecTypeIdString

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class String
Public NotInheritable Class String
public ref class String abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type String = class end

The SpecTypeIdString type exposes the following members.

Properties
Name | Description
MultilineText | Multiline Text, in discipline Common.
Text | Text, in discipline Common.
Url | URL, in discipline Common.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


String Properties

The SpecTypeIdString type exposes the following members.

Properties
Name | Description
MultilineText | Multiline Text, in discipline Common.
Text | Text, in discipline Common.
Url | URL, in discipline Common.
Top
See Also

Reference

SpecTypeIdString Class


SpecTypeId.String.MultilineText Property

SpecTypeIdStringMultilineText Property

Multiline Text, in discipline Common.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MultilineText { get; }
Public Shared ReadOnly Property MultilineText As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MultilineText {
    ForgeTypeId^ get ();
}
static member MultilineText : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeIdString Class


SpecTypeId.String.Text Property

SpecTypeIdStringText Property

Text, in discipline Common.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Text { get; }
Public Shared ReadOnly Property Text As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Text {
    ForgeTypeId^ get ();
}
static member Text : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeIdString Class


SpecTypeId.String.Url Property

SpecTypeIdStringUrl Property

URL, in discipline Common.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Url { get; }
Public Shared ReadOnly Property Url As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Url {
    ForgeTypeId^ get ();
}
static member Url : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SpecTypeIdString Class


SpecUtils Class

A utility class of functions related to specs. A spec describes a data type that parameters can hold.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSpecUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class SpecUtils
Public NotInheritable Class SpecUtils
public ref class SpecUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SpecUtils = class end

The SpecUtils type exposes the following members.

Methods
Name | Description
GetAllSpecs | Gets the identifiers of all specs.
IsSpec | Checks whether a ForgeTypeId identifies a spec.
IsValidDataType | Returns true if the given ForgeTypeId identifies a valid parameter data type.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SpecUtils Methods

The SpecUtils type exposes the following members.

Methods
Name | Description
GetAllSpecs | Gets the identifiers of all specs.
IsSpec | Checks whether a ForgeTypeId identifies a spec.
IsValidDataType | Returns true if the given ForgeTypeId identifies a valid parameter data type.
Top
See Also

Reference

SpecUtils Class


SpecUtils.GetAllSpecs Method

SpecUtilsGetAllSpecs Method

Gets the identifiers of all specs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<ForgeTypeId> GetAllSpecs()
Public Shared Function GetAllSpecs As IList(Of ForgeTypeId)
public:
static IList<ForgeTypeId^>^ GetAllSpecs()
static member GetAllSpecs : unit -> IList<ForgeTypeId>

Return Value

IList ForgeTypeId
The spec identifiers.
See Also

Reference

SpecUtils Class


SpecUtils.IsSpec Method

SpecUtilsIsSpec Method

Checks whether a ForgeTypeId identifies a spec.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsSpec(
    ForgeTypeId specTypeId
)
Public Shared Function IsSpec (
    specTypeId As ForgeTypeId
) As Boolean
public:
static bool IsSpec(
    ForgeTypeId^ specTypeId
)
static member IsSpec :
        specTypeId : ForgeTypeId -> bool

Parameters

specTypeId ForgeTypeId
The identifier to check.

Return Value

Boolean
True if the ForgeTypeId identifies a spec, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

SpecUtils Class


SpecUtils.IsValidDataType Method

SpecUtilsIsValidDataType Method

Returns true if the given ForgeTypeId identifies a valid parameter data type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidDataType(
    ForgeTypeId dataType
)
Public Shared Function IsValidDataType (
    dataType As ForgeTypeId
) As Boolean
public:
static bool IsValidDataType(
    ForgeTypeId^ dataType
)
static member IsValidDataType :
        dataType : ForgeTypeId -> bool

Parameters

dataType ForgeTypeId
The identifier to check.

Return Value

Boolean
True if the ForgeTypeId identifies either a spec or a category, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
A ForgeTypeId is acceptable as a parameter data type if it identifies either a spec or a category. When a category identifier is used as a parameter data type, it indicates a Family Type parameter of that category.
See Also

Reference

SpecUtils Class


SpotDimension Class

Object representing various types of SpotDimension
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBDimension
Autodesk.Revit.DBSpotDimension

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SpotDimension : Dimension
Public Class SpotDimension
    Inherits Dimension
public ref class SpotDimension : public Dimension
type SpotDimension =
    class
        inherit Dimension
    end

The SpotDimension type exposes the following members.

Properties
 | Name | Description
Public property | Above | The text shown above the segment's value. (Inherited from Dimension)
Public property | AreReferencesAvailable | Indicates if this dimension's references can be resolved. (Inherited from Dimension)
Public property | AreSegmentsEqual | Indicates if all segments are forced to be equal. (Inherited from Dimension)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | Below | The text shown below the segment's value. (Inherited from Dimension)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | Curve | A curve that represents the dimension line. (Inherited from Dimension)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | DimensionShape | The shape of this dimension. (Inherited from Dimension)
Public property | DimensionType | The dimension style of this dimension. (Inherited from Dimension)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyLabel | The family parameter label of the dimension. (Inherited from Dimension)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HasLeader | True if dimension has leader, false otherwise. (Inherited from Dimension)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsLocked | Indicates if this dimension is locked. (Inherited from Dimension)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValid | Indicates if this dimension is valid. (Inherited from Dimension)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LeaderEndPosition | The position of the dimension's leader end point. (Inherited from Dimension)
Public property | LeaderHasShoulder | True is dimension has leader with shoulder, false otherwise.
Public property | LeaderShoulderPosition | Position of spot dimension's leader shoulder point.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Retrieves or changes the name associated with the Dimension. (Inherited from Dimension)
Public property | NumberOfSegments | The number of segments for the dimension. (Inherited from Dimension)
Public property | Origin | The dimension origin. (Inherited from Dimension)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Prefix | The text shown before the segment's value. (Inherited from Dimension)
Public property | References | Returns an array of geometric references to which the dimension is attached. (Inherited from Dimension)
Public property | Segments | The segments in the dimension. (Inherited from Dimension)
Public property | SpotDimensionType | The dimension style of this dimension.
Public property | Suffix | The text shown after the segment's value. (Inherited from Dimension)
 | TextPosition | The position of the dimension text's drag point. (Inherited from Dimension)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | Value | The value of the dimension. (Inherited from Dimension)
Public property | ValueOverride | The text that replaces the segment's value. (Inherited from Dimension)
Public property | ValueString | The dimension value as a user visible string. (Inherited from Dimension)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | View | Supplies the view that contains the dimension if the dimension is view specific. (Inherited from Dimension)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanFlip | Verifies that the direction of the dimension can be flipped.
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | Flip | Flips dimension to the other side of the host.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasOneSegment | Determines whether a dimension has one segment. (Inherited from Dimension)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsTextPositionAdjustable | Indicates if this dimension is supported to set/get TextPosition/LeaderEndPosition. (Inherited from Dimension)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | ResetTextPosition | Resets the text position of the dimension to the initial position determined by its type and parameters. (Inherited from Dimension)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Example
C#
VB
C++
F#
Copy
private void Getinfo_SpotDimension(SpotDimension spotDimension)
{
    string message = "SpotDimension's Location : ";
    Location location = spotDimension.Location;

    if (location is LocationPoint)
    {
        LocationPoint point = location as LocationPoint;

        message += "\n" + location.GetType().Name + " : ";
        message += "(" + point.Point.X + ", " + point.Point.Y + ", " + point.Point.Z + ")";
    }
    else
    {
        LocationCurve locCurve = location as LocationCurve;
        Curve curve = locCurve.Curve;
        message += "\n" + location.GetType().Name + " : ";
        message += "\nStart Point : " + "(" + curve.GetEndPoint(0).X + ", "
                    + curve.GetEndPoint(0).Y + ", " + curve.GetEndPoint(0).Z + ")";
        message += "\nEnd point : " + "(" + curve.GetEndPoint(1).X + ", "
                    + curve.GetEndPoint(1).Y + ", " + curve.GetEndPoint(1).Z + ")";
    }

    TaskDialog.Show("Revit",message);
}
Private Sub Getinfo_SpotDimension(spotDimension As SpotDimension)
    Dim message As String = "SpotDimension's Location : "
    Dim location As Location = spotDimension.Location

    If TypeOf location Is LocationPoint Then
        Dim point As LocationPoint = TryCast(location, LocationPoint)

        message += vbLf + location.[GetType]().Name & " : "
        message += (("(" + point.Point.X & ", ") + point.Point.Y & ", ") + point.Point.Z & ")"
    Else
        Dim locCurve As LocationCurve = TryCast(location, LocationCurve)
        Dim curve As Curve = locCurve.Curve
        message += vbLf + location.[GetType]().Name & " : "
        message += (((vbLf & "Start Point : " & "(") + curve.GetEndPoint(0).X & ", ") + curve.GetEndPoint(0).Y & ", ") + curve.GetEndPoint(0).Z & ")"
        message += (((vbLf & "End point : " & "(") + curve.GetEndPoint(1).X & ", ") + curve.GetEndPoint(1).Y & ", ") + curve.GetEndPoint(1).Z & ")"
    End If

    TaskDialog.Show("Revit", message)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SpotDimension Properties

The SpotDimension type exposes the following members.

Properties
 | Name | Description
Public property | Above | The text shown above the segment's value. (Inherited from Dimension)
Public property | AreReferencesAvailable | Indicates if this dimension's references can be resolved. (Inherited from Dimension)
Public property | AreSegmentsEqual | Indicates if all segments are forced to be equal. (Inherited from Dimension)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | Below | The text shown below the segment's value. (Inherited from Dimension)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | Curve | A curve that represents the dimension line. (Inherited from Dimension)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | DimensionShape | The shape of this dimension. (Inherited from Dimension)
Public property | DimensionType | The dimension style of this dimension. (Inherited from Dimension)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyLabel | The family parameter label of the dimension. (Inherited from Dimension)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HasLeader | True if dimension has leader, false otherwise. (Inherited from Dimension)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsLocked | Indicates if this dimension is locked. (Inherited from Dimension)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValid | Indicates if this dimension is valid. (Inherited from Dimension)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LeaderEndPosition | The position of the dimension's leader end point. (Inherited from Dimension)
Public property | LeaderHasShoulder | True is dimension has leader with shoulder, false otherwise.
Public property | LeaderShoulderPosition | Position of spot dimension's leader shoulder point.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Retrieves or changes the name associated with the Dimension. (Inherited from Dimension)
Public property | NumberOfSegments | The number of segments for the dimension. (Inherited from Dimension)
Public property | Origin | The dimension origin. (Inherited from Dimension)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Prefix | The text shown before the segment's value. (Inherited from Dimension)
Public property | References | Returns an array of geometric references to which the dimension is attached. (Inherited from Dimension)
Public property | Segments | The segments in the dimension. (Inherited from Dimension)
Public property | SpotDimensionType | The dimension style of this dimension.
Public property | Suffix | The text shown after the segment's value. (Inherited from Dimension)
 | TextPosition | The position of the dimension text's drag point. (Inherited from Dimension)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | Value | The value of the dimension. (Inherited from Dimension)
Public property | ValueOverride | The text that replaces the segment's value. (Inherited from Dimension)
Public property | ValueString | The dimension value as a user visible string. (Inherited from Dimension)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | View | Supplies the view that contains the dimension if the dimension is view specific. (Inherited from Dimension)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

SpotDimension Class


SpotDimension.LeaderHasShoulder Property

SpotDimensionLeaderHasShoulder Property

True is dimension has leader with shoulder, false otherwise.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool LeaderHasShoulder { get; set; }
Public Property LeaderHasShoulder As Boolean
    Get
    Set
public:
property bool LeaderHasShoulder {
    bool get ();
    void set (bool value);
}
member LeaderHasShoulder : bool with get, set

Property Value

Boolean
Exceptions
Exception Condition
InvalidOperationException Dimension must have leader. -or- Thrown when:
  • SpotDimension style type is SpotSlope.
  • Using equality formula.
  • Dimension style is ordinate.
-or- The dimension is a SpotSlope or has no leader.
See Also

Reference

SpotDimension Class


SpotDimension.LeaderShoulderPosition Property

SpotDimensionLeaderShoulderPosition Property

Position of spot dimension's leader shoulder point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ LeaderShoulderPosition { get; set; }
Public Property LeaderShoulderPosition As XYZ
    Get
    Set
public:
property XYZ^ LeaderShoulderPosition {
    XYZ^ get ();
    void set (XYZ^ value);
}
member LeaderShoulderPosition : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
InvalidOperationException Dimension must have leader. -or- Dimension's leader must have shoulder. -or- Thrown when:
  • SpotDimension style type is SpotSlope.
  • Using equality formula.
  • Dimension style is ordinate.
-or- The dimension is a SpotSlope or has no leader or leader has no shoulder.
Remarks
Setting of this property also affects LeaderEndPosition and TextPosition.
See Also

Reference

SpotDimension Class


SpotDimension.SpotDimensionType Property

SpotDimensionSpotDimensionType Property

The dimension style of this dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SpotDimensionType SpotDimensionType { get; set; }
Public Property SpotDimensionType As SpotDimensionType
    Get
    Set
public:
property SpotDimensionType^ SpotDimensionType {
    SpotDimensionType^ get ();
    void set (SpotDimensionType^ value);
}
member SpotDimensionType : SpotDimensionType with get, set

Property Value

SpotDimensionType
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

SpotDimension Class


SpotDimension Methods

The SpotDimension type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanFlip | Verifies that the direction of the dimension can be flipped.
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | Flip | Flips dimension to the other side of the host.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasOneSegment | Determines whether a dimension has one segment. (Inherited from Dimension)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsTextPositionAdjustable | Indicates if this dimension is supported to set/get TextPosition/LeaderEndPosition. (Inherited from Dimension)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | ResetTextPosition | Resets the text position of the dimension to the initial position determined by its type and parameters. (Inherited from Dimension)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SpotDimension Class


SpotDimension.CanFlip Method

SpotDimensionCanFlip Method

Verifies that the direction of the dimension can be flipped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanFlip()
Public Function CanFlip As Boolean
public:
bool CanFlip()
member CanFlip : unit -> bool

Return Value

Boolean
True if the element can be flipped, false otherwise.
Remarks
Currently, flipping only allowed for non-pinned AlignmentStationLabels.
See Also

Reference

SpotDimension Class


SpotDimension.Flip Method

SpotDimensionFlip Method

Flips dimension to the other side of the host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Flip()
Public Sub Flip
public:
void Flip()
member Flip : unit -> unit
Exceptions
Exception | Condition
InvalidOperationException | SpotDimension cannot be flipped.
See Also

Reference

SpotDimension Class


SpotDimensionType Class

A type element containing the properties of a spot elevation.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBDimensionType
Autodesk.Revit.DBSpotDimensionType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SpotDimensionType : DimensionType
Public Class SpotDimensionType
    Inherits DimensionType
public ref class SpotDimensionType : public DimensionType
type SpotDimensionType =
    class
        inherit DimensionType
    end

The SpotDimensionType type exposes the following members.

Properties
 | Name | Description
Public property | AlternateUnits | The alternate units display mode for this DimensionType. (Inherited from DimensionType)
Public property | AlternateUnitsPrefix | The prefix text for the alternate units value. (Inherited from DimensionType)
Public property | AlternateUnitsSuffix | The suffix text for the alternate units value. (Inherited from DimensionType)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Prefix | The prefix text for the dimension value. (Inherited from DimensionType)
Public property | StyleType | The dimension style type of this DimensionType. (Inherited from DimensionType)
Public property | Suffix | The suffix text for the dimension value. (Inherited from DimensionType)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveEqualityFormula | Checks whether this DimensionType can have an equality formula. (Inherited from DimensionType)
Public method | CanHaveOrdinateDimensionSetting | Checks whether this DimensionType can have an ordinate dimension settings. (Inherited from DimensionType)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAlternateUnitsFormatOptions | Gets the FormatOptions to optionally override the default settings in the Units class for the alternate units value. (Inherited from DimensionType)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetEqualityFormula | Gets an ordered list of the entries in the equality formula definition. (Inherited from DimensionType)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetOrdinateDimensionSetting | Gets the ordinate dimension settings for this DimensionType. (Inherited from DimensionType)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSpecTypeId | Gets the spec of this dimension style. (Inherited from DimensionType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetUnitsFormatOptions | Gets the FormatOptions to optionally override the default settings in the Units class for the units value. (Inherited from DimensionType)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetAlternateUnitsFormatOptions | Sets the FormatOptions to optionally override the default settings in the Units class for the alternate units value. (Inherited from DimensionType)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetEqualityFormula | Sets an ordered list of the entries to use in the equality formula definition. (Inherited from DimensionType)
Public method | SetOrdinateDimensionSetting | Sets the ordinate dimension settings for this DimensionType. (Inherited from DimensionType)
Public method | SetUnitsFormatOptions | Sets the FormatOptions to optionally override the default settings in the Units class for the units value. (Inherited from DimensionType)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SpotDimensionType Properties

The SpotDimensionType type exposes the following members.

Properties
 | Name | Description
Public property | AlternateUnits | The alternate units display mode for this DimensionType. (Inherited from DimensionType)
Public property | AlternateUnitsPrefix | The prefix text for the alternate units value. (Inherited from DimensionType)
Public property | AlternateUnitsSuffix | The suffix text for the alternate units value. (Inherited from DimensionType)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Prefix | The prefix text for the dimension value. (Inherited from DimensionType)
Public property | StyleType | The dimension style type of this DimensionType. (Inherited from DimensionType)
Public property | Suffix | The suffix text for the dimension value. (Inherited from DimensionType)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

SpotDimensionType Class


SpotDimensionType Methods

The SpotDimensionType type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveEqualityFormula | Checks whether this DimensionType can have an equality formula. (Inherited from DimensionType)
Public method | CanHaveOrdinateDimensionSetting | Checks whether this DimensionType can have an ordinate dimension settings. (Inherited from DimensionType)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAlternateUnitsFormatOptions | Gets the FormatOptions to optionally override the default settings in the Units class for the alternate units value. (Inherited from DimensionType)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetEqualityFormula | Gets an ordered list of the entries in the equality formula definition. (Inherited from DimensionType)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetOrdinateDimensionSetting | Gets the ordinate dimension settings for this DimensionType. (Inherited from DimensionType)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSpecTypeId | Gets the spec of this dimension style. (Inherited from DimensionType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetUnitsFormatOptions | Gets the FormatOptions to optionally override the default settings in the Units class for the units value. (Inherited from DimensionType)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetAlternateUnitsFormatOptions | Sets the FormatOptions to optionally override the default settings in the Units class for the alternate units value. (Inherited from DimensionType)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetEqualityFormula | Sets an ordered list of the entries to use in the equality formula definition. (Inherited from DimensionType)
Public method | SetOrdinateDimensionSetting | Sets the ordinate dimension settings for this DimensionType. (Inherited from DimensionType)
Public method | SetUnitsFormatOptions | Sets the FormatOptions to optionally override the default settings in the Units class for the units value. (Inherited from DimensionType)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SpotDimensionType Class


SSEPointVisibilitySettings Class

Represents the settings contained in the document associated to the point display of Floor, Roof and Toposolid. for serialization public api methods
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBSSEPointVisibilitySettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SSEPointVisibilitySettings : Element
Public Class SSEPointVisibilitySettings
    Inherits Element
public ref class SSEPointVisibilitySettings : public Element
type SSEPointVisibilitySettings =
    class
        inherit Element
    end

The SSEPointVisibilitySettings type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
 | GetVisibility | Gets the SSE point visibility for the given category.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
 | SetVisibility | Sets the SSE point visibility for the given category.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SSEPointVisibilitySettings Properties

The SSEPointVisibilitySettings type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

SSEPointVisibilitySettings Class


SSEPointVisibilitySettings Methods

The SSEPointVisibilitySettings type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
 | GetVisibility | Gets the SSE point visibility for the given category.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
 | SetVisibility | Sets the SSE point visibility for the given category.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SSEPointVisibilitySettings Class


SSEPointVisibilitySettings.GetVisibility Method

SSEPointVisibilitySettingsGetVisibility Method

Gets the SSE point visibility for the given category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool GetVisibility(
    Document document,
    ElementId categoryId
)
Public Shared Function GetVisibility (
    document As Document,
    categoryId As ElementId
) As Boolean
public:
static bool GetVisibility(
    Document^ document,
    ElementId^ categoryId
)
static member GetVisibility :
        document : Document *
        categoryId : ElementId -> bool

Parameters

document Document
The document.
categoryId ElementId
The category id.

Return Value

Boolean
The visibility of the given category. True means the SSE points are visible.
Exceptions
Exception | Condition
ArgumentException | The category is not valid for SSE.
ArgumentNullException | A non-optional argument was null
See Also

Reference

SSEPointVisibilitySettings Class


SSEPointVisibilitySettings.SetVisibility Method

SSEPointVisibilitySettingsSetVisibility Method

Sets the SSE point visibility for the given category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void SetVisibility(
    Document document,
    ElementId categoryId,
    bool isVisible
)
Public Shared Sub SetVisibility (
    document As Document,
    categoryId As ElementId,
    isVisible As Boolean
)
public:
static void SetVisibility(
    Document^ document,
    ElementId^ categoryId,
    bool isVisible
)
static member SetVisibility :
        document : Document *
        categoryId : ElementId *
        isVisible : bool -> unit

Parameters

document Document
The document.
categoryId ElementId
The category id.
isVisible Boolean
The visibility of the given category. True means the SSE points are visible.
Exceptions
Exception | Condition
ArgumentException | The category is not valid for SSE.
ArgumentNullException | A non-optional argument was null
See Also

Reference

SSEPointVisibilitySettings Class


StairsEditScope Class

StairsEditScope allows user to maintain a stairs-editing session.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBEditScope
Autodesk.Revit.DBStairsEditScope

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class StairsEditScope : EditScope
Public Class StairsEditScope
    Inherits EditScope
public ref class StairsEditScope : public EditScope
type StairsEditScope =
    class
        inherit EditScope
    end

The StairsEditScope type exposes the following members.

Constructors
 | Name | Description
Public method | StairsEditScope | Instantiates a StairsEditScope object.
Top
Properties
 | Name | Description
Public property | IsActive | Tells if the EditScope is active. In other words, the EditScope has started but not committed/canceled yet. (Inherited from EditScope)
Public property | IsPermitted | Tells if the edit scope is permitted to start. (Inherited from EditScope)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from EditScope)
Top
Methods
 | Name | Description
Public method | Cancel | Cancels the edit scope. (Inherited from EditScope)
Public method | Commit | Finishes the edit scope. (Inherited from EditScope)
Public method | Dispose | (Inherited from EditScope)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Start(ElementId) | Starts an stairs edit mode for an existing Stairs element
Public method | Start(ElementId, ElementId) | Creates a new empty stairs element with a default stairs type in the specified levels and then starts stairs edit mode and editing the new stairs.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Start/end of a StairsEditScope will start/end a transaction group. After a StairsEditScope is started, user can start transactions and edit the stairs. Individual transactions the user creates inside StairsEditScope will not appear in the undo menu. All transactions committed during the edit mode will be merged into a single one which will bear the given name passed into StairsEditScope constructor.
Example
C#
VB
C++
F#
Copy
private ElementId CreateStairs(Document document, Level levelBottom, Level levelTop)
{
    ElementId newStairsId = null;

    using (StairsEditScope newStairsScope = new StairsEditScope(document, "New Stairs"))
    {
        newStairsId = newStairsScope.Start(levelBottom.Id, levelTop.Id);

        using (Transaction stairsTrans = new Transaction(document, "Add Runs and Landings to Stairs"))
        {
            stairsTrans.Start();

            // Create a sketched run for the stairs
            IList<Curve> bdryCurves = new List<Curve>();
            IList<Curve> riserCurves = new List<Curve>();
            IList<Curve> pathCurves = new List<Curve>();
            XYZ pnt1 = new XYZ(0, 0, 0);
            XYZ pnt2 = new XYZ(15, 0, 0);
            XYZ pnt3 = new XYZ(0, 10, 0);
            XYZ pnt4 = new XYZ(15, 10, 0);

            // boundaries
            bdryCurves.Add(Line.CreateBound(pnt1, pnt2));
            bdryCurves.Add(Line.CreateBound(pnt3, pnt4));

            // riser curves
            const int riserNum = 20;
            for (int ii = 0; ii <= riserNum; ii++)
            {
                XYZ end0 = (pnt1 + pnt2) * ii / (double)riserNum;
                XYZ end1 = (pnt3 + pnt4) * ii / (double)riserNum;
                XYZ end2 = new XYZ(end1.X, 10, 0);
                riserCurves.Add(Line.CreateBound(end0, end2));
            }

            //stairs path curves
            XYZ pathEnd0 = (pnt1 + pnt3) / 2.0;
            XYZ pathEnd1 = (pnt2 + pnt4) / 2.0;
            pathCurves.Add(Line.CreateBound(pathEnd0, pathEnd1));

            StairsRun newRun1 = StairsRun.CreateSketchedRun(document, newStairsId, levelBottom.Elevation, bdryCurves, riserCurves, pathCurves);

            // Add a straight run
            Line locationLine = Line.CreateBound(new XYZ(20, -5, newRun1.TopElevation), new XYZ(35, -5, newRun1.TopElevation));
            StairsRun newRun2 = StairsRun.CreateStraightRun(document, newStairsId, locationLine, StairsRunJustification.Center);
            newRun2.ActualRunWidth = 10;

            // Add a landing between the runs
            CurveLoop landingLoop = new CurveLoop();
            XYZ p1 = new XYZ(15, 10, 0);
            XYZ p2 = new XYZ(20, 10, 0);
            XYZ p3 = new XYZ(20, -10, 0);
            XYZ p4 = new XYZ(15, -10, 0);
            Line curve_1 = Line.CreateBound(p1, p2);
            Line curve_2 = Line.CreateBound(p2, p3);
            Line curve_3 = Line.CreateBound(p3, p4);
            Line curve_4 = Line.CreateBound(p4, p1);

            landingLoop.Append(curve_1);
            landingLoop.Append(curve_2);
            landingLoop.Append(curve_3);
            landingLoop.Append(curve_4);
            StairsLanding newLanding = StairsLanding.CreateSketchedLanding(document, newStairsId, landingLoop, newRun1.TopElevation);

            stairsTrans.Commit();
        }
        // A failure preprocessor is to handle possible failures during the edit mode commitment process.
        newStairsScope.Commit(new StairsFailurePreprocessor());
    }

    return newStairsId;
}
Private Function CreateStairs(document As Document, levelBottom As Level, levelTop As Level) As ElementId
    Dim newStairsId As ElementId = Nothing

    Using newStairsScope As New StairsEditScope(document, "New Stairs")
        newStairsId = newStairsScope.Start(levelBottom.Id, levelTop.Id)

        Using stairsTrans As New Transaction(document, "Add Runs and Landings to Stairs")
            stairsTrans.Start()

            ' Create a sketched run for the stairs
            Dim bdryCurves As IList(Of Curve) = New List(Of Curve)()
            Dim riserCurves As IList(Of Curve) = New List(Of Curve)()
            Dim pathCurves As IList(Of Curve) = New List(Of Curve)()
            Dim pnt1 As New XYZ(0, 0, 0)
            Dim pnt2 As New XYZ(15, 0, 0)
            Dim pnt3 As New XYZ(0, 10, 0)
            Dim pnt4 As New XYZ(15, 10, 0)

            ' boundaries
            bdryCurves.Add(Line.CreateBound(pnt1, pnt2))
            bdryCurves.Add(Line.CreateBound(pnt3, pnt4))

            ' riser curves
            Const riserNum As Integer = 20
            For ii As Integer = 0 To riserNum
                Dim end0 As XYZ = (pnt1 + pnt2) * ii / CDbl(riserNum)
                Dim end1 As XYZ = (pnt3 + pnt4) * ii / CDbl(riserNum)
                Dim end2 As New XYZ(end1.X, 10, 0)
                riserCurves.Add(Line.CreateBound(end0, end2))
            Next

            'stairs path curves
            Dim pathEnd0 As XYZ = (pnt1 + pnt3) / 2.0
            Dim pathEnd1 As XYZ = (pnt2 + pnt4) / 2.0
            pathCurves.Add(Line.CreateBound(pathEnd0, pathEnd1))

            Dim newRun1 As StairsRun = StairsRun.CreateSketchedRun(document, newStairsId, levelBottom.Elevation, bdryCurves, riserCurves, pathCurves)

            ' Add a straight run
            Dim locationLine As Line = Line.CreateBound(New XYZ(20, -5, newRun1.TopElevation), New XYZ(35, -5, newRun1.TopElevation))
            Dim newRun2 As StairsRun = StairsRun.CreateStraightRun(document, newStairsId, locationLine, StairsRunJustification.Center)
            newRun2.ActualRunWidth = 10

            ' Add a landing between the runs
            Dim landingLoop As New CurveLoop()
            Dim p1 As New XYZ(15, 10, 0)
            Dim p2 As New XYZ(20, 10, 0)
            Dim p3 As New XYZ(20, -10, 0)
            Dim p4 As New XYZ(15, -10, 0)
            Dim curve_1 As Line = Line.CreateBound(p1, p2)
            Dim curve_2 As Line = Line.CreateBound(p2, p3)
            Dim curve_3 As Line = Line.CreateBound(p3, p4)
            Dim curve_4 As Line = Line.CreateBound(p4, p1)

            landingLoop.Append(curve_1)
            landingLoop.Append(curve_2)
            landingLoop.Append(curve_3)
            landingLoop.Append(curve_4)
            Dim newLanding As StairsLanding = StairsLanding.CreateSketchedLanding(document, newStairsId, landingLoop, newRun1.TopElevation)

            stairsTrans.Commit()
        End Using
        ' A failure preprocessor is to handle possible failures during the edit mode commitment process.
        newStairsScope.Commit(New StairsFailurePreprocessor())
    End Using

    Return newStairsId
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


StairsEditScope Constructor

Instantiates a StairsEditScope object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public StairsEditScope(
    Document document,
    string transactionName
)
Public Sub New (
    document As Document,
    transactionName As String
)
public:
StairsEditScope(
    Document^ document,
    String^ transactionName
)
new :
        document : Document *
        transactionName : string -> StairsEditScope

Parameters

document Document
The document for which this StairsEditScope is going to be used.
transactionName String
The name that will appear in the Undo menu in Revit after the StairsEditScope is successfully committed.
Exceptions
Exception | Condition
ArgumentException | document is not a primary document, it is a linked document. -or- document is not a project document. -or- transactionName is an empty string.
ArgumentNullException | A non-optional argument was null
See Also

Reference

StairsEditScope Class


StairsEditScope Properties

The StairsEditScope type exposes the following members.

Properties
 | Name | Description
Public property | IsActive | Tells if the EditScope is active. In other words, the EditScope has started but not committed/canceled yet. (Inherited from EditScope)
Public property | IsPermitted | Tells if the edit scope is permitted to start. (Inherited from EditScope)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from EditScope)
Top
See Also

Reference

StairsEditScope Class


StairsEditScope Methods

The StairsEditScope type exposes the following members.

Methods
 | Name | Description
Public method | Cancel | Cancels the edit scope. (Inherited from EditScope)
Public method | Commit | Finishes the edit scope. (Inherited from EditScope)
Public method | Dispose | (Inherited from EditScope)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Start(ElementId) | Starts an stairs edit mode for an existing Stairs element
Public method | Start(ElementId, ElementId) | Creates a new empty stairs element with a default stairs type in the specified levels and then starts stairs edit mode and editing the new stairs.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

StairsEditScope Class


StairsEditScope.Start Method

StairsEditScopeStart Method

Overload List
 | Name | Description
Public method | Start(ElementId) | Starts an stairs edit mode for an existing Stairs element
Public method | Start(ElementId, ElementId) | Creates a new empty stairs element with a default stairs type in the specified levels and then starts stairs edit mode and editing the new stairs.
Top
See Also

Reference

StairsEditScope Class


StairsEditScope.Start(ElementId) Method

StairsEditScopeStart(ElementId) Method

Starts an stairs edit mode for an existing Stairs element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId Start(
    ElementId stairsId
)
Public Function Start (
    stairsId As ElementId
) As ElementId
public:
ElementId^ Start(
    ElementId^ stairsId
)
member Start :
        stairsId : ElementId -> ElementId

Parameters

stairsId ElementId
The stairs element to be edited.

Return Value

ElementId
ElementId of the editing stairs. It should be the same as the input stairsId
Exceptions
Exception | Condition
ArgumentException | It is not a Stair's id. -or- Stairs is not permitted to edit at this moment for the following reason: The Stairs is in an ElementGroup and it is not in Edit Group Mode.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This StairsEditScope is not permitted to start at this moment for one of the following possible reasons: The document is in read-only state, or the document is currently modifiable, or there already is another edit mode active in the document.
Remarks
User will need to start a transaction to actually make changes to the stairs element. StairsEditScope can only be started when there is no transaction active Thus it does not work for commands running in automatic transaction mode.
See Also

Reference

StairsEditScope Class
Start Overload


StairsEditScope.Start(ElementId, ElementId) Method

StairsEditScopeStart(ElementId, ElementId) Method

Creates a new empty stairs element with a default stairs type in the specified levels and then starts stairs edit mode and editing the new stairs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId Start(
    ElementId baseLevelId,
    ElementId topLevelId
)
Public Function Start (
    baseLevelId As ElementId,
    topLevelId As ElementId
) As ElementId
public:
ElementId^ Start(
    ElementId^ baseLevelId,
    ElementId^ topLevelId
)
member Start :
        baseLevelId : ElementId *
        topLevelId : ElementId -> ElementId

Parameters

baseLevelId ElementId
The base level on which the stairs is to be placed.
topLevelId ElementId
The top level where the stairs is to reach.

Return Value

ElementId
ElementId of the new stairs.
Exceptions
Exception | Condition
ArgumentException | It is not a Level's id. -or- Top level should be higher than base level.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This StairsEditScope is not permitted to start at this moment for one of the following possible reasons: The document is in read-only state, or the document is currently modifiable, or there already is another edit mode active in the document.
Remarks
A new stairs will be created after this operation. User will need to start a transaction to actually make changes to the stairs element. StairsEditScope can only be started when there is no transaction active Thus it does not work for commands running in automatic transaction mode.
See Also

Reference

StairsEditScope Class
Start Overload


StartingViewSettings Class

The initial view settings for a document dictate which view will initially be open when this model is opened. These settings are available for all Revit project documents.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBStartingViewSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class StartingViewSettings : Element
Public Class StartingViewSettings
    Inherits Element
public ref class StartingViewSettings : public Element
type StartingViewSettings =
    class
        inherit Element
    end

The StartingViewSettings type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewId | Indicates the specific view that will be opened when the model is loaded. InvalidElementId indicates that no view has been specified. In that case, Revit will open the last views that were open at the time the file was saved.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
 | GetStartingViewSettings | Returns the starting view settings for the specified document.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsAcceptableStartingView | Checks whether the given Id is an acceptable starting view. InvalidElementId corresponds to "Last Viewed" and is therefore also acceptable.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
If worksharing is enabled, the same settings will be used by the central model and all local files and the settings will live in the Project Info workset.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


StartingViewSettings Properties

The StartingViewSettings type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewId | Indicates the specific view that will be opened when the model is loaded. InvalidElementId indicates that no view has been specified. In that case, Revit will open the last views that were open at the time the file was saved.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

StartingViewSettings Class


StartingViewSettings.ViewId Property

StartingViewSettingsViewId Property

Indicates the specific view that will be opened when the model is loaded. InvalidElementId indicates that no view has been specified. In that case, Revit will open the last views that were open at the time the file was saved.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId ViewId { get; set; }
Public Property ViewId As ElementId
    Get
    Set
public:
property ElementId^ ViewId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member ViewId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentException | When setting this property: viewId is not an acceptable starting view for this model.
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
Note that InvalidElementId will cause Revit to open the same view it would have used in Revit 2011 and prior releases.
See Also

Reference

StartingViewSettings Class


StartingViewSettings Methods

The StartingViewSettings type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
 | GetStartingViewSettings | Returns the starting view settings for the specified document.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsAcceptableStartingView | Checks whether the given Id is an acceptable starting view. InvalidElementId corresponds to "Last Viewed" and is therefore also acceptable.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

StartingViewSettings Class


StartingViewSettings.GetStartingViewSettings Method

StartingViewSettingsGetStartingViewSettings Method

Returns the starting view settings for the specified document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static StartingViewSettings GetStartingViewSettings(
    Document doc
)
Public Shared Function GetStartingViewSettings (
    doc As Document
) As StartingViewSettings
public:
static StartingViewSettings^ GetStartingViewSettings(
    Document^ doc
)
static member GetStartingViewSettings :
        doc : Document -> StartingViewSettings

Parameters

doc Document
The document to get the settings from, which must be a project document.

Return Value

StartingViewSettings
The starting view settings for the document.
Exceptions
Exception | Condition
ArgumentException | doc is not a project document.
ArgumentNullException | A non-optional argument was null
See Also

Reference

StartingViewSettings Class


StartingViewSettings.IsAcceptableStartingView Method

StartingViewSettingsIsAcceptableStartingView Method

Checks whether the given Id is an acceptable starting view. InvalidElementId corresponds to "Last Viewed" and is therefore also acceptable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsAcceptableStartingView(
    ElementId viewId
)
Public Function IsAcceptableStartingView (
    viewId As ElementId
) As Boolean
public:
bool IsAcceptableStartingView(
    ElementId^ viewId
)
member IsAcceptableStartingView :
        viewId : ElementId -> bool

Parameters

viewId ElementId
The Id of the element to check.

Return Value

Boolean
True if the view is acceptable, False if it is not.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Model views (such as plans, ceiling plans, sections, elevations, and 3d views) are acceptable. In addition, drafting views, sheets, legends, schedules, and graphical column schedules are generally acceptable. Special views such as the project browser, system navigator, reports, revision schedules, internal schedules, sheets that are not actually in use, and views that belong to a family are not acceptable.
See Also

Reference

StartingViewSettings Class


StdPostedWarning Class

Support for Reviewable Warnings sent from AddOn.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBStdPostedWarning

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class StdPostedWarning : IDisposable
Public Class StdPostedWarning
    Implements IDisposable
public ref class StdPostedWarning : IDisposable
type StdPostedWarning =
    class
        interface IDisposable
    end

The StdPostedWarning type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the StdPostedWarning
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Used to create and send Reviewable Warning from AddOn.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


StdPostedWarning Properties

The StdPostedWarning type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

StdPostedWarning Class


StdPostedWarning.IsValidObject Property

StdPostedWarningIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

StdPostedWarning Class


StdPostedWarning Methods

The StdPostedWarning type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

StdPostedWarning Class


StdPostedWarning.Dispose Method

StdPostedWarningDispose Method

Releases all resources used by the StdPostedWarning

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

StdPostedWarning Class


STEPApplicationProtocol Enumeration

An enumeration for STEP Application Protocols.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum STEPApplicationProtocol
Public Enumeration STEPApplicationProtocol
public enum class STEPApplicationProtocol
type STEPApplicationProtocol
Members
Member name | Value | Description
ApplicationProtocol203 | 0 | Configuration Controlled Design Protocol 203.
ApplicationProtocol214 | 1 | Automotive Design Protocol 214.
ApplicationProtocol242 | 2 | Managed Model Based 3D Engineering, Includes Product Manufacturing Information Protocol 242.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


STEPExportOptions Class

The export options used by exporting STEP format file.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBIMExportOptions
Autodesk.Revit.DBSTEPExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class STEPExportOptions : BIMExportOptions
Public Class STEPExportOptions
    Inherits BIMExportOptions
public ref class STEPExportOptions : public BIMExportOptions
type STEPExportOptions =
    class
        inherit BIMExportOptions
    end

The STEPExportOptions type exposes the following members.

Constructors
 | Name | Description
Public method | STEPExportOptions | Constructs a new instance of STEPExportOptions with default values of all properties.
Top
Properties
 | Name | Description
Public property | ApplicationProtocol | The Application Protocol of the exported STEP file.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BIMExportOptions)
Public property | TargetUnit | The unit type of geometry in the resultant STEP file. Default value is ExportUnit::Default.
Public property | ViewId | The element id of the 3D view to export. InvalidElementId by default. (Inherited from BIMExportOptions)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from BIMExportOptions)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


STEPExportOptions Constructor

Constructs a new instance of STEPExportOptions with default values of all properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public STEPExportOptions()
Public Sub New
public:
STEPExportOptions()
new : unit -> STEPExportOptions
See Also

Reference

STEPExportOptions Class


STEPExportOptions Properties

The STEPExportOptions type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationProtocol | The Application Protocol of the exported STEP file.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BIMExportOptions)
Public property | TargetUnit | The unit type of geometry in the resultant STEP file. Default value is ExportUnit::Default.
Public property | ViewId | The element id of the 3D view to export. InvalidElementId by default. (Inherited from BIMExportOptions)
Top
See Also

Reference

STEPExportOptions Class


STEPExportOptions.ApplicationProtocol Property

STEPExportOptionsApplicationProtocol Property

The Application Protocol of the exported STEP file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public STEPApplicationProtocol ApplicationProtocol { get; set; }
Public Property ApplicationProtocol As STEPApplicationProtocol
    Get
    Set
public:
property STEPApplicationProtocol ApplicationProtocol {
    STEPApplicationProtocol get ();
    void set (STEPApplicationProtocol value);
}
member ApplicationProtocol : STEPApplicationProtocol with get, set

Property Value

STEPApplicationProtocol
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

STEPExportOptions Class


STEPExportOptions.TargetUnit Property

STEPExportOptionsTargetUnit Property

The unit type of geometry in the resultant STEP file. Default value is ExportUnit::Default.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportUnit TargetUnit { get; set; }
Public Property TargetUnit As ExportUnit
    Get
    Set
public:
property ExportUnit TargetUnit {
    ExportUnit get ();
    void set (ExportUnit value);
}
member TargetUnit : ExportUnit with get, set

Property Value

ExportUnit
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

STEPExportOptions Class


STEPExportOptions Methods

The STEPExportOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from BIMExportOptions)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

STEPExportOptions Class


STEPImportOptions Class

The import options used to import STEP format files.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBaseImportOptions
Autodesk.Revit.DBSTEPImportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class STEPImportOptions : BaseImportOptions
Public Class STEPImportOptions
    Inherits BaseImportOptions
public ref class STEPImportOptions : public BaseImportOptions
type STEPImportOptions =
    class
        inherit BaseImportOptions
    end

The STEPImportOptions type exposes the following members.

Constructors
 | Name | Description
Public method | STEPImportOptions | Constructs a new instance of STEPImportOptions with default values of all properties.
Public method | STEPImportOptions(STEPImportOptions) | Constructs a new instance of STEPImportOptions as a copy of the import options.
Top
Properties
 | Name | Description
Public property | AutoCorrectAlmostVHLines | Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines. (Inherited from BaseImportOptions)
Public property | ColorMode | Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors. (Inherited from BaseImportOptions)
Public property | CustomScale | Scaling the import. If this is defined and a valid value (> 0.0), it takes priority over units. (Inherited from BaseImportOptions)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BaseImportOptions)
Public property | OrientToView | Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false) (Inherited from BaseImportOptions)
Public property | Placement | Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates. (Inherited from BaseImportOptions)
Public property | ReferencePoint | The 3D point in the document where the imported instance will be inserted. If not explicitly set, the instance will be inserted at the document origin. (Inherited from BaseImportOptions)
Public property | ThisViewOnly | Imports drawings into the view that was passed into the import method. This option is not available in 3D views. (Inherited from BaseImportOptions)
Public property | Unit | The unit of measure for imported geometry. (Inherited from BaseImportOptions)
Public property | VisibleLayersOnly | Only import the visible layers. (Inherited from BaseImportOptions)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from BaseImportOptions)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetDefaultLengthUnit | Get the default length unit used for importing unitless files. (Inherited from BaseImportOptions)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLayerSelection | Get all set layers name which user want to import into Revit. (Inherited from BaseImportOptions)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetDefaultLengthUnit | Set the default length unit used for importing unitless files. (Inherited from BaseImportOptions)
Public method | SetLayerSelection | Set the layers name which user want to import into Revit. (Inherited from BaseImportOptions)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


STEPImportOptions Constructor

Overload List
 | Name | Description
Public method | STEPImportOptions | Constructs a new instance of STEPImportOptions with default values of all properties.
Public method | STEPImportOptions(STEPImportOptions) | Constructs a new instance of STEPImportOptions as a copy of the import options.
Top
See Also

Reference

STEPImportOptions Class


STEPImportOptions Constructor

Constructs a new instance of STEPImportOptions with default values of all properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public STEPImportOptions()
Public Sub New
public:
STEPImportOptions()
new : unit -> STEPImportOptions
See Also

Reference

STEPImportOptions Class
STEPImportOptions Overload


STEPImportOptions(STEPImportOptions) Constructor

Constructs a new instance of STEPImportOptions as a copy of the import options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public STEPImportOptions(
    STEPImportOptions option
)
Public Sub New (
    option As STEPImportOptions
)
public:
STEPImportOptions(
    STEPImportOptions^ option
)
new :
        option : STEPImportOptions -> STEPImportOptions

Parameters

option STEPImportOptions
The STEP options to be copied.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

STEPImportOptions Class
STEPImportOptions Overload


STEPImportOptions Properties

The STEPImportOptions type exposes the following members.

Properties
 | Name | Description
Public property | AutoCorrectAlmostVHLines | Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines. (Inherited from BaseImportOptions)
Public property | ColorMode | Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors. (Inherited from BaseImportOptions)
Public property | CustomScale | Scaling the import. If this is defined and a valid value (> 0.0), it takes priority over units. (Inherited from BaseImportOptions)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BaseImportOptions)
Public property | OrientToView | Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false) (Inherited from BaseImportOptions)
Public property | Placement | Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates. (Inherited from BaseImportOptions)
Public property | ReferencePoint | The 3D point in the document where the imported instance will be inserted. If not explicitly set, the instance will be inserted at the document origin. (Inherited from BaseImportOptions)
Public property | ThisViewOnly | Imports drawings into the view that was passed into the import method. This option is not available in 3D views. (Inherited from BaseImportOptions)
Public property | Unit | The unit of measure for imported geometry. (Inherited from BaseImportOptions)
Public property | VisibleLayersOnly | Only import the visible layers. (Inherited from BaseImportOptions)
Top
See Also

Reference

STEPImportOptions Class


STEPImportOptions Methods

The STEPImportOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from BaseImportOptions)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetDefaultLengthUnit | Get the default length unit used for importing unitless files. (Inherited from BaseImportOptions)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLayerSelection | Get all set layers name which user want to import into Revit. (Inherited from BaseImportOptions)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetDefaultLengthUnit | Set the default length unit used for importing unitless files. (Inherited from BaseImportOptions)
Public method | SetLayerSelection | Set the layers name which user want to import into Revit. (Inherited from BaseImportOptions)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

STEPImportOptions Class


StickSymbolLocation Enumeration

Indicates the stick symbol location on the UI, which is used for the BuiltInParameter STRUCTURAL_STICK_SYMBOL_LOCATION.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum StickSymbolLocation
Public Enumeration StickSymbolLocation
public enum class StickSymbolLocation
type StickSymbolLocation
Members
Member name | Value | Description
StickViewCenter | 0 |
StickViewTop | 1 |
StickViewBottom | 2 |
StickViewLocLine | 3 |
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


StiffenerClassification Enumeration

This enumeration is used to classify the stiffener.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum StiffenerClassification
Public Enumeration StiffenerClassification
public enum class StiffenerClassification
type StiffenerClassification
Members
Member name | Value | Description
External | 0 |
Internal | 1 |
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


STLExportOptions Class

The export options used by exporting STL format file.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBIMExportOptions
Autodesk.Revit.DBSTLExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class STLExportOptions : BIMExportOptions
Public Class STLExportOptions
    Inherits BIMExportOptions
public ref class STLExportOptions : public BIMExportOptions
type STLExportOptions =
    class
        inherit BIMExportOptions
    end

The STLExportOptions type exposes the following members.

Constructors
 | Name | Description
Public method | STLExportOptions | Constructs a new instance of STLExportOptions with default values of all properties.
Public method | STLExportOptions(ExportResolution) | Constructs a new instance of STLExportOptions with all predefined tessellation settings, depending on export resolution type. Note: in case of Custom resolution type, tessellation settings won't be predefined and will have default values.
Top
Properties
 | Name | Description
Public property | ExportBinary | True to export in binary STL format, false to export in ASCII STL format. Default value is true.
Public property | ExportColor | True to export color information, false otherwise. Default value is false.
Public property | GridAspectRatio | The maximum aspect ratio allowed in the grid placed across the face. The minimum allowed value is 1.0. The maximum allowed value is 10.0. By default this property is ignored.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BIMExportOptions)
Public property | MaxEdgeLength | The maximum length allowed for any chord on an edge or between any two adjacent grid lines. This is a percentage value. By exporting, the real value of maximum edge length is calculated as a percent from the length of the diameter of the body bounding box. The minimum allowed value is 0.1%. The maximum allowed value is 10.0%. By default this property is ignored.
Public property | NormalTolerance | The maximum change in the surface normal between adjacent nodes in the mesh. This property is defined in degrees. The minimum allowed value is 1.0 degrees. The maximum allowed value is 45.0 degrees. Default value is 15.0 degrees.
Public property | SurfaceTolerance | The maximum distance between mesh triangles and model geometry. This is a percentage value. By exporting, the real value of surface tolerance is calculated as a percent from the length of the diameter of the body bounding box. The minimum allowed value is 0.001%. The maximum allowed value is 1.0%. Default value is 0.1%.
Public property | TargetUnit | The unit type of geometry in the resultant STL file. Default value is ExportUnit::Default.
Public property | ViewId | The element id of the 3D view to export. InvalidElementId by default. (Inherited from BIMExportOptions)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from BIMExportOptions)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsGridAspectRatioSet | Checks whether the GridAspectRatio tessellation parameter is explicitly set.
Public method | IsMaxEdgeLengthSet | Checks whether the MaxEdgeLength tessellation parameter is explicitly set.
Public method | IsNormalToleranceSet | Checks whether the NormalTolerance tessellation parameter is explicitly set.
Public method | IsSurfaceToleranceSet | Checks whether the SurfaceTolerance tessellation parameter is explicitly set.
 | IsValidForGridAspectRatio | Checks whether the value is allowed (is in the allowed range) for GridAspectRatio tessellation parameter.
 | IsValidForMaxEdgeLength | Checks whether the value is allowed (is in the allowed range) for MaxEdgeLength tessellation parameter.
 | IsValidForNormalTolerance | Checks whether the value is allowed (is in the allowed range) for NormalTolerance tessellation parameter.
 | IsValidForSurfaceTolerance | Checks whether the value is allowed (is in the allowed range) for SurfaceTolerance tessellation parameter.
Public method | SetTessellationSettings | Sets all the tessellation parameters to its predefined values for the given resolution type.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


STLExportOptions Constructor

Overload List
 | Name | Description
Public method | STLExportOptions | Constructs a new instance of STLExportOptions with default values of all properties.
Public method | STLExportOptions(ExportResolution) | Constructs a new instance of STLExportOptions with all predefined tessellation settings, depending on export resolution type. Note: in case of Custom resolution type, tessellation settings won't be predefined and will have default values.
Top
See Also

Reference

STLExportOptions Class


STLExportOptions Constructor

Constructs a new instance of STLExportOptions with default values of all properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public STLExportOptions()
Public Sub New
public:
STLExportOptions()
new : unit -> STLExportOptions
See Also

Reference

STLExportOptions Class
STLExportOptions Overload


STLExportOptions(ExportResolution) Constructor

Constructs a new instance of STLExportOptions with all predefined tessellation settings, depending on export resolution type. Note: in case of Custom resolution type, tessellation settings won't be predefined and will have default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public STLExportOptions(
    ExportResolution resolutionType
)
Public Sub New (
    resolutionType As ExportResolution
)
public:
STLExportOptions(
    ExportResolution resolutionType
)
new :
        resolutionType : ExportResolution -> STLExportOptions

Parameters

resolutionType ExportResolution
The type of export resolution.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

STLExportOptions Class
STLExportOptions Overload


STLExportOptions Properties

The STLExportOptions type exposes the following members.

Properties
 | Name | Description
Public property | ExportBinary | True to export in binary STL format, false to export in ASCII STL format. Default value is true.
Public property | ExportColor | True to export color information, false otherwise. Default value is false.
Public property | GridAspectRatio | The maximum aspect ratio allowed in the grid placed across the face. The minimum allowed value is 1.0. The maximum allowed value is 10.0. By default this property is ignored.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BIMExportOptions)
Public property | MaxEdgeLength | The maximum length allowed for any chord on an edge or between any two adjacent grid lines. This is a percentage value. By exporting, the real value of maximum edge length is calculated as a percent from the length of the diameter of the body bounding box. The minimum allowed value is 0.1%. The maximum allowed value is 10.0%. By default this property is ignored.
Public property | NormalTolerance | The maximum change in the surface normal between adjacent nodes in the mesh. This property is defined in degrees. The minimum allowed value is 1.0 degrees. The maximum allowed value is 45.0 degrees. Default value is 15.0 degrees.
Public property | SurfaceTolerance | The maximum distance between mesh triangles and model geometry. This is a percentage value. By exporting, the real value of surface tolerance is calculated as a percent from the length of the diameter of the body bounding box. The minimum allowed value is 0.001%. The maximum allowed value is 1.0%. Default value is 0.1%.
Public property | TargetUnit | The unit type of geometry in the resultant STL file. Default value is ExportUnit::Default.
Public property | ViewId | The element id of the 3D view to export. InvalidElementId by default. (Inherited from BIMExportOptions)
Top
See Also

Reference

STLExportOptions Class


STLExportOptions.ExportBinary Property

STLExportOptionsExportBinary Property

True to export in binary STL format, false to export in ASCII STL format. Default value is true.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ExportBinary { get; set; }
Public Property ExportBinary As Boolean
    Get
    Set
public:
property bool ExportBinary {
    bool get ();
    void set (bool value);
}
member ExportBinary : bool with get, set

Property Value

Boolean
See Also

Reference

STLExportOptions Class


STLExportOptions.ExportColor Property

STLExportOptionsExportColor Property

True to export color information, false otherwise. Default value is false.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ExportColor { get; set; }
Public Property ExportColor As Boolean
    Get
    Set
public:
property bool ExportColor {
    bool get ();
    void set (bool value);
}
member ExportColor : bool with get, set

Property Value

Boolean
Remarks
Color information can be exported only in binary STL format, in the case of ASCII STL format this property will be ignored.
See Also

Reference

STLExportOptions Class


STLExportOptions.GridAspectRatio Property

STLExportOptionsGridAspectRatio Property

The maximum aspect ratio allowed in the grid placed across the face. The minimum allowed value is 1.0. The maximum allowed value is 10.0. By default this property is ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GridAspectRatio { get; set; }
Public Property GridAspectRatio As Double
    Get
    Set
public:
property double GridAspectRatio {
    double get ();
    void set (double value);
}
member GridAspectRatio : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The value gridAspectRatio is outside the allowable range of values for GridAspectRatio tessellation parameter.
InvalidOperationException | GridAspectRatio tessellation parameter is default (hasn't been explicitly set by the user) and cannot be obtained now.
Remarks
This property can be set by using export resolution type (by creation of STLExportOptions or using [!:Autodesk::Revit::DB::STLExportOptions::setTessellationSettings(ExportResolution::Enum)] method). In the case of Fine, Medium and Coarse resolutions, this property has the same value (10.0) and it is considered as explicitly set by the user. In the case of Custom resolution type, this property is only allowed to be obtained if it has been explicitly set.
See Also

Reference

STLExportOptions Class


STLExportOptions.MaxEdgeLength Property

STLExportOptionsMaxEdgeLength Property

The maximum length allowed for any chord on an edge or between any two adjacent grid lines. This is a percentage value. By exporting, the real value of maximum edge length is calculated as a percent from the length of the diameter of the body bounding box. The minimum allowed value is 0.1%. The maximum allowed value is 10.0%. By default this property is ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double MaxEdgeLength { get; set; }
Public Property MaxEdgeLength As Double
    Get
    Set
public:
property double MaxEdgeLength {
    double get ();
    void set (double value);
}
member MaxEdgeLength : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The value maxEdgeLength is outside the allowable range of values for MaxEdgeLength tessellation parameter.
InvalidOperationException | MaxEdgeLength tessellation parameter is default (hasn't been explicitly set by the user) and cannot be obtained now.
Remarks
This property can be set by using export resolution type (by creation of STLExportOptions or using [!:Autodesk::Revit::DB::STLExportOptions::setTessellationSettings(ExportResolution::Enum)] method). In the case of Fine, Medium and Coarse resolutions, this property has the same value (10.0%) and it is considered as explicitly set by the user. In the case of Custom resolution type, this property is only allowed to be obtained if it has been explicitly set.
See Also

Reference

STLExportOptions Class


STLExportOptions.NormalTolerance Property

STLExportOptionsNormalTolerance Property

The maximum change in the surface normal between adjacent nodes in the mesh. This property is defined in degrees. The minimum allowed value is 1.0 degrees. The maximum allowed value is 45.0 degrees. Default value is 15.0 degrees.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double NormalTolerance { get; set; }
Public Property NormalTolerance As Double
    Get
    Set
public:
property double NormalTolerance {
    double get ();
    void set (double value);
}
member NormalTolerance : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The value normalTolerance is outside the allowable range of values for NormalTolerance tessellation parameter.
InvalidOperationException | NormalTolerance tessellation parameter is default (hasn't been explicitly set by the user) and cannot be obtained now.
Remarks
This property can be set by using export resolution type (by creation of STLExportOptions or using [!:Autodesk::Revit::DB::STLExportOptions::setTessellationSettings(ExportResolution::Enum)] method). In the case of Fine (10.0 degrees), Medium (15.0 degrees) and Coarse (30.0 degrees) resolutions, this property is considered as explicitly set by the user. In the case of Custom resolution type, this property is only allowed to be obtained if it has been explicitly set.
See Also

Reference

STLExportOptions Class


STLExportOptions.SurfaceTolerance Property

STLExportOptionsSurfaceTolerance Property

The maximum distance between mesh triangles and model geometry. This is a percentage value. By exporting, the real value of surface tolerance is calculated as a percent from the length of the diameter of the body bounding box. The minimum allowed value is 0.001%. The maximum allowed value is 1.0%. Default value is 0.1%.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double SurfaceTolerance { get; set; }
Public Property SurfaceTolerance As Double
    Get
    Set
public:
property double SurfaceTolerance {
    double get ();
    void set (double value);
}
member SurfaceTolerance : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The value surfaceTolerance is outside the allowable range of values for SurfaceTolerance tessellation parameter.
InvalidOperationException | SurfaceTolerance tessellation parameter is default (hasn't been explicitly set by the user) and cannot be obtained now.
Remarks
This property can be set by using export resolution type (by creation of STLExportOptions or using [!:Autodesk::Revit::DB::STLExportOptions::setTessellationSettings(ExportResolution::Enum)] method). In the case of Fine (0.005%), Medium (0.016%) and Coarse (0.04%) resolutions, this property is considered as explicitly set by the user. In the case of Custom resolution type, this property is only allowed to be obtained if it has been explicitly set.
See Also

Reference

STLExportOptions Class


STLExportOptions.TargetUnit Property

STLExportOptionsTargetUnit Property

The unit type of geometry in the resultant STL file. Default value is ExportUnit::Default.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportUnit TargetUnit { get; set; }
Public Property TargetUnit As ExportUnit
    Get
    Set
public:
property ExportUnit TargetUnit {
    ExportUnit get ();
    void set (ExportUnit value);
}
member TargetUnit : ExportUnit with get, set

Property Value

ExportUnit
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

STLExportOptions Class


STLExportOptions Methods

The STLExportOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from BIMExportOptions)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsGridAspectRatioSet | Checks whether the GridAspectRatio tessellation parameter is explicitly set.
Public method | IsMaxEdgeLengthSet | Checks whether the MaxEdgeLength tessellation parameter is explicitly set.
Public method | IsNormalToleranceSet | Checks whether the NormalTolerance tessellation parameter is explicitly set.
Public method | IsSurfaceToleranceSet | Checks whether the SurfaceTolerance tessellation parameter is explicitly set.
 | IsValidForGridAspectRatio | Checks whether the value is allowed (is in the allowed range) for GridAspectRatio tessellation parameter.
 | IsValidForMaxEdgeLength | Checks whether the value is allowed (is in the allowed range) for MaxEdgeLength tessellation parameter.
 | IsValidForNormalTolerance | Checks whether the value is allowed (is in the allowed range) for NormalTolerance tessellation parameter.
 | IsValidForSurfaceTolerance | Checks whether the value is allowed (is in the allowed range) for SurfaceTolerance tessellation parameter.
Public method | SetTessellationSettings | Sets all the tessellation parameters to its predefined values for the given resolution type.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

STLExportOptions Class


STLExportOptions.IsGridAspectRatioSet Method

STLExportOptionsIsGridAspectRatioSet Method

Checks whether the GridAspectRatio tessellation parameter is explicitly set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsGridAspectRatioSet()
Public Function IsGridAspectRatioSet As Boolean
public:
bool IsGridAspectRatioSet()
member IsGridAspectRatioSet : unit -> bool

Return Value

Boolean
True if GridAspectRatio tessellation parameter is explicitly set, false otherwise.
See Also

Reference

STLExportOptions Class


STLExportOptions.IsMaxEdgeLengthSet Method

STLExportOptionsIsMaxEdgeLengthSet Method

Checks whether the MaxEdgeLength tessellation parameter is explicitly set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsMaxEdgeLengthSet()
Public Function IsMaxEdgeLengthSet As Boolean
public:
bool IsMaxEdgeLengthSet()
member IsMaxEdgeLengthSet : unit -> bool

Return Value

Boolean
True if MaxEdgeLength tessellation parameter is explicitly set, false otherwise.
See Also

Reference

STLExportOptions Class


STLExportOptions.IsNormalToleranceSet Method

STLExportOptionsIsNormalToleranceSet Method

Checks whether the NormalTolerance tessellation parameter is explicitly set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsNormalToleranceSet()
Public Function IsNormalToleranceSet As Boolean
public:
bool IsNormalToleranceSet()
member IsNormalToleranceSet : unit -> bool

Return Value

Boolean
True if NormalTolerance tessellation parameter is explicitly set, false otherwise.
See Also

Reference

STLExportOptions Class


STLExportOptions.IsSurfaceToleranceSet Method

STLExportOptionsIsSurfaceToleranceSet Method

Checks whether the SurfaceTolerance tessellation parameter is explicitly set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSurfaceToleranceSet()
Public Function IsSurfaceToleranceSet As Boolean
public:
bool IsSurfaceToleranceSet()
member IsSurfaceToleranceSet : unit -> bool

Return Value

Boolean
True if SurfaceTolerance tessellation parameter is explicitly set, false otherwise.
See Also

Reference

STLExportOptions Class


STLExportOptions.IsValidForGridAspectRatio Method

STLExportOptionsIsValidForGridAspectRatio Method

Checks whether the value is allowed (is in the allowed range) for GridAspectRatio tessellation parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidForGridAspectRatio(
    double value
)
Public Shared Function IsValidForGridAspectRatio (
    value As Double
) As Boolean
public:
static bool IsValidForGridAspectRatio(
    double value
)
static member IsValidForGridAspectRatio :
        value : float -> bool

Parameters

value Double
The value to be checked.

Return Value

Boolean
True if the value is valid for GridAspectRatio, false otherwise.
See Also

Reference

STLExportOptions Class


STLExportOptions.IsValidForMaxEdgeLength Method

STLExportOptionsIsValidForMaxEdgeLength Method

Checks whether the value is allowed (is in the allowed range) for MaxEdgeLength tessellation parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidForMaxEdgeLength(
    double value
)
Public Shared Function IsValidForMaxEdgeLength (
    value As Double
) As Boolean
public:
static bool IsValidForMaxEdgeLength(
    double value
)
static member IsValidForMaxEdgeLength :
        value : float -> bool

Parameters

value Double
The value to be checked.

Return Value

Boolean
True if the value is valid for MaxEdgeLength, false otherwise.
See Also

Reference

STLExportOptions Class


STLExportOptions.IsValidForNormalTolerance Method

STLExportOptionsIsValidForNormalTolerance Method

Checks whether the value is allowed (is in the allowed range) for NormalTolerance tessellation parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidForNormalTolerance(
    double value
)
Public Shared Function IsValidForNormalTolerance (
    value As Double
) As Boolean
public:
static bool IsValidForNormalTolerance(
    double value
)
static member IsValidForNormalTolerance :
        value : float -> bool

Parameters

value Double
The value to be checked.

Return Value

Boolean
True if the value is valid for NormalTolerance, false otherwise.
See Also

Reference

STLExportOptions Class


STLExportOptions.IsValidForSurfaceTolerance Method

STLExportOptionsIsValidForSurfaceTolerance Method

Checks whether the value is allowed (is in the allowed range) for SurfaceTolerance tessellation parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidForSurfaceTolerance(
    double value
)
Public Shared Function IsValidForSurfaceTolerance (
    value As Double
) As Boolean
public:
static bool IsValidForSurfaceTolerance(
    double value
)
static member IsValidForSurfaceTolerance :
        value : float -> bool

Parameters

value Double
The value to be checked.

Return Value

Boolean
True if the value is valid for SurfaceTolerance, false otherwise.
See Also

Reference

STLExportOptions Class


STLExportOptions.SetTessellationSettings Method

STLExportOptionsSetTessellationSettings Method

Sets all the tessellation parameters to its predefined values for the given resolution type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetTessellationSettings(
    ExportResolution resolutionType
)
Public Sub SetTessellationSettings (
    resolutionType As ExportResolution
)
public:
void SetTessellationSettings(
    ExportResolution resolutionType
)
member SetTessellationSettings :
        resolutionType : ExportResolution -> unit

Parameters

resolutionType ExportResolution
Type of exporting resolution.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

STLExportOptions Class


STLImportOptions Class

The import options used to import STL format files.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBBaseImportOptions
Autodesk.Revit.DBSTLImportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class STLImportOptions : BaseImportOptions
Public Class STLImportOptions
    Inherits BaseImportOptions
public ref class STLImportOptions : public BaseImportOptions
type STLImportOptions =
    class
        inherit BaseImportOptions
    end

The STLImportOptions type exposes the following members.

Constructors
 | Name | Description
Public method | STLImportOptions | Constructs a new instance of STLImportOptions with default values of all properties.
Public method | STLImportOptions(STLImportOptions) | Constructs a new instance of STLImportOptions as a copy of the import options.
Top
Properties
 | Name | Description
Public property | AutoCorrectAlmostVHLines | Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines. (Inherited from BaseImportOptions)
Public property | ColorMode | Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors. (Inherited from BaseImportOptions)
Public property | CustomScale | Scaling the import. If this is defined and a valid value (> 0.0), it takes priority over units. (Inherited from BaseImportOptions)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BaseImportOptions)
Public property | OrientToView | Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false) (Inherited from BaseImportOptions)
Public property | Placement | Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates. (Inherited from BaseImportOptions)
Public property | ReferencePoint | The 3D point in the document where the imported instance will be inserted. If not explicitly set, the instance will be inserted at the document origin. (Inherited from BaseImportOptions)
Public property | ThisViewOnly | Imports drawings into the view that was passed into the import method. This option is not available in 3D views. (Inherited from BaseImportOptions)
Public property | Unit | The unit of measure for imported geometry. (Inherited from BaseImportOptions)
Public property | VisibleLayersOnly | Only import the visible layers. (Inherited from BaseImportOptions)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from BaseImportOptions)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetDefaultLengthUnit | Get the default length unit used for importing unitless files. (Inherited from BaseImportOptions)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLayerSelection | Get all set layers name which user want to import into Revit. (Inherited from BaseImportOptions)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetDefaultLengthUnit | Set the default length unit used for importing unitless files. (Inherited from BaseImportOptions)
Public method | SetLayerSelection | Set the layers name which user want to import into Revit. (Inherited from BaseImportOptions)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


STLImportOptions Constructor

Overload List
 | Name | Description
Public method | STLImportOptions | Constructs a new instance of STLImportOptions with default values of all properties.
Public method | STLImportOptions(STLImportOptions) | Constructs a new instance of STLImportOptions as a copy of the import options.
Top
See Also

Reference

STLImportOptions Class


STLImportOptions Constructor

Constructs a new instance of STLImportOptions with default values of all properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public STLImportOptions()
Public Sub New
public:
STLImportOptions()
new : unit -> STLImportOptions
See Also

Reference

STLImportOptions Class
STLImportOptions Overload


STLImportOptions(STLImportOptions) Constructor

Constructs a new instance of STLImportOptions as a copy of the import options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public STLImportOptions(
    STLImportOptions option
)
Public Sub New (
    option As STLImportOptions
)
public:
STLImportOptions(
    STLImportOptions^ option
)
new :
        option : STLImportOptions -> STLImportOptions

Parameters

option STLImportOptions
The STL options to be copied.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

STLImportOptions Class
STLImportOptions Overload


STLImportOptions Properties

The STLImportOptions type exposes the following members.

Properties
 | Name | Description
Public property | AutoCorrectAlmostVHLines | Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines. (Inherited from BaseImportOptions)
Public property | ColorMode | Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors. (Inherited from BaseImportOptions)
Public property | CustomScale | Scaling the import. If this is defined and a valid value (> 0.0), it takes priority over units. (Inherited from BaseImportOptions)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from BaseImportOptions)
Public property | OrientToView | Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false) (Inherited from BaseImportOptions)
Public property | Placement | Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates. (Inherited from BaseImportOptions)
Public property | ReferencePoint | The 3D point in the document where the imported instance will be inserted. If not explicitly set, the instance will be inserted at the document origin. (Inherited from BaseImportOptions)
Public property | ThisViewOnly | Imports drawings into the view that was passed into the import method. This option is not available in 3D views. (Inherited from BaseImportOptions)
Public property | Unit | The unit of measure for imported geometry. (Inherited from BaseImportOptions)
Public property | VisibleLayersOnly | Only import the visible layers. (Inherited from BaseImportOptions)
Top
See Also

Reference

STLImportOptions Class


STLImportOptions Methods

The STLImportOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from BaseImportOptions)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetDefaultLengthUnit | Get the default length unit used for importing unitless files. (Inherited from BaseImportOptions)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLayerSelection | Get all set layers name which user want to import into Revit. (Inherited from BaseImportOptions)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetDefaultLengthUnit | Set the default length unit used for importing unitless files. (Inherited from BaseImportOptions)
Public method | SetLayerSelection | Set the layers name which user want to import into Revit. (Inherited from BaseImportOptions)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

STLImportOptions Class


StorageType Enumeration

An enumerated type listing all of the internal parameter data storage types that Autodesk Revit supports.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum StorageType
Public Enumeration StorageType
public enum class StorageType
type StorageType
Members
Member name | Value | Description
None | 0 | None represents an invalid storage type. This value should not be used.
Integer | 1 | The internal data is stored in the form of a signed 32 bit integer.
Double | 2 | The data will be stored internally in the form of an 8 byte floating point number.
String | 3 | The internal data will be stored in the form of a string of characters.
ElementId | 4 | The data type represents an element and is stored as the id of the element.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


StringParameterValue Class

A class that holds a String value of a parameter element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBParameterValue
Autodesk.Revit.DBStringParameterValue

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class StringParameterValue : ParameterValue
Public Class StringParameterValue
    Inherits ParameterValue
public ref class StringParameterValue : public ParameterValue
type StringParameterValue =
    class
        inherit ParameterValue
    end

The StringParameterValue type exposes the following members.

Constructors
 | Name | Description
Public method | StringParameterValue | Default constructor
Public method | StringParameterValue(String) | Value constructor
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ParameterValue)
Public property | Value | The stored value
Top
Methods
 | Name | Description
Public method | Copy | Makes an identical copy of the given parameter value. (Inherited from ParameterValue)
Public method | Dispose | (Inherited from ParameterValue)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqual | Tests equality with another instance of the same class. (Inherited from ParameterValue)
Public method | IsSameType | Tests another instance is of the same value type. (Inherited from ParameterValue)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


StringParameterValue Constructor

Overload List
 | Name | Description
Public method | StringParameterValue | Default constructor
Public method | StringParameterValue(String) | Value constructor
Top
See Also

Reference

StringParameterValue Class


StringParameterValue Constructor

Default constructor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public StringParameterValue()
Public Sub New
public:
StringParameterValue()
new : unit -> StringParameterValue
See Also

Reference

StringParameterValue Class
StringParameterValue Overload


StringParameterValue(String) Constructor

Value constructor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public StringParameterValue(
    string value
)
Public Sub New (
    value As String
)
public:
StringParameterValue(
    String^ value
)
new :
        value : string -> StringParameterValue

Parameters

value String
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

StringParameterValue Class
StringParameterValue Overload


StringParameterValue Properties

The StringParameterValue type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ParameterValue)
Public property | Value | The stored value
Top
See Also

Reference

StringParameterValue Class


StringParameterValue.Value Property

StringParameterValueValue Property

The stored value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}
member Value : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

StringParameterValue Class


StringParameterValue Methods

The StringParameterValue type exposes the following members.

Methods
 | Name | Description
Public method | Copy | Makes an identical copy of the given parameter value. (Inherited from ParameterValue)
Public method | Dispose | (Inherited from ParameterValue)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqual | Tests equality with another instance of the same class. (Inherited from ParameterValue)
Public method | IsSameType | Tests another instance is of the same value type. (Inherited from ParameterValue)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

StringParameterValue Class


StripedRowPattern Enumeration

An enumerated type representing the possible sets of rows of a striped row schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum StripedRowPattern
Public Enumeration StripedRowPattern
public enum class StripedRowPattern
type StripedRowPattern
Members
Member name | Value | Description
FirstRow | 0 | The first row and every other row thereafter.
SecondRow | 1 | The second row and every other row thereafter.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


StructDeckEmbeddingType Enumeration

Used in class CompoundStructure to specify the usage of a layer whose function is StructuralDeck.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum StructDeckEmbeddingType
Public Enumeration StructDeckEmbeddingType
public enum class StructDeckEmbeddingType
type StructDeckEmbeddingType
Members
Member name | Value | Description
MergeWithLayerAbove | 0 | Bound layer above.
Standalone | 1 | Standalone deck.
Invalid | -1 | Invalid usage.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


StructuralAsset Class

Represents the properties of a material pertinent to structural analysis.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBStructuralAsset

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class StructuralAsset : IDisposable
Public Class StructuralAsset
    Implements IDisposable
public ref class StructuralAsset : IDisposable
type StructuralAsset =
    class
        interface IDisposable
    end

The StructuralAsset type exposes the following members.

Constructors
 | Name | Description
Public method | StructuralAsset | Constructs an instance of StructuralAsset.
Top
Properties
 | Name | Description
Public property | Behavior | Flag indicating whether elements of this material behave isotropically or orthotropically.
Public property | ConcreteBendingReinforcement | The bending reinforcement of the asset.
Public property | ConcreteCompression | The compression strength of concrete-based assets.
Public property | ConcreteShearReinforcement | The shear reinforcement of the asset.
Public property | ConcreteShearStrengthReduction | The shear strength reduction of the asset.
Public property | Density | The density of the asset.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Lightweight | Flag indicating whether the asset describes a material that is light-weight or not.
Public property | MetalReductionFactor | The reduction factor of the asset.
Public property | MetalResistanceCalculationStrength | The resistance calculation strength of the asset.
Public property | MetalThermallyTreated | Flag indicating whether the asset describes a material that is thermally treated or not.
Public property | MinimumTensileStrength | The minimum tensile strength of the asset.
Public property | MinimumYieldStress | The minimum yield stress of the asset.
Public property | Name | The name of the structural asset.
Public property | PoissonRatio | The Poisson ratio of the asset.
Public property | ShearModulus | The shear modulus of the asset.
Public property | StructuralAssetClass | The type of material that this structural asset describes (e.g. wood, concrete, metal.)
Public property | SubClass | The sub-class of the asset.
Public property | ThermalExpansionCoefficient | The thermal expansion coefficient of the asset.
Public property | WoodBendingStrength | The bending strength of the asset.
Public property | WoodGrade | The grade of wood used in a wood-based asset.
Public property | WoodParallelCompressionStrength | The parallel compression strength of the asset.
Public property | WoodParallelShearStrength | The parallel shear strength of the asset.
Public property | WoodPerpendicularCompressionStrength | The perpendicular compression strength of the asset.
Public property | WoodPerpendicularShearStrength | The perpendicular shear strength of the asset.
Public property | WoodSpecies | The species of wood used in a wood-based asset.
Public property | YoungModulus | The Young's modulus of the asset.
Top
Methods
 | Name | Description
Public method | Copy | Produces a copy of the asset.
Public method | Dispose | Releases all resources used by the StructuralAsset
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Equals(StructuralAsset) | Determines whether this structural asset is equal to another.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetPoissonRatio | Sets the Poisson ratio of the asset.
Public method | SetShearModulus | Sets the shear modulus of the asset.
Public method | SetThermalExpansionCoefficient | Sets the thermal expansion coefficient of the asset.
Public method | SetYoungModulus | Sets the Young's modulus of the asset.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


StructuralAsset Constructor

Constructs an instance of StructuralAsset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public StructuralAsset(
    string name,
    StructuralAssetClass structuralAssetClass
)
Public Sub New (
    name As String,
    structuralAssetClass As StructuralAssetClass
)
public:
StructuralAsset(
    String^ name,
    StructuralAssetClass structuralAssetClass
)
new :
        name : string *
        structuralAssetClass : StructuralAssetClass -> StructuralAsset

Parameters

name String
The name of the asset.
structuralAssetClass StructuralAssetClass
The type of structural material that this asset will describe.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

StructuralAsset Class


StructuralAsset Properties

The StructuralAsset type exposes the following members.

Properties
 | Name | Description
Public property | Behavior | Flag indicating whether elements of this material behave isotropically or orthotropically.
Public property | ConcreteBendingReinforcement | The bending reinforcement of the asset.
Public property | ConcreteCompression | The compression strength of concrete-based assets.
Public property | ConcreteShearReinforcement | The shear reinforcement of the asset.
Public property | ConcreteShearStrengthReduction | The shear strength reduction of the asset.
Public property | Density | The density of the asset.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Lightweight | Flag indicating whether the asset describes a material that is light-weight or not.
Public property | MetalReductionFactor | The reduction factor of the asset.
Public property | MetalResistanceCalculationStrength | The resistance calculation strength of the asset.
Public property | MetalThermallyTreated | Flag indicating whether the asset describes a material that is thermally treated or not.
Public property | MinimumTensileStrength | The minimum tensile strength of the asset.
Public property | MinimumYieldStress | The minimum yield stress of the asset.
Public property | Name | The name of the structural asset.
Public property | PoissonRatio | The Poisson ratio of the asset.
Public property | ShearModulus | The shear modulus of the asset.
Public property | StructuralAssetClass | The type of material that this structural asset describes (e.g. wood, concrete, metal.)
Public property | SubClass | The sub-class of the asset.
Public property | ThermalExpansionCoefficient | The thermal expansion coefficient of the asset.
Public property | WoodBendingStrength | The bending strength of the asset.
Public property | WoodGrade | The grade of wood used in a wood-based asset.
Public property | WoodParallelCompressionStrength | The parallel compression strength of the asset.
Public property | WoodParallelShearStrength | The parallel shear strength of the asset.
Public property | WoodPerpendicularCompressionStrength | The perpendicular compression strength of the asset.
Public property | WoodPerpendicularShearStrength | The perpendicular shear strength of the asset.
Public property | WoodSpecies | The species of wood used in a wood-based asset.
Public property | YoungModulus | The Young's modulus of the asset.
Top
See Also

Reference

StructuralAsset Class


StructuralAsset.Behavior Property

StructuralAssetBehavior Property

Flag indicating whether elements of this material behave isotropically or orthotropically.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public StructuralBehavior Behavior { get; set; }
Public Property Behavior As StructuralBehavior
    Get
    Set
public:
property StructuralBehavior Behavior {
    StructuralBehavior get ();
    void set (StructuralBehavior value);
}
member Behavior : StructuralBehavior with get, set

Property Value

StructuralBehavior
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
Applies to concrete, Metal, and generic structural assets. If the behavior is set to Isotropic, then the y and z components of Young modulus, Poisson modulus, shear modulus and thermal expansion coefficient will be changed to the value the same as their x components.
See Also

Reference

StructuralAsset Class


StructuralAsset.ConcreteBendingReinforcement Property

StructuralAssetConcreteBendingReinforcement Property

The bending reinforcement of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double ConcreteBendingReinforcement { get; set; }
Public Property ConcreteBendingReinforcement As Double
    Get
    Set
public:
property double ConcreteBendingReinforcement {
    double get ();
    void set (double value);
}
member ConcreteBendingReinforcement : float with get, set

Property Value

Double
Exceptions
Exception | Condition
InapplicableDataException | When setting this property: the material type must be concrete to set this property.
Remarks
Applies to concrete-based structural assets.
See Also

Reference

StructuralAsset Class


StructuralAsset.ConcreteCompression Property

StructuralAssetConcreteCompression Property

The compression strength of concrete-based assets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double ConcreteCompression { get; set; }
Public Property ConcreteCompression As Double
    Get
    Set
public:
property double ConcreteCompression {
    double get ();
    void set (double value);
}
member ConcreteCompression : float with get, set

Property Value

Double
Exceptions
Exception | Condition
InapplicableDataException | When setting this property: the material type must be concrete to set this property.
Remarks
Applies to concrete-based structural assets. The value is in Newtons per foot meter (N/(ft Â· m)).
See Also

Reference

StructuralAsset Class


StructuralAsset.ConcreteShearReinforcement Property

StructuralAssetConcreteShearReinforcement Property

The shear reinforcement of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double ConcreteShearReinforcement { get; set; }
Public Property ConcreteShearReinforcement As Double
    Get
    Set
public:
property double ConcreteShearReinforcement {
    double get ();
    void set (double value);
}
member ConcreteShearReinforcement : float with get, set

Property Value

Double
Exceptions
Exception | Condition
InapplicableDataException | When setting this property: the material type must be concrete to set this property.
Remarks
Applies to concrete-based structural assets.
See Also

Reference

StructuralAsset Class


StructuralAsset.ConcreteShearStrengthReduction Property

StructuralAssetConcreteShearStrengthReduction Property

The shear strength reduction of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double ConcreteShearStrengthReduction { get; set; }
Public Property ConcreteShearStrengthReduction As Double
    Get
    Set
public:
property double ConcreteShearStrengthReduction {
    double get ();
    void set (double value);
}
member ConcreteShearStrengthReduction : float with get, set

Property Value

Double
Exceptions
Exception | Condition
InapplicableDataException | When setting this property: the material type must be concrete to set this property.
Remarks
Applies to concrete-based structural assets.
See Also

Reference

StructuralAsset Class


StructuralAsset.Density Property

StructuralAssetDensity Property

The density of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Density { get; set; }
Public Property Density As Double
    Get
    Set
public:
property double Density {
    double get ();
    void set (double value);
}
member Density : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The given value for density must be non-negative.
Remarks
Values are in kilograms per cubed feet (kg/ftÂ³) and must be non-negative.
See Also

Reference

StructuralAsset Class


StructuralAsset.IsValidObject Property

StructuralAssetIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

StructuralAsset Class


StructuralAsset.Lightweight Property

StructuralAssetLightweight Property

Flag indicating whether the asset describes a material that is light-weight or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Lightweight { get; set; }
Public Property Lightweight As Boolean
    Get
    Set
public:
property bool Lightweight {
    bool get ();
    void set (bool value);
}
member Lightweight : bool with get, set

Property Value

Boolean
See Also

Reference

StructuralAsset Class


StructuralAsset.MetalReductionFactor Property

StructuralAssetMetalReductionFactor Property

The reduction factor of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double MetalReductionFactor { get; set; }
Public Property MetalReductionFactor As Double
    Get
    Set
public:
property double MetalReductionFactor {
    double get ();
    void set (double value);
}
member MetalReductionFactor : float with get, set

Property Value

Double
Exceptions
Exception | Condition
InapplicableDataException | When setting this property: the material type must be Metal to set this property.
Remarks
Applies to Metal-based structural assets.
See Also

Reference

StructuralAsset Class


StructuralAsset.MetalResistanceCalculationStrength Property

StructuralAssetMetalResistanceCalculationStrength Property

The resistance calculation strength of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double MetalResistanceCalculationStrength { get; set; }
Public Property MetalResistanceCalculationStrength As Double
    Get
    Set
public:
property double MetalResistanceCalculationStrength {
    double get ();
    void set (double value);
}
member MetalResistanceCalculationStrength : float with get, set

Property Value

Double
Exceptions
Exception | Condition
InapplicableDataException | When setting this property: the material type must be Metal to set this property.
Remarks
Applies to metal-based structural assets.
See Also

Reference

StructuralAsset Class


StructuralAsset.MetalThermallyTreated Property

StructuralAssetMetalThermallyTreated Property

Flag indicating whether the asset describes a material that is thermally treated or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool MetalThermallyTreated { get; set; }
Public Property MetalThermallyTreated As Boolean
    Get
    Set
public:
property bool MetalThermallyTreated {
    bool get ();
    void set (bool value);
}
member MetalThermallyTreated : bool with get, set

Property Value

Boolean
Exceptions
Exception | Condition
InapplicableDataException | When setting this property: the material type must be Metal to set this property.
Remarks
Applies to Metal-based structural assets.
See Also

Reference

StructuralAsset Class


StructuralAsset.MinimumTensileStrength Property

StructuralAssetMinimumTensileStrength Property

The minimum tensile strength of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double MinimumTensileStrength { get; set; }
Public Property MinimumTensileStrength As Double
    Get
    Set
public:
property double MinimumTensileStrength {
    double get ();
    void set (double value);
}
member MinimumTensileStrength : float with get, set

Property Value

Double
Exceptions
Exception | Condition
InapplicableDataException | When setting this property: the material type must be Metal or generic to set this property.
Remarks
Applies to Metal-based and generic structural assets. The value is in Newtons per foot meter (N/(ft Â· m)).
See Also

Reference

StructuralAsset Class


StructuralAsset.MinimumYieldStress Property

StructuralAssetMinimumYieldStress Property

The minimum yield stress of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double MinimumYieldStress { get; set; }
Public Property MinimumYieldStress As Double
    Get
    Set
public:
property double MinimumYieldStress {
    double get ();
    void set (double value);
}
member MinimumYieldStress : float with get, set

Property Value

Double
Exceptions
Exception | Condition
InapplicableDataException | When setting this property: the material type must be Metal or generic to set this property.
Remarks
Applies to Metal-based and generic structural assets. The value is in Newtons per foot meter (N/(ft Â· m)).
See Also

Reference

StructuralAsset Class


StructuralAsset.Name Property

StructuralAssetName Property

The name of the structural asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

StructuralAsset Class


StructuralAsset.PoissonRatio Property

StructuralAssetPoissonRatio Property

The Poisson ratio of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ PoissonRatio { get; set; }
Public Property PoissonRatio As XYZ
    Get
    Set
public:
property XYZ^ PoissonRatio {
    XYZ^ get ();
    void set (XYZ^ value);
}
member PoissonRatio : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
InapplicableDataException | When setting this property: the material type is wood. -or- When setting this property: the behavior is isotropic.
Remarks
This property cannot be used to set the Poisson ratio for wood-based and isotropic materials. For such assets, use setPoissonRatio instead.
See Also

Reference

StructuralAsset Class


StructuralAsset.ShearModulus Property

StructuralAssetShearModulus Property

The shear modulus of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ ShearModulus { get; set; }
Public Property ShearModulus As XYZ
    Get
    Set
public:
property XYZ^ ShearModulus {
    XYZ^ get ();
    void set (XYZ^ value);
}
member ShearModulus : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
InapplicableDataException | When setting this property: the material type is wood. -or- When setting this property: the behavior is isotropic.
Remarks
This property cannot be used to set the shear modulus for wood-based and isotropic materials. For such assets, use setShearModulus instead. The value is in Newtons per foot meter (N/(ft Â· m)).
See Also

Reference

StructuralAsset Class


StructuralAsset.StructuralAssetClass Property

StructuralAssetStructuralAssetClass Property

The type of material that this structural asset describes (e.g. wood, concrete, metal.)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public StructuralAssetClass StructuralAssetClass { get; }
Public ReadOnly Property StructuralAssetClass As StructuralAssetClass
    Get
public:
property StructuralAssetClass StructuralAssetClass {
    StructuralAssetClass get ();
}
member StructuralAssetClass : StructuralAssetClass with get

Property Value

StructuralAssetClass
See Also

Reference

StructuralAsset Class


StructuralAsset.SubClass Property

StructuralAssetSubClass Property

The sub-class of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SubClass { get; set; }
Public Property SubClass As String
    Get
    Set
public:
property String^ SubClass {
    String^ get ();
    void set (String^ value);
}
member SubClass : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

StructuralAsset Class


StructuralAsset.ThermalExpansionCoefficient Property

StructuralAssetThermalExpansionCoefficient Property

The thermal expansion coefficient of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ ThermalExpansionCoefficient { get; set; }
Public Property ThermalExpansionCoefficient As XYZ
    Get
    Set
public:
property XYZ^ ThermalExpansionCoefficient {
    XYZ^ get ();
    void set (XYZ^ value);
}
member ThermalExpansionCoefficient : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
InapplicableDataException | When setting this property: the material type is wood. -or- When setting this property: the behavior is isotropic.
Remarks
This property cannot be used to set the thermal expansion coefficient for wood-based and isotropic materials. For such assets, use setThermalExpansionCoefficient instead. The value is in inverse Kelvin (1/K).
See Also

Reference

StructuralAsset Class


StructuralAsset.WoodBendingStrength Property

StructuralAssetWoodBendingStrength Property

The bending strength of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double WoodBendingStrength { get; set; }
Public Property WoodBendingStrength As Double
    Get
    Set
public:
property double WoodBendingStrength {
    double get ();
    void set (double value);
}
member WoodBendingStrength : float with get, set

Property Value

Double
Exceptions
Exception | Condition
InapplicableDataException | When setting this property: the material type must be wood to set this property.
Remarks
Applies to wood-based structural assets. The value is in Newtons per foot meter (N/(ft Â· m)).
See Also

Reference

StructuralAsset Class


StructuralAsset.WoodGrade Property

StructuralAssetWoodGrade Property

The grade of wood used in a wood-based asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string WoodGrade { get; set; }
Public Property WoodGrade As String
    Get
    Set
public:
property String^ WoodGrade {
    String^ get ();
    void set (String^ value);
}
member WoodGrade : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
InapplicableDataException | When setting this property: the material type must be wood to set this property.
Remarks
Applies to wood-based structural assets.
See Also

Reference

StructuralAsset Class


StructuralAsset.WoodParallelCompressionStrength Property

StructuralAssetWoodParallelCompressionStrength Property

The parallel compression strength of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double WoodParallelCompressionStrength { get; set; }
Public Property WoodParallelCompressionStrength As Double
    Get
    Set
public:
property double WoodParallelCompressionStrength {
    double get ();
    void set (double value);
}
member WoodParallelCompressionStrength : float with get, set

Property Value

Double
Exceptions
Exception | Condition
InapplicableDataException | When setting this property: the material type must be wood to set this property.
Remarks
Applies to wood-based structural assets. The value is in Newtons per foot meter (N/(ft Â· m)).
See Also

Reference

StructuralAsset Class


StructuralAsset.WoodParallelShearStrength Property

StructuralAssetWoodParallelShearStrength Property

The parallel shear strength of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double WoodParallelShearStrength { get; set; }
Public Property WoodParallelShearStrength As Double
    Get
    Set
public:
property double WoodParallelShearStrength {
    double get ();
    void set (double value);
}
member WoodParallelShearStrength : float with get, set

Property Value

Double
Exceptions
Exception | Condition
InapplicableDataException | When setting this property: the material type must be wood to set this property.
Remarks
Applies to wood-based structural assets. The value is in Newtons per foot meter (N/(ft Â· m)).
See Also

Reference

StructuralAsset Class


StructuralAsset.WoodPerpendicularCompressionStrength Property

StructuralAssetWoodPerpendicularCompressionStrength Property

The perpendicular compression strength of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double WoodPerpendicularCompressionStrength { get; set; }
Public Property WoodPerpendicularCompressionStrength As Double
    Get
    Set
public:
property double WoodPerpendicularCompressionStrength {
    double get ();
    void set (double value);
}
member WoodPerpendicularCompressionStrength : float with get, set

Property Value

Double
Exceptions
Exception | Condition
InapplicableDataException | When setting this property: the material type must be wood to set this property.
Remarks
Applies to wood-based structural assets. The value is in Newtons per foot meter (N/(ft Â· m)).
See Also

Reference

StructuralAsset Class


StructuralAsset.WoodPerpendicularShearStrength Property

StructuralAssetWoodPerpendicularShearStrength Property

The perpendicular shear strength of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double WoodPerpendicularShearStrength { get; set; }
Public Property WoodPerpendicularShearStrength As Double
    Get
    Set
public:
property double WoodPerpendicularShearStrength {
    double get ();
    void set (double value);
}
member WoodPerpendicularShearStrength : float with get, set

Property Value

Double
Exceptions
Exception | Condition
InapplicableDataException | When setting this property: the material type must be wood to set this property.
Remarks
Applies to wood-based structural assets. The value is in Newtons per foot meter (N/(ft Â· m)).
See Also

Reference

StructuralAsset Class


StructuralAsset.WoodSpecies Property

StructuralAssetWoodSpecies Property

The species of wood used in a wood-based asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string WoodSpecies { get; set; }
Public Property WoodSpecies As String
    Get
    Set
public:
property String^ WoodSpecies {
    String^ get ();
    void set (String^ value);
}
member WoodSpecies : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
InapplicableDataException | When setting this property: the material type must be wood to set this property.
Remarks
Applies to wood-based structural assets.
See Also

Reference

StructuralAsset Class


StructuralAsset.YoungModulus Property

StructuralAssetYoungModulus Property

The Young's modulus of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ YoungModulus { get; set; }
Public Property YoungModulus As XYZ
    Get
    Set
public:
property XYZ^ YoungModulus {
    XYZ^ get ();
    void set (XYZ^ value);
}
member YoungModulus : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
InapplicableDataException | When setting this property: the material type is wood. -or- When setting this property: the behavior is isotropic.
Remarks
This property cannot be used to set the Young's modulus for wood-based and isotropic materials. For such assets, use setYoungModulus instead. The value is in Newtons per foot meter (N/(ft Â· m)).
See Also

Reference

StructuralAsset Class


StructuralAsset Methods

The StructuralAsset type exposes the following members.

Methods
 | Name | Description
Public method | Copy | Produces a copy of the asset.
Public method | Dispose |
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Equals(StructuralAsset) | Determines whether this structural asset is equal to another.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetPoissonRatio | Sets the Poisson ratio of the asset.
Public method | SetShearModulus | Sets the shear modulus of the asset.
Public method | SetThermalExpansionCoefficient | Sets the thermal expansion coefficient of the asset.
Public method | SetYoungModulus | Sets the Young's modulus of the asset.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

StructuralAsset Class


StructuralAsset.Copy Method

StructuralAssetCopy Method

Produces a copy of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public StructuralAsset Copy()
Public Function Copy As StructuralAsset
public:
StructuralAsset^ Copy()
member Copy : unit -> StructuralAsset

Return Value

StructuralAsset
A copy of the asset.
See Also

Reference

StructuralAsset Class


StructuralAsset.Dispose Method

StructuralAssetDispose Method

Releases all resources used by the StructuralAsset

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

StructuralAsset Class


StructuralAsset.Equals Method

StructuralAssetEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object is equal to the current object.
Public method | Equals(StructuralAsset) | Determines whether this structural asset is equal to another.
Top
See Also

Reference

StructuralAsset Class


StructuralAsset.Equals(StructuralAsset) Method

StructuralAssetEquals(StructuralAsset) Method

Determines whether this structural asset is equal to another.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    StructuralAsset other
)
Public Function Equals (
    other As StructuralAsset
) As Boolean
public:
bool Equals(
    StructuralAsset^ other
)
member Equals :
        other : StructuralAsset -> bool

Parameters

other StructuralAsset
The structural asset with which to compare this structural asset.

Return Value

Boolean
True if the given structural asset is equal to this one, otherwise false.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

StructuralAsset Class
Equals Overload


StructuralAsset.SetPoissonRatio Method

StructuralAssetSetPoissonRatio Method

Sets the Poisson ratio of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetPoissonRatio(
    double poissonRatio
)
Public Sub SetPoissonRatio (
    poissonRatio As Double
)
public:
void SetPoissonRatio(
    double poissonRatio
)
member SetPoissonRatio :
        poissonRatio : float -> unit

Parameters

poissonRatio Double
Remarks
The Poisson ratio is one-dimensional for wood-based and isotropic materials. This method sets the x, y, and z components to the same value.
See Also

Reference

StructuralAsset Class


StructuralAsset.SetShearModulus Method

StructuralAssetSetShearModulus Method

Sets the shear modulus of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetShearModulus(
    double shearModulus
)
Public Sub SetShearModulus (
    shearModulus As Double
)
public:
void SetShearModulus(
    double shearModulus
)
member SetShearModulus :
        shearModulus : float -> unit

Parameters

shearModulus Double
Remarks
The shear modulus is one-dimensional for wood-based and isotropic materials. This method sets the x, y, and z components to the same value. The value is in Newtons per foot meter (N/(ft Â· m)).
See Also

Reference

StructuralAsset Class


StructuralAsset.SetThermalExpansionCoefficient Method

StructuralAssetSetThermalExpansionCoefficient Method

Sets the thermal expansion coefficient of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetThermalExpansionCoefficient(
    double thermalExpCoeff
)
Public Sub SetThermalExpansionCoefficient (
    thermalExpCoeff As Double
)
public:
void SetThermalExpansionCoefficient(
    double thermalExpCoeff
)
member SetThermalExpansionCoefficient :
        thermalExpCoeff : float -> unit

Parameters

thermalExpCoeff Double
Remarks
The thermal expansion coefficient is one-dimensional for wood-based and isotropic materials. This method sets the x, y, and z components to the same value. The value is in inverse Kelvin (1/K).
See Also

Reference

StructuralAsset Class


StructuralAsset.SetYoungModulus Method

StructuralAssetSetYoungModulus Method

Sets the Young's modulus of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetYoungModulus(
    double youngModulus
)
Public Sub SetYoungModulus (
    youngModulus As Double
)
public:
void SetYoungModulus(
    double youngModulus
)
member SetYoungModulus :
        youngModulus : float -> unit

Parameters

youngModulus Double
Remarks
The Young's modulus is one-dimensional for wood-based and isotropic materials. This method sets the x, y, and z components to the same value. The value is in Newtons per foot meter (N/(ft Â· m)).
See Also

Reference

StructuralAsset Class


StructuralAssetClass Enumeration

Represents the type of material described by a structural asset. This enum value is returned by Autodesk::Revit::DB::StructuralAsset::StructuralAssetClass.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum StructuralAssetClass
Public Enumeration StructuralAssetClass
public enum class StructuralAssetClass
type StructuralAssetClass
Members
Member name | Value | Description
Undefined | 0 | Structural asset class is undefined.
Basic | 1 | Structural asset class is basic.
Generic | 2 | Structural asset class is generic.
Metal | 3 | Structural asset class is metal.
Concrete | 4 | Structural asset class is concrete.
Wood | 5 | Structural asset class is wood.
Liquid | 6 | Structural asset class is liquid.
Gas | 7 | Structural asset class is gas.
Plastic | 8 | Structural asset class is plastic.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


StructuralBehavior Enumeration

Specifies whether structural elements behave orthotropically, isotropically, or transverse-isotropically.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum StructuralBehavior
Public Enumeration StructuralBehavior
public enum class StructuralBehavior
type StructuralBehavior
Members
Member name | Value | Description
Isotropic | 0 | The structural element behaves isotropically.
Orthotropic | 1 | The structural element behaves orthotropically.
TransverseIsotropic | 2 | The structural element behaves transverse-isotropically.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


StructuralReleaseType Enumeration

Type of structural release, which is used for the BuiltIn parameter STRUCTURAL_END_RELEASE_TYPE.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum StructuralReleaseType
Public Enumeration StructuralReleaseType
public enum class StructuralReleaseType
type StructuralReleaseType
Members
Member name | Value | Description
kFixed | 0 |
kPinned | 1 |
kBendingMoment | 2 |
kUserDefined | 3 |
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Subelement Class

An object that represents an element or a subelement within the Autodesk Revit project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSubelement

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Subelement : IDisposable
Public Class Subelement
    Implements IDisposable
public ref class Subelement : IDisposable
type Subelement =
    class
        interface IDisposable
    end

The Subelement type exposes the following members.

Properties
 | Name | Description
Public property | Category | Retrieves a Category object that represents the category or sub category of the subelement.
Public property | Document | The document in which the subelement resides.
Public property | Element | The element in which the subelement resides.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | TypeId | The identifier of this subelement's type.
Public property | UniqueId | A stable unique identifier for this subelement within the document.
Top
Methods
 | Name | Description
Public method | CanHaveTypeAssigned | Identifies if the subelement can have a type assigned.
Public method | ChangeTypeId | Changes the type of the subelement.
 | Create | Creates an object representing element or subelement.
Public method | Dispose | Releases all resources used by the Subelement
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAllParameters | Returns all parameters of this subelement.
Public method | GetBoundingBox | Retrieves a box that circumscribes all geometry of the subelement.
Public method | GetGeometryObject | Retrieve one geometric primitive representing given subelement.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetParameterValue | Obtains the current parameter value of this subelement given a parameter id.
Public method | GetReference | Obtains the reference to this subelement.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetValidTypes | Obtains a set of types that are valid for this subelement.
Public method | HasParameter | Checks if this subelement have given parameter.
Public method | IsParameterModifiable | Checks if given parameter of this subelement is modifiable.
 | IsValidSubelementReference | Checks if given Reference identifies either a valid element or subelement.
Public method | IsValidType | Checks if given type is valid for this subelement.
Public method | SetParameterValue | Sets a new parameter value of this subelement given a parameter id.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

Subelements provide a way for parts of an element to behave as though they were real elements without incurring the overhead of adding more full elements to the model.

Many Revit features (for example parameters, schedules, and tags) were designed to operate on Elements. As a result, the Revit code needs to represent objects as Elements for them to participate in those features. This can lead to scalability problems, because every Element adds overhead and adding many Elements may decrease the performance of the model. An alternative is to use Subelements. An element can expose a set of "Subelements" that it contains, specifying characteristics like their category and parameters, and certain Revit capabilities will treat those Subelements the same as ordinary Elements. For example, a Subelement may contribute geometry to the main element and may be able to be selected independently of its parent Element. It will possibly have its own (settable) type as well as an assigned category which can be different from its parent Element.

In the API, the new Subelement class is used to refer to either an Element or a specific subelement of a given Element. It is typically directly related to a Reference to either the Element or the specific subelement. Note that creation of new Subelements for a given element is not done generically. Instead, the given Element may provide the ability to modify it's definition, resulting in the creation of new Subelements.

Examples of Elements which may have Subelements in practice include:

  • RebarContainer
  • Rebar
  • FabricSheet
  • Stairs elements which make up MultistoryStairs elements
  • Railing
  • [!:Autodesk::Revit::DB::Architecture::ContinuousRail]

To get access to a particular Subelement, you may use any of the following:

  • Create(Document, Reference)
  • IsValidSubelementReference(Document, Reference)
  • Autodesk.Revit.DB.Document.GetSubelement(Autodesk.Revit.DB.Reference) if you have a Reference to a Subelement.
  • Autodesk.Revit.DB.Document.GetSubelement(String) if you have a unique id of a Subelement.
  • GetSubelements

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Subelement Properties

The Subelement type exposes the following members.

Properties
 | Name | Description
Public property | Category | Retrieves a Category object that represents the category or sub category of the subelement.
Public property | Document | The document in which the subelement resides.
Public property | Element | The element in which the subelement resides.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | TypeId | The identifier of this subelement's type.
Public property | UniqueId | A stable unique identifier for this subelement within the document.
Top
See Also

Reference

Subelement Class


Subelement.Category Property

SubelementCategory Property

Retrieves a Category object that represents the category or sub category of the subelement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Category Category { get; }
Public ReadOnly Property Category As Category
    Get
public:
property Category^ Category {
    Category^ get ();
}
member Category : Category with get

Property Value

Category
Remarks
All category objects can be retrieved from the application by using the Categories property of the Application.Settings object.
See Also

Reference

Subelement Class


Subelement.Document Property

SubelementDocument Property

The document in which the subelement resides.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Document Document { get; }
Public ReadOnly Property Document As Document
    Get
public:
property Document^ Document {
    Document^ get ();
}
member Document : Document with get

Property Value

Document
See Also

Reference

Subelement Class


Subelement.Element Property

SubelementElement Property

The element in which the subelement resides.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Element Element { get; }
Public ReadOnly Property Element As Element
    Get
public:
property Element^ Element {
    Element^ get ();
}
member Element : Element with get

Property Value

Element
Remarks
If subelement refers to whole element, this element is returned.
See Also

Reference

Subelement Class


Subelement.IsValidObject Property

SubelementIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

Subelement Class


Subelement.TypeId Property

SubelementTypeId Property

The identifier of this subelement's type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId TypeId { get; }
Public ReadOnly Property TypeId As ElementId
    Get
public:
property ElementId^ TypeId {
    ElementId^ get ();
}
member TypeId : ElementId with get

Property Value

ElementId
Remarks
Some subelements cannot have type assigned, in which case this method returns invalid element id.
See Also

Reference

Subelement Class


Subelement.UniqueId Property

SubelementUniqueId Property

A stable unique identifier for this subelement within the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string UniqueId { get; }
Public ReadOnly Property UniqueId As String
    Get
public:
property String^ UniqueId {
    String^ get ();
}
member UniqueId : string with get

Property Value

String
See Also

Reference

Subelement Class


Subelement Methods

The Subelement type exposes the following members.

Methods
 | Name | Description
Public method | CanHaveTypeAssigned | Identifies if the subelement can have a type assigned.
Public method | ChangeTypeId | Changes the type of the subelement.
 | Create | Creates an object representing element or subelement.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAllParameters | Returns all parameters of this subelement.
Public method | GetBoundingBox | Retrieves a box that circumscribes all geometry of the subelement.
Public method | GetGeometryObject | Retrieve one geometric primitive representing given subelement.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetParameterValue | Obtains the current parameter value of this subelement given a parameter id.
Public method | GetReference | Obtains the reference to this subelement.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetValidTypes | Obtains a set of types that are valid for this subelement.
Public method | HasParameter | Checks if this subelement have given parameter.
Public method | IsParameterModifiable | Checks if given parameter of this subelement is modifiable.
 | IsValidSubelementReference | Checks if given Reference identifies either a valid element or subelement.
Public method | IsValidType | Checks if given type is valid for this subelement.
Public method | SetParameterValue | Sets a new parameter value of this subelement given a parameter id.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Subelement Class


Subelement.CanHaveTypeAssigned Method

SubelementCanHaveTypeAssigned Method

Identifies if the subelement can have a type assigned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanHaveTypeAssigned()
Public Function CanHaveTypeAssigned As Boolean
public:
bool CanHaveTypeAssigned()
member CanHaveTypeAssigned : unit -> bool

Return Value

Boolean
True if subelement can have a type assigned, false otherwise.
Remarks
Some subelements cannot have type assigned, in which case invalid element id is considered to be their type id.
See Also

Reference

Subelement Class


Subelement.ChangeTypeId Method

SubelementChangeTypeId Method

Changes the type of the subelement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ChangeTypeId(
    ElementId typeId
)
Public Sub ChangeTypeId (
    typeId As ElementId
)
public:
void ChangeTypeId(
    ElementId^ typeId
)
member ChangeTypeId :
        typeId : ElementId -> unit

Parameters

typeId ElementId
Identifier of the type to assign to this subelement.
Exceptions
Exception | Condition
ArgumentException | The type typeId is not valid for this subelement.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This Subelement cannot have type assigned.
ModificationForbiddenException | This Subelement is an internal element, such as a component of a loaded family or a group type. -or- The document containing this Subelement is in Group Edit Mode, Sketch Edit Mode, or Paste Mode, and the element is not a member of the group, sketch, or clipboard. -or- This Subelement is a member of a group or sketch, and the document is not currently editing the group or sketch.
Remarks
In rare cases, applying a change in type will result in a new element being created. The only active examples of this are when:
  • Applying a normal wall type to a curtain panel.
  • Converting such a wall back to a curtain panel.
  • Applying a new type to a railing subelement.
In this situation this subelement object will be redirected to the new element.
See Also

Reference

Subelement Class


Subelement.Create Method

SubelementCreate Method

Creates an object representing element or subelement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Subelement Create(
    Document aDoc,
    Reference reference
)
Public Shared Function Create (
    aDoc As Document,
    reference As Reference
) As Subelement
public:
static Subelement^ Create(
    Document^ aDoc,
    Reference^ reference
)
static member Create :
        aDoc : Document *
        reference : Reference -> Subelement

Parameters

aDoc Document
The document.
reference Reference
The reference that identifies element or subelement.

Return Value

Subelement
The newly created subelement.
Exceptions
Exception | Condition
ArgumentException | reference does not identify a valid element or subelement.
ArgumentNullException | A non-optional argument was null
Remarks
If %reference% points to linked document:
  • The GetReference method of the newly created subelement will return the local reference in the linked document.
  • The Document property of the newly created subelement will return the linked document.
See Also

Reference

Subelement Class


Subelement.Dispose Method

SubelementDispose Method

Releases all resources used by the Subelement

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

Subelement Class


Subelement.GetAllParameters Method

SubelementGetAllParameters Method

Returns all parameters of this subelement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ElementId> GetAllParameters()
Public Function GetAllParameters As IList(Of ElementId)
public:
IList<ElementId^>^ GetAllParameters()
member GetAllParameters : unit -> IList<ElementId>

Return Value

IList ElementId
See Also

Reference

Subelement Class


Subelement.GetBoundingBox Method

SubelementGetBoundingBox Method

Retrieves a box that circumscribes all geometry of the subelement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BoundingBoxXYZ GetBoundingBox(
    View dbView
)
Public Function GetBoundingBox (
    dbView As View
) As BoundingBoxXYZ
public:
BoundingBoxXYZ^ GetBoundingBox(
    View^ dbView
)
member GetBoundingBox :
        dbView : View -> BoundingBoxXYZ

Parameters

dbView View
The view for view-specific geometry or for model geometry.

Return Value

BoundingBoxXYZ
The bounding box.
Remarks
Pass in a view to query view-specific (e.g., cut) geometry or for model geometry. If the view box is not known or cannot be calculated, this will return the model box; if the model box is not known, this will return . The box will always be aligned to the default axes of the model coordinate system (thus no rotation should be applied to the return value). Also note that this bounding box volume may enclose geometry that is not obvious. For example, the "flip controls" that could be part of a family will be included in the computation of the bounding box even though they are not always visible in the family instance of the family.
See Also

Reference

Subelement Class


Subelement.GetGeometryObject Method

SubelementGetGeometryObject Method

Retrieve one geometric primitive representing given subelement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GeometryObject GetGeometryObject(
    View dbView
)
Public Function GetGeometryObject (
    dbView As View
) As GeometryObject
public:
GeometryObject^ GetGeometryObject(
    View^ dbView
)
member GetGeometryObject :
        dbView : View -> GeometryObject

Parameters

dbView View
The view for view-specific geometry or for model geometry.

Return Value

GeometryObject
The geometric object representing this subelement.
Remarks
In case of whole element, geometric object representing element and its subelements will be returned. will be returned if related geometric object could not be found in the model.
See Also

Reference

Subelement Class


Subelement.GetParameterValue Method

SubelementGetParameterValue Method

Obtains the current parameter value of this subelement given a parameter id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ParameterValue GetParameterValue(
    ElementId parameterId
)
Public Function GetParameterValue (
    parameterId As ElementId
) As ParameterValue
public:
ParameterValue^ GetParameterValue(
    ElementId^ parameterId
)
member GetParameterValue :
        parameterId : ElementId -> ParameterValue

Parameters

parameterId ElementId
Parameter id.

Return Value

ParameterValue
Parameter value.
Exceptions
Exception | Condition
ArgumentException | parameterId does not identify a valid parameter of this subelement.
ArgumentNullException | A non-optional argument was null
See Also

Reference

Subelement Class


Subelement.GetReference Method

SubelementGetReference Method

Obtains the reference to this subelement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Reference GetReference()
Public Function GetReference As Reference
public:
Reference^ GetReference()
member GetReference : unit -> Reference

Return Value

Reference
The reference to this subelement.
See Also

Reference

Subelement Class


Subelement.GetValidTypes Method

SubelementGetValidTypes Method

Obtains a set of types that are valid for this subelement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ISet<ElementId> GetValidTypes()
Public Function GetValidTypes As ISet(Of ElementId)
public:
ISet<ElementId^>^ GetValidTypes()
member GetValidTypes : unit -> ISet<ElementId>

Return Value

ISet ElementId
A set of element IDs of types that are valid for this subelement or an empty set if subelement cannot have type assigned.
Remarks
A type is valid for a subelement if it can be assigned to the subelement.
See Also

Reference

Subelement Class


Subelement.HasParameter Method

SubelementHasParameter Method

Checks if this subelement have given parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasParameter(
    ElementId parameterId
)
Public Function HasParameter (
    parameterId As ElementId
) As Boolean
public:
bool HasParameter(
    ElementId^ parameterId
)
member HasParameter :
        parameterId : ElementId -> bool

Parameters

parameterId ElementId
Parameter id.

Return Value

Boolean
True if %parameterId% identifies valid parameter of this subelement, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

Subelement Class


Subelement.IsParameterModifiable Method

SubelementIsParameterModifiable Method

Checks if given parameter of this subelement is modifiable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsParameterModifiable(
    ElementId parameterId
)
Public Function IsParameterModifiable (
    parameterId As ElementId
) As Boolean
public:
bool IsParameterModifiable(
    ElementId^ parameterId
)
member IsParameterModifiable :
        parameterId : ElementId -> bool

Parameters

parameterId ElementId
Parameter id.

Return Value

Boolean
True if given parameter of this subelement is modifiable, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

Subelement Class


Subelement.IsValidSubelementReference Method

SubelementIsValidSubelementReference Method

Checks if given Reference identifies either a valid element or subelement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidSubelementReference(
    Document aDoc,
    Reference reference
)
Public Shared Function IsValidSubelementReference (
    aDoc As Document,
    reference As Reference
) As Boolean
public:
static bool IsValidSubelementReference(
    Document^ aDoc,
    Reference^ reference
)
static member IsValidSubelementReference :
        aDoc : Document *
        reference : Reference -> bool

Parameters

aDoc Document
The document.
reference Reference
The reference that identifies an element or subelement.

Return Value

Boolean
True if %reference% identifies a valid element or subelement, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
A reference to an element or subelement in a linked document is acceptable.
See Also

Reference

Subelement Class


Subelement.IsValidType Method

SubelementIsValidType Method

Checks if given type is valid for this subelement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidType(
    ElementId typeId
)
Public Function IsValidType (
    typeId As ElementId
) As Boolean
public:
bool IsValidType(
    ElementId^ typeId
)
member IsValidType :
        typeId : ElementId -> bool

Parameters

typeId ElementId
ElementId of the type to check.

Return Value

Boolean
True if subelement can have a type assigned and this type is valid for this subelement, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
A type is valid for a subelement if it can be assigned to the subelement.
See Also

Reference

Subelement Class


Subelement.SetParameterValue Method

SubelementSetParameterValue Method

Sets a new parameter value of this subelement given a parameter id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetParameterValue(
    ElementId parameterId,
    ParameterValue pValue
)
Public Sub SetParameterValue (
    parameterId As ElementId,
    pValue As ParameterValue
)
public:
void SetParameterValue(
    ElementId^ parameterId,
    ParameterValue^ pValue
)
member SetParameterValue :
        parameterId : ElementId *
        pValue : ParameterValue -> unit

Parameters

parameterId ElementId
Parameter id.
pValue ParameterValue
New value for the parameter.
Exceptions
Exception | Condition
ArgumentException | parameterId does not identify a valid parameter of this subelement. -or- The parameter parameterId is not modifiable for this subelement.
ArgumentNullException | A non-optional argument was null
See Also

Reference

Subelement Class


SubfaceType Enumeration

Meaning of a subface's type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum SubfaceType
Public Enumeration SubfaceType
public enum class SubfaceType
type SubfaceType
Members
Member name | Value | Description
Bottom | 0 | A horizontal face at the bottom of the room, as defined by the room's level and base offset, or a face of the room that is bounded below by a room-bounding element.
Top | 1 | A horizontal top face of the room as defined by the room's level and height, or a face of the room that is bounded above by a room-bounding element.
Side | 2 | Any face which does not meet the criteria to be Top or Bottom.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SubTransaction Class

Sub-transactions are objects that provide control over a subset of changes in a document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSubTransaction

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SubTransaction : IDisposable
Public Class SubTransaction
    Implements IDisposable
public ref class SubTransaction : IDisposable
type SubTransaction =
    class
        interface IDisposable
    end

The SubTransaction type exposes the following members.

Constructors
 | Name | Description
Public method | SubTransaction | Instantiates a sub-transaction object
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Commit | Commits all changes made to the model made during the sub-transaction.
Public method | Dispose | Releases all resources used by the SubTransaction
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetStatus | Returns the current status of the sub-transaction.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HasEnded | Determines whether the sub-transaction has ended already.
Public method | HasStarted | Determines whether the sub-transaction has been started yet.
Public method | RollBack | Discards all changes made to the model during the sub-transaction.
Public method | Start | Starts the sub-transaction.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
A Sub-transaction can only be active as a part of an open transaction. Sub-transactions may be nested inside each other, but with the restriction that every nested sub-transaction is entirely contained (opened and closed) in the parent sub-transaction.

If a sub-transaction was started and not committed or rolled back by the time the SubTransaction object is about to be disposed, the destructor will roll back the sub-transaction automatically, thus all changes made to the document during the sub-transaction will be discarded. It is not recommended to rely on this default behavior though. Instead, it is advised to always call either Commit or RollBack explicitly before the sub-transaction object gets disposed. Please note that unless invoked explicitly the actual destruction of an object in managed code might not happen until the object is collected by the garbage collector.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SubTransaction Constructor

Instantiates a sub-transaction object

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SubTransaction(
    Document document
)
Public Sub New (
    document As Document
)
public:
SubTransaction(
    Document^ document
)
new :
        document : Document -> SubTransaction

Parameters

document Document
The document for which this sub-transaction is going to be used.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

SubTransaction Class


SubTransaction Properties

The SubTransaction type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

SubTransaction Class


SubTransaction.IsValidObject Property

SubTransactionIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

SubTransaction Class


SubTransaction Methods

The SubTransaction type exposes the following members.

Methods
 | Name | Description
Public method | Commit | Commits all changes made to the model made during the sub-transaction.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetStatus | Returns the current status of the sub-transaction.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HasEnded | Determines whether the sub-transaction has ended already.
Public method | HasStarted | Determines whether the sub-transaction has been started yet.
Public method | RollBack | Discards all changes made to the model during the sub-transaction.
Public method | Start | Starts the sub-transaction.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SubTransaction Class


SubTransaction.Commit Method

SubTransactionCommit Method

Commits all changes made to the model made during the sub-transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TransactionStatus Commit()
Public Function Commit As TransactionStatus
public:
TransactionStatus Commit()
member Commit : unit -> TransactionStatus

Return Value

TransactionStatus
If finished successfully, this method returns TransactionStatus.Committed
Exceptions
Exception | Condition
InvalidOperationException | A sub-transaction can only be active inside an open Transaction. -or- The sub-transaction's current status is not TransactionStatus.Started, therefore it may not be committed or rolled back.
Remarks

The changes are not permanently committed to the document yet. They will be committed only when the active transaction is committed. If the transaction is rolled back instead, the changes committed during this sub-transaction will be discarded.

Commit can be called only when all inner sub-transactions, if any, are already finished, i.e. they were either committed or rolled back. If there is still a sub-transaction open, an attempt to commit this outer sub-transaction will cause an exception.

See Also

Reference

SubTransaction Class


SubTransaction.Dispose Method

SubTransactionDispose Method

Releases all resources used by the SubTransaction

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

SubTransaction Class


SubTransaction.GetStatus Method

SubTransactionGetStatus Method

Returns the current status of the sub-transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TransactionStatus GetStatus()
Public Function GetStatus As TransactionStatus
public:
TransactionStatus GetStatus()
member GetStatus : unit -> TransactionStatus

Return Value

TransactionStatus
The current status of the sub-transaction.
See Also

Reference

SubTransaction Class


SubTransaction.HasEnded Method

SubTransactionHasEnded Method

Determines whether the sub-transaction has ended already.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasEnded()
Public Function HasEnded As Boolean
public:
bool HasEnded()
member HasEnded : unit -> bool

Return Value

Boolean
True if the sub-transaction has already been committed or rolled back, False otherwise.
Remarks
A sub-transaction is ended by completing either the Commit or RollBack method. Another way of testing whether a sub-transaction has ended is by testing its current status returned from (see GetStatus). It must be either 'TransactionStatus.Committed' or 'TransactionStatus.RolledBack'
See Also

Reference

SubTransaction Class


SubTransaction.HasStarted Method

SubTransactionHasStarted Method

Determines whether the sub-transaction has been started yet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasStarted()
Public Function HasStarted As Boolean
public:
bool HasStarted()
member HasStarted : unit -> bool

Return Value

Boolean
True if the sub-transaction has already started, False otherwise.
Remarks
A sub-transaction is considered being started after the Start method was called and until the sub-transaction is either committed or rolled back.
See Also

Reference

SubTransaction Class


SubTransaction.RollBack Method

SubTransactionRollBack Method

Discards all changes made to the model during the sub-transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TransactionStatus RollBack()
Public Function RollBack As TransactionStatus
public:
TransactionStatus RollBack()
member RollBack : unit -> TransactionStatus

Return Value

TransactionStatus
If finished successfully, this method returns TransactionStatus.RolledBack.
Exceptions
Exception | Condition
InvalidOperationException | A sub-transaction can only be active inside an open Transaction. -or- The sub-transaction's current status is not TransactionStatus.Started, therefore it may not be committed or rolled back.
Remarks

The parent transaction (or a parent sub-transaction, if any) can still be committed, but the changes rolled back by this method will not be part of the committed transaction.

RollBack can be called only when all inner sub-transaction, if any, are finished, i.e. they were either committed or rolled back. If there is still a sub-transaction open, an attempt to roll this outer sub-transaction back will cause an exception.

See Also

Reference

SubTransaction Class


SubTransaction.Start Method

SubTransactionStart Method

Starts the sub-transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TransactionStatus Start()
Public Function Start As TransactionStatus
public:
TransactionStatus Start()
member Start : unit -> TransactionStatus

Return Value

TransactionStatus
If started successfully, this method returns TransactionStatus.Started.
Exceptions
Exception | Condition
InvalidOperationException | Cannot modify the document for either a read-only external command is being executed, or changes to the document are temporarily disabled. -or- A sub-transaction can only be active inside an open Transaction. -or- The sub-transaction was already started and has not finished yet.
Remarks

A sub-transaction can only be started in an open transaction, and it must be closed (committed or rolled back) while still inside the open transaction.

A sub-transaction can be started in another open sub-transaction, but then it must be closed before the parent sub-transaction is closed.

See Also

Reference

SubTransaction Class


SunAndShadowSettings Class

The SunAndShadowSettings class represents the sun control.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBSunAndShadowSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SunAndShadowSettings : Element
Public Class SunAndShadowSettings
    Inherits Element
public ref class SunAndShadowSettings : public Element
type SunAndShadowSettings =
    class
        inherit Element
    end

The SunAndShadowSettings type exposes the following members.

Properties
 | Name | Description
Public property | ActiveFrame | Identifies the active animation frame for a single-day or multi-day study, starting at 1.0 for the first frame and incrementing in intervals of 1.0.
Public property | ActiveFrameTime | Identifies the date and time of the SunAndShadowSettings element for the active frame.
Public property | Altitude | Altitude setting (angle in radians). This is only relevant when dealing with a SunAndShadowSettings element that uses lighting mode.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | Azimuth | Azimuth setting (angle in radians). This is only relevant when dealing with a SunAndShadowSettings element that uses lighting mode.
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | EndDateAndTime | Identifies the end date and time.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroundPlaneHeight | Identifies the ground plane height.
Public property | GroundPlaneLevelId | Identifies the element id of the Ground Plane level for the SunAndShadowSettings element.
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | Latitude | Identifies the current latitude used by the SunAndShadowSettings element.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Longitude | Identifies the current longitude used by the SunAndShadowSettings element.
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | NumberOfFrames | Identifies the total number of animation frames for a single-day or multi-day study.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ProjectLocationId | Identifies the ProjectLocation element used by the SunAndShadowSettings element.
Public property | ProjectLocationName | Identifies the name of the project location used by the SunAndShadowSettings element.
Public property | RelativeToView | Identifies whether the SunAndShadowSettings element is relative to the view direction. This is only relevant for lighting mode.
Public property | SharesSettings | Identifies whether settings are shared globally.
Public property | StartDateAndTime | Identifies the start or current date and time.
Public property | SunAndShadowType | Identifies the type of the SunAndShadowSettings element.
Public property | SunriseToSunset | Identifies whether the current single day sun study is set to run from sunrise to sunset.
Public property | TimeInterval | Identifies the time interval between animation frames.
Public property | TimeZone | Identifies the time zone.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | UsesDST | Identifies whether the SunAndShadowSettings element is using daylight savings time.
Public property | UsesGroundPlane | Identifies whether the SunAndShadowSettings element uses a ground plane.
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | Visible | Visibility in current view for a per-view SunAndShadowSettings element.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
 | CalculateTimeZone | Use Revit's utilities to calculate the time zone for a given longitude and latitude.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FitToModel | Adjust SunAndShadowSettings to fit around the current model geometry.
 | GetActiveSunAndShadowSettings | Returns the current SunAndShadowSettings element assigned to the active view for the supplied document.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFrameAltitude | Identifies the altitude of the sun (angle in radians) for a specific frame.
Public method | GetFrameAzimuth | Identifies the azimuth of the sun (angle in radians) for a specific frame.
Public method | GetFrameTime | Identifies the date and time of the SunAndShadowSettings element for a given frame.
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMatchingPreset | Finds the name of the 'per-document' SunAndShadowSettings that matches the properties of this per-view element.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetSunrise | Identifies the sunrise time for the SunAndShadowSettings element at its current location and indicated date.
Public method | GetSunset | Identifies the sunset time for the SunAndShadowSettings element at its current location and indicated date.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsAfterStartDateAndTime | Checks whether the end date and time is valid.
Public method | IsBeforeEndDateAndTime | Checks whether the start date and time is valid.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsFrameValid | Checks whether the frame is valid for the supplied SunAndShadowSettings.
Public method | IsGroundPlaneLevelValid | Checks whether the element represents a valid Ground Plane level.
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsTimeIntervalValid | Checks whether the time interval is valid for the SunAndShadowType.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The SunAndShadowSettings element represents the settings applied to a project or view regarding the position, dates, time intervals and other options for the sun control and solar studies. To differentiate between the project and view settings, test the ViewSpecific or OwnerViewId property. If the element is not view-specific this element represents a project-wide setting. If the element is associated to a view, this element represents a per view SunAndShadowSettings. When you create a new view, a new view-specific SunAndShadowSettings element is automatically created for it.
Example
C#
VB
C++
F#
Copy
SunAndShadowSettings sunSettings = view.SunAndShadowSettings; // get current settings from view

// modify Sun and Shadow Settings
DateTime sunrise = sunSettings.GetSunrise(DateTime.SpecifyKind(new DateTime(2011, 4, 20), DateTimeKind.Local)); // sunrise on April 20, 2011
DateTime sunset = sunSettings.GetSunset(DateTime.SpecifyKind(new DateTime(2011, 4, 22), DateTimeKind.Local)); // sunset on April 22, 2011
sunSettings.SunAndShadowType = SunAndShadowType.MultiDayStudy;
sunSettings.StartDateAndTime = sunrise.AddHours(2); // start 2 hours after sunrise on April 20, 2011
sunSettings.EndDateAndTime = sunset.AddHours(-2); // end 2 hours before sunset on April 22, 2011
if (sunSettings.IsTimeIntervalValid(SunStudyTimeInterval.Hour)) // check that this interval is valid for this SunAndShadowType
    sunSettings.TimeInterval = SunStudyTimeInterval.Hour;

// check for validity of start and end times
if (!(sunSettings.IsAfterStartDateAndTime(sunSettings.EndDateAndTime)
    && sunSettings.IsBeforeEndDateAndTime(sunSettings.StartDateAndTime)))
    TaskDialog.Show("Error", "Start and End dates are invalid");

view.get_Parameter(BuiltInParameter.VIEW_GRAPH_SUN_PATH).Set(1); // turn on display of the sun path
Dim sunSettings__1 As SunAndShadowSettings = view.SunAndShadowSettings
' get current settings from view
' modify Sun and Shadow Settings
Dim sunrise As DateTime = sunSettings__1.GetSunrise(DateTime.SpecifyKind(New DateTime(2011, 4, 20), DateTimeKind.Local))
' sunrise on April 20, 2011
Dim sunset As DateTime = sunSettings__1.GetSunset(DateTime.SpecifyKind(New DateTime(2011, 4, 22), DateTimeKind.Local))
' sunset on April 22, 2011
sunSettings__1.SunAndShadowType = SunAndShadowType.MultiDayStudy
sunSettings__1.StartDateAndTime = sunrise.AddHours(2)
' start 2 hours after sunrise on April 20, 2011
sunSettings__1.EndDateAndTime = sunset.AddHours(-2)
' end 2 hours before sunset on April 22, 2011
If sunSettings__1.IsTimeIntervalValid(SunStudyTimeInterval.Hour) Then
    ' check that this interval is valid for this SunAndShadowType
    sunSettings__1.TimeInterval = SunStudyTimeInterval.Hour
End If

' check for validity of start and end times
If Not (sunSettings__1.IsAfterStartDateAndTime(sunSettings__1.EndDateAndTime) AndAlso sunSettings__1.IsBeforeEndDateAndTime(sunSettings__1.StartDateAndTime)) Then
    TaskDialog.Show("Error", "Start and End dates are invalid")
End If

view.Parameter(BuiltInParameter.VIEW_GRAPH_SUN_PATH).[Set](1)
' turn on display of the sun path

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SunAndShadowSettings Properties

The SunAndShadowSettings type exposes the following members.

Properties
 | Name | Description
Public property | ActiveFrame | Identifies the active animation frame for a single-day or multi-day study, starting at 1.0 for the first frame and incrementing in intervals of 1.0.
Public property | ActiveFrameTime | Identifies the date and time of the SunAndShadowSettings element for the active frame.
Public property | Altitude | Altitude setting (angle in radians). This is only relevant when dealing with a SunAndShadowSettings element that uses lighting mode.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | Azimuth | Azimuth setting (angle in radians). This is only relevant when dealing with a SunAndShadowSettings element that uses lighting mode.
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | EndDateAndTime | Identifies the end date and time.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroundPlaneHeight | Identifies the ground plane height.
Public property | GroundPlaneLevelId | Identifies the element id of the Ground Plane level for the SunAndShadowSettings element.
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | Latitude | Identifies the current latitude used by the SunAndShadowSettings element.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Longitude | Identifies the current longitude used by the SunAndShadowSettings element.
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | NumberOfFrames | Identifies the total number of animation frames for a single-day or multi-day study.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ProjectLocationId | Identifies the ProjectLocation element used by the SunAndShadowSettings element.
Public property | ProjectLocationName | Identifies the name of the project location used by the SunAndShadowSettings element.
Public property | RelativeToView | Identifies whether the SunAndShadowSettings element is relative to the view direction. This is only relevant for lighting mode.
Public property | SharesSettings | Identifies whether settings are shared globally.
Public property | StartDateAndTime | Identifies the start or current date and time.
Public property | SunAndShadowType | Identifies the type of the SunAndShadowSettings element.
Public property | SunriseToSunset | Identifies whether the current single day sun study is set to run from sunrise to sunset.
Public property | TimeInterval | Identifies the time interval between animation frames.
Public property | TimeZone | Identifies the time zone.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | UsesDST | Identifies whether the SunAndShadowSettings element is using daylight savings time.
Public property | UsesGroundPlane | Identifies whether the SunAndShadowSettings element uses a ground plane.
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | Visible | Visibility in current view for a per-view SunAndShadowSettings element.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

SunAndShadowSettings Class


SunAndShadowSettings.ActiveFrame Property

SunAndShadowSettingsActiveFrame Property

Identifies the active animation frame for a single-day or multi-day study, starting at 1.0 for the first frame and incrementing in intervals of 1.0.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double ActiveFrame { get; set; }
Public Property ActiveFrame As Double
    Get
    Set
public:
property double ActiveFrame {
    double get ();
    void set (double value);
}
member ActiveFrame : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentException | When setting this property: the frame value frame is not valid.
See Also

Reference

SunAndShadowSettings Class


SunAndShadowSettings.ActiveFrameTime Property

SunAndShadowSettingsActiveFrameTime Property

Identifies the date and time of the SunAndShadowSettings element for the active frame.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime ActiveFrameTime { get; }
Public ReadOnly Property ActiveFrameTime As DateTime
    Get
public:
property DateTime ActiveFrameTime {
    DateTime get ();
}
member ActiveFrameTime : DateTime with get

Property Value

DateTime
See Also

Reference

SunAndShadowSettings Class


SunAndShadowSettings.Altitude Property

SunAndShadowSettingsAltitude Property

Altitude setting (angle in radians). This is only relevant when dealing with a SunAndShadowSettings element that uses lighting mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Altitude { get; set; }
Public Property Altitude As Double
    Get
    Set
public:
property double Altitude {
    double get ();
    void set (double value);
}
member Altitude : float with get, set

Property Value

Double
Altitude angle (radians)
See Also

Reference

SunAndShadowSettings Class


SunAndShadowSettings.Azimuth Property

SunAndShadowSettingsAzimuth Property

Azimuth setting (angle in radians). This is only relevant when dealing with a SunAndShadowSettings element that uses lighting mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Azimuth { get; set; }
Public Property Azimuth As Double
    Get
    Set
public:
property double Azimuth {
    double get ();
    void set (double value);
}
member Azimuth : float with get, set

Property Value

Double
Azimuth angle (radians)
See Also

Reference

SunAndShadowSettings Class


SunAndShadowSettings.EndDateAndTime Property

SunAndShadowSettingsEndDateAndTime Property

Identifies the end date and time.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime EndDateAndTime { get; set; }
Public Property EndDateAndTime As DateTime
    Get
    Set
public:
property DateTime EndDateAndTime {
    DateTime get ();
    void set (DateTime value);
}
member EndDateAndTime : DateTime with get, set

Property Value

DateTime
The date and time. The output value will be in Coordinated Universal Time (UTC), but input may be in local time as well.
Exceptions
Exception | Condition
ArgumentException | When setting this property: Revit does not accept input DateTime objects if they are of kind DateTypeKind.Unspecified.
Remarks
This property represents the end time for a single-day or multi-day study. The end date and time can be set for any study type, but is not always used. Note that Revit may ignore this value if the SunriseToSunset flag is set.
See Also

Reference

SunAndShadowSettings Class


SunAndShadowSettings.GroundPlaneHeight Property

SunAndShadowSettingsGroundPlaneHeight Property

Identifies the ground plane height.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GroundPlaneHeight { get; }
Public ReadOnly Property GroundPlaneHeight As Double
    Get
public:
property double GroundPlaneHeight {
    double get ();
}
member GroundPlaneHeight : float with get

Property Value

Double
See Also

Reference

SunAndShadowSettings Class


SunAndShadowSettings.GroundPlaneLevelId Property

SunAndShadowSettingsGroundPlaneLevelId Property

Identifies the element id of the Ground Plane level for the SunAndShadowSettings element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GroundPlaneLevelId { get; set; }
Public Property GroundPlaneLevelId As ElementId
    Get
    Set
public:
property ElementId^ GroundPlaneLevelId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member GroundPlaneLevelId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentException | When setting this property: the element level is not a valid Ground Plane Level element.
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

SunAndShadowSettings Class


SunAndShadowSettings.Latitude Property

SunAndShadowSettingsLatitude Property

Identifies the current latitude used by the SunAndShadowSettings element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Latitude { get; }
Public ReadOnly Property Latitude As Double
    Get
public:
property double Latitude {
    double get ();
}
member Latitude : float with get

Property Value

Double
See Also

Reference

SunAndShadowSettings Class


SunAndShadowSettings.Longitude Property

SunAndShadowSettingsLongitude Property

Identifies the current longitude used by the SunAndShadowSettings element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Longitude { get; }
Public ReadOnly Property Longitude As Double
    Get
public:
property double Longitude {
    double get ();
}
member Longitude : float with get

Property Value

Double
See Also

Reference

SunAndShadowSettings Class


SunAndShadowSettings.NumberOfFrames Property

SunAndShadowSettingsNumberOfFrames Property

Identifies the total number of animation frames for a single-day or multi-day study.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double NumberOfFrames { get; }
Public ReadOnly Property NumberOfFrames As Double
    Get
public:
property double NumberOfFrames {
    double get ();
}
member NumberOfFrames : float with get

Property Value

Double
See Also

Reference

SunAndShadowSettings Class


SunAndShadowSettings.ProjectLocationId Property

SunAndShadowSettingsProjectLocationId Property

Identifies the ProjectLocation element used by the SunAndShadowSettings element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId ProjectLocationId { get; }
Public ReadOnly Property ProjectLocationId As ElementId
    Get
public:
property ElementId^ ProjectLocationId {
    ElementId^ get ();
}
member ProjectLocationId : ElementId with get

Property Value

ElementId
See Also

Reference

SunAndShadowSettings Class


SunAndShadowSettings.ProjectLocationName Property

SunAndShadowSettingsProjectLocationName Property

Identifies the name of the project location used by the SunAndShadowSettings element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ProjectLocationName { get; }
Public ReadOnly Property ProjectLocationName As String
    Get
public:
property String^ ProjectLocationName {
    String^ get ();
}
member ProjectLocationName : string with get

Property Value

String
See Also

Reference

SunAndShadowSettings Class


SunAndShadowSettings.RelativeToView Property

SunAndShadowSettingsRelativeToView Property

Identifies whether the SunAndShadowSettings element is relative to the view direction. This is only relevant for lighting mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool RelativeToView { get; set; }
Public Property RelativeToView As Boolean
    Get
    Set
public:
property bool RelativeToView {
    bool get ();
    void set (bool value);
}
member RelativeToView : bool with get, set

Property Value

Boolean
See Also

Reference

SunAndShadowSettings Class


SunAndShadowSettings.SharesSettings Property

SunAndShadowSettingsSharesSettings Property

Identifies whether settings are shared globally.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SharesSettings { get; set; }
Public Property SharesSettings As Boolean
    Get
    Set
public:
property bool SharesSettings {
    bool get ();
    void set (bool value);
}
member SharesSettings : bool with get, set

Property Value

Boolean
Remarks
Identifies whether the per-view SunAndShadowSettings element shares global settings. Global settings are a special case that allows multiple views to be associated together in order that a change in one view affects that same change in other views. There cannot be multiple such groups, and a SunAndShadowSettings element is either a global setting or not.
See Also

Reference

SunAndShadowSettings Class


SunAndShadowSettings.StartDateAndTime Property

SunAndShadowSettingsStartDateAndTime Property

Identifies the start or current date and time.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime StartDateAndTime { get; set; }
Public Property StartDateAndTime As DateTime
    Get
    Set
public:
property DateTime StartDateAndTime {
    DateTime get ();
    void set (DateTime value);
}
member StartDateAndTime : DateTime with get, set

Property Value

DateTime
The date and time. The output value will be in Coordinated Universal Time (UTC), but input may be in local time as well.
Exceptions
Exception | Condition
ArgumentException | When setting this property: Revit does not accept input DateTime objects if they are of kind DateTypeKind.Unspecified.
Remarks
This property represents the start time for a single-day or multi-day study, or the current time for a still sun study. Note that Revit may ignore this value if the SunriseToSunset flag is set.
See Also

Reference

SunAndShadowSettings Class


SunAndShadowSettings.SunAndShadowType Property

SunAndShadowSettingsSunAndShadowType Property

Identifies the type of the SunAndShadowSettings element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SunAndShadowType SunAndShadowType { get; set; }
Public Property SunAndShadowType As SunAndShadowType
    Get
    Set
public:
property SunAndShadowType SunAndShadowType {
    SunAndShadowType get ();
    void set (SunAndShadowType value);
}
member SunAndShadowType : SunAndShadowType with get, set

Property Value

SunAndShadowType
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
There are no restrictions on setting the type, but do note that some properties are not relevant for certain types. For example, the property EndDateAndTime is not relevant for the type SunAndShadowType.StillImage. In this example (and elsewhere), the previous value for the property is remembered for when the type is reverted. If that property has not been set yet, default values will apply.
See Also

Reference

SunAndShadowSettings Class


SunAndShadowSettings.SunriseToSunset Property

SunAndShadowSettingsSunriseToSunset Property

Identifies whether the current single day sun study is set to run from sunrise to sunset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SunriseToSunset { get; set; }
Public Property SunriseToSunset As Boolean
    Get
    Set
public:
property bool SunriseToSunset {
    bool get ();
    void set (bool value);
}
member SunriseToSunset : bool with get, set

Property Value

Boolean
See Also

Reference

SunAndShadowSettings Class


SunAndShadowSettings.TimeInterval Property

SunAndShadowSettingsTimeInterval Property

Identifies the time interval between animation frames.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SunStudyTimeInterval TimeInterval { get; set; }
Public Property TimeInterval As SunStudyTimeInterval
    Get
    Set
public:
property SunStudyTimeInterval TimeInterval {
    SunStudyTimeInterval get ();
    void set (SunStudyTimeInterval value);
}
member TimeInterval : SunStudyTimeInterval with get, set

Property Value

SunStudyTimeInterval
Exceptions
Exception | Condition
ArgumentException | When setting this property: the time interval value interval is not valid for the current SunAndShadowType.
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

SunAndShadowSettings Class


SunAndShadowSettings.TimeZone Property

SunAndShadowSettingsTimeZone Property

Identifies the time zone.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double TimeZone { get; }
Public ReadOnly Property TimeZone As Double
    Get
public:
property double TimeZone {
    double get ();
}
member TimeZone : float with get

Property Value

Double
Remarks
Identifies the time zone used by the SunAndShadowSettings element. This property indicates the time zone in which the site resides. The value is in hours, ranging from +12 hours to -12 hours with 0 being GMT.
See Also

Reference

SunAndShadowSettings Class


SunAndShadowSettings.UsesDST Property

SunAndShadowSettingsUsesDST Property

Identifies whether the SunAndShadowSettings element is using daylight savings time.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UsesDST { get; }
Public ReadOnly Property UsesDST As Boolean
    Get
public:
property bool UsesDST {
    bool get ();
}
member UsesDST : bool with get

Property Value

Boolean
See Also

Reference

SunAndShadowSettings Class


SunAndShadowSettings.UsesGroundPlane Property

SunAndShadowSettingsUsesGroundPlane Property

Identifies whether the SunAndShadowSettings element uses a ground plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UsesGroundPlane { get; set; }
Public Property UsesGroundPlane As Boolean
    Get
    Set
public:
property bool UsesGroundPlane {
    bool get ();
    void set (bool value);
}
member UsesGroundPlane : bool with get, set

Property Value

Boolean
See Also

Reference

SunAndShadowSettings Class


SunAndShadowSettings.Visible Property

SunAndShadowSettingsVisible Property

Visibility in current view for a per-view SunAndShadowSettings element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Visible { get; set; }
Public Property Visible As Boolean
    Get
    Set
public:
property bool Visible {
    bool get ();
    void set (bool value);
}
member Visible : bool with get, set

Property Value

Boolean
Visibility
Exceptions
Exception | Condition
ArgumentException | The element is not view specific (in which case visibility is not relevant) or if internally its view is not accessible.
See Also

Reference

SunAndShadowSettings Class


SunAndShadowSettings Methods

The SunAndShadowSettings type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
 | CalculateTimeZone | Use Revit's utilities to calculate the time zone for a given longitude and latitude.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FitToModel | Adjust SunAndShadowSettings to fit around the current model geometry.
 | GetActiveSunAndShadowSettings | Returns the current SunAndShadowSettings element assigned to the active view for the supplied document.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFrameAltitude | Identifies the altitude of the sun (angle in radians) for a specific frame.
Public method | GetFrameAzimuth | Identifies the azimuth of the sun (angle in radians) for a specific frame.
Public method | GetFrameTime | Identifies the date and time of the SunAndShadowSettings element for a given frame.
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMatchingPreset | Finds the name of the 'per-document' SunAndShadowSettings that matches the properties of this per-view element.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetSunrise | Identifies the sunrise time for the SunAndShadowSettings element at its current location and indicated date.
Public method | GetSunset | Identifies the sunset time for the SunAndShadowSettings element at its current location and indicated date.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsAfterStartDateAndTime | Checks whether the end date and time is valid.
Public method | IsBeforeEndDateAndTime | Checks whether the start date and time is valid.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsFrameValid | Checks whether the frame is valid for the supplied SunAndShadowSettings.
Public method | IsGroundPlaneLevelValid | Checks whether the element represents a valid Ground Plane level.
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsTimeIntervalValid | Checks whether the time interval is valid for the SunAndShadowType.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SunAndShadowSettings Class


SunAndShadowSettings.CalculateTimeZone Method

SunAndShadowSettingsCalculateTimeZone Method

Use Revit's utilities to calculate the time zone for a given longitude and latitude.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static double CalculateTimeZone(
    double latitude,
    double longitude
)
Public Shared Function CalculateTimeZone (
    latitude As Double,
    longitude As Double
) As Double
public:
static double CalculateTimeZone(
    double latitude,
    double longitude
)
static member CalculateTimeZone :
        latitude : float *
        longitude : float -> float

Parameters

latitude Double
The latitude.
longitude Double
The longitude.

Return Value

Double
The time zone, in hours, ranging from +12 hours to -12 hours with 0 being GMT.
Remarks
For some latitude and longitude boundary cases, the time zone calculated may not be correct. The API offers the ability to adjust the time zone independent of Revit's calculations for situations where this happens.
See Also

Reference

SunAndShadowSettings Class


SunAndShadowSettings.FitToModel Method

SunAndShadowSettingsFitToModel Method

Adjust SunAndShadowSettings to fit around the current model geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void FitToModel()
Public Sub FitToModel
public:
void FitToModel()
member FitToModel : unit -> unit
Exceptions
Exception | Condition
ArgumentException | The SunAndShadowSettings is not view-specific.
See Also

Reference

SunAndShadowSettings Class


SunAndShadowSettings.GetActiveSunAndShadowSettings Method

SunAndShadowSettingsGetActiveSunAndShadowSettings Method

Returns the current SunAndShadowSettings element assigned to the active view for the supplied document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Element GetActiveSunAndShadowSettings(
    Document aDocument
)
Public Shared Function GetActiveSunAndShadowSettings (
    aDocument As Document
) As Element
public:
static Element^ GetActiveSunAndShadowSettings(
    Document^ aDocument
)
static member GetActiveSunAndShadowSettings :
        aDocument : Document -> Element

Parameters

aDocument Document
The document.

Return Value

Element
The active SunAndShadowSettings element for the supplied document.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

SunAndShadowSettings Class


SunAndShadowSettings.GetFrameAltitude Method

SunAndShadowSettingsGetFrameAltitude Method

Identifies the altitude of the sun (angle in radians) for a specific frame.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetFrameAltitude(
    double frame
)
Public Function GetFrameAltitude (
    frame As Double
) As Double
public:
double GetFrameAltitude(
    double frame
)
member GetFrameAltitude :
        frame : float -> float

Parameters

frame Double
Frame for which time is requested

Return Value

Double
Altitude angle (radians)
Exceptions
Exception | Condition
ArgumentException | the frame value frame is not valid.
See Also

Reference

SunAndShadowSettings Class


SunAndShadowSettings.GetFrameAzimuth Method

SunAndShadowSettingsGetFrameAzimuth Method

Identifies the azimuth of the sun (angle in radians) for a specific frame.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetFrameAzimuth(
    double frame
)
Public Function GetFrameAzimuth (
    frame As Double
) As Double
public:
double GetFrameAzimuth(
    double frame
)
member GetFrameAzimuth :
        frame : float -> float

Parameters

frame Double
Frame for which time is requested

Return Value

Double
Azimuth angle (radians). This is measured counterclockwise from the X axis (East direction). Note that this is a different frame of reference than is used by Revit for the Lighting Study Azimuth value.
Exceptions
Exception | Condition
ArgumentException | the frame value frame is not valid.
See Also

Reference

SunAndShadowSettings Class


SunAndShadowSettings.GetFrameTime Method

SunAndShadowSettingsGetFrameTime Method

Identifies the date and time of the SunAndShadowSettings element for a given frame.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime GetFrameTime(
    double frame
)
Public Function GetFrameTime (
    frame As Double
) As DateTime
public:
DateTime GetFrameTime(
    double frame
)
member GetFrameTime :
        frame : float -> DateTime

Parameters

frame Double
Frame for which time is requested

Return Value

DateTime
The date and time. The value will be in Coordinated Universal Time (UTC).
Exceptions
Exception | Condition
ArgumentException | the frame value frame is not valid.
See Also

Reference

SunAndShadowSettings Class


SunAndShadowSettings.GetMatchingPreset Method

SunAndShadowSettingsGetMatchingPreset Method

Finds the name of the 'per-document' SunAndShadowSettings that matches the properties of this per-view element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetMatchingPreset()
Public Function GetMatchingPreset As String
public:
String^ GetMatchingPreset()
member GetMatchingPreset : unit -> string

Return Value

String
Name of the per-document SunAndShadowSettings that matches the view specific element.
Exceptions
Exception | Condition
ArgumentException | The SunAndShadowSettings is not view-specific.
See Also

Reference

SunAndShadowSettings Class


SunAndShadowSettings.GetSunrise Method

SunAndShadowSettingsGetSunrise Method

Identifies the sunrise time for the SunAndShadowSettings element at its current location and indicated date.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime GetSunrise(
    DateTime date
)
Public Function GetSunrise (
    date As DateTime
) As DateTime
public:
DateTime GetSunrise(
    DateTime date
)
member GetSunrise :
        date : DateTime -> DateTime

Parameters

date DateTime
The date for which to determine sunrise time.

Return Value

DateTime
The date and time. The value will be in Coordinated Universal Time (UTC).
Remarks
The value returned is affected by the value of the UsesDST flag set for the current location. If this value is true, the sunrise value will be adjusted for Daylight Savings Time, regardless of the value of the input date.
See Also

Reference

SunAndShadowSettings Class


SunAndShadowSettings.GetSunset Method

SunAndShadowSettingsGetSunset Method

Identifies the sunset time for the SunAndShadowSettings element at its current location and indicated date.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime GetSunset(
    DateTime date
)
Public Function GetSunset (
    date As DateTime
) As DateTime
public:
DateTime GetSunset(
    DateTime date
)
member GetSunset :
        date : DateTime -> DateTime

Parameters

date DateTime
The date for which to determine sunset time.

Return Value

DateTime
The date and time. The value will be in Coordinated Universal Time (UTC).
Remarks
The value returned is affected by the value of the UsesDST flag set for the current location. If this value is true, the sunset value will be adjusted for Daylight Savings Time, regardless of the value of the input date.
See Also

Reference

SunAndShadowSettings Class


SunAndShadowSettings.IsAfterStartDateAndTime Method

SunAndShadowSettingsIsAfterStartDateAndTime Method

Checks whether the end date and time is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsAfterStartDateAndTime(
    DateTime time
)
Public Function IsAfterStartDateAndTime (
    time As DateTime
) As Boolean
public:
bool IsAfterStartDateAndTime(
    DateTime time
)
member IsAfterStartDateAndTime :
        time : DateTime -> bool

Parameters

time DateTime
Date and time value

Return Value

Boolean
True if the date and time is valid, false otherwise.
See Also

Reference

SunAndShadowSettings Class


SunAndShadowSettings.IsBeforeEndDateAndTime Method

SunAndShadowSettingsIsBeforeEndDateAndTime Method

Checks whether the start date and time is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsBeforeEndDateAndTime(
    DateTime time
)
Public Function IsBeforeEndDateAndTime (
    time As DateTime
) As Boolean
public:
bool IsBeforeEndDateAndTime(
    DateTime time
)
member IsBeforeEndDateAndTime :
        time : DateTime -> bool

Parameters

time DateTime
Date and time value

Return Value

Boolean
True if the date and time is valid, false otherwise.
See Also

Reference

SunAndShadowSettings Class


SunAndShadowSettings.IsFrameValid Method

SunAndShadowSettingsIsFrameValid Method

Checks whether the frame is valid for the supplied SunAndShadowSettings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsFrameValid(
    double frame
)
Public Function IsFrameValid (
    frame As Double
) As Boolean
public:
bool IsFrameValid(
    double frame
)
member IsFrameValid :
        frame : float -> bool

Parameters

frame Double
Frame value

Return Value

Boolean
True if the frame is valid for the SunAndShadowSettings, false otherwise.
See Also

Reference

SunAndShadowSettings Class


SunAndShadowSettings.IsGroundPlaneLevelValid Method

SunAndShadowSettingsIsGroundPlaneLevelValid Method

Checks whether the element represents a valid Ground Plane level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsGroundPlaneLevelValid(
    ElementId levelId
)
Public Function IsGroundPlaneLevelValid (
    levelId As ElementId
) As Boolean
public:
bool IsGroundPlaneLevelValid(
    ElementId^ levelId
)
member IsGroundPlaneLevelValid :
        levelId : ElementId -> bool

Parameters

levelId ElementId
Level element id.

Return Value

Boolean
True if the element is a valid Ground Plane Level, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

SunAndShadowSettings Class


SunAndShadowSettings.IsTimeIntervalValid Method

SunAndShadowSettingsIsTimeIntervalValid Method

Checks whether the time interval is valid for the SunAndShadowType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsTimeIntervalValid(
    SunStudyTimeInterval interval
)
Public Function IsTimeIntervalValid (
    interval As SunStudyTimeInterval
) As Boolean
public:
bool IsTimeIntervalValid(
    SunStudyTimeInterval interval
)
member IsTimeIntervalValid :
        interval : SunStudyTimeInterval -> bool

Parameters

interval SunStudyTimeInterval
Time interval value.

Return Value

Boolean
True if the time interval is valid for the current SunAndShadowType, false otherwise.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

SunAndShadowSettings Class


SunAndShadowType Enumeration

Sun study type enum of SunAndShadowSettings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum SunAndShadowType
Public Enumeration SunAndShadowType
public enum class SunAndShadowType
type SunAndShadowType
Members
Member name | Value | Description
StillImage | 0 | Still image study type (single point in time).
OneDayStudy | 1 | Single day study type (time range over a specific day).
MultiDayStudy | 2 | Multi day study type (range over date and time).
Lighting | 3 | Lighting study type (fixed sun position regardless of date and time).
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SunStudyTimeInterval Enumeration

Time interval enum for a single or multi-day sun study.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum SunStudyTimeInterval
Public Enumeration SunStudyTimeInterval
public enum class SunStudyTimeInterval
type SunStudyTimeInterval
Members
Member name | Value | Description
Minutes15 | 0 | Interval occurs every 15 minutes.
Minutes30 | 1 | Interval occurs every 30 minutes.
Minutes45 | 2 | Interval occurs every 45 minutes.
Hour | 3 | Interval occurs every hour.
Day | 4 | Interval occurs every day.
Week | 5 | Interval occurs once a week.
Month | 6 | Interval occurs once a month.
Minute | -1 | Interval occurs every minute.
Seconds45 | -2 | Interval occurs every 45 seconds.
Seconds30 | -3 | Interval occurs every 30 seconds.
Seconds15 | -4 | Interval occurs every 15 seconds.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Surface Class

A mathematical representation of a surface.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSurface
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Surface : IDisposable
Public Class Surface
    Implements IDisposable
public ref class Surface : IDisposable
type Surface =
    class
        interface IDisposable
    end

The Surface type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OrientationMatchesParametricOrientation | Indicates whether this Surface's orientation is the same as or opposite to its parametric orientation.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the Surface
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBoundingBoxUV | Gets the UV bounding box of the surface.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Project | Project a 3D point orthogonally onto a surface (to find the nearest point). Throws InvalidOperationException if the projection fails.
Public method | ProjectWithGuessPoint | Project a 3D point orthogonally onto a surface (to find the nearest point). This method is meant to be used when a good approximate solution for the projection is available. Throws InvalidOperationException if the projection fails.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This geometric object is not bounded by edges or edge loops. A bounded surface obtained from a Revit element will be represented by a Face instead.
See Also

Reference

Autodesk.Revit.DB Namespace
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSurface
Autodesk.Revit.DBConicalSurface
Autodesk.Revit.DBCylindricalSurface
Autodesk.Revit.DBHermiteSurface
Autodesk.Revit.DBOffsetSurface
Autodesk.Revit.DBPlane
Autodesk.Revit.DBRevolvedSurface
Autodesk.Revit.DBRuledSurface


Surface Properties

The Surface type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OrientationMatchesParametricOrientation | Indicates whether this Surface's orientation is the same as or opposite to its parametric orientation.
Top
See Also

Reference

Surface Class


Surface.IsValidObject Property

SurfaceIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

Surface Class


Surface.OrientationMatchesParametricOrientation Property

SurfaceOrientationMatchesParametricOrientation Property

Indicates whether this Surface's orientation is the same as or opposite to its parametric orientation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool OrientationMatchesParametricOrientation { get; }
Public ReadOnly Property OrientationMatchesParametricOrientation As Boolean
    Get
public:
property bool OrientationMatchesParametricOrientation {
    bool get ();
}
member OrientationMatchesParametricOrientation : bool with get

Property Value

Boolean
Remarks
(Revit uses only orientable surfaces). At any point on a surface, the surface's orientation is specified by a choice of the direction for the normal vector at that point.The direction can either match or be opposite to the direction of the parametric normal vector, which is the cross product of the surface's first partial derivatives: dS/du x dS/dv. The parametric normal vectors define the parametric orientation. A surface's orientation is then defined by getOrientationMatchesParametricOrientation() - if getOrientationMatchesParametricOrientation() is true, the surface's orientation is the same as its parametric orientation; otherwise it is opposite to its parametric orientation. The purpose of this information to an API user: Some systems, Industry Foundation Classes (IFC) for example, may only have parametric orientation for its surfaces. In such a system, the surface normal will always be the parametric normal, whereas in Revit, the surface normal will be the same as or opposite to the parametric normal according as getOrientationMatchesParametricOrientation is true or false. A user who is not familiar with Revit's orientation conventions might assume that Revit's normal vector is the same as the parametric normal, which is not always correct. Hence, this information is needed if and when the user tries to export Revit Geometry to IFC, for example. See also Face::OrientationMatchesSurfaceOrientation.
See Also

Reference

Surface Class


Surface Methods

The Surface type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBoundingBoxUV | Gets the UV bounding box of the surface.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Project | Project a 3D point orthogonally onto a surface (to find the nearest point). Throws InvalidOperationException if the projection fails.
Public method | ProjectWithGuessPoint | Project a 3D point orthogonally onto a surface (to find the nearest point). This method is meant to be used when a good approximate solution for the projection is available. Throws InvalidOperationException if the projection fails.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Surface Class


Surface.Dispose Method

SurfaceDispose Method

Releases all resources used by the Surface

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

Surface Class


Surface.GetBoundingBoxUV Method

SurfaceGetBoundingBoxUV Method

Gets the UV bounding box of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BoundingBoxUV GetBoundingBoxUV()
Public Function GetBoundingBoxUV As BoundingBoxUV
public:
BoundingBoxUV^ GetBoundingBoxUV()
member GetBoundingBoxUV : unit -> BoundingBoxUV

Return Value

BoundingBoxUV
The UV bounding box of the surface.
Remarks
The UV bounding box may not be set.
See Also

Reference

Surface Class


Surface.Project Method

SurfaceProject Method

Project a 3D point orthogonally onto a surface (to find the nearest point). Throws InvalidOperationException if the projection fails.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Project(
    XYZ point,
    out UV uv,
    out double distance
)
Public Sub Project (
    point As XYZ,
    <OutAttribute> ByRef uv As UV,
    <OutAttribute> ByRef distance As Double
)
public:
void Project(
    XYZ^ point,
    [OutAttribute] UV^% uv,
    [OutAttribute] double% distance
)
member Project :
        point : XYZ *
        uv : UV byref *
        distance : float byref -> unit

Parameters

point XYZ
The point to project.
uv UV
The surface coordinates of the projected point.
distance Double
Holds the distance from input point to its projection.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The projection failed.
See Also

Reference

Surface Class


Surface.ProjectWithGuessPoint Method

SurfaceProjectWithGuessPoint Method

Project a 3D point orthogonally onto a surface (to find the nearest point). This method is meant to be used when a good approximate solution for the projection is available. Throws InvalidOperationException if the projection fails.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ProjectWithGuessPoint(
    XYZ point,
    UV guessUV,
    out UV uv,
    out double distance
)
Public Sub ProjectWithGuessPoint (
    point As XYZ,
    guessUV As UV,
    <OutAttribute> ByRef uv As UV,
    <OutAttribute> ByRef distance As Double
)
public:
void ProjectWithGuessPoint(
    XYZ^ point,
    UV^ guessUV,
    [OutAttribute] UV^% uv,
    [OutAttribute] double% distance
)
member ProjectWithGuessPoint :
        point : XYZ *
        guessUV : UV *
        uv : UV byref *
        distance : float byref -> unit

Parameters

point XYZ
The point to project.
guessUV UV
The calculation will look for a project near the provided UV.
uv UV
The surface coordinates of the projected point.
distance Double
Holds the distance from input point to its projection.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The projection failed.
See Also

Reference

Surface Class


Sweep Class

A sweep solid or void form.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBCombinableElement
Autodesk.Revit.DBGenericForm
Autodesk.Revit.DBSweep

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Sweep : GenericForm
Public Class Sweep
    Inherits GenericForm
public ref class Sweep : public GenericForm
type Sweep =
    class
        inherit GenericForm
    end

The Sweep type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm)
Public property | IsTrajectorySegmentationEnabled | The trajectory segmentation option for the sweep.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | MaxSegmentAngle | The maximum segment angle of the sweep in radians.
Public property | Name | Get and Set the Name property (Inherited from GenericForm)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Path3d | The selected curves used for the sweep path.
Public property | PathSketch | The sketched path for the sweep.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ProfileSketch | The profile sketch of the sweep.
Public property | ProfileSymbol | The family symbol profile details for the sweep.
Public property | Subcategory | The subcategory. (Inherited from GenericForm)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Sweep Properties

The Sweep type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm)
Public property | IsTrajectorySegmentationEnabled | The trajectory segmentation option for the sweep.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | MaxSegmentAngle | The maximum segment angle of the sweep in radians.
Public property | Name | Get and Set the Name property (Inherited from GenericForm)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Path3d | The selected curves used for the sweep path.
Public property | PathSketch | The sketched path for the sweep.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ProfileSketch | The profile sketch of the sweep.
Public property | ProfileSymbol | The family symbol profile details for the sweep.
Public property | Subcategory | The subcategory. (Inherited from GenericForm)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

Sweep Class


Sweep.IsTrajectorySegmentationEnabled Property

SweepIsTrajectorySegmentationEnabled Property

The trajectory segmentation option for the sweep.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsTrajectorySegmentationEnabled { get; set; }
Public Property IsTrajectorySegmentationEnabled As Boolean
    Get
    Set
public:
property bool IsTrajectorySegmentationEnabled {
    bool get ();
    void set (bool value);
}
member IsTrajectorySegmentationEnabled : bool with get, set

Property Value

Boolean
Remarks
This property is used to retrieve/set the trajectory segmentation state of the sweep. if return is true, means user can control the MaxSegmentAngle, otherwise is disable.
See Also

Reference

Sweep Class


Sweep.MaxSegmentAngle Property

SweepMaxSegmentAngle Property

The maximum segment angle of the sweep in radians.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double MaxSegmentAngle { get; set; }
Public Property MaxSegmentAngle As Double
    Get
    Set
public:
property double MaxSegmentAngle {
    double get ();
    void set (double value);
}
member MaxSegmentAngle : float with get, set

Property Value

Double
Remarks
This property is used to retrieve/set the maximum segment angle of the sweep. It is settable only when the trajectory segmentation is enabled.
See Also

Reference

Sweep Class


Sweep.Path3d Property

SweepPath3d Property

The selected curves used for the sweep path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Path3d Path3d { get; }
Public ReadOnly Property Path3d As Path3d
    Get
public:
property Path3d^ Path3d {
    Path3d^ get ();
}
member Path3d : Path3d with get

Property Value

Path3d
Remarks
If the sweep is based on a sketched path, this property is .
See Also

Reference

Sweep Class


Sweep.PathSketch Property

SweepPathSketch Property

The sketched path for the sweep.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Sketch PathSketch { get; }
Public ReadOnly Property PathSketch As Sketch
    Get
public:
property Sketch^ PathSketch {
    Sketch^ get ();
}
member PathSketch : Sketch with get

Property Value

Sketch
Remarks
If the sweep is based on selected 3d curves, this property is .
See Also

Reference

Sweep Class


Sweep.ProfileSketch Property

SweepProfileSketch Property

The profile sketch of the sweep.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Sketch ProfileSketch { get; }
Public ReadOnly Property ProfileSketch As Sketch
    Get
public:
property Sketch^ ProfileSketch {
    Sketch^ get ();
}
member ProfileSketch : Sketch with get

Property Value

Sketch
Remarks
If the profile is not based on sketched curves, this property is .
See Also

Reference

Sweep Class


Sweep.ProfileSymbol Property

SweepProfileSymbol Property

The family symbol profile details for the sweep.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilySymbolProfile ProfileSymbol { get; }
Public ReadOnly Property ProfileSymbol As FamilySymbolProfile
    Get
public:
property FamilySymbolProfile^ ProfileSymbol {
    FamilySymbolProfile^ get ();
}
member ProfileSymbol : FamilySymbolProfile with get

Property Value

FamilySymbolProfile
Remarks
If the profile is not based on a profile family, this property is .
See Also

Reference

Sweep Class


Sweep Methods

The Sweep type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Sweep Class


SweepProfile Class

Represents a profile for sweep or swept blend elements.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBSweepProfile
Autodesk.Revit.DBCurveLoopsProfile
Autodesk.Revit.DBFamilySymbolProfile

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SweepProfile : APIObject
Public Class SweepProfile
    Inherits APIObject
public ref class SweepProfile : public APIObject
type SweepProfile =
    class
        inherit APIObject
    end

The SweepProfile type exposes the following members.

Properties
Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SweepProfile Properties

The SweepProfile type exposes the following members.

Properties
Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

SweepProfile Class


SweepProfile Methods

The SweepProfile type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SweepProfile Class


SweptBlend Class

A swept blend solid or void form.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBCombinableElement
Autodesk.Revit.DBGenericForm
Autodesk.Revit.DBSweptBlend

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SweptBlend : GenericForm
Public Class SweptBlend
    Inherits GenericForm
public ref class SweptBlend : public GenericForm
type SweptBlend =
    class
        inherit GenericForm
    end

The SweptBlend type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | BottomProfile | The curves which make up the bottom profile of the sketch.
Public property | BottomProfileSymbol | The bottom family symbol profile of the swept blend.
Public property | BottomSketch | The bottom profile sketch of the swept blend.
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Get and Set the Name property (Inherited from GenericForm)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | PathSketch | The sketched path for the swept blend.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SelectedPath | The selected curve used for the swept blend path.
Public property | Subcategory | The subcategory. (Inherited from GenericForm)
Public property | TopProfile | The curves which make up the top profile of the sketch.
Public property | TopProfileSymbol | The top family symbol profile of the swept blend.
Public property | TopSketch | The top profile sketch of the swept blend.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetVertexConnectionMap | Gets the mapping between the vertices in the top and bottom profiles.
Public method | GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetVertexConnectionMap | Sets the mapping between the vertices in the top and bottom profiles.
Public method | SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SweptBlend Properties

The SweptBlend type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | BottomProfile | The curves which make up the bottom profile of the sketch.
Public property | BottomProfileSymbol | The bottom family symbol profile of the swept blend.
Public property | BottomSketch | The bottom profile sketch of the swept blend.
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Get and Set the Name property (Inherited from GenericForm)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | PathSketch | The sketched path for the swept blend.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SelectedPath | The selected curve used for the swept blend path.
Public property | Subcategory | The subcategory. (Inherited from GenericForm)
Public property | TopProfile | The curves which make up the top profile of the sketch.
Public property | TopProfileSymbol | The top family symbol profile of the swept blend.
Public property | TopSketch | The top profile sketch of the swept blend.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

SweptBlend Class


SweptBlend.BottomProfile Property

SweptBlendBottomProfile Property

The curves which make up the bottom profile of the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurveArrArray BottomProfile { get; }
Public ReadOnly Property BottomProfile As CurveArrArray
    Get
public:
property CurveArrArray^ BottomProfile {
    CurveArrArray^ get ();
}
member BottomProfile : CurveArrArray with get

Property Value

CurveArrArray
Remarks
The indices of the curves in this array match the indices used in the vertex connection map.
See Also

Reference

SweptBlend Class


SweptBlend.BottomProfileSymbol Property

SweptBlendBottomProfileSymbol Property

The bottom family symbol profile of the swept blend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilySymbolProfile BottomProfileSymbol { get; }
Public ReadOnly Property BottomProfileSymbol As FamilySymbolProfile
    Get
public:
property FamilySymbolProfile^ BottomProfileSymbol {
    FamilySymbolProfile^ get ();
}
member BottomProfileSymbol : FamilySymbolProfile with get

Property Value

FamilySymbolProfile
Remarks
If the bottom profile is sketch-based, this property is .
See Also

Reference

SweptBlend Class


SweptBlend.BottomSketch Property

SweptBlendBottomSketch Property

The bottom profile sketch of the swept blend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Sketch BottomSketch { get; }
Public ReadOnly Property BottomSketch As Sketch
    Get
public:
property Sketch^ BottomSketch {
    Sketch^ get ();
}
member BottomSketch : Sketch with get

Property Value

Sketch
Remarks
If the bottom profile is based on a family symbol, this property is .
See Also

Reference

SweptBlend Class


SweptBlend.PathSketch Property

SweptBlendPathSketch Property

The sketched path for the swept blend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Sketch PathSketch { get; }
Public ReadOnly Property PathSketch As Sketch
    Get
public:
property Sketch^ PathSketch {
    Sketch^ get ();
}
member PathSketch : Sketch with get

Property Value

Sketch
Remarks
If the swept blend is based on selected 3d curve, this property is .
See Also

Reference

SweptBlend Class


SweptBlend.SelectedPath Property

SweptBlendSelectedPath Property

The selected curve used for the swept blend path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Curve SelectedPath { get; }
Public ReadOnly Property SelectedPath As Curve
    Get
public:
property Curve^ SelectedPath {
    Curve^ get ();
}
member SelectedPath : Curve with get

Property Value

Curve
Remarks
If the swept blend is based on a sketched path, this property is .
See Also

Reference

SweptBlend Class


SweptBlend.TopProfile Property

SweptBlendTopProfile Property

The curves which make up the top profile of the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurveArrArray TopProfile { get; }
Public ReadOnly Property TopProfile As CurveArrArray
    Get
public:
property CurveArrArray^ TopProfile {
    CurveArrArray^ get ();
}
member TopProfile : CurveArrArray with get

Property Value

CurveArrArray
Remarks
The indices of the curves in this array match the indices used in the vertex connection map.
See Also

Reference

SweptBlend Class


SweptBlend.TopProfileSymbol Property

SweptBlendTopProfileSymbol Property

The top family symbol profile of the swept blend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilySymbolProfile TopProfileSymbol { get; }
Public ReadOnly Property TopProfileSymbol As FamilySymbolProfile
    Get
public:
property FamilySymbolProfile^ TopProfileSymbol {
    FamilySymbolProfile^ get ();
}
member TopProfileSymbol : FamilySymbolProfile with get

Property Value

FamilySymbolProfile
Remarks
If the top profile is sketch-based, this property is .
See Also

Reference

SweptBlend Class


SweptBlend.TopSketch Property

SweptBlendTopSketch Property

The top profile sketch of the swept blend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Sketch TopSketch { get; }
Public ReadOnly Property TopSketch As Sketch
    Get
public:
property Sketch^ TopSketch {
    Sketch^ get ();
}
member TopSketch : Sketch with get

Property Value

Sketch
Remarks
If the top profile is based on a family symbol, this property is .
See Also

Reference

SweptBlend Class


SweptBlend Methods

The SweptBlend type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetVertexConnectionMap | Gets the mapping between the vertices in the top and bottom profiles.
Public method | GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetVertexConnectionMap | Sets the mapping between the vertices in the top and bottom profiles.
Public method | SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SweptBlend Class


SweptBlend.GetVertexConnectionMap Method

SweptBlendGetVertexConnectionMap Method

Gets the mapping between the vertices in the top and bottom profiles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VertexIndexPairArray GetVertexConnectionMap()
Public Function GetVertexConnectionMap As VertexIndexPairArray
public:
VertexIndexPairArray^ GetVertexConnectionMap()
member GetVertexConnectionMap : unit -> VertexIndexPairArray

Return Value

VertexIndexPairArray
Remarks
Each vertex refers to the start point of the curve from the top and bottom profiles.
See Also

Reference

SweptBlend Class


SweptBlend.SetVertexConnectionMap Method

SweptBlendSetVertexConnectionMap Method

Sets the mapping between the vertices in the top and bottom profiles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetVertexConnectionMap(
    VertexIndexPairArray vertexMap
)
Public Sub SetVertexConnectionMap (
    vertexMap As VertexIndexPairArray
)
public:
void SetVertexConnectionMap(
    VertexIndexPairArray^ vertexMap
)
member SetVertexConnectionMap :
        vertexMap : VertexIndexPairArray -> unit

Parameters

vertexMap VertexIndexPairArray
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input argument-"vertexMap"-is .
ArgumentException | Thrown if the input argument-"vertexMap"-is empty.
InvalidOperationException | Thrown when the document failed to regenerate.
See Also

Reference

SweptBlend Class


SweptProfile Class

Represents an extruded profile swept along a driving curve.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSweptProfile

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SweptProfile : IDisposable
Public Class SweptProfile
    Implements IDisposable
public ref class SweptProfile : IDisposable
type SweptProfile =
    class
        interface IDisposable
    end

The SweptProfile type exposes the following members.

Properties
 | Name | Description
Public property | EndSetBack | The distance from the end of the driving curve to the point where the sweep actually ends.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | StartSetBack | The distance from the start of the driving curve to the point where the sweep actually begins.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the SweptProfile
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetDrivingCurve | Provides access to the curve that dictates the path of the swept profile.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetSweptProfile | Returns an object that describes the profile that is swept along the driving curve.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Elements such as beams may be formed from a profile that has been swept along a curve. This class represents such a form and is used to access the cross section and the underlying curve that make up the Element.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SweptProfile Properties

The SweptProfile type exposes the following members.

Properties
 | Name | Description
Public property | EndSetBack | The distance from the end of the driving curve to the point where the sweep actually ends.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | StartSetBack | The distance from the start of the driving curve to the point where the sweep actually begins.
Top
See Also

Reference

SweptProfile Class


SweptProfile.EndSetBack Property

SweptProfileEndSetBack Property

The distance from the end of the driving curve to the point where the sweep actually ends.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double EndSetBack { get; }
Public ReadOnly Property EndSetBack As Double
    Get
public:
property double EndSetBack {
    double get ();
}
member EndSetBack : float with get

Property Value

Double
See Also

Reference

SweptProfile Class


SweptProfile.IsValidObject Property

SweptProfileIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

SweptProfile Class


SweptProfile.StartSetBack Property

SweptProfileStartSetBack Property

The distance from the start of the driving curve to the point where the sweep actually begins.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double StartSetBack { get; }
Public ReadOnly Property StartSetBack As Double
    Get
public:
property double StartSetBack {
    double get ();
}
member StartSetBack : float with get

Property Value

Double
See Also

Reference

SweptProfile Class


SweptProfile Methods

The SweptProfile type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetDrivingCurve | Provides access to the curve that dictates the path of the swept profile.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetSweptProfile | Returns an object that describes the profile that is swept along the driving curve.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SweptProfile Class


SweptProfile.Dispose Method

SweptProfileDispose Method

Releases all resources used by the SweptProfile

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

SweptProfile Class


SweptProfile.GetDrivingCurve Method

SweptProfileGetDrivingCurve Method

Provides access to the curve that dictates the path of the swept profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Curve GetDrivingCurve()
Public Function GetDrivingCurve As Curve
public:
Curve^ GetDrivingCurve()
member GetDrivingCurve : unit -> Curve

Return Value

Curve
A curve that defines the path of the swept profile.
Remarks
The profile may not be swept the entire length of this curve. One should check the set back properties on this object to locate how far the actual sweep is from the ends of the curve.
See Also

Reference

SweptProfile Class


SweptProfile.GetSweptProfile Method

SweptProfileGetSweptProfile Method

Returns an object that describes the profile that is swept along the driving curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Profile GetSweptProfile()
Public Function GetSweptProfile As Profile
public:
Profile^ GetSweptProfile()
member GetSweptProfile : unit -> Profile

Return Value

Profile
A geometric profile object.
Remarks
The profile is swept perpendicular to the driving curve.
See Also

Reference

SweptProfile Class


SymbolGeometryId Class

This class is used to identify a piece of geometry managed by a symbol element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSymbolGeometryId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SymbolGeometryId : IDisposable
Public Class SymbolGeometryId
    Implements IDisposable
public ref class SymbolGeometryId : IDisposable
type SymbolGeometryId =
    class
        interface IDisposable
    end

The SymbolGeometryId type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SymbolId | The id of the symbol which contains the shared geometry.
Top
Methods
 | Name | Description
Public method | AsUniqueIdentifier | Returns a string suitable to determine if two instances point to the same piece of geometry managed by the same symbol element.
Public method | Dispose | Releases all resources used by the SymbolGeometryId
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This class can be used to compare if two instances points to the same piece of geometry managed by a symbol element. The string returned by AsIdentifier can be used to achieve this.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SymbolGeometryId Properties

The SymbolGeometryId type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SymbolId | The id of the symbol which contains the shared geometry.
Top
See Also

Reference

SymbolGeometryId Class


SymbolGeometryId.IsValidObject Property

SymbolGeometryIdIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

SymbolGeometryId Class


SymbolGeometryId.SymbolId Property

SymbolGeometryIdSymbolId Property

The id of the symbol which contains the shared geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId SymbolId { get; }
Public ReadOnly Property SymbolId As ElementId
    Get
public:
property ElementId^ SymbolId {
    ElementId^ get ();
}
member SymbolId : ElementId with get

Property Value

ElementId
See Also

Reference

SymbolGeometryId Class


SymbolGeometryId Methods

The SymbolGeometryId type exposes the following members.

Methods
 | Name | Description
Public method | AsUniqueIdentifier | Returns a string suitable to determine if two instances point to the same piece of geometry managed by the same symbol element.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SymbolGeometryId Class


SymbolGeometryId.AsUniqueIdentifier Method

SymbolGeometryIdAsUniqueIdentifier Method

Returns a string suitable to determine if two instances point to the same piece of geometry managed by the same symbol element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string AsUniqueIdentifier()
Public Function AsUniqueIdentifier As String
public:
String^ AsUniqueIdentifier()
member AsUniqueIdentifier : unit -> string

Return Value

String
A string suitable to determine if two instances point to the same piece of geometry managed by the same symbol element.
See Also

Reference

SymbolGeometryId Class


SymbolGeometryId.Dispose Method

SymbolGeometryIdDispose Method

Releases all resources used by the SymbolGeometryId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

SymbolGeometryId Class


SymbolicCurve Class

A curve that provides information but is not intended to represent actual geometry in an element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBCurveElement
Autodesk.Revit.DBSymbolicCurve

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SymbolicCurve : CurveElement
Public Class SymbolicCurve
    Inherits CurveElement
public ref class SymbolicCurve : public CurveElement
type SymbolicCurve =
    class
        inherit CurveElement
    end

The SymbolicCurve type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CurveElementType | Type of the curve element. (Inherited from CurveElement)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsDrawnInForeground | Indicates if this curve will be drawn in the foreground of the family instance.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ReferenceType | Indicates the type of reference.
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement)
Public property | Subcategory | The subcategory.
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element. (Inherited from CurveElement)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetVisibility | Gets the visibility for the symbolic curve.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement)
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement)
Public method | SetVisibility | Sets the visibility for the symbolic curve.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
For example, when creating a door family, you might sketch symbolic lines in an elevation view to represent a door swing. Symbolic curves are visible parallel to the view in which you sketch them.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SymbolicCurve Properties

The SymbolicCurve type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CurveElementType | Type of the curve element. (Inherited from CurveElement)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsDrawnInForeground | Indicates if this curve will be drawn in the foreground of the family instance.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ReferenceType | Indicates the type of reference.
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement)
Public property | Subcategory | The subcategory.
Public property | SupportsTangentLocks | Indicates whether or not this curve element can have a locked tangent join at either of its end-points shared with another curve element. (Inherited from CurveElement)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

SymbolicCurve Class


SymbolicCurve.IsDrawnInForeground Property

SymbolicCurveIsDrawnInForeground Property

Indicates if this curve will be drawn in the foreground of the family instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsDrawnInForeground { get; set; }
Public Property IsDrawnInForeground As Boolean
    Get
    Set
public:
property bool IsDrawnInForeground {
    bool get ();
    void set (bool value);
}
member IsDrawnInForeground : bool with get, set

Property Value

Boolean
Exceptions
Exception | Condition
InvalidOperationException | Thrown when regeneration failed. Thrown when the value for this property cannot be changed.
See Also

Reference

SymbolicCurve Class


SymbolicCurve.ReferenceType Property

SymbolicCurveReferenceType Property

Indicates the type of reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReferenceType ReferenceType { get; set; }
Public Property ReferenceType As ReferenceType
    Get
    Set
public:
property ReferenceType ReferenceType {
    ReferenceType get ();
    void set (ReferenceType value);
}
member ReferenceType : ReferenceType with get, set

Property Value

ReferenceType
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown when argument is out of range.
InvalidOperationException | Thrown when regeneration failed.
See Also

Reference

SymbolicCurve Class


SymbolicCurve.Subcategory Property

SymbolicCurveSubcategory Property

The subcategory.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GraphicsStyle Subcategory { get; set; }
Public Property Subcategory As GraphicsStyle
    Get
    Set
public:
property GraphicsStyle^ Subcategory {
    GraphicsStyle^ get ();
    void set (GraphicsStyle^ value);
}
member Subcategory : GraphicsStyle with get, set

Property Value

GraphicsStyle
Remarks
If the family category is non-cuttable, the subcategory can be set to be the family category or one of its subcategories. If the family category is cuttable, the subcategory can be set as the graphics styles of the family category, its subcategories, or the invisible lines graphics style.
See Also

Reference

SymbolicCurve Class


SymbolicCurve Methods

The SymbolicCurve type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAdjoinedCurveElements | Returns elements that are joining with this curve element at the given end point. (Inherited from CurveElement)
Public method | GetAreaBasedLoadBoundaryLineData | Gets the area based load boundary line data from this curve, if applicable. (Inherited from CurveElement)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLineStyleIds | Ids of all line style Elements that are applicable to this curve element. (Inherited from CurveElement)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTangentLock | Returns the state of a tangent join between this and another curve element at the given end-point. (Inherited from CurveElement)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetVisibility | Gets the visibility for the symbolic curve.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasTangentJoin | Tests whether this curve element and the input curve element have common tangent join at the given end-point. (Inherited from CurveElement)
Public method | HasTangentLocks | Tests whether this curve element has any locked tangent joins at the given end-point. (Inherited from CurveElement)
Public method | IsAdjoinedCurveElement | This method tests whether this and the given curve elements are joined at the given end. (Inherited from CurveElement)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetGeometryCurve | Sets the geometry of the curve element. After the curve geometry is set, other nearby curves may join to the new curve geometry. (Inherited from CurveElement)
Public method | SetSketchPlaneAndCurve | Sets the sketch plane and the curve for this CurveElement. (Inherited from CurveElement)
Public method | SetTangentLock | Sets a new status for an existing tangent join with another curve element at the given end-point. (Inherited from CurveElement)
Public method | SetVisibility | Sets the visibility for the symbolic curve.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SymbolicCurve Class


SymbolicCurve.GetVisibility Method

SymbolicCurveGetVisibility Method

Gets the visibility for the symbolic curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FamilyElementVisibility GetVisibility()
Public Function GetVisibility As FamilyElementVisibility
public:
FamilyElementVisibility^ GetVisibility()
member GetVisibility : unit -> FamilyElementVisibility

Return Value

FamilyElementVisibility
A copy of visibility settings for the symbolic curve.
See Also

Reference

SymbolicCurve Class


SymbolicCurve.SetVisibility Method

SymbolicCurveSetVisibility Method

Sets the visibility for the symbolic curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetVisibility(
    FamilyElementVisibility visibility
)
Public Sub SetVisibility (
    visibility As FamilyElementVisibility
)
public:
void SetVisibility(
    FamilyElementVisibility^ visibility
)
member SetVisibility :
        visibility : FamilyElementVisibility -> unit

Parameters

visibility FamilyElementVisibility
Exceptions
Exception | Condition
ArgumentNullException | Thrown when visibility is .
ArgumentException | Thrown when visibility is not valid for symbolic curves.
InvalidOperationException | Thrown when regeneration failed.
Remarks
The visibility of the symbolic curve geometry can be changed for different detail levels.
See Also

Reference

SymbolicCurve Class


SymbolicCurveArray Class

An array that contains model curves.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBSymbolicCurveArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SymbolicCurveArray : APIObject,
    IEnumerable
Public Class SymbolicCurveArray
    Inherits APIObject
    Implements IEnumerable
public ref class SymbolicCurveArray : public APIObject,
    IEnumerable
type SymbolicCurveArray =
    class
        inherit APIObject
        interface IEnumerable
    end

The SymbolicCurveArray type exposes the following members.

Constructors
 | Name | Description
Public method | SymbolicCurveArray | Initializes a new instance of the SymbolicCurveArray class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets a model curve at a specified index within the array.
Public property | Size | Returns the number of model curves that are in the array.
Top
Methods
 | Name | Description
Public method | Append | Add the model curve to the end of the array.
Public method | Clear | Removes every model curve from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified model curve into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SymbolicCurveArray Constructor

Initializes a new instance of the SymbolicCurveArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SymbolicCurveArray()
Public Sub New
public:
SymbolicCurveArray()
new : unit -> SymbolicCurveArray
See Also

Reference

SymbolicCurveArray Class


SymbolicCurveArray Properties

The SymbolicCurveArray type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets a model curve at a specified index within the array.
Public property | Size | Returns the number of model curves that are in the array.
Top
See Also

Reference

SymbolicCurveArray Class


SymbolicCurveArray.IsEmpty Property

SymbolicCurveArrayIsEmpty Property

Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Boolean
Remarks
If the array is empty then True will be returned, otherwise False.
See Also

Reference

SymbolicCurveArray Class


SymbolicCurveArray.Item Property

SymbolicCurveArrayItem Property

Gets or sets a model curve at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual SymbolicCurve this[
    int index
] { get; set; }
Public Overridable Property Item (
    index As Integer
) As SymbolicCurve
    Get
    Set
public:
virtual property SymbolicCurve^ Item[int index] {
    SymbolicCurve^ get (int index);
    void set (int index, SymbolicCurve^ value);
}
abstract Item : SymbolicCurve with get, set
override Item : SymbolicCurve with get, set

Parameters

index Int32
The index of the model curve to be set or retrieved.

Return Value

SymbolicCurve
Returns the model curve at the specified index.
See Also

Reference

SymbolicCurveArray Class


SymbolicCurveArray.Size Property

SymbolicCurveArraySize Property

Returns the number of model curves that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
abstract Size : int with get
override Size : int with get

Property Value

Int32
See Also

Reference

SymbolicCurveArray Class


SymbolicCurveArray Methods

The SymbolicCurveArray type exposes the following members.

Methods
 | Name | Description
Public method | Append | Add the model curve to the end of the array.
Public method | Clear | Removes every model curve from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified model curve into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SymbolicCurveArray Class


SymbolicCurveArray.Append Method

SymbolicCurveArrayAppend Method

Add the model curve to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Append(
    SymbolicCurve item
)
Public Overridable Sub Append (
    item As SymbolicCurve
)
public:
virtual void Append(
    SymbolicCurve^ item
)
abstract Append :
        item : SymbolicCurve -> unit
override Append :
        item : SymbolicCurve -> unit

Parameters

item SymbolicCurve
The model curve to be added.
See Also

Reference

SymbolicCurveArray Class


SymbolicCurveArray.Clear Method

SymbolicCurveArrayClear Method

Removes every model curve from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

SymbolicCurveArray Class


SymbolicCurveArray.ForwardIterator Method

SymbolicCurveArrayForwardIterator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual SymbolicCurveArrayIterator ForwardIterator()
Public Overridable Function ForwardIterator As SymbolicCurveArrayIterator
public:
virtual SymbolicCurveArrayIterator^ ForwardIterator()
abstract ForwardIterator : unit -> SymbolicCurveArrayIterator
override ForwardIterator : unit -> SymbolicCurveArrayIterator

Return Value

SymbolicCurveArrayIterator
Returns a forward moving iterator to the array.
See Also

Reference

SymbolicCurveArray Class


SymbolicCurveArray.GetEnumerator Method

SymbolicCurveArrayGetEnumerator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

IEnumerator
Returns a forward moving iterator to the array.

Implements

IEnumerableGetEnumerator
See Also

Reference

SymbolicCurveArray Class


SymbolicCurveArray.Insert Method

SymbolicCurveArrayInsert Method

Insert the specified model curve into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Insert(
    SymbolicCurve item,
    int index
)
Public Overridable Sub Insert (
    item As SymbolicCurve,
    index As Integer
)
public:
virtual void Insert(
    SymbolicCurve^ item,
    int index
)
abstract Insert :
        item : SymbolicCurve *
        index : int -> unit
override Insert :
        item : SymbolicCurve *
        index : int -> unit

Parameters

item SymbolicCurve
The model curve to be inserted into the array.
index Int32
The model curve will be inserted before this index.

Return Value

Returns whether the model curve was inserted into the array.
See Also

Reference

SymbolicCurveArray Class


SymbolicCurveArray.ReverseIterator Method

SymbolicCurveArrayReverseIterator Method

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual SymbolicCurveArrayIterator ReverseIterator()
Public Overridable Function ReverseIterator As SymbolicCurveArrayIterator
public:
virtual SymbolicCurveArrayIterator^ ReverseIterator()
abstract ReverseIterator : unit -> SymbolicCurveArrayIterator
override ReverseIterator : unit -> SymbolicCurveArrayIterator

Return Value

SymbolicCurveArrayIterator
Returns a backward moving iterator to the array.
See Also

Reference

SymbolicCurveArray Class


SymbolicCurveArrayIterator Class

An iterator to a model curve array.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBSymbolicCurveArrayIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class SymbolicCurveArrayIterator : APIObject,
    IEnumerator
Public MustInherit Class SymbolicCurveArrayIterator
    Inherits APIObject
    Implements IEnumerator
public ref class SymbolicCurveArrayIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type SymbolicCurveArrayIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The SymbolicCurveArrayIterator type exposes the following members.

Constructors
 | Name | Description
Public method | SymbolicCurveArrayIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SymbolicCurveArrayIterator Constructor

For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SymbolicCurveArrayIterator()
Public Sub New
public:
SymbolicCurveArrayIterator()
new : unit -> SymbolicCurveArrayIterator
Remarks
This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.
See Also

Reference

SymbolicCurveArrayIterator Class


SymbolicCurveArrayIterator Properties

The SymbolicCurveArrayIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

SymbolicCurveArrayIterator Class


SymbolicCurveArrayIterator.Current Property

SymbolicCurveArrayIteratorCurrent Property

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}
abstract Current : Object with get
override Current : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.
See Also

Reference

SymbolicCurveArrayIterator Class


SymbolicCurveArrayIterator Methods

The SymbolicCurveArrayIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SymbolicCurveArrayIterator Class


SymbolicCurveArrayIterator.MoveNext Method

SymbolicCurveArrayIteratorMoveNext Method

Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumeratorMoveNext
Remarks
MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.
See Also

Reference

SymbolicCurveArrayIterator Class


SymbolicCurveArrayIterator.Reset Method

SymbolicCurveArrayIteratorReset Method

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
Remarks
The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.
See Also

Reference

SymbolicCurveArrayIterator Class


SymbolTypeId Class

This class contains constants identifying symbols.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSymbolTypeId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class SymbolTypeId
Public NotInheritable Class SymbolTypeId
public ref class SymbolTypeId abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SymbolTypeId = class end

The SymbolTypeId type exposes the following members.

Properties
Name | Description
Acres | Symbol acres, indicating unit Acres.
Ampere | Symbol A, indicating unit Amperes.
Atm | Symbol atm, indicating unit Atmospheres.
Baht | Symbol à¸¿, indicating unit Currency.
Bar | Symbol bar, indicating unit Bars.
Btu | Symbol Btu, indicating unit British thermal units.
BtuPerDegreeF | Symbol BTU/Â°F, indicating unit British thermal units per degree Fahrenheit.
BtuPerFtSup2DegreeF | Symbol BTU/(ftÂ²Â·Â°F), indicating unit British thermal units per square foot degree Fahrenheit.
BtuPerH | Symbol Btu/h, indicating unit British thermal units per hour.
BtuPerHFtDegreeF | Symbol BTU/(hÂ·ftÂ·Â°F), indicating unit British thermal units per hour foot degree Fahrenheit.
BtuPerHFtSup2 | Symbol Btu/(hÂ·ftÂ²), indicating unit British thermal units per hour square foot.
BtuPerHFtSup2DegreeF | Symbol BTU/(hÂ·ftÂ²Â·Â°F), indicating unit British thermal units per hour square foot degree Fahrenheit.
BtuPerHFtSup3 | Symbol Btu/(hÂ·ftÂ³), indicating unit British thermal units per hour cubic foot.
BtuPerLb | Symbol BTU/lb, indicating unit British thermal units per pound.
BtuPerLbDegreeF | Symbol BTU/(lbÂ·Â°F), indicating unit British thermal units per pound degree Fahrenheit.
BtuPerS | Symbol Btu/s, indicating unit British thermal units per second.
Cal | Symbol cal, indicating unit Calories.
CalPerS | Symbol cal/s, indicating unit Calories per second.
Cd | Symbol cd, indicating unit Candelas.
CdPerFtSup2 | Symbol cd/ftÂ², indicating unit Candelas per square foot.
CdPerMSup2 | Symbol cd/mÂ², indicating unit Candelas per square meter.
Cf | Symbol CF, indicating unit Cubic feet.
Cfh | Symbol CFH, indicating unit Cubic feet per hour.
Cfm | Symbol CFM, indicating unit Cubic feet per minute.
CfmPerCf | Symbol CFM/CF, indicating unit Cubic feet per minute cubic foot.
CfmPerFtSup2 | Symbol CFM/ftÂ², indicating unit Cubic feet per minute square foot.
CfmPerFtSup3 | Symbol CFM/ftÂ³, indicating unit Cubic feet per minute cubic foot.
CfmPerSf | Symbol CFM/SF, indicating unit Cubic feet per minute square foot.
CfmPerTon | Symbol CFM/ton, indicating unit Cubic feet per minute ton of refrigeration.
ChineseHongKongDollar | Symbol HK$, indicating unit Currency.
Cm | Symbol cm, indicating unit Centimeters.
CmCaret2 | Symbol cm^2, indicating unit Square centimeters.
CmCaret3 | Symbol cm^3, indicating unit Cubic centimeters.
Cmh | Symbol CMH, indicating unit Cubic meters per hour.
CmPerMin | Symbol cm/min, indicating unit Centimeters per minute.
Cms | Symbol CMS, indicating unit Cubic meters per second.
CmSup2 | Symbol cmÂ², indicating unit Square centimeters.
CmSup2PerM | Symbol cmÂ²/m, indicating unit Square centimeters per meter.
CmSup3 | Symbol cmÂ³, indicating unit Cubic centimeters.
CmSup4 | Symbol cmâ´, indicating unit Centimeters to the fourth power.
CmSup6 | Symbol cmâ¶, indicating unit Centimeters to the sixth power.
Colon1 | Symbol :1, indicating unit Ratio : 1.
Colon10 | Symbol :10, indicating unit Ratio : 10.
Colon12 | Symbol :12, indicating unit Ratio : 12.
CP | Symbol cP, indicating unit Centipoises.
Cps | Symbol cps, indicating unit Cycles per second.
Custom | Unrecognized custom symbol.
Cy | Symbol CY, indicating unit Cubic yards.
DaN | Symbol daN, indicating unit Dekanewtons.
DaNDashM | Symbol daN-m, indicating unit Dekanewton meters.
DaNDashMPerM | Symbol daN-m/m, indicating unit Dekanewton meters per meter.
DaNPerM | Symbol daN/m, indicating unit Dekanewtons per meter.
DaNPerMSup2 | Symbol daN/mÂ², indicating unit Dekanewtons per square meter.
Degree | Symbol Â°, indicating unit Degrees.
DegreeC | Symbol Â°C, indicating unit Celsius.
DegreeCInterval | Symbol Â°C, indicating unit Celsius interval.
DegreeF | Symbol Â°F, indicating unit Fahrenheit.
DegreeFInterval | Symbol Â°F, indicating unit Fahrenheit interval.
DegreeR | Symbol Â°R, indicating unit Rankine.
DegreeRInterval | Symbol Â°R, indicating unit Rankine interval.
DeltaDegreeC | Symbol deltaÂ°C, indicating unit Celsius interval.
DeltaDegreeF | Symbol deltaÂ°F, indicating unit Fahrenheit interval.
DeltaDegreeR | Symbol deltaÂ°R, indicating unit Rankine interval.
DeltaK | Symbol deltaK, indicating unit Kelvin interval.
Dm | Symbol dm, indicating unit Decimeters.
DollarHPerBtu | Symbol $Â·h/Btu, indicating unit Cost per British thermal unit per hour.
DollarPerBtu | Symbol $/Btu, indicating unit Cost per British thermal unit.
DollarPerFtSup2 | Symbol $/ftÂ², indicating unit Cost per square foot.
DollarPerMSup2 | Symbol $/mÂ², indicating unit Cost per square meter.
DollarPerW | Symbol $/W, indicating unit Cost per watt.
DollarPerWH | Symbol $/(WÂ·h), indicating unit Cost per watt hour.
Dong | Symbol â‚«, indicating unit Currency.
EuroPrefix | Symbol â‚¬, indicating unit Currency.
EuroSuffix | Symbol â‚¬, indicating unit Currency.
Fc | Symbol fc, indicating unit Footcandles.
FeetOfWater | Symbol Feet, indicating unit Feet of water (39.2 Â°F).
FeetOfWaterPer100ft | Symbol Feet/100ft, indicating unit Feet of water (39.2 Â°F) per 100 feet.
FL | Symbol fL, indicating unit Footlamberts.
FlLowercase | Symbol fl, indicating unit Footlamberts.
FootSingleQuote | Symbol ', indicating unit Feet.
Fpm | Symbol FPM, indicating unit Feet per minute.
Fps | Symbol FPS, indicating unit Feet per second.
Ft | Symbol ft, indicating unit Feet.
Ftc | Symbol Ftc, indicating unit Footcandles.
FtCaret2 | Symbol ft^2, indicating unit Square feet.
FtCaret3 | Symbol ft^3, indicating unit Cubic feet.
FtH2O | Symbol ftH2O, indicating unit Feet of water (39.2 Â°F).
FtH2OPer100ft | Symbol ftH2O/100ft, indicating unit Feet of water (39.2 Â°F) per 100 feet.
FtL | Symbol ftL, indicating unit Footlamberts.
FtOfWater | Symbol FT, indicating unit Feet of water (39.2 Â°F).
FtOfWaterPer100ft | Symbol FT/100ft, indicating unit Feet of water (39.2 Â°F) per 100 feet.
FtPerKip | Symbol ft/kip, indicating unit Feet per kip.
FtPerMin | Symbol ft/min, indicating unit Feet per minute.
FtPerS | Symbol ft/s, indicating unit Feet per second.
FtPerSSup2 | Symbol ft/sÂ², indicating unit Feet per second squared.
FtSup2 | Symbol ftÂ², indicating unit Square feet.
FtSup2HPerKbtu | Symbol ftÂ²Â·h/kBtu, indicating unit Square feet per thousand British thermal units per hour.
FtSup2PerFt | Symbol ftÂ²/ft, indicating unit Square feet per foot.
FtSup2PerKip | Symbol ftÂ²/kip, indicating unit Square feet per kip.
FtSup2PerMbh | Symbol ftÂ²/MBh, indicating unit Square feet per thousand British thermal units per hour.
FtSup2PerS | Symbol ftÂ²/s, indicating unit Square feet per second.
FtSup2PerTon | Symbol ftÂ²/ton, indicating unit Square feet per ton of refrigeration.
FtSup3 | Symbol ftÂ³, indicating unit Cubic feet.
FtSup3HPerMinBtu | Symbol ftÂ³Â·h/(minÂ·Btu), indicating unit Cubic feet per minute per British thermal unit per hour.
FtSup3PerH | Symbol ftÂ³/h, indicating unit Cubic feet per hour.
FtSup3PerKip | Symbol ftÂ³/kip, indicating unit Cubic feet per kip.
FtSup3PerLbMass | Symbol ftÂ³/lb, indicating unit Cubic feet per pound mass.
FtSup3PerMin | Symbol ftÂ³/min, indicating unit Cubic feet per minute.
FtSup4 | Symbol ftâ´, indicating unit Feet to the fourth power.
FtSup6 | Symbol ftâ¶, indicating unit Feet to the sixth power.
Gal | Symbol gal, indicating unit US gallons.
GalPerH | Symbol gal/h, indicating unit US gallons per hour.
GalPerMin | Symbol gal/min, indicating unit US gallons per minute.
GJ | Symbol GJ, indicating unit Gigajoules.
Gph | Symbol GPH, indicating unit US gallons per hour.
Gpm | Symbol GPM, indicating unit US gallons per minute.
Grad | Symbol grad, indicating unit Gradians.
GrPerHFtSup2InHg | Symbol gr/(hÂ·ftÂ²Â·inHg), indicating unit Grains per hour square foot inch mercury.
Hectare | Symbol hectare, indicating unit Hectares.
HFtSup2DegreeFPerBtu | Symbol (hÂ·ftÂ²Â·Â°F)/BTU, indicating unit Hour square foot degrees Fahrenheit per British thermal unit.
Hour | Symbol h, indicating unit Hours.
Hp | Symbol hp, indicating unit Horsepower.
Hz | Symbol Hz, indicating unit Hertz.
In | Symbol in, indicating unit Inches.
InCaret2 | Symbol in^2, indicating unit Square inches.
InCaret3 | Symbol in^3, indicating unit Cubic inches.
InchDoubleQuote | Symbol ", indicating unit Inches.
InDashWg | Symbol in-wg, indicating unit Inches of water (60 Â°F).
InDashWgPer100ft | Symbol in-wg/100ft, indicating unit Inches of water (60 Â°F) per 100 feet.
InHg | Symbol inHg, indicating unit Inches of mercury (32 Â°F).
InPerSSup2 | Symbol in/sÂ², indicating unit Inches per second squared.
InSup2 | Symbol inÂ², indicating unit Square inches.
InSup2PerFt | Symbol inÂ²/ft, indicating unit Square inches per foot.
InSup3 | Symbol inÂ³, indicating unit Cubic inches.
InSup4 | Symbol inâ´, indicating unit Inches to the fourth power.
InSup6 | Symbol inâ¶, indicating unit Inches to the sixth power.
InvDegreeC | Symbol 1/Â°C, indicating unit Inverse degrees Celsius.
InvDegreeF | Symbol 1/Â°F, indicating unit Inverse degrees Fahrenheit.
InvKip | Symbol 1/kip, indicating unit Inverse kips.
InvKN | Symbol 1/kN, indicating unit Inverse kilonewtons.
Joule | Symbol J, indicating unit Joules.
JPerG | Symbol J/g, indicating unit Joules per gram.
JPerGDegreeC | Symbol J/(gÂ·Â°C), indicating unit Joules per gram degree Celsius.
JPerK | Symbol J/K, indicating unit Joules per Kelvin.
JPerKgDegreeC | Symbol J/(kgÂ·Â°C), indicating unit Joules per kilogram degree Celsius.
JPerMSup2K | Symbol J/(mÂ²Â·K), indicating unit Joules per square meter Kelvin.
KA | Symbol kA, indicating unit Kiloamperes.
Kcal | Symbol kcal, indicating unit Kilocalories.
KcalPerS | Symbol kcal/s, indicating unit Kilocalories per second.
Kelvin | Symbol K, indicating unit Kelvin.
KelvinInterval | Symbol K, indicating unit Kelvin interval.
Kg | Symbol kg, indicating unit Kilograms.
Kgf | Symbol kgf, indicating unit Kilograms force.
KgfDashM | Symbol kgf-m, indicating unit Kilogram force meters.
KgfDashMPerM | Symbol kgf-m/m, indicating unit Kilogram force meters per meter.
KgfPerM | Symbol kgf/m, indicating unit Kilograms force per meter.
KgfPerMSup2 | Symbol kgf/mÂ², indicating unit Kilograms force per square meter.
KgPerH | Symbol kg/h, indicating unit Kilograms per hour.
KgPerKgK | Symbol kg/(kgÂ·K), indicating unit Kilograms per kilogram kelvin.
KgPerM | Symbol kg/m, indicating unit Kilograms per meter.
KgPerMH | Symbol kg/(mÂ·h), indicating unit Kilograms per meter hour.
KgPerMin | Symbol kg/min, indicating unit Kilograms per minute.
KgPerMS | Symbol kg/(mÂ·s), indicating unit Kilograms per meter second.
KgPerMSup2 | Symbol kg/mÂ², indicating unit Kilograms per square meter.
KgPerMSup3 | Symbol kg/mÂ³, indicating unit Kilograms per cubic meter.
KgPerS | Symbol kg/s, indicating unit Kilograms per second.
Kip | Symbol kip, indicating unit Kips.
KipDashFt | Symbol kip-ft, indicating unit Kip feet.
KipDashFtPerDegree | Symbol kip-ft/Â°, indicating unit Kip feet per degree.
KipDashFtPerDegreePerFt | Symbol kip-ft/Â°/ft, indicating unit Kip feet per degree per foot.
KipDashFtPerFt | Symbol kip-ft/ft, indicating unit Kip feet per foot.
KipPerFt | Symbol kip/ft, indicating unit Kips per foot.
KipPerFtSup2 | Symbol kip/ftÂ², indicating unit Kips per square foot.
KipPerFtSup3 | Symbol kip/ftÂ³, indicating unit Kips per cubic foot.
KipPerIn | Symbol kip/in, indicating unit Kips per inch.
KipPerInSup2 | Symbol kip/inÂ², indicating unit Kips per square inch.
KipPerInSup3 | Symbol kip/inÂ³, indicating unit Kips per cubic inch.
KJ | Symbol kJ, indicating unit Kilojoules.
KJPerK | Symbol kJ/K, indicating unit Kilojoules per Kelvin.
KJPerMSup2K | Symbol kJ/(mÂ²Â·K), indicating unit Kilojoules per square meter Kelvin.
KmPerH | Symbol km/h, indicating unit Kilometers per hour.
KmPerSSup2 | Symbol km/sÂ², indicating unit Kilometers per second squared.
KN | Symbol kN, indicating unit Kilonewtons.
KNDashM | Symbol kN-m, indicating unit Kilonewton meters.
KNDashMPerDegree | Symbol kN-m/Â°, indicating unit Kilonewton meters per degree.
KNDashMPerDegreePerM | Symbol kN-m/Â°/m, indicating unit Kilonewton meters per degree per meter.
KNDashMPerM | Symbol kN-m/m, indicating unit Kilonewton meters per meter.
KNPerCmSup2 | Symbol kN/cmÂ², indicating unit Kilonewtons per square centimeter.
KNPerM | Symbol kN/m, indicating unit Kilonewtons per meter.
KNPerMmSup2 | Symbol kN/mmÂ², indicating unit Kilonewtons per square millimeter.
KNPerMSup2 | Symbol kN/mÂ², indicating unit Kilonewtons per square meter.
KNPerMSup3 | Symbol kN/mÂ³, indicating unit Kilonewtons per cubic meter.
KPa | Symbol kPa, indicating unit Kilopascals.
Krone | Symbol kr, indicating unit Currency.
Ksf | Symbol ksf, indicating unit Kips per square foot.
Ksi | Symbol ksi, indicating unit Kips per square inch.
KV | Symbol kV, indicating unit Kilovolts.
KVA | Symbol kVA, indicating unit Kilovolt amperes.
KW | Symbol kW, indicating unit Kilowatts.
KWh | Symbol kWh, indicating unit Kilowatt hours.
Lbf | Symbol lbf, indicating unit Pounds force.
LbfDashFt | Symbol lbf-ft, indicating unit Pound force feet.
LbfDashFtPerFt | Symbol lbf-ft/ft, indicating unit Pound force feet per foot.
LbForce | Symbol lb, indicating unit Pounds force.
LbForceDashFt | Symbol lb-ft, indicating unit Pound force feet.
LbForceDashFtPerFt | Symbol lb-ft/ft, indicating unit Pound force feet per foot.
LbForcePerFt | Symbol lb/ft, indicating unit Pounds force per foot.
LbForcePerFtSup2 | Symbol lb/ftÂ², indicating unit Pounds force per square foot.
LbForcePerFtSup3 | Symbol lb/ftÂ³, indicating unit Pounds force per cubic foot.
LbForcePerInSup2 | Symbol lb/inÂ², indicating unit Pounds force per square inch.
LbForceSPerFtSup2 | Symbol lbÂ·s/ftÂ², indicating unit Pound force seconds per square foot.
LbfPerFt | Symbol lbf/ft, indicating unit Pounds force per foot.
LbfPerFtSup2 | Symbol lbf/ftÂ², indicating unit Pounds force per square foot.
LbfPerFtSup3 | Symbol lbf/ftÂ³, indicating unit Pounds force per cubic foot.
LbfPerInSup2 | Symbol lbf/inÂ², indicating unit Pounds force per square inch.
Lbm | Symbol lbm, indicating unit Pounds mass.
LbMass | Symbol lb, indicating unit Pounds mass.
LbMassPerFt | Symbol lb/ft, indicating unit Pounds mass per foot.
LbMassPerFtDashH | Symbol lb/ft-h, indicating unit Pounds mass per foot hour.
LbMassPerFtDashS | Symbol lb/ft-s, indicating unit Pounds mass per foot second.
LbMassPerFtSup2 | Symbol lb/ftÂ², indicating unit Pounds mass per square foot.
LbMassPerFtSup3 | Symbol lb/ftÂ³, indicating unit Pounds mass per cubic foot.
LbMassPerH | Symbol lb/h, indicating unit Pounds mass per hour.
LbMassPerInSup3 | Symbol lb/inÂ³, indicating unit Pounds mass per cubic inch.
LbMassPerLbDegreeF | Symbol lb/(lbÂ·Â°F), indicating unit Pounds mass per pound degree Fahrenheit.
LbMassPerMin | Symbol lb/min, indicating unit Pounds mass per minute.
LbMassPerS | Symbol lb/s, indicating unit Pounds mass per second.
LbmPerFt | Symbol lbm/ft, indicating unit Pounds mass per foot.
LbmPerFtDashH | Symbol lbm/ft-h, indicating unit Pounds mass per foot hour.
LbmPerFtDashS | Symbol lbm/ft-s, indicating unit Pounds mass per foot second.
LbmPerFtSup3 | Symbol lbm/ftÂ³, indicating unit Pounds mass per cubic foot.
LbmPerInSup3 | Symbol lbm/inÂ³, indicating unit Pounds mass per cubic inch.
Lf | Symbol LF, indicating unit Feet.
Liter | Symbol L, indicating unit Liters.
Lm | Symbol lm, indicating unit Lumens.
LmPerW | Symbol lm/W, indicating unit Lumens per watt.
LPerH | Symbol L/h, indicating unit Liters per hour.
LPerMin | Symbol L/min, indicating unit Liters per minute.
LPerS | Symbol L/s, indicating unit Liters per second.
LPerSKw | Symbol L/(sÂ·kW), indicating unit Liters per second kilowatt.
LPerSMSup2 | Symbol L/(sÂ·mÂ²), indicating unit Liters per second square meter.
LPerSMSup3 | Symbol L/(sÂ·mÂ³), indicating unit Liters per second cubic meter.
Lpm | Symbol LPM, indicating unit Liters per minute.
Lps | Symbol LPS, indicating unit Liters per second.
LpsPerMSup2 | Symbol LPS/mÂ², indicating unit Liters per second square meter.
Lx | Symbol lx, indicating unit Lux.
MA | Symbol mA, indicating unit Milliamperes.
Mbh | Symbol MBH, indicating unit Thousand British thermal units per hour.
MCaret2 | Symbol m^2, indicating unit Square meters.
MCaret3 | Symbol m^3, indicating unit Cubic meters.
Meter | Symbol m, indicating unit Meters.
MH2O | Symbol mH2O, indicating unit Meters of water column.
MH2OPerM | Symbol mH2O/m, indicating unit Meters of water column per meter.
Min | Symbol min, indicating unit Minutes.
MiPerSSup2 | Symbol mi/sÂ², indicating unit Miles per second squared.
MJ | Symbol MJ, indicating unit Megajoules.
Mm | Symbol mm, indicating unit Millimeters.
MmCaret2 | Symbol mm^2, indicating unit Square millimeters.
MmCaret3 | Symbol mm^3, indicating unit Cubic millimeters.
MmH2O | Symbol mmH2O, indicating unit Millimeters of water column.
MmH2OPerM | Symbol mmH2O/m, indicating unit Millimeters of water column per meter.
MmHg | Symbol mmHg, indicating unit Millimeters of mercury.
MmSup2 | Symbol mmÂ², indicating unit Square millimeters.
MmSup2PerM | Symbol mmÂ²/m, indicating unit Square millimeters per meter.
MmSup3 | Symbol mmÂ³, indicating unit Cubic millimeters.
MmSup4 | Symbol mmâ´, indicating unit Millimeters to the fourth power.
MmSup6 | Symbol mmâ¶, indicating unit Millimeters to the sixth power.
MN | Symbol MN, indicating unit Meganewtons.
MNDashM | Symbol MN-m, indicating unit Meganewton meters.
MNDashMPerM | Symbol MN-m/m, indicating unit Meganewton meters per meter.
MNPerM | Symbol MN/m, indicating unit Meganewtons per meter.
MNPerMSup2 | Symbol MN/mÂ², indicating unit Meganewtons per square meter.
MPa | Symbol MPa, indicating unit Megapascals.
MPerKN | Symbol m/kN, indicating unit Meters per kilonewton.
MPerS | Symbol m/s, indicating unit Meters per second.
MPerSSup2 | Symbol m/sÂ², indicating unit Meters per second squared.
Mph | Symbol mph, indicating unit Miles per hour.
Ms | Symbol ms, indicating unit Milliseconds.
MSup2 | Symbol mÂ², indicating unit Square meters.
MSup2KPerW | Symbol (mÂ²Â·K)/W, indicating unit Square meter kelvins per watt.
MSup2PerKN | Symbol mÂ²/kN, indicating unit Square meters per kilonewton.
MSup2PerKw | Symbol mÂ²/kW, indicating unit Square meters per kilowatt.
MSup2PerM | Symbol mÂ²/m, indicating unit Square meters per meter.
MSup2PerS | Symbol mÂ²/s, indicating unit Square meters per second.
MSup3 | Symbol mÂ³, indicating unit Cubic meters.
MSup3PerH | Symbol mÂ³/h, indicating unit Cubic meters per hour.
MSup3PerHMSup2 | Symbol mÂ³/(hÂ·mÂ²), indicating unit Cubic meters per hour square meter.
MSup3PerHMSup3 | Symbol mÂ³/(hÂ·mÂ³), indicating unit Cubic meters per hour cubic meter.
MSup3PerKg | Symbol mÂ³/kg, indicating unit Cubic meters per kilogram.
MSup3PerKN | Symbol mÂ³/kN, indicating unit Cubic meters per kilonewton.
MSup3PerS | Symbol mÂ³/s, indicating unit Cubic meters per second.
MSup3PerWS | Symbol mÂ³/(WÂ·s), indicating unit Cubic meters per watt second.
MSup4 | Symbol mâ´, indicating unit Meters to the fourth power.
MSup6 | Symbol mâ¶, indicating unit Meters to the sixth power.
MV | Symbol mV, indicating unit Millivolts.
MW | Symbol MW, indicating unit Megawatts.
NDashM | Symbol N-m, indicating unit Newton meters.
NDashMPerM | Symbol N-m/m, indicating unit Newton meters per meter.
Newton | Symbol N, indicating unit Newtons.
NgPerPaSMSup2 | Symbol ng/(PaÂ·sÂ·mÂ²), indicating unit Nanograms per pascal second square meter.
NPerM | Symbol N/m, indicating unit Newtons per meter.
NPerMmSup2 | Symbol N/mmÂ², indicating unit Newtons per square millimeter.
NPerMSup2 | Symbol N/mÂ², indicating unit Newtons per square meter.
NSPerMSup2 | Symbol NÂ·s/mÂ², indicating unit Newton seconds per square meter.
OhmM | Symbol ohmÂ·m, indicating unit Ohm meters.
OneColon | Symbol 1:, indicating unit 1 : Ratio.
Pa | Symbol Pa, indicating unit Pascals.
PaDashS | Symbol Pa-s, indicating unit Pascal seconds.
PaPerM | Symbol Pa/m, indicating unit Pascals per meter.
Percent | Symbol %, indicating unit Percentage.
PerMille | Symbol â€°, indicating unit Per mille.
Pi | Symbol Ï€, indicating unit Multiples of Ï€.
Psf | Symbol psf, indicating unit Pounds force per square foot.
Psi | Symbol psi, indicating unit Pounds force per square inch.
Psia | Symbol psia, indicating unit Pounds force per square inch.
Psig | Symbol psig, indicating unit Pounds force per square inch.
Rad | Symbol rad, indicating unit Radians.
RadPerS | Symbol rad/s, indicating unit Radians per second.
Rpm | Symbol RPM, indicating unit Revolutions per minute.
Rps | Symbol RPS, indicating unit Revolutions per second.
Second | Symbol s, indicating unit Seconds.
Sf | Symbol SF, indicating unit Square feet.
SfHPerKbtu | Symbol SFÂ·h/kBtu, indicating unit Square feet per thousand British thermal units per hour.
SfPerMbh | Symbol SF/MBh, indicating unit Square feet per thousand British thermal units per hour.
SfPerTon | Symbol SF/ton, indicating unit Square feet per ton of refrigeration.
Shaku | Symbol å°º, indicating unit Shaku.
Shekel | Symbol â‚ª, indicating unit Currency.
SlopeDegree | Symbol Â°, indicating unit Slope degrees.
Stf | Symbol STf, indicating unit US tonnes force.
Tf | Symbol Tf, indicating unit Tonnes force.
TfDashM | Symbol Tf-m, indicating unit Tonne force meters.
TfDashMPerM | Symbol Tf-m/m, indicating unit Tonne force meters per meter.
TfPerM | Symbol Tf/m, indicating unit Tonnes force per meter.
TfPerMSup2 | Symbol Tf/mÂ², indicating unit Tonnes force per square meter.
Therm | Symbol therm, indicating unit Therms.
Ton | Symbol ton, indicating unit Tons of refrigeration.
Tonne | Symbol t, indicating unit Tonnes.
TonOfRefrigeration | Symbol ton of refrigeration, indicating unit Tons of refrigeration.
Tonsf | Symbol Tonsf, indicating unit US tonnes force.
UinPerInDegreeF | Symbol Âµin/(inÂ·Â°F), indicating unit Microinches per inch degree Fahrenheit.
UkPound | Symbol Â£, indicating unit Currency.
UmPerMDegreeC | Symbol Âµm/(mÂ·Â°C), indicating unit Micrometers per meter degree Celsius.
UsDollar | Symbol $, indicating unit Currency.
Usft | Symbol USft, indicating unit US survey feet.
Usgph | Symbol usgph, indicating unit US gallons per hour.
Usgpm | Symbol usgpm, indicating unit US gallons per minute.
UsTonnesForceSt | Symbol ST, indicating unit US tonnes force.
UsTonnesForceT | Symbol T, indicating unit US tonnes force.
UsTonnesForceTons | Symbol Tons, indicating unit US tonnes force.
UsTonnesMassSt | Symbol ST, indicating unit US tonnes mass.
UsTonnesMassT | Symbol T, indicating unit US tonnes mass.
UsTonnesMassTons | Symbol Tons, indicating unit US tonnes mass.
VA | Symbol VA, indicating unit Volt amperes.
VAPerFtSup2 | Symbol VA/ftÂ², indicating unit Volt amperes per square foot.
VAPerMSup2 | Symbol VA/mÂ², indicating unit Volt amperes per square meter.
Volt | Symbol V, indicating unit Volts.
Watt | Symbol W, indicating unit Watts.
WMinPerFtSup3 | Symbol WÂ·min/ftÂ³, indicating unit Watts per cubic foot per minute.
Won | Symbol â‚©, indicating unit Currency.
WPerFt | Symbol W/ft, indicating unit Watts per foot.
WPerFtSup2 | Symbol W/ftÂ², indicating unit Watts per square foot.
WPerFtSup3 | Symbol W/ftÂ³, indicating unit Watts per cubic foot.
WPerM | Symbol W/m, indicating unit Watts per meter.
WPerMK | Symbol W/(mÂ·K), indicating unit Watts per meter kelvin.
WPerMSup2 | Symbol W/mÂ², indicating unit Watts per square meter.
WPerMSup2K | Symbol W/(mÂ²Â·K), indicating unit Watts per square meter kelvin.
WPerMSup3 | Symbol W/mÂ³, indicating unit Watts per cubic meter.
WSPerMSup3 | Symbol WÂ·s/mÂ³, indicating unit Watts per cubic meter per second.
YdCaret3 | Symbol yd^3, indicating unit Cubic yards.
YdSup3 | Symbol ydÂ³, indicating unit Cubic yards.
Yen | Symbol Â¥, indicating unit Currency.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SymbolTypeId Properties

The SymbolTypeId type exposes the following members.

Properties
Name | Description
Acres | Symbol acres, indicating unit Acres.
Ampere | Symbol A, indicating unit Amperes.
Atm | Symbol atm, indicating unit Atmospheres.
Baht | Symbol à¸¿, indicating unit Currency.
Bar | Symbol bar, indicating unit Bars.
Btu | Symbol Btu, indicating unit British thermal units.
BtuPerDegreeF | Symbol BTU/Â°F, indicating unit British thermal units per degree Fahrenheit.
BtuPerFtSup2DegreeF | Symbol BTU/(ftÂ²Â·Â°F), indicating unit British thermal units per square foot degree Fahrenheit.
BtuPerH | Symbol Btu/h, indicating unit British thermal units per hour.
BtuPerHFtDegreeF | Symbol BTU/(hÂ·ftÂ·Â°F), indicating unit British thermal units per hour foot degree Fahrenheit.
BtuPerHFtSup2 | Symbol Btu/(hÂ·ftÂ²), indicating unit British thermal units per hour square foot.
BtuPerHFtSup2DegreeF | Symbol BTU/(hÂ·ftÂ²Â·Â°F), indicating unit British thermal units per hour square foot degree Fahrenheit.
BtuPerHFtSup3 | Symbol Btu/(hÂ·ftÂ³), indicating unit British thermal units per hour cubic foot.
BtuPerLb | Symbol BTU/lb, indicating unit British thermal units per pound.
BtuPerLbDegreeF | Symbol BTU/(lbÂ·Â°F), indicating unit British thermal units per pound degree Fahrenheit.
BtuPerS | Symbol Btu/s, indicating unit British thermal units per second.
Cal | Symbol cal, indicating unit Calories.
CalPerS | Symbol cal/s, indicating unit Calories per second.
Cd | Symbol cd, indicating unit Candelas.
CdPerFtSup2 | Symbol cd/ftÂ², indicating unit Candelas per square foot.
CdPerMSup2 | Symbol cd/mÂ², indicating unit Candelas per square meter.
Cf | Symbol CF, indicating unit Cubic feet.
Cfh | Symbol CFH, indicating unit Cubic feet per hour.
Cfm | Symbol CFM, indicating unit Cubic feet per minute.
CfmPerCf | Symbol CFM/CF, indicating unit Cubic feet per minute cubic foot.
CfmPerFtSup2 | Symbol CFM/ftÂ², indicating unit Cubic feet per minute square foot.
CfmPerFtSup3 | Symbol CFM/ftÂ³, indicating unit Cubic feet per minute cubic foot.
CfmPerSf | Symbol CFM/SF, indicating unit Cubic feet per minute square foot.
CfmPerTon | Symbol CFM/ton, indicating unit Cubic feet per minute ton of refrigeration.
ChineseHongKongDollar | Symbol HK$, indicating unit Currency.
Cm | Symbol cm, indicating unit Centimeters.
CmCaret2 | Symbol cm^2, indicating unit Square centimeters.
CmCaret3 | Symbol cm^3, indicating unit Cubic centimeters.
Cmh | Symbol CMH, indicating unit Cubic meters per hour.
CmPerMin | Symbol cm/min, indicating unit Centimeters per minute.
Cms | Symbol CMS, indicating unit Cubic meters per second.
CmSup2 | Symbol cmÂ², indicating unit Square centimeters.
CmSup2PerM | Symbol cmÂ²/m, indicating unit Square centimeters per meter.
CmSup3 | Symbol cmÂ³, indicating unit Cubic centimeters.
CmSup4 | Symbol cmâ´, indicating unit Centimeters to the fourth power.
CmSup6 | Symbol cmâ¶, indicating unit Centimeters to the sixth power.
Colon1 | Symbol :1, indicating unit Ratio : 1.
Colon10 | Symbol :10, indicating unit Ratio : 10.
Colon12 | Symbol :12, indicating unit Ratio : 12.
CP | Symbol cP, indicating unit Centipoises.
Cps | Symbol cps, indicating unit Cycles per second.
Custom | Unrecognized custom symbol.
Cy | Symbol CY, indicating unit Cubic yards.
DaN | Symbol daN, indicating unit Dekanewtons.
DaNDashM | Symbol daN-m, indicating unit Dekanewton meters.
DaNDashMPerM | Symbol daN-m/m, indicating unit Dekanewton meters per meter.
DaNPerM | Symbol daN/m, indicating unit Dekanewtons per meter.
DaNPerMSup2 | Symbol daN/mÂ², indicating unit Dekanewtons per square meter.
Degree | Symbol Â°, indicating unit Degrees.
DegreeC | Symbol Â°C, indicating unit Celsius.
DegreeCInterval | Symbol Â°C, indicating unit Celsius interval.
DegreeF | Symbol Â°F, indicating unit Fahrenheit.
DegreeFInterval | Symbol Â°F, indicating unit Fahrenheit interval.
DegreeR | Symbol Â°R, indicating unit Rankine.
DegreeRInterval | Symbol Â°R, indicating unit Rankine interval.
DeltaDegreeC | Symbol deltaÂ°C, indicating unit Celsius interval.
DeltaDegreeF | Symbol deltaÂ°F, indicating unit Fahrenheit interval.
DeltaDegreeR | Symbol deltaÂ°R, indicating unit Rankine interval.
DeltaK | Symbol deltaK, indicating unit Kelvin interval.
Dm | Symbol dm, indicating unit Decimeters.
DollarHPerBtu | Symbol $Â·h/Btu, indicating unit Cost per British thermal unit per hour.
DollarPerBtu | Symbol $/Btu, indicating unit Cost per British thermal unit.
DollarPerFtSup2 | Symbol $/ftÂ², indicating unit Cost per square foot.
DollarPerMSup2 | Symbol $/mÂ², indicating unit Cost per square meter.
DollarPerW | Symbol $/W, indicating unit Cost per watt.
DollarPerWH | Symbol $/(WÂ·h), indicating unit Cost per watt hour.
Dong | Symbol â‚«, indicating unit Currency.
EuroPrefix | Symbol â‚¬, indicating unit Currency.
EuroSuffix | Symbol â‚¬, indicating unit Currency.
Fc | Symbol fc, indicating unit Footcandles.
FeetOfWater | Symbol Feet, indicating unit Feet of water (39.2 Â°F).
FeetOfWaterPer100ft | Symbol Feet/100ft, indicating unit Feet of water (39.2 Â°F) per 100 feet.
FL | Symbol fL, indicating unit Footlamberts.
FlLowercase | Symbol fl, indicating unit Footlamberts.
FootSingleQuote | Symbol ', indicating unit Feet.
Fpm | Symbol FPM, indicating unit Feet per minute.
Fps | Symbol FPS, indicating unit Feet per second.
Ft | Symbol ft, indicating unit Feet.
Ftc | Symbol Ftc, indicating unit Footcandles.
FtCaret2 | Symbol ft^2, indicating unit Square feet.
FtCaret3 | Symbol ft^3, indicating unit Cubic feet.
FtH2O | Symbol ftH2O, indicating unit Feet of water (39.2 Â°F).
FtH2OPer100ft | Symbol ftH2O/100ft, indicating unit Feet of water (39.2 Â°F) per 100 feet.
FtL | Symbol ftL, indicating unit Footlamberts.
FtOfWater | Symbol FT, indicating unit Feet of water (39.2 Â°F).
FtOfWaterPer100ft | Symbol FT/100ft, indicating unit Feet of water (39.2 Â°F) per 100 feet.
FtPerKip | Symbol ft/kip, indicating unit Feet per kip.
FtPerMin | Symbol ft/min, indicating unit Feet per minute.
FtPerS | Symbol ft/s, indicating unit Feet per second.
FtPerSSup2 | Symbol ft/sÂ², indicating unit Feet per second squared.
FtSup2 | Symbol ftÂ², indicating unit Square feet.
FtSup2HPerKbtu | Symbol ftÂ²Â·h/kBtu, indicating unit Square feet per thousand British thermal units per hour.
FtSup2PerFt | Symbol ftÂ²/ft, indicating unit Square feet per foot.
FtSup2PerKip | Symbol ftÂ²/kip, indicating unit Square feet per kip.
FtSup2PerMbh | Symbol ftÂ²/MBh, indicating unit Square feet per thousand British thermal units per hour.
FtSup2PerS | Symbol ftÂ²/s, indicating unit Square feet per second.
FtSup2PerTon | Symbol ftÂ²/ton, indicating unit Square feet per ton of refrigeration.
FtSup3 | Symbol ftÂ³, indicating unit Cubic feet.
FtSup3HPerMinBtu | Symbol ftÂ³Â·h/(minÂ·Btu), indicating unit Cubic feet per minute per British thermal unit per hour.
FtSup3PerH | Symbol ftÂ³/h, indicating unit Cubic feet per hour.
FtSup3PerKip | Symbol ftÂ³/kip, indicating unit Cubic feet per kip.
FtSup3PerLbMass | Symbol ftÂ³/lb, indicating unit Cubic feet per pound mass.
FtSup3PerMin | Symbol ftÂ³/min, indicating unit Cubic feet per minute.
FtSup4 | Symbol ftâ´, indicating unit Feet to the fourth power.
FtSup6 | Symbol ftâ¶, indicating unit Feet to the sixth power.
Gal | Symbol gal, indicating unit US gallons.
GalPerH | Symbol gal/h, indicating unit US gallons per hour.
GalPerMin | Symbol gal/min, indicating unit US gallons per minute.
GJ | Symbol GJ, indicating unit Gigajoules.
Gph | Symbol GPH, indicating unit US gallons per hour.
Gpm | Symbol GPM, indicating unit US gallons per minute.
Grad | Symbol grad, indicating unit Gradians.
GrPerHFtSup2InHg | Symbol gr/(hÂ·ftÂ²Â·inHg), indicating unit Grains per hour square foot inch mercury.
Hectare | Symbol hectare, indicating unit Hectares.
HFtSup2DegreeFPerBtu | Symbol (hÂ·ftÂ²Â·Â°F)/BTU, indicating unit Hour square foot degrees Fahrenheit per British thermal unit.
Hour | Symbol h, indicating unit Hours.
Hp | Symbol hp, indicating unit Horsepower.
Hz | Symbol Hz, indicating unit Hertz.
In | Symbol in, indicating unit Inches.
InCaret2 | Symbol in^2, indicating unit Square inches.
InCaret3 | Symbol in^3, indicating unit Cubic inches.
InchDoubleQuote | Symbol ", indicating unit Inches.
InDashWg | Symbol in-wg, indicating unit Inches of water (60 Â°F).
InDashWgPer100ft | Symbol in-wg/100ft, indicating unit Inches of water (60 Â°F) per 100 feet.
InHg | Symbol inHg, indicating unit Inches of mercury (32 Â°F).
InPerSSup2 | Symbol in/sÂ², indicating unit Inches per second squared.
InSup2 | Symbol inÂ², indicating unit Square inches.
InSup2PerFt | Symbol inÂ²/ft, indicating unit Square inches per foot.
InSup3 | Symbol inÂ³, indicating unit Cubic inches.
InSup4 | Symbol inâ´, indicating unit Inches to the fourth power.
InSup6 | Symbol inâ¶, indicating unit Inches to the sixth power.
InvDegreeC | Symbol 1/Â°C, indicating unit Inverse degrees Celsius.
InvDegreeF | Symbol 1/Â°F, indicating unit Inverse degrees Fahrenheit.
InvKip | Symbol 1/kip, indicating unit Inverse kips.
InvKN | Symbol 1/kN, indicating unit Inverse kilonewtons.
Joule | Symbol J, indicating unit Joules.
JPerG | Symbol J/g, indicating unit Joules per gram.
JPerGDegreeC | Symbol J/(gÂ·Â°C), indicating unit Joules per gram degree Celsius.
JPerK | Symbol J/K, indicating unit Joules per Kelvin.
JPerKgDegreeC | Symbol J/(kgÂ·Â°C), indicating unit Joules per kilogram degree Celsius.
JPerMSup2K | Symbol J/(mÂ²Â·K), indicating unit Joules per square meter Kelvin.
KA | Symbol kA, indicating unit Kiloamperes.
Kcal | Symbol kcal, indicating unit Kilocalories.
KcalPerS | Symbol kcal/s, indicating unit Kilocalories per second.
Kelvin | Symbol K, indicating unit Kelvin.
KelvinInterval | Symbol K, indicating unit Kelvin interval.
Kg | Symbol kg, indicating unit Kilograms.
Kgf | Symbol kgf, indicating unit Kilograms force.
KgfDashM | Symbol kgf-m, indicating unit Kilogram force meters.
KgfDashMPerM | Symbol kgf-m/m, indicating unit Kilogram force meters per meter.
KgfPerM | Symbol kgf/m, indicating unit Kilograms force per meter.
KgfPerMSup2 | Symbol kgf/mÂ², indicating unit Kilograms force per square meter.
KgPerH | Symbol kg/h, indicating unit Kilograms per hour.
KgPerKgK | Symbol kg/(kgÂ·K), indicating unit Kilograms per kilogram kelvin.
KgPerM | Symbol kg/m, indicating unit Kilograms per meter.
KgPerMH | Symbol kg/(mÂ·h), indicating unit Kilograms per meter hour.
KgPerMin | Symbol kg/min, indicating unit Kilograms per minute.
KgPerMS | Symbol kg/(mÂ·s), indicating unit Kilograms per meter second.
KgPerMSup2 | Symbol kg/mÂ², indicating unit Kilograms per square meter.
KgPerMSup3 | Symbol kg/mÂ³, indicating unit Kilograms per cubic meter.
KgPerS | Symbol kg/s, indicating unit Kilograms per second.
Kip | Symbol kip, indicating unit Kips.
KipDashFt | Symbol kip-ft, indicating unit Kip feet.
KipDashFtPerDegree | Symbol kip-ft/Â°, indicating unit Kip feet per degree.
KipDashFtPerDegreePerFt | Symbol kip-ft/Â°/ft, indicating unit Kip feet per degree per foot.
KipDashFtPerFt | Symbol kip-ft/ft, indicating unit Kip feet per foot.
KipPerFt | Symbol kip/ft, indicating unit Kips per foot.
KipPerFtSup2 | Symbol kip/ftÂ², indicating unit Kips per square foot.
KipPerFtSup3 | Symbol kip/ftÂ³, indicating unit Kips per cubic foot.
KipPerIn | Symbol kip/in, indicating unit Kips per inch.
KipPerInSup2 | Symbol kip/inÂ², indicating unit Kips per square inch.
KipPerInSup3 | Symbol kip/inÂ³, indicating unit Kips per cubic inch.
KJ | Symbol kJ, indicating unit Kilojoules.
KJPerK | Symbol kJ/K, indicating unit Kilojoules per Kelvin.
KJPerMSup2K | Symbol kJ/(mÂ²Â·K), indicating unit Kilojoules per square meter Kelvin.
KmPerH | Symbol km/h, indicating unit Kilometers per hour.
KmPerSSup2 | Symbol km/sÂ², indicating unit Kilometers per second squared.
KN | Symbol kN, indicating unit Kilonewtons.
KNDashM | Symbol kN-m, indicating unit Kilonewton meters.
KNDashMPerDegree | Symbol kN-m/Â°, indicating unit Kilonewton meters per degree.
KNDashMPerDegreePerM | Symbol kN-m/Â°/m, indicating unit Kilonewton meters per degree per meter.
KNDashMPerM | Symbol kN-m/m, indicating unit Kilonewton meters per meter.
KNPerCmSup2 | Symbol kN/cmÂ², indicating unit Kilonewtons per square centimeter.
KNPerM | Symbol kN/m, indicating unit Kilonewtons per meter.
KNPerMmSup2 | Symbol kN/mmÂ², indicating unit Kilonewtons per square millimeter.
KNPerMSup2 | Symbol kN/mÂ², indicating unit Kilonewtons per square meter.
KNPerMSup3 | Symbol kN/mÂ³, indicating unit Kilonewtons per cubic meter.
KPa | Symbol kPa, indicating unit Kilopascals.
Krone | Symbol kr, indicating unit Currency.
Ksf | Symbol ksf, indicating unit Kips per square foot.
Ksi | Symbol ksi, indicating unit Kips per square inch.
KV | Symbol kV, indicating unit Kilovolts.
KVA | Symbol kVA, indicating unit Kilovolt amperes.
KW | Symbol kW, indicating unit Kilowatts.
KWh | Symbol kWh, indicating unit Kilowatt hours.
Lbf | Symbol lbf, indicating unit Pounds force.
LbfDashFt | Symbol lbf-ft, indicating unit Pound force feet.
LbfDashFtPerFt | Symbol lbf-ft/ft, indicating unit Pound force feet per foot.
LbForce | Symbol lb, indicating unit Pounds force.
LbForceDashFt | Symbol lb-ft, indicating unit Pound force feet.
LbForceDashFtPerFt | Symbol lb-ft/ft, indicating unit Pound force feet per foot.
LbForcePerFt | Symbol lb/ft, indicating unit Pounds force per foot.
LbForcePerFtSup2 | Symbol lb/ftÂ², indicating unit Pounds force per square foot.
LbForcePerFtSup3 | Symbol lb/ftÂ³, indicating unit Pounds force per cubic foot.
LbForcePerInSup2 | Symbol lb/inÂ², indicating unit Pounds force per square inch.
LbForceSPerFtSup2 | Symbol lbÂ·s/ftÂ², indicating unit Pound force seconds per square foot.
LbfPerFt | Symbol lbf/ft, indicating unit Pounds force per foot.
LbfPerFtSup2 | Symbol lbf/ftÂ², indicating unit Pounds force per square foot.
LbfPerFtSup3 | Symbol lbf/ftÂ³, indicating unit Pounds force per cubic foot.
LbfPerInSup2 | Symbol lbf/inÂ², indicating unit Pounds force per square inch.
Lbm | Symbol lbm, indicating unit Pounds mass.
LbMass | Symbol lb, indicating unit Pounds mass.
LbMassPerFt | Symbol lb/ft, indicating unit Pounds mass per foot.
LbMassPerFtDashH | Symbol lb/ft-h, indicating unit Pounds mass per foot hour.
LbMassPerFtDashS | Symbol lb/ft-s, indicating unit Pounds mass per foot second.
LbMassPerFtSup2 | Symbol lb/ftÂ², indicating unit Pounds mass per square foot.
LbMassPerFtSup3 | Symbol lb/ftÂ³, indicating unit Pounds mass per cubic foot.
LbMassPerH | Symbol lb/h, indicating unit Pounds mass per hour.
LbMassPerInSup3 | Symbol lb/inÂ³, indicating unit Pounds mass per cubic inch.
LbMassPerLbDegreeF | Symbol lb/(lbÂ·Â°F), indicating unit Pounds mass per pound degree Fahrenheit.
LbMassPerMin | Symbol lb/min, indicating unit Pounds mass per minute.
LbMassPerS | Symbol lb/s, indicating unit Pounds mass per second.
LbmPerFt | Symbol lbm/ft, indicating unit Pounds mass per foot.
LbmPerFtDashH | Symbol lbm/ft-h, indicating unit Pounds mass per foot hour.
LbmPerFtDashS | Symbol lbm/ft-s, indicating unit Pounds mass per foot second.
LbmPerFtSup3 | Symbol lbm/ftÂ³, indicating unit Pounds mass per cubic foot.
LbmPerInSup3 | Symbol lbm/inÂ³, indicating unit Pounds mass per cubic inch.
Lf | Symbol LF, indicating unit Feet.
Liter | Symbol L, indicating unit Liters.
Lm | Symbol lm, indicating unit Lumens.
LmPerW | Symbol lm/W, indicating unit Lumens per watt.
LPerH | Symbol L/h, indicating unit Liters per hour.
LPerMin | Symbol L/min, indicating unit Liters per minute.
LPerS | Symbol L/s, indicating unit Liters per second.
LPerSKw | Symbol L/(sÂ·kW), indicating unit Liters per second kilowatt.
LPerSMSup2 | Symbol L/(sÂ·mÂ²), indicating unit Liters per second square meter.
LPerSMSup3 | Symbol L/(sÂ·mÂ³), indicating unit Liters per second cubic meter.
Lpm | Symbol LPM, indicating unit Liters per minute.
Lps | Symbol LPS, indicating unit Liters per second.
LpsPerMSup2 | Symbol LPS/mÂ², indicating unit Liters per second square meter.
Lx | Symbol lx, indicating unit Lux.
MA | Symbol mA, indicating unit Milliamperes.
Mbh | Symbol MBH, indicating unit Thousand British thermal units per hour.
MCaret2 | Symbol m^2, indicating unit Square meters.
MCaret3 | Symbol m^3, indicating unit Cubic meters.
Meter | Symbol m, indicating unit Meters.
MH2O | Symbol mH2O, indicating unit Meters of water column.
MH2OPerM | Symbol mH2O/m, indicating unit Meters of water column per meter.
Min | Symbol min, indicating unit Minutes.
MiPerSSup2 | Symbol mi/sÂ², indicating unit Miles per second squared.
MJ | Symbol MJ, indicating unit Megajoules.
Mm | Symbol mm, indicating unit Millimeters.
MmCaret2 | Symbol mm^2, indicating unit Square millimeters.
MmCaret3 | Symbol mm^3, indicating unit Cubic millimeters.
MmH2O | Symbol mmH2O, indicating unit Millimeters of water column.
MmH2OPerM | Symbol mmH2O/m, indicating unit Millimeters of water column per meter.
MmHg | Symbol mmHg, indicating unit Millimeters of mercury.
MmSup2 | Symbol mmÂ², indicating unit Square millimeters.
MmSup2PerM | Symbol mmÂ²/m, indicating unit Square millimeters per meter.
MmSup3 | Symbol mmÂ³, indicating unit Cubic millimeters.
MmSup4 | Symbol mmâ´, indicating unit Millimeters to the fourth power.
MmSup6 | Symbol mmâ¶, indicating unit Millimeters to the sixth power.
MN | Symbol MN, indicating unit Meganewtons.
MNDashM | Symbol MN-m, indicating unit Meganewton meters.
MNDashMPerM | Symbol MN-m/m, indicating unit Meganewton meters per meter.
MNPerM | Symbol MN/m, indicating unit Meganewtons per meter.
MNPerMSup2 | Symbol MN/mÂ², indicating unit Meganewtons per square meter.
MPa | Symbol MPa, indicating unit Megapascals.
MPerKN | Symbol m/kN, indicating unit Meters per kilonewton.
MPerS | Symbol m/s, indicating unit Meters per second.
MPerSSup2 | Symbol m/sÂ², indicating unit Meters per second squared.
Mph | Symbol mph, indicating unit Miles per hour.
Ms | Symbol ms, indicating unit Milliseconds.
MSup2 | Symbol mÂ², indicating unit Square meters.
MSup2KPerW | Symbol (mÂ²Â·K)/W, indicating unit Square meter kelvins per watt.
MSup2PerKN | Symbol mÂ²/kN, indicating unit Square meters per kilonewton.
MSup2PerKw | Symbol mÂ²/kW, indicating unit Square meters per kilowatt.
MSup2PerM | Symbol mÂ²/m, indicating unit Square meters per meter.
MSup2PerS | Symbol mÂ²/s, indicating unit Square meters per second.
MSup3 | Symbol mÂ³, indicating unit Cubic meters.
MSup3PerH | Symbol mÂ³/h, indicating unit Cubic meters per hour.
MSup3PerHMSup2 | Symbol mÂ³/(hÂ·mÂ²), indicating unit Cubic meters per hour square meter.
MSup3PerHMSup3 | Symbol mÂ³/(hÂ·mÂ³), indicating unit Cubic meters per hour cubic meter.
MSup3PerKg | Symbol mÂ³/kg, indicating unit Cubic meters per kilogram.
MSup3PerKN | Symbol mÂ³/kN, indicating unit Cubic meters per kilonewton.
MSup3PerS | Symbol mÂ³/s, indicating unit Cubic meters per second.
MSup3PerWS | Symbol mÂ³/(WÂ·s), indicating unit Cubic meters per watt second.
MSup4 | Symbol mâ´, indicating unit Meters to the fourth power.
MSup6 | Symbol mâ¶, indicating unit Meters to the sixth power.
MV | Symbol mV, indicating unit Millivolts.
MW | Symbol MW, indicating unit Megawatts.
NDashM | Symbol N-m, indicating unit Newton meters.
NDashMPerM | Symbol N-m/m, indicating unit Newton meters per meter.
Newton | Symbol N, indicating unit Newtons.
NgPerPaSMSup2 | Symbol ng/(PaÂ·sÂ·mÂ²), indicating unit Nanograms per pascal second square meter.
NPerM | Symbol N/m, indicating unit Newtons per meter.
NPerMmSup2 | Symbol N/mmÂ², indicating unit Newtons per square millimeter.
NPerMSup2 | Symbol N/mÂ², indicating unit Newtons per square meter.
NSPerMSup2 | Symbol NÂ·s/mÂ², indicating unit Newton seconds per square meter.
OhmM | Symbol ohmÂ·m, indicating unit Ohm meters.
OneColon | Symbol 1:, indicating unit 1 : Ratio.
Pa | Symbol Pa, indicating unit Pascals.
PaDashS | Symbol Pa-s, indicating unit Pascal seconds.
PaPerM | Symbol Pa/m, indicating unit Pascals per meter.
Percent | Symbol %, indicating unit Percentage.
PerMille | Symbol â€°, indicating unit Per mille.
Pi | Symbol Ï€, indicating unit Multiples of Ï€.
Psf | Symbol psf, indicating unit Pounds force per square foot.
Psi | Symbol psi, indicating unit Pounds force per square inch.
Psia | Symbol psia, indicating unit Pounds force per square inch.
Psig | Symbol psig, indicating unit Pounds force per square inch.
Rad | Symbol rad, indicating unit Radians.
RadPerS | Symbol rad/s, indicating unit Radians per second.
Rpm | Symbol RPM, indicating unit Revolutions per minute.
Rps | Symbol RPS, indicating unit Revolutions per second.
Second | Symbol s, indicating unit Seconds.
Sf | Symbol SF, indicating unit Square feet.
SfHPerKbtu | Symbol SFÂ·h/kBtu, indicating unit Square feet per thousand British thermal units per hour.
SfPerMbh | Symbol SF/MBh, indicating unit Square feet per thousand British thermal units per hour.
SfPerTon | Symbol SF/ton, indicating unit Square feet per ton of refrigeration.
Shaku | Symbol å°º, indicating unit Shaku.
Shekel | Symbol â‚ª, indicating unit Currency.
SlopeDegree | Symbol Â°, indicating unit Slope degrees.
Stf | Symbol STf, indicating unit US tonnes force.
Tf | Symbol Tf, indicating unit Tonnes force.
TfDashM | Symbol Tf-m, indicating unit Tonne force meters.
TfDashMPerM | Symbol Tf-m/m, indicating unit Tonne force meters per meter.
TfPerM | Symbol Tf/m, indicating unit Tonnes force per meter.
TfPerMSup2 | Symbol Tf/mÂ², indicating unit Tonnes force per square meter.
Therm | Symbol therm, indicating unit Therms.
Ton | Symbol ton, indicating unit Tons of refrigeration.
Tonne | Symbol t, indicating unit Tonnes.
TonOfRefrigeration | Symbol ton of refrigeration, indicating unit Tons of refrigeration.
Tonsf | Symbol Tonsf, indicating unit US tonnes force.
UinPerInDegreeF | Symbol Âµin/(inÂ·Â°F), indicating unit Microinches per inch degree Fahrenheit.
UkPound | Symbol Â£, indicating unit Currency.
UmPerMDegreeC | Symbol Âµm/(mÂ·Â°C), indicating unit Micrometers per meter degree Celsius.
UsDollar | Symbol $, indicating unit Currency.
Usft | Symbol USft, indicating unit US survey feet.
Usgph | Symbol usgph, indicating unit US gallons per hour.
Usgpm | Symbol usgpm, indicating unit US gallons per minute.
UsTonnesForceSt | Symbol ST, indicating unit US tonnes force.
UsTonnesForceT | Symbol T, indicating unit US tonnes force.
UsTonnesForceTons | Symbol Tons, indicating unit US tonnes force.
UsTonnesMassSt | Symbol ST, indicating unit US tonnes mass.
UsTonnesMassT | Symbol T, indicating unit US tonnes mass.
UsTonnesMassTons | Symbol Tons, indicating unit US tonnes mass.
VA | Symbol VA, indicating unit Volt amperes.
VAPerFtSup2 | Symbol VA/ftÂ², indicating unit Volt amperes per square foot.
VAPerMSup2 | Symbol VA/mÂ², indicating unit Volt amperes per square meter.
Volt | Symbol V, indicating unit Volts.
Watt | Symbol W, indicating unit Watts.
WMinPerFtSup3 | Symbol WÂ·min/ftÂ³, indicating unit Watts per cubic foot per minute.
Won | Symbol â‚©, indicating unit Currency.
WPerFt | Symbol W/ft, indicating unit Watts per foot.
WPerFtSup2 | Symbol W/ftÂ², indicating unit Watts per square foot.
WPerFtSup3 | Symbol W/ftÂ³, indicating unit Watts per cubic foot.
WPerM | Symbol W/m, indicating unit Watts per meter.
WPerMK | Symbol W/(mÂ·K), indicating unit Watts per meter kelvin.
WPerMSup2 | Symbol W/mÂ², indicating unit Watts per square meter.
WPerMSup2K | Symbol W/(mÂ²Â·K), indicating unit Watts per square meter kelvin.
WPerMSup3 | Symbol W/mÂ³, indicating unit Watts per cubic meter.
WSPerMSup3 | Symbol WÂ·s/mÂ³, indicating unit Watts per cubic meter per second.
YdCaret3 | Symbol yd^3, indicating unit Cubic yards.
YdSup3 | Symbol ydÂ³, indicating unit Cubic yards.
Yen | Symbol Â¥, indicating unit Currency.
Top
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Acres Property

SymbolTypeIdAcres Property

Symbol acres, indicating unit Acres.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Acres { get; }
Public Shared ReadOnly Property Acres As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Acres {
    ForgeTypeId^ get ();
}
static member Acres : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Ampere Property

SymbolTypeIdAmpere Property

Symbol A, indicating unit Amperes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Ampere { get; }
Public Shared ReadOnly Property Ampere As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Ampere {
    ForgeTypeId^ get ();
}
static member Ampere : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Atm Property

SymbolTypeIdAtm Property

Symbol atm, indicating unit Atmospheres.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Atm { get; }
Public Shared ReadOnly Property Atm As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Atm {
    ForgeTypeId^ get ();
}
static member Atm : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Baht Property

SymbolTypeIdBaht Property

Symbol à¸¿, indicating unit Currency.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Baht { get; }
Public Shared ReadOnly Property Baht As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Baht {
    ForgeTypeId^ get ();
}
static member Baht : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Bar Property

SymbolTypeIdBar Property

Symbol bar, indicating unit Bars.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Bar { get; }
Public Shared ReadOnly Property Bar As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Bar {
    ForgeTypeId^ get ();
}
static member Bar : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Btu Property

SymbolTypeIdBtu Property

Symbol Btu, indicating unit British thermal units.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Btu { get; }
Public Shared ReadOnly Property Btu As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Btu {
    ForgeTypeId^ get ();
}
static member Btu : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.BtuPerDegreeF Property

SymbolTypeIdBtuPerDegreeF Property

Symbol BTU/Â°F, indicating unit British thermal units per degree Fahrenheit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BtuPerDegreeF { get; }
Public Shared ReadOnly Property BtuPerDegreeF As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BtuPerDegreeF {
    ForgeTypeId^ get ();
}
static member BtuPerDegreeF : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.BtuPerFtSup2DegreeF Property

SymbolTypeIdBtuPerFtSup2DegreeF Property

Symbol BTU/(ftÂ²Â·Â°F), indicating unit British thermal units per square foot degree Fahrenheit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BtuPerFtSup2DegreeF { get; }
Public Shared ReadOnly Property BtuPerFtSup2DegreeF As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BtuPerFtSup2DegreeF {
    ForgeTypeId^ get ();
}
static member BtuPerFtSup2DegreeF : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.BtuPerH Property

SymbolTypeIdBtuPerH Property

Symbol Btu/h, indicating unit British thermal units per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BtuPerH { get; }
Public Shared ReadOnly Property BtuPerH As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BtuPerH {
    ForgeTypeId^ get ();
}
static member BtuPerH : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.BtuPerHFtDegreeF Property

SymbolTypeIdBtuPerHFtDegreeF Property

Symbol BTU/(hÂ·ftÂ·Â°F), indicating unit British thermal units per hour foot degree Fahrenheit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BtuPerHFtDegreeF { get; }
Public Shared ReadOnly Property BtuPerHFtDegreeF As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BtuPerHFtDegreeF {
    ForgeTypeId^ get ();
}
static member BtuPerHFtDegreeF : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.BtuPerHFtSup2 Property

SymbolTypeIdBtuPerHFtSup2 Property

Symbol Btu/(hÂ·ftÂ²), indicating unit British thermal units per hour square foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BtuPerHFtSup2 { get; }
Public Shared ReadOnly Property BtuPerHFtSup2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BtuPerHFtSup2 {
    ForgeTypeId^ get ();
}
static member BtuPerHFtSup2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.BtuPerHFtSup2DegreeF Property

SymbolTypeIdBtuPerHFtSup2DegreeF Property

Symbol BTU/(hÂ·ftÂ²Â·Â°F), indicating unit British thermal units per hour square foot degree Fahrenheit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BtuPerHFtSup2DegreeF { get; }
Public Shared ReadOnly Property BtuPerHFtSup2DegreeF As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BtuPerHFtSup2DegreeF {
    ForgeTypeId^ get ();
}
static member BtuPerHFtSup2DegreeF : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.BtuPerHFtSup3 Property

SymbolTypeIdBtuPerHFtSup3 Property

Symbol Btu/(hÂ·ftÂ³), indicating unit British thermal units per hour cubic foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BtuPerHFtSup3 { get; }
Public Shared ReadOnly Property BtuPerHFtSup3 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BtuPerHFtSup3 {
    ForgeTypeId^ get ();
}
static member BtuPerHFtSup3 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.BtuPerLb Property

SymbolTypeIdBtuPerLb Property

Symbol BTU/lb, indicating unit British thermal units per pound.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BtuPerLb { get; }
Public Shared ReadOnly Property BtuPerLb As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BtuPerLb {
    ForgeTypeId^ get ();
}
static member BtuPerLb : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.BtuPerLbDegreeF Property

SymbolTypeIdBtuPerLbDegreeF Property

Symbol BTU/(lbÂ·Â°F), indicating unit British thermal units per pound degree Fahrenheit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BtuPerLbDegreeF { get; }
Public Shared ReadOnly Property BtuPerLbDegreeF As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BtuPerLbDegreeF {
    ForgeTypeId^ get ();
}
static member BtuPerLbDegreeF : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.BtuPerS Property

SymbolTypeIdBtuPerS Property

Symbol Btu/s, indicating unit British thermal units per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BtuPerS { get; }
Public Shared ReadOnly Property BtuPerS As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BtuPerS {
    ForgeTypeId^ get ();
}
static member BtuPerS : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Cal Property

SymbolTypeIdCal Property

Symbol cal, indicating unit Calories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Cal { get; }
Public Shared ReadOnly Property Cal As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Cal {
    ForgeTypeId^ get ();
}
static member Cal : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.CalPerS Property

SymbolTypeIdCalPerS Property

Symbol cal/s, indicating unit Calories per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CalPerS { get; }
Public Shared ReadOnly Property CalPerS As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CalPerS {
    ForgeTypeId^ get ();
}
static member CalPerS : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Cd Property

SymbolTypeIdCd Property

Symbol cd, indicating unit Candelas.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Cd { get; }
Public Shared ReadOnly Property Cd As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Cd {
    ForgeTypeId^ get ();
}
static member Cd : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.CdPerFtSup2 Property

SymbolTypeIdCdPerFtSup2 Property

Symbol cd/ftÂ², indicating unit Candelas per square foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CdPerFtSup2 { get; }
Public Shared ReadOnly Property CdPerFtSup2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CdPerFtSup2 {
    ForgeTypeId^ get ();
}
static member CdPerFtSup2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.CdPerMSup2 Property

SymbolTypeIdCdPerMSup2 Property

Symbol cd/mÂ², indicating unit Candelas per square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CdPerMSup2 { get; }
Public Shared ReadOnly Property CdPerMSup2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CdPerMSup2 {
    ForgeTypeId^ get ();
}
static member CdPerMSup2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Cf Property

SymbolTypeIdCf Property

Symbol CF, indicating unit Cubic feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Cf { get; }
Public Shared ReadOnly Property Cf As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Cf {
    ForgeTypeId^ get ();
}
static member Cf : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Cfh Property

SymbolTypeIdCfh Property

Symbol CFH, indicating unit Cubic feet per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Cfh { get; }
Public Shared ReadOnly Property Cfh As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Cfh {
    ForgeTypeId^ get ();
}
static member Cfh : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Cfm Property

SymbolTypeIdCfm Property

Symbol CFM, indicating unit Cubic feet per minute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Cfm { get; }
Public Shared ReadOnly Property Cfm As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Cfm {
    ForgeTypeId^ get ();
}
static member Cfm : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.CfmPerCf Property

SymbolTypeIdCfmPerCf Property

Symbol CFM/CF, indicating unit Cubic feet per minute cubic foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CfmPerCf { get; }
Public Shared ReadOnly Property CfmPerCf As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CfmPerCf {
    ForgeTypeId^ get ();
}
static member CfmPerCf : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.CfmPerFtSup2 Property

SymbolTypeIdCfmPerFtSup2 Property

Symbol CFM/ftÂ², indicating unit Cubic feet per minute square foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CfmPerFtSup2 { get; }
Public Shared ReadOnly Property CfmPerFtSup2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CfmPerFtSup2 {
    ForgeTypeId^ get ();
}
static member CfmPerFtSup2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.CfmPerFtSup3 Property

SymbolTypeIdCfmPerFtSup3 Property

Symbol CFM/ftÂ³, indicating unit Cubic feet per minute cubic foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CfmPerFtSup3 { get; }
Public Shared ReadOnly Property CfmPerFtSup3 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CfmPerFtSup3 {
    ForgeTypeId^ get ();
}
static member CfmPerFtSup3 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.CfmPerSf Property

SymbolTypeIdCfmPerSf Property

Symbol CFM/SF, indicating unit Cubic feet per minute square foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CfmPerSf { get; }
Public Shared ReadOnly Property CfmPerSf As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CfmPerSf {
    ForgeTypeId^ get ();
}
static member CfmPerSf : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.CfmPerTon Property

SymbolTypeIdCfmPerTon Property

Symbol CFM/ton, indicating unit Cubic feet per minute ton of refrigeration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CfmPerTon { get; }
Public Shared ReadOnly Property CfmPerTon As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CfmPerTon {
    ForgeTypeId^ get ();
}
static member CfmPerTon : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.ChineseHongKongDollar Property

SymbolTypeIdChineseHongKongDollar Property

Symbol HK$, indicating unit Currency.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ChineseHongKongDollar { get; }
Public Shared ReadOnly Property ChineseHongKongDollar As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ChineseHongKongDollar {
    ForgeTypeId^ get ();
}
static member ChineseHongKongDollar : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Cm Property

SymbolTypeIdCm Property

Symbol cm, indicating unit Centimeters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Cm { get; }
Public Shared ReadOnly Property Cm As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Cm {
    ForgeTypeId^ get ();
}
static member Cm : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.CmCaret2 Property

SymbolTypeIdCmCaret2 Property

Symbol cm^2, indicating unit Square centimeters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CmCaret2 { get; }
Public Shared ReadOnly Property CmCaret2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CmCaret2 {
    ForgeTypeId^ get ();
}
static member CmCaret2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.CmCaret3 Property

SymbolTypeIdCmCaret3 Property

Symbol cm^3, indicating unit Cubic centimeters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CmCaret3 { get; }
Public Shared ReadOnly Property CmCaret3 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CmCaret3 {
    ForgeTypeId^ get ();
}
static member CmCaret3 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Cmh Property

SymbolTypeIdCmh Property

Symbol CMH, indicating unit Cubic meters per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Cmh { get; }
Public Shared ReadOnly Property Cmh As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Cmh {
    ForgeTypeId^ get ();
}
static member Cmh : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.CmPerMin Property

SymbolTypeIdCmPerMin Property

Symbol cm/min, indicating unit Centimeters per minute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CmPerMin { get; }
Public Shared ReadOnly Property CmPerMin As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CmPerMin {
    ForgeTypeId^ get ();
}
static member CmPerMin : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Cms Property

SymbolTypeIdCms Property

Symbol CMS, indicating unit Cubic meters per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Cms { get; }
Public Shared ReadOnly Property Cms As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Cms {
    ForgeTypeId^ get ();
}
static member Cms : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.CmSup2 Property

SymbolTypeIdCmSup2 Property

Symbol cmÂ², indicating unit Square centimeters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CmSup2 { get; }
Public Shared ReadOnly Property CmSup2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CmSup2 {
    ForgeTypeId^ get ();
}
static member CmSup2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.CmSup2PerM Property

SymbolTypeIdCmSup2PerM Property

Symbol cmÂ²/m, indicating unit Square centimeters per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CmSup2PerM { get; }
Public Shared ReadOnly Property CmSup2PerM As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CmSup2PerM {
    ForgeTypeId^ get ();
}
static member CmSup2PerM : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.CmSup3 Property

SymbolTypeIdCmSup3 Property

Symbol cmÂ³, indicating unit Cubic centimeters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CmSup3 { get; }
Public Shared ReadOnly Property CmSup3 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CmSup3 {
    ForgeTypeId^ get ();
}
static member CmSup3 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.CmSup4 Property

SymbolTypeIdCmSup4 Property

Symbol cmâ´, indicating unit Centimeters to the fourth power.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CmSup4 { get; }
Public Shared ReadOnly Property CmSup4 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CmSup4 {
    ForgeTypeId^ get ();
}
static member CmSup4 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.CmSup6 Property

SymbolTypeIdCmSup6 Property

Symbol cmâ¶, indicating unit Centimeters to the sixth power.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CmSup6 { get; }
Public Shared ReadOnly Property CmSup6 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CmSup6 {
    ForgeTypeId^ get ();
}
static member CmSup6 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Colon1 Property

SymbolTypeIdColon1 Property

Symbol :1, indicating unit Ratio : 1.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Colon1 { get; }
Public Shared ReadOnly Property Colon1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Colon1 {
    ForgeTypeId^ get ();
}
static member Colon1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Colon10 Property

SymbolTypeIdColon10 Property

Symbol :10, indicating unit Ratio : 10.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Colon10 { get; }
Public Shared ReadOnly Property Colon10 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Colon10 {
    ForgeTypeId^ get ();
}
static member Colon10 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Colon12 Property

SymbolTypeIdColon12 Property

Symbol :12, indicating unit Ratio : 12.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Colon12 { get; }
Public Shared ReadOnly Property Colon12 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Colon12 {
    ForgeTypeId^ get ();
}
static member Colon12 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.CP Property

SymbolTypeIdCP Property

Symbol cP, indicating unit Centipoises.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CP { get; }
Public Shared ReadOnly Property CP As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CP {
    ForgeTypeId^ get ();
}
static member CP : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Cps Property

SymbolTypeIdCps Property

Symbol cps, indicating unit Cycles per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Cps { get; }
Public Shared ReadOnly Property Cps As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Cps {
    ForgeTypeId^ get ();
}
static member Cps : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Custom Property

SymbolTypeIdCustom Property

Unrecognized custom symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Custom { get; }
Public Shared ReadOnly Property Custom As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Custom {
    ForgeTypeId^ get ();
}
static member Custom : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Cy Property

SymbolTypeIdCy Property

Symbol CY, indicating unit Cubic yards.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Cy { get; }
Public Shared ReadOnly Property Cy As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Cy {
    ForgeTypeId^ get ();
}
static member Cy : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.DaN Property

SymbolTypeIdDaN Property

Symbol daN, indicating unit Dekanewtons.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DaN { get; }
Public Shared ReadOnly Property DaN As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DaN {
    ForgeTypeId^ get ();
}
static member DaN : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.DaNDashM Property

SymbolTypeIdDaNDashM Property

Symbol daN-m, indicating unit Dekanewton meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DaNDashM { get; }
Public Shared ReadOnly Property DaNDashM As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DaNDashM {
    ForgeTypeId^ get ();
}
static member DaNDashM : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.DaNDashMPerM Property

SymbolTypeIdDaNDashMPerM Property

Symbol daN-m/m, indicating unit Dekanewton meters per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DaNDashMPerM { get; }
Public Shared ReadOnly Property DaNDashMPerM As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DaNDashMPerM {
    ForgeTypeId^ get ();
}
static member DaNDashMPerM : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.DaNPerM Property

SymbolTypeIdDaNPerM Property

Symbol daN/m, indicating unit Dekanewtons per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DaNPerM { get; }
Public Shared ReadOnly Property DaNPerM As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DaNPerM {
    ForgeTypeId^ get ();
}
static member DaNPerM : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.DaNPerMSup2 Property

SymbolTypeIdDaNPerMSup2 Property

Symbol daN/mÂ², indicating unit Dekanewtons per square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DaNPerMSup2 { get; }
Public Shared ReadOnly Property DaNPerMSup2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DaNPerMSup2 {
    ForgeTypeId^ get ();
}
static member DaNPerMSup2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Degree Property

SymbolTypeIdDegree Property

Symbol Â°, indicating unit Degrees.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Degree { get; }
Public Shared ReadOnly Property Degree As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Degree {
    ForgeTypeId^ get ();
}
static member Degree : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.DegreeC Property

SymbolTypeIdDegreeC Property

Symbol Â°C, indicating unit Celsius.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DegreeC { get; }
Public Shared ReadOnly Property DegreeC As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DegreeC {
    ForgeTypeId^ get ();
}
static member DegreeC : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.DegreeCInterval Property

SymbolTypeIdDegreeCInterval Property

Symbol Â°C, indicating unit Celsius interval.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DegreeCInterval { get; }
Public Shared ReadOnly Property DegreeCInterval As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DegreeCInterval {
    ForgeTypeId^ get ();
}
static member DegreeCInterval : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.DegreeF Property

SymbolTypeIdDegreeF Property

Symbol Â°F, indicating unit Fahrenheit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DegreeF { get; }
Public Shared ReadOnly Property DegreeF As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DegreeF {
    ForgeTypeId^ get ();
}
static member DegreeF : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.DegreeFInterval Property

SymbolTypeIdDegreeFInterval Property

Symbol Â°F, indicating unit Fahrenheit interval.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DegreeFInterval { get; }
Public Shared ReadOnly Property DegreeFInterval As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DegreeFInterval {
    ForgeTypeId^ get ();
}
static member DegreeFInterval : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.DegreeR Property

SymbolTypeIdDegreeR Property

Symbol Â°R, indicating unit Rankine.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DegreeR { get; }
Public Shared ReadOnly Property DegreeR As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DegreeR {
    ForgeTypeId^ get ();
}
static member DegreeR : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.DegreeRInterval Property

SymbolTypeIdDegreeRInterval Property

Symbol Â°R, indicating unit Rankine interval.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DegreeRInterval { get; }
Public Shared ReadOnly Property DegreeRInterval As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DegreeRInterval {
    ForgeTypeId^ get ();
}
static member DegreeRInterval : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.DeltaDegreeC Property

SymbolTypeIdDeltaDegreeC Property

Symbol deltaÂ°C, indicating unit Celsius interval.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DeltaDegreeC { get; }
Public Shared ReadOnly Property DeltaDegreeC As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DeltaDegreeC {
    ForgeTypeId^ get ();
}
static member DeltaDegreeC : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.DeltaDegreeF Property

SymbolTypeIdDeltaDegreeF Property

Symbol deltaÂ°F, indicating unit Fahrenheit interval.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DeltaDegreeF { get; }
Public Shared ReadOnly Property DeltaDegreeF As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DeltaDegreeF {
    ForgeTypeId^ get ();
}
static member DeltaDegreeF : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.DeltaDegreeR Property

SymbolTypeIdDeltaDegreeR Property

Symbol deltaÂ°R, indicating unit Rankine interval.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DeltaDegreeR { get; }
Public Shared ReadOnly Property DeltaDegreeR As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DeltaDegreeR {
    ForgeTypeId^ get ();
}
static member DeltaDegreeR : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.DeltaK Property

SymbolTypeIdDeltaK Property

Symbol deltaK, indicating unit Kelvin interval.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DeltaK { get; }
Public Shared ReadOnly Property DeltaK As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DeltaK {
    ForgeTypeId^ get ();
}
static member DeltaK : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Dm Property

SymbolTypeIdDm Property

Symbol dm, indicating unit Decimeters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Dm { get; }
Public Shared ReadOnly Property Dm As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Dm {
    ForgeTypeId^ get ();
}
static member Dm : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.DollarHPerBtu Property

SymbolTypeIdDollarHPerBtu Property

Symbol $Â·h/Btu, indicating unit Cost per British thermal unit per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DollarHPerBtu { get; }
Public Shared ReadOnly Property DollarHPerBtu As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DollarHPerBtu {
    ForgeTypeId^ get ();
}
static member DollarHPerBtu : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.DollarPerBtu Property

SymbolTypeIdDollarPerBtu Property

Symbol $/Btu, indicating unit Cost per British thermal unit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DollarPerBtu { get; }
Public Shared ReadOnly Property DollarPerBtu As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DollarPerBtu {
    ForgeTypeId^ get ();
}
static member DollarPerBtu : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.DollarPerFtSup2 Property

SymbolTypeIdDollarPerFtSup2 Property

Symbol $/ftÂ², indicating unit Cost per square foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DollarPerFtSup2 { get; }
Public Shared ReadOnly Property DollarPerFtSup2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DollarPerFtSup2 {
    ForgeTypeId^ get ();
}
static member DollarPerFtSup2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.DollarPerMSup2 Property

SymbolTypeIdDollarPerMSup2 Property

Symbol $/mÂ², indicating unit Cost per square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DollarPerMSup2 { get; }
Public Shared ReadOnly Property DollarPerMSup2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DollarPerMSup2 {
    ForgeTypeId^ get ();
}
static member DollarPerMSup2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.DollarPerW Property

SymbolTypeIdDollarPerW Property

Symbol $/W, indicating unit Cost per watt.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DollarPerW { get; }
Public Shared ReadOnly Property DollarPerW As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DollarPerW {
    ForgeTypeId^ get ();
}
static member DollarPerW : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.DollarPerWH Property

SymbolTypeIdDollarPerWH Property

Symbol $/(WÂ·h), indicating unit Cost per watt hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DollarPerWH { get; }
Public Shared ReadOnly Property DollarPerWH As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DollarPerWH {
    ForgeTypeId^ get ();
}
static member DollarPerWH : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Dong Property

SymbolTypeIdDong Property

Symbol â‚«, indicating unit Currency.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Dong { get; }
Public Shared ReadOnly Property Dong As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Dong {
    ForgeTypeId^ get ();
}
static member Dong : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.EuroPrefix Property

SymbolTypeIdEuroPrefix Property

Symbol â‚¬, indicating unit Currency.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EuroPrefix { get; }
Public Shared ReadOnly Property EuroPrefix As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EuroPrefix {
    ForgeTypeId^ get ();
}
static member EuroPrefix : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.EuroSuffix Property

SymbolTypeIdEuroSuffix Property

Symbol â‚¬, indicating unit Currency.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId EuroSuffix { get; }
Public Shared ReadOnly Property EuroSuffix As ForgeTypeId
    Get
public:
static property ForgeTypeId^ EuroSuffix {
    ForgeTypeId^ get ();
}
static member EuroSuffix : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Fc Property

SymbolTypeIdFc Property

Symbol fc, indicating unit Footcandles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Fc { get; }
Public Shared ReadOnly Property Fc As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Fc {
    ForgeTypeId^ get ();
}
static member Fc : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.FeetOfWater Property

SymbolTypeIdFeetOfWater Property

Symbol Feet, indicating unit Feet of water (39.2 Â°F).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FeetOfWater { get; }
Public Shared ReadOnly Property FeetOfWater As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FeetOfWater {
    ForgeTypeId^ get ();
}
static member FeetOfWater : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.FeetOfWaterPer100ft Property

SymbolTypeIdFeetOfWaterPer100ft Property

Symbol Feet/100ft, indicating unit Feet of water (39.2 Â°F) per 100 feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FeetOfWaterPer100ft { get; }
Public Shared ReadOnly Property FeetOfWaterPer100ft As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FeetOfWaterPer100ft {
    ForgeTypeId^ get ();
}
static member FeetOfWaterPer100ft : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.FL Property

SymbolTypeIdFL Property

Symbol fL, indicating unit Footlamberts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FL { get; }
Public Shared ReadOnly Property FL As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FL {
    ForgeTypeId^ get ();
}
static member FL : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.FlLowercase Property

SymbolTypeIdFlLowercase Property

Symbol fl, indicating unit Footlamberts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FlLowercase { get; }
Public Shared ReadOnly Property FlLowercase As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FlLowercase {
    ForgeTypeId^ get ();
}
static member FlLowercase : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.FootSingleQuote Property

SymbolTypeIdFootSingleQuote Property

Symbol ', indicating unit Feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FootSingleQuote { get; }
Public Shared ReadOnly Property FootSingleQuote As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FootSingleQuote {
    ForgeTypeId^ get ();
}
static member FootSingleQuote : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Fpm Property

SymbolTypeIdFpm Property

Symbol FPM, indicating unit Feet per minute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Fpm { get; }
Public Shared ReadOnly Property Fpm As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Fpm {
    ForgeTypeId^ get ();
}
static member Fpm : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Fps Property

SymbolTypeIdFps Property

Symbol FPS, indicating unit Feet per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Fps { get; }
Public Shared ReadOnly Property Fps As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Fps {
    ForgeTypeId^ get ();
}
static member Fps : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Ft Property

SymbolTypeIdFt Property

Symbol ft, indicating unit Feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Ft { get; }
Public Shared ReadOnly Property Ft As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Ft {
    ForgeTypeId^ get ();
}
static member Ft : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Ftc Property

SymbolTypeIdFtc Property

Symbol Ftc, indicating unit Footcandles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Ftc { get; }
Public Shared ReadOnly Property Ftc As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Ftc {
    ForgeTypeId^ get ();
}
static member Ftc : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.FtCaret2 Property

SymbolTypeIdFtCaret2 Property

Symbol ft^2, indicating unit Square feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FtCaret2 { get; }
Public Shared ReadOnly Property FtCaret2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FtCaret2 {
    ForgeTypeId^ get ();
}
static member FtCaret2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.FtCaret3 Property

SymbolTypeIdFtCaret3 Property

Symbol ft^3, indicating unit Cubic feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FtCaret3 { get; }
Public Shared ReadOnly Property FtCaret3 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FtCaret3 {
    ForgeTypeId^ get ();
}
static member FtCaret3 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.FtH2O Property

SymbolTypeIdFtH2O Property

Symbol ftH2O, indicating unit Feet of water (39.2 Â°F).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FtH2O { get; }
Public Shared ReadOnly Property FtH2O As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FtH2O {
    ForgeTypeId^ get ();
}
static member FtH2O : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.FtH2OPer100ft Property

SymbolTypeIdFtH2OPer100ft Property

Symbol ftH2O/100ft, indicating unit Feet of water (39.2 Â°F) per 100 feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FtH2OPer100ft { get; }
Public Shared ReadOnly Property FtH2OPer100ft As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FtH2OPer100ft {
    ForgeTypeId^ get ();
}
static member FtH2OPer100ft : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.FtL Property

SymbolTypeIdFtL Property

Symbol ftL, indicating unit Footlamberts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FtL { get; }
Public Shared ReadOnly Property FtL As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FtL {
    ForgeTypeId^ get ();
}
static member FtL : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.FtOfWater Property

SymbolTypeIdFtOfWater Property

Symbol FT, indicating unit Feet of water (39.2 Â°F).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FtOfWater { get; }
Public Shared ReadOnly Property FtOfWater As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FtOfWater {
    ForgeTypeId^ get ();
}
static member FtOfWater : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.FtOfWaterPer100ft Property

SymbolTypeIdFtOfWaterPer100ft Property

Symbol FT/100ft, indicating unit Feet of water (39.2 Â°F) per 100 feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FtOfWaterPer100ft { get; }
Public Shared ReadOnly Property FtOfWaterPer100ft As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FtOfWaterPer100ft {
    ForgeTypeId^ get ();
}
static member FtOfWaterPer100ft : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.FtPerKip Property

SymbolTypeIdFtPerKip Property

Symbol ft/kip, indicating unit Feet per kip.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FtPerKip { get; }
Public Shared ReadOnly Property FtPerKip As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FtPerKip {
    ForgeTypeId^ get ();
}
static member FtPerKip : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.FtPerMin Property

SymbolTypeIdFtPerMin Property

Symbol ft/min, indicating unit Feet per minute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FtPerMin { get; }
Public Shared ReadOnly Property FtPerMin As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FtPerMin {
    ForgeTypeId^ get ();
}
static member FtPerMin : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.FtPerS Property

SymbolTypeIdFtPerS Property

Symbol ft/s, indicating unit Feet per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FtPerS { get; }
Public Shared ReadOnly Property FtPerS As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FtPerS {
    ForgeTypeId^ get ();
}
static member FtPerS : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.FtPerSSup2 Property

SymbolTypeIdFtPerSSup2 Property

Symbol ft/sÂ², indicating unit Feet per second squared.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FtPerSSup2 { get; }
Public Shared ReadOnly Property FtPerSSup2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FtPerSSup2 {
    ForgeTypeId^ get ();
}
static member FtPerSSup2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.FtSup2 Property

SymbolTypeIdFtSup2 Property

Symbol ftÂ², indicating unit Square feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FtSup2 { get; }
Public Shared ReadOnly Property FtSup2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FtSup2 {
    ForgeTypeId^ get ();
}
static member FtSup2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.FtSup2HPerKbtu Property

SymbolTypeIdFtSup2HPerKbtu Property

Symbol ftÂ²Â·h/kBtu, indicating unit Square feet per thousand British thermal units per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FtSup2HPerKbtu { get; }
Public Shared ReadOnly Property FtSup2HPerKbtu As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FtSup2HPerKbtu {
    ForgeTypeId^ get ();
}
static member FtSup2HPerKbtu : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.FtSup2PerFt Property

SymbolTypeIdFtSup2PerFt Property

Symbol ftÂ²/ft, indicating unit Square feet per foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FtSup2PerFt { get; }
Public Shared ReadOnly Property FtSup2PerFt As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FtSup2PerFt {
    ForgeTypeId^ get ();
}
static member FtSup2PerFt : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.FtSup2PerKip Property

SymbolTypeIdFtSup2PerKip Property

Symbol ftÂ²/kip, indicating unit Square feet per kip.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FtSup2PerKip { get; }
Public Shared ReadOnly Property FtSup2PerKip As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FtSup2PerKip {
    ForgeTypeId^ get ();
}
static member FtSup2PerKip : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.FtSup2PerMbh Property

SymbolTypeIdFtSup2PerMbh Property

Symbol ftÂ²/MBh, indicating unit Square feet per thousand British thermal units per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FtSup2PerMbh { get; }
Public Shared ReadOnly Property FtSup2PerMbh As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FtSup2PerMbh {
    ForgeTypeId^ get ();
}
static member FtSup2PerMbh : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.FtSup2PerS Property

SymbolTypeIdFtSup2PerS Property

Symbol ftÂ²/s, indicating unit Square feet per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FtSup2PerS { get; }
Public Shared ReadOnly Property FtSup2PerS As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FtSup2PerS {
    ForgeTypeId^ get ();
}
static member FtSup2PerS : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.FtSup2PerTon Property

SymbolTypeIdFtSup2PerTon Property

Symbol ftÂ²/ton, indicating unit Square feet per ton of refrigeration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FtSup2PerTon { get; }
Public Shared ReadOnly Property FtSup2PerTon As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FtSup2PerTon {
    ForgeTypeId^ get ();
}
static member FtSup2PerTon : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.FtSup3 Property

SymbolTypeIdFtSup3 Property

Symbol ftÂ³, indicating unit Cubic feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FtSup3 { get; }
Public Shared ReadOnly Property FtSup3 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FtSup3 {
    ForgeTypeId^ get ();
}
static member FtSup3 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.FtSup3HPerMinBtu Property

SymbolTypeIdFtSup3HPerMinBtu Property

Symbol ftÂ³Â·h/(minÂ·Btu), indicating unit Cubic feet per minute per British thermal unit per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FtSup3HPerMinBtu { get; }
Public Shared ReadOnly Property FtSup3HPerMinBtu As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FtSup3HPerMinBtu {
    ForgeTypeId^ get ();
}
static member FtSup3HPerMinBtu : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.FtSup3PerH Property

SymbolTypeIdFtSup3PerH Property

Symbol ftÂ³/h, indicating unit Cubic feet per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FtSup3PerH { get; }
Public Shared ReadOnly Property FtSup3PerH As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FtSup3PerH {
    ForgeTypeId^ get ();
}
static member FtSup3PerH : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.FtSup3PerKip Property

SymbolTypeIdFtSup3PerKip Property

Symbol ftÂ³/kip, indicating unit Cubic feet per kip.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FtSup3PerKip { get; }
Public Shared ReadOnly Property FtSup3PerKip As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FtSup3PerKip {
    ForgeTypeId^ get ();
}
static member FtSup3PerKip : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.FtSup3PerLbMass Property

SymbolTypeIdFtSup3PerLbMass Property

Symbol ftÂ³/lb, indicating unit Cubic feet per pound mass.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FtSup3PerLbMass { get; }
Public Shared ReadOnly Property FtSup3PerLbMass As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FtSup3PerLbMass {
    ForgeTypeId^ get ();
}
static member FtSup3PerLbMass : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.FtSup3PerMin Property

SymbolTypeIdFtSup3PerMin Property

Symbol ftÂ³/min, indicating unit Cubic feet per minute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FtSup3PerMin { get; }
Public Shared ReadOnly Property FtSup3PerMin As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FtSup3PerMin {
    ForgeTypeId^ get ();
}
static member FtSup3PerMin : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.FtSup4 Property

SymbolTypeIdFtSup4 Property

Symbol ftâ´, indicating unit Feet to the fourth power.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FtSup4 { get; }
Public Shared ReadOnly Property FtSup4 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FtSup4 {
    ForgeTypeId^ get ();
}
static member FtSup4 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.FtSup6 Property

SymbolTypeIdFtSup6 Property

Symbol ftâ¶, indicating unit Feet to the sixth power.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FtSup6 { get; }
Public Shared ReadOnly Property FtSup6 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FtSup6 {
    ForgeTypeId^ get ();
}
static member FtSup6 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Gal Property

SymbolTypeIdGal Property

Symbol gal, indicating unit US gallons.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Gal { get; }
Public Shared ReadOnly Property Gal As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Gal {
    ForgeTypeId^ get ();
}
static member Gal : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.GalPerH Property

SymbolTypeIdGalPerH Property

Symbol gal/h, indicating unit US gallons per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GalPerH { get; }
Public Shared ReadOnly Property GalPerH As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GalPerH {
    ForgeTypeId^ get ();
}
static member GalPerH : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.GalPerMin Property

SymbolTypeIdGalPerMin Property

Symbol gal/min, indicating unit US gallons per minute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GalPerMin { get; }
Public Shared ReadOnly Property GalPerMin As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GalPerMin {
    ForgeTypeId^ get ();
}
static member GalPerMin : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.GJ Property

SymbolTypeIdGJ Property

Symbol GJ, indicating unit Gigajoules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GJ { get; }
Public Shared ReadOnly Property GJ As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GJ {
    ForgeTypeId^ get ();
}
static member GJ : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Gph Property

SymbolTypeIdGph Property

Symbol GPH, indicating unit US gallons per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Gph { get; }
Public Shared ReadOnly Property Gph As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Gph {
    ForgeTypeId^ get ();
}
static member Gph : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Gpm Property

SymbolTypeIdGpm Property

Symbol GPM, indicating unit US gallons per minute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Gpm { get; }
Public Shared ReadOnly Property Gpm As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Gpm {
    ForgeTypeId^ get ();
}
static member Gpm : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Grad Property

SymbolTypeIdGrad Property

Symbol grad, indicating unit Gradians.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Grad { get; }
Public Shared ReadOnly Property Grad As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Grad {
    ForgeTypeId^ get ();
}
static member Grad : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.GrPerHFtSup2InHg Property

SymbolTypeIdGrPerHFtSup2InHg Property

Symbol gr/(hÂ·ftÂ²Â·inHg), indicating unit Grains per hour square foot inch mercury.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GrPerHFtSup2InHg { get; }
Public Shared ReadOnly Property GrPerHFtSup2InHg As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GrPerHFtSup2InHg {
    ForgeTypeId^ get ();
}
static member GrPerHFtSup2InHg : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Hectare Property

SymbolTypeIdHectare Property

Symbol hectare, indicating unit Hectares.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Hectare { get; }
Public Shared ReadOnly Property Hectare As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Hectare {
    ForgeTypeId^ get ();
}
static member Hectare : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.HFtSup2DegreeFPerBtu Property

SymbolTypeIdHFtSup2DegreeFPerBtu Property

Symbol (hÂ·ftÂ²Â·Â°F)/BTU, indicating unit Hour square foot degrees Fahrenheit per British thermal unit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId HFtSup2DegreeFPerBtu { get; }
Public Shared ReadOnly Property HFtSup2DegreeFPerBtu As ForgeTypeId
    Get
public:
static property ForgeTypeId^ HFtSup2DegreeFPerBtu {
    ForgeTypeId^ get ();
}
static member HFtSup2DegreeFPerBtu : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Hour Property

SymbolTypeIdHour Property

Symbol h, indicating unit Hours.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Hour { get; }
Public Shared ReadOnly Property Hour As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Hour {
    ForgeTypeId^ get ();
}
static member Hour : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Hp Property

SymbolTypeIdHp Property

Symbol hp, indicating unit Horsepower.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Hp { get; }
Public Shared ReadOnly Property Hp As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Hp {
    ForgeTypeId^ get ();
}
static member Hp : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Hz Property

SymbolTypeIdHz Property

Symbol Hz, indicating unit Hertz.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Hz { get; }
Public Shared ReadOnly Property Hz As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Hz {
    ForgeTypeId^ get ();
}
static member Hz : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.In Property

SymbolTypeIdIn Property

Symbol in, indicating unit Inches.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId In { get; }
Public Shared ReadOnly Property In As ForgeTypeId
    Get
public:
static property ForgeTypeId^ In {
    ForgeTypeId^ get ();
}
static member In : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.InCaret2 Property

SymbolTypeIdInCaret2 Property

Symbol in^2, indicating unit Square inches.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId InCaret2 { get; }
Public Shared ReadOnly Property InCaret2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ InCaret2 {
    ForgeTypeId^ get ();
}
static member InCaret2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.InCaret3 Property

SymbolTypeIdInCaret3 Property

Symbol in^3, indicating unit Cubic inches.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId InCaret3 { get; }
Public Shared ReadOnly Property InCaret3 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ InCaret3 {
    ForgeTypeId^ get ();
}
static member InCaret3 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.InchDoubleQuote Property

SymbolTypeIdInchDoubleQuote Property

Symbol ", indicating unit Inches.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId InchDoubleQuote { get; }
Public Shared ReadOnly Property InchDoubleQuote As ForgeTypeId
    Get
public:
static property ForgeTypeId^ InchDoubleQuote {
    ForgeTypeId^ get ();
}
static member InchDoubleQuote : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.InDashWg Property

SymbolTypeIdInDashWg Property

Symbol in-wg, indicating unit Inches of water (60 Â°F).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId InDashWg { get; }
Public Shared ReadOnly Property InDashWg As ForgeTypeId
    Get
public:
static property ForgeTypeId^ InDashWg {
    ForgeTypeId^ get ();
}
static member InDashWg : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.InDashWgPer100ft Property

SymbolTypeIdInDashWgPer100ft Property

Symbol in-wg/100ft, indicating unit Inches of water (60 Â°F) per 100 feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId InDashWgPer100ft { get; }
Public Shared ReadOnly Property InDashWgPer100ft As ForgeTypeId
    Get
public:
static property ForgeTypeId^ InDashWgPer100ft {
    ForgeTypeId^ get ();
}
static member InDashWgPer100ft : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.InHg Property

SymbolTypeIdInHg Property

Symbol inHg, indicating unit Inches of mercury (32 Â°F).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId InHg { get; }
Public Shared ReadOnly Property InHg As ForgeTypeId
    Get
public:
static property ForgeTypeId^ InHg {
    ForgeTypeId^ get ();
}
static member InHg : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.InPerSSup2 Property

SymbolTypeIdInPerSSup2 Property

Symbol in/sÂ², indicating unit Inches per second squared.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId InPerSSup2 { get; }
Public Shared ReadOnly Property InPerSSup2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ InPerSSup2 {
    ForgeTypeId^ get ();
}
static member InPerSSup2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.InSup2 Property

SymbolTypeIdInSup2 Property

Symbol inÂ², indicating unit Square inches.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId InSup2 { get; }
Public Shared ReadOnly Property InSup2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ InSup2 {
    ForgeTypeId^ get ();
}
static member InSup2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.InSup2PerFt Property

SymbolTypeIdInSup2PerFt Property

Symbol inÂ²/ft, indicating unit Square inches per foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId InSup2PerFt { get; }
Public Shared ReadOnly Property InSup2PerFt As ForgeTypeId
    Get
public:
static property ForgeTypeId^ InSup2PerFt {
    ForgeTypeId^ get ();
}
static member InSup2PerFt : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.InSup3 Property

SymbolTypeIdInSup3 Property

Symbol inÂ³, indicating unit Cubic inches.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId InSup3 { get; }
Public Shared ReadOnly Property InSup3 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ InSup3 {
    ForgeTypeId^ get ();
}
static member InSup3 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.InSup4 Property

SymbolTypeIdInSup4 Property

Symbol inâ´, indicating unit Inches to the fourth power.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId InSup4 { get; }
Public Shared ReadOnly Property InSup4 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ InSup4 {
    ForgeTypeId^ get ();
}
static member InSup4 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.InSup6 Property

SymbolTypeIdInSup6 Property

Symbol inâ¶, indicating unit Inches to the sixth power.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId InSup6 { get; }
Public Shared ReadOnly Property InSup6 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ InSup6 {
    ForgeTypeId^ get ();
}
static member InSup6 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.InvDegreeC Property

SymbolTypeIdInvDegreeC Property

Symbol 1/Â°C, indicating unit Inverse degrees Celsius.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId InvDegreeC { get; }
Public Shared ReadOnly Property InvDegreeC As ForgeTypeId
    Get
public:
static property ForgeTypeId^ InvDegreeC {
    ForgeTypeId^ get ();
}
static member InvDegreeC : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.InvDegreeF Property

SymbolTypeIdInvDegreeF Property

Symbol 1/Â°F, indicating unit Inverse degrees Fahrenheit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId InvDegreeF { get; }
Public Shared ReadOnly Property InvDegreeF As ForgeTypeId
    Get
public:
static property ForgeTypeId^ InvDegreeF {
    ForgeTypeId^ get ();
}
static member InvDegreeF : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.InvKip Property

SymbolTypeIdInvKip Property

Symbol 1/kip, indicating unit Inverse kips.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId InvKip { get; }
Public Shared ReadOnly Property InvKip As ForgeTypeId
    Get
public:
static property ForgeTypeId^ InvKip {
    ForgeTypeId^ get ();
}
static member InvKip : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.InvKN Property

SymbolTypeIdInvKN Property

Symbol 1/kN, indicating unit Inverse kilonewtons.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId InvKN { get; }
Public Shared ReadOnly Property InvKN As ForgeTypeId
    Get
public:
static property ForgeTypeId^ InvKN {
    ForgeTypeId^ get ();
}
static member InvKN : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Joule Property

SymbolTypeIdJoule Property

Symbol J, indicating unit Joules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Joule { get; }
Public Shared ReadOnly Property Joule As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Joule {
    ForgeTypeId^ get ();
}
static member Joule : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.JPerG Property

SymbolTypeIdJPerG Property

Symbol J/g, indicating unit Joules per gram.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId JPerG { get; }
Public Shared ReadOnly Property JPerG As ForgeTypeId
    Get
public:
static property ForgeTypeId^ JPerG {
    ForgeTypeId^ get ();
}
static member JPerG : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.JPerGDegreeC Property

SymbolTypeIdJPerGDegreeC Property

Symbol J/(gÂ·Â°C), indicating unit Joules per gram degree Celsius.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId JPerGDegreeC { get; }
Public Shared ReadOnly Property JPerGDegreeC As ForgeTypeId
    Get
public:
static property ForgeTypeId^ JPerGDegreeC {
    ForgeTypeId^ get ();
}
static member JPerGDegreeC : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.JPerK Property

SymbolTypeIdJPerK Property

Symbol J/K, indicating unit Joules per Kelvin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId JPerK { get; }
Public Shared ReadOnly Property JPerK As ForgeTypeId
    Get
public:
static property ForgeTypeId^ JPerK {
    ForgeTypeId^ get ();
}
static member JPerK : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.JPerKgDegreeC Property

SymbolTypeIdJPerKgDegreeC Property

Symbol J/(kgÂ·Â°C), indicating unit Joules per kilogram degree Celsius.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId JPerKgDegreeC { get; }
Public Shared ReadOnly Property JPerKgDegreeC As ForgeTypeId
    Get
public:
static property ForgeTypeId^ JPerKgDegreeC {
    ForgeTypeId^ get ();
}
static member JPerKgDegreeC : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.JPerMSup2K Property

SymbolTypeIdJPerMSup2K Property

Symbol J/(mÂ²Â·K), indicating unit Joules per square meter Kelvin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId JPerMSup2K { get; }
Public Shared ReadOnly Property JPerMSup2K As ForgeTypeId
    Get
public:
static property ForgeTypeId^ JPerMSup2K {
    ForgeTypeId^ get ();
}
static member JPerMSup2K : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.KA Property

SymbolTypeIdKA Property

Symbol kA, indicating unit Kiloamperes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KA { get; }
Public Shared ReadOnly Property KA As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KA {
    ForgeTypeId^ get ();
}
static member KA : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Kcal Property

SymbolTypeIdKcal Property

Symbol kcal, indicating unit Kilocalories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Kcal { get; }
Public Shared ReadOnly Property Kcal As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Kcal {
    ForgeTypeId^ get ();
}
static member Kcal : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.KcalPerS Property

SymbolTypeIdKcalPerS Property

Symbol kcal/s, indicating unit Kilocalories per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KcalPerS { get; }
Public Shared ReadOnly Property KcalPerS As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KcalPerS {
    ForgeTypeId^ get ();
}
static member KcalPerS : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Kelvin Property

SymbolTypeIdKelvin Property

Symbol K, indicating unit Kelvin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Kelvin { get; }
Public Shared ReadOnly Property Kelvin As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Kelvin {
    ForgeTypeId^ get ();
}
static member Kelvin : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.KelvinInterval Property

SymbolTypeIdKelvinInterval Property

Symbol K, indicating unit Kelvin interval.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KelvinInterval { get; }
Public Shared ReadOnly Property KelvinInterval As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KelvinInterval {
    ForgeTypeId^ get ();
}
static member KelvinInterval : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Kg Property

SymbolTypeIdKg Property

Symbol kg, indicating unit Kilograms.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Kg { get; }
Public Shared ReadOnly Property Kg As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Kg {
    ForgeTypeId^ get ();
}
static member Kg : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Kgf Property

SymbolTypeIdKgf Property

Symbol kgf, indicating unit Kilograms force.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Kgf { get; }
Public Shared ReadOnly Property Kgf As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Kgf {
    ForgeTypeId^ get ();
}
static member Kgf : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.KgfDashM Property

SymbolTypeIdKgfDashM Property

Symbol kgf-m, indicating unit Kilogram force meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KgfDashM { get; }
Public Shared ReadOnly Property KgfDashM As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KgfDashM {
    ForgeTypeId^ get ();
}
static member KgfDashM : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.KgfDashMPerM Property

SymbolTypeIdKgfDashMPerM Property

Symbol kgf-m/m, indicating unit Kilogram force meters per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KgfDashMPerM { get; }
Public Shared ReadOnly Property KgfDashMPerM As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KgfDashMPerM {
    ForgeTypeId^ get ();
}
static member KgfDashMPerM : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.KgfPerM Property

SymbolTypeIdKgfPerM Property

Symbol kgf/m, indicating unit Kilograms force per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KgfPerM { get; }
Public Shared ReadOnly Property KgfPerM As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KgfPerM {
    ForgeTypeId^ get ();
}
static member KgfPerM : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.KgfPerMSup2 Property

SymbolTypeIdKgfPerMSup2 Property

Symbol kgf/mÂ², indicating unit Kilograms force per square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KgfPerMSup2 { get; }
Public Shared ReadOnly Property KgfPerMSup2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KgfPerMSup2 {
    ForgeTypeId^ get ();
}
static member KgfPerMSup2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.KgPerH Property

SymbolTypeIdKgPerH Property

Symbol kg/h, indicating unit Kilograms per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KgPerH { get; }
Public Shared ReadOnly Property KgPerH As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KgPerH {
    ForgeTypeId^ get ();
}
static member KgPerH : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.KgPerKgK Property

SymbolTypeIdKgPerKgK Property

Symbol kg/(kgÂ·K), indicating unit Kilograms per kilogram kelvin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KgPerKgK { get; }
Public Shared ReadOnly Property KgPerKgK As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KgPerKgK {
    ForgeTypeId^ get ();
}
static member KgPerKgK : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.KgPerM Property

SymbolTypeIdKgPerM Property

Symbol kg/m, indicating unit Kilograms per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KgPerM { get; }
Public Shared ReadOnly Property KgPerM As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KgPerM {
    ForgeTypeId^ get ();
}
static member KgPerM : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.KgPerMH Property

SymbolTypeIdKgPerMH Property

Symbol kg/(mÂ·h), indicating unit Kilograms per meter hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KgPerMH { get; }
Public Shared ReadOnly Property KgPerMH As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KgPerMH {
    ForgeTypeId^ get ();
}
static member KgPerMH : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.KgPerMin Property

SymbolTypeIdKgPerMin Property

Symbol kg/min, indicating unit Kilograms per minute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KgPerMin { get; }
Public Shared ReadOnly Property KgPerMin As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KgPerMin {
    ForgeTypeId^ get ();
}
static member KgPerMin : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.KgPerMS Property

SymbolTypeIdKgPerMS Property

Symbol kg/(mÂ·s), indicating unit Kilograms per meter second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KgPerMS { get; }
Public Shared ReadOnly Property KgPerMS As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KgPerMS {
    ForgeTypeId^ get ();
}
static member KgPerMS : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.KgPerMSup2 Property

SymbolTypeIdKgPerMSup2 Property

Symbol kg/mÂ², indicating unit Kilograms per square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KgPerMSup2 { get; }
Public Shared ReadOnly Property KgPerMSup2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KgPerMSup2 {
    ForgeTypeId^ get ();
}
static member KgPerMSup2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.KgPerMSup3 Property

SymbolTypeIdKgPerMSup3 Property

Symbol kg/mÂ³, indicating unit Kilograms per cubic meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KgPerMSup3 { get; }
Public Shared ReadOnly Property KgPerMSup3 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KgPerMSup3 {
    ForgeTypeId^ get ();
}
static member KgPerMSup3 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.KgPerS Property

SymbolTypeIdKgPerS Property

Symbol kg/s, indicating unit Kilograms per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KgPerS { get; }
Public Shared ReadOnly Property KgPerS As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KgPerS {
    ForgeTypeId^ get ();
}
static member KgPerS : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Kip Property

SymbolTypeIdKip Property

Symbol kip, indicating unit Kips.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Kip { get; }
Public Shared ReadOnly Property Kip As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Kip {
    ForgeTypeId^ get ();
}
static member Kip : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.KipDashFt Property

SymbolTypeIdKipDashFt Property

Symbol kip-ft, indicating unit Kip feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KipDashFt { get; }
Public Shared ReadOnly Property KipDashFt As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KipDashFt {
    ForgeTypeId^ get ();
}
static member KipDashFt : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.KipDashFtPerDegree Property

SymbolTypeIdKipDashFtPerDegree Property

Symbol kip-ft/Â°, indicating unit Kip feet per degree.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KipDashFtPerDegree { get; }
Public Shared ReadOnly Property KipDashFtPerDegree As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KipDashFtPerDegree {
    ForgeTypeId^ get ();
}
static member KipDashFtPerDegree : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.KipDashFtPerDegreePerFt Property

SymbolTypeIdKipDashFtPerDegreePerFt Property

Symbol kip-ft/Â°/ft, indicating unit Kip feet per degree per foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KipDashFtPerDegreePerFt { get; }
Public Shared ReadOnly Property KipDashFtPerDegreePerFt As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KipDashFtPerDegreePerFt {
    ForgeTypeId^ get ();
}
static member KipDashFtPerDegreePerFt : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.KipDashFtPerFt Property

SymbolTypeIdKipDashFtPerFt Property

Symbol kip-ft/ft, indicating unit Kip feet per foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KipDashFtPerFt { get; }
Public Shared ReadOnly Property KipDashFtPerFt As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KipDashFtPerFt {
    ForgeTypeId^ get ();
}
static member KipDashFtPerFt : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.KipPerFt Property

SymbolTypeIdKipPerFt Property

Symbol kip/ft, indicating unit Kips per foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KipPerFt { get; }
Public Shared ReadOnly Property KipPerFt As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KipPerFt {
    ForgeTypeId^ get ();
}
static member KipPerFt : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.KipPerFtSup2 Property

SymbolTypeIdKipPerFtSup2 Property

Symbol kip/ftÂ², indicating unit Kips per square foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KipPerFtSup2 { get; }
Public Shared ReadOnly Property KipPerFtSup2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KipPerFtSup2 {
    ForgeTypeId^ get ();
}
static member KipPerFtSup2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.KipPerFtSup3 Property

SymbolTypeIdKipPerFtSup3 Property

Symbol kip/ftÂ³, indicating unit Kips per cubic foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KipPerFtSup3 { get; }
Public Shared ReadOnly Property KipPerFtSup3 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KipPerFtSup3 {
    ForgeTypeId^ get ();
}
static member KipPerFtSup3 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.KipPerIn Property

SymbolTypeIdKipPerIn Property

Symbol kip/in, indicating unit Kips per inch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KipPerIn { get; }
Public Shared ReadOnly Property KipPerIn As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KipPerIn {
    ForgeTypeId^ get ();
}
static member KipPerIn : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.KipPerInSup2 Property

SymbolTypeIdKipPerInSup2 Property

Symbol kip/inÂ², indicating unit Kips per square inch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KipPerInSup2 { get; }
Public Shared ReadOnly Property KipPerInSup2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KipPerInSup2 {
    ForgeTypeId^ get ();
}
static member KipPerInSup2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.KipPerInSup3 Property

SymbolTypeIdKipPerInSup3 Property

Symbol kip/inÂ³, indicating unit Kips per cubic inch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KipPerInSup3 { get; }
Public Shared ReadOnly Property KipPerInSup3 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KipPerInSup3 {
    ForgeTypeId^ get ();
}
static member KipPerInSup3 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.KJ Property

SymbolTypeIdKJ Property

Symbol kJ, indicating unit Kilojoules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KJ { get; }
Public Shared ReadOnly Property KJ As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KJ {
    ForgeTypeId^ get ();
}
static member KJ : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.KJPerK Property

SymbolTypeIdKJPerK Property

Symbol kJ/K, indicating unit Kilojoules per Kelvin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KJPerK { get; }
Public Shared ReadOnly Property KJPerK As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KJPerK {
    ForgeTypeId^ get ();
}
static member KJPerK : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.KJPerMSup2K Property

SymbolTypeIdKJPerMSup2K Property

Symbol kJ/(mÂ²Â·K), indicating unit Kilojoules per square meter Kelvin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KJPerMSup2K { get; }
Public Shared ReadOnly Property KJPerMSup2K As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KJPerMSup2K {
    ForgeTypeId^ get ();
}
static member KJPerMSup2K : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.KmPerH Property

SymbolTypeIdKmPerH Property

Symbol km/h, indicating unit Kilometers per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KmPerH { get; }
Public Shared ReadOnly Property KmPerH As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KmPerH {
    ForgeTypeId^ get ();
}
static member KmPerH : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.KmPerSSup2 Property

SymbolTypeIdKmPerSSup2 Property

Symbol km/sÂ², indicating unit Kilometers per second squared.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KmPerSSup2 { get; }
Public Shared ReadOnly Property KmPerSSup2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KmPerSSup2 {
    ForgeTypeId^ get ();
}
static member KmPerSSup2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.KN Property

SymbolTypeIdKN Property

Symbol kN, indicating unit Kilonewtons.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KN { get; }
Public Shared ReadOnly Property KN As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KN {
    ForgeTypeId^ get ();
}
static member KN : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.KNDashM Property

SymbolTypeIdKNDashM Property

Symbol kN-m, indicating unit Kilonewton meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KNDashM { get; }
Public Shared ReadOnly Property KNDashM As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KNDashM {
    ForgeTypeId^ get ();
}
static member KNDashM : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.KNDashMPerDegree Property

SymbolTypeIdKNDashMPerDegree Property

Symbol kN-m/Â°, indicating unit Kilonewton meters per degree.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KNDashMPerDegree { get; }
Public Shared ReadOnly Property KNDashMPerDegree As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KNDashMPerDegree {
    ForgeTypeId^ get ();
}
static member KNDashMPerDegree : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.KNDashMPerDegreePerM Property

SymbolTypeIdKNDashMPerDegreePerM Property

Symbol kN-m/Â°/m, indicating unit Kilonewton meters per degree per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KNDashMPerDegreePerM { get; }
Public Shared ReadOnly Property KNDashMPerDegreePerM As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KNDashMPerDegreePerM {
    ForgeTypeId^ get ();
}
static member KNDashMPerDegreePerM : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.KNDashMPerM Property

SymbolTypeIdKNDashMPerM Property

Symbol kN-m/m, indicating unit Kilonewton meters per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KNDashMPerM { get; }
Public Shared ReadOnly Property KNDashMPerM As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KNDashMPerM {
    ForgeTypeId^ get ();
}
static member KNDashMPerM : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.KNPerCmSup2 Property

SymbolTypeIdKNPerCmSup2 Property

Symbol kN/cmÂ², indicating unit Kilonewtons per square centimeter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KNPerCmSup2 { get; }
Public Shared ReadOnly Property KNPerCmSup2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KNPerCmSup2 {
    ForgeTypeId^ get ();
}
static member KNPerCmSup2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.KNPerM Property

SymbolTypeIdKNPerM Property

Symbol kN/m, indicating unit Kilonewtons per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KNPerM { get; }
Public Shared ReadOnly Property KNPerM As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KNPerM {
    ForgeTypeId^ get ();
}
static member KNPerM : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.KNPerMmSup2 Property

SymbolTypeIdKNPerMmSup2 Property

Symbol kN/mmÂ², indicating unit Kilonewtons per square millimeter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KNPerMmSup2 { get; }
Public Shared ReadOnly Property KNPerMmSup2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KNPerMmSup2 {
    ForgeTypeId^ get ();
}
static member KNPerMmSup2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.KNPerMSup2 Property

SymbolTypeIdKNPerMSup2 Property

Symbol kN/mÂ², indicating unit Kilonewtons per square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KNPerMSup2 { get; }
Public Shared ReadOnly Property KNPerMSup2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KNPerMSup2 {
    ForgeTypeId^ get ();
}
static member KNPerMSup2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.KNPerMSup3 Property

SymbolTypeIdKNPerMSup3 Property

Symbol kN/mÂ³, indicating unit Kilonewtons per cubic meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KNPerMSup3 { get; }
Public Shared ReadOnly Property KNPerMSup3 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KNPerMSup3 {
    ForgeTypeId^ get ();
}
static member KNPerMSup3 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.KPa Property

SymbolTypeIdKPa Property

Symbol kPa, indicating unit Kilopascals.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KPa { get; }
Public Shared ReadOnly Property KPa As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KPa {
    ForgeTypeId^ get ();
}
static member KPa : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Krone Property

SymbolTypeIdKrone Property

Symbol kr, indicating unit Currency.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Krone { get; }
Public Shared ReadOnly Property Krone As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Krone {
    ForgeTypeId^ get ();
}
static member Krone : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Ksf Property

SymbolTypeIdKsf Property

Symbol ksf, indicating unit Kips per square foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Ksf { get; }
Public Shared ReadOnly Property Ksf As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Ksf {
    ForgeTypeId^ get ();
}
static member Ksf : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Ksi Property

SymbolTypeIdKsi Property

Symbol ksi, indicating unit Kips per square inch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Ksi { get; }
Public Shared ReadOnly Property Ksi As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Ksi {
    ForgeTypeId^ get ();
}
static member Ksi : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.KV Property

SymbolTypeIdKV Property

Symbol kV, indicating unit Kilovolts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KV { get; }
Public Shared ReadOnly Property KV As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KV {
    ForgeTypeId^ get ();
}
static member KV : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.KVA Property

SymbolTypeIdKVA Property

Symbol kVA, indicating unit Kilovolt amperes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KVA { get; }
Public Shared ReadOnly Property KVA As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KVA {
    ForgeTypeId^ get ();
}
static member KVA : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.KW Property

SymbolTypeIdKW Property

Symbol kW, indicating unit Kilowatts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KW { get; }
Public Shared ReadOnly Property KW As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KW {
    ForgeTypeId^ get ();
}
static member KW : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.KWh Property

SymbolTypeIdKWh Property

Symbol kWh, indicating unit Kilowatt hours.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KWh { get; }
Public Shared ReadOnly Property KWh As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KWh {
    ForgeTypeId^ get ();
}
static member KWh : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Lbf Property

SymbolTypeIdLbf Property

Symbol lbf, indicating unit Pounds force.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Lbf { get; }
Public Shared ReadOnly Property Lbf As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Lbf {
    ForgeTypeId^ get ();
}
static member Lbf : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.LbfDashFt Property

SymbolTypeIdLbfDashFt Property

Symbol lbf-ft, indicating unit Pound force feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LbfDashFt { get; }
Public Shared ReadOnly Property LbfDashFt As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LbfDashFt {
    ForgeTypeId^ get ();
}
static member LbfDashFt : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.LbfDashFtPerFt Property

SymbolTypeIdLbfDashFtPerFt Property

Symbol lbf-ft/ft, indicating unit Pound force feet per foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LbfDashFtPerFt { get; }
Public Shared ReadOnly Property LbfDashFtPerFt As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LbfDashFtPerFt {
    ForgeTypeId^ get ();
}
static member LbfDashFtPerFt : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.LbForce Property

SymbolTypeIdLbForce Property

Symbol lb, indicating unit Pounds force.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LbForce { get; }
Public Shared ReadOnly Property LbForce As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LbForce {
    ForgeTypeId^ get ();
}
static member LbForce : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.LbForceDashFt Property

SymbolTypeIdLbForceDashFt Property

Symbol lb-ft, indicating unit Pound force feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LbForceDashFt { get; }
Public Shared ReadOnly Property LbForceDashFt As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LbForceDashFt {
    ForgeTypeId^ get ();
}
static member LbForceDashFt : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.LbForceDashFtPerFt Property

SymbolTypeIdLbForceDashFtPerFt Property

Symbol lb-ft/ft, indicating unit Pound force feet per foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LbForceDashFtPerFt { get; }
Public Shared ReadOnly Property LbForceDashFtPerFt As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LbForceDashFtPerFt {
    ForgeTypeId^ get ();
}
static member LbForceDashFtPerFt : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.LbForcePerFt Property

SymbolTypeIdLbForcePerFt Property

Symbol lb/ft, indicating unit Pounds force per foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LbForcePerFt { get; }
Public Shared ReadOnly Property LbForcePerFt As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LbForcePerFt {
    ForgeTypeId^ get ();
}
static member LbForcePerFt : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.LbForcePerFtSup2 Property

SymbolTypeIdLbForcePerFtSup2 Property

Symbol lb/ftÂ², indicating unit Pounds force per square foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LbForcePerFtSup2 { get; }
Public Shared ReadOnly Property LbForcePerFtSup2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LbForcePerFtSup2 {
    ForgeTypeId^ get ();
}
static member LbForcePerFtSup2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.LbForcePerFtSup3 Property

SymbolTypeIdLbForcePerFtSup3 Property

Symbol lb/ftÂ³, indicating unit Pounds force per cubic foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LbForcePerFtSup3 { get; }
Public Shared ReadOnly Property LbForcePerFtSup3 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LbForcePerFtSup3 {
    ForgeTypeId^ get ();
}
static member LbForcePerFtSup3 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.LbForcePerInSup2 Property

SymbolTypeIdLbForcePerInSup2 Property

Symbol lb/inÂ², indicating unit Pounds force per square inch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LbForcePerInSup2 { get; }
Public Shared ReadOnly Property LbForcePerInSup2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LbForcePerInSup2 {
    ForgeTypeId^ get ();
}
static member LbForcePerInSup2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.LbForceSPerFtSup2 Property

SymbolTypeIdLbForceSPerFtSup2 Property

Symbol lbÂ·s/ftÂ², indicating unit Pound force seconds per square foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LbForceSPerFtSup2 { get; }
Public Shared ReadOnly Property LbForceSPerFtSup2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LbForceSPerFtSup2 {
    ForgeTypeId^ get ();
}
static member LbForceSPerFtSup2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.LbfPerFt Property

SymbolTypeIdLbfPerFt Property

Symbol lbf/ft, indicating unit Pounds force per foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LbfPerFt { get; }
Public Shared ReadOnly Property LbfPerFt As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LbfPerFt {
    ForgeTypeId^ get ();
}
static member LbfPerFt : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.LbfPerFtSup2 Property

SymbolTypeIdLbfPerFtSup2 Property

Symbol lbf/ftÂ², indicating unit Pounds force per square foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LbfPerFtSup2 { get; }
Public Shared ReadOnly Property LbfPerFtSup2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LbfPerFtSup2 {
    ForgeTypeId^ get ();
}
static member LbfPerFtSup2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.LbfPerFtSup3 Property

SymbolTypeIdLbfPerFtSup3 Property

Symbol lbf/ftÂ³, indicating unit Pounds force per cubic foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LbfPerFtSup3 { get; }
Public Shared ReadOnly Property LbfPerFtSup3 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LbfPerFtSup3 {
    ForgeTypeId^ get ();
}
static member LbfPerFtSup3 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.LbfPerInSup2 Property

SymbolTypeIdLbfPerInSup2 Property

Symbol lbf/inÂ², indicating unit Pounds force per square inch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LbfPerInSup2 { get; }
Public Shared ReadOnly Property LbfPerInSup2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LbfPerInSup2 {
    ForgeTypeId^ get ();
}
static member LbfPerInSup2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Lbm Property

SymbolTypeIdLbm Property

Symbol lbm, indicating unit Pounds mass.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Lbm { get; }
Public Shared ReadOnly Property Lbm As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Lbm {
    ForgeTypeId^ get ();
}
static member Lbm : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.LbMass Property

SymbolTypeIdLbMass Property

Symbol lb, indicating unit Pounds mass.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LbMass { get; }
Public Shared ReadOnly Property LbMass As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LbMass {
    ForgeTypeId^ get ();
}
static member LbMass : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.LbMassPerFt Property

SymbolTypeIdLbMassPerFt Property

Symbol lb/ft, indicating unit Pounds mass per foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LbMassPerFt { get; }
Public Shared ReadOnly Property LbMassPerFt As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LbMassPerFt {
    ForgeTypeId^ get ();
}
static member LbMassPerFt : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.LbMassPerFtDashH Property

SymbolTypeIdLbMassPerFtDashH Property

Symbol lb/ft-h, indicating unit Pounds mass per foot hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LbMassPerFtDashH { get; }
Public Shared ReadOnly Property LbMassPerFtDashH As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LbMassPerFtDashH {
    ForgeTypeId^ get ();
}
static member LbMassPerFtDashH : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.LbMassPerFtDashS Property

SymbolTypeIdLbMassPerFtDashS Property

Symbol lb/ft-s, indicating unit Pounds mass per foot second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LbMassPerFtDashS { get; }
Public Shared ReadOnly Property LbMassPerFtDashS As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LbMassPerFtDashS {
    ForgeTypeId^ get ();
}
static member LbMassPerFtDashS : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.LbMassPerFtSup2 Property

SymbolTypeIdLbMassPerFtSup2 Property

Symbol lb/ftÂ², indicating unit Pounds mass per square foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LbMassPerFtSup2 { get; }
Public Shared ReadOnly Property LbMassPerFtSup2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LbMassPerFtSup2 {
    ForgeTypeId^ get ();
}
static member LbMassPerFtSup2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.LbMassPerFtSup3 Property

SymbolTypeIdLbMassPerFtSup3 Property

Symbol lb/ftÂ³, indicating unit Pounds mass per cubic foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LbMassPerFtSup3 { get; }
Public Shared ReadOnly Property LbMassPerFtSup3 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LbMassPerFtSup3 {
    ForgeTypeId^ get ();
}
static member LbMassPerFtSup3 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.LbMassPerH Property

SymbolTypeIdLbMassPerH Property

Symbol lb/h, indicating unit Pounds mass per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LbMassPerH { get; }
Public Shared ReadOnly Property LbMassPerH As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LbMassPerH {
    ForgeTypeId^ get ();
}
static member LbMassPerH : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.LbMassPerInSup3 Property

SymbolTypeIdLbMassPerInSup3 Property

Symbol lb/inÂ³, indicating unit Pounds mass per cubic inch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LbMassPerInSup3 { get; }
Public Shared ReadOnly Property LbMassPerInSup3 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LbMassPerInSup3 {
    ForgeTypeId^ get ();
}
static member LbMassPerInSup3 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.LbMassPerLbDegreeF Property

SymbolTypeIdLbMassPerLbDegreeF Property

Symbol lb/(lbÂ·Â°F), indicating unit Pounds mass per pound degree Fahrenheit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LbMassPerLbDegreeF { get; }
Public Shared ReadOnly Property LbMassPerLbDegreeF As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LbMassPerLbDegreeF {
    ForgeTypeId^ get ();
}
static member LbMassPerLbDegreeF : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.LbMassPerMin Property

SymbolTypeIdLbMassPerMin Property

Symbol lb/min, indicating unit Pounds mass per minute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LbMassPerMin { get; }
Public Shared ReadOnly Property LbMassPerMin As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LbMassPerMin {
    ForgeTypeId^ get ();
}
static member LbMassPerMin : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.LbMassPerS Property

SymbolTypeIdLbMassPerS Property

Symbol lb/s, indicating unit Pounds mass per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LbMassPerS { get; }
Public Shared ReadOnly Property LbMassPerS As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LbMassPerS {
    ForgeTypeId^ get ();
}
static member LbMassPerS : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.LbmPerFt Property

SymbolTypeIdLbmPerFt Property

Symbol lbm/ft, indicating unit Pounds mass per foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LbmPerFt { get; }
Public Shared ReadOnly Property LbmPerFt As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LbmPerFt {
    ForgeTypeId^ get ();
}
static member LbmPerFt : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.LbmPerFtDashH Property

SymbolTypeIdLbmPerFtDashH Property

Symbol lbm/ft-h, indicating unit Pounds mass per foot hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LbmPerFtDashH { get; }
Public Shared ReadOnly Property LbmPerFtDashH As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LbmPerFtDashH {
    ForgeTypeId^ get ();
}
static member LbmPerFtDashH : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.LbmPerFtDashS Property

SymbolTypeIdLbmPerFtDashS Property

Symbol lbm/ft-s, indicating unit Pounds mass per foot second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LbmPerFtDashS { get; }
Public Shared ReadOnly Property LbmPerFtDashS As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LbmPerFtDashS {
    ForgeTypeId^ get ();
}
static member LbmPerFtDashS : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.LbmPerFtSup3 Property

SymbolTypeIdLbmPerFtSup3 Property

Symbol lbm/ftÂ³, indicating unit Pounds mass per cubic foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LbmPerFtSup3 { get; }
Public Shared ReadOnly Property LbmPerFtSup3 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LbmPerFtSup3 {
    ForgeTypeId^ get ();
}
static member LbmPerFtSup3 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.LbmPerInSup3 Property

SymbolTypeIdLbmPerInSup3 Property

Symbol lbm/inÂ³, indicating unit Pounds mass per cubic inch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LbmPerInSup3 { get; }
Public Shared ReadOnly Property LbmPerInSup3 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LbmPerInSup3 {
    ForgeTypeId^ get ();
}
static member LbmPerInSup3 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Lf Property

SymbolTypeIdLf Property

Symbol LF, indicating unit Feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Lf { get; }
Public Shared ReadOnly Property Lf As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Lf {
    ForgeTypeId^ get ();
}
static member Lf : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Liter Property

SymbolTypeIdLiter Property

Symbol L, indicating unit Liters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Liter { get; }
Public Shared ReadOnly Property Liter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Liter {
    ForgeTypeId^ get ();
}
static member Liter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Lm Property

SymbolTypeIdLm Property

Symbol lm, indicating unit Lumens.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Lm { get; }
Public Shared ReadOnly Property Lm As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Lm {
    ForgeTypeId^ get ();
}
static member Lm : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.LmPerW Property

SymbolTypeIdLmPerW Property

Symbol lm/W, indicating unit Lumens per watt.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LmPerW { get; }
Public Shared ReadOnly Property LmPerW As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LmPerW {
    ForgeTypeId^ get ();
}
static member LmPerW : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.LPerH Property

SymbolTypeIdLPerH Property

Symbol L/h, indicating unit Liters per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LPerH { get; }
Public Shared ReadOnly Property LPerH As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LPerH {
    ForgeTypeId^ get ();
}
static member LPerH : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.LPerMin Property

SymbolTypeIdLPerMin Property

Symbol L/min, indicating unit Liters per minute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LPerMin { get; }
Public Shared ReadOnly Property LPerMin As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LPerMin {
    ForgeTypeId^ get ();
}
static member LPerMin : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.LPerS Property

SymbolTypeIdLPerS Property

Symbol L/s, indicating unit Liters per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LPerS { get; }
Public Shared ReadOnly Property LPerS As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LPerS {
    ForgeTypeId^ get ();
}
static member LPerS : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.LPerSKw Property

SymbolTypeIdLPerSKw Property

Symbol L/(sÂ·kW), indicating unit Liters per second kilowatt.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LPerSKw { get; }
Public Shared ReadOnly Property LPerSKw As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LPerSKw {
    ForgeTypeId^ get ();
}
static member LPerSKw : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.LPerSMSup2 Property

SymbolTypeIdLPerSMSup2 Property

Symbol L/(sÂ·mÂ²), indicating unit Liters per second square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LPerSMSup2 { get; }
Public Shared ReadOnly Property LPerSMSup2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LPerSMSup2 {
    ForgeTypeId^ get ();
}
static member LPerSMSup2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.LPerSMSup3 Property

SymbolTypeIdLPerSMSup3 Property

Symbol L/(sÂ·mÂ³), indicating unit Liters per second cubic meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LPerSMSup3 { get; }
Public Shared ReadOnly Property LPerSMSup3 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LPerSMSup3 {
    ForgeTypeId^ get ();
}
static member LPerSMSup3 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Lpm Property

SymbolTypeIdLpm Property

Symbol LPM, indicating unit Liters per minute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Lpm { get; }
Public Shared ReadOnly Property Lpm As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Lpm {
    ForgeTypeId^ get ();
}
static member Lpm : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Lps Property

SymbolTypeIdLps Property

Symbol LPS, indicating unit Liters per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Lps { get; }
Public Shared ReadOnly Property Lps As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Lps {
    ForgeTypeId^ get ();
}
static member Lps : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.LpsPerMSup2 Property

SymbolTypeIdLpsPerMSup2 Property

Symbol LPS/mÂ², indicating unit Liters per second square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LpsPerMSup2 { get; }
Public Shared ReadOnly Property LpsPerMSup2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LpsPerMSup2 {
    ForgeTypeId^ get ();
}
static member LpsPerMSup2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Lx Property

SymbolTypeIdLx Property

Symbol lx, indicating unit Lux.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Lx { get; }
Public Shared ReadOnly Property Lx As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Lx {
    ForgeTypeId^ get ();
}
static member Lx : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.MA Property

SymbolTypeIdMA Property

Symbol mA, indicating unit Milliamperes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MA { get; }
Public Shared ReadOnly Property MA As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MA {
    ForgeTypeId^ get ();
}
static member MA : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Mbh Property

SymbolTypeIdMbh Property

Symbol MBH, indicating unit Thousand British thermal units per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Mbh { get; }
Public Shared ReadOnly Property Mbh As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Mbh {
    ForgeTypeId^ get ();
}
static member Mbh : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.MCaret2 Property

SymbolTypeIdMCaret2 Property

Symbol m^2, indicating unit Square meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MCaret2 { get; }
Public Shared ReadOnly Property MCaret2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MCaret2 {
    ForgeTypeId^ get ();
}
static member MCaret2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.MCaret3 Property

SymbolTypeIdMCaret3 Property

Symbol m^3, indicating unit Cubic meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MCaret3 { get; }
Public Shared ReadOnly Property MCaret3 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MCaret3 {
    ForgeTypeId^ get ();
}
static member MCaret3 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Meter Property

SymbolTypeIdMeter Property

Symbol m, indicating unit Meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Meter { get; }
Public Shared ReadOnly Property Meter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Meter {
    ForgeTypeId^ get ();
}
static member Meter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.MH2O Property

SymbolTypeIdMH2O Property

Symbol mH2O, indicating unit Meters of water column.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MH2O { get; }
Public Shared ReadOnly Property MH2O As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MH2O {
    ForgeTypeId^ get ();
}
static member MH2O : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.MH2OPerM Property

SymbolTypeIdMH2OPerM Property

Symbol mH2O/m, indicating unit Meters of water column per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MH2OPerM { get; }
Public Shared ReadOnly Property MH2OPerM As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MH2OPerM {
    ForgeTypeId^ get ();
}
static member MH2OPerM : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Min Property

SymbolTypeIdMin Property

Symbol min, indicating unit Minutes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Min { get; }
Public Shared ReadOnly Property Min As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Min {
    ForgeTypeId^ get ();
}
static member Min : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.MiPerSSup2 Property

SymbolTypeIdMiPerSSup2 Property

Symbol mi/sÂ², indicating unit Miles per second squared.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MiPerSSup2 { get; }
Public Shared ReadOnly Property MiPerSSup2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MiPerSSup2 {
    ForgeTypeId^ get ();
}
static member MiPerSSup2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.MJ Property

SymbolTypeIdMJ Property

Symbol MJ, indicating unit Megajoules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MJ { get; }
Public Shared ReadOnly Property MJ As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MJ {
    ForgeTypeId^ get ();
}
static member MJ : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Mm Property

SymbolTypeIdMm Property

Symbol mm, indicating unit Millimeters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Mm { get; }
Public Shared ReadOnly Property Mm As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Mm {
    ForgeTypeId^ get ();
}
static member Mm : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.MmCaret2 Property

SymbolTypeIdMmCaret2 Property

Symbol mm^2, indicating unit Square millimeters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MmCaret2 { get; }
Public Shared ReadOnly Property MmCaret2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MmCaret2 {
    ForgeTypeId^ get ();
}
static member MmCaret2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.MmCaret3 Property

SymbolTypeIdMmCaret3 Property

Symbol mm^3, indicating unit Cubic millimeters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MmCaret3 { get; }
Public Shared ReadOnly Property MmCaret3 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MmCaret3 {
    ForgeTypeId^ get ();
}
static member MmCaret3 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.MmH2O Property

SymbolTypeIdMmH2O Property

Symbol mmH2O, indicating unit Millimeters of water column.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MmH2O { get; }
Public Shared ReadOnly Property MmH2O As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MmH2O {
    ForgeTypeId^ get ();
}
static member MmH2O : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.MmH2OPerM Property

SymbolTypeIdMmH2OPerM Property

Symbol mmH2O/m, indicating unit Millimeters of water column per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MmH2OPerM { get; }
Public Shared ReadOnly Property MmH2OPerM As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MmH2OPerM {
    ForgeTypeId^ get ();
}
static member MmH2OPerM : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.MmHg Property

SymbolTypeIdMmHg Property

Symbol mmHg, indicating unit Millimeters of mercury.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MmHg { get; }
Public Shared ReadOnly Property MmHg As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MmHg {
    ForgeTypeId^ get ();
}
static member MmHg : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.MmSup2 Property

SymbolTypeIdMmSup2 Property

Symbol mmÂ², indicating unit Square millimeters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MmSup2 { get; }
Public Shared ReadOnly Property MmSup2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MmSup2 {
    ForgeTypeId^ get ();
}
static member MmSup2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.MmSup2PerM Property

SymbolTypeIdMmSup2PerM Property

Symbol mmÂ²/m, indicating unit Square millimeters per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MmSup2PerM { get; }
Public Shared ReadOnly Property MmSup2PerM As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MmSup2PerM {
    ForgeTypeId^ get ();
}
static member MmSup2PerM : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.MmSup3 Property

SymbolTypeIdMmSup3 Property

Symbol mmÂ³, indicating unit Cubic millimeters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MmSup3 { get; }
Public Shared ReadOnly Property MmSup3 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MmSup3 {
    ForgeTypeId^ get ();
}
static member MmSup3 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.MmSup4 Property

SymbolTypeIdMmSup4 Property

Symbol mmâ´, indicating unit Millimeters to the fourth power.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MmSup4 { get; }
Public Shared ReadOnly Property MmSup4 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MmSup4 {
    ForgeTypeId^ get ();
}
static member MmSup4 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.MmSup6 Property

SymbolTypeIdMmSup6 Property

Symbol mmâ¶, indicating unit Millimeters to the sixth power.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MmSup6 { get; }
Public Shared ReadOnly Property MmSup6 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MmSup6 {
    ForgeTypeId^ get ();
}
static member MmSup6 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.MN Property

SymbolTypeIdMN Property

Symbol MN, indicating unit Meganewtons.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MN { get; }
Public Shared ReadOnly Property MN As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MN {
    ForgeTypeId^ get ();
}
static member MN : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.MNDashM Property

SymbolTypeIdMNDashM Property

Symbol MN-m, indicating unit Meganewton meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MNDashM { get; }
Public Shared ReadOnly Property MNDashM As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MNDashM {
    ForgeTypeId^ get ();
}
static member MNDashM : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.MNDashMPerM Property

SymbolTypeIdMNDashMPerM Property

Symbol MN-m/m, indicating unit Meganewton meters per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MNDashMPerM { get; }
Public Shared ReadOnly Property MNDashMPerM As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MNDashMPerM {
    ForgeTypeId^ get ();
}
static member MNDashMPerM : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.MNPerM Property

SymbolTypeIdMNPerM Property

Symbol MN/m, indicating unit Meganewtons per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MNPerM { get; }
Public Shared ReadOnly Property MNPerM As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MNPerM {
    ForgeTypeId^ get ();
}
static member MNPerM : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.MNPerMSup2 Property

SymbolTypeIdMNPerMSup2 Property

Symbol MN/mÂ², indicating unit Meganewtons per square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MNPerMSup2 { get; }
Public Shared ReadOnly Property MNPerMSup2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MNPerMSup2 {
    ForgeTypeId^ get ();
}
static member MNPerMSup2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.MPa Property

SymbolTypeIdMPa Property

Symbol MPa, indicating unit Megapascals.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MPa { get; }
Public Shared ReadOnly Property MPa As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MPa {
    ForgeTypeId^ get ();
}
static member MPa : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.MPerKN Property

SymbolTypeIdMPerKN Property

Symbol m/kN, indicating unit Meters per kilonewton.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MPerKN { get; }
Public Shared ReadOnly Property MPerKN As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MPerKN {
    ForgeTypeId^ get ();
}
static member MPerKN : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.MPerS Property

SymbolTypeIdMPerS Property

Symbol m/s, indicating unit Meters per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MPerS { get; }
Public Shared ReadOnly Property MPerS As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MPerS {
    ForgeTypeId^ get ();
}
static member MPerS : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.MPerSSup2 Property

SymbolTypeIdMPerSSup2 Property

Symbol m/sÂ², indicating unit Meters per second squared.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MPerSSup2 { get; }
Public Shared ReadOnly Property MPerSSup2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MPerSSup2 {
    ForgeTypeId^ get ();
}
static member MPerSSup2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Mph Property

SymbolTypeIdMph Property

Symbol mph, indicating unit Miles per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Mph { get; }
Public Shared ReadOnly Property Mph As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Mph {
    ForgeTypeId^ get ();
}
static member Mph : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Ms Property

SymbolTypeIdMs Property

Symbol ms, indicating unit Milliseconds.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Ms { get; }
Public Shared ReadOnly Property Ms As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Ms {
    ForgeTypeId^ get ();
}
static member Ms : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.MSup2 Property

SymbolTypeIdMSup2 Property

Symbol mÂ², indicating unit Square meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MSup2 { get; }
Public Shared ReadOnly Property MSup2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MSup2 {
    ForgeTypeId^ get ();
}
static member MSup2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.MSup2KPerW Property

SymbolTypeIdMSup2KPerW Property

Symbol (mÂ²Â·K)/W, indicating unit Square meter kelvins per watt.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MSup2KPerW { get; }
Public Shared ReadOnly Property MSup2KPerW As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MSup2KPerW {
    ForgeTypeId^ get ();
}
static member MSup2KPerW : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.MSup2PerKN Property

SymbolTypeIdMSup2PerKN Property

Symbol mÂ²/kN, indicating unit Square meters per kilonewton.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MSup2PerKN { get; }
Public Shared ReadOnly Property MSup2PerKN As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MSup2PerKN {
    ForgeTypeId^ get ();
}
static member MSup2PerKN : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.MSup2PerKw Property

SymbolTypeIdMSup2PerKw Property

Symbol mÂ²/kW, indicating unit Square meters per kilowatt.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MSup2PerKw { get; }
Public Shared ReadOnly Property MSup2PerKw As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MSup2PerKw {
    ForgeTypeId^ get ();
}
static member MSup2PerKw : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.MSup2PerM Property

SymbolTypeIdMSup2PerM Property

Symbol mÂ²/m, indicating unit Square meters per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MSup2PerM { get; }
Public Shared ReadOnly Property MSup2PerM As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MSup2PerM {
    ForgeTypeId^ get ();
}
static member MSup2PerM : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.MSup2PerS Property

SymbolTypeIdMSup2PerS Property

Symbol mÂ²/s, indicating unit Square meters per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MSup2PerS { get; }
Public Shared ReadOnly Property MSup2PerS As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MSup2PerS {
    ForgeTypeId^ get ();
}
static member MSup2PerS : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.MSup3 Property

SymbolTypeIdMSup3 Property

Symbol mÂ³, indicating unit Cubic meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MSup3 { get; }
Public Shared ReadOnly Property MSup3 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MSup3 {
    ForgeTypeId^ get ();
}
static member MSup3 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.MSup3PerH Property

SymbolTypeIdMSup3PerH Property

Symbol mÂ³/h, indicating unit Cubic meters per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MSup3PerH { get; }
Public Shared ReadOnly Property MSup3PerH As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MSup3PerH {
    ForgeTypeId^ get ();
}
static member MSup3PerH : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.MSup3PerHMSup2 Property

SymbolTypeIdMSup3PerHMSup2 Property

Symbol mÂ³/(hÂ·mÂ²), indicating unit Cubic meters per hour square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MSup3PerHMSup2 { get; }
Public Shared ReadOnly Property MSup3PerHMSup2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MSup3PerHMSup2 {
    ForgeTypeId^ get ();
}
static member MSup3PerHMSup2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.MSup3PerHMSup3 Property

SymbolTypeIdMSup3PerHMSup3 Property

Symbol mÂ³/(hÂ·mÂ³), indicating unit Cubic meters per hour cubic meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MSup3PerHMSup3 { get; }
Public Shared ReadOnly Property MSup3PerHMSup3 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MSup3PerHMSup3 {
    ForgeTypeId^ get ();
}
static member MSup3PerHMSup3 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.MSup3PerKg Property

SymbolTypeIdMSup3PerKg Property

Symbol mÂ³/kg, indicating unit Cubic meters per kilogram.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MSup3PerKg { get; }
Public Shared ReadOnly Property MSup3PerKg As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MSup3PerKg {
    ForgeTypeId^ get ();
}
static member MSup3PerKg : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.MSup3PerKN Property

SymbolTypeIdMSup3PerKN Property

Symbol mÂ³/kN, indicating unit Cubic meters per kilonewton.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MSup3PerKN { get; }
Public Shared ReadOnly Property MSup3PerKN As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MSup3PerKN {
    ForgeTypeId^ get ();
}
static member MSup3PerKN : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.MSup3PerS Property

SymbolTypeIdMSup3PerS Property

Symbol mÂ³/s, indicating unit Cubic meters per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MSup3PerS { get; }
Public Shared ReadOnly Property MSup3PerS As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MSup3PerS {
    ForgeTypeId^ get ();
}
static member MSup3PerS : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.MSup3PerWS Property

SymbolTypeIdMSup3PerWS Property

Symbol mÂ³/(WÂ·s), indicating unit Cubic meters per watt second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MSup3PerWS { get; }
Public Shared ReadOnly Property MSup3PerWS As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MSup3PerWS {
    ForgeTypeId^ get ();
}
static member MSup3PerWS : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.MSup4 Property

SymbolTypeIdMSup4 Property

Symbol mâ´, indicating unit Meters to the fourth power.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MSup4 { get; }
Public Shared ReadOnly Property MSup4 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MSup4 {
    ForgeTypeId^ get ();
}
static member MSup4 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.MSup6 Property

SymbolTypeIdMSup6 Property

Symbol mâ¶, indicating unit Meters to the sixth power.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MSup6 { get; }
Public Shared ReadOnly Property MSup6 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MSup6 {
    ForgeTypeId^ get ();
}
static member MSup6 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.MV Property

SymbolTypeIdMV Property

Symbol mV, indicating unit Millivolts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MV { get; }
Public Shared ReadOnly Property MV As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MV {
    ForgeTypeId^ get ();
}
static member MV : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.MW Property

SymbolTypeIdMW Property

Symbol MW, indicating unit Megawatts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MW { get; }
Public Shared ReadOnly Property MW As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MW {
    ForgeTypeId^ get ();
}
static member MW : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.NDashM Property

SymbolTypeIdNDashM Property

Symbol N-m, indicating unit Newton meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId NDashM { get; }
Public Shared ReadOnly Property NDashM As ForgeTypeId
    Get
public:
static property ForgeTypeId^ NDashM {
    ForgeTypeId^ get ();
}
static member NDashM : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.NDashMPerM Property

SymbolTypeIdNDashMPerM Property

Symbol N-m/m, indicating unit Newton meters per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId NDashMPerM { get; }
Public Shared ReadOnly Property NDashMPerM As ForgeTypeId
    Get
public:
static property ForgeTypeId^ NDashMPerM {
    ForgeTypeId^ get ();
}
static member NDashMPerM : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Newton Property

SymbolTypeIdNewton Property

Symbol N, indicating unit Newtons.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Newton { get; }
Public Shared ReadOnly Property Newton As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Newton {
    ForgeTypeId^ get ();
}
static member Newton : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.NgPerPaSMSup2 Property

SymbolTypeIdNgPerPaSMSup2 Property

Symbol ng/(PaÂ·sÂ·mÂ²), indicating unit Nanograms per pascal second square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId NgPerPaSMSup2 { get; }
Public Shared ReadOnly Property NgPerPaSMSup2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ NgPerPaSMSup2 {
    ForgeTypeId^ get ();
}
static member NgPerPaSMSup2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.NPerM Property

SymbolTypeIdNPerM Property

Symbol N/m, indicating unit Newtons per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId NPerM { get; }
Public Shared ReadOnly Property NPerM As ForgeTypeId
    Get
public:
static property ForgeTypeId^ NPerM {
    ForgeTypeId^ get ();
}
static member NPerM : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.NPerMmSup2 Property

SymbolTypeIdNPerMmSup2 Property

Symbol N/mmÂ², indicating unit Newtons per square millimeter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId NPerMmSup2 { get; }
Public Shared ReadOnly Property NPerMmSup2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ NPerMmSup2 {
    ForgeTypeId^ get ();
}
static member NPerMmSup2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.NPerMSup2 Property

SymbolTypeIdNPerMSup2 Property

Symbol N/mÂ², indicating unit Newtons per square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId NPerMSup2 { get; }
Public Shared ReadOnly Property NPerMSup2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ NPerMSup2 {
    ForgeTypeId^ get ();
}
static member NPerMSup2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.NSPerMSup2 Property

SymbolTypeIdNSPerMSup2 Property

Symbol NÂ·s/mÂ², indicating unit Newton seconds per square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId NSPerMSup2 { get; }
Public Shared ReadOnly Property NSPerMSup2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ NSPerMSup2 {
    ForgeTypeId^ get ();
}
static member NSPerMSup2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.OhmM Property

SymbolTypeIdOhmM Property

Symbol ohmÂ·m, indicating unit Ohm meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId OhmM { get; }
Public Shared ReadOnly Property OhmM As ForgeTypeId
    Get
public:
static property ForgeTypeId^ OhmM {
    ForgeTypeId^ get ();
}
static member OhmM : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.OneColon Property

SymbolTypeIdOneColon Property

Symbol 1:, indicating unit 1 : Ratio.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId OneColon { get; }
Public Shared ReadOnly Property OneColon As ForgeTypeId
    Get
public:
static property ForgeTypeId^ OneColon {
    ForgeTypeId^ get ();
}
static member OneColon : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Pa Property

SymbolTypeIdPa Property

Symbol Pa, indicating unit Pascals.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Pa { get; }
Public Shared ReadOnly Property Pa As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Pa {
    ForgeTypeId^ get ();
}
static member Pa : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.PaDashS Property

SymbolTypeIdPaDashS Property

Symbol Pa-s, indicating unit Pascal seconds.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PaDashS { get; }
Public Shared ReadOnly Property PaDashS As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PaDashS {
    ForgeTypeId^ get ();
}
static member PaDashS : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.PaPerM Property

SymbolTypeIdPaPerM Property

Symbol Pa/m, indicating unit Pascals per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PaPerM { get; }
Public Shared ReadOnly Property PaPerM As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PaPerM {
    ForgeTypeId^ get ();
}
static member PaPerM : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Percent Property

SymbolTypeIdPercent Property

Symbol %, indicating unit Percentage.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Percent { get; }
Public Shared ReadOnly Property Percent As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Percent {
    ForgeTypeId^ get ();
}
static member Percent : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.PerMille Property

SymbolTypeIdPerMille Property

Symbol â€°, indicating unit Per mille.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PerMille { get; }
Public Shared ReadOnly Property PerMille As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PerMille {
    ForgeTypeId^ get ();
}
static member PerMille : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Pi Property

SymbolTypeIdPi Property

Symbol Ï€, indicating unit Multiples of Ï€.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Pi { get; }
Public Shared ReadOnly Property Pi As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Pi {
    ForgeTypeId^ get ();
}
static member Pi : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Psf Property

SymbolTypeIdPsf Property

Symbol psf, indicating unit Pounds force per square foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Psf { get; }
Public Shared ReadOnly Property Psf As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Psf {
    ForgeTypeId^ get ();
}
static member Psf : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Psi Property

SymbolTypeIdPsi Property

Symbol psi, indicating unit Pounds force per square inch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Psi { get; }
Public Shared ReadOnly Property Psi As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Psi {
    ForgeTypeId^ get ();
}
static member Psi : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Psia Property

SymbolTypeIdPsia Property

Symbol psia, indicating unit Pounds force per square inch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Psia { get; }
Public Shared ReadOnly Property Psia As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Psia {
    ForgeTypeId^ get ();
}
static member Psia : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Psig Property

SymbolTypeIdPsig Property

Symbol psig, indicating unit Pounds force per square inch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Psig { get; }
Public Shared ReadOnly Property Psig As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Psig {
    ForgeTypeId^ get ();
}
static member Psig : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Rad Property

SymbolTypeIdRad Property

Symbol rad, indicating unit Radians.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Rad { get; }
Public Shared ReadOnly Property Rad As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Rad {
    ForgeTypeId^ get ();
}
static member Rad : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.RadPerS Property

SymbolTypeIdRadPerS Property

Symbol rad/s, indicating unit Radians per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RadPerS { get; }
Public Shared ReadOnly Property RadPerS As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RadPerS {
    ForgeTypeId^ get ();
}
static member RadPerS : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Rpm Property

SymbolTypeIdRpm Property

Symbol RPM, indicating unit Revolutions per minute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Rpm { get; }
Public Shared ReadOnly Property Rpm As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Rpm {
    ForgeTypeId^ get ();
}
static member Rpm : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Rps Property

SymbolTypeIdRps Property

Symbol RPS, indicating unit Revolutions per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Rps { get; }
Public Shared ReadOnly Property Rps As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Rps {
    ForgeTypeId^ get ();
}
static member Rps : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Second Property

SymbolTypeIdSecond Property

Symbol s, indicating unit Seconds.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Second { get; }
Public Shared ReadOnly Property Second As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Second {
    ForgeTypeId^ get ();
}
static member Second : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Sf Property

SymbolTypeIdSf Property

Symbol SF, indicating unit Square feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Sf { get; }
Public Shared ReadOnly Property Sf As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Sf {
    ForgeTypeId^ get ();
}
static member Sf : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.SfHPerKbtu Property

SymbolTypeIdSfHPerKbtu Property

Symbol SFÂ·h/kBtu, indicating unit Square feet per thousand British thermal units per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SfHPerKbtu { get; }
Public Shared ReadOnly Property SfHPerKbtu As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SfHPerKbtu {
    ForgeTypeId^ get ();
}
static member SfHPerKbtu : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.SfPerMbh Property

SymbolTypeIdSfPerMbh Property

Symbol SF/MBh, indicating unit Square feet per thousand British thermal units per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SfPerMbh { get; }
Public Shared ReadOnly Property SfPerMbh As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SfPerMbh {
    ForgeTypeId^ get ();
}
static member SfPerMbh : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.SfPerTon Property

SymbolTypeIdSfPerTon Property

Symbol SF/ton, indicating unit Square feet per ton of refrigeration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SfPerTon { get; }
Public Shared ReadOnly Property SfPerTon As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SfPerTon {
    ForgeTypeId^ get ();
}
static member SfPerTon : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Shaku Property

SymbolTypeIdShaku Property

Symbol å°º, indicating unit Shaku.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Shaku { get; }
Public Shared ReadOnly Property Shaku As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Shaku {
    ForgeTypeId^ get ();
}
static member Shaku : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Shekel Property

SymbolTypeIdShekel Property

Symbol â‚ª, indicating unit Currency.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Shekel { get; }
Public Shared ReadOnly Property Shekel As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Shekel {
    ForgeTypeId^ get ();
}
static member Shekel : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.SlopeDegree Property

SymbolTypeIdSlopeDegree Property

Symbol Â°, indicating unit Slope degrees.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SlopeDegree { get; }
Public Shared ReadOnly Property SlopeDegree As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SlopeDegree {
    ForgeTypeId^ get ();
}
static member SlopeDegree : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Stf Property

SymbolTypeIdStf Property

Symbol STf, indicating unit US tonnes force.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Stf { get; }
Public Shared ReadOnly Property Stf As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Stf {
    ForgeTypeId^ get ();
}
static member Stf : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Tf Property

SymbolTypeIdTf Property

Symbol Tf, indicating unit Tonnes force.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Tf { get; }
Public Shared ReadOnly Property Tf As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Tf {
    ForgeTypeId^ get ();
}
static member Tf : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.TfDashM Property

SymbolTypeIdTfDashM Property

Symbol Tf-m, indicating unit Tonne force meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TfDashM { get; }
Public Shared ReadOnly Property TfDashM As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TfDashM {
    ForgeTypeId^ get ();
}
static member TfDashM : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.TfDashMPerM Property

SymbolTypeIdTfDashMPerM Property

Symbol Tf-m/m, indicating unit Tonne force meters per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TfDashMPerM { get; }
Public Shared ReadOnly Property TfDashMPerM As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TfDashMPerM {
    ForgeTypeId^ get ();
}
static member TfDashMPerM : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.TfPerM Property

SymbolTypeIdTfPerM Property

Symbol Tf/m, indicating unit Tonnes force per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TfPerM { get; }
Public Shared ReadOnly Property TfPerM As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TfPerM {
    ForgeTypeId^ get ();
}
static member TfPerM : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.TfPerMSup2 Property

SymbolTypeIdTfPerMSup2 Property

Symbol Tf/mÂ², indicating unit Tonnes force per square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TfPerMSup2 { get; }
Public Shared ReadOnly Property TfPerMSup2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TfPerMSup2 {
    ForgeTypeId^ get ();
}
static member TfPerMSup2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Therm Property

SymbolTypeIdTherm Property

Symbol therm, indicating unit Therms.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Therm { get; }
Public Shared ReadOnly Property Therm As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Therm {
    ForgeTypeId^ get ();
}
static member Therm : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Ton Property

SymbolTypeIdTon Property

Symbol ton, indicating unit Tons of refrigeration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Ton { get; }
Public Shared ReadOnly Property Ton As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Ton {
    ForgeTypeId^ get ();
}
static member Ton : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Tonne Property

SymbolTypeIdTonne Property

Symbol t, indicating unit Tonnes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Tonne { get; }
Public Shared ReadOnly Property Tonne As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Tonne {
    ForgeTypeId^ get ();
}
static member Tonne : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.TonOfRefrigeration Property

SymbolTypeIdTonOfRefrigeration Property

Symbol ton of refrigeration, indicating unit Tons of refrigeration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TonOfRefrigeration { get; }
Public Shared ReadOnly Property TonOfRefrigeration As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TonOfRefrigeration {
    ForgeTypeId^ get ();
}
static member TonOfRefrigeration : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Tonsf Property

SymbolTypeIdTonsf Property

Symbol Tonsf, indicating unit US tonnes force.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Tonsf { get; }
Public Shared ReadOnly Property Tonsf As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Tonsf {
    ForgeTypeId^ get ();
}
static member Tonsf : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.UinPerInDegreeF Property

SymbolTypeIdUinPerInDegreeF Property

Symbol Âµin/(inÂ·Â°F), indicating unit Microinches per inch degree Fahrenheit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId UinPerInDegreeF { get; }
Public Shared ReadOnly Property UinPerInDegreeF As ForgeTypeId
    Get
public:
static property ForgeTypeId^ UinPerInDegreeF {
    ForgeTypeId^ get ();
}
static member UinPerInDegreeF : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.UkPound Property

SymbolTypeIdUkPound Property

Symbol Â£, indicating unit Currency.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId UkPound { get; }
Public Shared ReadOnly Property UkPound As ForgeTypeId
    Get
public:
static property ForgeTypeId^ UkPound {
    ForgeTypeId^ get ();
}
static member UkPound : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.UmPerMDegreeC Property

SymbolTypeIdUmPerMDegreeC Property

Symbol Âµm/(mÂ·Â°C), indicating unit Micrometers per meter degree Celsius.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId UmPerMDegreeC { get; }
Public Shared ReadOnly Property UmPerMDegreeC As ForgeTypeId
    Get
public:
static property ForgeTypeId^ UmPerMDegreeC {
    ForgeTypeId^ get ();
}
static member UmPerMDegreeC : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.UsDollar Property

SymbolTypeIdUsDollar Property

Symbol $, indicating unit Currency.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId UsDollar { get; }
Public Shared ReadOnly Property UsDollar As ForgeTypeId
    Get
public:
static property ForgeTypeId^ UsDollar {
    ForgeTypeId^ get ();
}
static member UsDollar : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Usft Property

SymbolTypeIdUsft Property

Symbol USft, indicating unit US survey feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Usft { get; }
Public Shared ReadOnly Property Usft As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Usft {
    ForgeTypeId^ get ();
}
static member Usft : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Usgph Property

SymbolTypeIdUsgph Property

Symbol usgph, indicating unit US gallons per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Usgph { get; }
Public Shared ReadOnly Property Usgph As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Usgph {
    ForgeTypeId^ get ();
}
static member Usgph : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Usgpm Property

SymbolTypeIdUsgpm Property

Symbol usgpm, indicating unit US gallons per minute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Usgpm { get; }
Public Shared ReadOnly Property Usgpm As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Usgpm {
    ForgeTypeId^ get ();
}
static member Usgpm : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.UsTonnesForceSt Property

SymbolTypeIdUsTonnesForceSt Property

Symbol ST, indicating unit US tonnes force.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId UsTonnesForceSt { get; }
Public Shared ReadOnly Property UsTonnesForceSt As ForgeTypeId
    Get
public:
static property ForgeTypeId^ UsTonnesForceSt {
    ForgeTypeId^ get ();
}
static member UsTonnesForceSt : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.UsTonnesForceT Property

SymbolTypeIdUsTonnesForceT Property

Symbol T, indicating unit US tonnes force.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId UsTonnesForceT { get; }
Public Shared ReadOnly Property UsTonnesForceT As ForgeTypeId
    Get
public:
static property ForgeTypeId^ UsTonnesForceT {
    ForgeTypeId^ get ();
}
static member UsTonnesForceT : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.UsTonnesForceTons Property

SymbolTypeIdUsTonnesForceTons Property

Symbol Tons, indicating unit US tonnes force.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId UsTonnesForceTons { get; }
Public Shared ReadOnly Property UsTonnesForceTons As ForgeTypeId
    Get
public:
static property ForgeTypeId^ UsTonnesForceTons {
    ForgeTypeId^ get ();
}
static member UsTonnesForceTons : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.UsTonnesMassSt Property

SymbolTypeIdUsTonnesMassSt Property

Symbol ST, indicating unit US tonnes mass.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId UsTonnesMassSt { get; }
Public Shared ReadOnly Property UsTonnesMassSt As ForgeTypeId
    Get
public:
static property ForgeTypeId^ UsTonnesMassSt {
    ForgeTypeId^ get ();
}
static member UsTonnesMassSt : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.UsTonnesMassT Property

SymbolTypeIdUsTonnesMassT Property

Symbol T, indicating unit US tonnes mass.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId UsTonnesMassT { get; }
Public Shared ReadOnly Property UsTonnesMassT As ForgeTypeId
    Get
public:
static property ForgeTypeId^ UsTonnesMassT {
    ForgeTypeId^ get ();
}
static member UsTonnesMassT : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.UsTonnesMassTons Property

SymbolTypeIdUsTonnesMassTons Property

Symbol Tons, indicating unit US tonnes mass.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId UsTonnesMassTons { get; }
Public Shared ReadOnly Property UsTonnesMassTons As ForgeTypeId
    Get
public:
static property ForgeTypeId^ UsTonnesMassTons {
    ForgeTypeId^ get ();
}
static member UsTonnesMassTons : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.VA Property

SymbolTypeIdVA Property

Symbol VA, indicating unit Volt amperes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId VA { get; }
Public Shared ReadOnly Property VA As ForgeTypeId
    Get
public:
static property ForgeTypeId^ VA {
    ForgeTypeId^ get ();
}
static member VA : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.VAPerFtSup2 Property

SymbolTypeIdVAPerFtSup2 Property

Symbol VA/ftÂ², indicating unit Volt amperes per square foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId VAPerFtSup2 { get; }
Public Shared ReadOnly Property VAPerFtSup2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ VAPerFtSup2 {
    ForgeTypeId^ get ();
}
static member VAPerFtSup2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.VAPerMSup2 Property

SymbolTypeIdVAPerMSup2 Property

Symbol VA/mÂ², indicating unit Volt amperes per square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId VAPerMSup2 { get; }
Public Shared ReadOnly Property VAPerMSup2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ VAPerMSup2 {
    ForgeTypeId^ get ();
}
static member VAPerMSup2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Volt Property

SymbolTypeIdVolt Property

Symbol V, indicating unit Volts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Volt { get; }
Public Shared ReadOnly Property Volt As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Volt {
    ForgeTypeId^ get ();
}
static member Volt : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Watt Property

SymbolTypeIdWatt Property

Symbol W, indicating unit Watts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Watt { get; }
Public Shared ReadOnly Property Watt As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Watt {
    ForgeTypeId^ get ();
}
static member Watt : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.WMinPerFtSup3 Property

SymbolTypeIdWMinPerFtSup3 Property

Symbol WÂ·min/ftÂ³, indicating unit Watts per cubic foot per minute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WMinPerFtSup3 { get; }
Public Shared ReadOnly Property WMinPerFtSup3 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WMinPerFtSup3 {
    ForgeTypeId^ get ();
}
static member WMinPerFtSup3 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Won Property

SymbolTypeIdWon Property

Symbol â‚©, indicating unit Currency.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Won { get; }
Public Shared ReadOnly Property Won As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Won {
    ForgeTypeId^ get ();
}
static member Won : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.WPerFt Property

SymbolTypeIdWPerFt Property

Symbol W/ft, indicating unit Watts per foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WPerFt { get; }
Public Shared ReadOnly Property WPerFt As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WPerFt {
    ForgeTypeId^ get ();
}
static member WPerFt : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.WPerFtSup2 Property

SymbolTypeIdWPerFtSup2 Property

Symbol W/ftÂ², indicating unit Watts per square foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WPerFtSup2 { get; }
Public Shared ReadOnly Property WPerFtSup2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WPerFtSup2 {
    ForgeTypeId^ get ();
}
static member WPerFtSup2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.WPerFtSup3 Property

SymbolTypeIdWPerFtSup3 Property

Symbol W/ftÂ³, indicating unit Watts per cubic foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WPerFtSup3 { get; }
Public Shared ReadOnly Property WPerFtSup3 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WPerFtSup3 {
    ForgeTypeId^ get ();
}
static member WPerFtSup3 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.WPerM Property

SymbolTypeIdWPerM Property

Symbol W/m, indicating unit Watts per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WPerM { get; }
Public Shared ReadOnly Property WPerM As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WPerM {
    ForgeTypeId^ get ();
}
static member WPerM : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.WPerMK Property

SymbolTypeIdWPerMK Property

Symbol W/(mÂ·K), indicating unit Watts per meter kelvin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WPerMK { get; }
Public Shared ReadOnly Property WPerMK As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WPerMK {
    ForgeTypeId^ get ();
}
static member WPerMK : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.WPerMSup2 Property

SymbolTypeIdWPerMSup2 Property

Symbol W/mÂ², indicating unit Watts per square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WPerMSup2 { get; }
Public Shared ReadOnly Property WPerMSup2 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WPerMSup2 {
    ForgeTypeId^ get ();
}
static member WPerMSup2 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.WPerMSup2K Property

SymbolTypeIdWPerMSup2K Property

Symbol W/(mÂ²Â·K), indicating unit Watts per square meter kelvin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WPerMSup2K { get; }
Public Shared ReadOnly Property WPerMSup2K As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WPerMSup2K {
    ForgeTypeId^ get ();
}
static member WPerMSup2K : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.WPerMSup3 Property

SymbolTypeIdWPerMSup3 Property

Symbol W/mÂ³, indicating unit Watts per cubic meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WPerMSup3 { get; }
Public Shared ReadOnly Property WPerMSup3 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WPerMSup3 {
    ForgeTypeId^ get ();
}
static member WPerMSup3 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.WSPerMSup3 Property

SymbolTypeIdWSPerMSup3 Property

Symbol WÂ·s/mÂ³, indicating unit Watts per cubic meter per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WSPerMSup3 { get; }
Public Shared ReadOnly Property WSPerMSup3 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WSPerMSup3 {
    ForgeTypeId^ get ();
}
static member WSPerMSup3 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.YdCaret3 Property

SymbolTypeIdYdCaret3 Property

Symbol yd^3, indicating unit Cubic yards.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId YdCaret3 { get; }
Public Shared ReadOnly Property YdCaret3 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ YdCaret3 {
    ForgeTypeId^ get ();
}
static member YdCaret3 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.YdSup3 Property

SymbolTypeIdYdSup3 Property

Symbol ydÂ³, indicating unit Cubic yards.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId YdSup3 { get; }
Public Shared ReadOnly Property YdSup3 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ YdSup3 {
    ForgeTypeId^ get ();
}
static member YdSup3 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SymbolTypeId.Yen Property

SymbolTypeIdYen Property

Symbol Â¥, indicating unit Currency.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Yen { get; }
Public Shared ReadOnly Property Yen As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Yen {
    ForgeTypeId^ get ();
}
static member Yen : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

SymbolTypeId Class


SynchronizeWithCentralOptions Class

Options to control behavior of synchronization with central.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBSynchronizeWithCentralOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SynchronizeWithCentralOptions : IDisposable
Public Class SynchronizeWithCentralOptions
    Implements IDisposable
public ref class SynchronizeWithCentralOptions : IDisposable
type SynchronizeWithCentralOptions =
    class
        interface IDisposable
    end

The SynchronizeWithCentralOptions type exposes the following members.

Constructors
 | Name | Description
Public method | SynchronizeWithCentralOptions | Constructs a new instance of SynchronizeWithCentralOptions initialized with default options.
Top
Properties
 | Name | Description
Public property | Comment | User description of changes made since the last Sync with Central. Empty by default.
Public property | Compact | Indicates whether Revit should compact the central model while synchronizing with central. This option reduces the size of the central model but many increase the time it takes to perform the save. False by default.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | RelinquishBorrowedElements | Indicates whether Revit should relinquish borrowed elements after synchronizing with central.
Public property | RelinquishFamilyWorksets | Indicates whether Revit should relinquish Family worksets after synchronizing with central.
Public property | RelinquishProjectStandardWorksets | Indicates whether Revit should relinquish Project Standard worksets after synchronizing with central.
Public property | RelinquishUserCreatedWorksets | Indicates whether Revit should relinquish user-created Standard worksets after synchronizing with central.
Public property | RelinquishViewWorksets | Indicates whether Revit should relinquish View worksets after synchronizing with central.
Public property | SaveLocalAfter | True means to save local after saving changes to central. True by default. Silently ignored if the model in the current session is central rather than local.
Public property | SaveLocalBefore | True means to save local before the first reload latest if there are changes not yet saved to local. True by default. Silently ignored if the model in the current session is central rather than local.
Public property | SaveLocalFile | Indicates whether Revit will save the local file at least once while synchronizing with central.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the SynchronizeWithCentralOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRelinquishOptions | Gets the options which govern whether or not to relinquish elements and workset types.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetRelinquishOptions | Sets the options which govern whether or not to relinquish elements and workset types.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


SynchronizeWithCentralOptions Constructor

Constructs a new instance of SynchronizeWithCentralOptions initialized with default options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SynchronizeWithCentralOptions()
Public Sub New
public:
SynchronizeWithCentralOptions()
new : unit -> SynchronizeWithCentralOptions
See Also

Reference

SynchronizeWithCentralOptions Class


SynchronizeWithCentralOptions Properties

The SynchronizeWithCentralOptions type exposes the following members.

Properties
 | Name | Description
Public property | Comment | User description of changes made since the last Sync with Central. Empty by default.
Public property | Compact | Indicates whether Revit should compact the central model while synchronizing with central. This option reduces the size of the central model but many increase the time it takes to perform the save. False by default.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | RelinquishBorrowedElements | Indicates whether Revit should relinquish borrowed elements after synchronizing with central.
Public property | RelinquishFamilyWorksets | Indicates whether Revit should relinquish Family worksets after synchronizing with central.
Public property | RelinquishProjectStandardWorksets | Indicates whether Revit should relinquish Project Standard worksets after synchronizing with central.
Public property | RelinquishUserCreatedWorksets | Indicates whether Revit should relinquish user-created Standard worksets after synchronizing with central.
Public property | RelinquishViewWorksets | Indicates whether Revit should relinquish View worksets after synchronizing with central.
Public property | SaveLocalAfter | True means to save local after saving changes to central. True by default. Silently ignored if the model in the current session is central rather than local.
Public property | SaveLocalBefore | True means to save local before the first reload latest if there are changes not yet saved to local. True by default. Silently ignored if the model in the current session is central rather than local.
Public property | SaveLocalFile | Indicates whether Revit will save the local file at least once while synchronizing with central.
Top
See Also

Reference

SynchronizeWithCentralOptions Class


SynchronizeWithCentralOptions.Comment Property

SynchronizeWithCentralOptionsComment Property

User description of changes made since the last Sync with Central. Empty by default.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Comment { get; set; }
Public Property Comment As String
    Get
    Set
public:
property String^ Comment {
    String^ get ();
    void set (String^ value);
}
member Comment : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentException | When setting this property: comment has more than 30,000 characters.
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

SynchronizeWithCentralOptions Class


SynchronizeWithCentralOptions.Compact Property

SynchronizeWithCentralOptionsCompact Property

Indicates whether Revit should compact the central model while synchronizing with central. This option reduces the size of the central model but many increase the time it takes to perform the save. False by default.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Compact { get; set; }
Public Property Compact As Boolean
    Get
    Set
public:
property bool Compact {
    bool get ();
    void set (bool value);
}
member Compact : bool with get, set

Property Value

Boolean
See Also

Reference

SynchronizeWithCentralOptions Class


SynchronizeWithCentralOptions.IsValidObject Property

SynchronizeWithCentralOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

SynchronizeWithCentralOptions Class


SynchronizeWithCentralOptions.RelinquishBorrowedElements Property

SynchronizeWithCentralOptionsRelinquishBorrowedElements Property

Indicates whether Revit should relinquish borrowed elements after synchronizing with central.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool RelinquishBorrowedElements { get; }
Public ReadOnly Property RelinquishBorrowedElements As Boolean
    Get
public:
property bool RelinquishBorrowedElements {
    bool get ();
}
member RelinquishBorrowedElements : bool with get

Property Value

Boolean
Remarks
This is a shortcut to access the value stored in CheckedOutElements.
See Also

Reference

SynchronizeWithCentralOptions Class


SynchronizeWithCentralOptions.RelinquishFamilyWorksets Property

SynchronizeWithCentralOptionsRelinquishFamilyWorksets Property

Indicates whether Revit should relinquish Family worksets after synchronizing with central.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool RelinquishFamilyWorksets { get; }
Public ReadOnly Property RelinquishFamilyWorksets As Boolean
    Get
public:
property bool RelinquishFamilyWorksets {
    bool get ();
}
member RelinquishFamilyWorksets : bool with get

Property Value

Boolean
Remarks
This is a shortcut to access the value stored in FamilyWorksets.
See Also

Reference

SynchronizeWithCentralOptions Class


SynchronizeWithCentralOptions.RelinquishProjectStandardWorksets Property

SynchronizeWithCentralOptionsRelinquishProjectStandardWorksets Property

Indicates whether Revit should relinquish Project Standard worksets after synchronizing with central.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool RelinquishProjectStandardWorksets { get; }
Public ReadOnly Property RelinquishProjectStandardWorksets As Boolean
    Get
public:
property bool RelinquishProjectStandardWorksets {
    bool get ();
}
member RelinquishProjectStandardWorksets : bool with get

Property Value

Boolean
Remarks
This is a shortcut to access the value stored in StandardWorksets.
See Also

Reference

SynchronizeWithCentralOptions Class


SynchronizeWithCentralOptions.RelinquishUserCreatedWorksets Property

SynchronizeWithCentralOptionsRelinquishUserCreatedWorksets Property

Indicates whether Revit should relinquish user-created Standard worksets after synchronizing with central.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool RelinquishUserCreatedWorksets { get; }
Public ReadOnly Property RelinquishUserCreatedWorksets As Boolean
    Get
public:
property bool RelinquishUserCreatedWorksets {
    bool get ();
}
member RelinquishUserCreatedWorksets : bool with get

Property Value

Boolean
Remarks
This is a shortcut to access the value stored in UserWorksets.
See Also

Reference

SynchronizeWithCentralOptions Class


SynchronizeWithCentralOptions.RelinquishViewWorksets Property

SynchronizeWithCentralOptionsRelinquishViewWorksets Property

Indicates whether Revit should relinquish View worksets after synchronizing with central.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool RelinquishViewWorksets { get; }
Public ReadOnly Property RelinquishViewWorksets As Boolean
    Get
public:
property bool RelinquishViewWorksets {
    bool get ();
}
member RelinquishViewWorksets : bool with get

Property Value

Boolean
Remarks
This is a shortcut to access the value stored in ViewWorksets.
See Also

Reference

SynchronizeWithCentralOptions Class


SynchronizeWithCentralOptions.SaveLocalAfter Property

SynchronizeWithCentralOptionsSaveLocalAfter Property

True means to save local after saving changes to central. True by default. Silently ignored if the model in the current session is central rather than local.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SaveLocalAfter { get; set; }
Public Property SaveLocalAfter As Boolean
    Get
    Set
public:
property bool SaveLocalAfter {
    bool get ();
    void set (bool value);
}
member SaveLocalAfter : bool with get, set

Property Value

Boolean
Remarks
It is recommended practice to save local after SWC because otherwise local becomes incompatible with central.
See Also

Reference

SynchronizeWithCentralOptions Class


SynchronizeWithCentralOptions.SaveLocalBefore Property

SynchronizeWithCentralOptionsSaveLocalBefore Property

True means to save local before the first reload latest if there are changes not yet saved to local. True by default. Silently ignored if the model in the current session is central rather than local.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SaveLocalBefore { get; set; }
Public Property SaveLocalBefore As Boolean
    Get
    Set
public:
property bool SaveLocalBefore {
    bool get ();
    void set (bool value);
}
member SaveLocalBefore : bool with get, set

Property Value

Boolean
See Also

Reference

SynchronizeWithCentralOptions Class


SynchronizeWithCentralOptions.SaveLocalFile Property

SynchronizeWithCentralOptionsSaveLocalFile Property

Indicates whether Revit will save the local file at least once while synchronizing with central.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SaveLocalFile { get; }
Public ReadOnly Property SaveLocalFile As Boolean
    Get
public:
property bool SaveLocalFile {
    bool get ();
}
member SaveLocalFile : bool with get

Property Value

Boolean
See Also

Reference

SynchronizeWithCentralOptions Class


SynchronizeWithCentralOptions Methods

The SynchronizeWithCentralOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRelinquishOptions | Gets the options which govern whether or not to relinquish elements and workset types.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetRelinquishOptions | Sets the options which govern whether or not to relinquish elements and workset types.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SynchronizeWithCentralOptions Class


SynchronizeWithCentralOptions.Dispose Method

SynchronizeWithCentralOptionsDispose Method

Releases all resources used by the SynchronizeWithCentralOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

SynchronizeWithCentralOptions Class


SynchronizeWithCentralOptions.GetRelinquishOptions Method

SynchronizeWithCentralOptionsGetRelinquishOptions Method

Gets the options which govern whether or not to relinquish elements and workset types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RelinquishOptions GetRelinquishOptions()
Public Function GetRelinquishOptions As RelinquishOptions
public:
RelinquishOptions^ GetRelinquishOptions()
member GetRelinquishOptions : unit -> RelinquishOptions

Return Value

RelinquishOptions
The options. If , synchronize with central will relinquish the current user's ownership of all worksets and all elements.
See Also

Reference

SynchronizeWithCentralOptions Class


SynchronizeWithCentralOptions.SetRelinquishOptions Method

SynchronizeWithCentralOptionsSetRelinquishOptions Method

Sets the options which govern whether or not to relinquish elements and workset types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetRelinquishOptions(
    RelinquishOptions relinquishOptions
)
Public Sub SetRelinquishOptions (
    relinquishOptions As RelinquishOptions
)
public:
void SetRelinquishOptions(
    RelinquishOptions^ relinquishOptions
)
member SetRelinquishOptions :
        relinquishOptions : RelinquishOptions -> unit

Parameters

relinquishOptions RelinquishOptions
The options. If , synchronize with central will relinquish the current user's ownership of all worksets and all elements.
See Also

Reference

SynchronizeWithCentralOptions Class


TableCellCalculatedValueData Class

The TableCellCalculatedValueData stores the data for calculated value
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBTableCellCalculatedValueData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TableCellCalculatedValueData : IDisposable
Public Class TableCellCalculatedValueData
    Implements IDisposable
public ref class TableCellCalculatedValueData : IDisposable
type TableCellCalculatedValueData =
    class
        interface IDisposable
    end

The TableCellCalculatedValueData type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the TableCellCalculatedValueData
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetName | Gets the name of the calculated value.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TableCellCalculatedValueData Properties

The TableCellCalculatedValueData type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

TableCellCalculatedValueData Class


TableCellCalculatedValueData.IsValidObject Property

TableCellCalculatedValueDataIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

TableCellCalculatedValueData Class


TableCellCalculatedValueData Methods

The TableCellCalculatedValueData type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetName | Gets the name of the calculated value.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

TableCellCalculatedValueData Class


TableCellCalculatedValueData.Dispose Method

TableCellCalculatedValueDataDispose Method

Releases all resources used by the TableCellCalculatedValueData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

TableCellCalculatedValueData Class


TableCellCalculatedValueData.GetName Method

TableCellCalculatedValueDataGetName Method

Gets the name of the calculated value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetName()
Public Function GetName As String
public:
String^ GetName()
member GetName : unit -> string

Return Value

String
See Also

Reference

TableCellCalculatedValueData Class


TableCellCombinedParameterData Class

The TableCellCombinedParameterData stores the data for combined parameters
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBTableCellCombinedParameterData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TableCellCombinedParameterData : IDisposable
Public Class TableCellCombinedParameterData
    Implements IDisposable
public ref class TableCellCombinedParameterData : IDisposable
type TableCellCombinedParameterData =
    class
        interface IDisposable
    end

The TableCellCombinedParameterData type exposes the following members.

Properties
 | Name | Description
Public property | CategoryId | Category id for this parameter
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ParamId | The parameter id
Public property | Prefix | The prefix for this parameter
Public property | SampleValue | The sample/example value for the parameter in text form
Public property | Separator | The separator for this parameter
Public property | Suffix | The suffix for this parameter
Top
Methods
 | Name | Description
 | Create | construct a TableCellCombinedParameterData
Public method | Dispose | Releases all resources used by the TableCellCombinedParameterData
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TableCellCombinedParameterData Properties

The TableCellCombinedParameterData type exposes the following members.

Properties
 | Name | Description
Public property | CategoryId | Category id for this parameter
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ParamId | The parameter id
Public property | Prefix | The prefix for this parameter
Public property | SampleValue | The sample/example value for the parameter in text form
Public property | Separator | The separator for this parameter
Public property | Suffix | The suffix for this parameter
Top
See Also

Reference

TableCellCombinedParameterData Class


TableCellCombinedParameterData.CategoryId Property

TableCellCombinedParameterDataCategoryId Property

Category id for this parameter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId CategoryId { get; set; }
Public Property CategoryId As ElementId
    Get
    Set
public:
property ElementId^ CategoryId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member CategoryId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

TableCellCombinedParameterData Class


TableCellCombinedParameterData.IsValidObject Property

TableCellCombinedParameterDataIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

TableCellCombinedParameterData Class


TableCellCombinedParameterData.ParamId Property

TableCellCombinedParameterDataParamId Property

The parameter id

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId ParamId { get; set; }
Public Property ParamId As ElementId
    Get
    Set
public:
property ElementId^ ParamId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member ParamId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

TableCellCombinedParameterData Class


TableCellCombinedParameterData.Prefix Property

TableCellCombinedParameterDataPrefix Property

The prefix for this parameter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Prefix { get; set; }
Public Property Prefix As String
    Get
    Set
public:
property String^ Prefix {
    String^ get ();
    void set (String^ value);
}
member Prefix : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

TableCellCombinedParameterData Class


TableCellCombinedParameterData.SampleValue Property

TableCellCombinedParameterDataSampleValue Property

The sample/example value for the parameter in text form

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SampleValue { get; set; }
Public Property SampleValue As String
    Get
    Set
public:
property String^ SampleValue {
    String^ get ();
    void set (String^ value);
}
member SampleValue : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

TableCellCombinedParameterData Class


TableCellCombinedParameterData.Separator Property

TableCellCombinedParameterDataSeparator Property

The separator for this parameter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Separator { get; set; }
Public Property Separator As String
    Get
    Set
public:
property String^ Separator {
    String^ get ();
    void set (String^ value);
}
member Separator : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

TableCellCombinedParameterData Class


TableCellCombinedParameterData.Suffix Property

TableCellCombinedParameterDataSuffix Property

The suffix for this parameter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Suffix { get; set; }
Public Property Suffix As String
    Get
    Set
public:
property String^ Suffix {
    String^ get ();
    void set (String^ value);
}
member Suffix : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

TableCellCombinedParameterData Class


TableCellCombinedParameterData Methods

The TableCellCombinedParameterData type exposes the following members.

Methods
 | Name | Description
 | Create | construct a TableCellCombinedParameterData
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

TableCellCombinedParameterData Class


TableCellCombinedParameterData.Create Method

TableCellCombinedParameterDataCreate Method

construct a TableCellCombinedParameterData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static TableCellCombinedParameterData Create()
Public Shared Function Create As TableCellCombinedParameterData
public:
static TableCellCombinedParameterData^ Create()
static member Create : unit -> TableCellCombinedParameterData

Return Value

TableCellCombinedParameterData
See Also

Reference

TableCellCombinedParameterData Class


TableCellCombinedParameterData.Dispose Method

TableCellCombinedParameterDataDispose Method

Releases all resources used by the TableCellCombinedParameterData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

TableCellCombinedParameterData Class


TableCellStyle Class

The TableCellStyle class contains the appearance settings for a given table cell, column, or table.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBTableCellStyle

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TableCellStyle : IDisposable
Public Class TableCellStyle
    Implements IDisposable
public ref class TableCellStyle : IDisposable
type TableCellStyle =
    class
        interface IDisposable
    end

The TableCellStyle type exposes the following members.

Constructors
 | Name | Description
Public method | TableCellStyle | Constructs a new TableCellStyle with default settings.
Public method | TableCellStyle(TableCellStyle) | Constructs a new copy of the input TableCellStyle object.
Top
Properties
 | Name | Description
Public property | BackgroundColor | The background color of this cell in the grid view.
Public property | BorderBottomLineStyle | The element id (GraphicsStyle element) for the bottom line of the cell border.
Public property | BorderLeftLineStyle | The element id (GraphicsStyle element) for the left line of the cell border.
Public property | BorderRightLineStyle | The element id (GraphicsStyle element) for the right line of the cell border.
Public property | BorderTopLineStyle | The element id (GraphicsStyle element) for the top line of the cell border.
Public property | FontHorizontalAlignment | The horizontal alignment style of text font.
Public property | FontName | The font used for this style
Public property | FontVerticalAlignment | The vertical alignment style of text font.
Public property | IsEnabled | Gets or sets the status whether this cell is enabled.
Public property | IsFontBold | Gets or sets whether the text font is set to bold of this cell.
Public property | IsFontItalic | Gets or sets whether the text font is set to italic of this cell.
Public property | IsFontUnderline | Gets or sets whether the text font is set to Underline of this cell.
Public property | IsInactivePhaseload | Gets or sets whether this is an inactive phase load cell.
Public property | IsOverridden | Indicates if the cell is overridden or not.
Public property | IsReadOnly | Gets or sets whether this cell is read only.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SheetBackgroundColor | The background color of this cell in the sheet view.
Public property | TextColor | The text color of this cell.
Public property | TextOrientation | The orientation of the cell (for vertical/horizontal text) with input in degrees multiplied by 10
Public property | TextSize | The text size.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the TableCellStyle
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCellStyleOverrideOptions | Gets cell style override options of this cell.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ResetOverride | Resets any overrides applied to this cell.
 | SetCellStyleOverrideOptions | Sets cell style override options of this cell.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TableCellStyle Constructor

Overload List
 | Name | Description
Public method | TableCellStyle | Constructs a new TableCellStyle with default settings.
Public method | TableCellStyle(TableCellStyle) | Constructs a new copy of the input TableCellStyle object.
Top
See Also

Reference

TableCellStyle Class


TableCellStyle Constructor

Constructs a new TableCellStyle with default settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TableCellStyle()
Public Sub New
public:
TableCellStyle()
new : unit -> TableCellStyle
See Also

Reference

TableCellStyle Class
TableCellStyle Overload


TableCellStyle(TableCellStyle) Constructor

Constructs a new copy of the input TableCellStyle object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TableCellStyle(
    TableCellStyle other
)
Public Sub New (
    other As TableCellStyle
)
public:
TableCellStyle(
    TableCellStyle^ other
)
new :
        other : TableCellStyle -> TableCellStyle

Parameters

other TableCellStyle
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

TableCellStyle Class
TableCellStyle Overload


TableCellStyle Properties

The TableCellStyle type exposes the following members.

Properties
 | Name | Description
Public property | BackgroundColor | The background color of this cell in the grid view.
Public property | BorderBottomLineStyle | The element id (GraphicsStyle element) for the bottom line of the cell border.
Public property | BorderLeftLineStyle | The element id (GraphicsStyle element) for the left line of the cell border.
Public property | BorderRightLineStyle | The element id (GraphicsStyle element) for the right line of the cell border.
Public property | BorderTopLineStyle | The element id (GraphicsStyle element) for the top line of the cell border.
Public property | FontHorizontalAlignment | The horizontal alignment style of text font.
Public property | FontName | The font used for this style
Public property | FontVerticalAlignment | The vertical alignment style of text font.
Public property | IsEnabled | Gets or sets the status whether this cell is enabled.
Public property | IsFontBold | Gets or sets whether the text font is set to bold of this cell.
Public property | IsFontItalic | Gets or sets whether the text font is set to italic of this cell.
Public property | IsFontUnderline | Gets or sets whether the text font is set to Underline of this cell.
Public property | IsInactivePhaseload | Gets or sets whether this is an inactive phase load cell.
Public property | IsOverridden | Indicates if the cell is overridden or not.
Public property | IsReadOnly | Gets or sets whether this cell is read only.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SheetBackgroundColor | The background color of this cell in the sheet view.
Public property | TextColor | The text color of this cell.
Public property | TextOrientation | The orientation of the cell (for vertical/horizontal text) with input in degrees multiplied by 10
Public property | TextSize | The text size.
Top
See Also

Reference

TableCellStyle Class


TableCellStyle.BackgroundColor Property

TableCellStyleBackgroundColor Property

The background color of this cell in the grid view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color BackgroundColor { get; set; }
Public Property BackgroundColor As Color
    Get
    Set
public:
property Color^ BackgroundColor {
    Color^ get ();
    void set (Color^ value);
}
member BackgroundColor : Color with get, set

Property Value

Color
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

TableCellStyle Class


TableCellStyle.BorderBottomLineStyle Property

TableCellStyleBorderBottomLineStyle Property

The element id (GraphicsStyle element) for the bottom line of the cell border.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId BorderBottomLineStyle { get; set; }
Public Property BorderBottomLineStyle As ElementId
    Get
    Set
public:
property ElementId^ BorderBottomLineStyle {
    ElementId^ get ();
    void set (ElementId^ value);
}
member BorderBottomLineStyle : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

TableCellStyle Class


TableCellStyle.BorderLeftLineStyle Property

TableCellStyleBorderLeftLineStyle Property

The element id (GraphicsStyle element) for the left line of the cell border.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId BorderLeftLineStyle { get; set; }
Public Property BorderLeftLineStyle As ElementId
    Get
    Set
public:
property ElementId^ BorderLeftLineStyle {
    ElementId^ get ();
    void set (ElementId^ value);
}
member BorderLeftLineStyle : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

TableCellStyle Class


TableCellStyle.BorderRightLineStyle Property

TableCellStyleBorderRightLineStyle Property

The element id (GraphicsStyle element) for the right line of the cell border.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId BorderRightLineStyle { get; set; }
Public Property BorderRightLineStyle As ElementId
    Get
    Set
public:
property ElementId^ BorderRightLineStyle {
    ElementId^ get ();
    void set (ElementId^ value);
}
member BorderRightLineStyle : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

TableCellStyle Class


TableCellStyle.BorderTopLineStyle Property

TableCellStyleBorderTopLineStyle Property

The element id (GraphicsStyle element) for the top line of the cell border.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId BorderTopLineStyle { get; set; }
Public Property BorderTopLineStyle As ElementId
    Get
    Set
public:
property ElementId^ BorderTopLineStyle {
    ElementId^ get ();
    void set (ElementId^ value);
}
member BorderTopLineStyle : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

TableCellStyle Class


TableCellStyle.FontHorizontalAlignment Property

TableCellStyleFontHorizontalAlignment Property

The horizontal alignment style of text font.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public HorizontalAlignmentStyle FontHorizontalAlignment { get; set; }
Public Property FontHorizontalAlignment As HorizontalAlignmentStyle
    Get
    Set
public:
property HorizontalAlignmentStyle FontHorizontalAlignment {
    HorizontalAlignmentStyle get ();
    void set (HorizontalAlignmentStyle value);
}
member FontHorizontalAlignment : HorizontalAlignmentStyle with get, set

Property Value

HorizontalAlignmentStyle
Alignment style.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

TableCellStyle Class


TableCellStyle.FontName Property

TableCellStyleFontName Property

The font used for this style

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FontName { get; set; }
Public Property FontName As String
    Get
    Set
public:
property String^ FontName {
    String^ get ();
    void set (String^ value);
}
member FontName : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

TableCellStyle Class


TableCellStyle.FontVerticalAlignment Property

TableCellStyleFontVerticalAlignment Property

The vertical alignment style of text font.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VerticalAlignmentStyle FontVerticalAlignment { get; set; }
Public Property FontVerticalAlignment As VerticalAlignmentStyle
    Get
    Set
public:
property VerticalAlignmentStyle FontVerticalAlignment {
    VerticalAlignmentStyle get ();
    void set (VerticalAlignmentStyle value);
}
member FontVerticalAlignment : VerticalAlignmentStyle with get, set

Property Value

VerticalAlignmentStyle
Alignment style.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

TableCellStyle Class


TableCellStyle.IsEnabled Property

TableCellStyleIsEnabled Property

Gets or sets the status whether this cell is enabled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEnabled { get; set; }
Public Property IsEnabled As Boolean
    Get
    Set
public:
property bool IsEnabled {
    bool get ();
    void set (bool value);
}
member IsEnabled : bool with get, set

Property Value

Boolean
True if this cell is enabled; otherwise False.
See Also

Reference

TableCellStyle Class


TableCellStyle.IsFontBold Property

TableCellStyleIsFontBold Property

Gets or sets whether the text font is set to bold of this cell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsFontBold { get; set; }
Public Property IsFontBold As Boolean
    Get
    Set
public:
property bool IsFontBold {
    bool get ();
    void set (bool value);
}
member IsFontBold : bool with get, set

Property Value

Boolean
true if the font is bold; otherwise false.
See Also

Reference

TableCellStyle Class


TableCellStyle.IsFontItalic Property

TableCellStyleIsFontItalic Property

Gets or sets whether the text font is set to italic of this cell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsFontItalic { get; set; }
Public Property IsFontItalic As Boolean
    Get
    Set
public:
property bool IsFontItalic {
    bool get ();
    void set (bool value);
}
member IsFontItalic : bool with get, set

Property Value

Boolean
true if the font is italic; otherwise false.
See Also

Reference

TableCellStyle Class


TableCellStyle.IsFontUnderline Property

TableCellStyleIsFontUnderline Property

Gets or sets whether the text font is set to Underline of this cell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsFontUnderline { get; set; }
Public Property IsFontUnderline As Boolean
    Get
    Set
public:
property bool IsFontUnderline {
    bool get ();
    void set (bool value);
}
member IsFontUnderline : bool with get, set

Property Value

Boolean
true if the font is Underline; otherwise false.
See Also

Reference

TableCellStyle Class


TableCellStyle.IsInactivePhaseload Property

TableCellStyleIsInactivePhaseload Property

Gets or sets whether this is an inactive phase load cell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsInactivePhaseload { get; set; }
Public Property IsInactivePhaseload As Boolean
    Get
    Set
public:
property bool IsInactivePhaseload {
    bool get ();
    void set (bool value);
}
member IsInactivePhaseload : bool with get, set

Property Value

Boolean
true if the font is an inactive phase load cell; otherwise false.
See Also

Reference

TableCellStyle Class


TableCellStyle.IsOverridden Property

TableCellStyleIsOverridden Property

Indicates if the cell is overridden or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsOverridden { get; }
Public ReadOnly Property IsOverridden As Boolean
    Get
public:
property bool IsOverridden {
    bool get ();
}
member IsOverridden : bool with get

Property Value

Boolean
See Also

Reference

TableCellStyle Class


TableCellStyle.IsReadOnly Property

TableCellStyleIsReadOnly Property

Gets or sets whether this cell is read only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsReadOnly { get; set; }
Public Property IsReadOnly As Boolean
    Get
    Set
public:
property bool IsReadOnly {
    bool get ();
    void set (bool value);
}
member IsReadOnly : bool with get, set

Property Value

Boolean
true if this cell is read only; otherwise false.
See Also

Reference

TableCellStyle Class


TableCellStyle.IsValidObject Property

TableCellStyleIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

TableCellStyle Class


TableCellStyle.SheetBackgroundColor Property

TableCellStyleSheetBackgroundColor Property

The background color of this cell in the sheet view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color SheetBackgroundColor { get; }
Public ReadOnly Property SheetBackgroundColor As Color
    Get
public:
property Color^ SheetBackgroundColor {
    Color^ get ();
}
member SheetBackgroundColor : Color with get

Property Value

Color
Remarks
In most cases the background color on the sheet view is the same as it is in the grid view. The background may be different if conditional formatting is applied only in the grid view.
See Also

Reference

TableCellStyle Class


TableCellStyle.TextColor Property

TableCellStyleTextColor Property

The text color of this cell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color TextColor { get; set; }
Public Property TextColor As Color
    Get
    Set
public:
property Color^ TextColor {
    Color^ get ();
    void set (Color^ value);
}
member TextColor : Color with get, set

Property Value

Color
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

TableCellStyle Class


TableCellStyle.TextOrientation Property

TableCellStyleTextOrientation Property

The orientation of the cell (for vertical/horizontal text) with input in degrees multiplied by 10

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int TextOrientation { get; set; }
Public Property TextOrientation As Integer
    Get
    Set
public:
property int TextOrientation {
    int get ();
    void set (int value);
}
member TextOrientation : int with get, set

Property Value

Int32
See Also

Reference

TableCellStyle Class


TableCellStyle.TextSize Property

TableCellStyleTextSize Property

The text size.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double TextSize { get; set; }
Public Property TextSize As Double
    Get
    Set
public:
property double TextSize {
    double get ();
    void set (double value);
}
member TextSize : float with get, set

Property Value

Double
See Also

Reference

TableCellStyle Class


TableCellStyle Methods

The TableCellStyle type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCellStyleOverrideOptions | Gets cell style override options of this cell.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ResetOverride | Resets any overrides applied to this cell.
 | SetCellStyleOverrideOptions | Sets cell style override options of this cell.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

TableCellStyle Class


TableCellStyle.Dispose Method

TableCellStyleDispose Method

Releases all resources used by the TableCellStyle

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

TableCellStyle Class


TableCellStyle.GetCellStyleOverrideOptions Method

TableCellStyleGetCellStyleOverrideOptions Method

Gets cell style override options of this cell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TableCellStyleOverrideOptions GetCellStyleOverrideOptions()
Public Function GetCellStyleOverrideOptions As TableCellStyleOverrideOptions
public:
TableCellStyleOverrideOptions^ GetCellStyleOverrideOptions()
member GetCellStyleOverrideOptions : unit -> TableCellStyleOverrideOptions

Return Value

TableCellStyleOverrideOptions
See Also

Reference

TableCellStyle Class


TableCellStyle.ResetOverride Method

TableCellStyleResetOverride Method

Resets any overrides applied to this cell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetOverride()
Public Sub ResetOverride
public:
void ResetOverride()
member ResetOverride : unit -> unit
See Also

Reference

TableCellStyle Class


TableCellStyle.SetCellStyleOverrideOptions Method

TableCellStyleSetCellStyleOverrideOptions Method

Sets cell style override options of this cell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetCellStyleOverrideOptions(
    TableCellStyleOverrideOptions helper
)
Public Sub SetCellStyleOverrideOptions (
    helper As TableCellStyleOverrideOptions
)
public:
void SetCellStyleOverrideOptions(
    TableCellStyleOverrideOptions^ helper
)
member SetCellStyleOverrideOptions :
        helper : TableCellStyleOverrideOptions -> unit

Parameters

helper TableCellStyleOverrideOptions
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Example
C#
VB
C++
F#
Copy
public static void ApplyFormattingToField(ViewSchedule schedule, int fieldIndex)
{
    // Get the field.
    ScheduleDefinition definition = schedule.Definition;
    ScheduleField field = definition.GetField(fieldIndex);

    // Build unit formatting for the field.
    FormatOptions options = field.GetFormatOptions();
    options.UseDefault = false;
    options.SetUnitTypeId(UnitTypeId.SquareInches);
    options.SetSymbolTypeId(SymbolTypeId.InSup2);

    // Build style overrides for the field
    // Use override options to indicate fields that are overridden and apply changes
    TableCellStyle style = field.GetStyle();
    TableCellStyleOverrideOptions overrideOptions = style.GetCellStyleOverrideOptions();
    overrideOptions.BackgroundColor = true;
    style.BackgroundColor = new Color(0x00, 0x00, 0xFF);
    overrideOptions.FontColor = true;
    style.TextColor = new Color(0xFF, 0xFF, 0xFF);
    overrideOptions.Italics = true;
    style.IsFontItalic = true;

    style.SetCellStyleOverrideOptions(overrideOptions);

    double width = field.GridColumnWidth;

    using (Transaction t = new Transaction(schedule.Document, "Set style etc"))
    {
        t.Start();
        field.SetStyle(style);
        field.SetFormatOptions(options);
        // Change column width (affects width in grid and on sheet) - units are in Revit length units - ft.
        field.GridColumnWidth = width + 0.5;
        t.Commit();
    }
}
Public Shared Sub ApplyFormattingToField(schedule As ViewSchedule, fieldIndex As Integer)
    ' Get the field.
    Dim definition As ScheduleDefinition = schedule.Definition
    Dim field As ScheduleField = definition.GetField(fieldIndex)

    ' Build unit formatting for the field.
    Dim options As FormatOptions = field.GetFormatOptions()
    options.UseDefault = False
    options.SetUnitTypeId(UnitTypeId.SquareInches)
    options.SetSymbolTypeId(SymbolTypeId.InSup2)

    ' Build style overrides for the field
    ' Use override options to indicate fields that are overridden and apply changes
    Dim style As TableCellStyle = field.GetStyle()
    Dim overrideOptions As TableCellStyleOverrideOptions = style.GetCellStyleOverrideOptions()
    overrideOptions.BackgroundColor = True
    style.BackgroundColor = New Color(&H0, &H0, &HFF)
    overrideOptions.FontColor = True
    style.TextColor = New Color(&HFF, &HFF, &HFF)
    overrideOptions.Italics = True
    style.IsFontItalic = True

    style.SetCellStyleOverrideOptions(overrideOptions)

    Dim width As Double = field.GridColumnWidth

    Using t As New Transaction(schedule.Document, "Set style etc")
        t.Start()
        field.SetStyle(style)
        field.SetFormatOptions(options)
        ' Change column width (affects width in grid and on sheet) - units are in Revit length units - ft.
        field.GridColumnWidth = width + 0.5
        t.Commit()
    End Using
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

TableCellStyle Class


TableCellStyleOverrideOptions Class

This helper class represents the overridden characteristics of the associated cell.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBTableCellStyleOverrideOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TableCellStyleOverrideOptions : IDisposable
Public Class TableCellStyleOverrideOptions
    Implements IDisposable
public ref class TableCellStyleOverrideOptions : IDisposable
type TableCellStyleOverrideOptions =
    class
        interface IDisposable
    end

The TableCellStyleOverrideOptions type exposes the following members.

Constructors
 | Name | Description
Public method | TableCellStyleOverrideOptions | Creates a new instance with no style characteristics overridden.
Public method | TableCellStyleOverrideOptions(TableCellStyleOverrideOptions) | Creates a new instance by copying an existing instance.
Top
Properties
 | Name | Description
Public property | BackgroundColor | Indicates if the background color characteristic is overridden.
Public property | Bold | Indicates if the bold characteristic is overridden.
Public property | BorderBottomLineStyle | Indicates if the border bottom line style characteristic is overridden.
Public property | BorderLeftLineStyle | Indicates if the border left line style characteristic is overridden.
Public property | BorderLineStyle | Indicates if the border line style characteristic is overridden.
Public property | BorderRightLineStyle | Indicates if the border right line style characteristic is overridden.
Public property | BorderTopLineStyle | Indicates if the border top line style characteristic is overridden.
Public property | Font | Indicates if the font name characteristic is overridden.
Public property | FontColor | Indicates if the font color characteristic is overridden.
Public property | FontSize | Indicates if the font size characteristic is overridden.
Public property | HorizontalAlignment | Indicates if the horizontal alignment characteristic is overridden.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Italics | Indicates if the italics characteristic is overridden.
Public property | TextOrientation | Indicates if the text orientation characteristic is overridden.
Public property | Underline | Indicates if the underline characteristic is overridden.
Public property | VerticalAlignment | Indicates if the vertical alignment characteristic is overridden.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the TableCellStyleOverrideOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetAllOverrides | Sets all overrides to a specific value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The user can override the text appearance and cell graphic properties by setting the corresponding flag to true. The global base format will control the non-overridden characteristics.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TableCellStyleOverrideOptions Constructor

Overload List
 | Name | Description
Public method | TableCellStyleOverrideOptions | Creates a new instance with no style characteristics overridden.
Public method | TableCellStyleOverrideOptions(TableCellStyleOverrideOptions) | Creates a new instance by copying an existing instance.
Top
See Also

Reference

TableCellStyleOverrideOptions Class


TableCellStyleOverrideOptions Constructor

Creates a new instance with no style characteristics overridden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TableCellStyleOverrideOptions()
Public Sub New
public:
TableCellStyleOverrideOptions()
new : unit -> TableCellStyleOverrideOptions
See Also

Reference

TableCellStyleOverrideOptions Class
TableCellStyleOverrideOptions Overload


TableCellStyleOverrideOptions(TableCellStyleOverrideOptions) Constructor

Creates a new instance by copying an existing instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TableCellStyleOverrideOptions(
    TableCellStyleOverrideOptions other
)
Public Sub New (
    other As TableCellStyleOverrideOptions
)
public:
TableCellStyleOverrideOptions(
    TableCellStyleOverrideOptions^ other
)
new :
        other : TableCellStyleOverrideOptions -> TableCellStyleOverrideOptions

Parameters

other TableCellStyleOverrideOptions
The instance to copy
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

TableCellStyleOverrideOptions Class
TableCellStyleOverrideOptions Overload


TableCellStyleOverrideOptions Properties

The TableCellStyleOverrideOptions type exposes the following members.

Properties
 | Name | Description
Public property | BackgroundColor | Indicates if the background color characteristic is overridden.
Public property | Bold | Indicates if the bold characteristic is overridden.
Public property | BorderBottomLineStyle | Indicates if the border bottom line style characteristic is overridden.
Public property | BorderLeftLineStyle | Indicates if the border left line style characteristic is overridden.
Public property | BorderLineStyle | Indicates if the border line style characteristic is overridden.
Public property | BorderRightLineStyle | Indicates if the border right line style characteristic is overridden.
Public property | BorderTopLineStyle | Indicates if the border top line style characteristic is overridden.
Public property | Font | Indicates if the font name characteristic is overridden.
Public property | FontColor | Indicates if the font color characteristic is overridden.
Public property | FontSize | Indicates if the font size characteristic is overridden.
Public property | HorizontalAlignment | Indicates if the horizontal alignment characteristic is overridden.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Italics | Indicates if the italics characteristic is overridden.
Public property | TextOrientation | Indicates if the text orientation characteristic is overridden.
Public property | Underline | Indicates if the underline characteristic is overridden.
Public property | VerticalAlignment | Indicates if the vertical alignment characteristic is overridden.
Top
See Also

Reference

TableCellStyleOverrideOptions Class


TableCellStyleOverrideOptions.BackgroundColor Property

TableCellStyleOverrideOptionsBackgroundColor Property

Indicates if the background color characteristic is overridden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool BackgroundColor { get; set; }
Public Property BackgroundColor As Boolean
    Get
    Set
public:
property bool BackgroundColor {
    bool get ();
    void set (bool value);
}
member BackgroundColor : bool with get, set

Property Value

Boolean
See Also

Reference

TableCellStyleOverrideOptions Class


TableCellStyleOverrideOptions.Bold Property

TableCellStyleOverrideOptionsBold Property

Indicates if the bold characteristic is overridden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Bold { get; set; }
Public Property Bold As Boolean
    Get
    Set
public:
property bool Bold {
    bool get ();
    void set (bool value);
}
member Bold : bool with get, set

Property Value

Boolean
See Also

Reference

TableCellStyleOverrideOptions Class


TableCellStyleOverrideOptions.BorderBottomLineStyle Property

TableCellStyleOverrideOptionsBorderBottomLineStyle Property

Indicates if the border bottom line style characteristic is overridden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool BorderBottomLineStyle { get; set; }
Public Property BorderBottomLineStyle As Boolean
    Get
    Set
public:
property bool BorderBottomLineStyle {
    bool get ();
    void set (bool value);
}
member BorderBottomLineStyle : bool with get, set

Property Value

Boolean
See Also

Reference

TableCellStyleOverrideOptions Class


TableCellStyleOverrideOptions.BorderLeftLineStyle Property

TableCellStyleOverrideOptionsBorderLeftLineStyle Property

Indicates if the border left line style characteristic is overridden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool BorderLeftLineStyle { get; set; }
Public Property BorderLeftLineStyle As Boolean
    Get
    Set
public:
property bool BorderLeftLineStyle {
    bool get ();
    void set (bool value);
}
member BorderLeftLineStyle : bool with get, set

Property Value

Boolean
See Also

Reference

TableCellStyleOverrideOptions Class


TableCellStyleOverrideOptions.BorderLineStyle Property

TableCellStyleOverrideOptionsBorderLineStyle Property

Indicates if the border line style characteristic is overridden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool BorderLineStyle { get; set; }
Public Property BorderLineStyle As Boolean
    Get
    Set
public:
property bool BorderLineStyle {
    bool get ();
    void set (bool value);
}
member BorderLineStyle : bool with get, set

Property Value

Boolean
See Also

Reference

TableCellStyleOverrideOptions Class


TableCellStyleOverrideOptions.BorderRightLineStyle Property

TableCellStyleOverrideOptionsBorderRightLineStyle Property

Indicates if the border right line style characteristic is overridden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool BorderRightLineStyle { get; set; }
Public Property BorderRightLineStyle As Boolean
    Get
    Set
public:
property bool BorderRightLineStyle {
    bool get ();
    void set (bool value);
}
member BorderRightLineStyle : bool with get, set

Property Value

Boolean
See Also

Reference

TableCellStyleOverrideOptions Class


TableCellStyleOverrideOptions.BorderTopLineStyle Property

TableCellStyleOverrideOptionsBorderTopLineStyle Property

Indicates if the border top line style characteristic is overridden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool BorderTopLineStyle { get; set; }
Public Property BorderTopLineStyle As Boolean
    Get
    Set
public:
property bool BorderTopLineStyle {
    bool get ();
    void set (bool value);
}
member BorderTopLineStyle : bool with get, set

Property Value

Boolean
See Also

Reference

TableCellStyleOverrideOptions Class


TableCellStyleOverrideOptions.Font Property

TableCellStyleOverrideOptionsFont Property

Indicates if the font name characteristic is overridden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Font { get; set; }
Public Property Font As Boolean
    Get
    Set
public:
property bool Font {
    bool get ();
    void set (bool value);
}
member Font : bool with get, set

Property Value

Boolean
See Also

Reference

TableCellStyleOverrideOptions Class


TableCellStyleOverrideOptions.FontColor Property

TableCellStyleOverrideOptionsFontColor Property

Indicates if the font color characteristic is overridden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool FontColor { get; set; }
Public Property FontColor As Boolean
    Get
    Set
public:
property bool FontColor {
    bool get ();
    void set (bool value);
}
member FontColor : bool with get, set

Property Value

Boolean
See Also

Reference

TableCellStyleOverrideOptions Class


TableCellStyleOverrideOptions.FontSize Property

TableCellStyleOverrideOptionsFontSize Property

Indicates if the font size characteristic is overridden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool FontSize { get; set; }
Public Property FontSize As Boolean
    Get
    Set
public:
property bool FontSize {
    bool get ();
    void set (bool value);
}
member FontSize : bool with get, set

Property Value

Boolean
See Also

Reference

TableCellStyleOverrideOptions Class


TableCellStyleOverrideOptions.HorizontalAlignment Property

TableCellStyleOverrideOptionsHorizontalAlignment Property

Indicates if the horizontal alignment characteristic is overridden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HorizontalAlignment { get; set; }
Public Property HorizontalAlignment As Boolean
    Get
    Set
public:
property bool HorizontalAlignment {
    bool get ();
    void set (bool value);
}
member HorizontalAlignment : bool with get, set

Property Value

Boolean
See Also

Reference

TableCellStyleOverrideOptions Class


TableCellStyleOverrideOptions.IsValidObject Property

TableCellStyleOverrideOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

TableCellStyleOverrideOptions Class


TableCellStyleOverrideOptions.Italics Property

TableCellStyleOverrideOptionsItalics Property

Indicates if the italics characteristic is overridden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Italics { get; set; }
Public Property Italics As Boolean
    Get
    Set
public:
property bool Italics {
    bool get ();
    void set (bool value);
}
member Italics : bool with get, set

Property Value

Boolean
See Also

Reference

TableCellStyleOverrideOptions Class


TableCellStyleOverrideOptions.TextOrientation Property

TableCellStyleOverrideOptionsTextOrientation Property

Indicates if the text orientation characteristic is overridden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool TextOrientation { get; set; }
Public Property TextOrientation As Boolean
    Get
    Set
public:
property bool TextOrientation {
    bool get ();
    void set (bool value);
}
member TextOrientation : bool with get, set

Property Value

Boolean
See Also

Reference

TableCellStyleOverrideOptions Class


TableCellStyleOverrideOptions.Underline Property

TableCellStyleOverrideOptionsUnderline Property

Indicates if the underline characteristic is overridden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Underline { get; set; }
Public Property Underline As Boolean
    Get
    Set
public:
property bool Underline {
    bool get ();
    void set (bool value);
}
member Underline : bool with get, set

Property Value

Boolean
See Also

Reference

TableCellStyleOverrideOptions Class


TableCellStyleOverrideOptions.VerticalAlignment Property

TableCellStyleOverrideOptionsVerticalAlignment Property

Indicates if the vertical alignment characteristic is overridden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool VerticalAlignment { get; set; }
Public Property VerticalAlignment As Boolean
    Get
    Set
public:
property bool VerticalAlignment {
    bool get ();
    void set (bool value);
}
member VerticalAlignment : bool with get, set

Property Value

Boolean
See Also

Reference

TableCellStyleOverrideOptions Class


TableCellStyleOverrideOptions Methods

The TableCellStyleOverrideOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetAllOverrides | Sets all overrides to a specific value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

TableCellStyleOverrideOptions Class


TableCellStyleOverrideOptions.Dispose Method

TableCellStyleOverrideOptionsDispose Method

Releases all resources used by the TableCellStyleOverrideOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

TableCellStyleOverrideOptions Class


TableCellStyleOverrideOptions.SetAllOverrides Method

TableCellStyleOverrideOptionsSetAllOverrides Method

Sets all overrides to a specific value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetAllOverrides(
    bool bOverride
)
Public Sub SetAllOverrides (
    bOverride As Boolean
)
public:
void SetAllOverrides(
    bool bOverride
)
member SetAllOverrides :
        bOverride : bool -> unit

Parameters

bOverride Boolean
The value that will be assigned to all the overrides.
See Also

Reference

TableCellStyleOverrideOptions Class


TableData Class

The TableData class is implemented to hold most of the data that describe the style of the rows, columns, and cells in a table.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBTableData
Autodesk.Revit.DB.ElectricalPanelScheduleData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TableData : IDisposable
Public Class TableData
    Implements IDisposable
public ref class TableData : IDisposable
type TableData =
    class
        interface IDisposable
    end

The TableData type exposes the following members.

Properties
 | Name | Description
Public property | FreezeColumnsAndRows | set to true if the columns and rows should be unmovable by the slider grips
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NumberOfSections | Gets the number of items in section data array.
Public property | Width | Gets or sets the table width in feet
Public property | WidthInPixels | Gets the width of the panel schedule in logical pixels
Public property | ZoomLevel | The value of zoom level for corresponding TableView.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the TableData
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetSectionData(Int32) | Returns the section data array element at the specified index.
Public method | GetSectionData(SectionType) | Returns the pointer to the section data array element at the specified section type.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqual | Checks if this element is equal in value to the other element.
Public method | IsValidZoomLevel | Verifies if the value of zoom level is valid.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TableData Properties

The TableData type exposes the following members.

Properties
 | Name | Description
Public property | FreezeColumnsAndRows | set to true if the columns and rows should be unmovable by the slider grips
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NumberOfSections | Gets the number of items in section data array.
Public property | Width | Gets or sets the table width in feet
Public property | WidthInPixels | Gets the width of the panel schedule in logical pixels
Public property | ZoomLevel | The value of zoom level for corresponding TableView.
Top
See Also

Reference

TableData Class


TableData.FreezeColumnsAndRows Property

TableDataFreezeColumnsAndRows Property

set to true if the columns and rows should be unmovable by the slider grips

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool FreezeColumnsAndRows { get; set; }
Public Property FreezeColumnsAndRows As Boolean
    Get
    Set
public:
property bool FreezeColumnsAndRows {
    bool get ();
    void set (bool value);
}
member FreezeColumnsAndRows : bool with get, set

Property Value

Boolean
See Also

Reference

TableData Class


TableData.IsValidObject Property

TableDataIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

TableData Class


TableData.NumberOfSections Property

TableDataNumberOfSections Property

Gets the number of items in section data array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int NumberOfSections { get; }
Public ReadOnly Property NumberOfSections As Integer
    Get
public:
property int NumberOfSections {
    int get ();
}
member NumberOfSections : int with get

Property Value

Int32
See Also

Reference

TableData Class


TableData.Width Property

TableDataWidth Property

Gets or sets the table width in feet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Width { get; set; }
Public Property Width As Double
    Get
    Set
public:
property double Width {
    double get ();
    void set (double value);
}
member Width : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentException | When setting this property: The table width is outside of the acceptable range.
See Also

Reference

TableData Class


TableData.WidthInPixels Property

TableDataWidthInPixels Property

Gets the width of the panel schedule in logical pixels

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int WidthInPixels { get; }
Public ReadOnly Property WidthInPixels As Integer
    Get
public:
property int WidthInPixels {
    int get ();
}
member WidthInPixels : int with get

Property Value

Int32
See Also

Reference

TableData Class


TableData.ZoomLevel Property

TableDataZoomLevel Property

The value of zoom level for corresponding TableView.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ZoomLevel { get; set; }
Public Property ZoomLevel As Integer
    Get
    Set
public:
property int ZoomLevel {
    int get ();
    void set (int value);
}
member ZoomLevel : int with get, set

Property Value

Int32
Exceptions
Exception | Condition
ArgumentException | When setting this property: The value of zoom level must be a multiple of 10 in the range of 10 to 400.
Remarks

This value is used to change the size of text fonts in tabular views, and then the size of rows, colums and cells will also be changed to satisfy the text.

Note: This value is only used to improve the text readability in tabular view and will not change the size of texts, rows, columns and cells in sheet views.

Note: This value is temporary setting just for this session.

Note: This value is a percentage number which must be a multiple of 10 in the range of 10 to 400. A value of 400 indicates the maximum zoom permitted. The default value for new created tabular views is 100.

See Also

Reference

TableData Class


TableData Methods

The TableData type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetSectionData(Int32) | Returns the section data array element at the specified index.
Public method | GetSectionData(SectionType) | Returns the pointer to the section data array element at the specified section type.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqual | Checks if this element is equal in value to the other element.
Public method | IsValidZoomLevel | Verifies if the value of zoom level is valid.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

TableData Class


TableData.Dispose Method

TableDataDispose Method

Releases all resources used by the TableData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

TableData Class


TableData.GetSectionData Method

TableDataGetSectionData Method

Overload List
 | Name | Description
Public method | GetSectionData(Int32) | Returns the section data array element at the specified index.
Public method | GetSectionData(SectionType) | Returns the pointer to the section data array element at the specified section type.
Top
See Also

Reference

TableData Class


TableData.GetSectionData(Int32) Method

TableDataGetSectionData(Int32) Method

Returns the section data array element at the specified index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TableSectionData GetSectionData(
    int nIndex
)
Public Function GetSectionData (
    nIndex As Integer
) As TableSectionData
public:
TableSectionData^ GetSectionData(
    int nIndex
)
member GetSectionData :
        nIndex : int -> TableSectionData

Parameters

nIndex Int32
The index of section data array. If the index is out of the boundary of section data array, is returned.

Return Value

TableSectionData
See Also

Reference

TableData Class
GetSectionData Overload


TableData.GetSectionData(SectionType) Method

TableDataGetSectionData(SectionType) Method

Returns the pointer to the section data array element at the specified section type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TableSectionData GetSectionData(
    SectionType sectionType
)
Public Function GetSectionData (
    sectionType As SectionType
) As TableSectionData
public:
TableSectionData^ GetSectionData(
    SectionType sectionType
)
member GetSectionData :
        sectionType : SectionType -> TableSectionData

Parameters

sectionType SectionType
The section type of section data array. If the integral value of the section type is out of the boundary of section data array, null is returned.

Return Value

TableSectionData
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

TableData Class
GetSectionData Overload


TableData.IsEqual Method

TableDataIsEqual Method

Checks if this element is equal in value to the other element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEqual(
    TableData OtherElem
)
Public Function IsEqual (
    OtherElem As TableData
) As Boolean
public:
bool IsEqual(
    TableData^ OtherElem
)
member IsEqual :
        OtherElem : TableData -> bool

Parameters

OtherElem TableData

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

TableData Class


TableData.IsValidZoomLevel Method

TableDataIsValidZoomLevel Method

Verifies if the value of zoom level is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidZoomLevel(
    int zoomLevel
)
Public Function IsValidZoomLevel (
    zoomLevel As Integer
) As Boolean
public:
bool IsValidZoomLevel(
    int zoomLevel
)
member IsValidZoomLevel :
        zoomLevel : int -> bool

Parameters

zoomLevel Int32
The value of zoom level.

Return Value

Boolean
True if the value of zoom level is inside of the acceptable range, false otherwise.
See Also

Reference

TableData Class


TableMergedCell Class

The TableMergedCell class defines a merged area of the upper-left and lower-right of a table grid.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBTableMergedCell

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TableMergedCell : IDisposable
Public Class TableMergedCell
    Implements IDisposable
public ref class TableMergedCell : IDisposable
type TableMergedCell =
    class
        interface IDisposable
    end

The TableMergedCell type exposes the following members.

Constructors
 | Name | Description
Public method | TableMergedCell | Default constructor.
Public method | TableMergedCell(Int32, Int32, Int32, Int32) | Constructor.
Top
Properties
 | Name | Description
Public property | Bottom | Specifies the row index of the bottom-right corner of a table grid.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Left | Specifies the column index of the top-left corner of a table grid.
Public property | Right | Specifies the column index of the bottom-right corner of a table grid.
Public property | Top | Specifies the row index of the top-left corner of a table grid.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the TableMergedCell
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
A TableMergedCell contains member variables that define the top-left and bottom-right row and column indexes of a table grid. A TableMergedCell object can be passed as a function parameter wherever a TableMergedCell can be passed.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TableMergedCell Constructor

Overload List
 | Name | Description
Public method | TableMergedCell | Default constructor.
Public method | TableMergedCell(Int32, Int32, Int32, Int32) | Constructor.
Top
See Also

Reference

TableMergedCell Class


TableMergedCell Constructor

Default constructor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TableMergedCell()
Public Sub New
public:
TableMergedCell()
new : unit -> TableMergedCell
See Also

Reference

TableMergedCell Class
TableMergedCell Overload


TableMergedCell(Int32, Int32, Int32, Int32) Constructor

Constructor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TableMergedCell(
    int top,
    int left,
    int bottom,
    int right
)
Public Sub New (
    top As Integer,
    left As Integer,
    bottom As Integer,
    right As Integer
)
public:
TableMergedCell(
    int top,
    int left,
    int bottom,
    int right
)
new :
        top : int *
        left : int *
        bottom : int *
        right : int -> TableMergedCell

Parameters

top Int32
Row index of the top-left of a table grid.
left Int32
Column index of the top-left of a table grid.
bottom Int32
Row index of the bottom-right of a table grid.
right Int32
Column index of the bottom-right of a table grid.
See Also

Reference

TableMergedCell Class
TableMergedCell Overload


TableMergedCell Properties

The TableMergedCell type exposes the following members.

Properties
 | Name | Description
Public property | Bottom | Specifies the row index of the bottom-right corner of a table grid.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Left | Specifies the column index of the top-left corner of a table grid.
Public property | Right | Specifies the column index of the bottom-right corner of a table grid.
Public property | Top | Specifies the row index of the top-left corner of a table grid.
Top
See Also

Reference

TableMergedCell Class


TableMergedCell.Bottom Property

TableMergedCellBottom Property

Specifies the row index of the bottom-right corner of a table grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Bottom { get; set; }
Public Property Bottom As Integer
    Get
    Set
public:
property int Bottom {
    int get ();
    void set (int value);
}
member Bottom : int with get, set

Property Value

Int32
See Also

Reference

TableMergedCell Class


TableMergedCell.IsValidObject Property

TableMergedCellIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

TableMergedCell Class


TableMergedCell.Left Property

TableMergedCellLeft Property

Specifies the column index of the top-left corner of a table grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Left { get; set; }
Public Property Left As Integer
    Get
    Set
public:
property int Left {
    int get ();
    void set (int value);
}
member Left : int with get, set

Property Value

Int32
See Also

Reference

TableMergedCell Class


TableMergedCell.Right Property

TableMergedCellRight Property

Specifies the column index of the bottom-right corner of a table grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Right { get; set; }
Public Property Right As Integer
    Get
    Set
public:
property int Right {
    int get ();
    void set (int value);
}
member Right : int with get, set

Property Value

Int32
See Also

Reference

TableMergedCell Class


TableMergedCell.Top Property

TableMergedCellTop Property

Specifies the row index of the top-left corner of a table grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Top { get; set; }
Public Property Top As Integer
    Get
    Set
public:
property int Top {
    int get ();
    void set (int value);
}
member Top : int with get, set

Property Value

Int32
See Also

Reference

TableMergedCell Class


TableMergedCell Methods

The TableMergedCell type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

TableMergedCell Class


TableMergedCell.Dispose Method

TableMergedCellDispose Method

Releases all resources used by the TableMergedCell

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

TableMergedCell Class


TableSectionData Class

The TableSectionData class represents a serialized version of an instance of section table data. The class holds row, column and cell data.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBTableSectionData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TableSectionData : IDisposable
Public Class TableSectionData
    Implements IDisposable
public ref class TableSectionData : IDisposable
type TableSectionData =
    class
        interface IDisposable
    end

The TableSectionData type exposes the following members.

Properties
 | Name | Description
Public property | FirstColumnNumber | The first column in this section of the table.
Public property | FirstRowNumber | The first row in this section of the table.
Public property | HideSection | Whether or not the section is hidden.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LastColumnNumber | The last column in this section of the table.
Public property | LastRowNumber | The last row in this section of the table.
Public property | NeedsRefresh | Indicates if the table data need to refresh.
Public property | NumberOfColumns | Gets or sets the number of items in column data array.
Public property | NumberOfRows | Gets or sets the number of items in row data array.
Top
Methods
 | Name | Description
Public method | AllowOverrideCellStyle | Identifies if the style can be overridden in the given cell.
Public method | CanInsertColumn | Verifies if a new column can be inserted at the given index.
Public method | CanInsertRow | Verifies if a new row can be inserted at the given index.
Public method | CanRemoveColumn | Verifies that if the column at the given index can be removed.
Public method | CanRemoveRow | Verifies that if the row at the given index can be removed..
Public method | ClearCell | Deletes text or image, or removes parameter of this cell.
Public method | Dispose | Releases all resources used by the TableSectionData
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCellCalculatedValue(Int32) | Gets the calculated value for the specified column
Public method | GetCellCalculatedValue(Int32, Int32) | Gets the calculated value for the specified cell
Public method | GetCellCategoryId(Int32) | Returns a column's ParamId Associated with the paramId to find the correct element
Public method | GetCellCategoryId(Int32, Int32) | Returns a cell's CategoryId and if no CategoryId exists for this cell, it would come from the column. Associated with the paramId to find the correct element.
Public method | GetCellCombinedParameters(Int32) | Returns an array of combined parameter data for the specified column
Public method | GetCellCombinedParameters(Int32, Int32) | Returns an array of combined parameter data for the specified cell
Public method | GetCellFormatOptions(Int32, Document) | Returns a column's cell FormatOptions and if no FormatOptions exists for this column, it would come from the section.
Public method | GetCellFormatOptions(Int32, Int32, Document) | Returns a cell's FormatOptions and if no FormatOptions exists for this cell, it would come from the column, or the row, or the section.
Public method | GetCellParamId(Int32) | Returns a column's ParamId
Public method | GetCellParamId(Int32, Int32) | Returns a cell's ParamId and if no ParamId exists for this cell, it would come from the column
Public method | GetCellSpec | Gets the spec describing values of a cell, if applicable.
Public method | GetCellText | Returns the text shown by this cell, if the cell's type is CellType.Text or CellType.ParameterText or CellType.CustomField.
Public method | GetCellType(Int32) | Returns a column's cell type and if no type exists for this column, it would come from the section
Public method | GetCellType(Int32, Int32) | Returns a cell's Type and if no Type exists for this cell, it would come from the column, or the row, or the section
Public method | GetColumnWidth | Returns a column's width in feet
Public method | GetColumnWidthInPixels | This returns a column's width in logical pixels
Public method | GetCustomFieldId | Gets custom field id from the cell.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMergedCell | Gets the whole merged cell that this cell is a part of.
Public method | GetRowHeight | Returns a row's height in feet
Public method | GetRowHeightInPixels | This returns a row's height in logical pixels
Public method | GetTableCellStyle | Returns a cell's style and if no style exists for this cell, it would come from the column, or the section
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | InsertColumn | Inserts a new column at the specified index relative to the current set of columns.
Public method | InsertImage | Inserts a image in the given cell.
 | InsertRow | Inserts a row data at a specified index.
Public method | IsAcceptableParamIdAndCategoryId(ElementId, ElementId) | Identifies if the given parameter id and category id can be assigned to a cell in this table.
Public method | IsAcceptableParamIdAndCategoryId(Int32, ElementId, ElementId) | Identifies if the given parameter id and category id can be assigned to a cell in the given row in this table.
Public method | IsCellFormattable | Determines whether the cell is formattable or not
Public method | IsCellOverridden(Int32) | Indicates if the column is overridden or not.
Public method | IsCellOverridden(Int32, Int32) | Indicates if the cell is overridden or not.
Public method | IsDataOutOfDate | Indicates whether the data in this section is out of date.
Public method | IsValidColumnNumber | Verifies if the column number is valid.
Public method | IsValidImageSymbolId | Identifies if the element id represents a valid ImageSymbol element.
Public method | IsValidRowNumber | Verifies if the row number is valid.
Public method | MergeCells | Merges cells for the given area.
Public method | RefreshData | Rebuilds the data in this section if it is out of date.
Public method | RemoveColumn | Removes a column data at a specified index.
Public method | RemoveRow | Removes a row data at a specified index.
Public method | ResetCellOverride(Int32) | Resets the override of the column.
Public method | ResetCellOverride(Int32, Int32) | Resets the override of the cell.
Public method | SetCellCalculatedValue(Int32, TableCellCalculatedValueData) | Allows the caller to set the calculated value for a specified column
Public method | SetCellCalculatedValue(Int32, Int32, TableCellCalculatedValueData) | Allows the caller to set the calculated value for a specified cell
Public method | SetCellCombinedParameters(Int32, IListTableCellCombinedParameterData) | Allows the caller to set combined parameter for a specified column
Public method | SetCellCombinedParameters(Int32, Int32, IListTableCellCombinedParameterData) | Allows the caller to set combined parameter for a specified cell
Public method | SetCellFormatOptions | Sets a cell's FormatOptions.
Public method | SetCellParamIdAndCategoryId(Int32, ElementId, ElementId) | Sets a column's category and parameter Id
Public method | SetCellParamIdAndCategoryId(Int32, Int32, ElementId, ElementId) | Sets a cell's category and parameter Id
Public method | SetCellStyle(TableCellStyle) | Sets a section's style
Public method | SetCellStyle(Int32, TableCellStyle) | Sets a column's style.
 | SetCellStyle(Int32, Int32, TableCellStyle) | Sets a cell's style
Public method | SetCellText | Sets a cell's to display the specified text.
Public method | SetCellType(Int32, CellType) | Sets a column's cell type
Public method | SetCellType(Int32, Int32, CellType) | Sets a cell's Type
Public method | SetColumnWidth | Sets a column's width in feet
Public method | SetColumnWidthInPixels | This sets a column's width in logical pixels
Public method | SetMergedCell | Sets the merged cell that this cell is a part of.
Public method | SetRowHeight | Sets a row's height in feet
Public method | SetRowHeightInPixels | This sets a row's height in logical pixels
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TableSectionData Properties

The TableSectionData type exposes the following members.

Properties
 | Name | Description
Public property | FirstColumnNumber | The first column in this section of the table.
Public property | FirstRowNumber | The first row in this section of the table.
Public property | HideSection | Whether or not the section is hidden.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LastColumnNumber | The last column in this section of the table.
Public property | LastRowNumber | The last row in this section of the table.
Public property | NeedsRefresh | Indicates if the table data need to refresh.
Public property | NumberOfColumns | Gets or sets the number of items in column data array.
Public property | NumberOfRows | Gets or sets the number of items in row data array.
Top
See Also

Reference

TableSectionData Class


TableSectionData.FirstColumnNumber Property

TableSectionDataFirstColumnNumber Property

The first column in this section of the table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int FirstColumnNumber { get; }
Public ReadOnly Property FirstColumnNumber As Integer
    Get
public:
property int FirstColumnNumber {
    int get ();
}
member FirstColumnNumber : int with get

Property Value

Int32
Remarks
Some table sections have column 0 as their first column while others start with column 1.
See Also

Reference

TableSectionData Class


TableSectionData.FirstRowNumber Property

TableSectionDataFirstRowNumber Property

The first row in this section of the table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int FirstRowNumber { get; }
Public ReadOnly Property FirstRowNumber As Integer
    Get
public:
property int FirstRowNumber {
    int get ();
}
member FirstRowNumber : int with get

Property Value

Int32
Remarks
Some table sections have row 0 as their first row while others start with row 1.
See Also

Reference

TableSectionData Class


TableSectionData.HideSection Property

TableSectionDataHideSection Property

Whether or not the section is hidden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HideSection { get; set; }
Public Property HideSection As Boolean
    Get
    Set
public:
property bool HideSection {
    bool get ();
    void set (bool value);
}
member HideSection : bool with get, set

Property Value

Boolean
Exceptions
Exception | Condition
InvalidOperationException | When setting this property: This operation is forbidden for cells in standard schedule body sections.
See Also

Reference

TableSectionData Class


TableSectionData.IsValidObject Property

TableSectionDataIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

TableSectionData Class


TableSectionData.LastColumnNumber Property

TableSectionDataLastColumnNumber Property

The last column in this section of the table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int LastColumnNumber { get; }
Public ReadOnly Property LastColumnNumber As Integer
    Get
public:
property int LastColumnNumber {
    int get ();
}
member LastColumnNumber : int with get

Property Value

Int32
See Also

Reference

TableSectionData Class


TableSectionData.LastRowNumber Property

TableSectionDataLastRowNumber Property

The last row in this section of the table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int LastRowNumber { get; }
Public ReadOnly Property LastRowNumber As Integer
    Get
public:
property int LastRowNumber {
    int get ();
}
member LastRowNumber : int with get

Property Value

Int32
See Also

Reference

TableSectionData Class


TableSectionData.NeedsRefresh Property

TableSectionDataNeedsRefresh Property

Indicates if the table data need to refresh.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool NeedsRefresh { get; set; }
Public Property NeedsRefresh As Boolean
    Get
    Set
public:
property bool NeedsRefresh {
    bool get ();
    void set (bool value);
}
member NeedsRefresh : bool with get, set

Property Value

Boolean
Exceptions
Exception | Condition
InvalidOperationException | When setting this property: This operation is forbidden for cells in standard schedule body sections.
See Also

Reference

TableSectionData Class


TableSectionData.NumberOfColumns Property

TableSectionDataNumberOfColumns Property

Gets or sets the number of items in column data array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int NumberOfColumns { get; set; }
Public Property NumberOfColumns As Integer
    Get
    Set
public:
property int NumberOfColumns {
    int get ();
    void set (int value);
}
member NumberOfColumns : int with get, set

Property Value

Int32
Exceptions
Exception | Condition
InvalidOperationException | When setting this property: This operation is forbidden for cells in standard schedule body sections.
Remarks
Note that TableSections may use either 0 or 1 as the first row and column indices. To access the rows and columns:
  • Use FirstRowNumber and LastRowNumber to get the valid range of row indices.
  • Use FirstColumnNumber and LastColumnNumber to get the valid range of column indices.
See Also

Reference

TableSectionData Class


TableSectionData.NumberOfRows Property

TableSectionDataNumberOfRows Property

Gets or sets the number of items in row data array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int NumberOfRows { get; set; }
Public Property NumberOfRows As Integer
    Get
    Set
public:
property int NumberOfRows {
    int get ();
    void set (int value);
}
member NumberOfRows : int with get, set

Property Value

Int32
Exceptions
Exception | Condition
InvalidOperationException | When setting this property: This operation is forbidden for cells in standard schedule body sections.
Remarks
Note that TableSections may use either 0 or 1 as the first row and column indices. To access the rows and columns:
  • Use FirstRowNumber and LastRowNumber to get the valid range of row indices.
  • Use FirstColumnNumber and LastColumnNumber to get the valid range of column indices.
See Also

Reference

TableSectionData Class


TableSectionData Methods

The TableSectionData type exposes the following members.

Methods
 | Name | Description
Public method | AllowOverrideCellStyle | Identifies if the style can be overridden in the given cell.
Public method | CanInsertColumn | Verifies if a new column can be inserted at the given index.
Public method | CanInsertRow | Verifies if a new row can be inserted at the given index.
Public method | CanRemoveColumn | Verifies that if the column at the given index can be removed.
Public method | CanRemoveRow | Verifies that if the row at the given index can be removed..
Public method | ClearCell | Deletes text or image, or removes parameter of this cell.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCellCalculatedValue(Int32) | Gets the calculated value for the specified column
Public method | GetCellCalculatedValue(Int32, Int32) | Gets the calculated value for the specified cell
Public method | GetCellCategoryId(Int32) | Returns a column's ParamId Associated with the paramId to find the correct element
Public method | GetCellCategoryId(Int32, Int32) | Returns a cell's CategoryId and if no CategoryId exists for this cell, it would come from the column. Associated with the paramId to find the correct element.
Public method | GetCellCombinedParameters(Int32) | Returns an array of combined parameter data for the specified column
Public method | GetCellCombinedParameters(Int32, Int32) | Returns an array of combined parameter data for the specified cell
Public method | GetCellFormatOptions(Int32, Document) | Returns a column's cell FormatOptions and if no FormatOptions exists for this column, it would come from the section.
Public method | GetCellFormatOptions(Int32, Int32, Document) | Returns a cell's FormatOptions and if no FormatOptions exists for this cell, it would come from the column, or the row, or the section.
Public method | GetCellParamId(Int32) | Returns a column's ParamId
Public method | GetCellParamId(Int32, Int32) | Returns a cell's ParamId and if no ParamId exists for this cell, it would come from the column
Public method | GetCellSpec | Gets the spec describing values of a cell, if applicable.
Public method | GetCellText | Returns the text shown by this cell, if the cell's type is CellType.Text or CellType.ParameterText or CellType.CustomField.
Public method | GetCellType(Int32) | Returns a column's cell type and if no type exists for this column, it would come from the section
Public method | GetCellType(Int32, Int32) | Returns a cell's Type and if no Type exists for this cell, it would come from the column, or the row, or the section
Public method | GetColumnWidth | Returns a column's width in feet
Public method | GetColumnWidthInPixels | This returns a column's width in logical pixels
Public method | GetCustomFieldId | Gets custom field id from the cell.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMergedCell | Gets the whole merged cell that this cell is a part of.
Public method | GetRowHeight | Returns a row's height in feet
Public method | GetRowHeightInPixels | This returns a row's height in logical pixels
Public method | GetTableCellStyle | Returns a cell's style and if no style exists for this cell, it would come from the column, or the section
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | InsertColumn | Inserts a new column at the specified index relative to the current set of columns.
Public method | InsertImage | Inserts a image in the given cell.
 | InsertRow | Inserts a row data at a specified index.
Public method | IsAcceptableParamIdAndCategoryId(ElementId, ElementId) | Identifies if the given parameter id and category id can be assigned to a cell in this table.
Public method | IsAcceptableParamIdAndCategoryId(Int32, ElementId, ElementId) | Identifies if the given parameter id and category id can be assigned to a cell in the given row in this table.
Public method | IsCellFormattable | Determines whether the cell is formattable or not
Public method | IsCellOverridden(Int32) | Indicates if the column is overridden or not.
Public method | IsCellOverridden(Int32, Int32) | Indicates if the cell is overridden or not.
Public method | IsDataOutOfDate | Indicates whether the data in this section is out of date.
Public method | IsValidColumnNumber | Verifies if the column number is valid.
Public method | IsValidImageSymbolId | Identifies if the element id represents a valid ImageSymbol element.
Public method | IsValidRowNumber | Verifies if the row number is valid.
Public method | MergeCells | Merges cells for the given area.
Public method | RefreshData | Rebuilds the data in this section if it is out of date.
Public method | RemoveColumn | Removes a column data at a specified index.
Public method | RemoveRow | Removes a row data at a specified index.
Public method | ResetCellOverride(Int32) | Resets the override of the column.
Public method | ResetCellOverride(Int32, Int32) | Resets the override of the cell.
Public method | SetCellCalculatedValue(Int32, TableCellCalculatedValueData) | Allows the caller to set the calculated value for a specified column
Public method | SetCellCalculatedValue(Int32, Int32, TableCellCalculatedValueData) | Allows the caller to set the calculated value for a specified cell
Public method | SetCellCombinedParameters(Int32, IListTableCellCombinedParameterData) | Allows the caller to set combined parameter for a specified column
Public method | SetCellCombinedParameters(Int32, Int32, IListTableCellCombinedParameterData) | Allows the caller to set combined parameter for a specified cell
Public method | SetCellFormatOptions | Sets a cell's FormatOptions.
Public method | SetCellParamIdAndCategoryId(Int32, ElementId, ElementId) | Sets a column's category and parameter Id
Public method | SetCellParamIdAndCategoryId(Int32, Int32, ElementId, ElementId) | Sets a cell's category and parameter Id
Public method | SetCellStyle(TableCellStyle) | Sets a section's style
Public method | SetCellStyle(Int32, TableCellStyle) | Sets a column's style.
 | SetCellStyle(Int32, Int32, TableCellStyle) | Sets a cell's style
Public method | SetCellText | Sets a cell's to display the specified text.
Public method | SetCellType(Int32, CellType) | Sets a column's cell type
Public method | SetCellType(Int32, Int32, CellType) | Sets a cell's Type
Public method | SetColumnWidth | Sets a column's width in feet
Public method | SetColumnWidthInPixels | This sets a column's width in logical pixels
Public method | SetMergedCell | Sets the merged cell that this cell is a part of.
Public method | SetRowHeight | Sets a row's height in feet
Public method | SetRowHeightInPixels | This sets a row's height in logical pixels
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

TableSectionData Class


TableSectionData.AllowOverrideCellStyle Method

TableSectionDataAllowOverrideCellStyle Method

Identifies if the style can be overridden in the given cell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AllowOverrideCellStyle(
    int nRow,
    int nCol
)
Public Function AllowOverrideCellStyle (
    nRow As Integer,
    nCol As Integer
) As Boolean
public:
bool AllowOverrideCellStyle(
    int nRow,
    int nCol
)
member AllowOverrideCellStyle :
        nRow : int *
        nCol : int -> bool

Parameters

nRow Int32
nCol Int32

Return Value

Boolean
True if allow to override cell style.
Exceptions
Exception | Condition
ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid.
See Also

Reference

TableSectionData Class


TableSectionData.CanInsertColumn Method

TableSectionDataCanInsertColumn Method

Verifies if a new column can be inserted at the given index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanInsertColumn(
    int nIndex
)
Public Function CanInsertColumn (
    nIndex As Integer
) As Boolean
public:
bool CanInsertColumn(
    int nIndex
)
member CanInsertColumn :
        nIndex : int -> bool

Parameters

nIndex Int32
An integer index.

Return Value

Boolean
True if the column can be inserted, false otherwise.
See Also

Reference

TableSectionData Class


TableSectionData.CanInsertRow Method

TableSectionDataCanInsertRow Method

Verifies if a new row can be inserted at the given index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanInsertRow(
    int nIndex
)
Public Function CanInsertRow (
    nIndex As Integer
) As Boolean
public:
bool CanInsertRow(
    int nIndex
)
member CanInsertRow :
        nIndex : int -> bool

Parameters

nIndex Int32

Return Value

Boolean
True if the row can be inserted, false otherwise.
See Also

Reference

TableSectionData Class


TableSectionData.CanRemoveColumn Method

TableSectionDataCanRemoveColumn Method

Verifies that if the column at the given index can be removed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanRemoveColumn(
    int nIndex
)
Public Function CanRemoveColumn (
    nIndex As Integer
) As Boolean
public:
bool CanRemoveColumn(
    int nIndex
)
member CanRemoveColumn :
        nIndex : int -> bool

Parameters

nIndex Int32
An integer index.

Return Value

Boolean
True if the column can be removed, false otherwise.
See Also

Reference

TableSectionData Class


TableSectionData.CanRemoveRow Method

TableSectionDataCanRemoveRow Method

Verifies that if the row at the given index can be removed..

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanRemoveRow(
    int nIndex
)
Public Function CanRemoveRow (
    nIndex As Integer
) As Boolean
public:
bool CanRemoveRow(
    int nIndex
)
member CanRemoveRow :
        nIndex : int -> bool

Parameters

nIndex Int32
An integer index.

Return Value

Boolean
True if the row can be removed, false otherwise
See Also

Reference

TableSectionData Class


TableSectionData.ClearCell Method

TableSectionDataClearCell Method

Deletes text or image, or removes parameter of this cell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ClearCell(
    int nRow,
    int nCol
)
Public Sub ClearCell (
    nRow As Integer,
    nCol As Integer
)
public:
void ClearCell(
    int nRow,
    int nCol
)
member ClearCell :
        nRow : int *
        nCol : int -> unit

Parameters

nRow Int32
nCol Int32
Exceptions
Exception | Condition
ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid.
InvalidOperationException | This operation is forbidden for cells in standard schedule body sections.
See Also

Reference

TableSectionData Class


TableSectionData.Dispose Method

TableSectionDataDispose Method

Releases all resources used by the TableSectionData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

TableSectionData Class


TableSectionData.GetCellCalculatedValue Method

TableSectionDataGetCellCalculatedValue Method

Overload List
 | Name | Description
Public method | GetCellCalculatedValue(Int32) | Gets the calculated value for the specified column
Public method | GetCellCalculatedValue(Int32, Int32) | Gets the calculated value for the specified cell
Top
See Also

Reference

TableSectionData Class


TableSectionData.GetCellCalculatedValue(Int32) Method

TableSectionDataGetCellCalculatedValue(Int32) Method

Gets the calculated value for the specified column

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TableCellCalculatedValueData GetCellCalculatedValue(
    int nCol
)
Public Function GetCellCalculatedValue (
    nCol As Integer
) As TableCellCalculatedValueData
public:
TableCellCalculatedValueData^ GetCellCalculatedValue(
    int nCol
)
member GetCellCalculatedValue :
        nCol : int -> TableCellCalculatedValueData

Parameters

nCol Int32

Return Value

TableCellCalculatedValueData
Exceptions
Exception | Condition
ArgumentException | The given column number nCol is invalid.
See Also

Reference

TableSectionData Class
GetCellCalculatedValue Overload


TableSectionData.GetCellCalculatedValue(Int32, Int32) Method

TableSectionDataGetCellCalculatedValue(Int32, Int32) Method

Gets the calculated value for the specified cell

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TableCellCalculatedValueData GetCellCalculatedValue(
    int nRow,
    int nCol
)
Public Function GetCellCalculatedValue (
    nRow As Integer,
    nCol As Integer
) As TableCellCalculatedValueData
public:
TableCellCalculatedValueData^ GetCellCalculatedValue(
    int nRow,
    int nCol
)
member GetCellCalculatedValue :
        nRow : int *
        nCol : int -> TableCellCalculatedValueData

Parameters

nRow Int32
nCol Int32

Return Value

TableCellCalculatedValueData
Exceptions
Exception | Condition
ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid.
See Also

Reference

TableSectionData Class
GetCellCalculatedValue Overload


TableSectionData.GetCellCategoryId Method

TableSectionDataGetCellCategoryId Method

Overload List
 | Name | Description
Public method | GetCellCategoryId(Int32) | Returns a column's ParamId Associated with the paramId to find the correct element
Public method | GetCellCategoryId(Int32, Int32) | Returns a cell's CategoryId and if no CategoryId exists for this cell, it would come from the column. Associated with the paramId to find the correct element.
Top
See Also

Reference

TableSectionData Class


TableSectionData.GetCellCategoryId(Int32) Method

TableSectionDataGetCellCategoryId(Int32) Method

Returns a column's ParamId Associated with the paramId to find the correct element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GetCellCategoryId(
    int nCol
)
Public Function GetCellCategoryId (
    nCol As Integer
) As ElementId
public:
ElementId^ GetCellCategoryId(
    int nCol
)
member GetCellCategoryId :
        nCol : int -> ElementId

Parameters

nCol Int32

Return Value

ElementId
Exceptions
Exception | Condition
ArgumentException | The given column number nCol is invalid.
See Also

Reference

TableSectionData Class
GetCellCategoryId Overload


TableSectionData.GetCellCategoryId(Int32, Int32) Method

TableSectionDataGetCellCategoryId(Int32, Int32) Method

Returns a cell's CategoryId and if no CategoryId exists for this cell, it would come from the column. Associated with the paramId to find the correct element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GetCellCategoryId(
    int nRow,
    int nCol
)
Public Function GetCellCategoryId (
    nRow As Integer,
    nCol As Integer
) As ElementId
public:
ElementId^ GetCellCategoryId(
    int nRow,
    int nCol
)
member GetCellCategoryId :
        nRow : int *
        nCol : int -> ElementId

Parameters

nRow Int32
nCol Int32

Return Value

ElementId
Exceptions
Exception | Condition
ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid.
See Also

Reference

TableSectionData Class
GetCellCategoryId Overload


TableSectionData.GetCellCombinedParameters Method

TableSectionDataGetCellCombinedParameters Method

Overload List
 | Name | Description
Public method | GetCellCombinedParameters(Int32) | Returns an array of combined parameter data for the specified column
Public method | GetCellCombinedParameters(Int32, Int32) | Returns an array of combined parameter data for the specified cell
Top
See Also

Reference

TableSectionData Class


TableSectionData.GetCellCombinedParameters(Int32) Method

TableSectionDataGetCellCombinedParameters(Int32) Method

Returns an array of combined parameter data for the specified column

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<TableCellCombinedParameterData> GetCellCombinedParameters(
    int nCol
)
Public Function GetCellCombinedParameters (
    nCol As Integer
) As IList(Of TableCellCombinedParameterData)
public:
IList<TableCellCombinedParameterData^>^ GetCellCombinedParameters(
    int nCol
)
member GetCellCombinedParameters :
        nCol : int -> IList<TableCellCombinedParameterData>

Parameters

nCol Int32

Return Value

IList TableCellCombinedParameterData
Exceptions
Exception | Condition
ArgumentException | The given column number nCol is invalid.
See Also

Reference

TableSectionData Class
GetCellCombinedParameters Overload


TableSectionData.GetCellCombinedParameters(Int32, Int32) Method

TableSectionDataGetCellCombinedParameters(Int32, Int32) Method

Returns an array of combined parameter data for the specified cell

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<TableCellCombinedParameterData> GetCellCombinedParameters(
    int nRow,
    int nCol
)
Public Function GetCellCombinedParameters (
    nRow As Integer,
    nCol As Integer
) As IList(Of TableCellCombinedParameterData)
public:
IList<TableCellCombinedParameterData^>^ GetCellCombinedParameters(
    int nRow,
    int nCol
)
member GetCellCombinedParameters :
        nRow : int *
        nCol : int -> IList<TableCellCombinedParameterData>

Parameters

nRow Int32
nCol Int32

Return Value

IList TableCellCombinedParameterData
Exceptions
Exception | Condition
ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid.
See Also

Reference

TableSectionData Class
GetCellCombinedParameters Overload


TableSectionData.GetCellFormatOptions Method

TableSectionDataGetCellFormatOptions Method

Overload List
 | Name | Description
Public method | GetCellFormatOptions(Int32, Document) | Returns a column's cell FormatOptions and if no FormatOptions exists for this column, it would come from the section.
Public method | GetCellFormatOptions(Int32, Int32, Document) | Returns a cell's FormatOptions and if no FormatOptions exists for this cell, it would come from the column, or the row, or the section.
Top
See Also

Reference

TableSectionData Class


TableSectionData.GetCellFormatOptions(Int32, Document) Method

TableSectionDataGetCellFormatOptions(Int32, Document) Method

Returns a column's cell FormatOptions and if no FormatOptions exists for this column, it would come from the section.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormatOptions GetCellFormatOptions(
    int nCol,
    Document dcument
)
Public Function GetCellFormatOptions (
    nCol As Integer,
    dcument As Document
) As FormatOptions
public:
FormatOptions^ GetCellFormatOptions(
    int nCol,
    Document^ dcument
)
member GetCellFormatOptions :
        nCol : int *
        dcument : Document -> FormatOptions

Parameters

nCol Int32
dcument Document

Return Value

FormatOptions
Exceptions
Exception | Condition
ArgumentException | The given column number nCol is invalid.
ArgumentNullException | A non-optional argument was null
See Also

Reference

TableSectionData Class
GetCellFormatOptions Overload


TableSectionData.GetCellFormatOptions(Int32, Int32, Document) Method

TableSectionDataGetCellFormatOptions(Int32, Int32, Document) Method

Returns a cell's FormatOptions and if no FormatOptions exists for this cell, it would come from the column, or the row, or the section.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormatOptions GetCellFormatOptions(
    int nRow,
    int nCol,
    Document document
)
Public Function GetCellFormatOptions (
    nRow As Integer,
    nCol As Integer,
    document As Document
) As FormatOptions
public:
FormatOptions^ GetCellFormatOptions(
    int nRow,
    int nCol,
    Document^ document
)
member GetCellFormatOptions :
        nRow : int *
        nCol : int *
        document : Document -> FormatOptions

Parameters

nRow Int32
nCol Int32
document Document

Return Value

FormatOptions
Exceptions
Exception | Condition
ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid.
ArgumentNullException | A non-optional argument was null
See Also

Reference

TableSectionData Class
GetCellFormatOptions Overload


TableSectionData.GetCellParamId Method

TableSectionDataGetCellParamId Method

Overload List
 | Name | Description
Public method | GetCellParamId(Int32) | Returns a column's ParamId
Public method | GetCellParamId(Int32, Int32) | Returns a cell's ParamId and if no ParamId exists for this cell, it would come from the column
Top
See Also

Reference

TableSectionData Class


TableSectionData.GetCellParamId(Int32) Method

TableSectionDataGetCellParamId(Int32) Method

Returns a column's ParamId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GetCellParamId(
    int nCol
)
Public Function GetCellParamId (
    nCol As Integer
) As ElementId
public:
ElementId^ GetCellParamId(
    int nCol
)
member GetCellParamId :
        nCol : int -> ElementId

Parameters

nCol Int32

Return Value

ElementId
Exceptions
Exception | Condition
ArgumentException | The given column number nCol is invalid.
See Also

Reference

TableSectionData Class
GetCellParamId Overload


TableSectionData.GetCellParamId(Int32, Int32) Method

TableSectionDataGetCellParamId(Int32, Int32) Method

Returns a cell's ParamId and if no ParamId exists for this cell, it would come from the column

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GetCellParamId(
    int nRow,
    int nCol
)
Public Function GetCellParamId (
    nRow As Integer,
    nCol As Integer
) As ElementId
public:
ElementId^ GetCellParamId(
    int nRow,
    int nCol
)
member GetCellParamId :
        nRow : int *
        nCol : int -> ElementId

Parameters

nRow Int32
nCol Int32

Return Value

ElementId
Exceptions
Exception | Condition
ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid.
See Also

Reference

TableSectionData Class
GetCellParamId Overload


TableSectionData.GetCellSpec Method

TableSectionDataGetCellSpec Method

Gets the spec describing values of a cell, if applicable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ForgeTypeId GetCellSpec(
    int nRow,
    int nCol
)
Public Function GetCellSpec (
    nRow As Integer,
    nCol As Integer
) As ForgeTypeId
public:
ForgeTypeId^ GetCellSpec(
    int nRow,
    int nCol
)
member GetCellSpec :
        nRow : int *
        nCol : int -> ForgeTypeId

Parameters

nRow Int32
The row index of the cell
nCol Int32
The column index of the cell

Return Value

ForgeTypeId
Identifier of the spec, or empty if the cell does not contain a number with units.
Exceptions
Exception | Condition
ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid.
See Also

Reference

TableSectionData Class


TableSectionData.GetCellText Method

TableSectionDataGetCellText Method

Returns the text shown by this cell, if the cell's type is CellType.Text or CellType.ParameterText or CellType.CustomField.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetCellText(
    int nRow,
    int nCol
)
Public Function GetCellText (
    nRow As Integer,
    nCol As Integer
) As String
public:
String^ GetCellText(
    int nRow,
    int nCol
)
member GetCellText :
        nRow : int *
        nCol : int -> string

Parameters

nRow Int32
The cell row.
nCol Int32
The cell column.

Return Value

String
The text in the cell, or an empty string if the type if not CellType.Text or CellType.ParameterText or CellType.CustomField.
Exceptions
Exception | Condition
ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid.
Remarks
For standard view schedules, to read the formatted text of the cell regardless of cell type, use GetCellText(SectionType, Int32, Int32).
See Also

Reference

TableSectionData Class


TableSectionData.GetCellType Method

TableSectionDataGetCellType Method

Overload List
 | Name | Description
Public method | GetCellType(Int32) | Returns a column's cell type and if no type exists for this column, it would come from the section
Public method | GetCellType(Int32, Int32) | Returns a cell's Type and if no Type exists for this cell, it would come from the column, or the row, or the section
Top
See Also

Reference

TableSectionData Class


TableSectionData.GetCellType(Int32) Method

TableSectionDataGetCellType(Int32) Method

Returns a column's cell type and if no type exists for this column, it would come from the section

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CellType GetCellType(
    int nCol
)
Public Function GetCellType (
    nCol As Integer
) As CellType
public:
CellType GetCellType(
    int nCol
)
member GetCellType :
        nCol : int -> CellType

Parameters

nCol Int32

Return Value

CellType
Exceptions
Exception | Condition
ArgumentException | The given column number nCol is invalid.
See Also

Reference

TableSectionData Class
GetCellType Overload


TableSectionData.GetCellType(Int32, Int32) Method

TableSectionDataGetCellType(Int32, Int32) Method

Returns a cell's Type and if no Type exists for this cell, it would come from the column, or the row, or the section

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CellType GetCellType(
    int nRow,
    int nCol
)
Public Function GetCellType (
    nRow As Integer,
    nCol As Integer
) As CellType
public:
CellType GetCellType(
    int nRow,
    int nCol
)
member GetCellType :
        nRow : int *
        nCol : int -> CellType

Parameters

nRow Int32
nCol Int32

Return Value

CellType
Exceptions
Exception | Condition
ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid.
See Also

Reference

TableSectionData Class
GetCellType Overload


TableSectionData.GetColumnWidth Method

TableSectionDataGetColumnWidth Method

Returns a column's width in feet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetColumnWidth(
    int nCol
)
Public Function GetColumnWidth (
    nCol As Integer
) As Double
public:
double GetColumnWidth(
    int nCol
)
member GetColumnWidth :
        nCol : int -> float

Parameters

nCol Int32

Return Value

Double
Exceptions
Exception | Condition
ArgumentException | The given column number nCol is invalid.
See Also

Reference

TableSectionData Class


TableSectionData.GetColumnWidthInPixels Method

TableSectionDataGetColumnWidthInPixels Method

This returns a column's width in logical pixels

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetColumnWidthInPixels(
    int nCol
)
Public Function GetColumnWidthInPixels (
    nCol As Integer
) As Integer
public:
int GetColumnWidthInPixels(
    int nCol
)
member GetColumnWidthInPixels :
        nCol : int -> int

Parameters

nCol Int32

Return Value

Int32
Exceptions
Exception | Condition
ArgumentException | The given column number nCol is invalid.
See Also

Reference

TableSectionData Class


TableSectionData.GetCustomFieldId Method

TableSectionDataGetCustomFieldId Method

Gets custom field id from the cell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid GetCustomFieldId(
    int row,
    int col
)
Public Function GetCustomFieldId (
    row As Integer,
    col As Integer
) As Guid
public:
Guid GetCustomFieldId(
    int row,
    int col
)
member GetCustomFieldId :
        row : int *
        col : int -> Guid

Parameters

row Int32
The row of the cell.
col Int32
The column of the cell.

Return Value

Guid
Returns custom field id from the cell. If this cell is not of type CellType.CustomField it will return an empty Guid
Exceptions
Exception | Condition
ArgumentException | The given row number row is invalid. -or- The given column number col is invalid.
See Also

Reference

TableSectionData Class


TableSectionData.GetMergedCell Method

TableSectionDataGetMergedCell Method

Gets the whole merged cell that this cell is a part of.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TableMergedCell GetMergedCell(
    int nRow,
    int nCol
)
Public Function GetMergedCell (
    nRow As Integer,
    nCol As Integer
) As TableMergedCell
public:
TableMergedCell^ GetMergedCell(
    int nRow,
    int nCol
)
member GetMergedCell :
        nRow : int *
        nCol : int -> TableMergedCell

Parameters

nRow Int32
The cell row.
nCol Int32
The cell column.

Return Value

TableMergedCell
Exceptions
Exception | Condition
ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid.
See Also

Reference

TableSectionData Class


TableSectionData.GetRowHeight Method

TableSectionDataGetRowHeight Method

Returns a row's height in feet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetRowHeight(
    int nRow
)
Public Function GetRowHeight (
    nRow As Integer
) As Double
public:
double GetRowHeight(
    int nRow
)
member GetRowHeight :
        nRow : int -> float

Parameters

nRow Int32

Return Value

Double
Exceptions
Exception | Condition
ArgumentException | The given row number nRow is invalid.
See Also

Reference

TableSectionData Class


TableSectionData.GetRowHeightInPixels Method

TableSectionDataGetRowHeightInPixels Method

This returns a row's height in logical pixels

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetRowHeightInPixels(
    int nRow
)
Public Function GetRowHeightInPixels (
    nRow As Integer
) As Integer
public:
int GetRowHeightInPixels(
    int nRow
)
member GetRowHeightInPixels :
        nRow : int -> int

Parameters

nRow Int32

Return Value

Int32
Exceptions
Exception | Condition
ArgumentException | The given row number nRow is invalid.
See Also

Reference

TableSectionData Class


TableSectionData.GetTableCellStyle Method

TableSectionDataGetTableCellStyle Method

Returns a cell's style and if no style exists for this cell, it would come from the column, or the section

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TableCellStyle GetTableCellStyle(
    int nRow,
    int nCol
)
Public Function GetTableCellStyle (
    nRow As Integer,
    nCol As Integer
) As TableCellStyle
public:
TableCellStyle^ GetTableCellStyle(
    int nRow,
    int nCol
)
member GetTableCellStyle :
        nRow : int *
        nCol : int -> TableCellStyle

Parameters

nRow Int32
nCol Int32

Return Value

TableCellStyle
Exceptions
Exception | Condition
ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid.
See Also

Reference

TableSectionData Class


TableSectionData.InsertColumn Method

TableSectionDataInsertColumn Method

Inserts a new column at the specified index relative to the current set of columns.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void InsertColumn(
    int index
)
Public Sub InsertColumn (
    index As Integer
)
public:
void InsertColumn(
    int index
)
member InsertColumn :
        index : int -> unit

Parameters

index Int32
An integer index.
Exceptions
Exception | Condition
ArgumentException | index is invalid index.
InvalidOperationException | This operation is forbidden for cells in standard schedule body sections.
See Also

Reference

TableSectionData Class


TableSectionData.InsertImage Method

TableSectionDataInsertImage Method

Inserts a image in the given cell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void InsertImage(
    int nRow,
    int nColumn,
    ElementId imageSymbolId
)
Public Sub InsertImage (
    nRow As Integer,
    nColumn As Integer,
    imageSymbolId As ElementId
)
public:
void InsertImage(
    int nRow,
    int nColumn,
    ElementId^ imageSymbolId
)
member InsertImage :
        nRow : int *
        nColumn : int *
        imageSymbolId : ElementId -> unit

Parameters

nRow Int32
The given row index.
nColumn Int32
The given column index.
imageSymbolId ElementId
The element id of the image symbol.
Exceptions
Exception | Condition
ArgumentException | The given row number nRow is invalid. -or- The given column number nColumn is invalid. -or- The image symbol id doesn't represent a valid image symbol element.
ArgumentNullException | A non-optional argument was null
See Also

Reference

TableSectionData Class


TableSectionData.InsertRow Method

TableSectionDataInsertRow Method

Inserts a row data at a specified index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void InsertRow(
    int nIndex
)
Public Sub InsertRow (
    nIndex As Integer
)
public:
void InsertRow(
    int nIndex
)
member InsertRow :
        nIndex : int -> unit

Parameters

nIndex Int32
An integer index.
Exceptions
Exception | Condition
ArgumentException | The row can't be inserted in data section of standard schedule except Key Schedule, Sheet List Schedule or following categories without emdeded schedule: MEP Space, Room, Area. or nIndex is invalid index.
Example
C#
VB
C++
F#
Copy
public void CreateSubtitle(ViewSchedule schedule)
{
    TableData colTableData = schedule.GetTableData();

    TableSectionData tsd = colTableData.GetSectionData(SectionType.Header);
    tsd.InsertRow(tsd.FirstRowNumber + 1);
    tsd.SetCellText(tsd.FirstRowNumber + 1, tsd.FirstColumnNumber, "Schedule of column top and base levels with offsets");
}
Public Sub CreateSubtitle(schedule As ViewSchedule)
    Dim colTableData As TableData = schedule.GetTableData()

    Dim tsd As TableSectionData = colTableData.GetSectionData(SectionType.Header)
    tsd.InsertRow(tsd.FirstRowNumber + 1)
    tsd.SetCellText(tsd.FirstRowNumber + 1, tsd.FirstColumnNumber, "Schedule of column top and base levels with offsets")
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

TableSectionData Class


TableSectionData.IsAcceptableParamIdAndCategoryId Method

TableSectionDataIsAcceptableParamIdAndCategoryId Method

Overload List
 | Name | Description
Public method | IsAcceptableParamIdAndCategoryId(ElementId, ElementId) | Identifies if the given parameter id and category id can be assigned to a cell in this table.
Public method | IsAcceptableParamIdAndCategoryId(Int32, ElementId, ElementId) | Identifies if the given parameter id and category id can be assigned to a cell in the given row in this table.
Top
See Also

Reference

TableSectionData Class


TableSectionData.IsAcceptableParamIdAndCategoryId(ElementId, ElementId) Method

TableSectionDataIsAcceptableParamIdAndCategoryId(ElementId, ElementId) Method

Identifies if the given parameter id and category id can be assigned to a cell in this table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsAcceptableParamIdAndCategoryId(
    ElementId paramId,
    ElementId categoryId
)
Public Function IsAcceptableParamIdAndCategoryId (
    paramId As ElementId,
    categoryId As ElementId
) As Boolean
public:
bool IsAcceptableParamIdAndCategoryId(
    ElementId^ paramId,
    ElementId^ categoryId
)
member IsAcceptableParamIdAndCategoryId :
        paramId : ElementId *
        categoryId : ElementId -> bool

Parameters

paramId ElementId
categoryId ElementId

Return Value

Boolean
True if the ParamId and CategoryId are all acceptable.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

TableSectionData Class
IsAcceptableParamIdAndCategoryId Overload


TableSectionData.IsAcceptableParamIdAndCategoryId(Int32, ElementId, ElementId) Method

TableSectionDataIsAcceptableParamIdAndCategoryId(Int32, ElementId, ElementId) Method

Identifies if the given parameter id and category id can be assigned to a cell in the given row in this table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsAcceptableParamIdAndCategoryId(
    int nRow,
    ElementId paramId,
    ElementId categoryId
)
Public Function IsAcceptableParamIdAndCategoryId (
    nRow As Integer,
    paramId As ElementId,
    categoryId As ElementId
) As Boolean
public:
bool IsAcceptableParamIdAndCategoryId(
    int nRow,
    ElementId^ paramId,
    ElementId^ categoryId
)
member IsAcceptableParamIdAndCategoryId :
        nRow : int *
        paramId : ElementId *
        categoryId : ElementId -> bool

Parameters

nRow Int32
row index
paramId ElementId
categoryId ElementId

Return Value

Boolean
True if the ParamId and CategoryId are all valid.
Exceptions
Exception | Condition
ArgumentException | The given row number nRow is invalid.
ArgumentNullException | A non-optional argument was null
See Also

Reference

TableSectionData Class
IsAcceptableParamIdAndCategoryId Overload


TableSectionData.IsCellFormattable Method

TableSectionDataIsCellFormattable Method

Determines whether the cell is formattable or not

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCellFormattable(
    int nRow,
    int nCol
)
Public Function IsCellFormattable (
    nRow As Integer,
    nCol As Integer
) As Boolean
public:
bool IsCellFormattable(
    int nRow,
    int nCol
)
member IsCellFormattable :
        nRow : int *
        nCol : int -> bool

Parameters

nRow Int32
The row index of the cell
nCol Int32
The column index of the cell

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid.
See Also

Reference

TableSectionData Class


TableSectionData.IsCellOverridden Method

TableSectionDataIsCellOverridden Method

Overload List
 | Name | Description
Public method | IsCellOverridden(Int32) | Indicates if the column is overridden or not.
Public method | IsCellOverridden(Int32, Int32) | Indicates if the cell is overridden or not.
Top
See Also

Reference

TableSectionData Class


TableSectionData.IsCellOverridden(Int32) Method

TableSectionDataIsCellOverridden(Int32) Method

Indicates if the column is overridden or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCellOverridden(
    int nCol
)
Public Function IsCellOverridden (
    nCol As Integer
) As Boolean
public:
bool IsCellOverridden(
    int nCol
)
member IsCellOverridden :
        nCol : int -> bool

Parameters

nCol Int32

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentException | The given column number nCol is invalid.
See Also

Reference

TableSectionData Class
IsCellOverridden Overload


TableSectionData.IsCellOverridden(Int32, Int32) Method

TableSectionDataIsCellOverridden(Int32, Int32) Method

Indicates if the cell is overridden or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCellOverridden(
    int nRow,
    int nCol
)
Public Function IsCellOverridden (
    nRow As Integer,
    nCol As Integer
) As Boolean
public:
bool IsCellOverridden(
    int nRow,
    int nCol
)
member IsCellOverridden :
        nRow : int *
        nCol : int -> bool

Parameters

nRow Int32
nCol Int32

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid.
See Also

Reference

TableSectionData Class
IsCellOverridden Overload


TableSectionData.IsDataOutOfDate Method

TableSectionDataIsDataOutOfDate Method

Indicates whether the data in this section is out of date.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsDataOutOfDate()
Public Function IsDataOutOfDate As Boolean
public:
bool IsDataOutOfDate()
member IsDataOutOfDate : unit -> bool

Return Value

Boolean
True if the data in this section is out of date, false otherwise.
Remarks
To improve performance, some TableViews may contain TableSections that are only updated on demand. For example, the body section of a schedule is not updated when the ViewSchedule is closed. In this case, you need to call RefreshData to avoid getting the stale data.
See Also

Reference

TableSectionData Class


TableSectionData.IsValidColumnNumber Method

TableSectionDataIsValidColumnNumber Method

Verifies if the column number is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidColumnNumber(
    int nCol
)
Public Function IsValidColumnNumber (
    nCol As Integer
) As Boolean
public:
bool IsValidColumnNumber(
    int nCol
)
member IsValidColumnNumber :
        nCol : int -> bool

Parameters

nCol Int32
The column number.

Return Value

Boolean
True if the column number is between FirstColumnNumber and LastColumnNumber, false otherwise.
See Also

Reference

TableSectionData Class


TableSectionData.IsValidImageSymbolId Method

TableSectionDataIsValidImageSymbolId Method

Identifies if the element id represents a valid ImageSymbol element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidImageSymbolId(
    ElementId imageSymbolId
)
Public Function IsValidImageSymbolId (
    imageSymbolId As ElementId
) As Boolean
public:
bool IsValidImageSymbolId(
    ElementId^ imageSymbolId
)
member IsValidImageSymbolId :
        imageSymbolId : ElementId -> bool

Parameters

imageSymbolId ElementId
The element id of the image symbol.

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

TableSectionData Class


TableSectionData.IsValidRowNumber Method

TableSectionDataIsValidRowNumber Method

Verifies if the row number is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidRowNumber(
    int nRow
)
Public Function IsValidRowNumber (
    nRow As Integer
) As Boolean
public:
bool IsValidRowNumber(
    int nRow
)
member IsValidRowNumber :
        nRow : int -> bool

Parameters

nRow Int32
The row number.

Return Value

Boolean
True if the row number is between FirstRowNumber and LastRowNumber, false otherwise.
See Also

Reference

TableSectionData Class


TableSectionData.MergeCells Method

TableSectionDataMergeCells Method

Merges cells for the given area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void MergeCells(
    TableMergedCell mergedCell
)
Public Sub MergeCells (
    mergedCell As TableMergedCell
)
public:
void MergeCells(
    TableMergedCell^ mergedCell
)
member MergeCells :
        mergedCell : TableMergedCell -> unit

Parameters

mergedCell TableMergedCell
Exceptions
Exception | Condition
ArgumentException | The given TableMergedCell mergedCell is outside of acceptable range.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This operation is forbidden for cells in standard schedule body sections.
See Also

Reference

TableSectionData Class


TableSectionData.RefreshData Method

TableSectionDataRefreshData Method

Rebuilds the data in this section if it is out of date.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool RefreshData()
Public Function RefreshData As Boolean
public:
bool RefreshData()
member RefreshData : unit -> bool

Return Value

Boolean
True if the data is up to date after the refresh.
See Also

Reference

TableSectionData Class


TableSectionData.RemoveColumn Method

TableSectionDataRemoveColumn Method

Removes a column data at a specified index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveColumn(
    int nIndex
)
Public Sub RemoveColumn (
    nIndex As Integer
)
public:
void RemoveColumn(
    int nIndex
)
member RemoveColumn :
        nIndex : int -> unit

Parameters

nIndex Int32
An integer index
Exceptions
Exception | Condition
ArgumentException | nIndex is invalid index.
InvalidOperationException | This operation is forbidden for cells in standard schedule body sections.
See Also

Reference

TableSectionData Class


TableSectionData.RemoveRow Method

TableSectionDataRemoveRow Method

Removes a row data at a specified index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveRow(
    int nIndex
)
Public Sub RemoveRow (
    nIndex As Integer
)
public:
void RemoveRow(
    int nIndex
)
member RemoveRow :
        nIndex : int -> unit

Parameters

nIndex Int32
An integer index.
Exceptions
Exception | Condition
ArgumentException | The row can't be removed because it's an element in linked file, default zone or it's a row in body section of Material Quantity Take Off Schedule or it's the last row in header section of standard schedule or nIndex is invalid index.
See Also

Reference

TableSectionData Class


TableSectionData.ResetCellOverride Method

TableSectionDataResetCellOverride Method

Overload List
 | Name | Description
Public method | ResetCellOverride(Int32) | Resets the override of the column.
Public method | ResetCellOverride(Int32, Int32) | Resets the override of the cell.
Top
See Also

Reference

TableSectionData Class


TableSectionData.ResetCellOverride(Int32) Method

TableSectionDataResetCellOverride(Int32) Method

Resets the override of the column.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetCellOverride(
    int nCol
)
Public Sub ResetCellOverride (
    nCol As Integer
)
public:
void ResetCellOverride(
    int nCol
)
member ResetCellOverride :
        nCol : int -> unit

Parameters

nCol Int32
Exceptions
Exception | Condition
ArgumentException | The given column number nCol is invalid.
See Also

Reference

TableSectionData Class
ResetCellOverride Overload


TableSectionData.ResetCellOverride(Int32, Int32) Method

TableSectionDataResetCellOverride(Int32, Int32) Method

Resets the override of the cell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetCellOverride(
    int nRow,
    int nCol
)
Public Sub ResetCellOverride (
    nRow As Integer,
    nCol As Integer
)
public:
void ResetCellOverride(
    int nRow,
    int nCol
)
member ResetCellOverride :
        nRow : int *
        nCol : int -> unit

Parameters

nRow Int32
nCol Int32
Exceptions
Exception | Condition
ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid. -or- Only allow to override cell style for header section or column header in body section.
See Also

Reference

TableSectionData Class
ResetCellOverride Overload


TableSectionData.SetCellCalculatedValue Method

TableSectionDataSetCellCalculatedValue Method

Overload List
 | Name | Description
Public method | SetCellCalculatedValue(Int32, TableCellCalculatedValueData) | Allows the caller to set the calculated value for a specified column
Public method | SetCellCalculatedValue(Int32, Int32, TableCellCalculatedValueData) | Allows the caller to set the calculated value for a specified cell
Top
See Also

Reference

TableSectionData Class


TableSectionData.SetCellCalculatedValue(Int32, TableCellCalculatedValueData) Method

TableSectionDataSetCellCalculatedValue(Int32, TableCellCalculatedValueData) Method

Allows the caller to set the calculated value for a specified column

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetCellCalculatedValue(
    int nCol,
    TableCellCalculatedValueData pCalcValue
)
Public Sub SetCellCalculatedValue (
    nCol As Integer,
    pCalcValue As TableCellCalculatedValueData
)
public:
void SetCellCalculatedValue(
    int nCol,
    TableCellCalculatedValueData^ pCalcValue
)
member SetCellCalculatedValue :
        nCol : int *
        pCalcValue : TableCellCalculatedValueData -> unit

Parameters

nCol Int32
pCalcValue TableCellCalculatedValueData
Exceptions
Exception | Condition
ArgumentException | The given column number nCol is invalid.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This operation is forbidden for cells in standard schedule header sections. -or- This operation is forbidden for cells in standard schedule body sections.
See Also

Reference

TableSectionData Class
SetCellCalculatedValue Overload


TableSectionData.SetCellCalculatedValue(Int32, Int32, TableCellCalculatedValueData) Method

TableSectionDataSetCellCalculatedValue(Int32, Int32, TableCellCalculatedValueData) Method

Allows the caller to set the calculated value for a specified cell

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetCellCalculatedValue(
    int nRow,
    int nCol,
    TableCellCalculatedValueData pCalcValue
)
Public Sub SetCellCalculatedValue (
    nRow As Integer,
    nCol As Integer,
    pCalcValue As TableCellCalculatedValueData
)
public:
void SetCellCalculatedValue(
    int nRow,
    int nCol,
    TableCellCalculatedValueData^ pCalcValue
)
member SetCellCalculatedValue :
        nRow : int *
        nCol : int *
        pCalcValue : TableCellCalculatedValueData -> unit

Parameters

nRow Int32
nCol Int32
pCalcValue TableCellCalculatedValueData
Exceptions
Exception | Condition
ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This operation is forbidden for cells in standard schedule header sections. -or- This operation is forbidden for cells in standard schedule body sections.
See Also

Reference

TableSectionData Class
SetCellCalculatedValue Overload


TableSectionData.SetCellCombinedParameters Method

TableSectionDataSetCellCombinedParameters Method

Overload List
 | Name | Description
Public method | SetCellCombinedParameters(Int32, IListTableCellCombinedParameterData) | Allows the caller to set combined parameter for a specified column
Public method | SetCellCombinedParameters(Int32, Int32, IListTableCellCombinedParameterData) | Allows the caller to set combined parameter for a specified cell
Top
See Also

Reference

TableSectionData Class


TableSectionData.SetCellCombinedParameters(Int32, IList<TableCellCombinedParameterData>) Method

TableSectionDataSetCellCombinedParameters(Int32, IListTableCellCombinedParameterData) Method

Allows the caller to set combined parameter for a specified column

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetCellCombinedParameters(
    int nCol,
    IList<TableCellCombinedParameterData> paramData
)
Public Sub SetCellCombinedParameters (
    nCol As Integer,
    paramData As IList(Of TableCellCombinedParameterData)
)
public:
void SetCellCombinedParameters(
    int nCol,
    IList<TableCellCombinedParameterData^>^ paramData
)
member SetCellCombinedParameters :
        nCol : int *
        paramData : IList<TableCellCombinedParameterData> -> unit

Parameters

nCol Int32
paramData IList TableCellCombinedParameterData
Exceptions
Exception | Condition
ArgumentException | The given column number nCol is invalid.
ArgumentNullException | A non-optional argument was null
See Also

Reference

TableSectionData Class
SetCellCombinedParameters Overload


TableSectionData.SetCellCombinedParameters(Int32, Int32, IList<TableCellCombinedParameterData>) Method

TableSectionDataSetCellCombinedParameters(Int32, Int32, IListTableCellCombinedParameterData) Method

Allows the caller to set combined parameter for a specified cell

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetCellCombinedParameters(
    int nRow,
    int nCol,
    IList<TableCellCombinedParameterData> paramData
)
Public Sub SetCellCombinedParameters (
    nRow As Integer,
    nCol As Integer,
    paramData As IList(Of TableCellCombinedParameterData)
)
public:
void SetCellCombinedParameters(
    int nRow,
    int nCol,
    IList<TableCellCombinedParameterData^>^ paramData
)
member SetCellCombinedParameters :
        nRow : int *
        nCol : int *
        paramData : IList<TableCellCombinedParameterData> -> unit

Parameters

nRow Int32
nCol Int32
paramData IList TableCellCombinedParameterData
Exceptions
Exception | Condition
ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid.
ArgumentNullException | A non-optional argument was null
See Also

Reference

TableSectionData Class
SetCellCombinedParameters Overload


TableSectionData.SetCellFormatOptions Method

TableSectionDataSetCellFormatOptions Method

Sets a cell's FormatOptions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetCellFormatOptions(
    int nRow,
    int nCol,
    FormatOptions options
)
Public Sub SetCellFormatOptions (
    nRow As Integer,
    nCol As Integer,
    options As FormatOptions
)
public:
void SetCellFormatOptions(
    int nRow,
    int nCol,
    FormatOptions^ options
)
member SetCellFormatOptions :
        nRow : int *
        nCol : int *
        options : FormatOptions -> unit

Parameters

nRow Int32
The row index of the cell
nCol Int32
The column index of the cell
options FormatOptions
The format option to assign
Exceptions
Exception | Condition
ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid. -or- The display unit in options is not a valid display unit for the unit type of the cell, or the rounding method in options is not set to Nearest. See UnitUtils.IsValidDisplayUnit(UnitType, DisplayUnitType), UnitUtils.GetValidDisplayUnits(UnitType) and FormatOptions.RoundingMethod.
ArgumentNullException | A non-optional argument was null
See Also

Reference

TableSectionData Class


TableSectionData.SetCellParamIdAndCategoryId Method

TableSectionDataSetCellParamIdAndCategoryId Method

Overload List
 | Name | Description
Public method | SetCellParamIdAndCategoryId(Int32, ElementId, ElementId) | Sets a column's category and parameter Id
Public method | SetCellParamIdAndCategoryId(Int32, Int32, ElementId, ElementId) | Sets a cell's category and parameter Id
Top
See Also

Reference

TableSectionData Class


TableSectionData.SetCellParamIdAndCategoryId(Int32, ElementId, ElementId) Method

TableSectionDataSetCellParamIdAndCategoryId(Int32, ElementId, ElementId) Method

Sets a column's category and parameter Id

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetCellParamIdAndCategoryId(
    int nCol,
    ElementId paramId,
    ElementId categoryId
)
Public Sub SetCellParamIdAndCategoryId (
    nCol As Integer,
    paramId As ElementId,
    categoryId As ElementId
)
public:
void SetCellParamIdAndCategoryId(
    int nCol,
    ElementId^ paramId,
    ElementId^ categoryId
)
member SetCellParamIdAndCategoryId :
        nCol : int *
        paramId : ElementId *
        categoryId : ElementId -> unit

Parameters

nCol Int32
paramId ElementId
categoryId ElementId
Exceptions
Exception | Condition
ArgumentException | The given column number nCol is invalid. -or- The paramId or categoryId is not acceptable.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This operation is forbidden for cells in standard schedule body sections.
See Also

Reference

TableSectionData Class
SetCellParamIdAndCategoryId Overload


TableSectionData.SetCellParamIdAndCategoryId(Int32, Int32, ElementId, ElementId) Method

TableSectionDataSetCellParamIdAndCategoryId(Int32, Int32, ElementId, ElementId) Method

Sets a cell's category and parameter Id

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetCellParamIdAndCategoryId(
    int nRow,
    int nCol,
    ElementId paramId,
    ElementId categoryId
)
Public Sub SetCellParamIdAndCategoryId (
    nRow As Integer,
    nCol As Integer,
    paramId As ElementId,
    categoryId As ElementId
)
public:
void SetCellParamIdAndCategoryId(
    int nRow,
    int nCol,
    ElementId^ paramId,
    ElementId^ categoryId
)
member SetCellParamIdAndCategoryId :
        nRow : int *
        nCol : int *
        paramId : ElementId *
        categoryId : ElementId -> unit

Parameters

nRow Int32
nCol Int32
paramId ElementId
categoryId ElementId
Exceptions
Exception | Condition
ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid. -or- The paramId or categoryId is not valid.
ArgumentNullException | A non-optional argument was null
See Also

Reference

TableSectionData Class
SetCellParamIdAndCategoryId Overload


TableSectionData.SetCellStyle Method

TableSectionDataSetCellStyle Method

Overload List
 | Name | Description
Public method | SetCellStyle(TableCellStyle) | Sets a section's style
Public method | SetCellStyle(Int32, TableCellStyle) | Sets a column's style.
 | SetCellStyle(Int32, Int32, TableCellStyle) | Sets a cell's style
Top
See Also

Reference

TableSectionData Class


TableSectionData.SetCellStyle(TableCellStyle) Method

TableSectionDataSetCellStyle(TableCellStyle) Method

Sets a section's style

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetCellStyle(
    TableCellStyle Style
)
Public Sub SetCellStyle (
    Style As TableCellStyle
)
public:
void SetCellStyle(
    TableCellStyle^ Style
)
member SetCellStyle :
        Style : TableCellStyle -> unit

Parameters

Style TableCellStyle
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
For standard schedule, must set the TableCellStyleOverrideOptions in the TableCellStyle to override this section.
See Also

Reference

TableSectionData Class
SetCellStyle Overload


TableSectionData.SetCellStyle(Int32, TableCellStyle) Method

TableSectionDataSetCellStyle(Int32, TableCellStyle) Method

Sets a column's style.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetCellStyle(
    int nCol,
    TableCellStyle Style
)
Public Sub SetCellStyle (
    nCol As Integer,
    Style As TableCellStyle
)
public:
void SetCellStyle(
    int nCol,
    TableCellStyle^ Style
)
member SetCellStyle :
        nCol : int *
        Style : TableCellStyle -> unit

Parameters

nCol Int32
Style TableCellStyle
Exceptions
Exception | Condition
ArgumentException | The given column number nCol is invalid.
ArgumentNullException | A non-optional argument was null
See Also

Reference

TableSectionData Class
SetCellStyle Overload


TableSectionData.SetCellStyle(Int32, Int32, TableCellStyle) Method

TableSectionDataSetCellStyle(Int32, Int32, TableCellStyle) Method

Sets a cell's style

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetCellStyle(
    int nRow,
    int nCol,
    TableCellStyle Style
)
Public Sub SetCellStyle (
    nRow As Integer,
    nCol As Integer,
    Style As TableCellStyle
)
public:
void SetCellStyle(
    int nRow,
    int nCol,
    TableCellStyle^ Style
)
member SetCellStyle :
        nRow : int *
        nCol : int *
        Style : TableCellStyle -> unit

Parameters

nRow Int32
nCol Int32
Style TableCellStyle
Exceptions
Exception | Condition
ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid. -or- Only allow to override cell style for header section or column header in body section.
ArgumentNullException | A non-optional argument was null
Remarks
For standard schedule, must set the TableCellStyleOverrideOptions in the TableCellStyle to override this cell. The global base format controls any non-overridden characteristics of this cell.
Example
C#
VB
C++
F#
Copy
public void FormatSubtitle(ViewSchedule colSchedule)
{
    TableData colTableData = colSchedule.GetTableData();

    TableSectionData tsd = colTableData.GetSectionData(SectionType.Header);
    // Subtitle is second row, first column
    if (tsd.AllowOverrideCellStyle(tsd.FirstRowNumber + 1, tsd.FirstColumnNumber))
    {
        TableCellStyle tcs = new TableCellStyle();
        TableCellStyleOverrideOptions options = new TableCellStyleOverrideOptions();
        options.FontSize = true;
        options.Bold = true;
        tcs.SetCellStyleOverrideOptions(options);
        tcs.IsFontBold = true;
        tcs.TextSize = 10;
        tsd.SetCellStyle(tsd.FirstRowNumber + 1, tsd.FirstColumnNumber, tcs);
    }
}
Public Sub FormatSubtitle(colSchedule As ViewSchedule)
    Dim colTableData As TableData = colSchedule.GetTableData()

    Dim tsd As TableSectionData = colTableData.GetSectionData(SectionType.Header)
    ' Subtitle is second row, first column
    If tsd.AllowOverrideCellStyle(tsd.FirstRowNumber + 1, tsd.FirstColumnNumber) Then
        Dim tcs As New TableCellStyle()
        Dim options As New TableCellStyleOverrideOptions()
        options.FontSize = True
        options.Bold = True
        tcs.SetCellStyleOverrideOptions(options)
        tcs.IsFontBold = True
        tcs.TextSize = 10
        tsd.SetCellStyle(tsd.FirstRowNumber + 1, tsd.FirstColumnNumber, tcs)
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

TableSectionData Class
SetCellStyle Overload


TableSectionData.SetCellText Method

TableSectionDataSetCellText Method

Sets a cell's to display the specified text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetCellText(
    int nRow,
    int nCol,
    string text
)
Public Sub SetCellText (
    nRow As Integer,
    nCol As Integer,
    text As String
)
public:
void SetCellText(
    int nRow,
    int nCol,
    String^ text
)
member SetCellText :
        nRow : int *
        nCol : int *
        text : string -> unit

Parameters

nRow Int32
The cell row.
nCol Int32
The cell column.
text String
The text to show in the cell.
Exceptions
Exception | Condition
ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This operation is forbidden for cells in standard schedule body sections.
Remarks
If this cell's type is not CellType.Text, and the operation is permitted on this cell, the cell type will be changed to type CellType.Text as a result of this call.
See Also

Reference

TableSectionData Class


TableSectionData.SetCellType Method

TableSectionDataSetCellType Method

Overload List
 | Name | Description
Public method | SetCellType(Int32, CellType) | Sets a column's cell type
Public method | SetCellType(Int32, Int32, CellType) | Sets a cell's Type
Top
See Also

Reference

TableSectionData Class


TableSectionData.SetCellType(Int32, CellType) Method

TableSectionDataSetCellType(Int32, CellType) Method

Sets a column's cell type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetCellType(
    int nCol,
    CellType type
)
Public Sub SetCellType (
    nCol As Integer,
    type As CellType
)
public:
void SetCellType(
    int nCol,
    CellType type
)
member SetCellType :
        nCol : int *
        type : CellType -> unit

Parameters

nCol Int32
type CellType
Exceptions
Exception | Condition
ArgumentException | A CellType.CustomField can't be set. -or- The given column number nCol is invalid.
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | This operation is forbidden for cells in standard schedule body sections.
See Also

Reference

TableSectionData Class
SetCellType Overload


TableSectionData.SetCellType(Int32, Int32, CellType) Method

TableSectionDataSetCellType(Int32, Int32, CellType) Method

Sets a cell's Type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetCellType(
    int nRow,
    int nCol,
    CellType type
)
Public Sub SetCellType (
    nRow As Integer,
    nCol As Integer,
    type As CellType
)
public:
void SetCellType(
    int nRow,
    int nCol,
    CellType type
)
member SetCellType :
        nRow : int *
        nCol : int *
        type : CellType -> unit

Parameters

nRow Int32
nCol Int32
type CellType
Exceptions
Exception | Condition
ArgumentException | A CellType.CustomField can't be set. -or- The given row number nRow is invalid. -or- The given column number nCol is invalid.
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | This operation is forbidden for cells in standard schedule body sections.
See Also

Reference

TableSectionData Class
SetCellType Overload


TableSectionData.SetColumnWidth Method

TableSectionDataSetColumnWidth Method

Sets a column's width in feet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetColumnWidth(
    int nCol,
    double width
)
Public Sub SetColumnWidth (
    nCol As Integer,
    width As Double
)
public:
void SetColumnWidth(
    int nCol,
    double width
)
member SetColumnWidth :
        nCol : int *
        width : float -> unit

Parameters

nCol Int32
width Double
Exceptions
Exception | Condition
ArgumentException | The given column number nCol is invalid. -or- The column width is outside of acceptable range.
See Also

Reference

TableSectionData Class


TableSectionData.SetColumnWidthInPixels Method

TableSectionDataSetColumnWidthInPixels Method

This sets a column's width in logical pixels

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetColumnWidthInPixels(
    int nCol,
    int width
)
Public Sub SetColumnWidthInPixels (
    nCol As Integer,
    width As Integer
)
public:
void SetColumnWidthInPixels(
    int nCol,
    int width
)
member SetColumnWidthInPixels :
        nCol : int *
        width : int -> unit

Parameters

nCol Int32
width Int32
Exceptions
Exception | Condition
ArgumentException | The given column number nCol is invalid. -or- The column width is outside of acceptable range.
See Also

Reference

TableSectionData Class


TableSectionData.SetMergedCell Method

TableSectionDataSetMergedCell Method

Sets the merged cell that this cell is a part of.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetMergedCell(
    int nRow,
    int nCol,
    TableMergedCell mergedCell
)
Public Sub SetMergedCell (
    nRow As Integer,
    nCol As Integer,
    mergedCell As TableMergedCell
)
public:
void SetMergedCell(
    int nRow,
    int nCol,
    TableMergedCell^ mergedCell
)
member SetMergedCell :
        nRow : int *
        nCol : int *
        mergedCell : TableMergedCell -> unit

Parameters

nRow Int32
The cell row.
nCol Int32
The cell column.
mergedCell TableMergedCell
Exceptions
Exception | Condition
ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid. -or- The given TableMergedCell mergedCell is outside of acceptable range.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This operation is forbidden for cells in standard schedule body sections.
See Also

Reference

TableSectionData Class


TableSectionData.SetRowHeight Method

TableSectionDataSetRowHeight Method

Sets a row's height in feet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetRowHeight(
    int nRow,
    double height
)
Public Sub SetRowHeight (
    nRow As Integer,
    height As Double
)
public:
void SetRowHeight(
    int nRow,
    double height
)
member SetRowHeight :
        nRow : int *
        height : float -> unit

Parameters

nRow Int32
height Double
Exceptions
Exception | Condition
ArgumentException | The given row number nRow is invalid. -or- The row height is outside of acceptable range.
InvalidOperationException | This operation is forbidden for cells in standard schedule body sections.
See Also

Reference

TableSectionData Class


TableSectionData.SetRowHeightInPixels Method

TableSectionDataSetRowHeightInPixels Method

This sets a row's height in logical pixels

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetRowHeightInPixels(
    int nRow,
    int height
)
Public Sub SetRowHeightInPixels (
    nRow As Integer,
    height As Integer
)
public:
void SetRowHeightInPixels(
    int nRow,
    int height
)
member SetRowHeightInPixels :
        nRow : int *
        height : int -> unit

Parameters

nRow Int32
height Int32
Exceptions
Exception | Condition
ArgumentException | The given row number nRow is invalid. -or- The row height is outside of acceptable range.
InvalidOperationException | This operation is forbidden for cells in standard schedule body sections.
See Also

Reference

TableSectionData Class


TableView Class

This represents a view that shows a table. Most of the layout data for the table is contained in the TableData class.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBView
Autodesk.Revit.DBTableView
Autodesk.Revit.DB.ElectricalPanelScheduleView
Autodesk.Revit.DBViewSchedule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TableView : View
Public Class TableView
    Inherits View
public ref class TableView : public View
type TableView =
    class
        inherit View
    end

The TableView type exposes the following members.

Properties
 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View)
Public property | AreAnalyticalModelCategoriesHidden | Indicates if analytical model categories are currently hidden in the view. (Inherited from View)
Public property | AreAnnotationCategoriesHidden | Indicates if annotation categories are currently hidden in the view. (Inherited from View)
Public property | AreCoordinationModelHandlesHidden | Indicates if Coordination Model handles are currently hidden in the view. (Inherited from View)
Public property | AreImportCategoriesHidden | Indicates if import categories are currently hidden in the view. (Inherited from View)
Public property | AreModelCategoriesHidden | Indicates if model categories are currently hidden in the view. (Inherited from View)
Public property | ArePointCloudsHidden | Indicates if point clouds are currently hidden in the view. (Inherited from View)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CropBox | The Crop Box applied to the view, or an outline encompassing the crop region applied to the view. (Inherited from View)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | DetailLevel | The detail level of this view. (Inherited from View)
Public property | Discipline | The Discipline of the view. (Inherited from View)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | GenLevel | The level for the view. (Inherited from View)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsAssemblyView | Indicates if the view is assembly view. (Inherited from View)
Public property | IsCallout | Indicates if the view is a callout view. (Inherited from View)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | MaximumColumnWidth | Gets the maximum column width
Public property | MaximumGridWidth | Gets the allowed maximum grid width
Public property | MaximumRowHeight | Gets the maximum row height
Public property | MinimumColumnWidth | Gets the minimum column width
Public property | MinimumRowHeight | Gets the minimum row height
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | Origin | Returns the origin of the screen. (Inherited from View)
Public property | Outline | The bounds of the view in paper space (in feet). (Inherited from View)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | RevealConstraintsMode | Indicates whether the Reveal Constraints mode is activated in the view. (Inherited from View)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View)
Public property | Scale | The scale of the view. (Inherited from View)
Public property | ShadowIntensity | The intesity of cast shadows - 0 = no shadows, 100 = black. (Inherited from View)
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View)
Public property | SunlightIntensity | The intensity of the simulated (directional) sunlight. 0 = no directional light; maximum value is 100. (Inherited from View)
Public property | TargetId | the element id of the element that is being viewed
Public property | TemporaryViewModes | Data of temporary view modes associated with this view. (Inherited from View)
Public property | Title | The view title. This consists of the view name plus other modifiers, such as the view type, sheet number, area scheme, and/or assembly type, depending on the specifics of the view. (Inherited from View)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | ViewTemplateId | The id of the template view that controls this view's parameters. (Inherited from View)
 | ViewType | The type of the view. (Inherited from View)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | AddFilter | Adds a filter to the view. (Inherited from View)
Public method | AllowsAnalysisDisplay | Identifies if this view allows display of Analysis results. (Inherited from View)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of the input view that are not controlled by the current view template. (Inherited from View)
Public method | AreGraphicsOverridesAllowed | Determines if Visibility/Graphics Overriddes can be applied to the view. (Inherited from View)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanApplyColorFillScheme | Checks if the id can be applied as the scheme id of specified category to this view. (Inherited from View)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanCategoryBeHidden | Checks whether the category can be hidden in the view. (Inherited from View)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanEnableTemporaryViewPropertiesMode | Indicates if Temporary View Properties mode can be applied for view in current state. (Inherited from View)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified (Inherited from View)
Public method | CanUseDepthCueing | Indicates if view can use Depth Cueing (Inherited from View)
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes (Inherited from View)
Public method | CanViewBeDuplicated | Identifies if this view can be duplicated. (Inherited from View)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View)
 | ConvertToIndependent | Convert the dependent view to independent. (Inherited from View)
Public method | CreateViewTemplate | Creates a new view template instance from this view instance. (Inherited from View)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View)
Public method | Dispose | (Inherited from Element)
 | Duplicate | Duplicates this view. (Inherited from View)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View)
Public method | EnableTemporaryViewPropertiesMode | Turns Temporary View Properties mode on or off. In this mode, any changes made to the view are temporary and will be discarded once the mode is disabled. (Inherited from View)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAvailableParameterCategories | Get all available parameter categories.
 | GetAvailableParameters | Gets a list of valid parameters for the specified category that can be used in the table view.
Public method | GetBackground | Returns the current background set for the view. (Inherited from View)
Public method | GetCalculatedValueName | Gets the calculated value name for a cell from the template view.
Public method | GetCalculatedValueText | Gets the calculated value text for a cell from the instance view.
Public method | GetCalloutParentId | Gets ID of the callout parent view. (Inherited from View)
Public method | GetCategoryHidden | Checks if elements of the given category are set to be invisible (hidden) in this view. (Inherited from View)
Public method | GetCategoryOverrides | Gets graphic overrides for a category in view. (Inherited from View)
Public method | GetCellText | Gets the cell's text based on its type
Public method | GetColorFillSchemeId | Returns id of the color fill scheme element applied to the view. (Inherited from View)
Public method | GetCropRegionShapeManager | Returns an object for managing view crop region shape. (Inherited from View)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View)
Public method | GetDepthCueing | Returns the current depth cueing settings for the view. (Inherited from View)
Public method | GetDirectContext3DHandleOverrides | Returns DirectContext3D handle overrides object for the view. (Inherited from View)
Public method | GetElementOverrides | Gets graphic overrides for an element in the view. (Inherited from View)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFilterOverrides | Gets graphic overrides that a filter applies to the view. (Inherited from View)
Public method | GetFilters | Gets the filters applied to the view. (Inherited from View)
Public method | GetFilterVisibility | Gets the visibility of the elements associated with a filter. (Inherited from View)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIsFilterEnabled | Identifies if the filter is enabled in this view. (Inherited from View)
 | GetLinkOverrides | Gets the graphic overrides of a RevitLinkType or RevitLinkInstance in view. (Inherited from View)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetModelToProjectionTransforms | Gets the transforms from the model space to the view projection space. (Inherited from View)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetNonControlledTemplateParameterIds | Returns a list of parameters that are not marked as included when this view is used as a template. (Inherited from View)
Public method | GetOrderedFilters | Gets the filters applied to the view in the order they are applied. (Inherited from View)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPlacementOnSheetStatus | Determines if this view placed on a sheet completely or partially. (Inherited from View)
Public method | GetPointCloudOverrides | Returns point cloud overrides object for the view. (Inherited from View)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View)
Public method | GetReferenceCallouts | Returns element ids of all reference callouts in the view. (Inherited from View)
Public method | GetReferenceElevations | Returns element ids of all reference elevations in the view. (Inherited from View)
Public method | GetReferenceSections | Returns element ids of all reference sections in the view. (Inherited from View)
Public method | GetSketchyLines | Returns the current sketchy lines settings for the view. (Inherited from View)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTemplateParameterIds | Returns a list of parameter ids that may be controlled when this view is assigned as a template. (Inherited from View)
Public method | GetTemporaryViewPropertiesId | When Temporary View Properties mode is in progress it provides view id that overrode settings for current view. Outside Temporary View Properties mode InvalidElementId will be returned. (Inherited from View)
Public method | GetTemporaryViewPropertiesName | When Temporary View Properties mode is in progress, name of applied template is returned. Outside Temporary View Properties mode, empty string will be returned. (Inherited from View)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetViewDisplayModel | Returns the current view display model settings for the view. (Inherited from View)
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View)
Public method | HasDetailLevel | Check if the view has a Detail Level property (Inherited from View)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property (Inherited from View)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property (Inherited from View)
Public method | HasViewTransforms | Returns true if the view reports model space to view projection space transforms. (Inherited from View)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View)
Public method | IsCategoryOverridable | Checks whether the category can have graphic overrides in this view. (Inherited from View)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsFilterApplied | Indicates if a filter is applied to the view. (Inherited from View)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View)
Public method | IsTemporaryViewPropertiesModeEnabled | Returns true when Temporary View Properties mode is in progress, false otherwise. (Inherited from View)
Public method | IsValidSectionType | Identifies if the section type is valid for this view.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | IsValidViewTemplate | Verifies that the view represented by templateId can be set as the controlling view template for this view. (Inherited from View)
Public method | IsViewValidForTemplateCreation | Verifies that the view is valid for template creation. (Inherited from View)
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | Print | Print this view with the default view template and using the print setting of the current active document. (Inherited from View)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveCalloutParent | Replaces callout parent ID with InvalidElementId. (Inherited from View)
Public method | RemoveFilter | Removes a filter from the view. (Inherited from View)
 | RemoveLinkOverrides | Deletes the graphical link overrides in the current view. (Inherited from View)
Public method | RestoreCalloutParent | Restores callout parent ID to the original view ID if that view is still available. (Inherited from View)
Public method | SetBackground | Sets the background for the view. Background can only be set for 3d views and for Sections/Elevations. (Inherited from View)
Public method | SetCategoryHidden | Sets if elements of the given category will be visible in this view. (Inherited from View)
Public method | SetCategoryOverrides | Sets graphic overrides for a category in view. (Inherited from View)
Public method | SetColorFillSchemeId | Applies color fill scheme to this view. (Inherited from View)
Public method | SetDepthCueing | Sets the depth cueing settings for the view. (Inherited from View)
Public method | SetElementOverrides | Sets graphic overrides for an element in the view. (Inherited from View)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
 | SetFilterOverrides | Sets the overrides associated with a filter. (Inherited from View)
Public method | SetFilterVisibility | Sets the visibility of the elements associated with a filter. (Inherited from View)
Public method | SetIsFilterEnabled | Sets the filter enabled flag. (Inherited from View)
 | SetLinkOverrides | Sets the graphic overrides of a RevitLinkType or RevitLinkInstance in the view. (Inherited from View)
Public method | SetNonControlledTemplateParameterIds | Sets the parameters that will not be included when this view is used as a template. (Inherited from View)
Public method | SetSketchyLines | Sets the sketchy lines settings for the view. (Inherited from View)
Public method | SetViewDisplayModel | Sets the view display model settings for the view. (Inherited from View)
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View)
 | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View)
Public method | SupportedColorFillCategoryIds | Returns collection of all category ids that correspond to elements that can potentially be colored in this view according to a color fill scheme. The set may be different depending on the view type. (Inherited from View)
Public method | SupportsRevealConstraints | Checks that the view can have the Reveal Constraints mode activated. (Inherited from View)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TableView Properties

The TableView type exposes the following members.

Properties
 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View)
Public property | AreAnalyticalModelCategoriesHidden | Indicates if analytical model categories are currently hidden in the view. (Inherited from View)
Public property | AreAnnotationCategoriesHidden | Indicates if annotation categories are currently hidden in the view. (Inherited from View)
Public property | AreCoordinationModelHandlesHidden | Indicates if Coordination Model handles are currently hidden in the view. (Inherited from View)
Public property | AreImportCategoriesHidden | Indicates if import categories are currently hidden in the view. (Inherited from View)
Public property | AreModelCategoriesHidden | Indicates if model categories are currently hidden in the view. (Inherited from View)
Public property | ArePointCloudsHidden | Indicates if point clouds are currently hidden in the view. (Inherited from View)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CropBox | The Crop Box applied to the view, or an outline encompassing the crop region applied to the view. (Inherited from View)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | DetailLevel | The detail level of this view. (Inherited from View)
Public property | Discipline | The Discipline of the view. (Inherited from View)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | GenLevel | The level for the view. (Inherited from View)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsAssemblyView | Indicates if the view is assembly view. (Inherited from View)
Public property | IsCallout | Indicates if the view is a callout view. (Inherited from View)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | MaximumColumnWidth | Gets the maximum column width
Public property | MaximumGridWidth | Gets the allowed maximum grid width
Public property | MaximumRowHeight | Gets the maximum row height
Public property | MinimumColumnWidth | Gets the minimum column width
Public property | MinimumRowHeight | Gets the minimum row height
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | Origin | Returns the origin of the screen. (Inherited from View)
Public property | Outline | The bounds of the view in paper space (in feet). (Inherited from View)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | RevealConstraintsMode | Indicates whether the Reveal Constraints mode is activated in the view. (Inherited from View)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View)
Public property | Scale | The scale of the view. (Inherited from View)
Public property | ShadowIntensity | The intesity of cast shadows - 0 = no shadows, 100 = black. (Inherited from View)
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View)
Public property | SunlightIntensity | The intensity of the simulated (directional) sunlight. 0 = no directional light; maximum value is 100. (Inherited from View)
Public property | TargetId | the element id of the element that is being viewed
Public property | TemporaryViewModes | Data of temporary view modes associated with this view. (Inherited from View)
Public property | Title | The view title. This consists of the view name plus other modifiers, such as the view type, sheet number, area scheme, and/or assembly type, depending on the specifics of the view. (Inherited from View)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | ViewTemplateId | The id of the template view that controls this view's parameters. (Inherited from View)
 | ViewType | The type of the view. (Inherited from View)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

TableView Class


TableView.MaximumColumnWidth Property

TableViewMaximumColumnWidth Property

Gets the maximum column width

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int MaximumColumnWidth { get; }
Public ReadOnly Property MaximumColumnWidth As Integer
    Get
public:
property int MaximumColumnWidth {
    int get ();
}
member MaximumColumnWidth : int with get

Property Value

Int32
See Also

Reference

TableView Class


TableView.MaximumGridWidth Property

TableViewMaximumGridWidth Property

Gets the allowed maximum grid width

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int MaximumGridWidth { get; }
Public ReadOnly Property MaximumGridWidth As Integer
    Get
public:
property int MaximumGridWidth {
    int get ();
}
member MaximumGridWidth : int with get

Property Value

Int32
See Also

Reference

TableView Class


TableView.MaximumRowHeight Property

TableViewMaximumRowHeight Property

Gets the maximum row height

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int MaximumRowHeight { get; }
Public ReadOnly Property MaximumRowHeight As Integer
    Get
public:
property int MaximumRowHeight {
    int get ();
}
member MaximumRowHeight : int with get

Property Value

Int32
See Also

Reference

TableView Class


TableView.MinimumColumnWidth Property

TableViewMinimumColumnWidth Property

Gets the minimum column width

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int MinimumColumnWidth { get; }
Public ReadOnly Property MinimumColumnWidth As Integer
    Get
public:
property int MinimumColumnWidth {
    int get ();
}
member MinimumColumnWidth : int with get

Property Value

Int32
See Also

Reference

TableView Class


TableView.MinimumRowHeight Property

TableViewMinimumRowHeight Property

Gets the minimum row height

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int MinimumRowHeight { get; }
Public ReadOnly Property MinimumRowHeight As Integer
    Get
public:
property int MinimumRowHeight {
    int get ();
}
member MinimumRowHeight : int with get

Property Value

Int32
See Also

Reference

TableView Class


TableView.TargetId Property

TableViewTargetId Property

the element id of the element that is being viewed

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId TargetId { get; set; }
Public Property TargetId As ElementId
    Get
    Set
public:
property ElementId^ TargetId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member TargetId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

TableView Class


TableView Methods

The TableView type exposes the following members.

Methods
 | Name | Description
Public method | AddFilter | Adds a filter to the view. (Inherited from View)
Public method | AllowsAnalysisDisplay | Identifies if this view allows display of Analysis results. (Inherited from View)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of the input view that are not controlled by the current view template. (Inherited from View)
Public method | AreGraphicsOverridesAllowed | Determines if Visibility/Graphics Overriddes can be applied to the view. (Inherited from View)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanApplyColorFillScheme | Checks if the id can be applied as the scheme id of specified category to this view. (Inherited from View)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanCategoryBeHidden | Checks whether the category can be hidden in the view. (Inherited from View)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanEnableTemporaryViewPropertiesMode | Indicates if Temporary View Properties mode can be applied for view in current state. (Inherited from View)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified (Inherited from View)
Public method | CanUseDepthCueing | Indicates if view can use Depth Cueing (Inherited from View)
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes (Inherited from View)
Public method | CanViewBeDuplicated | Identifies if this view can be duplicated. (Inherited from View)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View)
 | ConvertToIndependent | Convert the dependent view to independent. (Inherited from View)
Public method | CreateViewTemplate | Creates a new view template instance from this view instance. (Inherited from View)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View)
Public method | Dispose | (Inherited from Element)
 | Duplicate | Duplicates this view. (Inherited from View)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View)
Public method | EnableTemporaryViewPropertiesMode | Turns Temporary View Properties mode on or off. In this mode, any changes made to the view are temporary and will be discarded once the mode is disabled. (Inherited from View)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAvailableParameterCategories | Get all available parameter categories.
 | GetAvailableParameters | Gets a list of valid parameters for the specified category that can be used in the table view.
Public method | GetBackground | Returns the current background set for the view. (Inherited from View)
Public method | GetCalculatedValueName | Gets the calculated value name for a cell from the template view.
Public method | GetCalculatedValueText | Gets the calculated value text for a cell from the instance view.
Public method | GetCalloutParentId | Gets ID of the callout parent view. (Inherited from View)
Public method | GetCategoryHidden | Checks if elements of the given category are set to be invisible (hidden) in this view. (Inherited from View)
Public method | GetCategoryOverrides | Gets graphic overrides for a category in view. (Inherited from View)
Public method | GetCellText | Gets the cell's text based on its type
Public method | GetColorFillSchemeId | Returns id of the color fill scheme element applied to the view. (Inherited from View)
Public method | GetCropRegionShapeManager | Returns an object for managing view crop region shape. (Inherited from View)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View)
Public method | GetDepthCueing | Returns the current depth cueing settings for the view. (Inherited from View)
Public method | GetDirectContext3DHandleOverrides | Returns DirectContext3D handle overrides object for the view. (Inherited from View)
Public method | GetElementOverrides | Gets graphic overrides for an element in the view. (Inherited from View)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFilterOverrides | Gets graphic overrides that a filter applies to the view. (Inherited from View)
Public method | GetFilters | Gets the filters applied to the view. (Inherited from View)
Public method | GetFilterVisibility | Gets the visibility of the elements associated with a filter. (Inherited from View)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIsFilterEnabled | Identifies if the filter is enabled in this view. (Inherited from View)
 | GetLinkOverrides | Gets the graphic overrides of a RevitLinkType or RevitLinkInstance in view. (Inherited from View)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetModelToProjectionTransforms | Gets the transforms from the model space to the view projection space. (Inherited from View)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetNonControlledTemplateParameterIds | Returns a list of parameters that are not marked as included when this view is used as a template. (Inherited from View)
Public method | GetOrderedFilters | Gets the filters applied to the view in the order they are applied. (Inherited from View)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPlacementOnSheetStatus | Determines if this view placed on a sheet completely or partially. (Inherited from View)
Public method | GetPointCloudOverrides | Returns point cloud overrides object for the view. (Inherited from View)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View)
Public method | GetReferenceCallouts | Returns element ids of all reference callouts in the view. (Inherited from View)
Public method | GetReferenceElevations | Returns element ids of all reference elevations in the view. (Inherited from View)
Public method | GetReferenceSections | Returns element ids of all reference sections in the view. (Inherited from View)
Public method | GetSketchyLines | Returns the current sketchy lines settings for the view. (Inherited from View)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTemplateParameterIds | Returns a list of parameter ids that may be controlled when this view is assigned as a template. (Inherited from View)
Public method | GetTemporaryViewPropertiesId | When Temporary View Properties mode is in progress it provides view id that overrode settings for current view. Outside Temporary View Properties mode InvalidElementId will be returned. (Inherited from View)
Public method | GetTemporaryViewPropertiesName | When Temporary View Properties mode is in progress, name of applied template is returned. Outside Temporary View Properties mode, empty string will be returned. (Inherited from View)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetViewDisplayModel | Returns the current view display model settings for the view. (Inherited from View)
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View)
Public method | HasDetailLevel | Check if the view has a Detail Level property (Inherited from View)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property (Inherited from View)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property (Inherited from View)
Public method | HasViewTransforms | Returns true if the view reports model space to view projection space transforms. (Inherited from View)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View)
Public method | IsCategoryOverridable | Checks whether the category can have graphic overrides in this view. (Inherited from View)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsFilterApplied | Indicates if a filter is applied to the view. (Inherited from View)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View)
Public method | IsTemporaryViewPropertiesModeEnabled | Returns true when Temporary View Properties mode is in progress, false otherwise. (Inherited from View)
Public method | IsValidSectionType | Identifies if the section type is valid for this view.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | IsValidViewTemplate | Verifies that the view represented by templateId can be set as the controlling view template for this view. (Inherited from View)
Public method | IsViewValidForTemplateCreation | Verifies that the view is valid for template creation. (Inherited from View)
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | Print | Print this view with the default view template and using the print setting of the current active document. (Inherited from View)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveCalloutParent | Replaces callout parent ID with InvalidElementId. (Inherited from View)
Public method | RemoveFilter | Removes a filter from the view. (Inherited from View)
 | RemoveLinkOverrides | Deletes the graphical link overrides in the current view. (Inherited from View)
Public method | RestoreCalloutParent | Restores callout parent ID to the original view ID if that view is still available. (Inherited from View)
Public method | SetBackground | Sets the background for the view. Background can only be set for 3d views and for Sections/Elevations. (Inherited from View)
Public method | SetCategoryHidden | Sets if elements of the given category will be visible in this view. (Inherited from View)
Public method | SetCategoryOverrides | Sets graphic overrides for a category in view. (Inherited from View)
Public method | SetColorFillSchemeId | Applies color fill scheme to this view. (Inherited from View)
Public method | SetDepthCueing | Sets the depth cueing settings for the view. (Inherited from View)
Public method | SetElementOverrides | Sets graphic overrides for an element in the view. (Inherited from View)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
 | SetFilterOverrides | Sets the overrides associated with a filter. (Inherited from View)
Public method | SetFilterVisibility | Sets the visibility of the elements associated with a filter. (Inherited from View)
Public method | SetIsFilterEnabled | Sets the filter enabled flag. (Inherited from View)
 | SetLinkOverrides | Sets the graphic overrides of a RevitLinkType or RevitLinkInstance in the view. (Inherited from View)
Public method | SetNonControlledTemplateParameterIds | Sets the parameters that will not be included when this view is used as a template. (Inherited from View)
Public method | SetSketchyLines | Sets the sketchy lines settings for the view. (Inherited from View)
Public method | SetViewDisplayModel | Sets the view display model settings for the view. (Inherited from View)
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View)
 | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View)
Public method | SupportedColorFillCategoryIds | Returns collection of all category ids that correspond to elements that can potentially be colored in this view according to a color fill scheme. The set may be different depending on the view type. (Inherited from View)
Public method | SupportsRevealConstraints | Checks that the view can have the Reveal Constraints mode activated. (Inherited from View)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View)
Top
See Also

Reference

TableView Class


TableView.GetAvailableParameterCategories Method

TableViewGetAvailableParameterCategories Method

Get all available parameter categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ElementId> GetAvailableParameterCategories(
    SectionType sectionType,
    int row
)
Public Function GetAvailableParameterCategories (
    sectionType As SectionType,
    row As Integer
) As IList(Of ElementId)
public:
IList<ElementId^>^ GetAvailableParameterCategories(
    SectionType sectionType,
    int row
)
member GetAvailableParameterCategories :
        sectionType : SectionType *
        row : int -> IList<ElementId>

Parameters

sectionType SectionType
The section the row lies in.
row Int32
The row.

Return Value

IList ElementId
The available parameter categories.
Exceptions
Exception | Condition
ArgumentException | The sectionType is not a valid type for this view.
ArgumentOutOfRangeException | The given row number row is invalid. -or- A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

TableView Class


TableView.GetAvailableParameters Method

TableViewGetAvailableParameters Method

Gets a list of valid parameters for the specified category that can be used in the table view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<ElementId> GetAvailableParameters(
    Document cda,
    ElementId categoryId
)
Public Shared Function GetAvailableParameters (
    cda As Document,
    categoryId As ElementId
) As IList(Of ElementId)
public:
static IList<ElementId^>^ GetAvailableParameters(
    Document^ cda,
    ElementId^ categoryId
)
static member GetAvailableParameters :
        cda : Document *
        categoryId : ElementId -> IList<ElementId>

Parameters

cda Document
The document.
categoryId ElementId
The specified element category id.

Return Value

IList ElementId
The IDs of all valid parameters.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

TableView Class


TableView.GetCalculatedValueName Method

TableViewGetCalculatedValueName Method

Gets the calculated value name for a cell from the template view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetCalculatedValueName(
    SectionType sectionType,
    int row,
    int column
)
Public Function GetCalculatedValueName (
    sectionType As SectionType,
    row As Integer,
    column As Integer
) As String
public:
String^ GetCalculatedValueName(
    SectionType sectionType,
    int row,
    int column
)
member GetCalculatedValueName :
        sectionType : SectionType *
        row : int *
        column : int -> string

Parameters

sectionType SectionType
The section type.
row Int32
The row.
column Int32
The column.

Return Value

String
The name of the calculated value.
Exceptions
Exception | Condition
ArgumentException | The sectionType is not a valid type for this view.
ArgumentOutOfRangeException | The given row number row is invalid. -or- The given column number column is invalid. -or- A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

TableView Class


TableView.GetCalculatedValueText Method

TableViewGetCalculatedValueText Method

Gets the calculated value text for a cell from the instance view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetCalculatedValueText(
    SectionType sectionType,
    int row,
    int column
)
Public Function GetCalculatedValueText (
    sectionType As SectionType,
    row As Integer,
    column As Integer
) As String
public:
String^ GetCalculatedValueText(
    SectionType sectionType,
    int row,
    int column
)
member GetCalculatedValueText :
        sectionType : SectionType *
        row : int *
        column : int -> string

Parameters

sectionType SectionType
The section type.
row Int32
The row.
column Int32
The column.

Return Value

String
The calculated value text.
Exceptions
Exception | Condition
ArgumentException | The sectionType is not a valid type for this view.
ArgumentOutOfRangeException | The given row number row is invalid. -or- The given column number column is invalid. -or- A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

TableView Class


TableView.GetCellText Method

TableViewGetCellText Method

Gets the cell's text based on its type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetCellText(
    SectionType sectionType,
    int row,
    int column
)
Public Function GetCellText (
    sectionType As SectionType,
    row As Integer,
    column As Integer
) As String
public:
String^ GetCellText(
    SectionType sectionType,
    int row,
    int column
)
member GetCellText :
        sectionType : SectionType *
        row : int *
        column : int -> string

Parameters

sectionType SectionType
The requested section type
row Int32
Row Number in the Section
column Int32
Column Number in the Section

Return Value

String
The text for the given cell
Exceptions
Exception | Condition
ArgumentException | The sectionType is not a valid type for this view.
ArgumentOutOfRangeException | The given row number row is invalid. -or- The given column number column is invalid. -or- A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

TableView Class


TableView.IsValidSectionType Method

TableViewIsValidSectionType Method

Identifies if the section type is valid for this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidSectionType(
    SectionType sectionType
)
Public Function IsValidSectionType (
    sectionType As SectionType
) As Boolean
public:
bool IsValidSectionType(
    SectionType sectionType
)
member IsValidSectionType :
        sectionType : SectionType -> bool

Parameters

sectionType SectionType
The section type.

Return Value

Boolean
True if the Section Type is valid, false otherwise.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Remarks
Some TableViews do not contain all of the possible section types. For example, standard schedules have only a Heading and Body.
See Also

Reference

TableView Class


TagHeadAlignment Enumeration

An enumerated type listing the tag-head alignment options supported by the Bending Detail.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum TagHeadAlignment
Public Enumeration TagHeadAlignment
public enum class TagHeadAlignment
type TagHeadAlignment
Members
Member name | Value | Description
RebarShapeFamily | 0 | The tag-head is aligned using the rebar shape family direction.
View | 1 | The tag-head is aligned using the view.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TagHeadPositionOptions Enumeration

An enumerated type listing the tag-head position options supported by the Bending Detail.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum TagHeadPositionOptions
Public Enumeration TagHeadPositionOptions
public enum class TagHeadPositionOptions
type TagHeadPositionOptions
Members
Member name | Value | Description
Top | 0 | The tag-head position is at the top of the Bending Detial.
Bottom | 1 | The tag-head position is at the bottom of the Bending Detial.
Right | 2 | The tag-head position is at the right of the Bending Detial.
Left | 3 | The tag-head position is at the left of the Bending Detial.
Center | 4 | The tag-head position is at the center of the Bending Detial.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TagMode Enumeration

The modes of tag creation that are supported for IndependentTags.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum TagMode
Public Enumeration TagMode
public enum class TagMode
type TagMode
Members
Member name | Value | Description
TM_ADDBY_CATEGORY | 0 | Add a single category tag.
TM_ADDBY_MULTICATEGORY | 1 | Add a multi-category tag.
TM_ADDBY_MATERIAL | 2 | Add a material tag.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TagOrientation Enumeration

An enumerated type listing tag orientation options that are supported by IndependentTags.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum TagOrientation
Public Enumeration TagOrientation
public enum class TagOrientation
type TagOrientation
Members
Member name | Value | Description
Horizontal | 0 | The Orientation of tag is Horizontal.
Vertical | 1 | The Orientation of tag is Vertical.
AnyModelDirection | 2 | The orientation of tag is Model.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TagOrientationBehavior Enumeration

This attribute describes the family orientation behavior.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum TagOrientationBehavior
Public Enumeration TagOrientationBehavior
public enum class TagOrientationBehavior
type TagOrientationBehavior
Members
Member name | Value | Description
Fixed | 0 |
RotateWithHost | 1 |
RotateAndStayUpright | 2 |
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TemporaryGraphicsManager Class

A class that provides functionality to create temporary graphics in a Revit model.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBTemporaryGraphicsManager

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TemporaryGraphicsManager : IDisposable
Public Class TemporaryGraphicsManager
    Implements IDisposable
public ref class TemporaryGraphicsManager : IDisposable
type TemporaryGraphicsManager =
    class
        interface IDisposable
    end

The TemporaryGraphicsManager type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | AddControl | Creates an in-canvas control.
Public method | Clear | Clear all temporary graphics objects managed by this manager.
Public method | Dispose | Releases all resources used by the TemporaryGraphicsManager
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAll | Returns all temporary graphics object indexes managed by this manager.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
 | GetTemporaryGraphicsManager | Gets a TemporaryGraphicsManager reference of the document.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | RemoveControl | Deletes the existing control identified by the unique index.
Public method | SetVisibility | Changes the visibility of temporary graphics object.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UpdateControl | Updates the in-canvas control identified by the unique index.
Top
Remarks

The graphics created by this class are temporary or transient. They are not subject to undo and are not saved. It's caller's responsiblity to manage their lifetime, creation and destruction, though Revit will destroy all of them when closing the model.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TemporaryGraphicsManager Properties

The TemporaryGraphicsManager type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

TemporaryGraphicsManager Class


TemporaryGraphicsManager.IsValidObject Property

TemporaryGraphicsManagerIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

TemporaryGraphicsManager Class


TemporaryGraphicsManager Methods

The TemporaryGraphicsManager type exposes the following members.

Methods
 | Name | Description
Public method | AddControl | Creates an in-canvas control.
Public method | Clear | Clear all temporary graphics objects managed by this manager.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAll | Returns all temporary graphics object indexes managed by this manager.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
 | GetTemporaryGraphicsManager | Gets a TemporaryGraphicsManager reference of the document.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | RemoveControl | Deletes the existing control identified by the unique index.
Public method | SetVisibility | Changes the visibility of temporary graphics object.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UpdateControl | Updates the in-canvas control identified by the unique index.
Top
See Also

Reference

TemporaryGraphicsManager Class


TemporaryGraphicsManager.AddControl Method

TemporaryGraphicsManagerAddControl Method

Creates an in-canvas control.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int AddControl(
    InCanvasControlData data,
    ElementId ownerViewId
)
Public Function AddControl (
    data As InCanvasControlData,
    ownerViewId As ElementId
) As Integer
public:
int AddControl(
    InCanvasControlData^ data,
    ElementId^ ownerViewId
)
member AddControl :
        data : InCanvasControlData *
        ownerViewId : ElementId -> int

Parameters

data InCanvasControlData
Data to generate in-canvas control appearance.
ownerViewId ElementId
The view in which the control appears. It will show in all views if the id is invalidElementId.

Return Value

Int32
Unique index of control for future references.
Exceptions
Exception | Condition
ArgumentException | The ownerViewId provided is not an id of a view.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Failed to load the image from specified path.
Remarks

This method can perform drawing an image (supplied by the caller) as an in-canvas control in the view(s). The control can react on click by invoking a callback defined in [!:Autodesk::Revit::UI::ITemporaryGraphicsHandler::OnClick(TemporaryGraphicsCommandData)]. The caller can use the returned index to update the control (changing image/location), delete and change visibility (hide/unhide) in response to any events later.

See Also

Reference

TemporaryGraphicsManager Class


TemporaryGraphicsManager.Clear Method

TemporaryGraphicsManagerClear Method

Clear all temporary graphics objects managed by this manager.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

TemporaryGraphicsManager Class


TemporaryGraphicsManager.Dispose Method

TemporaryGraphicsManagerDispose Method

Releases all resources used by the TemporaryGraphicsManager

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

TemporaryGraphicsManager Class


TemporaryGraphicsManager.GetAll Method

TemporaryGraphicsManagerGetAll Method

Returns all temporary graphics object indexes managed by this manager.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<int> GetAll()
Public Function GetAll As ICollection(Of Integer)
public:
ICollection<int>^ GetAll()
member GetAll : unit -> ICollection<int>

Return Value

ICollection Int32
Collection of temporary graphics object indexes managed by this manager.
See Also

Reference

TemporaryGraphicsManager Class


TemporaryGraphicsManager.GetTemporaryGraphicsManager Method

TemporaryGraphicsManagerGetTemporaryGraphicsManager Method

Gets a TemporaryGraphicsManager reference of the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static TemporaryGraphicsManager GetTemporaryGraphicsManager(
    Document document
)
Public Shared Function GetTemporaryGraphicsManager (
    document As Document
) As TemporaryGraphicsManager
public:
static TemporaryGraphicsManager^ GetTemporaryGraphicsManager(
    Document^ document
)
static member GetTemporaryGraphicsManager :
        document : Document -> TemporaryGraphicsManager

Parameters

document Document
The document.

Return Value

TemporaryGraphicsManager
Instance of TemporaryGraphicsManager.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

TemporaryGraphicsManager Class


TemporaryGraphicsManager.RemoveControl Method

TemporaryGraphicsManagerRemoveControl Method

Deletes the existing control identified by the unique index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveControl(
    int index
)
Public Sub RemoveControl (
    index As Integer
)
public:
void RemoveControl(
    int index
)
member RemoveControl :
        index : int -> unit

Parameters

index Int32
Unique index of the control to be deleted.
Exceptions
Exception | Condition
ArgumentException | index is out of range of TemporaryGraphicsManager managed objects, or the indexed object has been removed from the document.
See Also

Reference

TemporaryGraphicsManager Class


TemporaryGraphicsManager.SetVisibility Method

TemporaryGraphicsManagerSetVisibility Method

Changes the visibility of temporary graphics object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetVisibility(
    int index,
    bool visible
)
Public Sub SetVisibility (
    index As Integer,
    visible As Boolean
)
public:
void SetVisibility(
    int index,
    bool visible
)
member SetVisibility :
        index : int *
        visible : bool -> unit

Parameters

index Int32
Unique index of the temporary graphics object to be updated.
visible Boolean
if true, it will make the temporary graphics object visible. if false, it will make the temporary graphics object invisible.
Exceptions
Exception | Condition
ArgumentException | index is out of range of TemporaryGraphicsManager managed objects, or the indexed object has been removed from the document.
See Also

Reference

TemporaryGraphicsManager Class


TemporaryGraphicsManager.UpdateControl Method

TemporaryGraphicsManagerUpdateControl Method

Updates the in-canvas control identified by the unique index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void UpdateControl(
    int index,
    InCanvasControlData data
)
Public Sub UpdateControl (
    index As Integer,
    data As InCanvasControlData
)
public:
void UpdateControl(
    int index,
    InCanvasControlData^ data
)
member UpdateControl :
        index : int *
        data : InCanvasControlData -> unit

Parameters

index Int32
Unique index of the control to be updated.
data InCanvasControlData
data to generate in-canvas control appearance.
Exceptions
Exception | Condition
ArgumentException | index is out of range of TemporaryGraphicsManager managed objects, or the indexed object has been removed from the document.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Failed to load the image from specified path.
See Also

Reference

TemporaryGraphicsManager Class


TemporaryViewMode Enumeration

Enumeration to represent the various temporary view modes a view can be in.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum TemporaryViewMode
Public Enumeration TemporaryViewMode
public enum class TemporaryViewMode
type TemporaryViewMode
Members
Member name | Value | Description
RevealHiddenElements | 1 | The view is in reveal hidden elements mode
TemporaryHideIsolate | 2 | The view is in temporary hide/isolate mode
WorksharingDisplay | 3 | The view is in one of the worksharing display modes
TemporaryViewProperties | 4 | The view is in the selected View Properties applied temporarily.
ExplodedView | 6 | The view is in the mode that shows the model in exploded view and allows user changes/configurations
RevealConstraints | 7 | The view is in the mode that reveals constraints between elements in the model.
PreviewFamilyVisibility | 8 | The view is in the mode that shows visibility settings applied in the environment of a family document.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TemporaryViewModes Class

A data structure containing data related to temporary view modes.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBTemporaryViewModes

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TemporaryViewModes : APIObject
Public Class TemporaryViewModes
    Inherits APIObject
public ref class TemporaryViewModes : public APIObject
type TemporaryViewModes =
    class
        inherit APIObject
    end

The TemporaryViewModes type exposes the following members.

Properties
 | Name | Description
Public property | CustomColor | Custom color for the TemporaryViewProperties mode.
Public property | CustomTitle | Custom title for the TemporaryViewProperties mode.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
 | PreviewFamilyVisibility | The current state of the PreviewFamilyVisibility mode in the associated view.
 | PreviewFamilyVisibilityDefaultOnState | Controls the default state of the PreviewFamilyVisibility mode in all views.
 | PreviewFamilyVisibilityDefaultUncutState | Controls the default type of the On state of the PreviewFamilyVisibility mode in cut-able views.
Public property | RevealConstraints | The current state of the RevealConstraints mode in the associated view.
Public property | RevealHiddenElements | The current state of the RevealHiddenElements mode in the associated view.
Public property | WorksharingDisplay | The current state of the WorksharingDisplay mode in the associated view.
Top
Methods
 | Name | Description
Public method | DeactivateAllModes | Deactivates all temporary modes that are currently active.
Public method | DeactivateMode | Deactivates the given temporary mode.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCaption | A text caption to use for the given mode.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsCustomized | Identifies if a custom temporary view mode is currently active. A custom mode is active if there is a non-empty string set for CustomTitle.
Public method | IsModeActive | Tests whether a given mode is currently active or not.
Public method | IsModeAvailable | Tests whether a temporary view mode is currently available in the associated view.
Public method | IsModeEnabled | Tests whether a temporary view mode is currently enabled in the associated view.
Public method | IsValidState | Tests whether the given state is valid for the associated view and the context the view is currently in.
Public method | RemoveCustomization | Removes all customized values for the TemporaryViewProperties mode.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

The class contains methods and properties to manipulate states of various temporary view modes that may or may not be avilable in any of visible views of a Revit document. The temporary modes are enumerated in the TemporaryViewMode class.

Every view that supports temporary view modes owns an instance of this TemporaryViewModes class, which can be obtained by accessing the TemporaryViewModes property of the View class. Note that views which do not support temporary modes will have that property's value be Null.

Multiple temporary view modes can coexist. Also, TemporaryViewProperties mode can be customized to display custom title and custom color. Setting custom title and color affects only TemporaryViewProperties mode for the specific view.

  • CustomTitle
  • CustomColor
  • IsCustomized
  • RemoveCustomization

Example
C#
VB
C++
F#
Copy
public bool RevealHiddenElementsInView(View view)
{
    bool hiddenRevealed = false;
    TemporaryViewModes viewModes = view.TemporaryViewModes;

    if (viewModes == null)
    {
        TaskDialog.Show("Invalid View", "This view does not support temporary view modes.");
    }
    else
    {
        // Mode must be available and enabled to be activated
        if (viewModes.IsModeEnabled(TemporaryViewMode.RevealHiddenElements) && viewModes.IsModeAvailable(TemporaryViewMode.RevealHiddenElements))
        {
            viewModes.RevealHiddenElements = true;
            hiddenRevealed = viewModes.RevealHiddenElements;
        }
    }

    return hiddenRevealed;
}
Public Function RevealHiddenElementsInView(view As View) As Boolean
    Dim hiddenRevealed As Boolean = False
    Dim viewModes As TemporaryViewModes = view.TemporaryViewModes

    If viewModes Is Nothing Then
        TaskDialog.Show("Invalid View", "This view does not support temporary view modes.")
    Else
        ' Mode must be available and enabled to be activated
        If viewModes.IsModeEnabled(TemporaryViewMode.RevealHiddenElements) AndAlso viewModes.IsModeAvailable(TemporaryViewMode.RevealHiddenElements) Then
            viewModes.RevealHiddenElements = True
            hiddenRevealed = viewModes.RevealHiddenElements
        End If
    End If

    Return hiddenRevealed
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TemporaryViewModes Properties

The TemporaryViewModes type exposes the following members.

Properties
 | Name | Description
Public property | CustomColor | Custom color for the TemporaryViewProperties mode.
Public property | CustomTitle | Custom title for the TemporaryViewProperties mode.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
 | PreviewFamilyVisibility | The current state of the PreviewFamilyVisibility mode in the associated view.
 | PreviewFamilyVisibilityDefaultOnState | Controls the default state of the PreviewFamilyVisibility mode in all views.
 | PreviewFamilyVisibilityDefaultUncutState | Controls the default type of the On state of the PreviewFamilyVisibility mode in cut-able views.
Public property | RevealConstraints | The current state of the RevealConstraints mode in the associated view.
Public property | RevealHiddenElements | The current state of the RevealHiddenElements mode in the associated view.
Public property | WorksharingDisplay | The current state of the WorksharingDisplay mode in the associated view.
Top
See Also

Reference

TemporaryViewModes Class


TemporaryViewModes.CustomColor Property

TemporaryViewModesCustomColor Property

Custom color for the TemporaryViewProperties mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color CustomColor { get; set; }
Public Property CustomColor As Color
    Get
    Set
public:
property Color^ CustomColor {
    Color^ get ();
    void set (Color^ value);
}
member CustomColor : Color with get, set

Property Value

Color
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
If custom title is not empty, Temporary View Properties mode displays the colored view frame in custom color.
See Also

Reference

TemporaryViewModes Class


TemporaryViewModes.CustomTitle Property

TemporaryViewModesCustomTitle Property

Custom title for the TemporaryViewProperties mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string CustomTitle { get; set; }
Public Property CustomTitle As String
    Get
    Set
public:
property String^ CustomTitle {
    String^ get ();
    void set (String^ value);
}
member CustomTitle : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
If custom title is not empty, Temporary View Properties mode displays it in the upper left corner of colored view frame.
See Also

Reference

TemporaryViewModes Class


TemporaryViewModes.IsValidObject Property

TemporaryViewModesIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

TemporaryViewModes Class


TemporaryViewModes.PreviewFamilyVisibility Property

TemporaryViewModesPreviewFamilyVisibility Property

The current state of the PreviewFamilyVisibility mode in the associated view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PreviewFamilyVisibilityMode PreviewFamilyVisibility { get; set; }
Public Property PreviewFamilyVisibility As PreviewFamilyVisibilityMode
    Get
    Set
public:
property PreviewFamilyVisibilityMode PreviewFamilyVisibility {
    PreviewFamilyVisibilityMode get ();
    void set (PreviewFamilyVisibilityMode value);
}
member PreviewFamilyVisibility : PreviewFamilyVisibilityMode with get, set

Property Value

PreviewFamilyVisibilityMode
Exceptions
Exception | Condition
ArgumentException | When setting this property: The given PreviewFamilyVisibilityMode is not applicable in the associated view.
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | When setting this property: The PreviewFamilyVisibility mode is either disabled or inapplicable in the associated view.
Remarks

The state of the PreviewFamilyVisibility mode can be set only if the mode is currently available and enabled in the view. Even in such a condition, however, not all states are valid in all views. To ensure that the state to be applied is valid in the view, call the IsValidState(PreviewFamilyVisibilityMode) method first.

Even views which generally support temporary modes will have this particular mode available only when the document of the view is in the environment of the family editor.

This property affect only the view associated with this instance of TemporaryViewModes. When a view is opened for the first time, its state of the PreviewFamilyVisibility mode is determined based on the default settings which is controlled through the properties PreviewFamilyVisibilityDefaultOnState and PreviewFamilyVisibilityDefaultUncutState.

Example
C#
VB
C++
F#
Copy
public void TurnOffFamilyVisibilityMode(View view)
{
    TemporaryViewModes viewModes = view.TemporaryViewModes;

    if (viewModes != null)
    {
        if (viewModes.IsModeAvailable(TemporaryViewMode.PreviewFamilyVisibility) && viewModes.IsModeEnabled(TemporaryViewMode.PreviewFamilyVisibility))
        {
            if (viewModes.IsValidState(PreviewFamilyVisibilityMode.Off))
            {
                viewModes.PreviewFamilyVisibility = PreviewFamilyVisibilityMode.Off;
            }
        }
    }
}
Public Sub TurnOffFamilyVisibilityMode(view As View)
    Dim viewModes As TemporaryViewModes = view.TemporaryViewModes

    If viewModes IsNot Nothing Then
        If viewModes.IsModeAvailable(TemporaryViewMode.PreviewFamilyVisibility) AndAlso viewModes.IsModeEnabled(TemporaryViewMode.PreviewFamilyVisibility) Then
            If viewModes.IsValidState(PreviewFamilyVisibilityMode.Off) Then
                viewModes.PreviewFamilyVisibility = PreviewFamilyVisibilityMode.Off
            End If
        End If
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

TemporaryViewModes Class


TemporaryViewModes.PreviewFamilyVisibilityDefaultOnState Property

TemporaryViewModesPreviewFamilyVisibilityDefaultOnState Property

Controls the default state of the PreviewFamilyVisibility mode in all views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool PreviewFamilyVisibilityDefaultOnState { get; set; }
Public Shared Property PreviewFamilyVisibilityDefaultOnState As Boolean
    Get
    Set
public:
static property bool PreviewFamilyVisibilityDefaultOnState {
    bool get ();
    void set (bool value);
}
static member PreviewFamilyVisibilityDefaultOnState : bool with get, set

Property Value

Boolean
A boolean value to control whether the PreviewFamilyVisibility mode is to be turned On or Off in all views newly opened in a family editor.
Remarks

This flag controls whether each newly opened view is to have the PreviewFamilyVisibility mode turned On by default or not. This property is applicable to all types of views. Views that support both Cut and Non-cut preview (such as floor plans) can be controlled further via the PreviewFamilyVisibilityDefaultUncutState property.

The settings is applicable to the whole application rather than to individual family documents; the value persists between Revit sessions. Although the value is allowed to be set at any time, any changes made after the Revit application has been initialized will not have effect until the next session of Revit.

After a view is opened with the default family preview state applied, its PreviewFamilyVisibility mode may be independently modified through the PreviewFamilyVisibility property. Once explicitly modified, the settings stays in effect for the respective view even after the view is closed and later reopened again.

Example
C#
VB
C++
F#
Copy
public void SetDefaultPreviewFamilyVisibilityState()
{
    TemporaryViewModes.PreviewFamilyVisibilityDefaultOnState = true;
    TemporaryViewModes.PreviewFamilyVisibilityDefaultUncutState = true;
}
Public Sub SetDefaultPreviewFamilyVisibilityState()
    TemporaryViewModes.PreviewFamilyVisibilityDefaultOnState = True
    TemporaryViewModes.PreviewFamilyVisibilityDefaultUncutState = True
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

TemporaryViewModes Class


TemporaryViewModes.PreviewFamilyVisibilityDefaultUncutState Property

TemporaryViewModesPreviewFamilyVisibilityDefaultUncutState Property

Controls the default type of the On state of the PreviewFamilyVisibility mode in cut-able views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool PreviewFamilyVisibilityDefaultUncutState { get; set; }
Public Shared Property PreviewFamilyVisibilityDefaultUncutState As Boolean
    Get
    Set
public:
static property bool PreviewFamilyVisibilityDefaultUncutState {
    bool get ();
    void set (bool value);
}
static member PreviewFamilyVisibilityDefaultUncutState : bool with get, set

Property Value

Boolean
A Boolean value to control whether to use a non-cut preview in applicable views, such as floor and ceiling plan views.
Remarks

Newly opened views which can have both Cut and Uncut preview will use this default cut/uncut state as long as the default On state is set to True. To control the default state of the PreviewFamilyVisibility in all views refer to the PreviewFamilyVisibilityDefaultOnState property.

The settings is applicable to the whole application rather than to individual family documents; the value persists between Revit sessions. Although the value is allowed to be set at any time, any changes made after the Revit application has been initialized will not have effect until the next session of Revit.

After a view is opened with the default family preview state applied, its PreviewFamilyVisibility mode may be independently modified through the PreviewFamilyVisibility property. Once explicitly modified, the settings stays in effect for the respective view even after the view is closed and later reopened again.

See Also

Reference

TemporaryViewModes Class


TemporaryViewModes.RevealConstraints Property

TemporaryViewModesRevealConstraints Property

The current state of the RevealConstraints mode in the associated view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool RevealConstraints { get; set; }
Public Property RevealConstraints As Boolean
    Get
    Set
public:
property bool RevealConstraints {
    bool get ();
    void set (bool value);
}
member RevealConstraints : bool with get, set

Property Value

Boolean
Exceptions
Exception | Condition
InvalidOperationException | When setting this property: The RevealConstraints mode is either disabled or inapplicable in the associated view.
See Also

Reference

TemporaryViewModes Class


TemporaryViewModes.RevealHiddenElements Property

TemporaryViewModesRevealHiddenElements Property

The current state of the RevealHiddenElements mode in the associated view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool RevealHiddenElements { get; set; }
Public Property RevealHiddenElements As Boolean
    Get
    Set
public:
property bool RevealHiddenElements {
    bool get ();
    void set (bool value);
}
member RevealHiddenElements : bool with get, set

Property Value

Boolean
Exceptions
Exception | Condition
InvalidOperationException | When setting this property: The RevealHiddenElements mode is either disabled or inapplicable in the associated view.
See Also

Reference

TemporaryViewModes Class


TemporaryViewModes.WorksharingDisplay Property

TemporaryViewModesWorksharingDisplay Property

The current state of the WorksharingDisplay mode in the associated view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WorksharingDisplayMode WorksharingDisplay { get; set; }
Public Property WorksharingDisplay As WorksharingDisplayMode
    Get
    Set
public:
property WorksharingDisplayMode WorksharingDisplay {
    WorksharingDisplayMode get ();
    void set (WorksharingDisplayMode value);
}
member WorksharingDisplay : WorksharingDisplayMode with get, set

Property Value

WorksharingDisplayMode
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | When setting this property: The WorksharingDisplay mode is either disabled or inapplicable in the associated view.
See Also

Reference

TemporaryViewModes Class


TemporaryViewModes Methods

The TemporaryViewModes type exposes the following members.

Methods
 | Name | Description
Public method | DeactivateAllModes | Deactivates all temporary modes that are currently active.
Public method | DeactivateMode | Deactivates the given temporary mode.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCaption | A text caption to use for the given mode.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsCustomized | Identifies if a custom temporary view mode is currently active. A custom mode is active if there is a non-empty string set for CustomTitle.
Public method | IsModeActive | Tests whether a given mode is currently active or not.
Public method | IsModeAvailable | Tests whether a temporary view mode is currently available in the associated view.
Public method | IsModeEnabled | Tests whether a temporary view mode is currently enabled in the associated view.
Public method | IsValidState | Tests whether the given state is valid for the associated view and the context the view is currently in.
Public method | RemoveCustomization | Removes all customized values for the TemporaryViewProperties mode.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

TemporaryViewModes Class


TemporaryViewModes.DeactivateAllModes Method

TemporaryViewModesDeactivateAllModes Method

Deactivates all temporary modes that are currently active.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void DeactivateAllModes()
Public Sub DeactivateAllModes
public:
void DeactivateAllModes()
member DeactivateAllModes : unit -> unit
See Also

Reference

TemporaryViewModes Class


TemporaryViewModes.DeactivateMode Method

TemporaryViewModesDeactivateMode Method

Deactivates the given temporary mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void DeactivateMode(
    TemporaryViewMode mode
)
Public Sub DeactivateMode (
    mode As TemporaryViewMode
)
public:
void DeactivateMode(
    TemporaryViewMode mode
)
member DeactivateMode :
        mode : TemporaryViewMode -> unit

Parameters

mode TemporaryViewMode
The mode to deactivate
Exceptions
Exception | Condition
ArgumentException | The temporary mode is not available in the associated view. The view is either of a type that does not support this mode, or is currently in a context that makes the mode presently inapplicable. -or- The temporary mode is presently not enabled in the associated view.
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Remarks
The method has no effect on modes that are already deactivated.
See Also

Reference

TemporaryViewModes Class


TemporaryViewModes.GetCaption Method

TemporaryViewModesGetCaption Method

A text caption to use for the given mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetCaption(
    TemporaryViewMode mode
)
Public Function GetCaption (
    mode As TemporaryViewMode
) As String
public:
String^ GetCaption(
    TemporaryViewMode mode
)
member GetCaption :
        mode : TemporaryViewMode -> string

Parameters

mode TemporaryViewMode
The mode to get a caption for.

Return Value

String
Text of the caption. The text is localized.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Remarks
The text appears in the UI on the temporary frame when the view is in the temporary mode.
See Also

Reference

TemporaryViewModes Class


TemporaryViewModes.IsCustomized Method

TemporaryViewModesIsCustomized Method

Identifies if a custom temporary view mode is currently active. A custom mode is active if there is a non-empty string set for CustomTitle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCustomized()
Public Function IsCustomized As Boolean
public:
bool IsCustomized()
member IsCustomized : unit -> bool

Return Value

Boolean
Returns true a custom temporary view mode is currently active, false otherwise. A custom mode is active if there is a non-empty string set for CustomTitle.
See Also

Reference

TemporaryViewModes Class


TemporaryViewModes.IsModeActive Method

TemporaryViewModesIsModeActive Method

Tests whether a given mode is currently active or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsModeActive(
    TemporaryViewMode mode
)
Public Function IsModeActive (
    mode As TemporaryViewMode
) As Boolean
public:
bool IsModeActive(
    TemporaryViewMode mode
)
member IsModeActive :
        mode : TemporaryViewMode -> bool

Parameters

mode TemporaryViewMode
The mode being tested

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

TemporaryViewModes Class


TemporaryViewModes.IsModeAvailable Method

TemporaryViewModesIsModeAvailable Method

Tests whether a temporary view mode is currently available in the associated view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsModeAvailable(
    TemporaryViewMode mode
)
Public Function IsModeAvailable (
    mode As TemporaryViewMode
) As Boolean
public:
bool IsModeAvailable(
    TemporaryViewMode mode
)
member IsModeAvailable :
        mode : TemporaryViewMode -> bool

Parameters

mode TemporaryViewMode
The mode to evaluate

Return Value

Boolean
True of the temporary mode is currently available in the associated view.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Remarks

Not every mode is available in all views at all times. Some of the modes are only available in certain views, or only at certain time/context. Modes that are not available will not be visible on the view's tool bar in the UI.

Even modes that are available do not have to be currently enabled in the current context. Before using a mode its applicability should be tested by calling IsModeEnabled(TemporaryViewMode).

See Also

Reference

TemporaryViewModes Class


TemporaryViewModes.IsModeEnabled Method

TemporaryViewModesIsModeEnabled Method

Tests whether a temporary view mode is currently enabled in the associated view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsModeEnabled(
    TemporaryViewMode mode
)
Public Function IsModeEnabled (
    mode As TemporaryViewMode
) As Boolean
public:
bool IsModeEnabled(
    TemporaryViewMode mode
)
member IsModeEnabled :
        mode : TemporaryViewMode -> bool

Parameters

mode TemporaryViewMode
The mode to evaluate

Return Value

Boolean
True if the requested mode is available and enabled in the associated view; False otherwise.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Remarks
Most of temporary modes are enabled in a specific context only. A programmer who wants to use a mode needs to first test whether it is currently available and enabled, or not.
See Also

Reference

TemporaryViewModes Class


TemporaryViewModes.IsValidState Method

TemporaryViewModesIsValidState Method

Tests whether the given state is valid for the associated view and the context the view is currently in.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidState(
    PreviewFamilyVisibilityMode state
)
Public Function IsValidState (
    state As PreviewFamilyVisibilityMode
) As Boolean
public:
bool IsValidState(
    PreviewFamilyVisibilityMode state
)
member IsValidState :
        state : PreviewFamilyVisibilityMode -> bool

Parameters

state PreviewFamilyVisibilityMode
A state of the PreviewFamilyVisibilityMode

Return Value

Boolean
Returns True if the state is applicable for the view; False otherwise.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Remarks
As long as the PreviewFamilyVisibility mode is available and enabled in the associated view, the Off and On states are always valid. However, the Uncut state is only valid in plan views and reflected ceilings.
See Also

Reference

TemporaryViewModes Class


TemporaryViewModes.RemoveCustomization Method

TemporaryViewModesRemoveCustomization Method

Removes all customized values for the TemporaryViewProperties mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveCustomization()
Public Sub RemoveCustomization
public:
void RemoveCustomization()
member RemoveCustomization : unit -> unit
See Also

Reference

TemporaryViewModes Class


TessellatedBuildIssue Class

Types of issues encountered while constructing geometrical objects from the tessellated face sets.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBTessellatedBuildIssue

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TessellatedBuildIssue : IDisposable
Public Class TessellatedBuildIssue
    Implements IDisposable
public ref class TessellatedBuildIssue : IDisposable
type TessellatedBuildIssue =
    class
        interface IDisposable
    end

The TessellatedBuildIssue type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NumberEncountered | How many times this issue was encountered in its face set during the face set processing. This number can be less than the total number of such issues in the face set, as the face set processing could be aborted due to the presence of the issues which could not be handled.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the TessellatedBuildIssue
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIssueDescription | Gets a string describing the issue. If the issue does not present a problem, then an empty string is returned.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsValidIssue | Reports whether the issue is well-formed, valid and does describe a real problem.
Public method | MakesDataUnusable | Reports whether this issue makes some data unusable ('true') or is only shows that data format conventions were broken, but the data are still usable (false).
Public method | ReportIssueToDataSource | Reports whether this issue should be reported to the company which wrote the software which produced the face set data (true), or to Autodesk (false).
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TessellatedBuildIssue Properties

The TessellatedBuildIssue type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NumberEncountered | How many times this issue was encountered in its face set during the face set processing. This number can be less than the total number of such issues in the face set, as the face set processing could be aborted due to the presence of the issues which could not be handled.
Top
See Also

Reference

TessellatedBuildIssue Class


TessellatedBuildIssue.IsValidObject Property

TessellatedBuildIssueIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

TessellatedBuildIssue Class


TessellatedBuildIssue.NumberEncountered Property

TessellatedBuildIssueNumberEncountered Property

How many times this issue was encountered in its face set during the face set processing. This number can be less than the total number of such issues in the face set, as the face set processing could be aborted due to the presence of the issues which could not be handled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int NumberEncountered { get; }
Public ReadOnly Property NumberEncountered As Integer
    Get
public:
property int NumberEncountered {
    int get ();
}
member NumberEncountered : int with get

Property Value

Int32
See Also

Reference

TessellatedBuildIssue Class


TessellatedBuildIssue Methods

The TessellatedBuildIssue type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIssueDescription | Gets a string describing the issue. If the issue does not present a problem, then an empty string is returned.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsValidIssue | Reports whether the issue is well-formed, valid and does describe a real problem.
Public method | MakesDataUnusable | Reports whether this issue makes some data unusable ('true') or is only shows that data format conventions were broken, but the data are still usable (false).
Public method | ReportIssueToDataSource | Reports whether this issue should be reported to the company which wrote the software which produced the face set data (true), or to Autodesk (false).
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

TessellatedBuildIssue Class


TessellatedBuildIssue.Dispose Method

TessellatedBuildIssueDispose Method

Releases all resources used by the TessellatedBuildIssue

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

TessellatedBuildIssue Class


TessellatedBuildIssue.GetIssueDescription Method

TessellatedBuildIssueGetIssueDescription Method

Gets a string describing the issue. If the issue does not present a problem, then an empty string is returned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetIssueDescription()
Public Function GetIssueDescription As String
public:
String^ GetIssueDescription()
member GetIssueDescription : unit -> string

Return Value

String
Description of the issue.
See Also

Reference

TessellatedBuildIssue Class


TessellatedBuildIssue.IsValidIssue Method

TessellatedBuildIssueIsValidIssue Method

Reports whether the issue is well-formed, valid and does describe a real problem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidIssue()
Public Function IsValidIssue As Boolean
public:
bool IsValidIssue()
member IsValidIssue : unit -> bool

Return Value

Boolean
Whether the issue is well formed and does describe a real problem.
See Also

Reference

TessellatedBuildIssue Class


TessellatedBuildIssue.MakesDataUnusable Method

TessellatedBuildIssueMakesDataUnusable Method

Reports whether this issue makes some data unusable ('true') or is only shows that data format conventions were broken, but the data are still usable (false).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool MakesDataUnusable()
Public Function MakesDataUnusable As Boolean
public:
bool MakesDataUnusable()
member MakesDataUnusable : unit -> bool

Return Value

Boolean
See Also

Reference

TessellatedBuildIssue Class


TessellatedBuildIssue.ReportIssueToDataSource Method

TessellatedBuildIssueReportIssueToDataSource Method

Reports whether this issue should be reported to the company which wrote the software which produced the face set data (true), or to Autodesk (false).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ReportIssueToDataSource()
Public Function ReportIssueToDataSource As Boolean
public:
bool ReportIssueToDataSource()
member ReportIssueToDataSource : unit -> bool

Return Value

Boolean
See Also

Reference

TessellatedBuildIssue Class


TessellatedBuildIssueType Enumeration

Types of issues encountered while constructing geometrical objects from the tessellatted face sets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum TessellatedBuildIssueType
Public Enumeration TessellatedBuildIssueType
public enum class TessellatedBuildIssueType
type TessellatedBuildIssueType
Members
Member name | Value | Description
AllFine | 0 | No issues were encountered. Issues of this type should not be present in TessellatedShapeBuilderResult.
EmptyFace | 1 | A face which does not have any loops. An associated number is face index.
EmptyLoop | 2 | A face loop which does not have any points. Associated numbers are face index and loop index respectively.
TooFewOriginalVertices | 3 | A face loop, which from the very beginning does not have enough points. Associated numbers are face index and loop index respectively.
TooShortOriginalLoopMeshSegment | 4 | A face loop, containing a segment which is too short even for a mesh. Associated numbers are face, loop and point indices respectively (the segment goes from the previous point to this one).
TooShortOriginalLoopGeomSegment | 5 | A face loop, containing a segment which is too short for a geometry, but not for a mesh. Associated numbers are face, loop and point indices respectively (the segment goes from the previous point to this one).
LostTooManyLoopVertices | 6 | A face loop, which originally had enough vertices, but lost too many of them, while purging pseudo-duplicates. Associated numbers are face index and loop index respectively.
OriginalLoopGeomAcuteAngle | 7 | A face loop with a too acute angle between adjacent segments. This condition is not relevant for polymesh construction. Associated numbers are face, loop and point between segments indices respectively.
OriginalLoopMeshAcuteAngle | 8 | A face loop with a too acute angle between adjacent segments. This condition is not relevant for polymesh construction. Associated numbers are face, loop and point between segments indices respectively.
LostAllLoops | 9 | A face, which originally had enough loops lost all of them during purges. An associated number is face index.
NonPlanarFace | 10 | A face which is not planar. An associated number is face index.
OriginalPointsTooFarFromTheirPlane | 11 | A face whose original points taken together do define a plane, but some of them lie to far from it. An associated number is face index.
TooSmallVertexSegementDistInOriginalLoop | 12 | A face loop with too small vertex-segment distance. Associated numbers are face, loop, segment and vertex indices respectively.
LoopOnBestFitSelfIntersects | 13 | A face loop whose projection of the best-fit-plane self-intersects. Associated numbers are face, loop, and two segments indices respectively.
IntersectingOriginalLoops | 14 | A face whose loops intersect. Associated numbers are face and two loop indices respectively.
FaceWithIslands | 15 | A face which has a loop inside a loop inside a loop. Associated numbers are face and three loop indices respectively.
OriginalLoopsProximity | 16 | A face with excessive proximity between face loops. Associated numbers are face and two loop indices respectively.
OuterLoopIsNotFirst | 17 | A face have multiple loops, but the outer loop is not listed as the very first one. Associated numbers are face and loop indices respectively.
DegenOriginalLoop | 18 | A degenerate face loop is degenerate. Associated numbers are face and loop indices respectively.
InconsistentInnerOuterOriginalLoopCCW | 19 | A face where the CCW of inner loop is inconsistent with CCW of the outer loop. Associated numbers are face and inner loop indices respectively.
EdgeTwiceUsedByFace | 20 | A face with an edge encountered in the loops multiple times. Associated numbers are face and loop in which the problem became obvious indices respectively.
NonManifoldEdge | 21 | Same edge is used by more than two faces. This issue can be posted for topologically impossible face sets as well as for face sets with duplicate faces. Associated numbers are face and loop in which the problem became obvious indices respectively.
OverlappingAdjacentFaces | 22 | Adjacent faces which either exactly overlaps or have a too acute angle between them. This issue can be reported for face sets with duplicate faces as well. Associated numbers are face and loop indices of one face and face and loop indices of another face respectively.
PartitionPointsTooFarFromTrueEdge | 23 | Points representing partitions of input points are too far from the true edge. Associated numbers are face and loop indices, an index of the vertex in the beginning of the segment which is too far from the corresponding true edge, an index of another involved face respectively.
EdgeTraversalForFlip | 24 | A face edge with topological problems. Associated numbers are indices of the face, loop and vertex and an index of another involved face respectively.
InconsitentMultiEdgeTraversalForFlip | 25 | A face edge with topological problems. Associated numbers are indices of the involved faces.
TooSmallVertexSegementDistInFinalLoop | 26 | A face loop with too small vertex-segment distance. Associated numbers are face, loop, segment and vertex indices respectively
InternalUtilityError | 27 | An internal Revit problem. Issues of this type should not be present in TessellatedShapeBuilderResult. Please notify Autodesk support if encountered.
InternalError | 28 | An internal Revit problem. Issues of this type should not be present in TessellatedShapeBuilderResult. Please notify Autodesk support if encountered. Associated number is face index.
InternalLightError | 29 | An internal Revit problem. Issues of this type should not be present in TessellatedShapeBuilderResult. Please notify Autodesk support if encountered. Associated number is face index.
InternalMissingError | 30 | An internal Revit problem. Issues of this type should not be present in TessellatedShapeBuilderResult. Please notify Autodesk support if encountered. Associated number is face index.
UnarticulatedNonManifoldEdge | 31 | An input face is mising an edge conecting two non-adjacent vertices from its boundaries, which are adjacent in the boundaries of some other face(s). If such an edge would be added, it would split the face and result in 'NonManifoldEdge' or other issues. Associated numbers are indices of a face which misses an edge and indices of one or two faces in which boundaries such edge is present.
NotSetYet | 32 | An issue has not been set yet.
NumberOfIssueTypes | 33 | Not a code of some issue, but the number of known types of issues. Issues of this type should not be present in TessellatedShapeBuilderResult. Please notify Autodesk support if encountered
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TessellatedFace Class

Defines a planar face bounded by a polyline in 3d space. A face consists of a single connected component and can have holes.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBTessellatedFace

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TessellatedFace : IDisposable
Public Class TessellatedFace
    Implements IDisposable
public ref class TessellatedFace : IDisposable
type TessellatedFace =
    class
        interface IDisposable
    end

The TessellatedFace type exposes the following members.

Constructors
 | Name | Description
Public method | TessellatedFace(IListXYZ, ElementId) | Constructs a tessellated face without holes. Face data is always set, even if the input data are invalid (e.g., describes a wildly non-planar face). A TessellatedShepeBuilder's function is used to check the data and heal them if possible.
Public method | TessellatedFace(IListIListXYZ, ElementId) | Constructs a tessellated face, which, may be, have holes. Face data is always set, even if the input data are invalid (e.g., describes a wildly non-planar face). A TessellatedShepeBuilder's function is used to check the data and heal them if possible.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MaterialId | Material of the face.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the TessellatedFace
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBoundaryLoops | Get loops bounding the face.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TessellatedFace Constructor

Overload List
 | Name | Description
Public method | TessellatedFace(IListXYZ, ElementId) | Constructs a tessellated face without holes. Face data is always set, even if the input data are invalid (e.g., describes a wildly non-planar face). A TessellatedShepeBuilder's function is used to check the data and heal them if possible.
Public method | TessellatedFace(IListIListXYZ, ElementId) | Constructs a tessellated face, which, may be, have holes. Face data is always set, even if the input data are invalid (e.g., describes a wildly non-planar face). A TessellatedShepeBuilder's function is used to check the data and heal them if possible.
Top
See Also

Reference

TessellatedFace Class


TessellatedFace(IList<XYZ>, ElementId) Constructor

TessellatedFace(IListXYZ, ElementId) Constructor

Constructs a tessellated face without holes. Face data is always set, even if the input data are invalid (e.g., describes a wildly non-planar face). A TessellatedShepeBuilder's function is used to check the data and heal them if possible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TessellatedFace(
    IList<XYZ> outerLoopVertices,
    ElementId materialId
)
Public Sub New (
    outerLoopVertices As IList(Of XYZ),
    materialId As ElementId
)
public:
TessellatedFace(
    IList<XYZ^>^ outerLoopVertices,
    ElementId^ materialId
)
new :
        outerLoopVertices : IList<XYZ> *
        materialId : ElementId -> TessellatedFace

Parameters

outerLoopVertices IList XYZ
Boundary vertices without duplication of the ends - i.e., a boundary of a triangular face consists of 3 (and NOT 4) vertices. It is expected that boundaries are in CCW order with respect to the face normal in the solid. Boundaries in CW order will still be handled by TessellatedShapeBuilder, but performance may deteriorate. Contents of this parameter will be changed while constructing the face.
materialId ElementId
Material of the face to be used when the result is a Solid or a Sheet. If the result is a Mesh, a material will be assigned to the entire Mesh.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

TessellatedFace Class
TessellatedFace Overload


TessellatedFace(IList<IList<XYZ>>, ElementId) Constructor

TessellatedFace(IListIListXYZ, ElementId) Constructor

Constructs a tessellated face, which, may be, have holes. Face data is always set, even if the input data are invalid (e.g., describes a wildly non-planar face). A TessellatedShepeBuilder's function is used to check the data and heal them if possible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TessellatedFace(
    IList<IList<XYZ>> allLoopVertices,
    ElementId materialId
)
Public Sub New (
    allLoopVertices As IList(Of IList(Of XYZ)),
    materialId As ElementId
)
public:
TessellatedFace(
    IList<IList<XYZ^>^>^ allLoopVertices,
    ElementId^ materialId
)
new :
        allLoopVertices : IList<IList<XYZ>> *
        materialId : ElementId -> TessellatedFace

Parameters

allLoopVertices IList IList XYZ
Boundary vertices without duplication of the ends - i.e., a boundary of a triangular face consists of 3 (and NOT 4) vertices. The first array describes the outer loop, the following arrays, if any - inner loops. It is expected that vertices of outer boundary are listed in CCW order with respect to the face normal in the solid, while the vertices of inner loops - in CW order. The vertices listed in the wrong order will still be handled by TessellatedShapeBuilder, but performance may deteriorate. Contents of this parameter will be changed while constructing the face.
materialId ElementId
Material of the face to be used when the result is a Solid or a Sheet. If the result is a Mesh, a material will be assigned to the entire Mesh.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

TessellatedFace Class
TessellatedFace Overload


TessellatedFace Properties

The TessellatedFace type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MaterialId | Material of the face.
Top
See Also

Reference

TessellatedFace Class


TessellatedFace.IsValidObject Property

TessellatedFaceIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

TessellatedFace Class


TessellatedFace.MaterialId Property

TessellatedFaceMaterialId Property

Material of the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId MaterialId { get; set; }
Public Property MaterialId As ElementId
    Get
    Set
public:
property ElementId^ MaterialId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member MaterialId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

TessellatedFace Class


TessellatedFace Methods

The TessellatedFace type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBoundaryLoops | Get loops bounding the face.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

TessellatedFace Class


TessellatedFace.Dispose Method

TessellatedFaceDispose Method

Releases all resources used by the TessellatedFace

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

TessellatedFace Class


TessellatedFace.GetBoundaryLoops Method

TessellatedFaceGetBoundaryLoops Method

Get loops bounding the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<IList<XYZ>> GetBoundaryLoops()
Public Function GetBoundaryLoops As IList(Of IList(Of XYZ))
public:
IList<IList<XYZ^>^>^ GetBoundaryLoops()
member GetBoundaryLoops : unit -> IList<IList<XYZ>>

Return Value

IList IList XYZ
See Also

Reference

TessellatedFace Class


TessellatedShapeBuilder Class

A class that permits structured building of geometry or a mesh from a collection of connected faces. Contains all closed face sets and custom precisions.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBShapeBuilder
Autodesk.Revit.DBTessellatedShapeBuilder

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TessellatedShapeBuilder : ShapeBuilder
Public Class TessellatedShapeBuilder
    Inherits ShapeBuilder
public ref class TessellatedShapeBuilder : public ShapeBuilder
type TessellatedShapeBuilder =
    class
        inherit ShapeBuilder
    end

The TessellatedShapeBuilder type exposes the following members.

Constructors
 | Name | Description
Public method | TessellatedShapeBuilder | Constructs a new instance of a TessellatedShapeBuilder.
Top
Properties
 | Name | Description
Public property | Fallback | Defines acceptable fallback if the desired type of geometry can't be built.
Public property | GraphicsStyleId | Optional - if set, the built geometry will use that graphics style.
Public property | IsFaceSetOpen | Flag whether the current set of connected faces is open and additional tessellation faces can be added to it.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ShapeBuilder)
Public property | LogInteger | Integer value used for logging, if it is performed. Usually the number of the face set(s) in the IFC file, from which they are imported. Any value is acceptable.
Public property | LogString | String used for logging, if any. Usually the name of the file from which face sets were imported.
Public property | NumberOfCompletedFaceSets | Number of completed face sets.
Public property | OwnerInfo | String used for logging, if any. Usually describes the element or object, which either defined or will own the geoemtrical objects to be built.
Public property | Target | Requests the type of geometry to be built.
Top
Methods
 | Name | Description
Public method | AddFace | Adds a face to the currently open connected face set.
Public method | AreTargetAndFallbackCompatible | Checks whether this combination of fallback and target parameters can be used as a valid combination of inputs.
Public method | Build | Builds the designated geometrical objects from the stored face sets. Stores the result in this TessellatedShapeBuilder object.
Public method | CancelConnectedFaceSet | Cancels the current face set - i.e., all data from it will be lost and the builder will have no open connected face set anymore.
Public method | Clear | Erases all face set and clears the logs, if any.
Public method | CloseConnectedFaceSet | Closes the currently open connected face set.
 | CreateMeshByExtrusion | Builds a mesh by extruding curve loop(s) along extrusion distance.
Public method | Dispose | (Inherited from ShapeBuilder)
Public method | DoesFaceHaveEnoughLoopsAndVertices | Checks whether 'face' has enough loops and vertcies to be valid.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBuildResult | Get the built geometry, build status and other data stored in TessellatedShapeBuilderResult. Clears the stored data.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | OpenConnectedFaceSet | Opens a new connected face set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Creates a geometry populated with faces defined by TessellatedFace objects stored in the input connected face sets. The faces defined by each connected face set may form an open shell or the boundary of a solid 3D region. All faces are planar and have polyline boundaries, defined as sequences of 3d coordinates. Faces are added to the builder as a part of connected face sets, representing faces which share edges. Order of faces in the sets is irrelevant. Faces can only be added to the builder when a face set has been opened and is available to take in faces (use OpenConnectedFaceSet(Boolean) to open a new face set). Before attempting to build Revit geometry from the builder the current face set should be closed (CloseConnectedFaceSet). The builder allows for the possibility of multiple face sets. The builder will try to create a geometry valid in Revit despite inconsistencies or omissions in the input data.
  • For each connected face set, it will check the face orientations and change them wherever needed so that the orientations of the faces in that set are consistent.
  • If a connected face set is closed, it will check if the face normals point outward. If not, it will reverse the orientations of all faces. That means, each closed connected face set will represent a solid.
Limitations in the current implementation:
  • It does not support the definition of a "void", even if the user had set the orientations of the faces to define a "void".
  • If there is more than one connected face set, it does not check if they intersect or overlap each other.
Example
C#
VB
C++
F#
Copy
// Create a pyramid-shaped DirectShape using given material for the faces
public void CreateTessellatedShape(Document doc, ElementId materialId)
{
    List<XYZ> loopVertices = new List<XYZ>(4);

    TessellatedShapeBuilder builder = new TessellatedShapeBuilder();

    builder.OpenConnectedFaceSet(true);
    // create a pyramid with a square base 4' x 4' and 5' high
    double length = 4.0;
    double height = 5.0;

    XYZ basePt1 = XYZ.Zero;
    XYZ basePt2 = new XYZ(length, 0, 0);
    XYZ basePt3 = new XYZ(length, length, 0);
    XYZ basePt4 = new XYZ(0, length, 0);
    XYZ apex = new XYZ(length / 2, length / 2, height);

    loopVertices.Add(basePt1);
    loopVertices.Add(basePt2);
    loopVertices.Add(basePt3);
    loopVertices.Add(basePt4);
    builder.AddFace(new TessellatedFace(loopVertices, materialId));

    loopVertices.Clear();
    loopVertices.Add(basePt1);
    loopVertices.Add(apex);
    loopVertices.Add(basePt2);
    builder.AddFace(new TessellatedFace(loopVertices, materialId));

    loopVertices.Clear();
    loopVertices.Add(basePt2);
    loopVertices.Add(apex);
    loopVertices.Add(basePt3);
    builder.AddFace(new TessellatedFace(loopVertices, materialId));

    loopVertices.Clear();
    loopVertices.Add(basePt3);
    loopVertices.Add(apex);
    loopVertices.Add(basePt4);
    builder.AddFace(new TessellatedFace(loopVertices, materialId));

    loopVertices.Clear();
    loopVertices.Add(basePt4);
    loopVertices.Add(apex);
    loopVertices.Add(basePt1);
    builder.AddFace(new TessellatedFace(loopVertices, materialId));

    builder.CloseConnectedFaceSet();
    builder.Target = TessellatedShapeBuilderTarget.Solid;
    builder.Fallback = TessellatedShapeBuilderFallback.Abort;
    builder.Build();

    TessellatedShapeBuilderResult result = builder.GetBuildResult();

    using (Transaction t = new Transaction(doc, "Create tessellated direct shape"))
    {
        t.Start();

        DirectShape ds = DirectShape.CreateElement(doc, new ElementId(BuiltInCategory.OST_GenericModel));
       ds.ApplicationId = "Application id";
       ds.ApplicationDataId = "Geometry object id";

        ds.SetShape(result.GetGeometricalObjects());
        t.Commit();
    }
}
' Create a pyramid-shaped DirectShape using given material for the faces
Public Sub CreateTessellatedShape(doc As Document, materialId As ElementId)
    Dim loopVertices As New List(Of XYZ)(4)

    Dim builder As New TessellatedShapeBuilder()

    builder.OpenConnectedFaceSet(True)
    ' create a pyramid with a square base 4' x 4' and 5' high
    Dim length As Double = 4.0
    Dim height As Double = 5.0

    Dim basePt1 As XYZ = XYZ.Zero
    Dim basePt2 As New XYZ(length, 0, 0)
    Dim basePt3 As New XYZ(length, length, 0)
    Dim basePt4 As New XYZ(0, length, 0)
    Dim apex As New XYZ(length / 2, length / 2, height)

    loopVertices.Add(basePt1)
    loopVertices.Add(basePt2)
    loopVertices.Add(basePt3)
    loopVertices.Add(basePt4)
    builder.AddFace(New TessellatedFace(loopVertices, materialId))

    loopVertices.Clear()
    loopVertices.Add(basePt1)
    loopVertices.Add(apex)
    loopVertices.Add(basePt2)
    builder.AddFace(New TessellatedFace(loopVertices, materialId))

    loopVertices.Clear()
    loopVertices.Add(basePt2)
    loopVertices.Add(apex)
    loopVertices.Add(basePt3)
    builder.AddFace(New TessellatedFace(loopVertices, materialId))

    loopVertices.Clear()
    loopVertices.Add(basePt3)
    loopVertices.Add(apex)
    loopVertices.Add(basePt4)
    builder.AddFace(New TessellatedFace(loopVertices, materialId))

    loopVertices.Clear()
    loopVertices.Add(basePt4)
    loopVertices.Add(apex)
    loopVertices.Add(basePt1)
    builder.AddFace(New TessellatedFace(loopVertices, materialId))

    builder.CloseConnectedFaceSet()
    builder.Target = TessellatedShapeBuilderTarget.Solid
    builder.Fallback = TessellatedShapeBuilderFallback.Abort
    builder.Build()

    Dim result As TessellatedShapeBuilderResult = builder.GetBuildResult()

    Using t As New Transaction(doc, "Create tessellated direct shape")
        t.Start()

        Dim ds As DirectShape = DirectShape.CreateElement(doc, New ElementId(BuiltInCategory.OST_GenericModel))
        ds.ApplicationId = "Application id"
        ds.ApplicationDataId = "Geometry object id"

        ds.SetShape(result.GetGeometricalObjects())
        t.Commit()
    End Using
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TessellatedShapeBuilder Constructor

Constructs a new instance of a TessellatedShapeBuilder.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TessellatedShapeBuilder()
Public Sub New
public:
TessellatedShapeBuilder()
new : unit -> TessellatedShapeBuilder
See Also

Reference

TessellatedShapeBuilder Class


TessellatedShapeBuilder Properties

The TessellatedShapeBuilder type exposes the following members.

Properties
 | Name | Description
Public property | Fallback | Defines acceptable fallback if the desired type of geometry can't be built.
Public property | GraphicsStyleId | Optional - if set, the built geometry will use that graphics style.
Public property | IsFaceSetOpen | Flag whether the current set of connected faces is open and additional tessellation faces can be added to it.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ShapeBuilder)
Public property | LogInteger | Integer value used for logging, if it is performed. Usually the number of the face set(s) in the IFC file, from which they are imported. Any value is acceptable.
Public property | LogString | String used for logging, if any. Usually the name of the file from which face sets were imported.
Public property | NumberOfCompletedFaceSets | Number of completed face sets.
Public property | OwnerInfo | String used for logging, if any. Usually describes the element or object, which either defined or will own the geoemtrical objects to be built.
Public property | Target | Requests the type of geometry to be built.
Top
See Also

Reference

TessellatedShapeBuilder Class


TessellatedShapeBuilder.Fallback Property

TessellatedShapeBuilderFallback Property

Defines acceptable fallback if the desired type of geometry can't be built.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TessellatedShapeBuilderFallback Fallback { get; set; }
Public Property Fallback As TessellatedShapeBuilderFallback
    Get
    Set
public:
property TessellatedShapeBuilderFallback Fallback {
    TessellatedShapeBuilderFallback get ();
    void set (TessellatedShapeBuilderFallback value);
}
member Fallback : TessellatedShapeBuilderFallback with get, set

Property Value

TessellatedShapeBuilderFallback
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

TessellatedShapeBuilder Class


TessellatedShapeBuilder.GraphicsStyleId Property

TessellatedShapeBuilderGraphicsStyleId Property

Optional - if set, the built geometry will use that graphics style.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GraphicsStyleId { get; set; }
Public Property GraphicsStyleId As ElementId
    Get
    Set
public:
property ElementId^ GraphicsStyleId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member GraphicsStyleId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

TessellatedShapeBuilder Class


TessellatedShapeBuilder.IsFaceSetOpen Property

TessellatedShapeBuilderIsFaceSetOpen Property

Flag whether the current set of connected faces is open and additional tessellation faces can be added to it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsFaceSetOpen { get; }
Public ReadOnly Property IsFaceSetOpen As Boolean
    Get
public:
property bool IsFaceSetOpen {
    bool get ();
}
member IsFaceSetOpen : bool with get

Property Value

Boolean
See Also

Reference

TessellatedShapeBuilder Class


TessellatedShapeBuilder.LogInteger Property

TessellatedShapeBuilderLogInteger Property

Integer value used for logging, if it is performed. Usually the number of the face set(s) in the IFC file, from which they are imported. Any value is acceptable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int LogInteger { get; set; }
Public Property LogInteger As Integer
    Get
    Set
public:
property int LogInteger {
    int get ();
    void set (int value);
}
member LogInteger : int with get, set

Property Value

Int32
See Also

Reference

TessellatedShapeBuilder Class


TessellatedShapeBuilder.LogString Property

TessellatedShapeBuilderLogString Property

String used for logging, if any. Usually the name of the file from which face sets were imported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string LogString { get; set; }
Public Property LogString As String
    Get
    Set
public:
property String^ LogString {
    String^ get ();
    void set (String^ value);
}
member LogString : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

TessellatedShapeBuilder Class


TessellatedShapeBuilder.NumberOfCompletedFaceSets Property

TessellatedShapeBuilderNumberOfCompletedFaceSets Property

Number of completed face sets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int NumberOfCompletedFaceSets { get; }
Public ReadOnly Property NumberOfCompletedFaceSets As Integer
    Get
public:
property int NumberOfCompletedFaceSets {
    int get ();
}
member NumberOfCompletedFaceSets : int with get

Property Value

Int32
See Also

Reference

TessellatedShapeBuilder Class


TessellatedShapeBuilder.OwnerInfo Property

TessellatedShapeBuilderOwnerInfo Property

String used for logging, if any. Usually describes the element or object, which either defined or will own the geoemtrical objects to be built.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string OwnerInfo { get; set; }
Public Property OwnerInfo As String
    Get
    Set
public:
property String^ OwnerInfo {
    String^ get ();
    void set (String^ value);
}
member OwnerInfo : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

TessellatedShapeBuilder Class


TessellatedShapeBuilder.Target Property

TessellatedShapeBuilderTarget Property

Requests the type of geometry to be built.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TessellatedShapeBuilderTarget Target { get; set; }
Public Property Target As TessellatedShapeBuilderTarget
    Get
    Set
public:
property TessellatedShapeBuilderTarget Target {
    TessellatedShapeBuilderTarget get ();
    void set (TessellatedShapeBuilderTarget value);
}
member Target : TessellatedShapeBuilderTarget with get, set

Property Value

TessellatedShapeBuilderTarget
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

TessellatedShapeBuilder Class


TessellatedShapeBuilder Methods

The TessellatedShapeBuilder type exposes the following members.

Methods
 | Name | Description
Public method | AddFace | Adds a face to the currently open connected face set.
Public method | AreTargetAndFallbackCompatible | Checks whether this combination of fallback and target parameters can be used as a valid combination of inputs.
Public method | Build | Builds the designated geometrical objects from the stored face sets. Stores the result in this TessellatedShapeBuilder object.
Public method | CancelConnectedFaceSet | Cancels the current face set - i.e., all data from it will be lost and the builder will have no open connected face set anymore.
Public method | Clear | Erases all face set and clears the logs, if any.
Public method | CloseConnectedFaceSet | Closes the currently open connected face set.
 | CreateMeshByExtrusion | Builds a mesh by extruding curve loop(s) along extrusion distance.
Public method | Dispose | (Inherited from ShapeBuilder)
Public method | DoesFaceHaveEnoughLoopsAndVertices | Checks whether 'face' has enough loops and vertcies to be valid.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBuildResult | Get the built geometry, build status and other data stored in TessellatedShapeBuilderResult. Clears the stored data.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | OpenConnectedFaceSet | Opens a new connected face set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

TessellatedShapeBuilder Class


TessellatedShapeBuilder.AddFace Method

TessellatedShapeBuilderAddFace Method

Adds a face to the currently open connected face set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddFace(
    TessellatedFace face
)
Public Sub AddFace (
    face As TessellatedFace
)
public:
void AddFace(
    TessellatedFace^ face
)
member AddFace :
        face : TessellatedFace -> unit

Parameters

face TessellatedFace
Face to add. The 'face' parameter can be added only once, as its boundary loops will be cleared while adding and 'face' will become unusable.
Exceptions
Exception | Condition
ArgumentException | The 'face' does not have enough loops and/or vertices to be valid.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | A face set is closed and faces cannot be added to it.
See Also

Reference

TessellatedShapeBuilder Class


TessellatedShapeBuilder.AreTargetAndFallbackCompatible Method

TessellatedShapeBuilderAreTargetAndFallbackCompatible Method

Checks whether this combination of fallback and target parameters can be used as a valid combination of inputs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AreTargetAndFallbackCompatible(
    TessellatedShapeBuilderTarget target,
    TessellatedShapeBuilderFallback fallback
)
Public Function AreTargetAndFallbackCompatible (
    target As TessellatedShapeBuilderTarget,
    fallback As TessellatedShapeBuilderFallback
) As Boolean
public:
bool AreTargetAndFallbackCompatible(
    TessellatedShapeBuilderTarget target,
    TessellatedShapeBuilderFallback fallback
)
member AreTargetAndFallbackCompatible :
        target : TessellatedShapeBuilderTarget *
        fallback : TessellatedShapeBuilderFallback -> bool

Parameters

target TessellatedShapeBuilderTarget
What kind of geometrical objects should be built.
fallback TessellatedShapeBuilderFallback
What should be done if a geometrical object described by 'target' parameter cannot be built using all data from all stored face sets.

Return Value

Boolean
True if the combination of fallback and target are a valid combination, false otherwise.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

TessellatedShapeBuilder Class


TessellatedShapeBuilder.Build Method

TessellatedShapeBuilderBuild Method

Builds the designated geometrical objects from the stored face sets. Stores the result in this TessellatedShapeBuilder object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Build()
Public Sub Build
public:
void Build()
member Build : unit -> unit
Exceptions
Exception | Condition
InvalidOperationException | Throws if data in the stored face sets are so inconsistent, that they cannot be used in their entirety, or if an attempt is made to create unacceptable geometry with too many facets.
Remarks
The behavior of this function is affected by Target, Fallback and GStyleId properties of this TessellatedShapeBuilder object. Currently only "Solid/Abort", "AnyGeometry/Mesh" and "Mesh/Salvage" target/fallback combinations are supported. Note that this function does not erase the face sets stored in the builder. If the same builder is used to construct geometrical objects for different collections of face sets, (Clear) should be called while switching from one collection to another.
See Also

Reference

TessellatedShapeBuilder Class


TessellatedShapeBuilder.CancelConnectedFaceSet Method

TessellatedShapeBuilderCancelConnectedFaceSet Method

Cancels the current face set - i.e., all data from it will be lost and the builder will have no open connected face set anymore.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void CancelConnectedFaceSet()
Public Sub CancelConnectedFaceSet
public:
void CancelConnectedFaceSet()
member CancelConnectedFaceSet : unit -> unit
Remarks
This function can be safely called upon builder without an open face set.
See Also

Reference

TessellatedShapeBuilder Class


TessellatedShapeBuilder.Clear Method

TessellatedShapeBuilderClear Method

Erases all face set and clears the logs, if any.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
Remarks
This function can be safely called upon builder without an open face set.
See Also

Reference

TessellatedShapeBuilder Class


TessellatedShapeBuilder.CloseConnectedFaceSet Method

TessellatedShapeBuilderCloseConnectedFaceSet Method

Closes the currently open connected face set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void CloseConnectedFaceSet()
Public Sub CloseConnectedFaceSet
public:
void CloseConnectedFaceSet()
member CloseConnectedFaceSet : unit -> unit
Exceptions
Exception | Condition
InvalidOperationException | A face set is empty and cannot be closed until some faces are added.
See Also

Reference

TessellatedShapeBuilder Class


TessellatedShapeBuilder.CreateMeshByExtrusion Method

TessellatedShapeBuilderCreateMeshByExtrusion Method

Builds a mesh by extruding curve loop(s) along extrusion distance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static MeshFromGeometryOperationResult CreateMeshByExtrusion(
    IList<CurveLoop> profileLoops,
    XYZ extrusionDirection,
    double extrusionDistance,
    ElementId materialId
)
Public Shared Function CreateMeshByExtrusion (
    profileLoops As IList(Of CurveLoop),
    extrusionDirection As XYZ,
    extrusionDistance As Double,
    materialId As ElementId
) As MeshFromGeometryOperationResult
public:
static MeshFromGeometryOperationResult^ CreateMeshByExtrusion(
    IList<CurveLoop^>^ profileLoops,
    XYZ^ extrusionDirection,
    double extrusionDistance,
    ElementId^ materialId
)
static member CreateMeshByExtrusion :
        profileLoops : IList<CurveLoop> *
        extrusionDirection : XYZ *
        extrusionDistance : float *
        materialId : ElementId -> MeshFromGeometryOperationResult

Parameters

profileLoops IList CurveLoop
The profile loops to be extruded. The loops will not be modified.
extrusionDirection XYZ
Direction of extrusion. The length of this vector is ignored.
extrusionDistance Double
The positive distance by which the loops are extruded in the direction of the input extrusionDir.
materialId ElementId
Material which should be used by a constructed mesh.

Return Value

MeshFromGeometryOperationResult
Returns a mesh, which was constructed, and some additional information.
Exceptions
Exception | Condition
ArgumentException | The input value cannot be used as thickness for an extrusion, or blend, or wall layer, or similar geometric construct.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | extrusionDirection has zero length.
Remarks
This function supports creation of a mesh given a collection of continuous curve loops, which are processed independently from each other. Loops with gaps or with curves with wrong flips will be split before processing.
See Also

Reference

TessellatedShapeBuilder Class


TessellatedShapeBuilder.DoesFaceHaveEnoughLoopsAndVertices Method

TessellatedShapeBuilderDoesFaceHaveEnoughLoopsAndVertices Method

Checks whether 'face' has enough loops and vertcies to be valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool DoesFaceHaveEnoughLoopsAndVertices(
    TessellatedFace face
)
Public Function DoesFaceHaveEnoughLoopsAndVertices (
    face As TessellatedFace
) As Boolean
public:
bool DoesFaceHaveEnoughLoopsAndVertices(
    TessellatedFace^ face
)
member DoesFaceHaveEnoughLoopsAndVertices :
        face : TessellatedFace -> bool

Parameters

face TessellatedFace
The face to check.

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Face 'face' is not modified.
See Also

Reference

TessellatedShapeBuilder Class


TessellatedShapeBuilder.GetBuildResult Method

TessellatedShapeBuilderGetBuildResult Method

Get the built geometry, build status and other data stored in TessellatedShapeBuilderResult. Clears the stored data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TessellatedShapeBuilderResult GetBuildResult()
Public Function GetBuildResult As TessellatedShapeBuilderResult
public:
TessellatedShapeBuilderResult^ GetBuildResult()
member GetBuildResult : unit -> TessellatedShapeBuilderResult

Return Value

TessellatedShapeBuilderResult
See Also

Reference

TessellatedShapeBuilder Class


TessellatedShapeBuilder.OpenConnectedFaceSet Method

TessellatedShapeBuilderOpenConnectedFaceSet Method

Opens a new connected face set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void OpenConnectedFaceSet(
    bool isSolid
)
Public Sub OpenConnectedFaceSet (
    isSolid As Boolean
)
public:
void OpenConnectedFaceSet(
    bool isSolid
)
member OpenConnectedFaceSet :
        isSolid : bool -> unit

Parameters

isSolid Boolean
Whether the face set, which is being open, should be build as a solid or as a void.
Exceptions
Exception | Condition
InvalidOperationException | A face set is open and a geometry cannot be build until it is closed.
See Also

Reference

TessellatedShapeBuilder Class


TessellatedShapeBuilderFallback Enumeration

Describes what TessellatedShapeBuilder function should do, if it cannot build a requested TessellatedShapeBuilderTarget.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum TessellatedShapeBuilderFallback
Public Enumeration TessellatedShapeBuilderFallback
public enum class TessellatedShapeBuilderFallback
type TessellatedShapeBuilderFallback
Members
Member name | Value | Description
Abort | 0 | Do nothing.
Salvage | 1 | Ignore invalid data, and use all valid data. Note that if a complete set of data describes a solid and some data are ignored, then the result will be a sheet and not a solid.
Mesh | 2 | If a requested geometrical object cannot be built using all data from the face set(s), create a mesh while using as much data from the face set(s) as possible.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TessellatedShapeBuilderOutcome Enumeration

Describes the outcome of TessellatedShapeBuilder attempt to build geometrical objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum TessellatedShapeBuilderOutcome
Public Enumeration TessellatedShapeBuilderOutcome
public enum class TessellatedShapeBuilderOutcome
type TessellatedShapeBuilderOutcome
Members
Member name | Value | Description
Mesh | 1 | A mesh was created
Mixed | 2 | A geometry and a mesh were created
Nothing | 3 | Nothing was built.
Solid | 4 | A solid geometry was created.
Sheet | 5 | An open sheet was created.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TessellatedShapeBuilderResult Class

Describes what TessellatedShapeBuilder has construct.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBTessellatedShapeBuilderResult

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TessellatedShapeBuilderResult : IDisposable
Public Class TessellatedShapeBuilderResult
    Implements IDisposable
public ref class TessellatedShapeBuilderResult : IDisposable
type TessellatedShapeBuilderResult =
    class
        interface IDisposable
    end

The TessellatedShapeBuilderResult type exposes the following members.

Properties
 | Name | Description
Public property | AreObjectsAvailable | Shows whether 'issues' still contains the original data or whether these data have already been relinquished by 'getGeometricalObjects'. The former is true, the later is false.
Public property | HasInvalidData | Whether there were any inconsistencies in the face sets, stored in the tessellated shape builder while building geometrical objects.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Outcome | What kinds of geometrical objects were built.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the TessellatedShapeBuilderResult
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetGeometricalObjects | When called the first time, returns geometrical objects which were built. Later calls will throw exceptions.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIssuesForFaceSet | Returns the array of issues encountered while processing a face set with index 'setIndex'.
Public method | GetNumberOfFaceSets | Gets number of face sets for which 'this' result was obtained.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TessellatedShapeBuilderResult Properties

The TessellatedShapeBuilderResult type exposes the following members.

Properties
 | Name | Description
Public property | AreObjectsAvailable | Shows whether 'issues' still contains the original data or whether these data have already been relinquished by 'getGeometricalObjects'. The former is true, the later is false.
Public property | HasInvalidData | Whether there were any inconsistencies in the face sets, stored in the tessellated shape builder while building geometrical objects.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Outcome | What kinds of geometrical objects were built.
Top
See Also

Reference

TessellatedShapeBuilderResult Class


TessellatedShapeBuilderResult.AreObjectsAvailable Property

TessellatedShapeBuilderResultAreObjectsAvailable Property

Shows whether 'issues' still contains the original data or whether these data have already been relinquished by 'getGeometricalObjects'. The former is true, the later is false.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AreObjectsAvailable { get; }
Public ReadOnly Property AreObjectsAvailable As Boolean
    Get
public:
property bool AreObjectsAvailable {
    bool get ();
}
member AreObjectsAvailable : bool with get

Property Value

Boolean
See Also

Reference

TessellatedShapeBuilderResult Class


TessellatedShapeBuilderResult.HasInvalidData Property

TessellatedShapeBuilderResultHasInvalidData Property

Whether there were any inconsistencies in the face sets, stored in the tessellated shape builder while building geometrical objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasInvalidData { get; }
Public ReadOnly Property HasInvalidData As Boolean
    Get
public:
property bool HasInvalidData {
    bool get ();
}
member HasInvalidData : bool with get

Property Value

Boolean
See Also

Reference

TessellatedShapeBuilderResult Class


TessellatedShapeBuilderResult.IsValidObject Property

TessellatedShapeBuilderResultIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

TessellatedShapeBuilderResult Class


TessellatedShapeBuilderResult.Outcome Property

TessellatedShapeBuilderResultOutcome Property

What kinds of geometrical objects were built.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TessellatedShapeBuilderOutcome Outcome { get; }
Public ReadOnly Property Outcome As TessellatedShapeBuilderOutcome
    Get
public:
property TessellatedShapeBuilderOutcome Outcome {
    TessellatedShapeBuilderOutcome get ();
}
member Outcome : TessellatedShapeBuilderOutcome with get

Property Value

TessellatedShapeBuilderOutcome
See Also

Reference

TessellatedShapeBuilderResult Class


TessellatedShapeBuilderResult Methods

The TessellatedShapeBuilderResult type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetGeometricalObjects | When called the first time, returns geometrical objects which were built. Later calls will throw exceptions.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIssuesForFaceSet | Returns the array of issues encountered while processing a face set with index 'setIndex'.
Public method | GetNumberOfFaceSets | Gets number of face sets for which 'this' result was obtained.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

TessellatedShapeBuilderResult Class


TessellatedShapeBuilderResult.Dispose Method

TessellatedShapeBuilderResultDispose Method

Releases all resources used by the TessellatedShapeBuilderResult

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

TessellatedShapeBuilderResult Class


TessellatedShapeBuilderResult.GetGeometricalObjects Method

TessellatedShapeBuilderResultGetGeometricalObjects Method

When called the first time, returns geometrical objects which were built. Later calls will throw exceptions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<GeometryObject> GetGeometricalObjects()
Public Function GetGeometricalObjects As IList(Of GeometryObject)
public:
IList<GeometryObject^>^ GetGeometricalObjects()
member GetGeometricalObjects : unit -> IList<GeometryObject>

Return Value

IList GeometryObject
Geometrical object which were built.
Remarks
Normally an array contains a single geometrical object corresponding to either 'target' or 'fallback' type', but if multiple face sets are being built with target/fallback of "AnyGeometry/Mesh", then a two-element array with both geometry as the 1st element and mesh as the 2nd can be returned. It happens if some of the face sets require a fallback processing and some do not.
See Also

Reference

TessellatedShapeBuilderResult Class


TessellatedShapeBuilderResult.GetIssuesForFaceSet Method

TessellatedShapeBuilderResultGetIssuesForFaceSet Method

Returns the array of issues encountered while processing a face set with index 'setIndex'.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<TessellatedBuildIssue> GetIssuesForFaceSet(
    int setIndex
)
Public Function GetIssuesForFaceSet (
    setIndex As Integer
) As IList(Of TessellatedBuildIssue)
public:
IList<TessellatedBuildIssue^>^ GetIssuesForFaceSet(
    int setIndex
)
member GetIssuesForFaceSet :
        setIndex : int -> IList<TessellatedBuildIssue>

Parameters

setIndex Int32
Index of the face set.

Return Value

IList TessellatedBuildIssue
Array of issues encountered while processing a face set with index 'setIndex'.
Exceptions
Exception | Condition
ArgumentException | 'SetIndex' is a valid face set index for the results stored in 'this'.
See Also

Reference

TessellatedShapeBuilderResult Class


TessellatedShapeBuilderResult.GetNumberOfFaceSets Method

TessellatedShapeBuilderResultGetNumberOfFaceSets Method

Gets number of face sets for which 'this' result was obtained.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetNumberOfFaceSets()
Public Function GetNumberOfFaceSets As Integer
public:
int GetNumberOfFaceSets()
member GetNumberOfFaceSets : unit -> int

Return Value

Int32
The number of face sets.
See Also

Reference

TessellatedShapeBuilderResult Class


TessellatedShapeBuilderTarget Enumeration

Describes what TessellatedShapeBuilder should generate, if possible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum TessellatedShapeBuilderTarget
Public Enumeration TessellatedShapeBuilderTarget
public enum class TessellatedShapeBuilderTarget
type TessellatedShapeBuilderTarget
Members
Member name | Value | Description
Solid | 0 | A solid, i.e., a Geometry, where all edges are shared by two and only two faces and which divides all 3d space into bounded inner and infinite outer area(s).
AnyGeometry | 1 | A Geometry, which depending on input data can be a Solid or a 'sheet', where there is no fully enclosed volume formed by the generated faces.
Mesh | 2 | A mesh.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TextAlignFlags Enumeration

An enumerated type listing all the Text align flags.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum TextAlignFlags
Public Enumeration TextAlignFlags
public enum class TextAlignFlags
type TextAlignFlags
Members
Member name | Value | Description
TEF_ALIGN_LEFT | 64 | Align text left
TEF_ALIGN_CENTER | 128 | Align text center
TEF_ALIGN_RIGHT | 256 | Align text right
TEF_ALIGN_TOP | 512 | Align text top
TEF_ALIGN_MIDDLE | 1,024 | Align text middle
TEF_ALIGN_BOTTOM | 2,048 | Align text bottom
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TextAlignMask Enumeration

An enumerated type listing all the Text align mask.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum TextAlignMask
Public Enumeration TextAlignMask
public enum class TextAlignMask
type TextAlignMask
Members
Member name | Value | Description
horzAlignMask | 448 | The mask of the Text object being aligned in the horizontal direction.
vertAlignMask | 3,584 | The mask of the Text object being aligned in the vertical direction.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TextBaselineStyle Enumeration

Supported styles of text position relative to the normal baseline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum TextBaselineStyle
Public Enumeration TextBaselineStyle
public enum class TextBaselineStyle
type TextBaselineStyle
Members
Member name | Value | Description
Normal | 0 | Indicates a normal text with letters positioned on the baseline.
Subscript | 1 | Indicates a subsript text.
Superscript | 2 | Indicates a superscript text.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TextElement Class

Base class representing text elements in Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBTextElement
Autodesk.Revit.DBTextNote

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TextElement : Element
Public Class TextElement
    Inherits Element
public ref class TextElement : public Element
type TextElement =
    class
        inherit Element
    end

The TextElement type exposes the following members.

Properties
Name | Description
Public property AssemblyInstanceId The id of the assembly instance to which the element belongs.
(Inherited from Element)
Public property | BaseDirection | Direction of the base line of the text element.
BoundingBox Retrieves a box that circumscribes all geometry of the element.
(Inherited from Element)
Public property Category Retrieves a Category object that represents the category or sub category in which the element resides.
(Inherited from Element)
Public property | Coord | Position of the text (in model coordinates.)
CreatedPhaseId Id of a Phase at which the Element was created.
(Inherited from Element)
DemolishedPhaseId Id of a Phase at which the Element was demolished.
(Inherited from Element)
DesignOption Returns the design option to which the element belongs.
(Inherited from Element)
Public property Document Returns the Document in which the Element resides.
(Inherited from Element)
Geometry Retrieves the geometric representation of the element.
(Inherited from Element)
Public property GroupId The id of the group to which an element belongs.
(Inherited from Element)
Public property | Height | Height of the area of the text content.
Public property | HorizontalAlignment | Horizontal alignment of the text content within the text area of the element.
Id A unique identifier for an Element in an Autodesk Revit project.
(Inherited from Element)
Public property IsModifiable Identifies if the element is modifiable.
(Inherited from Element)
Public property IsTextWrappingActive

A flag identifying whether text-wrapping is currently active in this text element or not.

If text wrapping is active the width of the text box remains constant and the text will wrap. The height of the text box will automatically adjust to accomodate the height of the text.

If text wrapping is not active the text does not wrap and the width of the text box adjusts with the width of the longest line of text. As the text width changes, the position of the text may change depending on the HorizontalAlignment

Public property IsTransient Indicates whether an element is transient or permanent.
(Inherited from Element)
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from Element)
Public property | KeepRotatedTextReadable | A flag to control how text behaves inside a rotated text element.
Public property LevelId The id of the level associated with the element.
(Inherited from Element)
Location This property is used to find the physical location of an element within a project.
(Inherited from Element)
Public property Name A human readable name for the Element.
(Inherited from Element)
Public property OwnerViewId The id of the view that owns the element.
(Inherited from Element)
ParameterBuiltInParameter Retrieves a parameter from the element given a parameter id.
(Inherited from Element)
Public property ParameterDefinition Retrieves a parameter from the element based on its definition.
(Inherited from Element)
Public property ParameterGuid Retrieves a parameter from the element given a GUID for a shared parameter.
(Inherited from Element)
Parameters Retrieves a set containing all of the parameters that are contained within the element.
(Inherited from Element)
Public property ParametersMap Retrieves a map containing all of the parameters that are contained within the element.
(Inherited from Element)
Public property Pinned Identifies if the element has been pinned to prevent changes.
(Inherited from Element)
Public property | Symbol | Get the type of the TextElement object.
Public property | Text | The content of the element as a plain string stripped of all formating.
UniqueId A stable unique identifier for an element within the document.
(Inherited from Element)
Public property | UpDirection | Direction along the vertical axis of letters of the text note.
Public property VersionGuid Get the element version Guid.
(Inherited from Element)
Public property | VerticalAlignment | Vertical alignment of the text.
Public property ViewSpecific Identifies if the element is owned by a view.
(Inherited from Element)
Public property | Width | Width of the area of the text content.
Public property WorksetId Get Id of the Workset which owns the element.
(Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMaximumAllowedWidth | Returns the maximum width the text element can be assigned.
 | GetMaximumAllowedWidth(Document, ElementId) | Returns the maximum width the text element can be created with.
Public method | GetMinimumAllowedWidth | Returns the minimum width the text element can be assigned.
 | GetMinimumAllowedWidth(Document, ElementId) | Returns the minimum width a text element can be created with.
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
TextElement is a base class for other annotation classes, like TextNote, which have additional, more specific functionality.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TextElement Properties

The TextElement type exposes the following members.

Properties
Name | Description
Public property AssemblyInstanceId The id of the assembly instance to which the element belongs.
(Inherited from Element)
Public property | BaseDirection | Direction of the base line of the text element.
BoundingBox Retrieves a box that circumscribes all geometry of the element.
(Inherited from Element)
Public property Category Retrieves a Category object that represents the category or sub category in which the element resides.
(Inherited from Element)
Public property | Coord | Position of the text (in model coordinates.)
CreatedPhaseId Id of a Phase at which the Element was created.
(Inherited from Element)
DemolishedPhaseId Id of a Phase at which the Element was demolished.
(Inherited from Element)
DesignOption Returns the design option to which the element belongs.
(Inherited from Element)
Public property Document Returns the Document in which the Element resides.
(Inherited from Element)
Geometry Retrieves the geometric representation of the element.
(Inherited from Element)
Public property GroupId The id of the group to which an element belongs.
(Inherited from Element)
Public property | Height | Height of the area of the text content.
Public property | HorizontalAlignment | Horizontal alignment of the text content within the text area of the element.
Id A unique identifier for an Element in an Autodesk Revit project.
(Inherited from Element)
Public property IsModifiable Identifies if the element is modifiable.
(Inherited from Element)
Public property IsTextWrappingActive

A flag identifying whether text-wrapping is currently active in this text element or not.

If text wrapping is active the width of the text box remains constant and the text will wrap. The height of the text box will automatically adjust to accomodate the height of the text.

If text wrapping is not active the text does not wrap and the width of the text box adjusts with the width of the longest line of text. As the text width changes, the position of the text may change depending on the HorizontalAlignment

Public property IsTransient Indicates whether an element is transient or permanent.
(Inherited from Element)
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from Element)
Public property | KeepRotatedTextReadable | A flag to control how text behaves inside a rotated text element.
Public property LevelId The id of the level associated with the element.
(Inherited from Element)
Location This property is used to find the physical location of an element within a project.
(Inherited from Element)
Public property Name A human readable name for the Element.
(Inherited from Element)
Public property OwnerViewId The id of the view that owns the element.
(Inherited from Element)
ParameterBuiltInParameter Retrieves a parameter from the element given a parameter id.
(Inherited from Element)
Public property ParameterDefinition Retrieves a parameter from the element based on its definition.
(Inherited from Element)
Public property ParameterGuid Retrieves a parameter from the element given a GUID for a shared parameter.
(Inherited from Element)
Parameters Retrieves a set containing all of the parameters that are contained within the element.
(Inherited from Element)
Public property ParametersMap Retrieves a map containing all of the parameters that are contained within the element.
(Inherited from Element)
Public property Pinned Identifies if the element has been pinned to prevent changes.
(Inherited from Element)
Public property | Symbol | Get the type of the TextElement object.
Public property | Text | The content of the element as a plain string stripped of all formating.
UniqueId A stable unique identifier for an element within the document.
(Inherited from Element)
Public property | UpDirection | Direction along the vertical axis of letters of the text note.
Public property VersionGuid Get the element version Guid.
(Inherited from Element)
Public property | VerticalAlignment | Vertical alignment of the text.
Public property ViewSpecific Identifies if the element is owned by a view.
(Inherited from Element)
Public property | Width | Width of the area of the text content.
Public property WorksetId Get Id of the Workset which owns the element.
(Inherited from Element)
Top
See Also

Reference

TextElement Class


TextElement.BaseDirection Property

TextElementBaseDirection Property

Direction of the base line of the text element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ BaseDirection { get; }
Public ReadOnly Property BaseDirection As XYZ
    Get
public:
property XYZ^ BaseDirection {
    XYZ^ get ();
}
member BaseDirection : XYZ with get

Property Value

XYZ
Remarks

Base direction is always perpendicular to Up direction. Those two vectors together define the plane of the text.

See Also

Reference

TextElement Class


TextElement.Coord Property

TextElementCoord Property

Position of the text (in model coordinates.)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Coord { get; set; }
Public Property Coord As XYZ
    Get
    Set
public:
property XYZ^ Coord {
    XYZ^ get ();
    void set (XYZ^ value);
}
member Coord : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
ArgumentException | When setting this property: A valid point must not be father then 10 miles (approx. 16 km) from the origin.
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks

The position defines a point on the edge of the text area, not a point on the border (if a border is defined for the style.) It means that if the width of the border gets changed, the position of the text area remains unchanged.

The relation of the position point with respect to the text area depends on the text alignment as follows:

  • For Left-aligned text the point is at the Left-Top corned of the box.
  • For Center-aligned text the point is at the Middle-Top corned of the box.
  • For Right-aligned text the point is at the Right-Top corned of the box.
See Also

Reference

TextElement Class


TextElement.Height Property

TextElementHeight Property

Height of the area of the text content.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Height { get; }
Public ReadOnly Property Height As Double
    Get
public:
property double Height {
    double get ();
}
member Height : float with get

Property Value

Double
Remarks

The value is in sheet units, meaning it is as when measured on a printed sheet. The measurement is of the text content only; the border around it (if specified) is excluded.

This is a read-only property, for the height of the text area is calculated depending on the text content and its wrapping.

See Also

Reference

TextElement Class


TextElement.HorizontalAlignment Property

TextElementHorizontalAlignment Property

Horizontal alignment of the text content within the text area of the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public HorizontalTextAlignment HorizontalAlignment { get; set; }
Public Property HorizontalAlignment As HorizontalTextAlignment
    Get
    Set
public:
property HorizontalTextAlignment HorizontalAlignment {
    HorizontalTextAlignment get ();
    void set (HorizontalTextAlignment value);
}
member HorizontalAlignment : HorizontalTextAlignment with get, set

Property Value

HorizontalTextAlignment
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

TextElement Class


TextElement.IsTextWrappingActive Property

TextElementIsTextWrappingActive Property

A flag identifying whether text-wrapping is currently active in this text element or not.

If text wrapping is active the width of the text box remains constant and the text will wrap. The height of the text box will automatically adjust to accomodate the height of the text.

If text wrapping is not active the text does not wrap and the width of the text box adjusts with the width of the longest line of text. As the text width changes, the position of the text may change depending on the HorizontalAlignment

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsTextWrappingActive { get; }
Public ReadOnly Property IsTextWrappingActive As Boolean
    Get
public:
property bool IsTextWrappingActive {
    bool get ();
}
member IsTextWrappingActive : bool with get

Property Value

Boolean
Remarks

This is currently a read-only property and its value is set when the text element is created. If the element was created with a specified width or if an explicit width was set later, the wrapping would be automatically set as active. It means that any text line that is longer that the current width of the text-box will automatically wrapped onto the next line.

See Also

Reference

TextElement Class


TextElement.KeepRotatedTextReadable Property

TextElementKeepRotatedTextReadable Property

A flag to control how text behaves inside a rotated text element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool KeepRotatedTextReadable { get; set; }
Public Property KeepRotatedTextReadable As Boolean
    Get
    Set
public:
property bool KeepRotatedTextReadable {
    bool get ();
    void set (bool value);
}
member KeepRotatedTextReadable : bool with get, set

Property Value

Boolean
Remarks

If the property is True then the text inside the text box gets oriented so it is readable when looking straight up at the sheet or from its right side; in other words, the text would never be upside down.

If the value is False, however, the text's orientation strictly follows the rotation of the text box, which means the text may be upside down when viewed on screen or printed on a sheet.

See Also

Reference

TextElement Class


TextElement.Symbol Property

TextElementSymbol Property

Get the type of the TextElement object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TextElementType Symbol { get; }
Public ReadOnly Property Symbol As TextElementType
    Get
public:
property TextElementType^ Symbol {
    TextElementType^ get ();
}
member Symbol : TextElementType with get

Property Value

TextElementType
Remarks
The user can call this property to get the related type.
See Also

Reference

TextElement Class


TextElement.Text Property

TextElementText Property

The content of the element as a plain string stripped of all formating.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
member Text : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks

If a new text content is set, all previous formating that might have been set on parts of the original text will be lost. After setting the new text, only the formating parameters of the associated text type will be applied.

The value of this property can also be accessed via the TEXT_TEXT Built-In parameter.

See Also

Reference

TextElement Class


TextElement.UpDirection Property

TextElementUpDirection Property

Direction along the vertical axis of letters of the text note.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ UpDirection { get; }
Public ReadOnly Property UpDirection As XYZ
    Get
public:
property XYZ^ UpDirection {
    XYZ^ get ();
}
member UpDirection : XYZ with get

Property Value

XYZ
Remarks

This vector points up from the base of the letters and is always perpendicular to the base direction. Those two vectors together define the plane of the text.

See Also

Reference

TextElement Class


TextElement.VerticalAlignment Property

TextElementVerticalAlignment Property

Vertical alignment of the text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VerticalTextAlignment VerticalAlignment { get; set; }
Public Property VerticalAlignment As VerticalTextAlignment
    Get
    Set
public:
property VerticalTextAlignment VerticalAlignment {
    VerticalTextAlignment get ();
    void set (VerticalTextAlignment value);
}
member VerticalAlignment : VerticalTextAlignment with get, set

Property Value

VerticalTextAlignment
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
The vertical alignment determines the way text is positioned as the text height changes.
  • For Top-aligned text the top of the text will remain in place.
  • For Middle-aligned text the horizontal center line of the text will remain in place.
  • For Bottom-aligned text the bottom of the text will remain in place.
Changing this property will not affect the position of the text element.
See Also

Reference

TextElement Class


TextElement.Width Property

TextElementWidth Property

Width of the area of the text content.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Width { get; set; }
Public Property Width As Double
    Get
    Set
public:
property double Width {
    double get ();
    void set (double value);
}
member Width : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentException | When setting this property: The given width is not valid. A valid value must be within the range returned by the methods GetMinimumAllowedWidth and GetMaximumAllowedWidth.
Remarks

This property supersedes the older [!:LineWidth] property which has been deprecated.

The value is in sheet units, meaning it is as when measured on a printed sheet. The measurement is of the text content only; the border around it (if specified) is excluded.

For a text element which does is set not to use text wrapping the width is calculated to fit the longest line (a single line, typically) of the text. A setting the width explicitly by assigning value to this property will automatically activate text-wrapping for the element.

See Also

Reference

TextElement Class


TextElement Methods

The TextElement type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMaximumAllowedWidth | Returns the maximum width the text element can be assigned.
 | GetMaximumAllowedWidth(Document, ElementId) | Returns the maximum width the text element can be created with.
Public method | GetMinimumAllowedWidth | Returns the minimum width the text element can be assigned.
 | GetMinimumAllowedWidth(Document, ElementId) | Returns the minimum width a text element can be created with.
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

TextElement Class


TextElement.GetMaximumAllowedWidth Method

TextElementGetMaximumAllowedWidth Method

Overload List
 | Name | Description
Public method | GetMaximumAllowedWidth | Returns the maximum width the text element can be assigned.
 | GetMaximumAllowedWidth(Document, ElementId) | Returns the maximum width the text element can be created with.
Top
See Also

Reference

TextElement Class


TextElement.GetMaximumAllowedWidth Method

TextElementGetMaximumAllowedWidth Method

Returns the maximum width the text element can be assigned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetMaximumAllowedWidth()
Public Function GetMaximumAllowedWidth As Double
public:
double GetMaximumAllowedWidth()
member GetMaximumAllowedWidth : unit -> float

Return Value

Double
The maximum allowed width in paper space [ft].
Remarks
Note that it is not necessarily a constant; it can be affected by properties of the text and its type, such as the width factor.
See Also

Reference

TextElement Class
GetMaximumAllowedWidth Overload


TextElement.GetMaximumAllowedWidth(Document, ElementId) Method

TextElementGetMaximumAllowedWidth(Document, ElementId) Method

Returns the maximum width the text element can be created with.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static double GetMaximumAllowedWidth(
    Document cdda,
    ElementId typeId
)
Public Shared Function GetMaximumAllowedWidth (
    cdda As Document,
    typeId As ElementId
) As Double
public:
static double GetMaximumAllowedWidth(
    Document^ cdda,
    ElementId^ typeId
)
static member GetMaximumAllowedWidth :
        cdda : Document *
        typeId : ElementId -> float

Parameters

cdda Document
A document containing the new text element's type
typeId ElementId
Id of the text type

Return Value

Double
The maximum allowed width in paper space [ft].
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Note that it is not necessarily a constant; it can be affected by properties of the text type, such as the width factor.
See Also

Reference

TextElement Class
GetMaximumAllowedWidth Overload


TextElement.GetMinimumAllowedWidth Method

TextElementGetMinimumAllowedWidth Method

Overload List
 | Name | Description
Public method | GetMinimumAllowedWidth | Returns the minimum width the text element can be assigned.
 | GetMinimumAllowedWidth(Document, ElementId) | Returns the minimum width a text element can be created with.
Top
See Also

Reference

TextElement Class


TextElement.GetMinimumAllowedWidth Method

TextElementGetMinimumAllowedWidth Method

Returns the minimum width the text element can be assigned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetMinimumAllowedWidth()
Public Function GetMinimumAllowedWidth As Double
public:
double GetMinimumAllowedWidth()
member GetMinimumAllowedWidth : unit -> float

Return Value

Double
The minimum allowed width in paper space [ft].
Remarks
Note that it is not necessarily a constant; it can be affected by properties of the text and its type, such as the width factor.
See Also

Reference

TextElement Class
GetMinimumAllowedWidth Overload


TextElement.GetMinimumAllowedWidth(Document, ElementId) Method

TextElementGetMinimumAllowedWidth(Document, ElementId) Method

Returns the minimum width a text element can be created with.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static double GetMinimumAllowedWidth(
    Document cdda,
    ElementId typeId
)
Public Shared Function GetMinimumAllowedWidth (
    cdda As Document,
    typeId As ElementId
) As Double
public:
static double GetMinimumAllowedWidth(
    Document^ cdda,
    ElementId^ typeId
)
static member GetMinimumAllowedWidth :
        cdda : Document *
        typeId : ElementId -> float

Parameters

cdda Document
A document containing the new text element's type
typeId ElementId
Id of the text type

Return Value

Double
The minimum allowed width in paper space [ft].
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Note that it is not necessarily a constant; it can be affected by properties of the text type, such as the width factor.
Example
C#
VB
C++
F#
Copy
public TextNote AddNewTextNote(UIDocument uiDoc)
{
    Document doc = uiDoc.Document;
    XYZ textLoc = uiDoc.Selection.PickPoint("Pick a point for sample text.");
    ElementId defaultTextTypeId = doc.GetDefaultElementTypeId(ElementTypeGroup.TextNoteType);
    double noteWidth = .2;

    // make sure note width works for the text type
    double minWidth = TextNote.GetMinimumAllowedWidth(doc, defaultTextTypeId);
    double maxWidth = TextNote.GetMaximumAllowedWidth(doc, defaultTextTypeId);
    if (noteWidth < minWidth)
    {
        noteWidth = minWidth;
    }
    else if (noteWidth > maxWidth)
    {
        noteWidth = maxWidth;
    }

    TextNoteOptions opts = new TextNoteOptions(defaultTextTypeId);
    opts.HorizontalAlignment = HorizontalTextAlignment.Left;
    opts.Rotation = Math.PI / 4;

    TextNote textNote = TextNote.Create(doc, doc.ActiveView.Id, textLoc, noteWidth, "New sample text", opts);

    return textNote;
}
Public Function AddNewTextNote(uiDoc As UIDocument) As TextNote
    Dim doc As Document = uiDoc.Document
    Dim textLoc As XYZ = uiDoc.Selection.PickPoint("Pick a point for sample text.")
    Dim defaultTextTypeId As ElementId = doc.GetDefaultElementTypeId(ElementTypeGroup.TextNoteType)
    Dim noteWidth As Double = 0.2

    ' make sure note width works for the text type
    Dim minWidth As Double = TextNote.GetMinimumAllowedWidth(doc, defaultTextTypeId)
    Dim maxWidth As Double = TextNote.GetMaximumAllowedWidth(doc, defaultTextTypeId)
    If noteWidth < minWidth Then
        noteWidth = minWidth
    ElseIf noteWidth > maxWidth Then
        noteWidth = maxWidth
    End If

    Dim opts As New TextNoteOptions(defaultTextTypeId)
    opts.HorizontalAlignment = HorizontalTextAlignment.Left
    opts.Rotation = Math.PI / 4

    Dim textNote__1 As TextNote = TextNote.Create(doc, doc.ActiveView.Id, textLoc, noteWidth, "New sample text", opts)

    Return textNote__1
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

TextElement Class
GetMinimumAllowedWidth Overload


TextElementBackground Enumeration

An enumerated type listing all the background mode for the built-in parameter TEXT_BACKGROUND.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum TextElementBackground
Public Enumeration TextElementBackground
public enum class TextElementBackground
type TextElementBackground
Members
Member name | Value | Description
TBGR_OPAQUE | 0 | The TextElement object is opaque.
TBGR_TRANSPARENT | 1 | The TextElement object is transparent.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TextElementType Class

An object that represents a text style.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBLineAndTextAttrSymbol
Autodesk.Revit.DBTextElementType
Autodesk.Revit.DBTextNoteType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TextElementType : LineAndTextAttrSymbol
Public Class TextElementType
    Inherits LineAndTextAttrSymbol
public ref class TextElementType : public LineAndTextAttrSymbol
type TextElementType =
    class
        inherit LineAndTextAttrSymbol
    end

The TextElementType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TextElementType Properties

The TextElementType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

TextElementType Class


TextElementType Methods

The TextElementType type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

TextElementType Class


TextListStyle Enumeration

Supported styles of text list paragraphs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum TextListStyle
Public Enumeration TextListStyle
public enum class TextListStyle
type TextListStyle
Members
Member name | Value | Description
None | 0 | Indicates that the paragraph is not a list.
Bullet | 1 | Indicates a list that uses standard bullets.
NumberArabic | 2 | Indicates a list that uses arabic numbers.
LetterLowercase | 3 | Indicates a list that uses lowercase letters.
LetterUppercase | 4 | Indicates a list that uses uppercase letters.
NumberRomanLowercase | 5 | Indicates a list that uses lowercase Roman numbers.
NumberRomanUppercase | 6 | Indicates a list that uses uppercase Roman numbers.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TextNode Class

This class represents a text annotation object in a model-exporting process.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRenderNode
Autodesk.Revit.DBTextNode

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TextNode : RenderNode
Public Class TextNode
    Inherits RenderNode
public ref class TextNode : public RenderNode
type TextNode =
    class
        inherit RenderNode
    end

The TextNode type exposes the following members.

Properties
 | Name | Description
Public property | BaseDirection | Direction of the base line of the text object in model space.
Public property | Color | The color of the text.
Public property | FontHeight | Height [ft] of the text font, in model space.
Public property | FontName | The name of the text font.
Public property | Height | Height [ft] of the area of the text content in model space.
Public property | HorizontalAlignment | Indicates default horizontal alignment of the text.
Public property | IsBold | Indicates whether the default formatting is set to bold text.
Public property | IsItalic | Indicates whether the default formatting is set to italic text.
Public property | IsKeptReadable | Indicates text behavior inside a rotated text object.
Public property | IsTransparent | Indicates whether the text background is transparent or opaque.
Public property | IsUnderlined | Indicates whether the default formatting is set to underlined text.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode)
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode)
Public property | Position | Position of the text in model coordinates.
Public property | TabSize | The size [ft] of the interval between tab stops, in model space.
Public property | Text | The content of the text annotation as a plain string stripped of all formatting.
Public property | UpDirection | Direction along the vertical axis of letters of the text object in model space.
Public property | VerticalAlignment | Indicates default vertical alignment of the text.
Public property | Width | Width [ft] of the area of the text content in model space.
Public property | WidthScale | Scale applied to the width of the text.
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from RenderNode)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetFormattedText | Returns an FormattedText object that contains text and associated formatting of this TextNode.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
See also: OnText(TextNode).
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TextNode Properties

The TextNode type exposes the following members.

Properties
 | Name | Description
Public property | BaseDirection | Direction of the base line of the text object in model space.
Public property | Color | The color of the text.
Public property | FontHeight | Height [ft] of the text font, in model space.
Public property | FontName | The name of the text font.
Public property | Height | Height [ft] of the area of the text content in model space.
Public property | HorizontalAlignment | Indicates default horizontal alignment of the text.
Public property | IsBold | Indicates whether the default formatting is set to bold text.
Public property | IsItalic | Indicates whether the default formatting is set to italic text.
Public property | IsKeptReadable | Indicates text behavior inside a rotated text object.
Public property | IsTransparent | Indicates whether the text background is transparent or opaque.
Public property | IsUnderlined | Indicates whether the default formatting is set to underlined text.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode)
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode)
Public property | Position | Position of the text in model coordinates.
Public property | TabSize | The size [ft] of the interval between tab stops, in model space.
Public property | Text | The content of the text annotation as a plain string stripped of all formatting.
Public property | UpDirection | Direction along the vertical axis of letters of the text object in model space.
Public property | VerticalAlignment | Indicates default vertical alignment of the text.
Public property | Width | Width [ft] of the area of the text content in model space.
Public property | WidthScale | Scale applied to the width of the text.
Top
See Also

Reference

TextNode Class


TextNode.BaseDirection Property

TextNodeBaseDirection Property

Direction of the base line of the text object in model space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ BaseDirection { get; }
Public ReadOnly Property BaseDirection As XYZ
    Get
public:
property XYZ^ BaseDirection {
    XYZ^ get ();
}
member BaseDirection : XYZ with get

Property Value

XYZ
See Also

Reference

TextNode Class


TextNode.Color Property

TextNodeColor Property

The color of the text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color Color { get; }
Public ReadOnly Property Color As Color
    Get
public:
property Color^ Color {
    Color^ get ();
}
member Color : Color with get

Property Value

Color
See Also

Reference

TextNode Class


TextNode.FontHeight Property

TextNodeFontHeight Property

Height [ft] of the text font, in model space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double FontHeight { get; }
Public ReadOnly Property FontHeight As Double
    Get
public:
property double FontHeight {
    double get ();
}
member FontHeight : float with get

Property Value

Double
Remarks
This is the height of the 'M' glyph in the text font.
See Also

Reference

TextNode Class


TextNode.FontName Property

TextNodeFontName Property

The name of the text font.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FontName { get; }
Public ReadOnly Property FontName As String
    Get
public:
property String^ FontName {
    String^ get ();
}
member FontName : string with get

Property Value

String
See Also

Reference

TextNode Class


TextNode.Height Property

TextNodeHeight Property

Height [ft] of the area of the text content in model space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Height { get; }
Public ReadOnly Property Height As Double
    Get
public:
property double Height {
    double get ();
}
member Height : float with get

Property Value

Double
See Also

Reference

TextNode Class


TextNode.HorizontalAlignment Property

TextNodeHorizontalAlignment Property

Indicates default horizontal alignment of the text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public HorizontalTextAlignment HorizontalAlignment { get; }
Public ReadOnly Property HorizontalAlignment As HorizontalTextAlignment
    Get
public:
property HorizontalTextAlignment HorizontalAlignment {
    HorizontalTextAlignment get ();
}
member HorizontalAlignment : HorizontalTextAlignment with get

Property Value

HorizontalTextAlignment
See Also

Reference

TextNode Class


TextNode.IsBold Property

TextNodeIsBold Property

Indicates whether the default formatting is set to bold text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsBold { get; }
Public ReadOnly Property IsBold As Boolean
    Get
public:
property bool IsBold {
    bool get ();
}
member IsBold : bool with get

Property Value

Boolean
See Also

Reference

TextNode Class


TextNode.IsItalic Property

TextNodeIsItalic Property

Indicates whether the default formatting is set to italic text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsItalic { get; }
Public ReadOnly Property IsItalic As Boolean
    Get
public:
property bool IsItalic {
    bool get ();
}
member IsItalic : bool with get

Property Value

Boolean
See Also

Reference

TextNode Class


TextNode.IsKeptReadable Property

TextNodeIsKeptReadable Property

Indicates text behavior inside a rotated text object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsKeptReadable { get; }
Public ReadOnly Property IsKeptReadable As Boolean
    Get
public:
property bool IsKeptReadable {
    bool get ();
}
member IsKeptReadable : bool with get

Property Value

Boolean
Remarks

If the property is True then the text inside the text box gets oriented so it is readable when looking straight up at the sheet or from its right side; in other words, the text would never be upside down.

If the value is False, however, the text's orientation strictly follows the rotation of the text box, which means the text may be upside down when viewed on screen or printed on a sheet.

See Also

Reference

TextNode Class


TextNode.IsTransparent Property

TextNodeIsTransparent Property

Indicates whether the text background is transparent or opaque.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsTransparent { get; }
Public ReadOnly Property IsTransparent As Boolean
    Get
public:
property bool IsTransparent {
    bool get ();
}
member IsTransparent : bool with get

Property Value

Boolean
See Also

Reference

TextNode Class


TextNode.IsUnderlined Property

TextNodeIsUnderlined Property

Indicates whether the default formatting is set to underlined text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsUnderlined { get; }
Public ReadOnly Property IsUnderlined As Boolean
    Get
public:
property bool IsUnderlined {
    bool get ();
}
member IsUnderlined : bool with get

Property Value

Boolean
See Also

Reference

TextNode Class


TextNode.Position Property

TextNodePosition Property

Position of the text in model coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Position { get; }
Public ReadOnly Property Position As XYZ
    Get
public:
property XYZ^ Position {
    XYZ^ get ();
}
member Position : XYZ with get

Property Value

XYZ
Remarks

The relation of the position point with respect to the text area depends on the text alignment.

For example:

  • For Left-Top-aligned text the point is at the Left-Top corner of the box.
  • For Center-Bottom aligned text the point is at the Center-Bottom corner of the box.

See Also

Reference

TextNode Class


TextNode.TabSize Property

TextNodeTabSize Property

The size [ft] of the interval between tab stops, in model space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double TabSize { get; }
Public ReadOnly Property TabSize As Double
    Get
public:
property double TabSize {
    double get ();
}
member TabSize : float with get

Property Value

Double
See Also

Reference

TextNode Class


TextNode.Text Property

TextNodeText Property

The content of the text annotation as a plain string stripped of all formatting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Text { get; }
Public ReadOnly Property Text As String
    Get
public:
property String^ Text {
    String^ get ();
}
member Text : string with get

Property Value

String
Remarks
The text may contain new-lines if there are any in the text annotation.
See Also

Reference

TextNode Class


TextNode.UpDirection Property

TextNodeUpDirection Property

Direction along the vertical axis of letters of the text object in model space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ UpDirection { get; }
Public ReadOnly Property UpDirection As XYZ
    Get
public:
property XYZ^ UpDirection {
    XYZ^ get ();
}
member UpDirection : XYZ with get

Property Value

XYZ
See Also

Reference

TextNode Class


TextNode.VerticalAlignment Property

TextNodeVerticalAlignment Property

Indicates default vertical alignment of the text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VerticalTextAlignment VerticalAlignment { get; }
Public ReadOnly Property VerticalAlignment As VerticalTextAlignment
    Get
public:
property VerticalTextAlignment VerticalAlignment {
    VerticalTextAlignment get ();
}
member VerticalAlignment : VerticalTextAlignment with get

Property Value

VerticalTextAlignment
See Also

Reference

TextNode Class


TextNode.Width Property

TextNodeWidth Property

Width [ft] of the area of the text content in model space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Width { get; }
Public ReadOnly Property Width As Double
    Get
public:
property double Width {
    double get ();
}
member Width : float with get

Property Value

Double
Remarks
Specifies the actual width of the text, that is essentially the width of the longest line, including any spaces. The value represents the width after the width scale has been applied.
See Also

Reference

TextNode Class


TextNode.WidthScale Property

TextNodeWidthScale Property

Scale applied to the width of the text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double WidthScale { get; }
Public ReadOnly Property WidthScale As Double
    Get
public:
property double WidthScale {
    double get ();
}
member WidthScale : float with get

Property Value

Double
See Also

Reference

TextNode Class


TextNode Methods

The TextNode type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from RenderNode)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetFormattedText | Returns an FormattedText object that contains text and associated formatting of this TextNode.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

TextNode Class


TextNode.GetFormattedText Method

TextNodeGetFormattedText Method

Returns an FormattedText object that contains text and associated formatting of this TextNode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormattedText GetFormattedText()
Public Function GetFormattedText As FormattedText
public:
FormattedText^ GetFormattedText()
member GetFormattedText : unit -> FormattedText

Return Value

FormattedText
The object that contains the text and associated formatting of of the text in this text note.
See Also

Reference

TextNode Class


TextNote Class

A class representing text note annotations in Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBTextElement
Autodesk.Revit.DBTextNote

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TextNote : TextElement
Public Class TextNote
    Inherits TextElement
public ref class TextNote : public TextElement
type TextNote =
    class
        inherit TextElement
    end

The TextNote type exposes the following members.

Properties
Name | Description
Public property AssemblyInstanceId The id of the assembly instance to which the element belongs.
(Inherited from Element)
Public property BaseDirection Direction of the base line of the text element.
(Inherited from TextElement)
BoundingBox Retrieves a box that circumscribes all geometry of the element.
(Inherited from Element)
Public property Category Retrieves a Category object that represents the category or sub category in which the element resides.
(Inherited from Element)
Public property Coord Position of the text (in model coordinates.)
(Inherited from TextElement)
CreatedPhaseId Id of a Phase at which the Element was created.
(Inherited from Element)
DemolishedPhaseId Id of a Phase at which the Element was demolished.
(Inherited from Element)
DesignOption Returns the design option to which the element belongs.
(Inherited from Element)
Public property Document Returns the Document in which the Element resides.
(Inherited from Element)
Geometry Retrieves the geometric representation of the element.
(Inherited from Element)
Public property GroupId The id of the group to which an element belongs.
(Inherited from Element)
Public property Height Height of the area of the text content.
(Inherited from TextElement)
Public property HorizontalAlignment Horizontal alignment of the text content within the text area of the element.
(Inherited from TextElement)
Id A unique identifier for an Element in an Autodesk Revit project.
(Inherited from Element)
Public property IsModifiable Identifies if the element is modifiable.
(Inherited from Element)
Public property IsTextWrappingActive

A flag identifying whether text-wrapping is currently active in this text element or not.

If text wrapping is active the width of the text box remains constant and the text will wrap. The height of the text box will automatically adjust to accomodate the height of the text.

If text wrapping is not active the text does not wrap and the width of the text box adjusts with the width of the longest line of text. As the text width changes, the position of the text may change depending on the HorizontalAlignment

(Inherited from TextElement)
Public property IsTransient Indicates whether an element is transient or permanent.
(Inherited from Element)
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from Element)
Public property KeepRotatedTextReadable A flag to control how text behaves inside a rotated text element.
(Inherited from TextElement)
Public property | LeaderCount | Number of leader objects currently attached to the text note.
Public property | LeaderLeftAttachment | Attachment position of leaders on the left side of the text note.
Public property | LeaderRightAttachment | Attachment position of leaders on the right side of the text note.
Public property LevelId The id of the level associated with the element.
(Inherited from Element)
Location This property is used to find the physical location of an element within a project.
(Inherited from Element)
Public property Name A human readable name for the Element.
(Inherited from Element)
Public property OwnerViewId The id of the view that owns the element.
(Inherited from Element)
ParameterBuiltInParameter Retrieves a parameter from the element given a parameter id.
(Inherited from Element)
Public property ParameterDefinition Retrieves a parameter from the element based on its definition.
(Inherited from Element)
Public property ParameterGuid Retrieves a parameter from the element given a GUID for a shared parameter.
(Inherited from Element)
Parameters Retrieves a set containing all of the parameters that are contained within the element.
(Inherited from Element)
Public property ParametersMap Retrieves a map containing all of the parameters that are contained within the element.
(Inherited from Element)
Public property Pinned Identifies if the element has been pinned to prevent changes.
(Inherited from Element)
Public property Symbol Get the type of the TextElement object.
(Inherited from TextElement)
Public property Text The content of the element as a plain string stripped of all formating.
(Inherited from TextElement)
Public property | TextNoteType | Access the type of the TextNote object.
UniqueId A stable unique identifier for an element within the document.
(Inherited from Element)
Public property UpDirection Direction along the vertical axis of letters of the text note.
(Inherited from TextElement)
Public property VersionGuid Get the element version Guid.
(Inherited from Element)
Public property VerticalAlignment Vertical alignment of the text.
(Inherited from TextElement)
Public property ViewSpecific Identifies if the element is owned by a view.
(Inherited from Element)
Public property Width Width of the area of the text content.
(Inherited from TextElement)
Public property WorksetId Get Id of the Workset which owns the element.
(Inherited from Element)
Top
Methods
 | Name | Description
Public method | AddLeader | Adds a leader to the text note.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create(Document, ElementId, XYZ, String, ElementId) | Creates a new unwrapped TextNote element with the given properties.
 | Create(Document, ElementId, XYZ, String, TextNoteOptions) | Creates a new unwrapped text note element with the given properties.
 | Create(Document, ElementId, XYZ, Double, String, ElementId) | Creates a new line-wrapping text note element of the given width and properties.
 | Create(Document, ElementId, XYZ, Double, String, TextNoteOptions) | Creates a new line-wrapping text note element of the given width and properties.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetFormattedText | Returns an object that contains text and associated formatting of this note.
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLeaders | Returns a collection of leaders currently attached to the text note.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMaximumAllowedWidth | Returns the maximum width the text element can be assigned. (Inherited from TextElement)
Public method | GetMinimumAllowedWidth | Returns the minimum width the text element can be assigned. (Inherited from TextElement)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveLeaders | Removes all leaders currently attached to the text note.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
 | SetFormattedText | Sets the text and associated formatting of the text of in this text note with a given FormattedText object.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TextNote Properties

The TextNote type exposes the following members.

Properties
Name | Description
Public property AssemblyInstanceId The id of the assembly instance to which the element belongs.
(Inherited from Element)
Public property BaseDirection Direction of the base line of the text element.
(Inherited from TextElement)
BoundingBox Retrieves a box that circumscribes all geometry of the element.
(Inherited from Element)
Public property Category Retrieves a Category object that represents the category or sub category in which the element resides.
(Inherited from Element)
Public property Coord Position of the text (in model coordinates.)
(Inherited from TextElement)
CreatedPhaseId Id of a Phase at which the Element was created.
(Inherited from Element)
DemolishedPhaseId Id of a Phase at which the Element was demolished.
(Inherited from Element)
DesignOption Returns the design option to which the element belongs.
(Inherited from Element)
Public property Document Returns the Document in which the Element resides.
(Inherited from Element)
Geometry Retrieves the geometric representation of the element.
(Inherited from Element)
Public property GroupId The id of the group to which an element belongs.
(Inherited from Element)
Public property Height Height of the area of the text content.
(Inherited from TextElement)
Public property HorizontalAlignment Horizontal alignment of the text content within the text area of the element.
(Inherited from TextElement)
Id A unique identifier for an Element in an Autodesk Revit project.
(Inherited from Element)
Public property IsModifiable Identifies if the element is modifiable.
(Inherited from Element)
Public property IsTextWrappingActive

A flag identifying whether text-wrapping is currently active in this text element or not.

If text wrapping is active the width of the text box remains constant and the text will wrap. The height of the text box will automatically adjust to accomodate the height of the text.

If text wrapping is not active the text does not wrap and the width of the text box adjusts with the width of the longest line of text. As the text width changes, the position of the text may change depending on the HorizontalAlignment

(Inherited from TextElement)
Public property IsTransient Indicates whether an element is transient or permanent.
(Inherited from Element)
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from Element)
Public property KeepRotatedTextReadable A flag to control how text behaves inside a rotated text element.
(Inherited from TextElement)
Public property | LeaderCount | Number of leader objects currently attached to the text note.
Public property | LeaderLeftAttachment | Attachment position of leaders on the left side of the text note.
Public property | LeaderRightAttachment | Attachment position of leaders on the right side of the text note.
Public property LevelId The id of the level associated with the element.
(Inherited from Element)
Location This property is used to find the physical location of an element within a project.
(Inherited from Element)
Public property Name A human readable name for the Element.
(Inherited from Element)
Public property OwnerViewId The id of the view that owns the element.
(Inherited from Element)
ParameterBuiltInParameter Retrieves a parameter from the element given a parameter id.
(Inherited from Element)
Public property ParameterDefinition Retrieves a parameter from the element based on its definition.
(Inherited from Element)
Public property ParameterGuid Retrieves a parameter from the element given a GUID for a shared parameter.
(Inherited from Element)
Parameters Retrieves a set containing all of the parameters that are contained within the element.
(Inherited from Element)
Public property ParametersMap Retrieves a map containing all of the parameters that are contained within the element.
(Inherited from Element)
Public property Pinned Identifies if the element has been pinned to prevent changes.
(Inherited from Element)
Public property Symbol Get the type of the TextElement object.
(Inherited from TextElement)
Public property Text The content of the element as a plain string stripped of all formating.
(Inherited from TextElement)
Public property | TextNoteType | Access the type of the TextNote object.
UniqueId A stable unique identifier for an element within the document.
(Inherited from Element)
Public property UpDirection Direction along the vertical axis of letters of the text note.
(Inherited from TextElement)
Public property VersionGuid Get the element version Guid.
(Inherited from Element)
Public property VerticalAlignment Vertical alignment of the text.
(Inherited from TextElement)
Public property ViewSpecific Identifies if the element is owned by a view.
(Inherited from Element)
Public property Width Width of the area of the text content.
(Inherited from TextElement)
Public property WorksetId Get Id of the Workset which owns the element.
(Inherited from Element)
Top
See Also

Reference

TextNote Class


TextNote.LeaderCount Property

TextNoteLeaderCount Property

Number of leader objects currently attached to the text note.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int LeaderCount { get; }
Public ReadOnly Property LeaderCount As Integer
    Get
public:
property int LeaderCount {
    int get ();
}
member LeaderCount : int with get

Property Value

Int32
See Also

Reference

TextNote Class


TextNote.LeaderLeftAttachment Property

TextNoteLeaderLeftAttachment Property

Attachment position of leaders on the left side of the text note.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LeaderAtachement LeaderLeftAttachment { get; set; }
Public Property LeaderLeftAttachment As LeaderAtachement
    Get
    Set
public:
property LeaderAtachement LeaderLeftAttachment {
    LeaderAtachement get ();
    void set (LeaderAtachement value);
}
member LeaderLeftAttachment : LeaderAtachement with get, set

Property Value

LeaderAtachement
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks

The property controls the vertical position of leaders attached to the left side of the note.

Change of the value will affect all leaders currently attached to the left side.

See Also

Reference

TextNote Class


TextNote.LeaderRightAttachment Property

TextNoteLeaderRightAttachment Property

Attachment position of leaders on the right side of the text note.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LeaderAtachement LeaderRightAttachment { get; set; }
Public Property LeaderRightAttachment As LeaderAtachement
    Get
    Set
public:
property LeaderAtachement LeaderRightAttachment {
    LeaderAtachement get ();
    void set (LeaderAtachement value);
}
member LeaderRightAttachment : LeaderAtachement with get, set

Property Value

LeaderAtachement
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks

The property controls the vertical position of leaders attached to the right side of the note.

Change of the value will affect all leaders currently attached to the right side.

See Also

Reference

TextNote Class


TextNote.TextNoteType Property

TextNoteTextNoteType Property

Access the type of the TextNote object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TextNoteType TextNoteType { get; set; }
Public Property TextNoteType As TextNoteType
    Get
    Set
public:
property TextNoteType^ TextNoteType {
    TextNoteType^ get ();
    void set (TextNoteType^ value);
}
member TextNoteType : TextNoteType with get, set

Property Value

TextNoteType
Remarks
The type of the TextNote object can be retrieved or changed.
See Also

Reference

TextNote Class


TextNote Methods

The TextNote type exposes the following members.

Methods
 | Name | Description
Public method | AddLeader | Adds a leader to the text note.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create(Document, ElementId, XYZ, String, ElementId) | Creates a new unwrapped TextNote element with the given properties.
 | Create(Document, ElementId, XYZ, String, TextNoteOptions) | Creates a new unwrapped text note element with the given properties.
 | Create(Document, ElementId, XYZ, Double, String, ElementId) | Creates a new line-wrapping text note element of the given width and properties.
 | Create(Document, ElementId, XYZ, Double, String, TextNoteOptions) | Creates a new line-wrapping text note element of the given width and properties.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetFormattedText | Returns an object that contains text and associated formatting of this note.
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLeaders | Returns a collection of leaders currently attached to the text note.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMaximumAllowedWidth | Returns the maximum width the text element can be assigned. (Inherited from TextElement)
Public method | GetMinimumAllowedWidth | Returns the minimum width the text element can be assigned. (Inherited from TextElement)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveLeaders | Removes all leaders currently attached to the text note.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
 | SetFormattedText | Sets the text and associated formatting of the text of in this text note with a given FormattedText object.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

TextNote Class


TextNote.AddLeader Method

TextNoteAddLeader Method

Adds a leader to the text note.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Leader AddLeader(
    TextNoteLeaderTypes leaderType
)
Public Function AddLeader (
    leaderType As TextNoteLeaderTypes
) As Leader
public:
Leader^ AddLeader(
    TextNoteLeaderTypes leaderType
)
member AddLeader :
        leaderType : TextNoteLeaderTypes -> Leader

Parameters

leaderType TextNoteLeaderTypes
Type of the leader being added.

Return Value

Leader
The newly added leader.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Remarks
If the geometric type of the new leader (line vs arc.) differs from the type of existing leaders, then the type of the existing leaders will be changed to match the type of the newly created leader.
See Also

Reference

TextNote Class


TextNote.Create Method

TextNoteCreate Method

Overload List
Name | Description
Create(Document, ElementId, XYZ, String, ElementId) | Creates a new unwrapped TextNote element with the given properties.
Create(Document, ElementId, XYZ, String, TextNoteOptions) | Creates a new unwrapped text note element with the given properties.
Create(Document, ElementId, XYZ, Double, String, ElementId) | Creates a new line-wrapping text note element of the given width and properties.
Create(Document, ElementId, XYZ, Double, String, TextNoteOptions) | Creates a new line-wrapping text note element of the given width and properties.
Top
See Also

Reference

TextNote Class


TextNote.Create(Document, ElementId, XYZ, String, ElementId) Method

TextNoteCreate(Document, ElementId, XYZ, String, ElementId) Method

Creates a new unwrapped TextNote element with the given properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static TextNote Create(
    Document document,
    ElementId viewId,
    XYZ position,
    string text,
    ElementId typeId
)
Public Shared Function Create (
    document As Document,
    viewId As ElementId,
    position As XYZ,
    text As String,
    typeId As ElementId
) As TextNote
public:
static TextNote^ Create(
    Document^ document,
    ElementId^ viewId,
    XYZ^ position,
    String^ text,
    ElementId^ typeId
)
static member Create :
        document : Document *
        viewId : ElementId *
        position : XYZ *
        text : string *
        typeId : ElementId -> TextNote

Parameters

document Document
A valid Revit document that is currently modifiable (i.e. with an open transaction).
viewId ElementId
Id of the graphic view in which the note is to be created.
position XYZ
A model position of the new note.

For a left-aligned text (default), the origin is set at the top-left corner of the note's bounding box.

text String
Text to populate the text note with.
typeId ElementId
Id of the text type to use for the new text note.

Return Value

TextNote
The newly created text note.
Exceptions
Exception | Condition
ArgumentException | The document is a family that cannot contain text notes. -or- The viewId does not represent a valid graphic view element in the given document. -or- The typeId does not represent a valid text type in the given document. -or- A valid point must not be father then 10 miles (approx. 16 km) from the origin.
ArgumentNullException | A non-optional argument was null
Remarks

The new TextNote will consist of a single line of text unless there are carriage return ('\r') or vertical tab ('\v') characters in the given string. Once the text note is created its width gets adjusted to fit the longest (or the single one) line of text.

As a view-specific element the TextNote will be visible only in the specified view.

The new TextNote will be created using the given text type, which defines the style. The currently default style can be obtained from the Document.GetDefaultElementTypeId method.

See Also

Reference

TextNote Class
Create Overload


TextNote.Create(Document, ElementId, XYZ, String, TextNoteOptions) Method

TextNoteCreate(Document, ElementId, XYZ, String, TextNoteOptions) Method

Creates a new unwrapped text note element with the given properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static TextNote Create(
    Document document,
    ElementId viewId,
    XYZ position,
    string text,
    TextNoteOptions options
)
Public Shared Function Create (
    document As Document,
    viewId As ElementId,
    position As XYZ,
    text As String,
    options As TextNoteOptions
) As TextNote
public:
static TextNote^ Create(
    Document^ document,
    ElementId^ viewId,
    XYZ^ position,
    String^ text,
    TextNoteOptions^ options
)
static member Create :
        document : Document *
        viewId : ElementId *
        position : XYZ *
        text : string *
        options : TextNoteOptions -> TextNote

Parameters

document Document
A valid Revit document that is currently modifiable (i.e. with an open transaction).
viewId ElementId
Id of the graphic view in which the note is to be created.
position XYZ
A model position of the new note.

Note that the position's relation to the text's bounding box depends on the requested text alignment (set via the Options argument). It will be the box' top-left corner for a left-aligned text, the top-right corner for a right-aligned text, and middle-top point if the text is to be centered.

text String
Text to populate the text note with.
options TextNoteOptions
Options to control behavior and appearance of the text note.

Return Value

TextNote
The newly created text note.
Exceptions
Exception | Condition
ArgumentException | The document is a family that cannot contain text notes. -or- The viewId does not represent a valid graphic view element in the given document. -or- The options structure does not contain a valid text type to use for a new text note in the given document. -or- A valid point must not be father then 10 miles (approx. 16 km) from the origin.
ArgumentNullException | A non-optional argument was null
Remarks

The new text note will consist of a single line of text unless there are line-break characters (CR) in the given string. Once the text note is created its width gets adjusted to fit the longest (or the single one) line of text.

As a view-specific element the text note will be visible only in the specified view.

The new text note will be created using the given text type, which defines the style. The currently default style can be obtained from the Document.GetDefaultElementTypeId method.

See Also

Reference

TextNote Class
Create Overload


TextNote.Create(Document, ElementId, XYZ, Double, String, ElementId) Method

TextNoteCreate(Document, ElementId, XYZ, Double, String, ElementId) Method

Creates a new line-wrapping text note element of the given width and properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static TextNote Create(
    Document document,
    ElementId viewId,
    XYZ position,
    double width,
    string text,
    ElementId typeId
)
Public Shared Function Create (
    document As Document,
    viewId As ElementId,
    position As XYZ,
    width As Double,
    text As String,
    typeId As ElementId
) As TextNote
public:
static TextNote^ Create(
    Document^ document,
    ElementId^ viewId,
    XYZ^ position,
    double width,
    String^ text,
    ElementId^ typeId
)
static member Create :
        document : Document *
        viewId : ElementId *
        position : XYZ *
        width : float *
        text : string *
        typeId : ElementId -> TextNote

Parameters

document Document
A valid Revit document that is currently modifiable (i.e. with an open transaction).
viewId ElementId
Id of the graphic view in which the note is to be created.
position XYZ
A model position of the new note.

For a left-aligned text (default), the origin is set at the top-left corner of the note's bounding box.

width Double
Width [ft] of the text in paper space (i.e. as it is measured when printed.) If a line of text is longer than the specified Width, the text will be automatically wrapped. If a a zero Width is supplied then this method will create an unwrapped text note element.
text String
Text to populate the text note with.
typeId ElementId
Id of the text type to use for the new text note. The text type allows its font name parameter to be set to a font unavailable on the current system. However, any text note created with or set to this font type will be displayed in a default substituted font (e.g. Arial) and the UI will show a blank value in the text type font name parameter. Once the document is opened on a system which has the font set on the text type, the text note will display with that font and the UI will show that font in the text type font name parameter.

Return Value

TextNote
The newly created text note.
Exceptions
Exception | Condition
ArgumentException | The document is a family that cannot contain text notes. -or- The viewId does not represent a valid graphic view element in the given document. -or- The typeId does not represent a valid text type in the given document. -or- A valid point must not be father then 10 miles (approx. 16 km) from the origin. -or- The given width is not valid. A valid value must be within the range returned by the static methods GetMinimumAllowedWidth and GetMaximumAllowedWidth.
ArgumentNullException | A non-optional argument was null
Remarks

As a view-specific element the text note will be visible only in the specified view.

The new text note will be created using the given text type, which defines the style. The currently default style can be obtained from the Document.GetDefaultElementTypeId method.

See Also

Reference

TextNote Class
Create Overload


TextNote.Create(Document, ElementId, XYZ, Double, String, TextNoteOptions) Method

TextNoteCreate(Document, ElementId, XYZ, Double, String, TextNoteOptions) Method

Creates a new line-wrapping text note element of the given width and properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static TextNote Create(
    Document document,
    ElementId viewId,
    XYZ position,
    double width,
    string text,
    TextNoteOptions options
)
Public Shared Function Create (
    document As Document,
    viewId As ElementId,
    position As XYZ,
    width As Double,
    text As String,
    options As TextNoteOptions
) As TextNote
public:
static TextNote^ Create(
    Document^ document,
    ElementId^ viewId,
    XYZ^ position,
    double width,
    String^ text,
    TextNoteOptions^ options
)
static member Create :
        document : Document *
        viewId : ElementId *
        position : XYZ *
        width : float *
        text : string *
        options : TextNoteOptions -> TextNote

Parameters

document Document
A valid Revit document that is currently modifiable (i.e. with an open transaction).
viewId ElementId
Id of the graphic view in which the note is to be created.
position XYZ
A model position of the new note.

Note that the position's relation to the text's bounding box depends on the requested text alignment (set via the Options argument). It will be the box' top-left corner for a left-aligned text, the top-right corner for a right-aligned text, and middle-top point if the text is to be centered.

width Double
Width [ft] of the text in paper space (i.e. as it is measured when printed.) If a line of text is longer than the given specified Width, the text will be automatically wrapped. If a a zero Width is supplied then this method will create an unwrapped text note element.
text String
Text to populate the text note with.
options TextNoteOptions
Options to control behavior and appearance of the text note.

Return Value

TextNote
The newly created text note.
Exceptions
Exception | Condition
ArgumentException | The document is a family that cannot contain text notes. -or- The viewId does not represent a valid graphic view element in the given document. -or- The options structure does not contain a valid text type to use for a new text note in the given document. -or- A valid point must not be father then 10 miles (approx. 16 km) from the origin. -or- The given width is not valid. A valid value must be within the range returned by static methods GetMinimumWidthLimit and GetMaximumWidthLimit.
ArgumentNullException | A non-optional argument was null
Remarks

As a view-specific element the text note will be visible only in the specified view.

The new text note will be created using the give text type, which defines the style. The currently default style can be obtained from the Document.GetDefaultElementTypeId method.

Example
C#
VB
C++
F#
Copy
#region Autodesk.Revit.DB.TextElement.GetMinimumAllowedWidth(Autodesk.Revit.DB.Document, Autodesk.Revit.DB.ElementId)
public TextNote AddNewTextNote(UIDocument uiDoc)
{
    Document doc = uiDoc.Document;
    XYZ textLoc = uiDoc.Selection.PickPoint("Pick a point for sample text.");
    ElementId defaultTextTypeId = doc.GetDefaultElementTypeId(ElementTypeGroup.TextNoteType);
    double noteWidth = .2;

    // make sure note width works for the text type
    double minWidth = TextNote.GetMinimumAllowedWidth(doc, defaultTextTypeId);
    double maxWidth = TextNote.GetMaximumAllowedWidth(doc, defaultTextTypeId);
    if (noteWidth < minWidth)
    {
        noteWidth = minWidth;
    }
    else if (noteWidth > maxWidth)
    {
        noteWidth = maxWidth;
    }

    TextNoteOptions opts = new TextNoteOptions(defaultTextTypeId);
    opts.HorizontalAlignment = HorizontalTextAlignment.Left;
    opts.Rotation = Math.PI / 4;

    TextNote textNote = TextNote.Create(doc, doc.ActiveView.Id, textLoc, noteWidth, "New sample text", opts);

    return textNote;
}
#endregion
#Region "Autodesk.Revit.DB.TextElement.GetMinimumAllowedWidth(Autodesk.Revit.DB.Document, Autodesk.Revit.DB.ElementId)"
        Public Function AddNewTextNote(uiDoc As UIDocument) As TextNote
            Dim doc As Document = uiDoc.Document
            Dim textLoc As XYZ = uiDoc.Selection.PickPoint("Pick a point for sample text.")
            Dim defaultTextTypeId As ElementId = doc.GetDefaultElementTypeId(ElementTypeGroup.TextNoteType)
            Dim noteWidth As Double = 0.2

            ' make sure note width works for the text type
            Dim minWidth As Double = TextNote.GetMinimumAllowedWidth(doc, defaultTextTypeId)
            Dim maxWidth As Double = TextNote.GetMaximumAllowedWidth(doc, defaultTextTypeId)
            If noteWidth < minWidth Then
                noteWidth = minWidth
            ElseIf noteWidth > maxWidth Then
                noteWidth = maxWidth
            End If

            Dim opts As New TextNoteOptions(defaultTextTypeId)
            opts.HorizontalAlignment = HorizontalTextAlignment.Left
            opts.Rotation = Math.PI / 4

            Dim textNote__1 As TextNote = TextNote.Create(doc, doc.ActiveView.Id, textLoc, noteWidth, "New sample text", opts)

            Return textNote__1
        End Function
#End Region

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

TextNote Class
Create Overload


TextNote.GetFormattedText Method

TextNoteGetFormattedText Method

Returns an object that contains text and associated formatting of this note.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormattedText GetFormattedText()
Public Function GetFormattedText As FormattedText
public:
FormattedText^ GetFormattedText()
member GetFormattedText : unit -> FormattedText

Return Value

FormattedText
The object that contains the text and associated formatting of of the text in this text note.
Remarks
The returned object is not attached to the text note and modifying it will not modify the contents of the text note. After changes are made to the FormattedText, use SetFormattedText(FormattedText) apply those changes to the TextNote.
Example
C#
VB
C++
F#
Copy
#region Autodesk.Revit.DB.FormattedText.SetListType(Autodesk.Revit.DB.TextRange, Autodesk.Revit.DB.ListType)
#region Autodesk.Revit.DB.FormattedText.AsTextRange()
public void AppendText(TextNote textNote)
{
    FormattedText formatText = textNote.GetFormattedText();

    TextRange range = formatText.AsTextRange();

    range.Start = range.End - 1;
    // set Length to 0 to insert
    range.Length = 0;
    string someNewText = "\rThis is a new paragraph\vThis is a new line without a paragraph break\r";
    formatText.SetPlainText(range, someNewText);

    // get range for entire text
    range = formatText.AsTextRange();
    range.Start = range.End - 1;
    range.Length = 0;
    string someListText = "\rBulleted List item 1\rItem 2\vSecond line for Item 2\rThird bullet point";
    formatText.SetPlainText(range, someListText);
    range.Start++;
    range.Length = someListText.Length;
    formatText.SetListType(range, ListType.Bullet);

    if (formatText.GetAllCapsStatus(range) != FormatStatus.None)
    {
        formatText.SetAllCapsStatus(range, false);
    }

    textNote.SetFormattedText(formatText);
}
#endregion
#endregion
#Region "Autodesk.Revit.DB.FormattedText.SetListType(Autodesk.Revit.DB.TextRange, Autodesk.Revit.DB.ListType)"
#Region "Autodesk.Revit.DB.FormattedText.AsTextRange()"
        Public Sub AppendText(textNote As TextNote)
            Dim formatText As FormattedText = textNote.GetFormattedText()

            Dim range As TextRange = formatText.AsTextRange()

            range.Start = range.[End] - 1
            ' set Length to 0 to insert
            range.Length = 0
            Dim someNewText As String = vbCr & "This is a new paragraph" & vbVerticalTab & "This is a new line without a paragraph break" & vbCr
            formatText.SetPlainText(range, someNewText)

            ' get range for entire text
            range = formatText.AsTextRange()
            range.Start = range.[End] - 1
            range.Length = 0
            Dim someListText As String = vbCr & "Bulleted List item 1" & vbCr & "Item 2" & vbVerticalTab & "Second line for Item 2" & vbCr & "Third bullet point"
            formatText.SetPlainText(range, someListText)
            range.Start += 1
            range.Length = someListText.Length
            formatText.SetListType(range, ListType.Bullet)

            If formatText.GetAllCapsStatus(range) <> FormatStatus.None Then
                formatText.SetAllCapsStatus(range, False)
            End If

            textNote.SetFormattedText(formatText)
        End Sub
#End Region
#End Region

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

TextNote Class


TextNote.GetLeaders Method

TextNoteGetLeaders Method

Returns a collection of leaders currently attached to the text note.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<Leader> GetLeaders()
Public Function GetLeaders As IList(Of Leader)
public:
IList<Leader^>^ GetLeaders()
member GetLeaders : unit -> IList<Leader>

Return Value

IList Leader
Remarks
This method supersedes an older Leaders property which has been deprecated.
See Also

Reference

TextNote Class


TextNote.RemoveLeaders Method

TextNoteRemoveLeaders Method

Removes all leaders currently attached to the text note.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveLeaders()
Public Sub RemoveLeaders
public:
void RemoveLeaders()
member RemoveLeaders : unit -> unit
See Also

Reference

TextNote Class


TextNote.SetFormattedText Method

TextNoteSetFormattedText Method

Sets the text and associated formatting of the text of in this text note with a given FormattedText object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetFormattedText(
    FormattedText formattedText
)
Public Sub SetFormattedText (
    formattedText As FormattedText
)
public:
void SetFormattedText(
    FormattedText^ formattedText
)
member SetFormattedText :
        formattedText : FormattedText -> unit

Parameters

formattedText FormattedText
The FormattedText object containing the text and associated formatting of the text.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Example
C#
VB
C++
F#
Copy
#region Autodesk.Revit.DB.FormattedText
public void FormatText(TextNote textNote)
{
    // TextNote created with "New sample text"
    FormattedText formatText = textNote.GetFormattedText();

    // italicize "New"
    TextRange range = new TextRange(0, 3);
    formatText.SetItalicStatus(range, true);

    // make "sample" bold
    range = formatText.Find("sample", 0, false, true);
    if (range.Length > 0)
        formatText.SetBoldStatus(range, true);

    // make "text" underlined
    range = formatText.Find("text", 0, false, true);
    if (range.Length > 0)
        formatText.SetUnderlineStatus(range, true);

    // make all text uppercase
    formatText.SetAllCapsStatus(true);

    textNote.SetFormattedText(formatText);
}
#endregion
#Region "Autodesk.Revit.DB.FormattedText"
        Public Sub FormatText(textNote As TextNote)
            ' TextNote created with "New sample text"
            Dim formatText__1 As FormattedText = textNote.GetFormattedText()

            ' italicize "New"
            Dim range As New TextRange(0, 3)
            formatText__1.SetItalicStatus(range, True)

            ' make "sample" bold
            range = formatText__1.Find("sample", 0, False, True)
            If range.Length > 0 Then
                formatText__1.SetBoldStatus(range, True)
            End If

            ' make "text" underlined
            range = formatText__1.Find("text", 0, False, True)
            If range.Length > 0 Then
                formatText__1.SetUnderlineStatus(range, True)
            End If

            ' make all text uppercase
            formatText__1.SetAllCapsStatus(True)

            textNote.SetFormattedText(formatText__1)
        End Sub
#End Region

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

TextNote Class


TextNoteLeaderStyles Enumeration

An enumerated type listing all the Leader styles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum TextNoteLeaderStyles
Public Enumeration TextNoteLeaderStyles
public enum class TextNoteLeaderStyles
type TextNoteLeaderStyles
Members
Member name | Value | Description
LCS_NONE | 0 | No leader.
LCS_ONE_SEG_LINE | 1 | The leader only includes one line segment.
LCS_ONE_SEG_ARC | 2 | The leader is an arc.
LCS_TWO_SEG_LINE | 3 | The leader include two line segments.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TextNoteLeaderTypes Enumeration

Types of text-note leaders

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum TextNoteLeaderTypes
Public Enumeration TextNoteLeaderTypes
public enum class TextNoteLeaderTypes
type TextNoteLeaderTypes
Members
Member name | Value | Description
TNLT_STRAIGHT_L | 0 | A line leader attached from the left side of a text element
TNLT_STRAIGHT_R | 1 | A line leader attached from the right side of a text element
TNLT_ARC_L | 2 | An arc leader attached from the left side of a text element
TNLT_ARC_R | 3 | An arc leader attached from the right side of a text element
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TextNoteOptions Class

Options to use when creating a new text note element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBTextNoteOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TextNoteOptions : IDisposable
Public Class TextNoteOptions
    Implements IDisposable
public ref class TextNoteOptions : IDisposable
type TextNoteOptions =
    class
        interface IDisposable
    end

The TextNoteOptions type exposes the following members.

Constructors
 | Name | Description
Public method | TextNoteOptions | Default constructor; populates the options with their respective default values.
Public method | TextNoteOptions(ElementId) | Constructs text options to create text of the given type.
Top
Properties
 | Name | Description
Public property | HorizontalAlignment | Horizontal alignment of the text.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | KeepRotatedTextReadable | Flag controling whether a rotate text is to stay oriented to be always readable.
Public property | Rotation | Base line angle of a text note, in radians.
Public property | TypeId | Id of a text type that defines the style of a text note.
Public property | VerticalAlignment | Vertical alignment of the text.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the TextNoteOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Use an instance of this class as an argument in the TextNote.Create methods.
Example
C#
VB
C++
F#
Copy
#region Autodesk.Revit.DB.TextNote.Create(Autodesk.Revit.DB.Document, Autodesk.Revit.DB.ElementId, Autodesk.Revit.DB.XYZ, double, System.String, Autodesk.Revit.DB.TextNoteOptions)
#region Autodesk.Revit.DB.TextElement.GetMinimumAllowedWidth(Autodesk.Revit.DB.Document, Autodesk.Revit.DB.ElementId)
public TextNote AddNewTextNote(UIDocument uiDoc)
{
    Document doc = uiDoc.Document;
    XYZ textLoc = uiDoc.Selection.PickPoint("Pick a point for sample text.");
    ElementId defaultTextTypeId = doc.GetDefaultElementTypeId(ElementTypeGroup.TextNoteType);
    double noteWidth = .2;

    // make sure note width works for the text type
    double minWidth = TextNote.GetMinimumAllowedWidth(doc, defaultTextTypeId);
    double maxWidth = TextNote.GetMaximumAllowedWidth(doc, defaultTextTypeId);
    if (noteWidth < minWidth)
    {
        noteWidth = minWidth;
    }
    else if (noteWidth > maxWidth)
    {
        noteWidth = maxWidth;
    }

    TextNoteOptions opts = new TextNoteOptions(defaultTextTypeId);
    opts.HorizontalAlignment = HorizontalTextAlignment.Left;
    opts.Rotation = Math.PI / 4;

    TextNote textNote = TextNote.Create(doc, doc.ActiveView.Id, textLoc, noteWidth, "New sample text", opts);

    return textNote;
}
#endregion
#endregion
#Region "Autodesk.Revit.DB.TextNote.Create(Autodesk.Revit.DB.Document, Autodesk.Revit.DB.ElementId, Autodesk.Revit.DB.XYZ, double, System.String, Autodesk.Revit.DB.TextNoteOptions)"
#Region "Autodesk.Revit.DB.TextElement.GetMinimumAllowedWidth(Autodesk.Revit.DB.Document, Autodesk.Revit.DB.ElementId)"
        Public Function AddNewTextNote(uiDoc As UIDocument) As TextNote
            Dim doc As Document = uiDoc.Document
            Dim textLoc As XYZ = uiDoc.Selection.PickPoint("Pick a point for sample text.")
            Dim defaultTextTypeId As ElementId = doc.GetDefaultElementTypeId(ElementTypeGroup.TextNoteType)
            Dim noteWidth As Double = 0.2

            ' make sure note width works for the text type
            Dim minWidth As Double = TextNote.GetMinimumAllowedWidth(doc, defaultTextTypeId)
            Dim maxWidth As Double = TextNote.GetMaximumAllowedWidth(doc, defaultTextTypeId)
            If noteWidth < minWidth Then
                noteWidth = minWidth
            ElseIf noteWidth > maxWidth Then
                noteWidth = maxWidth
            End If

            Dim opts As New TextNoteOptions(defaultTextTypeId)
            opts.HorizontalAlignment = HorizontalTextAlignment.Left
            opts.Rotation = Math.PI / 4

            Dim textNote__1 As TextNote = TextNote.Create(doc, doc.ActiveView.Id, textLoc, noteWidth, "New sample text", opts)

            Return textNote__1
        End Function
#End Region
#End Region

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TextNoteOptions Constructor

Overload List
 | Name | Description
Public method | TextNoteOptions | Default constructor; populates the options with their respective default values.
Public method | TextNoteOptions(ElementId) | Constructs text options to create text of the given type.
Top
See Also

Reference

TextNoteOptions Class


TextNoteOptions Constructor

Default constructor; populates the options with their respective default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TextNoteOptions()
Public Sub New
public:
TextNoteOptions()
new : unit -> TextNoteOptions
Remarks
The constructed options need to be given a typeId before it can be used to create a text note.
See Also

Reference

TextNoteOptions Class
TextNoteOptions Overload


TextNoteOptions(ElementId) Constructor

Constructs text options to create text of the given type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TextNoteOptions(
    ElementId typeId
)
Public Sub New (
    typeId As ElementId
)
public:
TextNoteOptions(
    ElementId^ typeId
)
new :
        typeId : ElementId -> TextNoteOptions

Parameters

typeId ElementId
Id of a text type that defines the style of a text note.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Except for the TypeId, all other properties of the option class will be populated with their respective default values.
See Also

Reference

TextNoteOptions Class
TextNoteOptions Overload


TextNoteOptions Properties

The TextNoteOptions type exposes the following members.

Properties
 | Name | Description
Public property | HorizontalAlignment | Horizontal alignment of the text.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | KeepRotatedTextReadable | Flag controling whether a rotate text is to stay oriented to be always readable.
Public property | Rotation | Base line angle of a text note, in radians.
Public property | TypeId | Id of a text type that defines the style of a text note.
Public property | VerticalAlignment | Vertical alignment of the text.
Top
See Also

Reference

TextNoteOptions Class


TextNoteOptions.HorizontalAlignment Property

TextNoteOptionsHorizontalAlignment Property

Horizontal alignment of the text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public HorizontalTextAlignment HorizontalAlignment { get; set; }
Public Property HorizontalAlignment As HorizontalTextAlignment
    Get
    Set
public:
property HorizontalTextAlignment HorizontalAlignment {
    HorizontalTextAlignment get ();
    void set (HorizontalTextAlignment value);
}
member HorizontalAlignment : HorizontalTextAlignment with get, set

Property Value

HorizontalTextAlignment
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
Default is Left alignment.
See Also

Reference

TextNoteOptions Class


TextNoteOptions.IsValidObject Property

TextNoteOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

TextNoteOptions Class


TextNoteOptions.KeepRotatedTextReadable Property

TextNoteOptionsKeepRotatedTextReadable Property

Flag controling whether a rotate text is to stay oriented to be always readable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool KeepRotatedTextReadable { get; set; }
Public Property KeepRotatedTextReadable As Boolean
    Get
    Set
public:
property bool KeepRotatedTextReadable {
    bool get ();
    void set (bool value);
}
member KeepRotatedTextReadable : bool with get, set

Property Value

Boolean
Remarks
Default value is True.
See Also

Reference

TextNoteOptions Class


TextNoteOptions.Rotation Property

TextNoteOptionsRotation Property

Base line angle of a text note, in radians.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Rotation { get; set; }
Public Property Rotation As Double
    Get
    Set
public:
property double Rotation {
    double get ();
    void set (double value);
}
member Rotation : float with get, set

Property Value

Double
Remarks
Default value is 0.0.
See Also

Reference

TextNoteOptions Class


TextNoteOptions.TypeId Property

TextNoteOptionsTypeId Property

Id of a text type that defines the style of a text note.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId TypeId { get; set; }
Public Property TypeId As ElementId
    Get
    Set
public:
property ElementId^ TypeId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member TypeId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
No default value. A valid type element Id must be set prior using the options. The text type allows its font name parameter to be set to a font unavailable on the current system. However, any text note created with or set to this font type will be displayed in a default substituted font (e.g. Arial) and the UI will show a blank value in the text type font name parameter. Once the document is opened on a system which has the font set on the text type, the text note will display with that font and the UI will show that font in the text type font name parameter.
See Also

Reference

TextNoteOptions Class


TextNoteOptions.VerticalAlignment Property

TextNoteOptionsVerticalAlignment Property

Vertical alignment of the text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VerticalTextAlignment VerticalAlignment { get; set; }
Public Property VerticalAlignment As VerticalTextAlignment
    Get
    Set
public:
property VerticalTextAlignment VerticalAlignment {
    VerticalTextAlignment get ();
    void set (VerticalTextAlignment value);
}
member VerticalAlignment : VerticalTextAlignment with get, set

Property Value

VerticalTextAlignment
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
Default is Top alignment.
See Also

Reference

TextNoteOptions Class


TextNoteOptions Methods

The TextNoteOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

TextNoteOptions Class


TextNoteOptions.Dispose Method

TextNoteOptionsDispose Method

Releases all resources used by the TextNoteOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

TextNoteOptions Class


TextNoteType Class

An object that represents a text note style.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBLineAndTextAttrSymbol
Autodesk.Revit.DBTextElementType
Autodesk.Revit.DBTextNoteType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TextNoteType : TextElementType
Public Class TextNoteType
    Inherits TextElementType
public ref class TextNoteType : public TextElementType
type TextNoteType =
    class
        inherit TextElementType
    end

The TextNoteType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TextNoteType Properties

The TextNoteType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

TextNoteType Class


TextNoteType Methods

The TextNoteType type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

TextNoteType Class


TextRange Class

An object that is used to identify a range of characters in a FormattedText.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBTextRange

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TextRange : IDisposable
Public Class TextRange
    Implements IDisposable
public ref class TextRange : IDisposable
type TextRange =
    class
        interface IDisposable
    end

The TextRange type exposes the following members.

Constructors
 | Name | Description
Public method | TextRange | Constructs a TextRange with default values for start and length.
Public method | TextRange(TextRange) | Constructs a copy of the input TextRange object.
Public method | TextRange(Int32, Int32) | Constructs a TextRange with input start and length.
Top
Properties
 | Name | Description
Public property | End | The index of the first character after the end of the range
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Length | The length of the range.
Public property | Start | The start index of a range within the FormattedText.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the TextRange
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
A TextRange consists of a start, which is a zero-based index into the text, and a length, which is the number of characters in the range. The length can be zero.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TextRange Constructor

Overload List
 | Name | Description
Public method | TextRange | Constructs a TextRange with default values for start and length.
Public method | TextRange(TextRange) | Constructs a copy of the input TextRange object.
Public method | TextRange(Int32, Int32) | Constructs a TextRange with input start and length.
Top
See Also

Reference

TextRange Class


TextRange Constructor

Constructs a TextRange with default values for start and length.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TextRange()
Public Sub New
public:
TextRange()
new : unit -> TextRange
Remarks
The start and length are set to be 0 by default.
See Also

Reference

TextRange Class
TextRange Overload


TextRange(TextRange) Constructor

Constructs a copy of the input TextRange object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TextRange(
    TextRange other
)
Public Sub New (
    other As TextRange
)
public:
TextRange(
    TextRange^ other
)
new :
        other : TextRange -> TextRange

Parameters

other TextRange
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

TextRange Class
TextRange Overload


TextRange(Int32, Int32) Constructor

Constructs a TextRange with input start and length.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TextRange(
    int start,
    int length
)
Public Sub New (
    start As Integer,
    length As Integer
)
public:
TextRange(
    int start,
    int length
)
new :
        start : int *
        length : int -> TextRange

Parameters

start Int32
length Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The given value for start is negative. -or- The given value for length is negative.
Remarks
The input value for start as well as length should not be negative.
See Also

Reference

TextRange Class
TextRange Overload


TextRange Properties

The TextRange type exposes the following members.

Properties
 | Name | Description
Public property | End | The index of the first character after the end of the range
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Length | The length of the range.
Public property | Start | The start index of a range within the FormattedText.
Top
See Also

Reference

TextRange Class


TextRange.End Property

TextRangeEnd Property

The index of the first character after the end of the range

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int End { get; }
Public ReadOnly Property End As Integer
    Get
public:
property int End {
    int get ();
}
member End : int with get

Property Value

Int32
See Also

Reference

TextRange Class


TextRange.IsValidObject Property

TextRangeIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

TextRange Class


TextRange.Length Property

TextRangeLength Property

The length of the range.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Length { get; set; }
Public Property Length As Integer
    Get
    Set
public:
property int Length {
    int get ();
    void set (int value);
}
member Length : int with get, set

Property Value

Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The given value for length is negative.
See Also

Reference

TextRange Class


TextRange.Start Property

TextRangeStart Property

The start index of a range within the FormattedText.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Start { get; set; }
Public Property Start As Integer
    Get
    Set
public:
property int Start {
    int get ();
    void set (int value);
}
member Start : int with get, set

Property Value

Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The given value for start is negative.
See Also

Reference

TextRange Class


TextRange Methods

The TextRange type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

TextRange Class


TextRange.Dispose Method

TextRangeDispose Method

Releases all resources used by the TextRange

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

TextRange Class


TextTreatment Enumeration

An enumerated type listing possible text treatment modes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum TextTreatment
Public Enumeration TextTreatment
public enum class TextTreatment
type TextTreatment
Members
Member name | Value | Description
Exact | 0 | Export texts as exact visual fidelity. Formatting intelligence will be lost.
Approximate | 1 | Export texts as approximate visual fidelity. Formatting intelligence will be maintained.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ThermalAsset Class

Represents the properties of a material pertinent to energy analysis.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBThermalAsset

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ThermalAsset : IDisposable
Public Class ThermalAsset
    Implements IDisposable
public ref class ThermalAsset : IDisposable
type ThermalAsset =
    class
        interface IDisposable
    end

The ThermalAsset type exposes the following members.

Constructors
 | Name | Description
Public method | ThermalAsset | Constructs an instance of ThermalAsset.
Top
Properties
 | Name | Description
Public property | Behavior | Flag indicating whether elements of this material behave isotropically or orthotropically.
Public property | Compressibility | The compressibility of the asset.
Public property | Density | The density of the asset.
Public property | ElectricalResistivity | The electrical resistivity of the asset.
Public property | Emissivity | The emissivity of the asset.
Public property | GasViscosity | The gas viscosity of the asset.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LiquidViscosity | The liquid viscosity of the asset.
Public property | Name | The name of the thermal asset.
Public property | Permeability | The permeability of the asset.
Public property | Porosity | The porosity of the asset.
Public property | Reflectivity | The reflectivity of the asset.
Public property | SpecificHeat | The specific heat of the asset.
Public property | SpecificHeatOfVaporization | The specific heat of vaporization of the asset.
Public property | ThermalConductivity | The thermal conductivity of the asset.
Public property | ThermalMaterialType | The type of material that this thermal asset describes (e.g. solid, liquid, gas.)
Public property | TransmitsLight | A boolean flag that indicates whether or not the asset transmits light.
Public property | VaporPressure | The vapor pressure of the asset.
Top
Methods
 | Name | Description
Public method | Copy | Produces a copy of the asset.
Public method | Dispose | Releases all resources used by the ThermalAsset
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Equals(ThermalAsset) | Determines whether this thermal asset is equal to another.
Public method | EqualsThermalOnly | Determines whether this thermal asset is equal to another, but ignore data from base class.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ThermalAsset Constructor

Constructs an instance of ThermalAsset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ThermalAsset(
    string name,
    ThermalMaterialType materialType
)
Public Sub New (
    name As String,
    materialType As ThermalMaterialType
)
public:
ThermalAsset(
    String^ name,
    ThermalMaterialType materialType
)
new :
        name : string *
        materialType : ThermalMaterialType -> ThermalAsset

Parameters

name String
The name of the asset.
materialType ThermalMaterialType
The type of thermal material that this asset will describe.
Exceptions
Exception | Condition
ArgumentException | name is an empty string. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~".
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ThermalAsset Class


ThermalAsset Properties

The ThermalAsset type exposes the following members.

Properties
 | Name | Description
Public property | Behavior | Flag indicating whether elements of this material behave isotropically or orthotropically.
Public property | Compressibility | The compressibility of the asset.
Public property | Density | The density of the asset.
Public property | ElectricalResistivity | The electrical resistivity of the asset.
Public property | Emissivity | The emissivity of the asset.
Public property | GasViscosity | The gas viscosity of the asset.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LiquidViscosity | The liquid viscosity of the asset.
Public property | Name | The name of the thermal asset.
Public property | Permeability | The permeability of the asset.
Public property | Porosity | The porosity of the asset.
Public property | Reflectivity | The reflectivity of the asset.
Public property | SpecificHeat | The specific heat of the asset.
Public property | SpecificHeatOfVaporization | The specific heat of vaporization of the asset.
Public property | ThermalConductivity | The thermal conductivity of the asset.
Public property | ThermalMaterialType | The type of material that this thermal asset describes (e.g. solid, liquid, gas.)
Public property | TransmitsLight | A boolean flag that indicates whether or not the asset transmits light.
Public property | VaporPressure | The vapor pressure of the asset.
Top
See Also

Reference

ThermalAsset Class


ThermalAsset.Behavior Property

ThermalAssetBehavior Property

Flag indicating whether elements of this material behave isotropically or orthotropically.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public StructuralBehavior Behavior { get; set; }
Public Property Behavior As StructuralBehavior
    Get
    Set
public:
property StructuralBehavior Behavior {
    StructuralBehavior get ();
    void set (StructuralBehavior value);
}
member Behavior : StructuralBehavior with get, set

Property Value

StructuralBehavior
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ThermalAsset Class


ThermalAsset.Compressibility Property

ThermalAssetCompressibility Property

The compressibility of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Compressibility { get; set; }
Public Property Compressibility As Double
    Get
    Set
public:
property double Compressibility {
    double get ();
    void set (double value);
}
member Compressibility : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The given value for compressibility is out of range
Remarks
Values must be in the range 0 to 1.
See Also

Reference

ThermalAsset Class


ThermalAsset.Density Property

ThermalAssetDensity Property

The density of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Density { get; set; }
Public Property Density As Double
    Get
    Set
public:
property double Density {
    double get ();
    void set (double value);
}
member Density : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The given value for density must be non-negative.
Remarks
Values are in kilograms per cubed feet (kg/ftÂ³) and must be non-negative.
See Also

Reference

ThermalAsset Class


ThermalAsset.ElectricalResistivity Property

ThermalAssetElectricalResistivity Property

The electrical resistivity of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double ElectricalResistivity { get; set; }
Public Property ElectricalResistivity As Double
    Get
    Set
public:
property double ElectricalResistivity {
    double get ();
    void set (double value);
}
member ElectricalResistivity : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The given value for electricalResistivity must be non-negative.
Remarks
Values are in ohm-meters and must be non-negative.
See Also

Reference

ThermalAsset Class


ThermalAsset.Emissivity Property

ThermalAssetEmissivity Property

The emissivity of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Emissivity { get; set; }
Public Property Emissivity As Double
    Get
    Set
public:
property double Emissivity {
    double get ();
    void set (double value);
}
member Emissivity : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The given value for emissivity is out of range
Remarks
Values must be in the range 0 to 1.
See Also

Reference

ThermalAsset Class


ThermalAsset.GasViscosity Property

ThermalAssetGasViscosity Property

The gas viscosity of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GasViscosity { get; set; }
Public Property GasViscosity As Double
    Get
    Set
public:
property double GasViscosity {
    double get ();
    void set (double value);
}
member GasViscosity : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The given value for gasViscosity must be non-negative.
InapplicableDataException | When setting this property: the asset must be gas to set this property.
Remarks
Values are in kilograms per feet-second (kg/(ft Â· s)) and must be non-negative.
See Also

Reference

ThermalAsset Class


ThermalAsset.IsValidObject Property

ThermalAssetIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ThermalAsset Class


ThermalAsset.LiquidViscosity Property

ThermalAssetLiquidViscosity Property

The liquid viscosity of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double LiquidViscosity { get; set; }
Public Property LiquidViscosity As Double
    Get
    Set
public:
property double LiquidViscosity {
    double get ();
    void set (double value);
}
member LiquidViscosity : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The given value for liquidViscosity must be non-negative.
InapplicableDataException | When setting this property: the asset must be liquid to set this property.
Remarks
Values are in kilograms per feet-second (kg/(ft Â· s)) and must be non-negative.
See Also

Reference

ThermalAsset Class


ThermalAsset.Name Property

ThermalAssetName Property

The name of the thermal asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ThermalAsset Class


ThermalAsset.Permeability Property

ThermalAssetPermeability Property

The permeability of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Permeability { get; set; }
Public Property Permeability As Double
    Get
    Set
public:
property double Permeability {
    double get ();
    void set (double value);
}
member Permeability : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The given value for permeability must be non-negative.
Remarks
Values are in seconds per foot (s/ft) and must be non-negative.
See Also

Reference

ThermalAsset Class


ThermalAsset.Porosity Property

ThermalAssetPorosity Property

The porosity of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Porosity { get; set; }
Public Property Porosity As Double
    Get
    Set
public:
property double Porosity {
    double get ();
    void set (double value);
}
member Porosity : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The given value for porosity is out of range
Remarks
Values must be in the range 0 to 1.
See Also

Reference

ThermalAsset Class


ThermalAsset.Reflectivity Property

ThermalAssetReflectivity Property

The reflectivity of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Reflectivity { get; set; }
Public Property Reflectivity As Double
    Get
    Set
public:
property double Reflectivity {
    double get ();
    void set (double value);
}
member Reflectivity : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The given value for reflectivity is out of range
Remarks
Values must be in the range 0 to 1.
See Also

Reference

ThermalAsset Class


ThermalAsset.SpecificHeat Property

ThermalAssetSpecificHeat Property

The specific heat of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double SpecificHeat { get; set; }
Public Property SpecificHeat As Double
    Get
    Set
public:
property double SpecificHeat {
    double get ();
    void set (double value);
}
member SpecificHeat : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The given value for specificHeat must be non-negative.
Remarks
Values are in squared-feet per Kelvin, squared-second (ftÂ²/(K Â· sÂ²)) and must be non-negative.
See Also

Reference

ThermalAsset Class


ThermalAsset.SpecificHeatOfVaporization Property

ThermalAssetSpecificHeatOfVaporization Property

The specific heat of vaporization of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double SpecificHeatOfVaporization { get; set; }
Public Property SpecificHeatOfVaporization As Double
    Get
    Set
public:
property double SpecificHeatOfVaporization {
    double get ();
    void set (double value);
}
member SpecificHeatOfVaporization : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The given value for specificHeatOfVaporization must be non-negative.
Remarks
Values are in feet per squared-second (ft/sÂ²) and must be non-negative.
See Also

Reference

ThermalAsset Class


ThermalAsset.ThermalConductivity Property

ThermalAssetThermalConductivity Property

The thermal conductivity of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double ThermalConductivity { get; set; }
Public Property ThermalConductivity As Double
    Get
    Set
public:
property double ThermalConductivity {
    double get ();
    void set (double value);
}
member ThermalConductivity : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The given value for thermalConductivity must be non-negative.
Remarks
Values are in feet-kilograms per Kelvin-cubed-second ((ft Â· kg)/(K Â· sÂ³)) and must be non-negative.
See Also

Reference

ThermalAsset Class


ThermalAsset.ThermalMaterialType Property

ThermalAssetThermalMaterialType Property

The type of material that this thermal asset describes (e.g. solid, liquid, gas.)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ThermalMaterialType ThermalMaterialType { get; }
Public ReadOnly Property ThermalMaterialType As ThermalMaterialType
    Get
public:
property ThermalMaterialType ThermalMaterialType {
    ThermalMaterialType get ();
}
member ThermalMaterialType : ThermalMaterialType with get

Property Value

ThermalMaterialType
See Also

Reference

ThermalAsset Class


ThermalAsset.TransmitsLight Property

ThermalAssetTransmitsLight Property

A boolean flag that indicates whether or not the asset transmits light.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool TransmitsLight { get; set; }
Public Property TransmitsLight As Boolean
    Get
    Set
public:
property bool TransmitsLight {
    bool get ();
    void set (bool value);
}
member TransmitsLight : bool with get, set

Property Value

Boolean
See Also

Reference

ThermalAsset Class


ThermalAsset.VaporPressure Property

ThermalAssetVaporPressure Property

The vapor pressure of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double VaporPressure { get; set; }
Public Property VaporPressure As Double
    Get
    Set
public:
property double VaporPressure {
    double get ();
    void set (double value);
}
member VaporPressure : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The given value for vaporPressure must be non-negative.
Remarks
Values are in kilograms per feet, squared-second (kg/(ft Â· sÂ²)) and must be non-negative.
See Also

Reference

ThermalAsset Class


ThermalAsset Methods

The ThermalAsset type exposes the following members.

Methods
 | Name | Description
Public method | Copy | Produces a copy of the asset.
Public method | Dispose |
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Equals(ThermalAsset) | Determines whether this thermal asset is equal to another.
Public method | EqualsThermalOnly | Determines whether this thermal asset is equal to another, but ignore data from base class.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ThermalAsset Class


ThermalAsset.Copy Method

ThermalAssetCopy Method

Produces a copy of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ThermalAsset Copy()
Public Function Copy As ThermalAsset
public:
ThermalAsset^ Copy()
member Copy : unit -> ThermalAsset

Return Value

ThermalAsset
A copy of the asset.
See Also

Reference

ThermalAsset Class


ThermalAsset.Dispose Method

ThermalAssetDispose Method

Releases all resources used by the ThermalAsset

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ThermalAsset Class


ThermalAsset.Equals Method

ThermalAssetEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object is equal to the current object.
Public method | Equals(ThermalAsset) | Determines whether this thermal asset is equal to another.
Top
See Also

Reference

ThermalAsset Class


ThermalAsset.Equals(ThermalAsset) Method

ThermalAssetEquals(ThermalAsset) Method

Determines whether this thermal asset is equal to another.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Equals(
    ThermalAsset other
)
Public Function Equals (
    other As ThermalAsset
) As Boolean
public:
bool Equals(
    ThermalAsset^ other
)
member Equals :
        other : ThermalAsset -> bool

Parameters

other ThermalAsset
The thermal asset to compare with this one.

Return Value

Boolean
True if the given thermal asset is equal to this one, otherwise false.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ThermalAsset Class
Equals Overload


ThermalAsset.EqualsThermalOnly Method

ThermalAssetEqualsThermalOnly Method

Determines whether this thermal asset is equal to another, but ignore data from base class.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool EqualsThermalOnly(
    ThermalAsset other
)
Public Function EqualsThermalOnly (
    other As ThermalAsset
) As Boolean
public:
bool EqualsThermalOnly(
    ThermalAsset^ other
)
member EqualsThermalOnly :
        other : ThermalAsset -> bool

Parameters

other ThermalAsset
The thermal asset to compare with this one.

Return Value

Boolean
True if the given thermal asset is equal to this one, otherwise false.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ThermalAsset Class


ThermalMaterialType Enumeration

Represents the thermal material type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ThermalMaterialType
Public Enumeration ThermalMaterialType
public enum class ThermalMaterialType
type ThermalMaterialType
Members
Member name | Value | Description
Undefined | 0 | Thermal material type is undefined.
Gas | 1 | Thermal material type is gas.
Liquid | 2 | Thermal material type is liquid.
Solid | 3 | Thermal material type is solid.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ThermalProperties Class

Class specific to thermal properties for assembly types, such as Wall, Floor, Ceiling, Roof and Building Pad.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBThermalProperties

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ThermalProperties : APIObject
Public Class ThermalProperties
    Inherits APIObject
public ref class ThermalProperties : public APIObject
type ThermalProperties =
    class
        inherit APIObject
    end

The ThermalProperties type exposes the following members.

Properties
 | Name | Description
Public property | Absorptance | Value of absorptance.
Public property | HeatTransferCoefficient | The heat transfer coefficient value (U-Value). The unit is watts per meter-squared kelvin (W/(m^2*K)).
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Roughness | Value of roughness.
Public property | ThermalMass | The calculated thermal mass value. The unit is kilogram feet-squared per second squared kelvin (kg ft^2/(s^2 K)).
Public property | ThermalResistance | The calculated thermal resistance value (R-Value). The unit is meter-squared kelvin per watt ((m^2*K)/Watt).
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ThermalProperties Properties

The ThermalProperties type exposes the following members.

Properties
 | Name | Description
Public property | Absorptance | Value of absorptance.
Public property | HeatTransferCoefficient | The heat transfer coefficient value (U-Value). The unit is watts per meter-squared kelvin (W/(m^2*K)).
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Roughness | Value of roughness.
Public property | ThermalMass | The calculated thermal mass value. The unit is kilogram feet-squared per second squared kelvin (kg ft^2/(s^2 K)).
Public property | ThermalResistance | The calculated thermal resistance value (R-Value). The unit is meter-squared kelvin per watt ((m^2*K)/Watt).
Top
See Also

Reference

ThermalProperties Class


ThermalProperties.Absorptance Property

ThermalPropertiesAbsorptance Property

Value of absorptance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Absorptance { get; set; }
Public Property Absorptance As Double
    Get
    Set
public:
property double Absorptance {
    double get ();
    void set (double value);
}
member Absorptance : float with get, set

Property Value

Double
See Also

Reference

ThermalProperties Class


ThermalProperties.HeatTransferCoefficient Property

ThermalPropertiesHeatTransferCoefficient Property

The heat transfer coefficient value (U-Value). The unit is watts per meter-squared kelvin (W/(m^2*K)).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double HeatTransferCoefficient { get; }
Public ReadOnly Property HeatTransferCoefficient As Double
    Get
public:
property double HeatTransferCoefficient {
    double get ();
}
member HeatTransferCoefficient : float with get

Property Value

Double
See Also

Reference

ThermalProperties Class


ThermalProperties.IsValidObject Property

ThermalPropertiesIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ThermalProperties Class


ThermalProperties.Roughness Property

ThermalPropertiesRoughness Property

Value of roughness.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Roughness { get; set; }
Public Property Roughness As Integer
    Get
    Set
public:
property int Roughness {
    int get ();
    void set (int value);
}
member Roughness : int with get, set

Property Value

Int32
See Also

Reference

ThermalProperties Class


ThermalProperties.ThermalMass Property

ThermalPropertiesThermalMass Property

The calculated thermal mass value. The unit is kilogram feet-squared per second squared kelvin (kg ft^2/(s^2 K)).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double ThermalMass { get; }
Public ReadOnly Property ThermalMass As Double
    Get
public:
property double ThermalMass {
    double get ();
}
member ThermalMass : float with get

Property Value

Double
See Also

Reference

ThermalProperties Class


ThermalProperties.ThermalResistance Property

ThermalPropertiesThermalResistance Property

The calculated thermal resistance value (R-Value). The unit is meter-squared kelvin per watt ((m^2*K)/Watt).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double ThermalResistance { get; }
Public ReadOnly Property ThermalResistance As Double
    Get
public:
property double ThermalResistance {
    double get ();
}
member ThermalResistance : float with get

Property Value

Double
See Also

Reference

ThermalProperties Class


ThermalProperties Methods

The ThermalProperties type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ThermalProperties Class


TilePattern Class

An object representing a tile pattern that may be applied to a DividedSurface.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBTilePattern

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TilePattern : ElementType
Public Class TilePattern
    Inherits ElementType
public ref class TilePattern : public ElementType
type TilePattern =
    class
        inherit ElementType
    end

The TilePattern type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | TilePatternType | The built-in system tile pattern specified by this object.
Public property | TilesPerSeedNode | Get the number of tiles located at each seed node.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
TilePatterns cannot be created. A fixed selection is built into each Conceptual Mass family. TilePatterns can be retrieved by key from the Revit::DB::Document::Settings::TilePatternTable object.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TilePattern Properties

The TilePattern type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | TilePatternType | The built-in system tile pattern specified by this object.
Public property | TilesPerSeedNode | Get the number of tiles located at each seed node.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

TilePattern Class


TilePattern.TilePatternType Property

TilePatternTilePatternType Property

The built-in system tile pattern specified by this object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TilePatternsBuiltIn TilePatternType { get; }
Public ReadOnly Property TilePatternType As TilePatternsBuiltIn
    Get
public:
property TilePatternsBuiltIn TilePatternType {
    TilePatternsBuiltIn get ();
}
member TilePatternType : TilePatternsBuiltIn with get

Property Value

TilePatternsBuiltIn
See Also

Reference

TilePattern Class


TilePattern.TilesPerSeedNode Property

TilePatternTilesPerSeedNode Property

Get the number of tiles located at each seed node.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int TilesPerSeedNode { get; }
Public ReadOnly Property TilesPerSeedNode As Integer
    Get
public:
property int TilesPerSeedNode {
    int get ();
}
member TilesPerSeedNode : int with get

Property Value

Int32
Remarks
Currently the number of tiles per seed node is always either 1 or 2.
See Also

Reference

TilePattern Class


TilePattern Methods

The TilePattern type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

TilePattern Class


TilePatterns Class

The TilePatterns object is an interface for retrieving the TilePattern objects within the Document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBTilePatterns

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TilePatterns : APIObject
Public Class TilePatterns
    Inherits APIObject
public ref class TilePatterns : public APIObject
type TilePatterns =
    class
        inherit APIObject
    end

The TilePatterns type exposes the following members.

Properties
Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetTilePattern | Retrieve a TilePattern object from a built-in type.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TilePatterns Properties

The TilePatterns type exposes the following members.

Properties
Name | Description
IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

TilePatterns Class


TilePatterns Methods

The TilePatterns type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetTilePattern | Retrieve a TilePattern object from a built-in type.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

TilePatterns Class


TilePatterns.GetTilePattern Method

TilePatternsGetTilePattern Method

Retrieve a TilePattern object from a built-in type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TilePattern GetTilePattern(
    TilePatternsBuiltIn tilePatternBuiltIn
)
Public Function GetTilePattern (
    tilePatternBuiltIn As TilePatternsBuiltIn
) As TilePattern
public:
TilePattern^ GetTilePattern(
    TilePatternsBuiltIn tilePatternBuiltIn
)
member GetTilePattern :
        tilePatternBuiltIn : TilePatternsBuiltIn -> TilePattern

Parameters

tilePatternBuiltIn TilePatternsBuiltIn

Return Value

TilePattern
A TilePattern object, or if the document is not a Massing Family.
See Also

Reference

TilePatterns Class


TilePatternsBuiltIn Enumeration

Revit's built-in tile patterns. See TilePattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum TilePatternsBuiltIn
Public Enumeration TilePatternsBuiltIn
public enum class TilePatternsBuiltIn
type TilePatternsBuiltIn
Members
Member name | Value | Description
Rectangle | 1 |
Triangle_Bent | 2 |
Rhomboid | 3 |
Hexagon | 4 |
HalfStep | 5 |
ThirdStep | 6 |
TriangleCheckerboard_Bent | 7 |
RectangleCheckerboard | 8 |
RhomboidCheckerboard | 9 |
TriangleStep_Bent | 10 |
Arrows | 11 |
ZigZag | 12 |
Octagon | 13 |
OctagonRotate | 14 |
Triangle_Flat | 15 |
TriangleCheckerboard_Flat | 16 |
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Toposolid Class

An object that represents a Toposolid within the Autodesk Revit project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBHostObject
Autodesk.Revit.DBCeilingAndFloor
Autodesk.Revit.DBToposolid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Toposolid : CeilingAndFloor
Public Class Toposolid
    Inherits CeilingAndFloor
public ref class Toposolid : public CeilingAndFloor
type Toposolid =
    class
        inherit CeilingAndFloor
    end

The Toposolid type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HostTopoId | The host toposolid id of the current toposolid subdivision. If the object is not a toposolid subdivision, hostTopoId will be InvalidElementId.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SketchId | Returns id of the sketch.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeExcavatedBy | Checks if the given element can be used to excavate the toposolid.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create(Document, IListCurveLoop, ElementId, ElementId) | Creates a new instance of toposolid within the project.
 | Create(Document, IListXYZ, ElementId, ElementId) | Creates a new instance of toposolid within the project.
 | Create(Document, IListCurveLoop, IListXYZ, ElementId, ElementId) | Creates a new instance of toposolid within the project.
 | CreateFromTopographySurface | Creates a toposolid element from a host TopographySurface, and toposolid sub-divisions from its subregions.
Public method | CreateSubDivision | Create a toposolid subdivision element with the current toposolid as its host.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | ExcavateBy | Excavates the toposolid by a given element.
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIntersectingElementData | Gets intersection data of all intersecting elements.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSlabShapeEditor | Gets a SlabShapeEditor that can be used to add or modify points of this Toposolid.
Public method | GetSubDivisionIds | Get all element ids of toposolid subdivisions with the current toposolid as its host.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
 | IsSmoothedSurfaceEnabled | Get smoothed surface setting of Toposolid.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveExcavationBy | Remove the excavation between the given element and the toposolid.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
 | SetSmoothedSurface | Set smoothed surface setting of Toposolid.
Public method | Simplify | Simplifies the toposolid by reducing the number of inner vertices to the given percentage.
Public method | Split | Split the toposolid by the given curve loops.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Toposolid Properties

The Toposolid type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HostTopoId | The host toposolid id of the current toposolid subdivision. If the object is not a toposolid subdivision, hostTopoId will be InvalidElementId.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SketchId | Returns id of the sketch.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

Toposolid Class


Toposolid.HostTopoId Property

ToposolidHostTopoId Property

The host toposolid id of the current toposolid subdivision. If the object is not a toposolid subdivision, hostTopoId will be InvalidElementId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId HostTopoId { get; }
Public ReadOnly Property HostTopoId As ElementId
    Get
public:
property ElementId^ HostTopoId {
    ElementId^ get ();
}
member HostTopoId : ElementId with get

Property Value

ElementId
See Also

Reference

Toposolid Class


Toposolid.SketchId Property

ToposolidSketchId Property

Returns id of the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId SketchId { get; }
Public ReadOnly Property SketchId As ElementId
    Get
public:
property ElementId^ SketchId {
    ElementId^ get ();
}
member SketchId : ElementId with get

Property Value

ElementId
See Also

Reference

Toposolid Class


Toposolid Methods

The Toposolid type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeExcavatedBy | Checks if the given element can be used to excavate the toposolid.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create(Document, IListCurveLoop, ElementId, ElementId) | Creates a new instance of toposolid within the project.
 | Create(Document, IListXYZ, ElementId, ElementId) | Creates a new instance of toposolid within the project.
 | Create(Document, IListCurveLoop, IListXYZ, ElementId, ElementId) | Creates a new instance of toposolid within the project.
 | CreateFromTopographySurface | Creates a toposolid element from a host TopographySurface, and toposolid sub-divisions from its subregions.
Public method | CreateSubDivision | Create a toposolid subdivision element with the current toposolid as its host.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | ExcavateBy | Excavates the toposolid by a given element.
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIntersectingElementData | Gets intersection data of all intersecting elements.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSlabShapeEditor | Gets a SlabShapeEditor that can be used to add or modify points of this Toposolid.
Public method | GetSubDivisionIds | Get all element ids of toposolid subdivisions with the current toposolid as its host.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
 | IsSmoothedSurfaceEnabled | Get smoothed surface setting of Toposolid.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveExcavationBy | Remove the excavation between the given element and the toposolid.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
 | SetSmoothedSurface | Set smoothed surface setting of Toposolid.
Public method | Simplify | Simplifies the toposolid by reducing the number of inner vertices to the given percentage.
Public method | Split | Split the toposolid by the given curve loops.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Toposolid Class


Toposolid.CanBeExcavatedBy Method

ToposolidCanBeExcavatedBy Method

Checks if the given element can be used to excavate the toposolid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanBeExcavatedBy(
    ElementId elementId
)
Public Function CanBeExcavatedBy (
    elementId As ElementId
) As Boolean
public:
bool CanBeExcavatedBy(
    ElementId^ elementId
)
member CanBeExcavatedBy :
        elementId : ElementId -> bool

Parameters

elementId ElementId
Id of the element

Return Value

Boolean
True if the element can be used to excavate the toposolid.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

Toposolid Class


Toposolid.Create Method

ToposolidCreate Method

Overload List
Name | Description
Create(Document, IListCurveLoop, ElementId, ElementId) | Creates a new instance of toposolid within the project.
Create(Document, IListXYZ, ElementId, ElementId) | Creates a new instance of toposolid within the project.
Create(Document, IListCurveLoop, IListXYZ, ElementId, ElementId) | Creates a new instance of toposolid within the project.
Top
See Also

Reference

Toposolid Class


Toposolid.Create(Document, IList<CurveLoop>, ElementId, ElementId) Method

ToposolidCreate(Document, IListCurveLoop, ElementId, ElementId) Method

Creates a new instance of toposolid within the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Toposolid Create(
    Document document,
    IList<CurveLoop> profiles,
    ElementId topoTypeId,
    ElementId levelId
)
Public Shared Function Create (
    document As Document,
    profiles As IList(Of CurveLoop),
    topoTypeId As ElementId,
    levelId As ElementId
) As Toposolid
public:
static Toposolid^ Create(
    Document^ document,
    IList<CurveLoop^>^ profiles,
    ElementId^ topoTypeId,
    ElementId^ levelId
)
static member Create :
        document : Document *
        profiles : IList<CurveLoop> *
        topoTypeId : ElementId *
        levelId : ElementId -> Toposolid

Parameters

document Document
The document in which the new toposolid is created.
profiles IList CurveLoop
An array of planar curve loops that represent the profiles of the toposolid.
topoTypeId ElementId
Id of the toposolid type to be used by the new toposolid.
levelId ElementId
Id of the level on which the toposolid is to be placed.

Return Value

Toposolid
A new toposolid object within the project if successful.
Exceptions
Exception | Condition
ArgumentException | The input curve loops cannot compose a valid boundary, that means: the "curveLoops" collection is empty; or some curve loops intersect with each other; or each curve loop is not closed individually; or each curve loop is not planar; or each curve loop is not in a plane parallel to the horizontal(XY) plane; or input curves contain at least one helical curve. -or- The ElementId levelId is not a Level. -or- Toposolid type is not valid for this toposolid. -or- Input curves build invalid sketch. -or- Failed to create curve elements.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Cannot generate a sketch. -or- Failed to create new element.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
See Also

Reference

Toposolid Class
Create Overload


Toposolid.Create(Document, IList<XYZ>, ElementId, ElementId) Method

ToposolidCreate(Document, IListXYZ, ElementId, ElementId) Method

Creates a new instance of toposolid within the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Toposolid Create(
    Document document,
    IList<XYZ> points,
    ElementId topoTypeId,
    ElementId levelId
)
Public Shared Function Create (
    document As Document,
    points As IList(Of XYZ),
    topoTypeId As ElementId,
    levelId As ElementId
) As Toposolid
public:
static Toposolid^ Create(
    Document^ document,
    IList<XYZ^>^ points,
    ElementId^ topoTypeId,
    ElementId^ levelId
)
static member Create :
        document : Document *
        points : IList<XYZ> *
        topoTypeId : ElementId *
        levelId : ElementId -> Toposolid

Parameters

document Document
The document in which the new toposolid is created.
points IList XYZ
An array of points that used to construct the top face of the toposolid.
topoTypeId ElementId
Id of the toposolid type to be used by the new toposolid.
levelId ElementId
Id of the level on which the toposolid is to be placed.

Return Value

Toposolid
A new toposolid object within the project if successful.
Exceptions
Exception | Condition
ArgumentException | The input point array size is less than 3. -or- The ElementId levelId is not a Level. -or- Toposolid type is not valid for this toposolid. -or- Input curves build invalid sketch. -or- Failed to create curve elements.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Cannot generate a sketch. -or- Failed to create new element.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
See Also

Reference

Toposolid Class
Create Overload


Toposolid.Create(Document, IList<CurveLoop>, IList<XYZ>, ElementId, ElementId) Method

ToposolidCreate(Document, IListCurveLoop, IListXYZ, ElementId, ElementId) Method

Creates a new instance of toposolid within the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Toposolid Create(
    Document document,
    IList<CurveLoop> profiles,
    IList<XYZ> points,
    ElementId topoTypeId,
    ElementId levelId
)
Public Shared Function Create (
    document As Document,
    profiles As IList(Of CurveLoop),
    points As IList(Of XYZ),
    topoTypeId As ElementId,
    levelId As ElementId
) As Toposolid
public:
static Toposolid^ Create(
    Document^ document,
    IList<CurveLoop^>^ profiles,
    IList<XYZ^>^ points,
    ElementId^ topoTypeId,
    ElementId^ levelId
)
static member Create :
        document : Document *
        profiles : IList<CurveLoop> *
        points : IList<XYZ> *
        topoTypeId : ElementId *
        levelId : ElementId -> Toposolid

Parameters

document Document
The document in which the new toposolid is created.
profiles IList CurveLoop
An array of planar curve loops that represent the profiles of the toposolid.
points IList XYZ
An array of points that used to construct the top face of the toposolid.
topoTypeId ElementId
Id of the toposolid type to be used by the new toposolid.
levelId ElementId
Id of the level on which the toposolid is to be placed.

Return Value

Toposolid
A new toposolid object within the project if successful.
Exceptions
Exception | Condition
ArgumentException | The input curve loops cannot compose a valid boundary, that means: the "curveLoops" collection is empty; or some curve loops intersect with each other; or each curve loop is not closed individually; or each curve loop is not planar; or each curve loop is not in a plane parallel to the horizontal(XY) plane; or input curves contain at least one helical curve. -or- The ElementId levelId is not a Level. -or- Toposolid type is not valid for this toposolid. -or- Input curves build invalid sketch. -or- Failed to create curve elements.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Cannot generate a sketch. -or- Failed to create new element.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
See Also

Reference

Toposolid Class
Create Overload


Toposolid.CreateFromTopographySurface Method

ToposolidCreateFromTopographySurface Method

Creates a toposolid element from a host TopographySurface, and toposolid sub-divisions from its subregions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Toposolid CreateFromTopographySurface(
    Document document,
    ElementId hostSurfaceId,
    ElementId topoTypeId,
    ElementId levelId
)
Public Shared Function CreateFromTopographySurface (
    document As Document,
    hostSurfaceId As ElementId,
    topoTypeId As ElementId,
    levelId As ElementId
) As Toposolid
public:
static Toposolid^ CreateFromTopographySurface(
    Document^ document,
    ElementId^ hostSurfaceId,
    ElementId^ topoTypeId,
    ElementId^ levelId
)
static member CreateFromTopographySurface :
        document : Document *
        hostSurfaceId : ElementId *
        topoTypeId : ElementId *
        levelId : ElementId -> Toposolid

Parameters

document Document
The document in which the new toposolid is created.
hostSurfaceId ElementId
Id of the host TopogarphySurface element.
topoTypeId ElementId
Id of the toposolid type to be used by the new toposolid.
levelId ElementId
Id of the level on which the toposolid is to be placed.

Return Value

Toposolid
A new toposolid object within the project if successful.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

Toposolid Class


Toposolid.CreateSubDivision Method

ToposolidCreateSubDivision Method

Create a toposolid subdivision element with the current toposolid as its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Toposolid CreateSubDivision(
    Document document,
    IList<CurveLoop> profiles
)
Public Function CreateSubDivision (
    document As Document,
    profiles As IList(Of CurveLoop)
) As Toposolid
public:
Toposolid^ CreateSubDivision(
    Document^ document,
    IList<CurveLoop^>^ profiles
)
member CreateSubDivision :
        document : Document *
        profiles : IList<CurveLoop> -> Toposolid

Parameters

document Document
The document in which the new toposolid is created.
profiles IList CurveLoop
An array of planar curve loops that represent the profiles of the toposolid.

Return Value

Toposolid
The toposolid subdivision object.
Exceptions
Exception | Condition
ArgumentException | The input curve loops cannot compose a valid boundary, that means: the "curveLoops" collection is empty; or some curve loops intersect with each other; or each curve loop is not closed individually; or each curve loop is not planar; or each curve loop is not in a plane parallel to the horizontal(XY) plane; or input curves contain at least one helical curve.
ArgumentNullException | A non-optional argument was null
See Also

Reference

Toposolid Class


Toposolid.ExcavateBy Method

ToposolidExcavateBy Method

Excavates the toposolid by a given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ExcavateBy(
    ElementId elementId
)
Public Sub ExcavateBy (
    elementId As ElementId
)
public:
void ExcavateBy(
    ElementId^ elementId
)
member ExcavateBy :
        elementId : ElementId -> unit

Parameters

elementId ElementId
Id of the element used to excavate the toposolid.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The element is not supported for toposolid excavation operations.
See Also

Reference

Toposolid Class


Toposolid.GetIntersectingElementData Method

ToposolidGetIntersectingElementData Method

Gets intersection data of all intersecting elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<IntersectingElementData> GetIntersectingElementData()
Public Function GetIntersectingElementData As IList(Of IntersectingElementData)
public:
IList<IntersectingElementData^>^ GetIntersectingElementData()
member GetIntersectingElementData : unit -> IList<IntersectingElementData>

Return Value

IList IntersectingElementData
The array of all intersecting element data.
See Also

Reference

Toposolid Class


Toposolid.GetSlabShapeEditor Method

ToposolidGetSlabShapeEditor Method

Gets a SlabShapeEditor that can be used to add or modify points of this Toposolid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SlabShapeEditor GetSlabShapeEditor()
Public Function GetSlabShapeEditor As SlabShapeEditor
public:
SlabShapeEditor^ GetSlabShapeEditor()
member GetSlabShapeEditor : unit -> SlabShapeEditor

Return Value

SlabShapeEditor
The SlabShapeEditor object
See Also

Reference

Toposolid Class


Toposolid.GetSubDivisionIds Method

ToposolidGetSubDivisionIds Method

Get all element ids of toposolid subdivisions with the current toposolid as its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ElementId> GetSubDivisionIds()
Public Function GetSubDivisionIds As IList(Of ElementId)
public:
IList<ElementId^>^ GetSubDivisionIds()
member GetSubDivisionIds : unit -> IList<ElementId>

Return Value

IList ElementId
The array of toposolid subdivision ids.
See Also

Reference

Toposolid Class


Toposolid.IsSmoothedSurfaceEnabled Method

ToposolidIsSmoothedSurfaceEnabled Method

Get smoothed surface setting of Toposolid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsSmoothedSurfaceEnabled(
    Document document
)
Public Shared Function IsSmoothedSurfaceEnabled (
    document As Document
) As Boolean
public:
static bool IsSmoothedSurfaceEnabled(
    Document^ document
)
static member IsSmoothedSurfaceEnabled :
        document : Document -> bool

Parameters

document Document
The document.

Return Value

Boolean
True if smoothed surface is enabled for Toposolid, otherwise return false.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

Toposolid Class


Toposolid.RemoveExcavationBy Method

ToposolidRemoveExcavationBy Method

Remove the excavation between the given element and the toposolid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveExcavationBy(
    ElementId elementId
)
Public Sub RemoveExcavationBy (
    elementId As ElementId
)
public:
void RemoveExcavationBy(
    ElementId^ elementId
)
member RemoveExcavationBy :
        elementId : ElementId -> unit

Parameters

elementId ElementId
Id of the element that already excavates the toposolid.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The element is not supported for toposolid excavation operations.
See Also

Reference

Toposolid Class


Toposolid.SetSmoothedSurface Method

ToposolidSetSmoothedSurface Method

Set smoothed surface setting of Toposolid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void SetSmoothedSurface(
    Document document,
    bool enable
)
Public Shared Sub SetSmoothedSurface (
    document As Document,
    enable As Boolean
)
public:
static void SetSmoothedSurface(
    Document^ document,
    bool enable
)
static member SetSmoothedSurface :
        document : Document *
        enable : bool -> unit

Parameters

document Document
The document.
enable Boolean
True means enable smoothed surface setting, otherwise disable.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

Toposolid Class


Toposolid.Simplify Method

ToposolidSimplify Method

Simplifies the toposolid by reducing the number of inner vertices to the given percentage.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Simplify(
    double percentage
)
Public Sub Simplify (
    percentage As Double
)
public:
void Simplify(
    double percentage
)
member Simplify :
        percentage : float -> unit

Parameters

percentage Double
The ratio of the number of inner vertices after simplify to the original number.
Exceptions
Exception | Condition
ArgumentException | The input percentage should be greater than 0 and less than 1.
InvalidOperationException | this operation failed.
Remarks
At low percentages, the inner vertices may not be reduced to the exact percentage to keep a rough semblance of the original shape. Call this method again if you want to keep removing inner vertices.
See Also

Reference

Toposolid Class


Toposolid.Split Method

ToposolidSplit Method

Split the toposolid by the given curve loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ElementId> Split(
    IList<CurveLoop> splitCurveLoops
)
Public Function Split (
    splitCurveLoops As IList(Of CurveLoop)
) As IList(Of ElementId)
public:
IList<ElementId^>^ Split(
    IList<CurveLoop^>^ splitCurveLoops
)
member Split :
        splitCurveLoops : IList<CurveLoop> -> IList<ElementId>

Parameters

splitCurveLoops IList CurveLoop
An array of planar curve loops that are used to split the toposolid. All of the curve loops should lie on the sketch plane of the toposolid.

Return Value

IList ElementId
An array of newly created toposolid ids after split.
Exceptions
Exception | Condition
ArgumentException | The split curve loops should all lie on the sketch plane of the toposolid.
ArgumentNullException | A non-optional argument was null
See Also

Reference

Toposolid Class


ToposolidType Class

An object that specifies the type of a Toposolid in Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBHostObjAttributes
Autodesk.Revit.DBToposolidType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ToposolidType : HostObjAttributes
Public Class ToposolidType
    Inherits HostObjAttributes
public ref class ToposolidType : public HostObjAttributes
type ToposolidType =
    class
        inherit HostObjAttributes
    end

The ToposolidType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes)
Public method | GetContourSetting | Get the contour setting object from the current toposolid type.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes)
Public method | SetContourSettting | Set the contour setting for the current toposolid type by copying from an existing contour setting object.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ToposolidType Properties

The ToposolidType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

ToposolidType Class


ToposolidType Methods

The ToposolidType type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes)
Public method | GetContourSetting | Get the contour setting object from the current toposolid type.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes)
Public method | SetContourSettting | Set the contour setting for the current toposolid type by copying from an existing contour setting object.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ToposolidType Class


ToposolidType.GetContourSetting Method

ToposolidTypeGetContourSetting Method

Get the contour setting object from the current toposolid type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ContourSetting GetContourSetting()
Public Function GetContourSetting As ContourSetting
public:
ContourSetting^ GetContourSetting()
member GetContourSetting : unit -> ContourSetting

Return Value

ContourSetting
The contour setting object.
See Also

Reference

ToposolidType Class


ToposolidType.SetContourSettting Method

ToposolidTypeSetContourSettting Method

Set the contour setting for the current toposolid type by copying from an existing contour setting object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetContourSettting(
    ContourSetting setting
)
Public Sub SetContourSettting (
    setting As ContourSetting
)
public:
void SetContourSettting(
    ContourSetting^ setting
)
member SetContourSettting :
        setting : ContourSetting -> unit

Parameters

setting ContourSetting
An existing contour setting object.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ToposolidType Class


Transaction Class

Transactions are context-like objects that guard any changes made to a Revit model
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBTransaction

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Transaction : IDisposable
Public Class Transaction
    Implements IDisposable
public ref class Transaction : IDisposable
type Transaction =
    class
        interface IDisposable
    end

The Transaction type exposes the following members.

Constructors
 | Name | Description
Public method | Transaction(Document) | Instantiates a transaction object.
Public method | Transaction(Document, String) | Instantiates a transaction object
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
 | Commit | Commits all changes made to the model during the transaction.
 | Commit(FailureHandlingOptions) | Commits all changes made to the model during the transaction.
Public method | Dispose | Releases all resources used by the Transaction
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetFailureHandlingOptions | Returns the current failure handling options.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetName | Returns the transaction's name.
Public method | GetStatus | Returns the current status of the transaction.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HasEnded | Determines whether the transaction has ended already.
Public method | HasStarted | Determines whether the transaction has been started yet.
 | RollBack | Rolls back all changes made to the model during the transaction.
 | RollBack(FailureHandlingOptions) | Rolls back all changes made to the model during the transaction.
 | SetFailureHandlingOptions | Sets options for handling failures to be used when the transaction is being committed or rolled back.
 | SetName | Sets the transaction's name.
 | Start | Starts the transaction.
 | Start(String) | Starts the transaction with an assigned name.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

Any change to a document can only be made while there is an active transaction open for that document. Changes do not become part of the document until the active transaction is committed. Consequently, all changes made in a transaction can be rolled back either explicitly or implicitly by the transaction's destructor.

A document can have only one transaction open at any given time.

Transactions cannot be started when the document is in read-only mode, either permanently or temporarily. See the Document class methods IsReadOnly and IsModifiable for more details.

Transactions in linked documents are not permitted, for linked documents are not allowed to be modified.

If a transaction was started and not finished yet by the time the Transaction object is about to be disposed, the default destructor will roll it back automatically, thus all changes made to the document while this transaction was open will be discarded. It is not recommended to rely on this default behavior though. Instead, it is advised to always call either Commit or RollBack explicitly before the transaction object gets disposed. Please note that unless invoked explicitly the actual destruction of an object in managed code might not happen until the object is collected by the garbage collector.

Example
C#
VB
C++
F#
Copy
public void CreatingSketch(UIApplication uiApplication)
{
    Autodesk.Revit.DB.Document document = uiApplication.ActiveUIDocument.Document;
    Autodesk.Revit.ApplicationServices.Application application = uiApplication.Application;

    // Create a few geometry lines. These lines are transaction (not in the model),
    // therefore they do not need to be created inside a document transaction.
    XYZ Point1 = XYZ.Zero;
    XYZ Point2 = new XYZ(10, 0, 0);
    XYZ Point3 = new XYZ(10, 10, 0);
    XYZ Point4 = new XYZ(0, 10, 0);

    Line geomLine1 = Line.CreateBound(Point1, Point2);
    Line geomLine2 = Line.CreateBound(Point4, Point3);
    Line geomLine3 = Line.CreateBound(Point1, Point4);

    // This geometry plane is also transaction and does not need a transaction
    XYZ origin = XYZ.Zero;
    XYZ normal = new XYZ(0, 0, 1);
    Plane geomPlane = Plane.CreateByNormalAndOrigin(normal, origin);

    // In order to a sketch plane with model curves in it, we need
    // to start a transaction because such operations modify the model.

    // All and any transaction should be enclosed in a 'using'
    // block or guarded within a try-catch-finally blocks
    // to guarantee that a transaction does not out-live its scope.
    using (Transaction transaction = new Transaction(document))
    {
       if (transaction.Start("Create model curves") == TransactionStatus.Started)
       {
           // Create a sketch plane in current document
           SketchPlane sketch = SketchPlane.Create(document,geomPlane);

           // Create a ModelLine elements using the geometry lines and sketch plane
           ModelLine line1 = document.Create.NewModelCurve(geomLine1, sketch) as ModelLine;
           ModelLine line2 = document.Create.NewModelCurve(geomLine2, sketch) as ModelLine;
           ModelLine line3 = document.Create.NewModelCurve(geomLine3, sketch) as ModelLine;

           // Ask the end user whether the changes are to be committed or not
           TaskDialog taskDialog = new TaskDialog("Revit");
           taskDialog.MainContent = "Click either [OK] to Commit, or [Cancel] to Roll back the transaction.";
           TaskDialogCommonButtons buttons = TaskDialogCommonButtons.Ok | TaskDialogCommonButtons.Cancel;
           taskDialog.CommonButtons = buttons;

           if (TaskDialogResult.Ok == taskDialog.Show())
           {
               // For many various reasons, a transaction may not be committed
               // if the changes made during the transaction do not result a valid model.
               // If committing a transaction fails or is canceled by the end user,
               // the resulting status would be RolledBack instead of Committed.
               if (TransactionStatus.Committed != transaction.Commit())
               {
                  TaskDialog.Show("Failure", "Transaction could not be committed");
               }
           }
           else
           {
               transaction.RollBack();
           }
       }
    }
}
Public Sub CreatingSketch(uiApplication As UIApplication)
    Dim document As Autodesk.Revit.DB.Document = uiApplication.ActiveUIDocument.Document
    Dim application As Autodesk.Revit.ApplicationServices.Application = uiApplication.Application

    ' Create a few geometry lines. These lines are transaction (not in the model),
    ' therefore they do not need to be created inside a document transaction.
    Dim Point1 As XYZ = XYZ.Zero
    Dim Point2 As New XYZ(10, 0, 0)
    Dim Point3 As New XYZ(10, 10, 0)
    Dim Point4 As New XYZ(0, 10, 0)

    Dim geomLine1 As Line = Line.CreateBound(Point1, Point2)
    Dim geomLine2 As Line = Line.CreateBound(Point4, Point3)
    Dim geomLine3 As Line = Line.CreateBound(Point1, Point4)

    ' This geometry plane is also transaction and does not need a transaction
    Dim origin As XYZ = XYZ.Zero
    Dim normal As New XYZ(0, 0, 1)
 Dim geomPlane As Plane = Plane.CreateByNormalAndOrigin(normal, origin)

    ' In order to a sketch plane with model curves in it, we need
    ' to start a transaction because such operations modify the model.

    ' All and any transaction should be enclosed in a 'using'
    ' block or guarded within a try-catch-finally blocks
    ' to guarantee that a transaction does not out-live its scope.
    Using transaction As New Transaction(document)
        If transaction.Start("Create model curves") = TransactionStatus.Started Then
            ' Create a sketch plane in current document
            Dim sketch As SketchPlane = SketchPlane.Create(document, geomPlane)

            ' Create a ModelLine elements using the geometry lines and sketch plane
            Dim line1 As ModelLine = TryCast(document.Create.NewModelCurve(geomLine1, sketch), ModelLine)
            Dim line2 As ModelLine = TryCast(document.Create.NewModelCurve(geomLine2, sketch), ModelLine)
            Dim line3 As ModelLine = TryCast(document.Create.NewModelCurve(geomLine3, sketch), ModelLine)

            ' Ask the end user whether the changes are to be committed or not
            Dim taskDialog__1 As New TaskDialog("Revit")
            taskDialog__1.MainContent = "Click either [OK] to Commit, or [Cancel] to Roll back the transaction."
            Dim buttons As TaskDialogCommonButtons = TaskDialogCommonButtons.Ok Or TaskDialogCommonButtons.Cancel
            taskDialog__1.CommonButtons = buttons

            If TaskDialogResult.Ok = taskDialog__1.Show() Then
                ' For many various reasons, a transaction may not be committed
                ' if the changes made during the transaction do not result a valid model.
                ' If committing a transaction fails or is canceled by the end user,
                ' the resulting status would be RolledBack instead of Committed.
                If TransactionStatus.Committed <> transaction.Commit() Then
                    TaskDialog.Show("Failure", "Transaction could not be committed")
                End If
            Else
                transaction.RollBack()
            End If
        End If
    End Using
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Transaction Constructor

Overload List
 | Name | Description
Public method | Transaction(Document) | Instantiates a transaction object.
Public method | Transaction(Document, String) | Instantiates a transaction object
Top
See Also

Reference

Transaction Class


Transaction(Document) Constructor

Instantiates a transaction object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Transaction(
    Document document
)
Public Sub New (
    document As Document
)
public:
Transaction(
    Document^ document
)
new :
        document : Document -> Transaction

Parameters

document Document
The document for which this transaction is going to be used.
Exceptions
Exception | Condition
ArgumentException | Document is a linked file. Transactions can only be used in primary documents (projects or families.)
ArgumentNullException | A non-optional argument was null
Remarks

The transaction does not start by creating a transaction object. One of the 'Start' methods will need to be called in order to start this transaction.

A transaction cannot start unless is has a valid (non-empty) name. Because this constructor does not take a name, a name must be assigned later before or during the 'Start' method.

See Also

Reference

Transaction Class
Transaction Overload


Transaction(Document, String) Constructor

Instantiates a transaction object

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Transaction(
    Document document,
    string name
)
Public Sub New (
    document As Document,
    name As String
)
public:
Transaction(
    Document^ document,
    String^ name
)
new :
        document : Document *
        name : string -> Transaction

Parameters

document Document
The document for which this transaction is going to be used.
name String
The name of the transaction. This name will appear in the undo menu once the transaction is successfully committed. The name must not be empty. The name can be reset later by either calling SetName(String) or by using the name argument in the Start(String) method.
Exceptions
Exception | Condition
ArgumentException | The name argument is an empty string. -or- Document is a linked file. Transactions can only be used in primary documents (projects or families.)
ArgumentNullException | A non-optional argument was null
Remarks
The transaction does not start by creating a transaction object. One of the 'Start' methods will need to be called in order to start this transaction.
See Also

Reference

Transaction Class
Transaction Overload


Transaction Properties

The Transaction type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

Transaction Class


Transaction.IsValidObject Property

TransactionIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

Transaction Class


Transaction Methods

The Transaction type exposes the following members.

Methods
 | Name | Description
 | Commit | Commits all changes made to the model during the transaction.
 | Commit(FailureHandlingOptions) | Commits all changes made to the model during the transaction.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetFailureHandlingOptions | Returns the current failure handling options.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetName | Returns the transaction's name.
Public method | GetStatus | Returns the current status of the transaction.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HasEnded | Determines whether the transaction has ended already.
Public method | HasStarted | Determines whether the transaction has been started yet.
 | RollBack | Rolls back all changes made to the model during the transaction.
 | RollBack(FailureHandlingOptions) | Rolls back all changes made to the model during the transaction.
 | SetFailureHandlingOptions | Sets options for handling failures to be used when the transaction is being committed or rolled back.
 | SetName | Sets the transaction's name.
 | Start | Starts the transaction.
 | Start(String) | Starts the transaction with an assigned name.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Transaction Class


Transaction.Commit Method

TransactionCommit Method

Overload List
Name | Description
Commit | Commits all changes made to the model during the transaction.
Commit(FailureHandlingOptions) | Commits all changes made to the model during the transaction.
Top
See Also

Reference

Transaction Class


Transaction.Commit Method

TransactionCommit Method

Commits all changes made to the model during the transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TransactionStatus Commit()
Public Function Commit As TransactionStatus
public:
TransactionStatus Commit()
member Commit : unit -> TransactionStatus

Return Value

TransactionStatus
If finished successfully, this method returns TransactionStatus.Committed.

Note it is possible the RolledBack status is returned instead as an outcome of failure handling. If TransactionStatus::Pending is returned it means that failure handling has not been finalized yet and Revit awaits a user actions. Until committing is fully finalized, no changes to the document can be made (including starting of new transactions).

The returned status does not have to be necessarily the same as the status returned by GetStatus even when the method is called immediately after committing the transaction. Such a difference may happen due to actions made by a transaction finalizer, if there was one set. (See FailureHandlingOptions for more details.)

Exceptions
Exception | Condition
InvalidOperationException | The current status of the transaction is not 'Started'. Transaction must be started before calling Commit or Rollback. -or- The transaction's document is currently in failure mode. No transaction operations are permitted until failure handling is finished.
Remarks
By committing a transaction, all changes made to the model during the transaction are accepted. A new undo item will appear in the Undo menu in Revit, which allows the user to undo the changes. The undo item will have this transaction's name. Commit may only be called for a transaction that has been started. (Use the GetStatus method to check the current state.) Be aware that committing may fail or can be delayed (as a result of failure handling.) Callers should always check the returned status to test whether a transaction was committed successfully. Only after a transaction is successfully committed (or rolled back as a result of handling transaction failures), it may be started again.
Example
C#
VB
C++
F#
Copy
public bool CreateLevel(Autodesk.Revit.DB.Document document, double elevation)
{
   // All and any transaction should be enclosed in a 'using'
   // block or guarded within a try-catch-finally blocks
   // to guarantee that a transaction does not out-live its scope.
   using (Transaction transaction = new Transaction(document, "Creating Level"))
    {
       // Must start a transaction to be able to modify a document

       if( TransactionStatus.Started == transaction.Start())
       {
          if (null != Level.Create(document, elevation))
          {
             // For many various reasons, a transaction may not be committed
             // if the changes made during the transaction do not result a valid model.
             // If committing a transaction fails or is canceled by the end user,
             // the resulting status would be RolledBack instead of Committed.
             return (TransactionStatus.Committed == transaction.Commit());
          }

          // For we were unable to create the level, we will roll the transaction back
          // (although on this simplified case we know there weren't any other changes)

          transaction.RollBack();
       }
    }
    return false;
}
Public Function CreateLevel(document As Autodesk.Revit.DB.Document, elevation As Double) As Boolean
    ' All and any transaction should be enclosed in a 'using'
    ' block or guarded within a try-catch-finally blocks
    ' to guarantee that a transaction does not out-live its scope.
    Using transaction As New Transaction(document, "Creating Level")
        ' Must start a transaction to be able to modify a document

        If TransactionStatus.Started = transaction.Start() Then
       If Level.Create(document, elevation) IsNot Nothing Then
          ' For many various reasons, a transaction may not be committed
          ' if the changes made during the transaction do not result a valid model.
          ' If committing a transaction fails or is canceled by the end user,
          ' the resulting status would be RolledBack instead of Committed.
          Return (TransactionStatus.Committed = transaction.Commit())
       End If

            ' For we were unable to create the level, we will roll the transaction back
            ' (although on this simplified case we know there weren't any other changes)

            transaction.RollBack()
        End If
    End Using
    Return False
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Transaction Class
Commit Overload


Transaction.Commit(FailureHandlingOptions) Method

TransactionCommit(FailureHandlingOptions) Method

Commits all changes made to the model during the transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TransactionStatus Commit(
    FailureHandlingOptions options
)
Public Function Commit (
    options As FailureHandlingOptions
) As TransactionStatus
public:
TransactionStatus Commit(
    FailureHandlingOptions^ options
)
member Commit :
        options : FailureHandlingOptions -> TransactionStatus

Parameters

options FailureHandlingOptions
A set of options to be used for handling eventual failures during this call.

The options are only used temporarily during the commitment process. After the transaction is finished, the options will be reset to their default values.

Return Value

TransactionStatus
If finished successfully, this method returns TransactionStatus.Committed

Note it is possible the RolledBack status is returned instead as an outcome of failure handling. If TransactionStatus.Pending is returned it means that failure handling has not been finalized yet and Revit awaits user's actions. Until committing is fully finalized, no changes to the document can be made (including starting of new transactions).

Be aware that the returned status does not have to be necessarily the same like the status returned by GetStatus even when the method is called immediately after committing the transaction. Such difference may happen due to actions made by a transaction finalizer, if there was one set. (See FailureHandlingOptions for more details.)

Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The current status of the transaction is not 'Started'. Transaction must be started before calling Commit or Rollback. -or- The transaction's document is currently in failure mode. No transaction operations are permitted until failure handling is finished.
Example
C#
VB
C++
F#
Copy
// All and any transaction should be enclosed in a 'using'
// block or guarded within a try-catch-finally blocks
// to guarantee that a transaction does not out-live its scope.
using (Transaction transaction = new Transaction(document))
{
   // Must start the transaction first to be able to modify a document
   transaction.Start("Creating Level");

   if (null != Level.Create(document, elevation))
   {
      // If we have a few transactions chained (for whatever reason)
      // we may wish to collect eventual warnings, if any, and show
      // them only when the last transaction of the chain is committed.
      FailureHandlingOptions options = transaction.GetFailureHandlingOptions();

      // Now, showing of any eventual mini-warnings will be
      // postponed until the following transaction.
      transaction.Commit(options.SetDelayedMiniWarnings(true));

      // Note, after a transaction is committed, the used failure options
      // are lost and replaced with default options again.
   }
}
' All and any transaction should be enclosed in a 'using'
' block or guarded within a try-catch-finally blocks
' to guarantee that a transaction does not out-live its scope.
Using transaction As New Transaction(document)
    ' Must start the transaction first to be able to modify a document
    transaction.Start("Creating Level")

If Level.Create(document, elevation) IsNot Nothing Then
   ' If we have a few transactions chained (for whatever reason)
   ' we may wish to collect eventual warnings, if any, and show
   ' them only when the last transaction of the chain is committed.
   Dim options As FailureHandlingOptions = transaction.GetFailureHandlingOptions()

   ' Now, showing of any eventual mini-warnings will be
   ' postponed until the following transaction.

   ' Note, after a transaction is committed, the used failure options
   ' are lost and replaced with default options again.
   transaction.Commit(options.SetDelayedMiniWarnings(True))
End If
End Using

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Transaction Class
Commit Overload


Transaction.Dispose Method

TransactionDispose Method

Releases all resources used by the Transaction

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

Transaction Class


Transaction.GetFailureHandlingOptions Method

TransactionGetFailureHandlingOptions Method

Returns the current failure handling options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FailureHandlingOptions GetFailureHandlingOptions()
Public Function GetFailureHandlingOptions As FailureHandlingOptions
public:
FailureHandlingOptions^ GetFailureHandlingOptions()
member GetFailureHandlingOptions : unit -> FailureHandlingOptions

Return Value

FailureHandlingOptions
An instance of FailureHandlingOptions
Remarks
The returned instance is a copy of the options. If changes are made to the options, the new version can be set back to the transaction by calling the SetFailureHandlingOptions(FailureHandlingOptions) method.
See Also

Reference

Transaction Class


Transaction.GetName Method

TransactionGetName Method

Returns the transaction's name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetName()
Public Function GetName As String
public:
String^ GetName()
member GetName : unit -> string

Return Value

String
The transaction's current name.
See Also

Reference

Transaction Class


Transaction.GetStatus Method

TransactionGetStatus Method

Returns the current status of the transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TransactionStatus GetStatus()
Public Function GetStatus As TransactionStatus
public:
TransactionStatus GetStatus()
member GetStatus : unit -> TransactionStatus

Return Value

TransactionStatus
The current status of the transaction.
Remarks
If the status was set to TransactionStatus.Pending as the result of calling Commit or RollBack, the status will be changed later to either 'Committed' or 'RolledBack' after failure handling is finished. That status change will be made asynchronously.
See Also

Reference

Transaction Class


Transaction.HasEnded Method

TransactionHasEnded Method

Determines whether the transaction has ended already.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasEnded()
Public Function HasEnded As Boolean
public:
bool HasEnded()
member HasEnded : unit -> bool

Return Value

Boolean
True if the transaction has already been committed or rolled back, False otherwise.
Remarks
A transaction is ended by completing either the 'Commit' or 'RollBack' method. Another way of testing whether a transaction has ended is by testing the current status (see GetStatus). It must be either 'TransactionStatus.Committed' or 'TransactionStatus.RolledBack'
See Also

Reference

Transaction Class


Transaction.HasStarted Method

TransactionHasStarted Method

Determines whether the transaction has been started yet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasStarted()
Public Function HasStarted As Boolean
public:
bool HasStarted()
member HasStarted : unit -> bool

Return Value

Boolean
True if the transaction has already started, False otherwise.
Remarks
A transaction is considered being started after a 'Start' method was called and until the transaction is either completely committed or rolled back.

HasStarted may return True even after 'Commit' or 'RollBack' was called if the method returned the TransactionStatus.Pending value.

A transaction can only be Started when HasStarted returns false.

See Also

Reference

Transaction Class


Transaction.RollBack Method

TransactionRollBack Method

Overload List
Name | Description
RollBack | Rolls back all changes made to the model during the transaction.
RollBack(FailureHandlingOptions) | Rolls back all changes made to the model during the transaction.
Top
See Also

Reference

Transaction Class


Transaction.RollBack Method

TransactionRollBack Method

Rolls back all changes made to the model during the transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TransactionStatus RollBack()
Public Function RollBack As TransactionStatus
public:
TransactionStatus RollBack()
member RollBack : unit -> TransactionStatus

Return Value

TransactionStatus
If finished successfully, this method returns TransactionStatus.RolledBack.

Be aware that the returned status does not have to be necessarily the same like the status returned by GetStatus even when the method is called immediately after rolling back the transaction. Such difference may happen due to actions made by a transaction finalizer, if there was one set. (See FailureHandlingOptions for more details.)

Exceptions
Exception | Condition
InvalidOperationException | The current status of the transaction is not 'Started'. Transaction must be started before calling Commit or Rollback. -or- The transaction's document is currently in failure mode. No transaction operations are permitted until failure handling is finished.
Remarks
By rolling back a transaction, all changes made to the model are discarded. RollBack may only be called for a transaction that has been started. (Use the GetStatus method to check the current state.) Be aware that rolling back may be delayed (as a result of failure handling.) Callers should always check the returned status to test whether a transaction was rolled back successfully. Only after rolling back is fully completed, the transaction may be started again.
Example
C#
VB
C++
F#
Copy
public bool CreateGrid(Autodesk.Revit.DB.Document document, XYZ p1, XYZ p2)
{
   // All and any transaction should be enclosed in a 'using'
   // block or guarded within a try-catch-finally blocks
   // to guarantee that a transaction does not out-live its scope.
   using (Transaction transaction = new Transaction(document, "Creating Grid"))
   {
      // Must start a transaction to be able to modify a document
      if (TransactionStatus.Started == transaction.Start())
      {
         // We create a line and use it as an argument to create a grid
         Line gridLine = Line.CreateBound(p1, p2);

         if ((null != gridLine) && (null != Grid.Create(document, gridLine)))
         {
             if (TransactionStatus.Committed == transaction.Commit())
             {
                return true;
             }
         }

         // For we were unable to create the grid, we will roll the transaction back
         // (although on this simplified case we know there weren't any other changes)

         transaction.RollBack();
      }
   }
   return false;
}
Public Function CreateGrid(document As Autodesk.Revit.DB.Document, p1 As XYZ, p2 As XYZ) As Boolean
    ' All and any transaction should be enclosed in a 'using'
    ' block or guarded within a try-catch-finally blocks
    ' to guarantee that a transaction does not out-live its scope.
    Using transaction As New Transaction(document, "Creating Grid")
        ' Must start a transaction to be able to modify a document
        If TransactionStatus.Started = transaction.Start() Then
            ' We create a line and use it as an argument to create a grid
            Dim gridLine As Line = Line.CreateBound(p1, p2)

       If (gridLine IsNot Nothing) AndAlso (Grid.Create(document, gridLine) IsNot Nothing) Then
          If TransactionStatus.Committed = transaction.Commit() Then
             Return True
          End If
       End If

            ' For we were unable to create the grid, we will roll the transaction back
            ' (although on this simplified case we know there weren't any other changes)

            transaction.RollBack()
        End If
    End Using
    Return False
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Transaction Class
RollBack Overload


Transaction.RollBack(FailureHandlingOptions) Method

TransactionRollBack(FailureHandlingOptions) Method

Rolls back all changes made to the model during the transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TransactionStatus RollBack(
    FailureHandlingOptions options
)
Public Function RollBack (
    options As FailureHandlingOptions
) As TransactionStatus
public:
TransactionStatus RollBack(
    FailureHandlingOptions^ options
)
member RollBack :
        options : FailureHandlingOptions -> TransactionStatus

Parameters

options FailureHandlingOptions
A set of options to be used for handling eventual failures during this call.

The options are only used temporarily during this rolling back process. After the transaction is finished, the options will be reset to their default values.

Return Value

TransactionStatus
If finished successfully, this method returns TransactionStatus.RolledBack.

Be aware that the returned status does not have to be necessarily the same like the status returned by GetStatus even when the method is called immediately after rolling back the transaction. Such difference may happen due to actions made by a transaction finalizer, if there was one set. (See FailureHandlingOptions for more details.)

Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The current status of the transaction is not 'Started'. Transaction must be started before calling Commit or Rollback. -or- The transaction's document is currently in failure mode. No transaction operations are permitted until failure handling is finished.
Remarks
By rolling back a transaction, all changes made to the model are discarded. RollBack may only be called for a transaction that has been started. (Use the GetStatus method to check the current state.) Be aware that rolling back may be delayed (as a result of failure handling.) Callers should always check the returned status to test whether a transaction was rolled back successfully. Only after rolling back is fully completed, the transaction may be started again.
Example
C#
VB
C++
F#
Copy
// All and any transaction should be enclosed in a 'using'
// block or guarded within a try-catch-finally blocks
// to guarantee that a transaction does not out-live its scope.
using (Transaction transaction = new Transaction(document))
{
   // Must start the transaction first to be able to modify a document
   transaction.Start("Creating Grid");

   // We create a line and use it as an argument to create a grid
   Line gridLine = Line.CreateBound(new XYZ(0, 0, elevation), new XYZ(20, 0, elevation));

   if ((null != gridLine) && (null != Grid.Create(document, gridLine)))
   {
      if (TransactionStatus.Committed == transaction.Commit())
      {
         return true;
      }
   }

   // We could not create the grid, so we roll the transaction back.

   // To demonstrate one particular property of failure handling options,
   // we can set clearing of accumulated warnings (if any) for this
   // transaction which is about to get rolled back anyway.
   // Clearing warnings is rarely desirable, but sometimes it is convenient.
   FailureHandlingOptions options = transaction.GetFailureHandlingOptions();

   transaction.RollBack(options.SetClearAfterRollback(true));
}
' All and any transaction should be enclosed in a 'using'
' block or guarded within a try-catch-finally blocks
' to guarantee that a transaction does not out-live its scope.
Using transaction As New Transaction(document)
    ' Must start the transaction first to be able to modify a document
    transaction.Start("Creating Grid")

    ' We create a line and use it as an argument to create a grid
    Dim gridLine As Line = Line.CreateBound(New XYZ(0, 0, elevation), New XYZ(20, 0, elevation))

If (gridLine IsNot Nothing) AndAlso (Grid.Create(document, gridLine) IsNot Nothing) Then
   If TransactionStatus.Committed = transaction.Commit() Then
      Return True
   End If
End If

    ' We could not create the grid, so we roll the transaction back.

    ' To demonstrate one particular property of failure handling options,
    ' we can set clearing of accumulated warnings (if any) for this
    ' transaction which is about to get rolled back anyway.
    ' Clearing warnings is rarely desirable, but sometimes it is convenient.
    Dim options As FailureHandlingOptions = transaction.GetFailureHandlingOptions()

    transaction.RollBack(options.SetClearAfterRollback(True))
End Using

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Transaction Class
RollBack Overload


Transaction.SetFailureHandlingOptions Method

TransactionSetFailureHandlingOptions Method

Sets options for handling failures to be used when the transaction is being committed or rolled back.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetFailureHandlingOptions(
    FailureHandlingOptions options
)
Public Sub SetFailureHandlingOptions (
    options As FailureHandlingOptions
)
public:
void SetFailureHandlingOptions(
    FailureHandlingOptions^ options
)
member SetFailureHandlingOptions :
        options : FailureHandlingOptions -> unit

Parameters

options FailureHandlingOptions
An instance of FailureHandlingOptions to be applied to the transaction
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Options can be set at any time before the transaction is either committed or rolled back. See FailureHandlingOptions for details about available options. Once committed or rolled back, the transaction object will reset its options to their default values.
Example
C#
VB
C++
F#
Copy
// All and any transaction should be enclosed in a 'using'
// block or guarded within a try-catch-finally blocks
// to guarantee that a transaction does not out-live its scope.
using (Transaction transaction = new Transaction(doc))
{
   // Before we modify a document, we must start a transaction
   transaction.Start("Creating room");

   // obtain the current options and add failures preprocessor to it.
   // Note: preprocessor implements IFailuresProcessor and will receive
   // a notification about failures eventually posted during the transaction.
   FailureHandlingOptions options = transaction.GetFailureHandlingOptions();
   options.SetFailuresPreprocessor(new RoomWarningSwallower());
   transaction.SetFailureHandlingOptions(options);

   // Modify the document and commit the transaction.
   if (null != doc.Create.NewRoom(level, UV.Zero))
   {
      // Now, before the the transaction is committed, if there happened to
      // be any failure, the preprocessor would receive them first and would
      // have the option to analyze them, and ignore or re-qualify them.
      transaction.Commit();
   }
   else  // could not create the room; no need to commit the transaction
   {
      transaction.RollBack();
   }
}
' All and any transaction should be enclosed in a 'using'
' block or guarded within a try-catch-finally blocks
' to guarantee that a transaction does not out-live its scope.
Using transaction As New Transaction(doc)
    ' Before we modify a document, we must start a transaction
    transaction.Start("Creating room")

    ' obtain the current options and add failures preprocessor to it.
    ' Note: preprocessor implements IFailuresProcessor and will receive
    ' a notification about failures eventually posted during the transaction.
    Dim options As FailureHandlingOptions = transaction.GetFailureHandlingOptions()
    options.SetFailuresPreprocessor(New RoomWarningSwallower())
    transaction.SetFailureHandlingOptions(options)

    ' Modify the document and commit the transaction.
    If doc.Create.NewRoom(level, UV.Zero) IsNot Nothing Then
        ' Now, before the the transaction is committed, if there happened to
        ' be any failure, the preprocessor would receive them first and would
        ' have the option to analyze them, and ignore or re-qualify them.
        transaction.Commit()
    Else
        ' could not create the room; no need to commit the transaction
        transaction.RollBack()
    End If
End Using

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Transaction Class


Transaction.SetName Method

TransactionSetName Method

Sets the transaction's name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetName(
    string name
)
Public Sub SetName (
    name As String
)
public:
void SetName(
    String^ name
)
member SetName :
        name : string -> unit

Parameters

name String
A name for the transaction.
Exceptions
Exception | Condition
ArgumentException | The name argument is an empty string.
ArgumentNullException | A non-optional argument was null
Remarks
A transaction needs a name before it can be started, i.e. before one of the 'Start' method is invoked for this transaction object. The name will later appear in the Undo menu in Revit after a transaction is successfully committed.

Another ways of setting the name is either during construction or during the Start(String) method.

Example
C#
VB
C++
F#
Copy
public bool ModelChangingMethod(Autodesk.Revit.DB.Document document)
{
    bool result = false;

    // All and any transaction should be enclosed in a 'using'
    // block or guarded within a try-catch-finally blocks
    // to guarantee that a transaction does not out-live its scope.
    using (Transaction transaction = new Transaction(document))
    {
        // We can either start a transaction with a name or give
        // it a name later, but we have to name it before we commit.
        transaction.Start();

        // Some modification(s) of the model here, likely resulting in
        // changes of the 'result' value
        // result = .....

        if (result == true)
        {
            // Since the transaction is still unnamed,
            // we have to give it a name now before we commit

            transaction.SetName("Model change");

            // Now we can commit
            if (TransactionStatus.Committed != transaction.Commit())
            {
                result = false;
            }
        }
        else  // if modifications failed, transaction is to be rolled back
        {
            transaction.RollBack();
        }
    }
    return result;
}
Public Function ModelChangingMethod(document As Autodesk.Revit.DB.Document) As Boolean
    Dim result As Boolean = False

    ' All and any transaction should be enclosed in a 'using'
    ' block or guarded within a try-catch-finally blocks
    ' to guarantee that a transaction does not out-live its scope.
    Using transaction As New Transaction(document)
        ' We can either start a transaction with a name or give
        ' it a name later, but we have to name it before we commit.
        transaction.Start()

        ' Some modification(s) of the model here, likely resulting in
        ' changes of the 'result' value
        ' result = .....

        If result = True Then
            ' Since the transaction is still unnamed,
            ' we have to give it a name now before we commit

            transaction.SetName("Model change")

            ' Now we can commit
            If TransactionStatus.Committed <> transaction.Commit() Then
                result = False
            End If
        Else
            ' if modifications failed, transaction is to be rolled back
            transaction.RollBack()
        End If
    End Using
    Return result
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Transaction Class


Transaction.Start Method

TransactionStart Method

Overload List
Name | Description
Start | Starts the transaction.
Start(String) | Starts the transaction with an assigned name.
Top
See Also

Reference

Transaction Class


Transaction.Start Method

TransactionStart Method

Starts the transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TransactionStatus Start()
Public Function Start As TransactionStatus
public:
TransactionStatus Start()
member Start : unit -> TransactionStatus

Return Value

TransactionStatus
If finished successfully, this method returns TransactionStatus.Started. Note that unless starting is successful, changes cannot be made to the document.
Exceptions
Exception | Condition
InvalidOperationException | Cannot modify the document for either a read-only external command is being executed, or changes to the document are temporarily disabled. -or- The transaction's document is currently in failure mode. No transaction operations are permitted until failure handling is finished. -or- The transaction started already and has not been completed yet. -or- Starting a new transaction is not permitted. It could be because another transaction already started and has not been completed yet, or the document is in a state in which it cannot start a new transaction (e.g. during failure handling or a read-only mode, which could be either permanent or temporary). -or- The transaction does not have a valid name assigned yet.
Remarks

A transaction may be started only after it was instantiated or after it was previously committed or rolled back. In order to start a transaction, it must have a name assigned. If the name was not specified when the transaction object was instantiated, it has to be set by calling the SetName(String) method.

Be aware that every time a transaction starts, Failure Handling Options will be reset to their default values. If a specific failure handling is required, programmers need to use SetFailureHandlingOptions(FailureHandlingOptions) before the transaction is committed or rolled back.

Example
C#
VB
C++
F#
Copy
public void TransactionDuringElementCreation(UIApplication uiApplication, Level level)
{
    Autodesk.Revit.DB.Document document = uiApplication.ActiveUIDocument.Document;

    // Build a location line for the wall creation
    XYZ start = new XYZ(0, 0, 0);
    XYZ end = new XYZ(10, 10, 0);
    Autodesk.Revit.DB.Line geomLine = Line.CreateBound(start, end);

    // All and any transaction should be enclosed in a 'using'
    // block or guarded within a try-catch-finally blocks
    // to guarantee that a transaction does not out-live its scope.
    using (Transaction wallTransaction = new Transaction(document, "Creating wall"))
    {
       // To create a wall, a transaction must be first started
       if (wallTransaction.Start() == TransactionStatus.Started)
       {
           // Create a wall using the location line
           Wall wall = Wall.Create(document, geomLine, level.Id, true);

           // the transaction must be committed before you can
           // get the value of Geometry and AnalyticalModel.

           if (wallTransaction.Commit() == TransactionStatus.Committed)
           {
               Autodesk.Revit.DB.Options options = uiApplication.Application.Create.NewGeometryOptions();
               Autodesk.Revit.DB.GeometryElement geoelem = wall.get_Geometry(options);
           }
       }
    }
}
Public Sub TransactionDuringElementCreation(uiApplication As UIApplication, level As Level)
    Dim document As Autodesk.Revit.DB.Document = uiApplication.ActiveUIDocument.Document

    ' Build a location line for the wall creation
    Dim start As New XYZ(0, 0, 0)
    Dim [end] As New XYZ(10, 10, 0)
    Dim geomLine As Autodesk.Revit.DB.Line = Line.CreateBound(start, [end])

    ' All and any transaction should be enclosed in a 'using'
    ' block or guarded within a try-catch-finally blocks
    ' to guarantee that a transaction does not out-live its scope.
    Using wallTransaction As New Transaction(document, "Creating wall")
        ' To create a wall, a transaction must be first started
        If wallTransaction.Start() = TransactionStatus.Started Then
            ' Create a wall using the location line
            Dim wall__1 As Wall = Wall.Create(document, geomLine, level.Id, True)

            ' the transaction must be committed before you can
            ' get the value of Geometry and AnalyticalModel.

            If wallTransaction.Commit() = TransactionStatus.Committed Then
                Dim options As Autodesk.Revit.DB.Options = uiApplication.Application.Create.NewGeometryOptions()
                Dim geoelem As Autodesk.Revit.DB.GeometryElement = wall__1.Geometry(options)
            End If
        End If
    End Using
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Transaction Class
Start Overload


Transaction.Start(String) Method

TransactionStart(String) Method

Starts the transaction with an assigned name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TransactionStatus Start(
    string name
)
Public Function Start (
    name As String
) As TransactionStatus
public:
TransactionStatus Start(
    String^ name
)
member Start :
        name : string -> TransactionStatus

Parameters

name String
Name of the transaction; If the transaction already has name, this new one will preplace it. The name will appear on the Undo menu in Revit if the transaction is successfully committed.

Return Value

TransactionStatus
If finished successfully, this method returns TransactionStatus.Started. Note that unless starting is successful, changes cannot be made to the document.
Exceptions
Exception | Condition
ArgumentException | The name argument is an empty string.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Cannot modify the document for either a read-only external command is being executed, or changes to the document are temporarily disabled. -or- The transaction's document is currently in failure mode. No transaction operations are permitted until failure handling is finished. -or- The transaction started already and has not been completed yet. -or- Starting a new transaction is not permitted. It could be because another transaction already started and has not been completed yet, or the document is in a state in which it cannot start a new transaction (e.g. during failure handling or a read-only mode, which could be either permanent or temporary).
Remarks

A transaction may be started only after it was instantiated or after it was previously committed or rolled back.

Be aware that every time a transaction starts, Failure Handling Options will be reset to their default values. If a specific failure handling is required, programmers need to use SetFailureHandlingOptions(FailureHandlingOptions) before the transaction is committed or rolled back.

Example
C#
VB
C++
F#
Copy
public bool TransactionBoundaries(Autodesk.Revit.DB.Document document)
{
    bool result = false;

    // All and any transaction should be enclosed in a 'using'
    // block or guarded within a try-catch-finally blocks
    // to guarantee that a transaction does not out-live its scope.
    using (Transaction transaction = new Transaction(document))
    {
       transaction.Start("Transaction name");

       // some modification of the document here, likely resulting in
       // changes of the 'result' value
       // .....

       if (result == true)
       {
          // Modifications ended successfully, but it is still possible
          // for the transaction to fail due to model regeneration
          // (and other internal processes that validate the model)
          if (TransactionStatus.Committed != transaction.Commit())
          {
             result = false;
          }
       }
       else  // if modifications failed, transaction is to be rolled back
       {
          transaction.RollBack();
       }
    }
    return result;
}
Public Function TransactionBoundaries(document As Autodesk.Revit.DB.Document) As Boolean
    Dim result As Boolean = False

    ' All and any transaction should be enclosed in a 'using'
    ' block or guarded within a try-catch-finally blocks
    ' to guarantee that a transaction does not out-live its scope.
    Using transaction As New Transaction(document)
        transaction.Start("Transaction name")

        ' some modification of the document here, likely resulting in
        ' changes of the 'result' value
        ' .....

        If result = True Then
            ' Modifications ended successfully, but it is still possible
            ' for the transaction to fail due to model regeneration
            ' (and other internal processes that validate the model)
            If TransactionStatus.Committed <> transaction.Commit() Then
                result = False
            End If
        Else
            ' if modifications failed, transaction is to be rolled back
            transaction.RollBack()
        End If
    End Using
    Return result
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Transaction Class
Start Overload


TransactionGroup Class

Transaction groups aggregate a number of transactions.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBTransactionGroup

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TransactionGroup : IDisposable
Public Class TransactionGroup
    Implements IDisposable
public ref class TransactionGroup : IDisposable
type TransactionGroup =
    class
        interface IDisposable
    end

The TransactionGroup type exposes the following members.

Constructors
 | Name | Description
Public method | TransactionGroup(Document) | Constructs a transaction group object.
Public method | TransactionGroup(Document, String) | It constructs a transaction group object
Top
Properties
 | Name | Description
Public property | IsFailureHandlingForcedModal | Forces all transactions finished inside this group to use modal failure handling regardless of what failure handling options are set for those transactions.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
 | Assimilate | Assimilates all inner transactions by merging them into a single undo item.
 | Commit | Commits the transaction group.
Public method | Dispose | Releases all resources used by the TransactionGroup
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetName | Returns the transaction group's name. It could be an empty string.
Public method | GetStatus | Gets the current status of the transaction group.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HasEnded | Determines whether the transaction group has ended already.
Public method | HasStarted | Determines whether the transaction has been started yet.
Public method | RollBack | Rolls back the transaction group, which effectively undoes all transactions committed inside the group.
Public method | SetName | Sets the transaction group's name.
Public method | Start | Starts the transaction group
Public method | Start(String) | Starts the transaction group with an assigned name.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

A transaction group controls whether transactions committed inside the group should stay committed or should be all discarded. If the group is committed, all the transactions remain committed, but if the transaction group is rolled back instead, all the inner, already committed transactions will be undone (and removed).

There are two ways of committing a group - Commit and Assimilate. By committing, all transactions committed inside a group stay as they are, while by assimilating, all inner transactions will be merged into a single transaction.

A transaction group can only be started when no transaction is active, and must be closed only after the last transaction started inside the group is finished, i.e. after it was either committed or rolled back.

Transaction groups may be nested inside each other with the restriction that every nested transaction group is entirely contained (opened and closed) in the parent transaction group.

If a transaction group was started and not finished yet by the time the TransactionGroup object is about to be, the default destructor will roll it back automatically, thus all changes made to the document while this transaction group was open will be discarded. It is not recommended to rely on this default behavior though. Instead, it is advised to always call either Commit, RollBack, or Assimilate explicitly before the group object gets destroyed. Please note that unless invoked explicitly the actual destruction of an object in managed code might not happen until the object is collected by the garbage collector.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TransactionGroup Constructor

Overload List
 | Name | Description
Public method | TransactionGroup(Document) | Constructs a transaction group object.
Public method | TransactionGroup(Document, String) | It constructs a transaction group object
Top
See Also

Reference

TransactionGroup Class


TransactionGroup(Document) Constructor

Constructs a transaction group object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TransactionGroup(
    Document document
)
Public Sub New (
    document As Document
)
public:
TransactionGroup(
    Document^ document
)
new :
        document : Document -> TransactionGroup

Parameters

document Document
The document for which this transaction group is being used.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
The group does not start until its Start method is called.
See Also

Reference

TransactionGroup Class
TransactionGroup Overload


TransactionGroup(Document, String) Constructor

It constructs a transaction group object

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TransactionGroup(
    Document document,
    string transGroupName
)
Public Sub New (
    document As Document,
    transGroupName As String
)
public:
TransactionGroup(
    Document^ document,
    String^ transGroupName
)
new :
        document : Document *
        transGroupName : string -> TransactionGroup

Parameters

document Document
The document for which this transaction group is being used.
transGroupName String
Name of the group. The name will be used only for a group that is assimilated at the end.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
The group does not start until its Start method is called.
See Also

Reference

TransactionGroup Class
TransactionGroup Overload


TransactionGroup Properties

The TransactionGroup type exposes the following members.

Properties
 | Name | Description
Public property | IsFailureHandlingForcedModal | Forces all transactions finished inside this group to use modal failure handling regardless of what failure handling options are set for those transactions.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

TransactionGroup Class


TransactionGroup.IsFailureHandlingForcedModal Property

TransactionGroupIsFailureHandlingForcedModal Property

Forces all transactions finished inside this group to use modal failure handling regardless of what failure handling options are set for those transactions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsFailureHandlingForcedModal { get; set; }
Public Property IsFailureHandlingForcedModal As Boolean
    Get
    Set
public:
property bool IsFailureHandlingForcedModal {
    bool get ();
    void set (bool value);
}
member IsFailureHandlingForcedModal : bool with get, set

Property Value

Boolean
Remarks
This property is ignored during events, when failure handling is always modal.
See Also

Reference

TransactionGroup Class


TransactionGroup.IsValidObject Property

TransactionGroupIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

TransactionGroup Class


TransactionGroup Methods

The TransactionGroup type exposes the following members.

Methods
 | Name | Description
 | Assimilate | Assimilates all inner transactions by merging them into a single undo item.
 | Commit | Commits the transaction group.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetName | Returns the transaction group's name. It could be an empty string.
Public method | GetStatus | Gets the current status of the transaction group.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HasEnded | Determines whether the transaction group has ended already.
Public method | HasStarted | Determines whether the transaction has been started yet.
Public method | RollBack | Rolls back the transaction group, which effectively undoes all transactions committed inside the group.
Public method | SetName | Sets the transaction group's name.
Public method | Start | Starts the transaction group
Public method | Start(String) | Starts the transaction group with an assigned name.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

TransactionGroup Class


TransactionGroup.Assimilate Method

TransactionGroupAssimilate Method

Assimilates all inner transactions by merging them into a single undo item.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TransactionStatus Assimilate()
Public Function Assimilate As TransactionStatus
public:
TransactionStatus Assimilate()
member Assimilate : unit -> TransactionStatus

Return Value

TransactionStatus
If finished successfully, this method returns TransactionStatus.Committed.
Exceptions
Exception | Condition
InvalidOperationException | The Transaction group has not been started (its status is not 'Started').. -or- The transaction's document is currently in failure mode. Transaction groups cannot be closed until failure handling is finished. You may use a transaction finalizer to close a group after the failure handling ends.
Remarks

After a successful assimilation the transaction group is committed.

All transactions committed inside this group will be merged into one single transaction. The resulting undo item will bear this group's name.

Assimilate can be called only when all inner transaction groups and transactions are finished, i.e. after they were either committed or rolled back.

Example
C#
VB
C++
F#
Copy
public void CompoundOperation(Autodesk.Revit.DB.Document document)
{
   // All and any transaction group should be enclosed in a 'using' block or guarded within
   // a try-catch-finally blocks to guarantee that the group does not out-live its scope.
   using (TransactionGroup transGroup = new TransactionGroup(document, "Level and Grid"))
    {
       if (transGroup.Start() == TransactionStatus.Started)
       {
          // We are going to call two methods, each having its own local transaction.
          // For our compound operation to be considered successful, both the individual
          // transactions must succeed. If either one fails, we will roll our group back,
          // regardless of what transactions might have already been committed.

          if (CreateLevel(document, 25.0) && CreateGrid(document, new XYZ(0,0,0), new XYZ(10,0,0)))
          {
             // The process of assimilating will merge the two (or any number of) committed
             // transaction together and will assign the grid's name to the one resulting transaction,
             // which will become the only item from this compound operation appearing in the undo menu.
             transGroup.Assimilate();
          }
          else
          {
             // Since we could not successfully finish at least one of the individual
             // operation, we are going to roll the entire group back, which will
             // undo any transaction already committed while this group was open.
             transGroup.RollBack();
          }
       }
    }
}
Public Sub CompoundOperation(document As Autodesk.Revit.DB.Document)
    ' All and any transaction group should be enclosed in a 'using' block or guarded within
    ' a try-catch-finally blocks to guarantee that the group does not out-live its scope.
    Using transGroup As New TransactionGroup(document, "Level and Grid")
        If transGroup.Start() = TransactionStatus.Started Then
            ' We are going to call two methods, each having its own local transaction.
            ' For our compound operation to be considered successful, both the individual
            ' transactions must succeed. If either one fails, we will roll our group back,
            ' regardless of what transactions might have already been committed.

            If CreateLevel(document, 25.0) AndAlso CreateGrid(document, New XYZ(0, 0, 0), New XYZ(10, 0, 0)) Then
                ' The process of assimilating will merge the two (or any number of) committed
                ' transaction together and will assign the grid's name to the one resulting transaction,
                ' which will become the only item from this compound operation appearing in the undo menu.
                transGroup.Assimilate()
            Else
                ' Since we could not successfully finish at least one of the individual
                ' operation, we are going to roll the entire group back, which will
                ' undo any transaction already committed while this group was open.
                transGroup.RollBack()
            End If
        End If
    End Using
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

TransactionGroup Class


TransactionGroup.Commit Method

TransactionGroupCommit Method

Commits the transaction group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TransactionStatus Commit()
Public Function Commit As TransactionStatus
public:
TransactionStatus Commit()
member Commit : unit -> TransactionStatus

Return Value

TransactionStatus
If finished successfully, this method returns TransactionStatus.Committed.
Exceptions
Exception | Condition
InvalidOperationException | The Transaction group has not been started (its status is not 'Started').. -or- The transaction's document is currently in failure mode. Transaction groups cannot be closed until failure handling is finished. You may use a transaction finalizer to close a group after the failure handling ends.
Remarks

Committing a group does not change the model. It only confirms the commitment of all inner groups and transactions.

Commit can be called only when all inner transaction groups and transactions are finished, i.e. after they were either committed or rolled back. If there is still a transaction or an inner transaction group open, an attempt to commit this outer group will cause an exception.

Example
C#
VB
C++
F#
Copy
public void GroupedOperations(Autodesk.Revit.DB.Document document)
{
   // All and any transaction group should be enclosed in a 'using' block or guarded within
   // a try-catch-finally blocks to guarantee that the group does not out-live its scope.
   using (TransactionGroup transGroup = new TransactionGroup(document, "Level and Grid"))
   {
      if (transGroup.Start() == TransactionStatus.Started)
      {
         // We are going to call two methods, each having its own local transaction.
         // For our compound operation to be considered successful, both the individual
         // transactions must succeed. If either one fails, we will roll our group back,
         // regardless of what transactions might have already been committed.

         if (CreateLevel(document, 35.0) && CreateGrid(document, new XYZ(0, 0, 0), new XYZ(0, 10, 0)))
         {
            // The process of committing of a group does not do anything to the already committed
            // transactions. They will stay available on the undo menu and may still be undone
            // individually. If it is not desirable if one transaction from a multi-transaction
            // operation can be undone by th end user, then the transaction group must be
            // assimilated instead of committed. See TransactionGroup.Assimilate for details.
            transGroup.Commit();
         }
         else
         {
            // Since we could not successfully finish at least one of the individual
            // operation, we are going to roll the entire group back, which will
            // undo any transaction already committed while this group was open.
            transGroup.RollBack();
         }
      }
   }
}
Public Sub GroupedOperations(document As Autodesk.Revit.DB.Document)
    ' All and any transaction group should be enclosed in a 'using' block or guarded within
    ' a try-catch-finally blocks to guarantee that the group does not out-live its scope.
    Using transGroup As New TransactionGroup(document, "Level and Grid")
        If transGroup.Start() = TransactionStatus.Started Then
            ' We are going to call two methods, each having its own local transaction.
            ' For our compound operation to be considered successful, both the individual
            ' transactions must succeed. If either one fails, we will roll our group back,
            ' regardless of what transactions might have already been committed.

            If CreateLevel(document, 35.0) AndAlso CreateGrid(document, New XYZ(0, 0, 0), New XYZ(0, 10, 0)) Then
                ' The process of committing of a group does not do anything to the already committed
                ' transactions. They will stay available on the undo menu and may still be undone
                ' individually. If it is not desirable if one transaction from a multi-transaction
                ' operation can be undone by th end user, then the transaction group must be
                ' assimilated instead of committed. See TransactionGroup.Assimilate for details.
                transGroup.Commit()
            Else
                ' Since we could not successfully finish at least one of the individual
                ' operation, we are going to roll the entire group back, which will
                ' undo any transaction already committed while this group was open.
                transGroup.RollBack()
            End If
        End If
    End Using
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

TransactionGroup Class


TransactionGroup.Dispose Method

TransactionGroupDispose Method

Releases all resources used by the TransactionGroup

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

TransactionGroup Class


TransactionGroup.GetName Method

TransactionGroupGetName Method

Returns the transaction group's name. It could be an empty string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetName()
Public Function GetName As String
public:
String^ GetName()
member GetName : unit -> string

Return Value

String
The transaction group's current name.
See Also

Reference

TransactionGroup Class


TransactionGroup.GetStatus Method

TransactionGroupGetStatus Method

Gets the current status of the transaction group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TransactionStatus GetStatus()
Public Function GetStatus As TransactionStatus
public:
TransactionStatus GetStatus()
member GetStatus : unit -> TransactionStatus

Return Value

TransactionStatus
The current status of the transaction group.
See Also

Reference

TransactionGroup Class


TransactionGroup.HasEnded Method

TransactionGroupHasEnded Method

Determines whether the transaction group has ended already.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasEnded()
Public Function HasEnded As Boolean
public:
bool HasEnded()
member HasEnded : unit -> bool

Return Value

Boolean
True if the transaction group has already been committed or rolled back, False otherwise.
Remarks
A transaction is ended by completing either the Commit or RollBack or Assimilate method. Another way of testing whether a transaction group has ended is by testing its current status returned from (see GetStatus). It must be either 'TransactionStatus.Committed' or 'TransactionStatus.RolledBack'
See Also

Reference

TransactionGroup Class


TransactionGroup.HasStarted Method

TransactionGroupHasStarted Method

Determines whether the transaction has been started yet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasStarted()
Public Function HasStarted As Boolean
public:
bool HasStarted()
member HasStarted : unit -> bool

Return Value

Boolean
True if the transaction group has already started, False otherwise.
Remarks
A transaction group is considered being started after the Start method was called and until the transaction group is either completely committed or rolled back. A transaction group can only be Started when HasStarted returns false.
See Also

Reference

TransactionGroup Class


TransactionGroup.RollBack Method

TransactionGroupRollBack Method

Rolls back the transaction group, which effectively undoes all transactions committed inside the group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TransactionStatus RollBack()
Public Function RollBack As TransactionStatus
public:
TransactionStatus RollBack()
member RollBack : unit -> TransactionStatus

Return Value

TransactionStatus
If finished successfully, this method returns TransactionStatus.RolledBack.
Exceptions
Exception | Condition
InvalidOperationException | The Transaction group has not been started (its status is not 'Started').. -or- The transaction's document is currently in failure mode. Transaction groups cannot be closed until failure handling is finished. You may use a transaction finalizer to close a group after the failure handling ends.
Remarks

Note that once a group is rolled back, the undone transactions cannot be redone.

RollBack can be called only when all inner transaction groups and transactions are finished, i.e. after they were either committed or rolled back.

See Also

Reference

TransactionGroup Class


TransactionGroup.SetName Method

TransactionGroupSetName Method

Sets the transaction group's name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetName(
    string name
)
Public Sub SetName (
    name As String
)
public:
void SetName(
    String^ name
)
member SetName :
        name : string -> unit

Parameters

name String
A name for the transaction group.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Transaction group only needs a name if it is going to be assimilated at the end.
See Also

Reference

TransactionGroup Class


TransactionGroup.Start Method

TransactionGroupStart Method

Overload List
 | Name | Description
Public method | Start | Starts the transaction group
Public method | Start(String) | Starts the transaction group with an assigned name.
Top
See Also

Reference

TransactionGroup Class


TransactionGroup.Start Method

TransactionGroupStart Method

Starts the transaction group

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TransactionStatus Start()
Public Function Start As TransactionStatus
public:
TransactionStatus Start()
member Start : unit -> TransactionStatus

Return Value

TransactionStatus
If started successfully, this method returns TransactionStatus.Started.
Exceptions
Exception | Condition
InvalidOperationException | Cannot modify the document for either a read-only external command is being executed, or changes to the document are temporarily disabled. -or- Transaction group cannot be started during an active transaction. -or- The Transaction group has already been started.
Remarks
A transaction group can be started only when there is no transaction started currently. It can be started inside another transaction group. When groups are nested inside each other it is required that inner transaction groups are finished (i.e. rolled back, committed, or assimilated) before outer groups are.
See Also

Reference

TransactionGroup Class
Start Overload


TransactionGroup.Start(String) Method

TransactionGroupStart(String) Method

Starts the transaction group with an assigned name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TransactionStatus Start(
    string transGroupName
)
Public Function Start (
    transGroupName As String
) As TransactionStatus
public:
TransactionStatus Start(
    String^ transGroupName
)
member Start :
        transGroupName : string -> TransactionStatus

Parameters

transGroupName String
Name of the group. The name will be used only for a group that is assimilated at the end.

Return Value

TransactionStatus
If started successfully, this method returns TransactionStatus.Started.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Cannot modify the document for either a read-only external command is being executed, or changes to the document are temporarily disabled. -or- Transaction group cannot be started during an active transaction. -or- The Transaction group has already been started.
Remarks
A transaction group can be started only when there is no transaction started currently. It can be started inside another transaction group though. With such group nesting it is required that inner transaction groups are finished (i.e. rolled back, committed, or assimilated) before outer groups are.
See Also

Reference

TransactionGroup Class
Start Overload


TransactionStatus Enumeration

An enumerated type listing the possible statuses associated with a Transaction, TransactionGroup, or SubTransaction, or the result of a particular method call on one of those objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum TransactionStatus
Public Enumeration TransactionStatus
public enum class TransactionStatus
type TransactionStatus
Members
Member name | Value | Description
Uninitialized | 0 | initial value, the transaction has not been started yet in this status
Started | 1 | transaction has begun (until committed or rolled back)
RolledBack | 2 | rolled back (aborted)
Committed | 3 | simply committed, ended an empty transaction, flushed all, or undo is disabled
Pending | 4 | returned from error handling that took over managing the transaction
Error | 5 | error while committing or rolling back
Proceed | 6 | while still in error handling (internal status)
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TransactWithCentralOptions Class

Options to customize Revit behavior when accessing the central model.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBTransactWithCentralOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TransactWithCentralOptions : IDisposable
Public Class TransactWithCentralOptions
    Implements IDisposable
public ref class TransactWithCentralOptions : IDisposable
type TransactWithCentralOptions =
    class
        interface IDisposable
    end

The TransactWithCentralOptions type exposes the following members.

Constructors
 | Name | Description
Public method | TransactWithCentralOptions | Constructs a new TransactWithCentralOptions.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the TransactWithCentralOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLockCallback | Gets the callback object that changes Revit's default behavior of endlessly waiting and repeatedly trying to lock a central model.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetLockCallback | Sets or resets a callback object that would allow an external application to change Revit's default behavior of endlessly waiting and repeatedly trying to lock a central model.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Example
C#
VB
C++
F#
Copy
public static void SynchWithCentralWithMessage(Document doc)
{
    // Checkout workset (for use with "keep checked out worksets" option later)
    FilteredWorksetCollector fwc = new FilteredWorksetCollector(doc);
    fwc.OfKind(WorksetKind.UserWorkset);
    Workset workset1 = fwc.First<Workset>(ws => ws.Name == "Workset1");

    WorksharingUtils.CheckoutWorksets(doc, new WorksetId[] { workset1.Id });

    // Make a change
    using (Transaction t = new Transaction(doc, "Add Level"))
    {
        t.Start();
        Level.Create(doc, 100);
        t.Commit();
    }

    // Tell user what we're doing
    TaskDialog td = new TaskDialog("Alert");
    td.MainInstruction = "Application 'Automatic element creator' has made changes and is prepared to synchronize with central.";
    td.MainContent = "This will update central with all changes currently made in the project by the application or by the user.  This operation " +
                     "may take some time depending on the number of changes made by the app and by the user.";

    td.AddCommandLink(TaskDialogCommandLinkId.CommandLink1, "Do not synchronize at this time.");
    td.AddCommandLink(TaskDialogCommandLinkId.CommandLink2, "Synchronize and relinquish all elements.");
    td.AddCommandLink(TaskDialogCommandLinkId.CommandLink3, "Synchronize but keep checked out worksets.");
    td.DefaultButton = TaskDialogResult.CommandLink1;

    TaskDialogResult result = td.Show();

    switch (result)
    {
        case TaskDialogResult.CommandLink1:
        default:
            {
                // Do not synch.  Nothing to do.
                break;
            }
        case TaskDialogResult.CommandLink2:
        case TaskDialogResult.CommandLink3:
            {
                // Prepare to synch
                // TransactWithCentralOptions has to do with the behavior related to locked or busy central models.
                // We'll use the default behavior.
                TransactWithCentralOptions twcOpts = new TransactWithCentralOptions();

                // Setup synch-with-central options (add a comment about our change)
                SynchronizeWithCentralOptions swcOpts = new SynchronizeWithCentralOptions();
                swcOpts.Comment = "Synchronized by 'Automatic element creator' with user acceptance.";

                if (result == TaskDialogResult.CommandLink3)
                {
                    // Setup relinquish options to keep user worksets checked out
                    RelinquishOptions rOptions = new RelinquishOptions(true);
                    rOptions.UserWorksets = false;
                    swcOpts.SetRelinquishOptions(rOptions);
                }

                doc.SynchronizeWithCentral(twcOpts, swcOpts);

                break;
            }
    }
}
Public Shared Sub SynchWithCentralWithMessage(doc As Document)
    ' Checkout workset (for use with "keep checked out worksets" option later)
    Dim fwc As New FilteredWorksetCollector(doc)
    fwc.OfKind(WorksetKind.UserWorkset)
    Dim workset1 As Workset = fwc.First(Function(ws) ws.Name = "Workset1")

    WorksharingUtils.CheckoutWorksets(doc, New WorksetId() {workset1.Id})

    ' Make a change
    Using t As New Transaction(doc, "Add Level")
        t.Start()
        Level.Create(doc, 100)
        t.Commit()
    End Using

    ' Tell user what we're doing
    Dim td As New TaskDialog("Alert")
    td.MainInstruction = "Application 'Automatic element creator' has made changes and is prepared to synchronize with central."
    td.MainContent = "This will update central with all changes currently made in the project by the application or by the user.  This operation " + "may take some time depending on the number of changes made by the app and by the user."

    td.AddCommandLink(TaskDialogCommandLinkId.CommandLink1, "Do not synchronize at this time.")
    td.AddCommandLink(TaskDialogCommandLinkId.CommandLink2, "Synchronize and relinquish all elements.")
    td.AddCommandLink(TaskDialogCommandLinkId.CommandLink3, "Synchronize but keep checked out worksets.")
    td.DefaultButton = TaskDialogResult.CommandLink1

    Dim result As TaskDialogResult = td.Show()

    Select Case result
        Case TaskDialogResult.CommandLink1
            If True Then
                ' Do not synch.  Nothing to do.
                Exit Select
            End If
        Case TaskDialogResult.CommandLink2, TaskDialogResult.CommandLink3
            If True Then
                ' Prepare to synch
                ' TransactWithCentralOptions has to do with the behavior related to locked or busy central models.
                ' We'll use the default behavior.
                Dim twcOpts As New TransactWithCentralOptions()

                ' Setup synch-with-central options (add a comment about our change)
                Dim swcOpts As New SynchronizeWithCentralOptions()
                swcOpts.Comment = "Synchronized by 'Automatic element creator' with user acceptance."

                If result = TaskDialogResult.CommandLink3 Then
                    ' Setup relinquish options to keep user worksets checked out
                    Dim rOptions As New RelinquishOptions(True)
                    rOptions.UserWorksets = False
                    swcOpts.SetRelinquishOptions(rOptions)
                End If

                doc.SynchronizeWithCentral(twcOpts, swcOpts)

                Exit Select
            End If
    End Select
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TransactWithCentralOptions Constructor

Constructs a new TransactWithCentralOptions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TransactWithCentralOptions()
Public Sub New
public:
TransactWithCentralOptions()
new : unit -> TransactWithCentralOptions
See Also

Reference

TransactWithCentralOptions Class


TransactWithCentralOptions Properties

The TransactWithCentralOptions type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

TransactWithCentralOptions Class


TransactWithCentralOptions.IsValidObject Property

TransactWithCentralOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

TransactWithCentralOptions Class


TransactWithCentralOptions Methods

The TransactWithCentralOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLockCallback | Gets the callback object that changes Revit's default behavior of endlessly waiting and repeatedly trying to lock a central model.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetLockCallback | Sets or resets a callback object that would allow an external application to change Revit's default behavior of endlessly waiting and repeatedly trying to lock a central model.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

TransactWithCentralOptions Class


TransactWithCentralOptions.Dispose Method

TransactWithCentralOptionsDispose Method

Releases all resources used by the TransactWithCentralOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

TransactWithCentralOptions Class


TransactWithCentralOptions.GetLockCallback Method

TransactWithCentralOptionsGetLockCallback Method

Gets the callback object that changes Revit's default behavior of endlessly waiting and repeatedly trying to lock a central model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICentralLockedCallback GetLockCallback()
Public Function GetLockCallback As ICentralLockedCallback
public:
ICentralLockedCallback^ GetLockCallback()
member GetLockCallback : unit -> ICentralLockedCallback

Return Value

ICentralLockedCallback
See Also

Reference

TransactWithCentralOptions Class


TransactWithCentralOptions.SetLockCallback Method

TransactWithCentralOptionsSetLockCallback Method

Sets or resets a callback object that would allow an external application to change Revit's default behavior of endlessly waiting and repeatedly trying to lock a central model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetLockCallback(
    ICentralLockedCallback lockCallback
)
Public Sub SetLockCallback (
    lockCallback As ICentralLockedCallback
)
public:
void SetLockCallback(
    ICentralLockedCallback^ lockCallback
)
member SetLockCallback :
        lockCallback : ICentralLockedCallback -> unit

Parameters

lockCallback ICentralLockedCallback
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

TransactWithCentralOptions Class


Transform Class

A transformation of the affine 3-space.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBTransform

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Transform : APIObject
Public Class Transform
    Inherits APIObject
public ref class Transform : public APIObject
type Transform =
    class
        inherit APIObject
    end

The Transform type exposes the following members.

Constructors
 | Name | Description
Public method | Transform | The copy constructor.
Top
Properties
 | Name | Description
Public property | Basis | Defines the basis of the old coordinate system in the new coordinate system.
Public property | BasisX | The basis of the X axis of this transformation.
Public property | BasisY | The basis of the Y axis of this transformation.
Public property | BasisZ | The basis of the Z axis of this transformation.
Public property | Determinant | The determinant of this transformation.
Public property | HasReflection | The boolean value that indicates whether this transformation produces reflection.
 | Identity | The identity transformation.
Public property | Inverse | The inverse transformation of this transformation.
Public property | IsConformal | The boolean value that indicates whether this transformation is conformal.
Public property | IsIdentity | The boolean value that indicates whether this transformation is an identity.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | IsTranslation | The boolean value that indicates whether this transformation is a translation.
Public property | Origin | Defines the origin of the old coordinate system in the new coordinate system.
Public property | Scale | The real number that represents the scale of the transformation.
Top
Methods
 | Name | Description
Public method | AlmostEqual | Determines whether this transformation and the specified transformation are the same within the tolerance (1.0e-09).
 | CreateReflection | Creates a transform that represents a reflection across the given plane.
 | CreateRotation | Creates a transform that represents a rotation about the given axis at (0, 0, 0).
 | CreateRotationAtPoint | Creates a transform that represents a rotation about the given axis at the specified point.
 | CreateTranslation | Creates a transform that represents a translation via the specified vector.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Multiply | Multiplies this transformation by the specified transformation and returns the result.
Public method | OfPoint | Applies the transformation to the point and returns the result.
Public method | OfVector | Applies the transform to the vector
Public method | ScaleBasis | Scales the basis vectors of this transformation and returns the result.
Public method | ScaleBasisAndOrigin | Scales the basis vectors and the origin of this transformation and returns the result.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Operators
Name | Description
Multiply(Transform, Transform) | Multiplies the two specified transforms.
Top
Example
C#
VB
C++
F#
Copy
public static XYZ TransformPoint(XYZ point, Transform transform)
{
    double x = point.X;
    double y = point.Y;
    double z = point.Z;

    //transform basis of the old coordinate system in the new coordinate // system
    XYZ b0 = transform.get_Basis(0);
    XYZ b1 = transform.get_Basis(1);
    XYZ b2 = transform.get_Basis(2);
    XYZ origin = transform.Origin;

    //transform the origin of the old coordinate system in the new
    //coordinate system
    double xTemp = x * b0.X + y * b1.X + z * b2.X + origin.X;
    double yTemp = x * b0.Y + y * b1.Y + z * b2.Y + origin.Y;
    double zTemp = x * b0.Z + y * b1.Z + z * b2.Z + origin.Z;

    return new XYZ(xTemp, yTemp, zTemp);
}
Public Shared Function TransformPoint(point As XYZ, transform As Transform) As XYZ
    Dim x As Double = point.X
    Dim y As Double = point.Y
    Dim z As Double = point.Z

    'transform basis of the old coordinate system in the new coordinate // system
    Dim b0 As XYZ = transform.Basis(0)
    Dim b1 As XYZ = transform.Basis(1)
    Dim b2 As XYZ = transform.Basis(2)
    Dim origin As XYZ = transform.Origin

    'transform the origin of the old coordinate system in the new
    'coordinate system
    Dim xTemp As Double = x * b0.X + y * b1.X + z * b2.X + origin.X
    Dim yTemp As Double = x * b0.Y + y * b1.Y + z * b2.Y + origin.Y
    Dim zTemp As Double = x * b0.Z + y * b1.Z + z * b2.Z + origin.Z

    Return New XYZ(xTemp, yTemp, zTemp)
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Transform Constructor

The copy constructor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Transform(
    Transform source
)
Public Sub New (
    source As Transform
)
public:
Transform(
    Transform^ source
)
new :
        source : Transform -> Transform

Parameters

source Transform
See Also

Reference

Transform Class


Transform Properties

The Transform type exposes the following members.

Properties
 | Name | Description
Public property | Basis | Defines the basis of the old coordinate system in the new coordinate system.
Public property | BasisX | The basis of the X axis of this transformation.
Public property | BasisY | The basis of the Y axis of this transformation.
Public property | BasisZ | The basis of the Z axis of this transformation.
Public property | Determinant | The determinant of this transformation.
Public property | HasReflection | The boolean value that indicates whether this transformation produces reflection.
 | Identity | The identity transformation.
Public property | Inverse | The inverse transformation of this transformation.
Public property | IsConformal | The boolean value that indicates whether this transformation is conformal.
Public property | IsIdentity | The boolean value that indicates whether this transformation is an identity.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | IsTranslation | The boolean value that indicates whether this transformation is a translation.
Public property | Origin | Defines the origin of the old coordinate system in the new coordinate system.
Public property | Scale | The real number that represents the scale of the transformation.
Top
See Also

Reference

Transform Class


Transform.Basis Property

TransformBasis Property

Defines the basis of the old coordinate system in the new coordinate system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ this[
    int idx
] { get; set; }
Public Property Basis (
    idx As Integer
) As XYZ
    Get
    Set
public:
property XYZ^ Basis[int idx] {
    XYZ^ get (int idx);
    void set (int idx, XYZ^ value);
}
member Basis : XYZ with get, set

Parameters

idx Int32
The index of the basis vector: 0, 1 or 2.

Property Value

XYZ
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown when the given index is larger than 2 in the getter and setter.
InvalidOperationException | Thrown when the transform is internally marked as read-only.
Remarks
This corresponds to the first three column vectors of the conventional 3x4 matrix representation.
See Also

Reference

Transform Class


Transform.BasisX Property

TransformBasisX Property

The basis of the X axis of this transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ BasisX { get; set; }
Public Property BasisX As XYZ
    Get
    Set
public:
property XYZ^ BasisX {
    XYZ^ get ();
    void set (XYZ^ value);
}
member BasisX : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the transform is internally marked as read-only.
Remarks
The X axis of the old coordinate system in the new coordinate system, or the 1st column of the conventional 3x4 matrix representation.
See Also

Reference

Transform Class


Transform.BasisY Property

TransformBasisY Property

The basis of the Y axis of this transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ BasisY { get; set; }
Public Property BasisY As XYZ
    Get
    Set
public:
property XYZ^ BasisY {
    XYZ^ get ();
    void set (XYZ^ value);
}
member BasisY : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the transform is internally marked as read-only.
Remarks
The Y axis of the old coordinate system in the new coordinate system, or the 2nd column of the conventional 3x4 matrix representation.
See Also

Reference

Transform Class


Transform.BasisZ Property

TransformBasisZ Property

The basis of the Z axis of this transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ BasisZ { get; set; }
Public Property BasisZ As XYZ
    Get
    Set
public:
property XYZ^ BasisZ {
    XYZ^ get ();
    void set (XYZ^ value);
}
member BasisZ : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the transform is internally marked as read-only.
Remarks
The Z axis of the old coordinate system in the new coordinate system, or the 3rd column of the conventional 3x4 matrix representation.
See Also

Reference

Transform Class


Transform.Determinant Property

TransformDeterminant Property

The determinant of this transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Determinant { get; }
Public ReadOnly Property Determinant As Double
    Get
public:
property double Determinant {
    double get ();
}
member Determinant : float with get

Property Value

Double
Remarks
The geometric meaning of a determinant is as the scale factor for volume when applied as linear transformation.
See Also

Reference

Transform Class


Transform.HasReflection Property

TransformHasReflection Property

The boolean value that indicates whether this transformation produces reflection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasReflection { get; }
Public ReadOnly Property HasReflection As Boolean
    Get
public:
property bool HasReflection {
    bool get ();
}
member HasReflection : bool with get

Property Value

Boolean
Exceptions
Exception | Condition
InvalidOperationException | Thrown when this transformation is not conformal and the reflection is undefined.
Remarks
Reflection transformation changes the handedness of a coordinate system.
See Also

Reference

Transform Class


Transform.Identity Property

TransformIdentity Property

The identity transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Transform Identity { get; }
Public Shared ReadOnly Property Identity As Transform
    Get
public:
static property Transform^ Identity {
    Transform^ get ();
}
static member Identity : Transform with get

Property Value

Transform
Remarks
The identity transformation does not change a point or a vector that it is applied to.
See Also

Reference

Transform Class


Transform.Inverse Property

TransformInverse Property

The inverse transformation of this transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Transform Inverse { get; }
Public ReadOnly Property Inverse As Transform
    Get
public:
property Transform^ Inverse {
    Transform^ get ();
}
member Inverse : Transform with get

Property Value

Transform
Exceptions
Exception | Condition
InvalidOperationException | Thrown when this transformation is not conformal or invertible.
Remarks
The transformation matrix A is invertible if there exists a transformation matrix B such that A*B = B*A = I (identity).
See Also

Reference

Transform Class


Transform.IsConformal Property

TransformIsConformal Property

The boolean value that indicates whether this transformation is conformal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsConformal { get; }
Public ReadOnly Property IsConformal As Boolean
    Get
public:
property bool IsConformal {
    bool get ();
}
member IsConformal : bool with get

Property Value

Boolean
Remarks
This property is true if this transformation can be decomposed as the product of a rigid-body motion, uniform scale and reflection. Such transformation preserves angles between vectors.
See Also

Reference

Transform Class


Transform.IsIdentity Property

TransformIsIdentity Property

The boolean value that indicates whether this transformation is an identity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsIdentity { get; }
Public ReadOnly Property IsIdentity As Boolean
    Get
public:
property bool IsIdentity {
    bool get ();
}
member IsIdentity : bool with get

Property Value

Boolean
Remarks
The identity transformation does not change a point or a vector that it is applied to.
See Also

Reference

Transform Class


Transform.IsTranslation Property

TransformIsTranslation Property

The boolean value that indicates whether this transformation is a translation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsTranslation { get; }
Public ReadOnly Property IsTranslation As Boolean
    Get
public:
property bool IsTranslation {
    bool get ();
}
member IsTranslation : bool with get

Property Value

Boolean
Remarks
This property is true if the only effect of transformation is translation. It checks that the basis of the transform is identity. The translation vector may be zero (which would make this an identity transformation) or nonzero (which would make this a non-trivial translation).
See Also

Reference

Transform Class


Transform.Origin Property

TransformOrigin Property

Defines the origin of the old coordinate system in the new coordinate system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Origin { get; set; }
Public Property Origin As XYZ
    Get
    Set
public:
property XYZ^ Origin {
    XYZ^ get ();
    void set (XYZ^ value);
}
member Origin : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the transform is internally marked as read-only.
Remarks
This corresponds to the fourth column vector of the conventional 3x4 matrix representation. Also, this is the translation component of the transformation.
See Also

Reference

Transform Class


Transform.Scale Property

TransformScale Property

The real number that represents the scale of the transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Scale { get; }
Public ReadOnly Property Scale As Double
    Get
public:
property double Scale {
    double get ();
}
member Scale : float with get

Property Value

Double
Exceptions
Exception | Condition
InvalidOperationException | Thrown when this transformation is not conformal and the scale is undefined.
Remarks
When the transformation is conformal and can be decomposed as the product of a rigid-body motion, uniform scale and reflection, this property returns the scale value of the uniform scale transformation.
See Also

Reference

Transform Class


Transform Methods

The Transform type exposes the following members.

Methods
 | Name | Description
Public method | AlmostEqual | Determines whether this transformation and the specified transformation are the same within the tolerance (1.0e-09).
 | CreateReflection | Creates a transform that represents a reflection across the given plane.
 | CreateRotation | Creates a transform that represents a rotation about the given axis at (0, 0, 0).
 | CreateRotationAtPoint | Creates a transform that represents a rotation about the given axis at the specified point.
 | CreateTranslation | Creates a transform that represents a translation via the specified vector.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Multiply | Multiplies this transformation by the specified transformation and returns the result.
Public method | OfPoint | Applies the transformation to the point and returns the result.
Public method | OfVector | Applies the transform to the vector
Public method | ScaleBasis | Scales the basis vectors of this transformation and returns the result.
Public method | ScaleBasisAndOrigin | Scales the basis vectors and the origin of this transformation and returns the result.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Transform Class


Transform.AlmostEqual Method

TransformAlmostEqual Method

Determines whether this transformation and the specified transformation are the same within the tolerance (1.0e-09).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AlmostEqual(
    Transform right
)
Public Function AlmostEqual (
    right As Transform
) As Boolean
public:
bool AlmostEqual(
    Transform^ right
)
member AlmostEqual :
        right : Transform -> bool

Parameters

right Transform
The transformation to compare with this transformation.

Return Value

Boolean
True if the two transformations are equal; otherwise, false.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the specified transformation is .
Remarks
The tolerance is applied memberwise for comparison.
See Also

Reference

Transform Class


Transform.CreateReflection Method

TransformCreateReflection Method

Creates a transform that represents a reflection across the given plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Transform CreateReflection(
    Plane plane
)
Public Shared Function CreateReflection (
    plane As Plane
) As Transform
public:
static Transform^ CreateReflection(
    Plane^ plane
)
static member CreateReflection :
        plane : Plane -> Transform

Parameters

plane Plane
The plane.

Return Value

Transform
The new transform.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was NULL
Example
C#
VB
C++
F#
Copy
private Transform Reflect(ReferencePlane refPlane)
{
    Transform mirTrans = Transform.CreateReflection(refPlane.GetPlane());

    return mirTrans;
}
Private Function Reflect(refPlane As ReferencePlane) As Transform
    Dim mirTrans As Transform = Transform.CreateReflection(refPlane.GetPlane())

    Return mirTrans
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Transform Class


Transform.CreateRotation Method

TransformCreateRotation Method

Creates a transform that represents a rotation about the given axis at (0, 0, 0).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Transform CreateRotation(
    XYZ axis,
    double angle
)
Public Shared Function CreateRotation (
    axis As XYZ,
    angle As Double
) As Transform
public:
static Transform^ CreateRotation(
    XYZ^ axis,
    double angle
)
static member CreateRotation :
        axis : XYZ *
        angle : float -> Transform

Parameters

axis XYZ
The rotation axis.
angle Double
The angle.

Return Value

Transform
The new transform.
Exceptions
Exception | Condition
ArgumentException | The given value for angle is not finite
ArgumentNullException | A non-optional argument was NULL
ArgumentOutOfRangeException | axis has zero length.
See Also

Reference

Transform Class


Transform.CreateRotationAtPoint Method

TransformCreateRotationAtPoint Method

Creates a transform that represents a rotation about the given axis at the specified point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Transform CreateRotationAtPoint(
    XYZ axis,
    double angle,
    XYZ origin
)
Public Shared Function CreateRotationAtPoint (
    axis As XYZ,
    angle As Double,
    origin As XYZ
) As Transform
public:
static Transform^ CreateRotationAtPoint(
    XYZ^ axis,
    double angle,
    XYZ^ origin
)
static member CreateRotationAtPoint :
        axis : XYZ *
        angle : float *
        origin : XYZ -> Transform

Parameters

axis XYZ
The rotation axis.
angle Double
The angle.
origin XYZ
The origin point.

Return Value

Transform
The new transform.
Exceptions
Exception | Condition
ArgumentException | The given value for angle is not finite
ArgumentNullException | A non-optional argument was NULL
ArgumentOutOfRangeException | axis has zero length.
See Also

Reference

Transform Class


Transform.CreateTranslation Method

TransformCreateTranslation Method

Creates a transform that represents a translation via the specified vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Transform CreateTranslation(
    XYZ vector
)
Public Shared Function CreateTranslation (
    vector As XYZ
) As Transform
public:
static Transform^ CreateTranslation(
    XYZ^ vector
)
static member CreateTranslation :
        vector : XYZ -> Transform

Parameters

vector XYZ
The translation vector.

Return Value

Transform
The new transform.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was NULL
See Also

Reference

Transform Class


Transform.Multiply Method

TransformMultiply Method

Multiplies this transformation by the specified transformation and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Transform Multiply(
    Transform right
)
Public Function Multiply (
    right As Transform
) As Transform
public:
Transform^ Multiply(
    Transform^ right
)
member Multiply :
        right : Transform -> Transform

Parameters

right Transform
The specified transformation.

Return Value

Transform
The transformation equal to the composition of the two transformations.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the handle of the specified transformation is .
Remarks
The combined transformation has the same effect as applying the right transformation first, and the left transformation, second. So, (T1(T2(p)) = (T1 * T2) (p).
See Also

Reference

Transform Class


Transform.OfPoint Method

TransformOfPoint Method

Applies the transformation to the point and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ OfPoint(
    XYZ point
)
Public Function OfPoint (
    point As XYZ
) As XYZ
public:
XYZ^ OfPoint(
    XYZ^ point
)
member OfPoint :
        point : XYZ -> XYZ

Parameters

point XYZ
The point to transform.

Return Value

XYZ
The transformed point.
Remarks
Transformation of a point is affected by the translational part of the transformation.
See Also

Reference

Transform Class


Transform.OfVector Method

TransformOfVector Method

Applies the transform to the vector

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ OfVector(
    XYZ vec
)
Public Function OfVector (
    vec As XYZ
) As XYZ
public:
XYZ^ OfVector(
    XYZ^ vec
)
member OfVector :
        vec : XYZ -> XYZ

Parameters

vec XYZ
The vector to be transformed

Return Value

XYZ
The new vector after transform
Remarks
Transformation of a vector is not affected by the translational part of the transformation.
See Also

Reference

Transform Class


Transform.ScaleBasis Method

TransformScaleBasis Method

Scales the basis vectors of this transformation and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Transform ScaleBasis(
    double scale
)
Public Function ScaleBasis (
    scale As Double
) As Transform
public:
Transform^ ScaleBasis(
    double scale
)
member ScaleBasis :
        scale : float -> Transform

Parameters

scale Double
The scale value.

Return Value

Transform
The transformation equal to the composition of the two transformations.
Exceptions
Exception | Condition
ArgumentException | Thrown when the specified value is an infinite number.
Remarks
The resulting transformation is equivalent to the application of the uniform scale and then this transformation, in this order.
See Also

Reference

Transform Class


Transform.ScaleBasisAndOrigin Method

TransformScaleBasisAndOrigin Method

Scales the basis vectors and the origin of this transformation and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Transform ScaleBasisAndOrigin(
    double scale
)
Public Function ScaleBasisAndOrigin (
    scale As Double
) As Transform
public:
Transform^ ScaleBasisAndOrigin(
    double scale
)
member ScaleBasisAndOrigin :
        scale : float -> Transform

Parameters

scale Double
The scale value.

Return Value

Transform
The transformation equal to the composition of the two transformations.
Exceptions
Exception | Condition
ArgumentException | Thrown when the specified value is an infinite number.
Remarks
The resulting transformation is equivalent to the application of this transformation and then the uniform scale, in this order.
See Also

Reference

Transform Class


Transform Operators

The Transform type exposes the following members.

Operators
Name | Description
Multiply(Transform, Transform) | Multiplies the two specified transforms.
Top
See Also

Reference

Transform Class


Transform.Multiply Operator

TransformMultiply Operator

Multiplies the two specified transforms.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Transform operator *(
    Transform left,
    Transform right
)
Public Shared Operator * (
    left As Transform,
    right As Transform
) As Transform
public:
static Transform^ operator *(
    Transform^ left,
    Transform^ right
)
static let inline (*)
        left : Transform *
        right : Transform  : Transform

Parameters

left Transform
The first transformation.
right Transform
The second transformation.

Return Value

Transform
The transformation equal to the composition of the two transformations.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the handle of the first or second transformation is .
Remarks
The combined transformation has the same effect as applying the right transformation first, and the left transformation, second. So, (T1(T2(p)) = (T1 * T2) (p).
See Also

Reference

Transform Class


Transform1D Class

An affine transform of 1D Euclidean space.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBTransform1D

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Transform1D : IDisposable
Public Class Transform1D
    Implements IDisposable
public ref class Transform1D : IDisposable
type Transform1D =
    class
        interface IDisposable
    end

The Transform1D type exposes the following members.

Constructors
 | Name | Description
Public method | Transform1D(Double) | Constructs the transformation by specifying the scale only.
Public method | Transform1D(Transform1D) | The copy constructor.
Public method | Transform1D(Double, Double) | Constructs the transformation by specifying the scale and the translation.
Top
Properties
 | Name | Description
Public property | Determinant | The determinant of this transformation.
Public property | IsIdentity | The boolean value that indicates whether this transformation is an identity.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Scale | The real number that represents the scale of this transformation.
Public property | Translation | The translational part of this transformation.
Top
Methods
 | Name | Description
Public method | AlmostEqual | Determines whether this transformation and the specified transformation are the same within the tolerance (1.0e-09).
Public method | Assign | Assigns values from the input transformation to this transformation.
Public method | Dispose | Releases all resources used by the Transform1D
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetInverse | Gets the inverse transformation of this transformation.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Multiply | Multiplies this transformation by the specified transformation and returns the result.
Public method | OfPoint | Applies the transformation to the 1-dimensional point and returns the result.
Public method | OfVector | Applies the transformation to the 1-dimensional vector (a "tangent vector" on the real line) and returns the result.
Public method | SetToIdentity | Set this TrfUV to the identity transform
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | TransformParameterDomain | Performs a transform of the parameter range defined by domain, and ensures that the domain is ordered correctly.
Top
Remarks
An affine transform is a linear transform plus a translation (which may be zero). 1D space is tranformed according to the following formula: t -> A*t + B where A and B are constants. Some functions only accept certain kinds of transform (e.g., rigid motion, conformal, non-singular, etc.).
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Transform1D Constructor

Overload List
 | Name | Description
Public method | Transform1D(Double) | Constructs the transformation by specifying the scale only.
Public method | Transform1D(Transform1D) | The copy constructor.
Public method | Transform1D(Double, Double) | Constructs the transformation by specifying the scale and the translation.
Top
See Also

Reference

Transform1D Class


Transform1D(Double) Constructor

Constructs the transformation by specifying the scale only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Transform1D(
    double scale
)
Public Sub New (
    scale As Double
)
public:
Transform1D(
    double scale
)
new :
        scale : float -> Transform1D

Parameters

scale Double
The scale of the transformation.
Remarks
The translation is set to zero. 1D space is tranformed according to the following formula: t --> scale*t + translation This constructor sets translation to zero.
See Also

Reference

Transform1D Class
Transform1D Overload


Transform1D(Transform1D) Constructor

The copy constructor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Transform1D(
    Transform1D other
)
Public Sub New (
    other As Transform1D
)
public:
Transform1D(
    Transform1D^ other
)
new :
        other : Transform1D -> Transform1D

Parameters

other Transform1D
The transformation to use as input.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

Transform1D Class
Transform1D Overload


Transform1D(Double, Double) Constructor

Constructs the transformation by specifying the scale and the translation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Transform1D(
    double scale,
    double translation
)
Public Sub New (
    scale As Double,
    translation As Double
)
public:
Transform1D(
    double scale,
    double translation
)
new :
        scale : float *
        translation : float -> Transform1D

Parameters

scale Double
The scale of the transformation.
translation Double
The translational part of the transformation.
Remarks
1D space is tranformed according to the following formula: t --> scale*t + translation
See Also

Reference

Transform1D Class
Transform1D Overload


Transform1D Properties

The Transform1D type exposes the following members.

Properties
 | Name | Description
Public property | Determinant | The determinant of this transformation.
Public property | IsIdentity | The boolean value that indicates whether this transformation is an identity.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Scale | The real number that represents the scale of this transformation.
Public property | Translation | The translational part of this transformation.
Top
See Also

Reference

Transform1D Class


Transform1D.Determinant Property

Transform1DDeterminant Property

The determinant of this transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Determinant { get; }
Public ReadOnly Property Determinant As Double
    Get
public:
property double Determinant {
    double get ();
}
member Determinant : float with get

Property Value

Double
See Also

Reference

Transform1D Class


Transform1D.IsIdentity Property

Transform1DIsIdentity Property

The boolean value that indicates whether this transformation is an identity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsIdentity { get; }
Public ReadOnly Property IsIdentity As Boolean
    Get
public:
property bool IsIdentity {
    bool get ();
}
member IsIdentity : bool with get

Property Value

Boolean
Remarks
The identity transformation does not change a point or a vector that it is applied to.
See Also

Reference

Transform1D Class


Transform1D.IsValidObject Property

Transform1DIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

Transform1D Class


Transform1D.Scale Property

Transform1DScale Property

The real number that represents the scale of this transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Scale { get; set; }
Public Property Scale As Double
    Get
    Set
public:
property double Scale {
    double get ();
    void set (double value);
}
member Scale : float with get, set

Property Value

Double
See Also

Reference

Transform1D Class


Transform1D.Translation Property

Transform1DTranslation Property

The translational part of this transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Translation { get; set; }
Public Property Translation As Double
    Get
    Set
public:
property double Translation {
    double get ();
    void set (double value);
}
member Translation : float with get, set

Property Value

Double
See Also

Reference

Transform1D Class


Transform1D Methods

The Transform1D type exposes the following members.

Methods
 | Name | Description
Public method | AlmostEqual | Determines whether this transformation and the specified transformation are the same within the tolerance (1.0e-09).
Public method | Assign | Assigns values from the input transformation to this transformation.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetInverse | Gets the inverse transformation of this transformation.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Multiply | Multiplies this transformation by the specified transformation and returns the result.
Public method | OfPoint | Applies the transformation to the 1-dimensional point and returns the result.
Public method | OfVector | Applies the transformation to the 1-dimensional vector (a "tangent vector" on the real line) and returns the result.
Public method | SetToIdentity | Set this TrfUV to the identity transform
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | TransformParameterDomain | Performs a transform of the parameter range defined by domain, and ensures that the domain is ordered correctly.
Top
See Also

Reference

Transform1D Class


Transform1D.AlmostEqual Method

Transform1DAlmostEqual Method

Determines whether this transformation and the specified transformation are the same within the tolerance (1.0e-09).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AlmostEqual(
    Transform1D right
)
Public Function AlmostEqual (
    right As Transform1D
) As Boolean
public:
bool AlmostEqual(
    Transform1D^ right
)
member AlmostEqual :
        right : Transform1D -> bool

Parameters

right Transform1D
The transformation to compare with this transformation.

Return Value

Boolean
True if the two transformations are equal, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
The tolerance is applied memberwise for comparison.
See Also

Reference

Transform1D Class


Transform1D.Assign Method

Transform1DAssign Method

Assigns values from the input transformation to this transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Assign(
    Transform1D from
)
Public Sub Assign (
    from As Transform1D
)
public:
void Assign(
    Transform1D^ from
)
member Assign :
        from : Transform1D -> unit

Parameters

from Transform1D
The transformation to use as input.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

Transform1D Class


Transform1D.Dispose Method

Transform1DDispose Method

Releases all resources used by the Transform1D

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

Transform1D Class


Transform1D.GetInverse Method

Transform1DGetInverse Method

Gets the inverse transformation of this transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Transform1D GetInverse()
Public Function GetInverse As Transform1D
public:
Transform1D^ GetInverse()
member GetInverse : unit -> Transform1D

Return Value

Transform1D
Exceptions
Exception | Condition
InvalidOperationException | This transformation is singular.
Remarks
The transformation matrix A is invertible if there exists a transformation matrix B such that A*B = B*A = I (identity).
See Also

Reference

Transform1D Class


Transform1D.Multiply Method

Transform1DMultiply Method

Multiplies this transformation by the specified transformation and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Transform1D Multiply(
    Transform1D right
)
Public Function Multiply (
    right As Transform1D
) As Transform1D
public:
Transform1D^ Multiply(
    Transform1D^ right
)
member Multiply :
        right : Transform1D -> Transform1D

Parameters

right Transform1D
The input transformation.

Return Value

Transform1D
The transformation equal to the composition of the two transformations.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
The combined transformation has the same effect as applying the input transformation first, and this transformation, second. So, (T1(T2(p)) = (T1 * T2) (p).
See Also

Reference

Transform1D Class


Transform1D.OfPoint Method

Transform1DOfPoint Method

Applies the transformation to the 1-dimensional point and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double OfPoint(
    double point
)
Public Function OfPoint (
    point As Double
) As Double
public:
double OfPoint(
    double point
)
member OfPoint :
        point : float -> float

Parameters

point Double
The point to transform.

Return Value

Double
The transformed point.
Remarks
Transformation of a point is affected by the translational part of the transformation.
See Also

Reference

Transform1D Class


Transform1D.OfVector Method

Transform1DOfVector Method

Applies the transformation to the 1-dimensional vector (a "tangent vector" on the real line) and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double OfVector(
    double vector
)
Public Function OfVector (
    vector As Double
) As Double
public:
double OfVector(
    double vector
)
member OfVector :
        vector : float -> float

Parameters

vector Double
The vector to transform.

Return Value

Double
The transformed vector.
Remarks
Transformation of a vector is not affected by the translational part of the transformation.
See Also

Reference

Transform1D Class


Transform1D.SetToIdentity Method

Transform1DSetToIdentity Method

Set this TrfUV to the identity transform

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Transform1D SetToIdentity()
Public Function SetToIdentity As Transform1D
public:
Transform1D^ SetToIdentity()
member SetToIdentity : unit -> Transform1D

Return Value

Transform1D
Returns a pointer to "this" Transform1D.
See Also

Reference

Transform1D Class


Transform1D.TransformParameterDomain Method

Transform1DTransformParameterDomain Method

Performs a transform of the parameter range defined by domain, and ensures that the domain is ordered correctly.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<double> TransformParameterDomain(
    double domainStart,
    double domainEnd
)
Public Function TransformParameterDomain (
    domainStart As Double,
    domainEnd As Double
) As IList(Of Double)
public:
IList<double>^ TransformParameterDomain(
    double domainStart,
    double domainEnd
)
member TransformParameterDomain :
        domainStart : float *
        domainEnd : float -> IList<float>

Parameters

domainStart Double
The original parameter domain start.
domainEnd Double
The original parameter domain end.

Return Value

IList Double
Remarks
If the domain is empty it is unchanged.
See Also

Reference

Transform1D Class


Transform2D Class

An affine transform of 2D Euclidean space.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBTransform2D

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Transform2D : IDisposable
Public Class Transform2D
    Implements IDisposable
public ref class Transform2D : IDisposable
type Transform2D =
    class
        interface IDisposable
    end

The Transform2D type exposes the following members.

Constructors
 | Name | Description
Public method | Transform2D(Transform2D) | The copy constructor.
Public method | Transform2D(UV, UV, UV) | Constructs the transformation by specifying the vectors and the origin.
Top
Properties
 | Name | Description
Public property | BasisU | The image of (1, 0) under OfVector(UV).
Public property | BasisV | The image of (0, 1) under OfVector(UV).
Public property | Determinant | The determinant of this transformation.
Public property | HasReflection | The boolean value that indicates whether this transformation produces reflection (i.e., is orientation-reversing).
Public property | IsConformal | The boolean value that indicates whether this transformation is conformal.
Public property | IsIdentity | The boolean value that indicates whether this transformation is an identity.
Public property | IsTranslation | The boolean value that indicates whether this transformation is a translation.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Origin | The image of (0, 0) under OfPoint(UV). This defines the translational part of the transform.
Public property | Scale | The real number that represents the scale of the conformal transformation.
Top
Methods
 | Name | Description
Public method | AlmostEqual | Determines whether this transformation and the specified transformation are the same within the tolerance (1.0e-09).
Public method | Assign | Assigns values from the input transformation to this transformation.
 | CreateIdentity | Creates the identity transformation.
Public method | Dispose | Releases all resources used by the Transform2D
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetInverse | Gets the inverse transformation of this transformation.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Multiply | Multiplies this transformation by the specified transformation and returns the result.
Public method | OfPoint | Applies the transformation to the point and returns the result.
Public method | OfVector | Applies the transformation to the vector and returns the result.
Public method | PostScale | Scales both the linear and translational parts of this transformation and returns the result.
Public method | PreScale | Scales the linear part of this transformation and returns the result.
Public method | SetToIdentity | Set this TrfUV to the identity transform.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | TransformUVDomainIfPossible | Transforms an envelope (BoundingBoxUV) for one surface to an envelope for a coincident but differently parameterized surface.
Top
Remarks
An affine transform is a linear transform plus a translation (which may be zero). Some functions only accept certain kinds of transform (e.g., rigid motion, conformal, non-singular, etc.).
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Transform2D Constructor

Overload List
 | Name | Description
Public method | Transform2D(Transform2D) | The copy constructor.
Public method | Transform2D(UV, UV, UV) | Constructs the transformation by specifying the vectors and the origin.
Top
See Also

Reference

Transform2D Class


Transform2D(Transform2D) Constructor

The copy constructor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Transform2D(
    Transform2D other
)
Public Sub New (
    other As Transform2D
)
public:
Transform2D(
    Transform2D^ other
)
new :
        other : Transform2D -> Transform2D

Parameters

other Transform2D
The transformation to use as input.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

Transform2D Class
Transform2D Overload


Transform2D(UV, UV, UV) Constructor

Constructs the transformation by specifying the vectors and the origin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Transform2D(
    UV uVec,
    UV vVec,
    UV origin
)
Public Sub New (
    uVec As UV,
    vVec As UV,
    origin As UV
)
public:
Transform2D(
    UV^ uVec,
    UV^ vVec,
    UV^ origin
)
new :
        uVec : UV *
        vVec : UV *
        origin : UV -> Transform2D

Parameters

uVec UV
The image of (1, 0) under OfVector(UV).
vVec UV
The image of (0, 1) under OfVector(UV).
origin UV
The image of (0, 0) under OfPoint(UV). This defines the translational part of the transform.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

Transform2D Class
Transform2D Overload


Transform2D Properties

The Transform2D type exposes the following members.

Properties
 | Name | Description
Public property | BasisU | The image of (1, 0) under OfVector(UV).
Public property | BasisV | The image of (0, 1) under OfVector(UV).
Public property | Determinant | The determinant of this transformation.
Public property | HasReflection | The boolean value that indicates whether this transformation produces reflection (i.e., is orientation-reversing).
Public property | IsConformal | The boolean value that indicates whether this transformation is conformal.
Public property | IsIdentity | The boolean value that indicates whether this transformation is an identity.
Public property | IsTranslation | The boolean value that indicates whether this transformation is a translation.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Origin | The image of (0, 0) under OfPoint(UV). This defines the translational part of the transform.
Public property | Scale | The real number that represents the scale of the conformal transformation.
Top
See Also

Reference

Transform2D Class


Transform2D.BasisU Property

Transform2DBasisU Property

The image of (1, 0) under OfVector(UV).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public UV BasisU { get; set; }
Public Property BasisU As UV
    Get
    Set
public:
property UV^ BasisU {
    UV^ get ();
    void set (UV^ value);
}
member BasisU : UV with get, set

Property Value

UV
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

Transform2D Class


Transform2D.BasisV Property

Transform2DBasisV Property

The image of (0, 1) under OfVector(UV).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public UV BasisV { get; set; }
Public Property BasisV As UV
    Get
    Set
public:
property UV^ BasisV {
    UV^ get ();
    void set (UV^ value);
}
member BasisV : UV with get, set

Property Value

UV
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

Transform2D Class


Transform2D.Determinant Property

Transform2DDeterminant Property

The determinant of this transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Determinant { get; }
Public ReadOnly Property Determinant As Double
    Get
public:
property double Determinant {
    double get ();
}
member Determinant : float with get

Property Value

Double
Remarks
The geometric meaning of a determinant is as the scale factor for volume when applied as linear transformation.
See Also

Reference

Transform2D Class


Transform2D.HasReflection Property

Transform2DHasReflection Property

The boolean value that indicates whether this transformation produces reflection (i.e., is orientation-reversing).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasReflection { get; }
Public ReadOnly Property HasReflection As Boolean
    Get
public:
property bool HasReflection {
    bool get ();
}
member HasReflection : bool with get

Property Value

Boolean
Exceptions
Exception | Condition
InvalidOperationException | This transformation is singular and the reflection is undefined.
Remarks
Reflection transformation changes the handedness of a coordinate system.
See Also

Reference

Transform2D Class


Transform2D.IsConformal Property

Transform2DIsConformal Property

The boolean value that indicates whether this transformation is conformal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsConformal { get; }
Public ReadOnly Property IsConformal As Boolean
    Get
public:
property bool IsConformal {
    bool get ();
}
member IsConformal : bool with get

Property Value

Boolean
Remarks
This property is true if this transformation can be decomposed as the product of a rigid-body motion, uniform scale and reflection. Such transformation preserves angles between vectors.
See Also

Reference

Transform2D Class


Transform2D.IsIdentity Property

Transform2DIsIdentity Property

The boolean value that indicates whether this transformation is an identity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsIdentity { get; }
Public ReadOnly Property IsIdentity As Boolean
    Get
public:
property bool IsIdentity {
    bool get ();
}
member IsIdentity : bool with get

Property Value

Boolean
Remarks
The identity transformation does not change a point or a vector that it is applied to.
See Also

Reference

Transform2D Class


Transform2D.IsTranslation Property

Transform2DIsTranslation Property

The boolean value that indicates whether this transformation is a translation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsTranslation { get; }
Public ReadOnly Property IsTranslation As Boolean
    Get
public:
property bool IsTranslation {
    bool get ();
}
member IsTranslation : bool with get

Property Value

Boolean
Remarks
This property is true if the only effect of transformation is translation. It checks that the linear part of the transform is identity. The translation vector may be zero (which would make this an identity transformation) or nonzero (which would make this a non-trivial translation).
See Also

Reference

Transform2D Class


Transform2D.IsValidObject Property

Transform2DIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

Transform2D Class


Transform2D.Origin Property

Transform2DOrigin Property

The image of (0, 0) under OfPoint(UV). This defines the translational part of the transform.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public UV Origin { get; set; }
Public Property Origin As UV
    Get
    Set
public:
property UV^ Origin {
    UV^ get ();
    void set (UV^ value);
}
member Origin : UV with get, set

Property Value

UV
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

Transform2D Class


Transform2D.Scale Property

Transform2DScale Property

The real number that represents the scale of the conformal transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Scale { get; }
Public ReadOnly Property Scale As Double
    Get
public:
property double Scale {
    double get ();
}
member Scale : float with get

Property Value

Double
Exceptions
Exception | Condition
InvalidOperationException | This transformation is not conformal and the scale is undefined.
Remarks
When the transformation is conformal and can be decomposed as the product of a rigid-body motion, uniform scale and reflection, this property returns the scale value of the uniform scale transformation.
See Also

Reference

Transform2D Class


Transform2D Methods

The Transform2D type exposes the following members.

Methods
 | Name | Description
Public method | AlmostEqual | Determines whether this transformation and the specified transformation are the same within the tolerance (1.0e-09).
Public method | Assign | Assigns values from the input transformation to this transformation.
 | CreateIdentity | Creates the identity transformation.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetInverse | Gets the inverse transformation of this transformation.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Multiply | Multiplies this transformation by the specified transformation and returns the result.
Public method | OfPoint | Applies the transformation to the point and returns the result.
Public method | OfVector | Applies the transformation to the vector and returns the result.
Public method | PostScale | Scales both the linear and translational parts of this transformation and returns the result.
Public method | PreScale | Scales the linear part of this transformation and returns the result.
Public method | SetToIdentity | Set this TrfUV to the identity transform.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | TransformUVDomainIfPossible | Transforms an envelope (BoundingBoxUV) for one surface to an envelope for a coincident but differently parameterized surface.
Top
See Also

Reference

Transform2D Class


Transform2D.AlmostEqual Method

Transform2DAlmostEqual Method

Determines whether this transformation and the specified transformation are the same within the tolerance (1.0e-09).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AlmostEqual(
    Transform2D right
)
Public Function AlmostEqual (
    right As Transform2D
) As Boolean
public:
bool AlmostEqual(
    Transform2D^ right
)
member AlmostEqual :
        right : Transform2D -> bool

Parameters

right Transform2D
The transformation to compare with this transformation.

Return Value

Boolean
True if the two transformations are equal, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
The tolerance is applied memberwise for comparison.
See Also

Reference

Transform2D Class


Transform2D.Assign Method

Transform2DAssign Method

Assigns values from the input transformation to this transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Assign(
    Transform2D from
)
Public Sub Assign (
    from As Transform2D
)
public:
void Assign(
    Transform2D^ from
)
member Assign :
        from : Transform2D -> unit

Parameters

from Transform2D
The transformation to use as input.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

Transform2D Class


Transform2D.CreateIdentity Method

Transform2DCreateIdentity Method

Creates the identity transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Transform2D CreateIdentity()
Public Shared Function CreateIdentity As Transform2D
public:
static Transform2D^ CreateIdentity()
static member CreateIdentity : unit -> Transform2D

Return Value

Transform2D
The identity transformation.
Remarks
The identity transformation does not change a point or a vector that it is applied to.
See Also

Reference

Transform2D Class


Transform2D.Dispose Method

Transform2DDispose Method

Releases all resources used by the Transform2D

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

Transform2D Class


Transform2D.GetInverse Method

Transform2DGetInverse Method

Gets the inverse transformation of this transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Transform2D GetInverse()
Public Function GetInverse As Transform2D
public:
Transform2D^ GetInverse()
member GetInverse : unit -> Transform2D

Return Value

Transform2D
Exceptions
Exception | Condition
InvalidOperationException | This transformation is not conformal or invertible.
Remarks
The transformation matrix A is invertible if there exists a transformation matrix B such that A*B = B*A = I (identity).
See Also

Reference

Transform2D Class


Transform2D.Multiply Method

Transform2DMultiply Method

Multiplies this transformation by the specified transformation and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Transform2D Multiply(
    Transform2D right
)
Public Function Multiply (
    right As Transform2D
) As Transform2D
public:
Transform2D^ Multiply(
    Transform2D^ right
)
member Multiply :
        right : Transform2D -> Transform2D

Parameters

right Transform2D

Return Value

Transform2D
The transformation equal to the composition of the two transformations.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
The combined transformation has the same effect as applying the right transformation first, and this transformation, second. So, denoting this transform by T1 and the right transform by T2, (T1(T2(p)) = (T1 * T2) (p).
See Also

Reference

Transform2D Class


Transform2D.OfPoint Method

Transform2DOfPoint Method

Applies the transformation to the point and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public UV OfPoint(
    UV point
)
Public Function OfPoint (
    point As UV
) As UV
public:
UV^ OfPoint(
    UV^ point
)
member OfPoint :
        point : UV -> UV

Parameters

point UV
The point to transform.

Return Value

UV
The transformed point.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Transformation of a point is affected by the translational part of the transformation.
See Also

Reference

Transform2D Class


Transform2D.OfVector Method

Transform2DOfVector Method

Applies the transformation to the vector and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public UV OfVector(
    UV vector
)
Public Function OfVector (
    vector As UV
) As UV
public:
UV^ OfVector(
    UV^ vector
)
member OfVector :
        vector : UV -> UV

Parameters

vector UV
The vector to transform.

Return Value

UV
The transformed vector.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Transformation of a vector is not affected by the translational part of the transformation.
See Also

Reference

Transform2D Class


Transform2D.PostScale Method

Transform2DPostScale Method

Scales both the linear and translational parts of this transformation and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Transform2D PostScale(
    double scale
)
Public Function PostScale (
    scale As Double
) As Transform2D
public:
Transform2D^ PostScale(
    double scale
)
member PostScale :
        scale : float -> Transform2D

Parameters

scale Double
The scale value.

Return Value

Transform2D
Returns a pointer to "this" Transform2D.
Remarks
The resulting transformation is equivalent to the application of this transformation and then the uniform scale, in this order.
See Also

Reference

Transform2D Class


Transform2D.PreScale Method

Transform2DPreScale Method

Scales the linear part of this transformation and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Transform2D PreScale(
    double scale
)
Public Function PreScale (
    scale As Double
) As Transform2D
public:
Transform2D^ PreScale(
    double scale
)
member PreScale :
        scale : float -> Transform2D

Parameters

scale Double
The scale value.

Return Value

Transform2D
Returns a pointer to "this" Transform2D.
Remarks
The resulting transformation is equivalent to the application of the uniform scale and then this transformation, in this order.
See Also

Reference

Transform2D Class


Transform2D.SetToIdentity Method

Transform2DSetToIdentity Method

Set this TrfUV to the identity transform.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Transform2D SetToIdentity()
Public Function SetToIdentity As Transform2D
public:
Transform2D^ SetToIdentity()
member SetToIdentity : unit -> Transform2D

Return Value

Transform2D
Returns a pointer to "this" Transform2D.
See Also

Reference

Transform2D Class


Transform2D.TransformUVDomainIfPossible Method

Transform2DTransformUVDomainIfPossible Method

Transforms an envelope (BoundingBoxUV) for one surface to an envelope for a coincident but differently parameterized surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BoundingBoxUV TransformUVDomainIfPossible(
    BoundingBoxUV uvDomain
)
Public Function TransformUVDomainIfPossible (
    uvDomain As BoundingBoxUV
) As BoundingBoxUV
public:
BoundingBoxUV^ TransformUVDomainIfPossible(
    BoundingBoxUV^ uvDomain
)
member TransformUVDomainIfPossible :
        uvDomain : BoundingBoxUV -> BoundingBoxUV

Parameters

uvDomain BoundingBoxUV
The original surface envelope.

Return Value

BoundingBoxUV
If successful a new BoundingBoxUV transformed surface envelope, otherwise .
Exceptions
Exception | Condition
ArgumentException | uvDomain is not set.
ArgumentNullException | A non-optional argument was null
Remarks
This method succeeds in the case when the uv-parameter transform between the surfaces has a simple form, that commonly occurs for analytic surfaces, such that the image of the input envelope under the transform is itself a rectangular region aligned with the UV coordinate axes.
See Also

Reference

Transform2D Class


TransformWithBoundary Class

This class contains the transform from model space to projection space for a view and the boundary in model space in which the transform is valid.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBTransformWithBoundary

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TransformWithBoundary : IDisposable
Public Class TransformWithBoundary
    Implements IDisposable
public ref class TransformWithBoundary : IDisposable
type TransformWithBoundary =
    class
        interface IDisposable
    end

The TransformWithBoundary type exposes the following members.

Constructors
 | Name | Description
Public method | TransformWithBoundary | Constructs a new copy of the input TransformWithBoundary object.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the TransformWithBoundary
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBoundary | Returns the boundary for the model space to view projection space transform.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetModelToProjectionTransform | Gets the model space to view projection space transform.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

Use the model-to-projection transform returned by GetModelToProjectionTransform to transform model points to the view's projection space. The model-to-projection transform is only valid for points in 3D model space that that can be seen through the 2D boundary returned by GetBoundary, when looking in the direction of [!:View.ViewDirection].

For views that are placed on sheets, you can combine the View's model-to-projection transform and the Viewport's projection-to-sheet transform to transform model points to sheet space:

sheetXYZ = projectionToSheetTransform * modelToProjectionTransform * modelXYZ

Model space is the global 3D coordinate space in which the 3D geometry of the model lives.

View projection space is the 3D Euclidean space with a coordinate system such that X and Y are horizontal and vertical directions in the view projection plane and Z is the cross product of X and Y. Distances in the projection space are the same as would be measured on paper if the view is printed without additional scaling.

Sheet space is the coordinate space of one sheet. This is the space in which viewports and titleblocks are arranged on the sheet.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TransformWithBoundary Constructor

Constructs a new copy of the input TransformWithBoundary object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TransformWithBoundary(
    TransformWithBoundary other
)
Public Sub New (
    other As TransformWithBoundary
)
public:
TransformWithBoundary(
    TransformWithBoundary^ other
)
new :
        other : TransformWithBoundary -> TransformWithBoundary

Parameters

other TransformWithBoundary
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

TransformWithBoundary Class


TransformWithBoundary Properties

The TransformWithBoundary type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

TransformWithBoundary Class


TransformWithBoundary.IsValidObject Property

TransformWithBoundaryIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

TransformWithBoundary Class


TransformWithBoundary Methods

The TransformWithBoundary type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBoundary | Returns the boundary for the model space to view projection space transform.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetModelToProjectionTransform | Gets the model space to view projection space transform.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

TransformWithBoundary Class


TransformWithBoundary.Dispose Method

TransformWithBoundaryDispose Method

Releases all resources used by the TransformWithBoundary

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

TransformWithBoundary Class


TransformWithBoundary.GetBoundary Method

TransformWithBoundaryGetBoundary Method

Returns the boundary for the model space to view projection space transform.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurveLoop GetBoundary()
Public Function GetBoundary As CurveLoop
public:
CurveLoop^ GetBoundary()
member GetBoundary : unit -> CurveLoop

Return Value

CurveLoop
A closed loop in model space representing the region of model space to which the model space to view projection space transform applies.
Remarks

Before you transform a model point to view projection space using the transform returned by GetModelToProjectionTransform, test to make sure the model point is visible through this 2D boundary. The model space to view projection space transform is only valid for points in 3D model space that can be seen through the 2D boundary, when looking in the direction of [!:View.ViewDirection].

The boundary is one enclosed region of the view's crop.

For uncropped views 'null' is returned.

For cropped views that do not have split crop regions, the boundary is the shape of the view crop. Typically the boundary is rectangular, but more complex shapes are supported.

For cropped views that have split crop regions, the boundary is one rectangular region of the split view crop.

Even though the boundary represents the view crop - a 2D polygon drawn on the view's cut plane - any point in 3D model space that can be seen through the boundary when looking in the direction of the view (see [!:View.ViewDirection]) is considered to be inside the boundary and can be transformed using the model space to view projection space transform returned by GetModelToProjectionTransform. For example, if the shape of the CurveLoop is a circle, then there is an infinite cylinder in 3D model space and any point inside that cylinder can be transformed with the model space to view projection space transform.

To test if a point in 3D model space is within the boundary, first project the point and the CurveLoop onto a plane which is perpendicular to the view direction. Then use a point-in-polygon algorithm to check if the projected point is inside the polygon described by the CurveLoop.

It is guaranteed that the boundary CurveLoop lies on a plane which is perpendicular to [!:View.ViewDirection] and that the CurveLoop does not self-intersect and is closed. It is also guaranteed that the boundaries of different TransformWithBoundary regions of the same view don't overlap with each other.

See Also

Reference

TransformWithBoundary Class


TransformWithBoundary.GetModelToProjectionTransform Method

TransformWithBoundaryGetModelToProjectionTransform Method

Gets the model space to view projection space transform.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Transform GetModelToProjectionTransform()
Public Function GetModelToProjectionTransform As Transform
public:
Transform^ GetModelToProjectionTransform()
member GetModelToProjectionTransform : unit -> Transform

Return Value

Transform
The model space to view projection space transformation.
Remarks

The transform can be used to transform points from model space to view projection space.

Model space is the global 3D coordinate space in which the 3D geometry of the model lives.

View projection space is the 3D Euclidean space with a coordinate system such that X and Y are horizontal and vertical directions in the view projection plane and Z is the cross product of X and Y. Distances in the projection space are the same as would be measured on paper if the view is printed without additional scaling.

For uncropped views all model space points can be transformed to projection space using the this transform.

For cropped views only model points which lie inside the boundary returned by GetBoundary should be transformed to projection space using this transform.

See Also

Reference

TransformWithBoundary Class


TransmissionData Class

A class representing information on all external file references in a document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBTransmissionData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TransmissionData : IDisposable
Public Class TransmissionData
    Implements IDisposable
public ref class TransmissionData : IDisposable
type TransmissionData =
    class
        interface IDisposable
    end

The TransmissionData type exposes the following members.

Constructors
 | Name | Description
Public method | TransmissionData | Constructs a TransmissionData from another TransmissionData
Top
Properties
 | Name | Description
Public property | IsTransmitted | Determines whether this file has been transmitted or not.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | UserData | A string which users can store notes in.
Public property | Version | The format version for TransmissionData
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the TransmissionData
 | DocumentIsNotTransmitted | Determines whether the document at a given file location is not transmitted.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAllExternalFileReferenceIds | Gets the ids of all ExternalFileReferences.
Public method | GetDesiredReferenceData | Gets the ExternalFileReference representing path and load status information to be used the next time this TransmissionData's document is loaded.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLastSavedReferenceData | Gets the ExternalFileReference representing path and load status information concerning the most recent time this TransmissionData's document was opened.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | IsDocumentTransmitted | Determines whether the document at a given file location is transmitted.
 | ReadTransmissionData | Reads the TransmissionData associated with the file at the given location.
Public method | SetDesiredReferenceData | Sets the ExternalFileReference information which Revit should use the next time it opens the document which this TransmissionData belongs to.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
 | WriteTransmissionData | Writes the given TransmissionData into the Revit file at the given location.
Top
Remarks

TransmissionData stores information on both the previous state and requested state of an external file reference. This means that it stores the load state and path of the reference from the most recent time this TransmissionData's document was opened. It also stores load state and path information for what Revit should do the next time the document is opened.

As such, TransmissionData can be used to perform operations on external file references without having to open the entire associated Revit document. The methods ReadTransmissionData and WriteTransmissionData can be used to obtain information about external references, or to change that information. For example, calling WriteTransmissionData with a TransmissionData object which has had all references set to LinkedFileStatus.Unloaded would cause no references to be loaded upon next opening the document.

TransmissionData cannot add or remove references to external files. If, on file open, Revit discovers information in the TransmissionData which does not correspond to an existing external file reference, the information will be ignored on file load.

The TransmissionData for a document does not contain information about references which come from external servers. TransmissionData only contains references to local files or Revit links on Revit Server. TransmissionData cannot be used to change a reference from a local file reference to an external server reference.

Note that TransmissionData objects must be set to "transmitted" for the requested reference data to be meaningful. Revit ignores the TransmissionData for non-transmitted files. Marking a file as transmitted has other effects - workshared files are opened as detached from the central model, and creation of new local files is prohibited, until the file is in its final location and the file has been marked as no longer transmitted.

Example
C#
VB
C++
F#
Copy
void UnloadRevitLinks(ModelPath location)
///  This method will set all Revit links to be unloaded the next time the document at the given location is opened.
///  The TransmissionData for a given document only contains top-level Revit links, not nested links.
///  However, nested links will be unloaded if their parent links are unloaded, so this function only needs to look at the document's immediate links.
{
   // access transmission data in the given Revit file
   TransmissionData transData = TransmissionData.ReadTransmissionData(location);

   if (transData != null)
   {
      // collect all (immediate) external references in the model
      ICollection<ElementId> externalReferences = transData.GetAllExternalFileReferenceIds();

      // find every reference that is a link
      foreach (ElementId refId in externalReferences)
      {
         ExternalFileReference extRef = transData.GetLastSavedReferenceData(refId);

         if (extRef.ExternalFileReferenceType == ExternalFileReferenceType.RevitLink)
         {
            // we do not want to change neither the path nor the path-type
            // we only want the links to be unloaded (shouldLoad = false)
            transData.SetDesiredReferenceData(refId, extRef.GetPath(), extRef.PathType, false);
         }
      }

      // make sure the IsTransmitted property is set
      transData.IsTransmitted = true;

      // modified transmission data must be saved back to the model
      TransmissionData.WriteTransmissionData(location, transData);
   }
   else
   {
      Autodesk.Revit.UI.TaskDialog.Show("Unload Links", "The document does not have any transmission data");
   }
}
Private Sub UnloadRevitLinks(location As ModelPath)
    '  This method will set all Revit links to be unloaded the next time the document at the given location is opened.
    '  The TransmissionData for a given document only contains top-level Revit links, not nested links.
    '  However, nested links will be unloaded if their parent links are unloaded, so this function only needs to look at the document's immediate links.
    ' access transmission data in the given Revit file
    Dim transData As TransmissionData = TransmissionData.ReadTransmissionData(location)

    If transData IsNot Nothing Then
        ' collect all (immediate) external references in the model
        Dim externalReferences As ICollection(Of ElementId) = transData.GetAllExternalFileReferenceIds()

        ' find every reference that is a link
        For Each refId As ElementId In externalReferences
            Dim extRef As ExternalFileReference = transData.GetLastSavedReferenceData(refId)

            If extRef.ExternalFileReferenceType = ExternalFileReferenceType.RevitLink Then
                ' we do not want to change neither the path nor the path-type
                ' we only want the links to be unloaded (shouldLoad = false)
                transData.SetDesiredReferenceData(refId, extRef.GetPath(), extRef.PathType, False)
            End If
        Next

        ' make sure the IsTransmitted property is set
        transData.IsTransmitted = True

        ' modified transmission data must be saved back to the model
        TransmissionData.WriteTransmissionData(location, transData)
    Else
        Autodesk.Revit.UI.TaskDialog.Show("Unload Links", "The document does not have any transmission data")
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TransmissionData Constructor

Constructs a TransmissionData from another TransmissionData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TransmissionData(
    TransmissionData other
)
Public Sub New (
    other As TransmissionData
)
public:
TransmissionData(
    TransmissionData^ other
)
new :
        other : TransmissionData -> TransmissionData

Parameters

other TransmissionData
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

TransmissionData Class


TransmissionData Properties

The TransmissionData type exposes the following members.

Properties
 | Name | Description
Public property | IsTransmitted | Determines whether this file has been transmitted or not.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | UserData | A string which users can store notes in.
Public property | Version | The format version for TransmissionData
Top
See Also

Reference

TransmissionData Class


TransmissionData.IsTransmitted Property

TransmissionDataIsTransmitted Property

Determines whether this file has been transmitted or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsTransmitted { get; set; }
Public Property IsTransmitted As Boolean
    Get
    Set
public:
property bool IsTransmitted {
    bool get ();
    void set (bool value);
}
member IsTransmitted : bool with get, set

Property Value

Boolean
Remarks
"Transmitted" files have been moved from one place to another and are considered to be in a not-final state. Revit will read the TransmissionData on file open and overwrite any data stored in the external file reference elements themselves.
See Also

Reference

TransmissionData Class


TransmissionData.IsValidObject Property

TransmissionDataIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

TransmissionData Class


TransmissionData.UserData Property

TransmissionDataUserData Property

A string which users can store notes in.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string UserData { get; set; }
Public Property UserData As String
    Get
    Set
public:
property String^ UserData {
    String^ get ();
    void set (String^ value);
}
member UserData : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

TransmissionData Class


TransmissionData.Version Property

TransmissionDataVersion Property

The format version for TransmissionData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Version { get; }
Public ReadOnly Property Version As Integer
    Get
public:
property int Version {
    int get ();
}
member Version : int with get

Property Value

Int32
See Also

Reference

TransmissionData Class


TransmissionData Methods

The TransmissionData type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
 | DocumentIsNotTransmitted | Determines whether the document at a given file location is not transmitted.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAllExternalFileReferenceIds | Gets the ids of all ExternalFileReferences.
Public method | GetDesiredReferenceData | Gets the ExternalFileReference representing path and load status information to be used the next time this TransmissionData's document is loaded.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLastSavedReferenceData | Gets the ExternalFileReference representing path and load status information concerning the most recent time this TransmissionData's document was opened.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | IsDocumentTransmitted | Determines whether the document at a given file location is transmitted.
 | ReadTransmissionData | Reads the TransmissionData associated with the file at the given location.
Public method | SetDesiredReferenceData | Sets the ExternalFileReference information which Revit should use the next time it opens the document which this TransmissionData belongs to.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
 | WriteTransmissionData | Writes the given TransmissionData into the Revit file at the given location.
Top
See Also

Reference

TransmissionData Class


TransmissionData.Dispose Method

TransmissionDataDispose Method

Releases all resources used by the TransmissionData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

TransmissionData Class


TransmissionData.DocumentIsNotTransmitted Method

TransmissionDataDocumentIsNotTransmitted Method

Determines whether the document at a given file location is not transmitted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool DocumentIsNotTransmitted(
    ModelPath filePath
)
Public Shared Function DocumentIsNotTransmitted (
    filePath As ModelPath
) As Boolean
public:
static bool DocumentIsNotTransmitted(
    ModelPath^ filePath
)
static member DocumentIsNotTransmitted :
        filePath : ModelPath -> bool

Parameters

filePath ModelPath
The path to the document whose transmitted state will be checked.

Return Value

Boolean
False if the document is a transmitted file, true otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

TransmissionData Class


TransmissionData.GetAllExternalFileReferenceIds Method

TransmissionDataGetAllExternalFileReferenceIds Method

Gets the ids of all ExternalFileReferences.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetAllExternalFileReferenceIds()
Public Function GetAllExternalFileReferenceIds As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetAllExternalFileReferenceIds()
member GetAllExternalFileReferenceIds : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
The ids of all ExternalFileReferences.
See Also

Reference

TransmissionData Class


TransmissionData.GetDesiredReferenceData Method

TransmissionDataGetDesiredReferenceData Method

Gets the ExternalFileReference representing path and load status information to be used the next time this TransmissionData's document is loaded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExternalFileReference GetDesiredReferenceData(
    ElementId elemId
)
Public Function GetDesiredReferenceData (
    elemId As ElementId
) As ExternalFileReference
public:
ExternalFileReference^ GetDesiredReferenceData(
    ElementId^ elemId
)
member GetDesiredReferenceData :
        elemId : ElementId -> ExternalFileReference

Parameters

elemId ElementId
The ElementId of the Element which the external file reference is a component of.

Return Value

ExternalFileReference
An ExternalFileReference containing the requested path and load status information for an external file
Exceptions
Exception | Condition
ArgumentException | elemId does not correspond to an ExternalFileReference contained in this TransmissionData.
ArgumentNullException | A non-optional argument was null
See Also

Reference

TransmissionData Class


TransmissionData.GetLastSavedReferenceData Method

TransmissionDataGetLastSavedReferenceData Method

Gets the ExternalFileReference representing path and load status information concerning the most recent time this TransmissionData's document was opened.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExternalFileReference GetLastSavedReferenceData(
    ElementId elemId
)
Public Function GetLastSavedReferenceData (
    elemId As ElementId
) As ExternalFileReference
public:
ExternalFileReference^ GetLastSavedReferenceData(
    ElementId^ elemId
)
member GetLastSavedReferenceData :
        elemId : ElementId -> ExternalFileReference

Parameters

elemId ElementId
The ElementId of the Element which the external file reference is a component of.

Return Value

ExternalFileReference
An ExternalFileReference containing the previous path and load status information for an external file
Exceptions
Exception | Condition
ArgumentException | elemId does not correspond to an ExternalFileReference contained in this TransmissionData.
ArgumentNullException | A non-optional argument was null
See Also

Reference

TransmissionData Class


TransmissionData.IsDocumentTransmitted Method

TransmissionDataIsDocumentTransmitted Method

Determines whether the document at a given file location is transmitted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsDocumentTransmitted(
    ModelPath filePath
)
Public Shared Function IsDocumentTransmitted (
    filePath As ModelPath
) As Boolean
public:
static bool IsDocumentTransmitted(
    ModelPath^ filePath
)
static member IsDocumentTransmitted :
        filePath : ModelPath -> bool

Parameters

filePath ModelPath
The path to the document whose transmitted state will be checked.

Return Value

Boolean
True if the document is a transmitted file, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

TransmissionData Class


TransmissionData.ReadTransmissionData Method

TransmissionDataReadTransmissionData Method

Reads the TransmissionData associated with the file at the given location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static TransmissionData ReadTransmissionData(
    ModelPath path
)
Public Shared Function ReadTransmissionData (
    path As ModelPath
) As TransmissionData
public:
static TransmissionData^ ReadTransmissionData(
    ModelPath^ path
)
static member ReadTransmissionData :
        path : ModelPath -> TransmissionData

Parameters

path ModelPath
A ModelPath indicating the file Revit should read the TransmissionData of. If this ModelPath is a file path, it must be an absolute path.

Return Value

TransmissionData
The TransmissionData containing external file information for the file at the given location.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
CentralModelAccessDeniedException | Access to the central model was denied. A possible reason is because the model was under maintenance.
CentralModelContentionException | The central model are locked by another client.
CentralModelException | The central model is missing. -or- An internal error happened on the central model, please contact the server administrator.
FileArgumentNotFoundException | There is not a valid Revit file at path's location
RevitServerCommunicationException | The server-based central model could not be accessed because of a network communication error.
Remarks
The TransmissionData returned by this function contains data about all ExternalFileReferences in the document. ExternalResourceReferences to extenal servers will not be returned by this function. TransmissionData contains information about local or Revit Server references only.
See Also

Reference

TransmissionData Class


TransmissionData.SetDesiredReferenceData Method

TransmissionDataSetDesiredReferenceData Method

Sets the ExternalFileReference information which Revit should use the next time it opens the document which this TransmissionData belongs to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetDesiredReferenceData(
    ElementId elemId,
    ModelPath path,
    PathType pathType,
    bool shouldLoad
)
Public Sub SetDesiredReferenceData (
    elemId As ElementId,
    path As ModelPath,
    pathType As PathType,
    shouldLoad As Boolean
)
public:
void SetDesiredReferenceData(
    ElementId^ elemId,
    ModelPath^ path,
    PathType pathType,
    bool shouldLoad
)
member SetDesiredReferenceData :
        elemId : ElementId *
        path : ModelPath *
        pathType : PathType *
        shouldLoad : bool -> unit

Parameters

elemId ElementId
The id of the element associated with this reference.
path ModelPath
A ModelPath indicating the location to load the external file reference from.
pathType PathType
A PathType value indicating what type of path the ModelPath is.
shouldLoad Boolean
True if the external file should be loaded the next time Revit opens the document. False if it should be unloaded.
Exceptions
Exception | Condition
ArgumentException | elemId does not correspond to an ExternalFileReference contained in this TransmissionData. -or- These inputs will not produce a valid ExternalFileReference.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Remarks
There must already be a reference associated with the given id for this function to be valid. New references cannot be created in a closed file. See the documentation for a particular reference type to see its creation API.
See Also

Reference

TransmissionData Class


TransmissionData.WriteTransmissionData Method

TransmissionDataWriteTransmissionData Method

Writes the given TransmissionData into the Revit file at the given location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void WriteTransmissionData(
    ModelPath path,
    TransmissionData data
)
Public Shared Sub WriteTransmissionData (
    path As ModelPath,
    data As TransmissionData
)
public:
static void WriteTransmissionData(
    ModelPath^ path,
    TransmissionData^ data
)
static member WriteTransmissionData :
        path : ModelPath *
        data : TransmissionData -> unit

Parameters

path ModelPath
A ModelPath indicating the file Revit should write the TransmissionData of. This ModelPath must be a file path and an absolute path.
data TransmissionData
The TransmissionData to be written into the document. Note that Revit will not check that the ElementIds in the TransmissionData correspond to real Elements.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
FileArgumentNotFoundException | There is not a valid Revit file at path's location
InvalidOperationException | Operation is not valid for Revit Server models. -or- This function cannot be called on an opened document.
Remarks

This function will overwrite the existing TransmissionData in the file.

This function will not support models on Revit Server. References may be to Revit Server, but the host model must be local.

This function must be called on a closed document.

This function cannot be used to convert a reference from a local file to an external server.

See Also

Reference

TransmissionData Class


TransmittedModelOptions Enumeration

Enum giving desired behavior when opening or saving a transmitted workshared model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum TransmittedModelOptions
Public Enumeration TransmittedModelOptions
public enum class TransmittedModelOptions
type TransmittedModelOptions
Members
Member name | Value | Description
SaveAsNewCentral | 0 | The model should be saved as a new central. (On open, it will be saved as a new central in its current location. On save, it will be saved as central but the user can choose a location.)
KeepAsTransmitted | 1 | The model will remain marked as transmitted; users will not be able to create locals until it is saved as a new central.
CancelOperation | 2 | Cancel the save or load operation.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TriangleInShellComponent Class

This class represents a triangle in a TriangulatedShellComponent object. The triangle is defined by its vertices, which are specified by their indices in the TriangulatedShellComponent's array of vertices.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBTriangleInShellComponent

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TriangleInShellComponent : IDisposable
Public Class TriangleInShellComponent
    Implements IDisposable
public ref class TriangleInShellComponent : IDisposable
type TriangleInShellComponent =
    class
        interface IDisposable
    end

The TriangleInShellComponent type exposes the following members.

Constructors
 | Name | Description
Public method | TriangleInShellComponent | Creates a copy of the given TriangleInShellComponent
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | VertexIndex0 | Index of the triangle's first vertex in the TriangulatedShellComponent's array of vertices.
Public property | VertexIndex1 | Index of the triangle's second vertex in the TriangulatedShellComponent's array of vertices.
Public property | VertexIndex2 | Index of the triangle's third vertex in the TriangulatedShellComponent's array of vertices.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the TriangleInShellComponent
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
A TriangulatedShellComponent stores an array of TriangleInShellComponent objects representing the triangles of the triangulation. An external class is used because the API does not allow the use of a triple of integers. Note that a TriangleInShellComponent must only be used in the context of a single, fixed TriangulatedShellComponent.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TriangleInShellComponent Constructor

Creates a copy of the given TriangleInShellComponent

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TriangleInShellComponent(
    TriangleInShellComponent other
)
Public Sub New (
    other As TriangleInShellComponent
)
public:
TriangleInShellComponent(
    TriangleInShellComponent^ other
)
new :
        other : TriangleInShellComponent -> TriangleInShellComponent

Parameters

other TriangleInShellComponent
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

TriangleInShellComponent Class


TriangleInShellComponent Properties

The TriangleInShellComponent type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | VertexIndex0 | Index of the triangle's first vertex in the TriangulatedShellComponent's array of vertices.
Public property | VertexIndex1 | Index of the triangle's second vertex in the TriangulatedShellComponent's array of vertices.
Public property | VertexIndex2 | Index of the triangle's third vertex in the TriangulatedShellComponent's array of vertices.
Top
See Also

Reference

TriangleInShellComponent Class


TriangleInShellComponent.IsValidObject Property

TriangleInShellComponentIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

TriangleInShellComponent Class


TriangleInShellComponent.VertexIndex0 Property

TriangleInShellComponentVertexIndex0 Property

Index of the triangle's first vertex in the TriangulatedShellComponent's array of vertices.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int VertexIndex0 { get; }
Public ReadOnly Property VertexIndex0 As Integer
    Get
public:
property int VertexIndex0 {
    int get ();
}
member VertexIndex0 : int with get

Property Value

Int32
See Also

Reference

TriangleInShellComponent Class


TriangleInShellComponent.VertexIndex1 Property

TriangleInShellComponentVertexIndex1 Property

Index of the triangle's second vertex in the TriangulatedShellComponent's array of vertices.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int VertexIndex1 { get; }
Public ReadOnly Property VertexIndex1 As Integer
    Get
public:
property int VertexIndex1 {
    int get ();
}
member VertexIndex1 : int with get

Property Value

Int32
See Also

Reference

TriangleInShellComponent Class


TriangleInShellComponent.VertexIndex2 Property

TriangleInShellComponentVertexIndex2 Property

Index of the triangle's third vertex in the TriangulatedShellComponent's array of vertices.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int VertexIndex2 { get; }
Public ReadOnly Property VertexIndex2 As Integer
    Get
public:
property int VertexIndex2 {
    int get ();
}
member VertexIndex2 : int with get

Property Value

Int32
See Also

Reference

TriangleInShellComponent Class


TriangleInShellComponent Methods

The TriangleInShellComponent type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

TriangleInShellComponent Class


TriangleInShellComponent.Dispose Method

TriangleInShellComponentDispose Method

Releases all resources used by the TriangleInShellComponent

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

TriangleInShellComponent Class


TriangulatedShellComponent Class

This class represents a triangulated boundary component of a solid or a triangulated connected component of a shell.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBTriangulatedShellComponent

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TriangulatedShellComponent : IDisposable
Public Class TriangulatedShellComponent
    Implements IDisposable
public ref class TriangulatedShellComponent : IDisposable
type TriangulatedShellComponent =
    class
        interface IDisposable
    end

The TriangulatedShellComponent type exposes the following members.

Properties
 | Name | Description
Public property | IsClosed | True if and only if the triangulation represents a topologically closed shell (i.e., each edge is shared by two triangles).
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | TriangleCount | The number of triangles in the triangulation.
Public property | VertexCount | The number of vertices in the triangulation.
Top
Methods
 | Name | Description
Public method | Clear | Empties the contents of this TriangulatedShellComponent.
Public method | Dispose | Releases all resources used by the TriangulatedShellComponent
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetTriangle | Returns the triangle corresponding to the given index.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetVertex | Returns the vertex with a given index.
Public method | GetVertices | Returns the vertices of the triangulation.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The triangulation is "topologically connected" in the following sense: if two triangles share an edge geometrically, then they share a single edge topologically (i.e., they share two vertices defining the geometrically shared edge).
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TriangulatedShellComponent Properties

The TriangulatedShellComponent type exposes the following members.

Properties
 | Name | Description
Public property | IsClosed | True if and only if the triangulation represents a topologically closed shell (i.e., each edge is shared by two triangles).
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | TriangleCount | The number of triangles in the triangulation.
Public property | VertexCount | The number of vertices in the triangulation.
Top
See Also

Reference

TriangulatedShellComponent Class


TriangulatedShellComponent.IsClosed Property

TriangulatedShellComponentIsClosed Property

True if and only if the triangulation represents a topologically closed shell (i.e., each edge is shared by two triangles).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsClosed { get; }
Public ReadOnly Property IsClosed As Boolean
    Get
public:
property bool IsClosed {
    bool get ();
}
member IsClosed : bool with get

Property Value

Boolean
See Also

Reference

TriangulatedShellComponent Class


TriangulatedShellComponent.IsValidObject Property

TriangulatedShellComponentIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

TriangulatedShellComponent Class


TriangulatedShellComponent.TriangleCount Property

TriangulatedShellComponentTriangleCount Property

The number of triangles in the triangulation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int TriangleCount { get; }
Public ReadOnly Property TriangleCount As Integer
    Get
public:
property int TriangleCount {
    int get ();
}
member TriangleCount : int with get

Property Value

Int32
See Also

Reference

TriangulatedShellComponent Class


TriangulatedShellComponent.VertexCount Property

TriangulatedShellComponentVertexCount Property

The number of vertices in the triangulation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int VertexCount { get; }
Public ReadOnly Property VertexCount As Integer
    Get
public:
property int VertexCount {
    int get ();
}
member VertexCount : int with get

Property Value

Int32
See Also

Reference

TriangulatedShellComponent Class


TriangulatedShellComponent Methods

The TriangulatedShellComponent type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Empties the contents of this TriangulatedShellComponent.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetTriangle | Returns the triangle corresponding to the given index.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetVertex | Returns the vertex with a given index.
Public method | GetVertices | Returns the vertices of the triangulation.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

TriangulatedShellComponent Class


TriangulatedShellComponent.Clear Method

TriangulatedShellComponentClear Method

Empties the contents of this TriangulatedShellComponent.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

TriangulatedShellComponent Class


TriangulatedShellComponent.Dispose Method

TriangulatedShellComponentDispose Method

Releases all resources used by the TriangulatedShellComponent

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

TriangulatedShellComponent Class


TriangulatedShellComponent.GetTriangle Method

TriangulatedShellComponentGetTriangle Method

Returns the triangle corresponding to the given index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TriangleInShellComponent GetTriangle(
    int triangleIndex
)
Public Function GetTriangle (
    triangleIndex As Integer
) As TriangleInShellComponent
public:
TriangleInShellComponent^ GetTriangle(
    int triangleIndex
)
member GetTriangle :
        triangleIndex : int -> TriangleInShellComponent

Parameters

triangleIndex Int32
The index of the triangle (between 0 and TriangleCount-1, inclusive).

Return Value

TriangleInShellComponent
The triangle.
Exceptions
Exception | Condition
ArgumentException | triangleIndex is out of range.
See Also

Reference

TriangulatedShellComponent Class


TriangulatedShellComponent.GetVertex Method

TriangulatedShellComponentGetVertex Method

Returns the vertex with a given index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ GetVertex(
    int vertexIndex
)
Public Function GetVertex (
    vertexIndex As Integer
) As XYZ
public:
XYZ^ GetVertex(
    int vertexIndex
)
member GetVertex :
        vertexIndex : int -> XYZ

Parameters

vertexIndex Int32
The index of the vertex (between 0 and getVertexCount()-1, inclusive).

Return Value

XYZ
A copy of the requested vertex.
Exceptions
Exception | Condition
ArgumentException | vertexIndex is out of range.
See Also

Reference

TriangulatedShellComponent Class


TriangulatedShellComponent.GetVertices Method

TriangulatedShellComponentGetVertices Method

Returns the vertices of the triangulation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<XYZ> GetVertices()
Public Function GetVertices As IList(Of XYZ)
public:
IList<XYZ^>^ GetVertices()
member GetVertices : unit -> IList<XYZ>

Return Value

IList XYZ
The vertices of the triangulation.
See Also

Reference

TriangulatedShellComponent Class


TriangulatedSolidOrShell Class

This class represents a triangulated solid or shell.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBTriangulatedSolidOrShell

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TriangulatedSolidOrShell : IDisposable
Public Class TriangulatedSolidOrShell
    Implements IDisposable
public ref class TriangulatedSolidOrShell : IDisposable
type TriangulatedSolidOrShell =
    class
        interface IDisposable
    end

The TriangulatedSolidOrShell type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ShellComponentCount | The number of TriangulatedShellComponents that this TriangulatedSolidOrShell contains.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the TriangulatedSolidOrShell
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetShellComponent | Returns the specified shell component of a solid or shell. Input componentIndex must lie between 0 and ShellComponentCount-1, inclusive. The returned TriangulatedShellComponent should not be modified by the caller.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

The triangulation consists of a number of TriangulatedShellComponents. For a solid, there will be one TriangulatedShellComponent for each component of the solid's boundary. For example, a solid cube has just one boundary component (containing six faces), so there will be just one TriangulatedShellComponent. A solid consisting of two disjoint cubes has two boundary components (the boundaries of the two cubes), so there will be two TriangulatedShellComponents. A solid consisting of a sphere with a round void (or hole) inside it also has two boundary components (the outer sphere and the inner sphere), so there will be two TriangulatedShellComponents.

For a shell, there will be one TriangulatedShellComponent for each component of the shell.

Note that this class does not contain information on the containment structure of the boundary components of a solid.

Be careful not to confuse the components of a solid with the solid's boundary components. This class deals only with the boundary components.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TriangulatedSolidOrShell Properties

The TriangulatedSolidOrShell type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ShellComponentCount | The number of TriangulatedShellComponents that this TriangulatedSolidOrShell contains.
Top
See Also

Reference

TriangulatedSolidOrShell Class


TriangulatedSolidOrShell.IsValidObject Property

TriangulatedSolidOrShellIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

TriangulatedSolidOrShell Class


TriangulatedSolidOrShell.ShellComponentCount Property

TriangulatedSolidOrShellShellComponentCount Property

The number of TriangulatedShellComponents that this TriangulatedSolidOrShell contains.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ShellComponentCount { get; }
Public ReadOnly Property ShellComponentCount As Integer
    Get
public:
property int ShellComponentCount {
    int get ();
}
member ShellComponentCount : int with get

Property Value

Int32
See Also

Reference

TriangulatedSolidOrShell Class


TriangulatedSolidOrShell Methods

The TriangulatedSolidOrShell type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetShellComponent | Returns the specified shell component of a solid or shell. Input componentIndex must lie between 0 and ShellComponentCount-1, inclusive. The returned TriangulatedShellComponent should not be modified by the caller.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

TriangulatedSolidOrShell Class


TriangulatedSolidOrShell.Dispose Method

TriangulatedSolidOrShellDispose Method

Releases all resources used by the TriangulatedSolidOrShell

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

TriangulatedSolidOrShell Class


TriangulatedSolidOrShell.GetShellComponent Method

TriangulatedSolidOrShellGetShellComponent Method

Returns the specified shell component of a solid or shell. Input componentIndex must lie between 0 and ShellComponentCount-1, inclusive. The returned TriangulatedShellComponent should not be modified by the caller.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TriangulatedShellComponent GetShellComponent(
    int componentIndex
)
Public Function GetShellComponent (
    componentIndex As Integer
) As TriangulatedShellComponent
public:
TriangulatedShellComponent^ GetShellComponent(
    int componentIndex
)
member GetShellComponent :
        componentIndex : int -> TriangulatedShellComponent

Parameters

componentIndex Int32
The component index, must be between 0 and ShellComponentCount â€“ 1, inclusive.

Return Value

TriangulatedShellComponent
The component.
Exceptions
Exception | Condition
ArgumentException | Shell component index componentIndex is out of range.
See Also

Reference

TriangulatedSolidOrShell Class


TriangulationInterface Class

This abstract class provides an interface for querying a triangulation structure (vertices and triangles).
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBTriangulationInterface
Autodesk.Revit.DBTriangulationInterfaceForTriangulatedShellComponent
Autodesk.Revit.DBTriangulationInterfaceForTriangulatedSolidOrShell

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TriangulationInterface : IDisposable
Public Class TriangulationInterface
    Implements IDisposable
public ref class TriangulationInterface : IDisposable
type TriangulationInterface =
    class
        interface IDisposable
    end

The TriangulationInterface type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the TriangulationInterface
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TriangulationInterface Properties

The TriangulationInterface type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

TriangulationInterface Class


TriangulationInterface.IsValidObject Property

TriangulationInterfaceIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

TriangulationInterface Class


TriangulationInterface Methods

The TriangulationInterface type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

TriangulationInterface Class


TriangulationInterface.Dispose Method

TriangulationInterfaceDispose Method

Releases all resources used by the TriangulationInterface

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

TriangulationInterface Class


TriangulationInterfaceForTriangulatedShellComponent Class

This class is used to call FacetingUtils::convertTrianglesToQuads with a triangulation defined by a TriangulatedShellComponent.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBTriangulationInterface
Autodesk.Revit.DBTriangulationInterfaceForTriangulatedShellComponent

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TriangulationInterfaceForTriangulatedShellComponent : TriangulationInterface
Public Class TriangulationInterfaceForTriangulatedShellComponent
    Inherits TriangulationInterface
public ref class TriangulationInterfaceForTriangulatedShellComponent : public TriangulationInterface
type TriangulationInterfaceForTriangulatedShellComponent =
    class
        inherit TriangulationInterface
    end

The TriangulationInterfaceForTriangulatedShellComponent type exposes the following members.

Constructors
 | Name | Description
Public method | TriangulationInterfaceForTriangulatedShellComponent | Constructs an interface object for a TriangulatedShellComponent.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from TriangulationInterface)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from TriangulationInterface)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Compare to TriangulationInterfaceForTriangulatedSolidOrShell, which treats with the entire solid or shell as a single triangulated structure.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TriangulationInterfaceForTriangulatedShellComponent Constructor

Constructs an interface object for a TriangulatedShellComponent.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TriangulationInterfaceForTriangulatedShellComponent(
    TriangulatedShellComponent externalTriangulatedShellComponent
)
Public Sub New (
    externalTriangulatedShellComponent As TriangulatedShellComponent
)
public:
TriangulationInterfaceForTriangulatedShellComponent(
    TriangulatedShellComponent^ externalTriangulatedShellComponent
)
new :
        externalTriangulatedShellComponent : TriangulatedShellComponent -> TriangulationInterfaceForTriangulatedShellComponent

Parameters

externalTriangulatedShellComponent TriangulatedShellComponent
The TriangulatedShellComponent that the interface object represents.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

TriangulationInterfaceForTriangulatedShellComponent Class


TriangulationInterfaceForTriangulatedShellComponent Properties

The TriangulationInterfaceForTriangulatedShellComponent type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from TriangulationInterface)
Top
See Also

Reference

TriangulationInterfaceForTriangulatedShellComponent Class


TriangulationInterfaceForTriangulatedShellComponent Methods

The TriangulationInterfaceForTriangulatedShellComponent type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from TriangulationInterface)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

TriangulationInterfaceForTriangulatedShellComponent Class


TriangulationInterfaceForTriangulatedSolidOrShell Class

This class is used to call FacetingUtils::convertTrianglesToQuads with a triangulation defined by a TriangulatedSolidOrShell.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBTriangulationInterface
Autodesk.Revit.DBTriangulationInterfaceForTriangulatedSolidOrShell

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TriangulationInterfaceForTriangulatedSolidOrShell : TriangulationInterface
Public Class TriangulationInterfaceForTriangulatedSolidOrShell
    Inherits TriangulationInterface
public ref class TriangulationInterfaceForTriangulatedSolidOrShell : public TriangulationInterface
type TriangulationInterfaceForTriangulatedSolidOrShell =
    class
        inherit TriangulationInterface
    end

The TriangulationInterfaceForTriangulatedSolidOrShell type exposes the following members.

Constructors
 | Name | Description
Public method | TriangulationInterfaceForTriangulatedSolidOrShell | Construct an interface object for a TriangulatedSolidOrShell.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from TriangulationInterface)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from TriangulationInterface)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The vertex and triangle indices used by this class treat the triangulated solid or shell as if all the vertices and triangles of the different shell components were collected into single sets of vertices and triangles, respectively. For example, if a solid has two shell components and the first has ten vertices while the second has five vertices, vertexIndex 6 refers to vertex[6] of the first shell component, and vertexIndex 12 refers to vertex[2] of the second shell component. You can use the class TriangulationInterfaceForTriangulatedShellComponent to get a faceting of an individual shell component.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TriangulationInterfaceForTriangulatedSolidOrShell Constructor

Construct an interface object for a TriangulatedSolidOrShell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TriangulationInterfaceForTriangulatedSolidOrShell(
    TriangulatedSolidOrShell externalTriangulatedSolidOrShell
)
Public Sub New (
    externalTriangulatedSolidOrShell As TriangulatedSolidOrShell
)
public:
TriangulationInterfaceForTriangulatedSolidOrShell(
    TriangulatedSolidOrShell^ externalTriangulatedSolidOrShell
)
new :
        externalTriangulatedSolidOrShell : TriangulatedSolidOrShell -> TriangulationInterfaceForTriangulatedSolidOrShell

Parameters

externalTriangulatedSolidOrShell TriangulatedSolidOrShell
The TriangulatedSolidOrShell that the interface object represents.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

TriangulationInterfaceForTriangulatedSolidOrShell Class


TriangulationInterfaceForTriangulatedSolidOrShell Properties

The TriangulationInterfaceForTriangulatedSolidOrShell type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from TriangulationInterface)
Top
See Also

Reference

TriangulationInterfaceForTriangulatedSolidOrShell Class


TriangulationInterfaceForTriangulatedSolidOrShell Methods

The TriangulationInterfaceForTriangulatedSolidOrShell type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from TriangulationInterface)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

TriangulationInterfaceForTriangulatedSolidOrShell Class


TriOrQuadFacet Class

This class represents a triangle or quadrilateral in a faceted structure.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBTriOrQuadFacet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TriOrQuadFacet : IDisposable
Public Class TriOrQuadFacet
    Implements IDisposable
public ref class TriOrQuadFacet : IDisposable
type TriOrQuadFacet =
    class
        interface IDisposable
    end

The TriOrQuadFacet type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Normal | A unit normal vector for this facet.
Public property | NumberOfVertices | The number of vertices (3 for a triangle, 4 for a quadrilateral, 0 for an unset TriOrQuadFacet).
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the TriOrQuadFacet
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetVertexIndex | Returns the index of the specified vertex of this facet (as an index into the external array of vertices in the TriangulationInterface that was used to create the list of TriOrQuadFacets).
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This class defines a triangle or quadrilateral with reference to an external triangulation structure. The vertices of this TriOrQuadFacet are indices into the triangulation structure's array of vertices.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TriOrQuadFacet Properties

The TriOrQuadFacet type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Normal | A unit normal vector for this facet.
Public property | NumberOfVertices | The number of vertices (3 for a triangle, 4 for a quadrilateral, 0 for an unset TriOrQuadFacet).
Top
See Also

Reference

TriOrQuadFacet Class


TriOrQuadFacet.IsValidObject Property

TriOrQuadFacetIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

TriOrQuadFacet Class


TriOrQuadFacet.Normal Property

TriOrQuadFacetNormal Property

A unit normal vector for this facet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Normal { get; }
Public ReadOnly Property Normal As XYZ
    Get
public:
property XYZ^ Normal {
    XYZ^ get ();
}
member Normal : XYZ with get

Property Value

XYZ
See Also

Reference

TriOrQuadFacet Class


TriOrQuadFacet.NumberOfVertices Property

TriOrQuadFacetNumberOfVertices Property

The number of vertices (3 for a triangle, 4 for a quadrilateral, 0 for an unset TriOrQuadFacet).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int NumberOfVertices { get; }
Public ReadOnly Property NumberOfVertices As Integer
    Get
public:
property int NumberOfVertices {
    int get ();
}
member NumberOfVertices : int with get

Property Value

Int32
See Also

Reference

TriOrQuadFacet Class


TriOrQuadFacet Methods

The TriOrQuadFacet type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetVertexIndex | Returns the index of the specified vertex of this facet (as an index into the external array of vertices in the TriangulationInterface that was used to create the list of TriOrQuadFacets).
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

TriOrQuadFacet Class


TriOrQuadFacet.Dispose Method

TriOrQuadFacetDispose Method

Releases all resources used by the TriOrQuadFacet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

TriOrQuadFacet Class


TriOrQuadFacet.GetVertexIndex Method

TriOrQuadFacetGetVertexIndex Method

Returns the index of the specified vertex of this facet (as an index into the external array of vertices in the TriangulationInterface that was used to create the list of TriOrQuadFacets).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetVertexIndex(
    int index
)
Public Function GetVertexIndex (
    index As Integer
) As Integer
public:
int GetVertexIndex(
    int index
)
member GetVertexIndex :
        index : int -> int

Parameters

index Int32
Index of the desired vertex in this TriOrQuadFacet (between 0 and NumberOfVertices-1, inclusive).

Return Value

Int32
The index of the specified vertex in the external array of vertices (only valid if NumberOfVertices >= 3).
Exceptions
Exception | Condition
ArgumentException | index is out of range..
See Also

Reference

TriOrQuadFacet Class


TypeBinding Class

TypeBinding objects are used to bind a property to a Revit type, such as a wall type.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBBinding
Autodesk.Revit.DBElementBinding
Autodesk.Revit.DBTypeBinding

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class TypeBinding : ElementBinding
Public Class TypeBinding
    Inherits ElementBinding
public ref class TypeBinding : public ElementBinding
type TypeBinding =
    class
        inherit ElementBinding
    end

The TypeBinding type exposes the following members.

Constructors
 | Name | Description
Public method | TypeBinding | Constructs an empty type binding.
Public method | TypeBinding(CategorySet) | Constructs a type binding with the set of categories passed.
Top
Properties
 | Name | Description
Public property | Categories | Retrieve or set the categories to which a parameter definition will be bound. (Inherited from ElementBinding)
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This differs from Instance bindings in that the property is then shared by all instances that use that type. Changing the parameter for one type affects all other instances that use that type.
Example
C#
VB
C++
F#
Copy
public bool SetNewParameterToTypeWall(UIApplication app, DefinitionFile myDefinitionFile)
{
    // Create a new group in the shared parameters file
    DefinitionGroups myGroups = myDefinitionFile.Groups;
    DefinitionGroup myGroup = myGroups.Create("MyParameters");

    // Create a type definition
    ExternalDefinitionCreationOptions option = new ExternalDefinitionCreationOptions("CompanyName", SpecTypeId.String.Text);
    Definition myDefinition_CompanyName = myGroup.Definitions.Create(option);

    // Create a category set and insert category of wall to it
    CategorySet myCategories = app.Application.Create.NewCategorySet();
    // Use BuiltInCategory to get category of wall
    Category myCategory = Category.GetCategory(app.ActiveUIDocument.Document, BuiltInCategory.OST_Walls);

    myCategories.Insert(myCategory);

    //Create an object of TypeBinding according to the Categories
    TypeBinding typeBinding = app.Application.Create.NewTypeBinding(myCategories);

    // Get the BingdingMap of current document.
    BindingMap bindingMap = app.ActiveUIDocument.Document.ParameterBindings;

    // Bind the definitions to the document
    bool typeBindOK = bindingMap.Insert(myDefinition_CompanyName, typeBinding,
      GroupTypeId.Text);
    return typeBindOK;
}
Public Function SetNewParameterToTypeWall(app As UIApplication, myDefinitionFile As DefinitionFile) As Boolean
   ' Create a new group in the shared parameters file
   Dim myGroups As DefinitionGroups = myDefinitionFile.Groups
   Dim myGroup As DefinitionGroup = myGroups.Create("MyParameters")

   ' Create a type definition
   Dim [option] As New ExternalDefinitionCreationOptions("CompanyName", SpecTypeId.String.Text)
   Dim myDefinition_CompanyName As Definition = myGroup.Definitions.Create([option])

   ' Create a category set and insert category of wall to it
   Dim myCategories As CategorySet = app.Application.Create.NewCategorySet()
   ' Use BuiltInCategory to get category of wall
   Dim myCategory As Category = Category.GetCategory(app.ActiveUIDocument.Document, BuiltInCategory.OST_Walls)

   myCategories.Insert(myCategory)

   'Create an object of TypeBinding according to the Categories
   Dim typeBinding As TypeBinding = app.Application.Create.NewTypeBinding(myCategories)

   ' Get the BingdingMap of current document.
   Dim bindingMap As BindingMap = app.ActiveUIDocument.Document.ParameterBindings

      ' Bind the definitions to the document
      Dim typeBindOK As Boolean = bindingMap.Insert(myDefinition_CompanyName, typeBinding, GroupTypeId.Text)
      Return typeBindOK
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


TypeBinding Constructor

Overload List
 | Name | Description
Public method | TypeBinding | Constructs an empty type binding.
Public method | TypeBinding(CategorySet) | Constructs a type binding with the set of categories passed.
Top
See Also

Reference

TypeBinding Class


TypeBinding Constructor

Constructs an empty type binding.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TypeBinding()
Public Sub New
public:
TypeBinding()
new : unit -> TypeBinding
Remarks
Categories can be set a later time by using the Categories property of this object.
See Also

Reference

TypeBinding Class
TypeBinding Overload


TypeBinding(CategorySet) Constructor

Constructs a type binding with the set of categories passed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TypeBinding(
    CategorySet categories
)
Public Sub New (
    categories As CategorySet
)
public:
TypeBinding(
    CategorySet^ categories
)
new :
        categories : CategorySet -> TypeBinding

Parameters

categories CategorySet
Remarks
Categories can be set or changed at a later time by using the Categories property of this object.
See Also

Reference

TypeBinding Class
TypeBinding Overload


TypeBinding Properties

The TypeBinding type exposes the following members.

Properties
 | Name | Description
Public property | Categories | Retrieve or set the categories to which a parameter definition will be bound. (Inherited from ElementBinding)
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

TypeBinding Class


TypeBinding Methods

The TypeBinding type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

TypeBinding Class


UnderlayOrientation Enumeration

Indicates how elements in the underlay are viewed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum UnderlayOrientation
Public Enumeration UnderlayOrientation
public enum class UnderlayOrientation
type UnderlayOrientation
Members
Member name | Value | Description
LookingDown | 0 | Underlay elements are viewed as if looking down from above.
LookingUp | 1 | Underlay elements are viewed as if looking up from below.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


UnitFormatUtils Class

A utility class for formatting and parsing numbers with units.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBUnitFormatUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class UnitFormatUtils
Public NotInheritable Class UnitFormatUtils
public ref class UnitFormatUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type UnitFormatUtils = class end

The UnitFormatUtils type exposes the following members.

Methods
Name | Description
Format(Units, ForgeTypeId, Double, Boolean) | Formats a number with units into a string.
Format(Units, ForgeTypeId, Double, Boolean, FormatValueOptions) | Formats a number with units into a string.
TryParse(Units, ForgeTypeId, String, Double) | Parses a formatted string into a number with units if possible.
TryParse(Units, ForgeTypeId, String, ValueParsingOptions, Double) | Parses a formatted string into a number with units if possible.
TryParse(Units, ForgeTypeId, String, Double, String) | Parses a formatted string into a number with units if possible.
TryParse(Units, ForgeTypeId, String, ValueParsingOptions, Double, String) | Parses a formatted string into a number with units if possible.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


UnitFormatUtils Methods

The UnitFormatUtils type exposes the following members.

Methods
Name | Description
Format(Units, ForgeTypeId, Double, Boolean) | Formats a number with units into a string.
Format(Units, ForgeTypeId, Double, Boolean, FormatValueOptions) | Formats a number with units into a string.
TryParse(Units, ForgeTypeId, String, Double) | Parses a formatted string into a number with units if possible.
TryParse(Units, ForgeTypeId, String, ValueParsingOptions, Double) | Parses a formatted string into a number with units if possible.
TryParse(Units, ForgeTypeId, String, Double, String) | Parses a formatted string into a number with units if possible.
TryParse(Units, ForgeTypeId, String, ValueParsingOptions, Double, String) | Parses a formatted string into a number with units if possible.
Top
See Also

Reference

UnitFormatUtils Class


UnitFormatUtils.Format Method

UnitFormatUtilsFormat Method

Overload List
Name | Description
Format(Units, ForgeTypeId, Double, Boolean) | Formats a number with units into a string.
Format(Units, ForgeTypeId, Double, Boolean, FormatValueOptions) | Formats a number with units into a string.
Top
See Also

Reference

UnitFormatUtils Class


UnitFormatUtils.Format(Units, ForgeTypeId, Double, Boolean) Method

UnitFormatUtilsFormat(Units, ForgeTypeId, Double, Boolean) Method

Formats a number with units into a string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string Format(
    Units units,
    ForgeTypeId specTypeId,
    double value,
    bool forEditing
)
Public Shared Function Format (
    units As Units,
    specTypeId As ForgeTypeId,
    value As Double,
    forEditing As Boolean
) As String
public:
static String^ Format(
    Units^ units,
    ForgeTypeId^ specTypeId,
    double value,
    bool forEditing
)
static member Format :
        units : Units *
        specTypeId : ForgeTypeId *
        value : float *
        forEditing : bool -> string

Parameters

units Units
The units formatting settings, typically obtained from Document.GetUnits().
specTypeId ForgeTypeId
Identifier of the spec of the value to format.
value Double
The value to format, in Revit's internal units.
forEditing Boolean
True if the formatting should be modified as necessary so that the formatted string can be successfully parsed, for example by suppressing digit grouping. False if unmodified settings should be used, suitable for display only.

Return Value

String
The formatted string.
Exceptions
Exception | Condition
ArgumentException | specTypeId is not a measurable spec identifier. See UnitUtils.IsMeasurableSpec(ForgeTypeId). -or- The given value for value is not finite
ArgumentNullException | A non-optional argument was null
See Also

Reference

UnitFormatUtils Class
Format Overload


UnitFormatUtils.Format(Units, ForgeTypeId, Double, Boolean, FormatValueOptions) Method

UnitFormatUtilsFormat(Units, ForgeTypeId, Double, Boolean, FormatValueOptions) Method

Formats a number with units into a string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string Format(
    Units units,
    ForgeTypeId specTypeId,
    double value,
    bool forEditing,
    FormatValueOptions formatValueOptions
)
Public Shared Function Format (
    units As Units,
    specTypeId As ForgeTypeId,
    value As Double,
    forEditing As Boolean,
    formatValueOptions As FormatValueOptions
) As String
public:
static String^ Format(
    Units^ units,
    ForgeTypeId^ specTypeId,
    double value,
    bool forEditing,
    FormatValueOptions^ formatValueOptions
)
static member Format :
        units : Units *
        specTypeId : ForgeTypeId *
        value : float *
        forEditing : bool *
        formatValueOptions : FormatValueOptions -> string

Parameters

units Units
The units formatting settings, typically obtained from Document.GetUnits().
specTypeId ForgeTypeId
Identifier of the spec of the value to format.
value Double
The value to format, in Revit's internal units.
forEditing Boolean
True if the formatting should be modified as necessary so that the formatted string can be successfully parsed, for example by suppressing digit grouping. False if unmodified settings should be used, suitable for display only.
formatValueOptions FormatValueOptions
Additional formatting options.

Return Value

String
The formatted string.
Exceptions
Exception | Condition
ArgumentException | specTypeId is not a measurable spec identifier. See UnitUtils.IsMeasurableSpec(ForgeTypeId). -or- The given value for value is not finite -or- The unit in the FormatOptions in formatValueOptions is not a valid unit for specTypeId. See UnitUtils.IsValidUnit(ForgeTypeId, ForgeTypeId) and UnitUtils.GetValidUnits(ForgeTypeId).
ArgumentNullException | A non-optional argument was null
See Also

Reference

UnitFormatUtils Class
Format Overload


UnitFormatUtils.TryParse Method

UnitFormatUtilsTryParse Method

Overload List
Name | Description
TryParse(Units, ForgeTypeId, String, Double) | Parses a formatted string into a number with units if possible.
TryParse(Units, ForgeTypeId, String, ValueParsingOptions, Double) | Parses a formatted string into a number with units if possible.
TryParse(Units, ForgeTypeId, String, Double, String) | Parses a formatted string into a number with units if possible.
TryParse(Units, ForgeTypeId, String, ValueParsingOptions, Double, String) | Parses a formatted string into a number with units if possible.
Top
See Also

Reference

UnitFormatUtils Class


UnitFormatUtils.TryParse(Units, ForgeTypeId, String, Double) Method

UnitFormatUtilsTryParse(Units, ForgeTypeId, String, Double) Method

Parses a formatted string into a number with units if possible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool TryParse(
    Units units,
    ForgeTypeId specTypeId,
    string stringToParse,
    out double value
)
Public Shared Function TryParse (
    units As Units,
    specTypeId As ForgeTypeId,
    stringToParse As String,
    <OutAttribute> ByRef value As Double
) As Boolean
public:
static bool TryParse(
    Units^ units,
    ForgeTypeId^ specTypeId,
    String^ stringToParse,
    [OutAttribute] double% value
)
static member TryParse :
        units : Units *
        specTypeId : ForgeTypeId *
        stringToParse : string *
        value : float byref -> bool

Parameters

units Units
The units formatting settings, typically obtained from Document.GetUnits().
specTypeId ForgeTypeId
Identifier of the target spec for the value.
stringToParse String
The string to parse.
value Double
The parsed value. Ignore this value if the function returns false.

Return Value

Boolean
True if the string can be parsed, false otherwise.
Exceptions
Exception | Condition
ArgumentException | specTypeId is not a measurable spec identifier. See UnitUtils.IsMeasurableSpec(ForgeTypeId).
ArgumentNullException | A non-optional argument was null
See Also

Reference

UnitFormatUtils Class
TryParse Overload


UnitFormatUtils.TryParse(Units, ForgeTypeId, String, ValueParsingOptions, Double) Method

UnitFormatUtilsTryParse(Units, ForgeTypeId, String, ValueParsingOptions, Double) Method

Parses a formatted string into a number with units if possible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool TryParse(
    Units units,
    ForgeTypeId specTypeId,
    string stringToParse,
    ValueParsingOptions valueParsingOptions,
    out double value
)
Public Shared Function TryParse (
    units As Units,
    specTypeId As ForgeTypeId,
    stringToParse As String,
    valueParsingOptions As ValueParsingOptions,
    <OutAttribute> ByRef value As Double
) As Boolean
public:
static bool TryParse(
    Units^ units,
    ForgeTypeId^ specTypeId,
    String^ stringToParse,
    ValueParsingOptions^ valueParsingOptions,
    [OutAttribute] double% value
)
static member TryParse :
        units : Units *
        specTypeId : ForgeTypeId *
        stringToParse : string *
        valueParsingOptions : ValueParsingOptions *
        value : float byref -> bool

Parameters

units Units
The units formatting settings, typically obtained from Document.GetUnits().
specTypeId ForgeTypeId
Identifier of the target spec for the value.
stringToParse String
The string to parse.
valueParsingOptions ValueParsingOptions
Additional parsing options.
value Double
The parsed value. Ignore this value if the function returns false.

Return Value

Boolean
True if the string can be parsed, false otherwise.
Exceptions
Exception | Condition
ArgumentException | specTypeId is not a measurable spec identifier. See UnitUtils.IsMeasurableSpec(ForgeTypeId). -or- The unit in the FormatOptions in valueParsingOptions is not a valid unit for specTypeId. See UnitUtils.IsValidUnit(ForgeTypeId, ForgeTypeId) and UnitUtils.GetValidUnits(ForgeTypeId).
ArgumentNullException | A non-optional argument was null
See Also

Reference

UnitFormatUtils Class
TryParse Overload


UnitFormatUtils.TryParse(Units, ForgeTypeId, String, Double, String) Method

UnitFormatUtilsTryParse(Units, ForgeTypeId, String, Double, String) Method

Parses a formatted string into a number with units if possible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool TryParse(
    Units units,
    ForgeTypeId specTypeId,
    string stringToParse,
    out double value,
    out string message
)
Public Shared Function TryParse (
    units As Units,
    specTypeId As ForgeTypeId,
    stringToParse As String,
    <OutAttribute> ByRef value As Double,
    <OutAttribute> ByRef message As String
) As Boolean
public:
static bool TryParse(
    Units^ units,
    ForgeTypeId^ specTypeId,
    String^ stringToParse,
    [OutAttribute] double% value,
    [OutAttribute] String^% message
)
static member TryParse :
        units : Units *
        specTypeId : ForgeTypeId *
        stringToParse : string *
        value : float byref *
        message : string byref -> bool

Parameters

units Units
The units formatting settings, typically obtained from Document.GetUnits().
specTypeId ForgeTypeId
Identifier of the target spec for the value.
stringToParse String
The string to parse.
value Double
The parsed value. Ignore this value if the function returns false.
message String
A localized message that, if the parsing fails, explains the reason for failure.

Return Value

Boolean
True if the string can be parsed, false otherwise.
Exceptions
Exception | Condition
ArgumentException | specTypeId is not a measurable spec identifier. See UnitUtils.IsMeasurableSpec(ForgeTypeId).
ArgumentNullException | A non-optional argument was null
See Also

Reference

UnitFormatUtils Class
TryParse Overload


UnitFormatUtils.TryParse(Units, ForgeTypeId, String, ValueParsingOptions, Double, String) Method

UnitFormatUtilsTryParse(Units, ForgeTypeId, String, ValueParsingOptions, Double, String) Method

Parses a formatted string into a number with units if possible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool TryParse(
    Units units,
    ForgeTypeId specTypeId,
    string stringToParse,
    ValueParsingOptions valueParsingOptions,
    out double value,
    out string message
)
Public Shared Function TryParse (
    units As Units,
    specTypeId As ForgeTypeId,
    stringToParse As String,
    valueParsingOptions As ValueParsingOptions,
    <OutAttribute> ByRef value As Double,
    <OutAttribute> ByRef message As String
) As Boolean
public:
static bool TryParse(
    Units^ units,
    ForgeTypeId^ specTypeId,
    String^ stringToParse,
    ValueParsingOptions^ valueParsingOptions,
    [OutAttribute] double% value,
    [OutAttribute] String^% message
)
static member TryParse :
        units : Units *
        specTypeId : ForgeTypeId *
        stringToParse : string *
        valueParsingOptions : ValueParsingOptions *
        value : float byref *
        message : string byref -> bool

Parameters

units Units
The units formatting settings, typically obtained from Document.GetUnits().
specTypeId ForgeTypeId
Identifier of the target spec for the value.
stringToParse String
The string to parse.
valueParsingOptions ValueParsingOptions
Additional parsing options.
value Double
The parsed value. Ignore this value if the function returns false.
message String
A localized message that, if the parsing fails, explains the reason for failure.

Return Value

Boolean
True if the string can be parsed, false otherwise.
Exceptions
Exception | Condition
ArgumentException | specTypeId is not a measurable spec identifier. See UnitUtils.IsMeasurableSpec(ForgeTypeId). -or- The unit in the FormatOptions in valueParsingOptions is not a valid unit for specTypeId. See UnitUtils.IsValidUnit(ForgeTypeId, ForgeTypeId) and UnitUtils.GetValidUnits(ForgeTypeId).
ArgumentNullException | A non-optional argument was null
See Also

Reference

UnitFormatUtils Class
TryParse Overload


Units Class

A document's default settings for formatting numbers with units.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBUnits

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Units : IDisposable
Public Class Units
    Implements IDisposable
public ref class Units : IDisposable
type Units =
    class
        interface IDisposable
    end

The Units type exposes the following members.

Constructors
 | Name | Description
Public method | Units | Creates a new Units object with default settings for Metric or Imperial units.
Top
Properties
 | Name | Description
Public property | DecimalSymbol | The symbol used to separate the integer and fractional parts of a number.
Public property | DigitGroupingAmount | The number of digits in each group when numbers are formatted with digit grouping.
Public property | DigitGroupingSymbol | The symbol used to separate groups of digits when numbers are formatted with digit grouping.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the Units
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetFormatOptions | Gets the default FormatOptions for a spec.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
 | GetModifiableSpecs | Gets all specs for which the default FormatOptions can be modified.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | IsModifiableSpec | Checks whether the default FormatOptions can be modified for a given spec.
Public method | SetFormatOptions | Sets the default FormatOptions for a spec.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

The Units class represents a document's default settings for formatting numbers with units as strings. It contains a FormatOptions object for each unit type as well as settings related to decimal symbol and digit grouping.

The Units class stores a FormatOptions object for every valid unit type, but not all of them can be directly modified. Some, like UT_Number and UT_SiteAngle, have fixed definitions. Others have definitions which are automatically derived from other unit types. For example, UT_SheetLength is derived from UT_Length and UT_ForceScale is derived from UT_Force. See IsModifiableUnitType() and GetModifiableUnitTypes().

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Units Constructor

Creates a new Units object with default settings for Metric or Imperial units.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Units(
    UnitSystem unitSystem
)
Public Sub New (
    unitSystem As UnitSystem
)
public:
Units(
    UnitSystem unitSystem
)
new :
        unitSystem : UnitSystem -> Units

Parameters

unitSystem UnitSystem
Indicates whether the Units object should be initialized with default settings for Metric or Imperial units.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

Units Class


Units Properties

The Units type exposes the following members.

Properties
 | Name | Description
Public property | DecimalSymbol | The symbol used to separate the integer and fractional parts of a number.
Public property | DigitGroupingAmount | The number of digits in each group when numbers are formatted with digit grouping.
Public property | DigitGroupingSymbol | The symbol used to separate groups of digits when numbers are formatted with digit grouping.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

Units Class


Units.DecimalSymbol Property

UnitsDecimalSymbol Property

The symbol used to separate the integer and fractional parts of a number.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DecimalSymbol DecimalSymbol { get; set; }
Public Property DecimalSymbol As DecimalSymbol
    Get
    Set
public:
property DecimalSymbol DecimalSymbol {
    DecimalSymbol get ();
    void set (DecimalSymbol value);
}
member DecimalSymbol : DecimalSymbol with get, set

Property Value

DecimalSymbol
The decimal symbol. The default is Dot.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

Units Class


Units.DigitGroupingAmount Property

UnitsDigitGroupingAmount Property

The number of digits in each group when numbers are formatted with digit grouping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DigitGroupingAmount DigitGroupingAmount { get; set; }
Public Property DigitGroupingAmount As DigitGroupingAmount
    Get
    Set
public:
property DigitGroupingAmount DigitGroupingAmount {
    DigitGroupingAmount get ();
    void set (DigitGroupingAmount value);
}
member DigitGroupingAmount : DigitGroupingAmount with get, set

Property Value

DigitGroupingAmount
The number of digits in each group. The default is Three.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
This setting only has an effect when the UseDigitGrouping property is set to true in the FormatOptions object for the unit type being formatted.
See Also

Reference

Units Class


Units.DigitGroupingSymbol Property

UnitsDigitGroupingSymbol Property

The symbol used to separate groups of digits when numbers are formatted with digit grouping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DigitGroupingSymbol DigitGroupingSymbol { get; set; }
Public Property DigitGroupingSymbol As DigitGroupingSymbol
    Get
    Set
public:
property DigitGroupingSymbol DigitGroupingSymbol {
    DigitGroupingSymbol get ();
    void set (DigitGroupingSymbol value);
}
member DigitGroupingSymbol : DigitGroupingSymbol with get, set

Property Value

DigitGroupingSymbol
The digit grouping symbol. The default is Comma.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
This setting only has an effect when the UseDigitGrouping property is set to true in the FormatOptions object for the unit type being formatted.
See Also

Reference

Units Class


Units.IsValidObject Property

UnitsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

Units Class


Units Methods

The Units type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetFormatOptions | Gets the default FormatOptions for a spec.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
 | GetModifiableSpecs | Gets all specs for which the default FormatOptions can be modified.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | IsModifiableSpec | Checks whether the default FormatOptions can be modified for a given spec.
Public method | SetFormatOptions | Sets the default FormatOptions for a spec.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Units Class


Units.Dispose Method

UnitsDispose Method

Releases all resources used by the Units

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

Units Class


Units.GetFormatOptions Method

UnitsGetFormatOptions Method

Gets the default FormatOptions for a spec.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormatOptions GetFormatOptions(
    ForgeTypeId specTypeId
)
Public Function GetFormatOptions (
    specTypeId As ForgeTypeId
) As FormatOptions
public:
FormatOptions^ GetFormatOptions(
    ForgeTypeId^ specTypeId
)
member GetFormatOptions :
        specTypeId : ForgeTypeId -> FormatOptions

Parameters

specTypeId ForgeTypeId
Identifier of the spec.

Return Value

FormatOptions
A copy of the FormatOptions.
Exceptions
Exception | Condition
ArgumentException | specTypeId is not a measurable spec identifier. See UnitUtils.IsMeasurableSpec(ForgeTypeId).
ArgumentNullException | A non-optional argument was null
See Also

Reference

Units Class


Units.GetModifiableSpecs Method

UnitsGetModifiableSpecs Method

Gets all specs for which the default FormatOptions can be modified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<ForgeTypeId> GetModifiableSpecs()
Public Shared Function GetModifiableSpecs As IList(Of ForgeTypeId)
public:
static IList<ForgeTypeId^>^ GetModifiableSpecs()
static member GetModifiableSpecs : unit -> IList<ForgeTypeId>

Return Value

IList ForgeTypeId
Identifiers of the specs for which the FormatOptions can be modified.
See Also

Reference

Units Class


Units.IsModifiableSpec Method

UnitsIsModifiableSpec Method

Checks whether the default FormatOptions can be modified for a given spec.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsModifiableSpec(
    ForgeTypeId specTypeId
)
Public Shared Function IsModifiableSpec (
    specTypeId As ForgeTypeId
) As Boolean
public:
static bool IsModifiableSpec(
    ForgeTypeId^ specTypeId
)
static member IsModifiableSpec :
        specTypeId : ForgeTypeId -> bool

Parameters

specTypeId ForgeTypeId
Identifier of the spec to check.

Return Value

Boolean
True if the FormatOptions can be modified, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
The Units class stores a FormatOptions object for every spec, but not all of them can be directly modified. Some have fixed definitions.
See Also

Reference

Units Class


Units.SetFormatOptions Method

UnitsSetFormatOptions Method

Sets the default FormatOptions for a spec.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetFormatOptions(
    ForgeTypeId specTypeId,
    FormatOptions options
)
Public Sub SetFormatOptions (
    specTypeId As ForgeTypeId,
    options As FormatOptions
)
public:
void SetFormatOptions(
    ForgeTypeId^ specTypeId,
    FormatOptions^ options
)
member SetFormatOptions :
        specTypeId : ForgeTypeId *
        options : FormatOptions -> unit

Parameters

specTypeId ForgeTypeId
Identifier of the spec.
options FormatOptions
The FormatOptions.
Exceptions
Exception | Condition
ArgumentException | specTypeId is not a measurable spec identifier. See UnitUtils.IsMeasurableSpec(ForgeTypeId). -or- FormatOptions cannot be modified for specTypeId. See Units.IsModifiableSpec(ForgeTypeId) and Units.GetModifiableSpecs(). -or- UseDefault is true in options. -or- The unit in options is not valid for specTypeId. See UnitUtils.IsValidUnit(ForgeTypeId, ForgeTypeId) and UnitUtils.GetValidUnits(ForgeTypeId). -or- The rounding method in options is not set to Nearest.
ArgumentNullException | A non-optional argument was null
See Also

Reference

Units Class


UnitSystem Enumeration

A system of measurement: Metric or Imperial units.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum UnitSystem
Public Enumeration UnitSystem
public enum class UnitSystem
type UnitSystem
Members
Member name | Value | Description
Metric | 0 | Metric units.
Imperial | 1 | Imperial units.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


UnitTypeId Class

This class contains constants identifying units of measurement.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBUnitTypeId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class UnitTypeId
Public NotInheritable Class UnitTypeId
public ref class UnitTypeId abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type UnitTypeId = class end

The UnitTypeId type exposes the following members.

Properties
Name | Description
Acres | Acres.
Amperes | Amperes.
Atmospheres | Atmospheres.
Bars | Bars.
BritishThermalUnits | British thermal units.
BritishThermalUnitsPerDegreeFahrenheit | British thermal units per degree Fahrenheit.
BritishThermalUnitsPerHour | British thermal units per hour.
BritishThermalUnitsPerHourCubicFoot | British thermal units per hour cubic foot.
BritishThermalUnitsPerHourFootDegreeFahrenheit | British thermal units per hour foot degree Fahrenheit.
BritishThermalUnitsPerHourSquareFoot | British thermal units per hour square foot.
BritishThermalUnitsPerHourSquareFootDegreeFahrenheit | British thermal units per hour square foot degree Fahrenheit.
BritishThermalUnitsPerPound | British thermal units per pound.
BritishThermalUnitsPerPoundDegreeFahrenheit | British thermal units per pound degree Fahrenheit.
BritishThermalUnitsPerSecond | British thermal units per second.
BritishThermalUnitsPerSquareFootDegreeFahrenheit | British thermal units per square foot degree Fahrenheit.
Calories | Calories.
CaloriesPerSecond | Calories per second.
Candelas | Candelas.
CandelasPerSquareFoot | Candelas per square foot.
CandelasPerSquareMeter | Candelas per square meter.
Celsius | Celsius.
CelsiusInterval | Celsius interval.
Centimeters | Centimeters.
CentimetersPerMinute | Centimeters per minute.
CentimetersToTheFourthPower | Centimeters to the fourth power.
CentimetersToTheSixthPower | Centimeters to the sixth power.
Centipoises | Centipoises.
CubicCentimeters | Cubic centimeters.
CubicFeet | Cubic feet.
CubicFeetPerHour | Cubic feet per hour.
CubicFeetPerKip | Cubic feet per kip.
CubicFeetPerMinute | Cubic feet per minute.
CubicFeetPerMinuteCubicFoot | Cubic feet per minute cubic foot.
CubicFeetPerMinutePerBritishThermalUnitPerHour | Cubic feet per minute per British thermal unit per hour.
CubicFeetPerMinuteSquareFoot | Cubic feet per minute square foot.
CubicFeetPerMinuteTonOfRefrigeration | Cubic feet per minute ton of refrigeration.
CubicFeetPerPoundMass | Cubic feet per pound mass.
CubicInches | Cubic inches.
CubicMeters | Cubic meters.
CubicMetersPerHour | Cubic meters per hour.
CubicMetersPerHourCubicMeter | Cubic meters per hour cubic meter.
CubicMetersPerHourSquareMeter | Cubic meters per hour square meter.
CubicMetersPerKilogram | Cubic meters per kilogram.
CubicMetersPerKilonewton | Cubic meters per kilonewton.
CubicMetersPerSecond | Cubic meters per second.
CubicMetersPerWattSecond | Cubic meters per watt second.
CubicMillimeters | Cubic millimeters.
CubicYards | Cubic yards.
Currency | Currency.
CurrencyPerBritishThermalUnit | Cost per British thermal unit.
CurrencyPerBritishThermalUnitPerHour | Cost per British thermal unit per hour.
CurrencyPerSquareFoot | Cost per square foot.
CurrencyPerSquareMeter | Cost per square meter.
CurrencyPerWatt | Cost per watt.
CurrencyPerWattHour | Cost per watt hour.
Custom | Unrecognized custom unit.
CyclesPerSecond | Cycles per second.
Decimeters | Decimeters.
Degrees | Degrees.
DegreesMinutes | Degrees minutes seconds.
DekanewtonMeters | Dekanewton meters.
DekanewtonMetersPerMeter | Dekanewton meters per meter.
Dekanewtons | Dekanewtons.
DekanewtonsPerMeter | Dekanewtons per meter.
DekanewtonsPerSquareMeter | Dekanewtons per square meter.
Fahrenheit | Fahrenheit.
FahrenheitInterval | Fahrenheit interval.
Feet | Feet.
FeetFractionalInches | Feet and fractional inches.
FeetOfWater39_2DegreesFahrenheit | Feet of water (39.2 Â°F).
FeetOfWater39_2DegreesFahrenheitPer100Feet | Feet of water (39.2 Â°F) per 100 feet.
FeetPerKip | Feet per kip.
FeetPerMinute | Feet per minute.
FeetPerSecond | Feet per second.
FeetPerSecondSquared | Feet per second squared.
FeetToTheFourthPower | Feet to the fourth power.
FeetToTheSixthPower | Feet to the sixth power.
Fixed | Fixed.
Footcandles | Footcandles.
Footlamberts | Footlamberts.
FractionalInches | Fractional inches.
General | General.
Gigajoules | Gigajoules.
Gradians | Gradians.
GrainsPerHourSquareFootInchMercury | Grains per hour square foot inch mercury.
Hectares | Hectares.
Hertz | Hertz.
Horsepower | Horsepower.
Hours | Hours.
HourSquareFootDegreesFahrenheitPerBritishThermalUnit | Hour square foot degrees Fahrenheit per British thermal unit.
Inches | Inches.
InchesOfMercury32DegreesFahrenheit | Inches of mercury (32 Â°F).
InchesOfWater60DegreesFahrenheit | Inches of water (60 Â°F).
InchesOfWater60DegreesFahrenheitPer100Feet | Inches of water (60 Â°F) per 100 feet.
InchesPerSecondSquared | Inches per second squared.
InchesToTheFourthPower | Inches to the fourth power.
InchesToTheSixthPower | Inches to the sixth power.
InverseDegreesCelsius | Inverse degrees Celsius.
InverseDegreesFahrenheit | Inverse degrees Fahrenheit.
InverseKilonewtons | Inverse kilonewtons.
InverseKips | Inverse kips.
Joules | Joules.
JoulesPerGram | Joules per gram.
JoulesPerGramDegreeCelsius | Joules per gram degree Celsius.
JoulesPerKelvin | Joules per Kelvin.
JoulesPerKilogramDegreeCelsius | Joules per kilogram degree Celsius.
JoulesPerSquareMeterKelvin | Joules per square meter Kelvin.
Kelvin | Kelvin.
KelvinInterval | Kelvin interval.
Kiloamperes | Kiloamperes.
Kilocalories | Kilocalories.
KilocaloriesPerSecond | Kilocalories per second.
KilogramForceMeters | Kilogram force meters.
KilogramForceMetersPerMeter | Kilogram force meters per meter.
Kilograms | Kilograms.
KilogramsForce | Kilograms force.
KilogramsForcePerMeter | Kilograms force per meter.
KilogramsForcePerSquareMeter | Kilograms force per square meter.
KilogramsPerCubicMeter | Kilograms per cubic meter.
KilogramsPerHour | Kilograms per hour.
KilogramsPerKilogramKelvin | Kilograms per kilogram kelvin.
KilogramsPerMeter | Kilograms per meter.
KilogramsPerMeterHour | Kilograms per meter hour.
KilogramsPerMeterSecond | Kilograms per meter second.
KilogramsPerMinute | Kilograms per minute.
KilogramsPerSecond | Kilograms per second.
KilogramsPerSquareMeter | Kilograms per square meter.
Kilojoules | Kilojoules.
KilojoulesPerKelvin | Kilojoules per Kelvin.
KilojoulesPerSquareMeterKelvin | Kilojoules per square meter Kelvin.
KilometersPerHour | Kilometers per hour.
KilometersPerSecondSquared | Kilometers per second squared.
KilonewtonMeters | Kilonewton meters.
KilonewtonMetersPerDegree | Kilonewton meters per degree.
KilonewtonMetersPerDegreePerMeter | Kilonewton meters per degree per meter.
KilonewtonMetersPerMeter | Kilonewton meters per meter.
Kilonewtons | Kilonewtons.
KilonewtonsPerCubicMeter | Kilonewtons per cubic meter.
KilonewtonsPerMeter | Kilonewtons per meter.
KilonewtonsPerSquareCentimeter | Kilonewtons per square centimeter.
KilonewtonsPerSquareMeter | Kilonewtons per square meter.
KilonewtonsPerSquareMillimeter | Kilonewtons per square millimeter.
Kilopascals | Kilopascals.
KilovoltAmperes | Kilovolt amperes.
Kilovolts | Kilovolts.
KilowattHours | Kilowatt hours.
Kilowatts | Kilowatts.
KipFeet | Kip feet.
KipFeetPerDegree | Kip feet per degree.
KipFeetPerDegreePerFoot | Kip feet per degree per foot.
KipFeetPerFoot | Kip feet per foot.
Kips | Kips.
KipsPerCubicFoot | Kips per cubic foot.
KipsPerCubicInch | Kips per cubic inch.
KipsPerFoot | Kips per foot.
KipsPerInch | Kips per inch.
KipsPerSquareFoot | Kips per square foot.
KipsPerSquareInch | Kips per square inch.
Liters | Liters.
LitersPerHour | Liters per hour.
LitersPerMinute | Liters per minute.
LitersPerSecond | Liters per second.
LitersPerSecondCubicMeter | Liters per second cubic meter.
LitersPerSecondKilowatt | Liters per second kilowatt.
LitersPerSecondSquareMeter | Liters per second square meter.
Lumens | Lumens.
LumensPerWatt | Lumens per watt.
Lux | Lux.
Megajoules | Megajoules.
MeganewtonMeters | Meganewton meters.
MeganewtonMetersPerMeter | Meganewton meters per meter.
Meganewtons | Meganewtons.
MeganewtonsPerMeter | Meganewtons per meter.
MeganewtonsPerSquareMeter | Meganewtons per square meter.
Megapascals | Megapascals.
Megawatts | Megawatts.
Meters | Meters.
MetersCentimeters | Meters and centimeters.
MetersOfWaterColumn | Meters of water column.
MetersOfWaterColumnPerMeter | Meters of water column per meter.
MetersPerKilonewton | Meters per kilonewton.
MetersPerSecond | Meters per second.
MetersPerSecondSquared | Meters per second squared.
MetersToTheFourthPower | Meters to the fourth power.
MetersToTheSixthPower | Meters to the sixth power.
MicroinchesPerInchDegreeFahrenheit | Microinches per inch degree Fahrenheit.
MicrometersPerMeterDegreeCelsius | Micrometers per meter degree Celsius.
MilesPerHour | Miles per hour.
MilesPerSecondSquared | Miles per second squared.
Milliamperes | Milliamperes.
Millimeters | Millimeters.
MillimetersOfMercury | Millimeters of mercury.
MillimetersOfWaterColumn | Millimeters of water column.
MillimetersOfWaterColumnPerMeter | Millimeters of water column per meter.
MillimetersToTheFourthPower | Millimeters to the fourth power.
MillimetersToTheSixthPower | Millimeters to the sixth power.
Milliseconds | Milliseconds.
Millivolts | Millivolts.
Minutes | Minutes.
NanogramsPerPascalSecondSquareMeter | Nanograms per pascal second square meter.
NewtonMeters | Newton meters.
NewtonMetersPerMeter | Newton meters per meter.
Newtons | Newtons.
NewtonSecondsPerSquareMeter | Newton seconds per square meter.
NewtonsPerMeter | Newtons per meter.
NewtonsPerSquareMeter | Newtons per square meter.
NewtonsPerSquareMillimeter | Newtons per square millimeter.
OhmMeters | Ohm meters.
OneToRatio | 1 : Ratio.
Pascals | Pascals.
PascalSeconds | Pascal seconds.
PascalsPerMeter | Pascals per meter.
Percentage | Percentage.
PerMille | Per mille.
Pi | Multiples of Ï€.
PoundForceFeet | Pound force feet.
PoundForceFeetPerFoot | Pound force feet per foot.
PoundForceSecondsPerSquareFoot | Pound force seconds per square foot.
PoundsForce | Pounds force.
PoundsForcePerCubicFoot | Pounds force per cubic foot.
PoundsForcePerFoot | Pounds force per foot.
PoundsForcePerSquareFoot | Pounds force per square foot.
PoundsForcePerSquareInch | Pounds force per square inch.
PoundsMass | Pounds mass.
PoundsMassPerCubicFoot | Pounds mass per cubic foot.
PoundsMassPerCubicInch | Pounds mass per cubic inch.
PoundsMassPerFoot | Pounds mass per foot.
PoundsMassPerFootHour | Pounds mass per foot hour.
PoundsMassPerFootSecond | Pounds mass per foot second.
PoundsMassPerHour | Pounds mass per hour.
PoundsMassPerMinute | Pounds mass per minute.
PoundsMassPerPoundDegreeFahrenheit | Pounds mass per pound degree Fahrenheit.
PoundsMassPerSecond | Pounds mass per second.
PoundsMassPerSquareFoot | Pounds mass per square foot.
Radians | Radians.
RadiansPerSecond | Radians per second.
Rankine | Rankine.
RankineInterval | Rankine interval.
RatioTo1 | Ratio : 1.
RatioTo10 | Ratio : 10.
RatioTo12 | Ratio : 12.
RevolutionsPerMinute | Revolutions per minute.
RevolutionsPerSecond | Revolutions per second.
RiseDividedBy1000Millimeters | Rise / 1000 millimeters.
RiseDividedBy10Feet | Rise / 10 feet.
RiseDividedBy120Inches | Rise / 120 inches.
RiseDividedBy12Inches | Rise / 12 inches.
RiseDividedBy1Foot | Rise / 1 foot.
Seconds | Seconds.
Shaku | Shaku.
SlopeDegrees | Degrees.
SquareCentimeters | Square centimeters.
SquareCentimetersPerMeter | Square centimeters per meter.
SquareFeet | Square feet.
SquareFeetPer1000BritishThermalUnitsPerHour | Square feet per thousand British thermal units per hour.
SquareFeetPerFoot | Square feet per foot.
SquareFeetPerKip | Square feet per kip.
SquareFeetPerSecond | Square feet per second.
SquareFeetPerTonOfRefrigeration | Square feet per ton of refrigeration.
SquareInches | Square inches.
SquareInchesPerFoot | Square inches per foot.
SquareMeterKelvinsPerWatt | Square meter kelvins per watt.
SquareMeters | Square meters.
SquareMetersPerKilonewton | Square meters per kilonewton.
SquareMetersPerKilowatt | Square meters per kilowatt.
SquareMetersPerMeter | Square meters per meter.
SquareMetersPerSecond | Square meters per second.
SquareMillimeters | Square millimeters.
SquareMillimetersPerMeter | Square millimeters per meter.
StationingFeet | Feet.
StationingMeters | Meters.
StationingSurveyFeet | US survey feet.
Therms | Therms.
ThousandBritishThermalUnitsPerHour | Thousand British thermal units per hour.
TonneForceMeters | Tonne force meters.
TonneForceMetersPerMeter | Tonne force meters per meter.
Tonnes | Tonnes.
TonnesForce | Tonnes force.
TonnesForcePerMeter | Tonnes force per meter.
TonnesForcePerSquareMeter | Tonnes force per square meter.
TonsOfRefrigeration | Tons of refrigeration.
UsGallons | US gallons.
UsGallonsPerHour | US gallons per hour.
UsGallonsPerMinute | US gallons per minute.
UsSurveyFeet | US survey feet.
UsTonnesForce | US tonnes force.
UsTonnesMass | US tonnes mass.
VoltAmperes | Volt amperes.
VoltAmperesPerSquareFoot | Volt amperes per square foot.
VoltAmperesPerSquareMeter | Volt amperes per square meter.
Volts | Volts.
Watts | Watts.
WattsPerCubicFoot | Watts per cubic foot.
WattsPerCubicFootPerMinute | Watts per cubic foot per minute.
WattsPerCubicMeter | Watts per cubic meter.
WattsPerCubicMeterPerSecond | Watts per cubic meter per second.
WattsPerFoot | Watts per foot.
WattsPerMeter | Watts per meter.
WattsPerMeterKelvin | Watts per meter kelvin.
WattsPerSquareFoot | Watts per square foot.
WattsPerSquareMeter | Watts per square meter.
WattsPerSquareMeterKelvin | Watts per square meter kelvin.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


UnitTypeId Properties

The UnitTypeId type exposes the following members.

Properties
Name | Description
Acres | Acres.
Amperes | Amperes.
Atmospheres | Atmospheres.
Bars | Bars.
BritishThermalUnits | British thermal units.
BritishThermalUnitsPerDegreeFahrenheit | British thermal units per degree Fahrenheit.
BritishThermalUnitsPerHour | British thermal units per hour.
BritishThermalUnitsPerHourCubicFoot | British thermal units per hour cubic foot.
BritishThermalUnitsPerHourFootDegreeFahrenheit | British thermal units per hour foot degree Fahrenheit.
BritishThermalUnitsPerHourSquareFoot | British thermal units per hour square foot.
BritishThermalUnitsPerHourSquareFootDegreeFahrenheit | British thermal units per hour square foot degree Fahrenheit.
BritishThermalUnitsPerPound | British thermal units per pound.
BritishThermalUnitsPerPoundDegreeFahrenheit | British thermal units per pound degree Fahrenheit.
BritishThermalUnitsPerSecond | British thermal units per second.
BritishThermalUnitsPerSquareFootDegreeFahrenheit | British thermal units per square foot degree Fahrenheit.
Calories | Calories.
CaloriesPerSecond | Calories per second.
Candelas | Candelas.
CandelasPerSquareFoot | Candelas per square foot.
CandelasPerSquareMeter | Candelas per square meter.
Celsius | Celsius.
CelsiusInterval | Celsius interval.
Centimeters | Centimeters.
CentimetersPerMinute | Centimeters per minute.
CentimetersToTheFourthPower | Centimeters to the fourth power.
CentimetersToTheSixthPower | Centimeters to the sixth power.
Centipoises | Centipoises.
CubicCentimeters | Cubic centimeters.
CubicFeet | Cubic feet.
CubicFeetPerHour | Cubic feet per hour.
CubicFeetPerKip | Cubic feet per kip.
CubicFeetPerMinute | Cubic feet per minute.
CubicFeetPerMinuteCubicFoot | Cubic feet per minute cubic foot.
CubicFeetPerMinutePerBritishThermalUnitPerHour | Cubic feet per minute per British thermal unit per hour.
CubicFeetPerMinuteSquareFoot | Cubic feet per minute square foot.
CubicFeetPerMinuteTonOfRefrigeration | Cubic feet per minute ton of refrigeration.
CubicFeetPerPoundMass | Cubic feet per pound mass.
CubicInches | Cubic inches.
CubicMeters | Cubic meters.
CubicMetersPerHour | Cubic meters per hour.
CubicMetersPerHourCubicMeter | Cubic meters per hour cubic meter.
CubicMetersPerHourSquareMeter | Cubic meters per hour square meter.
CubicMetersPerKilogram | Cubic meters per kilogram.
CubicMetersPerKilonewton | Cubic meters per kilonewton.
CubicMetersPerSecond | Cubic meters per second.
CubicMetersPerWattSecond | Cubic meters per watt second.
CubicMillimeters | Cubic millimeters.
CubicYards | Cubic yards.
Currency | Currency.
CurrencyPerBritishThermalUnit | Cost per British thermal unit.
CurrencyPerBritishThermalUnitPerHour | Cost per British thermal unit per hour.
CurrencyPerSquareFoot | Cost per square foot.
CurrencyPerSquareMeter | Cost per square meter.
CurrencyPerWatt | Cost per watt.
CurrencyPerWattHour | Cost per watt hour.
Custom | Unrecognized custom unit.
CyclesPerSecond | Cycles per second.
Decimeters | Decimeters.
Degrees | Degrees.
DegreesMinutes | Degrees minutes seconds.
DekanewtonMeters | Dekanewton meters.
DekanewtonMetersPerMeter | Dekanewton meters per meter.
Dekanewtons | Dekanewtons.
DekanewtonsPerMeter | Dekanewtons per meter.
DekanewtonsPerSquareMeter | Dekanewtons per square meter.
Fahrenheit | Fahrenheit.
FahrenheitInterval | Fahrenheit interval.
Feet | Feet.
FeetFractionalInches | Feet and fractional inches.
FeetOfWater39_2DegreesFahrenheit | Feet of water (39.2 Â°F).
FeetOfWater39_2DegreesFahrenheitPer100Feet | Feet of water (39.2 Â°F) per 100 feet.
FeetPerKip | Feet per kip.
FeetPerMinute | Feet per minute.
FeetPerSecond | Feet per second.
FeetPerSecondSquared | Feet per second squared.
FeetToTheFourthPower | Feet to the fourth power.
FeetToTheSixthPower | Feet to the sixth power.
Fixed | Fixed.
Footcandles | Footcandles.
Footlamberts | Footlamberts.
FractionalInches | Fractional inches.
General | General.
Gigajoules | Gigajoules.
Gradians | Gradians.
GrainsPerHourSquareFootInchMercury | Grains per hour square foot inch mercury.
Hectares | Hectares.
Hertz | Hertz.
Horsepower | Horsepower.
Hours | Hours.
HourSquareFootDegreesFahrenheitPerBritishThermalUnit | Hour square foot degrees Fahrenheit per British thermal unit.
Inches | Inches.
InchesOfMercury32DegreesFahrenheit | Inches of mercury (32 Â°F).
InchesOfWater60DegreesFahrenheit | Inches of water (60 Â°F).
InchesOfWater60DegreesFahrenheitPer100Feet | Inches of water (60 Â°F) per 100 feet.
InchesPerSecondSquared | Inches per second squared.
InchesToTheFourthPower | Inches to the fourth power.
InchesToTheSixthPower | Inches to the sixth power.
InverseDegreesCelsius | Inverse degrees Celsius.
InverseDegreesFahrenheit | Inverse degrees Fahrenheit.
InverseKilonewtons | Inverse kilonewtons.
InverseKips | Inverse kips.
Joules | Joules.
JoulesPerGram | Joules per gram.
JoulesPerGramDegreeCelsius | Joules per gram degree Celsius.
JoulesPerKelvin | Joules per Kelvin.
JoulesPerKilogramDegreeCelsius | Joules per kilogram degree Celsius.
JoulesPerSquareMeterKelvin | Joules per square meter Kelvin.
Kelvin | Kelvin.
KelvinInterval | Kelvin interval.
Kiloamperes | Kiloamperes.
Kilocalories | Kilocalories.
KilocaloriesPerSecond | Kilocalories per second.
KilogramForceMeters | Kilogram force meters.
KilogramForceMetersPerMeter | Kilogram force meters per meter.
Kilograms | Kilograms.
KilogramsForce | Kilograms force.
KilogramsForcePerMeter | Kilograms force per meter.
KilogramsForcePerSquareMeter | Kilograms force per square meter.
KilogramsPerCubicMeter | Kilograms per cubic meter.
KilogramsPerHour | Kilograms per hour.
KilogramsPerKilogramKelvin | Kilograms per kilogram kelvin.
KilogramsPerMeter | Kilograms per meter.
KilogramsPerMeterHour | Kilograms per meter hour.
KilogramsPerMeterSecond | Kilograms per meter second.
KilogramsPerMinute | Kilograms per minute.
KilogramsPerSecond | Kilograms per second.
KilogramsPerSquareMeter | Kilograms per square meter.
Kilojoules | Kilojoules.
KilojoulesPerKelvin | Kilojoules per Kelvin.
KilojoulesPerSquareMeterKelvin | Kilojoules per square meter Kelvin.
KilometersPerHour | Kilometers per hour.
KilometersPerSecondSquared | Kilometers per second squared.
KilonewtonMeters | Kilonewton meters.
KilonewtonMetersPerDegree | Kilonewton meters per degree.
KilonewtonMetersPerDegreePerMeter | Kilonewton meters per degree per meter.
KilonewtonMetersPerMeter | Kilonewton meters per meter.
Kilonewtons | Kilonewtons.
KilonewtonsPerCubicMeter | Kilonewtons per cubic meter.
KilonewtonsPerMeter | Kilonewtons per meter.
KilonewtonsPerSquareCentimeter | Kilonewtons per square centimeter.
KilonewtonsPerSquareMeter | Kilonewtons per square meter.
KilonewtonsPerSquareMillimeter | Kilonewtons per square millimeter.
Kilopascals | Kilopascals.
KilovoltAmperes | Kilovolt amperes.
Kilovolts | Kilovolts.
KilowattHours | Kilowatt hours.
Kilowatts | Kilowatts.
KipFeet | Kip feet.
KipFeetPerDegree | Kip feet per degree.
KipFeetPerDegreePerFoot | Kip feet per degree per foot.
KipFeetPerFoot | Kip feet per foot.
Kips | Kips.
KipsPerCubicFoot | Kips per cubic foot.
KipsPerCubicInch | Kips per cubic inch.
KipsPerFoot | Kips per foot.
KipsPerInch | Kips per inch.
KipsPerSquareFoot | Kips per square foot.
KipsPerSquareInch | Kips per square inch.
Liters | Liters.
LitersPerHour | Liters per hour.
LitersPerMinute | Liters per minute.
LitersPerSecond | Liters per second.
LitersPerSecondCubicMeter | Liters per second cubic meter.
LitersPerSecondKilowatt | Liters per second kilowatt.
LitersPerSecondSquareMeter | Liters per second square meter.
Lumens | Lumens.
LumensPerWatt | Lumens per watt.
Lux | Lux.
Megajoules | Megajoules.
MeganewtonMeters | Meganewton meters.
MeganewtonMetersPerMeter | Meganewton meters per meter.
Meganewtons | Meganewtons.
MeganewtonsPerMeter | Meganewtons per meter.
MeganewtonsPerSquareMeter | Meganewtons per square meter.
Megapascals | Megapascals.
Megawatts | Megawatts.
Meters | Meters.
MetersCentimeters | Meters and centimeters.
MetersOfWaterColumn | Meters of water column.
MetersOfWaterColumnPerMeter | Meters of water column per meter.
MetersPerKilonewton | Meters per kilonewton.
MetersPerSecond | Meters per second.
MetersPerSecondSquared | Meters per second squared.
MetersToTheFourthPower | Meters to the fourth power.
MetersToTheSixthPower | Meters to the sixth power.
MicroinchesPerInchDegreeFahrenheit | Microinches per inch degree Fahrenheit.
MicrometersPerMeterDegreeCelsius | Micrometers per meter degree Celsius.
MilesPerHour | Miles per hour.
MilesPerSecondSquared | Miles per second squared.
Milliamperes | Milliamperes.
Millimeters | Millimeters.
MillimetersOfMercury | Millimeters of mercury.
MillimetersOfWaterColumn | Millimeters of water column.
MillimetersOfWaterColumnPerMeter | Millimeters of water column per meter.
MillimetersToTheFourthPower | Millimeters to the fourth power.
MillimetersToTheSixthPower | Millimeters to the sixth power.
Milliseconds | Milliseconds.
Millivolts | Millivolts.
Minutes | Minutes.
NanogramsPerPascalSecondSquareMeter | Nanograms per pascal second square meter.
NewtonMeters | Newton meters.
NewtonMetersPerMeter | Newton meters per meter.
Newtons | Newtons.
NewtonSecondsPerSquareMeter | Newton seconds per square meter.
NewtonsPerMeter | Newtons per meter.
NewtonsPerSquareMeter | Newtons per square meter.
NewtonsPerSquareMillimeter | Newtons per square millimeter.
OhmMeters | Ohm meters.
OneToRatio | 1 : Ratio.
Pascals | Pascals.
PascalSeconds | Pascal seconds.
PascalsPerMeter | Pascals per meter.
Percentage | Percentage.
PerMille | Per mille.
Pi | Multiples of Ï€.
PoundForceFeet | Pound force feet.
PoundForceFeetPerFoot | Pound force feet per foot.
PoundForceSecondsPerSquareFoot | Pound force seconds per square foot.
PoundsForce | Pounds force.
PoundsForcePerCubicFoot | Pounds force per cubic foot.
PoundsForcePerFoot | Pounds force per foot.
PoundsForcePerSquareFoot | Pounds force per square foot.
PoundsForcePerSquareInch | Pounds force per square inch.
PoundsMass | Pounds mass.
PoundsMassPerCubicFoot | Pounds mass per cubic foot.
PoundsMassPerCubicInch | Pounds mass per cubic inch.
PoundsMassPerFoot | Pounds mass per foot.
PoundsMassPerFootHour | Pounds mass per foot hour.
PoundsMassPerFootSecond | Pounds mass per foot second.
PoundsMassPerHour | Pounds mass per hour.
PoundsMassPerMinute | Pounds mass per minute.
PoundsMassPerPoundDegreeFahrenheit | Pounds mass per pound degree Fahrenheit.
PoundsMassPerSecond | Pounds mass per second.
PoundsMassPerSquareFoot | Pounds mass per square foot.
Radians | Radians.
RadiansPerSecond | Radians per second.
Rankine | Rankine.
RankineInterval | Rankine interval.
RatioTo1 | Ratio : 1.
RatioTo10 | Ratio : 10.
RatioTo12 | Ratio : 12.
RevolutionsPerMinute | Revolutions per minute.
RevolutionsPerSecond | Revolutions per second.
RiseDividedBy1000Millimeters | Rise / 1000 millimeters.
RiseDividedBy10Feet | Rise / 10 feet.
RiseDividedBy120Inches | Rise / 120 inches.
RiseDividedBy12Inches | Rise / 12 inches.
RiseDividedBy1Foot | Rise / 1 foot.
Seconds | Seconds.
Shaku | Shaku.
SlopeDegrees | Degrees.
SquareCentimeters | Square centimeters.
SquareCentimetersPerMeter | Square centimeters per meter.
SquareFeet | Square feet.
SquareFeetPer1000BritishThermalUnitsPerHour | Square feet per thousand British thermal units per hour.
SquareFeetPerFoot | Square feet per foot.
SquareFeetPerKip | Square feet per kip.
SquareFeetPerSecond | Square feet per second.
SquareFeetPerTonOfRefrigeration | Square feet per ton of refrigeration.
SquareInches | Square inches.
SquareInchesPerFoot | Square inches per foot.
SquareMeterKelvinsPerWatt | Square meter kelvins per watt.
SquareMeters | Square meters.
SquareMetersPerKilonewton | Square meters per kilonewton.
SquareMetersPerKilowatt | Square meters per kilowatt.
SquareMetersPerMeter | Square meters per meter.
SquareMetersPerSecond | Square meters per second.
SquareMillimeters | Square millimeters.
SquareMillimetersPerMeter | Square millimeters per meter.
StationingFeet | Feet.
StationingMeters | Meters.
StationingSurveyFeet | US survey feet.
Therms | Therms.
ThousandBritishThermalUnitsPerHour | Thousand British thermal units per hour.
TonneForceMeters | Tonne force meters.
TonneForceMetersPerMeter | Tonne force meters per meter.
Tonnes | Tonnes.
TonnesForce | Tonnes force.
TonnesForcePerMeter | Tonnes force per meter.
TonnesForcePerSquareMeter | Tonnes force per square meter.
TonsOfRefrigeration | Tons of refrigeration.
UsGallons | US gallons.
UsGallonsPerHour | US gallons per hour.
UsGallonsPerMinute | US gallons per minute.
UsSurveyFeet | US survey feet.
UsTonnesForce | US tonnes force.
UsTonnesMass | US tonnes mass.
VoltAmperes | Volt amperes.
VoltAmperesPerSquareFoot | Volt amperes per square foot.
VoltAmperesPerSquareMeter | Volt amperes per square meter.
Volts | Volts.
Watts | Watts.
WattsPerCubicFoot | Watts per cubic foot.
WattsPerCubicFootPerMinute | Watts per cubic foot per minute.
WattsPerCubicMeter | Watts per cubic meter.
WattsPerCubicMeterPerSecond | Watts per cubic meter per second.
WattsPerFoot | Watts per foot.
WattsPerMeter | Watts per meter.
WattsPerMeterKelvin | Watts per meter kelvin.
WattsPerSquareFoot | Watts per square foot.
WattsPerSquareMeter | Watts per square meter.
WattsPerSquareMeterKelvin | Watts per square meter kelvin.
Top
See Also

Reference

UnitTypeId Class


UnitTypeId.Acres Property

UnitTypeIdAcres Property

Acres.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Acres { get; }
Public Shared ReadOnly Property Acres As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Acres {
    ForgeTypeId^ get ();
}
static member Acres : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Amperes Property

UnitTypeIdAmperes Property

Amperes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Amperes { get; }
Public Shared ReadOnly Property Amperes As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Amperes {
    ForgeTypeId^ get ();
}
static member Amperes : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Atmospheres Property

UnitTypeIdAtmospheres Property

Atmospheres.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Atmospheres { get; }
Public Shared ReadOnly Property Atmospheres As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Atmospheres {
    ForgeTypeId^ get ();
}
static member Atmospheres : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Bars Property

UnitTypeIdBars Property

Bars.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Bars { get; }
Public Shared ReadOnly Property Bars As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Bars {
    ForgeTypeId^ get ();
}
static member Bars : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.BritishThermalUnits Property

UnitTypeIdBritishThermalUnits Property

British thermal units.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BritishThermalUnits { get; }
Public Shared ReadOnly Property BritishThermalUnits As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BritishThermalUnits {
    ForgeTypeId^ get ();
}
static member BritishThermalUnits : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.BritishThermalUnitsPerDegreeFahrenheit Property

UnitTypeIdBritishThermalUnitsPerDegreeFahrenheit Property

British thermal units per degree Fahrenheit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BritishThermalUnitsPerDegreeFahrenheit { get; }
Public Shared ReadOnly Property BritishThermalUnitsPerDegreeFahrenheit As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BritishThermalUnitsPerDegreeFahrenheit {
    ForgeTypeId^ get ();
}
static member BritishThermalUnitsPerDegreeFahrenheit : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.BritishThermalUnitsPerHour Property

UnitTypeIdBritishThermalUnitsPerHour Property

British thermal units per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BritishThermalUnitsPerHour { get; }
Public Shared ReadOnly Property BritishThermalUnitsPerHour As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BritishThermalUnitsPerHour {
    ForgeTypeId^ get ();
}
static member BritishThermalUnitsPerHour : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.BritishThermalUnitsPerHourCubicFoot Property

UnitTypeIdBritishThermalUnitsPerHourCubicFoot Property

British thermal units per hour cubic foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BritishThermalUnitsPerHourCubicFoot { get; }
Public Shared ReadOnly Property BritishThermalUnitsPerHourCubicFoot As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BritishThermalUnitsPerHourCubicFoot {
    ForgeTypeId^ get ();
}
static member BritishThermalUnitsPerHourCubicFoot : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.BritishThermalUnitsPerHourFootDegreeFahrenheit Property

UnitTypeIdBritishThermalUnitsPerHourFootDegreeFahrenheit Property

British thermal units per hour foot degree Fahrenheit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BritishThermalUnitsPerHourFootDegreeFahrenheit { get; }
Public Shared ReadOnly Property BritishThermalUnitsPerHourFootDegreeFahrenheit As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BritishThermalUnitsPerHourFootDegreeFahrenheit {
    ForgeTypeId^ get ();
}
static member BritishThermalUnitsPerHourFootDegreeFahrenheit : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.BritishThermalUnitsPerHourSquareFoot Property

UnitTypeIdBritishThermalUnitsPerHourSquareFoot Property

British thermal units per hour square foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BritishThermalUnitsPerHourSquareFoot { get; }
Public Shared ReadOnly Property BritishThermalUnitsPerHourSquareFoot As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BritishThermalUnitsPerHourSquareFoot {
    ForgeTypeId^ get ();
}
static member BritishThermalUnitsPerHourSquareFoot : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.BritishThermalUnitsPerHourSquareFootDegreeFahrenheit Property

UnitTypeIdBritishThermalUnitsPerHourSquareFootDegreeFahrenheit Property

British thermal units per hour square foot degree Fahrenheit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BritishThermalUnitsPerHourSquareFootDegreeFahrenheit { get; }
Public Shared ReadOnly Property BritishThermalUnitsPerHourSquareFootDegreeFahrenheit As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BritishThermalUnitsPerHourSquareFootDegreeFahrenheit {
    ForgeTypeId^ get ();
}
static member BritishThermalUnitsPerHourSquareFootDegreeFahrenheit : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.BritishThermalUnitsPerPound Property

UnitTypeIdBritishThermalUnitsPerPound Property

British thermal units per pound.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BritishThermalUnitsPerPound { get; }
Public Shared ReadOnly Property BritishThermalUnitsPerPound As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BritishThermalUnitsPerPound {
    ForgeTypeId^ get ();
}
static member BritishThermalUnitsPerPound : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.BritishThermalUnitsPerPoundDegreeFahrenheit Property

UnitTypeIdBritishThermalUnitsPerPoundDegreeFahrenheit Property

British thermal units per pound degree Fahrenheit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BritishThermalUnitsPerPoundDegreeFahrenheit { get; }
Public Shared ReadOnly Property BritishThermalUnitsPerPoundDegreeFahrenheit As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BritishThermalUnitsPerPoundDegreeFahrenheit {
    ForgeTypeId^ get ();
}
static member BritishThermalUnitsPerPoundDegreeFahrenheit : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.BritishThermalUnitsPerSecond Property

UnitTypeIdBritishThermalUnitsPerSecond Property

British thermal units per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BritishThermalUnitsPerSecond { get; }
Public Shared ReadOnly Property BritishThermalUnitsPerSecond As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BritishThermalUnitsPerSecond {
    ForgeTypeId^ get ();
}
static member BritishThermalUnitsPerSecond : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.BritishThermalUnitsPerSquareFootDegreeFahrenheit Property

UnitTypeIdBritishThermalUnitsPerSquareFootDegreeFahrenheit Property

British thermal units per square foot degree Fahrenheit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId BritishThermalUnitsPerSquareFootDegreeFahrenheit { get; }
Public Shared ReadOnly Property BritishThermalUnitsPerSquareFootDegreeFahrenheit As ForgeTypeId
    Get
public:
static property ForgeTypeId^ BritishThermalUnitsPerSquareFootDegreeFahrenheit {
    ForgeTypeId^ get ();
}
static member BritishThermalUnitsPerSquareFootDegreeFahrenheit : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Calories Property

UnitTypeIdCalories Property

Calories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Calories { get; }
Public Shared ReadOnly Property Calories As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Calories {
    ForgeTypeId^ get ();
}
static member Calories : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.CaloriesPerSecond Property

UnitTypeIdCaloriesPerSecond Property

Calories per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CaloriesPerSecond { get; }
Public Shared ReadOnly Property CaloriesPerSecond As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CaloriesPerSecond {
    ForgeTypeId^ get ();
}
static member CaloriesPerSecond : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Candelas Property

UnitTypeIdCandelas Property

Candelas.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Candelas { get; }
Public Shared ReadOnly Property Candelas As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Candelas {
    ForgeTypeId^ get ();
}
static member Candelas : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.CandelasPerSquareFoot Property

UnitTypeIdCandelasPerSquareFoot Property

Candelas per square foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CandelasPerSquareFoot { get; }
Public Shared ReadOnly Property CandelasPerSquareFoot As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CandelasPerSquareFoot {
    ForgeTypeId^ get ();
}
static member CandelasPerSquareFoot : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.CandelasPerSquareMeter Property

UnitTypeIdCandelasPerSquareMeter Property

Candelas per square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CandelasPerSquareMeter { get; }
Public Shared ReadOnly Property CandelasPerSquareMeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CandelasPerSquareMeter {
    ForgeTypeId^ get ();
}
static member CandelasPerSquareMeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Celsius Property

UnitTypeIdCelsius Property

Celsius.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Celsius { get; }
Public Shared ReadOnly Property Celsius As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Celsius {
    ForgeTypeId^ get ();
}
static member Celsius : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.CelsiusInterval Property

UnitTypeIdCelsiusInterval Property

Celsius interval.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CelsiusInterval { get; }
Public Shared ReadOnly Property CelsiusInterval As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CelsiusInterval {
    ForgeTypeId^ get ();
}
static member CelsiusInterval : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Centimeters Property

UnitTypeIdCentimeters Property

Centimeters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Centimeters { get; }
Public Shared ReadOnly Property Centimeters As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Centimeters {
    ForgeTypeId^ get ();
}
static member Centimeters : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.CentimetersPerMinute Property

UnitTypeIdCentimetersPerMinute Property

Centimeters per minute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CentimetersPerMinute { get; }
Public Shared ReadOnly Property CentimetersPerMinute As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CentimetersPerMinute {
    ForgeTypeId^ get ();
}
static member CentimetersPerMinute : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.CentimetersToTheFourthPower Property

UnitTypeIdCentimetersToTheFourthPower Property

Centimeters to the fourth power.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CentimetersToTheFourthPower { get; }
Public Shared ReadOnly Property CentimetersToTheFourthPower As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CentimetersToTheFourthPower {
    ForgeTypeId^ get ();
}
static member CentimetersToTheFourthPower : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.CentimetersToTheSixthPower Property

UnitTypeIdCentimetersToTheSixthPower Property

Centimeters to the sixth power.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CentimetersToTheSixthPower { get; }
Public Shared ReadOnly Property CentimetersToTheSixthPower As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CentimetersToTheSixthPower {
    ForgeTypeId^ get ();
}
static member CentimetersToTheSixthPower : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Centipoises Property

UnitTypeIdCentipoises Property

Centipoises.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Centipoises { get; }
Public Shared ReadOnly Property Centipoises As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Centipoises {
    ForgeTypeId^ get ();
}
static member Centipoises : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.CubicCentimeters Property

UnitTypeIdCubicCentimeters Property

Cubic centimeters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CubicCentimeters { get; }
Public Shared ReadOnly Property CubicCentimeters As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CubicCentimeters {
    ForgeTypeId^ get ();
}
static member CubicCentimeters : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.CubicFeet Property

UnitTypeIdCubicFeet Property

Cubic feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CubicFeet { get; }
Public Shared ReadOnly Property CubicFeet As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CubicFeet {
    ForgeTypeId^ get ();
}
static member CubicFeet : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.CubicFeetPerHour Property

UnitTypeIdCubicFeetPerHour Property

Cubic feet per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CubicFeetPerHour { get; }
Public Shared ReadOnly Property CubicFeetPerHour As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CubicFeetPerHour {
    ForgeTypeId^ get ();
}
static member CubicFeetPerHour : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.CubicFeetPerKip Property

UnitTypeIdCubicFeetPerKip Property

Cubic feet per kip.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CubicFeetPerKip { get; }
Public Shared ReadOnly Property CubicFeetPerKip As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CubicFeetPerKip {
    ForgeTypeId^ get ();
}
static member CubicFeetPerKip : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.CubicFeetPerMinute Property

UnitTypeIdCubicFeetPerMinute Property

Cubic feet per minute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CubicFeetPerMinute { get; }
Public Shared ReadOnly Property CubicFeetPerMinute As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CubicFeetPerMinute {
    ForgeTypeId^ get ();
}
static member CubicFeetPerMinute : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.CubicFeetPerMinuteCubicFoot Property

UnitTypeIdCubicFeetPerMinuteCubicFoot Property

Cubic feet per minute cubic foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CubicFeetPerMinuteCubicFoot { get; }
Public Shared ReadOnly Property CubicFeetPerMinuteCubicFoot As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CubicFeetPerMinuteCubicFoot {
    ForgeTypeId^ get ();
}
static member CubicFeetPerMinuteCubicFoot : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.CubicFeetPerMinutePerBritishThermalUnitPerHour Property

UnitTypeIdCubicFeetPerMinutePerBritishThermalUnitPerHour Property

Cubic feet per minute per British thermal unit per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CubicFeetPerMinutePerBritishThermalUnitPerHour { get; }
Public Shared ReadOnly Property CubicFeetPerMinutePerBritishThermalUnitPerHour As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CubicFeetPerMinutePerBritishThermalUnitPerHour {
    ForgeTypeId^ get ();
}
static member CubicFeetPerMinutePerBritishThermalUnitPerHour : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.CubicFeetPerMinuteSquareFoot Property

UnitTypeIdCubicFeetPerMinuteSquareFoot Property

Cubic feet per minute square foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CubicFeetPerMinuteSquareFoot { get; }
Public Shared ReadOnly Property CubicFeetPerMinuteSquareFoot As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CubicFeetPerMinuteSquareFoot {
    ForgeTypeId^ get ();
}
static member CubicFeetPerMinuteSquareFoot : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.CubicFeetPerMinuteTonOfRefrigeration Property

UnitTypeIdCubicFeetPerMinuteTonOfRefrigeration Property

Cubic feet per minute ton of refrigeration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CubicFeetPerMinuteTonOfRefrigeration { get; }
Public Shared ReadOnly Property CubicFeetPerMinuteTonOfRefrigeration As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CubicFeetPerMinuteTonOfRefrigeration {
    ForgeTypeId^ get ();
}
static member CubicFeetPerMinuteTonOfRefrigeration : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.CubicFeetPerPoundMass Property

UnitTypeIdCubicFeetPerPoundMass Property

Cubic feet per pound mass.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CubicFeetPerPoundMass { get; }
Public Shared ReadOnly Property CubicFeetPerPoundMass As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CubicFeetPerPoundMass {
    ForgeTypeId^ get ();
}
static member CubicFeetPerPoundMass : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.CubicInches Property

UnitTypeIdCubicInches Property

Cubic inches.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CubicInches { get; }
Public Shared ReadOnly Property CubicInches As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CubicInches {
    ForgeTypeId^ get ();
}
static member CubicInches : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.CubicMeters Property

UnitTypeIdCubicMeters Property

Cubic meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CubicMeters { get; }
Public Shared ReadOnly Property CubicMeters As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CubicMeters {
    ForgeTypeId^ get ();
}
static member CubicMeters : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.CubicMetersPerHour Property

UnitTypeIdCubicMetersPerHour Property

Cubic meters per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CubicMetersPerHour { get; }
Public Shared ReadOnly Property CubicMetersPerHour As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CubicMetersPerHour {
    ForgeTypeId^ get ();
}
static member CubicMetersPerHour : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.CubicMetersPerHourCubicMeter Property

UnitTypeIdCubicMetersPerHourCubicMeter Property

Cubic meters per hour cubic meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CubicMetersPerHourCubicMeter { get; }
Public Shared ReadOnly Property CubicMetersPerHourCubicMeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CubicMetersPerHourCubicMeter {
    ForgeTypeId^ get ();
}
static member CubicMetersPerHourCubicMeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.CubicMetersPerHourSquareMeter Property

UnitTypeIdCubicMetersPerHourSquareMeter Property

Cubic meters per hour square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CubicMetersPerHourSquareMeter { get; }
Public Shared ReadOnly Property CubicMetersPerHourSquareMeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CubicMetersPerHourSquareMeter {
    ForgeTypeId^ get ();
}
static member CubicMetersPerHourSquareMeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.CubicMetersPerKilogram Property

UnitTypeIdCubicMetersPerKilogram Property

Cubic meters per kilogram.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CubicMetersPerKilogram { get; }
Public Shared ReadOnly Property CubicMetersPerKilogram As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CubicMetersPerKilogram {
    ForgeTypeId^ get ();
}
static member CubicMetersPerKilogram : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.CubicMetersPerKilonewton Property

UnitTypeIdCubicMetersPerKilonewton Property

Cubic meters per kilonewton.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CubicMetersPerKilonewton { get; }
Public Shared ReadOnly Property CubicMetersPerKilonewton As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CubicMetersPerKilonewton {
    ForgeTypeId^ get ();
}
static member CubicMetersPerKilonewton : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.CubicMetersPerSecond Property

UnitTypeIdCubicMetersPerSecond Property

Cubic meters per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CubicMetersPerSecond { get; }
Public Shared ReadOnly Property CubicMetersPerSecond As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CubicMetersPerSecond {
    ForgeTypeId^ get ();
}
static member CubicMetersPerSecond : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.CubicMetersPerWattSecond Property

UnitTypeIdCubicMetersPerWattSecond Property

Cubic meters per watt second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CubicMetersPerWattSecond { get; }
Public Shared ReadOnly Property CubicMetersPerWattSecond As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CubicMetersPerWattSecond {
    ForgeTypeId^ get ();
}
static member CubicMetersPerWattSecond : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.CubicMillimeters Property

UnitTypeIdCubicMillimeters Property

Cubic millimeters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CubicMillimeters { get; }
Public Shared ReadOnly Property CubicMillimeters As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CubicMillimeters {
    ForgeTypeId^ get ();
}
static member CubicMillimeters : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.CubicYards Property

UnitTypeIdCubicYards Property

Cubic yards.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CubicYards { get; }
Public Shared ReadOnly Property CubicYards As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CubicYards {
    ForgeTypeId^ get ();
}
static member CubicYards : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Currency Property

UnitTypeIdCurrency Property

Currency.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Currency { get; }
Public Shared ReadOnly Property Currency As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Currency {
    ForgeTypeId^ get ();
}
static member Currency : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.CurrencyPerBritishThermalUnit Property

UnitTypeIdCurrencyPerBritishThermalUnit Property

Cost per British thermal unit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurrencyPerBritishThermalUnit { get; }
Public Shared ReadOnly Property CurrencyPerBritishThermalUnit As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurrencyPerBritishThermalUnit {
    ForgeTypeId^ get ();
}
static member CurrencyPerBritishThermalUnit : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.CurrencyPerBritishThermalUnitPerHour Property

UnitTypeIdCurrencyPerBritishThermalUnitPerHour Property

Cost per British thermal unit per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurrencyPerBritishThermalUnitPerHour { get; }
Public Shared ReadOnly Property CurrencyPerBritishThermalUnitPerHour As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurrencyPerBritishThermalUnitPerHour {
    ForgeTypeId^ get ();
}
static member CurrencyPerBritishThermalUnitPerHour : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.CurrencyPerSquareFoot Property

UnitTypeIdCurrencyPerSquareFoot Property

Cost per square foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurrencyPerSquareFoot { get; }
Public Shared ReadOnly Property CurrencyPerSquareFoot As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurrencyPerSquareFoot {
    ForgeTypeId^ get ();
}
static member CurrencyPerSquareFoot : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.CurrencyPerSquareMeter Property

UnitTypeIdCurrencyPerSquareMeter Property

Cost per square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurrencyPerSquareMeter { get; }
Public Shared ReadOnly Property CurrencyPerSquareMeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurrencyPerSquareMeter {
    ForgeTypeId^ get ();
}
static member CurrencyPerSquareMeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.CurrencyPerWatt Property

UnitTypeIdCurrencyPerWatt Property

Cost per watt.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurrencyPerWatt { get; }
Public Shared ReadOnly Property CurrencyPerWatt As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurrencyPerWatt {
    ForgeTypeId^ get ();
}
static member CurrencyPerWatt : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.CurrencyPerWattHour Property

UnitTypeIdCurrencyPerWattHour Property

Cost per watt hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CurrencyPerWattHour { get; }
Public Shared ReadOnly Property CurrencyPerWattHour As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CurrencyPerWattHour {
    ForgeTypeId^ get ();
}
static member CurrencyPerWattHour : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Custom Property

UnitTypeIdCustom Property

Unrecognized custom unit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Custom { get; }
Public Shared ReadOnly Property Custom As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Custom {
    ForgeTypeId^ get ();
}
static member Custom : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.CyclesPerSecond Property

UnitTypeIdCyclesPerSecond Property

Cycles per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId CyclesPerSecond { get; }
Public Shared ReadOnly Property CyclesPerSecond As ForgeTypeId
    Get
public:
static property ForgeTypeId^ CyclesPerSecond {
    ForgeTypeId^ get ();
}
static member CyclesPerSecond : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Decimeters Property

UnitTypeIdDecimeters Property

Decimeters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Decimeters { get; }
Public Shared ReadOnly Property Decimeters As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Decimeters {
    ForgeTypeId^ get ();
}
static member Decimeters : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Degrees Property

UnitTypeIdDegrees Property

Degrees.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Degrees { get; }
Public Shared ReadOnly Property Degrees As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Degrees {
    ForgeTypeId^ get ();
}
static member Degrees : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.DegreesMinutes Property

UnitTypeIdDegreesMinutes Property

Degrees minutes seconds.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DegreesMinutes { get; }
Public Shared ReadOnly Property DegreesMinutes As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DegreesMinutes {
    ForgeTypeId^ get ();
}
static member DegreesMinutes : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.DekanewtonMeters Property

UnitTypeIdDekanewtonMeters Property

Dekanewton meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DekanewtonMeters { get; }
Public Shared ReadOnly Property DekanewtonMeters As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DekanewtonMeters {
    ForgeTypeId^ get ();
}
static member DekanewtonMeters : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.DekanewtonMetersPerMeter Property

UnitTypeIdDekanewtonMetersPerMeter Property

Dekanewton meters per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DekanewtonMetersPerMeter { get; }
Public Shared ReadOnly Property DekanewtonMetersPerMeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DekanewtonMetersPerMeter {
    ForgeTypeId^ get ();
}
static member DekanewtonMetersPerMeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Dekanewtons Property

UnitTypeIdDekanewtons Property

Dekanewtons.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Dekanewtons { get; }
Public Shared ReadOnly Property Dekanewtons As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Dekanewtons {
    ForgeTypeId^ get ();
}
static member Dekanewtons : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.DekanewtonsPerMeter Property

UnitTypeIdDekanewtonsPerMeter Property

Dekanewtons per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DekanewtonsPerMeter { get; }
Public Shared ReadOnly Property DekanewtonsPerMeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DekanewtonsPerMeter {
    ForgeTypeId^ get ();
}
static member DekanewtonsPerMeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.DekanewtonsPerSquareMeter Property

UnitTypeIdDekanewtonsPerSquareMeter Property

Dekanewtons per square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId DekanewtonsPerSquareMeter { get; }
Public Shared ReadOnly Property DekanewtonsPerSquareMeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ DekanewtonsPerSquareMeter {
    ForgeTypeId^ get ();
}
static member DekanewtonsPerSquareMeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Fahrenheit Property

UnitTypeIdFahrenheit Property

Fahrenheit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Fahrenheit { get; }
Public Shared ReadOnly Property Fahrenheit As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Fahrenheit {
    ForgeTypeId^ get ();
}
static member Fahrenheit : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.FahrenheitInterval Property

UnitTypeIdFahrenheitInterval Property

Fahrenheit interval.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FahrenheitInterval { get; }
Public Shared ReadOnly Property FahrenheitInterval As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FahrenheitInterval {
    ForgeTypeId^ get ();
}
static member FahrenheitInterval : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Feet Property

UnitTypeIdFeet Property

Feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Feet { get; }
Public Shared ReadOnly Property Feet As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Feet {
    ForgeTypeId^ get ();
}
static member Feet : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.FeetFractionalInches Property

UnitTypeIdFeetFractionalInches Property

Feet and fractional inches.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FeetFractionalInches { get; }
Public Shared ReadOnly Property FeetFractionalInches As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FeetFractionalInches {
    ForgeTypeId^ get ();
}
static member FeetFractionalInches : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.FeetOfWater39_2DegreesFahrenheit Property

UnitTypeIdFeetOfWater39_2DegreesFahrenheit Property

Feet of water (39.2 Â°F).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FeetOfWater39_2DegreesFahrenheit { get; }
Public Shared ReadOnly Property FeetOfWater39_2DegreesFahrenheit As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FeetOfWater39_2DegreesFahrenheit {
    ForgeTypeId^ get ();
}
static member FeetOfWater39_2DegreesFahrenheit : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.FeetOfWater39_2DegreesFahrenheitPer100Feet Property

UnitTypeIdFeetOfWater39_2DegreesFahrenheitPer100Feet Property

Feet of water (39.2 Â°F) per 100 feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FeetOfWater39_2DegreesFahrenheitPer100Feet { get; }
Public Shared ReadOnly Property FeetOfWater39_2DegreesFahrenheitPer100Feet As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FeetOfWater39_2DegreesFahrenheitPer100Feet {
    ForgeTypeId^ get ();
}
static member FeetOfWater39_2DegreesFahrenheitPer100Feet : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.FeetPerKip Property

UnitTypeIdFeetPerKip Property

Feet per kip.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FeetPerKip { get; }
Public Shared ReadOnly Property FeetPerKip As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FeetPerKip {
    ForgeTypeId^ get ();
}
static member FeetPerKip : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.FeetPerMinute Property

UnitTypeIdFeetPerMinute Property

Feet per minute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FeetPerMinute { get; }
Public Shared ReadOnly Property FeetPerMinute As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FeetPerMinute {
    ForgeTypeId^ get ();
}
static member FeetPerMinute : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.FeetPerSecond Property

UnitTypeIdFeetPerSecond Property

Feet per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FeetPerSecond { get; }
Public Shared ReadOnly Property FeetPerSecond As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FeetPerSecond {
    ForgeTypeId^ get ();
}
static member FeetPerSecond : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.FeetPerSecondSquared Property

UnitTypeIdFeetPerSecondSquared Property

Feet per second squared.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FeetPerSecondSquared { get; }
Public Shared ReadOnly Property FeetPerSecondSquared As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FeetPerSecondSquared {
    ForgeTypeId^ get ();
}
static member FeetPerSecondSquared : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.FeetToTheFourthPower Property

UnitTypeIdFeetToTheFourthPower Property

Feet to the fourth power.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FeetToTheFourthPower { get; }
Public Shared ReadOnly Property FeetToTheFourthPower As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FeetToTheFourthPower {
    ForgeTypeId^ get ();
}
static member FeetToTheFourthPower : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.FeetToTheSixthPower Property

UnitTypeIdFeetToTheSixthPower Property

Feet to the sixth power.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FeetToTheSixthPower { get; }
Public Shared ReadOnly Property FeetToTheSixthPower As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FeetToTheSixthPower {
    ForgeTypeId^ get ();
}
static member FeetToTheSixthPower : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Fixed Property

UnitTypeIdFixed Property

Fixed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Fixed { get; }
Public Shared ReadOnly Property Fixed As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Fixed {
    ForgeTypeId^ get ();
}
static member Fixed : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Footcandles Property

UnitTypeIdFootcandles Property

Footcandles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Footcandles { get; }
Public Shared ReadOnly Property Footcandles As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Footcandles {
    ForgeTypeId^ get ();
}
static member Footcandles : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Footlamberts Property

UnitTypeIdFootlamberts Property

Footlamberts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Footlamberts { get; }
Public Shared ReadOnly Property Footlamberts As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Footlamberts {
    ForgeTypeId^ get ();
}
static member Footlamberts : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.FractionalInches Property

UnitTypeIdFractionalInches Property

Fractional inches.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId FractionalInches { get; }
Public Shared ReadOnly Property FractionalInches As ForgeTypeId
    Get
public:
static property ForgeTypeId^ FractionalInches {
    ForgeTypeId^ get ();
}
static member FractionalInches : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.General Property

UnitTypeIdGeneral Property

General.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId General { get; }
Public Shared ReadOnly Property General As ForgeTypeId
    Get
public:
static property ForgeTypeId^ General {
    ForgeTypeId^ get ();
}
static member General : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Gigajoules Property

UnitTypeIdGigajoules Property

Gigajoules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Gigajoules { get; }
Public Shared ReadOnly Property Gigajoules As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Gigajoules {
    ForgeTypeId^ get ();
}
static member Gigajoules : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Gradians Property

UnitTypeIdGradians Property

Gradians.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Gradians { get; }
Public Shared ReadOnly Property Gradians As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Gradians {
    ForgeTypeId^ get ();
}
static member Gradians : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.GrainsPerHourSquareFootInchMercury Property

UnitTypeIdGrainsPerHourSquareFootInchMercury Property

Grains per hour square foot inch mercury.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GrainsPerHourSquareFootInchMercury { get; }
Public Shared ReadOnly Property GrainsPerHourSquareFootInchMercury As ForgeTypeId
    Get
public:
static property ForgeTypeId^ GrainsPerHourSquareFootInchMercury {
    ForgeTypeId^ get ();
}
static member GrainsPerHourSquareFootInchMercury : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Hectares Property

UnitTypeIdHectares Property

Hectares.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Hectares { get; }
Public Shared ReadOnly Property Hectares As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Hectares {
    ForgeTypeId^ get ();
}
static member Hectares : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Hertz Property

UnitTypeIdHertz Property

Hertz.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Hertz { get; }
Public Shared ReadOnly Property Hertz As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Hertz {
    ForgeTypeId^ get ();
}
static member Hertz : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Horsepower Property

UnitTypeIdHorsepower Property

Horsepower.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Horsepower { get; }
Public Shared ReadOnly Property Horsepower As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Horsepower {
    ForgeTypeId^ get ();
}
static member Horsepower : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Hours Property

UnitTypeIdHours Property

Hours.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Hours { get; }
Public Shared ReadOnly Property Hours As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Hours {
    ForgeTypeId^ get ();
}
static member Hours : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.HourSquareFootDegreesFahrenheitPerBritishThermalUnit Property

UnitTypeIdHourSquareFootDegreesFahrenheitPerBritishThermalUnit Property

Hour square foot degrees Fahrenheit per British thermal unit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId HourSquareFootDegreesFahrenheitPerBritishThermalUnit { get; }
Public Shared ReadOnly Property HourSquareFootDegreesFahrenheitPerBritishThermalUnit As ForgeTypeId
    Get
public:
static property ForgeTypeId^ HourSquareFootDegreesFahrenheitPerBritishThermalUnit {
    ForgeTypeId^ get ();
}
static member HourSquareFootDegreesFahrenheitPerBritishThermalUnit : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Inches Property

UnitTypeIdInches Property

Inches.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Inches { get; }
Public Shared ReadOnly Property Inches As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Inches {
    ForgeTypeId^ get ();
}
static member Inches : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.InchesOfMercury32DegreesFahrenheit Property

UnitTypeIdInchesOfMercury32DegreesFahrenheit Property

Inches of mercury (32 Â°F).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId InchesOfMercury32DegreesFahrenheit { get; }
Public Shared ReadOnly Property InchesOfMercury32DegreesFahrenheit As ForgeTypeId
    Get
public:
static property ForgeTypeId^ InchesOfMercury32DegreesFahrenheit {
    ForgeTypeId^ get ();
}
static member InchesOfMercury32DegreesFahrenheit : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.InchesOfWater60DegreesFahrenheit Property

UnitTypeIdInchesOfWater60DegreesFahrenheit Property

Inches of water (60 Â°F).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId InchesOfWater60DegreesFahrenheit { get; }
Public Shared ReadOnly Property InchesOfWater60DegreesFahrenheit As ForgeTypeId
    Get
public:
static property ForgeTypeId^ InchesOfWater60DegreesFahrenheit {
    ForgeTypeId^ get ();
}
static member InchesOfWater60DegreesFahrenheit : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.InchesOfWater60DegreesFahrenheitPer100Feet Property

UnitTypeIdInchesOfWater60DegreesFahrenheitPer100Feet Property

Inches of water (60 Â°F) per 100 feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId InchesOfWater60DegreesFahrenheitPer100Feet { get; }
Public Shared ReadOnly Property InchesOfWater60DegreesFahrenheitPer100Feet As ForgeTypeId
    Get
public:
static property ForgeTypeId^ InchesOfWater60DegreesFahrenheitPer100Feet {
    ForgeTypeId^ get ();
}
static member InchesOfWater60DegreesFahrenheitPer100Feet : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.InchesPerSecondSquared Property

UnitTypeIdInchesPerSecondSquared Property

Inches per second squared.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId InchesPerSecondSquared { get; }
Public Shared ReadOnly Property InchesPerSecondSquared As ForgeTypeId
    Get
public:
static property ForgeTypeId^ InchesPerSecondSquared {
    ForgeTypeId^ get ();
}
static member InchesPerSecondSquared : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.InchesToTheFourthPower Property

UnitTypeIdInchesToTheFourthPower Property

Inches to the fourth power.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId InchesToTheFourthPower { get; }
Public Shared ReadOnly Property InchesToTheFourthPower As ForgeTypeId
    Get
public:
static property ForgeTypeId^ InchesToTheFourthPower {
    ForgeTypeId^ get ();
}
static member InchesToTheFourthPower : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.InchesToTheSixthPower Property

UnitTypeIdInchesToTheSixthPower Property

Inches to the sixth power.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId InchesToTheSixthPower { get; }
Public Shared ReadOnly Property InchesToTheSixthPower As ForgeTypeId
    Get
public:
static property ForgeTypeId^ InchesToTheSixthPower {
    ForgeTypeId^ get ();
}
static member InchesToTheSixthPower : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.InverseDegreesCelsius Property

UnitTypeIdInverseDegreesCelsius Property

Inverse degrees Celsius.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId InverseDegreesCelsius { get; }
Public Shared ReadOnly Property InverseDegreesCelsius As ForgeTypeId
    Get
public:
static property ForgeTypeId^ InverseDegreesCelsius {
    ForgeTypeId^ get ();
}
static member InverseDegreesCelsius : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.InverseDegreesFahrenheit Property

UnitTypeIdInverseDegreesFahrenheit Property

Inverse degrees Fahrenheit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId InverseDegreesFahrenheit { get; }
Public Shared ReadOnly Property InverseDegreesFahrenheit As ForgeTypeId
    Get
public:
static property ForgeTypeId^ InverseDegreesFahrenheit {
    ForgeTypeId^ get ();
}
static member InverseDegreesFahrenheit : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.InverseKilonewtons Property

UnitTypeIdInverseKilonewtons Property

Inverse kilonewtons.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId InverseKilonewtons { get; }
Public Shared ReadOnly Property InverseKilonewtons As ForgeTypeId
    Get
public:
static property ForgeTypeId^ InverseKilonewtons {
    ForgeTypeId^ get ();
}
static member InverseKilonewtons : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.InverseKips Property

UnitTypeIdInverseKips Property

Inverse kips.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId InverseKips { get; }
Public Shared ReadOnly Property InverseKips As ForgeTypeId
    Get
public:
static property ForgeTypeId^ InverseKips {
    ForgeTypeId^ get ();
}
static member InverseKips : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Joules Property

UnitTypeIdJoules Property

Joules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Joules { get; }
Public Shared ReadOnly Property Joules As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Joules {
    ForgeTypeId^ get ();
}
static member Joules : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.JoulesPerGram Property

UnitTypeIdJoulesPerGram Property

Joules per gram.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId JoulesPerGram { get; }
Public Shared ReadOnly Property JoulesPerGram As ForgeTypeId
    Get
public:
static property ForgeTypeId^ JoulesPerGram {
    ForgeTypeId^ get ();
}
static member JoulesPerGram : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.JoulesPerGramDegreeCelsius Property

UnitTypeIdJoulesPerGramDegreeCelsius Property

Joules per gram degree Celsius.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId JoulesPerGramDegreeCelsius { get; }
Public Shared ReadOnly Property JoulesPerGramDegreeCelsius As ForgeTypeId
    Get
public:
static property ForgeTypeId^ JoulesPerGramDegreeCelsius {
    ForgeTypeId^ get ();
}
static member JoulesPerGramDegreeCelsius : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.JoulesPerKelvin Property

UnitTypeIdJoulesPerKelvin Property

Joules per Kelvin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId JoulesPerKelvin { get; }
Public Shared ReadOnly Property JoulesPerKelvin As ForgeTypeId
    Get
public:
static property ForgeTypeId^ JoulesPerKelvin {
    ForgeTypeId^ get ();
}
static member JoulesPerKelvin : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.JoulesPerKilogramDegreeCelsius Property

UnitTypeIdJoulesPerKilogramDegreeCelsius Property

Joules per kilogram degree Celsius.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId JoulesPerKilogramDegreeCelsius { get; }
Public Shared ReadOnly Property JoulesPerKilogramDegreeCelsius As ForgeTypeId
    Get
public:
static property ForgeTypeId^ JoulesPerKilogramDegreeCelsius {
    ForgeTypeId^ get ();
}
static member JoulesPerKilogramDegreeCelsius : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.JoulesPerSquareMeterKelvin Property

UnitTypeIdJoulesPerSquareMeterKelvin Property

Joules per square meter Kelvin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId JoulesPerSquareMeterKelvin { get; }
Public Shared ReadOnly Property JoulesPerSquareMeterKelvin As ForgeTypeId
    Get
public:
static property ForgeTypeId^ JoulesPerSquareMeterKelvin {
    ForgeTypeId^ get ();
}
static member JoulesPerSquareMeterKelvin : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Kelvin Property

UnitTypeIdKelvin Property

Kelvin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Kelvin { get; }
Public Shared ReadOnly Property Kelvin As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Kelvin {
    ForgeTypeId^ get ();
}
static member Kelvin : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.KelvinInterval Property

UnitTypeIdKelvinInterval Property

Kelvin interval.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KelvinInterval { get; }
Public Shared ReadOnly Property KelvinInterval As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KelvinInterval {
    ForgeTypeId^ get ();
}
static member KelvinInterval : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Kiloamperes Property

UnitTypeIdKiloamperes Property

Kiloamperes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Kiloamperes { get; }
Public Shared ReadOnly Property Kiloamperes As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Kiloamperes {
    ForgeTypeId^ get ();
}
static member Kiloamperes : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Kilocalories Property

UnitTypeIdKilocalories Property

Kilocalories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Kilocalories { get; }
Public Shared ReadOnly Property Kilocalories As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Kilocalories {
    ForgeTypeId^ get ();
}
static member Kilocalories : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.KilocaloriesPerSecond Property

UnitTypeIdKilocaloriesPerSecond Property

Kilocalories per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KilocaloriesPerSecond { get; }
Public Shared ReadOnly Property KilocaloriesPerSecond As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KilocaloriesPerSecond {
    ForgeTypeId^ get ();
}
static member KilocaloriesPerSecond : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.KilogramForceMeters Property

UnitTypeIdKilogramForceMeters Property

Kilogram force meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KilogramForceMeters { get; }
Public Shared ReadOnly Property KilogramForceMeters As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KilogramForceMeters {
    ForgeTypeId^ get ();
}
static member KilogramForceMeters : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.KilogramForceMetersPerMeter Property

UnitTypeIdKilogramForceMetersPerMeter Property

Kilogram force meters per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KilogramForceMetersPerMeter { get; }
Public Shared ReadOnly Property KilogramForceMetersPerMeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KilogramForceMetersPerMeter {
    ForgeTypeId^ get ();
}
static member KilogramForceMetersPerMeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Kilograms Property

UnitTypeIdKilograms Property

Kilograms.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Kilograms { get; }
Public Shared ReadOnly Property Kilograms As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Kilograms {
    ForgeTypeId^ get ();
}
static member Kilograms : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.KilogramsForce Property

UnitTypeIdKilogramsForce Property

Kilograms force.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KilogramsForce { get; }
Public Shared ReadOnly Property KilogramsForce As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KilogramsForce {
    ForgeTypeId^ get ();
}
static member KilogramsForce : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.KilogramsForcePerMeter Property

UnitTypeIdKilogramsForcePerMeter Property

Kilograms force per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KilogramsForcePerMeter { get; }
Public Shared ReadOnly Property KilogramsForcePerMeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KilogramsForcePerMeter {
    ForgeTypeId^ get ();
}
static member KilogramsForcePerMeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.KilogramsForcePerSquareMeter Property

UnitTypeIdKilogramsForcePerSquareMeter Property

Kilograms force per square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KilogramsForcePerSquareMeter { get; }
Public Shared ReadOnly Property KilogramsForcePerSquareMeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KilogramsForcePerSquareMeter {
    ForgeTypeId^ get ();
}
static member KilogramsForcePerSquareMeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.KilogramsPerCubicMeter Property

UnitTypeIdKilogramsPerCubicMeter Property

Kilograms per cubic meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KilogramsPerCubicMeter { get; }
Public Shared ReadOnly Property KilogramsPerCubicMeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KilogramsPerCubicMeter {
    ForgeTypeId^ get ();
}
static member KilogramsPerCubicMeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.KilogramsPerHour Property

UnitTypeIdKilogramsPerHour Property

Kilograms per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KilogramsPerHour { get; }
Public Shared ReadOnly Property KilogramsPerHour As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KilogramsPerHour {
    ForgeTypeId^ get ();
}
static member KilogramsPerHour : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.KilogramsPerKilogramKelvin Property

UnitTypeIdKilogramsPerKilogramKelvin Property

Kilograms per kilogram kelvin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KilogramsPerKilogramKelvin { get; }
Public Shared ReadOnly Property KilogramsPerKilogramKelvin As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KilogramsPerKilogramKelvin {
    ForgeTypeId^ get ();
}
static member KilogramsPerKilogramKelvin : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.KilogramsPerMeter Property

UnitTypeIdKilogramsPerMeter Property

Kilograms per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KilogramsPerMeter { get; }
Public Shared ReadOnly Property KilogramsPerMeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KilogramsPerMeter {
    ForgeTypeId^ get ();
}
static member KilogramsPerMeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.KilogramsPerMeterHour Property

UnitTypeIdKilogramsPerMeterHour Property

Kilograms per meter hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KilogramsPerMeterHour { get; }
Public Shared ReadOnly Property KilogramsPerMeterHour As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KilogramsPerMeterHour {
    ForgeTypeId^ get ();
}
static member KilogramsPerMeterHour : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.KilogramsPerMeterSecond Property

UnitTypeIdKilogramsPerMeterSecond Property

Kilograms per meter second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KilogramsPerMeterSecond { get; }
Public Shared ReadOnly Property KilogramsPerMeterSecond As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KilogramsPerMeterSecond {
    ForgeTypeId^ get ();
}
static member KilogramsPerMeterSecond : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.KilogramsPerMinute Property

UnitTypeIdKilogramsPerMinute Property

Kilograms per minute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KilogramsPerMinute { get; }
Public Shared ReadOnly Property KilogramsPerMinute As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KilogramsPerMinute {
    ForgeTypeId^ get ();
}
static member KilogramsPerMinute : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.KilogramsPerSecond Property

UnitTypeIdKilogramsPerSecond Property

Kilograms per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KilogramsPerSecond { get; }
Public Shared ReadOnly Property KilogramsPerSecond As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KilogramsPerSecond {
    ForgeTypeId^ get ();
}
static member KilogramsPerSecond : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.KilogramsPerSquareMeter Property

UnitTypeIdKilogramsPerSquareMeter Property

Kilograms per square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KilogramsPerSquareMeter { get; }
Public Shared ReadOnly Property KilogramsPerSquareMeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KilogramsPerSquareMeter {
    ForgeTypeId^ get ();
}
static member KilogramsPerSquareMeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Kilojoules Property

UnitTypeIdKilojoules Property

Kilojoules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Kilojoules { get; }
Public Shared ReadOnly Property Kilojoules As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Kilojoules {
    ForgeTypeId^ get ();
}
static member Kilojoules : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.KilojoulesPerKelvin Property

UnitTypeIdKilojoulesPerKelvin Property

Kilojoules per Kelvin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KilojoulesPerKelvin { get; }
Public Shared ReadOnly Property KilojoulesPerKelvin As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KilojoulesPerKelvin {
    ForgeTypeId^ get ();
}
static member KilojoulesPerKelvin : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.KilojoulesPerSquareMeterKelvin Property

UnitTypeIdKilojoulesPerSquareMeterKelvin Property

Kilojoules per square meter Kelvin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KilojoulesPerSquareMeterKelvin { get; }
Public Shared ReadOnly Property KilojoulesPerSquareMeterKelvin As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KilojoulesPerSquareMeterKelvin {
    ForgeTypeId^ get ();
}
static member KilojoulesPerSquareMeterKelvin : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.KilometersPerHour Property

UnitTypeIdKilometersPerHour Property

Kilometers per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KilometersPerHour { get; }
Public Shared ReadOnly Property KilometersPerHour As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KilometersPerHour {
    ForgeTypeId^ get ();
}
static member KilometersPerHour : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.KilometersPerSecondSquared Property

UnitTypeIdKilometersPerSecondSquared Property

Kilometers per second squared.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KilometersPerSecondSquared { get; }
Public Shared ReadOnly Property KilometersPerSecondSquared As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KilometersPerSecondSquared {
    ForgeTypeId^ get ();
}
static member KilometersPerSecondSquared : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.KilonewtonMeters Property

UnitTypeIdKilonewtonMeters Property

Kilonewton meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KilonewtonMeters { get; }
Public Shared ReadOnly Property KilonewtonMeters As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KilonewtonMeters {
    ForgeTypeId^ get ();
}
static member KilonewtonMeters : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.KilonewtonMetersPerDegree Property

UnitTypeIdKilonewtonMetersPerDegree Property

Kilonewton meters per degree.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KilonewtonMetersPerDegree { get; }
Public Shared ReadOnly Property KilonewtonMetersPerDegree As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KilonewtonMetersPerDegree {
    ForgeTypeId^ get ();
}
static member KilonewtonMetersPerDegree : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.KilonewtonMetersPerDegreePerMeter Property

UnitTypeIdKilonewtonMetersPerDegreePerMeter Property

Kilonewton meters per degree per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KilonewtonMetersPerDegreePerMeter { get; }
Public Shared ReadOnly Property KilonewtonMetersPerDegreePerMeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KilonewtonMetersPerDegreePerMeter {
    ForgeTypeId^ get ();
}
static member KilonewtonMetersPerDegreePerMeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.KilonewtonMetersPerMeter Property

UnitTypeIdKilonewtonMetersPerMeter Property

Kilonewton meters per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KilonewtonMetersPerMeter { get; }
Public Shared ReadOnly Property KilonewtonMetersPerMeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KilonewtonMetersPerMeter {
    ForgeTypeId^ get ();
}
static member KilonewtonMetersPerMeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Kilonewtons Property

UnitTypeIdKilonewtons Property

Kilonewtons.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Kilonewtons { get; }
Public Shared ReadOnly Property Kilonewtons As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Kilonewtons {
    ForgeTypeId^ get ();
}
static member Kilonewtons : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.KilonewtonsPerCubicMeter Property

UnitTypeIdKilonewtonsPerCubicMeter Property

Kilonewtons per cubic meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KilonewtonsPerCubicMeter { get; }
Public Shared ReadOnly Property KilonewtonsPerCubicMeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KilonewtonsPerCubicMeter {
    ForgeTypeId^ get ();
}
static member KilonewtonsPerCubicMeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.KilonewtonsPerMeter Property

UnitTypeIdKilonewtonsPerMeter Property

Kilonewtons per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KilonewtonsPerMeter { get; }
Public Shared ReadOnly Property KilonewtonsPerMeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KilonewtonsPerMeter {
    ForgeTypeId^ get ();
}
static member KilonewtonsPerMeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.KilonewtonsPerSquareCentimeter Property

UnitTypeIdKilonewtonsPerSquareCentimeter Property

Kilonewtons per square centimeter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KilonewtonsPerSquareCentimeter { get; }
Public Shared ReadOnly Property KilonewtonsPerSquareCentimeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KilonewtonsPerSquareCentimeter {
    ForgeTypeId^ get ();
}
static member KilonewtonsPerSquareCentimeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.KilonewtonsPerSquareMeter Property

UnitTypeIdKilonewtonsPerSquareMeter Property

Kilonewtons per square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KilonewtonsPerSquareMeter { get; }
Public Shared ReadOnly Property KilonewtonsPerSquareMeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KilonewtonsPerSquareMeter {
    ForgeTypeId^ get ();
}
static member KilonewtonsPerSquareMeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.KilonewtonsPerSquareMillimeter Property

UnitTypeIdKilonewtonsPerSquareMillimeter Property

Kilonewtons per square millimeter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KilonewtonsPerSquareMillimeter { get; }
Public Shared ReadOnly Property KilonewtonsPerSquareMillimeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KilonewtonsPerSquareMillimeter {
    ForgeTypeId^ get ();
}
static member KilonewtonsPerSquareMillimeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Kilopascals Property

UnitTypeIdKilopascals Property

Kilopascals.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Kilopascals { get; }
Public Shared ReadOnly Property Kilopascals As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Kilopascals {
    ForgeTypeId^ get ();
}
static member Kilopascals : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.KilovoltAmperes Property

UnitTypeIdKilovoltAmperes Property

Kilovolt amperes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KilovoltAmperes { get; }
Public Shared ReadOnly Property KilovoltAmperes As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KilovoltAmperes {
    ForgeTypeId^ get ();
}
static member KilovoltAmperes : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Kilovolts Property

UnitTypeIdKilovolts Property

Kilovolts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Kilovolts { get; }
Public Shared ReadOnly Property Kilovolts As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Kilovolts {
    ForgeTypeId^ get ();
}
static member Kilovolts : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.KilowattHours Property

UnitTypeIdKilowattHours Property

Kilowatt hours.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KilowattHours { get; }
Public Shared ReadOnly Property KilowattHours As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KilowattHours {
    ForgeTypeId^ get ();
}
static member KilowattHours : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Kilowatts Property

UnitTypeIdKilowatts Property

Kilowatts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Kilowatts { get; }
Public Shared ReadOnly Property Kilowatts As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Kilowatts {
    ForgeTypeId^ get ();
}
static member Kilowatts : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.KipFeet Property

UnitTypeIdKipFeet Property

Kip feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KipFeet { get; }
Public Shared ReadOnly Property KipFeet As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KipFeet {
    ForgeTypeId^ get ();
}
static member KipFeet : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.KipFeetPerDegree Property

UnitTypeIdKipFeetPerDegree Property

Kip feet per degree.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KipFeetPerDegree { get; }
Public Shared ReadOnly Property KipFeetPerDegree As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KipFeetPerDegree {
    ForgeTypeId^ get ();
}
static member KipFeetPerDegree : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.KipFeetPerDegreePerFoot Property

UnitTypeIdKipFeetPerDegreePerFoot Property

Kip feet per degree per foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KipFeetPerDegreePerFoot { get; }
Public Shared ReadOnly Property KipFeetPerDegreePerFoot As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KipFeetPerDegreePerFoot {
    ForgeTypeId^ get ();
}
static member KipFeetPerDegreePerFoot : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.KipFeetPerFoot Property

UnitTypeIdKipFeetPerFoot Property

Kip feet per foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KipFeetPerFoot { get; }
Public Shared ReadOnly Property KipFeetPerFoot As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KipFeetPerFoot {
    ForgeTypeId^ get ();
}
static member KipFeetPerFoot : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Kips Property

UnitTypeIdKips Property

Kips.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Kips { get; }
Public Shared ReadOnly Property Kips As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Kips {
    ForgeTypeId^ get ();
}
static member Kips : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.KipsPerCubicFoot Property

UnitTypeIdKipsPerCubicFoot Property

Kips per cubic foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KipsPerCubicFoot { get; }
Public Shared ReadOnly Property KipsPerCubicFoot As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KipsPerCubicFoot {
    ForgeTypeId^ get ();
}
static member KipsPerCubicFoot : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.KipsPerCubicInch Property

UnitTypeIdKipsPerCubicInch Property

Kips per cubic inch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KipsPerCubicInch { get; }
Public Shared ReadOnly Property KipsPerCubicInch As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KipsPerCubicInch {
    ForgeTypeId^ get ();
}
static member KipsPerCubicInch : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.KipsPerFoot Property

UnitTypeIdKipsPerFoot Property

Kips per foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KipsPerFoot { get; }
Public Shared ReadOnly Property KipsPerFoot As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KipsPerFoot {
    ForgeTypeId^ get ();
}
static member KipsPerFoot : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.KipsPerInch Property

UnitTypeIdKipsPerInch Property

Kips per inch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KipsPerInch { get; }
Public Shared ReadOnly Property KipsPerInch As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KipsPerInch {
    ForgeTypeId^ get ();
}
static member KipsPerInch : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.KipsPerSquareFoot Property

UnitTypeIdKipsPerSquareFoot Property

Kips per square foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KipsPerSquareFoot { get; }
Public Shared ReadOnly Property KipsPerSquareFoot As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KipsPerSquareFoot {
    ForgeTypeId^ get ();
}
static member KipsPerSquareFoot : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.KipsPerSquareInch Property

UnitTypeIdKipsPerSquareInch Property

Kips per square inch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId KipsPerSquareInch { get; }
Public Shared ReadOnly Property KipsPerSquareInch As ForgeTypeId
    Get
public:
static property ForgeTypeId^ KipsPerSquareInch {
    ForgeTypeId^ get ();
}
static member KipsPerSquareInch : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Liters Property

UnitTypeIdLiters Property

Liters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Liters { get; }
Public Shared ReadOnly Property Liters As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Liters {
    ForgeTypeId^ get ();
}
static member Liters : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.LitersPerHour Property

UnitTypeIdLitersPerHour Property

Liters per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LitersPerHour { get; }
Public Shared ReadOnly Property LitersPerHour As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LitersPerHour {
    ForgeTypeId^ get ();
}
static member LitersPerHour : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.LitersPerMinute Property

UnitTypeIdLitersPerMinute Property

Liters per minute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LitersPerMinute { get; }
Public Shared ReadOnly Property LitersPerMinute As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LitersPerMinute {
    ForgeTypeId^ get ();
}
static member LitersPerMinute : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.LitersPerSecond Property

UnitTypeIdLitersPerSecond Property

Liters per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LitersPerSecond { get; }
Public Shared ReadOnly Property LitersPerSecond As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LitersPerSecond {
    ForgeTypeId^ get ();
}
static member LitersPerSecond : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.LitersPerSecondCubicMeter Property

UnitTypeIdLitersPerSecondCubicMeter Property

Liters per second cubic meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LitersPerSecondCubicMeter { get; }
Public Shared ReadOnly Property LitersPerSecondCubicMeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LitersPerSecondCubicMeter {
    ForgeTypeId^ get ();
}
static member LitersPerSecondCubicMeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.LitersPerSecondKilowatt Property

UnitTypeIdLitersPerSecondKilowatt Property

Liters per second kilowatt.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LitersPerSecondKilowatt { get; }
Public Shared ReadOnly Property LitersPerSecondKilowatt As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LitersPerSecondKilowatt {
    ForgeTypeId^ get ();
}
static member LitersPerSecondKilowatt : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.LitersPerSecondSquareMeter Property

UnitTypeIdLitersPerSecondSquareMeter Property

Liters per second square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LitersPerSecondSquareMeter { get; }
Public Shared ReadOnly Property LitersPerSecondSquareMeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LitersPerSecondSquareMeter {
    ForgeTypeId^ get ();
}
static member LitersPerSecondSquareMeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Lumens Property

UnitTypeIdLumens Property

Lumens.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Lumens { get; }
Public Shared ReadOnly Property Lumens As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Lumens {
    ForgeTypeId^ get ();
}
static member Lumens : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.LumensPerWatt Property

UnitTypeIdLumensPerWatt Property

Lumens per watt.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId LumensPerWatt { get; }
Public Shared ReadOnly Property LumensPerWatt As ForgeTypeId
    Get
public:
static property ForgeTypeId^ LumensPerWatt {
    ForgeTypeId^ get ();
}
static member LumensPerWatt : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Lux Property

UnitTypeIdLux Property

Lux.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Lux { get; }
Public Shared ReadOnly Property Lux As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Lux {
    ForgeTypeId^ get ();
}
static member Lux : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Megajoules Property

UnitTypeIdMegajoules Property

Megajoules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Megajoules { get; }
Public Shared ReadOnly Property Megajoules As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Megajoules {
    ForgeTypeId^ get ();
}
static member Megajoules : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.MeganewtonMeters Property

UnitTypeIdMeganewtonMeters Property

Meganewton meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MeganewtonMeters { get; }
Public Shared ReadOnly Property MeganewtonMeters As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MeganewtonMeters {
    ForgeTypeId^ get ();
}
static member MeganewtonMeters : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.MeganewtonMetersPerMeter Property

UnitTypeIdMeganewtonMetersPerMeter Property

Meganewton meters per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MeganewtonMetersPerMeter { get; }
Public Shared ReadOnly Property MeganewtonMetersPerMeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MeganewtonMetersPerMeter {
    ForgeTypeId^ get ();
}
static member MeganewtonMetersPerMeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Meganewtons Property

UnitTypeIdMeganewtons Property

Meganewtons.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Meganewtons { get; }
Public Shared ReadOnly Property Meganewtons As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Meganewtons {
    ForgeTypeId^ get ();
}
static member Meganewtons : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.MeganewtonsPerMeter Property

UnitTypeIdMeganewtonsPerMeter Property

Meganewtons per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MeganewtonsPerMeter { get; }
Public Shared ReadOnly Property MeganewtonsPerMeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MeganewtonsPerMeter {
    ForgeTypeId^ get ();
}
static member MeganewtonsPerMeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.MeganewtonsPerSquareMeter Property

UnitTypeIdMeganewtonsPerSquareMeter Property

Meganewtons per square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MeganewtonsPerSquareMeter { get; }
Public Shared ReadOnly Property MeganewtonsPerSquareMeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MeganewtonsPerSquareMeter {
    ForgeTypeId^ get ();
}
static member MeganewtonsPerSquareMeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Megapascals Property

UnitTypeIdMegapascals Property

Megapascals.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Megapascals { get; }
Public Shared ReadOnly Property Megapascals As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Megapascals {
    ForgeTypeId^ get ();
}
static member Megapascals : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Megawatts Property

UnitTypeIdMegawatts Property

Megawatts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Megawatts { get; }
Public Shared ReadOnly Property Megawatts As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Megawatts {
    ForgeTypeId^ get ();
}
static member Megawatts : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Meters Property

UnitTypeIdMeters Property

Meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Meters { get; }
Public Shared ReadOnly Property Meters As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Meters {
    ForgeTypeId^ get ();
}
static member Meters : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.MetersCentimeters Property

UnitTypeIdMetersCentimeters Property

Meters and centimeters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MetersCentimeters { get; }
Public Shared ReadOnly Property MetersCentimeters As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MetersCentimeters {
    ForgeTypeId^ get ();
}
static member MetersCentimeters : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.MetersOfWaterColumn Property

UnitTypeIdMetersOfWaterColumn Property

Meters of water column.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MetersOfWaterColumn { get; }
Public Shared ReadOnly Property MetersOfWaterColumn As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MetersOfWaterColumn {
    ForgeTypeId^ get ();
}
static member MetersOfWaterColumn : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.MetersOfWaterColumnPerMeter Property

UnitTypeIdMetersOfWaterColumnPerMeter Property

Meters of water column per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MetersOfWaterColumnPerMeter { get; }
Public Shared ReadOnly Property MetersOfWaterColumnPerMeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MetersOfWaterColumnPerMeter {
    ForgeTypeId^ get ();
}
static member MetersOfWaterColumnPerMeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.MetersPerKilonewton Property

UnitTypeIdMetersPerKilonewton Property

Meters per kilonewton.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MetersPerKilonewton { get; }
Public Shared ReadOnly Property MetersPerKilonewton As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MetersPerKilonewton {
    ForgeTypeId^ get ();
}
static member MetersPerKilonewton : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.MetersPerSecond Property

UnitTypeIdMetersPerSecond Property

Meters per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MetersPerSecond { get; }
Public Shared ReadOnly Property MetersPerSecond As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MetersPerSecond {
    ForgeTypeId^ get ();
}
static member MetersPerSecond : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.MetersPerSecondSquared Property

UnitTypeIdMetersPerSecondSquared Property

Meters per second squared.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MetersPerSecondSquared { get; }
Public Shared ReadOnly Property MetersPerSecondSquared As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MetersPerSecondSquared {
    ForgeTypeId^ get ();
}
static member MetersPerSecondSquared : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.MetersToTheFourthPower Property

UnitTypeIdMetersToTheFourthPower Property

Meters to the fourth power.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MetersToTheFourthPower { get; }
Public Shared ReadOnly Property MetersToTheFourthPower As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MetersToTheFourthPower {
    ForgeTypeId^ get ();
}
static member MetersToTheFourthPower : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.MetersToTheSixthPower Property

UnitTypeIdMetersToTheSixthPower Property

Meters to the sixth power.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MetersToTheSixthPower { get; }
Public Shared ReadOnly Property MetersToTheSixthPower As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MetersToTheSixthPower {
    ForgeTypeId^ get ();
}
static member MetersToTheSixthPower : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.MicroinchesPerInchDegreeFahrenheit Property

UnitTypeIdMicroinchesPerInchDegreeFahrenheit Property

Microinches per inch degree Fahrenheit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MicroinchesPerInchDegreeFahrenheit { get; }
Public Shared ReadOnly Property MicroinchesPerInchDegreeFahrenheit As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MicroinchesPerInchDegreeFahrenheit {
    ForgeTypeId^ get ();
}
static member MicroinchesPerInchDegreeFahrenheit : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.MicrometersPerMeterDegreeCelsius Property

UnitTypeIdMicrometersPerMeterDegreeCelsius Property

Micrometers per meter degree Celsius.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MicrometersPerMeterDegreeCelsius { get; }
Public Shared ReadOnly Property MicrometersPerMeterDegreeCelsius As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MicrometersPerMeterDegreeCelsius {
    ForgeTypeId^ get ();
}
static member MicrometersPerMeterDegreeCelsius : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.MilesPerHour Property

UnitTypeIdMilesPerHour Property

Miles per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MilesPerHour { get; }
Public Shared ReadOnly Property MilesPerHour As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MilesPerHour {
    ForgeTypeId^ get ();
}
static member MilesPerHour : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.MilesPerSecondSquared Property

UnitTypeIdMilesPerSecondSquared Property

Miles per second squared.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MilesPerSecondSquared { get; }
Public Shared ReadOnly Property MilesPerSecondSquared As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MilesPerSecondSquared {
    ForgeTypeId^ get ();
}
static member MilesPerSecondSquared : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Milliamperes Property

UnitTypeIdMilliamperes Property

Milliamperes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Milliamperes { get; }
Public Shared ReadOnly Property Milliamperes As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Milliamperes {
    ForgeTypeId^ get ();
}
static member Milliamperes : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Millimeters Property

UnitTypeIdMillimeters Property

Millimeters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Millimeters { get; }
Public Shared ReadOnly Property Millimeters As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Millimeters {
    ForgeTypeId^ get ();
}
static member Millimeters : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.MillimetersOfMercury Property

UnitTypeIdMillimetersOfMercury Property

Millimeters of mercury.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MillimetersOfMercury { get; }
Public Shared ReadOnly Property MillimetersOfMercury As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MillimetersOfMercury {
    ForgeTypeId^ get ();
}
static member MillimetersOfMercury : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.MillimetersOfWaterColumn Property

UnitTypeIdMillimetersOfWaterColumn Property

Millimeters of water column.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MillimetersOfWaterColumn { get; }
Public Shared ReadOnly Property MillimetersOfWaterColumn As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MillimetersOfWaterColumn {
    ForgeTypeId^ get ();
}
static member MillimetersOfWaterColumn : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.MillimetersOfWaterColumnPerMeter Property

UnitTypeIdMillimetersOfWaterColumnPerMeter Property

Millimeters of water column per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MillimetersOfWaterColumnPerMeter { get; }
Public Shared ReadOnly Property MillimetersOfWaterColumnPerMeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MillimetersOfWaterColumnPerMeter {
    ForgeTypeId^ get ();
}
static member MillimetersOfWaterColumnPerMeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.MillimetersToTheFourthPower Property

UnitTypeIdMillimetersToTheFourthPower Property

Millimeters to the fourth power.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MillimetersToTheFourthPower { get; }
Public Shared ReadOnly Property MillimetersToTheFourthPower As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MillimetersToTheFourthPower {
    ForgeTypeId^ get ();
}
static member MillimetersToTheFourthPower : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.MillimetersToTheSixthPower Property

UnitTypeIdMillimetersToTheSixthPower Property

Millimeters to the sixth power.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId MillimetersToTheSixthPower { get; }
Public Shared ReadOnly Property MillimetersToTheSixthPower As ForgeTypeId
    Get
public:
static property ForgeTypeId^ MillimetersToTheSixthPower {
    ForgeTypeId^ get ();
}
static member MillimetersToTheSixthPower : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Milliseconds Property

UnitTypeIdMilliseconds Property

Milliseconds.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Milliseconds { get; }
Public Shared ReadOnly Property Milliseconds As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Milliseconds {
    ForgeTypeId^ get ();
}
static member Milliseconds : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Millivolts Property

UnitTypeIdMillivolts Property

Millivolts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Millivolts { get; }
Public Shared ReadOnly Property Millivolts As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Millivolts {
    ForgeTypeId^ get ();
}
static member Millivolts : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Minutes Property

UnitTypeIdMinutes Property

Minutes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Minutes { get; }
Public Shared ReadOnly Property Minutes As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Minutes {
    ForgeTypeId^ get ();
}
static member Minutes : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.NanogramsPerPascalSecondSquareMeter Property

UnitTypeIdNanogramsPerPascalSecondSquareMeter Property

Nanograms per pascal second square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId NanogramsPerPascalSecondSquareMeter { get; }
Public Shared ReadOnly Property NanogramsPerPascalSecondSquareMeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ NanogramsPerPascalSecondSquareMeter {
    ForgeTypeId^ get ();
}
static member NanogramsPerPascalSecondSquareMeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.NewtonMeters Property

UnitTypeIdNewtonMeters Property

Newton meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId NewtonMeters { get; }
Public Shared ReadOnly Property NewtonMeters As ForgeTypeId
    Get
public:
static property ForgeTypeId^ NewtonMeters {
    ForgeTypeId^ get ();
}
static member NewtonMeters : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.NewtonMetersPerMeter Property

UnitTypeIdNewtonMetersPerMeter Property

Newton meters per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId NewtonMetersPerMeter { get; }
Public Shared ReadOnly Property NewtonMetersPerMeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ NewtonMetersPerMeter {
    ForgeTypeId^ get ();
}
static member NewtonMetersPerMeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Newtons Property

UnitTypeIdNewtons Property

Newtons.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Newtons { get; }
Public Shared ReadOnly Property Newtons As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Newtons {
    ForgeTypeId^ get ();
}
static member Newtons : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.NewtonSecondsPerSquareMeter Property

UnitTypeIdNewtonSecondsPerSquareMeter Property

Newton seconds per square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId NewtonSecondsPerSquareMeter { get; }
Public Shared ReadOnly Property NewtonSecondsPerSquareMeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ NewtonSecondsPerSquareMeter {
    ForgeTypeId^ get ();
}
static member NewtonSecondsPerSquareMeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.NewtonsPerMeter Property

UnitTypeIdNewtonsPerMeter Property

Newtons per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId NewtonsPerMeter { get; }
Public Shared ReadOnly Property NewtonsPerMeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ NewtonsPerMeter {
    ForgeTypeId^ get ();
}
static member NewtonsPerMeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.NewtonsPerSquareMeter Property

UnitTypeIdNewtonsPerSquareMeter Property

Newtons per square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId NewtonsPerSquareMeter { get; }
Public Shared ReadOnly Property NewtonsPerSquareMeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ NewtonsPerSquareMeter {
    ForgeTypeId^ get ();
}
static member NewtonsPerSquareMeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.NewtonsPerSquareMillimeter Property

UnitTypeIdNewtonsPerSquareMillimeter Property

Newtons per square millimeter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId NewtonsPerSquareMillimeter { get; }
Public Shared ReadOnly Property NewtonsPerSquareMillimeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ NewtonsPerSquareMillimeter {
    ForgeTypeId^ get ();
}
static member NewtonsPerSquareMillimeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.OhmMeters Property

UnitTypeIdOhmMeters Property

Ohm meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId OhmMeters { get; }
Public Shared ReadOnly Property OhmMeters As ForgeTypeId
    Get
public:
static property ForgeTypeId^ OhmMeters {
    ForgeTypeId^ get ();
}
static member OhmMeters : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.OneToRatio Property

UnitTypeIdOneToRatio Property

1 : Ratio.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId OneToRatio { get; }
Public Shared ReadOnly Property OneToRatio As ForgeTypeId
    Get
public:
static property ForgeTypeId^ OneToRatio {
    ForgeTypeId^ get ();
}
static member OneToRatio : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Pascals Property

UnitTypeIdPascals Property

Pascals.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Pascals { get; }
Public Shared ReadOnly Property Pascals As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Pascals {
    ForgeTypeId^ get ();
}
static member Pascals : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.PascalSeconds Property

UnitTypeIdPascalSeconds Property

Pascal seconds.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PascalSeconds { get; }
Public Shared ReadOnly Property PascalSeconds As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PascalSeconds {
    ForgeTypeId^ get ();
}
static member PascalSeconds : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.PascalsPerMeter Property

UnitTypeIdPascalsPerMeter Property

Pascals per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PascalsPerMeter { get; }
Public Shared ReadOnly Property PascalsPerMeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PascalsPerMeter {
    ForgeTypeId^ get ();
}
static member PascalsPerMeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Percentage Property

UnitTypeIdPercentage Property

Percentage.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Percentage { get; }
Public Shared ReadOnly Property Percentage As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Percentage {
    ForgeTypeId^ get ();
}
static member Percentage : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.PerMille Property

UnitTypeIdPerMille Property

Per mille.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PerMille { get; }
Public Shared ReadOnly Property PerMille As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PerMille {
    ForgeTypeId^ get ();
}
static member PerMille : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Pi Property

UnitTypeIdPi Property

Multiples of Ï€.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Pi { get; }
Public Shared ReadOnly Property Pi As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Pi {
    ForgeTypeId^ get ();
}
static member Pi : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.PoundForceFeet Property

UnitTypeIdPoundForceFeet Property

Pound force feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PoundForceFeet { get; }
Public Shared ReadOnly Property PoundForceFeet As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PoundForceFeet {
    ForgeTypeId^ get ();
}
static member PoundForceFeet : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.PoundForceFeetPerFoot Property

UnitTypeIdPoundForceFeetPerFoot Property

Pound force feet per foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PoundForceFeetPerFoot { get; }
Public Shared ReadOnly Property PoundForceFeetPerFoot As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PoundForceFeetPerFoot {
    ForgeTypeId^ get ();
}
static member PoundForceFeetPerFoot : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.PoundForceSecondsPerSquareFoot Property

UnitTypeIdPoundForceSecondsPerSquareFoot Property

Pound force seconds per square foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PoundForceSecondsPerSquareFoot { get; }
Public Shared ReadOnly Property PoundForceSecondsPerSquareFoot As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PoundForceSecondsPerSquareFoot {
    ForgeTypeId^ get ();
}
static member PoundForceSecondsPerSquareFoot : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.PoundsForce Property

UnitTypeIdPoundsForce Property

Pounds force.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PoundsForce { get; }
Public Shared ReadOnly Property PoundsForce As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PoundsForce {
    ForgeTypeId^ get ();
}
static member PoundsForce : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.PoundsForcePerCubicFoot Property

UnitTypeIdPoundsForcePerCubicFoot Property

Pounds force per cubic foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PoundsForcePerCubicFoot { get; }
Public Shared ReadOnly Property PoundsForcePerCubicFoot As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PoundsForcePerCubicFoot {
    ForgeTypeId^ get ();
}
static member PoundsForcePerCubicFoot : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.PoundsForcePerFoot Property

UnitTypeIdPoundsForcePerFoot Property

Pounds force per foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PoundsForcePerFoot { get; }
Public Shared ReadOnly Property PoundsForcePerFoot As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PoundsForcePerFoot {
    ForgeTypeId^ get ();
}
static member PoundsForcePerFoot : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.PoundsForcePerSquareFoot Property

UnitTypeIdPoundsForcePerSquareFoot Property

Pounds force per square foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PoundsForcePerSquareFoot { get; }
Public Shared ReadOnly Property PoundsForcePerSquareFoot As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PoundsForcePerSquareFoot {
    ForgeTypeId^ get ();
}
static member PoundsForcePerSquareFoot : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.PoundsForcePerSquareInch Property

UnitTypeIdPoundsForcePerSquareInch Property

Pounds force per square inch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PoundsForcePerSquareInch { get; }
Public Shared ReadOnly Property PoundsForcePerSquareInch As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PoundsForcePerSquareInch {
    ForgeTypeId^ get ();
}
static member PoundsForcePerSquareInch : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.PoundsMass Property

UnitTypeIdPoundsMass Property

Pounds mass.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PoundsMass { get; }
Public Shared ReadOnly Property PoundsMass As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PoundsMass {
    ForgeTypeId^ get ();
}
static member PoundsMass : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.PoundsMassPerCubicFoot Property

UnitTypeIdPoundsMassPerCubicFoot Property

Pounds mass per cubic foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PoundsMassPerCubicFoot { get; }
Public Shared ReadOnly Property PoundsMassPerCubicFoot As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PoundsMassPerCubicFoot {
    ForgeTypeId^ get ();
}
static member PoundsMassPerCubicFoot : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.PoundsMassPerCubicInch Property

UnitTypeIdPoundsMassPerCubicInch Property

Pounds mass per cubic inch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PoundsMassPerCubicInch { get; }
Public Shared ReadOnly Property PoundsMassPerCubicInch As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PoundsMassPerCubicInch {
    ForgeTypeId^ get ();
}
static member PoundsMassPerCubicInch : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.PoundsMassPerFoot Property

UnitTypeIdPoundsMassPerFoot Property

Pounds mass per foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PoundsMassPerFoot { get; }
Public Shared ReadOnly Property PoundsMassPerFoot As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PoundsMassPerFoot {
    ForgeTypeId^ get ();
}
static member PoundsMassPerFoot : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.PoundsMassPerFootHour Property

UnitTypeIdPoundsMassPerFootHour Property

Pounds mass per foot hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PoundsMassPerFootHour { get; }
Public Shared ReadOnly Property PoundsMassPerFootHour As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PoundsMassPerFootHour {
    ForgeTypeId^ get ();
}
static member PoundsMassPerFootHour : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.PoundsMassPerFootSecond Property

UnitTypeIdPoundsMassPerFootSecond Property

Pounds mass per foot second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PoundsMassPerFootSecond { get; }
Public Shared ReadOnly Property PoundsMassPerFootSecond As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PoundsMassPerFootSecond {
    ForgeTypeId^ get ();
}
static member PoundsMassPerFootSecond : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.PoundsMassPerHour Property

UnitTypeIdPoundsMassPerHour Property

Pounds mass per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PoundsMassPerHour { get; }
Public Shared ReadOnly Property PoundsMassPerHour As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PoundsMassPerHour {
    ForgeTypeId^ get ();
}
static member PoundsMassPerHour : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.PoundsMassPerMinute Property

UnitTypeIdPoundsMassPerMinute Property

Pounds mass per minute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PoundsMassPerMinute { get; }
Public Shared ReadOnly Property PoundsMassPerMinute As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PoundsMassPerMinute {
    ForgeTypeId^ get ();
}
static member PoundsMassPerMinute : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.PoundsMassPerPoundDegreeFahrenheit Property

UnitTypeIdPoundsMassPerPoundDegreeFahrenheit Property

Pounds mass per pound degree Fahrenheit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PoundsMassPerPoundDegreeFahrenheit { get; }
Public Shared ReadOnly Property PoundsMassPerPoundDegreeFahrenheit As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PoundsMassPerPoundDegreeFahrenheit {
    ForgeTypeId^ get ();
}
static member PoundsMassPerPoundDegreeFahrenheit : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.PoundsMassPerSecond Property

UnitTypeIdPoundsMassPerSecond Property

Pounds mass per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PoundsMassPerSecond { get; }
Public Shared ReadOnly Property PoundsMassPerSecond As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PoundsMassPerSecond {
    ForgeTypeId^ get ();
}
static member PoundsMassPerSecond : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.PoundsMassPerSquareFoot Property

UnitTypeIdPoundsMassPerSquareFoot Property

Pounds mass per square foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId PoundsMassPerSquareFoot { get; }
Public Shared ReadOnly Property PoundsMassPerSquareFoot As ForgeTypeId
    Get
public:
static property ForgeTypeId^ PoundsMassPerSquareFoot {
    ForgeTypeId^ get ();
}
static member PoundsMassPerSquareFoot : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Radians Property

UnitTypeIdRadians Property

Radians.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Radians { get; }
Public Shared ReadOnly Property Radians As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Radians {
    ForgeTypeId^ get ();
}
static member Radians : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.RadiansPerSecond Property

UnitTypeIdRadiansPerSecond Property

Radians per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RadiansPerSecond { get; }
Public Shared ReadOnly Property RadiansPerSecond As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RadiansPerSecond {
    ForgeTypeId^ get ();
}
static member RadiansPerSecond : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Rankine Property

UnitTypeIdRankine Property

Rankine.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Rankine { get; }
Public Shared ReadOnly Property Rankine As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Rankine {
    ForgeTypeId^ get ();
}
static member Rankine : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.RankineInterval Property

UnitTypeIdRankineInterval Property

Rankine interval.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RankineInterval { get; }
Public Shared ReadOnly Property RankineInterval As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RankineInterval {
    ForgeTypeId^ get ();
}
static member RankineInterval : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.RatioTo1 Property

UnitTypeIdRatioTo1 Property

Ratio : 1.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RatioTo1 { get; }
Public Shared ReadOnly Property RatioTo1 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RatioTo1 {
    ForgeTypeId^ get ();
}
static member RatioTo1 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.RatioTo10 Property

UnitTypeIdRatioTo10 Property

Ratio : 10.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RatioTo10 { get; }
Public Shared ReadOnly Property RatioTo10 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RatioTo10 {
    ForgeTypeId^ get ();
}
static member RatioTo10 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.RatioTo12 Property

UnitTypeIdRatioTo12 Property

Ratio : 12.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RatioTo12 { get; }
Public Shared ReadOnly Property RatioTo12 As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RatioTo12 {
    ForgeTypeId^ get ();
}
static member RatioTo12 : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.RevolutionsPerMinute Property

UnitTypeIdRevolutionsPerMinute Property

Revolutions per minute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RevolutionsPerMinute { get; }
Public Shared ReadOnly Property RevolutionsPerMinute As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RevolutionsPerMinute {
    ForgeTypeId^ get ();
}
static member RevolutionsPerMinute : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.RevolutionsPerSecond Property

UnitTypeIdRevolutionsPerSecond Property

Revolutions per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RevolutionsPerSecond { get; }
Public Shared ReadOnly Property RevolutionsPerSecond As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RevolutionsPerSecond {
    ForgeTypeId^ get ();
}
static member RevolutionsPerSecond : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.RiseDividedBy1000Millimeters Property

UnitTypeIdRiseDividedBy1000Millimeters Property

Rise / 1000 millimeters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RiseDividedBy1000Millimeters { get; }
Public Shared ReadOnly Property RiseDividedBy1000Millimeters As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RiseDividedBy1000Millimeters {
    ForgeTypeId^ get ();
}
static member RiseDividedBy1000Millimeters : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.RiseDividedBy10Feet Property

UnitTypeIdRiseDividedBy10Feet Property

Rise / 10 feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RiseDividedBy10Feet { get; }
Public Shared ReadOnly Property RiseDividedBy10Feet As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RiseDividedBy10Feet {
    ForgeTypeId^ get ();
}
static member RiseDividedBy10Feet : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.RiseDividedBy120Inches Property

UnitTypeIdRiseDividedBy120Inches Property

Rise / 120 inches.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RiseDividedBy120Inches { get; }
Public Shared ReadOnly Property RiseDividedBy120Inches As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RiseDividedBy120Inches {
    ForgeTypeId^ get ();
}
static member RiseDividedBy120Inches : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.RiseDividedBy12Inches Property

UnitTypeIdRiseDividedBy12Inches Property

Rise / 12 inches.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RiseDividedBy12Inches { get; }
Public Shared ReadOnly Property RiseDividedBy12Inches As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RiseDividedBy12Inches {
    ForgeTypeId^ get ();
}
static member RiseDividedBy12Inches : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.RiseDividedBy1Foot Property

UnitTypeIdRiseDividedBy1Foot Property

Rise / 1 foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId RiseDividedBy1Foot { get; }
Public Shared ReadOnly Property RiseDividedBy1Foot As ForgeTypeId
    Get
public:
static property ForgeTypeId^ RiseDividedBy1Foot {
    ForgeTypeId^ get ();
}
static member RiseDividedBy1Foot : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Seconds Property

UnitTypeIdSeconds Property

Seconds.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Seconds { get; }
Public Shared ReadOnly Property Seconds As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Seconds {
    ForgeTypeId^ get ();
}
static member Seconds : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Shaku Property

UnitTypeIdShaku Property

Shaku.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Shaku { get; }
Public Shared ReadOnly Property Shaku As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Shaku {
    ForgeTypeId^ get ();
}
static member Shaku : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.SlopeDegrees Property

UnitTypeIdSlopeDegrees Property

Degrees.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SlopeDegrees { get; }
Public Shared ReadOnly Property SlopeDegrees As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SlopeDegrees {
    ForgeTypeId^ get ();
}
static member SlopeDegrees : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.SquareCentimeters Property

UnitTypeIdSquareCentimeters Property

Square centimeters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SquareCentimeters { get; }
Public Shared ReadOnly Property SquareCentimeters As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SquareCentimeters {
    ForgeTypeId^ get ();
}
static member SquareCentimeters : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.SquareCentimetersPerMeter Property

UnitTypeIdSquareCentimetersPerMeter Property

Square centimeters per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SquareCentimetersPerMeter { get; }
Public Shared ReadOnly Property SquareCentimetersPerMeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SquareCentimetersPerMeter {
    ForgeTypeId^ get ();
}
static member SquareCentimetersPerMeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.SquareFeet Property

UnitTypeIdSquareFeet Property

Square feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SquareFeet { get; }
Public Shared ReadOnly Property SquareFeet As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SquareFeet {
    ForgeTypeId^ get ();
}
static member SquareFeet : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.SquareFeetPer1000BritishThermalUnitsPerHour Property

UnitTypeIdSquareFeetPer1000BritishThermalUnitsPerHour Property

Square feet per thousand British thermal units per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SquareFeetPer1000BritishThermalUnitsPerHour { get; }
Public Shared ReadOnly Property SquareFeetPer1000BritishThermalUnitsPerHour As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SquareFeetPer1000BritishThermalUnitsPerHour {
    ForgeTypeId^ get ();
}
static member SquareFeetPer1000BritishThermalUnitsPerHour : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.SquareFeetPerFoot Property

UnitTypeIdSquareFeetPerFoot Property

Square feet per foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SquareFeetPerFoot { get; }
Public Shared ReadOnly Property SquareFeetPerFoot As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SquareFeetPerFoot {
    ForgeTypeId^ get ();
}
static member SquareFeetPerFoot : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.SquareFeetPerKip Property

UnitTypeIdSquareFeetPerKip Property

Square feet per kip.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SquareFeetPerKip { get; }
Public Shared ReadOnly Property SquareFeetPerKip As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SquareFeetPerKip {
    ForgeTypeId^ get ();
}
static member SquareFeetPerKip : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.SquareFeetPerSecond Property

UnitTypeIdSquareFeetPerSecond Property

Square feet per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SquareFeetPerSecond { get; }
Public Shared ReadOnly Property SquareFeetPerSecond As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SquareFeetPerSecond {
    ForgeTypeId^ get ();
}
static member SquareFeetPerSecond : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.SquareFeetPerTonOfRefrigeration Property

UnitTypeIdSquareFeetPerTonOfRefrigeration Property

Square feet per ton of refrigeration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SquareFeetPerTonOfRefrigeration { get; }
Public Shared ReadOnly Property SquareFeetPerTonOfRefrigeration As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SquareFeetPerTonOfRefrigeration {
    ForgeTypeId^ get ();
}
static member SquareFeetPerTonOfRefrigeration : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.SquareInches Property

UnitTypeIdSquareInches Property

Square inches.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SquareInches { get; }
Public Shared ReadOnly Property SquareInches As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SquareInches {
    ForgeTypeId^ get ();
}
static member SquareInches : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.SquareInchesPerFoot Property

UnitTypeIdSquareInchesPerFoot Property

Square inches per foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SquareInchesPerFoot { get; }
Public Shared ReadOnly Property SquareInchesPerFoot As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SquareInchesPerFoot {
    ForgeTypeId^ get ();
}
static member SquareInchesPerFoot : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.SquareMeterKelvinsPerWatt Property

UnitTypeIdSquareMeterKelvinsPerWatt Property

Square meter kelvins per watt.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SquareMeterKelvinsPerWatt { get; }
Public Shared ReadOnly Property SquareMeterKelvinsPerWatt As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SquareMeterKelvinsPerWatt {
    ForgeTypeId^ get ();
}
static member SquareMeterKelvinsPerWatt : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.SquareMeters Property

UnitTypeIdSquareMeters Property

Square meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SquareMeters { get; }
Public Shared ReadOnly Property SquareMeters As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SquareMeters {
    ForgeTypeId^ get ();
}
static member SquareMeters : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.SquareMetersPerKilonewton Property

UnitTypeIdSquareMetersPerKilonewton Property

Square meters per kilonewton.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SquareMetersPerKilonewton { get; }
Public Shared ReadOnly Property SquareMetersPerKilonewton As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SquareMetersPerKilonewton {
    ForgeTypeId^ get ();
}
static member SquareMetersPerKilonewton : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.SquareMetersPerKilowatt Property

UnitTypeIdSquareMetersPerKilowatt Property

Square meters per kilowatt.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SquareMetersPerKilowatt { get; }
Public Shared ReadOnly Property SquareMetersPerKilowatt As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SquareMetersPerKilowatt {
    ForgeTypeId^ get ();
}
static member SquareMetersPerKilowatt : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.SquareMetersPerMeter Property

UnitTypeIdSquareMetersPerMeter Property

Square meters per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SquareMetersPerMeter { get; }
Public Shared ReadOnly Property SquareMetersPerMeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SquareMetersPerMeter {
    ForgeTypeId^ get ();
}
static member SquareMetersPerMeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.SquareMetersPerSecond Property

UnitTypeIdSquareMetersPerSecond Property

Square meters per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SquareMetersPerSecond { get; }
Public Shared ReadOnly Property SquareMetersPerSecond As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SquareMetersPerSecond {
    ForgeTypeId^ get ();
}
static member SquareMetersPerSecond : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.SquareMillimeters Property

UnitTypeIdSquareMillimeters Property

Square millimeters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SquareMillimeters { get; }
Public Shared ReadOnly Property SquareMillimeters As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SquareMillimeters {
    ForgeTypeId^ get ();
}
static member SquareMillimeters : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.SquareMillimetersPerMeter Property

UnitTypeIdSquareMillimetersPerMeter Property

Square millimeters per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId SquareMillimetersPerMeter { get; }
Public Shared ReadOnly Property SquareMillimetersPerMeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ SquareMillimetersPerMeter {
    ForgeTypeId^ get ();
}
static member SquareMillimetersPerMeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.StationingFeet Property

UnitTypeIdStationingFeet Property

Feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StationingFeet { get; }
Public Shared ReadOnly Property StationingFeet As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StationingFeet {
    ForgeTypeId^ get ();
}
static member StationingFeet : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.StationingMeters Property

UnitTypeIdStationingMeters Property

Meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StationingMeters { get; }
Public Shared ReadOnly Property StationingMeters As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StationingMeters {
    ForgeTypeId^ get ();
}
static member StationingMeters : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.StationingSurveyFeet Property

UnitTypeIdStationingSurveyFeet Property

US survey feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId StationingSurveyFeet { get; }
Public Shared ReadOnly Property StationingSurveyFeet As ForgeTypeId
    Get
public:
static property ForgeTypeId^ StationingSurveyFeet {
    ForgeTypeId^ get ();
}
static member StationingSurveyFeet : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Therms Property

UnitTypeIdTherms Property

Therms.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Therms { get; }
Public Shared ReadOnly Property Therms As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Therms {
    ForgeTypeId^ get ();
}
static member Therms : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.ThousandBritishThermalUnitsPerHour Property

UnitTypeIdThousandBritishThermalUnitsPerHour Property

Thousand British thermal units per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId ThousandBritishThermalUnitsPerHour { get; }
Public Shared ReadOnly Property ThousandBritishThermalUnitsPerHour As ForgeTypeId
    Get
public:
static property ForgeTypeId^ ThousandBritishThermalUnitsPerHour {
    ForgeTypeId^ get ();
}
static member ThousandBritishThermalUnitsPerHour : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.TonneForceMeters Property

UnitTypeIdTonneForceMeters Property

Tonne force meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TonneForceMeters { get; }
Public Shared ReadOnly Property TonneForceMeters As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TonneForceMeters {
    ForgeTypeId^ get ();
}
static member TonneForceMeters : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.TonneForceMetersPerMeter Property

UnitTypeIdTonneForceMetersPerMeter Property

Tonne force meters per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TonneForceMetersPerMeter { get; }
Public Shared ReadOnly Property TonneForceMetersPerMeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TonneForceMetersPerMeter {
    ForgeTypeId^ get ();
}
static member TonneForceMetersPerMeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Tonnes Property

UnitTypeIdTonnes Property

Tonnes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Tonnes { get; }
Public Shared ReadOnly Property Tonnes As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Tonnes {
    ForgeTypeId^ get ();
}
static member Tonnes : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.TonnesForce Property

UnitTypeIdTonnesForce Property

Tonnes force.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TonnesForce { get; }
Public Shared ReadOnly Property TonnesForce As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TonnesForce {
    ForgeTypeId^ get ();
}
static member TonnesForce : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.TonnesForcePerMeter Property

UnitTypeIdTonnesForcePerMeter Property

Tonnes force per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TonnesForcePerMeter { get; }
Public Shared ReadOnly Property TonnesForcePerMeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TonnesForcePerMeter {
    ForgeTypeId^ get ();
}
static member TonnesForcePerMeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.TonnesForcePerSquareMeter Property

UnitTypeIdTonnesForcePerSquareMeter Property

Tonnes force per square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TonnesForcePerSquareMeter { get; }
Public Shared ReadOnly Property TonnesForcePerSquareMeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TonnesForcePerSquareMeter {
    ForgeTypeId^ get ();
}
static member TonnesForcePerSquareMeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.TonsOfRefrigeration Property

UnitTypeIdTonsOfRefrigeration Property

Tons of refrigeration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId TonsOfRefrigeration { get; }
Public Shared ReadOnly Property TonsOfRefrigeration As ForgeTypeId
    Get
public:
static property ForgeTypeId^ TonsOfRefrigeration {
    ForgeTypeId^ get ();
}
static member TonsOfRefrigeration : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.UsGallons Property

UnitTypeIdUsGallons Property

US gallons.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId UsGallons { get; }
Public Shared ReadOnly Property UsGallons As ForgeTypeId
    Get
public:
static property ForgeTypeId^ UsGallons {
    ForgeTypeId^ get ();
}
static member UsGallons : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.UsGallonsPerHour Property

UnitTypeIdUsGallonsPerHour Property

US gallons per hour.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId UsGallonsPerHour { get; }
Public Shared ReadOnly Property UsGallonsPerHour As ForgeTypeId
    Get
public:
static property ForgeTypeId^ UsGallonsPerHour {
    ForgeTypeId^ get ();
}
static member UsGallonsPerHour : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.UsGallonsPerMinute Property

UnitTypeIdUsGallonsPerMinute Property

US gallons per minute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId UsGallonsPerMinute { get; }
Public Shared ReadOnly Property UsGallonsPerMinute As ForgeTypeId
    Get
public:
static property ForgeTypeId^ UsGallonsPerMinute {
    ForgeTypeId^ get ();
}
static member UsGallonsPerMinute : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.UsSurveyFeet Property

UnitTypeIdUsSurveyFeet Property

US survey feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId UsSurveyFeet { get; }
Public Shared ReadOnly Property UsSurveyFeet As ForgeTypeId
    Get
public:
static property ForgeTypeId^ UsSurveyFeet {
    ForgeTypeId^ get ();
}
static member UsSurveyFeet : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.UsTonnesForce Property

UnitTypeIdUsTonnesForce Property

US tonnes force.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId UsTonnesForce { get; }
Public Shared ReadOnly Property UsTonnesForce As ForgeTypeId
    Get
public:
static property ForgeTypeId^ UsTonnesForce {
    ForgeTypeId^ get ();
}
static member UsTonnesForce : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.UsTonnesMass Property

UnitTypeIdUsTonnesMass Property

US tonnes mass.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId UsTonnesMass { get; }
Public Shared ReadOnly Property UsTonnesMass As ForgeTypeId
    Get
public:
static property ForgeTypeId^ UsTonnesMass {
    ForgeTypeId^ get ();
}
static member UsTonnesMass : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.VoltAmperes Property

UnitTypeIdVoltAmperes Property

Volt amperes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId VoltAmperes { get; }
Public Shared ReadOnly Property VoltAmperes As ForgeTypeId
    Get
public:
static property ForgeTypeId^ VoltAmperes {
    ForgeTypeId^ get ();
}
static member VoltAmperes : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.VoltAmperesPerSquareFoot Property

UnitTypeIdVoltAmperesPerSquareFoot Property

Volt amperes per square foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId VoltAmperesPerSquareFoot { get; }
Public Shared ReadOnly Property VoltAmperesPerSquareFoot As ForgeTypeId
    Get
public:
static property ForgeTypeId^ VoltAmperesPerSquareFoot {
    ForgeTypeId^ get ();
}
static member VoltAmperesPerSquareFoot : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.VoltAmperesPerSquareMeter Property

UnitTypeIdVoltAmperesPerSquareMeter Property

Volt amperes per square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId VoltAmperesPerSquareMeter { get; }
Public Shared ReadOnly Property VoltAmperesPerSquareMeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ VoltAmperesPerSquareMeter {
    ForgeTypeId^ get ();
}
static member VoltAmperesPerSquareMeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Volts Property

UnitTypeIdVolts Property

Volts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Volts { get; }
Public Shared ReadOnly Property Volts As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Volts {
    ForgeTypeId^ get ();
}
static member Volts : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.Watts Property

UnitTypeIdWatts Property

Watts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId Watts { get; }
Public Shared ReadOnly Property Watts As ForgeTypeId
    Get
public:
static property ForgeTypeId^ Watts {
    ForgeTypeId^ get ();
}
static member Watts : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.WattsPerCubicFoot Property

UnitTypeIdWattsPerCubicFoot Property

Watts per cubic foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WattsPerCubicFoot { get; }
Public Shared ReadOnly Property WattsPerCubicFoot As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WattsPerCubicFoot {
    ForgeTypeId^ get ();
}
static member WattsPerCubicFoot : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.WattsPerCubicFootPerMinute Property

UnitTypeIdWattsPerCubicFootPerMinute Property

Watts per cubic foot per minute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WattsPerCubicFootPerMinute { get; }
Public Shared ReadOnly Property WattsPerCubicFootPerMinute As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WattsPerCubicFootPerMinute {
    ForgeTypeId^ get ();
}
static member WattsPerCubicFootPerMinute : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.WattsPerCubicMeter Property

UnitTypeIdWattsPerCubicMeter Property

Watts per cubic meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WattsPerCubicMeter { get; }
Public Shared ReadOnly Property WattsPerCubicMeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WattsPerCubicMeter {
    ForgeTypeId^ get ();
}
static member WattsPerCubicMeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.WattsPerCubicMeterPerSecond Property

UnitTypeIdWattsPerCubicMeterPerSecond Property

Watts per cubic meter per second.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WattsPerCubicMeterPerSecond { get; }
Public Shared ReadOnly Property WattsPerCubicMeterPerSecond As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WattsPerCubicMeterPerSecond {
    ForgeTypeId^ get ();
}
static member WattsPerCubicMeterPerSecond : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.WattsPerFoot Property

UnitTypeIdWattsPerFoot Property

Watts per foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WattsPerFoot { get; }
Public Shared ReadOnly Property WattsPerFoot As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WattsPerFoot {
    ForgeTypeId^ get ();
}
static member WattsPerFoot : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.WattsPerMeter Property

UnitTypeIdWattsPerMeter Property

Watts per meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WattsPerMeter { get; }
Public Shared ReadOnly Property WattsPerMeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WattsPerMeter {
    ForgeTypeId^ get ();
}
static member WattsPerMeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.WattsPerMeterKelvin Property

UnitTypeIdWattsPerMeterKelvin Property

Watts per meter kelvin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WattsPerMeterKelvin { get; }
Public Shared ReadOnly Property WattsPerMeterKelvin As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WattsPerMeterKelvin {
    ForgeTypeId^ get ();
}
static member WattsPerMeterKelvin : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.WattsPerSquareFoot Property

UnitTypeIdWattsPerSquareFoot Property

Watts per square foot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WattsPerSquareFoot { get; }
Public Shared ReadOnly Property WattsPerSquareFoot As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WattsPerSquareFoot {
    ForgeTypeId^ get ();
}
static member WattsPerSquareFoot : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.WattsPerSquareMeter Property

UnitTypeIdWattsPerSquareMeter Property

Watts per square meter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WattsPerSquareMeter { get; }
Public Shared ReadOnly Property WattsPerSquareMeter As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WattsPerSquareMeter {
    ForgeTypeId^ get ();
}
static member WattsPerSquareMeter : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitTypeId.WattsPerSquareMeterKelvin Property

UnitTypeIdWattsPerSquareMeterKelvin Property

Watts per square meter kelvin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId WattsPerSquareMeterKelvin { get; }
Public Shared ReadOnly Property WattsPerSquareMeterKelvin As ForgeTypeId
    Get
public:
static property ForgeTypeId^ WattsPerSquareMeterKelvin {
    ForgeTypeId^ get ();
}
static member WattsPerSquareMeterKelvin : ForgeTypeId with get

Property Value

ForgeTypeId
See Also

Reference

UnitTypeId Class


UnitUtils Class

A utility class of functions related to units.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBUnitUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class UnitUtils
Public NotInheritable Class UnitUtils
public ref class UnitUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type UnitUtils = class end

The UnitUtils type exposes the following members.

Methods
Name | Description
Convert | Converts a value from one unit to another, such as square feet to square meters.
ConvertFromInternalUnits | Converts a value from Revit's internal units to a given unit.
ConvertToInternalUnits | Converts a value from a given unit to Revit's internal units.
GetAllDisciplines | Gets the identifiers of all available disciplines.
GetAllMeasurableSpecs | Gets the identifiers of all available measurable specs.
GetAllUnits | Gets the identifiers of all available units.
GetDiscipline | Gets the discipline for a given measurable spec.
GetTypeCatalogStringForSpec | Gets the string used in type catalogs to identify a given measurable spec.
GetTypeCatalogStringForUnit | Gets the string used in type catalogs to identify a given unit.
GetValidUnits | Gets the identifiers of all valid units for a given measurable spec.
IsMeasurableSpec | Checks whether a ForgeTypeId identifies a spec associated with units of measurement.
IsSymbol | Checks whether a ForgeTypeId identifies a symbol.
IsUnit | Checks whether a ForgeTypeId identifies a unit.
IsValidUnit | Checks whether a unit is valid for a given measurable spec.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


UnitUtils Methods

The UnitUtils type exposes the following members.

Methods
Name | Description
Convert | Converts a value from one unit to another, such as square feet to square meters.
ConvertFromInternalUnits | Converts a value from Revit's internal units to a given unit.
ConvertToInternalUnits | Converts a value from a given unit to Revit's internal units.
GetAllDisciplines | Gets the identifiers of all available disciplines.
GetAllMeasurableSpecs | Gets the identifiers of all available measurable specs.
GetAllUnits | Gets the identifiers of all available units.
GetDiscipline | Gets the discipline for a given measurable spec.
GetTypeCatalogStringForSpec | Gets the string used in type catalogs to identify a given measurable spec.
GetTypeCatalogStringForUnit | Gets the string used in type catalogs to identify a given unit.
GetValidUnits | Gets the identifiers of all valid units for a given measurable spec.
IsMeasurableSpec | Checks whether a ForgeTypeId identifies a spec associated with units of measurement.
IsSymbol | Checks whether a ForgeTypeId identifies a symbol.
IsUnit | Checks whether a ForgeTypeId identifies a unit.
IsValidUnit | Checks whether a unit is valid for a given measurable spec.
Top
See Also

Reference

UnitUtils Class


UnitUtils.Convert Method

UnitUtilsConvert Method

Converts a value from one unit to another, such as square feet to square meters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static double Convert(
    double value,
    ForgeTypeId currentUnitTypeId,
    ForgeTypeId desiredUnitTypeId
)
Public Shared Function Convert (
    value As Double,
    currentUnitTypeId As ForgeTypeId,
    desiredUnitTypeId As ForgeTypeId
) As Double
public:
static double Convert(
    double value,
    ForgeTypeId^ currentUnitTypeId,
    ForgeTypeId^ desiredUnitTypeId
)
static member Convert :
        value : float *
        currentUnitTypeId : ForgeTypeId *
        desiredUnitTypeId : ForgeTypeId -> float

Parameters

value Double
The value to convert.
currentUnitTypeId ForgeTypeId
Identifier of the current unit.
desiredUnitTypeId ForgeTypeId
Identifier of the desired unit.

Return Value

Double
The converted value.
Exceptions
Exception | Condition
ArgumentException | The given value for value is not finite -or- currentUnitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType). -or- desiredUnitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType).
ArgumentNullException | A non-optional argument was null
ArgumentsInconsistentException | currentUnitTypeId and desiredUnitTypeId have different dimensions.
See Also

Reference

UnitUtils Class


UnitUtils.ConvertFromInternalUnits Method

UnitUtilsConvertFromInternalUnits Method

Converts a value from Revit's internal units to a given unit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static double ConvertFromInternalUnits(
    double value,
    ForgeTypeId unitTypeId
)
Public Shared Function ConvertFromInternalUnits (
    value As Double,
    unitTypeId As ForgeTypeId
) As Double
public:
static double ConvertFromInternalUnits(
    double value,
    ForgeTypeId^ unitTypeId
)
static member ConvertFromInternalUnits :
        value : float *
        unitTypeId : ForgeTypeId -> float

Parameters

value Double
The value to convert.
unitTypeId ForgeTypeId
Identifier of the desired unit.

Return Value

Double
The converted value.
Exceptions
Exception | Condition
ArgumentException | The given value for value is not finite -or- unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType).
ArgumentNullException | A non-optional argument was null
See Also

Reference

UnitUtils Class


UnitUtils.ConvertToInternalUnits Method

UnitUtilsConvertToInternalUnits Method

Converts a value from a given unit to Revit's internal units.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static double ConvertToInternalUnits(
    double value,
    ForgeTypeId unitTypeId
)
Public Shared Function ConvertToInternalUnits (
    value As Double,
    unitTypeId As ForgeTypeId
) As Double
public:
static double ConvertToInternalUnits(
    double value,
    ForgeTypeId^ unitTypeId
)
static member ConvertToInternalUnits :
        value : float *
        unitTypeId : ForgeTypeId -> float

Parameters

value Double
The value to convert.
unitTypeId ForgeTypeId
Identifier of the unit quantifying the value.

Return Value

Double
The converted value.
Exceptions
Exception | Condition
ArgumentException | The given value for value is not finite -or- unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType).
ArgumentNullException | A non-optional argument was null
See Also

Reference

UnitUtils Class


UnitUtils.GetAllDisciplines Method

UnitUtilsGetAllDisciplines Method

Gets the identifiers of all available disciplines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<ForgeTypeId> GetAllDisciplines()
Public Shared Function GetAllDisciplines As IList(Of ForgeTypeId)
public:
static IList<ForgeTypeId^>^ GetAllDisciplines()
static member GetAllDisciplines : unit -> IList<ForgeTypeId>

Return Value

IList ForgeTypeId
The discipline identifiers.
See Also

Reference

UnitUtils Class


UnitUtils.GetAllMeasurableSpecs Method

UnitUtilsGetAllMeasurableSpecs Method

Gets the identifiers of all available measurable specs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<ForgeTypeId> GetAllMeasurableSpecs()
Public Shared Function GetAllMeasurableSpecs As IList(Of ForgeTypeId)
public:
static IList<ForgeTypeId^>^ GetAllMeasurableSpecs()
static member GetAllMeasurableSpecs : unit -> IList<ForgeTypeId>

Return Value

IList ForgeTypeId
The spec identifiers.
See Also

Reference

UnitUtils Class


UnitUtils.GetAllUnits Method

UnitUtilsGetAllUnits Method

Gets the identifiers of all available units.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<ForgeTypeId> GetAllUnits()
Public Shared Function GetAllUnits As IList(Of ForgeTypeId)
public:
static IList<ForgeTypeId^>^ GetAllUnits()
static member GetAllUnits : unit -> IList<ForgeTypeId>

Return Value

IList ForgeTypeId
The unit identifiers.
See Also

Reference

UnitUtils Class


UnitUtils.GetDiscipline Method

UnitUtilsGetDiscipline Method

Gets the discipline for a given measurable spec.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ForgeTypeId GetDiscipline(
    ForgeTypeId specTypeId
)
Public Shared Function GetDiscipline (
    specTypeId As ForgeTypeId
) As ForgeTypeId
public:
static ForgeTypeId^ GetDiscipline(
    ForgeTypeId^ specTypeId
)
static member GetDiscipline :
        specTypeId : ForgeTypeId -> ForgeTypeId

Parameters

specTypeId ForgeTypeId
Identifier of the measurable spec.

Return Value

ForgeTypeId
Identifier of the discipline.
Exceptions
Exception | Condition
ArgumentException | specTypeId is not a measurable spec identifier. See UnitUtils.IsMeasurableSpec(ForgeTypeId).
ArgumentNullException | A non-optional argument was null
See Also

Reference

UnitUtils Class


UnitUtils.GetTypeCatalogStringForSpec Method

UnitUtilsGetTypeCatalogStringForSpec Method

Gets the string used in type catalogs to identify a given measurable spec.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetTypeCatalogStringForSpec(
    ForgeTypeId specTypeId
)
Public Shared Function GetTypeCatalogStringForSpec (
    specTypeId As ForgeTypeId
) As String
public:
static String^ GetTypeCatalogStringForSpec(
    ForgeTypeId^ specTypeId
)
static member GetTypeCatalogStringForSpec :
        specTypeId : ForgeTypeId -> string

Parameters

specTypeId ForgeTypeId
Identifier of the measurable spec.

Return Value

String
The type catalog string, or an empty string if the measurable spec cannot be used in type catalogs.
Exceptions
Exception | Condition
ArgumentException | specTypeId is not a measurable spec identifier. See UnitUtils.IsMeasurableSpec(ForgeTypeId).
ArgumentNullException | A non-optional argument was null
See Also

Reference

UnitUtils Class


UnitUtils.GetTypeCatalogStringForUnit Method

UnitUtilsGetTypeCatalogStringForUnit Method

Gets the string used in type catalogs to identify a given unit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetTypeCatalogStringForUnit(
    ForgeTypeId unitTypeId
)
Public Shared Function GetTypeCatalogStringForUnit (
    unitTypeId As ForgeTypeId
) As String
public:
static String^ GetTypeCatalogStringForUnit(
    ForgeTypeId^ unitTypeId
)
static member GetTypeCatalogStringForUnit :
        unitTypeId : ForgeTypeId -> string

Parameters

unitTypeId ForgeTypeId
Identifier of the unit.

Return Value

String
The type catalog string, or an empty string if the unit cannot be used in type catalogs.
Exceptions
Exception | Condition
ArgumentException | unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType).
ArgumentNullException | A non-optional argument was null
See Also

Reference

UnitUtils Class


UnitUtils.GetValidUnits Method

UnitUtilsGetValidUnits Method

Gets the identifiers of all valid units for a given measurable spec.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<ForgeTypeId> GetValidUnits(
    ForgeTypeId specTypeId
)
Public Shared Function GetValidUnits (
    specTypeId As ForgeTypeId
) As IList(Of ForgeTypeId)
public:
static IList<ForgeTypeId^>^ GetValidUnits(
    ForgeTypeId^ specTypeId
)
static member GetValidUnits :
        specTypeId : ForgeTypeId -> IList<ForgeTypeId>

Parameters

specTypeId ForgeTypeId
Identifier of the measurable spec.

Return Value

IList ForgeTypeId
Identifiers of the valid units.
Exceptions
Exception | Condition
ArgumentException | specTypeId is not a measurable spec identifier. See UnitUtils.IsMeasurableSpec(ForgeTypeId).
ArgumentNullException | A non-optional argument was null
See Also

Reference

UnitUtils Class


UnitUtils.IsMeasurableSpec Method

UnitUtilsIsMeasurableSpec Method

Checks whether a ForgeTypeId identifies a spec associated with units of measurement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsMeasurableSpec(
    ForgeTypeId specTypeId
)
Public Shared Function IsMeasurableSpec (
    specTypeId As ForgeTypeId
) As Boolean
public:
static bool IsMeasurableSpec(
    ForgeTypeId^ specTypeId
)
static member IsMeasurableSpec :
        specTypeId : ForgeTypeId -> bool

Parameters

specTypeId ForgeTypeId
The identifier to check.

Return Value

Boolean
True if the ForgeTypeId identifies a measurable spec, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

UnitUtils Class


UnitUtils.IsSymbol Method

UnitUtilsIsSymbol Method

Checks whether a ForgeTypeId identifies a symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsSymbol(
    ForgeTypeId symbolTypeId
)
Public Shared Function IsSymbol (
    symbolTypeId As ForgeTypeId
) As Boolean
public:
static bool IsSymbol(
    ForgeTypeId^ symbolTypeId
)
static member IsSymbol :
        symbolTypeId : ForgeTypeId -> bool

Parameters

symbolTypeId ForgeTypeId
The identifier to check.

Return Value

Boolean
True if the ForgeTypeId identifies a symbol, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
The SymbolTypeId class offers symbol identifiers.
See Also

Reference

UnitUtils Class


UnitUtils.IsUnit Method

UnitUtilsIsUnit Method

Checks whether a ForgeTypeId identifies a unit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsUnit(
    ForgeTypeId unitTypeId
)
Public Shared Function IsUnit (
    unitTypeId As ForgeTypeId
) As Boolean
public:
static bool IsUnit(
    ForgeTypeId^ unitTypeId
)
static member IsUnit :
        unitTypeId : ForgeTypeId -> bool

Parameters

unitTypeId ForgeTypeId
The identifier to check.

Return Value

Boolean
True if the ForgeTypeId identifies a unit, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
The UnitTypeId class offers unit identifiers.
See Also

Reference

UnitUtils Class


UnitUtils.IsValidUnit Method

UnitUtilsIsValidUnit Method

Checks whether a unit is valid for a given measurable spec.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidUnit(
    ForgeTypeId specTypeId,
    ForgeTypeId unitTypeId
)
Public Shared Function IsValidUnit (
    specTypeId As ForgeTypeId,
    unitTypeId As ForgeTypeId
) As Boolean
public:
static bool IsValidUnit(
    ForgeTypeId^ specTypeId,
    ForgeTypeId^ unitTypeId
)
static member IsValidUnit :
        specTypeId : ForgeTypeId *
        unitTypeId : ForgeTypeId -> bool

Parameters

specTypeId ForgeTypeId
Identifier of the measurable spec.
unitTypeId ForgeTypeId
Identifier of the unit to check.

Return Value

Boolean
True if the unit is valid, false otherwise.
Exceptions
Exception | Condition
ArgumentException | specTypeId is not a measurable spec identifier. See UnitUtils.IsMeasurableSpec(ForgeTypeId).
ArgumentNullException | A non-optional argument was null
See Also

Reference

UnitUtils Class


UpdaterData Class

Service class that is passed to an Updater to prove access to update execution context
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBUpdaterData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class UpdaterData : IDisposable
Public Class UpdaterData
    Implements IDisposable
public ref class UpdaterData : IDisposable
type UpdaterData =
    class
        interface IDisposable
    end

The UpdaterData type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the UpdaterData
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAddedElementIds | Returns set of elements newly added to the document. This set is mutually exclusive of elements returned by getDeletedElementIds() and getModifiedElementIds().
Public method | GetDeletedElementIds | Returns set of elements that were deleted from the document. This set is mutually exclusive of elements returned by getAddedElementIds() and getModifiedElementIds().
Public method | GetDocument | Returns document associated with this UpdaterData
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetModifiedElementIds | Returns set of elements that were modified. This set is mutually exclusive of elements returned by getAddedElementIds() and getDeletedElementIds().
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsChangeTriggered | Allows updater to check if specific change has happened to an element. Compares input type to the types that caused Updater::execute() to be triggered. If input type was not registered as a trigger for the associated Updater, this method will always return false for that ChangeType. For example, if the only trigger registered for UpdaterX is ChangeTypeAny for Element A, then passing in ChangeTypeGeometry will return false even if the geometry of A changed because the registered trigger was ChangeTypeAny. However, passing in ChangeTypeAny will return true.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


UpdaterData Properties

The UpdaterData type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

UpdaterData Class


UpdaterData.IsValidObject Property

UpdaterDataIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

UpdaterData Class


UpdaterData Methods

The UpdaterData type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAddedElementIds | Returns set of elements newly added to the document. This set is mutually exclusive of elements returned by getDeletedElementIds() and getModifiedElementIds().
Public method | GetDeletedElementIds | Returns set of elements that were deleted from the document. This set is mutually exclusive of elements returned by getAddedElementIds() and getModifiedElementIds().
Public method | GetDocument | Returns document associated with this UpdaterData
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetModifiedElementIds | Returns set of elements that were modified. This set is mutually exclusive of elements returned by getAddedElementIds() and getDeletedElementIds().
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsChangeTriggered | Allows updater to check if specific change has happened to an element. Compares input type to the types that caused Updater::execute() to be triggered. If input type was not registered as a trigger for the associated Updater, this method will always return false for that ChangeType. For example, if the only trigger registered for UpdaterX is ChangeTypeAny for Element A, then passing in ChangeTypeGeometry will return false even if the geometry of A changed because the registered trigger was ChangeTypeAny. However, passing in ChangeTypeAny will return true.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

UpdaterData Class


UpdaterData.Dispose Method

UpdaterDataDispose Method

Releases all resources used by the UpdaterData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

UpdaterData Class


UpdaterData.GetAddedElementIds Method

UpdaterDataGetAddedElementIds Method

Returns set of elements newly added to the document. This set is mutually exclusive of elements returned by getDeletedElementIds() and getModifiedElementIds().

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetAddedElementIds()
Public Function GetAddedElementIds As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetAddedElementIds()
member GetAddedElementIds : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
Set of elements that were added to the document and triggered the call to execute() Note: This will only return elements if the trigger registered for the associated updater contains the ChangeType returned by Element::getChangeTypeElementAddition()
See Also

Reference

UpdaterData Class


UpdaterData.GetDeletedElementIds Method

UpdaterDataGetDeletedElementIds Method

Returns set of elements that were deleted from the document. This set is mutually exclusive of elements returned by getAddedElementIds() and getModifiedElementIds().

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetDeletedElementIds()
Public Function GetDeletedElementIds As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetDeletedElementIds()
member GetDeletedElementIds : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
Set of elements that were deleted from the document and triggered the call to execute() Note: This will only return elements if the trigger registered for the associated updater contains the ChangeType returned by Element::getChangeTypeElementDeletion()
See Also

Reference

UpdaterData Class


UpdaterData.GetDocument Method

UpdaterDataGetDocument Method

Returns document associated with this UpdaterData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Document GetDocument()
Public Function GetDocument As Document
public:
Document^ GetDocument()
member GetDocument : unit -> Document

Return Value

Document
See Also

Reference

UpdaterData Class


UpdaterData.GetModifiedElementIds Method

UpdaterDataGetModifiedElementIds Method

Returns set of elements that were modified. This set is mutually exclusive of elements returned by getAddedElementIds() and getDeletedElementIds().

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetModifiedElementIds()
Public Function GetModifiedElementIds As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetModifiedElementIds()
member GetModifiedElementIds : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
Set of elements that were modified in the document and triggered the call to execute() Note: This set only contains modified elements (i.e. it is mutually exclusive of elements returned by getAddedElementIds() and getDeletedElementIds()). It does not contain any elements that were added to or deleted from the document during the current transaction. Newly added/deleted elements will be reported by getAddedElementIds()/getDeletedElementIds(), even if they were also modified during the same transaction, but only if ChangeTypeElementAddition/Deletion is registered as a trigger for the current Updater. I.e. Element creation and modification in the same transaction is considered to be "creation" only. Newly created elements are not considered to be "modified" and are therefore not returned as part of getModifiedElementIds()
See Also

Reference

UpdaterData Class


UpdaterData.IsChangeTriggered Method

UpdaterDataIsChangeTriggered Method

Allows updater to check if specific change has happened to an element. Compares input type to the types that caused Updater::execute() to be triggered. If input type was not registered as a trigger for the associated Updater, this method will always return false for that ChangeType. For example, if the only trigger registered for UpdaterX is ChangeTypeAny for Element A, then passing in ChangeTypeGeometry will return false even if the geometry of A changed because the registered trigger was ChangeTypeAny. However, passing in ChangeTypeAny will return true.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsChangeTriggered(
    ElementId id,
    ChangeType type
)
Public Function IsChangeTriggered (
    id As ElementId,
    type As ChangeType
) As Boolean
public:
bool IsChangeTriggered(
    ElementId^ id,
    ChangeType^ type
)
member IsChangeTriggered :
        id : ElementId *
        type : ChangeType -> bool

Parameters

id ElementId
Id of element to check
type ChangeType
ChangeType to check

Return Value

Boolean
True if ChangeType happened to specified element
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

UpdaterData Class


UpdaterId Class

A unique identifier of an Updater
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBUpdaterId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class UpdaterId : IDisposable
Public Class UpdaterId
    Implements IDisposable
public ref class UpdaterId : IDisposable
type UpdaterId =
    class
        interface IDisposable
    end

The UpdaterId type exposes the following members.

Constructors
 | Name | Description
Public method | UpdaterId | creates an instance of UpdaterId for given AddInId and a given GUID value
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the UpdaterId
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAddInId | AddInId of the UpdaterId
Public method | GetGUID | GUID value of the UpdaterId
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
UpdaterID used as a key to register and unregister Updaters and UpdateTriggers in Revit application
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


UpdaterId Constructor

creates an instance of UpdaterId for given AddInId and a given GUID value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public UpdaterId(
    AddInId addInId,
    Guid val
)
Public Sub New (
    addInId As AddInId,
    val As Guid
)
public:
UpdaterId(
    AddInId^ addInId,
    Guid val
)
new :
        addInId : AddInId *
        val : Guid -> UpdaterId

Parameters

addInId AddInId
Id of addin that registers an Updater
val Guid
a GUID identifying the Updater within addin
Exceptions
Exception | Condition
ArgumentException | addInId is not valid.
ArgumentNullException | A non-optional argument was null
See Also

Reference

UpdaterId Class


UpdaterId Properties

The UpdaterId type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

UpdaterId Class


UpdaterId.IsValidObject Property

UpdaterIdIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

UpdaterId Class


UpdaterId Methods

The UpdaterId type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAddInId | AddInId of the UpdaterId
Public method | GetGUID | GUID value of the UpdaterId
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

UpdaterId Class


UpdaterId.Dispose Method

UpdaterIdDispose Method

Releases all resources used by the UpdaterId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

UpdaterId Class


UpdaterId.GetAddInId Method

UpdaterIdGetAddInId Method

AddInId of the UpdaterId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AddInId GetAddInId()
Public Function GetAddInId As AddInId
public:
AddInId^ GetAddInId()
member GetAddInId : unit -> AddInId

Return Value

AddInId
See Also

Reference

UpdaterId Class


UpdaterId.GetGUID Method

UpdaterIdGetGUID Method

GUID value of the UpdaterId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid GetGUID()
Public Function GetGUID As Guid
public:
Guid GetGUID()
member GetGUID : unit -> Guid

Return Value

Guid
See Also

Reference

UpdaterId Class


UpdaterInfo Class

Information of an updater, such as: Name, AdditionalInformation, name of the application that owns the updater, etc.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBUpdaterInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class UpdaterInfo : IDisposable
Public Class UpdaterInfo
    Implements IDisposable
public ref class UpdaterInfo : IDisposable
type UpdaterInfo =
    class
        interface IDisposable
    end

The UpdaterInfo type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalInformation | Additional information about the updater.
Public property | ApplicationName | Name of the application that owns the updater.
Public property | IsOptional | Whether the updater is optional or not.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | UpdaterName | Name of the updater.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the UpdaterInfo
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


UpdaterInfo Properties

The UpdaterInfo type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalInformation | Additional information about the updater.
Public property | ApplicationName | Name of the application that owns the updater.
Public property | IsOptional | Whether the updater is optional or not.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | UpdaterName | Name of the updater.
Top
See Also

Reference

UpdaterInfo Class


UpdaterInfo.AdditionalInformation Property

UpdaterInfoAdditionalInformation Property

Additional information about the updater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string AdditionalInformation { get; }
Public ReadOnly Property AdditionalInformation As String
    Get
public:
property String^ AdditionalInformation {
    String^ get ();
}
member AdditionalInformation : string with get

Property Value

String
See Also

Reference

UpdaterInfo Class


UpdaterInfo.ApplicationName Property

UpdaterInfoApplicationName Property

Name of the application that owns the updater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ApplicationName { get; }
Public ReadOnly Property ApplicationName As String
    Get
public:
property String^ ApplicationName {
    String^ get ();
}
member ApplicationName : string with get

Property Value

String
See Also

Reference

UpdaterInfo Class


UpdaterInfo.IsOptional Property

UpdaterInfoIsOptional Property

Whether the updater is optional or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsOptional { get; }
Public ReadOnly Property IsOptional As Boolean
    Get
public:
property bool IsOptional {
    bool get ();
}
member IsOptional : bool with get

Property Value

Boolean
See Also

Reference

UpdaterInfo Class


UpdaterInfo.IsValidObject Property

UpdaterInfoIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

UpdaterInfo Class


UpdaterInfo.UpdaterName Property

UpdaterInfoUpdaterName Property

Name of the updater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string UpdaterName { get; }
Public ReadOnly Property UpdaterName As String
    Get
public:
property String^ UpdaterName {
    String^ get ();
}
member UpdaterName : string with get

Property Value

String
See Also

Reference

UpdaterInfo Class


UpdaterInfo Methods

The UpdaterInfo type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

UpdaterInfo Class


UpdaterInfo.Dispose Method

UpdaterInfoDispose Method

Releases all resources used by the UpdaterInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

UpdaterInfo Class


UpdaterRegistry Class

An object that stores and manages all updaters registered in the current session.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBUpdaterRegistry

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class UpdaterRegistry : IDisposable
Public Class UpdaterRegistry
    Implements IDisposable
public ref class UpdaterRegistry : IDisposable
type UpdaterRegistry =
    class
        interface IDisposable
    end

The UpdaterRegistry type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
 | AddTrigger(UpdaterId, ElementFilter, ChangeType) | Adds trigger with the specified element filter and ChangeType for all documents associated with this Updater
 | AddTrigger(UpdaterId, Document, ElementFilter, ChangeType) | Adds trigger with the specified element filter and ChangeType for the specified document
 | AddTrigger(UpdaterId, Document, ICollectionElementId, ChangeType) | Adds a trigger to an updater with specified set of elements and ChangeType
 | DisableUpdater | Disables the updater.
Public method | Dispose | Releases all resources used by the UpdaterRegistry
 | EnableUpdater | Enables the updater.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
 | GetIsUpdaterOptional | Check if the updater is optional or not.
 | GetRegisteredUpdaterInfos | Returns UpdaterInfos for all the application-wide updaters.
 | GetRegisteredUpdaterInfos(Document) | Returns information about all updaters applicable to the given document.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | IsUpdaterEnabled | Checks if the updater is enabled or not.
 | IsUpdaterRegistered(UpdaterId) | Checks whether updater with the given id is registered
 | IsUpdaterRegistered(UpdaterId, Document) | Checks whether updater with the given id is registered in a document.
 | RegisterUpdater(IUpdater) | Registers an updater application-wide, which means the updater may get triggered in any open document.
 | RegisterUpdater(IUpdater, Document) | Registers the updater for a specified document, which means the updater can only be triggered by changes made in that document.
 | RegisterUpdater(IUpdater, Boolean) | Registers an updater application-wide, which means the updater may get triggered in any open document.
 | RegisterUpdater(IUpdater, Document, Boolean) | Registers the updater for a specified document, which means the updater can only be triggered by changes made in that document.
 | RemoveAllTriggers | Removes all triggers associated with Updater with specified UpdaterId. Does not unregister updater.
 | RemoveDocumentTriggers | Removes all triggers associated with specified document and Updater Does not unregister updater.
 | SetExecutionOrder | Forces execution order between two updaters Execution order: first before second
 | SetIsUpdaterOptional | Sets a flag indicating whether an updater is optional or not.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
 | UnregisterUpdater(UpdaterId) | Removes the updater associated with the input id from the UpdaterRegistry. Also removes all triggers associated with the Updater.
 | UnregisterUpdater(UpdaterId, Document) | Unregisters an updater for the given document.
Top
Remarks

The registry is an application-wide singleton. It maintains all dynamic updaters currently registered, and also invokes them per their respective trigger condition during subsequent transactions.

Please note that only the application (an add-in, typically) which registered an updater is allowed to modify it later, including unregistering it. Also, an application is not allowed to register an updater with an Id, that is based on another application's Id.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


UpdaterRegistry Properties

The UpdaterRegistry type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

UpdaterRegistry Class


UpdaterRegistry.IsValidObject Property

UpdaterRegistryIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

UpdaterRegistry Class


UpdaterRegistry Methods

The UpdaterRegistry type exposes the following members.

Methods
 | Name | Description
 | AddTrigger(UpdaterId, ElementFilter, ChangeType) | Adds trigger with the specified element filter and ChangeType for all documents associated with this Updater
 | AddTrigger(UpdaterId, Document, ElementFilter, ChangeType) | Adds trigger with the specified element filter and ChangeType for the specified document
 | AddTrigger(UpdaterId, Document, ICollectionElementId, ChangeType) | Adds a trigger to an updater with specified set of elements and ChangeType
 | DisableUpdater | Disables the updater.
Public method | Dispose |
 | EnableUpdater | Enables the updater.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
 | GetIsUpdaterOptional | Check if the updater is optional or not.
 | GetRegisteredUpdaterInfos | Returns UpdaterInfos for all the application-wide updaters.
 | GetRegisteredUpdaterInfos(Document) | Returns information about all updaters applicable to the given document.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | IsUpdaterEnabled | Checks if the updater is enabled or not.
 | IsUpdaterRegistered(UpdaterId) | Checks whether updater with the given id is registered
 | IsUpdaterRegistered(UpdaterId, Document) | Checks whether updater with the given id is registered in a document.
 | RegisterUpdater(IUpdater) | Registers an updater application-wide, which means the updater may get triggered in any open document.
 | RegisterUpdater(IUpdater, Document) | Registers the updater for a specified document, which means the updater can only be triggered by changes made in that document.
 | RegisterUpdater(IUpdater, Boolean) | Registers an updater application-wide, which means the updater may get triggered in any open document.
 | RegisterUpdater(IUpdater, Document, Boolean) | Registers the updater for a specified document, which means the updater can only be triggered by changes made in that document.
 | RemoveAllTriggers | Removes all triggers associated with Updater with specified UpdaterId. Does not unregister updater.
 | RemoveDocumentTriggers | Removes all triggers associated with specified document and Updater Does not unregister updater.
 | SetExecutionOrder | Forces execution order between two updaters Execution order: first before second
 | SetIsUpdaterOptional | Sets a flag indicating whether an updater is optional or not.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
 | UnregisterUpdater(UpdaterId) | Removes the updater associated with the input id from the UpdaterRegistry. Also removes all triggers associated with the Updater.
 | UnregisterUpdater(UpdaterId, Document) | Unregisters an updater for the given document.
Top
See Also

Reference

UpdaterRegistry Class


UpdaterRegistry.AddTrigger Method

UpdaterRegistryAddTrigger Method

Overload List
Name | Description
AddTrigger(UpdaterId, ElementFilter, ChangeType) | Adds trigger with the specified element filter and ChangeType for all documents associated with this Updater
AddTrigger(UpdaterId, Document, ElementFilter, ChangeType) | Adds trigger with the specified element filter and ChangeType for the specified document
AddTrigger(UpdaterId, Document, ICollectionElementId, ChangeType) | Adds a trigger to an updater with specified set of elements and ChangeType
Top
See Also

Reference

UpdaterRegistry Class


UpdaterRegistry.AddTrigger(UpdaterId, ElementFilter, ChangeType) Method

UpdaterRegistryAddTrigger(UpdaterId, ElementFilter, ChangeType) Method

Adds trigger with the specified element filter and ChangeType for all documents associated with this Updater

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void AddTrigger(
    UpdaterId id,
    ElementFilter filter,
    ChangeType change
)
Public Shared Sub AddTrigger (
    id As UpdaterId,
    filter As ElementFilter,
    change As ChangeType
)
public:
static void AddTrigger(
    UpdaterId^ id,
    ElementFilter^ filter,
    ChangeType^ change
)
static member AddTrigger :
        id : UpdaterId *
        filter : ElementFilter *
        change : ChangeType -> unit

Parameters

id UpdaterId
Id of updater that trigger should be added to
filter ElementFilter
Element filter that defines elements that affect this trigger
change ChangeType
ChangeType associated with this trigger
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The updater's owner's AddIn does not match the currently active AddIn. -or- The id does not correspond to any registered Updaters. -or- AddTrigger called while executing an updater.
Remarks
This method only works with CategoryFilter and ParameterFilter.
See Also

Reference

UpdaterRegistry Class
AddTrigger Overload


UpdaterRegistry.AddTrigger(UpdaterId, Document, ElementFilter, ChangeType) Method

UpdaterRegistryAddTrigger(UpdaterId, Document, ElementFilter, ChangeType) Method

Adds trigger with the specified element filter and ChangeType for the specified document

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void AddTrigger(
    UpdaterId id,
    Document document,
    ElementFilter filter,
    ChangeType change
)
Public Shared Sub AddTrigger (
    id As UpdaterId,
    document As Document,
    filter As ElementFilter,
    change As ChangeType
)
public:
static void AddTrigger(
    UpdaterId^ id,
    Document^ document,
    ElementFilter^ filter,
    ChangeType^ change
)
static member AddTrigger :
        id : UpdaterId *
        document : Document *
        filter : ElementFilter *
        change : ChangeType -> unit

Parameters

id UpdaterId
Id of updater that trigger should be added to
document Document
Document that elements in 'elements' are contained in
filter ElementFilter
Element filter that defines elements that affect this trigger
change ChangeType
ChangeType associated with this trigger
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The updater's owner's AddIn does not match the currently active AddIn. -or- The id does not correspond to any registered Updaters -or- AddTrigger called while executing an updater.
Remarks
This method only works with CategoryFilter and ParameterFilter.
See Also

Reference

UpdaterRegistry Class
AddTrigger Overload


UpdaterRegistry.AddTrigger(UpdaterId, Document, ICollection<ElementId>, ChangeType) Method

UpdaterRegistryAddTrigger(UpdaterId, Document, ICollectionElementId, ChangeType) Method

Adds a trigger to an updater with specified set of elements and ChangeType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void AddTrigger(
    UpdaterId id,
    Document document,
    ICollection<ElementId> elements,
    ChangeType change
)
Public Shared Sub AddTrigger (
    id As UpdaterId,
    document As Document,
    elements As ICollection(Of ElementId),
    change As ChangeType
)
public:
static void AddTrigger(
    UpdaterId^ id,
    Document^ document,
    ICollection<ElementId^>^ elements,
    ChangeType^ change
)
static member AddTrigger :
        id : UpdaterId *
        document : Document *
        elements : ICollection<ElementId> *
        change : ChangeType -> unit

Parameters

id UpdaterId
Id of updater that trigger should be added to
document Document
Document that elements in 'elements' are contained in
elements ICollection ElementId
Set of elements which define this trigger
change ChangeType
ChangeType associated with this trigger
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | updater's owner AddIn does not match the currently active AddIn -or- id does not correspond to any registered Updaters -or- AddTrigger called while executing an updater.
See Also

Reference

UpdaterRegistry Class
AddTrigger Overload


UpdaterRegistry.DisableUpdater Method

UpdaterRegistryDisableUpdater Method

Disables the updater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void DisableUpdater(
    UpdaterId id
)
Public Shared Sub DisableUpdater (
    id As UpdaterId
)
public:
static void DisableUpdater(
    UpdaterId^ id
)
static member DisableUpdater :
        id : UpdaterId -> unit

Parameters

id UpdaterId
The updater id.
Exceptions
Exception | Condition
ArgumentException | Updater with this Id is not currently registered in Revit.
ArgumentNullException | A non-optional argument was null
See Also

Reference

UpdaterRegistry Class


UpdaterRegistry.Dispose Method

UpdaterRegistryDispose Method

Releases all resources used by the UpdaterRegistry

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

UpdaterRegistry Class


UpdaterRegistry.EnableUpdater Method

UpdaterRegistryEnableUpdater Method

Enables the updater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void EnableUpdater(
    UpdaterId id
)
Public Shared Sub EnableUpdater (
    id As UpdaterId
)
public:
static void EnableUpdater(
    UpdaterId^ id
)
static member EnableUpdater :
        id : UpdaterId -> unit

Parameters

id UpdaterId
The updater id.
Exceptions
Exception | Condition
ArgumentException | Updater with this Id is not currently registered in Revit.
ArgumentNullException | A non-optional argument was null
Remarks
Even when an updater is enabled it could still be suspended for misbehaving, in which case it would not be executed regardless of its enable/disable status.
See Also

Reference

UpdaterRegistry Class


UpdaterRegistry.GetIsUpdaterOptional Method

UpdaterRegistryGetIsUpdaterOptional Method

Check if the updater is optional or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool GetIsUpdaterOptional(
    UpdaterId id
)
Public Shared Function GetIsUpdaterOptional (
    id As UpdaterId
) As Boolean
public:
static bool GetIsUpdaterOptional(
    UpdaterId^ id
)
static member GetIsUpdaterOptional :
        id : UpdaterId -> bool

Parameters

id UpdaterId
Id of the updater to check

Return Value

Boolean
Returns True if the updater is optional, False otherwise.
Exceptions
Exception | Condition
ArgumentException | Updater with this Id is not currently registered in Revit.
ArgumentNullException | A non-optional argument was null
Remarks
This flag controls whether an updater is going to be required next time a document in which it had been used is opened. If a non-optional updater is not found (currently not registered) in a document, the end user will be presented with a warning and choices to resolve the situation.
See Also

Reference

UpdaterRegistry Class


UpdaterRegistry.GetRegisteredUpdaterInfos Method

UpdaterRegistryGetRegisteredUpdaterInfos Method

Overload List
Name | Description
GetRegisteredUpdaterInfos | Returns UpdaterInfos for all the application-wide updaters.
GetRegisteredUpdaterInfos(Document) | Returns information about all updaters applicable to the given document.
Top
See Also

Reference

UpdaterRegistry Class


UpdaterRegistry.GetRegisteredUpdaterInfos Method

UpdaterRegistryGetRegisteredUpdaterInfos Method

Returns UpdaterInfos for all the application-wide updaters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<UpdaterInfo> GetRegisteredUpdaterInfos()
Public Shared Function GetRegisteredUpdaterInfos As IList(Of UpdaterInfo)
public:
static IList<UpdaterInfo^>^ GetRegisteredUpdaterInfos()
static member GetRegisteredUpdaterInfos : unit -> IList<UpdaterInfo>

Return Value

IList UpdaterInfo
List of UpdaterInfo structures
See Also

Reference

UpdaterRegistry Class
GetRegisteredUpdaterInfos Overload


UpdaterRegistry.GetRegisteredUpdaterInfos(Document) Method

UpdaterRegistryGetRegisteredUpdaterInfos(Document) Method

Returns information about all updaters applicable to the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<UpdaterInfo> GetRegisteredUpdaterInfos(
    Document document
)
Public Shared Function GetRegisteredUpdaterInfos (
    document As Document
) As IList(Of UpdaterInfo)
public:
static IList<UpdaterInfo^>^ GetRegisteredUpdaterInfos(
    Document^ document
)
static member GetRegisteredUpdaterInfos :
        document : Document -> IList<UpdaterInfo>

Parameters

document Document
The document to which sought updaters are applicable to.

Return Value

IList UpdaterInfo
List of UpdaterInfo structures
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
The list of data includes information about all updaters explicitly registered for the document as well as information about all application-wide registered updaters (which are applicable to all documents).
See Also

Reference

UpdaterRegistry Class
GetRegisteredUpdaterInfos Overload


UpdaterRegistry.IsUpdaterEnabled Method

UpdaterRegistryIsUpdaterEnabled Method

Checks if the updater is enabled or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsUpdaterEnabled(
    UpdaterId id
)
Public Shared Function IsUpdaterEnabled (
    id As UpdaterId
) As Boolean
public:
static bool IsUpdaterEnabled(
    UpdaterId^ id
)
static member IsUpdaterEnabled :
        id : UpdaterId -> bool

Parameters

id UpdaterId
The updater id.

Return Value

Boolean
Returns true if the updater is enabled, false otherwise.
Exceptions
Exception | Condition
ArgumentException | Updater with this Id is not currently registered in Revit.
ArgumentNullException | A non-optional argument was null
Remarks
Even when an updater is enabled it could still be suspended for misbehaving, in which case it would not be executed regardless of its enable/disable status.
See Also

Reference

UpdaterRegistry Class


UpdaterRegistry.IsUpdaterRegistered Method

UpdaterRegistryIsUpdaterRegistered Method

Overload List
Name | Description
IsUpdaterRegistered(UpdaterId) | Checks whether updater with the given id is registered
IsUpdaterRegistered(UpdaterId, Document) | Checks whether updater with the given id is registered in a document.
Top
See Also

Reference

UpdaterRegistry Class


UpdaterRegistry.IsUpdaterRegistered(UpdaterId) Method

UpdaterRegistryIsUpdaterRegistered(UpdaterId) Method

Checks whether updater with the given id is registered

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsUpdaterRegistered(
    UpdaterId id
)
Public Shared Function IsUpdaterRegistered (
    id As UpdaterId
) As Boolean
public:
static bool IsUpdaterRegistered(
    UpdaterId^ id
)
static member IsUpdaterRegistered :
        id : UpdaterId -> bool

Parameters

id UpdaterId
Id of the updater being tested.

Return Value

Boolean
Returns true if the updater is registered.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

UpdaterRegistry Class
IsUpdaterRegistered Overload


UpdaterRegistry.IsUpdaterRegistered(UpdaterId, Document) Method

UpdaterRegistryIsUpdaterRegistered(UpdaterId, Document) Method

Checks whether updater with the given id is registered in a document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsUpdaterRegistered(
    UpdaterId id,
    Document document
)
Public Shared Function IsUpdaterRegistered (
    id As UpdaterId,
    document As Document
) As Boolean
public:
static bool IsUpdaterRegistered(
    UpdaterId^ id,
    Document^ document
)
static member IsUpdaterRegistered :
        id : UpdaterId *
        document : Document -> bool

Parameters

id UpdaterId
Id of the updater being tested.
document Document
Document in which this updater is tested whether it's registered or not.

Return Value

Boolean
Returns True if the updater is registered in the given document.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

UpdaterRegistry Class
IsUpdaterRegistered Overload


UpdaterRegistry.RegisterUpdater Method

UpdaterRegistryRegisterUpdater Method

Overload List
Name | Description
RegisterUpdater(IUpdater) | Registers an updater application-wide, which means the updater may get triggered in any open document.
RegisterUpdater(IUpdater, Document) | Registers the updater for a specified document, which means the updater can only be triggered by changes made in that document.
RegisterUpdater(IUpdater, Boolean) | Registers an updater application-wide, which means the updater may get triggered in any open document.
RegisterUpdater(IUpdater, Document, Boolean) | Registers the updater for a specified document, which means the updater can only be triggered by changes made in that document.
Top
See Also

Reference

UpdaterRegistry Class


UpdaterRegistry.RegisterUpdater(IUpdater) Method

UpdaterRegistryRegisterUpdater(IUpdater) Method

Registers an updater application-wide, which means the updater may get triggered in any open document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void RegisterUpdater(
    IUpdater updater
)
Public Shared Sub RegisterUpdater (
    updater As IUpdater
)
public:
static void RegisterUpdater(
    IUpdater^ updater
)
static member RegisterUpdater :
        updater : IUpdater -> unit

Parameters

updater IUpdater
Updater to be registered
Exceptions
Exception | Condition
ArgumentException | Updater with the the same Id has already been registered on the application level. -or- Updater's Id is not valid.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Method is not allowed during execution of a dynamic update. -or- The updater's owner's AddIn does not match the currently active AddIn, i.e. IUpdater.GetUpdaterId().GetAddInId() differs from the addInId field in the manifest file of the currently executing external application.
Remarks
By registering an updater application-wide, any previous registration explicitly made for particular documents will be voided. That means the updater will no longer be connected with just those documents, and the methodIsUpdaterRegistered(id,document) will also return False. Consequently, any attempt to either register or unregister this updater to (or from, respectively) a document will cause an exception to be thrown.
See Also

Reference

UpdaterRegistry Class
RegisterUpdater Overload


UpdaterRegistry.RegisterUpdater(IUpdater, Document) Method

UpdaterRegistryRegisterUpdater(IUpdater, Document) Method

Registers the updater for a specified document, which means the updater can only be triggered by changes made in that document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void RegisterUpdater(
    IUpdater updater,
    Document document
)
Public Shared Sub RegisterUpdater (
    updater As IUpdater,
    document As Document
)
public:
static void RegisterUpdater(
    IUpdater^ updater,
    Document^ document
)
static member RegisterUpdater :
        updater : IUpdater *
        document : Document -> unit

Parameters

updater IUpdater
Updater to be registered
document Document
Document for which this updater is to be registered
Exceptions
Exception | Condition
ArgumentException | Updater with the the same Id has already been registered on the application level. -or- Updater with the the same Id has already been registered either in the given document or on the application level. -or- Updater's Id is not valid.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Method is not allowed during execution of a dynamic update. -or- The updater's owner's AddIn does not match the currently active AddIn, i.e. IUpdater.GetUpdaterId().GetAddInId() differs from the addInId field in the manifest file of the currently executing external application.
Remarks
An updater may be registered in more than one document, but an updater may not be registered for a document and also for the entire application at the same time. If an updater has already been registered application-wide, an attempt to register it for a document will cause an exception.
See Also

Reference

UpdaterRegistry Class
RegisterUpdater Overload


UpdaterRegistry.RegisterUpdater(IUpdater, Boolean) Method

UpdaterRegistryRegisterUpdater(IUpdater, Boolean) Method

Registers an updater application-wide, which means the updater may get triggered in any open document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void RegisterUpdater(
    IUpdater updater,
    bool isOptional
)
Public Shared Sub RegisterUpdater (
    updater As IUpdater,
    isOptional As Boolean
)
public:
static void RegisterUpdater(
    IUpdater^ updater,
    bool isOptional
)
static member RegisterUpdater :
        updater : IUpdater *
        isOptional : bool -> unit

Parameters

updater IUpdater
Updater to be registered
isOptional Boolean
This argument controls whether the updater should be required next time a document is open in which the updater had been previously used. If a non-optional updater is not found (i.e. currently not registered), the end user will be presented with a warning and choices to resolve the situation.
Exceptions
Exception | Condition
ArgumentException | Updater with the the same Id has already been registered on the application level. -or- Updater's Id is not valid.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Method is not allowed during execution of a dynamic update. -or- The updater's owner's AddIn does not match the currently active AddIn, i.e. IUpdater.GetUpdaterId().GetAddInId() differs from the addInId field in the manifest file of the currently executing external application.
Remarks
By registering an updater application-wide, any previous registration explicitly made for particular documents will be voided. That means the updater will no longer be connected with just those documents, and the methodIsUpdaterRegistered(id,document) will also return False. Consequently, any attempt to either register or unregister this updater to (or from, respectively) a document will cause an exception to be thrown.
See Also

Reference

UpdaterRegistry Class
RegisterUpdater Overload


UpdaterRegistry.RegisterUpdater(IUpdater, Document, Boolean) Method

UpdaterRegistryRegisterUpdater(IUpdater, Document, Boolean) Method

Registers the updater for a specified document, which means the updater can only be triggered by changes made in that document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void RegisterUpdater(
    IUpdater updater,
    Document document,
    bool isOptional
)
Public Shared Sub RegisterUpdater (
    updater As IUpdater,
    document As Document,
    isOptional As Boolean
)
public:
static void RegisterUpdater(
    IUpdater^ updater,
    Document^ document,
    bool isOptional
)
static member RegisterUpdater :
        updater : IUpdater *
        document : Document *
        isOptional : bool -> unit

Parameters

updater IUpdater
Updater to be registered.
document Document
Document for which this updater is to be registered.
isOptional Boolean
This argument controls whether the updater should be required next time a document is open in which the updater had been previously used. If a non-optional updater is not found (i.e. currently not registered), the end user will be presented with a warning and choices to resolve the situation.
Exceptions
Exception | Condition
ArgumentException | Updater with the the same Id has already been registered on the application level. -or- Updater with the the same Id has already been registered either in the given document or on the application level. -or- Updater's Id is not valid.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Method is not allowed during execution of a dynamic update. -or- The updater's owner's AddIn does not match the currently active AddIn, i.e. IUpdater.GetUpdaterId().GetAddInId() differs from the addInId field in the manifest file of the currently executing external application.
Remarks
An updater may be registered in more then one document, but an updater may not be registered for a document and also for the entire application at the same time. If an updater has already been registered application-wide, an attempt to register it for a document will cause an exception.
See Also

Reference

UpdaterRegistry Class
RegisterUpdater Overload


UpdaterRegistry.RemoveAllTriggers Method

UpdaterRegistryRemoveAllTriggers Method

Removes all triggers associated with Updater with specified UpdaterId. Does not unregister updater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void RemoveAllTriggers(
    UpdaterId id
)
Public Shared Sub RemoveAllTriggers (
    id As UpdaterId
)
public:
static void RemoveAllTriggers(
    UpdaterId^ id
)
static member RemoveAllTriggers :
        id : UpdaterId -> unit

Parameters

id UpdaterId
Id of specified updater
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The updater's owner's AddIn does not match the currently active AddIn. -or- RemoveAllTriggers called while executing an updater.
See Also

Reference

UpdaterRegistry Class


UpdaterRegistry.RemoveDocumentTriggers Method

UpdaterRegistryRemoveDocumentTriggers Method

Removes all triggers associated with specified document and Updater Does not unregister updater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void RemoveDocumentTriggers(
    UpdaterId id,
    Document document
)
Public Shared Sub RemoveDocumentTriggers (
    id As UpdaterId,
    document As Document
)
public:
static void RemoveDocumentTriggers(
    UpdaterId^ id,
    Document^ document
)
static member RemoveDocumentTriggers :
        id : UpdaterId *
        document : Document -> unit

Parameters

id UpdaterId
Id of specified updater
document Document
Document for which to remove triggers
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The updater's owner's AddIn does not match the currently active AddIn. -or- RemoveDocumentTriggers called while executing an updater.
See Also

Reference

UpdaterRegistry Class


UpdaterRegistry.SetExecutionOrder Method

UpdaterRegistrySetExecutionOrder Method

Forces execution order between two updaters Execution order: first before second

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void SetExecutionOrder(
    UpdaterId first,
    UpdaterId second
)
Public Shared Sub SetExecutionOrder (
    first As UpdaterId,
    second As UpdaterId
)
public:
static void SetExecutionOrder(
    UpdaterId^ first,
    UpdaterId^ second
)
static member SetExecutionOrder :
        first : UpdaterId *
        second : UpdaterId -> unit

Parameters

first UpdaterId
Id of first Updater
second UpdaterId
Id of second Updater
Exceptions
Exception | Condition
ArgumentException | One or both inputs are not valid UpdaterIds -or- One or both of the Updaters are not registered -or- first and second are the same id
ArgumentNullException | A non-optional argument was null
ArgumentsInconsistentException | The updaters do not report the same ChangePriority
See Also

Reference

UpdaterRegistry Class


UpdaterRegistry.SetIsUpdaterOptional Method

UpdaterRegistrySetIsUpdaterOptional Method

Sets a flag indicating whether an updater is optional or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void SetIsUpdaterOptional(
    UpdaterId id,
    bool isOptional
)
Public Shared Sub SetIsUpdaterOptional (
    id As UpdaterId,
    isOptional As Boolean
)
public:
static void SetIsUpdaterOptional(
    UpdaterId^ id,
    bool isOptional
)
static member SetIsUpdaterOptional :
        id : UpdaterId *
        isOptional : bool -> unit

Parameters

id UpdaterId
Id of the updater
isOptional Boolean
Use True to make the updater optional, false to make it a mandatory updater.
Exceptions
Exception | Condition
ArgumentException | Updater with this Id is not currently registered in Revit.
ArgumentNullException | A non-optional argument was null
Remarks
This flag controls whether an updater is going to be required next time a document in which it had been used is opened. If a non-optional updater is not found (currently not registered) in a document, the end user will be presented with a warning and choices to resolve the situation.
See Also

Reference

UpdaterRegistry Class


UpdaterRegistry.UnregisterUpdater Method

UpdaterRegistryUnregisterUpdater Method

Overload List
Name | Description
UnregisterUpdater(UpdaterId) | Removes the updater associated with the input id from the UpdaterRegistry. Also removes all triggers associated with the Updater.
UnregisterUpdater(UpdaterId, Document) | Unregisters an updater for the given document.
Top
See Also

Reference

UpdaterRegistry Class


UpdaterRegistry.UnregisterUpdater(UpdaterId) Method

UpdaterRegistryUnregisterUpdater(UpdaterId) Method

Removes the updater associated with the input id from the UpdaterRegistry. Also removes all triggers associated with the Updater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void UnregisterUpdater(
    UpdaterId id
)
Public Shared Sub UnregisterUpdater (
    id As UpdaterId
)
public:
static void UnregisterUpdater(
    UpdaterId^ id
)
static member UnregisterUpdater :
        id : UpdaterId -> unit

Parameters

id UpdaterId
Id of updater to be removed
Exceptions
Exception | Condition
ArgumentException | Updater with this Id is not currently registered in Revit.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The updater's owner's AddIn does not match the currently active AddIn, i.e. IUpdater.GetUpdaterId().GetAddInId() differs from the addInId field in the manifest file of the currently executing external application. -or- Attempting to unregister an updater that is currently being executed.
Remarks
This methods works regardless of how the updater was registered. Whether the updater was registered application-wide or for a document (or a set of document), it will be removed from the registry and any connections with documents will also be lost.
See Also

Reference

UpdaterRegistry Class
UnregisterUpdater Overload


UpdaterRegistry.UnregisterUpdater(UpdaterId, Document) Method

UpdaterRegistryUnregisterUpdater(UpdaterId, Document) Method

Unregisters an updater for the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void UnregisterUpdater(
    UpdaterId id,
    Document document
)
Public Shared Sub UnregisterUpdater (
    id As UpdaterId,
    document As Document
)
public:
static void UnregisterUpdater(
    UpdaterId^ id,
    Document^ document
)
static member UnregisterUpdater :
        id : UpdaterId *
        document : Document -> unit

Parameters

id UpdaterId
Id of updater to be unregistered.
document Document
Document for which this updater is to be unregistered.
Exceptions
Exception | Condition
ArgumentException | Updater with this Id is not currently registered in the document.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The updater's owner's AddIn does not match the currently active AddIn, i.e. IUpdater.GetUpdaterId().GetAddInId() differs from the addInId field in the manifest file of the currently executing external application. -or- Attempting to unregister an updater that is currently being executed.
Remarks

Unregistering an updater from a document is only permitted if the updater was explicitly registered for that document.

If the updater was registered in other documents too, the remaining documents will still have the updater assigned.

However, if after unregistering from the document the updater is found not registered in any other (currently open) documents, the updater will be completely removed from the registry including its triggers. Should the updater be registered again later, the triggers need to be re-applied.

See Also

Reference

UpdaterRegistry Class
UnregisterUpdater Overload


UV Class

Object representing coordinates in 2-dimensional space.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBUV

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class UV
Public Class UV
public ref class UV
type UV = class end

The UV type exposes the following members.

Constructors
 | Name | Description
Public method | UV | Creates a default UV with the values (0, 0).
Public method | UV(Double, Double) | Creates a UV with the supplied coordinates.
Top
Properties
 | Name | Description
 | BasisU | The basis of the U axis.
 | BasisV | The basis of the V axis.
Public property | Item |
Public property | U | Gets the first coordinate.
Public property | V | Gets the second coordinate.
 | Zero | The coordinate origin or zero 2-D vector.
Top
Methods
 | Name | Description
Public method | Add | Adds the specified 2-D vector to this 2-D vector and returns the result.
Public method | AngleTo | Returns the angle between this vector and the specified vector.
Public method | CrossProduct | The cross product of this 2-D vector and the specified 2-D vector.
Public method | DistanceTo | Returns the distance from this 2-D point to the specified 2-D point.
Public method | Divide | Divides this 2-D vector by the specified value and returns the result.
Public method | DotProduct | The dot product of this 2-D vector and the specified 2-D vector.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLength | The length of this 2-D vector.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsAlmostEqualTo(UV) | Determines whether this 2-D vector and the specified 2-D vector are the same within the tolerance (1.0e-09).
Public method | IsAlmostEqualTo(UV, Double) | Determines whether this 2-D vector and the specified 2-D vector are the same within a specified tolerance.
Public method | IsUnitLength | The boolean value indicates whether this 2-D vector is of unit length.
Public method | IsZeroLength | The boolean value indicates whether this 2-D vector is a zero vector.
Public method | Multiply | Multiplies this 2-D vector by the specified value and returns the result.
Public method | Negate | Negates this 2-D vector.
Public method | Normalize | Returns a new UV whose coordinates are the normalized values from this vector.
Public method | Subtract | Subtracts the specified 2-D vector from this 2-D vector and returns the result.
Public method | ToString | Gets formatted string showing (U, V) with values formatted to 9 decimal places. (Overrides ObjectToString)
Top
Operators
Name | Description
Addition(UV, UV) | Adds the two specified 2-D vectors and returns the result.
Division(UV, Double) | Divides the specified 2-D vector by the specified value.
Multiply(Double, UV) | The product of the specified number and the specified 2-D vector.
Multiply(UV, Double) | The product of the specified number and the specified 2-D vector.
Subtraction(UV, UV) | Subtracts the two specified 2-D vectors and returns the result.
UnaryNegation(UV) | Negates this 2-D vector and returns the result.
Top
Remarks
Usually this means parameters on a surface. In actual use, it could be interpreted as either point or vector in 2-dimensional space.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


UV Constructor

Overload List
 | Name | Description
Public method | UV | Creates a default UV with the values (0, 0).
Public method | UV(Double, Double) | Creates a UV with the supplied coordinates.
Top
See Also

Reference

UV Class


UV Constructor

Creates a default UV with the values (0, 0).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public UV()
Public Sub New
public:
UV()
new : unit -> UV
See Also

Reference

UV Class
UV Overload


UV(Double, Double) Constructor

Creates a UV with the supplied coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public UV(
    double u,
    double v
)
Public Sub New (
    u As Double,
    v As Double
)
public:
UV(
    double u,
    double v
)
new :
        u : float *
        v : float -> UV

Parameters

u Double
The first coordinate.
v Double
The second coordinate.
Exceptions
Exception | Condition
ArgumentException | Thrown when setting an infinite number to the U or V property.
See Also

Reference

UV Class
UV Overload


UV Properties

The UV type exposes the following members.

Properties
 | Name | Description
 | BasisU | The basis of the U axis.
 | BasisV | The basis of the V axis.
Public property | Item |
Public property | U | Gets the first coordinate.
Public property | V | Gets the second coordinate.
 | Zero | The coordinate origin or zero 2-D vector.
Top
See Also

Reference

UV Class


UV.BasisU Property

UVBasisU Property

The basis of the U axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static UV BasisU { get; }
Public Shared ReadOnly Property BasisU As UV
    Get
public:
static property UV^ BasisU {
    UV^ get ();
}
static member BasisU : UV with get

Property Value

UV
Remarks
The basis of the U axis is the vector (1,0), the unit vector on the U axis.
See Also

Reference

UV Class


UV.BasisV Property

UVBasisV Property

The basis of the V axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static UV BasisV { get; }
Public Shared ReadOnly Property BasisV As UV
    Get
public:
static property UV^ BasisV {
    UV^ get ();
}
static member BasisV : UV with get

Property Value

UV
Remarks
The basis of the V axis is the vector (0,1), the unit vector on the V axis.
See Also

Reference

UV Class


UV.Item Property

UVItem Property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double this[
    int idx
] { get; }
Public ReadOnly Default Property Item (
    idx As Integer
) As Double
    Get
public:
property double default[int idx] {
    double get (int idx);
}
member Item : float with get

Parameters

idx Int32

Property Value

Double
See Also

Reference

UV Class


UV.U Property

UVU Property

Gets the first coordinate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double U { get; }
Public ReadOnly Property U As Double
    Get
public:
property double U {
    double get ();
}
member U : float with get

Property Value

Double
See Also

Reference

UV Class


UV.V Property

UVV Property

Gets the second coordinate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double V { get; }
Public ReadOnly Property V As Double
    Get
public:
property double V {
    double get ();
}
member V : float with get

Property Value

Double
See Also

Reference

UV Class


UV.Zero Property

UVZero Property

The coordinate origin or zero 2-D vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static UV Zero { get; }
Public Shared ReadOnly Property Zero As UV
    Get
public:
static property UV^ Zero {
    UV^ get ();
}
static member Zero : UV with get

Property Value

UV
Remarks
The zero vector is (0,0).
See Also

Reference

UV Class


UV Methods

The UV type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds the specified 2-D vector to this 2-D vector and returns the result.
Public method | AngleTo | Returns the angle between this vector and the specified vector.
Public method | CrossProduct | The cross product of this 2-D vector and the specified 2-D vector.
Public method | DistanceTo | Returns the distance from this 2-D point to the specified 2-D point.
Public method | Divide | Divides this 2-D vector by the specified value and returns the result.
Public method | DotProduct | The dot product of this 2-D vector and the specified 2-D vector.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLength | The length of this 2-D vector.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsAlmostEqualTo(UV) | Determines whether this 2-D vector and the specified 2-D vector are the same within the tolerance (1.0e-09).
Public method | IsAlmostEqualTo(UV, Double) | Determines whether this 2-D vector and the specified 2-D vector are the same within a specified tolerance.
Public method | IsUnitLength | The boolean value indicates whether this 2-D vector is of unit length.
Public method | IsZeroLength | The boolean value indicates whether this 2-D vector is a zero vector.
Public method | Multiply | Multiplies this 2-D vector by the specified value and returns the result.
Public method | Negate | Negates this 2-D vector.
Public method | Normalize | Returns a new UV whose coordinates are the normalized values from this vector.
Public method | Subtract | Subtracts the specified 2-D vector from this 2-D vector and returns the result.
Public method | ToString | Gets formatted string showing (U, V) with values formatted to 9 decimal places. (Overrides ObjectToString)
Top
See Also

Reference

UV Class


UV.Add Method

UVAdd Method

Adds the specified 2-D vector to this 2-D vector and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public UV Add(
    UV source
)
Public Function Add (
    source As UV
) As UV
public:
UV^ Add(
    UV^ source
)
member Add :
        source : UV -> UV

Parameters

source UV
The vector to add to this vector.

Return Value

UV
The 2-D vector equal to the sum of the two vectors.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when source is .
Remarks
The added vector is obtained by adding each coordinate of the specified vector to the corresponding coordinate of this vector.
See Also

Reference

UV Class


UV.AngleTo Method

UVAngleTo Method

Returns the angle between this vector and the specified vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double AngleTo(
    UV source
)
Public Function AngleTo (
    source As UV
) As Double
public:
double AngleTo(
    UV^ source
)
member AngleTo :
        source : UV -> float

Parameters

source UV
The specified vector.

Return Value

Double
The real number between 0 and 2*PI equal to the angle between the two vectors in radians.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when source is .
Remarks
The angle is measured counterclockwise.
See Also

Reference

UV Class


UV.CrossProduct Method

UVCrossProduct Method

The cross product of this 2-D vector and the specified 2-D vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double CrossProduct(
    UV source
)
Public Function CrossProduct (
    source As UV
) As Double
public:
double CrossProduct(
    UV^ source
)
member CrossProduct :
        source : UV -> float

Parameters

source UV
The vector to multiply with this vector.

Return Value

Double
The real number equal to the cross product.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when source is .
Remarks
The cross product of the two vectors in 2-D space is equivalent to the area of the parallelogram they span.
See Also

Reference

UV Class


UV.DistanceTo Method

UVDistanceTo Method

Returns the distance from this 2-D point to the specified 2-D point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double DistanceTo(
    UV source
)
Public Function DistanceTo (
    source As UV
) As Double
public:
double DistanceTo(
    UV^ source
)
member DistanceTo :
        source : UV -> float

Parameters

source UV
The specified point.

Return Value

Double
The real number equal to the distance between the two points.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when source is .
Remarks
The distance between the two points is equal to the length of the vector that joins the two points.
See Also

Reference

UV Class


UV.Divide Method

UVDivide Method

Divides this 2-D vector by the specified value and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public UV Divide(
    double value
)
Public Function Divide (
    value As Double
) As UV
public:
UV^ Divide(
    double value
)
member Divide :
        value : float -> UV

Parameters

value Double
The value to divide this vector by.

Return Value

UV
The divided 2-D vector.
Exceptions
Exception | Condition
ArgumentException | Thrown when the specified value is an infinite number.
ArgumentException | Thrown when the specified value is zero.
Remarks
The divided vector is obtained by dividing each coordinate of this vector by the specified value.
See Also

Reference

UV Class


UV.DotProduct Method

UVDotProduct Method

The dot product of this 2-D vector and the specified 2-D vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double DotProduct(
    UV source
)
Public Function DotProduct (
    source As UV
) As Double
public:
double DotProduct(
    UV^ source
)
member DotProduct :
        source : UV -> float

Parameters

source UV
The vector to multiply with this vector.

Return Value

Double
The real number equal to the dot product.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when source is .
Remarks
The dot product is the sum of the respective coordinates of the two vectors: Pu * Ru + Pv * Rv.
See Also

Reference

UV Class


UV.GetLength Method

UVGetLength Method

The length of this 2-D vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetLength()
Public Function GetLength As Double
public:
double GetLength()
member GetLength : unit -> float

Return Value

Double
Remarks
In 2-D Euclidean space, the length of the vector is the square root of the sum of the two coordinates squared.
See Also

Reference

UV Class


UV.IsAlmostEqualTo Method

UVIsAlmostEqualTo Method

Overload List
 | Name | Description
Public method | IsAlmostEqualTo(UV) | Determines whether this 2-D vector and the specified 2-D vector are the same within the tolerance (1.0e-09).
Public method | IsAlmostEqualTo(UV, Double) | Determines whether this 2-D vector and the specified 2-D vector are the same within a specified tolerance.
Top
See Also

Reference

UV Class


UV.IsAlmostEqualTo(UV) Method

UVIsAlmostEqualTo(UV) Method

Determines whether this 2-D vector and the specified 2-D vector are the same within the tolerance (1.0e-09).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsAlmostEqualTo(
    UV source
)
Public Function IsAlmostEqualTo (
    source As UV
) As Boolean
public:
bool IsAlmostEqualTo(
    UV^ source
)
member IsAlmostEqualTo :
        source : UV -> bool

Parameters

source UV
The vector to compare with this vector.

Return Value

Boolean
True if the vectors are the same; otherwise, false.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when left is .
See Also

Reference

UV Class
IsAlmostEqualTo Overload


UV.IsAlmostEqualTo(UV, Double) Method

UVIsAlmostEqualTo(UV, Double) Method

Determines whether this 2-D vector and the specified 2-D vector are the same within a specified tolerance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsAlmostEqualTo(
    UV source,
    double tolerance
)
Public Function IsAlmostEqualTo (
    source As UV,
    tolerance As Double
) As Boolean
public:
bool IsAlmostEqualTo(
    UV^ source,
    double tolerance
)
member IsAlmostEqualTo :
        source : UV *
        tolerance : float -> bool

Parameters

source UV
The vector to compare with this vector.
tolerance Double
The tolerance for equality check.

Return Value

Boolean
True if the vectors are the same; otherwise, false.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when source is .
ArgumentException | Thrown when tolerance is less than 0.
See Also

Reference

UV Class
IsAlmostEqualTo Overload


UV.IsUnitLength Method

UVIsUnitLength Method

The boolean value indicates whether this 2-D vector is of unit length.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsUnitLength()
Public Function IsUnitLength As Boolean
public:
bool IsUnitLength()
member IsUnitLength : unit -> bool

Return Value

Boolean
Remarks
A unit length vector has a length of one, and is considered normalized.
See Also

Reference

UV Class


UV.IsZeroLength Method

UVIsZeroLength Method

The boolean value indicates whether this 2-D vector is a zero vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsZeroLength()
Public Function IsZeroLength As Boolean
public:
bool IsZeroLength()
member IsZeroLength : unit -> bool

Return Value

Boolean
Remarks
The zero vector's each component is zero within the tolerance (1.0e-09).
See Also

Reference

UV Class


UV.Multiply Method

UVMultiply Method

Multiplies this 2-D vector by the specified value and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public UV Multiply(
    double value
)
Public Function Multiply (
    value As Double
) As UV
public:
UV^ Multiply(
    double value
)
member Multiply :
        value : float -> UV

Parameters

value Double
The value to multiply with this vector.

Return Value

UV
The multiplied 2-D vector.
Exceptions
Exception | Condition
ArgumentException | Thrown when the specified value is an infinite number.
Remarks
The multiplied vector is obtained by multiplying each coordinate of this vector by the specified value.
See Also

Reference

UV Class


UV.Negate Method

UVNegate Method

Negates this 2-D vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public UV Negate()
Public Function Negate As UV
public:
UV^ Negate()
member Negate : unit -> UV

Return Value

UV
The 2-D vector opposite to this vector.
Remarks
The negated vector is obtained by changing the sign of each coordinate of this vector.
See Also

Reference

UV Class


UV.Normalize Method

UVNormalize Method

Returns a new UV whose coordinates are the normalized values from this vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public UV Normalize()
Public Function Normalize As UV
public:
UV^ Normalize()
member Normalize : unit -> UV

Return Value

UV
The normalized UV or zero if the vector is almost Zero.
Remarks
Normalized indicates that the length of this vector equals one (a unit vector).
See Also

Reference

UV Class


UV.Subtract Method

UVSubtract Method

Subtracts the specified 2-D vector from this 2-D vector and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public UV Subtract(
    UV source
)
Public Function Subtract (
    source As UV
) As UV
public:
UV^ Subtract(
    UV^ source
)
member Subtract :
        source : UV -> UV

Parameters

source UV
The vector to subtract from this vector.

Return Value

UV
The 2-D vector equal to the difference between the two vectors.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when left is .
Remarks
The subtracted vector is obtained by subtracting each coordinate of the specified vector from the corresponding coordinate of this vector.
See Also

Reference

UV Class


UV.ToString Method

UVToString Method

Gets formatted string showing (U, V) with values formatted to 9 decimal places.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

String
See Also

Reference

UV Class


UV Operators

The UV type exposes the following members.

Operators
Name | Description
Addition(UV, UV) | Adds the two specified 2-D vectors and returns the result.
Division(UV, Double) | Divides the specified 2-D vector by the specified value.
Multiply(Double, UV) | The product of the specified number and the specified 2-D vector.
Multiply(UV, Double) | The product of the specified number and the specified 2-D vector.
Subtraction(UV, UV) | Subtracts the two specified 2-D vectors and returns the result.
UnaryNegation(UV) | Negates this 2-D vector and returns the result.
Top
See Also

Reference

UV Class


UV.Addition Operator

UVAddition Operator

Adds the two specified 2-D vectors and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static UV operator +(
    UV left,
    UV right
)
Public Shared Operator + (
    left As UV,
    right As UV
) As UV
public:
static UV^ operator +(
    UV^ left,
    UV^ right
)
static let inline (+)
        left : UV *
        right : UV  : UV

Parameters

left UV
The first vector.
right UV
The second vector.

Return Value

UV
The 2-D vector equal to the sum of the two source vectors.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when left or right is .
Remarks
The added vector is obtained by adding each coordinate of the right vector to the corresponding coordinate of the left vector.
See Also

Reference

UV Class


UV.Division Operator

UVDivision Operator

Divides the specified 2-D vector by the specified value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static UV operator /(
    UV left,
    double value
)
Public Shared Operator / (
    left As UV,
    value As Double
) As UV
public:
static UV^ operator /(
    UV^ left,
    double value
)
static let inline (/)
        left : UV *
        value : float  : UV

Parameters

left UV
The value to divide the vector by.
value Double
The vector to divide by the value.

Return Value

UV
The divided 2-D vector.
Exceptions
Exception | Condition
ArgumentException | Thrown when the specified value is an infinite number or zero.
ArgumentNullException | Thrown when left is .
Remarks
The divided vector is obtained by dividing each coordinate of the specified vector by the specified value.
See Also

Reference

UV Class


UV.Multiply Operator

UVMultiply Operator

Overload List
Name | Description
Multiply(Double, UV) | The product of the specified number and the specified 2-D vector.
Multiply(UV, Double) | The product of the specified number and the specified 2-D vector.
Top
See Also

Reference

UV Class


UV.Multiply(Double, UV) Operator

UVMultiply(Double, UV) Operator

The product of the specified number and the specified 2-D vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static UV operator *(
    double value,
    UV right
)
Public Shared Operator * (
    value As Double,
    right As UV
) As UV
public:
static UV^ operator *(
    double value,
    UV^ right
)
static let inline (*)
        value : float *
        right : UV  : UV

Parameters

value Double
The value to multiply with the specified vector.
right UV
The vector to multiply with the value.

Return Value

UV
The multiplied 2-D vector.
Exceptions
Exception | Condition
ArgumentException | Thrown when the specified value is an infinite number.
ArgumentNullException | Thrown when right is .
Remarks
The multiplied vector is obtained by multiplying each coordinate of the specified vector by the specified value.
See Also

Reference

UV Class
Multiply Overload


UV.Multiply(UV, Double) Operator

UVMultiply(UV, Double) Operator

The product of the specified number and the specified 2-D vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static UV operator *(
    UV left,
    double value
)
Public Shared Operator * (
    left As UV,
    value As Double
) As UV
public:
static UV^ operator *(
    UV^ left,
    double value
)
static let inline (*)
        left : UV *
        value : float  : UV

Parameters

left UV
The vector to multiply with the value.
value Double
The value to multiply with the specified vector.

Return Value

UV
The multiplied 2-D vector.
Exceptions
Exception | Condition
ArgumentException | Thrown when the specified value is an infinite number.
ArgumentNullException | Thrown when left is .
Remarks
The multiplied vector is obtained by multiplying each coordinate of the specified vector by the specified value.
See Also

Reference

UV Class
Multiply Overload


UV.Subtraction Operator

UVSubtraction Operator

Subtracts the two specified 2-D vectors and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static UV operator -(
    UV left,
    UV right
)
Public Shared Operator - (
    left As UV,
    right As UV
) As UV
public:
static UV^ operator -(
    UV^ left,
    UV^ right
)
static let inline (-)
        left : UV *
        right : UV  : UV

Parameters

left UV
The first vector.
right UV
The second vector.

Return Value

UV
The 2-D vector equal to the difference between the two source vectors.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when left or right is .
Remarks
The subtracted vector is obtained by subtracting each coordinate of the right vector from the corresponding coordinate of the left vector.
See Also

Reference

UV Class


UV.UnaryNegation Operator

UVUnaryNegation Operator

Negates this 2-D vector and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static UV operator -(
    UV source
)
Public Shared Operator - (
    source As UV
) As UV
public:
static UV^ operator -(
    UV^ source
)
static let inline (-)
        source : UV  : UV

Parameters

source UV

Return Value

UV
The 2-D vector opposite to this vector.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when source is .
Remarks
The negated vector is obtained by changing the sign of each coordinate of the specified vector.
See Also

Reference

UV Class


UVGridlineType Enumeration

A choice between U-gridlines or V-gridlines of a divided surface U Gridlines V Gridlines

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum UVGridlineType
Public Enumeration UVGridlineType
public enum class UVGridlineType
type UVGridlineType
Members
Member name | Value | Description
U | 0 |
V | 1 |
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ValidateCurveLoopsOptions Class

Options for array of curve loops validation.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBValidateCurveLoopsOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ValidateCurveLoopsOptions : IDisposable
Public Class ValidateCurveLoopsOptions
    Implements IDisposable
public ref class ValidateCurveLoopsOptions : IDisposable
type ValidateCurveLoopsOptions =
    class
        interface IDisposable
    end

The ValidateCurveLoopsOptions type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ValidateCurveLoopsOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ValidateCurveLoopsOptions Properties

The ValidateCurveLoopsOptions type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

ValidateCurveLoopsOptions Class


ValidateCurveLoopsOptions.IsValidObject Property

ValidateCurveLoopsOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ValidateCurveLoopsOptions Class


ValidateCurveLoopsOptions Methods

The ValidateCurveLoopsOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ValidateCurveLoopsOptions Class


ValidateCurveLoopsOptions.Dispose Method

ValidateCurveLoopsOptionsDispose Method

Releases all resources used by the ValidateCurveLoopsOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ValidateCurveLoopsOptions Class


ValueAtPointBase Class

A base class representing storage of values at a given point.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBValueAtPointBase
Autodesk.Revit.DB.AnalysisValueAtPoint
Autodesk.Revit.DB.AnalysisVectorAtPoint

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ValueAtPointBase : IDisposable
Public Class ValueAtPointBase
    Implements IDisposable
public ref class ValueAtPointBase : IDisposable
type ValueAtPointBase =
    class
        interface IDisposable
    end

The ValueAtPointBase type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | ClearAllFlags | Sets flags for all measurements to ValueAtPointFlags::None.
Public method | ClearFlagsAt | Sets flags for the given measurement to ValueAtPointFlags::None.
Public method | Dispose | Releases all resources used by the ValueAtPointBase
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetFlags | Returns flags for the given measurement.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetFlags(IListInt32) | Independently sets the flags associated to all measurements.
Public method | SetFlags(Int32) | Sets the flags associated to all measurements to the same value.
Public method | SetFlags(Int32, Int32) | Sets the flags associated to a given measurement.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This class stores a set of measurements and corresponding mapped flags. The flags are defined in the enumerated type ValueAtPointFlags.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ValueAtPointBase Properties

The ValueAtPointBase type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

ValueAtPointBase Class


ValueAtPointBase.IsValidObject Property

ValueAtPointBaseIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ValueAtPointBase Class


ValueAtPointBase Methods

The ValueAtPointBase type exposes the following members.

Methods
 | Name | Description
Public method | ClearAllFlags | Sets flags for all measurements to ValueAtPointFlags::None.
Public method | ClearFlagsAt | Sets flags for the given measurement to ValueAtPointFlags::None.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetFlags | Returns flags for the given measurement.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetFlags(IListInt32) | Independently sets the flags associated to all measurements.
Public method | SetFlags(Int32) | Sets the flags associated to all measurements to the same value.
Public method | SetFlags(Int32, Int32) | Sets the flags associated to a given measurement.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ValueAtPointBase Class


ValueAtPointBase.ClearAllFlags Method

ValueAtPointBaseClearAllFlags Method

Sets flags for all measurements to ValueAtPointFlags::None.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ClearAllFlags()
Public Sub ClearAllFlags
public:
void ClearAllFlags()
member ClearAllFlags : unit -> unit
See Also

Reference

ValueAtPointBase Class


ValueAtPointBase.ClearFlagsAt Method

ValueAtPointBaseClearFlagsAt Method

Sets flags for the given measurement to ValueAtPointFlags::None.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ClearFlagsAt(
    int measurement
)
Public Sub ClearFlagsAt (
    measurement As Integer
)
public:
void ClearFlagsAt(
    int measurement
)
member ClearFlagsAt :
        measurement : int -> unit

Parameters

measurement Int32
Measurement for which to clear flags.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The given value for measurement is negative.
See Also

Reference

ValueAtPointBase Class


ValueAtPointBase.Dispose Method

ValueAtPointBaseDispose Method

Releases all resources used by the ValueAtPointBase

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ValueAtPointBase Class


ValueAtPointBase.GetFlags Method

ValueAtPointBaseGetFlags Method

Returns flags for the given measurement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetFlags(
    int measurement
)
Public Function GetFlags (
    measurement As Integer
) As Integer
public:
int GetFlags(
    int measurement
)
member GetFlags :
        measurement : int -> int

Parameters

measurement Int32
Measurement number for which flags are returned.

Return Value

Int32
Flags value for the measurement.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The given value for measurement is negative.
See Also

Reference

ValueAtPointBase Class


ValueAtPointBase.SetFlags Method

ValueAtPointBaseSetFlags Method

Overload List
 | Name | Description
Public method | SetFlags(IListInt32) | Independently sets the flags associated to all measurements.
Public method | SetFlags(Int32) | Sets the flags associated to all measurements to the same value.
Public method | SetFlags(Int32, Int32) | Sets the flags associated to a given measurement.
Top
See Also

Reference

ValueAtPointBase Class


ValueAtPointBase.SetFlags(IList<Int32>) Method

ValueAtPointBaseSetFlags(IListInt32) Method

Independently sets the flags associated to all measurements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetFlags(
    IList<int> flags
)
Public Sub SetFlags (
    flags As IList(Of Integer)
)
public:
void SetFlags(
    IList<int>^ flags
)
member SetFlags :
        flags : IList<int> -> unit

Parameters

flags IList Int32
An array of flags values. Each member corresponds to a measurement. Flags values are defined in the enumerated class ValueAtPointFlags and are combined into the int value. Number of measurements is set at creation of SpatialFieldManager in method createSpatialFieldManager.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
If you set the array of flags to only contain one value, this flags value will apply to all measurements
See Also

Reference

ValueAtPointBase Class
SetFlags Overload


ValueAtPointBase.SetFlags(Int32) Method

ValueAtPointBaseSetFlags(Int32) Method

Sets the flags associated to all measurements to the same value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetFlags(
    int flags
)
Public Sub SetFlags (
    flags As Integer
)
public:
void SetFlags(
    int flags
)
member SetFlags :
        flags : int -> unit

Parameters

flags Int32
Value of flags, uniform for all measurements. Flags values are defined in the enumerated class ValueAtPointFlags and are combined into the int value.
See Also

Reference

ValueAtPointBase Class
SetFlags Overload


ValueAtPointBase.SetFlags(Int32, Int32) Method

ValueAtPointBaseSetFlags(Int32, Int32) Method

Sets the flags associated to a given measurement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetFlags(
    int flags,
    int measurement
)
Public Sub SetFlags (
    flags As Integer,
    measurement As Integer
)
public:
void SetFlags(
    int flags,
    int measurement
)
member SetFlags :
        flags : int *
        measurement : int -> unit

Parameters

flags Int32
The value of the flags to set. Flags values are defined in the enumerated class ValueAtPointFlags and are combined into the int value.
measurement Int32
Measurement for which to set flags.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The given value for measurement is negative.
See Also

Reference

ValueAtPointBase Class
SetFlags Overload


ValueAtPointFlags Enumeration

Enumerated type containing flags related to the display on particular points. Enumerated type that stores bit values of flags that can be set at any domain point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ValueAtPointFlags
Public Enumeration ValueAtPointFlags
public enum class ValueAtPointFlags
type ValueAtPointFlags
Members
Member name | Value | Description
None | 0 | No flags set
DisplayText | 1 | Show text marker for the point if allowed by display style (applies only to certain display styles)
DisplayFence | 2 | Show fence for the point if allowed by display style (applies only to diagram display style)
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ValueParsingOptions Class

Options for parsing strings into numbers with units.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBValueParsingOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ValueParsingOptions : IDisposable
Public Class ValueParsingOptions
    Implements IDisposable
public ref class ValueParsingOptions : IDisposable
type ValueParsingOptions =
    class
        interface IDisposable
    end

The ValueParsingOptions type exposes the following members.

Constructors
 | Name | Description
Public method | ValueParsingOptions | Creates a new ValueParsingOptions object with default settings.
Top
Properties
 | Name | Description
Public property | AllowedValues | The allowable range of values to be parsed.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ValueParsingOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetFormatOptions | Gets the FormatOptions to optionally override the default settings in the Units class.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetFormatOptions | Sets the FormatOptions to optionally override the default settings in the Units class.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ValueParsingOptions Constructor

Creates a new ValueParsingOptions object with default settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ValueParsingOptions()
Public Sub New
public:
ValueParsingOptions()
new : unit -> ValueParsingOptions
See Also

Reference

ValueParsingOptions Class


ValueParsingOptions Properties

The ValueParsingOptions type exposes the following members.

Properties
 | Name | Description
Public property | AllowedValues | The allowable range of values to be parsed.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

ValueParsingOptions Class


ValueParsingOptions.AllowedValues Property

ValueParsingOptionsAllowedValues Property

The allowable range of values to be parsed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AllowedValues AllowedValues { get; set; }
Public Property AllowedValues As AllowedValues
    Get
    Set
public:
property AllowedValues AllowedValues {
    AllowedValues get ();
    void set (AllowedValues value);
}
member AllowedValues : AllowedValues with get, set

Property Value

AllowedValues
The allowable range of values. The default is All.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ValueParsingOptions Class


ValueParsingOptions.IsValidObject Property

ValueParsingOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ValueParsingOptions Class


ValueParsingOptions Methods

The ValueParsingOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetFormatOptions | Gets the FormatOptions to optionally override the default settings in the Units class.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetFormatOptions | Sets the FormatOptions to optionally override the default settings in the Units class.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ValueParsingOptions Class


ValueParsingOptions.Dispose Method

ValueParsingOptionsDispose Method

Releases all resources used by the ValueParsingOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ValueParsingOptions Class


ValueParsingOptions.GetFormatOptions Method

ValueParsingOptionsGetFormatOptions Method

Gets the FormatOptions to optionally override the default settings in the Units class.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FormatOptions GetFormatOptions()
Public Function GetFormatOptions As FormatOptions
public:
FormatOptions^ GetFormatOptions()
member GetFormatOptions : unit -> FormatOptions

Return Value

FormatOptions
A copy of the FormatOptions.
Remarks
By default, the FormatOptions represents default formatting (UseDefault is true) and the FormatOptions in the Units class will be used.
See Also

Reference

ValueParsingOptions Class


ValueParsingOptions.SetFormatOptions Method

ValueParsingOptionsSetFormatOptions Method

Sets the FormatOptions to optionally override the default settings in the Units class.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetFormatOptions(
    FormatOptions formatOptions
)
Public Sub SetFormatOptions (
    formatOptions As FormatOptions
)
public:
void SetFormatOptions(
    FormatOptions^ formatOptions
)
member SetFormatOptions :
        formatOptions : FormatOptions -> unit

Parameters

formatOptions FormatOptions
The FormatOptions.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
By default, the FormatOptions represents default formatting (UseDefault is true) and the FormatOptions in the Units class will be used.
See Also

Reference

ValueParsingOptions Class


VertexIndexPair Class

Represents a connection between vertices in the top and bottom profile of a blend.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBVertexIndexPair

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class VertexIndexPair
Public Class VertexIndexPair
public ref class VertexIndexPair
type VertexIndexPair = class end

The VertexIndexPair type exposes the following members.

Constructors
 | Name | Description
Public method | VertexIndexPair | Initializes a new instance of the VertexIndexPair class
Top
Properties
 | Name | Description
Public property | Bottom | The index of the vertex pair from the bottom profile.
Public property | Top | The index of the vertex pair from the top profile.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Use objects of this type in GetVertexConnectionMap, SetVertexConnectionMap(VertexIndexPairArray), GetVertexConnectionMap and SetVertexConnectionMap(VertexIndexPairArray) to get/set the vertex connection map.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


VertexIndexPair Constructor

Initializes a new instance of the VertexIndexPair class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VertexIndexPair(
    int iTop,
    int iBottom
)
Public Sub New (
    iTop As Integer,
    iBottom As Integer
)
public:
VertexIndexPair(
    int iTop,
    int iBottom
)
new :
        iTop : int *
        iBottom : int -> VertexIndexPair

Parameters

iTop Int32
iBottom Int32
See Also

Reference

VertexIndexPair Class


VertexIndexPair Properties

The VertexIndexPair type exposes the following members.

Properties
 | Name | Description
Public property | Bottom | The index of the vertex pair from the bottom profile.
Public property | Top | The index of the vertex pair from the top profile.
Top
See Also

Reference

VertexIndexPair Class


VertexIndexPair.Bottom Property

VertexIndexPairBottom Property

The index of the vertex pair from the bottom profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Bottom { get; set; }
Public Property Bottom As Integer
    Get
    Set
public:
property int Bottom {
    int get ();
    void set (int value);
}
member Bottom : int with get, set

Property Value

Int32
See Also

Reference

VertexIndexPair Class


VertexIndexPair.Top Property

VertexIndexPairTop Property

The index of the vertex pair from the top profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Top { get; set; }
Public Property Top As Integer
    Get
    Set
public:
property int Top {
    int get ();
    void set (int value);
}
member Top : int with get, set

Property Value

Int32
See Also

Reference

VertexIndexPair Class


VertexIndexPair Methods

The VertexIndexPair type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

VertexIndexPair Class


VertexIndexPairArray Class

An array that contains VertexIndex pairs.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBVertexIndexPairArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class VertexIndexPairArray : APIObject,
    IEnumerable
Public Class VertexIndexPairArray
    Inherits APIObject
    Implements IEnumerable
public ref class VertexIndexPairArray : public APIObject,
    IEnumerable
type VertexIndexPairArray =
    class
        inherit APIObject
        interface IEnumerable
    end

The VertexIndexPairArray type exposes the following members.

Constructors
 | Name | Description
Public method | VertexIndexPairArray | Initializes a new instance of the VertexIndexPairArray class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets a VertexIndex pair at a specified index within the array.
Public property | Size | Returns the number of VertexIndex pairs that are in the array.
Top
Methods
 | Name | Description
Public method | Append |
Public method | Clear | Removes every VertexIndex pair from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


VertexIndexPairArray Constructor

Initializes a new instance of the VertexIndexPairArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VertexIndexPairArray()
Public Sub New
public:
VertexIndexPairArray()
new : unit -> VertexIndexPairArray
See Also

Reference

VertexIndexPairArray Class


VertexIndexPairArray Properties

The VertexIndexPairArray type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Item | Gets or sets a VertexIndex pair at a specified index within the array.
Public property | Size | Returns the number of VertexIndex pairs that are in the array.
Top
See Also

Reference

VertexIndexPairArray Class


VertexIndexPairArray.IsEmpty Property

VertexIndexPairArrayIsEmpty Property

Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Boolean
Remarks
If the array is empty then True will be returned, otherwise False.
See Also

Reference

VertexIndexPairArray Class


VertexIndexPairArray.Item Property

VertexIndexPairArrayItem Property

Gets or sets a VertexIndex pair at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual VertexIndexPair this[
    int index
] { get; set; }
Public Overridable Property Item (
    index As Integer
) As VertexIndexPair
    Get
    Set
public:
virtual property VertexIndexPair^ Item[int index] {
    VertexIndexPair^ get (int index);
    void set (int index, VertexIndexPair^ value);
}
abstract Item : VertexIndexPair with get, set
override Item : VertexIndexPair with get, set

Parameters

index Int32
The index of the VertexIndex pair to be set or retrieved.

Return Value

VertexIndexPair
Returns the VertexIndex pair at the specified index.
See Also

Reference

VertexIndexPairArray Class


VertexIndexPairArray.Size Property

VertexIndexPairArraySize Property

Returns the number of VertexIndex pairs that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
abstract Size : int with get
override Size : int with get

Property Value

Int32
See Also

Reference

VertexIndexPairArray Class


VertexIndexPairArray Methods

The VertexIndexPairArray type exposes the following members.

Methods
 | Name | Description
Public method | Append |
Public method | Clear | Removes every VertexIndex pair from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

VertexIndexPairArray Class


VertexIndexPairArray.Append Method

VertexIndexPairArrayAppend Method

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Append(
    VertexIndexPair item
)
Public Overridable Sub Append (
    item As VertexIndexPair
)
public:
virtual void Append(
    VertexIndexPair^ item
)
abstract Append :
        item : VertexIndexPair -> unit
override Append :
        item : VertexIndexPair -> unit

Parameters

item VertexIndexPair
See Also

Reference

VertexIndexPairArray Class


VertexIndexPairArray.Clear Method

VertexIndexPairArrayClear Method

Removes every VertexIndex pair from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

VertexIndexPairArray Class


VertexIndexPairArray.ForwardIterator Method

VertexIndexPairArrayForwardIterator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual VertexIndexPairArrayIterator ForwardIterator()
Public Overridable Function ForwardIterator As VertexIndexPairArrayIterator
public:
virtual VertexIndexPairArrayIterator^ ForwardIterator()
abstract ForwardIterator : unit -> VertexIndexPairArrayIterator
override ForwardIterator : unit -> VertexIndexPairArrayIterator

Return Value

VertexIndexPairArrayIterator
Returns a forward moving iterator to the array.
See Also

Reference

VertexIndexPairArray Class


VertexIndexPairArray.GetEnumerator Method

VertexIndexPairArrayGetEnumerator Method

Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

IEnumerator
Returns a forward moving iterator to the array.

Implements

IEnumerableGetEnumerator
See Also

Reference

VertexIndexPairArray Class


VertexIndexPairArray.Insert Method

VertexIndexPairArrayInsert Method

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Insert(
    VertexIndexPair item,
    int index
)
Public Overridable Sub Insert (
    item As VertexIndexPair,
    index As Integer
)
public:
virtual void Insert(
    VertexIndexPair^ item,
    int index
)
abstract Insert :
        item : VertexIndexPair *
        index : int -> unit
override Insert :
        item : VertexIndexPair *
        index : int -> unit

Parameters

item VertexIndexPair
index Int32
See Also

Reference

VertexIndexPairArray Class


VertexIndexPairArray.ReverseIterator Method

VertexIndexPairArrayReverseIterator Method

Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual VertexIndexPairArrayIterator ReverseIterator()
Public Overridable Function ReverseIterator As VertexIndexPairArrayIterator
public:
virtual VertexIndexPairArrayIterator^ ReverseIterator()
abstract ReverseIterator : unit -> VertexIndexPairArrayIterator
override ReverseIterator : unit -> VertexIndexPairArrayIterator

Return Value

VertexIndexPairArrayIterator
Returns a backward moving iterator to the array.
See Also

Reference

VertexIndexPairArray Class


VertexIndexPairArrayIterator Class

An iterator to an array of VertexIndex pairs.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBVertexIndexPairArrayIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class VertexIndexPairArrayIterator : APIObject,
    IEnumerator
Public MustInherit Class VertexIndexPairArrayIterator
    Inherits APIObject
    Implements IEnumerator
public ref class VertexIndexPairArrayIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type VertexIndexPairArrayIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The VertexIndexPairArrayIterator type exposes the following members.

Constructors
 | Name | Description
Public method | VertexIndexPairArrayIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


VertexIndexPairArrayIterator Constructor

For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VertexIndexPairArrayIterator()
Public Sub New
public:
VertexIndexPairArrayIterator()
new : unit -> VertexIndexPairArrayIterator
Remarks
This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.
See Also

Reference

VertexIndexPairArrayIterator Class


VertexIndexPairArrayIterator Properties

The VertexIndexPairArrayIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

VertexIndexPairArrayIterator Class


VertexIndexPairArrayIterator.Current Property

VertexIndexPairArrayIteratorCurrent Property

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}
abstract Current : Object with get
override Current : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.
See Also

Reference

VertexIndexPairArrayIterator Class


VertexIndexPairArrayIterator Methods

The VertexIndexPairArrayIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

VertexIndexPairArrayIterator Class


VertexIndexPairArrayIterator.MoveNext Method

VertexIndexPairArrayIteratorMoveNext Method

Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumeratorMoveNext
Remarks
MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.
See Also

Reference

VertexIndexPairArrayIterator Class


VertexIndexPairArrayIterator.Reset Method

VertexIndexPairArrayIteratorReset Method

Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
Remarks
The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.
See Also

Reference

VertexIndexPairArrayIterator Class


VertexPair Class

Indices of a pair of vertices in two CurveLoops(one vertex in each loop).
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBVertexPair

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class VertexPair : IDisposable
Public Class VertexPair
    Implements IDisposable
public ref class VertexPair : IDisposable
type VertexPair =
    class
        interface IDisposable
    end

The VertexPair type exposes the following members.

Constructors
 | Name | Description
Public method | VertexPair | Constructs a new VertexPair from a pair of indices in the curve loops.
Top
Properties
 | Name | Description
Public property | First | Identifies the first index of VertexPair.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Second | Identifies the second index of VertexPair.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the VertexPair
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
A vertex is specified by the index in the CurveLoop of the curve having that vertex as its start point. Indexes start at 0.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


VertexPair Constructor

Constructs a new VertexPair from a pair of indices in the curve loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VertexPair(
    int firstVertexIdx,
    int secondVertexIdx
)
Public Sub New (
    firstVertexIdx As Integer,
    secondVertexIdx As Integer
)
public:
VertexPair(
    int firstVertexIdx,
    int secondVertexIdx
)
new :
        firstVertexIdx : int *
        secondVertexIdx : int -> VertexPair

Parameters

firstVertexIdx Int32
secondVertexIdx Int32
See Also

Reference

VertexPair Class


VertexPair Properties

The VertexPair type exposes the following members.

Properties
 | Name | Description
Public property | First | Identifies the first index of VertexPair.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Second | Identifies the second index of VertexPair.
Top
See Also

Reference

VertexPair Class


VertexPair.First Property

VertexPairFirst Property

Identifies the first index of VertexPair.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int First { get; set; }
Public Property First As Integer
    Get
    Set
public:
property int First {
    int get ();
    void set (int value);
}
member First : int with get, set

Property Value

Int32
See Also

Reference

VertexPair Class


VertexPair.IsValidObject Property

VertexPairIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

VertexPair Class


VertexPair.Second Property

VertexPairSecond Property

Identifies the second index of VertexPair.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Second { get; set; }
Public Property Second As Integer
    Get
    Set
public:
property int Second {
    int get ();
    void set (int value);
}
member Second : int with get, set

Property Value

Int32
See Also

Reference

VertexPair Class


VertexPair Methods

The VertexPair type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

VertexPair Class


VertexPair.Dispose Method

VertexPairDispose Method

Releases all resources used by the VertexPair

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

VertexPair Class


VerticalAlignmentStyle Enumeration

Declares the vertical alignment style of font.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum VerticalAlignmentStyle
Public Enumeration VerticalAlignmentStyle
public enum class VerticalAlignmentStyle
type VerticalAlignmentStyle
Members
Member name | Value | Description
Top | 0 | Alignment to top
Middle | 4 | Alignment to middle
Bottom | 8 | Alignment to bottom
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


VerticalTextAlignment Enumeration

Supported types of vertical alignment of a text element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum VerticalTextAlignment
Public Enumeration VerticalTextAlignment
public enum class VerticalTextAlignment
type VerticalTextAlignment
Members
Member name | Value | Description
Top | 0 | Top of the text box remains in place as the height of the text changes.
Bottom | 1 | Bottom of the text box remains in place as the height of the text changes.
Middle | 2 | The horizontal center line of the text box remains in place as the height of the text changes.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


View Class

Base class for all types of views in Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBView
More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class View : Element
Public Class View
    Inherits Element
public ref class View : public Element
type View =
    class
        inherit Element
    end

The View type exposes the following members.

Properties
 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view.
Public property | AreAnalyticalModelCategoriesHidden | Indicates if analytical model categories are currently hidden in the view.
Public property | AreAnnotationCategoriesHidden | Indicates if annotation categories are currently hidden in the view.
Public property | AreCoordinationModelHandlesHidden | Indicates if Coordination Model handles are currently hidden in the view.
Public property | AreImportCategoriesHidden | Indicates if import categories are currently hidden in the view.
Public property | AreModelCategoriesHidden | Indicates if model categories are currently hidden in the view.
Public property | ArePointCloudsHidden | Indicates if point clouds are currently hidden in the view.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view.
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBePrinted | Test whether the view can be printed.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CropBox | The Crop Box applied to the view, or an outline encompassing the crop region applied to the view.
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view.
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view.
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | DetailLevel | The detail level of this view.
Public property | Discipline | The Discipline of the view.
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | GenLevel | The level for the view.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsAssemblyView | Indicates if the view is assembly view.
Public property | IsCallout | Indicates if the view is a callout view.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTemplate | Test whether the view is a view template.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | Origin | Returns the origin of the screen.
Public property | Outline | The bounds of the view in paper space (in feet).
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | PartsVisibility | The visibility setting for parts in this view.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | RevealConstraintsMode | Indicates whether the Reveal Constraints mode is activated in the view.
Public property | RightDirection | The direction towards the right side of the screen.
Public property | Scale | The scale of the view.
Public property | ShadowIntensity | The intesity of cast shadows - 0 = no shadows, 100 = black.
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation.
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering.
Public property | SunlightIntensity | The intensity of the simulated (directional) sunlight. 0 = no directional light; maximum value is 100.
Public property | TemporaryViewModes | Data of temporary view modes associated with this view.
Public property | Title | The view title. This consists of the view name plus other modifiers, such as the view type, sheet number, area scheme, and/or assembly type, depending on the specifics of the view.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | UpDirection | The direction towards the top of the screen.
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewDirection | The direction towards the viewer.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | ViewTemplateId | The id of the template view that controls this view's parameters.
 | ViewType | The type of the view.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | AddFilter | Adds a filter to the view.
Public method | AllowsAnalysisDisplay | Identifies if this view allows display of Analysis results.
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of the input view that are not controlled by the current view template.
Public method | AreGraphicsOverridesAllowed | Determines if Visibility/Graphics Overriddes can be applied to the view.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanApplyColorFillScheme | Checks if the id can be applied as the scheme id of specified category to this view.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanCategoryBeHidden | Checks whether the category can be hidden in the view.
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view.
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanEnableTemporaryViewPropertiesMode | Indicates if Temporary View Properties mode can be applied for view in current state.
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified.
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified.
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified
Public method | CanUseDepthCueing | Indicates if view can use Depth Cueing
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes
Public method | CanViewBeDuplicated | Identifies if this view can be duplicated.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view.
 | ConvertToIndependent | Convert the dependent view to independent.
Public method | CreateViewTemplate | Creates a new view template instance from this view instance.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode.
Public method | Dispose | (Inherited from Element)
 | Duplicate | Duplicates this view.
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode.
Public method | EnableTemporaryViewPropertiesMode | Turns Temporary View Properties mode on or off. In this mode, any changes made to the view are temporary and will be discarded once the mode is disabled.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetBackground | Returns the current background set for the view.
Public method | GetCalloutParentId | Gets ID of the callout parent view.
Public method | GetCategoryHidden | Checks if elements of the given category are set to be invisible (hidden) in this view.
Public method | GetCategoryOverrides | Gets graphic overrides for a category in view.
Public method | GetColorFillSchemeId | Returns id of the color fill scheme element applied to the view.
Public method | GetCropRegionShapeManager | Returns an object for managing view crop region shape.
 | GetCropRegionShapeManagerForReferenceCallout | Returns an object for managing view crop region shape for reference callout.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetDependentViewIds | Get the ids of dependent views.
Public method | GetDepthCueing | Returns the current depth cueing settings for the view.
Public method | GetDirectContext3DHandleOverrides | Returns DirectContext3D handle overrides object for the view.
Public method | GetElementOverrides | Gets graphic overrides for an element in the view.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFilterOverrides | Gets graphic overrides that a filter applies to the view.
Public method | GetFilters | Gets the filters applied to the view.
Public method | GetFilterVisibility | Gets the visibility of the elements associated with a filter.
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIsFilterEnabled | Identifies if the filter is enabled in this view.
 | GetLinkOverrides | Gets the graphic overrides of a RevitLinkType or RevitLinkInstance in view.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetModelToProjectionTransforms | Gets the transforms from the model space to the view projection space.
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetNonControlledTemplateParameterIds | Returns a list of parameters that are not marked as included when this view is used as a template.
Public method | GetOrderedFilters | Gets the filters applied to the view in the order they are applied.
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPlacementOnSheetStatus | Determines if this view placed on a sheet completely or partially.
Public method | GetPointCloudOverrides | Returns point cloud overrides object for the view.
Public method | GetPrimaryViewId | Get the id of the primary view.
Public method | GetReferenceCallouts | Returns element ids of all reference callouts in the view.
Public method | GetReferenceElevations | Returns element ids of all reference elevations in the view.
Public method | GetReferenceSections | Returns element ids of all reference sections in the view.
Public method | GetSketchyLines | Returns the current sketchy lines settings for the view.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTemplateParameterIds | Returns a list of parameter ids that may be controlled when this view is assigned as a template.
Public method | GetTemporaryViewPropertiesId | When Temporary View Properties mode is in progress it provides view id that overrode settings for current view. Outside Temporary View Properties mode InvalidElementId will be returned.
Public method | GetTemporaryViewPropertiesName | When Temporary View Properties mode is in progress, name of applied template is returned. Outside Temporary View Properties mode, empty string will be returned.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetViewDisplayModel | Returns the current view display model settings for the view.
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view.
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view.
Public method | HasDetailLevel | Check if the view has a Detail Level property
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property
Public method | HasViewTransforms | Returns true if the view reports model space to view projection space transforms.
Public method | HideActiveWorkPlane | Hide the active work plane of the view.
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view.
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view.
Public method | HideElements | Sets the elements to be hidden in the view.
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input.
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input.
Public method | IsCategoryOverridable | Checks whether the category can have graphic overrides in this view.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsFilterApplied | Indicates if a filter is applied to the view.
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view.
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view.
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input.
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories.
Public method | IsTemporaryViewPropertiesModeEnabled | Returns true when Temporary View Properties mode is in progress, false otherwise.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
 | IsValidViewScale | This validator checks that the view scale is in the allowable range.
Public method | IsValidViewTemplate | Verifies that the view represented by templateId can be set as the controlling view template for this view.
Public method | IsViewValidForTemplateCreation | Verifies that the view is valid for template creation.
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | Print | Print this view with the default view template and using the print setting of the current active document.
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document.
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document.
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document.
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveCalloutParent | Replaces callout parent ID with InvalidElementId.
Public method | RemoveFilter | Removes a filter from the view.
 | RemoveLinkOverrides | Deletes the graphical link overrides in the current view.
Public method | RestoreCalloutParent | Restores callout parent ID to the original view ID if that view is still available.
Public method | SetBackground | Sets the background for the view. Background can only be set for 3d views and for Sections/Elevations.
Public method | SetCategoryHidden | Sets if elements of the given category will be visible in this view.
Public method | SetCategoryOverrides | Sets graphic overrides for a category in view.
Public method | SetColorFillSchemeId | Applies color fill scheme to this view.
Public method | SetDepthCueing | Sets the depth cueing settings for the view.
Public method | SetElementOverrides | Sets graphic overrides for an element in the view.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
 | SetFilterOverrides | Sets the overrides associated with a filter.
Public method | SetFilterVisibility | Sets the visibility of the elements associated with a filter.
Public method | SetIsFilterEnabled | Sets the filter enabled flag.
 | SetLinkOverrides | Sets the graphic overrides of a RevitLinkType or RevitLinkInstance in the view.
Public method | SetNonControlledTemplateParameterIds | Sets the parameters that will not be included when this view is used as a template.
Public method | SetSketchyLines | Sets the sketchy lines settings for the view.
Public method | SetViewDisplayModel | Sets the view display model settings for the view.
Public method | SetWorksetVisibility | Sets visibility for a workset in this view.
 | SetWorksharingDisplayMode | Sets the worksharing display mode for this view.
Public method | ShowActiveWorkPlane | Show the active work plane of the view.
Public method | SupportedColorFillCategoryIds | Returns collection of all category ids that correspond to elements that can potentially be colored in this view according to a color fill scheme. The set may be different depending on the view type.
Public method | SupportsRevealConstraints | Checks that the view can have the Reveal Constraints mode activated.
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden.
Top
Remarks
A view can display an image produced from a Revit model. Views can be graphical (e.g. plans, elevations, or 3D views) or textual (e.g. schedules). Views keep track of Elements that can be seen in them.
Example
C#
VB
C++
F#
Copy
private void Getinfo_View(Autodesk.Revit.DB.View view)
{
    string message = "View: ";

    //get the name of the view
    message += "\nView name: " + view.Name;

    //The crop box sets display bounds of the view
    BoundingBoxXYZ cropBox = view.CropBox;
    XYZ max = cropBox.Max; //Maximum coordinates (upper-right-front corner of the box).
    XYZ min = cropBox.Min; //Minimum coordinates (lower-left-rear corner of the box).
    message += "\nCrop Box: ";
    message += "\nMaximum coordinates: (" + max.X + ", " + max.Y + ", " + max.Z + ")";
    message += "\nMinimum coordinates: (" + min.X + ", " + min.Y + ", " + min.Z + ")";

   //get the origin of the screen
    XYZ origin = view.Origin;
    message += "\nOrigin: (" + origin.X + ", " + origin.Y + ", " + origin.Z + ")";

    //The bounds of the view in paper space (in inches).
    BoundingBoxUV outline = view.Outline;
    UV maxUv = outline.Max; //Maximum coordinates (upper-right corner of the box).
    UV minUv = outline.Min; //Minimum coordinates (lower-left corner of the box).
    message += "\nOutline: ";
    message += "\nMaximum coordinates: (" + maxUv.U + ", " + maxUv.V + ")";
    message += "\nMinimum coordinates: (" + minUv.U + ", " + minUv.V + ")";

    //The direction towards the right side of the screen
    XYZ rightDirection = view.RightDirection;
    message += "\nRight direction: (" + rightDirection.X + ", " +
                   rightDirection.Y + ", " + rightDirection.Z + ")";

    //The direction towards the top of the screen
    XYZ upDirection = view.UpDirection;
    message += "\nUp direction: (" + upDirection.X + ", " +
                   upDirection.Y + ", " + upDirection.Z + ")";

    //The direction towards the viewer
    XYZ viewDirection = view.ViewDirection;
    message += "\nView direction: (" + viewDirection.X + ", " +
                   viewDirection.Y + ", " + viewDirection.Z + ")";

    //The scale of the view
    message += "\nScale: " + view.Scale;
    // Scale is meaningless for Schedules
    if (view.ViewType != ViewType.Schedule)
    {
        int testScale = 5;
        //set the scale of the view
        view.Scale = testScale;
        message += "\nScale after set: " + view.Scale;
    }

    TaskDialog.Show("Revit",message);
}
Private Sub Getinfo_View(view As Autodesk.Revit.DB.View)
    Dim message As String = "View: "

    'get the name of the view
    message += vbLf & "View name: " + view.Name

    'The crop box sets display bounds of the view
    Dim cropBox As BoundingBoxXYZ = view.CropBox
    Dim max As XYZ = cropBox.Max
    'Maximum coordinates (upper-right-front corner of the box).
    Dim min As XYZ = cropBox.Min
    'Minimum coordinates (lower-left-rear corner of the box).
    message += vbLf & "Crop Box: "
    message += vbLf & "Maximum coordinates: (" + max.X + ", " + max.Y + ", " + max.Z + ")"
    message += vbLf & "Minimum coordinates: (" + min.X + ", " + min.Y + ", " + min.Z + ")"

    'get the origin of the screen
    Dim origin As XYZ = view.Origin
    message += vbLf & "Origin: (" + origin.X + ", " + origin.Y + ", " + origin.Z + ")"

    'The bounds of the view in paper space (in inches).
    Dim outline As BoundingBoxUV = view.Outline
    Dim maxUv As UV = outline.Max
    'Maximum coordinates (upper-right corner of the box).
    Dim minUv As UV = outline.Min
    'Minimum coordinates (lower-left corner of the box).
    message += vbLf & "Outline: "
    message += vbLf & "Maximum coordinates: (" + maxUv.U + ", " + maxUv.V + ")"
    message += vbLf & "Minimum coordinates: (" + minUv.U + ", " + minUv.V + ")"

    'The direction towards the right side of the screen
    Dim rightDirection As XYZ = view.RightDirection
    message += vbLf & "Right direction: (" + rightDirection.X + ", " + rightDirection.Y + ", " + rightDirection.Z + ")"

    'The direction towards the top of the screen
    Dim upDirection As XYZ = view.UpDirection
    message += vbLf & "Up direction: (" + upDirection.X + ", " + upDirection.Y + ", " + upDirection.Z + ")"

    'The direction towards the viewer
    Dim viewDirection As XYZ = view.ViewDirection
    message += vbLf & "View direction: (" + viewDirection.X + ", " + viewDirection.Y + ", " + viewDirection.Z + ")"

    'The scale of the view
    message += vbLf & "Scale: " + view.Scale
    ' Scale is meaningless for Schedules
    If view.ViewType <> ViewType.Schedule Then
        Dim testScale As Integer = 5
        'set the scale of the view
        view.Scale = testScale
        message += vbLf & "Scale after set: " + view.Scale
    End If

    TaskDialog.Show("Revit", message)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBView
Autodesk.Revit.DB.AnalysisViewSystemsAnalysisReport
Autodesk.Revit.DBTableView
Autodesk.Revit.DBView3D
Autodesk.Revit.DBViewDrafting
Autodesk.Revit.DBViewPlan
Autodesk.Revit.DBViewSection
Autodesk.Revit.DBViewSheet


View Properties

The View type exposes the following members.

Properties
 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view.
Public property | AreAnalyticalModelCategoriesHidden | Indicates if analytical model categories are currently hidden in the view.
Public property | AreAnnotationCategoriesHidden | Indicates if annotation categories are currently hidden in the view.
Public property | AreCoordinationModelHandlesHidden | Indicates if Coordination Model handles are currently hidden in the view.
Public property | AreImportCategoriesHidden | Indicates if import categories are currently hidden in the view.
Public property | AreModelCategoriesHidden | Indicates if model categories are currently hidden in the view.
Public property | ArePointCloudsHidden | Indicates if point clouds are currently hidden in the view.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view.
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBePrinted | Test whether the view can be printed.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CropBox | The Crop Box applied to the view, or an outline encompassing the crop region applied to the view.
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view.
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view.
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | DetailLevel | The detail level of this view.
Public property | Discipline | The Discipline of the view.
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | GenLevel | The level for the view.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsAssemblyView | Indicates if the view is assembly view.
Public property | IsCallout | Indicates if the view is a callout view.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTemplate | Test whether the view is a view template.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | Origin | Returns the origin of the screen.
Public property | Outline | The bounds of the view in paper space (in feet).
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | PartsVisibility | The visibility setting for parts in this view.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | RevealConstraintsMode | Indicates whether the Reveal Constraints mode is activated in the view.
Public property | RightDirection | The direction towards the right side of the screen.
Public property | Scale | The scale of the view.
Public property | ShadowIntensity | The intesity of cast shadows - 0 = no shadows, 100 = black.
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation.
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering.
Public property | SunlightIntensity | The intensity of the simulated (directional) sunlight. 0 = no directional light; maximum value is 100.
Public property | TemporaryViewModes | Data of temporary view modes associated with this view.
Public property | Title | The view title. This consists of the view name plus other modifiers, such as the view type, sheet number, area scheme, and/or assembly type, depending on the specifics of the view.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | UpDirection | The direction towards the top of the screen.
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewDirection | The direction towards the viewer.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | ViewTemplateId | The id of the template view that controls this view's parameters.
 | ViewType | The type of the view.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

View Class


View.AnalysisDisplayStyleId Property

ViewAnalysisDisplayStyleId Property

Element id of Analysis Display Style associated with the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId AnalysisDisplayStyleId { get; set; }
Public Property AnalysisDisplayStyleId As ElementId
    Get
    Set
public:
property ElementId^ AnalysisDisplayStyleId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member AnalysisDisplayStyleId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
InvalidOperationException | When setting this property: Cannot set the AnalysisDisplayStyleId for the specified view.
See Also

Reference

View Class


View.AreAnalyticalModelCategoriesHidden Property

ViewAreAnalyticalModelCategoriesHidden Property

Indicates if analytical model categories are currently hidden in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AreAnalyticalModelCategoriesHidden { get; set; }
Public Property AreAnalyticalModelCategoriesHidden As Boolean
    Get
    Set
public:
property bool AreAnalyticalModelCategoriesHidden {
    bool get ();
    void set (bool value);
}
member AreAnalyticalModelCategoriesHidden : bool with get, set

Property Value

Boolean
True if analytical model categories are currently hidden in the view, false otherwise.
See Also

Reference

View Class


View.AreAnnotationCategoriesHidden Property

ViewAreAnnotationCategoriesHidden Property

Indicates if annotation categories are currently hidden in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AreAnnotationCategoriesHidden { get; set; }
Public Property AreAnnotationCategoriesHidden As Boolean
    Get
    Set
public:
property bool AreAnnotationCategoriesHidden {
    bool get ();
    void set (bool value);
}
member AreAnnotationCategoriesHidden : bool with get, set

Property Value

Boolean
True if annotation categories are currently hidden in the view, false otherwise.
See Also

Reference

View Class


View.AreCoordinationModelHandlesHidden Property

ViewAreCoordinationModelHandlesHidden Property

Indicates if Coordination Model handles are currently hidden in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AreCoordinationModelHandlesHidden { get; set; }
Public Property AreCoordinationModelHandlesHidden As Boolean
    Get
    Set
public:
property bool AreCoordinationModelHandlesHidden {
    bool get ();
    void set (bool value);
}
member AreCoordinationModelHandlesHidden : bool with get, set

Property Value

Boolean
True if Coordination Model handles are currently hidden in the view, false otherwise.
See Also

Reference

View Class


View.AreImportCategoriesHidden Property

ViewAreImportCategoriesHidden Property

Indicates if import categories are currently hidden in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AreImportCategoriesHidden { get; set; }
Public Property AreImportCategoriesHidden As Boolean
    Get
    Set
public:
property bool AreImportCategoriesHidden {
    bool get ();
    void set (bool value);
}
member AreImportCategoriesHidden : bool with get, set

Property Value

Boolean
True if import categories are currently hidden in the view, false otherwise.
See Also

Reference

View Class


View.AreModelCategoriesHidden Property

ViewAreModelCategoriesHidden Property

Indicates if model categories are currently hidden in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AreModelCategoriesHidden { get; set; }
Public Property AreModelCategoriesHidden As Boolean
    Get
    Set
public:
property bool AreModelCategoriesHidden {
    bool get ();
    void set (bool value);
}
member AreModelCategoriesHidden : bool with get, set

Property Value

Boolean
True if model categories are currently hidden in the view, false otherwise.
See Also

Reference

View Class


View.ArePointCloudsHidden Property

ViewArePointCloudsHidden Property

Indicates if point clouds are currently hidden in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ArePointCloudsHidden { get; set; }
Public Property ArePointCloudsHidden As Boolean
    Get
    Set
public:
property bool ArePointCloudsHidden {
    bool get ();
    void set (bool value);
}
member ArePointCloudsHidden : bool with get, set

Property Value

Boolean
True if point clouds are currently hidden in the view, false otherwise.
See Also

Reference

View Class


View.AssociatedAssemblyInstanceId Property

ViewAssociatedAssemblyInstanceId Property

The Id of the assembly instance that owns the assembly view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId AssociatedAssemblyInstanceId { get; }
Public ReadOnly Property AssociatedAssemblyInstanceId As ElementId
    Get
public:
property ElementId^ AssociatedAssemblyInstanceId {
    ElementId^ get ();
}
member AssociatedAssemblyInstanceId : ElementId with get

Property Value

ElementId
See Also

Reference

View Class


View.CanBePrinted Property

ViewCanBePrinted Property

Test whether the view can be printed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanBePrinted { get; }
Public ReadOnly Property CanBePrinted As Boolean
    Get
public:
property bool CanBePrinted {
    bool get ();
}
member CanBePrinted : bool with get

Property Value

Boolean
See Also

Reference

View Class


View.CropBox Property

ViewCropBox Property

The Crop Box applied to the view, or an outline encompassing the crop region applied to the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BoundingBoxXYZ CropBox { get; set; }
Public Property CropBox As BoundingBoxXYZ
    Get
    Set
public:
property BoundingBoxXYZ^ CropBox {
    BoundingBoxXYZ^ get ();
    void set (BoundingBoxXYZ^ value);
}
member CropBox : BoundingBoxXYZ with get, set

Property Value

BoundingBoxXYZ
if the view is a template, or does not support cropping. If the view has a non-rectangular crop region, defined by a sketch, the crop box will be the smallest box that contains the sketch. Setting the crop box for a view with a non-rectangular crop region will have no effect. For better access to the crop region of a given view, regardless of the shape of the crop region, use the return from GetCropRegionShapeManager.
Exceptions
Exception | Condition
InvalidOperationException | Cannot set the CropBox of the specified view.
Remarks
The X direction of the box is right on screen; Y is up; and Z is towards the user. The crop box Z value of a plan view is not meaningful.
See Also

Reference

View Class


View.CropBoxActive Property

ViewCropBoxActive Property

Whether or not the Crop Box/Region is active for the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CropBoxActive { get; set; }
Public Property CropBoxActive As Boolean
    Get
    Set
public:
property bool CropBoxActive {
    bool get ();
    void set (bool value);
}
member CropBoxActive : bool with get, set

Property Value

Boolean
Exceptions
Exception | Condition
InapplicableDataException | Thrown when getting this property, if the view is a template and cannot have a crop box applied.
InvalidOperationException | Thrown when setting this property, if the view is a template and cannot have a crop box applied.
Remarks
Identifies whether the crop region modifies the graphical appearance of elements in the view.
See Also

Reference

View Class


View.CropBoxVisible Property

ViewCropBoxVisible Property

Whether or not the Crop Box/Region is visible for the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CropBoxVisible { get; set; }
Public Property CropBoxVisible As Boolean
    Get
    Set
public:
property bool CropBoxVisible {
    bool get ();
    void set (bool value);
}
member CropBoxVisible : bool with get, set

Property Value

Boolean
Exceptions
Exception | Condition
InapplicableDataException | Thrown when getting this property, if the view is a template and cannot have a crop box applied.
InvalidOperationException | Thrown when setting this property, if the view is a template and cannot have a crop box applied.
See Also

Reference

View Class


View.DetailLevel Property

ViewDetailLevel Property

The detail level of this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ViewDetailLevel DetailLevel { get; set; }
Public Property DetailLevel As ViewDetailLevel
    Get
    Set
public:
property ViewDetailLevel DetailLevel {
    ViewDetailLevel get ();
    void set (ViewDetailLevel value);
}
member DetailLevel : ViewDetailLevel with get, set

Property Value

ViewDetailLevel
Exceptions
Exception | Condition
ArgumentException | When setting this property: Cannot set ViewDetailLevel to Unassigned
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | When setting this property: View does not have a Detail Level property -or- When setting this property: Detail Level cannot be modified.
See Also

Reference

View Class


View.Discipline Property

ViewDiscipline Property

The Discipline of the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ViewDiscipline Discipline { get; set; }
Public Property Discipline As ViewDiscipline
    Get
    Set
public:
property ViewDiscipline Discipline {
    ViewDiscipline get ();
    void set (ViewDiscipline value);
}
member Discipline : ViewDiscipline with get, set

Property Value

ViewDiscipline
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | View must have a Discipline property -or- When setting this property: View Discipline must be modifiable.
See Also

Reference

View Class


View.DisplayStyle Property

ViewDisplayStyle Property

The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DisplayStyle DisplayStyle { get; set; }
Public Property DisplayStyle As DisplayStyle
    Get
    Set
public:
property DisplayStyle DisplayStyle {
    DisplayStyle get ();
    void set (DisplayStyle value);
}
member DisplayStyle : DisplayStyle with get, set

Property Value

DisplayStyle
Exceptions
Exception | Condition
ArgumentException | When setting this property: DisplayStyle cannot be set to Undefined. -or- When setting this property: DisplayStyle of Drafting Views can be set only to Wireframe or HLR
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | When setting this property: DisplayStyle cannot be modified. -or- When setting this property: This view does not contain display-related properties.
See Also

Reference

View Class


View.GenLevel Property

ViewGenLevel Property

The level for the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Level GenLevel { get; }
Public ReadOnly Property GenLevel As Level
    Get
public:
property Level^ GenLevel {
    Level^ get ();
}
member GenLevel : Level with get

Property Value

Level
Remarks
This will obtain the level for views related to levels, such as Plan Views. If this View is not generated by a level, this property is .
See Also

Reference

View Class


View.IsAssemblyView Property

ViewIsAssemblyView Property

Indicates if the view is assembly view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsAssemblyView { get; }
Public ReadOnly Property IsAssemblyView As Boolean
    Get
public:
property bool IsAssemblyView {
    bool get ();
}
member IsAssemblyView : bool with get

Property Value

Boolean
See Also

Reference

View Class


View.IsCallout Property

ViewIsCallout Property

Indicates if the view is a callout view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCallout { get; }
Public ReadOnly Property IsCallout As Boolean
    Get
public:
property bool IsCallout {
    bool get ();
}
member IsCallout : bool with get

Property Value

Boolean
Remarks
Reference callouts are not treated as callout views. The view was created as a callout in its parent view but it may show as a section in orthogonal views.
See Also

Reference

View Class


View.IsTemplate Property

ViewIsTemplate Property

Test whether the view is a view template.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsTemplate { get; }
Public ReadOnly Property IsTemplate As Boolean
    Get
public:
property bool IsTemplate {
    bool get ();
}
member IsTemplate : bool with get

Property Value

Boolean
See Also

Reference

View Class


View.Origin Property

ViewOrigin Property

Returns the origin of the screen.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Origin { get; }
Public ReadOnly Property Origin As XYZ
    Get
public:
property XYZ^ Origin {
    XYZ^ get ();
}
member Origin : XYZ with get

Property Value

XYZ
if the view is a template.
Remarks
The origin of a plan view is not meaningful.
See Also

Reference

View Class


View.Outline Property

ViewOutline Property

The bounds of the view in paper space (in feet).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BoundingBoxUV Outline { get; }
Public ReadOnly Property Outline As BoundingBoxUV
    Get
public:
property BoundingBoxUV^ Outline {
    BoundingBoxUV^ get ();
}
member Outline : BoundingBoxUV with get

Property Value

BoundingBoxUV
Remarks
Returns all zeros for empty views.
See Also

Reference

View Class


View.PartsVisibility Property

ViewPartsVisibility Property

The visibility setting for parts in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PartsVisibility PartsVisibility { get; set; }
Public Property PartsVisibility As PartsVisibility
    Get
    Set
public:
property PartsVisibility PartsVisibility {
    PartsVisibility get ();
    void set (PartsVisibility value);
}
member PartsVisibility : PartsVisibility with get, set

Property Value

PartsVisibility
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

View Class


View.RevealConstraintsMode Property

ViewRevealConstraintsMode Property

Indicates whether the Reveal Constraints mode is activated in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool RevealConstraintsMode { get; set; }
Public Property RevealConstraintsMode As Boolean
    Get
    Set
public:
property bool RevealConstraintsMode {
    bool get ();
    void set (bool value);
}
member RevealConstraintsMode : bool with get, set

Property Value

Boolean
Exceptions
Exception | Condition
InvalidOperationException | When setting this property: View has a view type that does not allow Reveal Constraints mode to be activated.
See Also

Reference

View Class


View.RightDirection Property

ViewRightDirection Property

The direction towards the right side of the screen.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ RightDirection { get; }
Public ReadOnly Property RightDirection As XYZ
    Get
public:
property XYZ^ RightDirection {
    XYZ^ get ();
}
member RightDirection : XYZ with get

Property Value

XYZ
See Also

Reference

View Class


View.Scale Property

ViewScale Property

The scale of the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Scale { get; set; }
Public Property Scale As Integer
    Get
    Set
public:
property int Scale {
    int get ();
    void set (int value);
}
member Scale : int with get, set

Property Value

Int32
Remarks
The scale is the ratio of true model size to paper size. This property is meaningless for perspective views. When setting the scale if the scale corresponds to a predefined scale, the predefined item will be applied. Otherwise, a custom scale will be applied.
See Also

Reference

View Class


View.ShadowIntensity Property

ViewShadowIntensity Property

The intesity of cast shadows - 0 = no shadows, 100 = black.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ShadowIntensity { get; set; }
Public Property ShadowIntensity As Integer
    Get
    Set
public:
property int ShadowIntensity {
    int get ();
    void set (int value);
}
member ShadowIntensity : int with get, set

Property Value

Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The value is invalid. The valid range is 0 through 100
InvalidOperationException | When setting this property: This view does not contain display-related properties.
See Also

Reference

View Class


View.SketchPlane Property

ViewSketchPlane Property

The sketch plane assigned to the view for model curve creation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SketchPlane SketchPlane { get; set; }
Public Property SketchPlane As SketchPlane
    Get
    Set
public:
property SketchPlane^ SketchPlane {
    SketchPlane^ get ();
    void set (SketchPlane^ value);
}
member SketchPlane : SketchPlane with get, set

Property Value

SketchPlane
The sketch plane, or for views which don't allow sketching (such as schedules) or for views that allow model curve creation but have no current sketch plane assigned.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when setting the property to .
ArgumentException | Thrown when setting the property to a sketch plane that cannot be used to create model elements, or when the input sketch plane is orthogonal to the view orientation.
InvalidOperationException | Thrown when setting the property to a view that does not permit model curve creation, or when other errors occur.
Remarks
If this property is set in when the current work plane is visible, the updated work plane will not be shown until the current transaction is committed. Therefore it is recommended the Add-On commits the transaction before performing UI operations (for example, PickPoint).
See Also

Reference

View Class


View.SunAndShadowSettings Property

ViewSunAndShadowSettings Property

The sun and shadow settings assigned to the view for shadow calculation and rendering.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SunAndShadowSettings SunAndShadowSettings { get; }
Public ReadOnly Property SunAndShadowSettings As SunAndShadowSettings
    Get
public:
property SunAndShadowSettings^ SunAndShadowSettings {
    SunAndShadowSettings^ get ();
}
member SunAndShadowSettings : SunAndShadowSettings with get

Property Value

SunAndShadowSettings
The sun and shadow settings, or null for views which don't allow this (such as schedules).
See Also

Reference

View Class


View.SunlightIntensity Property

ViewSunlightIntensity Property

The intensity of the simulated (directional) sunlight. 0 = no directional light; maximum value is 100.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int SunlightIntensity { get; set; }
Public Property SunlightIntensity As Integer
    Get
    Set
public:
property int SunlightIntensity {
    int get ();
    void set (int value);
}
member SunlightIntensity : int with get, set

Property Value

Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The value is invalid. The valid range is 0 through 100
InvalidOperationException | When setting this property: This view does not contain display-related properties.
See Also

Reference

View Class


View.TemporaryViewModes Property

ViewTemporaryViewModes Property

Data of temporary view modes associated with this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TemporaryViewModes TemporaryViewModes { get; }
Public ReadOnly Property TemporaryViewModes As TemporaryViewModes
    Get
public:
property TemporaryViewModes^ TemporaryViewModes {
    TemporaryViewModes^ get ();
}
member TemporaryViewModes : TemporaryViewModes with get

Property Value

TemporaryViewModes
Remarks
Temporary view modes are available in graphic views only.
See Also

Reference

View Class


View.Title Property

ViewTitle Property

The view title. This consists of the view name plus other modifiers, such as the view type, sheet number, area scheme, and/or assembly type, depending on the specifics of the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Title { get; }
Public ReadOnly Property Title As String
    Get
public:
property String^ Title {
    String^ get ();
}
member Title : string with get

Property Value

String
See Also

Reference

View Class


View.UpDirection Property

ViewUpDirection Property

The direction towards the top of the screen.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ UpDirection { get; }
Public ReadOnly Property UpDirection As XYZ
    Get
public:
property XYZ^ UpDirection {
    XYZ^ get ();
}
member UpDirection : XYZ with get

Property Value

XYZ
See Also

Reference

View Class


View.ViewDirection Property

ViewViewDirection Property

The direction towards the viewer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ ViewDirection { get; }
Public ReadOnly Property ViewDirection As XYZ
    Get
public:
property XYZ^ ViewDirection {
    XYZ^ get ();
}
member ViewDirection : XYZ with get

Property Value

XYZ
Remarks
In orthographic views, all objects are projected onto the screen along this direction. In perspective views, the view target point is projected along this direction, but other points are projected towards the eye along different vectors.
See Also

Reference

View Class


View.ViewTemplateId Property

ViewViewTemplateId Property

The id of the template view that controls this view's parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId ViewTemplateId { get; set; }
Public Property ViewTemplateId As ElementId
    Get
    Set
public:
property ElementId^ ViewTemplateId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member ViewTemplateId : ElementId with get, set

Property Value

ElementId
The id of the template view that controls this view's parameters. InvalidElementId if there is no template set for this view.
Exceptions
Exception | Condition
ArgumentException | When setting this property: val is not valid as a view template id for this view.
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
Parameters controlled by the template cannot be changed directly in this view. Any change to controlled parameters in the template will cause change of the corresponding parameters in this view. Use GetTemplateParameterIds on the template view to get a list of all template parameters. Use GetNonControlledTemplateParameterIds on the template view to get parameters that are not controlled by the template.
See Also

Reference

View Class


View.ViewType Property

ViewViewType Property

The type of the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ViewType ViewType { get; }
Public ReadOnly Property ViewType As ViewType
    Get
public:
property ViewType ViewType {
    ViewType get ();
}
member ViewType : ViewType with get

Property Value

ViewType
Example
C#
VB
C++
F#
Copy
public void GetViewType(Autodesk.Revit.DB.View view)
{
    // Get the view type of the given view, and format the prompt string
    String prompt = "The view is ";

    switch (view.ViewType)
    {
        case ViewType.AreaPlan:
            prompt += "an area view.";
            break;
        case ViewType.CeilingPlan:
            prompt += "a reflected ceiling plan view.";
            break;
        case ViewType.ColumnSchedule:
            prompt += "a column schedule view.";
            break;
        case ViewType.CostReport:
            prompt += "a cost report view.";
            break;
        case ViewType.Detail:
            prompt += "a detail view.";
            break;
        case ViewType.DraftingView:
            prompt += "a drafting view.";
            break;
        case ViewType.DrawingSheet:
            prompt += "a drawing sheet view.";
            break;
        case ViewType.Elevation:
            prompt += "an elevation view.";
            break;
        case ViewType.EngineeringPlan:
            prompt += "an engineering view.";
            break;
        case ViewType.FloorPlan:
            prompt += "afloor plan view.";
            break;
        case ViewType.Internal:
            prompt += "Revit's internal view.";
            break;
        case ViewType.Legend:
            prompt += "a legend view.";
            break;
        case ViewType.LoadsReport:
            prompt += "a loads report view.";
            break;
        case ViewType.PanelSchedule:
            prompt += "a panel schedule view.";
            break;
        case ViewType.PresureLossReport:
            prompt += "a pressure loss report view.";
            break;
        case ViewType.Rendering:
            prompt += "a rendering view.";
            break;
        case ViewType.Report:
            prompt += "a report view.";
            break;
        case ViewType.Schedule:
            prompt += "a schedule view.";
            break;
        case ViewType.Section:
            prompt += "a cross section view.";
            break;
        case ViewType.ThreeD:
            prompt += "a 3-D view.";
            break;
        case ViewType.Undefined:
            prompt += "an undefined/unspecified view.";
            break;
        case ViewType.Walkthrough:
            prompt += "a walkthrough view.";
            break;
        default:
            break;
    }

    // Give the user some information
    TaskDialog.Show("Revit",prompt);
}
Public Sub GetViewType(view As Autodesk.Revit.DB.View)
    ' Get the view type of the given view, and format the prompt string
    Dim prompt As [String] = "The view is "

    Select Case view.ViewType
        Case ViewType.AreaPlan
            prompt += "an area view."
            Exit Select
        Case ViewType.CeilingPlan
            prompt += "a reflected ceiling plan view."
            Exit Select
        Case ViewType.ColumnSchedule
            prompt += "a column schedule view."
            Exit Select
        Case ViewType.CostReport
            prompt += "a cost report view."
            Exit Select
        Case ViewType.Detail
            prompt += "a detail view."
            Exit Select
        Case ViewType.DraftingView
            prompt += "a drafting view."
            Exit Select
        Case ViewType.DrawingSheet
            prompt += "a drawing sheet view."
            Exit Select
        Case ViewType.Elevation
            prompt += "an elevation view."
            Exit Select
        Case ViewType.EngineeringPlan
            prompt += "an engineering view."
            Exit Select
        Case ViewType.FloorPlan
            prompt += "afloor plan view."
            Exit Select
        Case ViewType.Internal
            prompt += "Revit's internal view."
            Exit Select
        Case ViewType.Legend
            prompt += "a legend view."
            Exit Select
        Case ViewType.LoadsReport
            prompt += "a loads report view."
            Exit Select
        Case ViewType.PanelSchedule
            prompt += "a panel schedule view."
            Exit Select
        Case ViewType.PresureLossReport
            prompt += "a pressure loss report view."
            Exit Select
        Case ViewType.Rendering
            prompt += "a rendering view."
            Exit Select
        Case ViewType.Report
            prompt += "a report view."
            Exit Select
        Case ViewType.Schedule
            prompt += "a schedule view."
            Exit Select
        Case ViewType.Section
            prompt += "a cross section view."
            Exit Select
        Case ViewType.ThreeD
            prompt += "a 3-D view."
            Exit Select
        Case ViewType.Undefined
            prompt += "an undefined/unspecified view."
            Exit Select
        Case ViewType.Walkthrough
            prompt += "a walkthrough view."
            Exit Select
        Case Else
            Exit Select
    End Select

    ' Give the user some information
    TaskDialog.Show("Revit", prompt)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

View Class


View Methods

The View type exposes the following members.

Methods
 | Name | Description
Public method | AddFilter | Adds a filter to the view.
Public method | AllowsAnalysisDisplay | Identifies if this view allows display of Analysis results.
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of the input view that are not controlled by the current view template.
Public method | AreGraphicsOverridesAllowed | Determines if Visibility/Graphics Overriddes can be applied to the view.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanApplyColorFillScheme | Checks if the id can be applied as the scheme id of specified category to this view.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanCategoryBeHidden | Checks whether the category can be hidden in the view.
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view.
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanEnableTemporaryViewPropertiesMode | Indicates if Temporary View Properties mode can be applied for view in current state.
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified.
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified.
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified
Public method | CanUseDepthCueing | Indicates if view can use Depth Cueing
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes
Public method | CanViewBeDuplicated | Identifies if this view can be duplicated.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view.
 | ConvertToIndependent | Convert the dependent view to independent.
Public method | CreateViewTemplate | Creates a new view template instance from this view instance.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode.
Public method | Dispose | (Inherited from Element)
 | Duplicate | Duplicates this view.
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode.
Public method | EnableTemporaryViewPropertiesMode | Turns Temporary View Properties mode on or off. In this mode, any changes made to the view are temporary and will be discarded once the mode is disabled.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetBackground | Returns the current background set for the view.
Public method | GetCalloutParentId | Gets ID of the callout parent view.
Public method | GetCategoryHidden | Checks if elements of the given category are set to be invisible (hidden) in this view.
Public method | GetCategoryOverrides | Gets graphic overrides for a category in view.
Public method | GetColorFillSchemeId | Returns id of the color fill scheme element applied to the view.
Public method | GetCropRegionShapeManager | Returns an object for managing view crop region shape.
 | GetCropRegionShapeManagerForReferenceCallout | Returns an object for managing view crop region shape for reference callout.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetDependentViewIds | Get the ids of dependent views.
Public method | GetDepthCueing | Returns the current depth cueing settings for the view.
Public method | GetDirectContext3DHandleOverrides | Returns DirectContext3D handle overrides object for the view.
Public method | GetElementOverrides | Gets graphic overrides for an element in the view.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFilterOverrides | Gets graphic overrides that a filter applies to the view.
Public method | GetFilters | Gets the filters applied to the view.
Public method | GetFilterVisibility | Gets the visibility of the elements associated with a filter.
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIsFilterEnabled | Identifies if the filter is enabled in this view.
 | GetLinkOverrides | Gets the graphic overrides of a RevitLinkType or RevitLinkInstance in view.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetModelToProjectionTransforms | Gets the transforms from the model space to the view projection space.
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetNonControlledTemplateParameterIds | Returns a list of parameters that are not marked as included when this view is used as a template.
Public method | GetOrderedFilters | Gets the filters applied to the view in the order they are applied.
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPlacementOnSheetStatus | Determines if this view placed on a sheet completely or partially.
Public method | GetPointCloudOverrides | Returns point cloud overrides object for the view.
Public method | GetPrimaryViewId | Get the id of the primary view.
Public method | GetReferenceCallouts | Returns element ids of all reference callouts in the view.
Public method | GetReferenceElevations | Returns element ids of all reference elevations in the view.
Public method | GetReferenceSections | Returns element ids of all reference sections in the view.
Public method | GetSketchyLines | Returns the current sketchy lines settings for the view.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTemplateParameterIds | Returns a list of parameter ids that may be controlled when this view is assigned as a template.
Public method | GetTemporaryViewPropertiesId | When Temporary View Properties mode is in progress it provides view id that overrode settings for current view. Outside Temporary View Properties mode InvalidElementId will be returned.
Public method | GetTemporaryViewPropertiesName | When Temporary View Properties mode is in progress, name of applied template is returned. Outside Temporary View Properties mode, empty string will be returned.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetViewDisplayModel | Returns the current view display model settings for the view.
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view.
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view.
Public method | HasDetailLevel | Check if the view has a Detail Level property
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property
Public method | HasViewTransforms | Returns true if the view reports model space to view projection space transforms.
Public method | HideActiveWorkPlane | Hide the active work plane of the view.
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view.
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view.
Public method | HideElements | Sets the elements to be hidden in the view.
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input.
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input.
Public method | IsCategoryOverridable | Checks whether the category can have graphic overrides in this view.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsFilterApplied | Indicates if a filter is applied to the view.
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view.
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view.
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input.
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories.
Public method | IsTemporaryViewPropertiesModeEnabled | Returns true when Temporary View Properties mode is in progress, false otherwise.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
 | IsValidViewScale | This validator checks that the view scale is in the allowable range.
Public method | IsValidViewTemplate | Verifies that the view represented by templateId can be set as the controlling view template for this view.
Public method | IsViewValidForTemplateCreation | Verifies that the view is valid for template creation.
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | Print | Print this view with the default view template and using the print setting of the current active document.
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document.
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document.
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document.
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveCalloutParent | Replaces callout parent ID with InvalidElementId.
Public method | RemoveFilter | Removes a filter from the view.
 | RemoveLinkOverrides | Deletes the graphical link overrides in the current view.
Public method | RestoreCalloutParent | Restores callout parent ID to the original view ID if that view is still available.
Public method | SetBackground | Sets the background for the view. Background can only be set for 3d views and for Sections/Elevations.
Public method | SetCategoryHidden | Sets if elements of the given category will be visible in this view.
Public method | SetCategoryOverrides | Sets graphic overrides for a category in view.
Public method | SetColorFillSchemeId | Applies color fill scheme to this view.
Public method | SetDepthCueing | Sets the depth cueing settings for the view.
Public method | SetElementOverrides | Sets graphic overrides for an element in the view.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
 | SetFilterOverrides | Sets the overrides associated with a filter.
Public method | SetFilterVisibility | Sets the visibility of the elements associated with a filter.
Public method | SetIsFilterEnabled | Sets the filter enabled flag.
 | SetLinkOverrides | Sets the graphic overrides of a RevitLinkType or RevitLinkInstance in the view.
Public method | SetNonControlledTemplateParameterIds | Sets the parameters that will not be included when this view is used as a template.
Public method | SetSketchyLines | Sets the sketchy lines settings for the view.
Public method | SetViewDisplayModel | Sets the view display model settings for the view.
Public method | SetWorksetVisibility | Sets visibility for a workset in this view.
 | SetWorksharingDisplayMode | Sets the worksharing display mode for this view.
Public method | ShowActiveWorkPlane | Show the active work plane of the view.
Public method | SupportedColorFillCategoryIds | Returns collection of all category ids that correspond to elements that can potentially be colored in this view according to a color fill scheme. The set may be different depending on the view type.
Public method | SupportsRevealConstraints | Checks that the view can have the Reveal Constraints mode activated.
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden.
Top
See Also

Reference

View Class


View.AddFilter Method

ViewAddFilter Method

Adds a filter to the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddFilter(
    ElementId filterElementId
)
Public Sub AddFilter (
    filterElementId As ElementId
)
public:
void AddFilter(
    ElementId^ filterElementId
)
member AddFilter :
        filterElementId : ElementId -> unit

Parameters

filterElementId ElementId
ElementId of the filter.
Exceptions
Exception | Condition
ArgumentException | ElementId is not associated with a FilterElement. -or- Filter is already applied to the view.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The element "this View" does not belong to a project document. -or- The view type does not support Visibility/Graphics Overriddes.
Remarks
The filter will be added with default overrides, which means that there will be no change in the view's display. The filter is appended as the last filter in the order of filters applied to this view.
See Also

Reference

View Class


View.AllowsAnalysisDisplay Method

ViewAllowsAnalysisDisplay Method

Identifies if this view allows display of Analysis results.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AllowsAnalysisDisplay()
Public Function AllowsAnalysisDisplay As Boolean
public:
bool AllowsAnalysisDisplay()
member AllowsAnalysisDisplay : unit -> bool

Return Value

Boolean
True if the view allows display of Analysis results, false otherwise.
See Also

Reference

View Class


View.ApplyViewTemplateParameters Method

ViewApplyViewTemplateParameters Method

Applies to this view the parameters of the input view that are not controlled by the current view template.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ApplyViewTemplateParameters(
    View otherView
)
Public Sub ApplyViewTemplateParameters (
    otherView As View
)
public:
void ApplyViewTemplateParameters(
    View^ otherView
)
member ApplyViewTemplateParameters :
        otherView : View -> unit

Parameters

otherView View
The view whose parameters are to be applied to this view. It does not have to be a valid template (property IsTemplate can be true or false).
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Apply the view template parameters is a one-time operation, the association between the views is not preserved. To get all template parameters call GetTemplateParameterIds on the template. To get parameters that are not controlled by the template call GetNonControlledTemplateParameterIds on the template. To get current view template of this view use property ViewTemplateId.
See Also

Reference

View Class


View.AreGraphicsOverridesAllowed Method

ViewAreGraphicsOverridesAllowed Method

Determines if Visibility/Graphics Overriddes can be applied to the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AreGraphicsOverridesAllowed()
Public Function AreGraphicsOverridesAllowed As Boolean
public:
bool AreGraphicsOverridesAllowed()
member AreGraphicsOverridesAllowed : unit -> bool

Return Value

Boolean
True if Overriddes can be applied to the view, false otherwise.
See Also

Reference

View Class


View.CanApplyColorFillScheme Method

ViewCanApplyColorFillScheme Method

Checks if the id can be applied as the scheme id of specified category to this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanApplyColorFillScheme(
    ElementId categoryId,
    ElementId schemeId
)
Public Function CanApplyColorFillScheme (
    categoryId As ElementId,
    schemeId As ElementId
) As Boolean
public:
bool CanApplyColorFillScheme(
    ElementId^ categoryId,
    ElementId^ schemeId
)
member CanApplyColorFillScheme :
        categoryId : ElementId *
        schemeId : ElementId -> bool

Parameters

categoryId ElementId
The id of category.
schemeId ElementId
The id of color fill scheme.

Return Value

Boolean
True if the id can be applied as the scheme id of specified category in this view, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks

The input scheme id could be InvalidElementId to clear the scheme for the specified category.

Some examples of returnning false:

  • The id is not a color fill scheme id.
  • The specified category is not supported by this view.
  • The category of scheme is not the same as the specified category.
  • The view is area plan but the scheme category is not OST_Areas, or their [!:Autodesk::Revit::DB::AreaScheme] are not the same.
  • Etc.
See Also

Reference

View Class


View.CanCategoryBeHidden Method

ViewCanCategoryBeHidden Method

Checks whether the category can be hidden in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanCategoryBeHidden(
    ElementId elementId
)
Public Function CanCategoryBeHidden (
    elementId As ElementId
) As Boolean
public:
bool CanCategoryBeHidden(
    ElementId^ elementId
)
member CanCategoryBeHidden :
        elementId : ElementId -> bool

Parameters

elementId ElementId
ElementId of the category.

Return Value

Boolean
True if the category can be hidden, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Categories can be allowed to be hidden in some view types and prohibited from being hidden in others. E.g., categories cannot be hidden in ProjectBrowser
See Also

Reference

View Class


View.CanCategoryBeHiddenTemporary Method

ViewCanCategoryBeHiddenTemporary Method

Check if category can be temporarily hidden in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanCategoryBeHiddenTemporary(
    ElementId elementId
)
Public Function CanCategoryBeHiddenTemporary (
    elementId As ElementId
) As Boolean
public:
bool CanCategoryBeHiddenTemporary(
    ElementId^ elementId
)
member CanCategoryBeHiddenTemporary :
        elementId : ElementId -> bool

Parameters

elementId ElementId
Id of the category to be checked

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

View Class


View.CanEnableTemporaryViewPropertiesMode Method

ViewCanEnableTemporaryViewPropertiesMode Method

Indicates if Temporary View Properties mode can be applied for view in current state.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanEnableTemporaryViewPropertiesMode()
Public Function CanEnableTemporaryViewPropertiesMode As Boolean
public:
bool CanEnableTemporaryViewPropertiesMode()
member CanEnableTemporaryViewPropertiesMode : unit -> bool

Return Value

Boolean
True if view can use Temporary View Properties mode in current state.
See Also

Reference

View Class


View.CanModifyDetailLevel Method

ViewCanModifyDetailLevel Method

Check if Detail Level can be modified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanModifyDetailLevel()
Public Function CanModifyDetailLevel As Boolean
public:
bool CanModifyDetailLevel()
member CanModifyDetailLevel : unit -> bool

Return Value

Boolean
True if Detail Level can be modified.
See Also

Reference

View Class


View.CanModifyDisplayStyle Method

ViewCanModifyDisplayStyle Method

Indicates if DisplayStyle can be modified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanModifyDisplayStyle()
Public Function CanModifyDisplayStyle As Boolean
public:
bool CanModifyDisplayStyle()
member CanModifyDisplayStyle : unit -> bool

Return Value

Boolean
True if DisplayStyle can be modified.
See Also

Reference

View Class


View.CanModifyViewDiscipline Method

ViewCanModifyViewDiscipline Method

Indicates if the View Discipline can be modified

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanModifyViewDiscipline()
Public Function CanModifyViewDiscipline As Boolean
public:
bool CanModifyViewDiscipline()
member CanModifyViewDiscipline : unit -> bool

Return Value

Boolean
True if View Discipline can be modified
See Also

Reference

View Class


View.CanUseDepthCueing Method

ViewCanUseDepthCueing Method

Indicates if view can use Depth Cueing

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanUseDepthCueing()
Public Function CanUseDepthCueing As Boolean
public:
bool CanUseDepthCueing()
member CanUseDepthCueing : unit -> bool

Return Value

Boolean
True if view can use Depth Cueing
See Also

Reference

View Class


View.CanUseTemporaryVisibilityModes Method

ViewCanUseTemporaryVisibilityModes Method

Indicates if view can use temporary visibility modes

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanUseTemporaryVisibilityModes()
Public Function CanUseTemporaryVisibilityModes As Boolean
public:
bool CanUseTemporaryVisibilityModes()
member CanUseTemporaryVisibilityModes : unit -> bool

Return Value

Boolean
True if view can use temporary visibility modes
See Also

Reference

View Class


View.CanViewBeDuplicated Method

ViewCanViewBeDuplicated Method

Identifies if this view can be duplicated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanViewBeDuplicated(
    ViewDuplicateOption duplicateOption
)
Public Function CanViewBeDuplicated (
    duplicateOption As ViewDuplicateOption
) As Boolean
public:
bool CanViewBeDuplicated(
    ViewDuplicateOption duplicateOption
)
member CanViewBeDuplicated :
        duplicateOption : ViewDuplicateOption -> bool

Parameters

duplicateOption ViewDuplicateOption
The option to use when duplicating the view.

Return Value

Boolean
True if the view can be duplicated, false otherwise.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

View Class


View.ConvertTemporaryHideIsolateToPermanent Method

ViewConvertTemporaryHideIsolateToPermanent Method

Convert all temporary hidden elements or categories to permanently hidden in view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ConvertTemporaryHideIsolateToPermanent()
Public Sub ConvertTemporaryHideIsolateToPermanent
public:
void ConvertTemporaryHideIsolateToPermanent()
member ConvertTemporaryHideIsolateToPermanent : unit -> unit
Exceptions
Exception | Condition
InvalidOperationException | The element "this View" does not belong to a project document.
ModificationForbiddenException | This View is an internal element, such as a component of a loaded family or a group type. -or- The document containing this View is in Group Edit Mode, Sketch Edit Mode, or Paste Mode, and the element is not a member of the group, sketch, or clipboard. -or- This View is a member of a group or sketch, and the document is not currently editing the group or sketch.
See Also

Reference

View Class


View.ConvertToIndependent Method

ViewConvertToIndependent Method

Convert the dependent view to independent.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ConvertToIndependent()
Public Sub ConvertToIndependent
public:
void ConvertToIndependent()
member ConvertToIndependent : unit -> unit
Exceptions
Exception | Condition
InvalidOperationException | This view is not dependent.
Remarks
This method can be only applied to a dependent view. A dependent view can be created from another view using method View.Duplicate(ViewDuplicateOption.AsDependent). Dependent views have a valid primary view element ID that can be obtained via method View.GetPrimaryViewId(); Independent views have InvalidElementId as their primary view ID.
Example
C#
VB
C++
F#
Copy
public void MakeViewIndependent(View view)
{
    // Independent views will have an InvalidElementId for the Primary View Id
    if (view.GetPrimaryViewId() != ElementId.InvalidElementId)
    {
        view.ConvertToIndependent();
    }
}
Public Sub MakeViewIndependent(view As View)
    ' Independent views will have an InvalidElementId for the Primary View Id
    If view.GetPrimaryViewId() <> ElementId.InvalidElementId Then
        view.ConvertToIndependent()
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

View Class


View.CreateViewTemplate Method

ViewCreateViewTemplate Method

Creates a new view template instance from this view instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public View CreateViewTemplate()
Public Function CreateViewTemplate As View
public:
View^ CreateViewTemplate()
member CreateViewTemplate : unit -> View

Return Value

View
New view template instance
Exceptions
Exception | Condition
InvalidOperationException | The view is not valid for view template creation.
See Also

Reference

View Class


View.DisableTemporaryViewMode Method

ViewDisableTemporaryViewMode Method

Disables the specified temporary view mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void DisableTemporaryViewMode(
    TemporaryViewMode mode
)
Public Sub DisableTemporaryViewMode (
    mode As TemporaryViewMode
)
public:
void DisableTemporaryViewMode(
    TemporaryViewMode mode
)
member DisableTemporaryViewMode :
        mode : TemporaryViewMode -> unit

Parameters

mode TemporaryViewMode
The mode to disable.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | View cannot use temporary visibility modes.
Remarks
Has no effect if the mode is already disabled.
See Also

Reference

View Class


View.Duplicate Method

ViewDuplicate Method

Duplicates this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId Duplicate(
    ViewDuplicateOption duplicateOption
)
Public Function Duplicate (
    duplicateOption As ViewDuplicateOption
) As ElementId
public:
ElementId^ Duplicate(
    ViewDuplicateOption duplicateOption
)
member Duplicate :
        duplicateOption : ViewDuplicateOption -> ElementId

Parameters

duplicateOption ViewDuplicateOption
The option to use when duplicating the view.

Return Value

ElementId
The id of the newly created view.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | View cannot be duplicated
Example
C#
VB
C++
F#
Copy
public View CreateDependentCopy(View view)
{
    View dependentView = null;
    ElementId newViewId = ElementId.InvalidElementId;
    if (view.CanViewBeDuplicated(ViewDuplicateOption.AsDependent))
    {
        newViewId = view.Duplicate(ViewDuplicateOption.AsDependent);
        dependentView = view.Document.GetElement(newViewId) as View;
        if (null != dependentView)
        {
            if (dependentView.GetPrimaryViewId() == view.Id)
            {
                TaskDialog.Show("Dependent View", "Dependent view created successfully!");
            }
        }
    }

    return dependentView;
}
Public Function CreateDependentCopy(view As View) As View
    Dim dependentView As View = Nothing
    Dim newViewId As ElementId = ElementId.InvalidElementId
    If view.CanViewBeDuplicated(ViewDuplicateOption.AsDependent) Then
        newViewId = view.Duplicate(ViewDuplicateOption.AsDependent)
        dependentView = TryCast(view.Document.GetElement(newViewId), View)
        If dependentView IsNot Nothing Then
            If dependentView.GetPrimaryViewId() = view.Id Then
                TaskDialog.Show("Dependent View", "Dependent view created successfully!")
            End If
        End If
    End If

    Return dependentView
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

View Class


View.EnableRevealHiddenMode Method

ViewEnableRevealHiddenMode Method

Enables Reveal Hidden elements mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void EnableRevealHiddenMode()
Public Sub EnableRevealHiddenMode
public:
void EnableRevealHiddenMode()
member EnableRevealHiddenMode : unit -> unit
Exceptions
Exception | Condition
InvalidOperationException | View cannot use temporary visibility modes.
See Also

Reference

View Class


View.EnableTemporaryViewPropertiesMode Method

ViewEnableTemporaryViewPropertiesMode Method

Turns Temporary View Properties mode on or off. In this mode, any changes made to the view are temporary and will be discarded once the mode is disabled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool EnableTemporaryViewPropertiesMode(
    ElementId viewTemplateId
)
Public Function EnableTemporaryViewPropertiesMode (
    viewTemplateId As ElementId
) As Boolean
public:
bool EnableTemporaryViewPropertiesMode(
    ElementId^ viewTemplateId
)
member EnableTemporaryViewPropertiesMode :
        viewTemplateId : ElementId -> bool

Parameters

viewTemplateId ElementId
If the id of a view template is provided, Temporary View Properties mode is turned on and the settings from the template are applied to the view for the duration of the mode. If the id provided is not that of a template but the id of the view itself, Temporary View Properties mode is turned on without any changes to the view. If ElementId.InvalidElementId is provided, Temporary View Properties mode is turned off.

Return Value

Boolean
Returns true when the view template provided by viewTemplateId was applied and Temporary View Properties was successfully turned on. Also returns true if ElementId.InvalidElementId was provided as input and Temporary View Properties was successfully turned off.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | View cannot use Temporary View Properties mode in current state.
See Also

Reference

View Class


View.GetBackground Method

ViewGetBackground Method

Returns the current background set for the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ViewDisplayBackground GetBackground()
Public Function GetBackground As ViewDisplayBackground
public:
ViewDisplayBackground^ GetBackground()
member GetBackground : unit -> ViewDisplayBackground

Return Value

ViewDisplayBackground
Current background.
See Also

Reference

View Class


View.GetCalloutParentId Method

ViewGetCalloutParentId Method

Gets ID of the callout parent view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GetCalloutParentId()
Public Function GetCalloutParentId As ElementId
public:
ElementId^ GetCalloutParentId()
member GetCalloutParentId : unit -> ElementId

Return Value

ElementId
ID of a view in which this callout was created or InvalidElementId if there is no parent.
Exceptions
Exception | Condition
InvalidOperationException | This view is not a callout.
See Also

Reference

View Class


View.GetCategoryHidden Method

ViewGetCategoryHidden Method

Checks if elements of the given category are set to be invisible (hidden) in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool GetCategoryHidden(
    ElementId categoryId
)
Public Function GetCategoryHidden (
    categoryId As ElementId
) As Boolean
public:
bool GetCategoryHidden(
    ElementId^ categoryId
)
member GetCategoryHidden :
        categoryId : ElementId -> bool

Parameters

categoryId ElementId
The ID of the category.

Return Value

Boolean
True if the category is invisible (hidden), false otherwise.
Exceptions
Exception | Condition
ArgumentException | categoryId does not correspond to a Category.
ArgumentNullException | A non-optional argument was null
Remarks
This checks only if the category is set visible or invisible individually. Other Revit mechanisms may also affect the visibility of elements of this category, including:
  • The category classes settings for model categories, annotation categories, import categories or analytical model categories.
  • View filters.
  • Elements hidden individually in the view.
Thus the return value may not reflect the actual visibility of elements of this category in the view.
See Also

Reference

View Class


View.GetCategoryOverrides Method

ViewGetCategoryOverrides Method

Gets graphic overrides for a category in view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OverrideGraphicSettings GetCategoryOverrides(
    ElementId categoryId
)
Public Function GetCategoryOverrides (
    categoryId As ElementId
) As OverrideGraphicSettings
public:
OverrideGraphicSettings^ GetCategoryOverrides(
    ElementId^ categoryId
)
member GetCategoryOverrides :
        categoryId : ElementId -> OverrideGraphicSettings

Parameters

categoryId ElementId
Category to be checked.

Return Value

OverrideGraphicSettings
Object representing all graphic overrides of the category categoryId in view. A default OverrideGraphicSettings object will be returned if it not previously been set for this view.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The view type does not support Visibility/Graphics Overriddes.
See Also

Reference

View Class


View.GetColorFillSchemeId Method

ViewGetColorFillSchemeId Method

Returns id of the color fill scheme element applied to the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GetColorFillSchemeId(
    ElementId categoryId
)
Public Function GetColorFillSchemeId (
    categoryId As ElementId
) As ElementId
public:
ElementId^ GetColorFillSchemeId(
    ElementId^ categoryId
)
member GetColorFillSchemeId :
        categoryId : ElementId -> ElementId

Parameters

categoryId ElementId
The id of the category which the color fill scheme element belongs to.

Return Value

ElementId
The id of the color fill scheme element.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

View Class


View.GetCropRegionShapeManager Method

ViewGetCropRegionShapeManager Method

Returns an object for managing view crop region shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ViewCropRegionShapeManager GetCropRegionShapeManager()
Public Function GetCropRegionShapeManager As ViewCropRegionShapeManager
public:
ViewCropRegionShapeManager^ GetCropRegionShapeManager()
member GetCropRegionShapeManager : unit -> ViewCropRegionShapeManager

Return Value

ViewCropRegionShapeManager
The crop region shape manager.
See Also

Reference

View Class


View.GetCropRegionShapeManagerForReferenceCallout Method

ViewGetCropRegionShapeManagerForReferenceCallout Method

Returns an object for managing view crop region shape for reference callout.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ViewCropRegionShapeManager GetCropRegionShapeManagerForReferenceCallout(
    Document doc,
    ElementId callout
)
Public Shared Function GetCropRegionShapeManagerForReferenceCallout (
    doc As Document,
    callout As ElementId
) As ViewCropRegionShapeManager
public:
static ViewCropRegionShapeManager^ GetCropRegionShapeManagerForReferenceCallout(
    Document^ doc,
    ElementId^ callout
)
static member GetCropRegionShapeManagerForReferenceCallout :
        doc : Document *
        callout : ElementId -> ViewCropRegionShapeManager

Parameters

doc Document
Document to which the callout belongs.
callout ElementId
Element id of reference callout.

Return Value

ViewCropRegionShapeManager
The crop region shape manager.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Reference callout is a view-specific element referencing another view. It can have its own crop region shape which doesn't affect the referenced view.
See Also

Reference

View Class


View.GetDependentViewIds Method

ViewGetDependentViewIds Method

Get the ids of dependent views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetDependentViewIds()
Public Function GetDependentViewIds As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetDependentViewIds()
member GetDependentViewIds : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
Ids of the dependent views.
See Also

Reference

View Class


View.GetDepthCueing Method

ViewGetDepthCueing Method

Returns the current depth cueing settings for the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ViewDisplayDepthCueing GetDepthCueing()
Public Function GetDepthCueing As ViewDisplayDepthCueing
public:
ViewDisplayDepthCueing^ GetDepthCueing()
member GetDepthCueing : unit -> ViewDisplayDepthCueing

Return Value

ViewDisplayDepthCueing
Current depth cueing settings.
Exceptions
Exception | Condition
InvalidOperationException | This view cannot use Depth Cueing
See Also

Reference

View Class


View.GetDirectContext3DHandleOverrides Method

ViewGetDirectContext3DHandleOverrides Method

Returns DirectContext3D handle overrides object for the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DirectContext3DHandleOverrides GetDirectContext3DHandleOverrides()
Public Function GetDirectContext3DHandleOverrides As DirectContext3DHandleOverrides
public:
DirectContext3DHandleOverrides^ GetDirectContext3DHandleOverrides()
member GetDirectContext3DHandleOverrides : unit -> DirectContext3DHandleOverrides

Return Value

DirectContext3DHandleOverrides
DirectContext3D handle overrides for the view
See Also

Reference

View Class


View.GetElementOverrides Method

ViewGetElementOverrides Method

Gets graphic overrides for an element in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OverrideGraphicSettings GetElementOverrides(
    ElementId elementId
)
Public Function GetElementOverrides (
    elementId As ElementId
) As OverrideGraphicSettings
public:
OverrideGraphicSettings^ GetElementOverrides(
    ElementId^ elementId
)
member GetElementOverrides :
        elementId : ElementId -> OverrideGraphicSettings

Parameters

elementId ElementId
The element.

Return Value

OverrideGraphicSettings
An object representing all graphic overrides of the element elementId in view.
Exceptions
Exception | Condition
ArgumentException | elementId is not a valid Element identifier.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The element "this View" does not belong to a project document. -or- The view type does not support Visibility/Graphics Overriddes.
See Also

Reference

View Class


View.GetFilterOverrides Method

ViewGetFilterOverrides Method

Gets graphic overrides that a filter applies to the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OverrideGraphicSettings GetFilterOverrides(
    ElementId filterElementId
)
Public Function GetFilterOverrides (
    filterElementId As ElementId
) As OverrideGraphicSettings
public:
OverrideGraphicSettings^ GetFilterOverrides(
    ElementId^ filterElementId
)
member GetFilterOverrides :
        filterElementId : ElementId -> OverrideGraphicSettings

Parameters

filterElementId ElementId
ElementId of the filter.

Return Value

OverrideGraphicSettings
Object representing all graphic overrides of the filter in the view.
Exceptions
Exception | Condition
ArgumentException | ElementId is not associated with a FilterElement. -or- Filter is not applied to the view.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The element "this View" does not belong to a project document. -or- The view type does not support Visibility/Graphics Overriddes.
See Also

Reference

View Class


View.GetFilters Method

ViewGetFilters Method

Gets the filters applied to the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetFilters()
Public Function GetFilters As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetFilters()
member GetFilters : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
The ElementIds of the Filters.
Exceptions
Exception | Condition
InvalidOperationException | The element "this View" does not belong to a project document. -or- The view type does not support Visibility/Graphics Overriddes.
Remarks
Note that this method returns filters in a set sorted according to their ids. To get filters in the order they are applied to the view use GetOrderedFilters.
See Also

Reference

View Class


View.GetFilterVisibility Method

ViewGetFilterVisibility Method

Gets the visibility of the elements associated with a filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool GetFilterVisibility(
    ElementId filterElementId
)
Public Function GetFilterVisibility (
    filterElementId As ElementId
) As Boolean
public:
bool GetFilterVisibility(
    ElementId^ filterElementId
)
member GetFilterVisibility :
        filterElementId : ElementId -> bool

Parameters

filterElementId ElementId
The ElementId of the filter.

Return Value

Boolean
True if the elements associated with the filter are visible in the view, false otherwise.
Exceptions
Exception | Condition
ArgumentException | Filter is not applied to the view. -or- ElementId is not associated with a FilterElement.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The element "this View" does not belong to a project document. -or- The view type does not support Visibility/Graphics Overriddes.
See Also

Reference

View Class


View.GetIsFilterEnabled Method

ViewGetIsFilterEnabled Method

Identifies if the filter is enabled in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool GetIsFilterEnabled(
    ElementId filterElementId
)
Public Function GetIsFilterEnabled (
    filterElementId As ElementId
) As Boolean
public:
bool GetIsFilterEnabled(
    ElementId^ filterElementId
)
member GetIsFilterEnabled :
        filterElementId : ElementId -> bool

Parameters

filterElementId ElementId
The ElementId of the filter.

Return Value

Boolean
True if the specified filter is enabled in this view, false otherwise.
Exceptions
Exception | Condition
ArgumentException | Filter is not applied to the view. -or- ElementId is not associated with a FilterElement.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The element "this View" does not belong to a project document. -or- The view type does not support Visibility/Graphics Overriddes.
Remarks
Several filters can be applied to a view in a certain order. This enable/disable flag allows one to quickly turn on/off the action of a particular filter in this view (without removing the filter from the set of applied filters and losing the corresponding overrides). By default, all the filters applied to a view are enabled.
See Also

Reference

View Class


View.GetLinkOverrides Method

ViewGetLinkOverrides Method

Gets the graphic overrides of a RevitLinkType or RevitLinkInstance in view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RevitLinkGraphicsSettings GetLinkOverrides(
    ElementId linkId
)
Public Function GetLinkOverrides (
    linkId As ElementId
) As RevitLinkGraphicsSettings
public:
RevitLinkGraphicsSettings^ GetLinkOverrides(
    ElementId^ linkId
)
member GetLinkOverrides :
        linkId : ElementId -> RevitLinkGraphicsSettings

Parameters

linkId ElementId
The id of the RevitLinkType or RevitLinkInstance.

Return Value

RevitLinkGraphicsSettings
Settings representing graphic overrides for the input element id in the view, or if the input id references RevitLinkInstance and it doesn't have overrides in the view.
Exceptions
Exception | Condition
ArgumentException | The input id is not a valid RevitLinkInstance or RevitLinkType id.
ArgumentNullException | A non-optional argument was null
Example
C#
Copy
public static void PrintLinkOverridesInView(View view)
{
    var ids = new FilteredElementCollector(view.Document)
                  .WhereElementIsElementType()
                  .OfType<RevitLinkType>()
                  .Select(link => link.Id)
                  .ToList();

    ids.AddRange(new FilteredElementCollector(view.Document)
                     .WhereElementIsNotElementType()
                     .OfType<RevitLinkInstance>()
                     .Select(link => link.Id)
                     .ToList());

    StringBuilder message = new StringBuilder();
    message.AppendLine("View: " + view.Id.ToString());
    foreach(ElementId id in ids)
    {
        message.AppendLine("Element Id in the view: " + id.ToString());

        RevitLinkGraphicsSettings settings = view.GetLinkOverrides(id);
        if (settings == null)
        {
            message.AppendLine("It doesn't have graphical overrides in the view.");
            continue;
        }

        message.AppendLine("    LinkVisibilityType " + settings.LinkVisibilityType);
        message.AppendLine("    LinkedView: " + settings.LinkedViewId.Value.ToString());
        message.AppendLine("    ViewFilterType: " + settings.ViewFilterType);
        message.AppendLine("    ViewRange: " + settings.ViewRange);
        message.AppendLine("    ColorFill: " + settings.ColorFill);
        message.AppendLine("    ObjectStyles: " + settings.ObjectStyles);
        message.AppendLine("    NestedLinks: " + settings.NestedLinks);

        message.AppendLine(string.Format("    Discipline has type {0} and value: {1}",
                                         settings.GetDisciplineType(), settings.GetDiscipline()));
        message.AppendLine(string.Format("    Phase has type {0} and value: {1}",
                                         settings.GetPhaseType(), settings.GetPhaseId().ToString()));
        message.AppendLine(string.Format("    PhaseFilter has type {0} and value: {1}",
                                         settings.GetPhaseFilterType(), settings.GetPhaseFilterId().ToString()));
        message.AppendLine(string.Format("    ViewDetailLevel has type {0} and value: {1}",
                                         settings.GetViewDetailLevelType(), settings.GetViewDetailLevel()));
    }

    TaskDialog.Show("Link Overrides report", message.ToString());
}
See Also

Reference

View Class


View.GetModelToProjectionTransforms Method

ViewGetModelToProjectionTransforms Method

Gets the transforms from the model space to the view projection space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<TransformWithBoundary> GetModelToProjectionTransforms()
Public Function GetModelToProjectionTransforms As IList(Of TransformWithBoundary)
public:
IList<TransformWithBoundary^>^ GetModelToProjectionTransforms()
member GetModelToProjectionTransforms : unit -> IList<TransformWithBoundary>

Return Value

IList TransformWithBoundary
The transformations from the model space to view projection space.
Exceptions
Exception | Condition
InvalidOperationException | The view does not return transforms. -or- The view is a perspective view.
Remarks

Model space is the global 3D coordinate space in which the geometry of the model lives.

View projection space is the 3D Euclidean space with a coordinate system such that X and Y are horizontal and vertical directions in the view projection plane and Z is the cross product of X and Y. Distances in the projection space are the same as would be measured on paper if the view is printed without additional scaling.

Most views will return just one TransformWithBoundary. The exceptions are views with split crop regions. Split crop regions can be independently moved and therefore each region of a split crop gets its own transform and boundary. You can check if a view has split crop regions by getting the ViewCropRegionShapeManager and calling [!:ViewCropRegionShapeManager.IsSplit()].

When the view's crop region is split, many TransformWithBoundary objects will be returned. Each TransformWithBoundary corresponds to one region of the split crop. To determine which TransformWithBoundary to use when converting a model point into view projection space, first test to see which split crop region boundary contains the model point. See [!:TransformWithBoundary.GetBoundary()].

See Also

Reference

View Class


View.GetNonControlledTemplateParameterIds Method

ViewGetNonControlledTemplateParameterIds Method

Returns a list of parameters that are not marked as included when this view is used as a template.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetNonControlledTemplateParameterIds()
Public Function GetNonControlledTemplateParameterIds As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetNonControlledTemplateParameterIds()
member GetNonControlledTemplateParameterIds : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
The parameter ids that are not marked to be included.
Remarks
This is a subset of the parameters returned by GetTemplateParameterIds.
See Also

Reference

View Class


View.GetOrderedFilters Method

ViewGetOrderedFilters Method

Gets the filters applied to the view in the order they are applied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ElementId> GetOrderedFilters()
Public Function GetOrderedFilters As IList(Of ElementId)
public:
IList<ElementId^>^ GetOrderedFilters()
member GetOrderedFilters : unit -> IList<ElementId>

Return Value

IList ElementId
The ElementIds of the Filters.
Exceptions
Exception | Condition
InvalidOperationException | The element "this View" does not belong to a project document. -or- The view type does not support Visibility/Graphics Overriddes.
See Also

Reference

View Class


View.GetPlacementOnSheetStatus Method

ViewGetPlacementOnSheetStatus Method

Determines if this view placed on a sheet completely or partially.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ViewPlacementOnSheetStatus GetPlacementOnSheetStatus()
Public Function GetPlacementOnSheetStatus As ViewPlacementOnSheetStatus
public:
ViewPlacementOnSheetStatus GetPlacementOnSheetStatus()
member GetPlacementOnSheetStatus : unit -> ViewPlacementOnSheetStatus

Return Value

ViewPlacementOnSheetStatus
A value indicating whether and how the View is placed on a Sheet.
Remarks
Some Views can be placed on one or more Sheets completely or partially. For example, a Schedule divided in segments, and only some of them are placed on Sheets.
See Also

Reference

View Class


View.GetPointCloudOverrides Method

ViewGetPointCloudOverrides Method

Returns point cloud overrides object for the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PointCloudOverrides GetPointCloudOverrides()
Public Function GetPointCloudOverrides As PointCloudOverrides
public:
PointCloudOverrides^ GetPointCloudOverrides()
member GetPointCloudOverrides : unit -> PointCloudOverrides

Return Value

PointCloudOverrides
Point cloud overrides for the view
See Also

Reference

View Class


View.GetPrimaryViewId Method

ViewGetPrimaryViewId Method

Get the id of the primary view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GetPrimaryViewId()
Public Function GetPrimaryViewId As ElementId
public:
ElementId^ GetPrimaryViewId()
member GetPrimaryViewId : unit -> ElementId

Return Value

ElementId
The id of the primary view, or InvalidElementId if there is no primary view.
Remarks
The primary view is the view from which a dependent view is created.
See Also

Reference

View Class


View.GetReferenceCallouts Method

ViewGetReferenceCallouts Method

Returns element ids of all reference callouts in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetReferenceCallouts()
Public Function GetReferenceCallouts As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetReferenceCallouts()
member GetReferenceCallouts : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
Element ids of all reference callouts in the view.
See Also

Reference

View Class


View.GetReferenceElevations Method

ViewGetReferenceElevations Method

Returns element ids of all reference elevations in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetReferenceElevations()
Public Function GetReferenceElevations As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetReferenceElevations()
member GetReferenceElevations : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
Element ids of all reference elevations in the view.
See Also

Reference

View Class


View.GetReferenceSections Method

ViewGetReferenceSections Method

Returns element ids of all reference sections in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetReferenceSections()
Public Function GetReferenceSections As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetReferenceSections()
member GetReferenceSections : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
Element ids of all reference sections in the view.
See Also

Reference

View Class


View.GetSketchyLines Method

ViewGetSketchyLines Method

Returns the current sketchy lines settings for the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ViewDisplaySketchyLines GetSketchyLines()
Public Function GetSketchyLines As ViewDisplaySketchyLines
public:
ViewDisplaySketchyLines^ GetSketchyLines()
member GetSketchyLines : unit -> ViewDisplaySketchyLines

Return Value

ViewDisplaySketchyLines
Current sketchy lines settings.
See Also

Reference

View Class


View.GetTemplateParameterIds Method

ViewGetTemplateParameterIds Method

Returns a list of parameter ids that may be controlled when this view is assigned as a template.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ElementId> GetTemplateParameterIds()
Public Function GetTemplateParameterIds As IList(Of ElementId)
public:
IList<ElementId^>^ GetTemplateParameterIds()
member GetTemplateParameterIds : unit -> IList<ElementId>

Return Value

IList ElementId
The parameter ids that may be controlled.
See Also

Reference

View Class


View.GetTemporaryViewPropertiesId Method

ViewGetTemporaryViewPropertiesId Method

When Temporary View Properties mode is in progress it provides view id that overrode settings for current view. Outside Temporary View Properties mode InvalidElementId will be returned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GetTemporaryViewPropertiesId()
Public Function GetTemporaryViewPropertiesId As ElementId
public:
ElementId^ GetTemporaryViewPropertiesId()
member GetTemporaryViewPropertiesId : unit -> ElementId

Return Value

ElementId
Remarks
Returned ElementId might refer to element that was deleted. It will happen when Temporary View Properties mode was applied basing on template that next was deleted.
See Also

Reference

View Class


View.GetTemporaryViewPropertiesName Method

ViewGetTemporaryViewPropertiesName Method

When Temporary View Properties mode is in progress, name of applied template is returned. Outside Temporary View Properties mode, empty string will be returned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetTemporaryViewPropertiesName()
Public Function GetTemporaryViewPropertiesName As String
public:
String^ GetTemporaryViewPropertiesName()
member GetTemporaryViewPropertiesName : unit -> string

Return Value

String
See Also

Reference

View Class


View.GetViewDisplayModel Method

ViewGetViewDisplayModel Method

Returns the current view display model settings for the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ViewDisplayModel GetViewDisplayModel()
Public Function GetViewDisplayModel As ViewDisplayModel
public:
ViewDisplayModel^ GetViewDisplayModel()
member GetViewDisplayModel : unit -> ViewDisplayModel

Return Value

ViewDisplayModel
Current view display model settings.
See Also

Reference

View Class


View.GetWorksetVisibility Method

ViewGetWorksetVisibility Method

Returns the visibility settings of a workset for this particular view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WorksetVisibility GetWorksetVisibility(
    WorksetId worksetId
)
Public Function GetWorksetVisibility (
    worksetId As WorksetId
) As WorksetVisibility
public:
WorksetVisibility GetWorksetVisibility(
    WorksetId^ worksetId
)
member GetWorksetVisibility :
        worksetId : WorksetId -> WorksetVisibility

Parameters

worksetId WorksetId
Id of the workset.

Return Value

WorksetVisibility
The visibility of a workset for this particular view.
Exceptions
Exception | Condition
ArgumentException | There is no workset with this Id in the document associated with this view.
ArgumentNullException | A non-optional argument was null
Remarks
The settings does not reflect the fact of whether a workset is currently closed or not.
See Also

Reference

View Class


View.GetWorksharingDisplayMode Method

ViewGetWorksharingDisplayMode Method

Gets the current worksharing display mode for this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WorksharingDisplayMode GetWorksharingDisplayMode()
Public Function GetWorksharingDisplayMode As WorksharingDisplayMode
public:
WorksharingDisplayMode GetWorksharingDisplayMode()
member GetWorksharingDisplayMode : unit -> WorksharingDisplayMode

Return Value

WorksharingDisplayMode
The active worksharing display mode in this view.
Remarks
Returns "Off" if no worksharing display mode is currently enabled.
See Also

Reference

View Class


View.HasDetailLevel Method

ViewHasDetailLevel Method

Check if the view has a Detail Level property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasDetailLevel()
Public Function HasDetailLevel As Boolean
public:
bool HasDetailLevel()
member HasDetailLevel : unit -> bool

Return Value

Boolean
True if the view has a Detail Level, false otherwise
See Also

Reference

View Class


View.HasDisplayStyle Method

ViewHasDisplayStyle Method

Indicates if view has a DisplayStyle property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasDisplayStyle()
Public Function HasDisplayStyle As Boolean
public:
bool HasDisplayStyle()
member HasDisplayStyle : unit -> bool

Return Value

Boolean
True if view has a DisplayStyle property
See Also

Reference

View Class


View.HasViewDiscipline Method

ViewHasViewDiscipline Method

Indicates if the view has a Discipline property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasViewDiscipline()
Public Function HasViewDiscipline As Boolean
public:
bool HasViewDiscipline()
member HasViewDiscipline : unit -> bool

Return Value

Boolean
True if the view has a Discipline property
See Also

Reference

View Class


View.HasViewTransforms Method

ViewHasViewTransforms Method

Returns true if the view reports model space to view projection space transforms.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasViewTransforms()
Public Function HasViewTransforms As Boolean
public:
bool HasViewTransforms()
member HasViewTransforms : unit -> bool

Return Value

Boolean
True if the view returns transforms, false otherwise.
Remarks
Not all views return transforms. For example, schedules and legends do not report transforms.
See Also

Reference

View Class


View.HideActiveWorkPlane Method

ViewHideActiveWorkPlane Method

Hide the active work plane of the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void HideActiveWorkPlane()
Public Sub HideActiveWorkPlane
public:
void HideActiveWorkPlane()
member HideActiveWorkPlane : unit -> unit
Exceptions
Exception | Condition
InvalidOperationException | Thrown when there is no active sketch plane, or when an error occurs during setting the sketch plane visibility.
See Also

Reference

View Class


View.HideCategoriesTemporary Method

ViewHideCategoriesTemporary Method

Set multiple categories to be temporarily hidden in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void HideCategoriesTemporary(
    ICollection<ElementId> elementIds
)
Public Sub HideCategoriesTemporary (
    elementIds As ICollection(Of ElementId)
)
public:
void HideCategoriesTemporary(
    ICollection<ElementId^>^ elementIds
)
member HideCategoriesTemporary :
        elementIds : ICollection<ElementId> -> unit

Parameters

elementIds ICollection ElementId
Ids of the categories to be hidden
Exceptions
Exception | Condition
ArgumentException | Some elements in elementIds do not correspond to a Category.
ArgumentNullException | A non-optional argument was null
See Also

Reference

View Class


View.HideCategoryTemporary Method

ViewHideCategoryTemporary Method

Set one category to be temporarily hidden in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void HideCategoryTemporary(
    ElementId elementId
)
Public Sub HideCategoryTemporary (
    elementId As ElementId
)
public:
void HideCategoryTemporary(
    ElementId^ elementId
)
member HideCategoryTemporary :
        elementId : ElementId -> unit

Parameters

elementId ElementId
Id of the category to be hidden
Exceptions
Exception | Condition
ArgumentException | elementId does not correspond to a Category.
ArgumentNullException | A non-optional argument was null
See Also

Reference

View Class


View.HideElements Method

ViewHideElements Method

Sets the elements to be hidden in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void HideElements(
    ICollection<ElementId> elementIdSet
)
Public Sub HideElements (
    elementIdSet As ICollection(Of ElementId)
)
public:
void HideElements(
    ICollection<ElementId^>^ elementIdSet
)
member HideElements :
        elementIdSet : ICollection<ElementId> -> unit

Parameters

elementIdSet ICollection ElementId
A set of ElementIds to be hidden.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when argument is .
ArgumentException | Thrown when the set of elements to be hidden is empty or one of the elements can not be hidden. Also thrown when the set of elements to be hidden includes the view itself.
InvalidOperationException | Thrown when document regeneration failed.
Remarks
This change is permanent until the elements are unhidden. All elements in the set must be currently unhidden and must be allowed to be hidden. An application can check this with IsHidden(View) and CanBeHidden(View).

Some elements cannot be hidden directly. Examples include: group, array, constraint, edit cut profile, face splitter and link to external documents.

Also, elements cannot be hidden in Revit family documents (but they can be hidden temporarily using [M:Autodesk.Revit.DB.View.HideElementsTemporary(System.Collections.Generic.ICollection`1{Autodesk.Revit.DB.ElementId})]).

To hide a group completely, you must also include all members of all groups and nested groups in your input.

See Also

Reference

View Class


View.HideElementsTemporary Method

ViewHideElementsTemporary Method

Set multiple elements to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void HideElementsTemporary(
    ICollection<ElementId> elementIdSet
)
Public Sub HideElementsTemporary (
    elementIdSet As ICollection(Of ElementId)
)
public:
void HideElementsTemporary(
    ICollection<ElementId^>^ elementIdSet
)
member HideElementsTemporary :
        elementIdSet : ICollection<ElementId> -> unit

Parameters

elementIdSet ICollection ElementId
Ids of the elements to be temporarily hidden.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

View Class


View.HideElementTemporary Method

ViewHideElementTemporary Method

Set one element to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void HideElementTemporary(
    ElementId elementId
)
Public Sub HideElementTemporary (
    elementId As ElementId
)
public:
void HideElementTemporary(
    ElementId^ elementId
)
member HideElementTemporary :
        elementId : ElementId -> unit

Parameters

elementId ElementId
The id of the element to be temporarily hidden.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

View Class


View.IsCategoryOverridable Method

ViewIsCategoryOverridable Method

Checks whether the category can have graphic overrides in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCategoryOverridable(
    ElementId categoryId
)
Public Function IsCategoryOverridable (
    categoryId As ElementId
) As Boolean
public:
bool IsCategoryOverridable(
    ElementId^ categoryId
)
member IsCategoryOverridable :
        categoryId : ElementId -> bool

Parameters

categoryId ElementId
ElementId of the category.

Return Value

Boolean
True if category can be overridden, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Categories can be allowed to be overridden in some view types and prohibited from being overridden in others. E.g., categories cannot be overridden in ProjectBrowser
See Also

Reference

View Class


View.IsElementVisibleInTemporaryViewMode Method

ViewIsElementVisibleInTemporaryViewMode Method

Identifies if the input element is visible for the temporary view mode for this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsElementVisibleInTemporaryViewMode(
    TemporaryViewMode mode,
    ElementId id
)
Public Function IsElementVisibleInTemporaryViewMode (
    mode As TemporaryViewMode,
    id As ElementId
) As Boolean
public:
bool IsElementVisibleInTemporaryViewMode(
    TemporaryViewMode mode,
    ElementId^ id
)
member IsElementVisibleInTemporaryViewMode :
        mode : TemporaryViewMode *
        id : ElementId -> bool

Parameters

mode TemporaryViewMode
The temporary view mode. Only TemporaryHideIsolate and AnalyticalModel modes are supported by this option. Other modes will result in an exception.
id ElementId
The element id.

Return Value

Boolean
True if the element is visible, false if the element is hidden in the view mode.
Exceptions
Exception | Condition
ArgumentException | This view mode is not supported for checking element visibility.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

View Class


View.IsFilterApplied Method

ViewIsFilterApplied Method

Indicates if a filter is applied to the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsFilterApplied(
    ElementId filterElementId
)
Public Function IsFilterApplied (
    filterElementId As ElementId
) As Boolean
public:
bool IsFilterApplied(
    ElementId^ filterElementId
)
member IsFilterApplied :
        filterElementId : ElementId -> bool

Parameters

filterElementId ElementId
ElementId of the filter.

Return Value

Boolean
True if the filter is applied to the view, false otherwise.
Exceptions
Exception | Condition
ArgumentException | ElementId is not associated with a FilterElement.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The element "this View" does not belong to a project document. -or- The view type does not support Visibility/Graphics Overriddes.
See Also

Reference

View Class


View.IsInTemporaryViewMode Method

ViewIsInTemporaryViewMode Method

Returns true if the view is in a particular temporary view mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsInTemporaryViewMode(
    TemporaryViewMode mode
)
Public Function IsInTemporaryViewMode (
    mode As TemporaryViewMode
) As Boolean
public:
bool IsInTemporaryViewMode(
    TemporaryViewMode mode
)
member IsInTemporaryViewMode :
        mode : TemporaryViewMode -> bool

Parameters

mode TemporaryViewMode
The mode.

Return Value

Boolean
True if this view is in the temporary view mode indicated, false otherwise.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

View Class


View.IsolateCategoriesTemporary Method

ViewIsolateCategoriesTemporary Method

Set categories to be temporarily isolated in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void IsolateCategoriesTemporary(
    ICollection<ElementId> elementIds
)
Public Sub IsolateCategoriesTemporary (
    elementIds As ICollection(Of ElementId)
)
public:
void IsolateCategoriesTemporary(
    ICollection<ElementId^>^ elementIds
)
member IsolateCategoriesTemporary :
        elementIds : ICollection<ElementId> -> unit

Parameters

elementIds ICollection ElementId
Ids of categories to be isolated.
Exceptions
Exception | Condition
ArgumentException | Some elements in elementIds do not correspond to a Category.
ArgumentNullException | A non-optional argument was null
See Also

Reference

View Class


View.IsolateCategoryTemporary Method

ViewIsolateCategoryTemporary Method

Set one category to be temporarily isolated in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void IsolateCategoryTemporary(
    ElementId elementId
)
Public Sub IsolateCategoryTemporary (
    elementId As ElementId
)
public:
void IsolateCategoryTemporary(
    ElementId^ elementId
)
member IsolateCategoryTemporary :
        elementId : ElementId -> unit

Parameters

elementId ElementId
Id of category to be isolated.
Exceptions
Exception | Condition
ArgumentException | elementId does not correspond to a Category.
ArgumentNullException | A non-optional argument was null
See Also

Reference

View Class


View.IsolateElementsTemporary Method

ViewIsolateElementsTemporary Method

Set multiple elements to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void IsolateElementsTemporary(
    ICollection<ElementId> elementIds
)
Public Sub IsolateElementsTemporary (
    elementIds As ICollection(Of ElementId)
)
public:
void IsolateElementsTemporary(
    ICollection<ElementId^>^ elementIds
)
member IsolateElementsTemporary :
        elementIds : ICollection<ElementId> -> unit

Parameters

elementIds ICollection ElementId
Ids of elements to be isolated.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

View Class


View.IsolateElementTemporary Method

ViewIsolateElementTemporary Method

Set one element to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void IsolateElementTemporary(
    ElementId elementId
)
Public Sub IsolateElementTemporary (
    elementId As ElementId
)
public:
void IsolateElementTemporary(
    ElementId^ elementId
)
member IsolateElementTemporary :
        elementId : ElementId -> unit

Parameters

elementId ElementId
Id of element to be isolated.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

View Class


View.IsTemporaryHideIsolateActive Method

ViewIsTemporaryHideIsolateActive Method

Indicates if the view is temporarily hiding or isolating elements or categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsTemporaryHideIsolateActive()
Public Function IsTemporaryHideIsolateActive As Boolean
public:
bool IsTemporaryHideIsolateActive()
member IsTemporaryHideIsolateActive : unit -> bool

Return Value

Boolean
True if elements/categories are being temporarily hidden or isolated, false otherwise.
See Also

Reference

View Class


View.IsTemporaryViewPropertiesModeEnabled Method

ViewIsTemporaryViewPropertiesModeEnabled Method

Returns true when Temporary View Properties mode is in progress, false otherwise.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsTemporaryViewPropertiesModeEnabled()
Public Function IsTemporaryViewPropertiesModeEnabled As Boolean
public:
bool IsTemporaryViewPropertiesModeEnabled()
member IsTemporaryViewPropertiesModeEnabled : unit -> bool

Return Value

Boolean
See Also

Reference

View Class


View.IsValidViewScale Method

ViewIsValidViewScale Method

This validator checks that the view scale is in the allowable range.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidViewScale(
    int viewScale
)
Public Shared Function IsValidViewScale (
    viewScale As Integer
) As Boolean
public:
static bool IsValidViewScale(
    int viewScale
)
static member IsValidViewScale :
        viewScale : int -> bool

Parameters

viewScale Int32
The denominator X in the view scale 1/X.

Return Value

Boolean
True if the view scale is within the allowable range, false otherwise.
Remarks
The view scale is expressed as 1/X, where X is an integer the range 1 to 24,000.
See Also

Reference

View Class


View.IsValidViewTemplate Method

ViewIsValidViewTemplate Method

Verifies that the view represented by templateId can be set as the controlling view template for this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidViewTemplate(
    ElementId templateId
)
Public Function IsValidViewTemplate (
    templateId As ElementId
) As Boolean
public:
bool IsValidViewTemplate(
    ElementId^ templateId
)
member IsValidViewTemplate :
        templateId : ElementId -> bool

Parameters

templateId ElementId
The id to be validated as a view template for this view.

Return Value

Boolean
True if the view is valid for us as a view template and compatible with this view, or if it is InvalidElementId, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

View Class


View.IsViewValidForTemplateCreation Method

ViewIsViewValidForTemplateCreation Method

Verifies that the view is valid for template creation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsViewValidForTemplateCreation()
Public Function IsViewValidForTemplateCreation As Boolean
public:
bool IsViewValidForTemplateCreation()
member IsViewValidForTemplateCreation : unit -> bool

Return Value

Boolean
True if the view can be used for view template creation, false otherwise.
See Also

Reference

View Class


View.IsWorksetVisible Method

ViewIsWorksetVisible Method

Indicates whether the workset is visible in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsWorksetVisible(
    WorksetId worksetId
)
Public Function IsWorksetVisible (
    worksetId As WorksetId
) As Boolean
public:
bool IsWorksetVisible(
    WorksetId^ worksetId
)
member IsWorksetVisible :
        worksetId : WorksetId -> bool

Parameters

worksetId WorksetId
Id of the workset.

Return Value

Boolean
Whether the workset is visible.
Exceptions
Exception | Condition
ArgumentException | There is no workset with this Id in the document associated with this view.
ArgumentNullException | A non-optional argument was null
Remarks
It will take into account whether the workset is opened or closed.
See Also

Reference

View Class


View.Print Method

ViewPrint Method

Print this view.
Overload List
 | Name | Description
Public method | Print | Print this view with the default view template and using the print setting of the current active document.
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document.
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document.
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document.
Top
See Also

Reference

View Class


View.Print Method

ViewPrint Method

Print this view with the default view template and using the print setting of the current active document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Print()
Public Sub Print
public:
void Print()
member Print : unit -> unit
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the view cannot be printed.
See Also

Reference

View Class
Print Overload


View.Print(Boolean) Method

ViewPrint(Boolean) Method

Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Print(
    bool useCurrentPrintSettings
)
Public Sub Print (
    useCurrentPrintSettings As Boolean
)
public:
void Print(
    bool useCurrentPrintSettings
)
member Print :
        useCurrentPrintSettings : bool -> unit

Parameters

useCurrentPrintSettings Boolean
If true, print the view with the print setting of the current active document; otherwise with the view's document's print setting.
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the view cannot be printed.
See Also

Reference

View Class
Print Overload


View.Print(View) Method

ViewPrint(View) Method

Print this view with the given view template and using the print setting of the current active document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Print(
    View viewTemplate
)
Public Sub Print (
    viewTemplate As View
)
public:
void Print(
    View^ viewTemplate
)
member Print :
        viewTemplate : View -> unit

Parameters

viewTemplate View
The view template which apply to the view.
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the view cannot be printed.
See Also

Reference

View Class
Print Overload


View.Print(View, Boolean) Method

ViewPrint(View, Boolean) Method

Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Print(
    View viewTemplate,
    bool useCurrentPrintSettings
)
Public Sub Print (
    viewTemplate As View,
    useCurrentPrintSettings As Boolean
)
public:
void Print(
    View^ viewTemplate,
    bool useCurrentPrintSettings
)
member Print :
        viewTemplate : View *
        useCurrentPrintSettings : bool -> unit

Parameters

viewTemplate View
The view template which apply to the view.
useCurrentPrintSettings Boolean
If true, print the view with the print setting of the current active document; otherwise with the view's document's print setting.
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the view cannot be printed.
See Also

Reference

View Class
Print Overload


View.RemoveCalloutParent Method

ViewRemoveCalloutParent Method

Replaces callout parent ID with InvalidElementId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveCalloutParent()
Public Sub RemoveCalloutParent
public:
void RemoveCalloutParent()
member RemoveCalloutParent : unit -> unit
Exceptions
Exception | Condition
InvalidOperationException | This view is not a callout.
Remarks
Nothing is done if the callout has already no parent.
See Also

Reference

View Class


View.RemoveFilter Method

ViewRemoveFilter Method

Removes a filter from the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveFilter(
    ElementId filterElementId
)
Public Sub RemoveFilter (
    filterElementId As ElementId
)
public:
void RemoveFilter(
    ElementId^ filterElementId
)
member RemoveFilter :
        filterElementId : ElementId -> unit

Parameters

filterElementId ElementId
ElementId of the filter.
Exceptions
Exception | Condition
ArgumentException | Filter is not applied to the view. -or- ElementId is not associated with a FilterElement.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The element "this View" does not belong to a project document. -or- The view type does not support Visibility/Graphics Overriddes.
See Also

Reference

View Class


View.RemoveLinkOverrides Method

ViewRemoveLinkOverrides Method

Deletes the graphical link overrides in the current view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveLinkOverrides(
    ElementId linkId
)
Public Sub RemoveLinkOverrides (
    linkId As ElementId
)
public:
void RemoveLinkOverrides(
    ElementId^ linkId
)
member RemoveLinkOverrides :
        linkId : ElementId -> unit

Parameters

linkId ElementId
The id of the RevitLinkType or RevitLinkInstance.
Exceptions
Exception | Condition
ArgumentException | The input id is not a valid RevitLinkInstance or RevitLinkType id.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The view type does not support Visibility/Graphics Overriddes. -or- The view does not support link graphical overrides.
Remarks
If the input linkId references RevitLinkType, then the link overrides will be set to default. If the input linkId references RevitLinkInstance, then the link overrides will be removed and the settings of RevitLinkType will be used for this instance.
Example
C#
Copy
public static void RemoveLinkOverridesInView(View view, ElementId linkId)
{
    using (Transaction transaction = new Transaction(view.Document, "Remove link overrides"))
    {
        transaction.Start();
        view.RemoveLinkOverrides(linkId);
        transaction.Commit();
    }
}
See Also

Reference

View Class


View.RestoreCalloutParent Method

ViewRestoreCalloutParent Method

Restores callout parent ID to the original view ID if that view is still available.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RestoreCalloutParent()
Public Sub RestoreCalloutParent
public:
void RestoreCalloutParent()
member RestoreCalloutParent : unit -> unit
Exceptions
Exception | Condition
InvalidOperationException | This view is not a callout.
Remarks
Nothing is done if the callout already has parent or if the original callout parent is deleted or is not parallel to the callout view.
See Also

Reference

View Class


View.SetBackground Method

ViewSetBackground Method

Sets the background for the view. Background can only be set for 3d views and for Sections/Elevations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetBackground(
    ViewDisplayBackground background
)
Public Sub SetBackground (
    background As ViewDisplayBackground
)
public:
void SetBackground(
    ViewDisplayBackground^ background
)
member SetBackground :
        background : ViewDisplayBackground -> unit

Parameters

background ViewDisplayBackground
Background to set. See 'ViewDisplayBackground' class and its 'create' methods.
Exceptions
Exception | Condition
ArgumentException | The background object is invalid, or view has 'Rendering' style.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This view does not contain display-related properties.
See Also

Reference

View Class


View.SetCategoryHidden Method

ViewSetCategoryHidden Method

Sets if elements of the given category will be visible in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetCategoryHidden(
    ElementId categoryId,
    bool hide
)
Public Sub SetCategoryHidden (
    categoryId As ElementId,
    hide As Boolean
)
public:
void SetCategoryHidden(
    ElementId^ categoryId,
    bool hide
)
member SetCategoryHidden :
        categoryId : ElementId *
        hide : bool -> unit

Parameters

categoryId ElementId
The ID of the category.
hide Boolean
True to make elements of this category invisible, false to make them visible.
Exceptions
Exception | Condition
ArgumentException | categoryId does not correspond to a Category. -or- Category cannot be hidden.
ArgumentNullException | A non-optional argument was null
Remarks
This affects only if the category is set visible or invisible individually. Other Revit mechanisms may also affect the visibility of elements of this category, including:
  • The category classes settings for model categories, annotation categories, import categories or analytical model categories.
  • View filters.
  • Elements hidden individually in the view.
Thus setting this value may not affect the actual visibility of elements of this category in the view.
See Also

Reference

View Class


View.SetCategoryOverrides Method

ViewSetCategoryOverrides Method

Sets graphic overrides for a category in view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetCategoryOverrides(
    ElementId categoryId,
    OverrideGraphicSettings overrideGraphicSettings
)
Public Sub SetCategoryOverrides (
    categoryId As ElementId,
    overrideGraphicSettings As OverrideGraphicSettings
)
public:
void SetCategoryOverrides(
    ElementId^ categoryId,
    OverrideGraphicSettings^ overrideGraphicSettings
)
member SetCategoryOverrides :
        categoryId : ElementId *
        overrideGraphicSettings : OverrideGraphicSettings -> unit

Parameters

categoryId ElementId
Category to be overridden
overrideGraphicSettings OverrideGraphicSettings
Object representing all graphic overrides of the category categoryId in view.
Exceptions
Exception | Condition
ArgumentException | Category cannot be overridden. -or- Fill pattern must be a drafting pattern. -or- Fill pattern Id must be invalidElementId or point to a LinePattern element.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The view type does not support Visibility/Graphics Overriddes.
See Also

Reference

View Class


View.SetColorFillSchemeId Method

ViewSetColorFillSchemeId Method

Applies color fill scheme to this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetColorFillSchemeId(
    ElementId categoryId,
    ElementId schemeId
)
Public Sub SetColorFillSchemeId (
    categoryId As ElementId,
    schemeId As ElementId
)
public:
void SetColorFillSchemeId(
    ElementId^ categoryId,
    ElementId^ schemeId
)
member SetColorFillSchemeId :
        categoryId : ElementId *
        schemeId : ElementId -> unit

Parameters

categoryId ElementId
The id of category to apply a color fill scheme element.
schemeId ElementId
The id of the color fill scheme element.
Exceptions
Exception | Condition
ArgumentException | The schemeId can not be applied as the scheme id of categoryId in this view.
ArgumentNullException | A non-optional argument was null
Remarks

There could be at most three [!:Autodesk::Revit::DB::ColorFillScheme] applied in a view: one for spatial elements (rooms, zones, spaces and areas), one for pipes and one for ducts.

Notes:

  • There's at most one scheme activated for all spatial categories.
  • For area plan view, the activated spatial scheme category must be OST_Areas and has the same [!:Autodesk::Revit::DB::AreaScheme] with this view if it is not used as a template.
  • To clear one of the above three schemes, use InvalidElementId as the parameter of this function.
  • To get list of element categories supportted to be colored in this view, use SupportedColorFillCategoryIds.
  • To check whether an specified ElementId could be applied to this view, use CanApplyColorFillScheme(ElementId, ElementId).
See Also

Reference

View Class


View.SetDepthCueing Method

ViewSetDepthCueing Method

Sets the depth cueing settings for the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetDepthCueing(
    ViewDisplayDepthCueing depthCueing
)
Public Sub SetDepthCueing (
    depthCueing As ViewDisplayDepthCueing
)
public:
void SetDepthCueing(
    ViewDisplayDepthCueing^ depthCueing
)
member SetDepthCueing :
        depthCueing : ViewDisplayDepthCueing -> unit

Parameters

depthCueing ViewDisplayDepthCueing
Depth cueing settings to set.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This view does not contain display-related properties. -or- This view cannot use Depth Cueing
See Also

Reference

View Class


View.SetElementOverrides Method

ViewSetElementOverrides Method

Sets graphic overrides for an element in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetElementOverrides(
    ElementId elementId,
    OverrideGraphicSettings overrideGraphicSettings
)
Public Sub SetElementOverrides (
    elementId As ElementId,
    overrideGraphicSettings As OverrideGraphicSettings
)
public:
void SetElementOverrides(
    ElementId^ elementId,
    OverrideGraphicSettings^ overrideGraphicSettings
)
member SetElementOverrides :
        elementId : ElementId *
        overrideGraphicSettings : OverrideGraphicSettings -> unit

Parameters

elementId ElementId
Element to override.
overrideGraphicSettings OverrideGraphicSettings
An object representing all graphic overrides of the element in view.
Exceptions
Exception | Condition
ArgumentException | elementId is not a valid Element identifier. -or- Fill pattern must be a drafting pattern. -or- Fill pattern Id must be invalidElementId or point to a LinePattern element.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The element "this View" does not belong to a project document. -or- The view type does not support Visibility/Graphics Overriddes.
See Also

Reference

View Class


View.SetFilterOverrides Method

ViewSetFilterOverrides Method

Sets the overrides associated with a filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetFilterOverrides(
    ElementId filterElementId,
    OverrideGraphicSettings overrideGraphicSettings
)
Public Sub SetFilterOverrides (
    filterElementId As ElementId,
    overrideGraphicSettings As OverrideGraphicSettings
)
public:
void SetFilterOverrides(
    ElementId^ filterElementId,
    OverrideGraphicSettings^ overrideGraphicSettings
)
member SetFilterOverrides :
        filterElementId : ElementId *
        overrideGraphicSettings : OverrideGraphicSettings -> unit

Parameters

filterElementId ElementId
ElementId of the filter.
overrideGraphicSettings OverrideGraphicSettings
The overrides to apply to the filter.
Exceptions
Exception | Condition
ArgumentException | ElementId is not associated with a FilterElement. -or- Fill pattern must be a drafting pattern. -or- Fill pattern Id must be invalidElementId or point to a LinePattern element.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The element "this View" does not belong to a project document. -or- The view type does not support Visibility/Graphics Overriddes.
Remarks
If the filter is not currently applied to the view, this will add the filter with the assigned overrides.
Example
C#
VB
C++
F#
Copy
public static void ModifyExistingFilter(Document doc, View view)
{
    // Find any filter with overrides setting cut color to Red
    Dictionary<ElementId, OverrideGraphicSettings> filterIdsToChange = new Dictionary<ElementId, OverrideGraphicSettings>();

    foreach (ElementId filterId in view.GetFilters())
    {
        OverrideGraphicSettings overrideSettings = view.GetFilterOverrides(filterId);

        Color lineColor = overrideSettings.CutLineColor;

        if (lineColor == Color.InvalidColorValue)
            continue;

        // Save overrides setting the cut color to green
        if (lineColor.Red == 0xFF && lineColor.Green == 0x00 && lineColor.Blue == 0x00)
        {
            overrideSettings.SetCutLineColor(new Color(0x00, 0xFF, 0x00));
            filterIdsToChange[filterId] = overrideSettings;
        }
    }

    // Make the change to all found filters
    using (Transaction t = new Transaction(doc, "Change override filters"))
    {
        t.Start();

        foreach (ElementId filterId in filterIdsToChange.Keys)
        {
            view.SetFilterOverrides(filterId, filterIdsToChange[filterId]);
        }
        t.Commit();
    }
}
Public Shared Sub ModifyExistingFilter(doc As Document, view As View)
    ' Find any filter with overrides setting cut color to Red
    Dim filterIdsToChange As New Dictionary(Of ElementId, OverrideGraphicSettings)()

    For Each filterId As ElementId In view.GetFilters()
        Dim overrideSettings As OverrideGraphicSettings = view.GetFilterOverrides(filterId)

        Dim lineColor As Color = overrideSettings.CutLineColor

        If lineColor.IsValid = False Then
            Continue For
        End If

        ' Save overrides setting the cut color to green
        If lineColor.Red = &Hff AndAlso lineColor.Green = &H0 AndAlso lineColor.Blue = &H0 Then
            overrideSettings.SetCutLineColor(New Color(&H0, &Hff, &H0))
            filterIdsToChange(filterId) = overrideSettings
        End If
    Next

    ' Make the change to all found filters
    Using t As New Transaction(doc, "Change override filters")
        t.Start()

        For Each filterId As ElementId In filterIdsToChange.Keys
            view.SetFilterOverrides(filterId, filterIdsToChange(filterId))
        Next
        t.Commit()
    End Using
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

View Class


View.SetFilterVisibility Method

ViewSetFilterVisibility Method

Sets the visibility of the elements associated with a filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetFilterVisibility(
    ElementId filterElementId,
    bool visibility
)
Public Sub SetFilterVisibility (
    filterElementId As ElementId,
    visibility As Boolean
)
public:
void SetFilterVisibility(
    ElementId^ filterElementId,
    bool visibility
)
member SetFilterVisibility :
        filterElementId : ElementId *
        visibility : bool -> unit

Parameters

filterElementId ElementId
The ElementId of the filter.
visibility Boolean
True if the elements associated with the filter are visible in the view, false otherwise.
Exceptions
Exception | Condition
ArgumentException | ElementId is not associated with a FilterElement.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The element "this View" does not belong to a project document. -or- The view type does not support Visibility/Graphics Overriddes.
Remarks
If the filter is not currently applied to the view, this will add the filter with the specified visibility.
See Also

Reference

View Class


View.SetIsFilterEnabled Method

ViewSetIsFilterEnabled Method

Sets the filter enabled flag.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetIsFilterEnabled(
    ElementId filterElementId,
    bool enable
)
Public Sub SetIsFilterEnabled (
    filterElementId As ElementId,
    enable As Boolean
)
public:
void SetIsFilterEnabled(
    ElementId^ filterElementId,
    bool enable
)
member SetIsFilterEnabled :
        filterElementId : ElementId *
        enable : bool -> unit

Parameters

filterElementId ElementId
The ElementId of the filter.
enable Boolean
True if the specified filter should be enabled in this view, false otherwise.
Exceptions
Exception | Condition
ArgumentException | Filter is not applied to the view. -or- ElementId is not associated with a FilterElement.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The element "this View" does not belong to a project document. -or- The view type does not support Visibility/Graphics Overriddes.
Remarks
Several filters can be applied to a view in a sertain order. This enable/disable flag allows one to quickly turn on/off the action of a particular filter in this view (without removing the filter from the set of applied filters and loosing the corresponding overrides). By default, all the filters applied to a view are enabled.
See Also

Reference

View Class


View.SetLinkOverrides Method

ViewSetLinkOverrides Method

Sets the graphic overrides of a RevitLinkType or RevitLinkInstance in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetLinkOverrides(
    ElementId linkId,
    RevitLinkGraphicsSettings linkDisplaySettings
)
Public Sub SetLinkOverrides (
    linkId As ElementId,
    linkDisplaySettings As RevitLinkGraphicsSettings
)
public:
void SetLinkOverrides(
    ElementId^ linkId,
    RevitLinkGraphicsSettings^ linkDisplaySettings
)
member SetLinkOverrides :
        linkId : ElementId *
        linkDisplaySettings : RevitLinkGraphicsSettings -> unit

Parameters

linkId ElementId
The id of the RevitLinkType or RevitLinkInstance.
linkDisplaySettings RevitLinkGraphicsSettings
Settings representing all link graphic overrides in the view.
Exceptions
Exception | Condition
ArgumentException | The input id is not a valid RevitLinkInstance or RevitLinkType id. -or- The LinkedViewId of linkDisplaySettings has incorrect value for the specified LinkVisibilityType. -or- The ViewFilterType of linkDisplaySettings has incorrect value. -or- The ViewRange of linkDisplaySettings has unsupported value. -or- The phase or pahse type of linkDisplaySettings has incorrect value for the specified LinkVisibilityType. -or- The phase filter or phase filter type of linkDisplaySettings has incorrect value for the specified LinkVisibilityType. -or- The view detail level or the type of view detail level of linkDisplaySettings has incorrect value for the specified LinkVisibilityType. -or- The discipline or the discipline type of linkDisplaySettings has incorrect value for the specified LinkVisibilityType. -or- The ColorFill of linkDisplaySettings has incorrect value for the specified LinkVisibilityType. -or- The ObjectStyles of linkDisplaySettings has incorrect value for the specified LinkVisibilityType. -or- The NestedLinks of linkDisplaySettings has incorrect value for the specified LinkVisibilityType.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The view type does not support Visibility/Graphics Overriddes. -or- The view does not support link graphical overrides.
Example
C#
Copy
public static void UpdateOverridesInView(View view, ElementId linkElementId, ElementId linkedViewId, LinkVisibility visibilityType)
{
    RevitLinkGraphicsSettings settings = new RevitLinkGraphicsSettings();

    switch (visibilityType)
    {
        case LinkVisibility.ByHostView:
            settings.LinkVisibilityType = LinkVisibility.ByHostView;
            break;
        case LinkVisibility.ByLinkView:
            settings.LinkVisibilityType = LinkVisibility.ByLinkView;
            settings.LinkedViewId = linkedViewId;
            break;
        case LinkVisibility.Custom:
            settings.LinkVisibilityType = LinkVisibility.Custom;
            settings.LinkedViewId = linkedViewId;
            settings.ViewFilterType = LinkVisibility.Custom;
            settings.ViewRange = RevitLinkGraphicsSettings.IsViewRangeSupported(view) ? LinkVisibility.ByLinkView : LinkVisibility.ByHostView;
            settings.ColorFill = view.SupportedColorFillCategoryIds().Any() ? LinkVisibility.ByLinkView : LinkVisibility.ByHostView;
            settings.ObjectStyles = LinkVisibility.ByLinkView;
            settings.NestedLinks = LinkVisibility.ByLinkView;

            settings.SetDiscipline(LinkVisibility.Custom, ViewDiscipline.Mechanical);
            settings.SetPhase(LinkVisibility.Custom, ElementId.InvalidElementId);
            settings.SetPhaseFilter(LinkVisibility.Custom, ElementId.InvalidElementId);
            settings.SetViewDetailLevel(LinkVisibility.Custom, ViewDetailLevel.Medium);
            break;
        default:
            throw new InvalidOperationException("Not expected visibility type.");
    }

    using (Transaction transaction = new Transaction(view.Document, "Set link graphical overrides"))
    {
        transaction.Start();
        view.SetLinkOverrides(linkElementId, settings);
        transaction.Commit();
    }
}
See Also

Reference

View Class


View.SetNonControlledTemplateParameterIds Method

ViewSetNonControlledTemplateParameterIds Method

Sets the parameters that will not be included when this view is used as a template.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetNonControlledTemplateParameterIds(
    ICollection<ElementId> newSet
)
Public Sub SetNonControlledTemplateParameterIds (
    newSet As ICollection(Of ElementId)
)
public:
void SetNonControlledTemplateParameterIds(
    ICollection<ElementId^>^ newSet
)
member SetNonControlledTemplateParameterIds :
        newSet : ICollection<ElementId> -> unit

Parameters

newSet ICollection ElementId
The parameter ids that should not be marked to be included.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
This should be a subset of the parameters returned by GetTemplateParameterIds (other parameters will be ignored).
See Also

Reference

View Class


View.SetSketchyLines Method

ViewSetSketchyLines Method

Sets the sketchy lines settings for the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetSketchyLines(
    ViewDisplaySketchyLines sketchyLines
)
Public Sub SetSketchyLines (
    sketchyLines As ViewDisplaySketchyLines
)
public:
void SetSketchyLines(
    ViewDisplaySketchyLines^ sketchyLines
)
member SetSketchyLines :
        sketchyLines : ViewDisplaySketchyLines -> unit

Parameters

sketchyLines ViewDisplaySketchyLines
Sketchy Lines settings to set.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This view does not contain display-related properties.
See Also

Reference

View Class


View.SetViewDisplayModel Method

ViewSetViewDisplayModel Method

Sets the view display model settings for the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetViewDisplayModel(
    ViewDisplayModel viewDisplayModel
)
Public Sub SetViewDisplayModel (
    viewDisplayModel As ViewDisplayModel
)
public:
void SetViewDisplayModel(
    ViewDisplayModel^ viewDisplayModel
)
member SetViewDisplayModel :
        viewDisplayModel : ViewDisplayModel -> unit

Parameters

viewDisplayModel ViewDisplayModel
View display model settings to set.
Exceptions
Exception | Condition
ArgumentException | The silhouette line style id is not a valid line style to apply to the view.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This view does not contain display-related properties.
See Also

Reference

View Class


View.SetWorksetVisibility Method

ViewSetWorksetVisibility Method

Sets visibility for a workset in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetWorksetVisibility(
    WorksetId worksetId,
    WorksetVisibility visible
)
Public Sub SetWorksetVisibility (
    worksetId As WorksetId,
    visible As WorksetVisibility
)
public:
void SetWorksetVisibility(
    WorksetId^ worksetId,
    WorksetVisibility visible
)
member SetWorksetVisibility :
        worksetId : WorksetId *
        visible : WorksetVisibility -> unit

Parameters

worksetId WorksetId
Id of the workset.
visible WorksetVisibility
The visibility of the workset.
Exceptions
Exception | Condition
ArgumentException | There is no workset with this Id in the document associated with this view.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Remarks
It works even when the workset is closed. This settings overrules implicit visibility of the workset (for this particular view only).
See Also

Reference

View Class


View.SetWorksharingDisplayMode Method

ViewSetWorksharingDisplayMode Method

Sets the worksharing display mode for this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetWorksharingDisplayMode(
    WorksharingDisplayMode displayMode
)
Public Sub SetWorksharingDisplayMode (
    displayMode As WorksharingDisplayMode
)
public:
void SetWorksharingDisplayMode(
    WorksharingDisplayMode displayMode
)
member SetWorksharingDisplayMode :
        displayMode : WorksharingDisplayMode -> unit

Parameters

displayMode WorksharingDisplayMode
The desired display mode. "Off" will turn off all worksharing display modes.
Exceptions
Exception | Condition
ArgumentException | This View does not support the requested worksharing display mode.
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Remarks
Turning on a worksharing display mode will disable other temporary view modes such as reveal hidden elements and temporary hide/isolate.
Example
C#
VB
C++
F#
Copy
public Result Execute(ExternalCommandData commandData, ref string message, ElementSet elements)
{
    View activeView = commandData.View;
    Document doc = activeView.Document;

    // Prepare settings
    Color red = new Color(0xFF, 0x00, 0x00);
    WorksharingDisplayGraphicSettings settingsToApply = new WorksharingDisplayGraphicSettings(true, red);

    // Toggle mode based on the current mode
    using (Transaction t = new Transaction(doc, "Toggle display mode"))
    {
        t.Start();

        WorksharingDisplaySettings settings = WorksharingDisplaySettings.GetOrCreateWorksharingDisplaySettings(doc);

        switch (activeView.GetWorksharingDisplayMode())
        {
            case WorksharingDisplayMode.Off:
                activeView.SetWorksharingDisplayMode(WorksharingDisplayMode.CheckoutStatus);
                settings.SetGraphicOverrides(CheckoutStatus.OwnedByOtherUser, settingsToApply);
                break;
            case WorksharingDisplayMode.CheckoutStatus:
                activeView.SetWorksharingDisplayMode(WorksharingDisplayMode.ModelUpdates);
                settings.SetGraphicOverrides(ModelUpdatesStatus.UpdatedInCentral, settingsToApply);
                break;
            case WorksharingDisplayMode.ModelUpdates:
                activeView.SetWorksharingDisplayMode(WorksharingDisplayMode.Owners);
                settings.SetGraphicOverrides("Target user", settingsToApply);
                break;
            case WorksharingDisplayMode.Owners:
                activeView.SetWorksharingDisplayMode(WorksharingDisplayMode.Worksets);
                settings.SetGraphicOverrides(doc.GetWorksetTable().GetActiveWorksetId(), settingsToApply);
                break;
            case WorksharingDisplayMode.Worksets:
                activeView.SetWorksharingDisplayMode(WorksharingDisplayMode.Off);
                break;
        }

        t.Commit();
    }

    return Result.Succeeded;
}
Public Function Execute(commandData As ExternalCommandData, ByRef message As String, elements As ElementSet) As Result Implements IExternalCommand.Execute
    Dim activeView As View = commandData.View
    Dim doc As Document = activeView.Document

    ' Prepare settings
    Dim red As New Color(&HFF, &H0, &H0)
    Dim settingsToApply As New WorksharingDisplayGraphicSettings(True, red)

    ' Toggle mode based on the current mode
    Using t As New Transaction(doc, "Toggle display mode")
        t.Start()

        Dim settings As WorksharingDisplaySettings = WorksharingDisplaySettings.GetOrCreateWorksharingDisplaySettings(doc)

        Select Case activeView.GetWorksharingDisplayMode()
            Case WorksharingDisplayMode.Off
                activeView.SetWorksharingDisplayMode(WorksharingDisplayMode.CheckoutStatus)
                settings.SetGraphicOverrides(CheckoutStatus.OwnedByOtherUser, settingsToApply)
                Exit Select
            Case WorksharingDisplayMode.CheckoutStatus
                activeView.SetWorksharingDisplayMode(WorksharingDisplayMode.ModelUpdates)
                settings.SetGraphicOverrides(ModelUpdatesStatus.UpdatedInCentral, settingsToApply)
                Exit Select
            Case WorksharingDisplayMode.ModelUpdates
                activeView.SetWorksharingDisplayMode(WorksharingDisplayMode.Owners)
                settings.SetGraphicOverrides("Target user", settingsToApply)
                Exit Select
            Case WorksharingDisplayMode.Owners
                activeView.SetWorksharingDisplayMode(WorksharingDisplayMode.Worksets)
                settings.SetGraphicOverrides(doc.GetWorksetTable().GetActiveWorksetId(), settingsToApply)
                Exit Select
            Case WorksharingDisplayMode.Worksets
                activeView.SetWorksharingDisplayMode(WorksharingDisplayMode.Off)
                Exit Select
        End Select

        t.Commit()
    End Using

    Return Result.Succeeded
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

View Class


View.ShowActiveWorkPlane Method

ViewShowActiveWorkPlane Method

Show the active work plane of the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ShowActiveWorkPlane()
Public Sub ShowActiveWorkPlane
public:
void ShowActiveWorkPlane()
member ShowActiveWorkPlane : unit -> unit
Exceptions
Exception | Condition
InvalidOperationException | Thrown when there is no active sketch plane, or when an error occurs during setting the sketch plane visibility.
Remarks
If this method is invoked while the current work plane is hidden, only the outline of the updated work plane will be shown immediately. The updated sketch plane will be shown fully after the current transaction is committed. Therefore it is recommended the Add-On commits the transaction before performing UI operations (for example, PickPoint).
See Also

Reference

View Class


View.SupportedColorFillCategoryIds Method

ViewSupportedColorFillCategoryIds Method

Returns collection of all category ids that correspond to elements that can potentially be colored in this view according to a color fill scheme. The set may be different depending on the view type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> SupportedColorFillCategoryIds()
Public Function SupportedColorFillCategoryIds As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ SupportedColorFillCategoryIds()
member SupportedColorFillCategoryIds : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
Remarks
All of the possible categories are OST_Rooms, OST_HVAC_Zones, OST_MEPSpaces, OST_Areas, OST_DuctCurves and OST_PipeCurves.
See Also

Reference

View Class


View.SupportsRevealConstraints Method

ViewSupportsRevealConstraints Method

Checks that the view can have the Reveal Constraints mode activated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SupportsRevealConstraints()
Public Function SupportsRevealConstraints As Boolean
public:
bool SupportsRevealConstraints()
member SupportsRevealConstraints : unit -> bool

Return Value

Boolean
True if the view has a view type that allows Reveal Constraints mode to be activated.
Remarks
Reveal Constraints mode can only be activated for the following viewtypes:
  • 3D Views
  • Area Plans
  • Ceiling Plans
  • Detail Views
  • Drafting Views
  • Elevations
  • Floor Plans
  • Sections
  • Structural Plans
See Also

Reference

View Class


View.SupportsWorksharingDisplayMode Method

ViewSupportsWorksharingDisplayMode Method

Checks whether this view supports the given worksharing display mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SupportsWorksharingDisplayMode(
    WorksharingDisplayMode mode
)
Public Function SupportsWorksharingDisplayMode (
    mode As WorksharingDisplayMode
) As Boolean
public:
bool SupportsWorksharingDisplayMode(
    WorksharingDisplayMode mode
)
member SupportsWorksharingDisplayMode :
        mode : WorksharingDisplayMode -> bool

Parameters

mode WorksharingDisplayMode
The mode of interest.

Return Value

Boolean
Returns True if this view is a graphical view in a workshared document or if the desired mode is Off. Returns False if this view is a non-graphical view (such as a schedule or the project browser) or if this view is not in a workshared document.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Remarks
For convenience, the "Off" mode is always supported. Other display modes are supported by graphical views in workshared documents.
See Also

Reference

View Class


View.UnhideElements Method

ViewUnhideElements Method

Sets the elements to be shown in the given view if they are currently hidden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void UnhideElements(
    ICollection<ElementId> elementIdSet
)
Public Sub UnhideElements (
    elementIdSet As ICollection(Of ElementId)
)
public:
void UnhideElements(
    ICollection<ElementId^>^ elementIdSet
)
member UnhideElements :
        elementIdSet : ICollection<ElementId> -> unit

Parameters

elementIdSet ICollection ElementId
A set of ElementIds to be unhidden.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when argument is .
ArgumentException | Thrown when the set of elements to be unhidden is empty or one of the elements can not be unhidden.
InvalidOperationException | Thrown when document regeneration failed.
Remarks
This change is permanent until the elements are hidden again. All elements in the set must be currently hidden. An application can check this with IsHidden(View).
See Also

Reference

View Class


View3D Class

Class for 3D views
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBView
Autodesk.Revit.DBView3D

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class View3D : View
Public Class View3D
    Inherits View
public ref class View3D : public View
type View3D =
    class
        inherit View
    end

The View3D type exposes the following members.

Properties
 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View)
Public property | AreAnalyticalModelCategoriesHidden | Indicates if analytical model categories are currently hidden in the view. (Inherited from View)
Public property | AreAnnotationCategoriesHidden | Indicates if annotation categories are currently hidden in the view. (Inherited from View)
Public property | AreCoordinationModelHandlesHidden | Indicates if Coordination Model handles are currently hidden in the view. (Inherited from View)
Public property | AreImportCategoriesHidden | Indicates if import categories are currently hidden in the view. (Inherited from View)
Public property | AreModelCategoriesHidden | Indicates if model categories are currently hidden in the view. (Inherited from View)
Public property | ArePointCloudsHidden | Indicates if point clouds are currently hidden in the view. (Inherited from View)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CropBox | The Crop Box applied to the view, or an outline encompassing the crop region applied to the view. (Inherited from View)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | DetailLevel | The detail level of this view. (Inherited from View)
Public property | Discipline | The Discipline of the view. (Inherited from View)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | GenLevel | The level for the view. (Inherited from View)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsAssemblyView | Indicates if the view is assembly view. (Inherited from View)
Public property | IsCallout | Indicates if the view is a callout view. (Inherited from View)
Public property | IsLocked | Indicates if the view is locked.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsPerspective | Identifies whether this is a perspective view.
 | IsSectionBoxActive | Identifies whether or not the section box is active in this 3D view.
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | Origin | Returns the origin of the screen. (Inherited from View)
Public property | Outline | The bounds of the view in paper space (in feet). (Inherited from View)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ProjectGridsOnSectionBox | This option projects all grids from the current 3d view on the bottom face of the section box. Only grids that are inside or intersects the section box
Public property | RevealConstraintsMode | Indicates whether the Reveal Constraints mode is activated in the view. (Inherited from View)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View)
Public property | Scale | The scale of the view. (Inherited from View)
Public property | ShadowIntensity | The intesity of cast shadows - 0 = no shadows, 100 = black. (Inherited from View)
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View)
Public property | SunlightIntensity | The intensity of the simulated (directional) sunlight. 0 = no directional light; maximum value is 100. (Inherited from View)
Public property | TemporaryViewModes | Data of temporary view modes associated with this view. (Inherited from View)
Public property | Title | The view title. This consists of the view name plus other modifiers, such as the view type, sheet number, area scheme, and/or assembly type, depending on the specifics of the view. (Inherited from View)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | ViewTemplateId | The id of the template view that controls this view's parameters. (Inherited from View)
 | ViewType | The type of the view. (Inherited from View)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | AddFilter | Adds a filter to the view. (Inherited from View)
Public method | AllowsAnalysisDisplay | Identifies if this view allows display of Analysis results. (Inherited from View)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of the input view that are not controlled by the current view template. (Inherited from View)
Public method | AreGraphicsOverridesAllowed | Determines if Visibility/Graphics Overriddes can be applied to the view. (Inherited from View)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanApplyColorFillScheme | Checks if the id can be applied as the scheme id of specified category to this view. (Inherited from View)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanCategoryBeHidden | Checks whether the category can be hidden in the view. (Inherited from View)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanEnableTemporaryViewPropertiesMode | Indicates if Temporary View Properties mode can be applied for view in current state. (Inherited from View)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified (Inherited from View)
Public method | CanResetCameraTarget | Checks whether the camera target can be reset for this view.
Public method | CanSaveOrientation | Returns true if the View3D's orientation can be saved, false otherwise.
Public method | CanToggleBetweenPerspectiveAndIsometric | Checks whether this view can toggle between perspective and isometric.
Public method | CanUseDepthCueing | Indicates if view can use Depth Cueing (Inherited from View)
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes (Inherited from View)
Public method | CanViewBeDuplicated | Identifies if this view can be duplicated. (Inherited from View)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View)
 | ConvertToIndependent | Convert the dependent view to independent. (Inherited from View)
 | CreateIsometric | Returns a new isometric View3D.
 | CreatePerspective | Returns a new perspective View3D.
Public method | CreateViewTemplate | Creates a new view template instance from this view instance. (Inherited from View)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View)
Public method | Dispose | (Inherited from Element)
 | Duplicate | Duplicates this view. (Inherited from View)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View)
Public method | EnableTemporaryViewPropertiesMode | Turns Temporary View Properties mode on or off. In this mode, any changes made to the view are temporary and will be discarded once the mode is disabled. (Inherited from View)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetBackground | Returns the current background set for the view. (Inherited from View)
Public method | GetCalloutParentId | Gets ID of the callout parent view. (Inherited from View)
Public method | GetCategoryHidden | Checks if elements of the given category are set to be invisible (hidden) in this view. (Inherited from View)
Public method | GetCategoryOverrides | Gets graphic overrides for a category in view. (Inherited from View)
Public method | GetColorFillSchemeId | Returns id of the color fill scheme element applied to the view. (Inherited from View)
Public method | GetCropRegionShapeManager | Returns an object for managing view crop region shape. (Inherited from View)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View)
Public method | GetDepthCueing | Returns the current depth cueing settings for the view. (Inherited from View)
Public method | GetDirectContext3DHandleOverrides | Returns DirectContext3D handle overrides object for the view. (Inherited from View)
Public method | GetElementOverrides | Gets graphic overrides for an element in the view. (Inherited from View)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFilterOverrides | Gets graphic overrides that a filter applies to the view. (Inherited from View)
Public method | GetFilters | Gets the filters applied to the view. (Inherited from View)
Public method | GetFilterVisibility | Gets the visibility of the elements associated with a filter. (Inherited from View)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIsFilterEnabled | Identifies if the filter is enabled in this view. (Inherited from View)
Public method | GetLevelsThatShowGrids | Returns the list of levels ids where grids are displayed in this 3D view.
 | GetLinkOverrides | Gets the graphic overrides of a RevitLinkType or RevitLinkInstance in view. (Inherited from View)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetModelToProjectionTransforms | Gets the transforms from the model space to the view projection space. (Inherited from View)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetNonControlledTemplateParameterIds | Returns a list of parameters that are not marked as included when this view is used as a template. (Inherited from View)
Public method | GetOrderedFilters | Gets the filters applied to the view in the order they are applied. (Inherited from View)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetOrientation | Gets the current non-saved orientation of the View3D.
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPlacementOnSheetStatus | Determines if this view placed on a sheet completely or partially. (Inherited from View)
Public method | GetPointCloudOverrides | Returns point cloud overrides object for the view. (Inherited from View)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View)
Public method | GetReferenceCallouts | Returns element ids of all reference callouts in the view. (Inherited from View)
Public method | GetReferenceElevations | Returns element ids of all reference elevations in the view. (Inherited from View)
Public method | GetReferenceSections | Returns element ids of all reference sections in the view. (Inherited from View)
 | GetRenderingSettings | Returns the current rendering settings for this 3d view.
Public method | GetSavedOrientation | Gets the saved orientation of the View3D.
Public method | GetSectionBox | Gets a copy of the section box for this 3D view.
Public method | GetSketchyLines | Returns the current sketchy lines settings for the view. (Inherited from View)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTemplateParameterIds | Returns a list of parameter ids that may be controlled when this view is assigned as a template. (Inherited from View)
Public method | GetTemporaryViewPropertiesId | When Temporary View Properties mode is in progress it provides view id that overrode settings for current view. Outside Temporary View Properties mode InvalidElementId will be returned. (Inherited from View)
Public method | GetTemporaryViewPropertiesName | When Temporary View Properties mode is in progress, name of applied template is returned. Outside Temporary View Properties mode, empty string will be returned. (Inherited from View)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetViewDisplayModel | Returns the current view display model settings for the view. (Inherited from View)
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View)
Public method | HasBeenLocked | Identifies if the view has ever been locked.
Public method | HasDetailLevel | Check if the view has a Detail Level property (Inherited from View)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property (Inherited from View)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property (Inherited from View)
Public method | HasViewTransforms | Returns true if the view reports model space to view projection space transforms. (Inherited from View)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View)
Public method | HideGridsOnLevel | This method hides the grid lines in this 3D view on the given Level.
Public method | IsCategoryOverridable | Checks whether the category can have graphic overrides in this view. (Inherited from View)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsFilterApplied | Indicates if a filter is applied to the view. (Inherited from View)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View)
Public method | IsTemporaryViewPropertiesModeEnabled | Returns true when Temporary View Properties mode is in progress, false otherwise. (Inherited from View)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | IsValidViewTemplate | Verifies that the view represented by templateId can be set as the controlling view template for this view. (Inherited from View)
Public method | IsViewValidForTemplateCreation | Verifies that the view is valid for template creation. (Inherited from View)
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | OrientTo | Reorients the view to align with the forward direction.
Public method | Print | Print this view with the default view template and using the print setting of the current active document. (Inherited from View)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveCalloutParent | Replaces callout parent ID with InvalidElementId. (Inherited from View)
Public method | RemoveFilter | Removes a filter from the view. (Inherited from View)
 | RemoveLinkOverrides | Deletes the graphical link overrides in the current view. (Inherited from View)
Public method | ResetCameraTarget | Resets the camera target to the center of the field of view.
Public method | RestoreCalloutParent | Restores callout parent ID to the original view ID if that view is still available. (Inherited from View)
Public method | RestoreOrientationAndLock | Locks the view and restores its orientation.
Public method | SaveOrientation | Converts the temporary orientation of the View3D into its saved orientation.
Public method | SaveOrientationAndLock | Locks the view and saves its orientation
Public method | ScalePerspectiveCropBox | Scale an existing crop box of the perspective view.
Public method | SetBackground | Sets the background for the view. Background can only be set for 3d views and for Sections/Elevations. (Inherited from View)
Public method | SetCategoryHidden | Sets if elements of the given category will be visible in this view. (Inherited from View)
Public method | SetCategoryOverrides | Sets graphic overrides for a category in view. (Inherited from View)
Public method | SetColorFillSchemeId | Applies color fill scheme to this view. (Inherited from View)
Public method | SetDepthCueing | Sets the depth cueing settings for the view. (Inherited from View)
Public method | SetElementOverrides | Sets graphic overrides for an element in the view. (Inherited from View)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
 | SetFilterOverrides | Sets the overrides associated with a filter. (Inherited from View)
Public method | SetFilterVisibility | Sets the visibility of the elements associated with a filter. (Inherited from View)
Public method | SetIsFilterEnabled | Sets the filter enabled flag. (Inherited from View)
 | SetLinkOverrides | Sets the graphic overrides of a RevitLinkType or RevitLinkInstance in the view. (Inherited from View)
Public method | SetNonControlledTemplateParameterIds | Sets the parameters that will not be included when this view is used as a template. (Inherited from View)
Public method | SetOrientation | Sets the temporary orientation of the View3D. The new orientation is not saved in the document.
Public method | SetRenderingSettings | Changes the rendering settings for this 3d view.
 | SetSectionBox | Sets the section box for this 3D view.
Public method | SetSketchyLines | Sets the sketchy lines settings for the view. (Inherited from View)
Public method | SetViewDisplayModel | Sets the view display model settings for the view. (Inherited from View)
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View)
 | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View)
Public method | ShowGridsOnLevel | This method displays the grid lines in this 3DView on the given Level.
Public method | ShowGridsOnLevels | This method displays the grid lines in this 3D view on the given Levels.
Public method | SupportedColorFillCategoryIds | Returns collection of all category ids that correspond to elements that can potentially be colored in this view according to a color fill scheme. The set may be different depending on the view type. (Inherited from View)
Public method | SupportsRevealConstraints | Checks that the view can have the Reveal Constraints mode activated. (Inherited from View)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View)
Public method | ToggleToIsometric | Toggles this view to isometric.
Public method | ToggleToPerspective | Toggles this view to perspective.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View)
Public method | Unlock | Unlocks the view. Has no effect if the view is already unlocked.
Top
Example
C#
VB
C++
F#
Copy
private void Getinfo_View3D(View3D view3D)
{
    string message = "View3D: ";

    // The position of the camera.
    XYZ eyePosition = view3D.GetOrientation().EyePosition;
    message += "\nCamera position: " + eyePosition;

    // Identifies whether the view is a perspective view.
    if (view3D.IsPerspective)
    {
        message += "\nThe view is a perspective view.";
    }

    // The section box of the 3D view can cut the model.
    if (view3D.IsSectionBoxActive)
    {
        BoundingBoxXYZ sectionBox = view3D.GetSectionBox();

        // Note that the section box can be rotated and transformed.
        // So the min/max corners coordinates relative to the model must be computed via the transform.
        Transform trf = sectionBox.Transform;

        XYZ max = sectionBox.Max; //Maximum coordinates (upper-right-front corner of the box before transform is applied).
        XYZ min = sectionBox.Min; //Minimum coordinates (lower-left-rear corner of the box before transform is applied).

        // Transform the min and max to model coordinates
        XYZ maxInModelCoords = trf.OfPoint(max);
        XYZ minInModelCoords = trf.OfPoint(min);

        message += "\nView has an active section box: ";
        message += "\n'Maximum' coordinates: " + maxInModelCoords;
        message += "\n'Minimum' coordinates: " + minInModelCoords;
    }
    TaskDialog.Show("Revit", message);
}
Private Sub Getinfo_View3D(view3D As View3D)
    Dim message As String = "View3D: "
    ' The position of the camera.
    Dim eyePosition As XYZ = view3D.GetOrientation().EyePosition
    message += ((vbLf & "Camera position: (" + eyePosition.X & ", ") + eyePosition.Y & ", ") + eyePosition.Z & ")"

    ' Identifies whether this is a perspective view.
    If view3D.IsPerspective Then
        message += vbLf & "The view is a perspective."
    End If

    ' The section box of the 3D view cuts the model by its bounds.
    Dim sectionBox As BoundingBoxXYZ = view3D.GetSectionBox()
    Dim max As XYZ = sectionBox.Max
    'Maximum coordinates (upper-right-front corner of the box).
    Dim min As XYZ = sectionBox.Min
    'Minimum coordinates (lower-left-rear corner of the box).
    message += vbLf & "Section Box: "
    message += ((vbLf & "Maximum coordinates: (" + max.X & ", ") + max.Y & ", ") + max.Z & ")"
    message += ((vbLf & "Minimum coordinates: (" + min.X & ", ") + min.Y & ", ") + min.Z & ")"

    TaskDialog.Show("Revit", message)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


View3D Properties

The View3D type exposes the following members.

Properties
 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View)
Public property | AreAnalyticalModelCategoriesHidden | Indicates if analytical model categories are currently hidden in the view. (Inherited from View)
Public property | AreAnnotationCategoriesHidden | Indicates if annotation categories are currently hidden in the view. (Inherited from View)
Public property | AreCoordinationModelHandlesHidden | Indicates if Coordination Model handles are currently hidden in the view. (Inherited from View)
Public property | AreImportCategoriesHidden | Indicates if import categories are currently hidden in the view. (Inherited from View)
Public property | AreModelCategoriesHidden | Indicates if model categories are currently hidden in the view. (Inherited from View)
Public property | ArePointCloudsHidden | Indicates if point clouds are currently hidden in the view. (Inherited from View)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CropBox | The Crop Box applied to the view, or an outline encompassing the crop region applied to the view. (Inherited from View)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | DetailLevel | The detail level of this view. (Inherited from View)
Public property | Discipline | The Discipline of the view. (Inherited from View)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | GenLevel | The level for the view. (Inherited from View)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsAssemblyView | Indicates if the view is assembly view. (Inherited from View)
Public property | IsCallout | Indicates if the view is a callout view. (Inherited from View)
Public property | IsLocked | Indicates if the view is locked.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsPerspective | Identifies whether this is a perspective view.
 | IsSectionBoxActive | Identifies whether or not the section box is active in this 3D view.
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | Origin | Returns the origin of the screen. (Inherited from View)
Public property | Outline | The bounds of the view in paper space (in feet). (Inherited from View)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ProjectGridsOnSectionBox | This option projects all grids from the current 3d view on the bottom face of the section box. Only grids that are inside or intersects the section box
Public property | RevealConstraintsMode | Indicates whether the Reveal Constraints mode is activated in the view. (Inherited from View)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View)
Public property | Scale | The scale of the view. (Inherited from View)
Public property | ShadowIntensity | The intesity of cast shadows - 0 = no shadows, 100 = black. (Inherited from View)
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View)
Public property | SunlightIntensity | The intensity of the simulated (directional) sunlight. 0 = no directional light; maximum value is 100. (Inherited from View)
Public property | TemporaryViewModes | Data of temporary view modes associated with this view. (Inherited from View)
Public property | Title | The view title. This consists of the view name plus other modifiers, such as the view type, sheet number, area scheme, and/or assembly type, depending on the specifics of the view. (Inherited from View)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | ViewTemplateId | The id of the template view that controls this view's parameters. (Inherited from View)
 | ViewType | The type of the view. (Inherited from View)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

View3D Class


View3D.IsLocked Property

View3DIsLocked Property

Indicates if the view is locked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsLocked { get; }
Public ReadOnly Property IsLocked As Boolean
    Get
public:
property bool IsLocked {
    bool get ();
}
member IsLocked : bool with get

Property Value

Boolean
Exceptions
Exception | Condition
InvalidOperationException | Returns true if the view is not a view template.
See Also

Reference

View3D Class


View3D.IsPerspective Property

View3DIsPerspective Property

Identifies whether this is a perspective view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsPerspective { get; }
Public ReadOnly Property IsPerspective As Boolean
    Get
public:
property bool IsPerspective {
    bool get ();
}
member IsPerspective : bool with get

Property Value

Boolean
Exceptions
Exception | Condition
InvalidOperationException | Returns true if the view is not a view template.
Remarks
In a perspective view, view direction is variable - it is the direction that connects a particular point on the model with the eye position. The property ViewDirection becomes less meaningful - it only describes the general orientation of the camera.
See Also

Reference

View3D Class


View3D.IsSectionBoxActive Property

View3DIsSectionBoxActive Property

Identifies whether or not the section box is active in this 3D view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSectionBoxActive { get; set; }
Public Property IsSectionBoxActive As Boolean
    Get
    Set
public:
property bool IsSectionBoxActive {
    bool get ();
    void set (bool value);
}
member IsSectionBoxActive : bool with get, set

Property Value

Boolean
An active section box clips the geometry of the model in the 3D view. This affects the appearance of the view, and also will affect information returned from the API. For example:
  • Elements outside the active section box will not be returned in the list of elements obtained from [!:Autodesk::Revit::DB::FilteredElementCollector] when this view is passed when contructing the collector.
  • Elements clipped by the active section box will return clipped geometry from GeometryOptions when this view is included in the options.
Exceptions
Exception | Condition
InvalidOperationException | Returns true if the view is not a view template.
Example
C#
Copy
private void DisableSectionBox(View3D view3d)
{
    if (!view3d.IsSectionBoxActive)
    {
        TaskDialog.Show("Revit", "The section box for View3D isn't active.");
        return;
    }

    // Disable the section box (requires an open transaction)
    view3d.IsSectionBoxActive = false;
}
See Also

Reference

View3D Class


View3D.ProjectGridsOnSectionBox Property

View3DProjectGridsOnSectionBox Property

This option projects all grids from the current 3d view on the bottom face of the section box. Only grids that are inside or intersects the section box

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ProjectGridsOnSectionBox { get; set; }
Public Property ProjectGridsOnSectionBox As Boolean
    Get
    Set
public:
property bool ProjectGridsOnSectionBox {
    bool get ();
    void set (bool value);
}
member ProjectGridsOnSectionBox : bool with get, set

Property Value

Boolean
Exceptions
Exception | Condition
InvalidOperationException | Returns true if the view is not a view template.
See Also

Reference

View3D Class


View3D Methods

The View3D type exposes the following members.

Methods
 | Name | Description
Public method | AddFilter | Adds a filter to the view. (Inherited from View)
Public method | AllowsAnalysisDisplay | Identifies if this view allows display of Analysis results. (Inherited from View)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of the input view that are not controlled by the current view template. (Inherited from View)
Public method | AreGraphicsOverridesAllowed | Determines if Visibility/Graphics Overriddes can be applied to the view. (Inherited from View)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanApplyColorFillScheme | Checks if the id can be applied as the scheme id of specified category to this view. (Inherited from View)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanCategoryBeHidden | Checks whether the category can be hidden in the view. (Inherited from View)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanEnableTemporaryViewPropertiesMode | Indicates if Temporary View Properties mode can be applied for view in current state. (Inherited from View)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified (Inherited from View)
Public method | CanResetCameraTarget | Checks whether the camera target can be reset for this view.
Public method | CanSaveOrientation | Returns true if the View3D's orientation can be saved, false otherwise.
Public method | CanToggleBetweenPerspectiveAndIsometric | Checks whether this view can toggle between perspective and isometric.
Public method | CanUseDepthCueing | Indicates if view can use Depth Cueing (Inherited from View)
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes (Inherited from View)
Public method | CanViewBeDuplicated | Identifies if this view can be duplicated. (Inherited from View)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View)
 | ConvertToIndependent | Convert the dependent view to independent. (Inherited from View)
 | CreateIsometric | Returns a new isometric View3D.
 | CreatePerspective | Returns a new perspective View3D.
Public method | CreateViewTemplate | Creates a new view template instance from this view instance. (Inherited from View)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View)
Public method | Dispose | (Inherited from Element)
 | Duplicate | Duplicates this view. (Inherited from View)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View)
Public method | EnableTemporaryViewPropertiesMode | Turns Temporary View Properties mode on or off. In this mode, any changes made to the view are temporary and will be discarded once the mode is disabled. (Inherited from View)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetBackground | Returns the current background set for the view. (Inherited from View)
Public method | GetCalloutParentId | Gets ID of the callout parent view. (Inherited from View)
Public method | GetCategoryHidden | Checks if elements of the given category are set to be invisible (hidden) in this view. (Inherited from View)
Public method | GetCategoryOverrides | Gets graphic overrides for a category in view. (Inherited from View)
Public method | GetColorFillSchemeId | Returns id of the color fill scheme element applied to the view. (Inherited from View)
Public method | GetCropRegionShapeManager | Returns an object for managing view crop region shape. (Inherited from View)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View)
Public method | GetDepthCueing | Returns the current depth cueing settings for the view. (Inherited from View)
Public method | GetDirectContext3DHandleOverrides | Returns DirectContext3D handle overrides object for the view. (Inherited from View)
Public method | GetElementOverrides | Gets graphic overrides for an element in the view. (Inherited from View)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFilterOverrides | Gets graphic overrides that a filter applies to the view. (Inherited from View)
Public method | GetFilters | Gets the filters applied to the view. (Inherited from View)
Public method | GetFilterVisibility | Gets the visibility of the elements associated with a filter. (Inherited from View)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIsFilterEnabled | Identifies if the filter is enabled in this view. (Inherited from View)
Public method | GetLevelsThatShowGrids | Returns the list of levels ids where grids are displayed in this 3D view.
 | GetLinkOverrides | Gets the graphic overrides of a RevitLinkType or RevitLinkInstance in view. (Inherited from View)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetModelToProjectionTransforms | Gets the transforms from the model space to the view projection space. (Inherited from View)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetNonControlledTemplateParameterIds | Returns a list of parameters that are not marked as included when this view is used as a template. (Inherited from View)
Public method | GetOrderedFilters | Gets the filters applied to the view in the order they are applied. (Inherited from View)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetOrientation | Gets the current non-saved orientation of the View3D.
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPlacementOnSheetStatus | Determines if this view placed on a sheet completely or partially. (Inherited from View)
Public method | GetPointCloudOverrides | Returns point cloud overrides object for the view. (Inherited from View)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View)
Public method | GetReferenceCallouts | Returns element ids of all reference callouts in the view. (Inherited from View)
Public method | GetReferenceElevations | Returns element ids of all reference elevations in the view. (Inherited from View)
Public method | GetReferenceSections | Returns element ids of all reference sections in the view. (Inherited from View)
 | GetRenderingSettings | Returns the current rendering settings for this 3d view.
Public method | GetSavedOrientation | Gets the saved orientation of the View3D.
Public method | GetSectionBox | Gets a copy of the section box for this 3D view.
Public method | GetSketchyLines | Returns the current sketchy lines settings for the view. (Inherited from View)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTemplateParameterIds | Returns a list of parameter ids that may be controlled when this view is assigned as a template. (Inherited from View)
Public method | GetTemporaryViewPropertiesId | When Temporary View Properties mode is in progress it provides view id that overrode settings for current view. Outside Temporary View Properties mode InvalidElementId will be returned. (Inherited from View)
Public method | GetTemporaryViewPropertiesName | When Temporary View Properties mode is in progress, name of applied template is returned. Outside Temporary View Properties mode, empty string will be returned. (Inherited from View)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetViewDisplayModel | Returns the current view display model settings for the view. (Inherited from View)
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View)
Public method | HasBeenLocked | Identifies if the view has ever been locked.
Public method | HasDetailLevel | Check if the view has a Detail Level property (Inherited from View)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property (Inherited from View)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property (Inherited from View)
Public method | HasViewTransforms | Returns true if the view reports model space to view projection space transforms. (Inherited from View)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View)
Public method | HideGridsOnLevel | This method hides the grid lines in this 3D view on the given Level.
Public method | IsCategoryOverridable | Checks whether the category can have graphic overrides in this view. (Inherited from View)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsFilterApplied | Indicates if a filter is applied to the view. (Inherited from View)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View)
Public method | IsTemporaryViewPropertiesModeEnabled | Returns true when Temporary View Properties mode is in progress, false otherwise. (Inherited from View)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | IsValidViewTemplate | Verifies that the view represented by templateId can be set as the controlling view template for this view. (Inherited from View)
Public method | IsViewValidForTemplateCreation | Verifies that the view is valid for template creation. (Inherited from View)
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | OrientTo | Reorients the view to align with the forward direction.
Public method | Print | Print this view with the default view template and using the print setting of the current active document. (Inherited from View)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveCalloutParent | Replaces callout parent ID with InvalidElementId. (Inherited from View)
Public method | RemoveFilter | Removes a filter from the view. (Inherited from View)
 | RemoveLinkOverrides | Deletes the graphical link overrides in the current view. (Inherited from View)
Public method | ResetCameraTarget | Resets the camera target to the center of the field of view.
Public method | RestoreCalloutParent | Restores callout parent ID to the original view ID if that view is still available. (Inherited from View)
Public method | RestoreOrientationAndLock | Locks the view and restores its orientation.
Public method | SaveOrientation | Converts the temporary orientation of the View3D into its saved orientation.
Public method | SaveOrientationAndLock | Locks the view and saves its orientation
Public method | ScalePerspectiveCropBox | Scale an existing crop box of the perspective view.
Public method | SetBackground | Sets the background for the view. Background can only be set for 3d views and for Sections/Elevations. (Inherited from View)
Public method | SetCategoryHidden | Sets if elements of the given category will be visible in this view. (Inherited from View)
Public method | SetCategoryOverrides | Sets graphic overrides for a category in view. (Inherited from View)
Public method | SetColorFillSchemeId | Applies color fill scheme to this view. (Inherited from View)
Public method | SetDepthCueing | Sets the depth cueing settings for the view. (Inherited from View)
Public method | SetElementOverrides | Sets graphic overrides for an element in the view. (Inherited from View)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
 | SetFilterOverrides | Sets the overrides associated with a filter. (Inherited from View)
Public method | SetFilterVisibility | Sets the visibility of the elements associated with a filter. (Inherited from View)
Public method | SetIsFilterEnabled | Sets the filter enabled flag. (Inherited from View)
 | SetLinkOverrides | Sets the graphic overrides of a RevitLinkType or RevitLinkInstance in the view. (Inherited from View)
Public method | SetNonControlledTemplateParameterIds | Sets the parameters that will not be included when this view is used as a template. (Inherited from View)
Public method | SetOrientation | Sets the temporary orientation of the View3D. The new orientation is not saved in the document.
Public method | SetRenderingSettings | Changes the rendering settings for this 3d view.
 | SetSectionBox | Sets the section box for this 3D view.
Public method | SetSketchyLines | Sets the sketchy lines settings for the view. (Inherited from View)
Public method | SetViewDisplayModel | Sets the view display model settings for the view. (Inherited from View)
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View)
 | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View)
Public method | ShowGridsOnLevel | This method displays the grid lines in this 3DView on the given Level.
Public method | ShowGridsOnLevels | This method displays the grid lines in this 3D view on the given Levels.
Public method | SupportedColorFillCategoryIds | Returns collection of all category ids that correspond to elements that can potentially be colored in this view according to a color fill scheme. The set may be different depending on the view type. (Inherited from View)
Public method | SupportsRevealConstraints | Checks that the view can have the Reveal Constraints mode activated. (Inherited from View)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View)
Public method | ToggleToIsometric | Toggles this view to isometric.
Public method | ToggleToPerspective | Toggles this view to perspective.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View)
Public method | Unlock | Unlocks the view. Has no effect if the view is already unlocked.
Top
See Also

Reference

View3D Class


View3D.CanResetCameraTarget Method

View3DCanResetCameraTarget Method

Checks whether the camera target can be reset for this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanResetCameraTarget()
Public Function CanResetCameraTarget As Boolean
public:
bool CanResetCameraTarget()
member CanResetCameraTarget : unit -> bool

Return Value

Boolean
True if camera target can be reset for this view, false otherwise.
Remarks
The camera target can only be reset for perspective view.
See Also

Reference

View3D Class


View3D.CanSaveOrientation Method

View3DCanSaveOrientation Method

Returns true if the View3D's orientation can be saved, false otherwise.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanSaveOrientation()
Public Function CanSaveOrientation As Boolean
public:
bool CanSaveOrientation()
member CanSaveOrientation : unit -> bool

Return Value

Boolean
True if the View3D's orientation can be saved, false otherwise.
Remarks
The saved orientation of the default 3D view cannot be overwritten. To convert the default 3D view into a normal 3D view, rename the default 3D view.
See Also

Reference

View3D Class


View3D.CanToggleBetweenPerspectiveAndIsometric Method

View3DCanToggleBetweenPerspectiveAndIsometric Method

Checks whether this view can toggle between perspective and isometric.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanToggleBetweenPerspectiveAndIsometric()
Public Function CanToggleBetweenPerspectiveAndIsometric As Boolean
public:
bool CanToggleBetweenPerspectiveAndIsometric()
member CanToggleBetweenPerspectiveAndIsometric : unit -> bool

Return Value

Boolean
True if this view can be toggled, false otherwise.
Remarks
This view can only be toggled if no view specific elements are contained.
See Also

Reference

View3D Class


View3D.CreateIsometric Method

View3DCreateIsometric Method

Returns a new isometric View3D.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static View3D CreateIsometric(
    Document document,
    ElementId viewFamilyTypeId
)
Public Shared Function CreateIsometric (
    document As Document,
    viewFamilyTypeId As ElementId
) As View3D
public:
static View3D^ CreateIsometric(
    Document^ document,
    ElementId^ viewFamilyTypeId
)
static member CreateIsometric :
        document : Document *
        viewFamilyTypeId : ElementId -> View3D

Parameters

document Document
The document to which the new View3D will be added.
viewFamilyTypeId ElementId
The id of the ViewFamilyType which will be used by the new View3D. The type needs to be a ThreeDimensional ViewType.

Return Value

View3D
The new isometric View3D.
Exceptions
Exception | Condition
ArgumentException | This View Family Type is not a ThreeDimensional view type. -or- 3D view creation is not allowed in this family.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
The new View3D will receive a unique view name. The view will be oriented in the same position as the default 3D view.
Example
VB
Copy
' Find a 3D view type
Dim collector1 As New FilteredElementCollector(document)
collector1 = collector1.OfClass(GetType(ViewFamilyType))
Dim viewFamilyTypes As IEnumerable(Of ViewFamilyType)

viewFamilyTypes = From elem In collector1 _
                  Let vftype = TryCast(elem, ViewFamilyType) _
                  Where vftype.ViewFamily = ViewFamily.ThreeDimensional _
                  Select vftype
' Create a new View3D
Dim view3D__1 As View3D = View3D.CreateIsometric(document, viewFamilyTypes.First().Id)
If view3D__1 IsNot Nothing Then
    ' By default, the 3D view uses a default orientation.
    ' Change the orientation by creating and setting a ViewOrientation3D
    Dim eye As New XYZ(10, 10, 10)
    Dim up As New XYZ(0, 1, 1)
    Dim forward As New XYZ(0, 1, -1)
    Dim viewOrientation3D As New ViewOrientation3D(eye, up, forward)
    view3D__1.SetOrientation(viewOrientation3D)
End If
See Also

Reference

View3D Class


View3D.CreatePerspective Method

View3DCreatePerspective Method

Returns a new perspective View3D.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static View3D CreatePerspective(
    Document document,
    ElementId viewFamilyTypeId
)
Public Shared Function CreatePerspective (
    document As Document,
    viewFamilyTypeId As ElementId
) As View3D
public:
static View3D^ CreatePerspective(
    Document^ document,
    ElementId^ viewFamilyTypeId
)
static member CreatePerspective :
        document : Document *
        viewFamilyTypeId : ElementId -> View3D

Parameters

document Document
The document to which the new View3D will be added.
viewFamilyTypeId ElementId
The id of the ViewFamilyType which will be used by the new View3D. The type needs to be a ThreeDimensional ViewType.

Return Value

View3D
The new perspective View3D.
Exceptions
Exception | Condition
ArgumentException | This View Family Type is not a ThreeDimensional view type. -or- 3D view creation is not allowed in this family.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
The new View3D will receive a unique view name. The view will be oriented in the same position as the default 3D view.
Example
VB
Copy
' Find a 3D view type
Dim collector1 As New FilteredElementCollector(document)
collector1 = collector1.OfClass(GetType(ViewFamilyType))
Dim viewFamilyTypes As IEnumerable(Of ViewFamilyType)

viewFamilyTypes = From elem In collector1 _
                  Let vftype = TryCast(elem, ViewFamilyType) _
                  Where vftype.ViewFamily = ViewFamily.ThreeDimensional _
                  Select vftype
' Create a new Perspective View3D
Dim view3D__1 As View3D = View3D.CreatePerspective(document, viewFamilyTypes.First().Id)
If view3D__1 IsNot Nothing Then
    ' By default, the 3D view uses a default orientation.
    ' Change the orientation by creating and setting a ViewOrientation3D
    Dim eye As New XYZ(0, -100, 10)
    Dim up As New XYZ(0, 0, 1)
    Dim forward As New XYZ(0, 1, 0)
    view3D__1.SetOrientation(New ViewOrientation3D(eye, up, forward))

    ' turn off the far clip plane with standard parameter API
    Dim farClip As Parameter = view3D__1.LookupParameter("Far Clip Active")
    farClip.[Set](0)
End If
See Also

Reference

View3D Class


View3D.GetLevelsThatShowGrids Method

View3DGetLevelsThatShowGrids Method

Returns the list of levels ids where grids are displayed in this 3D view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ISet<ElementId> GetLevelsThatShowGrids()
Public Function GetLevelsThatShowGrids As ISet(Of ElementId)
public:
ISet<ElementId^>^ GetLevelsThatShowGrids()
member GetLevelsThatShowGrids : unit -> ISet<ElementId>

Return Value

ISet ElementId
The list of levels ids where grids are displayed in 3D views.
See Also

Reference

View3D Class


View3D.GetOrientation Method

View3DGetOrientation Method

Gets the current non-saved orientation of the View3D.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ViewOrientation3D GetOrientation()
Public Function GetOrientation As ViewOrientation3D
public:
ViewOrientation3D^ GetOrientation()
member GetOrientation : unit -> ViewOrientation3D

Return Value

ViewOrientation3D
The current non-saved orientation of the View3D.
See Also

Reference

View3D Class


View3D.GetRenderingSettings Method

View3DGetRenderingSettings Method

Returns the current rendering settings for this 3d view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RenderingSettings GetRenderingSettings()
Public Function GetRenderingSettings As RenderingSettings
public:
RenderingSettings^ GetRenderingSettings()
member GetRenderingSettings : unit -> RenderingSettings

Return Value

RenderingSettings
The returned object represents the current rendering settings. If you change the returned object, you need to call SetRenderingSettings to apply the new settings back to Revit.
Example
C#
VB
C++
F#
Copy
public RenderingSettings GetFirstRenderingSettings(Document document)
{
    // RenderingSettings isn't used to support family document.
    if (document.IsFamilyDocument)
        return null;

    // Get 3d view
    List<View3D> theView3Ds = new List<View3D>();
    foreach (View3D view3D in RetrieveElementByType<View3D>(document))
    {
        // It's strongly recommend to get  RenderingSettings from visible 3d view,
        // although it can retrieve data from an invisible one,
        if (view3D.IsTemplate || !view3D.CanBePrinted)
            continue;
        return view3D.GetRenderingSettings();
    }
    return null;
}

public static List<T> RetrieveElementByType<T>(Document document) where T : Autodesk.Revit.DB.Element
{
    FilteredElementCollector collector = new FilteredElementCollector(document);
    return collector.OfClass(typeof(T)).Cast<T>().ToList<T>();
}
Public Function GetFirstRenderingSettings(document As Document) As RenderingSettings
   ' RenderingSettings isn't used to support family document.
   If document.IsFamilyDocument Then
      Return Nothing
   End If

   ' Get 3d view
   Dim theView3Ds As New List(Of View3D)()
   For Each view3D As View3D In RetrieveElementByType(Of View3D)(document)
      ' It's strongly recommend to get  RenderingSettings from visible 3d view,
      ' although it can retrieve data from an invisible one,
      If view3D.IsTemplate OrElse Not view3D.CanBePrinted Then
         Continue For
      End If
      Return view3D.GetRenderingSettings()
   Next
   Return Nothing
End Function

Public Shared Function RetrieveElementByType(Of T As Autodesk.Revit.DB.Element)(document As Document) As List(Of T)
   Dim collector As New FilteredElementCollector(document)
   Return collector.OfClass(GetType(T)).Cast(Of T)().ToList()
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

View3D Class


View3D.GetSavedOrientation Method

View3DGetSavedOrientation Method

Gets the saved orientation of the View3D.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ViewOrientation3D GetSavedOrientation()
Public Function GetSavedOrientation As ViewOrientation3D
public:
ViewOrientation3D^ GetSavedOrientation()
member GetSavedOrientation : unit -> ViewOrientation3D

Return Value

ViewOrientation3D
The saved orientation of the View3D.
See Also

Reference

View3D Class


View3D.GetSectionBox Method

View3DGetSectionBox Method

Gets a copy of the section box for this 3D view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BoundingBoxXYZ GetSectionBox()
Public Function GetSectionBox As BoundingBoxXYZ
public:
BoundingBoxXYZ^ GetSectionBox()
member GetSectionBox : unit -> BoundingBoxXYZ

Return Value

BoundingBoxXYZ
The section box. Note that the section box can be rotated and transformed and thus you will need to use [!:Autodesk::Revit::DB::BoundingBoxXYZ::Transform] to interpret the coordinates of the corners or sides of the box in model coordinates.
Exceptions
Exception | Condition
InvalidOperationException | Returns true if the view is not a view template.
Remarks
The section box cuts the model in this view by its boundaries.
See Also

Reference

View3D Class


View3D.HasBeenLocked Method

View3DHasBeenLocked Method

Identifies if the view has ever been locked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasBeenLocked()
Public Function HasBeenLocked As Boolean
public:
bool HasBeenLocked()
member HasBeenLocked : unit -> bool

Return Value

Boolean
See Also

Reference

View3D Class


View3D.HideGridsOnLevel Method

View3DHideGridsOnLevel Method

This method hides the grid lines in this 3D view on the given Level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void HideGridsOnLevel(
    ElementId levelId
)
Public Sub HideGridsOnLevel (
    levelId As ElementId
)
public:
void HideGridsOnLevel(
    ElementId^ levelId
)
member HideGridsOnLevel :
        levelId : ElementId -> unit

Parameters

levelId ElementId
The id of the Level where grids will not be displayed.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

View3D Class


View3D.OrientTo Method

View3DOrientTo Method

Reorients the view to align with the forward direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void OrientTo(
    XYZ forwardDirection
)
Public Sub OrientTo (
    forwardDirection As XYZ
)
public:
void OrientTo(
    XYZ^ forwardDirection
)
member OrientTo :
        forwardDirection : XYZ -> unit

Parameters

forwardDirection XYZ
The forward direction.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | forwardDirection has zero length.
InvalidOperationException | View is locked and cannot be reoriented.
Remarks
This method adjusts the ViewOrientation to align with the input forward direction. The eye position will be automatically determined based on the shape of the viewing area and size of the model. The UpDirection will be aligned with the project Z axis.
See Also

Reference

View3D Class


View3D.ResetCameraTarget Method

View3DResetCameraTarget Method

Resets the camera target to the center of the field of view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ResetCameraTarget()
Public Sub ResetCameraTarget
public:
void ResetCameraTarget()
member ResetCameraTarget : unit -> unit
Exceptions
Exception | Condition
InvalidOperationException | The camera target cannot be reset for the view.
Remarks
The camera target can only be reset for perspective view.
See Also

Reference

View3D Class


View3D.RestoreOrientationAndLock Method

View3DRestoreOrientationAndLock Method

Locks the view and restores its orientation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RestoreOrientationAndLock()
Public Sub RestoreOrientationAndLock
public:
void RestoreOrientationAndLock()
member RestoreOrientationAndLock : unit -> unit
Exceptions
Exception | Condition
InvalidOperationException | View has never been locked.
See Also

Reference

View3D Class


View3D.SaveOrientation Method

View3DSaveOrientation Method

Converts the temporary orientation of the View3D into its saved orientation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SaveOrientation()
Public Sub SaveOrientation
public:
void SaveOrientation()
member SaveOrientation : unit -> unit
Exceptions
Exception | Condition
InvalidOperationException | The orientation of the View3D cannot be saved.
Remarks
The View3D will be oriented to its saved orientation on file open. To save the orientation of the default View3D, first rename the default View3D.
See Also

Reference

View3D Class


View3D.SaveOrientationAndLock Method

View3DSaveOrientationAndLock Method

Locks the view and saves its orientation

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SaveOrientationAndLock()
Public Sub SaveOrientationAndLock
public:
void SaveOrientationAndLock()
member SaveOrientationAndLock : unit -> unit
Exceptions
Exception | Condition
InvalidOperationException | Returns true if the view is not a view template. -or- The orientation of the View3D cannot be saved.
See Also

Reference

View3D Class


View3D.ScalePerspectiveCropBox Method

View3DScalePerspectiveCropBox Method

Scale an existing crop box of the perspective view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ScalePerspectiveCropBox(
    double multiplier
)
Public Sub ScalePerspectiveCropBox (
    multiplier As Double
)
public:
void ScalePerspectiveCropBox(
    double multiplier
)
member ScalePerspectiveCropBox :
        multiplier : float -> unit

Parameters

multiplier Double
Multiplier to change the view scale and the current crop box size on both X and Y.
Exceptions
Exception | Condition
InvalidOperationException | Returns true if the view is not a view template.
Remarks
Remarks

In addition to changing the view crop box, this operation also makes the change analogous to changing the scale of the orthographic view, so that both the size and scale of the view on a sheet changes according to the provided argument 'multiplier'.

For getting or setting view crop box size use property CropBox

See Also

Reference

View3D Class


View3D.SetOrientation Method

View3DSetOrientation Method

Sets the temporary orientation of the View3D. The new orientation is not saved in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetOrientation(
    ViewOrientation3D newViewOrientation3D
)
Public Sub SetOrientation (
    newViewOrientation3D As ViewOrientation3D
)
public:
void SetOrientation(
    ViewOrientation3D^ newViewOrientation3D
)
member SetOrientation :
        newViewOrientation3D : ViewOrientation3D -> unit

Parameters

newViewOrientation3D ViewOrientation3D
The new orientation to set.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | View is locked and cannot be reoriented.
See Also

Reference

View3D Class


View3D.SetRenderingSettings Method

View3DSetRenderingSettings Method

Changes the rendering settings for this 3d view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetRenderingSettings(
    RenderingSettings settings
)
Public Sub SetRenderingSettings (
    settings As RenderingSettings
)
public:
void SetRenderingSettings(
    RenderingSettings^ settings
)
member SetRenderingSettings :
        settings : RenderingSettings -> unit

Parameters

settings RenderingSettings
The new rendering settings to be applied to this view.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

View3D Class


View3D.SetSectionBox Method

View3DSetSectionBox Method

Sets the section box for this 3D view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetSectionBox(
    BoundingBoxXYZ boundingBoxXYZ
)
Public Sub SetSectionBox (
    boundingBoxXYZ As BoundingBoxXYZ
)
public:
void SetSectionBox(
    BoundingBoxXYZ^ boundingBoxXYZ
)
member SetSectionBox :
        boundingBoxXYZ : BoundingBoxXYZ -> unit

Parameters

boundingBoxXYZ BoundingBoxXYZ
The bounding box to use for the section box. To turn off the section box, set IsSectionBoxActive to false. Individual bound enabled flags in the input box are ignored.
Exceptions
Exception | Condition
ArgumentException | Bounding box cannot be empty.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Returns true if the view is not a view template.
Example
C#
Copy
private void ExpandSectionBox(View3D view)
{
    // The original section box
    BoundingBoxXYZ sectionBox = view.GetSectionBox();

    // Expand the section box (doubling in size in all directions while preserving the same center and orientation)
    Autodesk.Revit.DB.XYZ deltaXYZ = sectionBox.Max - sectionBox.Min;
    sectionBox.Max += deltaXYZ / 2;
    sectionBox.Min -= deltaXYZ / 2;

    //After resetting the section box, it will be shown in the view.
    //It only works when the Section Box is active
    view.SetSectionBox(sectionBox);
}
See Also

Reference

View3D Class


View3D.ShowGridsOnLevel Method

View3DShowGridsOnLevel Method

This method displays the grid lines in this 3DView on the given Level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ShowGridsOnLevel(
    ElementId levelId
)
Public Sub ShowGridsOnLevel (
    levelId As ElementId
)
public:
void ShowGridsOnLevel(
    ElementId^ levelId
)
member ShowGridsOnLevel :
        levelId : ElementId -> unit

Parameters

levelId ElementId
The id of the Level where grids should be displayed.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Grids will be displayed only if they intersects Level's plane.
See Also

Reference

View3D Class


View3D.ShowGridsOnLevels Method

View3DShowGridsOnLevels Method

This method displays the grid lines in this 3D view on the given Levels.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ShowGridsOnLevels(
    ISet<ElementId> levelsIds
)
Public Sub ShowGridsOnLevels (
    levelsIds As ISet(Of ElementId)
)
public:
void ShowGridsOnLevels(
    ISet<ElementId^>^ levelsIds
)
member ShowGridsOnLevels :
        levelsIds : ISet<ElementId> -> unit

Parameters

levelsIds ISet ElementId
Levels ids where grids lines will be displayed.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Previously selected Levels for showing grids will be replaced with the new ids.
See Also

Reference

View3D Class


View3D.ToggleToIsometric Method

View3DToggleToIsometric Method

Toggles this view to isometric.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ToggleToIsometric()
Public Sub ToggleToIsometric
public:
void ToggleToIsometric()
member ToggleToIsometric : unit -> unit
Exceptions
Exception | Condition
InvalidOperationException | This view cannot be toggled.
Remarks
This view can only be toggled to isometric if no view specific elements are contained.
See Also

Reference

View3D Class


View3D.ToggleToPerspective Method

View3DToggleToPerspective Method

Toggles this view to perspective.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ToggleToPerspective()
Public Sub ToggleToPerspective
public:
void ToggleToPerspective()
member ToggleToPerspective : unit -> unit
Exceptions
Exception | Condition
InvalidOperationException | This view cannot be toggled.
Remarks
This view can only be toggled to perspective if no view specific elements are contained.
See Also

Reference

View3D Class


View3D.Unlock Method

View3DUnlock Method

Unlocks the view. Has no effect if the view is already unlocked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Unlock()
Public Sub Unlock
public:
void Unlock()
member Unlock : unit -> unit
See Also

Reference

View3D Class


ViewCropRegionShapeManager Class

A class that provides access to settings related to the crop assigned to a view or a reference callout.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBViewCropRegionShapeManager

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ViewCropRegionShapeManager : IDisposable
Public Class ViewCropRegionShapeManager
    Implements IDisposable
public ref class ViewCropRegionShapeManager : IDisposable
type ViewCropRegionShapeManager =
    class
        interface IDisposable
    end

The ViewCropRegionShapeManager type exposes the following members.

Properties
 | Name | Description
Public property | BottomAnnotationCropOffset | The offset from the bottom of the view crop that determines the location of the annotation crop bottom boundary.
Public property | CanBeSplit | Verifies that the crop of the associated view is permitted to have multiple regions.
Public property | CanHaveAnnotationCrop | Verifies that the view is allowed to have an annotation crop.
Public property | CanHaveShape | Verifies that the crop of the associated view is permitted to have a non-rectangular shape.
Public property | IsSplitHorizontally | Whether or not the view's crop is split (and the split is horizontal).
Public property | IsSplitVertically | Whether or not the view's crop is split (and the split is vertical).
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LeftAnnotationCropOffset | The offset from the left of the view crop that determines the location of the annotation crop left boundary.
Public property | NumberOfSplitRegions | The number of split crop regions (1 if the crop is not currently split).
Public property | RightAnnotationCropOffset | The offset from the right of the view crop that determines the location of the annotation crop right boundary.
Public property | ShapeSet | Whether or not the view crop has a non-rectangular shape set.
Public property | Split | Whether or not the view crop is split.
Public property | TopAnnotationCropOffset | The offset from the top of the view crop that determines the location of the annotation crop top boundary.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ViewCropRegionShapeManager
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAnnotationCropShape | Gets the annotation crop box assigned to the view.
Public method | GetCropShape | Gets the crop boundaries that are curently active.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetSplitRegionMaximum | Returns the proportional location of the maximum boundary of the specified split crop region.
Public method | GetSplitRegionMinimum | Returns the proportional location of the minimum boundary of the specified split crop region.
Public method | GetSplitRegionOffset | Returns the offset for the specified split crop region.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsCropRegionShapeValid | Verifies that boundary represents one closed curve loop without self-intersections, consisting of non-zero length straight lines in a plane parallel to the view plane.
Public method | RemoveCropRegionShape | Removes any non-rectangular boundary of the view's crop.
Public method | RemoveSplit | Removes any split applied to the view's crop.
Public method | RemoveSplitRegion | Removes one region in split crop.
Public method | SetCropShape | Sets the boundary of the view's crop to the specified shape.
Public method | SplitRegionHorizontally | Splits horizontally one region in split crop.
Public method | SplitRegionVertically | Splits vertically one region in split crop.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

This class manages all the settings that make up the model and annotation crop geometry for a given view or reference callout. You can obtain the settings for a view from GetCropRegionShapeManager. Obtain the settings for a reference callout from GetCropRegionShapeManagerForReferenceCallout(Document, ElementId).

The model crop region crops model elements, detail elements (such as insulation and detail lines), section boxes, and scope boxes at the model crop boundary. Visible crop boundaries of other related views are also cropped at the model crop boundary. The model crop region can be set as a polygonal boundary, a rectangular boundary, or rectangular boundary with one or more splits applied either horizontally or vertically. If a split is applied to the rectangular crop each resulting rectangular region is identified by a region index and occupies a percentage of the original crop rectangle. The regions may possibly be moved relative to one another.

The annotation crop region fully crops annotation elements when it touches any portion of the annotation element, so that no partial annotations are drawn. Annotations (such as symbols, tags, keynotes, and dimensions) that reference hidden or cropped model elements do not display in the view, even if they are inside the annotation crop region. The annotation crop region is always rectangular and at minimum occupies the same area as the rectangular model crop (or the corresponding rectangular boundary around the non-rectangular model crop), but can be offset to be bigger than the model crop in order to display more annotations.

Example
C#
VB
C++
F#
Copy
public void CropAroundRoom(Room room, View view)
{
    if (view != null)
    {
        IList<IList<Autodesk.Revit.DB.BoundarySegment>> segments = room.GetBoundarySegments(new SpatialElementBoundaryOptions());

        if (null != segments)  //the room may not be bound
        {
            foreach (IList<Autodesk.Revit.DB.BoundarySegment> segmentList in segments)
            {
                CurveLoop loop = new CurveLoop();
                foreach (Autodesk.Revit.DB.BoundarySegment boundarySegment in segmentList)
                {
                    loop.Append(boundarySegment.GetCurve());
                }

                ViewCropRegionShapeManager vcrShapeMgr = view.GetCropRegionShapeManager();
                vcrShapeMgr.SetCropShape(loop);
                break;  // if more than one set of boundary segments for room, crop around the first one
            }
        }
    }
}
Public Sub CropAroundRoom(room As Room, view As View)
    If view IsNot Nothing Then
        Dim segments As IList(Of IList(Of Autodesk.Revit.DB.BoundarySegment)) = room.GetBoundarySegments(New SpatialElementBoundaryOptions())

        If segments IsNot Nothing Then
            'the room may not be bound
            For Each segmentList As IList(Of Autodesk.Revit.DB.BoundarySegment) In segments
                Dim [loop] As New CurveLoop()
                For Each boundarySegment As Autodesk.Revit.DB.BoundarySegment In segmentList
                    [loop].Append(boundarySegment.GetCurve())
                Next

                Dim vcrShapeMgr As ViewCropRegionShapeManager = view.GetCropRegionShapeManager()
                vcrShapeMgr.SetCropShape([loop])
                    ' if more than one set of boundary segments for room, crop around the first one
                Exit For
            Next
        End If
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ViewCropRegionShapeManager Properties

The ViewCropRegionShapeManager type exposes the following members.

Properties
 | Name | Description
Public property | BottomAnnotationCropOffset | The offset from the bottom of the view crop that determines the location of the annotation crop bottom boundary.
Public property | CanBeSplit | Verifies that the crop of the associated view is permitted to have multiple regions.
Public property | CanHaveAnnotationCrop | Verifies that the view is allowed to have an annotation crop.
Public property | CanHaveShape | Verifies that the crop of the associated view is permitted to have a non-rectangular shape.
Public property | IsSplitHorizontally | Whether or not the view's crop is split (and the split is horizontal).
Public property | IsSplitVertically | Whether or not the view's crop is split (and the split is vertical).
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LeftAnnotationCropOffset | The offset from the left of the view crop that determines the location of the annotation crop left boundary.
Public property | NumberOfSplitRegions | The number of split crop regions (1 if the crop is not currently split).
Public property | RightAnnotationCropOffset | The offset from the right of the view crop that determines the location of the annotation crop right boundary.
Public property | ShapeSet | Whether or not the view crop has a non-rectangular shape set.
Public property | Split | Whether or not the view crop is split.
Public property | TopAnnotationCropOffset | The offset from the top of the view crop that determines the location of the annotation crop top boundary.
Top
See Also

Reference

ViewCropRegionShapeManager Class


ViewCropRegionShapeManager.BottomAnnotationCropOffset Property

ViewCropRegionShapeManagerBottomAnnotationCropOffset Property

The offset from the bottom of the view crop that determines the location of the annotation crop bottom boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double BottomAnnotationCropOffset { get; set; }
Public Property BottomAnnotationCropOffset As Double
    Get
    Set
public:
property double BottomAnnotationCropOffset {
    double get ();
    void set (double value);
}
member BottomAnnotationCropOffset : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The given value for offset must be non-negative.
InvalidOperationException | View is not allowed to have an annotation crop.
Remarks
This value must be a non-negative length in view units. Default value is 1/12' (1"), minimal value is 1/96' (1/8"). To get offset in model units, multiply the value by the view scale.
See Also

Reference

ViewCropRegionShapeManager Class


ViewCropRegionShapeManager.CanBeSplit Property

ViewCropRegionShapeManagerCanBeSplit Property

Verifies that the crop of the associated view is permitted to have multiple regions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanBeSplit { get; }
Public ReadOnly Property CanBeSplit As Boolean
    Get
public:
property bool CanBeSplit {
    bool get ();
}
member CanBeSplit : bool with get

Property Value

Boolean
See Also

Reference

ViewCropRegionShapeManager Class


ViewCropRegionShapeManager.CanHaveAnnotationCrop Property

ViewCropRegionShapeManagerCanHaveAnnotationCrop Property

Verifies that the view is allowed to have an annotation crop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanHaveAnnotationCrop { get; }
Public ReadOnly Property CanHaveAnnotationCrop As Boolean
    Get
public:
property bool CanHaveAnnotationCrop {
    bool get ();
}
member CanHaveAnnotationCrop : bool with get

Property Value

Boolean
See Also

Reference

ViewCropRegionShapeManager Class


ViewCropRegionShapeManager.CanHaveShape Property

ViewCropRegionShapeManagerCanHaveShape Property

Verifies that the crop of the associated view is permitted to have a non-rectangular shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanHaveShape { get; }
Public ReadOnly Property CanHaveShape As Boolean
    Get
public:
property bool CanHaveShape {
    bool get ();
}
member CanHaveShape : bool with get

Property Value

Boolean
See Also

Reference

ViewCropRegionShapeManager Class


ViewCropRegionShapeManager.IsSplitHorizontally Property

ViewCropRegionShapeManagerIsSplitHorizontally Property

Whether or not the view's crop is split (and the split is horizontal).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSplitHorizontally { get; }
Public ReadOnly Property IsSplitHorizontally As Boolean
    Get
public:
property bool IsSplitHorizontally {
    bool get ();
}
member IsSplitHorizontally : bool with get

Property Value

Boolean
See Also

Reference

ViewCropRegionShapeManager Class


ViewCropRegionShapeManager.IsSplitVertically Property

ViewCropRegionShapeManagerIsSplitVertically Property

Whether or not the view's crop is split (and the split is vertical).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSplitVertically { get; }
Public ReadOnly Property IsSplitVertically As Boolean
    Get
public:
property bool IsSplitVertically {
    bool get ();
}
member IsSplitVertically : bool with get

Property Value

Boolean
See Also

Reference

ViewCropRegionShapeManager Class


ViewCropRegionShapeManager.IsValidObject Property

ViewCropRegionShapeManagerIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ViewCropRegionShapeManager Class


ViewCropRegionShapeManager.LeftAnnotationCropOffset Property

ViewCropRegionShapeManagerLeftAnnotationCropOffset Property

The offset from the left of the view crop that determines the location of the annotation crop left boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double LeftAnnotationCropOffset { get; set; }
Public Property LeftAnnotationCropOffset As Double
    Get
    Set
public:
property double LeftAnnotationCropOffset {
    double get ();
    void set (double value);
}
member LeftAnnotationCropOffset : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The given value for offset must be non-negative.
InvalidOperationException | View is not allowed to have an annotation crop.
Remarks
This value must be a non-negative length in view units. Default value is 1/12' (1"), minimal value is 1/96' (1/8"). To get offset in model units, multiply the value by the view scale.
See Also

Reference

ViewCropRegionShapeManager Class


ViewCropRegionShapeManager.NumberOfSplitRegions Property

ViewCropRegionShapeManagerNumberOfSplitRegions Property

The number of split crop regions (1 if the crop is not currently split).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int NumberOfSplitRegions { get; }
Public ReadOnly Property NumberOfSplitRegions As Integer
    Get
public:
property int NumberOfSplitRegions {
    int get ();
}
member NumberOfSplitRegions : int with get

Property Value

Int32
See Also

Reference

ViewCropRegionShapeManager Class


ViewCropRegionShapeManager.RightAnnotationCropOffset Property

ViewCropRegionShapeManagerRightAnnotationCropOffset Property

The offset from the right of the view crop that determines the location of the annotation crop right boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double RightAnnotationCropOffset { get; set; }
Public Property RightAnnotationCropOffset As Double
    Get
    Set
public:
property double RightAnnotationCropOffset {
    double get ();
    void set (double value);
}
member RightAnnotationCropOffset : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The given value for offset must be non-negative.
InvalidOperationException | View is not allowed to have an annotation crop.
Remarks
This value must be a non-negative length in view units. Default value is 1/12' (1"), minimal value is 1/96' (1/8"). To get offset in model units, multiply the value by the view scale.
See Also

Reference

ViewCropRegionShapeManager Class


ViewCropRegionShapeManager.ShapeSet Property

ViewCropRegionShapeManagerShapeSet Property

Whether or not the view crop has a non-rectangular shape set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShapeSet { get; }
Public ReadOnly Property ShapeSet As Boolean
    Get
public:
property bool ShapeSet {
    bool get ();
}
member ShapeSet : bool with get

Property Value

Boolean
Remarks
This property reflects the actual shape of the crop region. Thus, if this property is true the view Split property is false.
See Also

Reference

ViewCropRegionShapeManager Class


ViewCropRegionShapeManager.Split Property

ViewCropRegionShapeManagerSplit Property

Whether or not the view crop is split.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Split { get; }
Public ReadOnly Property Split As Boolean
    Get
public:
property bool Split {
    bool get ();
}
member Split : bool with get

Property Value

Boolean
Remarks
This property reflects the actual visual split of the crop region. Thus, if the view has non-rectangular crop shape set, this property is false.
See Also

Reference

ViewCropRegionShapeManager Class


ViewCropRegionShapeManager.TopAnnotationCropOffset Property

ViewCropRegionShapeManagerTopAnnotationCropOffset Property

The offset from the top of the view crop that determines the location of the annotation crop top boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double TopAnnotationCropOffset { get; set; }
Public Property TopAnnotationCropOffset As Double
    Get
    Set
public:
property double TopAnnotationCropOffset {
    double get ();
    void set (double value);
}
member TopAnnotationCropOffset : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The given value for offset must be non-negative.
InvalidOperationException | View is not allowed to have an annotation crop.
Remarks
This value must be a non-negative length in view units. Default value is 1/12' (1"), minimal value is 1/96' (1/8"). To get offset in model units, multiply the value by the view scale.
See Also

Reference

ViewCropRegionShapeManager Class


ViewCropRegionShapeManager Methods

The ViewCropRegionShapeManager type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAnnotationCropShape | Gets the annotation crop box assigned to the view.
Public method | GetCropShape | Gets the crop boundaries that are curently active.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetSplitRegionMaximum | Returns the proportional location of the maximum boundary of the specified split crop region.
Public method | GetSplitRegionMinimum | Returns the proportional location of the minimum boundary of the specified split crop region.
Public method | GetSplitRegionOffset | Returns the offset for the specified split crop region.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsCropRegionShapeValid | Verifies that boundary represents one closed curve loop without self-intersections, consisting of non-zero length straight lines in a plane parallel to the view plane.
Public method | RemoveCropRegionShape | Removes any non-rectangular boundary of the view's crop.
Public method | RemoveSplit | Removes any split applied to the view's crop.
Public method | RemoveSplitRegion | Removes one region in split crop.
Public method | SetCropShape | Sets the boundary of the view's crop to the specified shape.
Public method | SplitRegionHorizontally | Splits horizontally one region in split crop.
Public method | SplitRegionVertically | Splits vertically one region in split crop.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ViewCropRegionShapeManager Class


ViewCropRegionShapeManager.Dispose Method

ViewCropRegionShapeManagerDispose Method

Releases all resources used by the ViewCropRegionShapeManager

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ViewCropRegionShapeManager Class


ViewCropRegionShapeManager.GetAnnotationCropShape Method

ViewCropRegionShapeManagerGetAnnotationCropShape Method

Gets the annotation crop box assigned to the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurveLoop GetAnnotationCropShape()
Public Function GetAnnotationCropShape As CurveLoop
public:
CurveLoop^ GetAnnotationCropShape()
member GetAnnotationCropShape : unit -> CurveLoop

Return Value

CurveLoop
The annotation crop boundary.
Exceptions
Exception | Condition
InvalidOperationException | View is not allowed to have an annotation crop.
Remarks
Currently, this method returns only the rectangular annotation crop box.
See Also

Reference

ViewCropRegionShapeManager Class


ViewCropRegionShapeManager.GetCropShape Method

ViewCropRegionShapeManagerGetCropShape Method

Gets the crop boundaries that are curently active.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<CurveLoop> GetCropShape()
Public Function GetCropShape As IList(Of CurveLoop)
public:
IList<CurveLoop^>^ GetCropShape()
member GetCropShape : unit -> IList<CurveLoop>

Return Value

IList CurveLoop
The crop boundaries.
Remarks
This method returns a representation of the boundaries of the currently active crop for the associated view. If the view crop has a non-rectangular shape, the method returns that shape. Otherwise, if the view crop has been split, the method returns the multiple rectangular boundaries visible in the crop - note that this does not reflect any offsets that may have been applied to the boundary regions. If the crop is not split, this returns a single rectangle representing the crop. All coordinates are in the coordinate frame of the view.
See Also

Reference

ViewCropRegionShapeManager Class


ViewCropRegionShapeManager.GetSplitRegionMaximum Method

ViewCropRegionShapeManagerGetSplitRegionMaximum Method

Returns the proportional location of the maximum boundary of the specified split crop region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetSplitRegionMaximum(
    int regionIndex
)
Public Function GetSplitRegionMaximum (
    regionIndex As Integer
) As Double
public:
double GetSplitRegionMaximum(
    int regionIndex
)
member GetSplitRegionMaximum :
        regionIndex : int -> float

Parameters

regionIndex Int32
Index of split crop region (numbering starts with 0).

Return Value

Double
A value from 0 to 1 representing the maximum location for the region's split boundary. This number represents the location as a ratio along the non-split rectangular crop.
Exceptions
Exception | Condition
ArgumentException | The provided region index is invalid.
See Also

Reference

ViewCropRegionShapeManager Class


ViewCropRegionShapeManager.GetSplitRegionMinimum Method

ViewCropRegionShapeManagerGetSplitRegionMinimum Method

Returns the proportional location of the minimum boundary of the specified split crop region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetSplitRegionMinimum(
    int regionIndex
)
Public Function GetSplitRegionMinimum (
    regionIndex As Integer
) As Double
public:
double GetSplitRegionMinimum(
    int regionIndex
)
member GetSplitRegionMinimum :
        regionIndex : int -> float

Parameters

regionIndex Int32
Index of split crop region (numbering starts with 0).

Return Value

Double
A value from 0 to 1 representing the minimum location for the region's split boundary. This number represents the location as a ratio along the non-split rectangular crop.
Exceptions
Exception | Condition
ArgumentException | The provided region index is invalid.
See Also

Reference

ViewCropRegionShapeManager Class


ViewCropRegionShapeManager.GetSplitRegionOffset Method

ViewCropRegionShapeManagerGetSplitRegionOffset Method

Returns the offset for the specified split crop region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ GetSplitRegionOffset(
    int regionIndex
)
Public Function GetSplitRegionOffset (
    regionIndex As Integer
) As XYZ
public:
XYZ^ GetSplitRegionOffset(
    int regionIndex
)
member GetSplitRegionOffset :
        regionIndex : int -> XYZ

Parameters

regionIndex Int32
Index of the split crop region (numbering starts with 0).

Return Value

XYZ
A vector in model space representing the offset which is applied to the split crop region's boundary.
Exceptions
Exception | Condition
ArgumentException | The provided region index is invalid.
Remarks
The points in the split crop region's boundary are not in model space. Add the offset returned by this method to each point in the crop region's boundary to transform the points into model space coordinates.
See Also

Reference

ViewCropRegionShapeManager Class


ViewCropRegionShapeManager.IsCropRegionShapeValid Method

ViewCropRegionShapeManagerIsCropRegionShapeValid Method

Verifies that boundary represents one closed curve loop without self-intersections, consisting of non-zero length straight lines in a plane parallel to the view plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCropRegionShapeValid(
    CurveLoop boundary
)
Public Function IsCropRegionShapeValid (
    boundary As CurveLoop
) As Boolean
public:
bool IsCropRegionShapeValid(
    CurveLoop^ boundary
)
member IsCropRegionShapeValid :
        boundary : CurveLoop -> bool

Parameters

boundary CurveLoop
The crop boundary.

Return Value

Boolean
True if the passed crop boundary represents one closed curve loop without self-intersections, consisting of non-zero length straight lines in a plane parallel to the view plane.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Curves in boundary use model coordinates.
See Also

Reference

ViewCropRegionShapeManager Class


ViewCropRegionShapeManager.RemoveCropRegionShape Method

ViewCropRegionShapeManagerRemoveCropRegionShape Method

Removes any non-rectangular boundary of the view's crop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveCropRegionShape()
Public Sub RemoveCropRegionShape
public:
void RemoveCropRegionShape()
member RemoveCropRegionShape : unit -> unit
Exceptions
Exception | Condition
InvalidOperationException | The crop of the associated view is not permitted to have a non-rectangular shape.
See Also

Reference

ViewCropRegionShapeManager Class


ViewCropRegionShapeManager.RemoveSplit Method

ViewCropRegionShapeManagerRemoveSplit Method

Removes any split applied to the view's crop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveSplit()
Public Sub RemoveSplit
public:
void RemoveSplit()
member RemoveSplit : unit -> unit
Exceptions
Exception | Condition
InvalidOperationException | The crop of the associated view is not permitted to have multiple regions.
See Also

Reference

ViewCropRegionShapeManager Class


ViewCropRegionShapeManager.RemoveSplitRegion Method

ViewCropRegionShapeManagerRemoveSplitRegion Method

Removes one region in split crop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveSplitRegion(
    int regionIndex
)
Public Sub RemoveSplitRegion (
    regionIndex As Integer
)
public:
void RemoveSplitRegion(
    int regionIndex
)
member RemoveSplitRegion :
        regionIndex : int -> unit

Parameters

regionIndex Int32
Index of region to be deleted (numbering starts with 0).
Exceptions
Exception | Condition
ArgumentException | The provided region index cannot be deleted.
InvalidOperationException | The crop of the associated view is not permitted to have multiple regions. -or- The view has non-rectangular crop shape set.
See Also

Reference

ViewCropRegionShapeManager Class


ViewCropRegionShapeManager.SetCropShape Method

ViewCropRegionShapeManagerSetCropShape Method

Sets the boundary of the view's crop to the specified shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetCropShape(
    CurveLoop boundary
)
Public Sub SetCropShape (
    boundary As CurveLoop
)
public:
void SetCropShape(
    CurveLoop^ boundary
)
member SetCropShape :
        boundary : CurveLoop -> unit

Parameters

boundary CurveLoop
The crop boundary.
Exceptions
Exception | Condition
ArgumentException | Boundary in boundary should represent one closed curve loop without self-intersections, consisting of non-zero length straight lines in a plane parallel to the view plane.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The crop of the associated view is not permitted to have a non-rectangular shape.
Remarks

Depending on the shape of the argument, view's crop is set to be either rectangular or non-rectangular. If the crop is set to be rectangular and it is also split, then the multiple view regions will be displayed for the view, with the same proportions as the split prior to the change, but adjusted to the new rectangular shape.

This Method is reserved for setting crop shape in views that allow non-rectangular crop shapes - see property CanHaveShape. For views that don't allow non-rectangular crop shapes (e.g. View3D), please use property CropBox for that purpose.

See Also

Reference

ViewCropRegionShapeManager Class


ViewCropRegionShapeManager.SplitRegionHorizontally Method

ViewCropRegionShapeManagerSplitRegionHorizontally Method

Splits horizontally one region in split crop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SplitRegionHorizontally(
    int regionIndex,
    double leftPart,
    double rightPart
)
Public Sub SplitRegionHorizontally (
    regionIndex As Integer,
    leftPart As Double,
    rightPart As Double
)
public:
void SplitRegionHorizontally(
    int regionIndex,
    double leftPart,
    double rightPart
)
member SplitRegionHorizontally :
        regionIndex : int *
        leftPart : float *
        rightPart : float -> unit

Parameters

regionIndex Int32
Index of region to be split horizontally (numbering starts with 0).
leftPart Double
Relative portion of the original region to become the new left region (0 to 1).
rightPart Double
Relative portion of the original region to become the new right region (0 to 1).
Exceptions
Exception | Condition
ArgumentException | The provided view region proportions are not valid. -or- The provided region index is invalid.
InvalidOperationException | The crop of the associated view is not permitted to have multiple regions. -or- The view has non-rectangular crop shape set. -or- The view crop is already split vertically.
Remarks
This function splits the crop into two regions: one occupying the left quarter of the crop, and the other the right quarter of the crop.
See Also

Reference

ViewCropRegionShapeManager Class


ViewCropRegionShapeManager.SplitRegionVertically Method

ViewCropRegionShapeManagerSplitRegionVertically Method

Splits vertically one region in split crop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SplitRegionVertically(
    int regionIndex,
    double topPart,
    double bottomPart
)
Public Sub SplitRegionVertically (
    regionIndex As Integer,
    topPart As Double,
    bottomPart As Double
)
public:
void SplitRegionVertically(
    int regionIndex,
    double topPart,
    double bottomPart
)
member SplitRegionVertically :
        regionIndex : int *
        topPart : float *
        bottomPart : float -> unit

Parameters

regionIndex Int32
Index of region to be split vertically (numbering starts with 0).
topPart Double
Relative portion of the original region to become the new top region (0 to 1).
bottomPart Double
Relative portion of the original region to become the new bottom region (0 to 1).
Exceptions
Exception | Condition
ArgumentException | The provided view region proportions are not valid. -or- The provided region index is invalid.
InvalidOperationException | The crop of the associated view is not permitted to have multiple regions. -or- The view has non-rectangular crop shape set. -or- The view crop is already split horizontally.
Remarks
This function splits the crop into two regions: one occupying the top quarter of the crop, and the other the bottom quarter of the crop.
See Also

Reference

ViewCropRegionShapeManager Class


ViewDetailLevel Enumeration

Detail level of the view

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ViewDetailLevel
Public Enumeration ViewDetailLevel
public enum class ViewDetailLevel
type ViewDetailLevel
Members
Member name | Value | Description
Undefined | 0 | View does not use Detail Level
Coarse | 1 | Coarse
Medium | 2 | Medium
Fine | 3 | Fine
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ViewDiscipline Enumeration

Discipline of the view

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ViewDiscipline
Public Enumeration ViewDiscipline
public enum class ViewDiscipline
type ViewDiscipline
Members
Member name | Value | Description
Architectural | 1 | Architectural
Structural | 2 | Structural
Mechanical | 4 | Mechanical
Electrical | 8 | Electrical
Plumbing | 16 | Plumbing
Coordination | 4,095 | Coordination
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ViewDisplayBackground Class

Set of values that control how background is drawn in a view. Background can only be set for a 3d view or for a section or elevation view.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBViewDisplayBackground

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ViewDisplayBackground : IDisposable
Public Class ViewDisplayBackground
    Implements IDisposable
public ref class ViewDisplayBackground : IDisposable
type ViewDisplayBackground =
    class
        interface IDisposable
    end

The ViewDisplayBackground type exposes the following members.

Properties
 | Name | Description
Public property | BackgroundColor | The color of the horizon when the type is 'Gradient'.
Public property | GroundColor | The color of the ground when the type is 'Gradient' or 'SunAndClouds'.
Public property | HorizontalImageOffset | The distance between the left viewport boundary and the left edge of the background image.
Public property | HorizontalImageScale | The horizontal scale of the background image; the scale of 1.0 puts the image pixel-to-pixel.
Public property | ImageFlags | The image alignment indicators when the type is 'Image'.
Public property | ImagePath | The path to the image file when the type is 'Image'.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SkyColor | The color of the sky when the type is 'Gradient'.
Public property | Type | The type of the background.
Public property | VerticalImageOffset | The distance between the bottom viewport boundary and the bottom edge of the background image.
Public property | VerticalImageScale | The vertical scale of the background image; the scale of 1.0 puts the image pixel-to-pixel.
Top
Methods
 | Name | Description
 | CreateGradient | Creates an object that can be passed to View.SetBackground method to set the background of the Gradient type.
 | CreateImage | Creates an object that can be passed to View.SetBackground method to set the background of the Image type.
 | CreateSky | Creates an object that can be passed to View.SetBackground method to set the background of the SunAndClouds type.
Public method | Dispose | Releases all resources used by the ViewDisplayBackground
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ViewDisplayBackground Properties

The ViewDisplayBackground type exposes the following members.

Properties
 | Name | Description
Public property | BackgroundColor | The color of the horizon when the type is 'Gradient'.
Public property | GroundColor | The color of the ground when the type is 'Gradient' or 'SunAndClouds'.
Public property | HorizontalImageOffset | The distance between the left viewport boundary and the left edge of the background image.
Public property | HorizontalImageScale | The horizontal scale of the background image; the scale of 1.0 puts the image pixel-to-pixel.
Public property | ImageFlags | The image alignment indicators when the type is 'Image'.
Public property | ImagePath | The path to the image file when the type is 'Image'.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SkyColor | The color of the sky when the type is 'Gradient'.
Public property | Type | The type of the background.
Public property | VerticalImageOffset | The distance between the bottom viewport boundary and the bottom edge of the background image.
Public property | VerticalImageScale | The vertical scale of the background image; the scale of 1.0 puts the image pixel-to-pixel.
Top
See Also

Reference

ViewDisplayBackground Class


ViewDisplayBackground.BackgroundColor Property

ViewDisplayBackgroundBackgroundColor Property

The color of the horizon when the type is 'Gradient'.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color BackgroundColor { get; }
Public ReadOnly Property BackgroundColor As Color
    Get
public:
property Color^ BackgroundColor {
    Color^ get ();
}
member BackgroundColor : Color with get

Property Value

Color
See Also

Reference

ViewDisplayBackground Class


ViewDisplayBackground.GroundColor Property

ViewDisplayBackgroundGroundColor Property

The color of the ground when the type is 'Gradient' or 'SunAndClouds'.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color GroundColor { get; }
Public ReadOnly Property GroundColor As Color
    Get
public:
property Color^ GroundColor {
    Color^ get ();
}
member GroundColor : Color with get

Property Value

Color
See Also

Reference

ViewDisplayBackground Class


ViewDisplayBackground.HorizontalImageOffset Property

ViewDisplayBackgroundHorizontalImageOffset Property

The distance between the left viewport boundary and the left edge of the background image.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double HorizontalImageOffset { get; }
Public ReadOnly Property HorizontalImageOffset As Double
    Get
public:
property double HorizontalImageOffset {
    double get ();
}
member HorizontalImageOffset : float with get

Property Value

Double
See Also

Reference

ViewDisplayBackground Class


ViewDisplayBackground.HorizontalImageScale Property

ViewDisplayBackgroundHorizontalImageScale Property

The horizontal scale of the background image; the scale of 1.0 puts the image pixel-to-pixel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double HorizontalImageScale { get; }
Public ReadOnly Property HorizontalImageScale As Double
    Get
public:
property double HorizontalImageScale {
    double get ();
}
member HorizontalImageScale : float with get

Property Value

Double
See Also

Reference

ViewDisplayBackground Class


ViewDisplayBackground.ImageFlags Property

ViewDisplayBackgroundImageFlags Property

The image alignment indicators when the type is 'Image'.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ViewDisplayBackgroundImageFlags ImageFlags { get; }
Public ReadOnly Property ImageFlags As ViewDisplayBackgroundImageFlags
    Get
public:
property ViewDisplayBackgroundImageFlags ImageFlags {
    ViewDisplayBackgroundImageFlags get ();
}
member ImageFlags : ViewDisplayBackgroundImageFlags with get

Property Value

ViewDisplayBackgroundImageFlags
See Also

Reference

ViewDisplayBackground Class


ViewDisplayBackground.ImagePath Property

ViewDisplayBackgroundImagePath Property

The path to the image file when the type is 'Image'.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ImagePath { get; }
Public ReadOnly Property ImagePath As String
    Get
public:
property String^ ImagePath {
    String^ get ();
}
member ImagePath : string with get

Property Value

String
See Also

Reference

ViewDisplayBackground Class


ViewDisplayBackground.IsValidObject Property

ViewDisplayBackgroundIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ViewDisplayBackground Class


ViewDisplayBackground.SkyColor Property

ViewDisplayBackgroundSkyColor Property

The color of the sky when the type is 'Gradient'.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color SkyColor { get; }
Public ReadOnly Property SkyColor As Color
    Get
public:
property Color^ SkyColor {
    Color^ get ();
}
member SkyColor : Color with get

Property Value

Color
See Also

Reference

ViewDisplayBackground Class


ViewDisplayBackground.Type Property

ViewDisplayBackgroundType Property

The type of the background.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ViewDisplayBackgroundType Type { get; }
Public ReadOnly Property Type As ViewDisplayBackgroundType
    Get
public:
property ViewDisplayBackgroundType Type {
    ViewDisplayBackgroundType get ();
}
member Type : ViewDisplayBackgroundType with get

Property Value

ViewDisplayBackgroundType
See Also

Reference

ViewDisplayBackground Class


ViewDisplayBackground.VerticalImageOffset Property

ViewDisplayBackgroundVerticalImageOffset Property

The distance between the bottom viewport boundary and the bottom edge of the background image.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double VerticalImageOffset { get; }
Public ReadOnly Property VerticalImageOffset As Double
    Get
public:
property double VerticalImageOffset {
    double get ();
}
member VerticalImageOffset : float with get

Property Value

Double
See Also

Reference

ViewDisplayBackground Class


ViewDisplayBackground.VerticalImageScale Property

ViewDisplayBackgroundVerticalImageScale Property

The vertical scale of the background image; the scale of 1.0 puts the image pixel-to-pixel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double VerticalImageScale { get; }
Public ReadOnly Property VerticalImageScale As Double
    Get
public:
property double VerticalImageScale {
    double get ();
}
member VerticalImageScale : float with get

Property Value

Double
See Also

Reference

ViewDisplayBackground Class


ViewDisplayBackground Methods

The ViewDisplayBackground type exposes the following members.

Methods
 | Name | Description
 | CreateGradient | Creates an object that can be passed to View.SetBackground method to set the background of the Gradient type.
 | CreateImage | Creates an object that can be passed to View.SetBackground method to set the background of the Image type.
 | CreateSky | Creates an object that can be passed to View.SetBackground method to set the background of the SunAndClouds type.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ViewDisplayBackground Class


ViewDisplayBackground.CreateGradient Method

ViewDisplayBackgroundCreateGradient Method

Creates an object that can be passed to View.SetBackground method to set the background of the Gradient type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ViewDisplayBackground CreateGradient(
    Color skyColor,
    Color horizonColor,
    Color groundColor
)
Public Shared Function CreateGradient (
    skyColor As Color,
    horizonColor As Color,
    groundColor As Color
) As ViewDisplayBackground
public:
static ViewDisplayBackground^ CreateGradient(
    Color^ skyColor,
    Color^ horizonColor,
    Color^ groundColor
)
static member CreateGradient :
        skyColor : Color *
        horizonColor : Color *
        groundColor : Color -> ViewDisplayBackground

Parameters

skyColor Color
The top of the sky gradient if the sky is visible.
horizonColor Color
The bottom or the sky gradient if the sky is visible, or the top of the ground gradient otherwise.
groundColor Color
The ground color if the sky is visible (ground shown in uniform color), or the bottom of the ground gradient if the sky is not visible.

Return Value

ViewDisplayBackground
New background object to pass to View.SetBackground.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ViewDisplayBackground Class


ViewDisplayBackground.CreateImage Method

ViewDisplayBackgroundCreateImage Method

Creates an object that can be passed to View.SetBackground method to set the background of the Image type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ViewDisplayBackground CreateImage(
    string imagePath,
    ViewDisplayBackgroundImageFlags flags,
    UV imageOffsets,
    UV imageScales
)
Public Shared Function CreateImage (
    imagePath As String,
    flags As ViewDisplayBackgroundImageFlags,
    imageOffsets As UV,
    imageScales As UV
) As ViewDisplayBackground
public:
static ViewDisplayBackground^ CreateImage(
    String^ imagePath,
    ViewDisplayBackgroundImageFlags flags,
    UV^ imageOffsets,
    UV^ imageScales
)
static member CreateImage :
        imagePath : string *
        flags : ViewDisplayBackgroundImageFlags *
        imageOffsets : UV *
        imageScales : UV -> ViewDisplayBackground

Parameters

imagePath String
File path with the image to be used.
flags ViewDisplayBackgroundImageFlags
Combination of flags (binary) that control how image is displayed in relation to the view/crop boundary.
imageOffsets UV
Horizontal (u) and vertical (v) offsets of the image.
imageScales UV
Horizontal (u) and vertical (v) scales of the image (1 == no change).

Return Value

ViewDisplayBackground
New background object to pass to View.SetBackground.
Exceptions
Exception | Condition
ArgumentException | The file specified by imagePath is not an image file. A valid image file should be in one of the following formats: bmp, jpg, jpeg, png, tif.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
FileArgumentNotFoundException | The file specified by imagePath doesn't exist.
See Also

Reference

ViewDisplayBackground Class


ViewDisplayBackground.CreateSky Method

ViewDisplayBackgroundCreateSky Method

Creates an object that can be passed to View.SetBackground method to set the background of the SunAndClouds type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ViewDisplayBackground CreateSky()
Public Shared Function CreateSky As ViewDisplayBackground
public:
static ViewDisplayBackground^ CreateSky()
static member CreateSky : unit -> ViewDisplayBackground

Return Value

ViewDisplayBackground
New background object to pass to View.SetBackground.
See Also

Reference

ViewDisplayBackground Class


ViewDisplayBackground.Dispose Method

ViewDisplayBackgroundDispose Method

Releases all resources used by the ViewDisplayBackground

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ViewDisplayBackground Class


ViewDisplayBackgroundImageFlags Enumeration

A collection of bit flags that control how the background image is positioned in relation to the crop region (or the view boundary).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ViewDisplayBackgroundImageFlags
Public Enumeration ViewDisplayBackgroundImageFlags
public enum class ViewDisplayBackgroundImageFlags
type ViewDisplayBackgroundImageFlags
Members
Member name | Value | Description
None | 0 | The image is displayed pixel-to-pixel
FitToScreen | 1 | The image is stretched in both directions
FixedAspectRatio | 2 | The image is stretched but the ratio of its height to width is preserved.
UseTiling | 4 | The pixels of the background are filled by tiling of the image.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ViewDisplayBackgroundType Enumeration

A collection of settings defining the type of the view background

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ViewDisplayBackgroundType
Public Enumeration ViewDisplayBackgroundType
public enum class ViewDisplayBackgroundType
type ViewDisplayBackgroundType
Members
Member name | Value | Description
None | 256 | No background defined - the color from Options is used to fill it.
Gradient | 257 | Three-color simulated sky-horizon-ground combination. The sky is drawn in gradually changing color from the top (the "sky" color) to the bottom (the "horizon" color). The ground is either drawn in the single (the "ground") color, if the sky is visible, or in a gradient from the top (the "horizon") color to the bottom (the "ground") color.
Image | 258 | User-specified image is drawn in the background either stretched vertically/horizontally/in both directions, or as is (pixel-to-pixel).
SunAndClouds | 512 | Best approximation to the colors of the sky and the visible sun disk. The position of the visible sun disk is calculated based on the "sun and shadow settings" (see 'ViewBackgroundLighting' object).
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ViewDisplayDepthCueing Class

Represents the settings for depth cueing.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBViewDisplayDepthCueing

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ViewDisplayDepthCueing : IDisposable
Public Class ViewDisplayDepthCueing
    Implements IDisposable
public ref class ViewDisplayDepthCueing : IDisposable
type ViewDisplayDepthCueing =
    class
        interface IDisposable
    end

The ViewDisplayDepthCueing type exposes the following members.

Properties
 | Name | Description
Public property | EnableDepthCueing | True to enable depth cueing. False to disable it.
Public property | EndPercentage | The end percentage defines where depth cueing ends. Values between 0 and 100.
Public property | FadeTo | The fade to defines the maximum fading in per cent. Values between 0 and 100.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | StartPercentage | The start percentage defines where depth cueing starts. Values between 0 and 100.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ViewDisplayDepthCueing
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetStartEndPercentages | Sets start and end percentages.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Example
C#
VB
C++
F#
Copy
private void AdjustDepthCueing(View view)
{
    if (view.CanUseDepthCueing())
    {
        using (Transaction t = new Transaction(view.Document, "Change depth cueing"))
        {
            t.Start();
            ViewDisplayDepthCueing depthCueing = view.GetDepthCueing();
            depthCueing.EnableDepthCueing = true;
            depthCueing.FadeTo = 50;    // set fade to percent
            depthCueing.SetStartEndPercentages(0, 75);
            view.SetDepthCueing(depthCueing);
            t.Commit();
        }
    }
}
Private Sub AdjustDepthCueing(view As View)
    If view.CanUseDepthCueing() Then
        Using t As New Transaction(view.Document, "Change depth cueing")
            t.Start()
            Dim depthCueing As ViewDisplayDepthCueing = view.GetDepthCueing()
            depthCueing.EnableDepthCueing = True
            depthCueing.FadeTo = 50
            ' set fade to percent
            depthCueing.SetStartEndPercentages(0, 75)
            view.SetDepthCueing(depthCueing)
            t.Commit()
        End Using
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ViewDisplayDepthCueing Properties

The ViewDisplayDepthCueing type exposes the following members.

Properties
 | Name | Description
Public property | EnableDepthCueing | True to enable depth cueing. False to disable it.
Public property | EndPercentage | The end percentage defines where depth cueing ends. Values between 0 and 100.
Public property | FadeTo | The fade to defines the maximum fading in per cent. Values between 0 and 100.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | StartPercentage | The start percentage defines where depth cueing starts. Values between 0 and 100.
Top
See Also

Reference

ViewDisplayDepthCueing Class


ViewDisplayDepthCueing.EnableDepthCueing Property

ViewDisplayDepthCueingEnableDepthCueing Property

True to enable depth cueing. False to disable it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool EnableDepthCueing { get; set; }
Public Property EnableDepthCueing As Boolean
    Get
    Set
public:
property bool EnableDepthCueing {
    bool get ();
    void set (bool value);
}
member EnableDepthCueing : bool with get, set

Property Value

Boolean
See Also

Reference

ViewDisplayDepthCueing Class


ViewDisplayDepthCueing.EndPercentage Property

ViewDisplayDepthCueingEndPercentage Property

The end percentage defines where depth cueing ends. Values between 0 and 100.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int EndPercentage { get; }
Public ReadOnly Property EndPercentage As Integer
    Get
public:
property int EndPercentage {
    int get ();
}
member EndPercentage : int with get

Property Value

Int32
See Also

Reference

ViewDisplayDepthCueing Class


ViewDisplayDepthCueing.FadeTo Property

ViewDisplayDepthCueingFadeTo Property

The fade to defines the maximum fading in per cent. Values between 0 and 100.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int FadeTo { get; set; }
Public Property FadeTo As Integer
    Get
    Set
public:
property int FadeTo {
    int get ();
    void set (int value);
}
member FadeTo : int with get, set

Property Value

Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The fade to value is not valid. The valid range is 0 to 100.
See Also

Reference

ViewDisplayDepthCueing Class


ViewDisplayDepthCueing.IsValidObject Property

ViewDisplayDepthCueingIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ViewDisplayDepthCueing Class


ViewDisplayDepthCueing.StartPercentage Property

ViewDisplayDepthCueingStartPercentage Property

The start percentage defines where depth cueing starts. Values between 0 and 100.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int StartPercentage { get; }
Public ReadOnly Property StartPercentage As Integer
    Get
public:
property int StartPercentage {
    int get ();
}
member StartPercentage : int with get

Property Value

Int32
See Also

Reference

ViewDisplayDepthCueing Class


ViewDisplayDepthCueing Methods

The ViewDisplayDepthCueing type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetStartEndPercentages | Sets start and end percentages.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ViewDisplayDepthCueing Class


ViewDisplayDepthCueing.Dispose Method

ViewDisplayDepthCueingDispose Method

Releases all resources used by the ViewDisplayDepthCueing

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ViewDisplayDepthCueing Class


ViewDisplayDepthCueing.SetStartEndPercentages Method

ViewDisplayDepthCueingSetStartEndPercentages Method

Sets start and end percentages.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetStartEndPercentages(
    int startPercentage,
    int endPercentage
)
Public Sub SetStartEndPercentages (
    startPercentage As Integer,
    endPercentage As Integer
)
public:
void SetStartEndPercentages(
    int startPercentage,
    int endPercentage
)
member SetStartEndPercentages :
        startPercentage : int *
        endPercentage : int -> unit

Parameters

startPercentage Int32
The start percentage defines where depth cueing starts.
endPercentage Int32
The end percentage defines where depth cueing ends.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The start and end percentages values are not valid. The valid range is 0 to 100 and start is smaller than end.
See Also

Reference

ViewDisplayDepthCueing Class


ViewDisplayEdges Enumeration

A collection of settings defining how visible edges are displayed

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ViewDisplayEdges
Public Enumeration ViewDisplayEdges
public enum class ViewDisplayEdges
type ViewDisplayEdges
Members
Member name | Value | Description
None | 0 | The edges are invisible
Simple | 1 | The edges are visible and drawn according to style
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ViewDisplayModel Class

Represents the settings for displaying model graphics. version 2: m_showHiddenLines type changed bool -> ShowHiddenLinesValues::Enum
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBViewDisplayModel

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ViewDisplayModel : IDisposable
Public Class ViewDisplayModel
    Implements IDisposable
public ref class ViewDisplayModel : IDisposable
type ViewDisplayModel =
    class
        interface IDisposable
    end

The ViewDisplayModel type exposes the following members.

Properties
 | Name | Description
Public property | EnableSilhouettes | True to show silhouettes edges. False to disable showing them.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ShowHiddenLines | True to enable hidden lines. False to disable showing them.
Public property | SilhouetteEdgesGStyleId | Style ID for silhouette edges
Public property | SmoothEdges | True to enable "smooth edge" (anti-aliasing) effect. False to disable it.
Public property | Transparency | The percentage (0..100) of surface transparency 0 means the surfaces are opaque, 100 means they are fully transparent
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ViewDisplayModel
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ViewDisplayModel Properties

The ViewDisplayModel type exposes the following members.

Properties
 | Name | Description
Public property | EnableSilhouettes | True to show silhouettes edges. False to disable showing them.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ShowHiddenLines | True to enable hidden lines. False to disable showing them.
Public property | SilhouetteEdgesGStyleId | Style ID for silhouette edges
Public property | SmoothEdges | True to enable "smooth edge" (anti-aliasing) effect. False to disable it.
Public property | Transparency | The percentage (0..100) of surface transparency 0 means the surfaces are opaque, 100 means they are fully transparent
Top
See Also

Reference

ViewDisplayModel Class


ViewDisplayModel.EnableSilhouettes Property

ViewDisplayModelEnableSilhouettes Property

True to show silhouettes edges. False to disable showing them.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool EnableSilhouettes { get; set; }
Public Property EnableSilhouettes As Boolean
    Get
    Set
public:
property bool EnableSilhouettes {
    bool get ();
    void set (bool value);
}
member EnableSilhouettes : bool with get, set

Property Value

Boolean
See Also

Reference

ViewDisplayModel Class


ViewDisplayModel.IsValidObject Property

ViewDisplayModelIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ViewDisplayModel Class


ViewDisplayModel.ShowHiddenLines Property

ViewDisplayModelShowHiddenLines Property

True to enable hidden lines. False to disable showing them.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ShowHiddenLinesValues ShowHiddenLines { get; set; }
Public Property ShowHiddenLines As ShowHiddenLinesValues
    Get
    Set
public:
property ShowHiddenLinesValues ShowHiddenLines {
    ShowHiddenLinesValues get ();
    void set (ShowHiddenLinesValues value);
}
member ShowHiddenLines : ShowHiddenLinesValues with get, set

Property Value

ShowHiddenLinesValues
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ViewDisplayModel Class


ViewDisplayModel.SilhouetteEdgesGStyleId Property

ViewDisplayModelSilhouetteEdgesGStyleId Property

Style ID for silhouette edges

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId SilhouetteEdgesGStyleId { get; set; }
Public Property SilhouetteEdgesGStyleId As ElementId
    Get
    Set
public:
property ElementId^ SilhouetteEdgesGStyleId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member SilhouetteEdgesGStyleId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ViewDisplayModel Class


ViewDisplayModel.SmoothEdges Property

ViewDisplayModelSmoothEdges Property

True to enable "smooth edge" (anti-aliasing) effect. False to disable it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SmoothEdges { get; set; }
Public Property SmoothEdges As Boolean
    Get
    Set
public:
property bool SmoothEdges {
    bool get ();
    void set (bool value);
}
member SmoothEdges : bool with get, set

Property Value

Boolean
See Also

Reference

ViewDisplayModel Class


ViewDisplayModel.Transparency Property

ViewDisplayModelTransparency Property

The percentage (0..100) of surface transparency 0 means the surfaces are opaque, 100 means they are fully transparent

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Transparency { get; set; }
Public Property Transparency As Integer
    Get
    Set
public:
property int Transparency {
    int get ();
    void set (int value);
}
member Transparency : int with get, set

Property Value

Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The value is invalid. The valid range is 0 through 100
See Also

Reference

ViewDisplayModel Class


ViewDisplayModel Methods

The ViewDisplayModel type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ViewDisplayModel Class


ViewDisplayModel.Dispose Method

ViewDisplayModelDispose Method

Releases all resources used by the ViewDisplayModel

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ViewDisplayModel Class


ViewDisplaySketchyLines Class

Represents the settings for sketchy lines.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBViewDisplaySketchyLines

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ViewDisplaySketchyLines : IDisposable
Public Class ViewDisplaySketchyLines
    Implements IDisposable
public ref class ViewDisplaySketchyLines : IDisposable
type ViewDisplaySketchyLines =
    class
        interface IDisposable
    end

The ViewDisplaySketchyLines type exposes the following members.

Properties
 | Name | Description
Public property | EnableSketchyLines | True to enable sketchy lines visibility. False to disable it.
Public property | Extension | The extension scale value. Controls the magnitude of line's extension. Values between 0 and 10.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Jitter | The jitter defines jitteriness of the line. Values between 0 and 10.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ViewDisplaySketchyLines
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ViewDisplaySketchyLines Properties

The ViewDisplaySketchyLines type exposes the following members.

Properties
 | Name | Description
Public property | EnableSketchyLines | True to enable sketchy lines visibility. False to disable it.
Public property | Extension | The extension scale value. Controls the magnitude of line's extension. Values between 0 and 10.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Jitter | The jitter defines jitteriness of the line. Values between 0 and 10.
Top
See Also

Reference

ViewDisplaySketchyLines Class


ViewDisplaySketchyLines.EnableSketchyLines Property

ViewDisplaySketchyLinesEnableSketchyLines Property

True to enable sketchy lines visibility. False to disable it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool EnableSketchyLines { get; set; }
Public Property EnableSketchyLines As Boolean
    Get
    Set
public:
property bool EnableSketchyLines {
    bool get ();
    void set (bool value);
}
member EnableSketchyLines : bool with get, set

Property Value

Boolean
See Also

Reference

ViewDisplaySketchyLines Class


ViewDisplaySketchyLines.Extension Property

ViewDisplaySketchyLinesExtension Property

The extension scale value. Controls the magnitude of line's extension. Values between 0 and 10.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Extension { get; set; }
Public Property Extension As Integer
    Get
    Set
public:
property int Extension {
    int get ();
    void set (int value);
}
member Extension : int with get, set

Property Value

Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The extension value is not valid. The valid range is 0 to 10.
See Also

Reference

ViewDisplaySketchyLines Class


ViewDisplaySketchyLines.IsValidObject Property

ViewDisplaySketchyLinesIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ViewDisplaySketchyLines Class


ViewDisplaySketchyLines.Jitter Property

ViewDisplaySketchyLinesJitter Property

The jitter defines jitteriness of the line. Values between 0 and 10.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Jitter { get; set; }
Public Property Jitter As Integer
    Get
    Set
public:
property int Jitter {
    int get ();
    void set (int value);
}
member Jitter : int with get, set

Property Value

Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The jitter value is not valid. The valid range is 0 to 10.
See Also

Reference

ViewDisplaySketchyLines Class


ViewDisplaySketchyLines Methods

The ViewDisplaySketchyLines type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ViewDisplaySketchyLines Class


ViewDisplaySketchyLines.Dispose Method

ViewDisplaySketchyLinesDispose Method

Releases all resources used by the ViewDisplaySketchyLines

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ViewDisplaySketchyLines Class


ViewDrafting Class

ViewDrafting represents a drafting view within the model.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBView
Autodesk.Revit.DBViewDrafting
Autodesk.Revit.DBImageView

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ViewDrafting : View
Public Class ViewDrafting
    Inherits View
public ref class ViewDrafting : public View
type ViewDrafting =
    class
        inherit View
    end

The ViewDrafting type exposes the following members.

Properties
 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View)
Public property | AreAnalyticalModelCategoriesHidden | Indicates if analytical model categories are currently hidden in the view. (Inherited from View)
Public property | AreAnnotationCategoriesHidden | Indicates if annotation categories are currently hidden in the view. (Inherited from View)
Public property | AreCoordinationModelHandlesHidden | Indicates if Coordination Model handles are currently hidden in the view. (Inherited from View)
Public property | AreImportCategoriesHidden | Indicates if import categories are currently hidden in the view. (Inherited from View)
Public property | AreModelCategoriesHidden | Indicates if model categories are currently hidden in the view. (Inherited from View)
Public property | ArePointCloudsHidden | Indicates if point clouds are currently hidden in the view. (Inherited from View)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CropBox | The Crop Box applied to the view, or an outline encompassing the crop region applied to the view. (Inherited from View)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | DetailLevel | The detail level of this view. (Inherited from View)
Public property | Discipline | The Discipline of the view. (Inherited from View)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | GenLevel | The level for the view. (Inherited from View)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsAssemblyView | Indicates if the view is assembly view. (Inherited from View)
Public property | IsCallout | Indicates if the view is a callout view. (Inherited from View)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | Origin | Returns the origin of the screen. (Inherited from View)
Public property | Outline | The bounds of the view in paper space (in feet). (Inherited from View)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | RevealConstraintsMode | Indicates whether the Reveal Constraints mode is activated in the view. (Inherited from View)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View)
Public property | Scale | The scale of the view. (Inherited from View)
Public property | ShadowIntensity | The intesity of cast shadows - 0 = no shadows, 100 = black. (Inherited from View)
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View)
Public property | SunlightIntensity | The intensity of the simulated (directional) sunlight. 0 = no directional light; maximum value is 100. (Inherited from View)
Public property | TemporaryViewModes | Data of temporary view modes associated with this view. (Inherited from View)
Public property | Title | The view title. This consists of the view name plus other modifiers, such as the view type, sheet number, area scheme, and/or assembly type, depending on the specifics of the view. (Inherited from View)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | ViewTemplateId | The id of the template view that controls this view's parameters. (Inherited from View)
 | ViewType | The type of the view. (Inherited from View)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | AddFilter | Adds a filter to the view. (Inherited from View)
Public method | AllowsAnalysisDisplay | Identifies if this view allows display of Analysis results. (Inherited from View)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of the input view that are not controlled by the current view template. (Inherited from View)
Public method | AreGraphicsOverridesAllowed | Determines if Visibility/Graphics Overriddes can be applied to the view. (Inherited from View)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanApplyColorFillScheme | Checks if the id can be applied as the scheme id of specified category to this view. (Inherited from View)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanCategoryBeHidden | Checks whether the category can be hidden in the view. (Inherited from View)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanEnableTemporaryViewPropertiesMode | Indicates if Temporary View Properties mode can be applied for view in current state. (Inherited from View)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified (Inherited from View)
Public method | CanUseDepthCueing | Indicates if view can use Depth Cueing (Inherited from View)
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes (Inherited from View)
Public method | CanViewBeDuplicated | Identifies if this view can be duplicated. (Inherited from View)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View)
 | ConvertToIndependent | Convert the dependent view to independent. (Inherited from View)
 | Create | Creates a new ViewDrafting in the model.
Public method | CreateViewTemplate | Creates a new view template instance from this view instance. (Inherited from View)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View)
Public method | Dispose | (Inherited from Element)
 | Duplicate | Duplicates this view. (Inherited from View)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View)
Public method | EnableTemporaryViewPropertiesMode | Turns Temporary View Properties mode on or off. In this mode, any changes made to the view are temporary and will be discarded once the mode is disabled. (Inherited from View)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetBackground | Returns the current background set for the view. (Inherited from View)
Public method | GetCalloutParentId | Gets ID of the callout parent view. (Inherited from View)
Public method | GetCategoryHidden | Checks if elements of the given category are set to be invisible (hidden) in this view. (Inherited from View)
Public method | GetCategoryOverrides | Gets graphic overrides for a category in view. (Inherited from View)
Public method | GetColorFillSchemeId | Returns id of the color fill scheme element applied to the view. (Inherited from View)
Public method | GetCropRegionShapeManager | Returns an object for managing view crop region shape. (Inherited from View)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View)
Public method | GetDepthCueing | Returns the current depth cueing settings for the view. (Inherited from View)
Public method | GetDirectContext3DHandleOverrides | Returns DirectContext3D handle overrides object for the view. (Inherited from View)
Public method | GetElementOverrides | Gets graphic overrides for an element in the view. (Inherited from View)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFilterOverrides | Gets graphic overrides that a filter applies to the view. (Inherited from View)
Public method | GetFilters | Gets the filters applied to the view. (Inherited from View)
Public method | GetFilterVisibility | Gets the visibility of the elements associated with a filter. (Inherited from View)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIsFilterEnabled | Identifies if the filter is enabled in this view. (Inherited from View)
 | GetLinkOverrides | Gets the graphic overrides of a RevitLinkType or RevitLinkInstance in view. (Inherited from View)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetModelToProjectionTransforms | Gets the transforms from the model space to the view projection space. (Inherited from View)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetNonControlledTemplateParameterIds | Returns a list of parameters that are not marked as included when this view is used as a template. (Inherited from View)
Public method | GetOrderedFilters | Gets the filters applied to the view in the order they are applied. (Inherited from View)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPlacementOnSheetStatus | Determines if this view placed on a sheet completely or partially. (Inherited from View)
Public method | GetPointCloudOverrides | Returns point cloud overrides object for the view. (Inherited from View)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View)
Public method | GetReferenceCallouts | Returns element ids of all reference callouts in the view. (Inherited from View)
Public method | GetReferenceElevations | Returns element ids of all reference elevations in the view. (Inherited from View)
Public method | GetReferenceSections | Returns element ids of all reference sections in the view. (Inherited from View)
Public method | GetSketchyLines | Returns the current sketchy lines settings for the view. (Inherited from View)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTemplateParameterIds | Returns a list of parameter ids that may be controlled when this view is assigned as a template. (Inherited from View)
Public method | GetTemporaryViewPropertiesId | When Temporary View Properties mode is in progress it provides view id that overrode settings for current view. Outside Temporary View Properties mode InvalidElementId will be returned. (Inherited from View)
Public method | GetTemporaryViewPropertiesName | When Temporary View Properties mode is in progress, name of applied template is returned. Outside Temporary View Properties mode, empty string will be returned. (Inherited from View)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetViewDisplayModel | Returns the current view display model settings for the view. (Inherited from View)
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View)
Public method | HasDetailLevel | Check if the view has a Detail Level property (Inherited from View)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property (Inherited from View)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property (Inherited from View)
Public method | HasViewTransforms | Returns true if the view reports model space to view projection space transforms. (Inherited from View)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View)
Public method | IsCategoryOverridable | Checks whether the category can have graphic overrides in this view. (Inherited from View)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsFilterApplied | Indicates if a filter is applied to the view. (Inherited from View)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View)
Public method | IsTemporaryViewPropertiesModeEnabled | Returns true when Temporary View Properties mode is in progress, false otherwise. (Inherited from View)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | IsValidViewTemplate | Verifies that the view represented by templateId can be set as the controlling view template for this view. (Inherited from View)
Public method | IsViewValidForTemplateCreation | Verifies that the view is valid for template creation. (Inherited from View)
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | Print | Print this view with the default view template and using the print setting of the current active document. (Inherited from View)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveCalloutParent | Replaces callout parent ID with InvalidElementId. (Inherited from View)
Public method | RemoveFilter | Removes a filter from the view. (Inherited from View)
 | RemoveLinkOverrides | Deletes the graphical link overrides in the current view. (Inherited from View)
Public method | RestoreCalloutParent | Restores callout parent ID to the original view ID if that view is still available. (Inherited from View)
Public method | SetBackground | Sets the background for the view. Background can only be set for 3d views and for Sections/Elevations. (Inherited from View)
Public method | SetCategoryHidden | Sets if elements of the given category will be visible in this view. (Inherited from View)
Public method | SetCategoryOverrides | Sets graphic overrides for a category in view. (Inherited from View)
Public method | SetColorFillSchemeId | Applies color fill scheme to this view. (Inherited from View)
Public method | SetDepthCueing | Sets the depth cueing settings for the view. (Inherited from View)
Public method | SetElementOverrides | Sets graphic overrides for an element in the view. (Inherited from View)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
 | SetFilterOverrides | Sets the overrides associated with a filter. (Inherited from View)
Public method | SetFilterVisibility | Sets the visibility of the elements associated with a filter. (Inherited from View)
Public method | SetIsFilterEnabled | Sets the filter enabled flag. (Inherited from View)
 | SetLinkOverrides | Sets the graphic overrides of a RevitLinkType or RevitLinkInstance in the view. (Inherited from View)
Public method | SetNonControlledTemplateParameterIds | Sets the parameters that will not be included when this view is used as a template. (Inherited from View)
Public method | SetSketchyLines | Sets the sketchy lines settings for the view. (Inherited from View)
Public method | SetViewDisplayModel | Sets the view display model settings for the view. (Inherited from View)
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View)
 | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View)
Public method | SupportedColorFillCategoryIds | Returns collection of all category ids that correspond to elements that can potentially be colored in this view according to a color fill scheme. The set may be different depending on the view type. (Inherited from View)
Public method | SupportsRevealConstraints | Checks that the view can have the Reveal Constraints mode activated. (Inherited from View)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ViewDrafting Properties

The ViewDrafting type exposes the following members.

Properties
 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View)
Public property | AreAnalyticalModelCategoriesHidden | Indicates if analytical model categories are currently hidden in the view. (Inherited from View)
Public property | AreAnnotationCategoriesHidden | Indicates if annotation categories are currently hidden in the view. (Inherited from View)
Public property | AreCoordinationModelHandlesHidden | Indicates if Coordination Model handles are currently hidden in the view. (Inherited from View)
Public property | AreImportCategoriesHidden | Indicates if import categories are currently hidden in the view. (Inherited from View)
Public property | AreModelCategoriesHidden | Indicates if model categories are currently hidden in the view. (Inherited from View)
Public property | ArePointCloudsHidden | Indicates if point clouds are currently hidden in the view. (Inherited from View)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CropBox | The Crop Box applied to the view, or an outline encompassing the crop region applied to the view. (Inherited from View)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | DetailLevel | The detail level of this view. (Inherited from View)
Public property | Discipline | The Discipline of the view. (Inherited from View)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | GenLevel | The level for the view. (Inherited from View)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsAssemblyView | Indicates if the view is assembly view. (Inherited from View)
Public property | IsCallout | Indicates if the view is a callout view. (Inherited from View)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | Origin | Returns the origin of the screen. (Inherited from View)
Public property | Outline | The bounds of the view in paper space (in feet). (Inherited from View)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | RevealConstraintsMode | Indicates whether the Reveal Constraints mode is activated in the view. (Inherited from View)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View)
Public property | Scale | The scale of the view. (Inherited from View)
Public property | ShadowIntensity | The intesity of cast shadows - 0 = no shadows, 100 = black. (Inherited from View)
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View)
Public property | SunlightIntensity | The intensity of the simulated (directional) sunlight. 0 = no directional light; maximum value is 100. (Inherited from View)
Public property | TemporaryViewModes | Data of temporary view modes associated with this view. (Inherited from View)
Public property | Title | The view title. This consists of the view name plus other modifiers, such as the view type, sheet number, area scheme, and/or assembly type, depending on the specifics of the view. (Inherited from View)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | ViewTemplateId | The id of the template view that controls this view's parameters. (Inherited from View)
 | ViewType | The type of the view. (Inherited from View)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

ViewDrafting Class


ViewDrafting Methods

The ViewDrafting type exposes the following members.

Methods
 | Name | Description
Public method | AddFilter | Adds a filter to the view. (Inherited from View)
Public method | AllowsAnalysisDisplay | Identifies if this view allows display of Analysis results. (Inherited from View)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of the input view that are not controlled by the current view template. (Inherited from View)
Public method | AreGraphicsOverridesAllowed | Determines if Visibility/Graphics Overriddes can be applied to the view. (Inherited from View)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanApplyColorFillScheme | Checks if the id can be applied as the scheme id of specified category to this view. (Inherited from View)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanCategoryBeHidden | Checks whether the category can be hidden in the view. (Inherited from View)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanEnableTemporaryViewPropertiesMode | Indicates if Temporary View Properties mode can be applied for view in current state. (Inherited from View)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified (Inherited from View)
Public method | CanUseDepthCueing | Indicates if view can use Depth Cueing (Inherited from View)
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes (Inherited from View)
Public method | CanViewBeDuplicated | Identifies if this view can be duplicated. (Inherited from View)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View)
 | ConvertToIndependent | Convert the dependent view to independent. (Inherited from View)
 | Create | Creates a new ViewDrafting in the model.
Public method | CreateViewTemplate | Creates a new view template instance from this view instance. (Inherited from View)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View)
Public method | Dispose | (Inherited from Element)
 | Duplicate | Duplicates this view. (Inherited from View)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View)
Public method | EnableTemporaryViewPropertiesMode | Turns Temporary View Properties mode on or off. In this mode, any changes made to the view are temporary and will be discarded once the mode is disabled. (Inherited from View)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetBackground | Returns the current background set for the view. (Inherited from View)
Public method | GetCalloutParentId | Gets ID of the callout parent view. (Inherited from View)
Public method | GetCategoryHidden | Checks if elements of the given category are set to be invisible (hidden) in this view. (Inherited from View)
Public method | GetCategoryOverrides | Gets graphic overrides for a category in view. (Inherited from View)
Public method | GetColorFillSchemeId | Returns id of the color fill scheme element applied to the view. (Inherited from View)
Public method | GetCropRegionShapeManager | Returns an object for managing view crop region shape. (Inherited from View)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View)
Public method | GetDepthCueing | Returns the current depth cueing settings for the view. (Inherited from View)
Public method | GetDirectContext3DHandleOverrides | Returns DirectContext3D handle overrides object for the view. (Inherited from View)
Public method | GetElementOverrides | Gets graphic overrides for an element in the view. (Inherited from View)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFilterOverrides | Gets graphic overrides that a filter applies to the view. (Inherited from View)
Public method | GetFilters | Gets the filters applied to the view. (Inherited from View)
Public method | GetFilterVisibility | Gets the visibility of the elements associated with a filter. (Inherited from View)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIsFilterEnabled | Identifies if the filter is enabled in this view. (Inherited from View)
 | GetLinkOverrides | Gets the graphic overrides of a RevitLinkType or RevitLinkInstance in view. (Inherited from View)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetModelToProjectionTransforms | Gets the transforms from the model space to the view projection space. (Inherited from View)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetNonControlledTemplateParameterIds | Returns a list of parameters that are not marked as included when this view is used as a template. (Inherited from View)
Public method | GetOrderedFilters | Gets the filters applied to the view in the order they are applied. (Inherited from View)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPlacementOnSheetStatus | Determines if this view placed on a sheet completely or partially. (Inherited from View)
Public method | GetPointCloudOverrides | Returns point cloud overrides object for the view. (Inherited from View)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View)
Public method | GetReferenceCallouts | Returns element ids of all reference callouts in the view. (Inherited from View)
Public method | GetReferenceElevations | Returns element ids of all reference elevations in the view. (Inherited from View)
Public method | GetReferenceSections | Returns element ids of all reference sections in the view. (Inherited from View)
Public method | GetSketchyLines | Returns the current sketchy lines settings for the view. (Inherited from View)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTemplateParameterIds | Returns a list of parameter ids that may be controlled when this view is assigned as a template. (Inherited from View)
Public method | GetTemporaryViewPropertiesId | When Temporary View Properties mode is in progress it provides view id that overrode settings for current view. Outside Temporary View Properties mode InvalidElementId will be returned. (Inherited from View)
Public method | GetTemporaryViewPropertiesName | When Temporary View Properties mode is in progress, name of applied template is returned. Outside Temporary View Properties mode, empty string will be returned. (Inherited from View)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetViewDisplayModel | Returns the current view display model settings for the view. (Inherited from View)
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View)
Public method | HasDetailLevel | Check if the view has a Detail Level property (Inherited from View)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property (Inherited from View)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property (Inherited from View)
Public method | HasViewTransforms | Returns true if the view reports model space to view projection space transforms. (Inherited from View)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View)
Public method | IsCategoryOverridable | Checks whether the category can have graphic overrides in this view. (Inherited from View)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsFilterApplied | Indicates if a filter is applied to the view. (Inherited from View)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View)
Public method | IsTemporaryViewPropertiesModeEnabled | Returns true when Temporary View Properties mode is in progress, false otherwise. (Inherited from View)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | IsValidViewTemplate | Verifies that the view represented by templateId can be set as the controlling view template for this view. (Inherited from View)
Public method | IsViewValidForTemplateCreation | Verifies that the view is valid for template creation. (Inherited from View)
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | Print | Print this view with the default view template and using the print setting of the current active document. (Inherited from View)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveCalloutParent | Replaces callout parent ID with InvalidElementId. (Inherited from View)
Public method | RemoveFilter | Removes a filter from the view. (Inherited from View)
 | RemoveLinkOverrides | Deletes the graphical link overrides in the current view. (Inherited from View)
Public method | RestoreCalloutParent | Restores callout parent ID to the original view ID if that view is still available. (Inherited from View)
Public method | SetBackground | Sets the background for the view. Background can only be set for 3d views and for Sections/Elevations. (Inherited from View)
Public method | SetCategoryHidden | Sets if elements of the given category will be visible in this view. (Inherited from View)
Public method | SetCategoryOverrides | Sets graphic overrides for a category in view. (Inherited from View)
Public method | SetColorFillSchemeId | Applies color fill scheme to this view. (Inherited from View)
Public method | SetDepthCueing | Sets the depth cueing settings for the view. (Inherited from View)
Public method | SetElementOverrides | Sets graphic overrides for an element in the view. (Inherited from View)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
 | SetFilterOverrides | Sets the overrides associated with a filter. (Inherited from View)
Public method | SetFilterVisibility | Sets the visibility of the elements associated with a filter. (Inherited from View)
Public method | SetIsFilterEnabled | Sets the filter enabled flag. (Inherited from View)
 | SetLinkOverrides | Sets the graphic overrides of a RevitLinkType or RevitLinkInstance in the view. (Inherited from View)
Public method | SetNonControlledTemplateParameterIds | Sets the parameters that will not be included when this view is used as a template. (Inherited from View)
Public method | SetSketchyLines | Sets the sketchy lines settings for the view. (Inherited from View)
Public method | SetViewDisplayModel | Sets the view display model settings for the view. (Inherited from View)
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View)
 | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View)
Public method | SupportedColorFillCategoryIds | Returns collection of all category ids that correspond to elements that can potentially be colored in this view according to a color fill scheme. The set may be different depending on the view type. (Inherited from View)
Public method | SupportsRevealConstraints | Checks that the view can have the Reveal Constraints mode activated. (Inherited from View)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View)
Top
See Also

Reference

ViewDrafting Class


ViewDrafting.Create Method

ViewDraftingCreate Method

Creates a new ViewDrafting in the model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ViewDrafting Create(
    Document document,
    ElementId viewFamilyTypeId
)
Public Shared Function Create (
    document As Document,
    viewFamilyTypeId As ElementId
) As ViewDrafting
public:
static ViewDrafting^ Create(
    Document^ document,
    ElementId^ viewFamilyTypeId
)
static member Create :
        document : Document *
        viewFamilyTypeId : ElementId -> ViewDrafting

Parameters

document Document
The document in which the new drafting view will be created.
viewFamilyTypeId ElementId
The id of the ViewFamilyType that should be assigned to the new drafting view.

Return Value

ViewDrafting
The newly created drafting view.
Exceptions
Exception | Condition
ArgumentException | viewFamilyTypeId is not a valid ViewFamilyType for a drafting view.
ArgumentNullException | A non-optional argument was null
Example
C#
VB
C++
F#
Copy
// For simplicity, we'll look what drafting view types are already available,
// and we'll use the first one we can find to create our new drafting view.
FilteredElementCollector collector = new FilteredElementCollector(document);
collector.OfClass(typeof(ViewFamilyType));
ViewFamilyType viewFamilyType = collector.Cast<ViewFamilyType>().First(vft => vft.ViewFamily == ViewFamily.Drafting);

// Create a new ViewDrafting instance
ViewDrafting view = ViewDrafting.Create(document, viewFamilyType.Id);
view.Name = "MyViewDrafting";

// Set the CropBox
BoundingBoxXYZ boundingBox = new BoundingBoxXYZ();
boundingBox.Max = new XYZ(100, 100, 50);
boundingBox.Min = new XYZ(-100, -100, -50);
view.CropBox = boundingBox;
' For simplicity, we'll look what drafting view types are already available,
' and we'll use the first one we can find to create our new drafting view.
Dim collector As New FilteredElementCollector(document)
collector.OfClass(GetType(ViewFamilyType))
Dim viewFamilyType As ViewFamilyType = collector.Cast(Of ViewFamilyType)().First(Function(vft) vft.ViewFamily = ViewFamily.Drafting)

' Create a new ViewDrafting instance
Dim view As ViewDrafting = ViewDrafting.Create(document, viewFamilyType.Id)
view.Name = "MyViewDrafting"

' Set the CropBox
Dim boundingBox As New BoundingBoxXYZ()
boundingBox.Max = New XYZ(100, 100, 50)
boundingBox.Min = New XYZ(-100, -100, -50)
view.CropBox = boundingBox

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

ViewDrafting Class


ViewDuplicateOption Enumeration

Options for duplicating views

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ViewDuplicateOption
Public Enumeration ViewDuplicateOption
public enum class ViewDuplicateOption
type ViewDuplicateOption
Members
Member name | Value | Description
Duplicate | 0 | Duplicate view
AsDependent | 1 | Duplicate as Dependent
WithDetailing | 2 | Duplicate with Detailing
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ViewFamily Enumeration

An enumerated type that corresponds to the type of a Revit view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ViewFamily
Public Enumeration ViewFamily
public enum class ViewFamily
type ViewFamily
Members
Member name | Value | Description
Invalid | 101 | Invalid view type.
ThreeDimensional | 102 | 3D view.
Walkthrough | 103 | Walkthrough view.
ImageView | 104 | Rendering view.
Schedule | 105 | Schedule view.
CostReport | 106 | Cost report view (obsolete).
Sheet | 107 | Sheet view.
Drafting | 108 | Drafting view.
FloorPlan | 109 | Floor plan view.
AreaPlan | 110 | Area plan view.
CeilingPlan | 111 | Ceiling plan view.
Section | 112 | Section view.
Detail | 113 | Detail view.
Elevation | 114 | Elevation view.
LoadsReport | 115 | HVAC load report.
PressureLossReport | 116 | Pressure loss report.
Legend | 117 | Legend view.
PanelSchedule | 118 | Panel schedule.
GraphicalColumnSchedule | 119 | Graphical column schedule.
StructuralPlan | 120 | Structural plan view.
SystemsAnalysisReport | 121 | Systems analysis report.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ViewFamilyType Class

Represents a type of a Revit view.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBViewFamilyType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ViewFamilyType : ElementType
Public Class ViewFamilyType
    Inherits ElementType
public ref class ViewFamilyType : public ElementType
type ViewFamilyType =
    class
        inherit ElementType
    end

The ViewFamilyType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | DefaultTemplateId | The default template id assigned to this view type.
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | PlanViewDirection | The PlanViewDirection of this view.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
 | ViewFamily | The ViewFamily for this view type.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidDefaultTemplate | Verifies that the input can be used as a default template for this view type.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
ViewFamilyTypes represent possible types for a Revit view and contain view type related properties and options such as the default template associated to views created from this type. They are commonly input to new View creation methods in the Revit API.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ViewFamilyType Properties

The ViewFamilyType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | DefaultTemplateId | The default template id assigned to this view type.
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | PlanViewDirection | The PlanViewDirection of this view.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
 | ViewFamily | The ViewFamily for this view type.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

ViewFamilyType Class


ViewFamilyType.DefaultTemplateId Property

ViewFamilyTypeDefaultTemplateId Property

The default template id assigned to this view type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId DefaultTemplateId { get; set; }
Public Property DefaultTemplateId As ElementId
    Get
    Set
public:
property ElementId^ DefaultTemplateId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member DefaultTemplateId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentException | When setting this property: val is not valid as a default template id.
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
This value will be the view template for all newly created instances of this view type.
See Also

Reference

ViewFamilyType Class


ViewFamilyType.PlanViewDirection Property

ViewFamilyTypePlanViewDirection Property

The PlanViewDirection of this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PlanViewDirection PlanViewDirection { get; set; }
Public Property PlanViewDirection As PlanViewDirection
    Get
    Set
public:
property PlanViewDirection PlanViewDirection {
    PlanViewDirection get ();
    void set (PlanViewDirection value);
}
member PlanViewDirection : PlanViewDirection with get, set

Property Value

PlanViewDirection
Exceptions
Exception | Condition
ArgumentException | When setting this property: PlanViewDirection cannot be set to Undefined
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | When setting this property: View must be a Structural Plan
See Also

Reference

ViewFamilyType Class


ViewFamilyType.ViewFamily Property

ViewFamilyTypeViewFamily Property

The ViewFamily for this view type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ViewFamily ViewFamily { get; }
Public ReadOnly Property ViewFamily As ViewFamily
    Get
public:
property ViewFamily ViewFamily {
    ViewFamily get ();
}
member ViewFamily : ViewFamily with get

Property Value

ViewFamily
Example
C#
VB
C++
F#
Copy
public ViewFamily GetViewFamily(Document doc, View view)
{
    ViewFamily viewFamily = ViewFamily.Invalid;

    ElementId viewTypeId = view.GetTypeId();
    ElementId viewTypeIdOne = new ElementId(1L);
    if (viewTypeId > viewTypeIdOne) // some views may not have a ViewFamilyType
    {
        ViewFamilyType viewFamilyType = doc.GetElement(viewTypeId) as ViewFamilyType;
        viewFamily = viewFamilyType.ViewFamily;
    }

    return viewFamily;
}
Public Function GetViewFamily(doc As Document, view As View) As ViewFamily
    Dim viewFamily__1 As ViewFamily = ViewFamily.Invalid

    Dim viewTypeId As ElementId = view.GetTypeId()
    Dim viewTypeIdOne As ElementId = New ElementId(1L)
    If viewTypeId > viewTypeIdOne Then
        ' some views may not have a ViewFamilyType
        Dim viewFamilyType As ViewFamilyType = TryCast(doc.GetElement(viewTypeId), ViewFamilyType)
        viewFamily__1 = viewFamilyType.ViewFamily
    End If

    Return viewFamily__1
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

ViewFamilyType Class


ViewFamilyType Methods

The ViewFamilyType type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidDefaultTemplate | Verifies that the input can be used as a default template for this view type.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ViewFamilyType Class


ViewFamilyType.IsValidDefaultTemplate Method

ViewFamilyTypeIsValidDefaultTemplate Method

Verifies that the input can be used as a default template for this view type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidDefaultTemplate(
    ElementId templateId
)
Public Function IsValidDefaultTemplate (
    templateId As ElementId
) As Boolean
public:
bool IsValidDefaultTemplate(
    ElementId^ templateId
)
member IsValidDefaultTemplate :
        templateId : ElementId -> bool

Parameters

templateId ElementId
Id to be validated as default template.

Return Value

Boolean
True if %templateId% is valid as default template, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
The id must represent a template view that is compatible with this view type, or InvalidElementId.
See Also

Reference

ViewFamilyType Class


ViewNavigationToolSettings Class

Represents the settings contained in the document associated to the View Navigation tools (such as the View Cube).
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBViewNavigationToolSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ViewNavigationToolSettings : Element
Public Class ViewNavigationToolSettings
    Inherits Element
public ref class ViewNavigationToolSettings : public Element
type ViewNavigationToolSettings =
    class
        inherit Element
    end

The ViewNavigationToolSettings type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetHomeCamera | Gets a copy of the structure containing information about the store Home view orientation.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
 | GetViewNavigationToolSettings | Gets the instance of the settings for the given document.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsHomeCameraSet | Checks if the home view is set in the settings.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ViewNavigationToolSettings Properties

The ViewNavigationToolSettings type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

ViewNavigationToolSettings Class


ViewNavigationToolSettings Methods

The ViewNavigationToolSettings type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetHomeCamera | Gets a copy of the structure containing information about the store Home view orientation.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
 | GetViewNavigationToolSettings | Gets the instance of the settings for the given document.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsHomeCameraSet | Checks if the home view is set in the settings.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ViewNavigationToolSettings Class


ViewNavigationToolSettings.GetHomeCamera Method

ViewNavigationToolSettingsGetHomeCamera Method

Gets a copy of the structure containing information about the store Home view orientation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public HomeCamera GetHomeCamera()
Public Function GetHomeCamera As HomeCamera
public:
HomeCamera^ GetHomeCamera()
member GetHomeCamera : unit -> HomeCamera

Return Value

HomeCamera
A copy of the structure containing information about the store Home view orientation, or if there is no home view set for this document.
See Also

Reference

ViewNavigationToolSettings Class


ViewNavigationToolSettings.GetViewNavigationToolSettings Method

ViewNavigationToolSettingsGetViewNavigationToolSettings Method

Gets the instance of the settings for the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ViewNavigationToolSettings GetViewNavigationToolSettings(
    Document pADoc
)
Public Shared Function GetViewNavigationToolSettings (
    pADoc As Document
) As ViewNavigationToolSettings
public:
static ViewNavigationToolSettings^ GetViewNavigationToolSettings(
    Document^ pADoc
)
static member GetViewNavigationToolSettings :
        pADoc : Document -> ViewNavigationToolSettings

Parameters

pADoc Document
The document.

Return Value

ViewNavigationToolSettings
The instance of the settings for the given document.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ViewNavigationToolSettings Class


ViewNavigationToolSettings.IsHomeCameraSet Method

ViewNavigationToolSettingsIsHomeCameraSet Method

Checks if the home view is set in the settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsHomeCameraSet()
Public Function IsHomeCameraSet As Boolean
public:
bool IsHomeCameraSet()
member IsHomeCameraSet : unit -> bool

Return Value

Boolean
Returns true if home view is set, otherwise false.
See Also

Reference

ViewNavigationToolSettings Class


ViewNode Class

A render node that represents a view.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBRenderNode
Autodesk.Revit.DBViewNode

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ViewNode : RenderNode
Public Class ViewNode
    Inherits RenderNode
public ref class ViewNode : public RenderNode
type ViewNode =
    class
        inherit RenderNode
    end

The ViewNode type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode)
Public property | LevelOfDetail | The level of detail the view is going to be rendered at.
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode)
Public property | ViewId | The Id of the view element.
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from RenderNode)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCameraInfo | Information about the observation point (the camera) of the view.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
See also: OnViewBegin(ViewNode).
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ViewNode Properties

The ViewNode type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode)
Public property | LevelOfDetail | The level of detail the view is going to be rendered at.
Public property | NodeName | A readable name of the output node. (Inherited from RenderNode)
Public property | ViewId | The Id of the view element.
Top
See Also

Reference

ViewNode Class


ViewNode.LevelOfDetail Property

ViewNodeLevelOfDetail Property

The level of detail the view is going to be rendered at.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int LevelOfDetail { get; set; }
Public Property LevelOfDetail As Integer
    Get
    Set
public:
property int LevelOfDetail {
    int get ();
    void set (int value);
}
member LevelOfDetail : int with get, set

Property Value

Int32
Exceptions
Exception | Condition
ArgumentException | When setting this property: The level of detail is not in valid range. It must be a number between -1 and 15, all inclusive.
Remarks

The value is an integer number in range of [0,15] (inclusive), or a value {-1}. If the value is positive, Revit will use the suggested level of detail when tessellating faces; otherwise it will use its default algorithm, which is based on output resolution.

If an explicit level of detail is requested (i.e. a positive value), using a value close to the middle of the valid range yields a very reasonable tessellation. Revit uses level 8 as its 'normal' LoD.

See Also

Reference

ViewNode Class


ViewNode.ViewId Property

ViewNodeViewId Property

The Id of the view element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId ViewId { get; }
Public ReadOnly Property ViewId As ElementId
    Get
public:
property ElementId^ ViewId {
    ElementId^ get ();
}
member ViewId : ElementId with get

Property Value

ElementId
See Also

Reference

ViewNode Class


ViewNode Methods

The ViewNode type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from RenderNode)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCameraInfo | Information about the observation point (the camera) of the view.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ViewNode Class


ViewNode.GetCameraInfo Method

ViewNodeGetCameraInfo Method

Information about the observation point (the camera) of the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CameraInfo GetCameraInfo()
Public Function GetCameraInfo As CameraInfo
public:
CameraInfo^ GetCameraInfo()
member GetCameraInfo : unit -> CameraInfo

Return Value

CameraInfo
An instance of CameraInfo or if there is no info associated with the view
See Also

Reference

ViewNode Class


ViewOrientation3D Class

Container for the point and vectors which define View3D's orientation.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBViewOrientation3D

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ViewOrientation3D : IDisposable
Public Class ViewOrientation3D
    Implements IDisposable
public ref class ViewOrientation3D : IDisposable
type ViewOrientation3D =
    class
        interface IDisposable
    end

The ViewOrientation3D type exposes the following members.

Constructors
 | Name | Description
Public method | ViewOrientation3D | Constructs a new ViewOrientation3D using the input eye position, up and forward directions.
Top
Properties
 | Name | Description
Public property | EyePosition | The eye position point
Public property | ForwardDirection | The forward direction vector
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | UpDirection | The up direction vector
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ViewOrientation3D
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ViewOrientation3D Constructor

Constructs a new ViewOrientation3D using the input eye position, up and forward directions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ViewOrientation3D(
    XYZ eyePosition,
    XYZ upDirection,
    XYZ forwardDirection
)
Public Sub New (
    eyePosition As XYZ,
    upDirection As XYZ,
    forwardDirection As XYZ
)
public:
ViewOrientation3D(
    XYZ^ eyePosition,
    XYZ^ upDirection,
    XYZ^ forwardDirection
)
new :
        eyePosition : XYZ *
        upDirection : XYZ *
        forwardDirection : XYZ -> ViewOrientation3D

Parameters

eyePosition XYZ
The eye position
upDirection XYZ
The up direction. This vector will be normalized. Up direction must be perpendicular to the forward direction.
forwardDirection XYZ
The forward direction. This vector will be normalized. Forward direction must be perpendicular to the up direction.
Exceptions
Exception | Condition
ArgumentException | One or both of the input vectors cannot be normalized.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | upDirection has zero length. -or- forwardDirection has zero length.
ArgumentsInconsistentException | The vectors upDirection and forwardDirection are not perpendicular.
See Also

Reference

ViewOrientation3D Class


ViewOrientation3D Properties

The ViewOrientation3D type exposes the following members.

Properties
 | Name | Description
Public property | EyePosition | The eye position point
Public property | ForwardDirection | The forward direction vector
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | UpDirection | The up direction vector
Top
See Also

Reference

ViewOrientation3D Class


ViewOrientation3D.EyePosition Property

ViewOrientation3DEyePosition Property

The eye position point

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ EyePosition { get; }
Public ReadOnly Property EyePosition As XYZ
    Get
public:
property XYZ^ EyePosition {
    XYZ^ get ();
}
member EyePosition : XYZ with get

Property Value

XYZ
See Also

Reference

ViewOrientation3D Class


ViewOrientation3D.ForwardDirection Property

ViewOrientation3DForwardDirection Property

The forward direction vector

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ ForwardDirection { get; }
Public ReadOnly Property ForwardDirection As XYZ
    Get
public:
property XYZ^ ForwardDirection {
    XYZ^ get ();
}
member ForwardDirection : XYZ with get

Property Value

XYZ
See Also

Reference

ViewOrientation3D Class


ViewOrientation3D.IsValidObject Property

ViewOrientation3DIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ViewOrientation3D Class


ViewOrientation3D.UpDirection Property

ViewOrientation3DUpDirection Property

The up direction vector

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ UpDirection { get; }
Public ReadOnly Property UpDirection As XYZ
    Get
public:
property XYZ^ UpDirection {
    XYZ^ get ();
}
member UpDirection : XYZ with get

Property Value

XYZ
See Also

Reference

ViewOrientation3D Class


ViewOrientation3D Methods

The ViewOrientation3D type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ViewOrientation3D Class


ViewOrientation3D.Dispose Method

ViewOrientation3DDispose Method

Releases all resources used by the ViewOrientation3D

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ViewOrientation3D Class


ViewPlacementOnSheetStatus Enumeration

Indicates whether the View is placed on a Sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ViewPlacementOnSheetStatus
Public Enumeration ViewPlacementOnSheetStatus
public enum class ViewPlacementOnSheetStatus
type ViewPlacementOnSheetStatus
Members
Member name | Value | Description
NotApplicable | 0 | The View cannot be placed on Sheet.
NotPlaced | 1 | The View is not placed on a Sheet.
PartiallyPlaced | 2 | The View is partially placed on a Sheet.
CompletelyPlaced | 3 | The View is completely placed on a Sheet.
Remarks
Some Views can be placed on one or more Sheets completely or partially. For example, a Schedule divided in segments, and only some of them are placed on Sheets.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ViewPlan Class

Represents floor plan, area plan, ceiling plan, and structural plan views in Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBView
Autodesk.Revit.DBViewPlan

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ViewPlan : View
Public Class ViewPlan
    Inherits View
public ref class ViewPlan : public View
type ViewPlan =
    class
        inherit View
    end

The ViewPlan type exposes the following members.

Properties
 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View)
Public property | AreAnalyticalModelCategoriesHidden | Indicates if analytical model categories are currently hidden in the view. (Inherited from View)
Public property | AreAnnotationCategoriesHidden | Indicates if annotation categories are currently hidden in the view. (Inherited from View)
Public property | AreaScheme | The area scheme.
Public property | AreCoordinationModelHandlesHidden | Indicates if Coordination Model handles are currently hidden in the view. (Inherited from View)
Public property | AreImportCategoriesHidden | Indicates if import categories are currently hidden in the view. (Inherited from View)
Public property | AreModelCategoriesHidden | Indicates if model categories are currently hidden in the view. (Inherited from View)
Public property | ArePointCloudsHidden | Indicates if point clouds are currently hidden in the view. (Inherited from View)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CropBox | The Crop Box applied to the view, or an outline encompassing the crop region applied to the view. (Inherited from View)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | DetailLevel | The detail level of this view. (Inherited from View)
Public property | Discipline | The Discipline of the view. (Inherited from View)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | GenLevel | The level for the view. (Inherited from View)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsAssemblyView | Indicates if the view is assembly view. (Inherited from View)
Public property | IsCallout | Indicates if the view is a callout view. (Inherited from View)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | Origin | Returns the origin of the screen. (Inherited from View)
Public property | Outline | The bounds of the view in paper space (in feet). (Inherited from View)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | RevealConstraintsMode | Indicates whether the Reveal Constraints mode is activated in the view. (Inherited from View)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View)
Public property | Scale | The scale of the view. (Inherited from View)
Public property | ShadowIntensity | The intesity of cast shadows - 0 = no shadows, 100 = black. (Inherited from View)
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View)
Public property | SunlightIntensity | The intensity of the simulated (directional) sunlight. 0 = no directional light; maximum value is 100. (Inherited from View)
Public property | TemporaryViewModes | Data of temporary view modes associated with this view. (Inherited from View)
Public property | Title | The view title. This consists of the view name plus other modifiers, such as the view type, sheet number, area scheme, and/or assembly type, depending on the specifics of the view. (Inherited from View)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | ViewTemplateId | The id of the template view that controls this view's parameters. (Inherited from View)
 | ViewType | The type of the view. (Inherited from View)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | AddFilter | Adds a filter to the view. (Inherited from View)
Public method | AllowsAnalysisDisplay | Identifies if this view allows display of Analysis results. (Inherited from View)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of the input view that are not controlled by the current view template. (Inherited from View)
Public method | AreGraphicsOverridesAllowed | Determines if Visibility/Graphics Overriddes can be applied to the view. (Inherited from View)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanApplyColorFillScheme | Checks if the id can be applied as the scheme id of specified category to this view. (Inherited from View)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanCategoryBeHidden | Checks whether the category can be hidden in the view. (Inherited from View)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanEnableTemporaryViewPropertiesMode | Indicates if Temporary View Properties mode can be applied for view in current state. (Inherited from View)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified (Inherited from View)
Public method | CanUseDepthCueing | Indicates if view can use Depth Cueing (Inherited from View)
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes (Inherited from View)
Public method | CanViewBeDuplicated | Identifies if this view can be duplicated. (Inherited from View)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | CheckPlanViewRangeValidity | Checks if the plan view range is valid.
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View)
 | ConvertToIndependent | Convert the dependent view to independent. (Inherited from View)
 | Create | Creates a new ViewPlan.
 | CreateAreaPlan | Creates a new area plan ViewPlan.
Public method | CreateViewTemplate | Creates a new view template instance from this view instance. (Inherited from View)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View)
Public method | Dispose | (Inherited from Element)
 | Duplicate | Duplicates this view. (Inherited from View)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View)
Public method | EnableTemporaryViewPropertiesMode | Turns Temporary View Properties mode on or off. In this mode, any changes made to the view are temporary and will be discarded once the mode is disabled. (Inherited from View)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetBackground | Returns the current background set for the view. (Inherited from View)
Public method | GetCalloutParentId | Gets ID of the callout parent view. (Inherited from View)
Public method | GetCategoryHidden | Checks if elements of the given category are set to be invisible (hidden) in this view. (Inherited from View)
Public method | GetCategoryOverrides | Gets graphic overrides for a category in view. (Inherited from View)
Public method | GetColorFillSchemeId | Returns id of the color fill scheme element applied to the view. (Inherited from View)
Public method | GetCropRegionShapeManager | Returns an object for managing view crop region shape. (Inherited from View)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View)
Public method | GetDepthCueing | Returns the current depth cueing settings for the view. (Inherited from View)
Public method | GetDirectContext3DHandleOverrides | Returns DirectContext3D handle overrides object for the view. (Inherited from View)
Public method | GetElementOverrides | Gets graphic overrides for an element in the view. (Inherited from View)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFilterOverrides | Gets graphic overrides that a filter applies to the view. (Inherited from View)
Public method | GetFilters | Gets the filters applied to the view. (Inherited from View)
Public method | GetFilterVisibility | Gets the visibility of the elements associated with a filter. (Inherited from View)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIsFilterEnabled | Identifies if the filter is enabled in this view. (Inherited from View)
 | GetLinkOverrides | Gets the graphic overrides of a RevitLinkType or RevitLinkInstance in view. (Inherited from View)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetModelToProjectionTransforms | Gets the transforms from the model space to the view projection space. (Inherited from View)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetNonControlledTemplateParameterIds | Returns a list of parameters that are not marked as included when this view is used as a template. (Inherited from View)
Public method | GetOrderedFilters | Gets the filters applied to the view in the order they are applied. (Inherited from View)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPlacementOnSheetStatus | Determines if this view placed on a sheet completely or partially. (Inherited from View)
Public method | GetPointCloudOverrides | Returns point cloud overrides object for the view. (Inherited from View)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View)
Public method | GetReferenceCallouts | Returns element ids of all reference callouts in the view. (Inherited from View)
Public method | GetReferenceElevations | Returns element ids of all reference elevations in the view. (Inherited from View)
Public method | GetReferenceSections | Returns element ids of all reference sections in the view. (Inherited from View)
Public method | GetSketchyLines | Returns the current sketchy lines settings for the view. (Inherited from View)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTemplateParameterIds | Returns a list of parameter ids that may be controlled when this view is assigned as a template. (Inherited from View)
Public method | GetTemporaryViewPropertiesId | When Temporary View Properties mode is in progress it provides view id that overrode settings for current view. Outside Temporary View Properties mode InvalidElementId will be returned. (Inherited from View)
Public method | GetTemporaryViewPropertiesName | When Temporary View Properties mode is in progress, name of applied template is returned. Outside Temporary View Properties mode, empty string will be returned. (Inherited from View)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetUnderlayBaseLevel | Returns the element id of the level that defines the bottom of the underlay range.
Public method | GetUnderlayOrientation | Returns the underlay orientation of this view.
Public method | GetUnderlayTopLevel | Returns the element id of the level that defines the top of the underlay range.
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetViewDisplayModel | Returns the current view display model settings for the view. (Inherited from View)
Public method | GetViewRange | Gets the view range.
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View)
Public method | HasDetailLevel | Check if the view has a Detail Level property (Inherited from View)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property (Inherited from View)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property (Inherited from View)
Public method | HasViewTransforms | Returns true if the view reports model space to view projection space transforms. (Inherited from View)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View)
Public method | IsCategoryOverridable | Checks whether the category can have graphic overrides in this view. (Inherited from View)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsFilterApplied | Indicates if a filter is applied to the view. (Inherited from View)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View)
Public method | IsTemporaryViewPropertiesModeEnabled | Returns true when Temporary View Properties mode is in progress, false otherwise. (Inherited from View)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | IsValidViewTemplate | Verifies that the view represented by templateId can be set as the controlling view template for this view. (Inherited from View)
Public method | IsViewValidForTemplateCreation | Verifies that the view is valid for template creation. (Inherited from View)
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | Print | Print this view with the default view template and using the print setting of the current active document. (Inherited from View)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveCalloutParent | Replaces callout parent ID with InvalidElementId. (Inherited from View)
Public method | RemoveFilter | Removes a filter from the view. (Inherited from View)
 | RemoveLinkOverrides | Deletes the graphical link overrides in the current view. (Inherited from View)
Public method | RestoreCalloutParent | Restores callout parent ID to the original view ID if that view is still available. (Inherited from View)
Public method | SetBackground | Sets the background for the view. Background can only be set for 3d views and for Sections/Elevations. (Inherited from View)
Public method | SetCategoryHidden | Sets if elements of the given category will be visible in this view. (Inherited from View)
Public method | SetCategoryOverrides | Sets graphic overrides for a category in view. (Inherited from View)
Public method | SetColorFillSchemeId | Applies color fill scheme to this view. (Inherited from View)
Public method | SetDepthCueing | Sets the depth cueing settings for the view. (Inherited from View)
Public method | SetElementOverrides | Sets graphic overrides for an element in the view. (Inherited from View)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
 | SetFilterOverrides | Sets the overrides associated with a filter. (Inherited from View)
Public method | SetFilterVisibility | Sets the visibility of the elements associated with a filter. (Inherited from View)
Public method | SetIsFilterEnabled | Sets the filter enabled flag. (Inherited from View)
 | SetLinkOverrides | Sets the graphic overrides of a RevitLinkType or RevitLinkInstance in the view. (Inherited from View)
Public method | SetNonControlledTemplateParameterIds | Sets the parameters that will not be included when this view is used as a template. (Inherited from View)
Public method | SetSketchyLines | Sets the sketchy lines settings for the view. (Inherited from View)
Public method | SetUnderlayBaseLevel | Sets the level whose elevation will determine the bottom of the underlay range. The elevation of the next highest level will be used to determine the top of the underlay range.
Public method | SetUnderlayOrientation | Sets the underlay orientation for this view.
 | SetUnderlayRange | Sets the underlay base and underlay top to the specified levels.
Public method | SetViewDisplayModel | Sets the view display model settings for the view. (Inherited from View)
Public method | SetViewRange | Sets the view range.
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View)
 | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View)
Public method | SupportedColorFillCategoryIds | Returns collection of all category ids that correspond to elements that can potentially be colored in this view according to a color fill scheme. The set may be different depending on the view type. (Inherited from View)
Public method | SupportsRevealConstraints | Checks that the view can have the Reveal Constraints mode activated. (Inherited from View)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View)
Top
Remarks
In a plan view, the model is viewed as if cut by the cut plane and viewed from above, looking down. In ceiling plan views and structural plan views which look up, the model is viewed as if cut by the cut plane, and viewed as if looking down at a mirror.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ViewPlan Properties

The ViewPlan type exposes the following members.

Properties
 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View)
Public property | AreAnalyticalModelCategoriesHidden | Indicates if analytical model categories are currently hidden in the view. (Inherited from View)
Public property | AreAnnotationCategoriesHidden | Indicates if annotation categories are currently hidden in the view. (Inherited from View)
Public property | AreaScheme | The area scheme.
Public property | AreCoordinationModelHandlesHidden | Indicates if Coordination Model handles are currently hidden in the view. (Inherited from View)
Public property | AreImportCategoriesHidden | Indicates if import categories are currently hidden in the view. (Inherited from View)
Public property | AreModelCategoriesHidden | Indicates if model categories are currently hidden in the view. (Inherited from View)
Public property | ArePointCloudsHidden | Indicates if point clouds are currently hidden in the view. (Inherited from View)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CropBox | The Crop Box applied to the view, or an outline encompassing the crop region applied to the view. (Inherited from View)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | DetailLevel | The detail level of this view. (Inherited from View)
Public property | Discipline | The Discipline of the view. (Inherited from View)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | GenLevel | The level for the view. (Inherited from View)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsAssemblyView | Indicates if the view is assembly view. (Inherited from View)
Public property | IsCallout | Indicates if the view is a callout view. (Inherited from View)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | Origin | Returns the origin of the screen. (Inherited from View)
Public property | Outline | The bounds of the view in paper space (in feet). (Inherited from View)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | RevealConstraintsMode | Indicates whether the Reveal Constraints mode is activated in the view. (Inherited from View)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View)
Public property | Scale | The scale of the view. (Inherited from View)
Public property | ShadowIntensity | The intesity of cast shadows - 0 = no shadows, 100 = black. (Inherited from View)
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View)
Public property | SunlightIntensity | The intensity of the simulated (directional) sunlight. 0 = no directional light; maximum value is 100. (Inherited from View)
Public property | TemporaryViewModes | Data of temporary view modes associated with this view. (Inherited from View)
Public property | Title | The view title. This consists of the view name plus other modifiers, such as the view type, sheet number, area scheme, and/or assembly type, depending on the specifics of the view. (Inherited from View)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | ViewTemplateId | The id of the template view that controls this view's parameters. (Inherited from View)
 | ViewType | The type of the view. (Inherited from View)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

ViewPlan Class


ViewPlan.AreaScheme Property

ViewPlanAreaScheme Property

The area scheme.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AreaScheme AreaScheme { get; }
Public ReadOnly Property AreaScheme As AreaScheme
    Get
public:
property AreaScheme^ AreaScheme {
    AreaScheme^ get ();
}
member AreaScheme : AreaScheme with get

Property Value

AreaScheme
Returns if this plan view is not an area plan.
See Also

Reference

ViewPlan Class


ViewPlan Methods

The ViewPlan type exposes the following members.

Methods
 | Name | Description
Public method | AddFilter | Adds a filter to the view. (Inherited from View)
Public method | AllowsAnalysisDisplay | Identifies if this view allows display of Analysis results. (Inherited from View)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of the input view that are not controlled by the current view template. (Inherited from View)
Public method | AreGraphicsOverridesAllowed | Determines if Visibility/Graphics Overriddes can be applied to the view. (Inherited from View)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanApplyColorFillScheme | Checks if the id can be applied as the scheme id of specified category to this view. (Inherited from View)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanCategoryBeHidden | Checks whether the category can be hidden in the view. (Inherited from View)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanEnableTemporaryViewPropertiesMode | Indicates if Temporary View Properties mode can be applied for view in current state. (Inherited from View)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified (Inherited from View)
Public method | CanUseDepthCueing | Indicates if view can use Depth Cueing (Inherited from View)
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes (Inherited from View)
Public method | CanViewBeDuplicated | Identifies if this view can be duplicated. (Inherited from View)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | CheckPlanViewRangeValidity | Checks if the plan view range is valid.
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View)
 | ConvertToIndependent | Convert the dependent view to independent. (Inherited from View)
 | Create | Creates a new ViewPlan.
 | CreateAreaPlan | Creates a new area plan ViewPlan.
Public method | CreateViewTemplate | Creates a new view template instance from this view instance. (Inherited from View)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View)
Public method | Dispose | (Inherited from Element)
 | Duplicate | Duplicates this view. (Inherited from View)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View)
Public method | EnableTemporaryViewPropertiesMode | Turns Temporary View Properties mode on or off. In this mode, any changes made to the view are temporary and will be discarded once the mode is disabled. (Inherited from View)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetBackground | Returns the current background set for the view. (Inherited from View)
Public method | GetCalloutParentId | Gets ID of the callout parent view. (Inherited from View)
Public method | GetCategoryHidden | Checks if elements of the given category are set to be invisible (hidden) in this view. (Inherited from View)
Public method | GetCategoryOverrides | Gets graphic overrides for a category in view. (Inherited from View)
Public method | GetColorFillSchemeId | Returns id of the color fill scheme element applied to the view. (Inherited from View)
Public method | GetCropRegionShapeManager | Returns an object for managing view crop region shape. (Inherited from View)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View)
Public method | GetDepthCueing | Returns the current depth cueing settings for the view. (Inherited from View)
Public method | GetDirectContext3DHandleOverrides | Returns DirectContext3D handle overrides object for the view. (Inherited from View)
Public method | GetElementOverrides | Gets graphic overrides for an element in the view. (Inherited from View)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFilterOverrides | Gets graphic overrides that a filter applies to the view. (Inherited from View)
Public method | GetFilters | Gets the filters applied to the view. (Inherited from View)
Public method | GetFilterVisibility | Gets the visibility of the elements associated with a filter. (Inherited from View)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIsFilterEnabled | Identifies if the filter is enabled in this view. (Inherited from View)
 | GetLinkOverrides | Gets the graphic overrides of a RevitLinkType or RevitLinkInstance in view. (Inherited from View)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetModelToProjectionTransforms | Gets the transforms from the model space to the view projection space. (Inherited from View)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetNonControlledTemplateParameterIds | Returns a list of parameters that are not marked as included when this view is used as a template. (Inherited from View)
Public method | GetOrderedFilters | Gets the filters applied to the view in the order they are applied. (Inherited from View)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPlacementOnSheetStatus | Determines if this view placed on a sheet completely or partially. (Inherited from View)
Public method | GetPointCloudOverrides | Returns point cloud overrides object for the view. (Inherited from View)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View)
Public method | GetReferenceCallouts | Returns element ids of all reference callouts in the view. (Inherited from View)
Public method | GetReferenceElevations | Returns element ids of all reference elevations in the view. (Inherited from View)
Public method | GetReferenceSections | Returns element ids of all reference sections in the view. (Inherited from View)
Public method | GetSketchyLines | Returns the current sketchy lines settings for the view. (Inherited from View)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTemplateParameterIds | Returns a list of parameter ids that may be controlled when this view is assigned as a template. (Inherited from View)
Public method | GetTemporaryViewPropertiesId | When Temporary View Properties mode is in progress it provides view id that overrode settings for current view. Outside Temporary View Properties mode InvalidElementId will be returned. (Inherited from View)
Public method | GetTemporaryViewPropertiesName | When Temporary View Properties mode is in progress, name of applied template is returned. Outside Temporary View Properties mode, empty string will be returned. (Inherited from View)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetUnderlayBaseLevel | Returns the element id of the level that defines the bottom of the underlay range.
Public method | GetUnderlayOrientation | Returns the underlay orientation of this view.
Public method | GetUnderlayTopLevel | Returns the element id of the level that defines the top of the underlay range.
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetViewDisplayModel | Returns the current view display model settings for the view. (Inherited from View)
Public method | GetViewRange | Gets the view range.
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View)
Public method | HasDetailLevel | Check if the view has a Detail Level property (Inherited from View)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property (Inherited from View)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property (Inherited from View)
Public method | HasViewTransforms | Returns true if the view reports model space to view projection space transforms. (Inherited from View)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View)
Public method | IsCategoryOverridable | Checks whether the category can have graphic overrides in this view. (Inherited from View)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsFilterApplied | Indicates if a filter is applied to the view. (Inherited from View)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View)
Public method | IsTemporaryViewPropertiesModeEnabled | Returns true when Temporary View Properties mode is in progress, false otherwise. (Inherited from View)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | IsValidViewTemplate | Verifies that the view represented by templateId can be set as the controlling view template for this view. (Inherited from View)
Public method | IsViewValidForTemplateCreation | Verifies that the view is valid for template creation. (Inherited from View)
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | Print | Print this view with the default view template and using the print setting of the current active document. (Inherited from View)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveCalloutParent | Replaces callout parent ID with InvalidElementId. (Inherited from View)
Public method | RemoveFilter | Removes a filter from the view. (Inherited from View)
 | RemoveLinkOverrides | Deletes the graphical link overrides in the current view. (Inherited from View)
Public method | RestoreCalloutParent | Restores callout parent ID to the original view ID if that view is still available. (Inherited from View)
Public method | SetBackground | Sets the background for the view. Background can only be set for 3d views and for Sections/Elevations. (Inherited from View)
Public method | SetCategoryHidden | Sets if elements of the given category will be visible in this view. (Inherited from View)
Public method | SetCategoryOverrides | Sets graphic overrides for a category in view. (Inherited from View)
Public method | SetColorFillSchemeId | Applies color fill scheme to this view. (Inherited from View)
Public method | SetDepthCueing | Sets the depth cueing settings for the view. (Inherited from View)
Public method | SetElementOverrides | Sets graphic overrides for an element in the view. (Inherited from View)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
 | SetFilterOverrides | Sets the overrides associated with a filter. (Inherited from View)
Public method | SetFilterVisibility | Sets the visibility of the elements associated with a filter. (Inherited from View)
Public method | SetIsFilterEnabled | Sets the filter enabled flag. (Inherited from View)
 | SetLinkOverrides | Sets the graphic overrides of a RevitLinkType or RevitLinkInstance in the view. (Inherited from View)
Public method | SetNonControlledTemplateParameterIds | Sets the parameters that will not be included when this view is used as a template. (Inherited from View)
Public method | SetSketchyLines | Sets the sketchy lines settings for the view. (Inherited from View)
Public method | SetUnderlayBaseLevel | Sets the level whose elevation will determine the bottom of the underlay range. The elevation of the next highest level will be used to determine the top of the underlay range.
Public method | SetUnderlayOrientation | Sets the underlay orientation for this view.
 | SetUnderlayRange | Sets the underlay base and underlay top to the specified levels.
Public method | SetViewDisplayModel | Sets the view display model settings for the view. (Inherited from View)
Public method | SetViewRange | Sets the view range.
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View)
 | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View)
Public method | SupportedColorFillCategoryIds | Returns collection of all category ids that correspond to elements that can potentially be colored in this view according to a color fill scheme. The set may be different depending on the view type. (Inherited from View)
Public method | SupportsRevealConstraints | Checks that the view can have the Reveal Constraints mode activated. (Inherited from View)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View)
Top
See Also

Reference

ViewPlan Class


ViewPlan.CheckPlanViewRangeValidity Method

ViewPlanCheckPlanViewRangeValidity Method

Checks if the plan view range is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<PlanViewRangeError> CheckPlanViewRangeValidity(
    PlanViewRange planViewRange
)
Public Function CheckPlanViewRangeValidity (
    planViewRange As PlanViewRange
) As IList(Of PlanViewRangeError)
public:
IList<PlanViewRangeError>^ CheckPlanViewRangeValidity(
    PlanViewRange^ planViewRange
)
member CheckPlanViewRangeValidity :
        planViewRange : PlanViewRange -> IList<PlanViewRangeError>

Parameters

planViewRange PlanViewRange
The view range to validate.

Return Value

IList PlanViewRangeError
List of enums describing any errors in the plan view range.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ViewPlan Class


ViewPlan.Create Method

ViewPlanCreate Method

Creates a new ViewPlan.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ViewPlan Create(
    Document document,
    ElementId viewFamilyTypeId,
    ElementId levelId
)
Public Shared Function Create (
    document As Document,
    viewFamilyTypeId As ElementId,
    levelId As ElementId
) As ViewPlan
public:
static ViewPlan^ Create(
    Document^ document,
    ElementId^ viewFamilyTypeId,
    ElementId^ levelId
)
static member Create :
        document : Document *
        viewFamilyTypeId : ElementId *
        levelId : ElementId -> ViewPlan

Parameters

document Document
The document to which the ViewPlan will be added.
viewFamilyTypeId ElementId
The id of the ViewFamilyType which will be used by the new ViewPlan. The type needs to be a FloorPlan, CeilingPlan, AreaPlan, or StructuralPlan ViewType.
levelId ElementId
The id of the Level to associate with the new plan view.

Return Value

ViewPlan
The new ViewPlan.
Exceptions
Exception | Condition
ArgumentException | This view family type is not a plan view type. -or- The ElementId levelId does not correspond to a Level. -or- StructuralPlans can only be created when the structural discipline is enabled whereas FloorPlans and CeilingPlans can only be created when architecture or MEP disciplines are enabled. -or- Plan view creation is not allowed in this family.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Example
C#
VB
C++
F#
Copy
// Create a Level and a Floor Plan based on it
double elevation = 10.0;
Level level1 = Level.Create(document, elevation);
ViewPlan floorView = ViewPlan.Create(document, floorPlanId, level1.Id);

// Create another Level and a Ceiling Plan based on it
elevation += 10.0;
Level level2 = Level.Create(document, elevation);
ViewPlan ceilingView = ViewPlan.Create(document, ceilingPlanId, level2.Id);
   ' Create a Level and a Floor Plan based on it
   Dim elevation As Double = 10.0
Dim level1 As Level = Level.Create(document, elevation)
   Dim floorView As ViewPlan = ViewPlan.Create(document, floorPlanId, level1.Id)

   ' Create another Level and a Ceiling Plan based on it
   elevation += 10.0
Dim level2 As Level = Level.Create(document, elevation)
   Dim ceilingView As ViewPlan = ViewPlan.Create(document, ceilingPlanId, level2.Id)

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

ViewPlan Class


ViewPlan.CreateAreaPlan Method

ViewPlanCreateAreaPlan Method

Creates a new area plan ViewPlan.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ViewPlan CreateAreaPlan(
    Document document,
    ElementId areaSchemeId,
    ElementId levelId
)
Public Shared Function CreateAreaPlan (
    document As Document,
    areaSchemeId As ElementId,
    levelId As ElementId
) As ViewPlan
public:
static ViewPlan^ CreateAreaPlan(
    Document^ document,
    ElementId^ areaSchemeId,
    ElementId^ levelId
)
static member CreateAreaPlan :
        document : Document *
        areaSchemeId : ElementId *
        levelId : ElementId -> ViewPlan

Parameters

document Document
The document to which the area plan will be added.
areaSchemeId ElementId
The id of the AreaScheme which will be used by the area plan.
levelId ElementId
The id of the Level to associate with the area plan.

Return Value

ViewPlan
The new area plan ViewPlan.
Exceptions
Exception | Condition
ArgumentException | The AreaScheme id is not valid and cannot be used for area plan views. -or- The ElementId levelId does not correspond to a Level. -or- Plan view creation is not allowed in this family.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
See Also

Reference

ViewPlan Class


ViewPlan.GetUnderlayBaseLevel Method

ViewPlanGetUnderlayBaseLevel Method

Returns the element id of the level that defines the bottom of the underlay range.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GetUnderlayBaseLevel()
Public Function GetUnderlayBaseLevel As ElementId
public:
ElementId^ GetUnderlayBaseLevel()
member GetUnderlayBaseLevel : unit -> ElementId

Return Value

ElementId
If InvalidElementId is returned, then the underlay base level is not set and no elements will be displayed as underlay.
See Also

Reference

ViewPlan Class


ViewPlan.GetUnderlayOrientation Method

ViewPlanGetUnderlayOrientation Method

Returns the underlay orientation of this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public UnderlayOrientation GetUnderlayOrientation()
Public Function GetUnderlayOrientation As UnderlayOrientation
public:
UnderlayOrientation GetUnderlayOrientation()
member GetUnderlayOrientation : unit -> UnderlayOrientation

Return Value

UnderlayOrientation
The underlay orientation for this view.
See Also

Reference

ViewPlan Class


ViewPlan.GetUnderlayTopLevel Method

ViewPlanGetUnderlayTopLevel Method

Returns the element id of the level that defines the top of the underlay range.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GetUnderlayTopLevel()
Public Function GetUnderlayTopLevel As ElementId
public:
ElementId^ GetUnderlayTopLevel()
member GetUnderlayTopLevel : unit -> ElementId

Return Value

ElementId
If the underlay base level is a valid level, and this method returns InvalidElementId, then the underlay range is unbounded, and consists of everything above the underlay base level.
See Also

Reference

ViewPlan Class


ViewPlan.GetViewRange Method

ViewPlanGetViewRange Method

Gets the view range.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PlanViewRange GetViewRange()
Public Function GetViewRange As PlanViewRange
public:
PlanViewRange^ GetViewRange()
member GetViewRange : unit -> PlanViewRange

Return Value

PlanViewRange
The view range.
See Also

Reference

ViewPlan Class


ViewPlan.SetUnderlayBaseLevel Method

ViewPlanSetUnderlayBaseLevel Method

Sets the level whose elevation will determine the bottom of the underlay range. The elevation of the next highest level will be used to determine the top of the underlay range.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetUnderlayBaseLevel(
    ElementId levelId
)
Public Sub SetUnderlayBaseLevel (
    levelId As ElementId
)
public:
void SetUnderlayBaseLevel(
    ElementId^ levelId
)
member SetUnderlayBaseLevel :
        levelId : ElementId -> unit

Parameters

levelId ElementId
The element id of a level in the project or else InvalidElementId.
Exceptions
Exception | Condition
ArgumentException | The ElementId levelId does not correspond to a Level in the project.
ArgumentNullException | A non-optional argument was null
Remarks
If the level specified is the highest level, the underlay range will be unbounded. The underlay range will consist of everything above the specified level.
See Also

Reference

ViewPlan Class


ViewPlan.SetUnderlayOrientation Method

ViewPlanSetUnderlayOrientation Method

Sets the underlay orientation for this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetUnderlayOrientation(
    UnderlayOrientation uo
)
Public Sub SetUnderlayOrientation (
    uo As UnderlayOrientation
)
public:
void SetUnderlayOrientation(
    UnderlayOrientation uo
)
member SetUnderlayOrientation :
        uo : UnderlayOrientation -> unit

Parameters

uo UnderlayOrientation
The underlay orientation for this view.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ViewPlan Class


ViewPlan.SetUnderlayRange Method

ViewPlanSetUnderlayRange Method

Sets the underlay base and underlay top to the specified levels.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetUnderlayRange(
    ElementId baseLevelId,
    ElementId topLevelId
)
Public Sub SetUnderlayRange (
    baseLevelId As ElementId,
    topLevelId As ElementId
)
public:
void SetUnderlayRange(
    ElementId^ baseLevelId,
    ElementId^ topLevelId
)
member SetUnderlayRange :
        baseLevelId : ElementId *
        topLevelId : ElementId -> unit

Parameters

baseLevelId ElementId
The element id of a level in the project or InvalidElementId. If InvalidElementId, then the underlay base level is not set and no elements will be displayed as underlay.
topLevelId ElementId
The element id of a level in the project or InvalidElementId. If InvalidElementId, then the underlay range is unbounded.
Exceptions
Exception | Condition
ArgumentException | The ElementId baseLevelId does not correspond to a Level in the project. -or- The ElementId topLevelId does not correspond to a Level in the project. -or- The elevation of level topLevelId must be greater than the elevation of level baseLevelId.
ArgumentNullException | A non-optional argument was null
Example
C#
VB
C++
F#
Copy
private void ViewUnderlay(ViewPlan planView, ElementId topLevelId, ElementId baseLevelId)
{
    if (planView.GetUnderlayOrientation() == UnderlayOrientation.LookingDown)
    {
        if (planView.GetUnderlayTopLevel() != topLevelId)
        {
            planView.SetUnderlayRange(baseLevelId, topLevelId);
        }

        planView.SetUnderlayOrientation(UnderlayOrientation.LookingUp);
    }
}
Private Sub ViewUnderlay(planView As ViewPlan, topLevelId As ElementId, baseLevelId As ElementId)
    If planView.GetUnderlayOrientation() = UnderlayOrientation.LookingDown Then
        If planView.GetUnderlayTopLevel() <> topLevelId Then
            planView.SetUnderlayRange(baseLevelId, topLevelId)
        End If

        planView.SetUnderlayOrientation(UnderlayOrientation.LookingUp)
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

ViewPlan Class


ViewPlan.SetViewRange Method

ViewPlanSetViewRange Method

Sets the view range.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetViewRange(
    PlanViewRange planViewRange
)
Public Sub SetViewRange (
    planViewRange As PlanViewRange
)
public:
void SetViewRange(
    PlanViewRange^ planViewRange
)
member SetViewRange :
        planViewRange : PlanViewRange -> unit

Parameters

planViewRange PlanViewRange
The view range.
Exceptions
Exception | Condition
ArgumentException | Plan view range is not valid.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ViewPlan Class


ViewPlanType Enumeration

An enumerated type listing plan view types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ViewPlanType
Public Enumeration ViewPlanType
public enum class ViewPlanType
type ViewPlanType
Members
Member name | Value | Description
FloorPlan | 1 | Floor plan view.
CeilingPlan | 2 | Reflected ceiling plan view.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Viewport Class

An element that establishes the placement of a view on a sheet.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBViewport

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Viewport : Element
Public Class Viewport
    Inherits Element
public ref class Viewport : public Element
type Viewport =
    class
        inherit Element
    end

The Viewport type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LabelLineLength | The length of the viewport label line in sheet space, measured in feet.
Public property | LabelOffset | The offset is a two-dimensional vector from left bottom corner of the viewport with Rotation set to None to the left end of the viewport label line. The Z coordinate is ignored.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Rotation | The rotation of the viewport on the sheet.
Public property | SheetId | The element id of the ViewSheet on which the viewport appears, or InvalidElementId if this viewport does not associate a view with placement onto a sheet.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewId | The element id of the associated View.
Public property | ViewportPositioning | Specifies the method the viewport will be positioned on the sheet when swapped to another view. Default is set to ViewportPositioning::ViewportCenter.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
 | CanAddViewToSheet | Verifies that the view can be added to the ViewSheet.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new Viewport at a given location on a sheet.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetBoxCenter | Returns the center of the outline of the viewport on the sheet, excluding the viewport label.
Public method | GetBoxOutline | Returns the outline of the viewport on the sheet, excluding the viewport label.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLabelOutline | Gets the outline viewport's label on the sheet.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetProjectionToSheetTransform | Returns the transform from the view's projection space to the sheet space.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasViewportTransforms | Indicates if the viewport has transforms.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | IsViewIdValidForViewport | Verifies that the Viewport can change it's view id to the input %viewId%.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
 | SetBoxCenter | Moves this viewport so that the center of the box outline (excluding the viewport label) is at a given point.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Viewports are used in Revit for purposes other than placement of views on sheets. Thus iteration of viewport elements in the model may locate viewports which are not assigned to sheets; you can use the SheetId property to filter these out.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Viewport Properties

The Viewport type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LabelLineLength | The length of the viewport label line in sheet space, measured in feet.
Public property | LabelOffset | The offset is a two-dimensional vector from left bottom corner of the viewport with Rotation set to None to the left end of the viewport label line. The Z coordinate is ignored.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Rotation | The rotation of the viewport on the sheet.
Public property | SheetId | The element id of the ViewSheet on which the viewport appears, or InvalidElementId if this viewport does not associate a view with placement onto a sheet.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewId | The element id of the associated View.
Public property | ViewportPositioning | Specifies the method the viewport will be positioned on the sheet when swapped to another view. Default is set to ViewportPositioning::ViewportCenter.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

Viewport Class


Viewport.LabelLineLength Property

ViewportLabelLineLength Property

The length of the viewport label line in sheet space, measured in feet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double LabelLineLength { get; set; }
Public Property LabelLineLength As Double
    Get
    Set
public:
property double LabelLineLength {
    double get ();
    void set (double value);
}
member LabelLineLength : float with get, set

Property Value

Double
Remarks
It can be negative. The sign depends on the direction of the label line.
See Also

Reference

Viewport Class


Viewport.LabelOffset Property

ViewportLabelOffset Property

The offset is a two-dimensional vector from left bottom corner of the viewport with Rotation set to None to the left end of the viewport label line. The Z coordinate is ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ LabelOffset { get; set; }
Public Property LabelOffset As XYZ
    Get
    Set
public:
property XYZ^ LabelOffset {
    XYZ^ get ();
    void set (XYZ^ value);
}
member LabelOffset : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

Viewport Class


Viewport.Rotation Property

ViewportRotation Property

The rotation of the viewport on the sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ViewportRotation Rotation { get; set; }
Public Property Rotation As ViewportRotation
    Get
    Set
public:
property ViewportRotation Rotation {
    ViewportRotation get ();
    void set (ViewportRotation value);
}
member Rotation : ViewportRotation with get, set

Property Value

ViewportRotation
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

Viewport Class


Viewport.SheetId Property

ViewportSheetId Property

The element id of the ViewSheet on which the viewport appears, or InvalidElementId if this viewport does not associate a view with placement onto a sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId SheetId { get; }
Public ReadOnly Property SheetId As ElementId
    Get
public:
property ElementId^ SheetId {
    ElementId^ get ();
}
member SheetId : ElementId with get

Property Value

ElementId
See Also

Reference

Viewport Class


Viewport.ViewId Property

ViewportViewId Property

The element id of the associated View.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId ViewId { get; set; }
Public Property ViewId As ElementId
    Get
    Set
public:
property ElementId^ ViewId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member ViewId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

Viewport Class


Viewport.ViewportPositioning Property

ViewportViewportPositioning Property

Specifies the method the viewport will be positioned on the sheet when swapped to another view. Default is set to ViewportPositioning::ViewportCenter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ViewportPositioning ViewportPositioning { get; set; }
Public Property ViewportPositioning As ViewportPositioning
    Get
    Set
public:
property ViewportPositioning ViewportPositioning {
    ViewportPositioning get ();
    void set (ViewportPositioning value);
}
member ViewportPositioning : ViewportPositioning with get, set

Property Value

ViewportPositioning
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

Viewport Class


Viewport Methods

The Viewport type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
 | CanAddViewToSheet | Verifies that the view can be added to the ViewSheet.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new Viewport at a given location on a sheet.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetBoxCenter | Returns the center of the outline of the viewport on the sheet, excluding the viewport label.
Public method | GetBoxOutline | Returns the outline of the viewport on the sheet, excluding the viewport label.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLabelOutline | Gets the outline viewport's label on the sheet.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetProjectionToSheetTransform | Returns the transform from the view's projection space to the sheet space.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasViewportTransforms | Indicates if the viewport has transforms.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | IsViewIdValidForViewport | Verifies that the Viewport can change it's view id to the input %viewId%.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
 | SetBoxCenter | Moves this viewport so that the center of the box outline (excluding the viewport label) is at a given point.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Viewport Class


Viewport.CanAddViewToSheet Method

ViewportCanAddViewToSheet Method

Verifies that the view can be added to the ViewSheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CanAddViewToSheet(
    Document document,
    ElementId viewSheetId,
    ElementId viewId
)
Public Shared Function CanAddViewToSheet (
    document As Document,
    viewSheetId As ElementId,
    viewId As ElementId
) As Boolean
public:
static bool CanAddViewToSheet(
    Document^ document,
    ElementId^ viewSheetId,
    ElementId^ viewId
)
static member CanAddViewToSheet :
        document : Document *
        viewSheetId : ElementId *
        viewId : ElementId -> bool

Parameters

document Document
The document in which the views reside.
viewSheetId ElementId
The ViewSheet on which the view will be placed.
viewId ElementId
The view which will be checked to see if it can be placed on the sheet.

Return Value

Boolean
True if the view can be added to the ViewSheet, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Schedule views are not handled by the Viewport class. Refer to [!:Autodesk::Revit::DB::ScheduleSheetInstance::Create()] for information about adding schedules to sheets.
See Also

Reference

Viewport Class


Viewport.Create Method

ViewportCreate Method

Creates a new Viewport at a given location on a sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Viewport Create(
    Document document,
    ElementId viewSheetId,
    ElementId viewId,
    XYZ point
)
Public Shared Function Create (
    document As Document,
    viewSheetId As ElementId,
    viewId As ElementId,
    point As XYZ
) As Viewport
public:
static Viewport^ Create(
    Document^ document,
    ElementId^ viewSheetId,
    ElementId^ viewId,
    XYZ^ point
)
static member Create :
        document : Document *
        viewSheetId : ElementId *
        viewId : ElementId *
        point : XYZ -> Viewport

Parameters

document Document
The document to which the new Viewport will be added.
viewSheetId ElementId
The ViewSheet on which the new Viewport will be placed.
viewId ElementId
The view shown in the Viewport.
point XYZ
The new Viewport will be centered on this point.

Return Value

Viewport
The new Viewport.
Exceptions
Exception | Condition
ArgumentException | viewSheetId is not a ViewSheet. -or- viewId cannot be added to the ViewSheet. -or- Plan view creation is not allowed in this family.
ArgumentNullException | A non-optional argument was null
ForbiddenForDynamicUpdateException | This method may not be called during dynamic update.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
Use [!:Autodesk::Revit::DB::ScheduleSheetInstance::Create()] to add schedules to sheets.
See Also

Reference

Viewport Class


Viewport.GetBoxCenter Method

ViewportGetBoxCenter Method

Returns the center of the outline of the viewport on the sheet, excluding the viewport label.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ GetBoxCenter()
Public Function GetBoxCenter As XYZ
public:
XYZ^ GetBoxCenter()
member GetBoxCenter : unit -> XYZ

Return Value

XYZ
The center of the outline of the viewport on the sheet.
Exceptions
Exception | Condition
InvalidOperationException | The viewport is not on a sheet.
See Also

Reference

Viewport Class


Viewport.GetBoxOutline Method

ViewportGetBoxOutline Method

Returns the outline of the viewport on the sheet, excluding the viewport label.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Outline GetBoxOutline()
Public Function GetBoxOutline As Outline
public:
Outline^ GetBoxOutline()
member GetBoxOutline : unit -> Outline

Return Value

Outline
The outline of the viewport on the sheet.
Exceptions
Exception | Condition
InvalidOperationException | The viewport is not on a sheet.
See Also

Reference

Viewport Class


Viewport.GetLabelOutline Method

ViewportGetLabelOutline Method

Gets the outline viewport's label on the sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Outline GetLabelOutline()
Public Function GetLabelOutline As Outline
public:
Outline^ GetLabelOutline()
member GetLabelOutline : unit -> Outline

Return Value

Outline
The outline of the viewport's label on the sheet. The outline may be empty if there is no label.
Exceptions
Exception | Condition
InvalidOperationException | The viewport is not on a sheet.
See Also

Reference

Viewport Class


Viewport.GetProjectionToSheetTransform Method

ViewportGetProjectionToSheetTransform Method

Returns the transform from the view's projection space to the sheet space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Transform GetProjectionToSheetTransform()
Public Function GetProjectionToSheetTransform As Transform
public:
Transform^ GetProjectionToSheetTransform()
member GetProjectionToSheetTransform : unit -> Transform

Return Value

Transform
The transform from the view's projection space to the sheet space.
Exceptions
Exception | Condition
InvalidOperationException | The viewport is not on a sheet. -or- The viewport does not have transforms.
Remarks

This transform accounts for the position and rotation of a viewport on a sheet.

The transforms from the model space to the view projection space are returned by [!:View.GetModelToProjectionTransforms()].

See Also

Reference

Viewport Class


Viewport.HasViewportTransforms Method

ViewportHasViewportTransforms Method

Indicates if the viewport has transforms.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasViewportTransforms()
Public Function HasViewportTransforms As Boolean
public:
bool HasViewportTransforms()
member HasViewportTransforms : unit -> bool

Return Value

Boolean
True if the viewport has transforms, false otherwise.
Remarks
Not all viewports have transforms. For example, viewports for schedules and legends do not have transforms.
See Also

Reference

Viewport Class


Viewport.IsViewIdValidForViewport Method

ViewportIsViewIdValidForViewport Method

Verifies that the Viewport can change it's view id to the input %viewId%.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsViewIdValidForViewport(
    ElementId viewId
)
Public Function IsViewIdValidForViewport (
    viewId As ElementId
) As Boolean
public:
bool IsViewIdValidForViewport(
    ElementId^ viewId
)
member IsViewIdValidForViewport :
        viewId : ElementId -> bool

Parameters

viewId ElementId
The view which will be checked to see if it can be applied to Viewport.

Return Value

Boolean
True if the %viewId% is valid for the viewport, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

Viewport Class


Viewport.SetBoxCenter Method

ViewportSetBoxCenter Method

Moves this viewport so that the center of the box outline (excluding the viewport label) is at a given point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetBoxCenter(
    XYZ newCenterPoint
)
Public Sub SetBoxCenter (
    newCenterPoint As XYZ
)
public:
void SetBoxCenter(
    XYZ^ newCenterPoint
)
member SetBoxCenter :
        newCenterPoint : XYZ -> unit

Parameters

newCenterPoint XYZ
The desired center for the box outline.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The viewport is not on a sheet.
Example
C#
VB
C++
F#
Copy
public static void PlaceAlignedViewsAtLeftCorner(Document doc)
{
    FilteredElementCollector fec = new FilteredElementCollector(doc);
    fec.OfClass(typeof(ViewPlan));
    var viewPlans = fec.Cast<ViewPlan>().Where<ViewPlan>(vp => !vp.IsTemplate && vp.ViewType == ViewType.CeilingPlan);

    ViewPlan vp1 = viewPlans.ElementAt(0);
    ViewPlan vp2 = viewPlans.ElementAt(1);

    using (Transaction t = new Transaction(doc, "Place on sheet"))
    {
        t.Start();

        // Add two viewports distinct from one another
        ViewSheet vs = ViewSheet.Create(doc, ElementId.InvalidElementId);
        Viewport viewport1 = Viewport.Create(doc, vs.Id, vp1.Id, new XYZ(0, 0, 0));
        Viewport viewport2 = Viewport.Create(doc, vs.Id, vp2.Id, new XYZ(0, 5, 0));

        doc.Regenerate();

        // Calculate the necessary move vector to align the lower left corner
        Outline outline1 = viewport1.GetBoxOutline();
        Outline outline2 = viewport2.GetBoxOutline();
        XYZ boxCenter = viewport2.GetBoxCenter();
        XYZ vectorToCenter = boxCenter - outline2.MinimumPoint;
        XYZ newCenter = outline1.MinimumPoint + vectorToCenter;

        // Move the viewport to the new location
        viewport2.SetBoxCenter(newCenter);

        t.Commit();
    }
}
Public Shared Sub PlaceAlignedViewsAtLeftCorner(doc As Document)
    Dim fec As New FilteredElementCollector(doc)
    fec.OfClass(GetType(ViewPlan))
    Dim viewPlans = fec.Cast(Of ViewPlan)().Where(Function(vp) Not vp.IsTemplate AndAlso vp.ViewType = ViewType.CeilingPlan)

    Dim vp1 As ViewPlan = viewPlans.ElementAt(0)
    Dim vp2 As ViewPlan = viewPlans.ElementAt(1)

    Using t As New Transaction(doc, "Place on sheet")
        t.Start()

        ' Add two viewports distinct from one another
        Dim vs As ViewSheet = ViewSheet.Create(doc, ElementId.InvalidElementId)
        Dim viewport1 As Viewport = Viewport.Create(doc, vs.Id, vp1.Id, New XYZ(0, 0, 0))
        Dim viewport2 As Viewport = Viewport.Create(doc, vs.Id, vp2.Id, New XYZ(0, 5, 0))

        doc.Regenerate()

        ' Calculate the necessary move vector to align the lower left corner
        Dim outline1 As Outline = viewport1.GetBoxOutline()
        Dim outline2 As Outline = viewport2.GetBoxOutline()
        Dim boxCenter As XYZ = viewport2.GetBoxCenter()
        Dim vectorToCenter As XYZ = boxCenter - outline2.MinimumPoint
        Dim newCenter As XYZ = outline1.MinimumPoint + vectorToCenter

        ' Move the viewport to the new location
        viewport2.SetBoxCenter(newCenter)

        t.Commit()
    End Using
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Viewport Class


ViewportPositioning Enumeration

An enumerated type listing of viewport positioning options on the sheet when swapped to another view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ViewportPositioning
Public Enumeration ViewportPositioning
public enum class ViewportPositioning
type ViewportPositioning
Members
Member name | Value | Description
ViewportCenter | 0 | When swapping to another view, the center of the viewport will be maintained.
ViewOrigin | 1 | When swapping to another view, the viewport location will be based on the view origin.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ViewportRotation Enumeration

Rotation of the viewport

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ViewportRotation
Public Enumeration ViewportRotation
public enum class ViewportRotation
type ViewportRotation
Members
Member name | Value | Description
None | 0 | Viewport is not rotated.
Clockwise | 1 | Viewport is rotated 90 degrees clockwise.
Counterclockwise | 2 | Viewport is rotated 90 degrees counterclockwise.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ViewSchedule Class

A schedule view.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBView
Autodesk.Revit.DBTableView
Autodesk.Revit.DBViewSchedule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ViewSchedule : TableView
Public Class ViewSchedule
    Inherits TableView
public ref class ViewSchedule : public TableView
type ViewSchedule =
    class
        inherit TableView
    end

The ViewSchedule type exposes the following members.

Properties
 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View)
Public property | AreAnalyticalModelCategoriesHidden | Indicates if analytical model categories are currently hidden in the view. (Inherited from View)
Public property | AreAnnotationCategoriesHidden | Indicates if annotation categories are currently hidden in the view. (Inherited from View)
Public property | AreCoordinationModelHandlesHidden | Indicates if Coordination Model handles are currently hidden in the view. (Inherited from View)
Public property | AreImportCategoriesHidden | Indicates if import categories are currently hidden in the view. (Inherited from View)
Public property | AreModelCategoriesHidden | Indicates if model categories are currently hidden in the view. (Inherited from View)
Public property | ArePointCloudsHidden | Indicates if point clouds are currently hidden in the view. (Inherited from View)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View)
Public property | BodyTextTypeId | Defines the default text style used for the data section of the schedule.
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CropBox | The Crop Box applied to the view, or an outline encompassing the crop region applied to the view. (Inherited from View)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View)
Public property | Definition | The primary ScheduleDefinition.
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | DetailLevel | The detail level of this view. (Inherited from View)
Public property | Discipline | The Discipline of the view. (Inherited from View)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | EmbeddedDefinition | The embedded ScheduleDefinition.
Public property | GenLevel | The level for the view. (Inherited from View)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HasStripedRows | Indicates whether this schedule has striped rows.
Public property | HeaderTextTypeId | Defines the default text style used in the column headers in the body section of the schedule.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsAssemblyView | Indicates if the view is assembly view. (Inherited from View)
Public property | IsCallout | Indicates if the view is a callout view. (Inherited from View)
 | IsHeaderFrozen | A static property defining if the schedule header frozen setting is turned on or off in current Revit Application Session.
Public property | IsInternalKeynoteSchedule | Identifies if this ViewSchedule is an internal schedule used when keynotes are filtered based on the elements that are shown on a sheet.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View)
Public property | IsTitleblockRevisionSchedule | Identifies if this ViewSchedule is an internal schedule used to display revision schedules as part of a titleblock.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | KeyScheduleParameterName | In a key schedule, the name of the parameter for choosing one of the keys.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | MaximumColumnWidth | Gets the maximum column width (Inherited from TableView)
Public property | MaximumGridWidth | Gets the allowed maximum grid width (Inherited from TableView)
Public property | MaximumRowHeight | Gets the maximum row height (Inherited from TableView)
Public property | MinimumColumnWidth | Gets the minimum column width (Inherited from TableView)
Public property | MinimumRowHeight | Gets the minimum row height (Inherited from TableView)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | Origin | Returns the origin of the screen. (Inherited from View)
Public property | Outline | The bounds of the view in paper space (in feet). (Inherited from View)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | RevealConstraintsMode | Indicates whether the Reveal Constraints mode is activated in the view. (Inherited from View)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View)
Public property | RowHeight | Defines the schedule body rows height.
Public property | RowHeightOverride | Defines the override that is applied to the row height.
Public property | Scale | The scale of the view. (Inherited from View)
Public property | ShadowIntensity | The intesity of cast shadows - 0 = no shadows, 100 = black. (Inherited from View)
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View)
Public property | SunlightIntensity | The intensity of the simulated (directional) sunlight. 0 = no directional light; maximum value is 100. (Inherited from View)
Public property | TargetId | the element id of the element that is being viewed (Inherited from TableView)
Public property | TemporaryViewModes | Data of temporary view modes associated with this view. (Inherited from View)
Public property | Title | The view title. This consists of the view name plus other modifiers, such as the view type, sheet number, area scheme, and/or assembly type, depending on the specifics of the view. (Inherited from View)
Public property | TitleTextTypeId | Defines the default text style used in the header section of the schedule.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View)
Public property | UseStripedRowsOnSheets | Indicates whether a property setting of true will also change the display of this schedule to show striped rows on a sheet. If true, setting that property to true will also change the display. If false, striped rows will not display for this schedule on a sheet no matter what value is set for HasStripedRows.
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | ViewTemplateId | The id of the template view that controls this view's parameters. (Inherited from View)
 | ViewType | The type of the view. (Inherited from View)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | AddFilter | Adds a filter to the view. (Inherited from View)
Public method | AllowsAnalysisDisplay | Identifies if this view allows display of Analysis results. (Inherited from View)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of the input view that are not controlled by the current view template. (Inherited from View)
Public method | AreGraphicsOverridesAllowed | Determines if Visibility/Graphics Overriddes can be applied to the view. (Inherited from View)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanApplyColorFillScheme | Checks if the id can be applied as the scheme id of specified category to this view. (Inherited from View)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanCategoryBeHidden | Checks whether the category can be hidden in the view. (Inherited from View)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanEnableTemporaryViewPropertiesMode | Indicates if Temporary View Properties mode can be applied for view in current state. (Inherited from View)
Public method | CanGroupHeaders | Indicates if selected headers can be grouped for this schedule.
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified (Inherited from View)
Public method | CanUngroupHeaders | Indicates if selected headers can be ungrouped.
Public method | CanUseDepthCueing | Indicates if view can use Depth Cueing (Inherited from View)
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes (Inherited from View)
Public method | CanViewBeDuplicated | Identifies if this view can be duplicated. (Inherited from View)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View)
 | ConvertToIndependent | Convert the dependent view to independent. (Inherited from View)
 | CreateKeynoteLegend | Creates a keynote legend.
 | CreateKeySchedule | Create a key schedule.
 | CreateMaterialTakeoff | Creates a material takeoff.
 | CreateNoteBlock | Creates a note block.
 | CreateRevisionSchedule | Creates a revision schedule.
 | CreateSchedule(Document, ElementId) | Creates a regular schedule.
 | CreateSchedule(Document, ElementId, ElementId) | Creates a regular schedule that can relate to a specific area scheme.
 | CreateSheetList | Creates a sheet list.
 | CreateViewList | Creates a view list.
Public method | CreateViewTemplate | Creates a new view template instance from this view instance. (Inherited from View)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSegment | Deletes a schedule segment.
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View)
Public method | Dispose | (Inherited from Element)
 | Duplicate | Duplicates this view. (Inherited from View)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View)
Public method | EnableTemporaryViewPropertiesMode | Turns Temporary View Properties mode on or off. In this mode, any changes made to the view are temporary and will be discarded once the mode is disabled. (Inherited from View)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | Export | Exports the schedule data to a text file.
Public method | GetAvailableParameterCategories | Get all available parameter categories. (Inherited from TableView)
Public method | GetBackground | Returns the current background set for the view. (Inherited from View)
Public method | GetCalculatedValueName | Gets the calculated value name for a cell from the template view. (Inherited from TableView)
Public method | GetCalculatedValueText | Gets the calculated value text for a cell from the instance view. (Inherited from TableView)
Public method | GetCalloutParentId | Gets ID of the callout parent view. (Inherited from View)
Public method | GetCategoryHidden | Checks if elements of the given category are set to be invisible (hidden) in this view. (Inherited from View)
Public method | GetCategoryOverrides | Gets graphic overrides for a category in view. (Inherited from View)
Public method | GetCellText | Gets the cell's text based on its type (Inherited from TableView)
Public method | GetColorFillSchemeId | Returns id of the color fill scheme element applied to the view. (Inherited from View)
Public method | GetCropRegionShapeManager | Returns an object for managing view crop region shape. (Inherited from View)
 | GetDefaultNameForKeynoteLegend | Gets the default view name that will be used when creating a keynote legend.
 | GetDefaultNameForKeySchedule | Gets the default view name that will be used when creating a key schedule.
 | GetDefaultNameForMaterialTakeoff | Gets the default view name that will be used when creating a material takeoff.
 | GetDefaultNameForNoteBlock | Gets the default view name that will be used when creating a note block.
 | GetDefaultNameForRevisionSchedule | Gets the default view name that will be used when creating a revision schedule.
 | GetDefaultNameForSchedule(Document, ElementId) | Gets the default view name that will be used when creating a regular schedule.
 | GetDefaultNameForSchedule(Document, ElementId, ElementId) | Gets the default view name that will be used when creating a schedule.
 | GetDefaultNameForSheetList | Gets the default view name that will be used when creating a sheet list.
 | GetDefaultNameForViewList | Gets the default view name that will be used when creating a view list.
 | GetDefaultParameterNameForKeySchedule | Gets the default parameter name that will be used when creating a key schedule.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View)
Public method | GetDepthCueing | Returns the current depth cueing settings for the view. (Inherited from View)
Public method | GetDirectContext3DHandleOverrides | Returns DirectContext3D handle overrides object for the view. (Inherited from View)
Public method | GetElementOverrides | Gets graphic overrides for an element in the view. (Inherited from View)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFilterOverrides | Gets graphic overrides that a filter applies to the view. (Inherited from View)
Public method | GetFilters | Gets the filters applied to the view. (Inherited from View)
Public method | GetFilterVisibility | Gets the visibility of the elements associated with a filter. (Inherited from View)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIsFilterEnabled | Identifies if the filter is enabled in this view. (Inherited from View)
 | GetLinkOverrides | Gets the graphic overrides of a RevitLinkType or RevitLinkInstance in view. (Inherited from View)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetModelToProjectionTransforms | Gets the transforms from the model space to the view projection space. (Inherited from View)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetNonControlledTemplateParameterIds | Returns a list of parameters that are not marked as included when this view is used as a template. (Inherited from View)
Public method | GetOrderedFilters | Gets the filters applied to the view in the order they are applied. (Inherited from View)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPlacementOnSheetStatus | Determines if this view placed on a sheet completely or partially. (Inherited from View)
Public method | GetPointCloudOverrides | Returns point cloud overrides object for the view. (Inherited from View)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View)
Public method | GetReferenceCallouts | Returns element ids of all reference callouts in the view. (Inherited from View)
Public method | GetReferenceElevations | Returns element ids of all reference elevations in the view. (Inherited from View)
Public method | GetReferenceSections | Returns element ids of all reference sections in the view. (Inherited from View)
Public method | GetScheduleHeightsOnSheet | Gets the heights of schedule title, column header and each schedule body row.
Public method | GetScheduleInstances | Gets the instances ids of schedule or schedule segment.
Public method | GetSegmentCount | Gets the total count of schedule segments.
Public method | GetSegmentHeight | Gets the segment height.
Public method | GetSketchyLines | Returns the current sketchy lines settings for the view. (Inherited from View)
Public method | GetStripedRowsColor | Gets the color applied to part of the pattern for a schedule with striped rows.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTableData | Gets the writable table data object.
Public method | GetTemplateParameterIds | Returns a list of parameter ids that may be controlled when this view is assigned as a template. (Inherited from View)
Public method | GetTemporaryViewPropertiesId | When Temporary View Properties mode is in progress it provides view id that overrode settings for current view. Outside Temporary View Properties mode InvalidElementId will be returned. (Inherited from View)
Public method | GetTemporaryViewPropertiesName | When Temporary View Properties mode is in progress, name of applied template is returned. Outside Temporary View Properties mode, empty string will be returned. (Inherited from View)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
 | GetValidCategoriesForKeySchedule | Gets a list of categories that can be used for a key schedule.
 | GetValidCategoriesForMaterialTakeoff | Gets a list of categories that can be used for a material takeoff.
 | GetValidCategoriesForSchedule | Gets a list of categories that can be used for a regular schedule.
 | GetValidFamiliesForNoteBlock | Gets a list of families that can be used for a note block.
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetViewDisplayModel | Returns the current view display model settings for the view. (Inherited from View)
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View)
 | GroupHeaders | Groups schedule header cells.
Public method | HasDetailLevel | Check if the view has a Detail Level property (Inherited from View)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property (Inherited from View)
Public method | HasImageField | Checks whether the schedule definition includes any image-related fields and if any elements in the schedule actually have images in those fields.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property (Inherited from View)
Public method | HasViewTransforms | Returns true if the view reports model space to view projection space transforms. (Inherited from View)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View)
Public method | IsCategoryOverridable | Checks whether the category can have graphic overrides in this view. (Inherited from View)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDataOutOfDate | Indicates whether the schedule data is out of date.
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsFilterApplied | Indicates if a filter is applied to the view. (Inherited from View)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSplit | Checks if the schedule is split.
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View)
Public method | IsTemporaryViewPropertiesModeEnabled | Returns true when Temporary View Properties mode is in progress, false otherwise. (Inherited from View)
 | IsValidCategoryForKeySchedule | Checks whether a category can be used for a key schedule.
 | IsValidCategoryForMaterialTakeoff | Checks whether a category can be used for a material takeoff.
 | IsValidCategoryForSchedule | Checks whether a category can be used for a regular schedule.
 | IsValidFamilyForNoteBlock | Checks whether a family can be used for a note block.
Public method | IsValidSectionType | Identifies if the section type is valid for this view. (Inherited from TableView)
Public method | IsValidTextTypeId | Identifies if the input id represents a valid text type id for use in the schedule properties.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | IsValidViewTemplate | Verifies that the view represented by templateId can be set as the controlling view template for this view. (Inherited from View)
Public method | IsViewValidForTemplateCreation | Verifies that the view is valid for template creation. (Inherited from View)
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | MergeSegments | Merges two adjacent segments into one.
Public method | Print | Print this view with the default view template and using the print setting of the current active document. (Inherited from View)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RefreshData | Rebuilds the schedule data if it is out of date.
Public method | RemoveCalloutParent | Replaces callout parent ID with InvalidElementId. (Inherited from View)
Public method | RemoveFilter | Removes a filter from the view. (Inherited from View)
 | RemoveLinkOverrides | Deletes the graphical link overrides in the current view. (Inherited from View)
Public method | RestoreCalloutParent | Restores callout parent ID to the original view ID if that view is still available. (Inherited from View)
Public method | RestoreImageSize | Restores all images to their original sizes.
Public method | SetBackground | Sets the background for the view. Background can only be set for 3d views and for Sections/Elevations. (Inherited from View)
Public method | SetCategoryHidden | Sets if elements of the given category will be visible in this view. (Inherited from View)
Public method | SetCategoryOverrides | Sets graphic overrides for a category in view. (Inherited from View)
Public method | SetColorFillSchemeId | Applies color fill scheme to this view. (Inherited from View)
Public method | SetDepthCueing | Sets the depth cueing settings for the view. (Inherited from View)
Public method | SetElementOverrides | Sets graphic overrides for an element in the view. (Inherited from View)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
 | SetFilterOverrides | Sets the overrides associated with a filter. (Inherited from View)
Public method | SetFilterVisibility | Sets the visibility of the elements associated with a filter. (Inherited from View)
Public method | SetIsFilterEnabled | Sets the filter enabled flag. (Inherited from View)
 | SetLinkOverrides | Sets the graphic overrides of a RevitLinkType or RevitLinkInstance in the view. (Inherited from View)
Public method | SetNonControlledTemplateParameterIds | Sets the parameters that will not be included when this view is used as a template. (Inherited from View)
Public method | SetSegmentHeight | Sets the segment height.
Public method | SetSketchyLines | Sets the sketchy lines settings for the view. (Inherited from View)
Public method | SetStripedRowsColor | Sets the color applied to part of the pattern for a schedule with striped rows.
Public method | SetViewDisplayModel | Sets the view display model settings for the view. (Inherited from View)
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View)
 | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View)
Public method | Split(IListDouble) | Splits the schedule into several segments by given height of each segment.
Public method | Split(Int32) | Splits the schedule into several segments by given segment number.
Public method | SplitSegment | Splits the schedule segment by the given heights of new segments.
Public method | SupportedColorFillCategoryIds | Returns collection of all category ids that correspond to elements that can potentially be colored in this view according to a color fill scheme. The set may be different depending on the view type. (Inherited from View)
Public method | SupportsRevealConstraints | Checks that the view can have the Reveal Constraints mode activated. (Inherited from View)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UngroupHeaders | Ungroups selected headers of schedule.
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View)
Top
Remarks

The ViewSchedule class represents schedules and other schedule-like views, including single-category and multi-category schedules, key schedules, material takeoffs, view lists, sheet lists, keynote legends, revision schedules, and note blocks. The ViewSchedule class is not used for panel schedules (see PanelScheduleView) or graphical column schedules.

A schedule is a tabular representation of data. A typical schedule shows all elements of a category (doors, rooms, etc.) with each row representing an element and each column representing a parameter. This basic structure can be modified using filters, sorting, grouping, totals, formulas, and other features.

The ScheduleDefinition class contains most settings that determine the contents of a schedule, including category, fields, filters, and sorting.

A graphical representation of a schedule can be placed on a sheet using the ScheduleSheetInstance class.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ViewSchedule Properties

The ViewSchedule type exposes the following members.

Properties
 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View)
Public property | AreAnalyticalModelCategoriesHidden | Indicates if analytical model categories are currently hidden in the view. (Inherited from View)
Public property | AreAnnotationCategoriesHidden | Indicates if annotation categories are currently hidden in the view. (Inherited from View)
Public property | AreCoordinationModelHandlesHidden | Indicates if Coordination Model handles are currently hidden in the view. (Inherited from View)
Public property | AreImportCategoriesHidden | Indicates if import categories are currently hidden in the view. (Inherited from View)
Public property | AreModelCategoriesHidden | Indicates if model categories are currently hidden in the view. (Inherited from View)
Public property | ArePointCloudsHidden | Indicates if point clouds are currently hidden in the view. (Inherited from View)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View)
Public property | BodyTextTypeId | Defines the default text style used for the data section of the schedule.
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CropBox | The Crop Box applied to the view, or an outline encompassing the crop region applied to the view. (Inherited from View)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View)
Public property | Definition | The primary ScheduleDefinition.
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | DetailLevel | The detail level of this view. (Inherited from View)
Public property | Discipline | The Discipline of the view. (Inherited from View)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | EmbeddedDefinition | The embedded ScheduleDefinition.
Public property | GenLevel | The level for the view. (Inherited from View)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HasStripedRows | Indicates whether this schedule has striped rows.
Public property | HeaderTextTypeId | Defines the default text style used in the column headers in the body section of the schedule.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsAssemblyView | Indicates if the view is assembly view. (Inherited from View)
Public property | IsCallout | Indicates if the view is a callout view. (Inherited from View)
 | IsHeaderFrozen | A static property defining if the schedule header frozen setting is turned on or off in current Revit Application Session.
Public property | IsInternalKeynoteSchedule | Identifies if this ViewSchedule is an internal schedule used when keynotes are filtered based on the elements that are shown on a sheet.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View)
Public property | IsTitleblockRevisionSchedule | Identifies if this ViewSchedule is an internal schedule used to display revision schedules as part of a titleblock.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | KeyScheduleParameterName | In a key schedule, the name of the parameter for choosing one of the keys.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | MaximumColumnWidth | Gets the maximum column width (Inherited from TableView)
Public property | MaximumGridWidth | Gets the allowed maximum grid width (Inherited from TableView)
Public property | MaximumRowHeight | Gets the maximum row height (Inherited from TableView)
Public property | MinimumColumnWidth | Gets the minimum column width (Inherited from TableView)
Public property | MinimumRowHeight | Gets the minimum row height (Inherited from TableView)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | Origin | Returns the origin of the screen. (Inherited from View)
Public property | Outline | The bounds of the view in paper space (in feet). (Inherited from View)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | RevealConstraintsMode | Indicates whether the Reveal Constraints mode is activated in the view. (Inherited from View)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View)
Public property | RowHeight | Defines the schedule body rows height.
Public property | RowHeightOverride | Defines the override that is applied to the row height.
Public property | Scale | The scale of the view. (Inherited from View)
Public property | ShadowIntensity | The intesity of cast shadows - 0 = no shadows, 100 = black. (Inherited from View)
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View)
Public property | SunlightIntensity | The intensity of the simulated (directional) sunlight. 0 = no directional light; maximum value is 100. (Inherited from View)
Public property | TargetId | the element id of the element that is being viewed (Inherited from TableView)
Public property | TemporaryViewModes | Data of temporary view modes associated with this view. (Inherited from View)
Public property | Title | The view title. This consists of the view name plus other modifiers, such as the view type, sheet number, area scheme, and/or assembly type, depending on the specifics of the view. (Inherited from View)
Public property | TitleTextTypeId | Defines the default text style used in the header section of the schedule.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View)
Public property | UseStripedRowsOnSheets | Indicates whether a property setting of true will also change the display of this schedule to show striped rows on a sheet. If true, setting that property to true will also change the display. If false, striped rows will not display for this schedule on a sheet no matter what value is set for HasStripedRows.
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | ViewTemplateId | The id of the template view that controls this view's parameters. (Inherited from View)
 | ViewType | The type of the view. (Inherited from View)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

ViewSchedule Class


ViewSchedule.BodyTextTypeId Property

ViewScheduleBodyTextTypeId Property

Defines the default text style used for the data section of the schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId BodyTextTypeId { get; set; }
Public Property BodyTextTypeId As ElementId
    Get
    Set
public:
property ElementId^ BodyTextTypeId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member BodyTextTypeId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentException | When setting this property: The text type id doesn't represent a valid text type element.
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
Columns may override the default style.
See Also

Reference

ViewSchedule Class


ViewSchedule.Definition Property

ViewScheduleDefinition Property

The primary ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScheduleDefinition Definition { get; }
Public ReadOnly Property Definition As ScheduleDefinition
    Get
public:
property ScheduleDefinition^ Definition {
    ScheduleDefinition^ get ();
}
member Definition : ScheduleDefinition with get

Property Value

ScheduleDefinition
See Also

Reference

ViewSchedule Class


ViewSchedule.EmbeddedDefinition Property

ViewScheduleEmbeddedDefinition Property

The embedded ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScheduleDefinition EmbeddedDefinition { get; }
Public ReadOnly Property EmbeddedDefinition As ScheduleDefinition
    Get
public:
property ScheduleDefinition^ EmbeddedDefinition {
    ScheduleDefinition^ get ();
}
member EmbeddedDefinition : ScheduleDefinition with get

Property Value

ScheduleDefinition
See Also

Reference

ViewSchedule Class


ViewSchedule.HasStripedRows Property

ViewScheduleHasStripedRows Property

Indicates whether this schedule has striped rows.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasStripedRows { get; set; }
Public Property HasStripedRows As Boolean
    Get
    Set
public:
property bool HasStripedRows {
    bool get ();
    void set (bool value);
}
member HasStripedRows : bool with get, set

Property Value

Boolean
Remarks
Striped rows can be overridden by shading or conditional formatting.
See Also

Reference

ViewSchedule Class


ViewSchedule.HeaderTextTypeId Property

ViewScheduleHeaderTextTypeId Property

Defines the default text style used in the column headers in the body section of the schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId HeaderTextTypeId { get; set; }
Public Property HeaderTextTypeId As ElementId
    Get
    Set
public:
property ElementId^ HeaderTextTypeId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member HeaderTextTypeId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentException | When setting this property: The text type id doesn't represent a valid text type element.
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ViewSchedule Class


ViewSchedule.IsHeaderFrozen Property

ViewScheduleIsHeaderFrozen Property

A static property defining if the schedule header frozen setting is turned on or off in current Revit Application Session.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsHeaderFrozen { get; set; }
Public Shared Property IsHeaderFrozen As Boolean
    Get
    Set
public:
static property bool IsHeaderFrozen {
    bool get ();
    void set (bool value);
}
static member IsHeaderFrozen : bool with get, set

Property Value

Boolean
Remarks
The setting will be written into Revit.ini if users set the value. If users start multiple Revit sessions, the schedule header frozen setting might be different in each session. Revit.ini file stores the lastest setting no matter what the Revit session is.
See Also

Reference

ViewSchedule Class


ViewSchedule.IsInternalKeynoteSchedule Property

ViewScheduleIsInternalKeynoteSchedule Property

Identifies if this ViewSchedule is an internal schedule used when keynotes are filtered based on the elements that are shown on a sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsInternalKeynoteSchedule { get; }
Public ReadOnly Property IsInternalKeynoteSchedule As Boolean
    Get
public:
property bool IsInternalKeynoteSchedule {
    bool get ();
}
member IsInternalKeynoteSchedule : bool with get

Property Value

Boolean
Remarks
These schedules cannot be modified by the user or placed on sheets.
See Also

Reference

ViewSchedule Class


ViewSchedule.IsTitleblockRevisionSchedule Property

ViewScheduleIsTitleblockRevisionSchedule Property

Identifies if this ViewSchedule is an internal schedule used to display revision schedules as part of a titleblock.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsTitleblockRevisionSchedule { get; }
Public ReadOnly Property IsTitleblockRevisionSchedule As Boolean
    Get
public:
property bool IsTitleblockRevisionSchedule {
    bool get ();
}
member IsTitleblockRevisionSchedule : bool with get

Property Value

Boolean
Remarks
These schedules cannot be modified by the user or placed on sheets.
See Also

Reference

ViewSchedule Class


ViewSchedule.KeyScheduleParameterName Property

ViewScheduleKeyScheduleParameterName Property

In a key schedule, the name of the parameter for choosing one of the keys.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string KeyScheduleParameterName { get; set; }
Public Property KeyScheduleParameterName As String
    Get
    Set
public:
property String^ KeyScheduleParameterName {
    String^ get ();
    void set (String^ value);
}
member KeyScheduleParameterName : string with get, set

Property Value

String
The name of the key schedule parameter.
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
InvalidOperationException | This ViewSchedule is not key schedule.
ModificationForbiddenException | When setting this property: The document containing this ViewSchedule is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- When setting this property: The document containing this ViewSchedule is being loaded, or is in the midst of another sensitive process. -or- When setting this property: This ViewSchedule is an internal element, such as a component of a loaded family or a group type. -or- When setting this property: The document containing this ViewSchedule is in Group Edit Mode, Sketch Edit Mode, or Paste Mode, and the element is not a member of the group, sketch, or clipboard. -or- When setting this property: This ViewSchedule is a member of a group or sketch, and the document is not currently editing the group or sketch.
ModificationOutsideTransactionException | When setting this property: The document containing this ViewSchedule has no open transaction.
Remarks
When a key schedule is created, elements of the schedule's category receive a new parameter for choosing one of the keys defined in the key schedule. This is the name of that parameter.
See Also

Reference

ViewSchedule Class


ViewSchedule.RowHeight Property

ViewScheduleRowHeight Property

Defines the schedule body rows height.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double RowHeight { get; set; }
Public Property RowHeight As Double
    Get
    Set
public:
property double RowHeight {
    double get ();
    void set (double value);
}
member RowHeight : float with get, set

Property Value

Double
The row height for any body rows in the schedule.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The given value for rowHeight must be between 0 and 30000 feet.
InvalidOperationException | The RowHeightOverride property is set to RowHeightOverrideOptions.None.
Remarks

Setting this property will force all or image only (depending on how RowHeightOverride is defined) schedule body rows to be resized to the indicated height value (when viewed as a ScheduleSheetInstance on a ViewSheet). If the value that is set is smaller than the height of the text (single or multi line), then that value is not taken into account. To access or set this property the RowHeightOverride property should not be None

See Also

Reference

ViewSchedule Class


ViewSchedule.RowHeightOverride Property

ViewScheduleRowHeightOverride Property

Defines the override that is applied to the row height.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RowHeightOverrideOptions RowHeightOverride { get; set; }
Public Property RowHeightOverride As RowHeightOverrideOptions
    Get
    Set
public:
property RowHeightOverrideOptions RowHeightOverride {
    RowHeightOverrideOptions get ();
    void set (RowHeightOverrideOptions value);
}
member RowHeightOverride : RowHeightOverrideOptions with get, set

Property Value

RowHeightOverrideOptions
  • None to disable row height override.
  • All enables row height override for all the body rows in the schedule.
  • ImageRows enables row height override for all the schedule body rows that contains images or custom graphics.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks

Setting this property to anything but None will allow setting the RowHeight property. This is taken into account when the schedule is viewed as a ScheduleSheetInstance on a ViewSheet.

See Also

Reference

ViewSchedule Class


ViewSchedule.TitleTextTypeId Property

ViewScheduleTitleTextTypeId Property

Defines the default text style used in the header section of the schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId TitleTextTypeId { get; set; }
Public Property TitleTextTypeId As ElementId
    Get
    Set
public:
property ElementId^ TitleTextTypeId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member TitleTextTypeId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentException | When setting this property: The text type id doesn't represent a valid text type element.
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
Cells may override the default style.
See Also

Reference

ViewSchedule Class


ViewSchedule.UseStripedRowsOnSheets Property

ViewScheduleUseStripedRowsOnSheets Property

Indicates whether a property setting of true will also change the display of this schedule to show striped rows on a sheet. If true, setting that property to true will also change the display. If false, striped rows will not display for this schedule on a sheet no matter what value is set for HasStripedRows.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UseStripedRowsOnSheets { get; set; }
Public Property UseStripedRowsOnSheets As Boolean
    Get
    Set
public:
property bool UseStripedRowsOnSheets {
    bool get ();
    void set (bool value);
}
member UseStripedRowsOnSheets : bool with get, set

Property Value

Boolean
Remarks
Striped rows on sheets can be overidden by shading or conditional formatting.
See Also

Reference

ViewSchedule Class


ViewSchedule Methods

The ViewSchedule type exposes the following members.

Methods
 | Name | Description
Public method | AddFilter | Adds a filter to the view. (Inherited from View)
Public method | AllowsAnalysisDisplay | Identifies if this view allows display of Analysis results. (Inherited from View)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of the input view that are not controlled by the current view template. (Inherited from View)
Public method | AreGraphicsOverridesAllowed | Determines if Visibility/Graphics Overriddes can be applied to the view. (Inherited from View)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanApplyColorFillScheme | Checks if the id can be applied as the scheme id of specified category to this view. (Inherited from View)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanCategoryBeHidden | Checks whether the category can be hidden in the view. (Inherited from View)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanEnableTemporaryViewPropertiesMode | Indicates if Temporary View Properties mode can be applied for view in current state. (Inherited from View)
Public method | CanGroupHeaders | Indicates if selected headers can be grouped for this schedule.
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified (Inherited from View)
Public method | CanUngroupHeaders | Indicates if selected headers can be ungrouped.
Public method | CanUseDepthCueing | Indicates if view can use Depth Cueing (Inherited from View)
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes (Inherited from View)
Public method | CanViewBeDuplicated | Identifies if this view can be duplicated. (Inherited from View)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View)
 | ConvertToIndependent | Convert the dependent view to independent. (Inherited from View)
 | CreateKeynoteLegend | Creates a keynote legend.
 | CreateKeySchedule | Create a key schedule.
 | CreateMaterialTakeoff | Creates a material takeoff.
 | CreateNoteBlock | Creates a note block.
 | CreateRevisionSchedule | Creates a revision schedule.
 | CreateSchedule(Document, ElementId) | Creates a regular schedule.
 | CreateSchedule(Document, ElementId, ElementId) | Creates a regular schedule that can relate to a specific area scheme.
 | CreateSheetList | Creates a sheet list.
 | CreateViewList | Creates a view list.
Public method | CreateViewTemplate | Creates a new view template instance from this view instance. (Inherited from View)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSegment | Deletes a schedule segment.
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View)
Public method | Dispose | (Inherited from Element)
 | Duplicate | Duplicates this view. (Inherited from View)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View)
Public method | EnableTemporaryViewPropertiesMode | Turns Temporary View Properties mode on or off. In this mode, any changes made to the view are temporary and will be discarded once the mode is disabled. (Inherited from View)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | Export | Exports the schedule data to a text file.
Public method | GetAvailableParameterCategories | Get all available parameter categories. (Inherited from TableView)
Public method | GetBackground | Returns the current background set for the view. (Inherited from View)
Public method | GetCalculatedValueName | Gets the calculated value name for a cell from the template view. (Inherited from TableView)
Public method | GetCalculatedValueText | Gets the calculated value text for a cell from the instance view. (Inherited from TableView)
Public method | GetCalloutParentId | Gets ID of the callout parent view. (Inherited from View)
Public method | GetCategoryHidden | Checks if elements of the given category are set to be invisible (hidden) in this view. (Inherited from View)
Public method | GetCategoryOverrides | Gets graphic overrides for a category in view. (Inherited from View)
Public method | GetCellText | Gets the cell's text based on its type (Inherited from TableView)
Public method | GetColorFillSchemeId | Returns id of the color fill scheme element applied to the view. (Inherited from View)
Public method | GetCropRegionShapeManager | Returns an object for managing view crop region shape. (Inherited from View)
 | GetDefaultNameForKeynoteLegend | Gets the default view name that will be used when creating a keynote legend.
 | GetDefaultNameForKeySchedule | Gets the default view name that will be used when creating a key schedule.
 | GetDefaultNameForMaterialTakeoff | Gets the default view name that will be used when creating a material takeoff.
 | GetDefaultNameForNoteBlock | Gets the default view name that will be used when creating a note block.
 | GetDefaultNameForRevisionSchedule | Gets the default view name that will be used when creating a revision schedule.
 | GetDefaultNameForSchedule(Document, ElementId) | Gets the default view name that will be used when creating a regular schedule.
 | GetDefaultNameForSchedule(Document, ElementId, ElementId) | Gets the default view name that will be used when creating a schedule.
 | GetDefaultNameForSheetList | Gets the default view name that will be used when creating a sheet list.
 | GetDefaultNameForViewList | Gets the default view name that will be used when creating a view list.
 | GetDefaultParameterNameForKeySchedule | Gets the default parameter name that will be used when creating a key schedule.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View)
Public method | GetDepthCueing | Returns the current depth cueing settings for the view. (Inherited from View)
Public method | GetDirectContext3DHandleOverrides | Returns DirectContext3D handle overrides object for the view. (Inherited from View)
Public method | GetElementOverrides | Gets graphic overrides for an element in the view. (Inherited from View)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFilterOverrides | Gets graphic overrides that a filter applies to the view. (Inherited from View)
Public method | GetFilters | Gets the filters applied to the view. (Inherited from View)
Public method | GetFilterVisibility | Gets the visibility of the elements associated with a filter. (Inherited from View)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIsFilterEnabled | Identifies if the filter is enabled in this view. (Inherited from View)
 | GetLinkOverrides | Gets the graphic overrides of a RevitLinkType or RevitLinkInstance in view. (Inherited from View)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetModelToProjectionTransforms | Gets the transforms from the model space to the view projection space. (Inherited from View)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetNonControlledTemplateParameterIds | Returns a list of parameters that are not marked as included when this view is used as a template. (Inherited from View)
Public method | GetOrderedFilters | Gets the filters applied to the view in the order they are applied. (Inherited from View)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPlacementOnSheetStatus | Determines if this view placed on a sheet completely or partially. (Inherited from View)
Public method | GetPointCloudOverrides | Returns point cloud overrides object for the view. (Inherited from View)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View)
Public method | GetReferenceCallouts | Returns element ids of all reference callouts in the view. (Inherited from View)
Public method | GetReferenceElevations | Returns element ids of all reference elevations in the view. (Inherited from View)
Public method | GetReferenceSections | Returns element ids of all reference sections in the view. (Inherited from View)
Public method | GetScheduleHeightsOnSheet | Gets the heights of schedule title, column header and each schedule body row.
Public method | GetScheduleInstances | Gets the instances ids of schedule or schedule segment.
Public method | GetSegmentCount | Gets the total count of schedule segments.
Public method | GetSegmentHeight | Gets the segment height.
Public method | GetSketchyLines | Returns the current sketchy lines settings for the view. (Inherited from View)
Public method | GetStripedRowsColor | Gets the color applied to part of the pattern for a schedule with striped rows.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTableData | Gets the writable table data object.
Public method | GetTemplateParameterIds | Returns a list of parameter ids that may be controlled when this view is assigned as a template. (Inherited from View)
Public method | GetTemporaryViewPropertiesId | When Temporary View Properties mode is in progress it provides view id that overrode settings for current view. Outside Temporary View Properties mode InvalidElementId will be returned. (Inherited from View)
Public method | GetTemporaryViewPropertiesName | When Temporary View Properties mode is in progress, name of applied template is returned. Outside Temporary View Properties mode, empty string will be returned. (Inherited from View)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
 | GetValidCategoriesForKeySchedule | Gets a list of categories that can be used for a key schedule.
 | GetValidCategoriesForMaterialTakeoff | Gets a list of categories that can be used for a material takeoff.
 | GetValidCategoriesForSchedule | Gets a list of categories that can be used for a regular schedule.
 | GetValidFamiliesForNoteBlock | Gets a list of families that can be used for a note block.
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetViewDisplayModel | Returns the current view display model settings for the view. (Inherited from View)
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View)
 | GroupHeaders | Groups schedule header cells.
Public method | HasDetailLevel | Check if the view has a Detail Level property (Inherited from View)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property (Inherited from View)
Public method | HasImageField | Checks whether the schedule definition includes any image-related fields and if any elements in the schedule actually have images in those fields.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property (Inherited from View)
Public method | HasViewTransforms | Returns true if the view reports model space to view projection space transforms. (Inherited from View)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View)
Public method | IsCategoryOverridable | Checks whether the category can have graphic overrides in this view. (Inherited from View)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDataOutOfDate | Indicates whether the schedule data is out of date.
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsFilterApplied | Indicates if a filter is applied to the view. (Inherited from View)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSplit | Checks if the schedule is split.
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View)
Public method | IsTemporaryViewPropertiesModeEnabled | Returns true when Temporary View Properties mode is in progress, false otherwise. (Inherited from View)
 | IsValidCategoryForKeySchedule | Checks whether a category can be used for a key schedule.
 | IsValidCategoryForMaterialTakeoff | Checks whether a category can be used for a material takeoff.
 | IsValidCategoryForSchedule | Checks whether a category can be used for a regular schedule.
 | IsValidFamilyForNoteBlock | Checks whether a family can be used for a note block.
Public method | IsValidSectionType | Identifies if the section type is valid for this view. (Inherited from TableView)
Public method | IsValidTextTypeId | Identifies if the input id represents a valid text type id for use in the schedule properties.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | IsValidViewTemplate | Verifies that the view represented by templateId can be set as the controlling view template for this view. (Inherited from View)
Public method | IsViewValidForTemplateCreation | Verifies that the view is valid for template creation. (Inherited from View)
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | MergeSegments | Merges two adjacent segments into one.
Public method | Print | Print this view with the default view template and using the print setting of the current active document. (Inherited from View)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RefreshData | Rebuilds the schedule data if it is out of date.
Public method | RemoveCalloutParent | Replaces callout parent ID with InvalidElementId. (Inherited from View)
Public method | RemoveFilter | Removes a filter from the view. (Inherited from View)
 | RemoveLinkOverrides | Deletes the graphical link overrides in the current view. (Inherited from View)
Public method | RestoreCalloutParent | Restores callout parent ID to the original view ID if that view is still available. (Inherited from View)
Public method | RestoreImageSize | Restores all images to their original sizes.
Public method | SetBackground | Sets the background for the view. Background can only be set for 3d views and for Sections/Elevations. (Inherited from View)
Public method | SetCategoryHidden | Sets if elements of the given category will be visible in this view. (Inherited from View)
Public method | SetCategoryOverrides | Sets graphic overrides for a category in view. (Inherited from View)
Public method | SetColorFillSchemeId | Applies color fill scheme to this view. (Inherited from View)
Public method | SetDepthCueing | Sets the depth cueing settings for the view. (Inherited from View)
Public method | SetElementOverrides | Sets graphic overrides for an element in the view. (Inherited from View)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
 | SetFilterOverrides | Sets the overrides associated with a filter. (Inherited from View)
Public method | SetFilterVisibility | Sets the visibility of the elements associated with a filter. (Inherited from View)
Public method | SetIsFilterEnabled | Sets the filter enabled flag. (Inherited from View)
 | SetLinkOverrides | Sets the graphic overrides of a RevitLinkType or RevitLinkInstance in the view. (Inherited from View)
Public method | SetNonControlledTemplateParameterIds | Sets the parameters that will not be included when this view is used as a template. (Inherited from View)
Public method | SetSegmentHeight | Sets the segment height.
Public method | SetSketchyLines | Sets the sketchy lines settings for the view. (Inherited from View)
Public method | SetStripedRowsColor | Sets the color applied to part of the pattern for a schedule with striped rows.
Public method | SetViewDisplayModel | Sets the view display model settings for the view. (Inherited from View)
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View)
 | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View)
Public method | Split(IListDouble) | Splits the schedule into several segments by given height of each segment.
Public method | Split(Int32) | Splits the schedule into several segments by given segment number.
Public method | SplitSegment | Splits the schedule segment by the given heights of new segments.
Public method | SupportedColorFillCategoryIds | Returns collection of all category ids that correspond to elements that can potentially be colored in this view according to a color fill scheme. The set may be different depending on the view type. (Inherited from View)
Public method | SupportsRevealConstraints | Checks that the view can have the Reveal Constraints mode activated. (Inherited from View)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UngroupHeaders | Ungroups selected headers of schedule.
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View)
Top
See Also

Reference

ViewSchedule Class


ViewSchedule.CanGroupHeaders Method

ViewScheduleCanGroupHeaders Method

Indicates if selected headers can be grouped for this schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanGroupHeaders(
    int top,
    int left,
    int bottom,
    int right
)
Public Function CanGroupHeaders (
    top As Integer,
    left As Integer,
    bottom As Integer,
    right As Integer
) As Boolean
public:
bool CanGroupHeaders(
    int top,
    int left,
    int bottom,
    int right
)
member CanGroupHeaders :
        top : int *
        left : int *
        bottom : int *
        right : int -> bool

Parameters

top Int32
The index of the top row of the selected headers.
left Int32
The index of the left column of the selected headers.
bottom Int32
The index of the bottom row of the selected headers.
right Int32
The index of the right column of the selected headers.

Return Value

Boolean
True if the selected headers can be grouped, false otherwise.
See Also

Reference

ViewSchedule Class


ViewSchedule.CanUngroupHeaders Method

ViewScheduleCanUngroupHeaders Method

Indicates if selected headers can be ungrouped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanUngroupHeaders(
    int top,
    int left,
    int bottom,
    int right
)
Public Function CanUngroupHeaders (
    top As Integer,
    left As Integer,
    bottom As Integer,
    right As Integer
) As Boolean
public:
bool CanUngroupHeaders(
    int top,
    int left,
    int bottom,
    int right
)
member CanUngroupHeaders :
        top : int *
        left : int *
        bottom : int *
        right : int -> bool

Parameters

top Int32
The index of the top row of the selected headers.
left Int32
The index of the left column of the selected headers.
bottom Int32
The index of the bottom row of the selected headers.
right Int32
The index of the right column of the selected headers.

Return Value

Boolean
True if the selected headers can be grouped, false otherwise.
See Also

Reference

ViewSchedule Class


ViewSchedule.CreateKeynoteLegend Method

ViewScheduleCreateKeynoteLegend Method

Creates a keynote legend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ViewSchedule CreateKeynoteLegend(
    Document document
)
Public Shared Function CreateKeynoteLegend (
    document As Document
) As ViewSchedule
public:
static ViewSchedule^ CreateKeynoteLegend(
    Document^ document
)
static member CreateKeynoteLegend :
        document : Document -> ViewSchedule

Parameters

document Document
The document to which the new schedule will be added.

Return Value

ViewSchedule
The newly created schedule.
Exceptions
Exception | Condition
ArgumentException | document is not a project document.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
A keynote legend is a schedule of the Keynote Tags category.
See Also

Reference

ViewSchedule Class


ViewSchedule.CreateKeySchedule Method

ViewScheduleCreateKeySchedule Method

Create a key schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ViewSchedule CreateKeySchedule(
    Document document,
    ElementId categoryId
)
Public Shared Function CreateKeySchedule (
    document As Document,
    categoryId As ElementId
) As ViewSchedule
public:
static ViewSchedule^ CreateKeySchedule(
    Document^ document,
    ElementId^ categoryId
)
static member CreateKeySchedule :
        document : Document *
        categoryId : ElementId -> ViewSchedule

Parameters

document Document
The document to which the new schedule will be added.
categoryId ElementId
The ID of the category of elements that the schedule's keys will be associated with.

Return Value

ViewSchedule
The newly created schedule.
Exceptions
Exception | Condition
ArgumentException | document is not a project document. -or- categoryId is not a valid category for a key schedule.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
A key schedule displays abstract "key" elements that can be used to populate parameters of ordinary model elements.
See Also

Reference

ViewSchedule Class


ViewSchedule.CreateMaterialTakeoff Method

ViewScheduleCreateMaterialTakeoff Method

Creates a material takeoff.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ViewSchedule CreateMaterialTakeoff(
    Document document,
    ElementId categoryId
)
Public Shared Function CreateMaterialTakeoff (
    document As Document,
    categoryId As ElementId
) As ViewSchedule
public:
static ViewSchedule^ CreateMaterialTakeoff(
    Document^ document,
    ElementId^ categoryId
)
static member CreateMaterialTakeoff :
        document : Document *
        categoryId : ElementId -> ViewSchedule

Parameters

document Document
The document to which the new schedule will be added.
categoryId ElementId
The ID of the category whose elements will be included in the schedule, or InvalidElementId for a multi-category schedule.

Return Value

ViewSchedule
The newly created schedule.
Exceptions
Exception | Condition
ArgumentException | document is not a project document. -or- categoryId is not a valid category for a material takeoff.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
A material takeoff is a schedule that displays information about the materials that make up elements in the model. Unlike regular schedules where each row (before grouping) represents a single element, each row in a material takeoff represents a single <element, material> pair.
See Also

Reference

ViewSchedule Class


ViewSchedule.CreateNoteBlock Method

ViewScheduleCreateNoteBlock Method

Creates a note block.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ViewSchedule CreateNoteBlock(
    Document document,
    ElementId familyId
)
Public Shared Function CreateNoteBlock (
    document As Document,
    familyId As ElementId
) As ViewSchedule
public:
static ViewSchedule^ CreateNoteBlock(
    Document^ document,
    ElementId^ familyId
)
static member CreateNoteBlock :
        document : Document *
        familyId : ElementId -> ViewSchedule

Parameters

document Document
The document to which the new schedule will be added.
familyId ElementId
The ID of the family whose elements will be included in the schedule.

Return Value

ViewSchedule
The newly created schedule.
Exceptions
Exception | Condition
ArgumentException | document is not a project document. -or- familyId is not a valid family for a note block.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
A note block is a schedule of the Generic Annotations category that shows elements of a single family rather than all elements in the category.
Example
C#
VB
C++
F#
Copy
ViewSchedule noteBlockSchedule = null;

using (Transaction transaction = new Transaction(doc, "Creating Note BLock"))
{
    //Get first ElementId of a Note Block family.
    ICollection<ElementId> noteblockFamilies = ViewSchedule.GetValidFamiliesForNoteBlock(doc);
    ElementId symbolId = noteblockFamilies.First<ElementId>();

    if (!symbolId.Equals(ElementId.InvalidElementId))
    {
        transaction.Start();

        //Create a note-block view schedule.
        noteBlockSchedule = ViewSchedule.CreateNoteBlock(doc, symbolId);
    }

    if (null != areaSchedule)
    {
        transaction.Commit();
    }
    else
    {
        transaction.RollBack();
    }
}
Dim noteBlockSchedule As ViewSchedule = Nothing

Using transaction As New Transaction(doc, "Creating Note BLock")
    'Get first ElementId of a Note Block family.
    Dim noteblockFamilies As ICollection(Of ElementId) = ViewSchedule.GetValidFamiliesForNoteBlock(doc)
    Dim symbolId As ElementId = noteblockFamilies.First()

    If Not symbolId.Equals(ElementId.InvalidElementId) Then
        transaction.Start()

        'Create a note-block view schedule.
        noteBlockSchedule = ViewSchedule.CreateNoteBlock(doc, symbolId)
    End If

    If areaSchedule IsNot Nothing Then
        transaction.Commit()
    Else
        transaction.RollBack()
    End If
End Using

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

ViewSchedule Class


ViewSchedule.CreateRevisionSchedule Method

ViewScheduleCreateRevisionSchedule Method

Creates a revision schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ViewSchedule CreateRevisionSchedule(
    Document document
)
Public Shared Function CreateRevisionSchedule (
    document As Document
) As ViewSchedule
public:
static ViewSchedule^ CreateRevisionSchedule(
    Document^ document
)
static member CreateRevisionSchedule :
        document : Document -> ViewSchedule

Parameters

document Document
The titleblock family document to which the new schedule will be added.

Return Value

ViewSchedule
The newly created schedule.
Exceptions
Exception | Condition
ArgumentException | document is not a titleblock family.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
Revision schedules are added to titleblock families and become visible as part of titleblocks on sheets.
See Also

Reference

ViewSchedule Class


ViewSchedule.CreateSchedule Method

ViewScheduleCreateSchedule Method

Overload List
Name | Description
CreateSchedule(Document, ElementId) | Creates a regular schedule.
CreateSchedule(Document, ElementId, ElementId) | Creates a regular schedule that can relate to a specific area scheme.
Top
See Also

Reference

ViewSchedule Class


ViewSchedule.CreateSchedule(Document, ElementId) Method

ViewScheduleCreateSchedule(Document, ElementId) Method

Creates a regular schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ViewSchedule CreateSchedule(
    Document document,
    ElementId categoryId
)
Public Shared Function CreateSchedule (
    document As Document,
    categoryId As ElementId
) As ViewSchedule
public:
static ViewSchedule^ CreateSchedule(
    Document^ document,
    ElementId^ categoryId
)
static member CreateSchedule :
        document : Document *
        categoryId : ElementId -> ViewSchedule

Parameters

document Document
The document to which the new schedule will be added.
categoryId ElementId
The ID of the category whose elements will be included in the schedule, or InvalidElementId for a multi-category schedule.

Return Value

ViewSchedule
The newly created schedule.
Exceptions
Exception | Condition
ArgumentException | document is not a project document. -or- categoryId is not a valid category for a regular schedule. -or- The Areas category was specified but an area scheme ID was not provided.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
See Also

Reference

ViewSchedule Class
CreateSchedule Overload


ViewSchedule.CreateSchedule(Document, ElementId, ElementId) Method

ViewScheduleCreateSchedule(Document, ElementId, ElementId) Method

Creates a regular schedule that can relate to a specific area scheme.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ViewSchedule CreateSchedule(
    Document document,
    ElementId categoryId,
    ElementId areaSchemeId
)
Public Shared Function CreateSchedule (
    document As Document,
    categoryId As ElementId,
    areaSchemeId As ElementId
) As ViewSchedule
public:
static ViewSchedule^ CreateSchedule(
    Document^ document,
    ElementId^ categoryId,
    ElementId^ areaSchemeId
)
static member CreateSchedule :
        document : Document *
        categoryId : ElementId *
        areaSchemeId : ElementId -> ViewSchedule

Parameters

document Document
The document to which the new schedule will be added.
categoryId ElementId
The ID of the category whose elements will be included in the schedule, or InvalidElementId for a multi-category schedule.
areaSchemeId ElementId
The ID of an area scheme in an area schedule, InvalidElementId otherwise.

Return Value

ViewSchedule
The newly created schedule.
Exceptions
Exception | Condition
ArgumentException | document is not a project document. -or- categoryId is not a valid category for a regular schedule. -or- In a non-area schedule, areaSchemeId is not InvalidElementId. -or- In an area schedule, areaSchemeId is not the ID of an area scheme.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Example
C#
VB
C++
F#
Copy
ViewSchedule areaSchedule = null;

using (Transaction transaction = new Transaction(doc, "Creating Schedule"))
{
    transaction.Start();

    FilteredElementCollector collector = new FilteredElementCollector(doc);
    collector.OfCategory(BuiltInCategory.OST_AreaSchemes);
    //Get first ElementId of AreaScheme.
    ElementId areaSchemeId = collector.FirstElementId();
    if (areaSchemeId != null && areaSchemeId != ElementId.InvalidElementId)
    {
        // If you want to create an area schedule, you must use CreateSchedule method with three arguments.
        // The value of the second argument must be ElementId of BuiltInCategory.OST_Areas category
        // and the value of third argument must be ElementId of an AreaScheme.
        areaSchedule = Autodesk.Revit.DB.ViewSchedule.CreateSchedule(doc, new ElementId(BuiltInCategory.OST_Areas), areaSchemeId);
    }
    if (null != areaSchedule)
    {
        transaction.Commit();
    }
    else
    {
        transaction.RollBack();
    }
}
Dim areaSchedule As ViewSchedule = Nothing

Using transaction As New Transaction(doc, "Creating Schedule")
    transaction.Start()

    Dim collector As New FilteredElementCollector(doc)
    collector.OfCategory(BuiltInCategory.OST_AreaSchemes)
    'Get first ElementId of AreaScheme.
    Dim areaSchemeId As ElementId = collector.FirstElementId()
    If areaSchemeId IsNot Nothing AndAlso areaSchemeId <> ElementId.InvalidElementId Then
        ' If you want to create an area schedule, you must use CreateSchedule method with three arguments.
        ' The value of the second argument must be ElementId of BuiltInCategory.OST_Areas category
        ' and the value of third argument must be ElementId of an AreaScheme.
        areaSchedule = Autodesk.Revit.DB.ViewSchedule.CreateSchedule(doc, New ElementId(BuiltInCategory.OST_Areas), areaSchemeId)
    End If
    If areaSchedule IsNot Nothing Then
        transaction.Commit()
    Else
        transaction.RollBack()
    End If
End Using

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

ViewSchedule Class
CreateSchedule Overload


ViewSchedule.CreateSheetList Method

ViewScheduleCreateSheetList Method

Creates a sheet list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ViewSchedule CreateSheetList(
    Document document
)
Public Shared Function CreateSheetList (
    document As Document
) As ViewSchedule
public:
static ViewSchedule^ CreateSheetList(
    Document^ document
)
static member CreateSheetList :
        document : Document -> ViewSchedule

Parameters

document Document
The document to which the new schedule will be added.

Return Value

ViewSchedule
The newly created schedule.
Exceptions
Exception | Condition
ArgumentException | document is not a project document.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
A sheet list is a schedule of sheets in the project. It is a schedule of the Sheets category.
See Also

Reference

ViewSchedule Class


ViewSchedule.CreateViewList Method

ViewScheduleCreateViewList Method

Creates a view list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ViewSchedule CreateViewList(
    Document document
)
Public Shared Function CreateViewList (
    document As Document
) As ViewSchedule
public:
static ViewSchedule^ CreateViewList(
    Document^ document
)
static member CreateViewList :
        document : Document -> ViewSchedule

Parameters

document Document
The document to which the new schedule will be added.

Return Value

ViewSchedule
The newly created schedule.
Exceptions
Exception | Condition
ArgumentException | document is not a project document.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
A view list is a schedule of views in the project. It is a schedule of the Views category.
See Also

Reference

ViewSchedule Class


ViewSchedule.DeleteSegment Method

ViewScheduleDeleteSegment Method

Deletes a schedule segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void DeleteSegment(
    int segmentIndex
)
Public Sub DeleteSegment (
    segmentIndex As Integer
)
public:
void DeleteSegment(
    int segmentIndex
)
member DeleteSegment :
        segmentIndex : int -> unit

Parameters

segmentIndex Int32
Zero-based index of the segment.
Exceptions
Exception | Condition
ArgumentException | The segment index should start from 0 and be less than the total segment count.
InvalidOperationException | This ViewSchedule is not split yet.
Remarks
If the last segment is deleted, the previous one will be the last one and its height will be modified to unlimited. If one segment is deleted when there are only two segments, all the instances will be deleted and the schedule will become unsplit again.
See Also

Reference

ViewSchedule Class


ViewSchedule.Export Method

ViewScheduleExport Method

Exports the schedule data to a text file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Export(
    string folder,
    string name,
    ViewScheduleExportOptions options
)
Public Sub Export (
    folder As String,
    name As String,
    options As ViewScheduleExportOptions
)
public:
void Export(
    String^ folder,
    String^ name,
    ViewScheduleExportOptions^ options
)
member Export :
        folder : string *
        name : string *
        options : ViewScheduleExportOptions -> unit

Parameters

folder String
Path to the location where the file will be saved.
name String
Name of file.
options ViewScheduleExportOptions
Options that relate to schedule export.
Exceptions
Exception | Condition
ArgumentException | NullOrEmpty -or- Contains invalid characters.
ArgumentNullException | A non-optional argument was null
FileAccessException | The path indicated could not be accessed.
InvalidPathArgumentException | The folder does not exist.
See Also

Reference

ViewSchedule Class


ViewSchedule.GetDefaultNameForKeynoteLegend Method

ViewScheduleGetDefaultNameForKeynoteLegend Method

Gets the default view name that will be used when creating a keynote legend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetDefaultNameForKeynoteLegend(
    Document document
)
Public Shared Function GetDefaultNameForKeynoteLegend (
    document As Document
) As String
public:
static String^ GetDefaultNameForKeynoteLegend(
    Document^ document
)
static member GetDefaultNameForKeynoteLegend :
        document : Document -> string

Parameters

document Document
The document to which the new schedule will be added.

Return Value

String
The default view name.
Exceptions
Exception | Condition
ArgumentException | document is not a project document.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ViewSchedule Class


ViewSchedule.GetDefaultNameForKeySchedule Method

ViewScheduleGetDefaultNameForKeySchedule Method

Gets the default view name that will be used when creating a key schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetDefaultNameForKeySchedule(
    Document document,
    ElementId categoryId
)
Public Shared Function GetDefaultNameForKeySchedule (
    document As Document,
    categoryId As ElementId
) As String
public:
static String^ GetDefaultNameForKeySchedule(
    Document^ document,
    ElementId^ categoryId
)
static member GetDefaultNameForKeySchedule :
        document : Document *
        categoryId : ElementId -> string

Parameters

document Document
The document to which the new schedule will be added.
categoryId ElementId
The ID of the category of elements that the schedule's keys will be associated with.

Return Value

String
The default view name.
Exceptions
Exception | Condition
ArgumentException | document is not a project document. -or- categoryId is not a valid category for a key schedule.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ViewSchedule Class


ViewSchedule.GetDefaultNameForMaterialTakeoff Method

ViewScheduleGetDefaultNameForMaterialTakeoff Method

Gets the default view name that will be used when creating a material takeoff.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetDefaultNameForMaterialTakeoff(
    Document document,
    ElementId categoryId
)
Public Shared Function GetDefaultNameForMaterialTakeoff (
    document As Document,
    categoryId As ElementId
) As String
public:
static String^ GetDefaultNameForMaterialTakeoff(
    Document^ document,
    ElementId^ categoryId
)
static member GetDefaultNameForMaterialTakeoff :
        document : Document *
        categoryId : ElementId -> string

Parameters

document Document
The document to which the new schedule will be added.
categoryId ElementId
The ID of the category whose elements will be included in the schedule, or InvalidElementId for a multi-category schedule.

Return Value

String
The default view name.
Exceptions
Exception | Condition
ArgumentException | document is not a project document. -or- categoryId is not a valid category for a material takeoff.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ViewSchedule Class


ViewSchedule.GetDefaultNameForNoteBlock Method

ViewScheduleGetDefaultNameForNoteBlock Method

Gets the default view name that will be used when creating a note block.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetDefaultNameForNoteBlock(
    Document document
)
Public Shared Function GetDefaultNameForNoteBlock (
    document As Document
) As String
public:
static String^ GetDefaultNameForNoteBlock(
    Document^ document
)
static member GetDefaultNameForNoteBlock :
        document : Document -> string

Parameters

document Document
The document to which the new schedule will be added.

Return Value

String
The default view name.
Exceptions
Exception | Condition
ArgumentException | document is not a project document.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ViewSchedule Class


ViewSchedule.GetDefaultNameForRevisionSchedule Method

ViewScheduleGetDefaultNameForRevisionSchedule Method

Gets the default view name that will be used when creating a revision schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetDefaultNameForRevisionSchedule(
    Document document
)
Public Shared Function GetDefaultNameForRevisionSchedule (
    document As Document
) As String
public:
static String^ GetDefaultNameForRevisionSchedule(
    Document^ document
)
static member GetDefaultNameForRevisionSchedule :
        document : Document -> string

Parameters

document Document
The titleblock family document to which the new schedule will be added.

Return Value

String
The default view name.
Exceptions
Exception | Condition
ArgumentException | document is not a titleblock family.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ViewSchedule Class


ViewSchedule.GetDefaultNameForSchedule Method

ViewScheduleGetDefaultNameForSchedule Method

Overload List
Name | Description
GetDefaultNameForSchedule(Document, ElementId) | Gets the default view name that will be used when creating a regular schedule.
GetDefaultNameForSchedule(Document, ElementId, ElementId) | Gets the default view name that will be used when creating a schedule.
Top
See Also

Reference

ViewSchedule Class


ViewSchedule.GetDefaultNameForSchedule(Document, ElementId) Method

ViewScheduleGetDefaultNameForSchedule(Document, ElementId) Method

Gets the default view name that will be used when creating a regular schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetDefaultNameForSchedule(
    Document document,
    ElementId categoryId
)
Public Shared Function GetDefaultNameForSchedule (
    document As Document,
    categoryId As ElementId
) As String
public:
static String^ GetDefaultNameForSchedule(
    Document^ document,
    ElementId^ categoryId
)
static member GetDefaultNameForSchedule :
        document : Document *
        categoryId : ElementId -> string

Parameters

document Document
The document to which the new schedule will be added.
categoryId ElementId
The ID of the category whose elements will be included in the schedule, or InvalidElementId for a multi-category schedule.

Return Value

String
The default view name.
Exceptions
Exception | Condition
ArgumentException | document is not a project document. -or- categoryId is not a valid category for a regular schedule. -or- The Areas category was specified but an area scheme ID was not provided.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ViewSchedule Class
GetDefaultNameForSchedule Overload


ViewSchedule.GetDefaultNameForSchedule(Document, ElementId, ElementId) Method

ViewScheduleGetDefaultNameForSchedule(Document, ElementId, ElementId) Method

Gets the default view name that will be used when creating a schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetDefaultNameForSchedule(
    Document document,
    ElementId categoryId,
    ElementId areaSchemeId
)
Public Shared Function GetDefaultNameForSchedule (
    document As Document,
    categoryId As ElementId,
    areaSchemeId As ElementId
) As String
public:
static String^ GetDefaultNameForSchedule(
    Document^ document,
    ElementId^ categoryId,
    ElementId^ areaSchemeId
)
static member GetDefaultNameForSchedule :
        document : Document *
        categoryId : ElementId *
        areaSchemeId : ElementId -> string

Parameters

document Document
The document to which the new schedule will be added.
categoryId ElementId
The ID of the category whose elements will be included in the schedule, or InvalidElementId for a multi-category schedule.
areaSchemeId ElementId
The ID of an area scheme in an area schedule, InvalidElementId otherwise.

Return Value

String
The default view name.
Exceptions
Exception | Condition
ArgumentException | document is not a project document. -or- categoryId is not a valid category for a regular schedule. -or- In a non-area schedule, areaSchemeId is not InvalidElementId. -or- In an area schedule, areaSchemeId is not the ID of an area scheme.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ViewSchedule Class
GetDefaultNameForSchedule Overload


ViewSchedule.GetDefaultNameForSheetList Method

ViewScheduleGetDefaultNameForSheetList Method

Gets the default view name that will be used when creating a sheet list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetDefaultNameForSheetList(
    Document document
)
Public Shared Function GetDefaultNameForSheetList (
    document As Document
) As String
public:
static String^ GetDefaultNameForSheetList(
    Document^ document
)
static member GetDefaultNameForSheetList :
        document : Document -> string

Parameters

document Document
The document to which the new schedule will be added.

Return Value

String
The default view name.
Exceptions
Exception | Condition
ArgumentException | document is not a project document.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ViewSchedule Class


ViewSchedule.GetDefaultNameForViewList Method

ViewScheduleGetDefaultNameForViewList Method

Gets the default view name that will be used when creating a view list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetDefaultNameForViewList(
    Document document
)
Public Shared Function GetDefaultNameForViewList (
    document As Document
) As String
public:
static String^ GetDefaultNameForViewList(
    Document^ document
)
static member GetDefaultNameForViewList :
        document : Document -> string

Parameters

document Document
The document to which the new schedule will be added.

Return Value

String
The default view name.
Exceptions
Exception | Condition
ArgumentException | document is not a project document.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ViewSchedule Class


ViewSchedule.GetDefaultParameterNameForKeySchedule Method

ViewScheduleGetDefaultParameterNameForKeySchedule Method

Gets the default parameter name that will be used when creating a key schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetDefaultParameterNameForKeySchedule(
    Document document,
    ElementId categoryId
)
Public Shared Function GetDefaultParameterNameForKeySchedule (
    document As Document,
    categoryId As ElementId
) As String
public:
static String^ GetDefaultParameterNameForKeySchedule(
    Document^ document,
    ElementId^ categoryId
)
static member GetDefaultParameterNameForKeySchedule :
        document : Document *
        categoryId : ElementId -> string

Parameters

document Document
The document to which the new schedule will be added.
categoryId ElementId
The ID of the category of elements that the schedule's keys will be associated with.

Return Value

String
The default parameter name.
Exceptions
Exception | Condition
ArgumentException | document is not a project document. -or- categoryId is not a valid category for a key schedule.
ArgumentNullException | A non-optional argument was null
Remarks
See ViewSchedule.KeyScheduleParameterName for details.
See Also

Reference

ViewSchedule Class


ViewSchedule.GetScheduleHeightsOnSheet Method

ViewScheduleGetScheduleHeightsOnSheet Method

Gets the heights of schedule title, column header and each schedule body row.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScheduleHeightsOnSheet GetScheduleHeightsOnSheet()
Public Function GetScheduleHeightsOnSheet As ScheduleHeightsOnSheet
public:
ScheduleHeightsOnSheet^ GetScheduleHeightsOnSheet()
member GetScheduleHeightsOnSheet : unit -> ScheduleHeightsOnSheet

Return Value

ScheduleHeightsOnSheet
The ScheduleHeightsOnSheet which contains heights information of a schedule on sheet.
Remarks
The height is Revit's internal units value.
See Also

Reference

ViewSchedule Class


ViewSchedule.GetScheduleInstances Method

ViewScheduleGetScheduleInstances Method

Gets the instances ids of schedule or schedule segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ElementId> GetScheduleInstances(
    int segmentIndex
)
Public Function GetScheduleInstances (
    segmentIndex As Integer
) As IList(Of ElementId)
public:
IList<ElementId^>^ GetScheduleInstances(
    int segmentIndex
)
member GetScheduleInstances :
        segmentIndex : int -> IList<ElementId>

Parameters

segmentIndex Int32
Index of the segment.

Return Value

IList ElementId
The array of schedule sheet instance element ids of schedule or schedule segment.
Exceptions
Exception | Condition
ArgumentException | The segment index should start from -1 and be less than the total segment count.
Remarks

The segment index value could be -1, it means to get schedule instances for the entire schedule.

When a (primary) schedule is set to filter by sheet and placed on a sheet, it will create a new schedule with elements visible in the Viewport(s) on that sheet. The instance created belongs to the newly created schedule. Calls to GetScheduleInstances() will return instances of the newly created schedule but no instances of the primary schedule.

See Also

Reference

ViewSchedule Class


ViewSchedule.GetSegmentCount Method

ViewScheduleGetSegmentCount Method

Gets the total count of schedule segments.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetSegmentCount()
Public Function GetSegmentCount As Integer
public:
int GetSegmentCount()
member GetSegmentCount : unit -> int

Return Value

Int32
The total count of schedule segments. 1 means the schedule is not split yet.
Remarks
There will be at least one segment for a schedule.
See Also

Reference

ViewSchedule Class


ViewSchedule.GetSegmentHeight Method

ViewScheduleGetSegmentHeight Method

Gets the segment height.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetSegmentHeight(
    int segmentIndex
)
Public Function GetSegmentHeight (
    segmentIndex As Integer
) As Double
public:
double GetSegmentHeight(
    int segmentIndex
)
member GetSegmentHeight :
        segmentIndex : int -> float

Parameters

segmentIndex Int32
Zero-based index of the segment.

Return Value

Double
The segment height value.
Exceptions
Exception | Condition
ArgumentException | The segment index should start from 0 and be less than the total segment count.
Remarks
The height is Revit's internal units value of schedule header and segment body. The real height of segment on sheet may be less than the segment height get here. It is the border height of segment instance on sheet. The last segment height get here is the max value of double as the last segment height is not set to a fix value. It will be determined by whole schedule height and other segments' heights. And the border for it is max value of double.
See Also

Reference

ViewSchedule Class


ViewSchedule.GetStripedRowsColor Method

ViewScheduleGetStripedRowsColor Method

Gets the color applied to part of the pattern for a schedule with striped rows.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color GetStripedRowsColor(
    StripedRowPattern index
)
Public Function GetStripedRowsColor (
    index As StripedRowPattern
) As Color
public:
Color^ GetStripedRowsColor(
    StripedRowPattern index
)
member GetStripedRowsColor :
        index : StripedRowPattern -> Color

Parameters

index StripedRowPattern
The part of the striped row pattern.

Return Value

Color
The applied color of the pattern part.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ViewSchedule Class


ViewSchedule.GetTableData Method

ViewScheduleGetTableData Method

Gets the writable table data object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TableData GetTableData()
Public Function GetTableData As TableData
public:
TableData^ GetTableData()
member GetTableData : unit -> TableData

Return Value

TableData
The schedule data object.
See Also

Reference

ViewSchedule Class


ViewSchedule.GetValidCategoriesForKeySchedule Method

ViewScheduleGetValidCategoriesForKeySchedule Method

Gets a list of categories that can be used for a key schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ICollection<ElementId> GetValidCategoriesForKeySchedule()
Public Shared Function GetValidCategoriesForKeySchedule As ICollection(Of ElementId)
public:
static ICollection<ElementId^>^ GetValidCategoriesForKeySchedule()
static member GetValidCategoriesForKeySchedule : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
The IDs of all valid categories.
See Also

Reference

ViewSchedule Class


ViewSchedule.GetValidCategoriesForMaterialTakeoff Method

ViewScheduleGetValidCategoriesForMaterialTakeoff Method

Gets a list of categories that can be used for a material takeoff.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ICollection<ElementId> GetValidCategoriesForMaterialTakeoff()
Public Shared Function GetValidCategoriesForMaterialTakeoff As ICollection(Of ElementId)
public:
static ICollection<ElementId^>^ GetValidCategoriesForMaterialTakeoff()
static member GetValidCategoriesForMaterialTakeoff : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
The IDs of all valid categories.
See Also

Reference

ViewSchedule Class


ViewSchedule.GetValidCategoriesForSchedule Method

ViewScheduleGetValidCategoriesForSchedule Method

Gets a list of categories that can be used for a regular schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ICollection<ElementId> GetValidCategoriesForSchedule()
Public Shared Function GetValidCategoriesForSchedule As ICollection(Of ElementId)
public:
static ICollection<ElementId^>^ GetValidCategoriesForSchedule()
static member GetValidCategoriesForSchedule : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
The IDs of all valid categories.
See Also

Reference

ViewSchedule Class


ViewSchedule.GetValidFamiliesForNoteBlock Method

ViewScheduleGetValidFamiliesForNoteBlock Method

Gets a list of families that can be used for a note block.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ICollection<ElementId> GetValidFamiliesForNoteBlock(
    Document document
)
Public Shared Function GetValidFamiliesForNoteBlock (
    document As Document
) As ICollection(Of ElementId)
public:
static ICollection<ElementId^>^ GetValidFamiliesForNoteBlock(
    Document^ document
)
static member GetValidFamiliesForNoteBlock :
        document : Document -> ICollection<ElementId>

Parameters

document Document
The document.

Return Value

ICollection ElementId
The IDs of all valid families.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ViewSchedule Class


ViewSchedule.GroupHeaders Method

ViewScheduleGroupHeaders Method

Groups schedule header cells.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void GroupHeaders(
    int top,
    int left,
    int bottom,
    int right,
    string caption
)
Public Sub GroupHeaders (
    top As Integer,
    left As Integer,
    bottom As Integer,
    right As Integer,
    caption As String
)
public:
void GroupHeaders(
    int top,
    int left,
    int bottom,
    int right,
    String^ caption
)
member GroupHeaders :
        top : int *
        left : int *
        bottom : int *
        right : int *
        caption : string -> unit

Parameters

top Int32
The index of the top row of the selected headers.
left Int32
The index of the left column of the selected headers.
bottom Int32
The index of the bottom row of the selected headers.
right Int32
The index of the right column of the selected headers.
caption String
The header caption.
Exceptions
Exception | Condition
ArgumentException | Headers could not be grouped.
ArgumentNullException | A non-optional argument was null
Example
C#
VB
C++
F#
Copy
public static void CreateSingleCategoryScheduleWithGroupedColumnHeaders(Document doc)
{
    using (Transaction t = new Transaction(doc, "Create single-category with grouped column headers"))
    {
        // Build the schedule
        t.Start();
        ViewSchedule vs = ViewSchedule.CreateSchedule(doc, new ElementId(BuiltInCategory.OST_Windows));

        AddRegularFieldToSchedule(vs, new ElementId(BuiltInParameter.WINDOW_HEIGHT));
        AddRegularFieldToSchedule(vs, new ElementId(BuiltInParameter.WINDOW_WIDTH));
        AddRegularFieldToSchedule(vs, new ElementId(BuiltInParameter.ALL_MODEL_MARK));
        AddRegularFieldToSchedule(vs, new ElementId(BuiltInParameter.ALL_MODEL_COST));

        doc.Regenerate();

        // Group the headers in the body section using ViewSchedule methods
        vs.GroupHeaders(0, 0, 0, 1, "Size");
        vs.GroupHeaders(0, 2, 0, 3, "Other");
        vs.GroupHeaders(0, 0, 0, 3, "All");

        t.Commit();
    }
}

/// <summary>
/// Adds a single parameter field to the schedule
/// </summary>
public static void AddRegularFieldToSchedule(ViewSchedule schedule, ElementId paramId)
{
    ScheduleDefinition definition = schedule.Definition;

    // Find a matching SchedulableField
    SchedulableField schedulableField =
        definition.GetSchedulableFields().FirstOrDefault<SchedulableField>(sf => sf.ParameterId == paramId);

    if (schedulableField != null)
    {
        // Add the found field
        definition.AddField(schedulableField);
    }
}
Public Shared Sub CreateSingleCategoryScheduleWithGroupedColumnHeaders(doc As Document)
    Using t As New Transaction(doc, "Create single-category with grouped column headers")
        ' Build the schedule
        t.Start()
        Dim vs As ViewSchedule = ViewSchedule.CreateSchedule(doc, New ElementId(BuiltInCategory.OST_Windows))

        AddRegularFieldToSchedule(vs, New ElementId(BuiltInParameter.WINDOW_HEIGHT))
        AddRegularFieldToSchedule(vs, New ElementId(BuiltInParameter.WINDOW_WIDTH))
        AddRegularFieldToSchedule(vs, New ElementId(BuiltInParameter.ALL_MODEL_MARK))
        AddRegularFieldToSchedule(vs, New ElementId(BuiltInParameter.ALL_MODEL_COST))

        doc.Regenerate()

        ' Group the headers in the body section using ViewSchedule methods
        vs.GroupHeaders(0, 0, 0, 1, "Size")
        vs.GroupHeaders(0, 2, 0, 3, "Other")
        vs.GroupHeaders(0, 0, 0, 3, "All")

        t.Commit()
    End Using
End Sub

' <summary>
' Adds a single parameter field to the schedule
' </summary>
Public Shared Sub AddRegularFieldToSchedule(schedule As ViewSchedule, paramId As ElementId)
    Dim definition As ScheduleDefinition = schedule.Definition

    ' Find a matching SchedulableField
    Dim schedulableField As SchedulableField = definition.GetSchedulableFields().FirstOrDefault(Function(sf) sf.ParameterId = paramId)

    If schedulableField IsNot Nothing Then
        ' Add the found field
        definition.AddField(schedulableField)
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

ViewSchedule Class


ViewSchedule.HasImageField Method

ViewScheduleHasImageField Method

Checks whether the schedule definition includes any image-related fields and if any elements in the schedule actually have images in those fields.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasImageField()
Public Function HasImageField As Boolean
public:
bool HasImageField()
member HasImageField : unit -> bool

Return Value

Boolean
True if the schedule has at least one image field showing at least one image, false otherwise
Remarks
This method may return an incorrect value if the data of the schedule view is out of date. Check [!:IsDataOutOfData()], and call RefreshData to ensure that the return value is correct.
See Also

Reference

ViewSchedule Class


ViewSchedule.IsDataOutOfDate Method

ViewScheduleIsDataOutOfDate Method

Indicates whether the schedule data is out of date.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsDataOutOfDate()
Public Function IsDataOutOfDate As Boolean
public:
bool IsDataOutOfDate()
member IsDataOutOfDate : unit -> bool

Return Value

Boolean
True if the schedule data is out of date, false otherwise.
Remarks
To improve performance, the ViewSchedule may contain TableSections that are only updated on demand. For example, the body section of a schedule is not updated when the ViewSchedule is closed. In this case, you need to call RefreshData to avoid getting the stale data.
See Also

Reference

ViewSchedule Class


ViewSchedule.IsSplit Method

ViewScheduleIsSplit Method

Checks if the schedule is split.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSplit()
Public Function IsSplit As Boolean
public:
bool IsSplit()
member IsSplit : unit -> bool

Return Value

Boolean
True if the schedule is split. Otherwise false.
See Also

Reference

ViewSchedule Class


ViewSchedule.IsValidCategoryForKeySchedule Method

ViewScheduleIsValidCategoryForKeySchedule Method

Checks whether a category can be used for a key schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidCategoryForKeySchedule(
    ElementId categoryId
)
Public Shared Function IsValidCategoryForKeySchedule (
    categoryId As ElementId
) As Boolean
public:
static bool IsValidCategoryForKeySchedule(
    ElementId^ categoryId
)
static member IsValidCategoryForKeySchedule :
        categoryId : ElementId -> bool

Parameters

categoryId ElementId
The category ID to check.

Return Value

Boolean
True if the category can be used for a key schedule, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ViewSchedule Class


ViewSchedule.IsValidCategoryForMaterialTakeoff Method

ViewScheduleIsValidCategoryForMaterialTakeoff Method

Checks whether a category can be used for a material takeoff.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidCategoryForMaterialTakeoff(
    ElementId categoryId
)
Public Shared Function IsValidCategoryForMaterialTakeoff (
    categoryId As ElementId
) As Boolean
public:
static bool IsValidCategoryForMaterialTakeoff(
    ElementId^ categoryId
)
static member IsValidCategoryForMaterialTakeoff :
        categoryId : ElementId -> bool

Parameters

categoryId ElementId
The category ID to check.

Return Value

Boolean
True if the category can be used for a material takeoff, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ViewSchedule Class


ViewSchedule.IsValidCategoryForSchedule Method

ViewScheduleIsValidCategoryForSchedule Method

Checks whether a category can be used for a regular schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidCategoryForSchedule(
    ElementId categoryId
)
Public Shared Function IsValidCategoryForSchedule (
    categoryId As ElementId
) As Boolean
public:
static bool IsValidCategoryForSchedule(
    ElementId^ categoryId
)
static member IsValidCategoryForSchedule :
        categoryId : ElementId -> bool

Parameters

categoryId ElementId
The category ID to check.

Return Value

Boolean
True if the category can be used for a regular schedule, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ViewSchedule Class


ViewSchedule.IsValidFamilyForNoteBlock Method

ViewScheduleIsValidFamilyForNoteBlock Method

Checks whether a family can be used for a note block.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidFamilyForNoteBlock(
    Document document,
    ElementId familyId
)
Public Shared Function IsValidFamilyForNoteBlock (
    document As Document,
    familyId As ElementId
) As Boolean
public:
static bool IsValidFamilyForNoteBlock(
    Document^ document,
    ElementId^ familyId
)
static member IsValidFamilyForNoteBlock :
        document : Document *
        familyId : ElementId -> bool

Parameters

document Document
The document.
familyId ElementId
The family ID to check.

Return Value

Boolean
True if the family can be used for a note block, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ViewSchedule Class


ViewSchedule.IsValidTextTypeId Method

ViewScheduleIsValidTextTypeId Method

Identifies if the input id represents a valid text type id for use in the schedule properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidTextTypeId(
    ElementId textTypeId
)
Public Function IsValidTextTypeId (
    textTypeId As ElementId
) As Boolean
public:
bool IsValidTextTypeId(
    ElementId^ textTypeId
)
member IsValidTextTypeId :
        textTypeId : ElementId -> bool

Parameters

textTypeId ElementId
The element id of the text type.

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ViewSchedule Class


ViewSchedule.MergeSegments Method

ViewScheduleMergeSegments Method

Merges two adjacent segments into one.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void MergeSegments(
    int movedSegmentIndex,
    int targetSegmentIndex
)
Public Sub MergeSegments (
    movedSegmentIndex As Integer,
    targetSegmentIndex As Integer
)
public:
void MergeSegments(
    int movedSegmentIndex,
    int targetSegmentIndex
)
member MergeSegments :
        movedSegmentIndex : int *
        targetSegmentIndex : int -> unit

Parameters

movedSegmentIndex Int32
The index of the moved segment.
targetSegmentIndex Int32
The index of the target segment.
Exceptions
Exception | Condition
ArgumentException | Only two adjacent segments can be merged. -or- The segment index should start from 0 and be less than the total segment count.
Remarks
Only adjacent segments can be merged. The moved segment will be deleted with all its instances on sheet and all the data will be merged into the target segment with height expanded.
See Also

Reference

ViewSchedule Class


ViewSchedule.RefreshData Method

ViewScheduleRefreshData Method

Rebuilds the schedule data if it is out of date.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool RefreshData()
Public Function RefreshData As Boolean
public:
bool RefreshData()
member RefreshData : unit -> bool

Return Value

Boolean
True if the data is up to date after the refresh.
See Also

Reference

ViewSchedule Class


ViewSchedule.RestoreImageSize Method

ViewScheduleRestoreImageSize Method

Restores all images to their original sizes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RestoreImageSize()
Public Sub RestoreImageSize
public:
void RestoreImageSize()
member RestoreImageSize : unit -> unit
Remarks

All images in the schedule will be restored to their original sizes when viewed as a ScheduleSheetInstance on a ViewSheet. This reverts any changes made by setting RowHeight. Calling this method has no effect if HasImageField is false.

In the schedule view the column widths will be adjusted to match the image sizes, but only the name of the image will be shown. For example, the users can attach different images to the kinds of rebar instances. These images may have different sizes. When the users create the rebar schedule with this image field, by default the column width of this image field is equal to other fields, which means it is not associated with the image original sizes during the schedule creation.

See Also

Reference

ViewSchedule Class


ViewSchedule.SetSegmentHeight Method

ViewScheduleSetSegmentHeight Method

Sets the segment height.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetSegmentHeight(
    int segmentIndex,
    double height
)
Public Sub SetSegmentHeight (
    segmentIndex As Integer,
    height As Double
)
public:
void SetSegmentHeight(
    int segmentIndex,
    double height
)
member SetSegmentHeight :
        segmentIndex : int *
        height : float -> unit

Parameters

segmentIndex Int32
Index of the segment.
height Double
New height for the segment.
Exceptions
Exception | Condition
ArgumentException | segmentIndex must be between 0 and the last second of all segments.
ArgumentOutOfRangeException | The given value for height must be greater than 0 and no more than 30000 feet.
Remarks
The height is Revit's internal units value of schedule header and segment body. The last segment can not set height. Its height will be determined by whole schedule height and other segments' heights. The height will not be the exact segment height on sheet. It will be the border height of the instance. The real height will be determined by the segment content. If the row cannot be shown within the instance boder, it will flow to the next segment.
See Also

Reference

ViewSchedule Class


ViewSchedule.SetStripedRowsColor Method

ViewScheduleSetStripedRowsColor Method

Sets the color applied to part of the pattern for a schedule with striped rows.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetStripedRowsColor(
    StripedRowPattern index,
    Color color
)
Public Sub SetStripedRowsColor (
    index As StripedRowPattern,
    color As Color
)
public:
void SetStripedRowsColor(
    StripedRowPattern index,
    Color^ color
)
member SetStripedRowsColor :
        index : StripedRowPattern *
        color : Color -> unit

Parameters

index StripedRowPattern
The part of the striped row pattern.
color Color
The color which will be used in striped row pattern.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ViewSchedule Class


ViewSchedule.Split Method

ViewScheduleSplit Method

Overload List
 | Name | Description
Public method | Split(IListDouble) | Splits the schedule into several segments by given height of each segment.
Public method | Split(Int32) | Splits the schedule into several segments by given segment number.
Top
See Also

Reference

ViewSchedule Class


ViewSchedule.Split(IList<Double>) Method

ViewScheduleSplit(IListDouble) Method

Splits the schedule into several segments by given height of each segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Split(
    IList<double> segmentHeights
)
Public Sub Split (
    segmentHeights As IList(Of Double)
)
public:
void Split(
    IList<double>^ segmentHeights
)
member Split :
        segmentHeights : IList<float> -> unit

Parameters

segmentHeights IList Double
An array contains the height limit of each segment except the last segment. The height is the value for segment body. The height is Revit's internal units value.
Exceptions
Exception | Condition
ArgumentException | The height of a schedule segment must be greater than 0 and no more than 30000 feet. The total segment count must be greater than 0 and less than 10000.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Revision schedules cannot be split. -or- A schedule filtered by sheet can't be split. -or- This ViewSchedule is split.
Remarks
  • A schedule can be split only when it is not split yet.
  • A titleblock revision schedule cannot be split.
  • Once a sheet specific schedule, i.e., the schedule is filtered by sheet, is split, the segments will be placed on its sheet view immediately.
  • The height values are used to set the height limits of the schedule instances of each segment except the last segment shown on the sheet view.
  • The height limit of the last segment cannot be set, because the height of the schedule instances of the last segment will be determined by the schedule instances of previous segments and the height of the whole schedule.
  • All height values must be greater than 0.
  • Also check [!:setSegmentHeight].
See Also

Reference

ViewSchedule Class
Split Overload


ViewSchedule.Split(Int32) Method

ViewScheduleSplit(Int32) Method

Splits the schedule into several segments by given segment number.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Split(
    int segmentNumber
)
Public Sub Split (
    segmentNumber As Integer
)
public:
void Split(
    int segmentNumber
)
member Split :
        segmentNumber : int -> unit

Parameters

segmentNumber Int32
The segment number.
Exceptions
Exception | Condition
ArgumentException | The segment number must be greater than 1.
InvalidOperationException | Revision schedules cannot be split. -or- A schedule filtered by sheet can't be split. -or- This ViewSchedule is split.
Remarks
  • The segment number must be greater than 0.
  • A schedule can be split only when it is not split yet.
  • A titleblock revision schedule cannot be split.
  • Once a sheet specific schedule, i.e., the schedule is filtered by sheet, is split, the segments will be placed on its sheet view immediately.
  • After split, all segments will have even height limits based on the schedule height and segment number except the last segment shown on the sheet view.
  • The height limit of the last segment cannot be set, because the height of the schedule instances of the last segment will be determined by the schedule instances of previous segments and the height of the whole schedule.
  • Check SetSegmentHeight(Int32, Double) to see more about segment height.
See Also

Reference

ViewSchedule Class
Split Overload


ViewSchedule.SplitSegment Method

ViewScheduleSplitSegment Method

Splits the schedule segment by the given heights of new segments.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SplitSegment(
    int segmentIndex,
    IList<double> segmentHeights
)
Public Sub SplitSegment (
    segmentIndex As Integer,
    segmentHeights As IList(Of Double)
)
public:
void SplitSegment(
    int segmentIndex,
    IList<double>^ segmentHeights
)
member SplitSegment :
        segmentIndex : int *
        segmentHeights : IList<float> -> unit

Parameters

segmentIndex Int32
The index of segment, starting with 0.
segmentHeights IList Double
An array contains the height for each new segment except the last segment. The height of the last segment will be determined by the height of previous new segments and the height of the split segment.
Exceptions
Exception | Condition
ArgumentException | The height of a schedule segment must be greater than 0. The total height must be less than the split segment height. The total segment count must be greater than 0 and less than 10000. -or- The segment index should start from 0 and be less than the total segment count.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This ViewSchedule is not split yet.
Remarks
The height values are used to set the height of schedule instance for each segment shown on sheet view. Each input height must be greater than 0 and the total height must be less than the height of the split segment.
See Also

Reference

ViewSchedule Class


ViewSchedule.UngroupHeaders Method

ViewScheduleUngroupHeaders Method

Ungroups selected headers of schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void UngroupHeaders(
    int top,
    int left,
    int bottom,
    int right
)
Public Sub UngroupHeaders (
    top As Integer,
    left As Integer,
    bottom As Integer,
    right As Integer
)
public:
void UngroupHeaders(
    int top,
    int left,
    int bottom,
    int right
)
member UngroupHeaders :
        top : int *
        left : int *
        bottom : int *
        right : int -> unit

Parameters

top Int32
The index of the top row of the selected headers.
left Int32
The index of the left column of the selected headers.
bottom Int32
The index of the bottom row of the selected headers.
right Int32
The index of the right column of the selected headers.
Exceptions
Exception | Condition
ArgumentException | Headers could not be ungrouped.
See Also

Reference

ViewSchedule Class


ViewScheduleExportOptions Class

The export options used to export schedule views.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBViewScheduleExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ViewScheduleExportOptions : IDisposable
Public Class ViewScheduleExportOptions
    Implements IDisposable
public ref class ViewScheduleExportOptions : IDisposable
type ViewScheduleExportOptions =
    class
        interface IDisposable
    end

The ViewScheduleExportOptions type exposes the following members.

Constructors
 | Name | Description
Public method | ViewScheduleExportOptions | Constructs a new instance of the ViewScheduleExportOptions class
Public method | ViewScheduleExportOptions(ViewScheduleExportOptions) | Constructs a new copy of the input ViewScheduleExportOptions object.
Top
Properties
 | Name | Description
Public property | ColumnHeaders | How to export column headers. Default is MultipleRows.
Public property | FieldDelimiter | How to delimit fields. Default is Tab.
Public property | HeadersFootersBlanks | Whether to export group headers, footers, and blank lines. Default is true.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | TextQualifier | How to qualify text fields. Default is DoubleQuote.
Public property | Title | Whether or not to export the schedule title. Default is true.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the ViewScheduleExportOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ViewScheduleExportOptions Constructor

Overload List
 | Name | Description
Public method | ViewScheduleExportOptions | Constructs a new instance of the ViewScheduleExportOptions class
Public method | ViewScheduleExportOptions(ViewScheduleExportOptions) | Constructs a new copy of the input ViewScheduleExportOptions object.
Top
See Also

Reference

ViewScheduleExportOptions Class


ViewScheduleExportOptions Constructor

Constructs a new instance of the ViewScheduleExportOptions class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ViewScheduleExportOptions()
Public Sub New
public:
ViewScheduleExportOptions()
new : unit -> ViewScheduleExportOptions
See Also

Reference

ViewScheduleExportOptions Class
ViewScheduleExportOptions Overload


ViewScheduleExportOptions(ViewScheduleExportOptions) Constructor

Constructs a new copy of the input ViewScheduleExportOptions object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ViewScheduleExportOptions(
    ViewScheduleExportOptions other
)
Public Sub New (
    other As ViewScheduleExportOptions
)
public:
ViewScheduleExportOptions(
    ViewScheduleExportOptions^ other
)
new :
        other : ViewScheduleExportOptions -> ViewScheduleExportOptions

Parameters

other ViewScheduleExportOptions
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ViewScheduleExportOptions Class
ViewScheduleExportOptions Overload


ViewScheduleExportOptions Properties

The ViewScheduleExportOptions type exposes the following members.

Properties
 | Name | Description
Public property | ColumnHeaders | How to export column headers. Default is MultipleRows.
Public property | FieldDelimiter | How to delimit fields. Default is Tab.
Public property | HeadersFootersBlanks | Whether to export group headers, footers, and blank lines. Default is true.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | TextQualifier | How to qualify text fields. Default is DoubleQuote.
Public property | Title | Whether or not to export the schedule title. Default is true.
Top
See Also

Reference

ViewScheduleExportOptions Class


ViewScheduleExportOptions.ColumnHeaders Property

ViewScheduleExportOptionsColumnHeaders Property

How to export column headers. Default is MultipleRows.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportColumnHeaders ColumnHeaders { get; set; }
Public Property ColumnHeaders As ExportColumnHeaders
    Get
    Set
public:
property ExportColumnHeaders ColumnHeaders {
    ExportColumnHeaders get ();
    void set (ExportColumnHeaders value);
}
member ColumnHeaders : ExportColumnHeaders with get, set

Property Value

ExportColumnHeaders
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ViewScheduleExportOptions Class


ViewScheduleExportOptions.FieldDelimiter Property

ViewScheduleExportOptionsFieldDelimiter Property

How to delimit fields. Default is Tab.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FieldDelimiter { get; set; }
Public Property FieldDelimiter As String
    Get
    Set
public:
property String^ FieldDelimiter {
    String^ get ();
    void set (String^ value);
}
member FieldDelimiter : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ViewScheduleExportOptions Class


ViewScheduleExportOptions.HeadersFootersBlanks Property

ViewScheduleExportOptionsHeadersFootersBlanks Property

Whether to export group headers, footers, and blank lines. Default is true.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HeadersFootersBlanks { get; set; }
Public Property HeadersFootersBlanks As Boolean
    Get
    Set
public:
property bool HeadersFootersBlanks {
    bool get ();
    void set (bool value);
}
member HeadersFootersBlanks : bool with get, set

Property Value

Boolean
See Also

Reference

ViewScheduleExportOptions Class


ViewScheduleExportOptions.IsValidObject Property

ViewScheduleExportOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

ViewScheduleExportOptions Class


ViewScheduleExportOptions.TextQualifier Property

ViewScheduleExportOptionsTextQualifier Property

How to qualify text fields. Default is DoubleQuote.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExportTextQualifier TextQualifier { get; set; }
Public Property TextQualifier As ExportTextQualifier
    Get
    Set
public:
property ExportTextQualifier TextQualifier {
    ExportTextQualifier get ();
    void set (ExportTextQualifier value);
}
member TextQualifier : ExportTextQualifier with get, set

Property Value

ExportTextQualifier
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ViewScheduleExportOptions Class


ViewScheduleExportOptions.Title Property

ViewScheduleExportOptionsTitle Property

Whether or not to export the schedule title. Default is true.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Title { get; set; }
Public Property Title As Boolean
    Get
    Set
public:
property bool Title {
    bool get ();
    void set (bool value);
}
member Title : bool with get, set

Property Value

Boolean
See Also

Reference

ViewScheduleExportOptions Class


ViewScheduleExportOptions Methods

The ViewScheduleExportOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ViewScheduleExportOptions Class


ViewScheduleExportOptions.Dispose Method

ViewScheduleExportOptionsDispose Method

Releases all resources used by the ViewScheduleExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ViewScheduleExportOptions Class


ViewSection Class

ViewSection covers sections, details, elevations, and callouts, all in their reference and non-reference variations.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBView
Autodesk.Revit.DBViewSection

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ViewSection : View
Public Class ViewSection
    Inherits View
public ref class ViewSection : public View
type ViewSection =
    class
        inherit View
    end

The ViewSection type exposes the following members.

Properties
 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View)
Public property | AreAnalyticalModelCategoriesHidden | Indicates if analytical model categories are currently hidden in the view. (Inherited from View)
Public property | AreAnnotationCategoriesHidden | Indicates if annotation categories are currently hidden in the view. (Inherited from View)
Public property | AreCoordinationModelHandlesHidden | Indicates if Coordination Model handles are currently hidden in the view. (Inherited from View)
Public property | AreImportCategoriesHidden | Indicates if import categories are currently hidden in the view. (Inherited from View)
Public property | AreModelCategoriesHidden | Indicates if model categories are currently hidden in the view. (Inherited from View)
Public property | ArePointCloudsHidden | Indicates if point clouds are currently hidden in the view. (Inherited from View)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CropBox | The Crop Box applied to the view, or an outline encompassing the crop region applied to the view. (Inherited from View)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | DetailLevel | The detail level of this view. (Inherited from View)
Public property | Discipline | The Discipline of the view. (Inherited from View)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | GenLevel | The level for the view. (Inherited from View)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsAssemblyView | Indicates if the view is assembly view. (Inherited from View)
Public property | IsCallout | Indicates if the view is a callout view. (Inherited from View)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | Origin | Returns the origin of the screen. (Inherited from View)
Public property | Outline | The bounds of the view in paper space (in feet). (Inherited from View)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | RevealConstraintsMode | Indicates whether the Reveal Constraints mode is activated in the view. (Inherited from View)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View)
Public property | Scale | The scale of the view. (Inherited from View)
Public property | ShadowIntensity | The intesity of cast shadows - 0 = no shadows, 100 = black. (Inherited from View)
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View)
Public property | SunlightIntensity | The intensity of the simulated (directional) sunlight. 0 = no directional light; maximum value is 100. (Inherited from View)
Public property | TemporaryViewModes | Data of temporary view modes associated with this view. (Inherited from View)
Public property | Title | The view title. This consists of the view name plus other modifiers, such as the view type, sheet number, area scheme, and/or assembly type, depending on the specifics of the view. (Inherited from View)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | ViewTemplateId | The id of the template view that controls this view's parameters. (Inherited from View)
 | ViewType | The type of the view. (Inherited from View)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | AddFilter | Adds a filter to the view. (Inherited from View)
Public method | AllowsAnalysisDisplay | Identifies if this view allows display of Analysis results. (Inherited from View)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of the input view that are not controlled by the current view template. (Inherited from View)
Public method | AreGraphicsOverridesAllowed | Determines if Visibility/Graphics Overriddes can be applied to the view. (Inherited from View)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanApplyColorFillScheme | Checks if the id can be applied as the scheme id of specified category to this view. (Inherited from View)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanCategoryBeHidden | Checks whether the category can be hidden in the view. (Inherited from View)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanEnableTemporaryViewPropertiesMode | Indicates if Temporary View Properties mode can be applied for view in current state. (Inherited from View)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified (Inherited from View)
Public method | CanUseDepthCueing | Indicates if view can use Depth Cueing (Inherited from View)
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes (Inherited from View)
Public method | CanViewBeDuplicated | Identifies if this view can be duplicated. (Inherited from View)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View)
 | ConvertToIndependent | Convert the dependent view to independent. (Inherited from View)
 | CreateCallout | Creates a new callout view.
 | CreateDetail | Returns a new detail ViewSection.
 | CreateReferenceCallout | Creates a new reference callout.
 | CreateReferenceSection | Creates a new reference section.
 | CreateSection | Returns a new section ViewSection.
Public method | CreateViewTemplate | Creates a new view template instance from this view instance. (Inherited from View)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View)
Public method | Dispose | (Inherited from Element)
 | Duplicate | Duplicates this view. (Inherited from View)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View)
Public method | EnableTemporaryViewPropertiesMode | Turns Temporary View Properties mode on or off. In this mode, any changes made to the view are temporary and will be discarded once the mode is disabled. (Inherited from View)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetBackground | Returns the current background set for the view. (Inherited from View)
Public method | GetCalloutParentId | Gets ID of the callout parent view. (Inherited from View)
Public method | GetCategoryHidden | Checks if elements of the given category are set to be invisible (hidden) in this view. (Inherited from View)
Public method | GetCategoryOverrides | Gets graphic overrides for a category in view. (Inherited from View)
Public method | GetColorFillSchemeId | Returns id of the color fill scheme element applied to the view. (Inherited from View)
Public method | GetCropRegionShapeManager | Returns an object for managing view crop region shape. (Inherited from View)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View)
Public method | GetDepthCueing | Returns the current depth cueing settings for the view. (Inherited from View)
Public method | GetDirectContext3DHandleOverrides | Returns DirectContext3D handle overrides object for the view. (Inherited from View)
Public method | GetElementOverrides | Gets graphic overrides for an element in the view. (Inherited from View)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFilterOverrides | Gets graphic overrides that a filter applies to the view. (Inherited from View)
Public method | GetFilters | Gets the filters applied to the view. (Inherited from View)
Public method | GetFilterVisibility | Gets the visibility of the elements associated with a filter. (Inherited from View)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIsFilterEnabled | Identifies if the filter is enabled in this view. (Inherited from View)
 | GetLinkOverrides | Gets the graphic overrides of a RevitLinkType or RevitLinkInstance in view. (Inherited from View)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetModelToProjectionTransforms | Gets the transforms from the model space to the view projection space. (Inherited from View)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetNonControlledTemplateParameterIds | Returns a list of parameters that are not marked as included when this view is used as a template. (Inherited from View)
Public method | GetOrderedFilters | Gets the filters applied to the view in the order they are applied. (Inherited from View)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPlacementOnSheetStatus | Determines if this view placed on a sheet completely or partially. (Inherited from View)
Public method | GetPointCloudOverrides | Returns point cloud overrides object for the view. (Inherited from View)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View)
Public method | GetReferenceCallouts | Returns element ids of all reference callouts in the view. (Inherited from View)
Public method | GetReferenceElevations | Returns element ids of all reference elevations in the view. (Inherited from View)
Public method | GetReferenceSections | Returns element ids of all reference sections in the view. (Inherited from View)
Public method | GetSketchyLines | Returns the current sketchy lines settings for the view. (Inherited from View)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTemplateParameterIds | Returns a list of parameter ids that may be controlled when this view is assigned as a template. (Inherited from View)
Public method | GetTemporaryViewPropertiesId | When Temporary View Properties mode is in progress it provides view id that overrode settings for current view. Outside Temporary View Properties mode InvalidElementId will be returned. (Inherited from View)
Public method | GetTemporaryViewPropertiesName | When Temporary View Properties mode is in progress, name of applied template is returned. Outside Temporary View Properties mode, empty string will be returned. (Inherited from View)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetViewDisplayModel | Returns the current view display model settings for the view. (Inherited from View)
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View)
Public method | HasDetailLevel | Check if the view has a Detail Level property (Inherited from View)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property (Inherited from View)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property (Inherited from View)
Public method | HasViewTransforms | Returns true if the view reports model space to view projection space transforms. (Inherited from View)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View)
Public method | IsCategoryOverridable | Checks whether the category can have graphic overrides in this view. (Inherited from View)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsFilterApplied | Indicates if a filter is applied to the view. (Inherited from View)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View)
 | IsParentViewValidForCallout | This validator checks that the parent view is appropriate for callout views.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSplitSection | Sections can be split (jog) so that they cut at >1 plane.
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View)
Public method | IsTemporaryViewPropertiesModeEnabled | Returns true when Temporary View Properties mode is in progress, false otherwise. (Inherited from View)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | IsValidViewTemplate | Verifies that the view represented by templateId can be set as the controlling view template for this view. (Inherited from View)
 | IsViewFamilyTypeValidForCallout | This validator checks that the ViewFamilyType is appropriate for callout views in the input parent view.
Public method | IsViewValidForTemplateCreation | Verifies that the view is valid for template creation. (Inherited from View)
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | Print | Print this view with the default view template and using the print setting of the current active document. (Inherited from View)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveCalloutParent | Replaces callout parent ID with InvalidElementId. (Inherited from View)
Public method | RemoveFilter | Removes a filter from the view. (Inherited from View)
 | RemoveLinkOverrides | Deletes the graphical link overrides in the current view. (Inherited from View)
Public method | RestoreCalloutParent | Restores callout parent ID to the original view ID if that view is still available. (Inherited from View)
Public method | SetBackground | Sets the background for the view. Background can only be set for 3d views and for Sections/Elevations. (Inherited from View)
Public method | SetCategoryHidden | Sets if elements of the given category will be visible in this view. (Inherited from View)
Public method | SetCategoryOverrides | Sets graphic overrides for a category in view. (Inherited from View)
Public method | SetColorFillSchemeId | Applies color fill scheme to this view. (Inherited from View)
Public method | SetDepthCueing | Sets the depth cueing settings for the view. (Inherited from View)
Public method | SetElementOverrides | Sets graphic overrides for an element in the view. (Inherited from View)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
 | SetFilterOverrides | Sets the overrides associated with a filter. (Inherited from View)
Public method | SetFilterVisibility | Sets the visibility of the elements associated with a filter. (Inherited from View)
Public method | SetIsFilterEnabled | Sets the filter enabled flag. (Inherited from View)
 | SetLinkOverrides | Sets the graphic overrides of a RevitLinkType or RevitLinkInstance in the view. (Inherited from View)
Public method | SetNonControlledTemplateParameterIds | Sets the parameters that will not be included when this view is used as a template. (Inherited from View)
Public method | SetSketchyLines | Sets the sketchy lines settings for the view. (Inherited from View)
Public method | SetViewDisplayModel | Sets the view display model settings for the view. (Inherited from View)
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View)
 | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View)
Public method | SupportedColorFillCategoryIds | Returns collection of all category ids that correspond to elements that can potentially be colored in this view according to a color fill scheme. The set may be different depending on the view type. (Inherited from View)
Public method | SupportsRevealConstraints | Checks that the view can have the Reveal Constraints mode activated. (Inherited from View)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View)
Top
Remarks
The creation functions for elevations can be found in the ElevationMarker class.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ViewSection Properties

The ViewSection type exposes the following members.

Properties
 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View)
Public property | AreAnalyticalModelCategoriesHidden | Indicates if analytical model categories are currently hidden in the view. (Inherited from View)
Public property | AreAnnotationCategoriesHidden | Indicates if annotation categories are currently hidden in the view. (Inherited from View)
Public property | AreCoordinationModelHandlesHidden | Indicates if Coordination Model handles are currently hidden in the view. (Inherited from View)
Public property | AreImportCategoriesHidden | Indicates if import categories are currently hidden in the view. (Inherited from View)
Public property | AreModelCategoriesHidden | Indicates if model categories are currently hidden in the view. (Inherited from View)
Public property | ArePointCloudsHidden | Indicates if point clouds are currently hidden in the view. (Inherited from View)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CropBox | The Crop Box applied to the view, or an outline encompassing the crop region applied to the view. (Inherited from View)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | DetailLevel | The detail level of this view. (Inherited from View)
Public property | Discipline | The Discipline of the view. (Inherited from View)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | GenLevel | The level for the view. (Inherited from View)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsAssemblyView | Indicates if the view is assembly view. (Inherited from View)
Public property | IsCallout | Indicates if the view is a callout view. (Inherited from View)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | Origin | Returns the origin of the screen. (Inherited from View)
Public property | Outline | The bounds of the view in paper space (in feet). (Inherited from View)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | RevealConstraintsMode | Indicates whether the Reveal Constraints mode is activated in the view. (Inherited from View)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View)
Public property | Scale | The scale of the view. (Inherited from View)
Public property | ShadowIntensity | The intesity of cast shadows - 0 = no shadows, 100 = black. (Inherited from View)
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View)
Public property | SunlightIntensity | The intensity of the simulated (directional) sunlight. 0 = no directional light; maximum value is 100. (Inherited from View)
Public property | TemporaryViewModes | Data of temporary view modes associated with this view. (Inherited from View)
Public property | Title | The view title. This consists of the view name plus other modifiers, such as the view type, sheet number, area scheme, and/or assembly type, depending on the specifics of the view. (Inherited from View)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | ViewTemplateId | The id of the template view that controls this view's parameters. (Inherited from View)
 | ViewType | The type of the view. (Inherited from View)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

ViewSection Class


ViewSection Methods

The ViewSection type exposes the following members.

Methods
 | Name | Description
Public method | AddFilter | Adds a filter to the view. (Inherited from View)
Public method | AllowsAnalysisDisplay | Identifies if this view allows display of Analysis results. (Inherited from View)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of the input view that are not controlled by the current view template. (Inherited from View)
Public method | AreGraphicsOverridesAllowed | Determines if Visibility/Graphics Overriddes can be applied to the view. (Inherited from View)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanApplyColorFillScheme | Checks if the id can be applied as the scheme id of specified category to this view. (Inherited from View)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanCategoryBeHidden | Checks whether the category can be hidden in the view. (Inherited from View)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanEnableTemporaryViewPropertiesMode | Indicates if Temporary View Properties mode can be applied for view in current state. (Inherited from View)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified (Inherited from View)
Public method | CanUseDepthCueing | Indicates if view can use Depth Cueing (Inherited from View)
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes (Inherited from View)
Public method | CanViewBeDuplicated | Identifies if this view can be duplicated. (Inherited from View)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View)
 | ConvertToIndependent | Convert the dependent view to independent. (Inherited from View)
 | CreateCallout | Creates a new callout view.
 | CreateDetail | Returns a new detail ViewSection.
 | CreateReferenceCallout | Creates a new reference callout.
 | CreateReferenceSection | Creates a new reference section.
 | CreateSection | Returns a new section ViewSection.
Public method | CreateViewTemplate | Creates a new view template instance from this view instance. (Inherited from View)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View)
Public method | Dispose | (Inherited from Element)
 | Duplicate | Duplicates this view. (Inherited from View)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View)
Public method | EnableTemporaryViewPropertiesMode | Turns Temporary View Properties mode on or off. In this mode, any changes made to the view are temporary and will be discarded once the mode is disabled. (Inherited from View)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetBackground | Returns the current background set for the view. (Inherited from View)
Public method | GetCalloutParentId | Gets ID of the callout parent view. (Inherited from View)
Public method | GetCategoryHidden | Checks if elements of the given category are set to be invisible (hidden) in this view. (Inherited from View)
Public method | GetCategoryOverrides | Gets graphic overrides for a category in view. (Inherited from View)
Public method | GetColorFillSchemeId | Returns id of the color fill scheme element applied to the view. (Inherited from View)
Public method | GetCropRegionShapeManager | Returns an object for managing view crop region shape. (Inherited from View)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View)
Public method | GetDepthCueing | Returns the current depth cueing settings for the view. (Inherited from View)
Public method | GetDirectContext3DHandleOverrides | Returns DirectContext3D handle overrides object for the view. (Inherited from View)
Public method | GetElementOverrides | Gets graphic overrides for an element in the view. (Inherited from View)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFilterOverrides | Gets graphic overrides that a filter applies to the view. (Inherited from View)
Public method | GetFilters | Gets the filters applied to the view. (Inherited from View)
Public method | GetFilterVisibility | Gets the visibility of the elements associated with a filter. (Inherited from View)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIsFilterEnabled | Identifies if the filter is enabled in this view. (Inherited from View)
 | GetLinkOverrides | Gets the graphic overrides of a RevitLinkType or RevitLinkInstance in view. (Inherited from View)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetModelToProjectionTransforms | Gets the transforms from the model space to the view projection space. (Inherited from View)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetNonControlledTemplateParameterIds | Returns a list of parameters that are not marked as included when this view is used as a template. (Inherited from View)
Public method | GetOrderedFilters | Gets the filters applied to the view in the order they are applied. (Inherited from View)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPlacementOnSheetStatus | Determines if this view placed on a sheet completely or partially. (Inherited from View)
Public method | GetPointCloudOverrides | Returns point cloud overrides object for the view. (Inherited from View)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View)
Public method | GetReferenceCallouts | Returns element ids of all reference callouts in the view. (Inherited from View)
Public method | GetReferenceElevations | Returns element ids of all reference elevations in the view. (Inherited from View)
Public method | GetReferenceSections | Returns element ids of all reference sections in the view. (Inherited from View)
Public method | GetSketchyLines | Returns the current sketchy lines settings for the view. (Inherited from View)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTemplateParameterIds | Returns a list of parameter ids that may be controlled when this view is assigned as a template. (Inherited from View)
Public method | GetTemporaryViewPropertiesId | When Temporary View Properties mode is in progress it provides view id that overrode settings for current view. Outside Temporary View Properties mode InvalidElementId will be returned. (Inherited from View)
Public method | GetTemporaryViewPropertiesName | When Temporary View Properties mode is in progress, name of applied template is returned. Outside Temporary View Properties mode, empty string will be returned. (Inherited from View)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetViewDisplayModel | Returns the current view display model settings for the view. (Inherited from View)
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View)
Public method | HasDetailLevel | Check if the view has a Detail Level property (Inherited from View)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property (Inherited from View)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property (Inherited from View)
Public method | HasViewTransforms | Returns true if the view reports model space to view projection space transforms. (Inherited from View)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View)
Public method | IsCategoryOverridable | Checks whether the category can have graphic overrides in this view. (Inherited from View)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsFilterApplied | Indicates if a filter is applied to the view. (Inherited from View)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View)
 | IsParentViewValidForCallout | This validator checks that the parent view is appropriate for callout views.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSplitSection | Sections can be split (jog) so that they cut at >1 plane.
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View)
Public method | IsTemporaryViewPropertiesModeEnabled | Returns true when Temporary View Properties mode is in progress, false otherwise. (Inherited from View)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | IsValidViewTemplate | Verifies that the view represented by templateId can be set as the controlling view template for this view. (Inherited from View)
 | IsViewFamilyTypeValidForCallout | This validator checks that the ViewFamilyType is appropriate for callout views in the input parent view.
Public method | IsViewValidForTemplateCreation | Verifies that the view is valid for template creation. (Inherited from View)
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | Print | Print this view with the default view template and using the print setting of the current active document. (Inherited from View)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveCalloutParent | Replaces callout parent ID with InvalidElementId. (Inherited from View)
Public method | RemoveFilter | Removes a filter from the view. (Inherited from View)
 | RemoveLinkOverrides | Deletes the graphical link overrides in the current view. (Inherited from View)
Public method | RestoreCalloutParent | Restores callout parent ID to the original view ID if that view is still available. (Inherited from View)
Public method | SetBackground | Sets the background for the view. Background can only be set for 3d views and for Sections/Elevations. (Inherited from View)
Public method | SetCategoryHidden | Sets if elements of the given category will be visible in this view. (Inherited from View)
Public method | SetCategoryOverrides | Sets graphic overrides for a category in view. (Inherited from View)
Public method | SetColorFillSchemeId | Applies color fill scheme to this view. (Inherited from View)
Public method | SetDepthCueing | Sets the depth cueing settings for the view. (Inherited from View)
Public method | SetElementOverrides | Sets graphic overrides for an element in the view. (Inherited from View)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
 | SetFilterOverrides | Sets the overrides associated with a filter. (Inherited from View)
Public method | SetFilterVisibility | Sets the visibility of the elements associated with a filter. (Inherited from View)
Public method | SetIsFilterEnabled | Sets the filter enabled flag. (Inherited from View)
 | SetLinkOverrides | Sets the graphic overrides of a RevitLinkType or RevitLinkInstance in the view. (Inherited from View)
Public method | SetNonControlledTemplateParameterIds | Sets the parameters that will not be included when this view is used as a template. (Inherited from View)
Public method | SetSketchyLines | Sets the sketchy lines settings for the view. (Inherited from View)
Public method | SetViewDisplayModel | Sets the view display model settings for the view. (Inherited from View)
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View)
 | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View)
Public method | SupportedColorFillCategoryIds | Returns collection of all category ids that correspond to elements that can potentially be colored in this view according to a color fill scheme. The set may be different depending on the view type. (Inherited from View)
Public method | SupportsRevealConstraints | Checks that the view can have the Reveal Constraints mode activated. (Inherited from View)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View)
Top
See Also

Reference

ViewSection Class


ViewSection.CreateCallout Method

ViewSectionCreateCallout Method

Creates a new callout view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static View CreateCallout(
    Document document,
    ElementId parentViewId,
    ElementId viewFamilyTypeId,
    XYZ point1,
    XYZ point2
)
Public Shared Function CreateCallout (
    document As Document,
    parentViewId As ElementId,
    viewFamilyTypeId As ElementId,
    point1 As XYZ,
    point2 As XYZ
) As View
public:
static View^ CreateCallout(
    Document^ document,
    ElementId^ parentViewId,
    ElementId^ viewFamilyTypeId,
    XYZ^ point1,
    XYZ^ point2
)
static member CreateCallout :
        document : Document *
        parentViewId : ElementId *
        viewFamilyTypeId : ElementId *
        point1 : XYZ *
        point2 : XYZ -> View

Parameters

document Document
The document to which the new callout will be added.
parentViewId ElementId
The view in which the callout appears. Callouts can be created in FloorPlan, CeilingPlan, StructuralPlan, Section, Elevation, and Detail views.
viewFamilyTypeId ElementId
The id of the ViewFamilyType which will be used by the new callout ViewSection. Detail ViewFamilyTypes can be used in all parent views except for CeilingPlan and Drafting views. FloorPlan, CeilingPlan, StructuralPlan, Section, and Elevation ViewFamilyTypes may be be used in parent views that also use a type with the same ViewFamily enum value. For example, in StructuralPlan parent views both StructuralPlan and Detail ViewFamilyTypes are allowed.
point1 XYZ
Determines the extents of the callout symbol in the parent view.
point2 XYZ
Determine the extents of the callout symbol in the parent view.

Return Value

View
The new callout view. The view will be either a ViewSection, ViewPlan or ViewDetail.
Exceptions
Exception | Condition
ArgumentException | Non-reference callouts are not allowed in parent views of this type. -or- Callouts of the supplied ViewFamilyType are not allowed in the parent view. -or- point1 and point2 do not differ when projected onto a plane perpendicular to the view direction. -or- Callout view creation is not allowed in this family.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
The extents of new callout are determined by using the two argument points as the opposing corners of a rectangle which is aligned to the directions of the parent view. The callout's near and far cut planes will match those of the parent view. The new view will receive a unique name.
See Also

Reference

ViewSection Class


ViewSection.CreateDetail Method

ViewSectionCreateDetail Method

Returns a new detail ViewSection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ViewSection CreateDetail(
    Document document,
    ElementId viewFamilyTypeId,
    BoundingBoxXYZ sectionBox
)
Public Shared Function CreateDetail (
    document As Document,
    viewFamilyTypeId As ElementId,
    sectionBox As BoundingBoxXYZ
) As ViewSection
public:
static ViewSection^ CreateDetail(
    Document^ document,
    ElementId^ viewFamilyTypeId,
    BoundingBoxXYZ^ sectionBox
)
static member CreateDetail :
        document : Document *
        viewFamilyTypeId : ElementId *
        sectionBox : BoundingBoxXYZ -> ViewSection

Parameters

document Document
The document to which the new detail ViewSection will be added.
viewFamilyTypeId ElementId
The id of the ViewFamilyType which will be used by the new detail ViewSection. The type needs to be a Detail ViewFamily.
sectionBox BoundingBoxXYZ
The BoundingBoxXYZ which specifies the new ViewSection's view direction and extents.

Return Value

ViewSection
The new detail ViewSection.
Exceptions
Exception | Condition
ArgumentException | The ViewFamilyType must be a Detail ViewFamily. -or- The BoundingBoxXYZ is not appropriate for detail views. The basis vectors of must be unit length and orthonormal. The near and far bound offsets cannot be reversed or too close to each other. MinEnabled and MaxEnabled must be set to true for all three directions. -or- Detail section view creation is not allowed in this family.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
Create a detail ViewSection whose view volume corresponds geometrically with the specified sectionBox. The view direction of the resulting section will be sectionBox.Transform.BasisZ and the up direction will be sectionBox.Transform.BasisY. The right hand direction will be computed so that (right, up, view direction) form a left handed coordinate system. The resulting view will be cropped, and far clipping will be active. The crop region will correspond to the projections of BoundingBoxXYZ.Min and BoundingBoxXYZ.Max onto the view's cut plane. The far clip distance will be equal to the difference of the z-coordinates of BoundingBoxXYZ.Min and BoundingBoxXYZ.Max. The new detail ViewSection will receive a unique view name.
Example
C#
VB
C++
F#
Copy
// Get a BoundingBoxXYZ instance from Revit
BoundingBoxXYZ box = document.ActiveView.CropBox;
if (null == box)
{
    throw new Exception("No BoundingBoxXYZ instance found.");
}

// Create a new view section.
ElementId DetailViewId = ElementId.InvalidElementId;
IList<Element> elems = new FilteredElementCollector(document).OfClass(typeof(ViewFamilyType)).ToElements();
foreach (Element e in elems)
{
    ViewFamilyType v = e as ViewFamilyType;

    if (v != null && v.ViewFamily == ViewFamily.Detail)
    {
        DetailViewId = e.Id;
        break;
    }
}
ViewSection viewSection = ViewSection.CreateDetail(document, DetailViewId, box);
' Get a BoundingBoxXYZ instance from Revit
Dim box As BoundingBoxXYZ = document.ActiveView.CropBox
If box Is Nothing Then
    Throw New Exception("No BoundingBoxXYZ instance found.")
End If

' Create a new view section.
Dim DetailViewId As ElementId = ElementId.InvalidElementId
Dim elems As IList(Of Element) = New FilteredElementCollector(document).OfClass(GetType(ViewFamilyType)).ToElements()
For Each e As Element In elems
    Dim v As ViewFamilyType = TryCast(e, ViewFamilyType)

    If v IsNot Nothing AndAlso v.ViewFamily = ViewFamily.Detail Then
        DetailViewId = e.Id
        Exit For
    End If
Next
Dim viewSection__1 As ViewSection = ViewSection.CreateDetail(document, DetailViewId, box)

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

ViewSection Class


ViewSection.CreateReferenceCallout Method

ViewSectionCreateReferenceCallout Method

Creates a new reference callout.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void CreateReferenceCallout(
    Document document,
    ElementId parentViewId,
    ElementId viewIdToReference,
    XYZ point1,
    XYZ point2
)
Public Shared Sub CreateReferenceCallout (
    document As Document,
    parentViewId As ElementId,
    viewIdToReference As ElementId,
    point1 As XYZ,
    point2 As XYZ
)
public:
static void CreateReferenceCallout(
    Document^ document,
    ElementId^ parentViewId,
    ElementId^ viewIdToReference,
    XYZ^ point1,
    XYZ^ point2
)
static member CreateReferenceCallout :
        document : Document *
        parentViewId : ElementId *
        viewIdToReference : ElementId *
        point1 : XYZ *
        point2 : XYZ -> unit

Parameters

document Document
The document to which the new reference callout will be added.
parentViewId ElementId
The view in which the callout symbol appears. Callouts can be created in FloorPlan, CeilingPlan, StructuralPlan, Section, Elevation, Drafting, and Detail views.
viewIdToReference ElementId
The view which will be referenced. The ViewFamilyType of the referenced view will be used by the new reference callout. Only cropped views can be referenced, unless the referenced view is a Drafting view. Drafting views can always be referenced regardless of the parent view type. Elevation views can be referenced from Elevation and Drafting parent views. Section views can be referenced from Section and Drafting parent views. Detail views can be referenced from all parent views except for in FloorPlan, CeilingPlan and StructuralPlan parent views where only horizontally-oriented Detail views can be referenced. FloorPlan, CeilingPlan and StructuralPlan views can be referenced from FloorPlan, CeilingPlan and StructuralPlan parent views.
point1 XYZ
One corner of the callout symbol in the parent view.
point2 XYZ
The other diagonally opposed corner of the callout symbol in the parent view.
Exceptions
Exception | Condition
ArgumentException | The ElementId viewIdToReference does not correspond to a View. -or- The ElementId parentViewId does not correspond to a View. -or- The parent view and the referenced view must be different views. -or- The parent view does not support reference callouts to views of the ViewFamily used by viewIdToReference. -or- point1 and point2 do not differ when projected onto a plane perpendicular to the view direction. -or- Callout view creation is not allowed in this family.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
The reference callout will assume the ViewFamilyType of the view it references. The corners of the callout symbol will be determined by the two point arguments. The sides of the callout symbol will be aligned to the sides of the parent view's crop region.
See Also

Reference

ViewSection Class


ViewSection.CreateReferenceSection Method

ViewSectionCreateReferenceSection Method

Creates a new reference section.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void CreateReferenceSection(
    Document document,
    ElementId parentViewId,
    ElementId viewIdToReference,
    XYZ headPoint,
    XYZ tailPoint
)
Public Shared Sub CreateReferenceSection (
    document As Document,
    parentViewId As ElementId,
    viewIdToReference As ElementId,
    headPoint As XYZ,
    tailPoint As XYZ
)
public:
static void CreateReferenceSection(
    Document^ document,
    ElementId^ parentViewId,
    ElementId^ viewIdToReference,
    XYZ^ headPoint,
    XYZ^ tailPoint
)
static member CreateReferenceSection :
        document : Document *
        parentViewId : ElementId *
        viewIdToReference : ElementId *
        headPoint : XYZ *
        tailPoint : XYZ -> unit

Parameters

document Document
The document to which the reference section will be added.
parentViewId ElementId
The view in which the new reference section marker will appear. Reference sections can be created in FloorPlan, CeilingPlan, StructuralPlan, Section, Elevation, Drafting, and Detail views.
viewIdToReference ElementId
Detail, Drafting and Section views can be referenced. The ViewFamilyType of the referenced view will be used by the new reference section.
headPoint XYZ
Determines the location of the section marker's head in the parent view.
tailPoint XYZ
Determines the location of the section marker's tail in the parent view.
Exceptions
Exception | Condition
ArgumentException | The ElementId viewIdToReference does not correspond to a View. -or- The ElementId parentViewId does not correspond to a View. -or- The parent view and the referenced view must be different views. -or- Can't create a new reference sections in parentViewId. Parent views must be FloorPlan, CeilingPlan, StructuralPlan, Section, Elevation, Drafting, or Detail views. -or- The viewIdToReference cannot be referenced by reference sections. Only Detail, Drafting and Section views can be referenced. -or- headPoint and tailPoint do not differ when projected onto a plane perpendicular to the view direction. -or- Reference section view creation is not allowed in this family.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
The reference section will assume the ViewFamilyType of the view it references.
See Also

Reference

ViewSection Class


ViewSection.CreateSection Method

ViewSectionCreateSection Method

Returns a new section ViewSection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ViewSection CreateSection(
    Document document,
    ElementId viewFamilyTypeId,
    BoundingBoxXYZ sectionBox
)
Public Shared Function CreateSection (
    document As Document,
    viewFamilyTypeId As ElementId,
    sectionBox As BoundingBoxXYZ
) As ViewSection
public:
static ViewSection^ CreateSection(
    Document^ document,
    ElementId^ viewFamilyTypeId,
    BoundingBoxXYZ^ sectionBox
)
static member CreateSection :
        document : Document *
        viewFamilyTypeId : ElementId *
        sectionBox : BoundingBoxXYZ -> ViewSection

Parameters

document Document
The document to which the new section ViewSection will be added.
viewFamilyTypeId ElementId
The id of the ViewFamilyType which will be used by the new section ViewSection. The type needs to be a Section ViewFamily.
sectionBox BoundingBoxXYZ
The BoundingBoxXYZ which specifies the new ViewSection's view direction and extents.

Return Value

ViewSection
The new section ViewSection.
Exceptions
Exception | Condition
ArgumentException | The ViewFamilyType must be a Section ViewFamily. -or- The BoundingBoxXYZ is not appropriate for detail views. The basis vectors of must be unit length and orthonormal. The near and far bound offsets cannot be reversed or too close to each other. MinEnabled and MaxEnabled must be set to true for all three directions. -or- Section view creation is not allowed in this family.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Remarks
Create a section whose view volume corresponds geometrically with the specified sectionBox. The view direction of the resulting section will be sectionBox.Transform.BasisZ and the up direction will be sectionBox.Transform.BasisY. The right hand direction will be computed so that (right, up, view direction) form a left handed coordinate system. The resulting view will be cropped, and far clipping will be active. The crop region will correspond to the projections of BoundingBoxXYZ.Min and BoundingBoxXYZ.Max onto the view's cut plane. The far clip distance will be equal to the difference of the z-coordinates of BoundingBoxXYZ.Min and BoundingBoxXYZ.Max. The new section ViewSection will receive a unique view name.
See Also

Reference

ViewSection Class


ViewSection.IsParentViewValidForCallout Method

ViewSectionIsParentViewValidForCallout Method

This validator checks that the parent view is appropriate for callout views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsParentViewValidForCallout(
    Document document,
    ElementId parentViewId
)
Public Shared Function IsParentViewValidForCallout (
    document As Document,
    parentViewId As ElementId
) As Boolean
public:
static bool IsParentViewValidForCallout(
    Document^ document,
    ElementId^ parentViewId
)
static member IsParentViewValidForCallout :
        document : Document *
        parentViewId : ElementId -> bool

Parameters

document Document
The document which contains the ViewFamilyType and parent view.
parentViewId ElementId
The view in which the new callout will appear. Callouts can be created in FloorPlan, CeilingPlan, StructuralPlan, Section, Elevation, and Detail views.

Return Value

Boolean
True if the ViewFamilyType can be used for callout views in the parent view, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ViewSection Class


ViewSection.IsSplitSection Method

ViewSectionIsSplitSection Method

Sections can be split (jog) so that they cut at >1 plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSplitSection()
Public Function IsSplitSection As Boolean
public:
bool IsSplitSection()
member IsSplitSection : unit -> bool

Return Value

Boolean
True if the section is split.
See Also

Reference

ViewSection Class


ViewSection.IsViewFamilyTypeValidForCallout Method

ViewSectionIsViewFamilyTypeValidForCallout Method

This validator checks that the ViewFamilyType is appropriate for callout views in the input parent view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsViewFamilyTypeValidForCallout(
    Document document,
    ElementId viewFamilyTypeId,
    ElementId parentViewId
)
Public Shared Function IsViewFamilyTypeValidForCallout (
    document As Document,
    viewFamilyTypeId As ElementId,
    parentViewId As ElementId
) As Boolean
public:
static bool IsViewFamilyTypeValidForCallout(
    Document^ document,
    ElementId^ viewFamilyTypeId,
    ElementId^ parentViewId
)
static member IsViewFamilyTypeValidForCallout :
        document : Document *
        viewFamilyTypeId : ElementId *
        parentViewId : ElementId -> bool

Parameters

document Document
The document which contains the ViewFamilyType and parent view.
viewFamilyTypeId ElementId
The id of the ViewFamilyType which will be used by the new callout ViewSection. Detail ViewFamilyTypes can be used in all parent views except for CeilingPlan and Drafting views. FloorPlan, CeilingPlan, StructuralPlan, Section, Elevation, and Detail ViewFamilyTypes may be be used in parent views that also use a type with the same ViewFamily enum value. For example, in StructuralPlan views both StructuralPlan and Detail ViewFamilyTypes are allowed.
parentViewId ElementId
The view in which the new callout will appear. Callouts can be created in FloorPlan, CeilingPlan, StructuralPlan, Section, Elevation, and Detail views.

Return Value

Boolean
True if the ViewFamilyType can be used for callout views in the parent view, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ViewSection Class


ViewSet Class

A set that contains views.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBViewSet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ViewSet : APIObject, IEnumerable
Public Class ViewSet
    Inherits APIObject
    Implements IEnumerable
public ref class ViewSet : public APIObject,
    IEnumerable
type ViewSet =
    class
        inherit APIObject
        interface IEnumerable
    end

The ViewSet type exposes the following members.

Constructors
 | Name | Description
Public method | ViewSet | Initializes a new instance of the ViewSet class
Top
Properties
 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Size | Returns the number of views that are in the set.
Top
Methods
 | Name | Description
Public method | Clear | Removes every view from the set, rendering it empty.
Public method | Contains | Tests for the existence of a view within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase | Removes a specified view from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified view into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ViewSet Constructor

Initializes a new instance of the ViewSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ViewSet()
Public Sub New
public:
ViewSet()
new : unit -> ViewSet
See Also

Reference

ViewSet Class


ViewSet Properties

The ViewSet type exposes the following members.

Properties
 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Public property | Size | Returns the number of views that are in the set.
Top
See Also

Reference

ViewSet Class


ViewSet.IsEmpty Property

ViewSetIsEmpty Property

Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
public:
virtual property bool IsEmpty {
    bool get ();
}
abstract IsEmpty : bool with get
override IsEmpty : bool with get

Property Value

Boolean
Remarks
If the set is empty then True will be returned, otherwise False.
See Also

Reference

ViewSet Class


ViewSet.Size Property

ViewSetSize Property

Returns the number of views that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get
public:
virtual property int Size {
    int get ();
}
abstract Size : int with get
override Size : int with get

Property Value

Int32
See Also

Reference

ViewSet Class


ViewSet Methods

The ViewSet type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Removes every view from the set, rendering it empty.
Public method | Contains | Tests for the existence of a view within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | Erase | Removes a specified view from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Insert | Insert the specified view into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ViewSet Class


ViewSet.Clear Method

ViewSetClear Method

Removes every view from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Clear()
Public Overridable Sub Clear
public:
virtual void Clear()
abstract Clear : unit -> unit
override Clear : unit -> unit
See Also

Reference

ViewSet Class


ViewSet.Contains Method

ViewSetContains Method

Tests for the existence of a view within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Contains(
    View item
)
Public Overridable Function Contains (
    item As View
) As Boolean
public:
virtual bool Contains(
    View^ item
)
abstract Contains :
        item : View -> bool
override Contains :
        item : View -> bool

Parameters

item View
The view to be searched for.

Return Value

Boolean
The Contains method returns True if the view is within the set, otherwise False.
See Also

Reference

ViewSet Class


ViewSet.Erase Method

ViewSetErase Method

Removes a specified view from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual int Erase(
    View item
)
Public Overridable Function Erase (
    item As View
) As Integer
public:
virtual int Erase(
    View^ item
)
abstract Erase :
        item : View -> int
override Erase :
        item : View -> int

Parameters

item View
The view to be erased.

Return Value

Int32
The number of views that were erased from the set.
See Also

Reference

ViewSet Class


ViewSet.ForwardIterator Method

ViewSetForwardIterator Method

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ViewSetIterator ForwardIterator()
Public Overridable Function ForwardIterator As ViewSetIterator
public:
virtual ViewSetIterator^ ForwardIterator()
abstract ForwardIterator : unit -> ViewSetIterator
override ForwardIterator : unit -> ViewSetIterator

Return Value

ViewSetIterator
Returns a forward moving iterator to the set.
See Also

Reference

ViewSet Class


ViewSet.GetEnumerator Method

ViewSetGetEnumerator Method

Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator
override GetEnumerator : unit -> IEnumerator

Return Value

IEnumerator
Returns a forward moving iterator to the set.

Implements

IEnumerableGetEnumerator
See Also

Reference

ViewSet Class


ViewSet.Insert Method

ViewSetInsert Method

Insert the specified view into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool Insert(
    View item
)
Public Overridable Function Insert (
    item As View
) As Boolean
public:
virtual bool Insert(
    View^ item
)
abstract Insert :
        item : View -> bool
override Insert :
        item : View -> bool

Parameters

item View
The view to be inserted into the set.

Return Value

Boolean
Returns whether the view was inserted into the set.
See Also

Reference

ViewSet Class


ViewSet.ReverseIterator Method

ViewSetReverseIterator Method

Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ViewSetIterator ReverseIterator()
Public Overridable Function ReverseIterator As ViewSetIterator
public:
virtual ViewSetIterator^ ReverseIterator()
abstract ReverseIterator : unit -> ViewSetIterator
override ReverseIterator : unit -> ViewSetIterator

Return Value

ViewSetIterator
Returns a backward moving iterator to the set.
See Also

Reference

ViewSet Class


ViewSetIterator Class

An iterator to a view set.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBViewSetIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class ViewSetIterator : APIObject,
    IEnumerator
Public MustInherit Class ViewSetIterator
    Inherits APIObject
    Implements IEnumerator
public ref class ViewSetIterator abstract : public APIObject,
    IEnumerator
[<AbstractClassAttribute>]
type ViewSetIterator =
    class
        inherit APIObject
        interface IEnumerator
    end

The ViewSetIterator type exposes the following members.

Constructors
 | Name | Description
Public method | ViewSetIterator | For Internal Use Only.
Top
Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ViewSetIterator Constructor

For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ViewSetIterator()
Public Sub New
public:
ViewSetIterator()
new : unit -> ViewSetIterator
Remarks
This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.
See Also

Reference

ViewSetIterator Class


ViewSetIterator Properties

The ViewSetIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

ViewSetIterator Class


ViewSetIterator.Current Property

ViewSetIteratorCurrent Property

Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual Object Current { get; }
Public Overridable ReadOnly Property Current As Object
    Get
public:
virtual property Object^ Current {
    Object^ get ();
}
abstract Current : Object with get
override Current : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.
See Also

Reference

ViewSetIterator Class


ViewSetIterator Methods

The ViewSetIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ViewSetIterator Class


ViewSetIterator.MoveNext Method

ViewSetIteratorMoveNext Method

Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumeratorMoveNext
Remarks
MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.
See Also

Reference

ViewSetIterator Class


ViewSetIterator.Reset Method

ViewSetIteratorReset Method

Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit

Implements

IEnumeratorReset
Remarks
The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.
See Also

Reference

ViewSetIterator Class


ViewShapeBuilder Class

Builds and verifies a view-specific shape representation that would typically be stored in a DirectShape object. Currently limited to curve-based representations for plan and elevation views.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBShapeBuilder
Autodesk.Revit.DBViewShapeBuilder

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ViewShapeBuilder : ShapeBuilder
Public Class ViewShapeBuilder
    Inherits ShapeBuilder
public ref class ViewShapeBuilder : public ShapeBuilder
type ViewShapeBuilder =
    class
        inherit ShapeBuilder
    end

The ViewShapeBuilder type exposes the following members.

Constructors
 | Name | Description
Public method | ViewShapeBuilder | Default constructor for an ViewShapeBuilder object.
Public method | ViewShapeBuilder(DirectShapeTargetViewType) | A constructor for an ViewShapeBuilder object that takes a view type. It will infer the view normal from view type. View normal and view type are used to validate the geometry to be stored as a view-specific shape representation of a DirectShape object.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ShapeBuilder)
Public property | ViewNormal | Normal of the view that will display the shape being built. Must be set explicitly before adding any geometry. Must be a unit vector. This is used to validate incoming geometry - it must be orthogonal to the viewNormal.
Public property | ViewType | View type where the view-specific shape currently being built will be used
Top
Methods
 | Name | Description
Public method | AddCurve | Add a curve to the GRep associated to this ViewShapeBuilder.
Public method | Dispose | (Inherited from ShapeBuilder)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Reset | Clears the accumulated geometry and resets other ViewShapeBuilder parameters to invalid values.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | ValidateCurve(Curve) | Validates curve to be added to the view-specific shape being constructed. Called by AddCurve() to validate input. Expects a valid view normal to be set prior to the call.
 | ValidateCurve(Curve, DirectShapeTargetViewType) | Validates curve to be added to the view-specific shape being constructed. Called by AddCurve() to validate input. This function may be used to pre-validate the geometry being added to avoid AddCurve() throwing an InvalidArgumentException
 | ValidateShape | Validates a shape represented as a collection of geometry objects for use as a view-specific shape. The objects are expected to be either points, curves or polylines. Curves are expected to be flat and lie in a plane perpendicular to view normal as defined by view type.
 | ValidateViewType | Validates the incoming view type. As of today, the only allowed view type is Plan.
Top
Remarks
The validation functionality is used by DirectShape to validate the incoming shape.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ViewShapeBuilder Constructor

Overload List
 | Name | Description
Public method | ViewShapeBuilder | Default constructor for an ViewShapeBuilder object.
Public method | ViewShapeBuilder(DirectShapeTargetViewType) | A constructor for an ViewShapeBuilder object that takes a view type. It will infer the view normal from view type. View normal and view type are used to validate the geometry to be stored as a view-specific shape representation of a DirectShape object.
Top
See Also

Reference

ViewShapeBuilder Class


ViewShapeBuilder Constructor

Default constructor for an ViewShapeBuilder object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ViewShapeBuilder()
Public Sub New
public:
ViewShapeBuilder()
new : unit -> ViewShapeBuilder
See Also

Reference

ViewShapeBuilder Class
ViewShapeBuilder Overload


ViewShapeBuilder(DirectShapeTargetViewType) Constructor

A constructor for an ViewShapeBuilder object that takes a view type. It will infer the view normal from view type. View normal and view type are used to validate the geometry to be stored as a view-specific shape representation of a DirectShape object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ViewShapeBuilder(
    DirectShapeTargetViewType targetViewType
)
Public Sub New (
    targetViewType As DirectShapeTargetViewType
)
public:
ViewShapeBuilder(
    DirectShapeTargetViewType targetViewType
)
new :
        targetViewType : DirectShapeTargetViewType -> ViewShapeBuilder

Parameters

targetViewType DirectShapeTargetViewType
View type for which this shape representation is intended. Currently limited to Plan Views.
Exceptions
Exception | Condition
ArgumentException | targetViewType is not DirectShapeTargetViewType::Plan
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ViewShapeBuilder Class
ViewShapeBuilder Overload


ViewShapeBuilder Properties

The ViewShapeBuilder type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ShapeBuilder)
Public property | ViewNormal | Normal of the view that will display the shape being built. Must be set explicitly before adding any geometry. Must be a unit vector. This is used to validate incoming geometry - it must be orthogonal to the viewNormal.
Public property | ViewType | View type where the view-specific shape currently being built will be used
Top
See Also

Reference

ViewShapeBuilder Class


ViewShapeBuilder.ViewNormal Property

ViewShapeBuilderViewNormal Property

Normal of the view that will display the shape being built. Must be set explicitly before adding any geometry. Must be a unit vector. This is used to validate incoming geometry - it must be orthogonal to the viewNormal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ ViewNormal { get; set; }
Public Property ViewNormal As XYZ
    Get
    Set
public:
property XYZ^ ViewNormal {
    XYZ^ get ();
    void set (XYZ^ value);
}
member ViewNormal : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
ArgumentOutOfRangeException | When setting this property: viewNormal is not length 1.0.
See Also

Reference

ViewShapeBuilder Class


ViewShapeBuilder.ViewType Property

ViewShapeBuilderViewType Property

View type where the view-specific shape currently being built will be used

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DirectShapeTargetViewType ViewType { get; set; }
Public Property ViewType As DirectShapeTargetViewType
    Get
    Set
public:
property DirectShapeTargetViewType ViewType {
    DirectShapeTargetViewType get ();
    void set (DirectShapeTargetViewType value);
}
member ViewType : DirectShapeTargetViewType with get, set

Property Value

DirectShapeTargetViewType
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ViewShapeBuilder Class


ViewShapeBuilder Methods

The ViewShapeBuilder type exposes the following members.

Methods
 | Name | Description
Public method | AddCurve | Add a curve to the GRep associated to this ViewShapeBuilder.
Public method | Dispose | (Inherited from ShapeBuilder)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Reset | Clears the accumulated geometry and resets other ViewShapeBuilder parameters to invalid values.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | ValidateCurve(Curve) | Validates curve to be added to the view-specific shape being constructed. Called by AddCurve() to validate input. Expects a valid view normal to be set prior to the call.
 | ValidateCurve(Curve, DirectShapeTargetViewType) | Validates curve to be added to the view-specific shape being constructed. Called by AddCurve() to validate input. This function may be used to pre-validate the geometry being added to avoid AddCurve() throwing an InvalidArgumentException
 | ValidateShape | Validates a shape represented as a collection of geometry objects for use as a view-specific shape. The objects are expected to be either points, curves or polylines. Curves are expected to be flat and lie in a plane perpendicular to view normal as defined by view type.
 | ValidateViewType | Validates the incoming view type. As of today, the only allowed view type is Plan.
Top
See Also

Reference

ViewShapeBuilder Class


ViewShapeBuilder.AddCurve Method

ViewShapeBuilderAddCurve Method

Add a curve to the GRep associated to this ViewShapeBuilder.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddCurve(
    Curve GCurve
)
Public Sub AddCurve (
    GCurve As Curve
)
public:
void AddCurve(
    Curve^ GCurve
)
member AddCurve :
        GCurve : Curve -> unit

Parameters

GCurve Curve
The curve to be added.
Exceptions
Exception | Condition
ArgumentException | GCurve is not acceptable for view-specific shape representation that is currently being built.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ViewShapeBuilder Class


ViewShapeBuilder.Reset Method

ViewShapeBuilderReset Method

Clears the accumulated geometry and resets other ViewShapeBuilder parameters to invalid values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Reset()
Public Sub Reset
public:
void Reset()
member Reset : unit -> unit
See Also

Reference

ViewShapeBuilder Class


ViewShapeBuilder.ValidateCurve Method

ViewShapeBuilderValidateCurve Method

Overload List
 | Name | Description
Public method | ValidateCurve(Curve) | Validates curve to be added to the view-specific shape being constructed. Called by AddCurve() to validate input. Expects a valid view normal to be set prior to the call.
 | ValidateCurve(Curve, DirectShapeTargetViewType) | Validates curve to be added to the view-specific shape being constructed. Called by AddCurve() to validate input. This function may be used to pre-validate the geometry being added to avoid AddCurve() throwing an InvalidArgumentException
Top
See Also

Reference

ViewShapeBuilder Class


ViewShapeBuilder.ValidateCurve(Curve) Method

ViewShapeBuilderValidateCurve(Curve) Method

Validates curve to be added to the view-specific shape being constructed. Called by AddCurve() to validate input. Expects a valid view normal to be set prior to the call.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ValidateCurve(
    Curve GCurve
)
Public Function ValidateCurve (
    GCurve As Curve
) As Boolean
public:
bool ValidateCurve(
    Curve^ GCurve
)
member ValidateCurve :
        GCurve : Curve -> bool

Parameters

GCurve Curve
Curve object to be validated.

Return Value

Boolean
True is %GCurve% is acceptable as a part of view-specific shape representation being built.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
This function may be used to pre-validate the geometry being added to avoid AddCurve() throwing an InvalidArgumentException Validation conditions depend on the type of view for which the shape representation is intended. For plan views, a curve is expected to be planar and non-degenerate (e.g., NOT a circle of zero radius).
See Also

Reference

ViewShapeBuilder Class
ValidateCurve Overload


ViewShapeBuilder.ValidateCurve(Curve, DirectShapeTargetViewType) Method

ViewShapeBuilderValidateCurve(Curve, DirectShapeTargetViewType) Method

Validates curve to be added to the view-specific shape being constructed. Called by AddCurve() to validate input. This function may be used to pre-validate the geometry being added to avoid AddCurve() throwing an InvalidArgumentException

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool ValidateCurve(
    Curve GCurve,
    DirectShapeTargetViewType targetViewType
)
Public Shared Function ValidateCurve (
    GCurve As Curve,
    targetViewType As DirectShapeTargetViewType
) As Boolean
public:
static bool ValidateCurve(
    Curve^ GCurve,
    DirectShapeTargetViewType targetViewType
)
static member ValidateCurve :
        GCurve : Curve *
        targetViewType : DirectShapeTargetViewType -> bool

Parameters

GCurve Curve
Curve object to be validated.
targetViewType DirectShapeTargetViewType
View type for which this curve is intended.

Return Value

Boolean
True is %GCurve% is acceptable as a part of view-specific shape representation.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Remarks
Validation conditions depend on the type of view for which the shape representation is intended. For plan views, a curve is expected to be planar and non-degenerate (e.g., NOT a circle of zero radius).
See Also

Reference

ViewShapeBuilder Class
ValidateCurve Overload


ViewShapeBuilder.ValidateShape Method

ViewShapeBuilderValidateShape Method

Validates a shape represented as a collection of geometry objects for use as a view-specific shape. The objects are expected to be either points, curves or polylines. Curves are expected to be flat and lie in a plane perpendicular to view normal as defined by view type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool ValidateShape(
    IList<GeometryObject> shape,
    DirectShapeTargetViewType targetViewType
)
Public Shared Function ValidateShape (
    shape As IList(Of GeometryObject),
    targetViewType As DirectShapeTargetViewType
) As Boolean
public:
static bool ValidateShape(
    IList<GeometryObject^>^ shape,
    DirectShapeTargetViewType targetViewType
)
static member ValidateShape :
        shape : IList<GeometryObject> *
        targetViewType : DirectShapeTargetViewType -> bool

Parameters

shape IList GeometryObject
targetViewType DirectShapeTargetViewType

Return Value

Boolean
Returns true if %shape% may be used as a view-specific shape representation, false otherwise.
Exceptions
Exception | Condition
ArgumentException | targetViewType is not DirectShapeTargetViewType::Plan
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ViewShapeBuilder Class


ViewShapeBuilder.ValidateViewType Method

ViewShapeBuilderValidateViewType Method

Validates the incoming view type. As of today, the only allowed view type is Plan.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool ValidateViewType(
    DirectShapeTargetViewType targetViewType
)
Public Shared Function ValidateViewType (
    targetViewType As DirectShapeTargetViewType
) As Boolean
public:
static bool ValidateViewType(
    DirectShapeTargetViewType targetViewType
)
static member ValidateViewType :
        targetViewType : DirectShapeTargetViewType -> bool

Parameters

targetViewType DirectShapeTargetViewType

Return Value

Boolean
True if %targetViewType% is DirectShapeTargetViewType::Plan
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ViewShapeBuilder Class


ViewSheet Class

Class for ViewSheet
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBView
Autodesk.Revit.DBViewSheet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ViewSheet : View
Public Class ViewSheet
    Inherits View
public ref class ViewSheet : public View
type ViewSheet =
    class
        inherit View
    end

The ViewSheet type exposes the following members.

Properties
 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View)
Public property | AreAnalyticalModelCategoriesHidden | Indicates if analytical model categories are currently hidden in the view. (Inherited from View)
Public property | AreAnnotationCategoriesHidden | Indicates if annotation categories are currently hidden in the view. (Inherited from View)
Public property | AreCoordinationModelHandlesHidden | Indicates if Coordination Model handles are currently hidden in the view. (Inherited from View)
Public property | AreImportCategoriesHidden | Indicates if import categories are currently hidden in the view. (Inherited from View)
Public property | AreModelCategoriesHidden | Indicates if model categories are currently hidden in the view. (Inherited from View)
Public property | ArePointCloudsHidden | Indicates if point clouds are currently hidden in the view. (Inherited from View)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CropBox | The Crop Box applied to the view, or an outline encompassing the crop region applied to the view. (Inherited from View)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | DetailLevel | The detail level of this view. (Inherited from View)
Public property | Discipline | The Discipline of the view. (Inherited from View)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | GenLevel | The level for the view. (Inherited from View)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsAssemblyView | Indicates if the view is assembly view. (Inherited from View)
Public property | IsCallout | Indicates if the view is a callout view. (Inherited from View)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsPlaceholder | Identifies whether or not the view sheet represents a placeholder sheet.
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | Origin | Returns the origin of the screen. (Inherited from View)
Public property | Outline | The bounds of the view in paper space (in feet). (Inherited from View)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | RevealConstraintsMode | Indicates whether the Reveal Constraints mode is activated in the view. (Inherited from View)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View)
Public property | Scale | The scale of the view. (Inherited from View)
Public property | ShadowIntensity | The intesity of cast shadows - 0 = no shadows, 100 = black. (Inherited from View)
Public property | SheetCollectionId | The ID of the sheet collection this sheet is associated with.
Public property | SheetNumber | The sheet number of the document.
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View)
Public property | SunlightIntensity | The intensity of the simulated (directional) sunlight. 0 = no directional light; maximum value is 100. (Inherited from View)
Public property | TemporaryViewModes | Data of temporary view modes associated with this view. (Inherited from View)
Public property | Title | The view title. This consists of the view name plus other modifiers, such as the view type, sheet number, area scheme, and/or assembly type, depending on the specifics of the view. (Inherited from View)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | ViewTemplateId | The id of the template view that controls this view's parameters. (Inherited from View)
 | ViewType | The type of the view. (Inherited from View)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | AddFilter | Adds a filter to the view. (Inherited from View)
Public method | AllowsAnalysisDisplay | Identifies if this view allows display of Analysis results. (Inherited from View)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of the input view that are not controlled by the current view template. (Inherited from View)
Public method | AreGraphicsOverridesAllowed | Determines if Visibility/Graphics Overriddes can be applied to the view. (Inherited from View)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanApplyColorFillScheme | Checks if the id can be applied as the scheme id of specified category to this view. (Inherited from View)
Public method | CanBeDuplicated | Identifies if this sheet can be duplicated.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanCategoryBeHidden | Checks whether the category can be hidden in the view. (Inherited from View)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanEnableTemporaryViewPropertiesMode | Indicates if Temporary View Properties mode can be applied for view in current state. (Inherited from View)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified (Inherited from View)
Public method | CanUseDepthCueing | Indicates if view can use Depth Cueing (Inherited from View)
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes (Inherited from View)
Public method | CanViewBeDuplicated | Identifies if this view can be duplicated. (Inherited from View)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View)
 | ConvertToIndependent | Convert the dependent view to independent. (Inherited from View)
Public method | ConvertToRealSheet | Converts a placeholder sheet to a real one with an optional titleblock.
 | Create | Creates a new ViewSheet.
 | CreatePlaceholder | Creates a placeholder sheet in a document.
Public method | CreateViewTemplate | Creates a new view template instance from this view instance. (Inherited from View)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | DeleteViewport | Removes a viewport from the sheet by deleting it from the document.
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate(SheetDuplicateOption) | Duplicates this sheet to generate a new one.
 | Duplicate(ViewDuplicateOption) | Duplicates this view. (Inherited from View)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View)
Public method | EnableTemporaryViewPropertiesMode | Turns Temporary View Properties mode on or off. In this mode, any changes made to the view are temporary and will be discarded once the mode is disabled. (Inherited from View)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAdditionalRevisionIds | Gets the Revisions that are additionally included in the sheet's revision schedules.
Public method | GetAllPlacedViews | Returns the ElementIds of Views placed on this sheet.
Public method | GetAllRevisionCloudIds | Gets the ids of the revision clouds which appear on the sheet's revision schedules.
Public method | GetAllRevisionIds | Gets the ordered array of Revisions which participate in the sheet's revision schedules.
Public method | GetAllViewports | Returns the ElementIds of Viewports on this sheet.
Public method | GetBackground | Returns the current background set for the view. (Inherited from View)
Public method | GetCalloutParentId | Gets ID of the callout parent view. (Inherited from View)
Public method | GetCategoryHidden | Checks if elements of the given category are set to be invisible (hidden) in this view. (Inherited from View)
Public method | GetCategoryOverrides | Gets graphic overrides for a category in view. (Inherited from View)
Public method | GetColorFillSchemeId | Returns id of the color fill scheme element applied to the view. (Inherited from View)
Public method | GetCropRegionShapeManager | Returns an object for managing view crop region shape. (Inherited from View)
Public method | GetCurrentRevision | Returns the most recent numbered Revision shown on this ViewSheet.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View)
Public method | GetDepthCueing | Returns the current depth cueing settings for the view. (Inherited from View)
Public method | GetDirectContext3DHandleOverrides | Returns DirectContext3D handle overrides object for the view. (Inherited from View)
Public method | GetElementOverrides | Gets graphic overrides for an element in the view. (Inherited from View)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFilterOverrides | Gets graphic overrides that a filter applies to the view. (Inherited from View)
Public method | GetFilters | Gets the filters applied to the view. (Inherited from View)
Public method | GetFilterVisibility | Gets the visibility of the elements associated with a filter. (Inherited from View)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIsFilterEnabled | Identifies if the filter is enabled in this view. (Inherited from View)
 | GetLinkOverrides | Gets the graphic overrides of a RevitLinkType or RevitLinkInstance in view. (Inherited from View)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetModelToProjectionTransforms | Gets the transforms from the model space to the view projection space. (Inherited from View)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetNonControlledTemplateParameterIds | Returns a list of parameters that are not marked as included when this view is used as a template. (Inherited from View)
Public method | GetOrderedFilters | Gets the filters applied to the view in the order they are applied. (Inherited from View)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPlacementOnSheetStatus | Determines if this view placed on a sheet completely or partially. (Inherited from View)
Public method | GetPointCloudOverrides | Returns point cloud overrides object for the view. (Inherited from View)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View)
Public method | GetReferenceCallouts | Returns element ids of all reference callouts in the view. (Inherited from View)
Public method | GetReferenceElevations | Returns element ids of all reference elevations in the view. (Inherited from View)
Public method | GetReferenceSections | Returns element ids of all reference sections in the view. (Inherited from View)
Public method | GetRevisionCloudNumberOnSheet | Gets the Revision Number for a RevisionCloud on this sheet.
Public method | GetRevisionNumberOnSheet | Gets the Revision Number for a particular Revision as it will appear on this sheet.
Public method | GetSketchyLines | Returns the current sketchy lines settings for the view. (Inherited from View)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTemplateParameterIds | Returns a list of parameter ids that may be controlled when this view is assigned as a template. (Inherited from View)
Public method | GetTemporaryViewPropertiesId | When Temporary View Properties mode is in progress it provides view id that overrode settings for current view. Outside Temporary View Properties mode InvalidElementId will be returned. (Inherited from View)
Public method | GetTemporaryViewPropertiesName | When Temporary View Properties mode is in progress, name of applied template is returned. Outside Temporary View Properties mode, empty string will be returned. (Inherited from View)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetViewDisplayModel | Returns the current view display model settings for the view. (Inherited from View)
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View)
Public method | HasDetailLevel | Check if the view has a Detail Level property (Inherited from View)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property (Inherited from View)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property (Inherited from View)
Public method | HasViewTransforms | Returns true if the view reports model space to view projection space transforms. (Inherited from View)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View)
Public method | IsCategoryOverridable | Checks whether the category can have graphic overrides in this view. (Inherited from View)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsFilterApplied | Indicates if a filter is applied to the view. (Inherited from View)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View)
Public method | IsTemporaryViewPropertiesModeEnabled | Returns true when Temporary View Properties mode is in progress, false otherwise. (Inherited from View)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | IsValidViewTemplate | Verifies that the view represented by templateId can be set as the controlling view template for this view. (Inherited from View)
Public method | IsViewValidForTemplateCreation | Verifies that the view is valid for template creation. (Inherited from View)
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | Print | Print this view with the default view template and using the print setting of the current active document. (Inherited from View)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveCalloutParent | Replaces callout parent ID with InvalidElementId. (Inherited from View)
Public method | RemoveFilter | Removes a filter from the view. (Inherited from View)
 | RemoveLinkOverrides | Deletes the graphical link overrides in the current view. (Inherited from View)
Public method | RestoreCalloutParent | Restores callout parent ID to the original view ID if that view is still available. (Inherited from View)
 | SetAdditionalRevisionIds | Sets the Revisions to additionally include in the sheet's revision schedules.
Public method | SetBackground | Sets the background for the view. Background can only be set for 3d views and for Sections/Elevations. (Inherited from View)
Public method | SetCategoryHidden | Sets if elements of the given category will be visible in this view. (Inherited from View)
Public method | SetCategoryOverrides | Sets graphic overrides for a category in view. (Inherited from View)
Public method | SetColorFillSchemeId | Applies color fill scheme to this view. (Inherited from View)
Public method | SetDepthCueing | Sets the depth cueing settings for the view. (Inherited from View)
Public method | SetElementOverrides | Sets graphic overrides for an element in the view. (Inherited from View)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
 | SetFilterOverrides | Sets the overrides associated with a filter. (Inherited from View)
Public method | SetFilterVisibility | Sets the visibility of the elements associated with a filter. (Inherited from View)
Public method | SetIsFilterEnabled | Sets the filter enabled flag. (Inherited from View)
 | SetLinkOverrides | Sets the graphic overrides of a RevitLinkType or RevitLinkInstance in the view. (Inherited from View)
Public method | SetNonControlledTemplateParameterIds | Sets the parameters that will not be included when this view is used as a template. (Inherited from View)
Public method | SetSketchyLines | Sets the sketchy lines settings for the view. (Inherited from View)
Public method | SetViewDisplayModel | Sets the view display model settings for the view. (Inherited from View)
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View)
 | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View)
Public method | SupportedColorFillCategoryIds | Returns collection of all category ids that correspond to elements that can potentially be colored in this view according to a color fill scheme. The set may be different depending on the view type. (Inherited from View)
Public method | SupportsRevealConstraints | Checks that the view can have the Reveal Constraints mode activated. (Inherited from View)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View)
Top
Example
C#
VB
C++
F#
Copy
private void Getinfo_ViewSheet(ViewSheet viewSheet)
{
    string message = "ViewSheet: ";
    //Get the number of the Sheet
    string sheetNumber = viewSheet.SheetNumber;
    message += "\nSheet Number: " + sheetNumber;

    //Exception occurs when set SheetNumber to a number that isn't unique
    string TestSheetNumber = "My sheet";
    viewSheet.SheetNumber = TestSheetNumber;
    message += "\nSheet Number after set: " + sheetNumber;

    ICollection<ElementId> views = viewSheet.GetAllPlacedViews();
    message += "\nNumber of views in the sheet : " + views.Count;

    TaskDialog.Show("Revit",message);
}
Private Sub Getinfo_ViewSheet(viewSheet As ViewSheet)
    Dim message As String = "ViewSheet: "
    'Get the number of the Sheet
    Dim sheetNumber As String = viewSheet.SheetNumber
    message += vbLf & "Sheet Number: " & sheetNumber

    'Exception occurs when set SheetNumber to a number that isn't unique
    Dim TestSheetNumber As String = "My sheet"
    viewSheet.SheetNumber = TestSheetNumber
    message += vbLf & "Sheet Number after set: " & sheetNumber

    Dim views As ICollection(Of ElementId) = viewSheet.GetAllPlacedViews()
    message += vbLf & "Number of views in the sheet : " & views.Count

    TaskDialog.Show("Revit", message)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ViewSheet Properties

The ViewSheet type exposes the following members.

Properties
 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View)
Public property | AreAnalyticalModelCategoriesHidden | Indicates if analytical model categories are currently hidden in the view. (Inherited from View)
Public property | AreAnnotationCategoriesHidden | Indicates if annotation categories are currently hidden in the view. (Inherited from View)
Public property | AreCoordinationModelHandlesHidden | Indicates if Coordination Model handles are currently hidden in the view. (Inherited from View)
Public property | AreImportCategoriesHidden | Indicates if import categories are currently hidden in the view. (Inherited from View)
Public property | AreModelCategoriesHidden | Indicates if model categories are currently hidden in the view. (Inherited from View)
Public property | ArePointCloudsHidden | Indicates if point clouds are currently hidden in the view. (Inherited from View)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CropBox | The Crop Box applied to the view, or an outline encompassing the crop region applied to the view. (Inherited from View)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | DetailLevel | The detail level of this view. (Inherited from View)
Public property | Discipline | The Discipline of the view. (Inherited from View)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | GenLevel | The level for the view. (Inherited from View)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsAssemblyView | Indicates if the view is assembly view. (Inherited from View)
Public property | IsCallout | Indicates if the view is a callout view. (Inherited from View)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsPlaceholder | Identifies whether or not the view sheet represents a placeholder sheet.
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | Origin | Returns the origin of the screen. (Inherited from View)
Public property | Outline | The bounds of the view in paper space (in feet). (Inherited from View)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | RevealConstraintsMode | Indicates whether the Reveal Constraints mode is activated in the view. (Inherited from View)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View)
Public property | Scale | The scale of the view. (Inherited from View)
Public property | ShadowIntensity | The intesity of cast shadows - 0 = no shadows, 100 = black. (Inherited from View)
Public property | SheetCollectionId | The ID of the sheet collection this sheet is associated with.
Public property | SheetNumber | The sheet number of the document.
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View)
Public property | SunlightIntensity | The intensity of the simulated (directional) sunlight. 0 = no directional light; maximum value is 100. (Inherited from View)
Public property | TemporaryViewModes | Data of temporary view modes associated with this view. (Inherited from View)
Public property | Title | The view title. This consists of the view name plus other modifiers, such as the view type, sheet number, area scheme, and/or assembly type, depending on the specifics of the view. (Inherited from View)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | ViewTemplateId | The id of the template view that controls this view's parameters. (Inherited from View)
 | ViewType | The type of the view. (Inherited from View)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

ViewSheet Class


ViewSheet.IsPlaceholder Property

ViewSheetIsPlaceholder Property

Identifies whether or not the view sheet represents a placeholder sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsPlaceholder { get; }
Public ReadOnly Property IsPlaceholder As Boolean
    Get
public:
property bool IsPlaceholder {
    bool get ();
}
member IsPlaceholder : bool with get

Property Value

Boolean
See Also

Reference

ViewSheet Class


ViewSheet.SheetCollectionId Property

ViewSheetSheetCollectionId Property

The ID of the sheet collection this sheet is associated with.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId SheetCollectionId { get; set; }
Public Property SheetCollectionId As ElementId
    Get
    Set
public:
property ElementId^ SheetCollectionId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member SheetCollectionId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentException | When setting this property: Assembly Sheets can't be SheetCollections. -or- When setting this property: The ElementId sheetCollectionId does not correspond to the SheetCollection.
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ViewSheet Class


ViewSheet.SheetNumber Property

ViewSheetSheetNumber Property

The sheet number of the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SheetNumber { get; set; }
Public Property SheetNumber As String
    Get
    Set
public:
property String^ SheetNumber {
    String^ get ();
    void set (String^ value);
}
member SheetNumber : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentException | When setting this property: sheetNumber is an empty string or contains only whitespace. -or- When setting this property: sheetNumber cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- When setting this property: Sheet number is already in use.
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ViewSheet Class


ViewSheet Methods

The ViewSheet type exposes the following members.

Methods
 | Name | Description
Public method | AddFilter | Adds a filter to the view. (Inherited from View)
Public method | AllowsAnalysisDisplay | Identifies if this view allows display of Analysis results. (Inherited from View)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of the input view that are not controlled by the current view template. (Inherited from View)
Public method | AreGraphicsOverridesAllowed | Determines if Visibility/Graphics Overriddes can be applied to the view. (Inherited from View)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanApplyColorFillScheme | Checks if the id can be applied as the scheme id of specified category to this view. (Inherited from View)
Public method | CanBeDuplicated | Identifies if this sheet can be duplicated.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanCategoryBeHidden | Checks whether the category can be hidden in the view. (Inherited from View)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanEnableTemporaryViewPropertiesMode | Indicates if Temporary View Properties mode can be applied for view in current state. (Inherited from View)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified (Inherited from View)
Public method | CanUseDepthCueing | Indicates if view can use Depth Cueing (Inherited from View)
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes (Inherited from View)
Public method | CanViewBeDuplicated | Identifies if this view can be duplicated. (Inherited from View)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View)
 | ConvertToIndependent | Convert the dependent view to independent. (Inherited from View)
Public method | ConvertToRealSheet | Converts a placeholder sheet to a real one with an optional titleblock.
 | Create | Creates a new ViewSheet.
 | CreatePlaceholder | Creates a placeholder sheet in a document.
Public method | CreateViewTemplate | Creates a new view template instance from this view instance. (Inherited from View)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | DeleteViewport | Removes a viewport from the sheet by deleting it from the document.
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate(SheetDuplicateOption) | Duplicates this sheet to generate a new one.
 | Duplicate(ViewDuplicateOption) | Duplicates this view. (Inherited from View)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View)
Public method | EnableTemporaryViewPropertiesMode | Turns Temporary View Properties mode on or off. In this mode, any changes made to the view are temporary and will be discarded once the mode is disabled. (Inherited from View)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAdditionalRevisionIds | Gets the Revisions that are additionally included in the sheet's revision schedules.
Public method | GetAllPlacedViews | Returns the ElementIds of Views placed on this sheet.
Public method | GetAllRevisionCloudIds | Gets the ids of the revision clouds which appear on the sheet's revision schedules.
Public method | GetAllRevisionIds | Gets the ordered array of Revisions which participate in the sheet's revision schedules.
Public method | GetAllViewports | Returns the ElementIds of Viewports on this sheet.
Public method | GetBackground | Returns the current background set for the view. (Inherited from View)
Public method | GetCalloutParentId | Gets ID of the callout parent view. (Inherited from View)
Public method | GetCategoryHidden | Checks if elements of the given category are set to be invisible (hidden) in this view. (Inherited from View)
Public method | GetCategoryOverrides | Gets graphic overrides for a category in view. (Inherited from View)
Public method | GetColorFillSchemeId | Returns id of the color fill scheme element applied to the view. (Inherited from View)
Public method | GetCropRegionShapeManager | Returns an object for managing view crop region shape. (Inherited from View)
Public method | GetCurrentRevision | Returns the most recent numbered Revision shown on this ViewSheet.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View)
Public method | GetDepthCueing | Returns the current depth cueing settings for the view. (Inherited from View)
Public method | GetDirectContext3DHandleOverrides | Returns DirectContext3D handle overrides object for the view. (Inherited from View)
Public method | GetElementOverrides | Gets graphic overrides for an element in the view. (Inherited from View)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFilterOverrides | Gets graphic overrides that a filter applies to the view. (Inherited from View)
Public method | GetFilters | Gets the filters applied to the view. (Inherited from View)
Public method | GetFilterVisibility | Gets the visibility of the elements associated with a filter. (Inherited from View)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIsFilterEnabled | Identifies if the filter is enabled in this view. (Inherited from View)
 | GetLinkOverrides | Gets the graphic overrides of a RevitLinkType or RevitLinkInstance in view. (Inherited from View)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetModelToProjectionTransforms | Gets the transforms from the model space to the view projection space. (Inherited from View)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetNonControlledTemplateParameterIds | Returns a list of parameters that are not marked as included when this view is used as a template. (Inherited from View)
Public method | GetOrderedFilters | Gets the filters applied to the view in the order they are applied. (Inherited from View)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPlacementOnSheetStatus | Determines if this view placed on a sheet completely or partially. (Inherited from View)
Public method | GetPointCloudOverrides | Returns point cloud overrides object for the view. (Inherited from View)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View)
Public method | GetReferenceCallouts | Returns element ids of all reference callouts in the view. (Inherited from View)
Public method | GetReferenceElevations | Returns element ids of all reference elevations in the view. (Inherited from View)
Public method | GetReferenceSections | Returns element ids of all reference sections in the view. (Inherited from View)
Public method | GetRevisionCloudNumberOnSheet | Gets the Revision Number for a RevisionCloud on this sheet.
Public method | GetRevisionNumberOnSheet | Gets the Revision Number for a particular Revision as it will appear on this sheet.
Public method | GetSketchyLines | Returns the current sketchy lines settings for the view. (Inherited from View)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTemplateParameterIds | Returns a list of parameter ids that may be controlled when this view is assigned as a template. (Inherited from View)
Public method | GetTemporaryViewPropertiesId | When Temporary View Properties mode is in progress it provides view id that overrode settings for current view. Outside Temporary View Properties mode InvalidElementId will be returned. (Inherited from View)
Public method | GetTemporaryViewPropertiesName | When Temporary View Properties mode is in progress, name of applied template is returned. Outside Temporary View Properties mode, empty string will be returned. (Inherited from View)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetViewDisplayModel | Returns the current view display model settings for the view. (Inherited from View)
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View)
Public method | HasDetailLevel | Check if the view has a Detail Level property (Inherited from View)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property (Inherited from View)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property (Inherited from View)
Public method | HasViewTransforms | Returns true if the view reports model space to view projection space transforms. (Inherited from View)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View)
Public method | IsCategoryOverridable | Checks whether the category can have graphic overrides in this view. (Inherited from View)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsFilterApplied | Indicates if a filter is applied to the view. (Inherited from View)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View)
Public method | IsTemporaryViewPropertiesModeEnabled | Returns true when Temporary View Properties mode is in progress, false otherwise. (Inherited from View)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | IsValidViewTemplate | Verifies that the view represented by templateId can be set as the controlling view template for this view. (Inherited from View)
Public method | IsViewValidForTemplateCreation | Verifies that the view is valid for template creation. (Inherited from View)
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | Print | Print this view with the default view template and using the print setting of the current active document. (Inherited from View)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveCalloutParent | Replaces callout parent ID with InvalidElementId. (Inherited from View)
Public method | RemoveFilter | Removes a filter from the view. (Inherited from View)
 | RemoveLinkOverrides | Deletes the graphical link overrides in the current view. (Inherited from View)
Public method | RestoreCalloutParent | Restores callout parent ID to the original view ID if that view is still available. (Inherited from View)
 | SetAdditionalRevisionIds | Sets the Revisions to additionally include in the sheet's revision schedules.
Public method | SetBackground | Sets the background for the view. Background can only be set for 3d views and for Sections/Elevations. (Inherited from View)
Public method | SetCategoryHidden | Sets if elements of the given category will be visible in this view. (Inherited from View)
Public method | SetCategoryOverrides | Sets graphic overrides for a category in view. (Inherited from View)
Public method | SetColorFillSchemeId | Applies color fill scheme to this view. (Inherited from View)
Public method | SetDepthCueing | Sets the depth cueing settings for the view. (Inherited from View)
Public method | SetElementOverrides | Sets graphic overrides for an element in the view. (Inherited from View)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
 | SetFilterOverrides | Sets the overrides associated with a filter. (Inherited from View)
Public method | SetFilterVisibility | Sets the visibility of the elements associated with a filter. (Inherited from View)
Public method | SetIsFilterEnabled | Sets the filter enabled flag. (Inherited from View)
 | SetLinkOverrides | Sets the graphic overrides of a RevitLinkType or RevitLinkInstance in the view. (Inherited from View)
Public method | SetNonControlledTemplateParameterIds | Sets the parameters that will not be included when this view is used as a template. (Inherited from View)
Public method | SetSketchyLines | Sets the sketchy lines settings for the view. (Inherited from View)
Public method | SetViewDisplayModel | Sets the view display model settings for the view. (Inherited from View)
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View)
 | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View)
Public method | SupportedColorFillCategoryIds | Returns collection of all category ids that correspond to elements that can potentially be colored in this view according to a color fill scheme. The set may be different depending on the view type. (Inherited from View)
Public method | SupportsRevealConstraints | Checks that the view can have the Reveal Constraints mode activated. (Inherited from View)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View)
Top
See Also

Reference

ViewSheet Class


ViewSheet.CanBeDuplicated Method

ViewSheetCanBeDuplicated Method

Identifies if this sheet can be duplicated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanBeDuplicated(
    SheetDuplicateOption duplicateOption
)
Public Function CanBeDuplicated (
    duplicateOption As SheetDuplicateOption
) As Boolean
public:
bool CanBeDuplicated(
    SheetDuplicateOption duplicateOption
)
member CanBeDuplicated :
        duplicateOption : SheetDuplicateOption -> bool

Parameters

duplicateOption SheetDuplicateOption
The option to use when duplicating the sheet.

Return Value

Boolean
True if the sheet can be duplicated, false otherwise.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ViewSheet Class


ViewSheet.ConvertToRealSheet Method

ViewSheetConvertToRealSheet Method

Converts a placeholder sheet to a real one with an optional titleblock.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void ConvertToRealSheet(
    ElementId titleBlockTypeId
)
Public Sub ConvertToRealSheet (
    titleBlockTypeId As ElementId
)
public:
void ConvertToRealSheet(
    ElementId^ titleBlockTypeId
)
member ConvertToRealSheet :
        titleBlockTypeId : ElementId -> unit

Parameters

titleBlockTypeId ElementId
The id of the placeholder sheet, or invalidElementId if no titleblock should be added.
Exceptions
Exception | Condition
ArgumentException | titleBlockTypeId does not correspond to a TitleBlock type.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This method may only be called on a placeholder sheet. -or- Failed to convert the sheet because the input titleblock could not be applied.
See Also

Reference

ViewSheet Class


ViewSheet.Create Method

ViewSheetCreate Method

Creates a new ViewSheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ViewSheet Create(
    Document document,
    ElementId titleBlockTypeId
)
Public Shared Function Create (
    document As Document,
    titleBlockTypeId As ElementId
) As ViewSheet
public:
static ViewSheet^ Create(
    Document^ document,
    ElementId^ titleBlockTypeId
)
static member Create :
        document : Document *
        titleBlockTypeId : ElementId -> ViewSheet

Parameters

document Document
The document to which the ViewSheet will be added.
titleBlockTypeId ElementId
The type id of the TitleBlock type which will be used by the new ViewSheet. For no TitleBlock, pass invalid element ID.

Return Value

ViewSheet
The new ViewSheet.
Exceptions
Exception | Condition
ArgumentException | The ElementId titleBlockTypeId does not correspond to a TitleBlock type. -or- document is not a project document.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Example
C#
VB
C++
F#
Copy
private void CreateSheetView(Autodesk.Revit.DB.Document document, View3D view3D)
{

    // Get an available title block from document
    FilteredElementCollector collector = new FilteredElementCollector(document);
    collector.OfClass(typeof(FamilySymbol));
    collector.OfCategory(BuiltInCategory.OST_TitleBlocks);

    FamilySymbol fs = collector.FirstElement() as FamilySymbol;
    if (fs != null)
    {
        using (Transaction t = new Transaction(document, "Create a new ViewSheet"))
        {
            t.Start();
            try
            {
                // Create a sheet view
                ViewSheet viewSheet = ViewSheet.Create(document, fs.Id);
                if (null == viewSheet)
                {
                    throw new Exception("Failed to create new ViewSheet.");
                }

                // Add passed in view onto the center of the sheet
                UV location = new UV((viewSheet.Outline.Max.U - viewSheet.Outline.Min.U) / 2,
                                     (viewSheet.Outline.Max.V - viewSheet.Outline.Min.V) / 2);

                //viewSheet.AddView(view3D, location);
                Viewport.Create(document, viewSheet.Id, view3D.Id, new XYZ(location.U, location.V, 0));

                // Print the sheet out
                if (viewSheet.CanBePrinted)
                {
                    TaskDialog taskDialog = new TaskDialog("Revit");
                    taskDialog.MainContent = "Print the sheet?";
                    TaskDialogCommonButtons buttons = TaskDialogCommonButtons.Yes | TaskDialogCommonButtons.No;
                    taskDialog.CommonButtons = buttons;
                    TaskDialogResult result = taskDialog.Show();

                    if (result == TaskDialogResult.Yes)
                    {
                        viewSheet.Print();
                    }
                }

                t.Commit();
            }
            catch
            {
                t.RollBack();
            }
        }
    }
}
Private Sub CreateSheetView(document As Autodesk.Revit.DB.Document, view3D As View3D)

    ' Get an available title block from document
    Dim collector As New FilteredElementCollector(document)
    collector.OfClass(GetType(FamilySymbol))
    collector.OfCategory(BuiltInCategory.OST_TitleBlocks)

    Dim fs As FamilySymbol = TryCast(collector.FirstElement(), FamilySymbol)
    If fs IsNot Nothing Then
        Using t As New Transaction(document, "Create a new ViewSheet")
            t.Start()
            Try
                ' Create a sheet view
                Dim viewSheet__1 As ViewSheet = ViewSheet.Create(document, fs.Id)
                If viewSheet__1 Is Nothing Then
                    Throw New Exception("Failed to create new ViewSheet.")
                End If

                ' Add passed in view onto the center of the sheet
                Dim location As New UV((viewSheet__1.Outline.Max.U - viewSheet__1.Outline.Min.U) / 2, (viewSheet__1.Outline.Max.V - viewSheet__1.Outline.Min.V) / 2)

                'viewSheet.AddView(view3D, location);
                Viewport.Create(document, viewSheet__1.Id, view3D.Id, New XYZ(location.U, location.V, 0))

                ' Print the sheet out
                If viewSheet__1.CanBePrinted Then
                    Dim taskDialog As New TaskDialog("Revit")
                    taskDialog.MainContent = "Print the sheet?"
                    Dim buttons As TaskDialogCommonButtons = TaskDialogCommonButtons.Yes Or TaskDialogCommonButtons.No
                    taskDialog.CommonButtons = buttons
                    Dim result As TaskDialogResult = taskDialog.Show()

                    If result = TaskDialogResult.Yes Then
                        viewSheet__1.Print()
                    End If
                End If

                t.Commit()
            Catch
                t.RollBack()
            End Try
        End Using
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

C#
VB
C++
F#
Copy
private void CreateSheetView(Autodesk.Revit.DB.Document document, View3D view3D)
{

    // Get an available title block from document
    IEnumerable<FamilySymbol>�familyList =�from�elem�in�new�FilteredElementCollector(document)
                                               .OfClass(typeof(FamilySymbol))
                                               .OfCategory(BuiltInCategory.OST_TitleBlocks)�
                                           let�type = elem�as�FamilySymbol    �
                                           where�type.Name.Contains("E1")�
                                           select�type;

    // Create a sheet view
    ViewSheet viewSheet = ViewSheet.Create(document, familyList.First().Id);
    if (null == viewSheet)
    {
        throw new Exception("Failed to create new ViewSheet.");
    }

    // Add passed in view onto the center of the sheet
    if (Viewport.CanAddViewToSheet(document, viewSheet.Id, view3D.Id))
    {
        BoundingBoxUV sheetBox = viewSheet.Outline;
        double yPosition = (sheetBox.Max.V - sheetBox.Min.V) / 2 + sheetBox.Min.V;
        double xPosition = (sheetBox.Max.U - sheetBox.Min.U) / 2 + sheetBox.Min.U;

        XYZ origin = new XYZ(xPosition, yPosition, 0);
        Viewport viewport = Viewport.Create(document, viewSheet.Id, view3D.Id, origin);
    }

    // Print the sheet out
    if (viewSheet.CanBePrinted)
    {
       TaskDialog taskDialog = new TaskDialog("Revit");
       taskDialog.MainContent = "Print the sheet?";
       TaskDialogCommonButtons buttons = TaskDialogCommonButtons.Yes | TaskDialogCommonButtons.No;
       taskDialog.CommonButtons = buttons;
       TaskDialogResult result = taskDialog.Show();

        if (result == TaskDialogResult.Yes)
        {
            viewSheet.Print();
        }
    }
}
Private Sub CreateSheetView(document As Autodesk.Revit.DB.Document, view3D As View3D)

    ' Get an available title block from document
    Dim collector1 As New FilteredElementCollector(document)
    collector1 = collector1.OfClass(GetType(FamilySymbol)).OfCategory(BuiltInCategory.OST_TitleBlocks)
    Dim familyList As IEnumerable(Of FamilySymbol)

    familyList = From elem In collector1
                 Let fstype = TryCast(elem, FamilySymbol)
                 Where fstype.Name.Contains("E1")
                 Select fstype

    ' Create a sheet view
    Dim viewSheet__1 As ViewSheet = ViewSheet.Create(document, familyList.First().Id)
    If viewSheet__1 Is Nothing Then
        Throw New Exception("Failed to create new ViewSheet.")
    End If

    ' Add passed in view onto the center of the sheet
    If Viewport.CanAddViewToSheet(document, viewSheet__1.Id, view3D.Id) Then
        Dim sheetBox As BoundingBoxUV = viewSheet__1.Outline
        Dim yPosition As Double = (sheetBox.Max.V - sheetBox.Min.V) / 2 + sheetBox.Min.V
        Dim xPosition As Double = (sheetBox.Max.U - sheetBox.Min.U) / 2 + sheetBox.Min.U

        Dim origin As New XYZ(xPosition, yPosition, 0)
        Dim viewport__2 As Viewport = Viewport.Create(document, viewSheet__1.Id, view3D.Id, origin)
    End If

    ' Print the sheet out
    If viewSheet__1.CanBePrinted Then
        Dim taskDialog As New TaskDialog("Revit")
        taskDialog.MainContent = "Print the sheet?"
        Dim buttons As TaskDialogCommonButtons = TaskDialogCommonButtons.Yes Or TaskDialogCommonButtons.No
        taskDialog.CommonButtons = buttons
        Dim result As TaskDialogResult = taskDialog.Show()

        If result = TaskDialogResult.Yes Then
            viewSheet__1.Print()
        End If
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

ViewSheet Class


ViewSheet.CreatePlaceholder Method

ViewSheetCreatePlaceholder Method

Creates a placeholder sheet in a document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ViewSheet CreatePlaceholder(
    Document aDoc
)
Public Shared Function CreatePlaceholder (
    aDoc As Document
) As ViewSheet
public:
static ViewSheet^ CreatePlaceholder(
    Document^ aDoc
)
static member CreatePlaceholder :
        aDoc : Document -> ViewSheet

Parameters

aDoc Document
The document.

Return Value

ViewSheet
The placeholder sheet.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Placeholder sheets represent sheets stored outside of the Revit model, but which should be organized along with the Revit sheets.
See Also

Reference

ViewSheet Class


ViewSheet.DeleteViewport Method

ViewSheetDeleteViewport Method

Removes a viewport from the sheet by deleting it from the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void DeleteViewport(
    Viewport viewport
)
Public Sub DeleteViewport (
    viewport As Viewport
)
public:
void DeleteViewport(
    Viewport^ viewport
)
member DeleteViewport :
        viewport : Viewport -> unit

Parameters

viewport Viewport
The viewport that will be deleted and removed from the sheet.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ViewSheet Class


ViewSheet.Duplicate Method

ViewSheetDuplicate Method

Overload List
 | Name | Description
Public method | Duplicate(SheetDuplicateOption) | Duplicates this sheet to generate a new one.
 | Duplicate(ViewDuplicateOption) | Duplicates this view.
Top
See Also

Reference

ViewSheet Class


ViewSheet.Duplicate(SheetDuplicateOption) Method

ViewSheetDuplicate(SheetDuplicateOption) Method

Duplicates this sheet to generate a new one.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId Duplicate(
    SheetDuplicateOption duplicateOption
)
Public Function Duplicate (
    duplicateOption As SheetDuplicateOption
) As ElementId
public:
ElementId^ Duplicate(
    SheetDuplicateOption duplicateOption
)
member Duplicate :
        duplicateOption : SheetDuplicateOption -> ElementId

Parameters

duplicateOption SheetDuplicateOption
The option to use when duplicating the sheet.

Return Value

ElementId
The id of the newly created sheet.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | Sheet cannot be duplicated
See Also

Reference

ViewSheet Class
Duplicate Overload


ViewSheet.GetAdditionalRevisionIds Method

ViewSheetGetAdditionalRevisionIds Method

Gets the Revisions that are additionally included in the sheet's revision schedules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetAdditionalRevisionIds()
Public Function GetAdditionalRevisionIds As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetAdditionalRevisionIds()
member GetAdditionalRevisionIds : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
The additionally included Revisions for the sheet's revision schedules.
Remarks
Revisions in the sheet's additional project revisions set will appear in revisions schedules even if no RevisionCloud belonging to that Revision is visible on the sheet. These ids correspond to the Revisions that are explicitly included on the sheet via the Revisions On Sheet parameter.
See Also

Reference

ViewSheet Class


ViewSheet.GetAllPlacedViews Method

ViewSheetGetAllPlacedViews Method

Returns the ElementIds of Views placed on this sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ISet<ElementId> GetAllPlacedViews()
Public Function GetAllPlacedViews As ISet(Of ElementId)
public:
ISet<ElementId^>^ GetAllPlacedViews()
member GetAllPlacedViews : unit -> ISet<ElementId>

Return Value

ISet ElementId
The ids of the views on this sheet.
Remarks
Schedules on the sheet are not returned by this method. Use ScheduleSheetInstance.OwnerViewId to find the sheet on which a schedule is placed.
See Also

Reference

ViewSheet Class


ViewSheet.GetAllRevisionCloudIds Method

ViewSheetGetAllRevisionCloudIds Method

Gets the ids of the revision clouds which appear on the sheet's revision schedules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ISet<ElementId> GetAllRevisionCloudIds()
Public Function GetAllRevisionCloudIds As ISet(Of ElementId)
public:
ISet<ElementId^>^ GetAllRevisionCloudIds()
member GetAllRevisionCloudIds : unit -> ISet<ElementId>

Return Value

ISet ElementId
The ids of the revisions clouds which appear on the sheet's revision schedules.
Remarks
The sheet's revision schedules include the revisions that are associated with revision clouds that are visible on the sheet. Revision schedules may also include revisions that have been additionally added to the sheet via the Revisions On Sheets parameter. Use GetAdditionalRevisionIds to get the additionally added revisions.
See Also

Reference

ViewSheet Class


ViewSheet.GetAllRevisionIds Method

ViewSheetGetAllRevisionIds Method

Gets the ordered array of Revisions which participate in the sheet's revision schedules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ElementId> GetAllRevisionIds()
Public Function GetAllRevisionIds As IList(Of ElementId)
public:
IList<ElementId^>^ GetAllRevisionIds()
member GetAllRevisionIds : unit -> IList<ElementId>

Return Value

IList ElementId
The ordered array of ids of Revisions participating in the sheet's revision schedules.
Remarks
The Revisions are ordered according to the revision sequence in the project. A Revision is considered to be participating in revision scheduling on the sheet if either a revision cloud belonging to that Revision is visible on the sheet or the Revision has been explicitly included using the Revisions On Sheet parameter.
See Also

Reference

ViewSheet Class


ViewSheet.GetAllViewports Method

ViewSheetGetAllViewports Method

Returns the ElementIds of Viewports on this sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetAllViewports()
Public Function GetAllViewports As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetAllViewports()
member GetAllViewports : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
The Viewports on this sheet.
Remarks
Schedules on the sheet are not returned by this method. Use ScheduleSheetInstance.OwnerViewId to find the sheet on which a schedule is placed.
See Also

Reference

ViewSheet Class


ViewSheet.GetCurrentRevision Method

ViewSheetGetCurrentRevision Method

Returns the most recent numbered Revision shown on this ViewSheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GetCurrentRevision()
Public Function GetCurrentRevision As ElementId
public:
ElementId^ GetCurrentRevision()
member GetCurrentRevision : unit -> ElementId

Return Value

ElementId
The Id of the most recent numbered Revision shown on this ViewSheet or InvalidElementId if none are shown.
Remarks
If the most recent Revision is not issued, Revit will typically use it as the default Revision for RevisionClouds placed on this ViewSheet. InvalidElementId will be returned if no Revisions are present. Revisions with RevisionNumberType.None will not be returned.
See Also

Reference

ViewSheet Class


ViewSheet.GetRevisionCloudNumberOnSheet Method

ViewSheetGetRevisionCloudNumberOnSheet Method

Gets the Revision Number for a RevisionCloud on this sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetRevisionCloudNumberOnSheet(
    ElementId revisionCloudId
)
Public Function GetRevisionCloudNumberOnSheet (
    revisionCloudId As ElementId
) As String
public:
String^ GetRevisionCloudNumberOnSheet(
    ElementId^ revisionCloudId
)
member GetRevisionCloudNumberOnSheet :
        revisionCloudId : ElementId -> string

Parameters

revisionCloudId ElementId
The id of the RevisionCLoud.

Return Value

String
Returns the Revision Number as it will appear on this sheet or if there is no Revision Number assigned on this sheet.
Exceptions
Exception | Condition
ArgumentException | revisionCloudId is not the Id of a RevisionCloud.
ArgumentNullException | A non-optional argument was null
Remarks
Returns if the RevisionCloud or its associated Revision do not appear on this sheet. The Revision Number for a RevisionCloud will always be the same as the Revision Number of the associated Revision.
See Also

Reference

ViewSheet Class


ViewSheet.GetRevisionNumberOnSheet Method

ViewSheetGetRevisionNumberOnSheet Method

Gets the Revision Number for a particular Revision as it will appear on this sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetRevisionNumberOnSheet(
    ElementId revisionId
)
Public Function GetRevisionNumberOnSheet (
    revisionId As ElementId
) As String
public:
String^ GetRevisionNumberOnSheet(
    ElementId^ revisionId
)
member GetRevisionNumberOnSheet :
        revisionId : ElementId -> string

Parameters

revisionId ElementId
The id of the Revision.

Return Value

String
Returns the Revision Number as it will appear on this sheet or if the Revision does not appear on this sheet.
Exceptions
Exception | Condition
ArgumentException | revisionId is not a valid Revision.
ArgumentNullException | A non-optional argument was null
Remarks
Returns if the Revision does not appear on this sheet.
See Also

Reference

ViewSheet Class


ViewSheet.SetAdditionalRevisionIds Method

ViewSheetSetAdditionalRevisionIds Method

Sets the Revisions to additionally include in the sheet's revision schedules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetAdditionalRevisionIds(
    ICollection<ElementId> projectRevisionIds
)
Public Sub SetAdditionalRevisionIds (
    projectRevisionIds As ICollection(Of ElementId)
)
public:
void SetAdditionalRevisionIds(
    ICollection<ElementId^>^ projectRevisionIds
)
member SetAdditionalRevisionIds :
        projectRevisionIds : ICollection<ElementId> -> unit

Parameters

projectRevisionIds ICollection ElementId
The ids of Revisions to explicitly include in the sheet's revision schedules.
Exceptions
Exception | Condition
ArgumentException | One or more ElementIds in projectRevisionIds do not correspond to a Revision element.
ArgumentNullException | A non-optional argument was null
Remarks
Additionally included Revisions will always participate in the sheet's revision schedules. Normally a Revision is scheduled in the revision schedule because one of its associated RevisionClouds is present on the sheet.

The additional project revision ids setting corresponds to the sheet's Revisions On Sheet parameter.

Example
C#
VB
C++
F#
Copy
public static void AddAdditionalRevisionsToSheet(ViewSheet viewSheet, String toMatch)
{
    Document doc = viewSheet.Document;

    ICollection<ElementId> revisions = viewSheet.GetAdditionalRevisionIds();

    // Find revisions whose description matches input string
    FilteredElementCollector collector = new FilteredElementCollector(doc);
    collector.OfCategory(BuiltInCategory.OST_Revisions);
    collector.WhereElementIsNotElementType();
    if (revisions.Count > 0)
        collector.Excluding(revisions);

    // Check if revision should be added
    foreach (Element revision in collector)
    {
        Parameter descriptionParam = revision.get_Parameter(BuiltInParameter.PROJECT_REVISION_REVISION_DESCRIPTION);
        String description = descriptionParam.AsString();
        if (description.Contains(toMatch))
            revisions.Add(revision.Id);
    }

    if (revisions.Count > 0)
    {
        // Apply the new list of revisions
        using (Transaction t = new Transaction(doc, "Add revisions to sheet"))
        {
            t.Start();
            viewSheet.SetAdditionalRevisionIds(revisions);
            t.Commit();
        }
    }
}
Public Shared Sub AddAdditionalRevisionsToSheet(viewSheet As ViewSheet, toMatch As [String])
    Dim doc As Document = viewSheet.Document

    Dim revisions As ICollection(Of ElementId) = viewSheet.GetAdditionalRevisionIds()

    ' Find revisions whose description matches input string
    Dim collector As New FilteredElementCollector(doc)
    collector.OfCategory(BuiltInCategory.OST_Revisions)
    collector.WhereElementIsNotElementType()
    If revisions.Count > 0 Then
        collector.Excluding(revisions)
    End If

    ' Check if revision should be added
    For Each revision As Element In collector
        Dim descriptionParam As Parameter = revision.Parameter(BuiltInParameter.PROJECT_REVISION_REVISION_DESCRIPTION)
        Dim description As [String] = descriptionParam.AsString()
        If description.Contains(toMatch) Then
            revisions.Add(revision.Id)
        End If
    Next

    If revisions.Count > 0 Then
        ' Apply the new list of revisions
        Using t As New Transaction(doc, "Add revisions to sheet")
            t.Start()
            viewSheet.SetAdditionalRevisionIds(revisions)
            t.Commit()
        End Using
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

ViewSheet Class


ViewSheetSet Class

Represents ViewSheetSets stored in a document. ViewSheetSets can be stored so that the same printing task can be executed multiple times.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBViewSheetSet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ViewSheetSet : Element,
    IViewSheetSet
Public Class ViewSheetSet
    Inherits Element
    Implements IViewSheetSet
public ref class ViewSheetSet : public Element,
    IViewSheetSet
type ViewSheetSet =
    class
        inherit Element
        interface IViewSheetSet
    end

The ViewSheetSet type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsAutomatic | Automatic order or manual order.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | The view sheet set name. (Overrides ElementName)
Public property | OrderedViewList | Ordered views.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SheetOrganizationId | ElementId to the BrowserOrganization for sheets.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewOrganizationId | ElementId to the BrowserOrganization for non-sheet views.
Public property | Views | The views.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
For the in-session ViewSheetSet, see the class InSessionViewSheetSet. Changes of ViewSheetSet would be effiective after [!:Autodesk::Revit::DB::ViewSheetSetting::Save]
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ViewSheetSet Properties

The ViewSheetSet type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsAutomatic | Automatic order or manual order.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | The view sheet set name. (Overrides ElementName)
Public property | OrderedViewList | Ordered views.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SheetOrganizationId | ElementId to the BrowserOrganization for sheets.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewOrganizationId | ElementId to the BrowserOrganization for non-sheet views.
Public property | Views | The views.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

ViewSheetSet Class


ViewSheetSet.IsAutomatic Property

ViewSheetSetIsAutomatic Property

Automatic order or manual order.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsAutomatic { get; set; }
Public Overridable Property IsAutomatic As Boolean
    Get
    Set
public:
virtual property bool IsAutomatic {
    bool get ();
    void set (bool value);
}
abstract IsAutomatic : bool with get, set
override IsAutomatic : bool with get, set

Property Value

Boolean

Implements

IViewSheetSetIsAutomatic
See Also

Reference

ViewSheetSet Class


ViewSheetSet.Name Property

ViewSheetSetName Property

The view sheet set name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string Name { get; set; }
Public Overrides Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

String
Exceptions
Exception | Condition
InvalidOperationException | Thrown when trying to set the name. Instead, set the name with the Rename(String) method.
See Also

Reference

ViewSheetSet Class


ViewSheetSet.OrderedViewList Property

ViewSheetSetOrderedViewList Property

Ordered views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IReadOnlyList<View> OrderedViewList { get; set; }
Public Overridable Property OrderedViewList As IReadOnlyList(Of View)
    Get
    Set
public:
virtual property IReadOnlyList<View^>^ OrderedViewList {
    IReadOnlyList<View^>^ get ();
    void set (IReadOnlyList<View^>^ value);
}
abstract OrderedViewList : IReadOnlyList<View> with get, set
override OrderedViewList : IReadOnlyList<View> with get, set

Property Value

IReadOnlyList View

Implements

IViewSheetSetOrderedViewList
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input ordered view list is .
InvalidOperationException | Thrown when the set operation failed due to invalid view which cannot be printed.
See Also

Reference

ViewSheetSet Class


ViewSheetSet.SheetOrganizationId Property

ViewSheetSetSheetOrganizationId Property

ElementId to the BrowserOrganization for sheets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ElementId SheetOrganizationId { get; set; }
Public Overridable Property SheetOrganizationId As ElementId
    Get
    Set
public:
virtual property ElementId^ SheetOrganizationId {
    ElementId^ get ();
    void set (ElementId^ value);
}
abstract SheetOrganizationId : ElementId with get, set
override SheetOrganizationId : ElementId with get, set

Property Value

ElementId

Implements

IViewSheetSetSheetOrganizationId
Exceptions
Exception | Condition
ArgumentException | Thrown when the ElementId does not reference to BrowserOrganization, or the target type of BrowserOrganization is incompatible.
Remarks
Ignored when [!:Autodesk::Revit::DB::PrintSetup::IsAutomatic] is .
See Also

Reference

ViewSheetSet Class


ViewSheetSet.ViewOrganizationId Property

ViewSheetSetViewOrganizationId Property

ElementId to the BrowserOrganization for non-sheet views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ElementId ViewOrganizationId { get; set; }
Public Overridable Property ViewOrganizationId As ElementId
    Get
    Set
public:
virtual property ElementId^ ViewOrganizationId {
    ElementId^ get ();
    void set (ElementId^ value);
}
abstract ViewOrganizationId : ElementId with get, set
override ViewOrganizationId : ElementId with get, set

Property Value

ElementId

Implements

IViewSheetSetViewOrganizationId
Exceptions
Exception | Condition
ArgumentException | Thrown when the ElementId does not reference to BrowserOrganization, or the target type of BrowserOrganization is incompatible.
Remarks
Ignored when [!:Autodesk::Revit::DB::PrintSetup::IsAutomatic] is .
See Also

Reference

ViewSheetSet Class


ViewSheetSet.Views Property

ViewSheetSetViews Property

The views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual ViewSet Views { get; set; }
Public Overridable Property Views As ViewSet
    Get
    Set
public:
virtual property ViewSet^ Views {
    ViewSet^ get ();
    void set (ViewSet^ value);
}
abstract Views : ViewSet with get, set
override Views : ViewSet with get, set

Property Value

ViewSet

Implements

IViewSheetSetViews
Exceptions
Exception | Condition
ArgumentNullException | Thrown when the input views is .
InvalidOperationException | Thrown when the set operation failed due to invalid view which cannot be printed.
See Also

Reference

ViewSheetSet Class


ViewSheetSet Methods

The ViewSheetSet type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ViewSheetSet Class


ViewSheetSetting Class

Represents the View/Sheet Set (Application Menu->Print) within Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBAPIObject
Autodesk.Revit.DBViewSheetSetting

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ViewSheetSetting : APIObject
Public Class ViewSheetSetting
    Inherits APIObject
public ref class ViewSheetSetting : public APIObject
type ViewSheetSetting =
    class
        inherit APIObject
    end

The ViewSheetSetting type exposes the following members.

Properties
 | Name | Description
Public property | AvailableViews | All views that can be printed.
Public property | CurrentViewSheetSet | The current view sheet set of PrintSetup.
Public property | InSession | The in-session view sheet set of Print Setup.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
Methods
 | Name | Description
Public method | Delete | Delete the current view sheet set, and make the In-Session set as the current one.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Rename | Rename the current view sheet set.
Public method | Revert | Revert the current view sheet set.
Public method | Save | Save the changes for the current view sheet set.
Public method | SaveAs | Save the current view sheet set to another view sheet set with the specified name.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ViewSheetSetting Properties

The ViewSheetSetting type exposes the following members.

Properties
 | Name | Description
Public property | AvailableViews | All views that can be printed.
Public property | CurrentViewSheetSet | The current view sheet set of PrintSetup.
Public property | InSession | The in-session view sheet set of Print Setup.
 | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject)
Top
See Also

Reference

ViewSheetSetting Class


ViewSheetSetting.AvailableViews Property

ViewSheetSettingAvailableViews Property

All views that can be printed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ViewSet AvailableViews { get; }
Public ReadOnly Property AvailableViews As ViewSet
    Get
public:
property ViewSet^ AvailableViews {
    ViewSet^ get ();
}
member AvailableViews : ViewSet with get

Property Value

ViewSet
Remarks
Users can select the view/sheet from this view set to printing.
See Also

Reference

ViewSheetSetting Class


ViewSheetSetting.CurrentViewSheetSet Property

ViewSheetSettingCurrentViewSheetSet Property

The current view sheet set of PrintSetup.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IViewSheetSet CurrentViewSheetSet { get; set; }
Public Property CurrentViewSheetSet As IViewSheetSet
    Get
    Set
public:
property IViewSheetSet^ CurrentViewSheetSet {
    IViewSheetSet^ get ();
    void set (IViewSheetSet^ value);
}
member CurrentViewSheetSet : IViewSheetSet with get, set

Property Value

IViewSheetSet
See Also

Reference

ViewSheetSetting Class


ViewSheetSetting.InSession Property

ViewSheetSettingInSession Property

The in-session view sheet set of Print Setup.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public InSessionViewSheetSet InSession { get; }
Public ReadOnly Property InSession As InSessionViewSheetSet
    Get
public:
property InSessionViewSheetSet^ InSession {
    InSessionViewSheetSet^ get ();
}
member InSession : InSessionViewSheetSet with get

Property Value

InSessionViewSheetSet
See Also

Reference

ViewSheetSetting Class


ViewSheetSetting Methods

The ViewSheetSetting type exposes the following members.

Methods
 | Name | Description
Public method | Delete | Delete the current view sheet set, and make the In-Session set as the current one.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Rename | Rename the current view sheet set.
Public method | Revert | Revert the current view sheet set.
Public method | Save | Save the changes for the current view sheet set.
Public method | SaveAs | Save the current view sheet set to another view sheet set with the specified name.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ViewSheetSetting Class


ViewSheetSetting.Delete Method

ViewSheetSettingDelete Method

Delete the current view sheet set, and make the In-Session set as the current one.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Delete()
Public Function Delete As Boolean
public:
bool Delete()
member Delete : unit -> bool

Return Value

Boolean
False if Delete operation fails, otherwise True.
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the current view sheet set is In-Session.
Remarks
If the current view sheet set is In-Session, an InvalidOperationException will be thrown.
See Also

Reference

ViewSheetSetting Class


ViewSheetSetting.Rename Method

ViewSheetSettingRename Method

Rename the current view sheet set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Rename(
    string newName
)
Public Function Rename (
    newName As String
) As Boolean
public:
bool Rename(
    String^ newName
)
member Rename :
        newName : string -> bool

Parameters

newName String
View sheet set name to be renamed as.

Return Value

Boolean
False if Rename operation fails, otherwise True.
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the input name is already existed in current view sheet set list.
See Also

Reference

ViewSheetSetting Class


ViewSheetSetting.Revert Method

ViewSheetSettingRevert Method

Revert the current view sheet set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Revert()
Public Sub Revert
public:
void Revert()
member Revert : unit -> unit
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the current view sheet set is In-Session.
See Also

Reference

ViewSheetSetting Class


ViewSheetSetting.Save Method

ViewSheetSettingSave Method

Save the changes for the current view sheet set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Save()
Public Function Save As Boolean
public:
bool Save()
member Save : unit -> bool

Return Value

Boolean
False if save operation fails, otherwise True.
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the current view sheet set is In-Session or the current view sheet set is unchanged.
See Also

Reference

ViewSheetSetting Class


ViewSheetSetting.SaveAs Method

ViewSheetSettingSaveAs Method

Save the current view sheet set to another view sheet set with the specified name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SaveAs(
    string newName
)
Public Function SaveAs (
    newName As String
) As Boolean
public:
bool SaveAs(
    String^ newName
)
member SaveAs :
        newName : string -> bool

Parameters

newName String
View sheet set name to be saved as.

Return Value

Boolean
False if Save As operation fails, otherwise True.
Exceptions
Exception | Condition
InvalidOperationException | Thrown when the input name is already existed in current view sheet set list.
See Also

Reference

ViewSheetSetting Class


ViewTemplateApplicationOption Enumeration

Options for applying view templates

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ViewTemplateApplicationOption
Public Enumeration ViewTemplateApplicationOption
public enum class ViewTemplateApplicationOption
type ViewTemplateApplicationOption
Members
Member name | Value | Description
AllParameters | 0 | Apply all parameters controlled by template
UncontrolledParameters | 1 | Apply only parameters controlled by template and not controlled by currently assigned view template
AllParametersAndStickIfNone | 2 | Apply all parameters controlled by template and if none is currently assigned make it view template
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ViewType Enumeration

An enumerated type listing available view types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ViewType
Public Enumeration ViewType
public enum class ViewType
type ViewType
Members
Member name | Value | Description
Undefined | 0 | Undefined/unspecified type of view.
FloorPlan | 1 | Floor plan type of view.
CeilingPlan | 2 | Reflected ceiling plan type of view.
Elevation | 3 | Elevation type of view.
ThreeD | 4 | 3-D type of view.
Schedule | 5 | Schedule type of view.
DrawingSheet | 6 | Drawing sheet type of view.
ProjectBrowser | 7 | The project browser view.
Report | 8 | Report type of view.
DraftingView | 10 | Drafting type of view.
Legend | 11 | Legend type of view.
SystemBrowser | 12 | The MEP system browser view.
EngineeringPlan | 115 | Structural plan or Engineering plan type of view.
AreaPlan | 116 | Area plan type of view.
Section | 117 | Cross section type of view.
Detail | 118 | Detail type of view.
CostReport | 119 | Cost Report view.
LoadsReport | 120 | Loads Report view.
PresureLossReport | 121 | Pressure Loss Report view.
ColumnSchedule | 122 | Column Schedule type of view.
PanelSchedule | 123 | Panel Schedule Report view.
Walkthrough | 124 | Walk-Through type of 3D view.
Rendering | 125 | Rendering type of view.
SystemsAnalysisReport | 126 | Systems analysis report view.
Internal | 214 | Revit's internal type of view
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


VirtualPrinterType Enumeration

An enumerated to list Virtual Printer Types in Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum VirtualPrinterType
Public Enumeration VirtualPrinterType
public enum class VirtualPrinterType
type VirtualPrinterType
Members
Member name | Value | Description
None | 0 | None.
AdobePDF | 1 | AdobePDF.
DWFWriter | 2 | DWFWriter.
XPSWriter | 3 | Microsoft XPS Document Writer.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Visibility Enumeration

Describes the visibility of a particular geometry object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum Visibility
Public Enumeration Visibility
public enum class Visibility
type Visibility
Members
Member name | Value | Description
Visible | 0 | The geometry object is always visible. This type of geometry is always returned by GeometryOptions
Highlight | 1 | The geometry object is visible, but is affected by highlight or prehighlight special coloration. This type of geometry is returned by GeometryOptions if IncludeNonVisibleObjects is true.
Contextual | 2 | The geometry object is visible in some contexts, but not in others. This type of geometry is always returned by GeometryOptions, even when Revit is in a context where the geometry should not be visible, but only if IncludeNonVisibleObjects is true. Examples of geometry of this class include Solids representing insulation and lining for MEP ducts and pipes.
Invisible | 3 | The geometry object is never visible. This type of geometry is never returned by GeometryOptions but may be obtained by other API operations.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


VisibleInViewFilter Class

A quick filter that passes elements that are most likely visible in the given view.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElementFilter
Autodesk.Revit.DBElementQuickFilter
Autodesk.Revit.DBVisibleInViewFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class VisibleInViewFilter : ElementQuickFilter
Public Class VisibleInViewFilter
    Inherits ElementQuickFilter
public ref class VisibleInViewFilter : public ElementQuickFilter
type VisibleInViewFilter =
    class
        inherit ElementQuickFilter
    end

The VisibleInViewFilter type exposes the following members.

Constructors
 | Name | Description
Public method | VisibleInViewFilter(Document, ElementId) | Constructs a new instance of a VisibleInViewFilter.
Public method | VisibleInViewFilter(Document, ElementId, Boolean) | Constructs a new instance of a VisibleInViewFilter, with the option to pass all non-visible elements.
Top
Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory. In some situations (for example, when the element geometry is not yet calculated for the input view) this filter may return true even though the element may not actually be visible when geometry is calculated.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


VisibleInViewFilter Constructor

Overload List
 | Name | Description
Public method | VisibleInViewFilter(Document, ElementId) | Constructs a new instance of a VisibleInViewFilter.
Public method | VisibleInViewFilter(Document, ElementId, Boolean) | Constructs a new instance of a VisibleInViewFilter, with the option to pass all non-visible elements.
Top
See Also

Reference

VisibleInViewFilter Class


VisibleInViewFilter(Document, ElementId) Constructor

Constructs a new instance of a VisibleInViewFilter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VisibleInViewFilter(
    Document document,
    ElementId viewId
)
Public Sub New (
    document As Document,
    viewId As ElementId
)
public:
VisibleInViewFilter(
    Document^ document,
    ElementId^ viewId
)
new :
        document : Document *
        viewId : ElementId -> VisibleInViewFilter

Parameters

document Document
The document that owns the view.
viewId ElementId
The view id.
Exceptions
Exception | Condition
ArgumentException | viewId is not a view. -or- viewId is not valid for element iteration, because it has no way of representing drawn elements. Many view templates will fail this check.
ArgumentNullException | A non-optional argument was null
See Also

Reference

VisibleInViewFilter Class
VisibleInViewFilter Overload


VisibleInViewFilter(Document, ElementId, Boolean) Constructor

Constructs a new instance of a VisibleInViewFilter, with the option to pass all non-visible elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VisibleInViewFilter(
    Document document,
    ElementId viewId,
    bool inverted
)
Public Sub New (
    document As Document,
    viewId As ElementId,
    inverted As Boolean
)
public:
VisibleInViewFilter(
    Document^ document,
    ElementId^ viewId,
    bool inverted
)
new :
        document : Document *
        viewId : ElementId *
        inverted : bool -> VisibleInViewFilter

Parameters

document Document
The document that owns the view.
viewId ElementId
The view id.
inverted Boolean
True if the filter should match all elements not visible in the given view.
Exceptions
Exception | Condition
ArgumentException | viewId is not a view. -or- viewId is not valid for element iteration, because it has no way of representing drawn elements. Many view templates will fail this check.
ArgumentNullException | A non-optional argument was null
See Also

Reference

VisibleInViewFilter Class
VisibleInViewFilter Overload


VisibleInViewFilter Properties

The VisibleInViewFilter type exposes the following members.

Properties
 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter)
Top
See Also

Reference

VisibleInViewFilter Class


VisibleInViewFilter Methods

The VisibleInViewFilter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from ElementFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

VisibleInViewFilter Class


Wall Class

Represents a wall in Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBHostObject
Autodesk.Revit.DBWall

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Wall : HostObject
Public Class Wall
    Inherits HostObject
public ref class Wall : public HostObject
type Wall =
    class
        inherit HostObject
    end

The Wall type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CrossSection | Gets or sets the Cross-section for this wall.
Public property | CurtainGrid | Get the grid object of a curtain wall
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | Flipped | Property to test whether the wall orientation is flipped.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsStackedWall | Identifies if the wall is a stacked wall.
Public property | IsStackedWallMember | Identifies if the wall is a member of a stacked wall.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | Orientation | The outward-facing normal vector of the exterior side face at the starting point of the wall.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SketchId | Returns id of the profile sketch, or invalidElementId if sketch does not exist.
Public property | StackedWallOwnerId | Gets the stacked wall which contains this stacked wall member.
Public property | StructuralUsage | Retrieves or changes the wall's designated structural usage.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WallType | Retrieves or changes the type of the wall.
Public property | Width | Get the overall thickness of the wall.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | AllowWrappingAtLocation | Allow end wrapping at the location.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveProfileSketch | Checks whether this wall has or can have a profile sketch.
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create(Document, IListCurve, Boolean) | Creates a non rectangular profile wall within the project using the default wall type.
 | Create(Document, Curve, ElementId, Boolean) | Creates a new rectangular profile wall within the project using the default wall style.
 | Create(Document, IListCurve, ElementId, ElementId, Boolean) | Creates a non rectangular profile wall within the project using the specified wall type.
 | Create(Document, IListCurve, ElementId, ElementId, Boolean, XYZ) | Creates a non rectangular profile wall within the project using the specified wall type and normal vector.
 | Create(Document, Curve, ElementId, ElementId, Double, Double, Boolean, Boolean) | Creates a new rectangular profile wall within the project using the specified wall type, height, and offset.
Public method | CreateProfileSketch | Creates a new Wall profile Sketch.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | DisallowWrappingAtLocation | Disallow end wrapping at the location.
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject)
Public method | Flip | The wall orientation will be flipped.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetStackedWallMemberIds | Get the sub walls which belongs to the wall.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetValidWrappingLocationIndices | Gets all valid locations for end wrapping.
Public method | GetWrappingLocationAsCurveParameter | Gets the non-normalized (actual) curve parameter of the location.
Public method | GetWrappingLocationAsReferences | Gets an array of references to faces at the location.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | IsWallCrossSectionValid | Checks whether the desired cross section is valid for the current wall.
Public method | IsWrappingAtLocationAllowed | If end wrapping is allowed at the location.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveProfileSketch | Reverts an edited wall to its original shape.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The wall object represents all the different kinds of walls in Revit.
Example
C#
VB
C++
F#
Copy
public void GetInfo_Wall(Wall wall)
{
    string message = "Wall : ";

    wall.Flip();
    message += "\nIf wall Flipped : " + wall.Flipped;
    // Get curve start point
    message += "\nWall orientation point is :(" + wall.Orientation.X + ", "
        + wall.Orientation.Y + ", " + wall.Orientation.Z + ")";
    // Get wall StructuralUsage
    message += "\nWall StructuralUsage is : " + wall.StructuralUsage;
    // Get wall type name
    message += "\nWall type name is : " + wall.WallType.Name;
    // Get wall width
    message += "\nWall width is : " + wall.Width;

    TaskDialog.Show("Revit",message);
}
Public Sub GetInfo_Wall(wall As Wall)
 Dim message As String = "Wall : "
 wall.Flip()
    message += vbLf & "If wall Flipped : " & Convert.ToString(wall.Flipped)
    ' Get curve start point
    message += vbLf & "Wall orientation point is :(" & Convert.ToString(wall.Orientation.X) & ", " & Convert.ToString(wall.Orientation.Y) & ", " & Convert.ToString(wall.Orientation.Z) & ")"
    ' Get wall StructuralUsage
    message += vbLf & "Wall StructuralUsage is : " & Convert.ToString(wall.StructuralUsage)
    ' Get wall type name
    message += vbLf & "Wall type name is : " & Convert.ToString(wall.WallType.Name)
    ' Get wall width
    message += vbLf & "Wall width is : " & Convert.ToString(wall.Width)

    TaskDialog.Show("Revit", message)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Wall Properties

The Wall type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CrossSection | Gets or sets the Cross-section for this wall.
Public property | CurtainGrid | Get the grid object of a curtain wall
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | Flipped | Property to test whether the wall orientation is flipped.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsStackedWall | Identifies if the wall is a stacked wall.
Public property | IsStackedWallMember | Identifies if the wall is a member of a stacked wall.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | Orientation | The outward-facing normal vector of the exterior side face at the starting point of the wall.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SketchId | Returns id of the profile sketch, or invalidElementId if sketch does not exist.
Public property | StackedWallOwnerId | Gets the stacked wall which contains this stacked wall member.
Public property | StructuralUsage | Retrieves or changes the wall's designated structural usage.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WallType | Retrieves or changes the type of the wall.
Public property | Width | Get the overall thickness of the wall.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

Wall Class


Wall.CrossSection Property

WallCrossSection Property

Gets or sets the Cross-section for this wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WallCrossSection CrossSection { get; set; }
Public Property CrossSection As WallCrossSection
    Get
    Set
public:
property WallCrossSection CrossSection {
    WallCrossSection get ();
    void set (WallCrossSection value);
}
member CrossSection : WallCrossSection with get, set

Property Value

WallCrossSection
Exceptions
Exception | Condition
ArgumentException | When setting this property: The current wall does not support the cross section wallCrossSection.
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
This value determines whether the wall is vertical, slanted or tapered. See also: WallCrossSection. Setting the value to "SingleSlanted" or "Tapered" will enable other parameters to control the slanted angle(s) for a slanted or a tapered wall.
See Also

Reference

Wall Class


Wall.CurtainGrid Property

WallCurtainGrid Property

Get the grid object of a curtain wall

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CurtainGrid CurtainGrid { get; }
Public ReadOnly Property CurtainGrid As CurtainGrid
    Get
public:
property CurtainGrid^ CurtainGrid {
    CurtainGrid^ get ();
}
member CurtainGrid : CurtainGrid with get

Property Value

CurtainGrid
Remarks
This property is readonly.
See Also

Reference

Wall Class


Wall.Flipped Property

WallFlipped Property

Property to test whether the wall orientation is flipped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Flipped { get; }
Public ReadOnly Property Flipped As Boolean
    Get
public:
property bool Flipped {
    bool get ();
}
member Flipped : bool with get

Property Value

Boolean
See Also

Reference

Wall Class


Wall.IsStackedWall Property

WallIsStackedWall Property

Identifies if the wall is a stacked wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsStackedWall { get; }
Public ReadOnly Property IsStackedWall As Boolean
    Get
public:
property bool IsStackedWall {
    bool get ();
}
member IsStackedWall : bool with get

Property Value

Boolean
See Also

Reference

Wall Class


Wall.IsStackedWallMember Property

WallIsStackedWallMember Property

Identifies if the wall is a member of a stacked wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsStackedWallMember { get; }
Public ReadOnly Property IsStackedWallMember As Boolean
    Get
public:
property bool IsStackedWallMember {
    bool get ();
}
member IsStackedWallMember : bool with get

Property Value

Boolean
See Also

Reference

Wall Class


Wall.Orientation Property

WallOrientation Property

The outward-facing normal vector of the exterior side face at the starting point of the wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Orientation { get; }
Public ReadOnly Property Orientation As XYZ
    Get
public:
property XYZ^ Orientation {
    XYZ^ get ();
}
member Orientation : XYZ with get

Property Value

XYZ
Remarks
For curtain walls and stacked walls, the wall itself doesn't have exterior and interior side faces. Therefore, in both cases, the wall's orientation is not changed when it is flipped. However, flipping curtain walls or stacked walls will change the orientations of their sub-walls. In the case of curtain walls, sub-walls are present when a curtain panel type is changed to a wall.
See Also

Reference

Wall Class


Wall.SketchId Property

WallSketchId Property

Returns id of the profile sketch, or invalidElementId if sketch does not exist.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId SketchId { get; }
Public ReadOnly Property SketchId As ElementId
    Get
public:
property ElementId^ SketchId {
    ElementId^ get ();
}
member SketchId : ElementId with get

Property Value

ElementId
Remarks
To create profile Sketch for the Wall, call CreateProfileSketch.
See Also

Reference

Wall Class


Wall.StackedWallOwnerId Property

WallStackedWallOwnerId Property

Gets the stacked wall which contains this stacked wall member.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId StackedWallOwnerId { get; }
Public ReadOnly Property StackedWallOwnerId As ElementId
    Get
public:
property ElementId^ StackedWallOwnerId {
    ElementId^ get ();
}
member StackedWallOwnerId : ElementId with get

Property Value

ElementId
See Also

Reference

Wall Class


Wall.StructuralUsage Property

WallStructuralUsage Property

Retrieves or changes the wall's designated structural usage.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public StructuralWallUsage StructuralUsage { get; set; }
Public Property StructuralUsage As StructuralWallUsage
    Get
    Set
public:
property StructuralWallUsage StructuralUsage {
    StructuralWallUsage get ();
    void set (StructuralWallUsage value);
}
member StructuralUsage : StructuralWallUsage with get, set

Property Value

StructuralWallUsage
The wall's designated structural usage, such as bearing or non bearing.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The enum value is not invalid for StructuralWallUsage. -or- When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

Wall Class


Wall.WallType Property

WallWallType Property

Retrieves or changes the type of the wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WallType WallType { get; set; }
Public Property WallType As WallType
    Get
    Set
public:
property WallType^ WallType {
    WallType^ get ();
    void set (WallType^ value);
}
member WallType : WallType with get, set

Property Value

WallType
The type of the wall.
Exceptions
Exception | Condition
ArgumentException | When setting this property: The wall type wallType is not valid for the current wall.
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
The WallType property can be used to retrieve the kind of the wall. This property can also be used to change the type of a wall by setting it to a different wall type. All the wall types in the project can be found using the Document.WallTypes property.
See Also

Reference

Wall Class


Wall.Width Property

WallWidth Property

Get the overall thickness of the wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Width { get; }
Public ReadOnly Property Width As Double
    Get
public:
property double Width {
    double get ();
}
member Width : float with get

Property Value

Double
See Also

Reference

Wall Class


Wall Methods

The Wall type exposes the following members.

Methods
 | Name | Description
Public method | AllowWrappingAtLocation | Allow end wrapping at the location.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveProfileSketch | Checks whether this wall has or can have a profile sketch.
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create(Document, IListCurve, Boolean) | Creates a non rectangular profile wall within the project using the default wall type.
 | Create(Document, Curve, ElementId, Boolean) | Creates a new rectangular profile wall within the project using the default wall style.
 | Create(Document, IListCurve, ElementId, ElementId, Boolean) | Creates a non rectangular profile wall within the project using the specified wall type.
 | Create(Document, IListCurve, ElementId, ElementId, Boolean, XYZ) | Creates a non rectangular profile wall within the project using the specified wall type and normal vector.
 | Create(Document, Curve, ElementId, ElementId, Double, Double, Boolean, Boolean) | Creates a new rectangular profile wall within the project using the specified wall type, height, and offset.
Public method | CreateProfileSketch | Creates a new Wall profile Sketch.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | DisallowWrappingAtLocation | Disallow end wrapping at the location.
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject)
Public method | Flip | The wall orientation will be flipped.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetStackedWallMemberIds | Get the sub walls which belongs to the wall.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetValidWrappingLocationIndices | Gets all valid locations for end wrapping.
Public method | GetWrappingLocationAsCurveParameter | Gets the non-normalized (actual) curve parameter of the location.
Public method | GetWrappingLocationAsReferences | Gets an array of references to faces at the location.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | IsWallCrossSectionValid | Checks whether the desired cross section is valid for the current wall.
Public method | IsWrappingAtLocationAllowed | If end wrapping is allowed at the location.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveProfileSketch | Reverts an edited wall to its original shape.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Wall Class


Wall.AllowWrappingAtLocation Method

WallAllowWrappingAtLocation Method

Allow end wrapping at the location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AllowWrappingAtLocation(
    int locationIndex
)
Public Sub AllowWrappingAtLocation (
    locationIndex As Integer
)
public:
void AllowWrappingAtLocation(
    int locationIndex
)
member AllowWrappingAtLocation :
        locationIndex : int -> unit

Parameters

locationIndex Int32
0 or 1 represents wall's end, other number represents the wrapping locations on vertical faces of openings or profiles.
Exceptions
Exception | Condition
ArgumentException | This location is invalid for wrapping.
InvalidOperationException | End wrapping is disabled in wall type.
Remarks
If Wrapping At Ends in wall type is set to none, this function throws InvalidOperationException If the location is invalid, for example: wall doesn't have this location or the location is joined, this function throws ArgumentException.
See Also

Reference

Wall Class


Wall.CanHaveProfileSketch Method

WallCanHaveProfileSketch Method

Checks whether this wall has or can have a profile sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanHaveProfileSketch()
Public Function CanHaveProfileSketch As Boolean
public:
bool CanHaveProfileSketch()
member CanHaveProfileSketch : unit -> bool

Return Value

Boolean
True if wall supports profile sketch, false otherwise.
Remarks
Wall does not support profile if it is not a straight wall; or wall is tapered; or it is an old curtain wall; or it is an infill wall; or it is a replacement curtain panel.
See Also

Reference

Wall Class


Wall.Create Method

WallCreate Method

Overload List
Name | Description
Create(Document, IListCurve, Boolean) | Creates a non rectangular profile wall within the project using the default wall type.
Create(Document, Curve, ElementId, Boolean) | Creates a new rectangular profile wall within the project using the default wall style.
Create(Document, IListCurve, ElementId, ElementId, Boolean) | Creates a non rectangular profile wall within the project using the specified wall type.
Create(Document, IListCurve, ElementId, ElementId, Boolean, XYZ) | Creates a non rectangular profile wall within the project using the specified wall type and normal vector.
Create(Document, Curve, ElementId, ElementId, Double, Double, Boolean, Boolean) | Creates a new rectangular profile wall within the project using the specified wall type, height, and offset.
Top
See Also

Reference

Wall Class


Wall.Create(Document, IList<Curve>, Boolean) Method

WallCreate(Document, IListCurve, Boolean) Method

Creates a non rectangular profile wall within the project using the default wall type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Wall Create(
    Document document,
    IList<Curve> profile,
    bool structural
)
Public Shared Function Create (
    document As Document,
    profile As IList(Of Curve),
    structural As Boolean
) As Wall
public:
static Wall^ Create(
    Document^ document,
    IList<Curve^>^ profile,
    bool structural
)
static member Create :
        document : Document *
        profile : IList<Curve> *
        structural : bool -> Wall

Parameters

document Document
The document in which the new wall is created.
profile IList Curve
An array of planar curves that represent the vertical profile of the wall.
structural Boolean
If set, specifies that the wall is structural in nature.

Return Value

Wall
If successful a new wall object within the project.
Exceptions
Exception | Condition
ArgumentException | The input profile contains at least one helical curve and is not supported for this operation.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Failed to create the wall.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
See Also

Reference

Wall Class
Create Overload


Wall.Create(Document, Curve, ElementId, Boolean) Method

WallCreate(Document, Curve, ElementId, Boolean) Method

Creates a new rectangular profile wall within the project using the default wall style.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Wall Create(
    Document document,
    Curve curve,
    ElementId levelId,
    bool structural
)
Public Shared Function Create (
    document As Document,
    curve As Curve,
    levelId As ElementId,
    structural As Boolean
) As Wall
public:
static Wall^ Create(
    Document^ document,
    Curve^ curve,
    ElementId^ levelId,
    bool structural
)
static member Create :
        document : Document *
        curve : Curve *
        levelId : ElementId *
        structural : bool -> Wall

Parameters

document Document
The document in which the new wall is created.
curve Curve
A curve representing the base line of the wall.
levelId ElementId
Id of the level on which the wall is to be placed.
structural Boolean
If set, specifies that the wall is structural in nature.

Return Value

Wall
If successful a new wall object within the project.
Exceptions
Exception | Condition
ArgumentException | The curve argument is not valid for wall creation.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Example
C#
VB
C++
F#
Copy
public Wall CreateWallUsingCurve1(Autodesk.Revit.DB.Document document, Level level)
{
    // Build a location line for the wall creation
    XYZ start = new XYZ(0, 0, 0);
    XYZ end = new XYZ(10, 10, 0);
    Line geomLine = Line.CreateBound(start, end);

    // Create a wall using the location line
    return Wall.Create(document, geomLine, level.Id, true);
}
Public Function CreateWallUsingCurve1(document As Autodesk.Revit.DB.Document, level As Level) As Wall
    ' Build a location line for the wall creation
    Dim start As New XYZ(0, 0, 0)
    Dim [end] As New XYZ(10, 10, 0)
    Dim geomLine As Line = Line.CreateBound(start, [end])

    ' Create a wall using the location line
    Return Wall.Create(document, geomLine, level.Id, True)
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Wall Class
Create Overload


Wall.Create(Document, IList<Curve>, ElementId, ElementId, Boolean) Method

WallCreate(Document, IListCurve, ElementId, ElementId, Boolean) Method

Creates a non rectangular profile wall within the project using the specified wall type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Wall Create(
    Document document,
    IList<Curve> profile,
    ElementId wallTypeId,
    ElementId levelId,
    bool structural
)
Public Shared Function Create (
    document As Document,
    profile As IList(Of Curve),
    wallTypeId As ElementId,
    levelId As ElementId,
    structural As Boolean
) As Wall
public:
static Wall^ Create(
    Document^ document,
    IList<Curve^>^ profile,
    ElementId^ wallTypeId,
    ElementId^ levelId,
    bool structural
)
static member Create :
        document : Document *
        profile : IList<Curve> *
        wallTypeId : ElementId *
        levelId : ElementId *
        structural : bool -> Wall

Parameters

document Document
The document in which the new wall is created.
profile IList Curve
An array of planar curves that represent the vertical profile of the wall.
wallTypeId ElementId
Id of the wall type to be used by the new wall instead of the default type.
levelId ElementId
Id of the level on which the wall is to be placed.
structural Boolean
If set, specifies that the wall is structural in nature.

Return Value

Wall
If successful a new wall object within the project.
Exceptions
Exception | Condition
ArgumentException | The input profile contains at least one helical curve and is not supported for this operation.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Failed to create the wall.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
See Also

Reference

Wall Class
Create Overload


Wall.Create(Document, IList<Curve>, ElementId, ElementId, Boolean, XYZ) Method

WallCreate(Document, IListCurve, ElementId, ElementId, Boolean, XYZ) Method

Creates a non rectangular profile wall within the project using the specified wall type and normal vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Wall Create(
    Document document,
    IList<Curve> profile,
    ElementId wallTypeId,
    ElementId levelId,
    bool structural,
    XYZ normal
)
Public Shared Function Create (
    document As Document,
    profile As IList(Of Curve),
    wallTypeId As ElementId,
    levelId As ElementId,
    structural As Boolean,
    normal As XYZ
) As Wall
public:
static Wall^ Create(
    Document^ document,
    IList<Curve^>^ profile,
    ElementId^ wallTypeId,
    ElementId^ levelId,
    bool structural,
    XYZ^ normal
)
static member Create :
        document : Document *
        profile : IList<Curve> *
        wallTypeId : ElementId *
        levelId : ElementId *
        structural : bool *
        normal : XYZ -> Wall

Parameters

document Document
The document in which the new wall is created.
profile IList Curve
An array of planar curves that represent the vertical profile of the wall.
wallTypeId ElementId
Id of the wall type to be used by the new wall instead of the default type.
levelId ElementId
Id of the level on which the wall is to be placed.
structural Boolean
If set, specifies that the wall is structural in nature.
normal XYZ
A vector that must be perpendicular to the profile which dictates which side of the wall is considered to be inside and outside.

Return Value

Wall
If successful a new wall object within the project.
Exceptions
Exception | Condition
ArgumentException | The input profile contains at least one helical curve and is not supported for this operation.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Failed to create the wall.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Example
C#
VB
C++
F#
Copy
public Wall CreateWallUsingProfile(Autodesk.Revit.DB.Document document, Level level, WallType wallType)
{
    // Build a wall profile for the wall creation
    XYZ first = new XYZ(0, 0, 0);
    XYZ second = new XYZ(20, 0, 0);
    XYZ third = new XYZ(20, 0, 15);
    XYZ fourth = new XYZ(0, 0, 15);
    IList<Curve> profile = new List<Curve>();

    // Get application creation object
    Autodesk.Revit.Creation.Application appCreation = document.Application.Create;

    profile.Add(Line.CreateBound(first, second));
    profile.Add(Line.CreateBound(second, third));
    profile.Add(Line.CreateBound(third, fourth));
    profile.Add(Line.CreateBound(fourth, first));

    XYZ normal = new XYZ(0, 1, 0);

    // Create a wall
    return Wall.Create(document, profile, wallType.Id, level.Id, true, normal);
}
Public Function CreateWallUsingProfile(document As Autodesk.Revit.DB.Document, level As Level, wallType As WallType) As Wall
    ' Build a wall profile for the wall creation
    Dim first As New XYZ(0, 0, 0)
    Dim second As New XYZ(20, 0, 0)
    Dim third As New XYZ(20, 0, 15)
    Dim fourth As New XYZ(0, 0, 15)
    Dim profile As IList(Of Curve) = New List(Of Curve)()

    ' Get application creation object
    Dim appCreation As Autodesk.Revit.Creation.Application = document.Application.Create

    profile.Add(Line.CreateBound(first, second))
    profile.Add(Line.CreateBound(second, third))
    profile.Add(Line.CreateBound(third, fourth))
    profile.Add(Line.CreateBound(fourth, first))

    Dim normal As New XYZ(0, 1, 0)

    ' Create a wall
    Return Wall.Create(document, profile, wallType.Id, level.Id, True, normal)
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Wall Class
Create Overload


Wall.Create(Document, Curve, ElementId, ElementId, Double, Double, Boolean, Boolean) Method

WallCreate(Document, Curve, ElementId, ElementId, Double, Double, Boolean, Boolean) Method

Creates a new rectangular profile wall within the project using the specified wall type, height, and offset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Wall Create(
    Document document,
    Curve curve,
    ElementId wallTypeId,
    ElementId levelId,
    double height,
    double offset,
    bool flip,
    bool structural
)
Public Shared Function Create (
    document As Document,
    curve As Curve,
    wallTypeId As ElementId,
    levelId As ElementId,
    height As Double,
    offset As Double,
    flip As Boolean,
    structural As Boolean
) As Wall
public:
static Wall^ Create(
    Document^ document,
    Curve^ curve,
    ElementId^ wallTypeId,
    ElementId^ levelId,
    double height,
    double offset,
    bool flip,
    bool structural
)
static member Create :
        document : Document *
        curve : Curve *
        wallTypeId : ElementId *
        levelId : ElementId *
        height : float *
        offset : float *
        flip : bool *
        structural : bool -> Wall

Parameters

document Document
The document in which the new wall is created.
curve Curve
A curve representing the base line of the wall.
wallTypeId ElementId
Id of the wall type to be used by the new wall instead of the default type.
levelId ElementId
Id of the level on which the wall is to be placed.
height Double
The height of the wall other than the default height.
offset Double
Modifies the wall's Base Offset parameter to determine its vertical placement.
flip Boolean
Change which side of the wall is considered to be the inside and outside of the wall.
structural Boolean
If set, specifies that the wall is structural in nature.

Return Value

Wall
If successful a new wall object within the project.
Exceptions
Exception | Condition
ArgumentException | The curve argument is not valid for wall creation.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | The given value for height must be greater than 0 and no more than 30000 feet. -or- The given value for offset must be no more than 30000 feet in absolute value.
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Example
C#
VB
C++
F#
Copy
public Wall CreateWallUsingCurve2(Autodesk.Revit.DB.Document document, Level level, WallType wallType)
{
    // Build a location line for the wall creation
    XYZ start = new XYZ(0, 0, 0);
    XYZ end = new XYZ(10, 10, 0);
    Line geomLine = Line.CreateBound(start, end);

    // Determine the other parameters
    double height = 15;
    double offset = 3;

    // Create a wall using the location line and wall type
    return Wall.Create(document, geomLine, wallType.Id, level.Id, height, offset, true, true);
}
Public Function CreateWallUsingCurve2(document As Autodesk.Revit.DB.Document, level As Level, wallType As WallType) As Wall
    ' Build a location line for the wall creation
    Dim start As New XYZ(0, 0, 0)
    Dim [end] As New XYZ(10, 10, 0)
    Dim geomLine As Line = Line.CreateBound(start, [end])

    ' Determine the other parameters
    Dim height As Double = 15
    Dim offset As Double = 3

    ' Create a wall using the location line and wall type
    Return Wall.Create(document, geomLine, wallType.Id, level.Id, height, offset, _
        True, True)
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Wall Class
Create Overload


Wall.CreateProfileSketch Method

WallCreateProfileSketch Method

Creates a new Wall profile Sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Sketch CreateProfileSketch()
Public Function CreateProfileSketch As Sketch
public:
Sketch^ CreateProfileSketch()
member CreateProfileSketch : unit -> Sketch

Return Value

Sketch
Created profile Sketch of the Wall.
Exceptions
Exception | Condition
InvalidOperationException | Wall does not support profile Sketch as it is not a straight wall; or is tapered; or it is an old curtain wall; or it is an infill wall; or it is a replacement curtain panel. -or- Wall already has a sketch.
Remarks
The loop of the sketch cannot be obtained until regeneration. To regenerate the document use Regenerate. To edit the Wall profile use [!:Autodesk::Revit::DB::SketchEditScope].
See Also

Reference

Wall Class


Wall.DisallowWrappingAtLocation Method

WallDisallowWrappingAtLocation Method

Disallow end wrapping at the location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void DisallowWrappingAtLocation(
    int locationIndex
)
Public Sub DisallowWrappingAtLocation (
    locationIndex As Integer
)
public:
void DisallowWrappingAtLocation(
    int locationIndex
)
member DisallowWrappingAtLocation :
        locationIndex : int -> unit

Parameters

locationIndex Int32
0 or 1 represents wall's end, other number represents the wrapping locations on vertical faces of openings or profiles.
Exceptions
Exception | Condition
ArgumentException | This location is invalid for wrapping.
Remarks
If Wrapping At Ends in wall type is set to none, this function does nothing. If the location is invalid, for example: wall doesn't have this location or the location is joined, this function throws ArgumentException.
See Also

Reference

Wall Class


Wall.Flip Method

WallFlip Method

The wall orientation will be flipped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Flip()
Public Sub Flip
public:
void Flip()
member Flip : unit -> unit
Remarks
For curtain walls and stacked walls, flip won't change the wall orientation. [!:Autodesk::Revit::DB::Wall.Orientation].
See Also

Reference

Wall Class


Wall.GetStackedWallMemberIds Method

WallGetStackedWallMemberIds Method

Get the sub walls which belongs to the wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ElementId> GetStackedWallMemberIds()
Public Function GetStackedWallMemberIds As IList(Of ElementId)
public:
IList<ElementId^>^ GetStackedWallMemberIds()
member GetStackedWallMemberIds : unit -> IList<ElementId>

Return Value

IList ElementId
If the wall is a stacked wall, the Ids of the sub will be returned in bottom-top order.
Exceptions
Exception | Condition
InvalidOperationException | This wall isn't a consistent stacked wall.
See Also

Reference

Wall Class


Wall.GetValidWrappingLocationIndices Method

WallGetValidWrappingLocationIndices Method

Gets all valid locations for end wrapping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<int> GetValidWrappingLocationIndices()
Public Function GetValidWrappingLocationIndices As IList(Of Integer)
public:
IList<int>^ GetValidWrappingLocationIndices()
member GetValidWrappingLocationIndices : unit -> IList<int>

Return Value

IList Int32
The list of valid wrapping locations.
Remarks
All valid wrapping locations include wall's two ends and locations on vertical faces of openings or profiles without join.
See Also

Reference

Wall Class


Wall.GetWrappingLocationAsCurveParameter Method

WallGetWrappingLocationAsCurveParameter Method

Gets the non-normalized (actual) curve parameter of the location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetWrappingLocationAsCurveParameter(
    int locationIndex
)
Public Function GetWrappingLocationAsCurveParameter (
    locationIndex As Integer
) As Double
public:
double GetWrappingLocationAsCurveParameter(
    int locationIndex
)
member GetWrappingLocationAsCurveParameter :
        locationIndex : int -> float

Parameters

locationIndex Int32
0 or 1 represents wall's end, other number represents the wrapping locations on vertical faces of openings or profiles.

Return Value

Double
The non-normalized (actual) curve parameter value on the curve.
Exceptions
Exception | Condition
ArgumentException | This location is invalid for wrapping.
Remarks
If the location is invalid, for example: wall doesn't have this location or the location is joined, this function throws ArgumentException.
See Also

Reference

Wall Class


Wall.GetWrappingLocationAsReferences Method

WallGetWrappingLocationAsReferences Method

Gets an array of references to faces at the location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<Reference> GetWrappingLocationAsReferences(
    int locationIndex
)
Public Function GetWrappingLocationAsReferences (
    locationIndex As Integer
) As IList(Of Reference)
public:
IList<Reference^>^ GetWrappingLocationAsReferences(
    int locationIndex
)
member GetWrappingLocationAsReferences :
        locationIndex : int -> IList<Reference>

Parameters

locationIndex Int32
0 or 1 represents wall's end, other number represents the wrapping locations on vertical faces of openings or profiles.

Return Value

IList Reference
All faces' references at the location.
Exceptions
Exception | Condition
ArgumentException | This location is invalid for wrapping.
Remarks
If the location is invalid, for example: wall doesn't have this location or the location is joined, this function throws ArgumentException. This function may return not only one face, for example: after editing profile, some aligned vertical faces have same location on curve.
See Also

Reference

Wall Class


Wall.IsWallCrossSectionValid Method

WallIsWallCrossSectionValid Method

Checks whether the desired cross section is valid for the current wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsWallCrossSectionValid(
    WallCrossSection wallCrossSection
)
Public Function IsWallCrossSectionValid (
    wallCrossSection As WallCrossSection
) As Boolean
public:
bool IsWallCrossSectionValid(
    WallCrossSection wallCrossSection
)
member IsWallCrossSectionValid :
        wallCrossSection : WallCrossSection -> bool

Parameters

wallCrossSection WallCrossSection
The desired cross section.

Return Value

Boolean
True if the wall can be set to the desired cross section.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

Wall Class


Wall.IsWrappingAtLocationAllowed Method

WallIsWrappingAtLocationAllowed Method

If end wrapping is allowed at the location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsWrappingAtLocationAllowed(
    int locationIndex
)
Public Function IsWrappingAtLocationAllowed (
    locationIndex As Integer
) As Boolean
public:
bool IsWrappingAtLocationAllowed(
    int locationIndex
)
member IsWrappingAtLocationAllowed :
        locationIndex : int -> bool

Parameters

locationIndex Int32
0 or 1 represents wall's end, other number represents the wrapping locations on vertical faces of openings or profiles.

Return Value

Boolean
true if it is allowed, false if it is disallowed.
Remarks
If Wrapping At Ends in wall type is set to none, this function returns false If the location is invalid, for example: wall doesn't have this location or the location is joined, this function returns false else check if that location is allowed.
See Also

Reference

Wall Class


Wall.RemoveProfileSketch Method

WallRemoveProfileSketch Method

Reverts an edited wall to its original shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveProfileSketch()
Public Sub RemoveProfileSketch
public:
void RemoveProfileSketch()
member RemoveProfileSketch : unit -> unit
Remarks
The wall profile is changed back to its original rectangular profile. All profile changes made in the sketch mode are discarded. To check if wall sketch can be removed call SketchId.
See Also

Reference

Wall Class


WallCrossSection Enumeration

The allowed values for the WALL_CROSS_SECTION parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum WallCrossSection
Public Enumeration WallCrossSection
public enum class WallCrossSection
type WallCrossSection
Members
Member name | Value | Description
SingleSlanted | 0 | A single-slanted wall whose angle is controlled by the parameter WALL_SINGLE_SLANT_ANGLE_FROM_VERTICAL.
Vertical | 1 | A vertical wall, 0 degrees.
Tapered | 2 | A tapered wall whose angle is controlled by the parameters WALL_TAPERED_EXTERIOR_INWARD_ANGLE and WALL_TAPERED_INTERIOR_INWARD_ANGLE.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


WallFoundation Class

An object that represents a wall foundation element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBHostObject
Autodesk.Revit.DBWallFoundation

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class WallFoundation : HostObject
Public Class WallFoundation
    Inherits HostObject
public ref class WallFoundation : public HostObject
type WallFoundation =
    class
        inherit HostObject
    end

The WallFoundation type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WallId | Returns the id of the host wall.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new wall foundation within the project.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Example
C#
VB
C++
F#
Copy
public void GetInfo_WallFoundation(WallFoundation wallFoundation)
{
    string message = "Wall Foundation : ";
    // Get Footing type name
    Document doc = wallFoundation.Document;
    message += "\nFoundation type name is : " + doc.GetElement(wallFoundation.GetTypeId()).Name;

    TaskDialog.Show("Revit",message);
}
Public Sub GetInfo_WallFoundation(wallFoundation As WallFoundation)
   Dim message As String = "Wall Foundation : "
   ' Get Footing type name
   Dim doc As Document = wallFoundation.Document
   message += vbLf & "Foundation type name is : " & Convert.ToString(doc.GetElement(wallFoundation.GetTypeId()).Name)

   TaskDialog.Show("Revit", message)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


WallFoundation Properties

The WallFoundation type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WallId | Returns the id of the host wall.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

WallFoundation Class


WallFoundation.WallId Property

WallFoundationWallId Property

Returns the id of the host wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId WallId { get; }
Public ReadOnly Property WallId As ElementId
    Get
public:
property ElementId^ WallId {
    ElementId^ get ();
}
member WallId : ElementId with get

Property Value

ElementId
See Also

Reference

WallFoundation Class


WallFoundation Methods

The WallFoundation type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new wall foundation within the project.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

WallFoundation Class


WallFoundation.Create Method

WallFoundationCreate Method

Creates a new wall foundation within the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static WallFoundation Create(
    Document document,
    ElementId typeId,
    ElementId wallId
)
Public Shared Function Create (
    document As Document,
    typeId As ElementId,
    wallId As ElementId
) As WallFoundation
public:
static WallFoundation^ Create(
    Document^ document,
    ElementId^ typeId,
    ElementId^ wallId
)
static member Create :
        document : Document *
        typeId : ElementId *
        wallId : ElementId -> WallFoundation

Parameters

document Document
The document.
typeId ElementId
The id of the wall foundation type of the newly created wall foundation.
wallId ElementId
The id of the host wall of the newly created wall foundation.

Return Value

WallFoundation
If successful, returns the newly created wall foundation, otherwise.
Exceptions
Exception | Condition
ArgumentException | typeId is not a valid WallFoundationType id. -or- wallId does not refer to a valid wall.
ArgumentNullException | A non-optional argument was null
See Also

Reference

WallFoundation Class


WallFoundationType Class

An object that represents the type of a wall foundation in Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBHostObjAttributes
Autodesk.Revit.DBWallFoundationType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class WallFoundationType : HostObjAttributes
Public Class WallFoundationType
    Inherits HostObjAttributes
public ref class WallFoundationType : public HostObjAttributes
type WallFoundationType =
    class
        inherit HostObjAttributes
    end

The WallFoundationType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


WallFoundationType Properties

The WallFoundationType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

WallFoundationType Class


WallFoundationType Methods

The WallFoundationType type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

WallFoundationType Class


WallFunction Enumeration

Indicates the function of a specified WallType, as specified in the parameter FUNCTION_PARAM on the WallType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum WallFunction
Public Enumeration WallFunction
public enum class WallFunction
type WallFunction
Members
Member name | Value | Description
Interior | 0 | An interior wall.
Exterior | 1 | An exterior wall.
Foundation | 2 | A foundation wall.
Retaining | 3 | A retaining wall.
Soffit | 4 | A soffit wall.
Coreshaft | 5 | A coreshaft wall.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


WallKind Enumeration

Describes the fundamental type of wall, such as curtain wall or stacked wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum WallKind
Public Enumeration WallKind
public enum class WallKind
type WallKind
Members
Member name | Value | Description
Basic | 0 | A standard wall.
Curtain | 1 | A curtain wall.
Stacked | 2 | A stacked wall of several wall types.
Unknown | -1 | The basic type is not known.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


WallLocationLine Enumeration

This enumerated type represents the options for alignment of a wall's location line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum WallLocationLine
Public Enumeration WallLocationLine
public enum class WallLocationLine
type WallLocationLine
Members
Member name | Value | Description
WallCenterline | 0 | The wall location line is aligned to the center of the wall.
CoreCenterline | 1 | The wall location line is aligned to the center of the core.
FinishFaceExterior | 2 | The wall location line is aligned to the exterior face of the wall.
FinishFaceInterior | 3 | The wall location line is aligned to the interior face of the wall.
CoreExterior | 4 | The wall location line is aligned to the exterior face of the core.
CoreInterior | 5 | The wall location line is aligned to the exterior face of the core.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


WallSide Enumeration

Represents the possible sides of a wall where a sweep or reveal may be attached.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum WallSide
Public Enumeration WallSide
public enum class WallSide
type WallSide
Members
Member name | Value | Description
Exterior | 0 | The exterior of the wall.
Interior | 1 | The interior of the wall.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


WallSweep Class

Represents a wall sweep or reveal.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBHostObject
Autodesk.Revit.DBWallSweep

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class WallSweep : HostObject
Public Class WallSweep
    Inherits HostObject
public ref class WallSweep : public HostObject
type WallSweep =
    class
        inherit HostObject
    end

The WallSweep type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new wall sweep or reveal.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetHostIds | Gets a list of all host walls on which the sweep resides.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetWallSweepInfo | Gets the information of the wall sweep or reveal.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
 | WallAllowsWallSweep | Validates that the wall is of a type that may be a host for a wall sweep or reveal.
Top
Remarks
This element may represent either a standalone sweep or reveal element created by the Revit user interface or API, or a "fixed" wall sweep or reveal that was created by the contents of a wall's compound structure.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


WallSweep Properties

The WallSweep type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

WallSweep Class


WallSweep Methods

The WallSweep type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new wall sweep or reveal.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetHostIds | Gets a list of all host walls on which the sweep resides.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetWallSweepInfo | Gets the information of the wall sweep or reveal.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
 | WallAllowsWallSweep | Validates that the wall is of a type that may be a host for a wall sweep or reveal.
Top
See Also

Reference

WallSweep Class


WallSweep.Create Method

WallSweepCreate Method

Creates a new wall sweep or reveal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static WallSweep Create(
    Wall wall,
    ElementId wallSweepType,
    WallSweepInfo wallSweepInfo
)
Public Shared Function Create (
    wall As Wall,
    wallSweepType As ElementId,
    wallSweepInfo As WallSweepInfo
) As WallSweep
public:
static WallSweep^ Create(
    Wall^ wall,
    ElementId^ wallSweepType,
    WallSweepInfo^ wallSweepInfo
)
static member Create :
        wall : Wall *
        wallSweepType : ElementId *
        wallSweepInfo : WallSweepInfo -> WallSweep

Parameters

wall Wall
The wall upon which to create the new sweep or reveal.
wallSweepType ElementId
The wall sweep or reveal type.
wallSweepInfo WallSweepInfo
The information that describes the new wall sweep or reveal.

Return Value

WallSweep
The new wall sweep.
Exceptions
Exception | Condition
ArgumentException | The wall sweep info represents a fixed wall sweep. Fixed wall sweeps may not be assigned to standalone wall sweep elements. -or- The WallSweepInfo id must be set to -1 for a non-fixed wall sweep. -or- wall may not host a wall sweep or reveal.
ArgumentNullException | A non-optional argument was null
Remarks
The wall sweep's profile and type are taken from the wall sweep type properties. The values set in the WallSweepInfo are ignored.
See Also

Reference

WallSweep Class


WallSweep.GetHostIds Method

WallSweepGetHostIds Method

Gets a list of all host walls on which the sweep resides.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ElementId> GetHostIds()
Public Function GetHostIds As IList(Of ElementId)
public:
IList<ElementId^>^ GetHostIds()
member GetHostIds : unit -> IList<ElementId>

Return Value

IList ElementId
The list of wall ids.
Remarks
Fixed wall sweeps from vertically compound structures will return only one host element.
See Also

Reference

WallSweep Class


WallSweep.GetWallSweepInfo Method

WallSweepGetWallSweepInfo Method

Gets the information of the wall sweep or reveal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WallSweepInfo GetWallSweepInfo()
Public Function GetWallSweepInfo As WallSweepInfo
public:
WallSweepInfo^ GetWallSweepInfo()
member GetWallSweepInfo : unit -> WallSweepInfo

Return Value

WallSweepInfo
The information that describes the wall sweep or reveal.
See Also

Reference

WallSweep Class


WallSweep.WallAllowsWallSweep Method

WallSweepWallAllowsWallSweep Method

Validates that the wall is of a type that may be a host for a wall sweep or reveal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool WallAllowsWallSweep(
    Wall wall
)
Public Shared Function WallAllowsWallSweep (
    wall As Wall
) As Boolean
public:
static bool WallAllowsWallSweep(
    Wall^ wall
)
static member WallAllowsWallSweep :
        wall : Wall -> bool

Parameters

wall Wall
The wall.

Return Value

Boolean
True if the wall may host a wall sweep, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
This function excludes curtain walls and the main wall of a set of stacked walls. The wall must be fully regenerated for this function to work correctly.
See Also

Reference

WallSweep Class


WallSweepInfo Class

Represents a wall sweep or reveal of a vertically compound structure.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBWallSweepInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class WallSweepInfo : IDisposable
Public Class WallSweepInfo
    Implements IDisposable
public ref class WallSweepInfo : IDisposable
type WallSweepInfo =
    class
        interface IDisposable
    end

The WallSweepInfo type exposes the following members.

Constructors
 | Name | Description
Public method | WallSweepInfo(Boolean, WallSweepType) | Constructs a new WallSweepInfo instance.
Public method | WallSweepInfo(WallSweepType, Boolean) | Constructs a new WallSweepInfo instance.
Top
Properties
 | Name | Description
Public property | CutsWall | Indicates if you want the sweep to cut geometry out of the host wall.
Public property | DefaultSetback | The sweep setback distance from inserts, such as windows and doors.
Public property | Distance | Represents the distance from either the top or base of the wall for horizontal sweeps, or the parameter along the wall's path curve for vertical ones.
Public property | DistanceMeasuredFrom | Indicates if Distance is measured from the top or bottom of the wall.
Public property | Id | The id of the sweep or reveal.
Public property | IsCutByInserts | Indicates if the sweep is cut by wall inserts.
Public property | IsFixed | Indicates if the described wall sweep is fixed. A sweep is fixed if it is a part of a vertical compound structure.
Public property | IsProfileFlipped | Indicates if the profile is applied upside-down.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | IsVertical | Indicates whether the sweep or reveal is swept vertically or horizontally.
Public property | MaterialId | The element id of the material used to create the sweep or reveal.
Public property | ProfileId | The element id of the profile family used to create the sweep or reveal.
Public property | WallOffset | The offset from the sweep or reveal to the wall.
Public property | WallSide | The side of the wall to which the sweep or reveal is attached.
Public property | WallSweepOrientation | Indicates how the profile of a horiztonal sweep is oriented with repect to the wall side face.
Public property | WallSweepType | The type (either a wall sweep or a reveal).
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the WallSweepInfo
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqual | Determines if the input object is equivalent to this WallSweepInfo.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


WallSweepInfo Constructor

Overload List
 | Name | Description
Public method | WallSweepInfo(Boolean, WallSweepType) | Constructs a new WallSweepInfo instance.
Public method | WallSweepInfo(WallSweepType, Boolean) | Constructs a new WallSweepInfo instance.
Top
See Also

Reference

WallSweepInfo Class


WallSweepInfo(Boolean, WallSweepType) Constructor

Constructs a new WallSweepInfo instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WallSweepInfo(
    bool fixed,
    WallSweepType type
)
Public Sub New (
    fixed As Boolean,
    type As WallSweepType
)
public:
WallSweepInfo(
    bool fixed,
    WallSweepType type
)
new :
        fixed : bool *
        type : WallSweepType -> WallSweepInfo

Parameters

fixed Boolean
True if the WallSweepInfo should be fixed (suitable for use in CompoundStructure.AddWallSweep()). False if the WallSweepInfo should be suitable for use in standalone wall sweep or reveal elements.
type WallSweepType
The type of the WallSweepInfo instance.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

WallSweepInfo Class
WallSweepInfo Overload


WallSweepInfo(WallSweepType, Boolean) Constructor

Constructs a new WallSweepInfo instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WallSweepInfo(
    WallSweepType type,
    bool vertical
)
Public Sub New (
    type As WallSweepType,
    vertical As Boolean
)
public:
WallSweepInfo(
    WallSweepType type,
    bool vertical
)
new :
        type : WallSweepType *
        vertical : bool -> WallSweepInfo

Parameters

type WallSweepType
The type of the WallSweepInfo instance.
vertical Boolean
True to construct a vertical wall sweep, false otherwise.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

WallSweepInfo Class
WallSweepInfo Overload


WallSweepInfo Properties

The WallSweepInfo type exposes the following members.

Properties
 | Name | Description
Public property | CutsWall | Indicates if you want the sweep to cut geometry out of the host wall.
Public property | DefaultSetback | The sweep setback distance from inserts, such as windows and doors.
Public property | Distance | Represents the distance from either the top or base of the wall for horizontal sweeps, or the parameter along the wall's path curve for vertical ones.
Public property | DistanceMeasuredFrom | Indicates if Distance is measured from the top or bottom of the wall.
Public property | Id | The id of the sweep or reveal.
Public property | IsCutByInserts | Indicates if the sweep is cut by wall inserts.
Public property | IsFixed | Indicates if the described wall sweep is fixed. A sweep is fixed if it is a part of a vertical compound structure.
Public property | IsProfileFlipped | Indicates if the profile is applied upside-down.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | IsVertical | Indicates whether the sweep or reveal is swept vertically or horizontally.
Public property | MaterialId | The element id of the material used to create the sweep or reveal.
Public property | ProfileId | The element id of the profile family used to create the sweep or reveal.
Public property | WallOffset | The offset from the sweep or reveal to the wall.
Public property | WallSide | The side of the wall to which the sweep or reveal is attached.
Public property | WallSweepOrientation | Indicates how the profile of a horiztonal sweep is oriented with repect to the wall side face.
Public property | WallSweepType | The type (either a wall sweep or a reveal).
Top
See Also

Reference

WallSweepInfo Class


WallSweepInfo.CutsWall Property

WallSweepInfoCutsWall Property

Indicates if you want the sweep to cut geometry out of the host wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CutsWall { get; set; }
Public Property CutsWall As Boolean
    Get
    Set
public:
property bool CutsWall {
    bool get ();
    void set (bool value);
}
member CutsWall : bool with get, set

Property Value

Boolean
Remarks
When a sweep is offset and embedded in the wall, it cuts the geometry from the wall.
See Also

Reference

WallSweepInfo Class


WallSweepInfo.DefaultSetback Property

WallSweepInfoDefaultSetback Property

The sweep setback distance from inserts, such as windows and doors.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double DefaultSetback { get; set; }
Public Property DefaultSetback As Double
    Get
    Set
public:
property double DefaultSetback {
    double get ();
    void set (double value);
}
member DefaultSetback : float with get, set

Property Value

Double
See Also

Reference

WallSweepInfo Class


WallSweepInfo.Distance Property

WallSweepInfoDistance Property

Represents the distance from either the top or base of the wall for horizontal sweeps, or the parameter along the wall's path curve for vertical ones.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Distance { get; set; }
Public Property Distance As Double
    Get
    Set
public:
property double Distance {
    double get ();
    void set (double value);
}
member Distance : float with get, set

Property Value

Double
DistanceMeasuredFrom determines where the measurement starts from, depending on the orientation of the sweep. If the sweep or reveal is vertical, this distance is equal to the parameter along the wall's path curve.
See Also

Reference

WallSweepInfo Class


WallSweepInfo.DistanceMeasuredFrom Property

WallSweepInfoDistanceMeasuredFrom Property

Indicates if Distance is measured from the top or bottom of the wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DistanceMeasuredFrom DistanceMeasuredFrom { get; set; }
Public Property DistanceMeasuredFrom As DistanceMeasuredFrom
    Get
    Set
public:
property DistanceMeasuredFrom DistanceMeasuredFrom {
    DistanceMeasuredFrom get ();
    void set (DistanceMeasuredFrom value);
}
member DistanceMeasuredFrom : DistanceMeasuredFrom with get, set

Property Value

DistanceMeasuredFrom
If the sweep or reveal is vertical, DistanceMeasuredFrom.Base represents the start of the wall's location curve (t=0). DistanceMeasuredFrom.Top is currently not implemented for vertical sweeps and shouldn't be used when creating them.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

WallSweepInfo Class


WallSweepInfo.Id Property

WallSweepInfoId Property

The id of the sweep or reveal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Id { get; set; }
Public Property Id As Integer
    Get
    Set
public:
property int Id {
    int get ();
    void set (int value);
}
member Id : int with get, set

Property Value

Int32
If the wall sweep belongs to a vertically compound structure, this must be a non-negative value. If the wall sweep belongs to a sweep defined outside of compound structures by UI or API the id will typically be -1 and is not used.
See Also

Reference

WallSweepInfo Class


WallSweepInfo.IsCutByInserts Property

WallSweepInfoIsCutByInserts Property

Indicates if the sweep is cut by wall inserts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCutByInserts { get; set; }
Public Property IsCutByInserts As Boolean
    Get
    Set
public:
property bool IsCutByInserts {
    bool get ();
    void set (bool value);
}
member IsCutByInserts : bool with get, set

Property Value

Boolean
True if the sweep is cut by wall inserts, false otherwise.
See Also

Reference

WallSweepInfo Class


WallSweepInfo.IsFixed Property

WallSweepInfoIsFixed Property

Indicates if the described wall sweep is fixed. A sweep is fixed if it is a part of a vertical compound structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsFixed { get; }
Public ReadOnly Property IsFixed As Boolean
    Get
public:
property bool IsFixed {
    bool get ();
}
member IsFixed : bool with get

Property Value

Boolean
Remarks
Wall sweeps from the definition of a vertical compound structure are fixed based on the wall type's definition. They are not permitted to be moved by users. Other wall sweeps defined outside of CompoundStructure by UI or API are permitted to be moved.
See Also

Reference

WallSweepInfo Class


WallSweepInfo.IsProfileFlipped Property

WallSweepInfoIsProfileFlipped Property

Indicates if the profile is applied upside-down.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsProfileFlipped { get; set; }
Public Property IsProfileFlipped As Boolean
    Get
    Set
public:
property bool IsProfileFlipped {
    bool get ();
    void set (bool value);
}
member IsProfileFlipped : bool with get, set

Property Value

Boolean
True if the profile is applied upside-down, false otherwise.
See Also

Reference

WallSweepInfo Class


WallSweepInfo.IsValidObject Property

WallSweepInfoIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

WallSweepInfo Class


WallSweepInfo.IsVertical Property

WallSweepInfoIsVertical Property

Indicates whether the sweep or reveal is swept vertically or horizontally.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsVertical { get; }
Public ReadOnly Property IsVertical As Boolean
    Get
public:
property bool IsVertical {
    bool get ();
}
member IsVertical : bool with get

Property Value

Boolean
Remarks
Wall sweeps defined as a part of a vertical compound structure will always be horizontal.
See Also

Reference

WallSweepInfo Class


WallSweepInfo.MaterialId Property

WallSweepInfoMaterialId Property

The element id of the material used to create the sweep or reveal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId MaterialId { get; set; }
Public Property MaterialId As ElementId
    Get
    Set
public:
property ElementId^ MaterialId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member MaterialId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
This value is not used when creating standalone wall sweeps. The material id of the wall sweep's type is used instead.
See Also

Reference

WallSweepInfo Class


WallSweepInfo.ProfileId Property

WallSweepInfoProfileId Property

The element id of the profile family used to create the sweep or reveal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId ProfileId { get; set; }
Public Property ProfileId As ElementId
    Get
    Set
public:
property ElementId^ ProfileId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member ProfileId : ElementId with get, set

Property Value

ElementId
May be InvalidElementId if the default profile is used.
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
This value is not used when creating standalone wall sweeps. The profile id of the wall sweep's type is used instead.
See Also

Reference

WallSweepInfo Class


WallSweepInfo.WallOffset Property

WallSweepInfoWallOffset Property

The offset from the sweep or reveal to the wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double WallOffset { get; set; }
Public Property WallOffset As Double
    Get
    Set
public:
property double WallOffset {
    double get ();
    void set (double value);
}
member WallOffset : float with get, set

Property Value

Double
If the sweep is a solid sweep, a negative value moves it toward the wall core. If the sweep is a reveal, a negative offset value moves it away from the wall.
See Also

Reference

WallSweepInfo Class


WallSweepInfo.WallSide Property

WallSweepInfoWallSide Property

The side of the wall to which the sweep or reveal is attached.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WallSide WallSide { get; set; }
Public Property WallSide As WallSide
    Get
    Set
public:
property WallSide WallSide {
    WallSide get ();
    void set (WallSide value);
}
member WallSide : WallSide with get, set

Property Value

WallSide
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

WallSweepInfo Class


WallSweepInfo.WallSweepOrientation Property

WallSweepInfoWallSweepOrientation Property

Indicates how the profile of a horiztonal sweep is oriented with repect to the wall side face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WallSweepOrientation WallSweepOrientation { get; set; }
Public Property WallSweepOrientation As WallSweepOrientation
    Get
    Set
public:
property WallSweepOrientation WallSweepOrientation {
    WallSweepOrientation get ();
    void set (WallSweepOrientation value);
}
member WallSweepOrientation : WallSweepOrientation with get, set

Property Value

WallSweepOrientation
Allowed values are Horizontal and Perpendicular. Default is Perpendicular
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

WallSweepInfo Class


WallSweepInfo.WallSweepType Property

WallSweepInfoWallSweepType Property

The type (either a wall sweep or a reveal).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WallSweepType WallSweepType { get; set; }
Public Property WallSweepType As WallSweepType
    Get
    Set
public:
property WallSweepType WallSweepType {
    WallSweepType get ();
    void set (WallSweepType value);
}
member WallSweepType : WallSweepType with get, set

Property Value

WallSweepType
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

WallSweepInfo Class


WallSweepInfo Methods

The WallSweepInfo type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqual | Determines if the input object is equivalent to this WallSweepInfo.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

WallSweepInfo Class


WallSweepInfo.Dispose Method

WallSweepInfoDispose Method

Releases all resources used by the WallSweepInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

WallSweepInfo Class


WallSweepInfo.IsEqual Method

WallSweepInfoIsEqual Method

Determines if the input object is equivalent to this WallSweepInfo.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEqual(
    WallSweepInfo toCompare
)
Public Function IsEqual (
    toCompare As WallSweepInfo
) As Boolean
public:
bool IsEqual(
    WallSweepInfo^ toCompare
)
member IsEqual :
        toCompare : WallSweepInfo -> bool

Parameters

toCompare WallSweepInfo

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

WallSweepInfo Class


WallSweepOrientation Enumeration

Represents the orientation of horizonally placed sweep's profile relative to the wall side face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum WallSweepOrientation
Public Enumeration WallSweepOrientation
public enum class WallSweepOrientation
type WallSweepOrientation
Members
Member name | Value | Description
Horizontal | 0 | Profile is oriented horizontally regardless of wall slant angle
Perpendicular | 1 | Profile is perpendicular to the wall side face
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


WallSweepType Enumeration

Represents the possible types for methods affecting wall sweeps or reveals.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum WallSweepType
Public Enumeration WallSweepType
public enum class WallSweepType
type WallSweepType
Members
Member name | Value | Description
Sweep | 0 | Represents a wall sweep.
Reveal | 1 | Represents a reveal.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


WallType Class

Represents a specific type of wall, such as 'Generic - 8"'.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBHostObjAttributes
Autodesk.Revit.DBWallType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class WallType : HostObjAttributes
Public Class WallType
    Inherits HostObjAttributes
public ref class WallType : public HostObjAttributes
type WallType =
    class
        inherit HostObjAttributes
    end

The WallType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
Public property | Function | The wall function.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | Kind | The nature of the wall.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ThermalProperties | The calculated and settable thermal properties of the WallType
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | Width | The overall thickness of this type of wall.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
All wall type objects available in the project can be retrieved from the Document object via the WallTypes property. Every Wall object has a WallType property that returns the a WallType object representing the type. This same WallType property can also be used to change the type of the wall by setting it to a different type.
Example
C#
VB
C++
F#
Copy
public void GetInfo_WallType(WallType wallType)
{
    string message;
    // Reports the nature of the wall
    message = "The wall type kind is : " + wallType.Kind.ToString();

    // Get the overall thickness of this type of wall.
    message += "\nThe wall type Width is : " + wallType.Width.ToString();

    TaskDialog.Show("Revit",message);
}
Public Sub GetInfo_WallType(wallType As WallType)
    Dim message As String
    ' Reports the nature of the wall
    message = "The wall type kind is : " & wallType.Kind.ToString()

    ' Get the overall thickness of this type of wall.
    message += vbLf & "The wall type Width is : " & wallType.Width.ToString()

    TaskDialog.Show("Revit", message)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


WallType Properties

The WallType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
Public property | Function | The wall function.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | Kind | The nature of the wall.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ThermalProperties | The calculated and settable thermal properties of the WallType
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | Width | The overall thickness of this type of wall.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

WallType Class


WallType.Function Property

WallTypeFunction Property

The wall function.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WallFunction Function { get; set; }
Public Property Function As WallFunction
    Get
    Set
public:
property WallFunction Function {
    WallFunction get ();
    void set (WallFunction value);
}
member Function : WallFunction with get, set

Property Value

WallFunction
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

WallType Class


WallType.Kind Property

WallTypeKind Property

The nature of the wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WallKind Kind { get; }
Public ReadOnly Property Kind As WallKind
    Get
public:
property WallKind Kind {
    WallKind get ();
}
member Kind : WallKind with get

Property Value

WallKind
See Also

Reference

WallType Class


WallType.ThermalProperties Property

WallTypeThermalProperties Property

The calculated and settable thermal properties of the WallType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ThermalProperties ThermalProperties { get; }
Public ReadOnly Property ThermalProperties As ThermalProperties
    Get
public:
property ThermalProperties^ ThermalProperties {
    ThermalProperties^ get ();
}
member ThermalProperties : ThermalProperties with get

Property Value

ThermalProperties
Remarks
Returns if the wall has no thermal properties. Curtain walls and stacked walls do not store thermal properties.
See Also

Reference

WallType Class


WallType.Width Property

WallTypeWidth Property

The overall thickness of this type of wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Width { get; }
Public ReadOnly Property Width As Double
    Get
public:
property double Width {
    double get ();
}
member Width : float with get

Property Value

Double
See Also

Reference

WallType Class


WallType Methods

The WallType type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Duplicate | Duplicates an existing element type and assigns it a new name. (Inherited from ElementType)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType)
Public method | IsValidDefaultFamilyType | Identifies if this type is a valid default family type for the given family category id. (Inherited from ElementType)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

WallType Class


WallUtils Class

General Wall utility methods
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBWallUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class WallUtils
Public NotInheritable Class WallUtils
public ref class WallUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type WallUtils = class end

The WallUtils type exposes the following members.

Methods
Name | Description
AllowWallJoinAtEnd | Allows the wall's end to join to other walls. If that end is near other walls it will become joined as a result.
DisallowWallJoinAtEnd | Sets the wall's end not to join to other walls.
IsWallJoinAllowedAtEnd | Identifies if the indicated end of the wall allows joins or not.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


WallUtils Methods

The WallUtils type exposes the following members.

Methods
Name | Description
AllowWallJoinAtEnd | Allows the wall's end to join to other walls. If that end is near other walls it will become joined as a result.
DisallowWallJoinAtEnd | Sets the wall's end not to join to other walls.
IsWallJoinAllowedAtEnd | Identifies if the indicated end of the wall allows joins or not.
Top
See Also

Reference

WallUtils Class


WallUtils.AllowWallJoinAtEnd Method

WallUtilsAllowWallJoinAtEnd Method

Allows the wall's end to join to other walls. If that end is near other walls it will become joined as a result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void AllowWallJoinAtEnd(
    Wall wall,
    int end
)
Public Shared Sub AllowWallJoinAtEnd (
    wall As Wall,
    end As Integer
)
public:
static void AllowWallJoinAtEnd(
    Wall^ wall,
    int end
)
static member AllowWallJoinAtEnd :
        wall : Wall *
        end : int -> unit

Parameters

wall Wall
The wall in question
end Int32
0 or 1 for the beginning or end of the wall's curve
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
By default all walls are allowed to join at ends, so this function is only needed if this wall end is already disallowed to join. If this wall is a stacked wall, all subwalls at this end will be allowed to join.
See Also

Reference

WallUtils Class


WallUtils.DisallowWallJoinAtEnd Method

WallUtilsDisallowWallJoinAtEnd Method

Sets the wall's end not to join to other walls.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void DisallowWallJoinAtEnd(
    Wall wall,
    int end
)
Public Shared Sub DisallowWallJoinAtEnd (
    wall As Wall,
    end As Integer
)
public:
static void DisallowWallJoinAtEnd(
    Wall^ wall,
    int end
)
static member DisallowWallJoinAtEnd :
        wall : Wall *
        end : int -> unit

Parameters

wall Wall
The wall in question
end Int32
0 or 1 for the beginning or end of the wall's curve
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
If this wall is already joined at this end, it will become disconnected. If this wall is a stacked wall, all subwalls at this end will be disallowed to join.
See Also

Reference

WallUtils Class


WallUtils.IsWallJoinAllowedAtEnd Method

WallUtilsIsWallJoinAllowedAtEnd Method

Identifies if the indicated end of the wall allows joins or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsWallJoinAllowedAtEnd(
    Wall wall,
    int end
)
Public Shared Function IsWallJoinAllowedAtEnd (
    wall As Wall,
    end As Integer
) As Boolean
public:
static bool IsWallJoinAllowedAtEnd(
    Wall^ wall,
    int end
)
static member IsWallJoinAllowedAtEnd :
        wall : Wall *
        end : int -> bool

Parameters

wall Wall
The wall in question
end Int32
0 or 1 for the beginning or end of the wall's curve

Return Value

Boolean
true if it is allowed to join. false if it is disallowed.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

WallUtils Class


WidthMeasuredAt Enumeration

The allowed values for the WALL_TYPE_WIDTH_MEASURED_AT parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum WidthMeasuredAt
Public Enumeration WidthMeasuredAt
public enum class WidthMeasuredAt
type WidthMeasuredAt
Members
Member name | Value | Description
Top | 0 | The top of the wall taking into account the top offset before any attachment.
Base | 1 | The base constraint of the wall.
Bottom | 2 | The bottom of the wall taking into the base offset before any attachment.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


WireframeBuilder Class

Constructs a shape representation consisting of points and curves. That shape would typically be stored in a DirectShape or a DirectShapeType object.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBShapeBuilder
Autodesk.Revit.DBWireframeBuilder

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class WireframeBuilder : ShapeBuilder
Public Class WireframeBuilder
    Inherits ShapeBuilder
public ref class WireframeBuilder : public ShapeBuilder
type WireframeBuilder =
    class
        inherit ShapeBuilder
    end

The WireframeBuilder type exposes the following members.

Constructors
 | Name | Description
Public method | WireframeBuilder | Default constructor.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ShapeBuilder)
Top
Methods
 | Name | Description
Public method | AddCurve | Add a curve to the shape representation stored in this WireframeBuilder.
Public method | AddPoint | Add a point to the shape representation stored in this WireframeBuilder.
Public method | Dispose | (Inherited from ShapeBuilder)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Reset | Clears the accumulated geometry.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
 | ValidateCurve | Validates curve to be added to the wireframe shape being constructed. Used by addCurve to validate input. This function may be used to pre-validate the geometry being added to avoid an exception from AddCurve().
 | ValidatePoint | Validates the point object to be added to the wireframe shape being constructed. Used by AddPoint() to validate input.
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


WireframeBuilder Constructor

Default constructor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WireframeBuilder()
Public Sub New
public:
WireframeBuilder()
new : unit -> WireframeBuilder
See Also

Reference

WireframeBuilder Class


WireframeBuilder Properties

The WireframeBuilder type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ShapeBuilder)
Top
See Also

Reference

WireframeBuilder Class


WireframeBuilder Methods

The WireframeBuilder type exposes the following members.

Methods
 | Name | Description
Public method | AddCurve | Add a curve to the shape representation stored in this WireframeBuilder.
Public method | AddPoint | Add a point to the shape representation stored in this WireframeBuilder.
Public method | Dispose | (Inherited from ShapeBuilder)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Reset | Clears the accumulated geometry.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
 | ValidateCurve | Validates curve to be added to the wireframe shape being constructed. Used by addCurve to validate input. This function may be used to pre-validate the geometry being added to avoid an exception from AddCurve().
 | ValidatePoint | Validates the point object to be added to the wireframe shape being constructed. Used by AddPoint() to validate input.
Top
See Also

Reference

WireframeBuilder Class


WireframeBuilder.AddCurve Method

WireframeBuilderAddCurve Method

Add a curve to the shape representation stored in this WireframeBuilder.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddCurve(
    Curve GCurve
)
Public Sub AddCurve (
    GCurve As Curve
)
public:
void AddCurve(
    Curve^ GCurve
)
member AddCurve :
        GCurve : Curve -> unit

Parameters

GCurve Curve
The curve to be added.
Exceptions
Exception | Condition
ArgumentException | GCurve is not acceptable for a wireframe shape representation.
ArgumentNullException | A non-optional argument was null
See Also

Reference

WireframeBuilder Class


WireframeBuilder.AddPoint Method

WireframeBuilderAddPoint Method

Add a point to the shape representation stored in this WireframeBuilder.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void AddPoint(
    Point GPoint
)
Public Sub AddPoint (
    GPoint As Point
)
public:
void AddPoint(
    Point^ GPoint
)
member AddPoint :
        GPoint : Point -> unit

Parameters

GPoint Point
The point to be added.
Exceptions
Exception | Condition
ArgumentException | GPoint is not acceptable for a wireframe shape representation.
ArgumentNullException | A non-optional argument was null
See Also

Reference

WireframeBuilder Class


WireframeBuilder.Reset Method

WireframeBuilderReset Method

Clears the accumulated geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Reset()
Public Sub Reset
public:
void Reset()
member Reset : unit -> unit
See Also

Reference

WireframeBuilder Class


WireframeBuilder.ValidateCurve Method

WireframeBuilderValidateCurve Method

Validates curve to be added to the wireframe shape being constructed. Used by addCurve to validate input. This function may be used to pre-validate the geometry being added to avoid an exception from AddCurve().

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool ValidateCurve(
    Curve GCurve
)
Public Shared Function ValidateCurve (
    GCurve As Curve
) As Boolean
public:
static bool ValidateCurve(
    Curve^ GCurve
)
static member ValidateCurve :
        GCurve : Curve -> bool

Parameters

GCurve Curve
Curve object to be validated.

Return Value

Boolean
True is %GCurve% is acceptable as a part of a wireframe shape representation being built.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

WireframeBuilder Class


WireframeBuilder.ValidatePoint Method

WireframeBuilderValidatePoint Method

Validates the point object to be added to the wireframe shape being constructed. Used by AddPoint() to validate input.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool ValidatePoint(
    Point GPoint
)
Public Shared Function ValidatePoint (
    GPoint As Point
) As Boolean
public:
static bool ValidatePoint(
    Point^ GPoint
)
static member ValidatePoint :
        GPoint : Point -> bool

Parameters

GPoint Point
Point object to be validated.

Return Value

Boolean
True is %GPoint% is acceptable as a part of a wireframe shape representation being built.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
This function may be used to pre-validate the geometry being added to avoid an exception from AddPoint().
See Also

Reference

WireframeBuilder Class


Workset Class

Represents a workset in the document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBWorksetPreview
Autodesk.Revit.DBWorkset

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Workset : WorksetPreview
Public Class Workset
    Inherits WorksetPreview
public ref class Workset : public WorksetPreview
type Workset =
    class
        inherit WorksetPreview
    end

The Workset type exposes the following members.

Properties
 | Name | Description
Public property | Id | Id of the workset. (Inherited from WorksetPreview)
Public property | IsDefaultWorkset | Whether the workset is the default one. (Inherited from WorksetPreview)
Public property | IsEditable | Whether the workset is editable.
Public property | IsOpen | Whether the workset is open (rather than closed).
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from WorksetPreview)
Public property | IsVisibleByDefault | Whether the workset is visible by default.
Public property | Kind | Kind of the workset.
Public property | Name | Name of the workset. (Inherited from WorksetPreview)
Public property | Owner | User name of the workset. (Inherited from WorksetPreview)
Public property | UniqueId | UniqueId of the workset. (Inherited from WorksetPreview)
Top
Methods
 | Name | Description
 | Create | Creates a new workset.
Public method | Dispose | (Inherited from WorksetPreview)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Worksets are a way to divide a set of elements in the Revit document into subsets for worksharing. There may be one or many worksets in a document. Each element in the document must belong to one and only one workset.
Example
C#
VB
C++
F#
Copy
public void GetWorksetsInfo(Document doc)
{
    String message = String.Empty;
    // Enumerating worksets in a document and getting basic information for each
    FilteredWorksetCollector collector = new FilteredWorksetCollector(doc);

    // find all user worksets
    collector.OfKind(WorksetKind.UserWorkset);

    // get information for each workset
    int count = 3;  // show info for 3 worksets only
    foreach (Workset workset in collector)
    {
        message += "Workset : " + workset.Name;
        message += "\nUnique Id : " + workset.UniqueId;
        message += "\nOwner : " + workset.Owner;
        message += "\nKind : " + workset.Kind;
        message += "\nIs default : " + workset.IsDefaultWorkset;
        message += "\nIs editable : " + workset.IsEditable;
        message += "\nIs open : " + workset.IsOpen;
        message += "\nIs visible by default : " + workset.IsVisibleByDefault;

        TaskDialog.Show("GetWorksetsInfo", message);

        if (0 == --count)
            break;
    }
}
Public Sub GetWorksetsInfo(doc As Document)
    Dim message As [String] = [String].Empty
    ' Enumerating worksets in a document and getting basic information for each
    Dim collector As New FilteredWorksetCollector(doc)

    ' find all user worksets
    collector.OfKind(WorksetKind.UserWorkset)

    ' get information for each workset
    Dim count As Integer = 3
    ' show info for 3 worksets only
    For Each workset As Workset In collector
        message += "Workset : " + workset.Name
        message += vbLf & "Unique Id : " & workset.UniqueId.ToString()
        message += vbLf & "Owner : " + workset.Owner
        message += vbLf & "Kind : " + workset.Kind
        message += vbLf & "Is default : " + workset.IsDefaultWorkset
        message += vbLf & "Is editable : " + workset.IsEditable
        message += vbLf & "Is open : " + workset.IsOpen
        message += vbLf & "Is visible by default : " + workset.IsVisibleByDefault

        TaskDialog.Show("GetWorksetsInfo", message)

        If 0 = System.Threading.Interlocked.Decrement(count) Then
            Exit For
        End If
    Next
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Workset Properties

The Workset type exposes the following members.

Properties
 | Name | Description
Public property | Id | Id of the workset. (Inherited from WorksetPreview)
Public property | IsDefaultWorkset | Whether the workset is the default one. (Inherited from WorksetPreview)
Public property | IsEditable | Whether the workset is editable.
Public property | IsOpen | Whether the workset is open (rather than closed).
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from WorksetPreview)
Public property | IsVisibleByDefault | Whether the workset is visible by default.
Public property | Kind | Kind of the workset.
Public property | Name | Name of the workset. (Inherited from WorksetPreview)
Public property | Owner | User name of the workset. (Inherited from WorksetPreview)
Public property | UniqueId | UniqueId of the workset. (Inherited from WorksetPreview)
Top
See Also

Reference

Workset Class


Workset.IsEditable Property

WorksetIsEditable Property

Whether the workset is editable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEditable { get; }
Public ReadOnly Property IsEditable As Boolean
    Get
public:
property bool IsEditable {
    bool get ();
}
member IsEditable : bool with get

Property Value

Boolean
Remarks
The workset is editable if owned by current user.
See Also

Reference

Workset Class


Workset.IsOpen Property

WorksetIsOpen Property

Whether the workset is open (rather than closed).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsOpen { get; }
Public ReadOnly Property IsOpen As Boolean
    Get
public:
property bool IsOpen {
    bool get ();
}
member IsOpen : bool with get

Property Value

Boolean
Remarks
The intent of closing a workset is to ask Revit to not display or expand any element in the workset, to reduce memory usage. Note that open/closed status is independent of editability.
See Also

Reference

Workset Class


Workset.IsVisibleByDefault Property

WorksetIsVisibleByDefault Property

Whether the workset is visible by default.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsVisibleByDefault { get; }
Public ReadOnly Property IsVisibleByDefault As Boolean
    Get
public:
property bool IsVisibleByDefault {
    bool get ();
}
member IsVisibleByDefault : bool with get

Property Value

Boolean
Exceptions
Exception | Condition
InvalidOperationException | WorksetDefaultVisibilitySettings is not applicable to family documents.
See Also

Reference

Workset Class


Workset.Kind Property

WorksetKind Property

Kind of the workset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WorksetKind Kind { get; }
Public ReadOnly Property Kind As WorksetKind
    Get
public:
property WorksetKind Kind {
    WorksetKind get ();
}
member Kind : WorksetKind with get

Property Value

WorksetKind
See Also

Reference

Workset Class


Workset Methods

The Workset type exposes the following members.

Methods
 | Name | Description
 | Create | Creates a new workset.
Public method | Dispose | (Inherited from WorksetPreview)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Workset Class


Workset.Create Method

WorksetCreate Method

Creates a new workset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Workset Create(
    Document document,
    string name
)
Public Shared Function Create (
    document As Document,
    name As String
) As Workset
public:
static Workset^ Create(
    Document^ document,
    String^ name
)
static member Create :
        document : Document *
        name : string -> Workset

Parameters

document Document
The document in which the new instance is created.
name String
The workset name.

Return Value

Workset
Returns the newly created workset.
Exceptions
Exception | Condition
ArgumentException | document is not a workshared document. -or- name is an empty string or contains only whitespace. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- The given workset name is already in use.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
Example
C#
VB
C++
F#
Copy
public Workset CreateWorkset(Document document)
{
    Workset newWorkset = null;
    // Worksets can only be created in a document with worksharing enabled
    if (document.IsWorkshared)
    {
        string worksetName = "New Workset";
        // Workset name must not be in use by another workset
        if (WorksetTable.IsWorksetNameUnique(document, worksetName))
        {
            using (Transaction worksetTransaction = new Transaction(document, "Set preview view id"))
            {
                worksetTransaction.Start();
                newWorkset = Workset.Create(document, worksetName);
                worksetTransaction.Commit();
            }
        }
    }

    return newWorkset;
}
Public Function CreateWorkset(document As Document) As Workset
    Dim newWorkset As Workset = Nothing
    ' Worksets can only be created in a document with worksharing enabled
    If document.IsWorkshared Then
        Dim worksetName As String = "New Workset"
        ' Workset name must not be in use by another workset
        If WorksetTable.IsWorksetNameUnique(document, worksetName) Then
            Using worksetTransaction As New Transaction(document, "Set preview view id")
                worksetTransaction.Start()
                newWorkset = Workset.Create(document, worksetName)
                worksetTransaction.Commit()
            End Using
        End If
    End If

    Return newWorkset
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Workset Class


WorksetConfiguration Class

A configuration class that is passed in to methods that open Revit documents to specify which user-created worksets are opened/closed.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBWorksetConfiguration

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class WorksetConfiguration : IDisposable
Public Class WorksetConfiguration
    Implements IDisposable
public ref class WorksetConfiguration : IDisposable
type WorksetConfiguration =
    class
        interface IDisposable
    end

The WorksetConfiguration type exposes the following members.

Constructors
 | Name | Description
Public method | WorksetConfiguration | Constructs a new workset configuration with an initial setting to open all user-created worksets.
Public method | WorksetConfiguration(WorksetConfiguration) | Constructs a new copy of the input WorksetConfiguration object.
Public method | WorksetConfiguration(WorksetConfigurationOption) | Constructs a new workset configuration with an initial setting to open or close all user-created worksets, or to open last viewed worksets.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Close | Sets a group of user-created worksets to close.
Public method | Dispose | Releases all resources used by the WorksetConfiguration
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Open | Sets a group of user-created worksets to open.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

Once an instance of this class is created, it can be further modified by calling any of the other methods in any order. It is a specification of a setting for model open; the methods of this class just adjust the specification, and do not themselves open or close worksets.

Only user-created worksets can be specified to be opened or closed. All system worksets are automatically open. An open workset allows its elements can be expanded and displayed. For a closed workset, Revit tries to not expand its elements, and to that end, does not display them. This is intended to help with performance by reducing Revit's memory footprint.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


WorksetConfiguration Constructor

Overload List
 | Name | Description
Public method | WorksetConfiguration | Constructs a new workset configuration with an initial setting to open all user-created worksets.
Public method | WorksetConfiguration(WorksetConfiguration) | Constructs a new copy of the input WorksetConfiguration object.
Public method | WorksetConfiguration(WorksetConfigurationOption) | Constructs a new workset configuration with an initial setting to open or close all user-created worksets, or to open last viewed worksets.
Top
See Also

Reference

WorksetConfiguration Class


WorksetConfiguration Constructor

Constructs a new workset configuration with an initial setting to open all user-created worksets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WorksetConfiguration()
Public Sub New
public:
WorksetConfiguration()
new : unit -> WorksetConfiguration
See Also

Reference

WorksetConfiguration Class
WorksetConfiguration Overload


WorksetConfiguration(WorksetConfiguration) Constructor

Constructs a new copy of the input WorksetConfiguration object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WorksetConfiguration(
    WorksetConfiguration other
)
Public Sub New (
    other As WorksetConfiguration
)
public:
WorksetConfiguration(
    WorksetConfiguration^ other
)
new :
        other : WorksetConfiguration -> WorksetConfiguration

Parameters

other WorksetConfiguration
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

WorksetConfiguration Class
WorksetConfiguration Overload


WorksetConfiguration(WorksetConfigurationOption) Constructor

Constructs a new workset configuration with an initial setting to open or close all user-created worksets, or to open last viewed worksets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WorksetConfiguration(
    WorksetConfigurationOption option
)
Public Sub New (
    option As WorksetConfigurationOption
)
public:
WorksetConfiguration(
    WorksetConfigurationOption option
)
new :
        option : WorksetConfigurationOption -> WorksetConfiguration

Parameters

option WorksetConfigurationOption
The option to open or close all user created worksets by default.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

WorksetConfiguration Class
WorksetConfiguration Overload


WorksetConfiguration Properties

The WorksetConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

WorksetConfiguration Class


WorksetConfiguration.IsValidObject Property

WorksetConfigurationIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

WorksetConfiguration Class


WorksetConfiguration Methods

The WorksetConfiguration type exposes the following members.

Methods
 | Name | Description
Public method | Close | Sets a group of user-created worksets to close.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Open | Sets a group of user-created worksets to open.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

WorksetConfiguration Class


WorksetConfiguration.Close Method

WorksetConfigurationClose Method

Sets a group of user-created worksets to close.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Close(
    IList<WorksetId> worksetsToClose
)
Public Sub Close (
    worksetsToClose As IList(Of WorksetId)
)
public:
void Close(
    IList<WorksetId^>^ worksetsToClose
)
member Close :
        worksetsToClose : IList<WorksetId> -> unit

Parameters

worksetsToClose IList WorksetId
The group of user-created worksets to close. Non-user-created worksets and invalid workset ids will be ignored.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Calling this method on a configuration created with options other than WorksetConfigurationOption.CloseAllWorksets will set these worksets to be explicitly closed. If all worksets are set to close, the configuration will be unchanged. Worksets other than the inputs are unaffected.
See Also

Reference

WorksetConfiguration Class


WorksetConfiguration.Dispose Method

WorksetConfigurationDispose Method

Releases all resources used by the WorksetConfiguration

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

WorksetConfiguration Class


WorksetConfiguration.Open Method

WorksetConfigurationOpen Method

Sets a group of user-created worksets to open.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Open(
    IList<WorksetId> worksetsToOpen
)
Public Sub Open (
    worksetsToOpen As IList(Of WorksetId)
)
public:
void Open(
    IList<WorksetId^>^ worksetsToOpen
)
member Open :
        worksetsToOpen : IList<WorksetId> -> unit

Parameters

worksetsToOpen IList WorksetId
The group of user-created worksets to open. Non-user-created worksets and invalid workset ids will be ignored.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Calling this method on a configuration created with options other than WorksetConfigurationOption.OpenAllWorksets will set these worksets to be explicitly opened. If all worksets are set to open, the configuration will be unchanged. Worksets other than the inputs are unaffected.
See Also

Reference

WorksetConfiguration Class


WorksetConfigurationOption Enumeration

A collection of options used to initialize a WorksetConfiguration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum WorksetConfigurationOption
Public Enumeration WorksetConfigurationOption
public enum class WorksetConfigurationOption
type WorksetConfigurationOption
Members
Member name | Value | Description
OpenAllWorksets | 0 | Open all user-created worksets by default. Additional open requests will be ignored for this type of configuration.
CloseAllWorksets | 1 | Close all user-created worksets by default. Additional close requests will be ignored for this type of configuration.
OpenLastViewed | 2 | Close all user-created worksets by default, but open last viewed worksets.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


WorksetDefaultVisibilitySettings Class

An object that manages default visibility of worksets in a document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBWorksetDefaultVisibilitySettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class WorksetDefaultVisibilitySettings : Element
Public Class WorksetDefaultVisibilitySettings
    Inherits Element
public ref class WorksetDefaultVisibilitySettings : public Element
type WorksetDefaultVisibilitySettings =
    class
        inherit Element
    end

The WorksetDefaultVisibilitySettings type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
 | GetWorksetDefaultVisibilitySettings | Get the WorksetDefaultVisibilitySettings of the document.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | IsWorksetVisible | Indicates whether the workset is visible by default.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
 | SetWorksetVisibility | Set the default visibility of a workset.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
WorksetDefaultVisibilitySettings does not exist for family documents. In case worksharing is disabled in a document, all elements are moved into a single workset; that workset, and any worksets (re)created if worksharing is re-enabled, is visible by default regardless of any current settings.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


WorksetDefaultVisibilitySettings Properties

The WorksetDefaultVisibilitySettings type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

WorksetDefaultVisibilitySettings Class


WorksetDefaultVisibilitySettings Methods

The WorksetDefaultVisibilitySettings type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
 | GetWorksetDefaultVisibilitySettings | Get the WorksetDefaultVisibilitySettings of the document.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | IsWorksetVisible | Indicates whether the workset is visible by default.
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
 | SetWorksetVisibility | Set the default visibility of a workset.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

WorksetDefaultVisibilitySettings Class


WorksetDefaultVisibilitySettings.GetWorksetDefaultVisibilitySettings Method

WorksetDefaultVisibilitySettingsGetWorksetDefaultVisibilitySettings Method

Get the WorksetDefaultVisibilitySettings of the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static WorksetDefaultVisibilitySettings GetWorksetDefaultVisibilitySettings(
    Document aDoc
)
Public Shared Function GetWorksetDefaultVisibilitySettings (
    aDoc As Document
) As WorksetDefaultVisibilitySettings
public:
static WorksetDefaultVisibilitySettings^ GetWorksetDefaultVisibilitySettings(
    Document^ aDoc
)
static member GetWorksetDefaultVisibilitySettings :
        aDoc : Document -> WorksetDefaultVisibilitySettings

Parameters

aDoc Document
The document.

Return Value

WorksetDefaultVisibilitySettings
The WorksetDefaultVisibilitySettings of the document.
Exceptions
Exception | Condition
ArgumentException | WorksetDefaultVisibilitySettings is not applicable to family documents.
ArgumentNullException | A non-optional argument was null
Remarks
WorksetDefaultVisibilitySettings is not available in family documents.
See Also

Reference

WorksetDefaultVisibilitySettings Class


WorksetDefaultVisibilitySettings.IsWorksetVisible Method

WorksetDefaultVisibilitySettingsIsWorksetVisible Method

Indicates whether the workset is visible by default.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsWorksetVisible(
    WorksetId worksetId
)
Public Function IsWorksetVisible (
    worksetId As WorksetId
) As Boolean
public:
bool IsWorksetVisible(
    WorksetId^ worksetId
)
member IsWorksetVisible :
        worksetId : WorksetId -> bool

Parameters

worksetId WorksetId
Id of the workset.

Return Value

Boolean
Whether the workset is visible by default.
Exceptions
Exception | Condition
ArgumentException | There is no workset with this Id in the document.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | WorksetDefaultVisibilitySettings is not applicable to family documents.
See Also

Reference

WorksetDefaultVisibilitySettings Class


WorksetDefaultVisibilitySettings.SetWorksetVisibility Method

WorksetDefaultVisibilitySettingsSetWorksetVisibility Method

Set the default visibility of a workset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetWorksetVisibility(
    WorksetId worksetId,
    bool visible
)
Public Sub SetWorksetVisibility (
    worksetId As WorksetId,
    visible As Boolean
)
public:
void SetWorksetVisibility(
    WorksetId^ worksetId,
    bool visible
)
member SetWorksetVisibility :
        worksetId : WorksetId *
        visible : bool -> unit

Parameters

worksetId WorksetId
Id of the workset.
visible Boolean
Whether the workset should be visible by default or not.
Exceptions
Exception | Condition
ArgumentException | There is no workset with this Id in the document.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | WorksetDefaultVisibilitySettings is not applicable to family documents.
Example
C#
VB
C++
F#
Copy
public void HideWorkset(Document doc, View view, WorksetId worksetId)
{
    // get the current visibility
    WorksetVisibility visibility = view.GetWorksetVisibility(worksetId);

    // and set it to 'Hidden' if it is not hidden yet
    if (visibility != WorksetVisibility.Hidden)
    {
        view.SetWorksetVisibility(worksetId, WorksetVisibility.Hidden);
    }

    // Get the workset’s default visibility
    WorksetDefaultVisibilitySettings defaultVisibility = WorksetDefaultVisibilitySettings.GetWorksetDefaultVisibilitySettings(doc);

    // and making sure it is set to 'false'
    if (defaultVisibility.IsWorksetVisible(worksetId))
    {
        defaultVisibility.SetWorksetVisibility(worksetId, false);
    }
}
Public Sub HideWorkset(doc As Document, view As View, worksetId As WorksetId)
    ' get the current visibility
    Dim visibility As WorksetVisibility = view.GetWorksetVisibility(worksetId)

    ' and set it to 'Hidden' if it is not hidden yet
    If visibility <> WorksetVisibility.Hidden Then
        view.SetWorksetVisibility(worksetId, WorksetVisibility.Hidden)
    End If

    ' Get the workset’s default visibility
    Dim defaultVisibility As WorksetDefaultVisibilitySettings = WorksetDefaultVisibilitySettings.GetWorksetDefaultVisibilitySettings(doc)

    ' and making sure it is set to 'false'
    If defaultVisibility.IsWorksetVisible(worksetId) Then
        defaultVisibility.SetWorksetVisibility(worksetId, False)
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

WorksetDefaultVisibilitySettings Class


WorksetFilter Class

A base class for a type of filter that accepts or rejects worksets based upon criteria.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBWorksetFilter
Autodesk.Revit.DBWorksetKindFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class WorksetFilter : IDisposable
Public Class WorksetFilter
    Implements IDisposable
public ref class WorksetFilter : IDisposable
type WorksetFilter =
    class
        interface IDisposable
    end

The WorksetFilter type exposes the following members.

Properties
 | Name | Description
Public property | IncludeStandaloneWorksetsOnly | True if the results of the filter only match stand-alone worksets; worksets that are not stand-alone will be rejected.
Public property | Inverted | True if the results of the filter are inverted; worksets that would normally be accepted by this filter will be rejected, and worksets that would normally be rejected will be accepted.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the WorksetFilter
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


WorksetFilter Properties

The WorksetFilter type exposes the following members.

Properties
 | Name | Description
Public property | IncludeStandaloneWorksetsOnly | True if the results of the filter only match stand-alone worksets; worksets that are not stand-alone will be rejected.
Public property | Inverted | True if the results of the filter are inverted; worksets that would normally be accepted by this filter will be rejected, and worksets that would normally be rejected will be accepted.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

WorksetFilter Class


WorksetFilter.IncludeStandaloneWorksetsOnly Property

WorksetFilterIncludeStandaloneWorksetsOnly Property

True if the results of the filter only match stand-alone worksets; worksets that are not stand-alone will be rejected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IncludeStandaloneWorksetsOnly { get; set; }
Public Property IncludeStandaloneWorksetsOnly As Boolean
    Get
    Set
public:
property bool IncludeStandaloneWorksetsOnly {
    bool get ();
    void set (bool value);
}
member IncludeStandaloneWorksetsOnly : bool with get, set

Property Value

Boolean
See Also

Reference

WorksetFilter Class


WorksetFilter.Inverted Property

WorksetFilterInverted Property

True if the results of the filter are inverted; worksets that would normally be accepted by this filter will be rejected, and worksets that would normally be rejected will be accepted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Inverted { get; }
Public ReadOnly Property Inverted As Boolean
    Get
public:
property bool Inverted {
    bool get ();
}
member Inverted : bool with get

Property Value

Boolean
See Also

Reference

WorksetFilter Class


WorksetFilter.IsValidObject Property

WorksetFilterIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

WorksetFilter Class


WorksetFilter Methods

The WorksetFilter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

WorksetFilter Class


WorksetFilter.Dispose Method

WorksetFilterDispose Method

Releases all resources used by the WorksetFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

WorksetFilter Class


WorksetId Class

WorksetId identifies a workset within a single document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBWorksetId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class WorksetId
Public Class WorksetId
public ref class WorksetId
type WorksetId = class end

The WorksetId type exposes the following members.

Constructors
 | Name | Description
Public method | WorksetId | Create an WorksetId handle with the given integer id.
Top
Properties
 | Name | Description
Public property | IntegerValue | Provides the value of the WorksetId as an integer.
 | InvalidWorksetId | Get the invalid WorksetId whose IntegerValue is -1.
Top
Methods
 | Name | Description
Public method | Compare | Compares two WorksetIds.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object))
Public method | GetHashCode | Gets the integer value of the id as hash code (Overrides ObjectGetHashCode)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Gets a String representation of the integer value of the id. (Overrides ObjectToString)
Top
Operators
Name | Description
Equality(WorksetId, WorksetId) | Determines whether these two WorksetIds are the same.
GreaterThan(WorksetId, WorksetId) | Determines whether one WorksetId is greater than another WorksetId.
GreaterThanOrEqual(WorksetId, WorksetId) | Determines whether one WorksetId is not less than another WorksetId.
Inequality(WorksetId, WorksetId) | Determines whether these two WorksetIds are different.
LessThan(WorksetId, WorksetId) | Determines whether this WorksetId is less than another WorksetId.
LessThanOrEqual(WorksetId, WorksetId) | Determines whether one WorksetId is not greater than another WorksetId.
Top
Remarks
WorksetId is not guaranteed to be unique. It is only valid within one model and its value may change when the model is synchronized with central. If unique identification of a workset is needed, the workset's GUID should be used instead.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


WorksetId Constructor

Create an WorksetId handle with the given integer id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WorksetId(
    int id
)
Public Sub New (
    id As Integer
)
public:
WorksetId(
    int id
)
new :
        id : int -> WorksetId

Parameters

id Int32
The id.
See Also

Reference

WorksetId Class


WorksetId Properties

The WorksetId type exposes the following members.

Properties
 | Name | Description
Public property | IntegerValue | Provides the value of the WorksetId as an integer.
 | InvalidWorksetId | Get the invalid WorksetId whose IntegerValue is -1.
Top
See Also

Reference

WorksetId Class


WorksetId.IntegerValue Property

WorksetIdIntegerValue Property

Provides the value of the WorksetId as an integer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int IntegerValue { get; }
Public ReadOnly Property IntegerValue As Integer
    Get
public:
property int IntegerValue {
    int get ();
}
member IntegerValue : int with get

Property Value

Int32
See Also

Reference

WorksetId Class


WorksetId.InvalidWorksetId Property

WorksetIdInvalidWorksetId Property

Get the invalid WorksetId whose IntegerValue is -1.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static WorksetId InvalidWorksetId { get; }
Public Shared ReadOnly Property InvalidWorksetId As WorksetId
    Get
public:
static property WorksetId^ InvalidWorksetId {
    WorksetId^ get ();
}
static member InvalidWorksetId : WorksetId with get

Property Value

WorksetId
See Also

Reference

WorksetId Class


WorksetId Methods

The WorksetId type exposes the following members.

Methods
 | Name | Description
Public method | Compare | Compares two WorksetIds.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object))
Public method | GetHashCode | Gets the integer value of the id as hash code (Overrides ObjectGetHashCode)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Gets a String representation of the integer value of the id. (Overrides ObjectToString)
Top
See Also

Reference

WorksetId Class


WorksetId.Compare Method

WorksetIdCompare Method

Compares two WorksetIds.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Compare(
    WorksetId id
)
Public Function Compare (
    id As WorksetId
) As Integer
public:
int Compare(
    WorksetId^ id
)
member Compare :
        id : WorksetId -> int

Parameters

id WorksetId
The WorksetId to be compared with this WorksetId.

Return Value

Int32
-1 if this WorksetId is less than id, 0 if equal, 1 if greater.
See Also

Reference

WorksetId Class


WorksetId.Equals Method

WorksetIdEquals Method

Determines whether the specified Object is equal to the current Object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj Object
Another object.

Return Value

Boolean
See Also

Reference

WorksetId Class


WorksetId.GetHashCode Method

WorksetIdGetHashCode Method

Gets the integer value of the id as hash code

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Int32
See Also

Reference

WorksetId Class


WorksetId.ToString Method

WorksetIdToString Method

Gets a String representation of the integer value of the id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

String
See Also

Reference

WorksetId Class


WorksetId Operators

The WorksetId type exposes the following members.

Operators
Name | Description
Equality(WorksetId, WorksetId) | Determines whether these two WorksetIds are the same.
GreaterThan(WorksetId, WorksetId) | Determines whether one WorksetId is greater than another WorksetId.
GreaterThanOrEqual(WorksetId, WorksetId) | Determines whether one WorksetId is not less than another WorksetId.
Inequality(WorksetId, WorksetId) | Determines whether these two WorksetIds are different.
LessThan(WorksetId, WorksetId) | Determines whether this WorksetId is less than another WorksetId.
LessThanOrEqual(WorksetId, WorksetId) | Determines whether one WorksetId is not greater than another WorksetId.
Top
See Also

Reference

WorksetId Class


WorksetId.Equality Operator

WorksetIdEquality Operator

Determines whether these two WorksetIds are the same.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool operator ==(
    WorksetId first,
    WorksetId second
)
Public Shared Operator = (
    first As WorksetId,
    second As WorksetId
) As Boolean
public:
static bool operator ==(
    WorksetId^ first,
    WorksetId^ second
)
static let inline (=)
        first : WorksetId *
        second : WorksetId  : bool

Parameters

first WorksetId
The first WorksetId.
second WorksetId
The second WorksetId.

Return Value

Boolean
True if the WorksetIds are the same; otherwise, false.
See Also

Reference

WorksetId Class


WorksetId.GreaterThan Operator

WorksetIdGreaterThan Operator

Determines whether one WorksetId is greater than another WorksetId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool operator >(
    WorksetId WorksetId1,
    WorksetId WorksetId2
)
Public Shared Operator > (
    WorksetId1 As WorksetId,
    WorksetId2 As WorksetId
) As Boolean
public:
static bool operator >(
    WorksetId^ WorksetId1,
    WorksetId^ WorksetId2
)
static let inline (>)
        WorksetId1 : WorksetId *
        WorksetId2 : WorksetId  : bool

Parameters

WorksetId1 WorksetId
The first WorksetId.
WorksetId2 WorksetId
The second WorksetId.

Return Value

Boolean
True if the first WorksetId is greater than the second WorksetId, otherwise, false.
See Also

Reference

WorksetId Class


WorksetId.GreaterThanOrEqual Operator

WorksetIdGreaterThanOrEqual Operator

Determines whether one WorksetId is not less than another WorksetId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool operator >=(
    WorksetId WorksetId1,
    WorksetId WorksetId2
)
Public Shared Operator >= (
    WorksetId1 As WorksetId,
    WorksetId2 As WorksetId
) As Boolean
public:
static bool operator >=(
    WorksetId^ WorksetId1,
    WorksetId^ WorksetId2
)
static let inline (>=)
        WorksetId1 : WorksetId *
        WorksetId2 : WorksetId  : bool

Parameters

WorksetId1 WorksetId
The first WorksetId.
WorksetId2 WorksetId
The second WorksetId.

Return Value

Boolean
True if the first WorksetId is not less than the second WorksetId, otherwise, false.
See Also

Reference

WorksetId Class


WorksetId.Inequality Operator

WorksetIdInequality Operator

Determines whether these two WorksetIds are different.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool operator !=(
    WorksetId first,
    WorksetId second
)
Public Shared Operator <> (
    first As WorksetId,
    second As WorksetId
) As Boolean
public:
static bool operator !=(
    WorksetId^ first,
    WorksetId^ second
)
static let inline (<>)
        first : WorksetId *
        second : WorksetId  : bool

Parameters

first WorksetId
The first WorksetId.
second WorksetId
The second WorksetId.

Return Value

Boolean
True if the WorksetIds are different; otherwise, false.
See Also

Reference

WorksetId Class


WorksetId.LessThan Operator

WorksetIdLessThan Operator

Determines whether this WorksetId is less than another WorksetId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool operator <(
    WorksetId WorksetId1,
    WorksetId WorksetId2
)
Public Shared Operator < (
    WorksetId1 As WorksetId,
    WorksetId2 As WorksetId
) As Boolean
public:
static bool operator <(
    WorksetId^ WorksetId1,
    WorksetId^ WorksetId2
)
static let inline (<)
        WorksetId1 : WorksetId *
        WorksetId2 : WorksetId  : bool

Parameters

WorksetId1 WorksetId
The first WorksetId.
WorksetId2 WorksetId
The second WorksetId.

Return Value

Boolean
True if the first WorksetId is less than the second WorksetId, otherwise, false.
See Also

Reference

WorksetId Class


WorksetId.LessThanOrEqual Operator

WorksetIdLessThanOrEqual Operator

Determines whether one WorksetId is not greater than another WorksetId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool operator <=(
    WorksetId WorksetId1,
    WorksetId WorksetId2
)
Public Shared Operator <= (
    WorksetId1 As WorksetId,
    WorksetId2 As WorksetId
) As Boolean
public:
static bool operator <=(
    WorksetId^ WorksetId1,
    WorksetId^ WorksetId2
)
static let inline (<=)
        WorksetId1 : WorksetId *
        WorksetId2 : WorksetId  : bool

Parameters

WorksetId1 WorksetId
The first WorksetId.
WorksetId2 WorksetId
The second WorksetId.

Return Value

Boolean
True if the first WorksetId is not greater than the second WorksetId, otherwise, false.
See Also

Reference

WorksetId Class


WorksetKind Enumeration

Indicates one of the standard kinds of workset (as available in the UI).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum WorksetKind
Public Enumeration WorksetKind
public enum class WorksetKind
type WorksetKind
Members
Member name | Value | Description
OtherWorkset | 0 | Any workset which is not one of the standard types included in this enum.
FamilyWorkset | 1 | Workset containing a family.
ViewWorkset | 2 | Workset containing a view.
StandardWorkset | 3 | Workset containing a standard.
UserWorkset | 4 | Workset defined by users, including the two default worksets created by Revit
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


WorksetKindFilter Class

A filter used to match worksets of the given WorksetKind.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBWorksetFilter
Autodesk.Revit.DBWorksetKindFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class WorksetKindFilter : WorksetFilter
Public Class WorksetKindFilter
    Inherits WorksetFilter
public ref class WorksetKindFilter : public WorksetFilter
type WorksetKindFilter =
    class
        inherit WorksetFilter
    end

The WorksetKindFilter type exposes the following members.

Constructors
 | Name | Description
Public method | WorksetKindFilter(WorksetKind) | Constructs a new instance of WorksetKindFilter filter to match worksets of the given WorksetKind.
Public method | WorksetKindFilter(WorksetKind, Boolean) | Constructs a new instance of WorksetKindFilter filter to match worksets of the given WorksetKind.
Top
Properties
 | Name | Description
Public property | IncludeStandaloneWorksetsOnly | True if the results of the filter only match stand-alone worksets; worksets that are not stand-alone will be rejected. (Inherited from WorksetFilter)
Public property | Inverted | True if the results of the filter are inverted; worksets that would normally be accepted by this filter will be rejected, and worksets that would normally be rejected will be accepted. (Inherited from WorksetFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from WorksetFilter)
Public property | WorksetKind | The WorksetKind.
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from WorksetFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This filter is a quick filter.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


WorksetKindFilter Constructor

Overload List
 | Name | Description
Public method | WorksetKindFilter(WorksetKind) | Constructs a new instance of WorksetKindFilter filter to match worksets of the given WorksetKind.
Public method | WorksetKindFilter(WorksetKind, Boolean) | Constructs a new instance of WorksetKindFilter filter to match worksets of the given WorksetKind.
Top
See Also

Reference

WorksetKindFilter Class


WorksetKindFilter(WorksetKind) Constructor

Constructs a new instance of WorksetKindFilter filter to match worksets of the given WorksetKind.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WorksetKindFilter(
    WorksetKind worksetKind
)
Public Sub New (
    worksetKind As WorksetKind
)
public:
WorksetKindFilter(
    WorksetKind worksetKind
)
new :
        worksetKind : WorksetKind -> WorksetKindFilter

Parameters

worksetKind WorksetKind
The WorksetKind to match.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

WorksetKindFilter Class
WorksetKindFilter Overload


WorksetKindFilter(WorksetKind, Boolean) Constructor

Constructs a new instance of WorksetKindFilter filter to match worksets of the given WorksetKind.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WorksetKindFilter(
    WorksetKind worksetKind,
    bool inverted
)
Public Sub New (
    worksetKind As WorksetKind,
    inverted As Boolean
)
public:
WorksetKindFilter(
    WorksetKind worksetKind,
    bool inverted
)
new :
        worksetKind : WorksetKind *
        inverted : bool -> WorksetKindFilter

Parameters

worksetKind WorksetKind
The WorksetKind to match.
inverted Boolean
True if the filter should match all worksets which are not of the given WorksetKind.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

WorksetKindFilter Class
WorksetKindFilter Overload


WorksetKindFilter Properties

The WorksetKindFilter type exposes the following members.

Properties
 | Name | Description
Public property | IncludeStandaloneWorksetsOnly | True if the results of the filter only match stand-alone worksets; worksets that are not stand-alone will be rejected. (Inherited from WorksetFilter)
Public property | Inverted | True if the results of the filter are inverted; worksets that would normally be accepted by this filter will be rejected, and worksets that would normally be rejected will be accepted. (Inherited from WorksetFilter)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from WorksetFilter)
Public property | WorksetKind | The WorksetKind.
Top
See Also

Reference

WorksetKindFilter Class


WorksetKindFilter.WorksetKind Property

WorksetKindFilterWorksetKind Property

The WorksetKind.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WorksetKind WorksetKind { get; }
Public ReadOnly Property WorksetKind As WorksetKind
    Get
public:
property WorksetKind WorksetKind {
    WorksetKind get ();
}
member WorksetKind : WorksetKind with get

Property Value

WorksetKind
See Also

Reference

WorksetKindFilter Class


WorksetKindFilter Methods

The WorksetKindFilter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from WorksetFilter)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

WorksetKindFilter Class


WorksetPreview Class

Represents an accessor for workset data which can be obtained from an unopened document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBWorksetPreview
Autodesk.Revit.DBWorkset

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class WorksetPreview : IDisposable
Public Class WorksetPreview
    Implements IDisposable
public ref class WorksetPreview : IDisposable
type WorksetPreview =
    class
        interface IDisposable
    end

The WorksetPreview type exposes the following members.

Properties
 | Name | Description
Public property | Id | Id of the workset.
Public property | IsDefaultWorkset | Whether the workset is the default one.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | Name of the workset.
Public property | Owner | User name of the workset.
Public property | UniqueId | UniqueId of the workset.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the WorksetPreview
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
As a base class of Workset, this class has limited access to data. WorksetPreviews are obtained from WorksharingUtils.GetUserWorksetInfo() from an unopened document.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


WorksetPreview Properties

The WorksetPreview type exposes the following members.

Properties
 | Name | Description
Public property | Id | Id of the workset.
Public property | IsDefaultWorkset | Whether the workset is the default one.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Name | Name of the workset.
Public property | Owner | User name of the workset.
Public property | UniqueId | UniqueId of the workset.
Top
See Also

Reference

WorksetPreview Class


WorksetPreview.Id Property

WorksetPreviewId Property

Id of the workset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WorksetId Id { get; }
Public ReadOnly Property Id As WorksetId
    Get
public:
property WorksetId^ Id {
    WorksetId^ get ();
}
member Id : WorksetId with get

Property Value

WorksetId
Remarks
Id of the workset may be changed while synchronizing with central. Please use UniqueId to reliably identify worksets despite changes which occur due to synchronization with central.
See Also

Reference

WorksetPreview Class


WorksetPreview.IsDefaultWorkset Property

WorksetPreviewIsDefaultWorkset Property

Whether the workset is the default one.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsDefaultWorkset { get; }
Public ReadOnly Property IsDefaultWorkset As Boolean
    Get
public:
property bool IsDefaultWorkset {
    bool get ();
}
member IsDefaultWorkset : bool with get

Property Value

Boolean
See Also

Reference

WorksetPreview Class


WorksetPreview.IsValidObject Property

WorksetPreviewIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

WorksetPreview Class


WorksetPreview.Name Property

WorksetPreviewName Property

Name of the workset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

String
Remarks
Name is case-insensitive.
See Also

Reference

WorksetPreview Class


WorksetPreview.Owner Property

WorksetPreviewOwner Property

User name of the workset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Owner { get; }
Public ReadOnly Property Owner As String
    Get
public:
property String^ Owner {
    String^ get ();
}
member Owner : string with get

Property Value

String
See Also

Reference

WorksetPreview Class


WorksetPreview.UniqueId Property

WorksetPreviewUniqueId Property

UniqueId of the workset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid UniqueId { get; }
Public ReadOnly Property UniqueId As Guid
    Get
public:
property Guid UniqueId {
    Guid get ();
}
member UniqueId : Guid with get

Property Value

Guid
Remarks
Stable identifier for a workset, UniqueId will not change while synchronizing with central.
See Also

Reference

WorksetPreview Class


WorksetPreview Methods

The WorksetPreview type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

WorksetPreview Class


WorksetPreview.Dispose Method

WorksetPreviewDispose Method

Releases all resources used by the WorksetPreview

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

WorksetPreview Class


WorksetTable Class

A table containing references to all the worksets contained in a document.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBWorksetTable

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class WorksetTable : IDisposable
Public Class WorksetTable
    Implements IDisposable
public ref class WorksetTable : IDisposable
type WorksetTable =
    class
        interface IDisposable
    end

The WorksetTable type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
 | CanDeleteWorkset | Indicates if a workset can be deleted.
 | DeleteWorkset | Delete the specific workset.
Public method | Dispose | Releases all resources used by the WorksetTable
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | GetActiveWorksetId | Returns the active workset's WorksetId.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetWorkset(Guid) | Returns the workset from a input Guid.
Public method | GetWorkset(WorksetId) | Returns the workset from a input WorksetId.
 | IsWorksetNameUnique | Checks if the given workset name is unique in the document.
 | RenameWorkset | Renames the workset.
Public method | SetActiveWorksetId | Sets the active workset.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
There is one WorksetTable for each document. There will be at least one default workset in the table, even if worksharing has not been enabled in the document.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


WorksetTable Properties

The WorksetTable type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

WorksetTable Class


WorksetTable.IsValidObject Property

WorksetTableIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

WorksetTable Class


WorksetTable Methods

The WorksetTable type exposes the following members.

Methods
 | Name | Description
 | CanDeleteWorkset | Indicates if a workset can be deleted.
 | DeleteWorkset | Delete the specific workset.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | GetActiveWorksetId | Returns the active workset's WorksetId.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetWorkset(Guid) | Returns the workset from a input Guid.
Public method | GetWorkset(WorksetId) | Returns the workset from a input WorksetId.
 | IsWorksetNameUnique | Checks if the given workset name is unique in the document.
 | RenameWorkset | Renames the workset.
Public method | SetActiveWorksetId | Sets the active workset.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

WorksetTable Class


WorksetTable.CanDeleteWorkset Method

WorksetTableCanDeleteWorkset Method

Indicates if a workset can be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CanDeleteWorkset(
    Document document,
    WorksetId worksetId,
    DeleteWorksetSettings deleteWorksetSettings
)
Public Shared Function CanDeleteWorkset (
    document As Document,
    worksetId As WorksetId,
    deleteWorksetSettings As DeleteWorksetSettings
) As Boolean
public:
static bool CanDeleteWorkset(
    Document^ document,
    WorksetId^ worksetId,
    DeleteWorksetSettings^ deleteWorksetSettings
)
static member CanDeleteWorkset :
        document : Document *
        worksetId : WorksetId *
        deleteWorksetSettings : DeleteWorksetSettings -> bool

Parameters

document Document
The document containing the worksets.
worksetId WorksetId
The id of the workset to delete.
deleteWorksetSettings DeleteWorksetSettings
The settings to delete a workset.

Return Value

Boolean
True if the workset can be deleted, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks

The workset can't be deleted in the following cases:

  • The input worksetId is not valid in the document.
  • The input worksetId doesn't represent a user-created workset, which means this workset might be a system workset.
  • The workset is not editable by the current user. In order to resolve this problem, please checkout the workset by calling [!:Autodesk::Revit::DB::WorksharingUtils::CheckoutWorksets].
  • The workset or some elements under the workset are owned by the other users. In order to resolve this problem, please ask the other users to call [!:Autodesk::Revit::DB::WorksharingUtils::RelinquishOwnership] to relinquish their ownership on the workset and elements.
  • The target workset is not a user-created workset.

See Also

Reference

WorksetTable Class


WorksetTable.DeleteWorkset Method

WorksetTableDeleteWorkset Method

Delete the specific workset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void DeleteWorkset(
    Document document,
    WorksetId worksetId,
    DeleteWorksetSettings deleteWorksetSettings
)
Public Shared Sub DeleteWorkset (
    document As Document,
    worksetId As WorksetId,
    deleteWorksetSettings As DeleteWorksetSettings
)
public:
static void DeleteWorkset(
    Document^ document,
    WorksetId^ worksetId,
    DeleteWorksetSettings^ deleteWorksetSettings
)
static member DeleteWorkset :
        document : Document *
        worksetId : WorksetId *
        deleteWorksetSettings : DeleteWorksetSettings -> unit

Parameters

document Document
The document containing the worksets.
worksetId WorksetId
The id of the workset to delete.
deleteWorksetSettings DeleteWorksetSettings
The settings to delete a workset.
Exceptions
Exception | Condition
ArgumentException | document is not a workshared document. -or- document is not a primary document, it is a linked document. -or- document is read-only: It cannot be modified. -or- There is no workset in the document with this id. -or- Workset cannot be deleted.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
RegenerationFailedException | The document regeneration fails during the DeleteWorkset operation.
Remarks
Please checkout the workset before executing this method. The method may fail in some situations that mentioned in CanDeleteWorkset(Document, WorksetId, DeleteWorksetSettings). Another failure case is the Transaction failure due to "Deleting all open views in a project is not allowed."
See Also

Reference

WorksetTable Class


WorksetTable.Dispose Method

WorksetTableDispose Method

Releases all resources used by the WorksetTable

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

WorksetTable Class


WorksetTable.GetActiveWorksetId Method

WorksetTableGetActiveWorksetId Method

Returns the active workset's WorksetId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WorksetId GetActiveWorksetId()
Public Function GetActiveWorksetId As WorksetId
public:
WorksetId^ GetActiveWorksetId()
member GetActiveWorksetId : unit -> WorksetId

Return Value

WorksetId
WorksetId of the active workset.
Example
C#
VB
C++
F#
Copy
public Workset GetActiveWorkset(Document doc)
{
    // Get the workset table from the document
    WorksetTable worksetTable = doc.GetWorksetTable();
    // Get the Id of the active workset
    WorksetId activeId = worksetTable.GetActiveWorksetId();
    // Find the workset with that Id
    Workset workset = worksetTable.GetWorkset(activeId);
    return workset;
}
Public Function GetActiveWorkset(doc As Document) As Workset
    ' Get the workset table from the document
    Dim worksetTable As WorksetTable = doc.GetWorksetTable()
    ' Get the Id of the active workset
    Dim activeId As WorksetId = worksetTable.GetActiveWorksetId()
    ' Find the workset with that Id
    Dim workset As Workset = worksetTable.GetWorkset(activeId)
    Return workset
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

WorksetTable Class


WorksetTable.GetWorkset Method

WorksetTableGetWorkset Method

Overload List
 | Name | Description
Public method | GetWorkset(Guid) | Returns the workset from a input Guid.
Public method | GetWorkset(WorksetId) | Returns the workset from a input WorksetId.
Top
See Also

Reference

WorksetTable Class


WorksetTable.GetWorkset(Guid) Method

WorksetTableGetWorkset(Guid) Method

Returns the workset from a input Guid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Workset GetWorkset(
    Guid guid
)
Public Function GetWorkset (
    guid As Guid
) As Workset
public:
Workset^ GetWorkset(
    Guid guid
)
member GetWorkset :
        guid : Guid -> Workset

Parameters

guid Guid
Guid of the workset.

Return Value

Workset
The returned workset. if there is no workset in this table with this Id.
See Also

Reference

WorksetTable Class
GetWorkset Overload


WorksetTable.GetWorkset(WorksetId) Method

WorksetTableGetWorkset(WorksetId) Method

Returns the workset from a input WorksetId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Workset GetWorkset(
    WorksetId id
)
Public Function GetWorkset (
    id As WorksetId
) As Workset
public:
Workset^ GetWorkset(
    WorksetId^ id
)
member GetWorkset :
        id : WorksetId -> Workset

Parameters

id WorksetId
Id of a workset.

Return Value

Workset
The returned workset. if there is no workset in this table with this Id.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

WorksetTable Class
GetWorkset Overload


WorksetTable.IsWorksetNameUnique Method

WorksetTableIsWorksetNameUnique Method

Checks if the given workset name is unique in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsWorksetNameUnique(
    Document aDoc,
    string name
)
Public Shared Function IsWorksetNameUnique (
    aDoc As Document,
    name As String
) As Boolean
public:
static bool IsWorksetNameUnique(
    Document^ aDoc,
    String^ name
)
static member IsWorksetNameUnique :
        aDoc : Document *
        name : string -> bool

Parameters

aDoc Document
The document in which the workset is accessed.
name String
The workset name.

Return Value

Boolean
True if this given workset name is unique in the document, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

WorksetTable Class


WorksetTable.RenameWorkset Method

WorksetTableRenameWorkset Method

Renames the workset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void RenameWorkset(
    Document aDoc,
    WorksetId worksetId,
    string name
)
Public Shared Sub RenameWorkset (
    aDoc As Document,
    worksetId As WorksetId,
    name As String
)
public:
static void RenameWorkset(
    Document^ aDoc,
    WorksetId^ worksetId,
    String^ name
)
static member RenameWorkset :
        aDoc : Document *
        worksetId : WorksetId *
        name : string -> unit

Parameters

aDoc Document
The document in which the workset is accessed.
worksetId WorksetId
The workset Id.
name String
The workset name.
Exceptions
Exception | Condition
ArgumentException | aDoc is not a workshared document. -or- name is an empty string or contains only whitespace. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- The given workset name is already in use. -or- There is no workset in the document with this id.
ArgumentNullException | A non-optional argument was null
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
See Also

Reference

WorksetTable Class


WorksetTable.SetActiveWorksetId Method

WorksetTableSetActiveWorksetId Method

Sets the active workset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetActiveWorksetId(
    WorksetId worksetId
)
Public Sub SetActiveWorksetId (
    worksetId As WorksetId
)
public:
void SetActiveWorksetId(
    WorksetId^ worksetId
)
member SetActiveWorksetId :
        worksetId : WorksetId -> unit

Parameters

worksetId WorksetId
The workset Id.
Exceptions
Exception | Condition
ArgumentException | There is no workset in the document with this id.
ArgumentNullException | A non-optional argument was null
See Also

Reference

WorksetTable Class


WorksetVisibility Enumeration

Indicates the visibility settings of a workset in a particular view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum WorksetVisibility
Public Enumeration WorksetVisibility
public enum class WorksetVisibility
type WorksetVisibility
Members
Member name | Value | Description
Visible | 0 | Be visible in a view (i.e. will be visible unless it is closed).
Hidden | 1 | Be hidden in a view.
UseGlobalSetting | 2 | Do not override the visibility.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


WorksharingDisplayGraphicSettings Class

Represents the graphical settings that can be assigned to elements in the worksharing display modes.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBWorksharingDisplayGraphicSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class WorksharingDisplayGraphicSettings : IDisposable
Public Class WorksharingDisplayGraphicSettings
    Implements IDisposable
public ref class WorksharingDisplayGraphicSettings : IDisposable
type WorksharingDisplayGraphicSettings =
    class
        interface IDisposable
    end

The WorksharingDisplayGraphicSettings type exposes the following members.

Constructors
 | Name | Description
Public method | WorksharingDisplayGraphicSettings | Creates a new instance.
Top
Properties
 | Name | Description
Public property | FillColor | The fill color that will be applied to elements when these settings are applied. Note that this is automatically set by increasing the luma of the specified line color by 65%.
Public property | IsApplied | Indicates whether this set of graphic overrides will be applied.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LineColor | The line color that will be applied to elements when these settings are applied.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the WorksharingDisplayGraphicSettings
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Example
C#
VB
C++
F#
Copy
public WorksharingDisplayGraphicSettings GetWorksharingDisplaySettings(Document doc, String userName, WorksetId worksetId, bool ownedbyCurrentUser)
{
    WorksharingDisplayGraphicSettings graphicSettings;

    // get or create a WorksharingDisplaySettings current active document
    WorksharingDisplaySettings displaySettings = WorksharingDisplaySettings.GetOrCreateWorksharingDisplaySettings(doc);

    // get graphic settings for a user, if specified
    if (!String.IsNullOrEmpty(userName))
        graphicSettings = displaySettings.GetGraphicOverrides(userName);

    // get graphicSettings for a workset, if specified
    else if (worksetId != WorksetId.InvalidWorksetId)
        graphicSettings = displaySettings.GetGraphicOverrides(worksetId);

    // get graphic settings for the OwnedByCurrentUser status
    else if (ownedbyCurrentUser)
        graphicSettings = displaySettings.GetGraphicOverrides(CheckoutStatus.OwnedByCurrentUser);

    // otherwise get graphic settings for the CurrentWithCentral status
    else
        graphicSettings = displaySettings.GetGraphicOverrides(ModelUpdatesStatus.CurrentWithCentral);

    return graphicSettings;
}
Public Function GetWorksharingDisplaySettings(doc As Document, userName As [String], worksetId__1 As WorksetId, ownedbyCurrentUser As Boolean) As WorksharingDisplayGraphicSettings
    Dim graphicSettings As WorksharingDisplayGraphicSettings

    ' get or create a WorksharingDisplaySettings current active document
    Dim displaySettings As WorksharingDisplaySettings = WorksharingDisplaySettings.GetOrCreateWorksharingDisplaySettings(doc)

    ' get graphic settings for a user, if specified
    If Not [String].IsNullOrEmpty(userName) Then
        graphicSettings = displaySettings.GetGraphicOverrides(userName)

    ' get graphicSettings for a workset, if specified
    ElseIf worksetId__1 <> WorksetId.InvalidWorksetId Then
        graphicSettings = displaySettings.GetGraphicOverrides(worksetId__1)

    ' get graphic settings for the OwnedByCurrentUser status
    ElseIf ownedbyCurrentUser Then
        graphicSettings = displaySettings.GetGraphicOverrides(CheckoutStatus.OwnedByCurrentUser)
    Else

        ' otherwise get graphic settings for the CurrentWithCentral status
        graphicSettings = displaySettings.GetGraphicOverrides(ModelUpdatesStatus.CurrentWithCentral)
    End If

    Return graphicSettings
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


WorksharingDisplayGraphicSettings Constructor

Creates a new instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WorksharingDisplayGraphicSettings(
    bool shouldApply,
    Color lineColor
)
Public Sub New (
    shouldApply As Boolean,
    lineColor As Color
)
public:
WorksharingDisplayGraphicSettings(
    bool shouldApply,
    Color^ lineColor
)
new :
        shouldApply : bool *
        lineColor : Color -> WorksharingDisplayGraphicSettings

Parameters

shouldApply Boolean
True if the settings should be applied, False if they should be set but not applied.
lineColor Color
The desired line color, which must be a valid color. Note that the fill color is calculated automatically from the line color so it is not advisable to use white, black, or shades of grey.
Exceptions
Exception | Condition
ArgumentException | The lineColor argument does not represent a valid color.
ArgumentNullException | A non-optional argument was null
See Also

Reference

WorksharingDisplayGraphicSettings Class


WorksharingDisplayGraphicSettings Properties

The WorksharingDisplayGraphicSettings type exposes the following members.

Properties
 | Name | Description
Public property | FillColor | The fill color that will be applied to elements when these settings are applied. Note that this is automatically set by increasing the luma of the specified line color by 65%.
Public property | IsApplied | Indicates whether this set of graphic overrides will be applied.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LineColor | The line color that will be applied to elements when these settings are applied.
Top
See Also

Reference

WorksharingDisplayGraphicSettings Class


WorksharingDisplayGraphicSettings.FillColor Property

WorksharingDisplayGraphicSettingsFillColor Property

The fill color that will be applied to elements when these settings are applied. Note that this is automatically set by increasing the luma of the specified line color by 65%.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color FillColor { get; }
Public ReadOnly Property FillColor As Color
    Get
public:
property Color^ FillColor {
    Color^ get ();
}
member FillColor : Color with get

Property Value

Color
See Also

Reference

WorksharingDisplayGraphicSettings Class


WorksharingDisplayGraphicSettings.IsApplied Property

WorksharingDisplayGraphicSettingsIsApplied Property

Indicates whether this set of graphic overrides will be applied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsApplied { get; }
Public ReadOnly Property IsApplied As Boolean
    Get
public:
property bool IsApplied {
    bool get ();
}
member IsApplied : bool with get

Property Value

Boolean
See Also

Reference

WorksharingDisplayGraphicSettings Class


WorksharingDisplayGraphicSettings.IsValidObject Property

WorksharingDisplayGraphicSettingsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

WorksharingDisplayGraphicSettings Class


WorksharingDisplayGraphicSettings.LineColor Property

WorksharingDisplayGraphicSettingsLineColor Property

The line color that will be applied to elements when these settings are applied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color LineColor { get; }
Public ReadOnly Property LineColor As Color
    Get
public:
property Color^ LineColor {
    Color^ get ();
}
member LineColor : Color with get

Property Value

Color
See Also

Reference

WorksharingDisplayGraphicSettings Class


WorksharingDisplayGraphicSettings Methods

The WorksharingDisplayGraphicSettings type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

WorksharingDisplayGraphicSettings Class


WorksharingDisplayGraphicSettings.Dispose Method

WorksharingDisplayGraphicSettingsDispose Method

Releases all resources used by the WorksharingDisplayGraphicSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

WorksharingDisplayGraphicSettings Class


WorksharingDisplayMode Enumeration

Indicates which worksharing display mode a view is in.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum WorksharingDisplayMode
Public Enumeration WorksharingDisplayMode
public enum class WorksharingDisplayMode
type WorksharingDisplayMode
Members
Member name | Value | Description
Off | 0 | No active worksharing display mode.
CheckoutStatus | 1 | The view is displaying the checkout status of elements.
Owners | 2 | The view is displaying the specific owners of elements.
ModelUpdates | 3 | The view is displaying model updates.
Worksets | 4 | The view is displaying which workset each element is assigned to.
Example
C#
VB
C++
F#
Copy
public void GetWorksharingDisplayMode(View view)
{
    // Get and Set worksharingDisplayMode of a given view
    WorksharingDisplayMode displayMode = view.GetWorksharingDisplayMode();
    Autodesk.Revit.UI.TaskDialog.Show("GetWorksharingDisplayMode", "WorksharingDisplayMode : " + displayMode);

    view.SetWorksharingDisplayMode(WorksharingDisplayMode.CheckoutStatus);
    Autodesk.Revit.UI.TaskDialog.Show("SetWorksharingDisplayMode", "CheckoutStatus was set for View: " + view.Name);
}
Public Sub GetWorksharingDisplayMode(view As View)
    ' Get and Set worksharingDisplayMode of a given view
    Dim displayMode As WorksharingDisplayMode = view.GetWorksharingDisplayMode()
    Autodesk.Revit.UI.TaskDialog.Show("GetWorksharingDisplayMode", "WorksharingDisplayMode : " + displayMode)

    view.SetWorksharingDisplayMode(WorksharingDisplayMode.CheckoutStatus)
    Autodesk.Revit.UI.TaskDialog.Show("SetWorksharingDisplayMode", "CheckoutStatus was set for View: " + view.Name)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


WorksharingDisplaySettings Class

WorksharingDisplaySettings controls how elements will appear when they are displayed in any of the worksharing display modes.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBWorksharingDisplaySettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class WorksharingDisplaySettings : Element
Public Class WorksharingDisplaySettings
    Inherits Element
public ref class WorksharingDisplaySettings : public Element
type WorksharingDisplaySettings =
    class
        inherit Element
    end

The WorksharingDisplaySettings type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | CanUserHaveOverrides | Checks whether a single username can have customized graphic overrides.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAllUsersWithGraphicOverrides | Returns all usernames that have graphic overrides. This list consists of all users included in the user table + all users who have explicitly been assigned overrides.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetGraphicOverrides(CheckoutStatus) | Returns the graphic overrides associated with a particular ownership status.
Public method | GetGraphicOverrides(ModelUpdatesStatus) | Returns the graphic overrides assigned to a particular model update status.
Public method | GetGraphicOverrides(String) | Returns the graphic overrides assigned for elements owned by a particular user.
Public method | GetGraphicOverrides(WorksetId) | Returns the graphic overrides assigned to elements in a particular workset.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
 | GetOrCreateWorksharingDisplaySettings | Returns the worksharing display settings for the document, creating new settings for the current user if necessary.
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetRemovedUsers | Returns the set of users who have been explicitly removed from the settings.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
 | RemoveUsers | Removes users from the list of displayed users and permanently discards any customization of the graphics. Note that a user cannot be removed if he or she owns any elements.
Public method | RestoreUsers | Adds users back to the list of displayed users and permits customization of the graphics. Any usernames that are not currently removed will be ignored. Returns the number of users who were actually restored.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
 | SetGraphicOverrides(CheckoutStatus, WorksharingDisplayGraphicSettings) | Sets the graphic overrides assigned to elements with a particular ownership status.
Public method | SetGraphicOverrides(ModelUpdatesStatus, WorksharingDisplayGraphicSettings) | Sets the graphic overrides assigned to elements with a particular status in the central model.
Public method | SetGraphicOverrides(String, WorksharingDisplayGraphicSettings) | Sets the graphic overrides assigned to elements owned by a particular user. The username cannot be on the list of removed usernames.
Public method | SetGraphicOverrides(WorksetId, WorksharingDisplayGraphicSettings) | Sets the graphic overrides assigned to elements in a particular user workset.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UserHasGraphicOverrides | Checks whether there are graphic overrides that would apply to elements owned by the given user in the "Individual Owners" display mode.
Top
Remarks
The colors stored in these settings are a common setting and are shared by all users in the model. Whether a given color is applied or not is specific to the current user and will not be shared by other users.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


WorksharingDisplaySettings Properties

The WorksharingDisplaySettings type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

WorksharingDisplaySettings Class


WorksharingDisplaySettings Methods

The WorksharingDisplaySettings type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | CanUserHaveOverrides | Checks whether a single username can have customized graphic overrides.
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAllUsersWithGraphicOverrides | Returns all usernames that have graphic overrides. This list consists of all users included in the user table + all users who have explicitly been assigned overrides.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetGraphicOverrides(CheckoutStatus) | Returns the graphic overrides associated with a particular ownership status.
Public method | GetGraphicOverrides(ModelUpdatesStatus) | Returns the graphic overrides assigned to a particular model update status.
Public method | GetGraphicOverrides(String) | Returns the graphic overrides assigned for elements owned by a particular user.
Public method | GetGraphicOverrides(WorksetId) | Returns the graphic overrides assigned to elements in a particular workset.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
 | GetOrCreateWorksharingDisplaySettings | Returns the worksharing display settings for the document, creating new settings for the current user if necessary.
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetRemovedUsers | Returns the set of users who have been explicitly removed from the settings.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
 | RemoveUsers | Removes users from the list of displayed users and permanently discards any customization of the graphics. Note that a user cannot be removed if he or she owns any elements.
Public method | RestoreUsers | Adds users back to the list of displayed users and permits customization of the graphics. Any usernames that are not currently removed will be ignored. Returns the number of users who were actually restored.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
 | SetGraphicOverrides(CheckoutStatus, WorksharingDisplayGraphicSettings) | Sets the graphic overrides assigned to elements with a particular ownership status.
Public method | SetGraphicOverrides(ModelUpdatesStatus, WorksharingDisplayGraphicSettings) | Sets the graphic overrides assigned to elements with a particular status in the central model.
Public method | SetGraphicOverrides(String, WorksharingDisplayGraphicSettings) | Sets the graphic overrides assigned to elements owned by a particular user. The username cannot be on the list of removed usernames.
Public method | SetGraphicOverrides(WorksetId, WorksharingDisplayGraphicSettings) | Sets the graphic overrides assigned to elements in a particular user workset.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UserHasGraphicOverrides | Checks whether there are graphic overrides that would apply to elements owned by the given user in the "Individual Owners" display mode.
Top
See Also

Reference

WorksharingDisplaySettings Class


WorksharingDisplaySettings.CanUserHaveOverrides Method

WorksharingDisplaySettingsCanUserHaveOverrides Method

Checks whether a single username can have customized graphic overrides.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanUserHaveOverrides(
    string username
)
Public Function CanUserHaveOverrides (
    username As String
) As Boolean
public:
bool CanUserHaveOverrides(
    String^ username
)
member CanUserHaveOverrides :
        username : string -> bool

Parameters

username String
The username to check.

Return Value

Boolean
False if the username is on the list of removed users, True otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Only users that have not been removed can have overrides. Once it is removed, a username must be restored before its associated graphic overrides can be customized.
See Also

Reference

WorksharingDisplaySettings Class


WorksharingDisplaySettings.GetAllUsersWithGraphicOverrides Method

WorksharingDisplaySettingsGetAllUsersWithGraphicOverrides Method

Returns all usernames that have graphic overrides. This list consists of all users included in the user table + all users who have explicitly been assigned overrides.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<string> GetAllUsersWithGraphicOverrides()
Public Function GetAllUsersWithGraphicOverrides As ICollection(Of String)
public:
ICollection<String^>^ GetAllUsersWithGraphicOverrides()
member GetAllUsersWithGraphicOverrides : unit -> ICollection<string>

Return Value

ICollection String
All usernames that have been assigned graphic overrides.
See Also

Reference

WorksharingDisplaySettings Class


WorksharingDisplaySettings.GetGraphicOverrides Method

WorksharingDisplaySettingsGetGraphicOverrides Method

Overload List
 | Name | Description
Public method | GetGraphicOverrides(CheckoutStatus) | Returns the graphic overrides associated with a particular ownership status.
Public method | GetGraphicOverrides(ModelUpdatesStatus) | Returns the graphic overrides assigned to a particular model update status.
Public method | GetGraphicOverrides(String) | Returns the graphic overrides assigned for elements owned by a particular user.
Public method | GetGraphicOverrides(WorksetId) | Returns the graphic overrides assigned to elements in a particular workset.
Top
See Also

Reference

WorksharingDisplaySettings Class


WorksharingDisplaySettings.GetGraphicOverrides(CheckoutStatus) Method

WorksharingDisplaySettingsGetGraphicOverrides(CheckoutStatus) Method

Returns the graphic overrides associated with a particular ownership status.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WorksharingDisplayGraphicSettings GetGraphicOverrides(
    CheckoutStatus ownershipStatus
)
Public Function GetGraphicOverrides (
    ownershipStatus As CheckoutStatus
) As WorksharingDisplayGraphicSettings
public:
WorksharingDisplayGraphicSettings^ GetGraphicOverrides(
    CheckoutStatus ownershipStatus
)
member GetGraphicOverrides :
        ownershipStatus : CheckoutStatus -> WorksharingDisplayGraphicSettings

Parameters

ownershipStatus CheckoutStatus
The ownership status of interest.

Return Value

WorksharingDisplayGraphicSettings
Returns the graphic overrides assigned to a particular ownership status.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

WorksharingDisplaySettings Class
GetGraphicOverrides Overload


WorksharingDisplaySettings.GetGraphicOverrides(ModelUpdatesStatus) Method

WorksharingDisplaySettingsGetGraphicOverrides(ModelUpdatesStatus) Method

Returns the graphic overrides assigned to a particular model update status.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WorksharingDisplayGraphicSettings GetGraphicOverrides(
    ModelUpdatesStatus statusInCentral
)
Public Function GetGraphicOverrides (
    statusInCentral As ModelUpdatesStatus
) As WorksharingDisplayGraphicSettings
public:
WorksharingDisplayGraphicSettings^ GetGraphicOverrides(
    ModelUpdatesStatus statusInCentral
)
member GetGraphicOverrides :
        statusInCentral : ModelUpdatesStatus -> WorksharingDisplayGraphicSettings

Parameters

statusInCentral ModelUpdatesStatus
The model update status of interest.

Return Value

WorksharingDisplayGraphicSettings
Returns the graphic overrides assigned to the model update status.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

WorksharingDisplaySettings Class
GetGraphicOverrides Overload


WorksharingDisplaySettings.GetGraphicOverrides(String) Method

WorksharingDisplaySettingsGetGraphicOverrides(String) Method

Returns the graphic overrides assigned for elements owned by a particular user.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WorksharingDisplayGraphicSettings GetGraphicOverrides(
    string username
)
Public Function GetGraphicOverrides (
    username As String
) As WorksharingDisplayGraphicSettings
public:
WorksharingDisplayGraphicSettings^ GetGraphicOverrides(
    String^ username
)
member GetGraphicOverrides :
        username : string -> WorksharingDisplayGraphicSettings

Parameters

username String
The username of a particular user.

Return Value

WorksharingDisplayGraphicSettings
The graphic overrides assigned to this user.
Exceptions
Exception | Condition
ArgumentException | This WorksharingDisplaySettings does not contain graphic overrides for the specified value of username.
ArgumentNullException | A non-optional argument was null
See Also

Reference

WorksharingDisplaySettings Class
GetGraphicOverrides Overload


WorksharingDisplaySettings.GetGraphicOverrides(WorksetId) Method

WorksharingDisplaySettingsGetGraphicOverrides(WorksetId) Method

Returns the graphic overrides assigned to elements in a particular workset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WorksharingDisplayGraphicSettings GetGraphicOverrides(
    WorksetId worksetId
)
Public Function GetGraphicOverrides (
    worksetId As WorksetId
) As WorksharingDisplayGraphicSettings
public:
WorksharingDisplayGraphicSettings^ GetGraphicOverrides(
    WorksetId^ worksetId
)
member GetGraphicOverrides :
        worksetId : WorksetId -> WorksharingDisplayGraphicSettings

Parameters

worksetId WorksetId
The workset id of interest. This must be a user workset.

Return Value

WorksharingDisplayGraphicSettings
Returns the graphic overrides assigned to the workset.
Exceptions
Exception | Condition
ArgumentException | worksetId does not correspond to a user workset in the document containing this WorksharingDisplaySettings.
ArgumentNullException | A non-optional argument was null
See Also

Reference

WorksharingDisplaySettings Class
GetGraphicOverrides Overload


WorksharingDisplaySettings.GetOrCreateWorksharingDisplaySettings Method

WorksharingDisplaySettingsGetOrCreateWorksharingDisplaySettings Method

Returns the worksharing display settings for the document, creating new settings for the current user if necessary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static WorksharingDisplaySettings GetOrCreateWorksharingDisplaySettings(
    Document doc
)
Public Shared Function GetOrCreateWorksharingDisplaySettings (
    doc As Document
) As WorksharingDisplaySettings
public:
static WorksharingDisplaySettings^ GetOrCreateWorksharingDisplaySettings(
    Document^ doc
)
static member GetOrCreateWorksharingDisplaySettings :
        doc : Document -> WorksharingDisplaySettings

Parameters

doc Document
The document of interest.

Return Value

WorksharingDisplaySettings
The worksharing display settings for the document.
Exceptions
Exception | Condition
ArgumentException | doc is not a project document.
ArgumentNullException | A non-optional argument was null
Remarks
Note that these settings are available even in models that are not workshared. This is to allow pre-configuring the display settings before enabling worksets so that they can be stored in template files.
See Also

Reference

WorksharingDisplaySettings Class


WorksharingDisplaySettings.GetRemovedUsers Method

WorksharingDisplaySettingsGetRemovedUsers Method

Returns the set of users who have been explicitly removed from the settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<string> GetRemovedUsers()
Public Function GetRemovedUsers As ICollection(Of String)
public:
ICollection<String^>^ GetRemovedUsers()
member GetRemovedUsers : unit -> ICollection<string>

Return Value

ICollection String
Users who have been explicitly removed from the list.
See Also

Reference

WorksharingDisplaySettings Class


WorksharingDisplaySettings.RemoveUsers Method

WorksharingDisplaySettingsRemoveUsers Method

Removes users from the list of displayed users and permanently discards any customization of the graphics. Note that a user cannot be removed if he or she owns any elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveUsers(
    Document document,
    ICollection<string> usersToRemove,
    out ICollection<string> usersActuallyRemoved
)
Public Sub RemoveUsers (
    document As Document,
    usersToRemove As ICollection(Of String),
    <OutAttribute> ByRef usersActuallyRemoved As ICollection(Of String)
)
public:
void RemoveUsers(
    Document^ document,
    ICollection<String^>^ usersToRemove,
    [OutAttribute] ICollection<String^>^% usersActuallyRemoved
)
member RemoveUsers :
        document : Document *
        usersToRemove : ICollection<string> *
        usersActuallyRemoved : ICollection<string> byref -> unit

Parameters

document Document
The document containing this.
usersToRemove ICollection String
The usernames of the users to remove.
usersActuallyRemoved ICollection String
The users that were successfully removed. Note that you cannot remove users who currently own any elements.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Note that default graphic overrides will be applied to any elements owned by these users if they take ownership of any elements or worksets while they are removed. Note also that the list of removed users will be shared by all users of the central model and will remove all customizations by all users.
Example
C#
VB
C++
F#
Copy
public void RemoveAndRestoreUsers(Document doc)
{
    // get or create a WorksharingDisplaySettings current active document
    WorksharingDisplaySettings displaySettings = WorksharingDisplaySettings.GetOrCreateWorksharingDisplaySettings(doc);

    // get all users with GraphicOverrides
    ICollection<String> users = displaySettings.GetAllUsersWithGraphicOverrides();

    // remove the users from the display settings (they will not have graphic overrides anymore)
    ICollection<String> outUserList;
    displaySettings.RemoveUsers(doc, users, out outUserList);

    // show the current list of removed users
    ICollection<String> removedUsers = displaySettings.GetRemovedUsers();

    String message = "Current list of removed users: ";
    if (removedUsers.Count > 0 )
    {
       foreach (String user in removedUsers)
       {
          message += "\n" + user;
       }
    }
    else
    {
        message = "[Empty]";
    }

    TaskDialog.Show("Users Removed", message);

    // restore the previously removed users
    int number = displaySettings.RestoreUsers(outUserList);

    // again, show the current list of removed users
    // it should not contain the users that were restored
    removedUsers = displaySettings.GetRemovedUsers();

    message = "Current list of removed users: ";
    if (removedUsers.Count > 0 )
    {
       foreach (String user in removedUsers)
       {
          message += "\n" + user;
       }
    }
    else
    {
        message = "[Empty]";
    }

    TaskDialog.Show("Removed Users Restored", message);
}
Public Sub RemoveAndRestoreUsers(doc As Document)
    ' get or create a WorksharingDisplaySettings current active document
    Dim displaySettings As WorksharingDisplaySettings = WorksharingDisplaySettings.GetOrCreateWorksharingDisplaySettings(doc)

    ' get all users with GraphicOverrides
    Dim users As ICollection(Of [String]) = displaySettings.GetAllUsersWithGraphicOverrides()

    ' remove the users from the display settings (they will not have graphic overrides anymore)
    Dim outUserList As ICollection(Of [String]) = New List(Of String)
    displaySettings.RemoveUsers(doc, users, outUserList)

    ' show the current list of removed users
    Dim removedUsers As ICollection(Of [String]) = displaySettings.GetRemovedUsers()

    Dim message As [String] = "Current list of removed users: "
    If removedUsers.Count > 0 Then
        For Each user As [String] In removedUsers
            message += vbLf + user
        Next
    Else
        message = "[Empty]"
    End If

    TaskDialog.Show("Users Removed", message)

    ' restore the previously removed users
    Dim number As Integer = displaySettings.RestoreUsers(outUserList)

    ' again, show the current list of removed users
    ' it should not contain the users that were restored
    removedUsers = displaySettings.GetRemovedUsers()

    message = "Current list of removed users: "
    If removedUsers.Count > 0 Then
        For Each user As [String] In removedUsers
            message += vbLf + user
        Next
    Else
        message = "[Empty]"
    End If

    TaskDialog.Show("Removed Users Restored", message)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

WorksharingDisplaySettings Class


WorksharingDisplaySettings.RestoreUsers Method

WorksharingDisplaySettingsRestoreUsers Method

Adds users back to the list of displayed users and permits customization of the graphics. Any usernames that are not currently removed will be ignored. Returns the number of users who were actually restored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int RestoreUsers(
    ICollection<string> usersToRestore
)
Public Function RestoreUsers (
    usersToRestore As ICollection(Of String)
) As Integer
public:
int RestoreUsers(
    ICollection<String^>^ usersToRestore
)
member RestoreUsers :
        usersToRestore : ICollection<string> -> int

Parameters

usersToRestore ICollection String
The usernames of the users to restore. Any usernames that are not currently removed will be ignored.

Return Value

Int32
The number of usernames that were actually restored.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
This is the opposite of removing users. Note that the user will be shown with default graphic overrides - any customizations that existed prior to removing the user will not be restored.
See Also

Reference

WorksharingDisplaySettings Class


WorksharingDisplaySettings.SetGraphicOverrides Method

WorksharingDisplaySettingsSetGraphicOverrides Method

Overload List
 | Name | Description
 | SetGraphicOverrides(CheckoutStatus, WorksharingDisplayGraphicSettings) | Sets the graphic overrides assigned to elements with a particular ownership status.
Public method | SetGraphicOverrides(ModelUpdatesStatus, WorksharingDisplayGraphicSettings) | Sets the graphic overrides assigned to elements with a particular status in the central model.
Public method | SetGraphicOverrides(String, WorksharingDisplayGraphicSettings) | Sets the graphic overrides assigned to elements owned by a particular user. The username cannot be on the list of removed usernames.
Public method | SetGraphicOverrides(WorksetId, WorksharingDisplayGraphicSettings) | Sets the graphic overrides assigned to elements in a particular user workset.
Top
See Also

Reference

WorksharingDisplaySettings Class


WorksharingDisplaySettings.SetGraphicOverrides(CheckoutStatus, WorksharingDisplayGraphicSettings) Method

WorksharingDisplaySettingsSetGraphicOverrides(CheckoutStatus, WorksharingDisplayGraphicSettings) Method

Sets the graphic overrides assigned to elements with a particular ownership status.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetGraphicOverrides(
    CheckoutStatus status,
    WorksharingDisplayGraphicSettings overrides
)
Public Sub SetGraphicOverrides (
    status As CheckoutStatus,
    overrides As WorksharingDisplayGraphicSettings
)
public:
void SetGraphicOverrides(
    CheckoutStatus status,
    WorksharingDisplayGraphicSettings^ overrides
)
member SetGraphicOverrides :
        status : CheckoutStatus *
        overrides : WorksharingDisplayGraphicSettings -> unit

Parameters

status CheckoutStatus
The ownership status of interest.
overrides WorksharingDisplayGraphicSettings
The desired graphic overrides for this ownership status.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Example
C#
VB
C++
F#
Copy
public void SetWorksharingDisplaySettings(Document doc, WorksetId worksetId, String userName)
{
    String message = String.Empty;

    // get or create a WorksharingDisplaySettings current active document
    WorksharingDisplaySettings displaySettings = WorksharingDisplaySettings.GetOrCreateWorksharingDisplaySettings(doc);

    // set a new graphicSettings for CheckoutStatus - NotOwned
    WorksharingDisplayGraphicSettings graphicSettings = new WorksharingDisplayGraphicSettings(true, new Color(255, 0, 0));
    displaySettings.SetGraphicOverrides(CheckoutStatus.NotOwned, graphicSettings);

    // set a new graphicSettings for ModelUpdatesStatus - CurrentWithCentral
    graphicSettings = new WorksharingDisplayGraphicSettings(true, new Color(128, 128, 0));
    displaySettings.SetGraphicOverrides(ModelUpdatesStatus.CurrentWithCentral, graphicSettings);

    // set a new graphicSettings by a given userName
    graphicSettings = new WorksharingDisplayGraphicSettings(true, new Color(0, 255, 0));
    displaySettings.SetGraphicOverrides(userName, graphicSettings);

    // set a new graphicSettings by a given workset Id
    graphicSettings = new WorksharingDisplayGraphicSettings(true, new Color(0, 0, 255));
    displaySettings.SetGraphicOverrides(worksetId, graphicSettings);
}
Public Sub SetWorksharingDisplaySettings(doc As Document, worksetId As WorksetId, userName As [String])
    Dim message As [String] = [String].Empty

    ' get or create a WorksharingDisplaySettings current active document
    Dim displaySettings As WorksharingDisplaySettings = WorksharingDisplaySettings.GetOrCreateWorksharingDisplaySettings(doc)

    ' set a new graphicSettings for CheckoutStatus - NotOwned
    Dim graphicSettings As New WorksharingDisplayGraphicSettings(True, New Color(255, 0, 0))
    displaySettings.SetGraphicOverrides(CheckoutStatus.NotOwned, graphicSettings)

    ' set a new graphicSettings for ModelUpdatesStatus - CurrentWithCentral
    graphicSettings = New WorksharingDisplayGraphicSettings(True, New Color(128, 128, 0))
    displaySettings.SetGraphicOverrides(ModelUpdatesStatus.CurrentWithCentral, graphicSettings)

    ' set a new graphicSettings by a given userName
    graphicSettings = New WorksharingDisplayGraphicSettings(True, New Color(0, 255, 0))
    displaySettings.SetGraphicOverrides(userName, graphicSettings)

    ' set a new graphicSettings by a given workset Id
    graphicSettings = New WorksharingDisplayGraphicSettings(True, New Color(0, 0, 255))
    displaySettings.SetGraphicOverrides(worksetId, graphicSettings)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

WorksharingDisplaySettings Class
SetGraphicOverrides Overload


WorksharingDisplaySettings.SetGraphicOverrides(ModelUpdatesStatus, WorksharingDisplayGraphicSettings) Method

WorksharingDisplaySettingsSetGraphicOverrides(ModelUpdatesStatus, WorksharingDisplayGraphicSettings) Method

Sets the graphic overrides assigned to elements with a particular status in the central model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetGraphicOverrides(
    ModelUpdatesStatus status,
    WorksharingDisplayGraphicSettings overrides
)
Public Sub SetGraphicOverrides (
    status As ModelUpdatesStatus,
    overrides As WorksharingDisplayGraphicSettings
)
public:
void SetGraphicOverrides(
    ModelUpdatesStatus status,
    WorksharingDisplayGraphicSettings^ overrides
)
member SetGraphicOverrides :
        status : ModelUpdatesStatus *
        overrides : WorksharingDisplayGraphicSettings -> unit

Parameters

status ModelUpdatesStatus
The status in the central model.
overrides WorksharingDisplayGraphicSettings
The desired graphic overrides for this status.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

WorksharingDisplaySettings Class
SetGraphicOverrides Overload


WorksharingDisplaySettings.SetGraphicOverrides(String, WorksharingDisplayGraphicSettings) Method

WorksharingDisplaySettingsSetGraphicOverrides(String, WorksharingDisplayGraphicSettings) Method

Sets the graphic overrides assigned to elements owned by a particular user. The username cannot be on the list of removed usernames.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetGraphicOverrides(
    string username,
    WorksharingDisplayGraphicSettings overrides
)
Public Sub SetGraphicOverrides (
    username As String,
    overrides As WorksharingDisplayGraphicSettings
)
public:
void SetGraphicOverrides(
    String^ username,
    WorksharingDisplayGraphicSettings^ overrides
)
member SetGraphicOverrides :
        username : string *
        overrides : WorksharingDisplayGraphicSettings -> unit

Parameters

username String
The username of the desired user.
overrides WorksharingDisplayGraphicSettings
The desired graphic overrides for this user.
Exceptions
Exception | Condition
ArgumentException | The username is on the list of removed users.
ArgumentNullException | A non-optional argument was null
Remarks
Note that you can specify usernames which do not yet exist in the document's user table.
See Also

Reference

WorksharingDisplaySettings Class
SetGraphicOverrides Overload


WorksharingDisplaySettings.SetGraphicOverrides(WorksetId, WorksharingDisplayGraphicSettings) Method

WorksharingDisplaySettingsSetGraphicOverrides(WorksetId, WorksharingDisplayGraphicSettings) Method

Sets the graphic overrides assigned to elements in a particular user workset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetGraphicOverrides(
    WorksetId worksetId,
    WorksharingDisplayGraphicSettings overrides
)
Public Sub SetGraphicOverrides (
    worksetId As WorksetId,
    overrides As WorksharingDisplayGraphicSettings
)
public:
void SetGraphicOverrides(
    WorksetId^ worksetId,
    WorksharingDisplayGraphicSettings^ overrides
)
member SetGraphicOverrides :
        worksetId : WorksetId *
        overrides : WorksharingDisplayGraphicSettings -> unit

Parameters

worksetId WorksetId
The workset of interest, which must be a user workset.
overrides WorksharingDisplayGraphicSettings
The desired graphic overrides for this workset.
Exceptions
Exception | Condition
ArgumentException | worksetId does not correspond to a user workset in the document containing this WorksharingDisplaySettings.
ArgumentNullException | A non-optional argument was null
See Also

Reference

WorksharingDisplaySettings Class
SetGraphicOverrides Overload


WorksharingDisplaySettings.UserHasGraphicOverrides Method

WorksharingDisplaySettingsUserHasGraphicOverrides Method

Checks whether there are graphic overrides that would apply to elements owned by the given user in the "Individual Owners" display mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UserHasGraphicOverrides(
    string username
)
Public Function UserHasGraphicOverrides (
    username As String
) As Boolean
public:
bool UserHasGraphicOverrides(
    String^ username
)
member UserHasGraphicOverrides :
        username : string -> bool

Parameters

username String
The username to check

Return Value

Boolean
True if there are graphic overrides assigned to the username, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
There will always be graphic overrides for all users included in the user table. In addition, there may be other users who have been explicitly assigned overrides.
See Also

Reference

WorksharingDisplaySettings Class


WorksharingSaveAsOptions Class

This class contains options specific to worksharing SaveAs.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBWorksharingSaveAsOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class WorksharingSaveAsOptions : IDisposable
Public Class WorksharingSaveAsOptions
    Implements IDisposable
public ref class WorksharingSaveAsOptions : IDisposable
type WorksharingSaveAsOptions =
    class
        interface IDisposable
    end

The WorksharingSaveAsOptions type exposes the following members.

Constructors
 | Name | Description
Public method | WorksharingSaveAsOptions | Constructs a new WorksharingSaveAsOptions with default settings.
Top
Properties
 | Name | Description
Public property | ClearTransmitted | For a transmitted model opened with DetachAndPreserveWorksets, clear its transmitted flag in the Save/SaveAs operation.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OpenWorksetsDefault | The default set of user-worksets to open when opening the model in the UI. Default is AskUserToSpecify.
Public property | SaveAsCentral | Whether to save the new model as a central instead of local model. True: save as a central model. Default is false: save as a local model.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the WorksharingSaveAsOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


WorksharingSaveAsOptions Constructor

Constructs a new WorksharingSaveAsOptions with default settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WorksharingSaveAsOptions()
Public Sub New
public:
WorksharingSaveAsOptions()
new : unit -> WorksharingSaveAsOptions
See Also

Reference

WorksharingSaveAsOptions Class


WorksharingSaveAsOptions Properties

The WorksharingSaveAsOptions type exposes the following members.

Properties
 | Name | Description
Public property | ClearTransmitted | For a transmitted model opened with DetachAndPreserveWorksets, clear its transmitted flag in the Save/SaveAs operation.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OpenWorksetsDefault | The default set of user-worksets to open when opening the model in the UI. Default is AskUserToSpecify.
Public property | SaveAsCentral | Whether to save the new model as a central instead of local model. True: save as a central model. Default is false: save as a local model.
Top
See Also

Reference

WorksharingSaveAsOptions Class


WorksharingSaveAsOptions.ClearTransmitted Property

WorksharingSaveAsOptionsClearTransmitted Property

For a transmitted model opened with DetachAndPreserveWorksets, clear its transmitted flag in the Save/SaveAs operation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ClearTransmitted { get; set; }
Public Property ClearTransmitted As Boolean
    Get
    Set
public:
property bool ClearTransmitted {
    bool get ();
    void set (bool value);
}
member ClearTransmitted : bool with get, set

Property Value

Boolean
See Also

Reference

WorksharingSaveAsOptions Class


WorksharingSaveAsOptions.IsValidObject Property

WorksharingSaveAsOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

WorksharingSaveAsOptions Class


WorksharingSaveAsOptions.OpenWorksetsDefault Property

WorksharingSaveAsOptionsOpenWorksetsDefault Property

The default set of user-worksets to open when opening the model in the UI. Default is AskUserToSpecify.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SimpleWorksetConfiguration OpenWorksetsDefault { get; set; }
Public Property OpenWorksetsDefault As SimpleWorksetConfiguration
    Get
    Set
public:
property SimpleWorksetConfiguration OpenWorksetsDefault {
    SimpleWorksetConfiguration get ();
    void set (SimpleWorksetConfiguration value);
}
member OpenWorksetsDefault : SimpleWorksetConfiguration with get, set

Property Value

SimpleWorksetConfiguration
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

WorksharingSaveAsOptions Class


WorksharingSaveAsOptions.SaveAsCentral Property

WorksharingSaveAsOptionsSaveAsCentral Property

Whether to save the new model as a central instead of local model. True: save as a central model. Default is false: save as a local model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SaveAsCentral { get; set; }
Public Property SaveAsCentral As Boolean
    Get
    Set
public:
property bool SaveAsCentral {
    bool get ();
    void set (bool value);
}
member SaveAsCentral : bool with get, set

Property Value

Boolean
Remarks
Must be true for a model where the model has not yet been saved as a central after either worksharing has just been enabled or the model was opened detached from central and .
See Also

Reference

WorksharingSaveAsOptions Class


WorksharingSaveAsOptions Methods

The WorksharingSaveAsOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

WorksharingSaveAsOptions Class


WorksharingSaveAsOptions.Dispose Method

WorksharingSaveAsOptionsDispose Method

Releases all resources used by the WorksharingSaveAsOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

WorksharingSaveAsOptions Class


WorksharingTooltipInfo Class

Worksharing information about a single element suitable for display in an in-canvas tooltip.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBWorksharingTooltipInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class WorksharingTooltipInfo : IDisposable
Public Class WorksharingTooltipInfo
    Implements IDisposable
public ref class WorksharingTooltipInfo : IDisposable
type WorksharingTooltipInfo =
    class
        interface IDisposable
    end

The WorksharingTooltipInfo type exposes the following members.

Properties
 | Name | Description
Public property | Creator | The user name of the user who created the element.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LastChangedBy | The user name of the most recent user who saved a user change of this element to the central model.
Public property | Owner | The current owner of the element or empty string if no one owns the element.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the WorksharingTooltipInfo
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRequesters | The ordered list of unique user names of users who have outstanding editing requests for the specified element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Some or all of the strings may be empty.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


WorksharingTooltipInfo Properties

The WorksharingTooltipInfo type exposes the following members.

Properties
 | Name | Description
Public property | Creator | The user name of the user who created the element.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | LastChangedBy | The user name of the most recent user who saved a user change of this element to the central model.
Public property | Owner | The current owner of the element or empty string if no one owns the element.
Top
See Also

Reference

WorksharingTooltipInfo Class


WorksharingTooltipInfo.Creator Property

WorksharingTooltipInfoCreator Property

The user name of the user who created the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Creator { get; }
Public ReadOnly Property Creator As String
    Get
public:
property String^ Creator {
    String^ get ();
}
member Creator : string with get

Property Value

String
See Also

Reference

WorksharingTooltipInfo Class


WorksharingTooltipInfo.IsValidObject Property

WorksharingTooltipInfoIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

WorksharingTooltipInfo Class


WorksharingTooltipInfo.LastChangedBy Property

WorksharingTooltipInfoLastChangedBy Property

The user name of the most recent user who saved a user change of this element to the central model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string LastChangedBy { get; }
Public ReadOnly Property LastChangedBy As String
    Get
public:
property String^ LastChangedBy {
    String^ get ();
}
member LastChangedBy : string with get

Property Value

String
See Also

Reference

WorksharingTooltipInfo Class


WorksharingTooltipInfo.Owner Property

WorksharingTooltipInfoOwner Property

The current owner of the element or empty string if no one owns the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Owner { get; }
Public ReadOnly Property Owner As String
    Get
public:
property String^ Owner {
    String^ get ();
}
member Owner : string with get

Property Value

String
See Also

Reference

WorksharingTooltipInfo Class


WorksharingTooltipInfo Methods

The WorksharingTooltipInfo type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetRequesters | The ordered list of unique user names of users who have outstanding editing requests for the specified element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

WorksharingTooltipInfo Class


WorksharingTooltipInfo.Dispose Method

WorksharingTooltipInfoDispose Method

Releases all resources used by the WorksharingTooltipInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

WorksharingTooltipInfo Class


WorksharingTooltipInfo.GetRequesters Method

WorksharingTooltipInfoGetRequesters Method

The ordered list of unique user names of users who have outstanding editing requests for the specified element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<string> GetRequesters()
Public Function GetRequesters As IList(Of String)
public:
IList<String^>^ GetRequesters()
member GetRequesters : unit -> IList<string>

Return Value

IList String
The ordered list of unique user names.
Remarks
The list is ordered by who placed the earliest request. If the list is empty it means that nobody is currently requesting the specified element.
See Also

Reference

WorksharingTooltipInfo Class


WorksharingUtils Class

A static class that contains utility functions related to worksharing.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBWorksharingUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class WorksharingUtils : IDisposable
Public Class WorksharingUtils
    Implements IDisposable
public ref class WorksharingUtils : IDisposable
type WorksharingUtils =
    class
        interface IDisposable
    end

The WorksharingUtils type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
 | CheckoutElements(Document, ICollectionElementId) | Obtains ownership for the current user of as many specified elements as possible.
 | CheckoutElements(Document, ISetElementId, TransactWithCentralOptions) | Obtains ownership for the current user of as many specified elements as possible.
 | CheckoutWorksets(Document, ICollectionWorksetId) | Obtains ownership for the current user of as many specified worksets as possible.
 | CheckoutWorksets(Document, ISetWorksetId, TransactWithCentralOptions) | Obtains ownership for the current user of as many specified worksets as possible.
 | CreateNewLocal | Takes a path to a central model and copies the model into a new local file for the current user.
Public method | Dispose | Releases all resources used by the WorksharingUtils
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | GetCheckoutStatus(Document, ElementId) | Gets the ownership status of an element.
 | GetCheckoutStatus(Document, ElementId, String) | Gets the ownership status and outputs the owner of an element.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
 | GetModelUpdatesStatus | Gets the status of a single element in the central model.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetUserWorksetInfo | Gets information about user worksets in a workshared model file, without fully opening the file.
 | GetWorksharingTooltipInfo | Gets worksharing information about an element to display in an in-canvas tooltip.
 | RelinquishOwnership | Relinquishes ownership by the current user of as many specified elements and worksets as possible, and grants element ownership requested by other users on a first-come, first-served basis.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks

Return values from inquiries about the worksharing status of elements or worksets rely on local caching of information from the central model so it is possible that the information is out of date. Because of this, the return value is suitable for reporting to an interactive user (e.g. via a mechanism similar to Worksharing display mode), but cannot be considered a reliable indication of whether the element can be immediately edited by the application. To make an immediate attempt to edit elements, use [!:CheckoutElements()] and check the return status, then confirm if the elements are up to date.

In addition, information about the current user may not be reliable while Revit is in the middle of an editing transaction. For example, if you move an unowned wall from an unowned workset to a workset you own, then before you explicitly or Revit automatically checks out the wall for you, GetCheckoutStatus() might erroneously tell you CheckoutStatus.OwnedByCurrentUser because although the official (as seen in central and by other users) owner is no one, locally it looks like you already own it since it belongs to a workset you own.

For operations that interact with central (as opposed to use only cached values), Revit might opportunistically refresh some editing permissions or check the status of editing requests.

Some useful definitions to keep in mind follow:

  • The owner of a workset: the user who has the Workset checked out; this could be nobody (the empty string).
  • The borrower of an element: the user who has explicitly checked out ("borrowed") the Element; this could be nobody.
  • The owner of an element: If element is borrowed (i.e. explicitly checked out), then the element's owner is the borrower, otherwise it is the owner or the workset containing the element.

Example
C#
VB
C++
F#
Copy
public void GetElementWorksharingInfo(Document doc, Element elem)
{
    String message = String.Empty;
    message += "Element Id: " + elem.Id;

    // The workset the element belongs to
    WorksetId worksetId = elem.WorksetId;
    message += ("\nWorkset Id : " + worksetId.ToString());

    // Model Updates Status of the element
    ModelUpdatesStatus updateStatus = WorksharingUtils.GetModelUpdatesStatus(doc, elem.Id);
    message += ("\nUpdate status : " + updateStatus.ToString());

    // Checkout Status of the element
    CheckoutStatus checkoutStatus = WorksharingUtils.GetCheckoutStatus(doc, elem.Id);
    message += ("\nCheckout status : " + checkoutStatus.ToString());

    // Getting WorksharingTooltipInfo of a given element Id
    WorksharingTooltipInfo tooltipInfo = WorksharingUtils.GetWorksharingTooltipInfo(doc, elem.Id);
    message += ("\nCreator : " + tooltipInfo.Creator);
    message += ("\nCurrent Owner : " + tooltipInfo.Owner);
    message += ("\nLast Changed by : " + tooltipInfo.LastChangedBy);

    Autodesk.Revit.UI.TaskDialog.Show("GetElementWorksharingInfo", message);
}
Public Sub GetElementWorksharingInfo(doc As Document, elem As Element)
    Dim message As [String] = [String].Empty
    message += "Element Id: " + elem.Id.ToString

    ' The workset the element belongs to
    Dim worksetId As WorksetId = elem.WorksetId
    message += (vbLf & "Workset Id : " + worksetId.ToString())

    ' Model Updates Status of the element
    Dim updateStatus As ModelUpdatesStatus = WorksharingUtils.GetModelUpdatesStatus(doc, elem.Id)
    message += (vbLf & "Update status : " + updateStatus.ToString())

    ' Checkout Status of the element
    Dim checkoutStatus As CheckoutStatus = WorksharingUtils.GetCheckoutStatus(doc, elem.Id)
    message += (vbLf & "Checkout status : " + checkoutStatus.ToString())

    ' Getting WorksharingTooltipInfo of a given element Id
    Dim tooltipInfo As WorksharingTooltipInfo = WorksharingUtils.GetWorksharingTooltipInfo(doc, elem.Id)
    message += (vbLf & "Creator : " + tooltipInfo.Creator)
    message += (vbLf & "Current Owner : " + tooltipInfo.Owner)
    message += (vbLf & "Last Changed by : " + tooltipInfo.LastChangedBy)

    Autodesk.Revit.UI.TaskDialog.Show("GetElementWorksharingInfo", message)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


WorksharingUtils Properties

The WorksharingUtils type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

WorksharingUtils Class


WorksharingUtils.IsValidObject Property

WorksharingUtilsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

WorksharingUtils Class


WorksharingUtils Methods

The WorksharingUtils type exposes the following members.

Methods
 | Name | Description
 | CheckoutElements(Document, ICollectionElementId) | Obtains ownership for the current user of as many specified elements as possible.
 | CheckoutElements(Document, ISetElementId, TransactWithCentralOptions) | Obtains ownership for the current user of as many specified elements as possible.
 | CheckoutWorksets(Document, ICollectionWorksetId) | Obtains ownership for the current user of as many specified worksets as possible.
 | CheckoutWorksets(Document, ISetWorksetId, TransactWithCentralOptions) | Obtains ownership for the current user of as many specified worksets as possible.
 | CreateNewLocal | Takes a path to a central model and copies the model into a new local file for the current user.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | GetCheckoutStatus(Document, ElementId) | Gets the ownership status of an element.
 | GetCheckoutStatus(Document, ElementId, String) | Gets the ownership status and outputs the owner of an element.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
 | GetModelUpdatesStatus | Gets the status of a single element in the central model.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetUserWorksetInfo | Gets information about user worksets in a workshared model file, without fully opening the file.
 | GetWorksharingTooltipInfo | Gets worksharing information about an element to display in an in-canvas tooltip.
 | RelinquishOwnership | Relinquishes ownership by the current user of as many specified elements and worksets as possible, and grants element ownership requested by other users on a first-come, first-served basis.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

WorksharingUtils Class


WorksharingUtils.CheckoutElements Method

WorksharingUtilsCheckoutElements Method

Overload List
Name | Description
CheckoutElements(Document, ICollectionElementId) | Obtains ownership for the current user of as many specified elements as possible.
CheckoutElements(Document, ISetElementId, TransactWithCentralOptions) | Obtains ownership for the current user of as many specified elements as possible.
Top
See Also

Reference

WorksharingUtils Class


WorksharingUtils.CheckoutElements(Document, ICollection<ElementId>) Method

WorksharingUtilsCheckoutElements(Document, ICollectionElementId) Method

Obtains ownership for the current user of as many specified elements as possible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ICollection<ElementId> CheckoutElements(
    Document document,
    ICollection<ElementId> elementsToCheckout
)
Public Shared Function CheckoutElements (
    document As Document,
    elementsToCheckout As ICollection(Of ElementId)
) As ICollection(Of ElementId)
public:
static ICollection<ElementId^>^ CheckoutElements(
    Document^ document,
    ICollection<ElementId^>^ elementsToCheckout
)
static member CheckoutElements :
        document : Document *
        elementsToCheckout : ICollection<ElementId> -> ICollection<ElementId>

Parameters

document Document
The document containing the elements.
elementsToCheckout ICollection ElementId
The ids of the elements to attempt to check out.

Return Value

ICollection ElementId
The ids of all specified elements that are now owned (but possibly out of date), including all that were owned prior to the function call.
Exceptions
Exception | Condition
ArgumentException | document is not a workshared document. -or- document is not a primary document, it is a linked document. -or- One or more elements in elementsToCheckout do not exist in the document. -or- Saving is not allowed in the current application mode.
ArgumentNullException | A non-optional argument was null
CentralFileCommunicationException | Editing permissions for the file-based central model could not be accessed for write, e.g. the network is down, central is missing, or central is read-only.
CentralModelAccessDeniedException | Access to the central model was denied. A possible reason is because the model was under maintenance.
CentralModelContentionException | Editing permissions for the central model are locked and the last attempt to lock was canceled. -or- The central model is being accessed by another client.
CentralModelException | An error has occurred while checking out worksets or elements. -or- The central model is overwritten by other user. -or- The central model is missing. -or- An internal error happened on the central model, please contact the server administrator.
CentralModelVersionArchivedException | Last central version merged into the local model has been archived in the central model. This exception could only be thrown from cloud models.
RevitServerCommunicationException | The server-based central model could not be accessed because of a network communication error.
RevitServerInternalException | An internal error happened on the server, please contact the server administrator.
Remarks

For best performance, checkout all elements in one big call, rather than many small calls.

Revit may check out additional elements that are needed to check out the elements you requested. For example, if you request an element that is in a group, Revit will check out the entire group.

When there comes a contention error when locking the central model, this API would wait and retry endlessly until getting the lock of the central model.

Example
C#
VB
C++
F#
Copy
void CheckoutAllRooms(Document doc)
{
    FilteredElementCollector collector = new FilteredElementCollector(doc);
    ICollection<ElementId> rooms = collector.WherePasses(new RoomFilter()).ToElementIds();
    ICollection<ElementId> checkoutelements = WorksharingUtils.CheckoutElements(doc, rooms);
    TaskDialog.Show("Checked out elements", "Number of elements checked out: " + checkoutelements.Count);
}
Private Sub CheckoutAllRooms(doc As Document)
    Dim collector As New FilteredElementCollector(doc)
    Dim rooms As ICollection(Of ElementId) = collector.WherePasses(New RoomFilter()).ToElementIds()
    Dim checkoutelements As ICollection(Of ElementId) = WorksharingUtils.CheckoutElements(doc, rooms)
    TaskDialog.Show("Checked out elements", "Number of elements checked out: " + checkoutelements.Count)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

WorksharingUtils Class
CheckoutElements Overload


WorksharingUtils.CheckoutElements(Document, ISet<ElementId>, TransactWithCentralOptions) Method

WorksharingUtilsCheckoutElements(Document, ISetElementId, TransactWithCentralOptions) Method

Obtains ownership for the current user of as many specified elements as possible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ISet<ElementId> CheckoutElements(
    Document document,
    ISet<ElementId> elementsToCheckout,
    TransactWithCentralOptions options
)
Public Shared Function CheckoutElements (
    document As Document,
    elementsToCheckout As ISet(Of ElementId),
    options As TransactWithCentralOptions
) As ISet(Of ElementId)
public:
static ISet<ElementId^>^ CheckoutElements(
    Document^ document,
    ISet<ElementId^>^ elementsToCheckout,
    TransactWithCentralOptions^ options
)
static member CheckoutElements :
        document : Document *
        elementsToCheckout : ISet<ElementId> *
        options : TransactWithCentralOptions -> ISet<ElementId>

Parameters

document Document
The document containing the elements.
elementsToCheckout ISet ElementId
The ids of the elements to attempt to check out.
options TransactWithCentralOptions
Options to customize access to the central model. is allowed and means no customization.

Return Value

ISet ElementId
The ids of all specified elements that are now owned (but possibly out of date), including all that were owned prior to the function call.
Exceptions
Exception | Condition
ArgumentException | document is not a workshared document. -or- document is not a primary document, it is a linked document. -or- One or more elements in elementsToCheckout do not exist in the document. -or- Saving is not allowed in the current application mode.
ArgumentNullException | A non-optional argument was null
CentralFileCommunicationException | Editing permissions for the file-based central model could not be accessed for write, e.g. the network is down, central is missing, or central is read-only.
CentralModelAccessDeniedException | Access to the central model was denied. A possible reason is because the model was under maintenance.
CentralModelContentionException | Editing permissions for the central model are locked and the last attempt to lock was canceled. -or- The central model is being accessed by another client.
CentralModelException | An error has occurred while checking out worksets or elements. -or- The central model is overwritten by other user. -or- The central model is missing. -or- An internal error happened on the central model, please contact the server administrator.
CentralModelVersionArchivedException | Last central version merged into the local model has been archived in the central model. This exception could only be thrown from cloud models.
RevitServerCommunicationException | The server-based central model could not be accessed because of a network communication error.
RevitServerInternalException | An internal error happened on the server, please contact the server administrator.
Remarks

For best performance, checkout all elements in one big call, rather than many small calls.

Revit may check out additional elements that are needed to check out the elements you requested. For example, if you request an element that is in a group, Revit will check out the entire group.

See Also

Reference

WorksharingUtils Class
CheckoutElements Overload


WorksharingUtils.CheckoutWorksets Method

WorksharingUtilsCheckoutWorksets Method

Overload List
Name | Description
CheckoutWorksets(Document, ICollectionWorksetId) | Obtains ownership for the current user of as many specified worksets as possible.
CheckoutWorksets(Document, ISetWorksetId, TransactWithCentralOptions) | Obtains ownership for the current user of as many specified worksets as possible.
Top
See Also

Reference

WorksharingUtils Class


WorksharingUtils.CheckoutWorksets(Document, ICollection<WorksetId>) Method

WorksharingUtilsCheckoutWorksets(Document, ICollectionWorksetId) Method

Obtains ownership for the current user of as many specified worksets as possible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ICollection<WorksetId> CheckoutWorksets(
    Document document,
    ICollection<WorksetId> worksetsToCheckout
)
Public Shared Function CheckoutWorksets (
    document As Document,
    worksetsToCheckout As ICollection(Of WorksetId)
) As ICollection(Of WorksetId)
public:
static ICollection<WorksetId^>^ CheckoutWorksets(
    Document^ document,
    ICollection<WorksetId^>^ worksetsToCheckout
)
static member CheckoutWorksets :
        document : Document *
        worksetsToCheckout : ICollection<WorksetId> -> ICollection<WorksetId>

Parameters

document Document
The document containing the worksets.
worksetsToCheckout ICollection WorksetId
The ids of the worksets to attempt to check out.

Return Value

ICollection WorksetId
The ids of all specified worksets that are now owned, including all that were owned prior to the function call.
Exceptions
Exception | Condition
ArgumentException | document is not a workshared document. -or- document is not a primary document, it is a linked document. -or- document is read-only: It cannot be modified. -or- document has an open editing transaction and is accepting changes. -or- There are one or more ids with no corresponding workset. -or- Saving is not allowed in the current application mode.
ArgumentNullException | A non-optional argument was null
CentralFileCommunicationException | The file-based central model could not be reached, e.g. the network is down or the file server is down.
CentralModelAccessDeniedException | Access to the central model was denied due to lack of access privileges. -or- Access to the central model was denied. A possible reason is because the model was under maintenance.
CentralModelContentionException | The central model are locked by another client.
CentralModelException | The central model is overwritten by other user. -or- The central model is missing. -or- An internal error happened on the central model, please contact the server administrator.
CentralModelVersionArchivedException | Last central version merged into the local model has been archived in the central model. This exception could only be thrown from cloud models.
InvalidOperationException | Operation is not permitted when there is any open sub-transaction, transaction, or transaction group.
RevitServerCommunicationException | The server-based central model could not be accessed because of a network communication error.
RevitServerInternalException | An internal error happened on the server, please contact the server administrator.
Remarks

For best performance, check out all worksets in one big call, rather than many small calls.

When there comes a contention error when locking the central model, this API would wait and retry endlessly until getting the lock of the central model.

Example
C#
VB
C++
F#
Copy
void CheckoutAllViewWorksets(Document doc)
{
    FilteredWorksetCollector collector = new FilteredWorksetCollector(doc);

    // find all view worksets
    collector.OfKind(WorksetKind.ViewWorkset);
    ICollection<WorksetId> viewworksets = collector.ToWorksetIds();
    ICollection<WorksetId> checkoutworksets = WorksharingUtils.CheckoutWorksets(doc, viewworksets);
    TaskDialog.Show("Checked out worksets", "Number of worksets checked out: " + checkoutworksets.Count);
}
Private Sub CheckoutAllViewWorksets(doc As Document)
    Dim collector As New FilteredWorksetCollector(doc)

    ' find all view worksets
    collector.OfKind(WorksetKind.ViewWorkset)
    Dim viewworksets As ICollection(Of WorksetId) = collector.ToWorksetIds()
    Dim checkoutworksets As ICollection(Of WorksetId) = WorksharingUtils.CheckoutWorksets(doc, viewworksets)
    TaskDialog.Show("Checked out worksets", "Number of worksets checked out: " + checkoutworksets.Count)
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

WorksharingUtils Class
CheckoutWorksets Overload


WorksharingUtils.CheckoutWorksets(Document, ISet<WorksetId>, TransactWithCentralOptions) Method

WorksharingUtilsCheckoutWorksets(Document, ISetWorksetId, TransactWithCentralOptions) Method

Obtains ownership for the current user of as many specified worksets as possible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ISet<WorksetId> CheckoutWorksets(
    Document document,
    ISet<WorksetId> worksetsToCheckout,
    TransactWithCentralOptions options
)
Public Shared Function CheckoutWorksets (
    document As Document,
    worksetsToCheckout As ISet(Of WorksetId),
    options As TransactWithCentralOptions
) As ISet(Of WorksetId)
public:
static ISet<WorksetId^>^ CheckoutWorksets(
    Document^ document,
    ISet<WorksetId^>^ worksetsToCheckout,
    TransactWithCentralOptions^ options
)
static member CheckoutWorksets :
        document : Document *
        worksetsToCheckout : ISet<WorksetId> *
        options : TransactWithCentralOptions -> ISet<WorksetId>

Parameters

document Document
The document containing the worksets.
worksetsToCheckout ISet WorksetId
The ids of the worksets to attempt to check out.
options TransactWithCentralOptions
Options to customize access to the central model. is allowed and means no customization.

Return Value

ISet WorksetId
The ids of all specified worksets that are now owned, including all that were owned prior to the function call.
Exceptions
Exception | Condition
ArgumentException | document is not a workshared document. -or- document is not a primary document, it is a linked document. -or- document is read-only: It cannot be modified. -or- document has an open editing transaction and is accepting changes. -or- There are one or more ids with no corresponding workset. -or- Saving is not allowed in the current application mode.
ArgumentNullException | A non-optional argument was null
CentralFileCommunicationException | The file-based central model could not be reached, e.g. the network is down or the file server is down.
CentralModelAccessDeniedException | Access to the central model was denied due to lack of access privileges. -or- Access to the central model was denied. A possible reason is because the model was under maintenance.
CentralModelContentionException | The central model are locked by another client.
CentralModelException | The central model is overwritten by other user. -or- The central model is missing. -or- An internal error happened on the central model, please contact the server administrator.
CentralModelVersionArchivedException | Last central version merged into the local model has been archived in the central model. This exception could only be thrown from cloud models.
InvalidOperationException | Operation is not permitted when there is any open sub-transaction, transaction, or transaction group.
RevitServerCommunicationException | The server-based central model could not be accessed because of a network communication error.
RevitServerInternalException | An internal error happened on the server, please contact the server administrator.
Remarks
For best performance, check out all worksets in one big call, rather than many small calls.
See Also

Reference

WorksharingUtils Class
CheckoutWorksets Overload


WorksharingUtils.CreateNewLocal Method

WorksharingUtilsCreateNewLocal Method

Takes a path to a central model and copies the model into a new local file for the current user.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static void CreateNewLocal(
    ModelPath sourcePath,
    ModelPath targetPath
)
Public Shared Sub CreateNewLocal (
    sourcePath As ModelPath,
    targetPath As ModelPath
)
public:
static void CreateNewLocal(
    ModelPath^ sourcePath,
    ModelPath^ targetPath
)
static member CreateNewLocal :
        sourcePath : ModelPath *
        targetPath : ModelPath -> unit

Parameters

sourcePath ModelPath
The path to the central model.
targetPath ModelPath
The path to put the new local file.
Exceptions
Exception | Condition
ArgumentException | The given path sourcePath is a cloud path which is not supported in this method. -or- The model is not workshared. -or- The central model has not fully enabled worksharing. It must be opened and resaved to finish enabling worksharing. -or- The model is a local file. -or- The central model is not saved in the current Revit version. -or- The model is transmitted. -or- -or- The specified filepath is invalid.
ArgumentNullException | A non-optional argument was null
CentralModelAccessDeniedException | Access to the central model was denied due to lack of access privileges. -or- Access to the central model was denied. A possible reason is because the model was under maintenance.
CentralModelContentionException | The central model is locked by another user. -or- The central model is being accessed by another client.
CentralModelException | The central model is missing. -or- An internal error happened on the central model, please contact the server administrator.
FileArgumentAlreadyExistsException | The file or folder already exists and cannot be overwritten.
InvalidOperationException | This functionality is not available in Revit LT. -or- File already exists! -or- Revit Server does not support local models.
RevitServerCommunicationException | The server-based central model could not be accessed because of a network communication error.
RevitServerInternalException | An internal error happened on the server, please contact the server administrator.
See Also

Reference

WorksharingUtils Class


WorksharingUtils.Dispose Method

WorksharingUtilsDispose Method

Releases all resources used by the WorksharingUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

WorksharingUtils Class


WorksharingUtils.GetCheckoutStatus Method

WorksharingUtilsGetCheckoutStatus Method

Overload List
Name | Description
GetCheckoutStatus(Document, ElementId) | Gets the ownership status of an element.
GetCheckoutStatus(Document, ElementId, String) | Gets the ownership status and outputs the owner of an element.
Top
See Also

Reference

WorksharingUtils Class


WorksharingUtils.GetCheckoutStatus(Document, ElementId) Method

WorksharingUtilsGetCheckoutStatus(Document, ElementId) Method

Gets the ownership status of an element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static CheckoutStatus GetCheckoutStatus(
    Document document,
    ElementId elementId
)
Public Shared Function GetCheckoutStatus (
    document As Document,
    elementId As ElementId
) As CheckoutStatus
public:
static CheckoutStatus GetCheckoutStatus(
    Document^ document,
    ElementId^ elementId
)
static member GetCheckoutStatus :
        document : Document *
        elementId : ElementId -> CheckoutStatus

Parameters

document Document
The document containing the element.
elementId ElementId
The id of the element.

Return Value

CheckoutStatus
A summary of whether the element is unowned, owned by the current user, or owned by another user.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks

This method returns a locally cached value which may not be up to date with the current state of the element in the central. Because of this, the return value is suitable for reporting to an interactive user (e.g. via a mechanism similar to Worksharing display mode), but cannot be considered a reliable indication of whether the element can be immediately edited by the application. Also, the return value may not be dependable in the middle of a local transaction. See the remarks on WorksharingUtils for more details.

For performance reasons, the model is not validated to be workshared, and the element id is also not validated; the element will not be expanded.

See Also

Reference

WorksharingUtils Class
GetCheckoutStatus Overload


WorksharingUtils.GetCheckoutStatus(Document, ElementId, String) Method

WorksharingUtilsGetCheckoutStatus(Document, ElementId, String) Method

Gets the ownership status and outputs the owner of an element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static CheckoutStatus GetCheckoutStatus(
    Document document,
    ElementId elementId,
    out string owner
)
Public Shared Function GetCheckoutStatus (
    document As Document,
    elementId As ElementId,
    <OutAttribute> ByRef owner As String
) As CheckoutStatus
public:
static CheckoutStatus GetCheckoutStatus(
    Document^ document,
    ElementId^ elementId,
    [OutAttribute] String^% owner
)
static member GetCheckoutStatus :
        document : Document *
        elementId : ElementId *
        owner : string byref -> CheckoutStatus

Parameters

document Document
The document containing the element.
elementId ElementId
The id of the element.
owner String
The owner of the element, or an empty string if no one owns it.

Return Value

CheckoutStatus
An indication of whether the element is unowned, owned by the current user, or owned by another user.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks

This method returns a locally cached value which may not be up to date with the current state of the element in the central. Because of this, the return value is suitable for reporting to an interactive user (e.g. via a mechanism similar to Worksharing display mode), but cannot be considered a reliable indication of whether the element can be immediately edited by the application. Also, the return value may not be dependable in the middle of a local transaction. See the remarks on WorksharingUtils for more details.

For performance reasons, the model is not validated to be workshared, and the element id is also not validated; the element will not be expanded.

See Also

Reference

WorksharingUtils Class
GetCheckoutStatus Overload


WorksharingUtils.GetModelUpdatesStatus Method

WorksharingUtilsGetModelUpdatesStatus Method

Gets the status of a single element in the central model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ModelUpdatesStatus GetModelUpdatesStatus(
    Document document,
    ElementId elementId
)
Public Shared Function GetModelUpdatesStatus (
    document As Document,
    elementId As ElementId
) As ModelUpdatesStatus
public:
static ModelUpdatesStatus GetModelUpdatesStatus(
    Document^ document,
    ElementId^ elementId
)
static member GetModelUpdatesStatus :
        document : Document *
        elementId : ElementId -> ModelUpdatesStatus

Parameters

document Document
The document containing the element.
elementId ElementId
The id of the element.

Return Value

ModelUpdatesStatus
The status of the element in the local session versus the central model.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks

This method returns a locally cached value which may not be up to date with the current state of the element in the central. Because of this, the return value is suitable for reporting to an interactive user (e.g. via a mechanism similar to Worksharing display mode), but cannot be considered a reliable indication of whether the element can be immediately edited by the application. Also, the return value may not be dependable in the middle of a local transaction. See the remarks on WorksharingUtils for more details.

For performance reasons, the model is not validated to be workshared, and the element id is also not validated; the element will not be expanded.

Example
C#
VB
C++
F#
Copy
public static bool AttemptToCheckoutInAdvance(Element element)
{
    Document doc = element.Document;
    String categoryName = element.Category.Name;

    // Checkout attempt
    ICollection<ElementId> checkedOutIds = WorksharingUtils.CheckoutElements(doc, new ElementId[] { element.Id });

    // Confirm checkout
    bool checkedOutSuccessfully = checkedOutIds.Contains(element.Id);

    if (!checkedOutSuccessfully)
    {
        TaskDialog.Show("Element is not checked out", "Cannot edit the " + categoryName + " element - " +
                        "it was not checked out successfully and may be checked out to another.");
        return false;
    }

    // If element is updated in central or deleted in central, it is not editable
    ModelUpdatesStatus updatesStatus = WorksharingUtils.GetModelUpdatesStatus(doc, element.Id);
    if (updatesStatus == ModelUpdatesStatus.DeletedInCentral || updatesStatus == ModelUpdatesStatus.UpdatedInCentral)
    {
        TaskDialog.Show("Element is not up to date", "Cannot edit the " + categoryName + " element - " +
                        "it is not up to date with central, but it is checked out.");
        return false;
    }

    return true;
}
Public Shared Function AttemptToCheckoutInAdvance(element As Element) As Boolean
    Dim doc As Document = element.Document
    Dim categoryName As [String] = element.Category.Name

    ' Checkout attempt
    Dim checkedOutIds As ICollection(Of ElementId) = WorksharingUtils.CheckoutElements(doc, New ElementId() {element.Id})

    ' Confirm checkout
    Dim checkedOutSuccessfully As Boolean = checkedOutIds.Contains(element.Id)

    If Not checkedOutSuccessfully Then
        TaskDialog.Show("Element is not checked out", "Cannot edit the " + categoryName + " element - " + "it was not checked out successfully and may be checked out to another.")
        Return False
    End If

    ' If element is updated in central or deleted in central, it is not editable
    Dim updatesStatus As ModelUpdatesStatus = WorksharingUtils.GetModelUpdatesStatus(doc, element.Id)
    If updatesStatus = ModelUpdatesStatus.DeletedInCentral OrElse updatesStatus = ModelUpdatesStatus.UpdatedInCentral Then
        TaskDialog.Show("Element is not up to date", "Cannot edit the " + categoryName + " element - " + "it is not up to date with central, but it is checked out.")
        Return False
    End If

    Return True
End Function

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

WorksharingUtils Class


WorksharingUtils.GetUserWorksetInfo Method

WorksharingUtilsGetUserWorksetInfo Method

Gets information about user worksets in a workshared model file, without fully opening the file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<WorksetPreview> GetUserWorksetInfo(
    ModelPath path
)
Public Shared Function GetUserWorksetInfo (
    path As ModelPath
) As IList(Of WorksetPreview)
public:
static IList<WorksetPreview^>^ GetUserWorksetInfo(
    ModelPath^ path
)
static member GetUserWorksetInfo :
        path : ModelPath -> IList<WorksetPreview>

Parameters

path ModelPath
The path to the workshared model.

Return Value

IList WorksetPreview
Information about all the user worksets in the model. The list is sorted by workset id.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
CentralModelAccessDeniedException | Access to the central model was denied due to lack of access privileges. -or- Access to the central model was denied. A possible reason is because the model was under maintenance.
CentralModelContentionException | The central model are locked by another client.
CentralModelException | The central model is missing. -or- The central model is corrupt or not an RVT file. -or- The model is not workshared. -or- The central model is overwritten by other user. -or- An internal error happened on the central model, please contact the server administrator.
FileAccessException | The model could not be accessed due to lack of access privileges.
FileArgumentNotFoundException | The Revit model specified by path doesn't exist.
FileNotFoundException | The model could not be found at the specified path.
InvalidOperationException | This functionality is not available in Revit LT.
RevitServerCommunicationException | The server-based central model could not be accessed because of a network communication error.
RevitServerInternalException | An internal error happened on the server, please contact the server administrator.
Remarks
This method provides a preview of the user worksets available in a file, allowing an application to look up the necessary workset ids and information to properly fill out a WorksetConfiguration structure before opening or linking to this model.
See Also

Reference

WorksharingUtils Class


WorksharingUtils.GetWorksharingTooltipInfo Method

WorksharingUtilsGetWorksharingTooltipInfo Method

Gets worksharing information about an element to display in an in-canvas tooltip.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static WorksharingTooltipInfo GetWorksharingTooltipInfo(
    Document document,
    ElementId elementId
)
Public Shared Function GetWorksharingTooltipInfo (
    document As Document,
    elementId As ElementId
) As WorksharingTooltipInfo
public:
static WorksharingTooltipInfo^ GetWorksharingTooltipInfo(
    Document^ document,
    ElementId^ elementId
)
static member GetWorksharingTooltipInfo :
        document : Document *
        elementId : ElementId -> WorksharingTooltipInfo

Parameters

document Document
The document containing the element
elementId ElementId
The id of the element in question

Return Value

WorksharingTooltipInfo
Worksharing information about the specified element.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks

If there is no element corresponding to the given id, then all the strings returned in WorksharingTooltipInfo are empty.

The return value may not be dependable in the middle of a transaction. See the remarks on WorksharingUtils for more details.

See Also

Reference

WorksharingUtils Class


WorksharingUtils.RelinquishOwnership Method

WorksharingUtilsRelinquishOwnership Method

Relinquishes ownership by the current user of as many specified elements and worksets as possible, and grants element ownership requested by other users on a first-come, first-served basis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static RelinquishedItems RelinquishOwnership(
    Document document,
    RelinquishOptions generalCategories,
    TransactWithCentralOptions options
)
Public Shared Function RelinquishOwnership (
    document As Document,
    generalCategories As RelinquishOptions,
    options As TransactWithCentralOptions
) As RelinquishedItems
public:
static RelinquishedItems^ RelinquishOwnership(
    Document^ document,
    RelinquishOptions^ generalCategories,
    TransactWithCentralOptions^ options
)
static member RelinquishOwnership :
        document : Document *
        generalCategories : RelinquishOptions *
        options : TransactWithCentralOptions -> RelinquishedItems

Parameters

document Document
The document containing the elements and worksets.
generalCategories RelinquishOptions
General categories of items to relinquish. See RelinquishOptions for details.
options TransactWithCentralOptions
Options to customize access to the central model. is allowed and means no customization.

Return Value

RelinquishedItems
The elements and worksets that were relinquished.
Exceptions
Exception | Condition
ArgumentException | document is not a workshared document. -or- document is not a primary document, it is a linked document. -or- document is read-only: It cannot be modified. -or- document has an open editing transaction and is accepting changes. -or- Saving is not allowed in the current application mode.
ArgumentNullException | A non-optional argument was null
CentralFileCommunicationException | The file-based central model could not be reached, e.g. the network is down or the file server is down.
CentralModelAccessDeniedException | Access to the central model was denied due to lack of access privileges. -or- Access to the central model was denied. A possible reason is because the model was under maintenance.
CentralModelContentionException | The central model is locked by another client.
CentralModelException | The central model is overwritten by other user. -or- The central model is missing. -or- An internal error happened on the central model, please contact the server administrator.
InvalidOperationException | Operation is not permitted when there is any open sub-transaction, transaction, or transaction group.
RevitServerCommunicationException | The server-based central model could not be accessed because of a network communication error.
RevitServerInternalException | An internal error happened on the server, please contact the server administrator.
Remarks

Elements and worksets owned by other users are ignored.

Only unmodified elements already in central will be relinquished by this method. Newly added and modified elements cannot be relinquished until they have been synchronized with central.

For best performance, relinquish items in one big call, rather than many small calls.

See Also

Reference

WorksharingUtils Class


XYZ Class

Object representing coordinates in 3-dimensional space.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBXYZ

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class XYZ
Public Class XYZ
public ref class XYZ
type XYZ = class end

The XYZ type exposes the following members.

Constructors
 | Name | Description
Public method | XYZ | Creates a default XYZ with the values (0, 0, 0).
Public method | XYZ(Double, Double, Double) | Creates an XYZ with the supplied coordinates.
Top
Properties
 | Name | Description
 | BasisX | The basis of the X axis.
 | BasisY | The basis of the Y axis.
 | BasisZ | The basis of the Z axis.
Public property | Item | Indexed access to coordinates.
Public property | X | Gets the first coordinate.
Public property | Y | Gets the second coordinate.
Public property | Z | Gets the third coordinate.
 | Zero | The coordinate origin or zero vector.
Top
Methods
 | Name | Description
Public method | Add | Adds the specified vector to this vector and returns the result.
Public method | AngleOnPlaneTo | Returns the angle between this vector and the specified vector projected to the specified plane.
Public method | AngleTo | Returns the angle between this vector and the specified vector.
Public method | CrossProduct | The cross product of this vector and the specified vector.
Public method | DistanceTo | Returns the distance from this point to the specified point.
Public method | Divide | Divides this vector by the specified value and returns the result.
Public method | DotProduct | The dot product of this vector and the specified vector.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLength | Gets the length of this vector.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsAlmostEqualTo(XYZ) | Determines whether this vector and the specified vector are the same within the tolerance (1.0e-09).
Public method | IsAlmostEqualTo(XYZ, Double) | Determines whether 2 vectors are the same within the given tolerance.
Public method | IsUnitLength | The boolean value that indicates whether this vector is of unit length.
 | IsWithinLengthLimits | Validates that the input point is within Revit design limits.
Public method | IsZeroLength | The boolean value that indicates whether this vector is a zero vector.
Public method | Multiply | Multiplies this vector by the specified value and returns the result.
Public method | Negate | Negates this vector.
Public method | Normalize | Returns a new XYZ whose coordinates are the normalized values from this vector.
Public method | Subtract | Subtracts the specified vector from this vector and returns the result.
Public method | ToString | Gets formatted string showing (X, Y, Z) with values formatted to 9 decimal places. (Overrides ObjectToString)
Public method | TripleProduct | The triple product of this vector and the two specified vectors.
Top
Operators
Name | Description
Addition(XYZ, XYZ) | Adds the two specified vectors and returns the result.
Division(XYZ, Double) | Divides the specified vector by the specified value.
Multiply(Double, XYZ) | Multiplies the specified number and the specified vector.
Multiply(XYZ, Double) | Multiplies the specified number and the specified vector.
Subtraction(XYZ, XYZ) | Subtracts the two specified vectors and returns the result.
UnaryNegation(XYZ) | Negates the specified vector and returns the result.
Top
Remarks
Usually this means a point or a vector in 3-dimensional space, depending on the actual use.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


XYZ Constructor

Overload List
 | Name | Description
Public method | XYZ | Creates a default XYZ with the values (0, 0, 0).
Public method | XYZ(Double, Double, Double) | Creates an XYZ with the supplied coordinates.
Top
See Also

Reference

XYZ Class


XYZ Constructor

Creates a default XYZ with the values (0, 0, 0).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ()
Public Sub New
public:
XYZ()
new : unit -> XYZ
See Also

Reference

XYZ Class
XYZ Overload


XYZ(Double, Double, Double) Constructor

Creates an XYZ with the supplied coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ(
    double x,
    double y,
    double z
)
Public Sub New (
    x As Double,
    y As Double,
    z As Double
)
public:
XYZ(
    double x,
    double y,
    double z
)
new :
        x : float *
        y : float *
        z : float -> XYZ

Parameters

x Double
The first coordinate.
y Double
The second coordinate.
z Double
The third coordinate.
Exceptions
Exception | Condition
ArgumentException | Thrown when setting an infinite number to the X, Y or Z property.
See Also

Reference

XYZ Class
XYZ Overload


XYZ Properties

The XYZ type exposes the following members.

Properties
 | Name | Description
 | BasisX | The basis of the X axis.
 | BasisY | The basis of the Y axis.
 | BasisZ | The basis of the Z axis.
Public property | Item | Indexed access to coordinates.
Public property | X | Gets the first coordinate.
Public property | Y | Gets the second coordinate.
Public property | Z | Gets the third coordinate.
 | Zero | The coordinate origin or zero vector.
Top
See Also

Reference

XYZ Class


XYZ.BasisX Property

XYZBasisX Property

The basis of the X axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static XYZ BasisX { get; }
Public Shared ReadOnly Property BasisX As XYZ
    Get
public:
static property XYZ^ BasisX {
    XYZ^ get ();
}
static member BasisX : XYZ with get

Property Value

XYZ
Remarks
The basis of the X axis is the vector (1,0,0), the unit vector on the X axis.
See Also

Reference

XYZ Class


XYZ.BasisY Property

XYZBasisY Property

The basis of the Y axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static XYZ BasisY { get; }
Public Shared ReadOnly Property BasisY As XYZ
    Get
public:
static property XYZ^ BasisY {
    XYZ^ get ();
}
static member BasisY : XYZ with get

Property Value

XYZ
Remarks
The basis of the Y axis is the vector (0,1,0), the unit vector on the Y axis.
See Also

Reference

XYZ Class


XYZ.BasisZ Property

XYZBasisZ Property

The basis of the Z axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static XYZ BasisZ { get; }
Public Shared ReadOnly Property BasisZ As XYZ
    Get
public:
static property XYZ^ BasisZ {
    XYZ^ get ();
}
static member BasisZ : XYZ with get

Property Value

XYZ
Remarks
The basis of the Z axis is the vector (0,0,1), the unit vector on the Z axis.
See Also

Reference

XYZ Class


XYZ.Item Property

XYZItem Property

Indexed access to coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double this[
    int idx
] { get; }
Public ReadOnly Default Property Item (
    idx As Integer
) As Double
    Get
public:
property double default[int idx] {
    double get (int idx);
}
member Item : float with get

Parameters

idx Int32
Use 0 for X, 1 for Y and 2 for Z.

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Thrown when an attempt is made to access the coordinate with an index that is larger than 2.
See Also

Reference

XYZ Class


XYZ.X Property

XYZX Property

Gets the first coordinate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double X { get; }
Public ReadOnly Property X As Double
    Get
public:
property double X {
    double get ();
}
member X : float with get

Property Value

Double
See Also

Reference

XYZ Class


XYZ.Y Property

XYZY Property

Gets the second coordinate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Y { get; }
Public ReadOnly Property Y As Double
    Get
public:
property double Y {
    double get ();
}
member Y : float with get

Property Value

Double
See Also

Reference

XYZ Class


XYZ.Z Property

XYZZ Property

Gets the third coordinate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Z { get; }
Public ReadOnly Property Z As Double
    Get
public:
property double Z {
    double get ();
}
member Z : float with get

Property Value

Double
See Also

Reference

XYZ Class


XYZ.Zero Property

XYZZero Property

The coordinate origin or zero vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static XYZ Zero { get; }
Public Shared ReadOnly Property Zero As XYZ
    Get
public:
static property XYZ^ Zero {
    XYZ^ get ();
}
static member Zero : XYZ with get

Property Value

XYZ
Remarks
The zero vector is (0,0,0).
See Also

Reference

XYZ Class


XYZ Methods

The XYZ type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds the specified vector to this vector and returns the result.
Public method | AngleOnPlaneTo | Returns the angle between this vector and the specified vector projected to the specified plane.
Public method | AngleTo | Returns the angle between this vector and the specified vector.
Public method | CrossProduct | The cross product of this vector and the specified vector.
Public method | DistanceTo | Returns the distance from this point to the specified point.
Public method | Divide | Divides this vector by the specified value and returns the result.
Public method | DotProduct | The dot product of this vector and the specified vector.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLength | Gets the length of this vector.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsAlmostEqualTo(XYZ) | Determines whether this vector and the specified vector are the same within the tolerance (1.0e-09).
Public method | IsAlmostEqualTo(XYZ, Double) | Determines whether 2 vectors are the same within the given tolerance.
Public method | IsUnitLength | The boolean value that indicates whether this vector is of unit length.
 | IsWithinLengthLimits | Validates that the input point is within Revit design limits.
Public method | IsZeroLength | The boolean value that indicates whether this vector is a zero vector.
Public method | Multiply | Multiplies this vector by the specified value and returns the result.
Public method | Negate | Negates this vector.
Public method | Normalize | Returns a new XYZ whose coordinates are the normalized values from this vector.
Public method | Subtract | Subtracts the specified vector from this vector and returns the result.
Public method | ToString | Gets formatted string showing (X, Y, Z) with values formatted to 9 decimal places. (Overrides ObjectToString)
Public method | TripleProduct | The triple product of this vector and the two specified vectors.
Top
See Also

Reference

XYZ Class


XYZ.Add Method

XYZAdd Method

Adds the specified vector to this vector and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Add(
    XYZ source
)
Public Function Add (
    source As XYZ
) As XYZ
public:
XYZ^ Add(
    XYZ^ source
)
member Add :
        source : XYZ -> XYZ

Parameters

source XYZ
The vector to add to this vector.

Return Value

XYZ
The vector equal to the sum of the two vectors.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when source is .
Remarks
The added vector is obtained by adding each coordinate of the specified vector to the corresponding coordinate of this vector.
See Also

Reference

XYZ Class


XYZ.AngleOnPlaneTo Method

XYZAngleOnPlaneTo Method

Returns the angle between this vector and the specified vector projected to the specified plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double AngleOnPlaneTo(
    XYZ right,
    XYZ normal
)
Public Function AngleOnPlaneTo (
    right As XYZ,
    normal As XYZ
) As Double
public:
double AngleOnPlaneTo(
    XYZ^ right,
    XYZ^ normal
)
member AngleOnPlaneTo :
        right : XYZ *
        normal : XYZ -> float

Parameters

right XYZ
The specified vector.
normal XYZ
The normal vector that defines the plane.

Return Value

Double
The real number between 0 and 2*PI equal to the projected angle between the two vectors.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when right or normal is .
Remarks
The angle is projected onto the plane orthogonal to the specified normal vector, counterclockwise with the normal pointing upwards.
See Also

Reference

XYZ Class


XYZ.AngleTo Method

XYZAngleTo Method

Returns the angle between this vector and the specified vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double AngleTo(
    XYZ source
)
Public Function AngleTo (
    source As XYZ
) As Double
public:
double AngleTo(
    XYZ^ source
)
member AngleTo :
        source : XYZ -> float

Parameters

source XYZ
The specified vector.

Return Value

Double
The real number between 0 and PI equal to the angle between the two vectors in radians..
Exceptions
Exception | Condition
ArgumentNullException | Thrown when source is .
Remarks
The angle between the two vectors is measured in the plane spanned by them.
See Also

Reference

XYZ Class


XYZ.CrossProduct Method

XYZCrossProduct Method

The cross product of this vector and the specified vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ CrossProduct(
    XYZ source
)
Public Function CrossProduct (
    source As XYZ
) As XYZ
public:
XYZ^ CrossProduct(
    XYZ^ source
)
member CrossProduct :
        source : XYZ -> XYZ

Parameters

source XYZ
The vector to multiply with this vector.

Return Value

XYZ
The vector equal to the cross product.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when source is .
Remarks
The cross product is defined as the vector which is perpendicular to both vectors with a magnitude equal to the area of the parallelogram they span. Also known as vector product or outer product.
See Also

Reference

XYZ Class


XYZ.DistanceTo Method

XYZDistanceTo Method

Returns the distance from this point to the specified point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double DistanceTo(
    XYZ source
)
Public Function DistanceTo (
    source As XYZ
) As Double
public:
double DistanceTo(
    XYZ^ source
)
member DistanceTo :
        source : XYZ -> float

Parameters

source XYZ
The specified point.

Return Value

Double
The real number equal to the distance between the two points.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when source is .
Remarks
The distance between the two points is equal to the length of the vector that joins the two points.
See Also

Reference

XYZ Class


XYZ.Divide Method

XYZDivide Method

Divides this vector by the specified value and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Divide(
    double value
)
Public Function Divide (
    value As Double
) As XYZ
public:
XYZ^ Divide(
    double value
)
member Divide :
        value : float -> XYZ

Parameters

value Double
The value to divide this vector by.

Return Value

XYZ
The divided vector.
Exceptions
Exception | Condition
ArgumentException | Thrown when the specified value is an infinite number or zero.
Remarks
The divided vector is obtained by dividing each coordinate of this vector by the specified value.
See Also

Reference

XYZ Class


XYZ.DotProduct Method

XYZDotProduct Method

The dot product of this vector and the specified vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double DotProduct(
    XYZ source
)
Public Function DotProduct (
    source As XYZ
) As Double
public:
double DotProduct(
    XYZ^ source
)
member DotProduct :
        source : XYZ -> float

Parameters

source XYZ
The vector to multiply with this vector.

Return Value

Double
The real number equal to the dot product.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when source is .
Remarks
The dot product is the sum of the respective coordinates of the two vectors: Vx*Wx + Vy*Wy + Vz*Wz. Also known as scalar product or inner product.
See Also

Reference

XYZ Class


XYZ.GetLength Method

XYZGetLength Method

Gets the length of this vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetLength()
Public Function GetLength As Double
public:
double GetLength()
member GetLength : unit -> float

Return Value

Double
Remarks
In 3-D Euclidean space, the length of the vector is the square root of the sum of the three coordinates squared.
See Also

Reference

XYZ Class


XYZ.IsAlmostEqualTo Method

XYZIsAlmostEqualTo Method

Overload List
 | Name | Description
Public method | IsAlmostEqualTo(XYZ) | Determines whether this vector and the specified vector are the same within the tolerance (1.0e-09).
Public method | IsAlmostEqualTo(XYZ, Double) | Determines whether 2 vectors are the same within the given tolerance.
Top
See Also

Reference

XYZ Class


XYZ.IsAlmostEqualTo(XYZ) Method

XYZIsAlmostEqualTo(XYZ) Method

Determines whether this vector and the specified vector are the same within the tolerance (1.0e-09).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsAlmostEqualTo(
    XYZ source
)
Public Function IsAlmostEqualTo (
    source As XYZ
) As Boolean
public:
bool IsAlmostEqualTo(
    XYZ^ source
)
member IsAlmostEqualTo :
        source : XYZ -> bool

Parameters

source XYZ
The vector to compare with this vector.

Return Value

Boolean
True if the vectors are the same; otherwise, false.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when source is .
Remarks
This routine uses Revit's default tolerance to compare two vectors to see if they are almost equivalent. Because the tolerance is small enough this can also be used to compare two points.
See Also

Reference

XYZ Class
IsAlmostEqualTo Overload


XYZ.IsAlmostEqualTo(XYZ, Double) Method

XYZIsAlmostEqualTo(XYZ, Double) Method

Determines whether 2 vectors are the same within the given tolerance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsAlmostEqualTo(
    XYZ source,
    double tolerance
)
Public Function IsAlmostEqualTo (
    source As XYZ,
    tolerance As Double
) As Boolean
public:
bool IsAlmostEqualTo(
    XYZ^ source,
    double tolerance
)
member IsAlmostEqualTo :
        source : XYZ *
        tolerance : float -> bool

Parameters

source XYZ
The vector to compare with this vector.
tolerance Double
The tolerance for equality check.

Return Value

Boolean
True if the vectors are the same; otherwise, false.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when source is .
ArgumentException | Thrown when tolerance is less than 0.
Remarks
This routine uses an input tolerance to compare two vectors to see if they are almost equivalent. Because it is comparing two vectors the tolerance value is not in length units but instead represents the variation in direction between the vectors. For very small tolerance values it should also be possible to compare two points with this method. To compute the distance between two points for a comparison with a larger allowable difference, use DistanceTo(XYZ).
See Also

Reference

XYZ Class
IsAlmostEqualTo Overload


XYZ.IsUnitLength Method

XYZIsUnitLength Method

The boolean value that indicates whether this vector is of unit length.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsUnitLength()
Public Function IsUnitLength As Boolean
public:
bool IsUnitLength()
member IsUnitLength : unit -> bool

Return Value

Boolean
Remarks
A unit length vector has a length of one, and is considered normalized.
See Also

Reference

XYZ Class


XYZ.IsWithinLengthLimits Method

XYZIsWithinLengthLimits Method

Validates that the input point is within Revit design limits.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsWithinLengthLimits(
    XYZ point
)
Public Shared Function IsWithinLengthLimits (
    point As XYZ
) As Boolean
public:
static bool IsWithinLengthLimits(
    XYZ^ point
)
static member IsWithinLengthLimits :
        point : XYZ -> bool

Parameters

point XYZ
The point to test.

Return Value

Boolean
True if the input point is within Revit design limits, false otherwise.
Remarks
Used to validate input for geometry construction methods.
See Also

Reference

XYZ Class


XYZ.IsZeroLength Method

XYZIsZeroLength Method

The boolean value that indicates whether this vector is a zero vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsZeroLength()
Public Function IsZeroLength As Boolean
public:
bool IsZeroLength()
member IsZeroLength : unit -> bool

Return Value

Boolean
Remarks
The zero vector's each component is zero within the tolerance (1.0e-09).
See Also

Reference

XYZ Class


XYZ.Multiply Method

XYZMultiply Method

Multiplies this vector by the specified value and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Multiply(
    double value
)
Public Function Multiply (
    value As Double
) As XYZ
public:
XYZ^ Multiply(
    double value
)
member Multiply :
        value : float -> XYZ

Parameters

value Double
The value to multiply with this vector.

Return Value

XYZ
The multiplied vector.
Exceptions
Exception | Condition
ArgumentException | Thrown when the specified value is an infinite number.
Remarks
The multiplied vector is obtained by multiplying each coordinate of this vector by the specified value.
See Also

Reference

XYZ Class


XYZ.Negate Method

XYZNegate Method

Negates this vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Negate()
Public Function Negate As XYZ
public:
XYZ^ Negate()
member Negate : unit -> XYZ

Return Value

XYZ
The vector opposite to this vector.
Remarks
The negated vector is obtained by changing the sign of each coordinate of this vector.
See Also

Reference

XYZ Class


XYZ.Normalize Method

XYZNormalize Method

Returns a new XYZ whose coordinates are the normalized values from this vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Normalize()
Public Function Normalize As XYZ
public:
XYZ^ Normalize()
member Normalize : unit -> XYZ

Return Value

XYZ
The normalized XYZ or zero if the vector is almost Zero.
Remarks
Normalized indicates that the length of this vector equals one (a unit vector).
See Also

Reference

XYZ Class


XYZ.Subtract Method

XYZSubtract Method

Subtracts the specified vector from this vector and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Subtract(
    XYZ source
)
Public Function Subtract (
    source As XYZ
) As XYZ
public:
XYZ^ Subtract(
    XYZ^ source
)
member Subtract :
        source : XYZ -> XYZ

Parameters

source XYZ
The vector to subtract from this vector.

Return Value

XYZ
The vector equal to the difference between the two vectors.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when source is .
Remarks
The subtracted vector is obtained by subtracting each coordinate of the specified vector from the corresponding coordinate of this vector.
See Also

Reference

XYZ Class


XYZ.ToString Method

XYZToString Method

Gets formatted string showing (X, Y, Z) with values formatted to 9 decimal places.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

String
See Also

Reference

XYZ Class


XYZ.TripleProduct Method

XYZTripleProduct Method

The triple product of this vector and the two specified vectors.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double TripleProduct(
    XYZ middle,
    XYZ right
)
Public Function TripleProduct (
    middle As XYZ,
    right As XYZ
) As Double
public:
double TripleProduct(
    XYZ^ middle,
    XYZ^ right
)
member TripleProduct :
        middle : XYZ *
        right : XYZ -> float

Parameters

middle XYZ
The second vector.
right XYZ
The third vector.

Return Value

Double
The real number equal to the triple product.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when middle or right is .
Remarks
The scalar triple product is defined as the dot product of one of the vectors with the cross product of the other two. Geometrically, this product is the (signed) volume of the parallelepiped formed by the three vectors given.
See Also

Reference

XYZ Class


XYZ Operators

The XYZ type exposes the following members.

Operators
Name | Description
Addition(XYZ, XYZ) | Adds the two specified vectors and returns the result.
Division(XYZ, Double) | Divides the specified vector by the specified value.
Multiply(Double, XYZ) | Multiplies the specified number and the specified vector.
Multiply(XYZ, Double) | Multiplies the specified number and the specified vector.
Subtraction(XYZ, XYZ) | Subtracts the two specified vectors and returns the result.
UnaryNegation(XYZ) | Negates the specified vector and returns the result.
Top
See Also

Reference

XYZ Class


XYZ.Addition Operator

XYZAddition Operator

Adds the two specified vectors and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static XYZ operator +(
    XYZ left,
    XYZ right
)
Public Shared Operator + (
    left As XYZ,
    right As XYZ
) As XYZ
public:
static XYZ^ operator +(
    XYZ^ left,
    XYZ^ right
)
static let inline (+)
        left : XYZ *
        right : XYZ  : XYZ

Parameters

left XYZ
The first vector.
right XYZ
The second vector.

Return Value

XYZ
The vector equal to the sum of the two source vectors.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when left or right is .
Remarks
The added vector is obtained by adding each coordinate of the right vector to the corresponding coordinate of the left vector.
See Also

Reference

XYZ Class


XYZ.Division Operator

XYZDivision Operator

Divides the specified vector by the specified value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static XYZ operator /(
    XYZ left,
    double value
)
Public Shared Operator / (
    left As XYZ,
    value As Double
) As XYZ
public:
static XYZ^ operator /(
    XYZ^ left,
    double value
)
static let inline (/)
        left : XYZ *
        value : float  : XYZ

Parameters

left XYZ
The value to divide the vector by.
value Double
The vector to divide by the value.

Return Value

XYZ
The divided vector.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when source is .
ArgumentException | Thrown when the specified value is an infinite number or zero.
Remarks
The divided vector is obtained by dividing each coordinate of the specified vector by the specified value.
See Also

Reference

XYZ Class


XYZ.Multiply Operator

XYZMultiply Operator

Overload List
Name | Description
Multiply(Double, XYZ) | Multiplies the specified number and the specified vector.
Multiply(XYZ, Double) | Multiplies the specified number and the specified vector.
Top
See Also

Reference

XYZ Class


XYZ.Multiply(Double, XYZ) Operator

XYZMultiply(Double, XYZ) Operator

Multiplies the specified number and the specified vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static XYZ operator *(
    double value,
    XYZ right
)
Public Shared Operator * (
    value As Double,
    right As XYZ
) As XYZ
public:
static XYZ^ operator *(
    double value,
    XYZ^ right
)
static let inline (*)
        value : float *
        right : XYZ  : XYZ

Parameters

value Double
The value to multiply with the specified vector.
right XYZ
The vector to multiply with the value.

Return Value

XYZ
The multiplied vector.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when right is .
ArgumentException | Thrown when the specified value is an infinite number.
Remarks
The multiplied vector is obtained by multiplying each coordinate of the specified vector by the specified value.
See Also

Reference

XYZ Class
Multiply Overload


XYZ.Multiply(XYZ, Double) Operator

XYZMultiply(XYZ, Double) Operator

Multiplies the specified number and the specified vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static XYZ operator *(
    XYZ left,
    double value
)
Public Shared Operator * (
    left As XYZ,
    value As Double
) As XYZ
public:
static XYZ^ operator *(
    XYZ^ left,
    double value
)
static let inline (*)
        left : XYZ *
        value : float  : XYZ

Parameters

left XYZ
The vector to multiply with the value.
value Double
The value to multiply with the specified vector.

Return Value

XYZ
The multiplied vector.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when source is .
ArgumentException | Thrown when the specified value is an infinite number.
Remarks
The multiplied vector is obtained by multiplying each coordinate of the specified vector by the specified value.
See Also

Reference

XYZ Class
Multiply Overload


XYZ.Subtraction Operator

XYZSubtraction Operator

Subtracts the two specified vectors and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static XYZ operator -(
    XYZ left,
    XYZ right
)
Public Shared Operator - (
    left As XYZ,
    right As XYZ
) As XYZ
public:
static XYZ^ operator -(
    XYZ^ left,
    XYZ^ right
)
static let inline (-)
        left : XYZ *
        right : XYZ  : XYZ

Parameters

left XYZ
The first vector.
right XYZ
The second vector.

Return Value

XYZ
The vector equal to the difference between the two source vectors.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when left or right is .
Remarks
The subtracted vector is obtained by subtracting each coordinate of the right vector from the corresponding coordinate of the left vector.
See Also

Reference

XYZ Class


XYZ.UnaryNegation Operator

XYZUnaryNegation Operator

Negates the specified vector and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static XYZ operator -(
    XYZ source
)
Public Shared Operator - (
    source As XYZ
) As XYZ
public:
static XYZ^ operator -(
    XYZ^ source
)
static let inline (-)
        source : XYZ  : XYZ

Parameters

source XYZ

Return Value

XYZ
The vector opposite to the specified vector.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when source is .
Remarks
The negated vector is obtained by changing the sign of each coordinate of the specified vector.
See Also

Reference

XYZ Class


ZoomFitType Enumeration

This enum is used to define type of zoom.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ZoomFitType
Public Enumeration ZoomFitType
public enum class ZoomFitType
type ZoomFitType
Members
Member name | Value | Description
FitToPage | 0 | Fit the whole view into a specific image size.
Zoom | 1 | Calculate the size of the image using physical size of the view, zoom value and resolution.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


ZoomType Enumeration

An enumerated type listing all Zoom types of Print Setting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ZoomType
Public Enumeration ZoomType
public enum class ZoomType
type ZoomType
Members
Member name | Value | Description
FitToPage | 0 | The type of Zoom is Fit To Page.
Zoom | 1 | The type of Zoom is user defined.
See Also

Reference

Autodesk.Revit.DB Namespace
Send comments on this topic to Autodesk


Autodesk.Revit.DB.Analysis Namespace

Classes
Class | Description
AnalysisDisplayColoredSurfaceSettings | Contains colored surface settings for analysis display style element.
Public class | AnalysisDisplayColorEntry | Contains one entry of intermediate colors in color settings for analysis display style.
AnalysisDisplayColorSettings | Contains color settings for analysis display style element.
Public class | AnalysisDisplayDeformedShapeSettings | Contains deformed shape settings for analysis display style element.
Public class | AnalysisDisplayDiagramSettings | Contains diagram settings for analysis display style element.
Public class | AnalysisDisplayLegend | The legend that describes an Analysis Visualization.
AnalysisDisplayLegendSettings | Contains legend settings for analysis display style element.
AnalysisDisplayMarkersAndTextSettings | Contains markers and text settings for analysis display style element.
AnalysisDisplayStyle | Exposes API for manipulation of analysis display style.
Public class | AnalysisDisplayVectorSettings | Contains vector settings for analysis display style element.
AnalysisResultSchema | Contains all information about one analysis result. Each result may contain several measurements.
Public class | BuildingEnvelopeAnalyzer | Analyzes which elements are part of the building envelope, the building elements exposed to the outside.
Public class | BuildingEnvelopeAnalyzerOptions | Specific options for the method analyzing the building elements for the building envelope.
Public class | BuildingOperatingDaySchedule | Represents the operating schedule of a 24 hour day.
Public class | BuildingOperatingYearSchedule | Represents an operating schedule that contains 365 daily usage BuildingOperatingDaySchedules.
Public class | ConceptualConstructionType | This element is used to describe the conceptual physical, construction, and energy properties in a manner that can be understood by both the Revit BIM model and Green Building Studio/Green Building XML. For serialization
Public class | ConceptualSurfaceType | This element represents a conceptual BIM object category to assign to faces in Mass geometries. There is one ConceptualSurfaceType element for each of the Mass Surface Subcategories. for serialization
Public class | CriticalPathCollector | This class is used to search and traverse the network analytical segments on the critical path.
Public class | CriticalPathIterator | An iterator to traverse the critical path in the CriticalPathCollector.
Public class | EnergyAnalysisConstruction | Represent an analytical construction as a composite of layered materials.
EnergyAnalysisDetailModel | Manage the analytical thermal model.
Public class | EnergyAnalysisDetailModelOptions | Options that govern the calculations for the generation of the energy analysis detail model.
Public class | EnergyAnalysisMaterial | A description of a material with thermal properties in a composite construction.
Public class | EnergyAnalysisOpening | Analytical opening.
Public class | EnergyAnalysisSpace | Analytical space.
Public class | EnergyAnalysisSurface | Analytical surface. The collection of analytic openings belonging to this analytical parent surface
Public class | EnergyAnalysisWindowType | The EnergyAnalysisWindowType class contains the thermal properties (e.g., heat transfer coefficient) of the window-type analytical openings.
Public class | EnergyAnalysisZone | Analytical zone.
EnergyDataSettings | This element contains settings for gbXML Export and Heating and Cooling Load Calculations and project level settings for Conceptual Energy Analysis. for serialization
Public class | FieldDomainPoints | Abstract base class for various classes of field domain points
FieldDomainPointsByParameter | Represents a set of one-dimensional point coordinates (defined usually on curve)
Public class | FieldDomainPointsByUV | Represents a set of two-dimensional point coordinates (defined usually on surface)
Public class | FieldDomainPointsByXYZ | Represents a set of three-dimensional point coordinates
Public class | FieldValues | Contains values corresponding to domain points. Each domain point may have an array of values, each corresponding to a separate "measurement" for which this value was calculated.
Public class | GenericZone | Provides access to the GenericZone Element in Autodesk Revit.
Public class | GenericZoneDomainData | A base class for specific domain requirements for a generic zone.
Public class | HVACLoadBuildingType | The type element of building.
Public class | HVACLoadSpaceType | The type element of space.
Public class | HVACLoadType | The base class for building type and space type.
Public class | MassLevelData | MassLevelData is a conceptual representation of an occupiable floor (Mass Floor) in a conceptual building model. It is defined by associating a particular level with a particular mass element in a Revit project.
Public class MassSurfaceData Obsolete.
Holds properties and other data about a face in the MassEnergyAnalyticalModel element.
Public class | MEPAnalyticalModelData | Represents the MEP analytical model data attached to individual element.
Public class | MEPAnalyticalNode | Represents an analytical node of the MEP analytical model.
Public class | MEPAnalyticalSegment | Represents an analytical segment of the MEP analytical model.
MEPNetworkIterator | An iterator to traverse the MEP analytical network.
Public class | MEPNetworkSegmentData | Represents the analysis data for one network segment.
Public class | MEPNetworkSegmentId | Represents a unique identifier for one analytical segment in the network.
Public class | PathOfTravel | An element which holds a graphical representation of the shortest route between two points in the plane of a floor plan view. The shortest route is calculated to go around model geometry visible in the view. Route calculation is affected by properties of the RouteAnalysisSettings element.
Public class | PathOfTravelCalculationServerIds | Ids for external servers implementing path of travel calculations.
Public class | Polyloop | A Polyloop represent a planar polygon with ordered points.
Public class RouteAnalysisSettings

RouteAnalysisSettings is an element which contains project-wide settings for route calculations. The PathOfTravel element uses these settings to calculate a route between two points in a plan view.

By default, the route will go around the geometry of all visible model elements which have model geometry in the Route Analysis Zone.

The Route Analysis Zone, determined per view, is the space between these two horizontal planes: a top plane vertically offset by AnalysisZoneTopOffset above the view's level and a bottom plane vertically offset by AnalysisZoneBottomOffset ft above the view's level.

By default, the route will ignore the following elements:
  • elements outside of the crop region of the view;
  • elements without any model geometry (annotations or view-specific elements);
  • model lines (category OST_Lines);
  • demolished elements;
  • elements displayed in the underlay of the view.
There are a few ways to customize Route Analysis on a project-wide basis.

You can adjust the Route Analysis Zone using AnalysisZoneTopOffset and AnalysisZoneBottomOffset.

You can specify a set of model categories you would like ignored during route calculation. To enable ignoring the set of specified categories, set EnableIgnoredCategoryIds to true. To change the set of ignored categories, use SetIgnoredCategoryIds method and IgnoreImports and IgnorePointClouds properties. To query the set of ignored categories, use GetIgnoredCategoryIds.

SpatialFieldManager | Exposes all API for an external analysis application. Its primary role is creation, deletion and modification of SpatialFieldElement elements.
Public class | SystemsAnalysisOptions | Contains the options for systems analysis.
Public class | ValueAtPoint | Stores values at one domain point. Each value corresponds to a "measurement" for which this value was calculated.
VectorAtPoint | Stores vectors at one domain point. Each vector corresponds to a "measurement" for which this vector was calculated.
Public class | ViewSystemsAnalysisReport | Represents a report instance of the systems analysis.
Enumerations
 | Enumeration | Description
Public enumeration | AllowLargeGeometry | An enumerated type containing settings information related to handling of large geometries.
Public enumeration | AnalysisDisplayStyleColorSettingsType | Defines types for color settings of analysis display style.
Public enumeration | AnalysisDisplayStyleDeformedShapeTextLabelType | Defines text visualization types for deformed shape settings of analysis display style.
Public enumeration | AnalysisDisplayStyleDiagramFenceType | Defines fence visualization types for diagram settings of analysis display style.
Public enumeration | AnalysisDisplayStyleDiagramTextLabelType | Defines text label visualization types for diagram settings of analysis display style.
Public enumeration | AnalysisDisplayStyleMarkerTextLabelType | Text label visualization types for Markers and Text settings of analysis display style.
Public enumeration | AnalysisDisplayStyleMarkerType | Marker types for Markers and Text settings of analysis display style.
Public enumeration | AnalysisDisplayStyleVectorArrowheadScale | Defines arrow head scaling for vector settings of analysis display style.
Public enumeration | AnalysisDisplayStyleVectorOrientation | Defines vector orientation for vector settings of analysis display style.
Public enumeration | AnalysisDisplayStyleVectorPosition | Defines vector position for vector settings of analysis display style.
Public enumeration | AnalysisDisplayStyleVectorTextType | Defines text visualization types for vector settings of analysis display style.
Public enumeration | AnalysisMode | This enum is used to define the Energy Analysis Model.
Public enumeration | ConceptualConstructionFloorSlabType | ConceptualConstructionType values for Floors.
Public enumeration | ConceptualConstructionOpeningType | ConceptualConstructionType values for Openings.
Public enumeration | ConceptualConstructionRoofType | ConceptualConstructionType values for Roofs.
Public enumeration | ConceptualConstructionShadeType | ConceptualConstructionType values for Shades.
Public enumeration | ConceptualConstructionWallType | ConceptualConstructionType values for Walls.
Public enumeration | ConceptualConstructionWindowSkylightType | ConceptualConstructionType values for Windows and Skylights
Public enumeration | ConstructionType | This enumeration specifies the available analytical construction types like external walls, windows etc. for use in the detailed analytical energy model.
Public enumeration | EnergyAnalysisDetailModelTier | Level of computation for energy analysis model.
Public enumeration | EnergyAnalysisOpeningType | Energy analysis opening type.
Public enumeration | EnergyAnalysisSurfaceType | Analytical surface types.
Public enumeration | EnergyModelType | This enum is used to define if the energy model is based on rooms/spaces, building elements or analysis mode in EnergyDataSettings.
Public enumeration | gbXMLBuildingHVACSystem | Enumerations for gbXML (Green Building XML) format, used for energy analysis, schema version 0.34.
Public enumeration | gbXMLBuildingOperatingSchedule | Enumerations for gbXML (Green Building XML) format, used for energy analysis, schema version 0.34.
Public enumeration | gbXMLBuildingType | Enumerations for gbXML (Green Building XML) format, used for energy analysis, schema version 0.34.
Public enumeration | gbXMLConditionType | This enumeration corresponds to the conditionType attribute in gbXML. The enumerated attribute identifies the type of heating, cooling, or ventilation the space has.
Public enumeration | gbXMLExportBuildingEnvelope | Indicates the determination method for the building envelope
Public enumeration | gbXMLExportComplexity | This enumeration specifies the level of detail of the exported analytical energy model in gbXML. Complex means that Curtain Walls and Curtain Systems are exported as several openings, panel by panel; a curtain wall with 50 panels gets exported as 50 openings. Simple means that one "huge" opening with the total opening area equal to the 50 panels is exported. This is more appropriate for most energy analysis. Mullions mean that Mullions in Curtain Walls and Systems are exported as shading surfaces. A "simplified" analytical shading surface is produced from a mullion based on its centerline, thickness and offset.
Public enumeration | gbXMLOpeningType | This enumeration corresponds to the openingType attribute in gbXML and identifies the type of opening defined.
Public enumeration | gbXMLServiceType | This enumeration corresponds to the systemType attribute in gbXML and is used for specifying the service for the building or space.
Public enumeration | gbXMLSpaceType | This enumeration corresponds to the spaceType attribute in gbXML. The enumerated attribute identifies the type of space defined and allows to better approximate the actual internal loads and schedules associated with the defined space type.
Public enumeration | gbXMLSurfaceType | This enumeration corresponds to the surfaceType attribute in gbXML and identifies the type of surface defined.
Public enumeration | HVACLoadConstructionClass | Enumerated type listing options for construction class for HVAC analysis.
Public enumeration | HVACLoadLoadsReportType | Enumerated type listing possible types of reports generated for HVAC loads.
Public enumeration | MassSurfaceDataMaterialType | Indicates how the visualization material for the MassSurfaceData is calculated.
Public enumeration | MassSurfaceDataSource | Indicates whether values for the properties of the MassSurfaceData are synchronized with the EnergyDataSettings of the document or instead, serve as overrides of those settings.
Public enumeration | MEPAnalyticalSegmentType | The type of analytical segment.
Public enumeration | OutdoorAirFlowStandard | An enumerated type listing all the possible outdoor airflow standard for a space type.
Public enumeration | PathOfTravelCalculationStatus | An enumerated type containing possible results of the Path of Travel calculation.
Public enumeration | SpatialFieldPrimitiveHideMode | Defines modes which can be used by a SpatialFieldPrimitive to hide the original referenced element.
Public enumeration | SystemsAnalysisReportStyle | The report style of systems analysis.


AllowLargeGeometry Enumeration

An enumerated type containing settings information related to handling of large geometries.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum AllowLargeGeometry
Public Enumeration AllowLargeGeometry
public enum class AllowLargeGeometry
type AllowLargeGeometry
Members
Member name | Value | Description
DisAllow | 0 | Cancel the export/path of travel creation, failing with the apporiate status.
Allow | 1 | Allow export/path of travel creation on large geometries.
Prompt | 2 | Prompt in the UI. If no UI is present, default will be DisAllow.
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColoredSurfaceSettings Class

Contains colored surface settings for analysis display style element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DB.AnalysisAnalysisDisplayColoredSurfaceSettings

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AnalysisDisplayColoredSurfaceSettings : IDisposable
Public Class AnalysisDisplayColoredSurfaceSettings
    Implements IDisposable
public ref class AnalysisDisplayColoredSurfaceSettings : IDisposable
type AnalysisDisplayColoredSurfaceSettings =
    class
        interface IDisposable
    end

The AnalysisDisplayColoredSurfaceSettings type exposes the following members.

Constructors
 | Name | Description
Public method | AnalysisDisplayColoredSurfaceSettings | Constructs a default instance of colored surface settings.
Public method | AnalysisDisplayColoredSurfaceSettings(AnalysisDisplayColoredSurfaceSettings) | Constructs a new copy of the input AnalysisDisplayColoredSurfaceSettings object.
Top
Properties
 | Name | Description
Public property | GridColor | Color of grid lines.
Public property | GridLineWeight | Line weight of grid lines.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ShowContourLines | If true, show contour lines in the analysis display.
Public property | ShowGridLines | If true, show grid lines in the analysis display.
Public property | Transparency | Transparency percentage of colored surface
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the AnalysisDisplayColoredSurfaceSettings
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqual | Compares two colored surface settings objects.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Example
C#
VB
C++
F#
Copy
AnalysisDisplayColoredSurfaceSettings coloredSurfaceSettings = new AnalysisDisplayColoredSurfaceSettings();
coloredSurfaceSettings.ShowGridLines = true;
Dim coloredSurfaceSettings As New AnalysisDisplayColoredSurfaceSettings()
coloredSurfaceSettings.ShowGridLines = True

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColoredSurfaceSettings Constructor

Overload List
 | Name | Description
Public method | AnalysisDisplayColoredSurfaceSettings | Constructs a default instance of colored surface settings.
Public method | AnalysisDisplayColoredSurfaceSettings(AnalysisDisplayColoredSurfaceSettings) | Constructs a new copy of the input AnalysisDisplayColoredSurfaceSettings object.
Top
See Also

Reference

AnalysisDisplayColoredSurfaceSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColoredSurfaceSettings Constructor

Constructs a default instance of colored surface settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AnalysisDisplayColoredSurfaceSettings()
Public Sub New
public:
AnalysisDisplayColoredSurfaceSettings()
new : unit -> AnalysisDisplayColoredSurfaceSettings
See Also

Reference

AnalysisDisplayColoredSurfaceSettings Class
AnalysisDisplayColoredSurfaceSettings Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColoredSurfaceSettings(AnalysisDisplayColoredSurfaceSettings) Constructor

Constructs a new copy of the input AnalysisDisplayColoredSurfaceSettings object.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AnalysisDisplayColoredSurfaceSettings(
    AnalysisDisplayColoredSurfaceSettings other
)
Public Sub New (
    other As AnalysisDisplayColoredSurfaceSettings
)
public:
AnalysisDisplayColoredSurfaceSettings(
    AnalysisDisplayColoredSurfaceSettings^ other
)
new :
        other : AnalysisDisplayColoredSurfaceSettings -> AnalysisDisplayColoredSurfaceSettings

Parameters

other AnalysisDisplayColoredSurfaceSettings
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

AnalysisDisplayColoredSurfaceSettings Class
AnalysisDisplayColoredSurfaceSettings Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColoredSurfaceSettings Properties

The AnalysisDisplayColoredSurfaceSettings type exposes the following members.

Properties
 | Name | Description
Public property | GridColor | Color of grid lines.
Public property | GridLineWeight | Line weight of grid lines.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | ShowContourLines | If true, show contour lines in the analysis display.
Public property | ShowGridLines | If true, show grid lines in the analysis display.
Public property | Transparency | Transparency percentage of colored surface
Top
See Also

Reference

AnalysisDisplayColoredSurfaceSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColoredSurfaceSettings.GridColor Property

AnalysisDisplayColoredSurfaceSettingsGridColor Property

Color of grid lines.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color GridColor { get; set; }
Public Property GridColor As Color
    Get
    Set
public:
property Color^ GridColor {
    Color^ get ();
    void set (Color^ value);
}
member GridColor : Color with get, set

Property Value

Color
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

AnalysisDisplayColoredSurfaceSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColoredSurfaceSettings.GridLineWeight Property

AnalysisDisplayColoredSurfaceSettingsGridLineWeight Property

Line weight of grid lines.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GridLineWeight { get; set; }
Public Property GridLineWeight As Integer
    Get
    Set
public:
property int GridLineWeight {
    int get ();
    void set (int value);
}
member GridLineWeight : int with get, set

Property Value

Int32
See Also

Reference

AnalysisDisplayColoredSurfaceSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColoredSurfaceSettings.IsValidObject Property

AnalysisDisplayColoredSurfaceSettingsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

AnalysisDisplayColoredSurfaceSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColoredSurfaceSettings.ShowContourLines Property

AnalysisDisplayColoredSurfaceSettingsShowContourLines Property

If true, show contour lines in the analysis display.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShowContourLines { get; set; }
Public Property ShowContourLines As Boolean
    Get
    Set
public:
property bool ShowContourLines {
    bool get ();
    void set (bool value);
}
member ShowContourLines : bool with get, set

Property Value

Boolean
See Also

Reference

AnalysisDisplayColoredSurfaceSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColoredSurfaceSettings.ShowGridLines Property

AnalysisDisplayColoredSurfaceSettingsShowGridLines Property

If true, show grid lines in the analysis display.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShowGridLines { get; set; }
Public Property ShowGridLines As Boolean
    Get
    Set
public:
property bool ShowGridLines {
    bool get ();
    void set (bool value);
}
member ShowGridLines : bool with get, set

Property Value

Boolean
See Also

Reference

AnalysisDisplayColoredSurfaceSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColoredSurfaceSettings.Transparency Property

AnalysisDisplayColoredSurfaceSettingsTransparency Property

Transparency percentage of colored surface

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Transparency { get; set; }
Public Property Transparency As Integer
    Get
    Set
public:
property int Transparency {
    int get ();
    void set (int value);
}
member Transparency : int with get, set

Property Value

Int32
Exceptions
Exception | Condition
ArgumentsInconsistentException | When setting this property: transparency is less than 0 or greater than 100
See Also

Reference

AnalysisDisplayColoredSurfaceSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColoredSurfaceSettings Methods

The AnalysisDisplayColoredSurfaceSettings type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqual | Compares two colored surface settings objects.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AnalysisDisplayColoredSurfaceSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColoredSurfaceSettings.Dispose Method

AnalysisDisplayColoredSurfaceSettingsDispose Method

Releases all resources used by the AnalysisDisplayColoredSurfaceSettings

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

AnalysisDisplayColoredSurfaceSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColoredSurfaceSettings.IsEqual Method

AnalysisDisplayColoredSurfaceSettingsIsEqual Method

Compares two colored surface settings objects.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEqual(
    AnalysisDisplayColoredSurfaceSettings other
)
Public Function IsEqual (
    other As AnalysisDisplayColoredSurfaceSettings
) As Boolean
public:
bool IsEqual(
    AnalysisDisplayColoredSurfaceSettings^ other
)
member IsEqual :
        other : AnalysisDisplayColoredSurfaceSettings -> bool

Parameters

other AnalysisDisplayColoredSurfaceSettings
Colored surface settings object to compare with.

Return Value

Boolean
True if objects are equal, false otherwise.
See Also

Reference

AnalysisDisplayColoredSurfaceSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorEntry Class

Contains one entry of intermediate colors in color settings for analysis display style.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DB.AnalysisAnalysisDisplayColorEntry

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AnalysisDisplayColorEntry : IDisposable
Public Class AnalysisDisplayColorEntry
    Implements IDisposable
public ref class AnalysisDisplayColorEntry : IDisposable
type AnalysisDisplayColorEntry =
    class
        interface IDisposable
    end

The AnalysisDisplayColorEntry type exposes the following members.

Constructors
 | Name | Description
Public method | AnalysisDisplayColorEntry | Constructs a new AnalysisDisplayColorEntry with default settings.
Public method | AnalysisDisplayColorEntry(Color) | Constructs a color entry with no value assigned.
Public method | AnalysisDisplayColorEntry(Color, Double) | Constructs a color entry with a specific value assigned.
Top
Properties
 | Name | Description
Public property | Color | Color associated with color entry.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Value | Value associated with color entry.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the AnalysisDisplayColorEntry
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HasValue | Check if color entry has associated value.
Public method | IsEqual | Compare color entries.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorEntry Constructor

Overload List
 | Name | Description
Public method | AnalysisDisplayColorEntry | Constructs a new AnalysisDisplayColorEntry with default settings.
Public method | AnalysisDisplayColorEntry(Color) | Constructs a color entry with no value assigned.
Public method | AnalysisDisplayColorEntry(Color, Double) | Constructs a color entry with a specific value assigned.
Top
See Also

Reference

AnalysisDisplayColorEntry Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorEntry Constructor

Constructs a new AnalysisDisplayColorEntry with default settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AnalysisDisplayColorEntry()
Public Sub New
public:
AnalysisDisplayColorEntry()
new : unit -> AnalysisDisplayColorEntry
See Also

Reference

AnalysisDisplayColorEntry Class
AnalysisDisplayColorEntry Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorEntry(Color) Constructor

Constructs a color entry with no value assigned.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AnalysisDisplayColorEntry(
    Color color
)
Public Sub New (
    color As Color
)
public:
AnalysisDisplayColorEntry(
    Color^ color
)
new :
        color : Color -> AnalysisDisplayColorEntry

Parameters

color Color
Color assigned to the entry.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

AnalysisDisplayColorEntry Class
AnalysisDisplayColorEntry Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorEntry(Color, Double) Constructor

Constructs a color entry with a specific value assigned.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AnalysisDisplayColorEntry(
    Color color,
    double value
)
Public Sub New (
    color As Color,
    value As Double
)
public:
AnalysisDisplayColorEntry(
    Color^ color,
    double value
)
new :
        color : Color *
        value : float -> AnalysisDisplayColorEntry

Parameters

color Color
Color assigned to the entry.
value Double
Value assigned to the entry.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

AnalysisDisplayColorEntry Class
AnalysisDisplayColorEntry Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorEntry Properties

The AnalysisDisplayColorEntry type exposes the following members.

Properties
 | Name | Description
Public property | Color | Color associated with color entry.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Value | Value associated with color entry.
Top
See Also

Reference

AnalysisDisplayColorEntry Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorEntry.Color Property

AnalysisDisplayColorEntryColor Property

Color associated with color entry.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color Color { get; }
Public ReadOnly Property Color As Color
    Get
public:
property Color^ Color {
    Color^ get ();
}
member Color : Color with get

Property Value

Color
See Also

Reference

AnalysisDisplayColorEntry Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorEntry.IsValidObject Property

AnalysisDisplayColorEntryIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

AnalysisDisplayColorEntry Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorEntry.Value Property

AnalysisDisplayColorEntryValue Property

Value associated with color entry.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Value { get; }
Public ReadOnly Property Value As Double
    Get
public:
property double Value {
    double get ();
}
member Value : float with get

Property Value

Double
See Also

Reference

AnalysisDisplayColorEntry Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorEntry Methods

The AnalysisDisplayColorEntry type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | HasValue | Check if color entry has associated value.
Public method | IsEqual | Compare color entries.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AnalysisDisplayColorEntry Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorEntry.Dispose Method

AnalysisDisplayColorEntryDispose Method

Releases all resources used by the AnalysisDisplayColorEntry

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

AnalysisDisplayColorEntry Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorEntry.HasValue Method

AnalysisDisplayColorEntryHasValue Method

Check if color entry has associated value.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasValue()
Public Function HasValue As Boolean
public:
bool HasValue()
member HasValue : unit -> bool

Return Value

Boolean
True if entry has a value associated with it, false otherwise.
See Also

Reference

AnalysisDisplayColorEntry Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorEntry.IsEqual Method

AnalysisDisplayColorEntryIsEqual Method

Compare color entries.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEqual(
    AnalysisDisplayColorEntry other
)
Public Function IsEqual (
    other As AnalysisDisplayColorEntry
) As Boolean
public:
bool IsEqual(
    AnalysisDisplayColorEntry^ other
)
member IsEqual :
        other : AnalysisDisplayColorEntry -> bool

Parameters

other AnalysisDisplayColorEntry
Color entry to compare to.

Return Value

Boolean
True if color entries are equal, false otherwise.
See Also

Reference

AnalysisDisplayColorEntry Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorSettings Class

Contains color settings for analysis display style element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DB.AnalysisAnalysisDisplayColorSettings

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AnalysisDisplayColorSettings : IDisposable
Public Class AnalysisDisplayColorSettings
    Implements IDisposable
public ref class AnalysisDisplayColorSettings : IDisposable
type AnalysisDisplayColorSettings =
    class
        interface IDisposable
    end

The AnalysisDisplayColorSettings type exposes the following members.

Constructors
 | Name | Description
Public method | AnalysisDisplayColorSettings | Constructs a default instance of color settings.
Public method | AnalysisDisplayColorSettings(AnalysisDisplayColorSettings) | Constructs a new copy of the input AnalysisDisplayColorSettings object.
Top
Properties
 | Name | Description
Public property | ColorSettingsType | Stores type of color settings
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MaxColor | Color assigned to the maximum value.
Public property | MinColor | Color assigned to the minimum value.
Top
Methods
 | Name | Description
Public method | AreIntermediateColorsValid | Verify intermediate color entries
Public method | Colors | Get number of colors, including min, max and intermediate.
Public method | Dispose | Releases all resources used by the AnalysisDisplayColorSettings
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIntermediateColors | Get intermediate color entries (other than the minimum and maximum settings).
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqual | Compares two color settings objects.
Public method | SetIntermediateColors | Set intermediate color entries (other than the minimum and maximum settings).
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Example
C#
VB
C++
F#
Copy
AnalysisDisplayColorSettings colorSettings = new AnalysisDisplayColorSettings();
Color orange = new Color(255, 205, 0);
Color purple = new Color(200, 0, 200);
colorSettings.MaxColor = orange;
colorSettings.MinColor = purple;
Dim colorSettings As New AnalysisDisplayColorSettings()
Dim orange As New Color(255, 205, 0)
Dim purple As New Color(200, 0, 200)
colorSettings.MaxColor = orange
colorSettings.MinColor = purple

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorSettings Constructor

Overload List
 | Name | Description
Public method | AnalysisDisplayColorSettings | Constructs a default instance of color settings.
Public method | AnalysisDisplayColorSettings(AnalysisDisplayColorSettings) | Constructs a new copy of the input AnalysisDisplayColorSettings object.
Top
See Also

Reference

AnalysisDisplayColorSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorSettings Constructor

Constructs a default instance of color settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AnalysisDisplayColorSettings()
Public Sub New
public:
AnalysisDisplayColorSettings()
new : unit -> AnalysisDisplayColorSettings
See Also

Reference

AnalysisDisplayColorSettings Class
AnalysisDisplayColorSettings Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorSettings(AnalysisDisplayColorSettings) Constructor

Constructs a new copy of the input AnalysisDisplayColorSettings object.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AnalysisDisplayColorSettings(
    AnalysisDisplayColorSettings other
)
Public Sub New (
    other As AnalysisDisplayColorSettings
)
public:
AnalysisDisplayColorSettings(
    AnalysisDisplayColorSettings^ other
)
new :
        other : AnalysisDisplayColorSettings -> AnalysisDisplayColorSettings

Parameters

other AnalysisDisplayColorSettings
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

AnalysisDisplayColorSettings Class
AnalysisDisplayColorSettings Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorSettings Properties

The AnalysisDisplayColorSettings type exposes the following members.

Properties
 | Name | Description
Public property | ColorSettingsType | Stores type of color settings
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MaxColor | Color assigned to the maximum value.
Public property | MinColor | Color assigned to the minimum value.
Top
See Also

Reference

AnalysisDisplayColorSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorSettings.ColorSettingsType Property

AnalysisDisplayColorSettingsColorSettingsType Property

Stores type of color settings

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AnalysisDisplayStyleColorSettingsType ColorSettingsType { get; set; }
Public Property ColorSettingsType As AnalysisDisplayStyleColorSettingsType
    Get
    Set
public:
property AnalysisDisplayStyleColorSettingsType ColorSettingsType {
    AnalysisDisplayStyleColorSettingsType get ();
    void set (AnalysisDisplayStyleColorSettingsType value);
}
member ColorSettingsType : AnalysisDisplayStyleColorSettingsType with get, set

Property Value

AnalysisDisplayStyleColorSettingsType
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

AnalysisDisplayColorSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorSettings.IsValidObject Property

AnalysisDisplayColorSettingsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

AnalysisDisplayColorSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorSettings.MaxColor Property

AnalysisDisplayColorSettingsMaxColor Property

Color assigned to the maximum value.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color MaxColor { get; set; }
Public Property MaxColor As Color
    Get
    Set
public:
property Color^ MaxColor {
    Color^ get ();
    void set (Color^ value);
}
member MaxColor : Color with get, set

Property Value

Color
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

AnalysisDisplayColorSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorSettings.MinColor Property

AnalysisDisplayColorSettingsMinColor Property

Color assigned to the minimum value.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color MinColor { get; set; }
Public Property MinColor As Color
    Get
    Set
public:
property Color^ MinColor {
    Color^ get ();
    void set (Color^ value);
}
member MinColor : Color with get, set

Property Value

Color
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

AnalysisDisplayColorSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorSettings Methods

The AnalysisDisplayColorSettings type exposes the following members.

Methods
 | Name | Description
Public method | AreIntermediateColorsValid | Verify intermediate color entries
Public method | Colors | Get number of colors, including min, max and intermediate.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIntermediateColors | Get intermediate color entries (other than the minimum and maximum settings).
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqual | Compares two color settings objects.
Public method | SetIntermediateColors | Set intermediate color entries (other than the minimum and maximum settings).
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AnalysisDisplayColorSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorSettings.AreIntermediateColorsValid Method

AnalysisDisplayColorSettingsAreIntermediateColorsValid Method

Verify intermediate color entries

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AreIntermediateColorsValid(
    IList<AnalysisDisplayColorEntry> map
)
Public Function AreIntermediateColorsValid (
    map As IList(Of AnalysisDisplayColorEntry)
) As Boolean
public:
bool AreIntermediateColorsValid(
    IList<AnalysisDisplayColorEntry^>^ map
)
member AreIntermediateColorsValid :
        map : IList<AnalysisDisplayColorEntry> -> bool

Parameters

map IList AnalysisDisplayColorEntry
Array of intermediate color entries.

Return Value

Boolean
True if intermediate colors are valid, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

AnalysisDisplayColorSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorSettings.Colors Method

AnalysisDisplayColorSettingsColors Method

Get number of colors, including min, max and intermediate.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Colors()
Public Function Colors As Integer
public:
int Colors()
member Colors : unit -> int

Return Value

Int32
Number of colors, including min, max and intermediate.
See Also

Reference

AnalysisDisplayColorSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorSettings.Dispose Method

AnalysisDisplayColorSettingsDispose Method

Releases all resources used by the AnalysisDisplayColorSettings

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

AnalysisDisplayColorSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorSettings.GetIntermediateColors Method

AnalysisDisplayColorSettingsGetIntermediateColors Method

Get intermediate color entries (other than the minimum and maximum settings).

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<AnalysisDisplayColorEntry> GetIntermediateColors()
Public Function GetIntermediateColors As IList(Of AnalysisDisplayColorEntry)
public:
IList<AnalysisDisplayColorEntry^>^ GetIntermediateColors()
member GetIntermediateColors : unit -> IList<AnalysisDisplayColorEntry>

Return Value

IList AnalysisDisplayColorEntry
Array of intermediate color entries.
See Also

Reference

AnalysisDisplayColorSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorSettings.IsEqual Method

AnalysisDisplayColorSettingsIsEqual Method

Compares two color settings objects.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEqual(
    AnalysisDisplayColorSettings other
)
Public Function IsEqual (
    other As AnalysisDisplayColorSettings
) As Boolean
public:
bool IsEqual(
    AnalysisDisplayColorSettings^ other
)
member IsEqual :
        other : AnalysisDisplayColorSettings -> bool

Parameters

other AnalysisDisplayColorSettings
Color settings object to compare to.

Return Value

Boolean
True if objects are equal, false otherwise.
See Also

Reference

AnalysisDisplayColorSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorSettings.SetIntermediateColors Method

AnalysisDisplayColorSettingsSetIntermediateColors Method

Set intermediate color entries (other than the minimum and maximum settings).

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetIntermediateColors(
    IList<AnalysisDisplayColorEntry> map
)
Public Sub SetIntermediateColors (
    map As IList(Of AnalysisDisplayColorEntry)
)
public:
void SetIntermediateColors(
    IList<AnalysisDisplayColorEntry^>^ map
)
member SetIntermediateColors :
        map : IList<AnalysisDisplayColorEntry> -> unit

Parameters

map IList AnalysisDisplayColorEntry
Array of intermediate color entries.
Exceptions
Exception | Condition
ArgumentException | intermediate color entries with specific values are not ordered by value (min to max) or too many intermediate colors (>100).
ArgumentNullException | A non-optional argument was null
See Also

Reference

AnalysisDisplayColorSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayDeformedShapeSettings Class

Contains deformed shape settings for analysis display style element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DB.AnalysisAnalysisDisplayDeformedShapeSettings

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AnalysisDisplayDeformedShapeSettings : IDisposable
Public Class AnalysisDisplayDeformedShapeSettings
    Implements IDisposable
public ref class AnalysisDisplayDeformedShapeSettings : IDisposable
type AnalysisDisplayDeformedShapeSettings =
    class
        interface IDisposable
    end

The AnalysisDisplayDeformedShapeSettings type exposes the following members.

Constructors
 | Name | Description
Public method | AnalysisDisplayDeformedShapeSettings | Constructs a default instance of deformed shape settings.
Public method | AnalysisDisplayDeformedShapeSettings(AnalysisDisplayDeformedShapeSettings) | Constructs a new copy of the input AnalysisDisplayDeformedShapeSettings object.
Top
Properties
 | Name | Description
Public property | GridColor | Color of grid lines.
Public property | GridLineWeight | Line weight of grid lines.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Rounding | Increment to which numeric values of analysis results are rounded in deformed shape.
Public property | ShowContourLines | If true, show contour lines in the analysis display.
Public property | ShowGridLines | If true, show grid lines in the analysis display.
Public property | TextLabelType | Type of deformed shape text visualization.
Public property | TextTypeId | Element id of text associated with the settings.
Public property | Transparency | Transparency percentage of deformed shape color fill on surfaces
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the AnalysisDisplayDeformedShapeSettings
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqual | Compares two deformed shape settings objects.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayDeformedShapeSettings Constructor

Overload List
 | Name | Description
Public method | AnalysisDisplayDeformedShapeSettings | Constructs a default instance of deformed shape settings.
Public method | AnalysisDisplayDeformedShapeSettings(AnalysisDisplayDeformedShapeSettings) | Constructs a new copy of the input AnalysisDisplayDeformedShapeSettings object.
Top
See Also

Reference

AnalysisDisplayDeformedShapeSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayDeformedShapeSettings Constructor

Constructs a default instance of deformed shape settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AnalysisDisplayDeformedShapeSettings()
Public Sub New
public:
AnalysisDisplayDeformedShapeSettings()
new : unit -> AnalysisDisplayDeformedShapeSettings
See Also

Reference

AnalysisDisplayDeformedShapeSettings Class
AnalysisDisplayDeformedShapeSettings Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayDeformedShapeSettings(AnalysisDisplayDeformedShapeSettings) Constructor

Constructs a new copy of the input AnalysisDisplayDeformedShapeSettings object.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AnalysisDisplayDeformedShapeSettings(
    AnalysisDisplayDeformedShapeSettings other
)
Public Sub New (
    other As AnalysisDisplayDeformedShapeSettings
)
public:
AnalysisDisplayDeformedShapeSettings(
    AnalysisDisplayDeformedShapeSettings^ other
)
new :
        other : AnalysisDisplayDeformedShapeSettings -> AnalysisDisplayDeformedShapeSettings

Parameters

other AnalysisDisplayDeformedShapeSettings
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

AnalysisDisplayDeformedShapeSettings Class
AnalysisDisplayDeformedShapeSettings Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayDeformedShapeSettings Properties

The AnalysisDisplayDeformedShapeSettings type exposes the following members.

Properties
 | Name | Description
Public property | GridColor | Color of grid lines.
Public property | GridLineWeight | Line weight of grid lines.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Rounding | Increment to which numeric values of analysis results are rounded in deformed shape.
Public property | ShowContourLines | If true, show contour lines in the analysis display.
Public property | ShowGridLines | If true, show grid lines in the analysis display.
Public property | TextLabelType | Type of deformed shape text visualization.
Public property | TextTypeId | Element id of text associated with the settings.
Public property | Transparency | Transparency percentage of deformed shape color fill on surfaces
Top
See Also

Reference

AnalysisDisplayDeformedShapeSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayDeformedShapeSettings.GridColor Property

AnalysisDisplayDeformedShapeSettingsGridColor Property

Color of grid lines.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color GridColor { get; set; }
Public Property GridColor As Color
    Get
    Set
public:
property Color^ GridColor {
    Color^ get ();
    void set (Color^ value);
}
member GridColor : Color with get, set

Property Value

Color
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

AnalysisDisplayDeformedShapeSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayDeformedShapeSettings.GridLineWeight Property

AnalysisDisplayDeformedShapeSettingsGridLineWeight Property

Line weight of grid lines.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GridLineWeight { get; set; }
Public Property GridLineWeight As Integer
    Get
    Set
public:
property int GridLineWeight {
    int get ();
    void set (int value);
}
member GridLineWeight : int with get, set

Property Value

Int32
See Also

Reference

AnalysisDisplayDeformedShapeSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayDeformedShapeSettings.IsValidObject Property

AnalysisDisplayDeformedShapeSettingsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

AnalysisDisplayDeformedShapeSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayDeformedShapeSettings.Rounding Property

AnalysisDisplayDeformedShapeSettingsRounding Property

Increment to which numeric values of analysis results are rounded in deformed shape.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Rounding { get; set; }
Public Property Rounding As Double
    Get
    Set
public:
property double Rounding {
    double get ();
    void set (double value);
}
member Rounding : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentsInconsistentException | When setting this property: rounding is not positive
See Also

Reference

AnalysisDisplayDeformedShapeSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayDeformedShapeSettings.ShowContourLines Property

AnalysisDisplayDeformedShapeSettingsShowContourLines Property

If true, show contour lines in the analysis display.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShowContourLines { get; set; }
Public Property ShowContourLines As Boolean
    Get
    Set
public:
property bool ShowContourLines {
    bool get ();
    void set (bool value);
}
member ShowContourLines : bool with get, set

Property Value

Boolean
See Also

Reference

AnalysisDisplayDeformedShapeSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayDeformedShapeSettings.ShowGridLines Property

AnalysisDisplayDeformedShapeSettingsShowGridLines Property

If true, show grid lines in the analysis display.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShowGridLines { get; set; }
Public Property ShowGridLines As Boolean
    Get
    Set
public:
property bool ShowGridLines {
    bool get ();
    void set (bool value);
}
member ShowGridLines : bool with get, set

Property Value

Boolean
See Also

Reference

AnalysisDisplayDeformedShapeSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayDeformedShapeSettings.TextLabelType Property

AnalysisDisplayDeformedShapeSettingsTextLabelType Property

Type of deformed shape text visualization.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AnalysisDisplayStyleDeformedShapeTextLabelType TextLabelType { get; set; }
Public Property TextLabelType As AnalysisDisplayStyleDeformedShapeTextLabelType
    Get
    Set
public:
property AnalysisDisplayStyleDeformedShapeTextLabelType TextLabelType {
    AnalysisDisplayStyleDeformedShapeTextLabelType get ();
    void set (AnalysisDisplayStyleDeformedShapeTextLabelType value);
}
member TextLabelType : AnalysisDisplayStyleDeformedShapeTextLabelType with get, set

Property Value

AnalysisDisplayStyleDeformedShapeTextLabelType
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

AnalysisDisplayDeformedShapeSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayDeformedShapeSettings.TextTypeId Property

AnalysisDisplayDeformedShapeSettingsTextTypeId Property

Element id of text associated with the settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId TextTypeId { get; set; }
Public Property TextTypeId As ElementId
    Get
    Set
public:
property ElementId^ TextTypeId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member TextTypeId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

AnalysisDisplayDeformedShapeSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayDeformedShapeSettings.Transparency Property

AnalysisDisplayDeformedShapeSettingsTransparency Property

Transparency percentage of deformed shape color fill on surfaces

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Transparency { get; set; }
Public Property Transparency As Integer
    Get
    Set
public:
property int Transparency {
    int get ();
    void set (int value);
}
member Transparency : int with get, set

Property Value

Int32
Exceptions
Exception | Condition
ArgumentsInconsistentException | When setting this property: transparency is less than 0 or greater than 100
See Also

Reference

AnalysisDisplayDeformedShapeSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayDeformedShapeSettings Methods

The AnalysisDisplayDeformedShapeSettings type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqual | Compares two deformed shape settings objects.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AnalysisDisplayDeformedShapeSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayDeformedShapeSettings.Dispose Method

AnalysisDisplayDeformedShapeSettingsDispose Method

Releases all resources used by the AnalysisDisplayDeformedShapeSettings

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

AnalysisDisplayDeformedShapeSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayDeformedShapeSettings.IsEqual Method

AnalysisDisplayDeformedShapeSettingsIsEqual Method

Compares two deformed shape settings objects.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEqual(
    AnalysisDisplayDeformedShapeSettings other
)
Public Function IsEqual (
    other As AnalysisDisplayDeformedShapeSettings
) As Boolean
public:
bool IsEqual(
    AnalysisDisplayDeformedShapeSettings^ other
)
member IsEqual :
        other : AnalysisDisplayDeformedShapeSettings -> bool

Parameters

other AnalysisDisplayDeformedShapeSettings
Deformed shape settings object to compare with.

Return Value

Boolean
True if objects are equal, false otherwise.
See Also

Reference

AnalysisDisplayDeformedShapeSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayDiagramSettings Class

Contains diagram settings for analysis display style element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DB.AnalysisAnalysisDisplayDiagramSettings

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AnalysisDisplayDiagramSettings : IDisposable
Public Class AnalysisDisplayDiagramSettings
    Implements IDisposable
public ref class AnalysisDisplayDiagramSettings : IDisposable
type AnalysisDisplayDiagramSettings =
    class
        interface IDisposable
    end

The AnalysisDisplayDiagramSettings type exposes the following members.

Constructors
 | Name | Description
Public method | AnalysisDisplayDiagramSettings | Constructs a default instance of diagram settings.
Public method | AnalysisDisplayDiagramSettings(AnalysisDisplayDiagramSettings) | Constructs a new copy of the input AnalysisDisplayDiagramSettings object.
Top
Properties
 | Name | Description
Public property | FenceType | Type of diagram fence visualization.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OutlineColor | Color of outline and fence lines in the diagram.
Public property | OutlineLineWeight | Line weight of outline and fence lines in the diagram.
Public property | Rounding | Increment to which numeric values of analysis results are rounded in diagram.
Public property | TextLabelType | Type of diagram text label visualization.
Public property | TextTypeId | Element id of text associated with the settings.
Public property | Transparency | Transparency percentage of diagram color fill
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the AnalysisDisplayDiagramSettings
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqual | Compares two diagram settings objects.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayDiagramSettings Constructor

Overload List
 | Name | Description
Public method | AnalysisDisplayDiagramSettings | Constructs a default instance of diagram settings.
Public method | AnalysisDisplayDiagramSettings(AnalysisDisplayDiagramSettings) | Constructs a new copy of the input AnalysisDisplayDiagramSettings object.
Top
See Also

Reference

AnalysisDisplayDiagramSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayDiagramSettings Constructor

Constructs a default instance of diagram settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AnalysisDisplayDiagramSettings()
Public Sub New
public:
AnalysisDisplayDiagramSettings()
new : unit -> AnalysisDisplayDiagramSettings
See Also

Reference

AnalysisDisplayDiagramSettings Class
AnalysisDisplayDiagramSettings Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayDiagramSettings(AnalysisDisplayDiagramSettings) Constructor

Constructs a new copy of the input AnalysisDisplayDiagramSettings object.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AnalysisDisplayDiagramSettings(
    AnalysisDisplayDiagramSettings other
)
Public Sub New (
    other As AnalysisDisplayDiagramSettings
)
public:
AnalysisDisplayDiagramSettings(
    AnalysisDisplayDiagramSettings^ other
)
new :
        other : AnalysisDisplayDiagramSettings -> AnalysisDisplayDiagramSettings

Parameters

other AnalysisDisplayDiagramSettings
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

AnalysisDisplayDiagramSettings Class
AnalysisDisplayDiagramSettings Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayDiagramSettings Properties

The AnalysisDisplayDiagramSettings type exposes the following members.

Properties
 | Name | Description
Public property | FenceType | Type of diagram fence visualization.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OutlineColor | Color of outline and fence lines in the diagram.
Public property | OutlineLineWeight | Line weight of outline and fence lines in the diagram.
Public property | Rounding | Increment to which numeric values of analysis results are rounded in diagram.
Public property | TextLabelType | Type of diagram text label visualization.
Public property | TextTypeId | Element id of text associated with the settings.
Public property | Transparency | Transparency percentage of diagram color fill
Top
See Also

Reference

AnalysisDisplayDiagramSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayDiagramSettings.FenceType Property

AnalysisDisplayDiagramSettingsFenceType Property

Type of diagram fence visualization.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AnalysisDisplayStyleDiagramFenceType FenceType { get; set; }
Public Property FenceType As AnalysisDisplayStyleDiagramFenceType
    Get
    Set
public:
property AnalysisDisplayStyleDiagramFenceType FenceType {
    AnalysisDisplayStyleDiagramFenceType get ();
    void set (AnalysisDisplayStyleDiagramFenceType value);
}
member FenceType : AnalysisDisplayStyleDiagramFenceType with get, set

Property Value

AnalysisDisplayStyleDiagramFenceType
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

AnalysisDisplayDiagramSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayDiagramSettings.IsValidObject Property

AnalysisDisplayDiagramSettingsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

AnalysisDisplayDiagramSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayDiagramSettings.OutlineColor Property

AnalysisDisplayDiagramSettingsOutlineColor Property

Color of outline and fence lines in the diagram.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Color OutlineColor { get; set; }
Public Property OutlineColor As Color
    Get
    Set
public:
property Color^ OutlineColor {
    Color^ get ();
    void set (Color^ value);
}
member OutlineColor : Color with get, set

Property Value

Color
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

AnalysisDisplayDiagramSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayDiagramSettings.OutlineLineWeight Property

AnalysisDisplayDiagramSettingsOutlineLineWeight Property

Line weight of outline and fence lines in the diagram.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int OutlineLineWeight { get; set; }
Public Property OutlineLineWeight As Integer
    Get
    Set
public:
property int OutlineLineWeight {
    int get ();
    void set (int value);
}
member OutlineLineWeight : int with get, set

Property Value

Int32
See Also

Reference

AnalysisDisplayDiagramSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayDiagramSettings.Rounding Property

AnalysisDisplayDiagramSettingsRounding Property

Increment to which numeric values of analysis results are rounded in diagram.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Rounding { get; set; }
Public Property Rounding As Double
    Get
    Set
public:
property double Rounding {
    double get ();
    void set (double value);
}
member Rounding : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentsInconsistentException | When setting this property: rounding is not positive
See Also

Reference

AnalysisDisplayDiagramSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayDiagramSettings.TextLabelType Property

AnalysisDisplayDiagramSettingsTextLabelType Property

Type of diagram text label visualization.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AnalysisDisplayStyleDiagramTextLabelType TextLabelType { get; set; }
Public Property TextLabelType As AnalysisDisplayStyleDiagramTextLabelType
    Get
    Set
public:
property AnalysisDisplayStyleDiagramTextLabelType TextLabelType {
    AnalysisDisplayStyleDiagramTextLabelType get ();
    void set (AnalysisDisplayStyleDiagramTextLabelType value);
}
member TextLabelType : AnalysisDisplayStyleDiagramTextLabelType with get, set

Property Value

AnalysisDisplayStyleDiagramTextLabelType
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

AnalysisDisplayDiagramSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayDiagramSettings.TextTypeId Property

AnalysisDisplayDiagramSettingsTextTypeId Property

Element id of text associated with the settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId TextTypeId { get; set; }
Public Property TextTypeId As ElementId
    Get
    Set
public:
property ElementId^ TextTypeId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member TextTypeId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

AnalysisDisplayDiagramSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayDiagramSettings.Transparency Property

AnalysisDisplayDiagramSettingsTransparency Property

Transparency percentage of diagram color fill

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Transparency { get; set; }
Public Property Transparency As Integer
    Get
    Set
public:
property int Transparency {
    int get ();
    void set (int value);
}
member Transparency : int with get, set

Property Value

Int32
Exceptions
Exception | Condition
ArgumentsInconsistentException | When setting this property: transparency is less than 0 or greater than 100
See Also

Reference

AnalysisDisplayDiagramSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayDiagramSettings Methods

The AnalysisDisplayDiagramSettings type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqual | Compares two diagram settings objects.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AnalysisDisplayDiagramSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayDiagramSettings.Dispose Method

AnalysisDisplayDiagramSettingsDispose Method

Releases all resources used by the AnalysisDisplayDiagramSettings

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

AnalysisDisplayDiagramSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayDiagramSettings.IsEqual Method

AnalysisDisplayDiagramSettingsIsEqual Method

Compares two diagram settings objects.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEqual(
    AnalysisDisplayDiagramSettings other
)
Public Function IsEqual (
    other As AnalysisDisplayDiagramSettings
) As Boolean
public:
bool IsEqual(
    AnalysisDisplayDiagramSettings^ other
)
member IsEqual :
        other : AnalysisDisplayDiagramSettings -> bool

Parameters

other AnalysisDisplayDiagramSettings
Diagram settings object to compare with.

Return Value

Boolean
True if objects are equal, false otherwise.
See Also

Reference

AnalysisDisplayDiagramSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayLegend Class

The legend that describes an Analysis Visualization.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DB.AnalysisAnalysisDisplayLegend

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AnalysisDisplayLegend : Element
Public Class AnalysisDisplayLegend
    Inherits Element
public ref class AnalysisDisplayLegend : public Element
type AnalysisDisplayLegend =
    class
        inherit Element
    end

The AnalysisDisplayLegend type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | Height | The height, in sheet size, of the legend's rectangle
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayLegend Properties

The AnalysisDisplayLegend type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | Height | The height, in sheet size, of the legend's rectangle
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

AnalysisDisplayLegend Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayLegend.Height Property

AnalysisDisplayLegendHeight Property

The height, in sheet size, of the legend's rectangle

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Height { get; set; }
Public Property Height As Double
    Get
    Set
public:
property double Height {
    double get ();
    void set (double value);
}
member Height : float with get, set

Property Value

Double
See Also

Reference

AnalysisDisplayLegend Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayLegend Methods

The AnalysisDisplayLegend type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AnalysisDisplayLegend Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayLegendSettings Class

Contains legend settings for analysis display style element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DB.AnalysisAnalysisDisplayLegendSettings

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AnalysisDisplayLegendSettings : IDisposable
Public Class AnalysisDisplayLegendSettings
    Implements IDisposable
public ref class AnalysisDisplayLegendSettings : IDisposable
type AnalysisDisplayLegendSettings =
    class
        interface IDisposable
    end

The AnalysisDisplayLegendSettings type exposes the following members.

Constructors
 | Name | Description
Public method | AnalysisDisplayLegendSettings | Constructs a default instance of legend settings.
Public method | AnalysisDisplayLegendSettings(AnalysisDisplayLegendSettings) | Constructs a new copy of the input AnalysisDisplayLegendSettings object.
Top
Properties
 | Name | Description
Public property | ColorRangeHeight | Height of color range (for Colored Surface, Markers and Text, and Vector display). Measured in paperspace units.
Public property | ColorRangeWidth | Width of color range (for Colored Surface, Markers and Text, and Vector display). Measured in paperspace units.
Public property | HeadingTextTypeId | Element id of text associated with legend heading.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NumberForScale | A fixed value to display on the legend scale (0 by default; 0 means width of legend scale is calculated dynamically).
Public property | NumberOfSteps | Number of steps (values between minimum and maximum) to be shown in legend.
Public property | Rounding | Rounding increment for numeric values of analysis results.
Public property | ScaleHeight | Height of scale (for Diagram display). Measured in paperspace units.
Public property | ShowDataDescription | If true, data description is shown in the legend.
Public property | ShowDataName | If true, data name is shown in the legend.
Public property | ShowLegend | If true, legend is shown in the view.
Public property | ShowUnits | If true, units are shown in the legend.
Public property | TextTypeId | Element id of text associated with legend body.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the AnalysisDisplayLegendSettings
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqual | Compares two legend settings objects.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Example
C#
VB
C++
F#
Copy
AnalysisDisplayLegendSettings legendSettings = new AnalysisDisplayLegendSettings();
legendSettings.NumberOfSteps = 10;
legendSettings.Rounding = 0.05;
legendSettings.ShowDataDescription = false;
legendSettings.ShowLegend = true;
Dim legendSettings As New AnalysisDisplayLegendSettings()
legendSettings.NumberOfSteps = 10
legendSettings.Rounding = 0.05
legendSettings.ShowDataDescription = False
legendSettings.ShowLegend = True

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayLegendSettings Constructor

Overload List
 | Name | Description
Public method | AnalysisDisplayLegendSettings | Constructs a default instance of legend settings.
Public method | AnalysisDisplayLegendSettings(AnalysisDisplayLegendSettings) | Constructs a new copy of the input AnalysisDisplayLegendSettings object.
Top
See Also

Reference

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayLegendSettings Constructor

Constructs a default instance of legend settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AnalysisDisplayLegendSettings()
Public Sub New
public:
AnalysisDisplayLegendSettings()
new : unit -> AnalysisDisplayLegendSettings
See Also

Reference

AnalysisDisplayLegendSettings Class
AnalysisDisplayLegendSettings Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayLegendSettings(AnalysisDisplayLegendSettings) Constructor

Constructs a new copy of the input AnalysisDisplayLegendSettings object.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AnalysisDisplayLegendSettings(
    AnalysisDisplayLegendSettings other
)
Public Sub New (
    other As AnalysisDisplayLegendSettings
)
public:
AnalysisDisplayLegendSettings(
    AnalysisDisplayLegendSettings^ other
)
new :
        other : AnalysisDisplayLegendSettings -> AnalysisDisplayLegendSettings

Parameters

other AnalysisDisplayLegendSettings
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

AnalysisDisplayLegendSettings Class
AnalysisDisplayLegendSettings Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayLegendSettings Properties

The AnalysisDisplayLegendSettings type exposes the following members.

Properties
 | Name | Description
Public property | ColorRangeHeight | Height of color range (for Colored Surface, Markers and Text, and Vector display). Measured in paperspace units.
Public property | ColorRangeWidth | Width of color range (for Colored Surface, Markers and Text, and Vector display). Measured in paperspace units.
Public property | HeadingTextTypeId | Element id of text associated with legend heading.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | NumberForScale | A fixed value to display on the legend scale (0 by default; 0 means width of legend scale is calculated dynamically).
Public property | NumberOfSteps | Number of steps (values between minimum and maximum) to be shown in legend.
Public property | Rounding | Rounding increment for numeric values of analysis results.
Public property | ScaleHeight | Height of scale (for Diagram display). Measured in paperspace units.
Public property | ShowDataDescription | If true, data description is shown in the legend.
Public property | ShowDataName | If true, data name is shown in the legend.
Public property | ShowLegend | If true, legend is shown in the view.
Public property | ShowUnits | If true, units are shown in the legend.
Public property | TextTypeId | Element id of text associated with legend body.
Top
See Also

Reference

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayLegendSettings.ColorRangeHeight Property

AnalysisDisplayLegendSettingsColorRangeHeight Property

Height of color range (for Colored Surface, Markers and Text, and Vector display). Measured in paperspace units.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ColorRangeHeight { get; set; }
Public Property ColorRangeHeight As Integer
    Get
    Set
public:
property int ColorRangeHeight {
    int get ();
    void set (int value);
}
member ColorRangeHeight : int with get, set

Property Value

Int32
Exceptions
Exception | Condition
ArgumentsInconsistentException | When setting this property: colorRangeHeight is greater than 10000 or less than 0
See Also

Reference

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayLegendSettings.ColorRangeWidth Property

AnalysisDisplayLegendSettingsColorRangeWidth Property

Width of color range (for Colored Surface, Markers and Text, and Vector display). Measured in paperspace units.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ColorRangeWidth { get; set; }
Public Property ColorRangeWidth As Integer
    Get
    Set
public:
property int ColorRangeWidth {
    int get ();
    void set (int value);
}
member ColorRangeWidth : int with get, set

Property Value

Int32
Exceptions
Exception | Condition
ArgumentsInconsistentException | When setting this property: colorRangeWidth is greater than 10000 or less than 0
See Also

Reference

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayLegendSettings.HeadingTextTypeId Property

AnalysisDisplayLegendSettingsHeadingTextTypeId Property

Element id of text associated with legend heading.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId HeadingTextTypeId { get; set; }
Public Property HeadingTextTypeId As ElementId
    Get
    Set
public:
property ElementId^ HeadingTextTypeId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member HeadingTextTypeId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayLegendSettings.IsValidObject Property

AnalysisDisplayLegendSettingsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayLegendSettings.NumberForScale Property

AnalysisDisplayLegendSettingsNumberForScale Property

A fixed value to display on the legend scale (0 by default; 0 means width of legend scale is calculated dynamically).

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double NumberForScale { get; set; }
Public Property NumberForScale As Double
    Get
    Set
public:
property double NumberForScale {
    double get ();
    void set (double value);
}
member NumberForScale : float with get, set

Property Value

Double
See Also

Reference

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayLegendSettings.NumberOfSteps Property

AnalysisDisplayLegendSettingsNumberOfSteps Property

Number of steps (values between minimum and maximum) to be shown in legend.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int NumberOfSteps { get; set; }
Public Property NumberOfSteps As Integer
    Get
    Set
public:
property int NumberOfSteps {
    int get ();
    void set (int value);
}
member NumberOfSteps : int with get, set

Property Value

Int32
Exceptions
Exception | Condition
ArgumentsInconsistentException | When setting this property: numberOfSteps is greater than 1000 or less than 0
See Also

Reference

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayLegendSettings.Rounding Property

AnalysisDisplayLegendSettingsRounding Property

Rounding increment for numeric values of analysis results.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Rounding { get; set; }
Public Property Rounding As Double
    Get
    Set
public:
property double Rounding {
    double get ();
    void set (double value);
}
member Rounding : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentsInconsistentException | When setting this property: rounding is not positive
See Also

Reference

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayLegendSettings.ScaleHeight Property

AnalysisDisplayLegendSettingsScaleHeight Property

Height of scale (for Diagram display). Measured in paperspace units.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ScaleHeight { get; set; }
Public Property ScaleHeight As Integer
    Get
    Set
public:
property int ScaleHeight {
    int get ();
    void set (int value);
}
member ScaleHeight : int with get, set

Property Value

Int32
Exceptions
Exception | Condition
ArgumentsInconsistentException | When setting this property: scaleHeight is greater than 10000 or less than 0
See Also

Reference

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayLegendSettings.ShowDataDescription Property

AnalysisDisplayLegendSettingsShowDataDescription Property

If true, data description is shown in the legend.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShowDataDescription { get; set; }
Public Property ShowDataDescription As Boolean
    Get
    Set
public:
property bool ShowDataDescription {
    bool get ();
    void set (bool value);
}
member ShowDataDescription : bool with get, set

Property Value

Boolean
See Also

Reference

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayLegendSettings.ShowDataName Property

AnalysisDisplayLegendSettingsShowDataName Property

If true, data name is shown in the legend.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShowDataName { get; set; }
Public Property ShowDataName As Boolean
    Get
    Set
public:
property bool ShowDataName {
    bool get ();
    void set (bool value);
}
member ShowDataName : bool with get, set

Property Value

Boolean
See Also

Reference

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayLegendSettings.ShowLegend Property

AnalysisDisplayLegendSettingsShowLegend Property

If true, legend is shown in the view.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShowLegend { get; set; }
Public Property ShowLegend As Boolean
    Get
    Set
public:
property bool ShowLegend {
    bool get ();
    void set (bool value);
}
member ShowLegend : bool with get, set

Property Value

Boolean
See Also

Reference

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayLegendSettings.ShowUnits Property

AnalysisDisplayLegendSettingsShowUnits Property

If true, units are shown in the legend.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShowUnits { get; set; }
Public Property ShowUnits As Boolean
    Get
    Set
public:
property bool ShowUnits {
    bool get ();
    void set (bool value);
}
member ShowUnits : bool with get, set

Property Value

Boolean
See Also

Reference

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayLegendSettings.TextTypeId Property

AnalysisDisplayLegendSettingsTextTypeId Property

Element id of text associated with legend body.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId TextTypeId { get; set; }
Public Property TextTypeId As ElementId
    Get
    Set
public:
property ElementId^ TextTypeId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member TextTypeId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayLegendSettings Methods

The AnalysisDisplayLegendSettings type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqual | Compares two legend settings objects.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayLegendSettings.Dispose Method

AnalysisDisplayLegendSettingsDispose Method

Releases all resources used by the AnalysisDisplayLegendSettings

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayLegendSettings.IsEqual Method

AnalysisDisplayLegendSettingsIsEqual Method

Compares two legend settings objects.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEqual(
    AnalysisDisplayLegendSettings other
)
Public Function IsEqual (
    other As AnalysisDisplayLegendSettings
) As Boolean
public:
bool IsEqual(
    AnalysisDisplayLegendSettings^ other
)
member IsEqual :
        other : AnalysisDisplayLegendSettings -> bool

Parameters

other AnalysisDisplayLegendSettings
Legend settings object to compare to.

Return Value

Boolean
True if objects are equal, false otherwise.
See Also

Reference

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayMarkersAndTextSettings Class

Contains markers and text settings for analysis display style element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DB.AnalysisAnalysisDisplayMarkersAndTextSettings

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AnalysisDisplayMarkersAndTextSettings : IDisposable
Public Class AnalysisDisplayMarkersAndTextSettings
    Implements IDisposable
public ref class AnalysisDisplayMarkersAndTextSettings : IDisposable
type AnalysisDisplayMarkersAndTextSettings =
    class
        interface IDisposable
    end

The AnalysisDisplayMarkersAndTextSettings type exposes the following members.

Constructors
 | Name | Description
Public method | AnalysisDisplayMarkersAndTextSettings | Constructs a default instance of markers and text settings.
Public method | AnalysisDisplayMarkersAndTextSettings(AnalysisDisplayMarkersAndTextSettings) | Constructs a new copy of the input AnalysisDisplayMarkersAndTextSettings object.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MarkerSize | Size of marker.
Public property | MarkerType | Type of marker.
Public property | Rounding | Increment to which numeric values of analysis results are rounded in markers.
Public property | TextLabelType | Type of diagram text label visualization.
Public property | TextTypeId | Element id of text associated with the settings.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the AnalysisDisplayMarkersAndTextSettings
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqual | Compares two colored surface settings objects.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Example
C#
VB
C++
F#
Copy
// Settings relating to the marker shape and size and the display of values
AnalysisDisplayMarkersAndTextSettings markerSettings = new AnalysisDisplayMarkersAndTextSettings();
markerSettings.MarkerSize = .05;
markerSettings.MarkerType = AnalysisDisplayStyleMarkerType.Triangle;
markerSettings.Rounding = .01;

// Settings relating to the marker color
AnalysisDisplayColorSettings colorSettings = new AnalysisDisplayColorSettings();
colorSettings.MaxColor = new Color(255, 0, 0);
colorSettings.MinColor = new Color(0, 255, 255);

// Settings relating to the legend
AnalysisDisplayLegendSettings legendSettings = new AnalysisDisplayLegendSettings();
legendSettings.Rounding = .01;

// Create the new display style
AnalysisDisplayStyle ads = AnalysisDisplayStyle.CreateAnalysisDisplayStyle(doc, "Markers 1", markerSettings, colorSettings, legendSettings);

// Assign the new display style to the current view
doc.ActiveView.AnalysisDisplayStyleId = ads.Id;
' Settings relating to the marker shape and size and the display of values
Dim markerSettings As New AnalysisDisplayMarkersAndTextSettings()
markerSettings.MarkerSize = 0.05
markerSettings.MarkerType = AnalysisDisplayStyleMarkerType.Triangle
markerSettings.Rounding = 0.01

' Settings relating to the marker color
Dim colorSettings As New AnalysisDisplayColorSettings()
colorSettings.MaxColor = New Color(255, 0, 0)
colorSettings.MinColor = New Color(0, 255, 255)

' Settings relating to the legend
Dim legendSettings As New AnalysisDisplayLegendSettings()
legendSettings.Rounding = 0.01

' Create the new display style
Dim ads As AnalysisDisplayStyle = AnalysisDisplayStyle.CreateAnalysisDisplayStyle(doc, "Markers 1", markerSettings, colorSettings, legendSettings)

' Assign the new display style to the current view

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayMarkersAndTextSettings Constructor

Overload List
 | Name | Description
Public method | AnalysisDisplayMarkersAndTextSettings | Constructs a default instance of markers and text settings.
Public method | AnalysisDisplayMarkersAndTextSettings(AnalysisDisplayMarkersAndTextSettings) | Constructs a new copy of the input AnalysisDisplayMarkersAndTextSettings object.
Top
See Also

Reference

AnalysisDisplayMarkersAndTextSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayMarkersAndTextSettings Constructor

Constructs a default instance of markers and text settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AnalysisDisplayMarkersAndTextSettings()
Public Sub New
public:
AnalysisDisplayMarkersAndTextSettings()
new : unit -> AnalysisDisplayMarkersAndTextSettings
See Also

Reference

AnalysisDisplayMarkersAndTextSettings Class
AnalysisDisplayMarkersAndTextSettings Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayMarkersAndTextSettings(AnalysisDisplayMarkersAndTextSettings) Constructor

Constructs a new copy of the input AnalysisDisplayMarkersAndTextSettings object.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AnalysisDisplayMarkersAndTextSettings(
    AnalysisDisplayMarkersAndTextSettings other
)
Public Sub New (
    other As AnalysisDisplayMarkersAndTextSettings
)
public:
AnalysisDisplayMarkersAndTextSettings(
    AnalysisDisplayMarkersAndTextSettings^ other
)
new :
        other : AnalysisDisplayMarkersAndTextSettings -> AnalysisDisplayMarkersAndTextSettings

Parameters

other AnalysisDisplayMarkersAndTextSettings
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

AnalysisDisplayMarkersAndTextSettings Class
AnalysisDisplayMarkersAndTextSettings Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayMarkersAndTextSettings Properties

The AnalysisDisplayMarkersAndTextSettings type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | MarkerSize | Size of marker.
Public property | MarkerType | Type of marker.
Public property | Rounding | Increment to which numeric values of analysis results are rounded in markers.
Public property | TextLabelType | Type of diagram text label visualization.
Public property | TextTypeId | Element id of text associated with the settings.
Top
See Also

Reference

AnalysisDisplayMarkersAndTextSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayMarkersAndTextSettings.IsValidObject Property

AnalysisDisplayMarkersAndTextSettingsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

AnalysisDisplayMarkersAndTextSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayMarkersAndTextSettings.MarkerSize Property

AnalysisDisplayMarkersAndTextSettingsMarkerSize Property

Size of marker.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double MarkerSize { get; set; }
Public Property MarkerSize As Double
    Get
    Set
public:
property double MarkerSize {
    double get ();
    void set (double value);
}
member MarkerSize : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentsInconsistentException | When setting this property: markerSize is negative
See Also

Reference

AnalysisDisplayMarkersAndTextSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayMarkersAndTextSettings.MarkerType Property

AnalysisDisplayMarkersAndTextSettingsMarkerType Property

Type of marker.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AnalysisDisplayStyleMarkerType MarkerType { get; set; }
Public Property MarkerType As AnalysisDisplayStyleMarkerType
    Get
    Set
public:
property AnalysisDisplayStyleMarkerType MarkerType {
    AnalysisDisplayStyleMarkerType get ();
    void set (AnalysisDisplayStyleMarkerType value);
}
member MarkerType : AnalysisDisplayStyleMarkerType with get, set

Property Value

AnalysisDisplayStyleMarkerType
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

AnalysisDisplayMarkersAndTextSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayMarkersAndTextSettings.Rounding Property

AnalysisDisplayMarkersAndTextSettingsRounding Property

Increment to which numeric values of analysis results are rounded in markers.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Rounding { get; set; }
Public Property Rounding As Double
    Get
    Set
public:
property double Rounding {
    double get ();
    void set (double value);
}
member Rounding : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentsInconsistentException | When setting this property: rounding is not positive
See Also

Reference

AnalysisDisplayMarkersAndTextSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayMarkersAndTextSettings.TextLabelType Property

AnalysisDisplayMarkersAndTextSettingsTextLabelType Property

Type of diagram text label visualization.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AnalysisDisplayStyleMarkerTextLabelType TextLabelType { get; set; }
Public Property TextLabelType As AnalysisDisplayStyleMarkerTextLabelType
    Get
    Set
public:
property AnalysisDisplayStyleMarkerTextLabelType TextLabelType {
    AnalysisDisplayStyleMarkerTextLabelType get ();
    void set (AnalysisDisplayStyleMarkerTextLabelType value);
}
member TextLabelType : AnalysisDisplayStyleMarkerTextLabelType with get, set

Property Value

AnalysisDisplayStyleMarkerTextLabelType
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

AnalysisDisplayMarkersAndTextSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayMarkersAndTextSettings.TextTypeId Property

AnalysisDisplayMarkersAndTextSettingsTextTypeId Property

Element id of text associated with the settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId TextTypeId { get; set; }
Public Property TextTypeId As ElementId
    Get
    Set
public:
property ElementId^ TextTypeId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member TextTypeId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

AnalysisDisplayMarkersAndTextSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayMarkersAndTextSettings Methods

The AnalysisDisplayMarkersAndTextSettings type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqual | Compares two colored surface settings objects.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AnalysisDisplayMarkersAndTextSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayMarkersAndTextSettings.Dispose Method

AnalysisDisplayMarkersAndTextSettingsDispose Method

Releases all resources used by the AnalysisDisplayMarkersAndTextSettings

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

AnalysisDisplayMarkersAndTextSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayMarkersAndTextSettings.IsEqual Method

AnalysisDisplayMarkersAndTextSettingsIsEqual Method

Compares two colored surface settings objects.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEqual(
    AnalysisDisplayMarkersAndTextSettings other
)
Public Function IsEqual (
    other As AnalysisDisplayMarkersAndTextSettings
) As Boolean
public:
bool IsEqual(
    AnalysisDisplayMarkersAndTextSettings^ other
)
member IsEqual :
        other : AnalysisDisplayMarkersAndTextSettings -> bool

Parameters

other AnalysisDisplayMarkersAndTextSettings
Markers and text settings object to compare with.

Return Value

Boolean
True if objects are equal, false otherwise.
See Also

Reference

AnalysisDisplayMarkersAndTextSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyle Class

Exposes API for manipulation of analysis display style.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DB.AnalysisAnalysisDisplayStyle

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AnalysisDisplayStyle : Element
Public Class AnalysisDisplayStyle
    Inherits Element
public ref class AnalysisDisplayStyle : public Element
type AnalysisDisplayStyle =
    class
        inherit Element
    end

The AnalysisDisplayStyle type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | CreateAnalysisDisplayStyle(Document, String, AnalysisDisplayColoredSurfaceSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) | Factory method - creates analysis display style object of type Colored Surface for the given document.
 | CreateAnalysisDisplayStyle(Document, String, AnalysisDisplayDeformedShapeSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) | Factory method - creates analysis display style object of type Deformed Shape for the given document.
 | CreateAnalysisDisplayStyle(Document, String, AnalysisDisplayDiagramSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) | Factory method - creates analysis display style object of type Diagram for the given document.
 | CreateAnalysisDisplayStyle(Document, String, AnalysisDisplayMarkersAndTextSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) | Factory method - creates analysis display style object of type Markers and Text for the given document.
 | CreateAnalysisDisplayStyle(Document, String, AnalysisDisplayVectorSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) | Factory method - creates analysis display style object of type Vectors for the given document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
 | FindByName | Finds analysis display style by name.
Public method | GetColoredSurfaceSettings | Get colored surface settings object from the style.
Public method | GetColorSettings | Get color settings object from the style.
Public method | GetDeformedShapeSettings | Get deformed shape settings object from the style.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetDiagramSettings | Get diagram settings object from the style.
 | GetElements | Returns set of all analysis display styles elements in the given document.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLegendSettings | Get legend settings object from the style.
Public method | GetMarkersAndTextSettings | Get markers and text settings object from the style.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetVectorSettings | Get vector settings object from the style.
Public method | HasColoredSurfaceSettings | If true style has colored surface settings.
Public method | HasDeformedShapeSettings | If true style has deformed shape settings.
Public method | HasDiagramSettings | If true style has diagram settings.
Public method | HasMarkersAndTextSettings | If true style has markers and text settings.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasVectorSettings | If true style has vector settings.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
 | IsNameUnique | Verify the uniqueness of the name among all analysis display style elements of the document.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
 | IsTextTypeIdValid | Verify if text type id is valid.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetColoredSurfaceSettings | Set colored surface settings object for the style.
Public method | SetColorSettings | Set color settings object for the style.
Public method | SetDeformedShapeSettings | Set deformed shape settings object for the style.
Public method | SetDiagramSettings | Set diagram settings object for the style.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetLegendSettings | Set legend settings object for the style.
Public method | SetMarkersAndTextSettings | Set markers and text settings object for the style.
Public method | SetName | Set name of analysis display style element.
Public method | SetVectorSettings | Set vector settings object for the style.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Example
C#
VB
C++
F#
Copy
Document doc = commandData.Application.ActiveUIDocument.Document;

AnalysisDisplayStyle analysisDisplayStyle = null;
// Look for an existing analysis display style with a specific name
FilteredElementCollector collector1 = new FilteredElementCollector(doc);
ICollection<Element> collection = collector1.OfClass(typeof(AnalysisDisplayStyle)).ToElements();
var displayStyle = from element in collection
                   where element.Name == "Display Style 1"
                   select element;

// If display style does not already exist in the document, create it
if (displayStyle.Count() == 0)
{
    AnalysisDisplayColoredSurfaceSettings coloredSurfaceSettings =
        new AnalysisDisplayColoredSurfaceSettings();
    coloredSurfaceSettings.ShowGridLines = true;

    AnalysisDisplayColorSettings colorSettings = new AnalysisDisplayColorSettings();
    Color orange = new Color(255, 205, 0);
    Color purple = new Color(200, 0, 200);
    colorSettings.MaxColor = orange;
    colorSettings.MinColor = purple;

    AnalysisDisplayLegendSettings legendSettings = new AnalysisDisplayLegendSettings();
    legendSettings.NumberOfSteps = 10;
    legendSettings.Rounding = 0.05;
    legendSettings.ShowDataDescription = false;
    legendSettings.ShowLegend = true;

    analysisDisplayStyle = AnalysisDisplayStyle.CreateAnalysisDisplayStyle(doc,
        "Display Style 1", coloredSurfaceSettings, colorSettings, legendSettings);
}
else
{
    analysisDisplayStyle = displayStyle.Cast<AnalysisDisplayStyle>().ElementAt<AnalysisDisplayStyle>(0);
}

// now assign the display style to the view
doc.ActiveView.AnalysisDisplayStyleId = analysisDisplayStyle.Id;
Dim doc As Document = commandData.Application.ActiveUIDocument.Document

Dim analysisDisplayStyle__1 As AnalysisDisplayStyle = Nothing
' Look for an existing analysis display style with a specific name
Dim collector1 As New FilteredElementCollector(doc)
Dim collection As ICollection(Of Element) = collector1.OfClass(GetType(AnalysisDisplayStyle)).ToElements()
Dim displayStyle As System.Collections.Generic.IEnumerable(Of Autodesk.Revit.DB.Element)
displayStyle = From element In collector1 _
 Where element.Name = "Display Style 1" _
 Select element

' If display style does not already exist in the document, create it
If displayStyle.Count() = 0 Then
   Dim coloredSurfaceSettings As New AnalysisDisplayColoredSurfaceSettings()
   coloredSurfaceSettings.ShowGridLines = True

   Dim colorSettings As New AnalysisDisplayColorSettings()
   Dim orange As New Color(255, 205, 0)
   Dim purple As New Color(200, 0, 200)
   colorSettings.MaxColor = orange
   colorSettings.MinColor = purple

   Dim legendSettings As New AnalysisDisplayLegendSettings()
   legendSettings.NumberOfSteps = 10
   legendSettings.Rounding = 0.05
   legendSettings.ShowDataDescription = False
   legendSettings.ShowLegend = True

   analysisDisplayStyle__1 = AnalysisDisplayStyle.CreateAnalysisDisplayStyle(doc, "Display Style 1", coloredSurfaceSettings, colorSettings, legendSettings)
Else
   analysisDisplayStyle__1 = displayStyle.Cast(Of AnalysisDisplayStyle)().ElementAt(0)
End If

' now assign the display style to the view
doc.ActiveView.AnalysisDisplayStyleId = analysisDisplayStyle__1.Id

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyle Properties

The AnalysisDisplayStyle type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyle Methods

The AnalysisDisplayStyle type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | CreateAnalysisDisplayStyle(Document, String, AnalysisDisplayColoredSurfaceSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) | Factory method - creates analysis display style object of type Colored Surface for the given document.
 | CreateAnalysisDisplayStyle(Document, String, AnalysisDisplayDeformedShapeSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) | Factory method - creates analysis display style object of type Deformed Shape for the given document.
 | CreateAnalysisDisplayStyle(Document, String, AnalysisDisplayDiagramSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) | Factory method - creates analysis display style object of type Diagram for the given document.
 | CreateAnalysisDisplayStyle(Document, String, AnalysisDisplayMarkersAndTextSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) | Factory method - creates analysis display style object of type Markers and Text for the given document.
 | CreateAnalysisDisplayStyle(Document, String, AnalysisDisplayVectorSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) | Factory method - creates analysis display style object of type Vectors for the given document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
 | FindByName | Finds analysis display style by name.
Public method | GetColoredSurfaceSettings | Get colored surface settings object from the style.
Public method | GetColorSettings | Get color settings object from the style.
Public method | GetDeformedShapeSettings | Get deformed shape settings object from the style.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetDiagramSettings | Get diagram settings object from the style.
 | GetElements | Returns set of all analysis display styles elements in the given document.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLegendSettings | Get legend settings object from the style.
Public method | GetMarkersAndTextSettings | Get markers and text settings object from the style.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetVectorSettings | Get vector settings object from the style.
Public method | HasColoredSurfaceSettings | If true style has colored surface settings.
Public method | HasDeformedShapeSettings | If true style has deformed shape settings.
Public method | HasDiagramSettings | If true style has diagram settings.
Public method | HasMarkersAndTextSettings | If true style has markers and text settings.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasVectorSettings | If true style has vector settings.
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
 | IsNameUnique | Verify the uniqueness of the name among all analysis display style elements of the document.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
 | IsTextTypeIdValid | Verify if text type id is valid.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetColoredSurfaceSettings | Set colored surface settings object for the style.
Public method | SetColorSettings | Set color settings object for the style.
Public method | SetDeformedShapeSettings | Set deformed shape settings object for the style.
Public method | SetDiagramSettings | Set diagram settings object for the style.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetLegendSettings | Set legend settings object for the style.
Public method | SetMarkersAndTextSettings | Set markers and text settings object for the style.
Public method | SetName | Set name of analysis display style element.
Public method | SetVectorSettings | Set vector settings object for the style.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyle.CreateAnalysisDisplayStyle Method

AnalysisDisplayStyleCreateAnalysisDisplayStyle Method

Overload List
Name | Description
CreateAnalysisDisplayStyle(Document, String, AnalysisDisplayColoredSurfaceSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) | Factory method - creates analysis display style object of type Colored Surface for the given document.
CreateAnalysisDisplayStyle(Document, String, AnalysisDisplayDeformedShapeSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) | Factory method - creates analysis display style object of type Deformed Shape for the given document.
CreateAnalysisDisplayStyle(Document, String, AnalysisDisplayDiagramSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) | Factory method - creates analysis display style object of type Diagram for the given document.
CreateAnalysisDisplayStyle(Document, String, AnalysisDisplayMarkersAndTextSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) | Factory method - creates analysis display style object of type Markers and Text for the given document.
CreateAnalysisDisplayStyle(Document, String, AnalysisDisplayVectorSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) | Factory method - creates analysis display style object of type Vectors for the given document.
Top
See Also

Reference

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyle.CreateAnalysisDisplayStyle(Document, String, AnalysisDisplayColoredSurfaceSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) Method

AnalysisDisplayStyleCreateAnalysisDisplayStyle(Document, String, AnalysisDisplayColoredSurfaceSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) Method

Factory method - creates analysis display style object of type Colored Surface for the given document.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static AnalysisDisplayStyle CreateAnalysisDisplayStyle(
    Document document,
    string name,
    AnalysisDisplayColoredSurfaceSettings coloredSurfaceSettings,
    AnalysisDisplayColorSettings colorSettings,
    AnalysisDisplayLegendSettings legendSettings
)
Public Shared Function CreateAnalysisDisplayStyle (
    document As Document,
    name As String,
    coloredSurfaceSettings As AnalysisDisplayColoredSurfaceSettings,
    colorSettings As AnalysisDisplayColorSettings,
    legendSettings As AnalysisDisplayLegendSettings
) As AnalysisDisplayStyle
public:
static AnalysisDisplayStyle^ CreateAnalysisDisplayStyle(
    Document^ document,
    String^ name,
    AnalysisDisplayColoredSurfaceSettings^ coloredSurfaceSettings,
    AnalysisDisplayColorSettings^ colorSettings,
    AnalysisDisplayLegendSettings^ legendSettings
)
static member CreateAnalysisDisplayStyle :
        document : Document *
        name : string *
        coloredSurfaceSettings : AnalysisDisplayColoredSurfaceSettings *
        colorSettings : AnalysisDisplayColorSettings *
        legendSettings : AnalysisDisplayLegendSettings -> AnalysisDisplayStyle

Parameters

document Document
Document for which analysis display style object is created.
name String
Name of the analysis display style within the %document%.
coloredSurfaceSettings AnalysisDisplayColoredSurfaceSettings
Colored surface settings for the style.
colorSettings AnalysisDisplayColorSettings
Color settings for the style.
legendSettings AnalysisDisplayLegendSettings
Legend settings for the style.

Return Value

AnalysisDisplayStyle
New analysis display style object.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentsInconsistentException | document is a family. -or- name is not unique in document.
See Also

Reference

AnalysisDisplayStyle Class
CreateAnalysisDisplayStyle Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyle.CreateAnalysisDisplayStyle(Document, String, AnalysisDisplayDeformedShapeSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) Method

AnalysisDisplayStyleCreateAnalysisDisplayStyle(Document, String, AnalysisDisplayDeformedShapeSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) Method

Factory method - creates analysis display style object of type Deformed Shape for the given document.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static AnalysisDisplayStyle CreateAnalysisDisplayStyle(
    Document document,
    string name,
    AnalysisDisplayDeformedShapeSettings deformedShapeSettings,
    AnalysisDisplayColorSettings colorSettings,
    AnalysisDisplayLegendSettings legendSettings
)
Public Shared Function CreateAnalysisDisplayStyle (
    document As Document,
    name As String,
    deformedShapeSettings As AnalysisDisplayDeformedShapeSettings,
    colorSettings As AnalysisDisplayColorSettings,
    legendSettings As AnalysisDisplayLegendSettings
) As AnalysisDisplayStyle
public:
static AnalysisDisplayStyle^ CreateAnalysisDisplayStyle(
    Document^ document,
    String^ name,
    AnalysisDisplayDeformedShapeSettings^ deformedShapeSettings,
    AnalysisDisplayColorSettings^ colorSettings,
    AnalysisDisplayLegendSettings^ legendSettings
)
static member CreateAnalysisDisplayStyle :
        document : Document *
        name : string *
        deformedShapeSettings : AnalysisDisplayDeformedShapeSettings *
        colorSettings : AnalysisDisplayColorSettings *
        legendSettings : AnalysisDisplayLegendSettings -> AnalysisDisplayStyle

Parameters

document Document
Document for which analysis display style object is created.
name String
Name of the analysis display style within the %document%.
deformedShapeSettings AnalysisDisplayDeformedShapeSettings
Deformed Shape settings for the style.
colorSettings AnalysisDisplayColorSettings
Color settings for the style.
legendSettings AnalysisDisplayLegendSettings
Legend settings for the style.

Return Value

AnalysisDisplayStyle
New analysis display style object.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentsInconsistentException | document is a family. -or- name is not unique in document.
See Also

Reference

AnalysisDisplayStyle Class
CreateAnalysisDisplayStyle Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyle.CreateAnalysisDisplayStyle(Document, String, AnalysisDisplayDiagramSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) Method

AnalysisDisplayStyleCreateAnalysisDisplayStyle(Document, String, AnalysisDisplayDiagramSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) Method

Factory method - creates analysis display style object of type Diagram for the given document.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static AnalysisDisplayStyle CreateAnalysisDisplayStyle(
    Document document,
    string name,
    AnalysisDisplayDiagramSettings diagramSettings,
    AnalysisDisplayColorSettings colorSettings,
    AnalysisDisplayLegendSettings legendSettings
)
Public Shared Function CreateAnalysisDisplayStyle (
    document As Document,
    name As String,
    diagramSettings As AnalysisDisplayDiagramSettings,
    colorSettings As AnalysisDisplayColorSettings,
    legendSettings As AnalysisDisplayLegendSettings
) As AnalysisDisplayStyle
public:
static AnalysisDisplayStyle^ CreateAnalysisDisplayStyle(
    Document^ document,
    String^ name,
    AnalysisDisplayDiagramSettings^ diagramSettings,
    AnalysisDisplayColorSettings^ colorSettings,
    AnalysisDisplayLegendSettings^ legendSettings
)
static member CreateAnalysisDisplayStyle :
        document : Document *
        name : string *
        diagramSettings : AnalysisDisplayDiagramSettings *
        colorSettings : AnalysisDisplayColorSettings *
        legendSettings : AnalysisDisplayLegendSettings -> AnalysisDisplayStyle

Parameters

document Document
Document for which analysis display style object is created.
name String
Name of the analysis display style within the %document%.
diagramSettings AnalysisDisplayDiagramSettings
Diagram settings for the style.
colorSettings AnalysisDisplayColorSettings
Color settings for the style.
legendSettings AnalysisDisplayLegendSettings
Legend settings for the style.

Return Value

AnalysisDisplayStyle
New analysis display style object.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentsInconsistentException | document is a family. -or- name is not unique in document.
See Also

Reference

AnalysisDisplayStyle Class
CreateAnalysisDisplayStyle Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyle.CreateAnalysisDisplayStyle(Document, String, AnalysisDisplayMarkersAndTextSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) Method

AnalysisDisplayStyleCreateAnalysisDisplayStyle(Document, String, AnalysisDisplayMarkersAndTextSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) Method

Factory method - creates analysis display style object of type Markers and Text for the given document.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static AnalysisDisplayStyle CreateAnalysisDisplayStyle(
    Document document,
    string name,
    AnalysisDisplayMarkersAndTextSettings markersAndTextSettings,
    AnalysisDisplayColorSettings colorSettings,
    AnalysisDisplayLegendSettings legendSettings
)
Public Shared Function CreateAnalysisDisplayStyle (
    document As Document,
    name As String,
    markersAndTextSettings As AnalysisDisplayMarkersAndTextSettings,
    colorSettings As AnalysisDisplayColorSettings,
    legendSettings As AnalysisDisplayLegendSettings
) As AnalysisDisplayStyle
public:
static AnalysisDisplayStyle^ CreateAnalysisDisplayStyle(
    Document^ document,
    String^ name,
    AnalysisDisplayMarkersAndTextSettings^ markersAndTextSettings,
    AnalysisDisplayColorSettings^ colorSettings,
    AnalysisDisplayLegendSettings^ legendSettings
)
static member CreateAnalysisDisplayStyle :
        document : Document *
        name : string *
        markersAndTextSettings : AnalysisDisplayMarkersAndTextSettings *
        colorSettings : AnalysisDisplayColorSettings *
        legendSettings : AnalysisDisplayLegendSettings -> AnalysisDisplayStyle

Parameters

document Document
Document for which analysis display style object is created.
name String
Name of the analysis display style within the %document%.
markersAndTextSettings AnalysisDisplayMarkersAndTextSettings
Markers and text settings for the style.
colorSettings AnalysisDisplayColorSettings
Color settings for the style.
legendSettings AnalysisDisplayLegendSettings
Legend settings for the style.

Return Value

AnalysisDisplayStyle
New analysis display style object.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentsInconsistentException | document is a family. -or- name is not unique in document.
See Also

Reference

AnalysisDisplayStyle Class
CreateAnalysisDisplayStyle Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyle.CreateAnalysisDisplayStyle(Document, String, AnalysisDisplayVectorSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) Method

AnalysisDisplayStyleCreateAnalysisDisplayStyle(Document, String, AnalysisDisplayVectorSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) Method

Factory method - creates analysis display style object of type Vectors for the given document.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static AnalysisDisplayStyle CreateAnalysisDisplayStyle(
    Document document,
    string name,
    AnalysisDisplayVectorSettings vectorSettings,
    AnalysisDisplayColorSettings colorSettings,
    AnalysisDisplayLegendSettings legendSettings
)
Public Shared Function CreateAnalysisDisplayStyle (
    document As Document,
    name As String,
    vectorSettings As AnalysisDisplayVectorSettings,
    colorSettings As AnalysisDisplayColorSettings,
    legendSettings As AnalysisDisplayLegendSettings
) As AnalysisDisplayStyle
public:
static AnalysisDisplayStyle^ CreateAnalysisDisplayStyle(
    Document^ document,
    String^ name,
    AnalysisDisplayVectorSettings^ vectorSettings,
    AnalysisDisplayColorSettings^ colorSettings,
    AnalysisDisplayLegendSettings^ legendSettings
)
static member CreateAnalysisDisplayStyle :
        document : Document *
        name : string *
        vectorSettings : AnalysisDisplayVectorSettings *
        colorSettings : AnalysisDisplayColorSettings *
        legendSettings : AnalysisDisplayLegendSettings -> AnalysisDisplayStyle

Parameters

document Document
Document for which analysis display style object is created.
name String
Name of the analysis display style within the %document%.
vectorSettings AnalysisDisplayVectorSettings
Vector settings for the style.
colorSettings AnalysisDisplayColorSettings
Color settings for the style.
legendSettings AnalysisDisplayLegendSettings
Legend settings for the style.

Return Value

AnalysisDisplayStyle
New analysis display style object.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentsInconsistentException | document is a family. -or- name is not unique in document.
See Also

Reference

AnalysisDisplayStyle Class
CreateAnalysisDisplayStyle Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyle.FindByName Method

AnalysisDisplayStyleFindByName Method

Finds analysis display style by name.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ElementId FindByName(
    Document document,
    string name
)
Public Shared Function FindByName (
    document As Document,
    name As String
) As ElementId
public:
static ElementId^ FindByName(
    Document^ document,
    String^ name
)
static member FindByName :
        document : Document *
        name : string -> ElementId

Parameters

document Document
Document in which to look for analysis display style element.
name String
Name of analysis display style to look for.

Return Value

ElementId
Element id of the found analysis display style, invalidElementId if not found.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyle.GetColoredSurfaceSettings Method

AnalysisDisplayStyleGetColoredSurfaceSettings Method

Get colored surface settings object from the style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AnalysisDisplayColoredSurfaceSettings GetColoredSurfaceSettings()
Public Function GetColoredSurfaceSettings As AnalysisDisplayColoredSurfaceSettings
public:
AnalysisDisplayColoredSurfaceSettings^ GetColoredSurfaceSettings()
member GetColoredSurfaceSettings : unit -> AnalysisDisplayColoredSurfaceSettings

Return Value

AnalysisDisplayColoredSurfaceSettings
Exceptions
Exception | Condition
InvalidOperationException | colored surface settings were not created with the object.
See Also

Reference

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyle.GetColorSettings Method

AnalysisDisplayStyleGetColorSettings Method

Get color settings object from the style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AnalysisDisplayColorSettings GetColorSettings()
Public Function GetColorSettings As AnalysisDisplayColorSettings
public:
AnalysisDisplayColorSettings^ GetColorSettings()
member GetColorSettings : unit -> AnalysisDisplayColorSettings

Return Value

AnalysisDisplayColorSettings
See Also

Reference

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyle.GetDeformedShapeSettings Method

AnalysisDisplayStyleGetDeformedShapeSettings Method

Get deformed shape settings object from the style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AnalysisDisplayDeformedShapeSettings GetDeformedShapeSettings()
Public Function GetDeformedShapeSettings As AnalysisDisplayDeformedShapeSettings
public:
AnalysisDisplayDeformedShapeSettings^ GetDeformedShapeSettings()
member GetDeformedShapeSettings : unit -> AnalysisDisplayDeformedShapeSettings

Return Value

AnalysisDisplayDeformedShapeSettings
Exceptions
Exception | Condition
InvalidOperationException | deformed shape settings were not created with the object.
See Also

Reference

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyle.GetDiagramSettings Method

AnalysisDisplayStyleGetDiagramSettings Method

Get diagram settings object from the style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AnalysisDisplayDiagramSettings GetDiagramSettings()
Public Function GetDiagramSettings As AnalysisDisplayDiagramSettings
public:
AnalysisDisplayDiagramSettings^ GetDiagramSettings()
member GetDiagramSettings : unit -> AnalysisDisplayDiagramSettings

Return Value

AnalysisDisplayDiagramSettings
Exceptions
Exception | Condition
InvalidOperationException | diagram settings were not created with the object.
See Also

Reference

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyle.GetElements Method

AnalysisDisplayStyleGetElements Method

Returns set of all analysis display styles elements in the given document.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ICollection<ElementId> GetElements(
    Document document
)
Public Shared Function GetElements (
    document As Document
) As ICollection(Of ElementId)
public:
static ICollection<ElementId^>^ GetElements(
    Document^ document
)
static member GetElements :
        document : Document -> ICollection<ElementId>

Parameters

document Document
Document from which analysis display style elements are retrieved.

Return Value

ICollection ElementId
All analysis display style elements existing in the document.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyle.GetLegendSettings Method

AnalysisDisplayStyleGetLegendSettings Method

Get legend settings object from the style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AnalysisDisplayLegendSettings GetLegendSettings()
Public Function GetLegendSettings As AnalysisDisplayLegendSettings
public:
AnalysisDisplayLegendSettings^ GetLegendSettings()
member GetLegendSettings : unit -> AnalysisDisplayLegendSettings

Return Value

AnalysisDisplayLegendSettings
See Also

Reference

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyle.GetMarkersAndTextSettings Method

AnalysisDisplayStyleGetMarkersAndTextSettings Method

Get markers and text settings object from the style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AnalysisDisplayMarkersAndTextSettings GetMarkersAndTextSettings()
Public Function GetMarkersAndTextSettings As AnalysisDisplayMarkersAndTextSettings
public:
AnalysisDisplayMarkersAndTextSettings^ GetMarkersAndTextSettings()
member GetMarkersAndTextSettings : unit -> AnalysisDisplayMarkersAndTextSettings

Return Value

AnalysisDisplayMarkersAndTextSettings
Exceptions
Exception | Condition
InvalidOperationException | markers and text settings were not created with the object.
See Also

Reference

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyle.GetVectorSettings Method

AnalysisDisplayStyleGetVectorSettings Method

Get vector settings object from the style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AnalysisDisplayVectorSettings GetVectorSettings()
Public Function GetVectorSettings As AnalysisDisplayVectorSettings
public:
AnalysisDisplayVectorSettings^ GetVectorSettings()
member GetVectorSettings : unit -> AnalysisDisplayVectorSettings

Return Value

AnalysisDisplayVectorSettings
Exceptions
Exception | Condition
InvalidOperationException | vector settings were not created with the object.
See Also

Reference

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyle.HasColoredSurfaceSettings Method

AnalysisDisplayStyleHasColoredSurfaceSettings Method

If true style has colored surface settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasColoredSurfaceSettings()
Public Function HasColoredSurfaceSettings As Boolean
public:
bool HasColoredSurfaceSettings()
member HasColoredSurfaceSettings : unit -> bool

Return Value

Boolean
See Also

Reference

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyle.HasDeformedShapeSettings Method

AnalysisDisplayStyleHasDeformedShapeSettings Method

If true style has deformed shape settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasDeformedShapeSettings()
Public Function HasDeformedShapeSettings As Boolean
public:
bool HasDeformedShapeSettings()
member HasDeformedShapeSettings : unit -> bool

Return Value

Boolean
See Also

Reference

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyle.HasDiagramSettings Method

AnalysisDisplayStyleHasDiagramSettings Method

If true style has diagram settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasDiagramSettings()
Public Function HasDiagramSettings As Boolean
public:
bool HasDiagramSettings()
member HasDiagramSettings : unit -> bool

Return Value

Boolean
See Also

Reference

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyle.HasMarkersAndTextSettings Method

AnalysisDisplayStyleHasMarkersAndTextSettings Method

If true style has markers and text settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasMarkersAndTextSettings()
Public Function HasMarkersAndTextSettings As Boolean
public:
bool HasMarkersAndTextSettings()
member HasMarkersAndTextSettings : unit -> bool

Return Value

Boolean
See Also

Reference

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyle.HasVectorSettings Method

AnalysisDisplayStyleHasVectorSettings Method

If true style has vector settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasVectorSettings()
Public Function HasVectorSettings As Boolean
public:
bool HasVectorSettings()
member HasVectorSettings : unit -> bool

Return Value

Boolean
See Also

Reference

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyle.IsNameUnique Method

AnalysisDisplayStyleIsNameUnique Method

Verify the uniqueness of the name among all analysis display style elements of the document.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsNameUnique(
    Document document,
    string name,
    AnalysisDisplayStyle excludedElement
)
Public Shared Function IsNameUnique (
    document As Document,
    name As String,
    excludedElement As AnalysisDisplayStyle
) As Boolean
public:
static bool IsNameUnique(
    Document^ document,
    String^ name,
    AnalysisDisplayStyle^ excludedElement
)
static member IsNameUnique :
        document : Document *
        name : string *
        excludedElement : AnalysisDisplayStyle -> bool

Parameters

document Document
Document in which name uniqueness is verified.
name String
Name to verify uniqueness of.
excludedElement AnalysisDisplayStyle
Element to be excluded from uniqueness verification (for renaming of an existing element).

Return Value

Boolean
True if name is unique, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyle.IsTextTypeIdValid Method

AnalysisDisplayStyleIsTextTypeIdValid Method

Verify if text type id is valid.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsTextTypeIdValid(
    ElementId textTypeId,
    Document doc
)
Public Shared Function IsTextTypeIdValid (
    textTypeId As ElementId,
    doc As Document
) As Boolean
public:
static bool IsTextTypeIdValid(
    ElementId^ textTypeId,
    Document^ doc
)
static member IsTextTypeIdValid :
        textTypeId : ElementId *
        doc : Document -> bool

Parameters

textTypeId ElementId
Text type id to be validated.
doc Document
Document for which %textTypeId% is validated.

Return Value

Boolean
True if text type id is valid, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyle.SetColoredSurfaceSettings Method

AnalysisDisplayStyleSetColoredSurfaceSettings Method

Set colored surface settings object for the style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetColoredSurfaceSettings(
    AnalysisDisplayColoredSurfaceSettings coloredSurfaceSettings
)
Public Sub SetColoredSurfaceSettings (
    coloredSurfaceSettings As AnalysisDisplayColoredSurfaceSettings
)
public:
void SetColoredSurfaceSettings(
    AnalysisDisplayColoredSurfaceSettings^ coloredSurfaceSettings
)
member SetColoredSurfaceSettings :
        coloredSurfaceSettings : AnalysisDisplayColoredSurfaceSettings -> unit

Parameters

coloredSurfaceSettings AnalysisDisplayColoredSurfaceSettings
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | colored surface settings were not created with the object.
See Also

Reference

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyle.SetColorSettings Method

AnalysisDisplayStyleSetColorSettings Method

Set color settings object for the style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetColorSettings(
    AnalysisDisplayColorSettings colorSettings
)
Public Sub SetColorSettings (
    colorSettings As AnalysisDisplayColorSettings
)
public:
void SetColorSettings(
    AnalysisDisplayColorSettings^ colorSettings
)
member SetColorSettings :
        colorSettings : AnalysisDisplayColorSettings -> unit

Parameters

colorSettings AnalysisDisplayColorSettings
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentsInconsistentException | for Diagram display style, colorSettings must have type SolidColorRanges and exactly one intermediate entry with zero value
See Also

Reference

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyle.SetDeformedShapeSettings Method

AnalysisDisplayStyleSetDeformedShapeSettings Method

Set deformed shape settings object for the style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetDeformedShapeSettings(
    AnalysisDisplayDeformedShapeSettings deformedShapeSettings
)
Public Sub SetDeformedShapeSettings (
    deformedShapeSettings As AnalysisDisplayDeformedShapeSettings
)
public:
void SetDeformedShapeSettings(
    AnalysisDisplayDeformedShapeSettings^ deformedShapeSettings
)
member SetDeformedShapeSettings :
        deformedShapeSettings : AnalysisDisplayDeformedShapeSettings -> unit

Parameters

deformedShapeSettings AnalysisDisplayDeformedShapeSettings
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Deformed shape settings were not created with the object.
See Also

Reference

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyle.SetDiagramSettings Method

AnalysisDisplayStyleSetDiagramSettings Method

Set diagram settings object for the style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetDiagramSettings(
    AnalysisDisplayDiagramSettings diagramSettings
)
Public Sub SetDiagramSettings (
    diagramSettings As AnalysisDisplayDiagramSettings
)
public:
void SetDiagramSettings(
    AnalysisDisplayDiagramSettings^ diagramSettings
)
member SetDiagramSettings :
        diagramSettings : AnalysisDisplayDiagramSettings -> unit

Parameters

diagramSettings AnalysisDisplayDiagramSettings
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | diagram settings were not created with the object.
See Also

Reference

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyle.SetLegendSettings Method

AnalysisDisplayStyleSetLegendSettings Method

Set legend settings object for the style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetLegendSettings(
    AnalysisDisplayLegendSettings legendSettings
)
Public Sub SetLegendSettings (
    legendSettings As AnalysisDisplayLegendSettings
)
public:
void SetLegendSettings(
    AnalysisDisplayLegendSettings^ legendSettings
)
member SetLegendSettings :
        legendSettings : AnalysisDisplayLegendSettings -> unit

Parameters

legendSettings AnalysisDisplayLegendSettings
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyle.SetMarkersAndTextSettings Method

AnalysisDisplayStyleSetMarkersAndTextSettings Method

Set markers and text settings object for the style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetMarkersAndTextSettings(
    AnalysisDisplayMarkersAndTextSettings markersAndTextSettings
)
Public Sub SetMarkersAndTextSettings (
    markersAndTextSettings As AnalysisDisplayMarkersAndTextSettings
)
public:
void SetMarkersAndTextSettings(
    AnalysisDisplayMarkersAndTextSettings^ markersAndTextSettings
)
member SetMarkersAndTextSettings :
        markersAndTextSettings : AnalysisDisplayMarkersAndTextSettings -> unit

Parameters

markersAndTextSettings AnalysisDisplayMarkersAndTextSettings
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | markers and text settings were not created with the object.
See Also

Reference

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyle.SetName Method

AnalysisDisplayStyleSetName Method

Set name of analysis display style element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetName(
    string name
)
Public Sub SetName (
    name As String
)
public:
void SetName(
    String^ name
)
member SetName :
        name : string -> unit

Parameters

name String
Analysis display style element name to be set.
Exceptions
Exception | Condition
ArgumentException | name is not unique in document.
ArgumentNullException | A non-optional argument was null
See Also

Reference

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyle.SetVectorSettings Method

AnalysisDisplayStyleSetVectorSettings Method

Set vector settings object for the style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetVectorSettings(
    AnalysisDisplayVectorSettings vectorSettings
)
Public Sub SetVectorSettings (
    vectorSettings As AnalysisDisplayVectorSettings
)
public:
void SetVectorSettings(
    AnalysisDisplayVectorSettings^ vectorSettings
)
member SetVectorSettings :
        vectorSettings : AnalysisDisplayVectorSettings -> unit

Parameters

vectorSettings AnalysisDisplayVectorSettings
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Vector settings were not created with the object.
See Also

Reference

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyleColorSettingsType Enumeration

Defines types for color settings of analysis display style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum AnalysisDisplayStyleColorSettingsType
Public Enumeration AnalysisDisplayStyleColorSettingsType
public enum class AnalysisDisplayStyleColorSettingsType
type AnalysisDisplayStyleColorSettingsType
Members
Member name | Value | Description
GradientColor | 0 | Intermediate and min/max color settings are used to interpolate color for values between adjacent entries.
SolidColorRanges | 1 | Intermediate and min/max color settings define ranges in which the color is constant.
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyleDeformedShapeTextLabelType Enumeration

Defines text visualization types for deformed shape settings of analysis display style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum AnalysisDisplayStyleDeformedShapeTextLabelType
Public Enumeration AnalysisDisplayStyleDeformedShapeTextLabelType
public enum class AnalysisDisplayStyleDeformedShapeTextLabelType
type AnalysisDisplayStyleDeformedShapeTextLabelType
Members
Member name | Value | Description
ShowAll | 0 | Show vector text label for each point
ShowNone | 1 | Don't show deformed shape text labels
ShowPredefined | 2 | Show deformed shape text label only for points that have flag ValueAtPointFlags::DisplayText
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyleDiagramFenceType Enumeration

Defines fence visualization types for diagram settings of analysis display style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum AnalysisDisplayStyleDiagramFenceType
Public Enumeration AnalysisDisplayStyleDiagramFenceType
public enum class AnalysisDisplayStyleDiagramFenceType
type AnalysisDisplayStyleDiagramFenceType
Members
Member name | Value | Description
ShowAll | 0 | Show fence for each point
ShowNone | 1 | Don't show fence
ShowPredefined | 2 | Show fence only for points that have flag ValueAtPointFlags::DisplayFence
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyleDiagramTextLabelType Enumeration

Defines text label visualization types for diagram settings of analysis display style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum AnalysisDisplayStyleDiagramTextLabelType
Public Enumeration AnalysisDisplayStyleDiagramTextLabelType
public enum class AnalysisDisplayStyleDiagramTextLabelType
type AnalysisDisplayStyleDiagramTextLabelType
Members
Member name | Value | Description
ShowAll | 0 | Show diagram text label for each point
ShowNone | 1 | Don't show diagram text labels
ShowPredefined | 2 | Show diagram text label only for points that have flag ValueAtPointFlags::DisplayText
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyleMarkerTextLabelType Enumeration

Text label visualization types for Markers and Text settings of analysis display style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum AnalysisDisplayStyleMarkerTextLabelType
Public Enumeration AnalysisDisplayStyleMarkerTextLabelType
public enum class AnalysisDisplayStyleMarkerTextLabelType
type AnalysisDisplayStyleMarkerTextLabelType
Members
Member name | Value | Description
ShowAll | 0 | Show text markers for each point
ShowNone | 1 | Don't show text markers
ShowPredefined | 2 | Show text markers only for points that have flag ValueAtPointFlags::DisplayText
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyleMarkerType Enumeration

Marker types for Markers and Text settings of analysis display style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum AnalysisDisplayStyleMarkerType
Public Enumeration AnalysisDisplayStyleMarkerType
public enum class AnalysisDisplayStyleMarkerType
type AnalysisDisplayStyleMarkerType
Members
Member name | Value | Description
Circle | 0 |
Square | 1 |
Triangle | 2 |
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyleVectorArrowheadScale Enumeration

Defines arrow head scaling for vector settings of analysis display style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum AnalysisDisplayStyleVectorArrowheadScale
Public Enumeration AnalysisDisplayStyleVectorArrowheadScale
public enum class AnalysisDisplayStyleVectorArrowheadScale
type AnalysisDisplayStyleVectorArrowheadScale
Members
Member name | Value | Description
NoScaling | 0 |
Length5Percent | 1 |
Length10Percent | 2 |
Length15Percent | 3 |
Length20Percent | 4 |
NoArrow | 5 |
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyleVectorOrientation Enumeration

Defines vector orientation for vector settings of analysis display style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum AnalysisDisplayStyleVectorOrientation
Public Enumeration AnalysisDisplayStyleVectorOrientation
public enum class AnalysisDisplayStyleVectorOrientation
type AnalysisDisplayStyleVectorOrientation
Members
Member name | Value | Description
Linear | 0 |
ArcAroundVectorAxis | 1 |
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyleVectorPosition Enumeration

Defines vector position for vector settings of analysis display style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum AnalysisDisplayStyleVectorPosition
Public Enumeration AnalysisDisplayStyleVectorPosition
public enum class AnalysisDisplayStyleVectorPosition
type AnalysisDisplayStyleVectorPosition
Members
Member name | Value | Description
ToDataPoint | 0 |
FromDataPoint | 1 |
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyleVectorTextType Enumeration

Defines text visualization types for vector settings of analysis display style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum AnalysisDisplayStyleVectorTextType
Public Enumeration AnalysisDisplayStyleVectorTextType
public enum class AnalysisDisplayStyleVectorTextType
type AnalysisDisplayStyleVectorTextType
Members
Member name | Value | Description
ShowAll | 0 | Show vector text label for each point
ShowNone | 1 | Don't show vector text labels
ShowPredefined | 2 | Show vector text label only for points that have flag ValueAtPointFlags::DisplayText
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayVectorSettings Class

Contains vector settings for analysis display style element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DB.AnalysisAnalysisDisplayVectorSettings

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AnalysisDisplayVectorSettings : IDisposable
Public Class AnalysisDisplayVectorSettings
    Implements IDisposable
public ref class AnalysisDisplayVectorSettings : IDisposable
type AnalysisDisplayVectorSettings =
    class
        interface IDisposable
    end

The AnalysisDisplayVectorSettings type exposes the following members.

Constructors
 | Name | Description
Public method | AnalysisDisplayVectorSettings | Constructs a default instance of vector settings.
Public method | AnalysisDisplayVectorSettings(AnalysisDisplayVectorSettings) | Constructs a new copy of the input AnalysisDisplayVectorSettings object.
Top
Properties
 | Name | Description
Public property | ArrowheadScale | Type of arrow head scaling.
Public property | ArrowLineWeight | Line weight assigned to arrow lines for vectors.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Rounding | Increment to which numeric values of analysis results are rounded in vectors.
Public property | TextTypeId | Element id of text associated with the settings.
Public property | VectorOrientation | Vector orientation.
Public property | VectorPosition | Vector position.
Public property | VectorTextType | Type of vector text visualization.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the AnalysisDisplayVectorSettings
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqual | Compares two vector settings objects.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayVectorSettings Constructor

Overload List
 | Name | Description
Public method | AnalysisDisplayVectorSettings | Constructs a default instance of vector settings.
Public method | AnalysisDisplayVectorSettings(AnalysisDisplayVectorSettings) | Constructs a new copy of the input AnalysisDisplayVectorSettings object.
Top
See Also

Reference

AnalysisDisplayVectorSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayVectorSettings Constructor

Constructs a default instance of vector settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AnalysisDisplayVectorSettings()
Public Sub New
public:
AnalysisDisplayVectorSettings()
new : unit -> AnalysisDisplayVectorSettings
See Also

Reference

AnalysisDisplayVectorSettings Class
AnalysisDisplayVectorSettings Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayVectorSettings(AnalysisDisplayVectorSettings) Constructor

Constructs a new copy of the input AnalysisDisplayVectorSettings object.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AnalysisDisplayVectorSettings(
    AnalysisDisplayVectorSettings other
)
Public Sub New (
    other As AnalysisDisplayVectorSettings
)
public:
AnalysisDisplayVectorSettings(
    AnalysisDisplayVectorSettings^ other
)
new :
        other : AnalysisDisplayVectorSettings -> AnalysisDisplayVectorSettings

Parameters

other AnalysisDisplayVectorSettings
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

AnalysisDisplayVectorSettings Class
AnalysisDisplayVectorSettings Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayVectorSettings Properties

The AnalysisDisplayVectorSettings type exposes the following members.

Properties
 | Name | Description
Public property | ArrowheadScale | Type of arrow head scaling.
Public property | ArrowLineWeight | Line weight assigned to arrow lines for vectors.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Rounding | Increment to which numeric values of analysis results are rounded in vectors.
Public property | TextTypeId | Element id of text associated with the settings.
Public property | VectorOrientation | Vector orientation.
Public property | VectorPosition | Vector position.
Public property | VectorTextType | Type of vector text visualization.
Top
See Also

Reference

AnalysisDisplayVectorSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayVectorSettings.ArrowheadScale Property

AnalysisDisplayVectorSettingsArrowheadScale Property

Type of arrow head scaling.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AnalysisDisplayStyleVectorArrowheadScale ArrowheadScale { get; set; }
Public Property ArrowheadScale As AnalysisDisplayStyleVectorArrowheadScale
    Get
    Set
public:
property AnalysisDisplayStyleVectorArrowheadScale ArrowheadScale {
    AnalysisDisplayStyleVectorArrowheadScale get ();
    void set (AnalysisDisplayStyleVectorArrowheadScale value);
}
member ArrowheadScale : AnalysisDisplayStyleVectorArrowheadScale with get, set

Property Value

AnalysisDisplayStyleVectorArrowheadScale
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

AnalysisDisplayVectorSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayVectorSettings.ArrowLineWeight Property

AnalysisDisplayVectorSettingsArrowLineWeight Property

Line weight assigned to arrow lines for vectors.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ArrowLineWeight { get; set; }
Public Property ArrowLineWeight As Integer
    Get
    Set
public:
property int ArrowLineWeight {
    int get ();
    void set (int value);
}
member ArrowLineWeight : int with get, set

Property Value

Int32
See Also

Reference

AnalysisDisplayVectorSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayVectorSettings.IsValidObject Property

AnalysisDisplayVectorSettingsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

AnalysisDisplayVectorSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayVectorSettings.Rounding Property

AnalysisDisplayVectorSettingsRounding Property

Increment to which numeric values of analysis results are rounded in vectors.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Rounding { get; set; }
Public Property Rounding As Double
    Get
    Set
public:
property double Rounding {
    double get ();
    void set (double value);
}
member Rounding : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentsInconsistentException | When setting this property: rounding is not positive
See Also

Reference

AnalysisDisplayVectorSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayVectorSettings.TextTypeId Property

AnalysisDisplayVectorSettingsTextTypeId Property

Element id of text associated with the settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId TextTypeId { get; set; }
Public Property TextTypeId As ElementId
    Get
    Set
public:
property ElementId^ TextTypeId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member TextTypeId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

AnalysisDisplayVectorSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayVectorSettings.VectorOrientation Property

AnalysisDisplayVectorSettingsVectorOrientation Property

Vector orientation.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AnalysisDisplayStyleVectorOrientation VectorOrientation { get; set; }
Public Property VectorOrientation As AnalysisDisplayStyleVectorOrientation
    Get
    Set
public:
property AnalysisDisplayStyleVectorOrientation VectorOrientation {
    AnalysisDisplayStyleVectorOrientation get ();
    void set (AnalysisDisplayStyleVectorOrientation value);
}
member VectorOrientation : AnalysisDisplayStyleVectorOrientation with get, set

Property Value

AnalysisDisplayStyleVectorOrientation
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

AnalysisDisplayVectorSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayVectorSettings.VectorPosition Property

AnalysisDisplayVectorSettingsVectorPosition Property

Vector position.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AnalysisDisplayStyleVectorPosition VectorPosition { get; set; }
Public Property VectorPosition As AnalysisDisplayStyleVectorPosition
    Get
    Set
public:
property AnalysisDisplayStyleVectorPosition VectorPosition {
    AnalysisDisplayStyleVectorPosition get ();
    void set (AnalysisDisplayStyleVectorPosition value);
}
member VectorPosition : AnalysisDisplayStyleVectorPosition with get, set

Property Value

AnalysisDisplayStyleVectorPosition
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

AnalysisDisplayVectorSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayVectorSettings.VectorTextType Property

AnalysisDisplayVectorSettingsVectorTextType Property

Type of vector text visualization.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AnalysisDisplayStyleVectorTextType VectorTextType { get; set; }
Public Property VectorTextType As AnalysisDisplayStyleVectorTextType
    Get
    Set
public:
property AnalysisDisplayStyleVectorTextType VectorTextType {
    AnalysisDisplayStyleVectorTextType get ();
    void set (AnalysisDisplayStyleVectorTextType value);
}
member VectorTextType : AnalysisDisplayStyleVectorTextType with get, set

Property Value

AnalysisDisplayStyleVectorTextType
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

AnalysisDisplayVectorSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayVectorSettings Methods

The AnalysisDisplayVectorSettings type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsEqual | Compares two vector settings objects.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AnalysisDisplayVectorSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayVectorSettings.Dispose Method

AnalysisDisplayVectorSettingsDispose Method

Releases all resources used by the AnalysisDisplayVectorSettings

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

AnalysisDisplayVectorSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayVectorSettings.IsEqual Method

AnalysisDisplayVectorSettingsIsEqual Method

Compares two vector settings objects.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEqual(
    AnalysisDisplayVectorSettings other
)
Public Function IsEqual (
    other As AnalysisDisplayVectorSettings
) As Boolean
public:
bool IsEqual(
    AnalysisDisplayVectorSettings^ other
)
member IsEqual :
        other : AnalysisDisplayVectorSettings -> bool

Parameters

other AnalysisDisplayVectorSettings
Vector settings object to compare with.

Return Value

Boolean
True if objects are equal, false otherwise.
See Also

Reference

AnalysisDisplayVectorSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisMode Enumeration

This enum is used to define the Energy Analysis Model.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum AnalysisMode
Public Enumeration AnalysisMode
public enum class AnalysisMode
type AnalysisMode
Members
Member name | Value | Description
BuildingElements | 0 | Energy Analysis Model based on building elements.
ConceptualMassesAndBuildingElements | 2 | Energy Analysis Model based on conceptual masses and building elements.
RoomsOrSpaces | 3 | Energy Analysis Model based on spatial elements. This mode uses volumes based on rooms or spaces defined in the building model.
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


AnalysisResultSchema Class

Contains all information about one analysis result. Each result may contain several measurements.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DB.AnalysisAnalysisResultSchema

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AnalysisResultSchema : IDisposable
Public Class AnalysisResultSchema
    Implements IDisposable
public ref class AnalysisResultSchema : IDisposable
type AnalysisResultSchema =
    class
        interface IDisposable
    end

The AnalysisResultSchema type exposes the following members.

Constructors
 | Name | Description
Public method | AnalysisResultSchema(AnalysisResultSchema) | Constructs a new copy of the input AnalysisResultSchema object.
Public method | AnalysisResultSchema(String, String) | Creates object and assigns name and description
Top
Properties
 | Name | Description
Public property | AnalysisDisplayStyleId | ElementId of analysis display style overriding the style set for view; -1 if the style is not overridden
Public property | CurrentUnits | Stores the index in the array of applicable units
Public property | Description | Description of analysis result in view
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | IsVisible | If true analysis result is visible in view
Public property | Name | Name of analysis result in view
Public property | Scale | Multiplier used for displaying diagram or vector values in view.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the AnalysisResultSchema
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetNumberOfUnits | returns number of possible units
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetUnitsMultiplier | returns units multiplier by index
Public method | GetUnitsName | returns units name by index
Public method | IsEqual | Determines if the input object is equivalent to this AnalysisResultSchema.
 | SetUnits | Sets names and multipliers of all units for result visualization
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
In order to take effect, the AnalysisResultSchema object has to be registered by calling SpatialFieldManager::RegisterResult, which returns result index for future references; to make changes to the properties of an already registered object, use method SpatialFieldManager::SetResultSchema and supply result index and replacing object.
Example
C#
VB
C++
F#
Copy
// By default, each analysis result uses the Analysis Display Style assigned to the view.
// To display different types of results (colored surface, markers, diagram, vector) simultaneously in a single view
// the Analysis Display Style for each result must be set to a style that matches result's type
foreach (int result in spatialFieldManager.GetRegisteredResults()) // get all results for this SpatialFieldManager
{
   AnalysisResultSchema schema = spatialFieldManager.GetResultSchema(result);
   switch (schema.Name)  // check the name of the schema
   {
      case "Reactions": // based on the schema name, set the schema's Analysis Display Style
         schema.AnalysisDisplayStyleId = AnalysisDisplayStyle.FindByName(doc, "Vector");
         break;
      case "Shear":
         schema.AnalysisDisplayStyleId = AnalysisDisplayStyle.FindByName(doc, "Diagram");
         break;
      case "Plate Shear":
         schema.AnalysisDisplayStyleId = AnalysisDisplayStyle.FindByName(doc, "Surface");
         break;
   }
   spatialFieldManager.SetResultSchema(result, schema); // update the schema
}
' By default, each analysis result uses the Analysis Display Style assigned to the view.
' To display different types of results (colored surface, markers, diagram, vector) simultaneously in a single view
' the Analysis Display Style for each result must be set to a style that matches result's type
For Each result As Integer In spatialFieldManager.GetRegisteredResults()
    ' get all results for this SpatialFieldManager
    Dim schema As AnalysisResultSchema = spatialFieldManager.GetResultSchema(result)
    Select Case schema.Name
        ' check the name of the schema
        Case "Reactions"
            ' based on the schema name, set the schema's Analysis Display Style
            schema.AnalysisDisplayStyleId = AnalysisDisplayStyle.FindByName(doc, "Vector")
            Exit Select
        Case "Shear"
            schema.AnalysisDisplayStyleId = AnalysisDisplayStyle.FindByName(doc, "Diagram")
            Exit Select
        Case "Plate Shear"
            schema.AnalysisDisplayStyleId = AnalysisDisplayStyle.FindByName(doc, "Surface")
            Exit Select
    End Select
        ' update the schema
    spatialFieldManager.SetResultSchema(result, schema)
Next

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


AnalysisResultSchema Constructor

Overload List
 | Name | Description
Public method | AnalysisResultSchema(AnalysisResultSchema) | Constructs a new copy of the input AnalysisResultSchema object.
Public method | AnalysisResultSchema(String, String) | Creates object and assigns name and description
Top
See Also

Reference

AnalysisResultSchema Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisResultSchema(AnalysisResultSchema) Constructor

Constructs a new copy of the input AnalysisResultSchema object.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AnalysisResultSchema(
    AnalysisResultSchema other
)
Public Sub New (
    other As AnalysisResultSchema
)
public:
AnalysisResultSchema(
    AnalysisResultSchema^ other
)
new :
        other : AnalysisResultSchema -> AnalysisResultSchema

Parameters

other AnalysisResultSchema
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

AnalysisResultSchema Class
AnalysisResultSchema Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisResultSchema(String, String) Constructor

Creates object and assigns name and description

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AnalysisResultSchema(
    string name,
    string description
)
Public Sub New (
    name As String,
    description As String
)
public:
AnalysisResultSchema(
    String^ name,
    String^ description
)
new :
        name : string *
        description : string -> AnalysisResultSchema

Parameters

name String
Name of the result schema
description String
Description of the result schema
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

AnalysisResultSchema Class
AnalysisResultSchema Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisResultSchema Properties

The AnalysisResultSchema type exposes the following members.

Properties
 | Name | Description
Public property | AnalysisDisplayStyleId | ElementId of analysis display style overriding the style set for view; -1 if the style is not overridden
Public property | CurrentUnits | Stores the index in the array of applicable units
Public property | Description | Description of analysis result in view
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | IsVisible | If true analysis result is visible in view
Public property | Name | Name of analysis result in view
Public property | Scale | Multiplier used for displaying diagram or vector values in view.
Top
See Also

Reference

AnalysisResultSchema Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisResultSchema.AnalysisDisplayStyleId Property

AnalysisResultSchemaAnalysisDisplayStyleId Property

ElementId of analysis display style overriding the style set for view; -1 if the style is not overridden

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId AnalysisDisplayStyleId { get; set; }
Public Property AnalysisDisplayStyleId As ElementId
    Get
    Set
public:
property ElementId^ AnalysisDisplayStyleId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member AnalysisDisplayStyleId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

AnalysisResultSchema Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisResultSchema.CurrentUnits Property

AnalysisResultSchemaCurrentUnits Property

Stores the index in the array of applicable units

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int CurrentUnits { get; set; }
Public Property CurrentUnits As Integer
    Get
    Set
public:
property int CurrentUnits {
    int get ();
    void set (int value);
}
member CurrentUnits : int with get, set

Property Value

Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: currentUnits is not in the range from 0 to (number of applicable units - 1)
Remarks
Must be between 0 and (number of applicable units - 1)
See Also

Reference

AnalysisResultSchema Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisResultSchema.Description Property

AnalysisResultSchemaDescription Property

Description of analysis result in view

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

AnalysisResultSchema Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisResultSchema.IsValidObject Property

AnalysisResultSchemaIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

AnalysisResultSchema Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisResultSchema.IsVisible Property

AnalysisResultSchemaIsVisible Property

If true analysis result is visible in view

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsVisible { get; set; }
Public Property IsVisible As Boolean
    Get
    Set
public:
property bool IsVisible {
    bool get ();
    void set (bool value);
}
member IsVisible : bool with get, set

Property Value

Boolean
See Also

Reference

AnalysisResultSchema Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisResultSchema.Name Property

AnalysisResultSchemaName Property

Name of analysis result in view

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

AnalysisResultSchema Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisResultSchema.Scale Property

AnalysisResultSchemaScale Property

Multiplier used for displaying diagram or vector values in view.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Scale { get; set; }
Public Property Scale As Double
    Get
    Set
public:
property double Scale {
    double get ();
    void set (double value);
}
member Scale : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: scale is zero or negative
See Also

Reference

AnalysisResultSchema Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisResultSchema Methods

The AnalysisResultSchema type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetNumberOfUnits | returns number of possible units
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetUnitsMultiplier | returns units multiplier by index
Public method | GetUnitsName | returns units name by index
Public method | IsEqual | Determines if the input object is equivalent to this AnalysisResultSchema.
 | SetUnits | Sets names and multipliers of all units for result visualization
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

AnalysisResultSchema Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisResultSchema.Dispose Method

AnalysisResultSchemaDispose Method

Releases all resources used by the AnalysisResultSchema

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

AnalysisResultSchema Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisResultSchema.GetNumberOfUnits Method

AnalysisResultSchemaGetNumberOfUnits Method

returns number of possible units

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetNumberOfUnits()
Public Function GetNumberOfUnits As Integer
public:
int GetNumberOfUnits()
member GetNumberOfUnits : unit -> int

Return Value

Int32
See Also

Reference

AnalysisResultSchema Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisResultSchema.GetUnitsMultiplier Method

AnalysisResultSchemaGetUnitsMultiplier Method

returns units multiplier by index

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetUnitsMultiplier(
    int index
)
Public Function GetUnitsMultiplier (
    index As Integer
) As Double
public:
double GetUnitsMultiplier(
    int index
)
member GetUnitsMultiplier :
        index : int -> float

Parameters

index Int32
index of unit in the list

Return Value

Double
See Also

Reference

AnalysisResultSchema Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisResultSchema.GetUnitsName Method

AnalysisResultSchemaGetUnitsName Method

returns units name by index

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetUnitsName(
    int index
)
Public Function GetUnitsName (
    index As Integer
) As String
public:
String^ GetUnitsName(
    int index
)
member GetUnitsName :
        index : int -> string

Parameters

index Int32
index of unit in the list

Return Value

String
See Also

Reference

AnalysisResultSchema Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisResultSchema.IsEqual Method

AnalysisResultSchemaIsEqual Method

Determines if the input object is equivalent to this AnalysisResultSchema.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEqual(
    AnalysisResultSchema other
)
Public Function IsEqual (
    other As AnalysisResultSchema
) As Boolean
public:
bool IsEqual(
    AnalysisResultSchema^ other
)
member IsEqual :
        other : AnalysisResultSchema -> bool

Parameters

other AnalysisResultSchema

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

AnalysisResultSchema Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisResultSchema.SetUnits Method

AnalysisResultSchemaSetUnits Method

Sets names and multipliers of all units for result visualization

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetUnits(
    IList<string> names,
    IList<double> multipliers
)
Public Sub SetUnits (
    names As IList(Of String),
    multipliers As IList(Of Double)
)
public:
void SetUnits(
    IList<String^>^ names,
    IList<double>^ multipliers
)
member SetUnits :
        names : IList<string> *
        multipliers : IList<float> -> unit

Parameters

names IList String
Unit names for all units (e.g., "Lb" and "Kg")
multipliers IList Double
Numerical coefficients mapped to unit names. They adjust measurement values shown in the legend and display (e.g., 1.0 and 0.451 - if actual measurements are in Lb)
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentsInconsistentException | names is zero-length or contains duplicate or empty names -or- multipliers contains non-positive numbers, or its length is not equal to the length of names
Example
C#
VB
C++
F#
Copy
IList<string> unitNames = new List<string>();
unitNames.Add("Feet");
unitNames.Add("Inches");
IList<double> multipliers = new List<double>();
multipliers.Add(1);
multipliers.Add(12);

AnalysisResultSchema resultSchema = new AnalysisResultSchema("Schema Name", "Description");

resultSchema.SetUnits(unitNames, multipliers);
Dim unitNames As IList(Of String) = New List(Of String)()
unitNames.Add("Feet")
unitNames.Add("Inches")
Dim multipliers As IList(Of Double) = New List(Of Double)()
multipliers.Add(1)
multipliers.Add(12)

Dim resultSchema As New AnalysisResultSchema("Schema Name", "Description")

resultSchema.SetUnits(unitNames, multipliers)

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

AnalysisResultSchema Class
Autodesk.Revit.DB.Analysis Namespace


BuildingEnvelopeAnalyzer Class

Analyzes which elements are part of the building envelope, the building elements exposed to the outside.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DB.AnalysisBuildingEnvelopeAnalyzer

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BuildingEnvelopeAnalyzer : IDisposable
Public Class BuildingEnvelopeAnalyzer
    Implements IDisposable
public ref class BuildingEnvelopeAnalyzer : IDisposable
type BuildingEnvelopeAnalyzer =
    class
        interface IDisposable
    end

The BuildingEnvelopeAnalyzer type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
 | Create | Creates a new analyzer.
Public method | Dispose | Releases all resources used by the BuildingEnvelopeAnalyzer
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBoundingElements | Returns the collection of building elements exposed to the outside forming the building envelope.
Public method | GetBoundingElementsForSpaceVolume | Returns the collection of bounding building elements for an enclosed space volume.
Public method | GetCenterPointsForConnectedGridCellsInSpaceVolume | Returns the collection of connected cells in an enclosed space volume.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This class uses a combination of ray-casting and flood-fill algorithms in order to find the building elements that are exposed to the outside of the building. This method can also look for the bounding building elements for enclosed space volumes inside the building.
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


BuildingEnvelopeAnalyzer Properties

The BuildingEnvelopeAnalyzer type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

BuildingEnvelopeAnalyzer Class
Autodesk.Revit.DB.Analysis Namespace


BuildingEnvelopeAnalyzer.IsValidObject Property

BuildingEnvelopeAnalyzerIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

BuildingEnvelopeAnalyzer Class
Autodesk.Revit.DB.Analysis Namespace


BuildingEnvelopeAnalyzer Methods

The BuildingEnvelopeAnalyzer type exposes the following members.

Methods
 | Name | Description
 | Create | Creates a new analyzer.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetBoundingElements | Returns the collection of building elements exposed to the outside forming the building envelope.
Public method | GetBoundingElementsForSpaceVolume | Returns the collection of bounding building elements for an enclosed space volume.
Public method | GetCenterPointsForConnectedGridCellsInSpaceVolume | Returns the collection of connected cells in an enclosed space volume.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

BuildingEnvelopeAnalyzer Class
Autodesk.Revit.DB.Analysis Namespace


BuildingEnvelopeAnalyzer.Create Method

BuildingEnvelopeAnalyzerCreate Method

Creates a new analyzer.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static BuildingEnvelopeAnalyzer Create(
    Document document,
    BuildingEnvelopeAnalyzerOptions options
)
Public Shared Function Create (
    document As Document,
    options As BuildingEnvelopeAnalyzerOptions
) As BuildingEnvelopeAnalyzer
public:
static BuildingEnvelopeAnalyzer^ Create(
    Document^ document,
    BuildingEnvelopeAnalyzerOptions^ options
)
static member Create :
        document : Document *
        options : BuildingEnvelopeAnalyzerOptions -> BuildingEnvelopeAnalyzer

Parameters

document Document
The document that contains the physical model of the building.
options BuildingEnvelopeAnalyzerOptions
Options for the method analyzing the building elements for the building envelope.

Return Value

BuildingEnvelopeAnalyzer
The created analyzer.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

BuildingEnvelopeAnalyzer Class
Autodesk.Revit.DB.Analysis Namespace


BuildingEnvelopeAnalyzer.Dispose Method

BuildingEnvelopeAnalyzerDispose Method

Releases all resources used by the BuildingEnvelopeAnalyzer

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

BuildingEnvelopeAnalyzer Class
Autodesk.Revit.DB.Analysis Namespace


BuildingEnvelopeAnalyzer.GetBoundingElements Method

BuildingEnvelopeAnalyzerGetBoundingElements Method

Returns the collection of building elements exposed to the outside forming the building envelope.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<LinkElementId> GetBoundingElements()
Public Function GetBoundingElements As IList(Of LinkElementId)
public:
IList<LinkElementId^>^ GetBoundingElements()
member GetBoundingElements : unit -> IList<LinkElementId>

Return Value

IList LinkElementId
The ids of the building elements in the envelope.
See Also

Reference

BuildingEnvelopeAnalyzer Class
Autodesk.Revit.DB.Analysis Namespace


BuildingEnvelopeAnalyzer.GetBoundingElementsForSpaceVolume Method

BuildingEnvelopeAnalyzerGetBoundingElementsForSpaceVolume Method

Returns the collection of bounding building elements for an enclosed space volume.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<LinkElementId> GetBoundingElementsForSpaceVolume(
    int spaceVolume
)
Public Function GetBoundingElementsForSpaceVolume (
    spaceVolume As Integer
) As IList(Of LinkElementId)
public:
IList<LinkElementId^>^ GetBoundingElementsForSpaceVolume(
    int spaceVolume
)
member GetBoundingElementsForSpaceVolume :
        spaceVolume : int -> IList<LinkElementId>

Parameters

spaceVolume Int32

Return Value

IList LinkElementId
The ids of the bounding building elements for the enclosed space volume.
Remarks
This method requires the building envelope analyzer method created with the option set to compute enclosed space volumes.
See Also

Reference

BuildingEnvelopeAnalyzer Class
Autodesk.Revit.DB.Analysis Namespace


BuildingEnvelopeAnalyzer.GetCenterPointsForConnectedGridCellsInSpaceVolume Method

BuildingEnvelopeAnalyzerGetCenterPointsForConnectedGridCellsInSpaceVolume Method

Returns the collection of connected cells in an enclosed space volume.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<XYZ> GetCenterPointsForConnectedGridCellsInSpaceVolume(
    int spaceVolume
)
Public Function GetCenterPointsForConnectedGridCellsInSpaceVolume (
    spaceVolume As Integer
) As IList(Of XYZ)
public:
IList<XYZ^>^ GetCenterPointsForConnectedGridCellsInSpaceVolume(
    int spaceVolume
)
member GetCenterPointsForConnectedGridCellsInSpaceVolume :
        spaceVolume : int -> IList<XYZ>

Parameters

spaceVolume Int32

Return Value

IList XYZ
The center points for the connected analytical grid cells in the enclosed space volume.
Remarks
This method requires the building envelope analyzer method created with the option set to compute enclosed space volumes.
See Also

Reference

BuildingEnvelopeAnalyzer Class
Autodesk.Revit.DB.Analysis Namespace


BuildingEnvelopeAnalyzerOptions Class

Specific options for the method analyzing the building elements for the building envelope.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DB.AnalysisBuildingEnvelopeAnalyzerOptions

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BuildingEnvelopeAnalyzerOptions : IDisposable
Public Class BuildingEnvelopeAnalyzerOptions
    Implements IDisposable
public ref class BuildingEnvelopeAnalyzerOptions : IDisposable
type BuildingEnvelopeAnalyzerOptions =
    class
        interface IDisposable
    end

The BuildingEnvelopeAnalyzerOptions type exposes the following members.

Constructors
 | Name | Description
Public method | BuildingEnvelopeAnalyzerOptions | Constructs a new instance of BuildingEnvelopeAnalyzerOptions, using default values.
Top
Properties
 | Name | Description
Public property | AnalyzeEnclosedSpaceVolumes | Whether or not to analyze interior connected regions inside the building forming enclosed space volumes.
Public property | GridCellSize | The cell size for the uniform cubical grid used when analyzing the building envelope.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OptimizeGridCellSize | Whether or not to use the exact value for the cell size or let the analyzer optimize the cell size based on the specified grid size
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the BuildingEnvelopeAnalyzerOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The analyze method uses a combination of ray-casting and flood-fill algorithms in order to find the building elements that are exposed to the outside of the building. The analyze method can also look for the bounding building elements for enclosed space volumes inside the building.
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


BuildingEnvelopeAnalyzerOptions Constructor

Constructs a new instance of BuildingEnvelopeAnalyzerOptions, using default values.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BuildingEnvelopeAnalyzerOptions()
Public Sub New
public:
BuildingEnvelopeAnalyzerOptions()
new : unit -> BuildingEnvelopeAnalyzerOptions
See Also

Reference

BuildingEnvelopeAnalyzerOptions Class
Autodesk.Revit.DB.Analysis Namespace


BuildingEnvelopeAnalyzerOptions Properties

The BuildingEnvelopeAnalyzerOptions type exposes the following members.

Properties
 | Name | Description
Public property | AnalyzeEnclosedSpaceVolumes | Whether or not to analyze interior connected regions inside the building forming enclosed space volumes.
Public property | GridCellSize | The cell size for the uniform cubical grid used when analyzing the building envelope.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OptimizeGridCellSize | Whether or not to use the exact value for the cell size or let the analyzer optimize the cell size based on the specified grid size
Top
See Also

Reference

BuildingEnvelopeAnalyzerOptions Class
Autodesk.Revit.DB.Analysis Namespace


BuildingEnvelopeAnalyzerOptions.AnalyzeEnclosedSpaceVolumes Property

BuildingEnvelopeAnalyzerOptionsAnalyzeEnclosedSpaceVolumes Property

Whether or not to analyze interior connected regions inside the building forming enclosed space volumes.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AnalyzeEnclosedSpaceVolumes { get; set; }
Public Property AnalyzeEnclosedSpaceVolumes As Boolean
    Get
    Set
public:
property bool AnalyzeEnclosedSpaceVolumes {
    bool get ();
    void set (bool value);
}
member AnalyzeEnclosedSpaceVolumes : bool with get, set

Property Value

Boolean
Remarks
If true, the analyzer will also look for bounding building elements and connected analytical grid cells for enclosed space volumes inside the building.
See Also

Reference

BuildingEnvelopeAnalyzerOptions Class
Autodesk.Revit.DB.Analysis Namespace


BuildingEnvelopeAnalyzerOptions.GridCellSize Property

BuildingEnvelopeAnalyzerOptionsGridCellSize Property

The cell size for the uniform cubical grid used when analyzing the building envelope.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GridCellSize { get; set; }
Public Property GridCellSize As Double
    Get
    Set
public:
property double GridCellSize {
    double get ();
    void set (double value);
}
member GridCellSize : float with get, set

Property Value

Double
Remarks
This is the base size of the "cubes" used to divide the building shell bounding box into a uniform cubical 3D grid. If this overrideGridCellSize option is set, this exact value will be used for the grid cell size. The cell size should be specified in the length unit for the Revit project.
See Also

Reference

BuildingEnvelopeAnalyzerOptions Class
Autodesk.Revit.DB.Analysis Namespace


BuildingEnvelopeAnalyzerOptions.IsValidObject Property

BuildingEnvelopeAnalyzerOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

BuildingEnvelopeAnalyzerOptions Class
Autodesk.Revit.DB.Analysis Namespace


BuildingEnvelopeAnalyzerOptions.OptimizeGridCellSize Property

BuildingEnvelopeAnalyzerOptionsOptimizeGridCellSize Property

Whether or not to use the exact value for the cell size or let the analyzer optimize the cell size based on the specified grid size

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool OptimizeGridCellSize { get; set; }
Public Property OptimizeGridCellSize As Boolean
    Get
    Set
public:
property bool OptimizeGridCellSize {
    bool get ();
    void set (bool value);
}
member OptimizeGridCellSize : bool with get, set

Property Value

Boolean
Remarks
If this option is true, the analyzer will decide the optimal cell size for the uniform cubical grid used when computing the building envelope. The optimal cell size is based on the specified cell size, but can be higher. If this option is false, the exact specified grid cell size will be used.
See Also

Reference

BuildingEnvelopeAnalyzerOptions Class
Autodesk.Revit.DB.Analysis Namespace


BuildingEnvelopeAnalyzerOptions Methods

The BuildingEnvelopeAnalyzerOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

BuildingEnvelopeAnalyzerOptions Class
Autodesk.Revit.DB.Analysis Namespace


BuildingEnvelopeAnalyzerOptions.Dispose Method

BuildingEnvelopeAnalyzerOptionsDispose Method

Releases all resources used by the BuildingEnvelopeAnalyzerOptions

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

BuildingEnvelopeAnalyzerOptions Class
Autodesk.Revit.DB.Analysis Namespace


BuildingOperatingDaySchedule Class

Represents the operating schedule of a 24 hour day.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DB.AnalysisBuildingOperatingDaySchedule

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BuildingOperatingDaySchedule : Element
Public Class BuildingOperatingDaySchedule
    Inherits Element
public ref class BuildingOperatingDaySchedule : public Element
type BuildingOperatingDaySchedule =
    class
        inherit Element
    end

The BuildingOperatingDaySchedule type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ScheduleName | The name of the schedule.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new instance of a BuildingOperatingDaySchedule.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetValueForHour | Gets the usage value for an hour.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetValueForHour | Sets the usage value for an hour.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


BuildingOperatingDaySchedule Properties

The BuildingOperatingDaySchedule type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ScheduleName | The name of the schedule.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

BuildingOperatingDaySchedule Class
Autodesk.Revit.DB.Analysis Namespace


BuildingOperatingDaySchedule.ScheduleName Property

BuildingOperatingDayScheduleScheduleName Property

The name of the schedule.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ScheduleName { get; set; }
Public Property ScheduleName As String
    Get
    Set
public:
property String^ ScheduleName {
    String^ get ();
    void set (String^ value);
}
member ScheduleName : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentException | When setting this property: name must not match an existing name, even with different case. -or- When setting this property: name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- When setting this property: name must be trimmed. -or- When setting this property: name is an empty string or contains only whitespace.
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

BuildingOperatingDaySchedule Class
Autodesk.Revit.DB.Analysis Namespace


BuildingOperatingDaySchedule Methods

The BuildingOperatingDaySchedule type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new instance of a BuildingOperatingDaySchedule.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetValueForHour | Gets the usage value for an hour.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetValueForHour | Sets the usage value for an hour.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

BuildingOperatingDaySchedule Class
Autodesk.Revit.DB.Analysis Namespace


BuildingOperatingDaySchedule.Create Method

BuildingOperatingDayScheduleCreate Method

Creates a new instance of a BuildingOperatingDaySchedule.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static BuildingOperatingDaySchedule Create(
    Document document,
    string name
)
Public Shared Function Create (
    document As Document,
    name As String
) As BuildingOperatingDaySchedule
public:
static BuildingOperatingDaySchedule^ Create(
    Document^ document,
    String^ name
)
static member Create :
        document : Document *
        name : string -> BuildingOperatingDaySchedule

Parameters

document Document
The document to create the new BuildingOperatingDaySchedule element.
name String
The intended name of the newly created BuildingOperatingDaySchedule, may be modified to disambiguate with existing element.

Return Value

BuildingOperatingDaySchedule
The newly created BuildingOperatingDaySchedule.
Exceptions
Exception | Condition
ArgumentException | name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- name must be trimmed. -or- name is an empty string or contains only whitespace.
ArgumentNullException | A non-optional argument was null
Remarks
The new BuildingOperatingDaySchedule will have all values set to off.
See Also

Reference

BuildingOperatingDaySchedule Class
Autodesk.Revit.DB.Analysis Namespace


BuildingOperatingDaySchedule.GetValueForHour Method

BuildingOperatingDayScheduleGetValueForHour Method

Gets the usage value for an hour.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetValueForHour(
    int hour
)
Public Function GetValueForHour (
    hour As Integer
) As Double
public:
double GetValueForHour(
    int hour
)
member GetValueForHour :
        hour : int -> float

Parameters

hour Int32
The hour in the day, as an integer. For example: 0 is 12:00 midnight to 1:00 am, 6 is 6:00 am to 7:00 am, 12 is 12:00 noon to 1:00 pm, and 23 is 11:00 pm to midnight. To avoid issues around daylight savings times, these hours represent 1/24 of an earth rotation, and will not be exactly 60 minutes.

Return Value

Double
The usage as a fraction between 0 and 1 inclusive. For example: 0 in a lighting schedule means all lights are off, .5 means half of lights are on, 1 means all lights are on.
Exceptions
Exception | Condition
ArgumentException | hour must be from 0 to 23 inclusive.
See Also

Reference

BuildingOperatingDaySchedule Class
Autodesk.Revit.DB.Analysis Namespace


BuildingOperatingDaySchedule.SetValueForHour Method

BuildingOperatingDayScheduleSetValueForHour Method

Sets the usage value for an hour.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetValueForHour(
    int hour,
    double usage
)
Public Sub SetValueForHour (
    hour As Integer,
    usage As Double
)
public:
void SetValueForHour(
    int hour,
    double usage
)
member SetValueForHour :
        hour : int *
        usage : float -> unit

Parameters

hour Int32
The hour in the day, as an integer. For example: 0 is 12:00 midnight to 1:00 am, 6 is 6:00 am to 7:00 am, 12 is 12:00 noon to 1:00 pm, and 23 is 11:00 pm to midnight. To avoid issues around daylight savings times, these hours represent 1/24 of an earth rotation, and will not be exactly 60 minutes.
usage Double
The usage as a fraction between 0 and 1 inclusive. For example: 0 in a lighting schedule means all lights are off, .5 means half of lights are on, 1 means all lights are on.
Exceptions
Exception | Condition
ArgumentException | hour must be from 0 to 23 inclusive. -or- usage should be less than or equal to 1.
ArgumentOutOfRangeException | The given value for usage must be non-negative.
See Also

Reference

BuildingOperatingDaySchedule Class
Autodesk.Revit.DB.Analysis Namespace


BuildingOperatingYearSchedule Class

Represents an operating schedule that contains 365 daily usage BuildingOperatingDaySchedules.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DB.AnalysisBuildingOperatingYearSchedule

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class BuildingOperatingYearSchedule : Element
Public Class BuildingOperatingYearSchedule
    Inherits Element
public ref class BuildingOperatingYearSchedule : public Element
type BuildingOperatingYearSchedule =
    class
        inherit Element
    end

The BuildingOperatingYearSchedule type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ScheduleName | The name of the schedule.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a valid BuildingOperatingYearSchedule with the given name, where every day has the schedule daySchedule.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetScheduleForDay | Gets the BuildingOperatingDaySchedule for this day of the year.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetScheduleForDay | Sets the BuildingOperatingDaySchedule for this day of the year.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


BuildingOperatingYearSchedule Properties

The BuildingOperatingYearSchedule type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ScheduleName | The name of the schedule.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

BuildingOperatingYearSchedule Class
Autodesk.Revit.DB.Analysis Namespace


BuildingOperatingYearSchedule.ScheduleName Property

BuildingOperatingYearScheduleScheduleName Property

The name of the schedule.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ScheduleName { get; set; }
Public Property ScheduleName As String
    Get
    Set
public:
property String^ ScheduleName {
    String^ get ();
    void set (String^ value);
}
member ScheduleName : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentException | When setting this property: name must not match an existing name, even with different case. -or- When setting this property: name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- When setting this property: name must be trimmed. -or- When setting this property: name is an empty string or contains only whitespace.
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

BuildingOperatingYearSchedule Class
Autodesk.Revit.DB.Analysis Namespace


BuildingOperatingYearSchedule Methods

The BuildingOperatingYearSchedule type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a valid BuildingOperatingYearSchedule with the given name, where every day has the schedule daySchedule.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetScheduleForDay | Gets the BuildingOperatingDaySchedule for this day of the year.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetScheduleForDay | Sets the BuildingOperatingDaySchedule for this day of the year.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

BuildingOperatingYearSchedule Class
Autodesk.Revit.DB.Analysis Namespace


BuildingOperatingYearSchedule.Create Method

BuildingOperatingYearScheduleCreate Method

Creates a valid BuildingOperatingYearSchedule with the given name, where every day has the schedule daySchedule.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static BuildingOperatingYearSchedule Create(
    Document document,
    BuildingOperatingDaySchedule daySchedule,
    string name
)
Public Shared Function Create (
    document As Document,
    daySchedule As BuildingOperatingDaySchedule,
    name As String
) As BuildingOperatingYearSchedule
public:
static BuildingOperatingYearSchedule^ Create(
    Document^ document,
    BuildingOperatingDaySchedule^ daySchedule,
    String^ name
)
static member Create :
        document : Document *
        daySchedule : BuildingOperatingDaySchedule *
        name : string -> BuildingOperatingYearSchedule

Parameters

document Document
The document to create this BuildingOperatingYearSchedule for.
daySchedule BuildingOperatingDaySchedule
A schedule to assign to every day.
name String
The intended schedule name, may be modified to disambiguate with existing elements.

Return Value

BuildingOperatingYearSchedule
The newly created BuildingOperatingYearSchedule.
Exceptions
Exception | Condition
ArgumentException | daySchedule must be in the same document. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- name must be trimmed. -or- name is an empty string or contains only whitespace.
ArgumentNullException | A non-optional argument was null
See Also

Reference

BuildingOperatingYearSchedule Class
Autodesk.Revit.DB.Analysis Namespace


BuildingOperatingYearSchedule.GetScheduleForDay Method

BuildingOperatingYearScheduleGetScheduleForDay Method

Gets the BuildingOperatingDaySchedule for this day of the year.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BuildingOperatingDaySchedule GetScheduleForDay(
    DateTime day
)
Public Function GetScheduleForDay (
    day As DateTime
) As BuildingOperatingDaySchedule
public:
BuildingOperatingDaySchedule^ GetScheduleForDay(
    DateTime day
)
member GetScheduleForDay :
        day : DateTime -> BuildingOperatingDaySchedule

Parameters

day DateTime
The day of the year. The value must be in 2023 (the template year) and have the time zone set to gmt/utc. Time values will be ignored.

Return Value

BuildingOperatingDaySchedule
The schedule used on that day.
Exceptions
Exception | Condition
ArgumentException | day must be in the year 2023.
Remarks
The day argument must be in 2023 to match the template year in the user interface calendar: it has 365 days and starts on a Sunday.
See Also

Reference

BuildingOperatingYearSchedule Class
Autodesk.Revit.DB.Analysis Namespace


BuildingOperatingYearSchedule.SetScheduleForDay Method

BuildingOperatingYearScheduleSetScheduleForDay Method

Sets the BuildingOperatingDaySchedule for this day of the year.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetScheduleForDay(
    DateTime day,
    BuildingOperatingDaySchedule daySchedule
)
Public Sub SetScheduleForDay (
    day As DateTime,
    daySchedule As BuildingOperatingDaySchedule
)
public:
void SetScheduleForDay(
    DateTime day,
    BuildingOperatingDaySchedule^ daySchedule
)
member SetScheduleForDay :
        day : DateTime *
        daySchedule : BuildingOperatingDaySchedule -> unit

Parameters

day DateTime
The day of the year. The value must be in 2023 (the template year) and have the time zone set to gmt/utc. Time values will be ignored.
daySchedule BuildingOperatingDaySchedule
The schedule used on that day.
Exceptions
Exception | Condition
ArgumentException | day must be in the year 2023. -or- daySchedule must be in the same document.
ArgumentNullException | A non-optional argument was null
Remarks
The day argument must be in 2023 to match the template year in the user interface calendar: it has 365 days and starts on a Sunday.
See Also

Reference

BuildingOperatingYearSchedule Class
Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionFloorSlabType Enumeration

ConceptualConstructionType values for Floors.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConceptualConstructionFloorSlabType
Public Enumeration ConceptualConstructionFloorSlabType
public enum class ConceptualConstructionFloorSlabType
type ConceptualConstructionFloorSlabType
Members
Member name | Value | Description
LightweightConstructionHighInsulation | 0 | Lightweight Construction High Insulation Floor
LightweightConstructionTypicalInsulation | 1 | Lightweight Construction Typical Insulation Floor
LightweightConstructionLowInsulation | 2 | Lightweight Construction Low Insulation Floor
LightweightConstructionNoInsulationInterior | 3 | Lightweight Construction No Insulation Interior Floor
HighMassConstructionFrigidClimateSlabInsulation | 4 | High Mass Construction Frigid Climate Insulation Slab
HighMassConstructionColdClimateSlabInsulation | 5 | High Mass Construction Cold Climate Insulation Slab
HighMassConstructionTypicalNoInsulation | 6 | High Mass Construction Typical No Insulation Slab
NumFloorSlabTypeConstruction | 7 | Total number of Floor/Slab Constructions
InvalidFloorSlabTypeConstruction | -1 | Invalid/not set Floor or Slab Type construction value
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionOpeningType Enumeration

ConceptualConstructionType values for Openings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConceptualConstructionOpeningType
Public Enumeration ConceptualConstructionOpeningType
public enum class ConceptualConstructionOpeningType
type ConceptualConstructionOpeningType
Members
Member name | Value | Description
Air | 0 | Air Opening
NumOpeningTypeConstruction | 1 | Total Number of Opening Type Constructions
InvalidOpeningTypeConstruction | -1 | Invalid value/not set Opening Type Construction
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionRoofType Enumeration

ConceptualConstructionType values for Roofs.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConceptualConstructionRoofType
Public Enumeration ConceptualConstructionRoofType
public enum class ConceptualConstructionRoofType
type ConceptualConstructionRoofType
Members
Member name | Value | Description
HighInsulationCoolRoof | 0 | High Insulation Cool Roof
HighInsulationDarkRoof | 1 | High Insulation Dark Roof
TypicalInsulationCoolRoof | 2 | Typical Insulation Cool Roof
TypicalInsulationDarkRoof | 3 | Typical Insulation Dark Roof
LowInsulationCoolRoof | 4 | Low Insulation Cool Roof
LowInsulationDarkRoof | 5 | Low Insulation Dark Roof
NoInsulationDarkRoof | 6 | No Insulation Dark Roof
NumRoofTypeConstruction | 7 | Total Number of Roof Type Constructions
InvalidRoofTypeConstruction | -1 | Invalid value/not set Roof Type Construction value
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionShadeType Enumeration

ConceptualConstructionType values for Shades.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConceptualConstructionShadeType
Public Enumeration ConceptualConstructionShadeType
public enum class ConceptualConstructionShadeType
type ConceptualConstructionShadeType
Members
Member name | Value | Description
BasicShade | 0 | Basic Shade
NumShadeTypeConstruction | 1 | Total Number of Shade Type Constructions
InvalidShadeTypeConstruction | -1 | Invalid value/not set Shade Type Construction
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionType Class

This element is used to describe the conceptual physical, construction, and energy properties in a manner that can be understood by both the Revit BIM model and Green Building Studio/Green Building XML. For serialization
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DB.AnalysisConceptualConstructionType

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ConceptualConstructionType : ElementType
Public Class ConceptualConstructionType
    Inherits ElementType
public ref class ConceptualConstructionType : public ElementType
type ConceptualConstructionType =
    class
        inherit ElementType
    end

The ConceptualConstructionType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | MassSurfaceSubCategoryId | The surface type subcategory element id associated with the ConceptualConstructionType.
Public property | MaterialId | Material used for visualization of this construction.
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
Name | Description
Public method ArePhasesModifiable Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element.
(Inherited from Element)
Public method CanBeHidden Indicates if the element can be hidden in the view.
(Inherited from Element)
Public method CanBeLocked Identifies if the element can be locked.
(Inherited from Element)
Public method CanDeleteSubelement Checks if given subelement can be removed from the element.
(Inherited from Element)
Public method CanHaveTypeAssigned Identifies if the element can have a type assigned.
(Inherited from Element)
Public method ChangeTypeId(ElementId) Changes the type of the element.
(Inherited from Element)
Public method DeleteEntity Deletes the existing entity created by %schema% in the element
(Inherited from Element)
Public method DeleteSubelement Removes a subelement from the element.
(Inherited from Element)
Public method DeleteSubelements Removes the subelements from the element.
(Inherited from Element)
Public method Dispose
(Inherited from Element)
Public method Duplicate Duplicates an existing element type and assigns it a new name.
(Inherited from ElementType)
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object)
Public method EvaluateAllParameterValues Evaluates all the parameters' values of the element.
(Inherited from Element)
Public method EvaluateParameterValues Evaluate the parameters' values of the element on the given parameter ID set.
(Inherited from Element)
GetAllConceptualConstructionsForCategory | Get all the ids of constructions applicable to the input massSubCategory
Public method GetDependentElements Get all elements that, from a logical point of view, are the children of this Element.
(Inherited from Element)
Public method GetEntity Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise.
(Inherited from Element)
Public method GetEntitySchemaGuids Returns the Schema guids of any Entities stored in this element.
(Inherited from Element)
Public method GetExternalFileReference Gets information pertaining to the external file referenced by the element.
(Inherited from Element)
Public method GetExternalResourceReference Gets the ExternalResourceReference associated with a specified external resource type.
(Inherited from Element)
Public method GetExternalResourceReferenceExpanded Gets the collection of ExternalResourceReference associated with a specified external resource type.
(Inherited from Element)
Public method GetExternalResourceReferences Gets the map of the external resource references referenced by the element.
(Inherited from Element)
Public method GetExternalResourceReferencesExpanded Gets the expanded map of the external resource references referenced by the element.
(Inherited from Element)
GetFloorOrSlabConstructionType | Get a Floor or Slab ConceptualConstructionType by its ConceptualConstructionFloorSlabType.
Public method | GetGBSId | Gets the Green Building Studio identifier associated with the construction.
GetGeneratingElementIds Returns the ids of the element(s) that generated the input geometry object.
(Inherited from Element)
Public method GetGeometryObjectFromReference Retrieve one geometric primitive contained in the element given a reference.
(Inherited from Element)
Public method GetHashCode Serves as the default hash function.
(Inherited from Object)
Public method GetMaterialArea Gets the area of the material with the given id.
(Inherited from Element)
Public method GetMaterialIds Gets the element ids of all materials present in the element.
(Inherited from Element)
Public method GetMaterialVolume Gets the volume of the material with the given id.
(Inherited from Element)
Public method GetMonitoredLinkElementIds Provides the link instance IDs when the element is monitoring.
(Inherited from Element)
Public method GetMonitoredLocalElementIds Provides the local element IDs when the element is monitoring.
(Inherited from Element)
GetOpeningConstructionType | Get an Opening ConceptualConstructionType by its ConceptualConstructionOpeningType.
Public method GetOrderedParameters Gets the parameters associated to the element in order.
(Inherited from Element)
Public method GetParameter Retrieves a parameter from the element given identifier.
(Inherited from Element)
Public method GetParameterFormatOptions Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists.
(Inherited from Element)
Public method GetParameters Retrieves the parameters from the element via the given name.
(Inherited from Element)
Public method GetPhaseStatus Gets the status of a given element in the input phase
(Inherited from Element)
Public method GetPreviewImage Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element.
(Inherited from ElementType)
GetRoofConstructionType | Get a Roof ConceptualConstructionType by its ConceptualConstructionRoofType.
GetShadeConstructionType | Get a Shade ConceptualConstructionType by its ConceptualConstructionShadeType.
Public method GetSimilarTypes Obtains a set of types that are similar to this type.
(Inherited from ElementType)
Public method GetSubelements Returns the collection of element subelements.
(Inherited from Element)
Public method GetType Gets the Type of the current instance.
(Inherited from Object)
GetTypeId Returns the identifier of this element's type.
(Inherited from Element)
Public method GetValidTypes Obtains a set of types that are valid for this element.
(Inherited from Element)
GetWallConstructionType | Get a Wall ConceptualConstructionType by its ConceptualConstructionWallType.
GetWindowOrSkylightConstructionType | Get a Window or Skylight ConceptualConstructionType by its ConceptualConstructionWindowSkylightType.
Public method HasPhases Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.
(Inherited from Element)
Public method IsCreatedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element)
Public method IsDemolishedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element)
Public method IsExternalFileReference Determines whether this Element represents an external file.
(Inherited from Element)
Public method IsHidden Identifies if the element has been permanently hidden in the view.
(Inherited from Element)
Public method IsMonitoringLinkElement Indicate whether an element is monitoring any elements in any linked models.
(Inherited from Element)
Public method IsMonitoringLocalElement Indicate whether an element is monitoring other local elements.
(Inherited from Element)
Public method IsPhaseCreatedValid Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element.
(Inherited from Element)
Public method IsPhaseDemolishedValid Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element.
(Inherited from Element)
Public method IsSimilarType Checks if given type is similar to this type.
(Inherited from ElementType)
IsValidConceptualConstructionId | Indicates if the ElementId is an id of a ConceptualConstructionType.
IsValidConceptualConstructionIdForCategory | Indicate if a ConceptualConstruction is appropriate to assign to a MassSurfaceData of a particular Mass subcategory.
Public method IsValidDefaultFamilyType Identifies if this type is a valid default family type for the given family category id.
(Inherited from ElementType)
IsValidSubcategoryForMassSurfaceDatas Validate if a subcategory is appropriate for assignment to Massing surfaces (MassSurfaceData). This is the list of acceptable values:
  1. OST_MassInteriorWall
  2. OST_MassExteriorWall
  3. OST_MassExteriorWallUnderground
  4. OST_MassRoof
  5. OST_MassFloor
  6. OST_MassSlab
  7. OST_MassShade
  8. OST_MassGlazing
  9. OST_MassSkylights
  10. OST_MassOpening
Public method | IsValidSurfaceSubcategoryForConstruction | Indicates if this ConceptualConstructionType is appropriate for the input MassSurfaceData subcategory.
Public method IsValidType(ElementId) Checks if given type is valid for this element.
(Inherited from Element)
Public method LookupParameter Attempts to find a parameter on the element which has the given name.
(Inherited from Element)
Public method RefersToExternalResourceReference Determines whether this Element uses external resources associated with a specified external resource type.
(Inherited from Element)
Public method RefersToExternalResourceReferences Determines whether this Element uses external resources.
(Inherited from Element)
Public method SetEntity Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten.
(Inherited from Element)
Public method ToString Returns a string that represents the current object.
(Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionType Properties

The ConceptualConstructionType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBeCopied | Determine if this ElementType can create a copy (Inherited from ElementType)
Public property | CanBeDeleted | Determine if this ElementType can be deleted (Inherited from ElementType)
Public property | CanBeRenamed | Determine if this ElementType can be renamed (Inherited from ElementType)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | FamilyName | Gets the family name of this element type. (Inherited from ElementType)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | MassSurfaceSubCategoryId | The surface type subcategory element id associated with the ConceptualConstructionType.
Public property | MaterialId | Material used for visualization of this construction.
Public property | Name | Set the name for the ElementType. (Inherited from ElementType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionType.MassSurfaceSubCategoryId Property

ConceptualConstructionTypeMassSurfaceSubCategoryId Property

The surface type subcategory element id associated with the ConceptualConstructionType.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId MassSurfaceSubCategoryId { get; }
Public ReadOnly Property MassSurfaceSubCategoryId As ElementId
    Get
public:
property ElementId^ MassSurfaceSubCategoryId {
    ElementId^ get ();
}
member MassSurfaceSubCategoryId : ElementId with get

Property Value

ElementId
See Also

Reference

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionType.MaterialId Property

ConceptualConstructionTypeMaterialId Property

Material used for visualization of this construction.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId MaterialId { get; set; }
Public Property MaterialId As ElementId
    Get
    Set
public:
property ElementId^ MaterialId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member MaterialId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentException | When setting this property: The input element materialId is not a material element.
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionType Methods

The ConceptualConstructionType type exposes the following members.

Methods
Name | Description
Public method ArePhasesModifiable Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element.
(Inherited from Element)
Public method CanBeHidden Indicates if the element can be hidden in the view.
(Inherited from Element)
Public method CanBeLocked Identifies if the element can be locked.
(Inherited from Element)
Public method CanDeleteSubelement Checks if given subelement can be removed from the element.
(Inherited from Element)
Public method CanHaveTypeAssigned Identifies if the element can have a type assigned.
(Inherited from Element)
Public method ChangeTypeId(ElementId) Changes the type of the element.
(Inherited from Element)
Public method DeleteEntity Deletes the existing entity created by %schema% in the element
(Inherited from Element)
Public method DeleteSubelement Removes a subelement from the element.
(Inherited from Element)
Public method DeleteSubelements Removes the subelements from the element.
(Inherited from Element)
Public method Dispose
(Inherited from Element)
Public method Duplicate Duplicates an existing element type and assigns it a new name.
(Inherited from ElementType)
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object)
Public method EvaluateAllParameterValues Evaluates all the parameters' values of the element.
(Inherited from Element)
Public method EvaluateParameterValues Evaluate the parameters' values of the element on the given parameter ID set.
(Inherited from Element)
GetAllConceptualConstructionsForCategory | Get all the ids of constructions applicable to the input massSubCategory
Public method GetDependentElements Get all elements that, from a logical point of view, are the children of this Element.
(Inherited from Element)
Public method GetEntity Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise.
(Inherited from Element)
Public method GetEntitySchemaGuids Returns the Schema guids of any Entities stored in this element.
(Inherited from Element)
Public method GetExternalFileReference Gets information pertaining to the external file referenced by the element.
(Inherited from Element)
Public method GetExternalResourceReference Gets the ExternalResourceReference associated with a specified external resource type.
(Inherited from Element)
Public method GetExternalResourceReferenceExpanded Gets the collection of ExternalResourceReference associated with a specified external resource type.
(Inherited from Element)
Public method GetExternalResourceReferences Gets the map of the external resource references referenced by the element.
(Inherited from Element)
Public method GetExternalResourceReferencesExpanded Gets the expanded map of the external resource references referenced by the element.
(Inherited from Element)
GetFloorOrSlabConstructionType | Get a Floor or Slab ConceptualConstructionType by its ConceptualConstructionFloorSlabType.
Public method | GetGBSId | Gets the Green Building Studio identifier associated with the construction.
GetGeneratingElementIds Returns the ids of the element(s) that generated the input geometry object.
(Inherited from Element)
Public method GetGeometryObjectFromReference Retrieve one geometric primitive contained in the element given a reference.
(Inherited from Element)
Public method GetHashCode Serves as the default hash function.
(Inherited from Object)
Public method GetMaterialArea Gets the area of the material with the given id.
(Inherited from Element)
Public method GetMaterialIds Gets the element ids of all materials present in the element.
(Inherited from Element)
Public method GetMaterialVolume Gets the volume of the material with the given id.
(Inherited from Element)
Public method GetMonitoredLinkElementIds Provides the link instance IDs when the element is monitoring.
(Inherited from Element)
Public method GetMonitoredLocalElementIds Provides the local element IDs when the element is monitoring.
(Inherited from Element)
GetOpeningConstructionType | Get an Opening ConceptualConstructionType by its ConceptualConstructionOpeningType.
Public method GetOrderedParameters Gets the parameters associated to the element in order.
(Inherited from Element)
Public method GetParameter Retrieves a parameter from the element given identifier.
(Inherited from Element)
Public method GetParameterFormatOptions Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists.
(Inherited from Element)
Public method GetParameters Retrieves the parameters from the element via the given name.
(Inherited from Element)
Public method GetPhaseStatus Gets the status of a given element in the input phase
(Inherited from Element)
Public method GetPreviewImage Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element.
(Inherited from ElementType)
GetRoofConstructionType | Get a Roof ConceptualConstructionType by its ConceptualConstructionRoofType.
GetShadeConstructionType | Get a Shade ConceptualConstructionType by its ConceptualConstructionShadeType.
Public method GetSimilarTypes Obtains a set of types that are similar to this type.
(Inherited from ElementType)
Public method GetSubelements Returns the collection of element subelements.
(Inherited from Element)
Public method GetType Gets the Type of the current instance.
(Inherited from Object)
GetTypeId Returns the identifier of this element's type.
(Inherited from Element)
Public method GetValidTypes Obtains a set of types that are valid for this element.
(Inherited from Element)
GetWallConstructionType | Get a Wall ConceptualConstructionType by its ConceptualConstructionWallType.
GetWindowOrSkylightConstructionType | Get a Window or Skylight ConceptualConstructionType by its ConceptualConstructionWindowSkylightType.
Public method HasPhases Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.
(Inherited from Element)
Public method IsCreatedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element)
Public method IsDemolishedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element)
Public method IsExternalFileReference Determines whether this Element represents an external file.
(Inherited from Element)
Public method IsHidden Identifies if the element has been permanently hidden in the view.
(Inherited from Element)
Public method IsMonitoringLinkElement Indicate whether an element is monitoring any elements in any linked models.
(Inherited from Element)
Public method IsMonitoringLocalElement Indicate whether an element is monitoring other local elements.
(Inherited from Element)
Public method IsPhaseCreatedValid Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element.
(Inherited from Element)
Public method IsPhaseDemolishedValid Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element.
(Inherited from Element)
Public method IsSimilarType Checks if given type is similar to this type.
(Inherited from ElementType)
IsValidConceptualConstructionId | Indicates if the ElementId is an id of a ConceptualConstructionType.
IsValidConceptualConstructionIdForCategory | Indicate if a ConceptualConstruction is appropriate to assign to a MassSurfaceData of a particular Mass subcategory.
Public method IsValidDefaultFamilyType Identifies if this type is a valid default family type for the given family category id.
(Inherited from ElementType)
IsValidSubcategoryForMassSurfaceDatas Validate if a subcategory is appropriate for assignment to Massing surfaces (MassSurfaceData). This is the list of acceptable values:
  1. OST_MassInteriorWall
  2. OST_MassExteriorWall
  3. OST_MassExteriorWallUnderground
  4. OST_MassRoof
  5. OST_MassFloor
  6. OST_MassSlab
  7. OST_MassShade
  8. OST_MassGlazing
  9. OST_MassSkylights
  10. OST_MassOpening
Public method | IsValidSurfaceSubcategoryForConstruction | Indicates if this ConceptualConstructionType is appropriate for the input MassSurfaceData subcategory.
Public method IsValidType(ElementId) Checks if given type is valid for this element.
(Inherited from Element)
Public method LookupParameter Attempts to find a parameter on the element which has the given name.
(Inherited from Element)
Public method RefersToExternalResourceReference Determines whether this Element uses external resources associated with a specified external resource type.
(Inherited from Element)
Public method RefersToExternalResourceReferences Determines whether this Element uses external resources.
(Inherited from Element)
Public method SetEntity Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten.
(Inherited from Element)
Public method ToString Returns a string that represents the current object.
(Inherited from Object)
Top
See Also

Reference

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionType.GetAllConceptualConstructionsForCategory Method

ConceptualConstructionTypeGetAllConceptualConstructionsForCategory Method

Get all the ids of constructions applicable to the input massSubCategory

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ICollection<ElementId> GetAllConceptualConstructionsForCategory(
    Document ccda,
    ElementId massSubCategoryId
)
Public Shared Function GetAllConceptualConstructionsForCategory (
    ccda As Document,
    massSubCategoryId As ElementId
) As ICollection(Of ElementId)
public:
static ICollection<ElementId^>^ GetAllConceptualConstructionsForCategory(
    Document^ ccda,
    ElementId^ massSubCategoryId
)
static member GetAllConceptualConstructionsForCategory :
        ccda : Document *
        massSubCategoryId : ElementId -> ICollection<ElementId>

Parameters

ccda Document
The document.
massSubCategoryId ElementId
The ElementId of the mass subcategory.

Return Value

ICollection ElementId
Returns a set of ElementIds that for the ConceptualConstructionTypes that are appropriate for the subcategory.
Exceptions
Exception | Condition
ArgumentException | The mass sub-category is none of the OST_MassInteriorWall, OST_MassExteriorWall, OST_MassExteriorWallUnderground, OST_MassWallsAll, OST_MassRoof, OST_MassFloor, OST_MassSlab, OST_MassFloorsAll, OST_MassShade, OST_MassGlazing, OST_MassSkylights, OST_MassGlazingAll or OST_MassOpening.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionType.GetFloorOrSlabConstructionType Method

ConceptualConstructionTypeGetFloorOrSlabConstructionType Method

Get a Floor or Slab ConceptualConstructionType by its ConceptualConstructionFloorSlabType.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ElementId GetFloorOrSlabConstructionType(
    Document ccda,
    ConceptualConstructionFloorSlabType typeEnum
)
Public Shared Function GetFloorOrSlabConstructionType (
    ccda As Document,
    typeEnum As ConceptualConstructionFloorSlabType
) As ElementId
public:
static ElementId^ GetFloorOrSlabConstructionType(
    Document^ ccda,
    ConceptualConstructionFloorSlabType typeEnum
)
static member GetFloorOrSlabConstructionType :
        ccda : Document *
        typeEnum : ConceptualConstructionFloorSlabType -> ElementId

Parameters

ccda Document
The Document.
typeEnum ConceptualConstructionFloorSlabType
The ConceptualConstructionFloorSlabType to get the ConceptualConstructionType for.

Return Value

ElementId
Returns ElementId of a ConceptualConstructionType.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | The enum is invalid for ConceptualConstructionFloorSlabType. -or- A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionType.GetGBSId Method

ConceptualConstructionTypeGetGBSId Method

Gets the Green Building Studio identifier associated with the construction.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetGBSId(
    ElementId massSurfaceSubCategoryId
)
Public Function GetGBSId (
    massSurfaceSubCategoryId As ElementId
) As Integer
public:
int GetGBSId(
    ElementId^ massSurfaceSubCategoryId
)
member GetGBSId :
        massSurfaceSubCategoryId : ElementId -> int

Parameters

massSurfaceSubCategoryId ElementId
The ElementId of a valid Mass subcategory of a MassSurfaceData.

Return Value

Int32
Returns the integer id used to represent the ConceptualConstructionType.
Exceptions
Exception | Condition
ArgumentException | The input Element massSurfaceSubCategoryId is not a valid subcategory value for MassSurfaceData. -or- The ElementId massSurfaceSubCategoryId is not appropriate for this ConceptualConstructionType.
ArgumentNullException | A non-optional argument was null
Remarks
Sometimes the GBSId is different for the same ConceptualConstructionType depending on the mass subcategory it is related to. This is usually the case, for example, for window and skylight constructions, which do not share GBSid's even when they share ConceptualConstructionTypes.
See Also

Reference

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionType.GetOpeningConstructionType Method

ConceptualConstructionTypeGetOpeningConstructionType Method

Get an Opening ConceptualConstructionType by its ConceptualConstructionOpeningType.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ElementId GetOpeningConstructionType(
    Document ccda,
    ConceptualConstructionOpeningType typeEnum
)
Public Shared Function GetOpeningConstructionType (
    ccda As Document,
    typeEnum As ConceptualConstructionOpeningType
) As ElementId
public:
static ElementId^ GetOpeningConstructionType(
    Document^ ccda,
    ConceptualConstructionOpeningType typeEnum
)
static member GetOpeningConstructionType :
        ccda : Document *
        typeEnum : ConceptualConstructionOpeningType -> ElementId

Parameters

ccda Document
The Document.
typeEnum ConceptualConstructionOpeningType
The ConceptualConstructionOpeningType to get the ConceptualConstructionType for.

Return Value

ElementId
Returns ElementId of a ConceptualConstructionType.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | The enum is invalid for ConceptualConstructionOpeningType. -or- A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionType.GetRoofConstructionType Method

ConceptualConstructionTypeGetRoofConstructionType Method

Get a Roof ConceptualConstructionType by its ConceptualConstructionRoofType.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ElementId GetRoofConstructionType(
    Document ccda,
    ConceptualConstructionRoofType typeEnum
)
Public Shared Function GetRoofConstructionType (
    ccda As Document,
    typeEnum As ConceptualConstructionRoofType
) As ElementId
public:
static ElementId^ GetRoofConstructionType(
    Document^ ccda,
    ConceptualConstructionRoofType typeEnum
)
static member GetRoofConstructionType :
        ccda : Document *
        typeEnum : ConceptualConstructionRoofType -> ElementId

Parameters

ccda Document
The Document.
typeEnum ConceptualConstructionRoofType
The ConceptualConstructionRoofType to get the ConceptualConstructionType for.

Return Value

ElementId
Returns ElementId of a ConceptualConstructionType.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | The enum is invalid for ConceptualConstructionRoofType. -or- A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionType.GetShadeConstructionType Method

ConceptualConstructionTypeGetShadeConstructionType Method

Get a Shade ConceptualConstructionType by its ConceptualConstructionShadeType.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ElementId GetShadeConstructionType(
    Document ccda,
    ConceptualConstructionShadeType typeEnum
)
Public Shared Function GetShadeConstructionType (
    ccda As Document,
    typeEnum As ConceptualConstructionShadeType
) As ElementId
public:
static ElementId^ GetShadeConstructionType(
    Document^ ccda,
    ConceptualConstructionShadeType typeEnum
)
static member GetShadeConstructionType :
        ccda : Document *
        typeEnum : ConceptualConstructionShadeType -> ElementId

Parameters

ccda Document
The Document.
typeEnum ConceptualConstructionShadeType
The ConceptualConstructionShadeType to get the ConceptualConstructionType for.

Return Value

ElementId
Returns ElementId of a ConceptualConstructionType.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | The enum is invalid for ConceptualConstructionShadeType. -or- A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionType.GetWallConstructionType Method

ConceptualConstructionTypeGetWallConstructionType Method

Get a Wall ConceptualConstructionType by its ConceptualConstructionWallType.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ElementId GetWallConstructionType(
    Document ccda,
    ConceptualConstructionWallType typeEnum
)
Public Shared Function GetWallConstructionType (
    ccda As Document,
    typeEnum As ConceptualConstructionWallType
) As ElementId
public:
static ElementId^ GetWallConstructionType(
    Document^ ccda,
    ConceptualConstructionWallType typeEnum
)
static member GetWallConstructionType :
        ccda : Document *
        typeEnum : ConceptualConstructionWallType -> ElementId

Parameters

ccda Document
The Document.
typeEnum ConceptualConstructionWallType
The ConceptualConstructionWallType to get the ConceptualConstructionType for.

Return Value

ElementId
Returns ElementId of a ConceptualConstructionType.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | The enum is invalid for ConceptualConstructionWallType. -or- A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionType.GetWindowOrSkylightConstructionType Method

ConceptualConstructionTypeGetWindowOrSkylightConstructionType Method

Get a Window or Skylight ConceptualConstructionType by its ConceptualConstructionWindowSkylightType.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ElementId GetWindowOrSkylightConstructionType(
    Document ccda,
    ConceptualConstructionWindowSkylightType typeEnum
)
Public Shared Function GetWindowOrSkylightConstructionType (
    ccda As Document,
    typeEnum As ConceptualConstructionWindowSkylightType
) As ElementId
public:
static ElementId^ GetWindowOrSkylightConstructionType(
    Document^ ccda,
    ConceptualConstructionWindowSkylightType typeEnum
)
static member GetWindowOrSkylightConstructionType :
        ccda : Document *
        typeEnum : ConceptualConstructionWindowSkylightType -> ElementId

Parameters

ccda Document
The Document.
typeEnum ConceptualConstructionWindowSkylightType
The ConceptualConstructionWindowSkylightType to get the ConceptualConstructionType for.

Return Value

ElementId
Returns ElementId of a ConceptualConstructionType.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | The enum is invalid for ConceptualConstructionWindowSkylightType. -or- A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionType.IsValidConceptualConstructionId Method

ConceptualConstructionTypeIsValidConceptualConstructionId Method

Indicates if the ElementId is an id of a ConceptualConstructionType.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidConceptualConstructionId(
    Document ccda,
    ElementId constructionTypeId
)
Public Shared Function IsValidConceptualConstructionId (
    ccda As Document,
    constructionTypeId As ElementId
) As Boolean
public:
static bool IsValidConceptualConstructionId(
    Document^ ccda,
    ElementId^ constructionTypeId
)
static member IsValidConceptualConstructionId :
        ccda : Document *
        constructionTypeId : ElementId -> bool

Parameters

ccda Document
The document.
constructionTypeId ElementId
The ElementId of the ConceptualConstructionType.

Return Value

Boolean
Returns true if is an id of a ConceptualConstructionType, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionType.IsValidConceptualConstructionIdForCategory Method

ConceptualConstructionTypeIsValidConceptualConstructionIdForCategory Method

Indicate if a ConceptualConstruction is appropriate to assign to a MassSurfaceData of a particular Mass subcategory.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidConceptualConstructionIdForCategory(
    Document ccda,
    ElementId constructionTypeId,
    ElementId massSubcategoryId
)
Public Shared Function IsValidConceptualConstructionIdForCategory (
    ccda As Document,
    constructionTypeId As ElementId,
    massSubcategoryId As ElementId
) As Boolean
public:
static bool IsValidConceptualConstructionIdForCategory(
    Document^ ccda,
    ElementId^ constructionTypeId,
    ElementId^ massSubcategoryId
)
static member IsValidConceptualConstructionIdForCategory :
        ccda : Document *
        constructionTypeId : ElementId *
        massSubcategoryId : ElementId -> bool

Parameters

ccda Document
The document.
constructionTypeId ElementId
The ElementId of the ConceptualConstructionType.
massSubcategoryId ElementId
The ElementId of the Mass subcategory.

Return Value

Boolean
Returns true if valid, false otherwise
Exceptions
Exception | Condition
ArgumentException | The ElementId constructionTypeId is not an id of a ConceptualConstructionType. -or- The mass sub-category is none of the OST_MassInteriorWall, OST_MassExteriorWall, OST_MassExteriorWallUnderground, OST_MassWallsAll, OST_MassRoof, OST_MassFloor, OST_MassSlab, OST_MassFloorsAll, OST_MassShade, OST_MassGlazing, OST_MassSkylights, OST_MassGlazingAll or OST_MassOpening.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionType.IsValidSubcategoryForMassSurfaceDatas Method

ConceptualConstructionTypeIsValidSubcategoryForMassSurfaceDatas Method

Validate if a subcategory is appropriate for assignment to Massing surfaces (MassSurfaceData). This is the list of acceptable values:
  1. OST_MassInteriorWall
  2. OST_MassExteriorWall
  3. OST_MassExteriorWallUnderground
  4. OST_MassRoof
  5. OST_MassFloor
  6. OST_MassSlab
  7. OST_MassShade
  8. OST_MassGlazing
  9. OST_MassSkylights
  10. OST_MassOpening

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidSubcategoryForMassSurfaceDatas(
    ElementId massSubCategoryId
)
Public Shared Function IsValidSubcategoryForMassSurfaceDatas (
    massSubCategoryId As ElementId
) As Boolean
public:
static bool IsValidSubcategoryForMassSurfaceDatas(
    ElementId^ massSubCategoryId
)
static member IsValidSubcategoryForMassSurfaceDatas :
        massSubCategoryId : ElementId -> bool

Parameters

massSubCategoryId ElementId
The mass sub-category to be checked.

Return Value

Boolean
True if the mass sub-category falls within the list, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
This excludes sub-categories which are not actually sub-categories that can be assigned to surfaces, such as OST_MassWallsAll for example.
See Also

Reference

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionType.IsValidSurfaceSubcategoryForConstruction Method

ConceptualConstructionTypeIsValidSurfaceSubcategoryForConstruction Method

Indicates if this ConceptualConstructionType is appropriate for the input MassSurfaceData subcategory.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidSurfaceSubcategoryForConstruction(
    ElementId massSurfaceSubcategoryId
)
Public Function IsValidSurfaceSubcategoryForConstruction (
    massSurfaceSubcategoryId As ElementId
) As Boolean
public:
bool IsValidSurfaceSubcategoryForConstruction(
    ElementId^ massSurfaceSubcategoryId
)
member IsValidSurfaceSubcategoryForConstruction :
        massSurfaceSubcategoryId : ElementId -> bool

Parameters

massSurfaceSubcategoryId ElementId
The ElementId of a Mass subcategory of a MassSurfaceData.

Return Value

Boolean
Returns true if appropriate for the input subcategory, false otherwise.
Exceptions
Exception | Condition
ArgumentException | The input Element massSurfaceSubcategoryId is not a valid subcategory value for MassSurfaceData.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionWallType Enumeration

ConceptualConstructionType values for Walls.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConceptualConstructionWallType
Public Enumeration ConceptualConstructionWallType
public enum class ConceptualConstructionWallType
type ConceptualConstructionWallType
Members
Member name | Value | Description
LightweightConstructionHighInsulation | 0 | Lightweight Construction High Insulation Wall
LightweightConstructionTypicalColdClimateInsulation | 1 | Lightweight Construction Typical Cold Climate Insulation Wall
LightweightConstructionTypicalMildClimateInsulation | 2 | Lightweight Construction Typical Mild Climate Insulation Wall
LightweightConstructionLowInsulation | 3 | Lightweight Construction Low Insulation Wall
LightweightConstructionNoInsulationInterior | 4 | Lightweight Construction No Insulation Interior Wall
HighMassConstructionHighInsulation | 5 | High Mass Construction High Insulation Wall
HighMassConstructionTypicalColdClimateInsulation | 6 | High Mass Construction Typical Cold Climate Insulation Wall
HighMassConstructionTypicalMildClimateInsulation | 7 | High Mass Construction Typical Mild Climate Insulation Wall
HighMassConstructionNoInsulationInterior | 8 | High Mass Construction No Insulation Interior Wall
NumWallTypeConstruction | 9 | Total Number of Wall Type Constructions
InvalidExteriorWallTypeConstruction | -1 | Invalid value/not set Roof Type Construction value
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionWindowSkylightType Enumeration

ConceptualConstructionType values for Windows and Skylights

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConceptualConstructionWindowSkylightType
Public Enumeration ConceptualConstructionWindowSkylightType
public enum class ConceptualConstructionWindowSkylightType
type ConceptualConstructionWindowSkylightType
Members
Member name | Value | Description
SinglePaneClearNoCoating | 0 | Single Pane Clear No Coating Window or Skylight
SinglePaneTinted | 1 | Single Pane Tinted Window or Skylight
SinglePaneReflective | 2 | Single Pane Reflective Window or Skylight
DoublePaneClearNoCoating | 3 | Double Pane Clear No Coating Window or Skylight
DoublePaneTinted | 4 | Double Pane Tinted Window or Skylight
DoublePaneReflective | 5 | Double Pane Reflective Window or Skylight
DoublePaneClearLowEColdClimateHighSHGC | 6 | Double Pane Clear Low Energy Cold Climate High Solar Heat Gain Coefficient Window or Skylight
DoublePaneClearLowEHotClimateLowSHGC | 7 | Double Pane Clear Low Energy Hot Climate Low Solar Heat Gain Coefficient Window or Skylight
DoublePaneClearHighestPerformanceLowEHighVisTransLowSHGC | 8 | Double Pane Clear Highest Performance Low Window or Skylight
TriplePaneClearLowEHotOrColdClimate | 9 | Triple Pane Clear Low Energy Hot or Cold Climate Window or Skylight
InvalidWindowSkylightTypeConstruction | -1 | Invalid value/not set Window or Skylight Type Construction
QuadPaneClearLowEHotOrColdClimate | 10 | Quad Pane Clear Low Energy Hot Or Cold Climate Window or Skylight
NumWindowSkylightTypeConstruction | 11 | Total Number of Window or Skylight Type Constructions
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


ConceptualSurfaceType Class

This element represents a conceptual BIM object category to assign to faces in Mass geometries. There is one ConceptualSurfaceType element for each of the Mass Surface Subcategories. for serialization
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DB.AnalysisConceptualSurfaceType

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ConceptualSurfaceType : Element
Public Class ConceptualSurfaceType
    Inherits Element
public ref class ConceptualSurfaceType : public Element
type ConceptualSurfaceType =
    class
        inherit Element
    end

The ConceptualSurfaceType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | DefaultConstructionTypeId | The element id of the user specified ConceptualConstructionType to be used by default on creation for mass faces of this mass subcategory.
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | MassSubCategoryId | The mass subcategory id of the ConceptualSurfaceType.
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
 | GetAllMassSubCategoryIds | Get all the mass subcategory ids for which there are ConceptualSurfaceType's.
 | GetByMassSubCategoryId | Get the ConceptualSurfaceType by its mass subcategory id.
Public method | GetConstructionTypeIds | The element ids of the ConceptualConstructionType's associated with this ConceptualSurfaceType.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
When Conceptual Energy Analysis is enabled in Revit Projects, massing faces will be assigned to the subcategories of Mass category that these ConceptualSurfaceType's are associated with. A default ConceptualConstructionType is associated with the ConceptualSurfaceType. This default ConceptualConstructionType is assigned to Mass faces with the corresponding subcategory. Changing the default ConceptualConstructionType associated with the ConceptualSurfaceType will update the ConceptualConstruction type for all Mass faces of that subcategory which the user has not specifically provided an override value for.
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


ConceptualSurfaceType Properties

The ConceptualSurfaceType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | DefaultConstructionTypeId | The element id of the user specified ConceptualConstructionType to be used by default on creation for mass faces of this mass subcategory.
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | MassSubCategoryId | The mass subcategory id of the ConceptualSurfaceType.
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

ConceptualSurfaceType Class
Autodesk.Revit.DB.Analysis Namespace


ConceptualSurfaceType.DefaultConstructionTypeId Property

ConceptualSurfaceTypeDefaultConstructionTypeId Property

The element id of the user specified ConceptualConstructionType to be used by default on creation for mass faces of this mass subcategory.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId DefaultConstructionTypeId { get; set; }
Public Property DefaultConstructionTypeId As ElementId
    Get
    Set
public:
property ElementId^ DefaultConstructionTypeId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member DefaultConstructionTypeId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentException | When setting this property: The input element is not a constructionType.
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

ConceptualSurfaceType Class
Autodesk.Revit.DB.Analysis Namespace


ConceptualSurfaceType.MassSubCategoryId Property

ConceptualSurfaceTypeMassSubCategoryId Property

The mass subcategory id of the ConceptualSurfaceType.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId MassSubCategoryId { get; }
Public ReadOnly Property MassSubCategoryId As ElementId
    Get
public:
property ElementId^ MassSubCategoryId {
    ElementId^ get ();
}
member MassSubCategoryId : ElementId with get

Property Value

ElementId
See Also

Reference

ConceptualSurfaceType Class
Autodesk.Revit.DB.Analysis Namespace


ConceptualSurfaceType Methods

The ConceptualSurfaceType type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
 | GetAllMassSubCategoryIds | Get all the mass subcategory ids for which there are ConceptualSurfaceType's.
 | GetByMassSubCategoryId | Get the ConceptualSurfaceType by its mass subcategory id.
Public method | GetConstructionTypeIds | The element ids of the ConceptualConstructionType's associated with this ConceptualSurfaceType.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ConceptualSurfaceType Class
Autodesk.Revit.DB.Analysis Namespace


ConceptualSurfaceType.GetAllMassSubCategoryIds Method

ConceptualSurfaceTypeGetAllMassSubCategoryIds Method

Get all the mass subcategory ids for which there are ConceptualSurfaceType's.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<ElementId> GetAllMassSubCategoryIds()
Public Shared Function GetAllMassSubCategoryIds As IList(Of ElementId)
public:
static IList<ElementId^>^ GetAllMassSubCategoryIds()
static member GetAllMassSubCategoryIds : unit -> IList<ElementId>

Return Value

IList ElementId
Returns an array of element id of mass subcategories for which there are ConceptualSurfaceType's.
See Also

Reference

ConceptualSurfaceType Class
Autodesk.Revit.DB.Analysis Namespace


ConceptualSurfaceType.GetByMassSubCategoryId Method

ConceptualSurfaceTypeGetByMassSubCategoryId Method

Get the ConceptualSurfaceType by its mass subcategory id.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ConceptualSurfaceType GetByMassSubCategoryId(
    Document cda,
    ElementId massSubCategoryId
)
Public Shared Function GetByMassSubCategoryId (
    cda As Document,
    massSubCategoryId As ElementId
) As ConceptualSurfaceType
public:
static ConceptualSurfaceType^ GetByMassSubCategoryId(
    Document^ cda,
    ElementId^ massSubCategoryId
)
static member GetByMassSubCategoryId :
        cda : Document *
        massSubCategoryId : ElementId -> ConceptualSurfaceType

Parameters

cda Document
The document.
massSubCategoryId ElementId
The mass subcategory id to get the ConceptualSurfaceType for.

Return Value

ConceptualSurfaceType
Returns ConceptualSurfaceType associated with input id or NULL.
Exceptions
Exception | Condition
ArgumentException | The mass sub-category is none of the OST_MassInteriorWall, OST_MassExteriorWall, OST_MassExteriorWallUnderground, OST_MassRoof, OST_MassFloor, OST_MassSlab, OST_MassShade, OST_MassGlazing, OST_MassSkylights, or OST_MassOpening.
ArgumentNullException | A non-optional argument was null
See Also

Reference

ConceptualSurfaceType Class
Autodesk.Revit.DB.Analysis Namespace


ConceptualSurfaceType.GetConstructionTypeIds Method

ConceptualSurfaceTypeGetConstructionTypeIds Method

The element ids of the ConceptualConstructionType's associated with this ConceptualSurfaceType.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetConstructionTypeIds()
Public Function GetConstructionTypeIds As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetConstructionTypeIds()
member GetConstructionTypeIds : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
See Also

Reference

ConceptualSurfaceType Class
Autodesk.Revit.DB.Analysis Namespace


ConstructionType Enumeration

This enumeration specifies the available analytical construction types like external walls, windows etc. for use in the detailed analytical energy model.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ConstructionType
Public Enumeration ConstructionType
public enum class ConstructionType
type ConstructionType
Members
Member name | Value | Description
ExteriorWall | 0 | An exterior wall surrounding the space
InteriorWall | 1 | An interior wall surrounding the space
Slab | 2 | A slab below the space
Roof | 3 | A roof over the space
Ceiling | 4 | A ceiling over the space
Floor | 5 | A floor below the space
Door | 6 | A door in a wall in the space
ExteriorWindow | 7 | A window in an exterior wall in the space
InteriorWindow | 8 | A window in an interior wall in the space
Skylight | 9 | A window in a roof in the space
UndergroundWall | 10 | Underground walls
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


CriticalPathCollector Class

This class is used to search and traverse the network analytical segments on the critical path.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DB.AnalysisCriticalPathCollector

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CriticalPathCollector : IEnumerable<MEPNetworkSegmentId>,
    IDisposable
Public Class CriticalPathCollector
    Implements IEnumerable(Of MEPNetworkSegmentId), IDisposable
public ref class CriticalPathCollector : IEnumerable<MEPNetworkSegmentId^>,
    IDisposable
type CriticalPathCollector =
    class
        interface IEnumerable<MEPNetworkSegmentId>
        interface IDisposable
    end

The CriticalPathCollector type exposes the following members.

Constructors
 | Name | Description
Public method | CriticalPathCollector | Creates a new CriticalPathCollector that visits the analytical segments on the network critical path.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the CriticalPathCollector
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetCalculatedFlow | Gets the calculated flow of the network.
Public method | GetCalculatedPressureDrop | Gets the calculated pressure drop of the network.
Public method | GetCriticalPathCollectorIterator | Gets the critical path iterator to traverse individual segment.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToNetworkSegmentIds | Returns the list of analytical segment ids on the network critical path.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The critcal path is a connected flow path that has the maximum pressure loss value on the network. The associated flow and pressure loss values are often used to select the equipment size. When this collector is constructed, the network is identified by one analytical segment seed. User may get the CriticalPathIterator from the collector to traverse the analytical segment on the critical path, in the sequence of their flow direction. Note that If the network contains multiple hydraulically separated levels, the critical path traversal is focused on the same hydraulic separation level as the seed segment.
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


CriticalPathCollector Constructor

Creates a new CriticalPathCollector that visits the analytical segments on the network critical path.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CriticalPathCollector(
    Document doc,
    MEPNetworkSegmentId segmentId
)
Public Sub New (
    doc As Document,
    segmentId As MEPNetworkSegmentId
)
public:
CriticalPathCollector(
    Document^ doc,
    MEPNetworkSegmentId^ segmentId
)
new :
        doc : Document *
        segmentId : MEPNetworkSegmentId -> CriticalPathCollector

Parameters

doc Document
The document of the analytical network.
segmentId MEPNetworkSegmentId
The analytical segment to identify the network. Note that this segment is not required to be on the critical path.
Exceptions
Exception | Condition
ArgumentException | The network segment id is invalid.
ArgumentNullException | A non-optional argument was null
See Also

Reference

CriticalPathCollector Class
Autodesk.Revit.DB.Analysis Namespace


CriticalPathCollector Properties

The CriticalPathCollector type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

CriticalPathCollector Class
Autodesk.Revit.DB.Analysis Namespace


CriticalPathCollector.IsValidObject Property

CriticalPathCollectorIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

CriticalPathCollector Class
Autodesk.Revit.DB.Analysis Namespace


CriticalPathCollector Methods

The CriticalPathCollector type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetCalculatedFlow | Gets the calculated flow of the network.
Public method | GetCalculatedPressureDrop | Gets the calculated pressure drop of the network.
Public method | GetCriticalPathCollectorIterator | Gets the critical path iterator to traverse individual segment.
Public method | GetEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToNetworkSegmentIds | Returns the list of analytical segment ids on the network critical path.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CriticalPathCollector Class
Autodesk.Revit.DB.Analysis Namespace


CriticalPathCollector.Dispose Method

CriticalPathCollectorDispose Method

Releases all resources used by the CriticalPathCollector

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

CriticalPathCollector Class
Autodesk.Revit.DB.Analysis Namespace


CriticalPathCollector.GetBasicIEnumerator Method

CriticalPathCollectorGetBasicIEnumerator Method

Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
internal virtual IEnumerator GetBasicIEnumerator()
Friend Overridable Function GetBasicIEnumerator As IEnumerator
internal:
virtual IEnumerator^ GetBasicIEnumerator()
internal abstract GetBasicIEnumerator : unit -> IEnumerator
internal override GetBasicIEnumerator : unit -> IEnumerator

Return Value

IEnumerator
An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerableGetEnumerator
See Also

Reference

CriticalPathCollector Class
Autodesk.Revit.DB.Analysis Namespace


CriticalPathCollector.GetCalculatedFlow Method

CriticalPathCollectorGetCalculatedFlow Method

Gets the calculated flow of the network.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetCalculatedFlow()
Public Function GetCalculatedFlow As Double
public:
double GetCalculatedFlow()
member GetCalculatedFlow : unit -> float

Return Value

Double
The flow value in the internal Revit unit ft^3/second.
Remarks
The calculated flow is the maximum flow value of any analytical segment on the network, typically associated with the main branch.
See Also

Reference

CriticalPathCollector Class
Autodesk.Revit.DB.Analysis Namespace


CriticalPathCollector.GetCalculatedPressureDrop Method

CriticalPathCollectorGetCalculatedPressureDrop Method

Gets the calculated pressure drop of the network.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetCalculatedPressureDrop()
Public Function GetCalculatedPressureDrop As Double
public:
double GetCalculatedPressureDrop()
member GetCalculatedPressureDrop : unit -> float

Return Value

Double
The pressure drop value in the internal Revit unit kg/(ft*s^2).
Remarks
The calculated pressure drop is the total pressure loss value of all analytical segment on the critical path. The value is often used to select the equipment.
See Also

Reference

CriticalPathCollector Class
Autodesk.Revit.DB.Analysis Namespace


CriticalPathCollector.GetCriticalPathCollectorIterator Method

CriticalPathCollectorGetCriticalPathCollectorIterator Method

Gets the critical path iterator to traverse individual segment.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CriticalPathIterator GetCriticalPathCollectorIterator()
Public Function GetCriticalPathCollectorIterator As CriticalPathIterator
public:
CriticalPathIterator^ GetCriticalPathCollectorIterator()
member GetCriticalPathCollectorIterator : unit -> CriticalPathIterator

Return Value

CriticalPathIterator
The iterator that traverses the critical path.
See Also

Reference

CriticalPathCollector Class
Autodesk.Revit.DB.Analysis Namespace


CriticalPathCollector.GetEnumerator Method

CriticalPathCollectorGetEnumerator Method

Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual IEnumerator<MEPNetworkSegmentId> GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator(Of MEPNetworkSegmentId)
public:
virtual IEnumerator<MEPNetworkSegmentId^>^ GetEnumerator()
abstract GetEnumerator : unit -> IEnumerator<MEPNetworkSegmentId>
override GetEnumerator : unit -> IEnumerator<MEPNetworkSegmentId>

Return Value

IEnumerator MEPNetworkSegmentId
An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerableTGetEnumerator
See Also

Reference

CriticalPathCollector Class
Autodesk.Revit.DB.Analysis Namespace


CriticalPathCollector.ToNetworkSegmentIds Method

CriticalPathCollectorToNetworkSegmentIds Method

Returns the list of analytical segment ids on the network critical path.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<MEPNetworkSegmentId> ToNetworkSegmentIds()
Public Function ToNetworkSegmentIds As IList(Of MEPNetworkSegmentId)
public:
IList<MEPNetworkSegmentId^>^ ToNetworkSegmentIds()
member ToNetworkSegmentIds : unit -> IList<MEPNetworkSegmentId>

Return Value

IList MEPNetworkSegmentId
The array of all analytical segment ids on the critical path.
See Also

Reference

CriticalPathCollector Class
Autodesk.Revit.DB.Analysis Namespace


CriticalPathIterator Class

An iterator to traverse the critical path in the CriticalPathCollector.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DB.AnalysisCriticalPathIterator

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class CriticalPathIterator : IEnumerator<MEPNetworkSegmentId>
Public Class CriticalPathIterator
    Implements IEnumerator(Of MEPNetworkSegmentId)
public ref class CriticalPathIterator : IEnumerator<MEPNetworkSegmentId^>
type CriticalPathIterator =
    class
        interface IEnumerator<MEPNetworkSegmentId>
    end

The CriticalPathIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the CriticalPathIterator
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCurrent | Gets the analytical segment id at the current iterating position.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next downstream segment on the critical path.
Public method | Reset | Resets the iterator to the beginning segment.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


CriticalPathIterator Properties

The CriticalPathIterator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

CriticalPathIterator Class
Autodesk.Revit.DB.Analysis Namespace


CriticalPathIterator.Current Property

CriticalPathIteratorCurrent Property

Gets the item at the current position of the iterator.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual MEPNetworkSegmentId Current { get; }
Public Overridable ReadOnly Property Current As MEPNetworkSegmentId
    Get
public:
virtual property MEPNetworkSegmentId^ Current {
    MEPNetworkSegmentId^ get ();
}
abstract Current : MEPNetworkSegmentId with get
override Current : MEPNetworkSegmentId with get

Property Value

MEPNetworkSegmentId

Implements

IEnumeratorTCurrent
Exceptions
Exception | Condition
InvalidOperationException | There is no current item in the iterator.
Remarks
There is no current item if the iterator has not started yet or has been done.
See Also

Reference

CriticalPathIterator Class
Autodesk.Revit.DB.Analysis Namespace


CriticalPathIterator.CurrentObject Property

CriticalPathIteratorCurrentObject Property

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
internal Object CurrentObject { get; }
Friend ReadOnly Property CurrentObject As Object
    Get
internal:
virtual property Object^ CurrentObject {
    Object^ get () sealed;
}
internal abstract CurrentObject : Object with get
internal override CurrentObject : Object with get

Property Value

Object

Implements

IEnumeratorCurrent
See Also

Reference

CriticalPathIterator Class
Autodesk.Revit.DB.Analysis Namespace


CriticalPathIterator.IsValidObject Property

CriticalPathIteratorIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

CriticalPathIterator Class
Autodesk.Revit.DB.Analysis Namespace


CriticalPathIterator Methods

The CriticalPathIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetCurrent | Gets the analytical segment id at the current iterating position.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next downstream segment on the critical path.
Public method | Reset | Resets the iterator to the beginning segment.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CriticalPathIterator Class
Autodesk.Revit.DB.Analysis Namespace


CriticalPathIterator.Dispose Method

CriticalPathIteratorDispose Method

Releases all resources used by the CriticalPathIterator

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit
See Also

Reference

CriticalPathIterator Class
Autodesk.Revit.DB.Analysis Namespace


CriticalPathIterator.GetCurrent Method

CriticalPathIteratorGetCurrent Method

Gets the analytical segment id at the current iterating position.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MEPNetworkSegmentId GetCurrent()
Public Function GetCurrent As MEPNetworkSegmentId
public:
MEPNetworkSegmentId^ GetCurrent()
member GetCurrent : unit -> MEPNetworkSegmentId

Return Value

MEPNetworkSegmentId
The segment id of the current iterating position.
See Also

Reference

CriticalPathIterator Class
Autodesk.Revit.DB.Analysis Namespace


CriticalPathIterator.IsDone Method

CriticalPathIteratorIsDone Method

Identifies if the iteration has completed.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsDone()
Public Overridable Function IsDone As Boolean
public:
virtual bool IsDone()
abstract IsDone : unit -> bool
override IsDone : unit -> bool

Return Value

Boolean
True if all segments have been visited on the critical path. False if there are more segments to be visited.
See Also

Reference

CriticalPathIterator Class
Autodesk.Revit.DB.Analysis Namespace


CriticalPathIterator.MoveNext Method

CriticalPathIteratorMoveNext Method

Increments the iterator to the next downstream segment on the critical path.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool MoveNext()
Public Overridable Function MoveNext As Boolean
public:
virtual bool MoveNext()
abstract MoveNext : unit -> bool
override MoveNext : unit -> bool

Return Value

Boolean
True if there is another segment available on the critical path that is not visited by this iterator, False if there is no next segment left.
See Also

Reference

CriticalPathIterator Class
Autodesk.Revit.DB.Analysis Namespace


CriticalPathIterator.Reset Method

CriticalPathIteratorReset Method

Resets the iterator to the beginning segment.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()
abstract Reset : unit -> unit
override Reset : unit -> unit
See Also

Reference

CriticalPathIterator Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisConstruction Class

Represent an analytical construction as a composite of layered materials.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DB.AnalysisEnergyAnalysisConstruction

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class EnergyAnalysisConstruction : Element
Public Class EnergyAnalysisConstruction
    Inherits Element
public ref class EnergyAnalysisConstruction : public Element
type EnergyAnalysisConstruction =
    class
        inherit Element
    end

The EnergyAnalysisConstruction type exposes the following members.

Properties
 | Name | Description
Public property | Absorptance | The absorptance value of the construction.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | ConstructionName | The name of the construction
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
Public property | Description | The description of the construction.
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HeatTransferCoefficient | The heat transfer coefficient value (U-value) of the construction, in W/(m^2*K) (equivalent to kg/(k*s^3)).
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsSchematic | Indicates if this originates from a schematic or analytical construction.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Roughness | The roughness value of the construction, from 1 (Very Rough) to 6 (Very Smooth) and -1 when unset.
Public property | ThermalMass | The thermal mass value (Cth-value) of the construction, in J/(m^2*k) (equivalent to kg/(k*s^2)).
Public property | ThermalResistance | The thermal resistance value (R-value) of the construction, in K*s^3/kg.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Returns a list of ids of the associated materials to analytical construction.
Public method | GetMaterialIds(Boolean) | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisConstruction Properties

The EnergyAnalysisConstruction type exposes the following members.

Properties
 | Name | Description
Public property | Absorptance | The absorptance value of the construction.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | ConstructionName | The name of the construction
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
Public property | Description | The description of the construction.
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HeatTransferCoefficient | The heat transfer coefficient value (U-value) of the construction, in W/(m^2*K) (equivalent to kg/(k*s^3)).
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsSchematic | Indicates if this originates from a schematic or analytical construction.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Roughness | The roughness value of the construction, from 1 (Very Rough) to 6 (Very Smooth) and -1 when unset.
Public property | ThermalMass | The thermal mass value (Cth-value) of the construction, in J/(m^2*k) (equivalent to kg/(k*s^2)).
Public property | ThermalResistance | The thermal resistance value (R-value) of the construction, in K*s^3/kg.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

EnergyAnalysisConstruction Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisConstruction.Absorptance Property

EnergyAnalysisConstructionAbsorptance Property

The absorptance value of the construction.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Absorptance { get; }
Public ReadOnly Property Absorptance As Double
    Get
public:
property double Absorptance {
    double get ();
}
member Absorptance : float with get

Property Value

Double
Remarks
The absorptance is 0 when no value is found.
See Also

Reference

EnergyAnalysisConstruction Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisConstruction.ConstructionName Property

EnergyAnalysisConstructionConstructionName Property

The name of the construction

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ConstructionName { get; }
Public ReadOnly Property ConstructionName As String
    Get
public:
property String^ ConstructionName {
    String^ get ();
}
member ConstructionName : string with get

Property Value

String
See Also

Reference

EnergyAnalysisConstruction Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisConstruction.Description Property

EnergyAnalysisConstructionDescription Property

The description of the construction.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get
public:
property String^ Description {
    String^ get ();
}
member Description : string with get

Property Value

String
See Also

Reference

EnergyAnalysisConstruction Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisConstruction.HeatTransferCoefficient Property

EnergyAnalysisConstructionHeatTransferCoefficient Property

The heat transfer coefficient value (U-value) of the construction, in W/(m^2*K) (equivalent to kg/(k*s^3)).

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double HeatTransferCoefficient { get; }
Public ReadOnly Property HeatTransferCoefficient As Double
    Get
public:
property double HeatTransferCoefficient {
    double get ();
}
member HeatTransferCoefficient : float with get

Property Value

Double
See Also

Reference

EnergyAnalysisConstruction Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisConstruction.IsSchematic Property

EnergyAnalysisConstructionIsSchematic Property

Indicates if this originates from a schematic or analytical construction.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSchematic { get; }
Public ReadOnly Property IsSchematic As Boolean
    Get
public:
property bool IsSchematic {
    bool get ();
}
member IsSchematic : bool with get

Property Value

Boolean
See Also

Reference

EnergyAnalysisConstruction Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisConstruction.Roughness Property

EnergyAnalysisConstructionRoughness Property

The roughness value of the construction, from 1 (Very Rough) to 6 (Very Smooth) and -1 when unset.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Roughness { get; }
Public ReadOnly Property Roughness As Integer
    Get
public:
property int Roughness {
    int get ();
}
member Roughness : int with get

Property Value

Int32
See Also

Reference

EnergyAnalysisConstruction Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisConstruction.ThermalMass Property

EnergyAnalysisConstructionThermalMass Property

The thermal mass value (Cth-value) of the construction, in J/(m^2*k) (equivalent to kg/(k*s^2)).

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double ThermalMass { get; }
Public ReadOnly Property ThermalMass As Double
    Get
public:
property double ThermalMass {
    double get ();
}
member ThermalMass : float with get

Property Value

Double
See Also

Reference

EnergyAnalysisConstruction Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisConstruction.ThermalResistance Property

EnergyAnalysisConstructionThermalResistance Property

The thermal resistance value (R-value) of the construction, in K*s^3/kg.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double ThermalResistance { get; }
Public ReadOnly Property ThermalResistance As Double
    Get
public:
property double ThermalResistance {
    double get ();
}
member ThermalResistance : float with get

Property Value

Double
See Also

Reference

EnergyAnalysisConstruction Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisConstruction Methods

The EnergyAnalysisConstruction type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Returns a list of ids of the associated materials to analytical construction.
Public method | GetMaterialIds(Boolean) | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

EnergyAnalysisConstruction Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisConstruction.GetMaterialIds Method

EnergyAnalysisConstructionGetMaterialIds Method

Overload List
 | Name | Description
Public method | GetMaterialIds | Returns a list of ids of the associated materials to analytical construction.
Public method | GetMaterialIds(Boolean) | Gets the element ids of all materials present in the element.
Top
See Also

Reference

EnergyAnalysisConstruction Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisConstruction.GetMaterialIds Method

EnergyAnalysisConstructionGetMaterialIds Method

Returns a list of ids of the associated materials to analytical construction.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<ElementId> GetMaterialIds()
Public Function GetMaterialIds As IList(Of ElementId)
public:
IList<ElementId^>^ GetMaterialIds()
member GetMaterialIds : unit -> IList<ElementId>

Return Value

IList ElementId
See Also

Reference

EnergyAnalysisConstruction Class
GetMaterialIds Overload
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisDetailModel Class

Manage the analytical thermal model.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DB.AnalysisEnergyAnalysisDetailModel

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class EnergyAnalysisDetailModel : Element
Public Class EnergyAnalysisDetailModel
    Inherits Element
public ref class EnergyAnalysisDetailModel : public Element
type EnergyAnalysisDetailModel =
    class
        inherit Element
    end

The EnergyAnalysisDetailModel type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | BuildingTypeId | The building type element.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | ExportCategory | Export elements of this category in energy analysis.
Public property | ExportMullions | Indicates if to specify the setting for exporting mullions.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IncludeShadingSurfaces | Indicates if to set and get the setting for if shading surfaces should be included.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SimplifyCurtainSystems | Indicates if to specify the setting for simplified curtain systems.
Public property | Tier | Level of computation for energy analysis model.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new energy analysis detailed model.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAnalyticalOpenings | The collection of analytical openings.
Public method | GetAnalyticalShadingSurfaces | The collection of analytical shading surfaces.
Public method | GetAnalyticalSpaces | The collection of analytical spaces.
Public method | GetAnalyticalSurfaces | The collection of analytical surfaces.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
 | GetMainEnergyAnalysisDetailModel | Gets the EnergyAnalysisDetailModel in given document.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | TransformModel | Transforms all surfaces in the model according to the document's active ground plane, shared coordinates and true north.
Top
Remarks
The Export to gbXML and the Heating and Cooling Loads features produces an analytical thermal model from the physical model of a building. The analytical thermal model is composed of spaces, zones and planar surfaces that represent the actual volumetric elements of the building. If there are currently no EnergyAnalysisDetailModel elements in the document, when the first one is generated it will be considered the persistent energy model (and maybe removed and recreated by actions the user takes in the UI). If there is already a persistent EnergyAnalysisDetailModel element in the document, the API can generate other independent energy models, but they will not be affected by the actions the user takes in the UI. The EnergyAnalysisDetailModel will remain in the document until it is discarded (either by the actions of the user, or by a call to Document.Delete() ).
Example
C#
VB
C++
F#
Copy
// Collect space and surface data from the building's analytical thermal model
EnergyAnalysisDetailModelOptions options = new EnergyAnalysisDetailModelOptions();
options.Tier = EnergyAnalysisDetailModelTier.Final; // include constructions, schedules, and non-graphical data in the computation of the energy analysis model
options.EnergyModelType = EnergyModelType.SpatialElement;   // Energy model based on rooms or spaces

EnergyAnalysisDetailModel eadm = EnergyAnalysisDetailModel.Create(doc, options); // Create a new energy analysis detailed model from the physical model
IList<EnergyAnalysisSpace> spaces = eadm.GetAnalyticalSpaces();
StringBuilder builder = new StringBuilder();
builder.AppendLine("Spaces: " + spaces.Count);
foreach (EnergyAnalysisSpace space in spaces)
{
    SpatialElement spatialElement = doc.GetElement(space.CADObjectUniqueId) as SpatialElement;
    ElementId spatialElementId = spatialElement == null ? ElementId.InvalidElementId : spatialElement.Id;
    builder.AppendLine("   >>> " + space.SpaceName + " related to " + spatialElementId);
    IList<EnergyAnalysisSurface> surfaces = space.GetAnalyticalSurfaces();
    builder.AppendLine("       has " + surfaces.Count + " surfaces.");
    foreach (EnergyAnalysisSurface surface in surfaces)
    {
        builder.AppendLine("            +++ Surface from " + surface.OriginatingElementDescription);
    }
}
Autodesk.Revit.UI.TaskDialog.Show("EAM", builder.ToString());
' Collect space and surface data from the building's analytical thermal model
Dim options As New EnergyAnalysisDetailModelOptions()
options.Tier = EnergyAnalysisDetailModelTier.Final
' include constructions, schedules, and non-graphical data in the computation of the energy analysis model
options.EnergyModelType = EnergyModelType.SpatialElement
' Energy model based on rooms or spaces
Dim eadm As EnergyAnalysisDetailModel = EnergyAnalysisDetailModel.Create(doc, options)
' Create a new energy analysis detailed model from the physical model
Dim spaces As IList(Of EnergyAnalysisSpace) = eadm.GetAnalyticalSpaces()
Dim builder As New StringBuilder()
builder.AppendLine("Spaces: " + spaces.Count)
For Each space As EnergyAnalysisSpace In spaces
    Dim spatialElement As SpatialElement = TryCast(doc.GetElement(space.CADObjectUniqueId), SpatialElement)
    Dim spatialElementId As ElementId = If(spatialElement Is Nothing, ElementId.InvalidElementId, spatialElement.Id)
    builder.AppendLine("   >>> " + space.SpaceName + " related to " + spatialElementId.ToString())
    Dim surfaces As IList(Of EnergyAnalysisSurface) = space.GetAnalyticalSurfaces()
    builder.AppendLine("       has " + surfaces.Count + " surfaces.")
    For Each surface As EnergyAnalysisSurface In surfaces
        builder.AppendLine("            +++ Surface from " + surface.OriginatingElementDescription)
    Next
Next
UI.TaskDialog.Show("EAM", builder.ToString())

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisDetailModel Properties

The EnergyAnalysisDetailModel type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | BuildingTypeId | The building type element.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | ExportCategory | Export elements of this category in energy analysis.
Public property | ExportMullions | Indicates if to specify the setting for exporting mullions.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IncludeShadingSurfaces | Indicates if to set and get the setting for if shading surfaces should be included.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SimplifyCurtainSystems | Indicates if to specify the setting for simplified curtain systems.
Public property | Tier | Level of computation for energy analysis model.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

EnergyAnalysisDetailModel Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisDetailModel.BuildingTypeId Property

EnergyAnalysisDetailModelBuildingTypeId Property

The building type element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId BuildingTypeId { get; set; }
Public Property BuildingTypeId As ElementId
    Get
    Set
public:
property ElementId^ BuildingTypeId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member BuildingTypeId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

EnergyAnalysisDetailModel Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisDetailModel.ExportCategory Property

EnergyAnalysisDetailModelExportCategory Property

Export elements of this category in energy analysis.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId ExportCategory { get; set; }
Public Property ExportCategory As ElementId
    Get
    Set
public:
property ElementId^ ExportCategory {
    ElementId^ get ();
    void set (ElementId^ value);
}
member ExportCategory : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
Export will be based on the space type associated with the product creating it. Valid categories are Rooms or MEP Spaces.
See Also

Reference

EnergyAnalysisDetailModel Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisDetailModel.ExportMullions Property

EnergyAnalysisDetailModelExportMullions Property

Indicates if to specify the setting for exporting mullions.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ExportMullions { get; }
Public ReadOnly Property ExportMullions As Boolean
    Get
public:
property bool ExportMullions {
    bool get ();
}
member ExportMullions : bool with get

Property Value

Boolean
Remarks
When this setting is on, mullions will be exported as shading surfaces. A "simplified" analytical shading surface is produced from a mullion based on its centerline, thickness and offset.
See Also

Reference

EnergyAnalysisDetailModel Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisDetailModel.IncludeShadingSurfaces Property

EnergyAnalysisDetailModelIncludeShadingSurfaces Property

Indicates if to set and get the setting for if shading surfaces should be included.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IncludeShadingSurfaces { get; }
Public ReadOnly Property IncludeShadingSurfaces As Boolean
    Get
public:
property bool IncludeShadingSurfaces {
    bool get ();
}
member IncludeShadingSurfaces : bool with get

Property Value

Boolean
See Also

Reference

EnergyAnalysisDetailModel Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisDetailModel.SimplifyCurtainSystems Property

EnergyAnalysisDetailModelSimplifyCurtainSystems Property

Indicates if to specify the setting for simplified curtain systems.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SimplifyCurtainSystems { get; }
Public ReadOnly Property SimplifyCurtainSystems As Boolean
    Get
public:
property bool SimplifyCurtainSystems {
    bool get ();
}
member SimplifyCurtainSystems : bool with get

Property Value

Boolean
Remarks
Curtain Walls and Curtain Systems are normally exported as several openings, panel by panel, while for energy analysis all you need is one giant window. A curtain wall with 50 panels gets exported as 50 openings, while 1 opening with the total opening area would be more appropriate. When this setting is on, one "large" window/opening will be exported for a curtain wall/system
See Also

Reference

EnergyAnalysisDetailModel Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisDetailModel.Tier Property

EnergyAnalysisDetailModelTier Property

Level of computation for energy analysis model.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EnergyAnalysisDetailModelTier Tier { get; }
Public ReadOnly Property Tier As EnergyAnalysisDetailModelTier
    Get
public:
property EnergyAnalysisDetailModelTier Tier {
    EnergyAnalysisDetailModelTier get ();
}
member Tier : EnergyAnalysisDetailModelTier with get

Property Value

EnergyAnalysisDetailModelTier
See Also

Reference

EnergyAnalysisDetailModel Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisDetailModel Methods

The EnergyAnalysisDetailModel type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new energy analysis detailed model.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAnalyticalOpenings | The collection of analytical openings.
Public method | GetAnalyticalShadingSurfaces | The collection of analytical shading surfaces.
Public method | GetAnalyticalSpaces | The collection of analytical spaces.
Public method | GetAnalyticalSurfaces | The collection of analytical surfaces.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
 | GetMainEnergyAnalysisDetailModel | Gets the EnergyAnalysisDetailModel in given document.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | TransformModel | Transforms all surfaces in the model according to the document's active ground plane, shared coordinates and true north.
Top
See Also

Reference

EnergyAnalysisDetailModel Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisDetailModel.Create Method

EnergyAnalysisDetailModelCreate Method

Creates a new energy analysis detailed model.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static EnergyAnalysisDetailModel Create(
    Document document,
    EnergyAnalysisDetailModelOptions options
)
Public Shared Function Create (
    document As Document,
    options As EnergyAnalysisDetailModelOptions
) As EnergyAnalysisDetailModel
public:
static EnergyAnalysisDetailModel^ Create(
    Document^ document,
    EnergyAnalysisDetailModelOptions^ options
)
static member Create :
        document : Document *
        options : EnergyAnalysisDetailModelOptions -> EnergyAnalysisDetailModel

Parameters

document Document
The document that contains the physical model of the building.
options EnergyAnalysisDetailModelOptions
The options to control the calculation rules.

Return Value

EnergyAnalysisDetailModel
The created model instance.
Exceptions
Exception | Condition
ArgumentException | An EnergyAnalysisDetailModel cannot be created if EnergyModelType.BuildingElement is input and AnalysisMode.ConceptualMasses is set in EnergyDataSettings (these values are incompatible). -or- Throws if there are no valid spatial bounding elements, or no valid spatial elements in the document.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Failed to create the energy analysis detail model.
OperationCanceledException | Throws if user aborted the energy analysis detail model creation.
Remarks
The generated energy model is always returned in world coordinates. The method TransformModel() transforms all surfaces in the model according to ground plane, shared coordinates and true north. The EnergyModelType in argument EnergyAnalysisDetailModelOptions indicates whether the generated energy model is based on rooms/spaces or building elements. The default value is EnergyModelType.SpatialElement.
See Also

Reference

EnergyAnalysisDetailModel Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisDetailModel.GetAnalyticalOpenings Method

EnergyAnalysisDetailModelGetAnalyticalOpenings Method

The collection of analytical openings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<EnergyAnalysisOpening> GetAnalyticalOpenings()
Public Function GetAnalyticalOpenings As IList(Of EnergyAnalysisOpening)
public:
IList<EnergyAnalysisOpening^>^ GetAnalyticalOpenings()
member GetAnalyticalOpenings : unit -> IList<EnergyAnalysisOpening>

Return Value

IList EnergyAnalysisOpening
Returns the analytical openings after model calculation.
See Also

Reference

EnergyAnalysisDetailModel Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisDetailModel.GetAnalyticalShadingSurfaces Method

EnergyAnalysisDetailModelGetAnalyticalShadingSurfaces Method

The collection of analytical shading surfaces.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<EnergyAnalysisSurface> GetAnalyticalShadingSurfaces()
Public Function GetAnalyticalShadingSurfaces As IList(Of EnergyAnalysisSurface)
public:
IList<EnergyAnalysisSurface^>^ GetAnalyticalShadingSurfaces()
member GetAnalyticalShadingSurfaces : unit -> IList<EnergyAnalysisSurface>

Return Value

IList EnergyAnalysisSurface
Returns the analytical shading surfaces after model calculation.
See Also

Reference

EnergyAnalysisDetailModel Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisDetailModel.GetAnalyticalSpaces Method

EnergyAnalysisDetailModelGetAnalyticalSpaces Method

The collection of analytical spaces.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<EnergyAnalysisSpace> GetAnalyticalSpaces()
Public Function GetAnalyticalSpaces As IList(Of EnergyAnalysisSpace)
public:
IList<EnergyAnalysisSpace^>^ GetAnalyticalSpaces()
member GetAnalyticalSpaces : unit -> IList<EnergyAnalysisSpace>

Return Value

IList EnergyAnalysisSpace
Returns the analytical spaces after model calculation.
See Also

Reference

EnergyAnalysisDetailModel Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisDetailModel.GetAnalyticalSurfaces Method

EnergyAnalysisDetailModelGetAnalyticalSurfaces Method

The collection of analytical surfaces.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<EnergyAnalysisSurface> GetAnalyticalSurfaces()
Public Function GetAnalyticalSurfaces As IList(Of EnergyAnalysisSurface)
public:
IList<EnergyAnalysisSurface^>^ GetAnalyticalSurfaces()
member GetAnalyticalSurfaces : unit -> IList<EnergyAnalysisSurface>

Return Value

IList EnergyAnalysisSurface
Returns the analytical surfaces after model calculation.
See Also

Reference

EnergyAnalysisDetailModel Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisDetailModel.GetMainEnergyAnalysisDetailModel Method

EnergyAnalysisDetailModelGetMainEnergyAnalysisDetailModel Method

Gets the EnergyAnalysisDetailModel in given document.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static EnergyAnalysisDetailModel GetMainEnergyAnalysisDetailModel(
    Document document
)
Public Shared Function GetMainEnergyAnalysisDetailModel (
    document As Document
) As EnergyAnalysisDetailModel
public:
static EnergyAnalysisDetailModel^ GetMainEnergyAnalysisDetailModel(
    Document^ document
)
static member GetMainEnergyAnalysisDetailModel :
        document : Document -> EnergyAnalysisDetailModel

Parameters

document Document
The document that contains the physical model of the building.

Return Value

EnergyAnalysisDetailModel
Returns the EnergyAnalysisDetailModel contained in the document, if it exists. If it does not exist, this returns .
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

EnergyAnalysisDetailModel Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisDetailModel.TransformModel Method

EnergyAnalysisDetailModelTransformModel Method

Transforms all surfaces in the model according to the document's active ground plane, shared coordinates and true north.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void TransformModel()
Public Sub TransformModel
public:
void TransformModel()
member TransformModel : unit -> unit
Exceptions
Exception | Condition
InvalidOperationException | This operation failed.
See Also

Reference

EnergyAnalysisDetailModel Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisDetailModelOptions Class

Options that govern the calculations for the generation of the energy analysis detail model.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DB.AnalysisEnergyAnalysisDetailModelOptions

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class EnergyAnalysisDetailModelOptions : IDisposable
Public Class EnergyAnalysisDetailModelOptions
    Implements IDisposable
public ref class EnergyAnalysisDetailModelOptions : IDisposable
type EnergyAnalysisDetailModelOptions =
    class
        interface IDisposable
    end

The EnergyAnalysisDetailModelOptions type exposes the following members.

Constructors
 | Name | Description
Public method | EnergyAnalysisDetailModelOptions | Constructs default options for energy analysis detailed model creation.
Top
Properties
 | Name | Description
Public property | EnergyModelType | It indicates whether the energy model is based on rooms/spaces or building elements.
Public property | ExportMullions | Indicates if to specify the setting for exporting mullions.
Public property | IncludeShadingSurfaces | Indicates if to set and get the setting for if shading surfaces should be included.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SimplifyCurtainSystems | Indicates if to specify the setting for simplified curtain systems.
Public property | Tier | Level of computation for energy analysis model.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the EnergyAnalysisDetailModelOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisDetailModelOptions Constructor

Constructs default options for energy analysis detailed model creation.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EnergyAnalysisDetailModelOptions()
Public Sub New
public:
EnergyAnalysisDetailModelOptions()
new : unit -> EnergyAnalysisDetailModelOptions
See Also

Reference

EnergyAnalysisDetailModelOptions Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisDetailModelOptions Properties

The EnergyAnalysisDetailModelOptions type exposes the following members.

Properties
 | Name | Description
Public property | EnergyModelType | It indicates whether the energy model is based on rooms/spaces or building elements.
Public property | ExportMullions | Indicates if to specify the setting for exporting mullions.
Public property | IncludeShadingSurfaces | Indicates if to set and get the setting for if shading surfaces should be included.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SimplifyCurtainSystems | Indicates if to specify the setting for simplified curtain systems.
Public property | Tier | Level of computation for energy analysis model.
Top
See Also

Reference

EnergyAnalysisDetailModelOptions Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisDetailModelOptions.EnergyModelType Property

EnergyAnalysisDetailModelOptionsEnergyModelType Property

It indicates whether the energy model is based on rooms/spaces or building elements.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EnergyModelType EnergyModelType { get; set; }
Public Property EnergyModelType As EnergyModelType
    Get
    Set
public:
property EnergyModelType EnergyModelType {
    EnergyModelType get ();
    void set (EnergyModelType value);
}
member EnergyModelType : EnergyModelType with get, set

Property Value

EnergyModelType
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
The default value is EnergyModelType::SpatialElement.
See Also

Reference

EnergyAnalysisDetailModelOptions Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisDetailModelOptions.ExportMullions Property

EnergyAnalysisDetailModelOptionsExportMullions Property

Indicates if to specify the setting for exporting mullions.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ExportMullions { get; set; }
Public Property ExportMullions As Boolean
    Get
    Set
public:
property bool ExportMullions {
    bool get ();
    void set (bool value);
}
member ExportMullions : bool with get, set

Property Value

Boolean
Remarks
When this setting is on, mullions will be exported as shading surfaces. A "simplified" analytical shading surface is produced from a mullion based on its centerline, thickness and offset.
See Also

Reference

EnergyAnalysisDetailModelOptions Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisDetailModelOptions.IncludeShadingSurfaces Property

EnergyAnalysisDetailModelOptionsIncludeShadingSurfaces Property

Indicates if to set and get the setting for if shading surfaces should be included.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IncludeShadingSurfaces { get; set; }
Public Property IncludeShadingSurfaces As Boolean
    Get
    Set
public:
property bool IncludeShadingSurfaces {
    bool get ();
    void set (bool value);
}
member IncludeShadingSurfaces : bool with get, set

Property Value

Boolean
Remarks
The default is to include the shading surfaces.
See Also

Reference

EnergyAnalysisDetailModelOptions Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisDetailModelOptions.IsValidObject Property

EnergyAnalysisDetailModelOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

EnergyAnalysisDetailModelOptions Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisDetailModelOptions.SimplifyCurtainSystems Property

EnergyAnalysisDetailModelOptionsSimplifyCurtainSystems Property

Indicates if to specify the setting for simplified curtain systems.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SimplifyCurtainSystems { get; set; }
Public Property SimplifyCurtainSystems As Boolean
    Get
    Set
public:
property bool SimplifyCurtainSystems {
    bool get ();
    void set (bool value);
}
member SimplifyCurtainSystems : bool with get, set

Property Value

Boolean
Remarks
Curtain Walls and Curtain Systems are normally exported as several openings, panel by panel, while for energy analysis all you need is one giant window. A curtain wall with 50 panels gets exported as 50 openings, while 1 opening with the total opening area would be more appropriate. When this setting is on, one "large" window/opening will be exported for a curtain wall/system
See Also

Reference

EnergyAnalysisDetailModelOptions Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisDetailModelOptions.Tier Property

EnergyAnalysisDetailModelOptionsTier Property

Level of computation for energy analysis model.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EnergyAnalysisDetailModelTier Tier { get; set; }
Public Property Tier As EnergyAnalysisDetailModelTier
    Get
    Set
public:
property EnergyAnalysisDetailModelTier Tier {
    EnergyAnalysisDetailModelTier get ();
    void set (EnergyAnalysisDetailModelTier value);
}
member Tier : EnergyAnalysisDetailModelTier with get, set

Property Value

EnergyAnalysisDetailModelTier
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
The default value is EnergyAnalysisModelTier::Final.
See Also

Reference

EnergyAnalysisDetailModelOptions Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisDetailModelOptions Methods

The EnergyAnalysisDetailModelOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

EnergyAnalysisDetailModelOptions Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisDetailModelOptions.Dispose Method

EnergyAnalysisDetailModelOptionsDispose Method

Releases all resources used by the EnergyAnalysisDetailModelOptions

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

EnergyAnalysisDetailModelOptions Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisDetailModelTier Enumeration

Level of computation for energy analysis model.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum EnergyAnalysisDetailModelTier
Public Enumeration EnergyAnalysisDetailModelTier
public enum class EnergyAnalysisDetailModelTier
type EnergyAnalysisDetailModelTier
Members
Member name | Value | Description
NotComputed | 0 | Not computed.
FirstLevelBoundaries | 1 | Spaces and zones, e.g. minimal need for display. This refers to the analytical spaces. The analytical spaces are produced from Rooms if you are using RAC, and from MEP Spaces if you are using RME.
SecondLevelBoundaries | 2 | Analytical surfaces.
Final | 3 | Constructions, schedules, non-graphical data.
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisMaterial Class

A description of a material with thermal properties in a composite construction.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DB.AnalysisEnergyAnalysisMaterial

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class EnergyAnalysisMaterial : Element
Public Class EnergyAnalysisMaterial
    Inherits Element
public ref class EnergyAnalysisMaterial : public Element
type EnergyAnalysisMaterial =
    class
        inherit Element
    end

The EnergyAnalysisMaterial type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
Public property | Density | The density of the material, in kg/(ft^3).
Public property | Description | The description of the material.
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | MaterialName | The name of the material.
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SpecificHeatCapacity | The specific heat capacity of the material, in ft^2/(k*s^2).
Public property | ThermalConductivity | The thermal conductivity of the material, kg*ft/(k*s^3).
Public property | ThermalResistance | The thermal resistance (R-value) of the material, in m^2*K/W (eqivelent to K*s^3/kg).
Public property | Thickness | The thickness of the material, in ft.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisMaterial Properties

The EnergyAnalysisMaterial type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
Public property | Density | The density of the material, in kg/(ft^3).
Public property | Description | The description of the material.
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | MaterialName | The name of the material.
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SpecificHeatCapacity | The specific heat capacity of the material, in ft^2/(k*s^2).
Public property | ThermalConductivity | The thermal conductivity of the material, kg*ft/(k*s^3).
Public property | ThermalResistance | The thermal resistance (R-value) of the material, in m^2*K/W (eqivelent to K*s^3/kg).
Public property | Thickness | The thickness of the material, in ft.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

EnergyAnalysisMaterial Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisMaterial.Density Property

EnergyAnalysisMaterialDensity Property

The density of the material, in kg/(ft^3).

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Density { get; }
Public ReadOnly Property Density As Double
    Get
public:
property double Density {
    double get ();
}
member Density : float with get

Property Value

Double
See Also

Reference

EnergyAnalysisMaterial Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisMaterial.Description Property

EnergyAnalysisMaterialDescription Property

The description of the material.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get
public:
property String^ Description {
    String^ get ();
}
member Description : string with get

Property Value

String
See Also

Reference

EnergyAnalysisMaterial Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisMaterial.MaterialName Property

EnergyAnalysisMaterialMaterialName Property

The name of the material.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string MaterialName { get; }
Public ReadOnly Property MaterialName As String
    Get
public:
property String^ MaterialName {
    String^ get ();
}
member MaterialName : string with get

Property Value

String
See Also

Reference

EnergyAnalysisMaterial Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisMaterial.SpecificHeatCapacity Property

EnergyAnalysisMaterialSpecificHeatCapacity Property

The specific heat capacity of the material, in ft^2/(k*s^2).

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double SpecificHeatCapacity { get; }
Public ReadOnly Property SpecificHeatCapacity As Double
    Get
public:
property double SpecificHeatCapacity {
    double get ();
}
member SpecificHeatCapacity : float with get

Property Value

Double
See Also

Reference

EnergyAnalysisMaterial Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisMaterial.ThermalConductivity Property

EnergyAnalysisMaterialThermalConductivity Property

The thermal conductivity of the material, kg*ft/(k*s^3).

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double ThermalConductivity { get; }
Public ReadOnly Property ThermalConductivity As Double
    Get
public:
property double ThermalConductivity {
    double get ();
}
member ThermalConductivity : float with get

Property Value

Double
See Also

Reference

EnergyAnalysisMaterial Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisMaterial.ThermalResistance Property

EnergyAnalysisMaterialThermalResistance Property

The thermal resistance (R-value) of the material, in m^2*K/W (eqivelent to K*s^3/kg).

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double ThermalResistance { get; }
Public ReadOnly Property ThermalResistance As Double
    Get
public:
property double ThermalResistance {
    double get ();
}
member ThermalResistance : float with get

Property Value

Double
See Also

Reference

EnergyAnalysisMaterial Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisMaterial.Thickness Property

EnergyAnalysisMaterialThickness Property

The thickness of the material, in ft.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Thickness { get; }
Public ReadOnly Property Thickness As Double
    Get
public:
property double Thickness {
    double get ();
}
member Thickness : float with get

Property Value

Double
See Also

Reference

EnergyAnalysisMaterial Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisMaterial Methods

The EnergyAnalysisMaterial type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

EnergyAnalysisMaterial Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisOpening Class

Analytical opening.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DB.AnalysisEnergyAnalysisOpening

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class EnergyAnalysisOpening : Element
Public Class EnergyAnalysisOpening
    Inherits Element
public ref class EnergyAnalysisOpening : public Element
type EnergyAnalysisOpening =
    class
        inherit Element
    end

The EnergyAnalysisOpening type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CADLinkUniqueId | The unique id of the originating CAD object's link (linked document) associated with this opening.
Public property | CADObjectUniqueId | The unique id of the originating CAD object (model element) associated with this opening.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | Corner | The lower-left coordinate for the analytical rectangular geometry viewed from outside.
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | Height | The height of the analytical rectangular geometry.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OpeningId | The unique identifier for the opening.
Public property | OpeningName | The unique name identifier for the opening.
Public property | OpeningType | The analytical opening type.
Public property | OriginatingElementDescription | The description for the originating Revit element.
Public property | OriginatingElementId | The element id for the originating Revit element.
Public property | OriginatingElementName | The name for the originating Revit element.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Type | The gbXML opening type attribute.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | Width | The width of the analytical rectangular geometry.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAnalyticalSurface | Gets the associative analytical parent surface element.
Public method | GetConstruction | Gets the analytic construction this surface is associated with. Null when this surface is a window.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPolyloop | Gets the planar polygon describing the opening geometry.
Public method | GetPolyloops | Gets the collection of planar polygons describing the opening geometry.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetWindowType | Gets the analytic window type this surface is associated with. Null when this surface is not a window.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisOpening Properties

The EnergyAnalysisOpening type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CADLinkUniqueId | The unique id of the originating CAD object's link (linked document) associated with this opening.
Public property | CADObjectUniqueId | The unique id of the originating CAD object (model element) associated with this opening.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | Corner | The lower-left coordinate for the analytical rectangular geometry viewed from outside.
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | Height | The height of the analytical rectangular geometry.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OpeningId | The unique identifier for the opening.
Public property | OpeningName | The unique name identifier for the opening.
Public property | OpeningType | The analytical opening type.
Public property | OriginatingElementDescription | The description for the originating Revit element.
Public property | OriginatingElementId | The element id for the originating Revit element.
Public property | OriginatingElementName | The name for the originating Revit element.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | Type | The gbXML opening type attribute.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | Width | The width of the analytical rectangular geometry.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

EnergyAnalysisOpening Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisOpening.CADLinkUniqueId Property

EnergyAnalysisOpeningCADLinkUniqueId Property

The unique id of the originating CAD object's link (linked document) associated with this opening.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string CADLinkUniqueId { get; }
Public ReadOnly Property CADLinkUniqueId As String
    Get
public:
property String^ CADLinkUniqueId {
    String^ get ();
}
member CADLinkUniqueId : string with get

Property Value

String
Remarks
This id can be passed to obtain the element from Document.Element[string] property, but any link obtained through this method may no longer be a valid or up-to-date link. The originating CAD link is only accurate and up-to-date at the time of creation of the energy model. An empty string is returned if the originating CAD object is not hosted in a linked document.
See Also

Reference

EnergyAnalysisOpening Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisOpening.CADObjectUniqueId Property

EnergyAnalysisOpeningCADObjectUniqueId Property

The unique id of the originating CAD object (model element) associated with this opening.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string CADObjectUniqueId { get; }
Public ReadOnly Property CADObjectUniqueId As String
    Get
public:
property String^ CADObjectUniqueId {
    String^ get ();
}
member CADObjectUniqueId : string with get

Property Value

String
Remarks
This id can be passed to obtain the element from Document.Element[string] property, but any element obtained through this method may no longer be a valid or up-to-date model element. The originating CAD object is only accurate and up-to-date at the time of creation of the energy model. If the originating element belongs to a linked document, the unique id of the link obtained from CADLinkUniqueId should be used to access it.
See Also

Reference

EnergyAnalysisOpening Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisOpening.Corner Property

EnergyAnalysisOpeningCorner Property

The lower-left coordinate for the analytical rectangular geometry viewed from outside.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Corner { get; }
Public ReadOnly Property Corner As XYZ
    Get
public:
property XYZ^ Corner {
    XYZ^ get ();
}
member Corner : XYZ with get

Property Value

XYZ
Remarks
A planar polygon describing the surface geometry as described in gbXML. The geometry is currently measured per analytical(center-line).
See Also

Reference

EnergyAnalysisOpening Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisOpening.Height Property

EnergyAnalysisOpeningHeight Property

The height of the analytical rectangular geometry.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Height { get; }
Public ReadOnly Property Height As Double
    Get
public:
property double Height {
    double get ();
}
member Height : float with get

Property Value

Double
See Also

Reference

EnergyAnalysisOpening Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisOpening.OpeningId Property

EnergyAnalysisOpeningOpeningId Property

The unique identifier for the opening.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string OpeningId { get; }
Public ReadOnly Property OpeningId As String
    Get
public:
property String^ OpeningId {
    String^ get ();
}
member OpeningId : string with get

Property Value

String
Remarks
This identification attribute is composed of the id for the parent surface, the prefix "op" and a sequential number, all separated by "-". A sample value would be "su-1-op-1".
See Also

Reference

EnergyAnalysisOpening Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisOpening.OpeningName Property

EnergyAnalysisOpeningOpeningName Property

The unique name identifier for the opening.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string OpeningName { get; }
Public ReadOnly Property OpeningName As String
    Get
public:
property String^ OpeningName {
    String^ get ();
}
member OpeningName : string with get

Property Value

String
Remarks

Surface and Opening elements get an Name element assigned according to the below described schema:

(Orientation)(Space#)[(Other space#)](Exposure)(Type)-(sequence number)[Opening Type+#]

Sample: N-101-102-E-W-O-77

  • N = Orientation [N/NE/E/SE/S/SW/W/NW/N/T/B/X] (every surface within the sector of 22.5 degrees from the north vector gets the letter N etc) (horizontal surfaces facing upwards get the letter T for top, downwards B for bottom) (shading surfaces get the letter X for differentiation).
  • 101 = Space number.
  • 102 = Other space number.
  • E = Exposure - exterior/interior/underground [E/I/U].
  • W = Type [W/C/R/F] (Wall, Roof, Ceiling, Floor, Shade) (every surface type has it's letter W-Wall R-Roof C-Ceiling F-Floor S-Shade).
  • O = Opening Type [W/D/O] (Window, Door, Opening) (every opening type has it's letter W-Window D-Door O-Opening).
  • 77 = sequence number.

Sample surface names:

  • N-101-E-W-84 North facing Exterior Wall #84 in space 101.
  • N-101-E-W-84-D-1 Door #1 in North facing Exterior Wall #84 in space 101.
  • E-101-102-I-W-92 Vertical Interior Wall #92 between space 101 and 102.
  • T-101-E-R-141 Top facing Exterior Roof #141 in space 101.
  • B-101-201-I-F-88 Bottom facing Interior Floor #88 between space 101 and 201.
  • X-73 Shade #73.
See Also

Reference

EnergyAnalysisOpening Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisOpening.OpeningType Property

EnergyAnalysisOpeningOpeningType Property

The analytical opening type.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EnergyAnalysisOpeningType OpeningType { get; }
Public ReadOnly Property OpeningType As EnergyAnalysisOpeningType
    Get
public:
property EnergyAnalysisOpeningType OpeningType {
    EnergyAnalysisOpeningType get ();
}
member OpeningType : EnergyAnalysisOpeningType with get

Property Value

EnergyAnalysisOpeningType
See Also

Reference

EnergyAnalysisOpening Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisOpening.OriginatingElementDescription Property

EnergyAnalysisOpeningOriginatingElementDescription Property

The description for the originating Revit element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string OriginatingElementDescription { get; }
Public ReadOnly Property OriginatingElementDescription As String
    Get
public:
property String^ OriginatingElementDescription {
    String^ get ();
}
member OriginatingElementDescription : string with get

Property Value

String
Remarks
Surface and Opening elements get an CADObjectId element assigned according to the below described schema, based on associative room bounding element:

(Family Name): (Family Type)[Element Id]

Sample: System Panel: System Panel [50566]
See Also

Reference

EnergyAnalysisOpening Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisOpening.OriginatingElementId Property

EnergyAnalysisOpeningOriginatingElementId Property

The element id for the originating Revit element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LinkElementId OriginatingElementId { get; }
Public ReadOnly Property OriginatingElementId As LinkElementId
    Get
public:
property LinkElementId^ OriginatingElementId {
    LinkElementId^ get ();
}
member OriginatingElementId : LinkElementId with get

Property Value

LinkElementId
See Also

Reference

EnergyAnalysisOpening Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisOpening.OriginatingElementName Property

EnergyAnalysisOpeningOriginatingElementName Property

The name for the originating Revit element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string OriginatingElementName { get; }
Public ReadOnly Property OriginatingElementName As String
    Get
public:
property String^ OriginatingElementName {
    String^ get ();
}
member OriginatingElementName : string with get

Property Value

String
Remarks
Opening elements get an originating element assigned according to the below described schema, based on associative room bounding element:

(Family Name) : (Family Type)

Sample: Basic Wall : Cast Concrete Wall 12"

See Also

Reference

EnergyAnalysisOpening Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisOpening.Type Property

EnergyAnalysisOpeningType Property

The gbXML opening type attribute.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public gbXMLOpeningType Type { get; }
Public ReadOnly Property Type As gbXMLOpeningType
    Get
public:
property gbXMLOpeningType Type {
    gbXMLOpeningType get ();
}
member Type : gbXMLOpeningType with get

Property Value

gbXMLOpeningType
Remarks
The type of the opening is based on the family category for the opening and in what element it is contained in:
  • If it is a Window it will have a type of OperableWindow.
  • If it is a Door it will have a type of NonSlidingDoor.
  • If the opening is contained in a Roof it will have a type of FixedSkylight.
  • If it is a Curtain Wall Panel, the opening will default to a type of FixedWindow. If the material specified for the family, and the material transparency is less than 3%, the opening will be ignored as a solid panel.
An opening of the category Openings will have the type of Air.
See Also

Reference

EnergyAnalysisOpening Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisOpening.Width Property

EnergyAnalysisOpeningWidth Property

The width of the analytical rectangular geometry.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Width { get; }
Public ReadOnly Property Width As Double
    Get
public:
property double Width {
    double get ();
}
member Width : float with get

Property Value

Double
Remarks
The product of width and height should be equal to the area of the polyloop for the opening. The width is adjusted to accomplish this.
See Also

Reference

EnergyAnalysisOpening Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisOpening Methods

The EnergyAnalysisOpening type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAnalyticalSurface | Gets the associative analytical parent surface element.
Public method | GetConstruction | Gets the analytic construction this surface is associated with. Null when this surface is a window.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPolyloop | Gets the planar polygon describing the opening geometry.
Public method | GetPolyloops | Gets the collection of planar polygons describing the opening geometry.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetWindowType | Gets the analytic window type this surface is associated with. Null when this surface is not a window.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

EnergyAnalysisOpening Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisOpening.GetAnalyticalSurface Method

EnergyAnalysisOpeningGetAnalyticalSurface Method

Gets the associative analytical parent surface element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EnergyAnalysisSurface GetAnalyticalSurface()
Public Function GetAnalyticalSurface As EnergyAnalysisSurface
public:
EnergyAnalysisSurface^ GetAnalyticalSurface()
member GetAnalyticalSurface : unit -> EnergyAnalysisSurface

Return Value

EnergyAnalysisSurface
The associative analytical parent surface element.
See Also

Reference

EnergyAnalysisOpening Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisOpening.GetConstruction Method

EnergyAnalysisOpeningGetConstruction Method

Gets the analytic construction this surface is associated with. Null when this surface is a window.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EnergyAnalysisConstruction GetConstruction()
Public Function GetConstruction As EnergyAnalysisConstruction
public:
EnergyAnalysisConstruction^ GetConstruction()
member GetConstruction : unit -> EnergyAnalysisConstruction

Return Value

EnergyAnalysisConstruction
The analytic construction.
See Also

Reference

EnergyAnalysisOpening Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisOpening.GetPolyloop Method

EnergyAnalysisOpeningGetPolyloop Method

Gets the planar polygon describing the opening geometry.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Polyloop GetPolyloop()
Public Function GetPolyloop As Polyloop
public:
Polyloop^ GetPolyloop()
member GetPolyloop : unit -> Polyloop

Return Value

Polyloop
Remarks
A planar polygon describing the surface geometry as described in gbXML. The geometry is currently measured per analytical(center-line).
See Also

Reference

EnergyAnalysisOpening Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisOpening.GetPolyloops Method

EnergyAnalysisOpeningGetPolyloops Method

Gets the collection of planar polygons describing the opening geometry.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<Polyloop> GetPolyloops()
Public Function GetPolyloops As IList(Of Polyloop)
public:
IList<Polyloop^>^ GetPolyloops()
member GetPolyloops : unit -> IList<Polyloop>

Return Value

IList Polyloop
The collection of polygons describing the opening geometry.
Remarks
A collection of polyloops (planar polygons) describing the opening geometry as described in gbXML. The geometry is currently measured per analytical(center-line).
See Also

Reference

EnergyAnalysisOpening Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisOpening.GetWindowType Method

EnergyAnalysisOpeningGetWindowType Method

Gets the analytic window type this surface is associated with. Null when this surface is not a window.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EnergyAnalysisWindowType GetWindowType()
Public Function GetWindowType As EnergyAnalysisWindowType
public:
EnergyAnalysisWindowType^ GetWindowType()
member GetWindowType : unit -> EnergyAnalysisWindowType

Return Value

EnergyAnalysisWindowType
The analytic window type.
See Also

Reference

EnergyAnalysisOpening Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisOpeningType Enumeration

Energy analysis opening type.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum EnergyAnalysisOpeningType
Public Enumeration EnergyAnalysisOpeningType
public enum class EnergyAnalysisOpeningType
type EnergyAnalysisOpeningType
Members
Member name | Value | Description
Door | 0 | Door.
Window | 1 | Window.
Skylight | 2 | Skylight.
Air | 3 | Air.
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisSpace Class

Analytical space.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DB.AnalysisEnergyAnalysisSpace

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class EnergyAnalysisSpace : Element
Public Class EnergyAnalysisSpace
    Inherits Element
public ref class EnergyAnalysisSpace : public Element
type EnergyAnalysisSpace =
    class
        inherit Element
    end

The EnergyAnalysisSpace type exposes the following members.

Properties
 | Name | Description
Public property | Area | The area for this space.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CADObjectUniqueId | The unique id of the originating CAD object (model element) associated with this space.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | ComposedName | The composed name for this space.
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
Public property | Description | The description.
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | Number | The number to identify the space.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SpaceName | The name.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | Volume | The volume for this space.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAnalyticalSurfaces | Provides a way to access the collection of analytical surfaces for a space. Geometry data defining an analytical space volume. Through an analytical surface you can connect a source element with each polygon in a space. The analytical surfaces defines an enclosed volume bounded by the center plane of walls and the top plane of roofs and floors.
Public method | GetBoundary | Gets the collection of polygons that form the 2D boundary. This method returns a collection of polyloops (planar polygons) that defines an enclosed area measured by interior bounding surfaces.
Public method | GetClosedShell | Gets the collection of polygons that form a closed shell. This method returns a collection of polyloops (planar polygons) that defines an enclosed volume measured by interior bounding surfaces.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisSpace Properties

The EnergyAnalysisSpace type exposes the following members.

Properties
 | Name | Description
Public property | Area | The area for this space.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CADObjectUniqueId | The unique id of the originating CAD object (model element) associated with this space.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | ComposedName | The composed name for this space.
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
Public property | Description | The description.
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | Number | The number to identify the space.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SpaceName | The name.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | Volume | The volume for this space.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

EnergyAnalysisSpace Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisSpace.Area Property

EnergyAnalysisSpaceArea Property

The area for this space.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Area { get; }
Public ReadOnly Property Area As Double
    Get
public:
property double Area {
    double get ();
}
member Area : float with get

Property Value

Double
Remarks
If the space is created with the mode 'Use Rooms or Spaces', this value is the enclosed area measured by interior bounding surfaces. Otherwise, this value is measured by the center plane of walls and the top plane of roofs and floors.
See Also

Reference

EnergyAnalysisSpace Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisSpace.CADObjectUniqueId Property

EnergyAnalysisSpaceCADObjectUniqueId Property

The unique id of the originating CAD object (model element) associated with this space.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string CADObjectUniqueId { get; }
Public ReadOnly Property CADObjectUniqueId As String
    Get
public:
property String^ CADObjectUniqueId {
    String^ get ();
}
member CADObjectUniqueId : string with get

Property Value

String
Remarks
This id can be passed to obtain the element from Document.Element[string] property, but any element obtained through this method may no longer point to a valid or up-to-date model element. The originating CAD object is only accurate and up-to-date at the time of creation of the energy model.
See Also

Reference

EnergyAnalysisSpace Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisSpace.ComposedName Property

EnergyAnalysisSpaceComposedName Property

The composed name for this space.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ComposedName { get; }
Public ReadOnly Property ComposedName As String
    Get
public:
property String^ ComposedName {
    String^ get ();
}
member ComposedName : string with get

Property Value

String
Remarks
This value is composed of the number and name attributes, separated by a space.
See Also

Reference

EnergyAnalysisSpace Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisSpace.Description Property

EnergyAnalysisSpaceDescription Property

The description.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get
public:
property String^ Description {
    String^ get ();
}
member Description : string with get

Property Value

String
See Also

Reference

EnergyAnalysisSpace Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisSpace.Number Property

EnergyAnalysisSpaceNumber Property

The number to identify the space.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Number { get; }
Public ReadOnly Property Number As String
    Get
public:
property String^ Number {
    String^ get ();
}
member Number : string with get

Property Value

String
See Also

Reference

EnergyAnalysisSpace Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisSpace.SpaceName Property

EnergyAnalysisSpaceSpaceName Property

The name.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SpaceName { get; }
Public ReadOnly Property SpaceName As String
    Get
public:
property String^ SpaceName {
    String^ get ();
}
member SpaceName : string with get

Property Value

String
See Also

Reference

EnergyAnalysisSpace Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisSpace.Volume Property

EnergyAnalysisSpaceVolume Property

The volume for this space.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Volume { get; }
Public ReadOnly Property Volume As Double
    Get
public:
property double Volume {
    double get ();
}
member Volume : float with get

Property Value

Double
Remarks
If the space is created with the mode 'Use Rooms or Spaces', this value is the enclosed volume measured by interior bounding surfaces. Otherwise, this value is the average of the analytical volume and the voxel volume. Note that the analytical volume is measured by the center plane of walls and the top plane of roofs and floors, and the voxel volume is measured by the number of enclosed unit cubes.
See Also

Reference

EnergyAnalysisSpace Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisSpace Methods

The EnergyAnalysisSpace type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAnalyticalSurfaces | Provides a way to access the collection of analytical surfaces for a space. Geometry data defining an analytical space volume. Through an analytical surface you can connect a source element with each polygon in a space. The analytical surfaces defines an enclosed volume bounded by the center plane of walls and the top plane of roofs and floors.
Public method | GetBoundary | Gets the collection of polygons that form the 2D boundary. This method returns a collection of polyloops (planar polygons) that defines an enclosed area measured by interior bounding surfaces.
Public method | GetClosedShell | Gets the collection of polygons that form a closed shell. This method returns a collection of polyloops (planar polygons) that defines an enclosed volume measured by interior bounding surfaces.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

EnergyAnalysisSpace Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisSpace.GetAnalyticalSurfaces Method

EnergyAnalysisSpaceGetAnalyticalSurfaces Method

Provides a way to access the collection of analytical surfaces for a space. Geometry data defining an analytical space volume. Through an analytical surface you can connect a source element with each polygon in a space. The analytical surfaces defines an enclosed volume bounded by the center plane of walls and the top plane of roofs and floors.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<EnergyAnalysisSurface> GetAnalyticalSurfaces()
Public Function GetAnalyticalSurfaces As IList(Of EnergyAnalysisSurface)
public:
IList<EnergyAnalysisSurface^>^ GetAnalyticalSurfaces()
member GetAnalyticalSurfaces : unit -> IList<EnergyAnalysisSurface>

Return Value

IList EnergyAnalysisSurface
the collection of analytical surfaces for a space.
See Also

Reference

EnergyAnalysisSpace Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisSpace.GetBoundary Method

EnergyAnalysisSpaceGetBoundary Method

Gets the collection of polygons that form the 2D boundary. This method returns a collection of polyloops (planar polygons) that defines an enclosed area measured by interior bounding surfaces.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<Polyloop> GetBoundary()
Public Function GetBoundary As IList(Of Polyloop)
public:
IList<Polyloop^>^ GetBoundary()
member GetBoundary : unit -> IList<Polyloop>

Return Value

IList Polyloop
The collection of polygons that form the 2D boundary.
See Also

Reference

EnergyAnalysisSpace Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisSpace.GetClosedShell Method

EnergyAnalysisSpaceGetClosedShell Method

Gets the collection of polygons that form a closed shell. This method returns a collection of polyloops (planar polygons) that defines an enclosed volume measured by interior bounding surfaces.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<Polyloop> GetClosedShell()
Public Function GetClosedShell As IList(Of Polyloop)
public:
IList<Polyloop^>^ GetClosedShell()
member GetClosedShell : unit -> IList<Polyloop>

Return Value

IList Polyloop
the collection of polygons that form a closed shell.
See Also

Reference

EnergyAnalysisSpace Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisSurface Class

Analytical surface. The collection of analytic openings belonging to this analytical parent surface
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DB.AnalysisEnergyAnalysisSurface

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class EnergyAnalysisSurface : Element
Public Class EnergyAnalysisSurface
    Inherits Element
public ref class EnergyAnalysisSurface : public Element
type EnergyAnalysisSurface =
    class
        inherit Element
    end

The EnergyAnalysisSurface type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | Azimuth | The azimuth angle for this surface.
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CADLinkUniqueId | The unique id of the originating CAD object's link (linked document) associated with this surface.
Public property | CADObjectUniqueId | The unique id of the originating CAD object (model element) associated with this surface.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | Corner | The lower-left coordinate for the analytical rectangular geometry viewed from outside.
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | Height | The height of the analytical rectangular geometry.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | Normal | The outward normal for this surface.
Public property | OriginatingElementDescription | The description for the originating Revit element.
Public property | OriginatingElementId | The element id for the originating Revit element.
Public property | OriginatingElementName | The name for the originating Revit element.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SurfaceId | The unique identifier for the surface.
Public property | SurfaceName | The unique name identifier for this surface.
Public property | SurfaceType | The analytical surface type.
Public property | Tilt | The tilt angle for this surface.
Public property | Type | The gbXML surface type attribute.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | Width | The width of the analytical rectangular geometry.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAdjacentAnalyticalSpace | Gets the secondary adjacent analytical space this surface is associated with.
Public method | GetAnalyticalOpenings | Returns the analytical openings of the analytical surface.
Public method | GetAnalyticalSpace | Gets the primary analytical space this surface is associated with.
Public method | GetConstruction | Gets the analytic construction this surface is associated with.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPolyloop | Gets the planar polygon describing the surface geometry.
Public method | GetPolyloops | Gets the collection of planar polygons describing the surface geometry.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisSurface Properties

The EnergyAnalysisSurface type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | Azimuth | The azimuth angle for this surface.
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CADLinkUniqueId | The unique id of the originating CAD object's link (linked document) associated with this surface.
Public property | CADObjectUniqueId | The unique id of the originating CAD object (model element) associated with this surface.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | Corner | The lower-left coordinate for the analytical rectangular geometry viewed from outside.
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | Height | The height of the analytical rectangular geometry.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | Normal | The outward normal for this surface.
Public property | OriginatingElementDescription | The description for the originating Revit element.
Public property | OriginatingElementId | The element id for the originating Revit element.
Public property | OriginatingElementName | The name for the originating Revit element.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SurfaceId | The unique identifier for the surface.
Public property | SurfaceName | The unique name identifier for this surface.
Public property | SurfaceType | The analytical surface type.
Public property | Tilt | The tilt angle for this surface.
Public property | Type | The gbXML surface type attribute.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | Width | The width of the analytical rectangular geometry.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisSurface.Azimuth Property

EnergyAnalysisSurfaceAzimuth Property

The azimuth angle for this surface.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Azimuth { get; }
Public ReadOnly Property Azimuth As Double
    Get
public:
property double Azimuth {
    double get ();
}
member Azimuth : float with get

Property Value

Double
Remarks
The azimuth is computed as the angle of rotation between the outward normal of the surface and the Y-axis (clockwise is positive).
See Also

Reference

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisSurface.CADLinkUniqueId Property

EnergyAnalysisSurfaceCADLinkUniqueId Property

The unique id of the originating CAD object's link (linked document) associated with this surface.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string CADLinkUniqueId { get; }
Public ReadOnly Property CADLinkUniqueId As String
    Get
public:
property String^ CADLinkUniqueId {
    String^ get ();
}
member CADLinkUniqueId : string with get

Property Value

String
Remarks
This id can be passed to obtain the element from Document.Element[string] property, but any link obtained through this method may no longer be a valid or up-to-date link. The originating CAD link is only accurate and up-to-date at the time of creation of the energy model. An empty string is returned if the originating CAD object is not hosted in a linked document.
See Also

Reference

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisSurface.CADObjectUniqueId Property

EnergyAnalysisSurfaceCADObjectUniqueId Property

The unique id of the originating CAD object (model element) associated with this surface.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string CADObjectUniqueId { get; }
Public ReadOnly Property CADObjectUniqueId As String
    Get
public:
property String^ CADObjectUniqueId {
    String^ get ();
}
member CADObjectUniqueId : string with get

Property Value

String
Remarks
This id can be passed to obtain the element from Document.Element[string] property, but any element obtained through this method may no longer be a valid or up-to-date model element. The originating CAD object is only accurate and up-to-date at the time of creation of the energy model. If the originating element belongs to a linked document, the unique id of the link obtained from CADLinkUniqueId should be used to access it.
See Also

Reference

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisSurface.Corner Property

EnergyAnalysisSurfaceCorner Property

The lower-left coordinate for the analytical rectangular geometry viewed from outside.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Corner { get; }
Public ReadOnly Property Corner As XYZ
    Get
public:
property XYZ^ Corner {
    XYZ^ get ();
}
member Corner : XYZ with get

Property Value

XYZ
Remarks
The analytical rectangular geometry is typically used in simulation engines.
See Also

Reference

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisSurface.Height Property

EnergyAnalysisSurfaceHeight Property

The height of the analytical rectangular geometry.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Height { get; }
Public ReadOnly Property Height As Double
    Get
public:
property double Height {
    double get ();
}
member Height : float with get

Property Value

Double
See Also

Reference

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisSurface.Normal Property

EnergyAnalysisSurfaceNormal Property

The outward normal for this surface.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Normal { get; }
Public ReadOnly Property Normal As XYZ
    Get
public:
property XYZ^ Normal {
    XYZ^ get ();
}
member Normal : XYZ with get

Property Value

XYZ
See Also

Reference

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisSurface.OriginatingElementDescription Property

EnergyAnalysisSurfaceOriginatingElementDescription Property

The description for the originating Revit element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string OriginatingElementDescription { get; }
Public ReadOnly Property OriginatingElementDescription As String
    Get
public:
property String^ OriginatingElementDescription {
    String^ get ();
}
member OriginatingElementDescription : string with get

Property Value

String
Remarks
Surface and Opening elements get an originating element assigned according to the below described schema, based on associative room bounding element:

(Family Name): (Family Type)[Element Id]

Sample: Basic Wall: Cast Concrete Wall 12" [49749]

See Also

Reference

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisSurface.OriginatingElementId Property

EnergyAnalysisSurfaceOriginatingElementId Property

The element id for the originating Revit element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LinkElementId OriginatingElementId { get; }
Public ReadOnly Property OriginatingElementId As LinkElementId
    Get
public:
property LinkElementId^ OriginatingElementId {
    LinkElementId^ get ();
}
member OriginatingElementId : LinkElementId with get

Property Value

LinkElementId
See Also

Reference

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisSurface.OriginatingElementName Property

EnergyAnalysisSurfaceOriginatingElementName Property

The name for the originating Revit element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string OriginatingElementName { get; }
Public ReadOnly Property OriginatingElementName As String
    Get
public:
property String^ OriginatingElementName {
    String^ get ();
}
member OriginatingElementName : string with get

Property Value

String
Remarks
Surface elements get an originating element assigned according to the below described schema, based on associative room bounding element:

(Family Name) : (Family Type)

Sample: Basic Wall : Cast Concrete Wall 12"

See Also

Reference

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisSurface.SurfaceId Property

EnergyAnalysisSurfaceSurfaceId Property

The unique identifier for the surface.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SurfaceId { get; }
Public ReadOnly Property SurfaceId As String
    Get
public:
property String^ SurfaceId {
    String^ get ();
}
member SurfaceId : string with get

Property Value

String
Remarks
This identification attribute is composed of the prefix "su" and a sequential number, separated by "-". A sample value would be "su-1".
See Also

Reference

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisSurface.SurfaceName Property

EnergyAnalysisSurfaceSurfaceName Property

The unique name identifier for this surface.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SurfaceName { get; }
Public ReadOnly Property SurfaceName As String
    Get
public:
property String^ SurfaceName {
    String^ get ();
}
member SurfaceName : string with get

Property Value

String
Remarks

Surface and Opening elements get an Name element assigned according to the below described schema:

(Orientation)(Space#)[(Other space#)](Exposure)(Type)-(sequence number)[Opening Type+#]

Sample: N-101-102-E-W-O-77

  • N = Orientation [N/NE/E/SE/S/SW/W/NW/N/T/B/X] (every surface within the sector of 22.5 degrees from the north vector gets the letter N etc) (horizontal surfaces facing upwards get the letter T for top, downwards B for bottom) (shading surfaces get the letter X for differentiation).
  • 101 = Space number.
  • 102 = Other space number.
  • E = Exposure - exterior/interior/underground [E/I/U].
  • W = Type [W/C/R/F] (Wall, Roof, Ceiling, Floor, Shade) (every surface type has it's letter W-Wall R-Roof C-Ceiling F-Floor S-Shade).
  • O = Opening Type [W/D/O] (Window, Door, Opening) (every opening type has it's letter W-Window D-Door O-Opening).
  • 77 = sequence number.

Sample surface names:

  • N-101-E-W-84 North facing Exterior Wall #84 in space 101.
  • N-101-E-W-84-D-1 Door #1 in North facing Exterior Wall #84 in space 101.
  • E-101-102-I-W-92 Vertical Interior Wall #92 between space 101 and 102.
  • T-101-E-R-141 Top facing Exterior Roof #141 in space 101.
  • B-101-201-I-F-88 Bottom facing Interior Floor #88 between space 101 and 201.
  • X-73 Shade #73.
See Also

Reference

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisSurface.SurfaceType Property

EnergyAnalysisSurfaceSurfaceType Property

The analytical surface type.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EnergyAnalysisSurfaceType SurfaceType { get; }
Public ReadOnly Property SurfaceType As EnergyAnalysisSurfaceType
    Get
public:
property EnergyAnalysisSurfaceType SurfaceType {
    EnergyAnalysisSurfaceType get ();
}
member SurfaceType : EnergyAnalysisSurfaceType with get

Property Value

EnergyAnalysisSurfaceType
See Also

Reference

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisSurface.Tilt Property

EnergyAnalysisSurfaceTilt Property

The tilt angle for this surface.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Tilt { get; }
Public ReadOnly Property Tilt As Double
    Get
public:
property double Tilt {
    double get ();
}
member Tilt : float with get

Property Value

Double
Remarks
The tilt is computed as the angle of rotation between the outward normal of the surface and the Z-axis.
See Also

Reference

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisSurface.Type Property

EnergyAnalysisSurfaceType Property

The gbXML surface type attribute.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public gbXMLSurfaceType Type { get; }
Public ReadOnly Property Type As gbXMLSurfaceType
    Get
public:
property gbXMLSurfaceType Type {
    gbXMLSurfaceType get ();
}
member Type : gbXMLSurfaceType with get

Property Value

gbXMLSurfaceType
Remarks
The type of surface is figured out depending on the source element and the number of space adjacencies.
  • If there is no associate source element and no space adjacencies, it will have a type of Shade. If there are any space adjacencies, it will have a type of Air.
  • If the source element is a Wall or a Curtain Wall and have one space adjacency, it will have a type of ExteriorWall.
  • If the source element is a Wall or a Curtain Wall and have two space adjacencies, it will have a type of InteriorWall.
  • If the source element is a Wall or a Curtain Wall and the type Function parameter is set to "Interior" or "CoreShaft", it will have a type of InteriorWall.
  • If the source element is a Wall or a Curtain Wall and have one space adjacency and if it is below grade, it will have a type of UndergroundWall.
  • If the source element is a Floor and have one space adjacency, it will have a type of SlabOnGrade. If the source element is above grade, it will have a type of RaisedFloor. If the source element is below grade, it will have a type of UndergroundSlab.
  • If the source element is a Floor and have two space adjacencies, it will have a type of InteriorFloor.
  • If the source element is a Floor and the type Function parameter is set to "Interior", it will have a type of InteriorFloor.
  • If the source element is a Roof or a Ceiling and have one space adjacency, it will have a type of Roof.
  • If the source element is a Roof or a Ceiling and have one space adjacency and is below grade, it will have a type of UndergroundCeiling.
  • If the source element is a Roof or a Ceiling and have two space adjacencies, it will have a type of Ceiling.
See Also

Reference

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisSurface.Width Property

EnergyAnalysisSurfaceWidth Property

The width of the analytical rectangular geometry.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Width { get; }
Public ReadOnly Property Width As Double
    Get
public:
property double Width {
    double get ();
}
member Width : float with get

Property Value

Double
Remarks
The product of width and height should be equal to the area of the polyloop for the opening. The width is adjusted to accomplish this.
See Also

Reference

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisSurface Methods

The EnergyAnalysisSurface type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetAdjacentAnalyticalSpace | Gets the secondary adjacent analytical space this surface is associated with.
Public method | GetAnalyticalOpenings | Returns the analytical openings of the analytical surface.
Public method | GetAnalyticalSpace | Gets the primary analytical space this surface is associated with.
Public method | GetConstruction | Gets the analytic construction this surface is associated with.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPolyloop | Gets the planar polygon describing the surface geometry.
Public method | GetPolyloops | Gets the collection of planar polygons describing the surface geometry.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisSurface.GetAdjacentAnalyticalSpace Method

EnergyAnalysisSurfaceGetAdjacentAnalyticalSpace Method

Gets the secondary adjacent analytical space this surface is associated with.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EnergyAnalysisSpace GetAdjacentAnalyticalSpace()
Public Function GetAdjacentAnalyticalSpace As EnergyAnalysisSpace
public:
EnergyAnalysisSpace^ GetAdjacentAnalyticalSpace()
member GetAdjacentAnalyticalSpace : unit -> EnergyAnalysisSpace

Return Value

EnergyAnalysisSpace
The secondary analytical space.
Remarks
An exterior surface will only have one space adjacency.
See Also

Reference

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisSurface.GetAnalyticalOpenings Method

EnergyAnalysisSurfaceGetAnalyticalOpenings Method

Returns the analytical openings of the analytical surface.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<EnergyAnalysisOpening> GetAnalyticalOpenings()
Public Function GetAnalyticalOpenings As IList(Of EnergyAnalysisOpening)
public:
IList<EnergyAnalysisOpening^>^ GetAnalyticalOpenings()
member GetAnalyticalOpenings : unit -> IList<EnergyAnalysisOpening>

Return Value

IList EnergyAnalysisOpening
The collection of analytical openings.
See Also

Reference

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisSurface.GetAnalyticalSpace Method

EnergyAnalysisSurfaceGetAnalyticalSpace Method

Gets the primary analytical space this surface is associated with.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EnergyAnalysisSpace GetAnalyticalSpace()
Public Function GetAnalyticalSpace As EnergyAnalysisSpace
public:
EnergyAnalysisSpace^ GetAnalyticalSpace()
member GetAnalyticalSpace : unit -> EnergyAnalysisSpace

Return Value

EnergyAnalysisSpace
The primary analytical space.
See Also

Reference

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisSurface.GetConstruction Method

EnergyAnalysisSurfaceGetConstruction Method

Gets the analytic construction this surface is associated with.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EnergyAnalysisConstruction GetConstruction()
Public Function GetConstruction As EnergyAnalysisConstruction
public:
EnergyAnalysisConstruction^ GetConstruction()
member GetConstruction : unit -> EnergyAnalysisConstruction

Return Value

EnergyAnalysisConstruction
The analytic construction.
See Also

Reference

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisSurface.GetPolyloop Method

EnergyAnalysisSurfaceGetPolyloop Method

Gets the planar polygon describing the surface geometry.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Polyloop GetPolyloop()
Public Function GetPolyloop As Polyloop
public:
Polyloop^ GetPolyloop()
member GetPolyloop : unit -> Polyloop

Return Value

Polyloop
The planar polygon describing the surface geometry.
Remarks
A planar polygon describing the surface geometry as described in gbXML. The geometry is currently measured per analytical(center-line).
See Also

Reference

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisSurface.GetPolyloops Method

EnergyAnalysisSurfaceGetPolyloops Method

Gets the collection of planar polygons describing the surface geometry.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<Polyloop> GetPolyloops()
Public Function GetPolyloops As IList(Of Polyloop)
public:
IList<Polyloop^>^ GetPolyloops()
member GetPolyloops : unit -> IList<Polyloop>

Return Value

IList Polyloop
The collection of polygons describing the surface geometry.
Remarks
A collection of polyloops (planar polygons) describing the surface geometry as described in gbXML. The geometry is currently measured per analytical(center-line).
See Also

Reference

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisSurfaceType Enumeration

Analytical surface types.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum EnergyAnalysisSurfaceType
Public Enumeration EnergyAnalysisSurfaceType
public enum class EnergyAnalysisSurfaceType
type EnergyAnalysisSurfaceType
Members
Member name | Value | Description
Roof | 0 | Roof.
ExteriorWall | 1 | Exterior wall.
InteriorWall | 2 | Interior wall.
Ceiling | 3 | Ceiling.
InteriorFloor | 4 | Interior floor.
ExteriorFloor | 5 | Exterior floor.
Shading | 6 | Shading.
Air | 7 | Air.
Underground | 8 | Underground
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisWindowType Class

The EnergyAnalysisWindowType class contains the thermal properties (e.g., heat transfer coefficient) of the window-type analytical openings.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DB.AnalysisEnergyAnalysisWindowType

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class EnergyAnalysisWindowType : Element
Public Class EnergyAnalysisWindowType
    Inherits Element
public ref class EnergyAnalysisWindowType : public Element
type EnergyAnalysisWindowType =
    class
        inherit Element
    end

The EnergyAnalysisWindowType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
Public property | Description | The description of the window type.
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HeatTransferCoefficient | The heat transfer coefficient value (U-value) of the window type, in W/(m^2*K) (equivalent to kg/(k*s^3)).
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsSchematic | Indicates if this originates from a schematic or analytical construction.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SolarHeatGainCoefficient | The solar heat gain coefficient (SHGC-value) for the window type, from 0.0 to 1.0.
Public property | Transmittance | The visual light transmittance value (VLT-value) for the window type, from 0.0 to 1.0.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WindowTypeName | The name of the window type.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSolarHeatGainCoefficientsForSolarIndicientAngles | Returns a map with solar heat gain coefficients (SHGC-values) for specific incident angles for the window type.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisWindowType Properties

The EnergyAnalysisWindowType type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
Public property | Description | The description of the window type.
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HeatTransferCoefficient | The heat transfer coefficient value (U-value) of the window type, in W/(m^2*K) (equivalent to kg/(k*s^3)).
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsSchematic | Indicates if this originates from a schematic or analytical construction.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | SolarHeatGainCoefficient | The solar heat gain coefficient (SHGC-value) for the window type, from 0.0 to 1.0.
Public property | Transmittance | The visual light transmittance value (VLT-value) for the window type, from 0.0 to 1.0.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WindowTypeName | The name of the window type.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

EnergyAnalysisWindowType Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisWindowType.Description Property

EnergyAnalysisWindowTypeDescription Property

The description of the window type.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get
public:
property String^ Description {
    String^ get ();
}
member Description : string with get

Property Value

String
See Also

Reference

EnergyAnalysisWindowType Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisWindowType.HeatTransferCoefficient Property

EnergyAnalysisWindowTypeHeatTransferCoefficient Property

The heat transfer coefficient value (U-value) of the window type, in W/(m^2*K) (equivalent to kg/(k*s^3)).

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double HeatTransferCoefficient { get; }
Public ReadOnly Property HeatTransferCoefficient As Double
    Get
public:
property double HeatTransferCoefficient {
    double get ();
}
member HeatTransferCoefficient : float with get

Property Value

Double
See Also

Reference

EnergyAnalysisWindowType Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisWindowType.IsSchematic Property

EnergyAnalysisWindowTypeIsSchematic Property

Indicates if this originates from a schematic or analytical construction.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSchematic { get; }
Public ReadOnly Property IsSchematic As Boolean
    Get
public:
property bool IsSchematic {
    bool get ();
}
member IsSchematic : bool with get

Property Value

Boolean
See Also

Reference

EnergyAnalysisWindowType Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisWindowType.SolarHeatGainCoefficient Property

EnergyAnalysisWindowTypeSolarHeatGainCoefficient Property

The solar heat gain coefficient (SHGC-value) for the window type, from 0.0 to 1.0.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double SolarHeatGainCoefficient { get; }
Public ReadOnly Property SolarHeatGainCoefficient As Double
    Get
public:
property double SolarHeatGainCoefficient {
    double get ();
}
member SolarHeatGainCoefficient : float with get

Property Value

Double
See Also

Reference

EnergyAnalysisWindowType Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisWindowType.Transmittance Property

EnergyAnalysisWindowTypeTransmittance Property

The visual light transmittance value (VLT-value) for the window type, from 0.0 to 1.0.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Transmittance { get; }
Public ReadOnly Property Transmittance As Double
    Get
public:
property double Transmittance {
    double get ();
}
member Transmittance : float with get

Property Value

Double
See Also

Reference

EnergyAnalysisWindowType Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisWindowType.WindowTypeName Property

EnergyAnalysisWindowTypeWindowTypeName Property

The name of the window type.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string WindowTypeName { get; }
Public ReadOnly Property WindowTypeName As String
    Get
public:
property String^ WindowTypeName {
    String^ get ();
}
member WindowTypeName : string with get

Property Value

String
See Also

Reference

EnergyAnalysisWindowType Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisWindowType Methods

The EnergyAnalysisWindowType type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSolarHeatGainCoefficientsForSolarIndicientAngles | Returns a map with solar heat gain coefficients (SHGC-values) for specific incident angles for the window type.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

EnergyAnalysisWindowType Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisWindowType.GetSolarHeatGainCoefficientsForSolarIndicientAngles Method

EnergyAnalysisWindowTypeGetSolarHeatGainCoefficientsForSolarIndicientAngles Method

Returns a map with solar heat gain coefficients (SHGC-values) for specific incident angles for the window type.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IDictionary<double, double> GetSolarHeatGainCoefficientsForSolarIndicientAngles()
Public Function GetSolarHeatGainCoefficientsForSolarIndicientAngles As IDictionary(Of Double, Double)
public:
IDictionary<double, double>^ GetSolarHeatGainCoefficientsForSolarIndicientAngles()
member GetSolarHeatGainCoefficientsForSolarIndicientAngles : unit -> IDictionary<float, float>

Return Value

IDictionary Double, Double
See Also

Reference

EnergyAnalysisWindowType Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisZone Class

Analytical zone.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DB.AnalysisEnergyAnalysisZone

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class EnergyAnalysisZone : Element
Public Class EnergyAnalysisZone
    Inherits Element
public ref class EnergyAnalysisZone : public Element
type EnergyAnalysisZone =
    class
        inherit Element
    end

The EnergyAnalysisZone type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisZone Properties

The EnergyAnalysisZone type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

EnergyAnalysisZone Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisZone Methods

The EnergyAnalysisZone type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

EnergyAnalysisZone Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings Class

This element contains settings for gbXML Export and Heating and Cooling Load Calculations and project level settings for Conceptual Energy Analysis. for serialization
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DB.AnalysisEnergyDataSettings

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class EnergyDataSettings : Element
Public Class EnergyDataSettings
    Inherits Element
public ref class EnergyDataSettings : public Element
type EnergyDataSettings =
    class
        inherit Element
    end

The EnergyDataSettings type exposes the following members.

Properties
 | Name | Description
Public property | AnalysisType | The type of analysis mode.
Public property | AnalyticalGridCellSize | The cell size for the uniform cubical grid used when computing the building envelope
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | BuildingConstructionClass | Used for both the detailed and conceptual energy model Construction class of building as defined by: loose, medium, tight, or none.
Public property | BuildingEnvelopeDeterminationMethod | Indicates if an analysis should be perform to find the model elements that are part of the building envelope
Public property | BuildingHVACSystem | The type of HVAC system used by the building for conceptual model energy calculations.
Public property | BuildingOperatingSchedule | The operating schedule of the building used for conceptual model energy calculations.
Public property | BuildingType | The type of building.
Public property | BuildingTypeId | The building type element.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | CoreOffset | The default offset used to determine the outer perimeter to be divided into zones.
Public property | CreateAnalyticalModel | If this is true, data, features, and geometry related to the Energy Analytical Model will be created, allowing the energy performance to be analyzed through GreenBuilidingXML.
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | DividePerimeter | If this is true, zones with exterior boundaries on each floor of the building will be divided based on geometric criteria.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | EnergyModel | if this is on there should be an energy model dependent on the current AnalysisType if it is off the conceptual energy model should be turned off but setting this datum does not do the work, just reflects the state.
Public property | ExportCategory | Value is a category indicating which discipline model will be used for GreenBuildingXML export.
Public property | ExportComplexity | Value determines Export Complexity for GreenBuildingXML detailed model export.
Public property | ExportDefaults | Use for detailed model GreenBuildingXML export. When this setting is true, all building and space defaults, schedules, and constructions will be exported to GreenBuildingXML. When this setting is false, only values that are specified on the zone or space will be exported to GreenBuildingXML.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroundPlane | Id of level which represents ground level.
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IncludeThermalProperties | Indicates if thermal information from model assemblies and components is included in GreenBuildingXML export of the detailed model.
Public property | IsExportMullionsEnabled | Indicates if mullions are included in GreenBuildingXML export of the detailed model.
Public property | IsExportShadingSurfacesEnabled | Indicates if "shading surfaces" are included in GreenBuildingXML export of the detailed model.
Public property | IsExportSimplifiedCurtainSystemsEnabled | Indicates if curtain system geometry is being simplified for GreenBuildingXML export of the detailed model.
Public property | IsGlazingShaded | If this is true, glazing/windows that are auto-created on exterior walls will automatically have a shading device created on their top edge.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OutsideAirChangesRatePerHour | The number of times the volume of air interchanges in the room in one hour.
Public property | OutsideAirPerArea | The rate of flow of outside air available per unit area.
Public property | OutsideAirPerPerson | The rate of flow of outside air available per person.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | PercentageGlazing | Used for the conceptual energy model. The approximate percentage of the building exterior wall surfaces which are covered by windows or other glazing.
Public property | PercentageSkylights | Used for the conceptual energy model. The approximate percentage of the building roof surfaces in massing instances for the Conceptual Energy Analytical Model.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ProjectPhase | The project phase of the EnergyData information.
Public property | ProjectReportType | Report type: None, simple, standard, detailed
Public property | ReportsFolder | The folder path where all systems analysis reports are stored. It may include special label and relative path.
Public property | ServiceType | The type of heating or cooling system.
Public property | ShadeDepth | Used for the conceptual energy model. Amount that auto-generated shading will extend from auto-generated windows.
Public property | SillHeight | Used for the conceptual energy model. The height from the nearest lower level used for auto-glazing created on walls.
Public property | SkylightWidth | Used for the conceptual energy model. The approximate width used for the skylights in massing instances when the Energy Analytical model is being created.
Public property | SliverSpaceTolerance | Used for Detailed GreenBuildingXML export. This value is used to identify sliver spaces, i.e. spaces bounded by parallel surfaces belonging to different rooms.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | UseAirChangesPerHour | True if user is specifying air changes per hour, false otherwise.
Public property | UseCurrentViewOnly | True if only elements visible in the currently active view are used for generation of Energy Model.
Public property | UseHeatingCredits | If true, Revit will use heating credits in the final load sum calculations. If false, Revit will ignore heating credits in the final load sum calculations.
Public property | UseOutsideAirPerArea | True is user is specifying outside air per area, false otherwise.
Public property | UseOutsideAirPerPerson | True if user is specifying outside air per person, false otherwise.
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
Name | Description
Public method ArePhasesModifiable Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element.
(Inherited from Element)
Public method CanBeHidden Indicates if the element can be hidden in the view.
(Inherited from Element)
Public method CanBeLocked Identifies if the element can be locked.
(Inherited from Element)
Public method CanDeleteSubelement Checks if given subelement can be removed from the element.
(Inherited from Element)
Public method CanHaveTypeAssigned Identifies if the element can have a type assigned.
(Inherited from Element)
Public method ChangeTypeId(ElementId) Changes the type of the element.
(Inherited from Element)
CheckAnalysisType | Checks that the analysis type falls within an appropriate range.
CheckBuildingConstructionClass | Checks that the building construction class falls within an appropriate range.
CheckBuildingEnvelope | Checks that the building envelope determination method falls within an appropriate range.
CheckBuildingHVACSystem | Checks that the building HVAC system falls within an appropriate range.
CheckBuildingOperatingSchedule | Checks that the building operating schedule falls within an appropriate range.
CheckBuildingType | Checks that the building type falls within an appropriate range.
Public method | CheckConstructionSetElement | Checks that the construction set ElementId is acceptable.
CheckExportCategory Checks whether the export category falls within the list:
  1. OST_Rooms
  2. OST_MEPSpaces
CheckExportComplexity | Checks that the export complexity falls within an appropriate range.
Public method | CheckGroundPlane(ElementId) | The ground plane should be an Element of type Level. This method checks to confirm that an ElementId is for a Level element.
CheckGroundPlane(Document, ElementId) | The ground plane should be an Element of type Level. This method checks to confirm that an ElementId is for a Level element.
Public method | CheckProjectPhase | Checks that the input element is a project phase.
CheckProjectReportType | Checks that the project report type falls within an appropriate range.
CheckRangeOfPercentageGlazing | Checks that the percentage glazing value is between 0.00 and 0.95.
CheckRangeOfPercentageSkylights | Checks that the percentage skylights value is between 0.00 and 0.95.
CheckRangeOfShadeDepth | Checks that the shade depth is greater than or equal to zero.
CheckRangeOfSillHeight | Checks that the sill height is greater than or equal to zero.
CheckRangeOfSkylightWidth | Checks that the skylight width is greater than or equal to eight inches.
CheckRangeOfSliverSpaceTolerance | Checks that the sliver space tolerance is greater than or equal to zero.
CheckServiceType | Checks that the service type falls within an appropriate range.
Public method DeleteEntity Deletes the existing entity created by %schema% in the element
(Inherited from Element)
Public method DeleteSubelement Removes a subelement from the element.
(Inherited from Element)
Public method DeleteSubelements Removes the subelements from the element.
(Inherited from Element)
Public method Dispose
(Inherited from Element)
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object)
Public method EvaluateAllParameterValues Evaluates all the parameters' values of the element.
(Inherited from Element)
Public method EvaluateParameterValues Evaluate the parameters' values of the element on the given parameter ID set.
(Inherited from Element)
GetBuildingConstructionSetElementId | Id of the building construction set.
Public method GetDependentElements Get all elements that, from a logical point of view, are the children of this Element.
(Inherited from Element)
Public method GetEntity Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise.
(Inherited from Element)
Public method GetEntitySchemaGuids Returns the Schema guids of any Entities stored in this element.
(Inherited from Element)
Public method GetExternalFileReference Gets information pertaining to the external file referenced by the element.
(Inherited from Element)
Public method GetExternalResourceReference Gets the ExternalResourceReference associated with a specified external resource type.
(Inherited from Element)
Public method GetExternalResourceReferenceExpanded Gets the collection of ExternalResourceReference associated with a specified external resource type.
(Inherited from Element)
Public method GetExternalResourceReferences Gets the map of the external resource references referenced by the element.
(Inherited from Element)
Public method GetExternalResourceReferencesExpanded Gets the expanded map of the external resource references referenced by the element.
(Inherited from Element)
GetFromDocument | Every project document has a EnergyDataSettings element. Family documents do not have EnergyDataSettings elements.
GetGeneratingElementIds Returns the ids of the element(s) that generated the input geometry object.
(Inherited from Element)
Public method GetGeometryObjectFromReference Retrieve one geometric primitive contained in the element given a reference.
(Inherited from Element)
Public method GetHashCode Serves as the default hash function.
(Inherited from Object)
Public method GetMaterialArea Gets the area of the material with the given id.
(Inherited from Element)
Public method GetMaterialIds Gets the element ids of all materials present in the element.
(Inherited from Element)
Public method GetMaterialVolume Gets the volume of the material with the given id.
(Inherited from Element)
Public method GetMonitoredLinkElementIds Provides the link instance IDs when the element is monitoring.
(Inherited from Element)
Public method GetMonitoredLocalElementIds Provides the local element IDs when the element is monitoring.
(Inherited from Element)
Public method GetOrderedParameters Gets the parameters associated to the element in order.
(Inherited from Element)
Public method GetParameter Retrieves a parameter from the element given identifier.
(Inherited from Element)
Public method GetParameterFormatOptions Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists.
(Inherited from Element)
Public method GetParameters Retrieves the parameters from the element via the given name.
(Inherited from Element)
Public method GetPhaseStatus Gets the status of a given element in the input phase
(Inherited from Element)
Public method | GetReportsFolderParsed | Gets the absolute reports folder path that is parsed from the original input.
Public method GetSubelements Returns the collection of element subelements.
(Inherited from Element)
Public method GetType Gets the Type of the current instance.
(Inherited from Object)
GetTypeId Returns the identifier of this element's type.
(Inherited from Element)
Public method GetValidTypes Obtains a set of types that are valid for this element.
(Inherited from Element)
Public method HasPhases Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.
(Inherited from Element)
Public method IsCreatedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element)
Public method IsDemolishedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element)
IsDocumentUsingEnergyDataAnalyticalModel | Get EnergyDataSettings element and if it exists, return result from getCreateAnalyticalModel.
Public method IsExternalFileReference Determines whether this Element represents an external file.
(Inherited from Element)
Public method IsHidden Identifies if the element has been permanently hidden in the view.
(Inherited from Element)
Public method IsMonitoringLinkElement Indicate whether an element is monitoring any elements in any linked models.
(Inherited from Element)
Public method IsMonitoringLocalElement Indicate whether an element is monitoring other local elements.
(Inherited from Element)
Public method IsPhaseCreatedValid Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element.
(Inherited from Element)
Public method IsPhaseDemolishedValid Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element.
(Inherited from Element)
Public method IsValidType(ElementId) Checks if given type is valid for this element.
(Inherited from Element)
Public method LookupParameter Attempts to find a parameter on the element which has the given name.
(Inherited from Element)
Public method RefersToExternalResourceReference Determines whether this Element uses external resources associated with a specified external resource type.
(Inherited from Element)
Public method RefersToExternalResourceReferences Determines whether this Element uses external resources.
(Inherited from Element)
Public method SetEntity Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten.
(Inherited from Element)
Public method | SetReportsFolder | Sets the reports folder path.
Public method ToString Returns a string that represents the current object.
(Inherited from Object)
Top
Example
C#
VB
C++
F#
Copy
public void GetInfo_EnergyData(Document document)
{
   EnergyDataSettings energyData = EnergyDataSettings.GetFromDocument(document);

   if (null != energyData)
    {
        string message = "energyData : ";
        message += "\nBuildingType : " + energyData.BuildingType;
        TaskDialog.Show("Revit",message);
    }
}
Public Sub GetInfo_EnergyData(document As Document)
    Dim energyData As EnergyDataSettings = EnergyDataSettings.GetFromDocument(document)

    If energyData IsNot Nothing Then
        Dim message As String = "energyData : "
        message += vbLf & "BuildingType : " + energyData.BuildingType
        TaskDialog.Show("Revit", message)
    End If
End Sub

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings Properties

The EnergyDataSettings type exposes the following members.

Properties
 | Name | Description
Public property | AnalysisType | The type of analysis mode.
Public property | AnalyticalGridCellSize | The cell size for the uniform cubical grid used when computing the building envelope
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | BuildingConstructionClass | Used for both the detailed and conceptual energy model Construction class of building as defined by: loose, medium, tight, or none.
Public property | BuildingEnvelopeDeterminationMethod | Indicates if an analysis should be perform to find the model elements that are part of the building envelope
Public property | BuildingHVACSystem | The type of HVAC system used by the building for conceptual model energy calculations.
Public property | BuildingOperatingSchedule | The operating schedule of the building used for conceptual model energy calculations.
Public property | BuildingType | The type of building.
Public property | BuildingTypeId | The building type element.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | CoreOffset | The default offset used to determine the outer perimeter to be divided into zones.
Public property | CreateAnalyticalModel | If this is true, data, features, and geometry related to the Energy Analytical Model will be created, allowing the energy performance to be analyzed through GreenBuilidingXML.
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | DividePerimeter | If this is true, zones with exterior boundaries on each floor of the building will be divided based on geometric criteria.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | EnergyModel | if this is on there should be an energy model dependent on the current AnalysisType if it is off the conceptual energy model should be turned off but setting this datum does not do the work, just reflects the state.
Public property | ExportCategory | Value is a category indicating which discipline model will be used for GreenBuildingXML export.
Public property | ExportComplexity | Value determines Export Complexity for GreenBuildingXML detailed model export.
Public property | ExportDefaults | Use for detailed model GreenBuildingXML export. When this setting is true, all building and space defaults, schedules, and constructions will be exported to GreenBuildingXML. When this setting is false, only values that are specified on the zone or space will be exported to GreenBuildingXML.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroundPlane | Id of level which represents ground level.
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IncludeThermalProperties | Indicates if thermal information from model assemblies and components is included in GreenBuildingXML export of the detailed model.
Public property | IsExportMullionsEnabled | Indicates if mullions are included in GreenBuildingXML export of the detailed model.
Public property | IsExportShadingSurfacesEnabled | Indicates if "shading surfaces" are included in GreenBuildingXML export of the detailed model.
Public property | IsExportSimplifiedCurtainSystemsEnabled | Indicates if curtain system geometry is being simplified for GreenBuildingXML export of the detailed model.
Public property | IsGlazingShaded | If this is true, glazing/windows that are auto-created on exterior walls will automatically have a shading device created on their top edge.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OutsideAirChangesRatePerHour | The number of times the volume of air interchanges in the room in one hour.
Public property | OutsideAirPerArea | The rate of flow of outside air available per unit area.
Public property | OutsideAirPerPerson | The rate of flow of outside air available per person.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | PercentageGlazing | Used for the conceptual energy model. The approximate percentage of the building exterior wall surfaces which are covered by windows or other glazing.
Public property | PercentageSkylights | Used for the conceptual energy model. The approximate percentage of the building roof surfaces in massing instances for the Conceptual Energy Analytical Model.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ProjectPhase | The project phase of the EnergyData information.
Public property | ProjectReportType | Report type: None, simple, standard, detailed
Public property | ReportsFolder | The folder path where all systems analysis reports are stored. It may include special label and relative path.
Public property | ServiceType | The type of heating or cooling system.
Public property | ShadeDepth | Used for the conceptual energy model. Amount that auto-generated shading will extend from auto-generated windows.
Public property | SillHeight | Used for the conceptual energy model. The height from the nearest lower level used for auto-glazing created on walls.
Public property | SkylightWidth | Used for the conceptual energy model. The approximate width used for the skylights in massing instances when the Energy Analytical model is being created.
Public property | SliverSpaceTolerance | Used for Detailed GreenBuildingXML export. This value is used to identify sliver spaces, i.e. spaces bounded by parallel surfaces belonging to different rooms.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | UseAirChangesPerHour | True if user is specifying air changes per hour, false otherwise.
Public property | UseCurrentViewOnly | True if only elements visible in the currently active view are used for generation of Energy Model.
Public property | UseHeatingCredits | If true, Revit will use heating credits in the final load sum calculations. If false, Revit will ignore heating credits in the final load sum calculations.
Public property | UseOutsideAirPerArea | True is user is specifying outside air per area, false otherwise.
Public property | UseOutsideAirPerPerson | True if user is specifying outside air per person, false otherwise.
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.AnalysisType Property

EnergyDataSettingsAnalysisType Property

The type of analysis mode.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AnalysisMode AnalysisType { get; set; }
Public Property AnalysisType As AnalysisMode
    Get
    Set
public:
property AnalysisMode AnalysisType {
    AnalysisMode get ();
    void set (AnalysisMode value);
}
member AnalysisType : AnalysisMode with get, set

Property Value

AnalysisMode
Exceptions
Exception | Condition
ArgumentException | When setting this property: The analysis type does not fall within an appropriate range.
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.AnalyticalGridCellSize Property

EnergyDataSettingsAnalyticalGridCellSize Property

The cell size for the uniform cubical grid used when computing the building envelope

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double AnalyticalGridCellSize { get; set; }
Public Property AnalyticalGridCellSize As Double
    Get
    Set
public:
property double AnalyticalGridCellSize {
    double get ();
    void set (double value);
}
member AnalyticalGridCellSize : float with get, set

Property Value

Double
Remarks
This is the size of the "cubes" used to divide the building shell bounding box into a uniform cubical 3D grid.
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.BuildingConstructionClass Property

EnergyDataSettingsBuildingConstructionClass Property

Used for both the detailed and conceptual energy model Construction class of building as defined by: loose, medium, tight, or none.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public HVACLoadConstructionClass BuildingConstructionClass { get; set; }
Public Property BuildingConstructionClass As HVACLoadConstructionClass
    Get
    Set
public:
property HVACLoadConstructionClass BuildingConstructionClass {
    HVACLoadConstructionClass get ();
    void set (HVACLoadConstructionClass value);
}
member BuildingConstructionClass : HVACLoadConstructionClass with get, set

Property Value

HVACLoadConstructionClass
Exceptions
Exception | Condition
ArgumentException | When setting this property: The building construction class does not fall within an appropriate range.
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.BuildingEnvelopeDeterminationMethod Property

EnergyDataSettingsBuildingEnvelopeDeterminationMethod Property

Indicates if an analysis should be perform to find the model elements that are part of the building envelope

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public gbXMLExportBuildingEnvelope BuildingEnvelopeDeterminationMethod { get; set; }
Public Property BuildingEnvelopeDeterminationMethod As gbXMLExportBuildingEnvelope
    Get
    Set
public:
property gbXMLExportBuildingEnvelope BuildingEnvelopeDeterminationMethod {
    gbXMLExportBuildingEnvelope get ();
    void set (gbXMLExportBuildingEnvelope value);
}
member BuildingEnvelopeDeterminationMethod : gbXMLExportBuildingEnvelope with get, set

Property Value

gbXMLExportBuildingEnvelope
Exceptions
Exception | Condition
ArgumentException | When setting this property: The building envelope determination method does not fall within an appropriate range.
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
The analysis is performed for the detailed GreenBuildingXML export and in heating and cooling load calculations. This method uses a combination of ray-casting and flood-fill algorithms in order to find the building elements that are exposed to the outside of the building. Analytical surface originated from the building elements in the envelope will be classified as exterior or shading surfaces.
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.BuildingHVACSystem Property

EnergyDataSettingsBuildingHVACSystem Property

The type of HVAC system used by the building for conceptual model energy calculations.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public gbXMLBuildingHVACSystem BuildingHVACSystem { get; set; }
Public Property BuildingHVACSystem As gbXMLBuildingHVACSystem
    Get
    Set
public:
property gbXMLBuildingHVACSystem BuildingHVACSystem {
    gbXMLBuildingHVACSystem get ();
    void set (gbXMLBuildingHVACSystem value);
}
member BuildingHVACSystem : gbXMLBuildingHVACSystem with get, set

Property Value

gbXMLBuildingHVACSystem
Exceptions
Exception | Condition
ArgumentException | When setting this property: The building HVAC system does not fall within an appropriate range.
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.BuildingOperatingSchedule Property

EnergyDataSettingsBuildingOperatingSchedule Property

The operating schedule of the building used for conceptual model energy calculations.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public gbXMLBuildingOperatingSchedule BuildingOperatingSchedule { get; set; }
Public Property BuildingOperatingSchedule As gbXMLBuildingOperatingSchedule
    Get
    Set
public:
property gbXMLBuildingOperatingSchedule BuildingOperatingSchedule {
    gbXMLBuildingOperatingSchedule get ();
    void set (gbXMLBuildingOperatingSchedule value);
}
member BuildingOperatingSchedule : gbXMLBuildingOperatingSchedule with get, set

Property Value

gbXMLBuildingOperatingSchedule
Exceptions
Exception | Condition
ArgumentException | When setting this property: The building operating schedule does not fall within an appropriate range.
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.BuildingType Property

EnergyDataSettingsBuildingType Property

The type of building.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public gbXMLBuildingType BuildingType { get; set; }
Public Property BuildingType As gbXMLBuildingType
    Get
    Set
public:
property gbXMLBuildingType BuildingType {
    gbXMLBuildingType get ();
    void set (gbXMLBuildingType value);
}
member BuildingType : gbXMLBuildingType with get, set

Property Value

gbXMLBuildingType
Exceptions
Exception | Condition
ArgumentException | When setting this property: The building type does not fall within an appropriate range.
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.BuildingTypeId Property

EnergyDataSettingsBuildingTypeId Property

The building type element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId BuildingTypeId { get; set; }
Public Property BuildingTypeId As ElementId
    Get
    Set
public:
property ElementId^ BuildingTypeId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member BuildingTypeId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.CoreOffset Property

EnergyDataSettingsCoreOffset Property

The default offset used to determine the outer perimeter to be divided into zones.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double CoreOffset { get; set; }
Public Property CoreOffset As Double
    Get
    Set
public:
property double CoreOffset {
    double get ();
    void set (double value);
}
member CoreOffset : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The given value for coreOffset must be between 0 and 30000 feet.
Remarks
A Zone can be either a Mass Zone or an Analytical Space depending on whether the AnalysisType is ConceptualMasses or otherwise. Specifying a value here determines the zone depth and creates a core zone.
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.CreateAnalyticalModel Property

EnergyDataSettingsCreateAnalyticalModel Property

If this is true, data, features, and geometry related to the Energy Analytical Model will be created, allowing the energy performance to be analyzed through GreenBuilidingXML.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CreateAnalyticalModel { get; }
Public ReadOnly Property CreateAnalyticalModel As Boolean
    Get
public:
property bool CreateAnalyticalModel {
    bool get ();
}
member CreateAnalyticalModel : bool with get

Property Value

Boolean
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.DividePerimeter Property

EnergyDataSettingsDividePerimeter Property

If this is true, zones with exterior boundaries on each floor of the building will be divided based on geometric criteria.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool DividePerimeter { get; set; }
Public Property DividePerimeter As Boolean
    Get
    Set
public:
property bool DividePerimeter {
    bool get ();
    void set (bool value);
}
member DividePerimeter : bool with get, set

Property Value

Boolean
Remarks
When the AnalysisType is ConceptualMasses, the division of the perimeter zones is based on the four compass directions. The quadrants will be True N, S, E, and W. The division of the quadrants will be along the axis of True NW to SE and True SW to NE. The intersection of the quadrants will be placed at the centroid of the zone. When the AnalysisType is not ConceptualMasses, the division of the perimeter zones is based on the difference of orientation, maximum length and depth. Any exterior surfaces that have an angle of 45 degrees or more between them will be divided into separate zones. Zones greater than 50 ft. will be divided equally. The CoreOffset will determine the depth of the zones. The purpose of these divisions is to ensure that auto-generated zoning is appropriate for thermal loads generated by the relative position of the building to the sun path.
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.EnergyModel Property

EnergyDataSettingsEnergyModel Property

if this is on there should be an energy model dependent on the current AnalysisType if it is off the conceptual energy model should be turned off but setting this datum does not do the work, just reflects the state.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool EnergyModel { get; set; }
Public Property EnergyModel As Boolean
    Get
    Set
public:
property bool EnergyModel {
    bool get ();
    void set (bool value);
}
member EnergyModel : bool with get, set

Property Value

Boolean
true if energy model is on, false otherwise
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.ExportCategory Property

EnergyDataSettingsExportCategory Property

Value is a category indicating which discipline model will be used for GreenBuildingXML export.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId ExportCategory { get; set; }
Public Property ExportCategory As ElementId
    Get
    Set
public:
property ElementId^ ExportCategory {
    ElementId^ get ();
    void set (ElementId^ value);
}
member ExportCategory : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentException | When setting this property: The export category is neither OST_Rooms nor OST_MEPSpaces.
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
OST_Rooms will use the architectural 3d rooms for export. OST_MEPSpaces will use the MEP 3d Spaces for export.
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.ExportComplexity Property

EnergyDataSettingsExportComplexity Property

Value determines Export Complexity for GreenBuildingXML detailed model export.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public gbXMLExportComplexity ExportComplexity { get; set; }
Public Property ExportComplexity As gbXMLExportComplexity
    Get
    Set
public:
property gbXMLExportComplexity ExportComplexity {
    gbXMLExportComplexity get ();
    void set (gbXMLExportComplexity value);
}
member ExportComplexity : gbXMLExportComplexity with get, set

Property Value

gbXMLExportComplexity
Exceptions
Exception | Condition
ArgumentException | When setting this property: The export complexity does not fall within an appropriate range.
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.ExportDefaults Property

EnergyDataSettingsExportDefaults Property

Use for detailed model GreenBuildingXML export. When this setting is true, all building and space defaults, schedules, and constructions will be exported to GreenBuildingXML. When this setting is false, only values that are specified on the zone or space will be exported to GreenBuildingXML.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ExportDefaults { get; set; }
Public Property ExportDefaults As Boolean
    Get
    Set
public:
property bool ExportDefaults {
    bool get ();
    void set (bool value);
}
member ExportDefaults : bool with get, set

Property Value

Boolean
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.GroundPlane Property

EnergyDataSettingsGroundPlane Property

Id of level which represents ground level.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId GroundPlane { get; set; }
Public Property GroundPlane As ElementId
    Get
    Set
public:
property ElementId^ GroundPlane {
    ElementId^ get ();
    void set (ElementId^ value);
}
member GroundPlane : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentException | When setting this property: The input element is not a level or invalidElementId.
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
The ground plane defines what is above and below ground for Conceptual Energy Analysis. The ground plane can optionally used for the rendering cast shadows.
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.IncludeThermalProperties Property

EnergyDataSettingsIncludeThermalProperties Property

Indicates if thermal information from model assemblies and components is included in GreenBuildingXML export of the detailed model.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IncludeThermalProperties { get; set; }
Public Property IncludeThermalProperties As Boolean
    Get
    Set
public:
property bool IncludeThermalProperties {
    bool get ();
    void set (bool value);
}
member IncludeThermalProperties : bool with get, set

Property Value

Boolean
Remarks
If true, Revit will include model thermal data from assemblies and components when available, when Export Category is Rooms.
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.IsExportMullionsEnabled Property

EnergyDataSettingsIsExportMullionsEnabled Property

Indicates if mullions are included in GreenBuildingXML export of the detailed model.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsExportMullionsEnabled { get; }
Public ReadOnly Property IsExportMullionsEnabled As Boolean
    Get
public:
property bool IsExportMullionsEnabled {
    bool get ();
}
member IsExportMullionsEnabled : bool with get

Property Value

Boolean
Remarks
Result is based on the ExportComplexity setting. When this setting is on, mullions will be exported as shading surfaces. A "simplified" analytical shading surface is produced from a mullion based on its centerline, thickness, and offset.
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.IsExportShadingSurfacesEnabled Property

EnergyDataSettingsIsExportShadingSurfacesEnabled Property

Indicates if "shading surfaces" are included in GreenBuildingXML export of the detailed model.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsExportShadingSurfacesEnabled { get; }
Public ReadOnly Property IsExportShadingSurfacesEnabled As Boolean
    Get
public:
property bool IsExportShadingSurfacesEnabled {
    bool get ();
}
member IsExportShadingSurfacesEnabled : bool with get

Property Value

Boolean
Remarks
Result is based on the ExportComplexity setting. The method described by gbs/gbxml.org to calculate the shading surfaces is to take all surfaces from the MEP spaces, subtract them from the surfaces from all building elements, and then the remaining surfaces are considered to be the shading surfaces.
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.IsExportSimplifiedCurtainSystemsEnabled Property

EnergyDataSettingsIsExportSimplifiedCurtainSystemsEnabled Property

Indicates if curtain system geometry is being simplified for GreenBuildingXML export of the detailed model.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsExportSimplifiedCurtainSystemsEnabled { get; }
Public ReadOnly Property IsExportSimplifiedCurtainSystemsEnabled As Boolean
    Get
public:
property bool IsExportSimplifiedCurtainSystemsEnabled {
    bool get ();
}
member IsExportSimplifiedCurtainSystemsEnabled : bool with get

Property Value

Boolean
Remarks
Result is based on the ExportComplexity setting. Curtain Walls and Curtain Systems are normally exported as multiple openings, panel by panel, while for energy analysis this can be more simply represented as a single glass surface as large as the entire curtain wall/system. Normally, a curtain wall with 50 panels would be exported as 50 openings. Often, exporting a single opening with the total curtain system area is more appropriate. When this setting is on, one "large" window/opening will be exported for a curtain wall/system.
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.IsGlazingShaded Property

EnergyDataSettingsIsGlazingShaded Property

If this is true, glazing/windows that are auto-created on exterior walls will automatically have a shading device created on their top edge.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsGlazingShaded { get; set; }
Public Property IsGlazingShaded As Boolean
    Get
    Set
public:
property bool IsGlazingShaded {
    bool get ();
    void set (bool value);
}
member IsGlazingShaded : bool with get, set

Property Value

Boolean
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.OutsideAirChangesRatePerHour Property

EnergyDataSettingsOutsideAirChangesRatePerHour Property

The number of times the volume of air interchanges in the room in one hour.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double OutsideAirChangesRatePerHour { get; set; }
Public Property OutsideAirChangesRatePerHour As Double
    Get
    Set
public:
property double OutsideAirChangesRatePerHour {
    double get ();
    void set (double value);
}
member OutsideAirChangesRatePerHour : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The outside airChangesRatePerHour does not fall within an appropriate range.
Remarks
Air Changes per hour is "unitless". It is a number. It is the number of times the air (the volume) interchanges in the room in one hour. This number is a format for expressing the requirement for airflow. The "flow" requirement for a room might be expressed, e.g., one room of 100 CF, and 3 Air Changes per Hour (ACH), would compute to 100 CF x 3 ACH / 60 min = 5 CFM.
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.OutsideAirPerArea Property

EnergyDataSettingsOutsideAirPerArea Property

The rate of flow of outside air available per unit area.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double OutsideAirPerArea { get; set; }
Public Property OutsideAirPerArea As Double
    Get
    Set
public:
property double OutsideAirPerArea {
    double get ();
    void set (double value);
}
member OutsideAirPerArea : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The outside airPerArea does not fall within an appropriate range.
Remarks
Stored in cubic feet per hour per square foot.
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.OutsideAirPerPerson Property

EnergyDataSettingsOutsideAirPerPerson Property

The rate of flow of outside air available per person.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double OutsideAirPerPerson { get; set; }
Public Property OutsideAirPerPerson As Double
    Get
    Set
public:
property double OutsideAirPerPerson {
    double get ();
    void set (double value);
}
member OutsideAirPerPerson : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The outside airPerPerson does not fall within an appropriate range.
Remarks
Stored in cubic feet per hour.
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.PercentageGlazing Property

EnergyDataSettingsPercentageGlazing Property

Used for the conceptual energy model. The approximate percentage of the building exterior wall surfaces which are covered by windows or other glazing.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double PercentageGlazing { get; set; }
Public Property PercentageGlazing As Double
    Get
    Set
public:
property double PercentageGlazing {
    double get ();
    void set (double value);
}
member PercentageGlazing : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The percentage glazing value is not between 0.00 and 0.95.
Remarks
This value is used to automatically model these glazed openings in massing instances for the Conceptual Energy Analytical Model.
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.PercentageSkylights Property

EnergyDataSettingsPercentageSkylights Property

Used for the conceptual energy model. The approximate percentage of the building roof surfaces in massing instances for the Conceptual Energy Analytical Model.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double PercentageSkylights { get; set; }
Public Property PercentageSkylights As Double
    Get
    Set
public:
property double PercentageSkylights {
    double get ();
    void set (double value);
}
member PercentageSkylights : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The percentage skylights value is between 0.00 and 0.95.
Remarks
This value is used to automatically model the skylights in massing instances when the Energy Analytical model is being created.
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.ProjectPhase Property

EnergyDataSettingsProjectPhase Property

The project phase of the EnergyData information.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId ProjectPhase { get; set; }
Public Property ProjectPhase As ElementId
    Get
    Set
public:
property ElementId^ ProjectPhase {
    ElementId^ get ();
    void set (ElementId^ value);
}
member ProjectPhase : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentException | When setting this property: The input element is not a project phase.
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.ProjectReportType Property

EnergyDataSettingsProjectReportType Property

Report type: None, simple, standard, detailed

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public HVACLoadLoadsReportType ProjectReportType { get; set; }
Public Property ProjectReportType As HVACLoadLoadsReportType
    Get
    Set
public:
property HVACLoadLoadsReportType ProjectReportType {
    HVACLoadLoadsReportType get ();
    void set (HVACLoadLoadsReportType value);
}
member ProjectReportType : HVACLoadLoadsReportType with get, set

Property Value

HVACLoadLoadsReportType
Exceptions
Exception | Condition
ArgumentException | When setting this property: The project report type does not fall within an appropriate range.
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.ReportsFolder Property

EnergyDataSettingsReportsFolder Property

The folder path where all systems analysis reports are stored. It may include special label and relative path.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ReportsFolder { get; }
Public ReadOnly Property ReportsFolder As String
    Get
public:
property String^ ReportsFolder {
    String^ get ();
}
member ReportsFolder : string with get

Property Value

String
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.ServiceType Property

EnergyDataSettingsServiceType Property

The type of heating or cooling system.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public gbXMLServiceType ServiceType { get; set; }
Public Property ServiceType As gbXMLServiceType
    Get
    Set
public:
property gbXMLServiceType ServiceType {
    gbXMLServiceType get ();
    void set (gbXMLServiceType value);
}
member ServiceType : gbXMLServiceType with get, set

Property Value

gbXMLServiceType
Exceptions
Exception | Condition
ArgumentException | When setting this property: The service type does not fall within an appropriate range.
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.ShadeDepth Property

EnergyDataSettingsShadeDepth Property

Used for the conceptual energy model. Amount that auto-generated shading will extend from auto-generated windows.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double ShadeDepth { get; set; }
Public Property ShadeDepth As Double
    Get
    Set
public:
property double ShadeDepth {
    double get ();
    void set (double value);
}
member ShadeDepth : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The shade depth is less than zero.
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.SillHeight Property

EnergyDataSettingsSillHeight Property

Used for the conceptual energy model. The height from the nearest lower level used for auto-glazing created on walls.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double SillHeight { get; set; }
Public Property SillHeight As Double
    Get
    Set
public:
property double SillHeight {
    double get ();
    void set (double value);
}
member SillHeight : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The sill height is less than zero.
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.SkylightWidth Property

EnergyDataSettingsSkylightWidth Property

Used for the conceptual energy model. The approximate width used for the skylights in massing instances when the Energy Analytical model is being created.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double SkylightWidth { get; set; }
Public Property SkylightWidth As Double
    Get
    Set
public:
property double SkylightWidth {
    double get ();
    void set (double value);
}
member SkylightWidth : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The skylight width is less than eight inches.
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.SliverSpaceTolerance Property

EnergyDataSettingsSliverSpaceTolerance Property

Used for Detailed GreenBuildingXML export. This value is used to identify sliver spaces, i.e. spaces bounded by parallel surfaces belonging to different rooms.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double SliverSpaceTolerance { get; set; }
Public Property SliverSpaceTolerance As Double
    Get
    Set
public:
property double SliverSpaceTolerance {
    double get ();
    void set (double value);
}
member SliverSpaceTolerance : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The sliver space tolerance is less than zero.
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.UseAirChangesPerHour Property

EnergyDataSettingsUseAirChangesPerHour Property

True if user is specifying air changes per hour, false otherwise.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UseAirChangesPerHour { get; set; }
Public Property UseAirChangesPerHour As Boolean
    Get
    Set
public:
property bool UseAirChangesPerHour {
    bool get ();
    void set (bool value);
}
member UseAirChangesPerHour : bool with get, set

Property Value

Boolean
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.UseCurrentViewOnly Property

EnergyDataSettingsUseCurrentViewOnly Property

True if only elements visible in the currently active view are used for generation of Energy Model.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UseCurrentViewOnly { get; set; }
Public Property UseCurrentViewOnly As Boolean
    Get
    Set
public:
property bool UseCurrentViewOnly {
    bool get ();
    void set (bool value);
}
member UseCurrentViewOnly : bool with get, set

Property Value

Boolean
Remarks
This setting is ignored if the currently active view is not a 3D view or AnalysisType is RoomsOrSpaces.
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.UseHeatingCredits Property

EnergyDataSettingsUseHeatingCredits Property

If true, Revit will use heating credits in the final load sum calculations. If false, Revit will ignore heating credits in the final load sum calculations.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UseHeatingCredits { get; set; }
Public Property UseHeatingCredits As Boolean
    Get
    Set
public:
property bool UseHeatingCredits {
    bool get ();
    void set (bool value);
}
member UseHeatingCredits : bool with get, set

Property Value

Boolean
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.UseOutsideAirPerArea Property

EnergyDataSettingsUseOutsideAirPerArea Property

True is user is specifying outside air per area, false otherwise.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UseOutsideAirPerArea { get; set; }
Public Property UseOutsideAirPerArea As Boolean
    Get
    Set
public:
property bool UseOutsideAirPerArea {
    bool get ();
    void set (bool value);
}
member UseOutsideAirPerArea : bool with get, set

Property Value

Boolean
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.UseOutsideAirPerPerson Property

EnergyDataSettingsUseOutsideAirPerPerson Property

True if user is specifying outside air per person, false otherwise.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UseOutsideAirPerPerson { get; set; }
Public Property UseOutsideAirPerPerson As Boolean
    Get
    Set
public:
property bool UseOutsideAirPerPerson {
    bool get ();
    void set (bool value);
}
member UseOutsideAirPerPerson : bool with get, set

Property Value

Boolean
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings Methods

The EnergyDataSettings type exposes the following members.

Methods
Name | Description
Public method ArePhasesModifiable Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element.
(Inherited from Element)
Public method CanBeHidden Indicates if the element can be hidden in the view.
(Inherited from Element)
Public method CanBeLocked Identifies if the element can be locked.
(Inherited from Element)
Public method CanDeleteSubelement Checks if given subelement can be removed from the element.
(Inherited from Element)
Public method CanHaveTypeAssigned Identifies if the element can have a type assigned.
(Inherited from Element)
Public method ChangeTypeId(ElementId) Changes the type of the element.
(Inherited from Element)
CheckAnalysisType | Checks that the analysis type falls within an appropriate range.
CheckBuildingConstructionClass | Checks that the building construction class falls within an appropriate range.
CheckBuildingEnvelope | Checks that the building envelope determination method falls within an appropriate range.
CheckBuildingHVACSystem | Checks that the building HVAC system falls within an appropriate range.
CheckBuildingOperatingSchedule | Checks that the building operating schedule falls within an appropriate range.
CheckBuildingType | Checks that the building type falls within an appropriate range.
Public method | CheckConstructionSetElement | Checks that the construction set ElementId is acceptable.
CheckExportCategory Checks whether the export category falls within the list:
  1. OST_Rooms
  2. OST_MEPSpaces
CheckExportComplexity | Checks that the export complexity falls within an appropriate range.
Public method | CheckGroundPlane(ElementId) | The ground plane should be an Element of type Level. This method checks to confirm that an ElementId is for a Level element.
CheckGroundPlane(Document, ElementId) | The ground plane should be an Element of type Level. This method checks to confirm that an ElementId is for a Level element.
Public method | CheckProjectPhase | Checks that the input element is a project phase.
CheckProjectReportType | Checks that the project report type falls within an appropriate range.
CheckRangeOfPercentageGlazing | Checks that the percentage glazing value is between 0.00 and 0.95.
CheckRangeOfPercentageSkylights | Checks that the percentage skylights value is between 0.00 and 0.95.
CheckRangeOfShadeDepth | Checks that the shade depth is greater than or equal to zero.
CheckRangeOfSillHeight | Checks that the sill height is greater than or equal to zero.
CheckRangeOfSkylightWidth | Checks that the skylight width is greater than or equal to eight inches.
CheckRangeOfSliverSpaceTolerance | Checks that the sliver space tolerance is greater than or equal to zero.
CheckServiceType | Checks that the service type falls within an appropriate range.
Public method DeleteEntity Deletes the existing entity created by %schema% in the element
(Inherited from Element)
Public method DeleteSubelement Removes a subelement from the element.
(Inherited from Element)
Public method DeleteSubelements Removes the subelements from the element.
(Inherited from Element)
Public method Dispose
(Inherited from Element)
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object)
Public method EvaluateAllParameterValues Evaluates all the parameters' values of the element.
(Inherited from Element)
Public method EvaluateParameterValues Evaluate the parameters' values of the element on the given parameter ID set.
(Inherited from Element)
GetBuildingConstructionSetElementId | Id of the building construction set.
Public method GetDependentElements Get all elements that, from a logical point of view, are the children of this Element.
(Inherited from Element)
Public method GetEntity Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise.
(Inherited from Element)
Public method GetEntitySchemaGuids Returns the Schema guids of any Entities stored in this element.
(Inherited from Element)
Public method GetExternalFileReference Gets information pertaining to the external file referenced by the element.
(Inherited from Element)
Public method GetExternalResourceReference Gets the ExternalResourceReference associated with a specified external resource type.
(Inherited from Element)
Public method GetExternalResourceReferenceExpanded Gets the collection of ExternalResourceReference associated with a specified external resource type.
(Inherited from Element)
Public method GetExternalResourceReferences Gets the map of the external resource references referenced by the element.
(Inherited from Element)
Public method GetExternalResourceReferencesExpanded Gets the expanded map of the external resource references referenced by the element.
(Inherited from Element)
GetFromDocument | Every project document has a EnergyDataSettings element. Family documents do not have EnergyDataSettings elements.
GetGeneratingElementIds Returns the ids of the element(s) that generated the input geometry object.
(Inherited from Element)
Public method GetGeometryObjectFromReference Retrieve one geometric primitive contained in the element given a reference.
(Inherited from Element)
Public method GetHashCode Serves as the default hash function.
(Inherited from Object)
Public method GetMaterialArea Gets the area of the material with the given id.
(Inherited from Element)
Public method GetMaterialIds Gets the element ids of all materials present in the element.
(Inherited from Element)
Public method GetMaterialVolume Gets the volume of the material with the given id.
(Inherited from Element)
Public method GetMonitoredLinkElementIds Provides the link instance IDs when the element is monitoring.
(Inherited from Element)
Public method GetMonitoredLocalElementIds Provides the local element IDs when the element is monitoring.
(Inherited from Element)
Public method GetOrderedParameters Gets the parameters associated to the element in order.
(Inherited from Element)
Public method GetParameter Retrieves a parameter from the element given identifier.
(Inherited from Element)
Public method GetParameterFormatOptions Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists.
(Inherited from Element)
Public method GetParameters Retrieves the parameters from the element via the given name.
(Inherited from Element)
Public method GetPhaseStatus Gets the status of a given element in the input phase
(Inherited from Element)
Public method | GetReportsFolderParsed | Gets the absolute reports folder path that is parsed from the original input.
Public method GetSubelements Returns the collection of element subelements.
(Inherited from Element)
Public method GetType Gets the Type of the current instance.
(Inherited from Object)
GetTypeId Returns the identifier of this element's type.
(Inherited from Element)
Public method GetValidTypes Obtains a set of types that are valid for this element.
(Inherited from Element)
Public method HasPhases Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.
(Inherited from Element)
Public method IsCreatedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element)
Public method IsDemolishedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element)
IsDocumentUsingEnergyDataAnalyticalModel | Get EnergyDataSettings element and if it exists, return result from getCreateAnalyticalModel.
Public method IsExternalFileReference Determines whether this Element represents an external file.
(Inherited from Element)
Public method IsHidden Identifies if the element has been permanently hidden in the view.
(Inherited from Element)
Public method IsMonitoringLinkElement Indicate whether an element is monitoring any elements in any linked models.
(Inherited from Element)
Public method IsMonitoringLocalElement Indicate whether an element is monitoring other local elements.
(Inherited from Element)
Public method IsPhaseCreatedValid Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element.
(Inherited from Element)
Public method IsPhaseDemolishedValid Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element.
(Inherited from Element)
Public method IsValidType(ElementId) Checks if given type is valid for this element.
(Inherited from Element)
Public method LookupParameter Attempts to find a parameter on the element which has the given name.
(Inherited from Element)
Public method RefersToExternalResourceReference Determines whether this Element uses external resources associated with a specified external resource type.
(Inherited from Element)
Public method RefersToExternalResourceReferences Determines whether this Element uses external resources.
(Inherited from Element)
Public method SetEntity Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten.
(Inherited from Element)
Public method | SetReportsFolder | Sets the reports folder path.
Public method ToString Returns a string that represents the current object.
(Inherited from Object)
Top
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.CheckAnalysisType Method

EnergyDataSettingsCheckAnalysisType Method

Checks that the analysis type falls within an appropriate range.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CheckAnalysisType(
    AnalysisMode analysisType
)
Public Shared Function CheckAnalysisType (
    analysisType As AnalysisMode
) As Boolean
public:
static bool CheckAnalysisType(
    AnalysisMode analysisType
)
static member CheckAnalysisType :
        analysisType : AnalysisMode -> bool

Parameters

analysisType AnalysisMode
The analysis type to be checked.

Return Value

Boolean
True if the analysis type falls within an appropriate range, false otherwise.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.CheckBuildingConstructionClass Method

EnergyDataSettingsCheckBuildingConstructionClass Method

Checks that the building construction class falls within an appropriate range.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CheckBuildingConstructionClass(
    HVACLoadConstructionClass buildingConstructionClass
)
Public Shared Function CheckBuildingConstructionClass (
    buildingConstructionClass As HVACLoadConstructionClass
) As Boolean
public:
static bool CheckBuildingConstructionClass(
    HVACLoadConstructionClass buildingConstructionClass
)
static member CheckBuildingConstructionClass :
        buildingConstructionClass : HVACLoadConstructionClass -> bool

Parameters

buildingConstructionClass HVACLoadConstructionClass
The building construction class to be checked.

Return Value

Boolean
True if the building construction class falls within an appropriate range, false otherwise.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.CheckBuildingEnvelope Method

EnergyDataSettingsCheckBuildingEnvelope Method

Checks that the building envelope determination method falls within an appropriate range.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CheckBuildingEnvelope(
    gbXMLExportBuildingEnvelope determinationMethod
)
Public Shared Function CheckBuildingEnvelope (
    determinationMethod As gbXMLExportBuildingEnvelope
) As Boolean
public:
static bool CheckBuildingEnvelope(
    gbXMLExportBuildingEnvelope determinationMethod
)
static member CheckBuildingEnvelope :
        determinationMethod : gbXMLExportBuildingEnvelope -> bool

Parameters

determinationMethod gbXMLExportBuildingEnvelope
The building envelope determination method to be checked.

Return Value

Boolean
True if the building envelope determination method falls within an appropriate range, false otherwise.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.CheckBuildingHVACSystem Method

EnergyDataSettingsCheckBuildingHVACSystem Method

Checks that the building HVAC system falls within an appropriate range.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CheckBuildingHVACSystem(
    gbXMLBuildingHVACSystem buildingHVACSystem
)
Public Shared Function CheckBuildingHVACSystem (
    buildingHVACSystem As gbXMLBuildingHVACSystem
) As Boolean
public:
static bool CheckBuildingHVACSystem(
    gbXMLBuildingHVACSystem buildingHVACSystem
)
static member CheckBuildingHVACSystem :
        buildingHVACSystem : gbXMLBuildingHVACSystem -> bool

Parameters

buildingHVACSystem gbXMLBuildingHVACSystem
The building HVAC system to be checked.

Return Value

Boolean
True if the building HVAC system falls within an appropriate range, false otherwise.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.CheckBuildingOperatingSchedule Method

EnergyDataSettingsCheckBuildingOperatingSchedule Method

Checks that the building operating schedule falls within an appropriate range.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CheckBuildingOperatingSchedule(
    gbXMLBuildingOperatingSchedule buildingOperatingSchedule
)
Public Shared Function CheckBuildingOperatingSchedule (
    buildingOperatingSchedule As gbXMLBuildingOperatingSchedule
) As Boolean
public:
static bool CheckBuildingOperatingSchedule(
    gbXMLBuildingOperatingSchedule buildingOperatingSchedule
)
static member CheckBuildingOperatingSchedule :
        buildingOperatingSchedule : gbXMLBuildingOperatingSchedule -> bool

Parameters

buildingOperatingSchedule gbXMLBuildingOperatingSchedule
The building operating schedule to be checked.

Return Value

Boolean
True if the building operating schedule falls within an appropriate range, false otherwise.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.CheckBuildingType Method

EnergyDataSettingsCheckBuildingType Method

Checks that the building type falls within an appropriate range.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CheckBuildingType(
    gbXMLBuildingType buildingType
)
Public Shared Function CheckBuildingType (
    buildingType As gbXMLBuildingType
) As Boolean
public:
static bool CheckBuildingType(
    gbXMLBuildingType buildingType
)
static member CheckBuildingType :
        buildingType : gbXMLBuildingType -> bool

Parameters

buildingType gbXMLBuildingType
The building type to be checked.

Return Value

Boolean
True if the building type falls within an appropriate range, false otherwise.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.CheckConstructionSetElement Method

EnergyDataSettingsCheckConstructionSetElement Method

Checks that the construction set ElementId is acceptable.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CheckConstructionSetElement(
    ElementId constructionSetElementId
)
Public Function CheckConstructionSetElement (
    constructionSetElementId As ElementId
) As Boolean
public:
bool CheckConstructionSetElement(
    ElementId^ constructionSetElementId
)
member CheckConstructionSetElement :
        constructionSetElementId : ElementId -> bool

Parameters

constructionSetElementId ElementId
The construction set ElementId to be checked.

Return Value

Boolean
True if the construction set ElementId is a valid construction set element, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.CheckExportCategory Method

EnergyDataSettingsCheckExportCategory Method

Checks whether the export category falls within the list:
  1. OST_Rooms
  2. OST_MEPSpaces

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CheckExportCategory(
    ElementId exportCategoryId
)
Public Shared Function CheckExportCategory (
    exportCategoryId As ElementId
) As Boolean
public:
static bool CheckExportCategory(
    ElementId^ exportCategoryId
)
static member CheckExportCategory :
        exportCategoryId : ElementId -> bool

Parameters

exportCategoryId ElementId
The export category to be checked.

Return Value

Boolean
True if the export category falls within the list, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.CheckExportComplexity Method

EnergyDataSettingsCheckExportComplexity Method

Checks that the export complexity falls within an appropriate range.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CheckExportComplexity(
    gbXMLExportComplexity exportComplexity
)
Public Shared Function CheckExportComplexity (
    exportComplexity As gbXMLExportComplexity
) As Boolean
public:
static bool CheckExportComplexity(
    gbXMLExportComplexity exportComplexity
)
static member CheckExportComplexity :
        exportComplexity : gbXMLExportComplexity -> bool

Parameters

exportComplexity gbXMLExportComplexity
The export complexity to be checked.

Return Value

Boolean
True if the export complexity falls within an appropriate range, false otherwise.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.CheckGroundPlane Method

EnergyDataSettingsCheckGroundPlane Method

Overload List
 | Name | Description
Public method | CheckGroundPlane(ElementId) | The ground plane should be an Element of type Level. This method checks to confirm that an ElementId is for a Level element.
 | CheckGroundPlane(Document, ElementId) | The ground plane should be an Element of type Level. This method checks to confirm that an ElementId is for a Level element.
Top
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.CheckGroundPlane(ElementId) Method

EnergyDataSettingsCheckGroundPlane(ElementId) Method

The ground plane should be an Element of type Level. This method checks to confirm that an ElementId is for a Level element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CheckGroundPlane(
    ElementId groundPlaneId
)
Public Function CheckGroundPlane (
    groundPlaneId As ElementId
) As Boolean
public:
bool CheckGroundPlane(
    ElementId^ groundPlaneId
)
member CheckGroundPlane :
        groundPlaneId : ElementId -> bool

Parameters

groundPlaneId ElementId
The element id to be checked to confirm that it is suitable to be a ground plane (i.e., that it is a level) or that it is invalidElementId. Setting ground plane with invalidElementId will lead to the ground plane being "reset".

Return Value

Boolean
True if the input element is a level or invalidElementId, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

EnergyDataSettings Class
CheckGroundPlane Overload
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.CheckGroundPlane(Document, ElementId) Method

EnergyDataSettingsCheckGroundPlane(Document, ElementId) Method

The ground plane should be an Element of type Level. This method checks to confirm that an ElementId is for a Level element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CheckGroundPlane(
    Document ccda,
    ElementId groundPlaneId
)
Public Shared Function CheckGroundPlane (
    ccda As Document,
    groundPlaneId As ElementId
) As Boolean
public:
static bool CheckGroundPlane(
    Document^ ccda,
    ElementId^ groundPlaneId
)
static member CheckGroundPlane :
        ccda : Document *
        groundPlaneId : ElementId -> bool

Parameters

ccda Document
The Document.
groundPlaneId ElementId
The element id to be checked to confirm that it is suitable to be a ground plane (i.e., that it is a level) or that it is invalidElementId. Setting ground plane with invalidElementId will lead to the ground plane being "reset".

Return Value

Boolean
True if the input element is a level or invalidElementId, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

EnergyDataSettings Class
CheckGroundPlane Overload
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.CheckProjectPhase Method

EnergyDataSettingsCheckProjectPhase Method

Checks that the input element is a project phase.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CheckProjectPhase(
    ElementId projectPhaseId
)
Public Function CheckProjectPhase (
    projectPhaseId As ElementId
) As Boolean
public:
bool CheckProjectPhase(
    ElementId^ projectPhaseId
)
member CheckProjectPhase :
        projectPhaseId : ElementId -> bool

Parameters

projectPhaseId ElementId
The element to be checked.

Return Value

Boolean
True if the input element is a project phase, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.CheckProjectReportType Method

EnergyDataSettingsCheckProjectReportType Method

Checks that the project report type falls within an appropriate range.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CheckProjectReportType(
    HVACLoadLoadsReportType projectReportType
)
Public Shared Function CheckProjectReportType (
    projectReportType As HVACLoadLoadsReportType
) As Boolean
public:
static bool CheckProjectReportType(
    HVACLoadLoadsReportType projectReportType
)
static member CheckProjectReportType :
        projectReportType : HVACLoadLoadsReportType -> bool

Parameters

projectReportType HVACLoadLoadsReportType
The project report type to be checked.

Return Value

Boolean
True if the project report type falls within an appropriate range, false otherwise.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.CheckRangeOfPercentageGlazing Method

EnergyDataSettingsCheckRangeOfPercentageGlazing Method

Checks that the percentage glazing value is between 0.00 and 0.95.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CheckRangeOfPercentageGlazing(
    double percentageGlazing
)
Public Shared Function CheckRangeOfPercentageGlazing (
    percentageGlazing As Double
) As Boolean
public:
static bool CheckRangeOfPercentageGlazing(
    double percentageGlazing
)
static member CheckRangeOfPercentageGlazing :
        percentageGlazing : float -> bool

Parameters

percentageGlazing Double
The percentage glazing to be checked.

Return Value

Boolean
True if the percentage glazing value is between 0.00 and 0.95, false otherwise.
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.CheckRangeOfPercentageSkylights Method

EnergyDataSettingsCheckRangeOfPercentageSkylights Method

Checks that the percentage skylights value is between 0.00 and 0.95.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CheckRangeOfPercentageSkylights(
    double percentageSkylights
)
Public Shared Function CheckRangeOfPercentageSkylights (
    percentageSkylights As Double
) As Boolean
public:
static bool CheckRangeOfPercentageSkylights(
    double percentageSkylights
)
static member CheckRangeOfPercentageSkylights :
        percentageSkylights : float -> bool

Parameters

percentageSkylights Double
The percentage skylights to be checked.

Return Value

Boolean
True if the percentage skylights value is between 0.00 and 0.95, false otherwise.
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.CheckRangeOfShadeDepth Method

EnergyDataSettingsCheckRangeOfShadeDepth Method

Checks that the shade depth is greater than or equal to zero.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CheckRangeOfShadeDepth(
    double shadeDepth
)
Public Shared Function CheckRangeOfShadeDepth (
    shadeDepth As Double
) As Boolean
public:
static bool CheckRangeOfShadeDepth(
    double shadeDepth
)
static member CheckRangeOfShadeDepth :
        shadeDepth : float -> bool

Parameters

shadeDepth Double
The shade depth to be checked.

Return Value

Boolean
True if the shade depth is greater than or equal to zero, false otherwise.
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.CheckRangeOfSillHeight Method

EnergyDataSettingsCheckRangeOfSillHeight Method

Checks that the sill height is greater than or equal to zero.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CheckRangeOfSillHeight(
    double sillHeight
)
Public Shared Function CheckRangeOfSillHeight (
    sillHeight As Double
) As Boolean
public:
static bool CheckRangeOfSillHeight(
    double sillHeight
)
static member CheckRangeOfSillHeight :
        sillHeight : float -> bool

Parameters

sillHeight Double
The sill height to be checked.

Return Value

Boolean
True if the sill height falls is greater than or equal to zero, false otherwise.
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.CheckRangeOfSkylightWidth Method

EnergyDataSettingsCheckRangeOfSkylightWidth Method

Checks that the skylight width is greater than or equal to eight inches.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CheckRangeOfSkylightWidth(
    double skylightWidth
)
Public Shared Function CheckRangeOfSkylightWidth (
    skylightWidth As Double
) As Boolean
public:
static bool CheckRangeOfSkylightWidth(
    double skylightWidth
)
static member CheckRangeOfSkylightWidth :
        skylightWidth : float -> bool

Parameters

skylightWidth Double
The skylight width to be checked. Should be greater than or equal to eight inches.

Return Value

Boolean
True if the skylight width is greater than or equal to eight inches, false otherwise.
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.CheckRangeOfSliverSpaceTolerance Method

EnergyDataSettingsCheckRangeOfSliverSpaceTolerance Method

Checks that the sliver space tolerance is greater than or equal to zero.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CheckRangeOfSliverSpaceTolerance(
    double silverSpaceTolerance
)
Public Shared Function CheckRangeOfSliverSpaceTolerance (
    silverSpaceTolerance As Double
) As Boolean
public:
static bool CheckRangeOfSliverSpaceTolerance(
    double silverSpaceTolerance
)
static member CheckRangeOfSliverSpaceTolerance :
        silverSpaceTolerance : float -> bool

Parameters

silverSpaceTolerance Double
The sliver space tolerance to be checked.

Return Value

Boolean
Returns true if the sliver space tolerance is greater than or equal to zero, false otherwise.
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.CheckServiceType Method

EnergyDataSettingsCheckServiceType Method

Checks that the service type falls within an appropriate range.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CheckServiceType(
    gbXMLServiceType serviceType
)
Public Shared Function CheckServiceType (
    serviceType As gbXMLServiceType
) As Boolean
public:
static bool CheckServiceType(
    gbXMLServiceType serviceType
)
static member CheckServiceType :
        serviceType : gbXMLServiceType -> bool

Parameters

serviceType gbXMLServiceType
The service type to be checked.

Return Value

Boolean
True if the service type falls within an appropriate range, false otherwise.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.GetBuildingConstructionSetElementId Method

EnergyDataSettingsGetBuildingConstructionSetElementId Method

Id of the building construction set.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static ElementId GetBuildingConstructionSetElementId(
    Document ccda
)
Public Shared Function GetBuildingConstructionSetElementId (
    ccda As Document
) As ElementId
public:
static ElementId^ GetBuildingConstructionSetElementId(
    Document^ ccda
)
static member GetBuildingConstructionSetElementId :
        ccda : Document -> ElementId

Parameters

ccda Document

Return Value

ElementId
Returns the id of the building construction set.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
The building construction set is the default project construction set used when spaces are not assigned a construction.
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.GetFromDocument Method

EnergyDataSettingsGetFromDocument Method

Every project document has a EnergyDataSettings element. Family documents do not have EnergyDataSettings elements.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static EnergyDataSettings GetFromDocument(
    Document cda
)
Public Shared Function GetFromDocument (
    cda As Document
) As EnergyDataSettings
public:
static EnergyDataSettings^ GetFromDocument(
    Document^ cda
)
static member GetFromDocument :
        cda : Document -> EnergyDataSettings

Parameters

cda Document
The document.

Return Value

EnergyDataSettings
Returns the EnergyDataSettings element or NULL.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.GetReportsFolderParsed Method

EnergyDataSettingsGetReportsFolderParsed Method

Gets the absolute reports folder path that is parsed from the original input.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GetReportsFolderParsed()
Public Function GetReportsFolderParsed As String
public:
String^ GetReportsFolderParsed()
member GetReportsFolderParsed : unit -> string

Return Value

String
The reports folder path after parsing the input string.
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.IsDocumentUsingEnergyDataAnalyticalModel Method

EnergyDataSettingsIsDocumentUsingEnergyDataAnalyticalModel Method

Get EnergyDataSettings element and if it exists, return result from getCreateAnalyticalModel.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsDocumentUsingEnergyDataAnalyticalModel(
    Document ccda
)
Public Shared Function IsDocumentUsingEnergyDataAnalyticalModel (
    ccda As Document
) As Boolean
public:
static bool IsDocumentUsingEnergyDataAnalyticalModel(
    Document^ ccda
)
static member IsDocumentUsingEnergyDataAnalyticalModel :
        ccda : Document -> bool

Parameters

ccda Document
The document.

Return Value

Boolean
Returns true if the Conceptual Energy Analytical Model is enabled, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings.SetReportsFolder Method

EnergyDataSettingsSetReportsFolder Method

Sets the reports folder path.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetReportsFolder(
    string folderPath
)
Public Sub SetReportsFolder (
    folderPath As String
)
public:
void SetReportsFolder(
    String^ folderPath
)
member SetReportsFolder :
        folderPath : string -> unit

Parameters

folderPath String
The string to specify the path. It may include the special label for project name.
Exceptions
Exception | Condition
ArgumentException | A folder path cannot contain special characters.
ArgumentNullException | A non-optional argument was null
See Also

Reference

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyModelType Enumeration

This enum is used to define if the energy model is based on rooms/spaces, building elements or analysis mode in EnergyDataSettings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum EnergyModelType
Public Enumeration EnergyModelType
public enum class EnergyModelType
type EnergyModelType
Members
Member name | Value | Description
SpatialElement | 0 | Energy model based on rooms or spaces.
BuildingElement | 1 | The building element based energy analytical model.
AnalysisMode | 2 | Energy model based on analysis mode in EnergyDataSettings.
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


FieldDomainPoints Class

Abstract base class for various classes of field domain points
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DB.AnalysisFieldDomainPoints
Autodesk.Revit.DB.AnalysisFieldDomainPointsByParameter
Autodesk.Revit.DB.AnalysisFieldDomainPointsByUV
Autodesk.Revit.DB.AnalysisFieldDomainPointsByXYZ

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FieldDomainPoints : IDisposable
Public Class FieldDomainPoints
    Implements IDisposable
public ref class FieldDomainPoints : IDisposable
type FieldDomainPoints =
    class
        interface IDisposable
    end

The FieldDomainPoints type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the FieldDomainPoints
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


FieldDomainPoints Properties

The FieldDomainPoints type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

FieldDomainPoints Class
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPoints.IsValidObject Property

FieldDomainPointsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

FieldDomainPoints Class
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPoints Methods

The FieldDomainPoints type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FieldDomainPoints Class
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPoints.Dispose Method

FieldDomainPointsDispose Method

Releases all resources used by the FieldDomainPoints

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FieldDomainPoints Class
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPointsByParameter Class

Represents a set of one-dimensional point coordinates (defined usually on curve)
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DB.AnalysisFieldDomainPoints
Autodesk.Revit.DB.AnalysisFieldDomainPointsByParameter

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FieldDomainPointsByParameter : FieldDomainPoints
Public Class FieldDomainPointsByParameter
    Inherits FieldDomainPoints
public ref class FieldDomainPointsByParameter : public FieldDomainPoints
type FieldDomainPointsByParameter =
    class
        inherit FieldDomainPoints
    end

The FieldDomainPointsByParameter type exposes the following members.

Constructors
 | Name | Description
Public method | FieldDomainPointsByParameter | Creates object from an array of one-dimensional point coordinates
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FieldDomainPoints)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from FieldDomainPoints)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Example
C#
VB
C++
F#
Copy
Document doc = commandData.Application.ActiveUIDocument.Document;
UIDocument uiDoc = commandData.Application.ActiveUIDocument;

SpatialFieldManager sfm = SpatialFieldManager.GetSpatialFieldManager(doc.ActiveView);
if (sfm == null)
{
    sfm = SpatialFieldManager.CreateSpatialFieldManager(doc.ActiveView, 1);
}

ReferenceArray ra = new ReferenceArray();
Reference curveRef = uiDoc.Selection.PickObject(ObjectType.Element, "Select a curve");
ra.Append(curveRef);

foreach (Reference reference in ra)
{
    ModelCurve modelCurve = doc.GetElement(reference) as ModelCurve;
    Curve curve = modelCurve.GeometryCurve;
    if (curve == null)
    {
        TaskDialog.Show("Error", "Must select a curve");
        return Result.Cancelled;
    }
    else
    {
        int idx = sfm.AddSpatialFieldPrimitive(curve.Reference);

        IList<double> pts = new List<double>();

        double u = curve.GetEndParameter(0);
        double range = curve.GetEndParameter(1) - u;
        for (int ii = 0; ii < 10; ii++)
        {
            pts.Add(u);
            u = u + range / 10;
        }

        FieldDomainPointsByParameter pnts = new FieldDomainPointsByParameter(pts);

        List<double> doubleList = new List<double>();
        IList<ValueAtPoint> valList = new List<ValueAtPoint>();
        double x = 0;
        while (valList.Count < pts.Count)
        //for (double x = 0; x < 1; x = x + 0.1)
        {
            doubleList.Clear();
            doubleList.Add(x * 10);
            valList.Add(new ValueAtPoint(doubleList));
            x = x + 0.1;
        }
        FieldValues vals = new FieldValues(valList);

        AnalysisResultSchema resultSchema = new AnalysisResultSchema("Schema Name", "Description");
        int schemaIndex = sfm.RegisterResult(resultSchema);
        sfm.UpdateSpatialFieldPrimitive(idx, pnts, vals, schemaIndex);
    }
}
Dim doc As Document = commandData.Application.ActiveUIDocument.Document
Dim uiDoc As UIDocument = commandData.Application.ActiveUIDocument

Dim sfm As SpatialFieldManager = SpatialFieldManager.GetSpatialFieldManager(doc.ActiveView)
If sfm Is Nothing Then
   sfm = SpatialFieldManager.CreateSpatialFieldManager(doc.ActiveView, 1)
End If

Dim ra As New ReferenceArray()
Dim curveRef As Reference = uiDoc.Selection.PickObject(ObjectType.Element, "Select a curve")
ra.Append(curveRef)

For Each reference As Reference In ra
   Dim modelCurve As ModelCurve = TryCast(doc.GetElement(reference), ModelCurve)
   Dim curve As Curve = modelCurve.GeometryCurve
   If curve Is Nothing Then
      TaskDialog.Show("Error", "Must select a curve")
      Return Result.Cancelled
   Else
      Dim idx As Integer = sfm.AddSpatialFieldPrimitive(curve.Reference)

      Dim pts As IList(Of Double) = New List(Of Double)()

      Dim u As Double = curve.GetEndParameter(0)
      Dim range As Double = curve.GetEndParameter(1) - u
      For ii As Integer = 0 To 9
         pts.Add(u)
         u = u + range / 10
      Next

      Dim pnts As New FieldDomainPointsByParameter(pts)

      Dim doubleList As New List(Of Double)()
      Dim valList As IList(Of ValueAtPoint) = New List(Of ValueAtPoint)()
      Dim x As Double = 0
      While valList.Count < pts.Count
         'for (double x = 0; x < 1; x = x + 0.1)
         doubleList.Clear()
         doubleList.Add(x * 10)
         valList.Add(New ValueAtPoint(doubleList))
         x = x + 0.1
      End While
      Dim vals As New FieldValues(valList)

      Dim resultSchema As New AnalysisResultSchema("Schema Name", "Description")
      Dim schemaIndex As Integer = sfm.RegisterResult(resultSchema)
      sfm.UpdateSpatialFieldPrimitive(idx, pnts, vals, schemaIndex)
   End If
Next

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


FieldDomainPointsByParameter Constructor

Creates object from an array of one-dimensional point coordinates

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FieldDomainPointsByParameter(
    IList<double> points
)
Public Sub New (
    points As IList(Of Double)
)
public:
FieldDomainPointsByParameter(
    IList<double>^ points
)
new :
        points : IList<float> -> FieldDomainPointsByParameter

Parameters

points IList Double
Array of one-dimensional point coordinates representing domain points (using raw parameters when on a curve)
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FieldDomainPointsByParameter Class
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPointsByParameter Properties

The FieldDomainPointsByParameter type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FieldDomainPoints)
Top
See Also

Reference

FieldDomainPointsByParameter Class
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPointsByParameter Methods

The FieldDomainPointsByParameter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from FieldDomainPoints)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FieldDomainPointsByParameter Class
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPointsByUV Class

Represents a set of two-dimensional point coordinates (defined usually on surface)
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DB.AnalysisFieldDomainPoints
Autodesk.Revit.DB.AnalysisFieldDomainPointsByUV

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FieldDomainPointsByUV : FieldDomainPoints
Public Class FieldDomainPointsByUV
    Inherits FieldDomainPoints
public ref class FieldDomainPointsByUV : public FieldDomainPoints
type FieldDomainPointsByUV =
    class
        inherit FieldDomainPoints
    end

The FieldDomainPointsByUV type exposes the following members.

Constructors
 | Name | Description
Public method | FieldDomainPointsByUV(IListUV) | Creates object from an array of two-dimensional point coordinates
Public method | FieldDomainPointsByUV(IListUV, ICollectionDouble, ICollectionDouble) | Creates object from an array of two-dimensional point coordinates
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FieldDomainPoints)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from FieldDomainPoints)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetGridCoordinates | Set u and v coordinates that specify a grid on the surface. The display of the grid is controlled by AnalysisDisplayColoredSurfaceSettings::getShowGridLines(). If AnalysisDisplayColoredSurfaceSettings::getShowGridLines() returns true and both sets are empty then a grid will be displayed using a default spacing; if only one of the sets is non-empty, then only the corresponding set of grid lines will be displayed, i.e. the grid will consist solely of parallel lines at the specified coordinates.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


FieldDomainPointsByUV Constructor

Overload List
 | Name | Description
Public method | FieldDomainPointsByUV(IListUV) | Creates object from an array of two-dimensional point coordinates
Public method | FieldDomainPointsByUV(IListUV, ICollectionDouble, ICollectionDouble) | Creates object from an array of two-dimensional point coordinates
Top
See Also

Reference

FieldDomainPointsByUV Class
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPointsByUV(IList<UV>) Constructor

FieldDomainPointsByUV(IListUV) Constructor

Creates object from an array of two-dimensional point coordinates

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FieldDomainPointsByUV(
    IList<UV> points
)
Public Sub New (
    points As IList(Of UV)
)
public:
FieldDomainPointsByUV(
    IList<UV^>^ points
)
new :
        points : IList<UV> -> FieldDomainPointsByUV

Parameters

points IList UV
Array of two-dimensional point coordinates representing domain points (usually on surface)
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FieldDomainPointsByUV Class
FieldDomainPointsByUV Overload
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPointsByUV(IList<UV>, ICollection<Double>, ICollection<Double>) Constructor

FieldDomainPointsByUV(IListUV, ICollectionDouble, ICollectionDouble) Constructor

Creates object from an array of two-dimensional point coordinates

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FieldDomainPointsByUV(
    IList<UV> points,
    ICollection<double> uCoordinates,
    ICollection<double> vCoordinates
)
Public Sub New (
    points As IList(Of UV),
    uCoordinates As ICollection(Of Double),
    vCoordinates As ICollection(Of Double)
)
public:
FieldDomainPointsByUV(
    IList<UV^>^ points,
    ICollection<double>^ uCoordinates,
    ICollection<double>^ vCoordinates
)
new :
        points : IList<UV> *
        uCoordinates : ICollection<float> *
        vCoordinates : ICollection<float> -> FieldDomainPointsByUV

Parameters

points IList UV
Array of two-dimensional point coordinates representing domain points (usually on surface)
uCoordinates ICollection Double
Set of u coordinates at which to draw grid lines on the surface
vCoordinates ICollection Double
Set of v coordinates at which to draw grid lines on the surface
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FieldDomainPointsByUV Class
FieldDomainPointsByUV Overload
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPointsByUV Properties

The FieldDomainPointsByUV type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FieldDomainPoints)
Top
See Also

Reference

FieldDomainPointsByUV Class
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPointsByUV Methods

The FieldDomainPointsByUV type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from FieldDomainPoints)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetGridCoordinates | Set u and v coordinates that specify a grid on the surface. The display of the grid is controlled by AnalysisDisplayColoredSurfaceSettings::getShowGridLines(). If AnalysisDisplayColoredSurfaceSettings::getShowGridLines() returns true and both sets are empty then a grid will be displayed using a default spacing; if only one of the sets is non-empty, then only the corresponding set of grid lines will be displayed, i.e. the grid will consist solely of parallel lines at the specified coordinates.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FieldDomainPointsByUV Class
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPointsByUV.SetGridCoordinates Method

FieldDomainPointsByUVSetGridCoordinates Method

Set u and v coordinates that specify a grid on the surface. The display of the grid is controlled by AnalysisDisplayColoredSurfaceSettings::getShowGridLines(). If AnalysisDisplayColoredSurfaceSettings::getShowGridLines() returns true and both sets are empty then a grid will be displayed using a default spacing; if only one of the sets is non-empty, then only the corresponding set of grid lines will be displayed, i.e. the grid will consist solely of parallel lines at the specified coordinates.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetGridCoordinates(
    ICollection<double> uCoordinates,
    ICollection<double> vCoordinates
)
Public Sub SetGridCoordinates (
    uCoordinates As ICollection(Of Double),
    vCoordinates As ICollection(Of Double)
)
public:
void SetGridCoordinates(
    ICollection<double>^ uCoordinates,
    ICollection<double>^ vCoordinates
)
member SetGridCoordinates :
        uCoordinates : ICollection<float> *
        vCoordinates : ICollection<float> -> unit

Parameters

uCoordinates ICollection Double
Set of u coordinates at which to draw grid lines
vCoordinates ICollection Double
Set of v coordinates at which to draw grid lines
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FieldDomainPointsByUV Class
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPointsByXYZ Class

Represents a set of three-dimensional point coordinates
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DB.AnalysisFieldDomainPoints
Autodesk.Revit.DB.AnalysisFieldDomainPointsByXYZ

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FieldDomainPointsByXYZ : FieldDomainPoints
Public Class FieldDomainPointsByXYZ
    Inherits FieldDomainPoints
public ref class FieldDomainPointsByXYZ : public FieldDomainPoints
type FieldDomainPointsByXYZ =
    class
        inherit FieldDomainPoints
    end

The FieldDomainPointsByXYZ type exposes the following members.

Constructors
 | Name | Description
Public method | FieldDomainPointsByXYZ | Creates object from an array of three-dimensional point coordinates
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FieldDomainPoints)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from FieldDomainPoints)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


FieldDomainPointsByXYZ Constructor

Creates object from an array of three-dimensional point coordinates

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FieldDomainPointsByXYZ(
    IList<XYZ> points
)
Public Sub New (
    points As IList(Of XYZ)
)
public:
FieldDomainPointsByXYZ(
    IList<XYZ^>^ points
)
new :
        points : IList<XYZ> -> FieldDomainPointsByXYZ

Parameters

points IList XYZ
Array of three-dimensional point coordinates representing domain points
Exceptions
Exception | Condition
ArgumentException | Thrown when supplied array points contain too many members (over 1000)
ArgumentNullException | A non-optional argument was null
See Also

Reference

FieldDomainPointsByXYZ Class
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPointsByXYZ Properties

The FieldDomainPointsByXYZ type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FieldDomainPoints)
Top
See Also

Reference

FieldDomainPointsByXYZ Class
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPointsByXYZ Methods

The FieldDomainPointsByXYZ type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from FieldDomainPoints)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FieldDomainPointsByXYZ Class
Autodesk.Revit.DB.Analysis Namespace


FieldValues Class

Contains values corresponding to domain points. Each domain point may have an array of values, each corresponding to a separate "measurement" for which this value was calculated.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DB.AnalysisFieldValues

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FieldValues : IDisposable
Public Class FieldValues
    Implements IDisposable
public ref class FieldValues : IDisposable
type FieldValues =
    class
        interface IDisposable
    end

The FieldValues type exposes the following members.

Constructors
 | Name | Description
Public method | FieldValues(FieldValues) | Creates a copy of the given FieldValues instance.
Public method | FieldValues(IListValueAtPoint) | Creates object from an array of domain point values
Public method | FieldValues(IListVectorAtPoint) | Creates object from an array of domain point vectors
Public method | FieldValues(IListValueAtPoint, XYZ) | Creates object from an array of domain point values
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the FieldValues
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


FieldValues Constructor

Overload List
 | Name | Description
Public method | FieldValues(FieldValues) | Creates a copy of the given FieldValues instance.
Public method | FieldValues(IListValueAtPoint) | Creates object from an array of domain point values
Public method | FieldValues(IListVectorAtPoint) | Creates object from an array of domain point vectors
Public method | FieldValues(IListValueAtPoint, XYZ) | Creates object from an array of domain point values
Top
See Also

Reference

FieldValues Class
Autodesk.Revit.DB.Analysis Namespace


FieldValues(FieldValues) Constructor

Creates a copy of the given FieldValues instance.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FieldValues(
    FieldValues otherObject
)
Public Sub New (
    otherObject As FieldValues
)
public:
FieldValues(
    FieldValues^ otherObject
)
new :
        otherObject : FieldValues -> FieldValues

Parameters

otherObject FieldValues
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

FieldValues Class
FieldValues Overload
Autodesk.Revit.DB.Analysis Namespace


FieldValues(IList<ValueAtPoint>) Constructor

FieldValues(IListValueAtPoint) Constructor

Creates object from an array of domain point values

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FieldValues(
    IList<ValueAtPoint> valueAtPoint
)
Public Sub New (
    valueAtPoint As IList(Of ValueAtPoint)
)
public:
FieldValues(
    IList<ValueAtPoint^>^ valueAtPoint
)
new :
        valueAtPoint : IList<ValueAtPoint> -> FieldValues

Parameters

valueAtPoint IList ValueAtPoint
Array of values, each corresponding to a domain point
Exceptions
Exception | Condition
ArgumentException | valueAtPoint array contains members with different numbers of measurements
ArgumentNullException | A non-optional argument was null
See Also

Reference

FieldValues Class
FieldValues Overload
Autodesk.Revit.DB.Analysis Namespace


FieldValues(IList<VectorAtPoint>) Constructor

FieldValues(IListVectorAtPoint) Constructor

Creates object from an array of domain point vectors

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FieldValues(
    IList<VectorAtPoint> vectorAtPoint
)
Public Sub New (
    vectorAtPoint As IList(Of VectorAtPoint)
)
public:
FieldValues(
    IList<VectorAtPoint^>^ vectorAtPoint
)
new :
        vectorAtPoint : IList<VectorAtPoint> -> FieldValues

Parameters

vectorAtPoint IList VectorAtPoint
Array of vectors, each corresponding to a domain point
Exceptions
Exception | Condition
ArgumentException | Members of vectorAtPoint contain different numbers of measurements
ArgumentNullException | A non-optional argument was null
See Also

Reference

FieldValues Class
FieldValues Overload
Autodesk.Revit.DB.Analysis Namespace


FieldValues(IList<ValueAtPoint>, XYZ) Constructor

FieldValues(IListValueAtPoint, XYZ) Constructor

Creates object from an array of domain point values

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FieldValues(
    IList<ValueAtPoint> valueAtPoint,
    XYZ unitDirection
)
Public Sub New (
    valueAtPoint As IList(Of ValueAtPoint),
    unitDirection As XYZ
)
public:
FieldValues(
    IList<ValueAtPoint^>^ valueAtPoint,
    XYZ^ unitDirection
)
new :
        valueAtPoint : IList<ValueAtPoint> *
        unitDirection : XYZ -> FieldValues

Parameters

valueAtPoint IList ValueAtPoint
Array of values, each corresponding to a domain point
unitDirection XYZ
Unit vector that gives the same direction for values (for diagrams)
Exceptions
Exception | Condition
ArgumentException | Members of valueAtPoint contain different numbers of measurements -or- unitDirection is not a unit vector
ArgumentNullException | A non-optional argument was null
See Also

Reference

FieldValues Class
FieldValues Overload
Autodesk.Revit.DB.Analysis Namespace


FieldValues Properties

The FieldValues type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

FieldValues Class
Autodesk.Revit.DB.Analysis Namespace


FieldValues.IsValidObject Property

FieldValuesIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

FieldValues Class
Autodesk.Revit.DB.Analysis Namespace


FieldValues Methods

The FieldValues type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

FieldValues Class
Autodesk.Revit.DB.Analysis Namespace


FieldValues.Dispose Method

FieldValuesDispose Method

Releases all resources used by the FieldValues

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

FieldValues Class
Autodesk.Revit.DB.Analysis Namespace


gbXMLBuildingHVACSystem Enumeration

Enumerations for gbXML (Green Building XML) format, used for energy analysis, schema version 0.34.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum gbXMLBuildingHVACSystem
Public Enumeration gbXMLBuildingHVACSystem
public enum class gbXMLBuildingHVACSystem
type gbXMLBuildingHVACSystem
Members
Member name | Value | Description
TwelveSEERSPointNineAFUESplitPackagedGasFiveToElevenTon | 0 |
ElevenPointThreeEERPackagedVAVEightyFourPointFourPercentBoilerHeating | 1 |
CentralVAVHWHeatChillerFivePointNinetySixCOPBoilersEightyFourPoint5Eff | 2 |
FourPipeFanCoilSystemChillerFivePointNinetySixCOPBoilersEightFourPointFiveEff | 3 |
CentralVAVElectricResistanceHeatChillerFivePointNinetySixCOP | 4 |
TwelveSEERSevenPointSevenHSPFSplitPackagedHeatPump | 5 |
TwoPipeFanCoilSystemChillerFivePointNinetySixCOPBoilersEightyFourPointFiveEff | 6 |
TwelveSEEREightPointThreeHSPFPackagedTerminalHeatPumpPTAC | 7 |
ResidentialSeventeenSEERNinePointSixHSPFSplitHPLessThanFivePointFiveTon | 8 |
UnderfloorAirDistribution | 9 |
ResidentialFourteenSEERPointNineAFUESplitPackagedGasLessThanFivePointFiveTon | 10 |
ResidentialFourteenSEEREightPointThreeHSPFSplitPackagedHeatPump | 11 |
NoOfHVACSystemEnums | 12 |
Remarks
This enumeration corresponds to the HVAC System attribute in gbXML and is used to specify the Building HVAC System.
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


gbXMLBuildingOperatingSchedule Enumeration

Enumerations for gbXML (Green Building XML) format, used for energy analysis, schema version 0.34.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum gbXMLBuildingOperatingSchedule
Public Enumeration gbXMLBuildingOperatingSchedule
public enum class gbXMLBuildingOperatingSchedule
type gbXMLBuildingOperatingSchedule
Members
Member name | Value | Description
DefaultOperatingSchedule | 0 |
TwentyFourHourSevenDayFacility | 1 |
TwentyFourHourHourSixDayFacility | 2 |
TwentyFourHourHourFiveDayFacility | 3 |
TwelveHourSevenDayFacility | 4 |
TwelveHourSixDayFacility | 5 |
TwelveHourFiveDayFacility | 6 |
KindergartenThruTwelveGradeSchool | 7 |
YearRoundSchool | 8 |
TheaterPerformingArts | 9 |
Worship | 10 |
NoOfOperatingScheduleEnums | 11 |
Remarks
This enumeration corresponds to the buildingType attribute in gbXML and is used to specify the building operating schedule.
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


gbXMLBuildingType Enumeration

Enumerations for gbXML (Green Building XML) format, used for energy analysis, schema version 0.34.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum gbXMLBuildingType
Public Enumeration gbXMLBuildingType
public enum class gbXMLBuildingType
type gbXMLBuildingType
Members
Member name | Value | Description
AutomotiveFacility | 0 |
ConventionCenter | 1 |
Courthouse | 2 |
DiningBarLoungeOrLeisure | 3 |
DiningCafeteriaFastFood | 4 |
DiningFamily | 5 |
Dormitory | 6 |
ExerciseCenter | 7 |
FireStation | 8 |
Gymnasium | 9 |
NoBuildingType | -1 |
HospitalOrHealthcare | 10 |
Hotel | 11 |
Library | 12 |
Manufacturing | 13 |
Motel | 14 |
MotionPictureTheatre | 15 |
MultiFamily | 16 |
Museum | 17 |
Office | 18 |
ParkingGarage | 19 |
CustomizeBuildingType | -2 |
Penitentiary | 20 |
PerformingArtsTheater | 21 |
PoliceStation | 22 |
PostOffice | 23 |
ReligiousBuilding | 24 |
Retail | 25 |
SchoolOrUniversity | 26 |
SingleFamily | 27 |
SportsArena | 28 |
TownHall | 29 |
Transportation | 30 |
Warehouse | 31 |
Workshop | 32 |
NoOfBuildingTypes | 33 |
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


gbXMLConditionType Enumeration

This enumeration corresponds to the conditionType attribute in gbXML. The enumerated attribute identifies the type of heating, cooling, or ventilation the space has.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum gbXMLConditionType
Public Enumeration gbXMLConditionType
public enum class gbXMLConditionType
type gbXMLConditionType
Members
Member name | Value | Description
Heated | 0 |
Cooled | 1 |
HeatedAndCooled | 2 |
Unconditioned | 3 |
Vented | 4 |
NaturallyVentedOnly | 5 |
NoOfConditionTypes | 6 |
NoConditionType | -1 |
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


gbXMLExportBuildingEnvelope Enumeration

Indicates the determination method for the building envelope

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum gbXMLExportBuildingEnvelope
Public Enumeration gbXMLExportBuildingEnvelope
public enum class gbXMLExportBuildingEnvelope
type gbXMLExportBuildingEnvelope
Members
Member name | Value | Description
UseFunctionParameter | 0 | This method uses the Function type parameter of Walls, Floors and Building Pads to determinate the building elements considered to be part of the building envelope. If a wall has one adjacent space, analytical surface originated from the wall will be classified as exterior surfaces. If a wall has two adjacent spaces and its function is Exterior, Foundation, Retaining, or Soffit, analytical surface originated from the wall will be classified as interior surfaces. If thw wall's function is Interior or Core Shaft, analytical surface originated from the wall will be classfied interior surfaces, regardless of the number of adjacent spaces.
IdentifyExteriorElements | 1 | This method uses a combination of ray-casting and flood-fill algorithms in order to identify the building elements that are exposed to the outside of the building, the building envelope. Analytical surface originated from the building elements in the envelope will be classified as exterior or shading surfaces.
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


gbXMLExportComplexity Enumeration

This enumeration specifies the level of detail of the exported analytical energy model in gbXML. Complex means that Curtain Walls and Curtain Systems are exported as several openings, panel by panel; a curtain wall with 50 panels gets exported as 50 openings. Simple means that one "huge" opening with the total opening area equal to the 50 panels is exported. This is more appropriate for most energy analysis. Mullions mean that Mullions in Curtain Walls and Systems are exported as shading surfaces. A "simplified" analytical shading surface is produced from a mullion based on its centerline, thickness and offset.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum gbXMLExportComplexity
Public Enumeration gbXMLExportComplexity
public enum class gbXMLExportComplexity
type gbXMLExportComplexity
Members
Member name | Value | Description
Simple | 0 | Curtain Walls and Curtain Systems are normally exported as several openings, panel by panel, while for energy analysis all you need is one giant window. A curtain wall with 50 panels gets exported as 50 openings, while 1 opening with the total opening area would be more appropriate. Using this enumeration, one "large" window/opening will be exported for a curtain wall/system
SimpleWithShadingSurfaces | 1 | Using this enumeration, shading surfaces will be produced from room bounding building elements that are not bounding spaces
Complex | 2 | Using this enumeration, Curtain Walls and Curtain Systems will exported as several openings, panel by panel.
ComplexWithShadingSurfaces | 3 | Using this enumeration, shading surfaces will be produced from room bounding building elements that are not bounding spaces.
ComplexWithMullionsAndShadingSurfaces | 4 | Using this enumeration, mullions will be exported as shading surfaces. A "simplified" analytical shading surface is produced from a mullion based on its centerline, thickness and offset.
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


gbXMLOpeningType Enumeration

This enumeration corresponds to the openingType attribute in gbXML and identifies the type of opening defined.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum gbXMLOpeningType
Public Enumeration gbXMLOpeningType
public enum class gbXMLOpeningType
type gbXMLOpeningType
Members
Member name | Value | Description
FixedWindow | 0 | Fixed window.
OperableWindow | 1 | Operable window.
FixedSkylight | 2 | Fixed skylight.
OperableSkylight | 3 | Operable skylight.
SlidingDoor | 4 | Sliding door.
NonSlidingDoor | 5 | Non sliding door.
OpeningAir | 6 | Opening air.
NoOfOpeningTypes | 7 | No of opening types.
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


gbXMLServiceType Enumeration

This enumeration corresponds to the systemType attribute in gbXML and is used for specifying the service for the building or space.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum gbXMLServiceType
Public Enumeration gbXMLServiceType
public enum class gbXMLServiceType
type gbXMLServiceType
Members
Member name | Value | Description
CentralHeatingRadiators | 0 |
CentralHeatingConvectors | 1 |
CentralHeatingRadiantFloor | 2 |
CentralHeatingHotAir | 3 |
OtherRoomHeater | 4 |
RadiantHeaterFlue | 5 |
RadiantHeaterNoFlue | 6 |
RadiantHeaterMultiburner | 7 |
ForcedConvectionHeaterFlue | 8 |
ForcedConvectionHeaterNoFlue | 9 |
NoServiceType | -1 |
VAVSingleDuct | 10 |
VAVDualDuct | 11 |
VAVIndoorPackagedCabinet | 12 |
VAVTerminalReheat | 13 |
FanCoilSystem | 14 |
InductionSystem | 15 |
ConstantVolumeFixedOA | 16 |
ConstantVolumeVariableOA | 17 |
ConstantVolumeTerminalReheat | 18 |
MultizoneHotDeckColdDeck | 19 |
ConstantVolumeDualDuct | 20 |
RadiantCooledCeilings | 21 |
ActiveChilledBeams | 22 |
WaterLoopHeatPump | 23 |
VariableRefrigerantFlow | 24 |
SplitSystemsWithNaturalVentilation | 25 |
SplitSystemsWithMechanicalVentilation | 26 |
SplitSystemsWithMechanicalVentilationWithCooling | 27 |
NoOfServiceTypes | 28 |
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


gbXMLSpaceType Enumeration

This enumeration corresponds to the spaceType attribute in gbXML. The enumerated attribute identifies the type of space defined and allows to better approximate the actual internal loads and schedules associated with the defined space type.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum gbXMLSpaceType
Public Enumeration gbXMLSpaceType
public enum class gbXMLSpaceType
type gbXMLSpaceType
Members
Member name | Value | Description
ActiveStorage | 0 |
ActiveStorageHospitalOrHealthcare | 1 |
AirOrTrainOrBusBaggageArea | 2 |
AirportConcourse | 3 |
AtriumEachAdditionalFloor | 4 |
AtriumFirstThreeFloors | 5 |
AudienceOrSeatingAreaPenitentiary | 6 |
AudienceOrSeatingAreaExerciseCenter | 7 |
AudienceOrSeatingAreaGymnasium | 8 |
AudienceOrSeatingAreaSportsArena | 9 |
NoSpaceType | -1 |
AudienceOrSeatingAreaConventionCenter | 10 |
AudienceOrSeatingAreaMotionPictureTheatre | 11 |
AudienceOrSeatingAreaPerformingArtsTheatre | 12 |
AudienceOrSeatingAreaReligious | 13 |
AudienceOrSeatingAreaPoliceOrFireStations | 14 |
AudienceOrSeatingAreaCourtHouse | 15 |
AudienceOrSeatingAreaAuditorium | 16 |
BankCustomerArea | 17 |
BankingActivityAreaOffice | 18 |
BarberAndBeautyParlor | 19 |
CustomizeSpaceType | -2 |
CardFileAndCataloguingLibrary | 20 |
ClassroomOrLectureOrTrainingPenitentiary | 21 |
ClassroomOrLectureOrTraining | 22 |
ConfinementCellsPenitentiary | 23 |
ConfinementCellsCourtHouse | 24 |
ConferenceMeetingOrMultipurpose | 25 |
CorridorOrTransition | 26 |
CorridorOrTransitionManufacturingFacility | 27 |
CorridorsWithPatientWaitingExamHospitalOrHealthcare | 28 |
CourtSportsAreaSportsArena | 29 |
CourtroomCourtHouse | 30 |
DepartmentStoreSalesAreaRetail | 31 |
DetailedManufacturingFacility | 32 |
DiningArea | 33 |
DiningAreaHotel | 34 |
DiningAreaFamilyDining | 35 |
DiningAreaLoungeOrLeisureDining | 36 |
DiningAreaMotel | 37 |
DiningAreaTransportation | 38 |
DiningAreaPenitentiary | 39 |
DiningAreaCivilServices | 40 |
DormitoryBedroom | 41 |
DormitoryStudyHall | 42 |
DressingOrLockerOrFittingRoomGymnasium | 43 |
DressingOrLockerOrFittingRoomCourtHouse | 44 |
DressingOrLockerOrFittingRoomPerformingArtsTheatre | 45 |
DressingOrLockerOrFittingRoomAuditorium | 46 |
DressingOrLockerOrFittingRoomExerciseCenter | 47 |
ElectricalOrMechanical | 48 |
ElevatorLobbies | 49 |
EmergencyHospitalOrHealthcare | 50 |
EquipmentRoomManufacturingFacility | 51 |
ExamOrTreatmentHospitalOrHealthcare | 52 |
ExerciseAreaExerciseCenter | 53 |
ExerciseAreaGymnasium | 54 |
ExhibitSpaceConventionCenter | 55 |
FellowshipHallReligiousBuildings | 56 |
FineMaterialWarehouse | 57 |
FineMerchandiseSalesAreaRetail | 58 |
FireStationEngineRoomPoliceOrFireStation | 59 |
FoodPreparation | 60 |
GarageServiceOrRepairAutomotiveFacility | 61 |
GeneralHighBayManufacturingFacility | 62 |
GeneralLowBayManufacturingFacility | 63 |
GeneralExhibitionMuseum | 64 |
HospitalNurseryHospitalOrHealthcare | 65 |
HospitalOrMedicalSuppliesHospitalOrHealthcare | 66 |
HospitalOrRadiologyHospitalOrHealthcare | 67 |
HotelOrConferenceCenterConferenceOrMeeting | 68 |
InactiveStorage | 69 |
JudgesChambersCourtHouse | 70 |
LaboratoryOffice | 71 |
LaundryIroningAndSorting | 72 |
LaundryWashingHospitalOrHealthcare | 73 |
LibraryAudioVisualLibraryAudioVisual | 74 |
LivingQuartersDormitory | 75 |
LivingQuartersMotel | 76 |
LivingQuartersHotel | 77 |
Lobby | 78 |
LobbyReligiousBuildings | 79 |
LobbyMotionPictureTheatre | 80 |
LobbyAuditorium | 81 |
LobbyPerformingArtsTheatre | 82 |
LobbyPostOffice | 83 |
LobbyHotel | 84 |
LoungeOrRecreation | 85 |
MallConcourseSalesAreaRetail | 86 |
MassMerchandisingSalesAreaRetail | 87 |
MediumOrBulkyMaterialWarehouse | 88 |
MerchandisingSalesAreaRetail | 89 |
MuseumAndGalleryStorage | 90 |
NurseStationHospitalOrHealthcare | 91 |
OfficeEnclosed | 92 |
OfficeOpenPlan | 93 |
OfficeCommonActivityAreasInactiveStorage | 94 |
OperatingRoomHospitalOrHealthcare | 95 |
OtherTelevisedPlayingAreaSportsArena | 96 |
ParkingAreaAttendantOnlyParkingGarage | 97 |
ParkingAreaPedestrianParkingGarage | 98 |
PatientRoomHospitalOrHealthcare | 99 |
PersonalServicesSalesAreaRetail | 100 |
PharmacyHospitalOrHealthcare | 101 |
PhysicalTherapyHospitalOrHealthcare | 102 |
PlayingAreaGymnasium | 103 |
Plenum | 104 |
PoliceStationLaboratoryPoliceOrFireStations | 105 |
PublicAndStaffLoungeHospitalOrHealthcare | 106 |
ReadingAreaLibrary | 107 |
ReceptionOrWaitingTransportation | 108 |
ReceptionOrWaitingMotel | 109 |
ReceptionOrWaitingHotel | 110 |
RecoveryHospitalOrHealthcare | 111 |
RestorationMuseum | 112 |
Restrooms | 113 |
RingSportsAreaSportsArena | 114 |
SleepingQuartersPoliceOrFireStation | 115 |
SortingAreaPostOffice | 116 |
SpecialtyStoreSalesAreaRetail | 117 |
StacksLibrary | 118 |
StairsInactive | 119 |
Stairway | 120 |
SupermarketSalesAreaRetail | 121 |
TerminalTicketCounterTransportation | 122 |
WorkshopWorkshop | 123 |
WorshipPulpitChoirReligious | 124 |
NoOfSpaceTypes | 125 |
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


gbXMLSurfaceType Enumeration

This enumeration corresponds to the surfaceType attribute in gbXML and identifies the type of surface defined.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum gbXMLSurfaceType
Public Enumeration gbXMLSurfaceType
public enum class gbXMLSurfaceType
type gbXMLSurfaceType
Members
Member name | Value | Description
InteriorWall | 0 | Interior wall.
ExteriorWall | 1 | Exterior wall.
Roof | 2 | Roof.
InteriorFloor | 3 | Interior floor.
ExposedFloor | 4 | Exposed floor.
Shade | 5 | Shade.
UndergroundWall | 6 | Underground wall.
UndergroundSlab | 7 | Underground slab.
Ceiling | 8 | Ceiling.
SurfaceAir | 9 | Surface air.
UndergroundCeiling | 10 | Underground ceiling.
RaisedFloor | 11 | Raised floor.
SlabOnGrade | 12 | Slab on grade.
NoOfSurfaceTypes | 13 | No of surface types.
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


GenericZone Class

Provides access to the GenericZone Element in Autodesk Revit.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DB.AnalysisGenericZone

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GenericZone : Element
Public Class GenericZone
    Inherits Element
public ref class GenericZone : public Element
type GenericZone =
    class
        inherit Element
    end

The GenericZone type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LevelOffset | The offset distance from this zone to the associated level.
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new instance of a generic zone and adds it to the document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetBoundaries | Gets the boundaries for the generic zone.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetDomainData | Gets the domain data for the generic zone.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
A generic zone is a tool that provides for a method of selecting elements that somehow come in contact with the zone object. A zone is a non-hierarchical structure of geometric information, area or volume definitions for the purpose of analysis. A generic zone will contain specific domain requirements provided at creation of the element.
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


GenericZone Properties

The GenericZone type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LevelOffset | The offset distance from this zone to the associated level.
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

GenericZone Class
Autodesk.Revit.DB.Analysis Namespace


GenericZone.LevelOffset Property

GenericZoneLevelOffset Property

The offset distance from this zone to the associated level.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double LevelOffset { get; set; }
Public Property LevelOffset As Double
    Get
    Set
public:
property double LevelOffset {
    double get ();
    void set (double value);
}
member LevelOffset : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The given value for offset must be no more than 30000 feet in absolute value.
See Also

Reference

GenericZone Class
Autodesk.Revit.DB.Analysis Namespace


GenericZone Methods

The GenericZone type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a new instance of a generic zone and adds it to the document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetBoundaries | Gets the boundaries for the generic zone.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetDomainData | Gets the domain data for the generic zone.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

GenericZone Class
Autodesk.Revit.DB.Analysis Namespace


GenericZone.Create Method

GenericZoneCreate Method

Creates a new instance of a generic zone and adds it to the document.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static GenericZone Create(
    Document doc,
    string name,
    GenericZoneDomainData domainData,
    ElementId levelId,
    IList<CurveLoop> curveLoops
)
Public Shared Function Create (
    doc As Document,
    name As String,
    domainData As GenericZoneDomainData,
    levelId As ElementId,
    curveLoops As IList(Of CurveLoop)
) As GenericZone
public:
static GenericZone^ Create(
    Document^ doc,
    String^ name,
    GenericZoneDomainData^ domainData,
    ElementId^ levelId,
    IList<CurveLoop^>^ curveLoops
)
static member Create :
        doc : Document *
        name : string *
        domainData : GenericZoneDomainData *
        levelId : ElementId *
        curveLoops : IList<CurveLoop> -> GenericZone

Parameters

doc Document
The document where the element will be created and added.
name String
The name of the generic zone to be created.
domainData GenericZoneDomainData
The specific domain requirements for the generic zone.
levelId ElementId
The base level on which the generic zone will be created.
curveLoops IList CurveLoop
The loops that define the lines, curves and areas that overlap or crosses the elements you want to belong to the zone. Multiple loops are allowed, they can be open or closed, but they should be on the same horizontal plane.

Return Value

GenericZone
The newly created generic zone.
Exceptions
Exception | Condition
ArgumentException | name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- name is an empty string. -or- The ElementId levelId is not a Level. -or- The curve loops in the input array are empty. -or- The input curve loops do not all lie in the same horizontal plane.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document has no open transaction.
See Also

Reference

GenericZone Class
Autodesk.Revit.DB.Analysis Namespace


GenericZone.GetBoundaries Method

GenericZoneGetBoundaries Method

Gets the boundaries for the generic zone.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<CurveLoop> GetBoundaries()
Public Function GetBoundaries As IList(Of CurveLoop)
public:
IList<CurveLoop^>^ GetBoundaries()
member GetBoundaries : unit -> IList<CurveLoop>

Return Value

IList CurveLoop
The generic zone boundaries.
See Also

Reference

GenericZone Class
Autodesk.Revit.DB.Analysis Namespace


GenericZone.GetDomainData Method

GenericZoneGetDomainData Method

Gets the domain data for the generic zone.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public GenericZoneDomainData GetDomainData()
Public Function GetDomainData As GenericZoneDomainData
public:
GenericZoneDomainData^ GetDomainData()
member GetDomainData : unit -> GenericZoneDomainData

Return Value

GenericZoneDomainData
Returns a pointer to the base class for specific domain requirements for the generic zone.
See Also

Reference

GenericZone Class
Autodesk.Revit.DB.Analysis Namespace


GenericZoneDomainData Class

A base class for specific domain requirements for a generic zone.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DB.AnalysisGenericZoneDomainData
Autodesk.Revit.DB.MechanicalSystemZoneData

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class GenericZoneDomainData : IDisposable
Public Class GenericZoneDomainData
    Implements IDisposable
public ref class GenericZoneDomainData : IDisposable
type GenericZoneDomainData =
    class
        interface IDisposable
    end

The GenericZoneDomainData type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the GenericZoneDomainData
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


GenericZoneDomainData Properties

The GenericZoneDomainData type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

GenericZoneDomainData Class
Autodesk.Revit.DB.Analysis Namespace


GenericZoneDomainData.IsValidObject Property

GenericZoneDomainDataIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

GenericZoneDomainData Class
Autodesk.Revit.DB.Analysis Namespace


GenericZoneDomainData Methods

The GenericZoneDomainData type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

GenericZoneDomainData Class
Autodesk.Revit.DB.Analysis Namespace


GenericZoneDomainData.Dispose Method

GenericZoneDomainDataDispose Method

Releases all resources used by the GenericZoneDomainData

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

GenericZoneDomainData Class
Autodesk.Revit.DB.Analysis Namespace


HVACLoadBuildingType Class

The type element of building.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DB.AnalysisHVACLoadType
Autodesk.Revit.DB.AnalysisHVACLoadBuildingType

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class HVACLoadBuildingType : HVACLoadType
Public Class HVACLoadBuildingType
    Inherits HVACLoadType
public ref class HVACLoadBuildingType : public HVACLoadType
type HVACLoadBuildingType =
    class
        inherit HVACLoadType
    end

The HVACLoadBuildingType type exposes the following members.

Properties
 | Name | Description
Public property | AirChangesPerHour | The air changes per hour. (Inherited from HVACLoadType)
Public property | AreaPerPerson | The area per person. (Inherited from HVACLoadType)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | BuildingTypeName | The building type name.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | ClosingTime | The closing time of the building type.
Public property | CoolingSetPoint | The cooling temperature set point in unit Kelvin (K). (Inherited from HVACLoadType)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | DehumidificationSetPoint | The dehumidification set point as a number between 0 and 1. (Inherited from HVACLoadType)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HeatingSetPoint | The heating temperature set point in unit Kelvin (K). (Inherited from HVACLoadType)
Public property | HumidificationSetPoint | The humidification set point as a number between 0 and 1. (Inherited from HVACLoadType)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LatentHeatGainPerPerson | The latent heat gain per person. (Inherited from HVACLoadType)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LightingLoadDensity | The lighting load density. (Inherited from HVACLoadType)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OpeningTime | The opening time of the building type.
Public property | OutdoorAirFlowStandard | The outdoor airflow standard. (Inherited from HVACLoadType)
Public property | OutdoorAirPerArea | The outdoor air per area. (Inherited from HVACLoadType)
Public property | OutdoorAirPerPerson | The outdoor air per person. (Inherited from HVACLoadType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | PlenumLighting | The percentage of plenum lighting contribution. (Inherited from HVACLoadType)
Public property | PowerLoadDensity | The power load density. (Inherited from HVACLoadType)
Public property | SensibleHeatGainPerPerson | The sensible heat gain per person. (Inherited from HVACLoadType)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | UnoccupiedCoolingSetPoint | The unoccupied cooling set point of the building type with unit kelvin (K).
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a building type element.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsNameUnique(String) | Determines whether a potential building type name is unique.
 | IsNameUnique(Document, String) | Determines whether a potential building type name is unique.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
 | IsValidTime | Check if the string can be parsed to a valid time for opening time and closing time. A valid string can be "16:30" or "4:30 PM";
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


HVACLoadBuildingType Properties

The HVACLoadBuildingType type exposes the following members.

Properties
 | Name | Description
Public property | AirChangesPerHour | The air changes per hour. (Inherited from HVACLoadType)
Public property | AreaPerPerson | The area per person. (Inherited from HVACLoadType)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | BuildingTypeName | The building type name.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | ClosingTime | The closing time of the building type.
Public property | CoolingSetPoint | The cooling temperature set point in unit Kelvin (K). (Inherited from HVACLoadType)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | DehumidificationSetPoint | The dehumidification set point as a number between 0 and 1. (Inherited from HVACLoadType)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HeatingSetPoint | The heating temperature set point in unit Kelvin (K). (Inherited from HVACLoadType)
Public property | HumidificationSetPoint | The humidification set point as a number between 0 and 1. (Inherited from HVACLoadType)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LatentHeatGainPerPerson | The latent heat gain per person. (Inherited from HVACLoadType)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LightingLoadDensity | The lighting load density. (Inherited from HVACLoadType)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OpeningTime | The opening time of the building type.
Public property | OutdoorAirFlowStandard | The outdoor airflow standard. (Inherited from HVACLoadType)
Public property | OutdoorAirPerArea | The outdoor air per area. (Inherited from HVACLoadType)
Public property | OutdoorAirPerPerson | The outdoor air per person. (Inherited from HVACLoadType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | PlenumLighting | The percentage of plenum lighting contribution. (Inherited from HVACLoadType)
Public property | PowerLoadDensity | The power load density. (Inherited from HVACLoadType)
Public property | SensibleHeatGainPerPerson | The sensible heat gain per person. (Inherited from HVACLoadType)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | UnoccupiedCoolingSetPoint | The unoccupied cooling set point of the building type with unit kelvin (K).
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

HVACLoadBuildingType Class
Autodesk.Revit.DB.Analysis Namespace


HVACLoadBuildingType.BuildingTypeName Property

HVACLoadBuildingTypeBuildingTypeName Property

The building type name.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string BuildingTypeName { get; set; }
Public Property BuildingTypeName As String
    Get
    Set
public:
property String^ BuildingTypeName {
    String^ get ();
    void set (String^ value);
}
member BuildingTypeName : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentException | When setting this property: name is an empty string or contains only whitespace. -or- When setting this property: name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- When setting this property: The given value for name is already in use as a building type name.
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

HVACLoadBuildingType Class
Autodesk.Revit.DB.Analysis Namespace


HVACLoadBuildingType.ClosingTime Property

HVACLoadBuildingTypeClosingTime Property

The closing time of the building type.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ClosingTime { get; set; }
Public Property ClosingTime As String
    Get
    Set
public:
property String^ ClosingTime {
    String^ get ();
    void set (String^ value);
}
member ClosingTime : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentException | When setting this property: It is not a valid time, can be something like "16:30" or "4:30 PM".
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

HVACLoadBuildingType Class
Autodesk.Revit.DB.Analysis Namespace


HVACLoadBuildingType.OpeningTime Property

HVACLoadBuildingTypeOpeningTime Property

The opening time of the building type.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string OpeningTime { get; set; }
Public Property OpeningTime As String
    Get
    Set
public:
property String^ OpeningTime {
    String^ get ();
    void set (String^ value);
}
member OpeningTime : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentException | When setting this property: It is not a valid time, can be something like "16:30" or "4:30 PM".
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

HVACLoadBuildingType Class
Autodesk.Revit.DB.Analysis Namespace


HVACLoadBuildingType.UnoccupiedCoolingSetPoint Property

HVACLoadBuildingTypeUnoccupiedCoolingSetPoint Property

The unoccupied cooling set point of the building type with unit kelvin (K).

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double UnoccupiedCoolingSetPoint { get; set; }
Public Property UnoccupiedCoolingSetPoint As Double
    Get
    Set
public:
property double UnoccupiedCoolingSetPoint {
    double get ();
    void set (double value);
}
member UnoccupiedCoolingSetPoint : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentException | When setting this property: The value should be between (273.15, 373.15] with unit kelvin (K).
See Also

Reference

HVACLoadBuildingType Class
Autodesk.Revit.DB.Analysis Namespace


HVACLoadBuildingType Methods

The HVACLoadBuildingType type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a building type element.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsNameUnique(String) | Determines whether a potential building type name is unique.
 | IsNameUnique(Document, String) | Determines whether a potential building type name is unique.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
 | IsValidTime | Check if the string can be parsed to a valid time for opening time and closing time. A valid string can be "16:30" or "4:30 PM";
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

HVACLoadBuildingType Class
Autodesk.Revit.DB.Analysis Namespace


HVACLoadBuildingType.Create Method

HVACLoadBuildingTypeCreate Method

Creates a building type element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static HVACLoadBuildingType Create(
    Document document,
    string name
)
Public Shared Function Create (
    document As Document,
    name As String
) As HVACLoadBuildingType
public:
static HVACLoadBuildingType^ Create(
    Document^ document,
    String^ name
)
static member Create :
        document : Document *
        name : string -> HVACLoadBuildingType

Parameters

document Document
The document.
name String
The building type name.

Return Value

HVACLoadBuildingType
The new building type.
Exceptions
Exception | Condition
ArgumentException | name is an empty string or contains only whitespace. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- The given value for name is already in use as a building type name.
ArgumentNullException | A non-optional argument was null
See Also

Reference

HVACLoadBuildingType Class
Autodesk.Revit.DB.Analysis Namespace


HVACLoadBuildingType.IsNameUnique Method

HVACLoadBuildingTypeIsNameUnique Method

Overload List
 | Name | Description
Public method | IsNameUnique(String) | Determines whether a potential building type name is unique.
 | IsNameUnique(Document, String) | Determines whether a potential building type name is unique.
Top
See Also

Reference

HVACLoadBuildingType Class
Autodesk.Revit.DB.Analysis Namespace


HVACLoadBuildingType.IsNameUnique(String) Method

HVACLoadBuildingTypeIsNameUnique(String) Method

Determines whether a potential building type name is unique.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsNameUnique(
    string name
)
Public Function IsNameUnique (
    name As String
) As Boolean
public:
bool IsNameUnique(
    String^ name
)
member IsNameUnique :
        name : string -> bool

Parameters

name String
The candidate name.

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

HVACLoadBuildingType Class
IsNameUnique Overload
Autodesk.Revit.DB.Analysis Namespace


HVACLoadBuildingType.IsNameUnique(Document, String) Method

HVACLoadBuildingTypeIsNameUnique(Document, String) Method

Determines whether a potential building type name is unique.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsNameUnique(
    Document document,
    string name
)
Public Shared Function IsNameUnique (
    document As Document,
    name As String
) As Boolean
public:
static bool IsNameUnique(
    Document^ document,
    String^ name
)
static member IsNameUnique :
        document : Document *
        name : string -> bool

Parameters

document Document
The document.
name String
The candidate name.

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

HVACLoadBuildingType Class
IsNameUnique Overload
Autodesk.Revit.DB.Analysis Namespace


HVACLoadBuildingType.IsValidTime Method

HVACLoadBuildingTypeIsValidTime Method

Check if the string can be parsed to a valid time for opening time and closing time. A valid string can be "16:30" or "4:30 PM";

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidTime(
    string hourMinute
)
Public Shared Function IsValidTime (
    hourMinute As String
) As Boolean
public:
static bool IsValidTime(
    String^ hourMinute
)
static member IsValidTime :
        hourMinute : string -> bool

Parameters

hourMinute String

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

HVACLoadBuildingType Class
Autodesk.Revit.DB.Analysis Namespace


HVACLoadConstructionClass Enumeration

Enumerated type listing options for construction class for HVAC analysis.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum HVACLoadConstructionClass
Public Enumeration HVACLoadConstructionClass
public enum class HVACLoadConstructionClass
type HVACLoadConstructionClass
Members
Member name | Value | Description
LooseConstruction | 0 | A loose construction has an infiltration level of approximately 0.076 cfm/sqft
MediumConstruction | 1 | A medium construction has an infiltration level of approximately 0.038 cfm/sqft
TightConstruction | 2 | A tight construction has an infiltration level of approximately 0.019 cfm/sqft
NoneConstruction | 3 | A none construction has an infiltration level of 0 cfm/sqft
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


HVACLoadLoadsReportType Enumeration

Enumerated type listing possible types of reports generated for HVAC loads.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum HVACLoadLoadsReportType
Public Enumeration HVACLoadLoadsReportType
public enum class HVACLoadLoadsReportType
type HVACLoadLoadsReportType
Members
Member name | Value | Description
NoReport | 0 | No report
SimpleReport | 1 | A simple report with summaries
StandardReport | 2 | A standard report including zones and spaces
DetailedReport | 3 | A detailed report including orientation breakdowns
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


HVACLoadSpaceType Class

The type element of space.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DB.AnalysisHVACLoadType
Autodesk.Revit.DB.AnalysisHVACLoadSpaceType

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class HVACLoadSpaceType : HVACLoadType
Public Class HVACLoadSpaceType
    Inherits HVACLoadType
public ref class HVACLoadSpaceType : public HVACLoadType
type HVACLoadSpaceType =
    class
        inherit HVACLoadType
    end

The HVACLoadSpaceType type exposes the following members.

Properties
 | Name | Description
Public property | AirChangesPerHour | The air changes per hour. (Inherited from HVACLoadType)
Public property | AreaPerPerson | The area per person. (Inherited from HVACLoadType)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | CoolingSetPoint | The cooling temperature set point in unit Kelvin (K). (Inherited from HVACLoadType)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | DehumidificationSetPoint | The dehumidification set point as a number between 0 and 1. (Inherited from HVACLoadType)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HeatingSetPoint | The heating temperature set point in unit Kelvin (K). (Inherited from HVACLoadType)
Public property | HumidificationSetPoint | The humidification set point as a number between 0 and 1. (Inherited from HVACLoadType)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsPlenum | True if the space type is plenum.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LatentHeatGainPerPerson | The latent heat gain per person. (Inherited from HVACLoadType)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LightingLoadDensity | The lighting load density. (Inherited from HVACLoadType)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OutdoorAirFlowStandard | The outdoor airflow standard. (Inherited from HVACLoadType)
Public property | OutdoorAirPerArea | The outdoor air per area. (Inherited from HVACLoadType)
Public property | OutdoorAirPerPerson | The outdoor air per person. (Inherited from HVACLoadType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | PlenumLighting | The percentage of plenum lighting contribution. (Inherited from HVACLoadType)
Public property | PowerLoadDensity | The power load density. (Inherited from HVACLoadType)
Public property | SensibleHeatGainPerPerson | The sensible heat gain per person. (Inherited from HVACLoadType)
Public property | SpaceTypeName | The space type name.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a space type.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsNameUnique(String) | Determines whether a potential space type name is unique.
 | IsNameUnique(Document, String) | Determines whether a potential space type name is unique.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


HVACLoadSpaceType Properties

The HVACLoadSpaceType type exposes the following members.

Properties
 | Name | Description
Public property | AirChangesPerHour | The air changes per hour. (Inherited from HVACLoadType)
Public property | AreaPerPerson | The area per person. (Inherited from HVACLoadType)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | CoolingSetPoint | The cooling temperature set point in unit Kelvin (K). (Inherited from HVACLoadType)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | DehumidificationSetPoint | The dehumidification set point as a number between 0 and 1. (Inherited from HVACLoadType)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HeatingSetPoint | The heating temperature set point in unit Kelvin (K). (Inherited from HVACLoadType)
Public property | HumidificationSetPoint | The humidification set point as a number between 0 and 1. (Inherited from HVACLoadType)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsPlenum | True if the space type is plenum.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LatentHeatGainPerPerson | The latent heat gain per person. (Inherited from HVACLoadType)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LightingLoadDensity | The lighting load density. (Inherited from HVACLoadType)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OutdoorAirFlowStandard | The outdoor airflow standard. (Inherited from HVACLoadType)
Public property | OutdoorAirPerArea | The outdoor air per area. (Inherited from HVACLoadType)
Public property | OutdoorAirPerPerson | The outdoor air per person. (Inherited from HVACLoadType)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | PlenumLighting | The percentage of plenum lighting contribution. (Inherited from HVACLoadType)
Public property | PowerLoadDensity | The power load density. (Inherited from HVACLoadType)
Public property | SensibleHeatGainPerPerson | The sensible heat gain per person. (Inherited from HVACLoadType)
Public property | SpaceTypeName | The space type name.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

HVACLoadSpaceType Class
Autodesk.Revit.DB.Analysis Namespace


HVACLoadSpaceType.IsPlenum Property

HVACLoadSpaceTypeIsPlenum Property

True if the space type is plenum.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsPlenum { get; }
Public ReadOnly Property IsPlenum As Boolean
    Get
public:
property bool IsPlenum {
    bool get ();
}
member IsPlenum : bool with get

Property Value

Boolean
See Also

Reference

HVACLoadSpaceType Class
Autodesk.Revit.DB.Analysis Namespace


HVACLoadSpaceType.SpaceTypeName Property

HVACLoadSpaceTypeSpaceTypeName Property

The space type name.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SpaceTypeName { get; set; }
Public Property SpaceTypeName As String
    Get
    Set
public:
property String^ SpaceTypeName {
    String^ get ();
    void set (String^ value);
}
member SpaceTypeName : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentException | When setting this property: name is an empty string or contains only whitespace. -or- When setting this property: name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- When setting this property: The given value for name is already in use as a space type name.
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

HVACLoadSpaceType Class
Autodesk.Revit.DB.Analysis Namespace


HVACLoadSpaceType Methods

The HVACLoadSpaceType type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create | Creates a space type.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsNameUnique(String) | Determines whether a potential space type name is unique.
 | IsNameUnique(Document, String) | Determines whether a potential space type name is unique.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

HVACLoadSpaceType Class
Autodesk.Revit.DB.Analysis Namespace


HVACLoadSpaceType.Create Method

HVACLoadSpaceTypeCreate Method

Creates a space type.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static HVACLoadSpaceType Create(
    Document document,
    string name
)
Public Shared Function Create (
    document As Document,
    name As String
) As HVACLoadSpaceType
public:
static HVACLoadSpaceType^ Create(
    Document^ document,
    String^ name
)
static member Create :
        document : Document *
        name : string -> HVACLoadSpaceType

Parameters

document Document
The document.
name String
The space type name.

Return Value

HVACLoadSpaceType
The new space type.
Exceptions
Exception | Condition
ArgumentException | name is an empty string or contains only whitespace. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- The given value for name is already in use as a space type name.
ArgumentNullException | A non-optional argument was null
See Also

Reference

HVACLoadSpaceType Class
Autodesk.Revit.DB.Analysis Namespace


HVACLoadSpaceType.IsNameUnique Method

HVACLoadSpaceTypeIsNameUnique Method

Overload List
 | Name | Description
Public method | IsNameUnique(String) | Determines whether a potential space type name is unique.
 | IsNameUnique(Document, String) | Determines whether a potential space type name is unique.
Top
See Also

Reference

HVACLoadSpaceType Class
Autodesk.Revit.DB.Analysis Namespace


HVACLoadSpaceType.IsNameUnique(String) Method

HVACLoadSpaceTypeIsNameUnique(String) Method

Determines whether a potential space type name is unique.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsNameUnique(
    string name
)
Public Function IsNameUnique (
    name As String
) As Boolean
public:
bool IsNameUnique(
    String^ name
)
member IsNameUnique :
        name : string -> bool

Parameters

name String
The candidate name.

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

HVACLoadSpaceType Class
IsNameUnique Overload
Autodesk.Revit.DB.Analysis Namespace


HVACLoadSpaceType.IsNameUnique(Document, String) Method

HVACLoadSpaceTypeIsNameUnique(Document, String) Method

Determines whether a potential space type name is unique.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsNameUnique(
    Document document,
    string name
)
Public Shared Function IsNameUnique (
    document As Document,
    name As String
) As Boolean
public:
static bool IsNameUnique(
    Document^ document,
    String^ name
)
static member IsNameUnique :
        document : Document *
        name : string -> bool

Parameters

document Document
The document.
name String
The candidate name.

Return Value

Boolean
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

HVACLoadSpaceType Class
IsNameUnique Overload
Autodesk.Revit.DB.Analysis Namespace


HVACLoadType Class

The base class for building type and space type.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DB.AnalysisHVACLoadType
Autodesk.Revit.DB.AnalysisHVACLoadBuildingType
Autodesk.Revit.DB.AnalysisHVACLoadSpaceType

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class HVACLoadType : Element
Public Class HVACLoadType
    Inherits Element
public ref class HVACLoadType : public Element
type HVACLoadType =
    class
        inherit Element
    end

The HVACLoadType type exposes the following members.

Properties
 | Name | Description
Public property | AirChangesPerHour | The air changes per hour.
Public property | AreaPerPerson | The area per person.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | CoolingSetPoint | The cooling temperature set point in unit Kelvin (K).
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | DehumidificationSetPoint | The dehumidification set point as a number between 0 and 1.
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HeatingSetPoint | The heating temperature set point in unit Kelvin (K).
Public property | HumidificationSetPoint | The humidification set point as a number between 0 and 1.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LatentHeatGainPerPerson | The latent heat gain per person.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LightingLoadDensity | The lighting load density.
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OutdoorAirFlowStandard | The outdoor airflow standard.
Public property | OutdoorAirPerArea | The outdoor air per area.
Public property | OutdoorAirPerPerson | The outdoor air per person.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | PlenumLighting | The percentage of plenum lighting contribution.
Public property | PowerLoadDensity | The power load density.
Public property | SensibleHeatGainPerPerson | The sensible heat gain per person.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


HVACLoadType Properties

The HVACLoadType type exposes the following members.

Properties
 | Name | Description
Public property | AirChangesPerHour | The air changes per hour.
Public property | AreaPerPerson | The area per person.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | CoolingSetPoint | The cooling temperature set point in unit Kelvin (K).
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | DehumidificationSetPoint | The dehumidification set point as a number between 0 and 1.
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
Public property | HeatingSetPoint | The heating temperature set point in unit Kelvin (K).
Public property | HumidificationSetPoint | The humidification set point as a number between 0 and 1.
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LatentHeatGainPerPerson | The latent heat gain per person.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LightingLoadDensity | The lighting load density.
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OutdoorAirFlowStandard | The outdoor airflow standard.
Public property | OutdoorAirPerArea | The outdoor air per area.
Public property | OutdoorAirPerPerson | The outdoor air per person.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | PlenumLighting | The percentage of plenum lighting contribution.
Public property | PowerLoadDensity | The power load density.
Public property | SensibleHeatGainPerPerson | The sensible heat gain per person.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

HVACLoadType Class
Autodesk.Revit.DB.Analysis Namespace


HVACLoadType.AirChangesPerHour Property

HVACLoadTypeAirChangesPerHour Property

The air changes per hour.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double AirChangesPerHour { get; set; }
Public Property AirChangesPerHour As Double
    Get
    Set
public:
property double AirChangesPerHour {
    double get ();
    void set (double value);
}
member AirChangesPerHour : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentException | When setting this property: The value should be between [0.0,10000].
See Also

Reference

HVACLoadType Class
Autodesk.Revit.DB.Analysis Namespace


HVACLoadType.AreaPerPerson Property

HVACLoadTypeAreaPerPerson Property

The area per person.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double AreaPerPerson { get; set; }
Public Property AreaPerPerson As Double
    Get
    Set
public:
property double AreaPerPerson {
    double get ();
    void set (double value);
}
member AreaPerPerson : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The given value for value must be non-negative.
See Also

Reference

HVACLoadType Class
Autodesk.Revit.DB.Analysis Namespace


HVACLoadType.CoolingSetPoint Property

HVACLoadTypeCoolingSetPoint Property

The cooling temperature set point in unit Kelvin (K).

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double CoolingSetPoint { get; set; }
Public Property CoolingSetPoint As Double
    Get
    Set
public:
property double CoolingSetPoint {
    double get ();
    void set (double value);
}
member CoolingSetPoint : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentException | When setting this property:
See Also

Reference

HVACLoadType Class
Autodesk.Revit.DB.Analysis Namespace


HVACLoadType.DehumidificationSetPoint Property

HVACLoadTypeDehumidificationSetPoint Property

The dehumidification set point as a number between 0 and 1.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double DehumidificationSetPoint { get; set; }
Public Property DehumidificationSetPoint As Double
    Get
    Set
public:
property double DehumidificationSetPoint {
    double get ();
    void set (double value);
}
member DehumidificationSetPoint : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentException | When setting this property:
See Also

Reference

HVACLoadType Class
Autodesk.Revit.DB.Analysis Namespace


HVACLoadType.HeatingSetPoint Property

HVACLoadTypeHeatingSetPoint Property

The heating temperature set point in unit Kelvin (K).

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double HeatingSetPoint { get; set; }
Public Property HeatingSetPoint As Double
    Get
    Set
public:
property double HeatingSetPoint {
    double get ();
    void set (double value);
}
member HeatingSetPoint : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentException | When setting this property:
See Also

Reference

HVACLoadType Class
Autodesk.Revit.DB.Analysis Namespace


HVACLoadType.HumidificationSetPoint Property

HVACLoadTypeHumidificationSetPoint Property

The humidification set point as a number between 0 and 1.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double HumidificationSetPoint { get; set; }
Public Property HumidificationSetPoint As Double
    Get
    Set
public:
property double HumidificationSetPoint {
    double get ();
    void set (double value);
}
member HumidificationSetPoint : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentException | When setting this property:
See Also

Reference

HVACLoadType Class
Autodesk.Revit.DB.Analysis Namespace


HVACLoadType.LatentHeatGainPerPerson Property

HVACLoadTypeLatentHeatGainPerPerson Property

The latent heat gain per person.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double LatentHeatGainPerPerson { get; set; }
Public Property LatentHeatGainPerPerson As Double
    Get
    Set
public:
property double LatentHeatGainPerPerson {
    double get ();
    void set (double value);
}
member LatentHeatGainPerPerson : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentException | When setting this property: The value should be between [0.0,5381.9].
See Also

Reference

HVACLoadType Class
Autodesk.Revit.DB.Analysis Namespace


HVACLoadType.LightingLoadDensity Property

HVACLoadTypeLightingLoadDensity Property

The lighting load density.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double LightingLoadDensity { get; set; }
Public Property LightingLoadDensity As Double
    Get
    Set
public:
property double LightingLoadDensity {
    double get ();
    void set (double value);
}
member LightingLoadDensity : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentException | When setting this property: The value should be between [0.0,500000.0].
See Also

Reference

HVACLoadType Class
Autodesk.Revit.DB.Analysis Namespace


HVACLoadType.OutdoorAirFlowStandard Property

HVACLoadTypeOutdoorAirFlowStandard Property

The outdoor airflow standard.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OutdoorAirFlowStandard OutdoorAirFlowStandard { get; set; }
Public Property OutdoorAirFlowStandard As OutdoorAirFlowStandard
    Get
    Set
public:
property OutdoorAirFlowStandard OutdoorAirFlowStandard {
    OutdoorAirFlowStandard get ();
    void set (OutdoorAirFlowStandard value);
}
member OutdoorAirFlowStandard : OutdoorAirFlowStandard with get, set

Property Value

OutdoorAirFlowStandard
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

HVACLoadType Class
Autodesk.Revit.DB.Analysis Namespace


HVACLoadType.OutdoorAirPerArea Property

HVACLoadTypeOutdoorAirPerArea Property

The outdoor air per area.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double OutdoorAirPerArea { get; set; }
Public Property OutdoorAirPerArea As Double
    Get
    Set
public:
property double OutdoorAirPerArea {
    double get ();
    void set (double value);
}
member OutdoorAirPerArea : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentException | When setting this property: The value should be between [0.0,166.66].
See Also

Reference

HVACLoadType Class
Autodesk.Revit.DB.Analysis Namespace


HVACLoadType.OutdoorAirPerPerson Property

HVACLoadTypeOutdoorAirPerPerson Property

The outdoor air per person.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double OutdoorAirPerPerson { get; set; }
Public Property OutdoorAirPerPerson As Double
    Get
    Set
public:
property double OutdoorAirPerPerson {
    double get ();
    void set (double value);
}
member OutdoorAirPerPerson : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentException | When setting this property: The value should be between [0.0,166.66].
See Also

Reference

HVACLoadType Class
Autodesk.Revit.DB.Analysis Namespace


HVACLoadType.PlenumLighting Property

HVACLoadTypePlenumLighting Property

The percentage of plenum lighting contribution.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double PlenumLighting { get; set; }
Public Property PlenumLighting As Double
    Get
    Set
public:
property double PlenumLighting {
    double get ();
    void set (double value);
}
member PlenumLighting : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentException | When setting this property: The value should be between [0.0,1.0].
See Also

Reference

HVACLoadType Class
Autodesk.Revit.DB.Analysis Namespace


HVACLoadType.PowerLoadDensity Property

HVACLoadTypePowerLoadDensity Property

The power load density.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double PowerLoadDensity { get; set; }
Public Property PowerLoadDensity As Double
    Get
    Set
public:
property double PowerLoadDensity {
    double get ();
    void set (double value);
}
member PowerLoadDensity : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentException | When setting this property: The value should be between [0.0,500000.0].
See Also

Reference

HVACLoadType Class
Autodesk.Revit.DB.Analysis Namespace


HVACLoadType.SensibleHeatGainPerPerson Property

HVACLoadTypeSensibleHeatGainPerPerson Property

The sensible heat gain per person.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double SensibleHeatGainPerPerson { get; set; }
Public Property SensibleHeatGainPerPerson As Double
    Get
    Set
public:
property double SensibleHeatGainPerPerson {
    double get ();
    void set (double value);
}
member SensibleHeatGainPerPerson : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentException | When setting this property: The value should be between [0.0,5381.9].
See Also

Reference

HVACLoadType Class
Autodesk.Revit.DB.Analysis Namespace


HVACLoadType Methods

The HVACLoadType type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

HVACLoadType Class
Autodesk.Revit.DB.Analysis Namespace


MassLevelData Class

MassLevelData is a conceptual representation of an occupiable floor (Mass Floor) in a conceptual building model. It is defined by associating a particular level with a particular mass element in a Revit project.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DB.AnalysisMassLevelData

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MassLevelData : Element
Public Class MassLevelData
    Inherits Element
public ref class MassLevelData : public Element
type MassLevelData =
    class
        inherit Element
    end

The MassLevelData type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | ConceptualConstructionId | The ElementId of the conceptual construction associated with the MassLevelData (Mass Floor).
Public property | ConceptualConstructionIsByEnergyData | Indicates if the ConceptualConstructionType of the MassLevelData (Mass Floor) is synchronized with the EnergyDataSettings or if it overrides those settings.
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | MaterialId | The ElementId of the visualization material used for the MassLevelData (Mass Floor)
Public property | MaterialType | Indicates if the material used for the graphical appearance is by category or a specific material, or if the material to be used should be taken from the ConceptualConstructionType of the MassLevelData.
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | NExteriorSurfaceArea | The exterior surface area of the volume of the mass between the level of this MassLevelData (Mass Floor) to the next in the mass.
Public property | NLevelFafArea | The surface area of the intersection of the MassLevelData's level with the mass geometry.
Public property | NLevelPerimeter | The perimeter of the intersection of the MassLevelData's level with the mass geometry.
Public property | NVolume | The volume of from the level of this MassLevelData (Mass Floor) to the next in the mass.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
Public property | OwningMassId | The ElementId of the mass that the MassLevelData (Mass Floor) is associated with.
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | StrUsage | A String which describes the usage or occupancy type of the level of the MassLevelData.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsEmpty | Indicates if the MassLevelData (Mass Floor) has a geometrical representation. May not if the level does not intersect the mass geometry.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
 | IsMassFamilyInstance | Checks if the ElementId is a mass family instance.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidConceptualConstructionTypeElement | Checks if the ElementId is an acceptable conceptual construction type ElementId for the MassLevelData (Mass Floor).
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
MassLevelData reports metrics, such as floor areas, related to conceptual space planning. MassLevelData contains information, such as ConceptualConstructionType, used as part of the Conceptual Energy Analytical model. The MassLevel data geometry is determined by combining all the geometry of a mass into a single geometry, and then taking the area of intersection with the level of the MassLevelData.
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


MassLevelData Properties

The MassLevelData type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | ConceptualConstructionId | The ElementId of the conceptual construction associated with the MassLevelData (Mass Floor).
Public property | ConceptualConstructionIsByEnergyData | Indicates if the ConceptualConstructionType of the MassLevelData (Mass Floor) is synchronized with the EnergyDataSettings or if it overrides those settings.
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | MaterialId | The ElementId of the visualization material used for the MassLevelData (Mass Floor)
Public property | MaterialType | Indicates if the material used for the graphical appearance is by category or a specific material, or if the material to be used should be taken from the ConceptualConstructionType of the MassLevelData.
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | NExteriorSurfaceArea | The exterior surface area of the volume of the mass between the level of this MassLevelData (Mass Floor) to the next in the mass.
Public property | NLevelFafArea | The surface area of the intersection of the MassLevelData's level with the mass geometry.
Public property | NLevelPerimeter | The perimeter of the intersection of the MassLevelData's level with the mass geometry.
Public property | NVolume | The volume of from the level of this MassLevelData (Mass Floor) to the next in the mass.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
Public property | OwningMassId | The ElementId of the mass that the MassLevelData (Mass Floor) is associated with.
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | StrUsage | A String which describes the usage or occupancy type of the level of the MassLevelData.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


MassLevelData.ConceptualConstructionId Property

MassLevelDataConceptualConstructionId Property

The ElementId of the conceptual construction associated with the MassLevelData (Mass Floor).

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId ConceptualConstructionId { get; set; }
Public Property ConceptualConstructionId As ElementId
    Get
    Set
public:
property ElementId^ ConceptualConstructionId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member ConceptualConstructionId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentException | When setting this property: The input ElementId conceptualConstructionId is not a valid conceptual construction type ElementId.
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


MassLevelData.ConceptualConstructionIsByEnergyData Property

MassLevelDataConceptualConstructionIsByEnergyData Property

Indicates if the ConceptualConstructionType of the MassLevelData (Mass Floor) is synchronized with the EnergyDataSettings or if it overrides those settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ConceptualConstructionIsByEnergyData { get; set; }
Public Property ConceptualConstructionIsByEnergyData As Boolean
    Get
    Set
public:
property bool ConceptualConstructionIsByEnergyData {
    bool get ();
    void set (bool value);
}
member ConceptualConstructionIsByEnergyData : bool with get, set

Property Value

Boolean
Exceptions
Exception | Condition
ArgumentException | When setting this property: ConceptualConstructionIsByEnergyData cannot be set to conceptualConstructionIsByEnergyData.
See Also

Reference

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


MassLevelData.MaterialId Property

MassLevelDataMaterialId Property

The ElementId of the visualization material used for the MassLevelData (Mass Floor)

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId MaterialId { get; set; }
Public Property MaterialId As ElementId
    Get
    Set
public:
property ElementId^ MaterialId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member MaterialId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentException | When setting this property: The input element materialId is not a material element.
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


MassLevelData.MaterialType Property

MassLevelDataMaterialType Property

Indicates if the material used for the graphical appearance is by category or a specific material, or if the material to be used should be taken from the ConceptualConstructionType of the MassLevelData.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MassSurfaceDataMaterialType MaterialType { get; set; }
Public Property MaterialType As MassSurfaceDataMaterialType
    Get
    Set
public:
property MassSurfaceDataMaterialType MaterialType {
    MassSurfaceDataMaterialType get ();
    void set (MassSurfaceDataMaterialType value);
}
member MaterialType : MassSurfaceDataMaterialType with get, set

Property Value

MassSurfaceDataMaterialType
Exceptions
Exception | Condition
ArgumentException | When setting this property: The material type does not fall within an appropriate range.
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


MassLevelData.NExteriorSurfaceArea Property

MassLevelDataNExteriorSurfaceArea Property

The exterior surface area of the volume of the mass between the level of this MassLevelData (Mass Floor) to the next in the mass.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double NExteriorSurfaceArea { get; }
Public ReadOnly Property NExteriorSurfaceArea As Double
    Get
public:
property double NExteriorSurfaceArea {
    double get ();
}
member NExteriorSurfaceArea : float with get

Property Value

Double
See Also

Reference

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


MassLevelData.NLevelFafArea Property

MassLevelDataNLevelFafArea Property

The surface area of the intersection of the MassLevelData's level with the mass geometry.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double NLevelFafArea { get; }
Public ReadOnly Property NLevelFafArea As Double
    Get
public:
property double NLevelFafArea {
    double get ();
}
member NLevelFafArea : float with get

Property Value

Double
See Also

Reference

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


MassLevelData.NLevelPerimeter Property

MassLevelDataNLevelPerimeter Property

The perimeter of the intersection of the MassLevelData's level with the mass geometry.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double NLevelPerimeter { get; }
Public ReadOnly Property NLevelPerimeter As Double
    Get
public:
property double NLevelPerimeter {
    double get ();
}
member NLevelPerimeter : float with get

Property Value

Double
See Also

Reference

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


MassLevelData.NVolume Property

MassLevelDataNVolume Property

The volume of from the level of this MassLevelData (Mass Floor) to the next in the mass.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double NVolume { get; }
Public ReadOnly Property NVolume As Double
    Get
public:
property double NVolume {
    double get ();
}
member NVolume : float with get

Property Value

Double
See Also

Reference

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


MassLevelData.OwningMassId Property

MassLevelDataOwningMassId Property

The ElementId of the mass that the MassLevelData (Mass Floor) is associated with.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId OwningMassId { get; }
Public ReadOnly Property OwningMassId As ElementId
    Get
public:
property ElementId^ OwningMassId {
    ElementId^ get ();
}
member OwningMassId : ElementId with get

Property Value

ElementId
See Also

Reference

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


MassLevelData.StrUsage Property

MassLevelDataStrUsage Property

A String which describes the usage or occupancy type of the level of the MassLevelData.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string StrUsage { get; set; }
Public Property StrUsage As String
    Get
    Set
public:
property String^ StrUsage {
    String^ get ();
    void set (String^ value);
}
member StrUsage : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


MassLevelData Methods

The MassLevelData type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsEmpty | Indicates if the MassLevelData (Mass Floor) has a geometrical representation. May not if the level does not intersect the mass geometry.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
 | IsMassFamilyInstance | Checks if the ElementId is a mass family instance.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidConceptualConstructionTypeElement | Checks if the ElementId is an acceptable conceptual construction type ElementId for the MassLevelData (Mass Floor).
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


MassLevelData.IsEmpty Method

MassLevelDataIsEmpty Method

Indicates if the MassLevelData (Mass Floor) has a geometrical representation. May not if the level does not intersect the mass geometry.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEmpty()
Public Function IsEmpty As Boolean
public:
bool IsEmpty()
member IsEmpty : unit -> bool

Return Value

Boolean
Returns True if MassLevelData is dimensionless, False otherwise.
See Also

Reference

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


MassLevelData.IsMassFamilyInstance Method

MassLevelDataIsMassFamilyInstance Method

Checks if the ElementId is a mass family instance.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsMassFamilyInstance(
    Document document,
    ElementId id
)
Public Shared Function IsMassFamilyInstance (
    document As Document,
    id As ElementId
) As Boolean
public:
static bool IsMassFamilyInstance(
    Document^ document,
    ElementId^ id
)
static member IsMassFamilyInstance :
        document : Document *
        id : ElementId -> bool

Parameters

document Document
The document.
id ElementId
The ElementId to be checked.

Return Value

Boolean
True if the ElementId is a mass family instance, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


MassLevelData.IsValidConceptualConstructionTypeElement Method

MassLevelDataIsValidConceptualConstructionTypeElement Method

Checks if the ElementId is an acceptable conceptual construction type ElementId for the MassLevelData (Mass Floor).

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidConceptualConstructionTypeElement(
    ElementId id
)
Public Function IsValidConceptualConstructionTypeElement (
    id As ElementId
) As Boolean
public:
bool IsValidConceptualConstructionTypeElement(
    ElementId^ id
)
member IsValidConceptualConstructionTypeElement :
        id : ElementId -> bool

Parameters

id ElementId
The ElementId to be checked.

Return Value

Boolean
True if the ElementId is an acceptable conceptual construction type ElementId, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
In the case that 'conceptualConstructionIsByEnergyData' is true, invalidElementId is also acceptable input.
See Also

Reference

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


MassSurfaceData Class

Note: This API is now obsolete.

Holds properties and other data about a face in the MassEnergyAnalyticalModel element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DB.AnalysisMassSurfaceData

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This class is deprecated in Revit 2023 and may be removed in a later version of Revit. We suggest you use the 'EnergyAnalyticalDetailModel' and 'EnergyAnalysisSurface' classes instead.")]
public class MassSurfaceData : Element
<ObsoleteAttribute("This class is deprecated in Revit 2023 and may be removed in a later version of Revit. We suggest you use the 'EnergyAnalyticalDetailModel' and 'EnergyAnalysisSurface' classes instead.")>
Public Class MassSurfaceData
    Inherits Element
[ObsoleteAttribute(L"This class is deprecated in Revit 2023 and may be removed in a later version of Revit. We suggest you use the 'EnergyAnalyticalDetailModel' and 'EnergyAnalysisSurface' classes instead.")]
public ref class MassSurfaceData : public Element
[<ObsoleteAttribute("This class is deprecated in Revit 2023 and may be removed in a later version of Revit. We suggest you use the 'EnergyAnalyticalDetailModel' and 'EnergyAnalysisSurface' classes instead.")>]
type MassSurfaceData =
    class
        inherit Element
    end

The MassSurfaceData type exposes the following members.

Properties
 | Name | Description
Public property | Area | Area of the references that the MassSurfaceData provides properties for.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | CategoryIdForConceptualSurfaceType | Returns the mass subcategory ElementId used for ConceptualSurfaceType for this MassSurfaceData.
Public property | ConceptualConstructionId | The id of the conceptual construction associated with the reference surface.
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsConceptualConstructionByEnergyData | True when the ConceptualConstructionType id is synchronized to the EnergyDataSettings. False when the ConceptualConstructionType id is overridden for this MassSurfaceData.
Public property | IsGlazingShaded | Indicates if shade geometry is auto-generated on the top edge of auto-generated glazing.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsSlab | Indicates if a floor is a slab.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsUnderground | Indicates if the roof, floor, slab, or wall surface reference is underground.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | MassLevelDataId | The MassLevelData used when the surface is horizontal, planar, and at the same height as a MassLevelData related to the same mass as the referenced face.
Public property | MaterialId | The visualization material used for the surface for displaying the energy analytical model.
Public property | MaterialType | material type of mass zone
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | PercentageGlazing | The target percentage of the reference wall surface that is to be covered with automatically generated windows. Revit will use this number when determining the size, shape, and location of automatically generated windows.
Public property | PercentageSkylights | The target percentage of the reference roof surface that is to be covered with automatically generated skylights. Revit will use this number when determining the size, shape, and location of automatically generated skylights.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ReferenceElementId | The ElementId of the element whose face the MassSurfaceData primarily refers to.
Public property | ShadeDepth | How far any auto-generated shades should extend from the wall surface.
Public property | SillHeight | The height above the level where the bottoms of auto-generated windows will be located.
Public property | SkylightWidth | The length dimension to be used for the sides of each individual square skylight produced in the grid of auto-generated skylights.
Public property | SurfaceDataSource | Indicates whether the MassSurfaceData properties are driven by the EnergyDataSettings of the Document or are overridden for the surface.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFaceReferences | Gets References to the faces that the MassSurfaceData provides properties for.
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
Properties stored in the MassSurfaceData can be used in regeneration by the MassEnergyAnalyticalModel. For example, faces of the MassEnergyAnalyticalModel take their material values from the settings in the MassSurfaceData.
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


MassSurfaceData Properties

The MassSurfaceData type exposes the following members.

Properties
 | Name | Description
Public property | Area | Area of the references that the MassSurfaceData provides properties for.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
Public property | CategoryIdForConceptualSurfaceType | Returns the mass subcategory ElementId used for ConceptualSurfaceType for this MassSurfaceData.
Public property | ConceptualConstructionId | The id of the conceptual construction associated with the reference surface.
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsConceptualConstructionByEnergyData | True when the ConceptualConstructionType id is synchronized to the EnergyDataSettings. False when the ConceptualConstructionType id is overridden for this MassSurfaceData.
Public property | IsGlazingShaded | Indicates if shade geometry is auto-generated on the top edge of auto-generated glazing.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsSlab | Indicates if a floor is a slab.
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsUnderground | Indicates if the roof, floor, slab, or wall surface reference is underground.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | MassLevelDataId | The MassLevelData used when the surface is horizontal, planar, and at the same height as a MassLevelData related to the same mass as the referenced face.
Public property | MaterialId | The visualization material used for the surface for displaying the energy analytical model.
Public property | MaterialType | material type of mass zone
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | PercentageGlazing | The target percentage of the reference wall surface that is to be covered with automatically generated windows. Revit will use this number when determining the size, shape, and location of automatically generated windows.
Public property | PercentageSkylights | The target percentage of the reference roof surface that is to be covered with automatically generated skylights. Revit will use this number when determining the size, shape, and location of automatically generated skylights.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ReferenceElementId | The ElementId of the element whose face the MassSurfaceData primarily refers to.
Public property | ShadeDepth | How far any auto-generated shades should extend from the wall surface.
Public property | SillHeight | The height above the level where the bottoms of auto-generated windows will be located.
Public property | SkylightWidth | The length dimension to be used for the sides of each individual square skylight produced in the grid of auto-generated skylights.
Public property | SurfaceDataSource | Indicates whether the MassSurfaceData properties are driven by the EnergyDataSettings of the Document or are overridden for the surface.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


MassSurfaceData.Area Property

MassSurfaceDataArea Property

Area of the references that the MassSurfaceData provides properties for.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Area { get; }
Public ReadOnly Property Area As Double
    Get
public:
property double Area {
    double get ();
}
member Area : float with get

Property Value

Double
Remarks
If it is used, should be greater than zero. Otherwise, it will be zero.
See Also

Reference

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


MassSurfaceData.CategoryIdForConceptualSurfaceType Property

MassSurfaceDataCategoryIdForConceptualSurfaceType Property

Returns the mass subcategory ElementId used for ConceptualSurfaceType for this MassSurfaceData.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId CategoryIdForConceptualSurfaceType { get; }
Public ReadOnly Property CategoryIdForConceptualSurfaceType As ElementId
    Get
public:
property ElementId^ CategoryIdForConceptualSurfaceType {
    ElementId^ get ();
}
member CategoryIdForConceptualSurfaceType : ElementId with get

Property Value

ElementId
Remarks
This value is determined by starting with the subcategory property and adjusting it according to properties such as "isSlab" or "isUnderground".
See Also

Reference

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


MassSurfaceData.ConceptualConstructionId Property

MassSurfaceDataConceptualConstructionId Property

The id of the conceptual construction associated with the reference surface.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId ConceptualConstructionId { get; set; }
Public Property ConceptualConstructionId As ElementId
    Get
    Set
public:
property ElementId^ ConceptualConstructionId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member ConceptualConstructionId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentException | When setting this property: The input element conceptualConstructionId is not a valid ConceptualConstructionType element id.
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


MassSurfaceData.IsConceptualConstructionByEnergyData Property

MassSurfaceDataIsConceptualConstructionByEnergyData Property

True when the ConceptualConstructionType id is synchronized to the EnergyDataSettings. False when the ConceptualConstructionType id is overridden for this MassSurfaceData.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsConceptualConstructionByEnergyData { get; set; }
Public Property IsConceptualConstructionByEnergyData As Boolean
    Get
    Set
public:
property bool IsConceptualConstructionByEnergyData {
    bool get ();
    void set (bool value);
}
member IsConceptualConstructionByEnergyData : bool with get, set

Property Value

Boolean
Exceptions
Exception | Condition
ArgumentException | When setting this property: ConceptualConstructionIsByEnergyData cannot be set to conceptualConstructionIsByEnergyData.
See Also

Reference

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


MassSurfaceData.IsGlazingShaded Property

MassSurfaceDataIsGlazingShaded Property

Indicates if shade geometry is auto-generated on the top edge of auto-generated glazing.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsGlazingShaded { get; set; }
Public Property IsGlazingShaded As Boolean
    Get
    Set
public:
property bool IsGlazingShaded {
    bool get ();
    void set (bool value);
}
member IsGlazingShaded : bool with get, set

Property Value

Boolean
See Also

Reference

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


MassSurfaceData.IsSlab Property

MassSurfaceDataIsSlab Property

Indicates if a floor is a slab.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSlab { get; }
Public ReadOnly Property IsSlab As Boolean
    Get
public:
property bool IsSlab {
    bool get ();
}
member IsSlab : bool with get

Property Value

Boolean
See Also

Reference

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


MassSurfaceData.IsUnderground Property

MassSurfaceDataIsUnderground Property

Indicates if the roof, floor, slab, or wall surface reference is underground.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsUnderground { get; set; }
Public Property IsUnderground As Boolean
    Get
    Set
public:
property bool IsUnderground {
    bool get ();
    void set (bool value);
}
member IsUnderground : bool with get, set

Property Value

Boolean
See Also

Reference

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


MassSurfaceData.MassLevelDataId Property

MassSurfaceDataMassLevelDataId Property

The MassLevelData used when the surface is horizontal, planar, and at the same height as a MassLevelData related to the same mass as the referenced face.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId MassLevelDataId { get; }
Public ReadOnly Property MassLevelDataId As ElementId
    Get
public:
property ElementId^ MassLevelDataId {
    ElementId^ get ();
}
member MassLevelDataId : ElementId with get

Property Value

ElementId
See Also

Reference

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


MassSurfaceData.MaterialId Property

MassSurfaceDataMaterialId Property

The visualization material used for the surface for displaying the energy analytical model.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId MaterialId { get; set; }
Public Property MaterialId As ElementId
    Get
    Set
public:
property ElementId^ MaterialId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member MaterialId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentException | When setting this property: The input element materialId is not a material element.
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


MassSurfaceData.MaterialType Property

MassSurfaceDataMaterialType Property

material type of mass zone

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MassSurfaceDataMaterialType MaterialType { get; set; }
Public Property MaterialType As MassSurfaceDataMaterialType
    Get
    Set
public:
property MassSurfaceDataMaterialType MaterialType {
    MassSurfaceDataMaterialType get ();
    void set (MassSurfaceDataMaterialType value);
}
member MaterialType : MassSurfaceDataMaterialType with get, set

Property Value

MassSurfaceDataMaterialType
Exceptions
Exception | Condition
ArgumentException | When setting this property: The material type does not fall within an appropriate range.
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


MassSurfaceData.PercentageGlazing Property

MassSurfaceDataPercentageGlazing Property

The target percentage of the reference wall surface that is to be covered with automatically generated windows. Revit will use this number when determining the size, shape, and location of automatically generated windows.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double PercentageGlazing { get; set; }
Public Property PercentageGlazing As Double
    Get
    Set
public:
property double PercentageGlazing {
    double get ();
    void set (double value);
}
member PercentageGlazing : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The percentage glazing value is not between 0.00 and 0.95.
Remarks
The resulting coverage of the wall with windows is not guaranteed to match this value. It is a target.
See Also

Reference

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


MassSurfaceData.PercentageSkylights Property

MassSurfaceDataPercentageSkylights Property

The target percentage of the reference roof surface that is to be covered with automatically generated skylights. Revit will use this number when determining the size, shape, and location of automatically generated skylights.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double PercentageSkylights { get; set; }
Public Property PercentageSkylights As Double
    Get
    Set
public:
property double PercentageSkylights {
    double get ();
    void set (double value);
}
member PercentageSkylights : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The percentage skylights value is between 0.00 and 0.95.
Remarks
The resulting coverage of the roof with skylights is not guaranteed to match this value. It is a target.
See Also

Reference

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


MassSurfaceData.ReferenceElementId Property

MassSurfaceDataReferenceElementId Property

The ElementId of the element whose face the MassSurfaceData primarily refers to.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId ReferenceElementId { get; }
Public ReadOnly Property ReferenceElementId As ElementId
    Get
public:
property ElementId^ ReferenceElementId {
    ElementId^ get ();
}
member ReferenceElementId : ElementId with get

Property Value

ElementId
Remarks
A MassSurfaceData may represent multiple faces from the same or different elements. This generally only happens if the faces are geometrically fully coincident and logically represent a single building object. "Interior walls" of the conceptual energy building model is a common example where two different faces may be represented by a single MassSurfaceData.
See Also

Reference

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


MassSurfaceData.ShadeDepth Property

MassSurfaceDataShadeDepth Property

How far any auto-generated shades should extend from the wall surface.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double ShadeDepth { get; set; }
Public Property ShadeDepth As Double
    Get
    Set
public:
property double ShadeDepth {
    double get ();
    void set (double value);
}
member ShadeDepth : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The shade depth is less than zero.
See Also

Reference

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


MassSurfaceData.SillHeight Property

MassSurfaceDataSillHeight Property

The height above the level where the bottoms of auto-generated windows will be located.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double SillHeight { get; set; }
Public Property SillHeight As Double
    Get
    Set
public:
property double SillHeight {
    double get ();
    void set (double value);
}
member SillHeight : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The sill height is less than zero.
Remarks
Will be accurate unless the target glazing percentage cannot be achieved using this height. In that case, the sillHeight will be ignored and windows will be created below this height.
See Also

Reference

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


MassSurfaceData.SkylightWidth Property

MassSurfaceDataSkylightWidth Property

The length dimension to be used for the sides of each individual square skylight produced in the grid of auto-generated skylights.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double SkylightWidth { get; set; }
Public Property SkylightWidth As Double
    Get
    Set
public:
property double SkylightWidth {
    double get ();
    void set (double value);
}
member SkylightWidth : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The skylight width is less than eight inches.
See Also

Reference

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


MassSurfaceData.SurfaceDataSource Property

MassSurfaceDataSurfaceDataSource Property

Indicates whether the MassSurfaceData properties are driven by the EnergyDataSettings of the Document or are overridden for the surface.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MassSurfaceDataSource SurfaceDataSource { get; set; }
Public Property SurfaceDataSource As MassSurfaceDataSource
    Get
    Set
public:
property MassSurfaceDataSource SurfaceDataSource {
    MassSurfaceDataSource get ();
    void set (MassSurfaceDataSource value);
}
member SurfaceDataSource : MassSurfaceDataSource with get, set

Property Value

MassSurfaceDataSource
Exceptions
Exception | Condition
ArgumentException | When setting this property: The surface data source does not fall within an appropriate range.
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
The Construction property is not governed by this setting and has a separate value to indicate if it is to be synchronized with EnergyDataSettings.
See Also

Reference

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


MassSurfaceData Methods

The MassSurfaceData type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFaceReferences | Gets References to the faces that the MassSurfaceData provides properties for.
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


MassSurfaceData.GetFaceReferences Method

MassSurfaceDataGetFaceReferences Method

Gets References to the faces that the MassSurfaceData provides properties for.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<Reference> GetFaceReferences()
Public Function GetFaceReferences As IList(Of Reference)
public:
IList<Reference^>^ GetFaceReferences()
member GetFaceReferences : unit -> IList<Reference>

Return Value

IList Reference
Returns an array of References to Faces that the MassSurfaceData provides properties for.
Remarks
The results are always references to Faces. The Reference Type should be REFERENCE_TYPE_SURFACE. Currently Revit improperly reports it as REFERENCE_TYPE_NONE.
See Also

Reference

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


MassSurfaceDataMaterialType Enumeration

Indicates how the visualization material for the MassSurfaceData is calculated.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum MassSurfaceDataMaterialType
Public Enumeration MassSurfaceDataMaterialType
public enum class MassSurfaceDataMaterialType
type MassSurfaceDataMaterialType
Members
Member name | Value | Description
NormalMaterial | 0 | The visualization material for the MassSurfaceData will be taken from the material associated with the object style of the subcategory of the MassSurfaceData if the materialId is InvalidElementId, or the MassSurfaceData will use the specific material indicated by the materialId property if its value is an ElementId of a MaterialElement.
MaterialByConstruction | -2 | The visualization material for the MassSurfaceData will be taken from the material assigned to the ConceptualConstructionType which is assigned to the MassSurfaceData.
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


MassSurfaceDataSource Enumeration

Indicates whether values for the properties of the MassSurfaceData are synchronized with the EnergyDataSettings of the document or instead, serve as overrides of those settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum MassSurfaceDataSource
Public Enumeration MassSurfaceDataSource
public enum class MassSurfaceDataSource
type MassSurfaceDataSource
Members
Member name | Value | Description
EnergyData | 0 | Synchronize with the EnergyDataSettings.
Surface | 1 | Override the EnergyDataSettings values for the surface.
Invalid | -1 | This value indicates that the parameter has not been properly set.
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


MEPAnalyticalModelData Class

Represents the MEP analytical model data attached to individual element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DB.AnalysisMEPAnalyticalModelData

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MEPAnalyticalModelData : IDisposable
Public Class MEPAnalyticalModelData
    Implements IDisposable
public ref class MEPAnalyticalModelData : IDisposable
type MEPAnalyticalModelData =
    class
        interface IDisposable
    end

The MEPAnalyticalModelData type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the MEPAnalyticalModelData
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
 | GetMEPAnalyticalModelData | Gets the MEP analytical model data of the specified element.
Public method | GetNodeById | Gets the analytical node with the specified id.
Public method | GetNodeByIndex | Gets the specified analytical node.
Public method | GetNumberOfNodes | Returns the number of analytical nodes.
Public method | GetNumberOfSegments | Returns the number of analytical segments.
Public method | GetSegmentById | Gets the analytical segment with the specified id.
Public method | GetSegmentByIndex | Gets the analytical segment at the specified position.
Public method | GetSegmentData | Gets the analysis data on the specified segment.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsValidNodeId | Verifies if a valid analytical node id.
Public method | IsValidSegmentId | Verifies if a valid segment id.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The MEP analytical model is composed of generic analytical segments and nodes. Each Revit element may have one or more analytical segments. Connected together, these data form a network that is used in the flow and pressure drop calculation.
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


MEPAnalyticalModelData Properties

The MEPAnalyticalModelData type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

MEPAnalyticalModelData Class
Autodesk.Revit.DB.Analysis Namespace


MEPAnalyticalModelData.IsValidObject Property

MEPAnalyticalModelDataIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

MEPAnalyticalModelData Class
Autodesk.Revit.DB.Analysis Namespace


MEPAnalyticalModelData Methods

The MEPAnalyticalModelData type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
 | GetMEPAnalyticalModelData | Gets the MEP analytical model data of the specified element.
Public method | GetNodeById | Gets the analytical node with the specified id.
Public method | GetNodeByIndex | Gets the specified analytical node.
Public method | GetNumberOfNodes | Returns the number of analytical nodes.
Public method | GetNumberOfSegments | Returns the number of analytical segments.
Public method | GetSegmentById | Gets the analytical segment with the specified id.
Public method | GetSegmentByIndex | Gets the analytical segment at the specified position.
Public method | GetSegmentData | Gets the analysis data on the specified segment.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsValidNodeId | Verifies if a valid analytical node id.
Public method | IsValidSegmentId | Verifies if a valid segment id.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MEPAnalyticalModelData Class
Autodesk.Revit.DB.Analysis Namespace


MEPAnalyticalModelData.Dispose Method

MEPAnalyticalModelDataDispose Method

Releases all resources used by the MEPAnalyticalModelData

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

MEPAnalyticalModelData Class
Autodesk.Revit.DB.Analysis Namespace


MEPAnalyticalModelData.GetMEPAnalyticalModelData Method

MEPAnalyticalModelDataGetMEPAnalyticalModelData Method

Gets the MEP analytical model data of the specified element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static MEPAnalyticalModelData GetMEPAnalyticalModelData(
    Element pElement
)
Public Shared Function GetMEPAnalyticalModelData (
    pElement As Element
) As MEPAnalyticalModelData
public:
static MEPAnalyticalModelData^ GetMEPAnalyticalModelData(
    Element^ pElement
)
static member GetMEPAnalyticalModelData :
        pElement : Element -> MEPAnalyticalModelData

Parameters

pElement Element
The element that owns the MEP analytical model data.

Return Value

MEPAnalyticalModelData
The MEP analytical model data of this element, null if not available.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

MEPAnalyticalModelData Class
Autodesk.Revit.DB.Analysis Namespace


MEPAnalyticalModelData.GetNodeById Method

MEPAnalyticalModelDataGetNodeById Method

Gets the analytical node with the specified id.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MEPAnalyticalNode GetNodeById(
    int nodeId
)
Public Function GetNodeById (
    nodeId As Integer
) As MEPAnalyticalNode
public:
MEPAnalyticalNode^ GetNodeById(
    int nodeId
)
member GetNodeById :
        nodeId : int -> MEPAnalyticalNode

Parameters

nodeId Int32
The node identifier, be aware that this identifier may not be sequentially ordered for all analytical nodes.

Return Value

MEPAnalyticalNode
The returned analytical node.
Exceptions
Exception | Condition
ArgumentException | The input must be a valid node id.
See Also

Reference

MEPAnalyticalModelData Class
Autodesk.Revit.DB.Analysis Namespace


MEPAnalyticalModelData.GetNodeByIndex Method

MEPAnalyticalModelDataGetNodeByIndex Method

Gets the specified analytical node.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MEPAnalyticalNode GetNodeByIndex(
    int index
)
Public Function GetNodeByIndex (
    index As Integer
) As MEPAnalyticalNode
public:
MEPAnalyticalNode^ GetNodeByIndex(
    int index
)
member GetNodeByIndex :
        index : int -> MEPAnalyticalNode

Parameters

index Int32
The node index number by their storing sequence, starting from 0.

Return Value

MEPAnalyticalNode
The returned analytical node.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The index must range from 0 to GetNumberOfNodes()-1.
See Also

Reference

MEPAnalyticalModelData Class
Autodesk.Revit.DB.Analysis Namespace


MEPAnalyticalModelData.GetNumberOfNodes Method

MEPAnalyticalModelDataGetNumberOfNodes Method

Returns the number of analytical nodes.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetNumberOfNodes()
Public Function GetNumberOfNodes As Integer
public:
int GetNumberOfNodes()
member GetNumberOfNodes : unit -> int

Return Value

Int32
See Also

Reference

MEPAnalyticalModelData Class
Autodesk.Revit.DB.Analysis Namespace


MEPAnalyticalModelData.GetNumberOfSegments Method

MEPAnalyticalModelDataGetNumberOfSegments Method

Returns the number of analytical segments.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int GetNumberOfSegments()
Public Function GetNumberOfSegments As Integer
public:
int GetNumberOfSegments()
member GetNumberOfSegments : unit -> int

Return Value

Int32
The total number of
See Also

Reference

MEPAnalyticalModelData Class
Autodesk.Revit.DB.Analysis Namespace


MEPAnalyticalModelData.GetSegmentById Method

MEPAnalyticalModelDataGetSegmentById Method

Gets the analytical segment with the specified id.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MEPAnalyticalSegment GetSegmentById(
    int segmentId
)
Public Function GetSegmentById (
    segmentId As Integer
) As MEPAnalyticalSegment
public:
MEPAnalyticalSegment^ GetSegmentById(
    int segmentId
)
member GetSegmentById :
        segmentId : int -> MEPAnalyticalSegment

Parameters

segmentId Int32
The segment id to be retrieved. This id is not 0 based.

Return Value

MEPAnalyticalSegment
The returned analytical segment.
Exceptions
Exception | Condition
ArgumentException | The input must be a valid segment id.
See Also

Reference

MEPAnalyticalModelData Class
Autodesk.Revit.DB.Analysis Namespace


MEPAnalyticalModelData.GetSegmentByIndex Method

MEPAnalyticalModelDataGetSegmentByIndex Method

Gets the analytical segment at the specified position.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MEPAnalyticalSegment GetSegmentByIndex(
    int index
)
Public Function GetSegmentByIndex (
    index As Integer
) As MEPAnalyticalSegment
public:
MEPAnalyticalSegment^ GetSegmentByIndex(
    int index
)
member GetSegmentByIndex :
        index : int -> MEPAnalyticalSegment

Parameters

index Int32
The index where the segment is stored. This index is 0 based.

Return Value

MEPAnalyticalSegment
The returned analytical segment.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The index must range from 0 to GetNumberOfSegments()-1.
See Also

Reference

MEPAnalyticalModelData Class
Autodesk.Revit.DB.Analysis Namespace


MEPAnalyticalModelData.GetSegmentData Method

MEPAnalyticalModelDataGetSegmentData Method

Gets the analysis data on the specified segment.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MEPNetworkSegmentData GetSegmentData(
    int segmentId
)
Public Function GetSegmentData (
    segmentId As Integer
) As MEPNetworkSegmentData
public:
MEPNetworkSegmentData^ GetSegmentData(
    int segmentId
)
member GetSegmentData :
        segmentId : int -> MEPNetworkSegmentData

Parameters

segmentId Int32
The segment id to be retrieved.

Return Value

MEPNetworkSegmentData
The calculated data of this segment. Be aware that the segment data may be invalid if the calculation failed.
Exceptions
Exception | Condition
ArgumentException | The input must be a valid segment id.
See Also

Reference

MEPAnalyticalModelData Class
Autodesk.Revit.DB.Analysis Namespace


MEPAnalyticalModelData.IsValidNodeId Method

MEPAnalyticalModelDataIsValidNodeId Method

Verifies if a valid analytical node id.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidNodeId(
    int nodeId
)
Public Function IsValidNodeId (
    nodeId As Integer
) As Boolean
public:
bool IsValidNodeId(
    int nodeId
)
member IsValidNodeId :
        nodeId : int -> bool

Parameters

nodeId Int32
The node id to be verified.

Return Value

Boolean
True if valid, otherwise false.
See Also

Reference

MEPAnalyticalModelData Class
Autodesk.Revit.DB.Analysis Namespace


MEPAnalyticalModelData.IsValidSegmentId Method

MEPAnalyticalModelDataIsValidSegmentId Method

Verifies if a valid segment id.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidSegmentId(
    int segmentId
)
Public Function IsValidSegmentId (
    segmentId As Integer
) As Boolean
public:
bool IsValidSegmentId(
    int segmentId
)
member IsValidSegmentId :
        segmentId : int -> bool

Parameters

segmentId Int32
The segment id to be verified.

Return Value

Boolean
True if the id is a valid segment id, otherwise false.
See Also

Reference

MEPAnalyticalModelData Class
Autodesk.Revit.DB.Analysis Namespace


MEPAnalyticalNode Class

Represents an analytical node of the MEP analytical model.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DB.AnalysisMEPAnalyticalNode

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MEPAnalyticalNode : IDisposable
Public Class MEPAnalyticalNode
    Implements IDisposable
public ref class MEPAnalyticalNode : IDisposable
type MEPAnalyticalNode =
    class
        interface IDisposable
    end

The MEPAnalyticalNode type exposes the following members.

Properties
 | Name | Description
Public property | Id | The identity used in the MEPAnalyticalSegment
Public property | IsFlowBlocked | Is the flow blocked at this analytical node?
Public property | IsFocalNode | Is this node a focal point of multiple branches?
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Location | The location of this node.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the MEPAnalyticalNode
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsSameNode | Verify if this node is connected to the other node and thus represents the same analytical node in the network.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


MEPAnalyticalNode Properties

The MEPAnalyticalNode type exposes the following members.

Properties
 | Name | Description
Public property | Id | The identity used in the MEPAnalyticalSegment
Public property | IsFlowBlocked | Is the flow blocked at this analytical node?
Public property | IsFocalNode | Is this node a focal point of multiple branches?
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | Location | The location of this node.
Top
See Also

Reference

MEPAnalyticalNode Class
Autodesk.Revit.DB.Analysis Namespace


MEPAnalyticalNode.Id Property

MEPAnalyticalNodeId Property

The identity used in the MEPAnalyticalSegment

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Id { get; }
Public ReadOnly Property Id As Integer
    Get
public:
property int Id {
    int get ();
}
member Id : int with get

Property Value

Int32
See Also

Reference

MEPAnalyticalNode Class
Autodesk.Revit.DB.Analysis Namespace


MEPAnalyticalNode.IsFlowBlocked Property

MEPAnalyticalNodeIsFlowBlocked Property

Is the flow blocked at this analytical node?

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsFlowBlocked { get; }
Public ReadOnly Property IsFlowBlocked As Boolean
    Get
public:
property bool IsFlowBlocked {
    bool get ();
}
member IsFlowBlocked : bool with get

Property Value

Boolean
See Also

Reference

MEPAnalyticalNode Class
Autodesk.Revit.DB.Analysis Namespace


MEPAnalyticalNode.IsFocalNode Property

MEPAnalyticalNodeIsFocalNode Property

Is this node a focal point of multiple branches?

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsFocalNode { get; }
Public ReadOnly Property IsFocalNode As Boolean
    Get
public:
property bool IsFocalNode {
    bool get ();
}
member IsFocalNode : bool with get

Property Value

Boolean
See Also

Reference

MEPAnalyticalNode Class
Autodesk.Revit.DB.Analysis Namespace


MEPAnalyticalNode.IsValidObject Property

MEPAnalyticalNodeIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

MEPAnalyticalNode Class
Autodesk.Revit.DB.Analysis Namespace


MEPAnalyticalNode.Location Property

MEPAnalyticalNodeLocation Property

The location of this node.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Location { get; }
Public ReadOnly Property Location As XYZ
    Get
public:
property XYZ^ Location {
    XYZ^ get ();
}
member Location : XYZ with get

Property Value

XYZ
See Also

Reference

MEPAnalyticalNode Class
Autodesk.Revit.DB.Analysis Namespace


MEPAnalyticalNode Methods

The MEPAnalyticalNode type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsSameNode | Verify if this node is connected to the other node and thus represents the same analytical node in the network.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MEPAnalyticalNode Class
Autodesk.Revit.DB.Analysis Namespace


MEPAnalyticalNode.Dispose Method

MEPAnalyticalNodeDispose Method

Releases all resources used by the MEPAnalyticalNode

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

MEPAnalyticalNode Class
Autodesk.Revit.DB.Analysis Namespace


MEPAnalyticalNode.IsSameNode Method

MEPAnalyticalNodeIsSameNode Method

Verify if this node is connected to the other node and thus represents the same analytical node in the network.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSameNode(
    MEPAnalyticalNode other
)
Public Function IsSameNode (
    other As MEPAnalyticalNode
) As Boolean
public:
bool IsSameNode(
    MEPAnalyticalNode^ other
)
member IsSameNode :
        other : MEPAnalyticalNode -> bool

Parameters

other MEPAnalyticalNode
The other node to be compared.

Return Value

Boolean
True if two nodes represent the same node of the network. Otherwise false.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

MEPAnalyticalNode Class
Autodesk.Revit.DB.Analysis Namespace


MEPAnalyticalSegment Class

Represents an analytical segment of the MEP analytical model.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DB.AnalysisMEPAnalyticalSegment

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MEPAnalyticalSegment : IDisposable
Public Class MEPAnalyticalSegment
    Implements IDisposable
public ref class MEPAnalyticalSegment : IDisposable
type MEPAnalyticalSegment =
    class
        interface IDisposable
    end

The MEPAnalyticalSegment type exposes the following members.

Properties
 | Name | Description
Public property | Area | The area of the segment profile.
Public property | DemandFlow | The designed flow value, in ft^3/s.
Public property | DomainType | The connector domain type of this segment.
Public property | EndNode | The id of the end analytical node.
Public property | Id | The identity of this segment.
Public property | InnerDiameter | The inner diameter of this segment, in ft. For rectangular or oval profile, this may be the hydraulic diameter.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | RevitElementId | The id of the owning Revit element.
Public property | Roughness | The roughness of this segment, in ft.
Public property | SegmentType | The analytical segment type.
Public property | StartNode | The id of the start analytical node.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the MEPAnalyticalSegment
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetNetworkSegmentId | Gets the NetworkSegmentId.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


MEPAnalyticalSegment Properties

The MEPAnalyticalSegment type exposes the following members.

Properties
 | Name | Description
Public property | Area | The area of the segment profile.
Public property | DemandFlow | The designed flow value, in ft^3/s.
Public property | DomainType | The connector domain type of this segment.
Public property | EndNode | The id of the end analytical node.
Public property | Id | The identity of this segment.
Public property | InnerDiameter | The inner diameter of this segment, in ft. For rectangular or oval profile, this may be the hydraulic diameter.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | RevitElementId | The id of the owning Revit element.
Public property | Roughness | The roughness of this segment, in ft.
Public property | SegmentType | The analytical segment type.
Public property | StartNode | The id of the start analytical node.
Top
See Also

Reference

MEPAnalyticalSegment Class
Autodesk.Revit.DB.Analysis Namespace


MEPAnalyticalSegment.Area Property

MEPAnalyticalSegmentArea Property

The area of the segment profile.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Area { get; }
Public ReadOnly Property Area As Double
    Get
public:
property double Area {
    double get ();
}
member Area : float with get

Property Value

Double
See Also

Reference

MEPAnalyticalSegment Class
Autodesk.Revit.DB.Analysis Namespace


MEPAnalyticalSegment.DemandFlow Property

MEPAnalyticalSegmentDemandFlow Property

The designed flow value, in ft^3/s.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double DemandFlow { get; }
Public ReadOnly Property DemandFlow As Double
    Get
public:
property double DemandFlow {
    double get ();
}
member DemandFlow : float with get

Property Value

Double
See Also

Reference

MEPAnalyticalSegment Class
Autodesk.Revit.DB.Analysis Namespace


MEPAnalyticalSegment.DomainType Property

MEPAnalyticalSegmentDomainType Property

The connector domain type of this segment.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConnectorDomainType DomainType { get; }
Public ReadOnly Property DomainType As ConnectorDomainType
    Get
public:
property ConnectorDomainType DomainType {
    ConnectorDomainType get ();
}
member DomainType : ConnectorDomainType with get

Property Value

ConnectorDomainType
See Also

Reference

MEPAnalyticalSegment Class
Autodesk.Revit.DB.Analysis Namespace


MEPAnalyticalSegment.EndNode Property

MEPAnalyticalSegmentEndNode Property

The id of the end analytical node.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int EndNode { get; }
Public ReadOnly Property EndNode As Integer
    Get
public:
property int EndNode {
    int get ();
}
member EndNode : int with get

Property Value

Int32
See Also

Reference

MEPAnalyticalSegment Class
Autodesk.Revit.DB.Analysis Namespace


MEPAnalyticalSegment.Id Property

MEPAnalyticalSegmentId Property

The identity of this segment.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Id { get; }
Public ReadOnly Property Id As Integer
    Get
public:
property int Id {
    int get ();
}
member Id : int with get

Property Value

Int32
See Also

Reference

MEPAnalyticalSegment Class
Autodesk.Revit.DB.Analysis Namespace


MEPAnalyticalSegment.InnerDiameter Property

MEPAnalyticalSegmentInnerDiameter Property

The inner diameter of this segment, in ft. For rectangular or oval profile, this may be the hydraulic diameter.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double InnerDiameter { get; }
Public ReadOnly Property InnerDiameter As Double
    Get
public:
property double InnerDiameter {
    double get ();
}
member InnerDiameter : float with get

Property Value

Double
See Also

Reference

MEPAnalyticalSegment Class
Autodesk.Revit.DB.Analysis Namespace


MEPAnalyticalSegment.IsValidObject Property

MEPAnalyticalSegmentIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

MEPAnalyticalSegment Class
Autodesk.Revit.DB.Analysis Namespace


MEPAnalyticalSegment.RevitElementId Property

MEPAnalyticalSegmentRevitElementId Property

The id of the owning Revit element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId RevitElementId { get; }
Public ReadOnly Property RevitElementId As ElementId
    Get
public:
property ElementId^ RevitElementId {
    ElementId^ get ();
}
member RevitElementId : ElementId with get

Property Value

ElementId
See Also

Reference

MEPAnalyticalSegment Class
Autodesk.Revit.DB.Analysis Namespace


MEPAnalyticalSegment.Roughness Property

MEPAnalyticalSegmentRoughness Property

The roughness of this segment, in ft.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Roughness { get; }
Public ReadOnly Property Roughness As Double
    Get
public:
property double Roughness {
    double get ();
}
member Roughness : float with get

Property Value

Double
See Also

Reference

MEPAnalyticalSegment Class
Autodesk.Revit.DB.Analysis Namespace


MEPAnalyticalSegment.SegmentType Property

MEPAnalyticalSegmentSegmentType Property

The analytical segment type.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MEPAnalyticalSegmentType SegmentType { get; }
Public ReadOnly Property SegmentType As MEPAnalyticalSegmentType
    Get
public:
property MEPAnalyticalSegmentType SegmentType {
    MEPAnalyticalSegmentType get ();
}
member SegmentType : MEPAnalyticalSegmentType with get

Property Value

MEPAnalyticalSegmentType
See Also

Reference

MEPAnalyticalSegment Class
Autodesk.Revit.DB.Analysis Namespace


MEPAnalyticalSegment.StartNode Property

MEPAnalyticalSegmentStartNode Property

The id of the start analytical node.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int StartNode { get; }
Public ReadOnly Property StartNode As Integer
    Get
public:
property int StartNode {
    int get ();
}
member StartNode : int with get

Property Value

Int32
See Also

Reference

MEPAnalyticalSegment Class
Autodesk.Revit.DB.Analysis Namespace


MEPAnalyticalSegment Methods

The MEPAnalyticalSegment type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetNetworkSegmentId | Gets the NetworkSegmentId.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MEPAnalyticalSegment Class
Autodesk.Revit.DB.Analysis Namespace


MEPAnalyticalSegment.Dispose Method

MEPAnalyticalSegmentDispose Method

Releases all resources used by the MEPAnalyticalSegment

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

MEPAnalyticalSegment Class
Autodesk.Revit.DB.Analysis Namespace


MEPAnalyticalSegment.GetNetworkSegmentId Method

MEPAnalyticalSegmentGetNetworkSegmentId Method

Gets the NetworkSegmentId.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MEPNetworkSegmentId GetNetworkSegmentId()
Public Function GetNetworkSegmentId As MEPNetworkSegmentId
public:
MEPNetworkSegmentId^ GetNetworkSegmentId()
member GetNetworkSegmentId : unit -> MEPNetworkSegmentId

Return Value

MEPNetworkSegmentId
See Also

Reference

MEPAnalyticalSegment Class
Autodesk.Revit.DB.Analysis Namespace


MEPAnalyticalSegmentType Enumeration

The type of analytical segment.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum MEPAnalyticalSegmentType
Public Enumeration MEPAnalyticalSegmentType
public enum class MEPAnalyticalSegmentType
type MEPAnalyticalSegmentType
Members
Member name | Value | Description
Undefined | 0 | The segment is undefined.
Segment | 1 | The segment is straight.
Fitting | 2 | The segment is fitting.
Pump | 3 | The segment is pump.
Loss | 4 | The terminal loss (e.g., radiator, coil, etc.)
SourceEquipment | 5 | The source equipment (e.g., chiller, boiler, etc.)
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


MEPNetworkIterator Class

An iterator to traverse the MEP analytical network.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DB.AnalysisMEPNetworkIterator

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MEPNetworkIterator : IDisposable
Public Class MEPNetworkIterator
    Implements IDisposable
public ref class MEPNetworkIterator : IDisposable
type MEPNetworkIterator =
    class
        interface IDisposable
    end

The MEPNetworkIterator type exposes the following members.

Constructors
 | Name | Description
Public method | MEPNetworkIterator(Document, MEPAnalyticalSegment) | Creates an iterator to visit the connected segments on both sides.
Public method | MEPNetworkIterator(Document, MEPAnalyticalModelData, ConnectorDomainType) | Creates an iterator by the analytical model data to visit all connected components in the network.
Public method | MEPNetworkIterator(Document, MEPAnalyticalNode, MEPAnalyticalSegment) | Creates an iterator to visit the connected segments on one side of the network.
Top
Properties
 | Name | Description
Public property | CurrentElementId | The element id at the current iteration step.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SystemClassification | The optional MEP system classification where the iterations are restricted.
Public property | SystemId | The optional MEP system element id where the iterations are restricted.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the MEPNetworkIterator
Public method | End | Checks if the network iteration has completed.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAnalyticalModelData | Gets the analytical model data at the current iteration step.
Public method | GetAnalyticalNode | Gets the analytical node at the current iteration step.
Public method | GetAnalyticalSegment | Gets the analytical segment at the current iteration step.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetOtherAnalyticalNode | Gets the other analytical node at the current iteration step.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Next | Moves this iterator to the next step of network iteration.
Public method | Start | Gets the first step of network iteration.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
The iterator will visit the entire MEP analytical network in the depth-first order. For evert next step, one analytical node and one analytical segment are typically visited. Sometimes an extra node is provided if the iteration reaches the end on one side and restarts at the previous intersect node. Also note that the start step may not contain any segment.
Example
C#
VB
C++
F#
Copy
// Create a new MEPNetworkIterator to traverse a piping network in the depth-first order.
int segmentCount = 0;
MEPNetworkIterator netIter = new MEPNetworkIterator(doc, modelData, ConnectorDomainType.Piping);
for(netIter.Start(); !netIter.End(); netIter.Next())
{
   MEPAnalyticalSegment segment = netIter.GetAnalyticalSegment();
   if (segment != null)
      segmentCount++;
}
' Create a new MEPNetworkIterator to traverse a piping network in the depth-first order.
Dim segmentCount = 0
Dim netIter As MEPNetworkIterator = New MEPNetworkIterator(doc, modelData, ConnectorDomainType.Piping)
netIter.Start()

While Not netIter.End()
    Dim segment As MEPAnalyticalSegment = netIter.GetAnalyticalSegment()
    If segment IsNot Nothing Then segmentCount += 1
    netIter.Next()
End While

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


MEPNetworkIterator Constructor

Overload List
 | Name | Description
Public method | MEPNetworkIterator(Document, MEPAnalyticalSegment) | Creates an iterator to visit the connected segments on both sides.
Public method | MEPNetworkIterator(Document, MEPAnalyticalModelData, ConnectorDomainType) | Creates an iterator by the analytical model data to visit all connected components in the network.
Public method | MEPNetworkIterator(Document, MEPAnalyticalNode, MEPAnalyticalSegment) | Creates an iterator to visit the connected segments on one side of the network.
Top
See Also

Reference

MEPNetworkIterator Class
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkIterator(Document, MEPAnalyticalSegment) Constructor

Creates an iterator to visit the connected segments on both sides.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MEPNetworkIterator(
    Document pADoc,
    MEPAnalyticalSegment startSegment
)
Public Sub New (
    pADoc As Document,
    startSegment As MEPAnalyticalSegment
)
public:
MEPNetworkIterator(
    Document^ pADoc,
    MEPAnalyticalSegment^ startSegment
)
new :
        pADoc : Document *
        startSegment : MEPAnalyticalSegment -> MEPNetworkIterator

Parameters

pADoc Document
The document of the analytical network.
startSegment MEPAnalyticalSegment
The starting analytical segment.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

MEPNetworkIterator Class
MEPNetworkIterator Overload
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkIterator(Document, MEPAnalyticalModelData, ConnectorDomainType) Constructor

Creates an iterator by the analytical model data to visit all connected components in the network.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MEPNetworkIterator(
    Document pADoc,
    MEPAnalyticalModelData seed,
    ConnectorDomainType eDomain
)
Public Sub New (
    pADoc As Document,
    seed As MEPAnalyticalModelData,
    eDomain As ConnectorDomainType
)
public:
MEPNetworkIterator(
    Document^ pADoc,
    MEPAnalyticalModelData^ seed,
    ConnectorDomainType eDomain
)
new :
        pADoc : Document *
        seed : MEPAnalyticalModelData *
        eDomain : ConnectorDomainType -> MEPNetworkIterator

Parameters

pADoc Document
The document of the analytical network.
seed MEPAnalyticalModelData
The analytical model data of the starting element.
eDomain ConnectorDomainType
The domain of network that the iteration happens.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

MEPNetworkIterator Class
MEPNetworkIterator Overload
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkIterator(Document, MEPAnalyticalNode, MEPAnalyticalSegment) Constructor

Creates an iterator to visit the connected segments on one side of the network.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MEPNetworkIterator(
    Document pADoc,
    MEPAnalyticalNode startNode,
    MEPAnalyticalSegment startSegment
)
Public Sub New (
    pADoc As Document,
    startNode As MEPAnalyticalNode,
    startSegment As MEPAnalyticalSegment
)
public:
MEPNetworkIterator(
    Document^ pADoc,
    MEPAnalyticalNode^ startNode,
    MEPAnalyticalSegment^ startSegment
)
new :
        pADoc : Document *
        startNode : MEPAnalyticalNode *
        startSegment : MEPAnalyticalSegment -> MEPNetworkIterator

Parameters

pADoc Document
The document of the analytical network.
startNode MEPAnalyticalNode
The starting analytical node. It must be one of two nodes of the starting segment.
startSegment MEPAnalyticalSegment
The starting analytical segment to specify the traversing direction from the starting node.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

MEPNetworkIterator Class
MEPNetworkIterator Overload
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkIterator Properties

The MEPNetworkIterator type exposes the following members.

Properties
 | Name | Description
Public property | CurrentElementId | The element id at the current iteration step.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SystemClassification | The optional MEP system classification where the iterations are restricted.
Public property | SystemId | The optional MEP system element id where the iterations are restricted.
Top
See Also

Reference

MEPNetworkIterator Class
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkIterator.CurrentElementId Property

MEPNetworkIteratorCurrentElementId Property

The element id at the current iteration step.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId CurrentElementId { get; }
Public ReadOnly Property CurrentElementId As ElementId
    Get
public:
property ElementId^ CurrentElementId {
    ElementId^ get ();
}
member CurrentElementId : ElementId with get

Property Value

ElementId
See Also

Reference

MEPNetworkIterator Class
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkIterator.IsValidObject Property

MEPNetworkIteratorIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

MEPNetworkIterator Class
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkIterator.SystemClassification Property

MEPNetworkIteratorSystemClassification Property

The optional MEP system classification where the iterations are restricted.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MEPSystemClassification SystemClassification { get; set; }
Public Property SystemClassification As MEPSystemClassification
    Get
    Set
public:
property MEPSystemClassification SystemClassification {
    MEPSystemClassification get ();
    void set (MEPSystemClassification value);
}
member SystemClassification : MEPSystemClassification with get, set

Property Value

MEPSystemClassification
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

MEPNetworkIterator Class
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkIterator.SystemId Property

MEPNetworkIteratorSystemId Property

The optional MEP system element id where the iterations are restricted.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId SystemId { get; set; }
Public Property SystemId As ElementId
    Get
    Set
public:
property ElementId^ SystemId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member SystemId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

MEPNetworkIterator Class
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkIterator Methods

The MEPNetworkIterator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | End | Checks if the network iteration has completed.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetAnalyticalModelData | Gets the analytical model data at the current iteration step.
Public method | GetAnalyticalNode | Gets the analytical node at the current iteration step.
Public method | GetAnalyticalSegment | Gets the analytical segment at the current iteration step.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetOtherAnalyticalNode | Gets the other analytical node at the current iteration step.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | Next | Moves this iterator to the next step of network iteration.
Public method | Start | Gets the first step of network iteration.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MEPNetworkIterator Class
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkIterator.Dispose Method

MEPNetworkIteratorDispose Method

Releases all resources used by the MEPNetworkIterator

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

MEPNetworkIterator Class
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkIterator.End Method

MEPNetworkIteratorEnd Method

Checks if the network iteration has completed.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool End()
Public Function End As Boolean
public:
bool End()
member End : unit -> bool

Return Value

Boolean
True if all analytical segments and nodes have been visited, otherwise false.
See Also

Reference

MEPNetworkIterator Class
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkIterator.GetAnalyticalModelData Method

MEPNetworkIteratorGetAnalyticalModelData Method

Gets the analytical model data at the current iteration step.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MEPAnalyticalModelData GetAnalyticalModelData()
Public Function GetAnalyticalModelData As MEPAnalyticalModelData
public:
MEPAnalyticalModelData^ GetAnalyticalModelData()
member GetAnalyticalModelData : unit -> MEPAnalyticalModelData

Return Value

MEPAnalyticalModelData
The retrieved model data.
See Also

Reference

MEPNetworkIterator Class
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkIterator.GetAnalyticalNode Method

MEPNetworkIteratorGetAnalyticalNode Method

Gets the analytical node at the current iteration step.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MEPAnalyticalNode GetAnalyticalNode()
Public Function GetAnalyticalNode As MEPAnalyticalNode
public:
MEPAnalyticalNode^ GetAnalyticalNode()
member GetAnalyticalNode : unit -> MEPAnalyticalNode

Return Value

MEPAnalyticalNode
The retrieved node.
See Also

Reference

MEPNetworkIterator Class
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkIterator.GetAnalyticalSegment Method

MEPNetworkIteratorGetAnalyticalSegment Method

Gets the analytical segment at the current iteration step.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MEPAnalyticalSegment GetAnalyticalSegment()
Public Function GetAnalyticalSegment As MEPAnalyticalSegment
public:
MEPAnalyticalSegment^ GetAnalyticalSegment()
member GetAnalyticalSegment : unit -> MEPAnalyticalSegment

Return Value

MEPAnalyticalSegment
The retrieved segment, may be null for the first step.
See Also

Reference

MEPNetworkIterator Class
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkIterator.GetOtherAnalyticalNode Method

MEPNetworkIteratorGetOtherAnalyticalNode Method

Gets the other analytical node at the current iteration step.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MEPAnalyticalNode GetOtherAnalyticalNode()
Public Function GetOtherAnalyticalNode As MEPAnalyticalNode
public:
MEPAnalyticalNode^ GetOtherAnalyticalNode()
member GetOtherAnalyticalNode : unit -> MEPAnalyticalNode

Return Value

MEPAnalyticalNode
The retrieved analytical node, null if the current iteration step does not have additional analytical node.
See Also

Reference

MEPNetworkIterator Class
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkIterator.Next Method

MEPNetworkIteratorNext Method

Moves this iterator to the next step of network iteration.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Next()
Public Sub Next
public:
void Next()
member Next : unit -> unit
See Also

Reference

MEPNetworkIterator Class
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkIterator.Start Method

MEPNetworkIteratorStart Method

Gets the first step of network iteration.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Start()
Public Sub Start
public:
void Start()
member Start : unit -> unit
Remarks
The first step may not contain any analytical segment, but the first analytical node.
See Also

Reference

MEPNetworkIterator Class
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkSegmentData Class

Represents the analysis data for one network segment.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DB.AnalysisMEPNetworkSegmentData

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MEPNetworkSegmentData : IDisposable
Public Class MEPNetworkSegmentData
    Implements IDisposable
public ref class MEPNetworkSegmentData : IDisposable
type MEPNetworkSegmentData =
    class
        interface IDisposable
    end

The MEPNetworkSegmentData type exposes the following members.

Constructors
 | Name | Description
Public method | MEPNetworkSegmentData | Creates a default segment data object.
Public method | MEPNetworkSegmentData(MEPNetworkSegmentData) | Creates a new segment data object based on another object.
Top
Properties
 | Name | Description
Public property | Coefficient | The calculated coefficient of this segment, dimensionless.
Public property | Flow | The calculated flow of this segment, in ft^3/s. The positive value means the flow is from the start to the end node, the negative value means opposite direction.
Public property | FlowState | The calculated flow state of this segment.
Public property | FrictionFactor | The calculated friction factor of this segment, dimensionless.
Public property | IsCriticalPath | Verifies if the segment is on the critical path.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | PressureDrop | The calculated pressure drop of this segment, in kg/(ft*s^2).
Public property | RelativeRoughness | The relative roughness of this segment, dimensionless.
Public property | ReynoldsNumber | The Reynolds number of this segment, dimensionless.
Public property | SectionNumber | The section this segment belongs to.
Public property | Velocity | The calculated velocity of this segment, in ft/s.
Public property | VelocityPressure | The calculated velocity pressure of this segment, in kg/(ft*s^2).
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the MEPNetworkSegmentData
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetDownstreamSegments | Gets all downstream network segments.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetUpstreamSegments | Gets all upstream network segments.
Public method | IsValid | Verified if this segment data has been assigned some valid values afer calculation.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


MEPNetworkSegmentData Constructor

Overload List
 | Name | Description
Public method | MEPNetworkSegmentData | Creates a default segment data object.
Public method | MEPNetworkSegmentData(MEPNetworkSegmentData) | Creates a new segment data object based on another object.
Top
See Also

Reference

MEPNetworkSegmentData Class
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkSegmentData Constructor

Creates a default segment data object.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MEPNetworkSegmentData()
Public Sub New
public:
MEPNetworkSegmentData()
new : unit -> MEPNetworkSegmentData
See Also

Reference

MEPNetworkSegmentData Class
MEPNetworkSegmentData Overload
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkSegmentData(MEPNetworkSegmentData) Constructor

Creates a new segment data object based on another object.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MEPNetworkSegmentData(
    MEPNetworkSegmentData other
)
Public Sub New (
    other As MEPNetworkSegmentData
)
public:
MEPNetworkSegmentData(
    MEPNetworkSegmentData^ other
)
new :
        other : MEPNetworkSegmentData -> MEPNetworkSegmentData

Parameters

other MEPNetworkSegmentData
The other segment data that the new object is based on.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

MEPNetworkSegmentData Class
MEPNetworkSegmentData Overload
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkSegmentData Properties

The MEPNetworkSegmentData type exposes the following members.

Properties
 | Name | Description
Public property | Coefficient | The calculated coefficient of this segment, dimensionless.
Public property | Flow | The calculated flow of this segment, in ft^3/s. The positive value means the flow is from the start to the end node, the negative value means opposite direction.
Public property | FlowState | The calculated flow state of this segment.
Public property | FrictionFactor | The calculated friction factor of this segment, dimensionless.
Public property | IsCriticalPath | Verifies if the segment is on the critical path.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | PressureDrop | The calculated pressure drop of this segment, in kg/(ft*s^2).
Public property | RelativeRoughness | The relative roughness of this segment, dimensionless.
Public property | ReynoldsNumber | The Reynolds number of this segment, dimensionless.
Public property | SectionNumber | The section this segment belongs to.
Public property | Velocity | The calculated velocity of this segment, in ft/s.
Public property | VelocityPressure | The calculated velocity pressure of this segment, in kg/(ft*s^2).
Top
See Also

Reference

MEPNetworkSegmentData Class
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkSegmentData.Coefficient Property

MEPNetworkSegmentDataCoefficient Property

The calculated coefficient of this segment, dimensionless.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Coefficient { get; }
Public ReadOnly Property Coefficient As Double
    Get
public:
property double Coefficient {
    double get ();
}
member Coefficient : float with get

Property Value

Double
See Also

Reference

MEPNetworkSegmentData Class
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkSegmentData.Flow Property

MEPNetworkSegmentDataFlow Property

The calculated flow of this segment, in ft^3/s. The positive value means the flow is from the start to the end node, the negative value means opposite direction.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Flow { get; }
Public ReadOnly Property Flow As Double
    Get
public:
property double Flow {
    double get ();
}
member Flow : float with get

Property Value

Double
See Also

Reference

MEPNetworkSegmentData Class
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkSegmentData.FlowState Property

MEPNetworkSegmentDataFlowState Property

The calculated flow state of this segment.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PipeFlowState FlowState { get; }
Public ReadOnly Property FlowState As PipeFlowState
    Get
public:
property PipeFlowState FlowState {
    PipeFlowState get ();
}
member FlowState : PipeFlowState with get

Property Value

PipeFlowState
See Also

Reference

MEPNetworkSegmentData Class
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkSegmentData.FrictionFactor Property

MEPNetworkSegmentDataFrictionFactor Property

The calculated friction factor of this segment, dimensionless.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double FrictionFactor { get; }
Public ReadOnly Property FrictionFactor As Double
    Get
public:
property double FrictionFactor {
    double get ();
}
member FrictionFactor : float with get

Property Value

Double
See Also

Reference

MEPNetworkSegmentData Class
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkSegmentData.IsCriticalPath Property

MEPNetworkSegmentDataIsCriticalPath Property

Verifies if the segment is on the critical path.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCriticalPath { get; }
Public ReadOnly Property IsCriticalPath As Boolean
    Get
public:
property bool IsCriticalPath {
    bool get ();
}
member IsCriticalPath : bool with get

Property Value

Boolean
See Also

Reference

MEPNetworkSegmentData Class
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkSegmentData.IsValidObject Property

MEPNetworkSegmentDataIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

MEPNetworkSegmentData Class
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkSegmentData.PressureDrop Property

MEPNetworkSegmentDataPressureDrop Property

The calculated pressure drop of this segment, in kg/(ft*s^2).

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double PressureDrop { get; }
Public ReadOnly Property PressureDrop As Double
    Get
public:
property double PressureDrop {
    double get ();
}
member PressureDrop : float with get

Property Value

Double
See Also

Reference

MEPNetworkSegmentData Class
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkSegmentData.RelativeRoughness Property

MEPNetworkSegmentDataRelativeRoughness Property

The relative roughness of this segment, dimensionless.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double RelativeRoughness { get; }
Public ReadOnly Property RelativeRoughness As Double
    Get
public:
property double RelativeRoughness {
    double get ();
}
member RelativeRoughness : float with get

Property Value

Double
See Also

Reference

MEPNetworkSegmentData Class
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkSegmentData.ReynoldsNumber Property

MEPNetworkSegmentDataReynoldsNumber Property

The Reynolds number of this segment, dimensionless.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double ReynoldsNumber { get; }
Public ReadOnly Property ReynoldsNumber As Double
    Get
public:
property double ReynoldsNumber {
    double get ();
}
member ReynoldsNumber : float with get

Property Value

Double
See Also

Reference

MEPNetworkSegmentData Class
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkSegmentData.SectionNumber Property

MEPNetworkSegmentDataSectionNumber Property

The section this segment belongs to.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int SectionNumber { get; }
Public ReadOnly Property SectionNumber As Integer
    Get
public:
property int SectionNumber {
    int get ();
}
member SectionNumber : int with get

Property Value

Int32
See Also

Reference

MEPNetworkSegmentData Class
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkSegmentData.Velocity Property

MEPNetworkSegmentDataVelocity Property

The calculated velocity of this segment, in ft/s.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double Velocity { get; }
Public ReadOnly Property Velocity As Double
    Get
public:
property double Velocity {
    double get ();
}
member Velocity : float with get

Property Value

Double
See Also

Reference

MEPNetworkSegmentData Class
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkSegmentData.VelocityPressure Property

MEPNetworkSegmentDataVelocityPressure Property

The calculated velocity pressure of this segment, in kg/(ft*s^2).

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double VelocityPressure { get; }
Public ReadOnly Property VelocityPressure As Double
    Get
public:
property double VelocityPressure {
    double get ();
}
member VelocityPressure : float with get

Property Value

Double
See Also

Reference

MEPNetworkSegmentData Class
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkSegmentData Methods

The MEPNetworkSegmentData type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetDownstreamSegments | Gets all downstream network segments.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetUpstreamSegments | Gets all upstream network segments.
Public method | IsValid | Verified if this segment data has been assigned some valid values afer calculation.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MEPNetworkSegmentData Class
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkSegmentData.Dispose Method

MEPNetworkSegmentDataDispose Method

Releases all resources used by the MEPNetworkSegmentData

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

MEPNetworkSegmentData Class
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkSegmentData.GetDownstreamSegments Method

MEPNetworkSegmentDataGetDownstreamSegments Method

Gets all downstream network segments.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<MEPNetworkSegmentId> GetDownstreamSegments()
Public Function GetDownstreamSegments As IList(Of MEPNetworkSegmentId)
public:
IList<MEPNetworkSegmentId^>^ GetDownstreamSegments()
member GetDownstreamSegments : unit -> IList<MEPNetworkSegmentId>

Return Value

IList MEPNetworkSegmentId
The list of segments that flow out of this segment.
See Also

Reference

MEPNetworkSegmentData Class
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkSegmentData.GetUpstreamSegments Method

MEPNetworkSegmentDataGetUpstreamSegments Method

Gets all upstream network segments.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<MEPNetworkSegmentId> GetUpstreamSegments()
Public Function GetUpstreamSegments As IList(Of MEPNetworkSegmentId)
public:
IList<MEPNetworkSegmentId^>^ GetUpstreamSegments()
member GetUpstreamSegments : unit -> IList<MEPNetworkSegmentId>

Return Value

IList MEPNetworkSegmentId
The list of segments that flow into this segment.
See Also

Reference

MEPNetworkSegmentData Class
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkSegmentData.IsValid Method

MEPNetworkSegmentDataIsValid Method

Verified if this segment data has been assigned some valid values afer calculation.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValid()
Public Function IsValid As Boolean
public:
bool IsValid()
member IsValid : unit -> bool

Return Value

Boolean
True if the segment was assigned valid values, otherwise false.
See Also

Reference

MEPNetworkSegmentData Class
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkSegmentId Class

Represents a unique identifier for one analytical segment in the network.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DB.AnalysisMEPNetworkSegmentId

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class MEPNetworkSegmentId : IDisposable
Public Class MEPNetworkSegmentId
    Implements IDisposable
public ref class MEPNetworkSegmentId : IDisposable
type MEPNetworkSegmentId =
    class
        interface IDisposable
    end

The MEPNetworkSegmentId type exposes the following members.

Constructors
 | Name | Description
Public method | MEPNetworkSegmentId | Creates a default invalid segment id on the network.
Public method | MEPNetworkSegmentId(ElementId, Int32) | Creates a valid segment id on the network.
Top
Properties
 | Name | Description
Public property | ElementId | The element id where this analytical segment belongs.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SegmentId | The segment identifier.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the MEPNetworkSegmentId
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsValid | Verifies if this is a valid segment id.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


MEPNetworkSegmentId Constructor

Overload List
 | Name | Description
Public method | MEPNetworkSegmentId | Creates a default invalid segment id on the network.
Public method | MEPNetworkSegmentId(ElementId, Int32) | Creates a valid segment id on the network.
Top
See Also

Reference

MEPNetworkSegmentId Class
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkSegmentId Constructor

Creates a default invalid segment id on the network.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MEPNetworkSegmentId()
Public Sub New
public:
MEPNetworkSegmentId()
new : unit -> MEPNetworkSegmentId
See Also

Reference

MEPNetworkSegmentId Class
MEPNetworkSegmentId Overload
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkSegmentId(ElementId, Int32) Constructor

Creates a valid segment id on the network.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MEPNetworkSegmentId(
    ElementId idElem,
    int segment
)
Public Sub New (
    idElem As ElementId,
    segment As Integer
)
public:
MEPNetworkSegmentId(
    ElementId^ idElem,
    int segment
)
new :
        idElem : ElementId *
        segment : int -> MEPNetworkSegmentId

Parameters

idElem ElementId
segment Int32
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

MEPNetworkSegmentId Class
MEPNetworkSegmentId Overload
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkSegmentId Properties

The MEPNetworkSegmentId type exposes the following members.

Properties
 | Name | Description
Public property | ElementId | The element id where this analytical segment belongs.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | SegmentId | The segment identifier.
Top
See Also

Reference

MEPNetworkSegmentId Class
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkSegmentId.ElementId Property

MEPNetworkSegmentIdElementId Property

The element id where this analytical segment belongs.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId ElementId { get; set; }
Public Property ElementId As ElementId
    Get
    Set
public:
property ElementId^ ElementId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member ElementId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

MEPNetworkSegmentId Class
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkSegmentId.IsValidObject Property

MEPNetworkSegmentIdIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

MEPNetworkSegmentId Class
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkSegmentId.SegmentId Property

MEPNetworkSegmentIdSegmentId Property

The segment identifier.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int SegmentId { get; set; }
Public Property SegmentId As Integer
    Get
    Set
public:
property int SegmentId {
    int get ();
    void set (int value);
}
member SegmentId : int with get, set

Property Value

Int32
See Also

Reference

MEPNetworkSegmentId Class
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkSegmentId Methods

The MEPNetworkSegmentId type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IsValid | Verifies if this is a valid segment id.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

MEPNetworkSegmentId Class
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkSegmentId.Dispose Method

MEPNetworkSegmentIdDispose Method

Releases all resources used by the MEPNetworkSegmentId

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

MEPNetworkSegmentId Class
Autodesk.Revit.DB.Analysis Namespace


MEPNetworkSegmentId.IsValid Method

MEPNetworkSegmentIdIsValid Method

Verifies if this is a valid segment id.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValid()
Public Function IsValid As Boolean
public:
bool IsValid()
member IsValid : unit -> bool

Return Value

Boolean
True if this is a valid segment id, otherwise false.
See Also

Reference

MEPNetworkSegmentId Class
Autodesk.Revit.DB.Analysis Namespace


OutdoorAirFlowStandard Enumeration

An enumerated type listing all the possible outdoor airflow standard for a space type.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum OutdoorAirFlowStandard
Public Enumeration OutdoorAirFlowStandard
public enum class OutdoorAirFlowStandard
type OutdoorAirFlowStandard
Members
Member name | Value | Description
ByPeopleAndByArea | 0 | By people and by area.
ByACH | 1 | By ACH.
MaxByPeople_ByArea | 2 | Maximum(by people, by area).
MaxByACH_ByPeopleByArea | 3 | Maximum(by ACH, by people and by area).
MaxByACH_ByArea_ByPeople | 4 | Maximum(by ACH, by area, by people).
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


PathOfTravel Class

An element which holds a graphical representation of the shortest route between two points in the plane of a floor plan view. The shortest route is calculated to go around model geometry visible in the view. Route calculation is affected by properties of the RouteAnalysisSettings element.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DB.AnalysisPathOfTravel

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PathOfTravel : Element
Public Class PathOfTravel
    Inherits Element
public ref class PathOfTravel : public Element
type PathOfTravel =
    class
        inherit Element
    end

The PathOfTravel type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LineStyle | The line style of the path.
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | PathEnd | The end point of the path. The Z coordinate will equal the view's level elevation. To update path calculations, call update.
Public property | PathMidpoint | The midpoint of the path. The Z coordinate will equal the view's level elevation.
Public property | PathStart | The start point of the path. The Z coordinate will equal the view's level elevation. To update path calculations, call update.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create(View, XYZ, XYZ) | Creates a new path of travel between two points.
 | Create(View, XYZ, XYZ, PathOfTravelCalculationStatus) | Creates a new path of travel between two points and provides creation result status.
 | CreateMapped(View, IListXYZ, IListXYZ) | Creates multiple new paths of travel by mapping each of a set of start points to each of a set of end points.
 | CreateMapped(View, IListXYZ, IListXYZ, IListPathOfTravelCalculationStatus) | Creates multiple new paths of travel by mapping each of a set of start points to each of a set of end points and provides creation result statuses.
 | CreateMultiple(View, IListXYZ, IListXYZ) | Creates multiple new paths of travel between same size sets of start and end points.
 | CreateMultiple(View, IListXYZ, IListXYZ, IListPathOfTravelCalculationStatus) | Creates multiple new paths of travel between same size sets of start and end points and provides creation result statuses.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
 | FindEndsOfShortestPaths | For a floor plan view, calculates the paths from each start point to its closest destination and return the path end points.
 | FindShortestPaths | For a floor plan view, calculates paths from each start point to its closest destinations. Returns the path, represented by an array of XYZ points.
 | FindStartsOfLongestPathsFromRooms | For a floor plan view, calculates paths from points inside rooms to the closests of the destinations. Returns the start points of the longest path(s). If multiple paths have the same longest length, returns multiple start points.
Public method | GetCurves | Gets the array of curves representing the path of travel.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetWaypoints | return the waypoints set for the Path of Travel
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | InsertWaypoint | Insert a waypoint at the specified index
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
 | IsInRevealObstaclesMode | Returns current state of Reveal Obstacles mode for the given view.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveWaypoint | Remove a waypoint.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
 | SetRevealObstaclesMode | Sets Reveal Obstacles mode for the given view.
Public method | SetWaypoint | Updates the specified waypoint.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | Update | Updates the path of travel by recalculating the path between the original start and end points.
 | UpdateMultiple(Document, IListElementId) | Updates the specified paths of travel by recalculating each path using their original start and end points.
 | UpdateMultiple(Document, IListElementId, IListPathOfTravelCalculationStatus) | Updates the specified paths of travel by recalculating each path using their original start and end points and provides creation result statuses.
Top
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


PathOfTravel Properties

The PathOfTravel type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
Public property | LineStyle | The line style of the path.
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | PathEnd | The end point of the path. The Z coordinate will equal the view's level elevation. To update path calculations, call update.
Public property | PathMidpoint | The midpoint of the path. The Z coordinate will equal the view's level elevation.
Public property | PathStart | The start point of the path. The Z coordinate will equal the view's level elevation. To update path calculations, call update.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

PathOfTravel Class
Autodesk.Revit.DB.Analysis Namespace


PathOfTravel.LineStyle Property

PathOfTravelLineStyle Property

The line style of the path.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId LineStyle { get; set; }
Public Property LineStyle As ElementId
    Get
    Set
public:
property ElementId^ LineStyle {
    ElementId^ get ();
    void set (ElementId^ value);
}
member LineStyle : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

PathOfTravel Class
Autodesk.Revit.DB.Analysis Namespace


PathOfTravel.PathEnd Property

PathOfTravelPathEnd Property

The end point of the path. The Z coordinate will equal the view's level elevation. To update path calculations, call update.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ PathEnd { get; set; }
Public Property PathEnd As XYZ
    Get
    Set
public:
property XYZ^ PathEnd {
    XYZ^ get ();
    void set (XYZ^ value);
}
member PathEnd : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
InvalidOperationException | When setting this property: This functionality is not available in Revit LT. -or- When setting this property: Cannot perform this operation for a path of travel in a group.
See Also

Reference

PathOfTravel Class
Autodesk.Revit.DB.Analysis Namespace


PathOfTravel.PathMidpoint Property

PathOfTravelPathMidpoint Property

The midpoint of the path. The Z coordinate will equal the view's level elevation.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ PathMidpoint { get; }
Public ReadOnly Property PathMidpoint As XYZ
    Get
public:
property XYZ^ PathMidpoint {
    XYZ^ get ();
}
member PathMidpoint : XYZ with get

Property Value

XYZ
See Also

Reference

PathOfTravel Class
Autodesk.Revit.DB.Analysis Namespace


PathOfTravel.PathStart Property

PathOfTravelPathStart Property

The start point of the path. The Z coordinate will equal the view's level elevation. To update path calculations, call update.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ PathStart { get; set; }
Public Property PathStart As XYZ
    Get
    Set
public:
property XYZ^ PathStart {
    XYZ^ get ();
    void set (XYZ^ value);
}
member PathStart : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
InvalidOperationException | When setting this property: This functionality is not available in Revit LT. -or- When setting this property: Cannot perform this operation for a path of travel in a group.
See Also

Reference

PathOfTravel Class
Autodesk.Revit.DB.Analysis Namespace


PathOfTravel Methods

The PathOfTravel type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
 | Create(View, XYZ, XYZ) | Creates a new path of travel between two points.
 | Create(View, XYZ, XYZ, PathOfTravelCalculationStatus) | Creates a new path of travel between two points and provides creation result status.
 | CreateMapped(View, IListXYZ, IListXYZ) | Creates multiple new paths of travel by mapping each of a set of start points to each of a set of end points.
 | CreateMapped(View, IListXYZ, IListXYZ, IListPathOfTravelCalculationStatus) | Creates multiple new paths of travel by mapping each of a set of start points to each of a set of end points and provides creation result statuses.
 | CreateMultiple(View, IListXYZ, IListXYZ) | Creates multiple new paths of travel between same size sets of start and end points.
 | CreateMultiple(View, IListXYZ, IListXYZ, IListPathOfTravelCalculationStatus) | Creates multiple new paths of travel between same size sets of start and end points and provides creation result statuses.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
 | FindEndsOfShortestPaths | For a floor plan view, calculates the paths from each start point to its closest destination and return the path end points.
 | FindShortestPaths | For a floor plan view, calculates paths from each start point to its closest destinations. Returns the path, represented by an array of XYZ points.
 | FindStartsOfLongestPathsFromRooms | For a floor plan view, calculates paths from points inside rooms to the closests of the destinations. Returns the start points of the longest path(s). If multiple paths have the same longest length, returns multiple start points.
Public method | GetCurves | Gets the array of curves representing the path of travel.
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetWaypoints | return the waypoints set for the Path of Travel
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | InsertWaypoint | Insert a waypoint at the specified index
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
 | IsInRevealObstaclesMode | Returns current state of Reveal Obstacles mode for the given view.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveWaypoint | Remove a waypoint.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
 | SetRevealObstaclesMode | Sets Reveal Obstacles mode for the given view.
Public method | SetWaypoint | Updates the specified waypoint.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | Update | Updates the path of travel by recalculating the path between the original start and end points.
 | UpdateMultiple(Document, IListElementId) | Updates the specified paths of travel by recalculating each path using their original start and end points.
 | UpdateMultiple(Document, IListElementId, IListPathOfTravelCalculationStatus) | Updates the specified paths of travel by recalculating each path using their original start and end points and provides creation result statuses.
Top
See Also

Reference

PathOfTravel Class
Autodesk.Revit.DB.Analysis Namespace


PathOfTravel.Create Method

PathOfTravelCreate Method

Overload List
Name | Description
Create(View, XYZ, XYZ) | Creates a new path of travel between two points.
Create(View, XYZ, XYZ, PathOfTravelCalculationStatus) | Creates a new path of travel between two points and provides creation result status.
Top
See Also

Reference

PathOfTravel Class
Autodesk.Revit.DB.Analysis Namespace


PathOfTravel.Create(View, XYZ, XYZ) Method

PathOfTravelCreate(View, XYZ, XYZ) Method

Creates a new path of travel between two points.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static PathOfTravel Create(
    View DBView,
    XYZ pathStart,
    XYZ pathEnd
)
Public Shared Function Create (
    DBView As View,
    pathStart As XYZ,
    pathEnd As XYZ
) As PathOfTravel
public:
static PathOfTravel^ Create(
    View^ DBView,
    XYZ^ pathStart,
    XYZ^ pathEnd
)
static member Create :
        DBView : View *
        pathStart : XYZ *
        pathEnd : XYZ -> PathOfTravel

Parameters

DBView View
The floor plan view to use when computing the shortest distance.
pathStart XYZ
The start point of the path. The input Z coordinates are ignored and set to the view's level elevation.
pathEnd XYZ
The end point of the path. The input Z coordinates are ignored and set to the view's level elevation.

Return Value

PathOfTravel
The newly created path of travel element, or if no path between the two points is found.
Exceptions
Exception | Condition
ArgumentException | The element "DBView" is in a family document or a document in in-place edit mode. -or- View is not a floor plan view.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The document containing DBView is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- This operation cannot be performed while the document is in edit mode. -or- The Path of Travel calculation service is not available -or- This functionality is not available in Revit LT.
ModificationForbiddenException | The document containing DBView is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document containing DBView is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document containing DBView has no open transaction.
Remarks
InvalidOperationException is thrown if PathOfTravel cannot be created for the following conditions:
  • View has crop box active and crop box is split
  • View has crop box active and start or end point lies outside of the crop
  • View model outline area is larger than the current limit (2,000,000 sq.ft.)
  • View export contains too much geometry (more than 200,000 lines)
  • Start and end points are too close
See Also

Reference

PathOfTravel Class
Create Overload
Autodesk.Revit.DB.Analysis Namespace


PathOfTravel.Create(View, XYZ, XYZ, PathOfTravelCalculationStatus) Method

PathOfTravelCreate(View, XYZ, XYZ, PathOfTravelCalculationStatus) Method

Creates a new path of travel between two points and provides creation result status.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static PathOfTravel Create(
    View DBView,
    XYZ pathStart,
    XYZ pathEnd,
    out PathOfTravelCalculationStatus resultStatus
)
Public Shared Function Create (
    DBView As View,
    pathStart As XYZ,
    pathEnd As XYZ,
    <OutAttribute> ByRef resultStatus As PathOfTravelCalculationStatus
) As PathOfTravel
public:
static PathOfTravel^ Create(
    View^ DBView,
    XYZ^ pathStart,
    XYZ^ pathEnd,
    [OutAttribute] PathOfTravelCalculationStatus% resultStatus
)
static member Create :
        DBView : View *
        pathStart : XYZ *
        pathEnd : XYZ *
        resultStatus : PathOfTravelCalculationStatus byref -> PathOfTravel

Parameters

DBView View
The floor plan view to use when computing the shortest distance.
pathStart XYZ
The start point of the path. The input Z coordinates are ignored and set to the view's level elevation.
pathEnd XYZ
The end point of the path. The input Z coordinates are ignored and set to the view's level elevation.
resultStatus PathOfTravelCalculationStatus
Result status of path of travel creation.

Return Value

PathOfTravel
The newly created path of travel element, or if no path between the two points is found.
Exceptions
Exception | Condition
ArgumentException | The element "DBView" is in a family document or a document in in-place edit mode. -or- View is not a floor plan view.
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException | The document containing DBView is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- This operation cannot be performed while the document is in edit mode. -or- The Path of Travel calculation service is not available -or- This functionality is not available in Revit LT.
ModificationForbiddenException | The document containing DBView is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document containing DBView is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document containing DBView has no open transaction.
Remarks
InvalidOperationException is thrown if PathOfTravel cannot be created for the following conditions:
  • View has crop box active and crop box is split
  • View has crop box active and start or end point lies outside of the crop
  • View model outline area is larger than the current limit (2,000,000 sq.ft.)
  • View export contains too much geometry (more than 200,000 lines)
  • Start and end points are too close
See Also

Reference

PathOfTravel Class
Create Overload
Autodesk.Revit.DB.Analysis Namespace


PathOfTravel.CreateMapped Method

PathOfTravelCreateMapped Method

Overload List
Name | Description
CreateMapped(View, IListXYZ, IListXYZ) | Creates multiple new paths of travel by mapping each of a set of start points to each of a set of end points.
CreateMapped(View, IListXYZ, IListXYZ, IListPathOfTravelCalculationStatus) | Creates multiple new paths of travel by mapping each of a set of start points to each of a set of end points and provides creation result statuses.
Top
See Also

Reference

PathOfTravel Class
Autodesk.Revit.DB.Analysis Namespace


PathOfTravel.CreateMapped(View, IList<XYZ>, IList<XYZ>) Method

PathOfTravelCreateMapped(View, IListXYZ, IListXYZ) Method

Creates multiple new paths of travel by mapping each of a set of start points to each of a set of end points.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<PathOfTravel> CreateMapped(
    View DBView,
    IList<XYZ> pathStarts,
    IList<XYZ> pathEnds
)
Public Shared Function CreateMapped (
    DBView As View,
    pathStarts As IList(Of XYZ),
    pathEnds As IList(Of XYZ)
) As IList(Of PathOfTravel)
public:
static IList<PathOfTravel^>^ CreateMapped(
    View^ DBView,
    IList<XYZ^>^ pathStarts,
    IList<XYZ^>^ pathEnds
)
static member CreateMapped :
        DBView : View *
        pathStarts : IList<XYZ> *
        pathEnds : IList<XYZ> -> IList<PathOfTravel>

Parameters

DBView View
The floor plan view to use when computing the shortest distance.
pathStarts IList XYZ
The start points of the path. The input Z coordinates are ignored and set to the view's level elevation.
pathEnds IList XYZ
The end points of the path. The input Z coordinates are ignored and set to the view's level elevation.

Return Value

IList PathOfTravel
The array of newly created path of travel elements, or if no path between the two points is found. The number of elements is the number of start points multiplied by the number of end points. The order of elements corresponds to the order of end and then start points in the argument arrays: s0->e0, s1->e0, ... , s0->e1, s1->e1... etc. There are some additional conditions that are checked and if any condition is true the value is returned:
  • View has crop box active and start or end point lies outside of the crop
  • Start and end points are too close
Exceptions
Exception | Condition
ArgumentException | The element "DBView" is in a family document or a document in in-place edit mode. -or- View is not a floor plan view.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The document containing DBView is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- This operation cannot be performed while the document is in edit mode. -or- The Path of Travel calculation service is not available -or- This functionality is not available in Revit LT.
ModificationForbiddenException | The document containing DBView is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document containing DBView is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document containing DBView has no open transaction.
Remarks
InvalidOperationException is thrown if PathOfTravel cannot be created for the following conditions:
  • View has crop box active and crop box is split
  • View model outline area is larger than the current limit (2,000,000 sq.ft.)
  • View export contains too much geometry (more than 200,000 lines)
ArgumentException exception is thrown if arrays of start or end points are of zero size or if the total number of paths of travel attempted to be created is more than maximum allowed (50000).
See Also

Reference

PathOfTravel Class
CreateMapped Overload
Autodesk.Revit.DB.Analysis Namespace


PathOfTravel.CreateMapped(View, IList<XYZ>, IList<XYZ>, IList<PathOfTravelCalculationStatus>) Method

PathOfTravelCreateMapped(View, IListXYZ, IListXYZ, IListPathOfTravelCalculationStatus) Method

Creates multiple new paths of travel by mapping each of a set of start points to each of a set of end points and provides creation result statuses.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<PathOfTravel> CreateMapped(
    View DBView,
    IList<XYZ> pathStarts,
    IList<XYZ> pathEnds,
    out IList<PathOfTravelCalculationStatus> resultStatus
)
Public Shared Function CreateMapped (
    DBView As View,
    pathStarts As IList(Of XYZ),
    pathEnds As IList(Of XYZ),
    <OutAttribute> ByRef resultStatus As IList(Of PathOfTravelCalculationStatus)
) As IList(Of PathOfTravel)
public:
static IList<PathOfTravel^>^ CreateMapped(
    View^ DBView,
    IList<XYZ^>^ pathStarts,
    IList<XYZ^>^ pathEnds,
    [OutAttribute] IList<PathOfTravelCalculationStatus>^% resultStatus
)
static member CreateMapped :
        DBView : View *
        pathStarts : IList<XYZ> *
        pathEnds : IList<XYZ> *
        resultStatus : IList<PathOfTravelCalculationStatus> byref -> IList<PathOfTravel>

Parameters

DBView View
The floor plan view to use when computing the shortest distance.
pathStarts IList XYZ
The start points of the path. The input Z coordinates are ignored and set to the view's level elevation.
pathEnds IList XYZ
The end points of the path. The input Z coordinates are ignored and set to the view's level elevation.
resultStatus IList PathOfTravelCalculationStatus
Result statuses of each path of travel creation. The order of statuses corresponds to the order of elements in the array returned by the function.

Return Value

IList PathOfTravel
The array of newly created path of travel elements, or if no path between the two points is found. The number of elements is the number of start points multiplied by the number of end points. The order of elements corresponds to the order of end and then start points in the argument arrays: s0->e0, s1->e0, ... , s0->e1, s1->e1... etc. There are some additional conditions that are checked and if any condition is true the value is returned:
  • View has crop box active and start or end point lies outside of the crop
  • Start and end points are too close
Exceptions
Exception | Condition
ArgumentException | The element "DBView" is in a family document or a document in in-place edit mode. -or- View is not a floor plan view.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The document containing DBView is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- This operation cannot be performed while the document is in edit mode. -or- The Path of Travel calculation service is not available -or- This functionality is not available in Revit LT.
ModificationForbiddenException | The document containing DBView is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document containing DBView is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document containing DBView has no open transaction.
Remarks
InvalidOperationException is thrown if PathOfTravel cannot be created for the following conditions:
  • View has crop box active and crop box is split
  • View model outline area is larger than the current limit (2,000,000 sq.ft.)
  • View export contains too much geometry (more than 200,000 lines)
ArgumentException exception is thrown if arrays of start or end points are of zero size or if the total number of paths of travel attempted to be created is more than maximum allowed (50000).
See Also

Reference

PathOfTravel Class
CreateMapped Overload
Autodesk.Revit.DB.Analysis Namespace


PathOfTravel.CreateMultiple Method

PathOfTravelCreateMultiple Method

Overload List
Name | Description
CreateMultiple(View, IListXYZ, IListXYZ) | Creates multiple new paths of travel between same size sets of start and end points.
CreateMultiple(View, IListXYZ, IListXYZ, IListPathOfTravelCalculationStatus) | Creates multiple new paths of travel between same size sets of start and end points and provides creation result statuses.
Top
See Also

Reference

PathOfTravel Class
Autodesk.Revit.DB.Analysis Namespace


PathOfTravel.CreateMultiple(View, IList<XYZ>, IList<XYZ>) Method

PathOfTravelCreateMultiple(View, IListXYZ, IListXYZ) Method

Creates multiple new paths of travel between same size sets of start and end points.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<PathOfTravel> CreateMultiple(
    View DBView,
    IList<XYZ> pathStarts,
    IList<XYZ> pathEnds
)
Public Shared Function CreateMultiple (
    DBView As View,
    pathStarts As IList(Of XYZ),
    pathEnds As IList(Of XYZ)
) As IList(Of PathOfTravel)
public:
static IList<PathOfTravel^>^ CreateMultiple(
    View^ DBView,
    IList<XYZ^>^ pathStarts,
    IList<XYZ^>^ pathEnds
)
static member CreateMultiple :
        DBView : View *
        pathStarts : IList<XYZ> *
        pathEnds : IList<XYZ> -> IList<PathOfTravel>

Parameters

DBView View
The floor plan view to use when computing the shortest distance.
pathStarts IList XYZ
The start points of the path. The input Z coordinates are ignored and set to the view's level elevation.
pathEnds IList XYZ
The end points of the path. The input Z coordinates are ignored and set to the view's level elevation.

Return Value

IList PathOfTravel
The array of newly created path of travel elements, or if no path between the two points is found. The order of elements corresponds to the order of start/end points in the argument arrays. There are some additional conditions that are checked and if any condition is true the value is returned:
  • View has crop box active and start or end point lies outside of the crop
  • Start and end points are too close
Exceptions
Exception | Condition
ArgumentException | The element "DBView" is in a family document or a document in in-place edit mode. -or- View is not a floor plan view.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The document containing DBView is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- This operation cannot be performed while the document is in edit mode. -or- The Path of Travel calculation service is not available -or- This functionality is not available in Revit LT.
ModificationForbiddenException | The document containing DBView is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document containing DBView is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document containing DBView has no open transaction.
Remarks
InvalidOperationException is thrown if PathOfTravel cannot be created for the following conditions:
  • View has crop box active and crop box is split
  • View model outline area is larger than the current limit (2,000,000 sq.ft.)
  • View export contains too much geometry (more than 200,000 lines)
ArgumentException exception is thrown if arrays of start and end points are of different size or if the total number of paths of travel attempted to be created is more than maximum allowed (50000).
See Also

Reference

PathOfTravel Class
CreateMultiple Overload
Autodesk.Revit.DB.Analysis Namespace


PathOfTravel.CreateMultiple(View, IList<XYZ>, IList<XYZ>, IList<PathOfTravelCalculationStatus>) Method

PathOfTravelCreateMultiple(View, IListXYZ, IListXYZ, IListPathOfTravelCalculationStatus) Method

Creates multiple new paths of travel between same size sets of start and end points and provides creation result statuses.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<PathOfTravel> CreateMultiple(
    View DBView,
    IList<XYZ> pathStarts,
    IList<XYZ> pathEnds,
    out IList<PathOfTravelCalculationStatus> resultStatus
)
Public Shared Function CreateMultiple (
    DBView As View,
    pathStarts As IList(Of XYZ),
    pathEnds As IList(Of XYZ),
    <OutAttribute> ByRef resultStatus As IList(Of PathOfTravelCalculationStatus)
) As IList(Of PathOfTravel)
public:
static IList<PathOfTravel^>^ CreateMultiple(
    View^ DBView,
    IList<XYZ^>^ pathStarts,
    IList<XYZ^>^ pathEnds,
    [OutAttribute] IList<PathOfTravelCalculationStatus>^% resultStatus
)
static member CreateMultiple :
        DBView : View *
        pathStarts : IList<XYZ> *
        pathEnds : IList<XYZ> *
        resultStatus : IList<PathOfTravelCalculationStatus> byref -> IList<PathOfTravel>

Parameters

DBView View
The floor plan view to use when computing the shortest distance.
pathStarts IList XYZ
The start points of the path. The input Z coordinates are ignored and set to the view's level elevation.
pathEnds IList XYZ
The end points of the path. The input Z coordinates are ignored and set to the view's level elevation.
resultStatus IList PathOfTravelCalculationStatus
Result statuses of each path of travel creation. The order of statuses corresponds to the order of elements in the array returned by the function.

Return Value

IList PathOfTravel
The array of newly created path of travel elements, or if no path between the two points is found. The order of elements corresponds to the order of start/end points in the argument arrays. There are some additional conditions that are checked and if any condition is true the value is returned:
  • View has crop box active and start or end point lies outside of the crop
  • Start and end points are too close
Exceptions
Exception | Condition
ArgumentException | The element "DBView" is in a family document or a document in in-place edit mode. -or- View is not a floor plan view.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The document containing DBView is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- This operation cannot be performed while the document is in edit mode. -or- The Path of Travel calculation service is not available -or- This functionality is not available in Revit LT.
ModificationForbiddenException | The document containing DBView is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document containing DBView is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document containing DBView has no open transaction.
Remarks
InvalidOperationException is thrown if PathOfTravel cannot be created for the following conditions:
  • View has crop box active and crop box is split
  • View model outline area is larger than the current limit (2,000,000 sq.ft.)
  • View export contains too much geometry (more than 200,000 lines)
ArgumentException exception is thrown if arrays of start and end points are of different size or if the total number of paths of travel attempted to be created is more than maximum allowed (50000).
See Also

Reference

PathOfTravel Class
CreateMultiple Overload
Autodesk.Revit.DB.Analysis Namespace


PathOfTravel.FindEndsOfShortestPaths Method

PathOfTravelFindEndsOfShortestPaths Method

For a floor plan view, calculates the paths from each start point to its closest destination and return the path end points.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<XYZ> FindEndsOfShortestPaths(
    View DBView,
    IList<XYZ> destinationPoints,
    IList<XYZ> startPoints
)
Public Shared Function FindEndsOfShortestPaths (
    DBView As View,
    destinationPoints As IList(Of XYZ),
    startPoints As IList(Of XYZ)
) As IList(Of XYZ)
public:
static IList<XYZ^>^ FindEndsOfShortestPaths(
    View^ DBView,
    IList<XYZ^>^ destinationPoints,
    IList<XYZ^>^ startPoints
)
static member FindEndsOfShortestPaths :
        DBView : View *
        destinationPoints : IList<XYZ> *
        startPoints : IList<XYZ> -> IList<XYZ>

Parameters

DBView View
The floor plan view to use when computing the points.
destinationPoints IList XYZ
Destination points. The input Z coordinates are ignored and set to the view's level elevation.
startPoints IList XYZ
Start points for which shortest path end points are calculated.

Return Value

IList XYZ
End points of paths calculated from each start point to its corresponding closest destination. If a path cannot be calculated the corresponsing end point is set to the corresponding start point.
Exceptions
Exception | Condition
ArgumentException | View is not a floor plan view.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The Path of Travel calculation service is not available -or- This functionality is not available in Revit LT.
Remarks
The calculation is done in a floor plan with one or more destinationPoints and one or more startPoints. The shortest path is calculated from each start point to its corresponding closest destination.
See Also

Reference

PathOfTravel Class
Autodesk.Revit.DB.Analysis Namespace


PathOfTravel.FindShortestPaths Method

PathOfTravelFindShortestPaths Method

For a floor plan view, calculates paths from each start point to its closest destinations. Returns the path, represented by an array of XYZ points.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<IList<XYZ>> FindShortestPaths(
    View DBView,
    IList<XYZ> destinationPoints,
    IList<XYZ> startPoints
)
Public Shared Function FindShortestPaths (
    DBView As View,
    destinationPoints As IList(Of XYZ),
    startPoints As IList(Of XYZ)
) As IList(Of IList(Of XYZ))
public:
static IList<IList<XYZ^>^>^ FindShortestPaths(
    View^ DBView,
    IList<XYZ^>^ destinationPoints,
    IList<XYZ^>^ startPoints
)
static member FindShortestPaths :
        DBView : View *
        destinationPoints : IList<XYZ> *
        startPoints : IList<XYZ> -> IList<IList<XYZ>>

Parameters

DBView View
The floor plan view to use when computing the points.
destinationPoints IList XYZ
Destination points. The input Z coordinates are ignored and set to the view's level elevation.
startPoints IList XYZ
Start points for which shortest paths are calculated.

Return Value

IList IList XYZ
Array of paths calculated from each start point to its corresponding closest destination. If a path cannot be caculated the corresponsing sub-array is set to an empty array.
Exceptions
Exception | Condition
ArgumentException | View is not a floor plan view.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The Path of Travel calculation service is not available -or- This functionality is not available in Revit LT.
Remarks
The calculation is done in a floor plan with one or more destinationPoints and one or more startPoints. The shortest path is calculated from each start point to its closest destination point.
See Also

Reference

PathOfTravel Class
Autodesk.Revit.DB.Analysis Namespace


PathOfTravel.FindStartsOfLongestPathsFromRooms Method

PathOfTravelFindStartsOfLongestPathsFromRooms Method

For a floor plan view, calculates paths from points inside rooms to the closests of the destinations. Returns the start points of the longest path(s). If multiple paths have the same longest length, returns multiple start points.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static IList<XYZ> FindStartsOfLongestPathsFromRooms(
    View DBView,
    IList<XYZ> destinationPoints
)
Public Shared Function FindStartsOfLongestPathsFromRooms (
    DBView As View,
    destinationPoints As IList(Of XYZ)
) As IList(Of XYZ)
public:
static IList<XYZ^>^ FindStartsOfLongestPathsFromRooms(
    View^ DBView,
    IList<XYZ^>^ destinationPoints
)
static member FindStartsOfLongestPathsFromRooms :
        DBView : View *
        destinationPoints : IList<XYZ> -> IList<XYZ>

Parameters

DBView View
The floor plan view to use when computing the points.
destinationPoints IList XYZ
Destination points. The input Z coordinates are ignored and set to the view's level elevation.

Return Value

IList XYZ
Start points of the paths with longest lengths. The array is empty if there are no valid paths from any points in rooms to any of the destination points.
Exceptions
Exception | Condition
ArgumentException | View is not a floor plan view.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The Path of Travel calculation service is not available -or- This functionality is not available in Revit LT.
Remarks
The entire plan is divided in small tiles, and the distance to the closest destination point is calculated for each tile center point. Only tile center points that are located in rooms in the view are taken into account.
See Also

Reference

PathOfTravel Class
Autodesk.Revit.DB.Analysis Namespace


PathOfTravel.GetCurves Method

PathOfTravelGetCurves Method

Gets the array of curves representing the path of travel.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<Curve> GetCurves()
Public Function GetCurves As IList(Of Curve)
public:
IList<Curve^>^ GetCurves()
member GetCurves : unit -> IList<Curve>

Return Value

IList Curve
The array of curves.
See Also

Reference

PathOfTravel Class
Autodesk.Revit.DB.Analysis Namespace


PathOfTravel.GetWaypoints Method

PathOfTravelGetWaypoints Method

return the waypoints set for the Path of Travel

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<XYZ> GetWaypoints()
Public Function GetWaypoints As IList(Of XYZ)
public:
IList<XYZ^>^ GetWaypoints()
member GetWaypoints : unit -> IList<XYZ>

Return Value

IList XYZ
See Also

Reference

PathOfTravel Class
Autodesk.Revit.DB.Analysis Namespace


PathOfTravel.InsertWaypoint Method

PathOfTravelInsertWaypoint Method

Insert a waypoint at the specified index

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void InsertWaypoint(
    XYZ waypoint,
    int index
)
Public Sub InsertWaypoint (
    waypoint As XYZ,
    index As Integer
)
public:
void InsertWaypoint(
    XYZ^ waypoint,
    int index
)
member InsertWaypoint :
        waypoint : XYZ *
        index : int -> unit

Parameters

waypoint XYZ
The waypoint to insert.
index Int32
The index to insert the waypoint at.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Index is invalid for an existing or new waypoint for this path. -or- This functionality is not available in Revit LT. -or- Cannot perform this operation for a path of travel in a group.
See Also

Reference

PathOfTravel Class
Autodesk.Revit.DB.Analysis Namespace


PathOfTravel.IsInRevealObstaclesMode Method

PathOfTravelIsInRevealObstaclesMode Method

Returns current state of Reveal Obstacles mode for the given view.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsInRevealObstaclesMode(
    View DBView
)
Public Shared Function IsInRevealObstaclesMode (
    DBView As View
) As Boolean
public:
static bool IsInRevealObstaclesMode(
    View^ DBView
)
static member IsInRevealObstaclesMode :
        DBView : View -> bool

Parameters

DBView View
The view to determine current state of Reveal Obstacles mode for.

Return Value

Boolean
True if Reveal Obstacles mode is ON for the view, false otherwise.
Exceptions
Exception | Condition
ArgumentException | The element "DBView" is in a family document or a document in in-place edit mode. -or- View is not a floor plan view.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The document containing DBView is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The Path of Travel calculation service is not available
See Also

Reference

PathOfTravel Class
Autodesk.Revit.DB.Analysis Namespace


PathOfTravel.RemoveWaypoint Method

PathOfTravelRemoveWaypoint Method

Remove a waypoint.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveWaypoint(
    int index
)
Public Sub RemoveWaypoint (
    index As Integer
)
public:
void RemoveWaypoint(
    int index
)
member RemoveWaypoint :
        index : int -> unit

Parameters

index Int32
The index of the waypoint to remove.
Exceptions
Exception | Condition
InvalidOperationException | Index refers to a non-existent waypoint. -or- This functionality is not available in Revit LT. -or- Cannot perform this operation for a path of travel in a group.
See Also

Reference

PathOfTravel Class
Autodesk.Revit.DB.Analysis Namespace


PathOfTravel.SetRevealObstaclesMode Method

PathOfTravelSetRevealObstaclesMode Method

Sets Reveal Obstacles mode for the given view.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static PathOfTravelCalculationStatus SetRevealObstaclesMode(
    View DBView,
    bool newState
)
Public Shared Function SetRevealObstaclesMode (
    DBView As View,
    newState As Boolean
) As PathOfTravelCalculationStatus
public:
static PathOfTravelCalculationStatus SetRevealObstaclesMode(
    View^ DBView,
    bool newState
)
static member SetRevealObstaclesMode :
        DBView : View *
        newState : bool -> PathOfTravelCalculationStatus

Parameters

DBView View
The view to set Reveal Obstacles mode for.
newState Boolean
New state of Reveal Obstacles mode to be set for the view.

Return Value

PathOfTravelCalculationStatus
Result status of the operation.
Exceptions
Exception | Condition
ArgumentException | The element "DBView" is in a family document or a document in in-place edit mode. -or- View is not a floor plan view.
ArgumentNullException | A non-optional argument was null
InvalidOperationException | The document containing DBView is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The Path of Travel calculation service is not available
ModificationForbiddenException | The document containing DBView is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document containing DBView is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException | The document containing DBView has no open transaction.
See Also

Reference

PathOfTravel Class
Autodesk.Revit.DB.Analysis Namespace


PathOfTravel.SetWaypoint Method

PathOfTravelSetWaypoint Method

Updates the specified waypoint.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetWaypoint(
    XYZ waypoint,
    int index
)
Public Sub SetWaypoint (
    waypoint As XYZ,
    index As Integer
)
public:
void SetWaypoint(
    XYZ^ waypoint,
    int index
)
member SetWaypoint :
        waypoint : XYZ *
        index : int -> unit

Parameters

waypoint XYZ
The new point for the waypoint.
index Int32
The index of the waypoint to update.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | Index refers to a non-existent waypoint. -or- This functionality is not available in Revit LT. -or- Cannot perform this operation for a path of travel in a group.
See Also

Reference

PathOfTravel Class
Autodesk.Revit.DB.Analysis Namespace


PathOfTravel.Update Method

PathOfTravelUpdate Method

Updates the path of travel by recalculating the path between the original start and end points.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PathOfTravelCalculationStatus Update()
Public Function Update As PathOfTravelCalculationStatus
public:
PathOfTravelCalculationStatus Update()
member Update : unit -> PathOfTravelCalculationStatus

Return Value

PathOfTravelCalculationStatus
The status result of the recalculation.
Exceptions
Exception | Condition
InvalidOperationException | This functionality is not available in Revit LT.
Remarks
If recalculation results in failure, Revit will post a warning.
See Also

Reference

PathOfTravel Class
Autodesk.Revit.DB.Analysis Namespace


PathOfTravel.UpdateMultiple Method

PathOfTravelUpdateMultiple Method

Overload List
Name | Description
UpdateMultiple(Document, IListElementId) | Updates the specified paths of travel by recalculating each path using their original start and end points.
UpdateMultiple(Document, IListElementId, IListPathOfTravelCalculationStatus) | Updates the specified paths of travel by recalculating each path using their original start and end points and provides creation result statuses.
Top
See Also

Reference

PathOfTravel Class
Autodesk.Revit.DB.Analysis Namespace


PathOfTravel.UpdateMultiple(Document, IList<ElementId>) Method

PathOfTravelUpdateMultiple(Document, IListElementId) Method

Updates the specified paths of travel by recalculating each path using their original start and end points.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int UpdateMultiple(
    Document adoc,
    IList<ElementId> elementsToUpdate
)
Public Shared Function UpdateMultiple (
    adoc As Document,
    elementsToUpdate As IList(Of ElementId)
) As Integer
public:
static int UpdateMultiple(
    Document^ adoc,
    IList<ElementId^>^ elementsToUpdate
)
static member UpdateMultiple :
        adoc : Document *
        elementsToUpdate : IList<ElementId> -> int

Parameters

adoc Document
Document of elements to be updated.
elementsToUpdate IList ElementId
The list of ElementIdof the paths to update.

Return Value

Int32
number of successfully updated elements
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This functionality is not available in Revit LT.
Remarks
For unsuccessfully updated elements, Revit will post warnings.
See Also

Reference

PathOfTravel Class
UpdateMultiple Overload
Autodesk.Revit.DB.Analysis Namespace


PathOfTravel.UpdateMultiple(Document, IList<ElementId>, IList<PathOfTravelCalculationStatus>) Method

PathOfTravelUpdateMultiple(Document, IListElementId, IListPathOfTravelCalculationStatus) Method

Updates the specified paths of travel by recalculating each path using their original start and end points and provides creation result statuses.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int UpdateMultiple(
    Document adoc,
    IList<ElementId> elementsToUpdate,
    out IList<PathOfTravelCalculationStatus> resultStatus
)
Public Shared Function UpdateMultiple (
    adoc As Document,
    elementsToUpdate As IList(Of ElementId),
    <OutAttribute> ByRef resultStatus As IList(Of PathOfTravelCalculationStatus)
) As Integer
public:
static int UpdateMultiple(
    Document^ adoc,
    IList<ElementId^>^ elementsToUpdate,
    [OutAttribute] IList<PathOfTravelCalculationStatus>^% resultStatus
)
static member UpdateMultiple :
        adoc : Document *
        elementsToUpdate : IList<ElementId> *
        resultStatus : IList<PathOfTravelCalculationStatus> byref -> int

Parameters

adoc Document
Document of elements to be updated.
elementsToUpdate IList ElementId
The list of ElementIdof the paths to update.
resultStatus IList PathOfTravelCalculationStatus
Result statuses of each path of travel creation. The order of statuses corresponds to the order of elements in the array passed to the function.

Return Value

Int32
number of successfully updated elements
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
InvalidOperationException | This functionality is not available in Revit LT.
Remarks
For unsuccessfully updated elements, Revit will post warnings.
See Also

Reference

PathOfTravel Class
UpdateMultiple Overload
Autodesk.Revit.DB.Analysis Namespace


PathOfTravelCalculationServerIds Class

Ids for external servers implementing path of travel calculations.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DB.AnalysisPathOfTravelCalculationServerIds

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static class PathOfTravelCalculationServerIds
Public NotInheritable Class PathOfTravelCalculationServerIds
public ref class PathOfTravelCalculationServerIds abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type PathOfTravelCalculationServerIds = class end

The PathOfTravelCalculationServerIds type exposes the following members.

Properties
Name | Description
DefaultPathOfTravelCalculationGUID | GUID to represent the default calculation server id.
Top
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


PathOfTravelCalculationServerIds Properties

The PathOfTravelCalculationServerIds type exposes the following members.

Properties
Name | Description
DefaultPathOfTravelCalculationGUID | GUID to represent the default calculation server id.
Top
See Also

Reference

PathOfTravelCalculationServerIds Class
Autodesk.Revit.DB.Analysis Namespace


PathOfTravelCalculationServerIds.DefaultPathOfTravelCalculationGUID Property

PathOfTravelCalculationServerIdsDefaultPathOfTravelCalculationGUID Property

GUID to represent the default calculation server id.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Guid DefaultPathOfTravelCalculationGUID { get; }
Public Shared ReadOnly Property DefaultPathOfTravelCalculationGUID As Guid
    Get
public:
static property Guid DefaultPathOfTravelCalculationGUID {
    Guid get ();
}
static member DefaultPathOfTravelCalculationGUID : Guid with get

Property Value

Guid
See Also

Reference

PathOfTravelCalculationServerIds Class
Autodesk.Revit.DB.Analysis Namespace


PathOfTravelCalculationStatus Enumeration

An enumerated type containing possible results of the Path of Travel calculation.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum PathOfTravelCalculationStatus
Public Enumeration PathOfTravelCalculationStatus
public enum class PathOfTravelCalculationStatus
type PathOfTravelCalculationStatus
Members
Member name | Value | Description
Success | 0 | A valid path of travel between the two points was found. Use [!:Autodesk::Revit::DB::Analysis::PathOfTravel::GetCurveLoop] to retrieve the calculated points of path of travel.
NoPathOfTravel | 1 | There is no valid path between the two points.
AreaTooLarge | 2 | The view outline is too large. Calculation of the path of travel cannot be performed.
SplitView | 3 | The view is split. Calculation of the path of travel cannot be performed.
ResultAffectedByCrop | 4 | The view has an active crop region set. If [!:Autodesk::Revit::DB::Analysis::PathOfTravel::GetCurveLoop] contains no points, no path of travel was found inside the crop region, but a valid path may exist outside of it. If [!:Autodesk::Revit::DB::Analysis::PathOfTravel::GetCurveLoop] contains valid points, a path of travel was found inside the crop region, but a better option may exist outside of it.
StartAndEndPointsTooClose | 5 | Distance between adjacent points of path of travel (start, end and way points) is less than the value of [!:Autodesk::Revit::DB::Analysis::RouteAnalysisSettings::MinimumLength].
PointOutsideActiveCrop | 6 | Start or end point is outside the active view crop.
TooMuchGeometry | 7 | The view is exporting too much geometry. Calculation of the path of travel cannot be performed.
RevealObstaclesModeFailureDataExist | 8 | Reveal Obstacles mode cannot be set for the view because analysis data exist in the view.
RevealObstaclesModeFailureWireframe | 9 | Reveal Obstacles mode cannot be set for the view because wireframe display style is set for the view.
TemporaryModeFailureDataExist | 10 | Temporary mode cannot be set for the view because analysis data exist in the view.
TemporaryModeFailureWireframe | 11 | Temporary mode cannot be set for the view because wireframe display style is set for the view.
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


Polyloop Class

A Polyloop represent a planar polygon with ordered points.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DB.AnalysisPolyloop

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class Polyloop : IDisposable
Public Class Polyloop
    Implements IDisposable
public ref class Polyloop : IDisposable
type Polyloop =
    class
        interface IDisposable
    end

The Polyloop type exposes the following members.

Properties
 | Name | Description
Public property | Centroid | The polygon centroid.
Public property | Direction | The direction for the outward normal for this polygon.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 | Name | Description
Public method | ComputeArea | Gets the area for this polygon.
Public method | Dispose | Releases all resources used by the Polyloop
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetPoints | Gets the array of points in the polygon.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Remarks
This class is a loop with straight edges bounding a planar region in space. The loop is represented by an ordered coplanar collection of points forming the vertices of the loop. The loop is composed of straight line segments joining a point in the collection to the succeeding point in the collection. The closing segment is from the last to the first point in the collection. The direction of the loop is in the direction of the line segments. All the points in the polygon defining the poly loop shall be coplanar.
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


Polyloop Properties

The Polyloop type exposes the following members.

Properties
 | Name | Description
Public property | Centroid | The polygon centroid.
Public property | Direction | The direction for the outward normal for this polygon.
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Top
See Also

Reference

Polyloop Class
Autodesk.Revit.DB.Analysis Namespace


Polyloop.Centroid Property

PolyloopCentroid Property

The polygon centroid.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Centroid { get; }
Public ReadOnly Property Centroid As XYZ
    Get
public:
property XYZ^ Centroid {
    XYZ^ get ();
}
member Centroid : XYZ with get

Property Value

XYZ
See Also

Reference

Polyloop Class
Autodesk.Revit.DB.Analysis Namespace


Polyloop.Direction Property

PolyloopDirection Property

The direction for the outward normal for this polygon.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ Direction { get; }
Public ReadOnly Property Direction As XYZ
    Get
public:
property XYZ^ Direction {
    XYZ^ get ();
}
member Direction : XYZ with get

Property Value

XYZ
See Also

Reference

Polyloop Class
Autodesk.Revit.DB.Analysis Namespace


Polyloop.IsValidObject Property

PolyloopIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

Polyloop Class
Autodesk.Revit.DB.Analysis Namespace


Polyloop Methods

The Polyloop type exposes the following members.

Methods
 | Name | Description
Public method | ComputeArea | Gets the area for this polygon.
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetPoints | Gets the array of points in the polygon.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Polyloop Class
Autodesk.Revit.DB.Analysis Namespace


Polyloop.ComputeArea Method

PolyloopComputeArea Method

Gets the area for this polygon.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double ComputeArea()
Public Function ComputeArea As Double
public:
double ComputeArea()
member ComputeArea : unit -> float

Return Value

Double
The area for this polygon.
Remarks
The area of the planar non-self-intersecting polygon computed as: A = 1/2 * (X1 Y2) - (X2 Y1) + ... + (Xn Y1) - (X1 Yn)
See Also

Reference

Polyloop Class
Autodesk.Revit.DB.Analysis Namespace


Polyloop.Dispose Method

PolyloopDispose Method

Releases all resources used by the Polyloop

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

Polyloop Class
Autodesk.Revit.DB.Analysis Namespace


Polyloop.GetPoints Method

PolyloopGetPoints Method

Gets the array of points in the polygon.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<XYZ> GetPoints()
Public Function GetPoints As IList(Of XYZ)
public:
IList<XYZ^>^ GetPoints()
member GetPoints : unit -> IList<XYZ>

Return Value

IList XYZ
The array of points in the polygon.
See Also

Reference

Polyloop Class
Autodesk.Revit.DB.Analysis Namespace


RouteAnalysisSettings Class

RouteAnalysisSettings is an element which contains project-wide settings for route calculations. The PathOfTravel element uses these settings to calculate a route between two points in a plan view.

By default, the route will go around the geometry of all visible model elements which have model geometry in the Route Analysis Zone.

The Route Analysis Zone, determined per view, is the space between these two horizontal planes: a top plane vertically offset by AnalysisZoneTopOffset above the view's level and a bottom plane vertically offset by AnalysisZoneBottomOffset ft above the view's level.

By default, the route will ignore the following elements:
  • elements outside of the crop region of the view;
  • elements without any model geometry (annotations or view-specific elements);
  • model lines (category OST_Lines);
  • demolished elements;
  • elements displayed in the underlay of the view.
There are a few ways to customize Route Analysis on a project-wide basis.

You can adjust the Route Analysis Zone using AnalysisZoneTopOffset and AnalysisZoneBottomOffset.

You can specify a set of model categories you would like ignored during route calculation. To enable ignoring the set of specified categories, set EnableIgnoredCategoryIds to true. To change the set of ignored categories, use SetIgnoredCategoryIds method and IgnoreImports and IgnorePointClouds properties. To query the set of ignored categories, use GetIgnoredCategoryIds.

Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DB.AnalysisRouteAnalysisSettings

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class RouteAnalysisSettings : Element
Public Class RouteAnalysisSettings
    Inherits Element
public ref class RouteAnalysisSettings : public Element
type RouteAnalysisSettings =
    class
        inherit Element
    end

The RouteAnalysisSettings type exposes the following members.

Properties
 | Name | Description
Public property | AnalysisZoneBottomOffset | The bottom plane offset, in ft, of the zone used in route calculation. Default value is 8".
Public property | AnalysisZoneTopOffset | The top plane offset, in ft, for the zone used in route calculation. Default value is 6'8".
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | EnableIgnoredCategoryIds | When this setting is true, elements with category ids returned by GetIgnoredCategoryIds will be ignored in route calculation. default is true as all elements with the Door Category Id are ignored by default.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IgnoreImports | If true, import instances are ignored by route calculation. For imports to be ignored, also EnableIgnoredCategoryIds must be set to true.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | MinimumLength | The constant storing minimum allowed length of path of travel
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExcludedCategoryIds | Returns ElementIds for Category elements which are excluded (not taken into account) by route calculation. These categories are always excluded, regardless of the EnableIgnoredCategoryIds value. If an excluded category has sub-categories, then the sub-categories will be excluded as well.
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIgnoredCategoryIds | Returns ElementIds for Category elements which are ignored (not taken into account) route calculation. To enable ignoring of these categories, EnableIgnoredCategoryIds must be set to true. If an ignored category has sub-categories, then the sub-categories will be ignored as well.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
 | GetRouteAnalysisSettings | Returns the RouteAnalysisSettings element for a given document.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsLargeGeometryAllowed | Returns if large geometry is allowed for path of travel creation or not.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetIgnoredCategoryIds | Sets the ElementIds for Category elements which are ignored by route calculation.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


RouteAnalysisSettings Properties

The RouteAnalysisSettings type exposes the following members.

Properties
 | Name | Description
Public property | AnalysisZoneBottomOffset | The bottom plane offset, in ft, of the zone used in route calculation. Default value is 8".
Public property | AnalysisZoneTopOffset | The top plane offset, in ft, for the zone used in route calculation. Default value is 6'8".
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | EnableIgnoredCategoryIds | When this setting is true, elements with category ids returned by GetIgnoredCategoryIds will be ignored in route calculation. default is true as all elements with the Door Category Id are ignored by default.
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IgnoreImports | If true, import instances are ignored by route calculation. For imports to be ignored, also EnableIgnoredCategoryIds must be set to true.
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | MinimumLength | The constant storing minimum allowed length of path of travel
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

RouteAnalysisSettings Class
Autodesk.Revit.DB.Analysis Namespace


RouteAnalysisSettings.AnalysisZoneBottomOffset Property

RouteAnalysisSettingsAnalysisZoneBottomOffset Property

The bottom plane offset, in ft, of the zone used in route calculation. Default value is 8".

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double AnalysisZoneBottomOffset { get; set; }
Public Property AnalysisZoneBottomOffset As Double
    Get
    Set
public:
property double AnalysisZoneBottomOffset {
    double get ();
    void set (double value);
}
member AnalysisZoneBottomOffset : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The given value for bottomOffset must be non-negative.
Remarks
The zone's bottom plane elevation is different per plan view and is determined by adding the bottom offset to the view's level elevation.
See Also

Reference

RouteAnalysisSettings Class
Autodesk.Revit.DB.Analysis Namespace


RouteAnalysisSettings.AnalysisZoneTopOffset Property

RouteAnalysisSettingsAnalysisZoneTopOffset Property

The top plane offset, in ft, for the zone used in route calculation. Default value is 6'8".

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double AnalysisZoneTopOffset { get; set; }
Public Property AnalysisZoneTopOffset As Double
    Get
    Set
public:
property double AnalysisZoneTopOffset {
    double get ();
    void set (double value);
}
member AnalysisZoneTopOffset : float with get, set

Property Value

Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: The given value for topOffset must be non-negative.
Remarks
The zone's top plane elevation is different per plan view and is determined by adding the top offset to the view's level elevation.
See Also

Reference

RouteAnalysisSettings Class
Autodesk.Revit.DB.Analysis Namespace


RouteAnalysisSettings.EnableIgnoredCategoryIds Property

RouteAnalysisSettingsEnableIgnoredCategoryIds Property

When this setting is true, elements with category ids returned by GetIgnoredCategoryIds will be ignored in route calculation. default is true as all elements with the Door Category Id are ignored by default.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool EnableIgnoredCategoryIds { get; set; }
Public Property EnableIgnoredCategoryIds As Boolean
    Get
    Set
public:
property bool EnableIgnoredCategoryIds {
    bool get ();
    void set (bool value);
}
member EnableIgnoredCategoryIds : bool with get, set

Property Value

Boolean
See Also

Reference

RouteAnalysisSettings Class
Autodesk.Revit.DB.Analysis Namespace


RouteAnalysisSettings.IgnoreImports Property

RouteAnalysisSettingsIgnoreImports Property

If true, import instances are ignored by route calculation. For imports to be ignored, also EnableIgnoredCategoryIds must be set to true.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IgnoreImports { get; set; }
Public Property IgnoreImports As Boolean
    Get
    Set
public:
property bool IgnoreImports {
    bool get ();
    void set (bool value);
}
member IgnoreImports : bool with get, set

Property Value

Boolean
See Also

Reference

RouteAnalysisSettings Class
Autodesk.Revit.DB.Analysis Namespace


RouteAnalysisSettings.MinimumLength Property

RouteAnalysisSettingsMinimumLength Property

The constant storing minimum allowed length of path of travel

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double MinimumLength { get; }
Public ReadOnly Property MinimumLength As Double
    Get
public:
property double MinimumLength {
    double get ();
}
member MinimumLength : float with get

Property Value

Double
See Also

Reference

RouteAnalysisSettings Class
Autodesk.Revit.DB.Analysis Namespace


RouteAnalysisSettings Methods

The RouteAnalysisSettings type exposes the following members.

Methods
 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExcludedCategoryIds | Returns ElementIds for Category elements which are excluded (not taken into account) by route calculation. These categories are always excluded, regardless of the EnableIgnoredCategoryIds value. If an excluded category has sub-categories, then the sub-categories will be excluded as well.
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIgnoredCategoryIds | Returns ElementIds for Category elements which are ignored (not taken into account) route calculation. To enable ignoring of these categories, EnableIgnoredCategoryIds must be set to true. If an ignored category has sub-categories, then the sub-categories will be ignored as well.
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
 | GetRouteAnalysisSettings | Returns the RouteAnalysisSettings element for a given document.
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsLargeGeometryAllowed | Returns if large geometry is allowed for path of travel creation or not.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetIgnoredCategoryIds | Sets the ElementIds for Category elements which are ignored by route calculation.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

RouteAnalysisSettings Class
Autodesk.Revit.DB.Analysis Namespace


RouteAnalysisSettings.GetExcludedCategoryIds Method

RouteAnalysisSettingsGetExcludedCategoryIds Method

Returns ElementIds for Category elements which are excluded (not taken into account) by route calculation. These categories are always excluded, regardless of the EnableIgnoredCategoryIds value. If an excluded category has sub-categories, then the sub-categories will be excluded as well.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetExcludedCategoryIds()
Public Function GetExcludedCategoryIds As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetExcludedCategoryIds()
member GetExcludedCategoryIds : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
The ids of Categories which are excluded by route calculation.
See Also

Reference

RouteAnalysisSettings Class
Autodesk.Revit.DB.Analysis Namespace


RouteAnalysisSettings.GetIgnoredCategoryIds Method

RouteAnalysisSettingsGetIgnoredCategoryIds Method

Returns ElementIds for Category elements which are ignored (not taken into account) route calculation. To enable ignoring of these categories, EnableIgnoredCategoryIds must be set to true. If an ignored category has sub-categories, then the sub-categories will be ignored as well.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ICollection<ElementId> GetIgnoredCategoryIds()
Public Function GetIgnoredCategoryIds As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetIgnoredCategoryIds()
member GetIgnoredCategoryIds : unit -> ICollection<ElementId>

Return Value

ICollection ElementId
The ids of Categories which are ignored by route calculation. By default, the set contains the Doors Category.
See Also

Reference

RouteAnalysisSettings Class
Autodesk.Revit.DB.Analysis Namespace


RouteAnalysisSettings.GetRouteAnalysisSettings Method

RouteAnalysisSettingsGetRouteAnalysisSettings Method

Returns the RouteAnalysisSettings element for a given document.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static RouteAnalysisSettings GetRouteAnalysisSettings(
    Document cda
)
Public Shared Function GetRouteAnalysisSettings (
    cda As Document
) As RouteAnalysisSettings
public:
static RouteAnalysisSettings^ GetRouteAnalysisSettings(
    Document^ cda
)
static member GetRouteAnalysisSettings :
        cda : Document -> RouteAnalysisSettings

Parameters

cda Document
The document for which to get the RouteAnalysisSettings element.

Return Value

RouteAnalysisSettings

Returns the RouteAnalysisSettings element in project documents or for family documents

.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
Remarks
Project documents have a RouteAnalysisSettings element, one per document. Family documents do not have RouteAnalysisSettings elements.
See Also

Reference

RouteAnalysisSettings Class
Autodesk.Revit.DB.Analysis Namespace


RouteAnalysisSettings.IsLargeGeometryAllowed Method

RouteAnalysisSettingsIsLargeGeometryAllowed Method

Returns if large geometry is allowed for path of travel creation or not.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsLargeGeometryAllowed()
Public Function IsLargeGeometryAllowed As Boolean
public:
bool IsLargeGeometryAllowed()
member IsLargeGeometryAllowed : unit -> bool

Return Value

Boolean
Remarks
The return value is based off the current setting for the AllowLargeGeometry Property as follows:
  • If it is set to Prompt, then prompts the user to continue or not, if no ui is present, returns false.
  • If it is set to DisAllaow, returns false.
  • If it is set to Allow, returns true.
See Also

Reference

RouteAnalysisSettings Class
Autodesk.Revit.DB.Analysis Namespace


RouteAnalysisSettings.SetIgnoredCategoryIds Method

RouteAnalysisSettingsSetIgnoredCategoryIds Method

Sets the ElementIds for Category elements which are ignored by route calculation.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetIgnoredCategoryIds(
    ICollection<ElementId> categoryIds
)
Public Sub SetIgnoredCategoryIds (
    categoryIds As ICollection(Of ElementId)
)
public:
void SetIgnoredCategoryIds(
    ICollection<ElementId^>^ categoryIds
)
member SetIgnoredCategoryIds :
        categoryIds : ICollection<ElementId> -> unit

Parameters

categoryIds ICollection ElementId
The ids of Categories to be ignored by route calculation.
Exceptions
Exception | Condition
ArgumentException | One or more ElementIds in categoryIds are not valid Category element ids.
ArgumentNullException | A non-optional argument was null
See Also

Reference

RouteAnalysisSettings Class
Autodesk.Revit.DB.Analysis Namespace


SpatialFieldManager Class

Exposes all API for an external analysis application. Its primary role is creation, deletion and modification of SpatialFieldElement elements.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DB.AnalysisSpatialFieldManager

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SpatialFieldManager : Element
Public Class SpatialFieldManager
    Inherits Element
public ref class SpatialFieldManager : public Element
type SpatialFieldManager =
    class
        inherit Element
    end

The SpatialFieldManager type exposes the following members.

Properties
 | Name | Description
Public property | AllowInteractiveSettings | If true interactive settings dialog and pick deletion are allowed.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CurrentMeasurement | Stores the currently displayed measurement
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LegendPosition | Stores current position of analysis results legend element in view
Public property | LegendShowConfigurationName | If true legend contains analysis configuration name.
Public property | LegendShowDescription | If true legend contains analysis description.
Public property | LegendTextTypeId | Stores element id of text associated with common (result-independent) part of legend in view.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | NumberOfMeasurements | Stores the total number of measurements
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ResultsVisibleInView | Enables analysis results visibility in the view.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | UseRangeForAllMeasurements | Governs how minimum and maximum values (the data range) are calculated.
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | AddSpatialFieldPrimitive | Creates empty analysis results primitive not associated with any geometry element
Public method | AddSpatialFieldPrimitive(Reference) | Creates an empty analysis results primitive associated with a reference.
Public method | AddSpatialFieldPrimitive(Curve, Transform) | Creates empty analysis results primitive associated with a curve and a transform.
 | AddSpatialFieldPrimitive(Face, Transform) | Creates empty analysis results primitive associated with a face and a transform.
Public method | AddSpatialFieldPrimitive(Reference, SpatialFieldPrimitiveHideMode) | Creates an empty analysis results primitive associated with a reference, with the option to control how the reference element is hidden.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | Clear | Clear all analysis results managed by this manager object
 | CreateSpatialFieldManager | Factory method - creates manager object for the given view
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLegend | Returns legend element or NULL
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMaximum | Calculates the maximum value for all primitives
Public method | GetMinimum | Calculates the minimum value for all primitives
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetRegisteredResults | Returns an array of indices of all registered results
Public method | GetResultSchema | Returns result schema by index
 | GetSpatialFieldManager | Retrieves manager object for the given view or returns NULL
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsResultSchemaNameUnique | Verify the uniqueness of the name among all registered result schemas.
 | IsTextTypeIdValid | Verify if text type id is valid.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
 | RegisterResult | Registers result and assigns it a unique result index
Public method | RemoveSpatialFieldPrimitive | Removes analysis results primitive identified by the unique index
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetMeasurementDescriptions | Sets Descriptions for all measurements
Public method | SetMeasurementNames | Sets Names for all measurements
Public method | SetResultSchema | Sets a new value for an existing result schema in the result registry
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UpdateSpatialFieldPrimitive | Populates analysis results data (or replaces the existing data) in the existing primitive identified by the unique index
Top
Example
C#
VB
C++
F#
Copy
Document doc = commandData.Application.ActiveUIDocument.Document;
UIDocument uiDoc = commandData.Application.ActiveUIDocument;

SpatialFieldManager sfm = SpatialFieldManager.GetSpatialFieldManager(doc.ActiveView);
if (null == sfm)
{
    sfm = SpatialFieldManager.CreateSpatialFieldManager(doc.ActiveView, 1);
}
Reference reference = uiDoc.Selection.PickObject(ObjectType.Face, "Select a face");
int idx = sfm.AddSpatialFieldPrimitive(reference);

Face face = doc.GetElement(reference).GetGeometryObjectFromReference(reference) as Face;

IList<UV> uvPts = new List<UV>();
BoundingBoxUV bb = face.GetBoundingBox();
UV min = bb.Min;
UV max = bb.Max;
uvPts.Add(new UV(min.U,min.V));
uvPts.Add(new UV(max.U,max.V));

FieldDomainPointsByUV pnts = new FieldDomainPointsByUV(uvPts);

List<double> doubleList = new List<double>();
IList<ValueAtPoint> valList = new List<ValueAtPoint>();
doubleList.Add(0);
valList.Add(new ValueAtPoint(doubleList));
doubleList.Clear();
doubleList.Add(10);
valList.Add(new ValueAtPoint(doubleList));

FieldValues vals = new FieldValues(valList);
AnalysisResultSchema resultSchema = new AnalysisResultSchema("Schema Name", "Description");
int schemaIndex = sfm.RegisterResult(resultSchema);
sfm.UpdateSpatialFieldPrimitive(idx, pnts, vals, schemaIndex);
Dim doc As Document = commandData.Application.ActiveUIDocument.Document
Dim uiDoc As UIDocument = commandData.Application.ActiveUIDocument

Dim sfm As SpatialFieldManager = SpatialFieldManager.GetSpatialFieldManager(doc.ActiveView)
If sfm Is Nothing Then
   sfm = SpatialFieldManager.CreateSpatialFieldManager(doc.ActiveView, 1)
End If
Dim reference As Reference = uiDoc.Selection.PickObject(ObjectType.Face, "Select a face")
Dim idx As Integer = sfm.AddSpatialFieldPrimitive(reference)

Dim face As Face = TryCast(doc.GetElement(reference).GetGeometryObjectFromReference(reference), Face)

Dim uvPts As IList(Of UV) = New List(Of UV)()
Dim bb As BoundingBoxUV = face.GetBoundingBox()
Dim min As UV = bb.Min
Dim max As UV = bb.Max
uvPts.Add(New UV(min.U, min.V))
uvPts.Add(New UV(max.U, max.V))

Dim pnts As New FieldDomainPointsByUV(uvPts)

Dim doubleList As New List(Of Double)()
Dim valList As IList(Of ValueAtPoint) = New List(Of ValueAtPoint)()
doubleList.Add(0)
valList.Add(New ValueAtPoint(doubleList))
doubleList.Clear()
doubleList.Add(10)
valList.Add(New ValueAtPoint(doubleList))

Dim vals As New FieldValues(valList)
Dim resultSchema As New AnalysisResultSchema("Schema Name", "Description")
Dim schemaIndex As Integer = sfm.RegisterResult(resultSchema)
sfm.UpdateSpatialFieldPrimitive(idx, pnts, vals, schemaIndex)

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


SpatialFieldManager Properties

The SpatialFieldManager type exposes the following members.

Properties
 | Name | Description
Public property | AllowInteractiveSettings | If true interactive settings dialog and pick deletion are allowed.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CurrentMeasurement | Stores the currently displayed measurement
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LegendPosition | Stores current position of analysis results legend element in view
Public property | LegendShowConfigurationName | If true legend contains analysis configuration name.
Public property | LegendShowDescription | If true legend contains analysis description.
Public property | LegendTextTypeId | Stores element id of text associated with common (result-independent) part of legend in view.
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | NumberOfMeasurements | Stores the total number of measurements
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ResultsVisibleInView | Enables analysis results visibility in the view.
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | UseRangeForAllMeasurements | Governs how minimum and maximum values (the data range) are calculated.
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


SpatialFieldManager.AllowInteractiveSettings Property

SpatialFieldManagerAllowInteractiveSettings Property

If true interactive settings dialog and pick deletion are allowed.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AllowInteractiveSettings { get; set; }
Public Property AllowInteractiveSettings As Boolean
    Get
    Set
public:
property bool AllowInteractiveSettings {
    bool get ();
    void set (bool value);
}
member AllowInteractiveSettings : bool with get, set

Property Value

Boolean
Remarks
Note that SpatialFieldManager cannot be deleted if this property is set to false.
See Also

Reference

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


SpatialFieldManager.CurrentMeasurement Property

SpatialFieldManagerCurrentMeasurement Property

Stores the currently displayed measurement

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int CurrentMeasurement { get; set; }
Public Property CurrentMeasurement As Integer
    Get
    Set
public:
property int CurrentMeasurement {
    int get ();
    void set (int value);
}
member CurrentMeasurement : int with get, set

Property Value

Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: measurement is not in the range from 0 to (number of measurements - 1)
Remarks
Must be in the range from 0 to (numberOfMeasurements - 1)
See Also

Reference

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


SpatialFieldManager.LegendPosition Property

SpatialFieldManagerLegendPosition Property

Stores current position of analysis results legend element in view

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public XYZ LegendPosition { get; set; }
Public Property LegendPosition As XYZ
    Get
    Set
public:
property XYZ^ LegendPosition {
    XYZ^ get ();
    void set (XYZ^ value);
}
member LegendPosition : XYZ with get, set

Property Value

XYZ
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


SpatialFieldManager.LegendShowConfigurationName Property

SpatialFieldManagerLegendShowConfigurationName Property

If true legend contains analysis configuration name.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool LegendShowConfigurationName { get; set; }
Public Property LegendShowConfigurationName As Boolean
    Get
    Set
public:
property bool LegendShowConfigurationName {
    bool get ();
    void set (bool value);
}
member LegendShowConfigurationName : bool with get, set

Property Value

Boolean
See Also

Reference

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


SpatialFieldManager.LegendShowDescription Property

SpatialFieldManagerLegendShowDescription Property

If true legend contains analysis description.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool LegendShowDescription { get; set; }
Public Property LegendShowDescription As Boolean
    Get
    Set
public:
property bool LegendShowDescription {
    bool get ();
    void set (bool value);
}
member LegendShowDescription : bool with get, set

Property Value

Boolean
See Also

Reference

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


SpatialFieldManager.LegendTextTypeId Property

SpatialFieldManagerLegendTextTypeId Property

Stores element id of text associated with common (result-independent) part of legend in view.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ElementId LegendTextTypeId { get; set; }
Public Property LegendTextTypeId As ElementId
    Get
    Set
public:
property ElementId^ LegendTextTypeId {
    ElementId^ get ();
    void set (ElementId^ value);
}
member LegendTextTypeId : ElementId with get, set

Property Value

ElementId
Exceptions
Exception | Condition
ArgumentNullException | When setting this property: A non-optional argument was null
See Also

Reference

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


SpatialFieldManager.NumberOfMeasurements Property

SpatialFieldManagerNumberOfMeasurements Property

Stores the total number of measurements

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int NumberOfMeasurements { get; }
Public ReadOnly Property NumberOfMeasurements As Integer
    Get
public:
property int NumberOfMeasurements {
    int get ();
}
member NumberOfMeasurements : int with get

Property Value

Int32
Remarks
This number defines the length of value arrays in ValueAtPoint objects
See Also

Reference

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


SpatialFieldManager.ResultsVisibleInView Property

SpatialFieldManagerResultsVisibleInView Property

Enables analysis results visibility in the view.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ResultsVisibleInView { get; set; }
Public Property ResultsVisibleInView As Boolean
    Get
    Set
public:
property bool ResultsVisibleInView {
    bool get ();
    void set (bool value);
}
member ResultsVisibleInView : bool with get, set

Property Value

Boolean
See Also

Reference

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


SpatialFieldManager.UseRangeForAllMeasurements Property

SpatialFieldManagerUseRangeForAllMeasurements Property

Governs how minimum and maximum values (the data range) are calculated.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UseRangeForAllMeasurements { get; set; }
Public Property UseRangeForAllMeasurements As Boolean
    Get
    Set
public:
property bool UseRangeForAllMeasurements {
    bool get ();
    void set (bool value);
}
member UseRangeForAllMeasurements : bool with get, set

Property Value

Boolean
Remarks
If true the data range is calculated from all measurements. Otherwise the data range is calculated from the current measurement only.
See Also

Reference

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


SpatialFieldManager Methods

The SpatialFieldManager type exposes the following members.

Methods
 | Name | Description
Public method | AddSpatialFieldPrimitive | Creates empty analysis results primitive not associated with any geometry element
Public method | AddSpatialFieldPrimitive(Reference) | Creates an empty analysis results primitive associated with a reference.
Public method | AddSpatialFieldPrimitive(Curve, Transform) | Creates empty analysis results primitive associated with a curve and a transform.
 | AddSpatialFieldPrimitive(Face, Transform) | Creates empty analysis results primitive associated with a face and a transform.
Public method | AddSpatialFieldPrimitive(Reference, SpatialFieldPrimitiveHideMode) | Creates an empty analysis results primitive associated with a reference, with the option to control how the reference element is hidden.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | Clear | Clear all analysis results managed by this manager object
 | CreateSpatialFieldManager | Factory method - creates manager object for the given view
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | Dispose | (Inherited from Element)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetLegend | Returns legend element or NULL
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetMaximum | Calculates the maximum value for all primitives
Public method | GetMinimum | Calculates the minimum value for all primitives
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetRegisteredResults | Returns an array of indices of all registered results
Public method | GetResultSchema | Returns result schema by index
 | GetSpatialFieldManager | Retrieves manager object for the given view or returns NULL
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsResultSchemaNameUnique | Verify the uniqueness of the name among all registered result schemas.
 | IsTextTypeIdValid | Verify if text type id is valid.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
 | RegisterResult | Registers result and assigns it a unique result index
Public method | RemoveSpatialFieldPrimitive | Removes analysis results primitive identified by the unique index
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
Public method | SetMeasurementDescriptions | Sets Descriptions for all measurements
Public method | SetMeasurementNames | Sets Names for all measurements
Public method | SetResultSchema | Sets a new value for an existing result schema in the result registry
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UpdateSpatialFieldPrimitive | Populates analysis results data (or replaces the existing data) in the existing primitive identified by the unique index
Top
See Also

Reference

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


SpatialFieldManager.AddSpatialFieldPrimitive Method

SpatialFieldManagerAddSpatialFieldPrimitive Method

Overload List
 | Name | Description
Public method | AddSpatialFieldPrimitive | Creates empty analysis results primitive not associated with any geometry element
Public method | AddSpatialFieldPrimitive(Reference) | Creates an empty analysis results primitive associated with a reference.
Public method | AddSpatialFieldPrimitive(Curve, Transform) | Creates empty analysis results primitive associated with a curve and a transform.
 | AddSpatialFieldPrimitive(Face, Transform) | Creates empty analysis results primitive associated with a face and a transform.
Public method | AddSpatialFieldPrimitive(Reference, SpatialFieldPrimitiveHideMode) | Creates an empty analysis results primitive associated with a reference, with the option to control how the reference element is hidden.
Top
See Also

Reference

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


SpatialFieldManager.AddSpatialFieldPrimitive Method

SpatialFieldManagerAddSpatialFieldPrimitive Method

Creates empty analysis results primitive not associated with any geometry element

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int AddSpatialFieldPrimitive()
Public Function AddSpatialFieldPrimitive As Integer
public:
int AddSpatialFieldPrimitive()
member AddSpatialFieldPrimitive : unit -> int

Return Value

Int32
Unique index of primitive for future references
See Also

Reference

SpatialFieldManager Class
AddSpatialFieldPrimitive Overload
Autodesk.Revit.DB.Analysis Namespace


SpatialFieldManager.AddSpatialFieldPrimitive(Reference) Method

SpatialFieldManagerAddSpatialFieldPrimitive(Reference) Method

Creates an empty analysis results primitive associated with a reference.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int AddSpatialFieldPrimitive(
    Reference reference
)
Public Function AddSpatialFieldPrimitive (
    reference As Reference
) As Integer
public:
int AddSpatialFieldPrimitive(
    Reference^ reference
)
member AddSpatialFieldPrimitive :
        reference : Reference -> int

Parameters

reference Reference
Reference pointing to the curve or face to be associated with the primitive

Return Value

Int32
Unique index of primitive for future references
Exceptions
Exception | Condition
ArgumentException | reference points to neither face nor curve
ArgumentNullException | A non-optional argument was null
Remarks

There can be multiple primitives associated with one reference, normally they would be shown with different results. However this is justified only if they have different sets of domain points. Otherwise one primitive can be used to display values for different results.

See Also

Reference

SpatialFieldManager Class
AddSpatialFieldPrimitive Overload
Autodesk.Revit.DB.Analysis Namespace


SpatialFieldManager.AddSpatialFieldPrimitive(Curve, Transform) Method

SpatialFieldManagerAddSpatialFieldPrimitive(Curve, Transform) Method

Creates empty analysis results primitive associated with a curve and a transform.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int AddSpatialFieldPrimitive(
    Curve curve,
    Transform trf
)
Public Function AddSpatialFieldPrimitive (
    curve As Curve,
    trf As Transform
) As Integer
public:
int AddSpatialFieldPrimitive(
    Curve^ curve,
    Transform^ trf
)
member AddSpatialFieldPrimitive :
        curve : Curve *
        trf : Transform -> int

Parameters

curve Curve
Curve to be associated with the primitive. %curve% does NOT correspond to actual Revit geometry, i.e. it cannot be associated with reference; otherwise the other overload of the method must be used (taking "reference" as the input)
trf Transform
Conformal Transform to be applied to %curve%.

Return Value

Int32
Unique index of primitive for future references
Exceptions
Exception | Condition
ArgumentException | The input curve points to a helical curve and is not supported for this operation. -or- Argument trf is not a conformal transform (see property Revit::DB::Transform::IsConformal)
ArgumentNullException | A non-optional argument was null
See Also

Reference

SpatialFieldManager Class
AddSpatialFieldPrimitive Overload
Autodesk.Revit.DB.Analysis Namespace


SpatialFieldManager.AddSpatialFieldPrimitive(Face, Transform) Method

SpatialFieldManagerAddSpatialFieldPrimitive(Face, Transform) Method

Creates empty analysis results primitive associated with a face and a transform.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int AddSpatialFieldPrimitive(
    Face face,
    Transform trf
)
Public Function AddSpatialFieldPrimitive (
    face As Face,
    trf As Transform
) As Integer
public:
int AddSpatialFieldPrimitive(
    Face^ face,
    Transform^ trf
)
member AddSpatialFieldPrimitive :
        face : Face *
        trf : Transform -> int

Parameters

face Face
Face to be associated with the primitive
trf Transform
Conformal Transform to be applied to %face%

Return Value

Int32
Unique index of primitive for future references
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | trf is not conformal.
Remarks

This method accepts a reference to a model face, and a transform to be applied to that face, allowing the display of analytical results on faces which are not strictly a part of the Revit model.

This method should not be used if the transform is the identity transform, i.e. the intent is to display results on a face which is part of the Revit model. In that case, use the overload of this method which accepts a reference.

If the input face is from the geometry of a symbol, the face will be considered to be in the location specified by its symbol geometry. If your intention is to transform the face relative to its location in the instance, your input transform must consist of the instance's transform left multiplied by the extra transform to get the results you expect.

Example
C#
VB
C++
F#
Copy
// Create SpatialFieldPrimitive to display results offset from a face
BoundingBoxUV bb = face.GetBoundingBox();
UV min = bb.Min;
UV max = bb.Max;

// Find the face normal at the center of the face's bounding box
UV faceCenter = new UV((max.U + min.U) / 2, (max.V + min.V) / 2);
Transform computeDerivatives = face.ComputeDerivatives(faceCenter);
XYZ faceCenterNormal = computeDerivatives.BasisZ;

// Normalize the normal vector and multiply by 2.5
XYZ faceCenterNormalMultiplied = faceCenterNormal.Normalize().Multiply(2.5);
Transform transform = Transform.CreateTranslation(faceCenterNormalMultiplied);

// Use face and transform when adding the SpatialFieldPrimitive
SpatialFieldManager sfm = SpatialFieldManager.CreateSpatialFieldManager(doc.ActiveView, 3);
int idx = sfm.AddSpatialFieldPrimitive(face, transform);
' Create SpatialFieldPrimitive to display results offset from a face
Dim bb As BoundingBoxUV = face.GetBoundingBox()
Dim min As UV = bb.Min
Dim max As UV = bb.Max

' Find the face normal at the center of the face's bounding box
Dim faceCenter As New UV((max.U + min.U) / 2, (max.V + min.V) / 2)
Dim computeDerivatives As Transform = face.ComputeDerivatives(faceCenter)
Dim faceCenterNormal As XYZ = computeDerivatives.BasisZ

' Normalize the normal vector and multiply by 2.5
Dim faceCenterNormalMultiplied As XYZ = faceCenterNormal.Normalize().Multiply(2.5)
Dim transform__1 As Transform = Transform.CreateTranslation(faceCenterNormalMultiplied)

' Use face and transform when adding the SpatialFieldPrimitive
Dim sfm As SpatialFieldManager = SpatialFieldManager.CreateSpatialFieldManager(doc.ActiveView, 3)
Dim idx As Integer = sfm.AddSpatialFieldPrimitive(face, transform__1)

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

SpatialFieldManager Class
AddSpatialFieldPrimitive Overload
Autodesk.Revit.DB.Analysis Namespace


SpatialFieldManager.AddSpatialFieldPrimitive(Reference, SpatialFieldPrimitiveHideMode) Method

SpatialFieldManagerAddSpatialFieldPrimitive(Reference, SpatialFieldPrimitiveHideMode) Method

Creates an empty analysis results primitive associated with a reference, with the option to control how the reference element is hidden.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int AddSpatialFieldPrimitive(
    Reference reference,
    SpatialFieldPrimitiveHideMode hidingMode
)
Public Function AddSpatialFieldPrimitive (
    reference As Reference,
    hidingMode As SpatialFieldPrimitiveHideMode
) As Integer
public:
int AddSpatialFieldPrimitive(
    Reference^ reference,
    SpatialFieldPrimitiveHideMode hidingMode
)
member AddSpatialFieldPrimitive :
        reference : Reference *
        hidingMode : SpatialFieldPrimitiveHideMode -> int

Parameters

reference Reference
Reference pointing to the curve or face to be associated with the primitive
hidingMode SpatialFieldPrimitiveHideMode
The mode used to hide the original model element

Return Value

Int32
Unique index of primitive for future references
Exceptions
Exception | Condition
ArgumentException | reference points to neither face nor curve
ArgumentNullException | A non-optional argument was null
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration
Remarks

There can be multiple primitives associated with one reference, normally they would be shown with different results. However this is justified only if they have different sets of domain points. Otherwise one primitive can be used to display values for different results.

See Also

Reference

SpatialFieldManager Class
AddSpatialFieldPrimitive Overload
Autodesk.Revit.DB.Analysis Namespace


SpatialFieldManager.Clear Method

SpatialFieldManagerClear Method

Clear all analysis results managed by this manager object

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


SpatialFieldManager.CreateSpatialFieldManager Method

SpatialFieldManagerCreateSpatialFieldManager Method

Factory method - creates manager object for the given view

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SpatialFieldManager CreateSpatialFieldManager(
    View view,
    int numberOfMeasurements
)
Public Shared Function CreateSpatialFieldManager (
    view As View,
    numberOfMeasurements As Integer
) As SpatialFieldManager
public:
static SpatialFieldManager^ CreateSpatialFieldManager(
    View^ view,
    int numberOfMeasurements
)
static member CreateSpatialFieldManager :
        view : View *
        numberOfMeasurements : int -> SpatialFieldManager

Parameters

view View
View for which manager object is created or retrieved
numberOfMeasurements Int32
Total number of measurements in the calculated results. This number defines the length of value arrays in ValueAtPoint objects

Return Value

SpatialFieldManager
Manager object for the view passed in the argument
Exceptions
Exception | Condition
ArgumentException | numberOfMeasurements is less than one
ArgumentNullException | A non-optional argument was null
InvalidOperationException | View is not allowed to display analysis results or a manager object for this view already exists
See Also

Reference

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


SpatialFieldManager.GetLegend Method

SpatialFieldManagerGetLegend Method

Returns legend element or NULL

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AnalysisDisplayLegend GetLegend()
Public Function GetLegend As AnalysisDisplayLegend
public:
AnalysisDisplayLegend^ GetLegend()
member GetLegend : unit -> AnalysisDisplayLegend

Return Value

AnalysisDisplayLegend
The legend element or NULL
See Also

Reference

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


SpatialFieldManager.GetMaximum Method

SpatialFieldManagerGetMaximum Method

Calculates the maximum value for all primitives

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetMaximum(
    int resultIndex,
    bool rawValue
)
Public Function GetMaximum (
    resultIndex As Integer,
    rawValue As Boolean
) As Double
public:
double GetMaximum(
    int resultIndex,
    bool rawValue
)
member GetMaximum :
        resultIndex : int *
        rawValue : bool -> float

Parameters

resultIndex Int32
Index of result schema
rawValue Boolean
If true returned value is NOT multiplied by the current result's units multiplier, otherwise it IS

Return Value

Double
Resulting maximum value
Exceptions
Exception | Condition
InapplicableDataException | Thrown when current measurement is >= the number of measurements for at least one primitive
See Also

Reference

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


SpatialFieldManager.GetMinimum Method

SpatialFieldManagerGetMinimum Method

Calculates the minimum value for all primitives

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public double GetMinimum(
    int resultIndex,
    bool rawValue
)
Public Function GetMinimum (
    resultIndex As Integer,
    rawValue As Boolean
) As Double
public:
double GetMinimum(
    int resultIndex,
    bool rawValue
)
member GetMinimum :
        resultIndex : int *
        rawValue : bool -> float

Parameters

resultIndex Int32
Index of result schema
rawValue Boolean
If true returned value is NOT multiplied by the current result's units multiplier, otherwise it IS

Return Value

Double
Resulting minimum value
Exceptions
Exception | Condition
InapplicableDataException | Thrown when current measurement is >= the number of measurements for at least one primitive
See Also

Reference

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


SpatialFieldManager.GetRegisteredResults Method

SpatialFieldManagerGetRegisteredResults Method

Returns an array of indices of all registered results

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IList<int> GetRegisteredResults()
Public Function GetRegisteredResults As IList(Of Integer)
public:
IList<int>^ GetRegisteredResults()
member GetRegisteredResults : unit -> IList<int>

Return Value

IList Int32
See Also

Reference

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


SpatialFieldManager.GetResultSchema Method

SpatialFieldManagerGetResultSchema Method

Returns result schema by index

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AnalysisResultSchema GetResultSchema(
    int idx
)
Public Function GetResultSchema (
    idx As Integer
) As AnalysisResultSchema
public:
AnalysisResultSchema^ GetResultSchema(
    int idx
)
member GetResultSchema :
        idx : int -> AnalysisResultSchema

Parameters

idx Int32
Index of registered result schema

Return Value

AnalysisResultSchema
Exceptions
Exception | Condition
ArgumentException | idx refers to non-existent result schema
See Also

Reference

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


SpatialFieldManager.GetSpatialFieldManager Method

SpatialFieldManagerGetSpatialFieldManager Method

Retrieves manager object for the given view or returns NULL

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static SpatialFieldManager GetSpatialFieldManager(
    View view
)
Public Shared Function GetSpatialFieldManager (
    view As View
) As SpatialFieldManager
public:
static SpatialFieldManager^ GetSpatialFieldManager(
    View^ view
)
static member GetSpatialFieldManager :
        view : View -> SpatialFieldManager

Parameters

view View
View for which manager object is retrieved

Return Value

SpatialFieldManager
Manager object for the view passed in the argument
See Also

Reference

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


SpatialFieldManager.IsResultSchemaNameUnique Method

SpatialFieldManagerIsResultSchemaNameUnique Method

Verify the uniqueness of the name among all registered result schemas.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsResultSchemaNameUnique(
    string name,
    int resultIndexToSkip
)
Public Function IsResultSchemaNameUnique (
    name As String,
    resultIndexToSkip As Integer
) As Boolean
public:
bool IsResultSchemaNameUnique(
    String^ name,
    int resultIndexToSkip
)
member IsResultSchemaNameUnique :
        name : string *
        resultIndexToSkip : int -> bool

Parameters

name String
Name to verify uniqueness of.
resultIndexToSkip Int32
Index of result (e.g. to be replaced) which names should not count for uniqueness; negative number means nothing is excluded from comparison.

Return Value

Boolean
True if name is unique, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


SpatialFieldManager.IsTextTypeIdValid Method

SpatialFieldManagerIsTextTypeIdValid Method

Verify if text type id is valid.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsTextTypeIdValid(
    ElementId textTypeId,
    Document doc
)
Public Shared Function IsTextTypeIdValid (
    textTypeId As ElementId,
    doc As Document
) As Boolean
public:
static bool IsTextTypeIdValid(
    ElementId^ textTypeId,
    Document^ doc
)
static member IsTextTypeIdValid :
        textTypeId : ElementId *
        doc : Document -> bool

Parameters

textTypeId ElementId
Text type id to be validated.
doc Document
Document for which %textTypeId% is validated.

Return Value

Boolean
True if text type id is valid, false otherwise.
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


SpatialFieldManager.RegisterResult Method

SpatialFieldManagerRegisterResult Method

Registers result and assigns it a unique result index

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int RegisterResult(
    AnalysisResultSchema resultSchema
)
Public Function RegisterResult (
    resultSchema As AnalysisResultSchema
) As Integer
public:
int RegisterResult(
    AnalysisResultSchema^ resultSchema
)
member RegisterResult :
        resultSchema : AnalysisResultSchema -> int

Parameters

resultSchema AnalysisResultSchema
Result schema to be registered

Return Value

Int32
Unique index assigned to the result
Exceptions
Exception | Condition
ArgumentException | name of resultSchema is not unique in view
ArgumentNullException | A non-optional argument was null
Example
C#
VB
C++
F#
Copy
// register a new result schema only if one with the same name does not already exist
IList<int> registeredResults = new List<int>();
AnalysisResultSchema resultSchema = new AnalysisResultSchema("Reactions", "Reaction Forces at Column Base");
registeredResults = spatialFieldManager.GetRegisteredResults();
int resultIndex = 999;
foreach (int myInt in registeredResults)
{
   if (spatialFieldManager.GetResultSchema(myInt).Name == "Reactions")
   {
      resultIndex = myInt;
      break;
   }
}
if (resultIndex == 999) // there are existing registered results, but none are named "Reactions"
   resultIndex = spatialFieldManager.RegisterResult(resultSchema);
' register a new result schema only if one with the same name does not already exist
Dim registeredResults As IList(Of Integer) = New List(Of Integer)()
Dim resultSchema As New AnalysisResultSchema("Reactions", "Reaction Forces at Column Base")
registeredResults = spatialFieldManager.GetRegisteredResults()
Dim resultIndex As Integer = 999
For Each myInt As Integer In registeredResults
    If spatialFieldManager.GetResultSchema(myInt).Name = "Reactions" Then
        resultIndex = myInt
        Exit For
    End If
Next
If resultIndex = 999 Then
    ' there are existing registered results, but none are named "Reactions"
    resultIndex = spatialFieldManager.RegisterResult(resultSchema)
End If

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


SpatialFieldManager.RemoveSpatialFieldPrimitive Method

SpatialFieldManagerRemoveSpatialFieldPrimitive Method

Removes analysis results primitive identified by the unique index

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveSpatialFieldPrimitive(
    int idx
)
Public Sub RemoveSpatialFieldPrimitive (
    idx As Integer
)
public:
void RemoveSpatialFieldPrimitive(
    int idx
)
member RemoveSpatialFieldPrimitive :
        idx : int -> unit

Parameters

idx Int32
Unique index identifying the primitive
Exceptions
Exception | Condition
ArgumentException | idx refers to non-existent primitive
See Also

Reference

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


SpatialFieldManager.SetMeasurementDescriptions Method

SpatialFieldManagerSetMeasurementDescriptions Method

Sets Descriptions for all measurements

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetMeasurementDescriptions(
    IList<string> measurementDescriptions
)
Public Sub SetMeasurementDescriptions (
    measurementDescriptions As IList(Of String)
)
public:
void SetMeasurementDescriptions(
    IList<String^>^ measurementDescriptions
)
member SetMeasurementDescriptions :
        measurementDescriptions : IList<string> -> unit

Parameters

measurementDescriptions IList String
Array of measurement descriptions. The lengths of the array must be equal to the number of measurements set during creation of SpatialFieldManager.
Exceptions
Exception | Condition
ArgumentException | measurementDescriptions lengths is not equal to the number of measurements set during creation of SpatialFieldManager
ArgumentNullException | A non-optional argument was null
See Also

Reference

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


SpatialFieldManager.SetMeasurementNames Method

SpatialFieldManagerSetMeasurementNames Method

Sets Names for all measurements

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetMeasurementNames(
    IList<string> measurementNames
)
Public Sub SetMeasurementNames (
    measurementNames As IList(Of String)
)
public:
void SetMeasurementNames(
    IList<String^>^ measurementNames
)
member SetMeasurementNames :
        measurementNames : IList<string> -> unit

Parameters

measurementNames IList String
Array of measurement names. All names in the array must be unique. The lengths of the array must be equal to the number of measurements set during creation of SpatialFieldManager.
Exceptions
Exception | Condition
ArgumentException | measurementNames contains duplicate names or its lengths is not equal to the number of measurements set during creation of SpatialFieldManager
ArgumentNullException | A non-optional argument was null
See Also

Reference

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


SpatialFieldManager.SetResultSchema Method

SpatialFieldManagerSetResultSchema Method

Sets a new value for an existing result schema in the result registry

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void SetResultSchema(
    int idx,
    AnalysisResultSchema resultSchema
)
Public Sub SetResultSchema (
    idx As Integer,
    resultSchema As AnalysisResultSchema
)
public:
void SetResultSchema(
    int idx,
    AnalysisResultSchema^ resultSchema
)
member SetResultSchema :
        idx : int *
        resultSchema : AnalysisResultSchema -> unit

Parameters

idx Int32
Index of registered result schema
resultSchema AnalysisResultSchema
Result schema replacing the existent one
Exceptions
Exception | Condition
ArgumentException | idx refers to non-existent result schema -or- name of resultSchema is not unique in view
ArgumentNullException | A non-optional argument was null
See Also

Reference

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


SpatialFieldManager.UpdateSpatialFieldPrimitive Method

SpatialFieldManagerUpdateSpatialFieldPrimitive Method

Populates analysis results data (or replaces the existing data) in the existing primitive identified by the unique index

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void UpdateSpatialFieldPrimitive(
    int idx,
    FieldDomainPoints fieldDomainPoints,
    FieldValues fieldValues,
    int resultIndex
)
Public Sub UpdateSpatialFieldPrimitive (
    idx As Integer,
    fieldDomainPoints As FieldDomainPoints,
    fieldValues As FieldValues,
    resultIndex As Integer
)
public:
void UpdateSpatialFieldPrimitive(
    int idx,
    FieldDomainPoints^ fieldDomainPoints,
    FieldValues^ fieldValues,
    int resultIndex
)
member UpdateSpatialFieldPrimitive :
        idx : int *
        fieldDomainPoints : FieldDomainPoints *
        fieldValues : FieldValues *
        resultIndex : int -> unit

Parameters

idx Int32
Unique index identifying the primitive
fieldDomainPoints FieldDomainPoints
Set of domain points. If the new set of domain points is supplied, all previously supplied domain points and field values for all results are removed from the primitive. If %fieldDomainPoints% is only fieldValues are updated
fieldValues FieldValues
Set of data values. Number of values in fieldValues must coincide with the number of points in fieldDomainPoints
resultIndex Int32
Unique index identifying the result schema
Exceptions
Exception | Condition
ArgumentException | idx refers to non-existent primitive -or- fieldValues has incorrect number of measurements in ValueAtPoint objects -or- fieldDomainPoints has inconsistent type -or- resultIndex refers to non-existent result schema
ArgumentNullException | A non-optional argument was null
ArgumentsInconsistentException | fieldDomainPoints and fieldValues have inconsistent number of points
See Also

Reference

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


SpatialFieldPrimitiveHideMode Enumeration

Defines modes which can be used by a SpatialFieldPrimitive to hide the original referenced element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum SpatialFieldPrimitiveHideMode
Public Enumeration SpatialFieldPrimitiveHideMode
public enum class SpatialFieldPrimitiveHideMode
type SpatialFieldPrimitiveHideMode
Members
Member name | Value | Description
Default | 0 | For ColoredSurface display style, hide only the referenced face passed at the primitive creation time. For DeformedShape display style, hide only the referenced face or curve passed at the primitive creation time.
HideNone | 1 | Do not hide any piece of the original model element.
HideOnlyReference | 2 | Hide only the referenced face or curve.
HideWholeElement | 3 | Hide the whole referenced element.
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


SystemsAnalysisOptions Class

Contains the options for systems analysis.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DB.AnalysisSystemsAnalysisOptions

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class SystemsAnalysisOptions : IDisposable
Public Class SystemsAnalysisOptions
    Implements IDisposable
public ref class SystemsAnalysisOptions : IDisposable
type SystemsAnalysisOptions =
    class
        interface IDisposable
    end

The SystemsAnalysisOptions type exposes the following members.

Constructors
 | Name | Description
Public method | SystemsAnalysisOptions | Constructs a new instance of the options.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OutputFolder | The path of the output folder for systems analysis.
Public property | WeatherFile | The file name of the EnergyPlus weather (*.epw).
Public property | WorkflowFile | The file name of the EnergyPlus workflow script.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the SystemsAnalysisOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


SystemsAnalysisOptions Constructor

Constructs a new instance of the options.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SystemsAnalysisOptions()
Public Sub New
public:
SystemsAnalysisOptions()
new : unit -> SystemsAnalysisOptions
See Also

Reference

SystemsAnalysisOptions Class
Autodesk.Revit.DB.Analysis Namespace


SystemsAnalysisOptions Properties

The SystemsAnalysisOptions type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity.
Public property | OutputFolder | The path of the output folder for systems analysis.
Public property | WeatherFile | The file name of the EnergyPlus weather (*.epw).
Public property | WorkflowFile | The file name of the EnergyPlus workflow script.
Top
See Also

Reference

SystemsAnalysisOptions Class
Autodesk.Revit.DB.Analysis Namespace


SystemsAnalysisOptions.IsValidObject Property

SystemsAnalysisOptionsIsValidObject Property

Specifies whether the .NET object represents a valid Revit entity.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValidObject { get; }
Public ReadOnly Property IsValidObject As Boolean
    Get
public:
property bool IsValidObject {
    bool get ();
}
member IsValidObject : bool with get

Return Value

Boolean
True if the API object holds a valid Revit native object, false otherwise.
Remarks
If the corresponding Revit native object is destroyed, or creation of the corresponding object is undone, a managed API object containing it is no longer valid. API methods cannot be called on invalidated wrapper objects.
See Also

Reference

SystemsAnalysisOptions Class
Autodesk.Revit.DB.Analysis Namespace


SystemsAnalysisOptions.OutputFolder Property

SystemsAnalysisOptionsOutputFolder Property

The path of the output folder for systems analysis.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string OutputFolder { get; set; }
Public Property OutputFolder As String
    Get
    Set
public:
property String^ OutputFolder {
    String^ get ();
    void set (String^ value);
}
member OutputFolder : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentException | When setting this property: The analysis requires a valid output folder.
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
When requesting a new system analysis, it is okay to have an empty output folder in the SystemsAnalysisOption. In that case, the ViewSystemsAnalysisReport would supply the output folder, typically at the system TEMP folder.
See Also

Reference

SystemsAnalysisOptions Class
Autodesk.Revit.DB.Analysis Namespace


SystemsAnalysisOptions.WeatherFile Property

SystemsAnalysisOptionsWeatherFile Property

The file name of the EnergyPlus weather (*.epw).

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string WeatherFile { get; set; }
Public Property WeatherFile As String
    Get
    Set
public:
property String^ WeatherFile {
    String^ get ();
    void set (String^ value);
}
member WeatherFile : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentException | When setting this property: The analysis requires a valid EnergyPlus weather (.epw) file.
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
When requesting a new system analysis, it is okay to have an empty weather file in the SystemsAnalysisOption. In that case, the ViewSystemsAnalysisReport would use the weather file at the current site location.
See Also

Reference

SystemsAnalysisOptions Class
Autodesk.Revit.DB.Analysis Namespace


SystemsAnalysisOptions.WorkflowFile Property

SystemsAnalysisOptionsWorkflowFile Property

The file name of the EnergyPlus workflow script.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string WorkflowFile { get; set; }
Public Property WorkflowFile As String
    Get
    Set
public:
property String^ WorkflowFile {
    String^ get ();
    void set (String^ value);
}
member WorkflowFile : string with get, set

Property Value

String
Exceptions
Exception | Condition
ArgumentException | When setting this property: The analysis requires a valid workflow file.
ArgumentNullException | When setting this property: A non-optional argument was null
Remarks
When requesting a new system analysis, it is okay to have an empty workflowFile in the SystemsAnalysisOption. In that case, the ViewSystemsAnalysisReport would supply the weather file with the default value "HVAC Systems Loads and Sizing.osw".
See Also

Reference

SystemsAnalysisOptions Class
Autodesk.Revit.DB.Analysis Namespace


SystemsAnalysisOptions Methods

The SystemsAnalysisOptions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

SystemsAnalysisOptions Class
Autodesk.Revit.DB.Analysis Namespace


SystemsAnalysisOptions.Dispose Method

SystemsAnalysisOptionsDispose Method

Releases all resources used by the SystemsAnalysisOptions

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

SystemsAnalysisOptions Class
Autodesk.Revit.DB.Analysis Namespace


SystemsAnalysisReportStyle Enumeration

The report style of systems analysis.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum SystemsAnalysisReportStyle
Public Enumeration SystemsAnalysisReportStyle
public enum class SystemsAnalysisReportStyle
type SystemsAnalysisReportStyle
Members
Member name | Value | Description
Detailed | 0 | The detailed report style.
Loads | 1 | The loads report style.
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


ValueAtPoint Class

Stores values at one domain point. Each value corresponds to a "measurement" for which this value was calculated.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBValueAtPointBase
Autodesk.Revit.DB.AnalysisValueAtPoint

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ValueAtPoint : ValueAtPointBase
Public Class ValueAtPoint
    Inherits ValueAtPointBase
public ref class ValueAtPoint : public ValueAtPointBase
type ValueAtPoint =
    class
        inherit ValueAtPointBase
    end

The ValueAtPoint type exposes the following members.

Constructors
 | Name | Description
Public method | ValueAtPoint(IListDouble) | Creates object from an array of values
Public method | ValueAtPoint(ValueAtPoint) | Creates a copy of the given ValueAtPoint instance.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ValueAtPointBase)
Top
Methods
 | Name | Description
Public method | ClearAllFlags | Sets flags for all measurements to ValueAtPointFlags::None. (Inherited from ValueAtPointBase)
Public method | ClearFlagsAt | Sets flags for the given measurement to ValueAtPointFlags::None. (Inherited from ValueAtPointBase)
Public method | Dispose | (Inherited from ValueAtPointBase)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetFlags | Returns flags for the given measurement. (Inherited from ValueAtPointBase)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetFlags(IListInt32) | Independently sets the flags associated to all measurements. (Inherited from ValueAtPointBase)
Public method | SetFlags(Int32) | Sets the flags associated to all measurements to the same value. (Inherited from ValueAtPointBase)
Public method | SetFlags(Int32, Int32) | Sets the flags associated to a given measurement. (Inherited from ValueAtPointBase)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


ValueAtPoint Constructor

Overload List
 | Name | Description
Public method | ValueAtPoint(IListDouble) | Creates object from an array of values
Public method | ValueAtPoint(ValueAtPoint) | Creates a copy of the given ValueAtPoint instance.
Top
See Also

Reference

ValueAtPoint Class
Autodesk.Revit.DB.Analysis Namespace


ValueAtPoint(IList<Double>) Constructor

ValueAtPoint(IListDouble) Constructor

Creates object from an array of values

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ValueAtPoint(
    IList<double> values
)
Public Sub New (
    values As IList(Of Double)
)
public:
ValueAtPoint(
    IList<double>^ values
)
new :
        values : IList<float> -> ValueAtPoint

Parameters

values IList Double
Array of values, each corresponding to "measurement"
Exceptions
Exception | Condition
ArgumentException | Thrown when supplied values contain invalid (infinite or non-number) doubles
ArgumentNullException | A non-optional argument was null
See Also

Reference

ValueAtPoint Class
ValueAtPoint Overload
Autodesk.Revit.DB.Analysis Namespace


ValueAtPoint(ValueAtPoint) Constructor

Creates a copy of the given ValueAtPoint instance.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ValueAtPoint(
    ValueAtPoint otherObject
)
Public Sub New (
    otherObject As ValueAtPoint
)
public:
ValueAtPoint(
    ValueAtPoint^ otherObject
)
new :
        otherObject : ValueAtPoint -> ValueAtPoint

Parameters

otherObject ValueAtPoint
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

ValueAtPoint Class
ValueAtPoint Overload
Autodesk.Revit.DB.Analysis Namespace


ValueAtPoint Properties

The ValueAtPoint type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ValueAtPointBase)
Top
See Also

Reference

ValueAtPoint Class
Autodesk.Revit.DB.Analysis Namespace


ValueAtPoint Methods

The ValueAtPoint type exposes the following members.

Methods
 | Name | Description
Public method | ClearAllFlags | Sets flags for all measurements to ValueAtPointFlags::None. (Inherited from ValueAtPointBase)
Public method | ClearFlagsAt | Sets flags for the given measurement to ValueAtPointFlags::None. (Inherited from ValueAtPointBase)
Public method | Dispose | (Inherited from ValueAtPointBase)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetFlags | Returns flags for the given measurement. (Inherited from ValueAtPointBase)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetFlags(IListInt32) | Independently sets the flags associated to all measurements. (Inherited from ValueAtPointBase)
Public method | SetFlags(Int32) | Sets the flags associated to all measurements to the same value. (Inherited from ValueAtPointBase)
Public method | SetFlags(Int32, Int32) | Sets the flags associated to a given measurement. (Inherited from ValueAtPointBase)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

ValueAtPoint Class
Autodesk.Revit.DB.Analysis Namespace


VectorAtPoint Class

Stores vectors at one domain point. Each vector corresponds to a "measurement" for which this vector was calculated.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBValueAtPointBase
Autodesk.Revit.DB.AnalysisVectorAtPoint

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class VectorAtPoint : ValueAtPointBase
Public Class VectorAtPoint
    Inherits ValueAtPointBase
public ref class VectorAtPoint : public ValueAtPointBase
type VectorAtPoint =
    class
        inherit ValueAtPointBase
    end

The VectorAtPoint type exposes the following members.

Constructors
 | Name | Description
Public method | VectorAtPoint(IListXYZ) | Creates object from an array of vectors
Public method | VectorAtPoint(VectorAtPoint) | Creates a copy of the given VectorAtPoint instance.
Top
Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ValueAtPointBase)
Top
Methods
 | Name | Description
Public method | ClearAllFlags | Sets flags for all measurements to ValueAtPointFlags::None. (Inherited from ValueAtPointBase)
Public method | ClearFlagsAt | Sets flags for the given measurement to ValueAtPointFlags::None. (Inherited from ValueAtPointBase)
Public method | Dispose | (Inherited from ValueAtPointBase)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetFlags | Returns flags for the given measurement. (Inherited from ValueAtPointBase)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetFlags(IListInt32) | Independently sets the flags associated to all measurements. (Inherited from ValueAtPointBase)
Public method | SetFlags(Int32) | Sets the flags associated to all measurements to the same value. (Inherited from ValueAtPointBase)
Public method | SetFlags(Int32, Int32) | Sets the flags associated to a given measurement. (Inherited from ValueAtPointBase)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Example
C#
VB
C++
F#
Copy
// Place analysis results in the form of vectors at each of a beam or column's analytical model curve
Transform transform = analyticalElem.GetTransform();
int index = spatialFieldManager.AddSpatialFieldPrimitive(curve, Transform.Identity);

IList<double> doubleList = new List<double>();
doubleList.Add(curve.GetEndParameter(0)); // vectors will be at each end of the analytical model curve
doubleList.Add(curve.GetEndParameter(1));
FieldDomainPointsByParameter pointsByParameter = new FieldDomainPointsByParameter(doubleList);

List<XYZ> xyzList = new List<XYZ>();
xyzList.Add(curve.ComputeDerivatives(0, true).BasisX.Normalize()); // vectors will be tangent to the curve at its ends
IList<VectorAtPoint> vectorList = new List<VectorAtPoint>();
vectorList.Add(new VectorAtPoint(xyzList));
xyzList.Clear();
xyzList.Add(curve.ComputeDerivatives(1, true).BasisX.Normalize().Negate());
vectorList.Add(new VectorAtPoint(xyzList));
FieldValues fieldValues = new FieldValues(vectorList);
' Place analysis results in the form of vectors at each of a beam or column's analytical model curve
Dim analyticalModel As Autodesk.Revit.DB.Structure.AnalyticalElement = Nothing
Dim relManager As Autodesk.Revit.DB.Structure.AnalyticalToPhysicalAssociationManager = Autodesk.Revit.DB.Structure.AnalyticalToPhysicalAssociationManager.GetAnalyticalToPhysicalAssociationManager(doc)

If (relManager Is Nothing) Then
   Exit Sub
End If

   Dim counterpartId As ElementId = relManager.GetAssociatedElementId(familyInstance.Id)
   If (counterpartId Is Nothing) Then
   Exit Sub
End If

analyticalModel = doc.GetElement(counterpartId)

Dim curve As Curve = analyticalModel.GetCurve()
Dim transform__1 As Transform = familyInstance.GetTransform()
   Dim index As Integer = spatialFieldManager.AddSpatialFieldPrimitive(curve, Transform.Identity)

   Dim doubleList As IList(Of Double) = New List(Of Double)()
   doubleList.Add(curve.GetEndParameter(0))
   ' vectors will be at each end of the analytical model curve
   doubleList.Add(curve.GetEndParameter(1))
   Dim pointsByParameter As New FieldDomainPointsByParameter(doubleList)

   Dim xyzList As New List(Of XYZ)()
   xyzList.Add(curve.ComputeDerivatives(0, True).BasisX.Normalize())
   ' vectors will be tangent to the curve at its ends
   Dim vectorList As IList(Of VectorAtPoint) = New List(Of VectorAtPoint)()
   vectorList.Add(New VectorAtPoint(xyzList))
   xyzList.Clear()
   xyzList.Add(curve.ComputeDerivatives(1, True).BasisX.Normalize().Negate())
   vectorList.Add(New VectorAtPoint(xyzList))
   Dim fieldValues As New FieldValues(vectorList)

No code example is currently available or this language may not be supported.

No code example is currently available or this language may not be supported.

See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


VectorAtPoint Constructor

Overload List
 | Name | Description
Public method | VectorAtPoint(IListXYZ) | Creates object from an array of vectors
Public method | VectorAtPoint(VectorAtPoint) | Creates a copy of the given VectorAtPoint instance.
Top
See Also

Reference

VectorAtPoint Class
Autodesk.Revit.DB.Analysis Namespace


VectorAtPoint(IList<XYZ>) Constructor

VectorAtPoint(IListXYZ) Constructor

Creates object from an array of vectors

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VectorAtPoint(
    IList<XYZ> vectors
)
Public Sub New (
    vectors As IList(Of XYZ)
)
public:
VectorAtPoint(
    IList<XYZ^>^ vectors
)
new :
        vectors : IList<XYZ> -> VectorAtPoint

Parameters

vectors IList XYZ
Array of vectors, each corresponding to "measurement"
Exceptions
Exception | Condition
ArgumentException | Thrown when supplied vectors contain invalid (infinite or non-number) coordinates
ArgumentNullException | A non-optional argument was null
See Also

Reference

VectorAtPoint Class
VectorAtPoint Overload
Autodesk.Revit.DB.Analysis Namespace


VectorAtPoint(VectorAtPoint) Constructor

Creates a copy of the given VectorAtPoint instance.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VectorAtPoint(
    VectorAtPoint otherObject
)
Public Sub New (
    otherObject As VectorAtPoint
)
public:
VectorAtPoint(
    VectorAtPoint^ otherObject
)
new :
        otherObject : VectorAtPoint -> VectorAtPoint

Parameters

otherObject VectorAtPoint
Exceptions
Exception | Condition
ArgumentNullException | A non-optional argument was null
See Also

Reference

VectorAtPoint Class
VectorAtPoint Overload
Autodesk.Revit.DB.Analysis Namespace


VectorAtPoint Properties

The VectorAtPoint type exposes the following members.

Properties
 | Name | Description
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ValueAtPointBase)
Top
See Also

Reference

VectorAtPoint Class
Autodesk.Revit.DB.Analysis Namespace


VectorAtPoint Methods

The VectorAtPoint type exposes the following members.

Methods
 | Name | Description
Public method | ClearAllFlags | Sets flags for all measurements to ValueAtPointFlags::None. (Inherited from ValueAtPointBase)
Public method | ClearFlagsAt | Sets flags for the given measurement to ValueAtPointFlags::None. (Inherited from ValueAtPointBase)
Public method | Dispose | (Inherited from ValueAtPointBase)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | GetFlags | Returns flags for the given measurement. (Inherited from ValueAtPointBase)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | SetFlags(IListInt32) | Independently sets the flags associated to all measurements. (Inherited from ValueAtPointBase)
Public method | SetFlags(Int32) | Sets the flags associated to all measurements to the same value. (Inherited from ValueAtPointBase)
Public method | SetFlags(Int32, Int32) | Sets the flags associated to a given measurement. (Inherited from ValueAtPointBase)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

VectorAtPoint Class
Autodesk.Revit.DB.Analysis Namespace


ViewSystemsAnalysisReport Class

Represents a report instance of the systems analysis.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBView
Autodesk.Revit.DB.AnalysisViewSystemsAnalysisReport

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ViewSystemsAnalysisReport : View
Public Class ViewSystemsAnalysisReport
    Inherits View
public ref class ViewSystemsAnalysisReport : public View
type ViewSystemsAnalysisReport =
    class
        inherit View
    end

The ViewSystemsAnalysisReport type exposes the following members.

Properties
 | Name | Description
Public property | AnalysisDateAndTime | Identifies the analysis date and time when it was requested.
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View)
Public property | AreAnalyticalModelCategoriesHidden | Indicates if analytical model categories are currently hidden in the view. (Inherited from View)
Public property | AreAnnotationCategoriesHidden | Indicates if annotation categories are currently hidden in the view. (Inherited from View)
Public property | AreCoordinationModelHandlesHidden | Indicates if Coordination Model handles are currently hidden in the view. (Inherited from View)
Public property | AreImportCategoriesHidden | Indicates if import categories are currently hidden in the view. (Inherited from View)
Public property | AreModelCategoriesHidden | Indicates if model categories are currently hidden in the view. (Inherited from View)
Public property | ArePointCloudsHidden | Indicates if point clouds are currently hidden in the view. (Inherited from View)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CropBox | The Crop Box applied to the view, or an outline encompassing the crop region applied to the view. (Inherited from View)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | DetailLevel | The detail level of this view. (Inherited from View)
Public property | Discipline | The Discipline of the view. (Inherited from View)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | GenLevel | The level for the view. (Inherited from View)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsAssemblyView | Indicates if the view is assembly view. (Inherited from View)
Public property | IsCallout | Indicates if the view is a callout view. (Inherited from View)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | Origin | Returns the origin of the screen. (Inherited from View)
Public property | Outline | The bounds of the view in paper space (in feet). (Inherited from View)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ReportStyle | The report style that specifies the display content.
Public property | RevealConstraintsMode | Indicates whether the Reveal Constraints mode is activated in the view. (Inherited from View)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View)
Public property | Scale | The scale of the view. (Inherited from View)
Public property | ShadowIntensity | The intesity of cast shadows - 0 = no shadows, 100 = black. (Inherited from View)
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View)
Public property | SunlightIntensity | The intensity of the simulated (directional) sunlight. 0 = no directional light; maximum value is 100. (Inherited from View)
Public property | SystemsAnalysisOutputFolder | The full path of the output folder for systems analysis
Public property | SystemsAnalysisWorkflowFile | The full path name of the original system analysis workflow file.
Public property | TemporaryViewModes | Data of temporary view modes associated with this view. (Inherited from View)
Public property | Title | The view title. This consists of the view name plus other modifiers, such as the view type, sheet number, area scheme, and/or assembly type, depending on the specifics of the view. (Inherited from View)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | ViewTemplateId | The id of the template view that controls this view's parameters. (Inherited from View)
 | ViewType | The type of the view. (Inherited from View)
Public property | WeatherFile | The full path name of the weather file used for the systems analysis.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
Methods
 | Name | Description
Public method | AddFilter | Adds a filter to the view. (Inherited from View)
Public method | AllowsAnalysisDisplay | Identifies if this view allows display of Analysis results. (Inherited from View)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of the input view that are not controlled by the current view template. (Inherited from View)
Public method | AreGraphicsOverridesAllowed | Determines if Visibility/Graphics Overriddes can be applied to the view. (Inherited from View)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element)
Public method | CanApplyColorFillScheme | Checks if the id can be applied as the scheme id of specified category to this view. (Inherited from View)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element)
Public method | CanBeLocked | Identifies if the element can be locked. (Inherited from Element)
Public method | CanCategoryBeHidden | Checks whether the category can be hidden in the view. (Inherited from View)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View)
 | CancelSystemsAnalysis | Cancels the systems analysis based on the report element id.
Public method | CanDeleteSubelement | Checks if given subelement can be removed from the element. (Inherited from Element)
Public method | CanEnableTemporaryViewPropertiesMode | Indicates if Temporary View Properties mode can be applied for view in current state. (Inherited from View)
Public method | CanHaveTypeAssigned | Identifies if the element can have a type assigned. (Inherited from Element)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified (Inherited from View)
Public method | CanUseDepthCueing | Indicates if view can use Depth Cueing (Inherited from View)
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes (Inherited from View)
Public method | CanViewBeDuplicated | Identifies if this view can be duplicated. (Inherited from View)
Public method | ChangeTypeId(ElementId) | Changes the type of the element. (Inherited from Element)
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View)
 | ConvertToIndependent | Convert the dependent view to independent. (Inherited from View)
 | Create | Creates a new view for the systems analysis report.
Public method | CreateViewTemplate | Creates a new view template instance from this view instance. (Inherited from View)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element (Inherited from Element)
Public method | DeleteSubelement | Removes a subelement from the element. (Inherited from Element)
Public method | DeleteSubelements | Removes the subelements from the element. (Inherited from Element)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View)
Public method | Dispose | (Inherited from Element)
 | Duplicate | Duplicates this view. (Inherited from View)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View)
Public method | EnableTemporaryViewPropertiesMode | Turns Temporary View Properties mode on or off. In this mode, any changes made to the view are temporary and will be discarded once the mode is disabled. (Inherited from View)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Public method | EvaluateAllParameterValues | Evaluates all the parameters' values of the element. (Inherited from Element)
Public method | EvaluateParameterValues | Evaluate the parameters' values of the element on the given parameter ID set. (Inherited from Element)
Public method | GetBackground | Returns the current background set for the view. (Inherited from View)
Public method | GetCalloutParentId | Gets ID of the callout parent view. (Inherited from View)
Public method | GetCategoryHidden | Checks if elements of the given category are set to be invisible (hidden) in this view. (Inherited from View)
Public method | GetCategoryOverrides | Gets graphic overrides for a category in view. (Inherited from View)
Public method | GetColorFillSchemeId | Returns id of the color fill scheme element applied to the view. (Inherited from View)
Public method | GetCropRegionShapeManager | Returns an object for managing view crop region shape. (Inherited from View)
Public method | GetDependentElements | Get all elements that, from a logical point of view, are the children of this Element. (Inherited from Element)
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View)
Public method | GetDepthCueing | Returns the current depth cueing settings for the view. (Inherited from View)
Public method | GetDirectContext3DHandleOverrides | Returns DirectContext3D handle overrides object for the view. (Inherited from View)
Public method | GetElementOverrides | Gets graphic overrides for an element in the view. (Inherited from View)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element)
Public method | GetEntitySchemaGuids | Returns the Schema guids of any Entities stored in this element. (Inherited from Element)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReference | Gets the ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferenceExpanded | Gets the collection of ExternalResourceReference associated with a specified external resource type. (Inherited from Element)
Public method | GetExternalResourceReferences | Gets the map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetExternalResourceReferencesExpanded | Gets the expanded map of the external resource references referenced by the element. (Inherited from Element)
Public method | GetFilterOverrides | Gets graphic overrides that a filter applies to the view. (Inherited from View)
Public method | GetFilters | Gets the filters applied to the view. (Inherited from View)
Public method | GetFilterVisibility | Gets the visibility of the elements associated with a filter. (Inherited from View)
 | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetIsFilterEnabled | Identifies if the filter is enabled in this view. (Inherited from View)
 | GetLatestSystemsAnalysisReport | Gets the latest report of systems analysis.
 | GetLinkOverrides | Gets the graphic overrides of a RevitLinkType or RevitLinkInstance in view. (Inherited from View)
Public method | GetMaterialArea | Gets the area of the material with the given id. (Inherited from Element)
Public method | GetMaterialIds | Gets the element ids of all materials present in the element. (Inherited from Element)
Public method | GetMaterialVolume | Gets the volume of the material with the given id. (Inherited from Element)
Public method | GetModelToProjectionTransforms | Gets the transforms from the model space to the view projection space. (Inherited from View)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element)
Public method | GetNonControlledTemplateParameterIds | Returns a list of parameters that are not marked as included when this view is used as a template. (Inherited from View)
Public method | GetOrderedFilters | Gets the filters applied to the view in the order they are applied. (Inherited from View)
Public method | GetOrderedParameters | Gets the parameters associated to the element in order. (Inherited from Element)
Public method | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element)
Public method | GetParameterFormatOptions | Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists. (Inherited from Element)
Public method | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase (Inherited from Element)
Public method | GetPlacementOnSheetStatus | Determines if this view placed on a sheet completely or partially. (Inherited from View)
Public method | GetPointCloudOverrides | Returns point cloud overrides object for the view. (Inherited from View)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View)
Public method | GetReferenceCallouts | Returns element ids of all reference callouts in the view. (Inherited from View)
Public method | GetReferenceElevations | Returns element ids of all reference elevations in the view. (Inherited from View)
Public method | GetReferenceSections | Returns element ids of all reference sections in the view. (Inherited from View)
Public method | GetReportContent | Gets the report content in this view.
Public method | GetSketchyLines | Returns the current sketchy lines settings for the view. (Inherited from View)
Public method | GetSubelements | Returns the collection of element subelements. (Inherited from Element)
Public method | GetTemplateParameterIds | Returns a list of parameter ids that may be controlled when this view is assigned as a template. (Inherited from View)
Public method | GetTemporaryViewPropertiesId | When Temporary View Properties mode is in progress it provides view id that overrode settings for current view. Outside Temporary View Properties mode InvalidElementId will be returned. (Inherited from View)
Public method | GetTemporaryViewPropertiesName | When Temporary View Properties mode is in progress, name of applied template is returned. Outside Temporary View Properties mode, empty string will be returned. (Inherited from View)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
 | GetTypeId | Returns the identifier of this element's type. (Inherited from Element)
Public method | GetValidTypes | Obtains a set of types that are valid for this element. (Inherited from Element)
Public method | GetViewDisplayModel | Returns the current view display model settings for the view. (Inherited from View)
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View)
Public method | HasDetailLevel | Check if the view has a Detail Level property (Inherited from View)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property (Inherited from View)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property (Inherited from View)
Public method | HasViewTransforms | Returns true if the view reports model space to view projection space transforms. (Inherited from View)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View)
Public method | IsAnalysisCompleted | Indicates if the background systems analysis has completed or not.
Public method | IsCategoryOverridable | Checks whether the category can have graphic overrides in this view. (Inherited from View)
Public method | IsCreatedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsDemolishedPhaseOrderValid | Returns true if createdPhaseId and demolishedPhaseId are in order. (Inherited from Element)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element)
Public method | IsFilterApplied | Indicates if a filter is applied to the view. (Inherited from View)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input. (Inherited from View)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input. (Inherited from View)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element)
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View)
Public method | IsTemporaryViewPropertiesModeEnabled | Returns true when Temporary View Properties mode is in progress, false otherwise. (Inherited from View)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element)
Public method | IsValidViewTemplate | Verifies that the view represented by templateId can be set as the controlling view template for this view. (Inherited from View)
Public method | IsViewValidForTemplateCreation | Verifies that the view is valid for template creation. (Inherited from View)
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View)
Public method | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element)
Public method | Print | Print this view with the default view template and using the print setting of the current active document. (Inherited from View)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View)
Public method | RefersToExternalResourceReference | Determines whether this Element uses external resources associated with a specified external resource type. (Inherited from Element)
Public method | RefersToExternalResourceReferences | Determines whether this Element uses external resources. (Inherited from Element)
Public method | RemoveCalloutParent | Replaces callout parent ID with InvalidElementId. (Inherited from View)
Public method | RemoveFilter | Removes a filter from the view. (Inherited from View)
 | RemoveLinkOverrides | Deletes the graphical link overrides in the current view. (Inherited from View)
 | RequestSystemsAnalysis | Requests a new systems analysis in the background.
Public method | RestoreCalloutParent | Restores callout parent ID to the original view ID if that view is still available. (Inherited from View)
Public method | SetBackground | Sets the background for the view. Background can only be set for 3d views and for Sections/Elevations. (Inherited from View)
Public method | SetCategoryHidden | Sets if elements of the given category will be visible in this view. (Inherited from View)
Public method | SetCategoryOverrides | Sets graphic overrides for a category in view. (Inherited from View)
Public method | SetColorFillSchemeId | Applies color fill scheme to this view. (Inherited from View)
Public method | SetDepthCueing | Sets the depth cueing settings for the view. (Inherited from View)
Public method | SetElementOverrides | Sets graphic overrides for an element in the view. (Inherited from View)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element)
 | SetFilterOverrides | Sets the overrides associated with a filter. (Inherited from View)
Public method | SetFilterVisibility | Sets the visibility of the elements associated with a filter. (Inherited from View)
Public method | SetIsFilterEnabled | Sets the filter enabled flag. (Inherited from View)
 | SetLinkOverrides | Sets the graphic overrides of a RevitLinkType or RevitLinkInstance in the view. (Inherited from View)
Public method | SetNonControlledTemplateParameterIds | Sets the parameters that will not be included when this view is used as a template. (Inherited from View)
Public method | SetSketchyLines | Sets the sketchy lines settings for the view. (Inherited from View)
Public method | SetViewDisplayModel | Sets the view display model settings for the view. (Inherited from View)
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View)
 | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View)
Public method | SupportedColorFillCategoryIds | Returns collection of all category ids that correspond to elements that can potentially be colored in this view according to a color fill scheme. The set may be different depending on the view type. (Inherited from View)
Public method | SupportsRevealConstraints | Checks that the view can have the Reveal Constraints mode activated. (Inherited from View)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View)
Top
See Also

Reference

Autodesk.Revit.DB.Analysis Namespace


ViewSystemsAnalysisReport Properties

The ViewSystemsAnalysisReport type exposes the following members.

Properties
 | Name | Description
Public property | AnalysisDateAndTime | Identifies the analysis date and time when it was requested.
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View)
Public property | AreAnalyticalModelCategoriesHidden | Indicates if analytical model categories are currently hidden in the view. (Inherited from View)
Public property | AreAnnotationCategoriesHidden | Indicates if annotation categories are currently hidden in the view. (Inherited from View)
Public property | AreCoordinationModelHandlesHidden | Indicates if Coordination Model handles are currently hidden in the view. (Inherited from View)
Public property | AreImportCategoriesHidden | Indicates if import categories are currently hidden in the view. (Inherited from View)
Public property | AreModelCategoriesHidden | Indicates if model categories are currently hidden in the view. (Inherited from View)
Public property | ArePointCloudsHidden | Indicates if point clouds are currently hidden in the view. (Inherited from View)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View)
 | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element)
 | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element)
Public property | CropBox | The Crop Box applied to the view, or an outline encompassing the crop region applied to the view. (Inherited from View)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View)
 | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element)
 | DesignOption | Returns the design option to which the element belongs. (Inherited from Element)
Public property | DetailLevel | The detail level of this view. (Inherited from View)
Public property | Discipline | The Discipline of the view. (Inherited from View)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element)
Public property | GenLevel | The level for the view. (Inherited from View)
 | Geometry | Retrieves the geometric representation of the element. (Inherited from Element)
Public property | GroupId | The id of the group to which an element belongs. (Inherited from Element)
 | Id | A unique identifier for an Element in an Autodesk Revit project. (Inherited from Element)
Public property | IsAssemblyView | Indicates if the view is assembly view. (Inherited from View)
Public property | IsCallout | Indicates if the view is a callout view. (Inherited from View)
Public property | IsModifiable | Identifies if the element is modifiable. (Inherited from Element)
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View)
Public property | IsTransient | Indicates whether an element is transient or permanent. (Inherited from Element)
Public property | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Element)
Public property | LevelId | The id of the level associated with the element. (Inherited from Element)
 | Location | This property is used to find the physical location of an element within a project. (Inherited from Element)
Public property | Name | A human readable name for the Element. (Inherited from Element)
Public property | Origin | Returns the origin of the screen. (Inherited from View)
Public property | Outline | The bounds of the view in paper space (in feet). (Inherited from View)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element)
 | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element)
Public property | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element)
Public property | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element)
 | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element)
Public property | ReportStyle | The report style that specifies the display content.
Public property | RevealConstraintsMode | Indicates whether the Reveal Constraints mode is activated in the view. (Inherited from View)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View)
Public property | Scale | The scale of the view. (Inherited from View)
Public property | ShadowIntensity | The intesity of cast shadows - 0 = no shadows, 100 = black. (Inherited from View)
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View)
Public property | SunlightIntensity | The intensity of the simulated (directional) sunlight. 0 = no directional light; maximum value is 100. (Inherited from View)
Public property | SystemsAnalysisOutputFolder | The full path of the output folder for systems analysis
Public property | SystemsAnalysisWorkflowFile | The full path name of the original system analysis workflow file.
Public property | TemporaryViewModes | Data of temporary view modes associated with this view. (Inherited from View)
Public property | Title | The view title. This consists of the view name plus other modifiers, such as the view type, sheet number, area scheme, and/or assembly type, depending on the specifics of the view. (Inherited from View)
 | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View)
Public property | VersionGuid | Get the element version Guid. (Inherited from Element)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element)
Public property | ViewTemplateId | The id of the template view that controls this view's parameters. (Inherited from View)
 | ViewType | The type of the view. (Inherited from View)
Public property | WeatherFile | The full path name of the weather file used for the systems analysis.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element)
Top
See Also

Reference

ViewSystemsAnalysisReport Class
Autodesk.Revit.DB.Analysis Namespace


ViewSystemsAnalysisReport.AnalysisDateAndTime Property

ViewSystemsAnalysisReportAnalysisDateAndTime Property

Identifies the analysis date and time when it was requested.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime AnalysisDateAndTime { get; }
Public ReadOnly Property AnalysisDateAndTime As DateTime
    Get
public:
property DateTime AnalysisDateAndTime {
    DateTime get ();
}
member AnalysisDateAndTime : DateTime with get

Property Value

DateTime
See Also

Reference

ViewSystemsAnalysisReport Class
Autodesk.Revit.DB.Analysis Namespace


ViewSystemsAnalysisReport.ReportStyle Property

ViewSystemsAnalysisReportReportStyle Property

The report style that specifies the display content.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SystemsAnalysisReportStyle ReportStyle { get; set; }
Public Property ReportStyle As SystemsAnalysisReportStyle
    Get
    Set
public:
property SystemsAnalysisReportStyle ReportStyle {
    SystemsAnalysisReportStyle get ();
    void set (SystemsAnalysisReportStyle value);
}
member ReportStyle : SystemsAnalysisReportStyle with get, set

Property Value

SystemsAnalysisReportStyle
Exceptions
Exception | Condition
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also

Reference

ViewSystemsAnalysisReport Class
Autodesk.Revit.DB.Analysis Namespace


ViewSystemsAnalysisReport.SystemsAnalysisOutputFolder Property

ViewSystemsAnalysisReportSystemsAnalysisOutputFolder Property

The full path of the output folder for systems analysis

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SystemsAnalysisOutputFolder { get; }
Public ReadOnly Property SystemsAnalysisOutputFolder As String
    Get
public:
property String^ SystemsAnalysisOutputFolder {
    String^ get ();
}
member SystemsAnalysisOutputFolder : string with get

Property Value

String
See Also

Reference

ViewSystemsAnalysisReport Class
Autodesk.Revit.DB.Analysis Namespace


ViewSystemsAnalysisReport.SystemsAnalysisWorkflowFile Property

ViewSystemsAnalysisReportSystemsAnalysisWorkflowFile Property

The full path name of the original system analysis workflow file.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SystemsAnalysisWorkflowFile { get; }
Public ReadOnly Property SystemsAnalysisWorkflowFile As String
    Get
public:
property String^ SystemsAnalysisWorkflowFile {
    String^ get ();
}
member SystemsAnalysisWorkflowFile : string with get

Property Value

String
See Also

Reference

ViewSystemsAnalysisReport Class
Autodesk.Revit.DB.Analysis Namespace